1202 C++ Programming Manual: D:/OneDrive/Desktop/产品文档/CHM/1202/C++/JYUSB1202Core.h File Reference

1202 C++ Programming Manual
Classes | Typedefs | Enumerations | Functions
JYUSB1202Core.h File Reference

Classes

struct ScalingCoefficients

Typedefs

typedef int | BOOL
Windows.
typedef void * | JYUSB1202_DeviceHandle

Enumerations

enum | JYUSB1202_AI_Terminal { JYUSB1202_AI_PSEUDIFF = 0x0 , JYUSB1202_AI_DIFF = 0x1 }
enum | JYUSB1202_AI_Coupling { JYUSB1202_AI_AC = 0x0 , JYUSB1202_AI_DC = 0x1 }
enum | JYUSB1202_AI_TEDS_IEPE_MODE { JYUSB1202_AI_TEDS = 0x0 , JYUSB1202_AI_IEPE = 0x1 , JYUSB1202_AI_TEDS_IEPE_OFF = 0x2 }
enum | JYUSB1202_AI_SampleMode { JYUSB1202_AI_Finite = 0x0 , JYUSB1202_AI_Continuous = 0x1 , JYUSB1202_AI_Single = 0x2 }
enum | JYUSB1202_AIFilterType { JYUSB1202_AI_Sinc5_Filter_DEC_X32_X1024 = 0x0 , JYUSB1202_AI_Sinc3_Filter = 0x3 , JYUSB1202_AI_Wideband_Filter = 0x4 }
enum | JYUSB1202_AIFDAMODE { JYUSB1202_AI_FULLPOWER = 0x0 , JYUSB1202_AI_STANDBY = 0x1 }
enum | JYUSB1202_TriggerType { JYUSB1202_Immediately = 0x0 , JYUSB1202_Digital = 0x1 , JYUSB1202_Soft = 0x2 }
enum | JYUSB1202_DigitalTriggerSource { JYUSB1202_GPIO_0 = 0x0 , JYUSB1202_GPIO_1 = 0x1 , JYUSB1202_GPIO_2 = 0x2 , JYUSB1202_GPIO_3 = 0x3 }
enum | JYUSB1202_DigitalTriggerEdge { JYUSB1202_Rising = 0x0 , JYUSB1202_Falling = 0x1 , JYUSB1202_High_Level = 0x2 , JYUSB1202_Low_Level = 0x3 }
enum JYUSB1202_CI_MeasureType {
JYUSB1202_CI_EdgeCount = 0 , JYUSB1202_CI_Measure_FrequencyOrPeriod = 1 , JYUSB1202_CI_Measure_PulseWidth = 2 , JYUSB1202_CI_Measure_EdgeSeparation = 3 ,
JYUSB1202_CI_Encoder_X2 = 4 , JYUSB1202_CI_Encoder_X4 = 5
}
enum | JYUSB1202_CountDirection { JYUSB1202_CI_Count_Up , JYUSB1202_CI_Count_Down }
enum | JYUSB1202_CI_CounterEventSignalIdleState { JYUSB1202_CI_CounterEventSignalIdleState_Low = 0 , JYUSB1202_CI_CounterEventSignalIdleState_High = 1 }
CI Counter Event Signal Idle State. More...
enum | JYUSB1202_LevelState { JYUSB1202_LowLevel = 0 , JYUSB1202_HighLevel = 1 }
enum | JYUSB1202_CO_IdleState { JYUSB1202_CO_LowLevel = 0 , JYUSB1202_CO_HighLevel = 1 }
enum JYUSB1202_Signal_SrcAndDest {
JYUSB1202_NONE = -1 , JYUSB1202_DIO_0 = 0 , JYUSB1202_DIO_1 = 1 , JYUSB1202_DIO_2 = 2 ,
JYUSB1202_DIO_3 = 3
}
enum | JYUSB1202_Capability_Item { JYUSB1202_AI_NumberOfChannels_Int = 0 , JYUSB1202_AI_MaxSampleRate_Double = 1 , JYUSB1202_AI_MinSampleRate_Double = 2 }

Functions

JYUSB1202API int | JYUSB1202_Open (JYUSB1202_DeviceHandle *hDevice)
Open the USB1202 board，default open the first card.
JYUSB1202API int | JYUSB1202_OpenByName (const char *cardName, JYUSB1202_DeviceHandle *hDevice)
Open this USB1202 board using the board alias name which is set by JYTEK utility JYDM.
JYUSB1202API int | JYUSB1202_Close (JYUSB1202_DeviceHandle hDevice)
Close this USB1202 board.
JYUSB1202API int | JYUSB1202_GetDeviceSerialNumber (JYUSB1202_DeviceHandle hDevice, char *serialNumber, int length)
Obtain the device serialNumber.
JYUSB1202API int | JYUSB1202_AI_EnableChannel (JYUSB1202_DeviceHandle hDevice, unsigned int channelCount, unsigned char *channels, double *lowRegion, double *highRegion, JYUSB1202_AI_Terminal *terminal, JYUSB1202_AI_Coupling *coupling, bool *enableIEPE)
Enable AI channels.
JYUSB1202API int | JYUSB1202_AI_SetMode (JYUSB1202_DeviceHandle hDevice, JYUSB1202_AI_SampleMode mode)
Set AI sampling mode.
JYUSB1202API int | JYUSB1202_AI_SetSampleRate (JYUSB1202_DeviceHandle hDevice, double sampleRate, double *actualSampleRate)
Set sampling rate.
JYUSB1202API int | JYUSB1202_AI_SetFilterType (JYUSB1202_DeviceHandle hDevice, JYUSB1202_AIFilterType filterType)
Set sampling rate.
JYUSB1202API int | JYUSB1202_AI_SetFDAMODE (JYUSB1202_DeviceHandle hDevice, JYUSB1202_AIFDAMODE fdaMode)
Set sampling rate.
JYUSB1202API int | JYUSB1202_AI_SetSamplesToAcquire (JYUSB1202_DeviceHandle hDevice, unsigned int sampleToAcquire)
Set AI samples to acquire for each channel in finite mode.The samples range is 1 to 64M samples / channelCount.
JYUSB1202API int | JYUSB1202_AI_SetStartTriggerType (JYUSB1202_DeviceHandle hDevice, JYUSB1202_TriggerType triggerType)
Set AI trigger type.
JYUSB1202API int | JYUSB1202_AI_SetDigitalStartTrigger (JYUSB1202_DeviceHandle hDevice, JYUSB1202_DigitalTriggerSource triggerSource, JYUSB1202_DigitalTriggerEdge triggerEdge)
Set AI digital trigger edge.
JYUSB1202API int | JYUSB1202_AI_ExportTriggerSignal (JYUSB1202_DeviceHandle hDevice, JYUSB1202_Signal_SrcAndDest triggerOutDestination)
Export trigger signal.
JYUSB1202API int | JYUSB1202_AI_GetScalingCoefficients (JYUSB1202_DeviceHandle hDevice, ScalingCoefficients coefOfEnabledChannels[], int enabledChannelCount)
在调用AI_Commit()或AI_Start()方法之后调用，获取当前已启用通道的电压换算因子，用于将Raw数据转换为电压值。
JYUSB1202API int | JYUSB1202_AI_Start (JYUSB1202_DeviceHandle hDevice)
Start AI acquisition.
JYUSB1202API int | JYUSB1202_AI_CheckBufferStatus (JYUSB1202_DeviceHandle hDevice, unsigned int *avaliableSamples, unsigned long long *transferedSamples, BOOL *overrun)
Check AI Buffer Status.
JYUSB1202API int | JYUSB1202_AI_SendSoftTrigger (JYUSB1202_DeviceHandle hDevice)
AI Send soft trigger.
JYUSB1202API int | JYUSB1202_AI_ReadData (JYUSB1202_DeviceHandle hDevice, double *dataBuffer, unsigned int samplesToRead, int timeOut, unsigned int *actualReadLength)
Read AI data to user defined data buffer.
JYUSB1202API int | JYUSB1202_AI_ExportSampleClock (JYUSB1202_DeviceHandle hDevice, bool sampleClkOutputEnable)
Export AI Sample clock.
JYUSB1202API int | JYUSB1202_AI_Stop (JYUSB1202_DeviceHandle hDevice)
Stop AI acquisition.
JYUSB1202API int | JYUSB1202_AI_ReadRawData (JYUSB1202_DeviceHandle hDevice, short *dataBuffer, unsigned int samplesToRead, int timeOut, unsigned int *actualReadSamples)
Read AI raw data to user defined data buffer.
JYUSB1202API int | JYUSB1202_AI_DisableCalibration (JYUSB1202_DeviceHandle hDevice, bool disableCalibration)
Disable AI calibration coefficient, default false.
JYUSB1202API int | JYUSB1202_GetCapabilityInt (JYUSB1202_DeviceHandle hDevice, JYUSB1202_Capability_Item item, int *value)
获取当前设备的能力信息中的整型数值参数，比如通道数
JYUSB1202API int | JYUSB1202_GetCapabilityDouble (JYUSB1202_DeviceHandle hDevice, JYUSB1202_Capability_Item item, double *value)
获取当前设备的能力信息，比如最高采样率
JYUSB1202API int | JYUSB1202_GetCapabilityIntBySlotNumber (int slotNumber, JYUSB1202_Capability_Item item, int *value, bool setDefaultIfDeviceNotFound=true)
在不打开设备的情况下，获取位于指定卡槽号的设备的能力信息中的整型数值参数，比如通道数
JYUSB1202API int | JYUSB1202_GetCapabilityDoubleBySlotNumber (int slotNumber, JYUSB1202_Capability_Item item, double *value, bool setDefaultIfDeviceNotFound=true)
在不打开设备的情况下，获取位于指定卡槽号的设备的能力信息中的浮点型数值参数，比如最高采样率
JYUSB1202API int | JYUSB1202_GetCapabilityIntByName (const char *deviceName, JYUSB1202_Capability_Item item, int *value, bool setDefaultIfDeviceNotFound=true)
在不打开设备的情况下，获取指定别名的设备的能力信息中的整型数值参数，比如通道数
JYUSB1202API int | JYUSB1202_GetCapabilityDoubleByName (const char *deviceName, JYUSB1202_Capability_Item item, double *value, bool setDefaultIfDeviceNotFound=true)
在不打开设备的情况下，获取指定别名的设备的能力信息中的浮点型数值参数，比如最高采样率
JYUSB1202API int | JYUSB1202_DI_AddLines (JYUSB1202_DeviceHandle hDevice, char *line, int lineCount)
Enabled DI channels.
JYUSB1202API int | JYUSB1202_DI_ReadSinglePoint (JYUSB1202_DeviceHandle hDevice, bool *readValues, int lineID)
read single data from a single line by lineID defined.if the lineID == -1,read all line data.The data type is bool, one bool defined one line status.
JYUSB1202API int | JYUSB1202_DI_Start (JYUSB1202_DeviceHandle hDevice)
Start digital signal input.
JYUSB1202API int | JYUSB1202_DI_Stop (JYUSB1202_DeviceHandle hDevice)
Stop digital signal input.
JYUSB1202API int | JYUSB1202_DO_AddLines (JYUSB1202_DeviceHandle hDevice, char *line, int lineCount)
Enabled DO channels.
JYUSB1202API int | JYUSB1202_DO_WriteSinglePoint (JYUSB1202_DeviceHandle hDevice, bool *writeValues, int lineID)
write single data to the line by lineID defined.if the lineID == -1,write all line data.
JYUSB1202API int | JYUSB1202_DO_Start (JYUSB1202_DeviceHandle hDevice)
Start digital signal output.
JYUSB1202API int | JYUSB1202_DO_Stop (JYUSB1202_DeviceHandle hDevice)
Stop digital signal output.
JYUSB1202API int | JYUSB1202_CI_SetCounterType (JYUSB1202_DeviceHandle hDevice, JYUSB1202_CI_MeasureType measureType)
Set CI measure type.
JYUSB1202API int | JYUSB1202_CI_SetCounterParamet (JYUSB1202_DeviceHandle hDevice, int initCount, JYUSB1202_CountDirection countDirection)
Set CI count parameter.
JYUSB1202API int | JYUSB1202_CI_SetZReloadEnabled (JYUSB1202_DeviceHandle hDevice, bool zReloadEnabled)
Set the Z signal enable in Encoder mode.
JYUSB1202API int | JYUSB1202_CI_SetEdgeCountEvent (JYUSB1202_DeviceHandle hDevice, JYUSB1202_CI_CounterEventSignalIdleState idleState, unsigned int threshold)
Set the counter threshold, and when the count reaches this threshold, output a single pulse at the output terminal.
JYUSB1202API int | JYUSB1202_CI_SetPauseTriggerLevel (JYUSB1202_DeviceHandle hDevice, bool enable, JYUSB1202_LevelState pauseTriggerActiveLevel)
Config CI pause trigger.
JYUSB1202API int | JYUSB1202_CI_ReadSingleCountValue (JYUSB1202_DeviceHandle hDevice, int *countValue)
Counter reads a single count value, this API supports the CI Type: JYUSB1202_CI_EdgeCount、JYUSB1202_CI_EncoderX1、 JYUSB1202_CI_EncoderX2 、 JYUSB1202_CI_EncoderX4 、JYUSB1202_CI_EncoderTwoPulse.
JYUSB1202API int | JYUSB1202_CI_CheckStatus (JYUSB1202_DeviceHandle hDevice, bool *completed)
check the CI measure is completed or not
JYUSB1202API int | JYUSB1202_CI_ReadSingleMeasureValue (JYUSB1202_DeviceHandle hDevice, double *measureValue1, double *measureValue2, int timeOut)
Reads a single counter measurement as follows.
JYUSB1202API int | JYUSB1202_CI_Start (JYUSB1202_DeviceHandle hDevice)
Start Counter input.
JYUSB1202API int | JYUSB1202_CI_Stop (JYUSB1202_DeviceHandle hDevice)
Stop Counter input.
JYUSB1202API int | JYUSB1202_CO_SetPauseTriggerLevel (JYUSB1202_DeviceHandle hDevice, bool enable, JYUSB1202_LevelState pauseTriggerActiveLevel)
Config CO pause trigger.
JYUSB1202API int | JYUSB1202_CO_SetCounterParamet (JYUSB1202_DeviceHandle hDevice, int pulseCount, JYUSB1202_CO_IdleState IdleState)
Set CO parameter.
JYUSB1202API int | JYUSB1202_CO_SetFrequency (JYUSB1202_DeviceHandle hDevice, unsigned int highTicks, unsigned int lowTicks)
Set counter output pulse frequency.
JYUSB1202API int | JYUSB1202_CO_Start (JYUSB1202_DeviceHandle hDevice)
Start counter output.
JYUSB1202API int | JYUSB1202_CO_Stop (JYUSB1202_DeviceHandle hDevice)
Stop counter output.
JYUSB1202API int | JYUSB1202_CO_WaitUntilDone (JYUSB1202_DeviceHandle hDevice, bool *done, int timeOut)
Check CO output is completed or not.

Typedef Documentation

◆ BOOL

typedef int BOOL

Windows.

Linux

◆ JYUSB1202_DeviceHandle

typedef void* JYUSB1202_DeviceHandle

Enumeration Type Documentation

◆ JYUSB1202_AI_Coupling

enum JYUSB1202_AI_Coupling
Enumerator
JYUSB1202_AI_AC | AI AC Coupling.
JYUSB1202_AI_DC | AI DC Coupling.

◆ JYUSB1202_AI_SampleMode

enum JYUSB1202_AI_SampleMode
Enumerator
JYUSB1202_AI_Finite | AI Finite mode.
JYUSB1202_AI_Continuous | AI Continuous mode.
JYUSB1202_AI_Single | AI Single mode.

◆ JYUSB1202_AI_TEDS_IEPE_MODE

enum JYUSB1202_AI_TEDS_IEPE_MODE
Enumerator
JYUSB1202_AI_TEDS
JYUSB1202_AI_IEPE
JYUSB1202_AI_TEDS_IEPE_OFF

◆ JYUSB1202_AI_Terminal

enum JYUSB1202_AI_Terminal
Enumerator
JYUSB1202_AI_PSEUDIFF | AI PSEUDIFF connection mode.
JYUSB1202_AI_DIFF | AI Diff connection mode.

◆ JYUSB1202_AIFDAMODE

enum JYUSB1202_AIFDAMODE
Enumerator
JYUSB1202_AI_FULLPOWER
JYUSB1202_AI_STANDBY

◆ JYUSB1202_AIFilterType

enum JYUSB1202_AIFilterType
Enumerator
JYUSB1202_AI_Sinc5_Filter_DEC_X32_X1024
JYUSB1202_AI_Sinc3_Filter
JYUSB1202_AI_Wideband_Filter

◆ JYUSB1202_Capability_Item

enum JYUSB1202_Capability_Item
Enumerator
JYUSB1202_AI_NumberOfChannels_Int | Number of channels.
JYUSB1202_AI_MaxSampleRate_Double | Max Sample Rate.
JYUSB1202_AI_MinSampleRate_Double | Min Sample Rate.

◆ JYUSB1202_CI_CounterEventSignalIdleState

enum JYUSB1202_CI_CounterEventSignalIdleState

CI Counter Event Signal Idle State.

Enumerator
JYUSB1202_CI_CounterEventSignalIdleState_Low | Low Level as the CI Counter Event Signal Idle State.
JYUSB1202_CI_CounterEventSignalIdleState_High | High Level as the CI Counter Event Signal Idle State.

◆ JYUSB1202_CI_MeasureType

enum JYUSB1202_CI_MeasureType
Enumerator
JYUSB1202_CI_EdgeCount | Edge count.
JYUSB1202_CI_Measure_FrequencyOrPeriod | FrequencyOrPeriod Measurement.
JYUSB1202_CI_Measure_PulseWidth | Pulse Measurement.
JYUSB1202_CI_Measure_EdgeSeparation | Two Edge Separation Measurement.
JYUSB1202_CI_Encoder_X2 | Encoder_X2.
JYUSB1202_CI_Encoder_X4 | Encoder_X4.

◆ JYUSB1202_CO_IdleState

enum JYUSB1202_CO_IdleState
Enumerator
JYUSB1202_CO_LowLevel | Low Level as the co idle state.
JYUSB1202_CO_HighLevel | High Level as the co idle state.

◆ JYUSB1202_CountDirection

enum JYUSB1202_CountDirection
Enumerator
JYUSB1202_CI_Count_Up | Increases count.
JYUSB1202_CI_Count_Down | Reduction count.

◆ JYUSB1202_DigitalTriggerEdge

enum JYUSB1202_DigitalTriggerEdge
Enumerator
JYUSB1202_Rising | Rsing edge for digital trigger.
JYUSB1202_Falling | Falling edge for digital trigger.
JYUSB1202_High_Level | High Level for digital trigger.
JYUSB1202_Low_Level | Low Level for digital trigger.

◆ JYUSB1202_DigitalTriggerSource

enum JYUSB1202_DigitalTriggerSource
Enumerator
JYUSB1202_GPIO_0 | GPIO_0 Source for digital trigger.
JYUSB1202_GPIO_1 | GPIO10 Source for digital trigger.
JYUSB1202_GPIO_2 | GPIO_2 Source for digital trigger.
JYUSB1202_GPIO_3 | GPIO_3 Source for digital trigger.

◆ JYUSB1202_LevelState

enum JYUSB1202_LevelState
Enumerator
JYUSB1202_LowLevel | Low Level as the pause trigger active level.
JYUSB1202_HighLevel | High Level as the pause trigger active level.

◆ JYUSB1202_Signal_SrcAndDest

enum JYUSB1202_Signal_SrcAndDest
Enumerator
JYUSB1202_NONE | NO signal need route.
JYUSB1202_DIO_0 | DIO_0 as the signal desition to rout.
JYUSB1202_DIO_1 | DIO_1 as the signal desition to rout.
JYUSB1202_DIO_2 | DIO_2 as the signal desition to rout.
JYUSB1202_DIO_3 | DIO_3 as the signal desition to rout.

◆ JYUSB1202_TriggerType

enum JYUSB1202_TriggerType
Enumerator
JYUSB1202_Immediately | AI Immediately trigger.
JYUSB1202_Digital | AI Digital trigger.
JYUSB1202_Soft | AI Soft trigger.

Function Documentation

◆ JYUSB1202_AI_CheckBufferStatus()

JYUSB1202API int JYUSB1202_AI_CheckBufferStatus | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | unsigned int * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | BOOL * | overrun )

Check AI Buffer Status.

Parameters
hDevice | device handle
avaliableSamples | avaliableSamples
transferedSamples | transferedSamples
overrun | overrun
Returns
0 if success or other error code

◆ JYUSB1202_AI_DisableCalibration()

JYUSB1202API int JYUSB1202_AI_DisableCalibration | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | bool | disableCalibration )

Disable AI calibration coefficient, default false.

Parameters
hDevice | device handle
DisableCalibration | true if disabled, false if not disabled.
Returns
0 if Success or other error code

◆ JYUSB1202_AI_EnableChannel()

JYUSB1202API int JYUSB1202_AI_EnableChannel | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | unsigned int | channelCount,
 |  | unsigned char * | channels,
 |  | double * | lowRegion,
 |  | double * | highRegion,
 |  | JYUSB1202_AI_Terminal * | terminal,
 |  | JYUSB1202_AI_Coupling * | coupling,
 |  | bool * | enableIEPE )

Enable AI channels.

Each channel can be independently configured

Parameters
hDevice | device handle
channelCount | number of channels to be enabled
channels | array[channelCount] containing channel IDs
lowRegion | array[channelCount] of lower limit numbers for each channel,typically in volts.
highRegion | higher limit numbers for each channel, typcially in volts.
terminal | terminal configuration defined by enum JYUSB1202_AI_Terminal which can be RSE,DIFF. Defalut : RSE
coupling | coupling configuration defined by enum JYUSB1202_AI_Coupling which can be DC,AC. Defalut : DC
enableIEPE | IEPE configuration defined by enum JYUSB1202_AI_TEDS_IEPE_MODE
Returns
0 if success or other error code

◆ JYUSB1202_AI_ExportSampleClock()

JYUSB1202API int JYUSB1202_AI_ExportSampleClock | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | bool | sampleClkOutputEnable )

Export AI Sample clock.

◆ JYUSB1202_AI_ExportTriggerSignal()

JYUSB1202API int JYUSB1202_AI_ExportTriggerSignal | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | JYUSB1202_Signal_SrcAndDest | triggerOutDestination )

Export trigger signal.

Parameters
hDevice | device handle
triggerOutDestination | destination
triggerOutEnable | enable
Returns

◆ JYUSB1202_AI_GetScalingCoefficients()

JYUSB1202API int JYUSB1202_AI_GetScalingCoefficients | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | ScalingCoefficients | coefOfEnabledChannels[],
 |  | int | enabledChannelCount )

在调用AI_Commit()或AI_Start()方法之后调用，获取当前已启用通道的电压换算因子，用于将Raw数据转换为电压值。

Parameters
hDevice | 板卡句柄
coefOfEnabledChannels | 已启用通道的电压换算因子
enabledChannelCount | 已启用的通道数
Returns
0：无错误；其它：发生错误

◆ JYUSB1202_AI_ReadData()

JYUSB1202API int JYUSB1202_AI_ReadData | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | double * | dataBuffer,
 |  | unsigned int | samplesToRead,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength )

Read AI data to user defined data buffer.

For the multi-channel acquisition, the data is interleaved in the order defined by JYUSB1202_AI_EnableChannel.

Parameters
hDevice | device handle
dataBuffer | user buffer,the buffer size must be greater than or equal to dataLength*channelCount.
samplesToRead | number of samples per channel
timeOut | timeout time in microsecond
actualReadLength | returns the number of samples per channel actually read
Returns
0 if success or other error code

◆ JYUSB1202_AI_ReadRawData()

JYUSB1202API int JYUSB1202_AI_ReadRawData | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | short * | dataBuffer,
 |  | unsigned int | samplesToRead,
 |  | int | timeOut,
 |  | unsigned int * | actualReadSamples )

Read AI raw data to user defined data buffer.

For the multi-channel acquisition, the data is interleaved in the order defined by JYUSB1202_AI_EnableChannel.

Parameters
hDevice | device handle
dataBuffer | user buffer, The size of dataBuffer must be greater than or equal to dataLength*channelCount.
samplesToRead | number of samples per channel
timeOut | timeout time in microsecond
actualReadSamples | return the number of samples per channel actually read
Returns
0 if success or other error code

◆ JYUSB1202_AI_SendSoftTrigger()

JYUSB1202API int JYUSB1202_AI_SendSoftTrigger ( JYUSB1202_DeviceHandle hDevice )

AI Send soft trigger.

Parameters
hDevice
Returns

◆ JYUSB1202_AI_SetDigitalStartTrigger()

JYUSB1202API int JYUSB1202_AI_SetDigitalStartTrigger | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | JYUSB1202_DigitalTriggerSource | triggerSource,
 |  | JYUSB1202_DigitalTriggerEdge | triggerEdge )

Set AI digital trigger edge.

Parameters
hDevice | device handle
triggerEdge | trigger edge
Returns

◆ JYUSB1202_AI_SetFDAMODE()

JYUSB1202API int JYUSB1202_AI_SetFDAMODE | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | JYUSB1202_AIFDAMODE | fdaMode )

Set sampling rate.

The sampling rate is the same for all channels.

Parameters
hDevice | device handle
fdaMode | fdaMode
Returns
0 if success or other error code

◆ JYUSB1202_AI_SetFilterType()

JYUSB1202API int JYUSB1202_AI_SetFilterType | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | JYUSB1202_AIFilterType | filterType )

Set sampling rate.

The sampling rate is the same for all channels.

Parameters
hDevice | device handle
filterType | filterType
Returns
0 if success or other error code

◆ JYUSB1202_AI_SetMode()

JYUSB1202API int JYUSB1202_AI_SetMode | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | JYUSB1202_AI_SampleMode | mode )

Set AI sampling mode.

Parameters
hDevice | device handle
mode | AI sampling mode defined by enum JYUSB1202_AI_SampleMode.
Returns
0 if success or other error code

◆ JYUSB1202_AI_SetSampleRate()

JYUSB1202API int JYUSB1202_AI_SetSampleRate | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | double | sampleRate,
 |  | double * | actualSampleRate )

Set sampling rate.

The sampling rate is the same for all channels.

Parameters
hDevice | device handle
sampleRate | AI sampling rate to be set per channel
actualSampleRate | actual sampling rate set by this device,which may be different from the desired sampleRate.
Returns
0 if success or other error code

◆ JYUSB1202_AI_SetSamplesToAcquire()

JYUSB1202API int JYUSB1202_AI_SetSamplesToAcquire | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | unsigned int | sampleToAcquire )

Set AI samples to acquire for each channel in finite mode.The samples range is 1 to 64M samples / channelCount.

Parameters
hDevice | device handle
sampleToAcquire | AI finite samples to acquire for each channel, samples range:1 to 64M samples / channelCount.
Returns
0 if success or other error code

◆ JYUSB1202_AI_SetStartTriggerType()

JYUSB1202API int JYUSB1202_AI_SetStartTriggerType | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | JYUSB1202_TriggerType | triggerType )

Set AI trigger type.

Parameters
hDevice | device handle
triggerType | AI trigger type. Options:immediate trigger, software trigger, digital trigger or analog trigger.
Returns

◆ JYUSB1202_AI_Start()

JYUSB1202API int JYUSB1202_AI_Start ( JYUSB1202_DeviceHandle hDevice )

Start AI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JYUSB1202_AI_Stop()

JYUSB1202API int JYUSB1202_AI_Stop ( JYUSB1202_DeviceHandle hDevice )

Stop AI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JYUSB1202_CI_CheckStatus()

JYUSB1202API int JYUSB1202_CI_CheckStatus | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | bool * | completed )

check the CI measure is completed or not

Parameters
hDevice | device handle
completed | true: completed; false: uncompleted
Returns
0 if success or other error code

◆ JYUSB1202_CI_ReadSingleCountValue()

JYUSB1202API int JYUSB1202_CI_ReadSingleCountValue | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | int * | countValue )

Counter reads a single count value, this API supports the CI Type: JYUSB1202_CI_EdgeCount、JYUSB1202_CI_EncoderX1、 JYUSB1202_CI_EncoderX2 、 JYUSB1202_CI_EncoderX4 、JYUSB1202_CI_EncoderTwoPulse.

Parameters
hDevice | device handle
countValue | return the current count value of counter.
Returns
0 if success or other error code

◆ JYUSB1202_CI_ReadSingleMeasureValue()

JYUSB1202API int JYUSB1202_CI_ReadSingleMeasureValue | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | double * | measureValue1,
 |  | double * | measureValue2,
 |  | int | timeOut )

Reads a single counter measurement as follows.

for JYUSB1202_CI_Measure_EdgeSeparation type, measureValues1 is the Gate signel to the Aux signal interval, the measureValues2 is the Aux signel to the Gate signal interval, the unit is in s. for JYUSB1202_CI_Measure_Pulse type, measureValues1 is the Low level signal time, the measureValues2 is the high level signal time, the unit is in second. for JYUSB1202_CI_Measure_Frequency type, measureValues1 is signal frequency in Hz, measureValue2 has no meaning. for JYUSB1202_CI_Measure_Period type, measureValues2 is signal period in second; measureValue1 has no meaning.

Parameters
hDevice | device handle
measureValue1 | current measure value of counter
measureValue2 | current measure value of counter
timeOut | timeout time in microsecond
Returns
0 if success or other error code

◆ JYUSB1202_CI_SetCounterParamet()

JYUSB1202API int JYUSB1202_CI_SetCounterParamet | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | int | initCount,
 |  | JYUSB1202_CountDirection | countDirection )

Set CI count parameter.

Parameters
hDevice | device handle
initCount | counter initial value
countDirection | counting direction of the counter defined by enum USB1202_CountDirection
Returns
0 if success or other error code

◆ JYUSB1202_CI_SetCounterType()

JYUSB1202API int JYUSB1202_CI_SetCounterType | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | JYUSB1202_CI_MeasureType | measureType )

Set CI measure type.

Parameters
hDevice | device handle
measureType | measure type. defined by enum USB1202_CI_MeasureType
Returns
0 if success or other error code

◆ JYUSB1202_CI_SetEdgeCountEvent()

JYUSB1202API int JYUSB1202_CI_SetEdgeCountEvent | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | JYUSB1202_CI_CounterEventSignalIdleState | idleState,
 |  | unsigned int | threshold )

Set the counter threshold, and when the count reaches this threshold, output a single pulse at the output terminal.

Parameters
hDevice | device handle
idleState | output terminal idle state
threshold | threshold
Returns
0 if success or other error code

◆ JYUSB1202_CI_SetPauseTriggerLevel()

JYUSB1202API int JYUSB1202_CI_SetPauseTriggerLevel | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | bool | enable,
 |  | JYUSB1202_LevelState | pauseTriggerActiveLevel )

Config CI pause trigger.

Parameters
hDevice | Device handle
enable | Enable pasue trigger
pauseTriggerActiveLevel | Pause trigger active level.
Returns
Succeed: 0 , Error: !=0

◆ JYUSB1202_CI_SetZReloadEnabled()

JYUSB1202API int JYUSB1202_CI_SetZReloadEnabled | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | bool | zReloadEnabled )

Set the Z signal enable in Encoder mode.

Parameters
hDevice | device handle
zReloadEnabled | enable z signal. True: enabled; False: disabled.Valid only under encoder mode.
Returns
0 if success or other error code

◆ JYUSB1202_CI_Start()

JYUSB1202API int JYUSB1202_CI_Start ( JYUSB1202_DeviceHandle hDevice )

Start Counter input.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JYUSB1202_CI_Stop()

JYUSB1202API int JYUSB1202_CI_Stop ( JYUSB1202_DeviceHandle hDevice )

Stop Counter input.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JYUSB1202_Close()

JYUSB1202API int JYUSB1202_Close ( JYUSB1202_DeviceHandle hDevice )

Close this USB1202 board.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JYUSB1202_CO_SetCounterParamet()

JYUSB1202API int JYUSB1202_CO_SetCounterParamet | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | int | pulseCount,
 |  | JYUSB1202_CO_IdleState | IdleState )

Set CO parameter.

Parameters
hDevice | device handle
pulseCount | counter output pulse number, if pulseCount = -1 ,the device always responds to output until the user stops it.
IdleState | counter output idle state
Returns
0 if success or other error code

◆ JYUSB1202_CO_SetFrequency()

JYUSB1202API int JYUSB1202_CO_SetFrequency | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | unsigned int | highTicks,
 |  | unsigned int | lowTicks )

Set counter output pulse frequency.

Parameters
hDevice | device handle
highTicks | the number of ticks for the high pulse, timebase is 200MHz.
lowTicks | the number of ticks for the low pulse, timebase is 200MHz.
Returns
0 if success or other error code

◆ JYUSB1202_CO_SetPauseTriggerLevel()

JYUSB1202API int JYUSB1202_CO_SetPauseTriggerLevel | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | bool | enable,
 |  | JYUSB1202_LevelState | pauseTriggerActiveLevel )

Config CO pause trigger.

Parameters
hDevice | Device handle
enable | Enable pasue trigger
pauseTriggerActiveLevel | Pause trigger active level.
Returns
Succeed: 0 , Error: !=0

◆ JYUSB1202_CO_Start()

JYUSB1202API int JYUSB1202_CO_Start ( JYUSB1202_DeviceHandle hDevice )

Start counter output.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JYUSB1202_CO_Stop()

JYUSB1202API int JYUSB1202_CO_Stop ( JYUSB1202_DeviceHandle hDevice )

Stop counter output.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JYUSB1202_CO_WaitUntilDone()

JYUSB1202API int JYUSB1202_CO_WaitUntilDone | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | bool * | done,
 |  | int | timeOut )

Check CO output is completed or not.

Parameters
hDevice | device handle
done | true if completed, false if not yet completed.
timeOut | timeout time in microsecond, this parament not valid in current version
Returns
0 if success or other error code

◆ JYUSB1202_DI_AddLines()

JYUSB1202API int JYUSB1202_DI_AddLines | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | char * | line,
 |  | int | lineCount )

Enabled DI channels.

Parameters
hDevice | device handle
line | array[lineCount] containing line IDs
lineCount | number of lines to be enabled
Returns
0 if success or other error code

◆ JYUSB1202_DI_ReadSinglePoint()

JYUSB1202API int JYUSB1202_DI_ReadSinglePoint | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | bool * | readValues,
 |  | int | lineID )

read single data from a single line by lineID defined.if the lineID == -1,read all line data.The data type is bool, one bool defined one line status.

Parameters
hDevice | device handle
readValues | read the specified line values. when the lineID is -1, read all enabled line values,the readValues Length must equal to lineCount(In function JYUSB1202_DI_AddLines defined), and the values store order is add order.
lineID | line number
Returns
0 if success or other error code

◆ JYUSB1202_DI_Start()

JYUSB1202API int JYUSB1202_DI_Start ( JYUSB1202_DeviceHandle hDevice )

Start digital signal input.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JYUSB1202_DI_Stop()

JYUSB1202API int JYUSB1202_DI_Stop ( JYUSB1202_DeviceHandle hDevice )

Stop digital signal input.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JYUSB1202_DO_AddLines()

JYUSB1202API int JYUSB1202_DO_AddLines | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | char * | line,
 |  | int | lineCount )

Enabled DO channels.

Parameters
hDevice | device handle
line | array[lineCount] containing line IDs.
lineCount | number of lines to be enabled
Returns
0 if success or other error code

◆ JYUSB1202_DO_Start()

JYUSB1202API int JYUSB1202_DO_Start ( JYUSB1202_DeviceHandle hDevice )

Start digital signal output.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JYUSB1202_DO_Stop()

JYUSB1202API int JYUSB1202_DO_Stop ( JYUSB1202_DeviceHandle hDevice )

Stop digital signal output.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JYUSB1202_DO_WriteSinglePoint()

JYUSB1202API int JYUSB1202_DO_WriteSinglePoint | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | bool * | writeValues,
 |  | int | lineID )

write single data to the line by lineID defined.if the lineID == -1,write all line data.

Parameters
hDevice | device handle
writeValues | write the specified line values when the lineID is -1, write all enabled lines values,the writeValues Length must equal to lineCount(In function JYUSB1202_DO_AddLines defined), and the values order is add order.
lineCount | line count
Returns
0 if success or other error code

◆ JYUSB1202_GetCapabilityDouble()

JYUSB1202API int JYUSB1202_GetCapabilityDouble | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | JYUSB1202_Capability_Item | item,
 |  | double * | value )

获取当前设备的能力信息，比如最高采样率

Parameters
hDevice | 板卡句柄
item | 设备能力项
value | 设备能力值
Returns
0：无错误；其它：发生错误

◆ JYUSB1202_GetCapabilityDoubleByName()

JYUSB1202API int JYUSB1202_GetCapabilityDoubleByName | ( | const char * | deviceName,
 |  | JYUSB1202_Capability_Item | item,
 |  | double * | value,
 |  | bool | setDefaultIfDeviceNotFound = true )

在不打开设备的情况下，获取指定别名的设备的能力信息中的浮点型数值参数，比如最高采样率

Parameters
deviceName | 设备别名
item | 设备能力项
value | 设备能力值
setDefaultIfDeviceNotFound | 当无法找到指定设备时，若该参数为true，则设置设备能力信息为默认值、不报错；若该参数为false，则返回无法打开设备错误
Returns
0：无错误；其它：发生错误

◆ JYUSB1202_GetCapabilityDoubleBySlotNumber()

JYUSB1202API int JYUSB1202_GetCapabilityDoubleBySlotNumber | ( | int | slotNumber,
 |  | JYUSB1202_Capability_Item | item,
 |  | double * | value,
 |  | bool | setDefaultIfDeviceNotFound = true )

在不打开设备的情况下，获取位于指定卡槽号的设备的能力信息中的浮点型数值参数，比如最高采样率

Parameters
slotNumber | 卡槽号
item | 设备能力项
value | 设备能力值
setDefaultIfDeviceNotFound | 当无法找到指定设备时，若该参数为true，则设置设备能力信息为默认值、不报错；若该参数为false，则返回无法打开设备错误
Returns
0：无错误；其它：发生错误

◆ JYUSB1202_GetCapabilityInt()

JYUSB1202API int JYUSB1202_GetCapabilityInt | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | JYUSB1202_Capability_Item | item,
 |  | int * | value )

获取当前设备的能力信息中的整型数值参数，比如通道数

Parameters
hDevice | 板卡句柄
item | 设备能力项
value | 设备能力值
Returns
0：无错误；其它：发生错误

◆ JYUSB1202_GetCapabilityIntByName()

JYUSB1202API int JYUSB1202_GetCapabilityIntByName | ( | const char * | deviceName,
 |  | JYUSB1202_Capability_Item | item,
 |  | int * | value,
 |  | bool | setDefaultIfDeviceNotFound = true )

在不打开设备的情况下，获取指定别名的设备的能力信息中的整型数值参数，比如通道数

Parameters
deviceName | 设备别名
item | 设备能力项
value | 设备能力值
setDefaultIfDeviceNotFound | 当无法找到指定设备时，若该参数为true，则设置设备能力信息为默认值、不报错；若该参数为false，则返回无法打开设备错误
Returns
0：无错误；其它：发生错误

◆ JYUSB1202_GetCapabilityIntBySlotNumber()

JYUSB1202API int JYUSB1202_GetCapabilityIntBySlotNumber | ( | int | slotNumber,
 |  | JYUSB1202_Capability_Item | item,
 |  | int * | value,
 |  | bool | setDefaultIfDeviceNotFound = true )

在不打开设备的情况下，获取位于指定卡槽号的设备的能力信息中的整型数值参数，比如通道数

Parameters
slotNumber | 卡槽号
item | 设备能力项
value | 设备能力值
setDefaultIfDeviceNotFound | 当无法找到指定设备时，若该参数为true，则设置设备能力信息为默认值、不报错；若该参数为false，则返回无法打开设备错误
Returns
0：无错误；其它：发生错误

◆ JYUSB1202_GetDeviceSerialNumber()

JYUSB1202API int JYUSB1202_GetDeviceSerialNumber | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | char * | serialNumber,
 |  | int | length )

Obtain the device serialNumber.

Parameters
hDevice | device handle
serialNumber | Pointer to a buffer receiving the serial number. The length of the serial number is 10.
length | serial Number length ,length is 10
Returns
0 if success or other error code

◆ JYUSB1202_Open()

JYUSB1202API int JYUSB1202_Open ( JYUSB1202_DeviceHandle * hDevice )

Open the USB1202 board，default open the first card.

Parameters
hDevice device handle. All other functions uses hDevice to represent this device.
Returns
0 if success or other error code

◆ JYUSB1202_OpenByName()

JYUSB1202API int JYUSB1202_OpenByName | ( | const char * | cardName,
 |  | JYUSB1202_DeviceHandle * | hDevice )

Open this USB1202 board using the board alias name which is set by JYTEK utility JYDM.

You can change the name using JYDM.

Parameters
cardName | board alias name
hDevice | device handle
Returns
0 if success or other error code
Generated by doxygen 1.15.0


1202 C++ Programming Manual: ScalingCoefficients Struct Reference

Public Attributes | List of all members
ScalingCoefficients Struct Reference

#include <JYUSB1202Core.h>

Public Attributes

double | Offset
double | Gain

Member Data Documentation

◆ Gain

double ScalingCoefficients::Gain

◆ Offset

double ScalingCoefficients::Offset
The documentation for this struct was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/1202/C++/JYUSB1202Core.h


1202 C++ Programming Manual: Class List

  • Main Page
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
C ScalingCoefficients


1202 C++ Programming Manual: Class Index

  • Class List
  • Class Index
  • Class Members
Class Index
S
S
ScalingCoefficients


1202 C++ Programming Manual: D:/OneDrive/Desktop/产品文档/CHM/1202 Directory Reference

  • File List
  • File Members
  • OneDrive
  • Desktop
  • 产品文档
  • CHM
  • 1202
1202 Directory Reference

Directories

         C++


1202 C++ Programming Manual: D:/OneDrive/Desktop/产品文档/CHM Directory Reference

  • File Members
  • OneDrive
  • Desktop
  • 产品文档
  • CHM
CHM Directory Reference

Directories

         1202


1202 C++ Programming Manual: D:/OneDrive/Desktop Directory Reference

  • OneDrive
  • Desktop
Desktop Directory Reference

Directories

         产品文档


1202 C++ Programming Manual: D:/OneDrive/Desktop/产品文档 Directory Reference

  • OneDrive
  • Desktop
  • 产品文档
产品文档 Directory Reference

Directories

         CHM


1202 C++ Programming Manual: D:/OneDrive Directory Reference

  • OneDrive
OneDrive Directory Reference

Directories

         Desktop


1202 C++ Programming Manual: D:/OneDrive/Desktop/产品文档/CHM/1202/C++ Directory Reference

  • OneDrive
  • Desktop
  • 产品文档
  • CHM
  • 1202
  • C++
C++ Directory Reference

Files

         JYUSB1202Core.h


1202 C++ Programming Manual: File List

File List
Here is a list of all files with brief descriptions:
[detail level 1234567]
 OneDrive
Desktop
产品文档
CHM
1202
C++
JYUSB1202Core.h


1202 C++ Programming Manual: Class Members

  • Class List
  • Class Index
  • Class Members
  • All
  • Variables
Here is a list of all class members with links to the classes they belong to:
  • Gain : ScalingCoefficients
  • Offset : ScalingCoefficients


1202 C++ Programming Manual: Class Members - Variables

  • Class List
  • Class Index
  • Class Members
  • All
  • Variables
Here is a list of all variables with links to the classes they belong to:
  • Gain : ScalingCoefficients
  • Offset : ScalingCoefficients


1202 C++ Programming Manual: File Members

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • b
  • j
Here is a list of all file members with links to the files they belong to:

- b -

  • BOOL : JYUSB1202Core.h

- j -

  • JYUSB1202_AI_AC : JYUSB1202Core.h
  • JYUSB1202_AI_CheckBufferStatus() : JYUSB1202Core.h
  • JYUSB1202_AI_Continuous : JYUSB1202Core.h
  • JYUSB1202_AI_Coupling : JYUSB1202Core.h
  • JYUSB1202_AI_DC : JYUSB1202Core.h
  • JYUSB1202_AI_DIFF : JYUSB1202Core.h
  • JYUSB1202_AI_DisableCalibration() : JYUSB1202Core.h
  • JYUSB1202_AI_EnableChannel() : JYUSB1202Core.h
  • JYUSB1202_AI_ExportSampleClock() : JYUSB1202Core.h
  • JYUSB1202_AI_ExportTriggerSignal() : JYUSB1202Core.h
  • JYUSB1202_AI_Finite : JYUSB1202Core.h
  • JYUSB1202_AI_FULLPOWER : JYUSB1202Core.h
  • JYUSB1202_AI_GetScalingCoefficients() : JYUSB1202Core.h
  • JYUSB1202_AI_IEPE : JYUSB1202Core.h
  • JYUSB1202_AI_MaxSampleRate_Double : JYUSB1202Core.h
  • JYUSB1202_AI_MinSampleRate_Double : JYUSB1202Core.h
  • JYUSB1202_AI_NumberOfChannels_Int : JYUSB1202Core.h
  • JYUSB1202_AI_PSEUDIFF : JYUSB1202Core.h
  • JYUSB1202_AI_ReadData() : JYUSB1202Core.h
  • JYUSB1202_AI_ReadRawData() : JYUSB1202Core.h
  • JYUSB1202_AI_SampleMode : JYUSB1202Core.h
  • JYUSB1202_AI_SendSoftTrigger() : JYUSB1202Core.h
  • JYUSB1202_AI_SetDigitalStartTrigger() : JYUSB1202Core.h
  • JYUSB1202_AI_SetFDAMODE() : JYUSB1202Core.h
  • JYUSB1202_AI_SetFilterType() : JYUSB1202Core.h
  • JYUSB1202_AI_SetMode() : JYUSB1202Core.h
  • JYUSB1202_AI_SetSampleRate() : JYUSB1202Core.h
  • JYUSB1202_AI_SetSamplesToAcquire() : JYUSB1202Core.h
  • JYUSB1202_AI_SetStartTriggerType() : JYUSB1202Core.h
  • JYUSB1202_AI_Sinc3_Filter : JYUSB1202Core.h
  • JYUSB1202_AI_Sinc5_Filter_DEC_X32_X1024 : JYUSB1202Core.h
  • JYUSB1202_AI_Single : JYUSB1202Core.h
  • JYUSB1202_AI_STANDBY : JYUSB1202Core.h
  • JYUSB1202_AI_Start() : JYUSB1202Core.h
  • JYUSB1202_AI_Stop() : JYUSB1202Core.h
  • JYUSB1202_AI_TEDS : JYUSB1202Core.h
  • JYUSB1202_AI_TEDS_IEPE_MODE : JYUSB1202Core.h
  • JYUSB1202_AI_TEDS_IEPE_OFF : JYUSB1202Core.h
  • JYUSB1202_AI_Terminal : JYUSB1202Core.h
  • JYUSB1202_AI_Wideband_Filter : JYUSB1202Core.h
  • JYUSB1202_AIFDAMODE : JYUSB1202Core.h
  • JYUSB1202_AIFilterType : JYUSB1202Core.h
  • JYUSB1202_Capability_Item : JYUSB1202Core.h
  • JYUSB1202_CI_CheckStatus() : JYUSB1202Core.h
  • JYUSB1202_CI_Count_Down : JYUSB1202Core.h
  • JYUSB1202_CI_Count_Up : JYUSB1202Core.h
  • JYUSB1202_CI_CounterEventSignalIdleState : JYUSB1202Core.h
  • JYUSB1202_CI_CounterEventSignalIdleState_High : JYUSB1202Core.h
  • JYUSB1202_CI_CounterEventSignalIdleState_Low : JYUSB1202Core.h
  • JYUSB1202_CI_EdgeCount : JYUSB1202Core.h
  • JYUSB1202_CI_Encoder_X2 : JYUSB1202Core.h
  • JYUSB1202_CI_Encoder_X4 : JYUSB1202Core.h
  • JYUSB1202_CI_Measure_EdgeSeparation : JYUSB1202Core.h
  • JYUSB1202_CI_Measure_FrequencyOrPeriod : JYUSB1202Core.h
  • JYUSB1202_CI_Measure_PulseWidth : JYUSB1202Core.h
  • JYUSB1202_CI_MeasureType : JYUSB1202Core.h
  • JYUSB1202_CI_ReadSingleCountValue() : JYUSB1202Core.h
  • JYUSB1202_CI_ReadSingleMeasureValue() : JYUSB1202Core.h
  • JYUSB1202_CI_SetCounterParamet() : JYUSB1202Core.h
  • JYUSB1202_CI_SetCounterType() : JYUSB1202Core.h
  • JYUSB1202_CI_SetEdgeCountEvent() : JYUSB1202Core.h
  • JYUSB1202_CI_SetPauseTriggerLevel() : JYUSB1202Core.h
  • JYUSB1202_CI_SetZReloadEnabled() : JYUSB1202Core.h
  • JYUSB1202_CI_Start() : JYUSB1202Core.h
  • JYUSB1202_CI_Stop() : JYUSB1202Core.h
  • JYUSB1202_Close() : JYUSB1202Core.h
  • JYUSB1202_CO_HighLevel : JYUSB1202Core.h
  • JYUSB1202_CO_IdleState : JYUSB1202Core.h
  • JYUSB1202_CO_LowLevel : JYUSB1202Core.h
  • JYUSB1202_CO_SetCounterParamet() : JYUSB1202Core.h
  • JYUSB1202_CO_SetFrequency() : JYUSB1202Core.h
  • JYUSB1202_CO_SetPauseTriggerLevel() : JYUSB1202Core.h
  • JYUSB1202_CO_Start() : JYUSB1202Core.h
  • JYUSB1202_CO_Stop() : JYUSB1202Core.h
  • JYUSB1202_CO_WaitUntilDone() : JYUSB1202Core.h
  • JYUSB1202_CountDirection : JYUSB1202Core.h
  • JYUSB1202_DeviceHandle : JYUSB1202Core.h
  • JYUSB1202_DI_AddLines() : JYUSB1202Core.h
  • JYUSB1202_DI_ReadSinglePoint() : JYUSB1202Core.h
  • JYUSB1202_DI_Start() : JYUSB1202Core.h
  • JYUSB1202_DI_Stop() : JYUSB1202Core.h
  • JYUSB1202_Digital : JYUSB1202Core.h
  • JYUSB1202_DigitalTriggerEdge : JYUSB1202Core.h
  • JYUSB1202_DigitalTriggerSource : JYUSB1202Core.h
  • JYUSB1202_DIO_0 : JYUSB1202Core.h
  • JYUSB1202_DIO_1 : JYUSB1202Core.h
  • JYUSB1202_DIO_2 : JYUSB1202Core.h
  • JYUSB1202_DIO_3 : JYUSB1202Core.h
  • JYUSB1202_DO_AddLines() : JYUSB1202Core.h
  • JYUSB1202_DO_Start() : JYUSB1202Core.h
  • JYUSB1202_DO_Stop() : JYUSB1202Core.h
  • JYUSB1202_DO_WriteSinglePoint() : JYUSB1202Core.h
  • JYUSB1202_Falling : JYUSB1202Core.h
  • JYUSB1202_GetCapabilityDouble() : JYUSB1202Core.h
  • JYUSB1202_GetCapabilityDoubleByName() : JYUSB1202Core.h
  • JYUSB1202_GetCapabilityDoubleBySlotNumber() : JYUSB1202Core.h
  • JYUSB1202_GetCapabilityInt() : JYUSB1202Core.h
  • JYUSB1202_GetCapabilityIntByName() : JYUSB1202Core.h
  • JYUSB1202_GetCapabilityIntBySlotNumber() : JYUSB1202Core.h
  • JYUSB1202_GetDeviceSerialNumber() : JYUSB1202Core.h
  • JYUSB1202_GPIO_0 : JYUSB1202Core.h
  • JYUSB1202_GPIO_1 : JYUSB1202Core.h
  • JYUSB1202_GPIO_2 : JYUSB1202Core.h
  • JYUSB1202_GPIO_3 : JYUSB1202Core.h
  • JYUSB1202_High_Level : JYUSB1202Core.h
  • JYUSB1202_HighLevel : JYUSB1202Core.h
  • JYUSB1202_Immediately : JYUSB1202Core.h
  • JYUSB1202_LevelState : JYUSB1202Core.h
  • JYUSB1202_Low_Level : JYUSB1202Core.h
  • JYUSB1202_LowLevel : JYUSB1202Core.h
  • JYUSB1202_NONE : JYUSB1202Core.h
  • JYUSB1202_Open() : JYUSB1202Core.h
  • JYUSB1202_OpenByName() : JYUSB1202Core.h
  • JYUSB1202_Rising : JYUSB1202Core.h
  • JYUSB1202_Signal_SrcAndDest : JYUSB1202Core.h
  • JYUSB1202_Soft : JYUSB1202Core.h
  • JYUSB1202_TriggerType : JYUSB1202Core.h


1202 C++ Programming Manual: File Members

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
Here is a list of all enums with links to the files they belong to:
  • JYUSB1202_AI_Coupling : JYUSB1202Core.h
  • JYUSB1202_AI_SampleMode : JYUSB1202Core.h
  • JYUSB1202_AI_TEDS_IEPE_MODE : JYUSB1202Core.h
  • JYUSB1202_AI_Terminal : JYUSB1202Core.h
  • JYUSB1202_AIFDAMODE : JYUSB1202Core.h
  • JYUSB1202_AIFilterType : JYUSB1202Core.h
  • JYUSB1202_Capability_Item : JYUSB1202Core.h
  • JYUSB1202_CI_CounterEventSignalIdleState : JYUSB1202Core.h
  • JYUSB1202_CI_MeasureType : JYUSB1202Core.h
  • JYUSB1202_CO_IdleState : JYUSB1202Core.h
  • JYUSB1202_CountDirection : JYUSB1202Core.h
  • JYUSB1202_DigitalTriggerEdge : JYUSB1202Core.h
  • JYUSB1202_DigitalTriggerSource : JYUSB1202Core.h
  • JYUSB1202_LevelState : JYUSB1202Core.h
  • JYUSB1202_Signal_SrcAndDest : JYUSB1202Core.h
  • JYUSB1202_TriggerType : JYUSB1202Core.h


1202 C++ Programming Manual: File Members

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • j
Here is a list of all enum values with links to the files they belong to:

- j -

  • JYUSB1202_AI_AC : JYUSB1202Core.h
  • JYUSB1202_AI_Continuous : JYUSB1202Core.h
  • JYUSB1202_AI_DC : JYUSB1202Core.h
  • JYUSB1202_AI_DIFF : JYUSB1202Core.h
  • JYUSB1202_AI_Finite : JYUSB1202Core.h
  • JYUSB1202_AI_FULLPOWER : JYUSB1202Core.h
  • JYUSB1202_AI_IEPE : JYUSB1202Core.h
  • JYUSB1202_AI_MaxSampleRate_Double : JYUSB1202Core.h
  • JYUSB1202_AI_MinSampleRate_Double : JYUSB1202Core.h
  • JYUSB1202_AI_NumberOfChannels_Int : JYUSB1202Core.h
  • JYUSB1202_AI_PSEUDIFF : JYUSB1202Core.h
  • JYUSB1202_AI_Sinc3_Filter : JYUSB1202Core.h
  • JYUSB1202_AI_Sinc5_Filter_DEC_X32_X1024 : JYUSB1202Core.h
  • JYUSB1202_AI_Single : JYUSB1202Core.h
  • JYUSB1202_AI_STANDBY : JYUSB1202Core.h
  • JYUSB1202_AI_TEDS : JYUSB1202Core.h
  • JYUSB1202_AI_TEDS_IEPE_OFF : JYUSB1202Core.h
  • JYUSB1202_AI_Wideband_Filter : JYUSB1202Core.h
  • JYUSB1202_CI_Count_Down : JYUSB1202Core.h
  • JYUSB1202_CI_Count_Up : JYUSB1202Core.h
  • JYUSB1202_CI_CounterEventSignalIdleState_High : JYUSB1202Core.h
  • JYUSB1202_CI_CounterEventSignalIdleState_Low : JYUSB1202Core.h
  • JYUSB1202_CI_EdgeCount : JYUSB1202Core.h
  • JYUSB1202_CI_Encoder_X2 : JYUSB1202Core.h
  • JYUSB1202_CI_Encoder_X4 : JYUSB1202Core.h
  • JYUSB1202_CI_Measure_EdgeSeparation : JYUSB1202Core.h
  • JYUSB1202_CI_Measure_FrequencyOrPeriod : JYUSB1202Core.h
  • JYUSB1202_CI_Measure_PulseWidth : JYUSB1202Core.h
  • JYUSB1202_CO_HighLevel : JYUSB1202Core.h
  • JYUSB1202_CO_LowLevel : JYUSB1202Core.h
  • JYUSB1202_Digital : JYUSB1202Core.h
  • JYUSB1202_DIO_0 : JYUSB1202Core.h
  • JYUSB1202_DIO_1 : JYUSB1202Core.h
  • JYUSB1202_DIO_2 : JYUSB1202Core.h
  • JYUSB1202_DIO_3 : JYUSB1202Core.h
  • JYUSB1202_Falling : JYUSB1202Core.h
  • JYUSB1202_GPIO_0 : JYUSB1202Core.h
  • JYUSB1202_GPIO_1 : JYUSB1202Core.h
  • JYUSB1202_GPIO_2 : JYUSB1202Core.h
  • JYUSB1202_GPIO_3 : JYUSB1202Core.h
  • JYUSB1202_High_Level : JYUSB1202Core.h
  • JYUSB1202_HighLevel : JYUSB1202Core.h
  • JYUSB1202_Immediately : JYUSB1202Core.h
  • JYUSB1202_Low_Level : JYUSB1202Core.h
  • JYUSB1202_LowLevel : JYUSB1202Core.h
  • JYUSB1202_NONE : JYUSB1202Core.h
  • JYUSB1202_Rising : JYUSB1202Core.h
  • JYUSB1202_Soft : JYUSB1202Core.h


1202 C++ Programming Manual: File Members

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • j
Here is a list of all functions with links to the files they belong to:

- j -

  • JYUSB1202_AI_CheckBufferStatus() : JYUSB1202Core.h
  • JYUSB1202_AI_DisableCalibration() : JYUSB1202Core.h
  • JYUSB1202_AI_EnableChannel() : JYUSB1202Core.h
  • JYUSB1202_AI_ExportSampleClock() : JYUSB1202Core.h
  • JYUSB1202_AI_ExportTriggerSignal() : JYUSB1202Core.h
  • JYUSB1202_AI_GetScalingCoefficients() : JYUSB1202Core.h
  • JYUSB1202_AI_ReadData() : JYUSB1202Core.h
  • JYUSB1202_AI_ReadRawData() : JYUSB1202Core.h
  • JYUSB1202_AI_SendSoftTrigger() : JYUSB1202Core.h
  • JYUSB1202_AI_SetDigitalStartTrigger() : JYUSB1202Core.h
  • JYUSB1202_AI_SetFDAMODE() : JYUSB1202Core.h
  • JYUSB1202_AI_SetFilterType() : JYUSB1202Core.h
  • JYUSB1202_AI_SetMode() : JYUSB1202Core.h
  • JYUSB1202_AI_SetSampleRate() : JYUSB1202Core.h
  • JYUSB1202_AI_SetSamplesToAcquire() : JYUSB1202Core.h
  • JYUSB1202_AI_SetStartTriggerType() : JYUSB1202Core.h
  • JYUSB1202_AI_Start() : JYUSB1202Core.h
  • JYUSB1202_AI_Stop() : JYUSB1202Core.h
  • JYUSB1202_CI_CheckStatus() : JYUSB1202Core.h
  • JYUSB1202_CI_ReadSingleCountValue() : JYUSB1202Core.h
  • JYUSB1202_CI_ReadSingleMeasureValue() : JYUSB1202Core.h
  • JYUSB1202_CI_SetCounterParamet() : JYUSB1202Core.h
  • JYUSB1202_CI_SetCounterType() : JYUSB1202Core.h
  • JYUSB1202_CI_SetEdgeCountEvent() : JYUSB1202Core.h
  • JYUSB1202_CI_SetPauseTriggerLevel() : JYUSB1202Core.h
  • JYUSB1202_CI_SetZReloadEnabled() : JYUSB1202Core.h
  • JYUSB1202_CI_Start() : JYUSB1202Core.h
  • JYUSB1202_CI_Stop() : JYUSB1202Core.h
  • JYUSB1202_Close() : JYUSB1202Core.h
  • JYUSB1202_CO_SetCounterParamet() : JYUSB1202Core.h
  • JYUSB1202_CO_SetFrequency() : JYUSB1202Core.h
  • JYUSB1202_CO_SetPauseTriggerLevel() : JYUSB1202Core.h
  • JYUSB1202_CO_Start() : JYUSB1202Core.h
  • JYUSB1202_CO_Stop() : JYUSB1202Core.h
  • JYUSB1202_CO_WaitUntilDone() : JYUSB1202Core.h
  • JYUSB1202_DI_AddLines() : JYUSB1202Core.h
  • JYUSB1202_DI_ReadSinglePoint() : JYUSB1202Core.h
  • JYUSB1202_DI_Start() : JYUSB1202Core.h
  • JYUSB1202_DI_Stop() : JYUSB1202Core.h
  • JYUSB1202_DO_AddLines() : JYUSB1202Core.h
  • JYUSB1202_DO_Start() : JYUSB1202Core.h
  • JYUSB1202_DO_Stop() : JYUSB1202Core.h
  • JYUSB1202_DO_WriteSinglePoint() : JYUSB1202Core.h
  • JYUSB1202_GetCapabilityDouble() : JYUSB1202Core.h
  • JYUSB1202_GetCapabilityDoubleByName() : JYUSB1202Core.h
  • JYUSB1202_GetCapabilityDoubleBySlotNumber() : JYUSB1202Core.h
  • JYUSB1202_GetCapabilityInt() : JYUSB1202Core.h
  • JYUSB1202_GetCapabilityIntByName() : JYUSB1202Core.h
  • JYUSB1202_GetCapabilityIntBySlotNumber() : JYUSB1202Core.h
  • JYUSB1202_GetDeviceSerialNumber() : JYUSB1202Core.h
  • JYUSB1202_Open() : JYUSB1202Core.h
  • JYUSB1202_OpenByName() : JYUSB1202Core.h


1202 C++ Programming Manual: File Members

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
Here is a list of all typedefs with links to the files they belong to:
  • BOOL : JYUSB1202Core.h
  • JYUSB1202_DeviceHandle : JYUSB1202Core.h


1202 C++ Programming Manual: Main Page

1202 C++ Programming Manual Documentation


1202 C++ Programming Manual: Member List

  • Class List
  • Class Index
  • Class Members
ScalingCoefficients Member List

This is the complete list of members for ScalingCoefficients, including all inherited members.

Gain | ScalingCoefficients
Offset | ScalingCoefficients