1601 C++ Programming Manual: D:/OneDrive/Desktop/CHM/1601/C++/JYUSB1601Core.h File Reference

1601 C++ Programming Manual
  • Main Page
  • Files
  • File List
  • File Members

Macros | Typedefs | Enumerations | Functions
JYUSB1601Core.h File Reference

Macros

#define EXTERN_C extern "C"
Windows.

Typedefs

typedef int | BOOL
typedef void * | JYUSB1601_DeviceHandle

Enumerations

enum | JYUSB160_AI_Terminal { JYUSB160_AI_RSE = 0x0 , JYUSB160_AI_Diff = 0x1 }
enum | JYUSB1601_AI_SampleMode { JYUSB1601_AI_Finite = 0x0 , JYUSB1601_AI_Continuous = 0x1 , JYUSB1601_AI_Single = 0x2 }
enum | JYUSB1601_TriggerType { JYUSB1601_Immediately = 0x0 , JYUSB1601_Digital = 0x1 , JYUSB1601_Soft = 0x2 }
enum | JYUSB1601_AI_Bandwidth { JYUSB1601_AI_39K = 0x0 , JYUSB1601_AI_15K = 0x1 , JYUSB1601_AI_80K = 0x2 }
enum | JYUSB1601_DigitalTriggerEdge { JYUSB1601_Rising = 0x0 , JYUSB1601_Falling = 0x1 , JYUSB1601_High_Level = 0x2 , JYUSB1601_Low_Level = 0x3 }
enum | JYUSB1601_AO_UpdateMode { JYUSB1601_AO_Finite = 0x0 , JYUSB1601_AO_ContinuousWrapping = 0x1 , JYUSB1601_AO_ContinuousNoWrapping = 0x2 , JYUSB1601_AO_Single = 0x3 }
enum | JYUSB1601_OutputCompleteState { JYUSB1601_Zero = 0x0 , JYUSB1601_Hold = 0x1 }
enum | JYUSB1601_SampleClockSource { JYUSB1601_InternalClock = 0x0 , JYUSB1601_ExternalClock = 0x1 }
enum JYUSB1601_CI_MeasureType {
JYUSB1601_CI_EdgeCount = 0 , JYUSB1601_CI_Measure_FrequencyOrPeriod = 1 , JYUSB1601_CI_Measure_PulseWidth = 2 , JYUSB1601_CI_Measure_EdgeSeparation = 3 ,
JYUSB1601_CI_Encoder_X2 = 4 , JYUSB1601_CI_Encoder_X4 = 5
}
enum | JYUSB1601_CountDirection { JYUSB1601_CI_Count_Up , JYUSB1601_CI_Count_Down }
enum | JYUSB1601_CI_CounterEventSignalIdleState { JYUSB1601_CI_CounterEventSignalIdleState_Low = 0 , JYUSB1601_CI_CounterEventSignalIdleState_High = 1 }
CI Counter Event Signal Idle State. More...
enum | JYUSB1601_LevelState { JYUSB1601_LowLevel = 0 , JYUSB1601_HighLevel = 1 }
enum | JYUSB1601_CO_IdleState { JYUSB1601_CO_LowLevel = 0 , JYUSB1601_CO_HighLevel = 1 }
enum JYUSB1601_Signal_SrcAndDest {
JYUSB1601_NONE = -1 , JYUSB1601_DIO_0 = 0 , JYUSB1601_DIO_1 = 1 , JYUSB1601_DIO_2 = 2 ,
JYUSB1601_DIO_3 = 3 , JYUSB1601_DIO_4 = 4 , JYUSB1601_DIO_5 = 5 , JYUSB1601_DIO_6 = 6 ,
JYUSB1601_DIO_7 = 7 , JYUSB1601_DIO_8 = 8 , JYUSB1601_DIO_9 = 9 , JYUSB1601_DIO_10 =10 ,
JYUSB1601_DIO_11 =11 , JYUSB1601_DIO_12 =12 , JYUSB1601_DIO_13 =13 , JYUSB1601_DIO_14 =14 ,
JYUSB1601_DIO_15 =15
}

Functions

EXTERN_C JYUSB1601API int | JYUSB1601_Open (JYUSB1601_DeviceHandle *hDevice)
Open the USB1601 board，default open the first card.
EXTERN_C JYUSB1601API int | JYUSB1601_OpenByName (const char *cardName, JYUSB1601_DeviceHandle *hDevice)
Open this USB1601 board using the board alias name which is set by JYTEK utility JYDM.
EXTERN_C JYUSB1601API int | JYUSB1601_Close (JYUSB1601_DeviceHandle hDevice)
Close this USB1601 board.
EXTERN_C JYUSB1601API int | JYUSB1601_GetDeviceSerialNumber (JYUSB1601_DeviceHandle hDevice, char *serialNumber, int length)
Obtain the device serialNumber.
EXTERN_C JYUSB1601API int | JYUSB1601_AI_EnableChannel (JYUSB1601_DeviceHandle hDevice, unsigned int channelCount, unsigned char *channels, double *lowRegion, double *highRegion, JYUSB160_AI_Terminal terminal)
Enable AI channels.
EXTERN_C JYUSB1601API int | JYUSB1601_AI_SetMode (JYUSB1601_DeviceHandle hDevice, JYUSB1601_AI_SampleMode mode)
Set AI sampling mode.
EXTERN_C JYUSB1601API int | JYUSB1601_AI_SetSampleClock (JYUSB1601_DeviceHandle hDevice, JYUSB1601_SampleClockSource sampleClockSource, double expectedRate)
Set AI sampling clock source.
EXTERN_C JYUSB1601API int | JYUSB1601_AI_SetSampleRate (JYUSB1601_DeviceHandle hDevice, double sampleRate, double *actualSampleRate)
Set sampling rate.
EXTERN_C JYUSB1601API int | JYUSB1601_AI_SetBandwidth (JYUSB1601_DeviceHandle hDevice, JYUSB1601_AI_Bandwidth bandWidth)
config the AI programble low pass filter
EXTERN_C JYUSB1601API int | JYUSB1601_AI_SetSamplesToAcquire (JYUSB1601_DeviceHandle hDevice, unsigned int sampleToAcquire)
Set AI samples to acquire for each channel in finite mode.The samples range is 1 to 64M samples / channelCount.
EXTERN_C JYUSB1601API int | JYUSB1601_AI_SetStartTriggerType (JYUSB1601_DeviceHandle hDevice, JYUSB1601_TriggerType triggerType)
Set AI trigger type.
EXTERN_C JYUSB1601API int | JYUSB1601_AI_SetDigitalStartTrigger (JYUSB1601_DeviceHandle hDevice, JYUSB1601_DigitalTriggerEdge triggerEdge, JYUSB1601_Signal_SrcAndDest triggerSrc)
Set AI digital trigger edge.
EXTERN_C JYUSB1601API int | JYUSB1601_AI_ExportTriggerSignal (JYUSB1601_DeviceHandle hDevice, JYUSB1601_Signal_SrcAndDest triggerOutDestination)
Export trigger signal.
EXTERN_C JYUSB1601API int | JYUSB1601_AI_Start (JYUSB1601_DeviceHandle hDevice)
Start AI acquisition.
EXTERN_C JYUSB1601API int | JYUSB1601_AI_CheckBufferStatus (JYUSB1601_DeviceHandle hDevice, unsigned int *avaliableSamples, unsigned long long *transferedSamples, BOOL *overrun)
Check AI Buffer Status.
EXTERN_C JYUSB1601API int | JYUSB1601_AI_SendSoftTrigger (JYUSB1601_DeviceHandle hDevice)
AI Send soft trigger.
EXTERN_C JYUSB1601API int | JYUSB1601_AI_ReadData (JYUSB1601_DeviceHandle hDevice, double *dataBuffer, unsigned int samplesToRead, int timeOut, unsigned int *actualReadLength)
Read AI data to user defined data buffer.
EXTERN_C JYUSB1601API int | JYUSB1601_AI_ExportSampleClock (JYUSB1601_DeviceHandle hDevice, bool sampleClkOutputEnable)
Export AI Sample clock.
EXTERN_C JYUSB1601API int | JYUSB1601_AI_ReadSinglePoint (JYUSB1601_DeviceHandle hDevice, double *readValue, int channelID)
Read single point for each channel to user defined data buffer.
EXTERN_C JYUSB1601API int | JYUSB1601_AI_ReadRawSinglePoint (JYUSB1601_DeviceHandle hDevice, short *readValue, int channelID)
Read raw single point for each channel to user defined data buffer.
EXTERN_C JYUSB1601API int | JYUSB1601_AI_Stop (JYUSB1601_DeviceHandle hDevice)
Stop AI acquisition.
EXTERN_C JYUSB1601API int | JYUSB1601_AI_ReadRawData (JYUSB1601_DeviceHandle hDevice, short *dataBuffer, unsigned int samplesToRead, int timeOut, unsigned int *actualReadSamples)
Read AI raw data to user defined data buffer.
EXTERN_C JYUSB1601API int | JYUSB1601_AI_DisableCalibration (JYUSB1601_DeviceHandle hDevice, bool disableCalibration)
Disable AI calibration coefficient, default false.
EXTERN_C JYUSB1601API int | JYUSB1601_AO_EnableChannel (JYUSB1601_DeviceHandle hDevice, unsigned int channelCount, unsigned char *channels)
Enables AO channels.
EXTERN_C JYUSB1601API int | JYUSB1601_AO_SetUpdateRate (JYUSB1601_DeviceHandle hDevice, double updateRate, double *actualUpdateRate)
Set AO update rate for each channel.
EXTERN_C JYUSB1601API int | JYUSB1601_AO_SetMode (JYUSB1601_DeviceHandle hDevice, JYUSB1601_AO_UpdateMode mode)
Set AO mode, the mode defined by enum JYUSB1601_AO_UpdateMode.
EXTERN_C JYUSB1601API int | JYUSB1601_AO_ExportSampleClock (JYUSB1601_DeviceHandle hDevice, bool sampleClkOutputEnable)
Exprot ao sample clock.
EXTERN_C JYUSB1601API int | JYUSB1601_AO_SetSamplesToUpdate (JYUSB1601_DeviceHandle hDevice, unsigned int sampleToUpdate)
Set AO samples for each channel in the finite mode.The sample range is from 1 to 32M / channelCount samples.
EXTERN_C JYUSB1601API int | JYUSB1601_AO_Start (JYUSB1601_DeviceHandle hDevice)
Start digital signal output.
EXTERN_C JYUSB1601API int | JYUSB1601_AO_WriteData (JYUSB1601_DeviceHandle hDevice, double *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualWriteLength)
AO write raw data.The data is interleaved in the buffer in channel order for multi-channel.
EXTERN_C JYUSB1601API int | JYUSB1601_AO_Stop (JYUSB1601_DeviceHandle hDevice)
Stop analog signal output.
EXTERN_C JYUSB1601API int | JYUSB1601_AO_SetSampleClock (JYUSB1601_DeviceHandle hDevice, JYUSB1601_SampleClockSource clockSource, double expectedRate)
Set AO sampling clock source.
EXTERN_C JYUSB1601API int | JYUSB1601_AO_WriteSinglePoint (JYUSB1601_DeviceHandle hDevice, double *writeValues, int channelID)
AO write single point raw data to the defined channel by channelID, if channelID == -1, write all enable channel.
EXTERN_C JYUSB1601API int | JYUSB1601_AO_WaitUntilDone (JYUSB1601_DeviceHandle hDevice, bool *done, int timeOut)
Check AO finite output is complete.
EXTERN_C JYUSB1601API int | JYUSB1601_AO_CheckBufferStatus (JYUSB1601_DeviceHandle hDevice, unsigned long *avaliableBufferInSamples, unsigned long long *transferedSamples, BOOL *overrun)
Check AO task buffer status.
EXTERN_C JYUSB1601API int | JYUSB1601_AO_SendSoftTrigger (JYUSB1601_DeviceHandle hDevice)
Send the software trigger signal.
EXTERN_C JYUSB1601API int | JYUSB1601_AO_SetStartTriggerType (JYUSB1601_DeviceHandle hDevice, JYUSB1601_TriggerType triggerType)
Set AO trigger type.
EXTERN_C JYUSB1601API int | JYUSB1601_AO_SetDigitalStartTrigger (JYUSB1601_DeviceHandle hDevice, JYUSB1601_DigitalTriggerEdge triggerEdge, JYUSB1601_Signal_SrcAndDest trigegrSrc)
Set AO digital trigger edge.
EXTERN_C JYUSB1601API int | JYUSB1601_AO_ExportTriggerSignal (JYUSB1601_DeviceHandle hDevice, JYUSB1601_Signal_SrcAndDest triggerOutDest)
Export trigger signal.
EXTERN_C JYUSB1601API int | JYUSB1601_AO_SetOutputCompleteState (JYUSB1601_DeviceHandle hDevice, JYUSB1601_OutputCompleteState State)
Set AO Output complete state, Default is Hold.
EXTERN_C JYUSB1601API int | JYUSB1601_AO_DisableCalibration (JYUSB1601_DeviceHandle hDevice, bool disableCalibration)
Disable AI calibration coefficient, default false.
EXTERN_C JYUSB1601API int | JYUSB1601_DI_AddLines (JYUSB1601_DeviceHandle hDevice, char *line, int lineCount)
Enabled DI channels.
EXTERN_C JYUSB1601API int | JYUSB1601_DI_ReadSinglePoint (JYUSB1601_DeviceHandle hDevice, bool *readValues, int lineID)
read single data from a single line by lineID defined.if the lineID == -1,read all line data.The data type is bool, one bool defined one line status.
EXTERN_C JYUSB1601API int | JYUSB1601_DI_Start (JYUSB1601_DeviceHandle hDevice)
Start digital signal input.
EXTERN_C JYUSB1601API int | JYUSB1601_DI_Stop (JYUSB1601_DeviceHandle hDevice)
Stop digital signal input.
EXTERN_C JYUSB1601API int | JYUSB1601_DO_AddLines (JYUSB1601_DeviceHandle hDevice, char *line, int lineCount)
Enabled DO channels.
EXTERN_C JYUSB1601API int | JYUSB1601_DO_WriteSinglePoint (JYUSB1601_DeviceHandle hDevice, bool *writeValues, int lineID)
write single data to the line by lineID defined.if the lineID == -1,write all line data.
EXTERN_C JYUSB1601API int | JYUSB1601_DO_Start (JYUSB1601_DeviceHandle hDevice)
Start digital signal output.
EXTERN_C JYUSB1601API int | JYUSB1601_DO_Stop (JYUSB1601_DeviceHandle hDevice)
Stop digital signal output.
EXTERN_C JYUSB1601API int | JYUSB1601_CI_SetCounterType (JYUSB1601_DeviceHandle hDevice, unsigned int channel, JYUSB1601_CI_MeasureType measureType)
Set CI measure type.
EXTERN_C JYUSB1601API int | JYUSB1601_CI_SetCounterParamet (JYUSB1601_DeviceHandle hDevice, unsigned int channel, int initCount, JYUSB1601_CountDirection countDirection)
Set CI count parameter.
EXTERN_C JYUSB1601API int | JYUSB1601_CI_SetZReloadEnabled (JYUSB1601_DeviceHandle hDevice, unsigned int channel, bool zReloadEnabled)
Set the Z signal enable in Encoder mode.
EXTERN_C JYUSB1601API int | JYUSB1601_CI_SetEdgeCountEvent (JYUSB1601_DeviceHandle hDevice, unsigned int channel, JYUSB1601_CI_CounterEventSignalIdleState idleState, unsigned int threshold)
Set the counter threshold, and when the count reaches this threshold, output a single pulse at the output terminal.
EXTERN_C JYUSB1601API int | JYUSB1601_CI_SetPauseTriggerLevel (JYUSB1601_DeviceHandle hDevice, unsigned int channel, bool enable, JYUSB1601_LevelState pauseTriggerActiveLevel)
Config CI pause trigger.
EXTERN_C JYUSB1601API int | JYUSB1601_CI_ReadSingleCountValue (JYUSB1601_DeviceHandle hDevice, unsigned int channel, int *countValue)
Counter reads a single count value, this API supports the CI Type: JYUSB1601_CI_EdgeCount、JYUSB1601_CI_EncoderX1、 JYUSB1601_CI_EncoderX2 、 JYUSB1601_CI_EncoderX4 、JYUSB1601_CI_EncoderTwoPulse.
EXTERN_C JYUSB1601API int | JYUSB1601_CI_CheckStatus (JYUSB1601_DeviceHandle hDevice, int channel, bool *completed)
check the CI measure is completed or not
EXTERN_C JYUSB1601API int | JYUSB1601_CI_ReadSingleMeasureValue (JYUSB1601_DeviceHandle hDevice, unsigned int channel, double *measureValue1, double *measureValue2, int timeOut)
Reads a single counter measurement as follows.
EXTERN_C JYUSB1601API int | JYUSB1601_CI_Start (JYUSB1601_DeviceHandle hDevice, unsigned int channel)
Start Counter input.
EXTERN_C JYUSB1601API int | JYUSB1601_CI_Stop (JYUSB1601_DeviceHandle hDevice, unsigned int channel)
Stop Counter input.
EXTERN_C JYUSB1601API int | JYUSB1601_CO_SetPauseTriggerLevel (JYUSB1601_DeviceHandle hDevice, unsigned int channel, bool enable, JYUSB1601_LevelState pauseTriggerActiveLevel)
Config CO pause trigger.
EXTERN_C JYUSB1601API int | JYUSB1601_CO_SetCounterParamet (JYUSB1601_DeviceHandle hDevice, unsigned int channel, int pulseCount, JYUSB1601_CO_IdleState IdleState)
Set CO parameter.
EXTERN_C JYUSB1601API int | JYUSB1601_CO_SetFrequency (JYUSB1601_DeviceHandle hDevice, unsigned int channel, unsigned int highTicks, unsigned int lowTicks)
Set counter output pulse frequency.
EXTERN_C JYUSB1601API int | JYUSB1601_CO_Start (JYUSB1601_DeviceHandle hDevice, unsigned int channel)
Start counter output.
EXTERN_C JYUSB1601API int | JYUSB1601_CO_Stop (JYUSB1601_DeviceHandle hDevice, unsigned int channel)
Stop counter output.
EXTERN_C JYUSB1601API int | JYUSB1601_CO_WaitUntilDone (JYUSB1601_DeviceHandle hDevice, unsigned int channel, bool *done, int timeOut)
Check CO output is completed or not.

Macro Definition Documentation

◆ EXTERN_C

#define EXTERN_C extern "C"

Windows.

Linux

Typedef Documentation

◆ BOOL

typedef int BOOL

◆ JYUSB1601_DeviceHandle

typedef void* JYUSB1601_DeviceHandle

Enumeration Type Documentation

◆ JYUSB1601_AI_Bandwidth

enum JYUSB1601_AI_Bandwidth
Enumerator
JYUSB1601_AI_39K | 39K Bandwidth
JYUSB1601_AI_15K | 15K Bandwidth
JYUSB1601_AI_80K | 80K Bandwidth

◆ JYUSB1601_AI_SampleMode

enum JYUSB1601_AI_SampleMode
Enumerator
JYUSB1601_AI_Finite | AI Finite mode.
JYUSB1601_AI_Continuous | AI Continuous mode.
JYUSB1601_AI_Single | AI Single mode.

◆ JYUSB1601_AO_UpdateMode

enum JYUSB1601_AO_UpdateMode
Enumerator
JYUSB1601_AO_Finite | AO Finite mode.
JYUSB1601_AO_ContinuousWrapping | AO ContinuousWrapping mode.
JYUSB1601_AO_ContinuousNoWrapping | AO ContinuousNoWrapping mode.
JYUSB1601_AO_Single | AO Single mode.

◆ JYUSB1601_CI_CounterEventSignalIdleState

enum JYUSB1601_CI_CounterEventSignalIdleState

CI Counter Event Signal Idle State.

Enumerator
JYUSB1601_CI_CounterEventSignalIdleState_Low | Low Level as the CI Counter Event Signal Idle State.
JYUSB1601_CI_CounterEventSignalIdleState_High | High Level as the CI Counter Event Signal Idle State.

◆ JYUSB1601_CI_MeasureType

enum JYUSB1601_CI_MeasureType
Enumerator
JYUSB1601_CI_EdgeCount | Edge count.
JYUSB1601_CI_Measure_FrequencyOrPeriod | FrequencyOrPeriod Measurement.
JYUSB1601_CI_Measure_PulseWidth | Pulse Measurement.
JYUSB1601_CI_Measure_EdgeSeparation | Two Edge Separation Measurement.
JYUSB1601_CI_Encoder_X2 | Encoder_X2.
JYUSB1601_CI_Encoder_X4 | Encoder_X4.

◆ JYUSB1601_CO_IdleState

enum JYUSB1601_CO_IdleState
Enumerator
JYUSB1601_CO_LowLevel | Low Level as the co idle state.
JYUSB1601_CO_HighLevel | High Level as the co idle state.

◆ JYUSB1601_CountDirection

enum JYUSB1601_CountDirection
Enumerator
JYUSB1601_CI_Count_Up | Increases count.
JYUSB1601_CI_Count_Down | Reduction count.

◆ JYUSB1601_DigitalTriggerEdge

enum JYUSB1601_DigitalTriggerEdge
Enumerator
JYUSB1601_Rising | Rsing edge for digital trigger.
JYUSB1601_Falling | Falling edge for digital trigger.
JYUSB1601_High_Level | High Level for digital trigger.
JYUSB1601_Low_Level | Low Level for digital trigger.

◆ JYUSB1601_LevelState

enum JYUSB1601_LevelState
Enumerator
JYUSB1601_LowLevel | Low Level as the pause trigger active level.
JYUSB1601_HighLevel | High Level as the pause trigger active level.

◆ JYUSB1601_OutputCompleteState

enum JYUSB1601_OutputCompleteState
Enumerator
JYUSB1601_Zero | Output Zero.
JYUSB1601_Hold | Output Hold.

◆ JYUSB1601_SampleClockSource

enum JYUSB1601_SampleClockSource
Enumerator
JYUSB1601_InternalClock | Internal Clock Source.
JYUSB1601_ExternalClock | External Clock Source.

◆ JYUSB1601_Signal_SrcAndDest

enum JYUSB1601_Signal_SrcAndDest
Enumerator
JYUSB1601_NONE | NO signal need route.
JYUSB1601_DIO_0 | DIO_0 as the signal desition to rout.
JYUSB1601_DIO_1 | DIO_1 as the signal desition to rout.
JYUSB1601_DIO_2 | DIO_2 as the signal desition to rout.
JYUSB1601_DIO_3 | DIO_3 as the signal desition to rout.
JYUSB1601_DIO_4 | DIO_4 as the signal desition to rout.
JYUSB1601_DIO_5 | DIO_5 as the signal desition to rout.
JYUSB1601_DIO_6 | DIO_6 as the signal desition to rout.
JYUSB1601_DIO_7 | DIO_7 as the signal desition to rout.
JYUSB1601_DIO_8 | DIO_0 as the signal desition to rout.
JYUSB1601_DIO_9 | DIO_1 as the signal desition to rout.
JYUSB1601_DIO_10 | DIO_2 as the signal desition to rout.
JYUSB1601_DIO_11 | DIO_3 as the signal desition to rout.
JYUSB1601_DIO_12 | DIO_4 as the signal desition to rout.
JYUSB1601_DIO_13 | DIO_5 as the signal desition to rout.
JYUSB1601_DIO_14 | DIO_6 as the signal desition to rout.
JYUSB1601_DIO_15 | DIO_7 as the signal desition to rout.

◆ JYUSB1601_TriggerType

enum JYUSB1601_TriggerType
Enumerator
JYUSB1601_Immediately | AI Immediately trigger.
JYUSB1601_Digital | AI Digital trigger.
JYUSB1601_Soft | AI Soft trigger.

◆ JYUSB160_AI_Terminal

enum JYUSB160_AI_Terminal
Enumerator
JYUSB160_AI_RSE | AI RSE connection mode.
JYUSB160_AI_Diff | AI Diff connection mode.

Function Documentation

◆ JYUSB1601_AI_CheckBufferStatus()

EXTERN_C JYUSB1601API int JYUSB1601_AI_CheckBufferStatus | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | unsigned int * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | BOOL * | overrun )

Check AI Buffer Status.

Parameters
hDevice | device handle
avaliableSamples | avaliableSamples
transferedSamples | transferedSamples
overrun | overrun
Returns
0 if success or other error code

◆ JYUSB1601_AI_DisableCalibration()

EXTERN_C JYUSB1601API int JYUSB1601_AI_DisableCalibration | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | bool | disableCalibration )

Disable AI calibration coefficient, default false.

Parameters
hDevice | device handle
DisableCalibration | true if disabled, false if not disabled.
Returns
0 if Success or other error code

◆ JYUSB1601_AI_EnableChannel()

EXTERN_C JYUSB1601API int JYUSB1601_AI_EnableChannel | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | unsigned int | channelCount,
 |  | unsigned char * | channels,
 |  | double * | lowRegion,
 |  | double * | highRegion,
 |  | JYUSB160_AI_Terminal | terminal )

Enable AI channels.

Each channel can be independently configured

Parameters
hDevice | device handle
channelCount | number of channels to be enabled
channels | array[channelCount] containing channel IDs
lowRegion | array[channelCount] of lower limit numbers for each channel,typically in volts.
highRegion | higher limit numbers for each channel, typcially in volts.
terminal | terminal configuration defined by enum JYUSB1601_AI_Terminal which can be RSE,DIFF. Defalut : RSE
Returns
0 if success or other error code

◆ JYUSB1601_AI_ExportSampleClock()

EXTERN_C JYUSB1601API int JYUSB1601_AI_ExportSampleClock | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | bool | sampleClkOutputEnable )

Export AI Sample clock.

◆ JYUSB1601_AI_ExportTriggerSignal()

EXTERN_C JYUSB1601API int JYUSB1601_AI_ExportTriggerSignal | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | JYUSB1601_Signal_SrcAndDest | triggerOutDestination )

Export trigger signal.

Parameters
hDevice | device handle
triggerOutDestination | destination
triggerOutEnable | enable
Returns

◆ JYUSB1601_AI_ReadData()

EXTERN_C JYUSB1601API int JYUSB1601_AI_ReadData | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | double * | dataBuffer,
 |  | unsigned int | samplesToRead,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength )

Read AI data to user defined data buffer.

For the multi-channel acquisition, the data is interleaved in the order defined by JYUSB1601_AI_EnableChannel.

Parameters
hDevice | device handle
dataBuffer | user buffer,the buffer size must be greater than or equal to dataLength*channelCount.
samplesToRead | number of samples per channel
timeOut | timeout time in microsecond
actualReadLength | returns the number of samples per channel actually read
Returns
0 if success or other error code

◆ JYUSB1601_AI_ReadRawData()

EXTERN_C JYUSB1601API int JYUSB1601_AI_ReadRawData | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | short * | dataBuffer,
 |  | unsigned int | samplesToRead,
 |  | int | timeOut,
 |  | unsigned int * | actualReadSamples )

Read AI raw data to user defined data buffer.

For the multi-channel acquisition, the data is interleaved in the order defined by JYUSB1601_AI_EnableChannel.

Parameters
hDevice | device handle
dataBuffer | user buffer, The size of dataBuffer must be greater than or equal to dataLength*channelCount.
samplesToRead | number of samples per channel
timeOut | timeout time in microsecond
actualReadSamples | return the number of samples per channel actually read
Returns
0 if success or other error code

◆ JYUSB1601_AI_ReadRawSinglePoint()

EXTERN_C JYUSB1601API int JYUSB1601_AI_ReadRawSinglePoint | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | short * | readValue,
 |  | int | channelID )

Read raw single point for each channel to user defined data buffer.

Parameters
hDevice | device handle
readValue | user buffer,the size of readValue must be greater than or equal to channelCount.
channelID | read the specified channelID. when the channelID is -1, read all enabled channels value.
Returns
0 if success or other error code

◆ JYUSB1601_AI_ReadSinglePoint()

EXTERN_C JYUSB1601API int JYUSB1601_AI_ReadSinglePoint | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | double * | readValue,
 |  | int | channelID )

Read single point for each channel to user defined data buffer.

Parameters
hDevice | device handle
readValue | user buffer,the size of readValue must be greater than or equal to channelCount.
channelID | read the specified channelID. when the channelID is -1, read all enabled channels value.
Returns
0 if success or other error code

◆ JYUSB1601_AI_SendSoftTrigger()

EXTERN_C JYUSB1601API int JYUSB1601_AI_SendSoftTrigger ( JYUSB1601_DeviceHandle hDevice )

AI Send soft trigger.

Parameters
hDevice
Returns

◆ JYUSB1601_AI_SetBandwidth()

EXTERN_C JYUSB1601API int JYUSB1601_AI_SetBandwidth | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | JYUSB1601_AI_Bandwidth | bandWidth )

config the AI programble low pass filter

Parameters
hDevice | device handle
bandWidth | 0: 39kHz; 1: 15kHz; 2: 80kHz,defalut: 80K
Returns
0 if success or other error code

◆ JYUSB1601_AI_SetDigitalStartTrigger()

EXTERN_C JYUSB1601API int JYUSB1601_AI_SetDigitalStartTrigger | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | JYUSB1601_DigitalTriggerEdge | triggerEdge,
 |  | JYUSB1601_Signal_SrcAndDest | triggerSrc )

Set AI digital trigger edge.

Parameters
hDevice | device handle
triggerEdge | trigger edge
Returns

◆ JYUSB1601_AI_SetMode()

EXTERN_C JYUSB1601API int JYUSB1601_AI_SetMode | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | JYUSB1601_AI_SampleMode | mode )

Set AI sampling mode.

Parameters
hDevice | device handle
mode | AI sampling mode defined by enum JYUSB1601_AI_SampleMode.
Returns
0 if success or other error code

◆ JYUSB1601_AI_SetSampleClock()

EXTERN_C JYUSB1601API int JYUSB1601_AI_SetSampleClock | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | JYUSB1601_SampleClockSource | sampleClockSource,
 |  | double | expectedRate )

Set AI sampling clock source.

the source of the sampling clock defined by enum JYUSB1601_ClockSource. If the clock source is external, external clock terminal and external clock frequency must be configured.

Parameters
hDevice | device handle
sampleClockSource | AI sampling clock source
expectedRate | AI external clock frequency
Returns
0 if success or other error code

◆ JYUSB1601_AI_SetSampleRate()

EXTERN_C JYUSB1601API int JYUSB1601_AI_SetSampleRate | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | double | sampleRate,
 |  | double * | actualSampleRate )

Set sampling rate.

The sampling rate is the same for all channels.

Parameters
hDevice | device handle
sampleRate | AI sampling rate to be set per channel
actualSampleRate | actual sampling rate set by this device,which may be different from the desired sampleRate.
Returns
0 if success or other error code

◆ JYUSB1601_AI_SetSamplesToAcquire()

EXTERN_C JYUSB1601API int JYUSB1601_AI_SetSamplesToAcquire | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | unsigned int | sampleToAcquire )

Set AI samples to acquire for each channel in finite mode.The samples range is 1 to 64M samples / channelCount.

Parameters
hDevice | device handle
sampleToAcquire | AI finite samples to acquire for each channel, samples range:1 to 64M samples / channelCount.
Returns
0 if success or other error code

◆ JYUSB1601_AI_SetStartTriggerType()

EXTERN_C JYUSB1601API int JYUSB1601_AI_SetStartTriggerType | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | JYUSB1601_TriggerType | triggerType )

Set AI trigger type.

Parameters
hDevice | device handle
triggerType | AI trigger type. Options:immediate trigger, software trigger, digital trigger or analog trigger.
Returns

◆ JYUSB1601_AI_Start()

EXTERN_C JYUSB1601API int JYUSB1601_AI_Start ( JYUSB1601_DeviceHandle hDevice )

Start AI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JYUSB1601_AI_Stop()

EXTERN_C JYUSB1601API int JYUSB1601_AI_Stop ( JYUSB1601_DeviceHandle hDevice )

Stop AI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JYUSB1601_AO_CheckBufferStatus()

EXTERN_C JYUSB1601API int JYUSB1601_AO_CheckBufferStatus | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | unsigned long * | avaliableBufferInSamples,
 |  | unsigned long long * | transferedSamples,
 |  | BOOL * | overrun )

Check AO task buffer status.

This API is intended to be compatible with older version drivers. It is recommended to use API JYUSB1601_AO_CheckBufferStatusEx.

Parameters
hDevice | device handle
avaliableSamples | number of AO samples per channel user can write
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JYUSB1601_AO_DisableCalibration()

EXTERN_C JYUSB1601API int JYUSB1601_AO_DisableCalibration | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | bool | disableCalibration )

Disable AI calibration coefficient, default false.

Parameters
hDevice | device handle
DisableCalibration | true if disabled, false if not disabled.
Returns
0 if Success or other error code

◆ JYUSB1601_AO_EnableChannel()

EXTERN_C JYUSB1601API int JYUSB1601_AO_EnableChannel | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | unsigned int | channelCount,
 |  | unsigned char * | channels )

Enables AO channels.

Parameters
hDevice | device handle
channelCount | number of channels to be enabled
channels | array[channelCount] containing channel IDs
lowRegion | array[channelCount] of lower limit numbers for each channel,typically in volts.
highRegion | array[channelCount] of higher limit numbers for each channel, typcially in volts.
Returns
0 if success or other error code

◆ JYUSB1601_AO_ExportSampleClock()

EXTERN_C JYUSB1601API int JYUSB1601_AO_ExportSampleClock | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | bool | sampleClkOutputEnable )

Exprot ao sample clock.

◆ JYUSB1601_AO_ExportTriggerSignal()

EXTERN_C JYUSB1601API int JYUSB1601_AO_ExportTriggerSignal | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | JYUSB1601_Signal_SrcAndDest | triggerOutDest )

Export trigger signal.

Parameters
hDevice | device handle
triggerOutDestination | destination
triggerOutEnable | enable
Returns

◆ JYUSB1601_AO_SendSoftTrigger()

EXTERN_C JYUSB1601API int JYUSB1601_AO_SendSoftTrigger ( JYUSB1601_DeviceHandle hDevice )

Send the software trigger signal.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JYUSB1601_AO_SetDigitalStartTrigger()

EXTERN_C JYUSB1601API int JYUSB1601_AO_SetDigitalStartTrigger | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | JYUSB1601_DigitalTriggerEdge | triggerEdge,
 |  | JYUSB1601_Signal_SrcAndDest | trigegrSrc )

Set AO digital trigger edge.

Parameters
hDevice | device handle
triggerEdge | trigger edge.
Returns

◆ JYUSB1601_AO_SetMode()

EXTERN_C JYUSB1601API int JYUSB1601_AO_SetMode | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | JYUSB1601_AO_UpdateMode | mode )

Set AO mode, the mode defined by enum JYUSB1601_AO_UpdateMode.

Parameters
hDevice | device handle
mode | AO output mode.Options: Single,Finite,ContinuousWrapping,ContinuousNoWrapping mode.
Returns
0 if success or other error code

◆ JYUSB1601_AO_SetOutputCompleteState()

EXTERN_C JYUSB1601API int JYUSB1601_AO_SetOutputCompleteState | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | JYUSB1601_OutputCompleteState | State )

Set AO Output complete state, Default is Hold.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JYUSB1601_AO_SetSampleClock()

EXTERN_C JYUSB1601API int JYUSB1601_AO_SetSampleClock | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | JYUSB1601_SampleClockSource | clockSource,
 |  | double | expectedRate )

Set AO sampling clock source.

the source of the sampling clock defined by enum JYUSB1601_ClockSource. If the clock source is external, need to configure external clock terminal and external clock frequency.

Parameters
hDevice | device handle
clockSource | AO sampling clock source
expectedRate | external clock frequency
Returns
0 if success or other error code

◆ JYUSB1601_AO_SetSamplesToUpdate()

EXTERN_C JYUSB1601API int JYUSB1601_AO_SetSamplesToUpdate | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | unsigned int | sampleToUpdate )

Set AO samples for each channel in the finite mode.The sample range is from 1 to 32M / channelCount samples.

Parameters
hDevice | device handle
sampleToUpdate | number of AO samples per channel. Data range:1 to 32M / channelCount samples.
Returns
0 if success or other error code

◆ JYUSB1601_AO_SetStartTriggerType()

EXTERN_C JYUSB1601API int JYUSB1601_AO_SetStartTriggerType | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | JYUSB1601_TriggerType | triggerType )

Set AO trigger type.

Parameters
hDevice | device handle
triggerType | AO trigger type. Options:immediate trigger, software trigger, digital trigger or analog trigger.
Returns

◆ JYUSB1601_AO_SetUpdateRate()

EXTERN_C JYUSB1601API int JYUSB1601_AO_SetUpdateRate | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | double | updateRate,
 |  | double * | actualUpdateRate )

Set AO update rate for each channel.

Parameters
hDevice | device handle
updateRate | AO update rate to be set per channel
actualUpdateRate | AO update rate actually set. The actual update rate set by this device,which may be different from the desired updata rate.
Returns
0 if success or other error code

◆ JYUSB1601_AO_Start()

EXTERN_C JYUSB1601API int JYUSB1601_AO_Start ( JYUSB1601_DeviceHandle hDevice )

Start digital signal output.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JYUSB1601_AO_Stop()

EXTERN_C JYUSB1601API int JYUSB1601_AO_Stop ( JYUSB1601_DeviceHandle hDevice )

Stop analog signal output.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JYUSB1601_AO_WaitUntilDone()

EXTERN_C JYUSB1601API int JYUSB1601_AO_WaitUntilDone | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | bool * | done,
 |  | int | timeOut )

Check AO finite output is complete.

Parameters
hDevice | device handle
done | true if completed, false if not yet completed.
timeOut | timeout time in microsecond, this parament not valid in current version
Returns
0 if success or other error code

◆ JYUSB1601_AO_WriteData()

EXTERN_C JYUSB1601API int JYUSB1601_AO_WriteData | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | double * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualWriteLength )

AO write raw data.The data is interleaved in the buffer in channel order for multi-channel.

Parameters
hDevice | device handle
dataBuffer | user buffer, the buffer size must be greater than or equal to dataLength*number of enabled channels.
dataLength | total number of output data for all channels, if there are 2 channels, 1 means 2 short for channel 0, 1 each
timeOut | timeout time in microsecond
actualWriteLength | the number of samples per channel actually write
Returns
0 if success or other error code

AO writes data.The data is interleaved in the buffer the order defined by JYUSB1601_AO_EnableChannel.

Parameters
hDevice | device handle
dataBuffer | user buffer of output data.The buffer size must be greater than or equal to dataLength*number of enabled channels.
dataLength | total number of output data for all channels
timeOut | timeout time in microsecond
actualWriteLength | the number of samples per channel actually write
Returns
0 if success or other error code

◆ JYUSB1601_AO_WriteSinglePoint()

EXTERN_C JYUSB1601API int JYUSB1601_AO_WriteSinglePoint | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | double * | writeValues,
 |  | int | channelID )

AO write single point raw data to the defined channel by channelID, if channelID == -1, write all enable channel.

Parameters
hDevice | device handle
writeValues | write value for each enable channel,when channelID == -1 the writeValue length must equal to channelCount
channelID | defined channel, if channelID == -1, write all enable channel one data
Returns
0 if success or other error code

AO write single point data to the defined channel by channelID, if channelID == -1, write all enable channel one data.

Parameters
hDevice | device handle
writeValues | write value for each enable channel,when channelID == -1 the writeValue length must equal to channelCount
channelID | defined channel, if channelID == -1, write all enable channel one data
Returns
0 if success or other error code

◆ JYUSB1601_CI_CheckStatus()

EXTERN_C JYUSB1601API int JYUSB1601_CI_CheckStatus | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | int | channel,
 |  | bool * | completed )

check the CI measure is completed or not

Parameters
hDevice | device handle
channel | >Counter channel
completed | true: completed; false: uncompleted
Returns
0 if success or other error code

◆ JYUSB1601_CI_ReadSingleCountValue()

EXTERN_C JYUSB1601API int JYUSB1601_CI_ReadSingleCountValue | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | int * | countValue )

Counter reads a single count value, this API supports the CI Type: JYUSB1601_CI_EdgeCount、JYUSB1601_CI_EncoderX1、 JYUSB1601_CI_EncoderX2 、 JYUSB1601_CI_EncoderX4 、JYUSB1601_CI_EncoderTwoPulse.

Parameters
hDevice | device handle
channel | counter input channel. An integer counter number, eg, 0 for counter 0.
countValue | return the current count value of counter.
Returns
0 if success or other error code

◆ JYUSB1601_CI_ReadSingleMeasureValue()

EXTERN_C JYUSB1601API int JYUSB1601_CI_ReadSingleMeasureValue | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | double * | measureValue1,
 |  | double * | measureValue2,
 |  | int | timeOut )

Reads a single counter measurement as follows.

for JYUSB1601_CI_Measure_EdgeSeparation type, measureValues1 is the Gate signel to the Aux signal interval, the measureValues2 is the Aux signel to the Gate signal interval, the unit is in s. for JYUSB1601_CI_Measure_Pulse type, measureValues1 is the Low level signal time, the measureValues2 is the high level signal time, the unit is in second. for JYUSB1601_CI_Measure_Frequency type, measureValues1 is signal frequency in Hz, measureValue2 has no meaning. for JYUSB1601_CI_Measure_Period type, measureValues2 is signal period in second; measureValue1 has no meaning.

Parameters
hDevice | device handle
channel | Counter input channel
measureValue1 | current measure value of counter
measureValue2 | current measure value of counter
timeOut | timeout time in microsecond
Returns
0 if success or other error code

◆ JYUSB1601_CI_SetCounterParamet()

EXTERN_C JYUSB1601API int JYUSB1601_CI_SetCounterParamet | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | int | initCount,
 |  | JYUSB1601_CountDirection | countDirection )

Set CI count parameter.

Parameters
hDevice | device handle
channel | counter input channel
initCount | counter initial value
countDirection | counting direction of the counter defined by enum USB1601_CountDirection
Returns
0 if success or other error code

◆ JYUSB1601_CI_SetCounterType()

EXTERN_C JYUSB1601API int JYUSB1601_CI_SetCounterType | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JYUSB1601_CI_MeasureType | measureType )

Set CI measure type.

Parameters
hDevice | device handle
channel | counter input channel
measureType | measure type. defined by enum USB1601_CI_MeasureType
Returns
0 if success or other error code

◆ JYUSB1601_CI_SetEdgeCountEvent()

EXTERN_C JYUSB1601API int JYUSB1601_CI_SetEdgeCountEvent | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JYUSB1601_CI_CounterEventSignalIdleState | idleState,
 |  | unsigned int | threshold )

Set the counter threshold, and when the count reaches this threshold, output a single pulse at the output terminal.

Parameters
hDevice | device handle
channel | counter input channel
idleState | output terminal idle state
threshold | threshold
Returns
0 if success or other error code

◆ JYUSB1601_CI_SetPauseTriggerLevel()

EXTERN_C JYUSB1601API int JYUSB1601_CI_SetPauseTriggerLevel | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool | enable,
 |  | JYUSB1601_LevelState | pauseTriggerActiveLevel )

Config CI pause trigger.

Parameters
hDevice | Device handle
channel | Counter channel
enable | Enable pasue trigger
pauseTriggerActiveLevel | Pause trigger active level.
Returns
Succeed: 0 , Error: !=0

◆ JYUSB1601_CI_SetZReloadEnabled()

EXTERN_C JYUSB1601API int JYUSB1601_CI_SetZReloadEnabled | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool | zReloadEnabled )

Set the Z signal enable in Encoder mode.

Parameters
hDevice | device handle
channel | counter input channel
zReloadEnabled | enable z signal. True: enabled; False: disabled.Valid only under encoder mode.
Returns
0 if success or other error code

◆ JYUSB1601_CI_Start()

EXTERN_C JYUSB1601API int JYUSB1601_CI_Start | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | unsigned int | channel )

Start Counter input.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if success or other error code

◆ JYUSB1601_CI_Stop()

EXTERN_C JYUSB1601API int JYUSB1601_CI_Stop | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | unsigned int | channel )

Stop Counter input.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if success or other error code

◆ JYUSB1601_Close()

EXTERN_C JYUSB1601API int JYUSB1601_Close ( JYUSB1601_DeviceHandle hDevice )

Close this USB1601 board.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JYUSB1601_CO_SetCounterParamet()

EXTERN_C JYUSB1601API int JYUSB1601_CO_SetCounterParamet | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | int | pulseCount,
 |  | JYUSB1601_CO_IdleState | IdleState )

Set CO parameter.

Parameters
hDevice | device handle
channel | counter output channel
pulseCount | counter output pulse number, if pulseCount = -1 ,the device always responds to output until the user stops it.
IdleState | counter output idle state
Returns
0 if success or other error code

◆ JYUSB1601_CO_SetFrequency()

EXTERN_C JYUSB1601API int JYUSB1601_CO_SetFrequency | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int | highTicks,
 |  | unsigned int | lowTicks )

Set counter output pulse frequency.

Parameters
hDevice | device handle
channel | counter output channel
highTicks | the number of ticks for the high pulse, timebase is 200MHz.
lowTicks | the number of ticks for the low pulse, timebase is 200MHz.
Returns
0 if success or other error code

◆ JYUSB1601_CO_SetPauseTriggerLevel()

EXTERN_C JYUSB1601API int JYUSB1601_CO_SetPauseTriggerLevel | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool | enable,
 |  | JYUSB1601_LevelState | pauseTriggerActiveLevel )

Config CO pause trigger.

Parameters
hDevice | Device handle
channel | Counter channel
enable | Enable pasue trigger
pauseTriggerActiveLevel | Pause trigger active level.
Returns
Succeed: 0 , Error: !=0

◆ JYUSB1601_CO_Start()

EXTERN_C JYUSB1601API int JYUSB1601_CO_Start | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | unsigned int | channel )

Start counter output.

Parameters
hDevice | device handle
channel | counter output channel
Returns
0 if success or other error code

◆ JYUSB1601_CO_Stop()

EXTERN_C JYUSB1601API int JYUSB1601_CO_Stop | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | unsigned int | channel )

Stop counter output.

Parameters
hDevice | device handle
channel | counter output channel
Returns
0 if success or other error code

◆ JYUSB1601_CO_WaitUntilDone()

EXTERN_C JYUSB1601API int JYUSB1601_CO_WaitUntilDone | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool * | done,
 |  | int | timeOut )

Check CO output is completed or not.

Parameters
hDevice | device handle
channel | counter output channel
done | true if completed, false if not yet completed.
timeOut | timeout time in microsecond, this parament not valid in current version
Returns
0 if success or other error code

◆ JYUSB1601_DI_AddLines()

EXTERN_C JYUSB1601API int JYUSB1601_DI_AddLines | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | char * | line,
 |  | int | lineCount )

Enabled DI channels.

Parameters
hDevice | device handle
line | array[lineCount] containing line IDs
lineCount | number of lines to be enabled
Returns
0 if success or other error code

◆ JYUSB1601_DI_ReadSinglePoint()

EXTERN_C JYUSB1601API int JYUSB1601_DI_ReadSinglePoint | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | bool * | readValues,
 |  | int | lineID )

read single data from a single line by lineID defined.if the lineID == -1,read all line data.The data type is bool, one bool defined one line status.

Parameters
hDevice | device handle
readValues | read the specified line values. when the lineID is -1, read all enabled line values,the readValues Length must equal to lineCount(In function JYUSB1601_DI_AddLines defined), and the values store order is add order.
lineID | line number
Returns
0 if success or other error code

◆ JYUSB1601_DI_Start()

EXTERN_C JYUSB1601API int JYUSB1601_DI_Start ( JYUSB1601_DeviceHandle hDevice )

Start digital signal input.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JYUSB1601_DI_Stop()

EXTERN_C JYUSB1601API int JYUSB1601_DI_Stop ( JYUSB1601_DeviceHandle hDevice )

Stop digital signal input.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JYUSB1601_DO_AddLines()

EXTERN_C JYUSB1601API int JYUSB1601_DO_AddLines | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | char * | line,
 |  | int | lineCount )

Enabled DO channels.

Parameters
hDevice | device handle
line | array[lineCount] containing line IDs.
lineCount | number of lines to be enabled
Returns
0 if success or other error code

◆ JYUSB1601_DO_Start()

EXTERN_C JYUSB1601API int JYUSB1601_DO_Start ( JYUSB1601_DeviceHandle hDevice )

Start digital signal output.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JYUSB1601_DO_Stop()

EXTERN_C JYUSB1601API int JYUSB1601_DO_Stop ( JYUSB1601_DeviceHandle hDevice )

Stop digital signal output.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JYUSB1601_DO_WriteSinglePoint()

EXTERN_C JYUSB1601API int JYUSB1601_DO_WriteSinglePoint | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | bool * | writeValues,
 |  | int | lineID )

write single data to the line by lineID defined.if the lineID == -1,write all line data.

Parameters
hDevice | device handle
writeValues | write the specified line values when the lineID is -1, write all enabled lines values,the writeValues Length must equal to lineCount(In function JYUSB1601_DO_AddLines defined), and the values order is add order.
lineCount | line count
Returns
0 if success or other error code

◆ JYUSB1601_GetDeviceSerialNumber()

EXTERN_C JYUSB1601API int JYUSB1601_GetDeviceSerialNumber | ( | JYUSB1601_DeviceHandle | hDevice,
 |  | char * | serialNumber,
 |  | int | length )

Obtain the device serialNumber.

Parameters
hDevice | device handle
serialNumber | Pointer to a buffer receiving the serial number. The length of the serial number is 10.
length | serial Number length ,length is 10
Returns
0 if success or other error code

◆ JYUSB1601_Open()

EXTERN_C JYUSB1601API int JYUSB1601_Open ( JYUSB1601_DeviceHandle * hDevice )

Open the USB1601 board，default open the first card.

Parameters
hDevice device handle. All other functions uses hDevice to represent this device.
Returns
0 if success or other error code

◆ JYUSB1601_OpenByName()

EXTERN_C JYUSB1601API int JYUSB1601_OpenByName | ( | const char * | cardName,
 |  | JYUSB1601_DeviceHandle * | hDevice )

Open this USB1601 board using the board alias name which is set by JYTEK utility JYDM.

You can change the name using JYDM.

Parameters
cardName | board alias name
hDevice | device handle
Returns
0 if success or other error code
Generated by doxygen 1.15.0


1601 C++ Programming Manual: D:/OneDrive/Desktop/CHM/1601 Directory Reference

  • OneDrive
  • Desktop
  • CHM
  • 1601
1601 Directory Reference

Directories

         C++


1601 C++ Programming Manual: D:/OneDrive/Desktop Directory Reference

  • OneDrive
  • Desktop
Desktop Directory Reference

Directories

         CHM


1601 C++ Programming Manual: D:/OneDrive/Desktop/CHM/1601/C++ Directory Reference

  • OneDrive
  • Desktop
  • CHM
  • 1601
  • C++
C++ Directory Reference

Files

         JYUSB1601Core.h


1601 C++ Programming Manual: D:/OneDrive/Desktop/CHM Directory Reference

  • OneDrive
  • Desktop
  • CHM
CHM Directory Reference

Directories

         1601


1601 C++ Programming Manual: D:/OneDrive Directory Reference

  • OneDrive
OneDrive Directory Reference

Directories

         Desktop


1601 C++ Programming Manual: File List


1601 C++ Programming Manual: File Members

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • b
  • e
  • j
Here is a list of all file members with links to the files they belong to:

- b -

  • BOOL : JYUSB1601Core.h

- e -

  • EXTERN_C : JYUSB1601Core.h

- j -

  • JYUSB1601_AI_15K : JYUSB1601Core.h
  • JYUSB1601_AI_39K : JYUSB1601Core.h
  • JYUSB1601_AI_80K : JYUSB1601Core.h
  • JYUSB1601_AI_Bandwidth : JYUSB1601Core.h
  • JYUSB1601_AI_CheckBufferStatus() : JYUSB1601Core.h
  • JYUSB1601_AI_Continuous : JYUSB1601Core.h
  • JYUSB1601_AI_DisableCalibration() : JYUSB1601Core.h
  • JYUSB1601_AI_EnableChannel() : JYUSB1601Core.h
  • JYUSB1601_AI_ExportSampleClock() : JYUSB1601Core.h
  • JYUSB1601_AI_ExportTriggerSignal() : JYUSB1601Core.h
  • JYUSB1601_AI_Finite : JYUSB1601Core.h
  • JYUSB1601_AI_ReadData() : JYUSB1601Core.h
  • JYUSB1601_AI_ReadRawData() : JYUSB1601Core.h
  • JYUSB1601_AI_ReadRawSinglePoint() : JYUSB1601Core.h
  • JYUSB1601_AI_ReadSinglePoint() : JYUSB1601Core.h
  • JYUSB1601_AI_SampleMode : JYUSB1601Core.h
  • JYUSB1601_AI_SendSoftTrigger() : JYUSB1601Core.h
  • JYUSB1601_AI_SetBandwidth() : JYUSB1601Core.h
  • JYUSB1601_AI_SetDigitalStartTrigger() : JYUSB1601Core.h
  • JYUSB1601_AI_SetMode() : JYUSB1601Core.h
  • JYUSB1601_AI_SetSampleClock() : JYUSB1601Core.h
  • JYUSB1601_AI_SetSampleRate() : JYUSB1601Core.h
  • JYUSB1601_AI_SetSamplesToAcquire() : JYUSB1601Core.h
  • JYUSB1601_AI_SetStartTriggerType() : JYUSB1601Core.h
  • JYUSB1601_AI_Single : JYUSB1601Core.h
  • JYUSB1601_AI_Start() : JYUSB1601Core.h
  • JYUSB1601_AI_Stop() : JYUSB1601Core.h
  • JYUSB1601_AO_CheckBufferStatus() : JYUSB1601Core.h
  • JYUSB1601_AO_ContinuousNoWrapping : JYUSB1601Core.h
  • JYUSB1601_AO_ContinuousWrapping : JYUSB1601Core.h
  • JYUSB1601_AO_DisableCalibration() : JYUSB1601Core.h
  • JYUSB1601_AO_EnableChannel() : JYUSB1601Core.h
  • JYUSB1601_AO_ExportSampleClock() : JYUSB1601Core.h
  • JYUSB1601_AO_ExportTriggerSignal() : JYUSB1601Core.h
  • JYUSB1601_AO_Finite : JYUSB1601Core.h
  • JYUSB1601_AO_SendSoftTrigger() : JYUSB1601Core.h
  • JYUSB1601_AO_SetDigitalStartTrigger() : JYUSB1601Core.h
  • JYUSB1601_AO_SetMode() : JYUSB1601Core.h
  • JYUSB1601_AO_SetOutputCompleteState() : JYUSB1601Core.h
  • JYUSB1601_AO_SetSampleClock() : JYUSB1601Core.h
  • JYUSB1601_AO_SetSamplesToUpdate() : JYUSB1601Core.h
  • JYUSB1601_AO_SetStartTriggerType() : JYUSB1601Core.h
  • JYUSB1601_AO_SetUpdateRate() : JYUSB1601Core.h
  • JYUSB1601_AO_Single : JYUSB1601Core.h
  • JYUSB1601_AO_Start() : JYUSB1601Core.h
  • JYUSB1601_AO_Stop() : JYUSB1601Core.h
  • JYUSB1601_AO_UpdateMode : JYUSB1601Core.h
  • JYUSB1601_AO_WaitUntilDone() : JYUSB1601Core.h
  • JYUSB1601_AO_WriteData() : JYUSB1601Core.h
  • JYUSB1601_AO_WriteSinglePoint() : JYUSB1601Core.h
  • JYUSB1601_CI_CheckStatus() : JYUSB1601Core.h
  • JYUSB1601_CI_Count_Down : JYUSB1601Core.h
  • JYUSB1601_CI_Count_Up : JYUSB1601Core.h
  • JYUSB1601_CI_CounterEventSignalIdleState : JYUSB1601Core.h
  • JYUSB1601_CI_CounterEventSignalIdleState_High : JYUSB1601Core.h
  • JYUSB1601_CI_CounterEventSignalIdleState_Low : JYUSB1601Core.h
  • JYUSB1601_CI_EdgeCount : JYUSB1601Core.h
  • JYUSB1601_CI_Encoder_X2 : JYUSB1601Core.h
  • JYUSB1601_CI_Encoder_X4 : JYUSB1601Core.h
  • JYUSB1601_CI_Measure_EdgeSeparation : JYUSB1601Core.h
  • JYUSB1601_CI_Measure_FrequencyOrPeriod : JYUSB1601Core.h
  • JYUSB1601_CI_Measure_PulseWidth : JYUSB1601Core.h
  • JYUSB1601_CI_MeasureType : JYUSB1601Core.h
  • JYUSB1601_CI_ReadSingleCountValue() : JYUSB1601Core.h
  • JYUSB1601_CI_ReadSingleMeasureValue() : JYUSB1601Core.h
  • JYUSB1601_CI_SetCounterParamet() : JYUSB1601Core.h
  • JYUSB1601_CI_SetCounterType() : JYUSB1601Core.h
  • JYUSB1601_CI_SetEdgeCountEvent() : JYUSB1601Core.h
  • JYUSB1601_CI_SetPauseTriggerLevel() : JYUSB1601Core.h
  • JYUSB1601_CI_SetZReloadEnabled() : JYUSB1601Core.h
  • JYUSB1601_CI_Start() : JYUSB1601Core.h
  • JYUSB1601_CI_Stop() : JYUSB1601Core.h
  • JYUSB1601_Close() : JYUSB1601Core.h
  • JYUSB1601_CO_HighLevel : JYUSB1601Core.h
  • JYUSB1601_CO_IdleState : JYUSB1601Core.h
  • JYUSB1601_CO_LowLevel : JYUSB1601Core.h
  • JYUSB1601_CO_SetCounterParamet() : JYUSB1601Core.h
  • JYUSB1601_CO_SetFrequency() : JYUSB1601Core.h
  • JYUSB1601_CO_SetPauseTriggerLevel() : JYUSB1601Core.h
  • JYUSB1601_CO_Start() : JYUSB1601Core.h
  • JYUSB1601_CO_Stop() : JYUSB1601Core.h
  • JYUSB1601_CO_WaitUntilDone() : JYUSB1601Core.h
  • JYUSB1601_CountDirection : JYUSB1601Core.h
  • JYUSB1601_DeviceHandle : JYUSB1601Core.h
  • JYUSB1601_DI_AddLines() : JYUSB1601Core.h
  • JYUSB1601_DI_ReadSinglePoint() : JYUSB1601Core.h
  • JYUSB1601_DI_Start() : JYUSB1601Core.h
  • JYUSB1601_DI_Stop() : JYUSB1601Core.h
  • JYUSB1601_Digital : JYUSB1601Core.h
  • JYUSB1601_DigitalTriggerEdge : JYUSB1601Core.h
  • JYUSB1601_DIO_0 : JYUSB1601Core.h
  • JYUSB1601_DIO_1 : JYUSB1601Core.h
  • JYUSB1601_DIO_10 : JYUSB1601Core.h
  • JYUSB1601_DIO_11 : JYUSB1601Core.h
  • JYUSB1601_DIO_12 : JYUSB1601Core.h
  • JYUSB1601_DIO_13 : JYUSB1601Core.h
  • JYUSB1601_DIO_14 : JYUSB1601Core.h
  • JYUSB1601_DIO_15 : JYUSB1601Core.h
  • JYUSB1601_DIO_2 : JYUSB1601Core.h
  • JYUSB1601_DIO_3 : JYUSB1601Core.h
  • JYUSB1601_DIO_4 : JYUSB1601Core.h
  • JYUSB1601_DIO_5 : JYUSB1601Core.h
  • JYUSB1601_DIO_6 : JYUSB1601Core.h
  • JYUSB1601_DIO_7 : JYUSB1601Core.h
  • JYUSB1601_DIO_8 : JYUSB1601Core.h
  • JYUSB1601_DIO_9 : JYUSB1601Core.h
  • JYUSB1601_DO_AddLines() : JYUSB1601Core.h
  • JYUSB1601_DO_Start() : JYUSB1601Core.h
  • JYUSB1601_DO_Stop() : JYUSB1601Core.h
  • JYUSB1601_DO_WriteSinglePoint() : JYUSB1601Core.h
  • JYUSB1601_ExternalClock : JYUSB1601Core.h
  • JYUSB1601_Falling : JYUSB1601Core.h
  • JYUSB1601_GetDeviceSerialNumber() : JYUSB1601Core.h
  • JYUSB1601_High_Level : JYUSB1601Core.h
  • JYUSB1601_HighLevel : JYUSB1601Core.h
  • JYUSB1601_Hold : JYUSB1601Core.h
  • JYUSB1601_Immediately : JYUSB1601Core.h
  • JYUSB1601_InternalClock : JYUSB1601Core.h
  • JYUSB1601_LevelState : JYUSB1601Core.h
  • JYUSB1601_Low_Level : JYUSB1601Core.h
  • JYUSB1601_LowLevel : JYUSB1601Core.h
  • JYUSB1601_NONE : JYUSB1601Core.h
  • JYUSB1601_Open() : JYUSB1601Core.h
  • JYUSB1601_OpenByName() : JYUSB1601Core.h
  • JYUSB1601_OutputCompleteState : JYUSB1601Core.h
  • JYUSB1601_Rising : JYUSB1601Core.h
  • JYUSB1601_SampleClockSource : JYUSB1601Core.h
  • JYUSB1601_Signal_SrcAndDest : JYUSB1601Core.h
  • JYUSB1601_Soft : JYUSB1601Core.h
  • JYUSB1601_TriggerType : JYUSB1601Core.h
  • JYUSB1601_Zero : JYUSB1601Core.h
  • JYUSB160_AI_Diff : JYUSB1601Core.h
  • JYUSB160_AI_RSE : JYUSB1601Core.h
  • JYUSB160_AI_Terminal : JYUSB1601Core.h


1601 C++ Programming Manual: File Members

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
Here is a list of all macros with links to the files they belong to:
  • EXTERN_C : JYUSB1601Core.h


1601 C++ Programming Manual: File Members

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
Here is a list of all enums with links to the files they belong to:
  • JYUSB1601_AI_Bandwidth : JYUSB1601Core.h
  • JYUSB1601_AI_SampleMode : JYUSB1601Core.h
  • JYUSB1601_AO_UpdateMode : JYUSB1601Core.h
  • JYUSB1601_CI_CounterEventSignalIdleState : JYUSB1601Core.h
  • JYUSB1601_CI_MeasureType : JYUSB1601Core.h
  • JYUSB1601_CO_IdleState : JYUSB1601Core.h
  • JYUSB1601_CountDirection : JYUSB1601Core.h
  • JYUSB1601_DigitalTriggerEdge : JYUSB1601Core.h
  • JYUSB1601_LevelState : JYUSB1601Core.h
  • JYUSB1601_OutputCompleteState : JYUSB1601Core.h
  • JYUSB1601_SampleClockSource : JYUSB1601Core.h
  • JYUSB1601_Signal_SrcAndDest : JYUSB1601Core.h
  • JYUSB1601_TriggerType : JYUSB1601Core.h
  • JYUSB160_AI_Terminal : JYUSB1601Core.h


1601 C++ Programming Manual: File Members

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • j
Here is a list of all enum values with links to the files they belong to:

- j -

  • JYUSB1601_AI_15K : JYUSB1601Core.h
  • JYUSB1601_AI_39K : JYUSB1601Core.h
  • JYUSB1601_AI_80K : JYUSB1601Core.h
  • JYUSB1601_AI_Continuous : JYUSB1601Core.h
  • JYUSB1601_AI_Finite : JYUSB1601Core.h
  • JYUSB1601_AI_Single : JYUSB1601Core.h
  • JYUSB1601_AO_ContinuousNoWrapping : JYUSB1601Core.h
  • JYUSB1601_AO_ContinuousWrapping : JYUSB1601Core.h
  • JYUSB1601_AO_Finite : JYUSB1601Core.h
  • JYUSB1601_AO_Single : JYUSB1601Core.h
  • JYUSB1601_CI_Count_Down : JYUSB1601Core.h
  • JYUSB1601_CI_Count_Up : JYUSB1601Core.h
  • JYUSB1601_CI_CounterEventSignalIdleState_High : JYUSB1601Core.h
  • JYUSB1601_CI_CounterEventSignalIdleState_Low : JYUSB1601Core.h
  • JYUSB1601_CI_EdgeCount : JYUSB1601Core.h
  • JYUSB1601_CI_Encoder_X2 : JYUSB1601Core.h
  • JYUSB1601_CI_Encoder_X4 : JYUSB1601Core.h
  • JYUSB1601_CI_Measure_EdgeSeparation : JYUSB1601Core.h
  • JYUSB1601_CI_Measure_FrequencyOrPeriod : JYUSB1601Core.h
  • JYUSB1601_CI_Measure_PulseWidth : JYUSB1601Core.h
  • JYUSB1601_CO_HighLevel : JYUSB1601Core.h
  • JYUSB1601_CO_LowLevel : JYUSB1601Core.h
  • JYUSB1601_Digital : JYUSB1601Core.h
  • JYUSB1601_DIO_0 : JYUSB1601Core.h
  • JYUSB1601_DIO_1 : JYUSB1601Core.h
  • JYUSB1601_DIO_10 : JYUSB1601Core.h
  • JYUSB1601_DIO_11 : JYUSB1601Core.h
  • JYUSB1601_DIO_12 : JYUSB1601Core.h
  • JYUSB1601_DIO_13 : JYUSB1601Core.h
  • JYUSB1601_DIO_14 : JYUSB1601Core.h
  • JYUSB1601_DIO_15 : JYUSB1601Core.h
  • JYUSB1601_DIO_2 : JYUSB1601Core.h
  • JYUSB1601_DIO_3 : JYUSB1601Core.h
  • JYUSB1601_DIO_4 : JYUSB1601Core.h
  • JYUSB1601_DIO_5 : JYUSB1601Core.h
  • JYUSB1601_DIO_6 : JYUSB1601Core.h
  • JYUSB1601_DIO_7 : JYUSB1601Core.h
  • JYUSB1601_DIO_8 : JYUSB1601Core.h
  • JYUSB1601_DIO_9 : JYUSB1601Core.h
  • JYUSB1601_ExternalClock : JYUSB1601Core.h
  • JYUSB1601_Falling : JYUSB1601Core.h
  • JYUSB1601_High_Level : JYUSB1601Core.h
  • JYUSB1601_HighLevel : JYUSB1601Core.h
  • JYUSB1601_Hold : JYUSB1601Core.h
  • JYUSB1601_Immediately : JYUSB1601Core.h
  • JYUSB1601_InternalClock : JYUSB1601Core.h
  • JYUSB1601_Low_Level : JYUSB1601Core.h
  • JYUSB1601_LowLevel : JYUSB1601Core.h
  • JYUSB1601_NONE : JYUSB1601Core.h
  • JYUSB1601_Rising : JYUSB1601Core.h
  • JYUSB1601_Soft : JYUSB1601Core.h
  • JYUSB1601_Zero : JYUSB1601Core.h
  • JYUSB160_AI_Diff : JYUSB1601Core.h
  • JYUSB160_AI_RSE : JYUSB1601Core.h


1601 C++ Programming Manual: File Members

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • j
Here is a list of all functions with links to the files they belong to:

- j -

  • JYUSB1601_AI_CheckBufferStatus() : JYUSB1601Core.h
  • JYUSB1601_AI_DisableCalibration() : JYUSB1601Core.h
  • JYUSB1601_AI_EnableChannel() : JYUSB1601Core.h
  • JYUSB1601_AI_ExportSampleClock() : JYUSB1601Core.h
  • JYUSB1601_AI_ExportTriggerSignal() : JYUSB1601Core.h
  • JYUSB1601_AI_ReadData() : JYUSB1601Core.h
  • JYUSB1601_AI_ReadRawData() : JYUSB1601Core.h
  • JYUSB1601_AI_ReadRawSinglePoint() : JYUSB1601Core.h
  • JYUSB1601_AI_ReadSinglePoint() : JYUSB1601Core.h
  • JYUSB1601_AI_SendSoftTrigger() : JYUSB1601Core.h
  • JYUSB1601_AI_SetBandwidth() : JYUSB1601Core.h
  • JYUSB1601_AI_SetDigitalStartTrigger() : JYUSB1601Core.h
  • JYUSB1601_AI_SetMode() : JYUSB1601Core.h
  • JYUSB1601_AI_SetSampleClock() : JYUSB1601Core.h
  • JYUSB1601_AI_SetSampleRate() : JYUSB1601Core.h
  • JYUSB1601_AI_SetSamplesToAcquire() : JYUSB1601Core.h
  • JYUSB1601_AI_SetStartTriggerType() : JYUSB1601Core.h
  • JYUSB1601_AI_Start() : JYUSB1601Core.h
  • JYUSB1601_AI_Stop() : JYUSB1601Core.h
  • JYUSB1601_AO_CheckBufferStatus() : JYUSB1601Core.h
  • JYUSB1601_AO_DisableCalibration() : JYUSB1601Core.h
  • JYUSB1601_AO_EnableChannel() : JYUSB1601Core.h
  • JYUSB1601_AO_ExportSampleClock() : JYUSB1601Core.h
  • JYUSB1601_AO_ExportTriggerSignal() : JYUSB1601Core.h
  • JYUSB1601_AO_SendSoftTrigger() : JYUSB1601Core.h
  • JYUSB1601_AO_SetDigitalStartTrigger() : JYUSB1601Core.h
  • JYUSB1601_AO_SetMode() : JYUSB1601Core.h
  • JYUSB1601_AO_SetOutputCompleteState() : JYUSB1601Core.h
  • JYUSB1601_AO_SetSampleClock() : JYUSB1601Core.h
  • JYUSB1601_AO_SetSamplesToUpdate() : JYUSB1601Core.h
  • JYUSB1601_AO_SetStartTriggerType() : JYUSB1601Core.h
  • JYUSB1601_AO_SetUpdateRate() : JYUSB1601Core.h
  • JYUSB1601_AO_Start() : JYUSB1601Core.h
  • JYUSB1601_AO_Stop() : JYUSB1601Core.h
  • JYUSB1601_AO_WaitUntilDone() : JYUSB1601Core.h
  • JYUSB1601_AO_WriteData() : JYUSB1601Core.h
  • JYUSB1601_AO_WriteSinglePoint() : JYUSB1601Core.h
  • JYUSB1601_CI_CheckStatus() : JYUSB1601Core.h
  • JYUSB1601_CI_ReadSingleCountValue() : JYUSB1601Core.h
  • JYUSB1601_CI_ReadSingleMeasureValue() : JYUSB1601Core.h
  • JYUSB1601_CI_SetCounterParamet() : JYUSB1601Core.h
  • JYUSB1601_CI_SetCounterType() : JYUSB1601Core.h
  • JYUSB1601_CI_SetEdgeCountEvent() : JYUSB1601Core.h
  • JYUSB1601_CI_SetPauseTriggerLevel() : JYUSB1601Core.h
  • JYUSB1601_CI_SetZReloadEnabled() : JYUSB1601Core.h
  • JYUSB1601_CI_Start() : JYUSB1601Core.h
  • JYUSB1601_CI_Stop() : JYUSB1601Core.h
  • JYUSB1601_Close() : JYUSB1601Core.h
  • JYUSB1601_CO_SetCounterParamet() : JYUSB1601Core.h
  • JYUSB1601_CO_SetFrequency() : JYUSB1601Core.h
  • JYUSB1601_CO_SetPauseTriggerLevel() : JYUSB1601Core.h
  • JYUSB1601_CO_Start() : JYUSB1601Core.h
  • JYUSB1601_CO_Stop() : JYUSB1601Core.h
  • JYUSB1601_CO_WaitUntilDone() : JYUSB1601Core.h
  • JYUSB1601_DI_AddLines() : JYUSB1601Core.h
  • JYUSB1601_DI_ReadSinglePoint() : JYUSB1601Core.h
  • JYUSB1601_DI_Start() : JYUSB1601Core.h
  • JYUSB1601_DI_Stop() : JYUSB1601Core.h
  • JYUSB1601_DO_AddLines() : JYUSB1601Core.h
  • JYUSB1601_DO_Start() : JYUSB1601Core.h
  • JYUSB1601_DO_Stop() : JYUSB1601Core.h
  • JYUSB1601_DO_WriteSinglePoint() : JYUSB1601Core.h
  • JYUSB1601_GetDeviceSerialNumber() : JYUSB1601Core.h
  • JYUSB1601_Open() : JYUSB1601Core.h
  • JYUSB1601_OpenByName() : JYUSB1601Core.h


1601 C++ Programming Manual: File Members

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
Here is a list of all typedefs with links to the files they belong to:
  • BOOL : JYUSB1601Core.h
  • JYUSB1601_DeviceHandle : JYUSB1601Core.h


1601 C++ Programming Manual: Main Page

1601 C++ Programming Manual Documentation