1601 C# Programming Manual: D:/OneDrive/Desktop/CHM/1601/C#/JYUSB1601AITask.cs File Reference

1601 C# Programming Manual
  • Main Page
  • Packages
  • Classes
  • Files
Classes | Namespaces | Enumerations
JYUSB1601AITask.cs File Reference

Classes

class | JYUSB1601.JYUSB1601AITask
JYUSB1601 Analog Input Task. More...
class | JYUSB1601.AIChannel
AI Channel parameter class . More...
class | JYUSB1601.AISampleClock
Sample clock configuration class. More...
class | JYUSB1601.AIExternalSampleClock
External Sample Clock Configuration Class. More...
class | JYUSB1601.AITrigger
Clock Terminal. More...
class | JYUSB1601.AIDigitalTrigger
AI Digital trigger class. More...
class | JYUSB1601.AIRecord
AI Record Parameters. More...
class | JYUSB1601.AISignalExport
AI Signal Export Class. More...

Namespaces

namespace JYUSB1601

Enumerations

enum | JYUSB1601.AITerminal { JYUSB1601.RSE = 0 , JYUSB1601.Differential = 1 }
AITerminal. More...
enum | JYUSB1601.AIBandwidth { JYUSB1601._39KHz = JYUSB1601Import.JYUSB1601_AI_BandWidth_39K , JYUSB1601._15KHz = JYUSB1601Import.JYUSB1601_AI_BandWidth_15K , JYUSB1601._80KHz = JYUSB1601Import.JYUSB1601_AI_BandWidth_80K }
AI BandWidth. More...
enum | JYUSB1601.AITriggerType { JYUSB1601.Immediate = 0 , JYUSB1601.Digital = 1 , JYUSB1601.Soft = 2 }
Trigger Type Digital/Analog/Immediate/Soft. More...
enum | JYUSB1601.AIDigitalTriggerEdge { JYUSB1601.Rising = 0 , JYUSB1601.Falling = 1 , JYUSB1601.HighLevel = 2 , JYUSB1601.LowLevel = 3 }
AI Digital Trigger Edge. More...
enum | JYUSB1601.AIMode { JYUSB1601.Single = JYUSB1601Import.JYUSB1601_AI_Single , JYUSB1601.Finite = JYUSB1601Import.JYUSB1601_AI_Finite , JYUSB1601.Continuous = JYUSB1601Import.JYUSB1601_AI_Continuous , JYUSB1601.Record = 0x3 }
AIMode. More...
enum | JYUSB1601.AISampleClockSource { JYUSB1601.Internal , JYUSB1601.External }
AI Sample Clock Source. More...
enum JYUSB1601.AIDigitalTriggerSource {
JYUSB1601.DIO_0 = 0 , JYUSB1601.DIO_1 = 1 , JYUSB1601.DIO_2 = 2 , JYUSB1601.DIO_3 = 3 ,
JYUSB1601.DIO_4 = 4 , JYUSB1601.DIO_5 = 5 , JYUSB1601.DIO_6 = 6 , JYUSB1601.DIO_7 = 7 ,
JYUSB1601.DIO_8 = 8 , JYUSB1601.DIO_9 = 9 , JYUSB1601.DIO_10 = 10 , JYUSB1601.DIO_11 = 11 ,
JYUSB1601.DIO_12 = 12 , JYUSB1601.DIO_13 = 13 , JYUSB1601.DIO_14 = 14 , JYUSB1601.DIO_15 = 15
}
Output DestinationTerminal. More...
enum | JYUSB1601.FileFormat { JYUSB1601.Bin }
Streaming file format. More...
enum | JYUSB1601.RecordMode { JYUSB1601.Finite , JYUSB1601.Infinite }
stream mode .enum Finite/Infinite More...
enum JYUSB1601.SignalExportDestination {
JYUSB1601.NONE = -1 , JYUSB1601.DIO_0 = 0 , JYUSB1601.DIO_1 = 1 , JYUSB1601.DIO_2 = 2 ,
JYUSB1601.DIO_3 = 3 , JYUSB1601.DIO_4 = 4 , JYUSB1601.DIO_5 = 5 , JYUSB1601.DIO_6 = 6 ,
JYUSB1601.DIO_7 = 7 , JYUSB1601.DIO_8 = 8 , JYUSB1601.DIO_9 = 9 , JYUSB1601.DIO_10 = 10 ,
JYUSB1601.DIO_11 = 11 , JYUSB1601.DIO_12 = 12 , JYUSB1601.DIO_13 = 13 , JYUSB1601.DIO_14 = 14 ,
JYUSB1601.DIO_15 = 15
}
Output DestinationTerminal. More...
enum | JYUSB1601.AISignalExportSource { JYUSB1601.StartTrig , JYUSB1601.SampleClock }
AI Signal Export Source. More...
Generated by doxygen 1.15.0


1601 C# Programming Manual: D:/OneDrive/Desktop/CHM/1601/C#/JYUSB1601AOTask.cs File Reference

  • Packages
  • Classes
  • Files
Classes | Namespaces | Enumerations
JYUSB1601AOTask.cs File Reference

Classes

class | JYUSB1601.JYUSB1601AOTask
JYUSB1601 Analog Output Task. More...
class | JYUSB1601.AOChannel
AO Channel parameter class. More...
class | JYUSB1601.AOSampleClock
AO Sample clock configuration class. More...
class | JYUSB1601.AOExternalSampleClock
External Sample Clock Configuration Class. More...
class | JYUSB1601.AOTrigger
Constructor to create an AOTrigger task object. More...
class | JYUSB1601.AODigitalTrigger
AO Digital trigger . More...
class | JYUSB1601.AOSignalExport
AO Signal Export Class. More...

Namespaces

namespace JYUSB1601

Enumerations

enum | JYUSB1601.AODigitalTriggerEdge { JYUSB1601.Rising , JYUSB1601.Falling , JYUSB1601.HighLevel = 2 , JYUSB1601.LowLevel = 3 }
AO Digital Trigger Edge. More...
enum | JYUSB1601.OutputCompleteState { JYUSB1601.Zero , JYUSB1601.Hold }
Output Complete State. More...
enum | JYUSB1601.AOMode { JYUSB1601.Single = 3 , JYUSB1601.Finite = 0 , JYUSB1601.ContinuousNoWrapping = 2 , JYUSB1601.ContinuousWrapping = 1 }
AOMode. More...
enum | JYUSB1601.AOSampleClockSource { JYUSB1601.Internal , JYUSB1601.External }
AO Sample Clock Source. More...
enum | JYUSB1601.AOSignalExportSource { JYUSB1601.StartTrig = 0 , JYUSB1601.SampleClock = 1 }
SourceSignal. More...
enum | JYUSB1601.AOTriggerType { JYUSB1601.Immediate = 0 , JYUSB1601.Digital = 1 , JYUSB1601.Soft = 2 }
TriggerType Digital/Immediate/Soft. More...
enum JYUSB1601.AODigitalTriggerSource {
JYUSB1601.DIO_0 = 0 , JYUSB1601.DIO_1 = 1 , JYUSB1601.DIO_2 = 2 , JYUSB1601.DIO_3 = 3 ,
JYUSB1601.DIO_4 = 4 , JYUSB1601.DIO_5 = 5 , JYUSB1601.DIO_6 = 6 , JYUSB1601.DIO_7 = 7 ,
JYUSB1601.DIO_8 = 8 , JYUSB1601.DIO_9 = 9 , JYUSB1601.DIO_10 = 10 , JYUSB1601.DIO_11 = 11 ,
JYUSB1601.DIO_12 = 12 , JYUSB1601.DIO_13 = 13 , JYUSB1601.DIO_14 = 14 , JYUSB1601.DIO_15 = 15
}
Output DestinationTerminal. More...


1601 C# Programming Manual: D:/OneDrive/Desktop/CHM/1601/C#/JYUSB1601CITask.cs File Reference

Classes | Namespaces | Enumerations
JYUSB1601CITask.cs File Reference

Classes

class | JYUSB1601.JYUSB1601CITask
JYUSB1601 Counter Input Task. More...
class | JYUSB1601.EdgeCounting
Configure CI EdgeCounting. More...
class | JYUSB1601.EdgeCountingOutEvent
Edge counting output event configuration class. More...
class | JYUSB1601.PauseTrigger
Pause trigger configuration class. More...
class | JYUSB1601.FrequencyMeas
Configure CI Measure. More...
class | JYUSB1601.PeriodMeas
Configure CI Measure. More...
class | JYUSB1601.PulseMeas
Configure CI Measure. More...
class | JYUSB1601.TwoEdgeSeparation
Configure CI Measure. More...
class | JYUSB1601.QuadEncoder
Configure CI Measure. More...
class | JYUSB1601.TwoPulseEncoder
Configure CI Measure. More...

Namespaces

namespace JYUSB1601

Enumerations

enum | JYUSB1601.CountDirection { JYUSB1601.Up = JYUSB1601Import.JYUSB1601_CI_Count_Up , JYUSB1601.Down = JYUSB1601Import.JYUSB1601_CI_Count_Down }
Counter direction. More...
enum JYUSB1601.CIType {
JYUSB1601.EdgeCounting , JYUSB1601.Period , JYUSB1601.Frequency , JYUSB1601.Pulse ,
JYUSB1601.TwoEdgeSeparation , JYUSB1601.QuadEncoder
}
Counter Input Application Type. More...
enum | JYUSB1601.EdgeType { JYUSB1601.Rising , JYUSB1601.Falling , JYUSB1601.Any }
Edge Type. More...
enum | JYUSB1601.EdgeCntOunEvtIdleState { JYUSB1601.LowLevel = 0 , JYUSB1601.HighLevel = 1 }
Output idle state when the event has not occurred. More...
enum | JYUSB1601.LevelPolarity { JYUSB1601.LowLevel = 0 , JYUSB1601.HighLevel = 1 , JYUSB1601.None = 2 }
Level Polarity. More...
enum | JYUSB1601.QuadEncodingType { JYUSB1601.X2 , JYUSB1601.X4 }
Quadrature Encoding Type. More...


1601 C# Programming Manual: D:/OneDrive/Desktop/CHM/1601/C#/JYUSB1601COTask.cs File Reference

Classes | Namespaces | Enumerations
JYUSB1601COTask.cs File Reference

Classes

class | JYUSB1601.JYUSB1601COTask
JYUSB1601 Counter Output Task. More...
class | JYUSB1601.COPulse
Pulse Parameter. More...

Namespaces

namespace JYUSB1601

Enumerations

enum | JYUSB1601.COIdleState { JYUSB1601.HighLevel = JYUSB1601Import.JYUSB1601_HighLevel , JYUSB1601.LowLevel = JYUSB1601Import.JYUSB1601_LowLevel }
Idle state when pulse output before start and after stop. More...
enum | JYUSB1601.COPulseType { JYUSB1601.DutyCycleFrequency , JYUSB1601.HighLowTime , JYUSB1601.HighLowTick }
Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick. More...


1601 C# Programming Manual: D:/OneDrive/Desktop/CHM/1601/C#/JYUSB1601DITask.cs File Reference

Classes | Namespaces
JYUSB1601DITask.cs File Reference

Classes

class | JYUSB1601.JYUSB1601DITask
JYUSB1601 Digital Iuput Task. More...
class | JYUSB1601.DIChannel
DI Channel parameter class . More...

Namespaces

namespace JYUSB1601


1601 C# Programming Manual: D:/OneDrive/Desktop/CHM/1601/C#/JYUSB1601DOTask.cs File Reference

Classes | Namespaces
JYUSB1601DOTask.cs File Reference

Classes

class | JYUSB1601.JYUSB1601DOTask
JYUSB1601 Digital Output Task. More...
class | JYUSB1601.DOChannel
DO Channel parameter class . More...

Namespaces

namespace JYUSB1601


1601 C# Programming Manual: Class List

  • Class List
  • Class Index
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
N JYUSB1601 |
C JYUSB1601AITask | JYUSB1601 Analog Input Task
C AIChannel | AI Channel parameter class
C AISampleClock | Sample clock configuration class
C AIExternalSampleClock | External Sample Clock Configuration Class
C AITrigger | Clock Terminal
C AIDigitalTrigger | AI Digital trigger class
C AIRecord | AI Record Parameters
C AISignalExport | AI Signal Export Class
C JYUSB1601AOTask | JYUSB1601 Analog Output Task
C AOChannel | AO Channel parameter class
C AOSampleClock | AO Sample clock configuration class
C AOExternalSampleClock | External Sample Clock Configuration Class
C AOTrigger | Constructor to create an AOTrigger task object
C AODigitalTrigger | AO Digital trigger
C AOSignalExport | AO Signal Export Class
C JYUSB1601CITask | JYUSB1601 Counter Input Task
C EdgeCounting | Configure CI EdgeCounting
C EdgeCountingOutEvent | Edge counting output event configuration class
C PauseTrigger | Pause trigger configuration class
C FrequencyMeas | Configure CI Measure
C PeriodMeas | Configure CI Measure
C PulseMeas | Configure CI Measure
C TwoEdgeSeparation | Configure CI Measure
C QuadEncoder | Configure CI Measure
C TwoPulseEncoder | Configure CI Measure
C JYUSB1601COTask | JYUSB1601 Counter Output Task
C COPulse | Pulse Parameter
C JYUSB1601DITask | JYUSB1601 Digital Iuput Task
C DIChannel | DI Channel parameter class
C JYUSB1601DOTask | JYUSB1601 Digital Output Task
C DOChannel | DO Channel parameter class


1601 C# Programming Manual: JYUSB1601.AIChannel Class Reference

  • JYUSB1601
  • AIChannel
Public Member Functions | Properties | List of all members
JYUSB1601.AIChannel Class Referencesealed

AI Channel parameter class . More...

Public Member Functions

AIChannel (int channelId, double rangeLow, double rangeHigh, AITerminal terminalCfg=AITerminal.RSE)
Constructor to create an AIChnParam task object.

Properties

int | ChannelID [get]
AI channel ID.
double | RangeLow [get, set]
Low range limit an AI channel.
double | RangeHigh [get, set]
High range limit an AI channel.
AITerminal | Terminal [get, set]
Configure AI terminal.

Detailed Description

AI Channel parameter class .

Constructor & Destructor Documentation

◆ AIChannel()

JYUSB1601.AIChannel.AIChannel | ( | int | channelId,
 |  | double | rangeLow,
 |  | double | rangeHigh,
 |  | AITerminal | terminalCfg = AITerminal::RSE )

Constructor to create an AIChnParam task object.

Parameters
channelId | AI channel ID.
rangeLow | Low range limit an AI channel.
rangeHigh | High range limit an AI channel.
terminalCfg | Configure AI terminal.

Property Documentation

◆ ChannelID

int JYUSB1601.AIChannel.ChannelID
get

AI channel ID.

◆ RangeHigh

double JYUSB1601.AIChannel.RangeHigh
getset

High range limit an AI channel.

◆ RangeLow

double JYUSB1601.AIChannel.RangeLow
getset

Low range limit an AI channel.

◆ Terminal

AITerminal JYUSB1601.AIChannel.Terminal
getset

Configure AI terminal.

(RSE,Differential)

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/CHM/1601/C#/JYUSB1601AITask.cs


1601 C# Programming Manual: Member List

  • AIChannel
JYUSB1601.AIChannel Member List

This is the complete list of members for JYUSB1601.AIChannel, including all inherited members.

AIChannel(int channelId, double rangeLow, double rangeHigh, AITerminal terminalCfg=AITerminal.RSE) | JYUSB1601.AIChannel
ChannelID | JYUSB1601.AIChannel
RangeHigh | JYUSB1601.AIChannel
RangeLow | JYUSB1601.AIChannel
Terminal | JYUSB1601.AIChannel


1601 C# Programming Manual: JYUSB1601.AIDigitalTrigger Class Reference

  • AIDigitalTrigger
Properties | List of all members
JYUSB1601.AIDigitalTrigger Class Referencesealed

AI Digital trigger class. More...

Properties

AIDigitalTriggerEdge | Edge [get, set]
Digital Trigger edge，Rising/Falling.
AIDigitalTriggerSource | Source [get, set]
Digital Trigger Source.

Detailed Description

AI Digital trigger class.

Property Documentation

◆ Edge

AIDigitalTriggerEdge JYUSB1601.AIDigitalTrigger.Edge
getset

Digital Trigger edge，Rising/Falling.

◆ Source

AIDigitalTriggerSource JYUSB1601.AIDigitalTrigger.Source
getset

Digital Trigger Source.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/CHM/1601/C#/JYUSB1601AITask.cs


1601 C# Programming Manual: Member List

  • AIDigitalTrigger
JYUSB1601.AIDigitalTrigger Member List

This is the complete list of members for JYUSB1601.AIDigitalTrigger, including all inherited members.

Edge | JYUSB1601.AIDigitalTrigger
Source | JYUSB1601.AIDigitalTrigger


1601 C# Programming Manual: JYUSB1601.AIExternalSampleClock Class Reference

  • AIExternalSampleClock
Properties | List of all members
JYUSB1601.AIExternalSampleClock Class Reference

External Sample Clock Configuration Class. More...

Properties

double ExpectedRate [get, set]
Expected External Sample Clock Rate.

Detailed Description

External Sample Clock Configuration Class.

Property Documentation

◆ ExpectedRate

double JYUSB1601.AIExternalSampleClock.ExpectedRate
getset

Expected External Sample Clock Rate.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/CHM/1601/C#/JYUSB1601AITask.cs


1601 C# Programming Manual: Member List

  • AIExternalSampleClock
JYUSB1601.AIExternalSampleClock Member List

This is the complete list of members for JYUSB1601.AIExternalSampleClock, including all inherited members.

ExpectedRate JYUSB1601.AIExternalSampleClock


1601 C# Programming Manual: JYUSB1601.AIRecord Class Reference

  • AIRecord
Properties | List of all members
JYUSB1601.AIRecord Class Referencesealed

AI Record Parameters. More...

Properties

string | FilePath [get, set]
User specified file path.
FileFormat | FileFormat [get]
Streaming file format.
RecordMode | Mode [get, set]
stream mode .
double | Length [get, set]
User specified stream length in second.

Detailed Description

AI Record Parameters.

Property Documentation

◆ FileFormat

FileFormat JYUSB1601.AIRecord.FileFormat
get

Streaming file format.

enum BIN.

◆ FilePath

string JYUSB1601.AIRecord.FilePath
getset

User specified file path.

◆ Length

double JYUSB1601.AIRecord.Length
getset

User specified stream length in second.

Only when Mode is RecordMode.Finite.

◆ Mode

RecordMode JYUSB1601.AIRecord.Mode
getset

stream mode .

enum Finite/Infinite.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/CHM/1601/C#/JYUSB1601AITask.cs


1601 C# Programming Manual: Member List

  • AIRecord
JYUSB1601.AIRecord Member List

This is the complete list of members for JYUSB1601.AIRecord, including all inherited members.

FileFormat | JYUSB1601.AIRecord
FilePath | JYUSB1601.AIRecord
Length | JYUSB1601.AIRecord
Mode | JYUSB1601.AIRecord


1601 C# Programming Manual: JYUSB1601.AISampleClock Class Reference

  • AISampleClock
Properties | List of all members
JYUSB1601.AISampleClock Class Reference

Sample clock configuration class. More...

Properties

AISampleClockSource | Source [get, set]
AI Sample Clock Source.
AIExternalSampleClock | External [get, set]
External Sample Clock Configuration.

Detailed Description

Sample clock configuration class.

Property Documentation

◆ External

AIExternalSampleClock JYUSB1601.AISampleClock.External
getset

External Sample Clock Configuration.

Valid when Source is AISampleClockSource.External.

◆ Source

AISampleClockSource JYUSB1601.AISampleClock.Source
getset

AI Sample Clock Source.

enum Internal/External. The default value is AISampleClockSource.Internal.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/CHM/1601/C#/JYUSB1601AITask.cs


1601 C# Programming Manual: Member List

  • AISampleClock
JYUSB1601.AISampleClock Member List

This is the complete list of members for JYUSB1601.AISampleClock, including all inherited members.

External | JYUSB1601.AISampleClock
Source | JYUSB1601.AISampleClock


1601 C# Programming Manual: JYUSB1601.AISignalExport Class Reference

  • AISignalExport
Public Member Functions | List of all members
JYUSB1601.AISignalExport Class Reference

AI Signal Export Class. More...

Public Member Functions

void | Add (AISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (AISignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

AI Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JYUSB1601.AISignalExport.Add | ( | AISignalExportSource | source,
 |  | List< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | AI Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JYUSB1601.AISignalExport.Add | ( | AISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | AI Signal Source
destination | Export Desination

◆ Clear()

void JYUSB1601.AISignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JYUSB1601.AISignalExport.ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/CHM/1601/C#/JYUSB1601AITask.cs


1601 C# Programming Manual: Member List

  • AISignalExport
JYUSB1601.AISignalExport Member List

This is the complete list of members for JYUSB1601.AISignalExport, including all inherited members.

Add(AISignalExportSource source, SignalExportDestination destination) | JYUSB1601.AISignalExport
Add(AISignalExportSource source, List< SignalExportDestination > destinations) | JYUSB1601.AISignalExport
Clear(SignalExportDestination destination) | JYUSB1601.AISignalExport
ClearAll() | JYUSB1601.AISignalExport


1601 C# Programming Manual: JYUSB1601.AITrigger Class Reference

  • AITrigger
Properties | List of all members
JYUSB1601.AITrigger Class Referencesealed

Clock Terminal. More...

Properties

AITriggerType | Type [get, set]
AI trigger type.
AIDigitalTrigger | Digital [get, set]
Digital Trigger Congfiguration.

Detailed Description

Clock Terminal.

Constructor to create an AITrigger task object. Used to build AI Trigger

Property Documentation

◆ Digital

AIDigitalTrigger JYUSB1601.AITrigger.Digital
getset

Digital Trigger Congfiguration.

Valid when Type is AITriggerType.Digital.

◆ Type

AITriggerType JYUSB1601.AITrigger.Type
getset

AI trigger type.

enum Analog/Digital/Immediate/Soft. The default value is AITriggerType.Immediate.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/CHM/1601/C#/JYUSB1601AITask.cs


1601 C# Programming Manual: Member List

  • AITrigger
JYUSB1601.AITrigger Member List

This is the complete list of members for JYUSB1601.AITrigger, including all inherited members.

Digital | JYUSB1601.AITrigger
Type | JYUSB1601.AITrigger


1601 C# Programming Manual: JYUSB1601.AOChannel Class Reference

  • AOChannel
Properties | List of all members
JYUSB1601.AOChannel Class Referencesealed

AO Channel parameter class. More...

Properties

int ChannelID [get]
AO channel ID.

Detailed Description

AO Channel parameter class.

Property Documentation

◆ ChannelID

int JYUSB1601.AOChannel.ChannelID
get

AO channel ID.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/CHM/1601/C#/JYUSB1601AOTask.cs


1601 C# Programming Manual: Member List

  • AOChannel
JYUSB1601.AOChannel Member List

This is the complete list of members for JYUSB1601.AOChannel, including all inherited members.

ChannelID JYUSB1601.AOChannel


1601 C# Programming Manual: JYUSB1601.AODigitalTrigger Class Reference

  • AODigitalTrigger
Properties | List of all members
JYUSB1601.AODigitalTrigger Class Referencesealed

AO Digital trigger . More...

Properties

AODigitalTriggerSource | Source [get, set]
AO Digital Trigger source.
AODigitalTriggerEdge | Edge [get, set]
Digital Trigger edge，Rising/Falling.

Detailed Description

AO Digital trigger .

Property Documentation

◆ Edge

AODigitalTriggerEdge JYUSB1601.AODigitalTrigger.Edge
getset

Digital Trigger edge，Rising/Falling.

◆ Source

AODigitalTriggerSource JYUSB1601.AODigitalTrigger.Source
getset

AO Digital Trigger source.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/CHM/1601/C#/JYUSB1601AOTask.cs


1601 C# Programming Manual: Member List

  • AODigitalTrigger
JYUSB1601.AODigitalTrigger Member List

This is the complete list of members for JYUSB1601.AODigitalTrigger, including all inherited members.

Edge | JYUSB1601.AODigitalTrigger
Source | JYUSB1601.AODigitalTrigger


1601 C# Programming Manual: JYUSB1601.AOExternalSampleClock Class Reference

  • AOExternalSampleClock
Properties | List of all members
JYUSB1601.AOExternalSampleClock Class Reference

External Sample Clock Configuration Class. More...

Properties

double ExpectedRate [get, set]
Expected External Sample Clock Rate.

Detailed Description

External Sample Clock Configuration Class.

Property Documentation

◆ ExpectedRate

double JYUSB1601.AOExternalSampleClock.ExpectedRate
getset

Expected External Sample Clock Rate.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/CHM/1601/C#/JYUSB1601AOTask.cs


1601 C# Programming Manual: Member List

  • AOExternalSampleClock
JYUSB1601.AOExternalSampleClock Member List

This is the complete list of members for JYUSB1601.AOExternalSampleClock, including all inherited members.

ExpectedRate JYUSB1601.AOExternalSampleClock


1601 C# Programming Manual: JYUSB1601.AOSampleClock Class Reference

  • AOSampleClock
Properties | List of all members
JYUSB1601.AOSampleClock Class Reference

AO Sample clock configuration class. More...

Properties

AOSampleClockSource | Source [get, set]
Clock Source.
AOExternalSampleClock | External [get, set]
External Sample Clock Configuration,Valid when Source is AOSampleClockSource.External.

Detailed Description

AO Sample clock configuration class.

Property Documentation

◆ External

AOExternalSampleClock JYUSB1601.AOSampleClock.External
getset

External Sample Clock Configuration,Valid when Source is AOSampleClockSource.External.

◆ Source

AOSampleClockSource JYUSB1601.AOSampleClock.Source
getset

Clock Source.

enum Internal/External,The default value is AOSampleClockSource.Internal.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/CHM/1601/C#/JYUSB1601AOTask.cs


1601 C# Programming Manual: Member List

  • AOSampleClock
JYUSB1601.AOSampleClock Member List

This is the complete list of members for JYUSB1601.AOSampleClock, including all inherited members.

External | JYUSB1601.AOSampleClock
Source | JYUSB1601.AOSampleClock


1601 C# Programming Manual: JYUSB1601.AOSignalExport Class Reference

  • AOSignalExport
Public Member Functions | List of all members
JYUSB1601.AOSignalExport Class Reference

AO Signal Export Class. More...

Public Member Functions

void | Add (AOSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (AOSignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

AO Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JYUSB1601.AOSignalExport.Add | ( | AOSignalExportSource | source,
 |  | List< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | AO Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JYUSB1601.AOSignalExport.Add | ( | AOSignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | AO Signal Source
destination | Export Desination

◆ Clear()

void JYUSB1601.AOSignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JYUSB1601.AOSignalExport.ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/CHM/1601/C#/JYUSB1601AOTask.cs


1601 C# Programming Manual: Member List

  • AOSignalExport
JYUSB1601.AOSignalExport Member List

This is the complete list of members for JYUSB1601.AOSignalExport, including all inherited members.

Add(AOSignalExportSource source, SignalExportDestination destination) | JYUSB1601.AOSignalExport
Add(AOSignalExportSource source, List< SignalExportDestination > destinations) | JYUSB1601.AOSignalExport
Clear(SignalExportDestination destination) | JYUSB1601.AOSignalExport
ClearAll() | JYUSB1601.AOSignalExport


1601 C# Programming Manual: JYUSB1601.AOTrigger Class Reference

  • AOTrigger
Properties | List of all members
JYUSB1601.AOTrigger Class Referencesealed

Constructor to create an AOTrigger task object. More...

Properties

AOTriggerType | Type [get, set]
AO trigger type.
AODigitalTrigger | Digital [get, set]
AO Digital Trigger.

Detailed Description

Constructor to create an AOTrigger task object.

Used to build AO Trigger

Property Documentation

◆ Digital

AODigitalTrigger JYUSB1601.AOTrigger.Digital
getset

AO Digital Trigger.

Valid when Type is AOTriggerType.Digital.

◆ Type

AOTriggerType JYUSB1601.AOTrigger.Type
getset

AO trigger type.

enum Immediate/Digital/Soft.The default value is AOTriggerType.Immediate.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/CHM/1601/C#/JYUSB1601AOTask.cs


1601 C# Programming Manual: Member List

  • AOTrigger
JYUSB1601.AOTrigger Member List

This is the complete list of members for JYUSB1601.AOTrigger, including all inherited members.

Digital | JYUSB1601.AOTrigger
Type | JYUSB1601.AOTrigger


1601 C# Programming Manual: JYUSB1601.COPulse Class Reference

  • COPulse
Public Member Functions | List of all members
JYUSB1601.COPulse Class Reference

Pulse Parameter. More...

Public Member Functions

COPulse (COPulseType type, double param1, double param2, int count)
Pulse Parameter.

Detailed Description

Pulse Parameter.

Constructor & Destructor Documentation

◆ COPulse()

JYUSB1601.COPulse.COPulse | ( | COPulseType | type,
 |  | double | param1,
 |  | double | param2,
 |  | int | count )

Pulse Parameter.

Parameters
type | The pulse type characteristics.
param1 | Parameter 1. Frequency (Hz) when constructed as COPulseType.DutyCycleFrequency; High duration in seconds when constructed as COPulseType.HighLowTime; High ticks of the clock when constructed as COPulseType.HighLowTick.
param2 | Parameter 1. Duty cycle (greater than 0 and less than 1) when constructed as COPulseType.DutyCycleFrequency; Low duration in seconds when constructed as COPulseType.HighLowTime; Low ticks of the clock when constructed as COPulseType.HighLowTick.
count | Number of pulses. When the value is -1 (indicating that the number of pulses is infinite), pulses will be continuously sent until requested to stop.
The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/CHM/1601/C#/JYUSB1601COTask.cs


1601 C# Programming Manual: Member List

  • COPulse
JYUSB1601.COPulse Member List

This is the complete list of members for JYUSB1601.COPulse, including all inherited members.

COPulse(COPulseType type, double param1, double param2, int count) JYUSB1601.COPulse


1601 C# Programming Manual: JYUSB1601.DIChannel Class Reference

  • DIChannel
Properties | List of all members
JYUSB1601.DIChannel Class Referencesealed

DI Channel parameter class . More...

Properties

int LineNum [get, set]
port number.

Detailed Description

DI Channel parameter class .

Property Documentation

◆ LineNum

int JYUSB1601.DIChannel.LineNum
getset

port number.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/CHM/1601/C#/JYUSB1601DITask.cs


1601 C# Programming Manual: Member List

  • DIChannel
JYUSB1601.DIChannel Member List

This is the complete list of members for JYUSB1601.DIChannel, including all inherited members.

LineNum JYUSB1601.DIChannel


1601 C# Programming Manual: JYUSB1601.DOChannel Class Reference

  • DOChannel
Properties | List of all members
JYUSB1601.DOChannel Class Referencesealed

DO Channel parameter class . More...

Properties

int LineNum [get, set]
port number.

Detailed Description

DO Channel parameter class .

Property Documentation

◆ LineNum

int JYUSB1601.DOChannel.LineNum
getset

port number.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/CHM/1601/C#/JYUSB1601DOTask.cs


1601 C# Programming Manual: Member List

  • DOChannel
JYUSB1601.DOChannel Member List

This is the complete list of members for JYUSB1601.DOChannel, including all inherited members.

LineNum JYUSB1601.DOChannel


1601 C# Programming Manual: JYUSB1601.EdgeCounting Class Reference

  • EdgeCounting
Properties | List of all members
JYUSB1601.EdgeCounting Class Referencesealed

Configure CI EdgeCounting. More...

Properties

int | InitialCount [get, set]
Initial Count.
CountDirection | Direction [get, set]
Counter direction.
PauseTrigger | Pause [get, set]
Pause Trigger Configuration.
EdgeCountingOutEvent | OutEvent [get, set]
Edge counting output event.

Detailed Description

Configure CI EdgeCounting.

Property Documentation

◆ Direction

CountDirection JYUSB1601.EdgeCounting.Direction
getset

Counter direction.

enum Up/Down/External

◆ InitialCount

int JYUSB1601.EdgeCounting.InitialCount
getset

Initial Count.

◆ OutEvent

EdgeCountingOutEvent JYUSB1601.EdgeCounting.OutEvent
getset

Edge counting output event.

A pulse will be generated when the count value reaches specified threshold

◆ Pause

PauseTrigger JYUSB1601.EdgeCounting.Pause
getset

Pause Trigger Configuration.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/CHM/1601/C#/JYUSB1601CITask.cs


1601 C# Programming Manual: Member List

  • EdgeCounting
JYUSB1601.EdgeCounting Member List

This is the complete list of members for JYUSB1601.EdgeCounting, including all inherited members.

Direction | JYUSB1601.EdgeCounting
InitialCount | JYUSB1601.EdgeCounting
OutEvent | JYUSB1601.EdgeCounting
Pause | JYUSB1601.EdgeCounting


1601 C# Programming Manual: JYUSB1601.EdgeCountingOutEvent Class Reference

  • EdgeCountingOutEvent
Properties | List of all members
JYUSB1601.EdgeCountingOutEvent Class Reference

Edge counting output event configuration class. More...

Properties

EdgeCntOunEvtIdleState | IdleState [get, set]
Output idle state when the event has not occurred.
uint | Threshold [get, set]
Comparison threshold.

Detailed Description

Edge counting output event configuration class.

Property Documentation

◆ IdleState

EdgeCntOunEvtIdleState JYUSB1601.EdgeCountingOutEvent.IdleState
getset

Output idle state when the event has not occurred.

The default value is EdgeCntOunEvtIdleState.LowLevel

◆ Threshold

uint JYUSB1601.EdgeCountingOutEvent.Threshold
getset

Comparison threshold.

The default value is 2^32-1

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/CHM/1601/C#/JYUSB1601CITask.cs


1601 C# Programming Manual: Member List

  • EdgeCountingOutEvent
JYUSB1601.EdgeCountingOutEvent Member List

This is the complete list of members for JYUSB1601.EdgeCountingOutEvent, including all inherited members.

IdleState | JYUSB1601.EdgeCountingOutEvent
Threshold | JYUSB1601.EdgeCountingOutEvent


1601 C# Programming Manual: JYUSB1601.FrequencyMeas Class Reference

  • FrequencyMeas
List of all members
JYUSB1601.FrequencyMeas Class Referencesealed

Configure CI Measure. More...

Detailed Description

Configure CI Measure.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/CHM/1601/C#/JYUSB1601CITask.cs


1601 C# Programming Manual: Member List

  • FrequencyMeas
JYUSB1601.FrequencyMeas Member List

This is the complete list of members for JYUSB1601.FrequencyMeas, including all inherited members.


1601 C# Programming Manual: JYUSB1601.JYUSB1601AITask Class Reference

  • JYUSB1601AITask
Public Member Functions | Properties | List of all members
JYUSB1601.JYUSB1601AITask Class Referencesealed

JYUSB1601 Analog Input Task. More...

Public Member Functions

JYUSB1601AITask ()
Constructor, Used to create an AI task by a slot number.
JYUSB1601AITask (string boardName)
Constructor.
void | AddChannel (int chnId, double rangeLow=-10, double rangeHigh=10, AITerminal terminalCfg=AITerminal.RSE)
Add one channel.
void | AddChannel (int[] chnsId, double rangeLow=-10, double rangeHigh=10, AITerminal terminalCfg=AITerminal.RSE)
Add a group of channels.
void | AddChannel (int[] chnsId, double[] rangeLow, double[] rangeHigh, AITerminal terminalCfg=AITerminal.RSE)
Add a group of channels.
void | RemoveChannel (int chnId)
Delete the specified channel number.
void | ReadData (IntPtr buf, int samplesPerChannel, int timeout)
Read one or multi-channel data by columns and store it in a data buffer.
void | ReadData (ref double[,] buf, int samplesPerChannel, int timeout)
Read the multi-channel data by columns and store it in a data buffer.
void | ReadData (ref double[,] buf, int timeout=-1)
Read the multi-channel data by columns and store it in a data buffer.
void | ReadData (ref double[] buf, int samplesPerChannel, int timeout)
Read the one channel data and store it in a data buffer.
void | ReadData (ref double[] buf, int timeout=-1)
Read the one channel data and store it in a data buffer.
void | ReadRawData (IntPtr buf, int samplesPerChannel, int timeout)
Read one or multi-channel raw data by columns and store it in a data buffer.
void | ReadRawData (ref short[,] buf, int samplesPerChannel, int timeout)
Read the multi-channel raw data by columns and store it in a data buffer.
void | ReadRawData (ref short[,] buf, int timeout=-1)
Read the multi-channel raw data by columns and store it in a data buffer.
void | ReadRawData (ref short[] buf, int samplesPerChannel, int timeout)
Read the one channel raw data and store it in a data buffer.
void | ReadRawData (ref short[] buf, int timeout=-1)
Read the one channel raw data and store it in a data buffer.
void | GetRecordPreviewData (ref double[,] buf, int samplesPerChannel, int timeout)
Preview multi-channel data when streaming is in progress.
void | GetRecordPreviewData (ref double[,] buf, int timeout=-1)
Preview multi-channel data when streaming is in progress.
void | GetRecordPreviewData (ref double[] buf, int samplesPerChannel, int timeout)
Preview one channel data when streaming is in progress.
void | GetRecordPreviewData (ref double[] buf, int timeout=-1)
Preview one channel data when streaming is in progress.
void | ReadSinglePoint (ref double[] readValues)
Read one sample for all channels in register .
void | ReadSinglePoint (ref double readValue, int channel)
Read one sample for specified channel in register.
void | ReadRawSinglePoint (ref short[] readValues)
Read one raw sample for all channels in register .
void | ReadRawSinglePoint (ref short readValue, int channel)
Read one raw sample for specified channel in register.
void | GetRecordStatus (out double recordedLength, out bool recordDone)
get the streaming status.
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.
void | Start ()
Start AI task .
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Stop ()
Stop AI task .

Properties

List< AIChannel > | Channels [get]
List of AI channels,(1601 support 16 SE channel).
AIMode | Mode [get, set]
AI acquisition mode，support Single/Finite/Continuous/Record.
double | SampleRate [get, set]
Sample rate per channel.
int | SamplesToAcquire [get, set]
Number of samples to be read per channel.
int | BufLenInSamples [get]
Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.
ulong | AvailableSamples [get]
Number of samples per channel that can be read in the buffer .
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel).
AISampleClock | SampleClock [get, set]
AI Sample Clock Configuration.
AITrigger | Trigger [get, set]
AI Trigger Configuration.
AIBandwidth | Bandwidth [get, set]
AI Bandwidth.defalut: 80KHz.
AIRecord | Record = new AIRecord() [get]
ai Data streaming Configuration
AISignalExport | SignalExport [get, set]
Export AI Signal Configuration.
JYUSB1601Device | Device [get]
Device.

Detailed Description

JYUSB1601 Analog Input Task.

Constructor & Destructor Documentation

◆ JYUSB1601AITask() [1/2]

JYUSB1601.JYUSB1601AITask.JYUSB1601AITask ( )

Constructor, Used to create an AI task by a slot number.

◆ JYUSB1601AITask() [2/2]

JYUSB1601.JYUSB1601AITask.JYUSB1601AITask ( string boardName )

Constructor.

Used to create an AI task by a board name.

Parameters
boardName Board name(device alias), set by device manager

Member Function Documentation

◆ AddChannel() [1/3]

void JYUSB1601.JYUSB1601AITask.AddChannel | ( | int | chnId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10,
 |  | AITerminal | terminalCfg = AITerminal::RSE )

Add one channel.

Parameters
chnId | channel's physical number ，chnId=-1, add all channels。
rangeLow | lower range limit for the channel，-10V,-5V defalut -10
rangeHigh | higher range limit for the channel，10V,5V defalut 10
terminalCfg | terminal input mode configuration，RSE/Differential.Default RSE

◆ AddChannel() [2/3]

void JYUSB1601.JYUSB1601AITask.AddChannel | ( | int[] | chnsId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10,
 |  | AITerminal | terminalCfg = AITerminal::RSE )

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers
rangeLow | lower range limit for the channel，-10V,-5V defalut -10
rangeHigh | higher range limit for the channel，10V,5V defalut 10
terminalCfg | terminal input mode configuration，RSE/Differential.Default RSE

◆ AddChannel() [3/3]

void JYUSB1601.JYUSB1601AITask.AddChannel | ( | int[] | chnsId,
 |  | double[] | rangeLow,
 |  | double[] | rangeHigh,
 |  | AITerminal | terminalCfg = AITerminal::RSE )

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers
rangeLow | lower range limit for the channel，-10V,-5V
rangeHigh | higher range limit for the channel，10V,5V
terminalCfg | terminal input mode configuration，RSE/Differential.Default RSE

◆ GetRecordPreviewData() [1/4]

void JYUSB1601.JYUSB1601AITask.GetRecordPreviewData | ( | ref double | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout )

Preview multi-channel data when streaming is in progress.

Each column represents one channel.

Parameters
buf | Data buffer
samplesPerChannel | Number of preview samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ GetRecordPreviewData() [2/4]

void JYUSB1601.JYUSB1601AITask.GetRecordPreviewData | ( | ref double | buf[,],
 |  | int | timeout = -1 )

Preview multi-channel data when streaming is in progress.

Each column represents one channel.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ GetRecordPreviewData() [3/4]

void JYUSB1601.JYUSB1601AITask.GetRecordPreviewData | ( | ref double[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Preview one channel data when streaming is in progress.

Parameters
buf | Data buffer
samplesPerChannel | Number of preview samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ GetRecordPreviewData() [4/4]

void JYUSB1601.JYUSB1601AITask.GetRecordPreviewData | ( | ref double[] | buf,
 |  | int | timeout = -1 )

Preview one channel data when streaming is in progress.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ GetRecordStatus()

void JYUSB1601.JYUSB1601AITask.GetRecordStatus | ( | out double | recordedLength,
 |  | out bool | recordDone )

get the streaming status.

Available when Mode is AIMode.Record

Parameters
recordedLength | Length of the streamed
recordDone | recordDone = false :streaming is not over.recordDone = true :streaming is over.

◆ ReadData() [1/5]

void JYUSB1601.JYUSB1601AITask.ReadData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read one or multi-channel data by columns and store it in a data buffer.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel to read
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadData() [2/5]

void JYUSB1601.JYUSB1601AITask.ReadData | ( | ref double | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read the multi-channel data by columns and store it in a data buffer.

Each channel is represented by one column of data.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel to read
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadData() [3/5]

void JYUSB1601.JYUSB1601AITask.ReadData | ( | ref double | buf[,],
 |  | int | timeout = -1 )

Read the multi-channel data by columns and store it in a data buffer.

Each channel is represented by one column of data.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadData() [4/5]

void JYUSB1601.JYUSB1601AITask.ReadData | ( | ref double[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read the one channel data and store it in a data buffer.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel to read
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadData() [5/5]

void JYUSB1601.JYUSB1601AITask.ReadData | ( | ref double[] | buf,
 |  | int | timeout = -1 )

Read the one channel data and store it in a data buffer.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadRawData() [1/5]

void JYUSB1601.JYUSB1601AITask.ReadRawData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read one or multi-channel raw data by columns and store it in a data buffer.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel to read
timeout | timeout before generating error message, uint is ms。, timeout =-1 keep waiting until finish.

◆ ReadRawData() [2/5]

void JYUSB1601.JYUSB1601AITask.ReadRawData | ( | ref short | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read the multi-channel raw data by columns and store it in a data buffer.

Each channel is represented by one column of data.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel to read
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadRawData() [3/5]

void JYUSB1601.JYUSB1601AITask.ReadRawData | ( | ref short | buf[,],
 |  | int | timeout = -1 )

Read the multi-channel raw data by columns and store it in a data buffer.

Each channel is represented by one column of data.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadRawData() [4/5]

void JYUSB1601.JYUSB1601AITask.ReadRawData | ( | ref short[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read the one channel raw data and store it in a data buffer.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel to read
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadRawData() [5/5]

void JYUSB1601.JYUSB1601AITask.ReadRawData | ( | ref short[] | buf,
 |  | int | timeout = -1 )

Read the one channel raw data and store it in a data buffer.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadRawSinglePoint() [1/2]

void JYUSB1601.JYUSB1601AITask.ReadRawSinglePoint | ( | ref short | readValue,
 |  | int | channel )

Read one raw sample for specified channel in register.

Available when Mode is AIMode.Single

Parameters
readValue | value read
channel | Specified channel numbers.

◆ ReadRawSinglePoint() [2/2]

void JYUSB1601.JYUSB1601AITask.ReadRawSinglePoint ( ref short[] readValues )

Read one raw sample for all channels in register .

Available when Mode is AIMode.Single

Parameters
readValues Values read. Array length >= Channels.Count.

◆ ReadSinglePoint() [1/2]

void JYUSB1601.JYUSB1601AITask.ReadSinglePoint | ( | ref double | readValue,
 |  | int | channel )

Read one sample for specified channel in register.

Available when Mode is AIMode.Single

Parameters
readValue | value read
channel | Specified channel numbers.

◆ ReadSinglePoint() [2/2]

void JYUSB1601.JYUSB1601AITask.ReadSinglePoint ( ref double[] readValues )

Read one sample for all channels in register .

Available when Mode is AIMode.Single

Parameters
readValues Values read. Array length >= Channels.Count.

◆ RemoveChannel()

void JYUSB1601.JYUSB1601AITask.RemoveChannel ( int chnId )

Delete the specified channel number.

If it is -1, delete all channels.

Parameters
chnId Specified channel ID.

◆ SendSoftwareTrigger()

void JYUSB1601.JYUSB1601AITask.SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JYUSB1601.JYUSB1601AITask.Start ( )

Start AI task .

◆ Stop()

void JYUSB1601.JYUSB1601AITask.Stop ( )

Stop AI task .

◆ WaitUntilDone()

bool JYUSB1601.JYUSB1601AITask.WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

Property Documentation

◆ AvailableSamples

ulong JYUSB1601.JYUSB1601AITask.AvailableSamples
get

Number of samples per channel that can be read in the buffer .

Valid when Mode is NOT AIMode.Single.

◆ Bandwidth

AIBandwidth JYUSB1601.JYUSB1601AITask.Bandwidth
getset

AI Bandwidth.defalut: 80KHz.

◆ BufLenInSamples

int JYUSB1601.JYUSB1601AITask.BufLenInSamples
get

Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.

◆ Channels

List<AIChannel> JYUSB1601.JYUSB1601AITask.Channels
get

List of AI channels,(1601 support 16 SE channel).

◆ Device

JYUSB1601Device JYUSB1601.JYUSB1601AITask.Device
get

Device.

◆ Mode

AIMode JYUSB1601.JYUSB1601AITask.Mode
getset

AI acquisition mode，support Single/Finite/Continuous/Record.

◆ Record

AIRecord JYUSB1601.JYUSB1601AITask.Record = new AIRecord()
get

ai Data streaming Configuration

◆ SampleClock

AISampleClock JYUSB1601.JYUSB1601AITask.SampleClock
getset

AI Sample Clock Configuration.

◆ SampleRate

double JYUSB1601.JYUSB1601AITask.SampleRate
getset

Sample rate per channel.

Maximum sample rate is 250K for single channel, 250K/N for multichannel (N) The defalut sample rate = 10k You can read this property to obtain the sample rate that will actually take effect in the current configuration.

◆ SamplesToAcquire

int JYUSB1601.JYUSB1601AITask.SamplesToAcquire
getset

Number of samples to be read per channel.

Only valid when Mode is AIMode.Finite.

◆ SignalExport

AISignalExport JYUSB1601.JYUSB1601AITask.SignalExport
getset

Export AI Signal Configuration.

◆ TransferedSamples

ulong JYUSB1601.JYUSB1601AITask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT AIMode.Single.

◆ Trigger

AITrigger JYUSB1601.JYUSB1601AITask.Trigger
getset

AI Trigger Configuration.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/CHM/1601/C#/JYUSB1601AITask.cs


1601 C# Programming Manual: Member List

  • JYUSB1601AITask
JYUSB1601.JYUSB1601AITask Member List

This is the complete list of members for JYUSB1601.JYUSB1601AITask, including all inherited members.

AddChannel(int chnId, double rangeLow=-10, double rangeHigh=10, AITerminal terminalCfg=AITerminal.RSE) | JYUSB1601.JYUSB1601AITask
AddChannel(int[] chnsId, double rangeLow=-10, double rangeHigh=10, AITerminal terminalCfg=AITerminal.RSE) | JYUSB1601.JYUSB1601AITask
AddChannel(int[] chnsId, double[] rangeLow, double[] rangeHigh, AITerminal terminalCfg=AITerminal.RSE) | JYUSB1601.JYUSB1601AITask
AvailableSamples | JYUSB1601.JYUSB1601AITask
Bandwidth | JYUSB1601.JYUSB1601AITask
BufLenInSamples | JYUSB1601.JYUSB1601AITask
Channels | JYUSB1601.JYUSB1601AITask
Device | JYUSB1601.JYUSB1601AITask
GetRecordPreviewData(ref double[,] buf, int samplesPerChannel, int timeout) | JYUSB1601.JYUSB1601AITask
GetRecordPreviewData(ref double[,] buf, int timeout=-1) | JYUSB1601.JYUSB1601AITask
GetRecordPreviewData(ref double[] buf, int samplesPerChannel, int timeout) | JYUSB1601.JYUSB1601AITask
GetRecordPreviewData(ref double[] buf, int timeout=-1) | JYUSB1601.JYUSB1601AITask
GetRecordStatus(out double recordedLength, out bool recordDone) | JYUSB1601.JYUSB1601AITask
JYUSB1601AITask() | JYUSB1601.JYUSB1601AITask
JYUSB1601AITask(string boardName) | JYUSB1601.JYUSB1601AITask
Mode | JYUSB1601.JYUSB1601AITask
ReadData(IntPtr buf, int samplesPerChannel, int timeout) | JYUSB1601.JYUSB1601AITask
ReadData(ref double[,] buf, int samplesPerChannel, int timeout) | JYUSB1601.JYUSB1601AITask
ReadData(ref double[,] buf, int timeout=-1) | JYUSB1601.JYUSB1601AITask
ReadData(ref double[] buf, int samplesPerChannel, int timeout) | JYUSB1601.JYUSB1601AITask
ReadData(ref double[] buf, int timeout=-1) | JYUSB1601.JYUSB1601AITask
ReadRawData(IntPtr buf, int samplesPerChannel, int timeout) | JYUSB1601.JYUSB1601AITask
ReadRawData(ref short[,] buf, int samplesPerChannel, int timeout) | JYUSB1601.JYUSB1601AITask
ReadRawData(ref short[,] buf, int timeout=-1) | JYUSB1601.JYUSB1601AITask
ReadRawData(ref short[] buf, int samplesPerChannel, int timeout) | JYUSB1601.JYUSB1601AITask
ReadRawData(ref short[] buf, int timeout=-1) | JYUSB1601.JYUSB1601AITask
ReadRawSinglePoint(ref short[] readValues) | JYUSB1601.JYUSB1601AITask
ReadRawSinglePoint(ref short readValue, int channel) | JYUSB1601.JYUSB1601AITask
ReadSinglePoint(ref double[] readValues) | JYUSB1601.JYUSB1601AITask
ReadSinglePoint(ref double readValue, int channel) | JYUSB1601.JYUSB1601AITask
Record | JYUSB1601.JYUSB1601AITask
RemoveChannel(int chnId) | JYUSB1601.JYUSB1601AITask
SampleClock | JYUSB1601.JYUSB1601AITask
SampleRate | JYUSB1601.JYUSB1601AITask
SamplesToAcquire | JYUSB1601.JYUSB1601AITask
SendSoftwareTrigger() | JYUSB1601.JYUSB1601AITask
SignalExport | JYUSB1601.JYUSB1601AITask
Start() | JYUSB1601.JYUSB1601AITask
Stop() | JYUSB1601.JYUSB1601AITask
TransferedSamples | JYUSB1601.JYUSB1601AITask
Trigger | JYUSB1601.JYUSB1601AITask
WaitUntilDone(int timeout=-1) | JYUSB1601.JYUSB1601AITask


1601 C# Programming Manual: JYUSB1601.JYUSB1601AOTask Class Reference

  • JYUSB1601AOTask
Public Member Functions | Properties | List of all members
JYUSB1601.JYUSB1601AOTask Class Referencesealed

JYUSB1601 Analog Output Task. More...

Public Member Functions

JYUSB1601AOTask ()
Constructor,Used to create an AO Task by a slot number.
JYUSB1601AOTask (string boardName)
Constructor.
void | AddChannel (int chnId)
Add one channel.
void | AddChannel (int[] chnsId)
Add a group of channels.
void | RemoveChannel (int chnId)
Delete the specified channel number.
void | WriteData (IntPtr buf, int samplesPerChannel, int timeout=10000)
Write to AO buffer one or multi-channel data.
void | WriteData (double[,] buf, int timeout=10000)
Write multi-channel data to AO buffer, Each column represents one channel.
void | WriteData (double[] buf, int timeout=10000)
Write one channel data to AO buffer.
void | WriteSinglePoint (double[] writeValues)
write one sample to all channels in register .
void | WriteSinglePoint (double writeValue, int channel)
Write one sample to the specified channel in register.Available when Mode is AOMode.Single.
bool | WaitUntilDone (int timeout=10000)
Waiting until current task to complete.
void | Start ()
Start AO task .
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Stop ()
Stop AO task .

Properties

List< AOChannel > | Channels [get]
AOMode | Mode [get, set]
Mode of AO Task.
double | UpdateRate [get, set]
Update rate per channel.
int | SamplesToUpdate [get, set]
Number of output samples to write per channel , Only valid when Mode is AOMode.Finite.
uint | AvaliableLenInSamples [get]
Number of output samples per channel that can be write in AO buffuer.
OutputCompleteState | CompleteState [get, set]
AO Output Complete State, Default is Hold.
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel).
AOSampleClock | SampleClock [get, set]
AO Sample Clock Configuration .
AOTrigger | Trigger = new AOTrigger() [get, set]
AO Trigger Configuration.
AOSignalExport | SignalExport [get, set]
Export AO Signal.
JYUSB1601Device | Device [get]
Device.

Detailed Description

JYUSB1601 Analog Output Task.

Constructor & Destructor Documentation

◆ JYUSB1601AOTask() [1/2]

JYUSB1601.JYUSB1601AOTask.JYUSB1601AOTask ( )

Constructor,Used to create an AO Task by a slot number.

◆ JYUSB1601AOTask() [2/2]

JYUSB1601.JYUSB1601AOTask.JYUSB1601AOTask ( string boardName )

Constructor.

Used to create an AO task by a board name.

Parameters
boardName Board name(device alias), set by device manager

Member Function Documentation

◆ AddChannel() [1/2]

void JYUSB1601.JYUSB1601AOTask.AddChannel ( int chnId )

Add one channel.

Parameters
chnId channel's physical number ，chnId=-1, add all channels。

◆ AddChannel() [2/2]

void JYUSB1601.JYUSB1601AOTask.AddChannel ( int[] chnsId )

Add a group of channels.

Parameters
chnsId a group of channel physical numbers。

◆ RemoveChannel()

void JYUSB1601.JYUSB1601AOTask.RemoveChannel ( int chnId )

Delete the specified channel number.

If it is -1, delete all channels.

Parameters
chnId Specified channel ID.

◆ SendSoftwareTrigger()

void JYUSB1601.JYUSB1601AOTask.SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JYUSB1601.JYUSB1601AOTask.Start ( )

Start AO task .

◆ Stop()

void JYUSB1601.JYUSB1601AOTask.Stop ( )

Stop AO task .

◆ WaitUntilDone()

bool JYUSB1601.JYUSB1601AOTask.WaitUntilDone ( int timeout = 10000 )

Waiting until current task to complete.

Available when Mode is AOMode.Finite

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteData() [1/3]

void JYUSB1601.JYUSB1601AOTask.WriteData | ( | double | buf[,],
 |  | int | timeout = 10000 )

Write multi-channel data to AO buffer, Each column represents one channel.

Parameters
buf | AO buffer for data.
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [2/3]

void JYUSB1601.JYUSB1601AOTask.WriteData | ( | double[] | buf,
 |  | int | timeout = 10000 )

Write one channel data to AO buffer.

Parameters
buf | AO buffer for data.
timeout | >timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [3/3]

void JYUSB1601.JYUSB1601AOTask.WriteData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Write to AO buffer one or multi-channel data.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | data buffer.
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteSinglePoint() [1/2]

void JYUSB1601.JYUSB1601AOTask.WriteSinglePoint | ( | double | writeValue,
 |  | int | channel )

Write one sample to the specified channel in register.Available when Mode is AOMode.Single.

Parameters
writeValue | Write value.
channel | Specified channel.

◆ WriteSinglePoint() [2/2]

void JYUSB1601.JYUSB1601AOTask.WriteSinglePoint ( double[] writeValues )

write one sample to all channels in register .

Available when Mode is AOMode.Single

Parameters
writeValues Write values. Array length >= Channels.Count.

Property Documentation

◆ AvaliableLenInSamples

uint JYUSB1601.JYUSB1601AOTask.AvaliableLenInSamples
get

Number of output samples per channel that can be write in AO buffuer.

◆ Channels

List<AOChannel> JYUSB1601.JYUSB1601AOTask.Channels
get

◆ CompleteState

OutputCompleteState JYUSB1601.JYUSB1601AOTask.CompleteState
getset

AO Output Complete State, Default is Hold.

◆ Device

JYUSB1601Device JYUSB1601.JYUSB1601AOTask.Device
get

Device.

◆ Mode

AOMode JYUSB1601.JYUSB1601AOTask.Mode
getset

Mode of AO Task.

Select AO Mode from enum:ContinuousNoWrapping/ContinuousWrapping/Finite/Single.

◆ SampleClock

AOSampleClock JYUSB1601.JYUSB1601AOTask.SampleClock
getset

AO Sample Clock Configuration .

◆ SamplesToUpdate

int JYUSB1601.JYUSB1601AOTask.SamplesToUpdate
getset

Number of output samples to write per channel , Only valid when Mode is AOMode.Finite.

◆ SignalExport

AOSignalExport JYUSB1601.JYUSB1601AOTask.SignalExport
getset

Export AO Signal.

◆ TransferedSamples

ulong JYUSB1601.JYUSB1601AOTask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT AOMode.Single.

◆ Trigger

AOTrigger JYUSB1601.JYUSB1601AOTask.Trigger = new AOTrigger()
getset

AO Trigger Configuration.

◆ UpdateRate

double JYUSB1601.JYUSB1601AOTask.UpdateRate
getset

Update rate per channel.

Maximum update rate is 2.86M for single channel, 2M for two channels, 1.5M for three channels, 1.25M for four channels. The defalut sample rate = 1000000 You can read this property to obtain the update rate that will actually take effect in the current configuration.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/CHM/1601/C#/JYUSB1601AOTask.cs


1601 C# Programming Manual: Member List

  • JYUSB1601AOTask
JYUSB1601.JYUSB1601AOTask Member List

This is the complete list of members for JYUSB1601.JYUSB1601AOTask, including all inherited members.

AddChannel(int chnId) | JYUSB1601.JYUSB1601AOTask
AddChannel(int[] chnsId) | JYUSB1601.JYUSB1601AOTask
AvaliableLenInSamples | JYUSB1601.JYUSB1601AOTask
Channels | JYUSB1601.JYUSB1601AOTask
CompleteState | JYUSB1601.JYUSB1601AOTask
Device | JYUSB1601.JYUSB1601AOTask
JYUSB1601AOTask() | JYUSB1601.JYUSB1601AOTask
JYUSB1601AOTask(string boardName) | JYUSB1601.JYUSB1601AOTask
Mode | JYUSB1601.JYUSB1601AOTask
RemoveChannel(int chnId) | JYUSB1601.JYUSB1601AOTask
SampleClock | JYUSB1601.JYUSB1601AOTask
SamplesToUpdate | JYUSB1601.JYUSB1601AOTask
SendSoftwareTrigger() | JYUSB1601.JYUSB1601AOTask
SignalExport | JYUSB1601.JYUSB1601AOTask
Start() | JYUSB1601.JYUSB1601AOTask
Stop() | JYUSB1601.JYUSB1601AOTask
TransferedSamples | JYUSB1601.JYUSB1601AOTask
Trigger | JYUSB1601.JYUSB1601AOTask
UpdateRate | JYUSB1601.JYUSB1601AOTask
WaitUntilDone(int timeout=10000) | JYUSB1601.JYUSB1601AOTask
WriteData(IntPtr buf, int samplesPerChannel, int timeout=10000) | JYUSB1601.JYUSB1601AOTask
WriteData(double[,] buf, int timeout=10000) | JYUSB1601.JYUSB1601AOTask
WriteData(double[] buf, int timeout=10000) | JYUSB1601.JYUSB1601AOTask
WriteSinglePoint(double[] writeValues) | JYUSB1601.JYUSB1601AOTask
WriteSinglePoint(double writeValue, int channel) | JYUSB1601.JYUSB1601AOTask


1601 C# Programming Manual: JYUSB1601.JYUSB1601CITask Class Reference

  • JYUSB1601CITask
Public Member Functions | Properties | List of all members
JYUSB1601.JYUSB1601CITask Class Referencesealed

JYUSB1601 Counter Input Task. More...

Public Member Functions

JYUSB1601CITask (int channel)
Constructor.
JYUSB1601CITask (string boardName, int channel)
Constructor.
void | Start ()
Start CI task .
void | Stop ()
Stop CI task .
void | ReadSinglePoint (ref uint count)
Read a signle count value from register, Available when Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder.
void | ReadSinglePoint (ref double measurement, int timeout=10000)
Read a signle frequency value or period value from register.
void | ReadSinglePoint (ref double measurement1, ref double measurement2, int timeout=10000)
Read a signle measurement of pulse's duration value, or two-edge separtion value (two results at a time) from register.

Properties

CIType | Type [get, set]
CI Application types.
EdgeCounting | EdgeCounting [get, set]
Edge Counting Configuration.
FrequencyMeas | FrequencyMeas [get, set]
Frequency Measurement Configuration.
PeriodMeas | PeriodMeas [get, set]
Period Measurement Configuration.
PulseMeas | PulseMeas [get, set]
Pulse Measurement Configuration.
TwoEdgeSeparation | TwoEdgeSeparation [get, set]
TwoEdgeSeparation.
QuadEncoder | QuadEncoder [get, set]
QuadEncoder.
JYUSB1601Device | Device [get]
Device.

Detailed Description

JYUSB1601 Counter Input Task.

Constructor & Destructor Documentation

◆ JYUSB1601CITask() [1/2]

JYUSB1601.JYUSB1601CITask.JYUSB1601CITask ( int channel )

Constructor.

Used to create an CI task by a slot number.

Parameters
channel Counter channel suppor0-1

◆ JYUSB1601CITask() [2/2]

JYUSB1601.JYUSB1601CITask.JYUSB1601CITask | ( | string | boardName,
 |  | int | channel )

Constructor.

Used to create an m task by a board name.

Parameters
boardName | Board name(device alias), set by device manager
channel | Counter channel （5112 support0-1）.

Member Function Documentation

◆ ReadSinglePoint() [1/3]

void JYUSB1601.JYUSB1601CITask.ReadSinglePoint | ( | ref double | measurement,
 |  | int | timeout = 10000 )

Read a signle frequency value or period value from register.

Valid when Type is CIType.Frequency or CIType.Period.

Parameters
measurement Measurement value. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period is seconds when Type is CIType.Period.
timeout
Timeout (ms). Wait until the measurement is completed or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [2/3]

void JYUSB1601.JYUSB1601CITask.ReadSinglePoint | ( | ref double | measurement1,
 |  | ref double | measurement2,
 |  | int | timeout = 10000 )

Read a signle measurement of pulse's duration value, or two-edge separtion value (two results at a time) from register.

Available when Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
measurement1 | Measurement Value 1. Indicates low level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
measurement2 | Measurement Value 2. Indicates high level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
timeout
Timeout (ms). Wait until the measurement is completed or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [3/3]

void JYUSB1601.JYUSB1601CITask.ReadSinglePoint ( ref uint count )

Read a signle count value from register, Available when Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder.

Parameters
count counter value。

◆ Start()

void JYUSB1601.JYUSB1601CITask.Start ( )

Start CI task .

◆ Stop()

void JYUSB1601.JYUSB1601CITask.Stop ( )

Stop CI task .

Property Documentation

◆ Device

JYUSB1601Device JYUSB1601.JYUSB1601CITask.Device
get

Device.

◆ EdgeCounting

EdgeCounting JYUSB1601.JYUSB1601CITask.EdgeCounting
getset

Edge Counting Configuration.

◆ FrequencyMeas

FrequencyMeas JYUSB1601.JYUSB1601CITask.FrequencyMeas
getset

Frequency Measurement Configuration.

◆ PeriodMeas

PeriodMeas JYUSB1601.JYUSB1601CITask.PeriodMeas
getset

Period Measurement Configuration.

◆ PulseMeas

PulseMeas JYUSB1601.JYUSB1601CITask.PulseMeas
getset

Pulse Measurement Configuration.

◆ QuadEncoder

QuadEncoder JYUSB1601.JYUSB1601CITask.QuadEncoder
getset

QuadEncoder.

◆ TwoEdgeSeparation

TwoEdgeSeparation JYUSB1601.JYUSB1601CITask.TwoEdgeSeparation
getset

TwoEdgeSeparation.

◆ Type

CIType JYUSB1601.JYUSB1601CITask.Type
getset

CI Application types.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/CHM/1601/C#/JYUSB1601CITask.cs


1601 C# Programming Manual: Member List

  • JYUSB1601CITask
JYUSB1601.JYUSB1601CITask Member List

This is the complete list of members for JYUSB1601.JYUSB1601CITask, including all inherited members.

Device | JYUSB1601.JYUSB1601CITask
EdgeCounting | JYUSB1601.JYUSB1601CITask
FrequencyMeas | JYUSB1601.JYUSB1601CITask
JYUSB1601CITask(int channel) | JYUSB1601.JYUSB1601CITask
JYUSB1601CITask(string boardName, int channel) | JYUSB1601.JYUSB1601CITask
PeriodMeas | JYUSB1601.JYUSB1601CITask
PulseMeas | JYUSB1601.JYUSB1601CITask
QuadEncoder | JYUSB1601.JYUSB1601CITask
ReadSinglePoint(ref uint count) | JYUSB1601.JYUSB1601CITask
ReadSinglePoint(ref double measurement, int timeout=10000) | JYUSB1601.JYUSB1601CITask
ReadSinglePoint(ref double measurement1, ref double measurement2, int timeout=10000) | JYUSB1601.JYUSB1601CITask
Start() | JYUSB1601.JYUSB1601CITask
Stop() | JYUSB1601.JYUSB1601CITask
TwoEdgeSeparation | JYUSB1601.JYUSB1601CITask
Type | JYUSB1601.JYUSB1601CITask


1601 C# Programming Manual: JYUSB1601.JYUSB1601COTask Class Reference

  • JYUSB1601COTask
Public Member Functions | Properties | List of all members
JYUSB1601.JYUSB1601COTask Class Referencesealed

JYUSB1601 Counter Output Task. More...

Public Member Functions

JYUSB1601COTask (int channel)
Constructor.
JYUSB1601COTask (string boardName, int channel)
Constructor.
void | WriteSinglePoint (COPulse pulse)
Write a single pulse parameter to the register.
void | Start ()
Start CO task .
void | Stop ()
Stop COtask .
bool | WaitUntilDone (int timeout=10000)
Waiting until current task to complete.

Properties

PauseTrigger | Pause [get, set]
COIdleState | IdleState [get, set]
Idle state when pulse output before start and after stop.
JYUSB1601Device | Device [get]
Device.

Detailed Description

JYUSB1601 Counter Output Task.

Constructor & Destructor Documentation

◆ JYUSB1601COTask() [1/2]

JYUSB1601.JYUSB1601COTask.JYUSB1601COTask ( int channel )

Constructor.

Used to create an CO task by a slot number.

Parameters
channel Counter channel （1601 support0-1）.

◆ JYUSB1601COTask() [2/2]

JYUSB1601.JYUSB1601COTask.JYUSB1601COTask | ( | string | boardName,
 |  | int | channel )

Constructor.

Used to create an CO task by a board name.

Parameters
boardName | Board name(device alias), set by device manager
channel | Counter channel （5112 support0-1）.

Member Function Documentation

◆ Start()

void JYUSB1601.JYUSB1601COTask.Start ( )

Start CO task .

◆ Stop()

void JYUSB1601.JYUSB1601COTask.Stop ( )

Stop COtask .

◆ WaitUntilDone()

bool JYUSB1601.JYUSB1601COTask.WaitUntilDone ( int timeout = 10000 )

Waiting until current task to complete.

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteSinglePoint()

void JYUSB1601.JYUSB1601COTask.WriteSinglePoint ( COPulse pulse )

Write a single pulse parameter to the register.

This function is also available after starting the task when the number of pulses being sent is infinite.

Parameters
pulse Pulse Parameter

Property Documentation

◆ Device

JYUSB1601Device JYUSB1601.JYUSB1601COTask.Device
get

Device.

◆ IdleState

COIdleState JYUSB1601.JYUSB1601COTask.IdleState
getset

Idle state when pulse output before start and after stop.

◆ Pause

PauseTrigger JYUSB1601.JYUSB1601COTask.Pause
getset

暂停触发配置

Pause Trigger Configuration

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/CHM/1601/C#/JYUSB1601COTask.cs


1601 C# Programming Manual: Member List

  • JYUSB1601COTask
JYUSB1601.JYUSB1601COTask Member List

This is the complete list of members for JYUSB1601.JYUSB1601COTask, including all inherited members.

Device | JYUSB1601.JYUSB1601COTask
IdleState | JYUSB1601.JYUSB1601COTask
JYUSB1601COTask(int channel) | JYUSB1601.JYUSB1601COTask
JYUSB1601COTask(string boardName, int channel) | JYUSB1601.JYUSB1601COTask
Pause | JYUSB1601.JYUSB1601COTask
Start() | JYUSB1601.JYUSB1601COTask
Stop() | JYUSB1601.JYUSB1601COTask
WaitUntilDone(int timeout=10000) | JYUSB1601.JYUSB1601COTask
WriteSinglePoint(COPulse pulse) | JYUSB1601.JYUSB1601COTask


1601 C# Programming Manual: JYUSB1601.JYUSB1601DITask Class Reference

  • JYUSB1601DITask
Public Member Functions | Properties | List of all members
JYUSB1601.JYUSB1601DITask Class Referencesealed

JYUSB1601 Digital Iuput Task. More...

Public Member Functions

JYUSB1601DITask ()
Constructor.
JYUSB1601DITask (string boardName)
Constructor.
void | AddChannel (int lineNum)
Add one channel.
void | AddChannel (int[] linesNum)
Add a group of channel.
void | RemoveChannel (int lineNum)
Delete the specified line number .If it is -1, delete all lines.
void | Start ()
Start DI task .
void | Stop ()
Stop DI task .
void | ReadSinglePoint (ref bool readValue, int line)
Read one sample for specified line in register.
void | ReadSinglePoint (ref bool[] readValues)
Read one sample for all lines in register.

Properties

List< DIChannel > | Channels [get]
List of DI channels,(1601 support 8 lines).
JYUSB1601Device | Device [get]
Device.

Detailed Description

JYUSB1601 Digital Iuput Task.

Constructor & Destructor Documentation

◆ JYUSB1601DITask() [1/2]

JYUSB1601.JYUSB1601DITask.JYUSB1601DITask ( )

Constructor.

Used to create an DItask by a slot number.

◆ JYUSB1601DITask() [2/2]

JYUSB1601.JYUSB1601DITask.JYUSB1601DITask ( string boardName )

Constructor.

Used to create an DI task by a board name.

Parameters
boardName Board name(device alias), set by device manager

Member Function Documentation

◆ AddChannel() [1/2]

void JYUSB1601.JYUSB1601DITask.AddChannel ( int lineNum )

Add one channel.

Parameters
lineNum line number to be added.

◆ AddChannel() [2/2]

void JYUSB1601.JYUSB1601DITask.AddChannel ( int[] linesNum )

Add a group of channel.

Parameters
linesNum an array of line numbers of added lines.

◆ ReadSinglePoint() [1/2]

void JYUSB1601.JYUSB1601DITask.ReadSinglePoint | ( | ref bool | readValue,
 |  | int | line )

Read one sample for specified line in register.

Parameters
readValue | values read.
line | Specified line number.

◆ ReadSinglePoint() [2/2]

void JYUSB1601.JYUSB1601DITask.ReadSinglePoint ( ref bool[] readValues )

Read one sample for all lines in register.

Parameters
readValues Values read. Buffer size >= number of lines.

◆ RemoveChannel()

void JYUSB1601.JYUSB1601DITask.RemoveChannel ( int lineNum )

Delete the specified line number .If it is -1, delete all lines.

Parameters
lineNum port number to be delete.

◆ Start()

void JYUSB1601.JYUSB1601DITask.Start ( )

Start DI task .

◆ Stop()

void JYUSB1601.JYUSB1601DITask.Stop ( )

Stop DI task .

Property Documentation

◆ Channels

List<DIChannel> JYUSB1601.JYUSB1601DITask.Channels
get

List of DI channels,(1601 support 8 lines).

◆ Device

JYUSB1601Device JYUSB1601.JYUSB1601DITask.Device
get

Device.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/CHM/1601/C#/JYUSB1601DITask.cs


1601 C# Programming Manual: Member List

  • JYUSB1601DITask
JYUSB1601.JYUSB1601DITask Member List

This is the complete list of members for JYUSB1601.JYUSB1601DITask, including all inherited members.

AddChannel(int lineNum) | JYUSB1601.JYUSB1601DITask
AddChannel(int[] linesNum) | JYUSB1601.JYUSB1601DITask
Channels | JYUSB1601.JYUSB1601DITask
Device | JYUSB1601.JYUSB1601DITask
JYUSB1601DITask() | JYUSB1601.JYUSB1601DITask
JYUSB1601DITask(string boardName) | JYUSB1601.JYUSB1601DITask
ReadSinglePoint(ref bool readValue, int line) | JYUSB1601.JYUSB1601DITask
ReadSinglePoint(ref bool[] readValues) | JYUSB1601.JYUSB1601DITask
RemoveChannel(int lineNum) | JYUSB1601.JYUSB1601DITask
Start() | JYUSB1601.JYUSB1601DITask
Stop() | JYUSB1601.JYUSB1601DITask


1601 C# Programming Manual: JYUSB1601.JYUSB1601DOTask Class Reference

  • JYUSB1601DOTask
Public Member Functions | Properties | List of all members
JYUSB1601.JYUSB1601DOTask Class Referencesealed

JYUSB1601 Digital Output Task. More...

Public Member Functions

JYUSB1601DOTask ()
Constructor.
JYUSB1601DOTask (string boardName)
Constructor.
void | AddChannel (int lineNum)
Add one channel.
void | AddChannel (int[] linesNum)
Add a group of channels.
void | RemoveChannel (int lineNum)
Delete the specified line number .If it is -1, delete all lines.
void | Start ()
Start DO task .
void | Stop ()
Stop DO task .
void | WriteSinglePoint (bool writeValue, int line)
Write one sample to the specified line in register.
void | WriteSinglePoint (bool[] writeValues)
write one sample to all lines in register .

Properties

List< DOChannel > | Channels [get]
List of DO channels,(1601 support 8 lines).
JYUSB1601Device | Device [get]
Device.

Detailed Description

JYUSB1601 Digital Output Task.

Constructor & Destructor Documentation

◆ JYUSB1601DOTask() [1/2]

JYUSB1601.JYUSB1601DOTask.JYUSB1601DOTask ( )

Constructor.

Used to create an DOtask by a slot number.

◆ JYUSB1601DOTask() [2/2]

JYUSB1601.JYUSB1601DOTask.JYUSB1601DOTask ( string boardName )

Constructor.

Used to create an DO task by a board name.

Parameters
boardName Board name(device alias), set by device manager

Member Function Documentation

◆ AddChannel() [1/2]

void JYUSB1601.JYUSB1601DOTask.AddChannel ( int lineNum )

Add one channel.

Parameters
lineNum line number to be added.

◆ AddChannel() [2/2]

void JYUSB1601.JYUSB1601DOTask.AddChannel ( int[] linesNum )

Add a group of channels.

Parameters
linesNum an array of line numbers of added lines.

◆ RemoveChannel()

void JYUSB1601.JYUSB1601DOTask.RemoveChannel ( int lineNum )

Delete the specified line number .If it is -1, delete all lines.

Parameters
lineNum line number to be delete.

◆ Start()

void JYUSB1601.JYUSB1601DOTask.Start ( )

Start DO task .

◆ Stop()

void JYUSB1601.JYUSB1601DOTask.Stop ( )

Stop DO task .

◆ WriteSinglePoint() [1/2]

void JYUSB1601.JYUSB1601DOTask.WriteSinglePoint | ( | bool | writeValue,
 |  | int | line )

Write one sample to the specified line in register.

Parameters
writeValue | Write values.
line | Specified line.

◆ WriteSinglePoint() [2/2]

void JYUSB1601.JYUSB1601DOTask.WriteSinglePoint ( bool[] writeValues )

write one sample to all lines in register .

Parameters
writeValues Data to be written.Buffer size >= number of lines。

Property Documentation

◆ Channels

List<DOChannel> JYUSB1601.JYUSB1601DOTask.Channels
get

List of DO channels,(1601 support 8 lines).

◆ Device

JYUSB1601Device JYUSB1601.JYUSB1601DOTask.Device
get

Device.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/CHM/1601/C#/JYUSB1601DOTask.cs


1601 C# Programming Manual: Member List

  • JYUSB1601DOTask
JYUSB1601.JYUSB1601DOTask Member List

This is the complete list of members for JYUSB1601.JYUSB1601DOTask, including all inherited members.

AddChannel(int lineNum) | JYUSB1601.JYUSB1601DOTask
AddChannel(int[] linesNum) | JYUSB1601.JYUSB1601DOTask
Channels | JYUSB1601.JYUSB1601DOTask
Device | JYUSB1601.JYUSB1601DOTask
JYUSB1601DOTask() | JYUSB1601.JYUSB1601DOTask
JYUSB1601DOTask(string boardName) | JYUSB1601.JYUSB1601DOTask
RemoveChannel(int lineNum) | JYUSB1601.JYUSB1601DOTask
Start() | JYUSB1601.JYUSB1601DOTask
Stop() | JYUSB1601.JYUSB1601DOTask
WriteSinglePoint(bool writeValue, int line) | JYUSB1601.JYUSB1601DOTask
WriteSinglePoint(bool[] writeValues) | JYUSB1601.JYUSB1601DOTask


1601 C# Programming Manual: JYUSB1601.PauseTrigger Class Reference

  • PauseTrigger
Properties | List of all members
JYUSB1601.PauseTrigger Class Referencesealed

Pause trigger configuration class. More...

Properties

LevelPolarity ActivePolarity [get, set]
Pause trigger active polarity.

Detailed Description

Pause trigger configuration class.

Property Documentation

◆ ActivePolarity

LevelPolarity JYUSB1601.PauseTrigger.ActivePolarity
getset

Pause trigger active polarity.

The default value is LevelPolarity.None, means the pause trigger is disabled.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/CHM/1601/C#/JYUSB1601CITask.cs


1601 C# Programming Manual: Member List

  • PauseTrigger
JYUSB1601.PauseTrigger Member List

This is the complete list of members for JYUSB1601.PauseTrigger, including all inherited members.

ActivePolarity JYUSB1601.PauseTrigger


1601 C# Programming Manual: JYUSB1601.PeriodMeas Class Reference

  • PeriodMeas
List of all members
JYUSB1601.PeriodMeas Class Referencesealed

Configure CI Measure. More...

Detailed Description

Configure CI Measure.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/CHM/1601/C#/JYUSB1601CITask.cs


1601 C# Programming Manual: Member List

  • PeriodMeas
JYUSB1601.PeriodMeas Member List

This is the complete list of members for JYUSB1601.PeriodMeas, including all inherited members.


1601 C# Programming Manual: JYUSB1601.PulseMeas Class Reference

  • PulseMeas
List of all members
JYUSB1601.PulseMeas Class Referencesealed

Configure CI Measure. More...

Detailed Description

Configure CI Measure.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/CHM/1601/C#/JYUSB1601CITask.cs


1601 C# Programming Manual: Member List

  • PulseMeas
JYUSB1601.PulseMeas Member List

This is the complete list of members for JYUSB1601.PulseMeas, including all inherited members.


1601 C# Programming Manual: JYUSB1601.QuadEncoder Class Reference

  • QuadEncoder
Properties | List of all members
JYUSB1601.QuadEncoder Class Referencesealed

Configure CI Measure. More...

Properties

QuadEncodingType | EncodingType [get, set]
Type of Encoding.
bool | ZReloadEnabled [get, set]
In Encoder mode ,the Z signal enable.
int | InitialCount [get, set]
Initial Count.

Detailed Description

Configure CI Measure.

Property Documentation

◆ EncodingType

QuadEncodingType JYUSB1601.QuadEncoder.EncodingType
getset

Type of Encoding.

◆ InitialCount

int JYUSB1601.QuadEncoder.InitialCount
getset

Initial Count.

◆ ZReloadEnabled

bool JYUSB1601.QuadEncoder.ZReloadEnabled
getset

In Encoder mode ,the Z signal enable.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/CHM/1601/C#/JYUSB1601CITask.cs


1601 C# Programming Manual: Member List

  • QuadEncoder
JYUSB1601.QuadEncoder Member List

This is the complete list of members for JYUSB1601.QuadEncoder, including all inherited members.

EncodingType | JYUSB1601.QuadEncoder
InitialCount | JYUSB1601.QuadEncoder
ZReloadEnabled | JYUSB1601.QuadEncoder


1601 C# Programming Manual: JYUSB1601.TwoEdgeSeparation Class Reference

  • TwoEdgeSeparation
List of all members
JYUSB1601.TwoEdgeSeparation Class Referencesealed

Configure CI Measure. More...

Detailed Description

Configure CI Measure.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/CHM/1601/C#/JYUSB1601CITask.cs


1601 C# Programming Manual: Member List

  • TwoEdgeSeparation
JYUSB1601.TwoEdgeSeparation Member List

This is the complete list of members for JYUSB1601.TwoEdgeSeparation, including all inherited members.


1601 C# Programming Manual: JYUSB1601.TwoPulseEncoder Class Reference

  • TwoPulseEncoder
Properties | List of all members
JYUSB1601.TwoPulseEncoder Class Referencesealed

Configure CI Measure. More...

Properties

int InitialCount [get, set]
Initial Count.

Detailed Description

Configure CI Measure.

Property Documentation

◆ InitialCount

int JYUSB1601.TwoPulseEncoder.InitialCount
getset

Initial Count.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/CHM/1601/C#/JYUSB1601CITask.cs


1601 C# Programming Manual: Member List

  • TwoPulseEncoder
JYUSB1601.TwoPulseEncoder Member List

This is the complete list of members for JYUSB1601.TwoPulseEncoder, including all inherited members.

InitialCount JYUSB1601.TwoPulseEncoder


1601 C# Programming Manual: Class Index

Class Index
A | C | D | E | F | J | P | Q | T
A
AIChannel (JYUSB1601)
AIDigitalTrigger (JYUSB1601)
AIExternalSampleClock (JYUSB1601)
AIRecord (JYUSB1601)
AISampleClock (JYUSB1601)
AISignalExport (JYUSB1601)
AITrigger (JYUSB1601)
AOChannel (JYUSB1601)
AODigitalTrigger (JYUSB1601)
AOExternalSampleClock (JYUSB1601)
AOSampleClock (JYUSB1601)
AOSignalExport (JYUSB1601)
AOTrigger (JYUSB1601)
C
COPulse (JYUSB1601)
D
DIChannel (JYUSB1601)
DOChannel (JYUSB1601)
E
EdgeCounting (JYUSB1601)
EdgeCountingOutEvent (JYUSB1601)
F
FrequencyMeas (JYUSB1601)
J
JYUSB1601AITask (JYUSB1601)
JYUSB1601AOTask (JYUSB1601)
JYUSB1601CITask (JYUSB1601)
JYUSB1601COTask (JYUSB1601)
JYUSB1601DITask (JYUSB1601)
JYUSB1601DOTask (JYUSB1601)
P
PauseTrigger (JYUSB1601)
PeriodMeas (JYUSB1601)
PulseMeas (JYUSB1601)
Q
QuadEncoder (JYUSB1601)
T
TwoEdgeSeparation (JYUSB1601)
TwoPulseEncoder (JYUSB1601)


1601 C# Programming Manual: D:/OneDrive/Desktop/CHM/1601/C# Directory Reference

Files

         JYUSB1601AITask.cs
JYUSB1601AOTask.cs
JYUSB1601CITask.cs
JYUSB1601COTask.cs
JYUSB1601DITask.cs
JYUSB1601DOTask.cs


1601 C# Programming Manual: D:/OneDrive/Desktop/CHM/1601 Directory Reference

  • File List
  • OneDrive
  • Desktop
  • CHM
  • 1601
1601 Directory Reference

Directories

         C#


1601 C# Programming Manual: D:/OneDrive/Desktop Directory Reference

  • File List
  • OneDrive
  • Desktop
Desktop Directory Reference

Directories

         CHM


1601 C# Programming Manual: D:/OneDrive/Desktop/CHM Directory Reference

  • File List
  • OneDrive
  • Desktop
  • CHM
CHM Directory Reference

Directories

         1601


1601 C# Programming Manual: D:/OneDrive Directory Reference

  • File List
  • OneDrive
OneDrive Directory Reference

Directories

         Desktop


1601 C# Programming Manual: File List

  • File List
File List
Here is a list of all files with brief descriptions:
[detail level 123456]
 OneDrive
Desktop
CHM
1601
C#
JYUSB1601AITask.cs
JYUSB1601AOTask.cs
JYUSB1601CITask.cs
JYUSB1601COTask.cs
JYUSB1601DITask.cs
JYUSB1601DOTask.cs


1601 C# Programming Manual: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- a -

  • ActivePolarity : JYUSB1601.PauseTrigger
  • Add() : JYUSB1601.AISignalExport, JYUSB1601.AOSignalExport
  • AddChannel() : JYUSB1601.JYUSB1601AITask, JYUSB1601.JYUSB1601AOTask, JYUSB1601.JYUSB1601DITask, JYUSB1601.JYUSB1601DOTask
  • AIChannel() : JYUSB1601.AIChannel
  • AvailableSamples : JYUSB1601.JYUSB1601AITask
  • AvaliableLenInSamples : JYUSB1601.JYUSB1601AOTask

- b -

  • Bandwidth : JYUSB1601.JYUSB1601AITask
  • BufLenInSamples : JYUSB1601.JYUSB1601AITask

- c -

  • ChannelID : JYUSB1601.AIChannel, JYUSB1601.AOChannel
  • Channels : JYUSB1601.JYUSB1601AITask, JYUSB1601.JYUSB1601AOTask, JYUSB1601.JYUSB1601DITask, JYUSB1601.JYUSB1601DOTask
  • Clear() : JYUSB1601.AISignalExport, JYUSB1601.AOSignalExport
  • ClearAll() : JYUSB1601.AISignalExport, JYUSB1601.AOSignalExport
  • CompleteState : JYUSB1601.JYUSB1601AOTask
  • COPulse() : JYUSB1601.COPulse

- d -

  • Device : JYUSB1601.JYUSB1601AITask, JYUSB1601.JYUSB1601AOTask, JYUSB1601.JYUSB1601CITask, JYUSB1601.JYUSB1601COTask, JYUSB1601.JYUSB1601DITask, JYUSB1601.JYUSB1601DOTask
  • Digital : JYUSB1601.AITrigger, JYUSB1601.AOTrigger
  • Direction : JYUSB1601.EdgeCounting

- e -

  • Edge : JYUSB1601.AIDigitalTrigger, JYUSB1601.AODigitalTrigger
  • EdgeCounting : JYUSB1601.JYUSB1601CITask
  • EncodingType : JYUSB1601.QuadEncoder
  • ExpectedRate : JYUSB1601.AIExternalSampleClock, JYUSB1601.AOExternalSampleClock
  • External : JYUSB1601.AISampleClock, JYUSB1601.AOSampleClock

- f -

  • FileFormat : JYUSB1601.AIRecord
  • FilePath : JYUSB1601.AIRecord
  • FrequencyMeas : JYUSB1601.JYUSB1601CITask

- g -

  • GetRecordPreviewData() : JYUSB1601.JYUSB1601AITask
  • GetRecordStatus() : JYUSB1601.JYUSB1601AITask

- i -

  • IdleState : JYUSB1601.EdgeCountingOutEvent, JYUSB1601.JYUSB1601COTask
  • InitialCount : JYUSB1601.EdgeCounting, JYUSB1601.QuadEncoder, JYUSB1601.TwoPulseEncoder

- j -

  • JYUSB1601AITask() : JYUSB1601.JYUSB1601AITask
  • JYUSB1601AOTask() : JYUSB1601.JYUSB1601AOTask
  • JYUSB1601CITask() : JYUSB1601.JYUSB1601CITask
  • JYUSB1601COTask() : JYUSB1601.JYUSB1601COTask
  • JYUSB1601DITask() : JYUSB1601.JYUSB1601DITask
  • JYUSB1601DOTask() : JYUSB1601.JYUSB1601DOTask

- l -

  • Length : JYUSB1601.AIRecord
  • LineNum : JYUSB1601.DIChannel, JYUSB1601.DOChannel

- m -

  • Mode : JYUSB1601.AIRecord, JYUSB1601.JYUSB1601AITask, JYUSB1601.JYUSB1601AOTask

- o -

  • OutEvent : JYUSB1601.EdgeCounting

- p -

  • Pause : JYUSB1601.EdgeCounting, JYUSB1601.JYUSB1601COTask
  • PeriodMeas : JYUSB1601.JYUSB1601CITask
  • PulseMeas : JYUSB1601.JYUSB1601CITask

- q -

  • QuadEncoder : JYUSB1601.JYUSB1601CITask

- r -

  • RangeHigh : JYUSB1601.AIChannel
  • RangeLow : JYUSB1601.AIChannel
  • ReadData() : JYUSB1601.JYUSB1601AITask
  • ReadRawData() : JYUSB1601.JYUSB1601AITask
  • ReadRawSinglePoint() : JYUSB1601.JYUSB1601AITask
  • ReadSinglePoint() : JYUSB1601.JYUSB1601AITask, JYUSB1601.JYUSB1601CITask, JYUSB1601.JYUSB1601DITask
  • Record : JYUSB1601.JYUSB1601AITask
  • RemoveChannel() : JYUSB1601.JYUSB1601AITask, JYUSB1601.JYUSB1601AOTask, JYUSB1601.JYUSB1601DITask, JYUSB1601.JYUSB1601DOTask

- s -

  • SampleClock : JYUSB1601.JYUSB1601AITask, JYUSB1601.JYUSB1601AOTask
  • SampleRate : JYUSB1601.JYUSB1601AITask
  • SamplesToAcquire : JYUSB1601.JYUSB1601AITask
  • SamplesToUpdate : JYUSB1601.JYUSB1601AOTask
  • SendSoftwareTrigger() : JYUSB1601.JYUSB1601AITask, JYUSB1601.JYUSB1601AOTask
  • SignalExport : JYUSB1601.JYUSB1601AITask, JYUSB1601.JYUSB1601AOTask
  • Source : JYUSB1601.AIDigitalTrigger, JYUSB1601.AISampleClock, JYUSB1601.AODigitalTrigger, JYUSB1601.AOSampleClock
  • Start() : JYUSB1601.JYUSB1601AITask, JYUSB1601.JYUSB1601AOTask, JYUSB1601.JYUSB1601CITask, JYUSB1601.JYUSB1601COTask, JYUSB1601.JYUSB1601DITask, JYUSB1601.JYUSB1601DOTask
  • Stop() : JYUSB1601.JYUSB1601AITask, JYUSB1601.JYUSB1601AOTask, JYUSB1601.JYUSB1601CITask, JYUSB1601.JYUSB1601COTask, JYUSB1601.JYUSB1601DITask, JYUSB1601.JYUSB1601DOTask

- t -

  • Terminal : JYUSB1601.AIChannel
  • Threshold : JYUSB1601.EdgeCountingOutEvent
  • TransferedSamples : JYUSB1601.JYUSB1601AITask, JYUSB1601.JYUSB1601AOTask
  • Trigger : JYUSB1601.JYUSB1601AITask, JYUSB1601.JYUSB1601AOTask
  • TwoEdgeSeparation : JYUSB1601.JYUSB1601CITask
  • Type : JYUSB1601.AITrigger, JYUSB1601.AOTrigger, JYUSB1601.JYUSB1601CITask

- u -

  • UpdateRate : JYUSB1601.JYUSB1601AOTask

- w -

  • WaitUntilDone() : JYUSB1601.JYUSB1601AITask, JYUSB1601.JYUSB1601AOTask, JYUSB1601.JYUSB1601COTask
  • WriteData() : JYUSB1601.JYUSB1601AOTask
  • WriteSinglePoint() : JYUSB1601.JYUSB1601AOTask, JYUSB1601.JYUSB1601COTask, JYUSB1601.JYUSB1601DOTask

- z -

  • ZReloadEnabled : JYUSB1601.QuadEncoder


1601 C# Programming Manual: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • c
  • g
  • j
  • r
  • s
  • w
Here is a list of all functions with links to the classes they belong to:

- a -

  • Add() : JYUSB1601.AISignalExport, JYUSB1601.AOSignalExport
  • AddChannel() : JYUSB1601.JYUSB1601AITask, JYUSB1601.JYUSB1601AOTask, JYUSB1601.JYUSB1601DITask, JYUSB1601.JYUSB1601DOTask
  • AIChannel() : JYUSB1601.AIChannel

- c -

  • Clear() : JYUSB1601.AISignalExport, JYUSB1601.AOSignalExport
  • ClearAll() : JYUSB1601.AISignalExport, JYUSB1601.AOSignalExport
  • COPulse() : JYUSB1601.COPulse

- g -

  • GetRecordPreviewData() : JYUSB1601.JYUSB1601AITask
  • GetRecordStatus() : JYUSB1601.JYUSB1601AITask

- j -

  • JYUSB1601AITask() : JYUSB1601.JYUSB1601AITask
  • JYUSB1601AOTask() : JYUSB1601.JYUSB1601AOTask
  • JYUSB1601CITask() : JYUSB1601.JYUSB1601CITask
  • JYUSB1601COTask() : JYUSB1601.JYUSB1601COTask
  • JYUSB1601DITask() : JYUSB1601.JYUSB1601DITask
  • JYUSB1601DOTask() : JYUSB1601.JYUSB1601DOTask

- r -

  • ReadData() : JYUSB1601.JYUSB1601AITask
  • ReadRawData() : JYUSB1601.JYUSB1601AITask
  • ReadRawSinglePoint() : JYUSB1601.JYUSB1601AITask
  • ReadSinglePoint() : JYUSB1601.JYUSB1601AITask, JYUSB1601.JYUSB1601CITask, JYUSB1601.JYUSB1601DITask
  • RemoveChannel() : JYUSB1601.JYUSB1601AITask, JYUSB1601.JYUSB1601AOTask, JYUSB1601.JYUSB1601DITask, JYUSB1601.JYUSB1601DOTask

- s -

  • SendSoftwareTrigger() : JYUSB1601.JYUSB1601AITask, JYUSB1601.JYUSB1601AOTask
  • Start() : JYUSB1601.JYUSB1601AITask, JYUSB1601.JYUSB1601AOTask, JYUSB1601.JYUSB1601CITask, JYUSB1601.JYUSB1601COTask, JYUSB1601.JYUSB1601DITask, JYUSB1601.JYUSB1601DOTask
  • Stop() : JYUSB1601.JYUSB1601AITask, JYUSB1601.JYUSB1601AOTask, JYUSB1601.JYUSB1601CITask, JYUSB1601.JYUSB1601COTask, JYUSB1601.JYUSB1601DITask, JYUSB1601.JYUSB1601DOTask

- w -

  • WaitUntilDone() : JYUSB1601.JYUSB1601AITask, JYUSB1601.JYUSB1601AOTask, JYUSB1601.JYUSB1601COTask
  • WriteData() : JYUSB1601.JYUSB1601AOTask
  • WriteSinglePoint() : JYUSB1601.JYUSB1601AOTask, JYUSB1601.JYUSB1601COTask, JYUSB1601.JYUSB1601DOTask


1601 C# Programming Manual: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • z
Here is a list of all properties with links to the classes they belong to:

- a -

  • ActivePolarity : JYUSB1601.PauseTrigger
  • AvailableSamples : JYUSB1601.JYUSB1601AITask
  • AvaliableLenInSamples : JYUSB1601.JYUSB1601AOTask

- b -

  • Bandwidth : JYUSB1601.JYUSB1601AITask
  • BufLenInSamples : JYUSB1601.JYUSB1601AITask

- c -

  • ChannelID : JYUSB1601.AIChannel, JYUSB1601.AOChannel
  • Channels : JYUSB1601.JYUSB1601AITask, JYUSB1601.JYUSB1601AOTask, JYUSB1601.JYUSB1601DITask, JYUSB1601.JYUSB1601DOTask
  • CompleteState : JYUSB1601.JYUSB1601AOTask

- d -

  • Device : JYUSB1601.JYUSB1601AITask, JYUSB1601.JYUSB1601AOTask, JYUSB1601.JYUSB1601CITask, JYUSB1601.JYUSB1601COTask, JYUSB1601.JYUSB1601DITask, JYUSB1601.JYUSB1601DOTask
  • Digital : JYUSB1601.AITrigger, JYUSB1601.AOTrigger
  • Direction : JYUSB1601.EdgeCounting

- e -

  • Edge : JYUSB1601.AIDigitalTrigger, JYUSB1601.AODigitalTrigger
  • EdgeCounting : JYUSB1601.JYUSB1601CITask
  • EncodingType : JYUSB1601.QuadEncoder
  • ExpectedRate : JYUSB1601.AIExternalSampleClock, JYUSB1601.AOExternalSampleClock
  • External : JYUSB1601.AISampleClock, JYUSB1601.AOSampleClock

- f -

  • FileFormat : JYUSB1601.AIRecord
  • FilePath : JYUSB1601.AIRecord
  • FrequencyMeas : JYUSB1601.JYUSB1601CITask

- i -

  • IdleState : JYUSB1601.EdgeCountingOutEvent, JYUSB1601.JYUSB1601COTask
  • InitialCount : JYUSB1601.EdgeCounting, JYUSB1601.QuadEncoder, JYUSB1601.TwoPulseEncoder

- l -

  • Length : JYUSB1601.AIRecord
  • LineNum : JYUSB1601.DIChannel, JYUSB1601.DOChannel

- m -

  • Mode : JYUSB1601.AIRecord, JYUSB1601.JYUSB1601AITask, JYUSB1601.JYUSB1601AOTask

- o -

  • OutEvent : JYUSB1601.EdgeCounting

- p -

  • Pause : JYUSB1601.EdgeCounting, JYUSB1601.JYUSB1601COTask
  • PeriodMeas : JYUSB1601.JYUSB1601CITask
  • PulseMeas : JYUSB1601.JYUSB1601CITask

- q -

  • QuadEncoder : JYUSB1601.JYUSB1601CITask

- r -

  • RangeHigh : JYUSB1601.AIChannel
  • RangeLow : JYUSB1601.AIChannel
  • Record : JYUSB1601.JYUSB1601AITask

- s -

  • SampleClock : JYUSB1601.JYUSB1601AITask, JYUSB1601.JYUSB1601AOTask
  • SampleRate : JYUSB1601.JYUSB1601AITask
  • SamplesToAcquire : JYUSB1601.JYUSB1601AITask
  • SamplesToUpdate : JYUSB1601.JYUSB1601AOTask
  • SignalExport : JYUSB1601.JYUSB1601AITask, JYUSB1601.JYUSB1601AOTask
  • Source : JYUSB1601.AIDigitalTrigger, JYUSB1601.AISampleClock, JYUSB1601.AODigitalTrigger, JYUSB1601.AOSampleClock

- t -

  • Terminal : JYUSB1601.AIChannel
  • Threshold : JYUSB1601.EdgeCountingOutEvent
  • TransferedSamples : JYUSB1601.JYUSB1601AITask, JYUSB1601.JYUSB1601AOTask
  • Trigger : JYUSB1601.JYUSB1601AITask, JYUSB1601.JYUSB1601AOTask
  • TwoEdgeSeparation : JYUSB1601.JYUSB1601CITask
  • Type : JYUSB1601.AITrigger, JYUSB1601.AOTrigger, JYUSB1601.JYUSB1601CITask

- u -

  • UpdateRate : JYUSB1601.JYUSB1601AOTask

- z -

  • ZReloadEnabled : JYUSB1601.QuadEncoder


1601 C# Programming Manual: Main Page

1601 C# Programming Manual Documentation


1601 C# Programming Manual: JYUSB1601 Namespace Reference

  • Package List
  • Package Members
Classes | Enumerations
JYUSB1601 Namespace Reference

Classes

class | JYUSB1601AITask
JYUSB1601 Analog Input Task. More...
class | AIChannel
AI Channel parameter class . More...
class | AISampleClock
Sample clock configuration class. More...
class | AIExternalSampleClock
External Sample Clock Configuration Class. More...
class | AITrigger
Clock Terminal. More...
class | AIDigitalTrigger
AI Digital trigger class. More...
class | AIRecord
AI Record Parameters. More...
class | AISignalExport
AI Signal Export Class. More...
class | JYUSB1601AOTask
JYUSB1601 Analog Output Task. More...
class | AOChannel
AO Channel parameter class. More...
class | AOSampleClock
AO Sample clock configuration class. More...
class | AOExternalSampleClock
External Sample Clock Configuration Class. More...
class | AOTrigger
Constructor to create an AOTrigger task object. More...
class | AODigitalTrigger
AO Digital trigger . More...
class | AOSignalExport
AO Signal Export Class. More...
class | JYUSB1601CITask
JYUSB1601 Counter Input Task. More...
class | EdgeCounting
Configure CI EdgeCounting. More...
class | EdgeCountingOutEvent
Edge counting output event configuration class. More...
class | PauseTrigger
Pause trigger configuration class. More...
class | FrequencyMeas
Configure CI Measure. More...
class | PeriodMeas
Configure CI Measure. More...
class | PulseMeas
Configure CI Measure. More...
class | TwoEdgeSeparation
Configure CI Measure. More...
class | QuadEncoder
Configure CI Measure. More...
class | TwoPulseEncoder
Configure CI Measure. More...
class | JYUSB1601COTask
JYUSB1601 Counter Output Task. More...
class | COPulse
Pulse Parameter. More...
class | JYUSB1601DITask
JYUSB1601 Digital Iuput Task. More...
class | DIChannel
DI Channel parameter class . More...
class | JYUSB1601DOTask
JYUSB1601 Digital Output Task. More...
class | DOChannel
DO Channel parameter class . More...

Enumerations

enum | AITerminal { RSE = 0 , Differential = 1 }
AITerminal. More...
enum | AIBandwidth { _39KHz = JYUSB1601Import.JYUSB1601_AI_BandWidth_39K , _15KHz = JYUSB1601Import.JYUSB1601_AI_BandWidth_15K , _80KHz = JYUSB1601Import.JYUSB1601_AI_BandWidth_80K }
AI BandWidth. More...
enum | AITriggerType { Immediate = 0 , Digital = 1 , Soft = 2 }
Trigger Type Digital/Analog/Immediate/Soft. More...
enum | AIDigitalTriggerEdge { Rising = 0 , Falling = 1 , HighLevel = 2 , LowLevel = 3 }
AI Digital Trigger Edge. More...
enum | AIMode { Single = JYUSB1601Import.JYUSB1601_AI_Single , Finite = JYUSB1601Import.JYUSB1601_AI_Finite , Continuous = JYUSB1601Import.JYUSB1601_AI_Continuous , Record = 0x3 }
AIMode. More...
enum | AISampleClockSource { Internal , External }
AI Sample Clock Source. More...
enum AIDigitalTriggerSource {
DIO_0 = 0 , DIO_1 = 1 , DIO_2 = 2 , DIO_3 = 3 ,
DIO_4 = 4 , DIO_5 = 5 , DIO_6 = 6 , DIO_7 = 7 ,
DIO_8 = 8 , DIO_9 = 9 , DIO_10 = 10 , DIO_11 = 11 ,
DIO_12 = 12 , DIO_13 = 13 , DIO_14 = 14 , DIO_15 = 15
}
Output DestinationTerminal. More...
enum | FileFormat { Bin }
Streaming file format. More...
enum | RecordMode { Finite , Infinite }
stream mode .enum Finite/Infinite More...
enum SignalExportDestination {
NONE = -1 , DIO_0 = 0 , DIO_1 = 1 , DIO_2 = 2 ,
DIO_3 = 3 , DIO_4 = 4 , DIO_5 = 5 , DIO_6 = 6 ,
DIO_7 = 7 , DIO_8 = 8 , DIO_9 = 9 , DIO_10 = 10 ,
DIO_11 = 11 , DIO_12 = 12 , DIO_13 = 13 , DIO_14 = 14 ,
DIO_15 = 15
}
Output DestinationTerminal. More...
enum | AISignalExportSource { StartTrig , SampleClock }
AI Signal Export Source. More...
enum | AODigitalTriggerEdge { Rising , Falling , HighLevel = 2 , LowLevel = 3 }
AO Digital Trigger Edge. More...
enum | OutputCompleteState { Zero , Hold }
Output Complete State. More...
enum | AOMode { Single = 3 , Finite = 0 , ContinuousNoWrapping = 2 , ContinuousWrapping = 1 }
AOMode. More...
enum | AOSampleClockSource { Internal , External }
AO Sample Clock Source. More...
enum | AOSignalExportSource { StartTrig = 0 , SampleClock = 1 }
SourceSignal. More...
enum | AOTriggerType { Immediate = 0 , Digital = 1 , Soft = 2 }
TriggerType Digital/Immediate/Soft. More...
enum AODigitalTriggerSource {
DIO_0 = 0 , DIO_1 = 1 , DIO_2 = 2 , DIO_3 = 3 ,
DIO_4 = 4 , DIO_5 = 5 , DIO_6 = 6 , DIO_7 = 7 ,
DIO_8 = 8 , DIO_9 = 9 , DIO_10 = 10 , DIO_11 = 11 ,
DIO_12 = 12 , DIO_13 = 13 , DIO_14 = 14 , DIO_15 = 15
}
Output DestinationTerminal. More...
enum | CountDirection { Up = JYUSB1601Import.JYUSB1601_CI_Count_Up , Down = JYUSB1601Import.JYUSB1601_CI_Count_Down }
Counter direction. More...
enum CIType {
EdgeCounting , Period , Frequency , Pulse ,
TwoEdgeSeparation , QuadEncoder
}
Counter Input Application Type. More...
enum | EdgeType { Rising , Falling , Any }
Edge Type. More...
enum | EdgeCntOunEvtIdleState { LowLevel = 0 , HighLevel = 1 }
Output idle state when the event has not occurred. More...
enum | LevelPolarity { LowLevel = 0 , HighLevel = 1 , None = 2 }
Level Polarity. More...
enum | QuadEncodingType { X2 , X4 }
Quadrature Encoding Type. More...
enum | COIdleState { HighLevel = JYUSB1601Import.JYUSB1601_HighLevel , LowLevel = JYUSB1601Import.JYUSB1601_LowLevel }
Idle state when pulse output before start and after stop. More...
enum | COPulseType { DutyCycleFrequency , HighLowTime , HighLowTick }
Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick. More...

Enumeration Type Documentation

◆ AIBandwidth

enum JYUSB1601.AIBandwidth

AI BandWidth.

Enumerator
_39KHz | 39KHz BandWidth
_15KHz | 15KHz BandWidth
_80KHz | 80KHz BandWidth

◆ AIDigitalTriggerEdge

enum JYUSB1601.AIDigitalTriggerEdge

AI Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.
HighLevel | High Level.
LowLevel | Low Level.

◆ AIDigitalTriggerSource

enum JYUSB1601.AIDigitalTriggerSource

Output DestinationTerminal.

Enumerator
DIO_0 | DIO_0.
DIO_1 | DIO_1.
DIO_2 | DIO_2.
DIO_3 | DIO_3.
DIO_4 | DIO_4.
DIO_5 | DIO_5.
DIO_6 | DIO_6.
DIO_7 | DIO_7.
DIO_8 | DIO_8.
DIO_9 | DIO_9.
DIO_10 | DIO_10.
DIO_11 | DIO_11.
DIO_12 | DIO_12.
DIO_13 | DIO_13.
DIO_14 | DIO_14.
DIO_15 | DIO_15.

◆ AIMode

enum JYUSB1601.AIMode

AIMode.

Enumerator
Single | Single.
Finite | Finite.
Continuous | Continuous.
Record | Record.

◆ AISampleClockSource

enum JYUSB1601.AISampleClockSource

AI Sample Clock Source.

Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ AISignalExportSource

enum JYUSB1601.AISignalExportSource

AI Signal Export Source.

Enumerator
StartTrig | AI_StartTrig.
SampleClock | AI_SampleClock.

◆ AITerminal

enum JYUSB1601.AITerminal

AITerminal.

Enumerator
RSE | RSE.
Differential | Differential.

◆ AITriggerType

enum JYUSB1601.AITriggerType

Trigger Type Digital/Analog/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ AODigitalTriggerEdge

enum JYUSB1601.AODigitalTriggerEdge

AO Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.
HighLevel | High Level.
LowLevel | Low Level.

◆ AODigitalTriggerSource

enum JYUSB1601.AODigitalTriggerSource

Output DestinationTerminal.

Enumerator
DIO_0 | DIO_0.
DIO_1 | DIO_1.
DIO_2 | DIO_2.
DIO_3 | DIO_3.
DIO_4 | DIO_4.
DIO_5 | DIO_5.
DIO_6 | DIO_6.
DIO_7 | DIO_7.
DIO_8 | DIO_8.
DIO_9 | DIO_9.
DIO_10 | DIO_10.
DIO_11 | DIO_11.
DIO_12 | DIO_12.
DIO_13 | DIO_13.
DIO_14 | DIO_14.
DIO_15 | DIO_15.

◆ AOMode

enum JYUSB1601.AOMode

AOMode.

Enumerator
Single | Single.
Finite | Finite.
ContinuousNoWrapping | ContinuousNoWrapping.
ContinuousWrapping | ContinuousWrapping.

◆ AOSampleClockSource

enum JYUSB1601.AOSampleClockSource

AO Sample Clock Source.

Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ AOSignalExportSource

enum JYUSB1601.AOSignalExportSource

SourceSignal.

Enumerator
StartTrig | AO_StartTrig.
SampleClock | AO_SampleClock.

◆ AOTriggerType

enum JYUSB1601.AOTriggerType

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ CIType

enum JYUSB1601.CIType

Counter Input Application Type.

Enumerator
EdgeCounting | Edge Counting.
Period | Period Measure.
Frequency | Frequenc Measure.
Pulse | Pulse Measure.
TwoEdgeSeparation | TwoEdgeSeparation Measure.
QuadEncoder | QuadEncoder.

◆ COIdleState

enum JYUSB1601.COIdleState

Idle state when pulse output before start and after stop.

Enumerator
HighLevel | Idle state is high level.
LowLevel | Idle state is low level.

◆ COPulseType

enum JYUSB1601.COPulseType

Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick.

Enumerator
DutyCycleFrequency | Configure CO output pulse according to its DutyCycle and Freqency.
HighLowTime | Configure CO output pulse according to duration of its high/low voltage levels.
HighLowTick | Configure CO output pulse according to its high/low tick level.

◆ CountDirection

enum JYUSB1601.CountDirection

Counter direction.

enum Up/Down/External

Enumerator
Up | Counter increases.
Down | Counter decreases.

◆ EdgeCntOunEvtIdleState

enum JYUSB1601.EdgeCntOunEvtIdleState

Output idle state when the event has not occurred.

Enumerator
LowLevel | Idle state is low level.
HighLevel | Idle state is high level.

◆ EdgeType

enum JYUSB1601.EdgeType

Edge Type.

Enumerator
Rising | Rising Edge.
Falling | Falling Edge.
Any | Any Edge.

◆ FileFormat

enum JYUSB1601.FileFormat

Streaming file format.

enum BIN.

Enumerator
Bin

BIN。

BIN.

◆ LevelPolarity

enum JYUSB1601.LevelPolarity

Level Polarity.

Enumerator
LowLevel | Low level.
HighLevel | High level.
None | No active polarity.

◆ OutputCompleteState

enum JYUSB1601.OutputCompleteState

Output Complete State.

Enumerator
Zero | Output Complete Zero.
Hold | Output Complete Hold in The last point.

◆ QuadEncodingType

enum JYUSB1601.QuadEncodingType

Quadrature Encoding Type.

Enumerator
X2 | X2.
X4 | X4.

◆ RecordMode

enum JYUSB1601.RecordMode

stream mode .enum Finite/Infinite

Enumerator
Finite | Finite Streaming.
Infinite | Infinite Streaming.

◆ SignalExportDestination

enum JYUSB1601.SignalExportDestination

Output DestinationTerminal.

Enumerator
NONE |
DIO_0 | DIO_0.
DIO_1 | DIO_1.
DIO_2 | DIO_2.
DIO_3 | DIO_3.
DIO_4 | DIO_4.
DIO_5 | DIO_5.
DIO_6 | DIO_6.
DIO_7 | DIO_7.
DIO_8 | DIO_8.
DIO_9 | DIO_9.
DIO_10 | DIO_10.
DIO_11 | DIO_11.
DIO_12 | DIO_12.
DIO_13 | DIO_13.
DIO_14 | DIO_14.
DIO_15 | DIO_15.


1601 C# Programming Manual: Package Members

  • Package List
  • Package Members
  • All
  • Enumerations
Here is a list of all namespace members with links to the namespace documentation for each member:
  • AIBandwidth : JYUSB1601
  • AIDigitalTriggerEdge : JYUSB1601
  • AIDigitalTriggerSource : JYUSB1601
  • AIMode : JYUSB1601
  • AISampleClockSource : JYUSB1601
  • AISignalExportSource : JYUSB1601
  • AITerminal : JYUSB1601
  • AITriggerType : JYUSB1601
  • AODigitalTriggerEdge : JYUSB1601
  • AODigitalTriggerSource : JYUSB1601
  • AOMode : JYUSB1601
  • AOSampleClockSource : JYUSB1601
  • AOSignalExportSource : JYUSB1601
  • AOTriggerType : JYUSB1601
  • CIType : JYUSB1601
  • COIdleState : JYUSB1601
  • COPulseType : JYUSB1601
  • CountDirection : JYUSB1601
  • EdgeCntOunEvtIdleState : JYUSB1601
  • EdgeType : JYUSB1601
  • FileFormat : JYUSB1601
  • LevelPolarity : JYUSB1601
  • OutputCompleteState : JYUSB1601
  • QuadEncodingType : JYUSB1601
  • RecordMode : JYUSB1601
  • SignalExportDestination : JYUSB1601


1601 C# Programming Manual: Package Members

  • Package List
  • Package Members
  • All
  • Enumerations
Here is a list of all namespace enums with links to the namespace documentation for each enum:
  • AIBandwidth : JYUSB1601
  • AIDigitalTriggerEdge : JYUSB1601
  • AIDigitalTriggerSource : JYUSB1601
  • AIMode : JYUSB1601
  • AISampleClockSource : JYUSB1601
  • AISignalExportSource : JYUSB1601
  • AITerminal : JYUSB1601
  • AITriggerType : JYUSB1601
  • AODigitalTriggerEdge : JYUSB1601
  • AODigitalTriggerSource : JYUSB1601
  • AOMode : JYUSB1601
  • AOSampleClockSource : JYUSB1601
  • AOSignalExportSource : JYUSB1601
  • AOTriggerType : JYUSB1601
  • CIType : JYUSB1601
  • COIdleState : JYUSB1601
  • COPulseType : JYUSB1601
  • CountDirection : JYUSB1601
  • EdgeCntOunEvtIdleState : JYUSB1601
  • EdgeType : JYUSB1601
  • FileFormat : JYUSB1601
  • LevelPolarity : JYUSB1601
  • OutputCompleteState : JYUSB1601
  • QuadEncodingType : JYUSB1601
  • RecordMode : JYUSB1601
  • SignalExportDestination : JYUSB1601


1601 C# Programming Manual: Package List

  • Package List
  • Package Members
Package List
Here are the packages with brief descriptions (if available):
N JYUSB1601