5101 C++ Programming Manual: D:/OneDrive/Desktop/产品文档/CHM/5101/C++/JY5101.h File Reference

5101 C++ Programming Manual
  • Main Page
  • Files
  • File List
  • File Members
  • OneDrive
  • Desktop
  • 产品文档
  • CHM
  • 5101
  • C++
Typedefs | Enumerations | Functions
JY5101.h File Reference

@SectionBegin JY5101 FileHead More...

Typedefs

typedef void * JY5101_DeviceHandle
@SectionEnd JY5101_Device FileHead

Enumerations

enum | JY5101_AI_SampleMode { JY5101_AI_Finite = 0x0 , JY5101_AI_Continuous = 0x1 , JY5101_AI_Single = 0x2 }
enum | JY5101_AI_BandWidth { JY5101_AI_BandWidth_39K = 0x0 , JY5101_AI_BandWidth_15K = 0x1 , JY5101_AI_BandWidth_376K = 0x2 }
enum | JY5101_AI_Terminal { JY5101_AI_RSE = 0x0 , JY5101_AI_Diff = 0x1 }
enum | JY5101_AI_TriggerType { JY5101_AI_Immediately = 0x0 , JY5101_AI_Digital = 0x1 , JY5101_AI_Analog = 0x2 , JY5101_AI_Soft = 0x3 }
enum | JY5101_AO_UpdateMode { JY5101_AO_Finite = 0x0 , JY5101_AO_ContinuousWrapping = 0x1 , JY5101_AO_ContinuousNoWrapping = 0x2 , JY5101_AO_Single = 0x3 }
enum | JY5101_TriggerType { JY5101_AO_Immediately = 0x0 , JY5101_AO_Digital = 0x1 , JY5101_AO_Soft = 0x3 }
enum | JY5101_CI_SampleMode { JY5101_CI_Finite = 0x0 , JY5101_CI_Continuous = 0x1 , JY5101_CI_Single = 0x2 }
enum JY5101_CI_MeasureType {
JY5101_CI_EdgeCount = 0 , JY5101_CI_Measure_FrequencyOrPeriod = 1 , JY5101_CI_Measure_PulseWidth = 2 , JY5101_CI_Measure_SemiPeriod = 3 ,
JY5101_CI_Measure_EdgeSeparation = 4 , JY5101_CI_EncoderX1 = 5 , JY5101_CI_EncoderX2 = 6 , JY5101_CI_EncoderX4 = 7 ,
JY5101_CI_EncoderTwoPulse = 8
}
enum | JY5101_CountDirection { JY5101_CI_Count_Up , JY5101_CI_Count_Down , JY5101_CI_Count_External }
enum | JY5101_CI_SampleClock { JY5101_CI_ImplicitClock , JY5101_CI_InternalClock , JY5101_CI_ExternalClock }
enum | JY5101_CI_CounterEventSignalIdleState { JY5101_CI_CounterEventSignalIdleState_Low = 0 , JY5101_CI_CounterEventSignalIdleState_High = 1 }
enum | JY5101_CI_ValueReturnMode { JY5101_CI_ReturnTwoValue = 0 , JY5101_CI_ReturnOneValue = 1 }
enum | JY5101_CI_CounterLevel { JY5101_CI_CounterLevel_Low = 0 , JY5101_CI_CounterLevel_High = 1 }
CI Counter Event Signal Idle State. More...
enum | JY5101_LevelState { JY5101_LowLevel = 0 , JY5101_HighLevel = 1 }
enum | JY5101_CI_StartingEdge { JY5101_RisingEdge = 0 , JY5101_FallingEdge = 1 , JY5101_AnyEdge = 2 }
enum | JY5101_CountTimeBase { JY5101_Internal_Timebase_100M = 0 , JY5101_Internal_Timebase_5M = 1 , JY5101_Internal_Timebase_100K = 2 , JY5101_External_Timebase = 3 }
enum | JY5101_CO_IdleState { JY5101_CO_LowLevel = 0 , JY5101_CO_HighLevel = 1 }
enum | JY5101_CIO_TriggerType { JY5101_CIO_Immediately = 0x0 , JY5101_CIO_Digital = 0x1 , JY5101_CIO_Soft = 0x3 }
enum | JY5101_CO_PauseTriger_OutState { JY5101_CO_HoldOn = 0x0 , JY5101_CO_HighOut = 0x1 , JY5101_CO_LowOut = 0x2 }
enum JY5101_Capability_Item {
JY5101_AI_NumberOfChannels_Int = 0 , JY5101_AI_MaxSampleRate_Double = 1 , JY5101_AI_MinSampleRate_Double = 2 , JY5101_AI_ChannelGroups_Int = 3 ,
JY5101_ADCCount_Int = 4
}
enum | JY5101_OutputCompleteState { JY5101_Zero = 0x0 , JY5101_Hold = 0x1 }
enum | JY5101_TriggerMode { JY5101_StartTrigger = 0x0 , JY5101_ReferenceTrigger = 0x1 }
enum JY5101_InputTerminal {
JY5101_PFI0_Input = 0 , JY5101_PFI1_Input = 1 , JY5101_PFI2_Input = 2 , JY5101_PFI3_Input = 3 ,
JY5101_PFI4_Input = 4 , JY5101_PFI5_Input = 5 , JY5101_PFI6_Input = 6 , JY5101_PFI7_Input = 7 ,
JY5101_PFI8_Input = 8 , JY5101_PFI9_Input = 9 , JY5101_PFI10_Input = 10 , JY5101_PFI11_Input = 11 ,
JY5101_PFI12_Input = 12 , JY5101_PFI13_Input = 13 , JY5101_PFI14_Input = 14 , JY5101_PFI15_Input = 15 ,
JY5101_PFI16_Input = 16 , JY5101_PFI17_Input = 17 , JY5101_PFI18_Input = 18 , JY5101_PFI19_Input = 19 ,
JY5101_PFI20_Input = 20 , JY5101_PFI21_Input = 21 , JY5101_PFI22_Input = 22 , JY5101_PFI23_Input = 23 ,
JY5101_PXI_Trig0_Input = 24 , JY5101_PXI_Trig1_Input = 25 , JY5101_PXI_Trig2_Input = 26 , JY5101_PXI_Trig3_Input = 27 ,
JY5101_PXI_Trig4_Input = 28 , JY5101_PXI_Trig5_Input = 29 , JY5101_PXI_Trig6_Input = 30 , JY5101_PXI_Trig7_Input = 31 ,
JY5101_AI_SampleClock_Input = 32 , JY5101_AO_SampleClock_Input = 33 , JY5101_CI_0_SampleClock_Input = 34 , JY5101_CI_1_SampleClock_Input = 35 ,
JY5101_CO_0_Output_Input = 36 , JY5101_CO_1_Output_Input = 37 , JY5101_CIO_100MHz_Input = 38 , JY5101_CIO_5MHz_Input = 39 ,
JY5101_CIO_100kHz_Input = 40
}
enum JY5101_DigitalTriggerSource {
JY5101_PFI0 = 0 , JY5101_PFI1 = 1 , JY5101_PFI2 = 2 , JY5101_PFI3 = 3 ,
JY5101_PFI4 = 4 , JY5101_PFI5 = 5 , JY5101_PFI6 = 6 , JY5101_PFI7 = 7 ,
JY5101_PFI8 = 8 , JY5101_PFI9 = 9 , JY5101_PFI10 = 10 , JY5101_PFI11 = 11 ,
JY5101_PFI12 = 12 , JY5101_PFI13 = 13 , JY5101_PFI14 = 14 , JY5101_PFI15 = 15 ,
JY5101_PFI16 = 16 , JY5101_PFI17 = 17 , JY5101_PFI18 = 18 , JY5101_PFI19 = 19 ,
JY5101_PFI20 = 20 , JY5101_PFI21 = 21 , JY5101_PFI22 = 22 , JY5101_PFI23 = 23 ,
JY5101_PXI_Trig0 = 24 , JY5101_PXI_Trig1 = 25 , JY5101_PXI_Trig2 = 26 , JY5101_PXI_Trig3 = 27 ,
JY5101_PXI_Trig4 = 28 , JY5101_PXI_Trig5 = 29 , JY5101_PXI_Trig6 = 30 , JY5101_PXI_Trig7 = 31 ,
JY5101_Inter_AI_StartTrig = 32 , JY5101_Inter_AI_ReferenceTrig = 33 , JY5101_Inter_AO_StartTrig = 34 , JY5101_Inter_Counter_0_StartTrig = 35 ,
JY5101_Inter_Counter_1_StartTrig = 36 , JY5101_Inter_Counter_0_Out = 37 , JY5101_Inter_Counter_1_Out = 38 , JY5101_Inter_Counter_0_EventOut = 39 ,
JY5101_Inter_Counter_1_EventOut = 40
}
enum | JY5101_DigitalTriggerEdge { JY5101_Rising = 0x0 , JY5101_Falling = 0x1 }
enum JY5101_AnalogTriggerSource {
JY5101_Channel_0 = 0 , JY5101_Channel_1 = 1 , JY5101_Channel_2 = 2 , JY5101_Channel_3 = 3 ,
JY5101_Channel_4 = 4 , JY5101_Channel_5 = 5 , JY5101_Channel_6 = 6 , JY5101_Channel_7 = 7 ,
JY5101_Channel_8 = 8 , JY5101_Channel_9 = 9 , JY5101_Channel_10 = 10 , JY5101_Channel_11 = 11 ,
JY5101_Channel_12 = 12 , JY5101_Channel_13 = 13 , JY5101_Channel_14 = 14 , JY5101_Channel_15 = 15 ,
JY5101_Channel_16 = 16 , JY5101_Channel_17 = 17 , JY5101_Channel_18 = 18 , JY5101_Channel_19 = 19 ,
JY5101_Channel_20 = 20 , JY5101_Channel_21 = 21 , JY5101_Channel_22 = 22 , JY5101_Channel_23 = 23 ,
JY5101_Channel_24 = 24 , JY5101_Channel_25 = 25 , JY5101_Channel_26 = 26 , JY5101_Channel_27 = 27 ,
JY5101_Channel_28 = 28 , JY5101_Channel_29 = 29 , JY5101_Channel_30 = 30 , JY5101_Channel_31 = 31
}
enum | JY5101_AnalogWindowCondition { JY5101_Entering = 0x0 , JY5101_Leaving = 0x1 }
enum | JY5101_AnalogTriggerEdge { JY5101_RisingSlope = 0x0 , JY5101_FallingSlope = 0x1 }
enum | JY5101_ClockSource { JY5101_InternalClock = 0x0 , JY5101_ExternalClock = 0x1 }
enum | JY5101_ReferenceClock { JY5101_Internal = 0x0 , JY5101_PXIe_Clk100 = 0x1 }
enum JY5101_ExternalClockTerminal {
JY5101_ECLK = 10000 , JY5101_Clock_PFI_0 = 0 , JY5101_Clock_PFI_1 = 1 , JY5101_Clock_PFI_2 = 2 ,
JY5101_Clock_PFI_3 = 3 , JY5101_Clock_PFI_4 = 4 , JY5101_Clock_PFI_5 = 5 , JY5101_Clock_PFI_6 = 6 ,
JY5101_Clock_PFI_7 = 7 , JY5101_Clock_PFI_8 = 8 , JY5101_Clock_PFI_9 = 9 , JY5101_Clock_PFI_10 = 10 ,
JY5101_Clock_PFI_11 = 11 , JY5101_Clock_PFI_12 = 12 , JY5101_Clock_PFI_13 = 13 , JY5101_Clock_PFI_14 = 14 ,
JY5101_Clock_PFI_15 = 15 , JY5101_Clock_PFI_16 = 16 , JY5101_Clock_PFI_17 = 17 , JY5101_Clock_PFI_18 = 18 ,
JY5101_Clock_PFI_19 = 19 , JY5101_Clock_PFI_20 = 20 , JY5101_Clock_PFI_21 = 21 , JY5101_Clock_PFI_22 = 22 ,
JY5101_Clock_PFI_23 = 23 , JY5101_Clock_PXI_Trig_0 = 24 , JY5101_Clock_PXI_Trig_1 = 25 , JY5101_Clock_PXI_Trig_2 = 26 ,
JY5101_Clock_PXI_Trig_3 = 27 , JY5101_Clock_PXI_Trig_4 = 28 , JY5101_Clock_PXI_Trig_5 = 29 , JY5101_Clock_PXI_Trig_6 = 30 ,
JY5101_Clock_PXI_Trig_7 = 31 , JY5101_Clock_AI_SampleClock = 32 , JY5101_Clock_AO_SampleClock = 33 , JY5101_Clock_CI_0_SampleClock = 34 ,
JY5101_Clock_CI_1_SampleClock = 35 , JY5101_Clock_CO_0_Output = 36 , JY5101_Clock_CO_1_Output = 37
}
enum JY5101_Signal_Source {
JY5101_Signal_PFI_0 = 0 , JY5101_Signal_PFI_1 = 1 , JY5101_Signal_PFI_2 = 2 , JY5101_Signal_PFI_3 = 3 ,
JY5101_Signal_PFI_4 = 4 , JY5101_Signal_PFI_5 = 5 , JY5101_Signal_PFI_6 = 6 , JY5101_Signal_PFI_7 = 7 ,
JY5101_Signal_PFI_8 = 8 , JY5101_Signal_PFI_9 = 9 , JY5101_Signal_PFI_10 = 10 , JY5101_Signal_PFI_11 = 11 ,
JY5101_Signal_PFI_12 = 12 , JY5101_Signal_PFI_13 = 13 , JY5101_Signal_PFI_14 = 14 , JY5101_Signal_PFI_15 = 15 ,
JY5101_Signal_PFI_16 = 16 , JY5101_Signal_PFI_17 = 17 , JY5101_Signal_PFI_18 = 18 , JY5101_Signal_PFI_19 = 19 ,
JY5101_Signal_PFI_20 = 20 , JY5101_Signal_PFI_21 = 21 , JY5101_Signal_PFI_22 = 22 , JY5101_Signal_PFI_23 = 23 ,
JY5101_Signal_PXI_Trig_0 = 24 , JY5101_Signal_PXI_Trig_1 = 25 , JY5101_Signal_PXI_Trig_2 = 26 , JY5101_Signal_PXI_Trig_3 = 27 ,
JY5101_Signal_PXI_Trig_4 = 28 , JY5101_Signal_PXI_Trig_5 = 29 , JY5101_Signal_PXI_Trig_6 = 30 , JY5101_Signal_PXI_Trig_7 = 31 ,
JY5101_Signal_AI_StartTrig = 32 , JY5101_Signal_AI_ReferenceTrig = 33 , JY5101_Signal_AO_StartTrig = 34 , JY5101_Signal_CIO_0_StartTrig = 35 ,
JY5101_Signal_CIO_1_StartTrig = 36 , JY5101_Signal_AI_SampleClock = 37 , JY5101_Signal_AO_SampleClock = 38 , JY5101_Signal_CI_0_SampleClock = 39 ,
JY5101_Signal_CI_1_SampleClock = 40 , JY5101_Signal_CO_0_Output = 41 , JY5101_Signal_CO_1_Output = 42 , JY5101_Signal_CIO_100MHz = 43 ,
JY5101_Signal_CIO_5MHz = 44 , JY5101_Signal_CIO_100kHz = 45 , JY5101_Signa_Counter_0_EventOut = 46 , JY5101_Signa_Counter_1_EventOut = 47
}
enum JY5101_Signal_Destination {
JY5101_PFI0_OUT = 0 , JY5101_PFI1_OUT = 1 , JY5101_PFI2_OUT = 2 , JY5101_PFI3_OUT = 3 ,
JY5101_PFI4_OUT = 4 , JY5101_PFI5_OUT = 5 , JY5101_PFI6_OUT = 6 , JY5101_PFI7_OUT = 7 ,
JY5101_PFI8_OUT = 8 , JY5101_PFI9_OUT = 9 , JY5101_PFI10_OUT = 10 , JY5101_PFI11_OUT = 11 ,
JY5101_PFI12_OUT = 12 , JY5101_PFI13_OUT = 13 , JY5101_PFI14_OUT = 14 , JY5101_PFI15_OUT = 15 ,
JY5101_PFI16_OUT = 16 , JY5101_PFI17_OUT = 17 , JY5101_PFI18_OUT = 18 , JY5101_PFI19_OUT = 19 ,
JY5101_PFI20_OUT = 20 , JY5101_PFI21_OUT = 21 , JY5101_PFI22_OUT = 22 , JY5101_PFI23_OUT = 23 ,
JY5101_PXITrig0_OUT = 24 , JY5101_PXITrig1_OUT = 25 , JY5101_PXITrig2_OUT = 26 , JY5101_PXITrig3_OUT = 27 ,
JY5101_PXITrig4_OUT = 28 , JY5101_PXITrig5_OUT = 29 , JY5101_PXITrig6_OUT = 30 , JY5101_PXITrig7_OUT = 31 ,
JY5101_None = 32
}
enum | JY5101_MultiChannelCompositionLogic { JY5101_Or = 0 , JY5101_And = 1 }

Functions

JY5101API int | JY5101_Open (int slotNumber, JY5101_DeviceHandle *hDevice)
Open the 5101 devices using the slot number or the device serial number.
JY5101API int | JY5101_OpenByName (const char *cardName, JY5101_DeviceHandle *hDevice)
Open this 5101 devices using the device alias name which is set by JYTEK utility JYDM.
JY5101API int | JY5101_GetDeviceInfo (JY5101_DeviceHandle hDevice, unsigned char *info)
获取设备信息
JY5101API int | JY5101_GetDeviceID (JY5101_DeviceHandle hDevice, int *deviceID)
Obtain the device ID.
JY5101API int | JY5101_GetDeviceSerialNumber (JY5101_DeviceHandle hDevice, char *serialNumber, int length)
Obtain the device serialNumber.
JY5101API int | JY5101_SetDeviceStatusLed (JY5101_DeviceHandle hDevice, bool enable, unsigned int frequency)
Control Front Panel Status Led.
JY5101API int | JY5101_Close (JY5101_DeviceHandle hDevice)
Close this 5101 device.
JY5101API int | JY5101_GetCapabilityIntBySlotNumber (int slotNumber, JY5101_Capability_Item item, int *value, bool setDefaultIfDeviceNotFound=true)
在不打开设备的情况下，获取位于指定卡槽号的设备的能力信息中的整型数值参数，比如通道数
JY5101API int | JY5101_GetCapabilityDoubleBySlotNumber (int slotNumber, JY5101_Capability_Item item, double *value, bool setDefaultIfDeviceNotFound=true)
在不打开设备的情况下，获取位于指定卡槽号的设备的能力信息中的浮点型数值参数，比如最高采样率
JY5101API int | JY5101_GetCapabilityIntByName (const char *deviceName, JY5101_Capability_Item item, int *value, bool setDefaultIfDeviceNotFound=true)
在不打开设备的情况下，获取指定别名的设备的能力信息中的整型数值参数，比如通道数
JY5101API int | JY5101_GetCapabilityDoubleByName (const char *deviceName, JY5101_Capability_Item item, double *value, bool setDefaultIfDeviceNotFound=true)
在不打开设备的情况下，获取指定别名的设备的能力信息中的浮点型数值参数，比如最高采样率
JY5101API int | JY5101_GetCapabilityInt (JY5101_DeviceHandle hDevice, JY5101_Capability_Item item, int *value)
获取当前设备的能力信息中的整型数值参数，比如通道数
JY5101API int | JY5101_GetCapabilityDouble (JY5101_DeviceHandle hDevice, JY5101_Capability_Item item, double *value)
获取当前设备的能力信息，比如最高采样率
JY5101API int | JY5101_SignalRouting (JY5101_DeviceHandle hDevice, JY5101_Signal_Source source, JY5101_Signal_Destination destination)
Route a singal from source to destination.
JY5101API int | JY5101_DisconnectSignalRouting (JY5101_DeviceHandle hDevice, JY5101_Signal_Destination destination)
Disconnect an established routing.
JY5101API int | JY5101_AI_EnableChannel (JY5101_DeviceHandle hDevice, unsigned int channelCount, unsigned char *channels, double *lowRegion, double *highRegion, JY5101_AI_Terminal terminal, JY5101_AI_BandWidth bandWidth)
Enable AI channels.
JY5101API int | JY5101_AI_SetMode (JY5101_DeviceHandle hDevice, JY5101_AI_SampleMode mode)
Set AI sampling mode.
JY5101API int | JY5101_AI_SetSampleRate (JY5101_DeviceHandle hDevice, double sampleRate, double *actualSampleRate)
Set sampling rate.
JY5101API int | JY5101_AI_SetSamplesToAcquire (JY5101_DeviceHandle hDevice, unsigned int sampleToAcquire)
Set convert rate.
JY5101API int | JY5101_AI_SetDSMode (JY5101_DeviceHandle hDevice, bool enable)
Set AI DSMode enable.default : disable(false).
JY5101API int | JY5101_AI_Start (JY5101_DeviceHandle hDevice)
Start AI acquisition.
JY5101API int | JY5101_AI_ReadData (JY5101_DeviceHandle hDevice, double *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
Read AI data to user defined data buffer.
JY5101API int | JY5101_AI_Stop (JY5101_DeviceHandle hDevice)
Stop AI acquisition.
JY5101API int | JY5101_AI_ReadRawData (JY5101_DeviceHandle hDevice, short *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
Read AI raw data to user defined data buffer.
JY5101API int | JY5101_AI_SetSampleClock (JY5101_DeviceHandle hDevice, JY5101_ClockSource clockSource, JY5101_ExternalClockTerminal terminal, double expectedRate)
Set AI sampling clock source.
JY5101API int | JY5101_AI_ReadSinglePoint (JY5101_DeviceHandle hDevice, double *readValue, int channelID)
Read single point for each channel to user defined data buffer.
JY5101API int | JY5101_AI_ReadRawSinglePoint (JY5101_DeviceHandle hDevice, short *readValue, int channelID)
Read raw single point for each channel to user defined data buffer.
JY5101API int | JY5101_AI_SetStartTriggerType (JY5101_DeviceHandle hDevice, JY5101_AI_TriggerType triggerType)
Set AI start trigger type,the triggerType is defined by enum JY5101_AI_TriggerType.
JY5101API int | JY5101_AI_SetDigitalStartTrigger (JY5101_DeviceHandle hDevice, JY5101_DigitalTriggerSource triggerSource, JY5101_DigitalTriggerEdge triggerEdge)
Set AI digital start trigger,the triggerSource is defined by enum JY5101_DigitalTriggerSource, the triggerEdge is defined by enum JY5101_DigitalTriggerEdge.
JY5101API int | JY5101_AI_SetAnalogWindowStartTrigger (JY5101_DeviceHandle hDevice, JY5101_AnalogTriggerSource triggerSource, JY5101_AnalogWindowCondition triggerCondition, double highThreshold, double lowThreshold)
Set AI analog window start trigger,the triggerSource is defined by enum JY5101_AnalogTriggerSource, the triggerCondition is defined by enum JY5101_AnalogWindowCondition.
JY5101API int | JY5101_AI_SetAnalogHysteresisStartTrigger (JY5101_DeviceHandle hDevice, JY5101_AnalogTriggerSource triggerSource, JY5101_AnalogTriggerEdge triggerEdge, double highThreshold, double lowThreshold)
Set AI analog hysteresis start trigger,the triggerSource is defined by enum JY5101_AnalogTriggerSource, the triggerEdge is defined by enum JY5101_AnalogTriggerEdge.
JY5101API int | JY5101_AI_SetAnalogEdgeStartTrigger (JY5101_DeviceHandle hDevice, JY5101_AnalogTriggerSource triggerSource, JY5101_AnalogTriggerEdge triggerEdge, double threshold)
Set AI analog edge start trigger,the triggerSource is defined by enum JY5101_AnalogTriggerSource, the triggerEdge is defined by enum JY5101_AnalogTriggerEdge.
JY5101API int | JY5101_AI_SetReferenceTriggerType (JY5101_DeviceHandle hDevice, JY5101_AI_TriggerType triggerType)
Set AI reference trigger type,the triggerType is defined by enum JY5101_AI_TriggerType.
JY5101API int | JY5101_AI_SetDigitalReferenceTrigger (JY5101_DeviceHandle hDevice, JY5101_DigitalTriggerSource triggerSource, JY5101_DigitalTriggerEdge triggerEdge)
Set AI digital reference trigger.the triggerSource is defined by enum JY5101_DigitalTriggerSource, the triggerEdge is defined by enum JY5101_DigitalTriggerEdge.
JY5101API int | JY5101_AI_SetAnalogWindowReferenceTrigger (JY5101_DeviceHandle hDevice, JY5101_AnalogTriggerSource triggerSource, JY5101_AnalogWindowCondition triggerCondition, double highThreshold, double lowThreshold)
Set AI analog window reference trigger,the triggerSource is defined by enum JY5101_AnalogTriggerSource, the triggerCondition is defined by enum JY5101_AnalogWindowCondition.
JY5101API int | JY5101_AI_SetAnalogHysteresisReferenceTrigger (JY5101_DeviceHandle hDevice, JY5101_AnalogTriggerSource triggerSource, JY5101_AnalogTriggerEdge triggerEdge, double highThreshold, double lowThreshold)
Set AI analog hysteresis reference trigger,the triggerSource is defined by enum JY5101_AnalogTriggerSource, the triggerEdge is defined by enum JY5101_AnalogTriggerEdge.
JY5101API int | JY5101_AI_SetAnalogEdgeReferenceTrigger (JY5101_DeviceHandle hDevice, JY5101_AnalogTriggerSource triggerSource, JY5101_AnalogTriggerEdge triggerEdge, double threshold)
Set AI analog edge window reference trigger,the triggerSource is defined by enum JY5101_AnalogTriggerSource, the triggerEdge is defined by enum JY5101_AnalogTriggerEdge.
JY5101API int | JY5101_AI_SetAnalogTriggerMultiChannelMode (JY5101_DeviceHandle hDevice, bool enableMultiChannelTriggerMode, JY5101_MultiChannelCompositionLogic resultLogic)
Enable the trigger mode for multiple channels.
JY5101API int | JY5101_AI_SetPreTriggerSamples (JY5101_DeviceHandle hDevice, unsigned int preTriggerSamples)
Set AI pretrigger samples, the samples must greater than 0.
JY5101API int | JY5101_AI_SetReTriggerCount (JY5101_DeviceHandle hDevice, unsigned long long reTriggerCount)
Set AI retrigger count.
JY5101API int | JY5101_AI_SendSoftTrigger (JY5101_DeviceHandle hDevice, JY5101_TriggerMode triggerMode)
Send the software trigger signal.
JY5101API int | JY5101_AI_WaitUntilDone (JY5101_DeviceHandle hDevice, bool *done)
Check if AI acquisition is completed in finite mode.
JY5101API int | JY5101_AI_CheckBufferStatus (JY5101_DeviceHandle hDevice, unsigned long long *avaliableSamples, unsigned long long *transferedSamples, bool *overrun)
Check AI task buffer status.
JY5101API int | JY5101_DisableAICalibration (JY5101_DeviceHandle hDevice, bool DisableCalibration)
Disable AI calibration coefficient, default enable calibration coefficient.
JY5101API int | JY5101_DI_AddLines (JY5101_DeviceHandle hDevice, unsigned int *line, unsigned int lineCount)
Enabled DI channels.
JY5101API int | JY5101_DI_ReadSinglePoint (JY5101_DeviceHandle hDevice, bool *readValues, int lineID)
read single data from a single line by lineID defined.if the lineID == -1,read all line data.The data type is bool, one bool defined one line status.
JY5101API int | JY5101_DI_ReadSinglePoint_U32 (JY5101_DeviceHandle hDevice, unsigned long *readValue)
read single data from a single port by portID defined.if the portID == -1,read all port data.The data type is unsigned long long,There are 3 ports, from 0 to 2.
JY5101API int | JY5101_DI_Start (JY5101_DeviceHandle hDevice)
Start DI acquisition.
JY5101API int | JY5101_DI_Stop (JY5101_DeviceHandle hDevice)
Stop DI acquisition.
JY5101API int | JY5101_DO_AddLines (JY5101_DeviceHandle hDevice, unsigned int *line, unsigned int lineCount)
Enabled DO channels.
JY5101API int | JY5101_DO_WriteSinglePoint (JY5101_DeviceHandle hDevice, bool *writeValues, int lineID)
Write single data to the line by lineID defined.if the lineID == -1,write all line data(enabled channels in function JY5101_DI_AddLines).
JY5101API int | JY5101_DO_WriteSinglePoint_U32 (JY5101_DeviceHandle hDevice, unsigned int writeValue)
Write single data to the line by lineID defined.if the lineID == -1,write all line data(enabled channels in function JY5101_DI_AddLines) There are a total of 24 lines from 0 to 23.
JY5101API int | JY5101_DO_ReadSinglePoint (JY5101_DeviceHandle hDevice, bool *readValues, int lineID)
read single data from a single port by portID defined.if the portID == -1,read all port data.The data type is bool, one bool defined one line status.
JY5101API int | JY5101_DO_ReadSinglePoint_U32 (JY5101_DeviceHandle hDevice, unsigned long *readValue)
read single data from a single port by portID defined.if the portID == -1,read all port data.The data type is unsigned long long,There are 3 ports, from 0 to 2.
JY5101API int | JY5101_DO_Start (JY5101_DeviceHandle hDevice)
Start digital signal output.
JY5101API int | JY5101_DO_Stop (JY5101_DeviceHandle hDevice)
Stop digital signal output.
JY5101API int | JY5101_AO_EnableChannel (JY5101_DeviceHandle hDevice, unsigned int channelCount, unsigned char *channels, double *lowRegion, double *highRegion)
Enables AO channels.
JY5101API int | JY5101_AO_SetUpdateRate (JY5101_DeviceHandle hDevice, double updateRate, double *actualUpdateRate)
Set AO update rate for each channel.
JY5101API int | JY5101_AO_SetMode (JY5101_DeviceHandle hDevice, JY5101_AO_UpdateMode mode)
Set AO mode, the mode defined by enum JY5101_AO_UpdateMode.
JY5101API int | JY5101_AO_SetSamplesToUpdate (JY5101_DeviceHandle hDevice, unsigned int sampleToUpdate)
Set AO samples for each channel in the finite mode.The sample range is from 1 to 32M / channelCount samples.
JY5101API int | JY5101_AO_Start (JY5101_DeviceHandle hDevice)
Start digital signal output.
JY5101API int | JY5101_AO_WriteRawData (JY5101_DeviceHandle hDevice, short *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualWriteLength)
AO write raw data.The data is interleaved in the buffer in channel order for multi-channel.
JY5101API int | JY5101_AO_WriteData (JY5101_DeviceHandle hDevice, double *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualWriteLength)
AO writes data.The data is interleaved in the buffer the order defined by JY5101_AO_EnableChannel.
JY5101API int | JY5101_AO_Stop (JY5101_DeviceHandle hDevice)
Stop analog signal output.
JY5101API int | JY5101_AO_SetSampleClock (JY5101_DeviceHandle hDevice, JY5101_ClockSource clockSource, JY5101_ExternalClockTerminal terminal, double expectedRate)
Set AO sampling clock source.
JY5101API int | JY5101_AO_WriteRawSinglePoint (JY5101_DeviceHandle hDevice, short *writeValues, int channelID)
AO write single point raw data to the defined channel by channelID, if channelID == -1, write all enable channel.
JY5101API int | JY5101_AO_WriteSinglePoint (JY5101_DeviceHandle hDevice, double *writeValues, int channelID)
AO write single point data to the defined channel by channelID, if channelID == -1, write all enable channel one data.
JY5101API int | JY5101_AO_SetStartTriggerType (JY5101_DeviceHandle hDevice, JY5101_TriggerType triggerType)
Set AO start trigger type,the triggerType is defined by enum JY5101_AO_TriggerType.
JY5101API int | JY5101_AO_SetDigitalStartTrigger (JY5101_DeviceHandle hDevice, JY5101_DigitalTriggerSource triggerSource, JY5101_DigitalTriggerEdge triggerEdge)
Set AO digital start trigger,the triggerSource is defined by enum JY5101_DigitalTriggerSource, the triggerEdge is defined by enum JY5101_DigitalTriggerEdge.
JY5101API int | JY5101_AO_WaitUntilDone (JY5101_DeviceHandle hDevice, bool *done, int timeOut)
Check AO finite output is complete.
JY5101API int | JY5101_AO_CheckBufferStatus (JY5101_DeviceHandle hDevice, unsigned long *avaliableSamples, unsigned long long *transferedSamples, bool *overrun)
Check AO task buffer status.
JY5101API int | JY5101_AO_SendSoftTrigger (JY5101_DeviceHandle hDevice)
Send the software trigger signal.
JY5101API int | JY5101_AO_SetOutputCompleteState (JY5101_DeviceHandle hDevice, JY5101_OutputCompleteState State)
Set AO Output complete state, only in Finite/ ContinuousWrapping/ ContinuousNoWrapping Mode,Default is Zero.
JY5101API int | JY5101_DisableAOCalibration (JY5101_DeviceHandle hDevice, bool DisableCalibration)
Disable AO calibration coefficient, default enable calibration coefficient.
JY5101API int | JY5101_CI_EnableChannel (JY5101_DeviceHandle hDevice, unsigned int channel)
Enables CI channel.There are 2 counter,from 0 and 1.
JY5101API int | JY5101_CI_SetCounterType (JY5101_DeviceHandle hDevice, unsigned int channel, JY5101_CI_MeasureType measureType)
Set CI measure type.
JY5101API int | JY5101_CI_SetSignalReverse (JY5101_DeviceHandle hDevice, unsigned int channel, int signalReverse)
Set the Signal Reverse terminal.
JY5101API int | JY5101_CI_SetCounterParament (JY5101_DeviceHandle hDevice, unsigned int channel, int initCount, JY5101_CountDirection countDirection)
Set CI count parameter.
JY5101API int | JY5101_CI_SetZReloadEnabled (JY5101_DeviceHandle hDevice, unsigned int channel, bool zReloadEnabled)
Set the Z signal enable in Encoder mode.
JY5101API int | JY5101_CI_SetMode (JY5101_DeviceHandle hDevice, unsigned int channel, JY5101_CI_SampleMode mode)
Set counter input mode, the mode is defined by enum JY5101_CI_SampleMode.
JY5101API int | JY5101_CI_SetSampleClock (JY5101_DeviceHandle hDevice, unsigned int channel, JY5101_CI_SampleClock clock, JY5101_ExternalClockTerminal terminal, double rate)
Set counter input sampling clock source.
JY5101API int | JY5101_CI_SetSamplesToAcquire (JY5101_DeviceHandle hDevice, unsigned int channel, unsigned int samplesToAcquire)
Set samples to acquire in finite mode.The samples range is 1 to 4M.
JY5101API int | JY5101_CI_SetEdgeCountEvent (JY5101_DeviceHandle hDevice, unsigned int channel, JY5101_CI_CounterEventSignalIdleState idleState, unsigned int threshold, bool reset)
Set the counter threshold, and when the count reaches this threshold, output a single pulse at the output terminal.
JY5101API int | JY5101_CI_SetPauseTriggerLevel (JY5101_DeviceHandle hDevice, unsigned int channel, bool enable, JY5101_LevelState pauseTriggerActiveLevel)
Config CI pause trigger.
JY5101API int | JY5101_CI_SetPauseTriggerTerminal (JY5101_DeviceHandle hDevice, int channel, JY5101_InputTerminal pauseTriggerTerminal)
Set CI pause trigger terminal.
JY5101API int | JY5101_CI_ReadSingleCountValue (JY5101_DeviceHandle hDevice, unsigned int channel, unsigned int *countValue)
Counter reads a single count value, this API supports the CI Type: JY5101_CI_EdgeCount、JY5101_CI_EncoderX1、 JY5101_CI_EncoderX2 、 JY5101_CI_EncoderX4 、JY5101_CI_EncoderTwoPulse.
JY5101API int | JY5101_CI_ReadSingleMeasureValue (JY5101_DeviceHandle hDevice, unsigned int channel, double *measureValue1, double *measureValue2, int timeOut)
Reads a single counter measurement as follows.
JY5101API int | JY5101_CI_ReadCountValues (JY5101_DeviceHandle hDevice, unsigned int channel, unsigned int *countValues, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
Counter reads the count values, this API is supprot CI Type ：JY5101_CI_EdgeCount、JY5101_CI_EncoderX1、 JY5101_CI_EncoderX2 、 JY5101_CI_EncoderX4 、JY5101_CI_EncoderTwoPulse.
JY5101API int | JY5101_CI_ReadMeasureValues (JY5101_DeviceHandle hDevice, unsigned int channel, double *measureValues1, double *measureValues2, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
Counter reads the measured values, this API only support CI Type for JY5101_CI_Measure_EdgeSeparation JY5101_CI_Measure_Pulse JY5101_CI_Measure_Frequency JY5101_CI_Measure_Period for JY5101_CI_Measure_EdgeSeparation type, the measureValues1 is the Gate signel to the Aux signal interval, the measureValues2 is the Aux signel to the Gate signal interval, the unit is s.
JY5101API int | JY5101_CI_Start (JY5101_DeviceHandle hDevice, unsigned int channel)
Start Counter input.
JY5101API int | JY5101_CI_Stop (JY5101_DeviceHandle hDevice, unsigned int channel)
Stop Counter input.
JY5101API int | JY5101_CI_SetValueReturnMode (JY5101_DeviceHandle hDevice, unsigned int channel, JY5101_CI_ValueReturnMode mode)
Config CI return value mode, only for JY5101_CI_Measure_EdgeSeparation type.
JY5101API int | JY5101_CI_CheckBufferStatus (JY5101_DeviceHandle hDevice, unsigned int channel, unsigned long long *avaliableSamples, unsigned long long *transferedSamples, bool *overrun)
Check CI task buffer status.
JY5101API int | JY5101_CI_SetTimeBase (JY5101_DeviceHandle hDevice, unsigned int channel, JY5101_CountTimeBase timebaseSrc, JY5101_InputTerminal externalTimebaseTerminal, double externalTimebaseFreq, double *actualTimebaseFreq)
Set CI timebase source.
JY5101API int | JY5101_CI_SetSourceTerminal (JY5101_DeviceHandle hDevice, int channel, JY5101_InputTerminal sourceTerminal)
Set source terminal.
JY5101API int | JY5101_CI_SetGateTerminal (JY5101_DeviceHandle hDevice, int channel, JY5101_InputTerminal gateTerminal)
Set gate terminal.
JY5101API int | JY5101_CI_SetAuxTerminal (JY5101_DeviceHandle hDevice, int channel, JY5101_InputTerminal auxTerminal)
Set aux terminal.
JY5101API int | JY5101_CI_SetOutTerminal (JY5101_DeviceHandle hDevice, int channel, JY5101_Signal_Destination outTerminal)
Set out terminal.
JY5101API int | JY5101_CI_SendSoftTrigger (JY5101_DeviceHandle hDevice, int channel)
Send the software trigger signal for CI.
JY5101API int | JY5101_CI_SetStartingEdge (JY5101_DeviceHandle hDevice, unsigned int channel, JY5101_CI_StartingEdge startingEdge)
Set start measure edge.
JY5101API int | JY5101_CI_SetFirstSampleClock (JY5101_DeviceHandle hDevice, unsigned int channel, bool ignore)
Set first sample clock is ignore.
JY5101API int | JY5101_CI_SetStartTriggerType (JY5101_DeviceHandle hDevice, int channel, JY5101_CIO_TriggerType triggerTyp)
Set CI start trigger type,the triggerType is defined by enum JY5101_CI_TriggerType.
JY5101API int | JY5101_CI_SetDigitalStartTrigger (JY5101_DeviceHandle hDevice, int channel, JY5101_DigitalTriggerSource triggerSource, JY5101_DigitalTriggerEdge triggerEdge)
Set CI digital start trigger.the triggerSource is defined by enum JY5101_DigitalTriggerSource, the triggerEdge is defined by enum JY5101_DigitalTriggerEdge.
JY5101API int | JY5101_CO_EnableChannel (JY5101_DeviceHandle hDevice, unsigned int channel)
Enabled counter output channel.
JY5101API int | JY5101_CO_SetOutTerminal (JY5101_DeviceHandle hDevice, int channel, JY5101_Signal_Destination outTerminal)
Set out terminal.
JY5101API int | JY5101_CO_SetCounterParament (JY5101_DeviceHandle hDevice, unsigned int channel, int pulseCount, JY5101_CO_IdleState IdleState, double delay)
Set CO parameter.
JY5101API int | JY5101_CO_SetFrequency (JY5101_DeviceHandle hDevice, unsigned int channel, unsigned int highTicks, unsigned int lowTicks)
Set counter output pulse frequency,After the output starts, you can call this interface to modify the pulse frequency in real time.
JY5101API int | JY5101_CO_CheckCounterStatus (JY5101_DeviceHandle hDevice, unsigned int channel, unsigned int *pulseTransfered, bool *underflow)
Check counter status.
JY5101API int | JY5101_CO_WaitUntilDone (JY5101_DeviceHandle hDevice, unsigned int channel, bool *done)
Check counter output complete status.
JY5101API int | JY5101_CO_Start (JY5101_DeviceHandle hDevice, unsigned int channel)
Start counter output.
JY5101API int | JY5101_CO_Stop (JY5101_DeviceHandle hDevice, unsigned int channel)
Stop counter output.
JY5101API int | JY5101_CO_SetPauseTriggerLevel (JY5101_DeviceHandle hDevice, unsigned int channel, bool enable, JY5101_LevelState pauseTriggerActiveLevel)
Config CO pause trigger.
JY5101API int | JY5101_CO_SetPauseTriggerTerminal (JY5101_DeviceHandle hDevice, int channel, JY5101_InputTerminal pauseTriggerTerminal)
Set CO pause trigger terminal.
JY5101API int | JY5101_CO_SetPauseTriggerOutState (JY5101_DeviceHandle hDevice, unsigned int channel, JY5101_CO_PauseTriger_OutState outState)
Config CO out state when pause trigger valid.
JY5101API int | JY5101_CO_SetTimeBase (JY5101_DeviceHandle hDevice, unsigned int channel, JY5101_CountTimeBase timebaseSrc, JY5101_InputTerminal externalTimebaseTerminal, double externalTimebaseFreq, double *actualTimebaseFreq)
Set CO timebase source.
JY5101API int | JY5101_CO_SendSoftTrigger (JY5101_DeviceHandle hDevice, int channel)
Send the software trigger signal.
JY5101API int | JY5101_CO_SetStartTriggerType (JY5101_DeviceHandle hDevice, int channel, JY5101_CIO_TriggerType triggerTyp)
Set CO start trigger type,the triggerType is defined by enum JY5101_AI_TriggerType.
JY5101API int | JY5101_CO_SetDigitalStartTrigger (JY5101_DeviceHandle hDevice, int channel, JY5101_DigitalTriggerSource triggerSource, JY5101_DigitalTriggerEdge triggerEdge)
Set CO digital start trigger,the triggerSource is defined by enum JY5101_DigitalTriggerSource, the triggerEdge is defined by enum JY5101_DigitalTriggerEdge.
JY5101API int | JY5101_SetPFIFilter (JY5101_DeviceHandle hDevice, int line, bool filterEnabled, int minPulseWidth, int *actualMinPulseWidth)
Set the filter for the specified PFI Minimum pulse width in ns, bounce less than this length will be ignored.
JY5101API int | JY5101_GetFPGATemperature (JY5101_DeviceHandle hDevice, double *temperature)
Get Device FPGATemperature.
JY5101API int | JY5101Cal_SetAIEnvironmentParam (JY5101_DeviceHandle handle, double temperature)
JY5101API int | JY5101Cal_SetAOEnvironmentParam (JY5101_DeviceHandle hDevice, double temperature)
JY5101API int | JY5101Cal_SaveAIToEEPROM (JY5101_DeviceHandle handle)
JY5101API int | JY5101Cal_SaveAOToEEPROM (JY5101_DeviceHandle handle)

Detailed Description

@SectionBegin JY5101 FileHead

COPYRIGHT NOTICE
Copyright (c) 2018-2022, JYTEK
All rights reserved.
Author
JYTEK
Version
4.1.0
Date
2025-11-3

This header file defines C/C++ API and enums used in the JY5101 driver.

Revision Notes:

Typedef Documentation

◆ JY5101_DeviceHandle

typedef void* JY5101_DeviceHandle

@SectionEnd JY5101_Device FileHead

Windows Linux

Enumeration Type Documentation

◆ JY5101_AI_BandWidth

enum JY5101_AI_BandWidth
Enumerator
JY5101_AI_BandWidth_39K
JY5101_AI_BandWidth_15K
JY5101_AI_BandWidth_376K

◆ JY5101_AI_SampleMode

enum JY5101_AI_SampleMode
Enumerator
JY5101_AI_Finite
JY5101_AI_Continuous
JY5101_AI_Single

◆ JY5101_AI_Terminal

enum JY5101_AI_Terminal
Enumerator
JY5101_AI_RSE
JY5101_AI_Diff

◆ JY5101_AI_TriggerType

enum JY5101_AI_TriggerType
Enumerator
JY5101_AI_Immediately
JY5101_AI_Digital
JY5101_AI_Analog
JY5101_AI_Soft

◆ JY5101_AnalogTriggerEdge

enum JY5101_AnalogTriggerEdge
Enumerator
JY5101_RisingSlope
JY5101_FallingSlope

◆ JY5101_AnalogTriggerSource

enum JY5101_AnalogTriggerSource
Enumerator
JY5101_Channel_0
JY5101_Channel_1
JY5101_Channel_2
JY5101_Channel_3
JY5101_Channel_4
JY5101_Channel_5
JY5101_Channel_6
JY5101_Channel_7
JY5101_Channel_8
JY5101_Channel_9
JY5101_Channel_10
JY5101_Channel_11
JY5101_Channel_12
JY5101_Channel_13
JY5101_Channel_14
JY5101_Channel_15
JY5101_Channel_16
JY5101_Channel_17
JY5101_Channel_18
JY5101_Channel_19
JY5101_Channel_20
JY5101_Channel_21
JY5101_Channel_22
JY5101_Channel_23
JY5101_Channel_24
JY5101_Channel_25
JY5101_Channel_26
JY5101_Channel_27
JY5101_Channel_28
JY5101_Channel_29
JY5101_Channel_30
JY5101_Channel_31

◆ JY5101_AnalogWindowCondition

enum JY5101_AnalogWindowCondition
Enumerator
JY5101_Entering
JY5101_Leaving

◆ JY5101_AO_UpdateMode

enum JY5101_AO_UpdateMode
Enumerator
JY5101_AO_Finite
JY5101_AO_ContinuousWrapping
JY5101_AO_ContinuousNoWrapping
JY5101_AO_Single

◆ JY5101_Capability_Item

enum JY5101_Capability_Item
Enumerator
JY5101_AI_NumberOfChannels_Int | Number of channels.
JY5101_AI_MaxSampleRate_Double | Max Sample Rate.
JY5101_AI_MinSampleRate_Double | Min Sample Rate.
JY5101_AI_ChannelGroups_Int | Channel Groups.
JY5101_ADCCount_Int | Number of ADCs.

◆ JY5101_CI_CounterEventSignalIdleState

enum JY5101_CI_CounterEventSignalIdleState
Enumerator
JY5101_CI_CounterEventSignalIdleState_Low
JY5101_CI_CounterEventSignalIdleState_High

◆ JY5101_CI_CounterLevel

enum JY5101_CI_CounterLevel

CI Counter Event Signal Idle State.

Enumerator
JY5101_CI_CounterLevel_Low
JY5101_CI_CounterLevel_High

◆ JY5101_CI_MeasureType

enum JY5101_CI_MeasureType
Enumerator
JY5101_CI_EdgeCount
JY5101_CI_Measure_FrequencyOrPeriod
JY5101_CI_Measure_PulseWidth
JY5101_CI_Measure_SemiPeriod
JY5101_CI_Measure_EdgeSeparation
JY5101_CI_EncoderX1
JY5101_CI_EncoderX2
JY5101_CI_EncoderX4
JY5101_CI_EncoderTwoPulse

◆ JY5101_CI_SampleClock

enum JY5101_CI_SampleClock
Enumerator
JY5101_CI_ImplicitClock
JY5101_CI_InternalClock
JY5101_CI_ExternalClock

◆ JY5101_CI_SampleMode

enum JY5101_CI_SampleMode
Enumerator
JY5101_CI_Finite
JY5101_CI_Continuous
JY5101_CI_Single

◆ JY5101_CI_StartingEdge

enum JY5101_CI_StartingEdge
Enumerator
JY5101_RisingEdge
JY5101_FallingEdge
JY5101_AnyEdge

◆ JY5101_CI_ValueReturnMode

enum JY5101_CI_ValueReturnMode
Enumerator
JY5101_CI_ReturnTwoValue
JY5101_CI_ReturnOneValue

◆ JY5101_CIO_TriggerType

enum JY5101_CIO_TriggerType
Enumerator
JY5101_CIO_Immediately
JY5101_CIO_Digital
JY5101_CIO_Soft

◆ JY5101_ClockSource

enum JY5101_ClockSource
Enumerator
JY5101_InternalClock
JY5101_ExternalClock

◆ JY5101_CO_IdleState

enum JY5101_CO_IdleState
Enumerator
JY5101_CO_LowLevel
JY5101_CO_HighLevel

◆ JY5101_CO_PauseTriger_OutState

enum JY5101_CO_PauseTriger_OutState
Enumerator
JY5101_CO_HoldOn
JY5101_CO_HighOut
JY5101_CO_LowOut

◆ JY5101_CountDirection

enum JY5101_CountDirection
Enumerator
JY5101_CI_Count_Up
JY5101_CI_Count_Down
JY5101_CI_Count_External

◆ JY5101_CountTimeBase

enum JY5101_CountTimeBase
Enumerator
JY5101_Internal_Timebase_100M
JY5101_Internal_Timebase_5M
JY5101_Internal_Timebase_100K
JY5101_External_Timebase

◆ JY5101_DigitalTriggerEdge

enum JY5101_DigitalTriggerEdge
Enumerator
JY5101_Rising
JY5101_Falling

◆ JY5101_DigitalTriggerSource

enum JY5101_DigitalTriggerSource
Enumerator
JY5101_PFI0
JY5101_PFI1
JY5101_PFI2
JY5101_PFI3
JY5101_PFI4
JY5101_PFI5
JY5101_PFI6
JY5101_PFI7
JY5101_PFI8
JY5101_PFI9
JY5101_PFI10
JY5101_PFI11
JY5101_PFI12
JY5101_PFI13
JY5101_PFI14
JY5101_PFI15
JY5101_PFI16
JY5101_PFI17
JY5101_PFI18
JY5101_PFI19
JY5101_PFI20
JY5101_PFI21
JY5101_PFI22
JY5101_PFI23
JY5101_PXI_Trig0
JY5101_PXI_Trig1
JY5101_PXI_Trig2
JY5101_PXI_Trig3
JY5101_PXI_Trig4
JY5101_PXI_Trig5
JY5101_PXI_Trig6
JY5101_PXI_Trig7
JY5101_Inter_AI_StartTrig
JY5101_Inter_AI_ReferenceTrig
JY5101_Inter_AO_StartTrig
JY5101_Inter_Counter_0_StartTrig
JY5101_Inter_Counter_1_StartTrig
JY5101_Inter_Counter_0_Out
JY5101_Inter_Counter_1_Out
JY5101_Inter_Counter_0_EventOut
JY5101_Inter_Counter_1_EventOut

◆ JY5101_ExternalClockTerminal

enum JY5101_ExternalClockTerminal
Enumerator
JY5101_ECLK
JY5101_Clock_PFI_0
JY5101_Clock_PFI_1
JY5101_Clock_PFI_2
JY5101_Clock_PFI_3
JY5101_Clock_PFI_4
JY5101_Clock_PFI_5
JY5101_Clock_PFI_6
JY5101_Clock_PFI_7
JY5101_Clock_PFI_8
JY5101_Clock_PFI_9
JY5101_Clock_PFI_10
JY5101_Clock_PFI_11
JY5101_Clock_PFI_12
JY5101_Clock_PFI_13
JY5101_Clock_PFI_14
JY5101_Clock_PFI_15
JY5101_Clock_PFI_16
JY5101_Clock_PFI_17
JY5101_Clock_PFI_18
JY5101_Clock_PFI_19
JY5101_Clock_PFI_20
JY5101_Clock_PFI_21
JY5101_Clock_PFI_22
JY5101_Clock_PFI_23
JY5101_Clock_PXI_Trig_0
JY5101_Clock_PXI_Trig_1
JY5101_Clock_PXI_Trig_2
JY5101_Clock_PXI_Trig_3
JY5101_Clock_PXI_Trig_4
JY5101_Clock_PXI_Trig_5
JY5101_Clock_PXI_Trig_6
JY5101_Clock_PXI_Trig_7
JY5101_Clock_AI_SampleClock
JY5101_Clock_AO_SampleClock
JY5101_Clock_CI_0_SampleClock
JY5101_Clock_CI_1_SampleClock
JY5101_Clock_CO_0_Output
JY5101_Clock_CO_1_Output

◆ JY5101_InputTerminal

enum JY5101_InputTerminal
Enumerator
JY5101_PFI0_Input
JY5101_PFI1_Input
JY5101_PFI2_Input
JY5101_PFI3_Input
JY5101_PFI4_Input
JY5101_PFI5_Input
JY5101_PFI6_Input
JY5101_PFI7_Input
JY5101_PFI8_Input
JY5101_PFI9_Input
JY5101_PFI10_Input
JY5101_PFI11_Input
JY5101_PFI12_Input
JY5101_PFI13_Input
JY5101_PFI14_Input
JY5101_PFI15_Input
JY5101_PFI16_Input
JY5101_PFI17_Input
JY5101_PFI18_Input
JY5101_PFI19_Input
JY5101_PFI20_Input
JY5101_PFI21_Input
JY5101_PFI22_Input
JY5101_PFI23_Input
JY5101_PXI_Trig0_Input
JY5101_PXI_Trig1_Input
JY5101_PXI_Trig2_Input
JY5101_PXI_Trig3_Input
JY5101_PXI_Trig4_Input
JY5101_PXI_Trig5_Input
JY5101_PXI_Trig6_Input
JY5101_PXI_Trig7_Input
JY5101_AI_SampleClock_Input
JY5101_AO_SampleClock_Input
JY5101_CI_0_SampleClock_Input
JY5101_CI_1_SampleClock_Input
JY5101_CO_0_Output_Input
JY5101_CO_1_Output_Input
JY5101_CIO_100MHz_Input
JY5101_CIO_5MHz_Input
JY5101_CIO_100kHz_Input

◆ JY5101_LevelState

enum JY5101_LevelState
Enumerator
JY5101_LowLevel
JY5101_HighLevel

◆ JY5101_MultiChannelCompositionLogic

enum JY5101_MultiChannelCompositionLogic
Enumerator
JY5101_Or | Multichannel result take or.
JY5101_And | Multichannel results take and.

◆ JY5101_OutputCompleteState

enum JY5101_OutputCompleteState
Enumerator
JY5101_Zero
JY5101_Hold

◆ JY5101_ReferenceClock

enum JY5101_ReferenceClock
Enumerator
JY5101_Internal
JY5101_PXIe_Clk100

◆ JY5101_Signal_Destination

enum JY5101_Signal_Destination
Enumerator
JY5101_PFI0_OUT
JY5101_PFI1_OUT
JY5101_PFI2_OUT
JY5101_PFI3_OUT
JY5101_PFI4_OUT
JY5101_PFI5_OUT
JY5101_PFI6_OUT
JY5101_PFI7_OUT
JY5101_PFI8_OUT
JY5101_PFI9_OUT
JY5101_PFI10_OUT
JY5101_PFI11_OUT
JY5101_PFI12_OUT
JY5101_PFI13_OUT
JY5101_PFI14_OUT
JY5101_PFI15_OUT
JY5101_PFI16_OUT
JY5101_PFI17_OUT
JY5101_PFI18_OUT
JY5101_PFI19_OUT
JY5101_PFI20_OUT
JY5101_PFI21_OUT
JY5101_PFI22_OUT
JY5101_PFI23_OUT
JY5101_PXITrig0_OUT
JY5101_PXITrig1_OUT
JY5101_PXITrig2_OUT
JY5101_PXITrig3_OUT
JY5101_PXITrig4_OUT
JY5101_PXITrig5_OUT
JY5101_PXITrig6_OUT
JY5101_PXITrig7_OUT
JY5101_None

◆ JY5101_Signal_Source

enum JY5101_Signal_Source
Enumerator
JY5101_Signal_PFI_0
JY5101_Signal_PFI_1
JY5101_Signal_PFI_2
JY5101_Signal_PFI_3
JY5101_Signal_PFI_4
JY5101_Signal_PFI_5
JY5101_Signal_PFI_6
JY5101_Signal_PFI_7
JY5101_Signal_PFI_8
JY5101_Signal_PFI_9
JY5101_Signal_PFI_10
JY5101_Signal_PFI_11
JY5101_Signal_PFI_12
JY5101_Signal_PFI_13
JY5101_Signal_PFI_14
JY5101_Signal_PFI_15
JY5101_Signal_PFI_16
JY5101_Signal_PFI_17
JY5101_Signal_PFI_18
JY5101_Signal_PFI_19
JY5101_Signal_PFI_20
JY5101_Signal_PFI_21
JY5101_Signal_PFI_22
JY5101_Signal_PFI_23
JY5101_Signal_PXI_Trig_0
JY5101_Signal_PXI_Trig_1
JY5101_Signal_PXI_Trig_2
JY5101_Signal_PXI_Trig_3
JY5101_Signal_PXI_Trig_4
JY5101_Signal_PXI_Trig_5
JY5101_Signal_PXI_Trig_6
JY5101_Signal_PXI_Trig_7
JY5101_Signal_AI_StartTrig
JY5101_Signal_AI_ReferenceTrig
JY5101_Signal_AO_StartTrig
JY5101_Signal_CIO_0_StartTrig
JY5101_Signal_CIO_1_StartTrig
JY5101_Signal_AI_SampleClock
JY5101_Signal_AO_SampleClock
JY5101_Signal_CI_0_SampleClock
JY5101_Signal_CI_1_SampleClock
JY5101_Signal_CO_0_Output
JY5101_Signal_CO_1_Output
JY5101_Signal_CIO_100MHz
JY5101_Signal_CIO_5MHz
JY5101_Signal_CIO_100kHz
JY5101_Signa_Counter_0_EventOut
JY5101_Signa_Counter_1_EventOut

◆ JY5101_TriggerMode

enum JY5101_TriggerMode
Enumerator
JY5101_StartTrigger
JY5101_ReferenceTrigger

◆ JY5101_TriggerType

enum JY5101_TriggerType
Enumerator
JY5101_AO_Immediately
JY5101_AO_Digital
JY5101_AO_Soft

Function Documentation

◆ JY5101_AI_CheckBufferStatus()

JY5101API int JY5101_AI_CheckBufferStatus | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned long long * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun )

Check AI task buffer status.

Parameters
hDevice | device handle
avaliableSamples | number of samples per channel in the device buffer
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5101_AI_EnableChannel()

JY5101API int JY5101_AI_EnableChannel | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned int | channelCount,
 |  | unsigned char * | channels,
 |  | double * | lowRegion,
 |  | double * | highRegion,
 |  | JY5101_AI_Terminal | terminal,
 |  | JY5101_AI_BandWidth | bandWidth )

Enable AI channels.

Each channel can be independently configured

Parameters
hDevice | device handle
channelCount | number of channels to be enabled
channels | array[channelCount] containing channel IDs
lowRegion | array[channelCount] of lower limit numbers for each channel,typically in volts.
highRegion | array[channelCount] of higher limit numbers for each channel, typcially in volts.
highRegion | array[channelCount] of higher limit numbers for each channel, typcially in volts.
terminal | array[channelCount] of the terminal configuration defined by enum JY5101_AI_Terminal which can be RSE,or DIFF.
bandWidth | bandwidth for each channel, default Wide
Returns
0 if success or other error code

◆ JY5101_AI_ReadData()

JY5101API int JY5101_AI_ReadData | ( | JY5101_DeviceHandle | hDevice,
 |  | double * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength )

Read AI data to user defined data buffer.

For the multi-channel acquisition, the data is interleaved in the order defined by JY5101_AI_EnableChannel.

Parameters
hDevice | device handle
dataBuffer | user buffer,the buffer size must be greater than or equal to dataLength*channelCount.
dataLength | number of samples per channel
timeOut | timeout time in microsecond
actualReadLength | returns the number of samples per channel actually read
Returns
0 if success or other error code

◆ JY5101_AI_ReadRawData()

JY5101API int JY5101_AI_ReadRawData | ( | JY5101_DeviceHandle | hDevice,
 |  | short * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength )

Read AI raw data to user defined data buffer.

For the multi-channel acquisition, the data is interleaved in the order defined by JY5101_AI_EnableChannel.

Parameters
hDevice | device handle
dataBuffer | user buffer, The size of dataBuffer must be greater than or equal to dataLength*channelCount.
dataLength | number of samples per channel
timeOut | timeout time in microsecond
actualReadLength | return the number of samples per channel actually read
Returns
0 if success or other error code

◆ JY5101_AI_ReadRawSinglePoint()

JY5101API int JY5101_AI_ReadRawSinglePoint | ( | JY5101_DeviceHandle | hDevice,
 |  | short * | readValue,
 |  | int | channelID )

Read raw single point for each channel to user defined data buffer.

Parameters
hDevice | device handle
readValue | user buffer,the size of readValue must be greater than or equal to channelCount.
channelID | read the specified channelID. when the channelID is -1, read all enabled channels value.
Returns
0 if success or other error code

◆ JY5101_AI_ReadSinglePoint()

JY5101API int JY5101_AI_ReadSinglePoint | ( | JY5101_DeviceHandle | hDevice,
 |  | double * | readValue,
 |  | int | channelID )

Read single point for each channel to user defined data buffer.

Parameters
hDevice | device handle
readValue | user buffer,the size of readValue must be greater than or equal to channelCount.
channelID | read the specified channelID. when the channelID is -1, read all enabled channels value.
Returns
0 if success or other error code

◆ JY5101_AI_SendSoftTrigger()

JY5101API int JY5101_AI_SendSoftTrigger | ( | JY5101_DeviceHandle | hDevice,
 |  | JY5101_TriggerMode | triggerMode )

Send the software trigger signal.

Parameters
hDevice | device handle
triggerMode | software trigger mode. Options: start trigger or reference trigger.
Returns
0 if success or other error code

◆ JY5101_AI_SetAnalogEdgeReferenceTrigger()

JY5101API int JY5101_AI_SetAnalogEdgeReferenceTrigger | ( | JY5101_DeviceHandle | hDevice,
 |  | JY5101_AnalogTriggerSource | triggerSource,
 |  | JY5101_AnalogTriggerEdge | triggerEdge,
 |  | double | threshold )

Set AI analog edge window reference trigger,the triggerSource is defined by enum JY5101_AnalogTriggerSource, the triggerEdge is defined by enum JY5101_AnalogTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source, 0-64 for RSE, 0-31 for differential
triggerCondition | AI analog trigger conditions.Options:JY5101_RisingSlope,JY5101_FallingSlope
threshold | threshold
Returns
0 if success or other error code

◆ JY5101_AI_SetAnalogEdgeStartTrigger()

JY5101API int JY5101_AI_SetAnalogEdgeStartTrigger | ( | JY5101_DeviceHandle | hDevice,
 |  | JY5101_AnalogTriggerSource | triggerSource,
 |  | JY5101_AnalogTriggerEdge | triggerEdge,
 |  | double | threshold )

Set AI analog edge start trigger,the triggerSource is defined by enum JY5101_AnalogTriggerSource, the triggerEdge is defined by enum JY5101_AnalogTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source, 0-64 for RSE, 0-31 for differential
triggerCondition | AI analog edge trigger conditions.Options:JY5101_RisingSlope,JY5101_FallingSlope
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY5101_AI_SetAnalogHysteresisReferenceTrigger()

JY5101API int JY5101_AI_SetAnalogHysteresisReferenceTrigger | ( | JY5101_DeviceHandle | hDevice,
 |  | JY5101_AnalogTriggerSource | triggerSource,
 |  | JY5101_AnalogTriggerEdge | triggerEdge,
 |  | double | highThreshold,
 |  | double | lowThreshold )

Set AI analog hysteresis reference trigger,the triggerSource is defined by enum JY5101_AnalogTriggerSource, the triggerEdge is defined by enum JY5101_AnalogTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source, 0-64 for RSE, 0-31 for differential
triggerCondition | AI analog trigger conditions.Options:JY5101_RisingSlope,JY5101_FallingSlope
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY5101_AI_SetAnalogHysteresisStartTrigger()

JY5101API int JY5101_AI_SetAnalogHysteresisStartTrigger | ( | JY5101_DeviceHandle | hDevice,
 |  | JY5101_AnalogTriggerSource | triggerSource,
 |  | JY5101_AnalogTriggerEdge | triggerEdge,
 |  | double | highThreshold,
 |  | double | lowThreshold )

Set AI analog hysteresis start trigger,the triggerSource is defined by enum JY5101_AnalogTriggerSource, the triggerEdge is defined by enum JY5101_AnalogTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source, 0-64 for RSE, 0-31 for differential
triggerCondition | AI analog hysteresis trigger conditions.Options:JY5101_RisingSlope,JY5101_FallingSlope
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY5101_AI_SetAnalogTriggerMultiChannelMode()

JY5101API int JY5101_AI_SetAnalogTriggerMultiChannelMode | ( | JY5101_DeviceHandle | hDevice,
 |  | bool | enableMultiChannelTriggerMode,
 |  | JY5101_MultiChannelCompositionLogic | resultLogic )

Enable the trigger mode for multiple channels.

If this mode is enabled, multiple channels participate in trigger comparison. If this mode is disabled, single channel participates in trigger comparison.

Parameters
hDevice | device handle
enableMultiChannelTriggerMode | Enable the trigger mode for multiple channels<
resultLogic | Multichannel composition logic, and / or. defalut or.
Returns
0 if success or other error code

◆ JY5101_AI_SetAnalogWindowReferenceTrigger()

JY5101API int JY5101_AI_SetAnalogWindowReferenceTrigger | ( | JY5101_DeviceHandle | hDevice,
 |  | JY5101_AnalogTriggerSource | triggerSource,
 |  | JY5101_AnalogWindowCondition | triggerCondition,
 |  | double | highThreshold,
 |  | double | lowThreshold )

Set AI analog window reference trigger,the triggerSource is defined by enum JY5101_AnalogTriggerSource, the triggerCondition is defined by enum JY5101_AnalogWindowCondition.

Parameters
hDevice | device handle
triggerSource | AI analog window reference trigger source, 0-64 for RSE, 0-31 for differential
triggerCondition | AI analog window trigger conditions.Options:JY5101_Entering,JY5101_Leaving
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY5101_AI_SetAnalogWindowStartTrigger()

JY5101API int JY5101_AI_SetAnalogWindowStartTrigger | ( | JY5101_DeviceHandle | hDevice,
 |  | JY5101_AnalogTriggerSource | triggerSource,
 |  | JY5101_AnalogWindowCondition | triggerCondition,
 |  | double | highThreshold,
 |  | double | lowThreshold )

Set AI analog window start trigger,the triggerSource is defined by enum JY5101_AnalogTriggerSource, the triggerCondition is defined by enum JY5101_AnalogWindowCondition.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source, 0-64 for RSE, 0-31 for differential
triggerCondition | AI analog window trigger conditions.Options:JY5101_Entering,JY5101_Leaving
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY5101_AI_SetDigitalReferenceTrigger()

JY5101API int JY5101_AI_SetDigitalReferenceTrigger | ( | JY5101_DeviceHandle | hDevice,
 |  | JY5101_DigitalTriggerSource | triggerSource,
 |  | JY5101_DigitalTriggerEdge | triggerEdge )

Set AI digital reference trigger.the triggerSource is defined by enum JY5101_DigitalTriggerSource, the triggerEdge is defined by enum JY5101_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI digital reference trigger source
triggerEdge | AI digital reference trigger edge. Options: rising or falling edge
Returns
0 if success or other error code

◆ JY5101_AI_SetDigitalStartTrigger()

JY5101API int JY5101_AI_SetDigitalStartTrigger | ( | JY5101_DeviceHandle | hDevice,
 |  | JY5101_DigitalTriggerSource | triggerSource,
 |  | JY5101_DigitalTriggerEdge | triggerEdge )

Set AI digital start trigger,the triggerSource is defined by enum JY5101_DigitalTriggerSource, the triggerEdge is defined by enum JY5101_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI digital start trigger source
triggerEdge | AI digital start trigger edge. Options: rising or falling edge
Returns
0 if success or other error code

◆ JY5101_AI_SetDSMode()

JY5101API int JY5101_AI_SetDSMode | ( | JY5101_DeviceHandle | hDevice,
 |  | bool | enable )

Set AI DSMode enable.default : disable(false).

Parameters
hDevice | device handle
enable | true: enable oversample; false: disable oversample
Returns
0 if success or other error code

◆ JY5101_AI_SetMode()

JY5101API int JY5101_AI_SetMode | ( | JY5101_DeviceHandle | hDevice,
 |  | JY5101_AI_SampleMode | mode )

Set AI sampling mode.

Parameters
hDevice | device handle
mode | AI sampling mode defined by enum JY5101_AI_SampleMode.
Returns
0 if success or other error code

◆ JY5101_AI_SetPreTriggerSamples()

JY5101API int JY5101_AI_SetPreTriggerSamples | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned int | preTriggerSamples )

Set AI pretrigger samples, the samples must greater than 0.

Parameters
hDevice | device handle
preTriggerSamples | AI pretrigger samples, valid only in reference trigger mode.
Returns
0 if success or other error code

◆ JY5101_AI_SetReferenceTriggerType()

JY5101API int JY5101_AI_SetReferenceTriggerType | ( | JY5101_DeviceHandle | hDevice,
 |  | JY5101_AI_TriggerType | triggerType )

Set AI reference trigger type,the triggerType is defined by enum JY5101_AI_TriggerType.

Parameters
hDevice | device handle
triggerType | AI reference trigger type.Options: immediate trigger, software trigger, digital trigger or analog trigger.
Returns
0 if success or other error code

◆ JY5101_AI_SetReTriggerCount()

JY5101API int JY5101_AI_SetReTriggerCount | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned long long | reTriggerCount )

Set AI retrigger count.

The device will be triggered reTriggerCount times.

Parameters
hDevice | device handle
reTriggerCount | AI retrigger count
Returns
0 if success or other error code

◆ JY5101_AI_SetSampleClock()

JY5101API int JY5101_AI_SetSampleClock | ( | JY5101_DeviceHandle | hDevice,
 |  | JY5101_ClockSource | clockSource,
 |  | JY5101_ExternalClockTerminal | terminal,
 |  | double | expectedRate )

Set AI sampling clock source.

the source of the sampling clock defined by enum JY5101_ClockSource. If the clock source is external, external clock terminal and external clock frequency must be configured.

Parameters
hDevice | device handle
clockSource | AI sampling clock source
terminal | external clock terminal
expectedRate | AI external clock frequency
Returns
0 if success or other error code

◆ JY5101_AI_SetSampleRate()

JY5101API int JY5101_AI_SetSampleRate | ( | JY5101_DeviceHandle | hDevice,
 |  | double | sampleRate,
 |  | double * | actualSampleRate )

Set sampling rate.

The sampling rate is the same for all channels.the API valid only in sample clock source is Internal.

Parameters
hDevice | device handle
sampleRate | AI sampling rate to be set per channel
actualSampleRate | actual sampling rate set by this device,which may be different from the desired sampleRate.
Returns
0 if success or other error code

◆ JY5101_AI_SetSamplesToAcquire()

JY5101API int JY5101_AI_SetSamplesToAcquire | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned int | sampleToAcquire )

Set convert rate.

convertRate is how fast ADC performs the AD conversion. convertRate = channelCount*sampleRate.

Parameters
hDevice | device handle
scanRate | user set convert rate
actualScanRate | actual convert rate set by this device, which may be different from the desired convertRate.
Returns
0 if success or other error code

Set AI samples to acquire for each channel in finite mode.The samples range is 1 to 128M samples / channelCount.

Parameters
hDevice | device handle
sampleToAcquire | AI finite samples to acquire for each channel, samples range:1 to 128M samples / channelCount.
Returns
0 if success or other error code

◆ JY5101_AI_SetStartTriggerType()

JY5101API int JY5101_AI_SetStartTriggerType | ( | JY5101_DeviceHandle | hDevice,
 |  | JY5101_AI_TriggerType | triggerType )

Set AI start trigger type,the triggerType is defined by enum JY5101_AI_TriggerType.

Parameters
hDevice | device handle
triggerType | AI start trigger type. Options:immediate trigger, software trigger, digital trigger or analog trigger.
Returns
0 if success or other error code

◆ JY5101_AI_Start()

JY5101API int JY5101_AI_Start ( JY5101_DeviceHandle hDevice )

Start AI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5101_AI_Stop()

JY5101API int JY5101_AI_Stop ( JY5101_DeviceHandle hDevice )

Stop AI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5101_AI_WaitUntilDone()

JY5101API int JY5101_AI_WaitUntilDone | ( | JY5101_DeviceHandle | hDevice,
 |  | bool * | done )

Check if AI acquisition is completed in finite mode.

Parameters
hDevice | device handle
done | true if completed, false if not yet completed.
Returns
0 if success or other error code

◆ JY5101_AO_CheckBufferStatus()

JY5101API int JY5101_AO_CheckBufferStatus | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned long * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun )

Check AO task buffer status.

Parameters
hDevice | device handle
avaliableSamples | number of AO samples per channel user can write
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5101_AO_EnableChannel()

JY5101API int JY5101_AO_EnableChannel | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned int | channelCount,
 |  | unsigned char * | channels,
 |  | double * | lowRegion,
 |  | double * | highRegion )

Enables AO channels.

Parameters
hDevice | device handle
channelCount | number of channels to be enabled
channels | array[channelCount] containing channel IDs
lowRegion | array[channelCount] of lower limit numbers for each channel,typically in volts.
highRegion | array[channelCount] of higher limit numbers for each channel, typcially in volts.
Returns
0 if success or other error code

◆ JY5101_AO_SendSoftTrigger()

JY5101API int JY5101_AO_SendSoftTrigger ( JY5101_DeviceHandle hDevice )

Send the software trigger signal.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5101_AO_SetDigitalStartTrigger()

JY5101API int JY5101_AO_SetDigitalStartTrigger | ( | JY5101_DeviceHandle | hDevice,
 |  | JY5101_DigitalTriggerSource | triggerSource,
 |  | JY5101_DigitalTriggerEdge | triggerEdge )

Set AO digital start trigger,the triggerSource is defined by enum JY5101_DigitalTriggerSource, the triggerEdge is defined by enum JY5101_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AO digital start trigger source
triggerEdge | AO digital start trigger edge. Options: rising or falling edge
Returns
0 if success or other error code

◆ JY5101_AO_SetMode()

JY5101API int JY5101_AO_SetMode | ( | JY5101_DeviceHandle | hDevice,
 |  | JY5101_AO_UpdateMode | mode )

Set AO mode, the mode defined by enum JY5101_AO_UpdateMode.

Parameters
hDevice | device handle
mode | AO output mode.Options: Single,Finite,ContinuousWrapping,ContinuousNoWrapping mode.
Returns
0 if success or other error code

◆ JY5101_AO_SetOutputCompleteState()

JY5101API int JY5101_AO_SetOutputCompleteState | ( | JY5101_DeviceHandle | hDevice,
 |  | JY5101_OutputCompleteState | State )

Set AO Output complete state, only in Finite/ ContinuousWrapping/ ContinuousNoWrapping Mode,Default is Zero.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5101_AO_SetSampleClock()

JY5101API int JY5101_AO_SetSampleClock | ( | JY5101_DeviceHandle | hDevice,
 |  | JY5101_ClockSource | clockSource,
 |  | JY5101_ExternalClockTerminal | terminal,
 |  | double | expectedRate )

Set AO sampling clock source.

the source of the sampling clock defined by enum JY5101_ClockSource. If the clock source is external, need to configure external clock terminal and external clock frequency.

Parameters
hDevice | device handle
clockSource | AO sampling clock source
terminal | external clock terminal,defined by enum JY5101_ExternalClockTerminal
expectedRate | external clock frequency
Returns
0 if success or other error code

◆ JY5101_AO_SetSamplesToUpdate()

JY5101API int JY5101_AO_SetSamplesToUpdate | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned int | sampleToUpdate )

Set AO samples for each channel in the finite mode.The sample range is from 1 to 32M / channelCount samples.

Parameters
hDevice | device handle
sampleToUpdate | number of AO samples per channel. Data range:1 to 32M / channelCount samples.
Returns
0 if success or other error code

◆ JY5101_AO_SetStartTriggerType()

JY5101API int JY5101_AO_SetStartTriggerType | ( | JY5101_DeviceHandle | hDevice,
 |  | JY5101_TriggerType | triggerType )

Set AO start trigger type,the triggerType is defined by enum JY5101_AO_TriggerType.

Parameters
hDevice | device handle
triggerType | AO start trigger type. Options: immediate trigger, software trigger, digital trigger .
Returns
0 if success or other error code

◆ JY5101_AO_SetUpdateRate()

JY5101API int JY5101_AO_SetUpdateRate | ( | JY5101_DeviceHandle | hDevice,
 |  | double | updateRate,
 |  | double * | actualUpdateRate )

Set AO update rate for each channel.

Parameters
hDevice | device handle
updateRate | AO update rate to be set per channel
actualUpdateRate | AO update rate actually set. The actual update rate set by this device,which may be different from the desired updata rate.
Returns
0 if success or other error code

◆ JY5101_AO_Start()

JY5101API int JY5101_AO_Start ( JY5101_DeviceHandle hDevice )

Start digital signal output.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5101_AO_Stop()

JY5101API int JY5101_AO_Stop ( JY5101_DeviceHandle hDevice )

Stop analog signal output.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5101_AO_WaitUntilDone()

JY5101API int JY5101_AO_WaitUntilDone | ( | JY5101_DeviceHandle | hDevice,
 |  | bool * | done,
 |  | int | timeOut )

Check AO finite output is complete.

Parameters
hDevice | device handle
done | true if completed, false if not yet completed.
timeOut | timeout time in microsecond, this parament not valid in current version
Returns
0 if success or other error code

◆ JY5101_AO_WriteData()

JY5101API int JY5101_AO_WriteData | ( | JY5101_DeviceHandle | hDevice,
 |  | double * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualWriteLength )

AO writes data.The data is interleaved in the buffer the order defined by JY5101_AO_EnableChannel.

Parameters
hDevice | device handle
dataBuffer | user buffer of output data.The buffer size must be greater than or equal to dataLength*number of enabled channels.
dataLength | total number of output data for all channels
timeOut | timeout time in microsecond
actualWriteLength | the number of samples per channel actually write
Returns
0 if success or other error code

◆ JY5101_AO_WriteRawData()

JY5101API int JY5101_AO_WriteRawData | ( | JY5101_DeviceHandle | hDevice,
 |  | short * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualWriteLength )

AO write raw data.The data is interleaved in the buffer in channel order for multi-channel.

Parameters
hDevice | device handle
dataBuffer | user buffer, the buffer size must be greater than or equal to dataLength*number of enabled channels.
dataLength | total number of output data for all channels
timeOut | timeout time in microsecond
actualWriteLength | the number of samples per channel actually write
Returns
0 if success or other error code

◆ JY5101_AO_WriteRawSinglePoint()

JY5101API int JY5101_AO_WriteRawSinglePoint | ( | JY5101_DeviceHandle | hDevice,
 |  | short * | writeValues,
 |  | int | channelID )

AO write single point raw data to the defined channel by channelID, if channelID == -1, write all enable channel.

Parameters
hDevice | device handle
writeValues | write value for each enable channel,when channelID == -1 the writeValue length must equal to channelCount
channelID | defined channel, if channelID == -1, write all enable channel one data
Returns
0 if success or other error code

◆ JY5101_AO_WriteSinglePoint()

JY5101API int JY5101_AO_WriteSinglePoint | ( | JY5101_DeviceHandle | hDevice,
 |  | double * | writeValues,
 |  | int | channelID )

AO write single point data to the defined channel by channelID, if channelID == -1, write all enable channel one data.

Parameters
hDevice | device handle
writeValues | write value for each enable channel,when channelID == -1 the writeValue length must equal to channelCount
channelID | defined channel, if channelID == -1, write all enable channel one data
Returns
0 if success or other error code

◆ JY5101_CI_CheckBufferStatus()

JY5101API int JY5101_CI_CheckBufferStatus | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned long long * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun )

Check CI task buffer status.

Parameters
hDevice | device handle
channel | counter input channel
avaliableSamples | number of samples that the device buffer can read
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5101_CI_EnableChannel()

JY5101API int JY5101_CI_EnableChannel | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned int | channel )

Enables CI channel.There are 2 counter,from 0 and 1.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if success or other error code

◆ JY5101_CI_ReadCountValues()

JY5101API int JY5101_CI_ReadCountValues | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int * | countValues,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength )

Counter reads the count values, this API is supprot CI Type ：JY5101_CI_EdgeCount、JY5101_CI_EncoderX1、 JY5101_CI_EncoderX2 、 JY5101_CI_EncoderX4 、JY5101_CI_EncoderTwoPulse.

Parameters
hDevice | device handle
channel | counter input channel
countValues | user buffer,the buffer size must be greater than or equal to dataLength
dataLength | read data length
timeOut | timeout time in microsecond
actualReadLength | return value, the actual length of the data read.
Returns
0 if success or other error code

◆ JY5101_CI_ReadMeasureValues()

JY5101API int JY5101_CI_ReadMeasureValues | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | double * | measureValues1,
 |  | double * | measureValues2,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength )

Counter reads the measured values, this API only support CI Type for JY5101_CI_Measure_EdgeSeparation JY5101_CI_Measure_Pulse JY5101_CI_Measure_Frequency JY5101_CI_Measure_Period for JY5101_CI_Measure_EdgeSeparation type, the measureValues1 is the Gate signel to the Aux signal interval, the measureValues2 is the Aux signel to the Gate signal interval, the unit is s.

for JY5101_CI_Measure_Pulse type, the measureValues1 is the Low level signal time, the measureValues2 is the Highe level signal time, the unit is s. for JY5101_CI_Measure_Frequency type, the measureValues1 is signal frequency, the unit is Hz. for JY5101_CI_Measure_Period type, the measureValues2 is signal period, the unit is s. The JY5101_CI_Measure_Period type and JY5101_CI_Measure_Frequency type is same time measurement, user need to read both measurements simultaneously.

Parameters
hDevice | device handle
channel | counter input channel
measureValues | user buffer.The buffer size must be greater than or equal to dataLength
dataLength | read data length
timeOut | measure timeout time in microsecond
actualReadLength | reture the actual length of the data read
Returns
0 if success or other error code

◆ JY5101_CI_ReadSingleCountValue()

JY5101API int JY5101_CI_ReadSingleCountValue | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int * | countValue )

Counter reads a single count value, this API supports the CI Type: JY5101_CI_EdgeCount、JY5101_CI_EncoderX1、 JY5101_CI_EncoderX2 、 JY5101_CI_EncoderX4 、JY5101_CI_EncoderTwoPulse.

Parameters
hDevice | device handle
channel | counter input channel. An integer counter number, eg, 0 for counter 0.
countValue | return the current count value of counter.
Returns
0 if success or other error code

◆ JY5101_CI_ReadSingleMeasureValue()

JY5101API int JY5101_CI_ReadSingleMeasureValue | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | double * | measureValue1,
 |  | double * | measureValue2,
 |  | int | timeOut )

Reads a single counter measurement as follows.

for JY5101_CI_Measure_EdgeSeparation type, measureValues1 is the Gate signel to the Aux signal interval, the measureValues2 is the Aux signel to the Gate signal interval, the unit is in s. for JY5101_CI_Measure_Pulse type, measureValues1 is the Low level signal time, the measureValues2 is the high level signal time, the unit is in second. for JY5101_CI_Measure_Frequency type, measureValues1 is signal frequency in Hz, measureValue2 has no meaning. for JY5101_CI_Measure_Period type, measureValues2 is signal period in second; measureValue1 has no meaning.

Parameters
hDevice | device handle
channel | Counter input channel
measureValue1 | current measure value of counter
measureValue2 | current measure value of counter
timeOut | timeout time in microsecond
Returns
0 if success or other error code

◆ JY5101_CI_SendSoftTrigger()

JY5101API int JY5101_CI_SendSoftTrigger | ( | JY5101_DeviceHandle | hDevice,
 |  | int | channel )

Send the software trigger signal for CI.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if success or other error code

◆ JY5101_CI_SetAuxTerminal()

JY5101API int JY5101_CI_SetAuxTerminal | ( | JY5101_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5101_InputTerminal | auxTerminal )

Set aux terminal.

Parameters
hDevice | device handle
channel | counter output channel
auxTerminal | aux terminal
Returns
0 if success or other error code

◆ JY5101_CI_SetCounterParament()

JY5101API int JY5101_CI_SetCounterParament | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | int | initCount,
 |  | JY5101_CountDirection | countDirection )

Set CI count parameter.

Parameters
hDevice | device handle
channel | counter input channel
initCount | counter initial value
countDirection | counting direction of the counter defined by enum JY5101_CountDirection
Returns
0 if success or other error code

◆ JY5101_CI_SetCounterType()

JY5101API int JY5101_CI_SetCounterType | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5101_CI_MeasureType | measureType )

Set CI measure type.

Parameters
hDevice | device handle
channel | counter input channel
measureType | measure type. defined by enum JY5101_CI_MeasureType
Returns
0 if success or other error code

◆ JY5101_CI_SetDigitalStartTrigger()

JY5101API int JY5101_CI_SetDigitalStartTrigger | ( | JY5101_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5101_DigitalTriggerSource | triggerSource,
 |  | JY5101_DigitalTriggerEdge | triggerEdge )

Set CI digital start trigger.the triggerSource is defined by enum JY5101_DigitalTriggerSource, the triggerEdge is defined by enum JY5101_DigitalTriggerEdge.

Parameters
hDevice | device handle
channel | counter input channel
triggerSource | CI digital start trigger source
triggerEdge | CI digital start trigger edge. Options: rising or falling edge.
Returns
0 if success or other error code

◆ JY5101_CI_SetEdgeCountEvent()

JY5101API int JY5101_CI_SetEdgeCountEvent | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5101_CI_CounterEventSignalIdleState | idleState,
 |  | unsigned int | threshold,
 |  | bool | reset )

Set the counter threshold, and when the count reaches this threshold, output a single pulse at the output terminal.

Parameters
hDevice | device handle
channel | counter input channel
idleState | output terminal idle state
threshold | threshold
Returns
0 if success or other error code

◆ JY5101_CI_SetFirstSampleClock()

JY5101API int JY5101_CI_SetFirstSampleClock | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool | ignore )

Set first sample clock is ignore.

Parameters
hDevice | device handle
channel | counter input channel
ignore | is ignore first sample clock
Returns
0 if success or other error code

◆ JY5101_CI_SetGateTerminal()

JY5101API int JY5101_CI_SetGateTerminal | ( | JY5101_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5101_InputTerminal | gateTerminal )

Set gate terminal.

Parameters
hDevice | device handle
channel | counter output channel
gateTerminal | gate terminal
Returns
0 if success or other error code

◆ JY5101_CI_SetMode()

JY5101API int JY5101_CI_SetMode | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5101_CI_SampleMode | mode )

Set counter input mode, the mode is defined by enum JY5101_CI_SampleMode.

Parameters
hDevice | device handle
channel | counter input channel
mode | counter input mode, Options: single,finite,continuous.
Returns
0 if success or other error code

◆ JY5101_CI_SetOutTerminal()

JY5101API int JY5101_CI_SetOutTerminal | ( | JY5101_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5101_Signal_Destination | outTerminal )

Set out terminal.

Parameters
hDevice | device handle
channel | counter output channel
outTerminal | source terminal
Returns
0 if success or other error code

◆ JY5101_CI_SetPauseTriggerLevel()

JY5101API int JY5101_CI_SetPauseTriggerLevel | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool | enable,
 |  | JY5101_LevelState | pauseTriggerActiveLevel )

Config CI pause trigger.

Parameters
hDevice | Device handle
channel | Counter channel
enable | Enable pasue trigger
pauseTriggerActiveLevel | Pause trigger active level.
Returns
Succeed: 0 , Error: !=0

◆ JY5101_CI_SetPauseTriggerTerminal()

JY5101API int JY5101_CI_SetPauseTriggerTerminal | ( | JY5101_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5101_InputTerminal | pauseTriggerTerminal )

Set CI pause trigger terminal.

Parameters
hDevice | device handle
channel | counter output channel
pauseTriggerTerminal | pause Trigger Terminal
Returns
0 if success or other error code

◆ JY5101_CI_SetSampleClock()

JY5101API int JY5101_CI_SetSampleClock | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5101_CI_SampleClock | clock,
 |  | JY5101_ExternalClockTerminal | terminal,
 |  | double | rate )

Set counter input sampling clock source.

If the clockType is internal, user need to define sampleRate, if the clockType is JY5101_CI_ImplicitClk, the sample rate determine by the measuer signal.

Parameters
hDevice | device handle
channel | counter input channel
clock | counter input clock type. Option: internal clock 、 implicit clock、external clock.
terminal | external clock terminal,defined by enum JY5101_ExternalClockTerminal
rate | clock frequency,when clockType is implicit clock or external clock. when clockType is Internal clock, the rate is internal sample rate
Returns
0 if success or other error code

◆ JY5101_CI_SetSamplesToAcquire()

JY5101API int JY5101_CI_SetSamplesToAcquire | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int | samplesToAcquire )

Set samples to acquire in finite mode.The samples range is 1 to 4M.

Parameters
hDevice | device handle
channel | counter input channel
samplesToAcquire | CI finite samples to acquire, samples range:1 to 4M samples.
Returns
0 if success or other error code

◆ JY5101_CI_SetSignalReverse()

JY5101API int JY5101_CI_SetSignalReverse | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | int | signalReverse )

Set the Signal Reverse terminal.

Parameters
hDevice | device handle
channel | counter input channel
signalReverse | The lower 4bit is valid. 0bit represents Source, 1bit represents Gate, 2bit represents Aux, and 3bit represents Extclk
Returns
0 if success or other error code

◆ JY5101_CI_SetSourceTerminal()

JY5101API int JY5101_CI_SetSourceTerminal | ( | JY5101_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5101_InputTerminal | sourceTerminal )

Set source terminal.

Parameters
hDevice | device handle
channel | counter output channel
sourceTerminal | source terminal
Returns
0 if success or other error code

◆ JY5101_CI_SetStartingEdge()

JY5101API int JY5101_CI_SetStartingEdge | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5101_CI_StartingEdge | startingEdge )

Set start measure edge.

Parameters
hDevice | device handle
channel | counter input channel
startingEdge | start measure edge
Returns
0 if success or other error code

◆ JY5101_CI_SetStartTriggerType()

JY5101API int JY5101_CI_SetStartTriggerType | ( | JY5101_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5101_CIO_TriggerType | triggerTyp )

Set CI start trigger type,the triggerType is defined by enum JY5101_CI_TriggerType.

Parameters
hDevice | device handle
channel | counter input channel
triggerType | CI start trigger type. Options: immediate trigger, software trigger, digital trigger.
Returns
0 if success or other error code

◆ JY5101_CI_SetTimeBase()

JY5101API int JY5101_CI_SetTimeBase | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5101_CountTimeBase | timebaseSrc,
 |  | JY5101_InputTerminal | externalTimebaseTerminal,
 |  | double | externalTimebaseFreq,
 |  | double * | actualTimebaseFreq )

Set CI timebase source.

Parameters
hDevice | device handle
channel | counter channel
timeBase | counter time base source.defined by emun JY5101_CountTimeBase.Options:JY5101_TimeBase_100M
externalTimebaseTerminal | counter external time base terminal.defined by emun JY5101_InputTerminal.
externalTimebaseFreq | counter external time base frequency.
actualTimebaseFreq | counter actual time base frequency.
Returns
0 if success or other error code

◆ JY5101_CI_SetValueReturnMode()

JY5101API int JY5101_CI_SetValueReturnMode | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5101_CI_ValueReturnMode | mode )

Config CI return value mode, only for JY5101_CI_Measure_EdgeSeparation type.

Parameters
hDevice | Device handle
channel | Counter channel
mode | Counter return value mode
Returns
Succeed: 0 , Error: !=0

◆ JY5101_CI_SetZReloadEnabled()

JY5101API int JY5101_CI_SetZReloadEnabled | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool | zReloadEnabled )

Set the Z signal enable in Encoder mode.

Parameters
hDevice | device handle
channel | counter input channel
zReloadEnabled | enable z signal. True: enabled; False: disabled.Valid only under encoder mode.
Returns
0 if success or other error code

◆ JY5101_CI_Start()

JY5101API int JY5101_CI_Start | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned int | channel )

Start Counter input.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if success or other error code

◆ JY5101_CI_Stop()

JY5101API int JY5101_CI_Stop | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned int | channel )

Stop Counter input.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if success or other error code

◆ JY5101_Close()

JY5101API int JY5101_Close ( JY5101_DeviceHandle hDevice )

Close this 5101 device.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5101_CO_CheckCounterStatus()

JY5101API int JY5101_CO_CheckCounterStatus | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int * | pulseTransfered,
 |  | bool * | underflow )

Check counter status.

Parameters
hDevice | device handle
channel | counter output channel
pulseTransfered | Transfered pulse number
underflow | counter under flow flag
Returns
0 if Success or other error code

◆ JY5101_CO_EnableChannel()

JY5101API int JY5101_CO_EnableChannel | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned int | channel )

Enabled counter output channel.

Parameters
hDevice | device handle
channel | counter output channel
Returns
0 if success or other error code

◆ JY5101_CO_SendSoftTrigger()

JY5101API int JY5101_CO_SendSoftTrigger | ( | JY5101_DeviceHandle | hDevice,
 |  | int | channel )

Send the software trigger signal.

Parameters
hDevice | device handle
channel | counter channel
Returns
0 if success or other error code

◆ JY5101_CO_SetCounterParament()

JY5101API int JY5101_CO_SetCounterParament | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | int | pulseCount,
 |  | JY5101_CO_IdleState | IdleState,
 |  | double | delay )

Set CO parameter.

Parameters
hDevice | device handle
channel | counter output channel
pulseCount | counter output pulse number, if pulseCount = -1 ,the device always responds to output until the user stops it.
IdleState | counter output idle state
delay | counter output delay, unit:s. There are five ticks of the timebase fixed delay in counter internal, so the total delay(s) = delay + (5 / timebase)
Returns
0 if success or other error code

◆ JY5101_CO_SetDigitalStartTrigger()

JY5101API int JY5101_CO_SetDigitalStartTrigger | ( | JY5101_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5101_DigitalTriggerSource | triggerSource,
 |  | JY5101_DigitalTriggerEdge | triggerEdge )

Set CO digital start trigger,the triggerSource is defined by enum JY5101_DigitalTriggerSource, the triggerEdge is defined by enum JY5101_DigitalTriggerEdge.

Parameters
hDevice | device handle
channel | counter channel
triggerSource | CO digital start trigger source
triggerEdge | CO digital start trigger edge. Options: rising or falling edge.
Returns
0 if success or other error code

◆ JY5101_CO_SetFrequency()

JY5101API int JY5101_CO_SetFrequency | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int | highTicks,
 |  | unsigned int | lowTicks )

Set counter output pulse frequency,After the output starts, you can call this interface to modify the pulse frequency in real time.

Parameters
hDevice | device handle
channel | counter output channel
highTicks | the number of ticks for the high pulse, default:timebase is 100MHz.
lowTicks | the number of ticks for the low pulse, default:timebase is 100MHz.
Returns
0 if success or other error code

◆ JY5101_CO_SetOutTerminal()

JY5101API int JY5101_CO_SetOutTerminal | ( | JY5101_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5101_Signal_Destination | outTerminal )

Set out terminal.

Parameters
hDevice | device handle
channel | counter output channel
outTerminal | source terminal
Returns
0 if success or other error code

◆ JY5101_CO_SetPauseTriggerLevel()

JY5101API int JY5101_CO_SetPauseTriggerLevel | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool | enable,
 |  | JY5101_LevelState | pauseTriggerActiveLevel )

Config CO pause trigger.

Parameters
hDevice | Device handle
channel | Counter channel
enable | Enable pasue trigger
pauseTriggerActiveLevel | Pause trigger active level.
Returns
Succeed: 0 , Error: !=0

◆ JY5101_CO_SetPauseTriggerOutState()

JY5101API int JY5101_CO_SetPauseTriggerOutState | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5101_CO_PauseTriger_OutState | outState )

Config CO out state when pause trigger valid.

Parameters
hDevice | Device handle
channel | Counter channel
outState | out state when pause trigger valid
Returns
Succeed: 0 , Error: !=0

◆ JY5101_CO_SetPauseTriggerTerminal()

JY5101API int JY5101_CO_SetPauseTriggerTerminal | ( | JY5101_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5101_InputTerminal | pauseTriggerTerminal )

Set CO pause trigger terminal.

Parameters
hDevice | device handle
channel | counter output channel
pauseTriggerTerminal | pause Trigger Terminal
Returns
0 if success or other error code

◆ JY5101_CO_SetStartTriggerType()

JY5101API int JY5101_CO_SetStartTriggerType | ( | JY5101_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5101_CIO_TriggerType | triggerTyp )

Set CO start trigger type,the triggerType is defined by enum JY5101_AI_TriggerType.

Parameters
hDevice | device handle
channel | counter channel
triggerType | CO start trigger type. Options:immediate trigger, software trigger, digital trigger.
Returns
0 if success or other error code

◆ JY5101_CO_SetTimeBase()

JY5101API int JY5101_CO_SetTimeBase | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5101_CountTimeBase | timebaseSrc,
 |  | JY5101_InputTerminal | externalTimebaseTerminal,
 |  | double | externalTimebaseFreq,
 |  | double * | actualTimebaseFreq )

Set CO timebase source.

Parameters
hDevice | device handle
channel | counter channel
timeBase | counter time base source.defined by emun JY5101_CountTimeBase.Options:JY5101_TimeBase_100M
externalTimebaseTerminal | counter external time base terminal.defined by emun JY5101_InputTerminal.
externalTimebaseFreq | counter external time base frequency.
actualTimebaseFreq | counter actual time base frequency.
Returns
0 if success or other error code

◆ JY5101_CO_Start()

JY5101API int JY5101_CO_Start | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned int | channel )

Start counter output.

Parameters
hDevice | device handle
channel | counter output channel
Returns
0 if success or other error code

◆ JY5101_CO_Stop()

JY5101API int JY5101_CO_Stop | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned int | channel )

Stop counter output.

Parameters
hDevice | device handle
channel | counter output channel
Returns
0 if success or other error code

◆ JY5101_CO_WaitUntilDone()

JY5101API int JY5101_CO_WaitUntilDone | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool * | done )

Check counter output complete status.

Parameters
hDevice | device handle
channel | counter output channel
done | true :counter output complete, false:counter output not complete
Returns
0 if success or other error code

◆ JY5101_DI_AddLines()

JY5101API int JY5101_DI_AddLines | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned int * | line,
 |  | unsigned int | lineCount )

Enabled DI channels.

Parameters
hDevice | device handle
line | array[lineCount] containing lineIDs
lineCount | number of lines to be enabled
Returns
0 if success or other error code

◆ JY5101_DI_ReadSinglePoint()

JY5101API int JY5101_DI_ReadSinglePoint | ( | JY5101_DeviceHandle | hDevice,
 |  | bool * | readValues,
 |  | int | lineID )

read single data from a single line by lineID defined.if the lineID == -1,read all line data.The data type is bool, one bool defined one line status.

Parameters
hDevice | device handle
readValues | read the specified line values,when the lineID is - 1, read all enabled row values(enabled channels in function JY5101_DI_AddLines), and store the values in the add order of the line
lineID | line number
Returns
0 if success or other error code

◆ JY5101_DI_ReadSinglePoint_U32()

JY5101API int JY5101_DI_ReadSinglePoint_U32 | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned long * | readValue )

read single data from a single port by portID defined.if the portID == -1,read all port data.The data type is unsigned long long,There are 3 ports, from 0 to 2.

Each port has 8 lines, from 0 to 7. There are a total of 24 lines from 0 to 23. Each bit from low to high represents one line.

Parameters
hDevice | device handle
readValues | read the specified line values,when the lineID is - 1, read all enabled row values(enabled channels in function JY5101_DI_AddLines), and store the values in the add order of the line
lineID | line number
Returns
0 if success or other error code

◆ JY5101_DI_Start()

JY5101API int JY5101_DI_Start ( JY5101_DeviceHandle hDevice )

Start DI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5101_DI_Stop()

JY5101API int JY5101_DI_Stop ( JY5101_DeviceHandle hDevice )

Stop DI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5101_DisableAICalibration()

JY5101API int JY5101_DisableAICalibration | ( | JY5101_DeviceHandle | hDevice,
 |  | bool | DisableCalibration )

Disable AI calibration coefficient, default enable calibration coefficient.

Parameters
hDevice | device handle
DisableCalibration | true if disabled, false if not disabled.
Returns
0 if success or other error code

◆ JY5101_DisableAOCalibration()

JY5101API int JY5101_DisableAOCalibration | ( | JY5101_DeviceHandle | hDevice,
 |  | bool | DisableCalibration )

Disable AO calibration coefficient, default enable calibration coefficient.

Parameters
hDevice | device handle
DisableCalibration | true if disabled, false if not disabled.
Returns
0 if success or other error code

◆ JY5101_DisconnectSignalRouting()

JY5101API int JY5101_DisconnectSignalRouting | ( | JY5101_DeviceHandle | hDevice,
 |  | JY5101_Signal_Destination | destination )

Disconnect an established routing.

Parameters
hDevice | device handle
destination | destination of the signal defined by enum JY5101_Signal_Destination
Returns
0 if success or other error code

◆ JY5101_DO_AddLines()

JY5101API int JY5101_DO_AddLines | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned int * | line,
 |  | unsigned int | lineCount )

Enabled DO channels.

Parameters
hDevice | device handle
line | array[lineCount] containing line IDs.
lineCount | number of lines to be enabled
Returns
0 if success or other error code

◆ JY5101_DO_ReadSinglePoint()

JY5101API int JY5101_DO_ReadSinglePoint | ( | JY5101_DeviceHandle | hDevice,
 |  | bool * | readValues,
 |  | int | lineID )

read single data from a single port by portID defined.if the portID == -1,read all port data.The data type is bool, one bool defined one line status.

Parameters
hDevice | device handle
readValues | read the specified port values,the readValues Length must equal to 8, and the order is form line 0 to line 7. when the portID is -1, read all enabled ports values,the readValues Length must equal to 8*portCount(In function JY5101_DI_AddLines defined), and the values store in the add order of ports, in one port, the order is form line 0 to line 7.
portID | port number
Returns
0 if success or other error code

◆ JY5101_DO_ReadSinglePoint_U32()

JY5101API int JY5101_DO_ReadSinglePoint_U32 | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned long * | readValue )

read single data from a single port by portID defined.if the portID == -1,read all port data.The data type is unsigned long long,There are 3 ports, from 0 to 2.

Each port has 8 lines, from 0 to 7. There are a total of 24 lines from 0 to 23. Each bit from low to high represents one line.

Parameters
hDevice device handle
readValue read the specified port values,each bit from low to high represents one line..
Returns
0 if success or other error code

◆ JY5101_DO_Start()

JY5101API int JY5101_DO_Start ( JY5101_DeviceHandle hDevice )

Start digital signal output.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5101_DO_Stop()

JY5101API int JY5101_DO_Stop ( JY5101_DeviceHandle hDevice )

Stop digital signal output.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5101_DO_WriteSinglePoint()

JY5101API int JY5101_DO_WriteSinglePoint | ( | JY5101_DeviceHandle | hDevice,
 |  | bool * | writeValues,
 |  | int | lineID )

Write single data to the line by lineID defined.if the lineID == -1,write all line data(enabled channels in function JY5101_DI_AddLines).

Parameters
hDevice | device handle
writeValues | Writes the specified line values, and when the lineID is -1, writes all enabled line values (enabled channels in the JY5101_DO_AddLines function), the values are stored in the order in which the ports were added
lineID | line number
Returns
0 if success or other error code

◆ JY5101_DO_WriteSinglePoint_U32()

JY5101API int JY5101_DO_WriteSinglePoint_U32 | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned int | writeValue )

Write single data to the line by lineID defined.if the lineID == -1,write all line data(enabled channels in function JY5101_DI_AddLines) There are a total of 24 lines from 0 to 23.

Each bit from low to high represents one line.

Parameters
hDevice | device handle
writeValues | Writes the specified line values, and when the lineID is -1, writes all enabled line values (enabled channels in the JY5101_DO_AddLines function), the values are stored in the order in which the ports were added
lineID | line number
Returns
0 if success or other error code

◆ JY5101_GetCapabilityDouble()

JY5101API int JY5101_GetCapabilityDouble | ( | JY5101_DeviceHandle | hDevice,
 |  | JY5101_Capability_Item | item,
 |  | double * | value )

获取当前设备的能力信息，比如最高采样率

Parameters
hDevice | 板卡句柄
item | 设备能力项
value | 设备能力值
Returns
0：无错误；其它：发生错误

◆ JY5101_GetCapabilityDoubleByName()

JY5101API int JY5101_GetCapabilityDoubleByName | ( | const char * | deviceName,
 |  | JY5101_Capability_Item | item,
 |  | double * | value,
 |  | bool | setDefaultIfDeviceNotFound = true )

在不打开设备的情况下，获取指定别名的设备的能力信息中的浮点型数值参数，比如最高采样率

Parameters
deviceName | 设备别名
item | 设备能力项
value | 设备能力值
setDefaultIfDeviceNotFound | 当无法找到指定设备时，若该参数为true，则设置设备能力信息为默认值、不报错；若该参数为false，则返回无法打开设备错误
Returns
0：无错误；其它：发生错误

◆ JY5101_GetCapabilityDoubleBySlotNumber()

JY5101API int JY5101_GetCapabilityDoubleBySlotNumber | ( | int | slotNumber,
 |  | JY5101_Capability_Item | item,
 |  | double * | value,
 |  | bool | setDefaultIfDeviceNotFound = true )

在不打开设备的情况下，获取位于指定卡槽号的设备的能力信息中的浮点型数值参数，比如最高采样率

Parameters
slotNumber | 卡槽号
item | 设备能力项
value | 设备能力值
setDefaultIfDeviceNotFound | 当无法找到指定设备时，若该参数为true，则设置设备能力信息为默认值、不报错；若该参数为false，则返回无法打开设备错误
Returns
0：无错误；其它：发生错误

◆ JY5101_GetCapabilityInt()

JY5101API int JY5101_GetCapabilityInt | ( | JY5101_DeviceHandle | hDevice,
 |  | JY5101_Capability_Item | item,
 |  | int * | value )

获取当前设备的能力信息中的整型数值参数，比如通道数

Parameters
hDevice | 板卡句柄
item | 设备能力项
value | 设备能力值
Returns
0：无错误；其它：发生错误

◆ JY5101_GetCapabilityIntByName()

JY5101API int JY5101_GetCapabilityIntByName | ( | const char * | deviceName,
 |  | JY5101_Capability_Item | item,
 |  | int * | value,
 |  | bool | setDefaultIfDeviceNotFound = true )

在不打开设备的情况下，获取指定别名的设备的能力信息中的整型数值参数，比如通道数

Parameters
deviceName | 设备别名
item | 设备能力项
value | 设备能力值
setDefaultIfDeviceNotFound | 当无法找到指定设备时，若该参数为true，则设置设备能力信息为默认值、不报错；若该参数为false，则返回无法打开设备错误
Returns
0：无错误；其它：发生错误

◆ JY5101_GetCapabilityIntBySlotNumber()

JY5101API int JY5101_GetCapabilityIntBySlotNumber | ( | int | slotNumber,
 |  | JY5101_Capability_Item | item,
 |  | int * | value,
 |  | bool | setDefaultIfDeviceNotFound = true )

在不打开设备的情况下，获取位于指定卡槽号的设备的能力信息中的整型数值参数，比如通道数

Parameters
slotNumber | 卡槽号
item | 设备能力项
value | 设备能力值
setDefaultIfDeviceNotFound | 当无法找到指定设备时，若该参数为true，则设置设备能力信息为默认值、不报错；若该参数为false，则返回无法打开设备错误
Returns
0：无错误；其它：发生错误

◆ JY5101_GetDeviceID()

JY5101API int JY5101_GetDeviceID | ( | JY5101_DeviceHandle | hDevice,
 |  | int * | deviceID )

Obtain the device ID.

The 5101 is a series of boards. The PCIe-5101 device ID is OxA101.

Parameters
hDevice | device handle
deviceID | device ID
Returns
0 if success or other error code

◆ JY5101_GetDeviceInfo()

JY5101API int JY5101_GetDeviceInfo | ( | JY5101_DeviceHandle | hDevice,
 |  | unsigned char * | info )

获取设备信息

Parameters
hDevice | 板卡句柄
deviceID | 板卡ID
Returns
0：无错误；其它：发生错误

◆ JY5101_GetDeviceSerialNumber()

JY5101API int JY5101_GetDeviceSerialNumber | ( | JY5101_DeviceHandle | hDevice,
 |  | char * | serialNumber,
 |  | int | length )

Obtain the device serialNumber.

Parameters
hDevice | device handle
serialNumber | Pointer to a buffer receiving the serial number. The length of the serial number is 10.
length | serial Number length ,length is 10
Returns
0 if success or other error code

◆ JY5101_GetFPGATemperature()

JY5101API int JY5101_GetFPGATemperature | ( | JY5101_DeviceHandle | hDevice,
 |  | double * | temperature )

Get Device FPGATemperature.

Parameters
hDevice | device handle
temperature | FPGA Temperature
Returns
0 if success or other error code

◆ JY5101_Open()

JY5101API int JY5101_Open | ( | int | slotNumber,
 |  | JY5101_DeviceHandle * | hDevice )

Open the 5101 devices using the slot number or the device serial number.

PXIe slot number is predefined by the PXIe chassis. PCIe slot number is defined by the DIP switch. The device serial number is defined by the system starting from 0. It's your responsibility to know the number. For a single board, the serial number is 0.

Parameters
slotNumber | slot number or device serial number
hDevice | device handle. All other functions uses hDevice to represent this device.
Returns
0 if success or other error code

◆ JY5101_OpenByName()

JY5101API int JY5101_OpenByName | ( | const char * | cardName,
 |  | JY5101_DeviceHandle * | hDevice )

Open this 5101 devices using the device alias name which is set by JYTEK utility JYDM.

You can change the name using JYDM. Open this 5101 devices using the device alias name which is set by JYTEK utility JYDM. You can change the name using JYDM.

Parameters
cardName | device alias name
hDevice | device handle
Returns
0 if success or other error code

◆ JY5101_SetDeviceStatusLed()

JY5101API int JY5101_SetDeviceStatusLed | ( | JY5101_DeviceHandle | hDevice,
 |  | bool | enable,
 |  | unsigned int | frequency )

Control Front Panel Status Led.

Parameters
hDevice | device handle
enable | enable front panel status led blink, true: blink, false: not blink
frequency | when enable is ture, the led blink speed by frequency define
Returns
0 if success or other error code

◆ JY5101_SetPFIFilter()

JY5101API int JY5101_SetPFIFilter | ( | JY5101_DeviceHandle | hDevice,
 |  | int | line,
 |  | bool | filterEnabled,
 |  | int | minPulseWidth,
 |  | int * | actualMinPulseWidth )

Set the filter for the specified PFI Minimum pulse width in ns, bounce less than this length will be ignored.

The smallest step in the range of 8 ns to 2040 ns is 8 ns, the smallest step in the range of 2040 ns to 65280 ns is 256ns, and the smallest step in the range of 65280 ns to 1044480 ns is 4096 ns

Parameters
hDevice | device handle
line | define PFI Line
filterEnabled | filter enable
minPulseWidth | The minimum pulse width below which pulses will be filtered out by the filter, unit:ns
actualMinPulseWidth | Actual minimum pulse width be set, unit:ns
Returns
0 if success or other error code

◆ JY5101_SignalRouting()

JY5101API int JY5101_SignalRouting | ( | JY5101_DeviceHandle | hDevice,
 |  | JY5101_Signal_Source | source,
 |  | JY5101_Signal_Destination | destination )

Route a singal from source to destination.

Both source and destination are defined by the corresponding enum JY5101_Signal_Source and JY5101_Signal_Destination. One source signal may be routed to multiple destinations.

Parameters
hDevice | device handle
source | source of the signal defined by enum JY5101_Signal_Source
destination | destination of the signal defined by enum JY5101_Signal_Destination
Returns
0 if success or other error code

◆ JY5101Cal_SaveAIToEEPROM()

JY5101API int JY5101Cal_SaveAIToEEPROM ( JY5101_DeviceHandle handle )

◆ JY5101Cal_SaveAOToEEPROM()

JY5101API int JY5101Cal_SaveAOToEEPROM ( JY5101_DeviceHandle handle )

◆ JY5101Cal_SetAIEnvironmentParam()

JY5101API int JY5101Cal_SetAIEnvironmentParam | ( | JY5101_DeviceHandle | handle,
 |  | double | temperature )

◆ JY5101Cal_SetAOEnvironmentParam()

JY5101API int JY5101Cal_SetAOEnvironmentParam | ( | JY5101_DeviceHandle | hDevice,
 |  | double | temperature )
Generated by doxygen 1.15.0


5101 C++ Programming Manual: D:/OneDrive/Desktop/产品文档/CHM/5101/C++ Directory Reference

  • OneDrive
  • Desktop
  • 产品文档
  • CHM
  • 5101
  • C++
C++ Directory Reference

Files

         JY5101.h
@SectionBegin JY5101 FileHead


5101 C++ Programming Manual: D:/OneDrive/Desktop/产品文档/CHM Directory Reference

  • OneDrive
  • Desktop
  • 产品文档
  • CHM
CHM Directory Reference

Directories

         5101


5101 C++ Programming Manual: D:/OneDrive/Desktop Directory Reference

  • OneDrive
  • Desktop
Desktop Directory Reference

Directories

         产品文档


5101 C++ Programming Manual: D:/OneDrive/Desktop/产品文档/CHM/5101 Directory Reference

  • OneDrive
  • Desktop
  • 产品文档
  • CHM
  • 5101
5101 Directory Reference

Directories

         C++


5101 C++ Programming Manual: D:/OneDrive/Desktop/产品文档 Directory Reference

  • OneDrive
  • Desktop
  • 产品文档
产品文档 Directory Reference

Directories

         CHM


5101 C++ Programming Manual: D:/OneDrive Directory Reference

  • OneDrive
OneDrive Directory Reference

Directories

         Desktop


5101 C++ Programming Manual: File List

File List
Here is a list of all files with brief descriptions:
[detail level 1234567]
OneDrive |
Desktop |
产品文档 |
CHM |
5101 |
C++ |
JY5101.h | @SectionBegin JY5101 FileHead


5101 C++ Programming Manual: File Members

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • j
Here is a list of all file members with links to the files they belong to:

- j -

  • JY5101_ADCCount_Int : JY5101.h
  • JY5101_AI_Analog : JY5101.h
  • JY5101_AI_BandWidth : JY5101.h
  • JY5101_AI_BandWidth_15K : JY5101.h
  • JY5101_AI_BandWidth_376K : JY5101.h
  • JY5101_AI_BandWidth_39K : JY5101.h
  • JY5101_AI_ChannelGroups_Int : JY5101.h
  • JY5101_AI_CheckBufferStatus() : JY5101.h
  • JY5101_AI_Continuous : JY5101.h
  • JY5101_AI_Diff : JY5101.h
  • JY5101_AI_Digital : JY5101.h
  • JY5101_AI_EnableChannel() : JY5101.h
  • JY5101_AI_Finite : JY5101.h
  • JY5101_AI_Immediately : JY5101.h
  • JY5101_AI_MaxSampleRate_Double : JY5101.h
  • JY5101_AI_MinSampleRate_Double : JY5101.h
  • JY5101_AI_NumberOfChannels_Int : JY5101.h
  • JY5101_AI_ReadData() : JY5101.h
  • JY5101_AI_ReadRawData() : JY5101.h
  • JY5101_AI_ReadRawSinglePoint() : JY5101.h
  • JY5101_AI_ReadSinglePoint() : JY5101.h
  • JY5101_AI_RSE : JY5101.h
  • JY5101_AI_SampleClock_Input : JY5101.h
  • JY5101_AI_SampleMode : JY5101.h
  • JY5101_AI_SendSoftTrigger() : JY5101.h
  • JY5101_AI_SetAnalogEdgeReferenceTrigger() : JY5101.h
  • JY5101_AI_SetAnalogEdgeStartTrigger() : JY5101.h
  • JY5101_AI_SetAnalogHysteresisReferenceTrigger() : JY5101.h
  • JY5101_AI_SetAnalogHysteresisStartTrigger() : JY5101.h
  • JY5101_AI_SetAnalogTriggerMultiChannelMode() : JY5101.h
  • JY5101_AI_SetAnalogWindowReferenceTrigger() : JY5101.h
  • JY5101_AI_SetAnalogWindowStartTrigger() : JY5101.h
  • JY5101_AI_SetDigitalReferenceTrigger() : JY5101.h
  • JY5101_AI_SetDigitalStartTrigger() : JY5101.h
  • JY5101_AI_SetDSMode() : JY5101.h
  • JY5101_AI_SetMode() : JY5101.h
  • JY5101_AI_SetPreTriggerSamples() : JY5101.h
  • JY5101_AI_SetReferenceTriggerType() : JY5101.h
  • JY5101_AI_SetReTriggerCount() : JY5101.h
  • JY5101_AI_SetSampleClock() : JY5101.h
  • JY5101_AI_SetSampleRate() : JY5101.h
  • JY5101_AI_SetSamplesToAcquire() : JY5101.h
  • JY5101_AI_SetStartTriggerType() : JY5101.h
  • JY5101_AI_Single : JY5101.h
  • JY5101_AI_Soft : JY5101.h
  • JY5101_AI_Start() : JY5101.h
  • JY5101_AI_Stop() : JY5101.h
  • JY5101_AI_Terminal : JY5101.h
  • JY5101_AI_TriggerType : JY5101.h
  • JY5101_AI_WaitUntilDone() : JY5101.h
  • JY5101_AnalogTriggerEdge : JY5101.h
  • JY5101_AnalogTriggerSource : JY5101.h
  • JY5101_AnalogWindowCondition : JY5101.h
  • JY5101_And : JY5101.h
  • JY5101_AnyEdge : JY5101.h
  • JY5101_AO_CheckBufferStatus() : JY5101.h
  • JY5101_AO_ContinuousNoWrapping : JY5101.h
  • JY5101_AO_ContinuousWrapping : JY5101.h
  • JY5101_AO_Digital : JY5101.h
  • JY5101_AO_EnableChannel() : JY5101.h
  • JY5101_AO_Finite : JY5101.h
  • JY5101_AO_Immediately : JY5101.h
  • JY5101_AO_SampleClock_Input : JY5101.h
  • JY5101_AO_SendSoftTrigger() : JY5101.h
  • JY5101_AO_SetDigitalStartTrigger() : JY5101.h
  • JY5101_AO_SetMode() : JY5101.h
  • JY5101_AO_SetOutputCompleteState() : JY5101.h
  • JY5101_AO_SetSampleClock() : JY5101.h
  • JY5101_AO_SetSamplesToUpdate() : JY5101.h
  • JY5101_AO_SetStartTriggerType() : JY5101.h
  • JY5101_AO_SetUpdateRate() : JY5101.h
  • JY5101_AO_Single : JY5101.h
  • JY5101_AO_Soft : JY5101.h
  • JY5101_AO_Start() : JY5101.h
  • JY5101_AO_Stop() : JY5101.h
  • JY5101_AO_UpdateMode : JY5101.h
  • JY5101_AO_WaitUntilDone() : JY5101.h
  • JY5101_AO_WriteData() : JY5101.h
  • JY5101_AO_WriteRawData() : JY5101.h
  • JY5101_AO_WriteRawSinglePoint() : JY5101.h
  • JY5101_AO_WriteSinglePoint() : JY5101.h
  • JY5101_Capability_Item : JY5101.h
  • JY5101_Channel_0 : JY5101.h
  • JY5101_Channel_1 : JY5101.h
  • JY5101_Channel_10 : JY5101.h
  • JY5101_Channel_11 : JY5101.h
  • JY5101_Channel_12 : JY5101.h
  • JY5101_Channel_13 : JY5101.h
  • JY5101_Channel_14 : JY5101.h
  • JY5101_Channel_15 : JY5101.h
  • JY5101_Channel_16 : JY5101.h
  • JY5101_Channel_17 : JY5101.h
  • JY5101_Channel_18 : JY5101.h
  • JY5101_Channel_19 : JY5101.h
  • JY5101_Channel_2 : JY5101.h
  • JY5101_Channel_20 : JY5101.h
  • JY5101_Channel_21 : JY5101.h
  • JY5101_Channel_22 : JY5101.h
  • JY5101_Channel_23 : JY5101.h
  • JY5101_Channel_24 : JY5101.h
  • JY5101_Channel_25 : JY5101.h
  • JY5101_Channel_26 : JY5101.h
  • JY5101_Channel_27 : JY5101.h
  • JY5101_Channel_28 : JY5101.h
  • JY5101_Channel_29 : JY5101.h
  • JY5101_Channel_3 : JY5101.h
  • JY5101_Channel_30 : JY5101.h
  • JY5101_Channel_31 : JY5101.h
  • JY5101_Channel_4 : JY5101.h
  • JY5101_Channel_5 : JY5101.h
  • JY5101_Channel_6 : JY5101.h
  • JY5101_Channel_7 : JY5101.h
  • JY5101_Channel_8 : JY5101.h
  • JY5101_Channel_9 : JY5101.h
  • JY5101_CI_0_SampleClock_Input : JY5101.h
  • JY5101_CI_1_SampleClock_Input : JY5101.h
  • JY5101_CI_CheckBufferStatus() : JY5101.h
  • JY5101_CI_Continuous : JY5101.h
  • JY5101_CI_Count_Down : JY5101.h
  • JY5101_CI_Count_External : JY5101.h
  • JY5101_CI_Count_Up : JY5101.h
  • JY5101_CI_CounterEventSignalIdleState : JY5101.h
  • JY5101_CI_CounterEventSignalIdleState_High : JY5101.h
  • JY5101_CI_CounterEventSignalIdleState_Low : JY5101.h
  • JY5101_CI_CounterLevel : JY5101.h
  • JY5101_CI_CounterLevel_High : JY5101.h
  • JY5101_CI_CounterLevel_Low : JY5101.h
  • JY5101_CI_EdgeCount : JY5101.h
  • JY5101_CI_EnableChannel() : JY5101.h
  • JY5101_CI_EncoderTwoPulse : JY5101.h
  • JY5101_CI_EncoderX1 : JY5101.h
  • JY5101_CI_EncoderX2 : JY5101.h
  • JY5101_CI_EncoderX4 : JY5101.h
  • JY5101_CI_ExternalClock : JY5101.h
  • JY5101_CI_Finite : JY5101.h
  • JY5101_CI_ImplicitClock : JY5101.h
  • JY5101_CI_InternalClock : JY5101.h
  • JY5101_CI_Measure_EdgeSeparation : JY5101.h
  • JY5101_CI_Measure_FrequencyOrPeriod : JY5101.h
  • JY5101_CI_Measure_PulseWidth : JY5101.h
  • JY5101_CI_Measure_SemiPeriod : JY5101.h
  • JY5101_CI_MeasureType : JY5101.h
  • JY5101_CI_ReadCountValues() : JY5101.h
  • JY5101_CI_ReadMeasureValues() : JY5101.h
  • JY5101_CI_ReadSingleCountValue() : JY5101.h
  • JY5101_CI_ReadSingleMeasureValue() : JY5101.h
  • JY5101_CI_ReturnOneValue : JY5101.h
  • JY5101_CI_ReturnTwoValue : JY5101.h
  • JY5101_CI_SampleClock : JY5101.h
  • JY5101_CI_SampleMode : JY5101.h
  • JY5101_CI_SendSoftTrigger() : JY5101.h
  • JY5101_CI_SetAuxTerminal() : JY5101.h
  • JY5101_CI_SetCounterParament() : JY5101.h
  • JY5101_CI_SetCounterType() : JY5101.h
  • JY5101_CI_SetDigitalStartTrigger() : JY5101.h
  • JY5101_CI_SetEdgeCountEvent() : JY5101.h
  • JY5101_CI_SetFirstSampleClock() : JY5101.h
  • JY5101_CI_SetGateTerminal() : JY5101.h
  • JY5101_CI_SetMode() : JY5101.h
  • JY5101_CI_SetOutTerminal() : JY5101.h
  • JY5101_CI_SetPauseTriggerLevel() : JY5101.h
  • JY5101_CI_SetPauseTriggerTerminal() : JY5101.h
  • JY5101_CI_SetSampleClock() : JY5101.h
  • JY5101_CI_SetSamplesToAcquire() : JY5101.h
  • JY5101_CI_SetSignalReverse() : JY5101.h
  • JY5101_CI_SetSourceTerminal() : JY5101.h
  • JY5101_CI_SetStartingEdge() : JY5101.h
  • JY5101_CI_SetStartTriggerType() : JY5101.h
  • JY5101_CI_SetTimeBase() : JY5101.h
  • JY5101_CI_SetValueReturnMode() : JY5101.h
  • JY5101_CI_SetZReloadEnabled() : JY5101.h
  • JY5101_CI_Single : JY5101.h
  • JY5101_CI_Start() : JY5101.h
  • JY5101_CI_StartingEdge : JY5101.h
  • JY5101_CI_Stop() : JY5101.h
  • JY5101_CI_ValueReturnMode : JY5101.h
  • JY5101_CIO_100kHz_Input : JY5101.h
  • JY5101_CIO_100MHz_Input : JY5101.h
  • JY5101_CIO_5MHz_Input : JY5101.h
  • JY5101_CIO_Digital : JY5101.h
  • JY5101_CIO_Immediately : JY5101.h
  • JY5101_CIO_Soft : JY5101.h
  • JY5101_CIO_TriggerType : JY5101.h
  • JY5101_Clock_AI_SampleClock : JY5101.h
  • JY5101_Clock_AO_SampleClock : JY5101.h
  • JY5101_Clock_CI_0_SampleClock : JY5101.h
  • JY5101_Clock_CI_1_SampleClock : JY5101.h
  • JY5101_Clock_CO_0_Output : JY5101.h
  • JY5101_Clock_CO_1_Output : JY5101.h
  • JY5101_Clock_PFI_0 : JY5101.h
  • JY5101_Clock_PFI_1 : JY5101.h
  • JY5101_Clock_PFI_10 : JY5101.h
  • JY5101_Clock_PFI_11 : JY5101.h
  • JY5101_Clock_PFI_12 : JY5101.h
  • JY5101_Clock_PFI_13 : JY5101.h
  • JY5101_Clock_PFI_14 : JY5101.h
  • JY5101_Clock_PFI_15 : JY5101.h
  • JY5101_Clock_PFI_16 : JY5101.h
  • JY5101_Clock_PFI_17 : JY5101.h
  • JY5101_Clock_PFI_18 : JY5101.h
  • JY5101_Clock_PFI_19 : JY5101.h
  • JY5101_Clock_PFI_2 : JY5101.h
  • JY5101_Clock_PFI_20 : JY5101.h
  • JY5101_Clock_PFI_21 : JY5101.h
  • JY5101_Clock_PFI_22 : JY5101.h
  • JY5101_Clock_PFI_23 : JY5101.h
  • JY5101_Clock_PFI_3 : JY5101.h
  • JY5101_Clock_PFI_4 : JY5101.h
  • JY5101_Clock_PFI_5 : JY5101.h
  • JY5101_Clock_PFI_6 : JY5101.h
  • JY5101_Clock_PFI_7 : JY5101.h
  • JY5101_Clock_PFI_8 : JY5101.h
  • JY5101_Clock_PFI_9 : JY5101.h
  • JY5101_Clock_PXI_Trig_0 : JY5101.h
  • JY5101_Clock_PXI_Trig_1 : JY5101.h
  • JY5101_Clock_PXI_Trig_2 : JY5101.h
  • JY5101_Clock_PXI_Trig_3 : JY5101.h
  • JY5101_Clock_PXI_Trig_4 : JY5101.h
  • JY5101_Clock_PXI_Trig_5 : JY5101.h
  • JY5101_Clock_PXI_Trig_6 : JY5101.h
  • JY5101_Clock_PXI_Trig_7 : JY5101.h
  • JY5101_ClockSource : JY5101.h
  • JY5101_Close() : JY5101.h
  • JY5101_CO_0_Output_Input : JY5101.h
  • JY5101_CO_1_Output_Input : JY5101.h
  • JY5101_CO_CheckCounterStatus() : JY5101.h
  • JY5101_CO_EnableChannel() : JY5101.h
  • JY5101_CO_HighLevel : JY5101.h
  • JY5101_CO_HighOut : JY5101.h
  • JY5101_CO_HoldOn : JY5101.h
  • JY5101_CO_IdleState : JY5101.h
  • JY5101_CO_LowLevel : JY5101.h
  • JY5101_CO_LowOut : JY5101.h
  • JY5101_CO_PauseTriger_OutState : JY5101.h
  • JY5101_CO_SendSoftTrigger() : JY5101.h
  • JY5101_CO_SetCounterParament() : JY5101.h
  • JY5101_CO_SetDigitalStartTrigger() : JY5101.h
  • JY5101_CO_SetFrequency() : JY5101.h
  • JY5101_CO_SetOutTerminal() : JY5101.h
  • JY5101_CO_SetPauseTriggerLevel() : JY5101.h
  • JY5101_CO_SetPauseTriggerOutState() : JY5101.h
  • JY5101_CO_SetPauseTriggerTerminal() : JY5101.h
  • JY5101_CO_SetStartTriggerType() : JY5101.h
  • JY5101_CO_SetTimeBase() : JY5101.h
  • JY5101_CO_Start() : JY5101.h
  • JY5101_CO_Stop() : JY5101.h
  • JY5101_CO_WaitUntilDone() : JY5101.h
  • JY5101_CountDirection : JY5101.h
  • JY5101_CountTimeBase : JY5101.h
  • JY5101_DeviceHandle : JY5101.h
  • JY5101_DI_AddLines() : JY5101.h
  • JY5101_DI_ReadSinglePoint() : JY5101.h
  • JY5101_DI_ReadSinglePoint_U32() : JY5101.h
  • JY5101_DI_Start() : JY5101.h
  • JY5101_DI_Stop() : JY5101.h
  • JY5101_DigitalTriggerEdge : JY5101.h
  • JY5101_DigitalTriggerSource : JY5101.h
  • JY5101_DisableAICalibration() : JY5101.h
  • JY5101_DisableAOCalibration() : JY5101.h
  • JY5101_DisconnectSignalRouting() : JY5101.h
  • JY5101_DO_AddLines() : JY5101.h
  • JY5101_DO_ReadSinglePoint() : JY5101.h
  • JY5101_DO_ReadSinglePoint_U32() : JY5101.h
  • JY5101_DO_Start() : JY5101.h
  • JY5101_DO_Stop() : JY5101.h
  • JY5101_DO_WriteSinglePoint() : JY5101.h
  • JY5101_DO_WriteSinglePoint_U32() : JY5101.h
  • JY5101_ECLK : JY5101.h
  • JY5101_Entering : JY5101.h
  • JY5101_External_Timebase : JY5101.h
  • JY5101_ExternalClock : JY5101.h
  • JY5101_ExternalClockTerminal : JY5101.h
  • JY5101_Falling : JY5101.h
  • JY5101_FallingEdge : JY5101.h
  • JY5101_FallingSlope : JY5101.h
  • JY5101_GetCapabilityDouble() : JY5101.h
  • JY5101_GetCapabilityDoubleByName() : JY5101.h
  • JY5101_GetCapabilityDoubleBySlotNumber() : JY5101.h
  • JY5101_GetCapabilityInt() : JY5101.h
  • JY5101_GetCapabilityIntByName() : JY5101.h
  • JY5101_GetCapabilityIntBySlotNumber() : JY5101.h
  • JY5101_GetDeviceID() : JY5101.h
  • JY5101_GetDeviceInfo() : JY5101.h
  • JY5101_GetDeviceSerialNumber() : JY5101.h
  • JY5101_GetFPGATemperature() : JY5101.h
  • JY5101_HighLevel : JY5101.h
  • JY5101_Hold : JY5101.h
  • JY5101_InputTerminal : JY5101.h
  • JY5101_Inter_AI_ReferenceTrig : JY5101.h
  • JY5101_Inter_AI_StartTrig : JY5101.h
  • JY5101_Inter_AO_StartTrig : JY5101.h
  • JY5101_Inter_Counter_0_EventOut : JY5101.h
  • JY5101_Inter_Counter_0_Out : JY5101.h
  • JY5101_Inter_Counter_0_StartTrig : JY5101.h
  • JY5101_Inter_Counter_1_EventOut : JY5101.h
  • JY5101_Inter_Counter_1_Out : JY5101.h
  • JY5101_Inter_Counter_1_StartTrig : JY5101.h
  • JY5101_Internal : JY5101.h
  • JY5101_Internal_Timebase_100K : JY5101.h
  • JY5101_Internal_Timebase_100M : JY5101.h
  • JY5101_Internal_Timebase_5M : JY5101.h
  • JY5101_InternalClock : JY5101.h
  • JY5101_Leaving : JY5101.h
  • JY5101_LevelState : JY5101.h
  • JY5101_LowLevel : JY5101.h
  • JY5101_MultiChannelCompositionLogic : JY5101.h
  • JY5101_None : JY5101.h
  • JY5101_Open() : JY5101.h
  • JY5101_OpenByName() : JY5101.h
  • JY5101_Or : JY5101.h
  • JY5101_OutputCompleteState : JY5101.h
  • JY5101_PFI0 : JY5101.h
  • JY5101_PFI0_Input : JY5101.h
  • JY5101_PFI0_OUT : JY5101.h
  • JY5101_PFI1 : JY5101.h
  • JY5101_PFI10 : JY5101.h
  • JY5101_PFI10_Input : JY5101.h
  • JY5101_PFI10_OUT : JY5101.h
  • JY5101_PFI11 : JY5101.h
  • JY5101_PFI11_Input : JY5101.h
  • JY5101_PFI11_OUT : JY5101.h
  • JY5101_PFI12 : JY5101.h
  • JY5101_PFI12_Input : JY5101.h
  • JY5101_PFI12_OUT : JY5101.h
  • JY5101_PFI13 : JY5101.h
  • JY5101_PFI13_Input : JY5101.h
  • JY5101_PFI13_OUT : JY5101.h
  • JY5101_PFI14 : JY5101.h
  • JY5101_PFI14_Input : JY5101.h
  • JY5101_PFI14_OUT : JY5101.h
  • JY5101_PFI15 : JY5101.h
  • JY5101_PFI15_Input : JY5101.h
  • JY5101_PFI15_OUT : JY5101.h
  • JY5101_PFI16 : JY5101.h
  • JY5101_PFI16_Input : JY5101.h
  • JY5101_PFI16_OUT : JY5101.h
  • JY5101_PFI17 : JY5101.h
  • JY5101_PFI17_Input : JY5101.h
  • JY5101_PFI17_OUT : JY5101.h
  • JY5101_PFI18 : JY5101.h
  • JY5101_PFI18_Input : JY5101.h
  • JY5101_PFI18_OUT : JY5101.h
  • JY5101_PFI19 : JY5101.h
  • JY5101_PFI19_Input : JY5101.h
  • JY5101_PFI19_OUT : JY5101.h
  • JY5101_PFI1_Input : JY5101.h
  • JY5101_PFI1_OUT : JY5101.h
  • JY5101_PFI2 : JY5101.h
  • JY5101_PFI20 : JY5101.h
  • JY5101_PFI20_Input : JY5101.h
  • JY5101_PFI20_OUT : JY5101.h
  • JY5101_PFI21 : JY5101.h
  • JY5101_PFI21_Input : JY5101.h
  • JY5101_PFI21_OUT : JY5101.h
  • JY5101_PFI22 : JY5101.h
  • JY5101_PFI22_Input : JY5101.h
  • JY5101_PFI22_OUT : JY5101.h
  • JY5101_PFI23 : JY5101.h
  • JY5101_PFI23_Input : JY5101.h
  • JY5101_PFI23_OUT : JY5101.h
  • JY5101_PFI2_Input : JY5101.h
  • JY5101_PFI2_OUT : JY5101.h
  • JY5101_PFI3 : JY5101.h
  • JY5101_PFI3_Input : JY5101.h
  • JY5101_PFI3_OUT : JY5101.h
  • JY5101_PFI4 : JY5101.h
  • JY5101_PFI4_Input : JY5101.h
  • JY5101_PFI4_OUT : JY5101.h
  • JY5101_PFI5 : JY5101.h
  • JY5101_PFI5_Input : JY5101.h
  • JY5101_PFI5_OUT : JY5101.h
  • JY5101_PFI6 : JY5101.h
  • JY5101_PFI6_Input : JY5101.h
  • JY5101_PFI6_OUT : JY5101.h
  • JY5101_PFI7 : JY5101.h
  • JY5101_PFI7_Input : JY5101.h
  • JY5101_PFI7_OUT : JY5101.h
  • JY5101_PFI8 : JY5101.h
  • JY5101_PFI8_Input : JY5101.h
  • JY5101_PFI8_OUT : JY5101.h
  • JY5101_PFI9 : JY5101.h
  • JY5101_PFI9_Input : JY5101.h
  • JY5101_PFI9_OUT : JY5101.h
  • JY5101_PXI_Trig0 : JY5101.h
  • JY5101_PXI_Trig0_Input : JY5101.h
  • JY5101_PXI_Trig1 : JY5101.h
  • JY5101_PXI_Trig1_Input : JY5101.h
  • JY5101_PXI_Trig2 : JY5101.h
  • JY5101_PXI_Trig2_Input : JY5101.h
  • JY5101_PXI_Trig3 : JY5101.h
  • JY5101_PXI_Trig3_Input : JY5101.h
  • JY5101_PXI_Trig4 : JY5101.h
  • JY5101_PXI_Trig4_Input : JY5101.h
  • JY5101_PXI_Trig5 : JY5101.h
  • JY5101_PXI_Trig5_Input : JY5101.h
  • JY5101_PXI_Trig6 : JY5101.h
  • JY5101_PXI_Trig6_Input : JY5101.h
  • JY5101_PXI_Trig7 : JY5101.h
  • JY5101_PXI_Trig7_Input : JY5101.h
  • JY5101_PXIe_Clk100 : JY5101.h
  • JY5101_PXITrig0_OUT : JY5101.h
  • JY5101_PXITrig1_OUT : JY5101.h
  • JY5101_PXITrig2_OUT : JY5101.h
  • JY5101_PXITrig3_OUT : JY5101.h
  • JY5101_PXITrig4_OUT : JY5101.h
  • JY5101_PXITrig5_OUT : JY5101.h
  • JY5101_PXITrig6_OUT : JY5101.h
  • JY5101_PXITrig7_OUT : JY5101.h
  • JY5101_ReferenceClock : JY5101.h
  • JY5101_ReferenceTrigger : JY5101.h
  • JY5101_Rising : JY5101.h
  • JY5101_RisingEdge : JY5101.h
  • JY5101_RisingSlope : JY5101.h
  • JY5101_SetDeviceStatusLed() : JY5101.h
  • JY5101_SetPFIFilter() : JY5101.h
  • JY5101_Signa_Counter_0_EventOut : JY5101.h
  • JY5101_Signa_Counter_1_EventOut : JY5101.h
  • JY5101_Signal_AI_ReferenceTrig : JY5101.h
  • JY5101_Signal_AI_SampleClock : JY5101.h
  • JY5101_Signal_AI_StartTrig : JY5101.h
  • JY5101_Signal_AO_SampleClock : JY5101.h
  • JY5101_Signal_AO_StartTrig : JY5101.h
  • JY5101_Signal_CI_0_SampleClock : JY5101.h
  • JY5101_Signal_CI_1_SampleClock : JY5101.h
  • JY5101_Signal_CIO_0_StartTrig : JY5101.h
  • JY5101_Signal_CIO_100kHz : JY5101.h
  • JY5101_Signal_CIO_100MHz : JY5101.h
  • JY5101_Signal_CIO_1_StartTrig : JY5101.h
  • JY5101_Signal_CIO_5MHz : JY5101.h
  • JY5101_Signal_CO_0_Output : JY5101.h
  • JY5101_Signal_CO_1_Output : JY5101.h
  • JY5101_Signal_Destination : JY5101.h
  • JY5101_Signal_PFI_0 : JY5101.h
  • JY5101_Signal_PFI_1 : JY5101.h
  • JY5101_Signal_PFI_10 : JY5101.h
  • JY5101_Signal_PFI_11 : JY5101.h
  • JY5101_Signal_PFI_12 : JY5101.h
  • JY5101_Signal_PFI_13 : JY5101.h
  • JY5101_Signal_PFI_14 : JY5101.h
  • JY5101_Signal_PFI_15 : JY5101.h
  • JY5101_Signal_PFI_16 : JY5101.h
  • JY5101_Signal_PFI_17 : JY5101.h
  • JY5101_Signal_PFI_18 : JY5101.h
  • JY5101_Signal_PFI_19 : JY5101.h
  • JY5101_Signal_PFI_2 : JY5101.h
  • JY5101_Signal_PFI_20 : JY5101.h
  • JY5101_Signal_PFI_21 : JY5101.h
  • JY5101_Signal_PFI_22 : JY5101.h
  • JY5101_Signal_PFI_23 : JY5101.h
  • JY5101_Signal_PFI_3 : JY5101.h
  • JY5101_Signal_PFI_4 : JY5101.h
  • JY5101_Signal_PFI_5 : JY5101.h
  • JY5101_Signal_PFI_6 : JY5101.h
  • JY5101_Signal_PFI_7 : JY5101.h
  • JY5101_Signal_PFI_8 : JY5101.h
  • JY5101_Signal_PFI_9 : JY5101.h
  • JY5101_Signal_PXI_Trig_0 : JY5101.h
  • JY5101_Signal_PXI_Trig_1 : JY5101.h
  • JY5101_Signal_PXI_Trig_2 : JY5101.h
  • JY5101_Signal_PXI_Trig_3 : JY5101.h
  • JY5101_Signal_PXI_Trig_4 : JY5101.h
  • JY5101_Signal_PXI_Trig_5 : JY5101.h
  • JY5101_Signal_PXI_Trig_6 : JY5101.h
  • JY5101_Signal_PXI_Trig_7 : JY5101.h
  • JY5101_Signal_Source : JY5101.h
  • JY5101_SignalRouting() : JY5101.h
  • JY5101_StartTrigger : JY5101.h
  • JY5101_TriggerMode : JY5101.h
  • JY5101_TriggerType : JY5101.h
  • JY5101_Zero : JY5101.h
  • JY5101Cal_SaveAIToEEPROM() : JY5101.h
  • JY5101Cal_SaveAOToEEPROM() : JY5101.h
  • JY5101Cal_SetAIEnvironmentParam() : JY5101.h
  • JY5101Cal_SetAOEnvironmentParam() : JY5101.h


5101 C++ Programming Manual: File Members

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • j
Here is a list of all enums with links to the files they belong to:

- j -

  • JY5101_AI_BandWidth : JY5101.h
  • JY5101_AI_SampleMode : JY5101.h
  • JY5101_AI_Terminal : JY5101.h
  • JY5101_AI_TriggerType : JY5101.h
  • JY5101_AnalogTriggerEdge : JY5101.h
  • JY5101_AnalogTriggerSource : JY5101.h
  • JY5101_AnalogWindowCondition : JY5101.h
  • JY5101_AO_UpdateMode : JY5101.h
  • JY5101_Capability_Item : JY5101.h
  • JY5101_CI_CounterEventSignalIdleState : JY5101.h
  • JY5101_CI_CounterLevel : JY5101.h
  • JY5101_CI_MeasureType : JY5101.h
  • JY5101_CI_SampleClock : JY5101.h
  • JY5101_CI_SampleMode : JY5101.h
  • JY5101_CI_StartingEdge : JY5101.h
  • JY5101_CI_ValueReturnMode : JY5101.h
  • JY5101_CIO_TriggerType : JY5101.h
  • JY5101_ClockSource : JY5101.h
  • JY5101_CO_IdleState : JY5101.h
  • JY5101_CO_PauseTriger_OutState : JY5101.h
  • JY5101_CountDirection : JY5101.h
  • JY5101_CountTimeBase : JY5101.h
  • JY5101_DigitalTriggerEdge : JY5101.h
  • JY5101_DigitalTriggerSource : JY5101.h
  • JY5101_ExternalClockTerminal : JY5101.h
  • JY5101_InputTerminal : JY5101.h
  • JY5101_LevelState : JY5101.h
  • JY5101_MultiChannelCompositionLogic : JY5101.h
  • JY5101_OutputCompleteState : JY5101.h
  • JY5101_ReferenceClock : JY5101.h
  • JY5101_Signal_Destination : JY5101.h
  • JY5101_Signal_Source : JY5101.h
  • JY5101_TriggerMode : JY5101.h
  • JY5101_TriggerType : JY5101.h


5101 C++ Programming Manual: File Members

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • j
Here is a list of all enum values with links to the files they belong to:

- j -

  • JY5101_ADCCount_Int : JY5101.h
  • JY5101_AI_Analog : JY5101.h
  • JY5101_AI_BandWidth_15K : JY5101.h
  • JY5101_AI_BandWidth_376K : JY5101.h
  • JY5101_AI_BandWidth_39K : JY5101.h
  • JY5101_AI_ChannelGroups_Int : JY5101.h
  • JY5101_AI_Continuous : JY5101.h
  • JY5101_AI_Diff : JY5101.h
  • JY5101_AI_Digital : JY5101.h
  • JY5101_AI_Finite : JY5101.h
  • JY5101_AI_Immediately : JY5101.h
  • JY5101_AI_MaxSampleRate_Double : JY5101.h
  • JY5101_AI_MinSampleRate_Double : JY5101.h
  • JY5101_AI_NumberOfChannels_Int : JY5101.h
  • JY5101_AI_RSE : JY5101.h
  • JY5101_AI_SampleClock_Input : JY5101.h
  • JY5101_AI_Single : JY5101.h
  • JY5101_AI_Soft : JY5101.h
  • JY5101_And : JY5101.h
  • JY5101_AnyEdge : JY5101.h
  • JY5101_AO_ContinuousNoWrapping : JY5101.h
  • JY5101_AO_ContinuousWrapping : JY5101.h
  • JY5101_AO_Digital : JY5101.h
  • JY5101_AO_Finite : JY5101.h
  • JY5101_AO_Immediately : JY5101.h
  • JY5101_AO_SampleClock_Input : JY5101.h
  • JY5101_AO_Single : JY5101.h
  • JY5101_AO_Soft : JY5101.h
  • JY5101_Channel_0 : JY5101.h
  • JY5101_Channel_1 : JY5101.h
  • JY5101_Channel_10 : JY5101.h
  • JY5101_Channel_11 : JY5101.h
  • JY5101_Channel_12 : JY5101.h
  • JY5101_Channel_13 : JY5101.h
  • JY5101_Channel_14 : JY5101.h
  • JY5101_Channel_15 : JY5101.h
  • JY5101_Channel_16 : JY5101.h
  • JY5101_Channel_17 : JY5101.h
  • JY5101_Channel_18 : JY5101.h
  • JY5101_Channel_19 : JY5101.h
  • JY5101_Channel_2 : JY5101.h
  • JY5101_Channel_20 : JY5101.h
  • JY5101_Channel_21 : JY5101.h
  • JY5101_Channel_22 : JY5101.h
  • JY5101_Channel_23 : JY5101.h
  • JY5101_Channel_24 : JY5101.h
  • JY5101_Channel_25 : JY5101.h
  • JY5101_Channel_26 : JY5101.h
  • JY5101_Channel_27 : JY5101.h
  • JY5101_Channel_28 : JY5101.h
  • JY5101_Channel_29 : JY5101.h
  • JY5101_Channel_3 : JY5101.h
  • JY5101_Channel_30 : JY5101.h
  • JY5101_Channel_31 : JY5101.h
  • JY5101_Channel_4 : JY5101.h
  • JY5101_Channel_5 : JY5101.h
  • JY5101_Channel_6 : JY5101.h
  • JY5101_Channel_7 : JY5101.h
  • JY5101_Channel_8 : JY5101.h
  • JY5101_Channel_9 : JY5101.h
  • JY5101_CI_0_SampleClock_Input : JY5101.h
  • JY5101_CI_1_SampleClock_Input : JY5101.h
  • JY5101_CI_Continuous : JY5101.h
  • JY5101_CI_Count_Down : JY5101.h
  • JY5101_CI_Count_External : JY5101.h
  • JY5101_CI_Count_Up : JY5101.h
  • JY5101_CI_CounterEventSignalIdleState_High : JY5101.h
  • JY5101_CI_CounterEventSignalIdleState_Low : JY5101.h
  • JY5101_CI_CounterLevel_High : JY5101.h
  • JY5101_CI_CounterLevel_Low : JY5101.h
  • JY5101_CI_EdgeCount : JY5101.h
  • JY5101_CI_EncoderTwoPulse : JY5101.h
  • JY5101_CI_EncoderX1 : JY5101.h
  • JY5101_CI_EncoderX2 : JY5101.h
  • JY5101_CI_EncoderX4 : JY5101.h
  • JY5101_CI_ExternalClock : JY5101.h
  • JY5101_CI_Finite : JY5101.h
  • JY5101_CI_ImplicitClock : JY5101.h
  • JY5101_CI_InternalClock : JY5101.h
  • JY5101_CI_Measure_EdgeSeparation : JY5101.h
  • JY5101_CI_Measure_FrequencyOrPeriod : JY5101.h
  • JY5101_CI_Measure_PulseWidth : JY5101.h
  • JY5101_CI_Measure_SemiPeriod : JY5101.h
  • JY5101_CI_ReturnOneValue : JY5101.h
  • JY5101_CI_ReturnTwoValue : JY5101.h
  • JY5101_CI_Single : JY5101.h
  • JY5101_CIO_100kHz_Input : JY5101.h
  • JY5101_CIO_100MHz_Input : JY5101.h
  • JY5101_CIO_5MHz_Input : JY5101.h
  • JY5101_CIO_Digital : JY5101.h
  • JY5101_CIO_Immediately : JY5101.h
  • JY5101_CIO_Soft : JY5101.h
  • JY5101_Clock_AI_SampleClock : JY5101.h
  • JY5101_Clock_AO_SampleClock : JY5101.h
  • JY5101_Clock_CI_0_SampleClock : JY5101.h
  • JY5101_Clock_CI_1_SampleClock : JY5101.h
  • JY5101_Clock_CO_0_Output : JY5101.h
  • JY5101_Clock_CO_1_Output : JY5101.h
  • JY5101_Clock_PFI_0 : JY5101.h
  • JY5101_Clock_PFI_1 : JY5101.h
  • JY5101_Clock_PFI_10 : JY5101.h
  • JY5101_Clock_PFI_11 : JY5101.h
  • JY5101_Clock_PFI_12 : JY5101.h
  • JY5101_Clock_PFI_13 : JY5101.h
  • JY5101_Clock_PFI_14 : JY5101.h
  • JY5101_Clock_PFI_15 : JY5101.h
  • JY5101_Clock_PFI_16 : JY5101.h
  • JY5101_Clock_PFI_17 : JY5101.h
  • JY5101_Clock_PFI_18 : JY5101.h
  • JY5101_Clock_PFI_19 : JY5101.h
  • JY5101_Clock_PFI_2 : JY5101.h
  • JY5101_Clock_PFI_20 : JY5101.h
  • JY5101_Clock_PFI_21 : JY5101.h
  • JY5101_Clock_PFI_22 : JY5101.h
  • JY5101_Clock_PFI_23 : JY5101.h
  • JY5101_Clock_PFI_3 : JY5101.h
  • JY5101_Clock_PFI_4 : JY5101.h
  • JY5101_Clock_PFI_5 : JY5101.h
  • JY5101_Clock_PFI_6 : JY5101.h
  • JY5101_Clock_PFI_7 : JY5101.h
  • JY5101_Clock_PFI_8 : JY5101.h
  • JY5101_Clock_PFI_9 : JY5101.h
  • JY5101_Clock_PXI_Trig_0 : JY5101.h
  • JY5101_Clock_PXI_Trig_1 : JY5101.h
  • JY5101_Clock_PXI_Trig_2 : JY5101.h
  • JY5101_Clock_PXI_Trig_3 : JY5101.h
  • JY5101_Clock_PXI_Trig_4 : JY5101.h
  • JY5101_Clock_PXI_Trig_5 : JY5101.h
  • JY5101_Clock_PXI_Trig_6 : JY5101.h
  • JY5101_Clock_PXI_Trig_7 : JY5101.h
  • JY5101_CO_0_Output_Input : JY5101.h
  • JY5101_CO_1_Output_Input : JY5101.h
  • JY5101_CO_HighLevel : JY5101.h
  • JY5101_CO_HighOut : JY5101.h
  • JY5101_CO_HoldOn : JY5101.h
  • JY5101_CO_LowLevel : JY5101.h
  • JY5101_CO_LowOut : JY5101.h
  • JY5101_ECLK : JY5101.h
  • JY5101_Entering : JY5101.h
  • JY5101_External_Timebase : JY5101.h
  • JY5101_ExternalClock : JY5101.h
  • JY5101_Falling : JY5101.h
  • JY5101_FallingEdge : JY5101.h
  • JY5101_FallingSlope : JY5101.h
  • JY5101_HighLevel : JY5101.h
  • JY5101_Hold : JY5101.h
  • JY5101_Inter_AI_ReferenceTrig : JY5101.h
  • JY5101_Inter_AI_StartTrig : JY5101.h
  • JY5101_Inter_AO_StartTrig : JY5101.h
  • JY5101_Inter_Counter_0_EventOut : JY5101.h
  • JY5101_Inter_Counter_0_Out : JY5101.h
  • JY5101_Inter_Counter_0_StartTrig : JY5101.h
  • JY5101_Inter_Counter_1_EventOut : JY5101.h
  • JY5101_Inter_Counter_1_Out : JY5101.h
  • JY5101_Inter_Counter_1_StartTrig : JY5101.h
  • JY5101_Internal : JY5101.h
  • JY5101_Internal_Timebase_100K : JY5101.h
  • JY5101_Internal_Timebase_100M : JY5101.h
  • JY5101_Internal_Timebase_5M : JY5101.h
  • JY5101_InternalClock : JY5101.h
  • JY5101_Leaving : JY5101.h
  • JY5101_LowLevel : JY5101.h
  • JY5101_None : JY5101.h
  • JY5101_Or : JY5101.h
  • JY5101_PFI0 : JY5101.h
  • JY5101_PFI0_Input : JY5101.h
  • JY5101_PFI0_OUT : JY5101.h
  • JY5101_PFI1 : JY5101.h
  • JY5101_PFI10 : JY5101.h
  • JY5101_PFI10_Input : JY5101.h
  • JY5101_PFI10_OUT : JY5101.h
  • JY5101_PFI11 : JY5101.h
  • JY5101_PFI11_Input : JY5101.h
  • JY5101_PFI11_OUT : JY5101.h
  • JY5101_PFI12 : JY5101.h
  • JY5101_PFI12_Input : JY5101.h
  • JY5101_PFI12_OUT : JY5101.h
  • JY5101_PFI13 : JY5101.h
  • JY5101_PFI13_Input : JY5101.h
  • JY5101_PFI13_OUT : JY5101.h
  • JY5101_PFI14 : JY5101.h
  • JY5101_PFI14_Input : JY5101.h
  • JY5101_PFI14_OUT : JY5101.h
  • JY5101_PFI15 : JY5101.h
  • JY5101_PFI15_Input : JY5101.h
  • JY5101_PFI15_OUT : JY5101.h
  • JY5101_PFI16 : JY5101.h
  • JY5101_PFI16_Input : JY5101.h
  • JY5101_PFI16_OUT : JY5101.h
  • JY5101_PFI17 : JY5101.h
  • JY5101_PFI17_Input : JY5101.h
  • JY5101_PFI17_OUT : JY5101.h
  • JY5101_PFI18 : JY5101.h
  • JY5101_PFI18_Input : JY5101.h
  • JY5101_PFI18_OUT : JY5101.h
  • JY5101_PFI19 : JY5101.h
  • JY5101_PFI19_Input : JY5101.h
  • JY5101_PFI19_OUT : JY5101.h
  • JY5101_PFI1_Input : JY5101.h
  • JY5101_PFI1_OUT : JY5101.h
  • JY5101_PFI2 : JY5101.h
  • JY5101_PFI20 : JY5101.h
  • JY5101_PFI20_Input : JY5101.h
  • JY5101_PFI20_OUT : JY5101.h
  • JY5101_PFI21 : JY5101.h
  • JY5101_PFI21_Input : JY5101.h
  • JY5101_PFI21_OUT : JY5101.h
  • JY5101_PFI22 : JY5101.h
  • JY5101_PFI22_Input : JY5101.h
  • JY5101_PFI22_OUT : JY5101.h
  • JY5101_PFI23 : JY5101.h
  • JY5101_PFI23_Input : JY5101.h
  • JY5101_PFI23_OUT : JY5101.h
  • JY5101_PFI2_Input : JY5101.h
  • JY5101_PFI2_OUT : JY5101.h
  • JY5101_PFI3 : JY5101.h
  • JY5101_PFI3_Input : JY5101.h
  • JY5101_PFI3_OUT : JY5101.h
  • JY5101_PFI4 : JY5101.h
  • JY5101_PFI4_Input : JY5101.h
  • JY5101_PFI4_OUT : JY5101.h
  • JY5101_PFI5 : JY5101.h
  • JY5101_PFI5_Input : JY5101.h
  • JY5101_PFI5_OUT : JY5101.h
  • JY5101_PFI6 : JY5101.h
  • JY5101_PFI6_Input : JY5101.h
  • JY5101_PFI6_OUT : JY5101.h
  • JY5101_PFI7 : JY5101.h
  • JY5101_PFI7_Input : JY5101.h
  • JY5101_PFI7_OUT : JY5101.h
  • JY5101_PFI8 : JY5101.h
  • JY5101_PFI8_Input : JY5101.h
  • JY5101_PFI8_OUT : JY5101.h
  • JY5101_PFI9 : JY5101.h
  • JY5101_PFI9_Input : JY5101.h
  • JY5101_PFI9_OUT : JY5101.h
  • JY5101_PXI_Trig0 : JY5101.h
  • JY5101_PXI_Trig0_Input : JY5101.h
  • JY5101_PXI_Trig1 : JY5101.h
  • JY5101_PXI_Trig1_Input : JY5101.h
  • JY5101_PXI_Trig2 : JY5101.h
  • JY5101_PXI_Trig2_Input : JY5101.h
  • JY5101_PXI_Trig3 : JY5101.h
  • JY5101_PXI_Trig3_Input : JY5101.h
  • JY5101_PXI_Trig4 : JY5101.h
  • JY5101_PXI_Trig4_Input : JY5101.h
  • JY5101_PXI_Trig5 : JY5101.h
  • JY5101_PXI_Trig5_Input : JY5101.h
  • JY5101_PXI_Trig6 : JY5101.h
  • JY5101_PXI_Trig6_Input : JY5101.h
  • JY5101_PXI_Trig7 : JY5101.h
  • JY5101_PXI_Trig7_Input : JY5101.h
  • JY5101_PXIe_Clk100 : JY5101.h
  • JY5101_PXITrig0_OUT : JY5101.h
  • JY5101_PXITrig1_OUT : JY5101.h
  • JY5101_PXITrig2_OUT : JY5101.h
  • JY5101_PXITrig3_OUT : JY5101.h
  • JY5101_PXITrig4_OUT : JY5101.h
  • JY5101_PXITrig5_OUT : JY5101.h
  • JY5101_PXITrig6_OUT : JY5101.h
  • JY5101_PXITrig7_OUT : JY5101.h
  • JY5101_ReferenceTrigger : JY5101.h
  • JY5101_Rising : JY5101.h
  • JY5101_RisingEdge : JY5101.h
  • JY5101_RisingSlope : JY5101.h
  • JY5101_Signa_Counter_0_EventOut : JY5101.h
  • JY5101_Signa_Counter_1_EventOut : JY5101.h
  • JY5101_Signal_AI_ReferenceTrig : JY5101.h
  • JY5101_Signal_AI_SampleClock : JY5101.h
  • JY5101_Signal_AI_StartTrig : JY5101.h
  • JY5101_Signal_AO_SampleClock : JY5101.h
  • JY5101_Signal_AO_StartTrig : JY5101.h
  • JY5101_Signal_CI_0_SampleClock : JY5101.h
  • JY5101_Signal_CI_1_SampleClock : JY5101.h
  • JY5101_Signal_CIO_0_StartTrig : JY5101.h
  • JY5101_Signal_CIO_100kHz : JY5101.h
  • JY5101_Signal_CIO_100MHz : JY5101.h
  • JY5101_Signal_CIO_1_StartTrig : JY5101.h
  • JY5101_Signal_CIO_5MHz : JY5101.h
  • JY5101_Signal_CO_0_Output : JY5101.h
  • JY5101_Signal_CO_1_Output : JY5101.h
  • JY5101_Signal_PFI_0 : JY5101.h
  • JY5101_Signal_PFI_1 : JY5101.h
  • JY5101_Signal_PFI_10 : JY5101.h
  • JY5101_Signal_PFI_11 : JY5101.h
  • JY5101_Signal_PFI_12 : JY5101.h
  • JY5101_Signal_PFI_13 : JY5101.h
  • JY5101_Signal_PFI_14 : JY5101.h
  • JY5101_Signal_PFI_15 : JY5101.h
  • JY5101_Signal_PFI_16 : JY5101.h
  • JY5101_Signal_PFI_17 : JY5101.h
  • JY5101_Signal_PFI_18 : JY5101.h
  • JY5101_Signal_PFI_19 : JY5101.h
  • JY5101_Signal_PFI_2 : JY5101.h
  • JY5101_Signal_PFI_20 : JY5101.h
  • JY5101_Signal_PFI_21 : JY5101.h
  • JY5101_Signal_PFI_22 : JY5101.h
  • JY5101_Signal_PFI_23 : JY5101.h
  • JY5101_Signal_PFI_3 : JY5101.h
  • JY5101_Signal_PFI_4 : JY5101.h
  • JY5101_Signal_PFI_5 : JY5101.h
  • JY5101_Signal_PFI_6 : JY5101.h
  • JY5101_Signal_PFI_7 : JY5101.h
  • JY5101_Signal_PFI_8 : JY5101.h
  • JY5101_Signal_PFI_9 : JY5101.h
  • JY5101_Signal_PXI_Trig_0 : JY5101.h
  • JY5101_Signal_PXI_Trig_1 : JY5101.h
  • JY5101_Signal_PXI_Trig_2 : JY5101.h
  • JY5101_Signal_PXI_Trig_3 : JY5101.h
  • JY5101_Signal_PXI_Trig_4 : JY5101.h
  • JY5101_Signal_PXI_Trig_5 : JY5101.h
  • JY5101_Signal_PXI_Trig_6 : JY5101.h
  • JY5101_Signal_PXI_Trig_7 : JY5101.h
  • JY5101_StartTrigger : JY5101.h
  • JY5101_Zero : JY5101.h


5101 C++ Programming Manual: File Members

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • j
Here is a list of all functions with links to the files they belong to:

- j -

  • JY5101_AI_CheckBufferStatus() : JY5101.h
  • JY5101_AI_EnableChannel() : JY5101.h
  • JY5101_AI_ReadData() : JY5101.h
  • JY5101_AI_ReadRawData() : JY5101.h
  • JY5101_AI_ReadRawSinglePoint() : JY5101.h
  • JY5101_AI_ReadSinglePoint() : JY5101.h
  • JY5101_AI_SendSoftTrigger() : JY5101.h
  • JY5101_AI_SetAnalogEdgeReferenceTrigger() : JY5101.h
  • JY5101_AI_SetAnalogEdgeStartTrigger() : JY5101.h
  • JY5101_AI_SetAnalogHysteresisReferenceTrigger() : JY5101.h
  • JY5101_AI_SetAnalogHysteresisStartTrigger() : JY5101.h
  • JY5101_AI_SetAnalogTriggerMultiChannelMode() : JY5101.h
  • JY5101_AI_SetAnalogWindowReferenceTrigger() : JY5101.h
  • JY5101_AI_SetAnalogWindowStartTrigger() : JY5101.h
  • JY5101_AI_SetDigitalReferenceTrigger() : JY5101.h
  • JY5101_AI_SetDigitalStartTrigger() : JY5101.h
  • JY5101_AI_SetDSMode() : JY5101.h
  • JY5101_AI_SetMode() : JY5101.h
  • JY5101_AI_SetPreTriggerSamples() : JY5101.h
  • JY5101_AI_SetReferenceTriggerType() : JY5101.h
  • JY5101_AI_SetReTriggerCount() : JY5101.h
  • JY5101_AI_SetSampleClock() : JY5101.h
  • JY5101_AI_SetSampleRate() : JY5101.h
  • JY5101_AI_SetSamplesToAcquire() : JY5101.h
  • JY5101_AI_SetStartTriggerType() : JY5101.h
  • JY5101_AI_Start() : JY5101.h
  • JY5101_AI_Stop() : JY5101.h
  • JY5101_AI_WaitUntilDone() : JY5101.h
  • JY5101_AO_CheckBufferStatus() : JY5101.h
  • JY5101_AO_EnableChannel() : JY5101.h
  • JY5101_AO_SendSoftTrigger() : JY5101.h
  • JY5101_AO_SetDigitalStartTrigger() : JY5101.h
  • JY5101_AO_SetMode() : JY5101.h
  • JY5101_AO_SetOutputCompleteState() : JY5101.h
  • JY5101_AO_SetSampleClock() : JY5101.h
  • JY5101_AO_SetSamplesToUpdate() : JY5101.h
  • JY5101_AO_SetStartTriggerType() : JY5101.h
  • JY5101_AO_SetUpdateRate() : JY5101.h
  • JY5101_AO_Start() : JY5101.h
  • JY5101_AO_Stop() : JY5101.h
  • JY5101_AO_WaitUntilDone() : JY5101.h
  • JY5101_AO_WriteData() : JY5101.h
  • JY5101_AO_WriteRawData() : JY5101.h
  • JY5101_AO_WriteRawSinglePoint() : JY5101.h
  • JY5101_AO_WriteSinglePoint() : JY5101.h
  • JY5101_CI_CheckBufferStatus() : JY5101.h
  • JY5101_CI_EnableChannel() : JY5101.h
  • JY5101_CI_ReadCountValues() : JY5101.h
  • JY5101_CI_ReadMeasureValues() : JY5101.h
  • JY5101_CI_ReadSingleCountValue() : JY5101.h
  • JY5101_CI_ReadSingleMeasureValue() : JY5101.h
  • JY5101_CI_SendSoftTrigger() : JY5101.h
  • JY5101_CI_SetAuxTerminal() : JY5101.h
  • JY5101_CI_SetCounterParament() : JY5101.h
  • JY5101_CI_SetCounterType() : JY5101.h
  • JY5101_CI_SetDigitalStartTrigger() : JY5101.h
  • JY5101_CI_SetEdgeCountEvent() : JY5101.h
  • JY5101_CI_SetFirstSampleClock() : JY5101.h
  • JY5101_CI_SetGateTerminal() : JY5101.h
  • JY5101_CI_SetMode() : JY5101.h
  • JY5101_CI_SetOutTerminal() : JY5101.h
  • JY5101_CI_SetPauseTriggerLevel() : JY5101.h
  • JY5101_CI_SetPauseTriggerTerminal() : JY5101.h
  • JY5101_CI_SetSampleClock() : JY5101.h
  • JY5101_CI_SetSamplesToAcquire() : JY5101.h
  • JY5101_CI_SetSignalReverse() : JY5101.h
  • JY5101_CI_SetSourceTerminal() : JY5101.h
  • JY5101_CI_SetStartingEdge() : JY5101.h
  • JY5101_CI_SetStartTriggerType() : JY5101.h
  • JY5101_CI_SetTimeBase() : JY5101.h
  • JY5101_CI_SetValueReturnMode() : JY5101.h
  • JY5101_CI_SetZReloadEnabled() : JY5101.h
  • JY5101_CI_Start() : JY5101.h
  • JY5101_CI_Stop() : JY5101.h
  • JY5101_Close() : JY5101.h
  • JY5101_CO_CheckCounterStatus() : JY5101.h
  • JY5101_CO_EnableChannel() : JY5101.h
  • JY5101_CO_SendSoftTrigger() : JY5101.h
  • JY5101_CO_SetCounterParament() : JY5101.h
  • JY5101_CO_SetDigitalStartTrigger() : JY5101.h
  • JY5101_CO_SetFrequency() : JY5101.h
  • JY5101_CO_SetOutTerminal() : JY5101.h
  • JY5101_CO_SetPauseTriggerLevel() : JY5101.h
  • JY5101_CO_SetPauseTriggerOutState() : JY5101.h
  • JY5101_CO_SetPauseTriggerTerminal() : JY5101.h
  • JY5101_CO_SetStartTriggerType() : JY5101.h
  • JY5101_CO_SetTimeBase() : JY5101.h
  • JY5101_CO_Start() : JY5101.h
  • JY5101_CO_Stop() : JY5101.h
  • JY5101_CO_WaitUntilDone() : JY5101.h
  • JY5101_DI_AddLines() : JY5101.h
  • JY5101_DI_ReadSinglePoint() : JY5101.h
  • JY5101_DI_ReadSinglePoint_U32() : JY5101.h
  • JY5101_DI_Start() : JY5101.h
  • JY5101_DI_Stop() : JY5101.h
  • JY5101_DisableAICalibration() : JY5101.h
  • JY5101_DisableAOCalibration() : JY5101.h
  • JY5101_DisconnectSignalRouting() : JY5101.h
  • JY5101_DO_AddLines() : JY5101.h
  • JY5101_DO_ReadSinglePoint() : JY5101.h
  • JY5101_DO_ReadSinglePoint_U32() : JY5101.h
  • JY5101_DO_Start() : JY5101.h
  • JY5101_DO_Stop() : JY5101.h
  • JY5101_DO_WriteSinglePoint() : JY5101.h
  • JY5101_DO_WriteSinglePoint_U32() : JY5101.h
  • JY5101_GetCapabilityDouble() : JY5101.h
  • JY5101_GetCapabilityDoubleByName() : JY5101.h
  • JY5101_GetCapabilityDoubleBySlotNumber() : JY5101.h
  • JY5101_GetCapabilityInt() : JY5101.h
  • JY5101_GetCapabilityIntByName() : JY5101.h
  • JY5101_GetCapabilityIntBySlotNumber() : JY5101.h
  • JY5101_GetDeviceID() : JY5101.h
  • JY5101_GetDeviceInfo() : JY5101.h
  • JY5101_GetDeviceSerialNumber() : JY5101.h
  • JY5101_GetFPGATemperature() : JY5101.h
  • JY5101_Open() : JY5101.h
  • JY5101_OpenByName() : JY5101.h
  • JY5101_SetDeviceStatusLed() : JY5101.h
  • JY5101_SetPFIFilter() : JY5101.h
  • JY5101_SignalRouting() : JY5101.h
  • JY5101Cal_SaveAIToEEPROM() : JY5101.h
  • JY5101Cal_SaveAOToEEPROM() : JY5101.h
  • JY5101Cal_SetAIEnvironmentParam() : JY5101.h
  • JY5101Cal_SetAOEnvironmentParam() : JY5101.h


5101 C++ Programming Manual: File Members

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
Here is a list of all typedefs with links to the files they belong to:
  • JY5101_DeviceHandle : JY5101.h


5101 C++ Programming Manual: Main Page

5101 C++ Programming Manual Documentation