5101 C# Programming Manual: D:/OneDrive/Desktop/产品文档/CHM/5101/C# Directory Reference

5101 C# Programming Manual
C# Directory Reference

Files

         JY5101AITask.cs
JY5101AOTask.cs
JY5101CITask.cs
JY5101COTask.cs
JY5101DITask.cs
JY5101DOTask.cs
Generated by doxygen 1.15.0


5101 C# Programming Manual: D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101AITask.cs File Reference

Classes | Namespaces | Enumerations
JY5101AITask.cs File Reference

Classes

class | JY5101.JY5101AITask
JY5101 Analog Input Task. More...
class | JY5101.AIChannel
AI Channel parameter class. More...
class | JY5101.AIAnalogHysteresisComparator
AI Analog Hysteresis Comparatorr. More...
class | JY5101.AIAnalogWindowComparator
AI Analog Window Comparatorr. More...
class | JY5101.AIAnalogEdgeComparator
AI Analog Edge Comparator. More...
class | JY5101.AISampleClock
Sample clock configuration class. More...
class | JY5101.AIExternalSampleClock
External Sample Clock Configuration Class. More...
class | JY5101.AITrigger
AI Trigger class. More...
class | JY5101.AIDigitalTrigger
AI Digital Trigger. More...
class | JY5101.AIAnalogTrigger
AI Analog Trigger. More...
class | JY5101.AIAnalogMultichannelComparator
AI Analog Multichannel Trigger/Comparator. More...
class | JY5101.AIAnalogMultichannelHysteresisComparator
AI Analog Multichannel Hysteresis Comparator. More...
class | JY5101.AIAnalogMultichannelHysteresisComparatorSource
AI Analog Multichannel Hysteresis Comparator Source. More...
class | JY5101.AIAnalogMultichannelWindowComparator
AI Analog Multichannel Window Comparator. More...
class | JY5101.AIAnalogMultichannelWindowComparatorSource
AI Analog Multichannel Window Comparator Source. More...
class | JY5101.AIAnalogMultichannelEdgeComparator
AI Analog Multichannel Edge Comparator. More...
class | JY5101.AIAnalogMultichannelEdgeComparatorSource
AI Analog Multichannel Edge Comparator Source. More...
class | JY5101.AIRecord
AI Record class. More...
class | JY5101.AIAdvanced
AI Advance parameter. More...
class | JY5101.DSMode
DS Mode Class Paraments. More...
class | JY5101.AISync
Configure sync signal. More...
class | JY5101.AISignalExport
AI Signal Export Class. More...

Namespaces

namespace JY5101

Enumerations

enum | JY5101.AIBandWidth { JY5101.Narrow = JY5101Import.JY5101_AI_BandWidth_15K , JY5101.Medium = JY5101Import.JY5101_AI_BandWidth_39K , JY5101.Wide = JY5101Import.JY5101_AI_BandWidth_376K }
AI BandWidth. More...
enum JY5101.AITriggerType {
JY5101.Immediate = JY5101Import.JY5101_TriggerType_Immediately , JY5101.Digital = JY5101Import.JY5101_TriggerType_Digital , JY5101.Analog = JY5101Import.JY5101_TriggerType_Analog , JY5101.Soft = JY5101Import.JY5101_TriggerType_Soft ,
JY5101.MultichannelAnalog = 4
}
Trigger Type: Digital/Analog/Immediate/Soft/MultiChannelAnalog. More...
enum | JY5101.AIDigitalTriggerEdge { JY5101.Rising = JY5101Import.JY5101_DigitalTriggerEdge_Rising , JY5101.Falling = JY5101Import.JY5101_DigitalTriggerEdge_Falling }
AI Digital Trigger Edge. More...
enum | JY5101.AIAnalogTriggerEdge { JY5101.Rising = JY5101Import.JY5101_AnalogTriggerEdge_Rising , JY5101.Falling = JY5101Import.JY5101_AnalogTriggerEdge_Falling }
AI Analog Trigger Edge. More...
enum | JY5101.AIAnalogWindowCondition { JY5101.Entering = JY5101Import.JY5101_AnalogWindowCondition_Entering , JY5101.Leaving = JY5101Import.JY5101_AnalogWindowCondition_Leaving }
AI Analog Window Trigger Condition. More...
enum | JY5101.AIAnalogTriggerComparator { JY5101.Edge , JY5101.Hysteresis , JY5101.Window }
AI Analog Trigger Comparator. More...
enum | JY5101.AIMode { JY5101.Single = JY5101Import.JY5101_AI_Single , JY5101.Finite = JY5101Import.JY5101_AI_Finite , JY5101.Continuous = JY5101Import.JY5101_AI_Continuous , JY5101.Record = 0x3 }
AIMode. More...
enum | JY5101.AITerminal { JY5101.RSE = JY5101Import.JY5101_AI_RSE , JY5101.Differential = JY5101Import.JY5101_AI_Diff }
AITerminal. More...
enum | JY5101.AISampleClockSource { JY5101.Internal = JY5101Import.JY5101_AI_InternalClock , JY5101.External = JY5101Import.JY5101_AI_ExternalClock }
AIClockSource Type. More...
enum JY5101.ClockTerminal {
JY5101.PFI0 = JY5101Import.JY5101_Clock_PFI_0 , JY5101.PFI1 = JY5101Import.JY5101_Clock_PFI_1 , JY5101.PFI2 = JY5101Import.JY5101_Clock_PFI_2 , JY5101.PFI3 = JY5101Import.JY5101_Clock_PFI_3 ,
JY5101.PFI4 = JY5101Import.JY5101_Clock_PFI_4 , JY5101.PFI5 = JY5101Import.JY5101_Clock_PFI_5 , JY5101.PFI6 = JY5101Import.JY5101_Clock_PFI_6 , JY5101.PFI7 = JY5101Import.JY5101_Clock_PFI_7 ,
JY5101.PFI8 = JY5101Import.JY5101_Clock_PFI_8 , JY5101.PFI9 = JY5101Import.JY5101_Clock_PFI_9 , JY5101.PFI10 = JY5101Import.JY5101_Clock_PFI_10 , JY5101.PFI11 = JY5101Import.JY5101_Clock_PFI_11 ,
JY5101.PFI12 = JY5101Import.JY5101_Clock_PFI_12 , JY5101.PFI13 = JY5101Import.JY5101_Clock_PFI_13 , JY5101.PFI14 = JY5101Import.JY5101_Clock_PFI_14 , JY5101.PFI15 = JY5101Import.JY5101_Clock_PFI_15 ,
JY5101.PFI16 = JY5101Import.JY5101_Clock_PFI_16 , JY5101.PFI17 = JY5101Import.JY5101_Clock_PFI_17 , JY5101.PFI18 = JY5101Import.JY5101_Clock_PFI_18 , JY5101.PFI19 = JY5101Import.JY5101_Clock_PFI_19 ,
JY5101.PFI20 = JY5101Import.JY5101_Clock_PFI_20 , JY5101.PFI21 = JY5101Import.JY5101_Clock_PFI_21 , JY5101.PFI22 = JY5101Import.JY5101_Clock_PFI_22 , JY5101.PFI23 = JY5101Import.JY5101_Clock_PFI_23 ,
JY5101.PXI_Trig0 = JY5101Import.JY5101_Clock_PXI_Trig_0 , JY5101.PXI_Trig1 = JY5101Import.JY5101_Clock_PXI_Trig_1 , JY5101.PXI_Trig2 = JY5101Import.JY5101_Clock_PXI_Trig_2 , JY5101.PXI_Trig3 = JY5101Import.JY5101_Clock_PXI_Trig_3 ,
JY5101.PXI_Trig4 = JY5101Import.JY5101_Clock_PXI_Trig_4 , JY5101.PXI_Trig5 = JY5101Import.JY5101_Clock_PXI_Trig_5 , JY5101.PXI_Trig6 = JY5101Import.JY5101_Clock_PXI_Trig_6 , JY5101.PXI_Trig7 = JY5101Import.JY5101_Clock_PXI_Trig_7 ,
JY5101.AI_SampleClock = JY5101Import.JY5101_Inter_AI_SampleClock , JY5101.AO_SampleClock = JY5101Import.JY5101_Inter_AO_SampleClock , JY5101.CI0_SampleClock = JY5101Import.JY5101_Inter_CI_0_SampleClock , JY5101.CI1_SampleClock = JY5101Import.JY5101_Inter_CI_1_SampleClock ,
JY5101.CO0_Output = JY5101Import.JY5101_Inter_CO_0_Output , JY5101.CO1_Output = JY5101Import.JY5101_Inter_CO_1_Output
}
External Sample Clock Terminal. More...
enum | JY5101.AITriggerMode { JY5101.Start = JY5101Import.JY5101_StartTrigger , JY5101.Reference =JY5101Import.JY5101_ReferenceTrigger }
AI Trigger Mode. More...
enum JY5101.AIAnalogTriggerSource {
JY5101.Channel_0 , JY5101.Channel_1 , JY5101.Channel_2 , JY5101.Channel_3 ,
JY5101.Channel_4 , JY5101.Channel_5 , JY5101.Channel_6 , JY5101.Channel_7 ,
JY5101.Channel_8 , JY5101.Channel_9 , JY5101.Channel_10 , JY5101.Channel_11 ,
JY5101.Channel_12 , JY5101.Channel_13 , JY5101.Channel_14 , JY5101.Channel_15 ,
JY5101.Channel_16 , JY5101.Channel_17 , JY5101.Channel_18 , JY5101.Channel_19 ,
JY5101.Channel_20 , JY5101.Channel_21 , JY5101.Channel_22 , JY5101.Channel_23 ,
JY5101.Channel_24 , JY5101.Channel_25 , JY5101.Channel_26 , JY5101.Channel_27 ,
JY5101.Channel_28 , JY5101.Channel_29 , JY5101.Channel_30 , JY5101.Channel_31
}
AI Analog Trigger Source. More...
enum JY5101.AIDigitalTriggerSource {
JY5101.PFI0 = JY5101Import.JY5101_DigitalTriggerSource_PFI_0 , JY5101.PFI1 = JY5101Import.JY5101_DigitalTriggerSource_PFI_1 , JY5101.PFI2 = JY5101Import.JY5101_DigitalTriggerSource_PFI_2 , JY5101.PFI3 = JY5101Import.JY5101_DigitalTriggerSource_PFI_3 ,
JY5101.PFI4 = JY5101Import.JY5101_DigitalTriggerSource_PFI_4 , JY5101.PFI5 = JY5101Import.JY5101_DigitalTriggerSource_PFI_5 , JY5101.PFI6 = JY5101Import.JY5101_DigitalTriggerSource_PFI_6 , JY5101.PFI7 = JY5101Import.JY5101_DigitalTriggerSource_PFI_7 ,
JY5101.PFI8 = JY5101Import.JY5101_DigitalTriggerSource_PFI_8 , JY5101.PFI9 = JY5101Import.JY5101_DigitalTriggerSource_PFI_9 , JY5101.PFI10 = JY5101Import.JY5101_DigitalTriggerSource_PFI_10 , JY5101.PFI11 = JY5101Import.JY5101_DigitalTriggerSource_PFI_11 ,
JY5101.PFI12 = JY5101Import.JY5101_DigitalTriggerSource_PFI_12 , JY5101.PFI13 = JY5101Import.JY5101_DigitalTriggerSource_PFI_13 , JY5101.PFI14 = JY5101Import.JY5101_DigitalTriggerSource_PFI_14 , JY5101.PFI15 = JY5101Import.JY5101_DigitalTriggerSource_PFI_15 ,
JY5101.PFI16 = JY5101Import.JY5101_DigitalTriggerSource_PFI_16 , JY5101.PFI17 = JY5101Import.JY5101_DigitalTriggerSource_PFI_17 , JY5101.PFI18 = JY5101Import.JY5101_DigitalTriggerSource_PFI_18 , JY5101.PFI19 = JY5101Import.JY5101_DigitalTriggerSource_PFI_19 ,
JY5101.PFI20 = JY5101Import.JY5101_DigitalTriggerSource_PFI_20 , JY5101.PFI21 = JY5101Import.JY5101_DigitalTriggerSource_PFI_21 , JY5101.PFI22 = JY5101Import.JY5101_DigitalTriggerSource_PFI_22 , JY5101.PFI23 = JY5101Import.JY5101_DigitalTriggerSource_PFI_23 ,
JY5101.PXI_Trig0 = JY5101Import.JY5101_DigitalTriggerSource_PXI_0 , JY5101.PXI_Trig1 = JY5101Import.JY5101_DigitalTriggerSource_PXI_1 , JY5101.PXI_Trig2 = JY5101Import.JY5101_DigitalTriggerSource_PXI_2 , JY5101.PXI_Trig3 = JY5101Import.JY5101_DigitalTriggerSource_PXI_3 ,
JY5101.PXI_Trig4 = JY5101Import.JY5101_DigitalTriggerSource_PXI_4 , JY5101.PXI_Trig5 = JY5101Import.JY5101_DigitalTriggerSource_PXI_5 , JY5101.PXI_Trig6 = JY5101Import.JY5101_DigitalTriggerSource_PXI_6 , JY5101.PXI_Trig7 = JY5101Import.JY5101_DigitalTriggerSource_PXI_7 ,
JY5101.AO_StartTrig = JY5101Import.JY5101_AO_StartTrig , JY5101.CIO_0_StartTrig = JY5101Import.JY5101_CIO0_StartTrig , JY5101.CIO_1_StartTrig = JY5101Import.JY5101_CIO1_StartTrig , JY5101.CO0_Output = JY5101Import.JY5101_CO_0_Out ,
JY5101.CO1_Output = JY5101Import.JY5101_CO_1_Out , JY5101.CI0_Event_Output = JY5101Import.JY5101_Event_0_Out , JY5101.CI1_Event_Output = JY5101Import.JY5101_Event_1_Out
}
AI Digital Trigger Source. More...
enum | JY5101.AIAnalogComparatorLogic { JY5101.Or = 0 , JY5101.And = 1 }
Multichannel composition logic. More...
enum | JY5101.FileFormat { JY5101.Bin }
Streaming file format. More...
enum | JY5101.RecordMode { JY5101.Finite , JY5101.Infinite }
Two stream mode from enum Finite/Infinite. More...
enum | JY5101.SyncTopology { JY5101.Independent , JY5101.Master , JY5101.Slave }
Synchronization board configuration. More...
enum JY5101.SyncTriggerRouting {
JY5101.NONE = -1 , JY5101.PXI_Trig0 = JY5101Import.JY5101_DigitalTriggerSource_PXI_0 , JY5101.PXI_Trig1 = JY5101Import.JY5101_DigitalTriggerSource_PXI_1 , JY5101.PXI_Trig2 = JY5101Import.JY5101_DigitalTriggerSource_PXI_2 ,
JY5101.PXI_Trig3 = JY5101Import.JY5101_DigitalTriggerSource_PXI_3 , JY5101.PXI_Trig4 = JY5101Import.JY5101_DigitalTriggerSource_PXI_4 , JY5101.PXI_Trig5 = JY5101Import.JY5101_DigitalTriggerSource_PXI_5 , JY5101.PXI_Trig6 = JY5101Import.JY5101_DigitalTriggerSource_PXI_6 ,
JY5101.PXI_Trig7 = JY5101Import.JY5101_DigitalTriggerSource_PXI_7
}
Master card trigger signal routing (Master card routes trigger signal to this port) 主控卡触发信号路由(主控卡将触发信号路由到此端口). More...
enum JY5101.SyncPulseRouting {
JY5101.NONE = -1 , JY5101.PXI_Trig0 = JY5101Import.JY5101_DigitalTriggerSource_PXI_0 , JY5101.PXI_Trig1 = JY5101Import.JY5101_DigitalTriggerSource_PXI_1 , JY5101.PXI_Trig2 = JY5101Import.JY5101_DigitalTriggerSource_PXI_2 ,
JY5101.PXI_Trig3 = JY5101Import.JY5101_DigitalTriggerSource_PXI_3 , JY5101.PXI_Trig4 = JY5101Import.JY5101_DigitalTriggerSource_PXI_4 , JY5101.PXI_Trig5 = JY5101Import.JY5101_DigitalTriggerSource_PXI_5 , JY5101.PXI_Trig6 = JY5101Import.JY5101_DigitalTriggerSource_PXI_6 ,
JY5101.PXI_Trig7 = JY5101Import.JY5101_DigitalTriggerSource_PXI_7
}
Synchronous signal routing (the master card routes the synchronous signal to this port, and the slave card receives the synchronous signal from this port) 同步信号路由(主卡将同步信号路由到该端口，从卡从该端口接收同步信号). More...
enum | JY5101.AISignalExportSource { JY5101.StartTrig = JY5101Import.SignalSource_JY5101_AI_StartTrig , JY5101.ReferenceTrig = JY5101Import.SignalSource_JY5101_AI_ReferenceTrig , JY5101.SampleClock = JY5101Import.SignalSource_JY5101_AI_SampleClock }
AI Signal Export Source. More...
enum JY5101.SignalExportDestination {
JY5101.PFI0 = JY5101Import.SignalDestination_JY5101_PFI0 , JY5101.PFI1 = JY5101Import.SignalDestination_JY5101_PFI1 , JY5101.PFI2 = JY5101Import.SignalDestination_JY5101_PFI2 , JY5101.PFI3 = JY5101Import.SignalDestination_JY5101_PFI3 ,
JY5101.PFI4 = JY5101Import.SignalDestination_JY5101_PFI4 , JY5101.PFI5 = JY5101Import.SignalDestination_JY5101_PFI5 , JY5101.PFI6 = JY5101Import.SignalDestination_JY5101_PFI6 , JY5101.PFI7 = JY5101Import.SignalDestination_JY5101_PFI7 ,
JY5101.PFI8 = JY5101Import.SignalDestination_JY5101_PFI8 , JY5101.PFI9 = JY5101Import.SignalDestination_JY5101_PFI9 , JY5101.PFI10 = JY5101Import.SignalDestination_JY5101_PFI10 , JY5101.PFI11 = JY5101Import.SignalDestination_JY5101_PFI11 ,
JY5101.PFI12 = JY5101Import.SignalDestination_JY5101_PFI12 , JY5101.PFI13 = JY5101Import.SignalDestination_JY5101_PFI13 , JY5101.PFI14 = JY5101Import.SignalDestination_JY5101_PFI14 , JY5101.PFI15 = JY5101Import.SignalDestination_JY5101_PFI15 ,
JY5101.PFI16 = JY5101Import.SignalDestination_JY5101_PFI16 , JY5101.PFI17 = JY5101Import.SignalDestination_JY5101_PFI17 , JY5101.PFI18 = JY5101Import.SignalDestination_JY5101_PFI18 , JY5101.PFI19 = JY5101Import.SignalDestination_JY5101_PFI19 ,
JY5101.PFI20 = JY5101Import.SignalDestination_JY5101_PFI20 , JY5101.PFI21 = JY5101Import.SignalDestination_JY5101_PFI21 , JY5101.PFI22 = JY5101Import.SignalDestination_JY5101_PFI22 , JY5101.PFI23 = JY5101Import.SignalDestination_JY5101_PFI23 ,
JY5101.PXI_Trig0 = JY5101Import.SignalDestination_JY5101_PXITrig0 , JY5101.PXI_Trig1 = JY5101Import.SignalDestination_JY5101_PXITrig1 , JY5101.PXI_Trig2 = JY5101Import.SignalDestination_JY5101_PXITrig2 , JY5101.PXI_Trig3 = JY5101Import.SignalDestination_JY5101_PXITrig3 ,
JY5101.PXI_Trig4 = JY5101Import.SignalDestination_JY5101_PXITrig4 , JY5101.PXI_Trig5 = JY5101Import.SignalDestination_JY5101_PXITrig5 , JY5101.PXI_Trig6 = JY5101Import.SignalDestination_JY5101_PXITrig6 , JY5101.PXI_Trig7 = JY5101Import.SignalDestination_JY5101_PXITrig7
}
输出目的终端 More...


5101 C# Programming Manual: JY5101.JY5101AITask Class Reference

  • Main Page
  • Packages
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JY5101
  • JY5101AITask
Public Member Functions | Properties | List of all members
JY5101.JY5101AITask Class Referencesealed

JY5101 Analog Input Task. More...

Public Member Functions

JY5101AITask (int slotNumber)
Constructor.
JY5101AITask (string boardName)
Constructor.
void | AddChannel (int chnId, double rangeLow=-10, double rangeHigh=10, AITerminal terminalCfg=AITerminal.RSE, AIBandWidth bandWidth=AIBandWidth.Wide)
Add one channel.
void | AddChannel (int[] chnsId, double rangeLow=-10, double rangeHigh=10, AITerminal terminalCfg=AITerminal.RSE, AIBandWidth bandWidth=AIBandWidth.Wide)
Add a group of channels.
void | AddChannel (int[] chnsId, double[] rangeLow, double[] rangeHigh, AITerminal terminalCfg, AIBandWidth bandWidth)
Add a set of channels, each with a different range (except terminal and bandwidth).
void | RemoveChannel (int chnId)
Delete the channel with the specified channel number.
void | ReadData (IntPtr buf, int samplesPerChannel, int timeout=10000)
Read one or multi-channel data by columns and store it in a data buffer.
void | ReadData (ref double[,] buf, int samplesPerChannel, int timeout=10000)
Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.
void | ReadData (ref double[,] buf, int timeout=10000)
Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.
void | ReadData (ref double[] buf, int samplesPerChannel, int timeout=10000)
Read the one channel data and store it in a data buffer.
void | ReadData (ref double[] buf, int timeout=10000)
Read the one channel data and store it in a data buffer.
void | ReadRawData (IntPtr buf, int samplesPerChannel, int timeout=10000)
Read one or multi-channel raw data by columns and store it in a data buffer.
void | ReadRawData (ref short[,] buf, int samplesPerChannel, int timeout=10000)
Read the multi-channel raw data by columns and store it in a data buffer,Each channel is represented by one column of data.
void | ReadRawData (ref short[,] buf, int timeout=10000)
Read the multi-channel raw data by columns and store it in a data buffer,Each channel is represented by one column of data.
void | ReadRawData (ref short[] buf, int samplesPerChannel, int timeout=10000)
Read the one channel raw data and store it in a data buffer.
void | ReadRawData (ref short[] buf, int timeout=10000)
Read the one channel raw data and store it in a data buffer.
void | ReadSinglePoint (ref double readValue, int channel)
Read one sample for specified channel in register.
void | ReadSinglePoint (ref double[] readValues)
Read one sample for all channels in register .
void | ReadRawSinglePoint (ref short readValue, int channel)
Read one sample for specified channel in register.
void | ReadRawSinglePoint (ref short[] readValues)
Read one sample for all channels in register .
void | GetRecordPreviewData (ref double[,] buf, int samplesPerChannel, int timeout=1000)
Preview multi-channel data when streaming is in progress.
void | GetRecordPreviewData (ref double[,] buf, int timeout=1000)
Preview multi-channel data when streaming is in progress.
void | GetRecordPreviewData (ref double[] buf, int samplesPerChannel, int timeout=1000)
Preview one channel data when streaming is in progress.
void | GetRecordPreviewData (ref double[] buf, int timeout=1000)
Preview one channel data when streaming is in progress.
void | GetRecordStatus (out double recordedLength, out bool recordDone)
Get the streaming status.
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.
void | Start ()
Start AITask.
void | SendSoftwareTrigger ()
Generate a software trigger signal generate a software trigger signal.
void | Stop ()
Stop AI Task.

Properties

JY5101Device | Device [get]
Device Handle.
List< AIChannel > | Channels [get, set]
List of AI channels, P7 P9:32CH SE or 16CH Different K7 K9:16CH SE or 8CH Different.
AIMode | Mode [get, set]
AI acquisition mode，support Finite/Continuous/Record.
double | SampleRate [get, set]
Sample rate per channel.
int | SamplesToAcquire [get, set]
Number of samples to be read per channel.
int | BufLenInSamples [get]
Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.
ulong | AvailableSamples [get]
Number of samples per channel that can be read in the buffer.
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel).
AISampleClock | SampleClock [get, set]
AI Sample Clock Configuration.
AITrigger | Trigger [get, set]
时钟沿。仅在外部时钟时有效。
AIRecord | Record [get]
Data streaming Configuration.
AISignalExport | SignalExport [get, set]
Export AI Signal Configuration.
AIAdvanced | Advanced [get, set]
AI Advanced Configuration.

Detailed Description

JY5101 Analog Input Task.

Constructor & Destructor Documentation

◆ JY5101AITask() [1/2]

JY5101.JY5101AITask.JY5101AITask ( int slotNumber )

Constructor.

Used to create an AI task by a slot number

Parameters
slotNumber Card slot number.

◆ JY5101AITask() [2/2]

JY5101.JY5101AITask.JY5101AITask ( string boardName )

Constructor.

Used to create an AI task by a board name.

Parameters
boardName Board name(device alias), set by device manager

Member Function Documentation

◆ AddChannel() [1/3]

void JY5101.JY5101AITask.AddChannel | ( | int | chnId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10,
 |  | AITerminal | terminalCfg = AITerminal::RSE,
 |  | AIBandWidth | bandWidth = AIBandWidth::Wide )

Add one channel.

Parameters
chnId | channel's physical number ，chnId=-1, add all channels,P7 P9:32CH K7 K9:16CH
rangeLow | lower range limit for the channel，-10V,-5V,-2.5V,default -10
rangeHigh | higher range limit for the channel,10V,5V,2.5V,default 10
terminalCfg | terminal input mode configuration，RSE/Differential.Default RSE
bandWidth | AI Bandwidth ,default 80KHz

◆ AddChannel() [2/3]

void JY5101.JY5101AITask.AddChannel | ( | int[] | chnsId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10,
 |  | AITerminal | terminalCfg = AITerminal::RSE,
 |  | AIBandWidth | bandWidth = AIBandWidth::Wide )

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers,P7 P9:32CH K7 K9:16CH
rangeLow | lower range limit for the channel，-10V,-5V,-2.5V,default -10
rangeHigh | higher range limit for the channel,10V,5V,2.5V,default 10
terminalCfg | terminal input mode configuration，RSE/Differential.Default RSE
bandWidth | AI Bandwidth ,default 80KHz

◆ AddChannel() [3/3]

void JY5101.JY5101AITask.AddChannel | ( | int[] | chnsId,
 |  | double[] | rangeLow,
 |  | double[] | rangeHigh,
 |  | AITerminal | terminalCfg,
 |  | AIBandWidth | bandWidth )

Add a set of channels, each with a different range (except terminal and bandwidth).

Parameters
chnsId | A collection of physical channel numbers. The range is 0 to 31 for the RSE channel and 0 to 15 for the Differential channel.(P7 P9:32CH K7 K9:16CH)
rangeLow | Higher range limit for the channel: 10V, 5V, 2.5V (default: 10V)
rangeHigh | Higher range limit for the channel: 10V, 5V, 2.5V (default: 10V)
terminalCfg | Terminal input mode configuration: RSE or Differential (default: RSE)
bandWidth | AI Bandwidth:Narrow,Medium，Wide (default: Wide)

◆ GetRecordPreviewData() [1/4]

void JY5101.JY5101AITask.GetRecordPreviewData | ( | ref double | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout = 1000 )

Preview multi-channel data when streaming is in progress.

Each column represents one channel.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ GetRecordPreviewData() [2/4]

void JY5101.JY5101AITask.GetRecordPreviewData | ( | ref double | buf[,],
 |  | int | timeout = 1000 )

Preview multi-channel data when streaming is in progress.

Each column represents one channel.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms
Returns

◆ GetRecordPreviewData() [3/4]

void JY5101.JY5101AITask.GetRecordPreviewData | ( | ref double[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 1000 )

Preview one channel data when streaming is in progress.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ GetRecordPreviewData() [4/4]

void JY5101.JY5101AITask.GetRecordPreviewData | ( | ref double[] | buf,
 |  | int | timeout = 1000 )

Preview one channel data when streaming is in progress.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms

◆ GetRecordStatus()

void JY5101.JY5101AITask.GetRecordStatus | ( | out double | recordedLength,
 |  | out bool | recordDone )

Get the streaming status.

Parameters
recordedLength | Length of the streamed, unit s
recordDone | recordDone = false :streaming is not over.recordDone = true :streaming is over

◆ ReadData() [1/5]

void JY5101.JY5101AITask.ReadData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Read one or multi-channel data by columns and store it in a data buffer.

The buffer is pointed by C# data type IntPtr.

param name="buf">Data buffer

Parameters
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish

◆ ReadData() [2/5]

void JY5101.JY5101AITask.ReadData | ( | ref double | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.

param name="buf">Data buffer

Parameters
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish

◆ ReadData() [3/5]

void JY5101.JY5101AITask.ReadData | ( | ref double | buf[,],
 |  | int | timeout = 10000 )

Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.

param name="buf">Data buffer

Parameters
timeout timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish

◆ ReadData() [4/5]

void JY5101.JY5101AITask.ReadData | ( | ref double[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Read the one channel data and store it in a data buffer.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ ReadData() [5/5]

void JY5101.JY5101AITask.ReadData | ( | ref double[] | buf,
 |  | int | timeout = 10000 )

Read the one channel data and store it in a data buffer.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [1/5]

void JY5101.JY5101AITask.ReadRawData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Read one or multi-channel raw data by columns and store it in a data buffer.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [2/5]

void JY5101.JY5101AITask.ReadRawData | ( | ref short | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Read the multi-channel raw data by columns and store it in a data buffer,Each channel is represented by one column of data.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [3/5]

void JY5101.JY5101AITask.ReadRawData | ( | ref short | buf[,],
 |  | int | timeout = 10000 )

Read the multi-channel raw data by columns and store it in a data buffer,Each channel is represented by one column of data.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [4/5]

void JY5101.JY5101AITask.ReadRawData | ( | ref short[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Read the one channel raw data and store it in a data buffer.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [5/5]

void JY5101.JY5101AITask.ReadRawData | ( | ref short[] | buf,
 |  | int | timeout = 10000 )

Read the one channel raw data and store it in a data buffer.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms

◆ ReadRawSinglePoint() [1/2]

void JY5101.JY5101AITask.ReadRawSinglePoint | ( | ref short | readValue,
 |  | int | channel )

Read one sample for specified channel in register.

Available when Mode is AIMode.Single

Parameters
readValue | value read
channel | Specified channel numbers.

◆ ReadRawSinglePoint() [2/2]

void JY5101.JY5101AITask.ReadRawSinglePoint ( ref short[] readValues )

Read one sample for all channels in register .

Available when Mode is AIMode.Single

Parameters
readValues Values read. Array length >= Channels.Count.

◆ ReadSinglePoint() [1/2]

void JY5101.JY5101AITask.ReadSinglePoint | ( | ref double | readValue,
 |  | int | channel )

Read one sample for specified channel in register.

Available when Mode is AIMode.Single

Parameters
readValue | value read
channel | Specified channel numbers.

◆ ReadSinglePoint() [2/2]

void JY5101.JY5101AITask.ReadSinglePoint ( ref double[] readValues )

Read one sample for all channels in register .

Available when Mode is AIMode.Single

Parameters
readValues Values read. Array length >= Channels.Count.

◆ RemoveChannel()

void JY5101.JY5101AITask.RemoveChannel ( int chnId )

Delete the channel with the specified channel number.

chnId=- 1, all channels will be deleted

Parameters
chnId Channel number of the channel to be deleted

◆ SendSoftwareTrigger()

void JY5101.JY5101AITask.SendSoftwareTrigger ( )

Generate a software trigger signal generate a software trigger signal.

Returns

◆ Start()

void JY5101.JY5101AITask.Start ( )

Start AITask.

◆ Stop()

void JY5101.JY5101AITask.Stop ( )

Stop AI Task.

◆ WaitUntilDone()

bool JY5101.JY5101AITask.WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate
Returns
True: task end, false: timeout

Property Documentation

◆ Advanced

AIAdvanced JY5101.JY5101AITask.Advanced
getset

AI Advanced Configuration.

◆ AvailableSamples

ulong JY5101.JY5101AITask.AvailableSamples
get

Number of samples per channel that can be read in the buffer.

◆ BufLenInSamples

int JY5101.JY5101AITask.BufLenInSamples
get

Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.

◆ Channels

List<AIChannel> JY5101.JY5101AITask.Channels
getset

List of AI channels, P7 P9:32CH SE or 16CH Different K7 K9:16CH SE or 8CH Different.

◆ Device

JY5101Device JY5101.JY5101AITask.Device
get

Device Handle.

◆ Mode

AIMode JY5101.JY5101AITask.Mode
getset

AI acquisition mode，support Finite/Continuous/Record.

◆ Record

AIRecord JY5101.JY5101AITask.Record
get

Data streaming Configuration.

◆ SampleClock

AISampleClock JY5101.JY5101AITask.SampleClock
getset

AI Sample Clock Configuration.

◆ SampleRate

double JY5101.JY5101AITask.SampleRate
getset

Sample rate per channel.

Maximum sample rate is 1M . The defalut sample rate = 10k You can read this property to obtain the sample rate that will actually take effect in the current configuration.

◆ SamplesToAcquire

int JY5101.JY5101AITask.SamplesToAcquire
getset

Number of samples to be read per channel.

default: 1000. Only valid when Mode is AIMode.Finite.

◆ SignalExport

AISignalExport JY5101.JY5101AITask.SignalExport
getset

Export AI Signal Configuration.

◆ TransferedSamples

ulong JY5101.JY5101AITask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

◆ Trigger

AITrigger JY5101.JY5101AITask.Trigger
getset

时钟沿。仅在外部时钟时有效。

AI Trigger Configuration

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101AITask.cs


5101 C# Programming Manual: JY5101.AIChannel Class Reference

  • Packages
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JY5101
  • AIChannel
Public Member Functions | Properties | List of all members
JY5101.AIChannel Class Referencesealed

AI Channel parameter class. More...

Public Member Functions

AIChannel (int channelId, double rangeLow, double rangeHigh, AITerminal terminalCfg, AIBandWidth bandWidth)
Constructor to create an AIChnParam task object.

Properties

int | ChannelID [get]
AI channel ID.
double | RangeLow [get, set]
Low range limit an AI channel，-10V,-5V,-2.5V.
double | RangeHigh [get, set]
High range limit an AI channel，10V,5V,2.5V.
AITerminal | Terminal [get, set]
Configure AI terminal.
AIBandWidth | BandWidth [get, set]
AI BandWidth,default 80KHz.

Detailed Description

AI Channel parameter class.

Constructor & Destructor Documentation

◆ AIChannel()

JY5101.AIChannel.AIChannel | ( | int | channelId,
 |  | double | rangeLow,
 |  | double | rangeHigh,
 |  | AITerminal | terminalCfg,
 |  | AIBandWidth | bandWidth )

Constructor to create an AIChnParam task object.

Parameters
channelId | AI channel ID.
rangeLow | Low range limit an AI channel.
rangeHigh | High range limit an AI channel.
terminalCfg | Configure AI terminal.(RSE,Differential).
bandWidth | AI BandWidth.

Property Documentation

◆ BandWidth

AIBandWidth JY5101.AIChannel.BandWidth
getset

AI BandWidth,default 80KHz.

◆ ChannelID

int JY5101.AIChannel.ChannelID
get

AI channel ID.

◆ RangeHigh

double JY5101.AIChannel.RangeHigh
getset

High range limit an AI channel，10V,5V,2.5V.

◆ RangeLow

double JY5101.AIChannel.RangeLow
getset

Low range limit an AI channel，-10V,-5V,-2.5V.

◆ Terminal

AITerminal JY5101.AIChannel.Terminal
getset

Configure AI terminal.

(RSE,Differential)

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101AITask.cs


5101 C# Programming Manual: JY5101.AIAnalogHysteresisComparator Class Reference

  • Class List
  • Class Index
  • Class Members
  • JY5101
  • AIAnalogHysteresisComparator
Public Attributes | Properties | List of all members
JY5101.AIAnalogHysteresisComparator Class Reference

AI Analog Hysteresis Comparatorr. More...

Public Attributes

double | HighThreshold
High Threshold.
double | LowThreshold
Low Threshold.

Properties

AIAnalogTriggerEdge Slope [get, set]
AI Analog Trigger Edge.

Detailed Description

AI Analog Hysteresis Comparatorr.

Member Data Documentation

◆ HighThreshold

double JY5101.AIAnalogHysteresisComparator.HighThreshold

High Threshold.

◆ LowThreshold

double JY5101.AIAnalogHysteresisComparator.LowThreshold

Low Threshold.

Property Documentation

◆ Slope

AIAnalogTriggerEdge JY5101.AIAnalogHysteresisComparator.Slope
getset

AI Analog Trigger Edge.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101AITask.cs


5101 C# Programming Manual: JY5101.AIAnalogWindowComparator Class Reference

  • JY5101
  • AIAnalogWindowComparator
Public Attributes | Properties | List of all members
JY5101.AIAnalogWindowComparator Class Reference

AI Analog Window Comparatorr. More...

Public Attributes

double | HighThreshold
High Threshold.
double | LowThreshold
Low Threshold.

Properties

AIAnalogWindowCondition Condition [get, set]
AI Analog Window Condition.

Detailed Description

AI Analog Window Comparatorr.

Member Data Documentation

◆ HighThreshold

double JY5101.AIAnalogWindowComparator.HighThreshold

High Threshold.

◆ LowThreshold

double JY5101.AIAnalogWindowComparator.LowThreshold

Low Threshold.

Property Documentation

◆ Condition

AIAnalogWindowCondition JY5101.AIAnalogWindowComparator.Condition
getset

AI Analog Window Condition.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101AITask.cs


5101 C# Programming Manual: JY5101.AIAnalogEdgeComparator Class Reference

  • AIAnalogEdgeComparator
Public Attributes | Properties | List of all members
JY5101.AIAnalogEdgeComparator Class Reference

AI Analog Edge Comparator. More...

Public Attributes

double Threshold
Threshold.

Properties

AIAnalogTriggerEdge Slope [get, set]
AI Analog Trigger Edge.

Detailed Description

AI Analog Edge Comparator.

Member Data Documentation

◆ Threshold

double JY5101.AIAnalogEdgeComparator.Threshold

Threshold.

Property Documentation

◆ Slope

AIAnalogTriggerEdge JY5101.AIAnalogEdgeComparator.Slope
getset

AI Analog Trigger Edge.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101AITask.cs


5101 C# Programming Manual: JY5101.AISampleClock Class Reference

  • AISampleClock
Properties | List of all members
JY5101.AISampleClock Class Reference

Sample clock configuration class. More...

Properties

AISampleClockSource | Source [get, set]
Clock Source.
AIExternalSampleClock | External [get, set]
External Sample Clock， Valid when Source is AISampleClockSource.External.

Detailed Description

Sample clock configuration class.

Property Documentation

◆ External

AIExternalSampleClock JY5101.AISampleClock.External
getset

External Sample Clock， Valid when Source is AISampleClockSource.External.

◆ Source

AISampleClockSource JY5101.AISampleClock.Source
getset

Clock Source.

enum Internal/External,The default value is AISampleClockSource.Internal.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101AITask.cs


5101 C# Programming Manual: JY5101.AIExternalSampleClock Class Reference

  • AIExternalSampleClock
Properties | List of all members
JY5101.AIExternalSampleClock Class Reference

External Sample Clock Configuration Class. More...

Properties

ClockTerminal | Terminal [get, set]
External Sample Clock Input Terminal.
double | ExpectedRate [get, set]
Expected External Sample Clock Rate.

Detailed Description

External Sample Clock Configuration Class.

Property Documentation

◆ ExpectedRate

double JY5101.AIExternalSampleClock.ExpectedRate
getset

Expected External Sample Clock Rate.

◆ Terminal

ClockTerminal JY5101.AIExternalSampleClock.Terminal
getset

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101AITask.cs


5101 C# Programming Manual: JY5101.AITrigger Class Reference

  • AITrigger
Properties | List of all members
JY5101.AITrigger Class Referencesealed

AI Trigger class. More...

Properties

AITriggerType | Type [get, set]
AI Trigger Type,enum Analog/Digital/Immediate/Soft.
AITriggerMode | Mode [get, set]
AI Trigger Mode.
AIDigitalTrigger | Digital [get, set]
Digital Trigger Congfiguration.
AIAnalogTrigger | Analog [get, set]
AI Analog Trigger.
AIAnalogMultichannelComparator | Multichannel [get, set]
AI Analog Trigger.
int | ReTriggerCount [get, set]
Number of repeat triggers.
uint | PreTriggerSamples [get, set]
AI pretrigger samples, must be less than or equal to JY5101AITask.SamplesToAcquire.

Detailed Description

AI Trigger class.

Property Documentation

◆ Analog

AIAnalogTrigger JY5101.AITrigger.Analog
getset

AI Analog Trigger.

Valid when Type is AITriggerType.Analog.

◆ Digital

AIDigitalTrigger JY5101.AITrigger.Digital
getset

Digital Trigger Congfiguration.

Valid when Type is AITriggerType.Digital.

◆ Mode

AITriggerMode JY5101.AITrigger.Mode
getset

AI Trigger Mode.

enum Start/Reference. The default value is AITriggerMode.Start.

◆ Multichannel

AIAnalogMultichannelComparator JY5101.AITrigger.Multichannel
getset

AI Analog Trigger.

Valid when Type is AITriggerType.Analog.

◆ PreTriggerSamples

uint JY5101.AITrigger.PreTriggerSamples
getset

AI pretrigger samples, must be less than or equal to JY5101AITask.SamplesToAcquire.

Valid when Mode is AITriggerMode.Reference.

◆ ReTriggerCount

int JY5101.AITrigger.ReTriggerCount
getset

Number of repeat triggers.

When 0 or 1 only trigger once, When -1 continuous retrigger until stop.

◆ Type

AITriggerType JY5101.AITrigger.Type
getset

AI Trigger Type,enum Analog/Digital/Immediate/Soft.

The default value is AITriggerType.Immediate.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101AITask.cs


5101 C# Programming Manual: JY5101.AIDigitalTrigger Class Reference

  • AIDigitalTrigger
Properties | List of all members
JY5101.AIDigitalTrigger Class Referencesealed

AI Digital Trigger. More...

Properties

AIDigitalTriggerSource | Source [get, set]
AI Digital Trigger Source.
AIDigitalTriggerEdge | Edge [get, set]
AI Digital Trigger Edge，Rising/Falling.

Detailed Description

AI Digital Trigger.

Property Documentation

◆ Edge

AIDigitalTriggerEdge JY5101.AIDigitalTrigger.Edge
getset

AI Digital Trigger Edge，Rising/Falling.

◆ Source

AIDigitalTriggerSource JY5101.AIDigitalTrigger.Source
getset

AI Digital Trigger Source.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101AITask.cs


5101 C# Programming Manual: JY5101.AIAnalogTrigger Class Reference

  • AIAnalogTrigger
Public Member Functions | Properties | List of all members
JY5101.AIAnalogTrigger Class Referencesealed

AI Analog Trigger. More...

Public Member Functions

AIAnalogTrigger ()
Default simulation trigger parameters: Trigger source - external trigger channel Trigger condition – above high threshold Threshold value – -0.1v.

Properties

AIAnalogTriggerSource | Source [get, set]
Analog Trigger source.
AIAnalogTriggerComparator | Comparator [get, set]
AI Analog Trigger Comparator.
AIAnalogEdgeComparator | Edge [get, set]
AI Analog Edge Comparator.
AIAnalogHysteresisComparator | Hysteresis [get, set]
AI Analog Hysteresis Comparatorr.
AIAnalogWindowComparator | Window [get, set]
AI Analog Window Comparatorr.

Detailed Description

AI Analog Trigger.

Constructor & Destructor Documentation

◆ AIAnalogTrigger()

JY5101.AIAnalogTrigger.AIAnalogTrigger ( )

Default simulation trigger parameters: Trigger source - external trigger channel Trigger condition – above high threshold Threshold value – -0.1v.

Property Documentation

◆ Comparator

AIAnalogTriggerComparator JY5101.AIAnalogTrigger.Comparator
getset

AI Analog Trigger Comparator.

◆ Edge

AIAnalogEdgeComparator JY5101.AIAnalogTrigger.Edge
getset

AI Analog Edge Comparator.

◆ Hysteresis

AIAnalogHysteresisComparator JY5101.AIAnalogTrigger.Hysteresis
getset

AI Analog Hysteresis Comparatorr.

◆ Source

AIAnalogTriggerSource JY5101.AIAnalogTrigger.Source
getset

Analog Trigger source.

◆ Window

AIAnalogWindowComparator JY5101.AIAnalogTrigger.Window
getset

AI Analog Window Comparatorr.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101AITask.cs


5101 C# Programming Manual: JY5101.AIAnalogMultichannelComparator Class Reference

  • AIAnalogMultichannelComparator
Public Member Functions | Properties | List of all members
JY5101.AIAnalogMultichannelComparator Class Referencesealed

AI Analog Multichannel Trigger/Comparator. More...

Public Member Functions

AIAnalogMultichannelComparator ()
Default simulation trigger parameters: Trigger source - external trigger channel Trigger condition – above high threshold Threshold value – -0.1v.

Properties

AIAnalogComparatorLogic | Logic [get, set]
Multichannel composition logic, and / or.
AIAnalogTriggerComparator | Comparator [get, set]
AI Analog Trigger Comparator.
AIAnalogMultichannelHysteresisComparator | Hysteresis [get, set]
Analog Trigger Config.
AIAnalogMultichannelEdgeComparator | Edge [get, set]
Analog Trigger Config.
AIAnalogMultichannelWindowComparator | Window [get, set]
Analog Trigger Config.

Detailed Description

AI Analog Multichannel Trigger/Comparator.

Constructor & Destructor Documentation

◆ AIAnalogMultichannelComparator()

JY5101.AIAnalogMultichannelComparator.AIAnalogMultichannelComparator ( )

Default simulation trigger parameters: Trigger source - external trigger channel Trigger condition – above high threshold Threshold value – -0.1v.

Property Documentation

◆ Comparator

AIAnalogTriggerComparator JY5101.AIAnalogMultichannelComparator.Comparator
getset

AI Analog Trigger Comparator.

◆ Edge

AIAnalogMultichannelEdgeComparator JY5101.AIAnalogMultichannelComparator.Edge
getset

Analog Trigger Config.

◆ Hysteresis

AIAnalogMultichannelHysteresisComparator JY5101.AIAnalogMultichannelComparator.Hysteresis
getset

Analog Trigger Config.

◆ Logic

AIAnalogComparatorLogic JY5101.AIAnalogMultichannelComparator.Logic
getset

Multichannel composition logic, and / or.

defalut or.

◆ Window

AIAnalogMultichannelWindowComparator JY5101.AIAnalogMultichannelComparator.Window
getset

Analog Trigger Config.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101AITask.cs


5101 C# Programming Manual: JY5101.AIAnalogMultichannelHysteresisComparator Class Reference

  • AIAnalogMultichannelHysteresisComparator
Public Member Functions | Properties | List of all members
JY5101.AIAnalogMultichannelHysteresisComparator Class Reference

AI Analog Multichannel Hysteresis Comparator. More...

Public Member Functions

void | Add (AIAnalogTriggerSource source, AIAnalogTriggerEdge slope, double highThreshold, double lowThreshold)
Add source.
void | Clear ()
Clear sources.
AIAnalogMultichannelHysteresisComparator ()

Properties

List< AIAnalogMultichannelHysteresisComparatorSource > Sources [get, set]
Sources of AI Analog Multichannel Hysteresis Comparator.

Detailed Description

AI Analog Multichannel Hysteresis Comparator.

Constructor & Destructor Documentation

◆ AIAnalogMultichannelHysteresisComparator()

JY5101.AIAnalogMultichannelHysteresisComparator.AIAnalogMultichannelHysteresisComparator ( )

Member Function Documentation

◆ Add()

void JY5101.AIAnalogMultichannelHysteresisComparator.Add | ( | AIAnalogTriggerSource | source,
 |  | AIAnalogTriggerEdge | slope,
 |  | double | highThreshold,
 |  | double | lowThreshold )

Add source.

Parameters
source | Analog Trigger source
slope | AI Analog Trigger Edge
highThreshold | High Threshold
lowThreshold | Low Threshold

◆ Clear()

void JY5101.AIAnalogMultichannelHysteresisComparator.Clear ( )

Clear sources.

Property Documentation

◆ Sources

List<AIAnalogMultichannelHysteresisComparatorSource> JY5101.AIAnalogMultichannelHysteresisComparator.Sources
getset

Sources of AI Analog Multichannel Hysteresis Comparator.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101AITask.cs


5101 C# Programming Manual: JY5101.AIAnalogMultichannelHysteresisComparatorSource Class Reference

  • JY5101
  • AIAnalogMultichannelHysteresisComparatorSource
Public Member Functions | Properties | List of all members
JY5101.AIAnalogMultichannelHysteresisComparatorSource Class Reference

AI Analog Multichannel Hysteresis Comparator Source. More...

Public Member Functions

AIAnalogMultichannelHysteresisComparatorSource ()
AI Analog Multichannel Hysteresis Comparator Source.
AIAnalogMultichannelHysteresisComparatorSource (AIAnalogTriggerSource source, AIAnalogTriggerEdge slope, double highThreshold, double lowThreshold)
AI Analog Multichannel Hysteresis Comparator Source.

Properties

AIAnalogTriggerSource | Source [get, set]
Analog Trigger source.
AIAnalogTriggerEdge | Slope [get, set]
AI Analog Trigger Edge.
double | HighThreshold [get, set]
High Threshold.
double | LowThreshold [get, set]
Low Threshold.

Detailed Description

AI Analog Multichannel Hysteresis Comparator Source.

Constructor & Destructor Documentation

◆ AIAnalogMultichannelHysteresisComparatorSource() [1/2]

JY5101.AIAnalogMultichannelHysteresisComparatorSource.AIAnalogMultichannelHysteresisComparatorSource ( )

AI Analog Multichannel Hysteresis Comparator Source.

◆ AIAnalogMultichannelHysteresisComparatorSource() [2/2]

JY5101.AIAnalogMultichannelHysteresisComparatorSource.AIAnalogMultichannelHysteresisComparatorSource | ( | AIAnalogTriggerSource | source,
 |  | AIAnalogTriggerEdge | slope,
 |  | double | highThreshold,
 |  | double | lowThreshold )

AI Analog Multichannel Hysteresis Comparator Source.

Property Documentation

◆ HighThreshold

double JY5101.AIAnalogMultichannelHysteresisComparatorSource.HighThreshold
getset

High Threshold.

◆ LowThreshold

double JY5101.AIAnalogMultichannelHysteresisComparatorSource.LowThreshold
getset

Low Threshold.

◆ Slope

AIAnalogTriggerEdge JY5101.AIAnalogMultichannelHysteresisComparatorSource.Slope
getset

AI Analog Trigger Edge.

◆ Source

AIAnalogTriggerSource JY5101.AIAnalogMultichannelHysteresisComparatorSource.Source
getset

Analog Trigger source.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101AITask.cs


5101 C# Programming Manual: JY5101.AIAnalogMultichannelWindowComparator Class Reference

  • AIAnalogMultichannelWindowComparator
Public Member Functions | Properties | List of all members
JY5101.AIAnalogMultichannelWindowComparator Class Reference

AI Analog Multichannel Window Comparator. More...

Public Member Functions

void | Add (AIAnalogTriggerSource source, AIAnalogWindowCondition condition, double highThreshold, double lowThreshold)
Add source.
void | Clear ()
Clear sources.
AIAnalogMultichannelWindowComparator ()

Properties

List< AIAnalogMultichannelWindowComparatorSource > Sources [get, set]
Sources of AI Analog Multichannel Window Comparator.

Detailed Description

AI Analog Multichannel Window Comparator.

Constructor & Destructor Documentation

◆ AIAnalogMultichannelWindowComparator()

JY5101.AIAnalogMultichannelWindowComparator.AIAnalogMultichannelWindowComparator ( )

Member Function Documentation

◆ Add()

void JY5101.AIAnalogMultichannelWindowComparator.Add | ( | AIAnalogTriggerSource | source,
 |  | AIAnalogWindowCondition | condition,
 |  | double | highThreshold,
 |  | double | lowThreshold )

Add source.

Parameters
source | Trigger source
condition | AI Analog Window Condition
highThreshold | High Threshold
lowThreshold | Low Threshold

◆ Clear()

void JY5101.AIAnalogMultichannelWindowComparator.Clear ( )

Clear sources.

Property Documentation

◆ Sources

List<AIAnalogMultichannelWindowComparatorSource> JY5101.AIAnalogMultichannelWindowComparator.Sources
getset

Sources of AI Analog Multichannel Window Comparator.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101AITask.cs


5101 C# Programming Manual: JY5101.AIAnalogMultichannelWindowComparatorSource Class Reference

  • JY5101
  • AIAnalogMultichannelWindowComparatorSource
Public Member Functions | Properties | List of all members
JY5101.AIAnalogMultichannelWindowComparatorSource Class Reference

AI Analog Multichannel Window Comparator Source. More...

Public Member Functions

AIAnalogMultichannelWindowComparatorSource ()
AIAnalogMultichannelWindowComparatorSource (AIAnalogTriggerSource source, AIAnalogWindowCondition condition, double highThreshold, double lowThreshold)
AI Analog Multichannel Window Comparator Source.

Properties

AIAnalogTriggerSource | Source [get, set]
Analog Trigger source.
AIAnalogWindowCondition | Condition [get, set]
AI Analog Window Condition.
double | HighThreshold [get, set]
High Threshold.
double | LowThreshold [get, set]
Low Threshold.

Detailed Description

AI Analog Multichannel Window Comparator Source.

Constructor & Destructor Documentation

◆ AIAnalogMultichannelWindowComparatorSource() [1/2]

JY5101.AIAnalogMultichannelWindowComparatorSource.AIAnalogMultichannelWindowComparatorSource ( )

◆ AIAnalogMultichannelWindowComparatorSource() [2/2]

JY5101.AIAnalogMultichannelWindowComparatorSource.AIAnalogMultichannelWindowComparatorSource | ( | AIAnalogTriggerSource | source,
 |  | AIAnalogWindowCondition | condition,
 |  | double | highThreshold,
 |  | double | lowThreshold )

AI Analog Multichannel Window Comparator Source.

Property Documentation

◆ Condition

AIAnalogWindowCondition JY5101.AIAnalogMultichannelWindowComparatorSource.Condition
getset

AI Analog Window Condition.

◆ HighThreshold

double JY5101.AIAnalogMultichannelWindowComparatorSource.HighThreshold
getset

High Threshold.

◆ LowThreshold

double JY5101.AIAnalogMultichannelWindowComparatorSource.LowThreshold
getset

Low Threshold.

◆ Source

AIAnalogTriggerSource JY5101.AIAnalogMultichannelWindowComparatorSource.Source
getset

Analog Trigger source.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101AITask.cs


5101 C# Programming Manual: JY5101.AIAnalogMultichannelEdgeComparator Class Reference

  • AIAnalogMultichannelEdgeComparator
Public Member Functions | Properties | List of all members
JY5101.AIAnalogMultichannelEdgeComparator Class Reference

AI Analog Multichannel Edge Comparator. More...

Public Member Functions

void | Add (AIAnalogTriggerSource source, AIAnalogTriggerEdge slope, double threshold)
Add source.
void | Clear ()
Clear sources.
AIAnalogMultichannelEdgeComparator ()

Properties

List< AIAnalogMultichannelEdgeComparatorSource > Sources [get, set]
Sources of AI Analog Multichannel Edge Comparator.

Detailed Description

AI Analog Multichannel Edge Comparator.

Constructor & Destructor Documentation

◆ AIAnalogMultichannelEdgeComparator()

JY5101.AIAnalogMultichannelEdgeComparator.AIAnalogMultichannelEdgeComparator ( )

Member Function Documentation

◆ Add()

void JY5101.AIAnalogMultichannelEdgeComparator.Add | ( | AIAnalogTriggerSource | source,
 |  | AIAnalogTriggerEdge | slope,
 |  | double | threshold )

Add source.

Parameters
source | Analog Trigger source
slope | AI Analog Trigger Edge
threshold | Threshold

◆ Clear()

void JY5101.AIAnalogMultichannelEdgeComparator.Clear ( )

Clear sources.

Property Documentation

◆ Sources

List<AIAnalogMultichannelEdgeComparatorSource> JY5101.AIAnalogMultichannelEdgeComparator.Sources
getset

Sources of AI Analog Multichannel Edge Comparator.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101AITask.cs


5101 C# Programming Manual: JY5101.AIAnalogMultichannelEdgeComparatorSource Class Reference

  • AIAnalogMultichannelEdgeComparatorSource
Public Member Functions | Properties | List of all members
JY5101.AIAnalogMultichannelEdgeComparatorSource Class Reference

AI Analog Multichannel Edge Comparator Source. More...

Public Member Functions

AIAnalogMultichannelEdgeComparatorSource ()
AI Analog Multichannel Edge Comparator Source.
AIAnalogMultichannelEdgeComparatorSource (AIAnalogTriggerSource source, AIAnalogTriggerEdge slope, double threshold)
AI Analog Multichannel Edge Comparator Source.

Properties

AIAnalogTriggerSource | Source [get, set]
Analog Trigger source.
AIAnalogTriggerEdge | Slope [get, set]
AI Analog Trigger Edge.
double | Threshold [get, set]
Threshold.

Detailed Description

AI Analog Multichannel Edge Comparator Source.

Constructor & Destructor Documentation

◆ AIAnalogMultichannelEdgeComparatorSource() [1/2]

JY5101.AIAnalogMultichannelEdgeComparatorSource.AIAnalogMultichannelEdgeComparatorSource ( )

AI Analog Multichannel Edge Comparator Source.

◆ AIAnalogMultichannelEdgeComparatorSource() [2/2]

JY5101.AIAnalogMultichannelEdgeComparatorSource.AIAnalogMultichannelEdgeComparatorSource | ( | AIAnalogTriggerSource | source,
 |  | AIAnalogTriggerEdge | slope,
 |  | double | threshold )

AI Analog Multichannel Edge Comparator Source.

Property Documentation

◆ Slope

AIAnalogTriggerEdge JY5101.AIAnalogMultichannelEdgeComparatorSource.Slope
getset

AI Analog Trigger Edge.

◆ Source

AIAnalogTriggerSource JY5101.AIAnalogMultichannelEdgeComparatorSource.Source
getset

Analog Trigger source.

◆ Threshold

double JY5101.AIAnalogMultichannelEdgeComparatorSource.Threshold
getset

Threshold.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101AITask.cs


5101 C# Programming Manual: JY5101.AIRecord Class Reference

  • AIRecord
Properties | List of all members
JY5101.AIRecord Class Referencesealed

AI Record class. More...

Properties

string | FilePath [get, set]
Path of streaming file,including filePath and filename.
FileFormat | FileFormat [get]
Streaming file format.
RecordMode | Mode [get, set]
Two stream mode from enum Finite/Infinite.
double | Length [get, set]
User specified stream length in second.

Detailed Description

AI Record class.

Property Documentation

◆ FileFormat

FileFormat JY5101.AIRecord.FileFormat
get

Streaming file format.

◆ FilePath

string JY5101.AIRecord.FilePath
getset

Path of streaming file,including filePath and filename.

◆ Length

double JY5101.AIRecord.Length
getset

User specified stream length in second.

Only valid in the Finite mode

◆ Mode

RecordMode JY5101.AIRecord.Mode
getset

Two stream mode from enum Finite/Infinite.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101AITask.cs


5101 C# Programming Manual: JY5101.AIAdvanced Class Reference

  • AIAdvanced
Properties | List of all members
JY5101.AIAdvanced Class Referencesealed

AI Advance parameter. More...

Properties

double | ConvertRate [get, set]
the convert rate of ADC.
DSMode | DSMode [get, set]
DSMode Config.

Detailed Description

AI Advance parameter.

Property Documentation

◆ ConvertRate

double JY5101.AIAdvanced.ConvertRate
getset

the convert rate of ADC.

◆ DSMode

DSMode JY5101.AIAdvanced.DSMode
getset

DSMode Config.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101AITask.cs


5101 C# Programming Manual: JY5101.DSMode Class Reference

  • DSMode
Properties | List of all members
JY5101.DSMode Class Referencesealed

DS Mode Class Paraments. More...

Properties

bool Enable [get, set]
Enable DSMode.

Detailed Description

DS Mode Class Paraments.

Property Documentation

◆ Enable

bool JY5101.DSMode.Enable
getset

Enable DSMode.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101AITask.cs


5101 C# Programming Manual: JY5101.AISync Class Reference

  • AISync
Properties | List of all members
JY5101.AISync Class Referencesealed

Configure sync signal. More...

Properties

SyncTopology | Topology [get, set]
Configure sync signal.
SyncTriggerRouting | TriggerRouting [get, set]
trigger signal Routing, default routing PXITrig0
SyncPulseRouting | PulseRouting [get, set]
Sync Pulse signal Routing, default routing PXITrig1.

Detailed Description

Configure sync signal.

Property Documentation

◆ PulseRouting

SyncPulseRouting JY5101.AISync.PulseRouting
getset

Sync Pulse signal Routing, default routing PXITrig1.

◆ Topology

SyncTopology JY5101.AISync.Topology
getset

Configure sync signal.

◆ TriggerRouting

SyncTriggerRouting JY5101.AISync.TriggerRouting
getset

trigger signal Routing, default routing PXITrig0

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101AITask.cs


5101 C# Programming Manual: JY5101.AISignalExport Class Reference

  • AISignalExport
Public Member Functions | List of all members
JY5101.AISignalExport Class Reference

AI Signal Export Class. More...

Public Member Functions

void | Add (AISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (AISignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

AI Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY5101.AISignalExport.Add | ( | AISignalExportSource | source,
 |  | List< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | AI Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY5101.AISignalExport.Add | ( | AISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | AI Signal Source
destination | Export Desination

◆ Clear()

void JY5101.AISignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5101.AISignalExport.ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101AITask.cs


5101 C# Programming Manual: JY5101 Namespace Reference

  • Package List
  • Package Members
Classes | Enumerations
JY5101 Namespace Reference

Classes

class | JY5101AITask
JY5101 Analog Input Task. More...
class | AIChannel
AI Channel parameter class. More...
class | AIAnalogHysteresisComparator
AI Analog Hysteresis Comparatorr. More...
class | AIAnalogWindowComparator
AI Analog Window Comparatorr. More...
class | AIAnalogEdgeComparator
AI Analog Edge Comparator. More...
class | AISampleClock
Sample clock configuration class. More...
class | AIExternalSampleClock
External Sample Clock Configuration Class. More...
class | AITrigger
AI Trigger class. More...
class | AIDigitalTrigger
AI Digital Trigger. More...
class | AIAnalogTrigger
AI Analog Trigger. More...
class | AIAnalogMultichannelComparator
AI Analog Multichannel Trigger/Comparator. More...
class | AIAnalogMultichannelHysteresisComparator
AI Analog Multichannel Hysteresis Comparator. More...
class | AIAnalogMultichannelHysteresisComparatorSource
AI Analog Multichannel Hysteresis Comparator Source. More...
class | AIAnalogMultichannelWindowComparator
AI Analog Multichannel Window Comparator. More...
class | AIAnalogMultichannelWindowComparatorSource
AI Analog Multichannel Window Comparator Source. More...
class | AIAnalogMultichannelEdgeComparator
AI Analog Multichannel Edge Comparator. More...
class | AIAnalogMultichannelEdgeComparatorSource
AI Analog Multichannel Edge Comparator Source. More...
class | AIRecord
AI Record class. More...
class | AIAdvanced
AI Advance parameter. More...
class | DSMode
DS Mode Class Paraments. More...
class | AISync
Configure sync signal. More...
class | AISignalExport
AI Signal Export Class. More...
class | JY5101AOTask
JY5101 Analog Ouput Task. More...
class | AOChannel
AO Channel parameter class . More...
class | AOSampleClock
AO Sample clock configuration class. More...
class | AOExternalSampleClock
External Sample Clock Configuration Class. More...
class | AOTrigger
Constructor to create an AOTrigger task object. More...
class | AODigitalTrigger
AO Digital trigger . More...
class | AOSignalExport
AO Signal Export Class. More...
class | JY5101CITask
JY5101 Counter Input Task. More...
class | CISampleClock
CI Sample Clock class. More...
class | CIInternalSampleClock
CI Internal Sample Clock Configuration Class. More...
class | CIImplicitSampleClock
CI Implicit Sample Clock class. More...
class | CIExternalSampleClock
CI Implicit Sample Clock class. More...
class | CIExternalTimebase
class | CITimebase
class | EdgeCounting
Configure CI EdgeCounting. More...
class | EdgeCountingOutEvent
Edge counting output event configuration class. More...
class | PauseTrigger
Pause trigger configuration class. More...
class | FrequencyMeas
Configure CI Measure. More...
class | PeriodMeas
Configure CI Measure. More...
class | PulseMeas
Configure CI Measure. More...
class | SemiPeriodMeas
Configure CI Measure. More...
class | TwoEdgeSeparation
Configure CI Measure. More...
class | QuadEncoder
Configure CI Measure. More...
class | TwoPulseEncoder
Configure CI Measure. More...
class | CITrigger
Constructor to create an CITrigger task object. More...
class | CIDigitalTrigger
CI Digital trigger . More...
class | CISignalExport
CI Signal Export Class. More...
class | JY5101COTask
JY5101 Counter Output Task. More...
class | COTrigger
Constructor to create an COTrigger task object. More...
class | CODigitalTrigger
CO Digital trigger . More...
class | COPulse
Pulse Parameter. More...
class | COExternalTimebase
class | COTimebase
class | COSignalExport
CO Signal Export Class. More...
class | JY5101DITask
JY5101 Digital Iuput Task. More...
class | DIChannel
DI Channel parameter class . More...
class | JY5101DOTask
JY5101 Digital Output Task. More...
class | DOChannel
DO Channel parameter class . More...

Enumerations

enum | AIBandWidth { Narrow = JY5101Import.JY5101_AI_BandWidth_15K , Medium = JY5101Import.JY5101_AI_BandWidth_39K , Wide = JY5101Import.JY5101_AI_BandWidth_376K }
AI BandWidth. More...
enum AITriggerType {
Immediate = JY5101Import.JY5101_TriggerType_Immediately , Digital = JY5101Import.JY5101_TriggerType_Digital , Analog = JY5101Import.JY5101_TriggerType_Analog , Soft = JY5101Import.JY5101_TriggerType_Soft ,
MultichannelAnalog = 4
}
Trigger Type: Digital/Analog/Immediate/Soft/MultiChannelAnalog. More...
enum | AIDigitalTriggerEdge { Rising = JY5101Import.JY5101_DigitalTriggerEdge_Rising , Falling = JY5101Import.JY5101_DigitalTriggerEdge_Falling }
AI Digital Trigger Edge. More...
enum | AIAnalogTriggerEdge { Rising = JY5101Import.JY5101_AnalogTriggerEdge_Rising , Falling = JY5101Import.JY5101_AnalogTriggerEdge_Falling }
AI Analog Trigger Edge. More...
enum | AIAnalogWindowCondition { Entering = JY5101Import.JY5101_AnalogWindowCondition_Entering , Leaving = JY5101Import.JY5101_AnalogWindowCondition_Leaving }
AI Analog Window Trigger Condition. More...
enum | AIAnalogTriggerComparator { Edge , Hysteresis , Window }
AI Analog Trigger Comparator. More...
enum | AIMode { Single = JY5101Import.JY5101_AI_Single , Finite = JY5101Import.JY5101_AI_Finite , Continuous = JY5101Import.JY5101_AI_Continuous , Record = 0x3 }
AIMode. More...
enum | AITerminal { RSE = JY5101Import.JY5101_AI_RSE , Differential = JY5101Import.JY5101_AI_Diff }
AITerminal. More...
enum | AISampleClockSource { Internal = JY5101Import.JY5101_AI_InternalClock , External = JY5101Import.JY5101_AI_ExternalClock }
AIClockSource Type. More...
enum ClockTerminal {
PFI0 = JY5101Import.JY5101_Clock_PFI_0 , PFI1 = JY5101Import.JY5101_Clock_PFI_1 , PFI2 = JY5101Import.JY5101_Clock_PFI_2 , PFI3 = JY5101Import.JY5101_Clock_PFI_3 ,
PFI4 = JY5101Import.JY5101_Clock_PFI_4 , PFI5 = JY5101Import.JY5101_Clock_PFI_5 , PFI6 = JY5101Import.JY5101_Clock_PFI_6 , PFI7 = JY5101Import.JY5101_Clock_PFI_7 ,
PFI8 = JY5101Import.JY5101_Clock_PFI_8 , PFI9 = JY5101Import.JY5101_Clock_PFI_9 , PFI10 = JY5101Import.JY5101_Clock_PFI_10 , PFI11 = JY5101Import.JY5101_Clock_PFI_11 ,
PFI12 = JY5101Import.JY5101_Clock_PFI_12 , PFI13 = JY5101Import.JY5101_Clock_PFI_13 , PFI14 = JY5101Import.JY5101_Clock_PFI_14 , PFI15 = JY5101Import.JY5101_Clock_PFI_15 ,
PFI16 = JY5101Import.JY5101_Clock_PFI_16 , PFI17 = JY5101Import.JY5101_Clock_PFI_17 , PFI18 = JY5101Import.JY5101_Clock_PFI_18 , PFI19 = JY5101Import.JY5101_Clock_PFI_19 ,
PFI20 = JY5101Import.JY5101_Clock_PFI_20 , PFI21 = JY5101Import.JY5101_Clock_PFI_21 , PFI22 = JY5101Import.JY5101_Clock_PFI_22 , PFI23 = JY5101Import.JY5101_Clock_PFI_23 ,
PXI_Trig0 = JY5101Import.JY5101_Clock_PXI_Trig_0 , PXI_Trig1 = JY5101Import.JY5101_Clock_PXI_Trig_1 , PXI_Trig2 = JY5101Import.JY5101_Clock_PXI_Trig_2 , PXI_Trig3 = JY5101Import.JY5101_Clock_PXI_Trig_3 ,
PXI_Trig4 = JY5101Import.JY5101_Clock_PXI_Trig_4 , PXI_Trig5 = JY5101Import.JY5101_Clock_PXI_Trig_5 , PXI_Trig6 = JY5101Import.JY5101_Clock_PXI_Trig_6 , PXI_Trig7 = JY5101Import.JY5101_Clock_PXI_Trig_7 ,
AI_SampleClock = JY5101Import.JY5101_Inter_AI_SampleClock , AO_SampleClock = JY5101Import.JY5101_Inter_AO_SampleClock , CI0_SampleClock = JY5101Import.JY5101_Inter_CI_0_SampleClock , CI1_SampleClock = JY5101Import.JY5101_Inter_CI_1_SampleClock ,
CO0_Output = JY5101Import.JY5101_Inter_CO_0_Output , CO1_Output = JY5101Import.JY5101_Inter_CO_1_Output
}
External Sample Clock Terminal. More...
enum | AITriggerMode { Start = JY5101Import.JY5101_StartTrigger , Reference =JY5101Import.JY5101_ReferenceTrigger }
AI Trigger Mode. More...
enum AIAnalogTriggerSource {
Channel_0 , Channel_1 , Channel_2 , Channel_3 ,
Channel_4 , Channel_5 , Channel_6 , Channel_7 ,
Channel_8 , Channel_9 , Channel_10 , Channel_11 ,
Channel_12 , Channel_13 , Channel_14 , Channel_15 ,
Channel_16 , Channel_17 , Channel_18 , Channel_19 ,
Channel_20 , Channel_21 , Channel_22 , Channel_23 ,
Channel_24 , Channel_25 , Channel_26 , Channel_27 ,
Channel_28 , Channel_29 , Channel_30 , Channel_31
}
AI Analog Trigger Source. More...
enum AIDigitalTriggerSource {
PFI0 = JY5101Import.JY5101_DigitalTriggerSource_PFI_0 , PFI1 = JY5101Import.JY5101_DigitalTriggerSource_PFI_1 , PFI2 = JY5101Import.JY5101_DigitalTriggerSource_PFI_2 , PFI3 = JY5101Import.JY5101_DigitalTriggerSource_PFI_3 ,
PFI4 = JY5101Import.JY5101_DigitalTriggerSource_PFI_4 , PFI5 = JY5101Import.JY5101_DigitalTriggerSource_PFI_5 , PFI6 = JY5101Import.JY5101_DigitalTriggerSource_PFI_6 , PFI7 = JY5101Import.JY5101_DigitalTriggerSource_PFI_7 ,
PFI8 = JY5101Import.JY5101_DigitalTriggerSource_PFI_8 , PFI9 = JY5101Import.JY5101_DigitalTriggerSource_PFI_9 , PFI10 = JY5101Import.JY5101_DigitalTriggerSource_PFI_10 , PFI11 = JY5101Import.JY5101_DigitalTriggerSource_PFI_11 ,
PFI12 = JY5101Import.JY5101_DigitalTriggerSource_PFI_12 , PFI13 = JY5101Import.JY5101_DigitalTriggerSource_PFI_13 , PFI14 = JY5101Import.JY5101_DigitalTriggerSource_PFI_14 , PFI15 = JY5101Import.JY5101_DigitalTriggerSource_PFI_15 ,
PFI16 = JY5101Import.JY5101_DigitalTriggerSource_PFI_16 , PFI17 = JY5101Import.JY5101_DigitalTriggerSource_PFI_17 , PFI18 = JY5101Import.JY5101_DigitalTriggerSource_PFI_18 , PFI19 = JY5101Import.JY5101_DigitalTriggerSource_PFI_19 ,
PFI20 = JY5101Import.JY5101_DigitalTriggerSource_PFI_20 , PFI21 = JY5101Import.JY5101_DigitalTriggerSource_PFI_21 , PFI22 = JY5101Import.JY5101_DigitalTriggerSource_PFI_22 , PFI23 = JY5101Import.JY5101_DigitalTriggerSource_PFI_23 ,
PXI_Trig0 = JY5101Import.JY5101_DigitalTriggerSource_PXI_0 , PXI_Trig1 = JY5101Import.JY5101_DigitalTriggerSource_PXI_1 , PXI_Trig2 = JY5101Import.JY5101_DigitalTriggerSource_PXI_2 , PXI_Trig3 = JY5101Import.JY5101_DigitalTriggerSource_PXI_3 ,
PXI_Trig4 = JY5101Import.JY5101_DigitalTriggerSource_PXI_4 , PXI_Trig5 = JY5101Import.JY5101_DigitalTriggerSource_PXI_5 , PXI_Trig6 = JY5101Import.JY5101_DigitalTriggerSource_PXI_6 , PXI_Trig7 = JY5101Import.JY5101_DigitalTriggerSource_PXI_7 ,
AO_StartTrig = JY5101Import.JY5101_AO_StartTrig , CIO_0_StartTrig = JY5101Import.JY5101_CIO0_StartTrig , CIO_1_StartTrig = JY5101Import.JY5101_CIO1_StartTrig , CO0_Output = JY5101Import.JY5101_CO_0_Out ,
CO1_Output = JY5101Import.JY5101_CO_1_Out , CI0_Event_Output = JY5101Import.JY5101_Event_0_Out , CI1_Event_Output = JY5101Import.JY5101_Event_1_Out
}
AI Digital Trigger Source. More...
enum | AIAnalogComparatorLogic { Or = 0 , And = 1 }
Multichannel composition logic. More...
enum | FileFormat { Bin }
Streaming file format. More...
enum | RecordMode { Finite , Infinite }
Two stream mode from enum Finite/Infinite. More...
enum | SyncTopology { Independent , Master , Slave }
Synchronization board configuration. More...
enum SyncTriggerRouting {
NONE = -1 , PXI_Trig0 = JY5101Import.JY5101_DigitalTriggerSource_PXI_0 , PXI_Trig1 = JY5101Import.JY5101_DigitalTriggerSource_PXI_1 , PXI_Trig2 = JY5101Import.JY5101_DigitalTriggerSource_PXI_2 ,
PXI_Trig3 = JY5101Import.JY5101_DigitalTriggerSource_PXI_3 , PXI_Trig4 = JY5101Import.JY5101_DigitalTriggerSource_PXI_4 , PXI_Trig5 = JY5101Import.JY5101_DigitalTriggerSource_PXI_5 , PXI_Trig6 = JY5101Import.JY5101_DigitalTriggerSource_PXI_6 ,
PXI_Trig7 = JY5101Import.JY5101_DigitalTriggerSource_PXI_7
}
Master card trigger signal routing (Master card routes trigger signal to this port) 主控卡触发信号路由(主控卡将触发信号路由到此端口). More...
enum SyncPulseRouting {
NONE = -1 , PXI_Trig0 = JY5101Import.JY5101_DigitalTriggerSource_PXI_0 , PXI_Trig1 = JY5101Import.JY5101_DigitalTriggerSource_PXI_1 , PXI_Trig2 = JY5101Import.JY5101_DigitalTriggerSource_PXI_2 ,
PXI_Trig3 = JY5101Import.JY5101_DigitalTriggerSource_PXI_3 , PXI_Trig4 = JY5101Import.JY5101_DigitalTriggerSource_PXI_4 , PXI_Trig5 = JY5101Import.JY5101_DigitalTriggerSource_PXI_5 , PXI_Trig6 = JY5101Import.JY5101_DigitalTriggerSource_PXI_6 ,
PXI_Trig7 = JY5101Import.JY5101_DigitalTriggerSource_PXI_7
}
Synchronous signal routing (the master card routes the synchronous signal to this port, and the slave card receives the synchronous signal from this port) 同步信号路由(主卡将同步信号路由到该端口，从卡从该端口接收同步信号). More...
enum | AISignalExportSource { StartTrig = JY5101Import.SignalSource_JY5101_AI_StartTrig , ReferenceTrig = JY5101Import.SignalSource_JY5101_AI_ReferenceTrig , SampleClock = JY5101Import.SignalSource_JY5101_AI_SampleClock }
AI Signal Export Source. More...
enum SignalExportDestination {
PFI0 = JY5101Import.SignalDestination_JY5101_PFI0 , PFI1 = JY5101Import.SignalDestination_JY5101_PFI1 , PFI2 = JY5101Import.SignalDestination_JY5101_PFI2 , PFI3 = JY5101Import.SignalDestination_JY5101_PFI3 ,
PFI4 = JY5101Import.SignalDestination_JY5101_PFI4 , PFI5 = JY5101Import.SignalDestination_JY5101_PFI5 , PFI6 = JY5101Import.SignalDestination_JY5101_PFI6 , PFI7 = JY5101Import.SignalDestination_JY5101_PFI7 ,
PFI8 = JY5101Import.SignalDestination_JY5101_PFI8 , PFI9 = JY5101Import.SignalDestination_JY5101_PFI9 , PFI10 = JY5101Import.SignalDestination_JY5101_PFI10 , PFI11 = JY5101Import.SignalDestination_JY5101_PFI11 ,
PFI12 = JY5101Import.SignalDestination_JY5101_PFI12 , PFI13 = JY5101Import.SignalDestination_JY5101_PFI13 , PFI14 = JY5101Import.SignalDestination_JY5101_PFI14 , PFI15 = JY5101Import.SignalDestination_JY5101_PFI15 ,
PFI16 = JY5101Import.SignalDestination_JY5101_PFI16 , PFI17 = JY5101Import.SignalDestination_JY5101_PFI17 , PFI18 = JY5101Import.SignalDestination_JY5101_PFI18 , PFI19 = JY5101Import.SignalDestination_JY5101_PFI19 ,
PFI20 = JY5101Import.SignalDestination_JY5101_PFI20 , PFI21 = JY5101Import.SignalDestination_JY5101_PFI21 , PFI22 = JY5101Import.SignalDestination_JY5101_PFI22 , PFI23 = JY5101Import.SignalDestination_JY5101_PFI23 ,
PXI_Trig0 = JY5101Import.SignalDestination_JY5101_PXITrig0 , PXI_Trig1 = JY5101Import.SignalDestination_JY5101_PXITrig1 , PXI_Trig2 = JY5101Import.SignalDestination_JY5101_PXITrig2 , PXI_Trig3 = JY5101Import.SignalDestination_JY5101_PXITrig3 ,
PXI_Trig4 = JY5101Import.SignalDestination_JY5101_PXITrig4 , PXI_Trig5 = JY5101Import.SignalDestination_JY5101_PXITrig5 , PXI_Trig6 = JY5101Import.SignalDestination_JY5101_PXITrig6 , PXI_Trig7 = JY5101Import.SignalDestination_JY5101_PXITrig7
}
输出目的终端 More...
enum | AODigitalTriggerEdge { Rising , Falling }
AO Digital Trigger Edge. More...
enum AODigitalTriggerSource {
PFI0 = JY5101Import.JY5101_DigitalTriggerSource_PFI_0 , PFI1 = JY5101Import.JY5101_DigitalTriggerSource_PFI_1 , PFI2 = JY5101Import.JY5101_DigitalTriggerSource_PFI_2 , PFI3 = JY5101Import.JY5101_DigitalTriggerSource_PFI_3 ,
PFI4 = JY5101Import.JY5101_DigitalTriggerSource_PFI_4 , PFI5 = JY5101Import.JY5101_DigitalTriggerSource_PFI_5 , PFI6 = JY5101Import.JY5101_DigitalTriggerSource_PFI_6 , PFI7 = JY5101Import.JY5101_DigitalTriggerSource_PFI_7 ,
PFI8 = JY5101Import.JY5101_DigitalTriggerSource_PFI_8 , PFI9 = JY5101Import.JY5101_DigitalTriggerSource_PFI_9 , PFI10 = JY5101Import.JY5101_DigitalTriggerSource_PFI_10 , PFI11 = JY5101Import.JY5101_DigitalTriggerSource_PFI_11 ,
PFI12 = JY5101Import.JY5101_DigitalTriggerSource_PFI_12 , PFI13 = JY5101Import.JY5101_DigitalTriggerSource_PFI_13 , PFI14 = JY5101Import.JY5101_DigitalTriggerSource_PFI_14 , PFI15 = JY5101Import.JY5101_DigitalTriggerSource_PFI_15 ,
PFI16 = JY5101Import.JY5101_DigitalTriggerSource_PFI_16 , PFI17 = JY5101Import.JY5101_DigitalTriggerSource_PFI_17 , PFI18 = JY5101Import.JY5101_DigitalTriggerSource_PFI_18 , PFI19 = JY5101Import.JY5101_DigitalTriggerSource_PFI_19 ,
PFI20 = JY5101Import.JY5101_DigitalTriggerSource_PFI_20 , PFI21 = JY5101Import.JY5101_DigitalTriggerSource_PFI_21 , PFI22 = JY5101Import.JY5101_DigitalTriggerSource_PFI_22 , PFI23 = JY5101Import.JY5101_DigitalTriggerSource_PFI_23 ,
PXI_Trig0 = JY5101Import.JY5101_DigitalTriggerSource_PXI_0 , PXI_Trig1 = JY5101Import.JY5101_DigitalTriggerSource_PXI_1 , PXI_Trig2 = JY5101Import.JY5101_DigitalTriggerSource_PXI_2 , PXI_Trig3 = JY5101Import.JY5101_DigitalTriggerSource_PXI_3 ,
PXI_Trig4 = JY5101Import.JY5101_DigitalTriggerSource_PXI_4 , PXI_Trig5 = JY5101Import.JY5101_DigitalTriggerSource_PXI_5 , PXI_Trig6 = JY5101Import.JY5101_DigitalTriggerSource_PXI_6 , PXI_Trig7 = JY5101Import.JY5101_DigitalTriggerSource_PXI_7 ,
AI_StartTrig = JY5101Import.JY5101_AI_StartTrig , AI_ReferenceTrig = JY5101Import.JY5101_AI_ReferenceTrig , CIO_0_StartTrig = JY5101Import.JY5101_CIO0_StartTrig , CIO_1_StartTrig = JY5101Import.JY5101_CIO1_StartTrig ,
CO_0_Out = JY5101Import.JY5101_CO_0_Out , CO_1_Out = JY5101Import.JY5101_CO_1_Out , CI0_Event_Output = JY5101Import.JY5101_Event_0_Out , CI1_Event_Output = JY5101Import.JY5101_Event_1_Out
}
AO Digital trigger source. More...
enum | OutputCompleteState { Zero , Hold }
Output Complete State. More...
enum | AOMode { Single = 3 , Finite = 0 , ContinuousNoWrapping = 2 , ContinuousWrapping = 1 }
AOMode. More...
enum | AOSampleClockSource { Internal , External }
AO Sample Clock Source. More...
enum | AOSignalExportSource { StartTrig = JY5101Import.SignalSource_JY5101_AO_StartTrig , SampleClock = JY5101Import.SignalSource_JY5101_AO_SampleClock }
SourceSignal. More...
enum | AOTriggerType { Immediate = JY5101Import.JY5101_TriggerType_Immediately , Digital = JY5101Import.JY5101_TriggerType_Digital , Soft = JY5101Import.JY5101_TriggerType_Soft }
TriggerType Digital/Immediate/Soft. More...
enum | CountDirection { Up = JY5101Import.JY5101_CI_Count_Up , Down = JY5101Import.JY5101_CI_Count_Down , External = JY5101Import.JY5101_CI_Count_External }
Counter direction. More...
enum | CIMode { Single = 2 , Finite = 0 , Continuous = 1 }
CIMode. More...
enum CIType {
EdgeCounting , Period , Frequency , Pulse ,
SemiPeriod , TwoEdgeSeparation , QuadEncoder , TwoPulseEncoder
}
Counter Input Application Type. More...
enum | CISampleClockSource { Implicit = JY5101Import.JY5101_CI_ImplicitClock , Internal = JY5101Import.JY5101_CI_InternalClock , External = JY5101Import.JY5101_CI_ExternalClock }
CI Sample Clock Source. More...
enum | EdgeType { Rising , Falling , Any }
Edge Type. More...
enum | CITimebaseSource { Internal100MHz = 0 , Internal5MHz = 1 , Internal100kHz = 2 , External = 3 }
enum | EdgeCntOunEvtIdleState { LowLevel = 0 , HighLevel = 1 }
Output idle state when the event has not occurred. More...
enum | LevelPolarity { LowLevel = 0 , HighLevel = 1 , None = 2 }
Level Polarity. More...
enum | OutputState { HoldOn = 0 , HighLevel = 1 , LowLevel = 2 }
CO output state when pause trigger valid. More...
enum | ValueReturnMode { TwoValue , OneValue }
TwoEdgeSeparation value return mode.only for TwoEdgeSeparation type. More...
enum | QuadEncodingType { X1 , X2 , X4 }
Quadrature Encoding Type. More...
enum | CITriggerType { Immediate = JY5101Import.JY5101_CIO_Immediately , Digital = JY5101Import.JY5101_CIO_Digital , Soft = JY5101Import.JY5101_CIO_Soft }
TriggerType Digital/Immediate/Soft. More...
enum CIDigitalTriggerSource {
PFI0 = JY5101Import.JY5101_DigitalTriggerSource_PFI_0 , PFI1 = JY5101Import.JY5101_DigitalTriggerSource_PFI_1 , PFI2 = JY5101Import.JY5101_DigitalTriggerSource_PFI_2 , PFI3 = JY5101Import.JY5101_DigitalTriggerSource_PFI_3 ,
PFI4 = JY5101Import.JY5101_DigitalTriggerSource_PFI_4 , PFI5 = JY5101Import.JY5101_DigitalTriggerSource_PFI_5 , PFI6 = JY5101Import.JY5101_DigitalTriggerSource_PFI_6 , PFI7 = JY5101Import.JY5101_DigitalTriggerSource_PFI_7 ,
PFI8 = JY5101Import.JY5101_DigitalTriggerSource_PFI_8 , PFI9 = JY5101Import.JY5101_DigitalTriggerSource_PFI_9 , PFI10 = JY5101Import.JY5101_DigitalTriggerSource_PFI_10 , PFI11 = JY5101Import.JY5101_DigitalTriggerSource_PFI_11 ,
PFI12 = JY5101Import.JY5101_DigitalTriggerSource_PFI_12 , PFI13 = JY5101Import.JY5101_DigitalTriggerSource_PFI_13 , PFI14 = JY5101Import.JY5101_DigitalTriggerSource_PFI_14 , PFI15 = JY5101Import.JY5101_DigitalTriggerSource_PFI_15 ,
PFI16 = JY5101Import.JY5101_DigitalTriggerSource_PFI_16 , PFI17 = JY5101Import.JY5101_DigitalTriggerSource_PFI_17 , PFI18 = JY5101Import.JY5101_DigitalTriggerSource_PFI_18 , PFI19 = JY5101Import.JY5101_DigitalTriggerSource_PFI_19 ,
PFI20 = JY5101Import.JY5101_DigitalTriggerSource_PFI_20 , PFI21 = JY5101Import.JY5101_DigitalTriggerSource_PFI_21 , PFI22 = JY5101Import.JY5101_DigitalTriggerSource_PFI_22 , PFI23 = JY5101Import.JY5101_DigitalTriggerSource_PFI_23 ,
PXI_Trig0 = JY5101Import.JY5101_DigitalTriggerSource_PXI_0 , PXI_Trig1 = JY5101Import.JY5101_DigitalTriggerSource_PXI_1 , PXI_Trig2 = JY5101Import.JY5101_DigitalTriggerSource_PXI_2 , PXI_Trig3 = JY5101Import.JY5101_DigitalTriggerSource_PXI_3 ,
PXI_Trig4 = JY5101Import.JY5101_DigitalTriggerSource_PXI_4 , PXI_Trig5 = JY5101Import.JY5101_DigitalTriggerSource_PXI_5 , PXI_Trig6 = JY5101Import.JY5101_DigitalTriggerSource_PXI_6 , PXI_Trig7 = JY5101Import.JY5101_DigitalTriggerSource_PXI_7 ,
AI_StartTrig = JY5101Import.JY5101_AI_StartTrig , AI_ReferenceTrig = JY5101Import.JY5101_AI_ReferenceTrig , AO_StartTrig = JY5101Import.JY5101_AO_StartTrig , CI_0_StartTrig = JY5101Import.JY5101_CIO0_StartTrig ,
CI_1_StartTrig = JY5101Import.JY5101_CIO1_StartTrig , CO0_Output = JY5101Import.JY5101_CO_0_Out , CO1_Output = JY5101Import.JY5101_CO_1_Out , CI0_EventOut = JY5101Import.JY5101_Event_0_Out ,
CI1_EventOut = JY5101Import.JY5101_Event_1_Out
}
CI Digital trigger source. More...
enum | CIDigitalTriggerEdge { Rising }
CI Digital Trigger Edge. More...
enum InputTerminal {
PFI0 = JY5101Import.JY5101_PFI0_Input , PFI1 = JY5101Import.JY5101_PFI1_Input , PFI2 = JY5101Import.JY5101_PFI2_Input , PFI3 = JY5101Import.JY5101_PFI3_Input ,
PFI4 = JY5101Import.JY5101_PFI4_Input , PFI5 = JY5101Import.JY5101_PFI5_Input , PFI6 = JY5101Import.JY5101_PFI6_Input , PFI7 = JY5101Import.JY5101_PFI7_Input ,
PFI8 = JY5101Import.JY5101_PFI8_Input , PFI9 = JY5101Import.JY5101_PFI9_Input , PFI10 = JY5101Import.JY5101_PFI10_Input , PFI11 = JY5101Import.JY5101_PFI11_Input ,
PFI12 = JY5101Import.JY5101_PFI12_Input , PFI13 = JY5101Import.JY5101_PFI13_Input , PFI14 = JY5101Import.JY5101_PFI14_Input , PFI15 = JY5101Import.JY5101_PFI15_Input ,
PFI16 = JY5101Import.JY5101_PFI16_Input , PFI17 = JY5101Import.JY5101_PFI17_Input , PFI18 = JY5101Import.JY5101_PFI18_Input , PFI19 = JY5101Import.JY5101_PFI19_Input ,
PFI20 = JY5101Import.JY5101_PFI20_Input , PFI21 = JY5101Import.JY5101_PFI21_Input , PFI22 = JY5101Import.JY5101_PFI22_Input , PFI23 = JY5101Import.JY5101_PFI23_Input ,
PXI_Trig0 = JY5101Import.JY5101_PXI_Trig0_Input , PXI_Trig1 = JY5101Import.JY5101_PXI_Trig1_Input , PXI_Trig2 = JY5101Import.JY5101_PXI_Trig2_Input , PXI_Trig3 = JY5101Import.JY5101_PXI_Trig3_Input ,
PXI_Trig4 = JY5101Import.JY5101_PXI_Trig4_Input , PXI_Trig5 = JY5101Import.JY5101_PXI_Trig5_Input , PXI_Trig6 = JY5101Import.JY5101_PXI_Trig6_Input , PXI_Trig7 = JY5101Import.JY5101_PXI_Trig7_Input ,
AI_SampleClock = JY5101Import.JY5101_IN_AI_SampleClock , AO_SampleClock = JY5101Import.JY5101_IN_AO_SampleClock , CO_0_Output = JY5101Import.JY5101_IN_CO_0_Output , CO_1_Output = JY5101Import.JY5101_IN_CO_1_Output ,
CIO_100MHz = JY5101Import.JY5101_IN_CIO_100MHz , CIO_5MHz = JY5101Import.JY5101_IN_CIO_5MHz , CIO_100kHz = JY5101Import.JY5101_IN_CIO_100kHz
}
输入终端 More...
enum IOTerminal {
PFI0 = JY5101Import.SignalDestination_JY5101_PFI0 , PFI1 = JY5101Import.SignalDestination_JY5101_PFI1 , PFI2 = JY5101Import.SignalDestination_JY5101_PFI2 , PFI3 = JY5101Import.SignalDestination_JY5101_PFI3 ,
PFI4 = JY5101Import.SignalDestination_JY5101_PFI4 , PFI5 = JY5101Import.SignalDestination_JY5101_PFI5 , PFI6 = JY5101Import.SignalDestination_JY5101_PFI6 , PFI7 = JY5101Import.SignalDestination_JY5101_PFI7 ,
PFI8 = JY5101Import.SignalDestination_JY5101_PFI8 , PFI9 = JY5101Import.SignalDestination_JY5101_PFI9 , PFI10 = JY5101Import.SignalDestination_JY5101_PFI10 , PFI11 = JY5101Import.SignalDestination_JY5101_PFI11 ,
PFI12 = JY5101Import.SignalDestination_JY5101_PFI12 , PFI13 = JY5101Import.SignalDestination_JY5101_PFI13 , PFI14 = JY5101Import.SignalDestination_JY5101_PFI14 , PFI15 = JY5101Import.SignalDestination_JY5101_PFI15 ,
PFI16 = JY5101Import.SignalDestination_JY5101_PFI16 , PFI17 = JY5101Import.SignalDestination_JY5101_PFI17 , PFI18 = JY5101Import.SignalDestination_JY5101_PFI18 , PFI19 = JY5101Import.SignalDestination_JY5101_PFI19 ,
PFI20 = JY5101Import.SignalDestination_JY5101_PFI20 , PFI21 = JY5101Import.SignalDestination_JY5101_PFI21 , PFI22 = JY5101Import.SignalDestination_JY5101_PFI22 , PFI23 = JY5101Import.SignalDestination_JY5101_PFI23 ,
PXI_Trig0 = JY5101Import.SignalDestination_JY5101_PXITrig0 , PXI_Trig1 = JY5101Import.SignalDestination_JY5101_PXITrig1 , PXI_Trig2 = JY5101Import.SignalDestination_JY5101_PXITrig2 , PXI_Trig3 = JY5101Import.SignalDestination_JY5101_PXITrig3 ,
PXI_Trig4 = JY5101Import.SignalDestination_JY5101_PXITrig4 , PXI_Trig5 = JY5101Import.SignalDestination_JY5101_PXITrig5 , PXI_Trig6 = JY5101Import.SignalDestination_JY5101_PXITrig6 , PXI_Trig7 = JY5101Import.SignalDestination_JY5101_PXITrig7 ,
None = 24
}
IO终端=信号的目的地（共24个） More...
enum | CISignalExportSource { StartTrig , SampleClock }
SourceSignal. More...
enum | COIdleState { HighLevel = JY5101Import.JY5101_HighLevel , LowLevel = JY5101Import.JY5101_LowLevel }
Idle state when pulse output before start and after stop. More...
enum | COMode { Single = 3 }
CO output mode. More...
enum | COTriggerType { Immediate = JY5101Import.JY5101_CIO_Immediately , Digital = JY5101Import.JY5101_CIO_Digital , Soft = JY5101Import.JY5101_CIO_Soft }
TriggerType Digital/Immediate/Soft. More...
enum CODigitalTriggerSource {
PFI0 = 0 , PFI1 = 1 , PFI2 = 2 , PFI3 = 3 ,
PFI4 = 4 , PFI5 = 5 , PFI6 = 6 , PFI7 = 7 ,
PFI8 = 8 , PFI9 = 9 , PFI10 = 10 , PFI11 = 11 ,
PFI12 = 12 , PFI13 = 13 , PFI14 = 14 , PFI15 = 15 ,
PFI16 = 16 , PFI17 = 17 , PFI18 = 18 , PFI19 = 19 ,
PFI20 = 20 , PFI21 = 21 , PFI22 = 22 , PFI23 = 23 ,
PXI_Trig0 = 24 , PXI_Trig1 = 25 , PXI_Trig2 = 26 , PXI_Trig3 = 27 ,
PXI_Trig4 = 28 , PXI_Trig5 = 29 , PXI_Trig6 = 30 , PXI_Trig7 = 31 ,
AI_StartTrig = 32 , AI_ReferenceTrig = 33 , AO_StartTrig = 34 , CIO_0_StartTrig = 35 ,
CIO_1_StartTrig = 36 , CO0_Output = 37 , CO1_Output = 38 , CI0_EventOut = 39 ,
CI1_EventOut = 40
}
CO Digital trigger source. More...
enum | CODigitalTriggerEdge { Rising }
CO Digital Trigger Edge. More...
enum | COPulseType { DutyCycleFrequency , HighLowTime , HighLowTick }
Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick. More...
enum | COTimebaseSource { Internal100MHz = 0 , Internal5MHz = 1 , Internal100kHz = 2 , External = 3 }
enum | COSignalExportSource { StartTrig , Output }
SourceSignal. More...

Enumeration Type Documentation

◆ AIAnalogComparatorLogic

enum JY5101.AIAnalogComparatorLogic

Multichannel composition logic.

Enumerator
Or | Multichannel result take or.
And | Multichannel results take and.

◆ AIAnalogTriggerComparator

enum JY5101.AIAnalogTriggerComparator

AI Analog Trigger Comparator.

Enumerator
Edge | Edge Comparator.
Hysteresis | Hysteresis Comparator.
Window | Window Comparator.

◆ AIAnalogTriggerEdge

enum JY5101.AIAnalogTriggerEdge

AI Analog Trigger Edge.

Enumerator
Rising | Rising.
Falling | Falling.

◆ AIAnalogTriggerSource

enum JY5101.AIAnalogTriggerSource

AI Analog Trigger Source.

Enumerator
Channel_0 | channel 0
Channel_1 | channel 1
Channel_2 | channel 2
Channel_3 | channel 3
Channel_4 | channel 4
Channel_5 | channel 5
Channel_6 | channel 6
Channel_7 | channel 7
Channel_8 | channel 8
Channel_9 | channel 9
Channel_10 | channel 10
Channel_11 | channel 11
Channel_12 | channel 12
Channel_13 | channel 13
Channel_14 | channel 14
Channel_15 | channel 15
Channel_16 | channel 16
Channel_17 | channel 17
Channel_18 | channel 18
Channel_19 | channel 19
Channel_20 | channel 20
Channel_21 | channel 21
Channel_22 | channel 22
Channel_23 | channel 23
Channel_24 | channel 24
Channel_25 | channel 25
Channel_26 | channel 26
Channel_27 | channel 27
Channel_28 | channel 28
Channel_29 | channel 29
Channel_30 | channel 30
Channel_31 | channel 31

◆ AIAnalogWindowCondition

enum JY5101.AIAnalogWindowCondition

AI Analog Window Trigger Condition.

Enumerator
Entering | Rising.
Leaving | Falling.

◆ AIBandWidth

enum JY5101.AIBandWidth

AI BandWidth.

Enumerator
Narrow | Narrow Bandwidth，typical 15KHz，refer to specification manual.
Medium | Medium Bandwidth，typical 39KHz，refer to specification manual.
Wide | Wide Bandwidth，typical 376KHz，refer to specification manual.

◆ AIDigitalTriggerEdge

enum JY5101.AIDigitalTriggerEdge

AI Digital Trigger Edge.

Enumerator
Rising | Rising.
Falling | Falling.

◆ AIDigitalTriggerSource

enum JY5101.AIDigitalTriggerSource

AI Digital Trigger Source.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PFI8 | PFI_8.
PFI9 | PFI_9.
PFI10 | PFI_10.
PFI11 | PFI_11.
PFI12 | PFI_12.
PFI13 | PFI_13.
PFI14 | PFI_14.
PFI15 | PFI_15.
PFI16 | PFI_16.
PFI17 | PFI_17.
PFI18 | PFI_18.
PFI19 | PFI_19.
PFI20 | PFI_20.
PFI21 | PFI_21.
PFI22 | PFI_22.
PFI23 | PFI_23.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
AO_StartTrig | AO_StartTrig.
CIO_0_StartTrig | CI0_StartTrig.
CIO_1_StartTrig | CI1_StartTrig.
CO0_Output | CO0_Output.
CO1_Output | CO1_Output.
CI0_Event_Output | CI 0 edge count event out.
CI1_Event_Output | CI 1 edge count event out.

◆ AIMode

enum JY5101.AIMode

AIMode.

Enumerator
Single | 单点模式
Finite | Finite.
Continuous | Continuous.
Record | Record.

◆ AISampleClockSource

enum JY5101.AISampleClockSource

AIClockSource Type.

Enumerator
Internal | Internal.
External | External.

◆ AISignalExportSource

enum JY5101.AISignalExportSource

AI Signal Export Source.

Enumerator
StartTrig | AI_StartTrig.
ReferenceTrig | AI_ReferenceTrig.
SampleClock | AI_SampleClock.

◆ AITerminal

enum JY5101.AITerminal

AITerminal.

Enumerator
RSE | RSE.
Differential | Differential.

◆ AITriggerMode

enum JY5101.AITriggerMode

AI Trigger Mode.

Enumerator
Start | Start Trigger Mode.
Reference | Reference Trigger Mode，Valid when JY5101AITask.Mode is AIMode.Finite.

◆ AITriggerType

enum JY5101.AITriggerType

Trigger Type: Digital/Analog/Immediate/Soft/MultiChannelAnalog.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Analog | Analog Trigger.
Soft | Soft Trigger.
MultichannelAnalog | MultiChannel Analog Trigger.

◆ AODigitalTriggerEdge

enum JY5101.AODigitalTriggerEdge

AO Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ AODigitalTriggerSource

enum JY5101.AODigitalTriggerSource

AO Digital trigger source.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PFI8 | PFI_8.
PFI9 | PFI_9.
PFI10 | PFI_10.
PFI11 | PFI_11.
PFI12 | PFI_12.
PFI13 | PFI_13.
PFI14 | PFI_14.
PFI15 | PFI_15.
PFI16 | PFI_16.
PFI17 | PFI_17.
PFI18 | PFI_18.
PFI19 | PFI_19.
PFI20 | PFI_20.
PFI21 | PFI_21.
PFI22 | PFI_22.
PFI23 | PFI_23.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
CIO_0_StartTrig | CI0_StartTrig.
CIO_1_StartTrig | CI1_StartTrig.
CO_0_Out | CI0_StartTrig.
CO_1_Out | CI1_StartTrig.
CI0_Event_Output | CI 0 edge count event out.
CI1_Event_Output | CI 1 edge count event out.

◆ AOMode

enum JY5101.AOMode

AOMode.

Enumerator
Single | Single.
Finite | Finite.
ContinuousNoWrapping | ContinuousNoWrapping.
ContinuousWrapping | ContinuousWrapping.

◆ AOSampleClockSource

enum JY5101.AOSampleClockSource

AO Sample Clock Source.

Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ AOSignalExportSource

enum JY5101.AOSignalExportSource

SourceSignal.

Enumerator
StartTrig | AO_StartTrig.
SampleClock | AO_SampleClock.

◆ AOTriggerType

enum JY5101.AOTriggerType

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ CIDigitalTriggerEdge

enum JY5101.CIDigitalTriggerEdge

CI Digital Trigger Edge.

Enumerator
Rising

RisingEdge.

◆ CIDigitalTriggerSource

enum JY5101.CIDigitalTriggerSource

CI Digital trigger source.

(共32个）

Enumerator
PFI0 | PFI_0 as the digital trigger source.
PFI1 | PFI_1 as the digital trigger source.
PFI2 | PFI_2 as the digital trigger source.
PFI3 | PFI_3 as the digital trigger source.
PFI4 | PFI_4 as the digital trigger source.
PFI5 | PFI_5 as the digital trigger source.
PFI6 | PFI_6 as the digital trigger source.
PFI7 | PFI_7 as the digital trigger source.
PFI8 | PFI_8 as the digital trigger source.
PFI9 | PFI_9 as the digital trigger source.
PFI10 | PFI_10 as the digital trigger source.
PFI11 | PFI_11 as the digital trigger source.
PFI12 | PFI_12 as the digital trigger source.
PFI13 | PFI_13 as the digital trigger source.
PFI14 | PFI_14 as the digital trigger source.
PFI15 | PFI_15 as the digital trigger source.
PFI16 | PFI_16 as the digital trigger source.
PFI17 | PFI_17 as the digital trigger source.
PFI18 | PFI_18 as the digital trigger source.
PFI19 | PFI_19 as the digital trigger source.
PFI20 | PFI_20 as the digital trigger source.
PFI21 | PFI_21 as the digital trigger source.
PFI22 | PFI_22 as the digital trigger source.
PFI23 | PFI_23 as the digital trigger source.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
AI_StartTrig | AI_StartTrig as the digital trigger source.
AI_ReferenceTrig | AI_ReferenceTrig as the digital trigger source.
AO_StartTrig | AO_StartTrig as the digital trigger source.
CI_0_StartTrig | CI0_StartTrig as the digital trigger source.
CI_1_StartTrig | CI1_StartTrig as the digital trigger source.
CO0_Output | CO_0 Output.
CO1_Output | CO_1 Output.
CI0_EventOut | CI0_EventOut.
CI1_EventOut | CI1_EventOut.

◆ CIMode

enum JY5101.CIMode

CIMode.

Enumerator
Single | Single.
Finite | Finite.
Continuous | Continuous.

◆ CISampleClockSource

enum JY5101.CISampleClockSource

CI Sample Clock Source.

Enumerator
Implicit | Implicit.
Internal | Internal.
External | External.

◆ CISignalExportSource

enum JY5101.CISignalExportSource

SourceSignal.

Enumerator
StartTrig | CI_StartTrig.
SampleClock | CI_SampleClock.

◆ CITimebaseSource

enum JY5101.CITimebaseSource

时基源

Timebase source

Enumerator
Internal100MHz | 内部100MHz时基 Internal 100MHz Timebase
Internal5MHz | 内部5MHz时基 Internal 5MHz Timebase
Internal100kHz | 内部100kHz时基 Internal 100kHz Timebase
External | 外部时基 External Timebase

◆ CITriggerType

enum JY5101.CITriggerType

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ CIType

enum JY5101.CIType

Counter Input Application Type.

Enumerator
EdgeCounting | Edge Counting.
Period | Period Measure.
Frequency | Frequenc Measure.
Pulse | Pulse Measure.
SemiPeriod | SemiPeriod Measure.
TwoEdgeSeparation | TwoEdgeSeparation Measure.
QuadEncoder | QuadEncoder.
TwoPulseEncoder | EncoderTwoPulse.

◆ ClockTerminal

enum JY5101.ClockTerminal

External Sample Clock Terminal.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PFI8 | PFI_8.
PFI9 | PFI_9.
PFI10 | PFI_10.
PFI11 | PFI_11.
PFI12 | PFI_12.
PFI13 | PFI_13.
PFI14 | PFI_14.
PFI15 | PFI_15.
PFI16 | PFI_16.
PFI17 | PFI_17.
PFI18 | PFI_18.
PFI19 | PFI_19.
PFI20 | PFI_20.
PFI21 | PFI_21.
PFI22 | PFI_22.
PFI23 | PFI_23.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
AI_SampleClock | AI SampleClock.
AO_SampleClock | AO SampleClock.
CI0_SampleClock | CI0_SampleClock.
CI1_SampleClock | CI1_SampleClock.
CO0_Output | CO0_Output.
CO1_Output | CO1_Output.

◆ CODigitalTriggerEdge

enum JY5101.CODigitalTriggerEdge

CO Digital Trigger Edge.

Enumerator
Rising

Rising Edge.

◆ CODigitalTriggerSource

enum JY5101.CODigitalTriggerSource

CO Digital trigger source.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PFI8 | PFI_8.
PFI9 | PFI_9.
PFI10 | PFI_10.
PFI11 | PFI_11.
PFI12 | PFI_12.
PFI13 | PFI_13.
PFI14 | PFI_14.
PFI15 | PFI_15.
PFI16 | PFI_16.
PFI17 | PFI_17.
PFI18 | PFI_18.
PFI19 | PFI_19.
PFI20 | PFI_20.
PFI21 | PFI_21.
PFI22 | PFI_22.
PFI23 | PFI_23.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
AO_StartTrig | AO_StartTrig.
CIO_0_StartTrig | CI0_StartTrig.
CIO_1_StartTrig | CI1_StartTrig.
CO0_Output | CO0_Output.
CO1_Output | CO1_Output.
CI0_EventOut | CI0_EventOut.
CI1_EventOut | CI1_EventOut.

◆ COIdleState

enum JY5101.COIdleState

Idle state when pulse output before start and after stop.

Enumerator
HighLevel | Idle state is high level.
LowLevel | Idle state is low level.

◆ COMode

enum JY5101.COMode

CO output mode.

Enumerator
Single

Single pulse output.

◆ COPulseType

enum JY5101.COPulseType

Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick.

Enumerator
DutyCycleFrequency | Configure CO output pulse according to its DutyCycle and Freqency.
HighLowTime | Configure CO output pulse according to duration of its high/low voltage levels.
HighLowTick | Configure CO output pulse according to its high/low tick level.

◆ COSignalExportSource

enum JY5101.COSignalExportSource

SourceSignal.

Enumerator
StartTrig | CI_StartTrig.
Output | CO_Output.

◆ COTimebaseSource

enum JY5101.COTimebaseSource

时基源

Timebase source

Enumerator
Internal100MHz | 内部100MHz时基 Internal 100MHz Timebase
Internal5MHz | 内部5MHz时基 Internal 5MHz Timebase
Internal100kHz | 内部100kHz时基 Internal 100kHz Timebase
External | 外部时基 External Timebase

◆ COTriggerType

enum JY5101.COTriggerType

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ CountDirection

enum JY5101.CountDirection

Counter direction.

enum Up/Down/External

Enumerator
Up | Counter increases.
Down | Counter decreases.
External | External signal control counter direction. If External signal is highlevel counter increases, or lowlevel counter decreases.

◆ EdgeCntOunEvtIdleState

enum JY5101.EdgeCntOunEvtIdleState

Output idle state when the event has not occurred.

Enumerator
LowLevel | Idle state is low level.
HighLevel | Idle state is high level.

◆ EdgeType

enum JY5101.EdgeType

Edge Type.

Enumerator
Rising | Rising Edge.
Falling | Falling Edge.
Any | Any Edge.

◆ FileFormat

enum JY5101.FileFormat

Streaming file format.

Enumerator
Bin

Binary file format.

◆ InputTerminal

enum JY5101.InputTerminal

输入终端

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PFI8 | PFI_8.
PFI9 | PFI_9.
PFI10 | PFI_10.
PFI11 | PFI_11.
PFI12 | PFI_12.
PFI13 | PFI_13.
PFI14 | PFI_14.
PFI15 | PFI_15.
PFI16 | PFI_16.
PFI17 | PFI_17.
PFI18 | PFI_18.
PFI19 | PFI_19.
PFI20 | PFI_20.
PFI21 | PFI_21.
PFI22 | PFI_22.
PFI23 | PFI_23.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
AI_SampleClock | AI_SampleClock as the Input Terminal.
AO_SampleClock | AO_SampleClock as the Input Terminal.
CO_0_Output | CO_0_Output as Input Terminal.
CO_1_Output | CO_1_Output as Input Terminal.
CIO_100MHz | Counter 100MHz timebase as Input Terminal.
CIO_5MHz | Counter 5MHz timebase as Input Terminal.
CIO_100kHz | Counter 100kHz timebase as Input Terminal.

◆ IOTerminal

enum JY5101.IOTerminal

IO终端=信号的目的地（共24个）

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PFI8 | PFI_8.
PFI9 | PFI_9.
PFI10 | PFI_10.
PFI11 | PFI_11.
PFI12 | PFI_12.
PFI13 | PFI_13.
PFI14 | PFI_14.
PFI15 | PFI_15.
PFI16 | PFI_16.
PFI17 | PFI_17.
PFI18 | PFI_18.
PFI19 | PFI_19.
PFI20 | PFI_20.
PFI21 | PFI_21.
PFI22 | PFI_22.
PFI23 | PFI_23.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
None | None.

◆ LevelPolarity

enum JY5101.LevelPolarity

Level Polarity.

Enumerator
LowLevel | Low level.
HighLevel | High level.
None | No active polarity.

◆ OutputCompleteState

enum JY5101.OutputCompleteState

Output Complete State.

Enumerator
Zero | Output Complete Zero.
Hold | Output Complete Hold in The last point.

◆ OutputState

enum JY5101.OutputState

CO output state when pause trigger valid.

Enumerator
HoldOn | output hold on
HighLevel | output HighLevel
LowLevel | output LowLevel

◆ QuadEncodingType

enum JY5101.QuadEncodingType

Quadrature Encoding Type.

Enumerator
X1 | X1.
X2 | X2.
X4 | X4.

◆ RecordMode

enum JY5101.RecordMode

Two stream mode from enum Finite/Infinite.

Enumerator
Finite | Finite Streaming.
Infinite | InFinite Streaming.

◆ SignalExportDestination

enum JY5101.SignalExportDestination

输出目的终端

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11.
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PFI16 | PFI16.
PFI17 | PFI17.
PFI18 | PFI18.
PFI19 | PFI19.
PFI20 | PFI20.
PFI21 | PFI21.
PFI22 | PFI22.
PFI23 | PFI23.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.

◆ SyncPulseRouting

enum JY5101.SyncPulseRouting

Synchronous signal routing (the master card routes the synchronous signal to this port, and the slave card receives the synchronous signal from this port) 同步信号路由(主卡将同步信号路由到该端口，从卡从该端口接收同步信号).

Enumerator
NONE | Default NONE.
PXI_Trig0 | PXI Trig0.
PXI_Trig1 | PXI Trig1.
PXI_Trig2 | PXI Trig2.
PXI_Trig3 | PXI Trig3.
PXI_Trig4 | PXI Trig4.
PXI_Trig5 | PXI Trig5.
PXI_Trig6 | PXI Trig6.
PXI_Trig7 | PXI Trig7.

◆ SyncTopology

enum JY5101.SyncTopology

Synchronization board configuration.

Enumerator
Independent | Independent, synchronization not supported
Master | master card
Slave | slave card

◆ SyncTriggerRouting

enum JY5101.SyncTriggerRouting

Master card trigger signal routing (Master card routes trigger signal to this port) 主控卡触发信号路由(主控卡将触发信号路由到此端口).

Enumerator
NONE | Default NONE.
PXI_Trig0 | PXI Trig0.
PXI_Trig1 | PXI Trig1.
PXI_Trig2 | PXI Trig2.
PXI_Trig3 | PXI Trig3.
PXI_Trig4 | PXI Trig4.
PXI_Trig5 | PXI Trig5.
PXI_Trig6 | PXI Trig6.
PXI_Trig7 | PXI Trig7.

◆ ValueReturnMode

enum JY5101.ValueReturnMode

TwoEdgeSeparation value return mode.only for TwoEdgeSeparation type.

Enumerator
TwoValue | Return two data simultaneously. first data is gate to aux edge separation, second data is aux to gate edge separation.
OneValue | only return gate to aux edge separation


5101 C# Programming Manual: D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101AOTask.cs File Reference

Classes | Namespaces | Enumerations
JY5101AOTask.cs File Reference

Classes

class | JY5101.JY5101AOTask
JY5101 Analog Ouput Task. More...
class | JY5101.AOChannel
AO Channel parameter class . More...
class | JY5101.AOSampleClock
AO Sample clock configuration class. More...
class | JY5101.AOExternalSampleClock
External Sample Clock Configuration Class. More...
class | JY5101.AOTrigger
Constructor to create an AOTrigger task object. More...
class | JY5101.AODigitalTrigger
AO Digital trigger . More...
class | JY5101.AOSignalExport
AO Signal Export Class. More...

Namespaces

namespace JY5101

Enumerations

enum | JY5101.AODigitalTriggerEdge { JY5101.Rising , JY5101.Falling }
AO Digital Trigger Edge. More...
enum JY5101.AODigitalTriggerSource {
JY5101.PFI0 = JY5101Import.JY5101_DigitalTriggerSource_PFI_0 , JY5101.PFI1 = JY5101Import.JY5101_DigitalTriggerSource_PFI_1 , JY5101.PFI2 = JY5101Import.JY5101_DigitalTriggerSource_PFI_2 , JY5101.PFI3 = JY5101Import.JY5101_DigitalTriggerSource_PFI_3 ,
JY5101.PFI4 = JY5101Import.JY5101_DigitalTriggerSource_PFI_4 , JY5101.PFI5 = JY5101Import.JY5101_DigitalTriggerSource_PFI_5 , JY5101.PFI6 = JY5101Import.JY5101_DigitalTriggerSource_PFI_6 , JY5101.PFI7 = JY5101Import.JY5101_DigitalTriggerSource_PFI_7 ,
JY5101.PFI8 = JY5101Import.JY5101_DigitalTriggerSource_PFI_8 , JY5101.PFI9 = JY5101Import.JY5101_DigitalTriggerSource_PFI_9 , JY5101.PFI10 = JY5101Import.JY5101_DigitalTriggerSource_PFI_10 , JY5101.PFI11 = JY5101Import.JY5101_DigitalTriggerSource_PFI_11 ,
JY5101.PFI12 = JY5101Import.JY5101_DigitalTriggerSource_PFI_12 , JY5101.PFI13 = JY5101Import.JY5101_DigitalTriggerSource_PFI_13 , JY5101.PFI14 = JY5101Import.JY5101_DigitalTriggerSource_PFI_14 , JY5101.PFI15 = JY5101Import.JY5101_DigitalTriggerSource_PFI_15 ,
JY5101.PFI16 = JY5101Import.JY5101_DigitalTriggerSource_PFI_16 , JY5101.PFI17 = JY5101Import.JY5101_DigitalTriggerSource_PFI_17 , JY5101.PFI18 = JY5101Import.JY5101_DigitalTriggerSource_PFI_18 , JY5101.PFI19 = JY5101Import.JY5101_DigitalTriggerSource_PFI_19 ,
JY5101.PFI20 = JY5101Import.JY5101_DigitalTriggerSource_PFI_20 , JY5101.PFI21 = JY5101Import.JY5101_DigitalTriggerSource_PFI_21 , JY5101.PFI22 = JY5101Import.JY5101_DigitalTriggerSource_PFI_22 , JY5101.PFI23 = JY5101Import.JY5101_DigitalTriggerSource_PFI_23 ,
JY5101.PXI_Trig0 = JY5101Import.JY5101_DigitalTriggerSource_PXI_0 , JY5101.PXI_Trig1 = JY5101Import.JY5101_DigitalTriggerSource_PXI_1 , JY5101.PXI_Trig2 = JY5101Import.JY5101_DigitalTriggerSource_PXI_2 , JY5101.PXI_Trig3 = JY5101Import.JY5101_DigitalTriggerSource_PXI_3 ,
JY5101.PXI_Trig4 = JY5101Import.JY5101_DigitalTriggerSource_PXI_4 , JY5101.PXI_Trig5 = JY5101Import.JY5101_DigitalTriggerSource_PXI_5 , JY5101.PXI_Trig6 = JY5101Import.JY5101_DigitalTriggerSource_PXI_6 , JY5101.PXI_Trig7 = JY5101Import.JY5101_DigitalTriggerSource_PXI_7 ,
JY5101.AI_StartTrig = JY5101Import.JY5101_AI_StartTrig , JY5101.AI_ReferenceTrig = JY5101Import.JY5101_AI_ReferenceTrig , JY5101.CIO_0_StartTrig = JY5101Import.JY5101_CIO0_StartTrig , JY5101.CIO_1_StartTrig = JY5101Import.JY5101_CIO1_StartTrig ,
JY5101.CO_0_Out = JY5101Import.JY5101_CO_0_Out , JY5101.CO_1_Out = JY5101Import.JY5101_CO_1_Out , JY5101.CI0_Event_Output = JY5101Import.JY5101_Event_0_Out , JY5101.CI1_Event_Output = JY5101Import.JY5101_Event_1_Out
}
AO Digital trigger source. More...
enum | JY5101.OutputCompleteState { JY5101.Zero , JY5101.Hold }
Output Complete State. More...
enum | JY5101.AOMode { JY5101.Single = 3 , JY5101.Finite = 0 , JY5101.ContinuousNoWrapping = 2 , JY5101.ContinuousWrapping = 1 }
AOMode. More...
enum | JY5101.AOSampleClockSource { JY5101.Internal , JY5101.External }
AO Sample Clock Source. More...
enum | JY5101.AOSignalExportSource { JY5101.StartTrig = JY5101Import.SignalSource_JY5101_AO_StartTrig , JY5101.SampleClock = JY5101Import.SignalSource_JY5101_AO_SampleClock }
SourceSignal. More...
enum | JY5101.AOTriggerType { JY5101.Immediate = JY5101Import.JY5101_TriggerType_Immediately , JY5101.Digital = JY5101Import.JY5101_TriggerType_Digital , JY5101.Soft = JY5101Import.JY5101_TriggerType_Soft }
TriggerType Digital/Immediate/Soft. More...


5101 C# Programming Manual: JY5101.JY5101AOTask Class Reference

  • JY5101AOTask
Public Member Functions | Properties | List of all members
JY5101.JY5101AOTask Class Referencesealed

JY5101 Analog Ouput Task. More...

Public Member Functions

JY5101AOTask (int slotNum)
Constructor, Used to create an AO task by a slot number.
JY5101AOTask (string boardName)
Constructor.
void | AddChannel (int chnId, double rangeLow=-10, double rangeHigh=10)
Add one channel.
void | AddChannel (int[] chnsId, double rangeLow=-10, double rangeHigh=10)
Add a group of channels.
void | AddChannel (int[] chnsId, double[] rangeLow, double[] rangeHigh)
Add a group of channels.
void | RemoveChannel (int chnId)
Delete the specified channel number.
void | WriteData (IntPtr buf, int samplesPerChannel, int timeout=10000)
Write to AO buffer one or multi-channel data.
void | WriteData (double[,] buf, int timeout=10000)
Write multi-channel data to AO buffer, Each column represents one channel.
void | WriteData (double[] buf, int timeout=10000)
Write one channel data to AO buffer.
void | WriteRawData (IntPtr buf, int samplesPerChannel, int timeout=10000)
Write to AO buffer one or multi-channel data.
void | WriteRawData (short[,] buf, int timeout=10000)
Write multi-channel data to AO buffer, Each column represents one channel.
void | WriteRawData (short[] buf, int timeout=10000)
Write one channel Data to AO buffer.
void | WriteSinglePoint (double[] writeValues)
write one sample to all channels in register .
void | WriteSinglePoint (double writeValue, int channel)
Write one sample to the specified channel in register.Available when Mode is AOMode.Single.
void | WriteRawSinglePoint (short[] writeValues)
write one sample to all channels in register .
void | WriteRawSinglePoint (short writeValue, int channel)
Write one sample to the specified channel in register.Available when Mode is AOMode.Single.
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.
void | Start ()
Start AO task .
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Stop ()
Stop AO task .

Properties

List< AOChannel > | Channels [get, set]
List of AO channels,,support 2 channels.
AOMode | Mode [get, set]
Mode of AO Task.
double | UpdateRate [get, set]
Update rate per channel.
int | SamplesToUpdate [get, set]
Number of samples to be read per channel.
int | BufLenInSamples [get]
Number of samples per channel can be storage in the buffer, the PropretySamplesToUpdate must be less than or equal to this value.
uint | AvaliableLenInSamples [get]
Number of output samples per channel that can be write in AO buffuer.
OutputCompleteState | CompleteState [get, set]
AO Output Complete State, Valid when Mode is NOT AOMode.Single.
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel).
AOSampleClock | SampleClock [get, set]
AI Sample Clock Configuration.
AOTrigger | Trigger = new AOTrigger() [get, set]
AO Trigger Configuration.
AOSignalExport | SignalExport [get, set]
Export AO Signal.
JY5101Device | Device [get]
Device.

Detailed Description

JY5101 Analog Ouput Task.

Constructor & Destructor Documentation

◆ JY5101AOTask() [1/2]

JY5101.JY5101AOTask.JY5101AOTask ( int slotNum )

Constructor, Used to create an AO task by a slot number.

Parameters
slotNum Card slot number.

◆ JY5101AOTask() [2/2]

JY5101.JY5101AOTask.JY5101AOTask ( string boardName )

Constructor.

Used to create an AO task by a board name.

Parameters
boardName Board name(device alias), set by device manager

Member Function Documentation

◆ AddChannel() [1/3]

void JY5101.JY5101AOTask.AddChannel | ( | int | chnId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10 )

Add one channel.

Parameters
chnId | channel's physical number ，chnId=-1, add all channels。
rangeLow | lower range limit for the channel，-10V,-5V defalut -10
rangeHigh | higher range limit for the channel，10V,5V defalut 10
Exceptions
JYDriverException

◆ AddChannel() [2/3]

void JY5101.JY5101AOTask.AddChannel | ( | int[] | chnsId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10 )

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers。
rangeLow | lower range limit for the channel，-10V,-5V defalut -10
rangeHigh | higher range limit for the channel，10V,5V defalut 10
Exceptions
JYDriverException

◆ AddChannel() [3/3]

void JY5101.JY5101AOTask.AddChannel | ( | int[] | chnsId,
 |  | double[] | rangeLow,
 |  | double[] | rangeHigh )

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers。
rangeLow | lower range limit for the channel，-10V,-5V
rangeHigh | higher range limit for the channel，10V,5V

◆ RemoveChannel()

void JY5101.JY5101AOTask.RemoveChannel ( int chnId )

Delete the specified channel number.

If it is -1, delete all channels.

Parameters
chnId Specified channel ID.

◆ SendSoftwareTrigger()

void JY5101.JY5101AOTask.SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5101.JY5101AOTask.Start ( )

Start AO task .

◆ Stop()

void JY5101.JY5101AOTask.Stop ( )

Stop AO task .

◆ WaitUntilDone()

bool JY5101.JY5101AOTask.WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Available when Mode is AOMode.Finite

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteData() [1/3]

void JY5101.JY5101AOTask.WriteData | ( | double | buf[,],
 |  | int | timeout = 10000 )

Write multi-channel data to AO buffer, Each column represents one channel.

Parameters
buf | AO buffer for data.
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [2/3]

void JY5101.JY5101AOTask.WriteData | ( | double[] | buf,
 |  | int | timeout = 10000 )

Write one channel data to AO buffer.

Parameters
buf | AO buffer for data.
timeout | >timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [3/3]

void JY5101.JY5101AOTask.WriteData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Write to AO buffer one or multi-channel data.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | data buffer.
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawData() [1/3]

void JY5101.JY5101AOTask.WriteRawData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Write to AO buffer one or multi-channel data.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | data buffer.
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawData() [2/3]

void JY5101.JY5101AOTask.WriteRawData | ( | short | buf[,],
 |  | int | timeout = 10000 )

Write multi-channel data to AO buffer, Each column represents one channel.

Parameters
buf | AO buffer for data.
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawData() [3/3]

void JY5101.JY5101AOTask.WriteRawData | ( | short[] | buf,
 |  | int | timeout = 10000 )

Write one channel Data to AO buffer.

Parameters
buf | AO buffer for data.
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawSinglePoint() [1/2]

void JY5101.JY5101AOTask.WriteRawSinglePoint | ( | short | writeValue,
 |  | int | channel )

Write one sample to the specified channel in register.Available when Mode is AOMode.Single.

Parameters
writeValue | Write value.
channel | Specified channel.

◆ WriteRawSinglePoint() [2/2]

void JY5101.JY5101AOTask.WriteRawSinglePoint ( short[] writeValues )

write one sample to all channels in register .

Available when Mode is AOMode.Single

Parameters
writeValues Write values. Array length >= Channels.Count.

◆ WriteSinglePoint() [1/2]

void JY5101.JY5101AOTask.WriteSinglePoint | ( | double | writeValue,
 |  | int | channel )

Write one sample to the specified channel in register.Available when Mode is AOMode.Single.

Parameters
writeValue | Write value.
channel | Specified channel.

◆ WriteSinglePoint() [2/2]

void JY5101.JY5101AOTask.WriteSinglePoint ( double[] writeValues )

write one sample to all channels in register .

Available when Mode is AOMode.Single

Parameters
writeValues Write values. Array length >= Channels.Count.

Property Documentation

◆ AvaliableLenInSamples

uint JY5101.JY5101AOTask.AvaliableLenInSamples
get

Number of output samples per channel that can be write in AO buffuer.

◆ BufLenInSamples

int JY5101.JY5101AOTask.BufLenInSamples
get

Number of samples per channel can be storage in the buffer, the PropretySamplesToUpdate must be less than or equal to this value.

◆ Channels

List<AOChannel> JY5101.JY5101AOTask.Channels
getset

List of AO channels,,support 2 channels.

◆ CompleteState

OutputCompleteState JY5101.JY5101AOTask.CompleteState
getset

AO Output Complete State, Valid when Mode is NOT AOMode.Single.

◆ Device

JY5101Device JY5101.JY5101AOTask.Device
get

Device.

◆ Mode

AOMode JY5101.JY5101AOTask.Mode
getset

Mode of AO Task.

Select AO Mode from enum:ContinuousNoWrapping/ContinuousWrapping/Finite/Single.

◆ SampleClock

AOSampleClock JY5101.JY5101AOTask.SampleClock
getset

AI Sample Clock Configuration.

◆ SamplesToUpdate

int JY5101.JY5101AOTask.SamplesToUpdate
getset

Number of samples to be read per channel.

default: 1000. Only valid when Mode is AIMode.Finite.

◆ SignalExport

AOSignalExport JY5101.JY5101AOTask.SignalExport
getset

Export AO Signal.

◆ TransferedSamples

ulong JY5101.JY5101AOTask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT AOMode.Single.

◆ Trigger

AOTrigger JY5101.JY5101AOTask.Trigger = new AOTrigger()
getset

AO Trigger Configuration.

◆ UpdateRate

double JY5101.JY5101AOTask.UpdateRate
getset

Update rate per channel.

Maximum sample rate is 400k . The defalut sample rate = 100k You can read this property to obtain the sample rate that will actually take effect in the current configuration.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101AOTask.cs


5101 C# Programming Manual: JY5101.AOChannel Class Reference

  • AOChannel
Properties | List of all members
JY5101.AOChannel Class Referencesealed

AO Channel parameter class . More...

Properties

int | ChannelID [get]
AO channel ID.
double | RangeLow [get, set]
Low range limit an AO channel.
double | RangeHigh [get, set]
High range limit an AO channel.

Detailed Description

AO Channel parameter class .

Property Documentation

◆ ChannelID

int JY5101.AOChannel.ChannelID
get

AO channel ID.

◆ RangeHigh

double JY5101.AOChannel.RangeHigh
getset

High range limit an AO channel.

◆ RangeLow

double JY5101.AOChannel.RangeLow
getset

Low range limit an AO channel.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101AOTask.cs


5101 C# Programming Manual: JY5101.AOSampleClock Class Reference

  • AOSampleClock
Properties | List of all members
JY5101.AOSampleClock Class Reference

AO Sample clock configuration class. More...

Properties

AOSampleClockSource | Source [get, set]
Clock Source.
AOExternalSampleClock | External [get, set]
External Sample Clock Configuration,Valid when Source is AOSampleClockSource.External.

Detailed Description

AO Sample clock configuration class.

Property Documentation

◆ External

AOExternalSampleClock JY5101.AOSampleClock.External
getset

External Sample Clock Configuration,Valid when Source is AOSampleClockSource.External.

◆ Source

AOSampleClockSource JY5101.AOSampleClock.Source
getset

Clock Source.

enum Internal/External,The default value is AOSampleClockSource.Internal.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101AOTask.cs


5101 C# Programming Manual: JY5101.AOExternalSampleClock Class Reference

  • AOExternalSampleClock
Properties | List of all members
JY5101.AOExternalSampleClock Class Reference

External Sample Clock Configuration Class. More...

Properties

ClockTerminal | Terminal [get, set]
External Sample Clock Input Terminal.
double | ExpectedRate [get, set]
Expected External Sample Clock Rate.

Detailed Description

External Sample Clock Configuration Class.

Property Documentation

◆ ExpectedRate

double JY5101.AOExternalSampleClock.ExpectedRate
getset

Expected External Sample Clock Rate.

◆ Terminal

ClockTerminal JY5101.AOExternalSampleClock.Terminal
getset

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101AOTask.cs


5101 C# Programming Manual: JY5101.AOTrigger Class Reference

  • AOTrigger
Properties | List of all members
JY5101.AOTrigger Class Referencesealed

Constructor to create an AOTrigger task object. More...

Properties

AOTriggerType | Type [get, set]
AO trigger type.
AODigitalTrigger | Digital [get, set]
AO Digital Trigger.

Detailed Description

Constructor to create an AOTrigger task object.

Used to build AO Trigger

Property Documentation

◆ Digital

AODigitalTrigger JY5101.AOTrigger.Digital
getset

AO Digital Trigger.

Valid when Type is AOTriggerType.Digital.

◆ Type

AOTriggerType JY5101.AOTrigger.Type
getset

AO trigger type.

enum Immediate/Digital/Soft.The default value is AOTriggerType.Immediate.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101AOTask.cs


5101 C# Programming Manual: JY5101.AODigitalTrigger Class Reference

  • AODigitalTrigger
Properties | List of all members
JY5101.AODigitalTrigger Class Referencesealed

AO Digital trigger . More...

Properties

AODigitalTriggerSource | Source [get, set]
AO Digital Trigger source.
AODigitalTriggerEdge | Edge [get, set]
Digital Trigger edge，Rising/Falling.

Detailed Description

AO Digital trigger .

Property Documentation

◆ Edge

AODigitalTriggerEdge JY5101.AODigitalTrigger.Edge
getset

Digital Trigger edge，Rising/Falling.

◆ Source

AODigitalTriggerSource JY5101.AODigitalTrigger.Source
getset

AO Digital Trigger source.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101AOTask.cs


5101 C# Programming Manual: JY5101.AOSignalExport Class Reference

  • AOSignalExport
Public Member Functions | List of all members
JY5101.AOSignalExport Class Reference

AO Signal Export Class. More...

Public Member Functions

void | Add (AOSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (AOSignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

AO Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY5101.AOSignalExport.Add | ( | AOSignalExportSource | source,
 |  | List< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | AO Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY5101.AOSignalExport.Add | ( | AOSignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | AO Signal Source
destination | Export Desination

◆ Clear()

void JY5101.AOSignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5101.AOSignalExport.ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101AOTask.cs


5101 C# Programming Manual: D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101CITask.cs File Reference

Classes | Namespaces | Enumerations
JY5101CITask.cs File Reference

Classes

class | JY5101.JY5101CITask
JY5101 Counter Input Task. More...
class | JY5101.CISampleClock
CI Sample Clock class. More...
class | JY5101.CIInternalSampleClock
CI Internal Sample Clock Configuration Class. More...
class | JY5101.CIImplicitSampleClock
CI Implicit Sample Clock class. More...
class | JY5101.CIExternalSampleClock
CI Implicit Sample Clock class. More...
class | JY5101.CIExternalTimebase
class | JY5101.CITimebase
class | JY5101.EdgeCounting
Configure CI EdgeCounting. More...
class | JY5101.EdgeCountingOutEvent
Edge counting output event configuration class. More...
class | JY5101.PauseTrigger
Pause trigger configuration class. More...
class | JY5101.FrequencyMeas
Configure CI Measure. More...
class | JY5101.PeriodMeas
Configure CI Measure. More...
class | JY5101.PulseMeas
Configure CI Measure. More...
class | JY5101.SemiPeriodMeas
Configure CI Measure. More...
class | JY5101.TwoEdgeSeparation
Configure CI Measure. More...
class | JY5101.QuadEncoder
Configure CI Measure. More...
class | JY5101.TwoPulseEncoder
Configure CI Measure. More...
class | JY5101.CITrigger
Constructor to create an CITrigger task object. More...
class | JY5101.CIDigitalTrigger
CI Digital trigger . More...
class | JY5101.CISignalExport
CI Signal Export Class. More...

Namespaces

namespace JY5101

Enumerations

enum | JY5101.CountDirection { JY5101.Up = JY5101Import.JY5101_CI_Count_Up , JY5101.Down = JY5101Import.JY5101_CI_Count_Down , JY5101.External = JY5101Import.JY5101_CI_Count_External }
Counter direction. More...
enum | JY5101.CIMode { JY5101.Single = 2 , JY5101.Finite = 0 , JY5101.Continuous = 1 }
CIMode. More...
enum JY5101.CIType {
JY5101.EdgeCounting , JY5101.Period , JY5101.Frequency , JY5101.Pulse ,
JY5101.SemiPeriod , JY5101.TwoEdgeSeparation , JY5101.QuadEncoder , JY5101.TwoPulseEncoder
}
Counter Input Application Type. More...
enum | JY5101.CISampleClockSource { JY5101.Implicit = JY5101Import.JY5101_CI_ImplicitClock , JY5101.Internal = JY5101Import.JY5101_CI_InternalClock , JY5101.External = JY5101Import.JY5101_CI_ExternalClock }
CI Sample Clock Source. More...
enum | JY5101.EdgeType { JY5101.Rising , JY5101.Falling , JY5101.Any }
Edge Type. More...
enum | JY5101.CITimebaseSource { JY5101.Internal100MHz = 0 , JY5101.Internal5MHz = 1 , JY5101.Internal100kHz = 2 , JY5101.External = 3 }
enum | JY5101.EdgeCntOunEvtIdleState { JY5101.LowLevel = 0 , JY5101.HighLevel = 1 }
Output idle state when the event has not occurred. More...
enum | JY5101.LevelPolarity { JY5101.LowLevel = 0 , JY5101.HighLevel = 1 , JY5101.None = 2 }
Level Polarity. More...
enum | JY5101.OutputState { JY5101.HoldOn = 0 , JY5101.HighLevel = 1 , JY5101.LowLevel = 2 }
CO output state when pause trigger valid. More...
enum | JY5101.ValueReturnMode { JY5101.TwoValue , JY5101.OneValue }
TwoEdgeSeparation value return mode.only for TwoEdgeSeparation type. More...
enum | JY5101.QuadEncodingType { JY5101.X1 , JY5101.X2 , JY5101.X4 }
Quadrature Encoding Type. More...
enum | JY5101.CITriggerType { JY5101.Immediate = JY5101Import.JY5101_CIO_Immediately , JY5101.Digital = JY5101Import.JY5101_CIO_Digital , JY5101.Soft = JY5101Import.JY5101_CIO_Soft }
TriggerType Digital/Immediate/Soft. More...
enum JY5101.CIDigitalTriggerSource {
JY5101.PFI0 = JY5101Import.JY5101_DigitalTriggerSource_PFI_0 , JY5101.PFI1 = JY5101Import.JY5101_DigitalTriggerSource_PFI_1 , JY5101.PFI2 = JY5101Import.JY5101_DigitalTriggerSource_PFI_2 , JY5101.PFI3 = JY5101Import.JY5101_DigitalTriggerSource_PFI_3 ,
JY5101.PFI4 = JY5101Import.JY5101_DigitalTriggerSource_PFI_4 , JY5101.PFI5 = JY5101Import.JY5101_DigitalTriggerSource_PFI_5 , JY5101.PFI6 = JY5101Import.JY5101_DigitalTriggerSource_PFI_6 , JY5101.PFI7 = JY5101Import.JY5101_DigitalTriggerSource_PFI_7 ,
JY5101.PFI8 = JY5101Import.JY5101_DigitalTriggerSource_PFI_8 , JY5101.PFI9 = JY5101Import.JY5101_DigitalTriggerSource_PFI_9 , JY5101.PFI10 = JY5101Import.JY5101_DigitalTriggerSource_PFI_10 , JY5101.PFI11 = JY5101Import.JY5101_DigitalTriggerSource_PFI_11 ,
JY5101.PFI12 = JY5101Import.JY5101_DigitalTriggerSource_PFI_12 , JY5101.PFI13 = JY5101Import.JY5101_DigitalTriggerSource_PFI_13 , JY5101.PFI14 = JY5101Import.JY5101_DigitalTriggerSource_PFI_14 , JY5101.PFI15 = JY5101Import.JY5101_DigitalTriggerSource_PFI_15 ,
JY5101.PFI16 = JY5101Import.JY5101_DigitalTriggerSource_PFI_16 , JY5101.PFI17 = JY5101Import.JY5101_DigitalTriggerSource_PFI_17 , JY5101.PFI18 = JY5101Import.JY5101_DigitalTriggerSource_PFI_18 , JY5101.PFI19 = JY5101Import.JY5101_DigitalTriggerSource_PFI_19 ,
JY5101.PFI20 = JY5101Import.JY5101_DigitalTriggerSource_PFI_20 , JY5101.PFI21 = JY5101Import.JY5101_DigitalTriggerSource_PFI_21 , JY5101.PFI22 = JY5101Import.JY5101_DigitalTriggerSource_PFI_22 , JY5101.PFI23 = JY5101Import.JY5101_DigitalTriggerSource_PFI_23 ,
JY5101.PXI_Trig0 = JY5101Import.JY5101_DigitalTriggerSource_PXI_0 , JY5101.PXI_Trig1 = JY5101Import.JY5101_DigitalTriggerSource_PXI_1 , JY5101.PXI_Trig2 = JY5101Import.JY5101_DigitalTriggerSource_PXI_2 , JY5101.PXI_Trig3 = JY5101Import.JY5101_DigitalTriggerSource_PXI_3 ,
JY5101.PXI_Trig4 = JY5101Import.JY5101_DigitalTriggerSource_PXI_4 , JY5101.PXI_Trig5 = JY5101Import.JY5101_DigitalTriggerSource_PXI_5 , JY5101.PXI_Trig6 = JY5101Import.JY5101_DigitalTriggerSource_PXI_6 , JY5101.PXI_Trig7 = JY5101Import.JY5101_DigitalTriggerSource_PXI_7 ,
JY5101.AI_StartTrig = JY5101Import.JY5101_AI_StartTrig , JY5101.AI_ReferenceTrig = JY5101Import.JY5101_AI_ReferenceTrig , JY5101.AO_StartTrig = JY5101Import.JY5101_AO_StartTrig , JY5101.CI_0_StartTrig = JY5101Import.JY5101_CIO0_StartTrig ,
JY5101.CI_1_StartTrig = JY5101Import.JY5101_CIO1_StartTrig , JY5101.CO0_Output = JY5101Import.JY5101_CO_0_Out , JY5101.CO1_Output = JY5101Import.JY5101_CO_1_Out , JY5101.CI0_EventOut = JY5101Import.JY5101_Event_0_Out ,
JY5101.CI1_EventOut = JY5101Import.JY5101_Event_1_Out
}
CI Digital trigger source. More...
enum | JY5101.CIDigitalTriggerEdge { JY5101.Rising }
CI Digital Trigger Edge. More...
enum JY5101.InputTerminal {
JY5101.PFI0 = JY5101Import.JY5101_PFI0_Input , JY5101.PFI1 = JY5101Import.JY5101_PFI1_Input , JY5101.PFI2 = JY5101Import.JY5101_PFI2_Input , JY5101.PFI3 = JY5101Import.JY5101_PFI3_Input ,
JY5101.PFI4 = JY5101Import.JY5101_PFI4_Input , JY5101.PFI5 = JY5101Import.JY5101_PFI5_Input , JY5101.PFI6 = JY5101Import.JY5101_PFI6_Input , JY5101.PFI7 = JY5101Import.JY5101_PFI7_Input ,
JY5101.PFI8 = JY5101Import.JY5101_PFI8_Input , JY5101.PFI9 = JY5101Import.JY5101_PFI9_Input , JY5101.PFI10 = JY5101Import.JY5101_PFI10_Input , JY5101.PFI11 = JY5101Import.JY5101_PFI11_Input ,
JY5101.PFI12 = JY5101Import.JY5101_PFI12_Input , JY5101.PFI13 = JY5101Import.JY5101_PFI13_Input , JY5101.PFI14 = JY5101Import.JY5101_PFI14_Input , JY5101.PFI15 = JY5101Import.JY5101_PFI15_Input ,
JY5101.PFI16 = JY5101Import.JY5101_PFI16_Input , JY5101.PFI17 = JY5101Import.JY5101_PFI17_Input , JY5101.PFI18 = JY5101Import.JY5101_PFI18_Input , JY5101.PFI19 = JY5101Import.JY5101_PFI19_Input ,
JY5101.PFI20 = JY5101Import.JY5101_PFI20_Input , JY5101.PFI21 = JY5101Import.JY5101_PFI21_Input , JY5101.PFI22 = JY5101Import.JY5101_PFI22_Input , JY5101.PFI23 = JY5101Import.JY5101_PFI23_Input ,
JY5101.PXI_Trig0 = JY5101Import.JY5101_PXI_Trig0_Input , JY5101.PXI_Trig1 = JY5101Import.JY5101_PXI_Trig1_Input , JY5101.PXI_Trig2 = JY5101Import.JY5101_PXI_Trig2_Input , JY5101.PXI_Trig3 = JY5101Import.JY5101_PXI_Trig3_Input ,
JY5101.PXI_Trig4 = JY5101Import.JY5101_PXI_Trig4_Input , JY5101.PXI_Trig5 = JY5101Import.JY5101_PXI_Trig5_Input , JY5101.PXI_Trig6 = JY5101Import.JY5101_PXI_Trig6_Input , JY5101.PXI_Trig7 = JY5101Import.JY5101_PXI_Trig7_Input ,
JY5101.AI_SampleClock = JY5101Import.JY5101_IN_AI_SampleClock , JY5101.AO_SampleClock = JY5101Import.JY5101_IN_AO_SampleClock , JY5101.CO_0_Output = JY5101Import.JY5101_IN_CO_0_Output , JY5101.CO_1_Output = JY5101Import.JY5101_IN_CO_1_Output ,
JY5101.CIO_100MHz = JY5101Import.JY5101_IN_CIO_100MHz , JY5101.CIO_5MHz = JY5101Import.JY5101_IN_CIO_5MHz , JY5101.CIO_100kHz = JY5101Import.JY5101_IN_CIO_100kHz
}
输入终端 More...
enum JY5101.IOTerminal {
JY5101.PFI0 = JY5101Import.SignalDestination_JY5101_PFI0 , JY5101.PFI1 = JY5101Import.SignalDestination_JY5101_PFI1 , JY5101.PFI2 = JY5101Import.SignalDestination_JY5101_PFI2 , JY5101.PFI3 = JY5101Import.SignalDestination_JY5101_PFI3 ,
JY5101.PFI4 = JY5101Import.SignalDestination_JY5101_PFI4 , JY5101.PFI5 = JY5101Import.SignalDestination_JY5101_PFI5 , JY5101.PFI6 = JY5101Import.SignalDestination_JY5101_PFI6 , JY5101.PFI7 = JY5101Import.SignalDestination_JY5101_PFI7 ,
JY5101.PFI8 = JY5101Import.SignalDestination_JY5101_PFI8 , JY5101.PFI9 = JY5101Import.SignalDestination_JY5101_PFI9 , JY5101.PFI10 = JY5101Import.SignalDestination_JY5101_PFI10 , JY5101.PFI11 = JY5101Import.SignalDestination_JY5101_PFI11 ,
JY5101.PFI12 = JY5101Import.SignalDestination_JY5101_PFI12 , JY5101.PFI13 = JY5101Import.SignalDestination_JY5101_PFI13 , JY5101.PFI14 = JY5101Import.SignalDestination_JY5101_PFI14 , JY5101.PFI15 = JY5101Import.SignalDestination_JY5101_PFI15 ,
JY5101.PFI16 = JY5101Import.SignalDestination_JY5101_PFI16 , JY5101.PFI17 = JY5101Import.SignalDestination_JY5101_PFI17 , JY5101.PFI18 = JY5101Import.SignalDestination_JY5101_PFI18 , JY5101.PFI19 = JY5101Import.SignalDestination_JY5101_PFI19 ,
JY5101.PFI20 = JY5101Import.SignalDestination_JY5101_PFI20 , JY5101.PFI21 = JY5101Import.SignalDestination_JY5101_PFI21 , JY5101.PFI22 = JY5101Import.SignalDestination_JY5101_PFI22 , JY5101.PFI23 = JY5101Import.SignalDestination_JY5101_PFI23 ,
JY5101.PXI_Trig0 = JY5101Import.SignalDestination_JY5101_PXITrig0 , JY5101.PXI_Trig1 = JY5101Import.SignalDestination_JY5101_PXITrig1 , JY5101.PXI_Trig2 = JY5101Import.SignalDestination_JY5101_PXITrig2 , JY5101.PXI_Trig3 = JY5101Import.SignalDestination_JY5101_PXITrig3 ,
JY5101.PXI_Trig4 = JY5101Import.SignalDestination_JY5101_PXITrig4 , JY5101.PXI_Trig5 = JY5101Import.SignalDestination_JY5101_PXITrig5 , JY5101.PXI_Trig6 = JY5101Import.SignalDestination_JY5101_PXITrig6 , JY5101.PXI_Trig7 = JY5101Import.SignalDestination_JY5101_PXITrig7 ,
JY5101.None = 24
}
IO终端=信号的目的地（共24个） More...
enum | JY5101.CISignalExportSource { JY5101.StartTrig , JY5101.SampleClock }
SourceSignal. More...


5101 C# Programming Manual: JY5101.JY5101CITask Class Reference

  • JY5101CITask
Public Member Functions | Properties | List of all members
JY5101.JY5101CITask Class Referencesealed

JY5101 Counter Input Task. More...

Public Member Functions

JY5101CITask (int slotNum, int channel)
Constructor.
JY5101CITask (string boardName, int channel)
Constructor.
void | Start ()
Start CI task .
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Stop ()
Stop CI task .
void | ReadSinglePoint (ref uint count)
Read a signle count value from register, Available when Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder.
void | ReadSinglePoint (ref int count)
Read a signle count value from register, Available when Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder.
void | ReadData (ref uint[] bufCount, int samplesToAcquire, int timeout=10000)
Read counter values from buffer.
void | ReadData (ref int[] bufCount, int samplesToAcquire, int timeout=10000)
Read counter values from buffer.
void | ReadData (ref uint[] bufCount, int timeout=10000)
Read counter values from buffer.
void | ReadData (ref int[] bufCount, int timeout=10000)
Read counter values from buffer.
void | ReadData (ref double[] bufMeasurement, int samplesToAcquire, int timeout=10000)
Read frequency value or period value from buffer.
void | ReadData (ref double[] bufMeasurement, int timeout=10000)
Read frequency value or period value from buffer.
void | ReadSinglePoint (ref double measurement, int timeout=10000)
Read a signle frequency value or period value from register.
void | ReadSinglePoint (ref double measurement1, ref double measurement2, int timeout=10000)
Read a signle measurement of pulse's duration value, or two-edge separtion value (two results at a time) from register.
void | ReadData (ref double[] bufMeasurement1, ref double[] bufMeasurement2, int samplesToAcquire, int timeout=10000)
Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.
void | ReadData (ref double[] bufMeasurement1, ref double[] bufMeasurement2, int timeout=10000)
Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.

Properties

CIType | Type [get, set]
CI Application types.
ulong | AvailableSamples [get]
Number of points per channel that can be read in the buffer .
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel).
CIMode | Mode [get, set]
CI Sampling mode，support Single/Finite/Continuous.
CISampleClock | SampleClock [get, set]
Clock Source.
uint | SamplesToAcquire [get, set]
Number of samples to be read per channel.Only valid when Mode is CIMode.Finite.
EdgeCounting | EdgeCounting [get, set]
Edge Counting Configuration.
FrequencyMeas | FrequencyMeas [get, set]
Frequency Measurement Configuration.
PeriodMeas | PeriodMeas [get, set]
Period Measurement Configuration.
SemiPeriodMeas | SemiPeriodMeas [get, set]
SemiPeriodMeas Measurement Configuration.
PulseMeas | PulseMeas [get, set]
Pulse Measurement Configuration.
TwoEdgeSeparation | TwoEdgeSeparation [get, set]
TwoEdgeSeparation.
QuadEncoder | QuadEncoder [get, set]
QuadEncoder.
TwoPulseEncoder | TwoPulseEncoder [get, set]
TwoPulseEncoder.
CITrigger | Trigger = new CITrigger() [get, set]
CI Trigger Configuration.
CISignalExport | SignalExport [get, set]
Export CI Signal Configuration.
JY5101Device | Device [get]
Device.

Detailed Description

JY5101 Counter Input Task.

Constructor & Destructor Documentation

◆ JY5101CITask() [1/2]

JY5101.JY5101CITask.JY5101CITask | ( | int | slotNum,
 |  | int | channel )

Constructor.

Used to create an CI task by a slot number.

Parameters
slotNum | Card slot number.
channel | Counter channel suppor0-1

◆ JY5101CITask() [2/2]

JY5101.JY5101CITask.JY5101CITask | ( | string | boardName,
 |  | int | channel )

Constructor.

Used to create an m task by a board name.

Parameters
boardName | Board name(device alias), set by device manager
channel | Counter channel .

Member Function Documentation

◆ ReadData() [1/8]

void JY5101.JY5101CITask.ReadData | ( | ref double[] | bufMeasurement,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read frequency value or period value from buffer.

Available when JY5101CITask.Mode is NOT CIMode.Single, and Type is CIType.Frequency or CIType.Period.

Parameters
bufMeasurement | Buffer for reading data. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period in seconds when Type is CIType.Period.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [2/8]

void JY5101.JY5101CITask.ReadData | ( | ref double[] | bufMeasurement,
 |  | int | timeout = 10000 )

Read frequency value or period value from buffer.

Available when JY5101CITask.Mode is NOT CIMode.Single, and Type is CIType.Frequency or CIType.Period.

Parameters
bufMeasurement | Buffer for reading data. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period in seconds when Type is CIType.Period.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [3/8]

void JY5101.JY5101CITask.ReadData | ( | ref double[] | bufMeasurement1,
 |  | ref double[] | bufMeasurement2,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.

. Available when JY5101CITask.Mode is NOT CIMode.Single, Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
bufMeasurement1 | Buffer for reading data. Indicates high level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
bufMeasurement2 | Buffer for reading data. Indicates low level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [4/8]

void JY5101.JY5101CITask.ReadData | ( | ref double[] | bufMeasurement1,
 |  | ref double[] | bufMeasurement2,
 |  | int | timeout = 10000 )

Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.

. Available when JY5101CITask.Mode is NOT CIMode.Single, Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
bufMeasurement1 | Buffer for reading data. Indicates high level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
bufMeasurement2 | Buffer for reading data. Indicates low level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [5/8]

void JY5101.JY5101CITask.ReadData | ( | ref int[] | bufCount,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read counter values from buffer.

Available when JY5101CITask.Mode is NOT CIMode.Single, and Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder

Parameters
bufCount | Buffer for reading data.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [6/8]

void JY5101.JY5101CITask.ReadData | ( | ref int[] | bufCount,
 |  | int | timeout = 10000 )

Read counter values from buffer.

Available when JY5101CITask.Mode is NOT CIMode.Single, and Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder

Parameters
bufCount | Buffer for reading data.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [7/8]

void JY5101.JY5101CITask.ReadData | ( | ref uint[] | bufCount,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read counter values from buffer.

Available when JY5101CITask.Mode is NOT CIMode.Single, and Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder

Parameters
bufCount | Buffer for reading data.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [8/8]

void JY5101.JY5101CITask.ReadData | ( | ref uint[] | bufCount,
 |  | int | timeout = 10000 )

Read counter values from buffer.

Available when JY5101CITask.Mode is NOT CIMode.Single, and Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder

Parameters
bufCount | Buffer for reading data.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [1/4]

void JY5101.JY5101CITask.ReadSinglePoint | ( | ref double | measurement,
 |  | int | timeout = 10000 )

Read a signle frequency value or period value from register.

Valid when Type is CIType.Frequency or CIType.Period.

Parameters
measurement Measurement value. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period is seconds when Type is CIType.Period.
timeout
Timeout (ms). Wait until the measurement is completed or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [2/4]

void JY5101.JY5101CITask.ReadSinglePoint | ( | ref double | measurement1,
 |  | ref double | measurement2,
 |  | int | timeout = 10000 )

Read a signle measurement of pulse's duration value, or two-edge separtion value (two results at a time) from register.

Available when Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
measurement1 | Measurement Value 1. Indicates low level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
measurement2 | Measurement Value 2. Indicates high level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
timeout
Timeout (ms). Wait until the measurement is completed or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [3/4]

void JY5101.JY5101CITask.ReadSinglePoint ( ref int count )

Read a signle count value from register, Available when Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder.

Parameters
count counter value。

◆ ReadSinglePoint() [4/4]

void JY5101.JY5101CITask.ReadSinglePoint ( ref uint count )

Read a signle count value from register, Available when Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder.

Parameters
count counter value。

◆ SendSoftwareTrigger()

void JY5101.JY5101CITask.SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5101.JY5101CITask.Start ( )

Start CI task .

◆ Stop()

void JY5101.JY5101CITask.Stop ( )

Stop CI task .

Property Documentation

◆ AvailableSamples

ulong JY5101.JY5101CITask.AvailableSamples
get

Number of points per channel that can be read in the buffer .

◆ Device

JY5101Device JY5101.JY5101CITask.Device
get

Device.

◆ EdgeCounting

EdgeCounting JY5101.JY5101CITask.EdgeCounting
getset

Edge Counting Configuration.

◆ FrequencyMeas

FrequencyMeas JY5101.JY5101CITask.FrequencyMeas
getset

Frequency Measurement Configuration.

◆ Mode

CIMode JY5101.JY5101CITask.Mode
getset

CI Sampling mode，support Single/Finite/Continuous.

◆ PeriodMeas

PeriodMeas JY5101.JY5101CITask.PeriodMeas
getset

Period Measurement Configuration.

◆ PulseMeas

PulseMeas JY5101.JY5101CITask.PulseMeas
getset

Pulse Measurement Configuration.

◆ QuadEncoder

QuadEncoder JY5101.JY5101CITask.QuadEncoder
getset

QuadEncoder.

◆ SampleClock

CISampleClock JY5101.JY5101CITask.SampleClock
getset

Clock Source.

◆ SamplesToAcquire

uint JY5101.JY5101CITask.SamplesToAcquire
getset

Number of samples to be read per channel.Only valid when Mode is CIMode.Finite.

◆ SemiPeriodMeas

SemiPeriodMeas JY5101.JY5101CITask.SemiPeriodMeas
getset

SemiPeriodMeas Measurement Configuration.

◆ SignalExport

CISignalExport JY5101.JY5101CITask.SignalExport
getset

Export CI Signal Configuration.

◆ TransferedSamples

ulong JY5101.JY5101CITask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT CIMode.Single.

◆ Trigger

CITrigger JY5101.JY5101CITask.Trigger = new CITrigger()
getset

CI Trigger Configuration.

◆ TwoEdgeSeparation

TwoEdgeSeparation JY5101.JY5101CITask.TwoEdgeSeparation
getset

TwoEdgeSeparation.

◆ TwoPulseEncoder

TwoPulseEncoder JY5101.JY5101CITask.TwoPulseEncoder
getset

TwoPulseEncoder.

◆ Type

CIType JY5101.JY5101CITask.Type
getset

CI Application types.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101CITask.cs


5101 C# Programming Manual: JY5101.CISampleClock Class Reference

  • CISampleClock
Properties | List of all members
JY5101.CISampleClock Class Reference

CI Sample Clock class. More...

Properties

CISampleClockSource | Source [get, set]
CI Sample Clock Source.
CIExternalSampleClock | External [get, set]
CI External Sample Clock Configuration.
CIImplicitSampleClock | Implicit [get, set]
CI Implicit Sample Clock Configuration.
CIInternalSampleClock | Internal [get]
Internal Sample Clock Configuration.

Detailed Description

CI Sample Clock class.

Property Documentation

◆ External

CIExternalSampleClock JY5101.CISampleClock.External
getset

CI External Sample Clock Configuration.

Valid when Source is CISampleClockSource.External.

◆ Implicit

CIImplicitSampleClock JY5101.CISampleClock.Implicit
getset

CI Implicit Sample Clock Configuration.

Valid when Source is CISampleClockSource.Implicit.

◆ Internal

CIInternalSampleClock JY5101.CISampleClock.Internal
get

Internal Sample Clock Configuration.

Valid when Source is CISampleClockSource.Internal.

◆ Source

CISampleClockSource JY5101.CISampleClock.Source
getset

CI Sample Clock Source.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101CITask.cs


5101 C# Programming Manual: JY5101.CIInternalSampleClock Class Reference

  • CIInternalSampleClock
Properties | List of all members
JY5101.CIInternalSampleClock Class Reference

CI Internal Sample Clock Configuration Class. More...

Properties

double | Rate [get, set]
The rate of the internal sample clock (sample rate) which is generated by dividing the internal clock (200MHz).
bool | IgnoreFirstSampleClock [get, set]
Ignore the first sample clock data.

Detailed Description

CI Internal Sample Clock Configuration Class.

Property Documentation

◆ IgnoreFirstSampleClock

bool JY5101.CIInternalSampleClock.IgnoreFirstSampleClock
getset

Ignore the first sample clock data.

◆ Rate

double JY5101.CIInternalSampleClock.Rate
getset

The rate of the internal sample clock (sample rate) which is generated by dividing the internal clock (200MHz).

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101CITask.cs


5101 C# Programming Manual: JY5101.CIImplicitSampleClock Class Reference

  • CIImplicitSampleClock
Properties | List of all members
JY5101.CIImplicitSampleClock Class Reference

CI Implicit Sample Clock class. More...

Properties

double ExpectedRate [get, set]
Expected Rate of Implicit Sample Clock.

Detailed Description

CI Implicit Sample Clock class.

Property Documentation

◆ ExpectedRate

double JY5101.CIImplicitSampleClock.ExpectedRate
getset

Expected Rate of Implicit Sample Clock.

Filling this parameter accurately would helps the driver to set a proper DDR write frequency internally.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101CITask.cs


5101 C# Programming Manual: JY5101.CIExternalSampleClock Class Reference

  • CIExternalSampleClock
Properties | List of all members
JY5101.CIExternalSampleClock Class Reference

CI Implicit Sample Clock class. More...

Properties

ClockTerminal | Terminal [get, set]
External Sample Clock Input Terminal.
double | ExpectedRate [get, set]
Expected Rate of External Sample Clock.
bool | IgnoreFirstSampleClock [get, set]
Ignore the first sample clock data.

Detailed Description

CI Implicit Sample Clock class.

Property Documentation

◆ ExpectedRate

double JY5101.CIExternalSampleClock.ExpectedRate
getset

Expected Rate of External Sample Clock.

Filling this parameter accurately would helps the driver to set a proper DDR write frequency internally.

◆ IgnoreFirstSampleClock

bool JY5101.CIExternalSampleClock.IgnoreFirstSampleClock
getset

Ignore the first sample clock data.

◆ Terminal

ClockTerminal JY5101.CIExternalSampleClock.Terminal
getset

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101CITask.cs


5101 C# Programming Manual: JY5101.CIExternalTimebase Class Reference

  • CIExternalTimebase
Properties | List of all members
JY5101.CIExternalTimebase Class Referencesealed

Properties

InputTerminal | Terminal [get, set]
double | Frequency [get, set]

Detailed Description

外部时基配置类

External timebase configuration class

Property Documentation

◆ Frequency

double JY5101.CIExternalTimebase.Frequency
getset

外部时基的频率

Frequency of The External Timebase

◆ Terminal

InputTerminal JY5101.CIExternalTimebase.Terminal
getset

外部时基的输入端口

External Timebase Input Terminal

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101CITask.cs


5101 C# Programming Manual: JY5101.CITimebase Class Reference

  • CITimebase
Properties | List of all members
JY5101.CITimebase Class Referencesealed

Properties

CITimebaseSource | Source [get, set]
CIExternalTimebase | External [get, set]

Detailed Description

时基配置类

Timebase configuration class

Property Documentation

◆ External

CIExternalTimebase JY5101.CITimebase.External
getset

外部时基配置。当 CITimebase.Source 为 CITimebaseSource.External时有效。

External Timebase Configuration. Valid when CITimebase.Source is COTimebaseSource.External.

◆ Source

CITimebaseSource JY5101.CITimebase.Source
getset

时基源。默认值为 CITimebaseSource.Internal100MHz。

Timebase Source. The default value is CITimebaseSource.Internal100MHz.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101CITask.cs


5101 C# Programming Manual: JY5101.EdgeCounting Class Reference

  • EdgeCounting
Properties | List of all members
JY5101.EdgeCounting Class Referencesealed

Configure CI EdgeCounting. More...

Properties

int | InitialCount [get, set]
Initial Count.
CountDirection | Direction [get, set]
Counter direction.
EdgeType | ActiveEdge [get, set]
The avtive edge of the input signal, the counter will count up or down on this edge.
PauseTrigger | Pause [get, set]
Pause Trigger Configuration.
EdgeCountingOutEvent | OutEvent [get, set]
Edge counting output event.
InputTerminal | InputTerminal [get, set]
Input Terminal.
InputTerminal | DirTerminal [get, set]
Terminal of External Count Diretion Control.
bool | InputSignalReversed [get, set]
Signal Reversed,fasle not reversed.
bool | DirectionSignalReversed [get, set]
Signal Reversed,fasle not reversed.

Detailed Description

Configure CI EdgeCounting.

Property Documentation

◆ ActiveEdge

EdgeType JY5101.EdgeCounting.ActiveEdge
getset

The avtive edge of the input signal, the counter will count up or down on this edge.

◆ Direction

CountDirection JY5101.EdgeCounting.Direction
getset

Counter direction.

enum Up/Down/External

◆ DirectionSignalReversed

bool JY5101.EdgeCounting.DirectionSignalReversed
getset

Signal Reversed,fasle not reversed.

ture reversed

◆ DirTerminal

InputTerminal JY5101.EdgeCounting.DirTerminal
getset

Terminal of External Count Diretion Control.

Valid when Direction is CountDirection.External

◆ InitialCount

int JY5101.EdgeCounting.InitialCount
getset

Initial Count.

◆ InputSignalReversed

bool JY5101.EdgeCounting.InputSignalReversed
getset

Signal Reversed,fasle not reversed.

ture reversed

◆ InputTerminal

InputTerminal JY5101.EdgeCounting.InputTerminal
getset

Input Terminal.

◆ OutEvent

EdgeCountingOutEvent JY5101.EdgeCounting.OutEvent
getset

Edge counting output event.

A pulse will be generated when the count value reaches specified threshold

◆ Pause

PauseTrigger JY5101.EdgeCounting.Pause
getset

Pause Trigger Configuration.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101CITask.cs


5101 C# Programming Manual: JY5101.EdgeCountingOutEvent Class Reference

  • EdgeCountingOutEvent
Properties | List of all members
JY5101.EdgeCountingOutEvent Class Reference

Edge counting output event configuration class. More...

Properties

EdgeCntOunEvtIdleState | IdleState [get, set]
Output idle state when the event has not occurred.
uint | Threshold [get, set]
Comparison threshold.
bool | Reset [get, set]
Reset count value to initialCount if ture.
IOTerminal | Terminal [get, set]
Terminal.

Detailed Description

Edge counting output event configuration class.

Property Documentation

◆ IdleState

EdgeCntOunEvtIdleState JY5101.EdgeCountingOutEvent.IdleState
getset

Output idle state when the event has not occurred.

The default value is EdgeCntOunEvtIdleState.LowLevel

◆ Reset

bool JY5101.EdgeCountingOutEvent.Reset
getset

Reset count value to initialCount if ture.

if false, the counter continuous count.

◆ Terminal

IOTerminal JY5101.EdgeCountingOutEvent.Terminal
getset

Terminal.

◆ Threshold

uint JY5101.EdgeCountingOutEvent.Threshold
getset

Comparison threshold.

The default value is 2^32-1

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101CITask.cs


5101 C# Programming Manual: JY5101.PauseTrigger Class Reference

  • PauseTrigger
Properties | List of all members
JY5101.PauseTrigger Class Referencesealed

Pause trigger configuration class. More...

Properties

LevelPolarity | ActivePolarity [get, set]
Pause trigger active polarity.
OutputState | OutputState [get, set]
CO output state when pause trigger valid.
InputTerminal | Terminal [get, set]
Terminal.
bool | SignalReversed [get, set]
Signal Reversed,fasle not reversed.

Detailed Description

Pause trigger configuration class.

Property Documentation

◆ ActivePolarity

LevelPolarity JY5101.PauseTrigger.ActivePolarity
getset

Pause trigger active polarity.

The default value is LevelPolarity.None, means the pause trigger is disabled.

◆ OutputState

OutputState JY5101.PauseTrigger.OutputState
getset

CO output state when pause trigger valid.

OutputState.HoldOn

◆ SignalReversed

bool JY5101.PauseTrigger.SignalReversed
getset

Signal Reversed,fasle not reversed.

ture reversed

◆ Terminal

InputTerminal JY5101.PauseTrigger.Terminal
getset

Terminal.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101CITask.cs


5101 C# Programming Manual: JY5101.FrequencyMeas Class Reference

  • FrequencyMeas
Properties | List of all members
JY5101.FrequencyMeas Class Referencesealed

Configure CI Measure. More...

Properties

CITimebase | Timebase [get, set]
Timebase configuration.
InputTerminal | InputTerminal [get, set]
Input Terminal.

Detailed Description

Configure CI Measure.

Property Documentation

◆ InputTerminal

InputTerminal JY5101.FrequencyMeas.InputTerminal
getset

Input Terminal.

◆ Timebase

CITimebase JY5101.FrequencyMeas.Timebase
getset

Timebase configuration.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101CITask.cs


5101 C# Programming Manual: JY5101.PeriodMeas Class Reference

  • PeriodMeas
Properties | List of all members
JY5101.PeriodMeas Class Referencesealed

Configure CI Measure. More...

Properties

CITimebase | Timebase [get, set]
Timebase configuration.
InputTerminal | InputTerminal [get, set]
Input Terminal.

Detailed Description

Configure CI Measure.

Property Documentation

◆ InputTerminal

InputTerminal JY5101.PeriodMeas.InputTerminal
getset

Input Terminal.

◆ Timebase

CITimebase JY5101.PeriodMeas.Timebase
getset

Timebase configuration.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101CITask.cs


5101 C# Programming Manual: JY5101.PulseMeas Class Reference

  • PulseMeas
Properties | List of all members
JY5101.PulseMeas Class Referencesealed

Configure CI Measure. More...

Properties

CITimebase | Timebase [get, set]
Timebase configuration.
EdgeType | StartingEdge [get, set]
The start edge of the input signal, the counter will count up or down on this edge.
InputTerminal | InputTerminal [get, set]
Input Terminal.
bool | SignalReversed [get, set]
Signal Reversed,fasle not reversed.

Detailed Description

Configure CI Measure.

Property Documentation

◆ InputTerminal

InputTerminal JY5101.PulseMeas.InputTerminal
getset

Input Terminal.

◆ SignalReversed

bool JY5101.PulseMeas.SignalReversed
getset

Signal Reversed,fasle not reversed.

ture reversed

◆ StartingEdge

EdgeType JY5101.PulseMeas.StartingEdge
getset

The start edge of the input signal, the counter will count up or down on this edge.

◆ Timebase

CITimebase JY5101.PulseMeas.Timebase
getset

Timebase configuration.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101CITask.cs


5101 C# Programming Manual: JY5101.SemiPeriodMeas Class Reference

  • SemiPeriodMeas
Properties | List of all members
JY5101.SemiPeriodMeas Class Referencesealed

Configure CI Measure. More...

Properties

CITimebase | Timebase [get, set]
Timebase configuration.
EdgeType | StartingEdge [get, set]
The start edge of the input signal, the counter will count up or down on this edge.
InputTerminal | InputTerminal [get, set]
Input Terminal.
bool | SignalReversed [get, set]
Signal Reversed,fasle not reversed.

Detailed Description

Configure CI Measure.

Property Documentation

◆ InputTerminal

InputTerminal JY5101.SemiPeriodMeas.InputTerminal
getset

Input Terminal.

◆ SignalReversed

bool JY5101.SemiPeriodMeas.SignalReversed
getset

Signal Reversed,fasle not reversed.

ture reversed

◆ StartingEdge

EdgeType JY5101.SemiPeriodMeas.StartingEdge
getset

The start edge of the input signal, the counter will count up or down on this edge.

◆ Timebase

CITimebase JY5101.SemiPeriodMeas.Timebase
getset

Timebase configuration.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101CITask.cs


5101 C# Programming Manual: JY5101.TwoEdgeSeparation Class Reference

  • TwoEdgeSeparation
Properties | List of all members
JY5101.TwoEdgeSeparation Class Referencesealed

Configure CI Measure. More...

Properties

CITimebase | Timebase [get, set]
Timebase configuration.
InputTerminal | FirstInputTerminal [get, set]
Input Terminal.
InputTerminal | SecondInputTerminal [get, set]
Input Terminal.
bool | FirstSignalReversed [get, set]
Signal Reversed,fasle not reversed.
bool | SecondSignalReversed [get, set]
Signal Reversed,fasle not reversed.
ValueReturnMode | EdgeSeparationMode [get, set]

Detailed Description

Configure CI Measure.

Property Documentation

◆ EdgeSeparationMode

ValueReturnMode JY5101.TwoEdgeSeparation.EdgeSeparationMode
getset

数据返回模式

data return mode

◆ FirstInputTerminal

InputTerminal JY5101.TwoEdgeSeparation.FirstInputTerminal
getset

Input Terminal.

◆ FirstSignalReversed

bool JY5101.TwoEdgeSeparation.FirstSignalReversed
getset

Signal Reversed,fasle not reversed.

ture reversed

◆ SecondInputTerminal

InputTerminal JY5101.TwoEdgeSeparation.SecondInputTerminal
getset

Input Terminal.

◆ SecondSignalReversed

bool JY5101.TwoEdgeSeparation.SecondSignalReversed
getset

Signal Reversed,fasle not reversed.

ture reversed

◆ Timebase

CITimebase JY5101.TwoEdgeSeparation.Timebase
getset

Timebase configuration.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101CITask.cs


5101 C# Programming Manual: JY5101.QuadEncoder Class Reference

  • QuadEncoder
Properties | List of all members
JY5101.QuadEncoder Class Referencesealed

Configure CI Measure. More...

Properties

QuadEncodingType | EncodingType [get, set]
Type of Encoding.
bool | ZReloadEnabled [get, set]
In Encoder mode ,the Z signal enable.
int | InitialCount [get, set]
Initial Count.
InputTerminal | AInputTerminal [get, set]
Input Terminal.
bool | ASignalReversed [get, set]
Signal Reversed,fasle not reversed.
InputTerminal | BInputTerminal [get, set]
Input Terminal.
bool | BSignalReversed [get, set]
Signal Reversed,fasle not reversed.
InputTerminal | ZInputTerminal [get, set]
Input Terminal.
bool | ZSignalReversed [get, set]
Signal Reversed,fasle not reversed.

Detailed Description

Configure CI Measure.

Property Documentation

◆ AInputTerminal

InputTerminal JY5101.QuadEncoder.AInputTerminal
getset

Input Terminal.

◆ ASignalReversed

bool JY5101.QuadEncoder.ASignalReversed
getset

Signal Reversed,fasle not reversed.

ture reversed

◆ BInputTerminal

InputTerminal JY5101.QuadEncoder.BInputTerminal
getset

Input Terminal.

◆ BSignalReversed

bool JY5101.QuadEncoder.BSignalReversed
getset

Signal Reversed,fasle not reversed.

ture reversed

◆ EncodingType

QuadEncodingType JY5101.QuadEncoder.EncodingType
getset

Type of Encoding.

◆ InitialCount

int JY5101.QuadEncoder.InitialCount
getset

Initial Count.

◆ ZInputTerminal

InputTerminal JY5101.QuadEncoder.ZInputTerminal
getset

Input Terminal.

◆ ZReloadEnabled

bool JY5101.QuadEncoder.ZReloadEnabled
getset

In Encoder mode ,the Z signal enable.

◆ ZSignalReversed

bool JY5101.QuadEncoder.ZSignalReversed
getset

Signal Reversed,fasle not reversed.

ture reversed

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101CITask.cs


5101 C# Programming Manual: JY5101.TwoPulseEncoder Class Reference

  • TwoPulseEncoder
Properties | List of all members
JY5101.TwoPulseEncoder Class Referencesealed

Configure CI Measure. More...

Properties

int | InitialCount [get, set]
Initial Count.
InputTerminal | AInputTerminal [get, set]
Input Terminal.
bool | ASignalReversed [get, set]
Signal Reversed,fasle not reversed.
InputTerminal | BInputTerminal [get, set]
Input Terminal.
bool | BSignalReversed [get, set]
Signal Reversed,fasle not reversed.

Detailed Description

Configure CI Measure.

Property Documentation

◆ AInputTerminal

InputTerminal JY5101.TwoPulseEncoder.AInputTerminal
getset

Input Terminal.

◆ ASignalReversed

bool JY5101.TwoPulseEncoder.ASignalReversed
getset

Signal Reversed,fasle not reversed.

ture reversed

◆ BInputTerminal

InputTerminal JY5101.TwoPulseEncoder.BInputTerminal
getset

Input Terminal.

◆ BSignalReversed

bool JY5101.TwoPulseEncoder.BSignalReversed
getset

Signal Reversed,fasle not reversed.

ture reversed

◆ InitialCount

int JY5101.TwoPulseEncoder.InitialCount
getset

Initial Count.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101CITask.cs


5101 C# Programming Manual: JY5101.CITrigger Class Reference

  • CITrigger
Properties | List of all members
JY5101.CITrigger Class Referencesealed

Constructor to create an CITrigger task object. More...

Properties

CITriggerType | Type [get, set]
CI trigger type.
CIDigitalTrigger | Digital [get, set]
CI Digital Trigger.

Detailed Description

Constructor to create an CITrigger task object.

Used to build CI Trigger

Property Documentation

◆ Digital

CIDigitalTrigger JY5101.CITrigger.Digital
getset

CI Digital Trigger.

Valid when Type is CITriggerType.Digital

◆ Type

CITriggerType JY5101.CITrigger.Type
getset

CI trigger type.

enum Immediate/Digital/Soft.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101CITask.cs


5101 C# Programming Manual: JY5101.CIDigitalTrigger Class Reference

  • CIDigitalTrigger
Properties | List of all members
JY5101.CIDigitalTrigger Class Referencesealed

CI Digital trigger . More...

Properties

CIDigitalTriggerSource | Source [get, set]
CI Digital Trigger source.
CIDigitalTriggerEdge | Edge [get, set]
Digital Trigger edge，Rising/Falling.

Detailed Description

CI Digital trigger .

Property Documentation

◆ Edge

CIDigitalTriggerEdge JY5101.CIDigitalTrigger.Edge
getset

Digital Trigger edge，Rising/Falling.

◆ Source

CIDigitalTriggerSource JY5101.CIDigitalTrigger.Source
getset

CI Digital Trigger source.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101CITask.cs


5101 C# Programming Manual: JY5101.CISignalExport Class Reference

  • CISignalExport
Public Member Functions | List of all members
JY5101.CISignalExport Class Reference

CI Signal Export Class. More...

Public Member Functions

void | Add (CISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (CISignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

CI Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY5101.CISignalExport.Add | ( | CISignalExportSource | source,
 |  | List< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | CI Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY5101.CISignalExport.Add | ( | CISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | CI Signal Source
destination | Export Desination

◆ Clear()

void JY5101.CISignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5101.CISignalExport.ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101CITask.cs


5101 C# Programming Manual: D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101COTask.cs File Reference

Classes | Namespaces | Enumerations
JY5101COTask.cs File Reference

Classes

class | JY5101.JY5101COTask
JY5101 Counter Output Task. More...
class | JY5101.COTrigger
Constructor to create an COTrigger task object. More...
class | JY5101.CODigitalTrigger
CO Digital trigger . More...
class | JY5101.COPulse
Pulse Parameter. More...
class | JY5101.COExternalTimebase
class | JY5101.COTimebase
class | JY5101.COSignalExport
CO Signal Export Class. More...

Namespaces

namespace JY5101

Enumerations

enum | JY5101.COIdleState { JY5101.HighLevel = JY5101Import.JY5101_HighLevel , JY5101.LowLevel = JY5101Import.JY5101_LowLevel }
Idle state when pulse output before start and after stop. More...
enum | JY5101.COMode { JY5101.Single = 3 }
CO output mode. More...
enum | JY5101.COTriggerType { JY5101.Immediate = JY5101Import.JY5101_CIO_Immediately , JY5101.Digital = JY5101Import.JY5101_CIO_Digital , JY5101.Soft = JY5101Import.JY5101_CIO_Soft }
TriggerType Digital/Immediate/Soft. More...
enum JY5101.CODigitalTriggerSource {
JY5101.PFI0 = 0 , JY5101.PFI1 = 1 , JY5101.PFI2 = 2 , JY5101.PFI3 = 3 ,
JY5101.PFI4 = 4 , JY5101.PFI5 = 5 , JY5101.PFI6 = 6 , JY5101.PFI7 = 7 ,
JY5101.PFI8 = 8 , JY5101.PFI9 = 9 , JY5101.PFI10 = 10 , JY5101.PFI11 = 11 ,
JY5101.PFI12 = 12 , JY5101.PFI13 = 13 , JY5101.PFI14 = 14 , JY5101.PFI15 = 15 ,
JY5101.PFI16 = 16 , JY5101.PFI17 = 17 , JY5101.PFI18 = 18 , JY5101.PFI19 = 19 ,
JY5101.PFI20 = 20 , JY5101.PFI21 = 21 , JY5101.PFI22 = 22 , JY5101.PFI23 = 23 ,
JY5101.PXI_Trig0 = 24 , JY5101.PXI_Trig1 = 25 , JY5101.PXI_Trig2 = 26 , JY5101.PXI_Trig3 = 27 ,
JY5101.PXI_Trig4 = 28 , JY5101.PXI_Trig5 = 29 , JY5101.PXI_Trig6 = 30 , JY5101.PXI_Trig7 = 31 ,
JY5101.AI_StartTrig = 32 , JY5101.AI_ReferenceTrig = 33 , JY5101.AO_StartTrig = 34 , JY5101.CIO_0_StartTrig = 35 ,
JY5101.CIO_1_StartTrig = 36 , JY5101.CO0_Output = 37 , JY5101.CO1_Output = 38 , JY5101.CI0_EventOut = 39 ,
JY5101.CI1_EventOut = 40
}
CO Digital trigger source. More...
enum | JY5101.CODigitalTriggerEdge { JY5101.Rising }
CO Digital Trigger Edge. More...
enum | JY5101.COPulseType { JY5101.DutyCycleFrequency , JY5101.HighLowTime , JY5101.HighLowTick }
Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick. More...
enum | JY5101.COTimebaseSource { JY5101.Internal100MHz = 0 , JY5101.Internal5MHz = 1 , JY5101.Internal100kHz = 2 , JY5101.External = 3 }
enum | JY5101.COSignalExportSource { JY5101.StartTrig , JY5101.Output }
SourceSignal. More...


5101 C# Programming Manual: JY5101.JY5101COTask Class Reference

  • JY5101COTask
Public Member Functions | Properties | List of all members
JY5101.JY5101COTask Class Referencesealed

JY5101 Counter Output Task. More...

Public Member Functions

JY5101COTask (int slotNum, int channel)
Constructor.
JY5101COTask (string boardName, int channel)
Constructor.
void | WriteSinglePoint (COPulse pulse)
Write a single pulse parameter to the register.
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Start ()
Start CO task .
void | Stop ()
Stop COtask .
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.

Properties

IOTerminal | OutputTerminal [get, set]
PauseTrigger | Pause [get, set]
COTimebase | Timebase [get, set]
CO's time base.
double | InitialDelay [get, set]
Counter output initial delay in seconds.
COIdleState | IdleState [get, set]
Idle state when pulse output before start and after stop.
COTrigger | Trigger = new COTrigger() [get, set]
CO trigger property configured by CO Trigger().
JY5101Device | Device [get]
Device.
COSignalExport | SignalExport [get, set]
Export CO Signal Configuration.

Detailed Description

JY5101 Counter Output Task.

Constructor & Destructor Documentation

◆ JY5101COTask() [1/2]

JY5101.JY5101COTask.JY5101COTask | ( | int | slotNum,
 |  | int | channel )

Constructor.

Used to create an CO task by a slot number.

Parameters
slotNum | Card slot number.
channel | Counter channel （5101 support0-1）.

◆ JY5101COTask() [2/2]

JY5101.JY5101COTask.JY5101COTask | ( | string | boardName,
 |  | int | channel )

Constructor.

Used to create an CO task by a board name.

Parameters
boardName | Board name(device alias), set by device manager
channel | Counter channel （5101 support0-1）.

Member Function Documentation

◆ SendSoftwareTrigger()

void JY5101.JY5101COTask.SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5101.JY5101COTask.Start ( )

Start CO task .

◆ Stop()

void JY5101.JY5101COTask.Stop ( )

Stop COtask .

◆ WaitUntilDone()

bool JY5101.JY5101COTask.WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteSinglePoint()

void JY5101.JY5101COTask.WriteSinglePoint ( COPulse pulse )

Write a single pulse parameter to the register.

This function is also available after starting the task when the number of pulses being sent is infinite.

Parameters
pulse Pulse Parameter

Property Documentation

◆ Device

JY5101Device JY5101.JY5101COTask.Device
get

Device.

◆ IdleState

COIdleState JY5101.JY5101COTask.IdleState
getset

Idle state when pulse output before start and after stop.

◆ InitialDelay

double JY5101.JY5101COTask.InitialDelay
getset

Counter output initial delay in seconds.

There are five ticks of the timebase fixed delay in counter internal, so the total delay(s) = InitialDelay + (5 / timebase)

◆ OutputTerminal

IOTerminal JY5101.JY5101COTask.OutputTerminal
getset

脉冲输出端口

Pulse Output Terminal

◆ Pause

PauseTrigger JY5101.JY5101COTask.Pause
getset

暂停触发配置

Pause Trigger Configuration

◆ SignalExport

COSignalExport JY5101.JY5101COTask.SignalExport
getset

Export CO Signal Configuration.

◆ Timebase

COTimebase JY5101.JY5101COTask.Timebase
getset

CO's time base.

◆ Trigger

COTrigger JY5101.JY5101COTask.Trigger = new COTrigger()
getset

CO trigger property configured by CO Trigger().

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101COTask.cs


5101 C# Programming Manual: JY5101.COTrigger Class Reference

  • COTrigger
Properties | List of all members
JY5101.COTrigger Class Referencesealed

Constructor to create an COTrigger task object. More...

Properties

COTriggerType | Type [get, set]
CO trigger type.
CODigitalTrigger | Digital [get, set]
CO Digital Trigger.

Detailed Description

Constructor to create an COTrigger task object.

Used to build CO Trigger

Property Documentation

◆ Digital

CODigitalTrigger JY5101.COTrigger.Digital
getset

CO Digital Trigger.

Valid when Type is COTriggerType.Digital

◆ Type

COTriggerType JY5101.COTrigger.Type
getset

CO trigger type.

enum Immediate/Digital/Soft.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101COTask.cs


5101 C# Programming Manual: JY5101.CODigitalTrigger Class Reference

  • CODigitalTrigger
Properties | List of all members
JY5101.CODigitalTrigger Class Referencesealed

CO Digital trigger . More...

Properties

CODigitalTriggerSource | Source [get, set]
CO Digital Trigger source.
CODigitalTriggerEdge | Edge [get, set]
Digital Trigger edge，Rising/Falling.

Detailed Description

CO Digital trigger .

Property Documentation

◆ Edge

CODigitalTriggerEdge JY5101.CODigitalTrigger.Edge
getset

Digital Trigger edge，Rising/Falling.

◆ Source

CODigitalTriggerSource JY5101.CODigitalTrigger.Source
getset

CO Digital Trigger source.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101COTask.cs


5101 C# Programming Manual: JY5101.COPulse Class Reference

  • COPulse
Public Member Functions | List of all members
JY5101.COPulse Class Reference

Pulse Parameter. More...

Public Member Functions

COPulse (COPulseType type, double param1, double param2, int count)
Pulse Parameter.

Detailed Description

Pulse Parameter.

Constructor & Destructor Documentation

◆ COPulse()

JY5101.COPulse.COPulse | ( | COPulseType | type,
 |  | double | param1,
 |  | double | param2,
 |  | int | count )

Pulse Parameter.

Parameters
type | The pulse type characteristics.
param1 | Parameter 1. Frequency (Hz) when constructed as COPulseType.DutyCycleFrequency; High duration in seconds when constructed as COPulseType.HighLowTime; High ticks of the clock when constructed as COPulseType.HighLowTick.
param2 | Parameter 1. Duty cycle (greater than 0 and less than 1) when constructed as COPulseType.DutyCycleFrequency; Low duration in seconds when constructed as COPulseType.HighLowTime; Low ticks of the clock when constructed as COPulseType.HighLowTick.
count | Number of pulses. When the value is -1 (indicating that the number of pulses is infinite), pulses will be continuously sent until requested to stop.
The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101COTask.cs


5101 C# Programming Manual: JY5101.COExternalTimebase Class Reference

  • COExternalTimebase
Properties | List of all members
JY5101.COExternalTimebase Class Referencesealed

Properties

InputTerminal | Terminal [get, set]
double | Frequency [get, set]

Detailed Description

外部时基配置类

External timebase configuration class

Property Documentation

◆ Frequency

double JY5101.COExternalTimebase.Frequency
getset

外部时基的频率

Frequency of The External Timebase

◆ Terminal

InputTerminal JY5101.COExternalTimebase.Terminal
getset

外部时基的输入端口

External Timebase Input Terminal

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101COTask.cs


5101 C# Programming Manual: JY5101.COTimebase Class Reference

  • COTimebase
Properties | List of all members
JY5101.COTimebase Class Referencesealed

Properties

COTimebaseSource | Source [get, set]
COExternalTimebase | External [get, set]

Detailed Description

时基配置类

Timebase configuration class

Property Documentation

◆ External

COExternalTimebase JY5101.COTimebase.External
getset

外部时基配置。当 COTimebase.Source 为 COTimebaseSource.External时有效。

External Timebase Configuration. Valid when COTimebase.Source is COTimebaseSource.External.

◆ Source

COTimebaseSource JY5101.COTimebase.Source
getset

时基源。默认值为 COTimebaseSource.Internal100MHz。

Timebase Source. The default value is COTimebaseSource.Internal100MHz.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101COTask.cs


5101 C# Programming Manual: JY5101.COSignalExport Class Reference

  • COSignalExport
Public Member Functions | List of all members
JY5101.COSignalExport Class Reference

CO Signal Export Class. More...

Public Member Functions

void | Add (COSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (COSignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

CO Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY5101.COSignalExport.Add | ( | COSignalExportSource | source,
 |  | List< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | CO Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY5101.COSignalExport.Add | ( | COSignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | CO Signal Source
destination | Export Desination

◆ Clear()

void JY5101.COSignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5101.COSignalExport.ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101COTask.cs


5101 C# Programming Manual: D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101DITask.cs File Reference

Classes | Namespaces
JY5101DITask.cs File Reference

Classes

class | JY5101.JY5101DITask
JY5101 Digital Iuput Task. More...
class | JY5101.DIChannel
DI Channel parameter class . More...

Namespaces

namespace JY5101


5101 C# Programming Manual: JY5101.JY5101DITask Class Reference

  • JY5101DITask
Public Member Functions | Properties | List of all members
JY5101.JY5101DITask Class Referencesealed

JY5101 Digital Iuput Task. More...

Public Member Functions

JY5101DITask (int slotNum)
Constructor.
JY5101DITask (string boardName)
Constructor.
void | AddChannel (int lineNum)
void | AddChannel (int lineNum, bool enableFilter=false, int minPulseWidth=10)
void | AddChannel (int[] linesNum)
void | AddChannel (int[] linesNum, bool enableFilter=false, int minPulseWidth=10)
void | AddChannel (int[] linesNum, bool[] enableFilter, int[] minPulseWidth)
void | RemoveChannel (int lineNum)
void | Start ()
Start DI task .
void | Stop ()
Stop DI task .
void | ReadSinglePoint (ref bool readValue, int lineID)
Read one sample for specified channel in register.
void | ReadSinglePoint (ref bool[] readValues)

Properties

List< DIChannel > | Channels [get]
List of DI channels,(5101 Support 24 lines including 16 PFI).
JY5101Device | Device [get]
Device.

Detailed Description

JY5101 Digital Iuput Task.

Constructor & Destructor Documentation

◆ JY5101DITask() [1/2]

JY5101.JY5101DITask.JY5101DITask ( int slotNum )

Constructor.

Used to create an DItask by a slot number.

Parameters
slotNum Card slot number.

◆ JY5101DITask() [2/2]

JY5101.JY5101DITask.JY5101DITask ( string boardName )

Constructor.

Used to create an DI task by a board name.

Parameters
boardName Board name(device alias), set by device manager

Member Function Documentation

◆ AddChannel() [1/5]

void JY5101.JY5101DITask.AddChannel ( int lineNum )

添加单通道

add single channel

Parameters
lineNum 通道编号lineID

◆ AddChannel() [2/5]

void JY5101.JY5101DITask.AddChannel | ( | int | lineNum,
 |  | bool | enableFilter = false,
 |  | int | minPulseWidth = 10 )

添加单通道

add single channel

Parameters
lineNum 通道编号lineIDc
Parameters
enableFilter | enable filter
minPulseWidth | Minimum pulse width in ns, bounce less than this length will be ignored. The smallest step in the range of 10 ns to 2550 ns is 10 ns, the smallest step in the range of 2550 ns to 40800 ns is 160 ns, and the smallest step in the range of 40800 ns to 652800 ns The step is 2560 ns

◆ AddChannel() [3/5]

void JY5101.JY5101DITask.AddChannel ( int[] linesNum )

添加多通道

add muliti channel

Parameters
linesNum 通道编号数组lineID

◆ AddChannel() [4/5]

void JY5101.JY5101DITask.AddChannel | ( | int[] | linesNum,
 |  | bool | enableFilter = false,
 |  | int | minPulseWidth = 10 )

添加多通道

add muliti channel

Parameters
linesNum 通道编号数组lineID
Parameters
enableFilter | enable filter
minPulseWidth | Minimum pulse width in ns, bounce less than this length will be ignored. The smallest step in the range of 10 ns to 2550 ns is 10 ns, the smallest step in the range of 2550 ns to 40800 ns is 160 ns, and the smallest step in the range of 40800 ns to 652800 ns The step is 2560 ns

◆ AddChannel() [5/5]

void JY5101.JY5101DITask.AddChannel | ( | int[] | linesNum,
 |  | bool[] | enableFilter,
 |  | int[] | minPulseWidth )

添加多通道

add muliti channel

Parameters
linesNum 通道编号数组lineID
Parameters
enableFilter | enable filter
minPulseWidth | Minimum pulse width in ns, bounce less than this length will be ignored. The smallest step in the range of 10 ns to 2550 ns is 10 ns, the smallest step in the range of 2550 ns to 40800 ns is 160 ns, and the smallest step in the range of 40800 ns to 652800 ns The step is 2560 ns

◆ ReadSinglePoint() [1/2]

void JY5101.JY5101DITask.ReadSinglePoint | ( | ref bool | readValue,
 |  | int | lineID )

Read one sample for specified channel in register.

. Available when DIMode.Single Mode 可用

Parameters
readValue | values read
lineID | Specified lineID numbers.when the lineID is -1, read all enabled lines values

◆ ReadSinglePoint() [2/2]

void JY5101.JY5101DITask.ReadSinglePoint ( ref bool[] readValues )

从寄存器读取样点值。当Type为DIMode.Single时

Read a signle count value from register. Available when Type is DIMode.Single时可用。

Parameters
readValues 存储样点值的数组，每个通道读取一个bool值Values read. Buffer size >= number of channels.

◆ RemoveChannel()

void JY5101.JY5101DITask.RemoveChannel ( int lineNum )

删除单通道

Delete the specified line number

Parameters
lineNum 通道编号lineID

◆ Start()

void JY5101.JY5101DITask.Start ( )

Start DI task .

◆ Stop()

void JY5101.JY5101DITask.Stop ( )

Stop DI task .

Property Documentation

◆ Channels

List<DIChannel> JY5101.JY5101DITask.Channels
get

List of DI channels,(5101 Support 24 lines including 16 PFI).

◆ Device

JY5101Device JY5101.JY5101DITask.Device
get

Device.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101DITask.cs


5101 C# Programming Manual: JY5101.DIChannel Class Reference

  • DIChannel
Properties | List of all members
JY5101.DIChannel Class Referencesealed

DI Channel parameter class . More...

Properties

int | LineNum [get, set]
Line number.
bool | EnableFilter [get, set]
Enable Filter.
int | MinPulseWidth [get, set]
Minimum pulse width in ns, bounce less than this length will be ignored.

Detailed Description

DI Channel parameter class .

Property Documentation

◆ EnableFilter

bool JY5101.DIChannel.EnableFilter
getset

Enable Filter.

◆ LineNum

int JY5101.DIChannel.LineNum
getset

Line number.

◆ MinPulseWidth

int JY5101.DIChannel.MinPulseWidth
getset

Minimum pulse width in ns, bounce less than this length will be ignored.

The smallest step in the range of 10 ns to 2550 ns is 10 ns, the smallest step in the range of 2550 ns to 40800 ns is 160 ns, and the smallest step in the range of 40800 ns to 652800 ns The step is 2560 ns

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101DITask.cs


5101 C# Programming Manual: D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101DOTask.cs File Reference

Classes | Namespaces
JY5101DOTask.cs File Reference

Classes

class | JY5101.JY5101DOTask
JY5101 Digital Output Task. More...
class | JY5101.DOChannel
DO Channel parameter class . More...

Namespaces

namespace JY5101


5101 C# Programming Manual: JY5101.JY5101DOTask Class Reference

  • JY5101DOTask
Public Member Functions | Properties | List of all members
JY5101.JY5101DOTask Class Referencesealed

JY5101 Digital Output Task. More...

Public Member Functions

JY5101DOTask (int slotNum)
Constructor.
JY5101DOTask (string boardName)
Constructor.
void | AddChannel (int LineID)
Add one channel.
void | AddChannel (int[] LineID)
Add a group of channels.
void | RemoveChannel (int LineID)
Delete the specified Line number .If it is -1, delete all Lines.
void | Start ()
Start DO task .
void | Stop ()
Stop DO task .
void | WriteSinglePoint (bool writeValues, int line)
Write one sample to the specified line in register.Available when Mode is DOMode.Single.
void | WriteSinglePoint (bool[] writeValues)
write one sample to all lines in register .
void | ReadSinglePoint (ref bool readValue, int line)
Read one sample for specified channel in register.
void | ReadSinglePoint (ref bool[] readValues)
Read one sample for Line in register .

Properties

List< DOChannel > | Channels [get]
List of DO channels,(5101 Support 24 lines including 16 PFI).
JY5101Device | Device [get]
Device.

Detailed Description

JY5101 Digital Output Task.

Constructor & Destructor Documentation

◆ JY5101DOTask() [1/2]

JY5101.JY5101DOTask.JY5101DOTask ( int slotNum )

Constructor.

Used to create an DOtask by a slot number.

Parameters
slotNum Card slot number.

◆ JY5101DOTask() [2/2]

JY5101.JY5101DOTask.JY5101DOTask ( string boardName )

Constructor.

Used to create an DO task by a board name.

Parameters
boardName Board name(device alias), set by device manager

Member Function Documentation

◆ AddChannel() [1/2]

void JY5101.JY5101DOTask.AddChannel ( int LineID )

Add one channel.

Parameters
LineID Line number to be added.

◆ AddChannel() [2/2]

void JY5101.JY5101DOTask.AddChannel ( int[] LineID )

Add a group of channels.

Parameters
LineID an array of line numbers of added lines.

◆ ReadSinglePoint() [1/2]

void JY5101.JY5101DOTask.ReadSinglePoint | ( | ref bool | readValue,
 |  | int | line )

Read one sample for specified channel in register.

Parameters
readValue | values read
line | Specified line numbers.

◆ ReadSinglePoint() [2/2]

void JY5101.JY5101DOTask.ReadSinglePoint ( ref bool[] readValues )

Read one sample for Line in register .

Parameters
readValues Values read. Buffer size >= number of lines.

◆ RemoveChannel()

void JY5101.JY5101DOTask.RemoveChannel ( int LineID )

Delete the specified Line number .If it is -1, delete all Lines.

Parameters
LineID Line number to be delete.

◆ Start()

void JY5101.JY5101DOTask.Start ( )

Start DO task .

◆ Stop()

void JY5101.JY5101DOTask.Stop ( )

Stop DO task .

◆ WriteSinglePoint() [1/2]

void JY5101.JY5101DOTask.WriteSinglePoint | ( | bool | writeValues,
 |  | int | line )

Write one sample to the specified line in register.Available when Mode is DOMode.Single.

Parameters
writeValues | Write values.
line | Specified line.

◆ WriteSinglePoint() [2/2]

void JY5101.JY5101DOTask.WriteSinglePoint ( bool[] writeValues )

write one sample to all lines in register .

Parameters
writeValues Data to be written.Buffer size >= number of lines。

Property Documentation

◆ Channels

List<DOChannel> JY5101.JY5101DOTask.Channels
get

List of DO channels,(5101 Support 24 lines including 16 PFI).

◆ Device

JY5101Device JY5101.JY5101DOTask.Device
get

Device.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101DOTask.cs


5101 C# Programming Manual: JY5101.DOChannel Class Reference

  • DOChannel
Properties | List of all members
JY5101.DOChannel Class Referencesealed

DO Channel parameter class . More...

Properties

int LineNum [get, set]
Line number.

Detailed Description

DO Channel parameter class .

Property Documentation

◆ LineNum

int JY5101.DOChannel.LineNum
getset

Line number.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/5101/C#/JY5101DOTask.cs


5101 C# Programming Manual: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
N JY5101 |
C JY5101AITask | JY5101 Analog Input Task
C AIChannel | AI Channel parameter class
C AIAnalogHysteresisComparator | AI Analog Hysteresis Comparatorr
C AIAnalogWindowComparator | AI Analog Window Comparatorr
C AIAnalogEdgeComparator | AI Analog Edge Comparator
C AISampleClock | Sample clock configuration class
C AIExternalSampleClock | External Sample Clock Configuration Class
C AITrigger | AI Trigger class
C AIDigitalTrigger | AI Digital Trigger
C AIAnalogTrigger | AI Analog Trigger
C AIAnalogMultichannelComparator | AI Analog Multichannel Trigger/Comparator
C AIAnalogMultichannelHysteresisComparator | AI Analog Multichannel Hysteresis Comparator
C AIAnalogMultichannelHysteresisComparatorSource | AI Analog Multichannel Hysteresis Comparator Source
C AIAnalogMultichannelWindowComparator | AI Analog Multichannel Window Comparator
C AIAnalogMultichannelWindowComparatorSource | AI Analog Multichannel Window Comparator Source
C AIAnalogMultichannelEdgeComparator | AI Analog Multichannel Edge Comparator
C AIAnalogMultichannelEdgeComparatorSource | AI Analog Multichannel Edge Comparator Source
C AIRecord | AI Record class
C AIAdvanced | AI Advance parameter
C DSMode | DS Mode Class Paraments
C AISync | Configure sync signal
C AISignalExport | AI Signal Export Class
C JY5101AOTask | JY5101 Analog Ouput Task
C AOChannel | AO Channel parameter class
C AOSampleClock | AO Sample clock configuration class
C AOExternalSampleClock | External Sample Clock Configuration Class
C AOTrigger | Constructor to create an AOTrigger task object
C AODigitalTrigger | AO Digital trigger
C AOSignalExport | AO Signal Export Class
C JY5101CITask | JY5101 Counter Input Task
C CISampleClock | CI Sample Clock class
C CIInternalSampleClock | CI Internal Sample Clock Configuration Class
C CIImplicitSampleClock | CI Implicit Sample Clock class
C CIExternalSampleClock | CI Implicit Sample Clock class
C CIExternalTimebase |
C CITimebase |
C EdgeCounting | Configure CI EdgeCounting
C EdgeCountingOutEvent | Edge counting output event configuration class
C PauseTrigger | Pause trigger configuration class
C FrequencyMeas | Configure CI Measure
C PeriodMeas | Configure CI Measure
C PulseMeas | Configure CI Measure
C SemiPeriodMeas | Configure CI Measure
C TwoEdgeSeparation | Configure CI Measure
C QuadEncoder | Configure CI Measure
C TwoPulseEncoder | Configure CI Measure
C CITrigger | Constructor to create an CITrigger task object
C CIDigitalTrigger | CI Digital trigger
C CISignalExport | CI Signal Export Class
C JY5101COTask | JY5101 Counter Output Task
C COTrigger | Constructor to create an COTrigger task object
C CODigitalTrigger | CO Digital trigger
C COPulse | Pulse Parameter
C COExternalTimebase |
C COTimebase |
C COSignalExport | CO Signal Export Class
C JY5101DITask | JY5101 Digital Iuput Task
C DIChannel | DI Channel parameter class
C JY5101DOTask | JY5101 Digital Output Task
C DOChannel | DO Channel parameter class


5101 C# Programming Manual: Member List

  • AIAdvanced
JY5101.AIAdvanced Member List

This is the complete list of members for JY5101.AIAdvanced, including all inherited members.

ConvertRate | JY5101.AIAdvanced
DSMode | JY5101.AIAdvanced


5101 C# Programming Manual: Member List

  • AIAnalogEdgeComparator
JY5101.AIAnalogEdgeComparator Member List

This is the complete list of members for JY5101.AIAnalogEdgeComparator, including all inherited members.

Slope | JY5101.AIAnalogEdgeComparator
Threshold | JY5101.AIAnalogEdgeComparator


5101 C# Programming Manual: Member List

  • AIAnalogHysteresisComparator
JY5101.AIAnalogHysteresisComparator Member List

This is the complete list of members for JY5101.AIAnalogHysteresisComparator, including all inherited members.

HighThreshold | JY5101.AIAnalogHysteresisComparator
LowThreshold | JY5101.AIAnalogHysteresisComparator
Slope | JY5101.AIAnalogHysteresisComparator


5101 C# Programming Manual: Member List

  • AIAnalogMultichannelComparator
JY5101.AIAnalogMultichannelComparator Member List

This is the complete list of members for JY5101.AIAnalogMultichannelComparator, including all inherited members.

AIAnalogMultichannelComparator() | JY5101.AIAnalogMultichannelComparator
Comparator | JY5101.AIAnalogMultichannelComparator
Edge | JY5101.AIAnalogMultichannelComparator
Hysteresis | JY5101.AIAnalogMultichannelComparator
Logic | JY5101.AIAnalogMultichannelComparator
Window | JY5101.AIAnalogMultichannelComparator


5101 C# Programming Manual: Member List

  • AIAnalogMultichannelEdgeComparator
JY5101.AIAnalogMultichannelEdgeComparator Member List

This is the complete list of members for JY5101.AIAnalogMultichannelEdgeComparator, including all inherited members.

Add(AIAnalogTriggerSource source, AIAnalogTriggerEdge slope, double threshold) | JY5101.AIAnalogMultichannelEdgeComparator
AIAnalogMultichannelEdgeComparator() | JY5101.AIAnalogMultichannelEdgeComparator
Clear() | JY5101.AIAnalogMultichannelEdgeComparator
Sources | JY5101.AIAnalogMultichannelEdgeComparator


5101 C# Programming Manual: Member List

  • AIAnalogMultichannelEdgeComparatorSource
JY5101.AIAnalogMultichannelEdgeComparatorSource Member List

This is the complete list of members for JY5101.AIAnalogMultichannelEdgeComparatorSource, including all inherited members.

AIAnalogMultichannelEdgeComparatorSource() | JY5101.AIAnalogMultichannelEdgeComparatorSource
AIAnalogMultichannelEdgeComparatorSource(AIAnalogTriggerSource source, AIAnalogTriggerEdge slope, double threshold) | JY5101.AIAnalogMultichannelEdgeComparatorSource
Slope | JY5101.AIAnalogMultichannelEdgeComparatorSource
Source | JY5101.AIAnalogMultichannelEdgeComparatorSource
Threshold | JY5101.AIAnalogMultichannelEdgeComparatorSource


5101 C# Programming Manual: Member List

  • AIAnalogMultichannelHysteresisComparator
JY5101.AIAnalogMultichannelHysteresisComparator Member List

This is the complete list of members for JY5101.AIAnalogMultichannelHysteresisComparator, including all inherited members.

Add(AIAnalogTriggerSource source, AIAnalogTriggerEdge slope, double highThreshold, double lowThreshold) | JY5101.AIAnalogMultichannelHysteresisComparator
AIAnalogMultichannelHysteresisComparator() | JY5101.AIAnalogMultichannelHysteresisComparator
Clear() | JY5101.AIAnalogMultichannelHysteresisComparator
Sources | JY5101.AIAnalogMultichannelHysteresisComparator


5101 C# Programming Manual: Member List

  • JY5101
  • AIAnalogMultichannelHysteresisComparatorSource
JY5101.AIAnalogMultichannelHysteresisComparatorSource Member List

This is the complete list of members for JY5101.AIAnalogMultichannelHysteresisComparatorSource, including all inherited members.

AIAnalogMultichannelHysteresisComparatorSource() | JY5101.AIAnalogMultichannelHysteresisComparatorSource
AIAnalogMultichannelHysteresisComparatorSource(AIAnalogTriggerSource source, AIAnalogTriggerEdge slope, double highThreshold, double lowThreshold) | JY5101.AIAnalogMultichannelHysteresisComparatorSource
HighThreshold | JY5101.AIAnalogMultichannelHysteresisComparatorSource
LowThreshold | JY5101.AIAnalogMultichannelHysteresisComparatorSource
Slope | JY5101.AIAnalogMultichannelHysteresisComparatorSource
Source | JY5101.AIAnalogMultichannelHysteresisComparatorSource


5101 C# Programming Manual: Member List

  • AIAnalogMultichannelWindowComparator
JY5101.AIAnalogMultichannelWindowComparator Member List

This is the complete list of members for JY5101.AIAnalogMultichannelWindowComparator, including all inherited members.

Add(AIAnalogTriggerSource source, AIAnalogWindowCondition condition, double highThreshold, double lowThreshold) | JY5101.AIAnalogMultichannelWindowComparator
AIAnalogMultichannelWindowComparator() | JY5101.AIAnalogMultichannelWindowComparator
Clear() | JY5101.AIAnalogMultichannelWindowComparator
Sources | JY5101.AIAnalogMultichannelWindowComparator


5101 C# Programming Manual: Member List

  • JY5101
  • AIAnalogMultichannelWindowComparatorSource
JY5101.AIAnalogMultichannelWindowComparatorSource Member List

This is the complete list of members for JY5101.AIAnalogMultichannelWindowComparatorSource, including all inherited members.

AIAnalogMultichannelWindowComparatorSource() | JY5101.AIAnalogMultichannelWindowComparatorSource
AIAnalogMultichannelWindowComparatorSource(AIAnalogTriggerSource source, AIAnalogWindowCondition condition, double highThreshold, double lowThreshold) | JY5101.AIAnalogMultichannelWindowComparatorSource
Condition | JY5101.AIAnalogMultichannelWindowComparatorSource
HighThreshold | JY5101.AIAnalogMultichannelWindowComparatorSource
LowThreshold | JY5101.AIAnalogMultichannelWindowComparatorSource
Source | JY5101.AIAnalogMultichannelWindowComparatorSource


5101 C# Programming Manual: Member List

  • AIAnalogTrigger
JY5101.AIAnalogTrigger Member List

This is the complete list of members for JY5101.AIAnalogTrigger, including all inherited members.

AIAnalogTrigger() | JY5101.AIAnalogTrigger
Comparator | JY5101.AIAnalogTrigger
Edge | JY5101.AIAnalogTrigger
Hysteresis | JY5101.AIAnalogTrigger
Source | JY5101.AIAnalogTrigger
Window | JY5101.AIAnalogTrigger


5101 C# Programming Manual: Member List

  • AIAnalogWindowComparator
JY5101.AIAnalogWindowComparator Member List

This is the complete list of members for JY5101.AIAnalogWindowComparator, including all inherited members.

Condition | JY5101.AIAnalogWindowComparator
HighThreshold | JY5101.AIAnalogWindowComparator
LowThreshold | JY5101.AIAnalogWindowComparator


5101 C# Programming Manual: Member List

  • AIChannel
JY5101.AIChannel Member List

This is the complete list of members for JY5101.AIChannel, including all inherited members.

AIChannel(int channelId, double rangeLow, double rangeHigh, AITerminal terminalCfg, AIBandWidth bandWidth) | JY5101.AIChannel
BandWidth | JY5101.AIChannel
ChannelID | JY5101.AIChannel
RangeHigh | JY5101.AIChannel
RangeLow | JY5101.AIChannel
Terminal | JY5101.AIChannel


5101 C# Programming Manual: Member List

  • AIDigitalTrigger
JY5101.AIDigitalTrigger Member List

This is the complete list of members for JY5101.AIDigitalTrigger, including all inherited members.

Edge | JY5101.AIDigitalTrigger
Source | JY5101.AIDigitalTrigger


5101 C# Programming Manual: Member List

  • AIExternalSampleClock
JY5101.AIExternalSampleClock Member List

This is the complete list of members for JY5101.AIExternalSampleClock, including all inherited members.

ExpectedRate | JY5101.AIExternalSampleClock
Terminal | JY5101.AIExternalSampleClock


5101 C# Programming Manual: Member List

  • AIRecord
JY5101.AIRecord Member List

This is the complete list of members for JY5101.AIRecord, including all inherited members.

FileFormat | JY5101.AIRecord
FilePath | JY5101.AIRecord
Length | JY5101.AIRecord
Mode | JY5101.AIRecord


5101 C# Programming Manual: Member List

  • AISampleClock
JY5101.AISampleClock Member List

This is the complete list of members for JY5101.AISampleClock, including all inherited members.

External | JY5101.AISampleClock
Source | JY5101.AISampleClock


5101 C# Programming Manual: Member List

  • AISignalExport
JY5101.AISignalExport Member List

This is the complete list of members for JY5101.AISignalExport, including all inherited members.

Add(AISignalExportSource source, SignalExportDestination destination) | JY5101.AISignalExport
Add(AISignalExportSource source, List< SignalExportDestination > destinations) | JY5101.AISignalExport
Clear(SignalExportDestination destination) | JY5101.AISignalExport
ClearAll() | JY5101.AISignalExport


5101 C# Programming Manual: Member List

  • AISync
JY5101.AISync Member List

This is the complete list of members for JY5101.AISync, including all inherited members.

PulseRouting | JY5101.AISync
Topology | JY5101.AISync
TriggerRouting | JY5101.AISync


5101 C# Programming Manual: Member List

  • AITrigger
JY5101.AITrigger Member List

This is the complete list of members for JY5101.AITrigger, including all inherited members.

Analog | JY5101.AITrigger
Digital | JY5101.AITrigger
Mode | JY5101.AITrigger
Multichannel | JY5101.AITrigger
PreTriggerSamples | JY5101.AITrigger
ReTriggerCount | JY5101.AITrigger
Type | JY5101.AITrigger


5101 C# Programming Manual: Member List

  • AOChannel
JY5101.AOChannel Member List

This is the complete list of members for JY5101.AOChannel, including all inherited members.

ChannelID | JY5101.AOChannel
RangeHigh | JY5101.AOChannel
RangeLow | JY5101.AOChannel


5101 C# Programming Manual: Member List

  • AODigitalTrigger
JY5101.AODigitalTrigger Member List

This is the complete list of members for JY5101.AODigitalTrigger, including all inherited members.

Edge | JY5101.AODigitalTrigger
Source | JY5101.AODigitalTrigger


5101 C# Programming Manual: Member List

  • AOExternalSampleClock
JY5101.AOExternalSampleClock Member List

This is the complete list of members for JY5101.AOExternalSampleClock, including all inherited members.

ExpectedRate | JY5101.AOExternalSampleClock
Terminal | JY5101.AOExternalSampleClock


5101 C# Programming Manual: Member List

  • AOSampleClock
JY5101.AOSampleClock Member List

This is the complete list of members for JY5101.AOSampleClock, including all inherited members.

External | JY5101.AOSampleClock
Source | JY5101.AOSampleClock


5101 C# Programming Manual: Member List

  • AOSignalExport
JY5101.AOSignalExport Member List

This is the complete list of members for JY5101.AOSignalExport, including all inherited members.

Add(AOSignalExportSource source, SignalExportDestination destination) | JY5101.AOSignalExport
Add(AOSignalExportSource source, List< SignalExportDestination > destinations) | JY5101.AOSignalExport
Clear(SignalExportDestination destination) | JY5101.AOSignalExport
ClearAll() | JY5101.AOSignalExport


5101 C# Programming Manual: Member List

  • AOTrigger
JY5101.AOTrigger Member List

This is the complete list of members for JY5101.AOTrigger, including all inherited members.

Digital | JY5101.AOTrigger
Type | JY5101.AOTrigger


5101 C# Programming Manual: Member List

  • CIDigitalTrigger
JY5101.CIDigitalTrigger Member List

This is the complete list of members for JY5101.CIDigitalTrigger, including all inherited members.

Edge | JY5101.CIDigitalTrigger
Source | JY5101.CIDigitalTrigger


5101 C# Programming Manual: Member List

  • CIExternalSampleClock
JY5101.CIExternalSampleClock Member List

This is the complete list of members for JY5101.CIExternalSampleClock, including all inherited members.

ExpectedRate | JY5101.CIExternalSampleClock
IgnoreFirstSampleClock | JY5101.CIExternalSampleClock
Terminal | JY5101.CIExternalSampleClock


5101 C# Programming Manual: Member List

  • CIExternalTimebase
JY5101.CIExternalTimebase Member List

This is the complete list of members for JY5101.CIExternalTimebase, including all inherited members.

Frequency | JY5101.CIExternalTimebase
Terminal | JY5101.CIExternalTimebase


5101 C# Programming Manual: Member List

  • CIImplicitSampleClock
JY5101.CIImplicitSampleClock Member List

This is the complete list of members for JY5101.CIImplicitSampleClock, including all inherited members.

ExpectedRate JY5101.CIImplicitSampleClock


5101 C# Programming Manual: Member List

  • CIInternalSampleClock
JY5101.CIInternalSampleClock Member List

This is the complete list of members for JY5101.CIInternalSampleClock, including all inherited members.

IgnoreFirstSampleClock | JY5101.CIInternalSampleClock
Rate | JY5101.CIInternalSampleClock


5101 C# Programming Manual: Member List

  • CISampleClock
JY5101.CISampleClock Member List

This is the complete list of members for JY5101.CISampleClock, including all inherited members.

External | JY5101.CISampleClock
Implicit | JY5101.CISampleClock
Internal | JY5101.CISampleClock
Source | JY5101.CISampleClock


5101 C# Programming Manual: Member List

  • CISignalExport
JY5101.CISignalExport Member List

This is the complete list of members for JY5101.CISignalExport, including all inherited members.

Add(CISignalExportSource source, SignalExportDestination destination) | JY5101.CISignalExport
Add(CISignalExportSource source, List< SignalExportDestination > destinations) | JY5101.CISignalExport
Clear(SignalExportDestination destination) | JY5101.CISignalExport
ClearAll() | JY5101.CISignalExport


5101 C# Programming Manual: Member List

  • CITimebase
JY5101.CITimebase Member List

This is the complete list of members for JY5101.CITimebase, including all inherited members.

External | JY5101.CITimebase
Source | JY5101.CITimebase


5101 C# Programming Manual: Member List

  • CITrigger
JY5101.CITrigger Member List

This is the complete list of members for JY5101.CITrigger, including all inherited members.

Digital | JY5101.CITrigger
Type | JY5101.CITrigger


5101 C# Programming Manual: Member List

  • CODigitalTrigger
JY5101.CODigitalTrigger Member List

This is the complete list of members for JY5101.CODigitalTrigger, including all inherited members.

Edge | JY5101.CODigitalTrigger
Source | JY5101.CODigitalTrigger


5101 C# Programming Manual: Member List

  • COExternalTimebase
JY5101.COExternalTimebase Member List

This is the complete list of members for JY5101.COExternalTimebase, including all inherited members.

Frequency | JY5101.COExternalTimebase
Terminal | JY5101.COExternalTimebase


5101 C# Programming Manual: Member List

  • COPulse
JY5101.COPulse Member List

This is the complete list of members for JY5101.COPulse, including all inherited members.

COPulse(COPulseType type, double param1, double param2, int count) JY5101.COPulse


5101 C# Programming Manual: Member List

  • COSignalExport
JY5101.COSignalExport Member List

This is the complete list of members for JY5101.COSignalExport, including all inherited members.

Add(COSignalExportSource source, SignalExportDestination destination) | JY5101.COSignalExport
Add(COSignalExportSource source, List< SignalExportDestination > destinations) | JY5101.COSignalExport
Clear(SignalExportDestination destination) | JY5101.COSignalExport
ClearAll() | JY5101.COSignalExport


5101 C# Programming Manual: Member List

  • COTimebase
JY5101.COTimebase Member List

This is the complete list of members for JY5101.COTimebase, including all inherited members.

External | JY5101.COTimebase
Source | JY5101.COTimebase


5101 C# Programming Manual: Member List

  • COTrigger
JY5101.COTrigger Member List

This is the complete list of members for JY5101.COTrigger, including all inherited members.

Digital | JY5101.COTrigger
Type | JY5101.COTrigger


5101 C# Programming Manual: Member List

  • DIChannel
JY5101.DIChannel Member List

This is the complete list of members for JY5101.DIChannel, including all inherited members.

EnableFilter | JY5101.DIChannel
LineNum | JY5101.DIChannel
MinPulseWidth | JY5101.DIChannel


5101 C# Programming Manual: Member List

  • DOChannel
JY5101.DOChannel Member List

This is the complete list of members for JY5101.DOChannel, including all inherited members.

LineNum JY5101.DOChannel


5101 C# Programming Manual: Member List

  • DSMode
JY5101.DSMode Member List

This is the complete list of members for JY5101.DSMode, including all inherited members.

Enable JY5101.DSMode


5101 C# Programming Manual: Member List

  • EdgeCounting
JY5101.EdgeCounting Member List

This is the complete list of members for JY5101.EdgeCounting, including all inherited members.

ActiveEdge | JY5101.EdgeCounting
Direction | JY5101.EdgeCounting
DirectionSignalReversed | JY5101.EdgeCounting
DirTerminal | JY5101.EdgeCounting
InitialCount | JY5101.EdgeCounting
InputSignalReversed | JY5101.EdgeCounting
InputTerminal | JY5101.EdgeCounting
OutEvent | JY5101.EdgeCounting
Pause | JY5101.EdgeCounting


5101 C# Programming Manual: Member List

  • EdgeCountingOutEvent
JY5101.EdgeCountingOutEvent Member List

This is the complete list of members for JY5101.EdgeCountingOutEvent, including all inherited members.

IdleState | JY5101.EdgeCountingOutEvent
Reset | JY5101.EdgeCountingOutEvent
Terminal | JY5101.EdgeCountingOutEvent
Threshold | JY5101.EdgeCountingOutEvent


5101 C# Programming Manual: Member List

  • FrequencyMeas
JY5101.FrequencyMeas Member List

This is the complete list of members for JY5101.FrequencyMeas, including all inherited members.

InputTerminal | JY5101.FrequencyMeas
Timebase | JY5101.FrequencyMeas


5101 C# Programming Manual: Member List

  • JY5101AITask
JY5101.JY5101AITask Member List

This is the complete list of members for JY5101.JY5101AITask, including all inherited members.

AddChannel(int chnId, double rangeLow=-10, double rangeHigh=10, AITerminal terminalCfg=AITerminal.RSE, AIBandWidth bandWidth=AIBandWidth.Wide) | JY5101.JY5101AITask
AddChannel(int[] chnsId, double rangeLow=-10, double rangeHigh=10, AITerminal terminalCfg=AITerminal.RSE, AIBandWidth bandWidth=AIBandWidth.Wide) | JY5101.JY5101AITask
AddChannel(int[] chnsId, double[] rangeLow, double[] rangeHigh, AITerminal terminalCfg, AIBandWidth bandWidth) | JY5101.JY5101AITask
Advanced | JY5101.JY5101AITask
AvailableSamples | JY5101.JY5101AITask
BufLenInSamples | JY5101.JY5101AITask
Channels | JY5101.JY5101AITask
Device | JY5101.JY5101AITask
GetRecordPreviewData(ref double[,] buf, int samplesPerChannel, int timeout=1000) | JY5101.JY5101AITask
GetRecordPreviewData(ref double[,] buf, int timeout=1000) | JY5101.JY5101AITask
GetRecordPreviewData(ref double[] buf, int samplesPerChannel, int timeout=1000) | JY5101.JY5101AITask
GetRecordPreviewData(ref double[] buf, int timeout=1000) | JY5101.JY5101AITask
GetRecordStatus(out double recordedLength, out bool recordDone) | JY5101.JY5101AITask
JY5101AITask(int slotNumber) | JY5101.JY5101AITask
JY5101AITask(string boardName) | JY5101.JY5101AITask
Mode | JY5101.JY5101AITask
ReadData(IntPtr buf, int samplesPerChannel, int timeout=10000) | JY5101.JY5101AITask
ReadData(ref double[,] buf, int samplesPerChannel, int timeout=10000) | JY5101.JY5101AITask
ReadData(ref double[,] buf, int timeout=10000) | JY5101.JY5101AITask
ReadData(ref double[] buf, int samplesPerChannel, int timeout=10000) | JY5101.JY5101AITask
ReadData(ref double[] buf, int timeout=10000) | JY5101.JY5101AITask
ReadRawData(IntPtr buf, int samplesPerChannel, int timeout=10000) | JY5101.JY5101AITask
ReadRawData(ref short[,] buf, int samplesPerChannel, int timeout=10000) | JY5101.JY5101AITask
ReadRawData(ref short[,] buf, int timeout=10000) | JY5101.JY5101AITask
ReadRawData(ref short[] buf, int samplesPerChannel, int timeout=10000) | JY5101.JY5101AITask
ReadRawData(ref short[] buf, int timeout=10000) | JY5101.JY5101AITask
ReadRawSinglePoint(ref short readValue, int channel) | JY5101.JY5101AITask
ReadRawSinglePoint(ref short[] readValues) | JY5101.JY5101AITask
ReadSinglePoint(ref double readValue, int channel) | JY5101.JY5101AITask
ReadSinglePoint(ref double[] readValues) | JY5101.JY5101AITask
Record | JY5101.JY5101AITask
RemoveChannel(int chnId) | JY5101.JY5101AITask
SampleClock | JY5101.JY5101AITask
SampleRate | JY5101.JY5101AITask
SamplesToAcquire | JY5101.JY5101AITask
SendSoftwareTrigger() | JY5101.JY5101AITask
SignalExport | JY5101.JY5101AITask
Start() | JY5101.JY5101AITask
Stop() | JY5101.JY5101AITask
TransferedSamples | JY5101.JY5101AITask
Trigger | JY5101.JY5101AITask
WaitUntilDone(int timeout=-1) | JY5101.JY5101AITask


5101 C# Programming Manual: Member List

  • JY5101AOTask
JY5101.JY5101AOTask Member List

This is the complete list of members for JY5101.JY5101AOTask, including all inherited members.

AddChannel(int chnId, double rangeLow=-10, double rangeHigh=10) | JY5101.JY5101AOTask
AddChannel(int[] chnsId, double rangeLow=-10, double rangeHigh=10) | JY5101.JY5101AOTask
AddChannel(int[] chnsId, double[] rangeLow, double[] rangeHigh) | JY5101.JY5101AOTask
AvaliableLenInSamples | JY5101.JY5101AOTask
BufLenInSamples | JY5101.JY5101AOTask
Channels | JY5101.JY5101AOTask
CompleteState | JY5101.JY5101AOTask
Device | JY5101.JY5101AOTask
JY5101AOTask(int slotNum) | JY5101.JY5101AOTask
JY5101AOTask(string boardName) | JY5101.JY5101AOTask
Mode | JY5101.JY5101AOTask
RemoveChannel(int chnId) | JY5101.JY5101AOTask
SampleClock | JY5101.JY5101AOTask
SamplesToUpdate | JY5101.JY5101AOTask
SendSoftwareTrigger() | JY5101.JY5101AOTask
SignalExport | JY5101.JY5101AOTask
Start() | JY5101.JY5101AOTask
Stop() | JY5101.JY5101AOTask
TransferedSamples | JY5101.JY5101AOTask
Trigger | JY5101.JY5101AOTask
UpdateRate | JY5101.JY5101AOTask
WaitUntilDone(int timeout=-1) | JY5101.JY5101AOTask
WriteData(IntPtr buf, int samplesPerChannel, int timeout=10000) | JY5101.JY5101AOTask
WriteData(double[,] buf, int timeout=10000) | JY5101.JY5101AOTask
WriteData(double[] buf, int timeout=10000) | JY5101.JY5101AOTask
WriteRawData(IntPtr buf, int samplesPerChannel, int timeout=10000) | JY5101.JY5101AOTask
WriteRawData(short[,] buf, int timeout=10000) | JY5101.JY5101AOTask
WriteRawData(short[] buf, int timeout=10000) | JY5101.JY5101AOTask
WriteRawSinglePoint(short[] writeValues) | JY5101.JY5101AOTask
WriteRawSinglePoint(short writeValue, int channel) | JY5101.JY5101AOTask
WriteSinglePoint(double[] writeValues) | JY5101.JY5101AOTask
WriteSinglePoint(double writeValue, int channel) | JY5101.JY5101AOTask


5101 C# Programming Manual: Member List

  • JY5101CITask
JY5101.JY5101CITask Member List

This is the complete list of members for JY5101.JY5101CITask, including all inherited members.

AvailableSamples | JY5101.JY5101CITask
Device | JY5101.JY5101CITask
EdgeCounting | JY5101.JY5101CITask
FrequencyMeas | JY5101.JY5101CITask
JY5101CITask(int slotNum, int channel) | JY5101.JY5101CITask
JY5101CITask(string boardName, int channel) | JY5101.JY5101CITask
Mode | JY5101.JY5101CITask
PeriodMeas | JY5101.JY5101CITask
PulseMeas | JY5101.JY5101CITask
QuadEncoder | JY5101.JY5101CITask
ReadData(ref uint[] bufCount, int samplesToAcquire, int timeout=10000) | JY5101.JY5101CITask
ReadData(ref int[] bufCount, int samplesToAcquire, int timeout=10000) | JY5101.JY5101CITask
ReadData(ref uint[] bufCount, int timeout=10000) | JY5101.JY5101CITask
ReadData(ref int[] bufCount, int timeout=10000) | JY5101.JY5101CITask
ReadData(ref double[] bufMeasurement, int samplesToAcquire, int timeout=10000) | JY5101.JY5101CITask
ReadData(ref double[] bufMeasurement, int timeout=10000) | JY5101.JY5101CITask
ReadData(ref double[] bufMeasurement1, ref double[] bufMeasurement2, int samplesToAcquire, int timeout=10000) | JY5101.JY5101CITask
ReadData(ref double[] bufMeasurement1, ref double[] bufMeasurement2, int timeout=10000) | JY5101.JY5101CITask
ReadSinglePoint(ref uint count) | JY5101.JY5101CITask
ReadSinglePoint(ref int count) | JY5101.JY5101CITask
ReadSinglePoint(ref double measurement, int timeout=10000) | JY5101.JY5101CITask
ReadSinglePoint(ref double measurement1, ref double measurement2, int timeout=10000) | JY5101.JY5101CITask
SampleClock | JY5101.JY5101CITask
SamplesToAcquire | JY5101.JY5101CITask
SemiPeriodMeas | JY5101.JY5101CITask
SendSoftwareTrigger() | JY5101.JY5101CITask
SignalExport | JY5101.JY5101CITask
Start() | JY5101.JY5101CITask
Stop() | JY5101.JY5101CITask
TransferedSamples | JY5101.JY5101CITask
Trigger | JY5101.JY5101CITask
TwoEdgeSeparation | JY5101.JY5101CITask
TwoPulseEncoder | JY5101.JY5101CITask
Type | JY5101.JY5101CITask


5101 C# Programming Manual: Member List

  • JY5101COTask
JY5101.JY5101COTask Member List

This is the complete list of members for JY5101.JY5101COTask, including all inherited members.

Device | JY5101.JY5101COTask
IdleState | JY5101.JY5101COTask
InitialDelay | JY5101.JY5101COTask
JY5101COTask(int slotNum, int channel) | JY5101.JY5101COTask
JY5101COTask(string boardName, int channel) | JY5101.JY5101COTask
OutputTerminal | JY5101.JY5101COTask
Pause | JY5101.JY5101COTask
SendSoftwareTrigger() | JY5101.JY5101COTask
SignalExport | JY5101.JY5101COTask
Start() | JY5101.JY5101COTask
Stop() | JY5101.JY5101COTask
Timebase | JY5101.JY5101COTask
Trigger | JY5101.JY5101COTask
WaitUntilDone(int timeout=-1) | JY5101.JY5101COTask
WriteSinglePoint(COPulse pulse) | JY5101.JY5101COTask


5101 C# Programming Manual: Member List

  • JY5101DITask
JY5101.JY5101DITask Member List

This is the complete list of members for JY5101.JY5101DITask, including all inherited members.

AddChannel(int lineNum) | JY5101.JY5101DITask
AddChannel(int lineNum, bool enableFilter=false, int minPulseWidth=10) | JY5101.JY5101DITask
AddChannel(int[] linesNum) | JY5101.JY5101DITask
AddChannel(int[] linesNum, bool enableFilter=false, int minPulseWidth=10) | JY5101.JY5101DITask
AddChannel(int[] linesNum, bool[] enableFilter, int[] minPulseWidth) | JY5101.JY5101DITask
Channels | JY5101.JY5101DITask
Device | JY5101.JY5101DITask
JY5101DITask(int slotNum) | JY5101.JY5101DITask
JY5101DITask(string boardName) | JY5101.JY5101DITask
ReadSinglePoint(ref bool readValue, int lineID) | JY5101.JY5101DITask
ReadSinglePoint(ref bool[] readValues) | JY5101.JY5101DITask
RemoveChannel(int lineNum) | JY5101.JY5101DITask
Start() | JY5101.JY5101DITask
Stop() | JY5101.JY5101DITask


5101 C# Programming Manual: Member List

  • JY5101DOTask
JY5101.JY5101DOTask Member List

This is the complete list of members for JY5101.JY5101DOTask, including all inherited members.

AddChannel(int LineID) | JY5101.JY5101DOTask
AddChannel(int[] LineID) | JY5101.JY5101DOTask
Channels | JY5101.JY5101DOTask
Device | JY5101.JY5101DOTask
JY5101DOTask(int slotNum) | JY5101.JY5101DOTask
JY5101DOTask(string boardName) | JY5101.JY5101DOTask
ReadSinglePoint(ref bool readValue, int line) | JY5101.JY5101DOTask
ReadSinglePoint(ref bool[] readValues) | JY5101.JY5101DOTask
RemoveChannel(int LineID) | JY5101.JY5101DOTask
Start() | JY5101.JY5101DOTask
Stop() | JY5101.JY5101DOTask
WriteSinglePoint(bool writeValues, int line) | JY5101.JY5101DOTask
WriteSinglePoint(bool[] writeValues) | JY5101.JY5101DOTask


5101 C# Programming Manual: Member List

  • PauseTrigger
JY5101.PauseTrigger Member List

This is the complete list of members for JY5101.PauseTrigger, including all inherited members.

ActivePolarity | JY5101.PauseTrigger
OutputState | JY5101.PauseTrigger
SignalReversed | JY5101.PauseTrigger
Terminal | JY5101.PauseTrigger


5101 C# Programming Manual: Member List

  • PeriodMeas
JY5101.PeriodMeas Member List

This is the complete list of members for JY5101.PeriodMeas, including all inherited members.

InputTerminal | JY5101.PeriodMeas
Timebase | JY5101.PeriodMeas


5101 C# Programming Manual: Member List

  • PulseMeas
JY5101.PulseMeas Member List

This is the complete list of members for JY5101.PulseMeas, including all inherited members.

InputTerminal | JY5101.PulseMeas
SignalReversed | JY5101.PulseMeas
StartingEdge | JY5101.PulseMeas
Timebase | JY5101.PulseMeas


5101 C# Programming Manual: Member List

  • QuadEncoder
JY5101.QuadEncoder Member List

This is the complete list of members for JY5101.QuadEncoder, including all inherited members.

AInputTerminal | JY5101.QuadEncoder
ASignalReversed | JY5101.QuadEncoder
BInputTerminal | JY5101.QuadEncoder
BSignalReversed | JY5101.QuadEncoder
EncodingType | JY5101.QuadEncoder
InitialCount | JY5101.QuadEncoder
ZInputTerminal | JY5101.QuadEncoder
ZReloadEnabled | JY5101.QuadEncoder
ZSignalReversed | JY5101.QuadEncoder


5101 C# Programming Manual: Member List

  • SemiPeriodMeas
JY5101.SemiPeriodMeas Member List

This is the complete list of members for JY5101.SemiPeriodMeas, including all inherited members.

InputTerminal | JY5101.SemiPeriodMeas
SignalReversed | JY5101.SemiPeriodMeas
StartingEdge | JY5101.SemiPeriodMeas
Timebase | JY5101.SemiPeriodMeas


5101 C# Programming Manual: Member List

  • TwoEdgeSeparation
JY5101.TwoEdgeSeparation Member List

This is the complete list of members for JY5101.TwoEdgeSeparation, including all inherited members.

EdgeSeparationMode | JY5101.TwoEdgeSeparation
FirstInputTerminal | JY5101.TwoEdgeSeparation
FirstSignalReversed | JY5101.TwoEdgeSeparation
SecondInputTerminal | JY5101.TwoEdgeSeparation
SecondSignalReversed | JY5101.TwoEdgeSeparation
Timebase | JY5101.TwoEdgeSeparation


5101 C# Programming Manual: Member List

  • TwoPulseEncoder
JY5101.TwoPulseEncoder Member List

This is the complete list of members for JY5101.TwoPulseEncoder, including all inherited members.

AInputTerminal | JY5101.TwoPulseEncoder
ASignalReversed | JY5101.TwoPulseEncoder
BInputTerminal | JY5101.TwoPulseEncoder
BSignalReversed | JY5101.TwoPulseEncoder
InitialCount | JY5101.TwoPulseEncoder


5101 C# Programming Manual: Class Index

Class Index
A | C | D | E | F | J | P | Q | S | T
A
AIAdvanced (JY5101)
AIAnalogEdgeComparator (JY5101)
AIAnalogHysteresisComparator (JY5101)
AIAnalogMultichannelComparator (JY5101)
AIAnalogMultichannelEdgeComparator (JY5101)
AIAnalogMultichannelEdgeComparatorSource (JY5101)
AIAnalogMultichannelHysteresisComparator (JY5101)
AIAnalogMultichannelHysteresisComparatorSource (JY5101)
AIAnalogMultichannelWindowComparator (JY5101)
AIAnalogMultichannelWindowComparatorSource (JY5101)
AIAnalogTrigger (JY5101)
AIAnalogWindowComparator (JY5101)
AIChannel (JY5101)
AIDigitalTrigger (JY5101)
AIExternalSampleClock (JY5101)
AIRecord (JY5101)
AISampleClock (JY5101)
AISignalExport (JY5101)
AISync (JY5101)
AITrigger (JY5101)
AOChannel (JY5101)
AODigitalTrigger (JY5101)
AOExternalSampleClock (JY5101)
AOSampleClock (JY5101)
AOSignalExport (JY5101)
AOTrigger (JY5101)
C
CIDigitalTrigger (JY5101)
CIExternalSampleClock (JY5101)
CIExternalTimebase (JY5101)
CIImplicitSampleClock (JY5101)
CIInternalSampleClock (JY5101)
CISampleClock (JY5101)
CISignalExport (JY5101)
CITimebase (JY5101)
CITrigger (JY5101)
CODigitalTrigger (JY5101)
COExternalTimebase (JY5101)
COPulse (JY5101)
COSignalExport (JY5101)
COTimebase (JY5101)
COTrigger (JY5101)
D
DIChannel (JY5101)
DOChannel (JY5101)
DSMode (JY5101)
E
EdgeCounting (JY5101)
EdgeCountingOutEvent (JY5101)
F
FrequencyMeas (JY5101)
J
JY5101AITask (JY5101)
JY5101AOTask (JY5101)
JY5101CITask (JY5101)
JY5101COTask (JY5101)
JY5101DITask (JY5101)
JY5101DOTask (JY5101)
P
PauseTrigger (JY5101)
PeriodMeas (JY5101)
PulseMeas (JY5101)
Q
QuadEncoder (JY5101)
S
SemiPeriodMeas (JY5101)
T
TwoEdgeSeparation (JY5101)
TwoPulseEncoder (JY5101)


5101 C# Programming Manual: D:/OneDrive/Desktop/产品文档/CHM Directory Reference

  • File List
  • OneDrive
  • Desktop
  • 产品文档
  • CHM
CHM Directory Reference

Directories

         5101


5101 C# Programming Manual: D:/OneDrive/Desktop Directory Reference

  • File List
  • OneDrive
  • Desktop
Desktop Directory Reference

Directories

         产品文档


5101 C# Programming Manual: D:/OneDrive/Desktop/产品文档/CHM/5101 Directory Reference

  • File List
  • OneDrive
  • Desktop
  • 产品文档
  • CHM
  • 5101
5101 Directory Reference

Directories

         C#


5101 C# Programming Manual: D:/OneDrive/Desktop/产品文档 Directory Reference

  • File List
  • OneDrive
  • Desktop
  • 产品文档
产品文档 Directory Reference

Directories

         CHM


5101 C# Programming Manual: D:/OneDrive Directory Reference

  • File List
  • OneDrive
OneDrive Directory Reference

Directories

         Desktop


5101 C# Programming Manual: File List

  • File List
File List
Here is a list of all files with brief descriptions:
[detail level 1234567]
 OneDrive
Desktop
产品文档
CHM
5101
C#
JY5101AITask.cs
JY5101AOTask.cs
JY5101CITask.cs
JY5101COTask.cs
JY5101DITask.cs
JY5101DOTask.cs


5101 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- a -

  • ActiveEdge : JY5101.EdgeCounting
  • ActivePolarity : JY5101.PauseTrigger
  • Add() : JY5101.AIAnalogMultichannelEdgeComparator, JY5101.AIAnalogMultichannelHysteresisComparator, JY5101.AIAnalogMultichannelWindowComparator, JY5101.AISignalExport, JY5101.AOSignalExport, JY5101.CISignalExport, JY5101.COSignalExport
  • AddChannel() : JY5101.JY5101AITask, JY5101.JY5101AOTask, JY5101.JY5101DITask, JY5101.JY5101DOTask
  • Advanced : JY5101.JY5101AITask
  • AIAnalogMultichannelComparator() : JY5101.AIAnalogMultichannelComparator
  • AIAnalogMultichannelEdgeComparator() : JY5101.AIAnalogMultichannelEdgeComparator
  • AIAnalogMultichannelEdgeComparatorSource() : JY5101.AIAnalogMultichannelEdgeComparatorSource
  • AIAnalogMultichannelHysteresisComparator() : JY5101.AIAnalogMultichannelHysteresisComparator
  • AIAnalogMultichannelHysteresisComparatorSource() : JY5101.AIAnalogMultichannelHysteresisComparatorSource
  • AIAnalogMultichannelWindowComparator() : JY5101.AIAnalogMultichannelWindowComparator
  • AIAnalogMultichannelWindowComparatorSource() : JY5101.AIAnalogMultichannelWindowComparatorSource
  • AIAnalogTrigger() : JY5101.AIAnalogTrigger
  • AIChannel() : JY5101.AIChannel
  • AInputTerminal : JY5101.QuadEncoder, JY5101.TwoPulseEncoder
  • Analog : JY5101.AITrigger
  • ASignalReversed : JY5101.QuadEncoder, JY5101.TwoPulseEncoder
  • AvailableSamples : JY5101.JY5101AITask, JY5101.JY5101CITask
  • AvaliableLenInSamples : JY5101.JY5101AOTask


5101 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- b -

  • BandWidth : JY5101.AIChannel
  • BInputTerminal : JY5101.QuadEncoder, JY5101.TwoPulseEncoder
  • BSignalReversed : JY5101.QuadEncoder, JY5101.TwoPulseEncoder
  • BufLenInSamples : JY5101.JY5101AITask, JY5101.JY5101AOTask


5101 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- c -

  • ChannelID : JY5101.AIChannel, JY5101.AOChannel
  • Channels : JY5101.JY5101AITask, JY5101.JY5101AOTask, JY5101.JY5101DITask, JY5101.JY5101DOTask
  • Clear() : JY5101.AIAnalogMultichannelEdgeComparator, JY5101.AIAnalogMultichannelHysteresisComparator, JY5101.AIAnalogMultichannelWindowComparator, JY5101.AISignalExport, JY5101.AOSignalExport, JY5101.CISignalExport, JY5101.COSignalExport
  • ClearAll() : JY5101.AISignalExport, JY5101.AOSignalExport, JY5101.CISignalExport, JY5101.COSignalExport
  • Comparator : JY5101.AIAnalogMultichannelComparator, JY5101.AIAnalogTrigger
  • CompleteState : JY5101.JY5101AOTask
  • Condition : JY5101.AIAnalogMultichannelWindowComparatorSource, JY5101.AIAnalogWindowComparator
  • ConvertRate : JY5101.AIAdvanced
  • COPulse() : JY5101.COPulse


5101 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- d -

  • Device : JY5101.JY5101AITask, JY5101.JY5101AOTask, JY5101.JY5101CITask, JY5101.JY5101COTask, JY5101.JY5101DITask, JY5101.JY5101DOTask
  • Digital : JY5101.AITrigger, JY5101.AOTrigger, JY5101.CITrigger, JY5101.COTrigger
  • Direction : JY5101.EdgeCounting
  • DirectionSignalReversed : JY5101.EdgeCounting
  • DirTerminal : JY5101.EdgeCounting
  • DSMode : JY5101.AIAdvanced


5101 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- e -

  • Edge : JY5101.AIAnalogMultichannelComparator, JY5101.AIAnalogTrigger, JY5101.AIDigitalTrigger, JY5101.AODigitalTrigger, JY5101.CIDigitalTrigger, JY5101.CODigitalTrigger
  • EdgeCounting : JY5101.JY5101CITask
  • EdgeSeparationMode : JY5101.TwoEdgeSeparation
  • Enable : JY5101.DSMode
  • EnableFilter : JY5101.DIChannel
  • EncodingType : JY5101.QuadEncoder
  • ExpectedRate : JY5101.AIExternalSampleClock, JY5101.AOExternalSampleClock, JY5101.CIExternalSampleClock, JY5101.CIImplicitSampleClock
  • External : JY5101.AISampleClock, JY5101.AOSampleClock, JY5101.CISampleClock, JY5101.CITimebase, JY5101.COTimebase


5101 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- f -

  • FileFormat : JY5101.AIRecord
  • FilePath : JY5101.AIRecord
  • FirstInputTerminal : JY5101.TwoEdgeSeparation
  • FirstSignalReversed : JY5101.TwoEdgeSeparation
  • Frequency : JY5101.CIExternalTimebase, JY5101.COExternalTimebase
  • FrequencyMeas : JY5101.JY5101CITask


5101 C# Programming Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • Properties
  • a
  • c
  • g
  • j
  • r
  • s
  • w
Here is a list of all functions with links to the classes they belong to:

- a -

  • Add() : JY5101.AIAnalogMultichannelEdgeComparator, JY5101.AIAnalogMultichannelHysteresisComparator, JY5101.AIAnalogMultichannelWindowComparator, JY5101.AISignalExport, JY5101.AOSignalExport, JY5101.CISignalExport, JY5101.COSignalExport
  • AddChannel() : JY5101.JY5101AITask, JY5101.JY5101AOTask, JY5101.JY5101DITask, JY5101.JY5101DOTask
  • AIAnalogMultichannelComparator() : JY5101.AIAnalogMultichannelComparator
  • AIAnalogMultichannelEdgeComparator() : JY5101.AIAnalogMultichannelEdgeComparator
  • AIAnalogMultichannelEdgeComparatorSource() : JY5101.AIAnalogMultichannelEdgeComparatorSource
  • AIAnalogMultichannelHysteresisComparator() : JY5101.AIAnalogMultichannelHysteresisComparator
  • AIAnalogMultichannelHysteresisComparatorSource() : JY5101.AIAnalogMultichannelHysteresisComparatorSource
  • AIAnalogMultichannelWindowComparator() : JY5101.AIAnalogMultichannelWindowComparator
  • AIAnalogMultichannelWindowComparatorSource() : JY5101.AIAnalogMultichannelWindowComparatorSource
  • AIAnalogTrigger() : JY5101.AIAnalogTrigger
  • AIChannel() : JY5101.AIChannel

- c -

  • Clear() : JY5101.AIAnalogMultichannelEdgeComparator, JY5101.AIAnalogMultichannelHysteresisComparator, JY5101.AIAnalogMultichannelWindowComparator, JY5101.AISignalExport, JY5101.AOSignalExport, JY5101.CISignalExport, JY5101.COSignalExport
  • ClearAll() : JY5101.AISignalExport, JY5101.AOSignalExport, JY5101.CISignalExport, JY5101.COSignalExport
  • COPulse() : JY5101.COPulse

- g -

  • GetRecordPreviewData() : JY5101.JY5101AITask
  • GetRecordStatus() : JY5101.JY5101AITask

- j -

  • JY5101AITask() : JY5101.JY5101AITask
  • JY5101AOTask() : JY5101.JY5101AOTask
  • JY5101CITask() : JY5101.JY5101CITask
  • JY5101COTask() : JY5101.JY5101COTask
  • JY5101DITask() : JY5101.JY5101DITask
  • JY5101DOTask() : JY5101.JY5101DOTask

- r -

  • ReadData() : JY5101.JY5101AITask, JY5101.JY5101CITask
  • ReadRawData() : JY5101.JY5101AITask
  • ReadRawSinglePoint() : JY5101.JY5101AITask
  • ReadSinglePoint() : JY5101.JY5101AITask, JY5101.JY5101CITask, JY5101.JY5101DITask, JY5101.JY5101DOTask
  • RemoveChannel() : JY5101.JY5101AITask, JY5101.JY5101AOTask, JY5101.JY5101DITask, JY5101.JY5101DOTask

- s -

  • SendSoftwareTrigger() : JY5101.JY5101AITask, JY5101.JY5101AOTask, JY5101.JY5101CITask, JY5101.JY5101COTask
  • Start() : JY5101.JY5101AITask, JY5101.JY5101AOTask, JY5101.JY5101CITask, JY5101.JY5101COTask, JY5101.JY5101DITask, JY5101.JY5101DOTask
  • Stop() : JY5101.JY5101AITask, JY5101.JY5101AOTask, JY5101.JY5101CITask, JY5101.JY5101COTask, JY5101.JY5101DITask, JY5101.JY5101DOTask

- w -

  • WaitUntilDone() : JY5101.JY5101AITask, JY5101.JY5101AOTask, JY5101.JY5101COTask
  • WriteData() : JY5101.JY5101AOTask
  • WriteRawData() : JY5101.JY5101AOTask
  • WriteRawSinglePoint() : JY5101.JY5101AOTask
  • WriteSinglePoint() : JY5101.JY5101AOTask, JY5101.JY5101COTask, JY5101.JY5101DOTask


5101 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- g -

  • GetRecordPreviewData() : JY5101.JY5101AITask
  • GetRecordStatus() : JY5101.JY5101AITask


5101 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- h -

  • HighThreshold : JY5101.AIAnalogHysteresisComparator, JY5101.AIAnalogMultichannelHysteresisComparatorSource, JY5101.AIAnalogMultichannelWindowComparatorSource, JY5101.AIAnalogWindowComparator
  • Hysteresis : JY5101.AIAnalogMultichannelComparator, JY5101.AIAnalogTrigger


5101 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- i -

  • IdleState : JY5101.EdgeCountingOutEvent, JY5101.JY5101COTask
  • IgnoreFirstSampleClock : JY5101.CIExternalSampleClock, JY5101.CIInternalSampleClock
  • Implicit : JY5101.CISampleClock
  • InitialCount : JY5101.EdgeCounting, JY5101.QuadEncoder, JY5101.TwoPulseEncoder
  • InitialDelay : JY5101.JY5101COTask
  • InputSignalReversed : JY5101.EdgeCounting
  • InputTerminal : JY5101.EdgeCounting, JY5101.FrequencyMeas, JY5101.PeriodMeas, JY5101.PulseMeas, JY5101.SemiPeriodMeas
  • Internal : JY5101.CISampleClock


5101 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- j -

  • JY5101AITask() : JY5101.JY5101AITask
  • JY5101AOTask() : JY5101.JY5101AOTask
  • JY5101CITask() : JY5101.JY5101CITask
  • JY5101COTask() : JY5101.JY5101COTask
  • JY5101DITask() : JY5101.JY5101DITask
  • JY5101DOTask() : JY5101.JY5101DOTask


5101 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- l -

  • Length : JY5101.AIRecord
  • LineNum : JY5101.DIChannel, JY5101.DOChannel
  • Logic : JY5101.AIAnalogMultichannelComparator
  • LowThreshold : JY5101.AIAnalogHysteresisComparator, JY5101.AIAnalogMultichannelHysteresisComparatorSource, JY5101.AIAnalogMultichannelWindowComparatorSource, JY5101.AIAnalogWindowComparator


5101 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- m -

  • MinPulseWidth : JY5101.DIChannel
  • Mode : JY5101.AIRecord, JY5101.AITrigger, JY5101.JY5101AITask, JY5101.JY5101AOTask, JY5101.JY5101CITask
  • Multichannel : JY5101.AITrigger


5101 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- o -

  • OutEvent : JY5101.EdgeCounting
  • OutputState : JY5101.PauseTrigger
  • OutputTerminal : JY5101.JY5101COTask


5101 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- p -

  • Pause : JY5101.EdgeCounting, JY5101.JY5101COTask
  • PeriodMeas : JY5101.JY5101CITask
  • PreTriggerSamples : JY5101.AITrigger
  • PulseMeas : JY5101.JY5101CITask
  • PulseRouting : JY5101.AISync


5101 C# Programming Manual: Class Members - Properties

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all properties with links to the classes they belong to:

- a -

  • ActiveEdge : JY5101.EdgeCounting
  • ActivePolarity : JY5101.PauseTrigger
  • Advanced : JY5101.JY5101AITask
  • AInputTerminal : JY5101.QuadEncoder, JY5101.TwoPulseEncoder
  • Analog : JY5101.AITrigger
  • ASignalReversed : JY5101.QuadEncoder, JY5101.TwoPulseEncoder
  • AvailableSamples : JY5101.JY5101AITask, JY5101.JY5101CITask
  • AvaliableLenInSamples : JY5101.JY5101AOTask

- b -

  • BandWidth : JY5101.AIChannel
  • BInputTerminal : JY5101.QuadEncoder, JY5101.TwoPulseEncoder
  • BSignalReversed : JY5101.QuadEncoder, JY5101.TwoPulseEncoder
  • BufLenInSamples : JY5101.JY5101AITask, JY5101.JY5101AOTask

- c -

  • ChannelID : JY5101.AIChannel, JY5101.AOChannel
  • Channels : JY5101.JY5101AITask, JY5101.JY5101AOTask, JY5101.JY5101DITask, JY5101.JY5101DOTask
  • Comparator : JY5101.AIAnalogMultichannelComparator, JY5101.AIAnalogTrigger
  • CompleteState : JY5101.JY5101AOTask
  • Condition : JY5101.AIAnalogMultichannelWindowComparatorSource, JY5101.AIAnalogWindowComparator
  • ConvertRate : JY5101.AIAdvanced

- d -

  • Device : JY5101.JY5101AITask, JY5101.JY5101AOTask, JY5101.JY5101CITask, JY5101.JY5101COTask, JY5101.JY5101DITask, JY5101.JY5101DOTask
  • Digital : JY5101.AITrigger, JY5101.AOTrigger, JY5101.CITrigger, JY5101.COTrigger
  • Direction : JY5101.EdgeCounting
  • DirectionSignalReversed : JY5101.EdgeCounting
  • DirTerminal : JY5101.EdgeCounting
  • DSMode : JY5101.AIAdvanced

- e -

  • Edge : JY5101.AIAnalogMultichannelComparator, JY5101.AIAnalogTrigger, JY5101.AIDigitalTrigger, JY5101.AODigitalTrigger, JY5101.CIDigitalTrigger, JY5101.CODigitalTrigger
  • EdgeCounting : JY5101.JY5101CITask
  • EdgeSeparationMode : JY5101.TwoEdgeSeparation
  • Enable : JY5101.DSMode
  • EnableFilter : JY5101.DIChannel
  • EncodingType : JY5101.QuadEncoder
  • ExpectedRate : JY5101.AIExternalSampleClock, JY5101.AOExternalSampleClock, JY5101.CIExternalSampleClock, JY5101.CIImplicitSampleClock
  • External : JY5101.AISampleClock, JY5101.AOSampleClock, JY5101.CISampleClock, JY5101.CITimebase, JY5101.COTimebase

- f -

  • FileFormat : JY5101.AIRecord
  • FilePath : JY5101.AIRecord
  • FirstInputTerminal : JY5101.TwoEdgeSeparation
  • FirstSignalReversed : JY5101.TwoEdgeSeparation
  • Frequency : JY5101.CIExternalTimebase, JY5101.COExternalTimebase
  • FrequencyMeas : JY5101.JY5101CITask

- h -

  • HighThreshold : JY5101.AIAnalogMultichannelHysteresisComparatorSource, JY5101.AIAnalogMultichannelWindowComparatorSource
  • Hysteresis : JY5101.AIAnalogMultichannelComparator, JY5101.AIAnalogTrigger

- i -

  • IdleState : JY5101.EdgeCountingOutEvent, JY5101.JY5101COTask
  • IgnoreFirstSampleClock : JY5101.CIExternalSampleClock, JY5101.CIInternalSampleClock
  • Implicit : JY5101.CISampleClock
  • InitialCount : JY5101.EdgeCounting, JY5101.QuadEncoder, JY5101.TwoPulseEncoder
  • InitialDelay : JY5101.JY5101COTask
  • InputSignalReversed : JY5101.EdgeCounting
  • InputTerminal : JY5101.EdgeCounting, JY5101.FrequencyMeas, JY5101.PeriodMeas, JY5101.PulseMeas, JY5101.SemiPeriodMeas
  • Internal : JY5101.CISampleClock

- l -

  • Length : JY5101.AIRecord
  • LineNum : JY5101.DIChannel, JY5101.DOChannel
  • Logic : JY5101.AIAnalogMultichannelComparator
  • LowThreshold : JY5101.AIAnalogMultichannelHysteresisComparatorSource, JY5101.AIAnalogMultichannelWindowComparatorSource

- m -

  • MinPulseWidth : JY5101.DIChannel
  • Mode : JY5101.AIRecord, JY5101.AITrigger, JY5101.JY5101AITask, JY5101.JY5101AOTask, JY5101.JY5101CITask
  • Multichannel : JY5101.AITrigger

- o -

  • OutEvent : JY5101.EdgeCounting
  • OutputState : JY5101.PauseTrigger
  • OutputTerminal : JY5101.JY5101COTask

- p -

  • Pause : JY5101.EdgeCounting, JY5101.JY5101COTask
  • PeriodMeas : JY5101.JY5101CITask
  • PreTriggerSamples : JY5101.AITrigger
  • PulseMeas : JY5101.JY5101CITask
  • PulseRouting : JY5101.AISync

- q -

  • QuadEncoder : JY5101.JY5101CITask

- r -

  • RangeHigh : JY5101.AIChannel, JY5101.AOChannel
  • RangeLow : JY5101.AIChannel, JY5101.AOChannel
  • Rate : JY5101.CIInternalSampleClock
  • Record : JY5101.JY5101AITask
  • Reset : JY5101.EdgeCountingOutEvent
  • ReTriggerCount : JY5101.AITrigger

- s -

  • SampleClock : JY5101.JY5101AITask, JY5101.JY5101AOTask, JY5101.JY5101CITask
  • SampleRate : JY5101.JY5101AITask
  • SamplesToAcquire : JY5101.JY5101AITask, JY5101.JY5101CITask
  • SamplesToUpdate : JY5101.JY5101AOTask
  • SecondInputTerminal : JY5101.TwoEdgeSeparation
  • SecondSignalReversed : JY5101.TwoEdgeSeparation
  • SemiPeriodMeas : JY5101.JY5101CITask
  • SignalExport : JY5101.JY5101AITask, JY5101.JY5101AOTask, JY5101.JY5101CITask, JY5101.JY5101COTask
  • SignalReversed : JY5101.PauseTrigger, JY5101.PulseMeas, JY5101.SemiPeriodMeas
  • Slope : JY5101.AIAnalogEdgeComparator, JY5101.AIAnalogHysteresisComparator, JY5101.AIAnalogMultichannelEdgeComparatorSource, JY5101.AIAnalogMultichannelHysteresisComparatorSource
  • Source : JY5101.AIAnalogMultichannelEdgeComparatorSource, JY5101.AIAnalogMultichannelHysteresisComparatorSource, JY5101.AIAnalogMultichannelWindowComparatorSource, JY5101.AIAnalogTrigger, JY5101.AIDigitalTrigger, JY5101.AISampleClock, JY5101.AODigitalTrigger, JY5101.AOSampleClock, JY5101.CIDigitalTrigger, JY5101.CISampleClock, JY5101.CITimebase, JY5101.CODigitalTrigger, JY5101.COTimebase
  • Sources : JY5101.AIAnalogMultichannelEdgeComparator, JY5101.AIAnalogMultichannelHysteresisComparator, JY5101.AIAnalogMultichannelWindowComparator
  • StartingEdge : JY5101.PulseMeas, JY5101.SemiPeriodMeas

- t -

  • Terminal : JY5101.AIChannel, JY5101.AIExternalSampleClock, JY5101.AOExternalSampleClock, JY5101.CIExternalSampleClock, JY5101.CIExternalTimebase, JY5101.COExternalTimebase, JY5101.EdgeCountingOutEvent, JY5101.PauseTrigger
  • Threshold : JY5101.AIAnalogMultichannelEdgeComparatorSource, JY5101.EdgeCountingOutEvent
  • Timebase : JY5101.FrequencyMeas, JY5101.JY5101COTask, JY5101.PeriodMeas, JY5101.PulseMeas, JY5101.SemiPeriodMeas, JY5101.TwoEdgeSeparation
  • Topology : JY5101.AISync
  • TransferedSamples : JY5101.JY5101AITask, JY5101.JY5101AOTask, JY5101.JY5101CITask
  • Trigger : JY5101.JY5101AITask, JY5101.JY5101AOTask, JY5101.JY5101CITask, JY5101.JY5101COTask
  • TriggerRouting : JY5101.AISync
  • TwoEdgeSeparation : JY5101.JY5101CITask
  • TwoPulseEncoder : JY5101.JY5101CITask
  • Type : JY5101.AITrigger, JY5101.AOTrigger, JY5101.CITrigger, JY5101.COTrigger, JY5101.JY5101CITask

- u -

  • UpdateRate : JY5101.JY5101AOTask

- w -

  • Window : JY5101.AIAnalogMultichannelComparator, JY5101.AIAnalogTrigger

- z -

  • ZInputTerminal : JY5101.QuadEncoder
  • ZReloadEnabled : JY5101.QuadEncoder
  • ZSignalReversed : JY5101.QuadEncoder


5101 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- q -

  • QuadEncoder : JY5101.JY5101CITask


5101 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- r -

  • RangeHigh : JY5101.AIChannel, JY5101.AOChannel
  • RangeLow : JY5101.AIChannel, JY5101.AOChannel
  • Rate : JY5101.CIInternalSampleClock
  • ReadData() : JY5101.JY5101AITask, JY5101.JY5101CITask
  • ReadRawData() : JY5101.JY5101AITask
  • ReadRawSinglePoint() : JY5101.JY5101AITask
  • ReadSinglePoint() : JY5101.JY5101AITask, JY5101.JY5101CITask, JY5101.JY5101DITask, JY5101.JY5101DOTask
  • Record : JY5101.JY5101AITask
  • RemoveChannel() : JY5101.JY5101AITask, JY5101.JY5101AOTask, JY5101.JY5101DITask, JY5101.JY5101DOTask
  • Reset : JY5101.EdgeCountingOutEvent
  • ReTriggerCount : JY5101.AITrigger


5101 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- s -

  • SampleClock : JY5101.JY5101AITask, JY5101.JY5101AOTask, JY5101.JY5101CITask
  • SampleRate : JY5101.JY5101AITask
  • SamplesToAcquire : JY5101.JY5101AITask, JY5101.JY5101CITask
  • SamplesToUpdate : JY5101.JY5101AOTask
  • SecondInputTerminal : JY5101.TwoEdgeSeparation
  • SecondSignalReversed : JY5101.TwoEdgeSeparation
  • SemiPeriodMeas : JY5101.JY5101CITask
  • SendSoftwareTrigger() : JY5101.JY5101AITask, JY5101.JY5101AOTask, JY5101.JY5101CITask, JY5101.JY5101COTask
  • SignalExport : JY5101.JY5101AITask, JY5101.JY5101AOTask, JY5101.JY5101CITask, JY5101.JY5101COTask
  • SignalReversed : JY5101.PauseTrigger, JY5101.PulseMeas, JY5101.SemiPeriodMeas
  • Slope : JY5101.AIAnalogEdgeComparator, JY5101.AIAnalogHysteresisComparator, JY5101.AIAnalogMultichannelEdgeComparatorSource, JY5101.AIAnalogMultichannelHysteresisComparatorSource
  • Source : JY5101.AIAnalogMultichannelEdgeComparatorSource, JY5101.AIAnalogMultichannelHysteresisComparatorSource, JY5101.AIAnalogMultichannelWindowComparatorSource, JY5101.AIAnalogTrigger, JY5101.AIDigitalTrigger, JY5101.AISampleClock, JY5101.AODigitalTrigger, JY5101.AOSampleClock, JY5101.CIDigitalTrigger, JY5101.CISampleClock, JY5101.CITimebase, JY5101.CODigitalTrigger, JY5101.COTimebase
  • Sources : JY5101.AIAnalogMultichannelEdgeComparator, JY5101.AIAnalogMultichannelHysteresisComparator, JY5101.AIAnalogMultichannelWindowComparator
  • Start() : JY5101.JY5101AITask, JY5101.JY5101AOTask, JY5101.JY5101CITask, JY5101.JY5101COTask, JY5101.JY5101DITask, JY5101.JY5101DOTask
  • StartingEdge : JY5101.PulseMeas, JY5101.SemiPeriodMeas
  • Stop() : JY5101.JY5101AITask, JY5101.JY5101AOTask, JY5101.JY5101CITask, JY5101.JY5101COTask, JY5101.JY5101DITask, JY5101.JY5101DOTask


5101 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- t -

  • Terminal : JY5101.AIChannel, JY5101.AIExternalSampleClock, JY5101.AOExternalSampleClock, JY5101.CIExternalSampleClock, JY5101.CIExternalTimebase, JY5101.COExternalTimebase, JY5101.EdgeCountingOutEvent, JY5101.PauseTrigger
  • Threshold : JY5101.AIAnalogEdgeComparator, JY5101.AIAnalogMultichannelEdgeComparatorSource, JY5101.EdgeCountingOutEvent
  • Timebase : JY5101.FrequencyMeas, JY5101.JY5101COTask, JY5101.PeriodMeas, JY5101.PulseMeas, JY5101.SemiPeriodMeas, JY5101.TwoEdgeSeparation
  • Topology : JY5101.AISync
  • TransferedSamples : JY5101.JY5101AITask, JY5101.JY5101AOTask, JY5101.JY5101CITask
  • Trigger : JY5101.JY5101AITask, JY5101.JY5101AOTask, JY5101.JY5101CITask, JY5101.JY5101COTask
  • TriggerRouting : JY5101.AISync
  • TwoEdgeSeparation : JY5101.JY5101CITask
  • TwoPulseEncoder : JY5101.JY5101CITask
  • Type : JY5101.AITrigger, JY5101.AOTrigger, JY5101.CITrigger, JY5101.COTrigger, JY5101.JY5101CITask


5101 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- u -

  • UpdateRate : JY5101.JY5101AOTask


5101 C# Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Properties
Here is a list of all variables with links to the classes they belong to:
  • HighThreshold : JY5101.AIAnalogHysteresisComparator, JY5101.AIAnalogWindowComparator
  • LowThreshold : JY5101.AIAnalogHysteresisComparator, JY5101.AIAnalogWindowComparator
  • Threshold : JY5101.AIAnalogEdgeComparator


5101 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- w -

  • WaitUntilDone() : JY5101.JY5101AITask, JY5101.JY5101AOTask, JY5101.JY5101COTask
  • Window : JY5101.AIAnalogMultichannelComparator, JY5101.AIAnalogTrigger
  • WriteData() : JY5101.JY5101AOTask
  • WriteRawData() : JY5101.JY5101AOTask
  • WriteRawSinglePoint() : JY5101.JY5101AOTask
  • WriteSinglePoint() : JY5101.JY5101AOTask, JY5101.JY5101COTask, JY5101.JY5101DOTask


5101 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- z -

  • ZInputTerminal : JY5101.QuadEncoder
  • ZReloadEnabled : JY5101.QuadEncoder
  • ZSignalReversed : JY5101.QuadEncoder


5101 C# Programming Manual: Main Page

5101 C# Programming Manual Documentation


5101 C# Programming Manual: Package Members

  • Package List
  • Package Members
  • All
  • Enumerations
  • a
  • c
  • e
  • f
  • i
  • l
  • o
  • q
  • r
  • s
  • v
Here is a list of all namespace members with links to the namespace documentation for each member:

- a -

  • AIAnalogComparatorLogic : JY5101
  • AIAnalogTriggerComparator : JY5101
  • AIAnalogTriggerEdge : JY5101
  • AIAnalogTriggerSource : JY5101
  • AIAnalogWindowCondition : JY5101
  • AIBandWidth : JY5101
  • AIDigitalTriggerEdge : JY5101
  • AIDigitalTriggerSource : JY5101
  • AIMode : JY5101
  • AISampleClockSource : JY5101
  • AISignalExportSource : JY5101
  • AITerminal : JY5101
  • AITriggerMode : JY5101
  • AITriggerType : JY5101
  • AODigitalTriggerEdge : JY5101
  • AODigitalTriggerSource : JY5101
  • AOMode : JY5101
  • AOSampleClockSource : JY5101
  • AOSignalExportSource : JY5101
  • AOTriggerType : JY5101

- c -

  • CIDigitalTriggerEdge : JY5101
  • CIDigitalTriggerSource : JY5101
  • CIMode : JY5101
  • CISampleClockSource : JY5101
  • CISignalExportSource : JY5101
  • CITimebaseSource : JY5101
  • CITriggerType : JY5101
  • CIType : JY5101
  • ClockTerminal : JY5101
  • CODigitalTriggerEdge : JY5101
  • CODigitalTriggerSource : JY5101
  • COIdleState : JY5101
  • COMode : JY5101
  • COPulseType : JY5101
  • COSignalExportSource : JY5101
  • COTimebaseSource : JY5101
  • COTriggerType : JY5101
  • CountDirection : JY5101

- e -

  • EdgeCntOunEvtIdleState : JY5101
  • EdgeType : JY5101

- f -

  • FileFormat : JY5101

- i -

  • InputTerminal : JY5101
  • IOTerminal : JY5101

- l -

  • LevelPolarity : JY5101

- o -

  • OutputCompleteState : JY5101
  • OutputState : JY5101

- q -

  • QuadEncodingType : JY5101

- r -

  • RecordMode : JY5101

- s -

  • SignalExportDestination : JY5101
  • SyncPulseRouting : JY5101
  • SyncTopology : JY5101
  • SyncTriggerRouting : JY5101

- v -

  • ValueReturnMode : JY5101


5101 C# Programming Manual: Package Members

  • Package List
  • Package Members
  • All
  • Enumerations
  • a
  • c
  • e
  • f
  • i
  • l
  • o
  • q
  • r
  • s
  • v
Here is a list of all namespace enums with links to the namespace documentation for each enum:

- a -

  • AIAnalogComparatorLogic : JY5101
  • AIAnalogTriggerComparator : JY5101
  • AIAnalogTriggerEdge : JY5101
  • AIAnalogTriggerSource : JY5101
  • AIAnalogWindowCondition : JY5101
  • AIBandWidth : JY5101
  • AIDigitalTriggerEdge : JY5101
  • AIDigitalTriggerSource : JY5101
  • AIMode : JY5101
  • AISampleClockSource : JY5101
  • AISignalExportSource : JY5101
  • AITerminal : JY5101
  • AITriggerMode : JY5101
  • AITriggerType : JY5101
  • AODigitalTriggerEdge : JY5101
  • AODigitalTriggerSource : JY5101
  • AOMode : JY5101
  • AOSampleClockSource : JY5101
  • AOSignalExportSource : JY5101
  • AOTriggerType : JY5101

- c -

  • CIDigitalTriggerEdge : JY5101
  • CIDigitalTriggerSource : JY5101
  • CIMode : JY5101
  • CISampleClockSource : JY5101
  • CISignalExportSource : JY5101
  • CITimebaseSource : JY5101
  • CITriggerType : JY5101
  • CIType : JY5101
  • ClockTerminal : JY5101
  • CODigitalTriggerEdge : JY5101
  • CODigitalTriggerSource : JY5101
  • COIdleState : JY5101
  • COMode : JY5101
  • COPulseType : JY5101
  • COSignalExportSource : JY5101
  • COTimebaseSource : JY5101
  • COTriggerType : JY5101
  • CountDirection : JY5101

- e -

  • EdgeCntOunEvtIdleState : JY5101
  • EdgeType : JY5101

- f -

  • FileFormat : JY5101

- i -

  • InputTerminal : JY5101
  • IOTerminal : JY5101

- l -

  • LevelPolarity : JY5101

- o -

  • OutputCompleteState : JY5101
  • OutputState : JY5101

- q -

  • QuadEncodingType : JY5101

- r -

  • RecordMode : JY5101

- s -

  • SignalExportDestination : JY5101
  • SyncPulseRouting : JY5101
  • SyncTopology : JY5101
  • SyncTriggerRouting : JY5101

- v -

  • ValueReturnMode : JY5101


5101 C# Programming Manual: Package List

  • Package List
  • Package Members
Package List
Here are the packages with brief descriptions (if available):
N JY5101