5111 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5111 Directory Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 5111
5111 Directory Reference

Files

JYPCIe5111CoreOOAITask.h
JYPCIe5111CoreOOAOTask.h
JYPCIe5111CoreOOCITask.h
JYPCIe5111CoreOOCommon.h
JYPCIe5111CoreOOCOTask.h
JYPCIe5111CoreOODevice.h
JYPCIe5111CoreOODITask.h
JYPCIe5111CoreOODOTask.h
JYPCIe5111CoreOOLog.h
Generated by doxygen 1.13.2


5111 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOAITask.h File Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 5111
Classes | Namespaces | Enumerations
JYPCIe5111CoreOOAITask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JYPCIe5111CoreOOCommon.h"
#include "JYPCIe5111CoreOODevice.h"

Classes

class | JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask
AITask类 More...
class | JYPCIe5111CoreOO::AIChannel
AI Channel parameter class . More...
class | JYPCIe5111CoreOO::AIExternalSampleClock
Sample clock configuration class. More...
class | JYPCIe5111CoreOO::AISampleClock
Sample clock configuration class. More...
class | JYPCIe5111CoreOO::AITrigger
Constructor to create an AITrigger task object. More...
class | JYPCIe5111CoreOO::AIDigitalTrigger
AI Digital trigger class. More...
class | JYPCIe5111CoreOO::AIAnalogHysteresisComparator
AI Analog Hysteresis Comparatorr. More...
class | JYPCIe5111CoreOO::AIAnalogWindowComparator
AI Analog Window Comparatorr. More...
class | JYPCIe5111CoreOO::AIAnalogEdgeComparator
AI Analog Edge Comparator. More...
class | JYPCIe5111CoreOO::AIAnalogTrigger
AI analog trigger . More...
class | JYPCIe5111CoreOO::AIRecord
AI Record Parameters. More...
class | JYPCIe5111CoreOO::AIDSMode
class | JYPCIe5111CoreOO::AIAdvanced
AI Advance parameter. More...
class | JYPCIe5111CoreOO::AISignalExport
AI Signal Export Class. More...

Namespaces

namespace JYPCIe5111CoreOO

Enumerations

enum class | JYPCIe5111CoreOO::AITerminal { JYPCIe5111CoreOO::RSE = 0x0 , JYPCIe5111CoreOO::NRSE = 0x1 , JYPCIe5111CoreOO::Differential = 0x2 }
enum class | JYPCIe5111CoreOO::AIMode { JYPCIe5111CoreOO::Single = 0x2 , JYPCIe5111CoreOO::Finite = 0x0 , JYPCIe5111CoreOO::Continuous = 0x1 , JYPCIe5111CoreOO::Record = 0x3 }
enum class | JYPCIe5111CoreOO::AISampleClockSource { JYPCIe5111CoreOO::Internal , JYPCIe5111CoreOO::External }
AI Sample Clock Source. More...
enum class | JYPCIe5111CoreOO::AITriggerType { JYPCIe5111CoreOO::Immediate = 0x0 , JYPCIe5111CoreOO::Digital = 0x1 , JYPCIe5111CoreOO::Analog = 0x2 , JYPCIe5111CoreOO::Soft = 0x3 }
Trigger Type Digital/Analog/Immediate/Soft. More...
enum class | JYPCIe5111CoreOO::AITriggerMode { JYPCIe5111CoreOO::Start , JYPCIe5111CoreOO::Reference }
AI Trigger Mode. More...
enum class JYPCIe5111CoreOO::AIAnalogTriggerSource {
JYPCIe5111CoreOO::Channel_0 , JYPCIe5111CoreOO::Channel_1 , JYPCIe5111CoreOO::Channel_2 , JYPCIe5111CoreOO::Channel_3 ,
JYPCIe5111CoreOO::Channel_4 , JYPCIe5111CoreOO::Channel_5 , JYPCIe5111CoreOO::Channel_6 , JYPCIe5111CoreOO::Channel_7 ,
JYPCIe5111CoreOO::Channel_8 , JYPCIe5111CoreOO::Channel_9 , JYPCIe5111CoreOO::Channel_10 , JYPCIe5111CoreOO::Channel_11 ,
JYPCIe5111CoreOO::Channel_12 , JYPCIe5111CoreOO::Channel_13 , JYPCIe5111CoreOO::Channel_14 , JYPCIe5111CoreOO::Channel_15 ,
JYPCIe5111CoreOO::Channel_16 , JYPCIe5111CoreOO::Channel_17 , JYPCIe5111CoreOO::Channel_18 , JYPCIe5111CoreOO::Channel_19 ,
JYPCIe5111CoreOO::Channel_20 , JYPCIe5111CoreOO::Channel_21 , JYPCIe5111CoreOO::Channel_22 , JYPCIe5111CoreOO::Channel_23 ,
JYPCIe5111CoreOO::Channel_24 , JYPCIe5111CoreOO::Channel_25 , JYPCIe5111CoreOO::Channel_26 , JYPCIe5111CoreOO::Channel_27 ,
JYPCIe5111CoreOO::Channel_28 , JYPCIe5111CoreOO::Channel_29 , JYPCIe5111CoreOO::Channel_30 , JYPCIe5111CoreOO::Channel_31
}
AI analog trigger source. More...
enum class JYPCIe5111CoreOO::AIDigitalTriggerSource {
JYPCIe5111CoreOO::PFI0 , JYPCIe5111CoreOO::PFI1 , JYPCIe5111CoreOO::PFI2 , JYPCIe5111CoreOO::PFI3 ,
JYPCIe5111CoreOO::PFI4 , JYPCIe5111CoreOO::PFI5 , JYPCIe5111CoreOO::PFI6 , JYPCIe5111CoreOO::PFI7 ,
JYPCIe5111CoreOO::PFI8 , JYPCIe5111CoreOO::PFI9 , JYPCIe5111CoreOO::PFI10 , JYPCIe5111CoreOO::PFI11 ,
JYPCIe5111CoreOO::PFI12 , JYPCIe5111CoreOO::PFI13 , JYPCIe5111CoreOO::PFI14 , JYPCIe5111CoreOO::PFI15 ,
JYPCIe5111CoreOO::PXI_Trig0 = 40 , JYPCIe5111CoreOO::PXI_Trig1 = 41 , JYPCIe5111CoreOO::PXI_Trig2 = 42 , JYPCIe5111CoreOO::PXI_Trig3 = 43 ,
JYPCIe5111CoreOO::PXI_Trig4 = 44 , JYPCIe5111CoreOO::PXI_Trig5 = 45 , JYPCIe5111CoreOO::PXI_Trig6 = 46 , JYPCIe5111CoreOO::PXI_Trig7 = 47 ,
JYPCIe5111CoreOO::AO_StartTrig = 26 , JYPCIe5111CoreOO::DI_StartTrig = 22 , JYPCIe5111CoreOO::DI_ReferenceTrig = 23 , JYPCIe5111CoreOO::DO_StartTrig = 29 ,
JYPCIe5111CoreOO::CI_0_StartTrig = 68 , JYPCIe5111CoreOO::CI_1_StartTrig = 73 , JYPCIe5111CoreOO::CI_2_StartTrig = 76 , JYPCIe5111CoreOO::CI_3_StartTrig = 79 ,
JYPCIe5111CoreOO::CO_0_StartTrig = 69 , JYPCIe5111CoreOO::CO_1_StartTrig = 74 , JYPCIe5111CoreOO::CO_2_StartTrig = 77 , JYPCIe5111CoreOO::CO_3_StartTrig = 80 ,
JYPCIe5111CoreOO::CO_0_Output = 37 , JYPCIe5111CoreOO::CO_1_Output = 51 , JYPCIe5111CoreOO::CO_2_Output = 60 , JYPCIe5111CoreOO::CO_3_Output = 66
}
AI Digital trigger source. More...
enum class | JYPCIe5111CoreOO::AIDigitalTriggerEdge { JYPCIe5111CoreOO::Rising = 0x0 , JYPCIe5111CoreOO::Falling = 0x1 }
AI Digital Trigger Edge. More...
enum class | JYPCIe5111CoreOO::AIAnalogTriggerEdge { JYPCIe5111CoreOO::Rising , JYPCIe5111CoreOO::Falling }
AI Analog Trigger Edge. More...
enum class | JYPCIe5111CoreOO::AIAnalogWindowCondition { JYPCIe5111CoreOO::Entering , JYPCIe5111CoreOO::Leaving }
AI Analog Window Trigger Condition. More...
enum class | JYPCIe5111CoreOO::AIAnalogTriggerComparator { JYPCIe5111CoreOO::Edge , JYPCIe5111CoreOO::Hysteresis , JYPCIe5111CoreOO::Window }
AI Analog Trigger Comparator. More...
enum class JYPCIe5111CoreOO::AISignalExportSource {
JYPCIe5111CoreOO::AI_StartTrig = 16 , JYPCIe5111CoreOO::AI_ReferenceTrig = 17 , JYPCIe5111CoreOO::DI_StartTrig = 22 , JYPCIe5111CoreOO::DI_ReferenceTrig = 23 ,
JYPCIe5111CoreOO::AO_StartTrig = 26 , JYPCIe5111CoreOO::DO_StartTrig = 29 , JYPCIe5111CoreOO::CI_0_StartTrig = 68 , JYPCIe5111CoreOO::CI_1_StartTrig = 73 ,
JYPCIe5111CoreOO::CI_2_StartTrig = 76 , JYPCIe5111CoreOO::CI_3_StartTrig = 79 , JYPCIe5111CoreOO::CO_0_StartTrig = 69 , JYPCIe5111CoreOO::CO_1_StartTrig = 74 ,
JYPCIe5111CoreOO::CO_2_StartTrig = 77 , JYPCIe5111CoreOO::CO_3_StartTrig = 80 , JYPCIe5111CoreOO::AI_SampleClock = 20 , JYPCIe5111CoreOO::AO_SampleClock = 28 ,
JYPCIe5111CoreOO::DI_SampleClock = 53 , JYPCIe5111CoreOO::DO_SampleClock = 54 , JYPCIe5111CoreOO::CI_0_SampleClock = 36 , JYPCIe5111CoreOO::CI_1_SampleClock = 50 ,
JYPCIe5111CoreOO::CI_2_SampleClock = 59 , JYPCIe5111CoreOO::CI_3_SampleClock = 65 , JYPCIe5111CoreOO::CO_0_Output = 37 , JYPCIe5111CoreOO::CO_1_Output = 51 ,
JYPCIe5111CoreOO::CO_2_Output = 60 , JYPCIe5111CoreOO::CO_3_Output = 66
}
AI Signal Export Source. More...
enum class | JYPCIe5111CoreOO::FileFormat { JYPCIe5111CoreOO::Bin }
Streaming file format. More...
enum class | JYPCIe5111CoreOO::RecordMode { JYPCIe5111CoreOO::Finite , JYPCIe5111CoreOO::Infinite }
stream mode .enum Finite/Infinite More...
enum class | JYPCIe5111CoreOO::PowerLineFrequency { JYPCIe5111CoreOO::_50Hz , JYPCIe5111CoreOO::_60Hz }


5111 C++ Programming Manual: JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • JYPCIe5111CoreOOAITask
Public Member Functions | Public Attributes | List of all members
JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask Class Reference

AITask类 More...

#include <JYPCIe5111CoreOOAOTask.h>

Public Member Functions

JYPCIe5111CoreOOAITask (int slotNum)
JYPCIe5111CoreOOAITask (std::string boardName)
~JYPCIe5111CoreOOAITask ()
void | AddChannel (int chnId, double rangeLow=-10, double rangeHigh=10, AITerminal terminalCfg=AITerminal::RSE)
Add one channel.
void | AddChannel (std::vector< int > chnsId, double rangeLow=-10, double rangeHigh=10, AITerminal terminalCfg=AITerminal::RSE)
Add a group of channels.
void | AddChannel (std::vector< int > chnsId, std::vector< double > rangeLow, std::vector< double > rangeHigh, AITerminal terminalCfg=AITerminal::RSE)
Add a group of channels.
void | RemoveChannel (int chnId)
Delete the specified channel number.
void | ReadData (double *pBuf, int samplesPerChannel, int timeout=-1)
Read the multi-channel data by columns and store it in a data buffer.
void | ReadData (std::vector< double > &pBuf, int samplesPerChannel, int timeout=-1)
Read the multi-channel data by columns and store it in a data buffer.
void | ReadRawData (int *pBuf, int samplesPerChannel, int timeout=-1)
Read one or multi-channel raw data by columns and store it in a data buffer.
void | ReadRawData (std::vector< int > &pBuf, int samplesPerChannel, int timeout=-1)
Read one or multi-channel raw data by columns and store it in a data buffer.
void | ReadSinglePoint (double &readValue, int channel)
Read one sample for specified channel in register.
void | ReadSinglePoint (std::vector< double > &readValues)
Read one sample for all channels in register .
void | ReadRawSinglePoint (int &readValue, int channel)
Read raw one sample for specified channel in register.
void | ReadRawSinglePoint (std::vector< uint32_t > &readValues)
Read raw one sample for all channels in register .
void | GetRecordPreviewData (double *buf, int samplesPerChannel, int timeout)
Preview multi-channel data when streaming is in progress.
void | GetRecordPreviewData (std::vector< double > &buf, int samplesPerChannel, int timeout)
Preview multi-channel data when streaming is in progress.
void | GetRecordStatus (double &recordedLength, bool &recordDone)
get the streaming status.
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.
void | Start ()
启动Task
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Stop ()
Stop AI task .

Public Attributes

std::list< AIChannel * > | Channels
List of AI channels,(5111 support 32 SE/16 Diff channel)
JYPCIe5111CoreOOProperty< JYPCIe5111CoreOOAITask, double, JYPCIe5111CoreOOPropertyType::READ_WRITE > | SampleRate
Sample rate per channel.
int | SamplesToAcquire
Number of samples to be read per channel.
JYPCIe5111CoreOOProperty< JYPCIe5111CoreOOAITask, int, JYPCIe5111CoreOOPropertyType::READ_ONLY > | BufLenInSamples
Number of samples per channel can be storage in the buffer, the Property SamplesToAcquire must be less than or equal to this value.
JYPCIe5111CoreOOProperty< JYPCIe5111CoreOOAITask, uint64_t, JYPCIe5111CoreOOPropertyType::READ_ONLY > | AvailableSamples
Number of samples per channel that can be read in the buffer .
JYPCIe5111CoreOOProperty< JYPCIe5111CoreOOAITask, uint64_t, JYPCIe5111CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
AIMode Mode
AI acquisition mode, support Single/Finite/Continuous/Record *.
AISampleClock * SampleClock
AI Sample Clock.
AITrigger * Trigger
AI Trigger Configuration.
AIAdvanced * Advanced
AI Trigger Configuration.
AIRecord * Record
ai Data streaming Configuration
AISignalExport * SignalExport
Export AI Signal Configuration.
JYPCIe5111CoreOODevice * Device
Device.

Detailed Description

AITask类

Constructor & Destructor Documentation

◆ JYPCIe5111CoreOOAITask() [1/2]

JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask::JYPCIe5111CoreOOAITask ( int slotNum )

◆ JYPCIe5111CoreOOAITask() [2/2]

JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask::JYPCIe5111CoreOOAITask ( std::string boardName )

◆ ~JYPCIe5111CoreOOAITask()

JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask::~JYPCIe5111CoreOOAITask ( )

Member Function Documentation

◆ AddChannel() [1/3]

void JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask::AddChannel | ( | int | chnId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10,
 |  | AITerminal | terminalCfg = AITerminal::RSE )

Add one channel.

Parameters
chnId | channel's physical number ，chnId=-1, add all channels。（5111 SE 0-31, Differential 0-15）
rangeLow | lower range limit for the channel，-10/-5/-2.5/-1.25/-0.625V defalut -10
rangeHigh | higher range limit for the channel，10/5/2.5/1.25/0.625VV defalut 10
terminalCfg | terminal input mode configuration，RSE/NRSE/Differential.Default RSE

◆ AddChannel() [2/3]

void JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10,
 |  | AITerminal | terminalCfg = AITerminal::RSE )

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers （5111 SE 0-31, Differential 0-15）
rangeLow | lower range limit for the channel，-10/-5/-2.5/-1.25/-0.625V defalut -10
rangeHigh | higher range limit for the channel，10/5/2.5/1.25/0.625VV defalut 10
terminalCfg | terminal input mode configuration，RSE/NRSE/Differential.Default RSE

◆ AddChannel() [3/3]

void JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | std::vector< double > | rangeLow,
 |  | std::vector< double > | rangeHigh,
 |  | AITerminal | terminalCfg = AITerminal::RSE )

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers （5111 SE 0-31, Differential 0-16）
rangeLow | lower range limit for the channel，-10/-5/-2.5/-1.25/-0.625V defalut -10
rangeHigh | higher range limit for the channel，10/5/2.5/1.25/0.625VV defalut 10
terminalCfg | terminal input mode configuration，RSE/NRSE/Differential.Default RSE

◆ GetRecordPreviewData() [1/2]

void JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask::GetRecordPreviewData | ( | double * | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Preview multi-channel data when streaming is in progress.

Each column represents one channel.

Parameters
buf | Data buffer
samplesPerChannel | Number of preview samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ GetRecordPreviewData() [2/2]

void JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask::GetRecordPreviewData | ( | std::vector< double > & | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Preview multi-channel data when streaming is in progress.

Each column represents one channel.

Parameters
buf | Data buffer
samplesPerChannel | Number of preview samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ GetRecordStatus()

void JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask::GetRecordStatus | ( | double & | recordedLength,
 |  | bool & | recordDone )

get the streaming status.

Available when Mode is AIMode.Record

Parameters
recordedLength | Length of the streamed
recordDone | recordDone = false :streaming is not over.recordDone = true :streaming is over.

◆ ReadData() [1/2]

void JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask::ReadData | ( | double * | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = -1 )

Read the multi-channel data by columns and store it in a data buffer.

Each channel is represented by one column of data.

Parameters
pBuf | Data buffer
samplesPerChannel | Number of samples per channel to read
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadData() [2/2]

void JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask::ReadData | ( | std::vector< double > & | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = -1 )

Read the multi-channel data by columns and store it in a data buffer.

Each channel is represented by one column of data.

Parameters
pBuf | Data buffer
samplesPerChannel | Number of samples per channel to read
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadRawData() [1/2]

void JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask::ReadRawData | ( | int * | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = -1 )

Read one or multi-channel raw data by columns and store it in a data buffer.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel to read
timeout | timeout before generating error message, uint is ms。, timeout =-1 keep waiting until finish.

◆ ReadRawData() [2/2]

void JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask::ReadRawData | ( | std::vector< int > & | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = -1 )

Read one or multi-channel raw data by columns and store it in a data buffer.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel to read
timeout | timeout before generating error message, uint is ms。, timeout =-1 keep waiting until finish.

◆ ReadRawSinglePoint() [1/2]

void JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask::ReadRawSinglePoint | ( | int & | readValue,
 |  | int | channel )

Read raw one sample for specified channel in register.

Available when Mode is AIMode.Single

Parameters
readValue | value read
channel | Specified channel numbers.

◆ ReadRawSinglePoint() [2/2]

void JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask::ReadRawSinglePoint ( std::vector< uint32_t > & readValues )

Read raw one sample for all channels in register .

Available when Mode is AIMode.Single

Parameters
readValues Values read. Array length >= Channels.Count.

◆ ReadSinglePoint() [1/2]

void JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask::ReadSinglePoint | ( | double & | readValue,
 |  | int | channel )

Read one sample for specified channel in register.

Available when Mode is AIMode.Single

Parameters
readValue | value read
channel | Specified channel numbers.

◆ ReadSinglePoint() [2/2]

void JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask::ReadSinglePoint ( std::vector< double > & readValues )

Read one sample for all channels in register .

Available when Mode is AIMode.Single

Parameters
readValues Values read. Array length >= Channels.Count.

◆ RemoveChannel()

void JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask::RemoveChannel ( int chnId )

Delete the specified channel number.

If it is -1, delete all channels.

Parameters
chnId Specified channel ID.

◆ SendSoftwareTrigger()

void JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask::SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask::Start ( )

启动Task

Parameters

return void

Exceptions
JYDriverException 如果启动失败

◆ Stop()

void JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask::Stop ( )

Stop AI task .

◆ WaitUntilDone()

bool JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask::WaitUntilDone ( int timeout = -1 )
inline

Waiting until current task to complete.

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

Member Data Documentation

◆ Advanced

AIAdvanced* JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask::Advanced

AI Trigger Configuration.

◆ AvailableSamples

JYPCIe5111CoreOOProperty<JYPCIe5111CoreOOAITask, uint64_t, JYPCIe5111CoreOOPropertyType::READ_ONLY> JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask::AvailableSamples

Number of samples per channel that can be read in the buffer .

Valid when Mode is NOT AIMode.Single.

◆ BufLenInSamples

JYPCIe5111CoreOOProperty<JYPCIe5111CoreOOAITask, int, JYPCIe5111CoreOOPropertyType::READ_ONLY> JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask::BufLenInSamples

Number of samples per channel can be storage in the buffer, the Property SamplesToAcquire must be less than or equal to this value.

◆ Channels

std::list<AIChannel*> JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask::Channels

List of AI channels,(5111 support 32 SE/16 Diff channel)

◆ Device

JYPCIe5111CoreOODevice* JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask::Device

Device.

◆ Mode

AIMode JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask::Mode

AI acquisition mode, support Single/Finite/Continuous/Record *.

◆ Record

AIRecord* JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask::Record

ai Data streaming Configuration

◆ SampleClock

AISampleClock* JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask::SampleClock

AI Sample Clock.

◆ SampleRate

JYPCIe5111CoreOOProperty<JYPCIe5111CoreOOAITask, double, JYPCIe5111CoreOOPropertyType::READ_WRITE> JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask::SampleRate

Sample rate per channel.

Maximum sample rate is 500K for single channel, 300K for multichannel The default sample rate = 300K You can read this property to obtain the sample rate that will actually take effect in the current configuration.

Exceptions
JYDriverException

◆ SamplesToAcquire

int JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask::SamplesToAcquire

Number of samples to be read per channel.

Only valid when Mode is Finite*

◆ SignalExport

AISignalExport* JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask::SignalExport

Export AI Signal Configuration.

◆ TransferedSamples

JYPCIe5111CoreOOProperty<JYPCIe5111CoreOOAITask, uint64_t, JYPCIe5111CoreOOPropertyType::READ_ONLY> JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT AIMode.Single.

◆ Trigger

AITrigger* JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask::Trigger

AI Trigger Configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOAITask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::AIChannel Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • AIChannel
Public Member Functions | Public Attributes | List of all members
JYPCIe5111CoreOO::AIChannel Class Reference

AI Channel parameter class . More...

#include <JYPCIe5111CoreOOAITask.h>

Public Member Functions

AIChannel (int channelId, double rangeLow, double rangeHigh, AITerminal terminalCfg=AITerminal::NRSE)

Public Attributes

int | ChannelID
double | RangeLow
double | RangeHigh
AITerminal Terminal

Detailed Description

AI Channel parameter class .

Constructor & Destructor Documentation

◆ AIChannel()

JYPCIe5111CoreOO::AIChannel::AIChannel | ( | int | channelId,
 |  | double | rangeLow,
 |  | double | rangeHigh,
 |  | AITerminal | terminalCfg = AITerminal::NRSE )
 inline

Member Data Documentation

◆ ChannelID

int JYPCIe5111CoreOO::AIChannel::ChannelID

◆ RangeHigh

double JYPCIe5111CoreOO::AIChannel::RangeHigh

◆ RangeLow

double JYPCIe5111CoreOO::AIChannel::RangeLow

◆ Terminal

AITerminal JYPCIe5111CoreOO::AIChannel::Terminal
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOAITask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::AIExternalSampleClock Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • AIExternalSampleClock
Public Attributes | List of all members
JYPCIe5111CoreOO::AIExternalSampleClock Class Reference

Sample clock configuration class. More...

#include <JYPCIe5111CoreOOAITask.h>

Public Attributes

ClockTerminal Terminal
External Sample Clock Input Terminal.
double ExpectedRate
Expected External Sample Clock Rate.

Detailed Description

Sample clock configuration class.

Member Data Documentation

◆ ExpectedRate

double JYPCIe5111CoreOO::AIExternalSampleClock::ExpectedRate

Expected External Sample Clock Rate.

◆ Terminal

ClockTerminal JYPCIe5111CoreOO::AIExternalSampleClock::Terminal

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOAITask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::AISampleClock Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • AISampleClock
Public Attributes | List of all members
JYPCIe5111CoreOO::AISampleClock Class Reference

Sample clock configuration class. More...

#include <JYPCIe5111CoreOOAITask.h>

Public Attributes

AISampleClockSource Source
AI Sample Clock Source.
AIExternalSampleClock * External
External Sample Clock Configuration.

Detailed Description

Sample clock configuration class.

Member Data Documentation

◆ External

AIExternalSampleClock* JYPCIe5111CoreOO::AISampleClock::External

External Sample Clock Configuration.

Valid when Source is AISampleClockSource.External.

◆ Source

AISampleClockSource JYPCIe5111CoreOO::AISampleClock::Source

AI Sample Clock Source.

enum Internal/External. The default value is AISampleClockSource.Internal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOAITask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::AITrigger Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • AITrigger
Public Attributes | List of all members
JYPCIe5111CoreOO::AITrigger Class Reference

Constructor to create an AITrigger task object. More...

#include <JYPCIe5111CoreOOAITask.h>

Public Attributes

AITriggerType Type
AI trigger type.
AITriggerMode Mode
AI trigger mode.
AIDigitalTrigger * Digital
Digital Trigger Congfiguration.
AIAnalogTrigger * Analog
AI Analog Trigger.
int | ReTriggerCount
Number of repeat triggers.
unsigned int | PreTriggerSamples
AI pretrigger samples, must be less than or equal to JYPCIe5111AITask.SamplesToAcquire.

Detailed Description

Constructor to create an AITrigger task object.

Used to build AI Trigger

Member Data Documentation

◆ Analog

AIAnalogTrigger* JYPCIe5111CoreOO::AITrigger::Analog

AI Analog Trigger.

Valid when Type is AITriggerType.Analog.

◆ Digital

AIDigitalTrigger* JYPCIe5111CoreOO::AITrigger::Digital

Digital Trigger Congfiguration.

Valid when Type is AITriggerType.Digital.

◆ Mode

AITriggerMode JYPCIe5111CoreOO::AITrigger::Mode

AI trigger mode.

enum Start/Reference. The default value is AITriggerMode.Start.

◆ PreTriggerSamples

unsigned int JYPCIe5111CoreOO::AITrigger::PreTriggerSamples

AI pretrigger samples, must be less than or equal to JYPCIe5111AITask.SamplesToAcquire.

Valid when Mode is AITriggerMode.Reference. Pretrigger samples, must be greater than 0. Valid when Type is AITriggerType.Analog. Pretrigger samples, must be greater than 1. Valid when Type is AITriggerType.Digital.

◆ ReTriggerCount

int JYPCIe5111CoreOO::AITrigger::ReTriggerCount

Number of repeat triggers.

When 0 or 1 only trigger once, When -1 continuous retrigger until stop.

◆ Type

AITriggerType JYPCIe5111CoreOO::AITrigger::Type

AI trigger type.

enum Analog/Digital/Immediate/Soft. The default value is AITriggerType.Immediate.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOAITask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::AIDigitalTrigger Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • AIDigitalTrigger
Public Attributes | List of all members
JYPCIe5111CoreOO::AIDigitalTrigger Class Reference

AI Digital trigger class. More...

#include <JYPCIe5111CoreOOAITask.h>

Public Attributes

AIDigitalTriggerSource Source
AI Digital Trigger source.
AIDigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Detailed Description

AI Digital trigger class.

Member Data Documentation

◆ Edge

AIDigitalTriggerEdge JYPCIe5111CoreOO::AIDigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

AIDigitalTriggerSource JYPCIe5111CoreOO::AIDigitalTrigger::Source

AI Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOAITask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::AIAnalogHysteresisComparator Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • AIAnalogHysteresisComparator
Public Attributes | List of all members
JYPCIe5111CoreOO::AIAnalogHysteresisComparator Class Reference

AI Analog Hysteresis Comparatorr. More...

#include <JYPCIe5111CoreOOAITask.h>

Public Attributes

AIAnalogTriggerEdge Slope
AI Analog Trigger Edge.
double | HighThreshold
High Threshold.
double | LowThreshold
Low Threshold.

Detailed Description

AI Analog Hysteresis Comparatorr.

Member Data Documentation

◆ HighThreshold

double JYPCIe5111CoreOO::AIAnalogHysteresisComparator::HighThreshold

High Threshold.

◆ LowThreshold

double JYPCIe5111CoreOO::AIAnalogHysteresisComparator::LowThreshold

Low Threshold.

◆ Slope

AIAnalogTriggerEdge JYPCIe5111CoreOO::AIAnalogHysteresisComparator::Slope

AI Analog Trigger Edge.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOAITask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::AIAnalogWindowComparator Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • AIAnalogWindowComparator
Public Attributes | List of all members
JYPCIe5111CoreOO::AIAnalogWindowComparator Class Reference

AI Analog Window Comparatorr. More...

#include <JYPCIe5111CoreOOAITask.h>

Public Attributes

AIAnalogWindowCondition Condition
AI Analog Window Condition.
double | HighThreshold
High Threshold.
double | LowThreshold
Low Threshold.

Detailed Description

AI Analog Window Comparatorr.

Member Data Documentation

◆ Condition

AIAnalogWindowCondition JYPCIe5111CoreOO::AIAnalogWindowComparator::Condition

AI Analog Window Condition.

◆ HighThreshold

double JYPCIe5111CoreOO::AIAnalogWindowComparator::HighThreshold

High Threshold.

◆ LowThreshold

double JYPCIe5111CoreOO::AIAnalogWindowComparator::LowThreshold

Low Threshold.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOAITask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::AIAnalogEdgeComparator Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • AIAnalogEdgeComparator
Public Attributes | List of all members
JYPCIe5111CoreOO::AIAnalogEdgeComparator Class Reference

AI Analog Edge Comparator. More...

#include <JYPCIe5111CoreOOAITask.h>

Public Attributes

AIAnalogTriggerEdge Slope
AI Analog Trigger Edge.
double Threshold
Threshold.

Detailed Description

AI Analog Edge Comparator.

Member Data Documentation

◆ Slope

AIAnalogTriggerEdge JYPCIe5111CoreOO::AIAnalogEdgeComparator::Slope

AI Analog Trigger Edge.

◆ Threshold

double JYPCIe5111CoreOO::AIAnalogEdgeComparator::Threshold

Threshold.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOAITask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::AIAnalogTrigger Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • AIAnalogTrigger
Public Attributes | List of all members
JYPCIe5111CoreOO::AIAnalogTrigger Class Reference

AI analog trigger . More...

#include <JYPCIe5111CoreOOAITask.h>

Public Attributes

AIAnalogTriggerSource Source
Analog Trigger source.
AIAnalogTriggerComparator Comparator
AI Analog Trigger Comparator.
AIAnalogEdgeComparator * Edge
AI Analog Edge Comparator.
AIAnalogHysteresisComparator * Hysteresis
AI Analog Hysteresis Comparatorr.
AIAnalogWindowComparator * Window
AI Analog Window Comparatorr.

Detailed Description

AI analog trigger .

Member Data Documentation

◆ Comparator

AIAnalogTriggerComparator JYPCIe5111CoreOO::AIAnalogTrigger::Comparator

AI Analog Trigger Comparator.

◆ Edge

AIAnalogEdgeComparator* JYPCIe5111CoreOO::AIAnalogTrigger::Edge

AI Analog Edge Comparator.

◆ Hysteresis

AIAnalogHysteresisComparator* JYPCIe5111CoreOO::AIAnalogTrigger::Hysteresis

AI Analog Hysteresis Comparatorr.

◆ Source

AIAnalogTriggerSource JYPCIe5111CoreOO::AIAnalogTrigger::Source

Analog Trigger source.

◆ Window

AIAnalogWindowComparator* JYPCIe5111CoreOO::AIAnalogTrigger::Window

AI Analog Window Comparatorr.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOAITask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::AIRecord Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • AIRecord
Public Attributes | List of all members
JYPCIe5111CoreOO::AIRecord Class Reference

AI Record Parameters. More...

#include <JYPCIe5111CoreOOAITask.h>

Public Attributes

std::string | FilePath
User specified file path.
JYPCIe5111CoreOO::FileFormat File_Format
Streaming file format.
RecordMode Mode
stream mode .
double | Length
User specified stream length in second.

Detailed Description

AI Record Parameters.

Member Data Documentation

◆ File_Format

JYPCIe5111CoreOO::FileFormat JYPCIe5111CoreOO::AIRecord::File_Format

Streaming file format.

enum BIN.

◆ FilePath

std::string JYPCIe5111CoreOO::AIRecord::FilePath

User specified file path.

◆ Length

double JYPCIe5111CoreOO::AIRecord::Length

User specified stream length in second.

Only when Mode is RecordMode.Finite.

◆ Mode

RecordMode JYPCIe5111CoreOO::AIRecord::Mode

stream mode .

enum Finite/Infinite.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOAITask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::AIDSMode Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • AIDSMode
Public Attributes | List of all members
JYPCIe5111CoreOO::AIDSMode Class Reference

#include <JYPCIe5111CoreOOAITask.h>

Public Attributes

bool Enable
Enable DSMode.
JYPCIe5111CoreOO::PowerLineFrequency PowerLine_Frequency
AC Power Frequency.

Member Data Documentation

◆ Enable

bool JYPCIe5111CoreOO::AIDSMode::Enable

Enable DSMode.

◆ PowerLine_Frequency

JYPCIe5111CoreOO::PowerLineFrequency JYPCIe5111CoreOO::AIDSMode::PowerLine_Frequency

AC Power Frequency.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOAITask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::AIAdvanced Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • AIAdvanced
Public Attributes | List of all members
JYPCIe5111CoreOO::AIAdvanced Class Reference

AI Advance parameter. More...

#include <JYPCIe5111CoreOOAITask.h>

Public Attributes

double ConvertRate
the convert rate of ADC.
AIDSMode * DSMode
DSMode Config.

Detailed Description

AI Advance parameter.

Member Data Documentation

◆ ConvertRate

double JYPCIe5111CoreOO::AIAdvanced::ConvertRate

the convert rate of ADC.

◆ DSMode

AIDSMode* JYPCIe5111CoreOO::AIAdvanced::DSMode

DSMode Config.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOAITask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::AISignalExport Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • AISignalExport
Public Member Functions | List of all members
JYPCIe5111CoreOO::AISignalExport Class Reference

AI Signal Export Class. More...

#include <JYPCIe5111CoreOOAITask.h>

Public Member Functions

void | Add (AISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (AISignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

AI Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JYPCIe5111CoreOO::AISignalExport::Add | ( | AISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | AI Signal Source
destination | Export Desination

◆ Add() [2/2]

void JYPCIe5111CoreOO::AISignalExport::Add | ( | AISignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | AI Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JYPCIe5111CoreOO::AISignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JYPCIe5111CoreOO::AISignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOAITask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO Namespace Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Namespace List
  • Namespace Members
Classes | Enumerations | Functions
JYPCIe5111CoreOO Namespace Reference

Classes

class | AIAdvanced
AI Advance parameter. More...
class | AIAnalogEdgeComparator
AI Analog Edge Comparator. More...
class | AIAnalogHysteresisComparator
AI Analog Hysteresis Comparatorr. More...
class | AIAnalogTrigger
AI analog trigger . More...
class | AIAnalogWindowComparator
AI Analog Window Comparatorr. More...
class | AIChannel
AI Channel parameter class . More...
class | AIDigitalTrigger
AI Digital trigger class. More...
class | AIDSMode
class | AIExternalSampleClock
Sample clock configuration class. More...
class | AIRecord
AI Record Parameters. More...
class | AISampleClock
Sample clock configuration class. More...
class | AISignalExport
AI Signal Export Class. More...
class | AITrigger
Constructor to create an AITrigger task object. More...
class | AOChannel
class | AODigitalTrigger
AO Digital trigger . More...
class | AOExternalSampleClock
External Sample Clock Configuration Class. More...
class | AOSampleClock
AO Sample clock configuration class. More...
class | AOTrigger
Constructor to create an AOTrigger task object. More...
class | CIDigitalTrigger
CI Digital trigger . More...
class | CIExternalSampleClock
CI Implicit Sample Clock class. More...
class | CIImplicitSampleClock
CI Implicit Sample Clock class. More...
class | CIInternalSampleClock
CI Internal Sample Clock Configuration Class. More...
class | CISampleClock
CI Sample Clock class. More...
class | CISignalExport
CI Signal Export Class. More...
class | CITimebase
Timebase configuration class. More...
class | CITrigger
Constructor to create an CITrigger task object. More...
class | CODigitalTrigger
CO Digital trigger . More...
class | COPulse
Pulse Parameter. More...
class | COSignalExport
CO Signal Export Class. More...
class | COTimebase
Timebase configuration class. More...
class | COTrigger
Constructor to create an COTrigger task object. More...
class | DIChannel
DI Channel parameter class . More...
class | DIDigitalTrigger
DI Digital trigger . More...
class | DIExternalSampleClock
External Sample Clock Configuration Class. More...
class | DISampleClock
Sample clock configuration class. More...
class | DISignalExport
DI Signal Export Class. More...
class | DITrigger
Constructor to create an DITrigger task object. More...
class | DOChannel
DO Channel parameter class . More...
class | DODigitalTrigger
DO Digital trigger. More...
class | DOExternalSampleClock
External Sample Clock Configuration Class. More...
class | DOSampleClock
Sample clock configuration class. More...
class | DOSignalExport
DO Signal Export Class. More...
class | DOTrigger
Constructor to create an DOTrigger task object. More...
class | EdgeCounting
Configure CI EdgeCounting. More...
class | EdgeCountingOutEvent
Edge counting output event configuration class. More...
class | ExternalReferenceClock
class | FrequencyMeas
Configure CI Measure. More...
class | JYDriverException
class | JYPCIe5111CoreOOAITask
AITask类 More...
class | JYPCIe5111CoreOOAOTask
class | JYPCIe5111CoreOOCITask
class | JYPCIe5111CoreOOCOTask
class | JYPCIe5111CoreOODevice
class | JYPCIe5111CoreOODITask
class | JYPCIe5111CoreOODOTask
class | JYPCIe5111CoreOOLog
class | JYPCIe5111CoreOOProperty
属性模板类 More...
class | JYPCIe5111CoreOOReferenceClock
class | PauseTrigger
Pause trigger configuration class. More...
class | PeriodMeas
Configure CI Measure. More...
class | PFIFilter
class | PFISetting
class | PulseMeas
Configure CI Measure. More...
class | QuadEncoder
Configure CI Measure. More...
class | TwoEdgeSeparation
Configure CI Measure. More...
class | TwoPulseEncoder
Configure CI Measure. More...

Enumerations

enum class | AITerminal { RSE = 0x0 , NRSE = 0x1 , Differential = 0x2 }
enum class | AIMode { Single = 0x2 , Finite = 0x0 , Continuous = 0x1 , Record = 0x3 }
enum class | AISampleClockSource { Internal , External }
AI Sample Clock Source. More...
enum class | AITriggerType { Immediate = 0x0 , Digital = 0x1 , Analog = 0x2 , Soft = 0x3 }
Trigger Type Digital/Analog/Immediate/Soft. More...
enum class | AITriggerMode { Start , Reference }
AI Trigger Mode. More...
enum class AIAnalogTriggerSource {
Channel_0 , Channel_1 , Channel_2 , Channel_3 ,
Channel_4 , Channel_5 , Channel_6 , Channel_7 ,
Channel_8 , Channel_9 , Channel_10 , Channel_11 ,
Channel_12 , Channel_13 , Channel_14 , Channel_15 ,
Channel_16 , Channel_17 , Channel_18 , Channel_19 ,
Channel_20 , Channel_21 , Channel_22 , Channel_23 ,
Channel_24 , Channel_25 , Channel_26 , Channel_27 ,
Channel_28 , Channel_29 , Channel_30 , Channel_31
}
AI analog trigger source. More...
enum class AIDigitalTriggerSource {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PFI8 , PFI9 , PFI10 , PFI11 ,
PFI12 , PFI13 , PFI14 , PFI15 ,
PXI_Trig0 = 40 , PXI_Trig1 = 41 , PXI_Trig2 = 42 , PXI_Trig3 = 43 ,
PXI_Trig4 = 44 , PXI_Trig5 = 45 , PXI_Trig6 = 46 , PXI_Trig7 = 47 ,
AO_StartTrig = 26 , DI_StartTrig = 22 , DI_ReferenceTrig = 23 , DO_StartTrig = 29 ,
CI_0_StartTrig = 68 , CI_1_StartTrig = 73 , CI_2_StartTrig = 76 , CI_3_StartTrig = 79 ,
CO_0_StartTrig = 69 , CO_1_StartTrig = 74 , CO_2_StartTrig = 77 , CO_3_StartTrig = 80 ,
CO_0_Output = 37 , CO_1_Output = 51 , CO_2_Output = 60 , CO_3_Output = 66
}
AI Digital trigger source. More...
enum class | AIDigitalTriggerEdge { Rising = 0x0 , Falling = 0x1 }
AI Digital Trigger Edge. More...
enum class | AIAnalogTriggerEdge { Rising , Falling }
AI Analog Trigger Edge. More...
enum class | AIAnalogWindowCondition { Entering , Leaving }
AI Analog Window Trigger Condition. More...
enum class | AIAnalogTriggerComparator { Edge , Hysteresis , Window }
AI Analog Trigger Comparator. More...
enum class AISignalExportSource {
AI_StartTrig = 16 , AI_ReferenceTrig = 17 , DI_StartTrig = 22 , DI_ReferenceTrig = 23 ,
AO_StartTrig = 26 , DO_StartTrig = 29 , CI_0_StartTrig = 68 , CI_1_StartTrig = 73 ,
CI_2_StartTrig = 76 , CI_3_StartTrig = 79 , CO_0_StartTrig = 69 , CO_1_StartTrig = 74 ,
CO_2_StartTrig = 77 , CO_3_StartTrig = 80 , AI_SampleClock = 20 , AO_SampleClock = 28 ,
DI_SampleClock = 53 , DO_SampleClock = 54 , CI_0_SampleClock = 36 , CI_1_SampleClock = 50 ,
CI_2_SampleClock = 59 , CI_3_SampleClock = 65 , CO_0_Output = 37 , CO_1_Output = 51 ,
CO_2_Output = 60 , CO_3_Output = 66
}
AI Signal Export Source. More...
enum class | FileFormat { Bin }
Streaming file format. More...
enum class | RecordMode { Finite , Infinite }
stream mode .enum Finite/Infinite More...
enum class | PowerLineFrequency { _50Hz , _60Hz }
enum class | AOMode { Single = 3 , Finite = 0 , ContinuousNoWrapping = 2 , ContinuousWrapping = 1 }
enum class | AODigitalTriggerEdge { Rising , Falling }
AO Digital Trigger Edge. More...
enum class AODigitalTriggerSource {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PFI8 , PFI9 , PFI10 , PFI11 ,
PFI12 , PFI13 , PFI14 , PFI15 ,
PXI_Trig0 = 40 , PXI_Trig1 = 41 , PXI_Trig2 = 42 , PXI_Trig3 = 43 ,
PXI_Trig4 = 44 , PXI_Trig5 = 45 , PXI_Trig6 = 46 , PXI_Trig7 = 47 ,
AI_StartTrig = 16 , AI_ReferenceTrig = 17 , DI_StartTrig = 22 , DI_ReferenceTrig = 23 ,
DO_StartTrig = 29 , CI_0_StartTrig = 68 , CI_1_StartTrig = 73 , CI_2_StartTrig = 76 ,
CI_3_StartTrig = 79 , CO_0_StartTrig = 69 , CO_1_StartTrig = 74 , CO_2_StartTrig = 77 ,
CO_3_StartTrig = 80 , CO_0_Output = 37 , CO_1_Output = 51 , CO_2_Output = 60 ,
CO_3_Output = 66
}
AO Digital trigger source. More...
enum class | AOSampleClockSource { Internal , External }
AO Sample Clock Source. More...
enum class | AOSignalExportSource { StartTrig = 26 , SampleClock = 28 }
SourceSignal. More...
enum class | AOTriggerType { Immediate = 0x0 , Digital = 0x1 , Soft = 0x3 }
TriggerType Digital/Immediate/Soft. More...
enum class | CountDirection { Up = 0x0 , Down = 0x1 , External = 0x2 }
Counter direction. More...
enum class | CIMode { Single = 2 , Finite = 0 , Continuous = 1 }
CIMode. More...
enum class CIType {
EdgeCounting , Period , Frequency , Pulse ,
TwoEdgeSeparation , QuadEncoder , TwoPulseEncoder
}
Counter Input Application Type. More...
enum class | CISampleClockSource { Implicit = 0x0 , Internal = 0x1 , External = 0x2 }
CI Sample Clock Source. More...
enum class | EdgeType { Rising , Falling }
Edge Type. More...
enum class | QuadEncodingType { X1 , X2 , X4 }
Quadrature Encoding Type. More...
enum class | CITriggerType { Immediate = 0x0 , Digital = 0x1 , Soft = 0x3 }
TriggerType Digital/Immediate/Soft. More...
enum class CIDigitalTriggerSource {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PFI8 , PFI9 , PFI10 , PFI11 ,
PFI12 , PFI13 , PFI14 , PFI15 ,
PXI_Trig0 = 40 , PXI_Trig1 = 41 , PXI_Trig2 = 42 , PXI_Trig3 = 43 ,
PXI_Trig4 = 44 , PXI_Trig5 = 45 , PXI_Trig6 = 46 , PXI_Trig7 = 47 ,
AI_StartTrig = 16 , AI_ReferenceTrig = 17 , AO_StartTrig = 26 , DI_StartTrig = 22 ,
DI_ReferenceTrig = 23 , DO_StartTrig = 29 , CI_0_StartTrig = 68 , CI_1_StartTrig = 73 ,
CI_2_StartTrig = 76 , CI_3_StartTrig = 79 , CO_0_StartTrig = 69 , CO_1_StartTrig = 74 ,
CO_2_StartTrig = 77 , CO_3_StartTrig = 80 , CO_0_Output = 37 , CO_1_Output = 51 ,
CO_2_Output = 60 , CO_3_Output = 66
}
CI Digital trigger source. More...
enum class | CIDigitalTriggerEdge { Rising , Falling }
CI Digital Trigger Edge. More...
enum class | EdgeCntOunEvtIdleState { LowLevel = 0 , HighLevel = 1 }
Output idle state when the event has not occurred. More...
enum class | CISignalExportSource { StartTrig , SampleClock }
SourceSignal. More...
enum class | CITimebaseSource { Internal200MHz }
Timebase source. More...
enum class | JYPCIe5111CoreOOPropertyType { READ_ONLY = 1 , WRITE_ONLY = 2 , READ_WRITE = 3 }
enum class JYDriverExceptionPublic {
UnKnown = 0 , OpenDeviceFailed = -10001 , CloseDeviceFailed = -10002 , ResetDeviceFailed = -10003 ,
GetDevicePropertyFailed = -10004 , SetDevicePropertyFailed = -10005 , HardwareResourceIsReserved = -10006 , MethodNotPermitedToCallWhenCurrentStatus = -10007 ,
InvalidUserDataBuffer = -10008 , NoChannelAdded = -10009 , NotSupportOperationForCurrentDevice = -10010 , CreatTaskFailed = -10100 ,
StartTaskFailed = -10101 , StopTaskFailed = -10102 , TaskHasNotStarted = -10103 , TaskHasStartedCannotPerformTheSetOperation = -10104 ,
ChannelNumberParameterInvalid = -10105 , ChannelInputRangeParameterInvalid = -10106 , ChannelTerminalParameterInvalid = -10107 , ChannelCouplingParameterInvalid = -10108 ,
SampeleModeParameterInvalid = -10109 , SampleClockParameterInvalid = -10110 , SampleRateParameterInvalid = -10111 , UpdateRateParameterInvalid = -10112 ,
TriggerParameterInvalid = -10113 , ReferenceTriggerDoesNotMatchWithSampleMode = -10114 , PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint = -10115 , ReadDataFailed = -10016 ,
ReadDataTimeout = -10017 , WriteDataFailed = -10018 , WriteDataTimeout = -10019 , WriteDataLengthCannotBeLessThanN = -10020 ,
BufferDataOverflow = -10021 , BufferDataDownflow = -10022 , CheckBufferFailed = -10023 , PointInvalidInFiniteMode = -10024 ,
ReadPointInvalid = -10025 , OnlySupportRecordMode = -10026 , SendSoftTirggerFailed = -10027 , TaskTimeout = -10028 ,
CounterParametersInvalid = -10029 , WritePointInvalid = -10030 , SignalExportDestinationInvalid = -10031 , InvalidParameter = -10033
}
enum class ClockTerminal {
ECLK = 10000 , PFI0 = 0 , PFI1 = 1 , PFI2 = 2 ,
PFI3 = 3 , PFI4 = 4 , PFI5 = 5 , PFI6 = 6 ,
PFI7 = 7 , PFI8 = 8 , PFI9 = 9 , PFI10 = 10 ,
PFI11 = 11 , PFI12 = 12 , PFI13 = 13 , PFI14 = 14 ,
PFI15 = 15 , PXI_Trig0 = 40 , PXI_Trig1 = 41 , PXI_Trig2 = 42 ,
PXI_Trig3 = 43 , PXI_Trig4 = 44 , PXI_Trig5 = 45 , PXI_Trig6 = 46 ,
PXI_Trig7 = 47 , AI_SampleClock = 20 , AO_SampleClock = 28 , DI_SampleClock = 53 ,
DO_SampleClock = 54 , CI0_SampleClock = 36 , CI1_SampleClock = 50 , CI2_SampleClock = 59 ,
CI3_SampleClock = 65 , CO_0_Output = 37 , CO_1_Output = 51 , CO_2_Output = 60 ,
CO_3_Output = 66
}
enum class SignalExportDestination {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PFI8 , PFI9 , PFI10 , PFI11 ,
PFI12 , PFI13 , PFI14 , PFI15 ,
PXI_Trig0 = 0x20 , PXI_Trig1 = 0x21 , PXI_Trig2 = 0x22 , PXI_Trig3 = 0x23 ,
PXI_Trig4 = 0x24 , PXI_Trig5 = 0x25 , PXI_Trig6 = 0x26 , PXI_Trig7 = 0x27
}
enum class | OutputCompleteState { Zero , Hold }
Output Complete State. More...
enum class IOTerminal {
Default = 0 , PXI_Trig0 = 0x20 , PXI_Trig1 = 0x21 , PXI_Trig2 = 0x22 ,
PXI_Trig3 = 0x23 , PXI_Trig4 = 0x24 , PXI_Trig5 = 0x25 , PXI_Trig6 = 0x26 ,
PXI_Trig7 = 0x27
}
Cunter IO Terminal. More...
enum class | LevelPolarity { LowLevel = 0 , HighLevel = 1 , None = 2 }
Level Polarity. More...
enum class InputTerminal {
Default = 0 , PXI_Trig0 = 40 , PXI_Trig1 = 41 , PXI_Trig2 = 42 ,
PXI_Trig3 = 43 , PXI_Trig4 = 44 , PXI_Trig5 = 45 , PXI_Trig6 = 46 ,
PXI_Trig7 = 47 , CI_0_OutPut = 37 , CI_1_OutPut = 51 , CI_2_OutPut = 60 ,
CI_3_OutPut = 66
}
Cunter Input Terminal. More...
enum class | COIdleState { HighLevel = 0x1 , LowLevel = 0x0 }
Idle state when pulse output before start and after stop. More...
enum class | COMode { Single = 3 , Finite = 0 , ContinuousNoWrapping = 2 , ContinuousWrapping = 1 }
enum class | COTriggerType { Immediate = 0x0 , Digital = 0x1 , Soft = 0x3 }
TriggerType Digital/Immediate/Soft. More...
enum class CODigitalTriggerSource {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PFI8 , PFI9 , PFI10 , PFI11 ,
PFI12 , PFI13 , PFI14 , PFI15 ,
PXI_Trig0 = 40 , PXI_Trig1 = 41 , PXI_Trig2 = 42 , PXI_Trig3 = 43 ,
PXI_Trig4 = 44 , PXI_Trig5 = 45 , PXI_Trig6 = 46 , PXI_Trig7 = 47 ,
AI_StartTrig = 16 , AI_ReferenceTrig = 17 , AO_StartTrig = 26 , DI_StartTrig = 22 ,
DI_ReferenceTrig = 23 , DO_StartTrig = 29 , CI_0_StartTrig = 68 , CI_1_StartTrig = 73 ,
CI_2_StartTrig = 76 , CI_3_StartTrig = 79 , CO_0_StartTrig = 69 , CO_1_StartTrig = 74 ,
CO_2_StartTrig = 77 , CO_3_StartTrig = 80
}
CO Digital trigger source. More...
enum class | CODigitalTriggerEdge { Rising , Falling }
CO Digital Trigger Edge. More...
enum class | COPulseType { DutyCycleFrequency , HighLowTime , HighLowTick }
Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick. More...
enum class | COTimebaseSource { Internal200MHz }
Timebase source. More...
enum class | COSignalExportSource { StartTrig , Output }
SourceSignal. More...
enum class | ExternalReferenceClockTerminal { PXIe_Clk100 = 0x1 }
enum class | ReferenceClockSource { Internal = 0x0 , External = 0x1 }
enum class PFITerminal {
PFI0 = 0 , PFI1 = 1 , PFI2 = 2 , PFI3 = 3 ,
PFI4 = 4 , PFI5 = 5 , PFI6 = 6 , PFI7 = 7 ,
PFI8 = 8 , PFI9 = 9 , PFI10 = 10 , PFI11 = 11 ,
PFI12 = 12 , PFI13 = 13 , PFI14 = 14 , PFI15 = 15
}
Input/Output Terminal of PFI. More...
enum class | DISampleClockSource { Internal , External }
DI Sample Clock Source. More...
enum class | DIMode { Single = 2 , Finite = 0 , Continuous = 1 }
DIMode. More...
enum class | DISignalExportSource { StartTrig = 22 , ReferenceTrig = 23 , SampleClock = 53 }
SourceSignal. More...
enum class | DITriggerMode { Start , Reference }
DI Trigger Mode. More...
enum class | DITriggerType { Immediate = 0 , Digital = 1 , Soft = 3 }
TriggerType Digital/Immediate/Soft. More...
enum class DIDigitalTriggerSource {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PFI8 , PFI9 , PFI10 , PFI11 ,
PFI12 , PFI13 , PFI14 , PFI15 ,
PXI_Trig0 = 40 , PXI_Trig1 = 41 , PXI_Trig2 = 42 , PXI_Trig3 = 43 ,
PXI_Trig4 = 44 , PXI_Trig5 = 45 , PXI_Trig6 = 46 , PXI_Trig7 = 47 ,
AI_StartTrig = 16 , AI_ReferenceTrig = 17 , AO_StartTrig = 26 , DO_StartTrig = 29 ,
CI_0_StartTrig = 68 , CI_1_StartTrig = 73 , CI_2_StartTrig = 73 , CI_3_StartTrig = 73 ,
CO_0_StartTrig = 69 , CO_1_StartTrig = 74 , CO2_StartTrig = 77 , CO_3_StartTrig = 80 ,
CO_0_Output = 37 , CO_1_Output = 51 , CO_2_Output = 60 , CO_3_Output = 66
}
DI Digital trigger source. More...
enum class | DIDigitalTriggerEdge { Rising , Falling }
DI Digital Trigger Edge. More...
enum class | DOSampleClockSource { Internal , External }
DO Sample Clock Source. More...
enum class | DOMode { Single = 3 , Finite = 0 , ContinuousWrapping = 1 , ContinuousNoWrapping = 2 }
DOMode. More...
enum class | DODigitalTriggerEdge { Rising , Falling }
DO Digital Trigger Edge. More...
enum class DODigitalTriggerSource {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PFI8 , PFI9 , PFI10 , PFI11 ,
PFI12 , PFI13 , PFI14 , PFI15 ,
PXI_Trig0 = 40 , PXI_Trig1 = 41 , PXI_Trig2 = 42 , PXI_Trig3 = 43 ,
PXI_Trig4 = 44 , PXI_Trig5 = 45 , PXI_Trig6 = 46 , PXI_Trig7 = 47 ,
AI_StartTrig = 16 , AI_ReferenceTrig = 17 , AO_StartTrig = 26 , DI_StartTrig = 22 ,
DI_ReferenceTrig = 23 , CI_0_StartTrig = 68 , CI_1_StartTrig = 73 , CI_2_StartTrig = 76 ,
CI_3_StartTrig = 79 , CO_0_StartTrig = 69 , CO_1_StartTrig = 74 , CO_2_StartTrig = 77 ,
CO_3_StartTrig = 80 , CO_0_Output = 37 , CO_1_Output = 51 , CO_2_Output = 60 ,
CO_3_Output = 66
}
DO Digital trigger source. More...
enum class | DOTriggerType { Immediate = 0 , Digital = 1 , Soft = 3 }
TriggerType Digital/Immediate/Soft. More...
enum class | DOSignalExportSource { StartTrig = 29 , SampleClock = 54 }
SourceSignal. More...
enum class JYPCIe5111CoreOOLogLevel {
DEBUG_LOG_LEVEL , INFO_LOG_LEVEL , WARN_LOG_LEVEL , ERROR_LOG_LEVEL ,
FATAL_LOG_LEVEL
}

Functions

std::string GetSignalExportDestinationString (SignalExportDestination destination)

Enumeration Type Documentation

◆ AIAnalogTriggerComparator

enum class JYPCIe5111CoreOO::AIAnalogTriggerComparator
strong

AI Analog Trigger Comparator.

Enumerator
Edge | Edge Comparator.
Hysteresis | Hysteresis Comparator.
Window | Window Comparator.

◆ AIAnalogTriggerEdge

enum class JYPCIe5111CoreOO::AIAnalogTriggerEdge
strong

AI Analog Trigger Edge.

Enumerator
Rising | Rising.
Falling | Falling.

◆ AIAnalogTriggerSource

enum class JYPCIe5111CoreOO::AIAnalogTriggerSource
strong

AI analog trigger source.

Enumerator
Channel_0 | Channel_0 as the trigger source.
Channel_1 | Channel_1 as the trigger source.
Channel_2 | Channel_2 as the trigger source.
Channel_3 | Channel_3 as the trigger source.
Channel_4 | Channel_4 as the trigger source.
Channel_5 | Channel_5 as the trigger source.
Channel_6 | Channel_6 as the trigger source.
Channel_7 | Channel_7 as the trigger source.
Channel_8 | Channel_8 as the trigger source.
Channel_9 | Channel_9 as the trigger source.
Channel_10 | Channel_10 as the trigger source.
Channel_11 | Channel_11 as the trigger source.
Channel_12 | Channel_12 as the trigger source.
Channel_13 | Channel_13 as the trigger source.
Channel_14 | Channel_14 as the trigger source.
Channel_15 | Channel_15 as the trigger source.
Channel_16 | Channel_16 as the trigger source.
Channel_17 | Channel_17 as the trigger source.
Channel_18 | Channel_18 as the trigger source.
Channel_19 | Channe_l9 as the trigger source.
Channel_20 | Channel_20 as the trigger source.
Channel_21 | Channel_21 as the trigger source.
Channel_22 | Channel_22 as the trigger source.
Channel_23 | Channel_23 as the trigger source.
Channel_24 | Channel_24 as the trigger source.
Channel_25 | Channel_25 as the trigger source.
Channel_26 | Channel_26 as the trigger source.
Channel_27 | Channel_27 as the trigger source.
Channel_28 | Channel_28 as the trigger source.
Channel_29 | Channel_29 as the trigger source.
Channel_30 | Channel_30 as the trigger source.
Channel_31 | Channel_31 as the trigger source.

◆ AIAnalogWindowCondition

enum class JYPCIe5111CoreOO::AIAnalogWindowCondition
strong

AI Analog Window Trigger Condition.

Enumerator
Entering | Rising.
Leaving | Falling.

◆ AIDigitalTriggerEdge

enum class JYPCIe5111CoreOO::AIDigitalTriggerEdge
strong

AI Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ AIDigitalTriggerSource

enum class JYPCIe5111CoreOO::AIDigitalTriggerSource
strong

AI Digital trigger source.

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11.
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.
AO_StartTrig | AO_StartTrig.
DI_StartTrig | DI_StartTrig.
DI_ReferenceTrig | DI_ReferenceTrig.
DO_StartTrig | DO_StartTrig.
CI_0_StartTrig | CI0_StartTrig.
CI_1_StartTrig | CI1_StartTrig.
CI_2_StartTrig | CI2_StartTrig.
CI_3_StartTrig | CI3_StartTrig.
CO_0_StartTrig | CO0_StartTrig.
CO_1_StartTrig | CO0_StartTrig.
CO_2_StartTrig | CO0_StartTrig.
CO_3_StartTrig | CO0_StartTrig.
CO_0_Output | CO_0_Output.
CO_1_Output | CO_1_Output.
CO_2_Output | CO_2_Output.
CO_3_Output | CO_3_Output.

◆ AIMode

enum class JYPCIe5111CoreOO::AIMode
strong
Enumerator
Single
Finite
Continuous
Record

◆ AISampleClockSource

enum class JYPCIe5111CoreOO::AISampleClockSource
strong

AI Sample Clock Source.

Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ AISignalExportSource

enum class JYPCIe5111CoreOO::AISignalExportSource
strong

AI Signal Export Source.

Enumerator
AI_StartTrig | AI_StartTrig as the source signal to rout.
AI_ReferenceTrig | AI_ReferenceTrig as the source signal to rout.
DI_StartTrig | DI_StartTrig as the source signal to rout.
DI_ReferenceTrig | DI_ReferenceTrig as the source signal to rout.
AO_StartTrig | AO_StartTrig as the source signal to rout.
DO_StartTrig | DO_StartTrig as the source signal to rout.
CI_0_StartTrig | CI0_StartTrig as the source signal to rout.
CI_1_StartTrig | CI1_StartTrig as the source signal to rout.
CI_2_StartTrig | CI2_StartTrig as the source signal to rout.
CI_3_StartTrig | CI3_StartTrig as the source signal to rout.
CO_0_StartTrig | CO0_StartTrig as the source signal to rout.
CO_1_StartTrig | CO1_StartTrig as the source signal to rout.
CO_2_StartTrig | CO2_StartTrig as the source signal to rout.
CO_3_StartTrig | CO3_StartTrig as the source signal to rout.
AI_SampleClock | AI_SampleClock as the source signal to rout.
AO_SampleClock | AO_SampleClock as the source signal to rout.
DI_SampleClock | DI_SampleClock as the source signal to rout.
DO_SampleClock | DO_SampleClock as the source signal to rout.
CI_0_SampleClock | CI0_SampleClock as the source signal to rout.
CI_1_SampleClock | CI1_SampleClock as the source signal to rout.
CI_2_SampleClock | CI2_SampleClock as the source signal to rout.
CI_3_SampleClock | CI3_SampleClock as the source signal to rout.
CO_0_Output | CO_0_Output as the source signal to rout.
CO_1_Output | CO_1_Output as the source signal to rout.
CO_2_Output | CO_2_Output as the source signal to rout.
CO_3_Output | CO_3_Output as the source signal to rout.

◆ AITerminal

enum class JYPCIe5111CoreOO::AITerminal
strong
Enumerator
RSE
NRSE
Differential

◆ AITriggerMode

enum class JYPCIe5111CoreOO::AITriggerMode
strong

AI Trigger Mode.

Enumerator
Start | Start Trigger.
Reference | Reference Trigger，Valid when JYPCIe5111AITask.Mode is AIMode.Finite

◆ AITriggerType

enum class JYPCIe5111CoreOO::AITriggerType
strong

Trigger Type Digital/Analog/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Analog | Analog Trigger.
Soft | Soft Trigger.

◆ AODigitalTriggerEdge

enum class JYPCIe5111CoreOO::AODigitalTriggerEdge
strong

AO Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ AODigitalTriggerSource

enum class JYPCIe5111CoreOO::AODigitalTriggerSource
strong

AO Digital trigger source.

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11.
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
DI_StartTrig | DI_StartTrig.
DI_ReferenceTrig | DI_ReferenceTrig.
DO_StartTrig | DO_StartTrig.
CI_0_StartTrig | CI0_StartTrig.
CI_1_StartTrig | CI1_StartTrig.
CI_2_StartTrig | CI2_StartTrig.
CI_3_StartTrig | CI3_StartTrig.
CO_0_StartTrig | CO0_StartTrig.
CO_1_StartTrig | CO0_StartTrig.
CO_2_StartTrig | CO0_StartTrig.
CO_3_StartTrig | CO0_StartTrig.
CO_0_Output | CO_0_Output.
CO_1_Output | CO_1_Output.
CO_2_Output | CO_2_Output.
CO_3_Output | CO_3_Output.

◆ AOMode

enum class JYPCIe5111CoreOO::AOMode
strong
Enumerator
Single | Single.
Finite | Finite.
ContinuousNoWrapping | ContinuousNoWrapping.
ContinuousWrapping | ContinuousWrapping.

◆ AOSampleClockSource

enum class JYPCIe5111CoreOO::AOSampleClockSource
strong

AO Sample Clock Source.

Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ AOSignalExportSource

enum class JYPCIe5111CoreOO::AOSignalExportSource
strong

SourceSignal.

Enumerator
StartTrig | AO_StartTrig.
SampleClock | AO_SampleClock.

◆ AOTriggerType

enum class JYPCIe5111CoreOO::AOTriggerType
strong

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ CIDigitalTriggerEdge

enum class JYPCIe5111CoreOO::CIDigitalTriggerEdge
strong

CI Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ CIDigitalTriggerSource

enum class JYPCIe5111CoreOO::CIDigitalTriggerSource
strong

CI Digital trigger source.

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11.
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
AO_StartTrig | AO_StartTrig.
DI_StartTrig | DI_StartTrig.
DI_ReferenceTrig | DI_ReferenceTrig.
DO_StartTrig | DO_StartTrig.
CI_0_StartTrig | CI0_StartTrig.
CI_1_StartTrig | CI1_StartTrig.
CI_2_StartTrig | CI2_StartTrig.
CI_3_StartTrig | CI3_StartTrig.
CO_0_StartTrig | CO0_StartTrig.
CO_1_StartTrig | CO0_StartTrig.
CO_2_StartTrig | CO0_StartTrig.
CO_3_StartTrig | CO0_StartTrig.
CO_0_Output | CO_0_Output.
CO_1_Output | CO_1_Output.
CO_2_Output | CO_2_Output.
CO_3_Output | CO_3_Output.

◆ CIMode

enum class JYPCIe5111CoreOO::CIMode
strong

CIMode.

Enumerator
Single | Single.
Finite | Finite.
Continuous | Continuous.

◆ CISampleClockSource

enum class JYPCIe5111CoreOO::CISampleClockSource
strong

CI Sample Clock Source.

Enumerator
Implicit | Implicit.
Internal | Internal.
External | External.

◆ CISignalExportSource

enum class JYPCIe5111CoreOO::CISignalExportSource
strong

SourceSignal.

Enumerator
StartTrig | CI_StartTrig.
SampleClock | CI_SampleClock.

◆ CITimebaseSource

enum class JYPCIe5111CoreOO::CITimebaseSource
strong

Timebase source.

Enumerator
Internal200MHz

Internal 200MHz Timebase.

◆ CITriggerType

enum class JYPCIe5111CoreOO::CITriggerType
strong

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ CIType

enum class JYPCIe5111CoreOO::CIType
strong

Counter Input Application Type.

Enumerator
EdgeCounting | Edge Counting.
Period | Period Measure.
Frequency | Frequenc Measure.
Pulse | Pulse Measure.
TwoEdgeSeparation | TwoEdgeSeparation Measure.
QuadEncoder | QuadEncoder.
TwoPulseEncoder | EncoderTwoPulse.

◆ ClockTerminal

enum class JYPCIe5111CoreOO::ClockTerminal
strong
Enumerator
ECLK | Extetnal Clock Terminal by Pin Define.
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11.
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PXI_Trig0 | PXITrigger_0.
PXI_Trig1 | PXITrigger_1.
PXI_Trig2 | PXITrigger_2.
PXI_Trig3 | PXITrigger_3.
PXI_Trig4 | PXITrigger_4.
PXI_Trig5 | PXITrigger_5.
PXI_Trig6 | PXITrigger_6.
PXI_Trig7 | PXITrigger_7.
AI_SampleClock | AI_SampleClock.
AO_SampleClock | AO_SampleClock.
DI_SampleClock | DI_SampleClock.
DO_SampleClock | DO_SampleClock.
CI0_SampleClock | CI0_SampleClock.
CI1_SampleClock | CI1_SampleClock.
CI2_SampleClock | CI2_SampleClock.
CI3_SampleClock | CI3_SampleClock.
CO_0_Output | CO_0_Output.
CO_1_Output | CO_1_Output.
CO_2_Output | CO_2_Output.
CO_3_Output | CO_3_Output.

◆ CODigitalTriggerEdge

enum class JYPCIe5111CoreOO::CODigitalTriggerEdge
strong

CO Digital Trigger Edge.

Enumerator
Rising | Rising Edge.
Falling | Falling Edge.

◆ CODigitalTriggerSource

enum class JYPCIe5111CoreOO::CODigitalTriggerSource
strong

CO Digital trigger source.

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11.
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
AO_StartTrig | AO_StartTrig.
DI_StartTrig | DI_StartTrig.
DI_ReferenceTrig | DI_ReferenceTrig.
DO_StartTrig | DO_StartTrig.
CI_0_StartTrig | CI0_StartTrig.
CI_1_StartTrig | CI1_StartTrig.
CI_2_StartTrig | CI2_StartTrig.
CI_3_StartTrig | CI3_StartTrig.
CO_0_StartTrig | CO0_StartTrig.
CO_1_StartTrig | CO0_StartTrig.
CO_2_StartTrig | CO0_StartTrig.
CO_3_StartTrig | CO0_StartTrig.

◆ COIdleState

enum class JYPCIe5111CoreOO::COIdleState
strong

Idle state when pulse output before start and after stop.

Enumerator
HighLevel | Idle state is high level.
LowLevel | Idle state is low level.

◆ COMode

enum class JYPCIe5111CoreOO::COMode
strong
Enumerator
Single | Single pulse output.
Finite | Finite.
ContinuousNoWrapping | ContinuousNoWrapping.
ContinuousWrapping | ContinuousWrapping.

◆ COPulseType

enum class JYPCIe5111CoreOO::COPulseType
strong

Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick.

Enumerator
DutyCycleFrequency | Configure CO output pulse according to its DutyCycle and Freqency.
HighLowTime | Configure CO output pulse according to duration of its high/low voltage levels.
HighLowTick | Configure CO output pulse according to its high/low tick level.

◆ COSignalExportSource

enum class JYPCIe5111CoreOO::COSignalExportSource
strong

SourceSignal.

Enumerator
StartTrig | CI_StartTrig.
Output | CO_Output.

◆ COTimebaseSource

enum class JYPCIe5111CoreOO::COTimebaseSource
strong

Timebase source.

Enumerator
Internal200MHz

Internal 200MHz Timebase.

◆ COTriggerType

enum class JYPCIe5111CoreOO::COTriggerType
strong

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ CountDirection

enum class JYPCIe5111CoreOO::CountDirection
strong

Counter direction.

enum Up/Down/External

Enumerator
Up | Counter increases.
Down | Counter decreases.
External | External signal control counter direction. If External signal is highlevel counter increases, or lowlevel counter decreases.

◆ DIDigitalTriggerEdge

enum class JYPCIe5111CoreOO::DIDigitalTriggerEdge
strong

DI Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ DIDigitalTriggerSource

enum class JYPCIe5111CoreOO::DIDigitalTriggerSource
strong

DI Digital trigger source.

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11.
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
AO_StartTrig | AO_StartTrig.
DO_StartTrig | DO_StartTrig.
CI_0_StartTrig | CI0_StartTrig.
CI_1_StartTrig | CI1_StartTrig.
CI_2_StartTrig | CI2_StartTrig.
CI_3_StartTrig | CI3_StartTrig.
CO_0_StartTrig | CO0_StartTrig.
CO_1_StartTrig | CO0_StartTrig.
CO2_StartTrig | CO0_StartTrig.
CO_3_StartTrig | CO0_StartTrig.
CO_0_Output | CO_0_Output.
CO_1_Output | CO_1_Output.
CO_2_Output | CO_2_Output.
CO_3_Output | CO_3_Output.

◆ DIMode

enum class JYPCIe5111CoreOO::DIMode
strong

DIMode.

Enumerator
Single | Single.
Finite | Finite.
Continuous | Continuous.

◆ DISampleClockSource

enum class JYPCIe5111CoreOO::DISampleClockSource
strong

DI Sample Clock Source.

Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ DISignalExportSource

enum class JYPCIe5111CoreOO::DISignalExportSource
strong

SourceSignal.

Enumerator
StartTrig | DI_StartTrig.
ReferenceTrig | DI_ReferenceTrig.
SampleClock | DI_SampleClock.

◆ DITriggerMode

enum class JYPCIe5111CoreOO::DITriggerMode
strong

DI Trigger Mode.

Enumerator
Start | Start Trigger.
Reference | Reference Trigger，only for finite acquisition mode.

◆ DITriggerType

enum class JYPCIe5111CoreOO::DITriggerType
strong

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ DODigitalTriggerEdge

enum class JYPCIe5111CoreOO::DODigitalTriggerEdge
strong

DO Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ DODigitalTriggerSource

enum class JYPCIe5111CoreOO::DODigitalTriggerSource
strong

DO Digital trigger source.

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11.
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
AO_StartTrig | AO_StartTrig.
DI_StartTrig | DI_StartTrig.
DI_ReferenceTrig | DI_ReferenceTrig.
CI_0_StartTrig | CI0_StartTrig.
CI_1_StartTrig | CI1_StartTrig.
CI_2_StartTrig | CI2_StartTrig.
CI_3_StartTrig | CI3_StartTrig.
CO_0_StartTrig | CO0_StartTrig.
CO_1_StartTrig | CO0_StartTrig.
CO_2_StartTrig | CO0_StartTrig.
CO_3_StartTrig | CO0_StartTrig.
CO_0_Output | CO_0_Output.
CO_1_Output | CO_1_Output.
CO_2_Output | CO_2_Output.
CO_3_Output | CO_3_Output.

◆ DOMode

enum class JYPCIe5111CoreOO::DOMode
strong

DOMode.

Enumerator
Single | Single.
Finite | Finite.
ContinuousWrapping | ContinuousNoWrapping.
ContinuousNoWrapping | ContinuousWrapping.

◆ DOSampleClockSource

enum class JYPCIe5111CoreOO::DOSampleClockSource
strong

DO Sample Clock Source.

Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ DOSignalExportSource

enum class JYPCIe5111CoreOO::DOSignalExportSource
strong

SourceSignal.

Enumerator
StartTrig | DO_StartTrig.
SampleClock | DO_SampleClock.

◆ DOTriggerType

enum class JYPCIe5111CoreOO::DOTriggerType
strong

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ EdgeCntOunEvtIdleState

enum class JYPCIe5111CoreOO::EdgeCntOunEvtIdleState
strong

Output idle state when the event has not occurred.

Enumerator
LowLevel | Idle state is low level.
HighLevel | Idle state is high level.

◆ EdgeType

enum class JYPCIe5111CoreOO::EdgeType
strong

Edge Type.

Enumerator
Rising | Rising Edge.
Falling | Falling Edge.

◆ ExternalReferenceClockTerminal

enum class JYPCIe5111CoreOO::ExternalReferenceClockTerminal
strong
Enumerator
PXIe_Clk100

PXIe_Clk100.

◆ FileFormat

enum class JYPCIe5111CoreOO::FileFormat
strong

Streaming file format.

enum BIN.

Enumerator
Bin

BIN。

BIN.

◆ InputTerminal

enum class JYPCIe5111CoreOO::InputTerminal
strong

Cunter Input Terminal.

Enumerator
Default | Default PFI pin by pin define.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
CI_0_OutPut | CI0_StartTrig.
CI_1_OutPut | CI1_StartTrig.
CI_2_OutPut | CI0_StartTrig.
CI_3_OutPut | CI1_StartTrig.

◆ IOTerminal

enum class JYPCIe5111CoreOO::IOTerminal
strong

Cunter IO Terminal.

Enumerator
Default | Default PFI pin by pin define.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.

◆ JYDriverExceptionPublic

enum class JYPCIe5111CoreOO::JYDriverExceptionPublic
strong
Enumerator
UnKnown | JYDriverExceptionPublic.
OpenDeviceFailed | JYDriverExceptionPublic.
CloseDeviceFailed | JYDriverExceptionPublic.
ResetDeviceFailed | JYDriverExceptionPublic.
GetDevicePropertyFailed | JYDriverExceptionPublic.
SetDevicePropertyFailed | JYDriverExceptionPublic.
HardwareResourceIsReserved | JYDriverExceptionPublic.
MethodNotPermitedToCallWhenCurrentStatus | JYDriverExceptionPublic.
InvalidUserDataBuffer | JYDriverExceptionPublic.
NoChannelAdded | JYDriverExceptionPublic.
NotSupportOperationForCurrentDevice | JYDriverExceptionPublic.
CreatTaskFailed | JYDriverExceptionPublic.
StartTaskFailed | JYDriverExceptionPublic.
StopTaskFailed | JYDriverExceptionPublic.
TaskHasNotStarted | JYDriverExceptionPublic.
TaskHasStartedCannotPerformTheSetOperation | JYDriverExceptionPublic.
ChannelNumberParameterInvalid | JYDriverExceptionPublic.
ChannelInputRangeParameterInvalid | JYDriverExceptionPublic.
ChannelTerminalParameterInvalid | JYDriverExceptionPublic.
ChannelCouplingParameterInvalid | JYDriverExceptionPublic.
SampeleModeParameterInvalid | JYDriverExceptionPublic.
SampleClockParameterInvalid | JYDriverExceptionPublic.
SampleRateParameterInvalid | JYDriverExceptionPublic.
UpdateRateParameterInvalid | JYDriverExceptionPublic.
TriggerParameterInvalid | JYDriverExceptionPublic.
ReferenceTriggerDoesNotMatchWithSampleMode | JYDriverExceptionPublic.
PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint | JYDriverExceptionPublic.
ReadDataFailed | JYDriverExceptionPublic.
ReadDataTimeout | JYDriverExceptionPublic.
WriteDataFailed | JYDriverExceptionPublic.
WriteDataTimeout | JYDriverExceptionPublic.
WriteDataLengthCannotBeLessThanN | JYDriverExceptionPublic.
BufferDataOverflow | JYDriverExceptionPublic.
BufferDataDownflow | JYDriverExceptionPublic.
CheckBufferFailed | JYDriverExceptionPublic.
PointInvalidInFiniteMode | JYDriverExceptionPublic.
ReadPointInvalid | JYDriverExceptionPublic.
OnlySupportRecordMode | JYDriverExceptionPublic.
SendSoftTirggerFailed | JYDriverExceptionPublic.
TaskTimeout | JYDriverExceptionPublic.
CounterParametersInvalid | JYDriverExceptionPublic.
WritePointInvalid | JYDriverExceptionPublic.
SignalExportDestinationInvalid | JYDriverExceptionPublic.
InvalidParameter | 无效参数。 Invaild parameter.

◆ JYPCIe5111CoreOOLogLevel

enum class JYPCIe5111CoreOO::JYPCIe5111CoreOOLogLevel
strong
Enumerator
DEBUG_LOG_LEVEL
INFO_LOG_LEVEL
WARN_LOG_LEVEL
ERROR_LOG_LEVEL
FATAL_LOG_LEVEL

◆ JYPCIe5111CoreOOPropertyType

enum class JYPCIe5111CoreOO::JYPCIe5111CoreOOPropertyType
strong
Enumerator
READ_ONLY
WRITE_ONLY
READ_WRITE

◆ LevelPolarity

enum class JYPCIe5111CoreOO::LevelPolarity
strong

Level Polarity.

Enumerator
LowLevel | Low level.
HighLevel | High level.
None | No active polarity.

◆ OutputCompleteState

enum class JYPCIe5111CoreOO::OutputCompleteState
strong

Output Complete State.

Enumerator
Zero | Output Complete Zero.
Hold | Output Complete Hold in The last point.

◆ PFITerminal

enum class JYPCIe5111CoreOO::PFITerminal
strong

Input/Output Terminal of PFI.

Enumerator
PFI0 | PFI 0.
PFI1 | PFI 1.
PFI2 | PFI 2.
PFI3 | PFI 3.
PFI4 | PFI 4.
PFI5 | PFI 5.
PFI6 | PFI 6.
PFI7 | PFI 7.
PFI8 | PFI 8.
PFI9 | PFI 9.
PFI10 | PFI 10.
PFI11 | PFI 11.
PFI12 | PFI 12.
PFI13 | PFI 13.
PFI14 | PFI 14.
PFI15 | PFI 15.

◆ PowerLineFrequency

enum class JYPCIe5111CoreOO::PowerLineFrequency
strong
Enumerator
_50Hz | 50 Hz AC Power Frequency
_60Hz | 60 Hz AC Power Frequency

◆ QuadEncodingType

enum class JYPCIe5111CoreOO::QuadEncodingType
strong

Quadrature Encoding Type.

Enumerator
X1 | X1.
X2 | X2.
X4 | X4.

◆ RecordMode

enum class JYPCIe5111CoreOO::RecordMode
strong

stream mode .enum Finite/Infinite

Enumerator
Finite | Finite Streaming.
Infinite | Infinite Streaming.

◆ ReferenceClockSource

enum class JYPCIe5111CoreOO::ReferenceClockSource
strong
Enumerator
Internal | Internal on board 25MHz Clock.
External | External Reference Clock Source.

◆ SignalExportDestination

enum class JYPCIe5111CoreOO::SignalExportDestination
strong
Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11.
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.

Function Documentation

◆ GetSignalExportDestinationString()

std::string JYPCIe5111CoreOO::GetSignalExportDestinationString ( SignalExportDestination destination )
inline


5111 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOAOTask.h File Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 5111
Classes | Namespaces | Enumerations
JYPCIe5111CoreOOAOTask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JYPCIe5111CoreOOCommon.h"
#include "JYPCIe5111CoreOODevice.h"

Classes

class | JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask
class | JYPCIe5111CoreOO::AOChannel
class | JYPCIe5111CoreOO::AOExternalSampleClock
External Sample Clock Configuration Class. More...
class | JYPCIe5111CoreOO::AOSampleClock
AO Sample clock configuration class. More...
class | JYPCIe5111CoreOO::AOTrigger
Constructor to create an AOTrigger task object. More...
class | JYPCIe5111CoreOO::AODigitalTrigger
AO Digital trigger . More...

Namespaces

namespace JYPCIe5111CoreOO

Enumerations

enum class | JYPCIe5111CoreOO::AOMode { JYPCIe5111CoreOO::Single = 3 , JYPCIe5111CoreOO::Finite = 0 , JYPCIe5111CoreOO::ContinuousNoWrapping = 2 , JYPCIe5111CoreOO::ContinuousWrapping = 1 }
enum class | JYPCIe5111CoreOO::AODigitalTriggerEdge { JYPCIe5111CoreOO::Rising , JYPCIe5111CoreOO::Falling }
AO Digital Trigger Edge. More...
enum class JYPCIe5111CoreOO::AODigitalTriggerSource {
JYPCIe5111CoreOO::PFI0 , JYPCIe5111CoreOO::PFI1 , JYPCIe5111CoreOO::PFI2 , JYPCIe5111CoreOO::PFI3 ,
JYPCIe5111CoreOO::PFI4 , JYPCIe5111CoreOO::PFI5 , JYPCIe5111CoreOO::PFI6 , JYPCIe5111CoreOO::PFI7 ,
JYPCIe5111CoreOO::PFI8 , JYPCIe5111CoreOO::PFI9 , JYPCIe5111CoreOO::PFI10 , JYPCIe5111CoreOO::PFI11 ,
JYPCIe5111CoreOO::PFI12 , JYPCIe5111CoreOO::PFI13 , JYPCIe5111CoreOO::PFI14 , JYPCIe5111CoreOO::PFI15 ,
JYPCIe5111CoreOO::PXI_Trig0 = 40 , JYPCIe5111CoreOO::PXI_Trig1 = 41 , JYPCIe5111CoreOO::PXI_Trig2 = 42 , JYPCIe5111CoreOO::PXI_Trig3 = 43 ,
JYPCIe5111CoreOO::PXI_Trig4 = 44 , JYPCIe5111CoreOO::PXI_Trig5 = 45 , JYPCIe5111CoreOO::PXI_Trig6 = 46 , JYPCIe5111CoreOO::PXI_Trig7 = 47 ,
JYPCIe5111CoreOO::AI_StartTrig = 16 , JYPCIe5111CoreOO::AI_ReferenceTrig = 17 , JYPCIe5111CoreOO::DI_StartTrig = 22 , JYPCIe5111CoreOO::DI_ReferenceTrig = 23 ,
JYPCIe5111CoreOO::DO_StartTrig = 29 , JYPCIe5111CoreOO::CI_0_StartTrig = 68 , JYPCIe5111CoreOO::CI_1_StartTrig = 73 , JYPCIe5111CoreOO::CI_2_StartTrig = 76 ,
JYPCIe5111CoreOO::CI_3_StartTrig = 79 , JYPCIe5111CoreOO::CO_0_StartTrig = 69 , JYPCIe5111CoreOO::CO_1_StartTrig = 74 , JYPCIe5111CoreOO::CO_2_StartTrig = 77 ,
JYPCIe5111CoreOO::CO_3_StartTrig = 80 , JYPCIe5111CoreOO::CO_0_Output = 37 , JYPCIe5111CoreOO::CO_1_Output = 51 , JYPCIe5111CoreOO::CO_2_Output = 60 ,
JYPCIe5111CoreOO::CO_3_Output = 66
}
AO Digital trigger source. More...
enum class | JYPCIe5111CoreOO::AOSampleClockSource { JYPCIe5111CoreOO::Internal , JYPCIe5111CoreOO::External }
AO Sample Clock Source. More...
enum class | JYPCIe5111CoreOO::AOSignalExportSource { JYPCIe5111CoreOO::StartTrig = 26 , JYPCIe5111CoreOO::SampleClock = 28 }
SourceSignal. More...
enum class | JYPCIe5111CoreOO::AOTriggerType { JYPCIe5111CoreOO::Immediate = 0x0 , JYPCIe5111CoreOO::Digital = 0x1 , JYPCIe5111CoreOO::Soft = 0x3 }
TriggerType Digital/Immediate/Soft. More...


5111 C++ Programming Manual: JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • JYPCIe5111CoreOOAOTask
Public Member Functions | Public Attributes | List of all members
JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask Class Reference

#include <JYPCIe5111CoreOOAOTask.h>

Public Member Functions

JYPCIe5111CoreOOAOTask (int slotNum)
JYPCIe5111CoreOOAOTask (std::string boardName)
~JYPCIe5111CoreOOAOTask ()
void | AddChannel (int chnId, double rangeLow=-10, double rangeHigh=10)
Add one channel.
void | AddChannel (std::vector< int > chnsId, double rangeLow=-10, double rangeHigh=10)
Add a group of channels.
void | AddChannel (std::vector< int > chnsId, std::vector< double > rangeLow, std::vector< double > rangeHigh)
Add a group of channels.
void | RemoveChannel (int chnId)
Delete the specified channel number.
void | WriteData (double *pBuf, int samplesPerChannel, int timeout=10000)
Write to AO buffer one or multi-channel data.
void | WriteData (std::vector< double > &pBuf, int samplesPerChannel, int timeout=10000)
Write to AO buffer one or multi-channel data.
void | WriteRawData (int16_t *pBuf, int samplesPerChannel, int timeout=10000)
Write to AO buffer one or multi-channel raw data.
void | WriteRawData (std::vector< int16_t > &pBuf, int samplesPerChannel, int timeout=10000)
Write to AO buffer one or multi-channel raw data.
void | WriteSinglePoint (std::vector< double > writeValues)
write one sample to all channels in register .
void | WriteSinglePoint (double writeValue, int channel)
Write one sample to the specified channel in register.Available when Mode is AOMode.Single
void | WriteRawSinglePoint (std::vector< int16_t > writeValues)
write one raw sample to all channels in register .
void | WriteRawSinglePoint (int16_t writeValue, int channel)
Write one raw sample to the specified channel in register.Available when Mode is AOMode.Single
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.
void | Start ()
Start AO task .
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Stop ()
Stop AO task .

Public Attributes

std::list< AOChannel * > | Channels
List of AI channels,(5111 support 2 channels)
AOMode Mode
Mode of AO Task.
JYPCIe5111CoreOOProperty< JYPCIe5111CoreOOAOTask, double, JYPCIe5111CoreOOPropertyType::READ_WRITE > | UpdateRate
Update rate per channel.
int | SamplesToUpdate
Number of output samples to write per channel , Only valid when Mode is AOMode.Finite.
JYPCIe5111CoreOOProperty< JYPCIe5111CoreOOAOTask, int, JYPCIe5111CoreOOPropertyType::READ_ONLY > | BufLenInSamples
Number of samples per channel can be storage in the buffer, the PropretySamplesToUpdate must be less than or equal to this value.
JYPCIe5111CoreOOProperty< JYPCIe5111CoreOOAOTask, uint32_t, JYPCIe5111CoreOOPropertyType::READ_ONLY > | AvaliableLenInSamples
Number of output samples per channel that can be write in AO buffuer.
OutputCompleteState CompleteState
AO Output Complete State, Valid when Mode is NOT OMode.Single.
JYPCIe5111CoreOOProperty< JYPCIe5111CoreOOAOTask, uint64_t, JYPCIe5111CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
AOSampleClock * SampleClock
AO Sample Clock Configuration.
AOTrigger * Trigger
AO Trigger Configuration.
AOSignalExport * | SignalExport
Export AO Signal.
JYPCIe5111CoreOODevice * Device

Constructor & Destructor Documentation

◆ JYPCIe5111CoreOOAOTask() [1/2]

JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask::JYPCIe5111CoreOOAOTask ( int slotNum )

◆ JYPCIe5111CoreOOAOTask() [2/2]

JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask::JYPCIe5111CoreOOAOTask ( std::string boardName )

◆ ~JYPCIe5111CoreOOAOTask()

JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask::~JYPCIe5111CoreOOAOTask ( )

Member Function Documentation

◆ AddChannel() [1/3]

void JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask::AddChannel | ( | int | chnId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10 )

Add one channel.

Parameters
chnId | channel's physical number ，chnId=-1, add all channels。（5111 support 4 channels）
rangeLow | lower range limit for the channel，-10V,-5V defalut -10
rangeHigh | higher range limit for the channel，10V,5V defalut 10

◆ AddChannel() [2/3]

void JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask::AddChannel | ( | std::vector< int > | chnsId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10 )

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers。（5111 support 4 channels）
rangeLow | lower range limit for the channel，-10V,-5V defalut -10
rangeHigh | higher range limit for the channel，10V,5V defalut 10

◆ AddChannel() [3/3]

void JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask::AddChannel | ( | std::vector< int > | chnsId,
 |  | std::vector< double > | rangeLow,
 |  | std::vector< double > | rangeHigh )

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers。（5111 support 4 channels）
rangeLow | lower range limit for the channel，-10V,-5V
rangeHigh | higher range limit for the channel，10V,5V

◆ RemoveChannel()

void JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask::RemoveChannel ( int chnId )

Delete the specified channel number.

If it is -1, delete all channels.

Parameters
chnId Specified channel ID.

◆ SendSoftwareTrigger()

void JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask::SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask::Start ( )

Start AO task .

◆ Stop()

void JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask::Stop ( )

Stop AO task .

◆ WaitUntilDone()

bool JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask::WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Available when Mode is AOMode.Finite

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteData() [1/2]

void JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask::WriteData | ( | double * | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Write to AO buffer one or multi-channel data.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | data buffer.
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [2/2]

void JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask::WriteData | ( | std::vector< double > & | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Write to AO buffer one or multi-channel data.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | data buffer.
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawData() [1/2]

void JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask::WriteRawData | ( | int16_t * | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Write to AO buffer one or multi-channel raw data.

Parameters
buf | data buffer.
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawData() [2/2]

void JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask::WriteRawData | ( | std::vector< int16_t > & | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Write to AO buffer one or multi-channel raw data.

Parameters
buf | data buffer.
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawSinglePoint() [1/2]

void JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask::WriteRawSinglePoint | ( | int16_t | writeValue,
 |  | int | channel )

Write one raw sample to the specified channel in register.Available when Mode is AOMode.Single

Parameters
writeValue | Write value.
channel | Specified channel.

◆ WriteRawSinglePoint() [2/2]

void JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask::WriteRawSinglePoint ( std::vector< int16_t > writeValues )

write one raw sample to all channels in register .

Available when Mode is AOMode.Single

Parameters
writeValues Write values. Array length >= Channels.Count.

◆ WriteSinglePoint() [1/2]

void JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask::WriteSinglePoint | ( | double | writeValue,
 |  | int | channel )

Write one sample to the specified channel in register.Available when Mode is AOMode.Single

Parameters
writeValue | Write value.
channel | Specified channel.

◆ WriteSinglePoint() [2/2]

void JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask::WriteSinglePoint ( std::vector< double > writeValues )

write one sample to all channels in register .

Available when Mode is AOMode.Single

Parameters
writeValues Write values. Array length >= Channels.Count.

Member Data Documentation

◆ AvaliableLenInSamples

JYPCIe5111CoreOOProperty<JYPCIe5111CoreOOAOTask, uint32_t, JYPCIe5111CoreOOPropertyType::READ_ONLY> JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask::AvaliableLenInSamples

Number of output samples per channel that can be write in AO buffuer.

◆ BufLenInSamples

JYPCIe5111CoreOOProperty<JYPCIe5111CoreOOAOTask, int, JYPCIe5111CoreOOPropertyType::READ_ONLY> JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask::BufLenInSamples

Number of samples per channel can be storage in the buffer, the PropretySamplesToUpdate must be less than or equal to this value.

◆ Channels

std::list<AOChannel*> JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask::Channels

List of AI channels,(5111 support 2 channels)

◆ CompleteState

OutputCompleteState JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask::CompleteState

AO Output Complete State, Valid when Mode is NOT OMode.Single.

Default is Zero.

◆ Device

JYPCIe5111CoreOODevice* JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask::Device

◆ Mode

AOMode JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask::Mode

Mode of AO Task.

Select AO Mode from enum:ContinuousNoWrapping/ContinuousWrapping/Finite/Single.

◆ SampleClock

AOSampleClock* JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask::SampleClock

AO Sample Clock Configuration.

◆ SamplesToUpdate

int JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask::SamplesToUpdate

Number of output samples to write per channel , Only valid when Mode is AOMode.Finite.

◆ SignalExport

AOSignalExport* JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask::SignalExport

Export AO Signal.

◆ TransferedSamples

JYPCIe5111CoreOOProperty<JYPCIe5111CoreOOAOTask, uint64_t, JYPCIe5111CoreOOPropertyType::READ_ONLY> JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT AOMode.Single.

◆ Trigger

AOTrigger* JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask::Trigger

AO Trigger Configuration.

◆ UpdateRate

JYPCIe5111CoreOOProperty<JYPCIe5111CoreOOAOTask, double, JYPCIe5111CoreOOPropertyType::READ_WRITE> JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask::UpdateRate

Update rate per channel.

Maximum update rate is 2.86M for single channel, 2M for two channels, 1.54M for three channels, 1.25M for four channels. The defalut sample rate = 1000000 You can read this property to obtain the update rate that will actually take effect in the current configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOAOTask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::AOChannel Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • AOChannel
Public Member Functions | Public Attributes | List of all members
JYPCIe5111CoreOO::AOChannel Class Reference

#include <JYPCIe5111CoreOOAOTask.h>

Public Member Functions

AOChannel (int channelId, double rangeLow, double rangeHigh)

Public Attributes

int | ChannelID
double | RangeLow
double | RangeHigh

Constructor & Destructor Documentation

◆ AOChannel()

JYPCIe5111CoreOO::AOChannel::AOChannel | ( | int | channelId,
 |  | double | rangeLow,
 |  | double | rangeHigh )
 inline

Member Data Documentation

◆ ChannelID

int JYPCIe5111CoreOO::AOChannel::ChannelID

◆ RangeHigh

double JYPCIe5111CoreOO::AOChannel::RangeHigh

◆ RangeLow

double JYPCIe5111CoreOO::AOChannel::RangeLow
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOAOTask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::AOExternalSampleClock Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • AOExternalSampleClock
Public Attributes | List of all members
JYPCIe5111CoreOO::AOExternalSampleClock Class Reference

External Sample Clock Configuration Class. More...

#include <JYPCIe5111CoreOOAOTask.h>

Public Attributes

ClockTerminal Terminal
External Sample Clock Input Terminal.
double ExpectedRate
Expected External Sample Clock Rate.

Detailed Description

External Sample Clock Configuration Class.

Member Data Documentation

◆ ExpectedRate

double JYPCIe5111CoreOO::AOExternalSampleClock::ExpectedRate

Expected External Sample Clock Rate.

◆ Terminal

ClockTerminal JYPCIe5111CoreOO::AOExternalSampleClock::Terminal

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOAOTask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::AOSampleClock Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • AOSampleClock
Public Attributes | Friends | List of all members
JYPCIe5111CoreOO::AOSampleClock Class Reference

AO Sample clock configuration class. More...

#include <JYPCIe5111CoreOOAOTask.h>

Public Attributes

AOSampleClockSource Source
Clock Source.
AOExternalSampleClock * External
External Sample Clock Configuration,Valid when Source is AOSampleClockSource::External.

Friends

class JYPCIe5111CoreOOAOTask

Detailed Description

AO Sample clock configuration class.

Friends And Related Symbol Documentation

◆ JYPCIe5111CoreOOAOTask

friend class JYPCIe5111CoreOOAOTask
friend

Member Data Documentation

◆ External

AOExternalSampleClock* JYPCIe5111CoreOO::AOSampleClock::External

External Sample Clock Configuration,Valid when Source is AOSampleClockSource::External.

◆ Source

AOSampleClockSource JYPCIe5111CoreOO::AOSampleClock::Source

Clock Source.

enum Internal/External,The default value is AOSampleClockSource.Internal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOAOTask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::AOTrigger Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • AOTrigger
Public Attributes | List of all members
JYPCIe5111CoreOO::AOTrigger Class Reference

Constructor to create an AOTrigger task object. More...

#include <JYPCIe5111CoreOOAOTask.h>

Public Attributes

AOTriggerType Type
AO trigger type.
AODigitalTrigger * Digital
AO Digital Trigger.

Detailed Description

Constructor to create an AOTrigger task object.

Used to build AO Trigger

Member Data Documentation

◆ Digital

AODigitalTrigger* JYPCIe5111CoreOO::AOTrigger::Digital

AO Digital Trigger.

Valid when Type is AOTriggerType.Digital.

◆ Type

AOTriggerType JYPCIe5111CoreOO::AOTrigger::Type

AO trigger type.

enum Immediate/Digital/Soft.The default value is AOTriggerType.Immediate.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOAOTask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::AODigitalTrigger Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • AODigitalTrigger
Public Attributes | List of all members
JYPCIe5111CoreOO::AODigitalTrigger Class Reference

AO Digital trigger . More...

#include <JYPCIe5111CoreOOAOTask.h>

Public Attributes

AODigitalTriggerSource Source
AO Digital Trigger source.
AODigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Detailed Description

AO Digital trigger .

Member Data Documentation

◆ Edge

AODigitalTriggerEdge JYPCIe5111CoreOO::AODigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

AODigitalTriggerSource JYPCIe5111CoreOO::AODigitalTrigger::Source

AO Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOAOTask.h


5111 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOCITask.h File Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 5111
Classes | Namespaces | Enumerations
JYPCIe5111CoreOOCITask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JYPCIe5111CoreOOCommon.h"
#include "JYPCIe5111CoreOODevice.h"

Classes

class | JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
class | JYPCIe5111CoreOO::CIInternalSampleClock
CI Internal Sample Clock Configuration Class. More...
class | JYPCIe5111CoreOO::CIImplicitSampleClock
CI Implicit Sample Clock class. More...
class | JYPCIe5111CoreOO::CIExternalSampleClock
CI Implicit Sample Clock class. More...
class | JYPCIe5111CoreOO::CISampleClock
CI Sample Clock class. More...
class | JYPCIe5111CoreOO::EdgeCounting
Configure CI EdgeCounting. More...
class | JYPCIe5111CoreOO::FrequencyMeas
Configure CI Measure. More...
class | JYPCIe5111CoreOO::PeriodMeas
Configure CI Measure. More...
class | JYPCIe5111CoreOO::PulseMeas
Configure CI Measure. More...
class | JYPCIe5111CoreOO::TwoEdgeSeparation
Configure CI Measure. More...
class | JYPCIe5111CoreOO::QuadEncoder
Configure CI Measure. More...
class | JYPCIe5111CoreOO::TwoPulseEncoder
Configure CI Measure. More...
class | JYPCIe5111CoreOO::CITrigger
Constructor to create an CITrigger task object. More...
class | JYPCIe5111CoreOO::CIDigitalTrigger
CI Digital trigger . More...
class | JYPCIe5111CoreOO::EdgeCountingOutEvent
Edge counting output event configuration class. More...
class | JYPCIe5111CoreOO::CITimebase
Timebase configuration class. More...
class | JYPCIe5111CoreOO::CISignalExport
CI Signal Export Class. More...

Namespaces

namespace JYPCIe5111CoreOO

Enumerations

enum class | JYPCIe5111CoreOO::CountDirection { JYPCIe5111CoreOO::Up = 0x0 , JYPCIe5111CoreOO::Down = 0x1 , JYPCIe5111CoreOO::External = 0x2 }
Counter direction. More...
enum class | JYPCIe5111CoreOO::CIMode { JYPCIe5111CoreOO::Single = 2 , JYPCIe5111CoreOO::Finite = 0 , JYPCIe5111CoreOO::Continuous = 1 }
CIMode. More...
enum class JYPCIe5111CoreOO::CIType {
JYPCIe5111CoreOO::EdgeCounting , JYPCIe5111CoreOO::Period , JYPCIe5111CoreOO::Frequency , JYPCIe5111CoreOO::Pulse ,
JYPCIe5111CoreOO::TwoEdgeSeparation , JYPCIe5111CoreOO::QuadEncoder , JYPCIe5111CoreOO::TwoPulseEncoder
}
Counter Input Application Type. More...
enum class | JYPCIe5111CoreOO::CISampleClockSource { JYPCIe5111CoreOO::Implicit = 0x0 , JYPCIe5111CoreOO::Internal = 0x1 , JYPCIe5111CoreOO::External = 0x2 }
CI Sample Clock Source. More...
enum class | JYPCIe5111CoreOO::EdgeType { JYPCIe5111CoreOO::Rising , JYPCIe5111CoreOO::Falling }
Edge Type. More...
enum class | JYPCIe5111CoreOO::QuadEncodingType { JYPCIe5111CoreOO::X1 , JYPCIe5111CoreOO::X2 , JYPCIe5111CoreOO::X4 }
Quadrature Encoding Type. More...
enum class | JYPCIe5111CoreOO::CITriggerType { JYPCIe5111CoreOO::Immediate = 0x0 , JYPCIe5111CoreOO::Digital = 0x1 , JYPCIe5111CoreOO::Soft = 0x3 }
TriggerType Digital/Immediate/Soft. More...
enum class JYPCIe5111CoreOO::CIDigitalTriggerSource {
JYPCIe5111CoreOO::PFI0 , JYPCIe5111CoreOO::PFI1 , JYPCIe5111CoreOO::PFI2 , JYPCIe5111CoreOO::PFI3 ,
JYPCIe5111CoreOO::PFI4 , JYPCIe5111CoreOO::PFI5 , JYPCIe5111CoreOO::PFI6 , JYPCIe5111CoreOO::PFI7 ,
JYPCIe5111CoreOO::PFI8 , JYPCIe5111CoreOO::PFI9 , JYPCIe5111CoreOO::PFI10 , JYPCIe5111CoreOO::PFI11 ,
JYPCIe5111CoreOO::PFI12 , JYPCIe5111CoreOO::PFI13 , JYPCIe5111CoreOO::PFI14 , JYPCIe5111CoreOO::PFI15 ,
JYPCIe5111CoreOO::PXI_Trig0 = 40 , JYPCIe5111CoreOO::PXI_Trig1 = 41 , JYPCIe5111CoreOO::PXI_Trig2 = 42 , JYPCIe5111CoreOO::PXI_Trig3 = 43 ,
JYPCIe5111CoreOO::PXI_Trig4 = 44 , JYPCIe5111CoreOO::PXI_Trig5 = 45 , JYPCIe5111CoreOO::PXI_Trig6 = 46 , JYPCIe5111CoreOO::PXI_Trig7 = 47 ,
JYPCIe5111CoreOO::AI_StartTrig = 16 , JYPCIe5111CoreOO::AI_ReferenceTrig = 17 , JYPCIe5111CoreOO::AO_StartTrig = 26 , JYPCIe5111CoreOO::DI_StartTrig = 22 ,
JYPCIe5111CoreOO::DI_ReferenceTrig = 23 , JYPCIe5111CoreOO::DO_StartTrig = 29 , JYPCIe5111CoreOO::CI_0_StartTrig = 68 , JYPCIe5111CoreOO::CI_1_StartTrig = 73 ,
JYPCIe5111CoreOO::CI_2_StartTrig = 76 , JYPCIe5111CoreOO::CI_3_StartTrig = 79 , JYPCIe5111CoreOO::CO_0_StartTrig = 69 , JYPCIe5111CoreOO::CO_1_StartTrig = 74 ,
JYPCIe5111CoreOO::CO_2_StartTrig = 77 , JYPCIe5111CoreOO::CO_3_StartTrig = 80 , JYPCIe5111CoreOO::CO_0_Output = 37 , JYPCIe5111CoreOO::CO_1_Output = 51 ,
JYPCIe5111CoreOO::CO_2_Output = 60 , JYPCIe5111CoreOO::CO_3_Output = 66
}
CI Digital trigger source. More...
enum class | JYPCIe5111CoreOO::CIDigitalTriggerEdge { JYPCIe5111CoreOO::Rising , JYPCIe5111CoreOO::Falling }
CI Digital Trigger Edge. More...
enum class | JYPCIe5111CoreOO::EdgeCntOunEvtIdleState { JYPCIe5111CoreOO::LowLevel = 0 , JYPCIe5111CoreOO::HighLevel = 1 }
Output idle state when the event has not occurred. More...
enum class | JYPCIe5111CoreOO::CISignalExportSource { JYPCIe5111CoreOO::StartTrig , JYPCIe5111CoreOO::SampleClock }
SourceSignal. More...
enum class | JYPCIe5111CoreOO::CITimebaseSource { JYPCIe5111CoreOO::Internal200MHz }
Timebase source. More...


5111 C++ Programming Manual: JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • JYPCIe5111CoreOOCITask
Public Member Functions | Public Attributes | List of all members
JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask Class Reference

#include <JYPCIe5111CoreOOCITask.h>

Public Member Functions

JYPCIe5111CoreOOCITask (int slotNum, int channel)
JYPCIe5111CoreOOCITask (std::string boardName, int channel)
~JYPCIe5111CoreOOCITask ()
void | Start ()
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Stop ()
Stop CI task .
void | ReadSinglePoint (int &count)
Read a signle count value from register, Available when Type is CIType.EdgeCounting, CIType.QuadEncoder or CIType.TwoPulseEncoder.
void | ReadData (int *pBufCount, int samplesToAcquire, int timeout=10000)
Read counter values from buffer.
void | ReadData (std::vector< int > &pBufCount, int samplesToAcquire, int timeout=10000)
Read counter values from buffer.
void | ReadData (double *pBufMeasurement, int samplesToAcquire, int timeout=10000)
Read frequency value or period value from buffer.
void | ReadData (std::vector< double > &pBufMeasurement, int samplesToAcquire, int timeout=10000)
Read frequency value or period value from buffer.
void | ReadSinglePoint (double &measurement, int timeout=10000)
Read a signle frequency value or period value from register.
void | ReadSinglePoint (double &measurement1, double &measurement2, int timeout=10000)
Read a signle measurement of pulse's duration value, or two-edge separtion value (two results at a time) from register.
void | ReadData (double *pBufMeasurement1, double *pBufMeasurement2, int samplesToAcquire, int timeout=10000)
Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.
void | ReadData (std::vector< double > &pBufMeasurement1, std::vector< double > &pBufMeasurement2, int samplesToAcquire, int timeout=10000)
Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.

Public Attributes

CIType Type
CI Application types.
JYPCIe5111CoreOOProperty< JYPCIe5111CoreOOCITask, uint64_t, JYPCIe5111CoreOOPropertyType::READ_ONLY > | AvailableSamples
Number of points per channel that can be read in the buffer .
JYPCIe5111CoreOOProperty< JYPCIe5111CoreOOCITask, uint64_t, JYPCIe5111CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
CIMode Mode
CI Sampling mode，support Single/Finite/Continuous.
CISampleClock * SampleClock
Clock Source.
uint32_t | SamplesToAcquire
Number of samples to be read per channel.Only valid when Mode is CIMode.Finite.
JYPCIe5111CoreOO::EdgeCounting * EdgeCounting
Edge Counting Configuration.
JYPCIe5111CoreOO::FrequencyMeas * FrequencyMeas
Frequency Measurement Configuration.
JYPCIe5111CoreOO::PeriodMeas * PeriodMeas
Period Measurement Configuration.
JYPCIe5111CoreOO::PulseMeas * PulseMeas
Pulse Measurement Configuration.
JYPCIe5111CoreOO::TwoEdgeSeparation * TwoEdgeSeparation
TwoEdgeSeparation.
JYPCIe5111CoreOO::QuadEncoder * QuadEncoder
QuadEncoder.
JYPCIe5111CoreOO::TwoPulseEncoder * TwoPulseEncoder
TwoPulseEncoder.
CITrigger * Trigger
CI Trigger Configuration.
CISignalExport * SignalExport
Export CI Signal Configuration.
JYPCIe5111CoreOODevice * Device
Device.

Constructor & Destructor Documentation

◆ JYPCIe5111CoreOOCITask() [1/2]

JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask::JYPCIe5111CoreOOCITask | ( | int | slotNum,
 |  | int | channel )

◆ JYPCIe5111CoreOOCITask() [2/2]

JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask::JYPCIe5111CoreOOCITask | ( | std::string | boardName,
 |  | int | channel )

◆ ~JYPCIe5111CoreOOCITask()

JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask::~JYPCIe5111CoreOOCITask ( )

Member Function Documentation

◆ ReadData() [1/6]

void JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask::ReadData | ( | double * | pBufMeasurement,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read frequency value or period value from buffer.

Available when JYPCIe5111CITask.Mode is NOT CIMode.Single, and Type is CIType.Frequency or CIType.Period.

Parameters
bufMeasurement | Buffer for reading data. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period in seconds when Type is CIType.Period.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [2/6]

void JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask::ReadData | ( | double * | pBufMeasurement1,
 |  | double * | pBufMeasurement2,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.

. Available when JYPCIe5111CITask.Mode is NOT CIMode.Single, Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
bufMeasurement1 | Buffer for reading data. Indicates high level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
bufMeasurement2 | Buffer for reading data. Indicates low level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [3/6]

void JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask::ReadData | ( | int * | pBufCount,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read counter values from buffer.

Available when JYPCIe5111CITask.Mode is NOT CIMode.Single, and Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder

Parameters
bufCount | Buffer for reading data.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [4/6]

void JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask::ReadData | ( | std::vector< double > & | pBufMeasurement,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read frequency value or period value from buffer.

Available when JYPCIe5111CITask.Mode is NOT CIMode.Single, and Type is CIType.Frequency or CIType.Period.

Parameters
bufMeasurement | Buffer for reading data. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period in seconds when Type is CIType.Period.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [5/6]

void JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask::ReadData | ( | std::vector< double > & | pBufMeasurement1,
 |  | std::vector< double > & | pBufMeasurement2,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.

. Available when JYPCIe5111CITask.Mode is NOT CIMode.Single, Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
bufMeasurement1 | Buffer for reading data. Indicates high level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
bufMeasurement2 | Buffer for reading data. Indicates low level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [6/6]

void JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask::ReadData | ( | std::vector< int > & | pBufCount,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read counter values from buffer.

Available when JYPCIe5111CITask.Mode is NOT CIMode.Single, and Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder

Parameters
bufCount | Buffer for reading data.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [1/3]

void JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask::ReadSinglePoint | ( | double & | measurement,
 |  | int | timeout = 10000 )

Read a signle frequency value or period value from register.

Valid when Type is CIType.Frequency or CIType.Period.

Parameters
measurement Measurement value. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period is seconds when Type is CIType.Period.
timeout
Timeout (ms). Wait until the measurement is completed or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [2/3]

void JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask::ReadSinglePoint | ( | double & | measurement1,
 |  | double & | measurement2,
 |  | int | timeout = 10000 )

Read a signle measurement of pulse's duration value, or two-edge separtion value (two results at a time) from register.

Available when Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
measurement1 | Measurement Value 1. Indicates low level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
measurement2 | Measurement Value 2. Indicates high level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
timeout
Timeout (ms). Wait until the measurement is completed or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [3/3]

void JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask::ReadSinglePoint ( int & count )

Read a signle count value from register, Available when Type is CIType.EdgeCounting, CIType.QuadEncoder or CIType.TwoPulseEncoder.

Parameters
count counter value。

◆ SendSoftwareTrigger()

void JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask::SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask::Start ( )

◆ Stop()

void JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask::Stop ( )

Stop CI task .

Member Data Documentation

◆ AvailableSamples

JYPCIe5111CoreOOProperty<JYPCIe5111CoreOOCITask, uint64_t, JYPCIe5111CoreOOPropertyType::READ_ONLY> JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask::AvailableSamples

Number of points per channel that can be read in the buffer .

◆ Device

JYPCIe5111CoreOODevice* JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask::Device

Device.

◆ EdgeCounting

JYPCIe5111CoreOO::EdgeCounting* JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask::EdgeCounting

Edge Counting Configuration.

◆ FrequencyMeas

JYPCIe5111CoreOO::FrequencyMeas* JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask::FrequencyMeas

Frequency Measurement Configuration.

◆ Mode

CIMode JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask::Mode

CI Sampling mode，support Single/Finite/Continuous.

◆ PeriodMeas

JYPCIe5111CoreOO::PeriodMeas* JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask::PeriodMeas

Period Measurement Configuration.

◆ PulseMeas

JYPCIe5111CoreOO::PulseMeas* JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask::PulseMeas

Pulse Measurement Configuration.

◆ QuadEncoder

JYPCIe5111CoreOO::QuadEncoder* JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask::QuadEncoder

QuadEncoder.

◆ SampleClock

CISampleClock* JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask::SampleClock

Clock Source.

◆ SamplesToAcquire

uint32_t JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask::SamplesToAcquire

Number of samples to be read per channel.Only valid when Mode is CIMode.Finite.

◆ SignalExport

CISignalExport* JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask::SignalExport

Export CI Signal Configuration.

◆ TransferedSamples

JYPCIe5111CoreOOProperty<JYPCIe5111CoreOOCITask, uint64_t, JYPCIe5111CoreOOPropertyType::READ_ONLY> JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT CIMode.Single.

◆ Trigger

CITrigger* JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask::Trigger

CI Trigger Configuration.

◆ TwoEdgeSeparation

JYPCIe5111CoreOO::TwoEdgeSeparation* JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask::TwoEdgeSeparation

TwoEdgeSeparation.

◆ TwoPulseEncoder

JYPCIe5111CoreOO::TwoPulseEncoder* JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask::TwoPulseEncoder

TwoPulseEncoder.

◆ Type

CIType JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask::Type

CI Application types.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOCITask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::CIInternalSampleClock Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • CIInternalSampleClock
Public Attributes | List of all members
JYPCIe5111CoreOO::CIInternalSampleClock Class Reference

CI Internal Sample Clock Configuration Class. More...

#include <JYPCIe5111CoreOOCITask.h>

Public Attributes

JYPCIe5111CoreOOProperty< CIInternalSampleClock, double, JYPCIe5111CoreOOPropertyType::READ_WRITE > Rate
The rate of the internal sample clock (sample rate) which is generated by dividing the internal clock (200MHz).

Detailed Description

CI Internal Sample Clock Configuration Class.

Member Data Documentation

◆ Rate

JYPCIe5111CoreOOProperty<CIInternalSampleClock, double, JYPCIe5111CoreOOPropertyType::READ_WRITE> JYPCIe5111CoreOO::CIInternalSampleClock::Rate

The rate of the internal sample clock (sample rate) which is generated by dividing the internal clock (200MHz).

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOCITask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::CIImplicitSampleClock Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • CIImplicitSampleClock
Public Attributes | List of all members
JYPCIe5111CoreOO::CIImplicitSampleClock Class Reference

CI Implicit Sample Clock class. More...

#include <JYPCIe5111CoreOOCITask.h>

Public Attributes

double ExpectedRate
Expected Rate of Implicit Sample Clock.

Detailed Description

CI Implicit Sample Clock class.

Member Data Documentation

◆ ExpectedRate

double JYPCIe5111CoreOO::CIImplicitSampleClock::ExpectedRate

Expected Rate of Implicit Sample Clock.

Filling this parameter accurately would helps the driver to set a proper DDR write frequency internally.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOCITask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::CIExternalSampleClock Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • CIExternalSampleClock
Public Attributes | List of all members
JYPCIe5111CoreOO::CIExternalSampleClock Class Reference

CI Implicit Sample Clock class. More...

#include <JYPCIe5111CoreOOCITask.h>

Public Attributes

ClockTerminal Terminal
External Sample Clock Input Terminal.
double ExpectedRate
Expected Rate of External Sample Clock.

Detailed Description

CI Implicit Sample Clock class.

Member Data Documentation

◆ ExpectedRate

double JYPCIe5111CoreOO::CIExternalSampleClock::ExpectedRate

Expected Rate of External Sample Clock.

Filling this parameter accurately would helps the driver to set a proper DDR write frequency internally.

◆ Terminal

ClockTerminal JYPCIe5111CoreOO::CIExternalSampleClock::Terminal

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOCITask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::CISampleClock Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • CISampleClock
Public Attributes | List of all members
JYPCIe5111CoreOO::CISampleClock Class Reference

CI Sample Clock class. More...

#include <JYPCIe5111CoreOOCITask.h>

Public Attributes

CISampleClockSource Source
CI Sample Clock Source.
CIExternalSampleClock * External
CI External Sample Clock Configuration.
CIImplicitSampleClock * Implicit
CI Implicit Sample Clock Configuration.
CIInternalSampleClock * Internal
Internal Sample Clock Configuration.

Detailed Description

CI Sample Clock class.

Member Data Documentation

◆ External

CIExternalSampleClock* JYPCIe5111CoreOO::CISampleClock::External

CI External Sample Clock Configuration.

Valid when Source is CISampleClockSource.External.

◆ Implicit

CIImplicitSampleClock* JYPCIe5111CoreOO::CISampleClock::Implicit

CI Implicit Sample Clock Configuration.

Valid when Source is CISampleClockSource.Implicit.

◆ Internal

CIInternalSampleClock* JYPCIe5111CoreOO::CISampleClock::Internal

Internal Sample Clock Configuration.

Valid when Source is CISampleClockSource.Internal.

◆ Source

CISampleClockSource JYPCIe5111CoreOO::CISampleClock::Source

CI Sample Clock Source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOCITask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::EdgeCounting Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • EdgeCounting
Public Attributes | List of all members
JYPCIe5111CoreOO::EdgeCounting Class Reference

Configure CI EdgeCounting. More...

#include <JYPCIe5111CoreOOCITask.h>

Public Attributes

int InitialCount
Initial Count.
CountDirection Direction
Counter direction.
EdgeType ActiveEdge
The avtive edge of the input signal, the counter will count up or down on this edge.
PauseTrigger * Pause
Pause Trigger Configuration.
EdgeCountingOutEvent * OutEvent
Edge counting output event.
JYPCIe5111CoreOO::InputTerminal DirTerminal
Terminal of External Count Diretion Control.
JYPCIe5111CoreOO::InputTerminal Input_Terminal
Input Terminal.

Detailed Description

Configure CI EdgeCounting.

Member Data Documentation

◆ ActiveEdge

EdgeType JYPCIe5111CoreOO::EdgeCounting::ActiveEdge

The avtive edge of the input signal, the counter will count up or down on this edge.

◆ Direction

CountDirection JYPCIe5111CoreOO::EdgeCounting::Direction

Counter direction.

enum Up/Down/External

◆ DirTerminal

JYPCIe5111CoreOO::InputTerminal JYPCIe5111CoreOO::EdgeCounting::DirTerminal

Terminal of External Count Diretion Control.

Valid when Direction is CountDirection.External

◆ InitialCount

int JYPCIe5111CoreOO::EdgeCounting::InitialCount

Initial Count.

◆ Input_Terminal

JYPCIe5111CoreOO::InputTerminal JYPCIe5111CoreOO::EdgeCounting::Input_Terminal

Input Terminal.

◆ OutEvent

EdgeCountingOutEvent* JYPCIe5111CoreOO::EdgeCounting::OutEvent

Edge counting output event.

A pulse will be generated when the count value reaches specified threshold

◆ Pause

PauseTrigger* JYPCIe5111CoreOO::EdgeCounting::Pause

Pause Trigger Configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOCITask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::FrequencyMeas Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • FrequencyMeas
Public Attributes | List of all members
JYPCIe5111CoreOO::FrequencyMeas Class Reference

Configure CI Measure. More...

#include <JYPCIe5111CoreOOCITask.h>

Public Attributes

CITimebase * Timebase
Timebase configuration.
JYPCIe5111CoreOO::InputTerminal Input_Terminal
Input Terminal.

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ Input_Terminal

JYPCIe5111CoreOO::InputTerminal JYPCIe5111CoreOO::FrequencyMeas::Input_Terminal

Input Terminal.

◆ Timebase

CITimebase* JYPCIe5111CoreOO::FrequencyMeas::Timebase

Timebase configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOCITask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::PeriodMeas Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • PeriodMeas
Public Attributes | List of all members
JYPCIe5111CoreOO::PeriodMeas Class Reference

Configure CI Measure. More...

#include <JYPCIe5111CoreOOCITask.h>

Public Attributes

CITimebase * Timebase
Timebase configuration.
JYPCIe5111CoreOO::InputTerminal Input_Terminal
Input Terminal.

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ Input_Terminal

JYPCIe5111CoreOO::InputTerminal JYPCIe5111CoreOO::PeriodMeas::Input_Terminal

Input Terminal.

◆ Timebase

CITimebase* JYPCIe5111CoreOO::PeriodMeas::Timebase

Timebase configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOCITask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::PulseMeas Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • PulseMeas
Public Attributes | List of all members
JYPCIe5111CoreOO::PulseMeas Class Reference

Configure CI Measure. More...

#include <JYPCIe5111CoreOOCITask.h>

Public Attributes

CITimebase * Timebase
Timebase configuration.
JYPCIe5111CoreOO::InputTerminal Input_Terminal
Input Terminal.

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ Input_Terminal

JYPCIe5111CoreOO::InputTerminal JYPCIe5111CoreOO::PulseMeas::Input_Terminal

Input Terminal.

◆ Timebase

CITimebase* JYPCIe5111CoreOO::PulseMeas::Timebase

Timebase configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOCITask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::TwoEdgeSeparation Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • TwoEdgeSeparation
Public Attributes | List of all members
JYPCIe5111CoreOO::TwoEdgeSeparation Class Reference

Configure CI Measure. More...

#include <JYPCIe5111CoreOOCITask.h>

Public Attributes

CITimebase * Timebase
Timebase configuration.
InputTerminal FirstInputTerminal
Input Terminal.
InputTerminal SecondInputTerminal
Input Terminal.

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ FirstInputTerminal

InputTerminal JYPCIe5111CoreOO::TwoEdgeSeparation::FirstInputTerminal

Input Terminal.

◆ SecondInputTerminal

InputTerminal JYPCIe5111CoreOO::TwoEdgeSeparation::SecondInputTerminal

Input Terminal.

◆ Timebase

CITimebase* JYPCIe5111CoreOO::TwoEdgeSeparation::Timebase

Timebase configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOCITask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::QuadEncoder Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • QuadEncoder
Public Attributes | List of all members
JYPCIe5111CoreOO::QuadEncoder Class Reference

Configure CI Measure. More...

#include <JYPCIe5111CoreOOCITask.h>

Public Attributes

QuadEncodingType EncodingType
Type of Encoding.
bool | ZReloadEnabled
In Encoder mode ,the Z signal enable.
int | InitialCount
Initial Count.
InputTerminal AInputTerminal
Input Terminal.
InputTerminal BInputTerminal
Input Terminal.
InputTerminal ZInputTerminal
Input Terminal.

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ AInputTerminal

InputTerminal JYPCIe5111CoreOO::QuadEncoder::AInputTerminal

Input Terminal.

◆ BInputTerminal

InputTerminal JYPCIe5111CoreOO::QuadEncoder::BInputTerminal

Input Terminal.

◆ EncodingType

QuadEncodingType JYPCIe5111CoreOO::QuadEncoder::EncodingType

Type of Encoding.

◆ InitialCount

int JYPCIe5111CoreOO::QuadEncoder::InitialCount

Initial Count.

◆ ZInputTerminal

InputTerminal JYPCIe5111CoreOO::QuadEncoder::ZInputTerminal

Input Terminal.

◆ ZReloadEnabled

bool JYPCIe5111CoreOO::QuadEncoder::ZReloadEnabled

In Encoder mode ,the Z signal enable.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOCITask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::TwoPulseEncoder Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • TwoPulseEncoder
Public Attributes | List of all members
JYPCIe5111CoreOO::TwoPulseEncoder Class Reference

Configure CI Measure. More...

#include <JYPCIe5111CoreOOCITask.h>

Public Attributes

int InitialCount
Initial Count.
InputTerminal AInputTerminal
Input Terminal.
InputTerminal BInputTerminal
Input Terminal.

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ AInputTerminal

InputTerminal JYPCIe5111CoreOO::TwoPulseEncoder::AInputTerminal

Input Terminal.

◆ BInputTerminal

InputTerminal JYPCIe5111CoreOO::TwoPulseEncoder::BInputTerminal

Input Terminal.

◆ InitialCount

int JYPCIe5111CoreOO::TwoPulseEncoder::InitialCount

Initial Count.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOCITask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::CITrigger Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • CITrigger
Public Attributes | List of all members
JYPCIe5111CoreOO::CITrigger Class Reference

Constructor to create an CITrigger task object. More...

#include <JYPCIe5111CoreOOCITask.h>

Public Attributes

CITriggerType Type
CI trigger type.
CIDigitalTrigger * Digital
CI Digital Trigger.

Detailed Description

Constructor to create an CITrigger task object.

Used to build CI Trigger

Member Data Documentation

◆ Digital

CIDigitalTrigger* JYPCIe5111CoreOO::CITrigger::Digital

CI Digital Trigger.

Valid when Type is CITriggerType.Digital

◆ Type

CITriggerType JYPCIe5111CoreOO::CITrigger::Type

CI trigger type.

enum Immediate/Digital/Soft.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOCITask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::CIDigitalTrigger Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • CIDigitalTrigger
Public Attributes | List of all members
JYPCIe5111CoreOO::CIDigitalTrigger Class Reference

CI Digital trigger . More...

#include <JYPCIe5111CoreOOCITask.h>

Public Attributes

CIDigitalTriggerSource Source
CI Digital Trigger source.
CIDigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Detailed Description

CI Digital trigger .

Member Data Documentation

◆ Edge

CIDigitalTriggerEdge JYPCIe5111CoreOO::CIDigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

CIDigitalTriggerSource JYPCIe5111CoreOO::CIDigitalTrigger::Source

CI Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOCITask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::EdgeCountingOutEvent Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • EdgeCountingOutEvent
Public Attributes | List of all members
JYPCIe5111CoreOO::EdgeCountingOutEvent Class Reference

Edge counting output event configuration class. More...

#include <JYPCIe5111CoreOOCITask.h>

Public Attributes

EdgeCntOunEvtIdleState IdleState
Output idle state when the event has not occurred.
uint32_t Threshold
Comparison threshold.
IOTerminal Terminal
Terminal.

Detailed Description

Edge counting output event configuration class.

Member Data Documentation

◆ IdleState

EdgeCntOunEvtIdleState JYPCIe5111CoreOO::EdgeCountingOutEvent::IdleState

Output idle state when the event has not occurred.

The default value is EdgeCntOunEvtIdleState.LowLevel

◆ Terminal

IOTerminal JYPCIe5111CoreOO::EdgeCountingOutEvent::Terminal

Terminal.

◆ Threshold

uint32_t JYPCIe5111CoreOO::EdgeCountingOutEvent::Threshold

Comparison threshold.

The default value is 2^32-1

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOCITask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::CITimebase Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • CITimebase
Public Attributes | List of all members
JYPCIe5111CoreOO::CITimebase Class Reference

Timebase configuration class. More...

#include <JYPCIe5111CoreOOCITask.h>

Public Attributes

CITimebaseSource Source
Timebase Source.

Detailed Description

Timebase configuration class.

Member Data Documentation

◆ Source

CITimebaseSource JYPCIe5111CoreOO::CITimebase::Source

Timebase Source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOCITask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::CISignalExport Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • CISignalExport
Public Member Functions | List of all members
JYPCIe5111CoreOO::CISignalExport Class Reference

CI Signal Export Class. More...

#include <JYPCIe5111CoreOOCITask.h>

Public Member Functions

void | Add (CISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (CISignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

CI Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JYPCIe5111CoreOO::CISignalExport::Add | ( | CISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | CI Signal Source
destination | Export Desination

◆ Add() [2/2]

void JYPCIe5111CoreOO::CISignalExport::Add | ( | CISignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | CI Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JYPCIe5111CoreOO::CISignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JYPCIe5111CoreOO::CISignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOCITask.h


5111 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOCommon.h File Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 5111
Classes | Namespaces | Macros | Enumerations | Functions
JYPCIe5111CoreOOCommon.h File Reference
#include <string>
#include <stdint.h>

Classes

class | JYPCIe5111CoreOO::JYDriverException
class | JYPCIe5111CoreOO::JYPCIe5111CoreOOProperty< ContainerClass, ValueType, propertyType >
属性模板类 More...
class | JYPCIe5111CoreOO::PauseTrigger
Pause trigger configuration class. More...

Namespaces

namespace JYPCIe5111CoreOO

Macros

#define | EXTERN_C extern
Windows.
#define | JYPCIe5111CoreOO_API

Enumerations

enum class | JYPCIe5111CoreOO::JYPCIe5111CoreOOPropertyType { JYPCIe5111CoreOO::READ_ONLY = 1 , JYPCIe5111CoreOO::WRITE_ONLY = 2 , JYPCIe5111CoreOO::READ_WRITE = 3 }
enum class JYPCIe5111CoreOO::JYDriverExceptionPublic {
JYPCIe5111CoreOO::UnKnown = 0 , JYPCIe5111CoreOO::OpenDeviceFailed = -10001 , JYPCIe5111CoreOO::CloseDeviceFailed = -10002 , JYPCIe5111CoreOO::ResetDeviceFailed = -10003 ,
JYPCIe5111CoreOO::GetDevicePropertyFailed = -10004 , JYPCIe5111CoreOO::SetDevicePropertyFailed = -10005 , JYPCIe5111CoreOO::HardwareResourceIsReserved = -10006 , JYPCIe5111CoreOO::MethodNotPermitedToCallWhenCurrentStatus = -10007 ,
JYPCIe5111CoreOO::InvalidUserDataBuffer = -10008 , JYPCIe5111CoreOO::NoChannelAdded = -10009 , JYPCIe5111CoreOO::NotSupportOperationForCurrentDevice = -10010 , JYPCIe5111CoreOO::CreatTaskFailed = -10100 ,
JYPCIe5111CoreOO::StartTaskFailed = -10101 , JYPCIe5111CoreOO::StopTaskFailed = -10102 , JYPCIe5111CoreOO::TaskHasNotStarted = -10103 , JYPCIe5111CoreOO::TaskHasStartedCannotPerformTheSetOperation = -10104 ,
JYPCIe5111CoreOO::ChannelNumberParameterInvalid = -10105 , JYPCIe5111CoreOO::ChannelInputRangeParameterInvalid = -10106 , JYPCIe5111CoreOO::ChannelTerminalParameterInvalid = -10107 , JYPCIe5111CoreOO::ChannelCouplingParameterInvalid = -10108 ,
JYPCIe5111CoreOO::SampeleModeParameterInvalid = -10109 , JYPCIe5111CoreOO::SampleClockParameterInvalid = -10110 , JYPCIe5111CoreOO::SampleRateParameterInvalid = -10111 , JYPCIe5111CoreOO::UpdateRateParameterInvalid = -10112 ,
JYPCIe5111CoreOO::TriggerParameterInvalid = -10113 , JYPCIe5111CoreOO::ReferenceTriggerDoesNotMatchWithSampleMode = -10114 , JYPCIe5111CoreOO::PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint = -10115 , JYPCIe5111CoreOO::ReadDataFailed = -10016 ,
JYPCIe5111CoreOO::ReadDataTimeout = -10017 , JYPCIe5111CoreOO::WriteDataFailed = -10018 , JYPCIe5111CoreOO::WriteDataTimeout = -10019 , JYPCIe5111CoreOO::WriteDataLengthCannotBeLessThanN = -10020 ,
JYPCIe5111CoreOO::BufferDataOverflow = -10021 , JYPCIe5111CoreOO::BufferDataDownflow = -10022 , JYPCIe5111CoreOO::CheckBufferFailed = -10023 , JYPCIe5111CoreOO::PointInvalidInFiniteMode = -10024 ,
JYPCIe5111CoreOO::ReadPointInvalid = -10025 , JYPCIe5111CoreOO::OnlySupportRecordMode = -10026 , JYPCIe5111CoreOO::SendSoftTirggerFailed = -10027 , JYPCIe5111CoreOO::TaskTimeout = -10028 ,
JYPCIe5111CoreOO::CounterParametersInvalid = -10029 , JYPCIe5111CoreOO::WritePointInvalid = -10030 , JYPCIe5111CoreOO::SignalExportDestinationInvalid = -10031 , JYPCIe5111CoreOO::InvalidParameter = -10033
}
enum class JYPCIe5111CoreOO::ClockTerminal {
JYPCIe5111CoreOO::ECLK = 10000 , JYPCIe5111CoreOO::PFI0 = 0 , JYPCIe5111CoreOO::PFI1 = 1 , JYPCIe5111CoreOO::PFI2 = 2 ,
JYPCIe5111CoreOO::PFI3 = 3 , JYPCIe5111CoreOO::PFI4 = 4 , JYPCIe5111CoreOO::PFI5 = 5 , JYPCIe5111CoreOO::PFI6 = 6 ,
JYPCIe5111CoreOO::PFI7 = 7 , JYPCIe5111CoreOO::PFI8 = 8 , JYPCIe5111CoreOO::PFI9 = 9 , JYPCIe5111CoreOO::PFI10 = 10 ,
JYPCIe5111CoreOO::PFI11 = 11 , JYPCIe5111CoreOO::PFI12 = 12 , JYPCIe5111CoreOO::PFI13 = 13 , JYPCIe5111CoreOO::PFI14 = 14 ,
JYPCIe5111CoreOO::PFI15 = 15 , JYPCIe5111CoreOO::PXI_Trig0 = 40 , JYPCIe5111CoreOO::PXI_Trig1 = 41 , JYPCIe5111CoreOO::PXI_Trig2 = 42 ,
JYPCIe5111CoreOO::PXI_Trig3 = 43 , JYPCIe5111CoreOO::PXI_Trig4 = 44 , JYPCIe5111CoreOO::PXI_Trig5 = 45 , JYPCIe5111CoreOO::PXI_Trig6 = 46 ,
JYPCIe5111CoreOO::PXI_Trig7 = 47 , JYPCIe5111CoreOO::AI_SampleClock = 20 , JYPCIe5111CoreOO::AO_SampleClock = 28 , JYPCIe5111CoreOO::DI_SampleClock = 53 ,
JYPCIe5111CoreOO::DO_SampleClock = 54 , JYPCIe5111CoreOO::CI0_SampleClock = 36 , JYPCIe5111CoreOO::CI1_SampleClock = 50 , JYPCIe5111CoreOO::CI2_SampleClock = 59 ,
JYPCIe5111CoreOO::CI3_SampleClock = 65 , JYPCIe5111CoreOO::CO_0_Output = 37 , JYPCIe5111CoreOO::CO_1_Output = 51 , JYPCIe5111CoreOO::CO_2_Output = 60 ,
JYPCIe5111CoreOO::CO_3_Output = 66
}
enum class JYPCIe5111CoreOO::SignalExportDestination {
JYPCIe5111CoreOO::PFI0 , JYPCIe5111CoreOO::PFI1 , JYPCIe5111CoreOO::PFI2 , JYPCIe5111CoreOO::PFI3 ,
JYPCIe5111CoreOO::PFI4 , JYPCIe5111CoreOO::PFI5 , JYPCIe5111CoreOO::PFI6 , JYPCIe5111CoreOO::PFI7 ,
JYPCIe5111CoreOO::PFI8 , JYPCIe5111CoreOO::PFI9 , JYPCIe5111CoreOO::PFI10 , JYPCIe5111CoreOO::PFI11 ,
JYPCIe5111CoreOO::PFI12 , JYPCIe5111CoreOO::PFI13 , JYPCIe5111CoreOO::PFI14 , JYPCIe5111CoreOO::PFI15 ,
JYPCIe5111CoreOO::PXI_Trig0 = 0x20 , JYPCIe5111CoreOO::PXI_Trig1 = 0x21 , JYPCIe5111CoreOO::PXI_Trig2 = 0x22 , JYPCIe5111CoreOO::PXI_Trig3 = 0x23 ,
JYPCIe5111CoreOO::PXI_Trig4 = 0x24 , JYPCIe5111CoreOO::PXI_Trig5 = 0x25 , JYPCIe5111CoreOO::PXI_Trig6 = 0x26 , JYPCIe5111CoreOO::PXI_Trig7 = 0x27
}
enum class | JYPCIe5111CoreOO::OutputCompleteState { JYPCIe5111CoreOO::Zero , JYPCIe5111CoreOO::Hold }
Output Complete State. More...
enum class JYPCIe5111CoreOO::IOTerminal {
JYPCIe5111CoreOO::Default = 0 , JYPCIe5111CoreOO::PXI_Trig0 = 0x20 , JYPCIe5111CoreOO::PXI_Trig1 = 0x21 , JYPCIe5111CoreOO::PXI_Trig2 = 0x22 ,
JYPCIe5111CoreOO::PXI_Trig3 = 0x23 , JYPCIe5111CoreOO::PXI_Trig4 = 0x24 , JYPCIe5111CoreOO::PXI_Trig5 = 0x25 , JYPCIe5111CoreOO::PXI_Trig6 = 0x26 ,
JYPCIe5111CoreOO::PXI_Trig7 = 0x27
}
Cunter IO Terminal. More...
enum class | JYPCIe5111CoreOO::LevelPolarity { JYPCIe5111CoreOO::LowLevel = 0 , JYPCIe5111CoreOO::HighLevel = 1 , JYPCIe5111CoreOO::None = 2 }
Level Polarity. More...
enum class JYPCIe5111CoreOO::InputTerminal {
JYPCIe5111CoreOO::Default = 0 , JYPCIe5111CoreOO::PXI_Trig0 = 40 , JYPCIe5111CoreOO::PXI_Trig1 = 41 , JYPCIe5111CoreOO::PXI_Trig2 = 42 ,
JYPCIe5111CoreOO::PXI_Trig3 = 43 , JYPCIe5111CoreOO::PXI_Trig4 = 44 , JYPCIe5111CoreOO::PXI_Trig5 = 45 , JYPCIe5111CoreOO::PXI_Trig6 = 46 ,
JYPCIe5111CoreOO::PXI_Trig7 = 47 , JYPCIe5111CoreOO::CI_0_OutPut = 37 , JYPCIe5111CoreOO::CI_1_OutPut = 51 , JYPCIe5111CoreOO::CI_2_OutPut = 60 ,
JYPCIe5111CoreOO::CI_3_OutPut = 66
}
Cunter Input Terminal. More...

Functions

std::string JYPCIe5111CoreOO::GetSignalExportDestinationString (SignalExportDestination destination)

Macro Definition Documentation

◆ EXTERN_C

#define EXTERN_C extern

Windows.

Linux

◆ JYPCIe5111CoreOO_API

#define JYPCIe5111CoreOO_API


5111 C++ Programming Manual: JYPCIe5111CoreOO::JYDriverException Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • JYDriverException
Public Member Functions | Public Attributes | List of all members
JYPCIe5111CoreOO::JYDriverException Class Reference

#include <JYPCIe5111CoreOOCommon.h>

Public Member Functions

JYDriverException (JYDriverExceptionPublic exceptionCode, std::string msg="")
JYDriverException (int, std::string msg)

Public Attributes

std::string exceptionMessage
JYDriverExceptionPublic errorCode
JYDriverException * FollowingException

Constructor & Destructor Documentation

◆ JYDriverException() [1/2]

JYPCIe5111CoreOO::JYDriverException::JYDriverException | ( | JYDriverExceptionPublic | exceptionCode,
 |  | std::string | msg = "" )

◆ JYDriverException() [2/2]

JYPCIe5111CoreOO::JYDriverException::JYDriverException | ( | int | ,
 |  | std::string | msg )

Member Data Documentation

◆ errorCode

JYDriverExceptionPublic JYPCIe5111CoreOO::JYDriverException::errorCode

◆ exceptionMessage

std::string JYPCIe5111CoreOO::JYDriverException::exceptionMessage

◆ FollowingException

JYDriverException* JYPCIe5111CoreOO::JYDriverException::FollowingException
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOCommon.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::JYPCIe5111CoreOOProperty< ContainerClass, ValueType, propertyType > Class Template Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • JYPCIe5111CoreOOProperty
Public Member Functions | List of all members
JYPCIe5111CoreOO::JYPCIe5111CoreOOProperty< ContainerClass, ValueType, propertyType > Class Template Reference

属性模板类 More...

#include <JYPCIe5111CoreOOCommon.h>

Public Member Functions

JYPCIe5111CoreOOProperty ()
JYPCIe5111CoreOOProperty (ContainerClass *cObject, ValueType(ContainerClass::*pGet)(), void(ContainerClass::*pSet)(ValueType value))
JYPCIe5111CoreOOProperty (ValueType(*pGet)(), void(*pSet)(ValueType value))
ValueType operator= (const ValueType &value)
operator ValueType ()

Detailed Description

template<typename ContainerClass, typename ValueType, JYPCIe5111CoreOOPropertyType propertyType>
class JYPCIe5111CoreOO::JYPCIe5111CoreOOProperty< ContainerClass, ValueType, propertyType >

属性模板类

Constructor & Destructor Documentation

◆ JYPCIe5111CoreOOProperty() [1/3]

template<typename ContainerClass, typename ValueType, JYPCIe5111CoreOOPropertyType propertyType>
JYPCIe5111CoreOO::JYPCIe5111CoreOOProperty< ContainerClass, ValueType, propertyType >::JYPCIe5111CoreOOProperty ( )

◆ JYPCIe5111CoreOOProperty() [2/3]

template<typename ContainerClass, typename ValueType, JYPCIe5111CoreOOPropertyType propertyType>
JYPCIe5111CoreOO::JYPCIe5111CoreOOProperty< ContainerClass, ValueType, propertyType >::JYPCIe5111CoreOOProperty | ( | ContainerClass * | cObject,
 |  | ValueType(ContainerClass::* | pGet )(),
 |  | void(ContainerClass::* | pSet )(ValueType value) )

◆ JYPCIe5111CoreOOProperty() [3/3]

template<typename ContainerClass, typename ValueType, JYPCIe5111CoreOOPropertyType propertyType>
JYPCIe5111CoreOO::JYPCIe5111CoreOOProperty< ContainerClass, ValueType, propertyType >::JYPCIe5111CoreOOProperty | ( | ValueType(* | pGet )(),
 |  | void(* | pSet )(ValueType value) )

Member Function Documentation

◆ operator ValueType()

template<typename ContainerClass, typename ValueType, JYPCIe5111CoreOOPropertyType propertyType>
JYPCIe5111CoreOO::JYPCIe5111CoreOOProperty< ContainerClass, ValueType, propertyType >::operator ValueType ( )

◆ operator=()

template<typename ContainerClass, typename ValueType, JYPCIe5111CoreOOPropertyType propertyType>
ValueType JYPCIe5111CoreOO::JYPCIe5111CoreOOProperty< ContainerClass, ValueType, propertyType >::operator= ( const ValueType & value )
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOCommon.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::PauseTrigger Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • PauseTrigger
Public Attributes | List of all members
JYPCIe5111CoreOO::PauseTrigger Class Reference

Pause trigger configuration class. More...

#include <JYPCIe5111CoreOOCommon.h>

Public Attributes

LevelPolarity ActivePolarity
Pause trigger active polarity.
InputTerminal Terminal
Terminal.

Detailed Description

Pause trigger configuration class.

Member Data Documentation

◆ ActivePolarity

LevelPolarity JYPCIe5111CoreOO::PauseTrigger::ActivePolarity

Pause trigger active polarity.

The default value is LevelPolarity.None, means the pause trigger is disabled.

◆ Terminal

InputTerminal JYPCIe5111CoreOO::PauseTrigger::Terminal

Terminal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOCommon.h


5111 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOCOTask.h File Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 5111
Classes | Namespaces | Enumerations
JYPCIe5111CoreOOCOTask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JYPCIe5111CoreOOCommon.h"
#include "JYPCIe5111CoreOODevice.h"

Classes

class | JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask
class | JYPCIe5111CoreOO::CODigitalTrigger
CO Digital trigger . More...
class | JYPCIe5111CoreOO::COTrigger
Constructor to create an COTrigger task object. More...
class | JYPCIe5111CoreOO::COPulse
Pulse Parameter. More...
class | JYPCIe5111CoreOO::COTimebase
Timebase configuration class. More...
class | JYPCIe5111CoreOO::COSignalExport
CO Signal Export Class. More...

Namespaces

namespace JYPCIe5111CoreOO

Enumerations

enum class | JYPCIe5111CoreOO::COIdleState { JYPCIe5111CoreOO::HighLevel = 0x1 , JYPCIe5111CoreOO::LowLevel = 0x0 }
Idle state when pulse output before start and after stop. More...
enum class | JYPCIe5111CoreOO::COMode { JYPCIe5111CoreOO::Single = 3 , JYPCIe5111CoreOO::Finite = 0 , JYPCIe5111CoreOO::ContinuousNoWrapping = 2 , JYPCIe5111CoreOO::ContinuousWrapping = 1 }
enum class | JYPCIe5111CoreOO::COTriggerType { JYPCIe5111CoreOO::Immediate = 0x0 , JYPCIe5111CoreOO::Digital = 0x1 , JYPCIe5111CoreOO::Soft = 0x3 }
TriggerType Digital/Immediate/Soft. More...
enum class JYPCIe5111CoreOO::CODigitalTriggerSource {
JYPCIe5111CoreOO::PFI0 , JYPCIe5111CoreOO::PFI1 , JYPCIe5111CoreOO::PFI2 , JYPCIe5111CoreOO::PFI3 ,
JYPCIe5111CoreOO::PFI4 , JYPCIe5111CoreOO::PFI5 , JYPCIe5111CoreOO::PFI6 , JYPCIe5111CoreOO::PFI7 ,
JYPCIe5111CoreOO::PFI8 , JYPCIe5111CoreOO::PFI9 , JYPCIe5111CoreOO::PFI10 , JYPCIe5111CoreOO::PFI11 ,
JYPCIe5111CoreOO::PFI12 , JYPCIe5111CoreOO::PFI13 , JYPCIe5111CoreOO::PFI14 , JYPCIe5111CoreOO::PFI15 ,
JYPCIe5111CoreOO::PXI_Trig0 = 40 , JYPCIe5111CoreOO::PXI_Trig1 = 41 , JYPCIe5111CoreOO::PXI_Trig2 = 42 , JYPCIe5111CoreOO::PXI_Trig3 = 43 ,
JYPCIe5111CoreOO::PXI_Trig4 = 44 , JYPCIe5111CoreOO::PXI_Trig5 = 45 , JYPCIe5111CoreOO::PXI_Trig6 = 46 , JYPCIe5111CoreOO::PXI_Trig7 = 47 ,
JYPCIe5111CoreOO::AI_StartTrig = 16 , JYPCIe5111CoreOO::AI_ReferenceTrig = 17 , JYPCIe5111CoreOO::AO_StartTrig = 26 , JYPCIe5111CoreOO::DI_StartTrig = 22 ,
JYPCIe5111CoreOO::DI_ReferenceTrig = 23 , JYPCIe5111CoreOO::DO_StartTrig = 29 , JYPCIe5111CoreOO::CI_0_StartTrig = 68 , JYPCIe5111CoreOO::CI_1_StartTrig = 73 ,
JYPCIe5111CoreOO::CI_2_StartTrig = 76 , JYPCIe5111CoreOO::CI_3_StartTrig = 79 , JYPCIe5111CoreOO::CO_0_StartTrig = 69 , JYPCIe5111CoreOO::CO_1_StartTrig = 74 ,
JYPCIe5111CoreOO::CO_2_StartTrig = 77 , JYPCIe5111CoreOO::CO_3_StartTrig = 80
}
CO Digital trigger source. More...
enum class | JYPCIe5111CoreOO::CODigitalTriggerEdge { JYPCIe5111CoreOO::Rising , JYPCIe5111CoreOO::Falling }
CO Digital Trigger Edge. More...
enum class | JYPCIe5111CoreOO::COPulseType { JYPCIe5111CoreOO::DutyCycleFrequency , JYPCIe5111CoreOO::HighLowTime , JYPCIe5111CoreOO::HighLowTick }
Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick. More...
enum class | JYPCIe5111CoreOO::COTimebaseSource { JYPCIe5111CoreOO::Internal200MHz }
Timebase source. More...
enum class | JYPCIe5111CoreOO::COSignalExportSource { JYPCIe5111CoreOO::StartTrig , JYPCIe5111CoreOO::Output }
SourceSignal. More...


5111 C++ Programming Manual: JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • JYPCIe5111CoreOOCOTask
Public Member Functions | Public Attributes | List of all members
JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask Class Reference

#include <JYPCIe5111CoreOOCOTask.h>

Public Member Functions

JYPCIe5111CoreOOCOTask (int slotNum, int channel)
JYPCIe5111CoreOOCOTask (std::string boardName, int channel)
~JYPCIe5111CoreOOCOTask ()
void | WriteSinglePoint (COPulse &pulse)
Write a single pulse parameter to the register.
void | WriteData (COPulse *pulsesGroup[], int samplesToWrite, int timeout=10000)
Write pulse parameters to be output to the buffer.
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Start ()
Start CO task .
void | Stop ()
Stop COtask .
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.

Public Attributes

COMode Mode
CO output mode.
IOTerminal OutputTerminal
PauseTrigger * Pause
COTimebase * TimeBase
CO's time base.
double | InitialDelay
Counter output initial delay in seconds.
COIdleState IdleState
Idle state when pulse output before start and after stop.
uint32_t | SamplesToUpdate
有限频率输出
JYPCIe5111CoreOOProperty< JYPCIe5111CoreOOCOTask, uint32_t, JYPCIe5111CoreOOPropertyType::READ_ONLY > | AvailableSamples
Number of points per channel that can be read in the buffer .
JYPCIe5111CoreOOProperty< JYPCIe5111CoreOOCOTask, uint64_t, JYPCIe5111CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
JYPCIe5111CoreOOProperty< JYPCIe5111CoreOOCOTask, uint32_t, JYPCIe5111CoreOOPropertyType::READ_ONLY > | TransferedPulses
COTrigger * Trigger
CO trigger property configured by CO Trigger().
JYPCIe5111CoreOODevice * Device
Device.
COSignalExport * SignalExport
Export CO Signal Configuration.

Constructor & Destructor Documentation

◆ JYPCIe5111CoreOOCOTask() [1/2]

JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask::JYPCIe5111CoreOOCOTask | ( | int | slotNum,
 |  | int | channel )

◆ JYPCIe5111CoreOOCOTask() [2/2]

JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask::JYPCIe5111CoreOOCOTask | ( | std::string | boardName,
 |  | int | channel )

◆ ~JYPCIe5111CoreOOCOTask()

JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask::~JYPCIe5111CoreOOCOTask ( )

Member Function Documentation

◆ SendSoftwareTrigger()

void JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask::SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask::Start ( )

Start CO task .

◆ Stop()

void JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask::Stop ( )

Stop COtask .

◆ WaitUntilDone()

bool JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask::WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteData()

void JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask::WriteData | ( | COPulse * | pulsesGroup[],
 |  | int | samplesToWrite,
 |  | int | timeout = 10000 )

Write pulse parameters to be output to the buffer.

Valid when Mode is NOT COMode.Single. When Mode is COMode.Finite or COMode.ContinuousWrapping, this function can only be called once before starting the task.

Parameters
pulsesGroup | A group of pulse parameters
samplesToWrite | Number of samples to write. If Mode is COMode.ContinuousWrapping, you need to write at least 2 samples before starting the task
timeout | Timeout (ms). Wait until all data is written to buffer or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ WriteSinglePoint()

void JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask::WriteSinglePoint ( COPulse & pulse )

Write a single pulse parameter to the register.

Valid when Mode is COMode.Single. This function is also available after starting the task when the number of pulses being sent is infinite.

Parameters
pulse Pulse Parameter

Member Data Documentation

◆ AvailableSamples

JYPCIe5111CoreOOProperty<JYPCIe5111CoreOOCOTask, uint32_t, JYPCIe5111CoreOOPropertyType::READ_ONLY> JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask::AvailableSamples

Number of points per channel that can be read in the buffer .

◆ Device

JYPCIe5111CoreOODevice* JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask::Device

Device.

◆ IdleState

COIdleState JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask::IdleState

Idle state when pulse output before start and after stop.

◆ InitialDelay

double JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask::InitialDelay

Counter output initial delay in seconds.

There are five ticks of the timebase fixed delay in counter internal, so the total delay(s) = InitialDelay + (5 / timebase)

◆ Mode

COMode JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask::Mode

CO output mode.

◆ OutputTerminal

IOTerminal JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask::OutputTerminal

脉冲输出端口

Pulse Output Terminal

◆ Pause

PauseTrigger* JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask::Pause

暂停触发配置

Pause Trigger Configuration

◆ SamplesToUpdate

uint32_t JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask::SamplesToUpdate

有限频率输出

◆ SignalExport

COSignalExport* JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask::SignalExport

Export CO Signal Configuration.

◆ TimeBase

COTimebase* JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask::TimeBase

CO's time base.

◆ TransferedPulses

JYPCIe5111CoreOOProperty<JYPCIe5111CoreOOCOTask, uint32_t, JYPCIe5111CoreOOPropertyType::READ_ONLY> JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask::TransferedPulses

当前配置下已发送的脉冲的数量。

The number of pulses transfered under the current configuration.

◆ TransferedSamples

JYPCIe5111CoreOOProperty<JYPCIe5111CoreOOCOTask, uint64_t, JYPCIe5111CoreOOPropertyType::READ_ONLY> JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT CIMode.Single.

◆ Trigger

COTrigger* JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask::Trigger

CO trigger property configured by CO Trigger().

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOCOTask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::CODigitalTrigger Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • CODigitalTrigger
Public Attributes | List of all members
JYPCIe5111CoreOO::CODigitalTrigger Class Reference

CO Digital trigger . More...

#include <JYPCIe5111CoreOOCOTask.h>

Public Attributes

CODigitalTriggerSource Source
CO Digital Trigger source.
CODigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Detailed Description

CO Digital trigger .

Member Data Documentation

◆ Edge

CODigitalTriggerEdge JYPCIe5111CoreOO::CODigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

CODigitalTriggerSource JYPCIe5111CoreOO::CODigitalTrigger::Source

CO Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOCOTask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::COTrigger Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • COTrigger
Public Attributes | List of all members
JYPCIe5111CoreOO::COTrigger Class Reference

Constructor to create an COTrigger task object. More...

#include <JYPCIe5111CoreOOCOTask.h>

Public Attributes

COTriggerType Type
CO trigger type.
CODigitalTrigger * Digital
CO Digital Trigger.

Detailed Description

Constructor to create an COTrigger task object.

Used to build CO Trigger

Member Data Documentation

◆ Digital

CODigitalTrigger* JYPCIe5111CoreOO::COTrigger::Digital

CO Digital Trigger.

Valid when Type is COTriggerType.Digital

◆ Type

COTriggerType JYPCIe5111CoreOO::COTrigger::Type

CO trigger type.

enum Immediate/Digital/Soft.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOCOTask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::COPulse Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • COPulse
Public Member Functions | List of all members
JYPCIe5111CoreOO::COPulse Class Reference

Pulse Parameter. More...

#include <JYPCIe5111CoreOOCOTask.h>

Public Member Functions

COPulse (COPulseType type, double param1, double param2, int count)
Pulse Parameter.
COPulse ()
~COPulse ()

Detailed Description

Pulse Parameter.

Constructor & Destructor Documentation

◆ COPulse() [1/2]

JYPCIe5111CoreOO::COPulse::COPulse | ( | COPulseType | type,
 |  | double | param1,
 |  | double | param2,
 |  | int | count )

Pulse Parameter.

Parameters
type | The pulse type characteristics.
param1 | Parameter 1. Frequency (Hz) when constructed as COPulseType.DutyCycleFrequency; High duration in seconds when constructed as COPulseType.HighLowTime; High ticks of the clock when constructed as COPulseType.HighLowTick.
param2 | Parameter 1. Duty cycle (greater than 0 and less than 1) when constructed as COPulseType.DutyCycleFrequency; Low duration in seconds when constructed as COPulseType.HighLowTime; Low ticks of the clock when constructed as COPulseType.HighLowTick.
count | Number of pulses. When the value is -1 (indicating that the number of pulses is infinite), pulses will be continuously sent until requested to stop.

◆ COPulse() [2/2]

JYPCIe5111CoreOO::COPulse::COPulse ( )

◆ ~COPulse()

JYPCIe5111CoreOO::COPulse::~COPulse ( )
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOCOTask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::COTimebase Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • COTimebase
Public Attributes | List of all members
JYPCIe5111CoreOO::COTimebase Class Reference

Timebase configuration class. More...

#include <JYPCIe5111CoreOOCOTask.h>

Public Attributes

COTimebaseSource Source
Timebase Source.

Detailed Description

Timebase configuration class.

Member Data Documentation

◆ Source

COTimebaseSource JYPCIe5111CoreOO::COTimebase::Source

Timebase Source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOCOTask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::COSignalExport Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • COSignalExport
Public Member Functions | List of all members
JYPCIe5111CoreOO::COSignalExport Class Reference

CO Signal Export Class. More...

#include <JYPCIe5111CoreOOCOTask.h>

Public Member Functions

void | Add (COSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (COSignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

CO Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JYPCIe5111CoreOO::COSignalExport::Add | ( | COSignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | CI Signal Source
destination | Export Desination

◆ Add() [2/2]

void JYPCIe5111CoreOO::COSignalExport::Add | ( | COSignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | CI Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JYPCIe5111CoreOO::COSignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JYPCIe5111CoreOO::COSignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOCOTask.h


5111 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOODevice.h File Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 5111
Classes | Namespaces | Enumerations
JYPCIe5111CoreOODevice.h File Reference
#include <iostream>
#include <string>
#include <list>
#include <vector>
#include "JYPCIe5111CoreOOCommon.h"

Classes

class | JYPCIe5111CoreOO::JYPCIe5111CoreOODevice
class | JYPCIe5111CoreOO::PFIFilter
class | JYPCIe5111CoreOO::PFISetting
class | JYPCIe5111CoreOO::ExternalReferenceClock
class | JYPCIe5111CoreOO::JYPCIe5111CoreOOReferenceClock

Namespaces

namespace JYPCIe5111CoreOO

Enumerations

enum class | JYPCIe5111CoreOO::ExternalReferenceClockTerminal { JYPCIe5111CoreOO::PXIe_Clk100 = 0x1 }
enum class | JYPCIe5111CoreOO::ReferenceClockSource { JYPCIe5111CoreOO::Internal = 0x0 , JYPCIe5111CoreOO::External = 0x1 }
enum class JYPCIe5111CoreOO::PFITerminal {
JYPCIe5111CoreOO::PFI0 = 0 , JYPCIe5111CoreOO::PFI1 = 1 , JYPCIe5111CoreOO::PFI2 = 2 , JYPCIe5111CoreOO::PFI3 = 3 ,
JYPCIe5111CoreOO::PFI4 = 4 , JYPCIe5111CoreOO::PFI5 = 5 , JYPCIe5111CoreOO::PFI6 = 6 , JYPCIe5111CoreOO::PFI7 = 7 ,
JYPCIe5111CoreOO::PFI8 = 8 , JYPCIe5111CoreOO::PFI9 = 9 , JYPCIe5111CoreOO::PFI10 = 10 , JYPCIe5111CoreOO::PFI11 = 11 ,
JYPCIe5111CoreOO::PFI12 = 12 , JYPCIe5111CoreOO::PFI13 = 13 , JYPCIe5111CoreOO::PFI14 = 14 , JYPCIe5111CoreOO::PFI15 = 15
}
Input/Output Terminal of PFI. More...


5111 C++ Programming Manual: JYPCIe5111CoreOO::JYPCIe5111CoreOODevice Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • JYPCIe5111CoreOODevice
Static Public Member Functions | Public Attributes | List of all members
JYPCIe5111CoreOO::JYPCIe5111CoreOODevice Class Reference

#include <JYPCIe5111CoreOODevice.h>

Static Public Member Functions

static JYPCIe5111CoreOODevice * | GetInstance (int cardNum)
static JYPCIe5111CoreOODevice * | GetInstance (std::string aliasName)

Public Attributes

const double | BoardClockRate = 10e7
const double | MaxSampleRateMutilChannel = 300E3
const int | AIBufferSize = 0x100000 * 64
const bool | IsAISync = false
const double | MaxUpdateRate = 2860000
const double | MaxUpdateRateSingleChannel = 500E3
const bool | IsAOSync = false
IsAOSync.
JYPCIe5111CoreOOProperty< JYPCIe5111CoreOODevice, int, JYPCIe5111CoreOOPropertyType::READ_ONLY > | DiffChannelCount
JYPCIe5111CoreOOProperty< JYPCIe5111CoreOODevice, int, JYPCIe5111CoreOOPropertyType::READ_ONLY > | SEChannelCount
JYPCIe5111CoreOOProperty< JYPCIe5111CoreOODevice, double, JYPCIe5111CoreOOPropertyType::READ_ONLY > | MaxSampleRateSingleChannel
JYPCIe5111CoreOOProperty< JYPCIe5111CoreOODevice, int, JYPCIe5111CoreOOPropertyType::READ_ONLY > | AOChannelCount
JYPCIe5111CoreOOProperty< JYPCIe5111CoreOODevice, std::string, JYPCIe5111CoreOOPropertyType::READ_ONLY > | SerialNumber
JYPCIe5111CoreOOProperty< JYPCIe5111CoreOODevice, int, JYPCIe5111CoreOOPropertyType::READ_ONLY > | DeviceID
JYPCIe5111CoreOOProperty< JYPCIe5111CoreOODevice, void *, JYPCIe5111CoreOOPropertyType::READ_ONLY > | Handle
PFISetting * PFI
JYPCIe5111CoreOOReferenceClock * ReferenceClock

Member Function Documentation

◆ GetInstance() [1/2]

static JYPCIe5111CoreOODevice * JYPCIe5111CoreOO::JYPCIe5111CoreOODevice::GetInstance ( int cardNum )
static

◆ GetInstance() [2/2]

static JYPCIe5111CoreOODevice * JYPCIe5111CoreOO::JYPCIe5111CoreOODevice::GetInstance ( std::string aliasName )
static

Member Data Documentation

◆ AIBufferSize

const int JYPCIe5111CoreOO::JYPCIe5111CoreOODevice::AIBufferSize = 0x100000 * 64

◆ AOChannelCount

JYPCIe5111CoreOOProperty<JYPCIe5111CoreOODevice, int, JYPCIe5111CoreOOPropertyType::READ_ONLY> JYPCIe5111CoreOO::JYPCIe5111CoreOODevice::AOChannelCount

◆ BoardClockRate

const double JYPCIe5111CoreOO::JYPCIe5111CoreOODevice::BoardClockRate = 10e7

◆ DeviceID

JYPCIe5111CoreOOProperty<JYPCIe5111CoreOODevice, int, JYPCIe5111CoreOOPropertyType::READ_ONLY> JYPCIe5111CoreOO::JYPCIe5111CoreOODevice::DeviceID

◆ DiffChannelCount

JYPCIe5111CoreOOProperty<JYPCIe5111CoreOODevice, int, JYPCIe5111CoreOOPropertyType::READ_ONLY> JYPCIe5111CoreOO::JYPCIe5111CoreOODevice::DiffChannelCount

◆ Handle

JYPCIe5111CoreOOProperty<JYPCIe5111CoreOODevice, void*, JYPCIe5111CoreOOPropertyType::READ_ONLY> JYPCIe5111CoreOO::JYPCIe5111CoreOODevice::Handle

◆ IsAISync

const bool JYPCIe5111CoreOO::JYPCIe5111CoreOODevice::IsAISync = false

◆ IsAOSync

const bool JYPCIe5111CoreOO::JYPCIe5111CoreOODevice::IsAOSync = false

IsAOSync.

◆ MaxSampleRateMutilChannel

const double JYPCIe5111CoreOO::JYPCIe5111CoreOODevice::MaxSampleRateMutilChannel = 300E3

◆ MaxSampleRateSingleChannel

JYPCIe5111CoreOOProperty<JYPCIe5111CoreOODevice, double, JYPCIe5111CoreOOPropertyType::READ_ONLY> JYPCIe5111CoreOO::JYPCIe5111CoreOODevice::MaxSampleRateSingleChannel

◆ MaxUpdateRate

const double JYPCIe5111CoreOO::JYPCIe5111CoreOODevice::MaxUpdateRate = 2860000

◆ MaxUpdateRateSingleChannel

const double JYPCIe5111CoreOO::JYPCIe5111CoreOODevice::MaxUpdateRateSingleChannel = 500E3

◆ PFI

PFISetting* JYPCIe5111CoreOO::JYPCIe5111CoreOODevice::PFI

◆ ReferenceClock

JYPCIe5111CoreOOReferenceClock* JYPCIe5111CoreOO::JYPCIe5111CoreOODevice::ReferenceClock

◆ SEChannelCount

JYPCIe5111CoreOOProperty<JYPCIe5111CoreOODevice, int, JYPCIe5111CoreOOPropertyType::READ_ONLY> JYPCIe5111CoreOO::JYPCIe5111CoreOODevice::SEChannelCount

◆ SerialNumber

JYPCIe5111CoreOOProperty<JYPCIe5111CoreOODevice, std::string, JYPCIe5111CoreOOPropertyType::READ_ONLY> JYPCIe5111CoreOO::JYPCIe5111CoreOODevice::SerialNumber
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOODevice.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::PFIFilter Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • PFIFilter
Public Member Functions | List of all members
JYPCIe5111CoreOO::PFIFilter Class Reference

#include <JYPCIe5111CoreOODevice.h>

Public Member Functions

void | Enable (PFITerminal terminal, int minPulseWidth)
Enable the filter on the specified terminal and set the minimum pulse width.
void | Enable (std::vector< PFITerminal > terminals, int minPulseWidth)
Enable the filter on a group of terminals and set the minimum pulse width.
void | Enable (std::vector< PFITerminal > terminals, std::vector< int > minPulseWidth)
Enable the filter on a group of terminals and set the minimum pulse width separately.
void | Disable (PFITerminal terminal)
Disable the filter on the specified terminal.
void | Disable (std::vector< PFITerminal > terminals)
Disable the filter on a group terminal.
void | DisableAll ()
Disable the filter on all the terminals.

Member Function Documentation

◆ Disable() [1/2]

void JYPCIe5111CoreOO::PFIFilter::Disable ( PFITerminal terminal )

Disable the filter on the specified terminal.

Parameters
terminal Specified Terminal

◆ Disable() [2/2]

void JYPCIe5111CoreOO::PFIFilter::Disable ( std::vector< PFITerminal > terminals )

Disable the filter on a group terminal.

Parameters
terminals Specified Group of Terminal

◆ DisableAll()

void JYPCIe5111CoreOO::PFIFilter::DisableAll ( )

Disable the filter on all the terminals.

◆ Enable() [1/3]

void JYPCIe5111CoreOO::PFIFilter::Enable | ( | PFITerminal | terminal,
 |  | int | minPulseWidth )

Enable the filter on the specified terminal and set the minimum pulse width.

Parameters
terminal | Specified Terminal
minPulseWidth | Minimum pulse width in ns, bounce less than this length will be ignored. The smallest step in the range of 10 ns to 2550 ns is 10 ns, the smallest step in the range of 2550 ns to 40800 ns is 160 ns, and the smallest step in the range of 40800 ns to 652800 ns The step is 2560 ns

◆ Enable() [2/3]

void JYPCIe5111CoreOO::PFIFilter::Enable | ( | std::vector< PFITerminal > | terminals,
 |  | int | minPulseWidth )

Enable the filter on a group of terminals and set the minimum pulse width.

Parameters
terminals | Specified Group of Terminals
minPulseWidth | Minimum pulse width in ns, bounce less than this length will be ignored. The smallest step in the range of 10 ns to 2550 ns is 10 ns, the smallest step in the range of 2550 ns to 40800 ns is 160 ns, and the smallest step in the range of 40800 ns to 652800 ns The step is 2560 ns

◆ Enable() [3/3]

void JYPCIe5111CoreOO::PFIFilter::Enable | ( | std::vector< PFITerminal > | terminals,
 |  | std::vector< int > | minPulseWidth )

Enable the filter on a group of terminals and set the minimum pulse width separately.

Parameters
terminals | Specified Group of Terminals
minPulseWidth | Minimum pulse width in ns, bounce less than this length will be ignored. The smallest step in the range of 10 ns to 2550 ns is 10 ns, the smallest step in the range of 2550 ns to 40800 ns is 160 ns, and the smallest step in the range of 40800 ns to 652800 ns The step is 2560 ns
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOODevice.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::PFISetting Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • PFISetting
Public Attributes | List of all members
JYPCIe5111CoreOO::PFISetting Class Reference

#include <JYPCIe5111CoreOODevice.h>

Public Attributes

PFIFilter * Filter
PFI Filter Setting.

Member Data Documentation

◆ Filter

PFIFilter* JYPCIe5111CoreOO::PFISetting::Filter

PFI Filter Setting.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOODevice.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::ExternalReferenceClock Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • ExternalReferenceClock
Public Attributes | List of all members
JYPCIe5111CoreOO::ExternalReferenceClock Class Reference

#include <JYPCIe5111CoreOODevice.h>

Public Attributes

ExternalReferenceClockTerminal Terminal

Member Data Documentation

◆ Terminal

ExternalReferenceClockTerminal JYPCIe5111CoreOO::ExternalReferenceClock::Terminal
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOODevice.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::JYPCIe5111CoreOOReferenceClock Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • JYPCIe5111CoreOOReferenceClock
Public Member Functions | Public Attributes | List of all members
JYPCIe5111CoreOO::JYPCIe5111CoreOOReferenceClock Class Reference

#include <JYPCIe5111CoreOODevice.h>

Public Member Functions

void Commit ()
Commit configuration.

Public Attributes

ReferenceClockSource Source
ExternalReferenceClock * External
External Reference Clock Source.

Member Function Documentation

◆ Commit()

void JYPCIe5111CoreOO::JYPCIe5111CoreOOReferenceClock::Commit ( )

Commit configuration.

Available only when the device is idle. WARNING: Incorrect parameters will cause the PLL to be unable to lock the reference clock and cannot be recovered until shutdown and restart.

Member Data Documentation

◆ External

ExternalReferenceClock* JYPCIe5111CoreOO::JYPCIe5111CoreOOReferenceClock::External

External Reference Clock Source.

Required when ReferenceClock.Source is ReferenceClockSource.External

◆ Source

ReferenceClockSource JYPCIe5111CoreOO::JYPCIe5111CoreOOReferenceClock::Source
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOODevice.h


5111 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOODITask.h File Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 5111
Classes | Namespaces | Enumerations
JYPCIe5111CoreOODITask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JYPCIe5111CoreOOCommon.h"
#include "JYPCIe5111CoreOODevice.h"

Classes

class | JYPCIe5111CoreOO::JYPCIe5111CoreOODITask
class | JYPCIe5111CoreOO::DIChannel
DI Channel parameter class . More...
class | JYPCIe5111CoreOO::DISampleClock
Sample clock configuration class. More...
class | JYPCIe5111CoreOO::DIExternalSampleClock
External Sample Clock Configuration Class. More...
class | JYPCIe5111CoreOO::DISignalExport
DI Signal Export Class. More...
class | JYPCIe5111CoreOO::DITrigger
Constructor to create an DITrigger task object. More...
class | JYPCIe5111CoreOO::DIDigitalTrigger
DI Digital trigger . More...

Namespaces

namespace JYPCIe5111CoreOO

Enumerations

enum class | JYPCIe5111CoreOO::DISampleClockSource { JYPCIe5111CoreOO::Internal , JYPCIe5111CoreOO::External }
DI Sample Clock Source. More...
enum class | JYPCIe5111CoreOO::DIMode { JYPCIe5111CoreOO::Single = 2 , JYPCIe5111CoreOO::Finite = 0 , JYPCIe5111CoreOO::Continuous = 1 }
DIMode. More...
enum class | JYPCIe5111CoreOO::DISignalExportSource { JYPCIe5111CoreOO::StartTrig = 22 , JYPCIe5111CoreOO::ReferenceTrig = 23 , JYPCIe5111CoreOO::SampleClock = 53 }
SourceSignal. More...
enum class | JYPCIe5111CoreOO::DITriggerMode { JYPCIe5111CoreOO::Start , JYPCIe5111CoreOO::Reference }
DI Trigger Mode. More...
enum class | JYPCIe5111CoreOO::DITriggerType { JYPCIe5111CoreOO::Immediate = 0 , JYPCIe5111CoreOO::Digital = 1 , JYPCIe5111CoreOO::Soft = 3 }
TriggerType Digital/Immediate/Soft. More...
enum class JYPCIe5111CoreOO::DIDigitalTriggerSource {
JYPCIe5111CoreOO::PFI0 , JYPCIe5111CoreOO::PFI1 , JYPCIe5111CoreOO::PFI2 , JYPCIe5111CoreOO::PFI3 ,
JYPCIe5111CoreOO::PFI4 , JYPCIe5111CoreOO::PFI5 , JYPCIe5111CoreOO::PFI6 , JYPCIe5111CoreOO::PFI7 ,
JYPCIe5111CoreOO::PFI8 , JYPCIe5111CoreOO::PFI9 , JYPCIe5111CoreOO::PFI10 , JYPCIe5111CoreOO::PFI11 ,
JYPCIe5111CoreOO::PFI12 , JYPCIe5111CoreOO::PFI13 , JYPCIe5111CoreOO::PFI14 , JYPCIe5111CoreOO::PFI15 ,
JYPCIe5111CoreOO::PXI_Trig0 = 40 , JYPCIe5111CoreOO::PXI_Trig1 = 41 , JYPCIe5111CoreOO::PXI_Trig2 = 42 , JYPCIe5111CoreOO::PXI_Trig3 = 43 ,
JYPCIe5111CoreOO::PXI_Trig4 = 44 , JYPCIe5111CoreOO::PXI_Trig5 = 45 , JYPCIe5111CoreOO::PXI_Trig6 = 46 , JYPCIe5111CoreOO::PXI_Trig7 = 47 ,
JYPCIe5111CoreOO::AI_StartTrig = 16 , JYPCIe5111CoreOO::AI_ReferenceTrig = 17 , JYPCIe5111CoreOO::AO_StartTrig = 26 , JYPCIe5111CoreOO::DO_StartTrig = 29 ,
JYPCIe5111CoreOO::CI_0_StartTrig = 68 , JYPCIe5111CoreOO::CI_1_StartTrig = 73 , JYPCIe5111CoreOO::CI_2_StartTrig = 73 , JYPCIe5111CoreOO::CI_3_StartTrig = 73 ,
JYPCIe5111CoreOO::CO_0_StartTrig = 69 , JYPCIe5111CoreOO::CO_1_StartTrig = 74 , JYPCIe5111CoreOO::CO2_StartTrig = 77 , JYPCIe5111CoreOO::CO_3_StartTrig = 80 ,
JYPCIe5111CoreOO::CO_0_Output = 37 , JYPCIe5111CoreOO::CO_1_Output = 51 , JYPCIe5111CoreOO::CO_2_Output = 60 , JYPCIe5111CoreOO::CO_3_Output = 66
}
DI Digital trigger source. More...
enum class | JYPCIe5111CoreOO::DIDigitalTriggerEdge { JYPCIe5111CoreOO::Rising , JYPCIe5111CoreOO::Falling }
DI Digital Trigger Edge. More...


5111 C++ Programming Manual: JYPCIe5111CoreOO::JYPCIe5111CoreOODITask Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • JYPCIe5111CoreOODITask
Public Member Functions | Public Attributes | List of all members
JYPCIe5111CoreOO::JYPCIe5111CoreOODITask Class Reference

#include <JYPCIe5111CoreOODITask.h>

Public Member Functions

JYPCIe5111CoreOODITask (int slotNum)
JYPCIe5111CoreOODITask (std::string boardName)
~JYPCIe5111CoreOODITask ()
void | AddChannel (int portNum)
Add one channel.
void | AddChannel (std::vector< int > portsNum)
Add a group of channel.
void | RemoveChannel (int portNum)
Delete the specified port number .If it is -1, delete all ports.
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Start ()
Start DI task .
void | Stop ()
Stop DI task .
void | ReadSinglePoint (std::vector< bool > &readValues, int port)
Read one sample for specified channel in register.
void | ReadSinglePoint (std::vector< bool > &readValues)
Read one sample for all ports in register .
void | ReadSinglePoint (bool *readValues)
Read one sample for all ports in register .
void | ReadData (uint32_t *dataBuffer, uint32_t samplesToAcquire, int timeOut=10000)
Read the uint data from one port or multi-ports.
void | ReadData (std::vector< uint32_t > &dataBuffer, uint32_t samplesToAcquire, int timeOut=10000)
Read the uint data from one port or multi-ports.
void | ReadData (uint8_t *dataBuffer, uint32_t samplesToAcquire, int timeOut=10000)
Read the byte data from one port.
void | ReadData (std::vector< uint8_t > &dataBuffer, uint32_t samplesToAcquire, int timeOut=10000)
Read the byte data from one port.

Public Attributes

std::list< DIChannel * > | Channels
List of DI channels,(5111 support 6 ports)
DIMode Mode
DI acquisition mode，support Single/ Finite/Continuous.
JYPCIe5111CoreOOProperty< JYPCIe5111CoreOODITask, double, JYPCIe5111CoreOOPropertyType::READ_WRITE > | SampleRate
Sample rate per channel.
int | SamplesToAcquire
Number of samples to be read per channel.
DISampleClock * SampleClock
DI Sample Clock Configuration.
JYPCIe5111CoreOOProperty< JYPCIe5111CoreOODITask, int, JYPCIe5111CoreOOPropertyType::READ_ONLY > | BufLenInSamples
Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.
JYPCIe5111CoreOOProperty< JYPCIe5111CoreOODITask, uint64_t, JYPCIe5111CoreOOPropertyType::READ_ONLY > | AvailableSamples
Number of samples per channel that can be read in the buffer.
JYPCIe5111CoreOOProperty< JYPCIe5111CoreOODITask, uint64_t, JYPCIe5111CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
DITrigger * Trigger
DI Trigger Configuration.
DISignalExport * SignalExport
Export DI Signal.
JYPCIe5111CoreOODevice * Device
Device.

Constructor & Destructor Documentation

◆ JYPCIe5111CoreOODITask() [1/2]

JYPCIe5111CoreOO::JYPCIe5111CoreOODITask::JYPCIe5111CoreOODITask ( int slotNum )

◆ JYPCIe5111CoreOODITask() [2/2]

JYPCIe5111CoreOO::JYPCIe5111CoreOODITask::JYPCIe5111CoreOODITask ( std::string boardName )

◆ ~JYPCIe5111CoreOODITask()

JYPCIe5111CoreOO::JYPCIe5111CoreOODITask::~JYPCIe5111CoreOODITask ( )

Member Function Documentation

◆ AddChannel() [1/2]

void JYPCIe5111CoreOO::JYPCIe5111CoreOODITask::AddChannel ( int portNum )

Add one channel.

Parameters
portNum port number to be added.

◆ AddChannel() [2/2]

void JYPCIe5111CoreOO::JYPCIe5111CoreOODITask::AddChannel ( std::vector< int > portsNum )

Add a group of channel.

Parameters
portsNum an array of port numbers of added ports.

◆ ReadData() [1/4]

void JYPCIe5111CoreOO::JYPCIe5111CoreOODITask::ReadData | ( | std::vector< uint32_t > & | dataBuffer,
 |  | uint32_t | samplesToAcquire,
 |  | int | timeOut = 10000 )

Read the uint data from one port or multi-ports.

There are 4 ports, from 0 to 3. Each port has 8 lines, from 0 to 7. There are a total of 32 lines from 0 to 31. Each bit from low to high represents one line.

Parameters
dataBuffer | Data buffer
samplesToAcquire | Number of samples per port to be read
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadData() [2/4]

void JYPCIe5111CoreOO::JYPCIe5111CoreOODITask::ReadData | ( | std::vector< uint8_t > & | dataBuffer,
 |  | uint32_t | samplesToAcquire,
 |  | int | timeOut = 10000 )

Read the byte data from one port.

Each port has 8 lines from 0 to 7. Each bit from low to high represents one line.

Parameters
dataBuffer | Data buffer
samplesToAcquire | Number of samples per port to be read
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadData() [3/4]

void JYPCIe5111CoreOO::JYPCIe5111CoreOODITask::ReadData | ( | uint32_t * | dataBuffer,
 |  | uint32_t | samplesToAcquire,
 |  | int | timeOut = 10000 )

Read the uint data from one port or multi-ports.

There are 4 ports, from 0 to 3. Each port has 8 lines, from 0 to 7. There are a total of 32 lines from 0 to 31. Each bit from low to high represents one line.

Parameters
dataBuffer | Data buffer
samplesToAcquire | Number of samples per port to be read
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadData() [4/4]

void JYPCIe5111CoreOO::JYPCIe5111CoreOODITask::ReadData | ( | uint8_t * | dataBuffer,
 |  | uint32_t | samplesToAcquire,
 |  | int | timeOut = 10000 )

Read the byte data from one port.

Each port has 8 lines from 0 to 7. Each bit from low to high represents one line.

Parameters
dataBuffer | Data buffer
samplesToAcquire | Number of samples per port to be read
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadSinglePoint() [1/3]

void JYPCIe5111CoreOO::JYPCIe5111CoreOODITask::ReadSinglePoint ( bool * readValues )

Read one sample for all ports in register .

Available when Mode is DIMode.Single

Parameters
readValues Values read. Buffer size >= number of ports * 8.

◆ ReadSinglePoint() [2/3]

void JYPCIe5111CoreOO::JYPCIe5111CoreOODITask::ReadSinglePoint ( std::vector< bool > & readValues )

Read one sample for all ports in register .

Available when Mode is DIMode.Single

Parameters
readValues Values read. Buffer size >= number of ports * 8.

◆ ReadSinglePoint() [3/3]

void JYPCIe5111CoreOO::JYPCIe5111CoreOODITask::ReadSinglePoint | ( | std::vector< bool > & | readValues,
 |  | int | port )

Read one sample for specified channel in register.

. Available when Mode is DIMode.Single

Parameters
readValues | values read,. Buffer size >= 8
port | Specified port numbers.

◆ RemoveChannel()

void JYPCIe5111CoreOO::JYPCIe5111CoreOODITask::RemoveChannel ( int portNum )

Delete the specified port number .If it is -1, delete all ports.

Parameters
portNum port number to be delete.

◆ SendSoftwareTrigger()

void JYPCIe5111CoreOO::JYPCIe5111CoreOODITask::SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JYPCIe5111CoreOO::JYPCIe5111CoreOODITask::Start ( )

Start DI task .

◆ Stop()

void JYPCIe5111CoreOO::JYPCIe5111CoreOODITask::Stop ( )

Stop DI task .

Member Data Documentation

◆ AvailableSamples

JYPCIe5111CoreOOProperty<JYPCIe5111CoreOODITask, uint64_t, JYPCIe5111CoreOOPropertyType::READ_ONLY> JYPCIe5111CoreOO::JYPCIe5111CoreOODITask::AvailableSamples

Number of samples per channel that can be read in the buffer.

◆ BufLenInSamples

JYPCIe5111CoreOOProperty<JYPCIe5111CoreOODITask, int, JYPCIe5111CoreOOPropertyType::READ_ONLY> JYPCIe5111CoreOO::JYPCIe5111CoreOODITask::BufLenInSamples

Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.

◆ Channels

std::list<DIChannel*> JYPCIe5111CoreOO::JYPCIe5111CoreOODITask::Channels

List of DI channels,(5111 support 6 ports)

◆ Device

JYPCIe5111CoreOODevice* JYPCIe5111CoreOO::JYPCIe5111CoreOODITask::Device

Device.

◆ Mode

DIMode JYPCIe5111CoreOO::JYPCIe5111CoreOODITask::Mode

DI acquisition mode，support Single/ Finite/Continuous.

◆ SampleClock

DISampleClock* JYPCIe5111CoreOO::JYPCIe5111CoreOODITask::SampleClock

DI Sample Clock Configuration.

◆ SampleRate

JYPCIe5111CoreOOProperty<JYPCIe5111CoreOODITask, double, JYPCIe5111CoreOOPropertyType::READ_WRITE> JYPCIe5111CoreOO::JYPCIe5111CoreOODITask::SampleRate

Sample rate per channel.

Maximum sample rate is 10M The defalut sample rate = 10k You can read this property to obtain the sample rate that will actually take effect in the current configuration.

◆ SamplesToAcquire

int JYPCIe5111CoreOO::JYPCIe5111CoreOODITask::SamplesToAcquire

Number of samples to be read per channel.

Only valid when Mode is DIMode.Finite.

◆ SignalExport

DISignalExport* JYPCIe5111CoreOO::JYPCIe5111CoreOODITask::SignalExport

Export DI Signal.

◆ TransferedSamples

JYPCIe5111CoreOOProperty<JYPCIe5111CoreOODITask, uint64_t, JYPCIe5111CoreOOPropertyType::READ_ONLY> JYPCIe5111CoreOO::JYPCIe5111CoreOODITask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT DIMode::Single.

◆ Trigger

DITrigger* JYPCIe5111CoreOO::JYPCIe5111CoreOODITask::Trigger

DI Trigger Configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOODITask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::DIChannel Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • DIChannel
Public Attributes | List of all members
JYPCIe5111CoreOO::DIChannel Class Reference

DI Channel parameter class . More...

#include <JYPCIe5111CoreOODITask.h>

Public Attributes

int PortNum
port number.

Detailed Description

DI Channel parameter class .

Member Data Documentation

◆ PortNum

int JYPCIe5111CoreOO::DIChannel::PortNum

port number.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOODITask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::DISampleClock Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • DISampleClock
Public Attributes | List of all members
JYPCIe5111CoreOO::DISampleClock Class Reference

Sample clock configuration class. More...

#include <JYPCIe5111CoreOODITask.h>

Public Attributes

DISampleClockSource Source
Clock Source.
DIExternalSampleClock * External
External Sample Clock, Valid when Source is DISampleClockSource.External.

Detailed Description

Sample clock configuration class.

Member Data Documentation

◆ External

DIExternalSampleClock* JYPCIe5111CoreOO::DISampleClock::External

External Sample Clock, Valid when Source is DISampleClockSource.External.

◆ Source

DISampleClockSource JYPCIe5111CoreOO::DISampleClock::Source

Clock Source.

enum Internal/External

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOODITask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::DIExternalSampleClock Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • DIExternalSampleClock
Public Attributes | List of all members
JYPCIe5111CoreOO::DIExternalSampleClock Class Reference

External Sample Clock Configuration Class. More...

#include <JYPCIe5111CoreOODITask.h>

Public Attributes

ClockTerminal Terminal
External Sample Clock Input Terminal.
double ExpectedRate
Expected External Sample Clock Rate.

Detailed Description

External Sample Clock Configuration Class.

Member Data Documentation

◆ ExpectedRate

double JYPCIe5111CoreOO::DIExternalSampleClock::ExpectedRate

Expected External Sample Clock Rate.

◆ Terminal

ClockTerminal JYPCIe5111CoreOO::DIExternalSampleClock::Terminal

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOODITask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::DISignalExport Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • DISignalExport
Public Member Functions | List of all members
JYPCIe5111CoreOO::DISignalExport Class Reference

DI Signal Export Class. More...

#include <JYPCIe5111CoreOODITask.h>

Public Member Functions

void | Add (DISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (DISignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

DI Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JYPCIe5111CoreOO::DISignalExport::Add | ( | DISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | CI Signal Source
destination | Export Desination

◆ Add() [2/2]

void JYPCIe5111CoreOO::DISignalExport::Add | ( | DISignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | CI Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JYPCIe5111CoreOO::DISignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JYPCIe5111CoreOO::DISignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOODITask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::DITrigger Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • DITrigger
Public Attributes | List of all members
JYPCIe5111CoreOO::DITrigger Class Reference

Constructor to create an DITrigger task object. More...

#include <JYPCIe5111CoreOODITask.h>

Public Attributes

DITriggerType Type
DI trigger type.
DITriggerMode Mode
DI trigger mode.
DIDigitalTrigger * Digital
DI Digital Trigger.Valid when Type is DITriggerType.Digital.
uint32_t PreTriggerSamples
Pretrigger Samples, must be less than or equal to JYPCIe5111DITask.SamplesToAcquire.

Detailed Description

Constructor to create an DITrigger task object.

Used to build DI Trigger

Member Data Documentation

◆ Digital

DIDigitalTrigger* JYPCIe5111CoreOO::DITrigger::Digital

DI Digital Trigger.Valid when Type is DITriggerType.Digital.

◆ Mode

DITriggerMode JYPCIe5111CoreOO::DITrigger::Mode

DI trigger mode.

enum Start/Reference.

◆ PreTriggerSamples

uint32_t JYPCIe5111CoreOO::DITrigger::PreTriggerSamples

Pretrigger Samples, must be less than or equal to JYPCIe5111DITask.SamplesToAcquire.

Valid when Mode is DITriggerMode.Reference. Pretrigger samples, must be greater than 1. Valid when Type is DITriggerType.Digital.

◆ Type

DITriggerType JYPCIe5111CoreOO::DITrigger::Type

DI trigger type.

enum Digital/Immediate/Soft.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOODITask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::DIDigitalTrigger Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • DIDigitalTrigger
Public Attributes | List of all members
JYPCIe5111CoreOO::DIDigitalTrigger Class Reference

DI Digital trigger . More...

#include <JYPCIe5111CoreOODITask.h>

Public Attributes

DIDigitalTriggerSource Source
DI Digital Trigger source.
DIDigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Detailed Description

DI Digital trigger .

Member Data Documentation

◆ Edge

DIDigitalTriggerEdge JYPCIe5111CoreOO::DIDigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

DIDigitalTriggerSource JYPCIe5111CoreOO::DIDigitalTrigger::Source

DI Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOODITask.h


5111 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOODOTask.h File Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 5111
Classes | Namespaces | Enumerations
JYPCIe5111CoreOODOTask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JYPCIe5111CoreOOCommon.h"
#include "JYPCIe5111CoreOODevice.h"

Classes

class | JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
class | JYPCIe5111CoreOO::DOChannel
DO Channel parameter class . More...
class | JYPCIe5111CoreOO::DOSampleClock
Sample clock configuration class. More...
class | JYPCIe5111CoreOO::DOExternalSampleClock
External Sample Clock Configuration Class. More...
class | JYPCIe5111CoreOO::DODigitalTrigger
DO Digital trigger. More...
class | JYPCIe5111CoreOO::DOTrigger
Constructor to create an DOTrigger task object. More...
class | JYPCIe5111CoreOO::DOSignalExport
DO Signal Export Class. More...

Namespaces

namespace JYPCIe5111CoreOO

Enumerations

enum class | JYPCIe5111CoreOO::DOSampleClockSource { JYPCIe5111CoreOO::Internal , JYPCIe5111CoreOO::External }
DO Sample Clock Source. More...
enum class | JYPCIe5111CoreOO::DOMode { JYPCIe5111CoreOO::Single = 3 , JYPCIe5111CoreOO::Finite = 0 , JYPCIe5111CoreOO::ContinuousWrapping = 1 , JYPCIe5111CoreOO::ContinuousNoWrapping = 2 }
DOMode. More...
enum class | JYPCIe5111CoreOO::DODigitalTriggerEdge { JYPCIe5111CoreOO::Rising , JYPCIe5111CoreOO::Falling }
DO Digital Trigger Edge. More...
enum class JYPCIe5111CoreOO::DODigitalTriggerSource {
JYPCIe5111CoreOO::PFI0 , JYPCIe5111CoreOO::PFI1 , JYPCIe5111CoreOO::PFI2 , JYPCIe5111CoreOO::PFI3 ,
JYPCIe5111CoreOO::PFI4 , JYPCIe5111CoreOO::PFI5 , JYPCIe5111CoreOO::PFI6 , JYPCIe5111CoreOO::PFI7 ,
JYPCIe5111CoreOO::PFI8 , JYPCIe5111CoreOO::PFI9 , JYPCIe5111CoreOO::PFI10 , JYPCIe5111CoreOO::PFI11 ,
JYPCIe5111CoreOO::PFI12 , JYPCIe5111CoreOO::PFI13 , JYPCIe5111CoreOO::PFI14 , JYPCIe5111CoreOO::PFI15 ,
JYPCIe5111CoreOO::PXI_Trig0 = 40 , JYPCIe5111CoreOO::PXI_Trig1 = 41 , JYPCIe5111CoreOO::PXI_Trig2 = 42 , JYPCIe5111CoreOO::PXI_Trig3 = 43 ,
JYPCIe5111CoreOO::PXI_Trig4 = 44 , JYPCIe5111CoreOO::PXI_Trig5 = 45 , JYPCIe5111CoreOO::PXI_Trig6 = 46 , JYPCIe5111CoreOO::PXI_Trig7 = 47 ,
JYPCIe5111CoreOO::AI_StartTrig = 16 , JYPCIe5111CoreOO::AI_ReferenceTrig = 17 , JYPCIe5111CoreOO::AO_StartTrig = 26 , JYPCIe5111CoreOO::DI_StartTrig = 22 ,
JYPCIe5111CoreOO::DI_ReferenceTrig = 23 , JYPCIe5111CoreOO::CI_0_StartTrig = 68 , JYPCIe5111CoreOO::CI_1_StartTrig = 73 , JYPCIe5111CoreOO::CI_2_StartTrig = 76 ,
JYPCIe5111CoreOO::CI_3_StartTrig = 79 , JYPCIe5111CoreOO::CO_0_StartTrig = 69 , JYPCIe5111CoreOO::CO_1_StartTrig = 74 , JYPCIe5111CoreOO::CO_2_StartTrig = 77 ,
JYPCIe5111CoreOO::CO_3_StartTrig = 80 , JYPCIe5111CoreOO::CO_0_Output = 37 , JYPCIe5111CoreOO::CO_1_Output = 51 , JYPCIe5111CoreOO::CO_2_Output = 60 ,
JYPCIe5111CoreOO::CO_3_Output = 66
}
DO Digital trigger source. More...
enum class | JYPCIe5111CoreOO::DOTriggerType { JYPCIe5111CoreOO::Immediate = 0 , JYPCIe5111CoreOO::Digital = 1 , JYPCIe5111CoreOO::Soft = 3 }
TriggerType Digital/Immediate/Soft. More...
enum class | JYPCIe5111CoreOO::DOSignalExportSource { JYPCIe5111CoreOO::StartTrig = 29 , JYPCIe5111CoreOO::SampleClock = 54 }
SourceSignal. More...


5111 C++ Programming Manual: JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • JYPCIe5111CoreOODOTask
Public Member Functions | Public Attributes | List of all members
JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask Class Reference

#include <JYPCIe5111CoreOODOTask.h>

Public Member Functions

JYPCIe5111CoreOODOTask (int slotNum)
JYPCIe5111CoreOODOTask (std::string boardName)
~JYPCIe5111CoreOODOTask ()
void | AddChannel (int portNum)
Add one channel.
void | AddChannel (std::vector< int > portsNum)
Add a group of channel.
void | RemoveChannel (int portNum)
Delete the specified port number .If it is -1, delete all ports.
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Start ()
Start DO task .
void | Stop ()
Stop DO task .
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.
void | WriteSinglePoint (std::vector< bool > &writeValues, int port)
Write one sample to the specified port in register.Available when Mode is DOMode.Single when the portID is -1, write all enabled ports values,the writeValues Length must equal to 8, and the values store in the add order of ports, in one port, the order is form line 0 to line 7.
void | WriteSinglePoint (std::vector< bool > &writeValues)
Write one sample for all ports in register .
void | WriteData (uint32_t *dataBuffer, uint32_t samplesToUpdate, int timeOut=10000)
Write the uint data from one port or multi-ports.
void | WriteData (std::vector< uint32_t > &dataBuffer, uint32_t samplesToUpdate, int timeOut=10000)
Write the uint data from one port or multi-ports.
void | WriteData (uint8_t *dataBuffer, uint32_t samplesToUpdate, int timeOut=10000)
wirte the byte data to one port.
void | WriteData (std::vector< uint8_t > &dataBuffer, uint32_t samplesToUpdate, int timeOut=10000)
wirte the byte data to one port.

Public Attributes

std::list< DOChannel * > | Channels
List of DO channels,(5111 support 6 ports)
DOMode Mode
DO acquisition mode，support Single/ Finite/Continuous.
JYPCIe5111CoreOOProperty< JYPCIe5111CoreOODOTask, double, JYPCIe5111CoreOOPropertyType::READ_WRITE > | UpdateRate
Sample rate per channel.
int | SamplesToUpdate
Number of output samples to write per channel , Only valid when Mode is DOMode::Finite.
DOSampleClock * SampleClock
DO Sample Clock Configuration.
JYPCIe5111CoreOOProperty< JYPCIe5111CoreOODOTask, int, JYPCIe5111CoreOOPropertyType::READ_ONLY > | BufLenInSamples
Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.
JYPCIe5111CoreOOProperty< JYPCIe5111CoreOODOTask, uint64_t, JYPCIe5111CoreOOPropertyType::READ_ONLY > | AvaliableLenInSamples
Number of output samples per channel avaliable to write in DO buffuer.
JYPCIe5111CoreOOProperty< JYPCIe5111CoreOODOTask, uint64_t, JYPCIe5111CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
OutputCompleteState CompleteState
DO Output Complete State, Valid when Mode is NOT DOMode.Single.Default is Zero.
DOTrigger * Trigger
DO Trigger Configuration.
DOSignalExport * SignalExport
Export DO Signal.
JYPCIe5111CoreOODevice * Device
Device.

Constructor & Destructor Documentation

◆ JYPCIe5111CoreOODOTask() [1/2]

JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask::JYPCIe5111CoreOODOTask ( int slotNum )

◆ JYPCIe5111CoreOODOTask() [2/2]

JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask::JYPCIe5111CoreOODOTask ( std::string boardName )

◆ ~JYPCIe5111CoreOODOTask()

JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask::~JYPCIe5111CoreOODOTask ( )

Member Function Documentation

◆ AddChannel() [1/2]

void JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask::AddChannel ( int portNum )

Add one channel.

Parameters
portNum port number to be added.

◆ AddChannel() [2/2]

void JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask::AddChannel ( std::vector< int > portsNum )

Add a group of channel.

Parameters
portsNum an array of port numbers of added ports.

◆ RemoveChannel()

void JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask::RemoveChannel ( int portNum )

Delete the specified port number .If it is -1, delete all ports.

Parameters
portNum port number to be delete.

◆ SendSoftwareTrigger()

void JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask::SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask::Start ( )

Start DO task .

◆ Stop()

void JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask::Stop ( )

Stop DO task .

◆ WaitUntilDone()

bool JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask::WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Available when Mode is DOMode.Finite

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteData() [1/4]

void JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask::WriteData | ( | std::vector< uint32_t > & | dataBuffer,
 |  | uint32_t | samplesToUpdate,
 |  | int | timeOut = 10000 )

Write the uint data from one port or multi-ports.

There are 4 ports, from 0 to 3. Each port has 8 lines, from 0 to 7. There are a total of 32 lines from 0 to 31. Each bit from low to high represents one line.

Parameters
dataBuffer | Data buffer
samplesToUpdate | Number of samples per port to be write
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [2/4]

void JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask::WriteData | ( | std::vector< uint8_t > & | dataBuffer,
 |  | uint32_t | samplesToUpdate,
 |  | int | timeOut = 10000 )

wirte the byte data to one port.

Each port has 8 lines from 0 to 7. Each bit from low to high represents one line.

Parameters
dataBuffer | Data buffer
samplesToUpdate | Number of samples per port to be write
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [3/4]

void JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask::WriteData | ( | uint32_t * | dataBuffer,
 |  | uint32_t | samplesToUpdate,
 |  | int | timeOut = 10000 )

Write the uint data from one port or multi-ports.

There are 4 ports, from 0 to 3. Each port has 8 lines, from 0 to 7. There are a total of 32 lines from 0 to 31. Each bit from low to high represents one line.

Parameters
dataBuffer | Data buffer
samplesToUpdate | Number of samples per port to be write
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [4/4]

void JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask::WriteData | ( | uint8_t * | dataBuffer,
 |  | uint32_t | samplesToUpdate,
 |  | int | timeOut = 10000 )

wirte the byte data to one port.

Each port has 8 lines from 0 to 7. Each bit from low to high represents one line.

Parameters
dataBuffer | Data buffer
samplesToUpdate | Number of samples per port to be write
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteSinglePoint() [1/2]

void JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask::WriteSinglePoint ( std::vector< bool > & writeValues )

Write one sample for all ports in register .

Available when Mode is DIMode.Single

Parameters
readValues Values read. Buffer size = number of ports * 8.

◆ WriteSinglePoint() [2/2]

void JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask::WriteSinglePoint | ( | std::vector< bool > & | writeValues,
 |  | int | port )

Write one sample to the specified port in register.Available when Mode is DOMode.Single when the portID is -1, write all enabled ports values,the writeValues Length must equal to 8, and the values store in the add order of ports, in one port, the order is form line 0 to line 7.

Parameters
writeValues | values write,. Buffer size = 8
port | Specified port numbers.

Member Data Documentation

◆ AvaliableLenInSamples

JYPCIe5111CoreOOProperty<JYPCIe5111CoreOODOTask, uint64_t, JYPCIe5111CoreOOPropertyType::READ_ONLY> JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask::AvaliableLenInSamples

Number of output samples per channel avaliable to write in DO buffuer.

◆ BufLenInSamples

JYPCIe5111CoreOOProperty<JYPCIe5111CoreOODOTask, int, JYPCIe5111CoreOOPropertyType::READ_ONLY> JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask::BufLenInSamples

Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.

◆ Channels

std::list<DOChannel*> JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask::Channels

List of DO channels,(5111 support 6 ports)

◆ CompleteState

OutputCompleteState JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask::CompleteState

DO Output Complete State, Valid when Mode is NOT DOMode.Single.Default is Zero.

◆ Device

JYPCIe5111CoreOODevice* JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask::Device

Device.

◆ Mode

DOMode JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask::Mode

DO acquisition mode，support Single/ Finite/Continuous.

◆ SampleClock

DOSampleClock* JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask::SampleClock

DO Sample Clock Configuration.

◆ SamplesToUpdate

int JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask::SamplesToUpdate

Number of output samples to write per channel , Only valid when Mode is DOMode::Finite.

◆ SignalExport

DOSignalExport* JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask::SignalExport

Export DO Signal.

◆ TransferedSamples

JYPCIe5111CoreOOProperty<JYPCIe5111CoreOODOTask, uint64_t, JYPCIe5111CoreOOPropertyType::READ_ONLY> JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT DIMode::Single.

◆ Trigger

DOTrigger* JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask::Trigger

DO Trigger Configuration.

◆ UpdateRate

JYPCIe5111CoreOOProperty<JYPCIe5111CoreOODOTask, double, JYPCIe5111CoreOOPropertyType::READ_WRITE> JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask::UpdateRate

Sample rate per channel.

Maximum sample rate is 10M The defalut sample rate = 10k You can read this property to obtain the sample rate that will actually take effect in the current configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOODOTask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::DOChannel Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • DOChannel
Public Attributes | List of all members
JYPCIe5111CoreOO::DOChannel Class Reference

DO Channel parameter class . More...

#include <JYPCIe5111CoreOODOTask.h>

Public Attributes

int PortNum
port number.

Detailed Description

DO Channel parameter class .

Member Data Documentation

◆ PortNum

int JYPCIe5111CoreOO::DOChannel::PortNum

port number.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOODOTask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::DOSampleClock Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • DOSampleClock
Public Attributes | List of all members
JYPCIe5111CoreOO::DOSampleClock Class Reference

Sample clock configuration class. More...

#include <JYPCIe5111CoreOODOTask.h>

Public Attributes

DOSampleClockSource Source
Clock Source.
DOExternalSampleClock * External
External Sample Clock.Valid when Source is DOSampleClockSource.External.

Detailed Description

Sample clock configuration class.

Member Data Documentation

◆ External

DOExternalSampleClock* JYPCIe5111CoreOO::DOSampleClock::External

External Sample Clock.Valid when Source is DOSampleClockSource.External.

◆ Source

DOSampleClockSource JYPCIe5111CoreOO::DOSampleClock::Source

Clock Source.

enum Internal/External

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOODOTask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::DOExternalSampleClock Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • DOExternalSampleClock
Public Attributes | List of all members
JYPCIe5111CoreOO::DOExternalSampleClock Class Reference

External Sample Clock Configuration Class. More...

#include <JYPCIe5111CoreOODOTask.h>

Public Attributes

ClockTerminal Terminal
External Sample Clock Input Terminal.
double ExpectedRate
Expected External Sample Clock Rate.

Detailed Description

External Sample Clock Configuration Class.

Member Data Documentation

◆ ExpectedRate

double JYPCIe5111CoreOO::DOExternalSampleClock::ExpectedRate

Expected External Sample Clock Rate.

◆ Terminal

ClockTerminal JYPCIe5111CoreOO::DOExternalSampleClock::Terminal

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOODOTask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::DODigitalTrigger Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • DODigitalTrigger
Public Attributes | List of all members
JYPCIe5111CoreOO::DODigitalTrigger Class Reference

DO Digital trigger. More...

#include <JYPCIe5111CoreOODOTask.h>

Public Attributes

DODigitalTriggerSource Source
DO Digital Trigger source.
DODigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Detailed Description

DO Digital trigger.

Member Data Documentation

◆ Edge

DODigitalTriggerEdge JYPCIe5111CoreOO::DODigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

DODigitalTriggerSource JYPCIe5111CoreOO::DODigitalTrigger::Source

DO Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOODOTask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::DOTrigger Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • DOTrigger
Public Attributes | List of all members
JYPCIe5111CoreOO::DOTrigger Class Reference

Constructor to create an DOTrigger task object. More...

#include <JYPCIe5111CoreOODOTask.h>

Public Attributes

DOTriggerType Type
DO trigger type.
DODigitalTrigger * Digital
DO Digital Trigger.Valid when Type is DOTriggerType.Digital.

Detailed Description

Constructor to create an DOTrigger task object.

Used to build DO Trigger

Member Data Documentation

◆ Digital

DODigitalTrigger* JYPCIe5111CoreOO::DOTrigger::Digital

DO Digital Trigger.Valid when Type is DOTriggerType.Digital.

◆ Type

DOTriggerType JYPCIe5111CoreOO::DOTrigger::Type

DO trigger type.

enum Digital/Immediate/Soft.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOODOTask.h


5111 C++ Programming Manual: JYPCIe5111CoreOO::DOSignalExport Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • DOSignalExport
Public Member Functions | List of all members
JYPCIe5111CoreOO::DOSignalExport Class Reference

DO Signal Export Class. More...

#include <JYPCIe5111CoreOODOTask.h>

Public Member Functions

void | Add (DOSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (DOSignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

DO Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JYPCIe5111CoreOO::DOSignalExport::Add | ( | DOSignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | CI Signal Source
destination | Export Desination

◆ Add() [2/2]

void JYPCIe5111CoreOO::DOSignalExport::Add | ( | DOSignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | CI Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JYPCIe5111CoreOO::DOSignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JYPCIe5111CoreOO::DOSignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOODOTask.h


5111 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOLog.h File Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 5111
Classes | Namespaces | Enumerations
JYPCIe5111CoreOOLog.h File Reference
#include <queue>
#include <string>
#include <thread>
#include "JYPCIe5111CoreOOCommon.h"

Classes

class JYPCIe5111CoreOO::JYPCIe5111CoreOOLog

Namespaces

namespace JYPCIe5111CoreOO

Enumerations

enum class JYPCIe5111CoreOO::JYPCIe5111CoreOOLogLevel {
JYPCIe5111CoreOO::DEBUG_LOG_LEVEL , JYPCIe5111CoreOO::INFO_LOG_LEVEL , JYPCIe5111CoreOO::WARN_LOG_LEVEL , JYPCIe5111CoreOO::ERROR_LOG_LEVEL ,
JYPCIe5111CoreOO::FATAL_LOG_LEVEL
}


5111 C++ Programming Manual: JYPCIe5111CoreOO::JYPCIe5111CoreOOLog Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • JYPCIe5111CoreOOLog
Static Public Member Functions | Static Public Attributes | List of all members
JYPCIe5111CoreOO::JYPCIe5111CoreOOLog Class Reference

#include <JYPCIe5111CoreOOLog.h>

Static Public Member Functions

static void | Print (const char *format,...)
static void | Print (JYPCIe5111CoreOOLogLevel logLevel, const char *format,...)
static void | Flush ()

Static Public Attributes

static JYPCIe5111CoreOOLogLevel | LogLevel
static JYPCIe5111CoreOOProperty< JYPCIe5111CoreOOLog, bool, JYPCIe5111CoreOOPropertyType::READ_WRITE > | EnableLog

Member Function Documentation

◆ Flush()

static void JYPCIe5111CoreOO::JYPCIe5111CoreOOLog::Flush ( )
static

◆ Print() [1/2]

static void JYPCIe5111CoreOO::JYPCIe5111CoreOOLog::Print | ( | const char * | format,
 |  |  | ... )
 static

◆ Print() [2/2]

static void JYPCIe5111CoreOO::JYPCIe5111CoreOOLog::Print | ( | JYPCIe5111CoreOOLogLevel | logLevel,
 |  | const char * | format,
 |  |  | ... )
 static

Member Data Documentation

◆ EnableLog

JYPCIe5111CoreOOProperty<JYPCIe5111CoreOOLog, bool, JYPCIe5111CoreOOPropertyType::READ_WRITE> JYPCIe5111CoreOO::JYPCIe5111CoreOOLog::EnableLog
static

◆ LogLevel

JYPCIe5111CoreOOLogLevel JYPCIe5111CoreOO::JYPCIe5111CoreOOLog::LogLevel
static
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOLog.h


5111 C++ Programming Manual: Class List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
▼N JYPCIe5111CoreOO |
C AIAdvanced | AI Advance parameter
C AIAnalogEdgeComparator | AI Analog Edge Comparator
C AIAnalogHysteresisComparator | AI Analog Hysteresis Comparatorr
C AIAnalogTrigger | AI analog trigger
C AIAnalogWindowComparator | AI Analog Window Comparatorr
C AIChannel | AI Channel parameter class
C AIDigitalTrigger | AI Digital trigger class
C AIDSMode |
C AIExternalSampleClock | Sample clock configuration class
C AIRecord | AI Record Parameters
C AISampleClock | Sample clock configuration class
C AISignalExport | AI Signal Export Class
C AITrigger | Constructor to create an AITrigger task object
C AOChannel |
C AODigitalTrigger | AO Digital trigger
C AOExternalSampleClock | External Sample Clock Configuration Class
C AOSampleClock | AO Sample clock configuration class
C AOTrigger | Constructor to create an AOTrigger task object
C CIDigitalTrigger | CI Digital trigger
C CIExternalSampleClock | CI Implicit Sample Clock class
C CIImplicitSampleClock | CI Implicit Sample Clock class
C CIInternalSampleClock | CI Internal Sample Clock Configuration Class
C CISampleClock | CI Sample Clock class
C CISignalExport | CI Signal Export Class
C CITimebase | Timebase configuration class
C CITrigger | Constructor to create an CITrigger task object
C CODigitalTrigger | CO Digital trigger
C COPulse | Pulse Parameter
C COSignalExport | CO Signal Export Class
C COTimebase | Timebase configuration class
C COTrigger | Constructor to create an COTrigger task object
C DIChannel | DI Channel parameter class
C DIDigitalTrigger | DI Digital trigger
C DIExternalSampleClock | External Sample Clock Configuration Class
C DISampleClock | Sample clock configuration class
C DISignalExport | DI Signal Export Class
C DITrigger | Constructor to create an DITrigger task object
C DOChannel | DO Channel parameter class
C DODigitalTrigger | DO Digital trigger
C DOExternalSampleClock | External Sample Clock Configuration Class
C DOSampleClock | Sample clock configuration class
C DOSignalExport | DO Signal Export Class
C DOTrigger | Constructor to create an DOTrigger task object
C EdgeCounting | Configure CI EdgeCounting
C EdgeCountingOutEvent | Edge counting output event configuration class
C ExternalReferenceClock |
C FrequencyMeas | Configure CI Measure
C JYDriverException |
C JYPCIe5111CoreOOAITask | AITask类
C JYPCIe5111CoreOOAOTask |
C JYPCIe5111CoreOOCITask |
C JYPCIe5111CoreOOCOTask |
C JYPCIe5111CoreOODevice |
C JYPCIe5111CoreOODITask |
C JYPCIe5111CoreOODOTask |
C JYPCIe5111CoreOOLog |
C JYPCIe5111CoreOOProperty | 属性模板类
C JYPCIe5111CoreOOReferenceClock |
C PauseTrigger | Pause trigger configuration class
C PeriodMeas | Configure CI Measure
C PFIFilter |
C PFISetting |
C PulseMeas | Configure CI Measure
C QuadEncoder | Configure CI Measure
C TwoEdgeSeparation | Configure CI Measure
C TwoPulseEncoder | Configure CI Measure
C AOMode | AIMode
C JYPCIe5111CoreOOAIMode | AIMode


5111 C++ Programming Manual: AOMode Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
AOMode Class Reference

AIMode. More...

#include <JYPCIe5111CoreOOAOTask.h>

Detailed Description

AIMode.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOAOTask.h


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • AIAdvanced
JYPCIe5111CoreOO::AIAdvanced Member List

This is the complete list of members for JYPCIe5111CoreOO::AIAdvanced, including all inherited members.

ConvertRate | JYPCIe5111CoreOO::AIAdvanced
DSMode | JYPCIe5111CoreOO::AIAdvanced


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • AIAnalogEdgeComparator
JYPCIe5111CoreOO::AIAnalogEdgeComparator Member List

This is the complete list of members for JYPCIe5111CoreOO::AIAnalogEdgeComparator, including all inherited members.

Slope | JYPCIe5111CoreOO::AIAnalogEdgeComparator
Threshold | JYPCIe5111CoreOO::AIAnalogEdgeComparator


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • AIAnalogHysteresisComparator
JYPCIe5111CoreOO::AIAnalogHysteresisComparator Member List

This is the complete list of members for JYPCIe5111CoreOO::AIAnalogHysteresisComparator, including all inherited members.

HighThreshold | JYPCIe5111CoreOO::AIAnalogHysteresisComparator
LowThreshold | JYPCIe5111CoreOO::AIAnalogHysteresisComparator
Slope | JYPCIe5111CoreOO::AIAnalogHysteresisComparator


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • AIAnalogTrigger
JYPCIe5111CoreOO::AIAnalogTrigger Member List

This is the complete list of members for JYPCIe5111CoreOO::AIAnalogTrigger, including all inherited members.

Comparator | JYPCIe5111CoreOO::AIAnalogTrigger
Edge | JYPCIe5111CoreOO::AIAnalogTrigger
Hysteresis | JYPCIe5111CoreOO::AIAnalogTrigger
Source | JYPCIe5111CoreOO::AIAnalogTrigger
Window | JYPCIe5111CoreOO::AIAnalogTrigger


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • AIAnalogWindowComparator
JYPCIe5111CoreOO::AIAnalogWindowComparator Member List

This is the complete list of members for JYPCIe5111CoreOO::AIAnalogWindowComparator, including all inherited members.

Condition | JYPCIe5111CoreOO::AIAnalogWindowComparator
HighThreshold | JYPCIe5111CoreOO::AIAnalogWindowComparator
LowThreshold | JYPCIe5111CoreOO::AIAnalogWindowComparator


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • AIChannel
JYPCIe5111CoreOO::AIChannel Member List

This is the complete list of members for JYPCIe5111CoreOO::AIChannel, including all inherited members.

AIChannel(int channelId, double rangeLow, double rangeHigh, AITerminal terminalCfg=AITerminal::NRSE) | JYPCIe5111CoreOO::AIChannel | inline
ChannelID | JYPCIe5111CoreOO::AIChannel |
RangeHigh | JYPCIe5111CoreOO::AIChannel |
RangeLow | JYPCIe5111CoreOO::AIChannel |
Terminal | JYPCIe5111CoreOO::AIChannel |


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • AIDSMode
JYPCIe5111CoreOO::AIDSMode Member List

This is the complete list of members for JYPCIe5111CoreOO::AIDSMode, including all inherited members.

Enable | JYPCIe5111CoreOO::AIDSMode
PowerLine_Frequency | JYPCIe5111CoreOO::AIDSMode


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • AIDigitalTrigger
JYPCIe5111CoreOO::AIDigitalTrigger Member List

This is the complete list of members for JYPCIe5111CoreOO::AIDigitalTrigger, including all inherited members.

Edge | JYPCIe5111CoreOO::AIDigitalTrigger
Source | JYPCIe5111CoreOO::AIDigitalTrigger


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • AIExternalSampleClock
JYPCIe5111CoreOO::AIExternalSampleClock Member List

This is the complete list of members for JYPCIe5111CoreOO::AIExternalSampleClock, including all inherited members.

ExpectedRate | JYPCIe5111CoreOO::AIExternalSampleClock
Terminal | JYPCIe5111CoreOO::AIExternalSampleClock


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • AIRecord
JYPCIe5111CoreOO::AIRecord Member List

This is the complete list of members for JYPCIe5111CoreOO::AIRecord, including all inherited members.

File_Format | JYPCIe5111CoreOO::AIRecord
FilePath | JYPCIe5111CoreOO::AIRecord
Length | JYPCIe5111CoreOO::AIRecord
Mode | JYPCIe5111CoreOO::AIRecord


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • AISampleClock
JYPCIe5111CoreOO::AISampleClock Member List

This is the complete list of members for JYPCIe5111CoreOO::AISampleClock, including all inherited members.

External | JYPCIe5111CoreOO::AISampleClock
Source | JYPCIe5111CoreOO::AISampleClock


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • AISignalExport
JYPCIe5111CoreOO::AISignalExport Member List

This is the complete list of members for JYPCIe5111CoreOO::AISignalExport, including all inherited members.

Add(AISignalExportSource source, SignalExportDestination destination) | JYPCIe5111CoreOO::AISignalExport
Add(AISignalExportSource source, std::list< SignalExportDestination > destinations) | JYPCIe5111CoreOO::AISignalExport
Clear(SignalExportDestination destination) | JYPCIe5111CoreOO::AISignalExport
ClearAll() | JYPCIe5111CoreOO::AISignalExport


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • AITrigger
JYPCIe5111CoreOO::AITrigger Member List

This is the complete list of members for JYPCIe5111CoreOO::AITrigger, including all inherited members.

Analog | JYPCIe5111CoreOO::AITrigger
Digital | JYPCIe5111CoreOO::AITrigger
Mode | JYPCIe5111CoreOO::AITrigger
PreTriggerSamples | JYPCIe5111CoreOO::AITrigger
ReTriggerCount | JYPCIe5111CoreOO::AITrigger
Type | JYPCIe5111CoreOO::AITrigger


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • AOChannel
JYPCIe5111CoreOO::AOChannel Member List

This is the complete list of members for JYPCIe5111CoreOO::AOChannel, including all inherited members.

AOChannel(int channelId, double rangeLow, double rangeHigh) | JYPCIe5111CoreOO::AOChannel | inline
ChannelID | JYPCIe5111CoreOO::AOChannel |
RangeHigh | JYPCIe5111CoreOO::AOChannel |
RangeLow | JYPCIe5111CoreOO::AOChannel |


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • AODigitalTrigger
JYPCIe5111CoreOO::AODigitalTrigger Member List

This is the complete list of members for JYPCIe5111CoreOO::AODigitalTrigger, including all inherited members.

Edge | JYPCIe5111CoreOO::AODigitalTrigger
Source | JYPCIe5111CoreOO::AODigitalTrigger


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • AOExternalSampleClock
JYPCIe5111CoreOO::AOExternalSampleClock Member List

This is the complete list of members for JYPCIe5111CoreOO::AOExternalSampleClock, including all inherited members.

ExpectedRate | JYPCIe5111CoreOO::AOExternalSampleClock
Terminal | JYPCIe5111CoreOO::AOExternalSampleClock


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • AOSampleClock
JYPCIe5111CoreOO::AOSampleClock Member List

This is the complete list of members for JYPCIe5111CoreOO::AOSampleClock, including all inherited members.

External | JYPCIe5111CoreOO::AOSampleClock |
JYPCIe5111CoreOOAOTask class | JYPCIe5111CoreOO::AOSampleClock | friend
Source | JYPCIe5111CoreOO::AOSampleClock |


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • AOTrigger
JYPCIe5111CoreOO::AOTrigger Member List

This is the complete list of members for JYPCIe5111CoreOO::AOTrigger, including all inherited members.

Digital | JYPCIe5111CoreOO::AOTrigger
Type | JYPCIe5111CoreOO::AOTrigger


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • CIDigitalTrigger
JYPCIe5111CoreOO::CIDigitalTrigger Member List

This is the complete list of members for JYPCIe5111CoreOO::CIDigitalTrigger, including all inherited members.

Edge | JYPCIe5111CoreOO::CIDigitalTrigger
Source | JYPCIe5111CoreOO::CIDigitalTrigger


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • CIExternalSampleClock
JYPCIe5111CoreOO::CIExternalSampleClock Member List

This is the complete list of members for JYPCIe5111CoreOO::CIExternalSampleClock, including all inherited members.

ExpectedRate | JYPCIe5111CoreOO::CIExternalSampleClock
Terminal | JYPCIe5111CoreOO::CIExternalSampleClock


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • CIImplicitSampleClock
JYPCIe5111CoreOO::CIImplicitSampleClock Member List

This is the complete list of members for JYPCIe5111CoreOO::CIImplicitSampleClock, including all inherited members.

ExpectedRate JYPCIe5111CoreOO::CIImplicitSampleClock


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • CIInternalSampleClock
JYPCIe5111CoreOO::CIInternalSampleClock Member List

This is the complete list of members for JYPCIe5111CoreOO::CIInternalSampleClock, including all inherited members.

Rate JYPCIe5111CoreOO::CIInternalSampleClock


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • CISampleClock
JYPCIe5111CoreOO::CISampleClock Member List

This is the complete list of members for JYPCIe5111CoreOO::CISampleClock, including all inherited members.

External | JYPCIe5111CoreOO::CISampleClock
Implicit | JYPCIe5111CoreOO::CISampleClock
Internal | JYPCIe5111CoreOO::CISampleClock
Source | JYPCIe5111CoreOO::CISampleClock


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • CISignalExport
JYPCIe5111CoreOO::CISignalExport Member List

This is the complete list of members for JYPCIe5111CoreOO::CISignalExport, including all inherited members.

Add(CISignalExportSource source, SignalExportDestination destination) | JYPCIe5111CoreOO::CISignalExport
Add(CISignalExportSource source, std::list< SignalExportDestination > destinations) | JYPCIe5111CoreOO::CISignalExport
Clear(SignalExportDestination destination) | JYPCIe5111CoreOO::CISignalExport
ClearAll() | JYPCIe5111CoreOO::CISignalExport


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • CITimebase
JYPCIe5111CoreOO::CITimebase Member List

This is the complete list of members for JYPCIe5111CoreOO::CITimebase, including all inherited members.

Source JYPCIe5111CoreOO::CITimebase


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • CITrigger
JYPCIe5111CoreOO::CITrigger Member List

This is the complete list of members for JYPCIe5111CoreOO::CITrigger, including all inherited members.

Digital | JYPCIe5111CoreOO::CITrigger
Type | JYPCIe5111CoreOO::CITrigger


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • CODigitalTrigger
JYPCIe5111CoreOO::CODigitalTrigger Member List

This is the complete list of members for JYPCIe5111CoreOO::CODigitalTrigger, including all inherited members.

Edge | JYPCIe5111CoreOO::CODigitalTrigger
Source | JYPCIe5111CoreOO::CODigitalTrigger


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • COPulse
JYPCIe5111CoreOO::COPulse Member List

This is the complete list of members for JYPCIe5111CoreOO::COPulse, including all inherited members.

COPulse(COPulseType type, double param1, double param2, int count) | JYPCIe5111CoreOO::COPulse
COPulse() | JYPCIe5111CoreOO::COPulse
~COPulse() | JYPCIe5111CoreOO::COPulse


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • COSignalExport
JYPCIe5111CoreOO::COSignalExport Member List

This is the complete list of members for JYPCIe5111CoreOO::COSignalExport, including all inherited members.

Add(COSignalExportSource source, SignalExportDestination destination) | JYPCIe5111CoreOO::COSignalExport
Add(COSignalExportSource source, std::list< SignalExportDestination > destinations) | JYPCIe5111CoreOO::COSignalExport
Clear(SignalExportDestination destination) | JYPCIe5111CoreOO::COSignalExport
ClearAll() | JYPCIe5111CoreOO::COSignalExport


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • COTimebase
JYPCIe5111CoreOO::COTimebase Member List

This is the complete list of members for JYPCIe5111CoreOO::COTimebase, including all inherited members.

Source JYPCIe5111CoreOO::COTimebase


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • COTrigger
JYPCIe5111CoreOO::COTrigger Member List

This is the complete list of members for JYPCIe5111CoreOO::COTrigger, including all inherited members.

Digital | JYPCIe5111CoreOO::COTrigger
Type | JYPCIe5111CoreOO::COTrigger


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • DIChannel
JYPCIe5111CoreOO::DIChannel Member List

This is the complete list of members for JYPCIe5111CoreOO::DIChannel, including all inherited members.

PortNum JYPCIe5111CoreOO::DIChannel


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • DIDigitalTrigger
JYPCIe5111CoreOO::DIDigitalTrigger Member List

This is the complete list of members for JYPCIe5111CoreOO::DIDigitalTrigger, including all inherited members.

Edge | JYPCIe5111CoreOO::DIDigitalTrigger
Source | JYPCIe5111CoreOO::DIDigitalTrigger


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • DIExternalSampleClock
JYPCIe5111CoreOO::DIExternalSampleClock Member List

This is the complete list of members for JYPCIe5111CoreOO::DIExternalSampleClock, including all inherited members.

ExpectedRate | JYPCIe5111CoreOO::DIExternalSampleClock
Terminal | JYPCIe5111CoreOO::DIExternalSampleClock


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • DISampleClock
JYPCIe5111CoreOO::DISampleClock Member List

This is the complete list of members for JYPCIe5111CoreOO::DISampleClock, including all inherited members.

External | JYPCIe5111CoreOO::DISampleClock
Source | JYPCIe5111CoreOO::DISampleClock


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • DISignalExport
JYPCIe5111CoreOO::DISignalExport Member List

This is the complete list of members for JYPCIe5111CoreOO::DISignalExport, including all inherited members.

Add(DISignalExportSource source, SignalExportDestination destination) | JYPCIe5111CoreOO::DISignalExport
Add(DISignalExportSource source, std::list< SignalExportDestination > destinations) | JYPCIe5111CoreOO::DISignalExport
Clear(SignalExportDestination destination) | JYPCIe5111CoreOO::DISignalExport
ClearAll() | JYPCIe5111CoreOO::DISignalExport


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • DITrigger
JYPCIe5111CoreOO::DITrigger Member List

This is the complete list of members for JYPCIe5111CoreOO::DITrigger, including all inherited members.

Digital | JYPCIe5111CoreOO::DITrigger
Mode | JYPCIe5111CoreOO::DITrigger
PreTriggerSamples | JYPCIe5111CoreOO::DITrigger
Type | JYPCIe5111CoreOO::DITrigger


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • DOChannel
JYPCIe5111CoreOO::DOChannel Member List

This is the complete list of members for JYPCIe5111CoreOO::DOChannel, including all inherited members.

PortNum JYPCIe5111CoreOO::DOChannel


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • DODigitalTrigger
JYPCIe5111CoreOO::DODigitalTrigger Member List

This is the complete list of members for JYPCIe5111CoreOO::DODigitalTrigger, including all inherited members.

Edge | JYPCIe5111CoreOO::DODigitalTrigger
Source | JYPCIe5111CoreOO::DODigitalTrigger


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • DOExternalSampleClock
JYPCIe5111CoreOO::DOExternalSampleClock Member List

This is the complete list of members for JYPCIe5111CoreOO::DOExternalSampleClock, including all inherited members.

ExpectedRate | JYPCIe5111CoreOO::DOExternalSampleClock
Terminal | JYPCIe5111CoreOO::DOExternalSampleClock


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • DOSampleClock
JYPCIe5111CoreOO::DOSampleClock Member List

This is the complete list of members for JYPCIe5111CoreOO::DOSampleClock, including all inherited members.

External | JYPCIe5111CoreOO::DOSampleClock
Source | JYPCIe5111CoreOO::DOSampleClock


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • DOSignalExport
JYPCIe5111CoreOO::DOSignalExport Member List

This is the complete list of members for JYPCIe5111CoreOO::DOSignalExport, including all inherited members.

Add(DOSignalExportSource source, SignalExportDestination destination) | JYPCIe5111CoreOO::DOSignalExport
Add(DOSignalExportSource source, std::list< SignalExportDestination > destinations) | JYPCIe5111CoreOO::DOSignalExport
Clear(SignalExportDestination destination) | JYPCIe5111CoreOO::DOSignalExport
ClearAll() | JYPCIe5111CoreOO::DOSignalExport


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • DOTrigger
JYPCIe5111CoreOO::DOTrigger Member List

This is the complete list of members for JYPCIe5111CoreOO::DOTrigger, including all inherited members.

Digital | JYPCIe5111CoreOO::DOTrigger
Type | JYPCIe5111CoreOO::DOTrigger


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • EdgeCounting
JYPCIe5111CoreOO::EdgeCounting Member List

This is the complete list of members for JYPCIe5111CoreOO::EdgeCounting, including all inherited members.

ActiveEdge | JYPCIe5111CoreOO::EdgeCounting
Direction | JYPCIe5111CoreOO::EdgeCounting
DirTerminal | JYPCIe5111CoreOO::EdgeCounting
InitialCount | JYPCIe5111CoreOO::EdgeCounting
Input_Terminal | JYPCIe5111CoreOO::EdgeCounting
OutEvent | JYPCIe5111CoreOO::EdgeCounting
Pause | JYPCIe5111CoreOO::EdgeCounting


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • EdgeCountingOutEvent
JYPCIe5111CoreOO::EdgeCountingOutEvent Member List

This is the complete list of members for JYPCIe5111CoreOO::EdgeCountingOutEvent, including all inherited members.

IdleState | JYPCIe5111CoreOO::EdgeCountingOutEvent
Terminal | JYPCIe5111CoreOO::EdgeCountingOutEvent
Threshold | JYPCIe5111CoreOO::EdgeCountingOutEvent


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • ExternalReferenceClock
JYPCIe5111CoreOO::ExternalReferenceClock Member List

This is the complete list of members for JYPCIe5111CoreOO::ExternalReferenceClock, including all inherited members.

Terminal JYPCIe5111CoreOO::ExternalReferenceClock


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • FrequencyMeas
JYPCIe5111CoreOO::FrequencyMeas Member List

This is the complete list of members for JYPCIe5111CoreOO::FrequencyMeas, including all inherited members.

Input_Terminal | JYPCIe5111CoreOO::FrequencyMeas
Timebase | JYPCIe5111CoreOO::FrequencyMeas


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • JYDriverException
JYPCIe5111CoreOO::JYDriverException Member List

This is the complete list of members for JYPCIe5111CoreOO::JYDriverException, including all inherited members.

errorCode | JYPCIe5111CoreOO::JYDriverException
exceptionMessage | JYPCIe5111CoreOO::JYDriverException
FollowingException | JYPCIe5111CoreOO::JYDriverException
JYDriverException(JYDriverExceptionPublic exceptionCode, std::string msg="") | JYPCIe5111CoreOO::JYDriverException
JYDriverException(int, std::string msg) | JYPCIe5111CoreOO::JYDriverException


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • JYPCIe5111CoreOOAITask
JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask Member List

This is the complete list of members for JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask, including all inherited members.

AddChannel(int chnId, double rangeLow=-10, double rangeHigh=10, AITerminal terminalCfg=AITerminal::RSE) | JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask |
AddChannel(std::vector< int > chnsId, double rangeLow=-10, double rangeHigh=10, AITerminal terminalCfg=AITerminal::RSE) | JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask |
AddChannel(std::vector< int > chnsId, std::vector< double > rangeLow, std::vector< double > rangeHigh, AITerminal terminalCfg=AITerminal::RSE) | JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask |
Advanced | JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask |
AvailableSamples | JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask |
BufLenInSamples | JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask |
Channels | JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask |
Device | JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask |
GetRecordPreviewData(double *buf, int samplesPerChannel, int timeout) | JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask |
GetRecordPreviewData(std::vector< double > &buf, int samplesPerChannel, int timeout) | JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask |
GetRecordStatus(double &recordedLength, bool &recordDone) | JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask |
JYPCIe5111CoreOOAITask(int slotNum) | JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask |
JYPCIe5111CoreOOAITask(std::string boardName) | JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask |
Mode | JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask |
ReadData(double *pBuf, int samplesPerChannel, int timeout=-1) | JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask |
ReadData(std::vector< double > &pBuf, int samplesPerChannel, int timeout=-1) | JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask |
ReadRawData(int *pBuf, int samplesPerChannel, int timeout=-1) | JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask |
ReadRawData(std::vector< int > &pBuf, int samplesPerChannel, int timeout=-1) | JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask |
ReadRawSinglePoint(int &readValue, int channel) | JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask |
ReadRawSinglePoint(std::vector< uint32_t > &readValues) | JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask |
ReadSinglePoint(double &readValue, int channel) | JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask |
ReadSinglePoint(std::vector< double > &readValues) | JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask |
Record | JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask |
RemoveChannel(int chnId) | JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask |
SampleClock | JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask |
SampleRate | JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask |
SamplesToAcquire | JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask |
SendSoftwareTrigger() | JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask |
SignalExport | JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask |
Start() | JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask |
Stop() | JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask |
TransferedSamples | JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask |
Trigger | JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask |
WaitUntilDone(int timeout=-1) | JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask | inline
~JYPCIe5111CoreOOAITask() | JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask |


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • JYPCIe5111CoreOOAOTask
JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask Member List

This is the complete list of members for JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask, including all inherited members.

AddChannel(int chnId, double rangeLow=-10, double rangeHigh=10) | JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask
AddChannel(std::vector< int > chnsId, double rangeLow=-10, double rangeHigh=10) | JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask
AddChannel(std::vector< int > chnsId, std::vector< double > rangeLow, std::vector< double > rangeHigh) | JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask
AvaliableLenInSamples | JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask
BufLenInSamples | JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask
Channels | JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask
CompleteState | JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask
Device | JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask
JYPCIe5111CoreOOAOTask(int slotNum) | JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask
JYPCIe5111CoreOOAOTask(std::string boardName) | JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask
Mode | JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask
RemoveChannel(int chnId) | JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask
SampleClock | JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask
SamplesToUpdate | JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask
SendSoftwareTrigger() | JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask
SignalExport | JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask
Start() | JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask
Stop() | JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask
TransferedSamples | JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask
Trigger | JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask
UpdateRate | JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask
WaitUntilDone(int timeout=-1) | JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask
WriteData(double *pBuf, int samplesPerChannel, int timeout=10000) | JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask
WriteData(std::vector< double > &pBuf, int samplesPerChannel, int timeout=10000) | JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask
WriteRawData(int16_t *pBuf, int samplesPerChannel, int timeout=10000) | JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask
WriteRawData(std::vector< int16_t > &pBuf, int samplesPerChannel, int timeout=10000) | JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask
WriteRawSinglePoint(std::vector< int16_t > writeValues) | JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask
WriteRawSinglePoint(int16_t writeValue, int channel) | JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask
WriteSinglePoint(std::vector< double > writeValues) | JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask
WriteSinglePoint(double writeValue, int channel) | JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask
~JYPCIe5111CoreOOAOTask() | JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • JYPCIe5111CoreOOCITask
JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask Member List

This is the complete list of members for JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask, including all inherited members.

AvailableSamples | JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
Device | JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
EdgeCounting | JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
FrequencyMeas | JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
JYPCIe5111CoreOOCITask(int slotNum, int channel) | JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
JYPCIe5111CoreOOCITask(std::string boardName, int channel) | JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
Mode | JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
PeriodMeas | JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
PulseMeas | JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
QuadEncoder | JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
ReadData(int *pBufCount, int samplesToAcquire, int timeout=10000) | JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
ReadData(std::vector< int > &pBufCount, int samplesToAcquire, int timeout=10000) | JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
ReadData(double *pBufMeasurement, int samplesToAcquire, int timeout=10000) | JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
ReadData(std::vector< double > &pBufMeasurement, int samplesToAcquire, int timeout=10000) | JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
ReadData(double *pBufMeasurement1, double *pBufMeasurement2, int samplesToAcquire, int timeout=10000) | JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
ReadData(std::vector< double > &pBufMeasurement1, std::vector< double > &pBufMeasurement2, int samplesToAcquire, int timeout=10000) | JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
ReadSinglePoint(int &count) | JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
ReadSinglePoint(double &measurement, int timeout=10000) | JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
ReadSinglePoint(double &measurement1, double &measurement2, int timeout=10000) | JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
SampleClock | JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
SamplesToAcquire | JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
SendSoftwareTrigger() | JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
SignalExport | JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
Start() | JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
Stop() | JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
TransferedSamples | JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
Trigger | JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
TwoEdgeSeparation | JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
TwoPulseEncoder | JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
Type | JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
~JYPCIe5111CoreOOCITask() | JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • JYPCIe5111CoreOOCOTask
JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask Member List

This is the complete list of members for JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask, including all inherited members.

AvailableSamples | JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask
Device | JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask
IdleState | JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask
InitialDelay | JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask
JYPCIe5111CoreOOCOTask(int slotNum, int channel) | JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask
JYPCIe5111CoreOOCOTask(std::string boardName, int channel) | JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask
Mode | JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask
OutputTerminal | JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask
Pause | JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask
SamplesToUpdate | JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask
SendSoftwareTrigger() | JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask
SignalExport | JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask
Start() | JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask
Stop() | JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask
TimeBase | JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask
TransferedPulses | JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask
TransferedSamples | JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask
Trigger | JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask
WaitUntilDone(int timeout=-1) | JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask
WriteData(COPulse *pulsesGroup[], int samplesToWrite, int timeout=10000) | JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask
WriteSinglePoint(COPulse &pulse) | JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask
~JYPCIe5111CoreOOCOTask() | JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • JYPCIe5111CoreOODITask
JYPCIe5111CoreOO::JYPCIe5111CoreOODITask Member List

This is the complete list of members for JYPCIe5111CoreOO::JYPCIe5111CoreOODITask, including all inherited members.

AddChannel(int portNum) | JYPCIe5111CoreOO::JYPCIe5111CoreOODITask
AddChannel(std::vector< int > portsNum) | JYPCIe5111CoreOO::JYPCIe5111CoreOODITask
AvailableSamples | JYPCIe5111CoreOO::JYPCIe5111CoreOODITask
BufLenInSamples | JYPCIe5111CoreOO::JYPCIe5111CoreOODITask
Channels | JYPCIe5111CoreOO::JYPCIe5111CoreOODITask
Device | JYPCIe5111CoreOO::JYPCIe5111CoreOODITask
JYPCIe5111CoreOODITask(int slotNum) | JYPCIe5111CoreOO::JYPCIe5111CoreOODITask
JYPCIe5111CoreOODITask(std::string boardName) | JYPCIe5111CoreOO::JYPCIe5111CoreOODITask
Mode | JYPCIe5111CoreOO::JYPCIe5111CoreOODITask
ReadData(uint32_t *dataBuffer, uint32_t samplesToAcquire, int timeOut=10000) | JYPCIe5111CoreOO::JYPCIe5111CoreOODITask
ReadData(std::vector< uint32_t > &dataBuffer, uint32_t samplesToAcquire, int timeOut=10000) | JYPCIe5111CoreOO::JYPCIe5111CoreOODITask
ReadData(uint8_t *dataBuffer, uint32_t samplesToAcquire, int timeOut=10000) | JYPCIe5111CoreOO::JYPCIe5111CoreOODITask
ReadData(std::vector< uint8_t > &dataBuffer, uint32_t samplesToAcquire, int timeOut=10000) | JYPCIe5111CoreOO::JYPCIe5111CoreOODITask
ReadSinglePoint(std::vector< bool > &readValues, int port) | JYPCIe5111CoreOO::JYPCIe5111CoreOODITask
ReadSinglePoint(std::vector< bool > &readValues) | JYPCIe5111CoreOO::JYPCIe5111CoreOODITask
ReadSinglePoint(bool *readValues) | JYPCIe5111CoreOO::JYPCIe5111CoreOODITask
RemoveChannel(int portNum) | JYPCIe5111CoreOO::JYPCIe5111CoreOODITask
SampleClock | JYPCIe5111CoreOO::JYPCIe5111CoreOODITask
SampleRate | JYPCIe5111CoreOO::JYPCIe5111CoreOODITask
SamplesToAcquire | JYPCIe5111CoreOO::JYPCIe5111CoreOODITask
SendSoftwareTrigger() | JYPCIe5111CoreOO::JYPCIe5111CoreOODITask
SignalExport | JYPCIe5111CoreOO::JYPCIe5111CoreOODITask
Start() | JYPCIe5111CoreOO::JYPCIe5111CoreOODITask
Stop() | JYPCIe5111CoreOO::JYPCIe5111CoreOODITask
TransferedSamples | JYPCIe5111CoreOO::JYPCIe5111CoreOODITask
Trigger | JYPCIe5111CoreOO::JYPCIe5111CoreOODITask
~JYPCIe5111CoreOODITask() | JYPCIe5111CoreOO::JYPCIe5111CoreOODITask


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • JYPCIe5111CoreOODOTask
JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask Member List

This is the complete list of members for JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask, including all inherited members.

AddChannel(int portNum) | JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
AddChannel(std::vector< int > portsNum) | JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
AvaliableLenInSamples | JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
BufLenInSamples | JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
Channels | JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
CompleteState | JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
Device | JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
JYPCIe5111CoreOODOTask(int slotNum) | JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
JYPCIe5111CoreOODOTask(std::string boardName) | JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
Mode | JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
RemoveChannel(int portNum) | JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
SampleClock | JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
SamplesToUpdate | JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
SendSoftwareTrigger() | JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
SignalExport | JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
Start() | JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
Stop() | JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
TransferedSamples | JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
Trigger | JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
UpdateRate | JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
WaitUntilDone(int timeout=-1) | JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
WriteData(uint32_t *dataBuffer, uint32_t samplesToUpdate, int timeOut=10000) | JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
WriteData(std::vector< uint32_t > &dataBuffer, uint32_t samplesToUpdate, int timeOut=10000) | JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
WriteData(uint8_t *dataBuffer, uint32_t samplesToUpdate, int timeOut=10000) | JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
WriteData(std::vector< uint8_t > &dataBuffer, uint32_t samplesToUpdate, int timeOut=10000) | JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
WriteSinglePoint(std::vector< bool > &writeValues, int port) | JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
WriteSinglePoint(std::vector< bool > &writeValues) | JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
~JYPCIe5111CoreOODOTask() | JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • JYPCIe5111CoreOODevice
JYPCIe5111CoreOO::JYPCIe5111CoreOODevice Member List

This is the complete list of members for JYPCIe5111CoreOO::JYPCIe5111CoreOODevice, including all inherited members.

AIBufferSize | JYPCIe5111CoreOO::JYPCIe5111CoreOODevice |
AOChannelCount | JYPCIe5111CoreOO::JYPCIe5111CoreOODevice |
BoardClockRate | JYPCIe5111CoreOO::JYPCIe5111CoreOODevice |
DeviceID | JYPCIe5111CoreOO::JYPCIe5111CoreOODevice |
DiffChannelCount | JYPCIe5111CoreOO::JYPCIe5111CoreOODevice |
GetInstance(int cardNum) | JYPCIe5111CoreOO::JYPCIe5111CoreOODevice | static
GetInstance(std::string aliasName) | JYPCIe5111CoreOO::JYPCIe5111CoreOODevice | static
Handle | JYPCIe5111CoreOO::JYPCIe5111CoreOODevice |
IsAISync | JYPCIe5111CoreOO::JYPCIe5111CoreOODevice |
IsAOSync | JYPCIe5111CoreOO::JYPCIe5111CoreOODevice |
MaxSampleRateMutilChannel | JYPCIe5111CoreOO::JYPCIe5111CoreOODevice |
MaxSampleRateSingleChannel | JYPCIe5111CoreOO::JYPCIe5111CoreOODevice |
MaxUpdateRate | JYPCIe5111CoreOO::JYPCIe5111CoreOODevice |
MaxUpdateRateSingleChannel | JYPCIe5111CoreOO::JYPCIe5111CoreOODevice |
PFI | JYPCIe5111CoreOO::JYPCIe5111CoreOODevice |
ReferenceClock | JYPCIe5111CoreOO::JYPCIe5111CoreOODevice |
SEChannelCount | JYPCIe5111CoreOO::JYPCIe5111CoreOODevice |
SerialNumber | JYPCIe5111CoreOO::JYPCIe5111CoreOODevice |


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • JYPCIe5111CoreOOLog
JYPCIe5111CoreOO::JYPCIe5111CoreOOLog Member List

This is the complete list of members for JYPCIe5111CoreOO::JYPCIe5111CoreOOLog, including all inherited members.

EnableLog | JYPCIe5111CoreOO::JYPCIe5111CoreOOLog | static
Flush() | JYPCIe5111CoreOO::JYPCIe5111CoreOOLog | static
LogLevel | JYPCIe5111CoreOO::JYPCIe5111CoreOOLog | static
Print(const char *format,...) | JYPCIe5111CoreOO::JYPCIe5111CoreOOLog | static
Print(JYPCIe5111CoreOOLogLevel logLevel, const char *format,...) | JYPCIe5111CoreOO::JYPCIe5111CoreOOLog | static


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • JYPCIe5111CoreOOProperty
JYPCIe5111CoreOO::JYPCIe5111CoreOOProperty< ContainerClass, ValueType, propertyType > Member List

This is the complete list of members for JYPCIe5111CoreOO::JYPCIe5111CoreOOProperty< ContainerClass, ValueType, propertyType >, including all inherited members.

JYPCIe5111CoreOOProperty() | JYPCIe5111CoreOO::JYPCIe5111CoreOOProperty< ContainerClass, ValueType, propertyType >
JYPCIe5111CoreOOProperty(ContainerClass *cObject, ValueType(ContainerClass::*pGet)(), void(ContainerClass::*pSet)(ValueType value)) | JYPCIe5111CoreOO::JYPCIe5111CoreOOProperty< ContainerClass, ValueType, propertyType >
JYPCIe5111CoreOOProperty(ValueType(*pGet)(), void(*pSet)(ValueType value)) | JYPCIe5111CoreOO::JYPCIe5111CoreOOProperty< ContainerClass, ValueType, propertyType >
operator ValueType() | JYPCIe5111CoreOO::JYPCIe5111CoreOOProperty< ContainerClass, ValueType, propertyType >
operator=(const ValueType &value) | JYPCIe5111CoreOO::JYPCIe5111CoreOOProperty< ContainerClass, ValueType, propertyType >


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • JYPCIe5111CoreOOReferenceClock
JYPCIe5111CoreOO::JYPCIe5111CoreOOReferenceClock Member List

This is the complete list of members for JYPCIe5111CoreOO::JYPCIe5111CoreOOReferenceClock, including all inherited members.

Commit() | JYPCIe5111CoreOO::JYPCIe5111CoreOOReferenceClock
External | JYPCIe5111CoreOO::JYPCIe5111CoreOOReferenceClock
Source | JYPCIe5111CoreOO::JYPCIe5111CoreOOReferenceClock


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • PFIFilter
JYPCIe5111CoreOO::PFIFilter Member List

This is the complete list of members for JYPCIe5111CoreOO::PFIFilter, including all inherited members.

Disable(PFITerminal terminal) | JYPCIe5111CoreOO::PFIFilter
Disable(std::vector< PFITerminal > terminals) | JYPCIe5111CoreOO::PFIFilter
DisableAll() | JYPCIe5111CoreOO::PFIFilter
Enable(PFITerminal terminal, int minPulseWidth) | JYPCIe5111CoreOO::PFIFilter
Enable(std::vector< PFITerminal > terminals, int minPulseWidth) | JYPCIe5111CoreOO::PFIFilter
Enable(std::vector< PFITerminal > terminals, std::vector< int > minPulseWidth) | JYPCIe5111CoreOO::PFIFilter


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • PFISetting
JYPCIe5111CoreOO::PFISetting Member List

This is the complete list of members for JYPCIe5111CoreOO::PFISetting, including all inherited members.

Filter JYPCIe5111CoreOO::PFISetting


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • PauseTrigger
JYPCIe5111CoreOO::PauseTrigger Member List

This is the complete list of members for JYPCIe5111CoreOO::PauseTrigger, including all inherited members.

ActivePolarity | JYPCIe5111CoreOO::PauseTrigger
Terminal | JYPCIe5111CoreOO::PauseTrigger


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • PeriodMeas
JYPCIe5111CoreOO::PeriodMeas Member List

This is the complete list of members for JYPCIe5111CoreOO::PeriodMeas, including all inherited members.

Input_Terminal | JYPCIe5111CoreOO::PeriodMeas
Timebase | JYPCIe5111CoreOO::PeriodMeas


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • PulseMeas
JYPCIe5111CoreOO::PulseMeas Member List

This is the complete list of members for JYPCIe5111CoreOO::PulseMeas, including all inherited members.

Input_Terminal | JYPCIe5111CoreOO::PulseMeas
Timebase | JYPCIe5111CoreOO::PulseMeas


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • QuadEncoder
JYPCIe5111CoreOO::QuadEncoder Member List

This is the complete list of members for JYPCIe5111CoreOO::QuadEncoder, including all inherited members.

AInputTerminal | JYPCIe5111CoreOO::QuadEncoder
BInputTerminal | JYPCIe5111CoreOO::QuadEncoder
EncodingType | JYPCIe5111CoreOO::QuadEncoder
InitialCount | JYPCIe5111CoreOO::QuadEncoder
ZInputTerminal | JYPCIe5111CoreOO::QuadEncoder
ZReloadEnabled | JYPCIe5111CoreOO::QuadEncoder


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • TwoEdgeSeparation
JYPCIe5111CoreOO::TwoEdgeSeparation Member List

This is the complete list of members for JYPCIe5111CoreOO::TwoEdgeSeparation, including all inherited members.

FirstInputTerminal | JYPCIe5111CoreOO::TwoEdgeSeparation
SecondInputTerminal | JYPCIe5111CoreOO::TwoEdgeSeparation
Timebase | JYPCIe5111CoreOO::TwoEdgeSeparation


5111 C++ Programming Manual: Member List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111CoreOO
  • TwoPulseEncoder
JYPCIe5111CoreOO::TwoPulseEncoder Member List

This is the complete list of members for JYPCIe5111CoreOO::TwoPulseEncoder, including all inherited members.

AInputTerminal | JYPCIe5111CoreOO::TwoPulseEncoder
BInputTerminal | JYPCIe5111CoreOO::TwoPulseEncoder
InitialCount | JYPCIe5111CoreOO::TwoPulseEncoder


5111 C++ Programming Manual: JYPCIe5111CoreOOAIMode Class Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
JYPCIe5111CoreOOAIMode Class Reference

AIMode. More...

#include <JYPCIe5111CoreOOAITask.h>

Detailed Description

AIMode.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5111/JYPCIe5111CoreOOAITask.h


5111 C++ Programming Manual: Class Index

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
Class Index
A | C | D | E | F | J | P | Q | T
A
AIAdvanced (JYPCIe5111CoreOO)
AIAnalogEdgeComparator (JYPCIe5111CoreOO)
AIAnalogHysteresisComparator (JYPCIe5111CoreOO)
AIAnalogTrigger (JYPCIe5111CoreOO)
AIAnalogWindowComparator (JYPCIe5111CoreOO)
AIChannel (JYPCIe5111CoreOO)
AIDigitalTrigger (JYPCIe5111CoreOO)
AIDSMode (JYPCIe5111CoreOO)
AIExternalSampleClock (JYPCIe5111CoreOO)
AIRecord (JYPCIe5111CoreOO)
AISampleClock (JYPCIe5111CoreOO)
AISignalExport (JYPCIe5111CoreOO)
AITrigger (JYPCIe5111CoreOO)
AOChannel (JYPCIe5111CoreOO)
AODigitalTrigger (JYPCIe5111CoreOO)
AOExternalSampleClock (JYPCIe5111CoreOO)
AOMode
AOSampleClock (JYPCIe5111CoreOO)
AOTrigger (JYPCIe5111CoreOO)
C
CIDigitalTrigger (JYPCIe5111CoreOO)
CIExternalSampleClock (JYPCIe5111CoreOO)
CIImplicitSampleClock (JYPCIe5111CoreOO)
CIInternalSampleClock (JYPCIe5111CoreOO)
CISampleClock (JYPCIe5111CoreOO)
CISignalExport (JYPCIe5111CoreOO)
CITimebase (JYPCIe5111CoreOO)
CITrigger (JYPCIe5111CoreOO)
CODigitalTrigger (JYPCIe5111CoreOO)
COPulse (JYPCIe5111CoreOO)
COSignalExport (JYPCIe5111CoreOO)
COTimebase (JYPCIe5111CoreOO)
COTrigger (JYPCIe5111CoreOO)
D
DIChannel (JYPCIe5111CoreOO)
DIDigitalTrigger (JYPCIe5111CoreOO)
DIExternalSampleClock (JYPCIe5111CoreOO)
DISampleClock (JYPCIe5111CoreOO)
DISignalExport (JYPCIe5111CoreOO)
DITrigger (JYPCIe5111CoreOO)
DOChannel (JYPCIe5111CoreOO)
DODigitalTrigger (JYPCIe5111CoreOO)
DOExternalSampleClock (JYPCIe5111CoreOO)
DOSampleClock (JYPCIe5111CoreOO)
DOSignalExport (JYPCIe5111CoreOO)
DOTrigger (JYPCIe5111CoreOO)
E
EdgeCounting (JYPCIe5111CoreOO)
EdgeCountingOutEvent (JYPCIe5111CoreOO)
ExternalReferenceClock (JYPCIe5111CoreOO)
F
FrequencyMeas (JYPCIe5111CoreOO)
J
JYDriverException (JYPCIe5111CoreOO)
JYPCIe5111CoreOOAIMode
JYPCIe5111CoreOOAITask (JYPCIe5111CoreOO)
JYPCIe5111CoreOOAOTask (JYPCIe5111CoreOO)
JYPCIe5111CoreOOCITask (JYPCIe5111CoreOO)
JYPCIe5111CoreOOCOTask (JYPCIe5111CoreOO)
JYPCIe5111CoreOODevice (JYPCIe5111CoreOO)
JYPCIe5111CoreOODITask (JYPCIe5111CoreOO)
JYPCIe5111CoreOODOTask (JYPCIe5111CoreOO)
JYPCIe5111CoreOOLog (JYPCIe5111CoreOO)
JYPCIe5111CoreOOProperty (JYPCIe5111CoreOO)
JYPCIe5111CoreOOReferenceClock (JYPCIe5111CoreOO)
P
PauseTrigger (JYPCIe5111CoreOO)
PeriodMeas (JYPCIe5111CoreOO)
PFIFilter (JYPCIe5111CoreOO)
PFISetting (JYPCIe5111CoreOO)
PulseMeas (JYPCIe5111CoreOO)
Q
QuadEncoder (JYPCIe5111CoreOO)
T
TwoEdgeSeparation (JYPCIe5111CoreOO)
TwoPulseEncoder (JYPCIe5111CoreOO)


5111 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO Directory Reference

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
COO Directory Reference

Directories

5111


5111 C++ Programming Manual: File List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
File List
Here is a list of all files with brief descriptions:
[detail level 123]
▼ COO
▼ 5111
JYPCIe5111CoreOOAITask.h
JYPCIe5111CoreOOAOTask.h
JYPCIe5111CoreOOCITask.h
JYPCIe5111CoreOOCommon.h
JYPCIe5111CoreOOCOTask.h
JYPCIe5111CoreOODevice.h
JYPCIe5111CoreOODITask.h
JYPCIe5111CoreOODOTask.h
JYPCIe5111CoreOOLog.h


5111 C++ Programming Manual: Class Members

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- a -

  • ActiveEdge : JYPCIe5111CoreOO::EdgeCounting
  • ActivePolarity : JYPCIe5111CoreOO::PauseTrigger
  • Add() : JYPCIe5111CoreOO::AISignalExport, JYPCIe5111CoreOO::CISignalExport, JYPCIe5111CoreOO::COSignalExport, JYPCIe5111CoreOO::DISignalExport, JYPCIe5111CoreOO::DOSignalExport
  • AddChannel() : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOODITask, JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
  • Advanced : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask
  • AIBufferSize : JYPCIe5111CoreOO::JYPCIe5111CoreOODevice
  • AIChannel() : JYPCIe5111CoreOO::AIChannel
  • AInputTerminal : JYPCIe5111CoreOO::QuadEncoder, JYPCIe5111CoreOO::TwoPulseEncoder
  • Analog : JYPCIe5111CoreOO::AITrigger
  • AOChannel() : JYPCIe5111CoreOO::AOChannel
  • AOChannelCount : JYPCIe5111CoreOO::JYPCIe5111CoreOODevice
  • AvailableSamples : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOODITask
  • AvaliableLenInSamples : JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask


5111 C++ Programming Manual: Class Members

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- b -

  • BInputTerminal : JYPCIe5111CoreOO::QuadEncoder, JYPCIe5111CoreOO::TwoPulseEncoder
  • BoardClockRate : JYPCIe5111CoreOO::JYPCIe5111CoreOODevice
  • BufLenInSamples : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOODITask, JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask


5111 C++ Programming Manual: Class Members

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- c -

  • ChannelID : JYPCIe5111CoreOO::AIChannel, JYPCIe5111CoreOO::AOChannel
  • Channels : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOODITask, JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
  • Clear() : JYPCIe5111CoreOO::AISignalExport, JYPCIe5111CoreOO::CISignalExport, JYPCIe5111CoreOO::COSignalExport, JYPCIe5111CoreOO::DISignalExport, JYPCIe5111CoreOO::DOSignalExport
  • ClearAll() : JYPCIe5111CoreOO::AISignalExport, JYPCIe5111CoreOO::CISignalExport, JYPCIe5111CoreOO::COSignalExport, JYPCIe5111CoreOO::DISignalExport, JYPCIe5111CoreOO::DOSignalExport
  • Commit() : JYPCIe5111CoreOO::JYPCIe5111CoreOOReferenceClock
  • Comparator : JYPCIe5111CoreOO::AIAnalogTrigger
  • CompleteState : JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
  • Condition : JYPCIe5111CoreOO::AIAnalogWindowComparator
  • ConvertRate : JYPCIe5111CoreOO::AIAdvanced
  • COPulse() : JYPCIe5111CoreOO::COPulse


5111 C++ Programming Manual: Class Members

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- d -

  • Device : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOODITask, JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
  • DeviceID : JYPCIe5111CoreOO::JYPCIe5111CoreOODevice
  • DiffChannelCount : JYPCIe5111CoreOO::JYPCIe5111CoreOODevice
  • Digital : JYPCIe5111CoreOO::AITrigger, JYPCIe5111CoreOO::AOTrigger, JYPCIe5111CoreOO::CITrigger, JYPCIe5111CoreOO::COTrigger, JYPCIe5111CoreOO::DITrigger, JYPCIe5111CoreOO::DOTrigger
  • Direction : JYPCIe5111CoreOO::EdgeCounting
  • DirTerminal : JYPCIe5111CoreOO::EdgeCounting
  • Disable() : JYPCIe5111CoreOO::PFIFilter
  • DisableAll() : JYPCIe5111CoreOO::PFIFilter
  • DSMode : JYPCIe5111CoreOO::AIAdvanced


5111 C++ Programming Manual: Class Members

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- e -

  • Edge : JYPCIe5111CoreOO::AIAnalogTrigger, JYPCIe5111CoreOO::AIDigitalTrigger, JYPCIe5111CoreOO::AODigitalTrigger, JYPCIe5111CoreOO::CIDigitalTrigger, JYPCIe5111CoreOO::CODigitalTrigger, JYPCIe5111CoreOO::DIDigitalTrigger, JYPCIe5111CoreOO::DODigitalTrigger
  • EdgeCounting : JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
  • Enable : JYPCIe5111CoreOO::AIDSMode, JYPCIe5111CoreOO::PFIFilter
  • EnableLog : JYPCIe5111CoreOO::JYPCIe5111CoreOOLog
  • EncodingType : JYPCIe5111CoreOO::QuadEncoder
  • errorCode : JYPCIe5111CoreOO::JYDriverException
  • exceptionMessage : JYPCIe5111CoreOO::JYDriverException
  • ExpectedRate : JYPCIe5111CoreOO::AIExternalSampleClock, JYPCIe5111CoreOO::AOExternalSampleClock, JYPCIe5111CoreOO::CIExternalSampleClock, JYPCIe5111CoreOO::CIImplicitSampleClock, JYPCIe5111CoreOO::DIExternalSampleClock, JYPCIe5111CoreOO::DOExternalSampleClock
  • External : JYPCIe5111CoreOO::AISampleClock, JYPCIe5111CoreOO::AOSampleClock, JYPCIe5111CoreOO::CISampleClock, JYPCIe5111CoreOO::DISampleClock, JYPCIe5111CoreOO::DOSampleClock, JYPCIe5111CoreOO::JYPCIe5111CoreOOReferenceClock


5111 C++ Programming Manual: Class Members

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- f -

  • File_Format : JYPCIe5111CoreOO::AIRecord
  • FilePath : JYPCIe5111CoreOO::AIRecord
  • Filter : JYPCIe5111CoreOO::PFISetting
  • FirstInputTerminal : JYPCIe5111CoreOO::TwoEdgeSeparation
  • Flush() : JYPCIe5111CoreOO::JYPCIe5111CoreOOLog
  • FollowingException : JYPCIe5111CoreOO::JYDriverException
  • FrequencyMeas : JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask


5111 C++ Programming Manual: Class Members - Functions

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • c
  • d
  • e
  • f
  • g
  • j
  • o
  • p
  • r
  • s
  • w
  • ~
Here is a list of all functions with links to the classes they belong to:

- a -

  • Add() : JYPCIe5111CoreOO::AISignalExport, JYPCIe5111CoreOO::CISignalExport, JYPCIe5111CoreOO::COSignalExport, JYPCIe5111CoreOO::DISignalExport, JYPCIe5111CoreOO::DOSignalExport
  • AddChannel() : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOODITask, JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
  • AIChannel() : JYPCIe5111CoreOO::AIChannel
  • AOChannel() : JYPCIe5111CoreOO::AOChannel

- c -

  • Clear() : JYPCIe5111CoreOO::AISignalExport, JYPCIe5111CoreOO::CISignalExport, JYPCIe5111CoreOO::COSignalExport, JYPCIe5111CoreOO::DISignalExport, JYPCIe5111CoreOO::DOSignalExport
  • ClearAll() : JYPCIe5111CoreOO::AISignalExport, JYPCIe5111CoreOO::CISignalExport, JYPCIe5111CoreOO::COSignalExport, JYPCIe5111CoreOO::DISignalExport, JYPCIe5111CoreOO::DOSignalExport
  • Commit() : JYPCIe5111CoreOO::JYPCIe5111CoreOOReferenceClock
  • COPulse() : JYPCIe5111CoreOO::COPulse

- d -

  • Disable() : JYPCIe5111CoreOO::PFIFilter
  • DisableAll() : JYPCIe5111CoreOO::PFIFilter

- e -

  • Enable() : JYPCIe5111CoreOO::PFIFilter

- f -

  • Flush() : JYPCIe5111CoreOO::JYPCIe5111CoreOOLog

- g -

  • GetInstance() : JYPCIe5111CoreOO::JYPCIe5111CoreOODevice
  • GetRecordPreviewData() : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask
  • GetRecordStatus() : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask

- j -

  • JYDriverException() : JYPCIe5111CoreOO::JYDriverException
  • JYPCIe5111CoreOOAITask() : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask
  • JYPCIe5111CoreOOAOTask() : JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask
  • JYPCIe5111CoreOOCITask() : JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
  • JYPCIe5111CoreOOCOTask() : JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask
  • JYPCIe5111CoreOODITask() : JYPCIe5111CoreOO::JYPCIe5111CoreOODITask
  • JYPCIe5111CoreOODOTask() : JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
  • JYPCIe5111CoreOOProperty() : JYPCIe5111CoreOO::JYPCIe5111CoreOOProperty< ContainerClass, ValueType, propertyType >

- o -

  • operator ValueType() : JYPCIe5111CoreOO::JYPCIe5111CoreOOProperty< ContainerClass, ValueType, propertyType >
  • operator=() : JYPCIe5111CoreOO::JYPCIe5111CoreOOProperty< ContainerClass, ValueType, propertyType >

- p -

  • Print() : JYPCIe5111CoreOO::JYPCIe5111CoreOOLog

- r -

  • ReadData() : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask, JYPCIe5111CoreOO::JYPCIe5111CoreOODITask
  • ReadRawData() : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask
  • ReadRawSinglePoint() : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask
  • ReadSinglePoint() : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask, JYPCIe5111CoreOO::JYPCIe5111CoreOODITask
  • RemoveChannel() : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOODITask, JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask

- s -

  • SendSoftwareTrigger() : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOODITask, JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
  • Start() : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOODITask, JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
  • Stop() : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOODITask, JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask

- w -

  • WaitUntilDone() : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
  • WriteData() : JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
  • WriteRawData() : JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask
  • WriteRawSinglePoint() : JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask
  • WriteSinglePoint() : JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask

- ~ -

  • ~COPulse() : JYPCIe5111CoreOO::COPulse
  • ~JYPCIe5111CoreOOAITask() : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask
  • ~JYPCIe5111CoreOOAOTask() : JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask
  • ~JYPCIe5111CoreOOCITask() : JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
  • ~JYPCIe5111CoreOOCOTask() : JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask
  • ~JYPCIe5111CoreOODITask() : JYPCIe5111CoreOO::JYPCIe5111CoreOODITask
  • ~JYPCIe5111CoreOODOTask() : JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask


5111 C++ Programming Manual: Class Members

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- g -

  • GetInstance() : JYPCIe5111CoreOO::JYPCIe5111CoreOODevice
  • GetRecordPreviewData() : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask
  • GetRecordStatus() : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask


5111 C++ Programming Manual: Class Members

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- h -

  • Handle : JYPCIe5111CoreOO::JYPCIe5111CoreOODevice
  • HighThreshold : JYPCIe5111CoreOO::AIAnalogHysteresisComparator, JYPCIe5111CoreOO::AIAnalogWindowComparator
  • Hysteresis : JYPCIe5111CoreOO::AIAnalogTrigger


5111 C++ Programming Manual: Class Members

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- i -

  • IdleState : JYPCIe5111CoreOO::EdgeCountingOutEvent, JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask
  • Implicit : JYPCIe5111CoreOO::CISampleClock
  • InitialCount : JYPCIe5111CoreOO::EdgeCounting, JYPCIe5111CoreOO::QuadEncoder, JYPCIe5111CoreOO::TwoPulseEncoder
  • InitialDelay : JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask
  • Input_Terminal : JYPCIe5111CoreOO::EdgeCounting, JYPCIe5111CoreOO::FrequencyMeas, JYPCIe5111CoreOO::PeriodMeas, JYPCIe5111CoreOO::PulseMeas
  • Internal : JYPCIe5111CoreOO::CISampleClock
  • IsAISync : JYPCIe5111CoreOO::JYPCIe5111CoreOODevice
  • IsAOSync : JYPCIe5111CoreOO::JYPCIe5111CoreOODevice


5111 C++ Programming Manual: Class Members

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- j -

  • JYDriverException() : JYPCIe5111CoreOO::JYDriverException
  • JYPCIe5111CoreOOAITask() : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask
  • JYPCIe5111CoreOOAOTask : JYPCIe5111CoreOO::AOSampleClock, JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask
  • JYPCIe5111CoreOOCITask() : JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
  • JYPCIe5111CoreOOCOTask() : JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask
  • JYPCIe5111CoreOODITask() : JYPCIe5111CoreOO::JYPCIe5111CoreOODITask
  • JYPCIe5111CoreOODOTask() : JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
  • JYPCIe5111CoreOOProperty() : JYPCIe5111CoreOO::JYPCIe5111CoreOOProperty< ContainerClass, ValueType, propertyType >


5111 C++ Programming Manual: Class Members

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- l -

  • Length : JYPCIe5111CoreOO::AIRecord
  • LogLevel : JYPCIe5111CoreOO::JYPCIe5111CoreOOLog
  • LowThreshold : JYPCIe5111CoreOO::AIAnalogHysteresisComparator, JYPCIe5111CoreOO::AIAnalogWindowComparator


5111 C++ Programming Manual: Class Members

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- m -

  • MaxSampleRateMutilChannel : JYPCIe5111CoreOO::JYPCIe5111CoreOODevice
  • MaxSampleRateSingleChannel : JYPCIe5111CoreOO::JYPCIe5111CoreOODevice
  • MaxUpdateRate : JYPCIe5111CoreOO::JYPCIe5111CoreOODevice
  • MaxUpdateRateSingleChannel : JYPCIe5111CoreOO::JYPCIe5111CoreOODevice
  • Mode : JYPCIe5111CoreOO::AIRecord, JYPCIe5111CoreOO::AITrigger, JYPCIe5111CoreOO::DITrigger, JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOODITask, JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask


5111 C++ Programming Manual: Class Members

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- o -

  • operator ValueType() : JYPCIe5111CoreOO::JYPCIe5111CoreOOProperty< ContainerClass, ValueType, propertyType >
  • operator=() : JYPCIe5111CoreOO::JYPCIe5111CoreOOProperty< ContainerClass, ValueType, propertyType >
  • OutEvent : JYPCIe5111CoreOO::EdgeCounting
  • OutputTerminal : JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask


5111 C++ Programming Manual: Class Members

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- p -

  • Pause : JYPCIe5111CoreOO::EdgeCounting, JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask
  • PeriodMeas : JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
  • PFI : JYPCIe5111CoreOO::JYPCIe5111CoreOODevice
  • PortNum : JYPCIe5111CoreOO::DIChannel, JYPCIe5111CoreOO::DOChannel
  • PowerLine_Frequency : JYPCIe5111CoreOO::AIDSMode
  • PreTriggerSamples : JYPCIe5111CoreOO::AITrigger, JYPCIe5111CoreOO::DITrigger
  • Print() : JYPCIe5111CoreOO::JYPCIe5111CoreOOLog
  • PulseMeas : JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask


5111 C++ Programming Manual: Class Members

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- q -

  • QuadEncoder : JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask


5111 C++ Programming Manual: Class Members

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- r -

  • RangeHigh : JYPCIe5111CoreOO::AIChannel, JYPCIe5111CoreOO::AOChannel
  • RangeLow : JYPCIe5111CoreOO::AIChannel, JYPCIe5111CoreOO::AOChannel
  • Rate : JYPCIe5111CoreOO::CIInternalSampleClock
  • ReadData() : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask, JYPCIe5111CoreOO::JYPCIe5111CoreOODITask
  • ReadRawData() : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask
  • ReadRawSinglePoint() : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask
  • ReadSinglePoint() : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask, JYPCIe5111CoreOO::JYPCIe5111CoreOODITask
  • Record : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask
  • ReferenceClock : JYPCIe5111CoreOO::JYPCIe5111CoreOODevice
  • RemoveChannel() : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOODITask, JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
  • ReTriggerCount : JYPCIe5111CoreOO::AITrigger


5111 C++ Programming Manual: Class Members - Related Symbols

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
Here is a list of all related symbols with links to the classes they belong to:
  • JYPCIe5111CoreOOAOTask : JYPCIe5111CoreOO::AOSampleClock


5111 C++ Programming Manual: Class Members

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- s -

  • SampleClock : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask, JYPCIe5111CoreOO::JYPCIe5111CoreOODITask, JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
  • SampleRate : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask, JYPCIe5111CoreOO::JYPCIe5111CoreOODITask
  • SamplesToAcquire : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask, JYPCIe5111CoreOO::JYPCIe5111CoreOODITask
  • SamplesToUpdate : JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
  • SEChannelCount : JYPCIe5111CoreOO::JYPCIe5111CoreOODevice
  • SecondInputTerminal : JYPCIe5111CoreOO::TwoEdgeSeparation
  • SendSoftwareTrigger() : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOODITask, JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
  • SerialNumber : JYPCIe5111CoreOO::JYPCIe5111CoreOODevice
  • SignalExport : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOODITask, JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
  • Slope : JYPCIe5111CoreOO::AIAnalogEdgeComparator, JYPCIe5111CoreOO::AIAnalogHysteresisComparator
  • Source : JYPCIe5111CoreOO::AIAnalogTrigger, JYPCIe5111CoreOO::AIDigitalTrigger, JYPCIe5111CoreOO::AISampleClock, JYPCIe5111CoreOO::AODigitalTrigger, JYPCIe5111CoreOO::AOSampleClock, JYPCIe5111CoreOO::CIDigitalTrigger, JYPCIe5111CoreOO::CISampleClock, JYPCIe5111CoreOO::CITimebase, JYPCIe5111CoreOO::CODigitalTrigger, JYPCIe5111CoreOO::COTimebase, JYPCIe5111CoreOO::DIDigitalTrigger, JYPCIe5111CoreOO::DISampleClock, JYPCIe5111CoreOO::DODigitalTrigger, JYPCIe5111CoreOO::DOSampleClock, JYPCIe5111CoreOO::JYPCIe5111CoreOOReferenceClock
  • Start() : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOODITask, JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
  • Stop() : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOODITask, JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask


5111 C++ Programming Manual: Class Members

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- t -

  • Terminal : JYPCIe5111CoreOO::AIChannel, JYPCIe5111CoreOO::AIExternalSampleClock, JYPCIe5111CoreOO::AOExternalSampleClock, JYPCIe5111CoreOO::CIExternalSampleClock, JYPCIe5111CoreOO::DIExternalSampleClock, JYPCIe5111CoreOO::DOExternalSampleClock, JYPCIe5111CoreOO::EdgeCountingOutEvent, JYPCIe5111CoreOO::ExternalReferenceClock, JYPCIe5111CoreOO::PauseTrigger
  • Threshold : JYPCIe5111CoreOO::AIAnalogEdgeComparator, JYPCIe5111CoreOO::EdgeCountingOutEvent
  • TimeBase : JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask
  • Timebase : JYPCIe5111CoreOO::FrequencyMeas, JYPCIe5111CoreOO::PeriodMeas, JYPCIe5111CoreOO::PulseMeas, JYPCIe5111CoreOO::TwoEdgeSeparation
  • TransferedPulses : JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask
  • TransferedSamples : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOODITask, JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
  • Trigger : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOODITask, JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
  • TwoEdgeSeparation : JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
  • TwoPulseEncoder : JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
  • Type : JYPCIe5111CoreOO::AITrigger, JYPCIe5111CoreOO::AOTrigger, JYPCIe5111CoreOO::CITrigger, JYPCIe5111CoreOO::COTrigger, JYPCIe5111CoreOO::DITrigger, JYPCIe5111CoreOO::DOTrigger, JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask


5111 C++ Programming Manual: Class Members

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- u -

  • UpdateRate : JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask


5111 C++ Programming Manual: Class Members - Variables

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- a -

  • ActiveEdge : JYPCIe5111CoreOO::EdgeCounting
  • ActivePolarity : JYPCIe5111CoreOO::PauseTrigger
  • Advanced : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask
  • AIBufferSize : JYPCIe5111CoreOO::JYPCIe5111CoreOODevice
  • AInputTerminal : JYPCIe5111CoreOO::QuadEncoder, JYPCIe5111CoreOO::TwoPulseEncoder
  • Analog : JYPCIe5111CoreOO::AITrigger
  • AOChannelCount : JYPCIe5111CoreOO::JYPCIe5111CoreOODevice
  • AvailableSamples : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOODITask
  • AvaliableLenInSamples : JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask


5111 C++ Programming Manual: Class Members - Variables

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- b -

  • BInputTerminal : JYPCIe5111CoreOO::QuadEncoder, JYPCIe5111CoreOO::TwoPulseEncoder
  • BoardClockRate : JYPCIe5111CoreOO::JYPCIe5111CoreOODevice
  • BufLenInSamples : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOODITask, JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask


5111 C++ Programming Manual: Class Members - Variables

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- c -

  • ChannelID : JYPCIe5111CoreOO::AIChannel, JYPCIe5111CoreOO::AOChannel
  • Channels : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOODITask, JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
  • Comparator : JYPCIe5111CoreOO::AIAnalogTrigger
  • CompleteState : JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
  • Condition : JYPCIe5111CoreOO::AIAnalogWindowComparator
  • ConvertRate : JYPCIe5111CoreOO::AIAdvanced


5111 C++ Programming Manual: Class Members - Variables

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- d -

  • Device : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOODITask, JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
  • DeviceID : JYPCIe5111CoreOO::JYPCIe5111CoreOODevice
  • DiffChannelCount : JYPCIe5111CoreOO::JYPCIe5111CoreOODevice
  • Digital : JYPCIe5111CoreOO::AITrigger, JYPCIe5111CoreOO::AOTrigger, JYPCIe5111CoreOO::CITrigger, JYPCIe5111CoreOO::COTrigger, JYPCIe5111CoreOO::DITrigger, JYPCIe5111CoreOO::DOTrigger
  • Direction : JYPCIe5111CoreOO::EdgeCounting
  • DirTerminal : JYPCIe5111CoreOO::EdgeCounting
  • DSMode : JYPCIe5111CoreOO::AIAdvanced


5111 C++ Programming Manual: Class Members - Variables

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- e -

  • Edge : JYPCIe5111CoreOO::AIAnalogTrigger, JYPCIe5111CoreOO::AIDigitalTrigger, JYPCIe5111CoreOO::AODigitalTrigger, JYPCIe5111CoreOO::CIDigitalTrigger, JYPCIe5111CoreOO::CODigitalTrigger, JYPCIe5111CoreOO::DIDigitalTrigger, JYPCIe5111CoreOO::DODigitalTrigger
  • EdgeCounting : JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
  • Enable : JYPCIe5111CoreOO::AIDSMode
  • EnableLog : JYPCIe5111CoreOO::JYPCIe5111CoreOOLog
  • EncodingType : JYPCIe5111CoreOO::QuadEncoder
  • errorCode : JYPCIe5111CoreOO::JYDriverException
  • exceptionMessage : JYPCIe5111CoreOO::JYDriverException
  • ExpectedRate : JYPCIe5111CoreOO::AIExternalSampleClock, JYPCIe5111CoreOO::AOExternalSampleClock, JYPCIe5111CoreOO::CIExternalSampleClock, JYPCIe5111CoreOO::CIImplicitSampleClock, JYPCIe5111CoreOO::DIExternalSampleClock, JYPCIe5111CoreOO::DOExternalSampleClock
  • External : JYPCIe5111CoreOO::AISampleClock, JYPCIe5111CoreOO::AOSampleClock, JYPCIe5111CoreOO::CISampleClock, JYPCIe5111CoreOO::DISampleClock, JYPCIe5111CoreOO::DOSampleClock, JYPCIe5111CoreOO::JYPCIe5111CoreOOReferenceClock


5111 C++ Programming Manual: Class Members - Variables

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- f -

  • File_Format : JYPCIe5111CoreOO::AIRecord
  • FilePath : JYPCIe5111CoreOO::AIRecord
  • Filter : JYPCIe5111CoreOO::PFISetting
  • FirstInputTerminal : JYPCIe5111CoreOO::TwoEdgeSeparation
  • FollowingException : JYPCIe5111CoreOO::JYDriverException
  • FrequencyMeas : JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask


5111 C++ Programming Manual: Class Members - Variables

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- h -

  • Handle : JYPCIe5111CoreOO::JYPCIe5111CoreOODevice
  • HighThreshold : JYPCIe5111CoreOO::AIAnalogHysteresisComparator, JYPCIe5111CoreOO::AIAnalogWindowComparator
  • Hysteresis : JYPCIe5111CoreOO::AIAnalogTrigger


5111 C++ Programming Manual: Class Members - Variables

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- i -

  • IdleState : JYPCIe5111CoreOO::EdgeCountingOutEvent, JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask
  • Implicit : JYPCIe5111CoreOO::CISampleClock
  • InitialCount : JYPCIe5111CoreOO::EdgeCounting, JYPCIe5111CoreOO::QuadEncoder, JYPCIe5111CoreOO::TwoPulseEncoder
  • InitialDelay : JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask
  • Input_Terminal : JYPCIe5111CoreOO::EdgeCounting, JYPCIe5111CoreOO::FrequencyMeas, JYPCIe5111CoreOO::PeriodMeas, JYPCIe5111CoreOO::PulseMeas
  • Internal : JYPCIe5111CoreOO::CISampleClock
  • IsAISync : JYPCIe5111CoreOO::JYPCIe5111CoreOODevice
  • IsAOSync : JYPCIe5111CoreOO::JYPCIe5111CoreOODevice


5111 C++ Programming Manual: Class Members - Variables

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- l -

  • Length : JYPCIe5111CoreOO::AIRecord
  • LogLevel : JYPCIe5111CoreOO::JYPCIe5111CoreOOLog
  • LowThreshold : JYPCIe5111CoreOO::AIAnalogHysteresisComparator, JYPCIe5111CoreOO::AIAnalogWindowComparator


5111 C++ Programming Manual: Class Members - Variables

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- m -

  • MaxSampleRateMutilChannel : JYPCIe5111CoreOO::JYPCIe5111CoreOODevice
  • MaxSampleRateSingleChannel : JYPCIe5111CoreOO::JYPCIe5111CoreOODevice
  • MaxUpdateRate : JYPCIe5111CoreOO::JYPCIe5111CoreOODevice
  • MaxUpdateRateSingleChannel : JYPCIe5111CoreOO::JYPCIe5111CoreOODevice
  • Mode : JYPCIe5111CoreOO::AIRecord, JYPCIe5111CoreOO::AITrigger, JYPCIe5111CoreOO::DITrigger, JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOODITask, JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask


5111 C++ Programming Manual: Class Members - Variables

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- o -

  • OutEvent : JYPCIe5111CoreOO::EdgeCounting
  • OutputTerminal : JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask


5111 C++ Programming Manual: Class Members - Variables

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- p -

  • Pause : JYPCIe5111CoreOO::EdgeCounting, JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask
  • PeriodMeas : JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
  • PFI : JYPCIe5111CoreOO::JYPCIe5111CoreOODevice
  • PortNum : JYPCIe5111CoreOO::DIChannel, JYPCIe5111CoreOO::DOChannel
  • PowerLine_Frequency : JYPCIe5111CoreOO::AIDSMode
  • PreTriggerSamples : JYPCIe5111CoreOO::AITrigger, JYPCIe5111CoreOO::DITrigger
  • PulseMeas : JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask


5111 C++ Programming Manual: Class Members - Variables

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- q -

  • QuadEncoder : JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask


5111 C++ Programming Manual: Class Members - Variables

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- r -

  • RangeHigh : JYPCIe5111CoreOO::AIChannel, JYPCIe5111CoreOO::AOChannel
  • RangeLow : JYPCIe5111CoreOO::AIChannel, JYPCIe5111CoreOO::AOChannel
  • Rate : JYPCIe5111CoreOO::CIInternalSampleClock
  • Record : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask
  • ReferenceClock : JYPCIe5111CoreOO::JYPCIe5111CoreOODevice
  • ReTriggerCount : JYPCIe5111CoreOO::AITrigger


5111 C++ Programming Manual: Class Members - Variables

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- s -

  • SampleClock : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask, JYPCIe5111CoreOO::JYPCIe5111CoreOODITask, JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
  • SampleRate : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask, JYPCIe5111CoreOO::JYPCIe5111CoreOODITask
  • SamplesToAcquire : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask, JYPCIe5111CoreOO::JYPCIe5111CoreOODITask
  • SamplesToUpdate : JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
  • SEChannelCount : JYPCIe5111CoreOO::JYPCIe5111CoreOODevice
  • SecondInputTerminal : JYPCIe5111CoreOO::TwoEdgeSeparation
  • SerialNumber : JYPCIe5111CoreOO::JYPCIe5111CoreOODevice
  • SignalExport : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOODITask, JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
  • Slope : JYPCIe5111CoreOO::AIAnalogEdgeComparator, JYPCIe5111CoreOO::AIAnalogHysteresisComparator
  • Source : JYPCIe5111CoreOO::AIAnalogTrigger, JYPCIe5111CoreOO::AIDigitalTrigger, JYPCIe5111CoreOO::AISampleClock, JYPCIe5111CoreOO::AODigitalTrigger, JYPCIe5111CoreOO::AOSampleClock, JYPCIe5111CoreOO::CIDigitalTrigger, JYPCIe5111CoreOO::CISampleClock, JYPCIe5111CoreOO::CITimebase, JYPCIe5111CoreOO::CODigitalTrigger, JYPCIe5111CoreOO::COTimebase, JYPCIe5111CoreOO::DIDigitalTrigger, JYPCIe5111CoreOO::DISampleClock, JYPCIe5111CoreOO::DODigitalTrigger, JYPCIe5111CoreOO::DOSampleClock, JYPCIe5111CoreOO::JYPCIe5111CoreOOReferenceClock


5111 C++ Programming Manual: Class Members - Variables

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- t -

  • Terminal : JYPCIe5111CoreOO::AIChannel, JYPCIe5111CoreOO::AIExternalSampleClock, JYPCIe5111CoreOO::AOExternalSampleClock, JYPCIe5111CoreOO::CIExternalSampleClock, JYPCIe5111CoreOO::DIExternalSampleClock, JYPCIe5111CoreOO::DOExternalSampleClock, JYPCIe5111CoreOO::EdgeCountingOutEvent, JYPCIe5111CoreOO::ExternalReferenceClock, JYPCIe5111CoreOO::PauseTrigger
  • Threshold : JYPCIe5111CoreOO::AIAnalogEdgeComparator, JYPCIe5111CoreOO::EdgeCountingOutEvent
  • TimeBase : JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask
  • Timebase : JYPCIe5111CoreOO::FrequencyMeas, JYPCIe5111CoreOO::PeriodMeas, JYPCIe5111CoreOO::PulseMeas, JYPCIe5111CoreOO::TwoEdgeSeparation
  • TransferedPulses : JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask
  • TransferedSamples : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOODITask, JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
  • Trigger : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOODITask, JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
  • TwoEdgeSeparation : JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
  • TwoPulseEncoder : JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
  • Type : JYPCIe5111CoreOO::AITrigger, JYPCIe5111CoreOO::AOTrigger, JYPCIe5111CoreOO::CITrigger, JYPCIe5111CoreOO::COTrigger, JYPCIe5111CoreOO::DITrigger, JYPCIe5111CoreOO::DOTrigger, JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask


5111 C++ Programming Manual: Class Members - Variables

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- u -

  • UpdateRate : JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask


5111 C++ Programming Manual: Class Members - Variables

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- w -

  • Window : JYPCIe5111CoreOO::AIAnalogTrigger


5111 C++ Programming Manual: Class Members - Variables

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- z -

  • ZInputTerminal : JYPCIe5111CoreOO::QuadEncoder
  • ZReloadEnabled : JYPCIe5111CoreOO::QuadEncoder


5111 C++ Programming Manual: Class Members

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- w -

  • WaitUntilDone() : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask, JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
  • Window : JYPCIe5111CoreOO::AIAnalogTrigger
  • WriteData() : JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask
  • WriteRawData() : JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask
  • WriteRawSinglePoint() : JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask
  • WriteSinglePoint() : JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask, JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask


5111 C++ Programming Manual: Class Members

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- z -

  • ZInputTerminal : JYPCIe5111CoreOO::QuadEncoder
  • ZReloadEnabled : JYPCIe5111CoreOO::QuadEncoder


5111 C++ Programming Manual: Class Members

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- ~ -

  • ~COPulse() : JYPCIe5111CoreOO::COPulse
  • ~JYPCIe5111CoreOOAITask() : JYPCIe5111CoreOO::JYPCIe5111CoreOOAITask
  • ~JYPCIe5111CoreOOAOTask() : JYPCIe5111CoreOO::JYPCIe5111CoreOOAOTask
  • ~JYPCIe5111CoreOOCITask() : JYPCIe5111CoreOO::JYPCIe5111CoreOOCITask
  • ~JYPCIe5111CoreOOCOTask() : JYPCIe5111CoreOO::JYPCIe5111CoreOOCOTask
  • ~JYPCIe5111CoreOODITask() : JYPCIe5111CoreOO::JYPCIe5111CoreOODITask
  • ~JYPCIe5111CoreOODOTask() : JYPCIe5111CoreOO::JYPCIe5111CoreOODOTask


5111 C++ Programming Manual: File Members

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • All
  • Macros
Here is a list of all file members with links to the files they belong to:
  • EXTERN_C : JYPCIe5111CoreOOCommon.h
  • JYPCIe5111CoreOO_API : JYPCIe5111CoreOOCommon.h


5111 C++ Programming Manual: File Members

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • All
  • Macros
Here is a list of all macros with links to the files they belong to:
  • EXTERN_C : JYPCIe5111CoreOOCommon.h
  • JYPCIe5111CoreOO_API : JYPCIe5111CoreOOCommon.h


5111 C++ Programming Manual: Main Page

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
5111 C++ Programming Manual Documentation


5111 C++ Programming Manual: Namespace Members

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • l
  • o
  • p
  • q
  • r
  • s
Here is a list of all namespace members with links to the namespace documentation for each member:

- a -

  • AIAnalogTriggerComparator : JYPCIe5111CoreOO
  • AIAnalogTriggerEdge : JYPCIe5111CoreOO
  • AIAnalogTriggerSource : JYPCIe5111CoreOO
  • AIAnalogWindowCondition : JYPCIe5111CoreOO
  • AIDigitalTriggerEdge : JYPCIe5111CoreOO
  • AIDigitalTriggerSource : JYPCIe5111CoreOO
  • AIMode : JYPCIe5111CoreOO
  • AISampleClockSource : JYPCIe5111CoreOO
  • AISignalExportSource : JYPCIe5111CoreOO
  • AITerminal : JYPCIe5111CoreOO
  • AITriggerMode : JYPCIe5111CoreOO
  • AITriggerType : JYPCIe5111CoreOO
  • AODigitalTriggerEdge : JYPCIe5111CoreOO
  • AODigitalTriggerSource : JYPCIe5111CoreOO
  • AOMode : JYPCIe5111CoreOO
  • AOSampleClockSource : JYPCIe5111CoreOO
  • AOSignalExportSource : JYPCIe5111CoreOO
  • AOTriggerType : JYPCIe5111CoreOO

- c -

  • CIDigitalTriggerEdge : JYPCIe5111CoreOO
  • CIDigitalTriggerSource : JYPCIe5111CoreOO
  • CIMode : JYPCIe5111CoreOO
  • CISampleClockSource : JYPCIe5111CoreOO
  • CISignalExportSource : JYPCIe5111CoreOO
  • CITimebaseSource : JYPCIe5111CoreOO
  • CITriggerType : JYPCIe5111CoreOO
  • CIType : JYPCIe5111CoreOO
  • ClockTerminal : JYPCIe5111CoreOO
  • CODigitalTriggerEdge : JYPCIe5111CoreOO
  • CODigitalTriggerSource : JYPCIe5111CoreOO
  • COIdleState : JYPCIe5111CoreOO
  • COMode : JYPCIe5111CoreOO
  • COPulseType : JYPCIe5111CoreOO
  • COSignalExportSource : JYPCIe5111CoreOO
  • COTimebaseSource : JYPCIe5111CoreOO
  • COTriggerType : JYPCIe5111CoreOO
  • CountDirection : JYPCIe5111CoreOO

- d -

  • DIDigitalTriggerEdge : JYPCIe5111CoreOO
  • DIDigitalTriggerSource : JYPCIe5111CoreOO
  • DIMode : JYPCIe5111CoreOO
  • DISampleClockSource : JYPCIe5111CoreOO
  • DISignalExportSource : JYPCIe5111CoreOO
  • DITriggerMode : JYPCIe5111CoreOO
  • DITriggerType : JYPCIe5111CoreOO
  • DODigitalTriggerEdge : JYPCIe5111CoreOO
  • DODigitalTriggerSource : JYPCIe5111CoreOO
  • DOMode : JYPCIe5111CoreOO
  • DOSampleClockSource : JYPCIe5111CoreOO
  • DOSignalExportSource : JYPCIe5111CoreOO
  • DOTriggerType : JYPCIe5111CoreOO

- e -

  • EdgeCntOunEvtIdleState : JYPCIe5111CoreOO
  • EdgeType : JYPCIe5111CoreOO
  • ExternalReferenceClockTerminal : JYPCIe5111CoreOO

- f -

  • FileFormat : JYPCIe5111CoreOO

- g -

  • GetSignalExportDestinationString() : JYPCIe5111CoreOO

- i -

  • InputTerminal : JYPCIe5111CoreOO
  • IOTerminal : JYPCIe5111CoreOO

- j -

  • JYDriverExceptionPublic : JYPCIe5111CoreOO
  • JYPCIe5111CoreOOLogLevel : JYPCIe5111CoreOO
  • JYPCIe5111CoreOOPropertyType : JYPCIe5111CoreOO

- l -

  • LevelPolarity : JYPCIe5111CoreOO

- o -

  • OutputCompleteState : JYPCIe5111CoreOO

- p -

  • PFITerminal : JYPCIe5111CoreOO
  • PowerLineFrequency : JYPCIe5111CoreOO

- q -

  • QuadEncodingType : JYPCIe5111CoreOO

- r -

  • RecordMode : JYPCIe5111CoreOO
  • ReferenceClockSource : JYPCIe5111CoreOO

- s -

  • SignalExportDestination : JYPCIe5111CoreOO


5111 C++ Programming Manual: Namespace Members

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • a
  • c
  • d
  • e
  • f
  • i
  • j
  • l
  • o
  • p
  • q
  • r
  • s
Here is a list of all namespace enums with links to the namespace documentation for each enum:

- a -

  • AIAnalogTriggerComparator : JYPCIe5111CoreOO
  • AIAnalogTriggerEdge : JYPCIe5111CoreOO
  • AIAnalogTriggerSource : JYPCIe5111CoreOO
  • AIAnalogWindowCondition : JYPCIe5111CoreOO
  • AIDigitalTriggerEdge : JYPCIe5111CoreOO
  • AIDigitalTriggerSource : JYPCIe5111CoreOO
  • AIMode : JYPCIe5111CoreOO
  • AISampleClockSource : JYPCIe5111CoreOO
  • AISignalExportSource : JYPCIe5111CoreOO
  • AITerminal : JYPCIe5111CoreOO
  • AITriggerMode : JYPCIe5111CoreOO
  • AITriggerType : JYPCIe5111CoreOO
  • AODigitalTriggerEdge : JYPCIe5111CoreOO
  • AODigitalTriggerSource : JYPCIe5111CoreOO
  • AOMode : JYPCIe5111CoreOO
  • AOSampleClockSource : JYPCIe5111CoreOO
  • AOSignalExportSource : JYPCIe5111CoreOO
  • AOTriggerType : JYPCIe5111CoreOO

- c -

  • CIDigitalTriggerEdge : JYPCIe5111CoreOO
  • CIDigitalTriggerSource : JYPCIe5111CoreOO
  • CIMode : JYPCIe5111CoreOO
  • CISampleClockSource : JYPCIe5111CoreOO
  • CISignalExportSource : JYPCIe5111CoreOO
  • CITimebaseSource : JYPCIe5111CoreOO
  • CITriggerType : JYPCIe5111CoreOO
  • CIType : JYPCIe5111CoreOO
  • ClockTerminal : JYPCIe5111CoreOO
  • CODigitalTriggerEdge : JYPCIe5111CoreOO
  • CODigitalTriggerSource : JYPCIe5111CoreOO
  • COIdleState : JYPCIe5111CoreOO
  • COMode : JYPCIe5111CoreOO
  • COPulseType : JYPCIe5111CoreOO
  • COSignalExportSource : JYPCIe5111CoreOO
  • COTimebaseSource : JYPCIe5111CoreOO
  • COTriggerType : JYPCIe5111CoreOO
  • CountDirection : JYPCIe5111CoreOO

- d -

  • DIDigitalTriggerEdge : JYPCIe5111CoreOO
  • DIDigitalTriggerSource : JYPCIe5111CoreOO
  • DIMode : JYPCIe5111CoreOO
  • DISampleClockSource : JYPCIe5111CoreOO
  • DISignalExportSource : JYPCIe5111CoreOO
  • DITriggerMode : JYPCIe5111CoreOO
  • DITriggerType : JYPCIe5111CoreOO
  • DODigitalTriggerEdge : JYPCIe5111CoreOO
  • DODigitalTriggerSource : JYPCIe5111CoreOO
  • DOMode : JYPCIe5111CoreOO
  • DOSampleClockSource : JYPCIe5111CoreOO
  • DOSignalExportSource : JYPCIe5111CoreOO
  • DOTriggerType : JYPCIe5111CoreOO

- e -

  • EdgeCntOunEvtIdleState : JYPCIe5111CoreOO
  • EdgeType : JYPCIe5111CoreOO
  • ExternalReferenceClockTerminal : JYPCIe5111CoreOO

- f -

  • FileFormat : JYPCIe5111CoreOO

- i -

  • InputTerminal : JYPCIe5111CoreOO
  • IOTerminal : JYPCIe5111CoreOO

- j -

  • JYDriverExceptionPublic : JYPCIe5111CoreOO
  • JYPCIe5111CoreOOLogLevel : JYPCIe5111CoreOO
  • JYPCIe5111CoreOOPropertyType : JYPCIe5111CoreOO

- l -

  • LevelPolarity : JYPCIe5111CoreOO

- o -

  • OutputCompleteState : JYPCIe5111CoreOO

- p -

  • PFITerminal : JYPCIe5111CoreOO
  • PowerLineFrequency : JYPCIe5111CoreOO

- q -

  • QuadEncodingType : JYPCIe5111CoreOO

- r -

  • RecordMode : JYPCIe5111CoreOO
  • ReferenceClockSource : JYPCIe5111CoreOO

- s -

  • SignalExportDestination : JYPCIe5111CoreOO


5111 C++ Programming Manual: Namespace Members

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
Here is a list of all namespace functions with links to the namespace documentation for each function:
  • GetSignalExportDestinationString() : JYPCIe5111CoreOO


5111 C++ Programming Manual: Namespace List

5111 C++ Programming Manual
5111 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • Namespace List
  • Namespace Members
Namespace List
Here is a list of all namespaces with brief descriptions:
N JYPCIe5111CoreOO