5111 C# Programming Manual: D:/5111/C# Directory Reference

5111 C# Programming Manual
  • Main Page
  • Packages
  • Classes
  • Files
  • File List
  • 5111
  • C#
C# Directory Reference

Files

JYPCIe5111AITask.cs
JYPCIe5111AOTask.cs
JYPCIe5111CITask.cs
JYPCIe5111COTask.cs
JYPCIe5111DITask.cs
JYPCIe5111DOTask.cs
Generated by doxygen 1.12.0


5111 C# Programming Manual: D:/5111/C#/JYPCIe5111AITask.cs File Reference

  • Packages
  • Classes
  • Files
  • File List
  • 5111
  • C#
Classes | Namespaces | Enumerations
JYPCIe5111AITask.cs File Reference

Classes

class | JYPCIe5111.JYPCIe5111AITask
JYPCIe5111 Analog Input Task. More...
class | JYPCIe5111.AIChannel
AI Channel parameter class . More...
class | JYPCIe5111.AISampleClock
Sample clock configuration class. More...
class | JYPCIe5111.AIExternalSampleClock
External Sample Clock Configuration Class. More...
class | JYPCIe5111.AITrigger
Constructor to create an AITrigger task object. More...
class | JYPCIe5111.AIDigitalTrigger
AI Digital trigger class. More...
class | JYPCIe5111.AIAnalogTrigger
AI analog trigger . More...
class | JYPCIe5111.AIAnalogHysteresisComparator
AI Analog Hysteresis Comparatorr. More...
class | JYPCIe5111.AIAnalogWindowComparator
AI Analog Window Comparatorr. More...
class | JYPCIe5111.AIAnalogEdgeComparator
AI Analog Edge Comparator. More...
class | JYPCIe5111.AIRecord
AI Record Parameters. More...
class | JYPCIe5111.AIAdvanced
AI Advance parameter. More...
class | JYPCIe5111.AISignalExport
AI Signal Export Class. More...

Namespaces

namespace JYPCIe5111

Enumerations

enum | JYPCIe5111.AITriggerType { JYPCIe5111.Immediate = JYPCIe5111Import.JYPCIe5111_TriggerType_Immediately , JYPCIe5111.Digital = JYPCIe5111Import.JYPCIe5111_TriggerType_Digital , JYPCIe5111.Analog = JYPCIe5111Import.JYPCIe5111_TriggerType_Analog , JYPCIe5111.Soft = JYPCIe5111Import.JYPCIe5111_TriggerType_Soft }
Trigger Type Digital/Analog/Immediate/Soft. More...
enum | JYPCIe5111.AIDigitalTriggerEdge { JYPCIe5111.Rising = JYPCIe5111Import.JYPCIe5111_DigitalTriggerEdge_Rising , JYPCIe5111.Falling = JYPCIe5111Import.JYPCIe5111_DigitalTriggerEdge_Falling }
AI Digital Trigger Edge. More...
enum | JYPCIe5111.AIMode { JYPCIe5111.Single = JYPCIe5111Import.JYPCIe5111_AI_Single , JYPCIe5111.Finite = JYPCIe5111Import.JYPCIe5111_AI_Finite , JYPCIe5111.Continuous = JYPCIe5111Import.JYPCIe5111_AI_Continuous , JYPCIe5111.Record = 0x3 }
AIMode. More...
enum | JYPCIe5111.AITerminal { JYPCIe5111.RSE = JYPCIe5111Import.JYPCIe5111_AI_RSE , JYPCIe5111.NRSE = JYPCIe5111Import.JYPCIe5111_AI_NRSE , JYPCIe5111.Differential = JYPCIe5111Import.JYPCIe5111_AI_Diff }
AITerminal. More...
enum | JYPCIe5111.AISampleClockSource { JYPCIe5111.Internal , JYPCIe5111.External }
AI Sample Clock Source. More...
enum JYPCIe5111.ClockTerminal {
JYPCIe5111.ECLK = 10000 , JYPCIe5111.PFI0 = 0 , JYPCIe5111.PFI1 = 1 , JYPCIe5111.PFI2 = 2 ,
JYPCIe5111.PFI3 = 3 , JYPCIe5111.PFI4 = 4 , JYPCIe5111.PFI5 = 5 , JYPCIe5111.PFI6 = 6 ,
JYPCIe5111.PFI7 = 7 , JYPCIe5111.PFI8 = 8 , JYPCIe5111.PFI9 = 9 , JYPCIe5111.PFI10 = 10 ,
JYPCIe5111.PFI11 = 11 , JYPCIe5111.PFI12 = 12 , JYPCIe5111.PFI13 = 13 , JYPCIe5111.PFI14 = 14 ,
JYPCIe5111.PFI15 = 15 , JYPCIe5111.PXI_Trig0 = 40 , JYPCIe5111.PXI_Trig1 = 41 , JYPCIe5111.PXI_Trig2 = 42 ,
JYPCIe5111.PXI_Trig3 = 43 , JYPCIe5111.PXI_Trig4 = 44 , JYPCIe5111.PXI_Trig5 = 45 , JYPCIe5111.PXI_Trig6 = 46 ,
JYPCIe5111.PXI_Trig7 = 47 , JYPCIe5111.AI_SampleClock = JYPCIe5111Import.JYPCIe5111_AI_SampleClock , JYPCIe5111.AO_SampleClock = JYPCIe5111Import.JYPCIe5111_AO_SampleClock , JYPCIe5111.CI0_SampleClock = JYPCIe5111Import.JYPCIe5111_CI0_SampleClock ,
JYPCIe5111.CI1_SampleClock = JYPCIe5111Import.JYPCIe5111_CI1_SampleClock , JYPCIe5111.CI2_SampleClock = JYPCIe5111Import.JYPCIe5111_CI2_SampleClock , JYPCIe5111.CI3_SampleClock = JYPCIe5111Import.JYPCIe5111_CI3_SampleClock
}
Clock Terminal. More...
enum | JYPCIe5111.AITriggerMode { JYPCIe5111.Start , JYPCIe5111.Reference }
AI Trigger Mode. More...
enum JYPCIe5111.AIAnalogTriggerSource {
JYPCIe5111.Channel_0 , JYPCIe5111.Channel_1 , JYPCIe5111.Channel_2 , JYPCIe5111.Channel_3 ,
JYPCIe5111.Channel_4 , JYPCIe5111.Channel_5 , JYPCIe5111.Channel_6 , JYPCIe5111.Channel_7 ,
JYPCIe5111.Channel_8 , JYPCIe5111.Channel_9 , JYPCIe5111.Channel_10 , JYPCIe5111.Channel_11 ,
JYPCIe5111.Channel_12 , JYPCIe5111.Channel_13 , JYPCIe5111.Channel_14 , JYPCIe5111.Channel_15 ,
JYPCIe5111.Channel_16 , JYPCIe5111.Channel_17 , JYPCIe5111.Channel_18 , JYPCIe5111.Channel_19 ,
JYPCIe5111.Channel_20 , JYPCIe5111.Channel_21 , JYPCIe5111.Channel_22 , JYPCIe5111.Channel_23 ,
JYPCIe5111.Channel_24 , JYPCIe5111.Channel_25 , JYPCIe5111.Channel_26 , JYPCIe5111.Channel_27 ,
JYPCIe5111.Channel_28 , JYPCIe5111.Channel_29 , JYPCIe5111.Channel_30 , JYPCIe5111.Channel_31
}
AI analog trigger source. More...
enum JYPCIe5111.AIDigitalTriggerSource {
JYPCIe5111.PFI0 , JYPCIe5111.PFI1 , JYPCIe5111.PFI2 , JYPCIe5111.PFI3 ,
JYPCIe5111.PFI4 , JYPCIe5111.PFI5 , JYPCIe5111.PFI6 , JYPCIe5111.PFI7 ,
JYPCIe5111.PFI8 , JYPCIe5111.PFI9 , JYPCIe5111.PFI10 , JYPCIe5111.PFI11 ,
JYPCIe5111.PFI12 , JYPCIe5111.PFI13 , JYPCIe5111.PFI14 , JYPCIe5111.PFI15 ,
JYPCIe5111.PXI_Trig0 = 40 , JYPCIe5111.PXI_Trig1 = 41 , JYPCIe5111.PXI_Trig2 = 42 , JYPCIe5111.PXI_Trig3 = 43 ,
JYPCIe5111.PXI_Trig4 = 44 , JYPCIe5111.PXI_Trig5 = 45 , JYPCIe5111.PXI_Trig6 = 46 , JYPCIe5111.PXI_Trig7 = 47 ,
JYPCIe5111.AO_StartTrig = JYPCIe5111Import.JYPCIe5111_AO_StartTrig , JYPCIe5111.DI_StartTrig = JYPCIe5111Import.JYPCIe5111_DI_StartTrig , JYPCIe5111.DI_ReferenceTrig = JYPCIe5111Import.JYPCIe5111_DI_ReferenceTrig , JYPCIe5111.DO_StartTrig = JYPCIe5111Import.JYPCIe5111_DO_StartTrig ,
JYPCIe5111.CI0_StartTrig = JYPCIe5111Import.JYPCIe5111_CI0_StartTrig , JYPCIe5111.CI1_StartTrig = JYPCIe5111Import.JYPCIe5111_CI1_StartTrig
}
AI Digital trigger source. More...
enum | JYPCIe5111.AIAnalogTriggerEdge { JYPCIe5111.Rising , JYPCIe5111.Falling }
AI Analog Trigger Edge. More...
enum | JYPCIe5111.AIAnalogWindowCondition { JYPCIe5111.Entering , JYPCIe5111.Leaving }
AI Analog Window Trigger Condition. More...
enum | JYPCIe5111.AIAnalogTriggerComparator { JYPCIe5111.Edge , JYPCIe5111.Hysteresis , JYPCIe5111.Window }
AI Analog Trigger Comparator. More...
enum | JYPCIe5111.AISignalExportSource { JYPCIe5111.StartTrig = JYPCIe5111Import.JYPCIe5111_AI_StartTrig , JYPCIe5111.ReferenceTrig = JYPCIe5111Import.JYPCIe5111_AI_ReferenceTrig , JYPCIe5111.SampleClock = JYPCIe5111Import.JYPCIe5111_AI_SampleClock }
AI Signal Export Source. More...
enum | JYPCIe5111.FileFormat { JYPCIe5111.Bin }
Streaming file format. More...
enum | JYPCIe5111.RecordMode { JYPCIe5111.Finite , JYPCIe5111.Infinite }
stream mode .enum Finite/Infinite More...
enum JYPCIe5111.SignalExportDestination {
JYPCIe5111.PFI0 , JYPCIe5111.PFI1 , JYPCIe5111.PFI2 , JYPCIe5111.PFI3 ,
JYPCIe5111.PFI4 , JYPCIe5111.PFI5 , JYPCIe5111.PFI6 , JYPCIe5111.PFI7 ,
JYPCIe5111.PFI8 , JYPCIe5111.PFI9 , JYPCIe5111.PFI10 , JYPCIe5111.PFI11 ,
JYPCIe5111.PFI12 , JYPCIe5111.PFI13 , JYPCIe5111.PFI14 , JYPCIe5111.PFI15 ,
JYPCIe5111.PXI_Trig0 = JYPCIe5111Import.JYPCIe5111_PXITrig0_OUT , JYPCIe5111.PXI_Trig1 = JYPCIe5111Import.JYPCIe5111_PXITrig1_OUT , JYPCIe5111.PXI_Trig2 = JYPCIe5111Import.JYPCIe5111_PXITrig2_OUT , JYPCIe5111.PXI_Trig3 = JYPCIe5111Import.JYPCIe5111_PXITrig3_OUT ,
JYPCIe5111.PXI_Trig4 = JYPCIe5111Import.JYPCIe5111_PXITrig4_OUT , JYPCIe5111.PXI_Trig5 = JYPCIe5111Import.JYPCIe5111_PXITrig5_OUT , JYPCIe5111.PXI_Trig6 = JYPCIe5111Import.JYPCIe5111_PXITrig6_OUT , JYPCIe5111.PXI_Trig7 = JYPCIe5111Import.JYPCIe5111_PXITrig7_OUT
}
Output DestinationTerminal. More...


5111 C# Programming Manual: JYPCIe5111.JYPCIe5111AITask Class Reference

  • Class List
  • Class Index
  • Class Members
  • JYPCIe5111
  • JYPCIe5111AITask
Public Member Functions | Properties | List of all members
JYPCIe5111.JYPCIe5111AITask Class Referencesealed

JYPCIe5111 Analog Input Task. More...

Public Member Functions

JYPCIe5111AITask (int slotNum)
Constructor, Used to create an AI task by a slot number.
JYPCIe5111AITask (string boardName)
Constructor.
void | AddChannel (int chnId, double rangeLow=-10, double rangeHigh=10, AITerminal terminalCfg=AITerminal.RSE)
Add one channel.
void | AddChannel (int[] chnsId, double rangeLow=-10, double rangeHigh=10, AITerminal terminalCfg=AITerminal.RSE)
Add a group of channels.
void | AddChannel (int[] chnsId, double[] rangeLow, double[] rangeHigh, AITerminal terminalCfg=AITerminal.RSE)
Add a group of channels.
void | RemoveChannel (int chnId)
Delete the specified channel number.
void | ReadData (IntPtr buf, int samplesPerChannel, int timeout)
Read one or multi-channel data by columns and store it in a data buffer.
void | ReadData (ref double[,] buf, int samplesPerChannel, int timeout)
Read the multi-channel data by columns and store it in a data buffer.
void | ReadData (ref double[,] buf, int timeout=-1)
Read the multi-channel data by columns and store it in a data buffer.
void | ReadData (ref double[] buf, int samplesPerChannel, int timeout)
Read the one channel data and store it in a data buffer.
void | ReadData (ref double[] buf, int timeout=-1)
Read the one channel data and store it in a data buffer.
void | ReadRawData (IntPtr buf, int samplesPerChannel, int timeout)
Read one or multi-channel raw data by columns and store it in a data buffer.
void | ReadRawData (ref int[,] buf, int samplesPerChannel, int timeout)
Read the multi-channel raw data by columns and store it in a data buffer.
void | ReadRawData (ref int[,] buf, int timeout=-1)
Read the multi-channel raw data by columns and store it in a data buffer.
void | ReadRawData (ref int[] buf, int samplesPerChannel, int timeout)
Read the one channel raw data and store it in a data buffer.
void | ReadRawData (ref int[] buf, int timeout=-1)
Read the one channel raw data and store it in a data buffer.
void | GetRecordPreviewData (ref double[,] buf, int samplesPerChannel, int timeout)
Preview multi-channel data when streaming is in progress.
void | GetRecordPreviewData (ref double[,] buf, int timeout=-1)
Preview multi-channel data when streaming is in progress.
void | GetRecordPreviewData (ref double[] buf, int samplesPerChannel, int timeout)
Preview one channel data when streaming is in progress.
void | GetRecordPreviewData (ref double[] buf, int timeout=-1)
Preview one channel data when streaming is in progress.
void | ReadSinglePoint (ref double[] readValues)
Read one sample for all channels in register .
void | ReadSinglePoint (ref double readValue, int channel)
Read one sample for specified channel in register.
void | ReadRawSinglePoint (ref int[] readValues)
Read raw one sample for all channels in register .
void | ReadRawSinglePoint (ref int readValue, int channel)
Read raw one sample for specified channel in register.
void | GetRecordStatus (out double recordedLength, out bool recordDone)
get the streaming status.
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.
void | Start ()
Start AI task .
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Stop ()
Stop AI task .

Properties

List< AIChannel > | Channels [get]
List of AI channels,(5111 support16 SE/8 Diff channel)
AIMode | Mode [get, set]
AI acquisition mode，support Single/Finite/Continuous/Record.
double | SampleRate [get, set]
Sample rate per channel.
int | SamplesToAcquire [get, set]
Number of samples to be read per channel.
int | BufLenInSamples [get]
Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.
ulong | AvailableSamples [get]
Number of samples per channel that can be read in the buffer .
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel).
AISampleClock | SampleClock [get, set]
AI Sample Clock Configuration.
AITrigger | Trigger [get, set]
AI Trigger Configuration.
AIAdvanced | Advanced [get, set]
AI Advanced Configuration.
AIRecord | Record = new AIRecord() [get]
ai Data streaming Configuration
bool | DisableCalibration [get, set]
Disalble calibration Enable.
AISignalExport | SignalExport [get, set]
Export AI Signal Configuration.
JYPCIe5111Device | Device [get]
Device.

Detailed Description

JYPCIe5111 Analog Input Task.

Constructor & Destructor Documentation

◆ JYPCIe5111AITask() [1/2]

JYPCIe5111.JYPCIe5111AITask.JYPCIe5111AITask ( int slotNum )

Constructor, Used to create an AI task by a slot number.

Parameters
slotNum slot number.

◆ JYPCIe5111AITask() [2/2]

JYPCIe5111.JYPCIe5111AITask.JYPCIe5111AITask ( string boardName )

Constructor.

Used to create an AI task by a board name.

Parameters
boardName Board name(device alias), set by device manager

Member Function Documentation

◆ AddChannel() [1/3]

void JYPCIe5111.JYPCIe5111AITask.AddChannel | ( | int | chnId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10,
 |  | AITerminal | terminalCfg = AITerminal::RSE )

Add one channel.

Parameters
chnId | channel's physical number ，chnId=-1, add all channels。（5111 SE 0-31, Differential 0-7,16-23）
rangeLow | lower range limit for the channel，-10V, -5V, -2.5V, -1.25V, -0.625V defalut -10
rangeHigh | higher range limit for the channel，10V, 5V, 2.5V, 1.25V, 0.625Vdefalut 10
terminalCfg | terminal input mode configuration，RSE/NRSE/Differential.Default RSE

◆ AddChannel() [2/3]

void JYPCIe5111.JYPCIe5111AITask.AddChannel | ( | int[] | chnsId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10,
 |  | AITerminal | terminalCfg = AITerminal::RSE )

Add a group of channels.

Parameters
chnsId | channel's physical number （5111 SE 0-31, Differential 0-7,16-23）
rangeLow | lower range limit for the channel，-10V, -5V, -2.5V, -1.25V, -0.625V defalut -10
rangeHigh | higher range limit for the channel，10V, 5V, 2.5V, 1.25V, 0.625V defalut 10
terminalCfg | terminal input mode configuration，RSE/NRSE/Differential.Default RSE

◆ AddChannel() [3/3]

void JYPCIe5111.JYPCIe5111AITask.AddChannel | ( | int[] | chnsId,
 |  | double[] | rangeLow,
 |  | double[] | rangeHigh,
 |  | AITerminal | terminalCfg = AITerminal::RSE )

Add a group of channels.

Parameters
chnsId | channel's physical number ，chnId=-1, add all channels。（5111 SE 0-31, Differential 0-7,16-23）
rangeLow | lower range limit for the channel，-10V, -5V, -2.5V, -1.25V, -0.625V defalut -10
rangeHigh | higher range limit for the channel，10V, 5V, 2.5V, 1.25V, 0.625V,defalut 10
terminalCfg | terminal input mode configuration，RSE/NRSE/Differential.Default RSE

◆ GetRecordPreviewData() [1/4]

void JYPCIe5111.JYPCIe5111AITask.GetRecordPreviewData | ( | ref double | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout )

Preview multi-channel data when streaming is in progress.

Each column represents one channel.

Parameters
buf | Data buffer
samplesPerChannel | Number of preview samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ GetRecordPreviewData() [2/4]

void JYPCIe5111.JYPCIe5111AITask.GetRecordPreviewData | ( | ref double | buf[,],
 |  | int | timeout = -1 )

Preview multi-channel data when streaming is in progress.

Each column represents one channel.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ GetRecordPreviewData() [3/4]

void JYPCIe5111.JYPCIe5111AITask.GetRecordPreviewData | ( | ref double[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Preview one channel data when streaming is in progress.

Parameters
buf | Data buffer
samplesPerChannel | Number of preview samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ GetRecordPreviewData() [4/4]

void JYPCIe5111.JYPCIe5111AITask.GetRecordPreviewData | ( | ref double[] | buf,
 |  | int | timeout = -1 )

Preview one channel data when streaming is in progress.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ GetRecordStatus()

void JYPCIe5111.JYPCIe5111AITask.GetRecordStatus | ( | out double | recordedLength,
 |  | out bool | recordDone )

get the streaming status.

Available when Mode is AIMode.Record

Parameters
recordedLength | Length of the streamed
recordDone | recordDone = false :streaming is not over.recordDone = true :streaming is over.

◆ ReadData() [1/5]

void JYPCIe5111.JYPCIe5111AITask.ReadData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read one or multi-channel data by columns and store it in a data buffer.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel to read
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadData() [2/5]

void JYPCIe5111.JYPCIe5111AITask.ReadData | ( | ref double | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read the multi-channel data by columns and store it in a data buffer.

Each channel is represented by one column of data.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel to read
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadData() [3/5]

void JYPCIe5111.JYPCIe5111AITask.ReadData | ( | ref double | buf[,],
 |  | int | timeout = -1 )

Read the multi-channel data by columns and store it in a data buffer.

Each channel is represented by one column of data.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadData() [4/5]

void JYPCIe5111.JYPCIe5111AITask.ReadData | ( | ref double[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read the one channel data and store it in a data buffer.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel to read
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadData() [5/5]

void JYPCIe5111.JYPCIe5111AITask.ReadData | ( | ref double[] | buf,
 |  | int | timeout = -1 )

Read the one channel data and store it in a data buffer.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadRawData() [1/5]

void JYPCIe5111.JYPCIe5111AITask.ReadRawData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read one or multi-channel raw data by columns and store it in a data buffer.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel to read
timeout | timeout before generating error message, uint is ms。, timeout =-1 keep waiting until finish.

◆ ReadRawData() [2/5]

void JYPCIe5111.JYPCIe5111AITask.ReadRawData | ( | ref int | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read the multi-channel raw data by columns and store it in a data buffer.

Each channel is represented by one column of data.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel to read
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadRawData() [3/5]

void JYPCIe5111.JYPCIe5111AITask.ReadRawData | ( | ref int | buf[,],
 |  | int | timeout = -1 )

Read the multi-channel raw data by columns and store it in a data buffer.

Each channel is represented by one column of data.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadRawData() [4/5]

void JYPCIe5111.JYPCIe5111AITask.ReadRawData | ( | ref int[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read the one channel raw data and store it in a data buffer.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel to read
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadRawData() [5/5]

void JYPCIe5111.JYPCIe5111AITask.ReadRawData | ( | ref int[] | buf,
 |  | int | timeout = -1 )

Read the one channel raw data and store it in a data buffer.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadRawSinglePoint() [1/2]

void JYPCIe5111.JYPCIe5111AITask.ReadRawSinglePoint | ( | ref int | readValue,
 |  | int | channel )

Read raw one sample for specified channel in register.

Available when Mode is AIMode.Single

Parameters
readValue | value read
channel | Specified channel numbers.

◆ ReadRawSinglePoint() [2/2]

void JYPCIe5111.JYPCIe5111AITask.ReadRawSinglePoint ( ref int[] readValues )

Read raw one sample for all channels in register .

Available when Mode is AIMode.Single

Parameters
readValues Values read. Array length >= Channels.Count.

◆ ReadSinglePoint() [1/2]

void JYPCIe5111.JYPCIe5111AITask.ReadSinglePoint | ( | ref double | readValue,
 |  | int | channel )

Read one sample for specified channel in register.

Available when Mode is AIMode.Single

Parameters
readValue | value read
channel | Specified channel numbers.

◆ ReadSinglePoint() [2/2]

void JYPCIe5111.JYPCIe5111AITask.ReadSinglePoint ( ref double[] readValues )

Read one sample for all channels in register .

Available when Mode is AIMode.Single

Parameters
readValues Values read. Array length >= Channels.Count.

◆ RemoveChannel()

void JYPCIe5111.JYPCIe5111AITask.RemoveChannel ( int chnId )

Delete the specified channel number.

If it is -1, delete all channels.

Parameters
chnId Specified channel ID.

◆ SendSoftwareTrigger()

void JYPCIe5111.JYPCIe5111AITask.SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JYPCIe5111.JYPCIe5111AITask.Start ( )

Start AI task .

◆ Stop()

void JYPCIe5111.JYPCIe5111AITask.Stop ( )

Stop AI task .

◆ WaitUntilDone()

bool JYPCIe5111.JYPCIe5111AITask.WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

Property Documentation

◆ Advanced

AIAdvanced JYPCIe5111.JYPCIe5111AITask.Advanced
getset

AI Advanced Configuration.

◆ AvailableSamples

ulong JYPCIe5111.JYPCIe5111AITask.AvailableSamples
get

Number of samples per channel that can be read in the buffer .

Valid when Mode is NOT AIMode.Single.

◆ BufLenInSamples

int JYPCIe5111.JYPCIe5111AITask.BufLenInSamples
get

Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.

◆ Channels

List<AIChannel> JYPCIe5111.JYPCIe5111AITask.Channels
get

List of AI channels,(5111 support16 SE/8 Diff channel)

◆ Device

JYPCIe5111Device JYPCIe5111.JYPCIe5111AITask.Device
get

Device.

◆ DisableCalibration

bool JYPCIe5111.JYPCIe5111AITask.DisableCalibration
getset

Disalble calibration Enable.

◆ Mode

AIMode JYPCIe5111.JYPCIe5111AITask.Mode
getset

AI acquisition mode，support Single/Finite/Continuous/Record.

◆ Record

AIRecord JYPCIe5111.JYPCIe5111AITask.Record = new AIRecord()
get

ai Data streaming Configuration

◆ SampleClock

AISampleClock JYPCIe5111.JYPCIe5111AITask.SampleClock
getset

AI Sample Clock Configuration.

◆ SampleRate

double JYPCIe5111.JYPCIe5111AITask.SampleRate
getset

Sample rate per channel.

Maximum sample rate is 250K for single channel, 250K /N for multichannel (N) The defalut sample rate = 10k You can read this property to obtain the sample rate that will actually take effect in the current configuration.

◆ SamplesToAcquire

int JYPCIe5111.JYPCIe5111AITask.SamplesToAcquire
getset

Number of samples to be read per channel.

Only valid when Mode is AIMode.Finite.

◆ SignalExport

AISignalExport JYPCIe5111.JYPCIe5111AITask.SignalExport
getset

Export AI Signal Configuration.

◆ TransferedSamples

ulong JYPCIe5111.JYPCIe5111AITask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT AIMode.Single.

◆ Trigger

AITrigger JYPCIe5111.JYPCIe5111AITask.Trigger
getset

AI Trigger Configuration.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111AITask.cs


5111 C# Programming Manual: JYPCIe5111.AIChannel Class Reference

  • JYPCIe5111
  • AIChannel
Public Member Functions | Properties | List of all members
JYPCIe5111.AIChannel Class Referencesealed

AI Channel parameter class . More...

Public Member Functions

AIChannel (int channelId, double rangeLow, double rangeHigh, AITerminal terminalCfg=AITerminal.NRSE)
Constructor to create an AIChnParam task object.

Properties

int | ChannelID [get]
AI channel ID.
double | RangeLow [get, set]
Low range limit an AI channel.
double | RangeHigh [get, set]
High range limit an AI channel.
AITerminal | Terminal [get, set]
Configure AI terminal.

Detailed Description

AI Channel parameter class .

Constructor & Destructor Documentation

◆ AIChannel()

JYPCIe5111.AIChannel.AIChannel | ( | int | channelId,
 |  | double | rangeLow,
 |  | double | rangeHigh,
 |  | AITerminal | terminalCfg = AITerminal::NRSE )

Constructor to create an AIChnParam task object.

Parameters
channelId | AI channel ID.
rangeLow | Low range limit an AI channel.
rangeHigh | High range limit an AI channel.
terminalCfg | Configure AI terminal.

Property Documentation

◆ ChannelID

int JYPCIe5111.AIChannel.ChannelID
get

AI channel ID.

◆ RangeHigh

double JYPCIe5111.AIChannel.RangeHigh
getset

High range limit an AI channel.

◆ RangeLow

double JYPCIe5111.AIChannel.RangeLow
getset

Low range limit an AI channel.

◆ Terminal

AITerminal JYPCIe5111.AIChannel.Terminal
getset

Configure AI terminal.

(RSE,NRSE,Differential)

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111AITask.cs


5111 C# Programming Manual: JYPCIe5111.AISampleClock Class Reference

  • AISampleClock
Properties | List of all members
JYPCIe5111.AISampleClock Class Reference

Sample clock configuration class. More...

Properties

AISampleClockSource | Source [get, set]
AI Sample Clock Source.
AIExternalSampleClock | External [get, set]
External Sample Clock Configuration.

Detailed Description

Sample clock configuration class.

Property Documentation

◆ External

AIExternalSampleClock JYPCIe5111.AISampleClock.External
getset

External Sample Clock Configuration.

Valid when Source is AISampleClockSource.External.

◆ Source

AISampleClockSource JYPCIe5111.AISampleClock.Source
getset

AI Sample Clock Source.

enum Internal/External. The default value is AISampleClockSource.Internal.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111AITask.cs


5111 C# Programming Manual: JYPCIe5111.AIExternalSampleClock Class Reference

  • AIExternalSampleClock
Properties | List of all members
JYPCIe5111.AIExternalSampleClock Class Reference

External Sample Clock Configuration Class. More...

Properties

ClockTerminal | Terminal [get, set]
External Sample Clock Input Terminal.
double | ExpectedRate [get, set]
Expected External Sample Clock Rate.

Detailed Description

External Sample Clock Configuration Class.

Property Documentation

◆ ExpectedRate

double JYPCIe5111.AIExternalSampleClock.ExpectedRate
getset

Expected External Sample Clock Rate.

◆ Terminal

ClockTerminal JYPCIe5111.AIExternalSampleClock.Terminal
getset

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111AITask.cs


5111 C# Programming Manual: JYPCIe5111.AITrigger Class Reference

  • AITrigger
Properties | List of all members
JYPCIe5111.AITrigger Class Referencesealed

Constructor to create an AITrigger task object. More...

Properties

AITriggerType | Type [get, set]
AI trigger type.
AITriggerMode | Mode [get, set]
AI trigger mode.
AIDigitalTrigger | Digital [get, set]
Digital Trigger Congfiguration.
AIAnalogTrigger | Analog [get, set]
AI Analog Trigger.
int | ReTriggerCount [get, set]
Number of repeat triggers.
uint | PreTriggerSamples [get, set]
AI pretrigger samples, must be less than or equal to JYPCIe5111AITask.SamplesToAcquire.

Detailed Description

Constructor to create an AITrigger task object.

Used to build AI Trigger

Property Documentation

◆ Analog

AIAnalogTrigger JYPCIe5111.AITrigger.Analog
getset

AI Analog Trigger.

Valid when Type is AITriggerType.Analog.

◆ Digital

AIDigitalTrigger JYPCIe5111.AITrigger.Digital
getset

Digital Trigger Congfiguration.

Valid when Type is AITriggerType.Digital.

◆ Mode

AITriggerMode JYPCIe5111.AITrigger.Mode
getset

AI trigger mode.

enum Start/Reference. The default value is AITriggerMode.Start.

◆ PreTriggerSamples

uint JYPCIe5111.AITrigger.PreTriggerSamples
getset

AI pretrigger samples, must be less than or equal to JYPCIe5111AITask.SamplesToAcquire.

Valid when Mode is AITriggerMode.Reference.

◆ ReTriggerCount

int JYPCIe5111.AITrigger.ReTriggerCount
getset

Number of repeat triggers.

When 0 or 1 only trigger once, When -1 continuous retrigger until stop.

◆ Type

AITriggerType JYPCIe5111.AITrigger.Type
getset

AI trigger type.

enum Analog/Digital/Immediate/Soft. The default value is AITriggerType.Immediate.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111AITask.cs


5111 C# Programming Manual: JYPCIe5111.AIDigitalTrigger Class Reference

  • AIDigitalTrigger
Properties | List of all members
JYPCIe5111.AIDigitalTrigger Class Referencesealed

AI Digital trigger class. More...

Properties

AIDigitalTriggerSource | Source [get, set]
AI Digital Trigger source.
AIDigitalTriggerEdge | Edge [get, set]
Digital Trigger edge，Rising/Falling.

Detailed Description

AI Digital trigger class.

Property Documentation

◆ Edge

AIDigitalTriggerEdge JYPCIe5111.AIDigitalTrigger.Edge
getset

Digital Trigger edge，Rising/Falling.

◆ Source

AIDigitalTriggerSource JYPCIe5111.AIDigitalTrigger.Source
getset

AI Digital Trigger source.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111AITask.cs


5111 C# Programming Manual: JYPCIe5111.AIAnalogTrigger Class Reference

  • AIAnalogTrigger
Properties | List of all members
JYPCIe5111.AIAnalogTrigger Class Referencesealed

AI analog trigger . More...

Properties

AIAnalogTriggerSource | Source [get, set]
Analog Trigger source.
AIAnalogTriggerComparator | Comparator [get, set]
AI Analog Trigger Comparator.
AIAnalogEdgeComparator | Edge [get, set]
AI Analog Edge Comparator.
AIAnalogHysteresisComparator | Hysteresis [get, set]
AI Analog Hysteresis Comparatorr.
AIAnalogWindowComparator | Window [get, set]
AI Analog Window Comparatorr.

Detailed Description

AI analog trigger .

Property Documentation

◆ Comparator

AIAnalogTriggerComparator JYPCIe5111.AIAnalogTrigger.Comparator
getset

AI Analog Trigger Comparator.

◆ Edge

AIAnalogEdgeComparator JYPCIe5111.AIAnalogTrigger.Edge
getset

AI Analog Edge Comparator.

◆ Hysteresis

AIAnalogHysteresisComparator JYPCIe5111.AIAnalogTrigger.Hysteresis
getset

AI Analog Hysteresis Comparatorr.

◆ Source

AIAnalogTriggerSource JYPCIe5111.AIAnalogTrigger.Source
getset

Analog Trigger source.

◆ Window

AIAnalogWindowComparator JYPCIe5111.AIAnalogTrigger.Window
getset

AI Analog Window Comparatorr.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111AITask.cs


5111 C# Programming Manual: JYPCIe5111.AIAnalogHysteresisComparator Class Reference

  • AIAnalogHysteresisComparator
Public Attributes | Properties | List of all members
JYPCIe5111.AIAnalogHysteresisComparator Class Reference

AI Analog Hysteresis Comparatorr. More...

Public Attributes

double | HighThreshold
High Threshold.
double | LowThreshold
Low Threshold.

Properties

AIAnalogTriggerEdge Slope [get, set]
AI Analog Trigger Edge.

Detailed Description

AI Analog Hysteresis Comparatorr.

Member Data Documentation

◆ HighThreshold

double JYPCIe5111.AIAnalogHysteresisComparator.HighThreshold

High Threshold.

◆ LowThreshold

double JYPCIe5111.AIAnalogHysteresisComparator.LowThreshold

Low Threshold.

Property Documentation

◆ Slope

AIAnalogTriggerEdge JYPCIe5111.AIAnalogHysteresisComparator.Slope
getset

AI Analog Trigger Edge.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111AITask.cs


5111 C# Programming Manual: JYPCIe5111.AIAnalogWindowComparator Class Reference

  • AIAnalogWindowComparator
Public Attributes | Properties | List of all members
JYPCIe5111.AIAnalogWindowComparator Class Reference

AI Analog Window Comparatorr. More...

Public Attributes

double | HighThreshold
High Threshold.
double | LowThreshold
Low Threshold.

Properties

AIAnalogWindowCondition Condition [get, set]
AI Analog Window Condition.

Detailed Description

AI Analog Window Comparatorr.

Member Data Documentation

◆ HighThreshold

double JYPCIe5111.AIAnalogWindowComparator.HighThreshold

High Threshold.

◆ LowThreshold

double JYPCIe5111.AIAnalogWindowComparator.LowThreshold

Low Threshold.

Property Documentation

◆ Condition

AIAnalogWindowCondition JYPCIe5111.AIAnalogWindowComparator.Condition
getset

AI Analog Window Condition.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111AITask.cs


5111 C# Programming Manual: JYPCIe5111.AIAnalogEdgeComparator Class Reference

  • AIAnalogEdgeComparator
Public Attributes | Properties | List of all members
JYPCIe5111.AIAnalogEdgeComparator Class Reference

AI Analog Edge Comparator. More...

Public Attributes

double Threshold
Threshold.

Properties

AIAnalogTriggerEdge Slope [get, set]
AI Analog Trigger Edge.

Detailed Description

AI Analog Edge Comparator.

Member Data Documentation

◆ Threshold

double JYPCIe5111.AIAnalogEdgeComparator.Threshold

Threshold.

Property Documentation

◆ Slope

AIAnalogTriggerEdge JYPCIe5111.AIAnalogEdgeComparator.Slope
getset

AI Analog Trigger Edge.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111AITask.cs


5111 C# Programming Manual: JYPCIe5111.AIRecord Class Reference

  • AIRecord
Properties | List of all members
JYPCIe5111.AIRecord Class Referencesealed

AI Record Parameters. More...

Properties

string | FilePath [get, set]
User specified file path.
FileFormat | FileFormat [get]
Streaming file format.
RecordMode | Mode [get, set]
stream mode .
double | Length [get, set]
User specified stream length in second.

Detailed Description

AI Record Parameters.

Property Documentation

◆ FileFormat

FileFormat JYPCIe5111.AIRecord.FileFormat
get

Streaming file format.

enum BIN.

◆ FilePath

string JYPCIe5111.AIRecord.FilePath
getset

User specified file path.

◆ Length

double JYPCIe5111.AIRecord.Length
getset

User specified stream length in second.

Only when Mode is RecordMode.Finite.

◆ Mode

RecordMode JYPCIe5111.AIRecord.Mode
getset

stream mode .

enum Finite/Infinite.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111AITask.cs


5111 C# Programming Manual: JYPCIe5111.AIAdvanced Class Reference

  • AIAdvanced
Properties | List of all members
JYPCIe5111.AIAdvanced Class Referencesealed

AI Advance parameter. More...

Properties

double ConvertRate [get, set]
the convert rate of ADC.

Detailed Description

AI Advance parameter.

Property Documentation

◆ ConvertRate

double JYPCIe5111.AIAdvanced.ConvertRate
getset

the convert rate of ADC.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111AITask.cs


5111 C# Programming Manual: JYPCIe5111.AISignalExport Class Reference

  • AISignalExport
Public Member Functions | List of all members
JYPCIe5111.AISignalExport Class Reference

AI Signal Export Class. More...

Public Member Functions

void | Add (AISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (AISignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

AI Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JYPCIe5111.AISignalExport.Add | ( | AISignalExportSource | source,
 |  | List< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | AI Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JYPCIe5111.AISignalExport.Add | ( | AISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | AI Signal Source
destination | Export Desination

◆ Clear()

void JYPCIe5111.AISignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JYPCIe5111.AISignalExport.ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111AITask.cs


5111 C# Programming Manual: D:/5111/C#/JYPCIe5111AOTask.cs File Reference

  • File List
  • 5111
  • C#
Classes | Namespaces | Enumerations
JYPCIe5111AOTask.cs File Reference

Classes

class | JYPCIe5111.JYPCIe5111AOTask
JYPCIe5111 Analog Ouput Task. More...
class | JYPCIe5111.AOChannel
AO Channel parameter class . More...
class | JYPCIe5111.AOSampleClock
AO Sample clock configuration class. More...
class | JYPCIe5111.AOExternalSampleClock
External Sample Clock Configuration Class. More...
class | JYPCIe5111.AOTrigger
Constructor to create an AOTrigger task object. More...
class | JYPCIe5111.AODigitalTrigger
AO Digital trigger . More...
class | JYPCIe5111.AOSignalExport
AO Signal Export Class. More...

Namespaces

namespace JYPCIe5111

Enumerations

enum | JYPCIe5111.AODigitalTriggerEdge { JYPCIe5111.Rising , JYPCIe5111.Falling }
AO Digital Trigger Edge. More...
enum JYPCIe5111.AODigitalTriggerSource {
JYPCIe5111.PFI0 , JYPCIe5111.PFI1 , JYPCIe5111.PFI2 , JYPCIe5111.PFI3 ,
JYPCIe5111.PFI4 , JYPCIe5111.PFI5 , JYPCIe5111.PFI6 , JYPCIe5111.PFI7 ,
JYPCIe5111.PFI8 , JYPCIe5111.PFI9 , JYPCIe5111.PFI10 , JYPCIe5111.PFI11 ,
JYPCIe5111.PFI12 , JYPCIe5111.PFI13 , JYPCIe5111.PFI14 , JYPCIe5111.PFI15 ,
JYPCIe5111.PXI_Trig0 = 40 , JYPCIe5111.PXI_Trig1 = 41 , JYPCIe5111.PXI_Trig2 = 42 , JYPCIe5111.PXI_Trig3 = 43 ,
JYPCIe5111.PXI_Trig4 = 44 , JYPCIe5111.PXI_Trig5 = 45 , JYPCIe5111.PXI_Trig6 = 46 , JYPCIe5111.PXI_Trig7 = 47 ,
JYPCIe5111.AI_StartTrig = JYPCIe5111Import.JYPCIe5111_AI_StartTrig , JYPCIe5111.AI_ReferenceTrig = JYPCIe5111Import.JYPCIe5111_AI_ReferenceTrig , JYPCIe5111.DI_StartTrig = JYPCIe5111Import.JYPCIe5111_DI_StartTrig , JYPCIe5111.DI_ReferenceTrig = JYPCIe5111Import.JYPCIe5111_DI_ReferenceTrig ,
JYPCIe5111.DO_StartTrig = JYPCIe5111Import.JYPCIe5111_DO_StartTrig , JYPCIe5111.CI0_StartTrig = JYPCIe5111Import.JYPCIe5111_CI0_StartTrig , JYPCIe5111.CI1_StartTrig = JYPCIe5111Import.JYPCIe5111_CI1_StartTrig
}
AO Digital trigger source. More...
enum | JYPCIe5111.AOMode { JYPCIe5111.Single = 3 , JYPCIe5111.Finite = 0 , JYPCIe5111.ContinuousNoWrapping = 2 , JYPCIe5111.ContinuousWrapping = 1 }
AOMode. More...
enum | JYPCIe5111.AOSampleClockSource { JYPCIe5111.Internal , JYPCIe5111.External }
AO Sample Clock Source. More...
enum | JYPCIe5111.AOSignalExportSource { JYPCIe5111.StartTrig = JYPCIe5111Import.JYPCIe5111_AO_StartTrig , JYPCIe5111.SampleClock = JYPCIe5111Import.JYPCIe5111_AO_SampleClock }
SourceSignal. More...
enum | JYPCIe5111.OutputCompleteState { JYPCIe5111.Zero , JYPCIe5111.Hold }
Output Complete State. More...
enum | JYPCIe5111.AOTriggerType { JYPCIe5111.Immediate = JYPCIe5111Import.JYPCIe5111_TriggerType_Immediately , JYPCIe5111.Digital = JYPCIe5111Import.JYPCIe5111_TriggerType_Digital , JYPCIe5111.Soft = JYPCIe5111Import.JYPCIe5111_TriggerType_Soft }
TriggerType Digital/Immediate/Soft. More...


5111 C# Programming Manual: JYPCIe5111.JYPCIe5111AOTask Class Reference

  • JYPCIe5111AOTask
Public Member Functions | Properties | List of all members
JYPCIe5111.JYPCIe5111AOTask Class Referencesealed

JYPCIe5111 Analog Ouput Task. More...

Public Member Functions

JYPCIe5111AOTask (int slotNum)
Constructor, Used to create an AO task by a slot number.
JYPCIe5111AOTask (string boardName)
Constructor.
void | AddChannel (int chnId, double rangeLow=-10, double rangeHigh=10)
Add one channel.
void | AddChannel (int[] chnsId, double rangeLow=-10, double rangeHigh=10)
Add a group of channels.
void | AddChannel (int[] chnsId, double[] rangeLow, double[] rangeHigh)
Add a group of channels.
void | RemoveChannel (int chnId)
Delete the specified channel number.
void | WriteData (double[,] buf, int timeout=10000)
Write multi-channel data to AO buffer, Each column represents one channel.
void | WriteData (IntPtr buf, int samplesPerChannel, int timeout=10000)
Write to AO buffer one or multi-channel data.
void | WriteData (double[] buf, int timeout=10000)
Write one channel data to AO buffer.
void | WriteRawData (short[,] buf, int timeout=10000)
Write multi-channel raw data to AO buffer, Each column represents one channel.
void | WriteRawData (IntPtr buf, int samplesPerChannel, int timeout=10000)
Write to AO buffer one or multi-channel raw data.
void | WriteRawData (short[] buf, int timeout=10000)
Write one channel raw Data to AO buffer.
void | WriteSinglePoint (double[] writeValues)
write one sample to all channels in register .
void | WriteSinglePoint (double writeValue, int channel)
Write one sample to the specified channel in register.Available when Mode is AOMode.Single
void | WriteRawSinglePoint (short[] writeValues)
write one raw sample to all channels in register .
void | WriteRawSinglePoint (short writeValue, int channel)
Write one raw sample to the specified channel in register.Available when Mode is AOMode.Single
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.
void | Start ()
Start AO task .
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Stop ()
Stop AO task .

Properties

List< AOChannel > | Channels [get]
List of AO channels,(5111 support 2 channels)
AOMode | Mode [get, set]
Mode of AO Task.
double | UpdateRate [get, set]
Update rate per channel.
int | SamplesToUpdate [get, set]
Number of output samples to write per channel , Only valid when Mode is AOMode.Finite.
int | BufLenInSamples [get]
Number of samples per channel can be storage in the buffer, the PropretySamplesToUpdate must be less than or equal to this value.
uint | AvaliableLenInSamples [get]
Number of output samples per channel that can be write in AO buffuer.
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel).
OutputCompleteState | CompleteState [get, set]
AO Output Complete State, Default is Hold.
AOSampleClock | SampleClock [get, set]
AO Sample Clock Configuration .
AOTrigger | Trigger = new AOTrigger() [get, set]
AO Trigger Configuration.
bool | DisableCalibration [get, set]
Disalble calibration.
AOSignalExport | SignalExport [get, set]
Export AO Signal.
JYPCIe5111Device | Device [get]
Device.

Detailed Description

JYPCIe5111 Analog Ouput Task.

Constructor & Destructor Documentation

◆ JYPCIe5111AOTask() [1/2]

JYPCIe5111.JYPCIe5111AOTask.JYPCIe5111AOTask ( int slotNum )

Constructor, Used to create an AO task by a slot number.

Parameters
slotNum Card slot number.

◆ JYPCIe5111AOTask() [2/2]

JYPCIe5111.JYPCIe5111AOTask.JYPCIe5111AOTask ( string boardName )

Constructor.

Used to create an AO task by a board name.

Parameters
boardName Board name(device alias), set by device manager

Member Function Documentation

◆ AddChannel() [1/3]

void JYPCIe5111.JYPCIe5111AOTask.AddChannel | ( | int | chnId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10 )

Add one channel.

Parameters
chnId | channel's physical number ，chnId=-1, add all channels。（5111 support 4 channels）
rangeLow | lower range limit for the channel，-10V,-5V defalut -10
rangeHigh | higher range limit for the channel，10V,5V defalut 10

◆ AddChannel() [2/3]

void JYPCIe5111.JYPCIe5111AOTask.AddChannel | ( | int[] | chnsId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10 )

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers。（5111 support 4 channels）
rangeLow | lower range limit for the channel，-10V,-5V defalut -10
rangeHigh | higher range limit for the channel，10V,5V defalut 10

◆ AddChannel() [3/3]

void JYPCIe5111.JYPCIe5111AOTask.AddChannel | ( | int[] | chnsId,
 |  | double[] | rangeLow,
 |  | double[] | rangeHigh )

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers。（5111 support 4 channels）
rangeLow | lower range limit for the channel，-10V,-5V
rangeHigh | higher range limit for the channel，10V,5V

◆ RemoveChannel()

void JYPCIe5111.JYPCIe5111AOTask.RemoveChannel ( int chnId )

Delete the specified channel number.

If it is -1, delete all channels.

Parameters
chnId Specified channel ID.

◆ SendSoftwareTrigger()

void JYPCIe5111.JYPCIe5111AOTask.SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JYPCIe5111.JYPCIe5111AOTask.Start ( )

Start AO task .

◆ Stop()

void JYPCIe5111.JYPCIe5111AOTask.Stop ( )

Stop AO task .

◆ WaitUntilDone()

bool JYPCIe5111.JYPCIe5111AOTask.WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Available when Mode is AOMode.Finite

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteData() [1/3]

void JYPCIe5111.JYPCIe5111AOTask.WriteData | ( | double | buf[,],
 |  | int | timeout = 10000 )

Write multi-channel data to AO buffer, Each column represents one channel.

Parameters
buf | AO buffer for data.
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [2/3]

void JYPCIe5111.JYPCIe5111AOTask.WriteData | ( | double[] | buf,
 |  | int | timeout = 10000 )

Write one channel data to AO buffer.

Parameters
buf | AO buffer for data.
timeout | >timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [3/3]

void JYPCIe5111.JYPCIe5111AOTask.WriteData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Write to AO buffer one or multi-channel data.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | data buffer.
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawData() [1/3]

void JYPCIe5111.JYPCIe5111AOTask.WriteRawData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Write to AO buffer one or multi-channel raw data.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | data buffer.
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawData() [2/3]

void JYPCIe5111.JYPCIe5111AOTask.WriteRawData | ( | short | buf[,],
 |  | int | timeout = 10000 )

Write multi-channel raw data to AO buffer, Each column represents one channel.

Parameters
buf | AO buffer for data.
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawData() [3/3]

void JYPCIe5111.JYPCIe5111AOTask.WriteRawData | ( | short[] | buf,
 |  | int | timeout = 10000 )

Write one channel raw Data to AO buffer.

Parameters
buf | AO buffer for data.
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawSinglePoint() [1/2]

void JYPCIe5111.JYPCIe5111AOTask.WriteRawSinglePoint | ( | short | writeValue,
 |  | int | channel )

Write one raw sample to the specified channel in register.Available when Mode is AOMode.Single

Parameters
writeValue | Write value.
channel | Specified channel.

◆ WriteRawSinglePoint() [2/2]

void JYPCIe5111.JYPCIe5111AOTask.WriteRawSinglePoint ( short[] writeValues )

write one raw sample to all channels in register .

Available when Mode is AOMode.Single

Parameters
writeValues Write values. Array length >= Channels.Count.

◆ WriteSinglePoint() [1/2]

void JYPCIe5111.JYPCIe5111AOTask.WriteSinglePoint | ( | double | writeValue,
 |  | int | channel )

Write one sample to the specified channel in register.Available when Mode is AOMode.Single

Parameters
writeValue | Write value.
channel | Specified channel.

◆ WriteSinglePoint() [2/2]

void JYPCIe5111.JYPCIe5111AOTask.WriteSinglePoint ( double[] writeValues )

write one sample to all channels in register .

Available when Mode is AOMode.Single

Parameters
writeValues Write values. Array length >= Channels.Count.

Property Documentation

◆ AvaliableLenInSamples

uint JYPCIe5111.JYPCIe5111AOTask.AvaliableLenInSamples
get

Number of output samples per channel that can be write in AO buffuer.

◆ BufLenInSamples

int JYPCIe5111.JYPCIe5111AOTask.BufLenInSamples
get

Number of samples per channel can be storage in the buffer, the PropretySamplesToUpdate must be less than or equal to this value.

◆ Channels

List<AOChannel> JYPCIe5111.JYPCIe5111AOTask.Channels
get

List of AO channels,(5111 support 2 channels)

◆ CompleteState

OutputCompleteState JYPCIe5111.JYPCIe5111AOTask.CompleteState
getset

AO Output Complete State, Default is Hold.

◆ Device

JYPCIe5111Device JYPCIe5111.JYPCIe5111AOTask.Device
get

Device.

◆ DisableCalibration

bool JYPCIe5111.JYPCIe5111AOTask.DisableCalibration
getset

Disalble calibration.

◆ Mode

AOMode JYPCIe5111.JYPCIe5111AOTask.Mode
getset

Mode of AO Task.

Select AO Mode from enum:ContinuousNoWrapping/ContinuousWrapping/Finite/Single.

◆ SampleClock

AOSampleClock JYPCIe5111.JYPCIe5111AOTask.SampleClock
getset

AO Sample Clock Configuration .

◆ SamplesToUpdate

int JYPCIe5111.JYPCIe5111AOTask.SamplesToUpdate
getset

Number of output samples to write per channel , Only valid when Mode is AOMode.Finite.

◆ SignalExport

AOSignalExport JYPCIe5111.JYPCIe5111AOTask.SignalExport
getset

Export AO Signal.

◆ TransferedSamples

ulong JYPCIe5111.JYPCIe5111AOTask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT AOMode.Single.

◆ Trigger

AOTrigger JYPCIe5111.JYPCIe5111AOTask.Trigger = new AOTrigger()
getset

AO Trigger Configuration.

◆ UpdateRate

double JYPCIe5111.JYPCIe5111AOTask.UpdateRate
getset

Update rate per channel.

Maximum update rate is 1M. The defalut sample rate = 1000000 You can read this property to obtain the update rate that will actually take effect in the current configuration.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111AOTask.cs


5111 C# Programming Manual: JYPCIe5111.AOChannel Class Reference

  • AOChannel
Properties | List of all members
JYPCIe5111.AOChannel Class Referencesealed

AO Channel parameter class . More...

Properties

int | ChannelID [get]
AO channel ID.
double | RangeLow [get, set]
Low range limit an AO channel.
double | RangeHigh [get, set]
High range limit an AO channel.

Detailed Description

AO Channel parameter class .

Property Documentation

◆ ChannelID

int JYPCIe5111.AOChannel.ChannelID
get

AO channel ID.

◆ RangeHigh

double JYPCIe5111.AOChannel.RangeHigh
getset

High range limit an AO channel.

◆ RangeLow

double JYPCIe5111.AOChannel.RangeLow
getset

Low range limit an AO channel.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111AOTask.cs


5111 C# Programming Manual: JYPCIe5111.AOSampleClock Class Reference

  • AOSampleClock
Properties | List of all members
JYPCIe5111.AOSampleClock Class Reference

AO Sample clock configuration class. More...

Properties

AOSampleClockSource | Source [get, set]
Clock Source.
AOExternalSampleClock | External [get, set]
External Sample Clock Configuration,Valid when Source is AOSampleClockSource.External.

Detailed Description

AO Sample clock configuration class.

Property Documentation

◆ External

AOExternalSampleClock JYPCIe5111.AOSampleClock.External
getset

External Sample Clock Configuration,Valid when Source is AOSampleClockSource.External.

◆ Source

AOSampleClockSource JYPCIe5111.AOSampleClock.Source
getset

Clock Source.

enum Internal/External,The default value is AOSampleClockSource.Internal.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111AOTask.cs


5111 C# Programming Manual: JYPCIe5111.AOExternalSampleClock Class Reference

  • AOExternalSampleClock
Properties | List of all members
JYPCIe5111.AOExternalSampleClock Class Reference

External Sample Clock Configuration Class. More...

Properties

ClockTerminal | Terminal [get, set]
External Sample Clock Input Terminal.
double | ExpectedRate [get, set]
Expected External Sample Clock Rate.

Detailed Description

External Sample Clock Configuration Class.

Property Documentation

◆ ExpectedRate

double JYPCIe5111.AOExternalSampleClock.ExpectedRate
getset

Expected External Sample Clock Rate.

◆ Terminal

ClockTerminal JYPCIe5111.AOExternalSampleClock.Terminal
getset

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111AOTask.cs


5111 C# Programming Manual: JYPCIe5111.AOTrigger Class Reference

  • AOTrigger
Properties | List of all members
JYPCIe5111.AOTrigger Class Referencesealed

Constructor to create an AOTrigger task object. More...

Properties

AOTriggerType | Type [get, set]
AO trigger type.
AODigitalTrigger | Digital [get, set]
AO Digital Trigger.

Detailed Description

Constructor to create an AOTrigger task object.

Used to build AO Trigger

Property Documentation

◆ Digital

AODigitalTrigger JYPCIe5111.AOTrigger.Digital
getset

AO Digital Trigger.

Valid when Type is AOTriggerType.Digital.

◆ Type

AOTriggerType JYPCIe5111.AOTrigger.Type
getset

AO trigger type.

enum Immediate/Digital/Soft.The default value is AOTriggerType.Immediate.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111AOTask.cs


5111 C# Programming Manual: JYPCIe5111.AODigitalTrigger Class Reference

  • AODigitalTrigger
Properties | List of all members
JYPCIe5111.AODigitalTrigger Class Referencesealed

AO Digital trigger . More...

Properties

AODigitalTriggerSource | Source [get, set]
AO Digital Trigger source.
AODigitalTriggerEdge | Edge [get, set]
Digital Trigger edge，Rising/Falling.

Detailed Description

AO Digital trigger .

Property Documentation

◆ Edge

AODigitalTriggerEdge JYPCIe5111.AODigitalTrigger.Edge
getset

Digital Trigger edge，Rising/Falling.

◆ Source

AODigitalTriggerSource JYPCIe5111.AODigitalTrigger.Source
getset

AO Digital Trigger source.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111AOTask.cs


5111 C# Programming Manual: JYPCIe5111.AOSignalExport Class Reference

  • AOSignalExport
Public Member Functions | List of all members
JYPCIe5111.AOSignalExport Class Reference

AO Signal Export Class. More...

Public Member Functions

void | Add (AOSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (AOSignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

AO Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JYPCIe5111.AOSignalExport.Add | ( | AOSignalExportSource | source,
 |  | List< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | AO Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JYPCIe5111.AOSignalExport.Add | ( | AOSignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | AO Signal Source
destination | Export Desination

◆ Clear()

void JYPCIe5111.AOSignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JYPCIe5111.AOSignalExport.ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111AOTask.cs


5111 C# Programming Manual: D:/5111/C#/JYPCIe5111CITask.cs File Reference

  • File List
  • 5111
  • C#
Classes | Namespaces | Enumerations
JYPCIe5111CITask.cs File Reference

Classes

class | JYPCIe5111.JYPCIe5111CITask
JYPCIe5111 Counter Input Task. More...
class | JYPCIe5111.CISampleClock
CI Sample Clock class. More...
class | JYPCIe5111.CIInternalSampleClock
CI Internal Sample Clock Configuration Class. More...
class | JYPCIe5111.CIImplicitSampleClock
CI Implicit Sample Clock class. More...
class | JYPCIe5111.CIExternalSampleClock
CI Implicit Sample Clock class. More...
class | JYPCIe5111.EdgeCounting
Configure CI EdgeCounting. More...
class | JYPCIe5111.FrequencyMeas
Configure CI Measure. More...
class | JYPCIe5111.PeriodMeas
Configure CI Measure. More...
class | JYPCIe5111.PulseMeas
Configure CI Measure. More...
class | JYPCIe5111.TwoEdgeSeparation
Configure CI Measure. More...
class | JYPCIe5111.QuadEncoder
Configure CI Measure. More...
class | JYPCIe5111.TwoPulseEncoder
Configure CI Measure. More...
class | JYPCIe5111.CITrigger
Constructor to create an CITrigger task object. More...
class | JYPCIe5111.CIDigitalTrigger
CI Digital trigger . More...
class | JYPCIe5111.EdgeCountingOutEvent
Edge counting output event configuration class. More...
class | JYPCIe5111.PauseTrigger
Pause trigger configuration class. More...
class | JYPCIe5111.CITimebase
Timebase configuration class. More...
class | JYPCIe5111.CISignalExport
CI Signal Export Class. More...

Namespaces

namespace JYPCIe5111

Enumerations

enum | JYPCIe5111.CountDirection { JYPCIe5111.Up = JYPCIe5111Import.JYPCIe5111_CI_Count_Up , JYPCIe5111.Down = JYPCIe5111Import.JYPCIe5111_CI_Count_Down , JYPCIe5111.External = JYPCIe5111Import.JYPCIe5111_CI_Count_External }
Counter direction. More...
enum | JYPCIe5111.CIMode { JYPCIe5111.Single = 2 , JYPCIe5111.Finite = 0 , JYPCIe5111.Continuous = 1 }
CIMode. More...
enum JYPCIe5111.CIType {
JYPCIe5111.EdgeCounting , JYPCIe5111.Period , JYPCIe5111.Frequency , JYPCIe5111.Pulse ,
JYPCIe5111.TwoEdgeSeparation , JYPCIe5111.QuadEncoder , JYPCIe5111.TwoPulseEncoder
}
Counter Input Application Type. More...
enum | JYPCIe5111.CISampleClockSource { JYPCIe5111.Implicit = JYPCIe5111Import.JYPCIe5111_CI_ImplicitClk , JYPCIe5111.Internal = JYPCIe5111Import.JYPCIe5111_CI_Internal , JYPCIe5111.External = JYPCIe5111Import.JYPCIe5111_CI_External }
CI Sample Clock Source. More...
enum JYPCIe5111.InputTerminal {
JYPCIe5111.Default = 0 , JYPCIe5111.PXI_Trig0 = 40 , JYPCIe5111.PXI_Trig1 = 41 , JYPCIe5111.PXI_Trig2 = 42 ,
JYPCIe5111.PXI_Trig3 = 43 , JYPCIe5111.PXI_Trig4 = 44 , JYPCIe5111.PXI_Trig5 = 45 , JYPCIe5111.PXI_Trig6 = 46 ,
JYPCIe5111.PXI_Trig7 = 47 , JYPCIe5111.CI_0_OutPut = JYPCIe5111Import.JYPCIe5111_CO_0_Output , JYPCIe5111.CI_1_OutPut = JYPCIe5111Import.JYPCIe5111_CO_1_Output , JYPCIe5111.CI_2_OutPut = JYPCIe5111Import.JYPCIe5111_CO_2_Output ,
JYPCIe5111.CI_3_OutPut = JYPCIe5111Import.JYPCIe5111_CO_3_Output
}
Cunter Input Terminal. More...
enum JYPCIe5111.IOTerminal {
JYPCIe5111.Default = 0 , JYPCIe5111.PXI_Trig0 = JYPCIe5111Import.JYPCIe5111_PXITrig0_OUT , JYPCIe5111.PXI_Trig1 = JYPCIe5111Import.JYPCIe5111_PXITrig1_OUT , JYPCIe5111.PXI_Trig2 = JYPCIe5111Import.JYPCIe5111_PXITrig2_OUT ,
JYPCIe5111.PXI_Trig3 = JYPCIe5111Import.JYPCIe5111_PXITrig3_OUT , JYPCIe5111.PXI_Trig4 = JYPCIe5111Import.JYPCIe5111_PXITrig4_OUT , JYPCIe5111.PXI_Trig5 = JYPCIe5111Import.JYPCIe5111_PXITrig5_OUT , JYPCIe5111.PXI_Trig6 = JYPCIe5111Import.JYPCIe5111_PXITrig6_OUT ,
JYPCIe5111.PXI_Trig7 = JYPCIe5111Import.JYPCIe5111_PXITrig7_OUT , JYPCIe5111.None = 100
}
Cunter IO Terminal. More...
enum | JYPCIe5111.EdgeType { JYPCIe5111.Rising , JYPCIe5111.Falling }
Edge Type. More...
enum | JYPCIe5111.QuadEncodingType { JYPCIe5111.X1 , JYPCIe5111.X2 , JYPCIe5111.X4 }
Quadrature Encoding Type. More...
enum | JYPCIe5111.CITriggerType { JYPCIe5111.Immediate = JYPCIe5111Import.JYPCIe5111_TriggerType_Immediately , JYPCIe5111.Digital = JYPCIe5111Import.JYPCIe5111_TriggerType_Digital , JYPCIe5111.Soft = JYPCIe5111Import.JYPCIe5111_TriggerType_Soft }
TriggerType Digital/Immediate/Soft. More...
enum JYPCIe5111.CIDigitalTriggerSource {
JYPCIe5111.PFI0 , JYPCIe5111.PFI1 , JYPCIe5111.PFI2 , JYPCIe5111.PFI3 ,
JYPCIe5111.PFI4 , JYPCIe5111.PFI5 , JYPCIe5111.PFI6 , JYPCIe5111.PFI7 ,
JYPCIe5111.PFI8 , JYPCIe5111.PFI9 , JYPCIe5111.PFI10 , JYPCIe5111.PFI11 ,
JYPCIe5111.PFI12 , JYPCIe5111.PFI13 , JYPCIe5111.PFI14 , JYPCIe5111.PFI15 ,
JYPCIe5111.PXI_Trig0 = 40 , JYPCIe5111.PXI_Trig1 = 41 , JYPCIe5111.PXI_Trig2 = 42 , JYPCIe5111.PXI_Trig3 = 43 ,
JYPCIe5111.PXI_Trig4 = 44 , JYPCIe5111.PXI_Trig5 = 45 , JYPCIe5111.PXI_Trig6 = 46 , JYPCIe5111.PXI_Trig7 = 47 ,
JYPCIe5111.AI_StartTrig = JYPCIe5111Import.JYPCIe5111_AI_StartTrig , JYPCIe5111.AI_ReferenceTrig = JYPCIe5111Import.JYPCIe5111_AI_ReferenceTrig , JYPCIe5111.AO_StartTrig = JYPCIe5111Import.JYPCIe5111_AO_StartTrig , JYPCIe5111.DI_StartTrig = JYPCIe5111Import.JYPCIe5111_DI_StartTrig ,
JYPCIe5111.DI_ReferenceTrig = JYPCIe5111Import.JYPCIe5111_DI_ReferenceTrig , JYPCIe5111.DO_StartTrig = JYPCIe5111Import.JYPCIe5111_DO_StartTrig , JYPCIe5111.CI0_StartTrig = JYPCIe5111Import.JYPCIe5111_CI0_StartTrig , JYPCIe5111.CI1_StartTrig = JYPCIe5111Import.JYPCIe5111_CI1_StartTrig
}
CI Digital trigger source. More...
enum | JYPCIe5111.CIDigitalTriggerEdge { JYPCIe5111.Rising , JYPCIe5111.Falling }
CI Digital Trigger Edge. More...
enum | JYPCIe5111.EdgeCntOunEvtIdleState { JYPCIe5111.LowLevel = 0 , JYPCIe5111.HighLevel = 1 }
Output idle state when the event has not occurred. More...
enum | JYPCIe5111.LevelPolarity { JYPCIe5111.LowLevel = 0 , JYPCIe5111.HighLevel = 1 , JYPCIe5111.None = 2 }
Level Polarity. More...
enum | JYPCIe5111.CISignalExportSource { JYPCIe5111.StartTrig , JYPCIe5111.SampleClock }
SourceSignal. More...
enum | JYPCIe5111.CITimebaseSource { JYPCIe5111.Internal200MHz }
Timebase source. More...


5111 C# Programming Manual: JYPCIe5111.JYPCIe5111CITask Class Reference

  • JYPCIe5111CITask
Public Member Functions | Properties | List of all members
JYPCIe5111.JYPCIe5111CITask Class Referencesealed

JYPCIe5111 Counter Input Task. More...

Public Member Functions

JYPCIe5111CITask (int slotNum, int channel)
Constructor.
JYPCIe5111CITask (string boardName, int channel)
Constructor.
void | Start ()
Start CI task .
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Stop ()
Stop CI task .
void | ReadSinglePoint (ref uint count)
Read a signle count value from register, Available when Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder
void | ReadData (ref uint[] bufCount, int samplesToAcquire, int timeout=10000)
Read counter values from buffer.
void | ReadData (ref uint[] bufCount, int timeout=10000)
Read counter values from buffer.
void | ReadData (ref double[] bufMeasurement, int samplesToAcquire, int timeout=10000)
Read frequency value or period value from buffer.
void | ReadData (ref double[] bufMeasurement, int timeout=10000)
Read frequency value or period value from buffer.
void | ReadSinglePoint (ref double measurement, int timeout=10000)
Read a signle frequency value or period value from register.
void | ReadSinglePoint (ref double measurement1, ref double measurement2, int timeout=10000)
Read a signle measurement of pulse's duration value, or two-edge separtion value (two results at a time) from register.
void | ReadData (ref double[] bufMeasurement1, ref double[] bufMeasurement2, int samplesToAcquire, int timeout=10000)
Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.
void | ReadData (ref double[] bufMeasurement1, ref double[] bufMeasurement2, int timeout=10000)
Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.

Properties

CIType | Type [get, set]
CI Application types.
ulong | AvailableSamples [get]
Number of points per channel that can be read in the buffer .
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel).
CIMode | Mode [get, set]
CI Sampling mode，support Single/Finite/Continuous.
CISampleClock | SampleClock [get, set]
Clock Source.
uint | SamplesToAcquire [get, set]
Number of samples to be read per channel.Only valid when Mode is CIMode.Finite.
EdgeCounting | EdgeCounting [get, set]
Edge Counting Configuration.
FrequencyMeas | FrequencyMeas [get, set]
Frequency Measurement Configuration.
PeriodMeas | PeriodMeas [get, set]
Period Measurement Configuration.
PulseMeas | PulseMeas [get, set]
Pulse Measurement Configuration.
TwoEdgeSeparation | TwoEdgeSeparation [get, set]
TwoEdgeSeparation.
QuadEncoder | QuadEncoder [get, set]
QuadEncoder.
TwoPulseEncoder | TwoPulseEncoder [get, set]
TwoPulseEncoder.
CITrigger | Trigger = new CITrigger() [get, set]
CI Trigger Configuration.
CISignalExport | SignalExport [get, set]
Export CI Signal Configuration.
JYPCIe5111Device | Device [get]
Device.

Detailed Description

JYPCIe5111 Counter Input Task.

Constructor & Destructor Documentation

◆ JYPCIe5111CITask() [1/2]

JYPCIe5111.JYPCIe5111CITask.JYPCIe5111CITask | ( | int | slotNum,
 |  | int | channel )

Constructor.

Used to create an CI task by a slot number.

Parameters
slotNum | Card slot number.
channel | Counter channel (5111 suppor0-1)

◆ JYPCIe5111CITask() [2/2]

JYPCIe5111.JYPCIe5111CITask.JYPCIe5111CITask | ( | string | boardName,
 |  | int | channel )

Constructor.

Used to create an CI task by a board name.

Parameters
boardName | Board name(device alias), set by device manager
channel | Counter channel (5111 suppor0-1).

Member Function Documentation

◆ ReadData() [1/6]

void JYPCIe5111.JYPCIe5111CITask.ReadData | ( | ref double[] | bufMeasurement,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read frequency value or period value from buffer.

Available when JYPCIe5111CITask.Mode is NOT CIMode.Single, and Type is CIType.Frequency or CIType.Period.

Parameters
bufMeasurement | Buffer for reading data. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period in seconds when Type is CIType.Period.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [2/6]

void JYPCIe5111.JYPCIe5111CITask.ReadData | ( | ref double[] | bufMeasurement,
 |  | int | timeout = 10000 )

Read frequency value or period value from buffer.

Available when JYPCIe5111CITask.Mode is NOT CIMode.Single, and Type is CIType.Frequency or CIType.Period.

Parameters
bufMeasurement | Buffer for reading data. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period in seconds when Type is CIType.Period.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [3/6]

void JYPCIe5111.JYPCIe5111CITask.ReadData | ( | ref double[] | bufMeasurement1,
 |  | ref double[] | bufMeasurement2,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.

. Available when JYPCIe5111CITask.Mode is NOT CIMode.Single, Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
bufMeasurement1 | Buffer for reading data. Indicates high level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
bufMeasurement2 | Buffer for reading data. Indicates low level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [4/6]

void JYPCIe5111.JYPCIe5111CITask.ReadData | ( | ref double[] | bufMeasurement1,
 |  | ref double[] | bufMeasurement2,
 |  | int | timeout = 10000 )

Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.

. Available when JYPCIe5111CITask.Mode is NOT CIMode.Single, Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
bufMeasurement1 | Buffer for reading data. Indicates high level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
bufMeasurement2 | Buffer for reading data. Indicates low level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [5/6]

void JYPCIe5111.JYPCIe5111CITask.ReadData | ( | ref uint[] | bufCount,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read counter values from buffer.

Available when JYPCIe5111CITask.Mode is NOT CIMode.Single, and Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder

Parameters
bufCount | Buffer for reading data.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [6/6]

void JYPCIe5111.JYPCIe5111CITask.ReadData | ( | ref uint[] | bufCount,
 |  | int | timeout = 10000 )

Read counter values from buffer.

Available when JYPCIe5111CITask.Mode is NOT CIMode.Single, and Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder

Parameters
bufCount | Buffer for reading data.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [1/3]

void JYPCIe5111.JYPCIe5111CITask.ReadSinglePoint | ( | ref double | measurement,
 |  | int | timeout = 10000 )

Read a signle frequency value or period value from register.

Valid when Type is CIType.Frequency or CIType.Period.

Parameters
measurement Measurement value. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period is seconds when Type is CIType.Period.
timeout
Timeout (ms). Wait until the measurement is completed or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [2/3]

void JYPCIe5111.JYPCIe5111CITask.ReadSinglePoint | ( | ref double | measurement1,
 |  | ref double | measurement2,
 |  | int | timeout = 10000 )

Read a signle measurement of pulse's duration value, or two-edge separtion value (two results at a time) from register.

Available when Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
measurement1 | Measurement Value 1. Indicates low level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
measurement2 | Measurement Value 2. Indicates high level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
timeout
Timeout (ms). Wait until the measurement is completed or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [3/3]

void JYPCIe5111.JYPCIe5111CITask.ReadSinglePoint ( ref uint count )

Read a signle count value from register, Available when Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder

Parameters
count counter value。

◆ SendSoftwareTrigger()

void JYPCIe5111.JYPCIe5111CITask.SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JYPCIe5111.JYPCIe5111CITask.Start ( )

Start CI task .

◆ Stop()

void JYPCIe5111.JYPCIe5111CITask.Stop ( )

Stop CI task .

Property Documentation

◆ AvailableSamples

ulong JYPCIe5111.JYPCIe5111CITask.AvailableSamples
get

Number of points per channel that can be read in the buffer .

◆ Device

JYPCIe5111Device JYPCIe5111.JYPCIe5111CITask.Device
get

Device.

◆ EdgeCounting

EdgeCounting JYPCIe5111.JYPCIe5111CITask.EdgeCounting
getset

Edge Counting Configuration.

◆ FrequencyMeas

FrequencyMeas JYPCIe5111.JYPCIe5111CITask.FrequencyMeas
getset

Frequency Measurement Configuration.

◆ Mode

CIMode JYPCIe5111.JYPCIe5111CITask.Mode
getset

CI Sampling mode，support Single/Finite/Continuous.

◆ PeriodMeas

PeriodMeas JYPCIe5111.JYPCIe5111CITask.PeriodMeas
getset

Period Measurement Configuration.

◆ PulseMeas

PulseMeas JYPCIe5111.JYPCIe5111CITask.PulseMeas
getset

Pulse Measurement Configuration.

◆ QuadEncoder

QuadEncoder JYPCIe5111.JYPCIe5111CITask.QuadEncoder
getset

QuadEncoder.

◆ SampleClock

CISampleClock JYPCIe5111.JYPCIe5111CITask.SampleClock
getset

Clock Source.

◆ SamplesToAcquire

uint JYPCIe5111.JYPCIe5111CITask.SamplesToAcquire
getset

Number of samples to be read per channel.Only valid when Mode is CIMode.Finite.

◆ SignalExport

CISignalExport JYPCIe5111.JYPCIe5111CITask.SignalExport
getset

Export CI Signal Configuration.

◆ TransferedSamples

ulong JYPCIe5111.JYPCIe5111CITask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT CIMode.Single.

◆ Trigger

CITrigger JYPCIe5111.JYPCIe5111CITask.Trigger = new CITrigger()
getset

CI Trigger Configuration.

◆ TwoEdgeSeparation

TwoEdgeSeparation JYPCIe5111.JYPCIe5111CITask.TwoEdgeSeparation
getset

TwoEdgeSeparation.

◆ TwoPulseEncoder

TwoPulseEncoder JYPCIe5111.JYPCIe5111CITask.TwoPulseEncoder
getset

TwoPulseEncoder.

◆ Type

CIType JYPCIe5111.JYPCIe5111CITask.Type
getset

CI Application types.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111CITask.cs


5111 C# Programming Manual: JYPCIe5111.CISampleClock Class Reference

  • CISampleClock
Properties | List of all members
JYPCIe5111.CISampleClock Class Reference

CI Sample Clock class. More...

Properties

CISampleClockSource | Source [get, set]
CI Sample Clock Source.
CIImplicitSampleClock | Implicit [get, set]
CI Implicit Sample Clock Configuration.
CIExternalSampleClock | External [get, set]
CI External Sample Clock Configuration.
CIInternalSampleClock | Internal [get]
Internal Sample Clock Configuration.

Detailed Description

CI Sample Clock class.

Property Documentation

◆ External

CIExternalSampleClock JYPCIe5111.CISampleClock.External
getset

CI External Sample Clock Configuration.

Valid when Source is CISampleClockSource.External.

◆ Implicit

CIImplicitSampleClock JYPCIe5111.CISampleClock.Implicit
getset

CI Implicit Sample Clock Configuration.

Valid when Source is CISampleClockSource.Implicit.

◆ Internal

CIInternalSampleClock JYPCIe5111.CISampleClock.Internal
get

Internal Sample Clock Configuration.

Valid when Source is CISampleClockSource.Internal.

◆ Source

CISampleClockSource JYPCIe5111.CISampleClock.Source
getset

CI Sample Clock Source.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111CITask.cs


5111 C# Programming Manual: JYPCIe5111.CIInternalSampleClock Class Reference

  • CIInternalSampleClock
Properties | List of all members
JYPCIe5111.CIInternalSampleClock Class Reference

CI Internal Sample Clock Configuration Class. More...

Properties

double Rate [get, set]
The rate of the internal sample clock (sample rate) which is generated by dividing the internal clock (200MHz).

Detailed Description

CI Internal Sample Clock Configuration Class.

Property Documentation

◆ Rate

double JYPCIe5111.CIInternalSampleClock.Rate
getset

The rate of the internal sample clock (sample rate) which is generated by dividing the internal clock (200MHz).

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111CITask.cs


5111 C# Programming Manual: JYPCIe5111.CIImplicitSampleClock Class Reference

  • CIImplicitSampleClock
Properties | List of all members
JYPCIe5111.CIImplicitSampleClock Class Reference

CI Implicit Sample Clock class. More...

Properties

double ExpectedRate [get, set]
Expected Rate of Implicit Sample Clock.

Detailed Description

CI Implicit Sample Clock class.

Property Documentation

◆ ExpectedRate

double JYPCIe5111.CIImplicitSampleClock.ExpectedRate
getset

Expected Rate of Implicit Sample Clock.

Filling this parameter accurately would helps the driver to set a proper DDR write frequency internally.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111CITask.cs


5111 C# Programming Manual: JYPCIe5111.CIExternalSampleClock Class Reference

  • CIExternalSampleClock
Properties | List of all members
JYPCIe5111.CIExternalSampleClock Class Reference

CI Implicit Sample Clock class. More...

Properties

ClockTerminal | Terminal [get, set]
External Sample Clock Input Terminal.
double | ExpectedRate [get, set]
Expected Rate of External Sample Clock.

Detailed Description

CI Implicit Sample Clock class.

Property Documentation

◆ ExpectedRate

double JYPCIe5111.CIExternalSampleClock.ExpectedRate
getset

Expected Rate of External Sample Clock.

Filling this parameter accurately would helps the driver to set a proper DDR write frequency internally.

◆ Terminal

ClockTerminal JYPCIe5111.CIExternalSampleClock.Terminal
getset

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111CITask.cs


5111 C# Programming Manual: JYPCIe5111.EdgeCounting Class Reference

  • EdgeCounting
Properties | List of all members
JYPCIe5111.EdgeCounting Class Referencesealed

Configure CI EdgeCounting. More...

Properties

int | InitialCount [get, set]
Initial Count.
CountDirection | Direction [get, set]
Counter direction.
EdgeType | ActiveEdge [get, set]
The avtive edge of the input signal, the counter will count up or down on this edge.
PauseTrigger | Pause [get, set]
Pause Trigger Configuration.
EdgeCountingOutEvent | OutEvent [get, set]
Edge counting output event.
InputTerminal | InputTerminal [get, set]
Input Terminal.
InputTerminal | DirTerminal [get, set]
Terminal of External Count Diretion Control.

Detailed Description

Configure CI EdgeCounting.

Property Documentation

◆ ActiveEdge

EdgeType JYPCIe5111.EdgeCounting.ActiveEdge
getset

The avtive edge of the input signal, the counter will count up or down on this edge.

◆ Direction

CountDirection JYPCIe5111.EdgeCounting.Direction
getset

Counter direction.

enum Up/Down/External

◆ DirTerminal

InputTerminal JYPCIe5111.EdgeCounting.DirTerminal
getset

Terminal of External Count Diretion Control.

Valid when Direction is CountDirection.External

◆ InitialCount

int JYPCIe5111.EdgeCounting.InitialCount
getset

Initial Count.

◆ InputTerminal

InputTerminal JYPCIe5111.EdgeCounting.InputTerminal
getset

Input Terminal.

◆ OutEvent

EdgeCountingOutEvent JYPCIe5111.EdgeCounting.OutEvent
getset

Edge counting output event.

A pulse will be generated when the count value reaches specified threshold

◆ Pause

PauseTrigger JYPCIe5111.EdgeCounting.Pause
getset

Pause Trigger Configuration.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111CITask.cs


5111 C# Programming Manual: JYPCIe5111.FrequencyMeas Class Reference

  • FrequencyMeas
Properties | List of all members
JYPCIe5111.FrequencyMeas Class Referencesealed

Configure CI Measure. More...

Properties

CITimebase | Timebase [get, set]
Timebase configuration.
InputTerminal | InputTerminal [get, set]
Input Terminal.

Detailed Description

Configure CI Measure.

Property Documentation

◆ InputTerminal

InputTerminal JYPCIe5111.FrequencyMeas.InputTerminal
getset

Input Terminal.

◆ Timebase

CITimebase JYPCIe5111.FrequencyMeas.Timebase
getset

Timebase configuration.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111CITask.cs


5111 C# Programming Manual: JYPCIe5111.PeriodMeas Class Reference

  • PeriodMeas
Properties | List of all members
JYPCIe5111.PeriodMeas Class Referencesealed

Configure CI Measure. More...

Properties

CITimebase | Timebase [get, set]
Timebase configuration.
InputTerminal | InputTerminal [get, set]
Input Terminal.

Detailed Description

Configure CI Measure.

Property Documentation

◆ InputTerminal

InputTerminal JYPCIe5111.PeriodMeas.InputTerminal
getset

Input Terminal.

◆ Timebase

CITimebase JYPCIe5111.PeriodMeas.Timebase
getset

Timebase configuration.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111CITask.cs


5111 C# Programming Manual: JYPCIe5111.PulseMeas Class Reference

  • PulseMeas
Properties | List of all members
JYPCIe5111.PulseMeas Class Referencesealed

Configure CI Measure. More...

Properties

CITimebase | Timebase [get, set]
Timebase configuration.
InputTerminal | InputTerminal [get, set]
Input Terminal.

Detailed Description

Configure CI Measure.

Property Documentation

◆ InputTerminal

InputTerminal JYPCIe5111.PulseMeas.InputTerminal
getset

Input Terminal.

◆ Timebase

CITimebase JYPCIe5111.PulseMeas.Timebase
getset

Timebase configuration.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111CITask.cs


5111 C# Programming Manual: JYPCIe5111.TwoEdgeSeparation Class Reference

  • TwoEdgeSeparation
Properties | List of all members
JYPCIe5111.TwoEdgeSeparation Class Referencesealed

Configure CI Measure. More...

Properties

CITimebase | Timebase [get, set]
Timebase configuration.
InputTerminal | FirstInputTerminal [get, set]
Input Terminal.
InputTerminal | SecondInputTerminal [get, set]
Input Terminal.

Detailed Description

Configure CI Measure.

Property Documentation

◆ FirstInputTerminal

InputTerminal JYPCIe5111.TwoEdgeSeparation.FirstInputTerminal
getset

Input Terminal.

◆ SecondInputTerminal

InputTerminal JYPCIe5111.TwoEdgeSeparation.SecondInputTerminal
getset

Input Terminal.

◆ Timebase

CITimebase JYPCIe5111.TwoEdgeSeparation.Timebase
getset

Timebase configuration.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111CITask.cs


5111 C# Programming Manual: JYPCIe5111.QuadEncoder Class Reference

  • QuadEncoder
Properties | List of all members
JYPCIe5111.QuadEncoder Class Referencesealed

Configure CI Measure. More...

Properties

QuadEncodingType | EncodingType [get, set]
Type of Encoding.
bool | ZReloadEnabled [get, set]
In Encoder mode ,the Z signal enable.
int | InitialCount [get, set]
Initial Count.
InputTerminal | AInputTerminal [get, set]
Input Terminal.
InputTerminal | BInputTerminal [get, set]
Input Terminal.
InputTerminal | ZInputTerminal [get, set]
Input Terminal.

Detailed Description

Configure CI Measure.

Property Documentation

◆ AInputTerminal

InputTerminal JYPCIe5111.QuadEncoder.AInputTerminal
getset

Input Terminal.

◆ BInputTerminal

InputTerminal JYPCIe5111.QuadEncoder.BInputTerminal
getset

Input Terminal.

◆ EncodingType

QuadEncodingType JYPCIe5111.QuadEncoder.EncodingType
getset

Type of Encoding.

◆ InitialCount

int JYPCIe5111.QuadEncoder.InitialCount
getset

Initial Count.

◆ ZInputTerminal

InputTerminal JYPCIe5111.QuadEncoder.ZInputTerminal
getset

Input Terminal.

◆ ZReloadEnabled

bool JYPCIe5111.QuadEncoder.ZReloadEnabled
getset

In Encoder mode ,the Z signal enable.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111CITask.cs


5111 C# Programming Manual: JYPCIe5111.TwoPulseEncoder Class Reference

  • TwoPulseEncoder
Properties | List of all members
JYPCIe5111.TwoPulseEncoder Class Referencesealed

Configure CI Measure. More...

Properties

int | InitialCount [get, set]
Initial Count.
InputTerminal | AInputTerminal [get, set]
Input Terminal.
InputTerminal | BInputTerminal [get, set]
Input Terminal.

Detailed Description

Configure CI Measure.

Property Documentation

◆ AInputTerminal

InputTerminal JYPCIe5111.TwoPulseEncoder.AInputTerminal
getset

Input Terminal.

◆ BInputTerminal

InputTerminal JYPCIe5111.TwoPulseEncoder.BInputTerminal
getset

Input Terminal.

◆ InitialCount

int JYPCIe5111.TwoPulseEncoder.InitialCount
getset

Initial Count.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111CITask.cs


5111 C# Programming Manual: JYPCIe5111.CITrigger Class Reference

  • CITrigger
Properties | List of all members
JYPCIe5111.CITrigger Class Referencesealed

Constructor to create an CITrigger task object. More...

Properties

CITriggerType | Type [get, set]
CI trigger type.
CIDigitalTrigger | Digital [get, set]
CI Digital Trigger.

Detailed Description

Constructor to create an CITrigger task object.

Used to build CI Trigger

Property Documentation

◆ Digital

CIDigitalTrigger JYPCIe5111.CITrigger.Digital
getset

CI Digital Trigger.

Valid when Type is CITriggerType.Digital

◆ Type

CITriggerType JYPCIe5111.CITrigger.Type
getset

CI trigger type.

enum Immediate/Digital/Soft.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111CITask.cs


5111 C# Programming Manual: JYPCIe5111.CIDigitalTrigger Class Reference

  • CIDigitalTrigger
Properties | List of all members
JYPCIe5111.CIDigitalTrigger Class Referencesealed

CI Digital trigger . More...

Properties

CIDigitalTriggerSource | Source [get, set]
CI Digital Trigger source.
CIDigitalTriggerEdge | Edge [get, set]
Digital Trigger edge，Rising/Falling.

Detailed Description

CI Digital trigger .

Property Documentation

◆ Edge

CIDigitalTriggerEdge JYPCIe5111.CIDigitalTrigger.Edge
getset

Digital Trigger edge，Rising/Falling.

◆ Source

CIDigitalTriggerSource JYPCIe5111.CIDigitalTrigger.Source
getset

CI Digital Trigger source.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111CITask.cs


5111 C# Programming Manual: JYPCIe5111.EdgeCountingOutEvent Class Reference

  • EdgeCountingOutEvent
Properties | List of all members
JYPCIe5111.EdgeCountingOutEvent Class Reference

Edge counting output event configuration class. More...

Properties

EdgeCntOunEvtIdleState | IdleState [get, set]
Output idle state when the event has not occurred.
uint | Threshold [get, set]
Comparison threshold.
IOTerminal | Terminal [get, set]
Terminal.

Detailed Description

Edge counting output event configuration class.

Property Documentation

◆ IdleState

EdgeCntOunEvtIdleState JYPCIe5111.EdgeCountingOutEvent.IdleState
getset

Output idle state when the event has not occurred.

The default value is EdgeCntOunEvtIdleState.LowLevel

◆ Terminal

IOTerminal JYPCIe5111.EdgeCountingOutEvent.Terminal
getset

Terminal.

◆ Threshold

uint JYPCIe5111.EdgeCountingOutEvent.Threshold
getset

Comparison threshold.

The default value is 2^32-1

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111CITask.cs


5111 C# Programming Manual: JYPCIe5111.PauseTrigger Class Reference

  • PauseTrigger
Properties | List of all members
JYPCIe5111.PauseTrigger Class Referencesealed

Pause trigger configuration class. More...

Properties

LevelPolarity | ActivePolarity [get, set]
Pause trigger active polarity.
InputTerminal | Terminal [get, set]
Terminal.

Detailed Description

Pause trigger configuration class.

Property Documentation

◆ ActivePolarity

LevelPolarity JYPCIe5111.PauseTrigger.ActivePolarity
getset

Pause trigger active polarity.

The default value is LevelPolarity.None, means the pause trigger is disabled.

◆ Terminal

InputTerminal JYPCIe5111.PauseTrigger.Terminal
getset

Terminal.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111CITask.cs


5111 C# Programming Manual: JYPCIe5111.CITimebase Class Reference

  • CITimebase
Properties | List of all members
JYPCIe5111.CITimebase Class Referencesealed

Timebase configuration class. More...

Properties

CITimebaseSource Source [get, set]
Timebase Source.

Detailed Description

Timebase configuration class.

Property Documentation

◆ Source

CITimebaseSource JYPCIe5111.CITimebase.Source
getset

Timebase Source.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111CITask.cs


5111 C# Programming Manual: JYPCIe5111.CISignalExport Class Reference

  • CISignalExport
Public Member Functions | List of all members
JYPCIe5111.CISignalExport Class Reference

CI Signal Export Class. More...

Public Member Functions

void | Add (CISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (CISignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

CI Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JYPCIe5111.CISignalExport.Add | ( | CISignalExportSource | source,
 |  | List< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | CI Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JYPCIe5111.CISignalExport.Add | ( | CISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | CI Signal Source
destination | Export Desination

◆ Clear()

void JYPCIe5111.CISignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JYPCIe5111.CISignalExport.ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111CITask.cs


5111 C# Programming Manual: D:/5111/C#/JYPCIe5111COTask.cs File Reference

  • File List
  • 5111
  • C#
Classes | Namespaces | Enumerations
JYPCIe5111COTask.cs File Reference

Classes

class | JYPCIe5111.JYPCIe5111COTask
JYPCIe5111 Counter Output Task. More...
class | JYPCIe5111.COTrigger
Constructor to create an COTrigger task object. More...
class | JYPCIe5111.CODigitalTrigger
CO Digital trigger . More...
class | JYPCIe5111.COPulse
Pulse Parameter. More...
class | JYPCIe5111.COTimebase
Timebase configuration class. More...
class | JYPCIe5111.COSignalExport
CO Signal Export Class. More...

Namespaces

namespace JYPCIe5111

Enumerations

enum | JYPCIe5111.COIdleState { JYPCIe5111.HighLevel = JYPCIe5111Import.JYPCIe5111_CO_HighLevel , JYPCIe5111.LowLevel = JYPCIe5111Import.JYPCIe5111_CO_LowLevel }
Idle state when pulse output before start and after stop. More...
enum | JYPCIe5111.COMode { JYPCIe5111.Single = 3 , JYPCIe5111.Finite = 0 , JYPCIe5111.ContinuousNoWrapping = 2 , JYPCIe5111.ContinuousWrapping = 1 }
CO output mode. More...
enum | JYPCIe5111.COTriggerType { JYPCIe5111.Immediate = JYPCIe5111Import.JYPCIe5111_TriggerType_Immediately , JYPCIe5111.Digital = JYPCIe5111Import.JYPCIe5111_TriggerType_Digital , JYPCIe5111.Soft = JYPCIe5111Import.JYPCIe5111_TriggerType_Soft }
TriggerType Digital/Immediate/Soft. More...
enum JYPCIe5111.CODigitalTriggerSource {
JYPCIe5111.PFI0 , JYPCIe5111.PFI1 , JYPCIe5111.PFI2 , JYPCIe5111.PFI3 ,
JYPCIe5111.PFI4 , JYPCIe5111.PFI5 , JYPCIe5111.PFI6 , JYPCIe5111.PFI7 ,
JYPCIe5111.PFI8 , JYPCIe5111.PFI9 , JYPCIe5111.PFI10 , JYPCIe5111.PFI11 ,
JYPCIe5111.PFI12 , JYPCIe5111.PFI13 , JYPCIe5111.PFI14 , JYPCIe5111.PFI15 ,
JYPCIe5111.PXI_Trig0 = 40 , JYPCIe5111.PXI_Trig1 = 41 , JYPCIe5111.PXI_Trig2 = 42 , JYPCIe5111.PXI_Trig3 = 43 ,
JYPCIe5111.PXI_Trig4 = 44 , JYPCIe5111.PXI_Trig5 = 45 , JYPCIe5111.PXI_Trig6 = 46 , JYPCIe5111.PXI_Trig7 = 47 ,
JYPCIe5111.AI_StartTrig = JYPCIe5111Import.JYPCIe5111_AI_StartTrig , JYPCIe5111.AI_ReferenceTrig = JYPCIe5111Import.JYPCIe5111_AI_ReferenceTrig , JYPCIe5111.AO_StartTrig = JYPCIe5111Import.JYPCIe5111_AO_StartTrig , JYPCIe5111.DI_StartTrig = JYPCIe5111Import.JYPCIe5111_DI_StartTrig ,
JYPCIe5111.DI_ReferenceTrig = JYPCIe5111Import.JYPCIe5111_DI_ReferenceTrig , JYPCIe5111.DO_StartTrig = JYPCIe5111Import.JYPCIe5111_DO_StartTrig , JYPCIe5111.CI0_StartTrig = JYPCIe5111Import.JYPCIe5111_CI0_StartTrig , JYPCIe5111.CI1_StartTrig = JYPCIe5111Import.JYPCIe5111_CI1_StartTrig
}
CO Digital trigger source. More...
enum | JYPCIe5111.CODigitalTriggerEdge { JYPCIe5111.Rising , JYPCIe5111.Falling }
CO Digital Trigger Edge. More...
enum | JYPCIe5111.COPulseType { JYPCIe5111.DutyCycleFrequency , JYPCIe5111.HighLowTime , JYPCIe5111.HighLowTick }
Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick. More...
enum | JYPCIe5111.COTimebaseSource { JYPCIe5111.Internal200MHz }
Timebase source. More...
enum | JYPCIe5111.COSignalExportSource { JYPCIe5111.StartTrig , JYPCIe5111.Output }
SourceSignal. More...


5111 C# Programming Manual: JYPCIe5111.JYPCIe5111COTask Class Reference

  • JYPCIe5111COTask
Public Member Functions | Properties | List of all members
JYPCIe5111.JYPCIe5111COTask Class Referencesealed

JYPCIe5111 Counter Output Task. More...

Public Member Functions

JYPCIe5111COTask (int slotNum, int channel)
Constructor.
JYPCIe5111COTask (string boardName, int channel)
Constructor.
void | WriteSinglePoint (COPulse pulse)
Write a single pulse parameter to the register.
void | WriteData (COPulse[] pulsesGroup, int samplesToWrite, int timeout=10000)
Write pulse parameters to be output to the buffer.
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Start ()
Start CO task .
void | Stop ()
Stop COtask .
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.

Properties

COMode | Mode [get, set]
CO output mode.
IOTerminal | OutputTerminal [get, set]
Pulse Output Terminal.
PauseTrigger | Pause [get, set]
Pause Trigger Configuration.
COTimebase | TimeBase [get, set]
CO's time base.
double | InitialDelay [get, set]
Counter output initial delay in seconds.
COIdleState | IdleState [get, set]
Idle state when pulse output before start and after stop.
uint | SamplesToUpdate [get, set]
Number of output samples to write, Only valid when Mode is COMode.Finite.
uint | AvaliableLenInSamples [get]
Number of output samples per channel that can be write in buffuer.
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel).
uint | TransferedPulses [get]
The number of pulses transfered under the current configuration.
COTrigger | Trigger = new COTrigger() [get, set]
CO trigger property configured by CO Trigger().
COSignalExport | SignalExport [get, set]
Export CO Signal Configuration.
JYPCIe5111Device | Device [get]
Device.

Detailed Description

JYPCIe5111 Counter Output Task.

Constructor & Destructor Documentation

◆ JYPCIe5111COTask() [1/2]

JYPCIe5111.JYPCIe5111COTask.JYPCIe5111COTask | ( | int | slotNum,
 |  | int | channel )

Constructor.

Used to create an CO task by a slot number.

Parameters
slotNum | Card slot number.
channel | Counter channel (5111 suppor0-1).

◆ JYPCIe5111COTask() [2/2]

JYPCIe5111.JYPCIe5111COTask.JYPCIe5111COTask | ( | string | boardName,
 |  | int | channel )

Constructor.

Used to create an CO task by a board name.

Parameters
boardName | Board name(device alias), set by device manager
channel | Counter channel (5111 suppor0-1).

Member Function Documentation

◆ SendSoftwareTrigger()

void JYPCIe5111.JYPCIe5111COTask.SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JYPCIe5111.JYPCIe5111COTask.Start ( )

Start CO task .

◆ Stop()

void JYPCIe5111.JYPCIe5111COTask.Stop ( )

Stop COtask .

◆ WaitUntilDone()

bool JYPCIe5111.JYPCIe5111COTask.WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteData()

void JYPCIe5111.JYPCIe5111COTask.WriteData | ( | COPulse[] | pulsesGroup,
 |  | int | samplesToWrite,
 |  | int | timeout = 10000 )

Write pulse parameters to be output to the buffer.

Valid when Mode is NOT COMode.Single. When Mode is COMode.Finite or COMode.ContinuousWrapping, this function can only be called once before starting the task.

Parameters
pulsesGroup | A group of pulse parameters
samplesToWrite | Number of samples to write. If Mode is COMode.ContinuousWrapping, you need to write at least 2 samples before starting the task
timeout | Timeout (ms). Wait until all data is written to buffer or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ WriteSinglePoint()

void JYPCIe5111.JYPCIe5111COTask.WriteSinglePoint ( COPulse pulse )

Write a single pulse parameter to the register.

Valid when Mode is COMode.Single. This function is also available after starting the task when the number of pulses being sent is infinite.

Parameters
pulse Pulse Parameter

Property Documentation

◆ AvaliableLenInSamples

uint JYPCIe5111.JYPCIe5111COTask.AvaliableLenInSamples
get

Number of output samples per channel that can be write in buffuer.

◆ Device

JYPCIe5111Device JYPCIe5111.JYPCIe5111COTask.Device
get

Device.

◆ IdleState

COIdleState JYPCIe5111.JYPCIe5111COTask.IdleState
getset

Idle state when pulse output before start and after stop.

◆ InitialDelay

double JYPCIe5111.JYPCIe5111COTask.InitialDelay
getset

Counter output initial delay in seconds.

The minimum value is 3 ticks of the timebase.

◆ Mode

COMode JYPCIe5111.JYPCIe5111COTask.Mode
getset

CO output mode.

◆ OutputTerminal

IOTerminal JYPCIe5111.JYPCIe5111COTask.OutputTerminal
getset

Pulse Output Terminal.

◆ Pause

PauseTrigger JYPCIe5111.JYPCIe5111COTask.Pause
getset

Pause Trigger Configuration.

◆ SamplesToUpdate

uint JYPCIe5111.JYPCIe5111COTask.SamplesToUpdate
getset

Number of output samples to write, Only valid when Mode is COMode.Finite.

◆ SignalExport

COSignalExport JYPCIe5111.JYPCIe5111COTask.SignalExport
getset

Export CO Signal Configuration.

◆ TimeBase

COTimebase JYPCIe5111.JYPCIe5111COTask.TimeBase
getset

CO's time base.

◆ TransferedPulses

uint JYPCIe5111.JYPCIe5111COTask.TransferedPulses
get

The number of pulses transfered under the current configuration.

◆ TransferedSamples

ulong JYPCIe5111.JYPCIe5111COTask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT COMode.Single.

◆ Trigger

COTrigger JYPCIe5111.JYPCIe5111COTask.Trigger = new COTrigger()
getset

CO trigger property configured by CO Trigger().

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111COTask.cs


5111 C# Programming Manual: JYPCIe5111.COTrigger Class Reference

  • COTrigger
Properties | List of all members
JYPCIe5111.COTrigger Class Referencesealed

Constructor to create an COTrigger task object. More...

Properties

COTriggerType | Type [get, set]
CO trigger type.
CODigitalTrigger | Digital [get, set]
CO Digital Trigger.

Detailed Description

Constructor to create an COTrigger task object.

Used to build CO Trigger

Property Documentation

◆ Digital

CODigitalTrigger JYPCIe5111.COTrigger.Digital
getset

CO Digital Trigger.

Valid when Type is COTriggerType.Digital

◆ Type

COTriggerType JYPCIe5111.COTrigger.Type
getset

CO trigger type.

enum Immediate/Digital/Soft.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111COTask.cs


5111 C# Programming Manual: JYPCIe5111.CODigitalTrigger Class Reference

  • CODigitalTrigger
Properties | List of all members
JYPCIe5111.CODigitalTrigger Class Referencesealed

CO Digital trigger . More...

Properties

CODigitalTriggerSource | Source [get, set]
CO Digital Trigger source.
CODigitalTriggerEdge | Edge [get, set]
Digital Trigger edge，Rising/Falling.

Detailed Description

CO Digital trigger .

Property Documentation

◆ Edge

CODigitalTriggerEdge JYPCIe5111.CODigitalTrigger.Edge
getset

Digital Trigger edge，Rising/Falling.

◆ Source

CODigitalTriggerSource JYPCIe5111.CODigitalTrigger.Source
getset

CO Digital Trigger source.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111COTask.cs


5111 C# Programming Manual: JYPCIe5111.COPulse Class Reference

  • COPulse
Public Member Functions | List of all members
JYPCIe5111.COPulse Class Reference

Pulse Parameter. More...

Public Member Functions

COPulse (COPulseType type, double param1, double param2, int count)
Pulse Parameter.

Detailed Description

Pulse Parameter.

Constructor & Destructor Documentation

◆ COPulse()

JYPCIe5111.COPulse.COPulse | ( | COPulseType | type,
 |  | double | param1,
 |  | double | param2,
 |  | int | count )

Pulse Parameter.

Parameters
type | The pulse type characteristics.
param1 | Parameter 1. Frequency (Hz) when constructed as COPulseType.DutyCycleFrequency; High duration in seconds when constructed as COPulseType.HighLowTime; High ticks of the clock when constructed as COPulseType.HighLowTick.
param2 | Parameter 1. Duty cycle (greater than 0 and less than 1) when constructed as COPulseType.DutyCycleFrequency; Low duration in seconds when constructed as COPulseType.HighLowTime; Low ticks of the clock when constructed as COPulseType.HighLowTick.
count | Number of pulses. When the value is -1 (indicating that the number of pulses is infinite), pulses will be continuously sent until requested to stop.
The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111COTask.cs


5111 C# Programming Manual: JYPCIe5111.COTimebase Class Reference

  • COTimebase
Properties | List of all members
JYPCIe5111.COTimebase Class Referencesealed

Timebase configuration class. More...

Properties

COTimebaseSource Source [get, set]
Timebase Source.

Detailed Description

Timebase configuration class.

Property Documentation

◆ Source

COTimebaseSource JYPCIe5111.COTimebase.Source
getset

Timebase Source.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111COTask.cs


5111 C# Programming Manual: JYPCIe5111.COSignalExport Class Reference

  • COSignalExport
Public Member Functions | List of all members
JYPCIe5111.COSignalExport Class Reference

CO Signal Export Class. More...

Public Member Functions

void | Add (COSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (COSignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

CO Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JYPCIe5111.COSignalExport.Add | ( | COSignalExportSource | source,
 |  | List< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | CO Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JYPCIe5111.COSignalExport.Add | ( | COSignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | CO Signal Source
destination | Export Desination

◆ Clear()

void JYPCIe5111.COSignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JYPCIe5111.COSignalExport.ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111COTask.cs


5111 C# Programming Manual: D:/5111/C#/JYPCIe5111DITask.cs File Reference

  • File List
  • 5111
  • C#
Classes | Namespaces | Enumerations
JYPCIe5111DITask.cs File Reference

Classes

class | JYPCIe5111.JYPCIe5111DITask
JYPCIe5111 Digital Iuput Task. More...
class | JYPCIe5111.DIChannel
DI Channel parameter class . More...
class | JYPCIe5111.DISampleClock
Sample clock configuration class. More...
class | JYPCIe5111.DIExternalSampleClock
External Sample Clock Configuration Class. More...
class | JYPCIe5111.DISignalExport
DI Signal Export Class. More...
class | JYPCIe5111.DITrigger
Constructor to create an DITrigger task object. More...
class | JYPCIe5111.DIDigitalTrigger
DI Digital trigger . More...

Namespaces

namespace JYPCIe5111

Enumerations

enum | JYPCIe5111.DISampleClockSource { JYPCIe5111.Internal , JYPCIe5111.External }
DI Sample Clock Source. More...
enum | JYPCIe5111.DIMode { JYPCIe5111.Single = 2 , JYPCIe5111.Finite = 0 , JYPCIe5111.Continuous = 1 }
DIMode. More...
enum | JYPCIe5111.DISignalExportSource { JYPCIe5111.StartTrig = JYPCIe5111Import.JYPCIe5111_DI_StartTrig , JYPCIe5111.ReferenceTrig = JYPCIe5111Import.JYPCIe5111_DI_ReferenceTrig , JYPCIe5111.SampleClock = JYPCIe5111Import.JYPCIe5111_DI_SampleClock }
SourceSignal. More...
enum | JYPCIe5111.DITriggerMode { JYPCIe5111.Start , JYPCIe5111.Reference }
DI Trigger Mode. More...
enum | JYPCIe5111.DITriggerType { JYPCIe5111.Immediate = JYPCIe5111Import.JYPCIe5111_TriggerType_Immediately , JYPCIe5111.Digital = JYPCIe5111Import.JYPCIe5111_TriggerType_Digital , JYPCIe5111.Soft = JYPCIe5111Import.JYPCIe5111_TriggerType_Soft }
TriggerType Digital/Immediate/Soft. More...
enum JYPCIe5111.DIDigitalTriggerSource {
JYPCIe5111.PFI0 , JYPCIe5111.PFI1 , JYPCIe5111.PFI2 , JYPCIe5111.PFI3 ,
JYPCIe5111.PFI4 , JYPCIe5111.PFI5 , JYPCIe5111.PFI6 , JYPCIe5111.PFI7 ,
JYPCIe5111.PFI8 , JYPCIe5111.PFI9 , JYPCIe5111.PFI10 , JYPCIe5111.PFI11 ,
JYPCIe5111.PFI12 , JYPCIe5111.PFI13 , JYPCIe5111.PFI14 , JYPCIe5111.PFI15 ,
JYPCIe5111.PXI_Trig0 = 40 , JYPCIe5111.PXI_Trig1 = 41 , JYPCIe5111.PXI_Trig2 = 42 , JYPCIe5111.PXI_Trig3 = 43 ,
JYPCIe5111.PXI_Trig4 = 44 , JYPCIe5111.PXI_Trig5 = 45 , JYPCIe5111.PXI_Trig6 = 46 , JYPCIe5111.PXI_Trig7 = 47 ,
JYPCIe5111.AI_StartTrig = JYPCIe5111Import.JYPCIe5111_AI_StartTrig , JYPCIe5111.AI_ReferenceTrig = JYPCIe5111Import.JYPCIe5111_AI_ReferenceTrig , JYPCIe5111.AO_StartTrig = JYPCIe5111Import.JYPCIe5111_AO_StartTrig , JYPCIe5111.DO_StartTrig = JYPCIe5111Import.JYPCIe5111_DO_StartTrig ,
JYPCIe5111.CI0_StartTrig = JYPCIe5111Import.JYPCIe5111_CI0_StartTrig , JYPCIe5111.CI1_StartTrig = JYPCIe5111Import.JYPCIe5111_CI1_StartTrig
}
DI Digital trigger source. More...
enum | JYPCIe5111.DIDigitalTriggerEdge { JYPCIe5111.Rising , JYPCIe5111.Falling }
DI Digital Trigger Edge. More...


5111 C# Programming Manual: JYPCIe5111.JYPCIe5111DITask Class Reference

  • JYPCIe5111DITask
Public Member Functions | Properties | List of all members
JYPCIe5111.JYPCIe5111DITask Class Referencesealed

JYPCIe5111 Digital Iuput Task. More...

Public Member Functions

JYPCIe5111DITask (int slotNum)
Constructor.
JYPCIe5111DITask (string boardName)
Constructor.
void | AddChannel (int portNum)
Add one channel.
void | AddChannel (int[] portsNum)
Add a group of channel.
void | RemoveChannel (int portNum)
Delete the specified port number .If it is -1, delete all ports.
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Start ()
Start DI task .
void | Stop ()
Stop DI task .
void | ReadSinglePoint (ref bool[] readValues, int port)
Read one sample for specified channel in register.
void | ReadSinglePoint (ref bool[] readValues)
Read one sample for all ports in register .
void | ReadData (ref uint[] dataBuffer, uint samplesToAcquire, int timeOut=10000)
Read the uint data from one port or multi-ports.
void | ReadData (ref byte[] dataBuffer, uint samplesToAcquire, int timeOut=10000)
Read the byte data from one port.
void | ReadData (ref byte[,] dataBuffer, uint samplesToAcquire, int timeOut=10000)
Read the port byte data from the ports.

Properties

List< DIChannel > | Channels [get]
List of DI channels,(5111 support 3 ports)
DIMode | Mode [get, set]
DI acquisition mode，support Single/ Finite/Continuous.
double | SampleRate [get, set]
Sample rate per channel.
int | SamplesToAcquire [get, set]
Number of samples to be read per channel.
DISampleClock | SampleClock [get, set]
DI Sample Clock Configuration.
int | BufLenInSamples [get]
Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.
ulong | AvailableSamples [get]
Number of samples per channel that can be read in the buffer.
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel).
DITrigger | Trigger [get, set]
DI Trigger Configuration.
DISignalExport | SignalExport [get, set]
Export DI Signal.
JYPCIe5111Device | Device [get]
Device.

Detailed Description

JYPCIe5111 Digital Iuput Task.

Constructor & Destructor Documentation

◆ JYPCIe5111DITask() [1/2]

JYPCIe5111.JYPCIe5111DITask.JYPCIe5111DITask ( int slotNum )

Constructor.

Used to create an DItask by a slot number.

Parameters
slotNum Card slot number.

◆ JYPCIe5111DITask() [2/2]

JYPCIe5111.JYPCIe5111DITask.JYPCIe5111DITask ( string boardName )

Constructor.

Used to create an DI task by a board name.

Parameters
boardName Board name(device alias), set by device manager

Member Function Documentation

◆ AddChannel() [1/2]

void JYPCIe5111.JYPCIe5111DITask.AddChannel ( int portNum )

Add one channel.

Parameters
portNum port number to be added.

◆ AddChannel() [2/2]

void JYPCIe5111.JYPCIe5111DITask.AddChannel ( int[] portsNum )

Add a group of channel.

Parameters
portsNum an array of port numbers of added ports.

◆ ReadData() [1/3]

void JYPCIe5111.JYPCIe5111DITask.ReadData | ( | ref byte | dataBuffer[,],
 |  | uint | samplesToAcquire,
 |  | int | timeOut = 10000 )

Read the port byte data from the ports.

Each column represents one port.

Parameters
dataBuffer | Data buffer
samplesToAcquire | Number of samples per port to be read
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadData() [2/3]

void JYPCIe5111.JYPCIe5111DITask.ReadData | ( | ref byte[] | dataBuffer,
 |  | uint | samplesToAcquire,
 |  | int | timeOut = 10000 )

Read the byte data from one port.

Parameters
dataBuffer | Data buffer
samplesToAcquire | Number of samples per port to be read
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadData() [3/3]

void JYPCIe5111.JYPCIe5111DITask.ReadData | ( | ref uint[] | dataBuffer,
 |  | uint | samplesToAcquire,
 |  | int | timeOut = 10000 )

Read the uint data from one port or multi-ports.

Parameters
dataBuffer | Data buffer
samplesToAcquire | Number of samples per port to be read
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadSinglePoint() [1/2]

void JYPCIe5111.JYPCIe5111DITask.ReadSinglePoint ( ref bool[] readValues )

Read one sample for all ports in register .

Available when Mode is DIMode.Single

Parameters
readValues Values read. Buffer size >= number of ports * 8.

◆ ReadSinglePoint() [2/2]

void JYPCIe5111.JYPCIe5111DITask.ReadSinglePoint | ( | ref bool[] | readValues,
 |  | int | port )

Read one sample for specified channel in register.

. Available when Mode is DIMode.Single

Parameters
readValues | values read,. Buffer size >= 8
port | Specified port numbers.

◆ RemoveChannel()

void JYPCIe5111.JYPCIe5111DITask.RemoveChannel ( int portNum )

Delete the specified port number .If it is -1, delete all ports.

Parameters
portNum port number to be delete.

◆ SendSoftwareTrigger()

void JYPCIe5111.JYPCIe5111DITask.SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JYPCIe5111.JYPCIe5111DITask.Start ( )

Start DI task .

◆ Stop()

void JYPCIe5111.JYPCIe5111DITask.Stop ( )

Stop DI task .

Property Documentation

◆ AvailableSamples

ulong JYPCIe5111.JYPCIe5111DITask.AvailableSamples
get

Number of samples per channel that can be read in the buffer.

◆ BufLenInSamples

int JYPCIe5111.JYPCIe5111DITask.BufLenInSamples
get

Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.

◆ Channels

List<DIChannel> JYPCIe5111.JYPCIe5111DITask.Channels
get

List of DI channels,(5111 support 3 ports)

◆ Device

JYPCIe5111Device JYPCIe5111.JYPCIe5111DITask.Device
get

Device.

◆ Mode

DIMode JYPCIe5111.JYPCIe5111DITask.Mode
getset

DI acquisition mode，support Single/ Finite/Continuous.

◆ SampleClock

DISampleClock JYPCIe5111.JYPCIe5111DITask.SampleClock
getset

DI Sample Clock Configuration.

◆ SampleRate

double JYPCIe5111.JYPCIe5111DITask.SampleRate
getset

Sample rate per channel.

Maximum sample rate is 10M The defalut sample rate = 10k You can read this property to obtain the sample rate that will actually take effect in the current configuration.

◆ SamplesToAcquire

int JYPCIe5111.JYPCIe5111DITask.SamplesToAcquire
getset

Number of samples to be read per channel.

Only valid when Mode is DIMode.Finite.

◆ SignalExport

DISignalExport JYPCIe5111.JYPCIe5111DITask.SignalExport
getset

Export DI Signal.

◆ TransferedSamples

ulong JYPCIe5111.JYPCIe5111DITask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT DIMode.Single.

◆ Trigger

DITrigger JYPCIe5111.JYPCIe5111DITask.Trigger
getset

DI Trigger Configuration.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111DITask.cs


5111 C# Programming Manual: JYPCIe5111.DIChannel Class Reference

  • DIChannel
Properties | List of all members
JYPCIe5111.DIChannel Class Referencesealed

DI Channel parameter class . More...

Properties

int PortNum [get, set]
port number.

Detailed Description

DI Channel parameter class .

Property Documentation

◆ PortNum

int JYPCIe5111.DIChannel.PortNum
getset

port number.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111DITask.cs


5111 C# Programming Manual: JYPCIe5111.DISampleClock Class Reference

  • DISampleClock
Properties | List of all members
JYPCIe5111.DISampleClock Class Reference

Sample clock configuration class. More...

Properties

DISampleClockSource | Source [get, set]
Clock Source.
DIExternalSampleClock | External [get, set]
External Sample Clock, Valid when Source is DISampleClockSource.External.

Detailed Description

Sample clock configuration class.

Property Documentation

◆ External

DIExternalSampleClock JYPCIe5111.DISampleClock.External
getset

External Sample Clock, Valid when Source is DISampleClockSource.External.

◆ Source

DISampleClockSource JYPCIe5111.DISampleClock.Source
getset

Clock Source.

enum Internal/External

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111DITask.cs


5111 C# Programming Manual: JYPCIe5111.DIExternalSampleClock Class Reference

  • DIExternalSampleClock
Properties | List of all members
JYPCIe5111.DIExternalSampleClock Class Reference

External Sample Clock Configuration Class. More...

Properties

ClockTerminal | Terminal [get, set]
External Sample Clock Input Terminal.
double | ExpectedRate [get, set]
Expected External Sample Clock Rate.

Detailed Description

External Sample Clock Configuration Class.

Property Documentation

◆ ExpectedRate

double JYPCIe5111.DIExternalSampleClock.ExpectedRate
getset

Expected External Sample Clock Rate.

◆ Terminal

ClockTerminal JYPCIe5111.DIExternalSampleClock.Terminal
getset

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111DITask.cs


5111 C# Programming Manual: JYPCIe5111.DISignalExport Class Reference

  • DISignalExport
Public Member Functions | List of all members
JYPCIe5111.DISignalExport Class Reference

DI Signal Export Class. More...

Public Member Functions

void | Add (DISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (DISignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

DI Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JYPCIe5111.DISignalExport.Add | ( | DISignalExportSource | source,
 |  | List< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | DI Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JYPCIe5111.DISignalExport.Add | ( | DISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | DI Signal Source
destination | Export Desination

◆ Clear()

void JYPCIe5111.DISignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JYPCIe5111.DISignalExport.ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111DITask.cs


5111 C# Programming Manual: JYPCIe5111.DITrigger Class Reference

  • DITrigger
Properties | List of all members
JYPCIe5111.DITrigger Class Referencesealed

Constructor to create an DITrigger task object. More...

Properties

DITriggerType | Type [get, set]
DI trigger type.
DITriggerMode | Mode [get, set]
DI trigger mode.
DIDigitalTrigger | Digital [get, set]
DI Digital Trigger.Valid when Type is DITriggerType.Digital.
uint | PreTriggerSamples [get, set]
Pretrigger Samples, must be less than or equal to JYPCIe5111DITask.SamplesToAcquire.

Detailed Description

Constructor to create an DITrigger task object.

Used to build DI Trigger

Property Documentation

◆ Digital

DIDigitalTrigger JYPCIe5111.DITrigger.Digital
getset

DI Digital Trigger.Valid when Type is DITriggerType.Digital.

◆ Mode

DITriggerMode JYPCIe5111.DITrigger.Mode
getset

DI trigger mode.

enum Start/Reference.

◆ PreTriggerSamples

uint JYPCIe5111.DITrigger.PreTriggerSamples
getset

Pretrigger Samples, must be less than or equal to JYPCIe5111DITask.SamplesToAcquire.

Valid when Mode is DITriggerMode.Reference.

◆ Type

DITriggerType JYPCIe5111.DITrigger.Type
getset

DI trigger type.

enum Digital/Immediate/Soft.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111DITask.cs


5111 C# Programming Manual: JYPCIe5111.DIDigitalTrigger Class Reference

  • DIDigitalTrigger
Properties | List of all members
JYPCIe5111.DIDigitalTrigger Class Referencesealed

DI Digital trigger . More...

Properties

DIDigitalTriggerSource | Source [get, set]
DI Digital Trigger source.
DIDigitalTriggerEdge | Edge [get, set]
Digital Trigger edge，Rising/Falling.

Detailed Description

DI Digital trigger .

Property Documentation

◆ Edge

DIDigitalTriggerEdge JYPCIe5111.DIDigitalTrigger.Edge
getset

Digital Trigger edge，Rising/Falling.

◆ Source

DIDigitalTriggerSource JYPCIe5111.DIDigitalTrigger.Source
getset

DI Digital Trigger source.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111DITask.cs


5111 C# Programming Manual: D:/5111/C#/JYPCIe5111DOTask.cs File Reference

  • File List
  • 5111
  • C#
Classes | Namespaces | Enumerations
JYPCIe5111DOTask.cs File Reference

Classes

class | JYPCIe5111.JYPCIe5111DOTask
JYPCIe5111 Digital Output Task. More...
class | JYPCIe5111.DOChannel
DO Channel parameter class . More...
class | JYPCIe5111.DOSampleClock
Sample clock configuration class. More...
class | JYPCIe5111.DOExternalSampleClock
External Sample Clock Configuration Class. More...
class | JYPCIe5111.DOTrigger
Constructor to create an DOTrigger task object. More...
class | JYPCIe5111.DODigitalTrigger
DO Digital trigger. More...
class | JYPCIe5111.DOSignalExport
DO Signal Export Class. More...

Namespaces

namespace JYPCIe5111

Enumerations

enum | JYPCIe5111.DOSampleClockSource { JYPCIe5111.Internal , JYPCIe5111.External }
DO Sample Clock Source. More...
enum | JYPCIe5111.DOMode { JYPCIe5111.Single = 3 , JYPCIe5111.Finite = 0 , JYPCIe5111.ContinuousWrapping = 1 , JYPCIe5111.ContinuousNoWrapping = 2 }
DOMode. More...
enum | JYPCIe5111.DODigitalTriggerEdge { JYPCIe5111.Rising , JYPCIe5111.Falling }
DO Digital Trigger Edge. More...
enum JYPCIe5111.DODigitalTriggerSource {
JYPCIe5111.PFI0 , JYPCIe5111.PFI1 , JYPCIe5111.PFI2 , JYPCIe5111.PFI3 ,
JYPCIe5111.PFI4 , JYPCIe5111.PFI5 , JYPCIe5111.PFI6 , JYPCIe5111.PFI7 ,
JYPCIe5111.PFI8 , JYPCIe5111.PFI9 , JYPCIe5111.PFI10 , JYPCIe5111.PFI11 ,
JYPCIe5111.PFI12 , JYPCIe5111.PFI13 , JYPCIe5111.PFI14 , JYPCIe5111.PFI15 ,
JYPCIe5111.PXI_Trig0 = 40 , JYPCIe5111.PXI_Trig1 = 41 , JYPCIe5111.PXI_Trig2 = 42 , JYPCIe5111.PXI_Trig3 = 43 ,
JYPCIe5111.PXI_Trig4 = 44 , JYPCIe5111.PXI_Trig5 = 45 , JYPCIe5111.PXI_Trig6 = 46 , JYPCIe5111.PXI_Trig7 = 47 ,
JYPCIe5111.AI_StartTrig = JYPCIe5111Import.JYPCIe5111_AI_StartTrig , JYPCIe5111.AI_ReferenceTrig = JYPCIe5111Import.JYPCIe5111_AI_ReferenceTrig , JYPCIe5111.AO_StartTrig = JYPCIe5111Import.JYPCIe5111_AO_StartTrig , JYPCIe5111.DI_StartTrig = JYPCIe5111Import.JYPCIe5111_DI_StartTrig ,
JYPCIe5111.DI_ReferenceTrig = JYPCIe5111Import.JYPCIe5111_DI_ReferenceTrig , JYPCIe5111.CI0_StartTrig = JYPCIe5111Import.JYPCIe5111_CI0_StartTrig , JYPCIe5111.CI1_StartTrig = JYPCIe5111Import.JYPCIe5111_CI1_StartTrig
}
DO Digital trigger source. More...
enum | JYPCIe5111.DOTriggerType { JYPCIe5111.Immediate = JYPCIe5111Import.JYPCIe5111_TriggerType_Immediately , JYPCIe5111.Digital = JYPCIe5111Import.JYPCIe5111_TriggerType_Digital , JYPCIe5111.Soft = JYPCIe5111Import.JYPCIe5111_TriggerType_Soft }
TriggerType Digital/Immediate/Soft. More...
enum | JYPCIe5111.DOSignalExportSource { JYPCIe5111.StartTrig = JYPCIe5111Import.JYPCIe5111_DO_StartTrig , JYPCIe5111.SampleClock = JYPCIe5111Import.JYPCIe5111_DO_SampleClock }
SourceSignal. More...


5111 C# Programming Manual: JYPCIe5111.JYPCIe5111DOTask Class Reference

  • JYPCIe5111DOTask
Public Member Functions | Properties | List of all members
JYPCIe5111.JYPCIe5111DOTask Class Referencesealed

JYPCIe5111 Digital Output Task. More...

Public Member Functions

JYPCIe5111DOTask (int slotNum)
Constructor.
JYPCIe5111DOTask (string boardName)
Constructor.
void | AddChannel (int portNum)
Add one channel.
void | AddChannel (int[] portsNum)
Add a group of channels.
void | RemoveChannel (int portNum)
Delete the specified port number .If it is -1, delete all ports.
void | Start ()
Start DO task .
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Stop ()
Stop DO task .
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.
void | WriteSinglePoint (bool[] writeValues, int port)
Write one sample to the specified port in register.Available when Mode is DOMode.Single
void | WriteSinglePoint (bool[] writeValues)
write one sample to all ports in register .
void | ReadSinglePoint (ref bool[] readValues, int port)
Read one sample for specified channel in register.
void | ReadSinglePoint (ref bool[] readValues)
Read one sample for all ports in register .
void | WriteData (uint[] dataBuffer, uint samplesToUpdate, int timeOut=10000)
Write the uint data from one port or multi-ports.
void | WriteData (byte[] dataBuffer, uint samplesToUpdate, int timeOut=10000)
wirte the byte data to one port.
void | WriteData (byte[,] dataBuffer, uint samplesToUpdate, int timeOut=10000)
write the port byte data to the ports.

Properties

List< DOChannel > | Channels [get]
List of DO channels,(5111 support 3 ports)
DOMode | Mode [get, set]
DO acquisition mode.Select DO Mode from enum:ContinuousNoWrapping/ContinuousWrapping/Finite/Single.
double | UpdateRate [get, set]
Update rate per channel.
int | SamplesToUpdate [get, set]
Number of output samples to write per channel , Only valid when Mode is DOMode.Finite.
DOSampleClock | SampleClock [get, set]
DO Sample Clock Configuration .
int | BufLenInSamples [get]
Number of samples per channel can be storage in the buffer, the PropretySamplesToUpdate must be less than or equal to this value.
uint | AvaliableLenInSamples [get]
Number of output samples per channel avaliable to write in DO buffuer.
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel).
OutputCompleteState | CompleteState [get, set]
DO Output Complete State, Default is Hold.
DOTrigger | Trigger [get, set]
DO Trigger Configuration.
DOSignalExport | SignalExport [get, set]
Export DO Signal.
JYPCIe5111Device | Device [get]
Device.

Detailed Description

JYPCIe5111 Digital Output Task.

Constructor & Destructor Documentation

◆ JYPCIe5111DOTask() [1/2]

JYPCIe5111.JYPCIe5111DOTask.JYPCIe5111DOTask ( int slotNum )

Constructor.

Used to create an DOtask by a slot number.

Parameters
slotNum Card slot number.

◆ JYPCIe5111DOTask() [2/2]

JYPCIe5111.JYPCIe5111DOTask.JYPCIe5111DOTask ( string boardName )

Constructor.

Used to create an DO task by a board name.

Parameters
boardName Board name(device alias), set by device manager

Member Function Documentation

◆ AddChannel() [1/2]

void JYPCIe5111.JYPCIe5111DOTask.AddChannel ( int portNum )

Add one channel.

Parameters
portNum port number to be added.

◆ AddChannel() [2/2]

void JYPCIe5111.JYPCIe5111DOTask.AddChannel ( int[] portsNum )

Add a group of channels.

Parameters
portsNum an array of port numbers of added ports.

◆ ReadSinglePoint() [1/2]

void JYPCIe5111.JYPCIe5111DOTask.ReadSinglePoint ( ref bool[] readValues )

Read one sample for all ports in register .

Available when Mode is DOMode.Single

Parameters
readValues Values read. Buffer size >= number of ports * 8.

◆ ReadSinglePoint() [2/2]

void JYPCIe5111.JYPCIe5111DOTask.ReadSinglePoint | ( | ref bool[] | readValues,
 |  | int | port )

Read one sample for specified channel in register.

. Available when Mode is DOMode.Single

Parameters
readValues | values read,. Buffer size >= 8
port | Specified port numbers.

◆ RemoveChannel()

void JYPCIe5111.JYPCIe5111DOTask.RemoveChannel ( int portNum )

Delete the specified port number .If it is -1, delete all ports.

Parameters
portNum port number to be delete.

◆ SendSoftwareTrigger()

void JYPCIe5111.JYPCIe5111DOTask.SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JYPCIe5111.JYPCIe5111DOTask.Start ( )

Start DO task .

◆ Stop()

void JYPCIe5111.JYPCIe5111DOTask.Stop ( )

Stop DO task .

◆ WaitUntilDone()

bool JYPCIe5111.JYPCIe5111DOTask.WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Available when Mode is DOMode.Finite

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteData() [1/3]

void JYPCIe5111.JYPCIe5111DOTask.WriteData | ( | byte | dataBuffer[,],
 |  | uint | samplesToUpdate,
 |  | int | timeOut = 10000 )

write the port byte data to the ports.

Each column represents one port. Each port has 8 lines from 0 to 7. Each bit from low to high represents one line.

Parameters
dataBuffer | Data buffer
samplesToUpdate | Number of samples per port to be write
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [2/3]

void JYPCIe5111.JYPCIe5111DOTask.WriteData | ( | byte[] | dataBuffer,
 |  | uint | samplesToUpdate,
 |  | int | timeOut = 10000 )

wirte the byte data to one port.

Each port has 8 lines from 0 to 7. Each bit from low to high represents one line.

Parameters
dataBuffer | Data buffer
samplesToUpdate | Number of samples per port to be write
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [3/3]

void JYPCIe5111.JYPCIe5111DOTask.WriteData | ( | uint[] | dataBuffer,
 |  | uint | samplesToUpdate,
 |  | int | timeOut = 10000 )

Write the uint data from one port or multi-ports.

There are 4 ports, from 0 to 3. Each port has 8 lines, from 0 to 7. There are a total of 32 lines from 0 to 31. Each bit from low to high represents one line.

Parameters
dataBuffer | Data buffer
samplesToUpdate | Number of samples per port to be write
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteSinglePoint() [1/2]

void JYPCIe5111.JYPCIe5111DOTask.WriteSinglePoint ( bool[] writeValues )

write one sample to all ports in register .

Available when Mode is DOMode.Single

Parameters
writeValues Data to be written.Buffer size >= number of ports * 8。

◆ WriteSinglePoint() [2/2]

void JYPCIe5111.JYPCIe5111DOTask.WriteSinglePoint | ( | bool[] | writeValues,
 |  | int | port )

Write one sample to the specified port in register.Available when Mode is DOMode.Single

Parameters
writeValues | Write values..Buffer size >= 8
port | Specified port.

Property Documentation

◆ AvaliableLenInSamples

uint JYPCIe5111.JYPCIe5111DOTask.AvaliableLenInSamples
get

Number of output samples per channel avaliable to write in DO buffuer.

◆ BufLenInSamples

int JYPCIe5111.JYPCIe5111DOTask.BufLenInSamples
get

Number of samples per channel can be storage in the buffer, the PropretySamplesToUpdate must be less than or equal to this value.

◆ Channels

List<DOChannel> JYPCIe5111.JYPCIe5111DOTask.Channels
get

List of DO channels,(5111 support 3 ports)

◆ CompleteState

OutputCompleteState JYPCIe5111.JYPCIe5111DOTask.CompleteState
getset

DO Output Complete State, Default is Hold.

◆ Device

JYPCIe5111Device JYPCIe5111.JYPCIe5111DOTask.Device
get

Device.

◆ Mode

DOMode JYPCIe5111.JYPCIe5111DOTask.Mode
getset

DO acquisition mode.Select DO Mode from enum:ContinuousNoWrapping/ContinuousWrapping/Finite/Single.

◆ SampleClock

DOSampleClock JYPCIe5111.JYPCIe5111DOTask.SampleClock
getset

DO Sample Clock Configuration .

◆ SamplesToUpdate

int JYPCIe5111.JYPCIe5111DOTask.SamplesToUpdate
getset

Number of output samples to write per channel , Only valid when Mode is DOMode.Finite.

◆ SignalExport

DOSignalExport JYPCIe5111.JYPCIe5111DOTask.SignalExport
getset

Export DO Signal.

◆ TransferedSamples

ulong JYPCIe5111.JYPCIe5111DOTask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT DOMode.Single.

◆ Trigger

DOTrigger JYPCIe5111.JYPCIe5111DOTask.Trigger
getset

DO Trigger Configuration.

◆ UpdateRate

double JYPCIe5111.JYPCIe5111DOTask.UpdateRate
getset

Update rate per channel.

Maximum update rate is 10M . The defalut sample rate = 10000 You can read this property to obtain the update rate that will actually take effect in the current configuration.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111DOTask.cs


5111 C# Programming Manual: JYPCIe5111.DOChannel Class Reference

  • DOChannel
Properties | List of all members
JYPCIe5111.DOChannel Class Referencesealed

DO Channel parameter class . More...

Properties

int PortNum [get, set]
port number.

Detailed Description

DO Channel parameter class .

Property Documentation

◆ PortNum

int JYPCIe5111.DOChannel.PortNum
getset

port number.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111DOTask.cs


5111 C# Programming Manual: JYPCIe5111.DOSampleClock Class Reference

  • DOSampleClock
Properties | List of all members
JYPCIe5111.DOSampleClock Class Reference

Sample clock configuration class. More...

Properties

DOSampleClockSource | Source [get, set]
Clock Source.
DOExternalSampleClock | External [get, set]
External Sample Clock.Valid when Source is DOSampleClockSource.External.

Detailed Description

Sample clock configuration class.

Property Documentation

◆ External

DOExternalSampleClock JYPCIe5111.DOSampleClock.External
getset

External Sample Clock.Valid when Source is DOSampleClockSource.External.

◆ Source

DOSampleClockSource JYPCIe5111.DOSampleClock.Source
getset

Clock Source.

enum Internal/External

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111DOTask.cs


5111 C# Programming Manual: JYPCIe5111.DOExternalSampleClock Class Reference

  • DOExternalSampleClock
Properties | List of all members
JYPCIe5111.DOExternalSampleClock Class Reference

External Sample Clock Configuration Class. More...

Properties

ClockTerminal | Terminal [get, set]
External Sample Clock Input Terminal.
double | ExpectedRate [get, set]
Expected External Sample Clock Rate.

Detailed Description

External Sample Clock Configuration Class.

Property Documentation

◆ ExpectedRate

double JYPCIe5111.DOExternalSampleClock.ExpectedRate
getset

Expected External Sample Clock Rate.

◆ Terminal

ClockTerminal JYPCIe5111.DOExternalSampleClock.Terminal
getset

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111DOTask.cs


5111 C# Programming Manual: JYPCIe5111.DOTrigger Class Reference

  • DOTrigger
Properties | List of all members
JYPCIe5111.DOTrigger Class Referencesealed

Constructor to create an DOTrigger task object. More...

Properties

DOTriggerType | Type [get, set]
DO trigger type.
DODigitalTrigger | Digital [get, set]
DO Digital Trigger.Valid when Type is DOTriggerType.Digital.

Detailed Description

Constructor to create an DOTrigger task object.

Used to build DO Trigger

Property Documentation

◆ Digital

DODigitalTrigger JYPCIe5111.DOTrigger.Digital
getset

DO Digital Trigger.Valid when Type is DOTriggerType.Digital.

◆ Type

DOTriggerType JYPCIe5111.DOTrigger.Type
getset

DO trigger type.

enum Digital/Immediate/Soft.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111DOTask.cs


5111 C# Programming Manual: JYPCIe5111.DODigitalTrigger Class Reference

  • DODigitalTrigger
Properties | List of all members
JYPCIe5111.DODigitalTrigger Class Referencesealed

DO Digital trigger. More...

Properties

DODigitalTriggerSource | Source [get, set]
DO Digital Trigger source.
DODigitalTriggerEdge | Edge [get, set]
Digital Trigger edge，Rising/Falling.

Detailed Description

DO Digital trigger.

Property Documentation

◆ Edge

DODigitalTriggerEdge JYPCIe5111.DODigitalTrigger.Edge
getset

Digital Trigger edge，Rising/Falling.

◆ Source

DODigitalTriggerSource JYPCIe5111.DODigitalTrigger.Source
getset

DO Digital Trigger source.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111DOTask.cs


5111 C# Programming Manual: JYPCIe5111.DOSignalExport Class Reference

  • DOSignalExport
Public Member Functions | List of all members
JYPCIe5111.DOSignalExport Class Reference

DO Signal Export Class. More...

Public Member Functions

void | Add (DOSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (DOSignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

DO Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JYPCIe5111.DOSignalExport.Add | ( | DOSignalExportSource | source,
 |  | List< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | DO Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JYPCIe5111.DOSignalExport.Add | ( | DOSignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | DO Signal Source
destination | Export Desination

◆ Clear()

void JYPCIe5111.DOSignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JYPCIe5111.DOSignalExport.ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • D:/5111/C#/JYPCIe5111DOTask.cs


5111 C# Programming Manual: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
▼N JYPCIe5111 |
C AIAdvanced | AI Advance parameter
C AIAnalogEdgeComparator | AI Analog Edge Comparator
C AIAnalogHysteresisComparator | AI Analog Hysteresis Comparatorr
C AIAnalogTrigger | AI analog trigger
C AIAnalogWindowComparator | AI Analog Window Comparatorr
C AIChannel | AI Channel parameter class
C AIDigitalTrigger | AI Digital trigger class
C AIExternalSampleClock | External Sample Clock Configuration Class
C AIRecord | AI Record Parameters
C AISampleClock | Sample clock configuration class
C AISignalExport | AI Signal Export Class
C AITrigger | Constructor to create an AITrigger task object
C AOChannel | AO Channel parameter class
C AODigitalTrigger | AO Digital trigger
C AOExternalSampleClock | External Sample Clock Configuration Class
C AOSampleClock | AO Sample clock configuration class
C AOSignalExport | AO Signal Export Class
C AOTrigger | Constructor to create an AOTrigger task object
C CIDigitalTrigger | CI Digital trigger
C CIExternalSampleClock | CI Implicit Sample Clock class
C CIImplicitSampleClock | CI Implicit Sample Clock class
C CIInternalSampleClock | CI Internal Sample Clock Configuration Class
C CISampleClock | CI Sample Clock class
C CISignalExport | CI Signal Export Class
C CITimebase | Timebase configuration class
C CITrigger | Constructor to create an CITrigger task object
C CODigitalTrigger | CO Digital trigger
C COPulse | Pulse Parameter
C COSignalExport | CO Signal Export Class
C COTimebase | Timebase configuration class
C COTrigger | Constructor to create an COTrigger task object
C DIChannel | DI Channel parameter class
C DIDigitalTrigger | DI Digital trigger
C DIExternalSampleClock | External Sample Clock Configuration Class
C DISampleClock | Sample clock configuration class
C DISignalExport | DI Signal Export Class
C DITrigger | Constructor to create an DITrigger task object
C DOChannel | DO Channel parameter class
C DODigitalTrigger | DO Digital trigger
C DOExternalSampleClock | External Sample Clock Configuration Class
C DOSampleClock | Sample clock configuration class
C DOSignalExport | DO Signal Export Class
C DOTrigger | Constructor to create an DOTrigger task object
C EdgeCounting | Configure CI EdgeCounting
C EdgeCountingOutEvent | Edge counting output event configuration class
C FrequencyMeas | Configure CI Measure
C JYPCIe5111AITask | JYPCIe5111 Analog Input Task
C JYPCIe5111AOTask | JYPCIe5111 Analog Ouput Task
C JYPCIe5111CITask | JYPCIe5111 Counter Input Task
C JYPCIe5111COTask | JYPCIe5111 Counter Output Task
C JYPCIe5111DITask | JYPCIe5111 Digital Iuput Task
C JYPCIe5111DOTask | JYPCIe5111 Digital Output Task
C PauseTrigger | Pause trigger configuration class
C PeriodMeas | Configure CI Measure
C PulseMeas | Configure CI Measure
C QuadEncoder | Configure CI Measure
C TwoEdgeSeparation | Configure CI Measure
C TwoPulseEncoder | Configure CI Measure


5111 C# Programming Manual: Member List

  • AIAdvanced
JYPCIe5111.AIAdvanced Member List

This is the complete list of members for JYPCIe5111.AIAdvanced, including all inherited members.

ConvertRate JYPCIe5111.AIAdvanced


5111 C# Programming Manual: Member List

  • AIAnalogEdgeComparator
JYPCIe5111.AIAnalogEdgeComparator Member List

This is the complete list of members for JYPCIe5111.AIAnalogEdgeComparator, including all inherited members.

Slope | JYPCIe5111.AIAnalogEdgeComparator
Threshold | JYPCIe5111.AIAnalogEdgeComparator


5111 C# Programming Manual: Member List

  • AIAnalogHysteresisComparator
JYPCIe5111.AIAnalogHysteresisComparator Member List

This is the complete list of members for JYPCIe5111.AIAnalogHysteresisComparator, including all inherited members.

HighThreshold | JYPCIe5111.AIAnalogHysteresisComparator
LowThreshold | JYPCIe5111.AIAnalogHysteresisComparator
Slope | JYPCIe5111.AIAnalogHysteresisComparator


5111 C# Programming Manual: Member List

  • AIAnalogTrigger
JYPCIe5111.AIAnalogTrigger Member List

This is the complete list of members for JYPCIe5111.AIAnalogTrigger, including all inherited members.

Comparator | JYPCIe5111.AIAnalogTrigger
Edge | JYPCIe5111.AIAnalogTrigger
Hysteresis | JYPCIe5111.AIAnalogTrigger
Source | JYPCIe5111.AIAnalogTrigger
Window | JYPCIe5111.AIAnalogTrigger


5111 C# Programming Manual: Member List

  • AIAnalogWindowComparator
JYPCIe5111.AIAnalogWindowComparator Member List

This is the complete list of members for JYPCIe5111.AIAnalogWindowComparator, including all inherited members.

Condition | JYPCIe5111.AIAnalogWindowComparator
HighThreshold | JYPCIe5111.AIAnalogWindowComparator
LowThreshold | JYPCIe5111.AIAnalogWindowComparator


5111 C# Programming Manual: Member List

  • AIChannel
JYPCIe5111.AIChannel Member List

This is the complete list of members for JYPCIe5111.AIChannel, including all inherited members.

AIChannel(int channelId, double rangeLow, double rangeHigh, AITerminal terminalCfg=AITerminal.NRSE) | JYPCIe5111.AIChannel
ChannelID | JYPCIe5111.AIChannel
RangeHigh | JYPCIe5111.AIChannel
RangeLow | JYPCIe5111.AIChannel
Terminal | JYPCIe5111.AIChannel


5111 C# Programming Manual: Member List

  • AIDigitalTrigger
JYPCIe5111.AIDigitalTrigger Member List

This is the complete list of members for JYPCIe5111.AIDigitalTrigger, including all inherited members.

Edge | JYPCIe5111.AIDigitalTrigger
Source | JYPCIe5111.AIDigitalTrigger


5111 C# Programming Manual: Member List

  • AIExternalSampleClock
JYPCIe5111.AIExternalSampleClock Member List

This is the complete list of members for JYPCIe5111.AIExternalSampleClock, including all inherited members.

ExpectedRate | JYPCIe5111.AIExternalSampleClock
Terminal | JYPCIe5111.AIExternalSampleClock


5111 C# Programming Manual: Member List

  • AIRecord
JYPCIe5111.AIRecord Member List

This is the complete list of members for JYPCIe5111.AIRecord, including all inherited members.

FileFormat | JYPCIe5111.AIRecord
FilePath | JYPCIe5111.AIRecord
Length | JYPCIe5111.AIRecord
Mode | JYPCIe5111.AIRecord


5111 C# Programming Manual: Member List

  • AISampleClock
JYPCIe5111.AISampleClock Member List

This is the complete list of members for JYPCIe5111.AISampleClock, including all inherited members.

External | JYPCIe5111.AISampleClock
Source | JYPCIe5111.AISampleClock


5111 C# Programming Manual: Member List

  • AISignalExport
JYPCIe5111.AISignalExport Member List

This is the complete list of members for JYPCIe5111.AISignalExport, including all inherited members.

Add(AISignalExportSource source, SignalExportDestination destination) | JYPCIe5111.AISignalExport
Add(AISignalExportSource source, List< SignalExportDestination > destinations) | JYPCIe5111.AISignalExport
Clear(SignalExportDestination destination) | JYPCIe5111.AISignalExport
ClearAll() | JYPCIe5111.AISignalExport


5111 C# Programming Manual: Member List

  • AITrigger
JYPCIe5111.AITrigger Member List

This is the complete list of members for JYPCIe5111.AITrigger, including all inherited members.

Analog | JYPCIe5111.AITrigger
Digital | JYPCIe5111.AITrigger
Mode | JYPCIe5111.AITrigger
PreTriggerSamples | JYPCIe5111.AITrigger
ReTriggerCount | JYPCIe5111.AITrigger
Type | JYPCIe5111.AITrigger


5111 C# Programming Manual: Member List

  • AOChannel
JYPCIe5111.AOChannel Member List

This is the complete list of members for JYPCIe5111.AOChannel, including all inherited members.

ChannelID | JYPCIe5111.AOChannel
RangeHigh | JYPCIe5111.AOChannel
RangeLow | JYPCIe5111.AOChannel


5111 C# Programming Manual: Member List

  • AODigitalTrigger
JYPCIe5111.AODigitalTrigger Member List

This is the complete list of members for JYPCIe5111.AODigitalTrigger, including all inherited members.

Edge | JYPCIe5111.AODigitalTrigger
Source | JYPCIe5111.AODigitalTrigger


5111 C# Programming Manual: Member List

  • AOExternalSampleClock
JYPCIe5111.AOExternalSampleClock Member List

This is the complete list of members for JYPCIe5111.AOExternalSampleClock, including all inherited members.

ExpectedRate | JYPCIe5111.AOExternalSampleClock
Terminal | JYPCIe5111.AOExternalSampleClock


5111 C# Programming Manual: Member List

  • AOSampleClock
JYPCIe5111.AOSampleClock Member List

This is the complete list of members for JYPCIe5111.AOSampleClock, including all inherited members.

External | JYPCIe5111.AOSampleClock
Source | JYPCIe5111.AOSampleClock


5111 C# Programming Manual: Member List

  • AOSignalExport
JYPCIe5111.AOSignalExport Member List

This is the complete list of members for JYPCIe5111.AOSignalExport, including all inherited members.

Add(AOSignalExportSource source, SignalExportDestination destination) | JYPCIe5111.AOSignalExport
Add(AOSignalExportSource source, List< SignalExportDestination > destinations) | JYPCIe5111.AOSignalExport
Clear(SignalExportDestination destination) | JYPCIe5111.AOSignalExport
ClearAll() | JYPCIe5111.AOSignalExport


5111 C# Programming Manual: Member List

  • AOTrigger
JYPCIe5111.AOTrigger Member List

This is the complete list of members for JYPCIe5111.AOTrigger, including all inherited members.

Digital | JYPCIe5111.AOTrigger
Type | JYPCIe5111.AOTrigger


5111 C# Programming Manual: Member List

  • CIDigitalTrigger
JYPCIe5111.CIDigitalTrigger Member List

This is the complete list of members for JYPCIe5111.CIDigitalTrigger, including all inherited members.

Edge | JYPCIe5111.CIDigitalTrigger
Source | JYPCIe5111.CIDigitalTrigger


5111 C# Programming Manual: Member List

  • CIExternalSampleClock
JYPCIe5111.CIExternalSampleClock Member List

This is the complete list of members for JYPCIe5111.CIExternalSampleClock, including all inherited members.

ExpectedRate | JYPCIe5111.CIExternalSampleClock
Terminal | JYPCIe5111.CIExternalSampleClock


5111 C# Programming Manual: Member List

  • CIImplicitSampleClock
JYPCIe5111.CIImplicitSampleClock Member List

This is the complete list of members for JYPCIe5111.CIImplicitSampleClock, including all inherited members.

ExpectedRate JYPCIe5111.CIImplicitSampleClock


5111 C# Programming Manual: Member List

  • CIInternalSampleClock
JYPCIe5111.CIInternalSampleClock Member List

This is the complete list of members for JYPCIe5111.CIInternalSampleClock, including all inherited members.

Rate JYPCIe5111.CIInternalSampleClock


5111 C# Programming Manual: Member List

  • CISampleClock
JYPCIe5111.CISampleClock Member List

This is the complete list of members for JYPCIe5111.CISampleClock, including all inherited members.

External | JYPCIe5111.CISampleClock
Implicit | JYPCIe5111.CISampleClock
Internal | JYPCIe5111.CISampleClock
Source | JYPCIe5111.CISampleClock


5111 C# Programming Manual: Member List

  • CISignalExport
JYPCIe5111.CISignalExport Member List

This is the complete list of members for JYPCIe5111.CISignalExport, including all inherited members.

Add(CISignalExportSource source, SignalExportDestination destination) | JYPCIe5111.CISignalExport
Add(CISignalExportSource source, List< SignalExportDestination > destinations) | JYPCIe5111.CISignalExport
Clear(SignalExportDestination destination) | JYPCIe5111.CISignalExport
ClearAll() | JYPCIe5111.CISignalExport


5111 C# Programming Manual: Member List

  • CITimebase
JYPCIe5111.CITimebase Member List

This is the complete list of members for JYPCIe5111.CITimebase, including all inherited members.

Source JYPCIe5111.CITimebase


5111 C# Programming Manual: Member List

  • CITrigger
JYPCIe5111.CITrigger Member List

This is the complete list of members for JYPCIe5111.CITrigger, including all inherited members.

Digital | JYPCIe5111.CITrigger
Type | JYPCIe5111.CITrigger


5111 C# Programming Manual: Member List

  • CODigitalTrigger
JYPCIe5111.CODigitalTrigger Member List

This is the complete list of members for JYPCIe5111.CODigitalTrigger, including all inherited members.

Edge | JYPCIe5111.CODigitalTrigger
Source | JYPCIe5111.CODigitalTrigger


5111 C# Programming Manual: Member List

  • COPulse
JYPCIe5111.COPulse Member List

This is the complete list of members for JYPCIe5111.COPulse, including all inherited members.

COPulse(COPulseType type, double param1, double param2, int count) JYPCIe5111.COPulse


5111 C# Programming Manual: Member List

  • COSignalExport
JYPCIe5111.COSignalExport Member List

This is the complete list of members for JYPCIe5111.COSignalExport, including all inherited members.

Add(COSignalExportSource source, SignalExportDestination destination) | JYPCIe5111.COSignalExport
Add(COSignalExportSource source, List< SignalExportDestination > destinations) | JYPCIe5111.COSignalExport
Clear(SignalExportDestination destination) | JYPCIe5111.COSignalExport
ClearAll() | JYPCIe5111.COSignalExport


5111 C# Programming Manual: Member List

  • COTimebase
JYPCIe5111.COTimebase Member List

This is the complete list of members for JYPCIe5111.COTimebase, including all inherited members.

Source JYPCIe5111.COTimebase


5111 C# Programming Manual: Member List

  • COTrigger
JYPCIe5111.COTrigger Member List

This is the complete list of members for JYPCIe5111.COTrigger, including all inherited members.

Digital | JYPCIe5111.COTrigger
Type | JYPCIe5111.COTrigger


5111 C# Programming Manual: Member List

  • DIChannel
JYPCIe5111.DIChannel Member List

This is the complete list of members for JYPCIe5111.DIChannel, including all inherited members.

PortNum JYPCIe5111.DIChannel


5111 C# Programming Manual: Member List

  • DIDigitalTrigger
JYPCIe5111.DIDigitalTrigger Member List

This is the complete list of members for JYPCIe5111.DIDigitalTrigger, including all inherited members.

Edge | JYPCIe5111.DIDigitalTrigger
Source | JYPCIe5111.DIDigitalTrigger


5111 C# Programming Manual: Member List

  • DIExternalSampleClock
JYPCIe5111.DIExternalSampleClock Member List

This is the complete list of members for JYPCIe5111.DIExternalSampleClock, including all inherited members.

ExpectedRate | JYPCIe5111.DIExternalSampleClock
Terminal | JYPCIe5111.DIExternalSampleClock


5111 C# Programming Manual: Member List

  • DISampleClock
JYPCIe5111.DISampleClock Member List

This is the complete list of members for JYPCIe5111.DISampleClock, including all inherited members.

External | JYPCIe5111.DISampleClock
Source | JYPCIe5111.DISampleClock


5111 C# Programming Manual: Member List

  • DISignalExport
JYPCIe5111.DISignalExport Member List

This is the complete list of members for JYPCIe5111.DISignalExport, including all inherited members.

Add(DISignalExportSource source, SignalExportDestination destination) | JYPCIe5111.DISignalExport
Add(DISignalExportSource source, List< SignalExportDestination > destinations) | JYPCIe5111.DISignalExport
Clear(SignalExportDestination destination) | JYPCIe5111.DISignalExport
ClearAll() | JYPCIe5111.DISignalExport


5111 C# Programming Manual: Member List

  • DITrigger
JYPCIe5111.DITrigger Member List

This is the complete list of members for JYPCIe5111.DITrigger, including all inherited members.

Digital | JYPCIe5111.DITrigger
Mode | JYPCIe5111.DITrigger
PreTriggerSamples | JYPCIe5111.DITrigger
Type | JYPCIe5111.DITrigger


5111 C# Programming Manual: Member List

  • DOChannel
JYPCIe5111.DOChannel Member List

This is the complete list of members for JYPCIe5111.DOChannel, including all inherited members.

PortNum JYPCIe5111.DOChannel


5111 C# Programming Manual: Member List

  • DODigitalTrigger
JYPCIe5111.DODigitalTrigger Member List

This is the complete list of members for JYPCIe5111.DODigitalTrigger, including all inherited members.

Edge | JYPCIe5111.DODigitalTrigger
Source | JYPCIe5111.DODigitalTrigger


5111 C# Programming Manual: Member List

  • DOExternalSampleClock
JYPCIe5111.DOExternalSampleClock Member List

This is the complete list of members for JYPCIe5111.DOExternalSampleClock, including all inherited members.

ExpectedRate | JYPCIe5111.DOExternalSampleClock
Terminal | JYPCIe5111.DOExternalSampleClock


5111 C# Programming Manual: Member List

  • DOSampleClock
JYPCIe5111.DOSampleClock Member List

This is the complete list of members for JYPCIe5111.DOSampleClock, including all inherited members.

External | JYPCIe5111.DOSampleClock
Source | JYPCIe5111.DOSampleClock


5111 C# Programming Manual: Member List

  • DOSignalExport
JYPCIe5111.DOSignalExport Member List

This is the complete list of members for JYPCIe5111.DOSignalExport, including all inherited members.

Add(DOSignalExportSource source, SignalExportDestination destination) | JYPCIe5111.DOSignalExport
Add(DOSignalExportSource source, List< SignalExportDestination > destinations) | JYPCIe5111.DOSignalExport
Clear(SignalExportDestination destination) | JYPCIe5111.DOSignalExport
ClearAll() | JYPCIe5111.DOSignalExport


5111 C# Programming Manual: Member List

  • DOTrigger
JYPCIe5111.DOTrigger Member List

This is the complete list of members for JYPCIe5111.DOTrigger, including all inherited members.

Digital | JYPCIe5111.DOTrigger
Type | JYPCIe5111.DOTrigger


5111 C# Programming Manual: Member List

  • EdgeCounting
JYPCIe5111.EdgeCounting Member List

This is the complete list of members for JYPCIe5111.EdgeCounting, including all inherited members.

ActiveEdge | JYPCIe5111.EdgeCounting
Direction | JYPCIe5111.EdgeCounting
DirTerminal | JYPCIe5111.EdgeCounting
InitialCount | JYPCIe5111.EdgeCounting
InputTerminal | JYPCIe5111.EdgeCounting
OutEvent | JYPCIe5111.EdgeCounting
Pause | JYPCIe5111.EdgeCounting


5111 C# Programming Manual: Member List

  • EdgeCountingOutEvent
JYPCIe5111.EdgeCountingOutEvent Member List

This is the complete list of members for JYPCIe5111.EdgeCountingOutEvent, including all inherited members.

IdleState | JYPCIe5111.EdgeCountingOutEvent
Terminal | JYPCIe5111.EdgeCountingOutEvent
Threshold | JYPCIe5111.EdgeCountingOutEvent


5111 C# Programming Manual: Member List

  • FrequencyMeas
JYPCIe5111.FrequencyMeas Member List

This is the complete list of members for JYPCIe5111.FrequencyMeas, including all inherited members.

InputTerminal | JYPCIe5111.FrequencyMeas
Timebase | JYPCIe5111.FrequencyMeas


5111 C# Programming Manual: Member List

  • JYPCIe5111AITask
JYPCIe5111.JYPCIe5111AITask Member List

This is the complete list of members for JYPCIe5111.JYPCIe5111AITask, including all inherited members.

AddChannel(int chnId, double rangeLow=-10, double rangeHigh=10, AITerminal terminalCfg=AITerminal.RSE) | JYPCIe5111.JYPCIe5111AITask
AddChannel(int[] chnsId, double rangeLow=-10, double rangeHigh=10, AITerminal terminalCfg=AITerminal.RSE) | JYPCIe5111.JYPCIe5111AITask
AddChannel(int[] chnsId, double[] rangeLow, double[] rangeHigh, AITerminal terminalCfg=AITerminal.RSE) | JYPCIe5111.JYPCIe5111AITask
Advanced | JYPCIe5111.JYPCIe5111AITask
AvailableSamples | JYPCIe5111.JYPCIe5111AITask
BufLenInSamples | JYPCIe5111.JYPCIe5111AITask
Channels | JYPCIe5111.JYPCIe5111AITask
Device | JYPCIe5111.JYPCIe5111AITask
DisableCalibration | JYPCIe5111.JYPCIe5111AITask
GetRecordPreviewData(ref double[,] buf, int samplesPerChannel, int timeout) | JYPCIe5111.JYPCIe5111AITask
GetRecordPreviewData(ref double[,] buf, int timeout=-1) | JYPCIe5111.JYPCIe5111AITask
GetRecordPreviewData(ref double[] buf, int samplesPerChannel, int timeout) | JYPCIe5111.JYPCIe5111AITask
GetRecordPreviewData(ref double[] buf, int timeout=-1) | JYPCIe5111.JYPCIe5111AITask
GetRecordStatus(out double recordedLength, out bool recordDone) | JYPCIe5111.JYPCIe5111AITask
JYPCIe5111AITask(int slotNum) | JYPCIe5111.JYPCIe5111AITask
JYPCIe5111AITask(string boardName) | JYPCIe5111.JYPCIe5111AITask
Mode | JYPCIe5111.JYPCIe5111AITask
ReadData(IntPtr buf, int samplesPerChannel, int timeout) | JYPCIe5111.JYPCIe5111AITask
ReadData(ref double[,] buf, int samplesPerChannel, int timeout) | JYPCIe5111.JYPCIe5111AITask
ReadData(ref double[,] buf, int timeout=-1) | JYPCIe5111.JYPCIe5111AITask
ReadData(ref double[] buf, int samplesPerChannel, int timeout) | JYPCIe5111.JYPCIe5111AITask
ReadData(ref double[] buf, int timeout=-1) | JYPCIe5111.JYPCIe5111AITask
ReadRawData(IntPtr buf, int samplesPerChannel, int timeout) | JYPCIe5111.JYPCIe5111AITask
ReadRawData(ref int[,] buf, int samplesPerChannel, int timeout) | JYPCIe5111.JYPCIe5111AITask
ReadRawData(ref int[,] buf, int timeout=-1) | JYPCIe5111.JYPCIe5111AITask
ReadRawData(ref int[] buf, int samplesPerChannel, int timeout) | JYPCIe5111.JYPCIe5111AITask
ReadRawData(ref int[] buf, int timeout=-1) | JYPCIe5111.JYPCIe5111AITask
ReadRawSinglePoint(ref int[] readValues) | JYPCIe5111.JYPCIe5111AITask
ReadRawSinglePoint(ref int readValue, int channel) | JYPCIe5111.JYPCIe5111AITask
ReadSinglePoint(ref double[] readValues) | JYPCIe5111.JYPCIe5111AITask
ReadSinglePoint(ref double readValue, int channel) | JYPCIe5111.JYPCIe5111AITask
Record | JYPCIe5111.JYPCIe5111AITask
RemoveChannel(int chnId) | JYPCIe5111.JYPCIe5111AITask
SampleClock | JYPCIe5111.JYPCIe5111AITask
SampleRate | JYPCIe5111.JYPCIe5111AITask
SamplesToAcquire | JYPCIe5111.JYPCIe5111AITask
SendSoftwareTrigger() | JYPCIe5111.JYPCIe5111AITask
SignalExport | JYPCIe5111.JYPCIe5111AITask
Start() | JYPCIe5111.JYPCIe5111AITask
Stop() | JYPCIe5111.JYPCIe5111AITask
TransferedSamples | JYPCIe5111.JYPCIe5111AITask
Trigger | JYPCIe5111.JYPCIe5111AITask
WaitUntilDone(int timeout=-1) | JYPCIe5111.JYPCIe5111AITask


5111 C# Programming Manual: Member List

  • JYPCIe5111AOTask
JYPCIe5111.JYPCIe5111AOTask Member List

This is the complete list of members for JYPCIe5111.JYPCIe5111AOTask, including all inherited members.

AddChannel(int chnId, double rangeLow=-10, double rangeHigh=10) | JYPCIe5111.JYPCIe5111AOTask
AddChannel(int[] chnsId, double rangeLow=-10, double rangeHigh=10) | JYPCIe5111.JYPCIe5111AOTask
AddChannel(int[] chnsId, double[] rangeLow, double[] rangeHigh) | JYPCIe5111.JYPCIe5111AOTask
AvaliableLenInSamples | JYPCIe5111.JYPCIe5111AOTask
BufLenInSamples | JYPCIe5111.JYPCIe5111AOTask
Channels | JYPCIe5111.JYPCIe5111AOTask
CompleteState | JYPCIe5111.JYPCIe5111AOTask
Device | JYPCIe5111.JYPCIe5111AOTask
DisableCalibration | JYPCIe5111.JYPCIe5111AOTask
JYPCIe5111AOTask(int slotNum) | JYPCIe5111.JYPCIe5111AOTask
JYPCIe5111AOTask(string boardName) | JYPCIe5111.JYPCIe5111AOTask
Mode | JYPCIe5111.JYPCIe5111AOTask
RemoveChannel(int chnId) | JYPCIe5111.JYPCIe5111AOTask
SampleClock | JYPCIe5111.JYPCIe5111AOTask
SamplesToUpdate | JYPCIe5111.JYPCIe5111AOTask
SendSoftwareTrigger() | JYPCIe5111.JYPCIe5111AOTask
SignalExport | JYPCIe5111.JYPCIe5111AOTask
Start() | JYPCIe5111.JYPCIe5111AOTask
Stop() | JYPCIe5111.JYPCIe5111AOTask
TransferedSamples | JYPCIe5111.JYPCIe5111AOTask
Trigger | JYPCIe5111.JYPCIe5111AOTask
UpdateRate | JYPCIe5111.JYPCIe5111AOTask
WaitUntilDone(int timeout=-1) | JYPCIe5111.JYPCIe5111AOTask
WriteData(double[,] buf, int timeout=10000) | JYPCIe5111.JYPCIe5111AOTask
WriteData(IntPtr buf, int samplesPerChannel, int timeout=10000) | JYPCIe5111.JYPCIe5111AOTask
WriteData(double[] buf, int timeout=10000) | JYPCIe5111.JYPCIe5111AOTask
WriteRawData(short[,] buf, int timeout=10000) | JYPCIe5111.JYPCIe5111AOTask
WriteRawData(IntPtr buf, int samplesPerChannel, int timeout=10000) | JYPCIe5111.JYPCIe5111AOTask
WriteRawData(short[] buf, int timeout=10000) | JYPCIe5111.JYPCIe5111AOTask
WriteRawSinglePoint(short[] writeValues) | JYPCIe5111.JYPCIe5111AOTask
WriteRawSinglePoint(short writeValue, int channel) | JYPCIe5111.JYPCIe5111AOTask
WriteSinglePoint(double[] writeValues) | JYPCIe5111.JYPCIe5111AOTask
WriteSinglePoint(double writeValue, int channel) | JYPCIe5111.JYPCIe5111AOTask


5111 C# Programming Manual: Member List

  • JYPCIe5111CITask
JYPCIe5111.JYPCIe5111CITask Member List

This is the complete list of members for JYPCIe5111.JYPCIe5111CITask, including all inherited members.

AvailableSamples | JYPCIe5111.JYPCIe5111CITask
Device | JYPCIe5111.JYPCIe5111CITask
EdgeCounting | JYPCIe5111.JYPCIe5111CITask
FrequencyMeas | JYPCIe5111.JYPCIe5111CITask
JYPCIe5111CITask(int slotNum, int channel) | JYPCIe5111.JYPCIe5111CITask
JYPCIe5111CITask(string boardName, int channel) | JYPCIe5111.JYPCIe5111CITask
Mode | JYPCIe5111.JYPCIe5111CITask
PeriodMeas | JYPCIe5111.JYPCIe5111CITask
PulseMeas | JYPCIe5111.JYPCIe5111CITask
QuadEncoder | JYPCIe5111.JYPCIe5111CITask
ReadData(ref uint[] bufCount, int samplesToAcquire, int timeout=10000) | JYPCIe5111.JYPCIe5111CITask
ReadData(ref uint[] bufCount, int timeout=10000) | JYPCIe5111.JYPCIe5111CITask
ReadData(ref double[] bufMeasurement, int samplesToAcquire, int timeout=10000) | JYPCIe5111.JYPCIe5111CITask
ReadData(ref double[] bufMeasurement, int timeout=10000) | JYPCIe5111.JYPCIe5111CITask
ReadData(ref double[] bufMeasurement1, ref double[] bufMeasurement2, int samplesToAcquire, int timeout=10000) | JYPCIe5111.JYPCIe5111CITask
ReadData(ref double[] bufMeasurement1, ref double[] bufMeasurement2, int timeout=10000) | JYPCIe5111.JYPCIe5111CITask
ReadSinglePoint(ref uint count) | JYPCIe5111.JYPCIe5111CITask
ReadSinglePoint(ref double measurement, int timeout=10000) | JYPCIe5111.JYPCIe5111CITask
ReadSinglePoint(ref double measurement1, ref double measurement2, int timeout=10000) | JYPCIe5111.JYPCIe5111CITask
SampleClock | JYPCIe5111.JYPCIe5111CITask
SamplesToAcquire | JYPCIe5111.JYPCIe5111CITask
SendSoftwareTrigger() | JYPCIe5111.JYPCIe5111CITask
SignalExport | JYPCIe5111.JYPCIe5111CITask
Start() | JYPCIe5111.JYPCIe5111CITask
Stop() | JYPCIe5111.JYPCIe5111CITask
TransferedSamples | JYPCIe5111.JYPCIe5111CITask
Trigger | JYPCIe5111.JYPCIe5111CITask
TwoEdgeSeparation | JYPCIe5111.JYPCIe5111CITask
TwoPulseEncoder | JYPCIe5111.JYPCIe5111CITask
Type | JYPCIe5111.JYPCIe5111CITask


5111 C# Programming Manual: Member List

  • JYPCIe5111COTask
JYPCIe5111.JYPCIe5111COTask Member List

This is the complete list of members for JYPCIe5111.JYPCIe5111COTask, including all inherited members.

AvaliableLenInSamples | JYPCIe5111.JYPCIe5111COTask
Device | JYPCIe5111.JYPCIe5111COTask
IdleState | JYPCIe5111.JYPCIe5111COTask
InitialDelay | JYPCIe5111.JYPCIe5111COTask
JYPCIe5111COTask(int slotNum, int channel) | JYPCIe5111.JYPCIe5111COTask
JYPCIe5111COTask(string boardName, int channel) | JYPCIe5111.JYPCIe5111COTask
Mode | JYPCIe5111.JYPCIe5111COTask
OutputTerminal | JYPCIe5111.JYPCIe5111COTask
Pause | JYPCIe5111.JYPCIe5111COTask
SamplesToUpdate | JYPCIe5111.JYPCIe5111COTask
SendSoftwareTrigger() | JYPCIe5111.JYPCIe5111COTask
SignalExport | JYPCIe5111.JYPCIe5111COTask
Start() | JYPCIe5111.JYPCIe5111COTask
Stop() | JYPCIe5111.JYPCIe5111COTask
TimeBase | JYPCIe5111.JYPCIe5111COTask
TransferedPulses | JYPCIe5111.JYPCIe5111COTask
TransferedSamples | JYPCIe5111.JYPCIe5111COTask
Trigger | JYPCIe5111.JYPCIe5111COTask
WaitUntilDone(int timeout=-1) | JYPCIe5111.JYPCIe5111COTask
WriteData(COPulse[] pulsesGroup, int samplesToWrite, int timeout=10000) | JYPCIe5111.JYPCIe5111COTask
WriteSinglePoint(COPulse pulse) | JYPCIe5111.JYPCIe5111COTask


5111 C# Programming Manual: Member List

  • JYPCIe5111DITask
JYPCIe5111.JYPCIe5111DITask Member List

This is the complete list of members for JYPCIe5111.JYPCIe5111DITask, including all inherited members.

AddChannel(int portNum) | JYPCIe5111.JYPCIe5111DITask
AddChannel(int[] portsNum) | JYPCIe5111.JYPCIe5111DITask
AvailableSamples | JYPCIe5111.JYPCIe5111DITask
BufLenInSamples | JYPCIe5111.JYPCIe5111DITask
Channels | JYPCIe5111.JYPCIe5111DITask
Device | JYPCIe5111.JYPCIe5111DITask
JYPCIe5111DITask(int slotNum) | JYPCIe5111.JYPCIe5111DITask
JYPCIe5111DITask(string boardName) | JYPCIe5111.JYPCIe5111DITask
Mode | JYPCIe5111.JYPCIe5111DITask
ReadData(ref uint[] dataBuffer, uint samplesToAcquire, int timeOut=10000) | JYPCIe5111.JYPCIe5111DITask
ReadData(ref byte[] dataBuffer, uint samplesToAcquire, int timeOut=10000) | JYPCIe5111.JYPCIe5111DITask
ReadData(ref byte[,] dataBuffer, uint samplesToAcquire, int timeOut=10000) | JYPCIe5111.JYPCIe5111DITask
ReadSinglePoint(ref bool[] readValues, int port) | JYPCIe5111.JYPCIe5111DITask
ReadSinglePoint(ref bool[] readValues) | JYPCIe5111.JYPCIe5111DITask
RemoveChannel(int portNum) | JYPCIe5111.JYPCIe5111DITask
SampleClock | JYPCIe5111.JYPCIe5111DITask
SampleRate | JYPCIe5111.JYPCIe5111DITask
SamplesToAcquire | JYPCIe5111.JYPCIe5111DITask
SendSoftwareTrigger() | JYPCIe5111.JYPCIe5111DITask
SignalExport | JYPCIe5111.JYPCIe5111DITask
Start() | JYPCIe5111.JYPCIe5111DITask
Stop() | JYPCIe5111.JYPCIe5111DITask
TransferedSamples | JYPCIe5111.JYPCIe5111DITask
Trigger | JYPCIe5111.JYPCIe5111DITask


5111 C# Programming Manual: Member List

  • JYPCIe5111DOTask
JYPCIe5111.JYPCIe5111DOTask Member List

This is the complete list of members for JYPCIe5111.JYPCIe5111DOTask, including all inherited members.

AddChannel(int portNum) | JYPCIe5111.JYPCIe5111DOTask
AddChannel(int[] portsNum) | JYPCIe5111.JYPCIe5111DOTask
AvaliableLenInSamples | JYPCIe5111.JYPCIe5111DOTask
BufLenInSamples | JYPCIe5111.JYPCIe5111DOTask
Channels | JYPCIe5111.JYPCIe5111DOTask
CompleteState | JYPCIe5111.JYPCIe5111DOTask
Device | JYPCIe5111.JYPCIe5111DOTask
JYPCIe5111DOTask(int slotNum) | JYPCIe5111.JYPCIe5111DOTask
JYPCIe5111DOTask(string boardName) | JYPCIe5111.JYPCIe5111DOTask
Mode | JYPCIe5111.JYPCIe5111DOTask
ReadSinglePoint(ref bool[] readValues, int port) | JYPCIe5111.JYPCIe5111DOTask
ReadSinglePoint(ref bool[] readValues) | JYPCIe5111.JYPCIe5111DOTask
RemoveChannel(int portNum) | JYPCIe5111.JYPCIe5111DOTask
SampleClock | JYPCIe5111.JYPCIe5111DOTask
SamplesToUpdate | JYPCIe5111.JYPCIe5111DOTask
SendSoftwareTrigger() | JYPCIe5111.JYPCIe5111DOTask
SignalExport | JYPCIe5111.JYPCIe5111DOTask
Start() | JYPCIe5111.JYPCIe5111DOTask
Stop() | JYPCIe5111.JYPCIe5111DOTask
TransferedSamples | JYPCIe5111.JYPCIe5111DOTask
Trigger | JYPCIe5111.JYPCIe5111DOTask
UpdateRate | JYPCIe5111.JYPCIe5111DOTask
WaitUntilDone(int timeout=-1) | JYPCIe5111.JYPCIe5111DOTask
WriteData(uint[] dataBuffer, uint samplesToUpdate, int timeOut=10000) | JYPCIe5111.JYPCIe5111DOTask
WriteData(byte[] dataBuffer, uint samplesToUpdate, int timeOut=10000) | JYPCIe5111.JYPCIe5111DOTask
WriteData(byte[,] dataBuffer, uint samplesToUpdate, int timeOut=10000) | JYPCIe5111.JYPCIe5111DOTask
WriteSinglePoint(bool[] writeValues, int port) | JYPCIe5111.JYPCIe5111DOTask
WriteSinglePoint(bool[] writeValues) | JYPCIe5111.JYPCIe5111DOTask


5111 C# Programming Manual: Member List

  • PauseTrigger
JYPCIe5111.PauseTrigger Member List

This is the complete list of members for JYPCIe5111.PauseTrigger, including all inherited members.

ActivePolarity | JYPCIe5111.PauseTrigger
Terminal | JYPCIe5111.PauseTrigger


5111 C# Programming Manual: Member List

  • PeriodMeas
JYPCIe5111.PeriodMeas Member List

This is the complete list of members for JYPCIe5111.PeriodMeas, including all inherited members.

InputTerminal | JYPCIe5111.PeriodMeas
Timebase | JYPCIe5111.PeriodMeas


5111 C# Programming Manual: Member List

  • PulseMeas
JYPCIe5111.PulseMeas Member List

This is the complete list of members for JYPCIe5111.PulseMeas, including all inherited members.

InputTerminal | JYPCIe5111.PulseMeas
Timebase | JYPCIe5111.PulseMeas


5111 C# Programming Manual: Member List

  • QuadEncoder
JYPCIe5111.QuadEncoder Member List

This is the complete list of members for JYPCIe5111.QuadEncoder, including all inherited members.

AInputTerminal | JYPCIe5111.QuadEncoder
BInputTerminal | JYPCIe5111.QuadEncoder
EncodingType | JYPCIe5111.QuadEncoder
InitialCount | JYPCIe5111.QuadEncoder
ZInputTerminal | JYPCIe5111.QuadEncoder
ZReloadEnabled | JYPCIe5111.QuadEncoder


5111 C# Programming Manual: Member List

  • TwoEdgeSeparation
JYPCIe5111.TwoEdgeSeparation Member List

This is the complete list of members for JYPCIe5111.TwoEdgeSeparation, including all inherited members.

FirstInputTerminal | JYPCIe5111.TwoEdgeSeparation
SecondInputTerminal | JYPCIe5111.TwoEdgeSeparation
Timebase | JYPCIe5111.TwoEdgeSeparation


5111 C# Programming Manual: Member List

  • TwoPulseEncoder
JYPCIe5111.TwoPulseEncoder Member List

This is the complete list of members for JYPCIe5111.TwoPulseEncoder, including all inherited members.

AInputTerminal | JYPCIe5111.TwoPulseEncoder
BInputTerminal | JYPCIe5111.TwoPulseEncoder
InitialCount | JYPCIe5111.TwoPulseEncoder


5111 C# Programming Manual: Class Index

Class Index
A | C | D | E | F | J | P | Q | T
A
AIAdvanced (JYPCIe5111)
AIAnalogEdgeComparator (JYPCIe5111)
AIAnalogHysteresisComparator (JYPCIe5111)
AIAnalogTrigger (JYPCIe5111)
AIAnalogWindowComparator (JYPCIe5111)
AIChannel (JYPCIe5111)
AIDigitalTrigger (JYPCIe5111)
AIExternalSampleClock (JYPCIe5111)
AIRecord (JYPCIe5111)
AISampleClock (JYPCIe5111)
AISignalExport (JYPCIe5111)
AITrigger (JYPCIe5111)
AOChannel (JYPCIe5111)
AODigitalTrigger (JYPCIe5111)
AOExternalSampleClock (JYPCIe5111)
AOSampleClock (JYPCIe5111)
AOSignalExport (JYPCIe5111)
AOTrigger (JYPCIe5111)
C
CIDigitalTrigger (JYPCIe5111)
CIExternalSampleClock (JYPCIe5111)
CIImplicitSampleClock (JYPCIe5111)
CIInternalSampleClock (JYPCIe5111)
CISampleClock (JYPCIe5111)
CISignalExport (JYPCIe5111)
CITimebase (JYPCIe5111)
CITrigger (JYPCIe5111)
CODigitalTrigger (JYPCIe5111)
COPulse (JYPCIe5111)
COSignalExport (JYPCIe5111)
COTimebase (JYPCIe5111)
COTrigger (JYPCIe5111)
D
DIChannel (JYPCIe5111)
DIDigitalTrigger (JYPCIe5111)
DIExternalSampleClock (JYPCIe5111)
DISampleClock (JYPCIe5111)
DISignalExport (JYPCIe5111)
DITrigger (JYPCIe5111)
DOChannel (JYPCIe5111)
DODigitalTrigger (JYPCIe5111)
DOExternalSampleClock (JYPCIe5111)
DOSampleClock (JYPCIe5111)
DOSignalExport (JYPCIe5111)
DOTrigger (JYPCIe5111)
E
EdgeCounting (JYPCIe5111)
EdgeCountingOutEvent (JYPCIe5111)
F
FrequencyMeas (JYPCIe5111)
J
JYPCIe5111AITask (JYPCIe5111)
JYPCIe5111AOTask (JYPCIe5111)
JYPCIe5111CITask (JYPCIe5111)
JYPCIe5111COTask (JYPCIe5111)
JYPCIe5111DITask (JYPCIe5111)
JYPCIe5111DOTask (JYPCIe5111)
P
PauseTrigger (JYPCIe5111)
PeriodMeas (JYPCIe5111)
PulseMeas (JYPCIe5111)
Q
QuadEncoder (JYPCIe5111)
T
TwoEdgeSeparation (JYPCIe5111)
TwoPulseEncoder (JYPCIe5111)


5111 C# Programming Manual: D:/5111 Directory Reference

  • File List
  • 5111
5111 Directory Reference

Directories

C#


5111 C# Programming Manual: File List

  • File List
File List
Here is a list of all files with brief descriptions:
[detail level 123]
▼ 5111
▼ C#
JYPCIe5111AITask.cs
JYPCIe5111AOTask.cs
JYPCIe5111CITask.cs
JYPCIe5111COTask.cs
JYPCIe5111DITask.cs
JYPCIe5111DOTask.cs


5111 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- a -

  • ActiveEdge : JYPCIe5111.EdgeCounting
  • ActivePolarity : JYPCIe5111.PauseTrigger
  • Add() : JYPCIe5111.AISignalExport, JYPCIe5111.AOSignalExport, JYPCIe5111.CISignalExport, JYPCIe5111.COSignalExport, JYPCIe5111.DISignalExport, JYPCIe5111.DOSignalExport
  • AddChannel() : JYPCIe5111.JYPCIe5111AITask, JYPCIe5111.JYPCIe5111AOTask, JYPCIe5111.JYPCIe5111DITask, JYPCIe5111.JYPCIe5111DOTask
  • Advanced : JYPCIe5111.JYPCIe5111AITask
  • AIChannel() : JYPCIe5111.AIChannel
  • AInputTerminal : JYPCIe5111.QuadEncoder, JYPCIe5111.TwoPulseEncoder
  • Analog : JYPCIe5111.AITrigger
  • AvailableSamples : JYPCIe5111.JYPCIe5111AITask, JYPCIe5111.JYPCIe5111CITask, JYPCIe5111.JYPCIe5111DITask
  • AvaliableLenInSamples : JYPCIe5111.JYPCIe5111AOTask, JYPCIe5111.JYPCIe5111COTask, JYPCIe5111.JYPCIe5111DOTask


5111 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- b -

  • BInputTerminal : JYPCIe5111.QuadEncoder, JYPCIe5111.TwoPulseEncoder
  • BufLenInSamples : JYPCIe5111.JYPCIe5111AITask, JYPCIe5111.JYPCIe5111AOTask, JYPCIe5111.JYPCIe5111DITask, JYPCIe5111.JYPCIe5111DOTask


5111 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- c -

  • ChannelID : JYPCIe5111.AIChannel, JYPCIe5111.AOChannel
  • Channels : JYPCIe5111.JYPCIe5111AITask, JYPCIe5111.JYPCIe5111AOTask, JYPCIe5111.JYPCIe5111DITask, JYPCIe5111.JYPCIe5111DOTask
  • Clear() : JYPCIe5111.AISignalExport, JYPCIe5111.AOSignalExport, JYPCIe5111.CISignalExport, JYPCIe5111.COSignalExport, JYPCIe5111.DISignalExport, JYPCIe5111.DOSignalExport
  • ClearAll() : JYPCIe5111.AISignalExport, JYPCIe5111.AOSignalExport, JYPCIe5111.CISignalExport, JYPCIe5111.COSignalExport, JYPCIe5111.DISignalExport, JYPCIe5111.DOSignalExport
  • Comparator : JYPCIe5111.AIAnalogTrigger
  • CompleteState : JYPCIe5111.JYPCIe5111AOTask, JYPCIe5111.JYPCIe5111DOTask
  • Condition : JYPCIe5111.AIAnalogWindowComparator
  • ConvertRate : JYPCIe5111.AIAdvanced
  • COPulse() : JYPCIe5111.COPulse


5111 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- d -

  • Device : JYPCIe5111.JYPCIe5111AITask, JYPCIe5111.JYPCIe5111AOTask, JYPCIe5111.JYPCIe5111CITask, JYPCIe5111.JYPCIe5111COTask, JYPCIe5111.JYPCIe5111DITask, JYPCIe5111.JYPCIe5111DOTask
  • Digital : JYPCIe5111.AITrigger, JYPCIe5111.AOTrigger, JYPCIe5111.CITrigger, JYPCIe5111.COTrigger, JYPCIe5111.DITrigger, JYPCIe5111.DOTrigger
  • Direction : JYPCIe5111.EdgeCounting
  • DirTerminal : JYPCIe5111.EdgeCounting
  • DisableCalibration : JYPCIe5111.JYPCIe5111AITask, JYPCIe5111.JYPCIe5111AOTask


5111 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- e -

  • Edge : JYPCIe5111.AIAnalogTrigger, JYPCIe5111.AIDigitalTrigger, JYPCIe5111.AODigitalTrigger, JYPCIe5111.CIDigitalTrigger, JYPCIe5111.CODigitalTrigger, JYPCIe5111.DIDigitalTrigger, JYPCIe5111.DODigitalTrigger
  • EdgeCounting : JYPCIe5111.JYPCIe5111CITask
  • EncodingType : JYPCIe5111.QuadEncoder
  • ExpectedRate : JYPCIe5111.AIExternalSampleClock, JYPCIe5111.AOExternalSampleClock, JYPCIe5111.CIExternalSampleClock, JYPCIe5111.CIImplicitSampleClock, JYPCIe5111.DIExternalSampleClock, JYPCIe5111.DOExternalSampleClock
  • External : JYPCIe5111.AISampleClock, JYPCIe5111.AOSampleClock, JYPCIe5111.CISampleClock, JYPCIe5111.DISampleClock, JYPCIe5111.DOSampleClock


5111 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- f -

  • FileFormat : JYPCIe5111.AIRecord
  • FilePath : JYPCIe5111.AIRecord
  • FirstInputTerminal : JYPCIe5111.TwoEdgeSeparation
  • FrequencyMeas : JYPCIe5111.JYPCIe5111CITask


5111 C# Programming Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • Properties
  • a
  • c
  • g
  • j
  • r
  • s
  • w
Here is a list of all functions with links to the classes they belong to:

- a -

  • Add() : JYPCIe5111.AISignalExport, JYPCIe5111.AOSignalExport, JYPCIe5111.CISignalExport, JYPCIe5111.COSignalExport, JYPCIe5111.DISignalExport, JYPCIe5111.DOSignalExport
  • AddChannel() : JYPCIe5111.JYPCIe5111AITask, JYPCIe5111.JYPCIe5111AOTask, JYPCIe5111.JYPCIe5111DITask, JYPCIe5111.JYPCIe5111DOTask
  • AIChannel() : JYPCIe5111.AIChannel

- c -

  • Clear() : JYPCIe5111.AISignalExport, JYPCIe5111.AOSignalExport, JYPCIe5111.CISignalExport, JYPCIe5111.COSignalExport, JYPCIe5111.DISignalExport, JYPCIe5111.DOSignalExport
  • ClearAll() : JYPCIe5111.AISignalExport, JYPCIe5111.AOSignalExport, JYPCIe5111.CISignalExport, JYPCIe5111.COSignalExport, JYPCIe5111.DISignalExport, JYPCIe5111.DOSignalExport
  • COPulse() : JYPCIe5111.COPulse

- g -

  • GetRecordPreviewData() : JYPCIe5111.JYPCIe5111AITask
  • GetRecordStatus() : JYPCIe5111.JYPCIe5111AITask

- j -

  • JYPCIe5111AITask() : JYPCIe5111.JYPCIe5111AITask
  • JYPCIe5111AOTask() : JYPCIe5111.JYPCIe5111AOTask
  • JYPCIe5111CITask() : JYPCIe5111.JYPCIe5111CITask
  • JYPCIe5111COTask() : JYPCIe5111.JYPCIe5111COTask
  • JYPCIe5111DITask() : JYPCIe5111.JYPCIe5111DITask
  • JYPCIe5111DOTask() : JYPCIe5111.JYPCIe5111DOTask

- r -

  • ReadData() : JYPCIe5111.JYPCIe5111AITask, JYPCIe5111.JYPCIe5111CITask, JYPCIe5111.JYPCIe5111DITask
  • ReadRawData() : JYPCIe5111.JYPCIe5111AITask
  • ReadRawSinglePoint() : JYPCIe5111.JYPCIe5111AITask
  • ReadSinglePoint() : JYPCIe5111.JYPCIe5111AITask, JYPCIe5111.JYPCIe5111CITask, JYPCIe5111.JYPCIe5111DITask, JYPCIe5111.JYPCIe5111DOTask
  • RemoveChannel() : JYPCIe5111.JYPCIe5111AITask, JYPCIe5111.JYPCIe5111AOTask, JYPCIe5111.JYPCIe5111DITask, JYPCIe5111.JYPCIe5111DOTask

- s -

  • SendSoftwareTrigger() : JYPCIe5111.JYPCIe5111AITask, JYPCIe5111.JYPCIe5111AOTask, JYPCIe5111.JYPCIe5111CITask, JYPCIe5111.JYPCIe5111COTask, JYPCIe5111.JYPCIe5111DITask, JYPCIe5111.JYPCIe5111DOTask
  • Start() : JYPCIe5111.JYPCIe5111AITask, JYPCIe5111.JYPCIe5111AOTask, JYPCIe5111.JYPCIe5111CITask, JYPCIe5111.JYPCIe5111COTask, JYPCIe5111.JYPCIe5111DITask, JYPCIe5111.JYPCIe5111DOTask
  • Stop() : JYPCIe5111.JYPCIe5111AITask, JYPCIe5111.JYPCIe5111AOTask, JYPCIe5111.JYPCIe5111CITask, JYPCIe5111.JYPCIe5111COTask, JYPCIe5111.JYPCIe5111DITask, JYPCIe5111.JYPCIe5111DOTask

- w -

  • WaitUntilDone() : JYPCIe5111.JYPCIe5111AITask, JYPCIe5111.JYPCIe5111AOTask, JYPCIe5111.JYPCIe5111COTask, JYPCIe5111.JYPCIe5111DOTask
  • WriteData() : JYPCIe5111.JYPCIe5111AOTask, JYPCIe5111.JYPCIe5111COTask, JYPCIe5111.JYPCIe5111DOTask
  • WriteRawData() : JYPCIe5111.JYPCIe5111AOTask
  • WriteRawSinglePoint() : JYPCIe5111.JYPCIe5111AOTask
  • WriteSinglePoint() : JYPCIe5111.JYPCIe5111AOTask, JYPCIe5111.JYPCIe5111COTask, JYPCIe5111.JYPCIe5111DOTask


5111 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- g -

  • GetRecordPreviewData() : JYPCIe5111.JYPCIe5111AITask
  • GetRecordStatus() : JYPCIe5111.JYPCIe5111AITask


5111 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- h -

  • HighThreshold : JYPCIe5111.AIAnalogHysteresisComparator, JYPCIe5111.AIAnalogWindowComparator
  • Hysteresis : JYPCIe5111.AIAnalogTrigger


5111 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- i -

  • IdleState : JYPCIe5111.EdgeCountingOutEvent, JYPCIe5111.JYPCIe5111COTask
  • Implicit : JYPCIe5111.CISampleClock
  • InitialCount : JYPCIe5111.EdgeCounting, JYPCIe5111.QuadEncoder, JYPCIe5111.TwoPulseEncoder
  • InitialDelay : JYPCIe5111.JYPCIe5111COTask
  • InputTerminal : JYPCIe5111.EdgeCounting, JYPCIe5111.FrequencyMeas, JYPCIe5111.PeriodMeas, JYPCIe5111.PulseMeas
  • Internal : JYPCIe5111.CISampleClock


5111 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- j -

  • JYPCIe5111AITask() : JYPCIe5111.JYPCIe5111AITask
  • JYPCIe5111AOTask() : JYPCIe5111.JYPCIe5111AOTask
  • JYPCIe5111CITask() : JYPCIe5111.JYPCIe5111CITask
  • JYPCIe5111COTask() : JYPCIe5111.JYPCIe5111COTask
  • JYPCIe5111DITask() : JYPCIe5111.JYPCIe5111DITask
  • JYPCIe5111DOTask() : JYPCIe5111.JYPCIe5111DOTask


5111 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- l -

  • Length : JYPCIe5111.AIRecord
  • LowThreshold : JYPCIe5111.AIAnalogHysteresisComparator, JYPCIe5111.AIAnalogWindowComparator


5111 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- m -

  • Mode : JYPCIe5111.AIRecord, JYPCIe5111.AITrigger, JYPCIe5111.DITrigger, JYPCIe5111.JYPCIe5111AITask, JYPCIe5111.JYPCIe5111AOTask, JYPCIe5111.JYPCIe5111CITask, JYPCIe5111.JYPCIe5111COTask, JYPCIe5111.JYPCIe5111DITask, JYPCIe5111.JYPCIe5111DOTask


5111 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- o -

  • OutEvent : JYPCIe5111.EdgeCounting
  • OutputTerminal : JYPCIe5111.JYPCIe5111COTask


5111 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- p -

  • Pause : JYPCIe5111.EdgeCounting, JYPCIe5111.JYPCIe5111COTask
  • PeriodMeas : JYPCIe5111.JYPCIe5111CITask
  • PortNum : JYPCIe5111.DIChannel, JYPCIe5111.DOChannel
  • PreTriggerSamples : JYPCIe5111.AITrigger, JYPCIe5111.DITrigger
  • PulseMeas : JYPCIe5111.JYPCIe5111CITask


5111 C# Programming Manual: Class Members - Properties

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all properties with links to the classes they belong to:

- a -

  • ActiveEdge : JYPCIe5111.EdgeCounting
  • ActivePolarity : JYPCIe5111.PauseTrigger
  • Advanced : JYPCIe5111.JYPCIe5111AITask
  • AInputTerminal : JYPCIe5111.QuadEncoder, JYPCIe5111.TwoPulseEncoder
  • Analog : JYPCIe5111.AITrigger
  • AvailableSamples : JYPCIe5111.JYPCIe5111AITask, JYPCIe5111.JYPCIe5111CITask, JYPCIe5111.JYPCIe5111DITask
  • AvaliableLenInSamples : JYPCIe5111.JYPCIe5111AOTask, JYPCIe5111.JYPCIe5111COTask, JYPCIe5111.JYPCIe5111DOTask

- b -

  • BInputTerminal : JYPCIe5111.QuadEncoder, JYPCIe5111.TwoPulseEncoder
  • BufLenInSamples : JYPCIe5111.JYPCIe5111AITask, JYPCIe5111.JYPCIe5111AOTask, JYPCIe5111.JYPCIe5111DITask, JYPCIe5111.JYPCIe5111DOTask

- c -

  • ChannelID : JYPCIe5111.AIChannel, JYPCIe5111.AOChannel
  • Channels : JYPCIe5111.JYPCIe5111AITask, JYPCIe5111.JYPCIe5111AOTask, JYPCIe5111.JYPCIe5111DITask, JYPCIe5111.JYPCIe5111DOTask
  • Comparator : JYPCIe5111.AIAnalogTrigger
  • CompleteState : JYPCIe5111.JYPCIe5111AOTask, JYPCIe5111.JYPCIe5111DOTask
  • Condition : JYPCIe5111.AIAnalogWindowComparator
  • ConvertRate : JYPCIe5111.AIAdvanced

- d -

  • Device : JYPCIe5111.JYPCIe5111AITask, JYPCIe5111.JYPCIe5111AOTask, JYPCIe5111.JYPCIe5111CITask, JYPCIe5111.JYPCIe5111COTask, JYPCIe5111.JYPCIe5111DITask, JYPCIe5111.JYPCIe5111DOTask
  • Digital : JYPCIe5111.AITrigger, JYPCIe5111.AOTrigger, JYPCIe5111.CITrigger, JYPCIe5111.COTrigger, JYPCIe5111.DITrigger, JYPCIe5111.DOTrigger
  • Direction : JYPCIe5111.EdgeCounting
  • DirTerminal : JYPCIe5111.EdgeCounting
  • DisableCalibration : JYPCIe5111.JYPCIe5111AITask, JYPCIe5111.JYPCIe5111AOTask

- e -

  • Edge : JYPCIe5111.AIAnalogTrigger, JYPCIe5111.AIDigitalTrigger, JYPCIe5111.AODigitalTrigger, JYPCIe5111.CIDigitalTrigger, JYPCIe5111.CODigitalTrigger, JYPCIe5111.DIDigitalTrigger, JYPCIe5111.DODigitalTrigger
  • EdgeCounting : JYPCIe5111.JYPCIe5111CITask
  • EncodingType : JYPCIe5111.QuadEncoder
  • ExpectedRate : JYPCIe5111.AIExternalSampleClock, JYPCIe5111.AOExternalSampleClock, JYPCIe5111.CIExternalSampleClock, JYPCIe5111.CIImplicitSampleClock, JYPCIe5111.DIExternalSampleClock, JYPCIe5111.DOExternalSampleClock
  • External : JYPCIe5111.AISampleClock, JYPCIe5111.AOSampleClock, JYPCIe5111.CISampleClock, JYPCIe5111.DISampleClock, JYPCIe5111.DOSampleClock

- f -

  • FileFormat : JYPCIe5111.AIRecord
  • FilePath : JYPCIe5111.AIRecord
  • FirstInputTerminal : JYPCIe5111.TwoEdgeSeparation
  • FrequencyMeas : JYPCIe5111.JYPCIe5111CITask

- h -

  • Hysteresis : JYPCIe5111.AIAnalogTrigger

- i -

  • IdleState : JYPCIe5111.EdgeCountingOutEvent, JYPCIe5111.JYPCIe5111COTask
  • Implicit : JYPCIe5111.CISampleClock
  • InitialCount : JYPCIe5111.EdgeCounting, JYPCIe5111.QuadEncoder, JYPCIe5111.TwoPulseEncoder
  • InitialDelay : JYPCIe5111.JYPCIe5111COTask
  • InputTerminal : JYPCIe5111.EdgeCounting, JYPCIe5111.FrequencyMeas, JYPCIe5111.PeriodMeas, JYPCIe5111.PulseMeas
  • Internal : JYPCIe5111.CISampleClock

- l -

  • Length : JYPCIe5111.AIRecord

- m -

  • Mode : JYPCIe5111.AIRecord, JYPCIe5111.AITrigger, JYPCIe5111.DITrigger, JYPCIe5111.JYPCIe5111AITask, JYPCIe5111.JYPCIe5111AOTask, JYPCIe5111.JYPCIe5111CITask, JYPCIe5111.JYPCIe5111COTask, JYPCIe5111.JYPCIe5111DITask, JYPCIe5111.JYPCIe5111DOTask

- o -

  • OutEvent : JYPCIe5111.EdgeCounting
  • OutputTerminal : JYPCIe5111.JYPCIe5111COTask

- p -

  • Pause : JYPCIe5111.EdgeCounting, JYPCIe5111.JYPCIe5111COTask
  • PeriodMeas : JYPCIe5111.JYPCIe5111CITask
  • PortNum : JYPCIe5111.DIChannel, JYPCIe5111.DOChannel
  • PreTriggerSamples : JYPCIe5111.AITrigger, JYPCIe5111.DITrigger
  • PulseMeas : JYPCIe5111.JYPCIe5111CITask

- q -

  • QuadEncoder : JYPCIe5111.JYPCIe5111CITask

- r -

  • RangeHigh : JYPCIe5111.AIChannel, JYPCIe5111.AOChannel
  • RangeLow : JYPCIe5111.AIChannel, JYPCIe5111.AOChannel
  • Rate : JYPCIe5111.CIInternalSampleClock
  • Record : JYPCIe5111.JYPCIe5111AITask
  • ReTriggerCount : JYPCIe5111.AITrigger

- s -

  • SampleClock : JYPCIe5111.JYPCIe5111AITask, JYPCIe5111.JYPCIe5111AOTask, JYPCIe5111.JYPCIe5111CITask, JYPCIe5111.JYPCIe5111DITask, JYPCIe5111.JYPCIe5111DOTask
  • SampleRate : JYPCIe5111.JYPCIe5111AITask, JYPCIe5111.JYPCIe5111DITask
  • SamplesToAcquire : JYPCIe5111.JYPCIe5111AITask, JYPCIe5111.JYPCIe5111CITask, JYPCIe5111.JYPCIe5111DITask
  • SamplesToUpdate : JYPCIe5111.JYPCIe5111AOTask, JYPCIe5111.JYPCIe5111COTask, JYPCIe5111.JYPCIe5111DOTask
  • SecondInputTerminal : JYPCIe5111.TwoEdgeSeparation
  • SignalExport : JYPCIe5111.JYPCIe5111AITask, JYPCIe5111.JYPCIe5111AOTask, JYPCIe5111.JYPCIe5111CITask, JYPCIe5111.JYPCIe5111COTask, JYPCIe5111.JYPCIe5111DITask, JYPCIe5111.JYPCIe5111DOTask
  • Slope : JYPCIe5111.AIAnalogEdgeComparator, JYPCIe5111.AIAnalogHysteresisComparator
  • Source : JYPCIe5111.AIAnalogTrigger, JYPCIe5111.AIDigitalTrigger, JYPCIe5111.AISampleClock, JYPCIe5111.AODigitalTrigger, JYPCIe5111.AOSampleClock, JYPCIe5111.CIDigitalTrigger, JYPCIe5111.CISampleClock, JYPCIe5111.CITimebase, JYPCIe5111.CODigitalTrigger, JYPCIe5111.COTimebase, JYPCIe5111.DIDigitalTrigger, JYPCIe5111.DISampleClock, JYPCIe5111.DODigitalTrigger, JYPCIe5111.DOSampleClock

- t -

  • Terminal : JYPCIe5111.AIChannel, JYPCIe5111.AIExternalSampleClock, JYPCIe5111.AOExternalSampleClock, JYPCIe5111.CIExternalSampleClock, JYPCIe5111.DIExternalSampleClock, JYPCIe5111.DOExternalSampleClock, JYPCIe5111.EdgeCountingOutEvent, JYPCIe5111.PauseTrigger
  • Threshold : JYPCIe5111.EdgeCountingOutEvent
  • TimeBase : JYPCIe5111.JYPCIe5111COTask
  • Timebase : JYPCIe5111.FrequencyMeas, JYPCIe5111.PeriodMeas, JYPCIe5111.PulseMeas, JYPCIe5111.TwoEdgeSeparation
  • TransferedPulses : JYPCIe5111.JYPCIe5111COTask
  • TransferedSamples : JYPCIe5111.JYPCIe5111AITask, JYPCIe5111.JYPCIe5111AOTask, JYPCIe5111.JYPCIe5111CITask, JYPCIe5111.JYPCIe5111COTask, JYPCIe5111.JYPCIe5111DITask, JYPCIe5111.JYPCIe5111DOTask
  • Trigger : JYPCIe5111.JYPCIe5111AITask, JYPCIe5111.JYPCIe5111AOTask, JYPCIe5111.JYPCIe5111CITask, JYPCIe5111.JYPCIe5111COTask, JYPCIe5111.JYPCIe5111DITask, JYPCIe5111.JYPCIe5111DOTask
  • TwoEdgeSeparation : JYPCIe5111.JYPCIe5111CITask
  • TwoPulseEncoder : JYPCIe5111.JYPCIe5111CITask
  • Type : JYPCIe5111.AITrigger, JYPCIe5111.AOTrigger, JYPCIe5111.CITrigger, JYPCIe5111.COTrigger, JYPCIe5111.DITrigger, JYPCIe5111.DOTrigger, JYPCIe5111.JYPCIe5111CITask

- u -

  • UpdateRate : JYPCIe5111.JYPCIe5111AOTask, JYPCIe5111.JYPCIe5111DOTask

- w -

  • Window : JYPCIe5111.AIAnalogTrigger

- z -

  • ZInputTerminal : JYPCIe5111.QuadEncoder
  • ZReloadEnabled : JYPCIe5111.QuadEncoder


5111 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- q -

  • QuadEncoder : JYPCIe5111.JYPCIe5111CITask


5111 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- r -

  • RangeHigh : JYPCIe5111.AIChannel, JYPCIe5111.AOChannel
  • RangeLow : JYPCIe5111.AIChannel, JYPCIe5111.AOChannel
  • Rate : JYPCIe5111.CIInternalSampleClock
  • ReadData() : JYPCIe5111.JYPCIe5111AITask, JYPCIe5111.JYPCIe5111CITask, JYPCIe5111.JYPCIe5111DITask
  • ReadRawData() : JYPCIe5111.JYPCIe5111AITask
  • ReadRawSinglePoint() : JYPCIe5111.JYPCIe5111AITask
  • ReadSinglePoint() : JYPCIe5111.JYPCIe5111AITask, JYPCIe5111.JYPCIe5111CITask, JYPCIe5111.JYPCIe5111DITask, JYPCIe5111.JYPCIe5111DOTask
  • Record : JYPCIe5111.JYPCIe5111AITask
  • RemoveChannel() : JYPCIe5111.JYPCIe5111AITask, JYPCIe5111.JYPCIe5111AOTask, JYPCIe5111.JYPCIe5111DITask, JYPCIe5111.JYPCIe5111DOTask
  • ReTriggerCount : JYPCIe5111.AITrigger


5111 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- s -

  • SampleClock : JYPCIe5111.JYPCIe5111AITask, JYPCIe5111.JYPCIe5111AOTask, JYPCIe5111.JYPCIe5111CITask, JYPCIe5111.JYPCIe5111DITask, JYPCIe5111.JYPCIe5111DOTask
  • SampleRate : JYPCIe5111.JYPCIe5111AITask, JYPCIe5111.JYPCIe5111DITask
  • SamplesToAcquire : JYPCIe5111.JYPCIe5111AITask, JYPCIe5111.JYPCIe5111CITask, JYPCIe5111.JYPCIe5111DITask
  • SamplesToUpdate : JYPCIe5111.JYPCIe5111AOTask, JYPCIe5111.JYPCIe5111COTask, JYPCIe5111.JYPCIe5111DOTask
  • SecondInputTerminal : JYPCIe5111.TwoEdgeSeparation
  • SendSoftwareTrigger() : JYPCIe5111.JYPCIe5111AITask, JYPCIe5111.JYPCIe5111AOTask, JYPCIe5111.JYPCIe5111CITask, JYPCIe5111.JYPCIe5111COTask, JYPCIe5111.JYPCIe5111DITask, JYPCIe5111.JYPCIe5111DOTask
  • SignalExport : JYPCIe5111.JYPCIe5111AITask, JYPCIe5111.JYPCIe5111AOTask, JYPCIe5111.JYPCIe5111CITask, JYPCIe5111.JYPCIe5111COTask, JYPCIe5111.JYPCIe5111DITask, JYPCIe5111.JYPCIe5111DOTask
  • Slope : JYPCIe5111.AIAnalogEdgeComparator, JYPCIe5111.AIAnalogHysteresisComparator
  • Source : JYPCIe5111.AIAnalogTrigger, JYPCIe5111.AIDigitalTrigger, JYPCIe5111.AISampleClock, JYPCIe5111.AODigitalTrigger, JYPCIe5111.AOSampleClock, JYPCIe5111.CIDigitalTrigger, JYPCIe5111.CISampleClock, JYPCIe5111.CITimebase, JYPCIe5111.CODigitalTrigger, JYPCIe5111.COTimebase, JYPCIe5111.DIDigitalTrigger, JYPCIe5111.DISampleClock, JYPCIe5111.DODigitalTrigger, JYPCIe5111.DOSampleClock
  • Start() : JYPCIe5111.JYPCIe5111AITask, JYPCIe5111.JYPCIe5111AOTask, JYPCIe5111.JYPCIe5111CITask, JYPCIe5111.JYPCIe5111COTask, JYPCIe5111.JYPCIe5111DITask, JYPCIe5111.JYPCIe5111DOTask
  • Stop() : JYPCIe5111.JYPCIe5111AITask, JYPCIe5111.JYPCIe5111AOTask, JYPCIe5111.JYPCIe5111CITask, JYPCIe5111.JYPCIe5111COTask, JYPCIe5111.JYPCIe5111DITask, JYPCIe5111.JYPCIe5111DOTask


5111 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- t -

  • Terminal : JYPCIe5111.AIChannel, JYPCIe5111.AIExternalSampleClock, JYPCIe5111.AOExternalSampleClock, JYPCIe5111.CIExternalSampleClock, JYPCIe5111.DIExternalSampleClock, JYPCIe5111.DOExternalSampleClock, JYPCIe5111.EdgeCountingOutEvent, JYPCIe5111.PauseTrigger
  • Threshold : JYPCIe5111.AIAnalogEdgeComparator, JYPCIe5111.EdgeCountingOutEvent
  • TimeBase : JYPCIe5111.JYPCIe5111COTask
  • Timebase : JYPCIe5111.FrequencyMeas, JYPCIe5111.PeriodMeas, JYPCIe5111.PulseMeas, JYPCIe5111.TwoEdgeSeparation
  • TransferedPulses : JYPCIe5111.JYPCIe5111COTask
  • TransferedSamples : JYPCIe5111.JYPCIe5111AITask, JYPCIe5111.JYPCIe5111AOTask, JYPCIe5111.JYPCIe5111CITask, JYPCIe5111.JYPCIe5111COTask, JYPCIe5111.JYPCIe5111DITask, JYPCIe5111.JYPCIe5111DOTask
  • Trigger : JYPCIe5111.JYPCIe5111AITask, JYPCIe5111.JYPCIe5111AOTask, JYPCIe5111.JYPCIe5111CITask, JYPCIe5111.JYPCIe5111COTask, JYPCIe5111.JYPCIe5111DITask, JYPCIe5111.JYPCIe5111DOTask
  • TwoEdgeSeparation : JYPCIe5111.JYPCIe5111CITask
  • TwoPulseEncoder : JYPCIe5111.JYPCIe5111CITask
  • Type : JYPCIe5111.AITrigger, JYPCIe5111.AOTrigger, JYPCIe5111.CITrigger, JYPCIe5111.COTrigger, JYPCIe5111.DITrigger, JYPCIe5111.DOTrigger, JYPCIe5111.JYPCIe5111CITask


5111 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- u -

  • UpdateRate : JYPCIe5111.JYPCIe5111AOTask, JYPCIe5111.JYPCIe5111DOTask


5111 C# Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Properties
Here is a list of all variables with links to the classes they belong to:
  • HighThreshold : JYPCIe5111.AIAnalogHysteresisComparator, JYPCIe5111.AIAnalogWindowComparator
  • LowThreshold : JYPCIe5111.AIAnalogHysteresisComparator, JYPCIe5111.AIAnalogWindowComparator
  • Threshold : JYPCIe5111.AIAnalogEdgeComparator


5111 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- w -

  • WaitUntilDone() : JYPCIe5111.JYPCIe5111AITask, JYPCIe5111.JYPCIe5111AOTask, JYPCIe5111.JYPCIe5111COTask, JYPCIe5111.JYPCIe5111DOTask
  • Window : JYPCIe5111.AIAnalogTrigger
  • WriteData() : JYPCIe5111.JYPCIe5111AOTask, JYPCIe5111.JYPCIe5111COTask, JYPCIe5111.JYPCIe5111DOTask
  • WriteRawData() : JYPCIe5111.JYPCIe5111AOTask
  • WriteRawSinglePoint() : JYPCIe5111.JYPCIe5111AOTask
  • WriteSinglePoint() : JYPCIe5111.JYPCIe5111AOTask, JYPCIe5111.JYPCIe5111COTask, JYPCIe5111.JYPCIe5111DOTask


5111 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- z -

  • ZInputTerminal : JYPCIe5111.QuadEncoder
  • ZReloadEnabled : JYPCIe5111.QuadEncoder


5111 C# Programming Manual: Main Page

5111 C# Programming Manual Documentation


5111 C# Programming Manual: JYPCIe5111 Namespace Reference

  • Package List
  • Package Members
Classes | Enumerations
JYPCIe5111 Namespace Reference

Classes

class | AIAdvanced
AI Advance parameter. More...
class | AIAnalogEdgeComparator
AI Analog Edge Comparator. More...
class | AIAnalogHysteresisComparator
AI Analog Hysteresis Comparatorr. More...
class | AIAnalogTrigger
AI analog trigger . More...
class | AIAnalogWindowComparator
AI Analog Window Comparatorr. More...
class | AIChannel
AI Channel parameter class . More...
class | AIDigitalTrigger
AI Digital trigger class. More...
class | AIExternalSampleClock
External Sample Clock Configuration Class. More...
class | AIRecord
AI Record Parameters. More...
class | AISampleClock
Sample clock configuration class. More...
class | AISignalExport
AI Signal Export Class. More...
class | AITrigger
Constructor to create an AITrigger task object. More...
class | AOChannel
AO Channel parameter class . More...
class | AODigitalTrigger
AO Digital trigger . More...
class | AOExternalSampleClock
External Sample Clock Configuration Class. More...
class | AOSampleClock
AO Sample clock configuration class. More...
class | AOSignalExport
AO Signal Export Class. More...
class | AOTrigger
Constructor to create an AOTrigger task object. More...
class | CIDigitalTrigger
CI Digital trigger . More...
class | CIExternalSampleClock
CI Implicit Sample Clock class. More...
class | CIImplicitSampleClock
CI Implicit Sample Clock class. More...
class | CIInternalSampleClock
CI Internal Sample Clock Configuration Class. More...
class | CISampleClock
CI Sample Clock class. More...
class | CISignalExport
CI Signal Export Class. More...
class | CITimebase
Timebase configuration class. More...
class | CITrigger
Constructor to create an CITrigger task object. More...
class | CODigitalTrigger
CO Digital trigger . More...
class | COPulse
Pulse Parameter. More...
class | COSignalExport
CO Signal Export Class. More...
class | COTimebase
Timebase configuration class. More...
class | COTrigger
Constructor to create an COTrigger task object. More...
class | DIChannel
DI Channel parameter class . More...
class | DIDigitalTrigger
DI Digital trigger . More...
class | DIExternalSampleClock
External Sample Clock Configuration Class. More...
class | DISampleClock
Sample clock configuration class. More...
class | DISignalExport
DI Signal Export Class. More...
class | DITrigger
Constructor to create an DITrigger task object. More...
class | DOChannel
DO Channel parameter class . More...
class | DODigitalTrigger
DO Digital trigger. More...
class | DOExternalSampleClock
External Sample Clock Configuration Class. More...
class | DOSampleClock
Sample clock configuration class. More...
class | DOSignalExport
DO Signal Export Class. More...
class | DOTrigger
Constructor to create an DOTrigger task object. More...
class | EdgeCounting
Configure CI EdgeCounting. More...
class | EdgeCountingOutEvent
Edge counting output event configuration class. More...
class | FrequencyMeas
Configure CI Measure. More...
class | JYPCIe5111AITask
JYPCIe5111 Analog Input Task. More...
class | JYPCIe5111AOTask
JYPCIe5111 Analog Ouput Task. More...
class | JYPCIe5111CITask
JYPCIe5111 Counter Input Task. More...
class | JYPCIe5111COTask
JYPCIe5111 Counter Output Task. More...
class | JYPCIe5111DITask
JYPCIe5111 Digital Iuput Task. More...
class | JYPCIe5111DOTask
JYPCIe5111 Digital Output Task. More...
class | PauseTrigger
Pause trigger configuration class. More...
class | PeriodMeas
Configure CI Measure. More...
class | PulseMeas
Configure CI Measure. More...
class | QuadEncoder
Configure CI Measure. More...
class | TwoEdgeSeparation
Configure CI Measure. More...
class | TwoPulseEncoder
Configure CI Measure. More...

Enumerations

enum | AITriggerType { Immediate = JYPCIe5111Import.JYPCIe5111_TriggerType_Immediately , Digital = JYPCIe5111Import.JYPCIe5111_TriggerType_Digital , Analog = JYPCIe5111Import.JYPCIe5111_TriggerType_Analog , Soft = JYPCIe5111Import.JYPCIe5111_TriggerType_Soft }
Trigger Type Digital/Analog/Immediate/Soft. More...
enum | AIDigitalTriggerEdge { Rising = JYPCIe5111Import.JYPCIe5111_DigitalTriggerEdge_Rising , Falling = JYPCIe5111Import.JYPCIe5111_DigitalTriggerEdge_Falling }
AI Digital Trigger Edge. More...
enum | AIMode { Single = JYPCIe5111Import.JYPCIe5111_AI_Single , Finite = JYPCIe5111Import.JYPCIe5111_AI_Finite , Continuous = JYPCIe5111Import.JYPCIe5111_AI_Continuous , Record = 0x3 }
AIMode. More...
enum | AITerminal { RSE = JYPCIe5111Import.JYPCIe5111_AI_RSE , NRSE = JYPCIe5111Import.JYPCIe5111_AI_NRSE , Differential = JYPCIe5111Import.JYPCIe5111_AI_Diff }
AITerminal. More...
enum | AISampleClockSource { Internal , External }
AI Sample Clock Source. More...
enum ClockTerminal {
ECLK = 10000 , PFI0 = 0 , PFI1 = 1 , PFI2 = 2 ,
PFI3 = 3 , PFI4 = 4 , PFI5 = 5 , PFI6 = 6 ,
PFI7 = 7 , PFI8 = 8 , PFI9 = 9 , PFI10 = 10 ,
PFI11 = 11 , PFI12 = 12 , PFI13 = 13 , PFI14 = 14 ,
PFI15 = 15 , PXI_Trig0 = 40 , PXI_Trig1 = 41 , PXI_Trig2 = 42 ,
PXI_Trig3 = 43 , PXI_Trig4 = 44 , PXI_Trig5 = 45 , PXI_Trig6 = 46 ,
PXI_Trig7 = 47 , AI_SampleClock = JYPCIe5111Import.JYPCIe5111_AI_SampleClock , AO_SampleClock = JYPCIe5111Import.JYPCIe5111_AO_SampleClock , CI0_SampleClock = JYPCIe5111Import.JYPCIe5111_CI0_SampleClock ,
CI1_SampleClock = JYPCIe5111Import.JYPCIe5111_CI1_SampleClock , CI2_SampleClock = JYPCIe5111Import.JYPCIe5111_CI2_SampleClock , CI3_SampleClock = JYPCIe5111Import.JYPCIe5111_CI3_SampleClock
}
Clock Terminal. More...
enum | AITriggerMode { Start , Reference }
AI Trigger Mode. More...
enum AIAnalogTriggerSource {
Channel_0 , Channel_1 , Channel_2 , Channel_3 ,
Channel_4 , Channel_5 , Channel_6 , Channel_7 ,
Channel_8 , Channel_9 , Channel_10 , Channel_11 ,
Channel_12 , Channel_13 , Channel_14 , Channel_15 ,
Channel_16 , Channel_17 , Channel_18 , Channel_19 ,
Channel_20 , Channel_21 , Channel_22 , Channel_23 ,
Channel_24 , Channel_25 , Channel_26 , Channel_27 ,
Channel_28 , Channel_29 , Channel_30 , Channel_31
}
AI analog trigger source. More...
enum AIDigitalTriggerSource {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PFI8 , PFI9 , PFI10 , PFI11 ,
PFI12 , PFI13 , PFI14 , PFI15 ,
PXI_Trig0 = 40 , PXI_Trig1 = 41 , PXI_Trig2 = 42 , PXI_Trig3 = 43 ,
PXI_Trig4 = 44 , PXI_Trig5 = 45 , PXI_Trig6 = 46 , PXI_Trig7 = 47 ,
AO_StartTrig = JYPCIe5111Import.JYPCIe5111_AO_StartTrig , DI_StartTrig = JYPCIe5111Import.JYPCIe5111_DI_StartTrig , DI_ReferenceTrig = JYPCIe5111Import.JYPCIe5111_DI_ReferenceTrig , DO_StartTrig = JYPCIe5111Import.JYPCIe5111_DO_StartTrig ,
CI0_StartTrig = JYPCIe5111Import.JYPCIe5111_CI0_StartTrig , CI1_StartTrig = JYPCIe5111Import.JYPCIe5111_CI1_StartTrig
}
AI Digital trigger source. More...
enum | AIAnalogTriggerEdge { Rising , Falling }
AI Analog Trigger Edge. More...
enum | AIAnalogWindowCondition { Entering , Leaving }
AI Analog Window Trigger Condition. More...
enum | AIAnalogTriggerComparator { Edge , Hysteresis , Window }
AI Analog Trigger Comparator. More...
enum | AISignalExportSource { StartTrig = JYPCIe5111Import.JYPCIe5111_AI_StartTrig , ReferenceTrig = JYPCIe5111Import.JYPCIe5111_AI_ReferenceTrig , SampleClock = JYPCIe5111Import.JYPCIe5111_AI_SampleClock }
AI Signal Export Source. More...
enum | FileFormat { Bin }
Streaming file format. More...
enum | RecordMode { Finite , Infinite }
stream mode .enum Finite/Infinite More...
enum SignalExportDestination {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PFI8 , PFI9 , PFI10 , PFI11 ,
PFI12 , PFI13 , PFI14 , PFI15 ,
PXI_Trig0 = JYPCIe5111Import.JYPCIe5111_PXITrig0_OUT , PXI_Trig1 = JYPCIe5111Import.JYPCIe5111_PXITrig1_OUT , PXI_Trig2 = JYPCIe5111Import.JYPCIe5111_PXITrig2_OUT , PXI_Trig3 = JYPCIe5111Import.JYPCIe5111_PXITrig3_OUT ,
PXI_Trig4 = JYPCIe5111Import.JYPCIe5111_PXITrig4_OUT , PXI_Trig5 = JYPCIe5111Import.JYPCIe5111_PXITrig5_OUT , PXI_Trig6 = JYPCIe5111Import.JYPCIe5111_PXITrig6_OUT , PXI_Trig7 = JYPCIe5111Import.JYPCIe5111_PXITrig7_OUT
}
Output DestinationTerminal. More...
enum | AODigitalTriggerEdge { Rising , Falling }
AO Digital Trigger Edge. More...
enum AODigitalTriggerSource {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PFI8 , PFI9 , PFI10 , PFI11 ,
PFI12 , PFI13 , PFI14 , PFI15 ,
PXI_Trig0 = 40 , PXI_Trig1 = 41 , PXI_Trig2 = 42 , PXI_Trig3 = 43 ,
PXI_Trig4 = 44 , PXI_Trig5 = 45 , PXI_Trig6 = 46 , PXI_Trig7 = 47 ,
AI_StartTrig = JYPCIe5111Import.JYPCIe5111_AI_StartTrig , AI_ReferenceTrig = JYPCIe5111Import.JYPCIe5111_AI_ReferenceTrig , DI_StartTrig = JYPCIe5111Import.JYPCIe5111_DI_StartTrig , DI_ReferenceTrig = JYPCIe5111Import.JYPCIe5111_DI_ReferenceTrig ,
DO_StartTrig = JYPCIe5111Import.JYPCIe5111_DO_StartTrig , CI0_StartTrig = JYPCIe5111Import.JYPCIe5111_CI0_StartTrig , CI1_StartTrig = JYPCIe5111Import.JYPCIe5111_CI1_StartTrig
}
AO Digital trigger source. More...
enum | AOMode { Single = 3 , Finite = 0 , ContinuousNoWrapping = 2 , ContinuousWrapping = 1 }
AOMode. More...
enum | AOSampleClockSource { Internal , External }
AO Sample Clock Source. More...
enum | AOSignalExportSource { StartTrig = JYPCIe5111Import.JYPCIe5111_AO_StartTrig , SampleClock = JYPCIe5111Import.JYPCIe5111_AO_SampleClock }
SourceSignal. More...
enum | OutputCompleteState { Zero , Hold }
Output Complete State. More...
enum | AOTriggerType { Immediate = JYPCIe5111Import.JYPCIe5111_TriggerType_Immediately , Digital = JYPCIe5111Import.JYPCIe5111_TriggerType_Digital , Soft = JYPCIe5111Import.JYPCIe5111_TriggerType_Soft }
TriggerType Digital/Immediate/Soft. More...
enum | CountDirection { Up = JYPCIe5111Import.JYPCIe5111_CI_Count_Up , Down = JYPCIe5111Import.JYPCIe5111_CI_Count_Down , External = JYPCIe5111Import.JYPCIe5111_CI_Count_External }
Counter direction. More...
enum | CIMode { Single = 2 , Finite = 0 , Continuous = 1 }
CIMode. More...
enum CIType {
EdgeCounting , Period , Frequency , Pulse ,
TwoEdgeSeparation , QuadEncoder , TwoPulseEncoder
}
Counter Input Application Type. More...
enum | CISampleClockSource { Implicit = JYPCIe5111Import.JYPCIe5111_CI_ImplicitClk , Internal = JYPCIe5111Import.JYPCIe5111_CI_Internal , External = JYPCIe5111Import.JYPCIe5111_CI_External }
CI Sample Clock Source. More...
enum InputTerminal {
Default = 0 , PXI_Trig0 = 40 , PXI_Trig1 = 41 , PXI_Trig2 = 42 ,
PXI_Trig3 = 43 , PXI_Trig4 = 44 , PXI_Trig5 = 45 , PXI_Trig6 = 46 ,
PXI_Trig7 = 47 , CI_0_OutPut = JYPCIe5111Import.JYPCIe5111_CO_0_Output , CI_1_OutPut = JYPCIe5111Import.JYPCIe5111_CO_1_Output , CI_2_OutPut = JYPCIe5111Import.JYPCIe5111_CO_2_Output ,
CI_3_OutPut = JYPCIe5111Import.JYPCIe5111_CO_3_Output
}
Cunter Input Terminal. More...
enum IOTerminal {
Default = 0 , PXI_Trig0 = JYPCIe5111Import.JYPCIe5111_PXITrig0_OUT , PXI_Trig1 = JYPCIe5111Import.JYPCIe5111_PXITrig1_OUT , PXI_Trig2 = JYPCIe5111Import.JYPCIe5111_PXITrig2_OUT ,
PXI_Trig3 = JYPCIe5111Import.JYPCIe5111_PXITrig3_OUT , PXI_Trig4 = JYPCIe5111Import.JYPCIe5111_PXITrig4_OUT , PXI_Trig5 = JYPCIe5111Import.JYPCIe5111_PXITrig5_OUT , PXI_Trig6 = JYPCIe5111Import.JYPCIe5111_PXITrig6_OUT ,
PXI_Trig7 = JYPCIe5111Import.JYPCIe5111_PXITrig7_OUT , None = 100
}
Cunter IO Terminal. More...
enum | EdgeType { Rising , Falling }
Edge Type. More...
enum | QuadEncodingType { X1 , X2 , X4 }
Quadrature Encoding Type. More...
enum | CITriggerType { Immediate = JYPCIe5111Import.JYPCIe5111_TriggerType_Immediately , Digital = JYPCIe5111Import.JYPCIe5111_TriggerType_Digital , Soft = JYPCIe5111Import.JYPCIe5111_TriggerType_Soft }
TriggerType Digital/Immediate/Soft. More...
enum CIDigitalTriggerSource {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PFI8 , PFI9 , PFI10 , PFI11 ,
PFI12 , PFI13 , PFI14 , PFI15 ,
PXI_Trig0 = 40 , PXI_Trig1 = 41 , PXI_Trig2 = 42 , PXI_Trig3 = 43 ,
PXI_Trig4 = 44 , PXI_Trig5 = 45 , PXI_Trig6 = 46 , PXI_Trig7 = 47 ,
AI_StartTrig = JYPCIe5111Import.JYPCIe5111_AI_StartTrig , AI_ReferenceTrig = JYPCIe5111Import.JYPCIe5111_AI_ReferenceTrig , AO_StartTrig = JYPCIe5111Import.JYPCIe5111_AO_StartTrig , DI_StartTrig = JYPCIe5111Import.JYPCIe5111_DI_StartTrig ,
DI_ReferenceTrig = JYPCIe5111Import.JYPCIe5111_DI_ReferenceTrig , DO_StartTrig = JYPCIe5111Import.JYPCIe5111_DO_StartTrig , CI0_StartTrig = JYPCIe5111Import.JYPCIe5111_CI0_StartTrig , CI1_StartTrig = JYPCIe5111Import.JYPCIe5111_CI1_StartTrig
}
CI Digital trigger source. More...
enum | CIDigitalTriggerEdge { Rising , Falling }
CI Digital Trigger Edge. More...
enum | EdgeCntOunEvtIdleState { LowLevel = 0 , HighLevel = 1 }
Output idle state when the event has not occurred. More...
enum | LevelPolarity { LowLevel = 0 , HighLevel = 1 , None = 2 }
Level Polarity. More...
enum | CISignalExportSource { StartTrig , SampleClock }
SourceSignal. More...
enum | CITimebaseSource { Internal200MHz }
Timebase source. More...
enum | COIdleState { HighLevel = JYPCIe5111Import.JYPCIe5111_CO_HighLevel , LowLevel = JYPCIe5111Import.JYPCIe5111_CO_LowLevel }
Idle state when pulse output before start and after stop. More...
enum | COMode { Single = 3 , Finite = 0 , ContinuousNoWrapping = 2 , ContinuousWrapping = 1 }
CO output mode. More...
enum | COTriggerType { Immediate = JYPCIe5111Import.JYPCIe5111_TriggerType_Immediately , Digital = JYPCIe5111Import.JYPCIe5111_TriggerType_Digital , Soft = JYPCIe5111Import.JYPCIe5111_TriggerType_Soft }
TriggerType Digital/Immediate/Soft. More...
enum CODigitalTriggerSource {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PFI8 , PFI9 , PFI10 , PFI11 ,
PFI12 , PFI13 , PFI14 , PFI15 ,
PXI_Trig0 = 40 , PXI_Trig1 = 41 , PXI_Trig2 = 42 , PXI_Trig3 = 43 ,
PXI_Trig4 = 44 , PXI_Trig5 = 45 , PXI_Trig6 = 46 , PXI_Trig7 = 47 ,
AI_StartTrig = JYPCIe5111Import.JYPCIe5111_AI_StartTrig , AI_ReferenceTrig = JYPCIe5111Import.JYPCIe5111_AI_ReferenceTrig , AO_StartTrig = JYPCIe5111Import.JYPCIe5111_AO_StartTrig , DI_StartTrig = JYPCIe5111Import.JYPCIe5111_DI_StartTrig ,
DI_ReferenceTrig = JYPCIe5111Import.JYPCIe5111_DI_ReferenceTrig , DO_StartTrig = JYPCIe5111Import.JYPCIe5111_DO_StartTrig , CI0_StartTrig = JYPCIe5111Import.JYPCIe5111_CI0_StartTrig , CI1_StartTrig = JYPCIe5111Import.JYPCIe5111_CI1_StartTrig
}
CO Digital trigger source. More...
enum | CODigitalTriggerEdge { Rising , Falling }
CO Digital Trigger Edge. More...
enum | COPulseType { DutyCycleFrequency , HighLowTime , HighLowTick }
Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick. More...
enum | COTimebaseSource { Internal200MHz }
Timebase source. More...
enum | COSignalExportSource { StartTrig , Output }
SourceSignal. More...
enum | DISampleClockSource { Internal , External }
DI Sample Clock Source. More...
enum | DIMode { Single = 2 , Finite = 0 , Continuous = 1 }
DIMode. More...
enum | DISignalExportSource { StartTrig = JYPCIe5111Import.JYPCIe5111_DI_StartTrig , ReferenceTrig = JYPCIe5111Import.JYPCIe5111_DI_ReferenceTrig , SampleClock = JYPCIe5111Import.JYPCIe5111_DI_SampleClock }
SourceSignal. More...
enum | DITriggerMode { Start , Reference }
DI Trigger Mode. More...
enum | DITriggerType { Immediate = JYPCIe5111Import.JYPCIe5111_TriggerType_Immediately , Digital = JYPCIe5111Import.JYPCIe5111_TriggerType_Digital , Soft = JYPCIe5111Import.JYPCIe5111_TriggerType_Soft }
TriggerType Digital/Immediate/Soft. More...
enum DIDigitalTriggerSource {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PFI8 , PFI9 , PFI10 , PFI11 ,
PFI12 , PFI13 , PFI14 , PFI15 ,
PXI_Trig0 = 40 , PXI_Trig1 = 41 , PXI_Trig2 = 42 , PXI_Trig3 = 43 ,
PXI_Trig4 = 44 , PXI_Trig5 = 45 , PXI_Trig6 = 46 , PXI_Trig7 = 47 ,
AI_StartTrig = JYPCIe5111Import.JYPCIe5111_AI_StartTrig , AI_ReferenceTrig = JYPCIe5111Import.JYPCIe5111_AI_ReferenceTrig , AO_StartTrig = JYPCIe5111Import.JYPCIe5111_AO_StartTrig , DO_StartTrig = JYPCIe5111Import.JYPCIe5111_DO_StartTrig ,
CI0_StartTrig = JYPCIe5111Import.JYPCIe5111_CI0_StartTrig , CI1_StartTrig = JYPCIe5111Import.JYPCIe5111_CI1_StartTrig
}
DI Digital trigger source. More...
enum | DIDigitalTriggerEdge { Rising , Falling }
DI Digital Trigger Edge. More...
enum | DOSampleClockSource { Internal , External }
DO Sample Clock Source. More...
enum | DOMode { Single = 3 , Finite = 0 , ContinuousWrapping = 1 , ContinuousNoWrapping = 2 }
DOMode. More...
enum | DODigitalTriggerEdge { Rising , Falling }
DO Digital Trigger Edge. More...
enum DODigitalTriggerSource {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PFI8 , PFI9 , PFI10 , PFI11 ,
PFI12 , PFI13 , PFI14 , PFI15 ,
PXI_Trig0 = 40 , PXI_Trig1 = 41 , PXI_Trig2 = 42 , PXI_Trig3 = 43 ,
PXI_Trig4 = 44 , PXI_Trig5 = 45 , PXI_Trig6 = 46 , PXI_Trig7 = 47 ,
AI_StartTrig = JYPCIe5111Import.JYPCIe5111_AI_StartTrig , AI_ReferenceTrig = JYPCIe5111Import.JYPCIe5111_AI_ReferenceTrig , AO_StartTrig = JYPCIe5111Import.JYPCIe5111_AO_StartTrig , DI_StartTrig = JYPCIe5111Import.JYPCIe5111_DI_StartTrig ,
DI_ReferenceTrig = JYPCIe5111Import.JYPCIe5111_DI_ReferenceTrig , CI0_StartTrig = JYPCIe5111Import.JYPCIe5111_CI0_StartTrig , CI1_StartTrig = JYPCIe5111Import.JYPCIe5111_CI1_StartTrig
}
DO Digital trigger source. More...
enum | DOTriggerType { Immediate = JYPCIe5111Import.JYPCIe5111_TriggerType_Immediately , Digital = JYPCIe5111Import.JYPCIe5111_TriggerType_Digital , Soft = JYPCIe5111Import.JYPCIe5111_TriggerType_Soft }
TriggerType Digital/Immediate/Soft. More...
enum | DOSignalExportSource { StartTrig = JYPCIe5111Import.JYPCIe5111_DO_StartTrig , SampleClock = JYPCIe5111Import.JYPCIe5111_DO_SampleClock }
SourceSignal. More...

Enumeration Type Documentation

◆ AIAnalogTriggerComparator

enum JYPCIe5111.AIAnalogTriggerComparator

AI Analog Trigger Comparator.

Enumerator
Edge | Edge Comparator.
Hysteresis | Hysteresis Comparator.
Window | Window Comparator.

◆ AIAnalogTriggerEdge

enum JYPCIe5111.AIAnalogTriggerEdge

AI Analog Trigger Edge.

Enumerator
Rising | Rising.
Falling | Falling.

◆ AIAnalogTriggerSource

enum JYPCIe5111.AIAnalogTriggerSource

AI analog trigger source.

Enumerator
Channel_0 | Channel_0 as the trigger source.
Channel_1 | Channel_1 as the trigger source.
Channel_2 | Channel_2 as the trigger source.
Channel_3 | Channel_3 as the trigger source.
Channel_4 | Channel_4 as the trigger source.
Channel_5 | Channel_5 as the trigger source.
Channel_6 | Channel_6 as the trigger source.
Channel_7 | Channel_7 as the trigger source.
Channel_8 | Channel_8 as the trigger source.
Channel_9 | Channel_9 as the trigger source.
Channel_10 | Channel_10 as the trigger source.
Channel_11 | Channel_11 as the trigger source.
Channel_12 | Channel_12 as the trigger source.
Channel_13 | Channel_13 as the trigger source.
Channel_14 | Channel_14 as the trigger source.
Channel_15 | Channel_15 as the trigger source.
Channel_16 | Channel_16 as the trigger source.
Channel_17 | Channel_17 as the trigger source.
Channel_18 | Channel_18 as the trigger source.
Channel_19 | Channe_l9 as the trigger source.
Channel_20 | Channel_20 as the trigger source.
Channel_21 | Channel_21 as the trigger source.
Channel_22 | Channel_22 as the trigger source.
Channel_23 | Channel_23 as the trigger source.
Channel_24 | Channel_24 as the trigger source.
Channel_25 | Channel_25 as the trigger source.
Channel_26 | Channel_26 as the trigger source.
Channel_27 | Channel_27 as the trigger source.
Channel_28 | Channel_28 as the trigger source.
Channel_29 | Channel_29 as the trigger source.
Channel_30 | Channel_30 as the trigger source.
Channel_31 | Channel_31 as the trigger source.

◆ AIAnalogWindowCondition

enum JYPCIe5111.AIAnalogWindowCondition

AI Analog Window Trigger Condition.

Enumerator
Entering | Rising.
Leaving | Falling.

◆ AIDigitalTriggerEdge

enum JYPCIe5111.AIDigitalTriggerEdge

AI Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ AIDigitalTriggerSource

enum JYPCIe5111.AIDigitalTriggerSource

AI Digital trigger source.

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11.
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.
AO_StartTrig | AO_StartTrig.
DI_StartTrig | DI_StartTrig.
DI_ReferenceTrig | DI_ReferenceTrig.
DO_StartTrig | DO_StartTrig.
CI0_StartTrig | CI0_StartTrig.
CI1_StartTrig | CI1_StartTrig.

◆ AIMode

enum JYPCIe5111.AIMode

AIMode.

Enumerator
Single | Single.
Finite | Finite.
Continuous | Continuous.
Record | Record.

◆ AISampleClockSource

enum JYPCIe5111.AISampleClockSource

AI Sample Clock Source.

Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ AISignalExportSource

enum JYPCIe5111.AISignalExportSource

AI Signal Export Source.

Enumerator
StartTrig | AI_StartTrig.
ReferenceTrig | AI_ReferenceTrig.
SampleClock | AI_SampleClock.

◆ AITerminal

enum JYPCIe5111.AITerminal

AITerminal.

Enumerator
RSE | RSE.
NRSE | NRSE.
Differential | Differential.

◆ AITriggerMode

enum JYPCIe5111.AITriggerMode

AI Trigger Mode.

Enumerator
Start | Start Trigger.
Reference | Reference Trigger，Valid when JYPCIe5111AITask.Mode is AIMode.Finite

◆ AITriggerType

enum JYPCIe5111.AITriggerType

Trigger Type Digital/Analog/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Analog | Analog Trigger.
Soft | Soft Trigger.

◆ AODigitalTriggerEdge

enum JYPCIe5111.AODigitalTriggerEdge

AO Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ AODigitalTriggerSource

enum JYPCIe5111.AODigitalTriggerSource

AO Digital trigger source.

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11.
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
DI_StartTrig | DI_StartTrig.
DI_ReferenceTrig | DI_ReferenceTrig.
DO_StartTrig | DO_StartTrig.
CI0_StartTrig | CI0_StartTrig.
CI1_StartTrig | CI1_StartTrig.

◆ AOMode

enum JYPCIe5111.AOMode

AOMode.

Enumerator
Single | Single.
Finite | Finite.
ContinuousNoWrapping | ContinuousNoWrapping.
ContinuousWrapping | ContinuousWrapping.

◆ AOSampleClockSource

enum JYPCIe5111.AOSampleClockSource

AO Sample Clock Source.

Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ AOSignalExportSource

enum JYPCIe5111.AOSignalExportSource

SourceSignal.

Enumerator
StartTrig | AO_StartTrig.
SampleClock | AO_SampleClock.

◆ AOTriggerType

enum JYPCIe5111.AOTriggerType

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ CIDigitalTriggerEdge

enum JYPCIe5111.CIDigitalTriggerEdge

CI Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ CIDigitalTriggerSource

enum JYPCIe5111.CIDigitalTriggerSource

CI Digital trigger source.

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11.
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
AO_StartTrig | AO_StartTrig.
DI_StartTrig | DI_StartTrig.
DI_ReferenceTrig | DI_ReferenceTrig.
DO_StartTrig | DO_StartTrig.
CI0_StartTrig | CI0_StartTrig.
CI1_StartTrig | CI1_StartTrig.

◆ CIMode

enum JYPCIe5111.CIMode

CIMode.

Enumerator
Single | Single.
Finite | Finite.
Continuous | Continuous.

◆ CISampleClockSource

enum JYPCIe5111.CISampleClockSource

CI Sample Clock Source.

Enumerator
Implicit | Implicit.
Internal | Internal.
External | External.

◆ CISignalExportSource

enum JYPCIe5111.CISignalExportSource

SourceSignal.

Enumerator
StartTrig | CI_StartTrig.
SampleClock | CI_SampleClock.

◆ CITimebaseSource

enum JYPCIe5111.CITimebaseSource

Timebase source.

Enumerator
Internal200MHz

Internal 200MHz Timebase.

◆ CITriggerType

enum JYPCIe5111.CITriggerType

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ CIType

enum JYPCIe5111.CIType

Counter Input Application Type.

Enumerator
EdgeCounting | Edge Counting.
Period | Period Measure.
Frequency | Frequenc Measure.
Pulse | Pulse Measure.
TwoEdgeSeparation | TwoEdgeSeparation Measure.
QuadEncoder | QuadEncoder.
TwoPulseEncoder | EncoderTwoPulse.

◆ ClockTerminal

enum JYPCIe5111.ClockTerminal

Clock Terminal.

Enumerator
ECLK | ECLK.
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11.
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PXI_Trig0 | PXITrigger_0.
PXI_Trig1 | PXITrigger_1.
PXI_Trig2 | PXITrigger_2.
PXI_Trig3 | PXITrigger_3.
PXI_Trig4 | PXITrigger_4.
PXI_Trig5 | PXITrigger_5.
PXI_Trig6 | PXITrigger_6.
PXI_Trig7 | PXITrigger_7.
AI_SampleClock | AI_SampleClock.
AO_SampleClock | AO_SampleClock.
CI0_SampleClock | CI0_SampleClock.
CI1_SampleClock | CI1_SampleClock.
CI2_SampleClock | CI2_SampleClock.
CI3_SampleClock | CI3_SampleClock.

◆ CODigitalTriggerEdge

enum JYPCIe5111.CODigitalTriggerEdge

CO Digital Trigger Edge.

Enumerator
Rising | Rising Edge.
Falling | Falling Edge.

◆ CODigitalTriggerSource

enum JYPCIe5111.CODigitalTriggerSource

CO Digital trigger source.

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11.
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
AO_StartTrig | AO_StartTrig.
DI_StartTrig | DI_StartTrig.
DI_ReferenceTrig | DI_ReferenceTrig.
DO_StartTrig | DO_StartTrig.
CI0_StartTrig | CI0_StartTrig.
CI1_StartTrig | CI1_StartTrig.

◆ COIdleState

enum JYPCIe5111.COIdleState

Idle state when pulse output before start and after stop.

Enumerator
HighLevel | Idle state is high level.
LowLevel | Idle state is low level.

◆ COMode

enum JYPCIe5111.COMode

CO output mode.

Enumerator
Single | Single pulse output.
Finite | Finite.
ContinuousNoWrapping | ContinuousNoWrapping.
ContinuousWrapping | ContinuousWrapping.

◆ COPulseType

enum JYPCIe5111.COPulseType

Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick.

Enumerator
DutyCycleFrequency | Configure CO output pulse according to its DutyCycle and Freqency.
HighLowTime | Configure CO output pulse according to duration of its high/low voltage levels.
HighLowTick | Configure CO output pulse according to its high/low tick level.

◆ COSignalExportSource

enum JYPCIe5111.COSignalExportSource

SourceSignal.

Enumerator
StartTrig | CI_StartTrig.
Output | CO_Output.

◆ COTimebaseSource

enum JYPCIe5111.COTimebaseSource

Timebase source.

Enumerator
Internal200MHz

Internal 200MHz Timebase.

◆ COTriggerType

enum JYPCIe5111.COTriggerType

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ CountDirection

enum JYPCIe5111.CountDirection

Counter direction.

enum Up/Down/External

Enumerator
Up | Counter increases.
Down | Counter decreases.
External | External signal control counter direction. If External signal is highlevel counter increases, or lowlevel counter decreases.

◆ DIDigitalTriggerEdge

enum JYPCIe5111.DIDigitalTriggerEdge

DI Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ DIDigitalTriggerSource

enum JYPCIe5111.DIDigitalTriggerSource

DI Digital trigger source.

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11.
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
AO_StartTrig | AO_StartTrig.
DO_StartTrig | DO_StartTrig.
CI0_StartTrig | CI0_StartTrig.
CI1_StartTrig | CI1_StartTrig.

◆ DIMode

enum JYPCIe5111.DIMode

DIMode.

Enumerator
Single | Single.
Finite | Finite.
Continuous | Continuous.

◆ DISampleClockSource

enum JYPCIe5111.DISampleClockSource

DI Sample Clock Source.

Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ DISignalExportSource

enum JYPCIe5111.DISignalExportSource

SourceSignal.

Enumerator
StartTrig | DI_StartTrig.
ReferenceTrig | DI_ReferenceTrig.
SampleClock | DI_SampleClock.

◆ DITriggerMode

enum JYPCIe5111.DITriggerMode

DI Trigger Mode.

Enumerator
Start | Start Trigger.
Reference | Reference Trigger，only for finite acquisition mode.

◆ DITriggerType

enum JYPCIe5111.DITriggerType

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ DODigitalTriggerEdge

enum JYPCIe5111.DODigitalTriggerEdge

DO Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ DODigitalTriggerSource

enum JYPCIe5111.DODigitalTriggerSource

DO Digital trigger source.

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11.
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
AO_StartTrig | AO_StartTrig.
DI_StartTrig | DI_StartTrig.
DI_ReferenceTrig | DI_ReferenceTrig.
CI0_StartTrig | CI0_StartTrig.
CI1_StartTrig | CI1_StartTrig.

◆ DOMode

enum JYPCIe5111.DOMode

DOMode.

Enumerator
Single | Single.
Finite | Finite.
ContinuousWrapping | ContinuousNoWrapping.
ContinuousNoWrapping | ContinuousWrapping.

◆ DOSampleClockSource

enum JYPCIe5111.DOSampleClockSource

DO Sample Clock Source.

Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ DOSignalExportSource

enum JYPCIe5111.DOSignalExportSource

SourceSignal.

Enumerator
StartTrig | DO_StartTrig.
SampleClock | DO_SampleClock.

◆ DOTriggerType

enum JYPCIe5111.DOTriggerType

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ EdgeCntOunEvtIdleState

enum JYPCIe5111.EdgeCntOunEvtIdleState

Output idle state when the event has not occurred.

Enumerator
LowLevel | Idle state is low level.
HighLevel | Idle state is high level.

◆ EdgeType

enum JYPCIe5111.EdgeType

Edge Type.

Enumerator
Rising | Rising Edge.
Falling | Falling Edge.

◆ FileFormat

enum JYPCIe5111.FileFormat

Streaming file format.

enum BIN.

Enumerator
Bin

BIN。

BIN.

◆ InputTerminal

enum JYPCIe5111.InputTerminal

Cunter Input Terminal.

Enumerator
Default | Default PFI pin by pin define.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
CI_0_OutPut | CI0_StartTrig.
CI_1_OutPut | CI1_StartTrig.
CI_2_OutPut | CI0_StartTrig.
CI_3_OutPut | CI1_StartTrig.

◆ IOTerminal

enum JYPCIe5111.IOTerminal

Cunter IO Terminal.

Enumerator
Default | Default PFI pin by pin define.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
None | None.

◆ LevelPolarity

enum JYPCIe5111.LevelPolarity

Level Polarity.

Enumerator
LowLevel | Low level.
HighLevel | High level.
None | No active polarity.

◆ OutputCompleteState

enum JYPCIe5111.OutputCompleteState

Output Complete State.

Enumerator
Zero | Output Complete Zero.
Hold | Output Complete Hold in The last point.

◆ QuadEncodingType

enum JYPCIe5111.QuadEncodingType

Quadrature Encoding Type.

Enumerator
X1 | X1.
X2 | X2.
X4 | X4.

◆ RecordMode

enum JYPCIe5111.RecordMode

stream mode .enum Finite/Infinite

Enumerator
Finite | Finite Streaming.
Infinite | Infinite Streaming.

◆ SignalExportDestination

enum JYPCIe5111.SignalExportDestination

Output DestinationTerminal.

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11.
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.


5111 C# Programming Manual: Package Members

  • Package List
  • Package Members
  • All
  • Enumerations
  • a
  • c
  • d
  • e
  • f
  • i
  • l
  • o
  • q
  • r
  • s
Here is a list of all namespace members with links to the namespace documentation for each member:

- a -

  • AIAnalogTriggerComparator : JYPCIe5111
  • AIAnalogTriggerEdge : JYPCIe5111
  • AIAnalogTriggerSource : JYPCIe5111
  • AIAnalogWindowCondition : JYPCIe5111
  • AIDigitalTriggerEdge : JYPCIe5111
  • AIDigitalTriggerSource : JYPCIe5111
  • AIMode : JYPCIe5111
  • AISampleClockSource : JYPCIe5111
  • AISignalExportSource : JYPCIe5111
  • AITerminal : JYPCIe5111
  • AITriggerMode : JYPCIe5111
  • AITriggerType : JYPCIe5111
  • AODigitalTriggerEdge : JYPCIe5111
  • AODigitalTriggerSource : JYPCIe5111
  • AOMode : JYPCIe5111
  • AOSampleClockSource : JYPCIe5111
  • AOSignalExportSource : JYPCIe5111
  • AOTriggerType : JYPCIe5111

- c -

  • CIDigitalTriggerEdge : JYPCIe5111
  • CIDigitalTriggerSource : JYPCIe5111
  • CIMode : JYPCIe5111
  • CISampleClockSource : JYPCIe5111
  • CISignalExportSource : JYPCIe5111
  • CITimebaseSource : JYPCIe5111
  • CITriggerType : JYPCIe5111
  • CIType : JYPCIe5111
  • ClockTerminal : JYPCIe5111
  • CODigitalTriggerEdge : JYPCIe5111
  • CODigitalTriggerSource : JYPCIe5111
  • COIdleState : JYPCIe5111
  • COMode : JYPCIe5111
  • COPulseType : JYPCIe5111
  • COSignalExportSource : JYPCIe5111
  • COTimebaseSource : JYPCIe5111
  • COTriggerType : JYPCIe5111
  • CountDirection : JYPCIe5111

- d -

  • DIDigitalTriggerEdge : JYPCIe5111
  • DIDigitalTriggerSource : JYPCIe5111
  • DIMode : JYPCIe5111
  • DISampleClockSource : JYPCIe5111
  • DISignalExportSource : JYPCIe5111
  • DITriggerMode : JYPCIe5111
  • DITriggerType : JYPCIe5111
  • DODigitalTriggerEdge : JYPCIe5111
  • DODigitalTriggerSource : JYPCIe5111
  • DOMode : JYPCIe5111
  • DOSampleClockSource : JYPCIe5111
  • DOSignalExportSource : JYPCIe5111
  • DOTriggerType : JYPCIe5111

- e -

  • EdgeCntOunEvtIdleState : JYPCIe5111
  • EdgeType : JYPCIe5111

- f -

  • FileFormat : JYPCIe5111

- i -

  • InputTerminal : JYPCIe5111
  • IOTerminal : JYPCIe5111

- l -

  • LevelPolarity : JYPCIe5111

- o -

  • OutputCompleteState : JYPCIe5111

- q -

  • QuadEncodingType : JYPCIe5111

- r -

  • RecordMode : JYPCIe5111

- s -

  • SignalExportDestination : JYPCIe5111


5111 C# Programming Manual: Package Members

  • Package List
  • Package Members
  • All
  • Enumerations
  • a
  • c
  • d
  • e
  • f
  • i
  • l
  • o
  • q
  • r
  • s
Here is a list of all namespace enums with links to the namespace documentation for each enum:

- a -

  • AIAnalogTriggerComparator : JYPCIe5111
  • AIAnalogTriggerEdge : JYPCIe5111
  • AIAnalogTriggerSource : JYPCIe5111
  • AIAnalogWindowCondition : JYPCIe5111
  • AIDigitalTriggerEdge : JYPCIe5111
  • AIDigitalTriggerSource : JYPCIe5111
  • AIMode : JYPCIe5111
  • AISampleClockSource : JYPCIe5111
  • AISignalExportSource : JYPCIe5111
  • AITerminal : JYPCIe5111
  • AITriggerMode : JYPCIe5111
  • AITriggerType : JYPCIe5111
  • AODigitalTriggerEdge : JYPCIe5111
  • AODigitalTriggerSource : JYPCIe5111
  • AOMode : JYPCIe5111
  • AOSampleClockSource : JYPCIe5111
  • AOSignalExportSource : JYPCIe5111
  • AOTriggerType : JYPCIe5111

- c -

  • CIDigitalTriggerEdge : JYPCIe5111
  • CIDigitalTriggerSource : JYPCIe5111
  • CIMode : JYPCIe5111
  • CISampleClockSource : JYPCIe5111
  • CISignalExportSource : JYPCIe5111
  • CITimebaseSource : JYPCIe5111
  • CITriggerType : JYPCIe5111
  • CIType : JYPCIe5111
  • ClockTerminal : JYPCIe5111
  • CODigitalTriggerEdge : JYPCIe5111
  • CODigitalTriggerSource : JYPCIe5111
  • COIdleState : JYPCIe5111
  • COMode : JYPCIe5111
  • COPulseType : JYPCIe5111
  • COSignalExportSource : JYPCIe5111
  • COTimebaseSource : JYPCIe5111
  • COTriggerType : JYPCIe5111
  • CountDirection : JYPCIe5111

- d -

  • DIDigitalTriggerEdge : JYPCIe5111
  • DIDigitalTriggerSource : JYPCIe5111
  • DIMode : JYPCIe5111
  • DISampleClockSource : JYPCIe5111
  • DISignalExportSource : JYPCIe5111
  • DITriggerMode : JYPCIe5111
  • DITriggerType : JYPCIe5111
  • DODigitalTriggerEdge : JYPCIe5111
  • DODigitalTriggerSource : JYPCIe5111
  • DOMode : JYPCIe5111
  • DOSampleClockSource : JYPCIe5111
  • DOSignalExportSource : JYPCIe5111
  • DOTriggerType : JYPCIe5111

- e -

  • EdgeCntOunEvtIdleState : JYPCIe5111
  • EdgeType : JYPCIe5111

- f -

  • FileFormat : JYPCIe5111

- i -

  • InputTerminal : JYPCIe5111
  • IOTerminal : JYPCIe5111

- l -

  • LevelPolarity : JYPCIe5111

- o -

  • OutputCompleteState : JYPCIe5111

- q -

  • QuadEncodingType : JYPCIe5111

- r -

  • RecordMode : JYPCIe5111

- s -

  • SignalExportDestination : JYPCIe5111


5111 C# Programming Manual: Package List

  • Package List
  • Package Members
Package List
Here are the packages with brief descriptions (if available):
N JYPCIe5111