5112 C++ Programming Manual: D:/5112/C++/JYPCIe5112.h File Reference

5112 C++ Programming Manual
  • Main Page
  • Files
  • File List
  • File Members
  • 5112
  • C++
Typedefs | Enumerations | Functions
JYPCIe5112.h File Reference

@SectionBegin JYPCIe5112 FileHead More...

Typedefs

typedef void * JYPCIe5112_DeviceHandle
@SectionEnd JYPCIe5112_Device FileHead

Enumerations

enum | JYPCIe5112_AI_SampleMode { JYPCIe5112_AI_Finite = 0x0 , JYPCIe5112_AI_Continuous = 0x1 , JYPCIe5112_AI_Single = 0x2 }
enum | JYPCIe5112_AI_Terminal { JYPCIe5112_AI_RSE = 0x0 , JYPCIe5112_AI_NRSE = 0x1 , JYPCIe5112_AI_Diff = 0x2 }
enum | JYPCIe5112_AO_UpdateMode { JYPCIe5112_AO_Finite = 0x0 , JYPCIe5112_AO_ContinuousWrapping = 0x1 , JYPCIe5112_AO_ContinuousNoWrapping = 0x2 , JYPCIe5112_AO_Single = 0x3 }
enum | JYPCIe5112_TriggerMode { JYPCIe5112_StartTrigger = 0x0 , JYPCIe5112_ReferenceTrigger = 0x1 }
enum | JYPCIe5112_AI_TriggerType { JYPCIe5112_AI_Immediately = 0x0 , JYPCIe5112_AI_Digital = 0x1 , JYPCIe5112_AI_Analog = 0x2 , JYPCIe5112_AI_Soft = 0x3 }
enum | JYPCIe5112_AO_TriggerType { JYPCIe5112_AO_Immediately = 0x0 , JYPCIe5112_AO_Digital = 0x1 , JYPCIe5112_AO_Soft = 0x3 }
enum | JYPCIe5112_CIO_TriggerType { JYPCIe5112_CIO_Immediately = 0x0 , JYPCIe5112_CIO_Digital = 0x1 , JYPCIe5112_CIO_Soft = 0x3 }
enum | JYPCIe5112_OutputCompleteState { JYPCIe5112_Zero = 0x0 , JYPCIe5112_Hold = 0x1 }
enum | JYPCIe5112_DigitalTriggerEdge { JYPCIe5112_Rising = 0x0 , JYPCIe5112_Falling = 0x1 }
enum JYPCIe5112_DigitalTriggerSource {
JYPCIe5112_DigitalTrigger_PFI0 = 0 , JYPCIe5112_DigitalTrigger_PFI1 = 1 , JYPCIe5112_DigitalTrigger_PFI2 = 2 , JYPCIe5112_DigitalTrigger_PFI3 = 3 ,
JYPCIe5112_DigitalTrigger_PFI4 = 4 , JYPCIe5112_DigitalTrigger_PFI5 = 5 , JYPCIe5112_DigitalTrigger_PFI6 = 6 , JYPCIe5112_DigitalTrigger_PFI7 = 7 ,
JYPCIe5112_DigitalTrigger_PFI8 = 8 , JYPCIe5112_DigitalTrigger_PFI9 = 9 , JYPCIe5112_DigitalTrigger_PFI10 = 10 , JYPCIe5112_DigitalTrigger_PFI11 = 11 ,
JYPCIe5112_DigitalTrigger_PFI12 = 12 , JYPCIe5112_DigitalTrigger_PFI13 = 13 , JYPCIe5112_DigitalTrigger_PFI14 = 14 , JYPCIe5112_DigitalTrigger_PFI15 = 15 ,
JYPCIe5112_DigitalTrigger_PXI_Trig0 = 16 , JYPCIe5112_DigitalTrigger_PXI_Trig1 = 17 , JYPCIe5112_DigitalTrigger_PXI_Trig2 = 18 , JYPCIe5112_DigitalTrigger_PXI_Trig3 = 19 ,
JYPCIe5112_DigitalTrigger_PXI_Trig4 = 20 , JYPCIe5112_DigitalTrigger_PXI_Trig5 = 21 , JYPCIe5112_DigitalTrigger_PXI_Trig6 = 22 , JYPCIe5112_DigitalTrigger_PXI_Trig7 = 23 ,
JYPCIe5112_DigitalTrigger_Inter_AI_StartTrig = 24 , JYPCIe5112_DigitalTrigger_Inter_AI_ReferenceTrig = 25 , JYPCIe5112_DigitalTrigger_Inter_AO_StartTrig = 26 , JYPCIe5112_DigitalTrigger_Inter_CIO_0_StartTrig = 27 ,
JYPCIe5112_DigitalTrigger_Inter_CIO_1_StartTrig = 28 , JYPCIe5112_DigitalTrigger_Inter_CO_0_Output = 29 , JYPCIe5112_DigitalTrigger_Inter_CO_1_Output = 30
}
enum | JYPCIe5112_AnalogWindowCondition { JYPCIe5112_Entering = 0x0 , JYPCIe5112_Leaving = 0x1 }
enum | JYPCIe5112_AnalogTriggerEdge { JYPCIe5112_RisingSlope = 0x0 , JYPCIe5112_FallingSlope = 0x1 }
enum JYPCIe5112_AnalogTriggerSource {
JYPCIe5112_Channel_0 = 0x0 , JYPCIe5112_Channel_1 = 0x1 , JYPCIe5112_Channel_2 = 0x2 , JYPCIe5112_Channel_3 = 0x3 ,
JYPCIe5112_Channel_4 = 0x4 , JYPCIe5112_Channel_5 = 0x5 , JYPCIe5112_Channel_6 = 0x6 , JYPCIe5112_Channel_7 = 0x7 ,
JYPCIe5112_Channel_8 = 0x8 , JYPCIe5112_Channel_9 = 0x9 , JYPCIe5112_Channel_10 = 0xA , JYPCIe5112_Channel_11 = 0xB ,
JYPCIe5112_Channel_12 = 0xC , JYPCIe5112_Channel_13 = 0xD , JYPCIe5112_Channel_14 = 0xE , JYPCIe5112_Channel_15 = 0xF
}
enum | JYPCIe5112_ClockSource { JYPCIe5112_InternalClock = 0x0 , JYPCIe5112_ExternalClock = 0x1 }
enum JYPCIe5112_ExternalClockTerminal {
JYPCIe5112_Clock_PFI0_IN = 0x0 , JYPCIe5112_Clock_PFI1_IN = 0x1 , JYPCIe5112_Clock_PFI2_IN = 0x2 , JYPCIe5112_Clock_PFI3_IN = 0x3 ,
JYPCIe5112_Clock_PFI4_IN = 0x4 , JYPCIe5112_Clock_PFI5_IN = 0x5 , JYPCIe5112_Clock_PFI6_IN = 0x6 , JYPCIe5112_Clock_PFI7_IN = 0x7 ,
JYPCIe5112_Clock_PFI8_IN = 0x8 , JYPCIe5112_Clock_PFI9_IN = 0x9 , JYPCIe5112_Clock_PFI10_IN = 0xA , JYPCIe5112_Clock_PFI11_IN = 0xB ,
JYPCIe5112_Clock_PFI12_IN = 0xC , JYPCIe5112_Clock_PFI13_IN = 0xD , JYPCIe5112_Clock_PFI14_IN = 0xE , JYPCIe5112_Clock_PFI15_IN = 0xF ,
JYPCIe5112_Clock_PXI_Trig0_IN = 16 , JYPCIe5112_Clock_PXI_Trig1_IN = 17 , JYPCIe5112_Clock_PXI_Trig2_IN = 18 , JYPCIe5112_Clock_PXI_Trig3_IN = 19 ,
JYPCIe5112_Clock_PXI_Trig4_IN = 20 , JYPCIe5112_Clock_PXI_Trig5_IN = 21 , JYPCIe5112_Clock_PXI_Trig6_IN = 22 , JYPCIe5112_Clock_PXI_Trig7_IN = 23 ,
JYPCIe5112_Clock_Inter_AI_SampleClock = 24 , JYPCIe5112_Clock_Inter_AO_SampleClock = 25 , JYPCIe5112_Clock_Inter_CO_0_Output = 26 , JYPCIe5112_Clock_Inter_CO_1_Output = 27 ,
JYPCIe5112_Clock_Default = 28
}
enum JYPCIe5112_InputTerminal {
JYPCIe5112_Input_PFI0 = 0 , JYPCIe5112_Input_PFI1 = 1 , JYPCIe5112_Input_PFI2 = 2 , JYPCIe5112_Input_PFI3 = 3 ,
JYPCIe5112_Input_PFI4 = 4 , JYPCIe5112_Input_PFI5 = 5 , JYPCIe5112_Input_PFI6 = 6 , JYPCIe5112_Input_PFI7 = 7 ,
JYPCIe5112_Input_PFI8 = 8 , JYPCIe5112_Input_PFI9 = 9 , JYPCIe5112_Input_PFI10 = 10 , JYPCIe5112_Input_PFI11 = 11 ,
JYPCIe5112_Input_PFI12 = 12 , JYPCIe5112_Input_PFI13 = 13 , JYPCIe5112_Input_PFI14 = 14 , JYPCIe5112_Input_PFI15 = 15 ,
JYPCIe5112_Input_PXI_Trig0 = 16 , JYPCIe5112_Input_PXI_Trig1 = 17 , JYPCIe5112_Input_PXI_Trig2 = 18 , JYPCIe5112_Input_PXI_Trig3 = 19 ,
JYPCIe5112_Input_PXI_Trig4 = 20 , JYPCIe5112_Input_PXI_Trig5_ = 21 , JYPCIe5112_Input_PXI_Trig6 = 22 , JYPCIe5112_Input_PXI_Trig7 = 23 ,
JYPCIe5112_Input_CO_0_Out = 24 , JYPCIe5112_Input_CO_1_Out = 25 , JYPCIe5112_Input_CIO_100MHz = 26 , JYPCIe5112_Input_CIO_5MHz = 27 ,
JYPCIe5112_Input_CIO_100KHz = 28
}
enum | JYPCIe5112_CountTimeBase { JYPCIe5112_Internal_Timebase_100M , JYPCIe5112_Internal_Timebase_5M , JYPCIe5112_Internal_Timebase_100K , JYPCIe5112_External_Timebase }
enum JYPCIe5112_CI_MeasureType {
JYPCIe5112_CI_EdgeCount = 0 , JYPCIe5112_CI_Measure_FrequencyOrPeriod = 1 , JYPCIe5112_CI_Measure_PulseWidth = 2 , JYPCIe5112_CI_Measure_SemiPeriod = 3 ,
JYPCIe5112_CI_Measure_EdgeSeparation = 4 , JYPCIe5112_CI_EncoderX1 = 5 , JYPCIe5112_CI_EncoderX2 = 6 , JYPCIe5112_CI_EncoderX4 = 7 ,
JYPCIe5112_CI_EncoderTwoPulse = 8
}
enum | JYPCIe5112_CountDirection { JYPCIe5112_CI_Count_Up , JYPCIe5112_CI_Count_Down , JYPCIe5112_CI_Count_External }
enum | JYPCIe5112_CI_SampleClock { JYPCIe5112_CI_ImplicitClock , JYPCIe5112_CI_InternalClock , JYPCIe5112_CI_ExternalClock }
enum | JYPCIe5112_CI_CounterEventSignalIdleState { JYPCIe5112_CI_CounterEventSignalIdleState_Low = 0 , JYPCIe5112_CI_CounterEventSignalIdleState_High = 1 }
enum | JYPCIe5112_CI_ValueReturnMode { JYPCIe5112_CI_ReturnTwoValue = 0 , JYPCIe5112_CI_ReturnOneValue = 1 }
enum | JYPCIe5112_LevelState { JYPCIe5112_LowLevel = 0 , JYPCIe5112_HighLevel = 1 }
enum | JYPCIe5112_CO_PauseTriger_OutState { JYPCIe5112_CO_HoldOn = 0x0 , JYPCIe5112_CO_HighOut = 0x1 , JYPCIe5112_CO_LowOut = 0x2 }
enum | JYPCIe5112_CI_StartingEdge { JYPCIe5112_RisingEdge = 0 , JYPCIe5112_FallingEdge = 1 , JYPCIe5112_AnyEdge = 2 }
enum | JYPCIe5112_CO_IdleState { JYPCIe5112_CO_LowLevel = 0 , JYPCIe5112_CO_HighLevel = 1 }
enum JYPCIe5112_Signal_Source {
JYPCIe5112_AI_StartTrig = 0 , JYPCIe5112_AI_ReferenceTrig = 1 , JYPCIe5112_AO_StartTrig = 2 , JYPCIe5112_CIO_0_StartTrig = 3 ,
JYPCIe5112_CIO_1_StartTrig = 4 , JYPCIe5112_AI_SampleClock = 5 , JYPCIe5112_AO_SampleClock = 6 , JYPCIe5112_CO_0_Output = 7 ,
JYPCIe5112_CO_1_Output = 8
}
enum JYPCIe5112_Signal_Destination {
JYPCIe5112_PFI0_OUT = 0 , JYPCIe5112_PFI1_OUT = 1 , JYPCIe5112_PFI2_OUT = 2 , JYPCIe5112_PFI3_OUT = 3 ,
JYPCIe5112_PFI4_OUT = 4 , JYPCIe5112_PFI5_OUT = 5 , JYPCIe5112_PFI6_OUT = 6 , JYPCIe5112_PFI7_OUT = 7 ,
JYPCIe5112_PFI8_OUT = 8 , JYPCIe5112_PFI9_OUT = 9 , JYPCIe5112_PFI10_OUT = 10 , JYPCIe5112_PFI11_OUT = 11 ,
JYPCIe5112_PFI12_OUT = 12 , JYPCIe5112_PFI13_OUT = 13 , JYPCIe5112_PFI14_OUT = 14 , JYPCIe5112_PFI15_OUT = 15 ,
JYPCIe5112_PXITrig0_OUT = 16 , JYPCIe5112_PXITrig1_OUT = 17 , JYPCIe5112_PXITrig2_OUT = 18 , JYPCIe5112_PXITrig3_OUT = 19 ,
JYPCIe5112_PXITrig4_OUT = 20 , JYPCIe5112_PXITrig5_OUT = 21 , JYPCIe5112_PXITrig6_OUT = 22 , JYPCIe5112_PXITrig7_OUT = 23 ,
JYPCIe5112_None = 24
}

Functions

JYPCIe5112API int | JYPCIe5112_Open (int slotNumber, JYPCIe5112_DeviceHandle *hDevice)
Open the 5112 board using the slot number or the board serial number.
JYPCIe5112API int | JYPCIe5112_OpenByName (const char *cardName, JYPCIe5112_DeviceHandle *hDevice)
Open this 5112 board using the board alias name which is set by JYTEK utility JYDM.
JYPCIe5112API int | JYPCIe5112_Close (JYPCIe5112_DeviceHandle hDevice)
Close 5112 board.
JYPCIe5112API int | JYPCIe5112_SignalRouting (JYPCIe5112_DeviceHandle hDevice, JYPCIe5112_Signal_Source source, JYPCIe5112_Signal_Destination destination)
Route a singal from source to destination.
JYPCIe5112API int | JYPCIe5112_DisconnectSignalRouting (JYPCIe5112_DeviceHandle hDevice, JYPCIe5112_Signal_Source source, JYPCIe5112_Signal_Destination destination)
Disconnect an established routing.
JYPCIe5112API int | JYPCIe5112_GetDeviceID (JYPCIe5112_DeviceHandle hDevice, int *deviceID)
Obtain the device ID.
JYPCIe5112API int | JYPCIe5112_GetDeviceSerialNumber (JYPCIe5112_DeviceHandle hDevice, char *serialNumber, int length)
Obtain the device serialNumber.
JYPCIe5112API int | JYPCIe5112_SetDeviceStatusLed (JYPCIe5112_DeviceHandle hDevice, bool enable, unsigned int frequency)
Control Front Panel Status Led.
JYPCIe5112API int | JYPCIe5112_AI_EnableChannel (JYPCIe5112_DeviceHandle hDevice, unsigned int channelCount, unsigned char *channels, double *lowRegion, double *highRegion, JYPCIe5112_AI_Terminal *terminal)
Enable AI channels.
JYPCIe5112API int | JYPCIe5112_AI_SetMode (JYPCIe5112_DeviceHandle hDevice, JYPCIe5112_AI_SampleMode mode)
Set AI sampling mode.
JYPCIe5112API int | JYPCIe5112_AI_SetSampleRate (JYPCIe5112_DeviceHandle hDevice, double sampleRate, double *actualSampleRate)
Set sampling rate.
JYPCIe5112API int | JYPCIe5112_AI_SetScanRate (JYPCIe5112_DeviceHandle hDevice, double scanRate, double *actualScanRate)
Set convert rate.
JYPCIe5112API int | JYPCIe5112_AI_SetSamplesToAcquire (JYPCIe5112_DeviceHandle hDevice, unsigned int sampleToAcquire)
Set AI samples to acquire for each channel in finite mode.The samples range is 1 to 64M samples / channelCount.
JYPCIe5112API int | JYPCIe5112_AI_Start (JYPCIe5112_DeviceHandle hDevice)
Start AI acquisition.
JYPCIe5112API int | JYPCIe5112_AI_ReadData (JYPCIe5112_DeviceHandle hDevice, double *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
Read AI data to user defined data buffer.
JYPCIe5112API int | JYPCIe5112_AI_Stop (JYPCIe5112_DeviceHandle hDevice)
Stop AI acquisition.
JYPCIe5112API int | JYPCIe5112_AI_ReadRawData (JYPCIe5112_DeviceHandle hDevice, short *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
Read AI raw data to user defined data buffer.
JYPCIe5112API int | JYPCIe5112_AI_SetSampleClock (JYPCIe5112_DeviceHandle hDevice, JYPCIe5112_ClockSource clockSource, JYPCIe5112_ExternalClockTerminal terminal, double expectedRate)
Set AI sampling clock source.
JYPCIe5112API int | JYPCIe5112_AI_ReadSinglePoint (JYPCIe5112_DeviceHandle hDevice, double *readValue, int channelID)
Read single point for each channel to user defined data buffer.
JYPCIe5112API int | JYPCIe5112_AI_ReadRawSinglePoint (JYPCIe5112_DeviceHandle hDevice, short *readValue, int channelID)
Read raw single point for each channel to user defined data buffer.
JYPCIe5112API int | JYPCIe5112_AI_SetStartTriggerType (JYPCIe5112_DeviceHandle hDevice, JYPCIe5112_AI_TriggerType triggerType)
Set AI start trigger type,the triggerType is defined by enum JYPCIe5112_AI_TriggerType.
JYPCIe5112API int | JYPCIe5112_AI_SetDigitalStartTrigger (JYPCIe5112_DeviceHandle hDevice, JYPCIe5112_DigitalTriggerSource triggerSource, JYPCIe5112_DigitalTriggerEdge triggerEdge)
Set AI digital start trigger,the triggerSource is defined by enum JYPCIe5112_DigitalTriggerSource, the triggerEdge is defined by enum JYPCIe5112_DigitalTriggerEdge.
JYPCIe5112API int | JYPCIe5112_AI_SetAnalogWindowStartTrigger (JYPCIe5112_DeviceHandle hDevice, JYPCIe5112_AnalogTriggerSource triggerSource, JYPCIe5112_AnalogWindowCondition triggerCondition, double highThreshold, double lowThreshold)
Set AI analog window start trigger,the triggerSource is defined by enum JYPCIe5112_AnalogTriggerSource, the triggerCondition is defined by enum JYPCIe5112_AnalogWindowCondition.
JYPCIe5112API int | JYPCIe5112_AI_SetAnalogHysteresisStartTrigger (JYPCIe5112_DeviceHandle hDevice, JYPCIe5112_AnalogTriggerSource triggerSource, JYPCIe5112_AnalogTriggerEdge triggerEdge, double highThreshold, double lowThreshold)
Set AI analog hysteresis start trigger,the triggerSource is defined by enum JYPCIe5112_AnalogTriggerSource, the triggerEdge is defined by enum JYPCIe5112_AnalogTriggerEdge.
JYPCIe5112API int | JYPCIe5112_AI_SetAnalogEdgeStartTrigger (JYPCIe5112_DeviceHandle hDevice, JYPCIe5112_AnalogTriggerSource triggerSource, JYPCIe5112_AnalogTriggerEdge triggerEdge, double threshold)
Set AI analog edge window start trigger,the triggerSource is defined by enum JYPCIe5112_AnalogTriggerSource, the triggerEdge is defined by enum JYPCIe5112_AnalogTriggerEdge.
JYPCIe5112API int | JYPCIe5112_AI_SetReferenceTriggerType (JYPCIe5112_DeviceHandle hDevice, JYPCIe5112_AI_TriggerType triggerType)
Set AI reference trigger type,the triggerType is defined by enum JYPCIe5112_AI_TriggerType.
JYPCIe5112API int | JYPCIe5112_AI_SetDigitalReferenceTrigger (JYPCIe5112_DeviceHandle hDevice, JYPCIe5112_DigitalTriggerSource triggerSource, JYPCIe5112_DigitalTriggerEdge triggerEdge)
Set AI digital reference trigger.the triggerSource is defined by enum JYPCIe5112_DigitalTriggerSource, the triggerEdge is defined by enum JYPCIe5112_DigitalTriggerEdge.
JYPCIe5112API int | JYPCIe5112_AI_SetAnalogWindowReferenceTrigger (JYPCIe5112_DeviceHandle hDevice, JYPCIe5112_AnalogTriggerSource triggerSource, JYPCIe5112_AnalogWindowCondition triggerCondition, double highThreshold, double lowThreshold)
Set AI analog reference trigger,the triggerSource is defined by enum JYPCIe5112_AnalogTriggerSource, the triggerCondition is defined by enum JYPCIe5112_AnalogTriggerCondition.
JYPCIe5112API int | JYPCIe5112_AI_SetAnalogHysteresisReferenceTrigger (JYPCIe5112_DeviceHandle hDevice, JYPCIe5112_AnalogTriggerSource triggerSource, JYPCIe5112_AnalogTriggerEdge triggerEdge, double highThreshold, double lowThreshold)
Set AI analog hysteresis reference trigger,the triggerSource is defined by enum JYPCIe5112_AnalogTriggerSource, the triggerEdge is defined by enum JYPCIe5112_AnalogTriggerEdge.
JYPCIe5112API int | JYPCIe5112_AI_SetAnalogEdgeReferenceTrigger (JYPCIe5112_DeviceHandle hDevice, JYPCIe5112_AnalogTriggerSource triggerSource, JYPCIe5112_AnalogTriggerEdge triggerEdge, double threshold)
Set AI analog edge window reference trigger,the triggerSource is defined by enum JYPCIe5112_AnalogTriggerSource, the triggerEdge is defined by enum JYPCIe5112_AnalogTriggerEdge.
JYPCIe5112API int | JYPCIe5112_AI_SetPreTriggerSamples (JYPCIe5112_DeviceHandle hDevice, unsigned int preTriggerSamples)
Set AI pretrigger samples, the samples must greater than 0.
JYPCIe5112API int | JYPCIe5112_AI_SetReTriggerCount (JYPCIe5112_DeviceHandle hDevice, unsigned long long reTriggerCount)
Set AI retrigger count.
JYPCIe5112API int | JYPCIe5112_AI_SendSoftTrigger (JYPCIe5112_DeviceHandle hDevice, JYPCIe5112_TriggerMode triggerMode)
Send the software trigger signal for AI.
JYPCIe5112API int | JYPCIe5112_AI_WaitUntilDone (JYPCIe5112_DeviceHandle hDevice, bool *done)
Check if AI acquisition is completed in finite mode.
JYPCIe5112API int | JYPCIe5112_AI_CheckBufferStatus (JYPCIe5112_DeviceHandle hDevice, unsigned long long *avaliableSamples, unsigned long long *transferedSamples, bool *overrun)
Check AI device buffer status.
JYPCIe5112API int | JYPCIe5112_DI_AddLines (JYPCIe5112_DeviceHandle hDevice, unsigned int *port, unsigned int portCount)
Enabled DI channels.
JYPCIe5112API int | JYPCIe5112_DI_ReadSinglePoint (JYPCIe5112_DeviceHandle hDevice, bool *readValues, int portID)
read single data from a single port by portID defined.if the portID == -1,read all port data.The data type is bool, one bool defined one line status.
JYPCIe5112API int | JYPCIe5112_DI_ReadSinglePoint_U8 (JYPCIe5112_DeviceHandle hDevice, unsigned char *readValues, int portID)
read single data from a single port by portID defined.if the portID == -1,read all port data.The data type is unsigned char, one char defined one port status.
JYPCIe5112API int | JYPCIe5112_DI_ReadSinglePoint_U32 (JYPCIe5112_DeviceHandle hDevice, unsigned long *readValue)
read single data from a single port by portID defined.if the portID == -1,read all port data.The data type is unsigned long long,There are 6 ports, from 0 to 5.
JYPCIe5112API int | JYPCIe5112_DI_Start (JYPCIe5112_DeviceHandle hDevice)
Start DI acquisition.
JYPCIe5112API int | JYPCIe5112_DI_Stop (JYPCIe5112_DeviceHandle hDevice)
Stop DI acquisition.
JYPCIe5112API int | JYPCIe5112_DO_AddLines (JYPCIe5112_DeviceHandle hDevice, unsigned int *port, unsigned int portCount)
Enabled DO channels.
JYPCIe5112API int | JYPCIe5112_DO_WriteSinglePoint (JYPCIe5112_DeviceHandle hDevice, bool *writeValues, int portID)
write single data to the port by portID defined.if the portID == -1,write all port data.
JYPCIe5112API int | JYPCIe5112_DO_WriteSinglePoint_U8 (JYPCIe5112_DeviceHandle hDevice, unsigned char *writeValue, int portID)
write single data to the port by portID defined.if the portID == -1,write all port data.The data type is unsigned char, one char defined one port status.
JYPCIe5112API int | JYPCIe5112_DO_WriteSinglePoint_U32 (JYPCIe5112_DeviceHandle hDevice, unsigned long writeValues)
write single data to the port by portID defined.if the portID == -1,write all port data.The data type is unsigned long long,There are 6 ports, from 0 to 5.
JYPCIe5112API int | JYPCIe5112_DO_Start (JYPCIe5112_DeviceHandle hDevice)
Start DO output.
JYPCIe5112API int | JYPCIe5112_DO_Stop (JYPCIe5112_DeviceHandle hDevice)
Stop DO output.
JYPCIe5112API int | JYPCIe5112_AO_EnableChannel (JYPCIe5112_DeviceHandle hDevice, unsigned int channelCount, unsigned char *channels, double *lowRegion, double *highRegion)
Enables AO output channels.
JYPCIe5112API int | JYPCIe5112_AO_SetUpdateRate (JYPCIe5112_DeviceHandle hDevice, double updateRate, double *actualUpdateRate)
Set AO update rate for each channel.
JYPCIe5112API int | JYPCIe5112_AO_SetMode (JYPCIe5112_DeviceHandle hDevice, JYPCIe5112_AO_UpdateMode mode)
Set AO output mode, the mode defined by enum JYPCIe5112_AO_UpdateMode.
JYPCIe5112API int | JYPCIe5112_AO_SetSamplesToUpdate (JYPCIe5112_DeviceHandle hDevice, unsigned int sampleToUpdate)
Set AO samples to output for each channel in the finite mode.The sample range is from 1 to 32M / channelCount samples.
JYPCIe5112API int | JYPCIe5112_AO_Start (JYPCIe5112_DeviceHandle hDevice)
Start AO output.
JYPCIe5112API int | JYPCIe5112_AO_WriteRawData (JYPCIe5112_DeviceHandle hDevice, short *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualWriteLength)
AO write raw data.The data is interleaved in the buffer in channel order for multi-channel.
JYPCIe5112API int | JYPCIe5112_AO_WriteData (JYPCIe5112_DeviceHandle hDevice, double *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualWriteLength)
AO writes data.The data is interleaved in the buffer the order defined by JYPCIe5112_AO_EnableChannel.
JYPCIe5112API int | JYPCIe5112_AO_Stop (JYPCIe5112_DeviceHandle hDevice)
Stop AO output.
JYPCIe5112API int | JYPCIe5112_AO_SetSampleClock (JYPCIe5112_DeviceHandle hDevice, JYPCIe5112_ClockSource clockSource, JYPCIe5112_ExternalClockTerminal terminal, double expectedRate)
Set AO sampling clock source.
JYPCIe5112API int | JYPCIe5112_AO_WriteSinglePoint (JYPCIe5112_DeviceHandle hDevice, double *writeValues, int channelID)
AO write single point data to the defined channel by channelID, if channelID == -1, write all enable channel.
JYPCIe5112API int | JYPCIe5112_AO_WriteRawSinglePoint (JYPCIe5112_DeviceHandle hDevice, short *writeValues, int channelID)
AO write single point raw data to the defined channel by channelID, if channelID == -1, write all enable channel.
JYPCIe5112API int | JYPCIe5112_AO_SetStartTriggerType (JYPCIe5112_DeviceHandle hDevice, JYPCIe5112_AO_TriggerType triggerTyp)
Set AO start trigger type,the triggerType is defined by enum JYPCIe5112_AO_TriggerType.
JYPCIe5112API int | JYPCIe5112_AO_SetDigitalStartTrigger (JYPCIe5112_DeviceHandle hDevice, JYPCIe5112_DigitalTriggerSource triggerSource, JYPCIe5112_DigitalTriggerEdge triggerEdge)
Set AO digital start trigger,the triggerSource is defined by enum JYPCIe5112_DigitalTriggerSource, the triggerEdge is defined by enum JYPCIe5112_DigitalTriggerEdge.
JYPCIe5112API int | JYPCIe5112_AO_WaitUntilDone (JYPCIe5112_DeviceHandle hDevice, bool *done, int timeOut)
Check AO finite output is complete.
JYPCIe5112API int | JYPCIe5112_AO_CheckBufferStatus (JYPCIe5112_DeviceHandle hDevice, unsigned long *availableSamples, unsigned long long *transferedSamples, bool *overrun)
Check AO device buffer status.
JYPCIe5112API int | JYPCIe5112_AO_SendSoftTrigger (JYPCIe5112_DeviceHandle hDevice)
Send the software trigger signal for AO.
JYPCIe5112API int | JYPCIe5112_AO_SetOutputCompleteState (JYPCIe5112_DeviceHandle hDevice, JYPCIe5112_OutputCompleteState State)
Set AO Output complete state, Default is Hold.
JYPCIe5112API int | JYPCIe5112_CI_EnableChannel (JYPCIe5112_DeviceHandle hDevice, unsigned int channel)
Enables CI channel.
JYPCIe5112API int | JYPCIe5112_CI_SetCounterType (JYPCIe5112_DeviceHandle hDevice, unsigned int channel, JYPCIe5112_CI_MeasureType measureType)
Set CI measure type.
JYPCIe5112API int | JYPCIe5112_CI_SetSignalReverse (JYPCIe5112_DeviceHandle hDevice, unsigned int channel, int signalReverse)
Set the Signal Reverse terminal.
JYPCIe5112API int | JYPCIe5112_CI_SetCounterParament (JYPCIe5112_DeviceHandle hDevice, unsigned int channel, int initCount, JYPCIe5112_CountDirection countDirection)
Set CI count parameter.
JYPCIe5112API int | JYPCIe5112_CI_SetZReloadEnabled (JYPCIe5112_DeviceHandle hDevice, unsigned int channel, bool zReloadEnabled)
Set the Z signal enable in Encoder mode.
JYPCIe5112API int | JYPCIe5112_CI_SetEdgeCountEvent (JYPCIe5112_DeviceHandle hDevice, unsigned int channel, JYPCIe5112_CI_CounterEventSignalIdleState idleState, unsigned int threshold)
Set the counter threshold, and when the count reaches this threshold, output a single pulse at the output terminal.
JYPCIe5112API int | JYPCIe5112_CI_SetPauseTriggerLevel (JYPCIe5112_DeviceHandle hDevice, unsigned int channel, bool enable, JYPCIe5112_LevelState pauseTriggerActiveLevel)
Config CI pause trigger.
JYPCIe5112API int | JYPCIe5112_CI_SetPauseTriggerTerminal (JYPCIe5112_DeviceHandle hDevice, int channel, JYPCIe5112_InputTerminal pauseTriggerTerminal)
Set CI pause trigger terminal.
JYPCIe5112API int | JYPCIe5112_CI_ReadSingleCountValue (JYPCIe5112_DeviceHandle hDevice, unsigned int channel, unsigned int *countValue)
Counter reads a single count value, this API supports the CI Type: JYPCIe5112_CI_EdgeCount、JYPCIe5112_CI_EncoderX1、 JYPCIe5112_CI_EncoderX2 、 JYPCIe5112_CI_EncoderX4 、JYPCIe5112_CI_EncoderTwoPulse.
JYPCIe5112API int | JYPCIe5112_CI_ReadSingleMeasureValue (JYPCIe5112_DeviceHandle hDevice, unsigned int channel, double *measureValue1, double *measureValue2, int timeOut)
Reads a single counter measurement as follows.
JYPCIe5112API int | JYPCIe5112_CI_Start (JYPCIe5112_DeviceHandle hDevice, unsigned int channel)
Start Counter input.
JYPCIe5112API int | JYPCIe5112_CI_Stop (JYPCIe5112_DeviceHandle hDevice, unsigned int channel)
Stop Counter input.
JYPCIe5112API int | JYPCIe5112_CI_SetTimeBase (JYPCIe5112_DeviceHandle hDevice, unsigned int channel, JYPCIe5112_CountTimeBase timebaseSrc, JYPCIe5112_InputTerminal externalTimebaseTerminal, double externalTimebaseFreq, double *actualTimebaseFreq)
Set CI timebase source.
JYPCIe5112API int | JYPCIe5112_CI_SendSoftTrigger (JYPCIe5112_DeviceHandle hDevice, int channel)
Send the software trigger signal for CI.
JYPCIe5112API int | JYPCIe5112_CI_SetStartTriggerType (JYPCIe5112_DeviceHandle hDevice, int channel, JYPCIe5112_CIO_TriggerType triggerTyp)
Set CI start trigger type,the triggerType is defined by enum JYPCIe5112_DI_TriggerType.
JYPCIe5112API int | JYPCIe5112_CI_SetDigitalStartTrigger (JYPCIe5112_DeviceHandle hDevice, int channel, JYPCIe5112_DigitalTriggerSource triggerSource, JYPCIe5112_DigitalTriggerEdge triggerEdge)
Set CI digital start trigger.the triggerSource is defined by enum JYPCIe5112_DigitalTriggerSource, the triggerEdge is defined by enum JYPCIe5112_DigitalTriggerEdge.
JYPCIe5112API int | JYPCIe5112_CI_SetSourceTerminal (JYPCIe5112_DeviceHandle hDevice, int channel, JYPCIe5112_InputTerminal sourceTerminal)
Set source terminal.
JYPCIe5112API int | JYPCIe5112_CI_SetValueReturnMode (JYPCIe5112_DeviceHandle hDevice, unsigned int channel, JYPCIe5112_CI_ValueReturnMode mode)
Config CI return value mode, only for JYPCIe5112_CI_Measure_EdgeSeparation type.
JYPCIe5112API int | JYPCIe5112_CI_SetStartingEdge (JYPCIe5112_DeviceHandle hDevice, unsigned int channel, JYPCIe5112_CI_StartingEdge startingEdge)
Set start measure edge.
JYPCIe5112API int | JYPCIe5112_CI_SetFirstSampleClock (JYPCIe5112_DeviceHandle hDevice, unsigned int channel, bool ignore)
Set first sample clock is ignore.
JYPCIe5112API int | JYPCIe5112_CI_SetGateTerminal (JYPCIe5112_DeviceHandle hDevice, int channel, JYPCIe5112_InputTerminal gateTerminal)
Set gate terminal.
JYPCIe5112API int | JYPCIe5112_CI_SetAuxTerminal (JYPCIe5112_DeviceHandle hDevice, int channel, JYPCIe5112_InputTerminal auxTerminal)
Set aux terminal.
JYPCIe5112API int | JYPCIe5112_CI_SetOutTerminal (JYPCIe5112_DeviceHandle hDevice, int channel, JYPCIe5112_Signal_Destination outTerminal)
Set out terminal.
JYPCIe5112API int | JYPCIe5112_CO_EnableChannel (JYPCIe5112_DeviceHandle hDevice, unsigned int channel)
Enabled counter output channel.
JYPCIe5112API int | JYPCIe5112_CO_SetCounterParament (JYPCIe5112_DeviceHandle hDevice, unsigned int channel, int pulseCount, JYPCIe5112_CO_IdleState IdleState, double delay)
Set CO parameter.
JYPCIe5112API int | JYPCIe5112_CO_SetFrequency (JYPCIe5112_DeviceHandle hDevice, unsigned int channel, unsigned int highTicks, unsigned int lowTicks)
Set counter output pulse frequency.
JYPCIe5112API int | JYPCIe5112_CO_SetTimeBase (JYPCIe5112_DeviceHandle hDevice, unsigned int channel, JYPCIe5112_CountTimeBase timebaseSrc, JYPCIe5112_InputTerminal externalTimebaseTerminal, double externalTimebaseFreq, double *actualTimebaseFreq)
Set CO timebase source.
JYPCIe5112API int | JYPCIe5112_CO_Start (JYPCIe5112_DeviceHandle hDevice, unsigned int channel)
Start counter output.
JYPCIe5112API int | JYPCIe5112_CO_Stop (JYPCIe5112_DeviceHandle hDevice, unsigned int channel)
Stop counter output.
JYPCIe5112API int | JYPCIe5112_CO_CheckCounterStatus (JYPCIe5112_DeviceHandle hDevice, unsigned int channel, unsigned int *pulseTransfered, bool *underflow)
Check counter status.
JYPCIe5112API int | JYPCIe5112_CO_WaitUntilDone (JYPCIe5112_DeviceHandle hDevice, unsigned int channel, bool *done)
Check counter output complete status.
JYPCIe5112API int | JYPCIe5112_CO_SendSoftTrigger (JYPCIe5112_DeviceHandle hDevice, int channel)
Send the software trigger signal for CO.
JYPCIe5112API int | JYPCIe5112_CO_SetStartTriggerType (JYPCIe5112_DeviceHandle hDevice, int channel, JYPCIe5112_CIO_TriggerType triggerTyp)
Set CO start trigger type,the triggerType is defined by enum JYPCIe5112_AI_TriggerType.
JYPCIe5112API int | JYPCIe5112_CO_SetDigitalStartTrigger (JYPCIe5112_DeviceHandle hDevice, int channel, JYPCIe5112_DigitalTriggerSource triggerSource, JYPCIe5112_DigitalTriggerEdge triggerEdge)
Set CO digital start trigger,the triggerSource is defined by enum JYPCIe5112_DigitalTriggerSource, the triggerEdge is defined by enum JYPCIe5112_DigitalTriggerEdge.
JYPCIe5112API int | JYPCIe5112_CO_SetOutTerminal (JYPCIe5112_DeviceHandle hDevice, int channel, JYPCIe5112_Signal_Destination outTerminal)
Set out terminal.
JYPCIe5112API int | JYPCIe5112_CO_SetPauseTriggerLevel (JYPCIe5112_DeviceHandle hDevice, unsigned int channel, bool enable, JYPCIe5112_LevelState pauseTriggerActiveLevel)
Config CO pause trigger.
JYPCIe5112API int | JYPCIe5112_CO_SetPauseTriggerTerminal (JYPCIe5112_DeviceHandle hDevice, int channel, JYPCIe5112_InputTerminal pauseTriggerTerminal)
Set CO pause trigger terminal.
JYPCIe5112API int | JYPCIe5112_CO_SetPauseTriggerOutState (JYPCIe5112_DeviceHandle hDevice, unsigned int channel, JYPCIe5112_CO_PauseTriger_OutState outState)
Config CO out state when pause trigger valid.
JYPCIe5112API int | JYPCIe5112_DisableAICalibration (JYPCIe5112_DeviceHandle hDevice, bool DisableCalibration)
Disable AI calibration coefficient, default false.
JYPCIe5112API int | JYPCIe5112_DisableAOCalibration (JYPCIe5112_DeviceHandle hDevice, bool DisableCalibration)
Disable AO calibration coefficient, default false.
JYPCIe5112API int | JYPCIe5112_SetPFIFilter (JYPCIe5112_DeviceHandle hDevice, int line, bool filterEnabled, int minPulseWidth, int *actualMinPulseWidth)
Set the filter for the specified PFI.

Detailed Description

@SectionBegin JYPCIe5112 FileHead

COPYRIGHT NOTICE
Copyright (c) 2018-2021, JYTEK
All rights reserved.
Author
JYTEK
Version
1.0.0
Date
2023-8-31

This header file defines C/C++ API and enums used in the JYPCIe5112 driver.

Revision Notes:

Typedef Documentation

◆ JYPCIe5112_DeviceHandle

typedef void* JYPCIe5112_DeviceHandle

@SectionEnd JYPCIe5112_Device FileHead

Windows Linux

Enumeration Type Documentation

◆ JYPCIe5112_AI_SampleMode

enum JYPCIe5112_AI_SampleMode
Enumerator
JYPCIe5112_AI_Finite | AI Finite mode.
JYPCIe5112_AI_Continuous | AI Continuous mode.
JYPCIe5112_AI_Single | AI Single mode.

◆ JYPCIe5112_AI_Terminal

enum JYPCIe5112_AI_Terminal
Enumerator
JYPCIe5112_AI_RSE | AI RSE connection mode.
JYPCIe5112_AI_NRSE | AI NRSE connection mode.
JYPCIe5112_AI_Diff | AI Diff connection mode.

◆ JYPCIe5112_AI_TriggerType

enum JYPCIe5112_AI_TriggerType
Enumerator
JYPCIe5112_AI_Immediately | AI Immediately trigger.
JYPCIe5112_AI_Digital | AI Digital trigger.
JYPCIe5112_AI_Analog | AI Analog trigger.
JYPCIe5112_AI_Soft | AI Soft trigger.

◆ JYPCIe5112_AnalogTriggerEdge

enum JYPCIe5112_AnalogTriggerEdge
Enumerator
JYPCIe5112_RisingSlope | Rsing edge for digital trigger.
JYPCIe5112_FallingSlope | Falling edge for digital trigger.

◆ JYPCIe5112_AnalogTriggerSource

enum JYPCIe5112_AnalogTriggerSource
Enumerator
JYPCIe5112_Channel_0
JYPCIe5112_Channel_1
JYPCIe5112_Channel_2
JYPCIe5112_Channel_3
JYPCIe5112_Channel_4
JYPCIe5112_Channel_5
JYPCIe5112_Channel_6
JYPCIe5112_Channel_7
JYPCIe5112_Channel_8
JYPCIe5112_Channel_9
JYPCIe5112_Channel_10
JYPCIe5112_Channel_11
JYPCIe5112_Channel_12
JYPCIe5112_Channel_13
JYPCIe5112_Channel_14
JYPCIe5112_Channel_15

◆ JYPCIe5112_AnalogWindowCondition

enum JYPCIe5112_AnalogWindowCondition
Enumerator
JYPCIe5112_Entering | Analog trigger condition is RisingHysteresis.
JYPCIe5112_Leaving | Analog trigger condition is FallingHysteresis.

◆ JYPCIe5112_AO_TriggerType

enum JYPCIe5112_AO_TriggerType
Enumerator
JYPCIe5112_AO_Immediately | AO Immediately trigger.
JYPCIe5112_AO_Digital | AO Digital trigger.
JYPCIe5112_AO_Soft | AO Soft trigger.

◆ JYPCIe5112_AO_UpdateMode

enum JYPCIe5112_AO_UpdateMode
Enumerator
JYPCIe5112_AO_Finite | AO Finite mode.
JYPCIe5112_AO_ContinuousWrapping | AO ContinuousWrapping mode.
JYPCIe5112_AO_ContinuousNoWrapping | AO ContinuousNoWrapping mode.
JYPCIe5112_AO_Single | AO Single mode.

◆ JYPCIe5112_CI_CounterEventSignalIdleState

enum JYPCIe5112_CI_CounterEventSignalIdleState
Enumerator
JYPCIe5112_CI_CounterEventSignalIdleState_Low
JYPCIe5112_CI_CounterEventSignalIdleState_High

◆ JYPCIe5112_CI_MeasureType

enum JYPCIe5112_CI_MeasureType
Enumerator
JYPCIe5112_CI_EdgeCount
JYPCIe5112_CI_Measure_FrequencyOrPeriod
JYPCIe5112_CI_Measure_PulseWidth
JYPCIe5112_CI_Measure_SemiPeriod
JYPCIe5112_CI_Measure_EdgeSeparation
JYPCIe5112_CI_EncoderX1
JYPCIe5112_CI_EncoderX2
JYPCIe5112_CI_EncoderX4
JYPCIe5112_CI_EncoderTwoPulse

◆ JYPCIe5112_CI_SampleClock

enum JYPCIe5112_CI_SampleClock
Enumerator
JYPCIe5112_CI_ImplicitClock
JYPCIe5112_CI_InternalClock
JYPCIe5112_CI_ExternalClock

◆ JYPCIe5112_CI_StartingEdge

enum JYPCIe5112_CI_StartingEdge
Enumerator
JYPCIe5112_RisingEdge
JYPCIe5112_FallingEdge
JYPCIe5112_AnyEdge

◆ JYPCIe5112_CI_ValueReturnMode

enum JYPCIe5112_CI_ValueReturnMode
Enumerator
JYPCIe5112_CI_ReturnTwoValue
JYPCIe5112_CI_ReturnOneValue

◆ JYPCIe5112_CIO_TriggerType

enum JYPCIe5112_CIO_TriggerType
Enumerator
JYPCIe5112_CIO_Immediately | CI Immediately trigger.
JYPCIe5112_CIO_Digital | CI Digital trigger.
JYPCIe5112_CIO_Soft | CI Soft trigger.

◆ JYPCIe5112_ClockSource

enum JYPCIe5112_ClockSource
Enumerator
JYPCIe5112_InternalClock | Internal Clock Source.
JYPCIe5112_ExternalClock | External Clock Source.

◆ JYPCIe5112_CO_IdleState

enum JYPCIe5112_CO_IdleState
Enumerator
JYPCIe5112_CO_LowLevel
JYPCIe5112_CO_HighLevel

◆ JYPCIe5112_CO_PauseTriger_OutState

enum JYPCIe5112_CO_PauseTriger_OutState
Enumerator
JYPCIe5112_CO_HoldOn | CO hold on current state.
JYPCIe5112_CO_HighOut | CO out high level.
JYPCIe5112_CO_LowOut | CO out low level.

◆ JYPCIe5112_CountDirection

enum JYPCIe5112_CountDirection
Enumerator
JYPCIe5112_CI_Count_Up
JYPCIe5112_CI_Count_Down
JYPCIe5112_CI_Count_External

◆ JYPCIe5112_CountTimeBase

enum JYPCIe5112_CountTimeBase
Enumerator
JYPCIe5112_Internal_Timebase_100M | Counter timebase 100 MHz.
JYPCIe5112_Internal_Timebase_5M | Counter timebase 5 MHz.
JYPCIe5112_Internal_Timebase_100K | Counter timebase 100 KHz.
JYPCIe5112_External_Timebase | External_Timebase.

◆ JYPCIe5112_DigitalTriggerEdge

enum JYPCIe5112_DigitalTriggerEdge
Enumerator
JYPCIe5112_Rising | Rsing edge for digital trigger.
JYPCIe5112_Falling | Falling edge for digital trigger.

◆ JYPCIe5112_DigitalTriggerSource

enum JYPCIe5112_DigitalTriggerSource
Enumerator
JYPCIe5112_DigitalTrigger_PFI0 | PFI_0 as the digital trigger source.
JYPCIe5112_DigitalTrigger_PFI1 | PFI_1 as the digital trigger source.
JYPCIe5112_DigitalTrigger_PFI2 | PFI_2 as the digital trigger source.
JYPCIe5112_DigitalTrigger_PFI3 | PFI_3 as the digital trigger source.
JYPCIe5112_DigitalTrigger_PFI4 | PFI_4 as the digital trigger source.
JYPCIe5112_DigitalTrigger_PFI5 | PFI_5 as the digital trigger source.
JYPCIe5112_DigitalTrigger_PFI6 | PFI_6 as the digital trigger source.
JYPCIe5112_DigitalTrigger_PFI7 | PFI_7 as the digital trigger source.
JYPCIe5112_DigitalTrigger_PFI8 | PFI_8 as the digital trigger source.
JYPCIe5112_DigitalTrigger_PFI9 | PFI_9 as the digital trigger source.
JYPCIe5112_DigitalTrigger_PFI10 | PFI_10 as the digital trigger source.
JYPCIe5112_DigitalTrigger_PFI11 | PFI_11 as the digital trigger source.
JYPCIe5112_DigitalTrigger_PFI12 | PFI_12 as the digital trigger source.
JYPCIe5112_DigitalTrigger_PFI13 | PFI_13 as the digital trigger source.
JYPCIe5112_DigitalTrigger_PFI14 | PFI_14 as the digital trigger source.
JYPCIe5112_DigitalTrigger_PFI15 | PFI_15 as the digital trigger source.
JYPCIe5112_DigitalTrigger_PXI_Trig0 | PXI_Trig0 as the digital trigger source.
JYPCIe5112_DigitalTrigger_PXI_Trig1 | PXI_Trig1 as the digital trigger source.
JYPCIe5112_DigitalTrigger_PXI_Trig2 | PXI_Trig2 as the digital trigger source.
JYPCIe5112_DigitalTrigger_PXI_Trig3 | PXI_Trig3 as the digital trigger source.
JYPCIe5112_DigitalTrigger_PXI_Trig4 | PXI_Trig4 as the digital trigger source.
JYPCIe5112_DigitalTrigger_PXI_Trig5 | PXI_Trig5 as the digital trigger source.
JYPCIe5112_DigitalTrigger_PXI_Trig6 | PXI_Trig6 as the digital trigger source.
JYPCIe5112_DigitalTrigger_PXI_Trig7 | PXI_Trig7 as the digital trigger source.
JYPCIe5112_DigitalTrigger_Inter_AI_StartTrig | AI_StartTrig as the digital trigger source.
JYPCIe5112_DigitalTrigger_Inter_AI_ReferenceTrig | AI_ReferenceTrig as the digital trigger source.
JYPCIe5112_DigitalTrigger_Inter_AO_StartTrig | AO_StartTrig as the digital trigger source.
JYPCIe5112_DigitalTrigger_Inter_CIO_0_StartTrig | CI0_StartTrig as the digital trigger source.
JYPCIe5112_DigitalTrigger_Inter_CIO_1_StartTrig | CI1_StartTrig as the digital trigger source.
JYPCIe5112_DigitalTrigger_Inter_CO_0_Output | CO0_StartTrig as the digital trigger source.
JYPCIe5112_DigitalTrigger_Inter_CO_1_Output | CO1_StartTrig as the digital trigger source.

◆ JYPCIe5112_ExternalClockTerminal

enum JYPCIe5112_ExternalClockTerminal
Enumerator
JYPCIe5112_Clock_PFI0_IN | PFI_0 as the External Clock Source.
JYPCIe5112_Clock_PFI1_IN | PFI_1 as the External Clock Source.
JYPCIe5112_Clock_PFI2_IN | PFI_2 as the External Clock Source.
JYPCIe5112_Clock_PFI3_IN | PFI_3 as the External Clock Source.
JYPCIe5112_Clock_PFI4_IN | PFI_4 as the External Clock Source.
JYPCIe5112_Clock_PFI5_IN | PFI_5 as the External Clock Source.
JYPCIe5112_Clock_PFI6_IN | PFI_6 as the External Clock Source.
JYPCIe5112_Clock_PFI7_IN | PFI_7 as the External Clock Source.
JYPCIe5112_Clock_PFI8_IN | PFI_8 as the External Clock Source.
JYPCIe5112_Clock_PFI9_IN | PFI_9 as the External Clock Source.
JYPCIe5112_Clock_PFI10_IN | PFI_10 as the External Clock Source.
JYPCIe5112_Clock_PFI11_IN | PFI_11 as the External Clock Source.
JYPCIe5112_Clock_PFI12_IN | PFI_12 as the External Clock Source.
JYPCIe5112_Clock_PFI13_IN | PFI_13 as the External Clock Source.
JYPCIe5112_Clock_PFI14_IN | PFI_14 as the External Clock Source.
JYPCIe5112_Clock_PFI15_IN | PFI_15 as the External Clock Source.
JYPCIe5112_Clock_PXI_Trig0_IN | PXI_Trig0 as External Clock Source.
JYPCIe5112_Clock_PXI_Trig1_IN | PXI_Trig1 as External Clock Source.
JYPCIe5112_Clock_PXI_Trig2_IN | PXI_Trig2 as External Clock Source.
JYPCIe5112_Clock_PXI_Trig3_IN | PXI_Trig3 as External Clock Source.
JYPCIe5112_Clock_PXI_Trig4_IN | PXI_Trig4 as External Clock Source.
JYPCIe5112_Clock_PXI_Trig5_IN | PXI_Trig5 as External Clock Source.
JYPCIe5112_Clock_PXI_Trig6_IN | PXI_Trig6 as External Clock Source.
JYPCIe5112_Clock_PXI_Trig7_IN | PXI_Trig7 as External Clock Source.
JYPCIe5112_Clock_Inter_AI_SampleClock | AI_SampleClock as other task External Clock Source.
JYPCIe5112_Clock_Inter_AO_SampleClock | AO_SampleClock as other task External Clock Source.
JYPCIe5112_Clock_Inter_CO_0_Output | CO_0_Output as other task External Clock Source.
JYPCIe5112_Clock_Inter_CO_1_Output | CO_1_Output as other task External Clock Source.
JYPCIe5112_Clock_Default |

◆ JYPCIe5112_InputTerminal

enum JYPCIe5112_InputTerminal
Enumerator
JYPCIe5112_Input_PFI0 | PFI_0 as the External Clock Source.
JYPCIe5112_Input_PFI1 | PFI_1 as the External Clock Source.
JYPCIe5112_Input_PFI2 | PFI_2 as the External Clock Source.
JYPCIe5112_Input_PFI3 | PFI_3 as the External Clock Source.
JYPCIe5112_Input_PFI4 | PFI_4 as the External Clock Source.
JYPCIe5112_Input_PFI5 | PFI_5 as the External Clock Source.
JYPCIe5112_Input_PFI6 | PFI_6 as the External Clock Source.
JYPCIe5112_Input_PFI7 | PFI_7 as the External Clock Source.
JYPCIe5112_Input_PFI8 | PFI_8 as the External Clock Source.
JYPCIe5112_Input_PFI9 | PFI_9 as the External Clock Source.
JYPCIe5112_Input_PFI10 | PFI_10 as the External Clock Source.
JYPCIe5112_Input_PFI11 | PFI_11 as the External Clock Source.
JYPCIe5112_Input_PFI12 | PFI_12 as the External Clock Source.
JYPCIe5112_Input_PFI13 | PFI_13 as the External Clock Source.
JYPCIe5112_Input_PFI14 | PFI_14 as the External Clock Source.
JYPCIe5112_Input_PFI15 | PFI_15 as the External Clock Source.
JYPCIe5112_Input_PXI_Trig0 | PXI_Trig0 as Input Terminal.
JYPCIe5112_Input_PXI_Trig1 | PXI_Trig1 as Input Terminal.
JYPCIe5112_Input_PXI_Trig2 | PXI_Trig2 as Input Terminal.
JYPCIe5112_Input_PXI_Trig3 | PXI_Trig3 as Input Terminal.
JYPCIe5112_Input_PXI_Trig4 | PXI_Trig4 as Input Terminal.
JYPCIe5112_Input_PXI_Trig5_ | PXI_Trig5 as Input Terminal.
JYPCIe5112_Input_PXI_Trig6 | PXI_Trig6 as Input Terminal.
JYPCIe5112_Input_PXI_Trig7 | PXI_Trig7 as Input Terminal.
JYPCIe5112_Input_CO_0_Out | CO_0_Output as Internal Input Terminal.
JYPCIe5112_Input_CO_1_Out | CO_1_Output as Internal Input Terminal.
JYPCIe5112_Input_CIO_100MHz | JYPCIe5112_CIO_100MHz_Input as Internal Input Terminal.
JYPCIe5112_Input_CIO_5MHz | JYPCIe5112_CIO_5MHz_Input as Internal Input Terminal.
JYPCIe5112_Input_CIO_100KHz | JYPCIe5112_CIO_100KHz_Input as Internal Input Terminal.

◆ JYPCIe5112_LevelState

enum JYPCIe5112_LevelState
Enumerator
JYPCIe5112_LowLevel
JYPCIe5112_HighLevel

◆ JYPCIe5112_OutputCompleteState

enum JYPCIe5112_OutputCompleteState
Enumerator
JYPCIe5112_Zero | Output Zero.
JYPCIe5112_Hold | Output Hold.

◆ JYPCIe5112_Signal_Destination

enum JYPCIe5112_Signal_Destination
Enumerator
JYPCIe5112_PFI0_OUT | PFI0 as the signal desition to rout.
JYPCIe5112_PFI1_OUT | PFI1 as the signal desition to rout.
JYPCIe5112_PFI2_OUT | PFI2 as the signal desition to rout.
JYPCIe5112_PFI3_OUT | PFI3 as the signal desition to rout.
JYPCIe5112_PFI4_OUT | PFI4 as the signal desition to rout.
JYPCIe5112_PFI5_OUT | PFI5 as the signal desition to rout.
JYPCIe5112_PFI6_OUT | PFI6 as the signal desition to rout.
JYPCIe5112_PFI7_OUT | PFI7 as the signal desition to rout.
JYPCIe5112_PFI8_OUT | PFI8 as the signal desition to rout.
JYPCIe5112_PFI9_OUT | PFI9 as the signal desition to rout.
JYPCIe5112_PFI10_OUT | PFI10 as the signal desition to rout.
JYPCIe5112_PFI11_OUT | PFI11 as the signal desition to rout.
JYPCIe5112_PFI12_OUT | PFI12 as the signal desition to rout.
JYPCIe5112_PFI13_OUT | PFI13 as the signal desition to rout.
JYPCIe5112_PFI14_OUT | PFI14 as the signal desition to rout.
JYPCIe5112_PFI15_OUT | PFI15 as the signal desition to rout.
JYPCIe5112_PXITrig0_OUT | PXITrig0 as the signal desition to rout.
JYPCIe5112_PXITrig1_OUT | PXITrig1 as the signal desition to rout.
JYPCIe5112_PXITrig2_OUT | PXITrig2 as the signal desition to rout.
JYPCIe5112_PXITrig3_OUT | PXITrig3 as the signal desition to rout.
JYPCIe5112_PXITrig4_OUT | PXITrig4 as the signal desition to rout.
JYPCIe5112_PXITrig5_OUT | PXITrig5 as the signal desition to rout.
JYPCIe5112_PXITrig6_OUT | PXITrig6 as the signal desition to rout.
JYPCIe5112_PXITrig7_OUT | PXITrig7 as the signal desition to rout.
JYPCIe5112_None | None desition to rout.

◆ JYPCIe5112_Signal_Source

enum JYPCIe5112_Signal_Source
Enumerator
JYPCIe5112_AI_StartTrig | AI_StartTrig as the source signal to rout.
JYPCIe5112_AI_ReferenceTrig | AI_ReferenceTrig as the source signal to rout.
JYPCIe5112_AO_StartTrig | AO_StartTrig as the source signal to rout.
JYPCIe5112_CIO_0_StartTrig | CI0_StartTrig as the source signal to rout.
JYPCIe5112_CIO_1_StartTrig | CI1_StartTrig as the source signal to rout.
JYPCIe5112_AI_SampleClock | AI_SampleClock as the source signal to rout.
JYPCIe5112_AO_SampleClock | AO_SampleClock as the source signal to rout.
JYPCIe5112_CO_0_Output | CO_0_Output as the source signal to rout.
JYPCIe5112_CO_1_Output | CO_1_Output as the source signal to rout.

◆ JYPCIe5112_TriggerMode

enum JYPCIe5112_TriggerMode
Enumerator
JYPCIe5112_StartTrigger | Start trigger mode.
JYPCIe5112_ReferenceTrigger | Reference trigger mode.

Function Documentation

◆ JYPCIe5112_AI_CheckBufferStatus()

JYPCIe5112API int JYPCIe5112_AI_CheckBufferStatus | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | unsigned long long * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun )

Check AI device buffer status.

Parameters
hDevice | device handle
avaliableSamples | number of samples per channel in the device buffer
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if Success or other error code

◆ JYPCIe5112_AI_EnableChannel()

JYPCIe5112API int JYPCIe5112_AI_EnableChannel | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | unsigned int | channelCount,
 |  | unsigned char * | channels,
 |  | double * | lowRegion,
 |  | double * | highRegion,
 |  | JYPCIe5112_AI_Terminal * | terminal )

Enable AI channels.

Each channel can be independently configured

Parameters
hDevice | device handle
channelCount | number of channels to be enabled
channels | array[channelCount] containing channel IDs
lowRegion | array[channelCount] of lower limit numbers for each channel,typically in volts.
highRegion | array[channelCount] of higher limit numbers for each channel, typcially in volts.
terminal | array[channelCount] of the terminal configuration defined by enum JYPCIe5112_AI_Terminal which can be RSE,NRSE,or DIFF.
Returns
0 if Success or other error code

◆ JYPCIe5112_AI_ReadData()

JYPCIe5112API int JYPCIe5112_AI_ReadData | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | double * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength )

Read AI data to user defined data buffer.

For the multi-channel acquisition, the data is interleaved in the order defined by JYPCIe5112_AI_EnableChannel.

Parameters
hDevice | device handle
dataBuffer | user buffer,the buffer size must be greater than or equal to dataLength*channelCount.
dataLength | number of samples per channel
timeOut | timeout time in microsecond
actualReadLength | returns the number of samples per channel actually read
Returns
0 if Success or other error code

◆ JYPCIe5112_AI_ReadRawData()

JYPCIe5112API int JYPCIe5112_AI_ReadRawData | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | short * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength )

Read AI raw data to user defined data buffer.

For the multi-channel acquisition, the data is interleaved in the order defined by JYPCIe5112_AI_EnableChannel.

Parameters
hDevice | device handle
dataBuffer | user buffer, The size of dataBuffer must be greater than or equal to dataLength*channelCount.
dataLength | number of samples per channel
timeOut | timeout time in microsecond
actualReadLength | return the number of samples per channel actually read
Returns
0 if Success or other error code

◆ JYPCIe5112_AI_ReadRawSinglePoint()

JYPCIe5112API int JYPCIe5112_AI_ReadRawSinglePoint | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | short * | readValue,
 |  | int | channelID )

Read raw single point for each channel to user defined data buffer.

Parameters
hDevice | device handle
readValue | user buffer,the size of readValue must be greater than or equal to channelCount.
channelID | read the specified channelID. when the channelID is -1, read all enabled channels value.
Returns
0 if success or other error code

◆ JYPCIe5112_AI_ReadSinglePoint()

JYPCIe5112API int JYPCIe5112_AI_ReadSinglePoint | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | double * | readValue,
 |  | int | channelID )

Read single point for each channel to user defined data buffer.

Parameters
hDevice | device handle
readValue | user buffer,the size of readValue must be greater than or equal to channelCount.
channelID | read the specified channelID. when the channelID is -1, read all enabled channels value.
Returns
0 if success or other error code

◆ JYPCIe5112_AI_SendSoftTrigger()

JYPCIe5112API int JYPCIe5112_AI_SendSoftTrigger | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | JYPCIe5112_TriggerMode | triggerMode )

Send the software trigger signal for AI.

Parameters
hDevice | device handle
triggerMode | software trigger mode. Options: start trigger or reference trigger.
Returns
0 if Success or other error code

◆ JYPCIe5112_AI_SetAnalogEdgeReferenceTrigger()

JYPCIe5112API int JYPCIe5112_AI_SetAnalogEdgeReferenceTrigger | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | JYPCIe5112_AnalogTriggerSource | triggerSource,
 |  | JYPCIe5112_AnalogTriggerEdge | triggerEdge,
 |  | double | threshold )

Set AI analog edge window reference trigger,the triggerSource is defined by enum JYPCIe5112_AnalogTriggerSource, the triggerEdge is defined by enum JYPCIe5112_AnalogTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source,0-15
triggerCondition | AI analog trigger conditions
threshold | threshold
Returns
0 if Success or other error code

◆ JYPCIe5112_AI_SetAnalogEdgeStartTrigger()

JYPCIe5112API int JYPCIe5112_AI_SetAnalogEdgeStartTrigger | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | JYPCIe5112_AnalogTriggerSource | triggerSource,
 |  | JYPCIe5112_AnalogTriggerEdge | triggerEdge,
 |  | double | threshold )

Set AI analog edge window start trigger,the triggerSource is defined by enum JYPCIe5112_AnalogTriggerSource, the triggerEdge is defined by enum JYPCIe5112_AnalogTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source,0-15
triggerCondition | AI analog trigger conditions
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if Success or other error code

◆ JYPCIe5112_AI_SetAnalogHysteresisReferenceTrigger()

JYPCIe5112API int JYPCIe5112_AI_SetAnalogHysteresisReferenceTrigger | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | JYPCIe5112_AnalogTriggerSource | triggerSource,
 |  | JYPCIe5112_AnalogTriggerEdge | triggerEdge,
 |  | double | highThreshold,
 |  | double | lowThreshold )

Set AI analog hysteresis reference trigger,the triggerSource is defined by enum JYPCIe5112_AnalogTriggerSource, the triggerEdge is defined by enum JYPCIe5112_AnalogTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source,0-15
triggerCondition | AI analog trigger conditions
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if Success or other error code

◆ JYPCIe5112_AI_SetAnalogHysteresisStartTrigger()

JYPCIe5112API int JYPCIe5112_AI_SetAnalogHysteresisStartTrigger | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | JYPCIe5112_AnalogTriggerSource | triggerSource,
 |  | JYPCIe5112_AnalogTriggerEdge | triggerEdge,
 |  | double | highThreshold,
 |  | double | lowThreshold )

Set AI analog hysteresis start trigger,the triggerSource is defined by enum JYPCIe5112_AnalogTriggerSource, the triggerEdge is defined by enum JYPCIe5112_AnalogTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source,0-15
triggerCondition | AI analog trigger conditions
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if Success or other error code

◆ JYPCIe5112_AI_SetAnalogWindowReferenceTrigger()

JYPCIe5112API int JYPCIe5112_AI_SetAnalogWindowReferenceTrigger | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | JYPCIe5112_AnalogTriggerSource | triggerSource,
 |  | JYPCIe5112_AnalogWindowCondition | triggerCondition,
 |  | double | highThreshold,
 |  | double | lowThreshold )

Set AI analog reference trigger,the triggerSource is defined by enum JYPCIe5112_AnalogTriggerSource, the triggerCondition is defined by enum JYPCIe5112_AnalogTriggerCondition.

Parameters
hDevice | device handle
triggerSource | AI reference trigger source,0-15
triggerCondition | AI analog trigger conditions
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if Success or other error code

◆ JYPCIe5112_AI_SetAnalogWindowStartTrigger()

JYPCIe5112API int JYPCIe5112_AI_SetAnalogWindowStartTrigger | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | JYPCIe5112_AnalogTriggerSource | triggerSource,
 |  | JYPCIe5112_AnalogWindowCondition | triggerCondition,
 |  | double | highThreshold,
 |  | double | lowThreshold )

Set AI analog window start trigger,the triggerSource is defined by enum JYPCIe5112_AnalogTriggerSource, the triggerCondition is defined by enum JYPCIe5112_AnalogWindowCondition.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source,0-15
triggerCondition | AI analog trigger conditions
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if Success or other error code

◆ JYPCIe5112_AI_SetDigitalReferenceTrigger()

JYPCIe5112API int JYPCIe5112_AI_SetDigitalReferenceTrigger | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | JYPCIe5112_DigitalTriggerSource | triggerSource,
 |  | JYPCIe5112_DigitalTriggerEdge | triggerEdge )

Set AI digital reference trigger.the triggerSource is defined by enum JYPCIe5112_DigitalTriggerSource, the triggerEdge is defined by enum JYPCIe5112_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI reference trigger source
triggerEdge | AI reference to the trigger edge. Options: rising or falling edge
Returns
0 if Success or other error code

◆ JYPCIe5112_AI_SetDigitalStartTrigger()

JYPCIe5112API int JYPCIe5112_AI_SetDigitalStartTrigger | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | JYPCIe5112_DigitalTriggerSource | triggerSource,
 |  | JYPCIe5112_DigitalTriggerEdge | triggerEdge )

Set AI digital start trigger,the triggerSource is defined by enum JYPCIe5112_DigitalTriggerSource, the triggerEdge is defined by enum JYPCIe5112_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI digital start trigger source
triggerEdge | AI digital start trigger edge. Options: rising or falling edge
Returns
0 if Success or other error code

◆ JYPCIe5112_AI_SetMode()

JYPCIe5112API int JYPCIe5112_AI_SetMode | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | JYPCIe5112_AI_SampleMode | mode )

Set AI sampling mode.

Parameters
hDevice | device handle
mode | AI sampling mode defined by enum JYPCIe5112_AI_SampleMode.
Returns
0 if Success or other error code

◆ JYPCIe5112_AI_SetPreTriggerSamples()

JYPCIe5112API int JYPCIe5112_AI_SetPreTriggerSamples | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | unsigned int | preTriggerSamples )

Set AI pretrigger samples, the samples must greater than 0.

Parameters
hDevice | device handle
preTriggerSamples | AI pretrigger samples, valid only in reference trigger mode.
Returns
0 if Success or other error code

◆ JYPCIe5112_AI_SetReferenceTriggerType()

JYPCIe5112API int JYPCIe5112_AI_SetReferenceTriggerType | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | JYPCIe5112_AI_TriggerType | triggerType )

Set AI reference trigger type,the triggerType is defined by enum JYPCIe5112_AI_TriggerType.

Parameters
hDevice | device handle
triggerType | AI reference trigger type.Options: immediate trigger, software trigger, digital trigger or analog trigger.
Returns
0 if Success or other error code

◆ JYPCIe5112_AI_SetReTriggerCount()

JYPCIe5112API int JYPCIe5112_AI_SetReTriggerCount | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | unsigned long long | reTriggerCount )

Set AI retrigger count.

The device will be triggered reTriggerCount times.

Parameters
hDevice | device handle
reTriggerCount | AI retrigger count
Returns
0 if Success or other error code

◆ JYPCIe5112_AI_SetSampleClock()

JYPCIe5112API int JYPCIe5112_AI_SetSampleClock | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | JYPCIe5112_ClockSource | clockSource,
 |  | JYPCIe5112_ExternalClockTerminal | terminal,
 |  | double | expectedRate )

Set AI sampling clock source.

the source of the sampling clock defined by enum JYPCIe5112_ClockSource. If the clock source is external, external clock terminal and external clock frequency must be configured.

Parameters
hDevice | device handle
clockSource | AI sampling clock source
terminal | external terminal
expectedRate | AI external clock frequency
Returns
0 if Success or other error code

◆ JYPCIe5112_AI_SetSampleRate()

JYPCIe5112API int JYPCIe5112_AI_SetSampleRate | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | double | sampleRate,
 |  | double * | actualSampleRate )

Set sampling rate.

The sampling rate is the same for all channels.

Parameters
hDevice | device handle
sampleRate | AI sampling rate to be set per channel
actualSampleRate | actual sampling rate set by this device,which may be different from the desired sampleRate.
Returns
0 if Success or other error code

◆ JYPCIe5112_AI_SetSamplesToAcquire()

JYPCIe5112API int JYPCIe5112_AI_SetSamplesToAcquire | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | unsigned int | sampleToAcquire )

Set AI samples to acquire for each channel in finite mode.The samples range is 1 to 64M samples / channelCount.

Parameters
hDevice | device handle
sampleToAcquire | AI finite samples to acquire for each channel, samples range:1 to 64M samples / channelCount.
Returns
0 if Success or other error code

◆ JYPCIe5112_AI_SetScanRate()

JYPCIe5112API int JYPCIe5112_AI_SetScanRate | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | double | scanRate,
 |  | double * | actualScanRate )

Set convert rate.

convertRate is how fast ADC performs the AD conversion. Normally, convertRate = channelCount*sampleRate.

Parameters
hDevice | device handle
scanRate | user set convert rate
actualScanRate | actual convert rate set by this device, which may be different from the desired convertRate.
Returns
0 if Success or other error code

◆ JYPCIe5112_AI_SetStartTriggerType()

JYPCIe5112API int JYPCIe5112_AI_SetStartTriggerType | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | JYPCIe5112_AI_TriggerType | triggerType )

Set AI start trigger type,the triggerType is defined by enum JYPCIe5112_AI_TriggerType.

Parameters
hDevice | device handle
triggerType | AI start trigger type. Options:immediate trigger, software trigger, digital trigger or analog trigger.
Returns
0 if Success or other error code

◆ JYPCIe5112_AI_Start()

JYPCIe5112API int JYPCIe5112_AI_Start ( JYPCIe5112_DeviceHandle hDevice )

Start AI acquisition.

Parameters
hDevice device handle
Returns
0 if Success or other error code

◆ JYPCIe5112_AI_Stop()

JYPCIe5112API int JYPCIe5112_AI_Stop ( JYPCIe5112_DeviceHandle hDevice )

Stop AI acquisition.

Parameters
hDevice device handle
Returns
0 if Success or other error code

◆ JYPCIe5112_AI_WaitUntilDone()

JYPCIe5112API int JYPCIe5112_AI_WaitUntilDone | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | bool * | done )

Check if AI acquisition is completed in finite mode.

Parameters
hDevice | device handle
done | true if completed, false if not yet completed.
Returns
0 if Success or other error code

◆ JYPCIe5112_AO_CheckBufferStatus()

JYPCIe5112API int JYPCIe5112_AO_CheckBufferStatus | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | unsigned long * | availableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun )

Check AO device buffer status.

Parameters
hDevice | device handle
avaliableSamples | number of AO points per channel user can write
overrun | true if overflow, false if not overflow.
Returns
0 if Success or other error code

◆ JYPCIe5112_AO_EnableChannel()

JYPCIe5112API int JYPCIe5112_AO_EnableChannel | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | unsigned int | channelCount,
 |  | unsigned char * | channels,
 |  | double * | lowRegion,
 |  | double * | highRegion )

Enables AO output channels.

Parameters
hDevice | device handle
channelCount | number of channels to be enabled
channels | array[channelCount] containing channel IDs
lowRegion | array[channelCount] of lower limit numbers for each channel,typically in volts.
highRegion | array[channelCount] of higher limit numbers for each channel, typcially in volts.
Returns
0 if Success or other error code

◆ JYPCIe5112_AO_SendSoftTrigger()

JYPCIe5112API int JYPCIe5112_AO_SendSoftTrigger ( JYPCIe5112_DeviceHandle hDevice )

Send the software trigger signal for AO.

Parameters
hDevice device handle
Returns
0 if Success or other error code

◆ JYPCIe5112_AO_SetDigitalStartTrigger()

JYPCIe5112API int JYPCIe5112_AO_SetDigitalStartTrigger | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | JYPCIe5112_DigitalTriggerSource | triggerSource,
 |  | JYPCIe5112_DigitalTriggerEdge | triggerEdge )

Set AO digital start trigger,the triggerSource is defined by enum JYPCIe5112_DigitalTriggerSource, the triggerEdge is defined by enum JYPCIe5112_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AO digital start trigger source
triggerEdge | AO digital start trigger edge. Options: rising or falling edge
Returns
0 if Success or other error code

◆ JYPCIe5112_AO_SetMode()

JYPCIe5112API int JYPCIe5112_AO_SetMode | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | JYPCIe5112_AO_UpdateMode | mode )

Set AO output mode, the mode defined by enum JYPCIe5112_AO_UpdateMode.

Parameters
hDevice | device handle
mode | AO output mode.Options: Single,Finite,ContinuousWrapping,ContinuousNoWrapping mode.
Returns
0 if Success or other error code

◆ JYPCIe5112_AO_SetOutputCompleteState()

JYPCIe5112API int JYPCIe5112_AO_SetOutputCompleteState | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | JYPCIe5112_OutputCompleteState | State )

Set AO Output complete state, Default is Hold.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JYPCIe5112_AO_SetSampleClock()

JYPCIe5112API int JYPCIe5112_AO_SetSampleClock | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | JYPCIe5112_ClockSource | clockSource,
 |  | JYPCIe5112_ExternalClockTerminal | terminal,
 |  | double | expectedRate )

Set AO sampling clock source.

the source of the sampling clock defined by enum JYPCIe5112_ClockSource. If the clock source is external, need to configure external clock terminal and external clock frequency.

Parameters
hDevice | device handle
clockSource | AO sampling clock source
terminal | external clock terminal,defined by enum JYPCIe5112_ExternalClockTerminal
expectedRate | external clock frequency
Returns
0 if Success or other error code

◆ JYPCIe5112_AO_SetSamplesToUpdate()

JYPCIe5112API int JYPCIe5112_AO_SetSamplesToUpdate | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | unsigned int | sampleToUpdate )

Set AO samples to output for each channel in the finite mode.The sample range is from 1 to 32M / channelCount samples.

Parameters
hDevice | device handle
sampleToUpdate | number of AO samples per channel. Data range:1 to 32M / channelCount samples.
Returns
0 if Success or other error code

◆ JYPCIe5112_AO_SetStartTriggerType()

JYPCIe5112API int JYPCIe5112_AO_SetStartTriggerType | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | JYPCIe5112_AO_TriggerType | triggerTyp )

Set AO start trigger type,the triggerType is defined by enum JYPCIe5112_AO_TriggerType.

Parameters
hDevice | device handle
triggerType | AO start trigger type. Options: immediate trigger, software trigger, digital trigger .
Returns
0 if Success or other error code

◆ JYPCIe5112_AO_SetUpdateRate()

JYPCIe5112API int JYPCIe5112_AO_SetUpdateRate | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | double | updateRate,
 |  | double * | actualUpdateRate )

Set AO update rate for each channel.

Parameters
hDevice | device handle
updateRate | AO update rate to be set per channel
actualUpdateRate | AO update rate actually set. The actual update rate set by this device,which may be different from the desired updata rate.
Returns
0 if Success or other error code

◆ JYPCIe5112_AO_Start()

JYPCIe5112API int JYPCIe5112_AO_Start ( JYPCIe5112_DeviceHandle hDevice )

Start AO output.

Parameters
hDevice device handle
Returns
0 if Success or other error code

◆ JYPCIe5112_AO_Stop()

JYPCIe5112API int JYPCIe5112_AO_Stop ( JYPCIe5112_DeviceHandle hDevice )

Stop AO output.

Parameters
hDevice device handle
Returns
0 if Success or other error code

◆ JYPCIe5112_AO_WaitUntilDone()

JYPCIe5112API int JYPCIe5112_AO_WaitUntilDone | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | bool * | done,
 |  | int | timeOut )

Check AO finite output is complete.

Parameters
hDevice | device handle
done | true if completed, false if not yet completed.
timeOut | timeout time in microsecond
Returns
0 if Success or other error code

◆ JYPCIe5112_AO_WriteData()

JYPCIe5112API int JYPCIe5112_AO_WriteData | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | double * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualWriteLength )

AO writes data.The data is interleaved in the buffer the order defined by JYPCIe5112_AO_EnableChannel.

Parameters
hDevice | device handle
dataBuffer | user buffer of output data.The buffer size must be greater than or equal to dataLength*number of enabled channels.
dataLength | total number of output data for all channels
timeOut | timeout time in microsecond
actualWriteLength | the number of points per channel actually write
Returns
0 if Success or other error code

◆ JYPCIe5112_AO_WriteRawData()

JYPCIe5112API int JYPCIe5112_AO_WriteRawData | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | short * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualWriteLength )

AO write raw data.The data is interleaved in the buffer in channel order for multi-channel.

Parameters
hDevice | device handle
dataBuffer | user buffer, the buffer size must be greater than or equal to dataLength*number of enabled channels.
dataLength | total number of output data for all channels
timeOut | timeout time in microsecond
actualWriteLength | the number of points per channel actually write
Returns
0 if Success or other error code

◆ JYPCIe5112_AO_WriteRawSinglePoint()

JYPCIe5112API int JYPCIe5112_AO_WriteRawSinglePoint | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | short * | writeValues,
 |  | int | channelID )

AO write single point raw data to the defined channel by channelID, if channelID == -1, write all enable channel.

Parameters
hDevice | device handle
writeValues | write value for each enable channel,when channelID == -1 the writeValue length must equal to channelCount
channelID | defined channel, if channelID == -1, write all enable channel one data
Returns
0 if success or other error code

◆ JYPCIe5112_AO_WriteSinglePoint()

JYPCIe5112API int JYPCIe5112_AO_WriteSinglePoint | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | double * | writeValues,
 |  | int | channelID )

AO write single point data to the defined channel by channelID, if channelID == -1, write all enable channel.

Parameters
hDevice | device handle
writeValues | write value for each enable channel,when channelID == -1 the writeValue length must equal to channelCount
channelID | defined channel, if channelID == -1, write all enable channel one data
Returns
0 if success or other error code

◆ JYPCIe5112_CI_EnableChannel()

JYPCIe5112API int JYPCIe5112_CI_EnableChannel | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | unsigned int | channel )

Enables CI channel.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if Success or other error code

◆ JYPCIe5112_CI_ReadSingleCountValue()

JYPCIe5112API int JYPCIe5112_CI_ReadSingleCountValue | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int * | countValue )

Counter reads a single count value, this API supports the CI Type: JYPCIe5112_CI_EdgeCount、JYPCIe5112_CI_EncoderX1、 JYPCIe5112_CI_EncoderX2 、 JYPCIe5112_CI_EncoderX4 、JYPCIe5112_CI_EncoderTwoPulse.

Parameters
hDevice | device handle
channel | counter input channel. An integer counter number, eg, 0 for counter 0.
countValue | return the current count value of counter.
Returns
0 if success or other error code

◆ JYPCIe5112_CI_ReadSingleMeasureValue()

JYPCIe5112API int JYPCIe5112_CI_ReadSingleMeasureValue | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | double * | measureValue1,
 |  | double * | measureValue2,
 |  | int | timeOut )

Reads a single counter measurement as follows.

for JYPCIe5112_CI_Measure_EdgeSeparation type, measureValues1 is the Gate signel to the Aux signal interval, the measureValues2 is the Aux signel to the Gate signal interval, the unit is in s. for JYPCIe5112_CI_Measure_Pulse type, measureValues1 is the Low level signal time, the measureValues2 is the high level signal time, the unit is in second. for JYPCIe5112_CI_Measure_Frequency type, measureValues1 is signal frequency in Hz, measureValue2 has no meaning. for JYPCIe5112_CI_Measure_Period type, measureValues2 is signal period in second; measureValue1 has no meaning.

Parameters
hDevice | device handle
channel | Counter input channel
measureValue1 | current measure value of counter
measureValue2 | current measure value of counter
timeOut | timeout time in microsecond
Returns
0 if Success or other error code

◆ JYPCIe5112_CI_SendSoftTrigger()

JYPCIe5112API int JYPCIe5112_CI_SendSoftTrigger | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | int | channel )

Send the software trigger signal for CI.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if Success or other error code

◆ JYPCIe5112_CI_SetAuxTerminal()

JYPCIe5112API int JYPCIe5112_CI_SetAuxTerminal | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JYPCIe5112_InputTerminal | auxTerminal )

Set aux terminal.

Parameters
hDevice | device handle
channel | counter output channel
auxTerminal | aux terminal
Returns
0 if success or other error code

◆ JYPCIe5112_CI_SetCounterParament()

JYPCIe5112API int JYPCIe5112_CI_SetCounterParament | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | int | initCount,
 |  | JYPCIe5112_CountDirection | countDirection )

Set CI count parameter.

Parameters
hDevice | device handle
channel | counter input channel
initCount | counter initial value
countDirection | counting direction of the counter defined by enum JYPCIe5112_CountDirection
Returns
0 if success or other error code

◆ JYPCIe5112_CI_SetCounterType()

JYPCIe5112API int JYPCIe5112_CI_SetCounterType | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JYPCIe5112_CI_MeasureType | measureType )

Set CI measure type.

Parameters
hDevice | device handle
channel | counter input channel
measureType | measure type. defined by enum JYPCIe5112_CI_MeasureType
Returns
0 if success or other error code

◆ JYPCIe5112_CI_SetDigitalStartTrigger()

JYPCIe5112API int JYPCIe5112_CI_SetDigitalStartTrigger | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JYPCIe5112_DigitalTriggerSource | triggerSource,
 |  | JYPCIe5112_DigitalTriggerEdge | triggerEdge )

Set CI digital start trigger.the triggerSource is defined by enum JYPCIe5112_DigitalTriggerSource, the triggerEdge is defined by enum JYPCIe5112_DigitalTriggerEdge.

Parameters
hDevice | device handle
channel | counter input channel
triggerSource | CI digital start trigger source
triggerEdge | CI digital start trigger edge. Options: rising or falling edge.
Returns
0 if Success or other error code

◆ JYPCIe5112_CI_SetEdgeCountEvent()

JYPCIe5112API int JYPCIe5112_CI_SetEdgeCountEvent | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JYPCIe5112_CI_CounterEventSignalIdleState | idleState,
 |  | unsigned int | threshold )

Set the counter threshold, and when the count reaches this threshold, output a single pulse at the output terminal.

Parameters
hDevice | device handle
channel | counter input channel
idleState | output terminal idle state
threshold | threshold
Returns
0 if success or other error code

◆ JYPCIe5112_CI_SetFirstSampleClock()

JYPCIe5112API int JYPCIe5112_CI_SetFirstSampleClock | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool | ignore )

Set first sample clock is ignore.

Parameters
hDevice | device handle
channel | counter input channel
ignore | is ignore first sample clock
Returns
0 if success or other error code

◆ JYPCIe5112_CI_SetGateTerminal()

JYPCIe5112API int JYPCIe5112_CI_SetGateTerminal | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JYPCIe5112_InputTerminal | gateTerminal )

Set gate terminal.

Parameters
hDevice | device handle
channel | counter output channel
gateTerminal | gate terminal
Returns
0 if success or other error code

◆ JYPCIe5112_CI_SetOutTerminal()

JYPCIe5112API int JYPCIe5112_CI_SetOutTerminal | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JYPCIe5112_Signal_Destination | outTerminal )

Set out terminal.

Parameters
hDevice | device handle
channel | counter output channel
outTerminal | source terminal
Returns
0 if success or other error code

◆ JYPCIe5112_CI_SetPauseTriggerLevel()

JYPCIe5112API int JYPCIe5112_CI_SetPauseTriggerLevel | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool | enable,
 |  | JYPCIe5112_LevelState | pauseTriggerActiveLevel )

Config CI pause trigger.

Parameters
hDevice | Device handle
channel | Counter channel
enable | Enable pasue trigger
pauseTriggerActiveLevel | Pause trigger active level.
Returns
Succeed: 0 , Error: !=0

◆ JYPCIe5112_CI_SetPauseTriggerTerminal()

JYPCIe5112API int JYPCIe5112_CI_SetPauseTriggerTerminal | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JYPCIe5112_InputTerminal | pauseTriggerTerminal )

Set CI pause trigger terminal.

Parameters
hDevice | device handle
channel | counter output channel
pauseTriggerTerminal | pause Trigger Terminal
Returns
0 if success or other error code

◆ JYPCIe5112_CI_SetSignalReverse()

JYPCIe5112API int JYPCIe5112_CI_SetSignalReverse | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | int | signalReverse )

Set the Signal Reverse terminal.

Parameters
hDevice | device handle
channel | counter input channel
signalReverse | The lower 4bit is valid. 0bit represents Source, 1bit represents Gate, 2bit represents Aux, and 3bit represents Extclk
Returns
0 if success or other error code

◆ JYPCIe5112_CI_SetSourceTerminal()

JYPCIe5112API int JYPCIe5112_CI_SetSourceTerminal | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JYPCIe5112_InputTerminal | sourceTerminal )

Set source terminal.

Parameters
hDevice | device handle
channel | counter output channel
sourceTerminal | source terminal
Returns
0 if success or other error code

◆ JYPCIe5112_CI_SetStartingEdge()

JYPCIe5112API int JYPCIe5112_CI_SetStartingEdge | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JYPCIe5112_CI_StartingEdge | startingEdge )

Set start measure edge.

Parameters
hDevice | device handle
channel | counter input channel
startingEdge | start measure edge
Returns
0 if success or other error code

◆ JYPCIe5112_CI_SetStartTriggerType()

JYPCIe5112API int JYPCIe5112_CI_SetStartTriggerType | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JYPCIe5112_CIO_TriggerType | triggerTyp )

Set CI start trigger type,the triggerType is defined by enum JYPCIe5112_DI_TriggerType.

Parameters
hDevice | device handle
channel | counter input channel
triggerType | CI start trigger type. Options: immediate trigger, software trigger, digital trigger.
Returns
0 if Success or other error code

◆ JYPCIe5112_CI_SetTimeBase()

JYPCIe5112API int JYPCIe5112_CI_SetTimeBase | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JYPCIe5112_CountTimeBase | timebaseSrc,
 |  | JYPCIe5112_InputTerminal | externalTimebaseTerminal,
 |  | double | externalTimebaseFreq,
 |  | double * | actualTimebaseFreq )

Set CI timebase source.

Parameters
hDevice | device handle
channel | counter channel
timeBase | counter time base source.defined by emun JYPCIe5112_CountTimeBase.Options:JYPCIe5112_TimeBase_200M
externalTimebaseTerminal | counter external time base terminal.defined by emun JYPCIe5112_InputTerminal.
externalTimebaseFreq | counter external time base frequency.
actualTimebaseFreq | counter actual time base frequency.
Returns
0 if success or other error code

◆ JYPCIe5112_CI_SetValueReturnMode()

JYPCIe5112API int JYPCIe5112_CI_SetValueReturnMode | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JYPCIe5112_CI_ValueReturnMode | mode )

Config CI return value mode, only for JYPCIe5112_CI_Measure_EdgeSeparation type.

Parameters
hDevice | Device handle
channel | Counter channel
mode | Counter return value mode
Returns
Succeed: 0 , Error: !=0

◆ JYPCIe5112_CI_SetZReloadEnabled()

JYPCIe5112API int JYPCIe5112_CI_SetZReloadEnabled | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool | zReloadEnabled )

Set the Z signal enable in Encoder mode.

Parameters
hDevice | device handle
channel | counter input channel
zReloadEnabled | enable z signal. True: enabled; False: disabled.Valid only under encoder mode.
Returns
0 if success or other error code

◆ JYPCIe5112_CI_Start()

JYPCIe5112API int JYPCIe5112_CI_Start | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | unsigned int | channel )

Start Counter input.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if Success or other error code

◆ JYPCIe5112_CI_Stop()

JYPCIe5112API int JYPCIe5112_CI_Stop | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | unsigned int | channel )

Stop Counter input.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if Success or other error code

◆ JYPCIe5112_Close()

JYPCIe5112API int JYPCIe5112_Close ( JYPCIe5112_DeviceHandle hDevice )

Close 5112 board.

Parameters
hDevice device handle
Returns
0 if Success or other error code

◆ JYPCIe5112_CO_CheckCounterStatus()

JYPCIe5112API int JYPCIe5112_CO_CheckCounterStatus | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int * | pulseTransfered,
 |  | bool * | underflow )

Check counter status.

Parameters
hDevice | device handle
channel | counter output channel
pulseTransfered | Transfered pulse number
underflow | counter under flow flag
Returns
0 if Success or other error code

◆ JYPCIe5112_CO_EnableChannel()

JYPCIe5112API int JYPCIe5112_CO_EnableChannel | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | unsigned int | channel )

Enabled counter output channel.

Parameters
hDevice | device handle
channel | counter output channel
Returns
0 if Success or other error code

◆ JYPCIe5112_CO_SendSoftTrigger()

JYPCIe5112API int JYPCIe5112_CO_SendSoftTrigger | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | int | channel )

Send the software trigger signal for CO.

Parameters
hDevice | device handle
channel | counter channel
Returns
0 if Success or other error code

◆ JYPCIe5112_CO_SetCounterParament()

JYPCIe5112API int JYPCIe5112_CO_SetCounterParament | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | int | pulseCount,
 |  | JYPCIe5112_CO_IdleState | IdleState,
 |  | double | delay )

Set CO parameter.

Parameters
hDevice | device handle
channel | counter output channel
pulseCount | counter output pulse number, if pulseCount = -1 ,the device always responds to output until the user stops it.
IdleState | counter output idle state
delay | counter output delay, unit:s.
Returns
0 if Success or other error code

◆ JYPCIe5112_CO_SetDigitalStartTrigger()

JYPCIe5112API int JYPCIe5112_CO_SetDigitalStartTrigger | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JYPCIe5112_DigitalTriggerSource | triggerSource,
 |  | JYPCIe5112_DigitalTriggerEdge | triggerEdge )

Set CO digital start trigger,the triggerSource is defined by enum JYPCIe5112_DigitalTriggerSource, the triggerEdge is defined by enum JYPCIe5112_DigitalTriggerEdge.

Parameters
hDevice | device handle
channel | counter channel
triggerSource | CO digital start trigger source
triggerEdge | CO digital start trigger edge. Options: rising or falling edge.
Returns
0 if Success or other error code

◆ JYPCIe5112_CO_SetFrequency()

JYPCIe5112API int JYPCIe5112_CO_SetFrequency | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int | highTicks,
 |  | unsigned int | lowTicks )

Set counter output pulse frequency.

Parameters
hDevice | device handle
channel | counter output channel
highTicks | the number of ticks for the high pulse, timebase is 200MHz.
lowTicks | the number of ticks for the low pulse, timebase is 200MHz.
Returns
0 if Success or other error code

◆ JYPCIe5112_CO_SetOutTerminal()

JYPCIe5112API int JYPCIe5112_CO_SetOutTerminal | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JYPCIe5112_Signal_Destination | outTerminal )

Set out terminal.

Parameters
hDevice | device handle
channel | counter output channel
outTerminal | out terminal
Returns
0 if success or other error code

◆ JYPCIe5112_CO_SetPauseTriggerLevel()

JYPCIe5112API int JYPCIe5112_CO_SetPauseTriggerLevel | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool | enable,
 |  | JYPCIe5112_LevelState | pauseTriggerActiveLevel )

Config CO pause trigger.

Parameters
hDevice | Device handle
channel | Counter channel
enable | Enable pasue trigger
pauseTriggerActiveLevel | Pause trigger active level.
Returns
Succeed: 0 , Error: !=0

◆ JYPCIe5112_CO_SetPauseTriggerOutState()

JYPCIe5112API int JYPCIe5112_CO_SetPauseTriggerOutState | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JYPCIe5112_CO_PauseTriger_OutState | outState )

Config CO out state when pause trigger valid.

Parameters
hDevice | Device handle
channel | Counter channel
outState | out state when pause trigger valid
Returns
Succeed: 0 , Error: !=0

◆ JYPCIe5112_CO_SetPauseTriggerTerminal()

JYPCIe5112API int JYPCIe5112_CO_SetPauseTriggerTerminal | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JYPCIe5112_InputTerminal | pauseTriggerTerminal )

Set CO pause trigger terminal.

Parameters
hDevice | device handle
channel | counter output channel
pauseTriggerTerminal | pause Trigger Terminal
Returns
0 if success or other error code

◆ JYPCIe5112_CO_SetStartTriggerType()

JYPCIe5112API int JYPCIe5112_CO_SetStartTriggerType | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JYPCIe5112_CIO_TriggerType | triggerTyp )

Set CO start trigger type,the triggerType is defined by enum JYPCIe5112_AI_TriggerType.

Parameters
hDevice | device handle
channel | counter channel
triggerType | CO start trigger type. Options:immediate trigger, software trigger, digital trigger.
Returns
0 if Success or other error code

◆ JYPCIe5112_CO_SetTimeBase()

JYPCIe5112API int JYPCIe5112_CO_SetTimeBase | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JYPCIe5112_CountTimeBase | timebaseSrc,
 |  | JYPCIe5112_InputTerminal | externalTimebaseTerminal,
 |  | double | externalTimebaseFreq,
 |  | double * | actualTimebaseFreq )

Set CO timebase source.

Parameters
hDevice | device handle
channel | counter channel
timeBase | counter time base source.defined by emun JYPCIe5112_CountTimeBase.Options:JYPCIe5112_TimeBase_200M
externalTimebaseTerminal | counter external time base terminal.defined by emun JYPCIe5112_InputTerminal.
externalTimebaseFreq | counter external time base frequency.
actualTimebaseFreq | counter actual time base frequency.
Returns
0 if success or other error code

◆ JYPCIe5112_CO_Start()

JYPCIe5112API int JYPCIe5112_CO_Start | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | unsigned int | channel )

Start counter output.

Parameters
hDevice | device handle
channel | counter output channel
Returns
0 if Success or other error code

◆ JYPCIe5112_CO_Stop()

JYPCIe5112API int JYPCIe5112_CO_Stop | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | unsigned int | channel )

Stop counter output.

Parameters
hDevice | device handle
channel | counter output channel
Returns
0 if Success or other error code

◆ JYPCIe5112_CO_WaitUntilDone()

JYPCIe5112API int JYPCIe5112_CO_WaitUntilDone | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool * | done )

Check counter output complete status.

Parameters
hDevice | device handle
channel | counter output channel
done | true :counter output complete, false:counter output not complete
Returns
0 if success or other error code

◆ JYPCIe5112_DI_AddLines()

JYPCIe5112API int JYPCIe5112_DI_AddLines | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | unsigned int * | port,
 |  | unsigned int | portCount )

Enabled DI channels.

Parameters
hDevice | device handle
port | array[portCount] containing port IDs
portCount | number of ports to be enabled
Returns
0 if Success or other error code

◆ JYPCIe5112_DI_ReadSinglePoint()

JYPCIe5112API int JYPCIe5112_DI_ReadSinglePoint | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | bool * | readValues,
 |  | int | portID )

read single data from a single port by portID defined.if the portID == -1,read all port data.The data type is bool, one bool defined one line status.

Parameters
hDevice | device handle
readValues | read the specified port values,the readValues Length must equal to 8, and the order is form line 0 to line 7. when the portID is -1, read all enabled ports values,the readValues Length must equal to 8*portCount(In function JYPCIe5112_DI_AddLines defined), and the values store in the add order of ports, in one port, the order is form line 0 to line 7.
portID | port number
Returns
0 if success or other error code

◆ JYPCIe5112_DI_ReadSinglePoint_U32()

JYPCIe5112API int JYPCIe5112_DI_ReadSinglePoint_U32 | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | unsigned long * | readValue )

read single data from a single port by portID defined.if the portID == -1,read all port data.The data type is unsigned long long,There are 6 ports, from 0 to 5.

Each port has 8 lines, from 0 to 7. There are a total of 32 lines from 0 to 31. Each bit from low to high represents one line.

Parameters
hDevice device handle
readValue read the specified port values,each bit from low to high represents one line..
Returns
0 if success or other error code

◆ JYPCIe5112_DI_ReadSinglePoint_U8()

JYPCIe5112API int JYPCIe5112_DI_ReadSinglePoint_U8 | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | unsigned char * | readValues,
 |  | int | portID )

read single data from a single port by portID defined.if the portID == -1,read all port data.The data type is unsigned char, one char defined one port status.

Parameters
hDevice | device handle
readValues | read the specified port values,the char bit 1 to 7 defined the port line 0 to line 7. when the portID is -1, read all enabled ports values,the readValues Length must equal to portCount(In function JYPCIe5112_DI_AddLines defined), and the values store in the add order of ports.
portID | port number
Returns
0 if success or other error code

◆ JYPCIe5112_DI_Start()

JYPCIe5112API int JYPCIe5112_DI_Start ( JYPCIe5112_DeviceHandle hDevice )

Start DI acquisition.

Parameters
hDevice device handle
Returns
0 if Success or other error code

◆ JYPCIe5112_DI_Stop()

JYPCIe5112API int JYPCIe5112_DI_Stop ( JYPCIe5112_DeviceHandle hDevice )

Stop DI acquisition.

Parameters
hDevice device handle
Returns
0 if Success or other error code

◆ JYPCIe5112_DisableAICalibration()

JYPCIe5112API int JYPCIe5112_DisableAICalibration | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | bool | DisableCalibration )

Disable AI calibration coefficient, default false.

Parameters
hDevice | device handle
DisableCalibration | true if disabled, false if not disabled.
Returns
0 if Success or other error code

◆ JYPCIe5112_DisableAOCalibration()

JYPCIe5112API int JYPCIe5112_DisableAOCalibration | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | bool | DisableCalibration )

Disable AO calibration coefficient, default false.

Parameters
hDevice | device handle
DisableCalibration | true if disabled, false if not disabled.
Returns
0 if Success or other error code

◆ JYPCIe5112_DisconnectSignalRouting()

JYPCIe5112API int JYPCIe5112_DisconnectSignalRouting | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | JYPCIe5112_Signal_Source | source,
 |  | JYPCIe5112_Signal_Destination | destination )

Disconnect an established routing.

Parameters
hDevice | device handle
source | source of the signal defined by enum JYPCIe5112_Signal_Source
destination | destination of the signal defined by enum JYPCIe5112_Signal_Destination
Returns
0 if Success or other error code

◆ JYPCIe5112_DO_AddLines()

JYPCIe5112API int JYPCIe5112_DO_AddLines | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | unsigned int * | port,
 |  | unsigned int | portCount )

Enabled DO channels.

Parameters
hDevice | device handle
port | array[portCount] containing port IDs.
portCount | number of ports to be enabled
Returns
0 if Success or other error code

◆ JYPCIe5112_DO_Start()

JYPCIe5112API int JYPCIe5112_DO_Start ( JYPCIe5112_DeviceHandle hDevice )

Start DO output.

Parameters
hDevice device handle
Returns
0 if Success or other error code

◆ JYPCIe5112_DO_Stop()

JYPCIe5112API int JYPCIe5112_DO_Stop ( JYPCIe5112_DeviceHandle hDevice )

Stop DO output.

Parameters
hDevice device handle
Returns
0 if Success or other error code

◆ JYPCIe5112_DO_WriteSinglePoint()

JYPCIe5112API int JYPCIe5112_DO_WriteSinglePoint | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | bool * | writeValues,
 |  | int | portID )

write single data to the port by portID defined.if the portID == -1,write all port data.

Parameters
hDevice | device handle
writeValues | write the specified port values,the writeValues Length must equal to 8, and the order is form line 0 to line 7. when the portID is -1, write all enabled ports values,the writeValues Length must equal to 8*portCount(In function JYPCIe5112_DO_AddLines defined), and the values store in the add order of ports, in one port, the order is form line 0 to line 7.
portID | port number
Returns
0 if success or other error code

◆ JYPCIe5112_DO_WriteSinglePoint_U32()

JYPCIe5112API int JYPCIe5112_DO_WriteSinglePoint_U32 | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | unsigned long | writeValues )

write single data to the port by portID defined.if the portID == -1,write all port data.The data type is unsigned long long,There are 6 ports, from 0 to 5.

Each port has 8 lines, from 0 to 7. There are a total of 32 lines from 0 to 31. Each bit from low to high represents one line.

Parameters
hDevice device handle
writeValue write the specified port values,each bit from low to high represents one line..
Returns
0 if success or other error code

◆ JYPCIe5112_DO_WriteSinglePoint_U8()

JYPCIe5112API int JYPCIe5112_DO_WriteSinglePoint_U8 | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | unsigned char * | writeValue,
 |  | int | portID )

write single data to the port by portID defined.if the portID == -1,write all port data.The data type is unsigned char, one char defined one port status.

Parameters
hDevice | device handle
writeValue | write the specified port values,the char bit 1 to 7 defined the port line 0 to line 7. when the portID is -1, write all enabled ports values,the readValues Length must equal to portCount(In function JYPCIe5112_DI_AddLines defined), and the values store in the add order of ports.
portID | port number
Returns
0 if success or other error code

◆ JYPCIe5112_GetDeviceID()

JYPCIe5112API int JYPCIe5112_GetDeviceID | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | int * | deviceID )

Obtain the device ID.

Parameters
hDevice | device handle
deviceID | device ID
Returns
0 if success or other error code

◆ JYPCIe5112_GetDeviceSerialNumber()

JYPCIe5112API int JYPCIe5112_GetDeviceSerialNumber | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | char * | serialNumber,
 |  | int | length )

Obtain the device serialNumber.

Parameters
hDevice | device handle
serialNumber | Pointer to a buffer receiving the serial number. The length of the serial number is 10.
length | serial Number length ,length is 10
Returns
0 if success or other error code

◆ JYPCIe5112_Open()

JYPCIe5112API int JYPCIe5112_Open | ( | int | slotNumber,
 |  | JYPCIe5112_DeviceHandle * | hDevice )

Open the 5112 board using the slot number or the board serial number.

PCIe slot number is defined by the DIP switch. The board number is defined by the system starting from 0. It's your responsibility to know the number. For a single board, the serial number is 0.

Parameters
slotNumber | slot number or board serial number
hDevice | device handle. All other functions uses hDevice to represent this device.
Returns
0 if Success or other error code

◆ JYPCIe5112_OpenByName()

JYPCIe5112API int JYPCIe5112_OpenByName | ( | const char * | cardName,
 |  | JYPCIe5112_DeviceHandle * | hDevice )

Open this 5112 board using the board alias name which is set by JYTEK utility JYDM.

You can change the name using JYDM.

Parameters
cardName | board alias name
hDevice | device handle
Returns
0 if Success or other error code

◆ JYPCIe5112_SetDeviceStatusLed()

JYPCIe5112API int JYPCIe5112_SetDeviceStatusLed | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | bool | enable,
 |  | unsigned int | frequency )

Control Front Panel Status Led.

Parameters
hDevice | device handle
enable | enable front panel status led blink, true: blink, false: not blink
frequency | when enable is ture, the led blink speed by frequency define
Returns
0 if Success or other error code

◆ JYPCIe5112_SetPFIFilter()

JYPCIe5112API int JYPCIe5112_SetPFIFilter | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | int | line,
 |  | bool | filterEnabled,
 |  | int | minPulseWidth,
 |  | int * | actualMinPulseWidth )

Set the filter for the specified PFI.

Parameters
hDevice | device handle
line | define PFI Line
filterEnabled | filter enable
minPulseWidth | The minimum pulse width below which pulses will be filtered out by the filter, unit:ns
actualMinPulseWidth | Actual minimum pulse width be set, unit:ns
Returns
0 if success or other error code

◆ JYPCIe5112_SignalRouting()

JYPCIe5112API int JYPCIe5112_SignalRouting | ( | JYPCIe5112_DeviceHandle | hDevice,
 |  | JYPCIe5112_Signal_Source | source,
 |  | JYPCIe5112_Signal_Destination | destination )

Route a singal from source to destination.

Both source and destination are defined by the corresponding enum JYPCIe5112_Signal_Source and JYPCIe5112_Signal_Destination. One source signal may be routed to multiple destinations.

Parameters
hDevice | device handle
source | source of the signal defined by enum JYPCIe5112_Signal_Source
destination | destination of the signal defined by enum JYPCIe5112_Signal_Destination
Returns
0 if Success or other error code
Generated by doxygen 1.12.0


5112 C++ Programming Manual: D:/5112/C++ Directory Reference

  • 5112
  • C++
C++ Directory Reference

Files

JYPCIe5112.h
@SectionBegin JYPCIe5112 FileHead


5112 C++ Programming Manual: D:/5112 Directory Reference

  • 5112
5112 Directory Reference

Directories

C++


5112 C++ Programming Manual: File List

File List
Here is a list of all files with brief descriptions:
[detail level 123]
▼ 5112 |
▼ C++ |
JYPCIe5112.h | @SectionBegin JYPCIe5112 FileHead


5112 C++ Programming Manual: File Members

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • j
Here is a list of all file members with links to the files they belong to:

- j -

  • JYPCIe5112_AI_Analog : JYPCIe5112.h
  • JYPCIe5112_AI_CheckBufferStatus() : JYPCIe5112.h
  • JYPCIe5112_AI_Continuous : JYPCIe5112.h
  • JYPCIe5112_AI_Diff : JYPCIe5112.h
  • JYPCIe5112_AI_Digital : JYPCIe5112.h
  • JYPCIe5112_AI_EnableChannel() : JYPCIe5112.h
  • JYPCIe5112_AI_Finite : JYPCIe5112.h
  • JYPCIe5112_AI_Immediately : JYPCIe5112.h
  • JYPCIe5112_AI_NRSE : JYPCIe5112.h
  • JYPCIe5112_AI_ReadData() : JYPCIe5112.h
  • JYPCIe5112_AI_ReadRawData() : JYPCIe5112.h
  • JYPCIe5112_AI_ReadRawSinglePoint() : JYPCIe5112.h
  • JYPCIe5112_AI_ReadSinglePoint() : JYPCIe5112.h
  • JYPCIe5112_AI_ReferenceTrig : JYPCIe5112.h
  • JYPCIe5112_AI_RSE : JYPCIe5112.h
  • JYPCIe5112_AI_SampleClock : JYPCIe5112.h
  • JYPCIe5112_AI_SampleMode : JYPCIe5112.h
  • JYPCIe5112_AI_SendSoftTrigger() : JYPCIe5112.h
  • JYPCIe5112_AI_SetAnalogEdgeReferenceTrigger() : JYPCIe5112.h
  • JYPCIe5112_AI_SetAnalogEdgeStartTrigger() : JYPCIe5112.h
  • JYPCIe5112_AI_SetAnalogHysteresisReferenceTrigger() : JYPCIe5112.h
  • JYPCIe5112_AI_SetAnalogHysteresisStartTrigger() : JYPCIe5112.h
  • JYPCIe5112_AI_SetAnalogWindowReferenceTrigger() : JYPCIe5112.h
  • JYPCIe5112_AI_SetAnalogWindowStartTrigger() : JYPCIe5112.h
  • JYPCIe5112_AI_SetDigitalReferenceTrigger() : JYPCIe5112.h
  • JYPCIe5112_AI_SetDigitalStartTrigger() : JYPCIe5112.h
  • JYPCIe5112_AI_SetMode() : JYPCIe5112.h
  • JYPCIe5112_AI_SetPreTriggerSamples() : JYPCIe5112.h
  • JYPCIe5112_AI_SetReferenceTriggerType() : JYPCIe5112.h
  • JYPCIe5112_AI_SetReTriggerCount() : JYPCIe5112.h
  • JYPCIe5112_AI_SetSampleClock() : JYPCIe5112.h
  • JYPCIe5112_AI_SetSampleRate() : JYPCIe5112.h
  • JYPCIe5112_AI_SetSamplesToAcquire() : JYPCIe5112.h
  • JYPCIe5112_AI_SetScanRate() : JYPCIe5112.h
  • JYPCIe5112_AI_SetStartTriggerType() : JYPCIe5112.h
  • JYPCIe5112_AI_Single : JYPCIe5112.h
  • JYPCIe5112_AI_Soft : JYPCIe5112.h
  • JYPCIe5112_AI_Start() : JYPCIe5112.h
  • JYPCIe5112_AI_StartTrig : JYPCIe5112.h
  • JYPCIe5112_AI_Stop() : JYPCIe5112.h
  • JYPCIe5112_AI_Terminal : JYPCIe5112.h
  • JYPCIe5112_AI_TriggerType : JYPCIe5112.h
  • JYPCIe5112_AI_WaitUntilDone() : JYPCIe5112.h
  • JYPCIe5112_AnalogTriggerEdge : JYPCIe5112.h
  • JYPCIe5112_AnalogTriggerSource : JYPCIe5112.h
  • JYPCIe5112_AnalogWindowCondition : JYPCIe5112.h
  • JYPCIe5112_AnyEdge : JYPCIe5112.h
  • JYPCIe5112_AO_CheckBufferStatus() : JYPCIe5112.h
  • JYPCIe5112_AO_ContinuousNoWrapping : JYPCIe5112.h
  • JYPCIe5112_AO_ContinuousWrapping : JYPCIe5112.h
  • JYPCIe5112_AO_Digital : JYPCIe5112.h
  • JYPCIe5112_AO_EnableChannel() : JYPCIe5112.h
  • JYPCIe5112_AO_Finite : JYPCIe5112.h
  • JYPCIe5112_AO_Immediately : JYPCIe5112.h
  • JYPCIe5112_AO_SampleClock : JYPCIe5112.h
  • JYPCIe5112_AO_SendSoftTrigger() : JYPCIe5112.h
  • JYPCIe5112_AO_SetDigitalStartTrigger() : JYPCIe5112.h
  • JYPCIe5112_AO_SetMode() : JYPCIe5112.h
  • JYPCIe5112_AO_SetOutputCompleteState() : JYPCIe5112.h
  • JYPCIe5112_AO_SetSampleClock() : JYPCIe5112.h
  • JYPCIe5112_AO_SetSamplesToUpdate() : JYPCIe5112.h
  • JYPCIe5112_AO_SetStartTriggerType() : JYPCIe5112.h
  • JYPCIe5112_AO_SetUpdateRate() : JYPCIe5112.h
  • JYPCIe5112_AO_Single : JYPCIe5112.h
  • JYPCIe5112_AO_Soft : JYPCIe5112.h
  • JYPCIe5112_AO_Start() : JYPCIe5112.h
  • JYPCIe5112_AO_StartTrig : JYPCIe5112.h
  • JYPCIe5112_AO_Stop() : JYPCIe5112.h
  • JYPCIe5112_AO_TriggerType : JYPCIe5112.h
  • JYPCIe5112_AO_UpdateMode : JYPCIe5112.h
  • JYPCIe5112_AO_WaitUntilDone() : JYPCIe5112.h
  • JYPCIe5112_AO_WriteData() : JYPCIe5112.h
  • JYPCIe5112_AO_WriteRawData() : JYPCIe5112.h
  • JYPCIe5112_AO_WriteRawSinglePoint() : JYPCIe5112.h
  • JYPCIe5112_AO_WriteSinglePoint() : JYPCIe5112.h
  • JYPCIe5112_Channel_0 : JYPCIe5112.h
  • JYPCIe5112_Channel_1 : JYPCIe5112.h
  • JYPCIe5112_Channel_10 : JYPCIe5112.h
  • JYPCIe5112_Channel_11 : JYPCIe5112.h
  • JYPCIe5112_Channel_12 : JYPCIe5112.h
  • JYPCIe5112_Channel_13 : JYPCIe5112.h
  • JYPCIe5112_Channel_14 : JYPCIe5112.h
  • JYPCIe5112_Channel_15 : JYPCIe5112.h
  • JYPCIe5112_Channel_2 : JYPCIe5112.h
  • JYPCIe5112_Channel_3 : JYPCIe5112.h
  • JYPCIe5112_Channel_4 : JYPCIe5112.h
  • JYPCIe5112_Channel_5 : JYPCIe5112.h
  • JYPCIe5112_Channel_6 : JYPCIe5112.h
  • JYPCIe5112_Channel_7 : JYPCIe5112.h
  • JYPCIe5112_Channel_8 : JYPCIe5112.h
  • JYPCIe5112_Channel_9 : JYPCIe5112.h
  • JYPCIe5112_CI_Count_Down : JYPCIe5112.h
  • JYPCIe5112_CI_Count_External : JYPCIe5112.h
  • JYPCIe5112_CI_Count_Up : JYPCIe5112.h
  • JYPCIe5112_CI_CounterEventSignalIdleState : JYPCIe5112.h
  • JYPCIe5112_CI_CounterEventSignalIdleState_High : JYPCIe5112.h
  • JYPCIe5112_CI_CounterEventSignalIdleState_Low : JYPCIe5112.h
  • JYPCIe5112_CI_EdgeCount : JYPCIe5112.h
  • JYPCIe5112_CI_EnableChannel() : JYPCIe5112.h
  • JYPCIe5112_CI_EncoderTwoPulse : JYPCIe5112.h
  • JYPCIe5112_CI_EncoderX1 : JYPCIe5112.h
  • JYPCIe5112_CI_EncoderX2 : JYPCIe5112.h
  • JYPCIe5112_CI_EncoderX4 : JYPCIe5112.h
  • JYPCIe5112_CI_ExternalClock : JYPCIe5112.h
  • JYPCIe5112_CI_ImplicitClock : JYPCIe5112.h
  • JYPCIe5112_CI_InternalClock : JYPCIe5112.h
  • JYPCIe5112_CI_Measure_EdgeSeparation : JYPCIe5112.h
  • JYPCIe5112_CI_Measure_FrequencyOrPeriod : JYPCIe5112.h
  • JYPCIe5112_CI_Measure_PulseWidth : JYPCIe5112.h
  • JYPCIe5112_CI_Measure_SemiPeriod : JYPCIe5112.h
  • JYPCIe5112_CI_MeasureType : JYPCIe5112.h
  • JYPCIe5112_CI_ReadSingleCountValue() : JYPCIe5112.h
  • JYPCIe5112_CI_ReadSingleMeasureValue() : JYPCIe5112.h
  • JYPCIe5112_CI_ReturnOneValue : JYPCIe5112.h
  • JYPCIe5112_CI_ReturnTwoValue : JYPCIe5112.h
  • JYPCIe5112_CI_SampleClock : JYPCIe5112.h
  • JYPCIe5112_CI_SendSoftTrigger() : JYPCIe5112.h
  • JYPCIe5112_CI_SetAuxTerminal() : JYPCIe5112.h
  • JYPCIe5112_CI_SetCounterParament() : JYPCIe5112.h
  • JYPCIe5112_CI_SetCounterType() : JYPCIe5112.h
  • JYPCIe5112_CI_SetDigitalStartTrigger() : JYPCIe5112.h
  • JYPCIe5112_CI_SetEdgeCountEvent() : JYPCIe5112.h
  • JYPCIe5112_CI_SetFirstSampleClock() : JYPCIe5112.h
  • JYPCIe5112_CI_SetGateTerminal() : JYPCIe5112.h
  • JYPCIe5112_CI_SetOutTerminal() : JYPCIe5112.h
  • JYPCIe5112_CI_SetPauseTriggerLevel() : JYPCIe5112.h
  • JYPCIe5112_CI_SetPauseTriggerTerminal() : JYPCIe5112.h
  • JYPCIe5112_CI_SetSignalReverse() : JYPCIe5112.h
  • JYPCIe5112_CI_SetSourceTerminal() : JYPCIe5112.h
  • JYPCIe5112_CI_SetStartingEdge() : JYPCIe5112.h
  • JYPCIe5112_CI_SetStartTriggerType() : JYPCIe5112.h
  • JYPCIe5112_CI_SetTimeBase() : JYPCIe5112.h
  • JYPCIe5112_CI_SetValueReturnMode() : JYPCIe5112.h
  • JYPCIe5112_CI_SetZReloadEnabled() : JYPCIe5112.h
  • JYPCIe5112_CI_Start() : JYPCIe5112.h
  • JYPCIe5112_CI_StartingEdge : JYPCIe5112.h
  • JYPCIe5112_CI_Stop() : JYPCIe5112.h
  • JYPCIe5112_CI_ValueReturnMode : JYPCIe5112.h
  • JYPCIe5112_CIO_0_StartTrig : JYPCIe5112.h
  • JYPCIe5112_CIO_1_StartTrig : JYPCIe5112.h
  • JYPCIe5112_CIO_Digital : JYPCIe5112.h
  • JYPCIe5112_CIO_Immediately : JYPCIe5112.h
  • JYPCIe5112_CIO_Soft : JYPCIe5112.h
  • JYPCIe5112_CIO_TriggerType : JYPCIe5112.h
  • JYPCIe5112_Clock_Default : JYPCIe5112.h
  • JYPCIe5112_Clock_Inter_AI_SampleClock : JYPCIe5112.h
  • JYPCIe5112_Clock_Inter_AO_SampleClock : JYPCIe5112.h
  • JYPCIe5112_Clock_Inter_CO_0_Output : JYPCIe5112.h
  • JYPCIe5112_Clock_Inter_CO_1_Output : JYPCIe5112.h
  • JYPCIe5112_Clock_PFI0_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PFI10_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PFI11_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PFI12_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PFI13_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PFI14_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PFI15_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PFI1_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PFI2_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PFI3_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PFI4_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PFI5_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PFI6_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PFI7_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PFI8_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PFI9_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PXI_Trig0_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PXI_Trig1_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PXI_Trig2_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PXI_Trig3_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PXI_Trig4_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PXI_Trig5_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PXI_Trig6_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PXI_Trig7_IN : JYPCIe5112.h
  • JYPCIe5112_ClockSource : JYPCIe5112.h
  • JYPCIe5112_Close() : JYPCIe5112.h
  • JYPCIe5112_CO_0_Output : JYPCIe5112.h
  • JYPCIe5112_CO_1_Output : JYPCIe5112.h
  • JYPCIe5112_CO_CheckCounterStatus() : JYPCIe5112.h
  • JYPCIe5112_CO_EnableChannel() : JYPCIe5112.h
  • JYPCIe5112_CO_HighLevel : JYPCIe5112.h
  • JYPCIe5112_CO_HighOut : JYPCIe5112.h
  • JYPCIe5112_CO_HoldOn : JYPCIe5112.h
  • JYPCIe5112_CO_IdleState : JYPCIe5112.h
  • JYPCIe5112_CO_LowLevel : JYPCIe5112.h
  • JYPCIe5112_CO_LowOut : JYPCIe5112.h
  • JYPCIe5112_CO_PauseTriger_OutState : JYPCIe5112.h
  • JYPCIe5112_CO_SendSoftTrigger() : JYPCIe5112.h
  • JYPCIe5112_CO_SetCounterParament() : JYPCIe5112.h
  • JYPCIe5112_CO_SetDigitalStartTrigger() : JYPCIe5112.h
  • JYPCIe5112_CO_SetFrequency() : JYPCIe5112.h
  • JYPCIe5112_CO_SetOutTerminal() : JYPCIe5112.h
  • JYPCIe5112_CO_SetPauseTriggerLevel() : JYPCIe5112.h
  • JYPCIe5112_CO_SetPauseTriggerOutState() : JYPCIe5112.h
  • JYPCIe5112_CO_SetPauseTriggerTerminal() : JYPCIe5112.h
  • JYPCIe5112_CO_SetStartTriggerType() : JYPCIe5112.h
  • JYPCIe5112_CO_SetTimeBase() : JYPCIe5112.h
  • JYPCIe5112_CO_Start() : JYPCIe5112.h
  • JYPCIe5112_CO_Stop() : JYPCIe5112.h
  • JYPCIe5112_CO_WaitUntilDone() : JYPCIe5112.h
  • JYPCIe5112_CountDirection : JYPCIe5112.h
  • JYPCIe5112_CountTimeBase : JYPCIe5112.h
  • JYPCIe5112_DeviceHandle : JYPCIe5112.h
  • JYPCIe5112_DI_AddLines() : JYPCIe5112.h
  • JYPCIe5112_DI_ReadSinglePoint() : JYPCIe5112.h
  • JYPCIe5112_DI_ReadSinglePoint_U32() : JYPCIe5112.h
  • JYPCIe5112_DI_ReadSinglePoint_U8() : JYPCIe5112.h
  • JYPCIe5112_DI_Start() : JYPCIe5112.h
  • JYPCIe5112_DI_Stop() : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_Inter_AI_ReferenceTrig : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_Inter_AI_StartTrig : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_Inter_AO_StartTrig : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_Inter_CIO_0_StartTrig : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_Inter_CIO_1_StartTrig : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_Inter_CO_0_Output : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_Inter_CO_1_Output : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PFI0 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PFI1 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PFI10 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PFI11 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PFI12 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PFI13 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PFI14 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PFI15 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PFI2 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PFI3 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PFI4 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PFI5 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PFI6 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PFI7 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PFI8 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PFI9 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PXI_Trig0 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PXI_Trig1 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PXI_Trig2 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PXI_Trig3 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PXI_Trig4 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PXI_Trig5 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PXI_Trig6 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PXI_Trig7 : JYPCIe5112.h
  • JYPCIe5112_DigitalTriggerEdge : JYPCIe5112.h
  • JYPCIe5112_DigitalTriggerSource : JYPCIe5112.h
  • JYPCIe5112_DisableAICalibration() : JYPCIe5112.h
  • JYPCIe5112_DisableAOCalibration() : JYPCIe5112.h
  • JYPCIe5112_DisconnectSignalRouting() : JYPCIe5112.h
  • JYPCIe5112_DO_AddLines() : JYPCIe5112.h
  • JYPCIe5112_DO_Start() : JYPCIe5112.h
  • JYPCIe5112_DO_Stop() : JYPCIe5112.h
  • JYPCIe5112_DO_WriteSinglePoint() : JYPCIe5112.h
  • JYPCIe5112_DO_WriteSinglePoint_U32() : JYPCIe5112.h
  • JYPCIe5112_DO_WriteSinglePoint_U8() : JYPCIe5112.h
  • JYPCIe5112_Entering : JYPCIe5112.h
  • JYPCIe5112_External_Timebase : JYPCIe5112.h
  • JYPCIe5112_ExternalClock : JYPCIe5112.h
  • JYPCIe5112_ExternalClockTerminal : JYPCIe5112.h
  • JYPCIe5112_Falling : JYPCIe5112.h
  • JYPCIe5112_FallingEdge : JYPCIe5112.h
  • JYPCIe5112_FallingSlope : JYPCIe5112.h
  • JYPCIe5112_GetDeviceID() : JYPCIe5112.h
  • JYPCIe5112_GetDeviceSerialNumber() : JYPCIe5112.h
  • JYPCIe5112_HighLevel : JYPCIe5112.h
  • JYPCIe5112_Hold : JYPCIe5112.h
  • JYPCIe5112_Input_CIO_100KHz : JYPCIe5112.h
  • JYPCIe5112_Input_CIO_100MHz : JYPCIe5112.h
  • JYPCIe5112_Input_CIO_5MHz : JYPCIe5112.h
  • JYPCIe5112_Input_CO_0_Out : JYPCIe5112.h
  • JYPCIe5112_Input_CO_1_Out : JYPCIe5112.h
  • JYPCIe5112_Input_PFI0 : JYPCIe5112.h
  • JYPCIe5112_Input_PFI1 : JYPCIe5112.h
  • JYPCIe5112_Input_PFI10 : JYPCIe5112.h
  • JYPCIe5112_Input_PFI11 : JYPCIe5112.h
  • JYPCIe5112_Input_PFI12 : JYPCIe5112.h
  • JYPCIe5112_Input_PFI13 : JYPCIe5112.h
  • JYPCIe5112_Input_PFI14 : JYPCIe5112.h
  • JYPCIe5112_Input_PFI15 : JYPCIe5112.h
  • JYPCIe5112_Input_PFI2 : JYPCIe5112.h
  • JYPCIe5112_Input_PFI3 : JYPCIe5112.h
  • JYPCIe5112_Input_PFI4 : JYPCIe5112.h
  • JYPCIe5112_Input_PFI5 : JYPCIe5112.h
  • JYPCIe5112_Input_PFI6 : JYPCIe5112.h
  • JYPCIe5112_Input_PFI7 : JYPCIe5112.h
  • JYPCIe5112_Input_PFI8 : JYPCIe5112.h
  • JYPCIe5112_Input_PFI9 : JYPCIe5112.h
  • JYPCIe5112_Input_PXI_Trig0 : JYPCIe5112.h
  • JYPCIe5112_Input_PXI_Trig1 : JYPCIe5112.h
  • JYPCIe5112_Input_PXI_Trig2 : JYPCIe5112.h
  • JYPCIe5112_Input_PXI_Trig3 : JYPCIe5112.h
  • JYPCIe5112_Input_PXI_Trig4 : JYPCIe5112.h
  • JYPCIe5112_Input_PXI_Trig5_ : JYPCIe5112.h
  • JYPCIe5112_Input_PXI_Trig6 : JYPCIe5112.h
  • JYPCIe5112_Input_PXI_Trig7 : JYPCIe5112.h
  • JYPCIe5112_InputTerminal : JYPCIe5112.h
  • JYPCIe5112_Internal_Timebase_100K : JYPCIe5112.h
  • JYPCIe5112_Internal_Timebase_100M : JYPCIe5112.h
  • JYPCIe5112_Internal_Timebase_5M : JYPCIe5112.h
  • JYPCIe5112_InternalClock : JYPCIe5112.h
  • JYPCIe5112_Leaving : JYPCIe5112.h
  • JYPCIe5112_LevelState : JYPCIe5112.h
  • JYPCIe5112_LowLevel : JYPCIe5112.h
  • JYPCIe5112_None : JYPCIe5112.h
  • JYPCIe5112_Open() : JYPCIe5112.h
  • JYPCIe5112_OpenByName() : JYPCIe5112.h
  • JYPCIe5112_OutputCompleteState : JYPCIe5112.h
  • JYPCIe5112_PFI0_OUT : JYPCIe5112.h
  • JYPCIe5112_PFI10_OUT : JYPCIe5112.h
  • JYPCIe5112_PFI11_OUT : JYPCIe5112.h
  • JYPCIe5112_PFI12_OUT : JYPCIe5112.h
  • JYPCIe5112_PFI13_OUT : JYPCIe5112.h
  • JYPCIe5112_PFI14_OUT : JYPCIe5112.h
  • JYPCIe5112_PFI15_OUT : JYPCIe5112.h
  • JYPCIe5112_PFI1_OUT : JYPCIe5112.h
  • JYPCIe5112_PFI2_OUT : JYPCIe5112.h
  • JYPCIe5112_PFI3_OUT : JYPCIe5112.h
  • JYPCIe5112_PFI4_OUT : JYPCIe5112.h
  • JYPCIe5112_PFI5_OUT : JYPCIe5112.h
  • JYPCIe5112_PFI6_OUT : JYPCIe5112.h
  • JYPCIe5112_PFI7_OUT : JYPCIe5112.h
  • JYPCIe5112_PFI8_OUT : JYPCIe5112.h
  • JYPCIe5112_PFI9_OUT : JYPCIe5112.h
  • JYPCIe5112_PXITrig0_OUT : JYPCIe5112.h
  • JYPCIe5112_PXITrig1_OUT : JYPCIe5112.h
  • JYPCIe5112_PXITrig2_OUT : JYPCIe5112.h
  • JYPCIe5112_PXITrig3_OUT : JYPCIe5112.h
  • JYPCIe5112_PXITrig4_OUT : JYPCIe5112.h
  • JYPCIe5112_PXITrig5_OUT : JYPCIe5112.h
  • JYPCIe5112_PXITrig6_OUT : JYPCIe5112.h
  • JYPCIe5112_PXITrig7_OUT : JYPCIe5112.h
  • JYPCIe5112_ReferenceTrigger : JYPCIe5112.h
  • JYPCIe5112_Rising : JYPCIe5112.h
  • JYPCIe5112_RisingEdge : JYPCIe5112.h
  • JYPCIe5112_RisingSlope : JYPCIe5112.h
  • JYPCIe5112_SetDeviceStatusLed() : JYPCIe5112.h
  • JYPCIe5112_SetPFIFilter() : JYPCIe5112.h
  • JYPCIe5112_Signal_Destination : JYPCIe5112.h
  • JYPCIe5112_Signal_Source : JYPCIe5112.h
  • JYPCIe5112_SignalRouting() : JYPCIe5112.h
  • JYPCIe5112_StartTrigger : JYPCIe5112.h
  • JYPCIe5112_TriggerMode : JYPCIe5112.h
  • JYPCIe5112_Zero : JYPCIe5112.h


  • Enumerations
  • Enumerator
Here is a list of all enums with links to the files they belong to:
  • JYPCIe5112_AI_SampleMode : JYPCIe5112.h
  • JYPCIe5112_AI_Terminal : JYPCIe5112.h
  • JYPCIe5112_AI_TriggerType : JYPCIe5112.h
  • JYPCIe5112_AnalogTriggerEdge : JYPCIe5112.h
  • JYPCIe5112_AnalogTriggerSource : JYPCIe5112.h
  • JYPCIe5112_AnalogWindowCondition : JYPCIe5112.h
  • JYPCIe5112_AO_TriggerType : JYPCIe5112.h
  • JYPCIe5112_AO_UpdateMode : JYPCIe5112.h
  • JYPCIe5112_CI_CounterEventSignalIdleState : JYPCIe5112.h
  • JYPCIe5112_CI_MeasureType : JYPCIe5112.h
  • JYPCIe5112_CI_SampleClock : JYPCIe5112.h
  • JYPCIe5112_CI_StartingEdge : JYPCIe5112.h
  • JYPCIe5112_CI_ValueReturnMode : JYPCIe5112.h
  • JYPCIe5112_CIO_TriggerType : JYPCIe5112.h
  • JYPCIe5112_ClockSource : JYPCIe5112.h
  • JYPCIe5112_CO_IdleState : JYPCIe5112.h
  • JYPCIe5112_CO_PauseTriger_OutState : JYPCIe5112.h
  • JYPCIe5112_CountDirection : JYPCIe5112.h
  • JYPCIe5112_CountTimeBase : JYPCIe5112.h
  • JYPCIe5112_DigitalTriggerEdge : JYPCIe5112.h
  • JYPCIe5112_DigitalTriggerSource : JYPCIe5112.h
  • JYPCIe5112_ExternalClockTerminal : JYPCIe5112.h
  • JYPCIe5112_InputTerminal : JYPCIe5112.h
  • JYPCIe5112_LevelState : JYPCIe5112.h
  • JYPCIe5112_OutputCompleteState : JYPCIe5112.h
  • JYPCIe5112_Signal_Destination : JYPCIe5112.h
  • JYPCIe5112_Signal_Source : JYPCIe5112.h
  • JYPCIe5112_TriggerMode : JYPCIe5112.h


  • Enumerations
  • Enumerator
  • j
Here is a list of all enum values with links to the files they belong to:

- j -

  • JYPCIe5112_AI_Analog : JYPCIe5112.h
  • JYPCIe5112_AI_Continuous : JYPCIe5112.h
  • JYPCIe5112_AI_Diff : JYPCIe5112.h
  • JYPCIe5112_AI_Digital : JYPCIe5112.h
  • JYPCIe5112_AI_Finite : JYPCIe5112.h
  • JYPCIe5112_AI_Immediately : JYPCIe5112.h
  • JYPCIe5112_AI_NRSE : JYPCIe5112.h
  • JYPCIe5112_AI_ReferenceTrig : JYPCIe5112.h
  • JYPCIe5112_AI_RSE : JYPCIe5112.h
  • JYPCIe5112_AI_SampleClock : JYPCIe5112.h
  • JYPCIe5112_AI_Single : JYPCIe5112.h
  • JYPCIe5112_AI_Soft : JYPCIe5112.h
  • JYPCIe5112_AI_StartTrig : JYPCIe5112.h
  • JYPCIe5112_AnyEdge : JYPCIe5112.h
  • JYPCIe5112_AO_ContinuousNoWrapping : JYPCIe5112.h
  • JYPCIe5112_AO_ContinuousWrapping : JYPCIe5112.h
  • JYPCIe5112_AO_Digital : JYPCIe5112.h
  • JYPCIe5112_AO_Finite : JYPCIe5112.h
  • JYPCIe5112_AO_Immediately : JYPCIe5112.h
  • JYPCIe5112_AO_SampleClock : JYPCIe5112.h
  • JYPCIe5112_AO_Single : JYPCIe5112.h
  • JYPCIe5112_AO_Soft : JYPCIe5112.h
  • JYPCIe5112_AO_StartTrig : JYPCIe5112.h
  • JYPCIe5112_Channel_0 : JYPCIe5112.h
  • JYPCIe5112_Channel_1 : JYPCIe5112.h
  • JYPCIe5112_Channel_10 : JYPCIe5112.h
  • JYPCIe5112_Channel_11 : JYPCIe5112.h
  • JYPCIe5112_Channel_12 : JYPCIe5112.h
  • JYPCIe5112_Channel_13 : JYPCIe5112.h
  • JYPCIe5112_Channel_14 : JYPCIe5112.h
  • JYPCIe5112_Channel_15 : JYPCIe5112.h
  • JYPCIe5112_Channel_2 : JYPCIe5112.h
  • JYPCIe5112_Channel_3 : JYPCIe5112.h
  • JYPCIe5112_Channel_4 : JYPCIe5112.h
  • JYPCIe5112_Channel_5 : JYPCIe5112.h
  • JYPCIe5112_Channel_6 : JYPCIe5112.h
  • JYPCIe5112_Channel_7 : JYPCIe5112.h
  • JYPCIe5112_Channel_8 : JYPCIe5112.h
  • JYPCIe5112_Channel_9 : JYPCIe5112.h
  • JYPCIe5112_CI_Count_Down : JYPCIe5112.h
  • JYPCIe5112_CI_Count_External : JYPCIe5112.h
  • JYPCIe5112_CI_Count_Up : JYPCIe5112.h
  • JYPCIe5112_CI_CounterEventSignalIdleState_High : JYPCIe5112.h
  • JYPCIe5112_CI_CounterEventSignalIdleState_Low : JYPCIe5112.h
  • JYPCIe5112_CI_EdgeCount : JYPCIe5112.h
  • JYPCIe5112_CI_EncoderTwoPulse : JYPCIe5112.h
  • JYPCIe5112_CI_EncoderX1 : JYPCIe5112.h
  • JYPCIe5112_CI_EncoderX2 : JYPCIe5112.h
  • JYPCIe5112_CI_EncoderX4 : JYPCIe5112.h
  • JYPCIe5112_CI_ExternalClock : JYPCIe5112.h
  • JYPCIe5112_CI_ImplicitClock : JYPCIe5112.h
  • JYPCIe5112_CI_InternalClock : JYPCIe5112.h
  • JYPCIe5112_CI_Measure_EdgeSeparation : JYPCIe5112.h
  • JYPCIe5112_CI_Measure_FrequencyOrPeriod : JYPCIe5112.h
  • JYPCIe5112_CI_Measure_PulseWidth : JYPCIe5112.h
  • JYPCIe5112_CI_Measure_SemiPeriod : JYPCIe5112.h
  • JYPCIe5112_CI_ReturnOneValue : JYPCIe5112.h
  • JYPCIe5112_CI_ReturnTwoValue : JYPCIe5112.h
  • JYPCIe5112_CIO_0_StartTrig : JYPCIe5112.h
  • JYPCIe5112_CIO_1_StartTrig : JYPCIe5112.h
  • JYPCIe5112_CIO_Digital : JYPCIe5112.h
  • JYPCIe5112_CIO_Immediately : JYPCIe5112.h
  • JYPCIe5112_CIO_Soft : JYPCIe5112.h
  • JYPCIe5112_Clock_Default : JYPCIe5112.h
  • JYPCIe5112_Clock_Inter_AI_SampleClock : JYPCIe5112.h
  • JYPCIe5112_Clock_Inter_AO_SampleClock : JYPCIe5112.h
  • JYPCIe5112_Clock_Inter_CO_0_Output : JYPCIe5112.h
  • JYPCIe5112_Clock_Inter_CO_1_Output : JYPCIe5112.h
  • JYPCIe5112_Clock_PFI0_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PFI10_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PFI11_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PFI12_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PFI13_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PFI14_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PFI15_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PFI1_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PFI2_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PFI3_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PFI4_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PFI5_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PFI6_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PFI7_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PFI8_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PFI9_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PXI_Trig0_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PXI_Trig1_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PXI_Trig2_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PXI_Trig3_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PXI_Trig4_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PXI_Trig5_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PXI_Trig6_IN : JYPCIe5112.h
  • JYPCIe5112_Clock_PXI_Trig7_IN : JYPCIe5112.h
  • JYPCIe5112_CO_0_Output : JYPCIe5112.h
  • JYPCIe5112_CO_1_Output : JYPCIe5112.h
  • JYPCIe5112_CO_HighLevel : JYPCIe5112.h
  • JYPCIe5112_CO_HighOut : JYPCIe5112.h
  • JYPCIe5112_CO_HoldOn : JYPCIe5112.h
  • JYPCIe5112_CO_LowLevel : JYPCIe5112.h
  • JYPCIe5112_CO_LowOut : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_Inter_AI_ReferenceTrig : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_Inter_AI_StartTrig : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_Inter_AO_StartTrig : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_Inter_CIO_0_StartTrig : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_Inter_CIO_1_StartTrig : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_Inter_CO_0_Output : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_Inter_CO_1_Output : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PFI0 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PFI1 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PFI10 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PFI11 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PFI12 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PFI13 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PFI14 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PFI15 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PFI2 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PFI3 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PFI4 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PFI5 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PFI6 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PFI7 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PFI8 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PFI9 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PXI_Trig0 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PXI_Trig1 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PXI_Trig2 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PXI_Trig3 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PXI_Trig4 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PXI_Trig5 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PXI_Trig6 : JYPCIe5112.h
  • JYPCIe5112_DigitalTrigger_PXI_Trig7 : JYPCIe5112.h
  • JYPCIe5112_Entering : JYPCIe5112.h
  • JYPCIe5112_External_Timebase : JYPCIe5112.h
  • JYPCIe5112_ExternalClock : JYPCIe5112.h
  • JYPCIe5112_Falling : JYPCIe5112.h
  • JYPCIe5112_FallingEdge : JYPCIe5112.h
  • JYPCIe5112_FallingSlope : JYPCIe5112.h
  • JYPCIe5112_HighLevel : JYPCIe5112.h
  • JYPCIe5112_Hold : JYPCIe5112.h
  • JYPCIe5112_Input_CIO_100KHz : JYPCIe5112.h
  • JYPCIe5112_Input_CIO_100MHz : JYPCIe5112.h
  • JYPCIe5112_Input_CIO_5MHz : JYPCIe5112.h
  • JYPCIe5112_Input_CO_0_Out : JYPCIe5112.h
  • JYPCIe5112_Input_CO_1_Out : JYPCIe5112.h
  • JYPCIe5112_Input_PFI0 : JYPCIe5112.h
  • JYPCIe5112_Input_PFI1 : JYPCIe5112.h
  • JYPCIe5112_Input_PFI10 : JYPCIe5112.h
  • JYPCIe5112_Input_PFI11 : JYPCIe5112.h
  • JYPCIe5112_Input_PFI12 : JYPCIe5112.h
  • JYPCIe5112_Input_PFI13 : JYPCIe5112.h
  • JYPCIe5112_Input_PFI14 : JYPCIe5112.h
  • JYPCIe5112_Input_PFI15 : JYPCIe5112.h
  • JYPCIe5112_Input_PFI2 : JYPCIe5112.h
  • JYPCIe5112_Input_PFI3 : JYPCIe5112.h
  • JYPCIe5112_Input_PFI4 : JYPCIe5112.h
  • JYPCIe5112_Input_PFI5 : JYPCIe5112.h
  • JYPCIe5112_Input_PFI6 : JYPCIe5112.h
  • JYPCIe5112_Input_PFI7 : JYPCIe5112.h
  • JYPCIe5112_Input_PFI8 : JYPCIe5112.h
  • JYPCIe5112_Input_PFI9 : JYPCIe5112.h
  • JYPCIe5112_Input_PXI_Trig0 : JYPCIe5112.h
  • JYPCIe5112_Input_PXI_Trig1 : JYPCIe5112.h
  • JYPCIe5112_Input_PXI_Trig2 : JYPCIe5112.h
  • JYPCIe5112_Input_PXI_Trig3 : JYPCIe5112.h
  • JYPCIe5112_Input_PXI_Trig4 : JYPCIe5112.h
  • JYPCIe5112_Input_PXI_Trig5_ : JYPCIe5112.h
  • JYPCIe5112_Input_PXI_Trig6 : JYPCIe5112.h
  • JYPCIe5112_Input_PXI_Trig7 : JYPCIe5112.h
  • JYPCIe5112_Internal_Timebase_100K : JYPCIe5112.h
  • JYPCIe5112_Internal_Timebase_100M : JYPCIe5112.h
  • JYPCIe5112_Internal_Timebase_5M : JYPCIe5112.h
  • JYPCIe5112_InternalClock : JYPCIe5112.h
  • JYPCIe5112_Leaving : JYPCIe5112.h
  • JYPCIe5112_LowLevel : JYPCIe5112.h
  • JYPCIe5112_None : JYPCIe5112.h
  • JYPCIe5112_PFI0_OUT : JYPCIe5112.h
  • JYPCIe5112_PFI10_OUT : JYPCIe5112.h
  • JYPCIe5112_PFI11_OUT : JYPCIe5112.h
  • JYPCIe5112_PFI12_OUT : JYPCIe5112.h
  • JYPCIe5112_PFI13_OUT : JYPCIe5112.h
  • JYPCIe5112_PFI14_OUT : JYPCIe5112.h
  • JYPCIe5112_PFI15_OUT : JYPCIe5112.h
  • JYPCIe5112_PFI1_OUT : JYPCIe5112.h
  • JYPCIe5112_PFI2_OUT : JYPCIe5112.h
  • JYPCIe5112_PFI3_OUT : JYPCIe5112.h
  • JYPCIe5112_PFI4_OUT : JYPCIe5112.h
  • JYPCIe5112_PFI5_OUT : JYPCIe5112.h
  • JYPCIe5112_PFI6_OUT : JYPCIe5112.h
  • JYPCIe5112_PFI7_OUT : JYPCIe5112.h
  • JYPCIe5112_PFI8_OUT : JYPCIe5112.h
  • JYPCIe5112_PFI9_OUT : JYPCIe5112.h
  • JYPCIe5112_PXITrig0_OUT : JYPCIe5112.h
  • JYPCIe5112_PXITrig1_OUT : JYPCIe5112.h
  • JYPCIe5112_PXITrig2_OUT : JYPCIe5112.h
  • JYPCIe5112_PXITrig3_OUT : JYPCIe5112.h
  • JYPCIe5112_PXITrig4_OUT : JYPCIe5112.h
  • JYPCIe5112_PXITrig5_OUT : JYPCIe5112.h
  • JYPCIe5112_PXITrig6_OUT : JYPCIe5112.h
  • JYPCIe5112_PXITrig7_OUT : JYPCIe5112.h
  • JYPCIe5112_ReferenceTrigger : JYPCIe5112.h
  • JYPCIe5112_Rising : JYPCIe5112.h
  • JYPCIe5112_RisingEdge : JYPCIe5112.h
  • JYPCIe5112_RisingSlope : JYPCIe5112.h
  • JYPCIe5112_StartTrigger : JYPCIe5112.h
  • JYPCIe5112_Zero : JYPCIe5112.h


  • Enumerations
  • Enumerator
  • j
Here is a list of all functions with links to the files they belong to:

- j -

  • JYPCIe5112_AI_CheckBufferStatus() : JYPCIe5112.h
  • JYPCIe5112_AI_EnableChannel() : JYPCIe5112.h
  • JYPCIe5112_AI_ReadData() : JYPCIe5112.h
  • JYPCIe5112_AI_ReadRawData() : JYPCIe5112.h
  • JYPCIe5112_AI_ReadRawSinglePoint() : JYPCIe5112.h
  • JYPCIe5112_AI_ReadSinglePoint() : JYPCIe5112.h
  • JYPCIe5112_AI_SendSoftTrigger() : JYPCIe5112.h
  • JYPCIe5112_AI_SetAnalogEdgeReferenceTrigger() : JYPCIe5112.h
  • JYPCIe5112_AI_SetAnalogEdgeStartTrigger() : JYPCIe5112.h
  • JYPCIe5112_AI_SetAnalogHysteresisReferenceTrigger() : JYPCIe5112.h
  • JYPCIe5112_AI_SetAnalogHysteresisStartTrigger() : JYPCIe5112.h
  • JYPCIe5112_AI_SetAnalogWindowReferenceTrigger() : JYPCIe5112.h
  • JYPCIe5112_AI_SetAnalogWindowStartTrigger() : JYPCIe5112.h
  • JYPCIe5112_AI_SetDigitalReferenceTrigger() : JYPCIe5112.h
  • JYPCIe5112_AI_SetDigitalStartTrigger() : JYPCIe5112.h
  • JYPCIe5112_AI_SetMode() : JYPCIe5112.h
  • JYPCIe5112_AI_SetPreTriggerSamples() : JYPCIe5112.h
  • JYPCIe5112_AI_SetReferenceTriggerType() : JYPCIe5112.h
  • JYPCIe5112_AI_SetReTriggerCount() : JYPCIe5112.h
  • JYPCIe5112_AI_SetSampleClock() : JYPCIe5112.h
  • JYPCIe5112_AI_SetSampleRate() : JYPCIe5112.h
  • JYPCIe5112_AI_SetSamplesToAcquire() : JYPCIe5112.h
  • JYPCIe5112_AI_SetScanRate() : JYPCIe5112.h
  • JYPCIe5112_AI_SetStartTriggerType() : JYPCIe5112.h
  • JYPCIe5112_AI_Start() : JYPCIe5112.h
  • JYPCIe5112_AI_Stop() : JYPCIe5112.h
  • JYPCIe5112_AI_WaitUntilDone() : JYPCIe5112.h
  • JYPCIe5112_AO_CheckBufferStatus() : JYPCIe5112.h
  • JYPCIe5112_AO_EnableChannel() : JYPCIe5112.h
  • JYPCIe5112_AO_SendSoftTrigger() : JYPCIe5112.h
  • JYPCIe5112_AO_SetDigitalStartTrigger() : JYPCIe5112.h
  • JYPCIe5112_AO_SetMode() : JYPCIe5112.h
  • JYPCIe5112_AO_SetOutputCompleteState() : JYPCIe5112.h
  • JYPCIe5112_AO_SetSampleClock() : JYPCIe5112.h
  • JYPCIe5112_AO_SetSamplesToUpdate() : JYPCIe5112.h
  • JYPCIe5112_AO_SetStartTriggerType() : JYPCIe5112.h
  • JYPCIe5112_AO_SetUpdateRate() : JYPCIe5112.h
  • JYPCIe5112_AO_Start() : JYPCIe5112.h
  • JYPCIe5112_AO_Stop() : JYPCIe5112.h
  • JYPCIe5112_AO_WaitUntilDone() : JYPCIe5112.h
  • JYPCIe5112_AO_WriteData() : JYPCIe5112.h
  • JYPCIe5112_AO_WriteRawData() : JYPCIe5112.h
  • JYPCIe5112_AO_WriteRawSinglePoint() : JYPCIe5112.h
  • JYPCIe5112_AO_WriteSinglePoint() : JYPCIe5112.h
  • JYPCIe5112_CI_EnableChannel() : JYPCIe5112.h
  • JYPCIe5112_CI_ReadSingleCountValue() : JYPCIe5112.h
  • JYPCIe5112_CI_ReadSingleMeasureValue() : JYPCIe5112.h
  • JYPCIe5112_CI_SendSoftTrigger() : JYPCIe5112.h
  • JYPCIe5112_CI_SetAuxTerminal() : JYPCIe5112.h
  • JYPCIe5112_CI_SetCounterParament() : JYPCIe5112.h
  • JYPCIe5112_CI_SetCounterType() : JYPCIe5112.h
  • JYPCIe5112_CI_SetDigitalStartTrigger() : JYPCIe5112.h
  • JYPCIe5112_CI_SetEdgeCountEvent() : JYPCIe5112.h
  • JYPCIe5112_CI_SetFirstSampleClock() : JYPCIe5112.h
  • JYPCIe5112_CI_SetGateTerminal() : JYPCIe5112.h
  • JYPCIe5112_CI_SetOutTerminal() : JYPCIe5112.h
  • JYPCIe5112_CI_SetPauseTriggerLevel() : JYPCIe5112.h
  • JYPCIe5112_CI_SetPauseTriggerTerminal() : JYPCIe5112.h
  • JYPCIe5112_CI_SetSignalReverse() : JYPCIe5112.h
  • JYPCIe5112_CI_SetSourceTerminal() : JYPCIe5112.h
  • JYPCIe5112_CI_SetStartingEdge() : JYPCIe5112.h
  • JYPCIe5112_CI_SetStartTriggerType() : JYPCIe5112.h
  • JYPCIe5112_CI_SetTimeBase() : JYPCIe5112.h
  • JYPCIe5112_CI_SetValueReturnMode() : JYPCIe5112.h
  • JYPCIe5112_CI_SetZReloadEnabled() : JYPCIe5112.h
  • JYPCIe5112_CI_Start() : JYPCIe5112.h
  • JYPCIe5112_CI_Stop() : JYPCIe5112.h
  • JYPCIe5112_Close() : JYPCIe5112.h
  • JYPCIe5112_CO_CheckCounterStatus() : JYPCIe5112.h
  • JYPCIe5112_CO_EnableChannel() : JYPCIe5112.h
  • JYPCIe5112_CO_SendSoftTrigger() : JYPCIe5112.h
  • JYPCIe5112_CO_SetCounterParament() : JYPCIe5112.h
  • JYPCIe5112_CO_SetDigitalStartTrigger() : JYPCIe5112.h
  • JYPCIe5112_CO_SetFrequency() : JYPCIe5112.h
  • JYPCIe5112_CO_SetOutTerminal() : JYPCIe5112.h
  • JYPCIe5112_CO_SetPauseTriggerLevel() : JYPCIe5112.h
  • JYPCIe5112_CO_SetPauseTriggerOutState() : JYPCIe5112.h
  • JYPCIe5112_CO_SetPauseTriggerTerminal() : JYPCIe5112.h
  • JYPCIe5112_CO_SetStartTriggerType() : JYPCIe5112.h
  • JYPCIe5112_CO_SetTimeBase() : JYPCIe5112.h
  • JYPCIe5112_CO_Start() : JYPCIe5112.h
  • JYPCIe5112_CO_Stop() : JYPCIe5112.h
  • JYPCIe5112_CO_WaitUntilDone() : JYPCIe5112.h
  • JYPCIe5112_DI_AddLines() : JYPCIe5112.h
  • JYPCIe5112_DI_ReadSinglePoint() : JYPCIe5112.h
  • JYPCIe5112_DI_ReadSinglePoint_U32() : JYPCIe5112.h
  • JYPCIe5112_DI_ReadSinglePoint_U8() : JYPCIe5112.h
  • JYPCIe5112_DI_Start() : JYPCIe5112.h
  • JYPCIe5112_DI_Stop() : JYPCIe5112.h
  • JYPCIe5112_DisableAICalibration() : JYPCIe5112.h
  • JYPCIe5112_DisableAOCalibration() : JYPCIe5112.h
  • JYPCIe5112_DisconnectSignalRouting() : JYPCIe5112.h
  • JYPCIe5112_DO_AddLines() : JYPCIe5112.h
  • JYPCIe5112_DO_Start() : JYPCIe5112.h
  • JYPCIe5112_DO_Stop() : JYPCIe5112.h
  • JYPCIe5112_DO_WriteSinglePoint() : JYPCIe5112.h
  • JYPCIe5112_DO_WriteSinglePoint_U32() : JYPCIe5112.h
  • JYPCIe5112_DO_WriteSinglePoint_U8() : JYPCIe5112.h
  • JYPCIe5112_GetDeviceID() : JYPCIe5112.h
  • JYPCIe5112_GetDeviceSerialNumber() : JYPCIe5112.h
  • JYPCIe5112_Open() : JYPCIe5112.h
  • JYPCIe5112_OpenByName() : JYPCIe5112.h
  • JYPCIe5112_SetDeviceStatusLed() : JYPCIe5112.h
  • JYPCIe5112_SetPFIFilter() : JYPCIe5112.h
  • JYPCIe5112_SignalRouting() : JYPCIe5112.h


  • Enumerations
  • Enumerator
Here is a list of all typedefs with links to the files they belong to:
  • JYPCIe5112_DeviceHandle : JYPCIe5112.h


5112 C++ Programming Manual: Main Page

5112 C++ Programming Manual Documentation