5112 C++ Programming Manual: COO/5112 Directory Reference

5112 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 5112
5112 Directory Reference

Files

JYPCIe5112CoreOOAITask.h
JYPCIe5112CoreOOAOTask.h
JYPCIe5112CoreOOCITask.h
JYPCIe5112CoreOOCommon.h
JYPCIe5112CoreOOCOTask.h
JYPCIe5112CoreOODevice.h
JYPCIe5112CoreOODITask.h
JYPCIe5112CoreOODOTask.h
JYPCIe5112CoreOOLog.h
Generated by doxygen 1.13.2


5112 C++ Programming Manual: COO/5112/JYPCIe5112CoreOOAITask.h File Reference

  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 5112
Classes | Namespaces | Enumerations
JYPCIe5112CoreOOAITask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JYPCIe5112CoreOOCommon.h"
#include "JYPCIe5112CoreOODevice.h"

Classes

class | JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
AITask类 More...
class | JYPCIe5112CoreOO::AIChannel
AI Channel parameter class . More...
class | JYPCIe5112CoreOO::AIExternalSampleClock
Sample clock configuration class. More...
class | JYPCIe5112CoreOO::AISampleClock
Sample clock configuration class. More...
class | JYPCIe5112CoreOO::AITrigger
Constructor to create an AITrigger task object. More...
class | JYPCIe5112CoreOO::AIDigitalTrigger
AI Digital trigger class. More...
class | JYPCIe5112CoreOO::AIAnalogHysteresisComparator
AI Analog Hysteresis Comparatorr. More...
class | JYPCIe5112CoreOO::AIAnalogWindowComparator
AI Analog Window Comparatorr. More...
class | JYPCIe5112CoreOO::AIAnalogEdgeComparator
AI Analog Edge Comparator. More...
class | JYPCIe5112CoreOO::AIAnalogTrigger
AI analog trigger . More...
class | JYPCIe5112CoreOO::AIRecord
AI Record Parameters. More...
class | JYPCIe5112CoreOO::AIDSMode
class | JYPCIe5112CoreOO::AIAdvanced
AI Advance parameter. More...
class | JYPCIe5112CoreOO::AISignalExport
AI Signal Export Class. More...

Namespaces

namespace JYPCIe5112CoreOO

Enumerations

enum class | JYPCIe5112CoreOO::AITerminal { JYPCIe5112CoreOO::RSE = 0x0 , JYPCIe5112CoreOO::NRSE = 0x1 , JYPCIe5112CoreOO::Differential = 0x2 }
enum class | JYPCIe5112CoreOO::AIMode { JYPCIe5112CoreOO::Single = 0x2 , JYPCIe5112CoreOO::Finite = 0x0 , JYPCIe5112CoreOO::Continuous = 0x1 , JYPCIe5112CoreOO::Record = 0x3 }
enum class | JYPCIe5112CoreOO::AISampleClockSource { JYPCIe5112CoreOO::Internal , JYPCIe5112CoreOO::External }
AI Sample Clock Source. More...
enum class | JYPCIe5112CoreOO::AITriggerType { JYPCIe5112CoreOO::Immediate = 0x0 , JYPCIe5112CoreOO::Digital = 0x1 , JYPCIe5112CoreOO::Analog = 0x2 , JYPCIe5112CoreOO::Soft = 0x3 }
Trigger Type Digital/Analog/Immediate/Soft. More...
enum class | JYPCIe5112CoreOO::AITriggerMode { JYPCIe5112CoreOO::Start , JYPCIe5112CoreOO::Reference }
AI Trigger Mode. More...
enum class JYPCIe5112CoreOO::AIAnalogTriggerSource {
JYPCIe5112CoreOO::Channel_0 , JYPCIe5112CoreOO::Channel_1 , JYPCIe5112CoreOO::Channel_2 , JYPCIe5112CoreOO::Channel_3 ,
JYPCIe5112CoreOO::Channel_4 , JYPCIe5112CoreOO::Channel_5 , JYPCIe5112CoreOO::Channel_6 , JYPCIe5112CoreOO::Channel_7 ,
JYPCIe5112CoreOO::Channel_8 , JYPCIe5112CoreOO::Channel_9 , JYPCIe5112CoreOO::Channel_10 , JYPCIe5112CoreOO::Channel_11 ,
JYPCIe5112CoreOO::Channel_12 , JYPCIe5112CoreOO::Channel_13 , JYPCIe5112CoreOO::Channel_14 , JYPCIe5112CoreOO::Channel_15 ,
JYPCIe5112CoreOO::Channel_16 , JYPCIe5112CoreOO::Channel_17 , JYPCIe5112CoreOO::Channel_18 , JYPCIe5112CoreOO::Channel_19 ,
JYPCIe5112CoreOO::Channel_20 , JYPCIe5112CoreOO::Channel_21 , JYPCIe5112CoreOO::Channel_22 , JYPCIe5112CoreOO::Channel_23 ,
JYPCIe5112CoreOO::Channel_24 , JYPCIe5112CoreOO::Channel_25 , JYPCIe5112CoreOO::Channel_26 , JYPCIe5112CoreOO::Channel_27 ,
JYPCIe5112CoreOO::Channel_28 , JYPCIe5112CoreOO::Channel_29 , JYPCIe5112CoreOO::Channel_30 , JYPCIe5112CoreOO::Channel_31
}
AI analog trigger source. More...
enum class JYPCIe5112CoreOO::AIDigitalTriggerSource {
JYPCIe5112CoreOO::PFI0 , JYPCIe5112CoreOO::PFI1 , JYPCIe5112CoreOO::PFI2 , JYPCIe5112CoreOO::PFI3 ,
JYPCIe5112CoreOO::PFI4 , JYPCIe5112CoreOO::PFI5 , JYPCIe5112CoreOO::PFI6 , JYPCIe5112CoreOO::PFI7 ,
JYPCIe5112CoreOO::PFI8 , JYPCIe5112CoreOO::PFI9 , JYPCIe5112CoreOO::PFI10 , JYPCIe5112CoreOO::PFI11 ,
JYPCIe5112CoreOO::PFI12 , JYPCIe5112CoreOO::PFI13 , JYPCIe5112CoreOO::PFI14 , JYPCIe5112CoreOO::PFI15 ,
JYPCIe5112CoreOO::PXI_Trig0 = 40 , JYPCIe5112CoreOO::PXI_Trig1 = 41 , JYPCIe5112CoreOO::PXI_Trig2 = 42 , JYPCIe5112CoreOO::PXI_Trig3 = 43 ,
JYPCIe5112CoreOO::PXI_Trig4 = 44 , JYPCIe5112CoreOO::PXI_Trig5 = 45 , JYPCIe5112CoreOO::PXI_Trig6 = 46 , JYPCIe5112CoreOO::PXI_Trig7 = 47 ,
JYPCIe5112CoreOO::AO_StartTrig = 26 , JYPCIe5112CoreOO::DI_StartTrig = 22 , JYPCIe5112CoreOO::DI_ReferenceTrig = 23 , JYPCIe5112CoreOO::DO_StartTrig = 29 ,
JYPCIe5112CoreOO::CI_0_StartTrig = 68 , JYPCIe5112CoreOO::CI_1_StartTrig = 73 , JYPCIe5112CoreOO::CI_2_StartTrig = 76 , JYPCIe5112CoreOO::CI_3_StartTrig = 79 ,
JYPCIe5112CoreOO::CO_0_StartTrig = 69 , JYPCIe5112CoreOO::CO_1_StartTrig = 74 , JYPCIe5112CoreOO::CO_2_StartTrig = 77 , JYPCIe5112CoreOO::CO_3_StartTrig = 80 ,
JYPCIe5112CoreOO::CO_0_Output = 37 , JYPCIe5112CoreOO::CO_1_Output = 51 , JYPCIe5112CoreOO::CO_2_Output = 60 , JYPCIe5112CoreOO::CO_3_Output = 66
}
AI Digital trigger source. More...
enum class | JYPCIe5112CoreOO::AIDigitalTriggerEdge { JYPCIe5112CoreOO::Rising = 0x0 , JYPCIe5112CoreOO::Falling = 0x1 }
AI Digital Trigger Edge. More...
enum class | JYPCIe5112CoreOO::AIAnalogTriggerEdge { JYPCIe5112CoreOO::Rising , JYPCIe5112CoreOO::Falling }
AI Analog Trigger Edge. More...
enum class | JYPCIe5112CoreOO::AIAnalogWindowCondition { JYPCIe5112CoreOO::Entering , JYPCIe5112CoreOO::Leaving }
AI Analog Window Trigger Condition. More...
enum class | JYPCIe5112CoreOO::AIAnalogTriggerComparator { JYPCIe5112CoreOO::Edge , JYPCIe5112CoreOO::Hysteresis , JYPCIe5112CoreOO::Window }
AI Analog Trigger Comparator. More...
enum class | JYPCIe5112CoreOO::AISignalExportSource { JYPCIe5112CoreOO::StartTrig = 0 , JYPCIe5112CoreOO::ReferenceTrig = 1 , JYPCIe5112CoreOO::SampleClock = 5 }
AI Signal Export Source. More...
enum class | JYPCIe5112CoreOO::FileFormat { JYPCIe5112CoreOO::Bin }
Streaming file format. More...
enum class | JYPCIe5112CoreOO::RecordMode { JYPCIe5112CoreOO::Finite , JYPCIe5112CoreOO::Infinite }
stream mode .enum Finite/Infinite More...
enum class | JYPCIe5112CoreOO::PowerLineFrequency { JYPCIe5112CoreOO::_50Hz , JYPCIe5112CoreOO::_60Hz }


5112 C++ Programming Manual: JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask Class Reference

  • Class List
  • Class Index
  • Class Members
  • JYPCIe5112CoreOO
  • JYPCIe5112CoreOOAITask
Public Member Functions | Public Attributes | List of all members
JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask Class Reference

AITask类 More...

#include <JYPCIe5112CoreOOAOTask.h>

Public Member Functions

JYPCIe5112CoreOOAITask (int slotNum)
JYPCIe5112CoreOOAITask (std::string boardName)
void | AddChannel (int chnId, double rangeLow=-10, double rangeHigh=10, AITerminal terminalCfg=AITerminal::RSE)
Add one channel.
void | AddChannel (std::vector< int > chnsId, double rangeLow=-10, double rangeHigh=10, AITerminal terminalCfg=AITerminal::RSE)
Add a group of channels.
void | AddChannel (std::vector< int > chnsId, std::vector< double > rangeLow, std::vector< double > rangeHigh, AITerminal terminalCfg=AITerminal::RSE)
Add a group of channels.
void | RemoveChannel (int chnId)
Delete the specified channel number.
void | ReadData (double *pBuf, int samplesPerChannel, int timeout=-1)
Read the multi-channel data by columns and store it in a data buffer.
void | ReadData (std::vector< double > &pBuf, int samplesPerChannel, int timeout=-1)
Read the multi-channel data by columns and store it in a data buffer.
void | ReadRawData (short *pBuf, int samplesPerChannel, int timeout=-1)
Read one or multi-channel raw data by columns and store it in a data buffer.
void | ReadRawData (std::vector< short > &pBuf, int samplesPerChannel, int timeout=-1)
Read one or multi-channel raw data by columns and store it in a data buffer.
void | ReadSinglePoint (double &readValue, int channel)
Read one sample for specified channel in register.
void | ReadSinglePoint (std::vector< double > &readValues)
Read one sample for all channels in register .
void | ReadRawSinglePoint (unsigned int &readValue, int channel)
Read raw one sample for specified channel in register.
void | ReadRawSinglePoint (std::vector< uint32_t > &readValues)
Read raw one sample for all channels in register .
void | GetRecordPreviewData (double *buf, int samplesPerChannel, int timeout)
Preview multi-channel data when streaming is in progress.
void | GetRecordPreviewData (std::vector< double > &buf, int samplesPerChannel, int timeout)
Preview multi-channel data when streaming is in progress.
void | GetRecordStatus (double &recordedLength, bool &recordDone)
get the streaming status.
void | Start ()
启动Task
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Stop ()
Stop AI task .

Public Attributes

std::list< AIChannel * > | Channels
List of AI channels,(5112 support 16 SE/8 Diff channel)
JYPCIe5112CoreOOProperty< JYPCIe5112CoreOOAITask, double, JYPCIe5112CoreOOPropertyType::READ_WRITE > | SampleRate
Sample rate per channel.
int | SamplesToAcquire
Number of samples to be read per channel.
JYPCIe5112CoreOOProperty< JYPCIe5112CoreOOAITask, int, JYPCIe5112CoreOOPropertyType::READ_ONLY > | BufLenInSamples
Number of samples per channel can be storage in the buffer, the Property SamplesToAcquire must be less than or equal to this value.
JYPCIe5112CoreOOProperty< JYPCIe5112CoreOOAITask, uint64_t, JYPCIe5112CoreOOPropertyType::READ_ONLY > | AvailableSamples
Number of samples per channel that can be read in the buffer .
JYPCIe5112CoreOOProperty< JYPCIe5112CoreOOAITask, uint64_t, JYPCIe5112CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
AIMode Mode
AI acquisition mode, support Single/Finite/Continuous/Record *.
AISampleClock * SampleClock
AI Sample Clock.
AITrigger * Trigger
AI Trigger Configuration.
AIAdvanced * Advanced
AI Trigger Configuration.
AIRecord * Record
ai Data streaming Configuration
AISignalExport * SignalExport
Export AI Signal Configuration.
JYPCIe5112CoreOODevice * Device
Device.

Detailed Description

AITask类

Constructor & Destructor Documentation

◆ JYPCIe5112CoreOOAITask() [1/2]

JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask::JYPCIe5112CoreOOAITask ( int slotNum )

◆ JYPCIe5112CoreOOAITask() [2/2]

JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask::JYPCIe5112CoreOOAITask ( std::string boardName )

Member Function Documentation

◆ AddChannel() [1/3]

void JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask::AddChannel | ( | int | chnId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10,
 |  | AITerminal | terminalCfg = AITerminal::RSE )

Add one channel.

Parameters
chnId | channel's physical number ，chnId=-1, add all channels。（5112 SE 0-15, Differential 0-7）
rangeLow | lower range limit for the channel，-10V,-5V,-2V，-1V,-0.5V，-0.2V，-0.1V defalut -10
rangeHigh | higher range limit for the channel，10V,5V,2V，1V,0.5V，0.2V，0.1V defalut 10
terminalCfg | terminal input mode configuration，RSE/NRSE/Differential.Default RSE

◆ AddChannel() [2/3]

void JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10,
 |  | AITerminal | terminalCfg = AITerminal::RSE )

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers （5112 SE 0-15, Differential 0-7）
rangeLow | lower range limit for the channel，-10V,-5V,-2V，-1V,-0.5V，-0.2V，-0.1V defalut -10
rangeHigh | higher range limit for the channel，10V,5V,2V，1V,0.5V，0.2V，0.1V defalut 10
terminalCfg | terminal input mode configuration，RSE/NRSE/Differential.Default RSE

◆ AddChannel() [3/3]

void JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | std::vector< double > | rangeLow,
 |  | std::vector< double > | rangeHigh,
 |  | AITerminal | terminalCfg = AITerminal::RSE )

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers （5112 SE 0-15, Differential 0-7）
rangeLow | lower range limit for the channel，-10V,-5V,-2V，-1V,-0.5V，-0.2V，-0.1V
rangeHigh | higher range limit for the channel，10V,5V,2V，1V,0.5V，0.2V，0.1V
terminalCfg | terminal input mode configuration，RSE/NRSE/Differential.Default RSE

◆ GetRecordPreviewData() [1/2]

void JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask::GetRecordPreviewData | ( | double * | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Preview multi-channel data when streaming is in progress.

Each column represents one channel.

Parameters
buf | Data buffer
samplesPerChannel | Number of preview samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ GetRecordPreviewData() [2/2]

void JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask::GetRecordPreviewData | ( | std::vector< double > & | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Preview multi-channel data when streaming is in progress.

Each column represents one channel.

Parameters
buf | Data buffer
samplesPerChannel | Number of preview samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ GetRecordStatus()

void JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask::GetRecordStatus | ( | double & | recordedLength,
 |  | bool & | recordDone )

get the streaming status.

Available when Mode is AIMode.Record

Parameters
recordedLength | Length of the streamed
recordDone | recordDone = false :streaming is not over.recordDone = true :streaming is over.

◆ ReadData() [1/2]

void JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask::ReadData | ( | double * | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = -1 )

Read the multi-channel data by columns and store it in a data buffer.

Each channel is represented by one column of data.

Parameters
pBuf | Data buffer
samplesPerChannel | Number of samples per channel to read
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadData() [2/2]

void JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask::ReadData | ( | std::vector< double > & | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = -1 )

Read the multi-channel data by columns and store it in a data buffer.

Each channel is represented by one column of data.

Parameters
pBuf | Data buffer
samplesPerChannel | Number of samples per channel to read
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadRawData() [1/2]

void JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask::ReadRawData | ( | short * | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = -1 )

Read one or multi-channel raw data by columns and store it in a data buffer.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel to read
timeout | timeout before generating error message, uint is ms。, timeout =-1 keep waiting until finish.

◆ ReadRawData() [2/2]

void JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask::ReadRawData | ( | std::vector< short > & | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = -1 )

Read one or multi-channel raw data by columns and store it in a data buffer.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel to read
timeout | timeout before generating error message, uint is ms。, timeout =-1 keep waiting until finish.

◆ ReadRawSinglePoint() [1/2]

void JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask::ReadRawSinglePoint ( std::vector< uint32_t > & readValues )

Read raw one sample for all channels in register .

Available when Mode is AIMode.Single

Parameters
readValues Values read. Array length >= Channels.Count.

◆ ReadRawSinglePoint() [2/2]

void JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask::ReadRawSinglePoint | ( | unsigned int & | readValue,
 |  | int | channel )

Read raw one sample for specified channel in register.

Available when Mode is AIMode.Single

Parameters
readValue | value read
channel | Specified channel numbers.

◆ ReadSinglePoint() [1/2]

void JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask::ReadSinglePoint | ( | double & | readValue,
 |  | int | channel )

Read one sample for specified channel in register.

Available when Mode is AIMode.Single

Parameters
readValue | value read
channel | Specified channel numbers.

◆ ReadSinglePoint() [2/2]

void JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask::ReadSinglePoint ( std::vector< double > & readValues )

Read one sample for all channels in register .

Available when Mode is AIMode.Single

Parameters
readValues Values read. Array length >= Channels.Count.

◆ RemoveChannel()

void JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask::RemoveChannel ( int chnId )

Delete the specified channel number.

If it is -1, delete all channels.

Parameters
chnId Specified channel ID.

◆ SendSoftwareTrigger()

void JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask::SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask::Start ( )

启动Task

Parameters

return void

Exceptions
JYDriverException 如果启动失败

◆ Stop()

void JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask::Stop ( )

Stop AI task .

Member Data Documentation

◆ Advanced

AIAdvanced* JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask::Advanced

AI Trigger Configuration.

◆ AvailableSamples

JYPCIe5112CoreOOProperty<JYPCIe5112CoreOOAITask, uint64_t, JYPCIe5112CoreOOPropertyType::READ_ONLY> JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask::AvailableSamples

Number of samples per channel that can be read in the buffer .

Valid when Mode is NOT AIMode.Single.

◆ BufLenInSamples

JYPCIe5112CoreOOProperty<JYPCIe5112CoreOOAITask, int, JYPCIe5112CoreOOPropertyType::READ_ONLY> JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask::BufLenInSamples

Number of samples per channel can be storage in the buffer, the Property SamplesToAcquire must be less than or equal to this value.

◆ Channels

std::list<AIChannel*> JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask::Channels

List of AI channels,(5112 support 16 SE/8 Diff channel)

◆ Device

JYPCIe5112CoreOODevice* JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask::Device

Device.

◆ Mode

AIMode JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask::Mode

AI acquisition mode, support Single/Finite/Continuous/Record *.

◆ Record

AIRecord* JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask::Record

ai Data streaming Configuration

◆ SampleClock

AISampleClock* JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask::SampleClock

AI Sample Clock.

◆ SampleRate

JYPCIe5112CoreOOProperty<JYPCIe5112CoreOOAITask, double, JYPCIe5112CoreOOPropertyType::READ_WRITE> JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask::SampleRate

Sample rate per channel.

5112 support Maximum sample rate is 250K for single channel, 250K for multichannel The default sample rate = 250K You can read this property to obtain the sample rate that will actually take effect in the current configuration.

Exceptions
JYDriverException

◆ SamplesToAcquire

int JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask::SamplesToAcquire

Number of samples to be read per channel.

Only valid when Mode is Finite*

◆ SignalExport

AISignalExport* JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask::SignalExport

Export AI Signal Configuration.

◆ TransferedSamples

JYPCIe5112CoreOOProperty<JYPCIe5112CoreOOAITask, uint64_t, JYPCIe5112CoreOOPropertyType::READ_ONLY> JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT AIMode.Single.

◆ Trigger

AITrigger* JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask::Trigger

AI Trigger Configuration.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOAITask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::AIChannel Class Reference

  • JYPCIe5112CoreOO
  • AIChannel
Public Member Functions | Public Attributes | List of all members
JYPCIe5112CoreOO::AIChannel Class Reference

AI Channel parameter class . More...

#include <JYPCIe5112CoreOOAITask.h>

Public Member Functions

AIChannel (int channelId, double rangeLow, double rangeHigh, AITerminal terminalCfg=AITerminal::NRSE)

Public Attributes

int | ChannelID
double | RangeLow
double | RangeHigh
AITerminal Terminal

Detailed Description

AI Channel parameter class .

Constructor & Destructor Documentation

◆ AIChannel()

JYPCIe5112CoreOO::AIChannel::AIChannel | ( | int | channelId,
 |  | double | rangeLow,
 |  | double | rangeHigh,
 |  | AITerminal | terminalCfg = AITerminal::NRSE )
 inline

Member Data Documentation

◆ ChannelID

int JYPCIe5112CoreOO::AIChannel::ChannelID

◆ RangeHigh

double JYPCIe5112CoreOO::AIChannel::RangeHigh

◆ RangeLow

double JYPCIe5112CoreOO::AIChannel::RangeLow

◆ Terminal

AITerminal JYPCIe5112CoreOO::AIChannel::Terminal
The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOAITask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::AIExternalSampleClock Class Reference

  • AIExternalSampleClock
Public Attributes | List of all members
JYPCIe5112CoreOO::AIExternalSampleClock Class Reference

Sample clock configuration class. More...

#include <JYPCIe5112CoreOOAITask.h>

Public Attributes

ClockTerminal Terminal
External Sample Clock Input Terminal.
double ExpectedRate
Expected External Sample Clock Rate.

Detailed Description

Sample clock configuration class.

Member Data Documentation

◆ ExpectedRate

double JYPCIe5112CoreOO::AIExternalSampleClock::ExpectedRate

Expected External Sample Clock Rate.

◆ Terminal

ClockTerminal JYPCIe5112CoreOO::AIExternalSampleClock::Terminal

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOAITask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::AISampleClock Class Reference

  • AISampleClock
Public Attributes | List of all members
JYPCIe5112CoreOO::AISampleClock Class Reference

Sample clock configuration class. More...

#include <JYPCIe5112CoreOOAITask.h>

Public Attributes

AISampleClockSource Source
AI Sample Clock Source.
AIExternalSampleClock * External
External Sample Clock Configuration.

Detailed Description

Sample clock configuration class.

Member Data Documentation

◆ External

AIExternalSampleClock* JYPCIe5112CoreOO::AISampleClock::External

External Sample Clock Configuration.

Valid when Source is AISampleClockSource.External.

◆ Source

AISampleClockSource JYPCIe5112CoreOO::AISampleClock::Source

AI Sample Clock Source.

enum Internal/External. The default value is AISampleClockSource.Internal.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOAITask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::AITrigger Class Reference

  • AITrigger
Public Attributes | List of all members
JYPCIe5112CoreOO::AITrigger Class Reference

Constructor to create an AITrigger task object. More...

#include <JYPCIe5112CoreOOAITask.h>

Public Attributes

AITriggerType Type
AI trigger type.
AITriggerMode Mode
AI trigger mode.
AIDigitalTrigger * Digital
Digital Trigger Congfiguration.
AIAnalogTrigger * Analog
AI Analog Trigger.
int | ReTriggerCount
Number of repeat triggers.
unsigned int | PreTriggerSamples
AI pretrigger samples, must be less than or equal to JYPCIe5112AITask.SamplesToAcquire.

Detailed Description

Constructor to create an AITrigger task object.

Used to build AI Trigger

Member Data Documentation

◆ Analog

AIAnalogTrigger* JYPCIe5112CoreOO::AITrigger::Analog

AI Analog Trigger.

Valid when Type is AITriggerType.Analog.

◆ Digital

AIDigitalTrigger* JYPCIe5112CoreOO::AITrigger::Digital

Digital Trigger Congfiguration.

Valid when Type is AITriggerType.Digital.

◆ Mode

AITriggerMode JYPCIe5112CoreOO::AITrigger::Mode

AI trigger mode.

enum Start/Reference. The default value is AITriggerMode.Start.

◆ PreTriggerSamples

unsigned int JYPCIe5112CoreOO::AITrigger::PreTriggerSamples

AI pretrigger samples, must be less than or equal to JYPCIe5112AITask.SamplesToAcquire.

Valid when Mode is AITriggerMode.Reference. Pretrigger samples, must be greater than 0. Valid when Type is AITriggerType.Analog. Pretrigger samples, must be greater than 1. Valid when Type is AITriggerType.Digital.

◆ ReTriggerCount

int JYPCIe5112CoreOO::AITrigger::ReTriggerCount

Number of repeat triggers.

When 0 or 1 only trigger once, When -1 continuous retrigger until stop.

◆ Type

AITriggerType JYPCIe5112CoreOO::AITrigger::Type

AI trigger type.

enum Analog/Digital/Immediate/Soft. The default value is AITriggerType.Immediate.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOAITask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::AIDigitalTrigger Class Reference

  • AIDigitalTrigger
Public Attributes | List of all members
JYPCIe5112CoreOO::AIDigitalTrigger Class Reference

AI Digital trigger class. More...

#include <JYPCIe5112CoreOOAITask.h>

Public Attributes

AIDigitalTriggerSource Source
AI Digital Trigger source.
AIDigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Detailed Description

AI Digital trigger class.

Member Data Documentation

◆ Edge

AIDigitalTriggerEdge JYPCIe5112CoreOO::AIDigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

AIDigitalTriggerSource JYPCIe5112CoreOO::AIDigitalTrigger::Source

AI Digital Trigger source.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOAITask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::AIAnalogHysteresisComparator Class Reference

  • AIAnalogHysteresisComparator
Public Attributes | List of all members
JYPCIe5112CoreOO::AIAnalogHysteresisComparator Class Reference

AI Analog Hysteresis Comparatorr. More...

#include <JYPCIe5112CoreOOAITask.h>

Public Attributes

AIAnalogTriggerEdge Slope
AI Analog Trigger Edge.
double | HighThreshold
High Threshold.
double | LowThreshold
Low Threshold.

Detailed Description

AI Analog Hysteresis Comparatorr.

Member Data Documentation

◆ HighThreshold

double JYPCIe5112CoreOO::AIAnalogHysteresisComparator::HighThreshold

High Threshold.

◆ LowThreshold

double JYPCIe5112CoreOO::AIAnalogHysteresisComparator::LowThreshold

Low Threshold.

◆ Slope

AIAnalogTriggerEdge JYPCIe5112CoreOO::AIAnalogHysteresisComparator::Slope

AI Analog Trigger Edge.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOAITask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::AIAnalogWindowComparator Class Reference

  • AIAnalogWindowComparator
Public Attributes | List of all members
JYPCIe5112CoreOO::AIAnalogWindowComparator Class Reference

AI Analog Window Comparatorr. More...

#include <JYPCIe5112CoreOOAITask.h>

Public Attributes

AIAnalogWindowCondition Condition
AI Analog Window Condition.
double | HighThreshold
High Threshold.
double | LowThreshold
Low Threshold.

Detailed Description

AI Analog Window Comparatorr.

Member Data Documentation

◆ Condition

AIAnalogWindowCondition JYPCIe5112CoreOO::AIAnalogWindowComparator::Condition

AI Analog Window Condition.

◆ HighThreshold

double JYPCIe5112CoreOO::AIAnalogWindowComparator::HighThreshold

High Threshold.

◆ LowThreshold

double JYPCIe5112CoreOO::AIAnalogWindowComparator::LowThreshold

Low Threshold.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOAITask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::AIAnalogEdgeComparator Class Reference

  • AIAnalogEdgeComparator
Public Attributes | List of all members
JYPCIe5112CoreOO::AIAnalogEdgeComparator Class Reference

AI Analog Edge Comparator. More...

#include <JYPCIe5112CoreOOAITask.h>

Public Attributes

AIAnalogTriggerEdge Slope
AI Analog Trigger Edge.
double Threshold
Threshold.

Detailed Description

AI Analog Edge Comparator.

Member Data Documentation

◆ Slope

AIAnalogTriggerEdge JYPCIe5112CoreOO::AIAnalogEdgeComparator::Slope

AI Analog Trigger Edge.

◆ Threshold

double JYPCIe5112CoreOO::AIAnalogEdgeComparator::Threshold

Threshold.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOAITask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::AIAnalogTrigger Class Reference

  • AIAnalogTrigger
Public Attributes | List of all members
JYPCIe5112CoreOO::AIAnalogTrigger Class Reference

AI analog trigger . More...

#include <JYPCIe5112CoreOOAITask.h>

Public Attributes

AIAnalogTriggerSource Source
Analog Trigger source.
AIAnalogTriggerComparator Comparator
AI Analog Trigger Comparator.
AIAnalogEdgeComparator * Edge
AI Analog Edge Comparator.
AIAnalogHysteresisComparator * Hysteresis
AI Analog Hysteresis Comparatorr.
AIAnalogWindowComparator * Window
AI Analog Window Comparatorr.

Detailed Description

AI analog trigger .

Member Data Documentation

◆ Comparator

AIAnalogTriggerComparator JYPCIe5112CoreOO::AIAnalogTrigger::Comparator

AI Analog Trigger Comparator.

◆ Edge

AIAnalogEdgeComparator* JYPCIe5112CoreOO::AIAnalogTrigger::Edge

AI Analog Edge Comparator.

◆ Hysteresis

AIAnalogHysteresisComparator* JYPCIe5112CoreOO::AIAnalogTrigger::Hysteresis

AI Analog Hysteresis Comparatorr.

◆ Source

AIAnalogTriggerSource JYPCIe5112CoreOO::AIAnalogTrigger::Source

Analog Trigger source.

◆ Window

AIAnalogWindowComparator* JYPCIe5112CoreOO::AIAnalogTrigger::Window

AI Analog Window Comparatorr.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOAITask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::AIRecord Class Reference

  • AIRecord
Public Attributes | List of all members
JYPCIe5112CoreOO::AIRecord Class Reference

AI Record Parameters. More...

#include <JYPCIe5112CoreOOAITask.h>

Public Attributes

std::string | FilePath
User specified file path.
JYPCIe5112CoreOO::FileFormat File_Format
Streaming file format.
RecordMode Mode
stream mode .
double | Length
User specified stream length in second.

Detailed Description

AI Record Parameters.

Member Data Documentation

◆ File_Format

JYPCIe5112CoreOO::FileFormat JYPCIe5112CoreOO::AIRecord::File_Format

Streaming file format.

enum BIN.

◆ FilePath

std::string JYPCIe5112CoreOO::AIRecord::FilePath

User specified file path.

◆ Length

double JYPCIe5112CoreOO::AIRecord::Length

User specified stream length in second.

Only when Mode is RecordMode.Finite.

◆ Mode

RecordMode JYPCIe5112CoreOO::AIRecord::Mode

stream mode .

enum Finite/Infinite.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOAITask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::AIDSMode Class Reference

  • AIDSMode
Public Attributes | List of all members
JYPCIe5112CoreOO::AIDSMode Class Reference

#include <JYPCIe5112CoreOOAITask.h>

Public Attributes

bool Enable
Enable DSMode.
JYPCIe5112CoreOO::PowerLineFrequency PowerLineFrequency
AC Power Frequency.

Member Data Documentation

◆ Enable

bool JYPCIe5112CoreOO::AIDSMode::Enable

Enable DSMode.

◆ PowerLineFrequency

JYPCIe5112CoreOO::PowerLineFrequency JYPCIe5112CoreOO::AIDSMode::PowerLineFrequency

AC Power Frequency.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOAITask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::AIAdvanced Class Reference

  • AIAdvanced
Public Attributes | List of all members
JYPCIe5112CoreOO::AIAdvanced Class Reference

AI Advance parameter. More...

#include <JYPCIe5112CoreOOAITask.h>

Public Attributes

double ConvertRate
the convert rate of ADC.
AIDSMode * DSMode
DSMode Config.

Detailed Description

AI Advance parameter.

Member Data Documentation

◆ ConvertRate

double JYPCIe5112CoreOO::AIAdvanced::ConvertRate

the convert rate of ADC.

◆ DSMode

AIDSMode* JYPCIe5112CoreOO::AIAdvanced::DSMode

DSMode Config.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOAITask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::AISignalExport Class Reference

  • AISignalExport
Public Member Functions | List of all members
JYPCIe5112CoreOO::AISignalExport Class Reference

AI Signal Export Class. More...

#include <JYPCIe5112CoreOOAITask.h>

Public Member Functions

void | Add (AISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (AISignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

AI Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JYPCIe5112CoreOO::AISignalExport::Add | ( | AISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | AI Signal Source
destination | Export Desination

◆ Add() [2/2]

void JYPCIe5112CoreOO::AISignalExport::Add | ( | AISignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | AI Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JYPCIe5112CoreOO::AISignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JYPCIe5112CoreOO::AISignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOAITask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Enumerations | Functions
JYPCIe5112CoreOO Namespace Reference

Classes

class | AIAdvanced
AI Advance parameter. More...
class | AIAnalogEdgeComparator
AI Analog Edge Comparator. More...
class | AIAnalogHysteresisComparator
AI Analog Hysteresis Comparatorr. More...
class | AIAnalogTrigger
AI analog trigger . More...
class | AIAnalogWindowComparator
AI Analog Window Comparatorr. More...
class | AIChannel
AI Channel parameter class . More...
class | AIDigitalTrigger
AI Digital trigger class. More...
class | AIDSMode
class | AIExternalSampleClock
Sample clock configuration class. More...
class | AIRecord
AI Record Parameters. More...
class | AISampleClock
Sample clock configuration class. More...
class | AISignalExport
AI Signal Export Class. More...
class | AITrigger
Constructor to create an AITrigger task object. More...
class | AOChannel
class | AODigitalTrigger
AO Digital trigger . More...
class | AOExternalSampleClock
External Sample Clock Configuration Class. More...
class | AOSampleClock
AO Sample clock configuration class. More...
class | AOSignalExport
AO Signal Export Class. More...
class | AOTrigger
Constructor to create an AOTrigger task object. More...
class | CIDigitalTrigger
CI Digital trigger . More...
class | CIExternalSampleClock
CI Implicit Sample Clock class. More...
class | CIExternalTimebase
class | CIImplicitSampleClock
CI Implicit Sample Clock class. More...
class | CIInternalSampleClock
CI Internal Sample Clock Configuration Class. More...
class | CISampleClock
CI Sample Clock class. More...
class | CISignalExport
CI Signal Export Class. More...
class | CITimebase
Timebase configuration class. More...
class | CITrigger
Constructor to create an CITrigger task object. More...
class | CODigitalTrigger
CO Digital trigger . More...
class | COPulse
Pulse Parameter. More...
class | COSignalExport
CO Signal Export Class. More...
class | COTimebase
Timebase configuration class. More...
class | COTrigger
Constructor to create an COTrigger task object. More...
class | DIChannel
DI Channel parameter class . More...
class | DOChannel
DO Channel parameter class . More...
class | EdgeCounting
Configure CI EdgeCounting. More...
class | EdgeCountingOutEvent
Edge counting output event configuration class. More...
class | ExternalReferenceClock
class | FrequencyMeas
Configure CI Measure. More...
class | JYDriverException
class | JYPCIe5112CoreOOAITask
AITask类 More...
class | JYPCIe5112CoreOOAOTask
class | JYPCIe5112CoreOOCITask
class | JYPCIe5112CoreOOCOTask
class | JYPCIe5112CoreOODevice
class | JYPCIe5112CoreOODITask
class | JYPCIe5112CoreOODOTask
class | JYPCIe5112CoreOOLog
class | JYPCIe5112CoreOOProperty
属性模板类 More...
class | JYPCIe5112CoreOOReferenceClock
class | PauseTrigger
Pause trigger configuration class. More...
class | PeriodMeas
Configure CI Measure. More...
class | PFIFilter
class | PFISetting
class | PulseMeas
Configure CI Measure. More...
class | QuadEncoder
Configure CI Measure. More...
class | SemiPeriodMeas
Configure CI SemiPeriodMeas. More...
class | TwoEdgeSeparation
Configure CI Measure. More...
class | TwoPulseEncoder
Configure CI Measure. More...

Enumerations

enum class | AITerminal { RSE = 0x0 , NRSE = 0x1 , Differential = 0x2 }
enum class | AIMode { Single = 0x2 , Finite = 0x0 , Continuous = 0x1 , Record = 0x3 }
enum class | AISampleClockSource { Internal , External }
AI Sample Clock Source. More...
enum class | AITriggerType { Immediate = 0x0 , Digital = 0x1 , Analog = 0x2 , Soft = 0x3 }
Trigger Type Digital/Analog/Immediate/Soft. More...
enum class | AITriggerMode { Start , Reference }
AI Trigger Mode. More...
enum class AIAnalogTriggerSource {
Channel_0 , Channel_1 , Channel_2 , Channel_3 ,
Channel_4 , Channel_5 , Channel_6 , Channel_7 ,
Channel_8 , Channel_9 , Channel_10 , Channel_11 ,
Channel_12 , Channel_13 , Channel_14 , Channel_15 ,
Channel_16 , Channel_17 , Channel_18 , Channel_19 ,
Channel_20 , Channel_21 , Channel_22 , Channel_23 ,
Channel_24 , Channel_25 , Channel_26 , Channel_27 ,
Channel_28 , Channel_29 , Channel_30 , Channel_31
}
AI analog trigger source. More...
enum class AIDigitalTriggerSource {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PFI8 , PFI9 , PFI10 , PFI11 ,
PFI12 , PFI13 , PFI14 , PFI15 ,
PXI_Trig0 = 40 , PXI_Trig1 = 41 , PXI_Trig2 = 42 , PXI_Trig3 = 43 ,
PXI_Trig4 = 44 , PXI_Trig5 = 45 , PXI_Trig6 = 46 , PXI_Trig7 = 47 ,
AO_StartTrig = 26 , DI_StartTrig = 22 , DI_ReferenceTrig = 23 , DO_StartTrig = 29 ,
CI_0_StartTrig = 68 , CI_1_StartTrig = 73 , CI_2_StartTrig = 76 , CI_3_StartTrig = 79 ,
CO_0_StartTrig = 69 , CO_1_StartTrig = 74 , CO_2_StartTrig = 77 , CO_3_StartTrig = 80 ,
CO_0_Output = 37 , CO_1_Output = 51 , CO_2_Output = 60 , CO_3_Output = 66
}
AI Digital trigger source. More...
enum class | AIDigitalTriggerEdge { Rising = 0x0 , Falling = 0x1 }
AI Digital Trigger Edge. More...
enum class | AIAnalogTriggerEdge { Rising , Falling }
AI Analog Trigger Edge. More...
enum class | AIAnalogWindowCondition { Entering , Leaving }
AI Analog Window Trigger Condition. More...
enum class | AIAnalogTriggerComparator { Edge , Hysteresis , Window }
AI Analog Trigger Comparator. More...
enum class | AISignalExportSource { StartTrig = 0 , ReferenceTrig = 1 , SampleClock = 5 }
AI Signal Export Source. More...
enum class | FileFormat { Bin }
Streaming file format. More...
enum class | RecordMode { Finite , Infinite }
stream mode .enum Finite/Infinite More...
enum class | PowerLineFrequency { _50Hz , _60Hz }
enum class | AOMode { Single = 3 , Finite = 0 , ContinuousNoWrapping = 2 , ContinuousWrapping = 1 }
enum class | AODigitalTriggerEdge { Rising , Falling }
AO Digital Trigger Edge. More...
enum class AODigitalTriggerSource {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PFI8 , PFI9 , PFI10 , PFI11 ,
PFI12 , PFI13 , PFI14 , PFI15 ,
PXI_Trig0 = 40 , PXI_Trig1 = 41 , PXI_Trig2 = 42 , PXI_Trig3 = 43 ,
PXI_Trig4 = 44 , PXI_Trig5 = 45 , PXI_Trig6 = 46 , PXI_Trig7 = 47 ,
AI_StartTrig = 16 , AI_ReferenceTrig = 17 , DI_StartTrig = 22 , DI_ReferenceTrig = 23 ,
DO_StartTrig = 29 , CI_0_StartTrig = 68 , CI_1_StartTrig = 73 , CI_2_StartTrig = 76 ,
CI_3_StartTrig = 79 , CO_0_StartTrig = 69 , CO_1_StartTrig = 74 , CO_2_StartTrig = 77 ,
CO_3_StartTrig = 80 , CO_0_Output = 37 , CO_1_Output = 51 , CO_2_Output = 60 ,
CO_3_Output = 66
}
AO Digital trigger source. More...
enum class | AOSampleClockSource { Internal , External }
AO Sample Clock Source. More...
enum class | AOSignalExportSource { StartTrig = 26 , SampleClock = 28 }
SourceSignal. More...
enum class | AOTriggerType { Immediate = 0x0 , Digital = 0x1 , Soft = 0x3 }
TriggerType Digital/Immediate/Soft. More...
enum class | CountDirection { Up = 0x0 , Down = 0x1 , External = 0x2 }
Counter direction. More...
enum class | ValueReturnMode { TwoValue , OneValue }
enum class CIType {
EdgeCounting , Period , Frequency , Pulse ,
SemiPeriod , TwoEdgeSeparation , QuadEncoder , TwoPulseEncoder
}
Counter Input Application Type. More...
enum class | CISampleClockSource { Implicit = 0x0 , Internal = 0x1 , External = 0x2 }
CI Sample Clock Source. More...
enum class | EdgeType { Rising , Falling }
Edge Type. More...
enum class | QuadEncodingType { X1 , X2 , X4 }
Quadrature Encoding Type. More...
enum class | CITriggerType { Immediate = 0x0 , Digital = 0x1 , Soft = 0x3 }
TriggerType Digital/Immediate/Soft. More...
enum class CIDigitalTriggerSource {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PFI8 , PFI9 , PFI10 , PFI11 ,
PFI12 , PFI13 , PFI14 , PFI15 ,
PXI_Trig0 = 40 , PXI_Trig1 = 41 , PXI_Trig2 = 42 , PXI_Trig3 = 43 ,
PXI_Trig4 = 44 , PXI_Trig5 = 45 , PXI_Trig6 = 46 , PXI_Trig7 = 47 ,
AI_StartTrig = 16 , AI_ReferenceTrig = 17 , AO_StartTrig = 26 , DI_StartTrig = 22 ,
DI_ReferenceTrig = 23 , DO_StartTrig = 29 , CI_0_StartTrig = 68 , CI_1_StartTrig = 73 ,
CI_2_StartTrig = 76 , CI_3_StartTrig = 79 , CO_0_StartTrig = 69 , CO_1_StartTrig = 74 ,
CO_2_StartTrig = 77 , CO_3_StartTrig = 80 , CO_0_Output = 37 , CO_1_Output = 51 ,
CO_2_Output = 60 , CO_3_Output = 66
}
CI Digital trigger source. More...
enum class | CIDigitalTriggerEdge { Rising , Falling }
CI Digital Trigger Edge. More...
enum class | EdgeCntOunEvtIdleState { LowLevel = 0 , HighLevel = 1 }
Output idle state when the event has not occurred. More...
enum class | CISignalExportSource { StartTrig , SampleClock }
SourceSignal. More...
enum class | CITimebaseSource { Internal100MHz = 0 , Internal5MHz = 1 , Internal100kHz = 2 , External = 3 }
Timebase source. More...
enum class | OutputState { HoldOn = 0 , HighLevel = 1 , LowLevel = 2 }
CO output state when pause trigger valid. More...
enum class | JYPCIe5112CoreOOPropertyType { READ_ONLY = 1 , WRITE_ONLY = 2 , READ_WRITE = 3 }
enum class JYDriverExceptionPublic {
UnKnown = 0 , OpenDeviceFailed = -10001 , CloseDeviceFailed = -10002 , ResetDeviceFailed = -10003 ,
GetDevicePropertyFailed = -10004 , SetDevicePropertyFailed = -10005 , HardwareResourceIsReserved = -10006 , MethodNotPermitedToCallWhenCurrentStatus = -10007 ,
InvalidUserDataBuffer = -10008 , NoChannelAdded = -10009 , NotSupportOperationForCurrentDevice = -10010 , CreatTaskFailed = -10100 ,
StartTaskFailed = -10101 , StopTaskFailed = -10102 , TaskHasNotStarted = -10103 , TaskHasStartedCannotPerformTheSetOperation = -10104 ,
ChannelNumberParameterInvalid = -10105 , ChannelInputRangeParameterInvalid = -10106 , ChannelTerminalParameterInvalid = -10107 , ChannelCouplingParameterInvalid = -10108 ,
SampeleModeParameterInvalid = -10109 , SampleClockParameterInvalid = -10110 , SampleRateParameterInvalid = -10111 , UpdateRateParameterInvalid = -10112 ,
TriggerParameterInvalid = -10113 , ReferenceTriggerDoesNotMatchWithSampleMode = -10114 , PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint = -10115 , ReadDataFailed = -10016 ,
ReadDataTimeout = -10017 , WriteDataFailed = -10018 , WriteDataTimeout = -10019 , WriteDataLengthCannotBeLessThanN = -10020 ,
BufferDataOverflow = -10021 , BufferDataDownflow = -10022 , CheckBufferFailed = -10023 , PointInvalidInFiniteMode = -10024 ,
ReadPointInvalid = -10025 , OnlySupportRecordMode = -10026 , SendSoftTirggerFailed = -10027 , TaskTimeout = -10028 ,
CounterParametersInvalid = -10029 , WritePointInvalid = -10030 , SignalExportDestinationInvalid = -10031 , InvalidParameter = -10033
}
enum class ClockTerminal {
PFI0 = 0 , PFI1 = 1 , PFI2 = 2 , PFI3 = 3 ,
PFI4 = 4 , PFI5 = 5 , PFI6 = 6 , PFI7 = 7 ,
PFI8 = 8 , PFI9 = 9 , PFI10 = 10 , PFI11 = 11 ,
PFI12 = 12 , PFI13 = 13 , PFI14 = 14 , PFI15 = 15 ,
PXI_Trig0 = 16 , PXI_Trig1 = 17 , PXI_Trig2 = 18 , PXI_Trig3 = 19 ,
PXI_Trig4 = 20 , PXI_Trig5 = 21 , PXI_Trig6 = 22 , PXI_Trig7 = 23 ,
AI_SampleClock = 24 , AO_SampleClock = 25 , CO0_Output = 26 , CO1_Output = 27 ,
ECLK = 28
}
enum class SignalExportDestination {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PFI8 , PFI9 , PFI10 , PFI11 ,
PFI12 , PFI13 , PFI14 , PFI15 ,
PXI_Trig0 , PXI_Trig1 , PXI_Trig2 , PXI_Trig3 ,
PXI_Trig4 , PXI_Trig5 , PXI_Trig6 , PXI_Trig7
}
enum class | OutputCompleteState { Zero , Hold }
Output Complete State. More...
enum class IOTerminal {
PFI0 = 0 , PFI1 = 1 , PFI2 = 2 , PFI3 = 3 ,
PFI4 = 44 , PFI5 = 5 , PFI6 = 6 , PFI7 = 7 ,
PFI8 = 8 , PFI9 = 9 , PFI10 = 10 , PFI11 = 11 ,
PFI12 = 12 , PFI13 = 13 , PFI14 = 14 , PFI15 = 15 ,
PXI_Trig0 = 16 , PXI_Trig1 = 17 , PXI_Trig2 = 18 , PXI_Trig3 = 19 ,
PXI_Trig4 = 20 , PXI_Trig5 =21 , PXI_Trig6 = 22 , PXI_Trig7 = 23 ,
None = 24
}
Cunter IO Terminal. More...
enum class | LevelPolarity { LowLevel = 0 , HighLevel = 1 , None = 2 }
Level Polarity. More...
enum class InputTerminal {
PFI0 = 0 , PFI1 = 1 , PFI2 = 2 , PFI3 = 3 ,
PFI4 = 4 , PFI5 = 5 , PFI6 = 6 , PFI7 = 7 ,
PFI8 = 8 , PFI9 = 9 , PFI10 = 10 , PFI11 = 11 ,
PFI12 = 12 , PFI13 = 13 , PFI14 = 14 , PFI15 = 15 ,
PXI_Trig0 = 16 , PXI_Trig1 = 17 , PXI_Trig2 = 18 , PXI_Trig3 = 19 ,
PXI_Trig4 = 20 , PXI_Trig5 = 21 , PXI_Trig6 = 22 , PXI_Trig7 = 23 ,
CO_0_OutPut = 24 , CO_1_OutPut = 25 , Timebase_100MHz = 26 , Timebase_5MHz = 27 ,
Timebase_100kHz = 28
}
Cunter Input Terminal. More...
enum class | COIdleState { HighLevel = 0x1 , LowLevel = 0x0 }
Idle state when pulse output before start and after stop. More...
enum class | COMode { Single = 3 }
enum class | COTriggerType { Immediate = 0x0 , Digital = 0x1 , Soft = 0x3 }
TriggerType Digital/Immediate/Soft. More...
enum class CODigitalTriggerSource {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PFI8 , PFI9 , PFI10 , PFI11 ,
PFI12 , PFI13 , PFI14 , PFI15 ,
PXI_Trig0 = 16 , PXI_Trig1 = 17 , PXI_Trig2 = 18 , PXI_Trig3 = 19 ,
PXI_Trig4 = 20 , PXI_Trig5 = 21 , PXI_Trig6 = 22 , PXI_Trig7 = 23 ,
AI_StartTrig = 24 , AI_ReferenceTrig = 25 , AO_StartTrig = 26 , CIO_0_StartTrig = 27 ,
CIO_1_StartTrig = 28 , CO0_Output = 29 , CO1_Output = 30
}
CO Digital trigger source. More...
enum class | CODigitalTriggerEdge { Rising , Falling }
CO Digital Trigger Edge. More...
enum class | COPulseType { DutyCycleFrequency , HighLowTime , HighLowTick }
Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick. More...
enum class | COTimebaseSource { Internal200MHz }
Timebase source. More...
enum class | COSignalExportSource { StartTrig , Output }
SourceSignal. More...
enum class | ExternalReferenceClockTerminal { PXIe_Clk100 = 0x1 }
enum class | ReferenceClockSource { Internal = 0x0 , External = 0x1 }
enum class PFITerminal {
PFI0 = 0 , PFI1 = 1 , PFI2 = 2 , PFI3 = 3 ,
PFI4 = 4 , PFI5 = 5 , PFI6 = 6 , PFI7 = 7 ,
PFI8 = 8 , PFI9 = 9 , PFI10 = 10 , PFI11 = 11 ,
PFI12 = 12 , PFI13 = 13 , PFI14 = 14 , PFI15 = 15
}
Input/Output Terminal of PFI. More...
enum class JYPCIe5112CoreOOLogLevel {
DEBUG_LOG_LEVEL , INFO_LOG_LEVEL , WARN_LOG_LEVEL , ERROR_LOG_LEVEL ,
FATAL_LOG_LEVEL
}

Functions

std::string GetSignalExportDestinationString (SignalExportDestination destination)

Enumeration Type Documentation

◆ AIAnalogTriggerComparator

enum class JYPCIe5112CoreOO::AIAnalogTriggerComparator
strong

AI Analog Trigger Comparator.

Enumerator
Edge | Edge Comparator.
Hysteresis | Hysteresis Comparator.
Window | Window Comparator.

◆ AIAnalogTriggerEdge

enum class JYPCIe5112CoreOO::AIAnalogTriggerEdge
strong

AI Analog Trigger Edge.

Enumerator
Rising | Rising.
Falling | Falling.

◆ AIAnalogTriggerSource

enum class JYPCIe5112CoreOO::AIAnalogTriggerSource
strong

AI analog trigger source.

Enumerator
Channel_0 | Channel_0 as the trigger source.
Channel_1 | Channel_1 as the trigger source.
Channel_2 | Channel_2 as the trigger source.
Channel_3 | Channel_3 as the trigger source.
Channel_4 | Channel_4 as the trigger source.
Channel_5 | Channel_5 as the trigger source.
Channel_6 | Channel_6 as the trigger source.
Channel_7 | Channel_7 as the trigger source.
Channel_8 | Channel_8 as the trigger source.
Channel_9 | Channel_9 as the trigger source.
Channel_10 | Channel_10 as the trigger source.
Channel_11 | Channel_11 as the trigger source.
Channel_12 | Channel_12 as the trigger source.
Channel_13 | Channel_13 as the trigger source.
Channel_14 | Channel_14 as the trigger source.
Channel_15 | Channel_15 as the trigger source.
Channel_16 | Channel_16 as the trigger source.
Channel_17 | Channel_17 as the trigger source.
Channel_18 | Channel_18 as the trigger source.
Channel_19 | Channe_l9 as the trigger source.
Channel_20 | Channel_20 as the trigger source.
Channel_21 | Channel_21 as the trigger source.
Channel_22 | Channel_22 as the trigger source.
Channel_23 | Channel_23 as the trigger source.
Channel_24 | Channel_24 as the trigger source.
Channel_25 | Channel_25 as the trigger source.
Channel_26 | Channel_26 as the trigger source.
Channel_27 | Channel_27 as the trigger source.
Channel_28 | Channel_28 as the trigger source.
Channel_29 | Channel_29 as the trigger source.
Channel_30 | Channel_30 as the trigger source.
Channel_31 | Channel_31 as the trigger source.

◆ AIAnalogWindowCondition

enum class JYPCIe5112CoreOO::AIAnalogWindowCondition
strong

AI Analog Window Trigger Condition.

Enumerator
Entering | Rising.
Leaving | Falling.

◆ AIDigitalTriggerEdge

enum class JYPCIe5112CoreOO::AIDigitalTriggerEdge
strong

AI Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ AIDigitalTriggerSource

enum class JYPCIe5112CoreOO::AIDigitalTriggerSource
strong

AI Digital trigger source.

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11.
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.
AO_StartTrig | AO_StartTrig.
DI_StartTrig | DI_StartTrig.
DI_ReferenceTrig | DI_ReferenceTrig.
DO_StartTrig | DO_StartTrig.
CI_0_StartTrig | CI0_StartTrig.
CI_1_StartTrig | CI1_StartTrig.
CI_2_StartTrig | CI2_StartTrig.
CI_3_StartTrig | CI3_StartTrig.
CO_0_StartTrig | CO0_StartTrig.
CO_1_StartTrig | CO0_StartTrig.
CO_2_StartTrig | CO0_StartTrig.
CO_3_StartTrig | CO0_StartTrig.
CO_0_Output | CO_0_Output.
CO_1_Output | CO_1_Output.
CO_2_Output | CO_2_Output.
CO_3_Output | CO_3_Output.

◆ AIMode

enum class JYPCIe5112CoreOO::AIMode
strong
Enumerator
Single
Finite
Continuous
Record

◆ AISampleClockSource

enum class JYPCIe5112CoreOO::AISampleClockSource
strong

AI Sample Clock Source.

Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ AISignalExportSource

enum class JYPCIe5112CoreOO::AISignalExportSource
strong

AI Signal Export Source.

Enumerator
StartTrig | AI_StartTrig.
ReferenceTrig | AI_ReferenceTrig.
SampleClock | AI_SampleClock.

◆ AITerminal

enum class JYPCIe5112CoreOO::AITerminal
strong
Enumerator
RSE
NRSE
Differential

◆ AITriggerMode

enum class JYPCIe5112CoreOO::AITriggerMode
strong

AI Trigger Mode.

Enumerator
Start | Start Trigger.
Reference | Reference Trigger，Valid when JYPCIe5112AITask.Mode is AIMode.Finite

◆ AITriggerType

enum class JYPCIe5112CoreOO::AITriggerType
strong

Trigger Type Digital/Analog/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Analog | Analog Trigger.
Soft | Soft Trigger.

◆ AODigitalTriggerEdge

enum class JYPCIe5112CoreOO::AODigitalTriggerEdge
strong

AO Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ AODigitalTriggerSource

enum class JYPCIe5112CoreOO::AODigitalTriggerSource
strong

AO Digital trigger source.

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11.
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
DI_StartTrig | DI_StartTrig.
DI_ReferenceTrig | DI_ReferenceTrig.
DO_StartTrig | DO_StartTrig.
CI_0_StartTrig | CI0_StartTrig.
CI_1_StartTrig | CI1_StartTrig.
CI_2_StartTrig | CI2_StartTrig.
CI_3_StartTrig | CI3_StartTrig.
CO_0_StartTrig | CO0_StartTrig.
CO_1_StartTrig | CO0_StartTrig.
CO_2_StartTrig | CO0_StartTrig.
CO_3_StartTrig | CO0_StartTrig.
CO_0_Output | CO_0_Output.
CO_1_Output | CO_1_Output.
CO_2_Output | CO_2_Output.
CO_3_Output | CO_3_Output.

◆ AOMode

enum class JYPCIe5112CoreOO::AOMode
strong
Enumerator
Single | Single.
Finite | Finite.
ContinuousNoWrapping | ContinuousNoWrapping.
ContinuousWrapping | ContinuousWrapping.

◆ AOSampleClockSource

enum class JYPCIe5112CoreOO::AOSampleClockSource
strong

AO Sample Clock Source.

Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ AOSignalExportSource

enum class JYPCIe5112CoreOO::AOSignalExportSource
strong

SourceSignal.

Enumerator
StartTrig | AO_StartTrig.
SampleClock | AO_SampleClock.

◆ AOTriggerType

enum class JYPCIe5112CoreOO::AOTriggerType
strong

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ CIDigitalTriggerEdge

enum class JYPCIe5112CoreOO::CIDigitalTriggerEdge
strong

CI Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ CIDigitalTriggerSource

enum class JYPCIe5112CoreOO::CIDigitalTriggerSource
strong

CI Digital trigger source.

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11.
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
AO_StartTrig | AO_StartTrig.
DI_StartTrig | DI_StartTrig.
DI_ReferenceTrig | DI_ReferenceTrig.
DO_StartTrig | DO_StartTrig.
CI_0_StartTrig | CI0_StartTrig.
CI_1_StartTrig | CI1_StartTrig.
CI_2_StartTrig | CI2_StartTrig.
CI_3_StartTrig | CI3_StartTrig.
CO_0_StartTrig | CO0_StartTrig.
CO_1_StartTrig | CO0_StartTrig.
CO_2_StartTrig | CO0_StartTrig.
CO_3_StartTrig | CO0_StartTrig.
CO_0_Output | CO_0_Output.
CO_1_Output | CO_1_Output.
CO_2_Output | CO_2_Output.
CO_3_Output | CO_3_Output.

◆ CISampleClockSource

enum class JYPCIe5112CoreOO::CISampleClockSource
strong

CI Sample Clock Source.

Enumerator
Implicit | Implicit.
Internal | Internal.
External | External.

◆ CISignalExportSource

enum class JYPCIe5112CoreOO::CISignalExportSource
strong

SourceSignal.

Enumerator
StartTrig | CI_StartTrig.
SampleClock | CI_SampleClock.

◆ CITimebaseSource

enum class JYPCIe5112CoreOO::CITimebaseSource
strong

Timebase source.

Enumerator
Internal100MHz | 内部100MHz时基 Internal 100MHz Timebase
Internal5MHz | 内部5MHz时基 Internal 5MHz Timebase
Internal100kHz | 内部100kHz时基 Internal 100kHz Timebase
External | 外部时基 External Timebase

◆ CITriggerType

enum class JYPCIe5112CoreOO::CITriggerType
strong

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ CIType

enum class JYPCIe5112CoreOO::CIType
strong

Counter Input Application Type.

Enumerator
EdgeCounting | Edge Counting.
Period | Period Measure.
Frequency | Frequenc Measure.
Pulse | Pulse Measure.
SemiPeriod | SemiPeriod Measure.
TwoEdgeSeparation | TwoEdgeSeparation Measure.
QuadEncoder | QuadEncoder.
TwoPulseEncoder | EncoderTwoPulse.

◆ ClockTerminal

enum class JYPCIe5112CoreOO::ClockTerminal
strong
Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11.
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PXI_Trig0 | PXITrigger_0.
PXI_Trig1 | PXITrigger_1.
PXI_Trig2 | PXITrigger_2.
PXI_Trig3 | PXITrigger_3.
PXI_Trig4 | PXITrigger_4.
PXI_Trig5 | PXITrigger_5.
PXI_Trig6 | PXITrigger_6.
PXI_Trig7 | PXITrigger_7.
AI_SampleClock | AI_SampleClock.
AO_SampleClock | AO_SampleClock.
CO0_Output | CO0_Output.
CO1_Output | CO1_Output.
ECLK | ECLK.

◆ CODigitalTriggerEdge

enum class JYPCIe5112CoreOO::CODigitalTriggerEdge
strong

CO Digital Trigger Edge.

Enumerator
Rising | Rising Edge.
Falling | Falling Edge.

◆ CODigitalTriggerSource

enum class JYPCIe5112CoreOO::CODigitalTriggerSource
strong

CO Digital trigger source.

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11.
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
AO_StartTrig | AO_StartTrig.
CIO_0_StartTrig | CI0_StartTrig.
CIO_1_StartTrig | CI1_StartTrig.
CO0_Output | CO0_Output.
CO1_Output | CO1_Output.

◆ COIdleState

enum class JYPCIe5112CoreOO::COIdleState
strong

Idle state when pulse output before start and after stop.

Enumerator
HighLevel | Idle state is high level.
LowLevel | Idle state is low level.

◆ COMode

enum class JYPCIe5112CoreOO::COMode
strong
Enumerator
Single

Single pulse output.

◆ COPulseType

enum class JYPCIe5112CoreOO::COPulseType
strong

Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick.

Enumerator
DutyCycleFrequency | Configure CO output pulse according to its DutyCycle and Freqency.
HighLowTime | Configure CO output pulse according to duration of its high/low voltage levels.
HighLowTick | Configure CO output pulse according to its high/low tick level.

◆ COSignalExportSource

enum class JYPCIe5112CoreOO::COSignalExportSource
strong

SourceSignal.

Enumerator
StartTrig | CI_StartTrig.
Output | CO_Output.

◆ COTimebaseSource

enum class JYPCIe5112CoreOO::COTimebaseSource
strong

Timebase source.

Enumerator
Internal200MHz

Internal 200MHz Timebase.

◆ COTriggerType

enum class JYPCIe5112CoreOO::COTriggerType
strong

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ CountDirection

enum class JYPCIe5112CoreOO::CountDirection
strong

Counter direction.

enum Up/Down/External

Enumerator
Up | Counter increases.
Down | Counter decreases.
External | External signal control counter direction. If External signal is highlevel counter increases, or lowlevel counter decreases.

◆ EdgeCntOunEvtIdleState

enum class JYPCIe5112CoreOO::EdgeCntOunEvtIdleState
strong

Output idle state when the event has not occurred.

Enumerator
LowLevel | Idle state is low level.
HighLevel | Idle state is high level.

◆ EdgeType

enum class JYPCIe5112CoreOO::EdgeType
strong

Edge Type.

Enumerator
Rising | Rising Edge.
Falling | Falling Edge.

◆ ExternalReferenceClockTerminal

enum class JYPCIe5112CoreOO::ExternalReferenceClockTerminal
strong
Enumerator
PXIe_Clk100

PXIe_Clk100.

◆ FileFormat

enum class JYPCIe5112CoreOO::FileFormat
strong

Streaming file format.

enum BIN.

Enumerator
Bin

BIN。

BIN.

◆ InputTerminal

enum class JYPCIe5112CoreOO::InputTerminal
strong

Cunter Input Terminal.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PFI8 | PFI_8.
PFI9 | PFI_9.
PFI10 | PFI_10.
PFI11 | PFI_11.
PFI12 | PFI_12.
PFI13 | PFI_13.
PFI14 | PFI_14.
PFI15 | PFI_15.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
CO_0_OutPut | CO_0_OutPut.
CO_1_OutPut | CO_1_OutPut.
Timebase_100MHz | Timebase_100MHz.
Timebase_5MHz | Timebase_5MHz.
Timebase_100kHz | Timebase_100kHz.

◆ IOTerminal

enum class JYPCIe5112CoreOO::IOTerminal
strong

Cunter IO Terminal.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PFI8 | PFI_8.
PFI9 | PFI_9.
PFI10 | PFI_10.
PFI11 | PFI_11.
PFI12 | PFI_12.
PFI13 | PFI_13.
PFI14 | PFI_14.
PFI15 | PFI_15.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
None | None.

◆ JYDriverExceptionPublic

enum class JYPCIe5112CoreOO::JYDriverExceptionPublic
strong
Enumerator
UnKnown | JYDriverExceptionPublic.
OpenDeviceFailed | JYDriverExceptionPublic.
CloseDeviceFailed | JYDriverExceptionPublic.
ResetDeviceFailed | JYDriverExceptionPublic.
GetDevicePropertyFailed | JYDriverExceptionPublic.
SetDevicePropertyFailed | JYDriverExceptionPublic.
HardwareResourceIsReserved | JYDriverExceptionPublic.
MethodNotPermitedToCallWhenCurrentStatus | JYDriverExceptionPublic.
InvalidUserDataBuffer | JYDriverExceptionPublic.
NoChannelAdded | JYDriverExceptionPublic.
NotSupportOperationForCurrentDevice | JYDriverExceptionPublic.
CreatTaskFailed | JYDriverExceptionPublic.
StartTaskFailed | JYDriverExceptionPublic.
StopTaskFailed | JYDriverExceptionPublic.
TaskHasNotStarted | JYDriverExceptionPublic.
TaskHasStartedCannotPerformTheSetOperation | JYDriverExceptionPublic.
ChannelNumberParameterInvalid | JYDriverExceptionPublic.
ChannelInputRangeParameterInvalid | JYDriverExceptionPublic.
ChannelTerminalParameterInvalid | JYDriverExceptionPublic.
ChannelCouplingParameterInvalid | JYDriverExceptionPublic.
SampeleModeParameterInvalid | JYDriverExceptionPublic.
SampleClockParameterInvalid | JYDriverExceptionPublic.
SampleRateParameterInvalid | JYDriverExceptionPublic.
UpdateRateParameterInvalid | JYDriverExceptionPublic.
TriggerParameterInvalid | JYDriverExceptionPublic.
ReferenceTriggerDoesNotMatchWithSampleMode | JYDriverExceptionPublic.
PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint | JYDriverExceptionPublic.
ReadDataFailed | JYDriverExceptionPublic.
ReadDataTimeout | JYDriverExceptionPublic.
WriteDataFailed | JYDriverExceptionPublic.
WriteDataTimeout | JYDriverExceptionPublic.
WriteDataLengthCannotBeLessThanN | JYDriverExceptionPublic.
BufferDataOverflow | JYDriverExceptionPublic.
BufferDataDownflow | JYDriverExceptionPublic.
CheckBufferFailed | JYDriverExceptionPublic.
PointInvalidInFiniteMode | JYDriverExceptionPublic.
ReadPointInvalid | JYDriverExceptionPublic.
OnlySupportRecordMode | JYDriverExceptionPublic.
SendSoftTirggerFailed | JYDriverExceptionPublic.
TaskTimeout | JYDriverExceptionPublic.
CounterParametersInvalid | JYDriverExceptionPublic.
WritePointInvalid | JYDriverExceptionPublic.
SignalExportDestinationInvalid | JYDriverExceptionPublic.
InvalidParameter | 无效参数。 Invalid parameter.

◆ JYPCIe5112CoreOOLogLevel

enum class JYPCIe5112CoreOO::JYPCIe5112CoreOOLogLevel
strong
Enumerator
DEBUG_LOG_LEVEL
INFO_LOG_LEVEL
WARN_LOG_LEVEL
ERROR_LOG_LEVEL
FATAL_LOG_LEVEL

◆ JYPCIe5112CoreOOPropertyType

enum class JYPCIe5112CoreOO::JYPCIe5112CoreOOPropertyType
strong
Enumerator
READ_ONLY
WRITE_ONLY
READ_WRITE

◆ LevelPolarity

enum class JYPCIe5112CoreOO::LevelPolarity
strong

Level Polarity.

Enumerator
LowLevel | Low level.
HighLevel | High level.
None | No active polarity.

◆ OutputCompleteState

enum class JYPCIe5112CoreOO::OutputCompleteState
strong

Output Complete State.

Enumerator
Zero | Output Complete Zero.
Hold | Output Complete Hold in The last point.

◆ OutputState

enum class JYPCIe5112CoreOO::OutputState
strong

CO output state when pause trigger valid.

Enumerator
HoldOn | output hold on
HighLevel | output HighLevel
LowLevel | output LowLevel

◆ PFITerminal

enum class JYPCIe5112CoreOO::PFITerminal
strong

Input/Output Terminal of PFI.

Enumerator
PFI0 | PFI 0.
PFI1 | PFI 1.
PFI2 | PFI 2.
PFI3 | PFI 3.
PFI4 | PFI 4.
PFI5 | PFI 5.
PFI6 | PFI 6.
PFI7 | PFI 7.
PFI8 | PFI 8.
PFI9 | PFI 9.
PFI10 | PFI 10.
PFI11 | PFI 11.
PFI12 | PFI 12.
PFI13 | PFI 13.
PFI14 | PFI 14.
PFI15 | PFI 15.

◆ PowerLineFrequency

enum class JYPCIe5112CoreOO::PowerLineFrequency
strong
Enumerator
_50Hz | 50 Hz AC Power Frequency
_60Hz | 60 Hz AC Power Frequency

◆ QuadEncodingType

enum class JYPCIe5112CoreOO::QuadEncodingType
strong

Quadrature Encoding Type.

Enumerator
X1 | X1.
X2 | X2.
X4 | X4.

◆ RecordMode

enum class JYPCIe5112CoreOO::RecordMode
strong

stream mode .enum Finite/Infinite

Enumerator
Finite | Finite Streaming.
Infinite | Infinite Streaming.

◆ ReferenceClockSource

enum class JYPCIe5112CoreOO::ReferenceClockSource
strong
Enumerator
Internal | Internal on board 25MHz Clock.
External | External Reference Clock Source.

◆ SignalExportDestination

enum class JYPCIe5112CoreOO::SignalExportDestination
strong
Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11.
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.

◆ ValueReturnMode

enum class JYPCIe5112CoreOO::ValueReturnMode
strong
Enumerator
TwoValue | Return two data simultaneously. first data is gate to aux edge separation, second data is aux to gate edge separation.
OneValue | only return gate to aux edge separation

Function Documentation

◆ GetSignalExportDestinationString()

std::string JYPCIe5112CoreOO::GetSignalExportDestinationString ( SignalExportDestination destination )
inline


5112 C++ Programming Manual: COO/5112/JYPCIe5112CoreOOAOTask.h File Reference

  • File List
  • File Members
  • COO
  • 5112
Classes | Namespaces | Enumerations
JYPCIe5112CoreOOAOTask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JYPCIe5112CoreOOCommon.h"
#include "JYPCIe5112CoreOODevice.h"

Classes

class | JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask
class | JYPCIe5112CoreOO::AOChannel
class | JYPCIe5112CoreOO::AOExternalSampleClock
External Sample Clock Configuration Class. More...
class | JYPCIe5112CoreOO::AOSampleClock
AO Sample clock configuration class. More...
class | JYPCIe5112CoreOO::AOTrigger
Constructor to create an AOTrigger task object. More...
class | JYPCIe5112CoreOO::AODigitalTrigger
AO Digital trigger . More...
class | JYPCIe5112CoreOO::AOSignalExport
AO Signal Export Class. More...

Namespaces

namespace JYPCIe5112CoreOO

Enumerations

enum class | JYPCIe5112CoreOO::AOMode { JYPCIe5112CoreOO::Single = 3 , JYPCIe5112CoreOO::Finite = 0 , JYPCIe5112CoreOO::ContinuousNoWrapping = 2 , JYPCIe5112CoreOO::ContinuousWrapping = 1 }
enum class | JYPCIe5112CoreOO::AODigitalTriggerEdge { JYPCIe5112CoreOO::Rising , JYPCIe5112CoreOO::Falling }
AO Digital Trigger Edge. More...
enum class JYPCIe5112CoreOO::AODigitalTriggerSource {
JYPCIe5112CoreOO::PFI0 , JYPCIe5112CoreOO::PFI1 , JYPCIe5112CoreOO::PFI2 , JYPCIe5112CoreOO::PFI3 ,
JYPCIe5112CoreOO::PFI4 , JYPCIe5112CoreOO::PFI5 , JYPCIe5112CoreOO::PFI6 , JYPCIe5112CoreOO::PFI7 ,
JYPCIe5112CoreOO::PFI8 , JYPCIe5112CoreOO::PFI9 , JYPCIe5112CoreOO::PFI10 , JYPCIe5112CoreOO::PFI11 ,
JYPCIe5112CoreOO::PFI12 , JYPCIe5112CoreOO::PFI13 , JYPCIe5112CoreOO::PFI14 , JYPCIe5112CoreOO::PFI15 ,
JYPCIe5112CoreOO::PXI_Trig0 = 40 , JYPCIe5112CoreOO::PXI_Trig1 = 41 , JYPCIe5112CoreOO::PXI_Trig2 = 42 , JYPCIe5112CoreOO::PXI_Trig3 = 43 ,
JYPCIe5112CoreOO::PXI_Trig4 = 44 , JYPCIe5112CoreOO::PXI_Trig5 = 45 , JYPCIe5112CoreOO::PXI_Trig6 = 46 , JYPCIe5112CoreOO::PXI_Trig7 = 47 ,
JYPCIe5112CoreOO::AI_StartTrig = 16 , JYPCIe5112CoreOO::AI_ReferenceTrig = 17 , JYPCIe5112CoreOO::DI_StartTrig = 22 , JYPCIe5112CoreOO::DI_ReferenceTrig = 23 ,
JYPCIe5112CoreOO::DO_StartTrig = 29 , JYPCIe5112CoreOO::CI_0_StartTrig = 68 , JYPCIe5112CoreOO::CI_1_StartTrig = 73 , JYPCIe5112CoreOO::CI_2_StartTrig = 76 ,
JYPCIe5112CoreOO::CI_3_StartTrig = 79 , JYPCIe5112CoreOO::CO_0_StartTrig = 69 , JYPCIe5112CoreOO::CO_1_StartTrig = 74 , JYPCIe5112CoreOO::CO_2_StartTrig = 77 ,
JYPCIe5112CoreOO::CO_3_StartTrig = 80 , JYPCIe5112CoreOO::CO_0_Output = 37 , JYPCIe5112CoreOO::CO_1_Output = 51 , JYPCIe5112CoreOO::CO_2_Output = 60 ,
JYPCIe5112CoreOO::CO_3_Output = 66
}
AO Digital trigger source. More...
enum class | JYPCIe5112CoreOO::AOSampleClockSource { JYPCIe5112CoreOO::Internal , JYPCIe5112CoreOO::External }
AO Sample Clock Source. More...
enum class | JYPCIe5112CoreOO::AOSignalExportSource { JYPCIe5112CoreOO::StartTrig = 26 , JYPCIe5112CoreOO::SampleClock = 28 }
SourceSignal. More...
enum class | JYPCIe5112CoreOO::AOTriggerType { JYPCIe5112CoreOO::Immediate = 0x0 , JYPCIe5112CoreOO::Digital = 0x1 , JYPCIe5112CoreOO::Soft = 0x3 }
TriggerType Digital/Immediate/Soft. More...


5112 C++ Programming Manual: JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask Class Reference

  • JYPCIe5112CoreOOAOTask
Public Member Functions | Public Attributes | List of all members
JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask Class Reference

#include <JYPCIe5112CoreOOAOTask.h>

Public Member Functions

JYPCIe5112CoreOOAOTask (int slotNum)
JYPCIe5112CoreOOAOTask (std::string boardName)
void | AddChannel (int chnId, double rangeLow=-10, double rangeHigh=10)
Add one channel.
void | AddChannel (std::vector< int > chnsId, double rangeLow=-10, double rangeHigh=10)
Add a group of channels.
void | AddChannel (std::vector< int > chnsId, std::vector< double > rangeLow, std::vector< double > rangeHigh)
Add a group of channels.
void | RemoveChannel (int chnId)
Delete the specified channel number.
void | WriteData (double *pBuf, int samplesPerChannel, int timeout=10000)
Write to AO buffer one or multi-channel data.
void | WriteData (std::vector< double > &pBuf, int samplesPerChannel, int timeout=10000)
Write to AO buffer one or multi-channel data.
void | WriteRawData (int16_t *pBuf, int samplesPerChannel, int timeout=10000)
Write to AO buffer one or multi-channel raw data.
void | WriteRawData (std::vector< int16_t > &pBuf, int samplesPerChannel, int timeout=10000)
Write to AO buffer one or multi-channel raw data.
void | WriteSinglePoint (std::vector< double > writeValues)
write one sample to all channels in register .
void | WriteSinglePoint (double writeValue, int channel)
Write one sample to the specified channel in register.Available when Mode is AOMode.Single
void | WriteRawSinglePoint (std::vector< short > &writeValues)
write one raw sample to all channels in register .
void | WriteRawSinglePoint (short writeValue, int channel)
Write one raw sample to the specified channel in register.Available when Mode is AOMode.Single
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.
void | Start ()
Start AO task .
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Stop ()
Stop AO task .

Public Attributes

std::list< AOChannel * > | Channels
List of AI channels,(5112 support 4 channels)
AOMode Mode
Mode of AO Task.
JYPCIe5112CoreOOProperty< JYPCIe5112CoreOOAOTask, double, JYPCIe5112CoreOOPropertyType::READ_WRITE > | UpdateRate
Update rate per channel.
int | SamplesToUpdate
Number of output samples to write per channel , Only valid when Mode is AOMode.Finite.
JYPCIe5112CoreOOProperty< JYPCIe5112CoreOOAOTask, int, JYPCIe5112CoreOOPropertyType::READ_ONLY > | BufLenInSamples
Number of samples per channel can be storage in the buffer, the PropretySamplesToUpdate must be less than or equal to this value.
JYPCIe5112CoreOOProperty< JYPCIe5112CoreOOAOTask, uint32_t, JYPCIe5112CoreOOPropertyType::READ_ONLY > | AvaliableLenInSamples
Number of output samples per channel that can be write in AO buffuer.
OutputCompleteState CompleteState
AO Output Complete State, Valid when Mode is NOT OMode.Single.
JYPCIe5112CoreOOProperty< JYPCIe5112CoreOOAOTask, uint64_t, JYPCIe5112CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
AOSampleClock * SampleClock
AO Sample Clock Configuration.
AOTrigger * Trigger
AO Trigger Configuration.
bool | DisableCalibration
AOSignalExport * SignalExport
Export AO Signal.
JYPCIe5112CoreOODevice * Device

Constructor & Destructor Documentation

◆ JYPCIe5112CoreOOAOTask() [1/2]

JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask::JYPCIe5112CoreOOAOTask ( int slotNum )

◆ JYPCIe5112CoreOOAOTask() [2/2]

JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask::JYPCIe5112CoreOOAOTask ( std::string boardName )

Member Function Documentation

◆ AddChannel() [1/3]

void JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask::AddChannel | ( | int | chnId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10 )

Add one channel.

Parameters
chnId | channel's physical number ，chnId=-1, add all channels。（5112 support 0-3 channels）
rangeLow | lower range limit for the channel，-10V,-5V defalut -10
rangeHigh | higher range limit for the channel，10V,5V defalut 10

◆ AddChannel() [2/3]

void JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask::AddChannel | ( | std::vector< int > | chnsId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10 )

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers。（5112 support 0-3 channels）
rangeLow | lower range limit for the channel，-10V,-5V defalut -10
rangeHigh | higher range limit for the channel，10V,5V defalut 10

◆ AddChannel() [3/3]

void JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask::AddChannel | ( | std::vector< int > | chnsId,
 |  | std::vector< double > | rangeLow,
 |  | std::vector< double > | rangeHigh )

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers。（5112 support 0-3 channels）
rangeLow | lower range limit for the channel，-10V,-5V
rangeHigh | higher range limit for the channel，10V,5V

◆ RemoveChannel()

void JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask::RemoveChannel ( int chnId )

Delete the specified channel number.

If it is -1, delete all channels.

Parameters
chnId Specified channel ID.

◆ SendSoftwareTrigger()

void JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask::SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask::Start ( )

Start AO task .

◆ Stop()

void JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask::Stop ( )

Stop AO task .

◆ WaitUntilDone()

bool JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask::WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Available when Mode is AOMode.Finite

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteData() [1/2]

void JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask::WriteData | ( | double * | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Write to AO buffer one or multi-channel data.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | data buffer.
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [2/2]

void JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask::WriteData | ( | std::vector< double > & | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Write to AO buffer one or multi-channel data.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | data buffer.
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawData() [1/2]

void JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask::WriteRawData | ( | int16_t * | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Write to AO buffer one or multi-channel raw data.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | data buffer.
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawData() [2/2]

void JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask::WriteRawData | ( | std::vector< int16_t > & | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Write to AO buffer one or multi-channel raw data.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | data buffer.
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawSinglePoint() [1/2]

void JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask::WriteRawSinglePoint | ( | short | writeValue,
 |  | int | channel )

Write one raw sample to the specified channel in register.Available when Mode is AOMode.Single

Parameters
writeValue | Write value.
channel | Specified channel.

◆ WriteRawSinglePoint() [2/2]

void JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask::WriteRawSinglePoint ( std::vector< short > & writeValues )

write one raw sample to all channels in register .

Available when Mode is AOMode.Single

Parameters
writeValues Write values. Array length >= Channels.Count.

◆ WriteSinglePoint() [1/2]

void JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask::WriteSinglePoint | ( | double | writeValue,
 |  | int | channel )

Write one sample to the specified channel in register.Available when Mode is AOMode.Single

Parameters
writeValue | Write value.
channel | Specified channel.

◆ WriteSinglePoint() [2/2]

void JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask::WriteSinglePoint ( std::vector< double > writeValues )

write one sample to all channels in register .

Available when Mode is AOMode.Single

Parameters
writeValues Write values. Array length >= Channels.Count.

Member Data Documentation

◆ AvaliableLenInSamples

JYPCIe5112CoreOOProperty<JYPCIe5112CoreOOAOTask, uint32_t, JYPCIe5112CoreOOPropertyType::READ_ONLY> JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask::AvaliableLenInSamples

Number of output samples per channel that can be write in AO buffuer.

◆ BufLenInSamples

JYPCIe5112CoreOOProperty<JYPCIe5112CoreOOAOTask, int, JYPCIe5112CoreOOPropertyType::READ_ONLY> JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask::BufLenInSamples

Number of samples per channel can be storage in the buffer, the PropretySamplesToUpdate must be less than or equal to this value.

◆ Channels

std::list<AOChannel*> JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask::Channels

List of AI channels,(5112 support 4 channels)

◆ CompleteState

OutputCompleteState JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask::CompleteState

AO Output Complete State, Valid when Mode is NOT OMode.Single.

Default is Zero.

◆ Device

JYPCIe5112CoreOODevice* JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask::Device

◆ DisableCalibration

bool JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask::DisableCalibration

◆ Mode

AOMode JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask::Mode

Mode of AO Task.

Select AO Mode from enum:ContinuousNoWrapping/ContinuousWrapping/Finite/Single.

◆ SampleClock

AOSampleClock* JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask::SampleClock

AO Sample Clock Configuration.

◆ SamplesToUpdate

int JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask::SamplesToUpdate

Number of output samples to write per channel , Only valid when Mode is AOMode.Finite.

◆ SignalExport

AOSignalExport* JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask::SignalExport

Export AO Signal.

◆ TransferedSamples

JYPCIe5112CoreOOProperty<JYPCIe5112CoreOOAOTask, uint64_t, JYPCIe5112CoreOOPropertyType::READ_ONLY> JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT AOMode.Single.

◆ Trigger

AOTrigger* JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask::Trigger

AO Trigger Configuration.

◆ UpdateRate

JYPCIe5112CoreOOProperty<JYPCIe5112CoreOOAOTask, double, JYPCIe5112CoreOOPropertyType::READ_WRITE> JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask::UpdateRate

Update rate per channel.

Maximum update rate is 2.86M for single channel, 2M for two channels, 1.5M for three channels, 1.25M for four channels. The defalut sample rate = 1000000 You can read this property to obtain the update rate that will actually take effect in the current configuration.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOAOTask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::AOChannel Class Reference

  • AOChannel
Public Member Functions | Public Attributes | List of all members
JYPCIe5112CoreOO::AOChannel Class Reference

#include <JYPCIe5112CoreOOAOTask.h>

Public Member Functions

AOChannel (int channelId, double rangeLow, double rangeHigh)

Public Attributes

int | ChannelID
double | RangeLow
double | RangeHigh

Constructor & Destructor Documentation

◆ AOChannel()

JYPCIe5112CoreOO::AOChannel::AOChannel | ( | int | channelId,
 |  | double | rangeLow,
 |  | double | rangeHigh )
 inline

Member Data Documentation

◆ ChannelID

int JYPCIe5112CoreOO::AOChannel::ChannelID

◆ RangeHigh

double JYPCIe5112CoreOO::AOChannel::RangeHigh

◆ RangeLow

double JYPCIe5112CoreOO::AOChannel::RangeLow
The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOAOTask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::AOExternalSampleClock Class Reference

  • AOExternalSampleClock
Public Attributes | List of all members
JYPCIe5112CoreOO::AOExternalSampleClock Class Reference

External Sample Clock Configuration Class. More...

#include <JYPCIe5112CoreOOAOTask.h>

Public Attributes

ClockTerminal Terminal
External Sample Clock Input Terminal.
double ExpectedRate
Expected External Sample Clock Rate.

Detailed Description

External Sample Clock Configuration Class.

Member Data Documentation

◆ ExpectedRate

double JYPCIe5112CoreOO::AOExternalSampleClock::ExpectedRate

Expected External Sample Clock Rate.

◆ Terminal

ClockTerminal JYPCIe5112CoreOO::AOExternalSampleClock::Terminal

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOAOTask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::AOSampleClock Class Reference

  • AOSampleClock
Public Attributes | List of all members
JYPCIe5112CoreOO::AOSampleClock Class Reference

AO Sample clock configuration class. More...

#include <JYPCIe5112CoreOOAOTask.h>

Public Attributes

AOSampleClockSource Source
Clock Source.
AOExternalSampleClock * External
External Sample Clock Configuration,Valid when Source is AOSampleClockSource::External.

Detailed Description

AO Sample clock configuration class.

Member Data Documentation

◆ External

AOExternalSampleClock* JYPCIe5112CoreOO::AOSampleClock::External

External Sample Clock Configuration,Valid when Source is AOSampleClockSource::External.

◆ Source

AOSampleClockSource JYPCIe5112CoreOO::AOSampleClock::Source

Clock Source.

enum Internal/External,The default value is AOSampleClockSource.Internal.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOAOTask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::AOTrigger Class Reference

  • AOTrigger
Public Attributes | List of all members
JYPCIe5112CoreOO::AOTrigger Class Reference

Constructor to create an AOTrigger task object. More...

#include <JYPCIe5112CoreOOAOTask.h>

Public Attributes

AOTriggerType Type
AO trigger type.
AODigitalTrigger * Digital
AO Digital Trigger.

Detailed Description

Constructor to create an AOTrigger task object.

Used to build AO Trigger

Member Data Documentation

◆ Digital

AODigitalTrigger* JYPCIe5112CoreOO::AOTrigger::Digital

AO Digital Trigger.

Valid when Type is AOTriggerType.Digital.

◆ Type

AOTriggerType JYPCIe5112CoreOO::AOTrigger::Type

AO trigger type.

enum Immediate/Digital/Soft.The default value is AOTriggerType.Immediate.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOAOTask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::AODigitalTrigger Class Reference

  • AODigitalTrigger
Public Attributes | List of all members
JYPCIe5112CoreOO::AODigitalTrigger Class Reference

AO Digital trigger . More...

#include <JYPCIe5112CoreOOAOTask.h>

Public Attributes

AODigitalTriggerSource Source
AO Digital Trigger source.
AODigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Detailed Description

AO Digital trigger .

Member Data Documentation

◆ Edge

AODigitalTriggerEdge JYPCIe5112CoreOO::AODigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

AODigitalTriggerSource JYPCIe5112CoreOO::AODigitalTrigger::Source

AO Digital Trigger source.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOAOTask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::AOSignalExport Class Reference

  • AOSignalExport
Public Member Functions | List of all members
JYPCIe5112CoreOO::AOSignalExport Class Reference

AO Signal Export Class. More...

#include <JYPCIe5112CoreOOAOTask.h>

Public Member Functions

void | Add (AOSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (AOSignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

AO Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JYPCIe5112CoreOO::AOSignalExport::Add | ( | AOSignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | AO Signal Source
destination | Export Desination

◆ Add() [2/2]

void JYPCIe5112CoreOO::AOSignalExport::Add | ( | AOSignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | AO Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JYPCIe5112CoreOO::AOSignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JYPCIe5112CoreOO::AOSignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOAOTask.h


5112 C++ Programming Manual: COO/5112/JYPCIe5112CoreOOCITask.h File Reference

  • File List
  • File Members
  • COO
  • 5112
Classes | Namespaces | Enumerations
JYPCIe5112CoreOOCITask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JYPCIe5112CoreOOCommon.h"
#include "JYPCIe5112CoreOODevice.h"

Classes

class | JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
class | JYPCIe5112CoreOO::CIInternalSampleClock
CI Internal Sample Clock Configuration Class. More...
class | JYPCIe5112CoreOO::CIImplicitSampleClock
CI Implicit Sample Clock class. More...
class | JYPCIe5112CoreOO::CIExternalSampleClock
CI Implicit Sample Clock class. More...
class | JYPCIe5112CoreOO::CISampleClock
CI Sample Clock class. More...
class | JYPCIe5112CoreOO::EdgeCounting
Configure CI EdgeCounting. More...
class | JYPCIe5112CoreOO::FrequencyMeas
Configure CI Measure. More...
class | JYPCIe5112CoreOO::PeriodMeas
Configure CI Measure. More...
class | JYPCIe5112CoreOO::PulseMeas
Configure CI Measure. More...
class | JYPCIe5112CoreOO::SemiPeriodMeas
Configure CI SemiPeriodMeas. More...
class | JYPCIe5112CoreOO::TwoEdgeSeparation
Configure CI Measure. More...
class | JYPCIe5112CoreOO::QuadEncoder
Configure CI Measure. More...
class | JYPCIe5112CoreOO::TwoPulseEncoder
Configure CI Measure. More...
class | JYPCIe5112CoreOO::CITrigger
Constructor to create an CITrigger task object. More...
class | JYPCIe5112CoreOO::CIDigitalTrigger
CI Digital trigger . More...
class | JYPCIe5112CoreOO::EdgeCountingOutEvent
Edge counting output event configuration class. More...
class | JYPCIe5112CoreOO::CIExternalTimebase
class | JYPCIe5112CoreOO::CITimebase
Timebase configuration class. More...
class | JYPCIe5112CoreOO::CISignalExport
CI Signal Export Class. More...

Namespaces

namespace JYPCIe5112CoreOO

Enumerations

enum class | JYPCIe5112CoreOO::CountDirection { JYPCIe5112CoreOO::Up = 0x0 , JYPCIe5112CoreOO::Down = 0x1 , JYPCIe5112CoreOO::External = 0x2 }
Counter direction. More...
enum class | JYPCIe5112CoreOO::ValueReturnMode { JYPCIe5112CoreOO::TwoValue , JYPCIe5112CoreOO::OneValue }
enum class JYPCIe5112CoreOO::CIType {
JYPCIe5112CoreOO::EdgeCounting , JYPCIe5112CoreOO::Period , JYPCIe5112CoreOO::Frequency , JYPCIe5112CoreOO::Pulse ,
JYPCIe5112CoreOO::SemiPeriod , JYPCIe5112CoreOO::TwoEdgeSeparation , JYPCIe5112CoreOO::QuadEncoder , JYPCIe5112CoreOO::TwoPulseEncoder
}
Counter Input Application Type. More...
enum class | JYPCIe5112CoreOO::CISampleClockSource { JYPCIe5112CoreOO::Implicit = 0x0 , JYPCIe5112CoreOO::Internal = 0x1 , JYPCIe5112CoreOO::External = 0x2 }
CI Sample Clock Source. More...
enum class | JYPCIe5112CoreOO::EdgeType { JYPCIe5112CoreOO::Rising , JYPCIe5112CoreOO::Falling }
Edge Type. More...
enum class | JYPCIe5112CoreOO::QuadEncodingType { JYPCIe5112CoreOO::X1 , JYPCIe5112CoreOO::X2 , JYPCIe5112CoreOO::X4 }
Quadrature Encoding Type. More...
enum class | JYPCIe5112CoreOO::CITriggerType { JYPCIe5112CoreOO::Immediate = 0x0 , JYPCIe5112CoreOO::Digital = 0x1 , JYPCIe5112CoreOO::Soft = 0x3 }
TriggerType Digital/Immediate/Soft. More...
enum class JYPCIe5112CoreOO::CIDigitalTriggerSource {
JYPCIe5112CoreOO::PFI0 , JYPCIe5112CoreOO::PFI1 , JYPCIe5112CoreOO::PFI2 , JYPCIe5112CoreOO::PFI3 ,
JYPCIe5112CoreOO::PFI4 , JYPCIe5112CoreOO::PFI5 , JYPCIe5112CoreOO::PFI6 , JYPCIe5112CoreOO::PFI7 ,
JYPCIe5112CoreOO::PFI8 , JYPCIe5112CoreOO::PFI9 , JYPCIe5112CoreOO::PFI10 , JYPCIe5112CoreOO::PFI11 ,
JYPCIe5112CoreOO::PFI12 , JYPCIe5112CoreOO::PFI13 , JYPCIe5112CoreOO::PFI14 , JYPCIe5112CoreOO::PFI15 ,
JYPCIe5112CoreOO::PXI_Trig0 = 40 , JYPCIe5112CoreOO::PXI_Trig1 = 41 , JYPCIe5112CoreOO::PXI_Trig2 = 42 , JYPCIe5112CoreOO::PXI_Trig3 = 43 ,
JYPCIe5112CoreOO::PXI_Trig4 = 44 , JYPCIe5112CoreOO::PXI_Trig5 = 45 , JYPCIe5112CoreOO::PXI_Trig6 = 46 , JYPCIe5112CoreOO::PXI_Trig7 = 47 ,
JYPCIe5112CoreOO::AI_StartTrig = 16 , JYPCIe5112CoreOO::AI_ReferenceTrig = 17 , JYPCIe5112CoreOO::AO_StartTrig = 26 , JYPCIe5112CoreOO::DI_StartTrig = 22 ,
JYPCIe5112CoreOO::DI_ReferenceTrig = 23 , JYPCIe5112CoreOO::DO_StartTrig = 29 , JYPCIe5112CoreOO::CI_0_StartTrig = 68 , JYPCIe5112CoreOO::CI_1_StartTrig = 73 ,
JYPCIe5112CoreOO::CI_2_StartTrig = 76 , JYPCIe5112CoreOO::CI_3_StartTrig = 79 , JYPCIe5112CoreOO::CO_0_StartTrig = 69 , JYPCIe5112CoreOO::CO_1_StartTrig = 74 ,
JYPCIe5112CoreOO::CO_2_StartTrig = 77 , JYPCIe5112CoreOO::CO_3_StartTrig = 80 , JYPCIe5112CoreOO::CO_0_Output = 37 , JYPCIe5112CoreOO::CO_1_Output = 51 ,
JYPCIe5112CoreOO::CO_2_Output = 60 , JYPCIe5112CoreOO::CO_3_Output = 66
}
CI Digital trigger source. More...
enum class | JYPCIe5112CoreOO::CIDigitalTriggerEdge { JYPCIe5112CoreOO::Rising , JYPCIe5112CoreOO::Falling }
CI Digital Trigger Edge. More...
enum class | JYPCIe5112CoreOO::EdgeCntOunEvtIdleState { JYPCIe5112CoreOO::LowLevel = 0 , JYPCIe5112CoreOO::HighLevel = 1 }
Output idle state when the event has not occurred. More...
enum class | JYPCIe5112CoreOO::CISignalExportSource { JYPCIe5112CoreOO::StartTrig , JYPCIe5112CoreOO::SampleClock }
SourceSignal. More...
enum class | JYPCIe5112CoreOO::CITimebaseSource { JYPCIe5112CoreOO::Internal100MHz = 0 , JYPCIe5112CoreOO::Internal5MHz = 1 , JYPCIe5112CoreOO::Internal100kHz = 2 , JYPCIe5112CoreOO::External = 3 }
Timebase source. More...


5112 C++ Programming Manual: JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask Class Reference

  • JYPCIe5112CoreOOCITask
Public Member Functions | Public Attributes | List of all members
JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask Class Reference

#include <JYPCIe5112CoreOOCITask.h>

Public Member Functions

JYPCIe5112CoreOOCITask (int slotNum, int channel)
JYPCIe5112CoreOOCITask (std::string boardName, int channel)
void | Start ()
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Stop ()
Stop CI task .
void | ReadSinglePoint (uint32_t &count)
Read a signle count value from register, Available when Type is CIType.EdgeCounting, CIType.QuadEncoder or CIType.TwoPulseEncoder.
void | ReadData (uint32_t *pBufCount, int samplesToAcquire, int timeout=10000)
Read counter values from buffer.
void | ReadData (std::vector< uint32_t > &pBufCount, int samplesToAcquire, int timeout=10000)
Read counter values from buffer.
void | ReadData (double *pBufMeasurement, int samplesToAcquire, int timeout=10000)
Read frequency value or period value from buffer.
void | ReadData (std::vector< double > &pBufMeasurement, int samplesToAcquire, int timeout=10000)
Read frequency value or period value from buffer.
void | ReadSinglePoint (double &measurement, int timeout=10000)
Read a signle frequency value or period value from register.
void | ReadSinglePoint (double &measurement1, double &measurement2, int timeout=10000)
Read a signle measurement of pulse's duration value, or two-edge separtion value (two results at a time) from register.
void | ReadData (double *pBufMeasurement1, double *pBufMeasurement2, int samplesToAcquire, int timeout=10000)
Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.
void | ReadData (std::vector< double > &pBufMeasurement1, std::vector< double > &pBufMeasurement2, int samplesToAcquire, int timeout=10000)
Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.

Public Attributes

CIType Type
CI Application types.
JYPCIe5112CoreOOProperty< JYPCIe5112CoreOOCITask, uint64_t, JYPCIe5112CoreOOPropertyType::READ_ONLY > | AvailableSamples
Number of points per channel that can be read in the buffer .
JYPCIe5112CoreOOProperty< JYPCIe5112CoreOOCITask, uint64_t, JYPCIe5112CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
CISampleClock * SampleClock
Clock Source.
uint32_t | SamplesToAcquire
Number of samples to be read per channel.Only valid when Mode is CIMode.Finite.
JYPCIe5112CoreOO::EdgeCounting * EdgeCounting
Edge Counting Configuration.
JYPCIe5112CoreOO::FrequencyMeas * FrequencyMeas
Frequency Measurement Configuration.
JYPCIe5112CoreOO::PeriodMeas * PeriodMeas
Period Measurement Configuration.
JYPCIe5112CoreOO::PulseMeas * PulseMeas
Pulse Measurement Configuration.
JYPCIe5112CoreOO::SemiPeriodMeas * SemiPeriodMeas
Pulse Measurement Configuration.
JYPCIe5112CoreOO::TwoEdgeSeparation * TwoEdgeSeparation
TwoEdgeSeparation.
JYPCIe5112CoreOO::QuadEncoder * QuadEncoder
QuadEncoder.
JYPCIe5112CoreOO::TwoPulseEncoder * TwoPulseEncoder
TwoPulseEncoder.
CITrigger * Trigger
CI Trigger Configuration.
CISignalExport * SignalExport
Export CI Signal Configuration.
JYPCIe5112CoreOODevice * Device
Device.

Constructor & Destructor Documentation

◆ JYPCIe5112CoreOOCITask() [1/2]

JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask::JYPCIe5112CoreOOCITask | ( | int | slotNum,
 |  | int | channel )

◆ JYPCIe5112CoreOOCITask() [2/2]

JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask::JYPCIe5112CoreOOCITask | ( | std::string | boardName,
 |  | int | channel )

Member Function Documentation

◆ ReadData() [1/6]

void JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask::ReadData | ( | double * | pBufMeasurement,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read frequency value or period value from buffer.

Available when JYPCIe5112CITask.Mode is NOT CIMode.Single, and Type is CIType.Frequency or CIType.Period.

Parameters
bufMeasurement | Buffer for reading data. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period in seconds when Type is CIType.Period.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [2/6]

void JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask::ReadData | ( | double * | pBufMeasurement1,
 |  | double * | pBufMeasurement2,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.

. Available when JYPCIe5112CITask.Mode is NOT CIMode.Single, Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
bufMeasurement1 | Buffer for reading data. Indicates high level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
bufMeasurement2 | Buffer for reading data. Indicates low level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [3/6]

void JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask::ReadData | ( | std::vector< double > & | pBufMeasurement,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read frequency value or period value from buffer.

Available when JYPCIe5112CITask.Mode is NOT CIMode.Single, and Type is CIType.Frequency or CIType.Period.

Parameters
bufMeasurement | Buffer for reading data. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period in seconds when Type is CIType.Period.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [4/6]

void JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask::ReadData | ( | std::vector< double > & | pBufMeasurement1,
 |  | std::vector< double > & | pBufMeasurement2,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.

. Available when JYPCIe5112CITask.Mode is NOT CIMode.Single, Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
bufMeasurement1 | Buffer for reading data. Indicates high level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
bufMeasurement2 | Buffer for reading data. Indicates low level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [5/6]

void JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask::ReadData | ( | std::vector< uint32_t > & | pBufCount,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read counter values from buffer.

Available when JYPCIe5112CITask.Mode is NOT CIMode.Single, and Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder

Parameters
bufCount | Buffer for reading data.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [6/6]

void JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask::ReadData | ( | uint32_t * | pBufCount,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read counter values from buffer.

Available when JYPCIe5112CITask.Mode is NOT CIMode.Single, and Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder

Parameters
bufCount | Buffer for reading data.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [1/3]

void JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask::ReadSinglePoint | ( | double & | measurement,
 |  | int | timeout = 10000 )

Read a signle frequency value or period value from register.

Valid when Type is CIType.Frequency or CIType.Period.

Parameters
measurement Measurement value. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period is seconds when Type is CIType.Period.
timeout
Timeout (ms). Wait until the measurement is completed or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [2/3]

void JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask::ReadSinglePoint | ( | double & | measurement1,
 |  | double & | measurement2,
 |  | int | timeout = 10000 )

Read a signle measurement of pulse's duration value, or two-edge separtion value (two results at a time) from register.

Available when Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
measurement1 | Measurement Value 1. Indicates low level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
measurement2 | Measurement Value 2. Indicates high level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
timeout
Timeout (ms). Wait until the measurement is completed or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [3/3]

void JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask::ReadSinglePoint ( uint32_t & count )

Read a signle count value from register, Available when Type is CIType.EdgeCounting, CIType.QuadEncoder or CIType.TwoPulseEncoder.

Parameters
count counter value。

◆ SendSoftwareTrigger()

void JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask::SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask::Start ( )

◆ Stop()

void JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask::Stop ( )

Stop CI task .

Member Data Documentation

◆ AvailableSamples

JYPCIe5112CoreOOProperty<JYPCIe5112CoreOOCITask, uint64_t, JYPCIe5112CoreOOPropertyType::READ_ONLY> JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask::AvailableSamples

Number of points per channel that can be read in the buffer .

◆ Device

JYPCIe5112CoreOODevice* JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask::Device

Device.

◆ EdgeCounting

JYPCIe5112CoreOO::EdgeCounting* JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask::EdgeCounting

Edge Counting Configuration.

◆ FrequencyMeas

JYPCIe5112CoreOO::FrequencyMeas* JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask::FrequencyMeas

Frequency Measurement Configuration.

◆ PeriodMeas

JYPCIe5112CoreOO::PeriodMeas* JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask::PeriodMeas

Period Measurement Configuration.

◆ PulseMeas

JYPCIe5112CoreOO::PulseMeas* JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask::PulseMeas

Pulse Measurement Configuration.

◆ QuadEncoder

JYPCIe5112CoreOO::QuadEncoder* JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask::QuadEncoder

QuadEncoder.

◆ SampleClock

CISampleClock* JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask::SampleClock

Clock Source.

◆ SamplesToAcquire

uint32_t JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask::SamplesToAcquire

Number of samples to be read per channel.Only valid when Mode is CIMode.Finite.

◆ SemiPeriodMeas

JYPCIe5112CoreOO::SemiPeriodMeas* JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask::SemiPeriodMeas

Pulse Measurement Configuration.

◆ SignalExport

CISignalExport* JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask::SignalExport

Export CI Signal Configuration.

◆ TransferedSamples

JYPCIe5112CoreOOProperty<JYPCIe5112CoreOOCITask, uint64_t, JYPCIe5112CoreOOPropertyType::READ_ONLY> JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT CIMode.Single.

◆ Trigger

CITrigger* JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask::Trigger

CI Trigger Configuration.

◆ TwoEdgeSeparation

JYPCIe5112CoreOO::TwoEdgeSeparation* JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask::TwoEdgeSeparation

TwoEdgeSeparation.

◆ TwoPulseEncoder

JYPCIe5112CoreOO::TwoPulseEncoder* JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask::TwoPulseEncoder

TwoPulseEncoder.

◆ Type

CIType JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask::Type

CI Application types.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOCITask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::CIInternalSampleClock Class Reference

  • CIInternalSampleClock
Public Attributes | List of all members
JYPCIe5112CoreOO::CIInternalSampleClock Class Reference

CI Internal Sample Clock Configuration Class. More...

#include <JYPCIe5112CoreOOCITask.h>

Public Attributes

JYPCIe5112CoreOOProperty< CIInternalSampleClock, double, JYPCIe5112CoreOOPropertyType::READ_WRITE > Rate
The rate of the internal sample clock (sample rate) which is generated by dividing the internal clock (200MHz).

Detailed Description

CI Internal Sample Clock Configuration Class.

Member Data Documentation

◆ Rate

JYPCIe5112CoreOOProperty<CIInternalSampleClock, double, JYPCIe5112CoreOOPropertyType::READ_WRITE> JYPCIe5112CoreOO::CIInternalSampleClock::Rate

The rate of the internal sample clock (sample rate) which is generated by dividing the internal clock (200MHz).

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOCITask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::CIImplicitSampleClock Class Reference

  • CIImplicitSampleClock
Public Attributes | List of all members
JYPCIe5112CoreOO::CIImplicitSampleClock Class Reference

CI Implicit Sample Clock class. More...

#include <JYPCIe5112CoreOOCITask.h>

Public Attributes

double ExpectedRate
Expected Rate of Implicit Sample Clock.

Detailed Description

CI Implicit Sample Clock class.

Member Data Documentation

◆ ExpectedRate

double JYPCIe5112CoreOO::CIImplicitSampleClock::ExpectedRate

Expected Rate of Implicit Sample Clock.

Filling this parameter accurately would helps the driver to set a proper DDR write frequency internally.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOCITask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::CIExternalSampleClock Class Reference

  • CIExternalSampleClock
Public Attributes | List of all members
JYPCIe5112CoreOO::CIExternalSampleClock Class Reference

CI Implicit Sample Clock class. More...

#include <JYPCIe5112CoreOOCITask.h>

Public Attributes

ClockTerminal Terminal
External Sample Clock Input Terminal.
double ExpectedRate
Expected Rate of External Sample Clock.

Detailed Description

CI Implicit Sample Clock class.

Member Data Documentation

◆ ExpectedRate

double JYPCIe5112CoreOO::CIExternalSampleClock::ExpectedRate

Expected Rate of External Sample Clock.

Filling this parameter accurately would helps the driver to set a proper DDR write frequency internally.

◆ Terminal

ClockTerminal JYPCIe5112CoreOO::CIExternalSampleClock::Terminal

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOCITask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::CISampleClock Class Reference

  • CISampleClock
Public Attributes | List of all members
JYPCIe5112CoreOO::CISampleClock Class Reference

CI Sample Clock class. More...

#include <JYPCIe5112CoreOOCITask.h>

Public Attributes

CISampleClockSource Source
CI Sample Clock Source.
CIExternalSampleClock * External
CI External Sample Clock Configuration.
CIImplicitSampleClock * Implicit
CI Implicit Sample Clock Configuration.
CIInternalSampleClock * Internal
Internal Sample Clock Configuration.

Detailed Description

CI Sample Clock class.

Member Data Documentation

◆ External

CIExternalSampleClock* JYPCIe5112CoreOO::CISampleClock::External

CI External Sample Clock Configuration.

Valid when Source is CISampleClockSource.External.

◆ Implicit

CIImplicitSampleClock* JYPCIe5112CoreOO::CISampleClock::Implicit

CI Implicit Sample Clock Configuration.

Valid when Source is CISampleClockSource.Implicit.

◆ Internal

CIInternalSampleClock* JYPCIe5112CoreOO::CISampleClock::Internal

Internal Sample Clock Configuration.

Valid when Source is CISampleClockSource.Internal.

◆ Source

CISampleClockSource JYPCIe5112CoreOO::CISampleClock::Source

CI Sample Clock Source.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOCITask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::EdgeCounting Class Reference

  • EdgeCounting
Public Attributes | List of all members
JYPCIe5112CoreOO::EdgeCounting Class Reference

Configure CI EdgeCounting. More...

#include <JYPCIe5112CoreOOCITask.h>

Public Attributes

int InitialCount
Initial Count.
CountDirection Direction
Counter direction.
EdgeType ActiveEdge
The avtive edge of the input signal, the counter will count up or down on this edge.
PauseTrigger * Pause
Pause Trigger Configuration.
EdgeCountingOutEvent * OutEvent
Edge counting output event.
JYPCIe5112CoreOO::InputTerminal DirTerminal
Terminal of External Count Diretion Control.
JYPCIe5112CoreOO::InputTerminal Input_Terminal
Input Terminal.

Detailed Description

Configure CI EdgeCounting.

Member Data Documentation

◆ ActiveEdge

EdgeType JYPCIe5112CoreOO::EdgeCounting::ActiveEdge

The avtive edge of the input signal, the counter will count up or down on this edge.

◆ Direction

CountDirection JYPCIe5112CoreOO::EdgeCounting::Direction

Counter direction.

enum Up/Down/External

◆ DirTerminal

JYPCIe5112CoreOO::InputTerminal JYPCIe5112CoreOO::EdgeCounting::DirTerminal

Terminal of External Count Diretion Control.

Valid when Direction is CountDirection.External

◆ InitialCount

int JYPCIe5112CoreOO::EdgeCounting::InitialCount

Initial Count.

◆ Input_Terminal

JYPCIe5112CoreOO::InputTerminal JYPCIe5112CoreOO::EdgeCounting::Input_Terminal

Input Terminal.

◆ OutEvent

EdgeCountingOutEvent* JYPCIe5112CoreOO::EdgeCounting::OutEvent

Edge counting output event.

A pulse will be generated when the count value reaches specified threshold

◆ Pause

PauseTrigger* JYPCIe5112CoreOO::EdgeCounting::Pause

Pause Trigger Configuration.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOCITask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::FrequencyMeas Class Reference

  • FrequencyMeas
Public Attributes | List of all members
JYPCIe5112CoreOO::FrequencyMeas Class Reference

Configure CI Measure. More...

#include <JYPCIe5112CoreOOCITask.h>

Public Attributes

CITimebase * Timebase
Timebase configuration.
JYPCIe5112CoreOO::InputTerminal Input_Terminal
Input Terminal.

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ Input_Terminal

JYPCIe5112CoreOO::InputTerminal JYPCIe5112CoreOO::FrequencyMeas::Input_Terminal

Input Terminal.

◆ Timebase

CITimebase* JYPCIe5112CoreOO::FrequencyMeas::Timebase

Timebase configuration.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOCITask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::PeriodMeas Class Reference

  • PeriodMeas
Public Attributes | List of all members
JYPCIe5112CoreOO::PeriodMeas Class Reference

Configure CI Measure. More...

#include <JYPCIe5112CoreOOCITask.h>

Public Attributes

CITimebase * Timebase
Timebase configuration.
JYPCIe5112CoreOO::InputTerminal Input_Terminal
Input Terminal.

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ Input_Terminal

JYPCIe5112CoreOO::InputTerminal JYPCIe5112CoreOO::PeriodMeas::Input_Terminal

Input Terminal.

◆ Timebase

CITimebase* JYPCIe5112CoreOO::PeriodMeas::Timebase

Timebase configuration.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOCITask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::PulseMeas Class Reference

  • PulseMeas
Public Attributes | List of all members
JYPCIe5112CoreOO::PulseMeas Class Reference

Configure CI Measure. More...

#include <JYPCIe5112CoreOOCITask.h>

Public Attributes

CITimebase * Timebase
Timebase configuration.
JYPCIe5112CoreOO::InputTerminal Input_Terminal
Input Terminal.
EdgeType StartingEdge = EdgeType::Rising

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ Input_Terminal

JYPCIe5112CoreOO::InputTerminal JYPCIe5112CoreOO::PulseMeas::Input_Terminal

Input Terminal.

◆ StartingEdge

EdgeType JYPCIe5112CoreOO::PulseMeas::StartingEdge = EdgeType::Rising

◆ Timebase

CITimebase* JYPCIe5112CoreOO::PulseMeas::Timebase

Timebase configuration.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOCITask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::SemiPeriodMeas Class Reference

  • SemiPeriodMeas
Public Attributes | List of all members
JYPCIe5112CoreOO::SemiPeriodMeas Class Reference

Configure CI SemiPeriodMeas. More...

#include <JYPCIe5112CoreOOCITask.h>

Public Attributes

CITimebase * Timebase
Timebase configuration.
JYPCIe5112CoreOO::InputTerminal Input_Terminal
Input Terminal.
EdgeType StartingEdge = EdgeType::Rising

Detailed Description

Configure CI SemiPeriodMeas.

Member Data Documentation

◆ Input_Terminal

JYPCIe5112CoreOO::InputTerminal JYPCIe5112CoreOO::SemiPeriodMeas::Input_Terminal

Input Terminal.

◆ StartingEdge

EdgeType JYPCIe5112CoreOO::SemiPeriodMeas::StartingEdge = EdgeType::Rising

◆ Timebase

CITimebase* JYPCIe5112CoreOO::SemiPeriodMeas::Timebase

Timebase configuration.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOCITask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::TwoEdgeSeparation Class Reference

  • TwoEdgeSeparation
Public Attributes | List of all members
JYPCIe5112CoreOO::TwoEdgeSeparation Class Reference

Configure CI Measure. More...

#include <JYPCIe5112CoreOOCITask.h>

Public Attributes

CITimebase * Timebase
Timebase configuration.
InputTerminal FirstInputTerminal
Input Terminal.
InputTerminal SecondInputTerminal
Input Terminal.
ValueReturnMode EdgeSeparationMode

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ EdgeSeparationMode

ValueReturnMode JYPCIe5112CoreOO::TwoEdgeSeparation::EdgeSeparationMode

◆ FirstInputTerminal

InputTerminal JYPCIe5112CoreOO::TwoEdgeSeparation::FirstInputTerminal

Input Terminal.

◆ SecondInputTerminal

InputTerminal JYPCIe5112CoreOO::TwoEdgeSeparation::SecondInputTerminal

Input Terminal.

◆ Timebase

CITimebase* JYPCIe5112CoreOO::TwoEdgeSeparation::Timebase

Timebase configuration.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOCITask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::QuadEncoder Class Reference

  • QuadEncoder
Public Attributes | List of all members
JYPCIe5112CoreOO::QuadEncoder Class Reference

Configure CI Measure. More...

#include <JYPCIe5112CoreOOCITask.h>

Public Attributes

QuadEncodingType EncodingType
Type of Encoding.
bool | ZReloadEnabled
In Encoder mode ,the Z signal enable.
int | InitialCount
Initial Count.
InputTerminal AInputTerminal
Input Terminal.
InputTerminal BInputTerminal
Input Terminal.
InputTerminal ZInputTerminal
Input Terminal.

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ AInputTerminal

InputTerminal JYPCIe5112CoreOO::QuadEncoder::AInputTerminal

Input Terminal.

◆ BInputTerminal

InputTerminal JYPCIe5112CoreOO::QuadEncoder::BInputTerminal

Input Terminal.

◆ EncodingType

QuadEncodingType JYPCIe5112CoreOO::QuadEncoder::EncodingType

Type of Encoding.

◆ InitialCount

int JYPCIe5112CoreOO::QuadEncoder::InitialCount

Initial Count.

◆ ZInputTerminal

InputTerminal JYPCIe5112CoreOO::QuadEncoder::ZInputTerminal

Input Terminal.

◆ ZReloadEnabled

bool JYPCIe5112CoreOO::QuadEncoder::ZReloadEnabled

In Encoder mode ,the Z signal enable.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOCITask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::TwoPulseEncoder Class Reference

  • TwoPulseEncoder
Public Attributes | List of all members
JYPCIe5112CoreOO::TwoPulseEncoder Class Reference

Configure CI Measure. More...

#include <JYPCIe5112CoreOOCITask.h>

Public Attributes

int InitialCount
Initial Count.
InputTerminal AInputTerminal
Input Terminal.
InputTerminal BInputTerminal
Input Terminal.

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ AInputTerminal

InputTerminal JYPCIe5112CoreOO::TwoPulseEncoder::AInputTerminal

Input Terminal.

◆ BInputTerminal

InputTerminal JYPCIe5112CoreOO::TwoPulseEncoder::BInputTerminal

Input Terminal.

◆ InitialCount

int JYPCIe5112CoreOO::TwoPulseEncoder::InitialCount

Initial Count.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOCITask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::CITrigger Class Reference

  • CITrigger
Public Attributes | List of all members
JYPCIe5112CoreOO::CITrigger Class Reference

Constructor to create an CITrigger task object. More...

#include <JYPCIe5112CoreOOCITask.h>

Public Attributes

CITriggerType Type
CI trigger type.
CIDigitalTrigger * Digital
CI Digital Trigger.

Detailed Description

Constructor to create an CITrigger task object.

Used to build CI Trigger

Member Data Documentation

◆ Digital

CIDigitalTrigger* JYPCIe5112CoreOO::CITrigger::Digital

CI Digital Trigger.

Valid when Type is CITriggerType.Digital

◆ Type

CITriggerType JYPCIe5112CoreOO::CITrigger::Type

CI trigger type.

enum Immediate/Digital/Soft.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOCITask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::CIDigitalTrigger Class Reference

  • CIDigitalTrigger
Public Attributes | List of all members
JYPCIe5112CoreOO::CIDigitalTrigger Class Reference

CI Digital trigger . More...

#include <JYPCIe5112CoreOOCITask.h>

Public Attributes

CIDigitalTriggerSource Source
CI Digital Trigger source.
CIDigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Detailed Description

CI Digital trigger .

Member Data Documentation

◆ Edge

CIDigitalTriggerEdge JYPCIe5112CoreOO::CIDigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

CIDigitalTriggerSource JYPCIe5112CoreOO::CIDigitalTrigger::Source

CI Digital Trigger source.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOCITask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::EdgeCountingOutEvent Class Reference

  • EdgeCountingOutEvent
Public Attributes | List of all members
JYPCIe5112CoreOO::EdgeCountingOutEvent Class Reference

Edge counting output event configuration class. More...

#include <JYPCIe5112CoreOOCITask.h>

Public Attributes

EdgeCntOunEvtIdleState IdleState
Output idle state when the event has not occurred.
uint32_t Threshold
Comparison threshold.
IOTerminal Terminal
Terminal.

Detailed Description

Edge counting output event configuration class.

Member Data Documentation

◆ IdleState

EdgeCntOunEvtIdleState JYPCIe5112CoreOO::EdgeCountingOutEvent::IdleState

Output idle state when the event has not occurred.

The default value is EdgeCntOunEvtIdleState.LowLevel

◆ Terminal

IOTerminal JYPCIe5112CoreOO::EdgeCountingOutEvent::Terminal

Terminal.

◆ Threshold

uint32_t JYPCIe5112CoreOO::EdgeCountingOutEvent::Threshold

Comparison threshold.

The default value is 2^32-1

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOCITask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::CIExternalTimebase Class Reference

  • CIExternalTimebase
Public Attributes | List of all members
JYPCIe5112CoreOO::CIExternalTimebase Class Reference

#include <JYPCIe5112CoreOOCITask.h>

Public Attributes

JYPCIe5112CoreOO::InputTerminal Terminal
double Frequency = 100e6

Member Data Documentation

◆ Frequency

double JYPCIe5112CoreOO::CIExternalTimebase::Frequency = 100e6

◆ Terminal

JYPCIe5112CoreOO::InputTerminal JYPCIe5112CoreOO::CIExternalTimebase::Terminal
The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOCITask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::CITimebase Class Reference

  • CITimebase
Public Attributes | List of all members
JYPCIe5112CoreOO::CITimebase Class Reference

Timebase configuration class. More...

#include <JYPCIe5112CoreOOCITask.h>

Public Attributes

CITimebaseSource Source
Timebase Source.
CIExternalTimebase External

Detailed Description

Timebase configuration class.

Member Data Documentation

◆ External

CIExternalTimebase JYPCIe5112CoreOO::CITimebase::External

◆ Source

CITimebaseSource JYPCIe5112CoreOO::CITimebase::Source

Timebase Source.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOCITask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::CISignalExport Class Reference

  • CISignalExport
Public Member Functions | List of all members
JYPCIe5112CoreOO::CISignalExport Class Reference

CI Signal Export Class. More...

#include <JYPCIe5112CoreOOCITask.h>

Public Member Functions

void | Add (CISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (CISignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

CI Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JYPCIe5112CoreOO::CISignalExport::Add | ( | CISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | CI Signal Source
destination | Export Desination

◆ Add() [2/2]

void JYPCIe5112CoreOO::CISignalExport::Add | ( | CISignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | CI Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JYPCIe5112CoreOO::CISignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JYPCIe5112CoreOO::CISignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOCITask.h


5112 C++ Programming Manual: COO/5112/JYPCIe5112CoreOOCommon.h File Reference

  • File List
  • File Members
  • COO
  • 5112
Classes | Namespaces | Macros | Enumerations | Functions
JYPCIe5112CoreOOCommon.h File Reference
#include <string>
#include <stdint.h>

Classes

class | JYPCIe5112CoreOO::JYDriverException
class | JYPCIe5112CoreOO::JYPCIe5112CoreOOProperty< ContainerClass, ValueType, propertyType >
属性模板类 More...
class | JYPCIe5112CoreOO::PauseTrigger
Pause trigger configuration class. More...

Namespaces

namespace JYPCIe5112CoreOO

Macros

#define | EXTERN_C extern
Windows.
#define | JYPCIe5112CoreOO_API

Enumerations

enum class | JYPCIe5112CoreOO::OutputState { JYPCIe5112CoreOO::HoldOn = 0 , JYPCIe5112CoreOO::HighLevel = 1 , JYPCIe5112CoreOO::LowLevel = 2 }
CO output state when pause trigger valid. More...
enum class | JYPCIe5112CoreOO::JYPCIe5112CoreOOPropertyType { JYPCIe5112CoreOO::READ_ONLY = 1 , JYPCIe5112CoreOO::WRITE_ONLY = 2 , JYPCIe5112CoreOO::READ_WRITE = 3 }
enum class JYPCIe5112CoreOO::JYDriverExceptionPublic {
JYPCIe5112CoreOO::UnKnown = 0 , JYPCIe5112CoreOO::OpenDeviceFailed = -10001 , JYPCIe5112CoreOO::CloseDeviceFailed = -10002 , JYPCIe5112CoreOO::ResetDeviceFailed = -10003 ,
JYPCIe5112CoreOO::GetDevicePropertyFailed = -10004 , JYPCIe5112CoreOO::SetDevicePropertyFailed = -10005 , JYPCIe5112CoreOO::HardwareResourceIsReserved = -10006 , JYPCIe5112CoreOO::MethodNotPermitedToCallWhenCurrentStatus = -10007 ,
JYPCIe5112CoreOO::InvalidUserDataBuffer = -10008 , JYPCIe5112CoreOO::NoChannelAdded = -10009 , JYPCIe5112CoreOO::NotSupportOperationForCurrentDevice = -10010 , JYPCIe5112CoreOO::CreatTaskFailed = -10100 ,
JYPCIe5112CoreOO::StartTaskFailed = -10101 , JYPCIe5112CoreOO::StopTaskFailed = -10102 , JYPCIe5112CoreOO::TaskHasNotStarted = -10103 , JYPCIe5112CoreOO::TaskHasStartedCannotPerformTheSetOperation = -10104 ,
JYPCIe5112CoreOO::ChannelNumberParameterInvalid = -10105 , JYPCIe5112CoreOO::ChannelInputRangeParameterInvalid = -10106 , JYPCIe5112CoreOO::ChannelTerminalParameterInvalid = -10107 , JYPCIe5112CoreOO::ChannelCouplingParameterInvalid = -10108 ,
JYPCIe5112CoreOO::SampeleModeParameterInvalid = -10109 , JYPCIe5112CoreOO::SampleClockParameterInvalid = -10110 , JYPCIe5112CoreOO::SampleRateParameterInvalid = -10111 , JYPCIe5112CoreOO::UpdateRateParameterInvalid = -10112 ,
JYPCIe5112CoreOO::TriggerParameterInvalid = -10113 , JYPCIe5112CoreOO::ReferenceTriggerDoesNotMatchWithSampleMode = -10114 , JYPCIe5112CoreOO::PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint = -10115 , JYPCIe5112CoreOO::ReadDataFailed = -10016 ,
JYPCIe5112CoreOO::ReadDataTimeout = -10017 , JYPCIe5112CoreOO::WriteDataFailed = -10018 , JYPCIe5112CoreOO::WriteDataTimeout = -10019 , JYPCIe5112CoreOO::WriteDataLengthCannotBeLessThanN = -10020 ,
JYPCIe5112CoreOO::BufferDataOverflow = -10021 , JYPCIe5112CoreOO::BufferDataDownflow = -10022 , JYPCIe5112CoreOO::CheckBufferFailed = -10023 , JYPCIe5112CoreOO::PointInvalidInFiniteMode = -10024 ,
JYPCIe5112CoreOO::ReadPointInvalid = -10025 , JYPCIe5112CoreOO::OnlySupportRecordMode = -10026 , JYPCIe5112CoreOO::SendSoftTirggerFailed = -10027 , JYPCIe5112CoreOO::TaskTimeout = -10028 ,
JYPCIe5112CoreOO::CounterParametersInvalid = -10029 , JYPCIe5112CoreOO::WritePointInvalid = -10030 , JYPCIe5112CoreOO::SignalExportDestinationInvalid = -10031 , JYPCIe5112CoreOO::InvalidParameter = -10033
}
enum class JYPCIe5112CoreOO::ClockTerminal {
JYPCIe5112CoreOO::PFI0 = 0 , JYPCIe5112CoreOO::PFI1 = 1 , JYPCIe5112CoreOO::PFI2 = 2 , JYPCIe5112CoreOO::PFI3 = 3 ,
JYPCIe5112CoreOO::PFI4 = 4 , JYPCIe5112CoreOO::PFI5 = 5 , JYPCIe5112CoreOO::PFI6 = 6 , JYPCIe5112CoreOO::PFI7 = 7 ,
JYPCIe5112CoreOO::PFI8 = 8 , JYPCIe5112CoreOO::PFI9 = 9 , JYPCIe5112CoreOO::PFI10 = 10 , JYPCIe5112CoreOO::PFI11 = 11 ,
JYPCIe5112CoreOO::PFI12 = 12 , JYPCIe5112CoreOO::PFI13 = 13 , JYPCIe5112CoreOO::PFI14 = 14 , JYPCIe5112CoreOO::PFI15 = 15 ,
JYPCIe5112CoreOO::PXI_Trig0 = 16 , JYPCIe5112CoreOO::PXI_Trig1 = 17 , JYPCIe5112CoreOO::PXI_Trig2 = 18 , JYPCIe5112CoreOO::PXI_Trig3 = 19 ,
JYPCIe5112CoreOO::PXI_Trig4 = 20 , JYPCIe5112CoreOO::PXI_Trig5 = 21 , JYPCIe5112CoreOO::PXI_Trig6 = 22 , JYPCIe5112CoreOO::PXI_Trig7 = 23 ,
JYPCIe5112CoreOO::AI_SampleClock = 24 , JYPCIe5112CoreOO::AO_SampleClock = 25 , JYPCIe5112CoreOO::CO0_Output = 26 , JYPCIe5112CoreOO::CO1_Output = 27 ,
JYPCIe5112CoreOO::ECLK = 28
}
enum class JYPCIe5112CoreOO::SignalExportDestination {
JYPCIe5112CoreOO::PFI0 , JYPCIe5112CoreOO::PFI1 , JYPCIe5112CoreOO::PFI2 , JYPCIe5112CoreOO::PFI3 ,
JYPCIe5112CoreOO::PFI4 , JYPCIe5112CoreOO::PFI5 , JYPCIe5112CoreOO::PFI6 , JYPCIe5112CoreOO::PFI7 ,
JYPCIe5112CoreOO::PFI8 , JYPCIe5112CoreOO::PFI9 , JYPCIe5112CoreOO::PFI10 , JYPCIe5112CoreOO::PFI11 ,
JYPCIe5112CoreOO::PFI12 , JYPCIe5112CoreOO::PFI13 , JYPCIe5112CoreOO::PFI14 , JYPCIe5112CoreOO::PFI15 ,
JYPCIe5112CoreOO::PXI_Trig0 , JYPCIe5112CoreOO::PXI_Trig1 , JYPCIe5112CoreOO::PXI_Trig2 , JYPCIe5112CoreOO::PXI_Trig3 ,
JYPCIe5112CoreOO::PXI_Trig4 , JYPCIe5112CoreOO::PXI_Trig5 , JYPCIe5112CoreOO::PXI_Trig6 , JYPCIe5112CoreOO::PXI_Trig7
}
enum class | JYPCIe5112CoreOO::OutputCompleteState { JYPCIe5112CoreOO::Zero , JYPCIe5112CoreOO::Hold }
Output Complete State. More...
enum class JYPCIe5112CoreOO::IOTerminal {
JYPCIe5112CoreOO::PFI0 = 0 , JYPCIe5112CoreOO::PFI1 = 1 , JYPCIe5112CoreOO::PFI2 = 2 , JYPCIe5112CoreOO::PFI3 = 3 ,
JYPCIe5112CoreOO::PFI4 = 44 , JYPCIe5112CoreOO::PFI5 = 5 , JYPCIe5112CoreOO::PFI6 = 6 , JYPCIe5112CoreOO::PFI7 = 7 ,
JYPCIe5112CoreOO::PFI8 = 8 , JYPCIe5112CoreOO::PFI9 = 9 , JYPCIe5112CoreOO::PFI10 = 10 , JYPCIe5112CoreOO::PFI11 = 11 ,
JYPCIe5112CoreOO::PFI12 = 12 , JYPCIe5112CoreOO::PFI13 = 13 , JYPCIe5112CoreOO::PFI14 = 14 , JYPCIe5112CoreOO::PFI15 = 15 ,
JYPCIe5112CoreOO::PXI_Trig0 = 16 , JYPCIe5112CoreOO::PXI_Trig1 = 17 , JYPCIe5112CoreOO::PXI_Trig2 = 18 , JYPCIe5112CoreOO::PXI_Trig3 = 19 ,
JYPCIe5112CoreOO::PXI_Trig4 = 20 , JYPCIe5112CoreOO::PXI_Trig5 =21 , JYPCIe5112CoreOO::PXI_Trig6 = 22 , JYPCIe5112CoreOO::PXI_Trig7 = 23 ,
JYPCIe5112CoreOO::None = 24
}
Cunter IO Terminal. More...
enum class | JYPCIe5112CoreOO::LevelPolarity { JYPCIe5112CoreOO::LowLevel = 0 , JYPCIe5112CoreOO::HighLevel = 1 , JYPCIe5112CoreOO::None = 2 }
Level Polarity. More...
enum class JYPCIe5112CoreOO::InputTerminal {
JYPCIe5112CoreOO::PFI0 = 0 , JYPCIe5112CoreOO::PFI1 = 1 , JYPCIe5112CoreOO::PFI2 = 2 , JYPCIe5112CoreOO::PFI3 = 3 ,
JYPCIe5112CoreOO::PFI4 = 4 , JYPCIe5112CoreOO::PFI5 = 5 , JYPCIe5112CoreOO::PFI6 = 6 , JYPCIe5112CoreOO::PFI7 = 7 ,
JYPCIe5112CoreOO::PFI8 = 8 , JYPCIe5112CoreOO::PFI9 = 9 , JYPCIe5112CoreOO::PFI10 = 10 , JYPCIe5112CoreOO::PFI11 = 11 ,
JYPCIe5112CoreOO::PFI12 = 12 , JYPCIe5112CoreOO::PFI13 = 13 , JYPCIe5112CoreOO::PFI14 = 14 , JYPCIe5112CoreOO::PFI15 = 15 ,
JYPCIe5112CoreOO::PXI_Trig0 = 16 , JYPCIe5112CoreOO::PXI_Trig1 = 17 , JYPCIe5112CoreOO::PXI_Trig2 = 18 , JYPCIe5112CoreOO::PXI_Trig3 = 19 ,
JYPCIe5112CoreOO::PXI_Trig4 = 20 , JYPCIe5112CoreOO::PXI_Trig5 = 21 , JYPCIe5112CoreOO::PXI_Trig6 = 22 , JYPCIe5112CoreOO::PXI_Trig7 = 23 ,
JYPCIe5112CoreOO::CO_0_OutPut = 24 , JYPCIe5112CoreOO::CO_1_OutPut = 25 , JYPCIe5112CoreOO::Timebase_100MHz = 26 , JYPCIe5112CoreOO::Timebase_5MHz = 27 ,
JYPCIe5112CoreOO::Timebase_100kHz = 28
}
Cunter Input Terminal. More...

Functions

std::string JYPCIe5112CoreOO::GetSignalExportDestinationString (SignalExportDestination destination)

Macro Definition Documentation

◆ EXTERN_C

#define EXTERN_C extern

Windows.

Linux

◆ JYPCIe5112CoreOO_API

#define JYPCIe5112CoreOO_API


5112 C++ Programming Manual: JYPCIe5112CoreOO::JYDriverException Class Reference

  • JYDriverException
Public Member Functions | Public Attributes | List of all members
JYPCIe5112CoreOO::JYDriverException Class Reference

#include <JYPCIe5112CoreOOCommon.h>

Public Member Functions

JYDriverException (JYDriverExceptionPublic exceptionCode, std::string msg="")
JYDriverException (int, std::string msg)

Public Attributes

std::string exceptionMessage
JYDriverExceptionPublic errorCode
JYDriverException * FollowingException

Constructor & Destructor Documentation

◆ JYDriverException() [1/2]

JYPCIe5112CoreOO::JYDriverException::JYDriverException | ( | JYDriverExceptionPublic | exceptionCode,
 |  | std::string | msg = "" )

◆ JYDriverException() [2/2]

JYPCIe5112CoreOO::JYDriverException::JYDriverException | ( | int | ,
 |  | std::string | msg )

Member Data Documentation

◆ errorCode

JYDriverExceptionPublic JYPCIe5112CoreOO::JYDriverException::errorCode

◆ exceptionMessage

std::string JYPCIe5112CoreOO::JYDriverException::exceptionMessage

◆ FollowingException

JYDriverException* JYPCIe5112CoreOO::JYDriverException::FollowingException
The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOCommon.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::JYPCIe5112CoreOOProperty< ContainerClass, ValueType, propertyType > Class Template Reference

  • JYPCIe5112CoreOOProperty
Public Member Functions | List of all members
JYPCIe5112CoreOO::JYPCIe5112CoreOOProperty< ContainerClass, ValueType, propertyType > Class Template Reference

属性模板类 More...

#include <JYPCIe5112CoreOOCommon.h>

Public Member Functions

JYPCIe5112CoreOOProperty ()
JYPCIe5112CoreOOProperty (ContainerClass *cObject, ValueType(ContainerClass::*pGet)(), void(ContainerClass::*pSet)(ValueType value))
JYPCIe5112CoreOOProperty (ValueType(*pGet)(), void(*pSet)(ValueType value))
ValueType operator= (const ValueType &value)
operator ValueType ()

Detailed Description

template<typename ContainerClass, typename ValueType, JYPCIe5112CoreOOPropertyType propertyType>
class JYPCIe5112CoreOO::JYPCIe5112CoreOOProperty< ContainerClass, ValueType, propertyType >

属性模板类

Constructor & Destructor Documentation

◆ JYPCIe5112CoreOOProperty() [1/3]

template<typename ContainerClass, typename ValueType, JYPCIe5112CoreOOPropertyType propertyType>
JYPCIe5112CoreOO::JYPCIe5112CoreOOProperty< ContainerClass, ValueType, propertyType >::JYPCIe5112CoreOOProperty ( )

◆ JYPCIe5112CoreOOProperty() [2/3]

template<typename ContainerClass, typename ValueType, JYPCIe5112CoreOOPropertyType propertyType>
JYPCIe5112CoreOO::JYPCIe5112CoreOOProperty< ContainerClass, ValueType, propertyType >::JYPCIe5112CoreOOProperty | ( | ContainerClass * | cObject,
 |  | ValueType(ContainerClass::* | pGet )(),
 |  | void(ContainerClass::* | pSet )(ValueType value) )

◆ JYPCIe5112CoreOOProperty() [3/3]

template<typename ContainerClass, typename ValueType, JYPCIe5112CoreOOPropertyType propertyType>
JYPCIe5112CoreOO::JYPCIe5112CoreOOProperty< ContainerClass, ValueType, propertyType >::JYPCIe5112CoreOOProperty | ( | ValueType(* | pGet )(),
 |  | void(* | pSet )(ValueType value) )

Member Function Documentation

◆ operator ValueType()

template<typename ContainerClass, typename ValueType, JYPCIe5112CoreOOPropertyType propertyType>
JYPCIe5112CoreOO::JYPCIe5112CoreOOProperty< ContainerClass, ValueType, propertyType >::operator ValueType ( )

◆ operator=()

template<typename ContainerClass, typename ValueType, JYPCIe5112CoreOOPropertyType propertyType>
ValueType JYPCIe5112CoreOO::JYPCIe5112CoreOOProperty< ContainerClass, ValueType, propertyType >::operator= ( const ValueType & value )
The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOCommon.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::PauseTrigger Class Reference

  • PauseTrigger
Public Attributes | List of all members
JYPCIe5112CoreOO::PauseTrigger Class Reference

Pause trigger configuration class. More...

#include <JYPCIe5112CoreOOCommon.h>

Public Attributes

LevelPolarity ActivePolarity
Pause trigger active polarity.
InputTerminal Terminal
Terminal.
OutputState Output_State

Detailed Description

Pause trigger configuration class.

Member Data Documentation

◆ ActivePolarity

LevelPolarity JYPCIe5112CoreOO::PauseTrigger::ActivePolarity

Pause trigger active polarity.

The default value is LevelPolarity.None, means the pause trigger is disabled.

◆ Output_State

OutputState JYPCIe5112CoreOO::PauseTrigger::Output_State

◆ Terminal

InputTerminal JYPCIe5112CoreOO::PauseTrigger::Terminal

Terminal.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOCommon.h


5112 C++ Programming Manual: COO/5112/JYPCIe5112CoreOOCOTask.h File Reference

  • File List
  • File Members
  • COO
  • 5112
Classes | Namespaces | Enumerations
JYPCIe5112CoreOOCOTask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JYPCIe5112CoreOOCommon.h"
#include "JYPCIe5112CoreOODevice.h"

Classes

class | JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask
class | JYPCIe5112CoreOO::CODigitalTrigger
CO Digital trigger . More...
class | JYPCIe5112CoreOO::COTrigger
Constructor to create an COTrigger task object. More...
class | JYPCIe5112CoreOO::COPulse
Pulse Parameter. More...
class | JYPCIe5112CoreOO::COTimebase
Timebase configuration class. More...
class | JYPCIe5112CoreOO::COSignalExport
CO Signal Export Class. More...

Namespaces

namespace JYPCIe5112CoreOO

Enumerations

enum class | JYPCIe5112CoreOO::COIdleState { JYPCIe5112CoreOO::HighLevel = 0x1 , JYPCIe5112CoreOO::LowLevel = 0x0 }
Idle state when pulse output before start and after stop. More...
enum class | JYPCIe5112CoreOO::COMode { JYPCIe5112CoreOO::Single = 3 }
enum class | JYPCIe5112CoreOO::COTriggerType { JYPCIe5112CoreOO::Immediate = 0x0 , JYPCIe5112CoreOO::Digital = 0x1 , JYPCIe5112CoreOO::Soft = 0x3 }
TriggerType Digital/Immediate/Soft. More...
enum class JYPCIe5112CoreOO::CODigitalTriggerSource {
JYPCIe5112CoreOO::PFI0 , JYPCIe5112CoreOO::PFI1 , JYPCIe5112CoreOO::PFI2 , JYPCIe5112CoreOO::PFI3 ,
JYPCIe5112CoreOO::PFI4 , JYPCIe5112CoreOO::PFI5 , JYPCIe5112CoreOO::PFI6 , JYPCIe5112CoreOO::PFI7 ,
JYPCIe5112CoreOO::PFI8 , JYPCIe5112CoreOO::PFI9 , JYPCIe5112CoreOO::PFI10 , JYPCIe5112CoreOO::PFI11 ,
JYPCIe5112CoreOO::PFI12 , JYPCIe5112CoreOO::PFI13 , JYPCIe5112CoreOO::PFI14 , JYPCIe5112CoreOO::PFI15 ,
JYPCIe5112CoreOO::PXI_Trig0 = 16 , JYPCIe5112CoreOO::PXI_Trig1 = 17 , JYPCIe5112CoreOO::PXI_Trig2 = 18 , JYPCIe5112CoreOO::PXI_Trig3 = 19 ,
JYPCIe5112CoreOO::PXI_Trig4 = 20 , JYPCIe5112CoreOO::PXI_Trig5 = 21 , JYPCIe5112CoreOO::PXI_Trig6 = 22 , JYPCIe5112CoreOO::PXI_Trig7 = 23 ,
JYPCIe5112CoreOO::AI_StartTrig = 24 , JYPCIe5112CoreOO::AI_ReferenceTrig = 25 , JYPCIe5112CoreOO::AO_StartTrig = 26 , JYPCIe5112CoreOO::CIO_0_StartTrig = 27 ,
JYPCIe5112CoreOO::CIO_1_StartTrig = 28 , JYPCIe5112CoreOO::CO0_Output = 29 , JYPCIe5112CoreOO::CO1_Output = 30
}
CO Digital trigger source. More...
enum class | JYPCIe5112CoreOO::CODigitalTriggerEdge { JYPCIe5112CoreOO::Rising , JYPCIe5112CoreOO::Falling }
CO Digital Trigger Edge. More...
enum class | JYPCIe5112CoreOO::COPulseType { JYPCIe5112CoreOO::DutyCycleFrequency , JYPCIe5112CoreOO::HighLowTime , JYPCIe5112CoreOO::HighLowTick }
Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick. More...
enum class | JYPCIe5112CoreOO::COTimebaseSource { JYPCIe5112CoreOO::Internal200MHz }
Timebase source. More...
enum class | JYPCIe5112CoreOO::COSignalExportSource { JYPCIe5112CoreOO::StartTrig , JYPCIe5112CoreOO::Output }
SourceSignal. More...


5112 C++ Programming Manual: JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask Class Reference

  • JYPCIe5112CoreOOCOTask
Public Member Functions | Public Attributes | List of all members
JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask Class Reference

#include <JYPCIe5112CoreOOCOTask.h>

Public Member Functions

JYPCIe5112CoreOOCOTask (int slotNum, int channel)
JYPCIe5112CoreOOCOTask (std::string boardName, int channel)
void | WriteSinglePoint (COPulse &pulse)
Write a single pulse parameter to the register.
void | WriteData (COPulse *pulsesGroup[], int samplesToWrite, int timeout=10000)
Write pulse parameters to be output to the buffer.
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Start ()
Start CO task .
void | Stop ()
Stop COtask .
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.

Public Attributes

COMode Mode
CO output mode.
IOTerminal OutputTerminal
PauseTrigger * Pause
COTimebase * TimeBase
CO's time base.
double | InitialDelay
Counter output initial delay in seconds.
COIdleState IdleState
Idle state when pulse output before start and after stop.
uint32_t | SamplesToUpdate
有限频率输出
COTrigger * Trigger
CO trigger property configured by CO Trigger().
JYPCIe5112CoreOODevice * Device
Device.
COSignalExport * SignalExport
Export CO Signal Configuration.

Constructor & Destructor Documentation

◆ JYPCIe5112CoreOOCOTask() [1/2]

JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask::JYPCIe5112CoreOOCOTask | ( | int | slotNum,
 |  | int | channel )

◆ JYPCIe5112CoreOOCOTask() [2/2]

JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask::JYPCIe5112CoreOOCOTask | ( | std::string | boardName,
 |  | int | channel )

Member Function Documentation

◆ SendSoftwareTrigger()

void JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask::SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask::Start ( )

Start CO task .

◆ Stop()

void JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask::Stop ( )

Stop COtask .

◆ WaitUntilDone()

bool JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask::WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteData()

void JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask::WriteData | ( | COPulse * | pulsesGroup[],
 |  | int | samplesToWrite,
 |  | int | timeout = 10000 )

Write pulse parameters to be output to the buffer.

Valid when Mode is NOT COMode.Single. When Mode is COMode.Finite or COMode.ContinuousWrapping, this function can only be called once before starting the task.

Parameters
pulsesGroup | A group of pulse parameters
samplesToWrite | Number of samples to write. If Mode is COMode.ContinuousWrapping, you need to write at least 2 samples before starting the task
timeout | Timeout (ms). Wait until all data is written to buffer or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ WriteSinglePoint()

void JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask::WriteSinglePoint ( COPulse & pulse )

Write a single pulse parameter to the register.

Valid when Mode is COMode.Single. This function is also available after starting the task when the number of pulses being sent is infinite.

Parameters
pulse Pulse Parameter

Member Data Documentation

◆ Device

JYPCIe5112CoreOODevice* JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask::Device

Device.

◆ IdleState

COIdleState JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask::IdleState

Idle state when pulse output before start and after stop.

◆ InitialDelay

double JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask::InitialDelay

Counter output initial delay in seconds.

There are five ticks of the timebase fixed delay in counter internal, so the total delay(s) = InitialDelay + (5 / timebase)

◆ Mode

COMode JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask::Mode

CO output mode.

◆ OutputTerminal

IOTerminal JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask::OutputTerminal

脉冲输出端口

Pulse Output Terminal

◆ Pause

PauseTrigger* JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask::Pause

暂停触发配置

Pause Trigger Configuration

◆ SamplesToUpdate

uint32_t JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask::SamplesToUpdate

有限频率输出

◆ SignalExport

COSignalExport* JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask::SignalExport

Export CO Signal Configuration.

◆ TimeBase

COTimebase* JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask::TimeBase

CO's time base.

◆ Trigger

COTrigger* JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask::Trigger

CO trigger property configured by CO Trigger().

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOCOTask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::CODigitalTrigger Class Reference

  • CODigitalTrigger
Public Attributes | List of all members
JYPCIe5112CoreOO::CODigitalTrigger Class Reference

CO Digital trigger . More...

#include <JYPCIe5112CoreOOCOTask.h>

Public Attributes

CODigitalTriggerSource Source
CO Digital Trigger source.
CODigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Detailed Description

CO Digital trigger .

Member Data Documentation

◆ Edge

CODigitalTriggerEdge JYPCIe5112CoreOO::CODigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

CODigitalTriggerSource JYPCIe5112CoreOO::CODigitalTrigger::Source

CO Digital Trigger source.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOCOTask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::COTrigger Class Reference

  • COTrigger
Public Attributes | List of all members
JYPCIe5112CoreOO::COTrigger Class Reference

Constructor to create an COTrigger task object. More...

#include <JYPCIe5112CoreOOCOTask.h>

Public Attributes

COTriggerType Type
CO trigger type.
CODigitalTrigger * Digital
CO Digital Trigger.

Detailed Description

Constructor to create an COTrigger task object.

Used to build CO Trigger

Member Data Documentation

◆ Digital

CODigitalTrigger* JYPCIe5112CoreOO::COTrigger::Digital

CO Digital Trigger.

Valid when Type is COTriggerType.Digital

◆ Type

COTriggerType JYPCIe5112CoreOO::COTrigger::Type

CO trigger type.

enum Immediate/Digital/Soft.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOCOTask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::COPulse Class Reference

  • COPulse
Public Member Functions | List of all members
JYPCIe5112CoreOO::COPulse Class Reference

Pulse Parameter. More...

#include <JYPCIe5112CoreOOCOTask.h>

Public Member Functions

COPulse (COPulseType type, double param1, double param2, int count)
Pulse Parameter.

Detailed Description

Pulse Parameter.

Constructor & Destructor Documentation

◆ COPulse()

JYPCIe5112CoreOO::COPulse::COPulse | ( | COPulseType | type,
 |  | double | param1,
 |  | double | param2,
 |  | int | count )

Pulse Parameter.

Parameters
type | The pulse type characteristics.
param1 | Parameter 1. Frequency (Hz) when constructed as COPulseType.DutyCycleFrequency; High duration in seconds when constructed as COPulseType.HighLowTime; High ticks of the clock when constructed as COPulseType.HighLowTick.
param2 | Parameter 1. Duty cycle (greater than 0 and less than 1) when constructed as COPulseType.DutyCycleFrequency; Low duration in seconds when constructed as COPulseType.HighLowTime; Low ticks of the clock when constructed as COPulseType.HighLowTick.
count | Number of pulses. When the value is -1 (indicating that the number of pulses is infinite), pulses will be continuously sent until requested to stop.
The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOCOTask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::COTimebase Class Reference

  • COTimebase
Public Attributes | List of all members
JYPCIe5112CoreOO::COTimebase Class Reference

Timebase configuration class. More...

#include <JYPCIe5112CoreOOCOTask.h>

Public Attributes

COTimebaseSource Source
Timebase Source.

Detailed Description

Timebase configuration class.

Member Data Documentation

◆ Source

COTimebaseSource JYPCIe5112CoreOO::COTimebase::Source

Timebase Source.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOCOTask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::COSignalExport Class Reference

  • COSignalExport
Public Member Functions | List of all members
JYPCIe5112CoreOO::COSignalExport Class Reference

CO Signal Export Class. More...

#include <JYPCIe5112CoreOOCOTask.h>

Public Member Functions

void | Add (COSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (COSignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

CO Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JYPCIe5112CoreOO::COSignalExport::Add | ( | COSignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | CI Signal Source
destination | Export Desination

◆ Add() [2/2]

void JYPCIe5112CoreOO::COSignalExport::Add | ( | COSignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | CI Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JYPCIe5112CoreOO::COSignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JYPCIe5112CoreOO::COSignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOCOTask.h


5112 C++ Programming Manual: COO/5112/JYPCIe5112CoreOODevice.h File Reference

  • File List
  • File Members
  • COO
  • 5112
Classes | Namespaces | Enumerations
JYPCIe5112CoreOODevice.h File Reference
#include <iostream>
#include <string>
#include <list>
#include <vector>
#include "JYPCIe5112CoreOOCommon.h"

Classes

class | JYPCIe5112CoreOO::JYPCIe5112CoreOODevice
class | JYPCIe5112CoreOO::PFIFilter
class | JYPCIe5112CoreOO::PFISetting
class | JYPCIe5112CoreOO::ExternalReferenceClock
class | JYPCIe5112CoreOO::JYPCIe5112CoreOOReferenceClock

Namespaces

namespace JYPCIe5112CoreOO

Enumerations

enum class | JYPCIe5112CoreOO::ExternalReferenceClockTerminal { JYPCIe5112CoreOO::PXIe_Clk100 = 0x1 }
enum class | JYPCIe5112CoreOO::ReferenceClockSource { JYPCIe5112CoreOO::Internal = 0x0 , JYPCIe5112CoreOO::External = 0x1 }
enum class JYPCIe5112CoreOO::PFITerminal {
JYPCIe5112CoreOO::PFI0 = 0 , JYPCIe5112CoreOO::PFI1 = 1 , JYPCIe5112CoreOO::PFI2 = 2 , JYPCIe5112CoreOO::PFI3 = 3 ,
JYPCIe5112CoreOO::PFI4 = 4 , JYPCIe5112CoreOO::PFI5 = 5 , JYPCIe5112CoreOO::PFI6 = 6 , JYPCIe5112CoreOO::PFI7 = 7 ,
JYPCIe5112CoreOO::PFI8 = 8 , JYPCIe5112CoreOO::PFI9 = 9 , JYPCIe5112CoreOO::PFI10 = 10 , JYPCIe5112CoreOO::PFI11 = 11 ,
JYPCIe5112CoreOO::PFI12 = 12 , JYPCIe5112CoreOO::PFI13 = 13 , JYPCIe5112CoreOO::PFI14 = 14 , JYPCIe5112CoreOO::PFI15 = 15
}
Input/Output Terminal of PFI. More...


5112 C++ Programming Manual: JYPCIe5112CoreOO::JYPCIe5112CoreOODevice Class Reference

  • JYPCIe5112CoreOODevice
Static Public Member Functions | Public Attributes | List of all members
JYPCIe5112CoreOO::JYPCIe5112CoreOODevice Class Reference

#include <JYPCIe5112CoreOODevice.h>

Static Public Member Functions

static JYPCIe5112CoreOODevice * | GetInstance (int cardNum)
static JYPCIe5112CoreOODevice * | GetInstance (std::string aliasName)

Public Attributes

const double | BoardClockRate = 10e7
const double | MaxUpdateRateSingleChannel = 2860000
AOMaxUpdateRateSingleChannel.
const double | MaxSampleRateMutilChannel = 250E3
const int | AIBufferSize = 0x100000 * 64
const bool | IsAISync = false
const double | MaxUpdateRate = 2860000
const int | LineCountPerPort = 2
DIOLineCountPerPort.
const bool | IsAOSync = false
IsAOSync.
JYPCIe5112CoreOOProperty< JYPCIe5112CoreOODevice, int, JYPCIe5112CoreOOPropertyType::READ_ONLY > | DiffChannelCount
JYPCIe5112CoreOOProperty< JYPCIe5112CoreOODevice, int, JYPCIe5112CoreOOPropertyType::READ_ONLY > | SEChannelCount
JYPCIe5112CoreOOProperty< JYPCIe5112CoreOODevice, double, JYPCIe5112CoreOOPropertyType::READ_ONLY > | MaxSampleRateSingleChannel
JYPCIe5112CoreOOProperty< JYPCIe5112CoreOODevice, int, JYPCIe5112CoreOOPropertyType::READ_ONLY > | AOChannelCount
JYPCIe5112CoreOOProperty< JYPCIe5112CoreOODevice, std::string, JYPCIe5112CoreOOPropertyType::READ_ONLY > | SerialNumber
JYPCIe5112CoreOOProperty< JYPCIe5112CoreOODevice, int, JYPCIe5112CoreOOPropertyType::READ_ONLY > | DeviceID
JYPCIe5112CoreOOProperty< JYPCIe5112CoreOODevice, void *, JYPCIe5112CoreOOPropertyType::READ_ONLY > | Handle
PFISetting * PFI
JYPCIe5112CoreOOReferenceClock * ReferenceClock

Member Function Documentation

◆ GetInstance() [1/2]

static JYPCIe5112CoreOODevice * JYPCIe5112CoreOO::JYPCIe5112CoreOODevice::GetInstance ( int cardNum )
static

◆ GetInstance() [2/2]

static JYPCIe5112CoreOODevice * JYPCIe5112CoreOO::JYPCIe5112CoreOODevice::GetInstance ( std::string aliasName )
static

Member Data Documentation

◆ AIBufferSize

const int JYPCIe5112CoreOO::JYPCIe5112CoreOODevice::AIBufferSize = 0x100000 * 64

◆ AOChannelCount

JYPCIe5112CoreOOProperty<JYPCIe5112CoreOODevice, int, JYPCIe5112CoreOOPropertyType::READ_ONLY> JYPCIe5112CoreOO::JYPCIe5112CoreOODevice::AOChannelCount

◆ BoardClockRate

const double JYPCIe5112CoreOO::JYPCIe5112CoreOODevice::BoardClockRate = 10e7

◆ DeviceID

JYPCIe5112CoreOOProperty<JYPCIe5112CoreOODevice, int, JYPCIe5112CoreOOPropertyType::READ_ONLY> JYPCIe5112CoreOO::JYPCIe5112CoreOODevice::DeviceID

◆ DiffChannelCount

JYPCIe5112CoreOOProperty<JYPCIe5112CoreOODevice, int, JYPCIe5112CoreOOPropertyType::READ_ONLY> JYPCIe5112CoreOO::JYPCIe5112CoreOODevice::DiffChannelCount

◆ Handle

JYPCIe5112CoreOOProperty<JYPCIe5112CoreOODevice, void*, JYPCIe5112CoreOOPropertyType::READ_ONLY> JYPCIe5112CoreOO::JYPCIe5112CoreOODevice::Handle

◆ IsAISync

const bool JYPCIe5112CoreOO::JYPCIe5112CoreOODevice::IsAISync = false

◆ IsAOSync

const bool JYPCIe5112CoreOO::JYPCIe5112CoreOODevice::IsAOSync = false

IsAOSync.

◆ LineCountPerPort

const int JYPCIe5112CoreOO::JYPCIe5112CoreOODevice::LineCountPerPort = 2

DIOLineCountPerPort.

◆ MaxSampleRateMutilChannel

const double JYPCIe5112CoreOO::JYPCIe5112CoreOODevice::MaxSampleRateMutilChannel = 250E3

◆ MaxSampleRateSingleChannel

JYPCIe5112CoreOOProperty<JYPCIe5112CoreOODevice, double, JYPCIe5112CoreOOPropertyType::READ_ONLY> JYPCIe5112CoreOO::JYPCIe5112CoreOODevice::MaxSampleRateSingleChannel

◆ MaxUpdateRate

const double JYPCIe5112CoreOO::JYPCIe5112CoreOODevice::MaxUpdateRate = 2860000

◆ MaxUpdateRateSingleChannel

const double JYPCIe5112CoreOO::JYPCIe5112CoreOODevice::MaxUpdateRateSingleChannel = 2860000

AOMaxUpdateRateSingleChannel.

◆ PFI

PFISetting* JYPCIe5112CoreOO::JYPCIe5112CoreOODevice::PFI

◆ ReferenceClock

JYPCIe5112CoreOOReferenceClock* JYPCIe5112CoreOO::JYPCIe5112CoreOODevice::ReferenceClock

◆ SEChannelCount

JYPCIe5112CoreOOProperty<JYPCIe5112CoreOODevice, int, JYPCIe5112CoreOOPropertyType::READ_ONLY> JYPCIe5112CoreOO::JYPCIe5112CoreOODevice::SEChannelCount

◆ SerialNumber

JYPCIe5112CoreOOProperty<JYPCIe5112CoreOODevice, std::string, JYPCIe5112CoreOOPropertyType::READ_ONLY> JYPCIe5112CoreOO::JYPCIe5112CoreOODevice::SerialNumber
The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOODevice.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::PFIFilter Class Reference

  • PFIFilter
Public Member Functions | List of all members
JYPCIe5112CoreOO::PFIFilter Class Reference

#include <JYPCIe5112CoreOODevice.h>

Public Member Functions

void | Enable (PFITerminal terminal, int minPulseWidth)
Enable the filter on the specified terminal and set the minimum pulse width.
void | Enable (std::vector< PFITerminal > terminals, int minPulseWidth)
Enable the filter on a group of terminals and set the minimum pulse width.
void | Enable (std::vector< PFITerminal > terminals, std::vector< int > minPulseWidth)
Enable the filter on a group of terminals and set the minimum pulse width separately.
void | Disable (PFITerminal terminal)
Disable the filter on the specified terminal.
void | Disable (std::vector< PFITerminal > terminals)
Disable the filter on a group terminal.
void | DisableAll ()
Disable the filter on all the terminals.

Member Function Documentation

◆ Disable() [1/2]

void JYPCIe5112CoreOO::PFIFilter::Disable ( PFITerminal terminal )

Disable the filter on the specified terminal.

Parameters
terminal Specified Terminal

◆ Disable() [2/2]

void JYPCIe5112CoreOO::PFIFilter::Disable ( std::vector< PFITerminal > terminals )

Disable the filter on a group terminal.

Parameters
terminals Specified Group of Terminal

◆ DisableAll()

void JYPCIe5112CoreOO::PFIFilter::DisableAll ( )

Disable the filter on all the terminals.

◆ Enable() [1/3]

void JYPCIe5112CoreOO::PFIFilter::Enable | ( | PFITerminal | terminal,
 |  | int | minPulseWidth )

Enable the filter on the specified terminal and set the minimum pulse width.

Parameters
terminal | Specified Terminal
minPulseWidth | Minimum pulse width in ns, bounce less than this length will be ignored. The smallest step in the range of 10 ns to 2550 ns is 10 ns, the smallest step in the range of 2550 ns to 40800 ns is 160 ns, and the smallest step in the range of 40800 ns to 652800 ns The step is 2560 ns

◆ Enable() [2/3]

void JYPCIe5112CoreOO::PFIFilter::Enable | ( | std::vector< PFITerminal > | terminals,
 |  | int | minPulseWidth )

Enable the filter on a group of terminals and set the minimum pulse width.

Parameters
terminals | Specified Group of Terminals
minPulseWidth | Minimum pulse width in ns, bounce less than this length will be ignored. The smallest step in the range of 10 ns to 2550 ns is 10 ns, the smallest step in the range of 2550 ns to 40800 ns is 160 ns, and the smallest step in the range of 40800 ns to 652800 ns The step is 2560 ns

◆ Enable() [3/3]

void JYPCIe5112CoreOO::PFIFilter::Enable | ( | std::vector< PFITerminal > | terminals,
 |  | std::vector< int > | minPulseWidth )

Enable the filter on a group of terminals and set the minimum pulse width separately.

Parameters
terminals | Specified Group of Terminals
minPulseWidth | Minimum pulse width in ns, bounce less than this length will be ignored. The smallest step in the range of 10 ns to 2550 ns is 10 ns, the smallest step in the range of 2550 ns to 40800 ns is 160 ns, and the smallest step in the range of 40800 ns to 652800 ns The step is 2560 ns
The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOODevice.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::PFISetting Class Reference

  • PFISetting
Public Attributes | List of all members
JYPCIe5112CoreOO::PFISetting Class Reference

#include <JYPCIe5112CoreOODevice.h>

Public Attributes

PFIFilter * Filter
PFI Filter Setting.

Member Data Documentation

◆ Filter

PFIFilter* JYPCIe5112CoreOO::PFISetting::Filter

PFI Filter Setting.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOODevice.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::ExternalReferenceClock Class Reference

  • ExternalReferenceClock
Public Attributes | List of all members
JYPCIe5112CoreOO::ExternalReferenceClock Class Reference

#include <JYPCIe5112CoreOODevice.h>

Public Attributes

ExternalReferenceClockTerminal Terminal

Member Data Documentation

◆ Terminal

ExternalReferenceClockTerminal JYPCIe5112CoreOO::ExternalReferenceClock::Terminal
The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOODevice.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::JYPCIe5112CoreOOReferenceClock Class Reference

  • JYPCIe5112CoreOOReferenceClock
Public Member Functions | Public Attributes | List of all members
JYPCIe5112CoreOO::JYPCIe5112CoreOOReferenceClock Class Reference

#include <JYPCIe5112CoreOODevice.h>

Public Member Functions

void Commit ()
Commit configuration.

Public Attributes

ReferenceClockSource Source
ExternalReferenceClock * External
External Reference Clock Source.

Member Function Documentation

◆ Commit()

void JYPCIe5112CoreOO::JYPCIe5112CoreOOReferenceClock::Commit ( )

Commit configuration.

Available only when the device is idle. WARNING: Incorrect parameters will cause the PLL to be unable to lock the reference clock and cannot be recovered until shutdown and restart.

Member Data Documentation

◆ External

ExternalReferenceClock* JYPCIe5112CoreOO::JYPCIe5112CoreOOReferenceClock::External

External Reference Clock Source.

Required when ReferenceClock.Source is ReferenceClockSource.External

◆ Source

ReferenceClockSource JYPCIe5112CoreOO::JYPCIe5112CoreOOReferenceClock::Source
The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOODevice.h


5112 C++ Programming Manual: COO/5112/JYPCIe5112CoreOODITask.h File Reference

  • File List
  • File Members
  • COO
  • 5112
Classes | Namespaces
JYPCIe5112CoreOODITask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JYPCIe5112CoreOOCommon.h"
#include "JYPCIe5112CoreOODevice.h"

Classes

class | JYPCIe5112CoreOO::JYPCIe5112CoreOODITask
class | JYPCIe5112CoreOO::DIChannel
DI Channel parameter class . More...

Namespaces

namespace JYPCIe5112CoreOO


5112 C++ Programming Manual: JYPCIe5112CoreOO::JYPCIe5112CoreOODITask Class Reference

  • JYPCIe5112CoreOODITask
Public Member Functions | Public Attributes | List of all members
JYPCIe5112CoreOO::JYPCIe5112CoreOODITask Class Reference

#include <JYPCIe5112CoreOODITask.h>

Public Member Functions

JYPCIe5112CoreOODITask (int slotNum)
JYPCIe5112CoreOODITask (std::string boardName)
~JYPCIe5112CoreOODITask ()
void | AddChannel (int portNum)
Add one channel.
void | AddChannel (std::vector< int > portsNum)
Add a group of channel.
void | RemoveChannel (int portNum)
Delete the specified port number .If it is -1, delete all ports.
void | Start ()
Start DI task .
void | Stop ()
Stop DI task .
void | ReadSinglePoint (std::vector< bool > &readValues, int port)
Read one sample for specified channel in register.
void | ReadSinglePoint (std::vector< int > &readValues)
Read one sample for all ports in register .
void | ReadSinglePoint (bool *readValues)
Read one sample for all ports in register .
void | ReadSinglePoint (std::vector< bool > &readValues)
Read one sample for all ports in register .

Public Attributes

std::list< DIChannel * > Channels
List of DI channels,(5112 support 3 ports)
JYPCIe5112CoreOODevice * Device
Device.

Constructor & Destructor Documentation

◆ JYPCIe5112CoreOODITask() [1/2]

JYPCIe5112CoreOO::JYPCIe5112CoreOODITask::JYPCIe5112CoreOODITask ( int slotNum )

◆ JYPCIe5112CoreOODITask() [2/2]

JYPCIe5112CoreOO::JYPCIe5112CoreOODITask::JYPCIe5112CoreOODITask ( std::string boardName )

◆ ~JYPCIe5112CoreOODITask()

JYPCIe5112CoreOO::JYPCIe5112CoreOODITask::~JYPCIe5112CoreOODITask ( )

Member Function Documentation

◆ AddChannel() [1/2]

void JYPCIe5112CoreOO::JYPCIe5112CoreOODITask::AddChannel ( int portNum )

Add one channel.

Parameters
portNum port number to be added.

◆ AddChannel() [2/2]

void JYPCIe5112CoreOO::JYPCIe5112CoreOODITask::AddChannel ( std::vector< int > portsNum )

Add a group of channel.

Parameters
portsNum an array of port numbers of added ports.

◆ ReadSinglePoint() [1/4]

void JYPCIe5112CoreOO::JYPCIe5112CoreOODITask::ReadSinglePoint ( bool * readValues )

Read one sample for all ports in register .

Available when Mode is DIMode.Single

Parameters
readValues Values read. Buffer size >= number of ports * 8.

◆ ReadSinglePoint() [2/4]

void JYPCIe5112CoreOO::JYPCIe5112CoreOODITask::ReadSinglePoint ( std::vector< bool > & readValues )

Read one sample for all ports in register .

Available when Mode is DIMode.Single

Parameters
readValues Values read. Buffer size >= number of ports * 8.

◆ ReadSinglePoint() [3/4]

void JYPCIe5112CoreOO::JYPCIe5112CoreOODITask::ReadSinglePoint | ( | std::vector< bool > & | readValues,
 |  | int | port )

Read one sample for specified channel in register.

. Available when Mode is DIMode.Single

Parameters
readValues | values read,. Buffer size >= 8
port | Specified port numbers.

◆ ReadSinglePoint() [4/4]

void JYPCIe5112CoreOO::JYPCIe5112CoreOODITask::ReadSinglePoint ( std::vector< int > & readValues )

Read one sample for all ports in register .

Available when Mode is DIMode.Single

Parameters
readValues Values read. Buffer size >= number of ports * 8.

◆ RemoveChannel()

void JYPCIe5112CoreOO::JYPCIe5112CoreOODITask::RemoveChannel ( int portNum )

Delete the specified port number .If it is -1, delete all ports.

Parameters
portNum port number to be delete.

◆ Start()

void JYPCIe5112CoreOO::JYPCIe5112CoreOODITask::Start ( )

Start DI task .

◆ Stop()

void JYPCIe5112CoreOO::JYPCIe5112CoreOODITask::Stop ( )

Stop DI task .

Member Data Documentation

◆ Channels

std::list<DIChannel*> JYPCIe5112CoreOO::JYPCIe5112CoreOODITask::Channels

List of DI channels,(5112 support 3 ports)

◆ Device

JYPCIe5112CoreOODevice* JYPCIe5112CoreOO::JYPCIe5112CoreOODITask::Device

Device.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOODITask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::DIChannel Class Reference

  • DIChannel
Public Attributes | List of all members
JYPCIe5112CoreOO::DIChannel Class Reference

DI Channel parameter class . More...

#include <JYPCIe5112CoreOODITask.h>

Public Attributes

int PortNum
port number.

Detailed Description

DI Channel parameter class .

Member Data Documentation

◆ PortNum

int JYPCIe5112CoreOO::DIChannel::PortNum

port number.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOODITask.h


5112 C++ Programming Manual: COO/5112/JYPCIe5112CoreOODOTask.h File Reference

  • File List
  • File Members
  • COO
  • 5112
Classes | Namespaces
JYPCIe5112CoreOODOTask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JYPCIe5112CoreOOCommon.h"
#include "JYPCIe5112CoreOODevice.h"

Classes

class | JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask
class | JYPCIe5112CoreOO::DOChannel
DO Channel parameter class . More...

Namespaces

namespace JYPCIe5112CoreOO


5112 C++ Programming Manual: JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask Class Reference

  • JYPCIe5112CoreOODOTask
Public Member Functions | Public Attributes | List of all members
JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask Class Reference

#include <JYPCIe5112CoreOODOTask.h>

Public Member Functions

JYPCIe5112CoreOODOTask (int slotNum)
JYPCIe5112CoreOODOTask (std::string boardName)
~JYPCIe5112CoreOODOTask ()
void | AddChannel (int portNum)
Add one channel.
void | AddChannel (std::vector< int > portsNum)
Add a group of channel.
void | RemoveChannel (int portNum)
Delete the specified port number .If it is -1, delete all ports.
void | Start ()
Start DO task .
void | Stop ()
Stop DO task .
void | WriteSinglePoint (std::vector< bool > &writeValues, int port)
Write one sample to the specified port in register.Available when Mode is DOMode.Single
void | WriteSinglePoint (std::vector< bool > &writeValues)
Read one sample for all ports in register .

Public Attributes

std::list< DOChannel * > Channels
List of DO channels, (5512 support 3 ports)
JYPCIe5112CoreOODevice * Device
Device.

Constructor & Destructor Documentation

◆ JYPCIe5112CoreOODOTask() [1/2]

JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask::JYPCIe5112CoreOODOTask ( int slotNum )

◆ JYPCIe5112CoreOODOTask() [2/2]

JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask::JYPCIe5112CoreOODOTask ( std::string boardName )

◆ ~JYPCIe5112CoreOODOTask()

JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask::~JYPCIe5112CoreOODOTask ( )

Member Function Documentation

◆ AddChannel() [1/2]

void JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask::AddChannel ( int portNum )

Add one channel.

Parameters
portNum port number to be added.

◆ AddChannel() [2/2]

void JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask::AddChannel ( std::vector< int > portsNum )

Add a group of channel.

Parameters
portsNum an array of port numbers of added ports.

◆ RemoveChannel()

void JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask::RemoveChannel ( int portNum )

Delete the specified port number .If it is -1, delete all ports.

Parameters
portNum port number to be delete.

◆ Start()

void JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask::Start ( )

Start DO task .

◆ Stop()

void JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask::Stop ( )

Stop DO task .

◆ WriteSinglePoint() [1/2]

void JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask::WriteSinglePoint ( std::vector< bool > & writeValues )

Read one sample for all ports in register .

Available when Mode is DIMode.Single

Parameters
readValues Values read. Buffer size >= number of ports * 8.

◆ WriteSinglePoint() [2/2]

void JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask::WriteSinglePoint | ( | std::vector< bool > & | writeValues,
 |  | int | port )

Write one sample to the specified port in register.Available when Mode is DOMode.Single

Parameters
writeValues | values read,. Buffer size >= 8
port | Specified port numbers.

Member Data Documentation

◆ Channels

std::list<DOChannel*> JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask::Channels

List of DO channels, (5512 support 3 ports)

◆ Device

JYPCIe5112CoreOODevice* JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask::Device

Device.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOODOTask.h


5112 C++ Programming Manual: JYPCIe5112CoreOO::DOChannel Class Reference

  • DOChannel
Public Attributes | List of all members
JYPCIe5112CoreOO::DOChannel Class Reference

DO Channel parameter class . More...

#include <JYPCIe5112CoreOODOTask.h>

Public Attributes

int PortNum
port number.

Detailed Description

DO Channel parameter class .

Member Data Documentation

◆ PortNum

int JYPCIe5112CoreOO::DOChannel::PortNum

port number.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOODOTask.h


5112 C++ Programming Manual: COO/5112/JYPCIe5112CoreOOLog.h File Reference

  • File List
  • File Members
  • COO
  • 5112
Classes | Namespaces | Enumerations
JYPCIe5112CoreOOLog.h File Reference
#include <queue>
#include <string>
#include <thread>
#include "JYPCIe5112CoreOOCommon.h"

Classes

class JYPCIe5112CoreOO::JYPCIe5112CoreOOLog

Namespaces

namespace JYPCIe5112CoreOO

Enumerations

enum class JYPCIe5112CoreOO::JYPCIe5112CoreOOLogLevel {
JYPCIe5112CoreOO::DEBUG_LOG_LEVEL , JYPCIe5112CoreOO::INFO_LOG_LEVEL , JYPCIe5112CoreOO::WARN_LOG_LEVEL , JYPCIe5112CoreOO::ERROR_LOG_LEVEL ,
JYPCIe5112CoreOO::FATAL_LOG_LEVEL
}


5112 C++ Programming Manual: JYPCIe5112CoreOO::JYPCIe5112CoreOOLog Class Reference

  • JYPCIe5112CoreOOLog
Static Public Member Functions | Static Public Attributes | List of all members
JYPCIe5112CoreOO::JYPCIe5112CoreOOLog Class Reference

#include <JYPCIe5112CoreOOLog.h>

Static Public Member Functions

static void | Print (const char *format,...)
static void | Print (JYPCIe5112CoreOOLogLevel logLevel, const char *format,...)
static void | Flush ()

Static Public Attributes

static JYPCIe5112CoreOOLogLevel | LogLevel
static JYPCIe5112CoreOOProperty< JYPCIe5112CoreOOLog, bool, JYPCIe5112CoreOOPropertyType::READ_WRITE > | EnableLog

Member Function Documentation

◆ Flush()

static void JYPCIe5112CoreOO::JYPCIe5112CoreOOLog::Flush ( )
static

◆ Print() [1/2]

static void JYPCIe5112CoreOO::JYPCIe5112CoreOOLog::Print | ( | const char * | format,
 |  |  | ... )
 static

◆ Print() [2/2]

static void JYPCIe5112CoreOO::JYPCIe5112CoreOOLog::Print | ( | JYPCIe5112CoreOOLogLevel | logLevel,
 |  | const char * | format,
 |  |  | ... )
 static

Member Data Documentation

◆ EnableLog

JYPCIe5112CoreOOProperty<JYPCIe5112CoreOOLog, bool, JYPCIe5112CoreOOPropertyType::READ_WRITE> JYPCIe5112CoreOO::JYPCIe5112CoreOOLog::EnableLog
static

◆ LogLevel

JYPCIe5112CoreOOLogLevel JYPCIe5112CoreOO::JYPCIe5112CoreOOLog::LogLevel
static
The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOLog.h


5112 C++ Programming Manual: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
▼N JYPCIe5112CoreOO |
C AIAdvanced | AI Advance parameter
C AIAnalogEdgeComparator | AI Analog Edge Comparator
C AIAnalogHysteresisComparator | AI Analog Hysteresis Comparatorr
C AIAnalogTrigger | AI analog trigger
C AIAnalogWindowComparator | AI Analog Window Comparatorr
C AIChannel | AI Channel parameter class
C AIDigitalTrigger | AI Digital trigger class
C AIDSMode |
C AIExternalSampleClock | Sample clock configuration class
C AIRecord | AI Record Parameters
C AISampleClock | Sample clock configuration class
C AISignalExport | AI Signal Export Class
C AITrigger | Constructor to create an AITrigger task object
C AOChannel |
C AODigitalTrigger | AO Digital trigger
C AOExternalSampleClock | External Sample Clock Configuration Class
C AOSampleClock | AO Sample clock configuration class
C AOSignalExport | AO Signal Export Class
C AOTrigger | Constructor to create an AOTrigger task object
C CIDigitalTrigger | CI Digital trigger
C CIExternalSampleClock | CI Implicit Sample Clock class
C CIExternalTimebase |
C CIImplicitSampleClock | CI Implicit Sample Clock class
C CIInternalSampleClock | CI Internal Sample Clock Configuration Class
C CISampleClock | CI Sample Clock class
C CISignalExport | CI Signal Export Class
C CITimebase | Timebase configuration class
C CITrigger | Constructor to create an CITrigger task object
C CODigitalTrigger | CO Digital trigger
C COPulse | Pulse Parameter
C COSignalExport | CO Signal Export Class
C COTimebase | Timebase configuration class
C COTrigger | Constructor to create an COTrigger task object
C DIChannel | DI Channel parameter class
C DOChannel | DO Channel parameter class
C EdgeCounting | Configure CI EdgeCounting
C EdgeCountingOutEvent | Edge counting output event configuration class
C ExternalReferenceClock |
C FrequencyMeas | Configure CI Measure
C JYDriverException |
C JYPCIe5112CoreOOAITask | AITask类
C JYPCIe5112CoreOOAOTask |
C JYPCIe5112CoreOOCITask |
C JYPCIe5112CoreOOCOTask |
C JYPCIe5112CoreOODevice |
C JYPCIe5112CoreOODITask |
C JYPCIe5112CoreOODOTask |
C JYPCIe5112CoreOOLog |
C JYPCIe5112CoreOOProperty | 属性模板类
C JYPCIe5112CoreOOReferenceClock |
C PauseTrigger | Pause trigger configuration class
C PeriodMeas | Configure CI Measure
C PFIFilter |
C PFISetting |
C PulseMeas | Configure CI Measure
C QuadEncoder | Configure CI Measure
C SemiPeriodMeas | Configure CI SemiPeriodMeas
C TwoEdgeSeparation | Configure CI Measure
C TwoPulseEncoder | Configure CI Measure
C AOMode | AIMode
C JYPCIe5112CoreOOAIMode | AIMode


5112 C++ Programming Manual: AOMode Class Reference

AOMode Class Reference

AIMode. More...

#include <JYPCIe5112CoreOOAOTask.h>

Detailed Description

AIMode.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOAOTask.h


5112 C++ Programming Manual: Member List

  • AIAdvanced
JYPCIe5112CoreOO::AIAdvanced Member List

This is the complete list of members for JYPCIe5112CoreOO::AIAdvanced, including all inherited members.

ConvertRate | JYPCIe5112CoreOO::AIAdvanced
DSMode | JYPCIe5112CoreOO::AIAdvanced


5112 C++ Programming Manual: Member List

  • AIAnalogEdgeComparator
JYPCIe5112CoreOO::AIAnalogEdgeComparator Member List

This is the complete list of members for JYPCIe5112CoreOO::AIAnalogEdgeComparator, including all inherited members.

Slope | JYPCIe5112CoreOO::AIAnalogEdgeComparator
Threshold | JYPCIe5112CoreOO::AIAnalogEdgeComparator


5112 C++ Programming Manual: Member List

  • AIAnalogHysteresisComparator
JYPCIe5112CoreOO::AIAnalogHysteresisComparator Member List

This is the complete list of members for JYPCIe5112CoreOO::AIAnalogHysteresisComparator, including all inherited members.

HighThreshold | JYPCIe5112CoreOO::AIAnalogHysteresisComparator
LowThreshold | JYPCIe5112CoreOO::AIAnalogHysteresisComparator
Slope | JYPCIe5112CoreOO::AIAnalogHysteresisComparator


5112 C++ Programming Manual: Member List

  • AIAnalogTrigger
JYPCIe5112CoreOO::AIAnalogTrigger Member List

This is the complete list of members for JYPCIe5112CoreOO::AIAnalogTrigger, including all inherited members.

Comparator | JYPCIe5112CoreOO::AIAnalogTrigger
Edge | JYPCIe5112CoreOO::AIAnalogTrigger
Hysteresis | JYPCIe5112CoreOO::AIAnalogTrigger
Source | JYPCIe5112CoreOO::AIAnalogTrigger
Window | JYPCIe5112CoreOO::AIAnalogTrigger


5112 C++ Programming Manual: Member List

  • AIAnalogWindowComparator
JYPCIe5112CoreOO::AIAnalogWindowComparator Member List

This is the complete list of members for JYPCIe5112CoreOO::AIAnalogWindowComparator, including all inherited members.

Condition | JYPCIe5112CoreOO::AIAnalogWindowComparator
HighThreshold | JYPCIe5112CoreOO::AIAnalogWindowComparator
LowThreshold | JYPCIe5112CoreOO::AIAnalogWindowComparator


5112 C++ Programming Manual: Member List

  • AIChannel
JYPCIe5112CoreOO::AIChannel Member List

This is the complete list of members for JYPCIe5112CoreOO::AIChannel, including all inherited members.

AIChannel(int channelId, double rangeLow, double rangeHigh, AITerminal terminalCfg=AITerminal::NRSE) | JYPCIe5112CoreOO::AIChannel | inline
ChannelID | JYPCIe5112CoreOO::AIChannel |
RangeHigh | JYPCIe5112CoreOO::AIChannel |
RangeLow | JYPCIe5112CoreOO::AIChannel |
Terminal | JYPCIe5112CoreOO::AIChannel |


5112 C++ Programming Manual: Member List

  • AIDSMode
JYPCIe5112CoreOO::AIDSMode Member List

This is the complete list of members for JYPCIe5112CoreOO::AIDSMode, including all inherited members.

Enable | JYPCIe5112CoreOO::AIDSMode
PowerLineFrequency | JYPCIe5112CoreOO::AIDSMode


5112 C++ Programming Manual: Member List

  • AIDigitalTrigger
JYPCIe5112CoreOO::AIDigitalTrigger Member List

This is the complete list of members for JYPCIe5112CoreOO::AIDigitalTrigger, including all inherited members.

Edge | JYPCIe5112CoreOO::AIDigitalTrigger
Source | JYPCIe5112CoreOO::AIDigitalTrigger


5112 C++ Programming Manual: Member List

  • AIExternalSampleClock
JYPCIe5112CoreOO::AIExternalSampleClock Member List

This is the complete list of members for JYPCIe5112CoreOO::AIExternalSampleClock, including all inherited members.

ExpectedRate | JYPCIe5112CoreOO::AIExternalSampleClock
Terminal | JYPCIe5112CoreOO::AIExternalSampleClock


5112 C++ Programming Manual: Member List

  • AIRecord
JYPCIe5112CoreOO::AIRecord Member List

This is the complete list of members for JYPCIe5112CoreOO::AIRecord, including all inherited members.

File_Format | JYPCIe5112CoreOO::AIRecord
FilePath | JYPCIe5112CoreOO::AIRecord
Length | JYPCIe5112CoreOO::AIRecord
Mode | JYPCIe5112CoreOO::AIRecord


5112 C++ Programming Manual: Member List

  • AISampleClock
JYPCIe5112CoreOO::AISampleClock Member List

This is the complete list of members for JYPCIe5112CoreOO::AISampleClock, including all inherited members.

External | JYPCIe5112CoreOO::AISampleClock
Source | JYPCIe5112CoreOO::AISampleClock


5112 C++ Programming Manual: Member List

  • AISignalExport
JYPCIe5112CoreOO::AISignalExport Member List

This is the complete list of members for JYPCIe5112CoreOO::AISignalExport, including all inherited members.

Add(AISignalExportSource source, SignalExportDestination destination) | JYPCIe5112CoreOO::AISignalExport
Add(AISignalExportSource source, std::list< SignalExportDestination > destinations) | JYPCIe5112CoreOO::AISignalExport
Clear(SignalExportDestination destination) | JYPCIe5112CoreOO::AISignalExport
ClearAll() | JYPCIe5112CoreOO::AISignalExport


5112 C++ Programming Manual: Member List

  • AITrigger
JYPCIe5112CoreOO::AITrigger Member List

This is the complete list of members for JYPCIe5112CoreOO::AITrigger, including all inherited members.

Analog | JYPCIe5112CoreOO::AITrigger
Digital | JYPCIe5112CoreOO::AITrigger
Mode | JYPCIe5112CoreOO::AITrigger
PreTriggerSamples | JYPCIe5112CoreOO::AITrigger
ReTriggerCount | JYPCIe5112CoreOO::AITrigger
Type | JYPCIe5112CoreOO::AITrigger


5112 C++ Programming Manual: Member List

  • AOChannel
JYPCIe5112CoreOO::AOChannel Member List

This is the complete list of members for JYPCIe5112CoreOO::AOChannel, including all inherited members.

AOChannel(int channelId, double rangeLow, double rangeHigh) | JYPCIe5112CoreOO::AOChannel | inline
ChannelID | JYPCIe5112CoreOO::AOChannel |
RangeHigh | JYPCIe5112CoreOO::AOChannel |
RangeLow | JYPCIe5112CoreOO::AOChannel |


5112 C++ Programming Manual: Member List

  • AODigitalTrigger
JYPCIe5112CoreOO::AODigitalTrigger Member List

This is the complete list of members for JYPCIe5112CoreOO::AODigitalTrigger, including all inherited members.

Edge | JYPCIe5112CoreOO::AODigitalTrigger
Source | JYPCIe5112CoreOO::AODigitalTrigger


5112 C++ Programming Manual: Member List

  • AOExternalSampleClock
JYPCIe5112CoreOO::AOExternalSampleClock Member List

This is the complete list of members for JYPCIe5112CoreOO::AOExternalSampleClock, including all inherited members.

ExpectedRate | JYPCIe5112CoreOO::AOExternalSampleClock
Terminal | JYPCIe5112CoreOO::AOExternalSampleClock


5112 C++ Programming Manual: Member List

  • AOSampleClock
JYPCIe5112CoreOO::AOSampleClock Member List

This is the complete list of members for JYPCIe5112CoreOO::AOSampleClock, including all inherited members.

External | JYPCIe5112CoreOO::AOSampleClock
Source | JYPCIe5112CoreOO::AOSampleClock


5112 C++ Programming Manual: Member List

  • AOSignalExport
JYPCIe5112CoreOO::AOSignalExport Member List

This is the complete list of members for JYPCIe5112CoreOO::AOSignalExport, including all inherited members.

Add(AOSignalExportSource source, SignalExportDestination destination) | JYPCIe5112CoreOO::AOSignalExport
Add(AOSignalExportSource source, std::list< SignalExportDestination > destinations) | JYPCIe5112CoreOO::AOSignalExport
Clear(SignalExportDestination destination) | JYPCIe5112CoreOO::AOSignalExport
ClearAll() | JYPCIe5112CoreOO::AOSignalExport


5112 C++ Programming Manual: Member List

  • AOTrigger
JYPCIe5112CoreOO::AOTrigger Member List

This is the complete list of members for JYPCIe5112CoreOO::AOTrigger, including all inherited members.

Digital | JYPCIe5112CoreOO::AOTrigger
Type | JYPCIe5112CoreOO::AOTrigger


5112 C++ Programming Manual: Member List

  • CIDigitalTrigger
JYPCIe5112CoreOO::CIDigitalTrigger Member List

This is the complete list of members for JYPCIe5112CoreOO::CIDigitalTrigger, including all inherited members.

Edge | JYPCIe5112CoreOO::CIDigitalTrigger
Source | JYPCIe5112CoreOO::CIDigitalTrigger


5112 C++ Programming Manual: Member List

  • CIExternalSampleClock
JYPCIe5112CoreOO::CIExternalSampleClock Member List

This is the complete list of members for JYPCIe5112CoreOO::CIExternalSampleClock, including all inherited members.

ExpectedRate | JYPCIe5112CoreOO::CIExternalSampleClock
Terminal | JYPCIe5112CoreOO::CIExternalSampleClock


5112 C++ Programming Manual: Member List

  • CIExternalTimebase
JYPCIe5112CoreOO::CIExternalTimebase Member List

This is the complete list of members for JYPCIe5112CoreOO::CIExternalTimebase, including all inherited members.

Frequency | JYPCIe5112CoreOO::CIExternalTimebase
Terminal | JYPCIe5112CoreOO::CIExternalTimebase


5112 C++ Programming Manual: Member List

  • CIImplicitSampleClock
JYPCIe5112CoreOO::CIImplicitSampleClock Member List

This is the complete list of members for JYPCIe5112CoreOO::CIImplicitSampleClock, including all inherited members.

ExpectedRate JYPCIe5112CoreOO::CIImplicitSampleClock


5112 C++ Programming Manual: Member List

  • CIInternalSampleClock
JYPCIe5112CoreOO::CIInternalSampleClock Member List

This is the complete list of members for JYPCIe5112CoreOO::CIInternalSampleClock, including all inherited members.

Rate JYPCIe5112CoreOO::CIInternalSampleClock


5112 C++ Programming Manual: Member List

  • CISampleClock
JYPCIe5112CoreOO::CISampleClock Member List

This is the complete list of members for JYPCIe5112CoreOO::CISampleClock, including all inherited members.

External | JYPCIe5112CoreOO::CISampleClock
Implicit | JYPCIe5112CoreOO::CISampleClock
Internal | JYPCIe5112CoreOO::CISampleClock
Source | JYPCIe5112CoreOO::CISampleClock


5112 C++ Programming Manual: Member List

  • CISignalExport
JYPCIe5112CoreOO::CISignalExport Member List

This is the complete list of members for JYPCIe5112CoreOO::CISignalExport, including all inherited members.

Add(CISignalExportSource source, SignalExportDestination destination) | JYPCIe5112CoreOO::CISignalExport
Add(CISignalExportSource source, std::list< SignalExportDestination > destinations) | JYPCIe5112CoreOO::CISignalExport
Clear(SignalExportDestination destination) | JYPCIe5112CoreOO::CISignalExport
ClearAll() | JYPCIe5112CoreOO::CISignalExport


5112 C++ Programming Manual: Member List

  • CITimebase
JYPCIe5112CoreOO::CITimebase Member List

This is the complete list of members for JYPCIe5112CoreOO::CITimebase, including all inherited members.

External | JYPCIe5112CoreOO::CITimebase
Source | JYPCIe5112CoreOO::CITimebase


5112 C++ Programming Manual: Member List

  • CITrigger
JYPCIe5112CoreOO::CITrigger Member List

This is the complete list of members for JYPCIe5112CoreOO::CITrigger, including all inherited members.

Digital | JYPCIe5112CoreOO::CITrigger
Type | JYPCIe5112CoreOO::CITrigger


5112 C++ Programming Manual: Member List

  • CODigitalTrigger
JYPCIe5112CoreOO::CODigitalTrigger Member List

This is the complete list of members for JYPCIe5112CoreOO::CODigitalTrigger, including all inherited members.

Edge | JYPCIe5112CoreOO::CODigitalTrigger
Source | JYPCIe5112CoreOO::CODigitalTrigger


5112 C++ Programming Manual: Member List

  • COPulse
JYPCIe5112CoreOO::COPulse Member List

This is the complete list of members for JYPCIe5112CoreOO::COPulse, including all inherited members.

COPulse(COPulseType type, double param1, double param2, int count) JYPCIe5112CoreOO::COPulse


5112 C++ Programming Manual: Member List

  • COSignalExport
JYPCIe5112CoreOO::COSignalExport Member List

This is the complete list of members for JYPCIe5112CoreOO::COSignalExport, including all inherited members.

Add(COSignalExportSource source, SignalExportDestination destination) | JYPCIe5112CoreOO::COSignalExport
Add(COSignalExportSource source, std::list< SignalExportDestination > destinations) | JYPCIe5112CoreOO::COSignalExport
Clear(SignalExportDestination destination) | JYPCIe5112CoreOO::COSignalExport
ClearAll() | JYPCIe5112CoreOO::COSignalExport


5112 C++ Programming Manual: Member List

  • COTimebase
JYPCIe5112CoreOO::COTimebase Member List

This is the complete list of members for JYPCIe5112CoreOO::COTimebase, including all inherited members.

Source JYPCIe5112CoreOO::COTimebase


5112 C++ Programming Manual: Member List

  • COTrigger
JYPCIe5112CoreOO::COTrigger Member List

This is the complete list of members for JYPCIe5112CoreOO::COTrigger, including all inherited members.

Digital | JYPCIe5112CoreOO::COTrigger
Type | JYPCIe5112CoreOO::COTrigger


5112 C++ Programming Manual: Member List

  • DIChannel
JYPCIe5112CoreOO::DIChannel Member List

This is the complete list of members for JYPCIe5112CoreOO::DIChannel, including all inherited members.

PortNum JYPCIe5112CoreOO::DIChannel


5112 C++ Programming Manual: Member List

  • DOChannel
JYPCIe5112CoreOO::DOChannel Member List

This is the complete list of members for JYPCIe5112CoreOO::DOChannel, including all inherited members.

PortNum JYPCIe5112CoreOO::DOChannel


5112 C++ Programming Manual: Member List

  • EdgeCounting
JYPCIe5112CoreOO::EdgeCounting Member List

This is the complete list of members for JYPCIe5112CoreOO::EdgeCounting, including all inherited members.

ActiveEdge | JYPCIe5112CoreOO::EdgeCounting
Direction | JYPCIe5112CoreOO::EdgeCounting
DirTerminal | JYPCIe5112CoreOO::EdgeCounting
InitialCount | JYPCIe5112CoreOO::EdgeCounting
Input_Terminal | JYPCIe5112CoreOO::EdgeCounting
OutEvent | JYPCIe5112CoreOO::EdgeCounting
Pause | JYPCIe5112CoreOO::EdgeCounting


5112 C++ Programming Manual: Member List

  • EdgeCountingOutEvent
JYPCIe5112CoreOO::EdgeCountingOutEvent Member List

This is the complete list of members for JYPCIe5112CoreOO::EdgeCountingOutEvent, including all inherited members.

IdleState | JYPCIe5112CoreOO::EdgeCountingOutEvent
Terminal | JYPCIe5112CoreOO::EdgeCountingOutEvent
Threshold | JYPCIe5112CoreOO::EdgeCountingOutEvent


5112 C++ Programming Manual: Member List

  • ExternalReferenceClock
JYPCIe5112CoreOO::ExternalReferenceClock Member List

This is the complete list of members for JYPCIe5112CoreOO::ExternalReferenceClock, including all inherited members.

Terminal JYPCIe5112CoreOO::ExternalReferenceClock


5112 C++ Programming Manual: Member List

  • FrequencyMeas
JYPCIe5112CoreOO::FrequencyMeas Member List

This is the complete list of members for JYPCIe5112CoreOO::FrequencyMeas, including all inherited members.

Input_Terminal | JYPCIe5112CoreOO::FrequencyMeas
Timebase | JYPCIe5112CoreOO::FrequencyMeas


5112 C++ Programming Manual: Member List

  • JYDriverException
JYPCIe5112CoreOO::JYDriverException Member List

This is the complete list of members for JYPCIe5112CoreOO::JYDriverException, including all inherited members.

errorCode | JYPCIe5112CoreOO::JYDriverException
exceptionMessage | JYPCIe5112CoreOO::JYDriverException
FollowingException | JYPCIe5112CoreOO::JYDriverException
JYDriverException(JYDriverExceptionPublic exceptionCode, std::string msg="") | JYPCIe5112CoreOO::JYDriverException
JYDriverException(int, std::string msg) | JYPCIe5112CoreOO::JYDriverException


5112 C++ Programming Manual: Member List

  • JYPCIe5112CoreOOAITask
JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask Member List

This is the complete list of members for JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask, including all inherited members.

AddChannel(int chnId, double rangeLow=-10, double rangeHigh=10, AITerminal terminalCfg=AITerminal::RSE) | JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
AddChannel(std::vector< int > chnsId, double rangeLow=-10, double rangeHigh=10, AITerminal terminalCfg=AITerminal::RSE) | JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
AddChannel(std::vector< int > chnsId, std::vector< double > rangeLow, std::vector< double > rangeHigh, AITerminal terminalCfg=AITerminal::RSE) | JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
Advanced | JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
AvailableSamples | JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
BufLenInSamples | JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
Channels | JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
Device | JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
GetRecordPreviewData(double *buf, int samplesPerChannel, int timeout) | JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
GetRecordPreviewData(std::vector< double > &buf, int samplesPerChannel, int timeout) | JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
GetRecordStatus(double &recordedLength, bool &recordDone) | JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
JYPCIe5112CoreOOAITask(int slotNum) | JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
JYPCIe5112CoreOOAITask(std::string boardName) | JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
Mode | JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
ReadData(double *pBuf, int samplesPerChannel, int timeout=-1) | JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
ReadData(std::vector< double > &pBuf, int samplesPerChannel, int timeout=-1) | JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
ReadRawData(short *pBuf, int samplesPerChannel, int timeout=-1) | JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
ReadRawData(std::vector< short > &pBuf, int samplesPerChannel, int timeout=-1) | JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
ReadRawSinglePoint(unsigned int &readValue, int channel) | JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
ReadRawSinglePoint(std::vector< uint32_t > &readValues) | JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
ReadSinglePoint(double &readValue, int channel) | JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
ReadSinglePoint(std::vector< double > &readValues) | JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
Record | JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
RemoveChannel(int chnId) | JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
SampleClock | JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
SampleRate | JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
SamplesToAcquire | JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
SendSoftwareTrigger() | JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
SignalExport | JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
Start() | JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
Stop() | JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
TransferedSamples | JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
Trigger | JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask


5112 C++ Programming Manual: Member List

  • JYPCIe5112CoreOOAOTask
JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask Member List

This is the complete list of members for JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask, including all inherited members.

AddChannel(int chnId, double rangeLow=-10, double rangeHigh=10) | JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask
AddChannel(std::vector< int > chnsId, double rangeLow=-10, double rangeHigh=10) | JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask
AddChannel(std::vector< int > chnsId, std::vector< double > rangeLow, std::vector< double > rangeHigh) | JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask
AvaliableLenInSamples | JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask
BufLenInSamples | JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask
Channels | JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask
CompleteState | JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask
Device | JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask
DisableCalibration | JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask
JYPCIe5112CoreOOAOTask(int slotNum) | JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask
JYPCIe5112CoreOOAOTask(std::string boardName) | JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask
Mode | JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask
RemoveChannel(int chnId) | JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask
SampleClock | JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask
SamplesToUpdate | JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask
SendSoftwareTrigger() | JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask
SignalExport | JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask
Start() | JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask
Stop() | JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask
TransferedSamples | JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask
Trigger | JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask
UpdateRate | JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask
WaitUntilDone(int timeout=-1) | JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask
WriteData(double *pBuf, int samplesPerChannel, int timeout=10000) | JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask
WriteData(std::vector< double > &pBuf, int samplesPerChannel, int timeout=10000) | JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask
WriteRawData(int16_t *pBuf, int samplesPerChannel, int timeout=10000) | JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask
WriteRawData(std::vector< int16_t > &pBuf, int samplesPerChannel, int timeout=10000) | JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask
WriteRawSinglePoint(std::vector< short > &writeValues) | JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask
WriteRawSinglePoint(short writeValue, int channel) | JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask
WriteSinglePoint(std::vector< double > writeValues) | JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask
WriteSinglePoint(double writeValue, int channel) | JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask


5112 C++ Programming Manual: Member List

  • JYPCIe5112CoreOOCITask
JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask Member List

This is the complete list of members for JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask, including all inherited members.

AvailableSamples | JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
Device | JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
EdgeCounting | JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
FrequencyMeas | JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
JYPCIe5112CoreOOCITask(int slotNum, int channel) | JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
JYPCIe5112CoreOOCITask(std::string boardName, int channel) | JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
PeriodMeas | JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
PulseMeas | JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
QuadEncoder | JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
ReadData(uint32_t *pBufCount, int samplesToAcquire, int timeout=10000) | JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
ReadData(std::vector< uint32_t > &pBufCount, int samplesToAcquire, int timeout=10000) | JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
ReadData(double *pBufMeasurement, int samplesToAcquire, int timeout=10000) | JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
ReadData(std::vector< double > &pBufMeasurement, int samplesToAcquire, int timeout=10000) | JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
ReadData(double *pBufMeasurement1, double *pBufMeasurement2, int samplesToAcquire, int timeout=10000) | JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
ReadData(std::vector< double > &pBufMeasurement1, std::vector< double > &pBufMeasurement2, int samplesToAcquire, int timeout=10000) | JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
ReadSinglePoint(uint32_t &count) | JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
ReadSinglePoint(double &measurement, int timeout=10000) | JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
ReadSinglePoint(double &measurement1, double &measurement2, int timeout=10000) | JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
SampleClock | JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
SamplesToAcquire | JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
SemiPeriodMeas | JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
SendSoftwareTrigger() | JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
SignalExport | JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
Start() | JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
Stop() | JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
TransferedSamples | JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
Trigger | JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
TwoEdgeSeparation | JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
TwoPulseEncoder | JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
Type | JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask


5112 C++ Programming Manual: Member List

  • JYPCIe5112CoreOOCOTask
JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask Member List

This is the complete list of members for JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask, including all inherited members.

Device | JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask
IdleState | JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask
InitialDelay | JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask
JYPCIe5112CoreOOCOTask(int slotNum, int channel) | JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask
JYPCIe5112CoreOOCOTask(std::string boardName, int channel) | JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask
Mode | JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask
OutputTerminal | JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask
Pause | JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask
SamplesToUpdate | JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask
SendSoftwareTrigger() | JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask
SignalExport | JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask
Start() | JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask
Stop() | JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask
TimeBase | JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask
Trigger | JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask
WaitUntilDone(int timeout=-1) | JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask
WriteData(COPulse *pulsesGroup[], int samplesToWrite, int timeout=10000) | JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask
WriteSinglePoint(COPulse &pulse) | JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask


5112 C++ Programming Manual: Member List

  • JYPCIe5112CoreOODITask
JYPCIe5112CoreOO::JYPCIe5112CoreOODITask Member List

This is the complete list of members for JYPCIe5112CoreOO::JYPCIe5112CoreOODITask, including all inherited members.

AddChannel(int portNum) | JYPCIe5112CoreOO::JYPCIe5112CoreOODITask
AddChannel(std::vector< int > portsNum) | JYPCIe5112CoreOO::JYPCIe5112CoreOODITask
Channels | JYPCIe5112CoreOO::JYPCIe5112CoreOODITask
Device | JYPCIe5112CoreOO::JYPCIe5112CoreOODITask
JYPCIe5112CoreOODITask(int slotNum) | JYPCIe5112CoreOO::JYPCIe5112CoreOODITask
JYPCIe5112CoreOODITask(std::string boardName) | JYPCIe5112CoreOO::JYPCIe5112CoreOODITask
ReadSinglePoint(std::vector< bool > &readValues, int port) | JYPCIe5112CoreOO::JYPCIe5112CoreOODITask
ReadSinglePoint(std::vector< int > &readValues) | JYPCIe5112CoreOO::JYPCIe5112CoreOODITask
ReadSinglePoint(bool *readValues) | JYPCIe5112CoreOO::JYPCIe5112CoreOODITask
ReadSinglePoint(std::vector< bool > &readValues) | JYPCIe5112CoreOO::JYPCIe5112CoreOODITask
RemoveChannel(int portNum) | JYPCIe5112CoreOO::JYPCIe5112CoreOODITask
Start() | JYPCIe5112CoreOO::JYPCIe5112CoreOODITask
Stop() | JYPCIe5112CoreOO::JYPCIe5112CoreOODITask
~JYPCIe5112CoreOODITask() | JYPCIe5112CoreOO::JYPCIe5112CoreOODITask


5112 C++ Programming Manual: Member List

  • JYPCIe5112CoreOODOTask
JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask Member List

This is the complete list of members for JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask, including all inherited members.

AddChannel(int portNum) | JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask
AddChannel(std::vector< int > portsNum) | JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask
Channels | JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask
Device | JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask
JYPCIe5112CoreOODOTask(int slotNum) | JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask
JYPCIe5112CoreOODOTask(std::string boardName) | JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask
RemoveChannel(int portNum) | JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask
Start() | JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask
Stop() | JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask
WriteSinglePoint(std::vector< bool > &writeValues, int port) | JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask
WriteSinglePoint(std::vector< bool > &writeValues) | JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask
~JYPCIe5112CoreOODOTask() | JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask


5112 C++ Programming Manual: Member List

  • JYPCIe5112CoreOODevice
JYPCIe5112CoreOO::JYPCIe5112CoreOODevice Member List

This is the complete list of members for JYPCIe5112CoreOO::JYPCIe5112CoreOODevice, including all inherited members.

AIBufferSize | JYPCIe5112CoreOO::JYPCIe5112CoreOODevice |
AOChannelCount | JYPCIe5112CoreOO::JYPCIe5112CoreOODevice |
BoardClockRate | JYPCIe5112CoreOO::JYPCIe5112CoreOODevice |
DeviceID | JYPCIe5112CoreOO::JYPCIe5112CoreOODevice |
DiffChannelCount | JYPCIe5112CoreOO::JYPCIe5112CoreOODevice |
GetInstance(int cardNum) | JYPCIe5112CoreOO::JYPCIe5112CoreOODevice | static
GetInstance(std::string aliasName) | JYPCIe5112CoreOO::JYPCIe5112CoreOODevice | static
Handle | JYPCIe5112CoreOO::JYPCIe5112CoreOODevice |
IsAISync | JYPCIe5112CoreOO::JYPCIe5112CoreOODevice |
IsAOSync | JYPCIe5112CoreOO::JYPCIe5112CoreOODevice |
LineCountPerPort | JYPCIe5112CoreOO::JYPCIe5112CoreOODevice |
MaxSampleRateMutilChannel | JYPCIe5112CoreOO::JYPCIe5112CoreOODevice |
MaxSampleRateSingleChannel | JYPCIe5112CoreOO::JYPCIe5112CoreOODevice |
MaxUpdateRate | JYPCIe5112CoreOO::JYPCIe5112CoreOODevice |
MaxUpdateRateSingleChannel | JYPCIe5112CoreOO::JYPCIe5112CoreOODevice |
PFI | JYPCIe5112CoreOO::JYPCIe5112CoreOODevice |
ReferenceClock | JYPCIe5112CoreOO::JYPCIe5112CoreOODevice |
SEChannelCount | JYPCIe5112CoreOO::JYPCIe5112CoreOODevice |
SerialNumber | JYPCIe5112CoreOO::JYPCIe5112CoreOODevice |


5112 C++ Programming Manual: Member List

  • JYPCIe5112CoreOOLog
JYPCIe5112CoreOO::JYPCIe5112CoreOOLog Member List

This is the complete list of members for JYPCIe5112CoreOO::JYPCIe5112CoreOOLog, including all inherited members.

EnableLog | JYPCIe5112CoreOO::JYPCIe5112CoreOOLog | static
Flush() | JYPCIe5112CoreOO::JYPCIe5112CoreOOLog | static
LogLevel | JYPCIe5112CoreOO::JYPCIe5112CoreOOLog | static
Print(const char *format,...) | JYPCIe5112CoreOO::JYPCIe5112CoreOOLog | static
Print(JYPCIe5112CoreOOLogLevel logLevel, const char *format,...) | JYPCIe5112CoreOO::JYPCIe5112CoreOOLog | static


5112 C++ Programming Manual: Member List

  • JYPCIe5112CoreOOProperty
JYPCIe5112CoreOO::JYPCIe5112CoreOOProperty< ContainerClass, ValueType, propertyType > Member List

This is the complete list of members for JYPCIe5112CoreOO::JYPCIe5112CoreOOProperty< ContainerClass, ValueType, propertyType >, including all inherited members.

JYPCIe5112CoreOOProperty() | JYPCIe5112CoreOO::JYPCIe5112CoreOOProperty< ContainerClass, ValueType, propertyType >
JYPCIe5112CoreOOProperty(ContainerClass *cObject, ValueType(ContainerClass::*pGet)(), void(ContainerClass::*pSet)(ValueType value)) | JYPCIe5112CoreOO::JYPCIe5112CoreOOProperty< ContainerClass, ValueType, propertyType >
JYPCIe5112CoreOOProperty(ValueType(*pGet)(), void(*pSet)(ValueType value)) | JYPCIe5112CoreOO::JYPCIe5112CoreOOProperty< ContainerClass, ValueType, propertyType >
operator ValueType() | JYPCIe5112CoreOO::JYPCIe5112CoreOOProperty< ContainerClass, ValueType, propertyType >
operator=(const ValueType &value) | JYPCIe5112CoreOO::JYPCIe5112CoreOOProperty< ContainerClass, ValueType, propertyType >


5112 C++ Programming Manual: Member List

  • JYPCIe5112CoreOOReferenceClock
JYPCIe5112CoreOO::JYPCIe5112CoreOOReferenceClock Member List

This is the complete list of members for JYPCIe5112CoreOO::JYPCIe5112CoreOOReferenceClock, including all inherited members.

Commit() | JYPCIe5112CoreOO::JYPCIe5112CoreOOReferenceClock
External | JYPCIe5112CoreOO::JYPCIe5112CoreOOReferenceClock
Source | JYPCIe5112CoreOO::JYPCIe5112CoreOOReferenceClock


5112 C++ Programming Manual: Member List

  • PFIFilter
JYPCIe5112CoreOO::PFIFilter Member List

This is the complete list of members for JYPCIe5112CoreOO::PFIFilter, including all inherited members.

Disable(PFITerminal terminal) | JYPCIe5112CoreOO::PFIFilter
Disable(std::vector< PFITerminal > terminals) | JYPCIe5112CoreOO::PFIFilter
DisableAll() | JYPCIe5112CoreOO::PFIFilter
Enable(PFITerminal terminal, int minPulseWidth) | JYPCIe5112CoreOO::PFIFilter
Enable(std::vector< PFITerminal > terminals, int minPulseWidth) | JYPCIe5112CoreOO::PFIFilter
Enable(std::vector< PFITerminal > terminals, std::vector< int > minPulseWidth) | JYPCIe5112CoreOO::PFIFilter


5112 C++ Programming Manual: Member List

  • PFISetting
JYPCIe5112CoreOO::PFISetting Member List

This is the complete list of members for JYPCIe5112CoreOO::PFISetting, including all inherited members.

Filter JYPCIe5112CoreOO::PFISetting


5112 C++ Programming Manual: Member List

  • PauseTrigger
JYPCIe5112CoreOO::PauseTrigger Member List

This is the complete list of members for JYPCIe5112CoreOO::PauseTrigger, including all inherited members.

ActivePolarity | JYPCIe5112CoreOO::PauseTrigger
Output_State | JYPCIe5112CoreOO::PauseTrigger
Terminal | JYPCIe5112CoreOO::PauseTrigger


5112 C++ Programming Manual: Member List

  • PeriodMeas
JYPCIe5112CoreOO::PeriodMeas Member List

This is the complete list of members for JYPCIe5112CoreOO::PeriodMeas, including all inherited members.

Input_Terminal | JYPCIe5112CoreOO::PeriodMeas
Timebase | JYPCIe5112CoreOO::PeriodMeas


5112 C++ Programming Manual: Member List

  • PulseMeas
JYPCIe5112CoreOO::PulseMeas Member List

This is the complete list of members for JYPCIe5112CoreOO::PulseMeas, including all inherited members.

Input_Terminal | JYPCIe5112CoreOO::PulseMeas
StartingEdge | JYPCIe5112CoreOO::PulseMeas
Timebase | JYPCIe5112CoreOO::PulseMeas


5112 C++ Programming Manual: Member List

  • QuadEncoder
JYPCIe5112CoreOO::QuadEncoder Member List

This is the complete list of members for JYPCIe5112CoreOO::QuadEncoder, including all inherited members.

AInputTerminal | JYPCIe5112CoreOO::QuadEncoder
BInputTerminal | JYPCIe5112CoreOO::QuadEncoder
EncodingType | JYPCIe5112CoreOO::QuadEncoder
InitialCount | JYPCIe5112CoreOO::QuadEncoder
ZInputTerminal | JYPCIe5112CoreOO::QuadEncoder
ZReloadEnabled | JYPCIe5112CoreOO::QuadEncoder


5112 C++ Programming Manual: Member List

  • SemiPeriodMeas
JYPCIe5112CoreOO::SemiPeriodMeas Member List

This is the complete list of members for JYPCIe5112CoreOO::SemiPeriodMeas, including all inherited members.

Input_Terminal | JYPCIe5112CoreOO::SemiPeriodMeas
StartingEdge | JYPCIe5112CoreOO::SemiPeriodMeas
Timebase | JYPCIe5112CoreOO::SemiPeriodMeas


5112 C++ Programming Manual: Member List

  • TwoEdgeSeparation
JYPCIe5112CoreOO::TwoEdgeSeparation Member List

This is the complete list of members for JYPCIe5112CoreOO::TwoEdgeSeparation, including all inherited members.

EdgeSeparationMode | JYPCIe5112CoreOO::TwoEdgeSeparation
FirstInputTerminal | JYPCIe5112CoreOO::TwoEdgeSeparation
SecondInputTerminal | JYPCIe5112CoreOO::TwoEdgeSeparation
Timebase | JYPCIe5112CoreOO::TwoEdgeSeparation


5112 C++ Programming Manual: Member List

  • TwoPulseEncoder
JYPCIe5112CoreOO::TwoPulseEncoder Member List

This is the complete list of members for JYPCIe5112CoreOO::TwoPulseEncoder, including all inherited members.

AInputTerminal | JYPCIe5112CoreOO::TwoPulseEncoder
BInputTerminal | JYPCIe5112CoreOO::TwoPulseEncoder
InitialCount | JYPCIe5112CoreOO::TwoPulseEncoder


5112 C++ Programming Manual: JYPCIe5112CoreOOAIMode Class Reference

JYPCIe5112CoreOOAIMode Class Reference

AIMode. More...

#include <JYPCIe5112CoreOOAITask.h>

Detailed Description

AIMode.

The documentation for this class was generated from the following file:
  • COO/5112/JYPCIe5112CoreOOAITask.h


5112 C++ Programming Manual: Class Index

Class Index
A | C | D | E | F | J | P | Q | S | T
A
AIAdvanced (JYPCIe5112CoreOO)
AIAnalogEdgeComparator (JYPCIe5112CoreOO)
AIAnalogHysteresisComparator (JYPCIe5112CoreOO)
AIAnalogTrigger (JYPCIe5112CoreOO)
AIAnalogWindowComparator (JYPCIe5112CoreOO)
AIChannel (JYPCIe5112CoreOO)
AIDigitalTrigger (JYPCIe5112CoreOO)
AIDSMode (JYPCIe5112CoreOO)
AIExternalSampleClock (JYPCIe5112CoreOO)
AIRecord (JYPCIe5112CoreOO)
AISampleClock (JYPCIe5112CoreOO)
AISignalExport (JYPCIe5112CoreOO)
AITrigger (JYPCIe5112CoreOO)
AOChannel (JYPCIe5112CoreOO)
AODigitalTrigger (JYPCIe5112CoreOO)
AOExternalSampleClock (JYPCIe5112CoreOO)
AOMode
AOSampleClock (JYPCIe5112CoreOO)
AOSignalExport (JYPCIe5112CoreOO)
AOTrigger (JYPCIe5112CoreOO)
C
CIDigitalTrigger (JYPCIe5112CoreOO)
CIExternalSampleClock (JYPCIe5112CoreOO)
CIExternalTimebase (JYPCIe5112CoreOO)
CIImplicitSampleClock (JYPCIe5112CoreOO)
CIInternalSampleClock (JYPCIe5112CoreOO)
CISampleClock (JYPCIe5112CoreOO)
CISignalExport (JYPCIe5112CoreOO)
CITimebase (JYPCIe5112CoreOO)
CITrigger (JYPCIe5112CoreOO)
CODigitalTrigger (JYPCIe5112CoreOO)
COPulse (JYPCIe5112CoreOO)
COSignalExport (JYPCIe5112CoreOO)
COTimebase (JYPCIe5112CoreOO)
COTrigger (JYPCIe5112CoreOO)
D
DIChannel (JYPCIe5112CoreOO)
DOChannel (JYPCIe5112CoreOO)
E
EdgeCounting (JYPCIe5112CoreOO)
EdgeCountingOutEvent (JYPCIe5112CoreOO)
ExternalReferenceClock (JYPCIe5112CoreOO)
F
FrequencyMeas (JYPCIe5112CoreOO)
J
JYDriverException (JYPCIe5112CoreOO)
JYPCIe5112CoreOOAIMode
JYPCIe5112CoreOOAITask (JYPCIe5112CoreOO)
JYPCIe5112CoreOOAOTask (JYPCIe5112CoreOO)
JYPCIe5112CoreOOCITask (JYPCIe5112CoreOO)
JYPCIe5112CoreOOCOTask (JYPCIe5112CoreOO)
JYPCIe5112CoreOODevice (JYPCIe5112CoreOO)
JYPCIe5112CoreOODITask (JYPCIe5112CoreOO)
JYPCIe5112CoreOODOTask (JYPCIe5112CoreOO)
JYPCIe5112CoreOOLog (JYPCIe5112CoreOO)
JYPCIe5112CoreOOProperty (JYPCIe5112CoreOO)
JYPCIe5112CoreOOReferenceClock (JYPCIe5112CoreOO)
P
PauseTrigger (JYPCIe5112CoreOO)
PeriodMeas (JYPCIe5112CoreOO)
PFIFilter (JYPCIe5112CoreOO)
PFISetting (JYPCIe5112CoreOO)
PulseMeas (JYPCIe5112CoreOO)
Q
QuadEncoder (JYPCIe5112CoreOO)
S
SemiPeriodMeas (JYPCIe5112CoreOO)
T
TwoEdgeSeparation (JYPCIe5112CoreOO)
TwoPulseEncoder (JYPCIe5112CoreOO)


5112 C++ Programming Manual: COO Directory Reference

  • File List
  • File Members
  • COO
COO Directory Reference

Directories

5112


5112 C++ Programming Manual: File List

  • File List
  • File Members
File List
Here is a list of all files with brief descriptions:
[detail level 123]
▼ COO
▼ 5112
JYPCIe5112CoreOOAITask.h
JYPCIe5112CoreOOAOTask.h
JYPCIe5112CoreOOCITask.h
JYPCIe5112CoreOOCommon.h
JYPCIe5112CoreOOCOTask.h
JYPCIe5112CoreOODevice.h
JYPCIe5112CoreOODITask.h
JYPCIe5112CoreOODOTask.h
JYPCIe5112CoreOOLog.h


5112 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- a -

  • ActiveEdge : JYPCIe5112CoreOO::EdgeCounting
  • ActivePolarity : JYPCIe5112CoreOO::PauseTrigger
  • Add() : JYPCIe5112CoreOO::AISignalExport, JYPCIe5112CoreOO::AOSignalExport, JYPCIe5112CoreOO::CISignalExport, JYPCIe5112CoreOO::COSignalExport
  • AddChannel() : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask, JYPCIe5112CoreOO::JYPCIe5112CoreOODITask, JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask
  • Advanced : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
  • AIBufferSize : JYPCIe5112CoreOO::JYPCIe5112CoreOODevice
  • AIChannel() : JYPCIe5112CoreOO::AIChannel
  • AInputTerminal : JYPCIe5112CoreOO::QuadEncoder, JYPCIe5112CoreOO::TwoPulseEncoder
  • Analog : JYPCIe5112CoreOO::AITrigger
  • AOChannel() : JYPCIe5112CoreOO::AOChannel
  • AOChannelCount : JYPCIe5112CoreOO::JYPCIe5112CoreOODevice
  • AvailableSamples : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
  • AvaliableLenInSamples : JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask


5112 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- b -

  • BInputTerminal : JYPCIe5112CoreOO::QuadEncoder, JYPCIe5112CoreOO::TwoPulseEncoder
  • BoardClockRate : JYPCIe5112CoreOO::JYPCIe5112CoreOODevice
  • BufLenInSamples : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask


5112 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- c -

  • ChannelID : JYPCIe5112CoreOO::AIChannel, JYPCIe5112CoreOO::AOChannel
  • Channels : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask, JYPCIe5112CoreOO::JYPCIe5112CoreOODITask, JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask
  • Clear() : JYPCIe5112CoreOO::AISignalExport, JYPCIe5112CoreOO::AOSignalExport, JYPCIe5112CoreOO::CISignalExport, JYPCIe5112CoreOO::COSignalExport
  • ClearAll() : JYPCIe5112CoreOO::AISignalExport, JYPCIe5112CoreOO::AOSignalExport, JYPCIe5112CoreOO::CISignalExport, JYPCIe5112CoreOO::COSignalExport
  • Commit() : JYPCIe5112CoreOO::JYPCIe5112CoreOOReferenceClock
  • Comparator : JYPCIe5112CoreOO::AIAnalogTrigger
  • CompleteState : JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask
  • Condition : JYPCIe5112CoreOO::AIAnalogWindowComparator
  • ConvertRate : JYPCIe5112CoreOO::AIAdvanced
  • COPulse() : JYPCIe5112CoreOO::COPulse


5112 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- d -

  • Device : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask, JYPCIe5112CoreOO::JYPCIe5112CoreOODITask, JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask
  • DeviceID : JYPCIe5112CoreOO::JYPCIe5112CoreOODevice
  • DiffChannelCount : JYPCIe5112CoreOO::JYPCIe5112CoreOODevice
  • Digital : JYPCIe5112CoreOO::AITrigger, JYPCIe5112CoreOO::AOTrigger, JYPCIe5112CoreOO::CITrigger, JYPCIe5112CoreOO::COTrigger
  • Direction : JYPCIe5112CoreOO::EdgeCounting
  • DirTerminal : JYPCIe5112CoreOO::EdgeCounting
  • Disable() : JYPCIe5112CoreOO::PFIFilter
  • DisableAll() : JYPCIe5112CoreOO::PFIFilter
  • DisableCalibration : JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask
  • DSMode : JYPCIe5112CoreOO::AIAdvanced


5112 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- e -

  • Edge : JYPCIe5112CoreOO::AIAnalogTrigger, JYPCIe5112CoreOO::AIDigitalTrigger, JYPCIe5112CoreOO::AODigitalTrigger, JYPCIe5112CoreOO::CIDigitalTrigger, JYPCIe5112CoreOO::CODigitalTrigger
  • EdgeCounting : JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
  • EdgeSeparationMode : JYPCIe5112CoreOO::TwoEdgeSeparation
  • Enable : JYPCIe5112CoreOO::AIDSMode, JYPCIe5112CoreOO::PFIFilter
  • EnableLog : JYPCIe5112CoreOO::JYPCIe5112CoreOOLog
  • EncodingType : JYPCIe5112CoreOO::QuadEncoder
  • errorCode : JYPCIe5112CoreOO::JYDriverException
  • exceptionMessage : JYPCIe5112CoreOO::JYDriverException
  • ExpectedRate : JYPCIe5112CoreOO::AIExternalSampleClock, JYPCIe5112CoreOO::AOExternalSampleClock, JYPCIe5112CoreOO::CIExternalSampleClock, JYPCIe5112CoreOO::CIImplicitSampleClock
  • External : JYPCIe5112CoreOO::AISampleClock, JYPCIe5112CoreOO::AOSampleClock, JYPCIe5112CoreOO::CISampleClock, JYPCIe5112CoreOO::CITimebase, JYPCIe5112CoreOO::JYPCIe5112CoreOOReferenceClock


5112 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- f -

  • File_Format : JYPCIe5112CoreOO::AIRecord
  • FilePath : JYPCIe5112CoreOO::AIRecord
  • Filter : JYPCIe5112CoreOO::PFISetting
  • FirstInputTerminal : JYPCIe5112CoreOO::TwoEdgeSeparation
  • Flush() : JYPCIe5112CoreOO::JYPCIe5112CoreOOLog
  • FollowingException : JYPCIe5112CoreOO::JYDriverException
  • Frequency : JYPCIe5112CoreOO::CIExternalTimebase
  • FrequencyMeas : JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask


5112 C++ Programming Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • c
  • d
  • e
  • f
  • g
  • j
  • o
  • p
  • r
  • s
  • w
  • ~
Here is a list of all functions with links to the classes they belong to:

- a -

  • Add() : JYPCIe5112CoreOO::AISignalExport, JYPCIe5112CoreOO::AOSignalExport, JYPCIe5112CoreOO::CISignalExport, JYPCIe5112CoreOO::COSignalExport
  • AddChannel() : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask, JYPCIe5112CoreOO::JYPCIe5112CoreOODITask, JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask
  • AIChannel() : JYPCIe5112CoreOO::AIChannel
  • AOChannel() : JYPCIe5112CoreOO::AOChannel

- c -

  • Clear() : JYPCIe5112CoreOO::AISignalExport, JYPCIe5112CoreOO::AOSignalExport, JYPCIe5112CoreOO::CISignalExport, JYPCIe5112CoreOO::COSignalExport
  • ClearAll() : JYPCIe5112CoreOO::AISignalExport, JYPCIe5112CoreOO::AOSignalExport, JYPCIe5112CoreOO::CISignalExport, JYPCIe5112CoreOO::COSignalExport
  • Commit() : JYPCIe5112CoreOO::JYPCIe5112CoreOOReferenceClock
  • COPulse() : JYPCIe5112CoreOO::COPulse

- d -

  • Disable() : JYPCIe5112CoreOO::PFIFilter
  • DisableAll() : JYPCIe5112CoreOO::PFIFilter

- e -

  • Enable() : JYPCIe5112CoreOO::PFIFilter

- f -

  • Flush() : JYPCIe5112CoreOO::JYPCIe5112CoreOOLog

- g -

  • GetInstance() : JYPCIe5112CoreOO::JYPCIe5112CoreOODevice
  • GetRecordPreviewData() : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
  • GetRecordStatus() : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask

- j -

  • JYDriverException() : JYPCIe5112CoreOO::JYDriverException
  • JYPCIe5112CoreOOAITask() : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
  • JYPCIe5112CoreOOAOTask() : JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask
  • JYPCIe5112CoreOOCITask() : JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
  • JYPCIe5112CoreOOCOTask() : JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask
  • JYPCIe5112CoreOODITask() : JYPCIe5112CoreOO::JYPCIe5112CoreOODITask
  • JYPCIe5112CoreOODOTask() : JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask
  • JYPCIe5112CoreOOProperty() : JYPCIe5112CoreOO::JYPCIe5112CoreOOProperty< ContainerClass, ValueType, propertyType >

- o -

  • operator ValueType() : JYPCIe5112CoreOO::JYPCIe5112CoreOOProperty< ContainerClass, ValueType, propertyType >
  • operator=() : JYPCIe5112CoreOO::JYPCIe5112CoreOOProperty< ContainerClass, ValueType, propertyType >

- p -

  • Print() : JYPCIe5112CoreOO::JYPCIe5112CoreOOLog

- r -

  • ReadData() : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
  • ReadRawData() : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
  • ReadRawSinglePoint() : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
  • ReadSinglePoint() : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask, JYPCIe5112CoreOO::JYPCIe5112CoreOODITask
  • RemoveChannel() : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask, JYPCIe5112CoreOO::JYPCIe5112CoreOODITask, JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask

- s -

  • SendSoftwareTrigger() : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask
  • Start() : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask, JYPCIe5112CoreOO::JYPCIe5112CoreOODITask, JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask
  • Stop() : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask, JYPCIe5112CoreOO::JYPCIe5112CoreOODITask, JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask

- w -

  • WaitUntilDone() : JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask
  • WriteData() : JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask
  • WriteRawData() : JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask
  • WriteRawSinglePoint() : JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask
  • WriteSinglePoint() : JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask, JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask

- ~ -

  • ~JYPCIe5112CoreOODITask() : JYPCIe5112CoreOO::JYPCIe5112CoreOODITask
  • ~JYPCIe5112CoreOODOTask() : JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask


5112 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- g -

  • GetInstance() : JYPCIe5112CoreOO::JYPCIe5112CoreOODevice
  • GetRecordPreviewData() : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
  • GetRecordStatus() : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask


5112 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- h -

  • Handle : JYPCIe5112CoreOO::JYPCIe5112CoreOODevice
  • HighThreshold : JYPCIe5112CoreOO::AIAnalogHysteresisComparator, JYPCIe5112CoreOO::AIAnalogWindowComparator
  • Hysteresis : JYPCIe5112CoreOO::AIAnalogTrigger


5112 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- i -

  • IdleState : JYPCIe5112CoreOO::EdgeCountingOutEvent, JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask
  • Implicit : JYPCIe5112CoreOO::CISampleClock
  • InitialCount : JYPCIe5112CoreOO::EdgeCounting, JYPCIe5112CoreOO::QuadEncoder, JYPCIe5112CoreOO::TwoPulseEncoder
  • InitialDelay : JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask
  • Input_Terminal : JYPCIe5112CoreOO::EdgeCounting, JYPCIe5112CoreOO::FrequencyMeas, JYPCIe5112CoreOO::PeriodMeas, JYPCIe5112CoreOO::PulseMeas, JYPCIe5112CoreOO::SemiPeriodMeas
  • Internal : JYPCIe5112CoreOO::CISampleClock
  • IsAISync : JYPCIe5112CoreOO::JYPCIe5112CoreOODevice
  • IsAOSync : JYPCIe5112CoreOO::JYPCIe5112CoreOODevice


5112 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- j -

  • JYDriverException() : JYPCIe5112CoreOO::JYDriverException
  • JYPCIe5112CoreOOAITask() : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
  • JYPCIe5112CoreOOAOTask() : JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask
  • JYPCIe5112CoreOOCITask() : JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
  • JYPCIe5112CoreOOCOTask() : JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask
  • JYPCIe5112CoreOODITask() : JYPCIe5112CoreOO::JYPCIe5112CoreOODITask
  • JYPCIe5112CoreOODOTask() : JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask
  • JYPCIe5112CoreOOProperty() : JYPCIe5112CoreOO::JYPCIe5112CoreOOProperty< ContainerClass, ValueType, propertyType >


5112 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- l -

  • Length : JYPCIe5112CoreOO::AIRecord
  • LineCountPerPort : JYPCIe5112CoreOO::JYPCIe5112CoreOODevice
  • LogLevel : JYPCIe5112CoreOO::JYPCIe5112CoreOOLog
  • LowThreshold : JYPCIe5112CoreOO::AIAnalogHysteresisComparator, JYPCIe5112CoreOO::AIAnalogWindowComparator


5112 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- m -

  • MaxSampleRateMutilChannel : JYPCIe5112CoreOO::JYPCIe5112CoreOODevice
  • MaxSampleRateSingleChannel : JYPCIe5112CoreOO::JYPCIe5112CoreOODevice
  • MaxUpdateRate : JYPCIe5112CoreOO::JYPCIe5112CoreOODevice
  • MaxUpdateRateSingleChannel : JYPCIe5112CoreOO::JYPCIe5112CoreOODevice
  • Mode : JYPCIe5112CoreOO::AIRecord, JYPCIe5112CoreOO::AITrigger, JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask


5112 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- o -

  • operator ValueType() : JYPCIe5112CoreOO::JYPCIe5112CoreOOProperty< ContainerClass, ValueType, propertyType >
  • operator=() : JYPCIe5112CoreOO::JYPCIe5112CoreOOProperty< ContainerClass, ValueType, propertyType >
  • OutEvent : JYPCIe5112CoreOO::EdgeCounting
  • Output_State : JYPCIe5112CoreOO::PauseTrigger
  • OutputTerminal : JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask


5112 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- p -

  • Pause : JYPCIe5112CoreOO::EdgeCounting, JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask
  • PeriodMeas : JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
  • PFI : JYPCIe5112CoreOO::JYPCIe5112CoreOODevice
  • PortNum : JYPCIe5112CoreOO::DIChannel, JYPCIe5112CoreOO::DOChannel
  • PowerLineFrequency : JYPCIe5112CoreOO::AIDSMode
  • PreTriggerSamples : JYPCIe5112CoreOO::AITrigger
  • Print() : JYPCIe5112CoreOO::JYPCIe5112CoreOOLog
  • PulseMeas : JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask


5112 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- q -

  • QuadEncoder : JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask


5112 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- r -

  • RangeHigh : JYPCIe5112CoreOO::AIChannel, JYPCIe5112CoreOO::AOChannel
  • RangeLow : JYPCIe5112CoreOO::AIChannel, JYPCIe5112CoreOO::AOChannel
  • Rate : JYPCIe5112CoreOO::CIInternalSampleClock
  • ReadData() : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
  • ReadRawData() : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
  • ReadRawSinglePoint() : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
  • ReadSinglePoint() : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask, JYPCIe5112CoreOO::JYPCIe5112CoreOODITask
  • Record : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
  • ReferenceClock : JYPCIe5112CoreOO::JYPCIe5112CoreOODevice
  • RemoveChannel() : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask, JYPCIe5112CoreOO::JYPCIe5112CoreOODITask, JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask
  • ReTriggerCount : JYPCIe5112CoreOO::AITrigger


5112 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- s -

  • SampleClock : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
  • SampleRate : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
  • SamplesToAcquire : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
  • SamplesToUpdate : JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask
  • SEChannelCount : JYPCIe5112CoreOO::JYPCIe5112CoreOODevice
  • SecondInputTerminal : JYPCIe5112CoreOO::TwoEdgeSeparation
  • SemiPeriodMeas : JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
  • SendSoftwareTrigger() : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask
  • SerialNumber : JYPCIe5112CoreOO::JYPCIe5112CoreOODevice
  • SignalExport : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask
  • Slope : JYPCIe5112CoreOO::AIAnalogEdgeComparator, JYPCIe5112CoreOO::AIAnalogHysteresisComparator
  • Source : JYPCIe5112CoreOO::AIAnalogTrigger, JYPCIe5112CoreOO::AIDigitalTrigger, JYPCIe5112CoreOO::AISampleClock, JYPCIe5112CoreOO::AODigitalTrigger, JYPCIe5112CoreOO::AOSampleClock, JYPCIe5112CoreOO::CIDigitalTrigger, JYPCIe5112CoreOO::CISampleClock, JYPCIe5112CoreOO::CITimebase, JYPCIe5112CoreOO::CODigitalTrigger, JYPCIe5112CoreOO::COTimebase, JYPCIe5112CoreOO::JYPCIe5112CoreOOReferenceClock
  • Start() : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask, JYPCIe5112CoreOO::JYPCIe5112CoreOODITask, JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask
  • StartingEdge : JYPCIe5112CoreOO::PulseMeas, JYPCIe5112CoreOO::SemiPeriodMeas
  • Stop() : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask, JYPCIe5112CoreOO::JYPCIe5112CoreOODITask, JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask


5112 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- t -

  • Terminal : JYPCIe5112CoreOO::AIChannel, JYPCIe5112CoreOO::AIExternalSampleClock, JYPCIe5112CoreOO::AOExternalSampleClock, JYPCIe5112CoreOO::CIExternalSampleClock, JYPCIe5112CoreOO::CIExternalTimebase, JYPCIe5112CoreOO::EdgeCountingOutEvent, JYPCIe5112CoreOO::ExternalReferenceClock, JYPCIe5112CoreOO::PauseTrigger
  • Threshold : JYPCIe5112CoreOO::AIAnalogEdgeComparator, JYPCIe5112CoreOO::EdgeCountingOutEvent
  • TimeBase : JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask
  • Timebase : JYPCIe5112CoreOO::FrequencyMeas, JYPCIe5112CoreOO::PeriodMeas, JYPCIe5112CoreOO::PulseMeas, JYPCIe5112CoreOO::SemiPeriodMeas, JYPCIe5112CoreOO::TwoEdgeSeparation
  • TransferedSamples : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
  • Trigger : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask
  • TwoEdgeSeparation : JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
  • TwoPulseEncoder : JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
  • Type : JYPCIe5112CoreOO::AITrigger, JYPCIe5112CoreOO::AOTrigger, JYPCIe5112CoreOO::CITrigger, JYPCIe5112CoreOO::COTrigger, JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask


5112 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- u -

  • UpdateRate : JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask


5112 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- a -

  • ActiveEdge : JYPCIe5112CoreOO::EdgeCounting
  • ActivePolarity : JYPCIe5112CoreOO::PauseTrigger
  • Advanced : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
  • AIBufferSize : JYPCIe5112CoreOO::JYPCIe5112CoreOODevice
  • AInputTerminal : JYPCIe5112CoreOO::QuadEncoder, JYPCIe5112CoreOO::TwoPulseEncoder
  • Analog : JYPCIe5112CoreOO::AITrigger
  • AOChannelCount : JYPCIe5112CoreOO::JYPCIe5112CoreOODevice
  • AvailableSamples : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
  • AvaliableLenInSamples : JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask

- b -

  • BInputTerminal : JYPCIe5112CoreOO::QuadEncoder, JYPCIe5112CoreOO::TwoPulseEncoder
  • BoardClockRate : JYPCIe5112CoreOO::JYPCIe5112CoreOODevice
  • BufLenInSamples : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask

- c -

  • ChannelID : JYPCIe5112CoreOO::AIChannel, JYPCIe5112CoreOO::AOChannel
  • Channels : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask, JYPCIe5112CoreOO::JYPCIe5112CoreOODITask, JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask
  • Comparator : JYPCIe5112CoreOO::AIAnalogTrigger
  • CompleteState : JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask
  • Condition : JYPCIe5112CoreOO::AIAnalogWindowComparator
  • ConvertRate : JYPCIe5112CoreOO::AIAdvanced

- d -

  • Device : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask, JYPCIe5112CoreOO::JYPCIe5112CoreOODITask, JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask
  • DeviceID : JYPCIe5112CoreOO::JYPCIe5112CoreOODevice
  • DiffChannelCount : JYPCIe5112CoreOO::JYPCIe5112CoreOODevice
  • Digital : JYPCIe5112CoreOO::AITrigger, JYPCIe5112CoreOO::AOTrigger, JYPCIe5112CoreOO::CITrigger, JYPCIe5112CoreOO::COTrigger
  • Direction : JYPCIe5112CoreOO::EdgeCounting
  • DirTerminal : JYPCIe5112CoreOO::EdgeCounting
  • DisableCalibration : JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask
  • DSMode : JYPCIe5112CoreOO::AIAdvanced

- e -

  • Edge : JYPCIe5112CoreOO::AIAnalogTrigger, JYPCIe5112CoreOO::AIDigitalTrigger, JYPCIe5112CoreOO::AODigitalTrigger, JYPCIe5112CoreOO::CIDigitalTrigger, JYPCIe5112CoreOO::CODigitalTrigger
  • EdgeCounting : JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
  • EdgeSeparationMode : JYPCIe5112CoreOO::TwoEdgeSeparation
  • Enable : JYPCIe5112CoreOO::AIDSMode
  • EnableLog : JYPCIe5112CoreOO::JYPCIe5112CoreOOLog
  • EncodingType : JYPCIe5112CoreOO::QuadEncoder
  • errorCode : JYPCIe5112CoreOO::JYDriverException
  • exceptionMessage : JYPCIe5112CoreOO::JYDriverException
  • ExpectedRate : JYPCIe5112CoreOO::AIExternalSampleClock, JYPCIe5112CoreOO::AOExternalSampleClock, JYPCIe5112CoreOO::CIExternalSampleClock, JYPCIe5112CoreOO::CIImplicitSampleClock
  • External : JYPCIe5112CoreOO::AISampleClock, JYPCIe5112CoreOO::AOSampleClock, JYPCIe5112CoreOO::CISampleClock, JYPCIe5112CoreOO::CITimebase, JYPCIe5112CoreOO::JYPCIe5112CoreOOReferenceClock

- f -

  • File_Format : JYPCIe5112CoreOO::AIRecord
  • FilePath : JYPCIe5112CoreOO::AIRecord
  • Filter : JYPCIe5112CoreOO::PFISetting
  • FirstInputTerminal : JYPCIe5112CoreOO::TwoEdgeSeparation
  • FollowingException : JYPCIe5112CoreOO::JYDriverException
  • Frequency : JYPCIe5112CoreOO::CIExternalTimebase
  • FrequencyMeas : JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask

- h -

  • Handle : JYPCIe5112CoreOO::JYPCIe5112CoreOODevice
  • HighThreshold : JYPCIe5112CoreOO::AIAnalogHysteresisComparator, JYPCIe5112CoreOO::AIAnalogWindowComparator
  • Hysteresis : JYPCIe5112CoreOO::AIAnalogTrigger

- i -

  • IdleState : JYPCIe5112CoreOO::EdgeCountingOutEvent, JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask
  • Implicit : JYPCIe5112CoreOO::CISampleClock
  • InitialCount : JYPCIe5112CoreOO::EdgeCounting, JYPCIe5112CoreOO::QuadEncoder, JYPCIe5112CoreOO::TwoPulseEncoder
  • InitialDelay : JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask
  • Input_Terminal : JYPCIe5112CoreOO::EdgeCounting, JYPCIe5112CoreOO::FrequencyMeas, JYPCIe5112CoreOO::PeriodMeas, JYPCIe5112CoreOO::PulseMeas, JYPCIe5112CoreOO::SemiPeriodMeas
  • Internal : JYPCIe5112CoreOO::CISampleClock
  • IsAISync : JYPCIe5112CoreOO::JYPCIe5112CoreOODevice
  • IsAOSync : JYPCIe5112CoreOO::JYPCIe5112CoreOODevice

- l -

  • Length : JYPCIe5112CoreOO::AIRecord
  • LineCountPerPort : JYPCIe5112CoreOO::JYPCIe5112CoreOODevice
  • LogLevel : JYPCIe5112CoreOO::JYPCIe5112CoreOOLog
  • LowThreshold : JYPCIe5112CoreOO::AIAnalogHysteresisComparator, JYPCIe5112CoreOO::AIAnalogWindowComparator

- m -

  • MaxSampleRateMutilChannel : JYPCIe5112CoreOO::JYPCIe5112CoreOODevice
  • MaxSampleRateSingleChannel : JYPCIe5112CoreOO::JYPCIe5112CoreOODevice
  • MaxUpdateRate : JYPCIe5112CoreOO::JYPCIe5112CoreOODevice
  • MaxUpdateRateSingleChannel : JYPCIe5112CoreOO::JYPCIe5112CoreOODevice
  • Mode : JYPCIe5112CoreOO::AIRecord, JYPCIe5112CoreOO::AITrigger, JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask

- o -

  • OutEvent : JYPCIe5112CoreOO::EdgeCounting
  • Output_State : JYPCIe5112CoreOO::PauseTrigger
  • OutputTerminal : JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask

- p -

  • Pause : JYPCIe5112CoreOO::EdgeCounting, JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask
  • PeriodMeas : JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
  • PFI : JYPCIe5112CoreOO::JYPCIe5112CoreOODevice
  • PortNum : JYPCIe5112CoreOO::DIChannel, JYPCIe5112CoreOO::DOChannel
  • PowerLineFrequency : JYPCIe5112CoreOO::AIDSMode
  • PreTriggerSamples : JYPCIe5112CoreOO::AITrigger
  • PulseMeas : JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask

- q -

  • QuadEncoder : JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask

- r -

  • RangeHigh : JYPCIe5112CoreOO::AIChannel, JYPCIe5112CoreOO::AOChannel
  • RangeLow : JYPCIe5112CoreOO::AIChannel, JYPCIe5112CoreOO::AOChannel
  • Rate : JYPCIe5112CoreOO::CIInternalSampleClock
  • Record : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
  • ReferenceClock : JYPCIe5112CoreOO::JYPCIe5112CoreOODevice
  • ReTriggerCount : JYPCIe5112CoreOO::AITrigger

- s -

  • SampleClock : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
  • SampleRate : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask
  • SamplesToAcquire : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
  • SamplesToUpdate : JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask
  • SEChannelCount : JYPCIe5112CoreOO::JYPCIe5112CoreOODevice
  • SecondInputTerminal : JYPCIe5112CoreOO::TwoEdgeSeparation
  • SemiPeriodMeas : JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
  • SerialNumber : JYPCIe5112CoreOO::JYPCIe5112CoreOODevice
  • SignalExport : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask
  • Slope : JYPCIe5112CoreOO::AIAnalogEdgeComparator, JYPCIe5112CoreOO::AIAnalogHysteresisComparator
  • Source : JYPCIe5112CoreOO::AIAnalogTrigger, JYPCIe5112CoreOO::AIDigitalTrigger, JYPCIe5112CoreOO::AISampleClock, JYPCIe5112CoreOO::AODigitalTrigger, JYPCIe5112CoreOO::AOSampleClock, JYPCIe5112CoreOO::CIDigitalTrigger, JYPCIe5112CoreOO::CISampleClock, JYPCIe5112CoreOO::CITimebase, JYPCIe5112CoreOO::CODigitalTrigger, JYPCIe5112CoreOO::COTimebase, JYPCIe5112CoreOO::JYPCIe5112CoreOOReferenceClock
  • StartingEdge : JYPCIe5112CoreOO::PulseMeas, JYPCIe5112CoreOO::SemiPeriodMeas

- t -

  • Terminal : JYPCIe5112CoreOO::AIChannel, JYPCIe5112CoreOO::AIExternalSampleClock, JYPCIe5112CoreOO::AOExternalSampleClock, JYPCIe5112CoreOO::CIExternalSampleClock, JYPCIe5112CoreOO::CIExternalTimebase, JYPCIe5112CoreOO::EdgeCountingOutEvent, JYPCIe5112CoreOO::ExternalReferenceClock, JYPCIe5112CoreOO::PauseTrigger
  • Threshold : JYPCIe5112CoreOO::AIAnalogEdgeComparator, JYPCIe5112CoreOO::EdgeCountingOutEvent
  • TimeBase : JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask
  • Timebase : JYPCIe5112CoreOO::FrequencyMeas, JYPCIe5112CoreOO::PeriodMeas, JYPCIe5112CoreOO::PulseMeas, JYPCIe5112CoreOO::SemiPeriodMeas, JYPCIe5112CoreOO::TwoEdgeSeparation
  • TransferedSamples : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
  • Trigger : JYPCIe5112CoreOO::JYPCIe5112CoreOOAITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask
  • TwoEdgeSeparation : JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
  • TwoPulseEncoder : JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask
  • Type : JYPCIe5112CoreOO::AITrigger, JYPCIe5112CoreOO::AOTrigger, JYPCIe5112CoreOO::CITrigger, JYPCIe5112CoreOO::COTrigger, JYPCIe5112CoreOO::JYPCIe5112CoreOOCITask

- u -

  • UpdateRate : JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask

- w -

  • Window : JYPCIe5112CoreOO::AIAnalogTrigger

- z -

  • ZInputTerminal : JYPCIe5112CoreOO::QuadEncoder
  • ZReloadEnabled : JYPCIe5112CoreOO::QuadEncoder


5112 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- w -

  • WaitUntilDone() : JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask
  • Window : JYPCIe5112CoreOO::AIAnalogTrigger
  • WriteData() : JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask
  • WriteRawData() : JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask
  • WriteRawSinglePoint() : JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask
  • WriteSinglePoint() : JYPCIe5112CoreOO::JYPCIe5112CoreOOAOTask, JYPCIe5112CoreOO::JYPCIe5112CoreOOCOTask, JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask


5112 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- z -

  • ZInputTerminal : JYPCIe5112CoreOO::QuadEncoder
  • ZReloadEnabled : JYPCIe5112CoreOO::QuadEncoder


5112 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- ~ -

  • ~JYPCIe5112CoreOODITask() : JYPCIe5112CoreOO::JYPCIe5112CoreOODITask
  • ~JYPCIe5112CoreOODOTask() : JYPCIe5112CoreOO::JYPCIe5112CoreOODOTask


5112 C++ Programming Manual: File Members

  • File List
  • File Members
  • All
  • Macros
Here is a list of all file members with links to the files they belong to:
  • EXTERN_C : JYPCIe5112CoreOOCommon.h
  • JYPCIe5112CoreOO_API : JYPCIe5112CoreOOCommon.h


5112 C++ Programming Manual: File Members

  • File List
  • File Members
  • All
  • Macros
Here is a list of all macros with links to the files they belong to:
  • EXTERN_C : JYPCIe5112CoreOOCommon.h
  • JYPCIe5112CoreOO_API : JYPCIe5112CoreOOCommon.h


5112 C++ Programming Manual: Main Page

5112 C++ Programming Manual Documentation


5112 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • a
  • c
  • e
  • f
  • g
  • i
  • j
  • l
  • o
  • p
  • q
  • r
  • s
  • v
Here is a list of all namespace members with links to the namespace documentation for each member:

- a -

  • AIAnalogTriggerComparator : JYPCIe5112CoreOO
  • AIAnalogTriggerEdge : JYPCIe5112CoreOO
  • AIAnalogTriggerSource : JYPCIe5112CoreOO
  • AIAnalogWindowCondition : JYPCIe5112CoreOO
  • AIDigitalTriggerEdge : JYPCIe5112CoreOO
  • AIDigitalTriggerSource : JYPCIe5112CoreOO
  • AIMode : JYPCIe5112CoreOO
  • AISampleClockSource : JYPCIe5112CoreOO
  • AISignalExportSource : JYPCIe5112CoreOO
  • AITerminal : JYPCIe5112CoreOO
  • AITriggerMode : JYPCIe5112CoreOO
  • AITriggerType : JYPCIe5112CoreOO
  • AODigitalTriggerEdge : JYPCIe5112CoreOO
  • AODigitalTriggerSource : JYPCIe5112CoreOO
  • AOMode : JYPCIe5112CoreOO
  • AOSampleClockSource : JYPCIe5112CoreOO
  • AOSignalExportSource : JYPCIe5112CoreOO
  • AOTriggerType : JYPCIe5112CoreOO

- c -

  • CIDigitalTriggerEdge : JYPCIe5112CoreOO
  • CIDigitalTriggerSource : JYPCIe5112CoreOO
  • CISampleClockSource : JYPCIe5112CoreOO
  • CISignalExportSource : JYPCIe5112CoreOO
  • CITimebaseSource : JYPCIe5112CoreOO
  • CITriggerType : JYPCIe5112CoreOO
  • CIType : JYPCIe5112CoreOO
  • ClockTerminal : JYPCIe5112CoreOO
  • CODigitalTriggerEdge : JYPCIe5112CoreOO
  • CODigitalTriggerSource : JYPCIe5112CoreOO
  • COIdleState : JYPCIe5112CoreOO
  • COMode : JYPCIe5112CoreOO
  • COPulseType : JYPCIe5112CoreOO
  • COSignalExportSource : JYPCIe5112CoreOO
  • COTimebaseSource : JYPCIe5112CoreOO
  • COTriggerType : JYPCIe5112CoreOO
  • CountDirection : JYPCIe5112CoreOO

- e -

  • EdgeCntOunEvtIdleState : JYPCIe5112CoreOO
  • EdgeType : JYPCIe5112CoreOO
  • ExternalReferenceClockTerminal : JYPCIe5112CoreOO

- f -

  • FileFormat : JYPCIe5112CoreOO

- g -

  • GetSignalExportDestinationString() : JYPCIe5112CoreOO

- i -

  • InputTerminal : JYPCIe5112CoreOO
  • IOTerminal : JYPCIe5112CoreOO

- j -

  • JYDriverExceptionPublic : JYPCIe5112CoreOO
  • JYPCIe5112CoreOOLogLevel : JYPCIe5112CoreOO
  • JYPCIe5112CoreOOPropertyType : JYPCIe5112CoreOO

- l -

  • LevelPolarity : JYPCIe5112CoreOO

- o -

  • OutputCompleteState : JYPCIe5112CoreOO
  • OutputState : JYPCIe5112CoreOO

- p -

  • PFITerminal : JYPCIe5112CoreOO
  • PowerLineFrequency : JYPCIe5112CoreOO

- q -

  • QuadEncodingType : JYPCIe5112CoreOO

- r -

  • RecordMode : JYPCIe5112CoreOO
  • ReferenceClockSource : JYPCIe5112CoreOO

- s -

  • SignalExportDestination : JYPCIe5112CoreOO

- v -

  • ValueReturnMode : JYPCIe5112CoreOO


5112 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • a
  • c
  • e
  • f
  • i
  • j
  • l
  • o
  • p
  • q
  • r
  • s
  • v
Here is a list of all namespace enums with links to the namespace documentation for each enum:

- a -

  • AIAnalogTriggerComparator : JYPCIe5112CoreOO
  • AIAnalogTriggerEdge : JYPCIe5112CoreOO
  • AIAnalogTriggerSource : JYPCIe5112CoreOO
  • AIAnalogWindowCondition : JYPCIe5112CoreOO
  • AIDigitalTriggerEdge : JYPCIe5112CoreOO
  • AIDigitalTriggerSource : JYPCIe5112CoreOO
  • AIMode : JYPCIe5112CoreOO
  • AISampleClockSource : JYPCIe5112CoreOO
  • AISignalExportSource : JYPCIe5112CoreOO
  • AITerminal : JYPCIe5112CoreOO
  • AITriggerMode : JYPCIe5112CoreOO
  • AITriggerType : JYPCIe5112CoreOO
  • AODigitalTriggerEdge : JYPCIe5112CoreOO
  • AODigitalTriggerSource : JYPCIe5112CoreOO
  • AOMode : JYPCIe5112CoreOO
  • AOSampleClockSource : JYPCIe5112CoreOO
  • AOSignalExportSource : JYPCIe5112CoreOO
  • AOTriggerType : JYPCIe5112CoreOO

- c -

  • CIDigitalTriggerEdge : JYPCIe5112CoreOO
  • CIDigitalTriggerSource : JYPCIe5112CoreOO
  • CISampleClockSource : JYPCIe5112CoreOO
  • CISignalExportSource : JYPCIe5112CoreOO
  • CITimebaseSource : JYPCIe5112CoreOO
  • CITriggerType : JYPCIe5112CoreOO
  • CIType : JYPCIe5112CoreOO
  • ClockTerminal : JYPCIe5112CoreOO
  • CODigitalTriggerEdge : JYPCIe5112CoreOO
  • CODigitalTriggerSource : JYPCIe5112CoreOO
  • COIdleState : JYPCIe5112CoreOO
  • COMode : JYPCIe5112CoreOO
  • COPulseType : JYPCIe5112CoreOO
  • COSignalExportSource : JYPCIe5112CoreOO
  • COTimebaseSource : JYPCIe5112CoreOO
  • COTriggerType : JYPCIe5112CoreOO
  • CountDirection : JYPCIe5112CoreOO

- e -

  • EdgeCntOunEvtIdleState : JYPCIe5112CoreOO
  • EdgeType : JYPCIe5112CoreOO
  • ExternalReferenceClockTerminal : JYPCIe5112CoreOO

- f -

  • FileFormat : JYPCIe5112CoreOO

- i -

  • InputTerminal : JYPCIe5112CoreOO
  • IOTerminal : JYPCIe5112CoreOO

- j -

  • JYDriverExceptionPublic : JYPCIe5112CoreOO
  • JYPCIe5112CoreOOLogLevel : JYPCIe5112CoreOO
  • JYPCIe5112CoreOOPropertyType : JYPCIe5112CoreOO

- l -

  • LevelPolarity : JYPCIe5112CoreOO

- o -

  • OutputCompleteState : JYPCIe5112CoreOO
  • OutputState : JYPCIe5112CoreOO

- p -

  • PFITerminal : JYPCIe5112CoreOO
  • PowerLineFrequency : JYPCIe5112CoreOO

- q -

  • QuadEncodingType : JYPCIe5112CoreOO

- r -

  • RecordMode : JYPCIe5112CoreOO
  • ReferenceClockSource : JYPCIe5112CoreOO

- s -

  • SignalExportDestination : JYPCIe5112CoreOO

- v -

  • ValueReturnMode : JYPCIe5112CoreOO


5112 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
Here is a list of all namespace functions with links to the namespace documentation for each function:
  • GetSignalExportDestinationString() : JYPCIe5112CoreOO


5112 C++ Programming Manual: Namespace List

  • Namespace List
  • Namespace Members
Namespace List
Here is a list of all namespaces with brief descriptions:
N JYPCIe5112CoreOO