5112 C# Programming Manual: D:/5112/C# Directory Reference

5112 C# Programming Manual
  • Main Page
  • Packages
  • Classes
  • Files
  • File List
  • 5112
  • C#
C# Directory Reference

Files

JYPCIe5112AITask.cs
JYPCIe5112AOTask.cs
JYPCIe5112CITask.cs
JYPCIe5112COTask.cs
JYPCIe5112DITask.cs
JYPCIe5112DOTask.cs
Generated by doxygen 1.12.0


5112 C# Programming Manual: D:/5112/C#/JYPCIe5112AITask.cs File Reference

  • Packages
  • Classes
  • Files
  • File List
  • 5112
  • C#
Classes | Namespaces | Enumerations
JYPCIe5112AITask.cs File Reference

Classes

class | JYPCIe5112.JYPCIe5112AITask
JYPCIe5112 Analog Input Task. More...
class | JYPCIe5112.AIChannel
AI Channel parameter class . More...
class | JYPCIe5112.AISampleClock
Sample clock configuration class. More...
class | JYPCIe5112.AIExternalSampleClock
External Sample Clock Configuration Class. More...
class | JYPCIe5112.AITrigger
Constructor to create an AITrigger task object. More...
class | JYPCIe5112.AIDigitalTrigger
AI Digital trigger class. More...
class | JYPCIe5112.AIAnalogTrigger
AI analog trigger . More...
class | JYPCIe5112.AIAnalogHysteresisComparator
AI Analog Hysteresis Comparatorr. More...
class | JYPCIe5112.AIAnalogWindowComparator
AI Analog Window Comparatorr. More...
class | JYPCIe5112.AIAnalogEdgeComparator
AI Analog Edge Comparator. More...
class | JYPCIe5112.AIRecord
AI Record Parameters. More...
class | JYPCIe5112.AIAdvanced
AI Advance parameter. More...
class | JYPCIe5112.AISignalExport
AI Signal Export Class. More...

Namespaces

namespace JYPCIe5112

Enumerations

enum | JYPCIe5112.AITriggerType { JYPCIe5112.Immediate = JYPCIe5112Import.JYPCIe5112_TriggerType_Immediately , JYPCIe5112.Digital = JYPCIe5112Import.JYPCIe5112_TriggerType_Digital , JYPCIe5112.Analog = JYPCIe5112Import.JYPCIe5112_TriggerType_Analog , JYPCIe5112.Soft = JYPCIe5112Import.JYPCIe5112_TriggerType_Soft }
Trigger Type Digital/Analog/Immediate/Soft. More...
enum | JYPCIe5112.AIDigitalTriggerEdge { JYPCIe5112.Rising = JYPCIe5112Import.JYPCIe5112_DigitalTriggerEdge_Rising , JYPCIe5112.Falling = JYPCIe5112Import.JYPCIe5112_DigitalTriggerEdge_Falling }
AI Digital Trigger Edge. More...
enum | JYPCIe5112.AIMode { JYPCIe5112.Single = JYPCIe5112Import.JYPCIe5112_AI_Single , JYPCIe5112.Finite = JYPCIe5112Import.JYPCIe5112_AI_Finite , JYPCIe5112.Continuous = JYPCIe5112Import.JYPCIe5112_AI_Continuous , JYPCIe5112.Record = 0x3 }
AIMode. More...
enum | JYPCIe5112.AITerminal { JYPCIe5112.RSE = JYPCIe5112Import.JYPCIe5112_AI_RSE , JYPCIe5112.NRSE = JYPCIe5112Import.JYPCIe5112_AI_NRSE , JYPCIe5112.Differential = JYPCIe5112Import.JYPCIe5112_AI_Diff }
AITerminal. More...
enum | JYPCIe5112.AISampleClockSource { JYPCIe5112.Internal , JYPCIe5112.External }
AI Sample Clock Source. More...
enum JYPCIe5112.ClockTerminal {
JYPCIe5112.PFI0 = 0 , JYPCIe5112.PFI1 = 1 , JYPCIe5112.PFI2 = 2 , JYPCIe5112.PFI3 = 3 ,
JYPCIe5112.PFI4 = 4 , JYPCIe5112.PFI5 = 5 , JYPCIe5112.PFI6 = 6 , JYPCIe5112.PFI7 = 7 ,
JYPCIe5112.PFI8 = 8 , JYPCIe5112.PFI9 = 9 , JYPCIe5112.PFI10 = 10 , JYPCIe5112.PFI11 = 11 ,
JYPCIe5112.PFI12 = 12 , JYPCIe5112.PFI13 = 13 , JYPCIe5112.PFI14 = 14 , JYPCIe5112.PFI15 = 15 ,
JYPCIe5112.PXI_Trig0 = 16 , JYPCIe5112.PXI_Trig1 = 17 , JYPCIe5112.PXI_Trig2 = 18 , JYPCIe5112.PXI_Trig3 = 19 ,
JYPCIe5112.PXI_Trig4 = 20 , JYPCIe5112.PXI_Trig5 = 21 , JYPCIe5112.PXI_Trig6 = 22 , JYPCIe5112.PXI_Trig7 = 23 ,
JYPCIe5112.AI_SampleClock = 24 , JYPCIe5112.AO_SampleClock = 25 , JYPCIe5112.CO0_Output = 26 , JYPCIe5112.CO1_Output = 27 ,
JYPCIe5112.ECLK = 28
}
Clock Terminal. More...
enum | JYPCIe5112.AITriggerMode { JYPCIe5112.Start , JYPCIe5112.Reference }
AI Trigger Mode. More...
enum JYPCIe5112.AIAnalogTriggerSource {
JYPCIe5112.Channel_0 , JYPCIe5112.Channel_1 , JYPCIe5112.Channel_2 , JYPCIe5112.Channel_3 ,
JYPCIe5112.Channel_4 , JYPCIe5112.Channel_5 , JYPCIe5112.Channel_6 , JYPCIe5112.Channel_7 ,
JYPCIe5112.Channel_8 , JYPCIe5112.Channel_9 , JYPCIe5112.Channel_10 , JYPCIe5112.Channel_11 ,
JYPCIe5112.Channel_12 , JYPCIe5112.Channel_13 , JYPCIe5112.Channel_14 , JYPCIe5112.Channel_15
}
AI analog trigger source. More...
enum JYPCIe5112.AIDigitalTriggerSource {
JYPCIe5112.PFI0 , JYPCIe5112.PFI1 , JYPCIe5112.PFI2 , JYPCIe5112.PFI3 ,
JYPCIe5112.PFI4 , JYPCIe5112.PFI5 , JYPCIe5112.PFI6 , JYPCIe5112.PFI7 ,
JYPCIe5112.PFI8 , JYPCIe5112.PFI9 , JYPCIe5112.PFI10 , JYPCIe5112.PFI11 ,
JYPCIe5112.PFI12 , JYPCIe5112.PFI13 , JYPCIe5112.PFI14 , JYPCIe5112.PFI15 ,
JYPCIe5112.PXI_Trig0 = 16 , JYPCIe5112.PXI_Trig1 = 17 , JYPCIe5112.PXI_Trig2 = 18 , JYPCIe5112.PXI_Trig3 = 19 ,
JYPCIe5112.PXI_Trig4 = 20 , JYPCIe5112.PXI_Trig5 = 21 , JYPCIe5112.PXI_Trig6 = 22 , JYPCIe5112.PXI_Trig7 = 23 ,
JYPCIe5112.AO_StartTrig = 26 , JYPCIe5112.CI0_StartTrig = 27 , JYPCIe5112.CI1_StartTrig = 28 , JYPCIe5112.CO0_Output = 29 ,
JYPCIe5112.CO1_Output = 30
}
AI Digital trigger source. More...
enum | JYPCIe5112.AIAnalogTriggerEdge { JYPCIe5112.Rising , JYPCIe5112.Falling }
AI Analog Trigger Edge. More...
enum | JYPCIe5112.AIAnalogWindowCondition { JYPCIe5112.Entering , JYPCIe5112.Leaving }
AI Analog Window Trigger Condition. More...
enum | JYPCIe5112.AIAnalogTriggerComparator { JYPCIe5112.Edge , JYPCIe5112.Hysteresis , JYPCIe5112.Window }
AI Analog Trigger Comparator. More...
enum | JYPCIe5112.AISignalExportSource { JYPCIe5112.StartTrig = 0 , JYPCIe5112.ReferenceTrig = 1 , JYPCIe5112.SampleClock = 5 }
AI Signal Export Source. More...
enum | JYPCIe5112.FileFormat { JYPCIe5112.Bin }
Streaming file format. More...
enum | JYPCIe5112.RecordMode { JYPCIe5112.Finite , JYPCIe5112.Infinite }
stream mode .enum Finite/Infinite More...
enum JYPCIe5112.SignalExportDestination {
JYPCIe5112.PFI0 , JYPCIe5112.PFI1 , JYPCIe5112.PFI2 , JYPCIe5112.PFI3 ,
JYPCIe5112.PFI4 , JYPCIe5112.PFI5 , JYPCIe5112.PFI6 , JYPCIe5112.PFI7 ,
JYPCIe5112.PFI8 , JYPCIe5112.PFI9 , JYPCIe5112.PFI10 , JYPCIe5112.PFI11 ,
JYPCIe5112.PFI12 , JYPCIe5112.PFI13 , JYPCIe5112.PFI14 , JYPCIe5112.PFI15 ,
JYPCIe5112.PXI_Trig0 , JYPCIe5112.PXI_Trig1 , JYPCIe5112.PXI_Trig2 , JYPCIe5112.PXI_Trig3 ,
JYPCIe5112.PXI_Trig4 , JYPCIe5112.PXI_Trig5 , JYPCIe5112.PXI_Trig6 , JYPCIe5112.PXI_Trig7
}
Output DestinationTerminal. More...


5112 C# Programming Manual: JYPCIe5112.JYPCIe5112AITask Class Reference

  • Class List
  • Class Index
  • Class Members
  • JYPCIe5112
  • JYPCIe5112AITask
Public Member Functions | Properties | List of all members
JYPCIe5112.JYPCIe5112AITask Class Referencesealed

JYPCIe5112 Analog Input Task. More...

Public Member Functions

JYPCIe5112AITask (int slotNum)
Constructor, Used to create an AI task by a slot number.
JYPCIe5112AITask (string boardName)
Constructor.
void | AddChannel (int chnId, double rangeLow=-10, double rangeHigh=10, AITerminal terminalCfg=AITerminal.RSE)
Add one channel.
void | AddChannel (int[] chnsId, double rangeLow=-10, double rangeHigh=10, AITerminal terminalCfg=AITerminal.RSE)
Add a group of channels.
void | AddChannel (int[] chnsId, double[] rangeLow, double[] rangeHigh, AITerminal terminalCfg=AITerminal.RSE)
Add a group of channels.
void | RemoveChannel (int chnId)
Delete the specified channel number.
void | ReadData (IntPtr buf, int samplesPerChannel, int timeout)
Read one or multi-channel data by columns and store it in a data buffer.
void | ReadData (ref double[,] buf, int samplesPerChannel, int timeout)
Read the multi-channel data by columns and store it in a data buffer.
void | ReadData (ref double[,] buf, int timeout=-1)
Read the multi-channel data by columns and store it in a data buffer.
void | ReadData (ref double[] buf, int samplesPerChannel, int timeout)
Read the one channel data and store it in a data buffer.
void | ReadData (ref double[] buf, int timeout=-1)
Read the one channel data and store it in a data buffer.
void | ReadRawData (IntPtr buf, int samplesPerChannel, int timeout)
Read one or multi-channel raw data by columns and store it in a data buffer.
void | ReadRawData (ref short[,] buf, int samplesPerChannel, int timeout)
Read the multi-channel raw data by columns and store it in a data buffer.
void | ReadRawData (ref short[,] buf, int timeout=-1)
Read the multi-channel raw data by columns and store it in a data buffer.
void | ReadRawData (ref short[] buf, int samplesPerChannel, int timeout)
Read the one channel raw data and store it in a data buffer.
void | ReadRawData (ref short[] buf, int timeout=-1)
Read the one channel raw data and store it in a data buffer.
void | GetRecordPreviewData (ref double[,] buf, int samplesPerChannel, int timeout)
Preview multi-channel data when streaming is in progress.
void | GetRecordPreviewData (ref double[,] buf, int timeout=-1)
Preview multi-channel data when streaming is in progress.
void | GetRecordPreviewData (ref double[] buf, int samplesPerChannel, int timeout)
Preview one channel data when streaming is in progress.
void | GetRecordPreviewData (ref double[] buf, int timeout=-1)
Preview one channel data when streaming is in progress.
void | ReadSinglePoint (ref double[] readValues)
Read one sample for all channels in register .
void | ReadSinglePoint (ref double readValue, int channel)
Read one sample for specified channel in register.
void | ReadRawSinglePoint (ref short[] readValues)
Read raw one sample for all channels in register .
void | ReadRawSinglePoint (ref short readValue, int channel)
Read raw one sample for specified channel in register.
void | GetRecordStatus (out double recordedLength, out bool recordDone)
get the streaming status.
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.
void | Start ()
Start AI task .
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Stop ()
Stop AI task .

Properties

List< AIChannel > | Channels [get]
List of AI channels,(5112 support16 SE/8 Diff channel)
AIMode | Mode [get, set]
AI acquisition mode，support Single/Finite/Continuous/Record.
double | SampleRate [get, set]
Sample rate per channel.
int | SamplesToAcquire [get, set]
Number of samples to be read per channel.
int | BufLenInSamples [get]
Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.
ulong | AvailableSamples [get]
Number of samples per channel that can be read in the buffer .
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel).
AISampleClock | SampleClock [get, set]
AI Sample Clock Configuration.
AITrigger | Trigger [get, set]
AI Trigger Configuration.
AIAdvanced | Advanced [get, set]
AI Advanced Configuration.
AIRecord | Record = new AIRecord() [get]
ai Data streaming Configuration
bool | DisableCalibration [get, set]
Disalble calibration Enable.
AISignalExport | SignalExport [get, set]
Export AI Signal Configuration.
JYPCIe5112Device | Device [get]
Device.

Detailed Description

JYPCIe5112 Analog Input Task.

Constructor & Destructor Documentation

◆ JYPCIe5112AITask() [1/2]

JYPCIe5112.JYPCIe5112AITask.JYPCIe5112AITask ( int slotNum )

Constructor, Used to create an AI task by a slot number.

Parameters
slotNum slot number.

◆ JYPCIe5112AITask() [2/2]

JYPCIe5112.JYPCIe5112AITask.JYPCIe5112AITask ( string boardName )

Constructor.

Used to create an AI task by a board name.

Parameters
boardName Board name(device alias), set by device manager

Member Function Documentation

◆ AddChannel() [1/3]

void JYPCIe5112.JYPCIe5112AITask.AddChannel | ( | int | chnId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10,
 |  | AITerminal | terminalCfg = AITerminal::RSE )

Add one channel.

Parameters
chnId | channel's physical number ，chnId=-1, add all channels。（5112 SE 0-16, Differential 0-7）
rangeLow | lower range limit for the channel，-10V, -5V, -2.5V, -1.25V, -0.625V defalut -10
rangeHigh | higher range limit for the channel，10V, 5V, 2.5V, 1.25V, 0.625Vdefalut 10
terminalCfg | terminal input mode configuration，RSE/NRSE/Differential.Default RSE

◆ AddChannel() [2/3]

void JYPCIe5112.JYPCIe5112AITask.AddChannel | ( | int[] | chnsId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10,
 |  | AITerminal | terminalCfg = AITerminal::RSE )

Add a group of channels.

Parameters
chnsId | channel's physical number (5112 SE 0-16, Differential 0-7）
rangeLow | lower range limit for the channel，-10V, -5V, -2.5V, -1.25V, -0.625V defalut -10
rangeHigh | higher range limit for the channel，10V, 5V, 2.5V, 1.25V, 0.625V defalut 10
terminalCfg | terminal input mode configuration，RSE/NRSE/Differential.Default RSE

◆ AddChannel() [3/3]

void JYPCIe5112.JYPCIe5112AITask.AddChannel | ( | int[] | chnsId,
 |  | double[] | rangeLow,
 |  | double[] | rangeHigh,
 |  | AITerminal | terminalCfg = AITerminal::RSE )

Add a group of channels.

Parameters
chnsId | channel's physical number ，chnId=-1, add all channels。(5112 SE 0-16, Differential 0-7）
rangeLow | lower range limit for the channel，-10V, -5V, -2.5V, -1.25V, -0.625V defalut -10
rangeHigh | higher range limit for the channel，10V, 5V, 2.5V, 1.25V, 0.625V,defalut 10
terminalCfg | terminal input mode configuration，RSE/NRSE/Differential.Default RSE

◆ GetRecordPreviewData() [1/4]

void JYPCIe5112.JYPCIe5112AITask.GetRecordPreviewData | ( | ref double | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout )

Preview multi-channel data when streaming is in progress.

Each column represents one channel.

Parameters
buf | Data buffer
samplesPerChannel | Number of preview samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ GetRecordPreviewData() [2/4]

void JYPCIe5112.JYPCIe5112AITask.GetRecordPreviewData | ( | ref double | buf[,],
 |  | int | timeout = -1 )

Preview multi-channel data when streaming is in progress.

Each column represents one channel.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ GetRecordPreviewData() [3/4]

void JYPCIe5112.JYPCIe5112AITask.GetRecordPreviewData | ( | ref double[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Preview one channel data when streaming is in progress.

Parameters
buf | Data buffer
samplesPerChannel | Number of preview samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ GetRecordPreviewData() [4/4]

void JYPCIe5112.JYPCIe5112AITask.GetRecordPreviewData | ( | ref double[] | buf,
 |  | int | timeout = -1 )

Preview one channel data when streaming is in progress.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ GetRecordStatus()

void JYPCIe5112.JYPCIe5112AITask.GetRecordStatus | ( | out double | recordedLength,
 |  | out bool | recordDone )

get the streaming status.

Available when Mode is AIMode.Record

Parameters
recordedLength | Length of the streamed
recordDone | recordDone = false :streaming is not over.recordDone = true :streaming is over.

◆ ReadData() [1/5]

void JYPCIe5112.JYPCIe5112AITask.ReadData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read one or multi-channel data by columns and store it in a data buffer.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel to read
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadData() [2/5]

void JYPCIe5112.JYPCIe5112AITask.ReadData | ( | ref double | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read the multi-channel data by columns and store it in a data buffer.

Each channel is represented by one column of data.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel to read
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadData() [3/5]

void JYPCIe5112.JYPCIe5112AITask.ReadData | ( | ref double | buf[,],
 |  | int | timeout = -1 )

Read the multi-channel data by columns and store it in a data buffer.

Each channel is represented by one column of data.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadData() [4/5]

void JYPCIe5112.JYPCIe5112AITask.ReadData | ( | ref double[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read the one channel data and store it in a data buffer.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel to read
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadData() [5/5]

void JYPCIe5112.JYPCIe5112AITask.ReadData | ( | ref double[] | buf,
 |  | int | timeout = -1 )

Read the one channel data and store it in a data buffer.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadRawData() [1/5]

void JYPCIe5112.JYPCIe5112AITask.ReadRawData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read one or multi-channel raw data by columns and store it in a data buffer.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel to read
timeout | timeout before generating error message, uint is ms。, timeout =-1 keep waiting until finish.

◆ ReadRawData() [2/5]

void JYPCIe5112.JYPCIe5112AITask.ReadRawData | ( | ref short | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read the multi-channel raw data by columns and store it in a data buffer.

Each channel is represented by one column of data.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel to read
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadRawData() [3/5]

void JYPCIe5112.JYPCIe5112AITask.ReadRawData | ( | ref short | buf[,],
 |  | int | timeout = -1 )

Read the multi-channel raw data by columns and store it in a data buffer.

Each channel is represented by one column of data.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadRawData() [4/5]

void JYPCIe5112.JYPCIe5112AITask.ReadRawData | ( | ref short[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read the one channel raw data and store it in a data buffer.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel to read
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadRawData() [5/5]

void JYPCIe5112.JYPCIe5112AITask.ReadRawData | ( | ref short[] | buf,
 |  | int | timeout = -1 )

Read the one channel raw data and store it in a data buffer.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadRawSinglePoint() [1/2]

void JYPCIe5112.JYPCIe5112AITask.ReadRawSinglePoint | ( | ref short | readValue,
 |  | int | channel )

Read raw one sample for specified channel in register.

Available when Mode is AIMode.Single

Parameters
readValue | value read
channel | Specified channel numbers.

◆ ReadRawSinglePoint() [2/2]

void JYPCIe5112.JYPCIe5112AITask.ReadRawSinglePoint ( ref short[] readValues )

Read raw one sample for all channels in register .

Available when Mode is AIMode.Single

Parameters
readValues Values read. Array length >= Channels.Count.

◆ ReadSinglePoint() [1/2]

void JYPCIe5112.JYPCIe5112AITask.ReadSinglePoint | ( | ref double | readValue,
 |  | int | channel )

Read one sample for specified channel in register.

Available when Mode is AIMode.Single

Parameters
readValue | value read
channel | Specified channel numbers.

◆ ReadSinglePoint() [2/2]

void JYPCIe5112.JYPCIe5112AITask.ReadSinglePoint ( ref double[] readValues )

Read one sample for all channels in register .

Available when Mode is AIMode.Single

Parameters
readValues Values read. Array length >= Channels.Count.

◆ RemoveChannel()

void JYPCIe5112.JYPCIe5112AITask.RemoveChannel ( int chnId )

Delete the specified channel number.

If it is -1, delete all channels.

Parameters
chnId Specified channel ID.

◆ SendSoftwareTrigger()

void JYPCIe5112.JYPCIe5112AITask.SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JYPCIe5112.JYPCIe5112AITask.Start ( )

Start AI task .

◆ Stop()

void JYPCIe5112.JYPCIe5112AITask.Stop ( )

Stop AI task .

◆ WaitUntilDone()

bool JYPCIe5112.JYPCIe5112AITask.WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

Property Documentation

◆ Advanced

AIAdvanced JYPCIe5112.JYPCIe5112AITask.Advanced
getset

AI Advanced Configuration.

◆ AvailableSamples

ulong JYPCIe5112.JYPCIe5112AITask.AvailableSamples
get

Number of samples per channel that can be read in the buffer .

Valid when Mode is NOT AIMode.Single.

◆ BufLenInSamples

int JYPCIe5112.JYPCIe5112AITask.BufLenInSamples
get

Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.

◆ Channels

List<AIChannel> JYPCIe5112.JYPCIe5112AITask.Channels
get

List of AI channels,(5112 support16 SE/8 Diff channel)

◆ Device

JYPCIe5112Device JYPCIe5112.JYPCIe5112AITask.Device
get

Device.

◆ DisableCalibration

bool JYPCIe5112.JYPCIe5112AITask.DisableCalibration
getset

Disalble calibration Enable.

◆ Mode

AIMode JYPCIe5112.JYPCIe5112AITask.Mode
getset

AI acquisition mode，support Single/Finite/Continuous/Record.

◆ Record

AIRecord JYPCIe5112.JYPCIe5112AITask.Record = new AIRecord()
get

ai Data streaming Configuration

◆ SampleClock

AISampleClock JYPCIe5112.JYPCIe5112AITask.SampleClock
getset

AI Sample Clock Configuration.

◆ SampleRate

double JYPCIe5112.JYPCIe5112AITask.SampleRate
getset

Sample rate per channel.

Maximum sample rate is 250K for single channel, 250K /N for multichannel (N) The defalut sample rate = 10k You can read this property to obtain the sample rate that will actually take effect in the current configuration.

◆ SamplesToAcquire

int JYPCIe5112.JYPCIe5112AITask.SamplesToAcquire
getset

Number of samples to be read per channel.

Only valid when Mode is AIMode.Finite.

◆ SignalExport

AISignalExport JYPCIe5112.JYPCIe5112AITask.SignalExport
getset

Export AI Signal Configuration.

◆ TransferedSamples

ulong JYPCIe5112.JYPCIe5112AITask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT AIMode.Single.

◆ Trigger

AITrigger JYPCIe5112.JYPCIe5112AITask.Trigger
getset

AI Trigger Configuration.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112AITask.cs


5112 C# Programming Manual: JYPCIe5112.AIChannel Class Reference

  • JYPCIe5112
  • AIChannel
Public Member Functions | Properties | List of all members
JYPCIe5112.AIChannel Class Referencesealed

AI Channel parameter class . More...

Public Member Functions

AIChannel (int channelId, double rangeLow, double rangeHigh, AITerminal terminalCfg=AITerminal.NRSE)
Constructor to create an AIChnParam task object.

Properties

int | ChannelID [get]
AI channel ID.
double | RangeLow [get, set]
Low range limit an AI channel.
double | RangeHigh [get, set]
High range limit an AI channel.
AITerminal | Terminal [get, set]
Configure AI terminal.

Detailed Description

AI Channel parameter class .

Constructor & Destructor Documentation

◆ AIChannel()

JYPCIe5112.AIChannel.AIChannel | ( | int | channelId,
 |  | double | rangeLow,
 |  | double | rangeHigh,
 |  | AITerminal | terminalCfg = AITerminal::NRSE )

Constructor to create an AIChnParam task object.

Parameters
channelId | AI channel ID.
rangeLow | Low range limit an AI channel.
rangeHigh | High range limit an AI channel.
terminalCfg | Configure AI terminal.

Property Documentation

◆ ChannelID

int JYPCIe5112.AIChannel.ChannelID
get

AI channel ID.

◆ RangeHigh

double JYPCIe5112.AIChannel.RangeHigh
getset

High range limit an AI channel.

◆ RangeLow

double JYPCIe5112.AIChannel.RangeLow
getset

Low range limit an AI channel.

◆ Terminal

AITerminal JYPCIe5112.AIChannel.Terminal
getset

Configure AI terminal.

(RSE,NRSE,Differential)

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112AITask.cs


5112 C# Programming Manual: JYPCIe5112.AISampleClock Class Reference

  • AISampleClock
Properties | List of all members
JYPCIe5112.AISampleClock Class Reference

Sample clock configuration class. More...

Properties

AISampleClockSource | Source [get, set]
AI Sample Clock Source.
AIExternalSampleClock | External [get, set]
External Sample Clock Configuration.

Detailed Description

Sample clock configuration class.

Property Documentation

◆ External

AIExternalSampleClock JYPCIe5112.AISampleClock.External
getset

External Sample Clock Configuration.

Valid when Source is AISampleClockSource.External.

◆ Source

AISampleClockSource JYPCIe5112.AISampleClock.Source
getset

AI Sample Clock Source.

enum Internal/External. The default value is AISampleClockSource.Internal.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112AITask.cs


5112 C# Programming Manual: JYPCIe5112.AIExternalSampleClock Class Reference

  • AIExternalSampleClock
Properties | List of all members
JYPCIe5112.AIExternalSampleClock Class Reference

External Sample Clock Configuration Class. More...

Properties

ClockTerminal | Terminal [get, set]
External Sample Clock Input Terminal.
double | ExpectedRate [get, set]
Expected External Sample Clock Rate.

Detailed Description

External Sample Clock Configuration Class.

Property Documentation

◆ ExpectedRate

double JYPCIe5112.AIExternalSampleClock.ExpectedRate
getset

Expected External Sample Clock Rate.

◆ Terminal

ClockTerminal JYPCIe5112.AIExternalSampleClock.Terminal
getset

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112AITask.cs


5112 C# Programming Manual: JYPCIe5112.AITrigger Class Reference

  • AITrigger
Properties | List of all members
JYPCIe5112.AITrigger Class Referencesealed

Constructor to create an AITrigger task object. More...

Properties

AITriggerType | Type [get, set]
AI trigger type.
AITriggerMode | Mode [get, set]
AI trigger mode.
AIDigitalTrigger | Digital [get, set]
Digital Trigger Congfiguration.
AIAnalogTrigger | Analog [get, set]
AI Analog Trigger.
int | ReTriggerCount [get, set]
Number of repeat triggers.
uint | PreTriggerSamples [get, set]
AI pretrigger samples, must be less than or equal to JYPCIe5112AITask.SamplesToAcquire.

Detailed Description

Constructor to create an AITrigger task object.

Used to build AI Trigger

Property Documentation

◆ Analog

AIAnalogTrigger JYPCIe5112.AITrigger.Analog
getset

AI Analog Trigger.

Valid when Type is AITriggerType.Analog.

◆ Digital

AIDigitalTrigger JYPCIe5112.AITrigger.Digital
getset

Digital Trigger Congfiguration.

Valid when Type is AITriggerType.Digital.

◆ Mode

AITriggerMode JYPCIe5112.AITrigger.Mode
getset

AI trigger mode.

enum Start/Reference. The default value is AITriggerMode.Start.

◆ PreTriggerSamples

uint JYPCIe5112.AITrigger.PreTriggerSamples
getset

AI pretrigger samples, must be less than or equal to JYPCIe5112AITask.SamplesToAcquire.

Valid when Mode is AITriggerMode.Reference.

◆ ReTriggerCount

int JYPCIe5112.AITrigger.ReTriggerCount
getset

Number of repeat triggers.

When 0 or 1 only trigger once, When -1 continuous retrigger until stop.

◆ Type

AITriggerType JYPCIe5112.AITrigger.Type
getset

AI trigger type.

enum Analog/Digital/Immediate/Soft. The default value is AITriggerType.Immediate.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112AITask.cs


5112 C# Programming Manual: JYPCIe5112.AIDigitalTrigger Class Reference

  • AIDigitalTrigger
Properties | List of all members
JYPCIe5112.AIDigitalTrigger Class Referencesealed

AI Digital trigger class. More...

Properties

AIDigitalTriggerSource | Source [get, set]
AI Digital Trigger source.
AIDigitalTriggerEdge | Edge [get, set]
Digital Trigger edge，Rising/Falling.

Detailed Description

AI Digital trigger class.

Property Documentation

◆ Edge

AIDigitalTriggerEdge JYPCIe5112.AIDigitalTrigger.Edge
getset

Digital Trigger edge，Rising/Falling.

◆ Source

AIDigitalTriggerSource JYPCIe5112.AIDigitalTrigger.Source
getset

AI Digital Trigger source.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112AITask.cs


5112 C# Programming Manual: JYPCIe5112.AIAnalogTrigger Class Reference

  • AIAnalogTrigger
Properties | List of all members
JYPCIe5112.AIAnalogTrigger Class Referencesealed

AI analog trigger . More...

Properties

AIAnalogTriggerSource | Source [get, set]
Analog Trigger source.
AIAnalogTriggerComparator | Comparator [get, set]
AI Analog Trigger Comparator.
AIAnalogEdgeComparator | Edge [get, set]
AI Analog Edge Comparator.
AIAnalogHysteresisComparator | Hysteresis [get, set]
AI Analog Hysteresis Comparatorr.
AIAnalogWindowComparator | Window [get, set]
AI Analog Window Comparatorr.

Detailed Description

AI analog trigger .

Property Documentation

◆ Comparator

AIAnalogTriggerComparator JYPCIe5112.AIAnalogTrigger.Comparator
getset

AI Analog Trigger Comparator.

◆ Edge

AIAnalogEdgeComparator JYPCIe5112.AIAnalogTrigger.Edge
getset

AI Analog Edge Comparator.

◆ Hysteresis

AIAnalogHysteresisComparator JYPCIe5112.AIAnalogTrigger.Hysteresis
getset

AI Analog Hysteresis Comparatorr.

◆ Source

AIAnalogTriggerSource JYPCIe5112.AIAnalogTrigger.Source
getset

Analog Trigger source.

◆ Window

AIAnalogWindowComparator JYPCIe5112.AIAnalogTrigger.Window
getset

AI Analog Window Comparatorr.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112AITask.cs


5112 C# Programming Manual: JYPCIe5112.AIAnalogHysteresisComparator Class Reference

  • AIAnalogHysteresisComparator
Public Attributes | Properties | List of all members
JYPCIe5112.AIAnalogHysteresisComparator Class Reference

AI Analog Hysteresis Comparatorr. More...

Public Attributes

double | HighThreshold
High Threshold.
double | LowThreshold
Low Threshold.

Properties

AIAnalogTriggerEdge Slope [get, set]
AI Analog Trigger Edge.

Detailed Description

AI Analog Hysteresis Comparatorr.

Member Data Documentation

◆ HighThreshold

double JYPCIe5112.AIAnalogHysteresisComparator.HighThreshold

High Threshold.

◆ LowThreshold

double JYPCIe5112.AIAnalogHysteresisComparator.LowThreshold

Low Threshold.

Property Documentation

◆ Slope

AIAnalogTriggerEdge JYPCIe5112.AIAnalogHysteresisComparator.Slope
getset

AI Analog Trigger Edge.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112AITask.cs


5112 C# Programming Manual: JYPCIe5112.AIAnalogWindowComparator Class Reference

  • AIAnalogWindowComparator
Public Attributes | Properties | List of all members
JYPCIe5112.AIAnalogWindowComparator Class Reference

AI Analog Window Comparatorr. More...

Public Attributes

double | HighThreshold
High Threshold.
double | LowThreshold
Low Threshold.

Properties

AIAnalogWindowCondition Condition [get, set]
AI Analog Window Condition.

Detailed Description

AI Analog Window Comparatorr.

Member Data Documentation

◆ HighThreshold

double JYPCIe5112.AIAnalogWindowComparator.HighThreshold

High Threshold.

◆ LowThreshold

double JYPCIe5112.AIAnalogWindowComparator.LowThreshold

Low Threshold.

Property Documentation

◆ Condition

AIAnalogWindowCondition JYPCIe5112.AIAnalogWindowComparator.Condition
getset

AI Analog Window Condition.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112AITask.cs


5112 C# Programming Manual: JYPCIe5112.AIAnalogEdgeComparator Class Reference

  • AIAnalogEdgeComparator
Public Attributes | Properties | List of all members
JYPCIe5112.AIAnalogEdgeComparator Class Reference

AI Analog Edge Comparator. More...

Public Attributes

double Threshold
Threshold.

Properties

AIAnalogTriggerEdge Slope [get, set]
AI Analog Trigger Edge.

Detailed Description

AI Analog Edge Comparator.

Member Data Documentation

◆ Threshold

double JYPCIe5112.AIAnalogEdgeComparator.Threshold

Threshold.

Property Documentation

◆ Slope

AIAnalogTriggerEdge JYPCIe5112.AIAnalogEdgeComparator.Slope
getset

AI Analog Trigger Edge.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112AITask.cs


5112 C# Programming Manual: JYPCIe5112.AIRecord Class Reference

  • AIRecord
Properties | List of all members
JYPCIe5112.AIRecord Class Referencesealed

AI Record Parameters. More...

Properties

string | FilePath [get, set]
User specified file path.
FileFormat | FileFormat [get]
Streaming file format.
RecordMode | Mode [get, set]
stream mode .
double | Length [get, set]
User specified stream length in second.

Detailed Description

AI Record Parameters.

Property Documentation

◆ FileFormat

FileFormat JYPCIe5112.AIRecord.FileFormat
get

Streaming file format.

enum BIN.

◆ FilePath

string JYPCIe5112.AIRecord.FilePath
getset

User specified file path.

◆ Length

double JYPCIe5112.AIRecord.Length
getset

User specified stream length in second.

Only when Mode is RecordMode.Finite.

◆ Mode

RecordMode JYPCIe5112.AIRecord.Mode
getset

stream mode .

enum Finite/Infinite.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112AITask.cs


5112 C# Programming Manual: JYPCIe5112.AIAdvanced Class Reference

  • AIAdvanced
Properties | List of all members
JYPCIe5112.AIAdvanced Class Referencesealed

AI Advance parameter. More...

Properties

double ConvertRate [get, set]
the convert rate of ADC.

Detailed Description

AI Advance parameter.

Property Documentation

◆ ConvertRate

double JYPCIe5112.AIAdvanced.ConvertRate
getset

the convert rate of ADC.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112AITask.cs


5112 C# Programming Manual: JYPCIe5112.AISignalExport Class Reference

  • AISignalExport
Public Member Functions | List of all members
JYPCIe5112.AISignalExport Class Reference

AI Signal Export Class. More...

Public Member Functions

void | Add (AISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (AISignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

AI Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JYPCIe5112.AISignalExport.Add | ( | AISignalExportSource | source,
 |  | List< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | AI Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JYPCIe5112.AISignalExport.Add | ( | AISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | AI Signal Source
destination | Export Desination

◆ Clear()

void JYPCIe5112.AISignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JYPCIe5112.AISignalExport.ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112AITask.cs


5112 C# Programming Manual: D:/5112/C#/JYPCIe5112AOTask.cs File Reference

  • File List
  • 5112
  • C#
Classes | Namespaces | Enumerations
JYPCIe5112AOTask.cs File Reference

Classes

class | JYPCIe5112.JYPCIe5112AOTask
JYPCIe5112 Analog Ouput Task. More...
class | JYPCIe5112.AOChannel
AO Channel parameter class . More...
class | JYPCIe5112.AOSampleClock
AO Sample clock configuration class. More...
class | JYPCIe5112.AOExternalSampleClock
External Sample Clock Configuration Class. More...
class | JYPCIe5112.AOTrigger
Constructor to create an AOTrigger task object. More...
class | JYPCIe5112.AODigitalTrigger
AO Digital trigger . More...
class | JYPCIe5112.AOSignalExport
AO Signal Export Class. More...

Namespaces

namespace JYPCIe5112

Enumerations

enum | JYPCIe5112.AODigitalTriggerEdge { JYPCIe5112.Rising , JYPCIe5112.Falling }
AO Digital Trigger Edge. More...
enum JYPCIe5112.AODigitalTriggerSource {
JYPCIe5112.PFI0 = 0 , JYPCIe5112.PFI1 = 1 , JYPCIe5112.PFI2 = 2 , JYPCIe5112.PFI3 = 3 ,
JYPCIe5112.PFI4 = 4 , JYPCIe5112.PFI5 = 5 , JYPCIe5112.PFI6 = 6 , JYPCIe5112.PFI7 = 7 ,
JYPCIe5112.PFI8 = 8 , JYPCIe5112.PFI9 = 9 , JYPCIe5112.PFI10 = 10 , JYPCIe5112.PFI11 = 11 ,
JYPCIe5112.PFI12 = 12 , JYPCIe5112.PFI13 = 13 , JYPCIe5112.PFI14 = 14 , JYPCIe5112.PFI15 = 15 ,
JYPCIe5112.PXI_Trig0 = 16 , JYPCIe5112.PXI_Trig1 = 17 , JYPCIe5112.PXI_Trig2 = 18 , JYPCIe5112.PXI_Trig3 = 19 ,
JYPCIe5112.PXI_Trig4 = 20 , JYPCIe5112.PXI_Trig5 = 21 , JYPCIe5112.PXI_Trig6 = 22 , JYPCIe5112.PXI_Trig7 = 23 ,
JYPCIe5112.AI_StartTrig = 24 , JYPCIe5112.AI_ReferenceTrig = 25 , JYPCIe5112.CIO_0_StartTrig = 27 , JYPCIe5112.CIO_1_StartTrig = 28 ,
JYPCIe5112.CO0_Output = 29 , JYPCIe5112.CO1_Output = 30
}
AO Digital trigger source. More...
enum | JYPCIe5112.AOMode { JYPCIe5112.Single = 3 , JYPCIe5112.Finite = 0 , JYPCIe5112.ContinuousNoWrapping = 2 , JYPCIe5112.ContinuousWrapping = 1 }
AOMode. More...
enum | JYPCIe5112.AOSampleClockSource { JYPCIe5112.Internal , JYPCIe5112.External }
AO Sample Clock Source. More...
enum | JYPCIe5112.AOSignalExportSource { JYPCIe5112.StartTrig = 2 , JYPCIe5112.SampleClock = 6 }
SourceSignal. More...
enum | JYPCIe5112.AOTriggerType { JYPCIe5112.Immediate = JYPCIe5112Import.JYPCIe5112_TriggerType_Immediately , JYPCIe5112.Digital = JYPCIe5112Import.JYPCIe5112_TriggerType_Digital , JYPCIe5112.Soft = JYPCIe5112Import.JYPCIe5112_TriggerType_Soft }
TriggerType Digital/Immediate/Soft. More...
enum | JYPCIe5112.OutputCompleteState { JYPCIe5112.Zero , JYPCIe5112.Hold }
Output Complete State. More...


5112 C# Programming Manual: JYPCIe5112.JYPCIe5112AOTask Class Reference

  • JYPCIe5112AOTask
Public Member Functions | Properties | List of all members
JYPCIe5112.JYPCIe5112AOTask Class Referencesealed

JYPCIe5112 Analog Ouput Task. More...

Public Member Functions

JYPCIe5112AOTask (int slotNum)
Constructor, Used to create an AO task by a slot number.
JYPCIe5112AOTask (string boardName)
Constructor.
void | AddChannel (int chnId, double rangeLow=-10, double rangeHigh=10)
Add one channel.
void | AddChannel (int[] chnsId, double rangeLow=-10, double rangeHigh=10)
Add a group of channels.
void | AddChannel (int[] chnsId, double[] rangeLow, double[] rangeHigh)
Add a group of channels.
void | RemoveChannel (int chnId)
Delete the specified channel number.
void | WriteData (IntPtr buf, int samplesPerChannel, int timeout=10000)
Write to AO buffer one or multi-channel data.
void | WriteData (double[,] buf, int timeout=10000)
Write multi-channel data to AO buffer, Each column represents one channel.
void | WriteData (double[] buf, int timeout=10000)
Write one channel data to AO buffer.
void | WriteRawData (IntPtr buf, int samplesPerChannel, int timeout=10000)
Write to AO buffer one or multi-channel raw data.
void | WriteRawData (short[,] buf, int timeout=10000)
Write multi-channel raw data to AO buffer, Each column represents one channel.
void | WriteRawData (short[] buf, int timeout=10000)
Write one channel raw Data to AO buffer.
void | WriteSinglePoint (double[] writeValues)
write one sample to all channels in register .
void | WriteSinglePoint (double writeValue, int channel)
Write one sample to the specified channel in register.Available when Mode is AOMode.Single
void | WriteRawSinglePoint (short[] writeValues)
write one raw sample to all channels in register .
void | WriteRawSinglePoint (short writeValue, int channel)
Write one raw sample to the specified channel in register.Available when Mode is AOMode.Single
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.
void | Start ()
Start AO task .
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Stop ()
Stop AO task .

Properties

List< AOChannel > | Channels [get]
List of AO channels,(5112 support 2 channels)
AOMode | Mode [get, set]
Mode of AO Task.
double | UpdateRate [get, set]
Update rate per channel.
int | SamplesToUpdate [get, set]
Number of output samples to write per channel , Only valid when Mode is AOMode.Finite.
int | BufLenInSamples [get]
Number of samples per channel can be storage in the buffer, the PropretySamplesToUpdate must be less than or equal to this value.
uint | AvaliableLenInSamples [get]
Number of output samples per channel that can be write in AO buffuer.
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel).
OutputCompleteState | CompleteState [get, set]
AO Output Complete State, Default is Hold.
AOSampleClock | SampleClock [get, set]
AO Sample Clock Configuration .
AOTrigger | Trigger = new AOTrigger() [get, set]
AO Trigger Configuration.
bool | DisableCalibration [get, set]
Disalble calibration.
AOSignalExport | SignalExport [get, set]
Export AO Signal.
JYPCIe5112Device | Device [get]
Device.

Detailed Description

JYPCIe5112 Analog Ouput Task.

Constructor & Destructor Documentation

◆ JYPCIe5112AOTask() [1/2]

JYPCIe5112.JYPCIe5112AOTask.JYPCIe5112AOTask ( int slotNum )

Constructor, Used to create an AO task by a slot number.

Parameters
slotNum Card slot number.

◆ JYPCIe5112AOTask() [2/2]

JYPCIe5112.JYPCIe5112AOTask.JYPCIe5112AOTask ( string boardName )

Constructor.

Used to create an AO task by a board name.

Parameters
boardName Board name(device alias), set by device manager

Member Function Documentation

◆ AddChannel() [1/3]

void JYPCIe5112.JYPCIe5112AOTask.AddChannel | ( | int | chnId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10 )

Add one channel.

Parameters
chnId | channel's physical number ，chnId=-1, add all channels。（5112 support 2 channels）
rangeLow | lower range limit for the channel，-10V,-5V defalut -10
rangeHigh | higher range limit for the channel，10V,5V defalut 10

◆ AddChannel() [2/3]

void JYPCIe5112.JYPCIe5112AOTask.AddChannel | ( | int[] | chnsId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10 )

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers。（5112 support 2 channels）
rangeLow | lower range limit for the channel，-10V,-5V defalut -10
rangeHigh | higher range limit for the channel，10V,5V defalut 10

◆ AddChannel() [3/3]

void JYPCIe5112.JYPCIe5112AOTask.AddChannel | ( | int[] | chnsId,
 |  | double[] | rangeLow,
 |  | double[] | rangeHigh )

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers。（5112 support 2 channels）
rangeLow | lower range limit for the channel，-10V,-5V
rangeHigh | higher range limit for the channel，10V,5V

◆ RemoveChannel()

void JYPCIe5112.JYPCIe5112AOTask.RemoveChannel ( int chnId )

Delete the specified channel number.

If it is -1, delete all channels.

Parameters
chnId Specified channel ID.

◆ SendSoftwareTrigger()

void JYPCIe5112.JYPCIe5112AOTask.SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JYPCIe5112.JYPCIe5112AOTask.Start ( )

Start AO task .

◆ Stop()

void JYPCIe5112.JYPCIe5112AOTask.Stop ( )

Stop AO task .

◆ WaitUntilDone()

bool JYPCIe5112.JYPCIe5112AOTask.WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Available when Mode is AOMode.Finite

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteData() [1/3]

void JYPCIe5112.JYPCIe5112AOTask.WriteData | ( | double | buf[,],
 |  | int | timeout = 10000 )

Write multi-channel data to AO buffer, Each column represents one channel.

Parameters
buf | AO buffer for data.
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [2/3]

void JYPCIe5112.JYPCIe5112AOTask.WriteData | ( | double[] | buf,
 |  | int | timeout = 10000 )

Write one channel data to AO buffer.

Parameters
buf | AO buffer for data.
timeout | >timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [3/3]

void JYPCIe5112.JYPCIe5112AOTask.WriteData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Write to AO buffer one or multi-channel data.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | data buffer.
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawData() [1/3]

void JYPCIe5112.JYPCIe5112AOTask.WriteRawData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Write to AO buffer one or multi-channel raw data.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | data buffer.
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawData() [2/3]

void JYPCIe5112.JYPCIe5112AOTask.WriteRawData | ( | short | buf[,],
 |  | int | timeout = 10000 )

Write multi-channel raw data to AO buffer, Each column represents one channel.

Parameters
buf | AO buffer for data.
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawData() [3/3]

void JYPCIe5112.JYPCIe5112AOTask.WriteRawData | ( | short[] | buf,
 |  | int | timeout = 10000 )

Write one channel raw Data to AO buffer.

Parameters
buf | AO buffer for data.
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawSinglePoint() [1/2]

void JYPCIe5112.JYPCIe5112AOTask.WriteRawSinglePoint | ( | short | writeValue,
 |  | int | channel )

Write one raw sample to the specified channel in register.Available when Mode is AOMode.Single

Parameters
writeValue | Write value.
channel | Specified channel.

◆ WriteRawSinglePoint() [2/2]

void JYPCIe5112.JYPCIe5112AOTask.WriteRawSinglePoint ( short[] writeValues )

write one raw sample to all channels in register .

Available when Mode is AOMode.Single

Parameters
writeValues Write values. Array length >= Channels.Count.

◆ WriteSinglePoint() [1/2]

void JYPCIe5112.JYPCIe5112AOTask.WriteSinglePoint | ( | double | writeValue,
 |  | int | channel )

Write one sample to the specified channel in register.Available when Mode is AOMode.Single

Parameters
writeValue | Write value.
channel | Specified channel.

◆ WriteSinglePoint() [2/2]

void JYPCIe5112.JYPCIe5112AOTask.WriteSinglePoint ( double[] writeValues )

write one sample to all channels in register .

Available when Mode is AOMode.Single

Parameters
writeValues Write values. Array length >= Channels.Count.

Property Documentation

◆ AvaliableLenInSamples

uint JYPCIe5112.JYPCIe5112AOTask.AvaliableLenInSamples
get

Number of output samples per channel that can be write in AO buffuer.

◆ BufLenInSamples

int JYPCIe5112.JYPCIe5112AOTask.BufLenInSamples
get

Number of samples per channel can be storage in the buffer, the PropretySamplesToUpdate must be less than or equal to this value.

◆ Channels

List<AOChannel> JYPCIe5112.JYPCIe5112AOTask.Channels
get

List of AO channels,(5112 support 2 channels)

◆ CompleteState

OutputCompleteState JYPCIe5112.JYPCIe5112AOTask.CompleteState
getset

AO Output Complete State, Default is Hold.

◆ Device

JYPCIe5112Device JYPCIe5112.JYPCIe5112AOTask.Device
get

Device.

◆ DisableCalibration

bool JYPCIe5112.JYPCIe5112AOTask.DisableCalibration
getset

Disalble calibration.

◆ Mode

AOMode JYPCIe5112.JYPCIe5112AOTask.Mode
getset

Mode of AO Task.

Select AO Mode from enum:ContinuousNoWrapping/ContinuousWrapping/Finite/Single.

◆ SampleClock

AOSampleClock JYPCIe5112.JYPCIe5112AOTask.SampleClock
getset

AO Sample Clock Configuration .

◆ SamplesToUpdate

int JYPCIe5112.JYPCIe5112AOTask.SamplesToUpdate
getset

Number of output samples to write per channel , Only valid when Mode is AOMode.Finite.

◆ SignalExport

AOSignalExport JYPCIe5112.JYPCIe5112AOTask.SignalExport
getset

Export AO Signal.

◆ TransferedSamples

ulong JYPCIe5112.JYPCIe5112AOTask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT AOMode.Single.

◆ Trigger

AOTrigger JYPCIe5112.JYPCIe5112AOTask.Trigger = new AOTrigger()
getset

AO Trigger Configuration.

◆ UpdateRate

double JYPCIe5112.JYPCIe5112AOTask.UpdateRate
getset

Update rate per channel.

Maximum update rate is 2.86M. The defalut sample rate = 1000000 You can read this property to obtain the update rate that will actually take effect in the current configuration.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112AOTask.cs


5112 C# Programming Manual: JYPCIe5112.AOChannel Class Reference

  • AOChannel
Properties | List of all members
JYPCIe5112.AOChannel Class Referencesealed

AO Channel parameter class . More...

Properties

int | ChannelID [get]
AO channel ID.
double | RangeLow [get, set]
Low range limit an AO channel.
double | RangeHigh [get, set]
High range limit an AO channel.

Detailed Description

AO Channel parameter class .

Property Documentation

◆ ChannelID

int JYPCIe5112.AOChannel.ChannelID
get

AO channel ID.

◆ RangeHigh

double JYPCIe5112.AOChannel.RangeHigh
getset

High range limit an AO channel.

◆ RangeLow

double JYPCIe5112.AOChannel.RangeLow
getset

Low range limit an AO channel.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112AOTask.cs


5112 C# Programming Manual: JYPCIe5112.AOSampleClock Class Reference

  • AOSampleClock
Properties | List of all members
JYPCIe5112.AOSampleClock Class Reference

AO Sample clock configuration class. More...

Properties

AOSampleClockSource | Source [get, set]
Clock Source.
AOExternalSampleClock | External [get, set]
External Sample Clock Configuration,Valid when Source is AOSampleClockSource.External.

Detailed Description

AO Sample clock configuration class.

Property Documentation

◆ External

AOExternalSampleClock JYPCIe5112.AOSampleClock.External
getset

External Sample Clock Configuration,Valid when Source is AOSampleClockSource.External.

◆ Source

AOSampleClockSource JYPCIe5112.AOSampleClock.Source
getset

Clock Source.

enum Internal/External,The default value is AOSampleClockSource.Internal.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112AOTask.cs


5112 C# Programming Manual: JYPCIe5112.AOExternalSampleClock Class Reference

  • AOExternalSampleClock
Properties | List of all members
JYPCIe5112.AOExternalSampleClock Class Reference

External Sample Clock Configuration Class. More...

Properties

ClockTerminal | Terminal [get, set]
External Sample Clock Input Terminal.
double | ExpectedRate [get, set]
Expected External Sample Clock Rate.

Detailed Description

External Sample Clock Configuration Class.

Property Documentation

◆ ExpectedRate

double JYPCIe5112.AOExternalSampleClock.ExpectedRate
getset

Expected External Sample Clock Rate.

◆ Terminal

ClockTerminal JYPCIe5112.AOExternalSampleClock.Terminal
getset

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112AOTask.cs


5112 C# Programming Manual: JYPCIe5112.AOTrigger Class Reference

  • AOTrigger
Properties | List of all members
JYPCIe5112.AOTrigger Class Referencesealed

Constructor to create an AOTrigger task object. More...

Properties

AOTriggerType | Type [get, set]
AO trigger type.
AODigitalTrigger | Digital [get, set]
AO Digital Trigger.

Detailed Description

Constructor to create an AOTrigger task object.

Used to build AO Trigger

Property Documentation

◆ Digital

AODigitalTrigger JYPCIe5112.AOTrigger.Digital
getset

AO Digital Trigger.

Valid when Type is AOTriggerType.Digital.

◆ Type

AOTriggerType JYPCIe5112.AOTrigger.Type
getset

AO trigger type.

enum Immediate/Digital/Soft.The default value is AOTriggerType.Immediate.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112AOTask.cs


5112 C# Programming Manual: JYPCIe5112.AODigitalTrigger Class Reference

  • AODigitalTrigger
Properties | List of all members
JYPCIe5112.AODigitalTrigger Class Referencesealed

AO Digital trigger . More...

Properties

AODigitalTriggerSource | Source [get, set]
AO Digital Trigger source.
AODigitalTriggerEdge | Edge [get, set]
Digital Trigger edge，Rising/Falling.

Detailed Description

AO Digital trigger .

Property Documentation

◆ Edge

AODigitalTriggerEdge JYPCIe5112.AODigitalTrigger.Edge
getset

Digital Trigger edge，Rising/Falling.

◆ Source

AODigitalTriggerSource JYPCIe5112.AODigitalTrigger.Source
getset

AO Digital Trigger source.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112AOTask.cs


5112 C# Programming Manual: JYPCIe5112.AOSignalExport Class Reference

  • AOSignalExport
Public Member Functions | List of all members
JYPCIe5112.AOSignalExport Class Reference

AO Signal Export Class. More...

Public Member Functions

void | Add (AOSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (AOSignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

AO Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JYPCIe5112.AOSignalExport.Add | ( | AOSignalExportSource | source,
 |  | List< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | AO Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JYPCIe5112.AOSignalExport.Add | ( | AOSignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | AO Signal Source
destination | Export Desination

◆ Clear()

void JYPCIe5112.AOSignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JYPCIe5112.AOSignalExport.ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112AOTask.cs


5112 C# Programming Manual: D:/5112/C#/JYPCIe5112CITask.cs File Reference

  • File List
  • 5112
  • C#
Classes | Namespaces | Enumerations
JYPCIe5112CITask.cs File Reference

Classes

class | JYPCIe5112.JYPCIe5112CITask
JYPCIe5112 Counter Input Task. More...
class | JYPCIe5112.CIExternalTimebase
class | JYPCIe5112.CITimebase
class | JYPCIe5112.EdgeCounting
Configure CI EdgeCounting. More...
class | JYPCIe5112.EdgeCountingOutEvent
Edge counting output event configuration class. More...
class | JYPCIe5112.PauseTrigger
Pause trigger configuration class. More...
class | JYPCIe5112.FrequencyMeas
Configure CI Measure. More...
class | JYPCIe5112.PeriodMeas
Configure CI Measure. More...
class | JYPCIe5112.PulseMeas
Configure CI Measure. More...
class | JYPCIe5112.SemiPeriodMeas
Configure CI Measure. More...
class | JYPCIe5112.TwoEdgeSeparation
Configure CI Measure. More...
class | JYPCIe5112.QuadEncoder
Configure CI Measure. More...
class | JYPCIe5112.TwoPulseEncoder
Configure CI Measure. More...
class | JYPCIe5112.CITrigger
Constructor to create an CITrigger task object. More...
class | JYPCIe5112.CIDigitalTrigger
CI Digital trigger . More...
class | JYPCIe5112.CISignalExport
CI Signal Export Class. More...

Namespaces

namespace JYPCIe5112

Enumerations

enum | JYPCIe5112.CountDirection { JYPCIe5112.Up = JYPCIe5112Import.JYPCIe5112_CI_Count_Up , JYPCIe5112.Down = JYPCIe5112Import.JYPCIe5112_CI_Count_Down , JYPCIe5112.External = JYPCIe5112Import.JYPCIe5112_CI_Count_External }
Counter direction. More...
enum JYPCIe5112.CIType {
JYPCIe5112.EdgeCounting , JYPCIe5112.Period , JYPCIe5112.Frequency , JYPCIe5112.Pulse ,
JYPCIe5112.SemiPeriod , JYPCIe5112.TwoEdgeSeparation , JYPCIe5112.QuadEncoder , JYPCIe5112.TwoPulseEncoder
}
Counter Input Application Type. More...
enum | JYPCIe5112.EdgeType { JYPCIe5112.Rising , JYPCIe5112.Falling , JYPCIe5112.Any }
Edge Type. More...
enum | JYPCIe5112.CITimebaseSource { JYPCIe5112.Internal100MHz = 0 , JYPCIe5112.Internal5MHz = 1 , JYPCIe5112.Internal100kHz = 2 , JYPCIe5112.External = 3 }
enum | JYPCIe5112.EdgeCntOunEvtIdleState { JYPCIe5112.LowLevel = 0 , JYPCIe5112.HighLevel = 1 }
Output idle state when the event has not occurred. More...
enum | JYPCIe5112.LevelPolarity { JYPCIe5112.LowLevel = 0 , JYPCIe5112.HighLevel = 1 , JYPCIe5112.None = 2 }
Level Polarity. More...
enum | JYPCIe5112.OutputState { JYPCIe5112.HoldOn = 0 , JYPCIe5112.HighLevel = 1 , JYPCIe5112.LowLevel = 2 }
CO output state when pause trigger valid. More...
enum | JYPCIe5112.ValueReturnMode { JYPCIe5112.TwoValue , JYPCIe5112.OneValue }
TwoEdgeSeparation value return mode.only for TwoEdgeSeparation type. More...
enum | JYPCIe5112.QuadEncodingType { JYPCIe5112.X1 , JYPCIe5112.X2 , JYPCIe5112.X4 }
Quadrature Encoding Type. More...
enum | JYPCIe5112.CITriggerType { JYPCIe5112.Immediate = JYPCIe5112Import.JYPCIe5112_CIO_Immediately , JYPCIe5112.Digital = JYPCIe5112Import.JYPCIe5112_CIO_Digital , JYPCIe5112.Soft = JYPCIe5112Import.JYPCIe5112_CIO_Soft }
TriggerType Digital/Immediate/Soft. More...
enum JYPCIe5112.CIDigitalTriggerSource {
JYPCIe5112.PFI0 = 0 , JYPCIe5112.PFI1 = 1 , JYPCIe5112.PFI2 = 2 , JYPCIe5112.PFI3 = 3 ,
JYPCIe5112.PFI4 = 4 , JYPCIe5112.PFI5 = 5 , JYPCIe5112.PFI6 = 6 , JYPCIe5112.PFI7 = 7 ,
JYPCIe5112.PFI8 = 8 , JYPCIe5112.PFI9 = 9 , JYPCIe5112.PFI10 = 10 , JYPCIe5112.PFI11 = 11 ,
JYPCIe5112.PFI12 = 12 , JYPCIe5112.PFI13 = 13 , JYPCIe5112.PFI14 = 14 , JYPCIe5112.PFI15 = 15 ,
JYPCIe5112.PXI_Trig0 = 16 , JYPCIe5112.PXI_Trig1 = 17 , JYPCIe5112.PXI_Trig2 = 18 , JYPCIe5112.PXI_Trig3 = 19 ,
JYPCIe5112.PXI_Trig4 = 20 , JYPCIe5112.PXI_Trig5 = 21 , JYPCIe5112.PXI_Trig6 = 22 , JYPCIe5112.PXI_Trig7 = 23 ,
JYPCIe5112.AI_StartTrig = 24 , JYPCIe5112.AI_ReferenceTrig = 25 , JYPCIe5112.AO_StartTrig = 26 , JYPCIe5112.CIO_0_StartTrig = 27 ,
JYPCIe5112.CIO_1_StartTrig = 28 , JYPCIe5112.CO0_Output = 29 , JYPCIe5112.CO1_Output = 30
}
CI Digital trigger source. More...
enum | JYPCIe5112.CIDigitalTriggerEdge { JYPCIe5112.Rising , JYPCIe5112.Falling }
CI Digital Trigger Edge. More...
enum JYPCIe5112.InputTerminal {
JYPCIe5112.PFI0 = JYPCIe5112Import.JYPCIe5112_PFI0_Input , JYPCIe5112.PFI1 = JYPCIe5112Import.JYPCIe5112_PFI1_Input , JYPCIe5112.PFI2 = JYPCIe5112Import.JYPCIe5112_PFI2_Input , JYPCIe5112.PFI3 = JYPCIe5112Import.JYPCIe5112_PFI3_Input ,
JYPCIe5112.PFI4 = JYPCIe5112Import.JYPCIe5112_PFI4_Input , JYPCIe5112.PFI5 = JYPCIe5112Import.JYPCIe5112_PFI5_Input , JYPCIe5112.PFI6 = JYPCIe5112Import.JYPCIe5112_PFI6_Input , JYPCIe5112.PFI7 = JYPCIe5112Import.JYPCIe5112_PFI7_Input ,
JYPCIe5112.PFI8 = JYPCIe5112Import.JYPCIe5112_PFI8_Input , JYPCIe5112.PFI9 = JYPCIe5112Import.JYPCIe5112_PFI9_Input , JYPCIe5112.PFI10 = JYPCIe5112Import.JYPCIe5112_PFI10_Input , JYPCIe5112.PFI11 = JYPCIe5112Import.JYPCIe5112_PFI11_Input ,
JYPCIe5112.PFI12 = JYPCIe5112Import.JYPCIe5112_PFI12_Input , JYPCIe5112.PFI13 = JYPCIe5112Import.JYPCIe5112_PFI13_Input , JYPCIe5112.PFI14 = JYPCIe5112Import.JYPCIe5112_PFI14_Input , JYPCIe5112.PFI15 = JYPCIe5112Import.JYPCIe5112_PFI15_Input ,
JYPCIe5112.PXI_Trig0 = JYPCIe5112Import.JYPCIe5112_PXI_Trig0_Input , JYPCIe5112.PXI_Trig1 = JYPCIe5112Import.JYPCIe5112_PXI_Trig1_Input , JYPCIe5112.PXI_Trig2 = JYPCIe5112Import.JYPCIe5112_PXI_Trig2_Input , JYPCIe5112.PXI_Trig3 = JYPCIe5112Import.JYPCIe5112_PXI_Trig3_Input ,
JYPCIe5112.PXI_Trig4 = JYPCIe5112Import.JYPCIe5112_PXI_Trig4_Input , JYPCIe5112.PXI_Trig5 = JYPCIe5112Import.JYPCIe5112_PXI_Trig5_Input , JYPCIe5112.PXI_Trig6 = JYPCIe5112Import.JYPCIe5112_PXI_Trig6_Input , JYPCIe5112.PXI_Trig7 = JYPCIe5112Import.JYPCIe5112_PXI_Trig7_Input ,
JYPCIe5112.CO_0_OutPut = 24 , JYPCIe5112.CO_1_OutPut = 25 , JYPCIe5112.Timebase_100MHz = 26 , JYPCIe5112.Timebase_5MHz = 27 ,
JYPCIe5112.Timebase_100kHz = 28
}
输入终端 More...
enum JYPCIe5112.IOTerminal {
JYPCIe5112.PFI0 = JYPCIe5112Import.JYPCIe5112_DigitalTriggerOut_PFI_0 , JYPCIe5112.PFI1 = JYPCIe5112Import.JYPCIe5112_DigitalTriggerOut_PFI_1 , JYPCIe5112.PFI2 = JYPCIe5112Import.JYPCIe5112_DigitalTriggerOut_PFI_2 , JYPCIe5112.PFI3 = JYPCIe5112Import.JYPCIe5112_DigitalTriggerOut_PFI_3 ,
JYPCIe5112.PFI4 = JYPCIe5112Import.JYPCIe5112_DigitalTriggerOut_PFI_4 , JYPCIe5112.PFI5 = JYPCIe5112Import.JYPCIe5112_DigitalTriggerOut_PFI_5 , JYPCIe5112.PFI6 = JYPCIe5112Import.JYPCIe5112_DigitalTriggerOut_PFI_6 , JYPCIe5112.PFI7 = JYPCIe5112Import.JYPCIe5112_DigitalTriggerOut_PFI_7 ,
JYPCIe5112.PFI8 = JYPCIe5112Import.JYPCIe5112_DigitalTriggerOut_PFI_8 , JYPCIe5112.PFI9 = JYPCIe5112Import.JYPCIe5112_DigitalTriggerOut_PFI_9 , JYPCIe5112.PFI10 = JYPCIe5112Import.JYPCIe5112_DigitalTriggerOut_PFI_10 , JYPCIe5112.PFI11 = JYPCIe5112Import.JYPCIe5112_DigitalTriggerOut_PFI_11 ,
JYPCIe5112.PFI12 = JYPCIe5112Import.JYPCIe5112_DigitalTriggerOut_PFI_12 , JYPCIe5112.PFI13 = JYPCIe5112Import.JYPCIe5112_DigitalTriggerOut_PFI_13 , JYPCIe5112.PFI14 = JYPCIe5112Import.JYPCIe5112_DigitalTriggerOut_PFI_14 , JYPCIe5112.PFI15 = JYPCIe5112Import.JYPCIe5112_DigitalTriggerOut_PFI_15 ,
JYPCIe5112.PXI_Trig0 = JYPCIe5112Import.JYPCIe5112_TriggerOut_PXI_0 , JYPCIe5112.PXI_Trig1 = JYPCIe5112Import.JYPCIe5112_TriggerOut_PXI_1 , JYPCIe5112.PXI_Trig2 = JYPCIe5112Import.JYPCIe5112_TriggerOut_PXI_2 , JYPCIe5112.PXI_Trig3 = JYPCIe5112Import.JYPCIe5112_TriggerOut_PXI_3 ,
JYPCIe5112.PXI_Trig4 = JYPCIe5112Import.JYPCIe5112_TriggerOut_PXI_4 , JYPCIe5112.PXI_Trig5 = JYPCIe5112Import.JYPCIe5112_TriggerOut_PXI_5 , JYPCIe5112.PXI_Trig6 = JYPCIe5112Import.JYPCIe5112_TriggerOut_PXI_6 , JYPCIe5112.PXI_Trig7 = JYPCIe5112Import.JYPCIe5112_TriggerOut_PXI_7 ,
JYPCIe5112.None = 24
}
IO终端=信号的目的地（共24个） More...
enum | JYPCIe5112.CISignalExportSource { JYPCIe5112.StartTrig }
SourceSignal. More...


5112 C# Programming Manual: JYPCIe5112.JYPCIe5112CITask Class Reference

  • JYPCIe5112CITask
Public Member Functions | Properties | List of all members
JYPCIe5112.JYPCIe5112CITask Class Referencesealed

JYPCIe5112 Counter Input Task. More...

Public Member Functions

JYPCIe5112CITask (int slotNum, int channel)
Constructor.
JYPCIe5112CITask (string boardName, int channel)
Constructor.
void | Start ()
Start CI task .
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Stop ()
Stop CI task .
void | ReadSinglePoint (ref uint count)
Read a signle count value from register, Available when Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder
void | ReadSinglePoint (ref double measurement, int timeout=10000)
Read a signle frequency value or period value from register.
void | ReadSinglePoint (ref double measurement1, ref double measurement2, int timeout=10000)
Read a signle measurement of pulse's duration value, or two-edge separtion value (two results at a time) from register.

Properties

CIType | Type [get, set]
CI Application types.
EdgeCounting | EdgeCounting [get, set]
Edge Counting Configuration.
FrequencyMeas | FrequencyMeas [get, set]
Frequency Measurement Configuration.
PeriodMeas | PeriodMeas [get, set]
Period Measurement Configuration.
SemiPeriodMeas | SemiPeriodMeas [get, set]
SemiPeriodMeas Measurement Configuration.
PulseMeas | PulseMeas [get, set]
Pulse Measurement Configuration.
TwoEdgeSeparation | TwoEdgeSeparation [get, set]
TwoEdgeSeparation.
QuadEncoder | QuadEncoder [get, set]
QuadEncoder.
TwoPulseEncoder | TwoPulseEncoder [get, set]
TwoPulseEncoder.
CISignalExport | SignalExport [get, set]
Export CI Signal Configuration.
JYPCIe5112Device | Device [get]
Device.

Detailed Description

JYPCIe5112 Counter Input Task.

Constructor & Destructor Documentation

◆ JYPCIe5112CITask() [1/2]

JYPCIe5112.JYPCIe5112CITask.JYPCIe5112CITask | ( | int | slotNum,
 |  | int | channel )

Constructor.

Used to create an CI task by a slot number.

Parameters
slotNum | Card slot number.
channel | Counter channel suppor0-1

◆ JYPCIe5112CITask() [2/2]

JYPCIe5112.JYPCIe5112CITask.JYPCIe5112CITask | ( | string | boardName,
 |  | int | channel )

Constructor.

Used to create an m task by a board name.

Parameters
boardName | Board name(device alias), set by device manager
channel | Counter channel （5112 support0-1）.

Member Function Documentation

◆ ReadSinglePoint() [1/3]

void JYPCIe5112.JYPCIe5112CITask.ReadSinglePoint | ( | ref double | measurement,
 |  | int | timeout = 10000 )

Read a signle frequency value or period value from register.

Valid when Type is CIType.Frequency or CIType.Period.

Parameters
measurement Measurement value. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period is seconds when Type is CIType.Period.
timeout
Timeout (ms). Wait until the measurement is completed or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [2/3]

void JYPCIe5112.JYPCIe5112CITask.ReadSinglePoint | ( | ref double | measurement1,
 |  | ref double | measurement2,
 |  | int | timeout = 10000 )

Read a signle measurement of pulse's duration value, or two-edge separtion value (two results at a time) from register.

Available when Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
measurement1 | Measurement Value 1. Indicates low level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
measurement2 | Measurement Value 2. Indicates high level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
timeout
Timeout (ms). Wait until the measurement is completed or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [3/3]

void JYPCIe5112.JYPCIe5112CITask.ReadSinglePoint ( ref uint count )

Read a signle count value from register, Available when Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder

Parameters
count counter value。

◆ SendSoftwareTrigger()

void JYPCIe5112.JYPCIe5112CITask.SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JYPCIe5112.JYPCIe5112CITask.Start ( )

Start CI task .

◆ Stop()

void JYPCIe5112.JYPCIe5112CITask.Stop ( )

Stop CI task .

Property Documentation

◆ Device

JYPCIe5112Device JYPCIe5112.JYPCIe5112CITask.Device
get

Device.

◆ EdgeCounting

EdgeCounting JYPCIe5112.JYPCIe5112CITask.EdgeCounting
getset

Edge Counting Configuration.

◆ FrequencyMeas

FrequencyMeas JYPCIe5112.JYPCIe5112CITask.FrequencyMeas
getset

Frequency Measurement Configuration.

◆ PeriodMeas

PeriodMeas JYPCIe5112.JYPCIe5112CITask.PeriodMeas
getset

Period Measurement Configuration.

◆ PulseMeas

PulseMeas JYPCIe5112.JYPCIe5112CITask.PulseMeas
getset

Pulse Measurement Configuration.

◆ QuadEncoder

QuadEncoder JYPCIe5112.JYPCIe5112CITask.QuadEncoder
getset

QuadEncoder.

◆ SemiPeriodMeas

SemiPeriodMeas JYPCIe5112.JYPCIe5112CITask.SemiPeriodMeas
getset

SemiPeriodMeas Measurement Configuration.

◆ SignalExport

CISignalExport JYPCIe5112.JYPCIe5112CITask.SignalExport
getset

Export CI Signal Configuration.

◆ TwoEdgeSeparation

TwoEdgeSeparation JYPCIe5112.JYPCIe5112CITask.TwoEdgeSeparation
getset

TwoEdgeSeparation.

◆ TwoPulseEncoder

TwoPulseEncoder JYPCIe5112.JYPCIe5112CITask.TwoPulseEncoder
getset

TwoPulseEncoder.

◆ Type

CIType JYPCIe5112.JYPCIe5112CITask.Type
getset

CI Application types.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112CITask.cs


5112 C# Programming Manual: JYPCIe5112.CIExternalTimebase Class Reference

  • CIExternalTimebase
Properties | List of all members
JYPCIe5112.CIExternalTimebase Class Referencesealed

Properties

InputTerminal | Terminal [get, set]
double | Frequency [get, set]

Detailed Description

外部时基配置类

External timebase configuration class

Property Documentation

◆ Frequency

double JYPCIe5112.CIExternalTimebase.Frequency
getset

外部时基的频率

Frequency of The External Timebase

◆ Terminal

InputTerminal JYPCIe5112.CIExternalTimebase.Terminal
getset

外部时基的输入端口

External Timebase Input Terminal

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112CITask.cs


5112 C# Programming Manual: JYPCIe5112.CITimebase Class Reference

  • CITimebase
Properties | List of all members
JYPCIe5112.CITimebase Class Referencesealed

Properties

CITimebaseSource | Source [get, set]
CIExternalTimebase | External [get, set]

Detailed Description

时基配置类

Timebase configuration class

Property Documentation

◆ External

CIExternalTimebase JYPCIe5112.CITimebase.External
getset

外部时基配置。当 CITimebase.Source 为 CITimebaseSource.External时有效。

External Timebase Configuration. Valid when CITimebase.Source is COTimebaseSource.External.

◆ Source

CITimebaseSource JYPCIe5112.CITimebase.Source
getset

时基源。默认值为 CITimebaseSource.Internal100MHz。

Timebase Source. The default value is CITimebaseSource.Internal100MHz.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112CITask.cs


5112 C# Programming Manual: JYPCIe5112.EdgeCounting Class Reference

  • EdgeCounting
Properties | List of all members
JYPCIe5112.EdgeCounting Class Referencesealed

Configure CI EdgeCounting. More...

Properties

int | InitialCount [get, set]
Initial Count.
CountDirection | Direction [get, set]
Counter direction.
EdgeType | ActiveEdge [get, set]
The avtive edge of the input signal, the counter will count up or down on this edge.
PauseTrigger | Pause [get, set]
Pause Trigger Configuration.
EdgeCountingOutEvent | OutEvent [get, set]
Edge counting output event.
InputTerminal | InputTerminal [get, set]
Input Terminal.
InputTerminal | DirTerminal [get, set]
Terminal of External Count Diretion Control.

Detailed Description

Configure CI EdgeCounting.

Property Documentation

◆ ActiveEdge

EdgeType JYPCIe5112.EdgeCounting.ActiveEdge
getset

The avtive edge of the input signal, the counter will count up or down on this edge.

◆ Direction

CountDirection JYPCIe5112.EdgeCounting.Direction
getset

Counter direction.

enum Up/Down/External

◆ DirTerminal

InputTerminal JYPCIe5112.EdgeCounting.DirTerminal
getset

Terminal of External Count Diretion Control.

Valid when Direction is CountDirection.External

◆ InitialCount

int JYPCIe5112.EdgeCounting.InitialCount
getset

Initial Count.

◆ InputTerminal

InputTerminal JYPCIe5112.EdgeCounting.InputTerminal
getset

Input Terminal.

◆ OutEvent

EdgeCountingOutEvent JYPCIe5112.EdgeCounting.OutEvent
getset

Edge counting output event.

A pulse will be generated when the count value reaches specified threshold

◆ Pause

PauseTrigger JYPCIe5112.EdgeCounting.Pause
getset

Pause Trigger Configuration.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112CITask.cs


5112 C# Programming Manual: JYPCIe5112.EdgeCountingOutEvent Class Reference

  • EdgeCountingOutEvent
Properties | List of all members
JYPCIe5112.EdgeCountingOutEvent Class Reference

Edge counting output event configuration class. More...

Properties

EdgeCntOunEvtIdleState | IdleState [get, set]
Output idle state when the event has not occurred.
uint | Threshold [get, set]
Comparison threshold.
IOTerminal | Terminal [get, set]
Terminal.

Detailed Description

Edge counting output event configuration class.

Property Documentation

◆ IdleState

EdgeCntOunEvtIdleState JYPCIe5112.EdgeCountingOutEvent.IdleState
getset

Output idle state when the event has not occurred.

The default value is EdgeCntOunEvtIdleState.LowLevel

◆ Terminal

IOTerminal JYPCIe5112.EdgeCountingOutEvent.Terminal
getset

Terminal.

◆ Threshold

uint JYPCIe5112.EdgeCountingOutEvent.Threshold
getset

Comparison threshold.

The default value is 2^32-1

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112CITask.cs


5112 C# Programming Manual: JYPCIe5112.PauseTrigger Class Reference

  • PauseTrigger
Properties | List of all members
JYPCIe5112.PauseTrigger Class Referencesealed

Pause trigger configuration class. More...

Properties

LevelPolarity | ActivePolarity [get, set]
Pause trigger active polarity.
OutputState | OutputState [get, set]
CO output state when pause trigger valid.
InputTerminal | Terminal [get, set]
Terminal.

Detailed Description

Pause trigger configuration class.

Property Documentation

◆ ActivePolarity

LevelPolarity JYPCIe5112.PauseTrigger.ActivePolarity
getset

Pause trigger active polarity.

The default value is LevelPolarity.None, means the pause trigger is disabled.

◆ OutputState

OutputState JYPCIe5112.PauseTrigger.OutputState
getset

CO output state when pause trigger valid.

OutputState.HoldOn

◆ Terminal

InputTerminal JYPCIe5112.PauseTrigger.Terminal
getset

Terminal.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112CITask.cs


5112 C# Programming Manual: JYPCIe5112.FrequencyMeas Class Reference

  • FrequencyMeas
Properties | List of all members
JYPCIe5112.FrequencyMeas Class Referencesealed

Configure CI Measure. More...

Properties

CITimebase | Timebase [get, set]
Timebase configuration.
InputTerminal | InputTerminal [get, set]
Input Terminal.

Detailed Description

Configure CI Measure.

Property Documentation

◆ InputTerminal

InputTerminal JYPCIe5112.FrequencyMeas.InputTerminal
getset

Input Terminal.

◆ Timebase

CITimebase JYPCIe5112.FrequencyMeas.Timebase
getset

Timebase configuration.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112CITask.cs


5112 C# Programming Manual: JYPCIe5112.PeriodMeas Class Reference

  • PeriodMeas
Properties | List of all members
JYPCIe5112.PeriodMeas Class Referencesealed

Configure CI Measure. More...

Properties

CITimebase | Timebase [get, set]
Timebase configuration.
InputTerminal | InputTerminal [get, set]
Input Terminal.

Detailed Description

Configure CI Measure.

Property Documentation

◆ InputTerminal

InputTerminal JYPCIe5112.PeriodMeas.InputTerminal
getset

Input Terminal.

◆ Timebase

CITimebase JYPCIe5112.PeriodMeas.Timebase
getset

Timebase configuration.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112CITask.cs


5112 C# Programming Manual: JYPCIe5112.PulseMeas Class Reference

  • PulseMeas
Properties | List of all members
JYPCIe5112.PulseMeas Class Referencesealed

Configure CI Measure. More...

Properties

CITimebase | Timebase [get, set]
Timebase configuration.
EdgeType | StartingEdge [get, set]
The start edge of the input signal, the counter will count up or down on this edge.
InputTerminal | InputTerminal [get, set]
Input Terminal.

Detailed Description

Configure CI Measure.

Property Documentation

◆ InputTerminal

InputTerminal JYPCIe5112.PulseMeas.InputTerminal
getset

Input Terminal.

◆ StartingEdge

EdgeType JYPCIe5112.PulseMeas.StartingEdge
getset

The start edge of the input signal, the counter will count up or down on this edge.

◆ Timebase

CITimebase JYPCIe5112.PulseMeas.Timebase
getset

Timebase configuration.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112CITask.cs


5112 C# Programming Manual: JYPCIe5112.SemiPeriodMeas Class Reference

  • SemiPeriodMeas
Properties | List of all members
JYPCIe5112.SemiPeriodMeas Class Referencesealed

Configure CI Measure. More...

Properties

CITimebase | Timebase [get, set]
Timebase configuration.
EdgeType | StartingEdge [get, set]
The start edge of the input signal, the counter will count up or down on this edge.
InputTerminal | InputTerminal [get, set]
Input Terminal.

Detailed Description

Configure CI Measure.

Property Documentation

◆ InputTerminal

InputTerminal JYPCIe5112.SemiPeriodMeas.InputTerminal
getset

Input Terminal.

◆ StartingEdge

EdgeType JYPCIe5112.SemiPeriodMeas.StartingEdge
getset

The start edge of the input signal, the counter will count up or down on this edge.

◆ Timebase

CITimebase JYPCIe5112.SemiPeriodMeas.Timebase
getset

Timebase configuration.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112CITask.cs


5112 C# Programming Manual: JYPCIe5112.TwoEdgeSeparation Class Reference

  • TwoEdgeSeparation
Properties | List of all members
JYPCIe5112.TwoEdgeSeparation Class Referencesealed

Configure CI Measure. More...

Properties

CITimebase | Timebase [get, set]
Timebase configuration.
InputTerminal | FirstInputTerminal [get, set]
Input Terminal.
InputTerminal | SecondInputTerminal [get, set]
Input Terminal.
ValueReturnMode | EdgeSeparationMode [get, set]

Detailed Description

Configure CI Measure.

Property Documentation

◆ EdgeSeparationMode

ValueReturnMode JYPCIe5112.TwoEdgeSeparation.EdgeSeparationMode
getset

数据返回模式

data return mode

◆ FirstInputTerminal

InputTerminal JYPCIe5112.TwoEdgeSeparation.FirstInputTerminal
getset

Input Terminal.

◆ SecondInputTerminal

InputTerminal JYPCIe5112.TwoEdgeSeparation.SecondInputTerminal
getset

Input Terminal.

◆ Timebase

CITimebase JYPCIe5112.TwoEdgeSeparation.Timebase
getset

Timebase configuration.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112CITask.cs


5112 C# Programming Manual: JYPCIe5112.QuadEncoder Class Reference

  • QuadEncoder
Properties | List of all members
JYPCIe5112.QuadEncoder Class Referencesealed

Configure CI Measure. More...

Properties

QuadEncodingType | EncodingType [get, set]
Type of Encoding.
bool | ZReloadEnabled [get, set]
In Encoder mode ,the Z signal enable.
int | InitialCount [get, set]
Initial Count.
InputTerminal | AInputTerminal [get, set]
Input Terminal.
InputTerminal | BInputTerminal [get, set]
Input Terminal.
InputTerminal | ZInputTerminal [get, set]
Input Terminal.

Detailed Description

Configure CI Measure.

Property Documentation

◆ AInputTerminal

InputTerminal JYPCIe5112.QuadEncoder.AInputTerminal
getset

Input Terminal.

◆ BInputTerminal

InputTerminal JYPCIe5112.QuadEncoder.BInputTerminal
getset

Input Terminal.

◆ EncodingType

QuadEncodingType JYPCIe5112.QuadEncoder.EncodingType
getset

Type of Encoding.

◆ InitialCount

int JYPCIe5112.QuadEncoder.InitialCount
getset

Initial Count.

◆ ZInputTerminal

InputTerminal JYPCIe5112.QuadEncoder.ZInputTerminal
getset

Input Terminal.

◆ ZReloadEnabled

bool JYPCIe5112.QuadEncoder.ZReloadEnabled
getset

In Encoder mode ,the Z signal enable.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112CITask.cs


5112 C# Programming Manual: JYPCIe5112.TwoPulseEncoder Class Reference

  • TwoPulseEncoder
Properties | List of all members
JYPCIe5112.TwoPulseEncoder Class Referencesealed

Configure CI Measure. More...

Properties

int | InitialCount [get, set]
Initial Count.
InputTerminal | AInputTerminal [get, set]
Input Terminal.
InputTerminal | BInputTerminal [get, set]
Input Terminal.

Detailed Description

Configure CI Measure.

Property Documentation

◆ AInputTerminal

InputTerminal JYPCIe5112.TwoPulseEncoder.AInputTerminal
getset

Input Terminal.

◆ BInputTerminal

InputTerminal JYPCIe5112.TwoPulseEncoder.BInputTerminal
getset

Input Terminal.

◆ InitialCount

int JYPCIe5112.TwoPulseEncoder.InitialCount
getset

Initial Count.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112CITask.cs


5112 C# Programming Manual: JYPCIe5112.CITrigger Class Reference

  • CITrigger
Properties | List of all members
JYPCIe5112.CITrigger Class Referencesealed

Constructor to create an CITrigger task object. More...

Properties

CITriggerType | Type [get, set]
CI trigger type.
CIDigitalTrigger | Digital [get, set]
CI Digital Trigger.

Detailed Description

Constructor to create an CITrigger task object.

Used to build CI Trigger

Property Documentation

◆ Digital

CIDigitalTrigger JYPCIe5112.CITrigger.Digital
getset

CI Digital Trigger.

Valid when Type is CITriggerType.Digital

◆ Type

CITriggerType JYPCIe5112.CITrigger.Type
getset

CI trigger type.

enum Immediate/Digital/Soft.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112CITask.cs


5112 C# Programming Manual: JYPCIe5112.CIDigitalTrigger Class Reference

  • CIDigitalTrigger
Properties | List of all members
JYPCIe5112.CIDigitalTrigger Class Referencesealed

CI Digital trigger . More...

Properties

CIDigitalTriggerSource | Source [get, set]
CI Digital Trigger source.
CIDigitalTriggerEdge | Edge [get, set]
Digital Trigger edge，Rising/Falling.

Detailed Description

CI Digital trigger .

Property Documentation

◆ Edge

CIDigitalTriggerEdge JYPCIe5112.CIDigitalTrigger.Edge
getset

Digital Trigger edge，Rising/Falling.

◆ Source

CIDigitalTriggerSource JYPCIe5112.CIDigitalTrigger.Source
getset

CI Digital Trigger source.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112CITask.cs


5112 C# Programming Manual: JYPCIe5112.CISignalExport Class Reference

  • CISignalExport
Public Member Functions | List of all members
JYPCIe5112.CISignalExport Class Reference

CI Signal Export Class. More...

Public Member Functions

void | Add (CISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (CISignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

CI Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JYPCIe5112.CISignalExport.Add | ( | CISignalExportSource | source,
 |  | List< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | CI Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JYPCIe5112.CISignalExport.Add | ( | CISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | CI Signal Source
destination | Export Desination

◆ Clear()

void JYPCIe5112.CISignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JYPCIe5112.CISignalExport.ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112CITask.cs


5112 C# Programming Manual: D:/5112/C#/JYPCIe5112COTask.cs File Reference

  • File List
  • 5112
  • C#
Classes | Namespaces | Enumerations
JYPCIe5112COTask.cs File Reference

Classes

class | JYPCIe5112.JYPCIe5112COTask
JYPCIe5112 Counter Output Task. More...
class | JYPCIe5112.COTrigger
Constructor to create an COTrigger task object. More...
class | JYPCIe5112.CODigitalTrigger
CO Digital trigger . More...
class | JYPCIe5112.COPulse
Pulse Parameter. More...
class | JYPCIe5112.COExternalTimebase
class | JYPCIe5112.COTimebase
class | JYPCIe5112.COSignalExport
CO Signal Export Class. More...

Namespaces

namespace JYPCIe5112

Enumerations

enum | JYPCIe5112.COIdleState { JYPCIe5112.HighLevel = JYPCIe5112Import.JYPCIe5112_HighLevel , JYPCIe5112.LowLevel = JYPCIe5112Import.JYPCIe5112_LowLevel }
Idle state when pulse output before start and after stop. More...
enum | JYPCIe5112.COMode { JYPCIe5112.Single = 3 , JYPCIe5112.Finite = 0 , JYPCIe5112.ContinuousNoWrapping = 2 , JYPCIe5112.ContinuousWrapping = 1 }
CO output mode. More...
enum | JYPCIe5112.COTriggerType { JYPCIe5112.Immediate = JYPCIe5112Import.JYPCIe5112_CIO_Immediately , JYPCIe5112.Digital = JYPCIe5112Import.JYPCIe5112_CIO_Digital , JYPCIe5112.Soft = JYPCIe5112Import.JYPCIe5112_CIO_Soft }
TriggerType Digital/Immediate/Soft. More...
enum JYPCIe5112.CODigitalTriggerSource {
JYPCIe5112.PFI0 = 0 , JYPCIe5112.PFI1 = 1 , JYPCIe5112.PFI2 = 2 , JYPCIe5112.PFI3 = 3 ,
JYPCIe5112.PFI4 = 4 , JYPCIe5112.PFI5 = 5 , JYPCIe5112.PFI6 = 6 , JYPCIe5112.PFI7 = 7 ,
JYPCIe5112.PFI8 = 8 , JYPCIe5112.PFI9 = 9 , JYPCIe5112.PFI10 = 10 , JYPCIe5112.PFI11 = 11 ,
JYPCIe5112.PFI12 = 12 , JYPCIe5112.PFI13 = 13 , JYPCIe5112.PFI14 = 14 , JYPCIe5112.PFI15 = 15 ,
JYPCIe5112.PXI_Trig0 = 16 , JYPCIe5112.PXI_Trig1 = 17 , JYPCIe5112.PXI_Trig2 = 18 , JYPCIe5112.PXI_Trig3 = 19 ,
JYPCIe5112.PXI_Trig4 = 20 , JYPCIe5112.PXI_Trig5 = 21 , JYPCIe5112.PXI_Trig6 = 22 , JYPCIe5112.PXI_Trig7 = 23 ,
JYPCIe5112.AI_StartTrig = 24 , JYPCIe5112.AI_ReferenceTrig = 25 , JYPCIe5112.AO_StartTrig = 26 , JYPCIe5112.CIO_0_StartTrig = 27 ,
JYPCIe5112.CIO_1_StartTrig = 28 , JYPCIe5112.CO0_Output = 29 , JYPCIe5112.CO1_Output = 30
}
CO Digital trigger source. More...
enum | JYPCIe5112.CODigitalTriggerEdge { JYPCIe5112.Rising , JYPCIe5112.Falling }
CO Digital Trigger Edge. More...
enum | JYPCIe5112.COPulseType { JYPCIe5112.DutyCycleFrequency , JYPCIe5112.HighLowTime , JYPCIe5112.HighLowTick }
Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick. More...
enum | JYPCIe5112.COTimebaseSource { JYPCIe5112.Internal100MHz = 0 , JYPCIe5112.Internal5MHz = 1 , JYPCIe5112.Internal100kHz = 2 , JYPCIe5112.External = 3 }
enum | JYPCIe5112.COSignalExportSource { JYPCIe5112.StartTrig , JYPCIe5112.Output }
SourceSignal. More...


5112 C# Programming Manual: JYPCIe5112.JYPCIe5112COTask Class Reference

  • JYPCIe5112COTask
Public Member Functions | Properties | List of all members
JYPCIe5112.JYPCIe5112COTask Class Referencesealed

JYPCIe5112 Counter Output Task. More...

Public Member Functions

JYPCIe5112COTask (int slotNum, int channel)
Constructor.
JYPCIe5112COTask (string boardName, int channel)
Constructor.
void | WriteSinglePoint (COPulse pulse)
Write a single pulse parameter to the register.
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Start ()
Start CO task .
void | Stop ()
Stop COtask .
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.

Properties

IOTerminal | OutputTerminal [get, set]
PauseTrigger | Pause [get, set]
COTimebase | Timebase [get, set]
CO's time base.
double | InitialDelay [get, set]
Counter output initial delay in seconds.
COIdleState | IdleState [get, set]
Idle state when pulse output before start and after stop.
JYPCIe5112Device | Device [get]
Device.
COSignalExport | SignalExport [get, set]
Export CO Signal Configuration.

Detailed Description

JYPCIe5112 Counter Output Task.

Constructor & Destructor Documentation

◆ JYPCIe5112COTask() [1/2]

JYPCIe5112.JYPCIe5112COTask.JYPCIe5112COTask | ( | int | slotNum,
 |  | int | channel )

Constructor.

Used to create an CO task by a slot number.

Parameters
slotNum | Card slot number.
channel | Counter channel （5112 support0-1）.

◆ JYPCIe5112COTask() [2/2]

JYPCIe5112.JYPCIe5112COTask.JYPCIe5112COTask | ( | string | boardName,
 |  | int | channel )

Constructor.

Used to create an CO task by a board name.

Parameters
boardName | Board name(device alias), set by device manager
channel | Counter channel （5112 support0-1）.

Member Function Documentation

◆ SendSoftwareTrigger()

void JYPCIe5112.JYPCIe5112COTask.SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JYPCIe5112.JYPCIe5112COTask.Start ( )

Start CO task .

◆ Stop()

void JYPCIe5112.JYPCIe5112COTask.Stop ( )

Stop COtask .

◆ WaitUntilDone()

bool JYPCIe5112.JYPCIe5112COTask.WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteSinglePoint()

void JYPCIe5112.JYPCIe5112COTask.WriteSinglePoint ( COPulse pulse )

Write a single pulse parameter to the register.

This function is also available after starting the task when the number of pulses being sent is infinite.

Parameters
pulse Pulse Parameter

Property Documentation

◆ Device

JYPCIe5112Device JYPCIe5112.JYPCIe5112COTask.Device
get

Device.

◆ IdleState

COIdleState JYPCIe5112.JYPCIe5112COTask.IdleState
getset

Idle state when pulse output before start and after stop.

◆ InitialDelay

double JYPCIe5112.JYPCIe5112COTask.InitialDelay
getset

Counter output initial delay in seconds.

There are five ticks of the timebase fixed delay in counter internal, so the total delay(s) = InitialDelay + (5 / timebase)

◆ OutputTerminal

IOTerminal JYPCIe5112.JYPCIe5112COTask.OutputTerminal
getset

脉冲输出端口

Pulse Output Terminal

◆ Pause

PauseTrigger JYPCIe5112.JYPCIe5112COTask.Pause
getset

暂停触发配置

Pause Trigger Configuration

◆ SignalExport

COSignalExport JYPCIe5112.JYPCIe5112COTask.SignalExport
getset

Export CO Signal Configuration.

◆ Timebase

COTimebase JYPCIe5112.JYPCIe5112COTask.Timebase
getset

CO's time base.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112COTask.cs


5112 C# Programming Manual: JYPCIe5112.COTrigger Class Reference

  • COTrigger
Properties | List of all members
JYPCIe5112.COTrigger Class Referencesealed

Constructor to create an COTrigger task object. More...

Properties

COTriggerType | Type [get, set]
CO trigger type.
CODigitalTrigger | Digital [get, set]
CO Digital Trigger.

Detailed Description

Constructor to create an COTrigger task object.

Used to build CO Trigger

Property Documentation

◆ Digital

CODigitalTrigger JYPCIe5112.COTrigger.Digital
getset

CO Digital Trigger.

Valid when Type is COTriggerType.Digital

◆ Type

COTriggerType JYPCIe5112.COTrigger.Type
getset

CO trigger type.

enum Immediate/Digital/Soft.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112COTask.cs


5112 C# Programming Manual: JYPCIe5112.CODigitalTrigger Class Reference

  • CODigitalTrigger
Properties | List of all members
JYPCIe5112.CODigitalTrigger Class Referencesealed

CO Digital trigger . More...

Properties

CODigitalTriggerSource | Source [get, set]
CO Digital Trigger source.
CODigitalTriggerEdge | Edge [get, set]
Digital Trigger edge，Rising/Falling.

Detailed Description

CO Digital trigger .

Property Documentation

◆ Edge

CODigitalTriggerEdge JYPCIe5112.CODigitalTrigger.Edge
getset

Digital Trigger edge，Rising/Falling.

◆ Source

CODigitalTriggerSource JYPCIe5112.CODigitalTrigger.Source
getset

CO Digital Trigger source.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112COTask.cs


5112 C# Programming Manual: JYPCIe5112.COPulse Class Reference

  • COPulse
Public Member Functions | List of all members
JYPCIe5112.COPulse Class Reference

Pulse Parameter. More...

Public Member Functions

COPulse (COPulseType type, double param1, double param2, int count)
Pulse Parameter.

Detailed Description

Pulse Parameter.

Constructor & Destructor Documentation

◆ COPulse()

JYPCIe5112.COPulse.COPulse | ( | COPulseType | type,
 |  | double | param1,
 |  | double | param2,
 |  | int | count )

Pulse Parameter.

Parameters
type | The pulse type characteristics.
param1 | Parameter 1. Frequency (Hz) when constructed as COPulseType.DutyCycleFrequency; High duration in seconds when constructed as COPulseType.HighLowTime; High ticks of the clock when constructed as COPulseType.HighLowTick.
param2 | Parameter 1. Duty cycle (greater than 0 and less than 1) when constructed as COPulseType.DutyCycleFrequency; Low duration in seconds when constructed as COPulseType.HighLowTime; Low ticks of the clock when constructed as COPulseType.HighLowTick.
count | Number of pulses. When the value is -1 (indicating that the number of pulses is infinite), pulses will be continuously sent until requested to stop.
The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112COTask.cs


5112 C# Programming Manual: JYPCIe5112.COExternalTimebase Class Reference

  • COExternalTimebase
Properties | List of all members
JYPCIe5112.COExternalTimebase Class Referencesealed

Properties

InputTerminal | Terminal [get, set]
double | Frequency [get, set]

Detailed Description

外部时基配置类

External timebase configuration class

Property Documentation

◆ Frequency

double JYPCIe5112.COExternalTimebase.Frequency
getset

外部时基的频率

Frequency of The External Timebase

◆ Terminal

InputTerminal JYPCIe5112.COExternalTimebase.Terminal
getset

外部时基的输入端口

External Timebase Input Terminal

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112COTask.cs


5112 C# Programming Manual: JYPCIe5112.COTimebase Class Reference

  • COTimebase
Properties | List of all members
JYPCIe5112.COTimebase Class Referencesealed

Properties

COTimebaseSource | Source [get, set]
COExternalTimebase | External [get, set]

Detailed Description

时基配置类

Timebase configuration class

Property Documentation

◆ External

COExternalTimebase JYPCIe5112.COTimebase.External
getset

外部时基配置。当 COTimebase.Source 为 COTimebaseSource.External时有效。

External Timebase Configuration. Valid when COTimebase.Source is COTimebaseSource.External.

◆ Source

COTimebaseSource JYPCIe5112.COTimebase.Source
getset

时基源。默认值为 COTimebaseSource.Internal100MHz。

Timebase Source. The default value is COTimebaseSource.Internal100MHz.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112COTask.cs


5112 C# Programming Manual: JYPCIe5112.COSignalExport Class Reference

  • COSignalExport
Public Member Functions | List of all members
JYPCIe5112.COSignalExport Class Reference

CO Signal Export Class. More...

Public Member Functions

void | Add (COSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (COSignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

CO Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JYPCIe5112.COSignalExport.Add | ( | COSignalExportSource | source,
 |  | List< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | CO Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JYPCIe5112.COSignalExport.Add | ( | COSignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | CO Signal Source
destination | Export Desination

◆ Clear()

void JYPCIe5112.COSignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JYPCIe5112.COSignalExport.ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112COTask.cs


5112 C# Programming Manual: D:/5112/C#/JYPCIe5112DITask.cs File Reference

  • File List
  • 5112
  • C#
Classes | Namespaces
JYPCIe5112DITask.cs File Reference

Classes

class | JYPCIe5112.JYPCIe5112DITask
JYPCIe5112 Digital Iuput Task. More...
class | JYPCIe5112.DIChannel
DI Channel parameter class . More...

Namespaces

namespace JYPCIe5112


5112 C# Programming Manual: JYPCIe5112.JYPCIe5112DITask Class Reference

  • JYPCIe5112DITask
Public Member Functions | Properties | List of all members
JYPCIe5112.JYPCIe5112DITask Class Referencesealed

JYPCIe5112 Digital Iuput Task. More...

Public Member Functions

JYPCIe5112DITask (int slotNum)
Constructor.
JYPCIe5112DITask (string boardName)
Constructor.
void | AddChannel (int portNum)
Add one channel.
void | AddChannel (int[] portsNum)
Add a group of channel.
void | RemoveChannel (int portNum)
Delete the specified port number .If it is -1, delete all ports.
void | Start ()
Start DI task .
void | Stop ()
Stop DI task .
void | ReadSinglePoint (ref bool[] readValues, int port)
Read one sample for specified channel in register.
void | ReadSinglePoint (ref bool[] readValues)
Read one sample for all ports in register.

Properties

List< DIChannel > | Channels [get]
List of DI channels,(5112 support 3 ports)
JYPCIe5112Device | Device [get]
Device.

Detailed Description

JYPCIe5112 Digital Iuput Task.

Constructor & Destructor Documentation

◆ JYPCIe5112DITask() [1/2]

JYPCIe5112.JYPCIe5112DITask.JYPCIe5112DITask ( int slotNum )

Constructor.

Used to create an DItask by a slot number.

Parameters
slotNum Card slot number.

◆ JYPCIe5112DITask() [2/2]

JYPCIe5112.JYPCIe5112DITask.JYPCIe5112DITask ( string boardName )

Constructor.

Used to create an DI task by a board name.

Parameters
boardName Board name(device alias), set by device manager

Member Function Documentation

◆ AddChannel() [1/2]

void JYPCIe5112.JYPCIe5112DITask.AddChannel ( int portNum )

Add one channel.

Parameters
portNum port number to be added.

◆ AddChannel() [2/2]

void JYPCIe5112.JYPCIe5112DITask.AddChannel ( int[] portsNum )

Add a group of channel.

Parameters
portsNum an array of port numbers of added ports.

◆ ReadSinglePoint() [1/2]

void JYPCIe5112.JYPCIe5112DITask.ReadSinglePoint ( ref bool[] readValues )

Read one sample for all ports in register.

Parameters
readValues Values read. Buffer size >= number of ports * 8.

◆ ReadSinglePoint() [2/2]

void JYPCIe5112.JYPCIe5112DITask.ReadSinglePoint | ( | ref bool[] | readValues,
 |  | int | port )

Read one sample for specified channel in register.

Parameters
readValues | values read,. Buffer size >= 8
port | Specified port numbers.

◆ RemoveChannel()

void JYPCIe5112.JYPCIe5112DITask.RemoveChannel ( int portNum )

Delete the specified port number .If it is -1, delete all ports.

Parameters
portNum port number to be delete.

◆ Start()

void JYPCIe5112.JYPCIe5112DITask.Start ( )

Start DI task .

◆ Stop()

void JYPCIe5112.JYPCIe5112DITask.Stop ( )

Stop DI task .

Property Documentation

◆ Channels

List<DIChannel> JYPCIe5112.JYPCIe5112DITask.Channels
get

List of DI channels,(5112 support 3 ports)

◆ Device

JYPCIe5112Device JYPCIe5112.JYPCIe5112DITask.Device
get

Device.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112DITask.cs


5112 C# Programming Manual: JYPCIe5112.DIChannel Class Reference

  • DIChannel
Properties | List of all members
JYPCIe5112.DIChannel Class Referencesealed

DI Channel parameter class . More...

Properties

int PortNum [get, set]
port number.

Detailed Description

DI Channel parameter class .

Property Documentation

◆ PortNum

int JYPCIe5112.DIChannel.PortNum
getset

port number.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112DITask.cs


5112 C# Programming Manual: D:/5112/C#/JYPCIe5112DOTask.cs File Reference

  • File List
  • 5112
  • C#
Classes | Namespaces
JYPCIe5112DOTask.cs File Reference

Classes

class | JYPCIe5112.JYPCIe5112DOTask
JYPCIe5112 Digital Output Task. More...
class | JYPCIe5112.DOChannel
DO Channel parameter class . More...

Namespaces

namespace JYPCIe5112


5112 C# Programming Manual: JYPCIe5112.JYPCIe5112DOTask Class Reference

  • JYPCIe5112DOTask
Public Member Functions | Properties | List of all members
JYPCIe5112.JYPCIe5112DOTask Class Referencesealed

JYPCIe5112 Digital Output Task. More...

Public Member Functions

JYPCIe5112DOTask (int slotNum)
Constructor.
JYPCIe5112DOTask (string boardName)
Constructor.
void | AddChannel (int portNum)
Add one channel.
void | AddChannel (int[] portsNum)
Add a group of channels.
void | RemoveChannel (int portNum)
Delete the specified port number .If it is -1, delete all ports.
void | Start ()
Start DO task .
void | Stop ()
Stop DO task .
void | WriteSinglePoint (bool[] writeValues, int port)
Write one sample to the specified port in register.
void | WriteSinglePoint (bool[] writeValues)
write one sample to all ports in register .

Properties

List< DOChannel > | Channels [get]
List of DO channels,(5112 support 3 ports)
JYPCIe5112Device | Device [get]
Device.

Detailed Description

JYPCIe5112 Digital Output Task.

Constructor & Destructor Documentation

◆ JYPCIe5112DOTask() [1/2]

JYPCIe5112.JYPCIe5112DOTask.JYPCIe5112DOTask ( int slotNum )

Constructor.

Used to create an DOtask by a slot number.

Parameters
slotNum Card slot number.

◆ JYPCIe5112DOTask() [2/2]

JYPCIe5112.JYPCIe5112DOTask.JYPCIe5112DOTask ( string boardName )

Constructor.

Used to create an DO task by a board name.

Parameters
boardName Board name(device alias), set by device manager

Member Function Documentation

◆ AddChannel() [1/2]

void JYPCIe5112.JYPCIe5112DOTask.AddChannel ( int portNum )

Add one channel.

Parameters
portNum port number to be added.

◆ AddChannel() [2/2]

void JYPCIe5112.JYPCIe5112DOTask.AddChannel ( int[] portsNum )

Add a group of channels.

Parameters
portsNum an array of port numbers of added ports.

◆ RemoveChannel()

void JYPCIe5112.JYPCIe5112DOTask.RemoveChannel ( int portNum )

Delete the specified port number .If it is -1, delete all ports.

Parameters
portNum port number to be delete.

◆ Start()

void JYPCIe5112.JYPCIe5112DOTask.Start ( )

Start DO task .

◆ Stop()

void JYPCIe5112.JYPCIe5112DOTask.Stop ( )

Stop DO task .

◆ WriteSinglePoint() [1/2]

void JYPCIe5112.JYPCIe5112DOTask.WriteSinglePoint ( bool[] writeValues )

write one sample to all ports in register .

Parameters
writeValues Data to be written.Buffer size >= number of ports * 8。

◆ WriteSinglePoint() [2/2]

void JYPCIe5112.JYPCIe5112DOTask.WriteSinglePoint | ( | bool[] | writeValues,
 |  | int | port )

Write one sample to the specified port in register.

Parameters
writeValues | Write values..Buffer size >= 8
port | Specified port.

Property Documentation

◆ Channels

List<DOChannel> JYPCIe5112.JYPCIe5112DOTask.Channels
get

List of DO channels,(5112 support 3 ports)

◆ Device

JYPCIe5112Device JYPCIe5112.JYPCIe5112DOTask.Device
get

Device.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112DOTask.cs


5112 C# Programming Manual: JYPCIe5112.DOChannel Class Reference

  • DOChannel
Properties | List of all members
JYPCIe5112.DOChannel Class Referencesealed

DO Channel parameter class . More...

Properties

int PortNum [get, set]
port number.

Detailed Description

DO Channel parameter class .

Property Documentation

◆ PortNum

int JYPCIe5112.DOChannel.PortNum
getset

port number.

The documentation for this class was generated from the following file:
  • D:/5112/C#/JYPCIe5112DOTask.cs


5112 C# Programming Manual: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
▼N JYPCIe5112 |
C AIAdvanced | AI Advance parameter
C AIAnalogEdgeComparator | AI Analog Edge Comparator
C AIAnalogHysteresisComparator | AI Analog Hysteresis Comparatorr
C AIAnalogTrigger | AI analog trigger
C AIAnalogWindowComparator | AI Analog Window Comparatorr
C AIChannel | AI Channel parameter class
C AIDigitalTrigger | AI Digital trigger class
C AIExternalSampleClock | External Sample Clock Configuration Class
C AIRecord | AI Record Parameters
C AISampleClock | Sample clock configuration class
C AISignalExport | AI Signal Export Class
C AITrigger | Constructor to create an AITrigger task object
C AOChannel | AO Channel parameter class
C AODigitalTrigger | AO Digital trigger
C AOExternalSampleClock | External Sample Clock Configuration Class
C AOSampleClock | AO Sample clock configuration class
C AOSignalExport | AO Signal Export Class
C AOTrigger | Constructor to create an AOTrigger task object
C CIDigitalTrigger | CI Digital trigger
C CIExternalTimebase |
C CISignalExport | CI Signal Export Class
C CITimebase |
C CITrigger | Constructor to create an CITrigger task object
C CODigitalTrigger | CO Digital trigger
C COExternalTimebase |
C COPulse | Pulse Parameter
C COSignalExport | CO Signal Export Class
C COTimebase |
C COTrigger | Constructor to create an COTrigger task object
C DIChannel | DI Channel parameter class
C DOChannel | DO Channel parameter class
C EdgeCounting | Configure CI EdgeCounting
C EdgeCountingOutEvent | Edge counting output event configuration class
C FrequencyMeas | Configure CI Measure
C JYPCIe5112AITask | JYPCIe5112 Analog Input Task
C JYPCIe5112AOTask | JYPCIe5112 Analog Ouput Task
C JYPCIe5112CITask | JYPCIe5112 Counter Input Task
C JYPCIe5112COTask | JYPCIe5112 Counter Output Task
C JYPCIe5112DITask | JYPCIe5112 Digital Iuput Task
C JYPCIe5112DOTask | JYPCIe5112 Digital Output Task
C PauseTrigger | Pause trigger configuration class
C PeriodMeas | Configure CI Measure
C PulseMeas | Configure CI Measure
C QuadEncoder | Configure CI Measure
C SemiPeriodMeas | Configure CI Measure
C TwoEdgeSeparation | Configure CI Measure
C TwoPulseEncoder | Configure CI Measure


5112 C# Programming Manual: Member List

  • AIAdvanced
JYPCIe5112.AIAdvanced Member List

This is the complete list of members for JYPCIe5112.AIAdvanced, including all inherited members.

ConvertRate JYPCIe5112.AIAdvanced


5112 C# Programming Manual: Member List

  • AIAnalogEdgeComparator
JYPCIe5112.AIAnalogEdgeComparator Member List

This is the complete list of members for JYPCIe5112.AIAnalogEdgeComparator, including all inherited members.

Slope | JYPCIe5112.AIAnalogEdgeComparator
Threshold | JYPCIe5112.AIAnalogEdgeComparator


5112 C# Programming Manual: Member List

  • AIAnalogHysteresisComparator
JYPCIe5112.AIAnalogHysteresisComparator Member List

This is the complete list of members for JYPCIe5112.AIAnalogHysteresisComparator, including all inherited members.

HighThreshold | JYPCIe5112.AIAnalogHysteresisComparator
LowThreshold | JYPCIe5112.AIAnalogHysteresisComparator
Slope | JYPCIe5112.AIAnalogHysteresisComparator


5112 C# Programming Manual: Member List

  • AIAnalogTrigger
JYPCIe5112.AIAnalogTrigger Member List

This is the complete list of members for JYPCIe5112.AIAnalogTrigger, including all inherited members.

Comparator | JYPCIe5112.AIAnalogTrigger
Edge | JYPCIe5112.AIAnalogTrigger
Hysteresis | JYPCIe5112.AIAnalogTrigger
Source | JYPCIe5112.AIAnalogTrigger
Window | JYPCIe5112.AIAnalogTrigger


5112 C# Programming Manual: Member List

  • AIAnalogWindowComparator
JYPCIe5112.AIAnalogWindowComparator Member List

This is the complete list of members for JYPCIe5112.AIAnalogWindowComparator, including all inherited members.

Condition | JYPCIe5112.AIAnalogWindowComparator
HighThreshold | JYPCIe5112.AIAnalogWindowComparator
LowThreshold | JYPCIe5112.AIAnalogWindowComparator


5112 C# Programming Manual: Member List

  • AIChannel
JYPCIe5112.AIChannel Member List

This is the complete list of members for JYPCIe5112.AIChannel, including all inherited members.

AIChannel(int channelId, double rangeLow, double rangeHigh, AITerminal terminalCfg=AITerminal.NRSE) | JYPCIe5112.AIChannel
ChannelID | JYPCIe5112.AIChannel
RangeHigh | JYPCIe5112.AIChannel
RangeLow | JYPCIe5112.AIChannel
Terminal | JYPCIe5112.AIChannel


5112 C# Programming Manual: Member List

  • AIDigitalTrigger
JYPCIe5112.AIDigitalTrigger Member List

This is the complete list of members for JYPCIe5112.AIDigitalTrigger, including all inherited members.

Edge | JYPCIe5112.AIDigitalTrigger
Source | JYPCIe5112.AIDigitalTrigger


5112 C# Programming Manual: Member List

  • AIExternalSampleClock
JYPCIe5112.AIExternalSampleClock Member List

This is the complete list of members for JYPCIe5112.AIExternalSampleClock, including all inherited members.

ExpectedRate | JYPCIe5112.AIExternalSampleClock
Terminal | JYPCIe5112.AIExternalSampleClock


5112 C# Programming Manual: Member List

  • AIRecord
JYPCIe5112.AIRecord Member List

This is the complete list of members for JYPCIe5112.AIRecord, including all inherited members.

FileFormat | JYPCIe5112.AIRecord
FilePath | JYPCIe5112.AIRecord
Length | JYPCIe5112.AIRecord
Mode | JYPCIe5112.AIRecord


5112 C# Programming Manual: Member List

  • AISampleClock
JYPCIe5112.AISampleClock Member List

This is the complete list of members for JYPCIe5112.AISampleClock, including all inherited members.

External | JYPCIe5112.AISampleClock
Source | JYPCIe5112.AISampleClock


5112 C# Programming Manual: Member List

  • AISignalExport
JYPCIe5112.AISignalExport Member List

This is the complete list of members for JYPCIe5112.AISignalExport, including all inherited members.

Add(AISignalExportSource source, SignalExportDestination destination) | JYPCIe5112.AISignalExport
Add(AISignalExportSource source, List< SignalExportDestination > destinations) | JYPCIe5112.AISignalExport
Clear(SignalExportDestination destination) | JYPCIe5112.AISignalExport
ClearAll() | JYPCIe5112.AISignalExport


5112 C# Programming Manual: Member List

  • AITrigger
JYPCIe5112.AITrigger Member List

This is the complete list of members for JYPCIe5112.AITrigger, including all inherited members.

Analog | JYPCIe5112.AITrigger
Digital | JYPCIe5112.AITrigger
Mode | JYPCIe5112.AITrigger
PreTriggerSamples | JYPCIe5112.AITrigger
ReTriggerCount | JYPCIe5112.AITrigger
Type | JYPCIe5112.AITrigger


5112 C# Programming Manual: Member List

  • AOChannel
JYPCIe5112.AOChannel Member List

This is the complete list of members for JYPCIe5112.AOChannel, including all inherited members.

ChannelID | JYPCIe5112.AOChannel
RangeHigh | JYPCIe5112.AOChannel
RangeLow | JYPCIe5112.AOChannel


5112 C# Programming Manual: Member List

  • AODigitalTrigger
JYPCIe5112.AODigitalTrigger Member List

This is the complete list of members for JYPCIe5112.AODigitalTrigger, including all inherited members.

Edge | JYPCIe5112.AODigitalTrigger
Source | JYPCIe5112.AODigitalTrigger


5112 C# Programming Manual: Member List

  • AOExternalSampleClock
JYPCIe5112.AOExternalSampleClock Member List

This is the complete list of members for JYPCIe5112.AOExternalSampleClock, including all inherited members.

ExpectedRate | JYPCIe5112.AOExternalSampleClock
Terminal | JYPCIe5112.AOExternalSampleClock


5112 C# Programming Manual: Member List

  • AOSampleClock
JYPCIe5112.AOSampleClock Member List

This is the complete list of members for JYPCIe5112.AOSampleClock, including all inherited members.

External | JYPCIe5112.AOSampleClock
Source | JYPCIe5112.AOSampleClock


5112 C# Programming Manual: Member List

  • AOSignalExport
JYPCIe5112.AOSignalExport Member List

This is the complete list of members for JYPCIe5112.AOSignalExport, including all inherited members.

Add(AOSignalExportSource source, SignalExportDestination destination) | JYPCIe5112.AOSignalExport
Add(AOSignalExportSource source, List< SignalExportDestination > destinations) | JYPCIe5112.AOSignalExport
Clear(SignalExportDestination destination) | JYPCIe5112.AOSignalExport
ClearAll() | JYPCIe5112.AOSignalExport


5112 C# Programming Manual: Member List

  • AOTrigger
JYPCIe5112.AOTrigger Member List

This is the complete list of members for JYPCIe5112.AOTrigger, including all inherited members.

Digital | JYPCIe5112.AOTrigger
Type | JYPCIe5112.AOTrigger


5112 C# Programming Manual: Member List

  • CIDigitalTrigger
JYPCIe5112.CIDigitalTrigger Member List

This is the complete list of members for JYPCIe5112.CIDigitalTrigger, including all inherited members.

Edge | JYPCIe5112.CIDigitalTrigger
Source | JYPCIe5112.CIDigitalTrigger


5112 C# Programming Manual: Member List

  • CIExternalTimebase
JYPCIe5112.CIExternalTimebase Member List

This is the complete list of members for JYPCIe5112.CIExternalTimebase, including all inherited members.

Frequency | JYPCIe5112.CIExternalTimebase
Terminal | JYPCIe5112.CIExternalTimebase


5112 C# Programming Manual: Member List

  • CISignalExport
JYPCIe5112.CISignalExport Member List

This is the complete list of members for JYPCIe5112.CISignalExport, including all inherited members.

Add(CISignalExportSource source, SignalExportDestination destination) | JYPCIe5112.CISignalExport
Add(CISignalExportSource source, List< SignalExportDestination > destinations) | JYPCIe5112.CISignalExport
Clear(SignalExportDestination destination) | JYPCIe5112.CISignalExport
ClearAll() | JYPCIe5112.CISignalExport


5112 C# Programming Manual: Member List

  • CITimebase
JYPCIe5112.CITimebase Member List

This is the complete list of members for JYPCIe5112.CITimebase, including all inherited members.

External | JYPCIe5112.CITimebase
Source | JYPCIe5112.CITimebase


5112 C# Programming Manual: Member List

  • CITrigger
JYPCIe5112.CITrigger Member List

This is the complete list of members for JYPCIe5112.CITrigger, including all inherited members.

Digital | JYPCIe5112.CITrigger
Type | JYPCIe5112.CITrigger


5112 C# Programming Manual: Member List

  • CODigitalTrigger
JYPCIe5112.CODigitalTrigger Member List

This is the complete list of members for JYPCIe5112.CODigitalTrigger, including all inherited members.

Edge | JYPCIe5112.CODigitalTrigger
Source | JYPCIe5112.CODigitalTrigger


5112 C# Programming Manual: Member List

  • COExternalTimebase
JYPCIe5112.COExternalTimebase Member List

This is the complete list of members for JYPCIe5112.COExternalTimebase, including all inherited members.

Frequency | JYPCIe5112.COExternalTimebase
Terminal | JYPCIe5112.COExternalTimebase


5112 C# Programming Manual: Member List

  • COPulse
JYPCIe5112.COPulse Member List

This is the complete list of members for JYPCIe5112.COPulse, including all inherited members.

COPulse(COPulseType type, double param1, double param2, int count) JYPCIe5112.COPulse


5112 C# Programming Manual: Member List

  • COSignalExport
JYPCIe5112.COSignalExport Member List

This is the complete list of members for JYPCIe5112.COSignalExport, including all inherited members.

Add(COSignalExportSource source, SignalExportDestination destination) | JYPCIe5112.COSignalExport
Add(COSignalExportSource source, List< SignalExportDestination > destinations) | JYPCIe5112.COSignalExport
Clear(SignalExportDestination destination) | JYPCIe5112.COSignalExport
ClearAll() | JYPCIe5112.COSignalExport


5112 C# Programming Manual: Member List

  • COTimebase
JYPCIe5112.COTimebase Member List

This is the complete list of members for JYPCIe5112.COTimebase, including all inherited members.

External | JYPCIe5112.COTimebase
Source | JYPCIe5112.COTimebase


5112 C# Programming Manual: Member List

  • COTrigger
JYPCIe5112.COTrigger Member List

This is the complete list of members for JYPCIe5112.COTrigger, including all inherited members.

Digital | JYPCIe5112.COTrigger
Type | JYPCIe5112.COTrigger


5112 C# Programming Manual: Member List

  • DIChannel
JYPCIe5112.DIChannel Member List

This is the complete list of members for JYPCIe5112.DIChannel, including all inherited members.

PortNum JYPCIe5112.DIChannel


5112 C# Programming Manual: Member List

  • DOChannel
JYPCIe5112.DOChannel Member List

This is the complete list of members for JYPCIe5112.DOChannel, including all inherited members.

PortNum JYPCIe5112.DOChannel


5112 C# Programming Manual: Member List

  • EdgeCounting
JYPCIe5112.EdgeCounting Member List

This is the complete list of members for JYPCIe5112.EdgeCounting, including all inherited members.

ActiveEdge | JYPCIe5112.EdgeCounting
Direction | JYPCIe5112.EdgeCounting
DirTerminal | JYPCIe5112.EdgeCounting
InitialCount | JYPCIe5112.EdgeCounting
InputTerminal | JYPCIe5112.EdgeCounting
OutEvent | JYPCIe5112.EdgeCounting
Pause | JYPCIe5112.EdgeCounting


5112 C# Programming Manual: Member List

  • EdgeCountingOutEvent
JYPCIe5112.EdgeCountingOutEvent Member List

This is the complete list of members for JYPCIe5112.EdgeCountingOutEvent, including all inherited members.

IdleState | JYPCIe5112.EdgeCountingOutEvent
Terminal | JYPCIe5112.EdgeCountingOutEvent
Threshold | JYPCIe5112.EdgeCountingOutEvent


5112 C# Programming Manual: Member List

  • FrequencyMeas
JYPCIe5112.FrequencyMeas Member List

This is the complete list of members for JYPCIe5112.FrequencyMeas, including all inherited members.

InputTerminal | JYPCIe5112.FrequencyMeas
Timebase | JYPCIe5112.FrequencyMeas


5112 C# Programming Manual: Member List

  • JYPCIe5112AITask
JYPCIe5112.JYPCIe5112AITask Member List

This is the complete list of members for JYPCIe5112.JYPCIe5112AITask, including all inherited members.

AddChannel(int chnId, double rangeLow=-10, double rangeHigh=10, AITerminal terminalCfg=AITerminal.RSE) | JYPCIe5112.JYPCIe5112AITask
AddChannel(int[] chnsId, double rangeLow=-10, double rangeHigh=10, AITerminal terminalCfg=AITerminal.RSE) | JYPCIe5112.JYPCIe5112AITask
AddChannel(int[] chnsId, double[] rangeLow, double[] rangeHigh, AITerminal terminalCfg=AITerminal.RSE) | JYPCIe5112.JYPCIe5112AITask
Advanced | JYPCIe5112.JYPCIe5112AITask
AvailableSamples | JYPCIe5112.JYPCIe5112AITask
BufLenInSamples | JYPCIe5112.JYPCIe5112AITask
Channels | JYPCIe5112.JYPCIe5112AITask
Device | JYPCIe5112.JYPCIe5112AITask
DisableCalibration | JYPCIe5112.JYPCIe5112AITask
GetRecordPreviewData(ref double[,] buf, int samplesPerChannel, int timeout) | JYPCIe5112.JYPCIe5112AITask
GetRecordPreviewData(ref double[,] buf, int timeout=-1) | JYPCIe5112.JYPCIe5112AITask
GetRecordPreviewData(ref double[] buf, int samplesPerChannel, int timeout) | JYPCIe5112.JYPCIe5112AITask
GetRecordPreviewData(ref double[] buf, int timeout=-1) | JYPCIe5112.JYPCIe5112AITask
GetRecordStatus(out double recordedLength, out bool recordDone) | JYPCIe5112.JYPCIe5112AITask
JYPCIe5112AITask(int slotNum) | JYPCIe5112.JYPCIe5112AITask
JYPCIe5112AITask(string boardName) | JYPCIe5112.JYPCIe5112AITask
Mode | JYPCIe5112.JYPCIe5112AITask
ReadData(IntPtr buf, int samplesPerChannel, int timeout) | JYPCIe5112.JYPCIe5112AITask
ReadData(ref double[,] buf, int samplesPerChannel, int timeout) | JYPCIe5112.JYPCIe5112AITask
ReadData(ref double[,] buf, int timeout=-1) | JYPCIe5112.JYPCIe5112AITask
ReadData(ref double[] buf, int samplesPerChannel, int timeout) | JYPCIe5112.JYPCIe5112AITask
ReadData(ref double[] buf, int timeout=-1) | JYPCIe5112.JYPCIe5112AITask
ReadRawData(IntPtr buf, int samplesPerChannel, int timeout) | JYPCIe5112.JYPCIe5112AITask
ReadRawData(ref short[,] buf, int samplesPerChannel, int timeout) | JYPCIe5112.JYPCIe5112AITask
ReadRawData(ref short[,] buf, int timeout=-1) | JYPCIe5112.JYPCIe5112AITask
ReadRawData(ref short[] buf, int samplesPerChannel, int timeout) | JYPCIe5112.JYPCIe5112AITask
ReadRawData(ref short[] buf, int timeout=-1) | JYPCIe5112.JYPCIe5112AITask
ReadRawSinglePoint(ref short[] readValues) | JYPCIe5112.JYPCIe5112AITask
ReadRawSinglePoint(ref short readValue, int channel) | JYPCIe5112.JYPCIe5112AITask
ReadSinglePoint(ref double[] readValues) | JYPCIe5112.JYPCIe5112AITask
ReadSinglePoint(ref double readValue, int channel) | JYPCIe5112.JYPCIe5112AITask
Record | JYPCIe5112.JYPCIe5112AITask
RemoveChannel(int chnId) | JYPCIe5112.JYPCIe5112AITask
SampleClock | JYPCIe5112.JYPCIe5112AITask
SampleRate | JYPCIe5112.JYPCIe5112AITask
SamplesToAcquire | JYPCIe5112.JYPCIe5112AITask
SendSoftwareTrigger() | JYPCIe5112.JYPCIe5112AITask
SignalExport | JYPCIe5112.JYPCIe5112AITask
Start() | JYPCIe5112.JYPCIe5112AITask
Stop() | JYPCIe5112.JYPCIe5112AITask
TransferedSamples | JYPCIe5112.JYPCIe5112AITask
Trigger | JYPCIe5112.JYPCIe5112AITask
WaitUntilDone(int timeout=-1) | JYPCIe5112.JYPCIe5112AITask


5112 C# Programming Manual: Member List

  • JYPCIe5112AOTask
JYPCIe5112.JYPCIe5112AOTask Member List

This is the complete list of members for JYPCIe5112.JYPCIe5112AOTask, including all inherited members.

AddChannel(int chnId, double rangeLow=-10, double rangeHigh=10) | JYPCIe5112.JYPCIe5112AOTask
AddChannel(int[] chnsId, double rangeLow=-10, double rangeHigh=10) | JYPCIe5112.JYPCIe5112AOTask
AddChannel(int[] chnsId, double[] rangeLow, double[] rangeHigh) | JYPCIe5112.JYPCIe5112AOTask
AvaliableLenInSamples | JYPCIe5112.JYPCIe5112AOTask
BufLenInSamples | JYPCIe5112.JYPCIe5112AOTask
Channels | JYPCIe5112.JYPCIe5112AOTask
CompleteState | JYPCIe5112.JYPCIe5112AOTask
Device | JYPCIe5112.JYPCIe5112AOTask
DisableCalibration | JYPCIe5112.JYPCIe5112AOTask
JYPCIe5112AOTask(int slotNum) | JYPCIe5112.JYPCIe5112AOTask
JYPCIe5112AOTask(string boardName) | JYPCIe5112.JYPCIe5112AOTask
Mode | JYPCIe5112.JYPCIe5112AOTask
RemoveChannel(int chnId) | JYPCIe5112.JYPCIe5112AOTask
SampleClock | JYPCIe5112.JYPCIe5112AOTask
SamplesToUpdate | JYPCIe5112.JYPCIe5112AOTask
SendSoftwareTrigger() | JYPCIe5112.JYPCIe5112AOTask
SignalExport | JYPCIe5112.JYPCIe5112AOTask
Start() | JYPCIe5112.JYPCIe5112AOTask
Stop() | JYPCIe5112.JYPCIe5112AOTask
TransferedSamples | JYPCIe5112.JYPCIe5112AOTask
Trigger | JYPCIe5112.JYPCIe5112AOTask
UpdateRate | JYPCIe5112.JYPCIe5112AOTask
WaitUntilDone(int timeout=-1) | JYPCIe5112.JYPCIe5112AOTask
WriteData(IntPtr buf, int samplesPerChannel, int timeout=10000) | JYPCIe5112.JYPCIe5112AOTask
WriteData(double[,] buf, int timeout=10000) | JYPCIe5112.JYPCIe5112AOTask
WriteData(double[] buf, int timeout=10000) | JYPCIe5112.JYPCIe5112AOTask
WriteRawData(IntPtr buf, int samplesPerChannel, int timeout=10000) | JYPCIe5112.JYPCIe5112AOTask
WriteRawData(short[,] buf, int timeout=10000) | JYPCIe5112.JYPCIe5112AOTask
WriteRawData(short[] buf, int timeout=10000) | JYPCIe5112.JYPCIe5112AOTask
WriteRawSinglePoint(short[] writeValues) | JYPCIe5112.JYPCIe5112AOTask
WriteRawSinglePoint(short writeValue, int channel) | JYPCIe5112.JYPCIe5112AOTask
WriteSinglePoint(double[] writeValues) | JYPCIe5112.JYPCIe5112AOTask
WriteSinglePoint(double writeValue, int channel) | JYPCIe5112.JYPCIe5112AOTask


5112 C# Programming Manual: Member List

  • JYPCIe5112CITask
JYPCIe5112.JYPCIe5112CITask Member List

This is the complete list of members for JYPCIe5112.JYPCIe5112CITask, including all inherited members.

Device | JYPCIe5112.JYPCIe5112CITask
EdgeCounting | JYPCIe5112.JYPCIe5112CITask
FrequencyMeas | JYPCIe5112.JYPCIe5112CITask
JYPCIe5112CITask(int slotNum, int channel) | JYPCIe5112.JYPCIe5112CITask
JYPCIe5112CITask(string boardName, int channel) | JYPCIe5112.JYPCIe5112CITask
PeriodMeas | JYPCIe5112.JYPCIe5112CITask
PulseMeas | JYPCIe5112.JYPCIe5112CITask
QuadEncoder | JYPCIe5112.JYPCIe5112CITask
ReadSinglePoint(ref uint count) | JYPCIe5112.JYPCIe5112CITask
ReadSinglePoint(ref double measurement, int timeout=10000) | JYPCIe5112.JYPCIe5112CITask
ReadSinglePoint(ref double measurement1, ref double measurement2, int timeout=10000) | JYPCIe5112.JYPCIe5112CITask
SemiPeriodMeas | JYPCIe5112.JYPCIe5112CITask
SendSoftwareTrigger() | JYPCIe5112.JYPCIe5112CITask
SignalExport | JYPCIe5112.JYPCIe5112CITask
Start() | JYPCIe5112.JYPCIe5112CITask
Stop() | JYPCIe5112.JYPCIe5112CITask
TwoEdgeSeparation | JYPCIe5112.JYPCIe5112CITask
TwoPulseEncoder | JYPCIe5112.JYPCIe5112CITask
Type | JYPCIe5112.JYPCIe5112CITask


5112 C# Programming Manual: Member List

  • JYPCIe5112COTask
JYPCIe5112.JYPCIe5112COTask Member List

This is the complete list of members for JYPCIe5112.JYPCIe5112COTask, including all inherited members.

Device | JYPCIe5112.JYPCIe5112COTask
IdleState | JYPCIe5112.JYPCIe5112COTask
InitialDelay | JYPCIe5112.JYPCIe5112COTask
JYPCIe5112COTask(int slotNum, int channel) | JYPCIe5112.JYPCIe5112COTask
JYPCIe5112COTask(string boardName, int channel) | JYPCIe5112.JYPCIe5112COTask
OutputTerminal | JYPCIe5112.JYPCIe5112COTask
Pause | JYPCIe5112.JYPCIe5112COTask
SendSoftwareTrigger() | JYPCIe5112.JYPCIe5112COTask
SignalExport | JYPCIe5112.JYPCIe5112COTask
Start() | JYPCIe5112.JYPCIe5112COTask
Stop() | JYPCIe5112.JYPCIe5112COTask
Timebase | JYPCIe5112.JYPCIe5112COTask
WaitUntilDone(int timeout=-1) | JYPCIe5112.JYPCIe5112COTask
WriteSinglePoint(COPulse pulse) | JYPCIe5112.JYPCIe5112COTask


5112 C# Programming Manual: Member List

  • JYPCIe5112DITask
JYPCIe5112.JYPCIe5112DITask Member List

This is the complete list of members for JYPCIe5112.JYPCIe5112DITask, including all inherited members.

AddChannel(int portNum) | JYPCIe5112.JYPCIe5112DITask
AddChannel(int[] portsNum) | JYPCIe5112.JYPCIe5112DITask
Channels | JYPCIe5112.JYPCIe5112DITask
Device | JYPCIe5112.JYPCIe5112DITask
JYPCIe5112DITask(int slotNum) | JYPCIe5112.JYPCIe5112DITask
JYPCIe5112DITask(string boardName) | JYPCIe5112.JYPCIe5112DITask
ReadSinglePoint(ref bool[] readValues, int port) | JYPCIe5112.JYPCIe5112DITask
ReadSinglePoint(ref bool[] readValues) | JYPCIe5112.JYPCIe5112DITask
RemoveChannel(int portNum) | JYPCIe5112.JYPCIe5112DITask
Start() | JYPCIe5112.JYPCIe5112DITask
Stop() | JYPCIe5112.JYPCIe5112DITask


5112 C# Programming Manual: Member List

  • JYPCIe5112DOTask
JYPCIe5112.JYPCIe5112DOTask Member List

This is the complete list of members for JYPCIe5112.JYPCIe5112DOTask, including all inherited members.

AddChannel(int portNum) | JYPCIe5112.JYPCIe5112DOTask
AddChannel(int[] portsNum) | JYPCIe5112.JYPCIe5112DOTask
Channels | JYPCIe5112.JYPCIe5112DOTask
Device | JYPCIe5112.JYPCIe5112DOTask
JYPCIe5112DOTask(int slotNum) | JYPCIe5112.JYPCIe5112DOTask
JYPCIe5112DOTask(string boardName) | JYPCIe5112.JYPCIe5112DOTask
RemoveChannel(int portNum) | JYPCIe5112.JYPCIe5112DOTask
Start() | JYPCIe5112.JYPCIe5112DOTask
Stop() | JYPCIe5112.JYPCIe5112DOTask
WriteSinglePoint(bool[] writeValues, int port) | JYPCIe5112.JYPCIe5112DOTask
WriteSinglePoint(bool[] writeValues) | JYPCIe5112.JYPCIe5112DOTask


5112 C# Programming Manual: Member List

  • PauseTrigger
JYPCIe5112.PauseTrigger Member List

This is the complete list of members for JYPCIe5112.PauseTrigger, including all inherited members.

ActivePolarity | JYPCIe5112.PauseTrigger
OutputState | JYPCIe5112.PauseTrigger
Terminal | JYPCIe5112.PauseTrigger


5112 C# Programming Manual: Member List

  • PeriodMeas
JYPCIe5112.PeriodMeas Member List

This is the complete list of members for JYPCIe5112.PeriodMeas, including all inherited members.

InputTerminal | JYPCIe5112.PeriodMeas
Timebase | JYPCIe5112.PeriodMeas


5112 C# Programming Manual: Member List

  • PulseMeas
JYPCIe5112.PulseMeas Member List

This is the complete list of members for JYPCIe5112.PulseMeas, including all inherited members.

InputTerminal | JYPCIe5112.PulseMeas
StartingEdge | JYPCIe5112.PulseMeas
Timebase | JYPCIe5112.PulseMeas


5112 C# Programming Manual: Member List

  • QuadEncoder
JYPCIe5112.QuadEncoder Member List

This is the complete list of members for JYPCIe5112.QuadEncoder, including all inherited members.

AInputTerminal | JYPCIe5112.QuadEncoder
BInputTerminal | JYPCIe5112.QuadEncoder
EncodingType | JYPCIe5112.QuadEncoder
InitialCount | JYPCIe5112.QuadEncoder
ZInputTerminal | JYPCIe5112.QuadEncoder
ZReloadEnabled | JYPCIe5112.QuadEncoder


5112 C# Programming Manual: Member List

  • SemiPeriodMeas
JYPCIe5112.SemiPeriodMeas Member List

This is the complete list of members for JYPCIe5112.SemiPeriodMeas, including all inherited members.

InputTerminal | JYPCIe5112.SemiPeriodMeas
StartingEdge | JYPCIe5112.SemiPeriodMeas
Timebase | JYPCIe5112.SemiPeriodMeas


5112 C# Programming Manual: Member List

  • TwoEdgeSeparation
JYPCIe5112.TwoEdgeSeparation Member List

This is the complete list of members for JYPCIe5112.TwoEdgeSeparation, including all inherited members.

EdgeSeparationMode | JYPCIe5112.TwoEdgeSeparation
FirstInputTerminal | JYPCIe5112.TwoEdgeSeparation
SecondInputTerminal | JYPCIe5112.TwoEdgeSeparation
Timebase | JYPCIe5112.TwoEdgeSeparation


5112 C# Programming Manual: Member List

  • TwoPulseEncoder
JYPCIe5112.TwoPulseEncoder Member List

This is the complete list of members for JYPCIe5112.TwoPulseEncoder, including all inherited members.

AInputTerminal | JYPCIe5112.TwoPulseEncoder
BInputTerminal | JYPCIe5112.TwoPulseEncoder
InitialCount | JYPCIe5112.TwoPulseEncoder


5112 C# Programming Manual: Class Index

Class Index
A | C | D | E | F | J | P | Q | S | T
A
AIAdvanced (JYPCIe5112)
AIAnalogEdgeComparator (JYPCIe5112)
AIAnalogHysteresisComparator (JYPCIe5112)
AIAnalogTrigger (JYPCIe5112)
AIAnalogWindowComparator (JYPCIe5112)
AIChannel (JYPCIe5112)
AIDigitalTrigger (JYPCIe5112)
AIExternalSampleClock (JYPCIe5112)
AIRecord (JYPCIe5112)
AISampleClock (JYPCIe5112)
AISignalExport (JYPCIe5112)
AITrigger (JYPCIe5112)
AOChannel (JYPCIe5112)
AODigitalTrigger (JYPCIe5112)
AOExternalSampleClock (JYPCIe5112)
AOSampleClock (JYPCIe5112)
AOSignalExport (JYPCIe5112)
AOTrigger (JYPCIe5112)
C
CIDigitalTrigger (JYPCIe5112)
CIExternalTimebase (JYPCIe5112)
CISignalExport (JYPCIe5112)
CITimebase (JYPCIe5112)
CITrigger (JYPCIe5112)
CODigitalTrigger (JYPCIe5112)
COExternalTimebase (JYPCIe5112)
COPulse (JYPCIe5112)
COSignalExport (JYPCIe5112)
COTimebase (JYPCIe5112)
COTrigger (JYPCIe5112)
D
DIChannel (JYPCIe5112)
DOChannel (JYPCIe5112)
E
EdgeCounting (JYPCIe5112)
EdgeCountingOutEvent (JYPCIe5112)
F
FrequencyMeas (JYPCIe5112)
J
JYPCIe5112AITask (JYPCIe5112)
JYPCIe5112AOTask (JYPCIe5112)
JYPCIe5112CITask (JYPCIe5112)
JYPCIe5112COTask (JYPCIe5112)
JYPCIe5112DITask (JYPCIe5112)
JYPCIe5112DOTask (JYPCIe5112)
P
PauseTrigger (JYPCIe5112)
PeriodMeas (JYPCIe5112)
PulseMeas (JYPCIe5112)
Q
QuadEncoder (JYPCIe5112)
S
SemiPeriodMeas (JYPCIe5112)
T
TwoEdgeSeparation (JYPCIe5112)
TwoPulseEncoder (JYPCIe5112)


5112 C# Programming Manual: D:/5112 Directory Reference

  • File List
  • 5112
5112 Directory Reference

Directories

C#


5112 C# Programming Manual: File List

  • File List
File List
Here is a list of all files with brief descriptions:
[detail level 123]
▼ 5112
▼ C#
JYPCIe5112AITask.cs
JYPCIe5112AOTask.cs
JYPCIe5112CITask.cs
JYPCIe5112COTask.cs
JYPCIe5112DITask.cs
JYPCIe5112DOTask.cs


5112 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- a -

  • ActiveEdge : JYPCIe5112.EdgeCounting
  • ActivePolarity : JYPCIe5112.PauseTrigger
  • Add() : JYPCIe5112.AISignalExport, JYPCIe5112.AOSignalExport, JYPCIe5112.CISignalExport, JYPCIe5112.COSignalExport
  • AddChannel() : JYPCIe5112.JYPCIe5112AITask, JYPCIe5112.JYPCIe5112AOTask, JYPCIe5112.JYPCIe5112DITask, JYPCIe5112.JYPCIe5112DOTask
  • Advanced : JYPCIe5112.JYPCIe5112AITask
  • AIChannel() : JYPCIe5112.AIChannel
  • AInputTerminal : JYPCIe5112.QuadEncoder, JYPCIe5112.TwoPulseEncoder
  • Analog : JYPCIe5112.AITrigger
  • AvailableSamples : JYPCIe5112.JYPCIe5112AITask
  • AvaliableLenInSamples : JYPCIe5112.JYPCIe5112AOTask


5112 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- b -

  • BInputTerminal : JYPCIe5112.QuadEncoder, JYPCIe5112.TwoPulseEncoder
  • BufLenInSamples : JYPCIe5112.JYPCIe5112AITask, JYPCIe5112.JYPCIe5112AOTask


5112 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- c -

  • ChannelID : JYPCIe5112.AIChannel, JYPCIe5112.AOChannel
  • Channels : JYPCIe5112.JYPCIe5112AITask, JYPCIe5112.JYPCIe5112AOTask, JYPCIe5112.JYPCIe5112DITask, JYPCIe5112.JYPCIe5112DOTask
  • Clear() : JYPCIe5112.AISignalExport, JYPCIe5112.AOSignalExport, JYPCIe5112.CISignalExport, JYPCIe5112.COSignalExport
  • ClearAll() : JYPCIe5112.AISignalExport, JYPCIe5112.AOSignalExport, JYPCIe5112.CISignalExport, JYPCIe5112.COSignalExport
  • Comparator : JYPCIe5112.AIAnalogTrigger
  • CompleteState : JYPCIe5112.JYPCIe5112AOTask
  • Condition : JYPCIe5112.AIAnalogWindowComparator
  • ConvertRate : JYPCIe5112.AIAdvanced
  • COPulse() : JYPCIe5112.COPulse


5112 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- d -

  • Device : JYPCIe5112.JYPCIe5112AITask, JYPCIe5112.JYPCIe5112AOTask, JYPCIe5112.JYPCIe5112CITask, JYPCIe5112.JYPCIe5112COTask, JYPCIe5112.JYPCIe5112DITask, JYPCIe5112.JYPCIe5112DOTask
  • Digital : JYPCIe5112.AITrigger, JYPCIe5112.AOTrigger, JYPCIe5112.CITrigger, JYPCIe5112.COTrigger
  • Direction : JYPCIe5112.EdgeCounting
  • DirTerminal : JYPCIe5112.EdgeCounting
  • DisableCalibration : JYPCIe5112.JYPCIe5112AITask, JYPCIe5112.JYPCIe5112AOTask


5112 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- e -

  • Edge : JYPCIe5112.AIAnalogTrigger, JYPCIe5112.AIDigitalTrigger, JYPCIe5112.AODigitalTrigger, JYPCIe5112.CIDigitalTrigger, JYPCIe5112.CODigitalTrigger
  • EdgeCounting : JYPCIe5112.JYPCIe5112CITask
  • EdgeSeparationMode : JYPCIe5112.TwoEdgeSeparation
  • EncodingType : JYPCIe5112.QuadEncoder
  • ExpectedRate : JYPCIe5112.AIExternalSampleClock, JYPCIe5112.AOExternalSampleClock
  • External : JYPCIe5112.AISampleClock, JYPCIe5112.AOSampleClock, JYPCIe5112.CITimebase, JYPCIe5112.COTimebase


5112 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- f -

  • FileFormat : JYPCIe5112.AIRecord
  • FilePath : JYPCIe5112.AIRecord
  • FirstInputTerminal : JYPCIe5112.TwoEdgeSeparation
  • Frequency : JYPCIe5112.CIExternalTimebase, JYPCIe5112.COExternalTimebase
  • FrequencyMeas : JYPCIe5112.JYPCIe5112CITask


5112 C# Programming Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • Properties
  • a
  • c
  • g
  • j
  • r
  • s
  • w
Here is a list of all functions with links to the classes they belong to:

- a -

  • Add() : JYPCIe5112.AISignalExport, JYPCIe5112.AOSignalExport, JYPCIe5112.CISignalExport, JYPCIe5112.COSignalExport
  • AddChannel() : JYPCIe5112.JYPCIe5112AITask, JYPCIe5112.JYPCIe5112AOTask, JYPCIe5112.JYPCIe5112DITask, JYPCIe5112.JYPCIe5112DOTask
  • AIChannel() : JYPCIe5112.AIChannel

- c -

  • Clear() : JYPCIe5112.AISignalExport, JYPCIe5112.AOSignalExport, JYPCIe5112.CISignalExport, JYPCIe5112.COSignalExport
  • ClearAll() : JYPCIe5112.AISignalExport, JYPCIe5112.AOSignalExport, JYPCIe5112.CISignalExport, JYPCIe5112.COSignalExport
  • COPulse() : JYPCIe5112.COPulse

- g -

  • GetRecordPreviewData() : JYPCIe5112.JYPCIe5112AITask
  • GetRecordStatus() : JYPCIe5112.JYPCIe5112AITask

- j -

  • JYPCIe5112AITask() : JYPCIe5112.JYPCIe5112AITask
  • JYPCIe5112AOTask() : JYPCIe5112.JYPCIe5112AOTask
  • JYPCIe5112CITask() : JYPCIe5112.JYPCIe5112CITask
  • JYPCIe5112COTask() : JYPCIe5112.JYPCIe5112COTask
  • JYPCIe5112DITask() : JYPCIe5112.JYPCIe5112DITask
  • JYPCIe5112DOTask() : JYPCIe5112.JYPCIe5112DOTask

- r -

  • ReadData() : JYPCIe5112.JYPCIe5112AITask
  • ReadRawData() : JYPCIe5112.JYPCIe5112AITask
  • ReadRawSinglePoint() : JYPCIe5112.JYPCIe5112AITask
  • ReadSinglePoint() : JYPCIe5112.JYPCIe5112AITask, JYPCIe5112.JYPCIe5112CITask, JYPCIe5112.JYPCIe5112DITask
  • RemoveChannel() : JYPCIe5112.JYPCIe5112AITask, JYPCIe5112.JYPCIe5112AOTask, JYPCIe5112.JYPCIe5112DITask, JYPCIe5112.JYPCIe5112DOTask

- s -

  • SendSoftwareTrigger() : JYPCIe5112.JYPCIe5112AITask, JYPCIe5112.JYPCIe5112AOTask, JYPCIe5112.JYPCIe5112CITask, JYPCIe5112.JYPCIe5112COTask
  • Start() : JYPCIe5112.JYPCIe5112AITask, JYPCIe5112.JYPCIe5112AOTask, JYPCIe5112.JYPCIe5112CITask, JYPCIe5112.JYPCIe5112COTask, JYPCIe5112.JYPCIe5112DITask, JYPCIe5112.JYPCIe5112DOTask
  • Stop() : JYPCIe5112.JYPCIe5112AITask, JYPCIe5112.JYPCIe5112AOTask, JYPCIe5112.JYPCIe5112CITask, JYPCIe5112.JYPCIe5112COTask, JYPCIe5112.JYPCIe5112DITask, JYPCIe5112.JYPCIe5112DOTask

- w -

  • WaitUntilDone() : JYPCIe5112.JYPCIe5112AITask, JYPCIe5112.JYPCIe5112AOTask, JYPCIe5112.JYPCIe5112COTask
  • WriteData() : JYPCIe5112.JYPCIe5112AOTask
  • WriteRawData() : JYPCIe5112.JYPCIe5112AOTask
  • WriteRawSinglePoint() : JYPCIe5112.JYPCIe5112AOTask
  • WriteSinglePoint() : JYPCIe5112.JYPCIe5112AOTask, JYPCIe5112.JYPCIe5112COTask, JYPCIe5112.JYPCIe5112DOTask


5112 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- g -

  • GetRecordPreviewData() : JYPCIe5112.JYPCIe5112AITask
  • GetRecordStatus() : JYPCIe5112.JYPCIe5112AITask


5112 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- h -

  • HighThreshold : JYPCIe5112.AIAnalogHysteresisComparator, JYPCIe5112.AIAnalogWindowComparator
  • Hysteresis : JYPCIe5112.AIAnalogTrigger


5112 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- i -

  • IdleState : JYPCIe5112.EdgeCountingOutEvent, JYPCIe5112.JYPCIe5112COTask
  • InitialCount : JYPCIe5112.EdgeCounting, JYPCIe5112.QuadEncoder, JYPCIe5112.TwoPulseEncoder
  • InitialDelay : JYPCIe5112.JYPCIe5112COTask
  • InputTerminal : JYPCIe5112.EdgeCounting, JYPCIe5112.FrequencyMeas, JYPCIe5112.PeriodMeas, JYPCIe5112.PulseMeas, JYPCIe5112.SemiPeriodMeas


5112 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- j -

  • JYPCIe5112AITask() : JYPCIe5112.JYPCIe5112AITask
  • JYPCIe5112AOTask() : JYPCIe5112.JYPCIe5112AOTask
  • JYPCIe5112CITask() : JYPCIe5112.JYPCIe5112CITask
  • JYPCIe5112COTask() : JYPCIe5112.JYPCIe5112COTask
  • JYPCIe5112DITask() : JYPCIe5112.JYPCIe5112DITask
  • JYPCIe5112DOTask() : JYPCIe5112.JYPCIe5112DOTask


5112 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- l -

  • Length : JYPCIe5112.AIRecord
  • LowThreshold : JYPCIe5112.AIAnalogHysteresisComparator, JYPCIe5112.AIAnalogWindowComparator


5112 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- m -

  • Mode : JYPCIe5112.AIRecord, JYPCIe5112.AITrigger, JYPCIe5112.JYPCIe5112AITask, JYPCIe5112.JYPCIe5112AOTask


5112 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- o -

  • OutEvent : JYPCIe5112.EdgeCounting
  • OutputState : JYPCIe5112.PauseTrigger
  • OutputTerminal : JYPCIe5112.JYPCIe5112COTask


5112 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- p -

  • Pause : JYPCIe5112.EdgeCounting, JYPCIe5112.JYPCIe5112COTask
  • PeriodMeas : JYPCIe5112.JYPCIe5112CITask
  • PortNum : JYPCIe5112.DIChannel, JYPCIe5112.DOChannel
  • PreTriggerSamples : JYPCIe5112.AITrigger
  • PulseMeas : JYPCIe5112.JYPCIe5112CITask


5112 C# Programming Manual: Class Members - Properties

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all properties with links to the classes they belong to:

- a -

  • ActiveEdge : JYPCIe5112.EdgeCounting
  • ActivePolarity : JYPCIe5112.PauseTrigger
  • Advanced : JYPCIe5112.JYPCIe5112AITask
  • AInputTerminal : JYPCIe5112.QuadEncoder, JYPCIe5112.TwoPulseEncoder
  • Analog : JYPCIe5112.AITrigger
  • AvailableSamples : JYPCIe5112.JYPCIe5112AITask
  • AvaliableLenInSamples : JYPCIe5112.JYPCIe5112AOTask

- b -

  • BInputTerminal : JYPCIe5112.QuadEncoder, JYPCIe5112.TwoPulseEncoder
  • BufLenInSamples : JYPCIe5112.JYPCIe5112AITask, JYPCIe5112.JYPCIe5112AOTask

- c -

  • ChannelID : JYPCIe5112.AIChannel, JYPCIe5112.AOChannel
  • Channels : JYPCIe5112.JYPCIe5112AITask, JYPCIe5112.JYPCIe5112AOTask, JYPCIe5112.JYPCIe5112DITask, JYPCIe5112.JYPCIe5112DOTask
  • Comparator : JYPCIe5112.AIAnalogTrigger
  • CompleteState : JYPCIe5112.JYPCIe5112AOTask
  • Condition : JYPCIe5112.AIAnalogWindowComparator
  • ConvertRate : JYPCIe5112.AIAdvanced

- d -

  • Device : JYPCIe5112.JYPCIe5112AITask, JYPCIe5112.JYPCIe5112AOTask, JYPCIe5112.JYPCIe5112CITask, JYPCIe5112.JYPCIe5112COTask, JYPCIe5112.JYPCIe5112DITask, JYPCIe5112.JYPCIe5112DOTask
  • Digital : JYPCIe5112.AITrigger, JYPCIe5112.AOTrigger, JYPCIe5112.CITrigger, JYPCIe5112.COTrigger
  • Direction : JYPCIe5112.EdgeCounting
  • DirTerminal : JYPCIe5112.EdgeCounting
  • DisableCalibration : JYPCIe5112.JYPCIe5112AITask, JYPCIe5112.JYPCIe5112AOTask

- e -

  • Edge : JYPCIe5112.AIAnalogTrigger, JYPCIe5112.AIDigitalTrigger, JYPCIe5112.AODigitalTrigger, JYPCIe5112.CIDigitalTrigger, JYPCIe5112.CODigitalTrigger
  • EdgeCounting : JYPCIe5112.JYPCIe5112CITask
  • EdgeSeparationMode : JYPCIe5112.TwoEdgeSeparation
  • EncodingType : JYPCIe5112.QuadEncoder
  • ExpectedRate : JYPCIe5112.AIExternalSampleClock, JYPCIe5112.AOExternalSampleClock
  • External : JYPCIe5112.AISampleClock, JYPCIe5112.AOSampleClock, JYPCIe5112.CITimebase, JYPCIe5112.COTimebase

- f -

  • FileFormat : JYPCIe5112.AIRecord
  • FilePath : JYPCIe5112.AIRecord
  • FirstInputTerminal : JYPCIe5112.TwoEdgeSeparation
  • Frequency : JYPCIe5112.CIExternalTimebase, JYPCIe5112.COExternalTimebase
  • FrequencyMeas : JYPCIe5112.JYPCIe5112CITask

- h -

  • Hysteresis : JYPCIe5112.AIAnalogTrigger

- i -

  • IdleState : JYPCIe5112.EdgeCountingOutEvent, JYPCIe5112.JYPCIe5112COTask
  • InitialCount : JYPCIe5112.EdgeCounting, JYPCIe5112.QuadEncoder, JYPCIe5112.TwoPulseEncoder
  • InitialDelay : JYPCIe5112.JYPCIe5112COTask
  • InputTerminal : JYPCIe5112.EdgeCounting, JYPCIe5112.FrequencyMeas, JYPCIe5112.PeriodMeas, JYPCIe5112.PulseMeas, JYPCIe5112.SemiPeriodMeas

- l -

  • Length : JYPCIe5112.AIRecord

- m -

  • Mode : JYPCIe5112.AIRecord, JYPCIe5112.AITrigger, JYPCIe5112.JYPCIe5112AITask, JYPCIe5112.JYPCIe5112AOTask

- o -

  • OutEvent : JYPCIe5112.EdgeCounting
  • OutputState : JYPCIe5112.PauseTrigger
  • OutputTerminal : JYPCIe5112.JYPCIe5112COTask

- p -

  • Pause : JYPCIe5112.EdgeCounting, JYPCIe5112.JYPCIe5112COTask
  • PeriodMeas : JYPCIe5112.JYPCIe5112CITask
  • PortNum : JYPCIe5112.DIChannel, JYPCIe5112.DOChannel
  • PreTriggerSamples : JYPCIe5112.AITrigger
  • PulseMeas : JYPCIe5112.JYPCIe5112CITask

- q -

  • QuadEncoder : JYPCIe5112.JYPCIe5112CITask

- r -

  • RangeHigh : JYPCIe5112.AIChannel, JYPCIe5112.AOChannel
  • RangeLow : JYPCIe5112.AIChannel, JYPCIe5112.AOChannel
  • Record : JYPCIe5112.JYPCIe5112AITask
  • ReTriggerCount : JYPCIe5112.AITrigger

- s -

  • SampleClock : JYPCIe5112.JYPCIe5112AITask, JYPCIe5112.JYPCIe5112AOTask
  • SampleRate : JYPCIe5112.JYPCIe5112AITask
  • SamplesToAcquire : JYPCIe5112.JYPCIe5112AITask
  • SamplesToUpdate : JYPCIe5112.JYPCIe5112AOTask
  • SecondInputTerminal : JYPCIe5112.TwoEdgeSeparation
  • SemiPeriodMeas : JYPCIe5112.JYPCIe5112CITask
  • SignalExport : JYPCIe5112.JYPCIe5112AITask, JYPCIe5112.JYPCIe5112AOTask, JYPCIe5112.JYPCIe5112CITask, JYPCIe5112.JYPCIe5112COTask
  • Slope : JYPCIe5112.AIAnalogEdgeComparator, JYPCIe5112.AIAnalogHysteresisComparator
  • Source : JYPCIe5112.AIAnalogTrigger, JYPCIe5112.AIDigitalTrigger, JYPCIe5112.AISampleClock, JYPCIe5112.AODigitalTrigger, JYPCIe5112.AOSampleClock, JYPCIe5112.CIDigitalTrigger, JYPCIe5112.CITimebase, JYPCIe5112.CODigitalTrigger, JYPCIe5112.COTimebase
  • StartingEdge : JYPCIe5112.PulseMeas, JYPCIe5112.SemiPeriodMeas

- t -

  • Terminal : JYPCIe5112.AIChannel, JYPCIe5112.AIExternalSampleClock, JYPCIe5112.AOExternalSampleClock, JYPCIe5112.CIExternalTimebase, JYPCIe5112.COExternalTimebase, JYPCIe5112.EdgeCountingOutEvent, JYPCIe5112.PauseTrigger
  • Threshold : JYPCIe5112.EdgeCountingOutEvent
  • Timebase : JYPCIe5112.FrequencyMeas, JYPCIe5112.JYPCIe5112COTask, JYPCIe5112.PeriodMeas, JYPCIe5112.PulseMeas, JYPCIe5112.SemiPeriodMeas, JYPCIe5112.TwoEdgeSeparation
  • TransferedSamples : JYPCIe5112.JYPCIe5112AITask, JYPCIe5112.JYPCIe5112AOTask
  • Trigger : JYPCIe5112.JYPCIe5112AITask, JYPCIe5112.JYPCIe5112AOTask
  • TwoEdgeSeparation : JYPCIe5112.JYPCIe5112CITask
  • TwoPulseEncoder : JYPCIe5112.JYPCIe5112CITask
  • Type : JYPCIe5112.AITrigger, JYPCIe5112.AOTrigger, JYPCIe5112.CITrigger, JYPCIe5112.COTrigger, JYPCIe5112.JYPCIe5112CITask

- u -

  • UpdateRate : JYPCIe5112.JYPCIe5112AOTask

- w -

  • Window : JYPCIe5112.AIAnalogTrigger

- z -

  • ZInputTerminal : JYPCIe5112.QuadEncoder
  • ZReloadEnabled : JYPCIe5112.QuadEncoder


5112 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- q -

  • QuadEncoder : JYPCIe5112.JYPCIe5112CITask


5112 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- r -

  • RangeHigh : JYPCIe5112.AIChannel, JYPCIe5112.AOChannel
  • RangeLow : JYPCIe5112.AIChannel, JYPCIe5112.AOChannel
  • ReadData() : JYPCIe5112.JYPCIe5112AITask
  • ReadRawData() : JYPCIe5112.JYPCIe5112AITask
  • ReadRawSinglePoint() : JYPCIe5112.JYPCIe5112AITask
  • ReadSinglePoint() : JYPCIe5112.JYPCIe5112AITask, JYPCIe5112.JYPCIe5112CITask, JYPCIe5112.JYPCIe5112DITask
  • Record : JYPCIe5112.JYPCIe5112AITask
  • RemoveChannel() : JYPCIe5112.JYPCIe5112AITask, JYPCIe5112.JYPCIe5112AOTask, JYPCIe5112.JYPCIe5112DITask, JYPCIe5112.JYPCIe5112DOTask
  • ReTriggerCount : JYPCIe5112.AITrigger


5112 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- s -

  • SampleClock : JYPCIe5112.JYPCIe5112AITask, JYPCIe5112.JYPCIe5112AOTask
  • SampleRate : JYPCIe5112.JYPCIe5112AITask
  • SamplesToAcquire : JYPCIe5112.JYPCIe5112AITask
  • SamplesToUpdate : JYPCIe5112.JYPCIe5112AOTask
  • SecondInputTerminal : JYPCIe5112.TwoEdgeSeparation
  • SemiPeriodMeas : JYPCIe5112.JYPCIe5112CITask
  • SendSoftwareTrigger() : JYPCIe5112.JYPCIe5112AITask, JYPCIe5112.JYPCIe5112AOTask, JYPCIe5112.JYPCIe5112CITask, JYPCIe5112.JYPCIe5112COTask
  • SignalExport : JYPCIe5112.JYPCIe5112AITask, JYPCIe5112.JYPCIe5112AOTask, JYPCIe5112.JYPCIe5112CITask, JYPCIe5112.JYPCIe5112COTask
  • Slope : JYPCIe5112.AIAnalogEdgeComparator, JYPCIe5112.AIAnalogHysteresisComparator
  • Source : JYPCIe5112.AIAnalogTrigger, JYPCIe5112.AIDigitalTrigger, JYPCIe5112.AISampleClock, JYPCIe5112.AODigitalTrigger, JYPCIe5112.AOSampleClock, JYPCIe5112.CIDigitalTrigger, JYPCIe5112.CITimebase, JYPCIe5112.CODigitalTrigger, JYPCIe5112.COTimebase
  • Start() : JYPCIe5112.JYPCIe5112AITask, JYPCIe5112.JYPCIe5112AOTask, JYPCIe5112.JYPCIe5112CITask, JYPCIe5112.JYPCIe5112COTask, JYPCIe5112.JYPCIe5112DITask, JYPCIe5112.JYPCIe5112DOTask
  • StartingEdge : JYPCIe5112.PulseMeas, JYPCIe5112.SemiPeriodMeas
  • Stop() : JYPCIe5112.JYPCIe5112AITask, JYPCIe5112.JYPCIe5112AOTask, JYPCIe5112.JYPCIe5112CITask, JYPCIe5112.JYPCIe5112COTask, JYPCIe5112.JYPCIe5112DITask, JYPCIe5112.JYPCIe5112DOTask


5112 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- t -

  • Terminal : JYPCIe5112.AIChannel, JYPCIe5112.AIExternalSampleClock, JYPCIe5112.AOExternalSampleClock, JYPCIe5112.CIExternalTimebase, JYPCIe5112.COExternalTimebase, JYPCIe5112.EdgeCountingOutEvent, JYPCIe5112.PauseTrigger
  • Threshold : JYPCIe5112.AIAnalogEdgeComparator, JYPCIe5112.EdgeCountingOutEvent
  • Timebase : JYPCIe5112.FrequencyMeas, JYPCIe5112.JYPCIe5112COTask, JYPCIe5112.PeriodMeas, JYPCIe5112.PulseMeas, JYPCIe5112.SemiPeriodMeas, JYPCIe5112.TwoEdgeSeparation
  • TransferedSamples : JYPCIe5112.JYPCIe5112AITask, JYPCIe5112.JYPCIe5112AOTask
  • Trigger : JYPCIe5112.JYPCIe5112AITask, JYPCIe5112.JYPCIe5112AOTask
  • TwoEdgeSeparation : JYPCIe5112.JYPCIe5112CITask
  • TwoPulseEncoder : JYPCIe5112.JYPCIe5112CITask
  • Type : JYPCIe5112.AITrigger, JYPCIe5112.AOTrigger, JYPCIe5112.CITrigger, JYPCIe5112.COTrigger, JYPCIe5112.JYPCIe5112CITask


5112 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- u -

  • UpdateRate : JYPCIe5112.JYPCIe5112AOTask


5112 C# Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Properties
Here is a list of all variables with links to the classes they belong to:
  • HighThreshold : JYPCIe5112.AIAnalogHysteresisComparator, JYPCIe5112.AIAnalogWindowComparator
  • LowThreshold : JYPCIe5112.AIAnalogHysteresisComparator, JYPCIe5112.AIAnalogWindowComparator
  • Threshold : JYPCIe5112.AIAnalogEdgeComparator


5112 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- w -

  • WaitUntilDone() : JYPCIe5112.JYPCIe5112AITask, JYPCIe5112.JYPCIe5112AOTask, JYPCIe5112.JYPCIe5112COTask
  • Window : JYPCIe5112.AIAnalogTrigger
  • WriteData() : JYPCIe5112.JYPCIe5112AOTask
  • WriteRawData() : JYPCIe5112.JYPCIe5112AOTask
  • WriteRawSinglePoint() : JYPCIe5112.JYPCIe5112AOTask
  • WriteSinglePoint() : JYPCIe5112.JYPCIe5112AOTask, JYPCIe5112.JYPCIe5112COTask, JYPCIe5112.JYPCIe5112DOTask


5112 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- z -

  • ZInputTerminal : JYPCIe5112.QuadEncoder
  • ZReloadEnabled : JYPCIe5112.QuadEncoder


5112 C# Programming Manual: Main Page

5112 C# Programming Manual Documentation


5112 C# Programming Manual: JYPCIe5112 Namespace Reference

  • Package List
  • Package Members
Classes | Enumerations
JYPCIe5112 Namespace Reference

Classes

class | AIAdvanced
AI Advance parameter. More...
class | AIAnalogEdgeComparator
AI Analog Edge Comparator. More...
class | AIAnalogHysteresisComparator
AI Analog Hysteresis Comparatorr. More...
class | AIAnalogTrigger
AI analog trigger . More...
class | AIAnalogWindowComparator
AI Analog Window Comparatorr. More...
class | AIChannel
AI Channel parameter class . More...
class | AIDigitalTrigger
AI Digital trigger class. More...
class | AIExternalSampleClock
External Sample Clock Configuration Class. More...
class | AIRecord
AI Record Parameters. More...
class | AISampleClock
Sample clock configuration class. More...
class | AISignalExport
AI Signal Export Class. More...
class | AITrigger
Constructor to create an AITrigger task object. More...
class | AOChannel
AO Channel parameter class . More...
class | AODigitalTrigger
AO Digital trigger . More...
class | AOExternalSampleClock
External Sample Clock Configuration Class. More...
class | AOSampleClock
AO Sample clock configuration class. More...
class | AOSignalExport
AO Signal Export Class. More...
class | AOTrigger
Constructor to create an AOTrigger task object. More...
class | CIDigitalTrigger
CI Digital trigger . More...
class | CIExternalTimebase
class | CISignalExport
CI Signal Export Class. More...
class | CITimebase
class | CITrigger
Constructor to create an CITrigger task object. More...
class | CODigitalTrigger
CO Digital trigger . More...
class | COExternalTimebase
class | COPulse
Pulse Parameter. More...
class | COSignalExport
CO Signal Export Class. More...
class | COTimebase
class | COTrigger
Constructor to create an COTrigger task object. More...
class | DIChannel
DI Channel parameter class . More...
class | DOChannel
DO Channel parameter class . More...
class | EdgeCounting
Configure CI EdgeCounting. More...
class | EdgeCountingOutEvent
Edge counting output event configuration class. More...
class | FrequencyMeas
Configure CI Measure. More...
class | JYPCIe5112AITask
JYPCIe5112 Analog Input Task. More...
class | JYPCIe5112AOTask
JYPCIe5112 Analog Ouput Task. More...
class | JYPCIe5112CITask
JYPCIe5112 Counter Input Task. More...
class | JYPCIe5112COTask
JYPCIe5112 Counter Output Task. More...
class | JYPCIe5112DITask
JYPCIe5112 Digital Iuput Task. More...
class | JYPCIe5112DOTask
JYPCIe5112 Digital Output Task. More...
class | PauseTrigger
Pause trigger configuration class. More...
class | PeriodMeas
Configure CI Measure. More...
class | PulseMeas
Configure CI Measure. More...
class | QuadEncoder
Configure CI Measure. More...
class | SemiPeriodMeas
Configure CI Measure. More...
class | TwoEdgeSeparation
Configure CI Measure. More...
class | TwoPulseEncoder
Configure CI Measure. More...

Enumerations

enum | AITriggerType { Immediate = JYPCIe5112Import.JYPCIe5112_TriggerType_Immediately , Digital = JYPCIe5112Import.JYPCIe5112_TriggerType_Digital , Analog = JYPCIe5112Import.JYPCIe5112_TriggerType_Analog , Soft = JYPCIe5112Import.JYPCIe5112_TriggerType_Soft }
Trigger Type Digital/Analog/Immediate/Soft. More...
enum | AIDigitalTriggerEdge { Rising = JYPCIe5112Import.JYPCIe5112_DigitalTriggerEdge_Rising , Falling = JYPCIe5112Import.JYPCIe5112_DigitalTriggerEdge_Falling }
AI Digital Trigger Edge. More...
enum | AIMode { Single = JYPCIe5112Import.JYPCIe5112_AI_Single , Finite = JYPCIe5112Import.JYPCIe5112_AI_Finite , Continuous = JYPCIe5112Import.JYPCIe5112_AI_Continuous , Record = 0x3 }
AIMode. More...
enum | AITerminal { RSE = JYPCIe5112Import.JYPCIe5112_AI_RSE , NRSE = JYPCIe5112Import.JYPCIe5112_AI_NRSE , Differential = JYPCIe5112Import.JYPCIe5112_AI_Diff }
AITerminal. More...
enum | AISampleClockSource { Internal , External }
AI Sample Clock Source. More...
enum ClockTerminal {
PFI0 = 0 , PFI1 = 1 , PFI2 = 2 , PFI3 = 3 ,
PFI4 = 4 , PFI5 = 5 , PFI6 = 6 , PFI7 = 7 ,
PFI8 = 8 , PFI9 = 9 , PFI10 = 10 , PFI11 = 11 ,
PFI12 = 12 , PFI13 = 13 , PFI14 = 14 , PFI15 = 15 ,
PXI_Trig0 = 16 , PXI_Trig1 = 17 , PXI_Trig2 = 18 , PXI_Trig3 = 19 ,
PXI_Trig4 = 20 , PXI_Trig5 = 21 , PXI_Trig6 = 22 , PXI_Trig7 = 23 ,
AI_SampleClock = 24 , AO_SampleClock = 25 , CO0_Output = 26 , CO1_Output = 27 ,
ECLK = 28
}
Clock Terminal. More...
enum | AITriggerMode { Start , Reference }
AI Trigger Mode. More...
enum AIAnalogTriggerSource {
Channel_0 , Channel_1 , Channel_2 , Channel_3 ,
Channel_4 , Channel_5 , Channel_6 , Channel_7 ,
Channel_8 , Channel_9 , Channel_10 , Channel_11 ,
Channel_12 , Channel_13 , Channel_14 , Channel_15
}
AI analog trigger source. More...
enum AIDigitalTriggerSource {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PFI8 , PFI9 , PFI10 , PFI11 ,
PFI12 , PFI13 , PFI14 , PFI15 ,
PXI_Trig0 = 16 , PXI_Trig1 = 17 , PXI_Trig2 = 18 , PXI_Trig3 = 19 ,
PXI_Trig4 = 20 , PXI_Trig5 = 21 , PXI_Trig6 = 22 , PXI_Trig7 = 23 ,
AO_StartTrig = 26 , CI0_StartTrig = 27 , CI1_StartTrig = 28 , CO0_Output = 29 ,
CO1_Output = 30
}
AI Digital trigger source. More...
enum | AIAnalogTriggerEdge { Rising , Falling }
AI Analog Trigger Edge. More...
enum | AIAnalogWindowCondition { Entering , Leaving }
AI Analog Window Trigger Condition. More...
enum | AIAnalogTriggerComparator { Edge , Hysteresis , Window }
AI Analog Trigger Comparator. More...
enum | AISignalExportSource { StartTrig = 0 , ReferenceTrig = 1 , SampleClock = 5 }
AI Signal Export Source. More...
enum | FileFormat { Bin }
Streaming file format. More...
enum | RecordMode { Finite , Infinite }
stream mode .enum Finite/Infinite More...
enum SignalExportDestination {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PFI8 , PFI9 , PFI10 , PFI11 ,
PFI12 , PFI13 , PFI14 , PFI15 ,
PXI_Trig0 , PXI_Trig1 , PXI_Trig2 , PXI_Trig3 ,
PXI_Trig4 , PXI_Trig5 , PXI_Trig6 , PXI_Trig7
}
Output DestinationTerminal. More...
enum | AODigitalTriggerEdge { Rising , Falling }
AO Digital Trigger Edge. More...
enum AODigitalTriggerSource {
PFI0 = 0 , PFI1 = 1 , PFI2 = 2 , PFI3 = 3 ,
PFI4 = 4 , PFI5 = 5 , PFI6 = 6 , PFI7 = 7 ,
PFI8 = 8 , PFI9 = 9 , PFI10 = 10 , PFI11 = 11 ,
PFI12 = 12 , PFI13 = 13 , PFI14 = 14 , PFI15 = 15 ,
PXI_Trig0 = 16 , PXI_Trig1 = 17 , PXI_Trig2 = 18 , PXI_Trig3 = 19 ,
PXI_Trig4 = 20 , PXI_Trig5 = 21 , PXI_Trig6 = 22 , PXI_Trig7 = 23 ,
AI_StartTrig = 24 , AI_ReferenceTrig = 25 , CIO_0_StartTrig = 27 , CIO_1_StartTrig = 28 ,
CO0_Output = 29 , CO1_Output = 30
}
AO Digital trigger source. More...
enum | AOMode { Single = 3 , Finite = 0 , ContinuousNoWrapping = 2 , ContinuousWrapping = 1 }
AOMode. More...
enum | AOSampleClockSource { Internal , External }
AO Sample Clock Source. More...
enum | AOSignalExportSource { StartTrig = 2 , SampleClock = 6 }
SourceSignal. More...
enum | AOTriggerType { Immediate = JYPCIe5112Import.JYPCIe5112_TriggerType_Immediately , Digital = JYPCIe5112Import.JYPCIe5112_TriggerType_Digital , Soft = JYPCIe5112Import.JYPCIe5112_TriggerType_Soft }
TriggerType Digital/Immediate/Soft. More...
enum | OutputCompleteState { Zero , Hold }
Output Complete State. More...
enum | CountDirection { Up = JYPCIe5112Import.JYPCIe5112_CI_Count_Up , Down = JYPCIe5112Import.JYPCIe5112_CI_Count_Down , External = JYPCIe5112Import.JYPCIe5112_CI_Count_External }
Counter direction. More...
enum CIType {
EdgeCounting , Period , Frequency , Pulse ,
SemiPeriod , TwoEdgeSeparation , QuadEncoder , TwoPulseEncoder
}
Counter Input Application Type. More...
enum | EdgeType { Rising , Falling , Any }
Edge Type. More...
enum | CITimebaseSource { Internal100MHz = 0 , Internal5MHz = 1 , Internal100kHz = 2 , External = 3 }
enum | EdgeCntOunEvtIdleState { LowLevel = 0 , HighLevel = 1 }
Output idle state when the event has not occurred. More...
enum | LevelPolarity { LowLevel = 0 , HighLevel = 1 , None = 2 }
Level Polarity. More...
enum | OutputState { HoldOn = 0 , HighLevel = 1 , LowLevel = 2 }
CO output state when pause trigger valid. More...
enum | ValueReturnMode { TwoValue , OneValue }
TwoEdgeSeparation value return mode.only for TwoEdgeSeparation type. More...
enum | QuadEncodingType { X1 , X2 , X4 }
Quadrature Encoding Type. More...
enum | CITriggerType { Immediate = JYPCIe5112Import.JYPCIe5112_CIO_Immediately , Digital = JYPCIe5112Import.JYPCIe5112_CIO_Digital , Soft = JYPCIe5112Import.JYPCIe5112_CIO_Soft }
TriggerType Digital/Immediate/Soft. More...
enum CIDigitalTriggerSource {
PFI0 = 0 , PFI1 = 1 , PFI2 = 2 , PFI3 = 3 ,
PFI4 = 4 , PFI5 = 5 , PFI6 = 6 , PFI7 = 7 ,
PFI8 = 8 , PFI9 = 9 , PFI10 = 10 , PFI11 = 11 ,
PFI12 = 12 , PFI13 = 13 , PFI14 = 14 , PFI15 = 15 ,
PXI_Trig0 = 16 , PXI_Trig1 = 17 , PXI_Trig2 = 18 , PXI_Trig3 = 19 ,
PXI_Trig4 = 20 , PXI_Trig5 = 21 , PXI_Trig6 = 22 , PXI_Trig7 = 23 ,
AI_StartTrig = 24 , AI_ReferenceTrig = 25 , AO_StartTrig = 26 , CIO_0_StartTrig = 27 ,
CIO_1_StartTrig = 28 , CO0_Output = 29 , CO1_Output = 30
}
CI Digital trigger source. More...
enum | CIDigitalTriggerEdge { Rising , Falling }
CI Digital Trigger Edge. More...
enum InputTerminal {
PFI0 = JYPCIe5112Import.JYPCIe5112_PFI0_Input , PFI1 = JYPCIe5112Import.JYPCIe5112_PFI1_Input , PFI2 = JYPCIe5112Import.JYPCIe5112_PFI2_Input , PFI3 = JYPCIe5112Import.JYPCIe5112_PFI3_Input ,
PFI4 = JYPCIe5112Import.JYPCIe5112_PFI4_Input , PFI5 = JYPCIe5112Import.JYPCIe5112_PFI5_Input , PFI6 = JYPCIe5112Import.JYPCIe5112_PFI6_Input , PFI7 = JYPCIe5112Import.JYPCIe5112_PFI7_Input ,
PFI8 = JYPCIe5112Import.JYPCIe5112_PFI8_Input , PFI9 = JYPCIe5112Import.JYPCIe5112_PFI9_Input , PFI10 = JYPCIe5112Import.JYPCIe5112_PFI10_Input , PFI11 = JYPCIe5112Import.JYPCIe5112_PFI11_Input ,
PFI12 = JYPCIe5112Import.JYPCIe5112_PFI12_Input , PFI13 = JYPCIe5112Import.JYPCIe5112_PFI13_Input , PFI14 = JYPCIe5112Import.JYPCIe5112_PFI14_Input , PFI15 = JYPCIe5112Import.JYPCIe5112_PFI15_Input ,
PXI_Trig0 = JYPCIe5112Import.JYPCIe5112_PXI_Trig0_Input , PXI_Trig1 = JYPCIe5112Import.JYPCIe5112_PXI_Trig1_Input , PXI_Trig2 = JYPCIe5112Import.JYPCIe5112_PXI_Trig2_Input , PXI_Trig3 = JYPCIe5112Import.JYPCIe5112_PXI_Trig3_Input ,
PXI_Trig4 = JYPCIe5112Import.JYPCIe5112_PXI_Trig4_Input , PXI_Trig5 = JYPCIe5112Import.JYPCIe5112_PXI_Trig5_Input , PXI_Trig6 = JYPCIe5112Import.JYPCIe5112_PXI_Trig6_Input , PXI_Trig7 = JYPCIe5112Import.JYPCIe5112_PXI_Trig7_Input ,
CO_0_OutPut = 24 , CO_1_OutPut = 25 , Timebase_100MHz = 26 , Timebase_5MHz = 27 ,
Timebase_100kHz = 28
}
输入终端 More...
enum IOTerminal {
PFI0 = JYPCIe5112Import.JYPCIe5112_DigitalTriggerOut_PFI_0 , PFI1 = JYPCIe5112Import.JYPCIe5112_DigitalTriggerOut_PFI_1 , PFI2 = JYPCIe5112Import.JYPCIe5112_DigitalTriggerOut_PFI_2 , PFI3 = JYPCIe5112Import.JYPCIe5112_DigitalTriggerOut_PFI_3 ,
PFI4 = JYPCIe5112Import.JYPCIe5112_DigitalTriggerOut_PFI_4 , PFI5 = JYPCIe5112Import.JYPCIe5112_DigitalTriggerOut_PFI_5 , PFI6 = JYPCIe5112Import.JYPCIe5112_DigitalTriggerOut_PFI_6 , PFI7 = JYPCIe5112Import.JYPCIe5112_DigitalTriggerOut_PFI_7 ,
PFI8 = JYPCIe5112Import.JYPCIe5112_DigitalTriggerOut_PFI_8 , PFI9 = JYPCIe5112Import.JYPCIe5112_DigitalTriggerOut_PFI_9 , PFI10 = JYPCIe5112Import.JYPCIe5112_DigitalTriggerOut_PFI_10 , PFI11 = JYPCIe5112Import.JYPCIe5112_DigitalTriggerOut_PFI_11 ,
PFI12 = JYPCIe5112Import.JYPCIe5112_DigitalTriggerOut_PFI_12 , PFI13 = JYPCIe5112Import.JYPCIe5112_DigitalTriggerOut_PFI_13 , PFI14 = JYPCIe5112Import.JYPCIe5112_DigitalTriggerOut_PFI_14 , PFI15 = JYPCIe5112Import.JYPCIe5112_DigitalTriggerOut_PFI_15 ,
PXI_Trig0 = JYPCIe5112Import.JYPCIe5112_TriggerOut_PXI_0 , PXI_Trig1 = JYPCIe5112Import.JYPCIe5112_TriggerOut_PXI_1 , PXI_Trig2 = JYPCIe5112Import.JYPCIe5112_TriggerOut_PXI_2 , PXI_Trig3 = JYPCIe5112Import.JYPCIe5112_TriggerOut_PXI_3 ,
PXI_Trig4 = JYPCIe5112Import.JYPCIe5112_TriggerOut_PXI_4 , PXI_Trig5 = JYPCIe5112Import.JYPCIe5112_TriggerOut_PXI_5 , PXI_Trig6 = JYPCIe5112Import.JYPCIe5112_TriggerOut_PXI_6 , PXI_Trig7 = JYPCIe5112Import.JYPCIe5112_TriggerOut_PXI_7 ,
None = 24
}
IO终端=信号的目的地（共24个） More...
enum | CISignalExportSource { StartTrig }
SourceSignal. More...
enum | COIdleState { HighLevel = JYPCIe5112Import.JYPCIe5112_HighLevel , LowLevel = JYPCIe5112Import.JYPCIe5112_LowLevel }
Idle state when pulse output before start and after stop. More...
enum | COMode { Single = 3 , Finite = 0 , ContinuousNoWrapping = 2 , ContinuousWrapping = 1 }
CO output mode. More...
enum | COTriggerType { Immediate = JYPCIe5112Import.JYPCIe5112_CIO_Immediately , Digital = JYPCIe5112Import.JYPCIe5112_CIO_Digital , Soft = JYPCIe5112Import.JYPCIe5112_CIO_Soft }
TriggerType Digital/Immediate/Soft. More...
enum CODigitalTriggerSource {
PFI0 = 0 , PFI1 = 1 , PFI2 = 2 , PFI3 = 3 ,
PFI4 = 4 , PFI5 = 5 , PFI6 = 6 , PFI7 = 7 ,
PFI8 = 8 , PFI9 = 9 , PFI10 = 10 , PFI11 = 11 ,
PFI12 = 12 , PFI13 = 13 , PFI14 = 14 , PFI15 = 15 ,
PXI_Trig0 = 16 , PXI_Trig1 = 17 , PXI_Trig2 = 18 , PXI_Trig3 = 19 ,
PXI_Trig4 = 20 , PXI_Trig5 = 21 , PXI_Trig6 = 22 , PXI_Trig7 = 23 ,
AI_StartTrig = 24 , AI_ReferenceTrig = 25 , AO_StartTrig = 26 , CIO_0_StartTrig = 27 ,
CIO_1_StartTrig = 28 , CO0_Output = 29 , CO1_Output = 30
}
CO Digital trigger source. More...
enum | CODigitalTriggerEdge { Rising , Falling }
CO Digital Trigger Edge. More...
enum | COPulseType { DutyCycleFrequency , HighLowTime , HighLowTick }
Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick. More...
enum | COTimebaseSource { Internal100MHz = 0 , Internal5MHz = 1 , Internal100kHz = 2 , External = 3 }
enum | COSignalExportSource { StartTrig , Output }
SourceSignal. More...

Enumeration Type Documentation

◆ AIAnalogTriggerComparator

enum JYPCIe5112.AIAnalogTriggerComparator

AI Analog Trigger Comparator.

Enumerator
Edge | Edge Comparator.
Hysteresis | Hysteresis Comparator.
Window | Window Comparator.

◆ AIAnalogTriggerEdge

enum JYPCIe5112.AIAnalogTriggerEdge

AI Analog Trigger Edge.

Enumerator
Rising | Rising.
Falling | Falling.

◆ AIAnalogTriggerSource

enum JYPCIe5112.AIAnalogTriggerSource

AI analog trigger source.

Enumerator
Channel_0 | Channel_0 as the trigger source.
Channel_1 | Channel_1 as the trigger source.
Channel_2 | Channel_2 as the trigger source.
Channel_3 | Channel_3 as the trigger source.
Channel_4 | Channel_4 as the trigger source.
Channel_5 | Channel_5 as the trigger source.
Channel_6 | Channel_6 as the trigger source.
Channel_7 | Channel_7 as the trigger source.
Channel_8 | Channel_8 as the trigger source.
Channel_9 | Channel_9 as the trigger source.
Channel_10 | Channel_10 as the trigger source.
Channel_11 | Channel_11 as the trigger source.
Channel_12 | Channel_12 as the trigger source.
Channel_13 | Channel_13 as the trigger source.
Channel_14 | Channel_14 as the trigger source.
Channel_15 | Channel_15 as the trigger source.

◆ AIAnalogWindowCondition

enum JYPCIe5112.AIAnalogWindowCondition

AI Analog Window Trigger Condition.

Enumerator
Entering | Rising.
Leaving | Falling.

◆ AIDigitalTriggerEdge

enum JYPCIe5112.AIDigitalTriggerEdge

AI Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ AIDigitalTriggerSource

enum JYPCIe5112.AIDigitalTriggerSource

AI Digital trigger source.

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11.
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.
AO_StartTrig | AO_StartTrig.
CI0_StartTrig | CI0_StartTrig.
CI1_StartTrig | CI1_StartTrig.
CO0_Output | CO0_Output.
CO1_Output | CO1_Output.

◆ AIMode

enum JYPCIe5112.AIMode

AIMode.

Enumerator
Single | Single.
Finite | Finite.
Continuous | Continuous.
Record | Record.

◆ AISampleClockSource

enum JYPCIe5112.AISampleClockSource

AI Sample Clock Source.

Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ AISignalExportSource

enum JYPCIe5112.AISignalExportSource

AI Signal Export Source.

Enumerator
StartTrig | AI_StartTrig.
ReferenceTrig | AI_ReferenceTrig.
SampleClock | AI_SampleClock.

◆ AITerminal

enum JYPCIe5112.AITerminal

AITerminal.

Enumerator
RSE | RSE.
NRSE | NRSE.
Differential | Differential.

◆ AITriggerMode

enum JYPCIe5112.AITriggerMode

AI Trigger Mode.

Enumerator
Start | Start Trigger.
Reference | Reference Trigger，Valid when JYPCIe5112AITask.Mode is AIMode.Finite

◆ AITriggerType

enum JYPCIe5112.AITriggerType

Trigger Type Digital/Analog/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Analog | Analog Trigger.
Soft | Soft Trigger.

◆ AODigitalTriggerEdge

enum JYPCIe5112.AODigitalTriggerEdge

AO Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ AODigitalTriggerSource

enum JYPCIe5112.AODigitalTriggerSource

AO Digital trigger source.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PFI8 | PFI_8.
PFI9 | PFI_9.
PFI10 | PFI_10.
PFI11 | PFI_11.
PFI12 | PFI_12.
PFI13 | PFI_13.
PFI14 | PFI_14.
PFI15 | PFI_15.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
CIO_0_StartTrig | CI0_StartTrig.
CIO_1_StartTrig | CI1_StartTrig.
CO0_Output | CO0_Output.
CO1_Output | CO1_Output.

◆ AOMode

enum JYPCIe5112.AOMode

AOMode.

Enumerator
Single | Single.
Finite | Finite.
ContinuousNoWrapping | ContinuousNoWrapping.
ContinuousWrapping | ContinuousWrapping.

◆ AOSampleClockSource

enum JYPCIe5112.AOSampleClockSource

AO Sample Clock Source.

Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ AOSignalExportSource

enum JYPCIe5112.AOSignalExportSource

SourceSignal.

Enumerator
StartTrig | AO_StartTrig.
SampleClock | AO_SampleClock.

◆ AOTriggerType

enum JYPCIe5112.AOTriggerType

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ CIDigitalTriggerEdge

enum JYPCIe5112.CIDigitalTriggerEdge

CI Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ CIDigitalTriggerSource

enum JYPCIe5112.CIDigitalTriggerSource

CI Digital trigger source.

(共32个）

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PFI8 | PFI_8.
PFI9 | PFI_9.
PFI10 | PFI_10.
PFI11 | PFI_11.
PFI12 | PFI_12.
PFI13 | PFI_13.
PFI14 | PFI_14.
PFI15 | PFI_15.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
AO_StartTrig | AO_StartTrig.
CIO_0_StartTrig | CI0_StartTrig.
CIO_1_StartTrig | CI1_StartTrig.
CO0_Output | CO0_Output.
CO1_Output | CO1_Output.

◆ CISignalExportSource

enum JYPCIe5112.CISignalExportSource

SourceSignal.

Enumerator
StartTrig

CI_StartTrig.

◆ CITimebaseSource

enum JYPCIe5112.CITimebaseSource

时基源

Timebase source

Enumerator
Internal100MHz | 内部100MHz时基 Internal 100MHz Timebase
Internal5MHz | 内部5MHz时基 Internal 5MHz Timebase
Internal100kHz | 内部100kHz时基 Internal 100kHz Timebase
External | 外部时基 External Timebase

◆ CITriggerType

enum JYPCIe5112.CITriggerType

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ CIType

enum JYPCIe5112.CIType

Counter Input Application Type.

Enumerator
EdgeCounting | Edge Counting.
Period | Period Measure.
Frequency | Frequenc Measure.
Pulse | Pulse Measure.
SemiPeriod | SemiPeriod Measure.
TwoEdgeSeparation | TwoEdgeSeparation Measure.
QuadEncoder | QuadEncoder.
TwoPulseEncoder | EncoderTwoPulse.

◆ ClockTerminal

enum JYPCIe5112.ClockTerminal

Clock Terminal.

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11.
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PXI_Trig0 | PXITrigger_0.
PXI_Trig1 | PXITrigger_1.
PXI_Trig2 | PXITrigger_2.
PXI_Trig3 | PXITrigger_3.
PXI_Trig4 | PXITrigger_4.
PXI_Trig5 | PXITrigger_5.
PXI_Trig6 | PXITrigger_6.
PXI_Trig7 | PXITrigger_7.
AI_SampleClock | AI_SampleClock.
AO_SampleClock | AO_SampleClock.
CO0_Output | CO0_Output.
CO1_Output | CO1_Output.
ECLK | ECLK.

◆ CODigitalTriggerEdge

enum JYPCIe5112.CODigitalTriggerEdge

CO Digital Trigger Edge.

Enumerator
Rising | Rising Edge.
Falling | Falling Edge.

◆ CODigitalTriggerSource

enum JYPCIe5112.CODigitalTriggerSource

CO Digital trigger source.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PFI8 | PFI_8.
PFI9 | PFI_9.
PFI10 | PFI_10.
PFI11 | PFI_11.
PFI12 | PFI_12.
PFI13 | PFI_13.
PFI14 | PFI_14.
PFI15 | PFI_15.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
AO_StartTrig | AO_StartTrig.
CIO_0_StartTrig | CI0_StartTrig.
CIO_1_StartTrig | CI1_StartTrig.
CO0_Output | CO0_Output.
CO1_Output | CO1_Output.

◆ COIdleState

enum JYPCIe5112.COIdleState

Idle state when pulse output before start and after stop.

Enumerator
HighLevel | Idle state is high level.
LowLevel | Idle state is low level.

◆ COMode

enum JYPCIe5112.COMode

CO output mode.

Enumerator
Single | Single pulse output.
Finite | Finite.
ContinuousNoWrapping | ContinuousNoWrapping.
ContinuousWrapping | ContinuousWrapping.

◆ COPulseType

enum JYPCIe5112.COPulseType

Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick.

Enumerator
DutyCycleFrequency | Configure CO output pulse according to its DutyCycle and Freqency.
HighLowTime | Configure CO output pulse according to duration of its high/low voltage levels.
HighLowTick | Configure CO output pulse according to its high/low tick level.

◆ COSignalExportSource

enum JYPCIe5112.COSignalExportSource

SourceSignal.

Enumerator
StartTrig | CI_StartTrig.
Output | CO_Output.

◆ COTimebaseSource

enum JYPCIe5112.COTimebaseSource

时基源

Timebase source

Enumerator
Internal100MHz | 内部100MHz时基 Internal 100MHz Timebase
Internal5MHz | 内部5MHz时基 Internal 5MHz Timebase
Internal100kHz | 内部100kHz时基 Internal 100kHz Timebase
External | 外部时基 External Timebase

◆ COTriggerType

enum JYPCIe5112.COTriggerType

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ CountDirection

enum JYPCIe5112.CountDirection

Counter direction.

enum Up/Down/External

Enumerator
Up | Counter increases.
Down | Counter decreases.
External | External signal control counter direction. If External signal is highlevel counter increases, or lowlevel counter decreases.

◆ EdgeCntOunEvtIdleState

enum JYPCIe5112.EdgeCntOunEvtIdleState

Output idle state when the event has not occurred.

Enumerator
LowLevel | Idle state is low level.
HighLevel | Idle state is high level.

◆ EdgeType

enum JYPCIe5112.EdgeType

Edge Type.

Enumerator
Rising | Rising Edge.
Falling | Falling Edge.
Any | Any Edge.

◆ FileFormat

enum JYPCIe5112.FileFormat

Streaming file format.

enum BIN.

Enumerator
Bin

BIN。

BIN.

◆ InputTerminal

enum JYPCIe5112.InputTerminal

输入终端

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PFI8 | PFI_8.
PFI9 | PFI_9.
PFI10 | PFI_10.
PFI11 | PFI_11.
PFI12 | PFI_12.
PFI13 | PFI_13.
PFI14 | PFI_14.
PFI15 | PFI_15.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
CO_0_OutPut | CO_0_OutPut.
CO_1_OutPut | CO_1_OutPut.
Timebase_100MHz | Timebase_100MHz.
Timebase_5MHz | Timebase_5MHz.
Timebase_100kHz | Timebase_100kHz.

◆ IOTerminal

enum JYPCIe5112.IOTerminal

IO终端=信号的目的地（共24个）

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PFI8 | PFI_8.
PFI9 | PFI_9.
PFI10 | PFI_10.
PFI11 | PFI_11.
PFI12 | PFI_12.
PFI13 | PFI_13.
PFI14 | PFI_14.
PFI15 | PFI_15.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
None | None.

◆ LevelPolarity

enum JYPCIe5112.LevelPolarity

Level Polarity.

Enumerator
LowLevel | Low level.
HighLevel | High level.
None | No active polarity.

◆ OutputCompleteState

enum JYPCIe5112.OutputCompleteState

Output Complete State.

Enumerator
Zero | Output Complete Zero.
Hold | Output Complete Hold in The last point.

◆ OutputState

enum JYPCIe5112.OutputState

CO output state when pause trigger valid.

Enumerator
HoldOn | output hold on
HighLevel | output HighLevel
LowLevel | output LowLevel

◆ QuadEncodingType

enum JYPCIe5112.QuadEncodingType

Quadrature Encoding Type.

Enumerator
X1 | X1.
X2 | X2.
X4 | X4.

◆ RecordMode

enum JYPCIe5112.RecordMode

stream mode .enum Finite/Infinite

Enumerator
Finite | Finite Streaming.
Infinite | Infinite Streaming.

◆ SignalExportDestination

enum JYPCIe5112.SignalExportDestination

Output DestinationTerminal.

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11.
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.

◆ ValueReturnMode

enum JYPCIe5112.ValueReturnMode

TwoEdgeSeparation value return mode.only for TwoEdgeSeparation type.

Enumerator
TwoValue | Return two data simultaneously. first data is gate to aux edge separation, second data is aux to gate edge separation.
OneValue | only return gate to aux edge separation


5112 C# Programming Manual: Package Members

  • Package List
  • Package Members
  • All
  • Enumerations
  • a
  • c
  • e
  • f
  • i
  • l
  • o
  • q
  • r
  • s
  • v
Here is a list of all namespace members with links to the namespace documentation for each member:

- a -

  • AIAnalogTriggerComparator : JYPCIe5112
  • AIAnalogTriggerEdge : JYPCIe5112
  • AIAnalogTriggerSource : JYPCIe5112
  • AIAnalogWindowCondition : JYPCIe5112
  • AIDigitalTriggerEdge : JYPCIe5112
  • AIDigitalTriggerSource : JYPCIe5112
  • AIMode : JYPCIe5112
  • AISampleClockSource : JYPCIe5112
  • AISignalExportSource : JYPCIe5112
  • AITerminal : JYPCIe5112
  • AITriggerMode : JYPCIe5112
  • AITriggerType : JYPCIe5112
  • AODigitalTriggerEdge : JYPCIe5112
  • AODigitalTriggerSource : JYPCIe5112
  • AOMode : JYPCIe5112
  • AOSampleClockSource : JYPCIe5112
  • AOSignalExportSource : JYPCIe5112
  • AOTriggerType : JYPCIe5112

- c -

  • CIDigitalTriggerEdge : JYPCIe5112
  • CIDigitalTriggerSource : JYPCIe5112
  • CISignalExportSource : JYPCIe5112
  • CITimebaseSource : JYPCIe5112
  • CITriggerType : JYPCIe5112
  • CIType : JYPCIe5112
  • ClockTerminal : JYPCIe5112
  • CODigitalTriggerEdge : JYPCIe5112
  • CODigitalTriggerSource : JYPCIe5112
  • COIdleState : JYPCIe5112
  • COMode : JYPCIe5112
  • COPulseType : JYPCIe5112
  • COSignalExportSource : JYPCIe5112
  • COTimebaseSource : JYPCIe5112
  • COTriggerType : JYPCIe5112
  • CountDirection : JYPCIe5112

- e -

  • EdgeCntOunEvtIdleState : JYPCIe5112
  • EdgeType : JYPCIe5112

- f -

  • FileFormat : JYPCIe5112

- i -

  • InputTerminal : JYPCIe5112
  • IOTerminal : JYPCIe5112

- l -

  • LevelPolarity : JYPCIe5112

- o -

  • OutputCompleteState : JYPCIe5112
  • OutputState : JYPCIe5112

- q -

  • QuadEncodingType : JYPCIe5112

- r -

  • RecordMode : JYPCIe5112

- s -

  • SignalExportDestination : JYPCIe5112

- v -

  • ValueReturnMode : JYPCIe5112


5112 C# Programming Manual: Package Members

  • Package List
  • Package Members
  • All
  • Enumerations
  • a
  • c
  • e
  • f
  • i
  • l
  • o
  • q
  • r
  • s
  • v
Here is a list of all namespace enums with links to the namespace documentation for each enum:

- a -

  • AIAnalogTriggerComparator : JYPCIe5112
  • AIAnalogTriggerEdge : JYPCIe5112
  • AIAnalogTriggerSource : JYPCIe5112
  • AIAnalogWindowCondition : JYPCIe5112
  • AIDigitalTriggerEdge : JYPCIe5112
  • AIDigitalTriggerSource : JYPCIe5112
  • AIMode : JYPCIe5112
  • AISampleClockSource : JYPCIe5112
  • AISignalExportSource : JYPCIe5112
  • AITerminal : JYPCIe5112
  • AITriggerMode : JYPCIe5112
  • AITriggerType : JYPCIe5112
  • AODigitalTriggerEdge : JYPCIe5112
  • AODigitalTriggerSource : JYPCIe5112
  • AOMode : JYPCIe5112
  • AOSampleClockSource : JYPCIe5112
  • AOSignalExportSource : JYPCIe5112
  • AOTriggerType : JYPCIe5112

- c -

  • CIDigitalTriggerEdge : JYPCIe5112
  • CIDigitalTriggerSource : JYPCIe5112
  • CISignalExportSource : JYPCIe5112
  • CITimebaseSource : JYPCIe5112
  • CITriggerType : JYPCIe5112
  • CIType : JYPCIe5112
  • ClockTerminal : JYPCIe5112
  • CODigitalTriggerEdge : JYPCIe5112
  • CODigitalTriggerSource : JYPCIe5112
  • COIdleState : JYPCIe5112
  • COMode : JYPCIe5112
  • COPulseType : JYPCIe5112
  • COSignalExportSource : JYPCIe5112
  • COTimebaseSource : JYPCIe5112
  • COTriggerType : JYPCIe5112
  • CountDirection : JYPCIe5112

- e -

  • EdgeCntOunEvtIdleState : JYPCIe5112
  • EdgeType : JYPCIe5112

- f -

  • FileFormat : JYPCIe5112

- i -

  • InputTerminal : JYPCIe5112
  • IOTerminal : JYPCIe5112

- l -

  • LevelPolarity : JYPCIe5112

- o -

  • OutputCompleteState : JYPCIe5112
  • OutputState : JYPCIe5112

- q -

  • QuadEncodingType : JYPCIe5112

- r -

  • RecordMode : JYPCIe5112

- s -

  • SignalExportDestination : JYPCIe5112

- v -

  • ValueReturnMode : JYPCIe5112


5112 C# Programming Manual: Package List

  • Package List
  • Package Members
Package List
Here are the packages with brief descriptions (if available):
N JYPCIe5112