5113 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5113 Directory Reference

5113 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 5113
5113 Directory Reference

Files

JY5113CoreOOAITask.h
JY5113CoreOOAOTask.h
JY5113CoreOOCITask.h
JY5113CoreOOCommon.h
JY5113CoreOOCOTask.h
JY5113CoreOODevice.h
JY5113CoreOODITask.h
JY5113CoreOODOTask.h
JY5113CoreOOLog.h
Generated by doxygen 1.13.2


5113 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOAITask.h File Reference

  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 5113
Classes | Namespaces | Enumerations
JY5113CoreOOAITask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JY5113CoreOOCommon.h"
#include "JY5113CoreOODevice.h"

Classes

class | JY5113CoreOO::JY5113CoreOOAITask
AITask类 More...
class | JY5113CoreOO::AIChannel
class | JY5113CoreOO::AIExternalSampleClock
Sample clock configuration class. More...
class | JY5113CoreOO::AISampleClock
Sample clock configuration class. More...
class | JY5113CoreOO::AITrigger
Constructor to create an AITrigger task object. More...
class | JY5113CoreOO::AIDigitalTrigger
AI Digital trigger class. More...
class | JY5113CoreOO::AIAnalogHysteresisComparator
AI Analog Hysteresis Comparatorr. More...
class | JY5113CoreOO::AIAnalogWindowComparator
AI Analog Window Comparatorr. More...
class | JY5113CoreOO::AIAnalogEdgeComparator
AI Analog Edge Comparator. More...
class | JY5113CoreOO::AIAnalogTrigger
AI analog trigger . More...
class | JY5113CoreOO::AIRecord
AI Record Parameters. More...
class | JY5113CoreOO::AIDSMode
class | JY5113CoreOO::AIAdvanced
AI Advance parameter. More...
class | JY5113CoreOO::AISignalExport
AI Signal Export Class. More...

Namespaces

namespace JY5113CoreOO

Enumerations

enum class | JY5113CoreOO::AITerminal { JY5113CoreOO::RSE = 0x0 , JY5113CoreOO::NRSE = 0x1 , JY5113CoreOO::Differential = 0x2 }
enum class | JY5113CoreOO::AIMode { JY5113CoreOO::Single = 0x2 , JY5113CoreOO::Finite = 0x0 , JY5113CoreOO::Continuous = 0x1 , JY5113CoreOO::Record = 0x3 }
enum class | JY5113CoreOO::AIBandWidth { JY5113CoreOO::_39KHz , JY5113CoreOO::_15KHz , JY5113CoreOO::_80KHz }
AI BandWidth. More...
enum class | JY5113CoreOO::AISampleClockSource { JY5113CoreOO::Internal , JY5113CoreOO::External }
AI Sample Clock Source. More...
enum class | JY5113CoreOO::AITriggerType { JY5113CoreOO::Immediate = 0x0 , JY5113CoreOO::Digital = 0x1 , JY5113CoreOO::Analog = 0x2 , JY5113CoreOO::Soft = 0x3 }
Trigger Type Digital/Analog/Immediate/Soft. More...
enum class | JY5113CoreOO::AITriggerMode { JY5113CoreOO::Start , JY5113CoreOO::Reference }
AI Trigger Mode. More...
enum class JY5113CoreOO::AIAnalogTriggerSource {
JY5113CoreOO::Channel_0 , JY5113CoreOO::Channel_1 , JY5113CoreOO::Channel_2 , JY5113CoreOO::Channel_3 ,
JY5113CoreOO::Channel_4 , JY5113CoreOO::Channel_5 , JY5113CoreOO::Channel_6 , JY5113CoreOO::Channel_7 ,
JY5113CoreOO::Channel_8 , JY5113CoreOO::Channel_9 , JY5113CoreOO::Channel_10 , JY5113CoreOO::Channel_11 ,
JY5113CoreOO::Channel_12 , JY5113CoreOO::Channel_13 , JY5113CoreOO::Channel_14 , JY5113CoreOO::Channel_15 ,
JY5113CoreOO::Channel_16 , JY5113CoreOO::Channel_17 , JY5113CoreOO::Channel_18 , JY5113CoreOO::Channel_19 ,
JY5113CoreOO::Channel_20 , JY5113CoreOO::Channel_21 , JY5113CoreOO::Channel_22 , JY5113CoreOO::Channel_23 ,
JY5113CoreOO::Channel_24 , JY5113CoreOO::Channel_25 , JY5113CoreOO::Channel_26 , JY5113CoreOO::Channel_27 ,
JY5113CoreOO::Channel_28 , JY5113CoreOO::Channel_29 , JY5113CoreOO::Channel_30 , JY5113CoreOO::Channel_31 ,
JY5113CoreOO::Channel_32 , JY5113CoreOO::Channel_33 , JY5113CoreOO::Channel_34 , JY5113CoreOO::Channel_35 ,
JY5113CoreOO::Channel_36 , JY5113CoreOO::Channel_37 , JY5113CoreOO::Channel_38 , JY5113CoreOO::Channel_39 ,
JY5113CoreOO::Channel_40 , JY5113CoreOO::Channel_41 , JY5113CoreOO::Channel_42 , JY5113CoreOO::Channel_43 ,
JY5113CoreOO::Channel_44 , JY5113CoreOO::Channel_45 , JY5113CoreOO::Channel_46 , JY5113CoreOO::Channel_47 ,
JY5113CoreOO::Channel_48 , JY5113CoreOO::Channel_49 , JY5113CoreOO::Channel_50 , JY5113CoreOO::Channel_51 ,
JY5113CoreOO::Channel_52 , JY5113CoreOO::Channel_53 , JY5113CoreOO::Channel_54 , JY5113CoreOO::Channel_55 ,
JY5113CoreOO::Channel_56 , JY5113CoreOO::Channel_57 , JY5113CoreOO::Channel_58 , JY5113CoreOO::Channel_59 ,
JY5113CoreOO::Channel_60 , JY5113CoreOO::Channel_61 , JY5113CoreOO::Channel_62 , JY5113CoreOO::Channel_63
}
AI analog trigger source. More...
enum class JY5113CoreOO::AIDigitalTriggerSource {
JY5113CoreOO::PFI0 , JY5113CoreOO::PFI1 , JY5113CoreOO::PFI2 , JY5113CoreOO::PFI3 ,
JY5113CoreOO::PFI4 , JY5113CoreOO::PFI5 , JY5113CoreOO::PFI6 , JY5113CoreOO::PFI7 ,
JY5113CoreOO::PFI8 , JY5113CoreOO::PFI9 , JY5113CoreOO::PFI10 , JY5113CoreOO::PFI11 ,
JY5113CoreOO::PFI12 , JY5113CoreOO::PFI13 , JY5113CoreOO::PFI14 , JY5113CoreOO::PFI15 ,
JY5113CoreOO::PXI_Trig0 , JY5113CoreOO::PXI_Trig1 , JY5113CoreOO::PXI_Trig2 , JY5113CoreOO::PXI_Trig3 ,
JY5113CoreOO::PXI_Trig4 , JY5113CoreOO::PXI_Trig5 , JY5113CoreOO::PXI_Trig6 , JY5113CoreOO::PXI_Trig7 = 23 ,
JY5113CoreOO::DI_StartTrig = 26 , JY5113CoreOO::DI_ReferenceTrig , JY5113CoreOO::AO_StartTrig , JY5113CoreOO::DO_StartTrig ,
JY5113CoreOO::CIO_0_StartTrig , JY5113CoreOO::CIO_1_StartTrig , JY5113CoreOO::CIO_2_StartTrig , JY5113CoreOO::CIO_3_StartTrig ,
JY5113CoreOO::CO0_Output , JY5113CoreOO::CO1_Output , JY5113CoreOO::CO2_Output , JY5113CoreOO::CO3_Output
}
AI Digital trigger source. More...
enum class | JY5113CoreOO::AIDigitalTriggerEdge { JY5113CoreOO::Rising = 0x0 , JY5113CoreOO::Falling = 0x1 }
AI Digital Trigger Edge. More...
enum class | JY5113CoreOO::AIAnalogTriggerEdge { JY5113CoreOO::Rising , JY5113CoreOO::Falling }
AI Analog Trigger Edge. More...
enum class | JY5113CoreOO::AIAnalogWindowCondition { JY5113CoreOO::Entering , JY5113CoreOO::Leaving }
AI Analog Window Trigger Condition. More...
enum class | JY5113CoreOO::AIAnalogTriggerComparator { JY5113CoreOO::Edge , JY5113CoreOO::Hysteresis , JY5113CoreOO::Window }
AI Analog Trigger Comparator. More...
enum class | JY5113CoreOO::AISignalExportSource { JY5113CoreOO::StartTrig = 24 , JY5113CoreOO::ReferenceTrig = 25 , JY5113CoreOO::SampleClock = 34 }
AI Signal Export Source. More...
enum class | JY5113CoreOO::FileFormat { JY5113CoreOO::Bin }
Streaming file format. More...
enum class | JY5113CoreOO::RecordMode { JY5113CoreOO::Finite , JY5113CoreOO::Infinite }
stream mode .enum Finite/Infinite More...
enum class | JY5113CoreOO::PowerLineFrequency { JY5113CoreOO::_50Hz , JY5113CoreOO::_60Hz }
enum class JY5113CoreOO::SyncTriggerRouting {
JY5113CoreOO::NONE = -1 , JY5113CoreOO::PXI_Trig0 = 16 , JY5113CoreOO::PXI_Trig1 , JY5113CoreOO::PXI_Trig2 ,
JY5113CoreOO::PXI_Trig3 , JY5113CoreOO::PXI_Trig4 , JY5113CoreOO::PXI_Trig5 , JY5113CoreOO::PXI_Trig6 ,
JY5113CoreOO::PXI_Trig7
}
Master card trigger signal routing (Master card routes trigger signal to this port) 主控卡触发信号路由(主控卡将触发信号路由到此端口) More...
enum class JY5113CoreOO::SyncPulseRouting {
JY5113CoreOO::NONE = -1 , JY5113CoreOO::PXI_Trig0 = 16 , JY5113CoreOO::PXI_Trig1 , JY5113CoreOO::PXI_Trig2 ,
JY5113CoreOO::PXI_Trig3 , JY5113CoreOO::PXI_Trig4 , JY5113CoreOO::PXI_Trig5 , JY5113CoreOO::PXI_Trig6 ,
JY5113CoreOO::PXI_Trig7
}
Synchronous signal routing (the master card routes the synchronous signal to this port, and the slave card receives the synchronous signal from this port) 同步信号路由(主卡将同步信号路由到该端口，从卡从该端口接收同步信号) More...


5113 C++ Programming Manual: JY5113CoreOO::JY5113CoreOOAITask Class Reference

  • Class List
  • Class Index
  • Class Members
  • JY5113CoreOO
  • JY5113CoreOOAITask
Public Member Functions | Public Attributes | List of all members
JY5113CoreOO::JY5113CoreOOAITask Class Reference

AITask类 More...

#include <JY5113CoreOOAOTask.h>

Public Member Functions

JY5113CoreOOAITask (int slotNum)
JY5113CoreOOAITask (std::string boardName)
void | AddChannel (int chnId, double rangeLow=-10, double rangeHigh=10, AITerminal terminalCfg=AITerminal::RSE, AIBandWidth bandWidth=AIBandWidth::_80KHz)
Add one channel.
void | AddChannel (std::vector< int > chnsId, double rangeLow=-10, double rangeHigh=10, AITerminal terminalCfg=AITerminal::RSE, AIBandWidth bandWidth=AIBandWidth::_80KHz)
Add a group of channels.
void | AddChannel (std::vector< int > chnsId, std::vector< double > rangeLow, std::vector< double > rangeHigh, AITerminal terminalCfg=AITerminal::RSE, AIBandWidth bandWidth=AIBandWidth::_80KHz)
Add a group of channels.
void | RemoveChannel (int chnId)
Delete the specified channel number.
void | ReadData (double *pBuf, int samplesPerChannel, int timeout=-1)
Read the multi-channel data by columns and store it in a data buffer.
void | ReadRawData (short *pBuf, int samplesPerChannel, int timeout=-1)
Read one or multi-channel raw data by columns and store it in a data buffer.
void | ReadSinglePoint (double &readValue, int channel)
Read one sample for specified channel in register.
void | ReadSinglePoint (std::vector< double > &readValues)
Read one sample for all channels in register .
void | ReadRawSinglePoint (int &readValue, int channel)
Read raw one sample for specified channel in register.
void | ReadRawSinglePoint (std::vector< uint32_t > &readValues)
Read raw one sample for all channels in register .
void | GetRecordPreviewData (double *buf, int samplesPerChannel, int timeout)
Preview multi-channel data when streaming is in progress.
void | GetRecordStatus (double &recordedLength, bool &recordDone)
get the streaming status.
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.
void | Start ()
启动Task
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Stop ()
Stop AI task .

Public Attributes

std::list< AIChannel * > | Channels
List of AI channels,(5113 support 64 SE/ 32 DIFF)
JY5113CoreOOProperty< JY5113CoreOOAITask, double, JY5113CoreOOPropertyType::READ_WRITE > | SampleRate
Single channel maximum sample rate:1 MS/s Multichannel maximum sample rate with same range(aggregate): 1 MS/s/n(n=1,2,3…64) The default sample rate = 300K You can read this property to obtain the sample rate that will actually take effect in the current configuration.
int | SamplesToAcquire
Number of samples to be read per channel.
JY5113CoreOOProperty< JY5113CoreOOAITask, int, JY5113CoreOOPropertyType::READ_ONLY > | BufLenInSamples
Number of samples per channel can be storage in the buffer, the Property SamplesToAcquire must be less than or equal to this value.
JY5113CoreOOProperty< JY5113CoreOOAITask, uint64_t, JY5113CoreOOPropertyType::READ_ONLY > | AvailableSamples
Number of samples per channel that can be read in the buffer .
JY5113CoreOOProperty< JY5113CoreOOAITask, uint64_t, JY5113CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
AIMode Mode
AI acquisition mode, support Single/Finite/Continuous/Record *.
AISampleClock * SampleClock
AI Sample Clock.
AITrigger * Trigger
AI Trigger Configuration.
AIAdvanced * Advanced
AIRecord * Record
ai Data streaming Configuration
AISignalExport * SignalExport
Export AI Signal Configuration.
JY5113CoreOODevice * Device
Device.
bool | DisableCalibration

Detailed Description

AITask类

Constructor & Destructor Documentation

◆ JY5113CoreOOAITask() [1/2]

JY5113CoreOO::JY5113CoreOOAITask::JY5113CoreOOAITask ( int slotNum )

◆ JY5113CoreOOAITask() [2/2]

JY5113CoreOO::JY5113CoreOOAITask::JY5113CoreOOAITask ( std::string boardName )

Member Function Documentation

◆ AddChannel() [1/3]

void JY5113CoreOO::JY5113CoreOOAITask::AddChannel | ( | int | chnId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10,
 |  | AITerminal | terminalCfg = AITerminal::RSE,
 |  | AIBandWidth | bandWidth = AIBandWidth::_80KHz )

Add one channel.

Parameters
chnId | channel's physical number ，chnId=-1, add all channels。（64 SE/ 32 DIFF）
rangeLow | lower range limit for the channel，-10/-5/-2.5V defalut -10V
rangeHigh | higher range limit for the channel，10/5/2.5V defalut 10V
terminalCfg | terminal input mode configuration，RSE/NRSE/Differential.Default RSE

◆ AddChannel() [2/3]

void JY5113CoreOO::JY5113CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10,
 |  | AITerminal | terminalCfg = AITerminal::RSE,
 |  | AIBandWidth | bandWidth = AIBandWidth::_80KHz )

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers （64 SE/ 32 DIFF）
rangeLow | lower range limit for the channel，-10/-5/-2.5V defalut -10V
rangeHigh | higher range limit for the channel，10/5/2.5V defalut 10V
terminalCfg | terminal input mode configuration，RSE/NRSE/Differential.Default RSE

◆ AddChannel() [3/3]

void JY5113CoreOO::JY5113CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | std::vector< double > | rangeLow,
 |  | std::vector< double > | rangeHigh,
 |  | AITerminal | terminalCfg = AITerminal::RSE,
 |  | AIBandWidth | bandWidth = AIBandWidth::_80KHz )

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers （64 SE/ 32 DIFF）
rangeLow | lower range limit for the channel，-10/-5/-2.5V defalut -10V
rangeHigh | higher range limit for the channel，10/5/2.5V defalut 10V
terminalCfg | terminal input mode configuration，RSE/NRSE/Differential.Default RSE

◆ GetRecordPreviewData()

void JY5113CoreOO::JY5113CoreOOAITask::GetRecordPreviewData | ( | double * | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Preview multi-channel data when streaming is in progress.

Each column represents one channel.

Parameters
buf | Data buffer
samplesPerChannel | Number of preview samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ GetRecordStatus()

void JY5113CoreOO::JY5113CoreOOAITask::GetRecordStatus | ( | double & | recordedLength,
 |  | bool & | recordDone )

get the streaming status.

Available when Mode is AIMode.Record

Parameters
recordedLength | Length of the streamed
recordDone | recordDone = false :streaming is not over.recordDone = true :streaming is over.

◆ ReadData()

void JY5113CoreOO::JY5113CoreOOAITask::ReadData | ( | double * | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = -1 )

Read the multi-channel data by columns and store it in a data buffer.

Each channel is represented by one column of data.

Parameters
pBuf | Data buffer
samplesPerChannel | Number of samples per channel to read
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadRawData()

void JY5113CoreOO::JY5113CoreOOAITask::ReadRawData | ( | short * | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = -1 )

Read one or multi-channel raw data by columns and store it in a data buffer.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel to read
timeout | timeout before generating error message, uint is ms。, timeout =-1 keep waiting until finish.

◆ ReadRawSinglePoint() [1/2]

void JY5113CoreOO::JY5113CoreOOAITask::ReadRawSinglePoint | ( | int & | readValue,
 |  | int | channel )

Read raw one sample for specified channel in register.

Available when Mode is AIMode.Single

Parameters
readValue | value read
channel | Specified channel numbers.

◆ ReadRawSinglePoint() [2/2]

void JY5113CoreOO::JY5113CoreOOAITask::ReadRawSinglePoint ( std::vector< uint32_t > & readValues )

Read raw one sample for all channels in register .

Available when Mode is AIMode.Single

Parameters
readValues Values read. Array length >= Channels.Count.

◆ ReadSinglePoint() [1/2]

void JY5113CoreOO::JY5113CoreOOAITask::ReadSinglePoint | ( | double & | readValue,
 |  | int | channel )

Read one sample for specified channel in register.

Available when Mode is AIMode.Single

Parameters
readValue | value read
channel | Specified channel numbers.

◆ ReadSinglePoint() [2/2]

void JY5113CoreOO::JY5113CoreOOAITask::ReadSinglePoint ( std::vector< double > & readValues )

Read one sample for all channels in register .

Available when Mode is AIMode.Single

Parameters
readValues Values read. Array length >= Channels.Count.

◆ RemoveChannel()

void JY5113CoreOO::JY5113CoreOOAITask::RemoveChannel ( int chnId )

Delete the specified channel number.

If it is -1, delete all channels.

Parameters
chnId Specified channel ID.

◆ SendSoftwareTrigger()

void JY5113CoreOO::JY5113CoreOOAITask::SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5113CoreOO::JY5113CoreOOAITask::Start ( )

启动Task

Parameters

return void

Exceptions
JYDriverException 如果启动失败

◆ Stop()

void JY5113CoreOO::JY5113CoreOOAITask::Stop ( )

Stop AI task .

◆ WaitUntilDone()

bool JY5113CoreOO::JY5113CoreOOAITask::WaitUntilDone ( int timeout = -1 )
inline

Waiting until current task to complete.

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

Member Data Documentation

◆ Advanced

AIAdvanced* JY5113CoreOO::JY5113CoreOOAITask::Advanced

◆ AvailableSamples

JY5113CoreOOProperty<JY5113CoreOOAITask, uint64_t, JY5113CoreOOPropertyType::READ_ONLY> JY5113CoreOO::JY5113CoreOOAITask::AvailableSamples

Number of samples per channel that can be read in the buffer .

Valid when Mode is NOT AIMode.Single.

◆ BufLenInSamples

JY5113CoreOOProperty<JY5113CoreOOAITask, int, JY5113CoreOOPropertyType::READ_ONLY> JY5113CoreOO::JY5113CoreOOAITask::BufLenInSamples

Number of samples per channel can be storage in the buffer, the Property SamplesToAcquire must be less than or equal to this value.

◆ Channels

std::list<AIChannel*> JY5113CoreOO::JY5113CoreOOAITask::Channels

List of AI channels,(5113 support 64 SE/ 32 DIFF)

◆ Device

JY5113CoreOODevice* JY5113CoreOO::JY5113CoreOOAITask::Device

Device.

◆ DisableCalibration

bool JY5113CoreOO::JY5113CoreOOAITask::DisableCalibration

◆ Mode

AIMode JY5113CoreOO::JY5113CoreOOAITask::Mode

AI acquisition mode, support Single/Finite/Continuous/Record *.

◆ Record

AIRecord* JY5113CoreOO::JY5113CoreOOAITask::Record

ai Data streaming Configuration

◆ SampleClock

AISampleClock* JY5113CoreOO::JY5113CoreOOAITask::SampleClock

AI Sample Clock.

◆ SampleRate

JY5113CoreOOProperty<JY5113CoreOOAITask, double, JY5113CoreOOPropertyType::READ_WRITE> JY5113CoreOO::JY5113CoreOOAITask::SampleRate

Single channel maximum sample rate:1 MS/s Multichannel maximum sample rate with same range(aggregate): 1 MS/s/n(n=1,2,3…64) The default sample rate = 300K You can read this property to obtain the sample rate that will actually take effect in the current configuration.

Exceptions
JYDriverException

◆ SamplesToAcquire

int JY5113CoreOO::JY5113CoreOOAITask::SamplesToAcquire

Number of samples to be read per channel.

Only valid when Mode is Finite*

◆ SignalExport

AISignalExport* JY5113CoreOO::JY5113CoreOOAITask::SignalExport

Export AI Signal Configuration.

◆ TransferedSamples

JY5113CoreOOProperty<JY5113CoreOOAITask, uint64_t, JY5113CoreOOPropertyType::READ_ONLY> JY5113CoreOO::JY5113CoreOOAITask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT AIMode.Single.

◆ Trigger

AITrigger* JY5113CoreOO::JY5113CoreOOAITask::Trigger

AI Trigger Configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOAITask.h


5113 C++ Programming Manual: JY5113CoreOO::AIChannel Class Reference

  • JY5113CoreOO
  • AIChannel
Public Member Functions | Public Attributes | List of all members
JY5113CoreOO::AIChannel Class Reference

#include <JY5113CoreOOAITask.h>

Public Member Functions

AIChannel (int channelId, double rangeLow, double rangeHigh, AITerminal terminalCfg=AITerminal::NRSE, AIBandWidth bandWidth=AIBandWidth::_80KHz)
Constructor to create an AIChnParam task object.

Public Attributes

int | ChannelID
AI channel ID.
double | RangeLow
Low range limit an AI channel，-10V,-5V,-2.5V，-1V, -0.5V, -0.25V.
double | RangeHigh
High range limit an AI channel，10V,5V,2.5V，1V, 0.5V, 0.25V.
AITerminal Terminal
Configure AI terminal.
AIBandWidth BandWidth
AI BandWidth,default 80KHz.

Constructor & Destructor Documentation

◆ AIChannel()

JY5113CoreOO::AIChannel::AIChannel | ( | int | channelId,
 |  | double | rangeLow,
 |  | double | rangeHigh,
 |  | AITerminal | terminalCfg = AITerminal::NRSE,
 |  | AIBandWidth | bandWidth = AIBandWidth::_80KHz )
 inline

Constructor to create an AIChnParam task object.

Parameters
channelId | AI channel ID.
rangeLow | Low range limit an AI channel.
rangeHigh | High range limit an AI channel.
terminalCfg | Configure AI terminal.(RSE,Differential).
bandWidth | AI BandWidth.

Member Data Documentation

◆ BandWidth

AIBandWidth JY5113CoreOO::AIChannel::BandWidth

AI BandWidth,default 80KHz.

◆ ChannelID

int JY5113CoreOO::AIChannel::ChannelID

AI channel ID.

◆ RangeHigh

double JY5113CoreOO::AIChannel::RangeHigh

High range limit an AI channel，10V,5V,2.5V，1V, 0.5V, 0.25V.

◆ RangeLow

double JY5113CoreOO::AIChannel::RangeLow

Low range limit an AI channel，-10V,-5V,-2.5V，-1V, -0.5V, -0.25V.

◆ Terminal

AITerminal JY5113CoreOO::AIChannel::Terminal

Configure AI terminal.

(RSE,Differential)

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOAITask.h


5113 C++ Programming Manual: JY5113CoreOO::AIExternalSampleClock Class Reference

  • AIExternalSampleClock
Public Attributes | List of all members
JY5113CoreOO::AIExternalSampleClock Class Reference

Sample clock configuration class. More...

#include <JY5113CoreOOAITask.h>

Public Attributes

ClockTerminal Terminal
External Sample Clock Input Terminal.
double ExpectedRate
Expected External Sample Clock Rate.

Detailed Description

Sample clock configuration class.

Member Data Documentation

◆ ExpectedRate

double JY5113CoreOO::AIExternalSampleClock::ExpectedRate

Expected External Sample Clock Rate.

◆ Terminal

ClockTerminal JY5113CoreOO::AIExternalSampleClock::Terminal

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOAITask.h


5113 C++ Programming Manual: JY5113CoreOO::AISampleClock Class Reference

  • AISampleClock
Public Attributes | List of all members
JY5113CoreOO::AISampleClock Class Reference

Sample clock configuration class. More...

#include <JY5113CoreOOAITask.h>

Public Attributes

AISampleClockSource Source
AI Sample Clock Source.
AIExternalSampleClock * External
External Sample Clock Configuration.

Detailed Description

Sample clock configuration class.

Member Data Documentation

◆ External

AIExternalSampleClock* JY5113CoreOO::AISampleClock::External

External Sample Clock Configuration.

Valid when Source is AISampleClockSource.External.

◆ Source

AISampleClockSource JY5113CoreOO::AISampleClock::Source

AI Sample Clock Source.

enum Internal/External. The default value is AISampleClockSource.Internal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOAITask.h


5113 C++ Programming Manual: JY5113CoreOO::AITrigger Class Reference

  • AITrigger
Public Attributes | List of all members
JY5113CoreOO::AITrigger Class Reference

Constructor to create an AITrigger task object. More...

#include <JY5113CoreOOAITask.h>

Public Attributes

AITriggerType Type
AI trigger type.
AITriggerMode Mode
AI trigger mode.
AIDigitalTrigger * Digital
Digital Trigger Congfiguration.
AIAnalogTrigger * Analog
AI Analog Trigger.
int | ReTriggerCount
Number of repeat triggers.
unsigned int | PreTriggerSamples
AI pretrigger samples, must be less than or equal to JY5113AITask.SamplesToAcquire.

Detailed Description

Constructor to create an AITrigger task object.

Used to build AI Trigger

Member Data Documentation

◆ Analog

AIAnalogTrigger* JY5113CoreOO::AITrigger::Analog

AI Analog Trigger.

Valid when Type is AITriggerType.Analog.

◆ Digital

AIDigitalTrigger* JY5113CoreOO::AITrigger::Digital

Digital Trigger Congfiguration.

Valid when Type is AITriggerType.Digital.

◆ Mode

AITriggerMode JY5113CoreOO::AITrigger::Mode

AI trigger mode.

enum Start/Reference. The default value is AITriggerMode.Start.

◆ PreTriggerSamples

unsigned int JY5113CoreOO::AITrigger::PreTriggerSamples

AI pretrigger samples, must be less than or equal to JY5113AITask.SamplesToAcquire.

Valid when Mode is AITriggerMode.Reference. Pretrigger samples, must be greater than 0. Valid when Type is AITriggerType.Analog. Pretrigger samples, must be greater than 1. Valid when Type is AITriggerType.Digital.

◆ ReTriggerCount

int JY5113CoreOO::AITrigger::ReTriggerCount

Number of repeat triggers.

When 0 or 1 only trigger once, When -1 continuous retrigger until stop.

◆ Type

AITriggerType JY5113CoreOO::AITrigger::Type

AI trigger type.

enum Analog/Digital/Immediate/Soft. The default value is AITriggerType.Immediate.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOAITask.h


5113 C++ Programming Manual: JY5113CoreOO::AIDigitalTrigger Class Reference

  • AIDigitalTrigger
Public Attributes | List of all members
JY5113CoreOO::AIDigitalTrigger Class Reference

AI Digital trigger class. More...

#include <JY5113CoreOOAITask.h>

Public Attributes

AIDigitalTriggerSource Source
AI Digital Trigger source.
AIDigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Detailed Description

AI Digital trigger class.

Member Data Documentation

◆ Edge

AIDigitalTriggerEdge JY5113CoreOO::AIDigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

AIDigitalTriggerSource JY5113CoreOO::AIDigitalTrigger::Source

AI Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOAITask.h


5113 C++ Programming Manual: JY5113CoreOO::AIAnalogHysteresisComparator Class Reference

  • AIAnalogHysteresisComparator
Public Attributes | List of all members
JY5113CoreOO::AIAnalogHysteresisComparator Class Reference

AI Analog Hysteresis Comparatorr. More...

#include <JY5113CoreOOAITask.h>

Public Attributes

AIAnalogTriggerEdge Slope
AI Analog Trigger Edge.
double | HighThreshold
High Threshold.
double | LowThreshold
Low Threshold.

Detailed Description

AI Analog Hysteresis Comparatorr.

Member Data Documentation

◆ HighThreshold

double JY5113CoreOO::AIAnalogHysteresisComparator::HighThreshold

High Threshold.

◆ LowThreshold

double JY5113CoreOO::AIAnalogHysteresisComparator::LowThreshold

Low Threshold.

◆ Slope

AIAnalogTriggerEdge JY5113CoreOO::AIAnalogHysteresisComparator::Slope

AI Analog Trigger Edge.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOAITask.h


5113 C++ Programming Manual: JY5113CoreOO::AIAnalogWindowComparator Class Reference

  • AIAnalogWindowComparator
Public Attributes | List of all members
JY5113CoreOO::AIAnalogWindowComparator Class Reference

AI Analog Window Comparatorr. More...

#include <JY5113CoreOOAITask.h>

Public Attributes

AIAnalogWindowCondition Condition
AI Analog Window Condition.
double | HighThreshold
High Threshold.
double | LowThreshold
Low Threshold.

Detailed Description

AI Analog Window Comparatorr.

Member Data Documentation

◆ Condition

AIAnalogWindowCondition JY5113CoreOO::AIAnalogWindowComparator::Condition

AI Analog Window Condition.

◆ HighThreshold

double JY5113CoreOO::AIAnalogWindowComparator::HighThreshold

High Threshold.

◆ LowThreshold

double JY5113CoreOO::AIAnalogWindowComparator::LowThreshold

Low Threshold.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOAITask.h


5113 C++ Programming Manual: JY5113CoreOO::AIAnalogEdgeComparator Class Reference

  • AIAnalogEdgeComparator
Public Attributes | List of all members
JY5113CoreOO::AIAnalogEdgeComparator Class Reference

AI Analog Edge Comparator. More...

#include <JY5113CoreOOAITask.h>

Public Attributes

AIAnalogTriggerEdge Slope
AI Analog Trigger Edge.
double Threshold
Threshold.

Detailed Description

AI Analog Edge Comparator.

Member Data Documentation

◆ Slope

AIAnalogTriggerEdge JY5113CoreOO::AIAnalogEdgeComparator::Slope

AI Analog Trigger Edge.

◆ Threshold

double JY5113CoreOO::AIAnalogEdgeComparator::Threshold

Threshold.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOAITask.h


5113 C++ Programming Manual: JY5113CoreOO::AIAnalogTrigger Class Reference

  • AIAnalogTrigger
Public Attributes | List of all members
JY5113CoreOO::AIAnalogTrigger Class Reference

AI analog trigger . More...

#include <JY5113CoreOOAITask.h>

Public Attributes

AIAnalogTriggerSource Source
Analog Trigger source.
AIAnalogTriggerComparator Comparator
AI Analog Trigger Comparator.
AIAnalogEdgeComparator * Edge
AI Analog Edge Comparator.
AIAnalogHysteresisComparator * Hysteresis
AI Analog Hysteresis Comparatorr.
AIAnalogWindowComparator * Window
AI Analog Window Comparatorr.

Detailed Description

AI analog trigger .

Member Data Documentation

◆ Comparator

AIAnalogTriggerComparator JY5113CoreOO::AIAnalogTrigger::Comparator

AI Analog Trigger Comparator.

◆ Edge

AIAnalogEdgeComparator* JY5113CoreOO::AIAnalogTrigger::Edge

AI Analog Edge Comparator.

◆ Hysteresis

AIAnalogHysteresisComparator* JY5113CoreOO::AIAnalogTrigger::Hysteresis

AI Analog Hysteresis Comparatorr.

◆ Source

AIAnalogTriggerSource JY5113CoreOO::AIAnalogTrigger::Source

Analog Trigger source.

◆ Window

AIAnalogWindowComparator* JY5113CoreOO::AIAnalogTrigger::Window

AI Analog Window Comparatorr.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOAITask.h


5113 C++ Programming Manual: JY5113CoreOO::AIRecord Class Reference

  • AIRecord
Public Attributes | List of all members
JY5113CoreOO::AIRecord Class Reference

AI Record Parameters. More...

#include <JY5113CoreOOAITask.h>

Public Attributes

std::string | FilePath
User specified file path.
JY5113CoreOO::FileFormat File_Format
Streaming file format.
RecordMode Mode
stream mode .
double | Length
User specified stream length in second.

Detailed Description

AI Record Parameters.

Member Data Documentation

◆ File_Format

JY5113CoreOO::FileFormat JY5113CoreOO::AIRecord::File_Format

Streaming file format.

enum BIN.

◆ FilePath

std::string JY5113CoreOO::AIRecord::FilePath

User specified file path.

◆ Length

double JY5113CoreOO::AIRecord::Length

User specified stream length in second.

Only when Mode is RecordMode.Finite.

◆ Mode

RecordMode JY5113CoreOO::AIRecord::Mode

stream mode .

enum Finite/Infinite.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOAITask.h


5113 C++ Programming Manual: JY5113CoreOO::AIDSMode Class Reference

  • AIDSMode
Public Attributes | List of all members
JY5113CoreOO::AIDSMode Class Reference

#include <JY5113CoreOOAITask.h>

Public Attributes

bool Enable
Enable DSMode.

Member Data Documentation

◆ Enable

bool JY5113CoreOO::AIDSMode::Enable

Enable DSMode.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOAITask.h


5113 C++ Programming Manual: JY5113CoreOO::AIAdvanced Class Reference

  • AIAdvanced
Public Attributes | List of all members
JY5113CoreOO::AIAdvanced Class Reference

AI Advance parameter. More...

#include <JY5113CoreOOAITask.h>

Public Attributes

double ConvertRate
the convert rate of ADC.
AIDSMode * DSMode
DSMode Config.

Detailed Description

AI Advance parameter.

Member Data Documentation

◆ ConvertRate

double JY5113CoreOO::AIAdvanced::ConvertRate

the convert rate of ADC.

◆ DSMode

AIDSMode* JY5113CoreOO::AIAdvanced::DSMode

DSMode Config.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOAITask.h


5113 C++ Programming Manual: JY5113CoreOO::AISignalExport Class Reference

  • AISignalExport
Public Member Functions | List of all members
JY5113CoreOO::AISignalExport Class Reference

AI Signal Export Class. More...

#include <JY5113CoreOOAITask.h>

Public Member Functions

void | Add (AISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (AISignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

AI Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY5113CoreOO::AISignalExport::Add | ( | AISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | AI Signal Source
destination | Export Desination

◆ Add() [2/2]

void JY5113CoreOO::AISignalExport::Add | ( | AISignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | AI Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JY5113CoreOO::AISignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5113CoreOO::AISignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOAITask.h


5113 C++ Programming Manual: JY5113CoreOO Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Enumerations | Functions
JY5113CoreOO Namespace Reference

Classes

class | AIAdvanced
AI Advance parameter. More...
class | AIAnalogEdgeComparator
AI Analog Edge Comparator. More...
class | AIAnalogHysteresisComparator
AI Analog Hysteresis Comparatorr. More...
class | AIAnalogTrigger
AI analog trigger . More...
class | AIAnalogWindowComparator
AI Analog Window Comparatorr. More...
class | AIChannel
class | AIDigitalTrigger
AI Digital trigger class. More...
class | AIDSMode
class | AIExternalSampleClock
Sample clock configuration class. More...
class | AIRecord
AI Record Parameters. More...
class | AISampleClock
Sample clock configuration class. More...
class | AISignalExport
AI Signal Export Class. More...
class | AITrigger
Constructor to create an AITrigger task object. More...
class | AOChannel
class | AODigitalTrigger
AO Digital trigger . More...
class | AOExternalSampleClock
External Sample Clock Configuration Class. More...
class | AOSampleClock
AO Sample clock configuration class. More...
class | AOSignalExport
AO Signal Export Class. More...
class | AOTrigger
Constructor to create an AOTrigger task object. More...
class | CIDigitalTrigger
CI Digital trigger . More...
class | CIExternalSampleClock
CI Implicit Sample Clock class. More...
class | CIExternalTimebase
class | CIImplicitSampleClock
CI Implicit Sample Clock class. More...
class | CIInternalSampleClock
CI Internal Sample Clock Configuration Class. More...
class | CISampleClock
CI Sample Clock class. More...
class | CISignalExport
CI Signal Export Class. More...
class | CITimebase
Timebase configuration class. More...
class | CITrigger
Constructor to create an CITrigger task object. More...
class | CODigitalTrigger
CO Digital trigger . More...
class | COExternalTimebase
class | COPulse
Pulse Parameter. More...
class | COSignalExport
CO Signal Export Class. More...
class | COTimebase
Timebase configuration class. More...
class | COTrigger
Constructor to create an COTrigger task object. More...
class | DIChannel
DI Channel parameter class . More...
class | DIDigitalTrigger
DI Digital trigger . More...
class | DIExternalSampleClock
External Sample Clock Configuration Class. More...
class | DISampleClock
Sample clock configuration class. More...
class | DISignalExport
DI Signal Export Class. More...
class | DITrigger
Constructor to create an DITrigger task object. More...
class | DOChannel
DO Channel parameter class . More...
class | DODigitalTrigger
DO Digital trigger. More...
class | DOExternalSampleClock
External Sample Clock Configuration Class. More...
class | DOSampleClock
Sample clock configuration class. More...
class | DOSignalExport
DO Signal Export Class. More...
class | DOTrigger
Constructor to create an DOTrigger task object. More...
class | EdgeCounting
Configure CI EdgeCounting. More...
class | EdgeCountingOutEvent
Edge counting output event configuration class. More...
class | ExternalReferenceClock
class | FrequencyMeas
Configure CI Measure. More...
class | JY5113CoreOOAITask
AITask类 More...
class | JY5113CoreOOAOTask
class | JY5113CoreOOCITask
class | JY5113CoreOOCOTask
class | JY5113CoreOODevice
class | JY5113CoreOODITask
class | JY5113CoreOODOTask
class | JY5113CoreOOLog
class | JY5113CoreOOProperty
属性模板类 More...
class | JY5113CoreOOReferenceClock
class | JYDriverException
class | PauseTrigger
Pause trigger configuration class. More...
class | PeriodMeas
Configure CI Measure. More...
class | PFIFilter
class | PFISetting
class | PulseMeas
Configure CI Measure. More...
class | QuadEncoder
Configure CI Measure. More...
class | SemiPeriodMeas
Configure CI Measure. More...
class | TwoEdgeSeparation
Configure CI Measure. More...
class | TwoPulseEncoder
Configure CI Measure. More...

Enumerations

enum class | AITerminal { RSE = 0x0 , NRSE = 0x1 , Differential = 0x2 }
enum class | AIMode { Single = 0x2 , Finite = 0x0 , Continuous = 0x1 , Record = 0x3 }
enum class | AIBandWidth { _39KHz , _15KHz , _80KHz }
AI BandWidth. More...
enum class | AISampleClockSource { Internal , External }
AI Sample Clock Source. More...
enum class | AITriggerType { Immediate = 0x0 , Digital = 0x1 , Analog = 0x2 , Soft = 0x3 }
Trigger Type Digital/Analog/Immediate/Soft. More...
enum class | AITriggerMode { Start , Reference }
AI Trigger Mode. More...
enum class AIAnalogTriggerSource {
Channel_0 , Channel_1 , Channel_2 , Channel_3 ,
Channel_4 , Channel_5 , Channel_6 , Channel_7 ,
Channel_8 , Channel_9 , Channel_10 , Channel_11 ,
Channel_12 , Channel_13 , Channel_14 , Channel_15 ,
Channel_16 , Channel_17 , Channel_18 , Channel_19 ,
Channel_20 , Channel_21 , Channel_22 , Channel_23 ,
Channel_24 , Channel_25 , Channel_26 , Channel_27 ,
Channel_28 , Channel_29 , Channel_30 , Channel_31 ,
Channel_32 , Channel_33 , Channel_34 , Channel_35 ,
Channel_36 , Channel_37 , Channel_38 , Channel_39 ,
Channel_40 , Channel_41 , Channel_42 , Channel_43 ,
Channel_44 , Channel_45 , Channel_46 , Channel_47 ,
Channel_48 , Channel_49 , Channel_50 , Channel_51 ,
Channel_52 , Channel_53 , Channel_54 , Channel_55 ,
Channel_56 , Channel_57 , Channel_58 , Channel_59 ,
Channel_60 , Channel_61 , Channel_62 , Channel_63
}
AI analog trigger source. More...
enum class AIDigitalTriggerSource {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PFI8 , PFI9 , PFI10 , PFI11 ,
PFI12 , PFI13 , PFI14 , PFI15 ,
PXI_Trig0 , PXI_Trig1 , PXI_Trig2 , PXI_Trig3 ,
PXI_Trig4 , PXI_Trig5 , PXI_Trig6 , PXI_Trig7 = 23 ,
DI_StartTrig = 26 , DI_ReferenceTrig , AO_StartTrig , DO_StartTrig ,
CIO_0_StartTrig , CIO_1_StartTrig , CIO_2_StartTrig , CIO_3_StartTrig ,
CO0_Output , CO1_Output , CO2_Output , CO3_Output
}
AI Digital trigger source. More...
enum class | AIDigitalTriggerEdge { Rising = 0x0 , Falling = 0x1 }
AI Digital Trigger Edge. More...
enum class | AIAnalogTriggerEdge { Rising , Falling }
AI Analog Trigger Edge. More...
enum class | AIAnalogWindowCondition { Entering , Leaving }
AI Analog Window Trigger Condition. More...
enum class | AIAnalogTriggerComparator { Edge , Hysteresis , Window }
AI Analog Trigger Comparator. More...
enum class | AISignalExportSource { StartTrig = 24 , ReferenceTrig = 25 , SampleClock = 34 }
AI Signal Export Source. More...
enum class | FileFormat { Bin }
Streaming file format. More...
enum class | RecordMode { Finite , Infinite }
stream mode .enum Finite/Infinite More...
enum class | PowerLineFrequency { _50Hz , _60Hz }
enum class SyncTriggerRouting {
NONE = -1 , PXI_Trig0 = 16 , PXI_Trig1 , PXI_Trig2 ,
PXI_Trig3 , PXI_Trig4 , PXI_Trig5 , PXI_Trig6 ,
PXI_Trig7
}
Master card trigger signal routing (Master card routes trigger signal to this port) 主控卡触发信号路由(主控卡将触发信号路由到此端口) More...
enum class SyncPulseRouting {
NONE = -1 , PXI_Trig0 = 16 , PXI_Trig1 , PXI_Trig2 ,
PXI_Trig3 , PXI_Trig4 , PXI_Trig5 , PXI_Trig6 ,
PXI_Trig7
}
Synchronous signal routing (the master card routes the synchronous signal to this port, and the slave card receives the synchronous signal from this port) 同步信号路由(主卡将同步信号路由到该端口，从卡从该端口接收同步信号) More...
enum class | AOMode { Single = 3 , Finite = 0 , ContinuousNoWrapping = 2 , ContinuousWrapping = 1 }
enum class | AODigitalTriggerEdge { Rising , Falling }
AO Digital Trigger Edge. More...
enum class AODigitalTriggerSource {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PFI8 , PFI9 , PFI10 , PFI11 ,
PFI12 , PFI13 , PFI14 , PFI15 ,
PXI_Trig0 = 40 , PXI_Trig1 = 41 , PXI_Trig2 = 42 , PXI_Trig3 = 43 ,
PXI_Trig4 = 44 , PXI_Trig5 = 45 , PXI_Trig6 = 46 , PXI_Trig7 = 47 ,
AI_StartTrig = 16 , AI_ReferenceTrig = 17 , DI_StartTrig = 22 , DI_ReferenceTrig = 23 ,
DO_StartTrig = 29 , CI_0_StartTrig = 68 , CI_1_StartTrig = 73 , CI_2_StartTrig = 76 ,
CI_3_StartTrig = 79 , CO_0_StartTrig = 69 , CO_1_StartTrig = 74 , CO_2_StartTrig = 77 ,
CO_3_StartTrig = 80 , CO_0_Output = 37 , CO_1_Output = 51 , CO_2_Output = 60 ,
CO_3_Output = 66
}
AO Digital trigger source. More...
enum class | AOSampleClockSource { Internal , External }
AO Sample Clock Source. More...
enum class | AOSignalExportSource { StartTrig = 28 , SampleClock = 35 }
SourceSignal. More...
enum class | AOTriggerType { Immediate = 0x0 , Digital = 0x1 , Soft = 0x3 }
TriggerType Digital/Immediate/Soft. More...
enum class | CountDirection { Up = 0x0 , Down = 0x1 , External = 0x2 }
Counter direction. More...
enum class | CIMode { Single = 2 , Finite = 0 , Continuous = 1 }
CIMode. More...
enum class CIType {
EdgeCounting , Period , Frequency , Pulse ,
SemiPeriod , TwoEdgeSeparation , QuadEncoder , TwoPulseEncoder
}
Counter Input Application Type. More...
enum class | CISampleClockSource { Implicit = 0x0 , Internal = 0x1 , External = 0x2 }
CI Sample Clock Source. More...
enum class | EdgeType { Rising , Falling , Any }
Edge Type. More...
enum class | ValueReturnMode { TwoValue , OneValue }
TwoEdgeSeparation value return mode.only for TwoEdgeSeparation type. More...
enum class | QuadEncodingType { X1 , X2 , X4 }
Quadrature Encoding Type. More...
enum class | CITriggerType { Immediate = 0x0 , Digital = 0x1 , Soft = 0x3 }
TriggerType Digital/Immediate/Soft. More...
enum class CIDigitalTriggerSource {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PFI8 , PFI9 , PFI10 , PFI11 ,
PFI12 , PFI13 , PFI14 , PFI15 ,
PXI_Trig0 , PXI_Trig1 , PXI_Trig2 , PXI_Trig3 ,
PXI_Trig4 , PXI_Trig5 , PXI_Trig6 , PXI_Trig7 ,
AI_StartTrig , AI_ReferenceTrig , DI_StartTrig , DI_ReferenceTrig ,
AO_StartTrig , DO_StartTrig , CIO_0_StartTrig , CIO_1_StartTrig
}
CI Digital trigger source. More...
enum class | CIDigitalTriggerEdge { Rising , Falling }
CI Digital Trigger Edge. More...
enum class | EdgeCntOunEvtIdleState { LowLevel = 0 , HighLevel = 1 }
Output idle state when the event has not occurred. More...
enum class | CISignalExportSource { StartTrig , SampleClock }
SourceSignal. More...
enum class | CITimebaseSource { Internal100MHz = 0 , Internal5MHz = 1 , Internal100kHz = 2 , External = 3 }
Timebase source. More...
enum class | JY5113CoreOOPropertyType { READ_ONLY = 1 , WRITE_ONLY = 2 , READ_WRITE = 3 }
enum class JYDriverExceptionPublic {
UnKnown = 0 , OpenDeviceFailed = -10001 , CloseDeviceFailed = -10002 , ResetDeviceFailed = -10003 ,
GetDevicePropertyFailed = -10004 , SetDevicePropertyFailed = -10005 , HardwareResourceIsReserved = -10006 , MethodNotPermitedToCallWhenCurrentStatus = -10007 ,
InvalidUserDataBuffer = -10008 , NoChannelAdded = -10009 , NotSupportOperationForCurrentDevice = -10010 , CreatTaskFailed = -10100 ,
StartTaskFailed = -10101 , StopTaskFailed = -10102 , TaskHasNotStarted = -10103 , TaskHasStartedCannotPerformTheSetOperation = -10104 ,
ChannelNumberParameterInvalid = -10105 , ChannelInputRangeParameterInvalid = -10106 , ChannelTerminalParameterInvalid = -10107 , ChannelCouplingParameterInvalid = -10108 ,
SampeleModeParameterInvalid = -10109 , SampleClockParameterInvalid = -10110 , SampleRateParameterInvalid = -10111 , UpdateRateParameterInvalid = -10112 ,
TriggerParameterInvalid = -10113 , ReferenceTriggerDoesNotMatchWithSampleMode = -10114 , PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint = -10115 , ReadDataFailed = -10016 ,
ReadDataTimeout = -10017 , WriteDataFailed = -10018 , WriteDataTimeout = -10019 , WriteDataLengthCannotBeLessThanN = -10020 ,
BufferDataOverflow = -10021 , BufferDataDownflow = -10022 , CheckBufferFailed = -10023 , PointInvalidInFiniteMode = -10024 ,
ReadPointInvalid = -10025 , OnlySupportRecordMode = -10026 , SendSoftTirggerFailed = -10027 , TaskTimeout = -10028 ,
CounterParametersInvalid = -10029 , WritePointInvalid = -10030 , SignalExportDestinationInvalid = -10031 , InvalidParameter = -10033
}
enum class ClockTerminal {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PFI8 , PFI9 , PFI10 , PFI11 ,
PFI12 , PFI13 , PFI14 , PFI15 ,
PXI_Trig0 , PXI_Trig1 , PXI_Trig2 , PXI_Trig3 ,
PXI_Trig4 , PXI_Trig5 , PXI_Trig6 , PXI_Trig7 ,
AI_SampleClock , AO_SampleClock , DI_SampleClock , DO_SampleClock ,
CI0_SampleClock , CI1_SampleClock , CI2_SampleClock , CI3_SampleClock ,
CO0_Output , CO1_Output , CO2_Output , CO3_Output
}
enum class SignalExportDestination {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PFI8 , PFI9 , PFI10 , PFI11 ,
PFI12 , PFI13 , PFI14 , PFI15 ,
PXI_Trig0 , PXI_Trig1 , PXI_Trig2 , PXI_Trig3 = 29 ,
PXI_Trig4 = 20 , PXI_Trig5 , PXI_Trig6 , PXI_Trig7
}
enum class | OutputCompleteState { Zero , Hold }
Output Complete State. More...
enum class IOTerminal {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PFI8 , PFI9 , PFI10 , PFI11 ,
PFI12 , PFI13 , PFI14 , PFI15 ,
PXI_Trig0 , PXI_Trig1 , PXI_Trig2 , PXI_Trig3 ,
PXI_Trig4 , PXI_Trig5 , PXI_Trig6 , PXI_Trig7 ,
None
}
Cunter IO Terminal. More...
enum class | LevelPolarity { LowLevel = 0 , HighLevel = 1 , None = 2 }
Level Polarity. More...
enum class | COIdleState { HighLevel = 0x1 , LowLevel = 0x0 }
Idle state when pulse output before start and after stop. More...
enum class | COMode { Single = 3 , Finite = 0 , ContinuousNoWrapping = 2 , ContinuousWrapping = 1 }
enum class | COTriggerType { Immediate = 0x0 , Digital = 0x1 , Soft = 0x3 }
TriggerType Digital/Immediate/Soft. More...
enum class CODigitalTriggerSource {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PFI8 , PFI9 , PFI10 , PFI11 ,
PFI12 , PFI13 , PFI14 , PFI15 ,
PXI_Trig0 , PXI_Trig1 , PXI_Trig2 , PXI_Trig3 ,
PXI_Trig4 , PXI_Trig5 , PXI_Trig6 , PXI_Trig7 ,
AI_StartTrig , AI_ReferenceTrig , DI_StartTrig , DI_ReferenceTrig ,
AO_StartTrig , DO_StartTrig , CIO_0_StartTrig , CIO_1_StartTrig = 31 ,
CO_0_Out = 34 , CO_1_Out = 35
}
CO Digital trigger source. More...
enum class | CODigitalTriggerEdge { Rising , Falling }
CO Digital Trigger Edge. More...
enum class | COPulseType { DutyCycleFrequency , HighLowTime , HighLowTick }
Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick. More...
enum class | COTimebaseSource { Internal100MHz = 0 , Internal5MHz = 1 , Internal100kHz = 2 , External = 3 }
Timebase source. More...
enum class | COSignalExportSource { StartTrig , Output }
SourceSignal. More...
enum class | ExternalReferenceClockTerminal { PXIe_Clk100 = 0x1 }
enum class | ReferenceClockSource { Internal = 0x0 , External = 0x1 }
enum class PFITerminal {
PFI0 = 0 , PFI1 = 1 , PFI2 = 2 , PFI3 = 3 ,
PFI4 = 4 , PFI5 = 5 , PFI6 = 6 , PFI7 = 7 ,
PFI8 = 8 , PFI9 = 9 , PFI10 = 10 , PFI11 = 11 ,
PFI12 = 12 , PFI13 = 13 , PFI14 = 14 , PFI15 = 15
}
Input/Output Terminal of PFI. More...
enum class InputTerminal {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PFI8 , PFI9 , PFI10 , PFI11 ,
PFI12 , PFI13 , PFI14 , PFI15 ,
PXI_Trig0 , PXI_Trig1 , PXI_Trig2 , PXI_Trig3 ,
PXI_Trig4 , PXI_Trig5 , PXI_Trig6 , PXI_Trig7 ,
AI_SampleClock , AO_SampleClock , DI_SampleClock , DO_SampleClock ,
CO_0_OutPut , CO_1_OutPut , CO_2_OutPut , CO_3_OutPut ,
Timebase_100MHz , Timebase_5MHz , Timebase_100kHz
}
Cunter Input Terminal. More...
enum class | DISampleClockSource { Internal , External }
DI Sample Clock Source. More...
enum class | DIMode { Single = 2 , Finite = 0 , Continuous = 1 }
DIMode. More...
enum class | DISignalExportSource { StartTrig = 26 , ReferenceTrig = 27 , SampleClock = 36 }
SourceSignal. More...
enum class | DITriggerMode { Start , Reference }
DI Trigger Mode. More...
enum class | DITriggerType { Immediate = 0 , Digital = 1 , Soft = 3 }
TriggerType Digital/Immediate/Soft. More...
enum class DIDigitalTriggerSource {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PFI8 , PFI9 , PFI10 , PFI11 ,
PFI12 , PFI13 , PFI14 , PFI15 ,
PXI_Trig0 , PXI_Trig1 , PXI_Trig2 , PXI_Trig3 ,
PXI_Trig4 , PXI_Trig5 , PXI_Trig6 , PXI_Trig7 ,
AI_StartTrig , AI_ReferenceTrig , DI_StartTrig , DI_ReferenceTrig ,
AO_StartTrig , DO_StartTrig , CIO_0_StartTrig , CIO_1_StartTrig ,
CO_0_Out = 34 , CO_1_Out = 35
}
DI Digital trigger source. More...
enum class | DIDigitalTriggerEdge { Rising , Falling }
DI Digital Trigger Edge. More...
enum class | DOSampleClockSource { Internal , External }
DO Sample Clock Source. More...
enum class | DOMode { Single = 3 , Finite = 0 , ContinuousWrapping = 1 , ContinuousNoWrapping = 2 }
DOMode. More...
enum class | DODigitalTriggerEdge { Rising , Falling }
DO Digital Trigger Edge. More...
enum class DODigitalTriggerSource {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PFI8 , PFI9 , PFI10 , PFI11 ,
PFI12 , PFI13 , PFI14 , PFI15 ,
PXI_Trig0 , PXI_Trig1 , PXI_Trig2 , PXI_Trig3 ,
PXI_Trig4 , PXI_Trig5 , PXI_Trig6 , PXI_Trig7 ,
AI_StartTrig , AI_ReferenceTrig , DI_StartTrig , DI_ReferenceTrig ,
AO_StartTrig , DO_StartTrig , CIO_0_StartTrig , CIO_1_StartTrig ,
CO_0_Out = 34 , CO_1_Out = 35
}
DO Digital trigger source. More...
enum class | DOTriggerType { Immediate = 0 , Digital = 1 , Soft = 3 }
TriggerType Digital/Immediate/Soft. More...
enum class | DOSignalExportSource { StartTrig = 29 , SampleClock = 37 }
SourceSignal. More...
enum class JY5113CoreOOLogLevel {
DEBUG_LOG_LEVEL , INFO_LOG_LEVEL , WARN_LOG_LEVEL , ERROR_LOG_LEVEL ,
FATAL_LOG_LEVEL
}

Functions

std::string GetSignalExportDestinationString (SignalExportDestination destination)

Enumeration Type Documentation

◆ AIAnalogTriggerComparator

enum class JY5113CoreOO::AIAnalogTriggerComparator
strong

AI Analog Trigger Comparator.

Enumerator
Edge | Edge Comparator.
Hysteresis | Hysteresis Comparator.
Window | Window Comparator.

◆ AIAnalogTriggerEdge

enum class JY5113CoreOO::AIAnalogTriggerEdge
strong

AI Analog Trigger Edge.

Enumerator
Rising | Rising.
Falling | Falling.

◆ AIAnalogTriggerSource

enum class JY5113CoreOO::AIAnalogTriggerSource
strong

AI analog trigger source.

Enumerator
Channel_0 | channel 0
Channel_1 | channel 1
Channel_2 | channel 2
Channel_3 | channel 3
Channel_4 | channel 4
Channel_5 | channel 5
Channel_6 | channel 6
Channel_7 | channel 7
Channel_8 | channel 8
Channel_9 | channel 9
Channel_10 | channel 10
Channel_11 | channel 11
Channel_12 | channel 12
Channel_13 | channel 13
Channel_14 | channel 14
Channel_15 | channel 15
Channel_16 | channel 16
Channel_17 | channel 17
Channel_18 | channel 18
Channel_19 | channel 19
Channel_20 | channel 20
Channel_21 | channel 21
Channel_22 | channel 22
Channel_23 | channel 23
Channel_24 | channel 24
Channel_25 | channel 25
Channel_26 | channel 26
Channel_27 | channel 27
Channel_28 | channel 28
Channel_29 | channel 29
Channel_30 | channel 30
Channel_31 | channel 31
Channel_32 | channel 32
Channel_33 | channel 33
Channel_34 | channel 34
Channel_35 | channel 35
Channel_36 | channel 36
Channel_37 | channel 37
Channel_38 | channel 38
Channel_39 | channel 39
Channel_40 | channel 40
Channel_41 | channel 41
Channel_42 | channel 42
Channel_43 | channel 43
Channel_44 | channel 44
Channel_45 | channel 45
Channel_46 | channel 46
Channel_47 | channel 47
Channel_48 | channel 48
Channel_49 | channel 49
Channel_50 | channel 50
Channel_51 | channel 51
Channel_52 | channel 52
Channel_53 | channel 53
Channel_54 | channel 54
Channel_55 | channel 55
Channel_56 | channel 56
Channel_57 | channel 57
Channel_58 | channel 58
Channel_59 | channel 59
Channel_60 | channel 60
Channel_61 | channel 61
Channel_62 | channel 62
Channel_63 | channel 63

◆ AIAnalogWindowCondition

enum class JY5113CoreOO::AIAnalogWindowCondition
strong

AI Analog Window Trigger Condition.

Enumerator
Entering | Rising.
Leaving | Falling.

◆ AIBandWidth

enum class JY5113CoreOO::AIBandWidth
strong

AI BandWidth.

Enumerator
_39KHz | 39KHz BandWidth
_15KHz | 15KHz BandWidth
_80KHz | 80KHz BandWidth

◆ AIDigitalTriggerEdge

enum class JY5113CoreOO::AIDigitalTriggerEdge
strong

AI Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ AIDigitalTriggerSource

enum class JY5113CoreOO::AIDigitalTriggerSource
strong

AI Digital trigger source.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PFI8 | PFI_8.
PFI9 | PFI_9.
PFI10 | PFI_10.
PFI11 | PFI_11.
PFI12 | PFI_12.
PFI13 | PFI_13.
PFI14 | PFI_14.
PFI15 | PFI_15.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
DI_StartTrig | DI_StartTrig.
DI_ReferenceTrig | DI_ReferenceTrig.
AO_StartTrig | AO_StartTrig.
DO_StartTrig | AO_StartTrig.
CIO_0_StartTrig | CI0_StartTrig.
CIO_1_StartTrig | CI1_StartTrig.
CIO_2_StartTrig | CI2_StartTrig.
CIO_3_StartTrig | CI3_StartTrig.
CO0_Output | CO0_Output.
CO1_Output | CO1_Output.
CO2_Output | CO2_Output.
CO3_Output | CO3_Output.

◆ AIMode

enum class JY5113CoreOO::AIMode
strong
Enumerator
Single
Finite
Continuous
Record

◆ AISampleClockSource

enum class JY5113CoreOO::AISampleClockSource
strong

AI Sample Clock Source.

Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ AISignalExportSource

enum class JY5113CoreOO::AISignalExportSource
strong

AI Signal Export Source.

Enumerator
StartTrig | AI_StartTrig.
ReferenceTrig | AI_ReferenceTrig.
SampleClock | AI_SampleClock.

◆ AITerminal

enum class JY5113CoreOO::AITerminal
strong
Enumerator
RSE
NRSE
Differential

◆ AITriggerMode

enum class JY5113CoreOO::AITriggerMode
strong

AI Trigger Mode.

Enumerator
Start | Start Trigger.
Reference | Reference Trigger，Valid when JY5113AITask.Mode is AIMode.Finite

◆ AITriggerType

enum class JY5113CoreOO::AITriggerType
strong

Trigger Type Digital/Analog/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Analog | Analog Trigger.
Soft | Soft Trigger.

◆ AODigitalTriggerEdge

enum class JY5113CoreOO::AODigitalTriggerEdge
strong

AO Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ AODigitalTriggerSource

enum class JY5113CoreOO::AODigitalTriggerSource
strong

AO Digital trigger source.

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11.
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
DI_StartTrig | DI_StartTrig.
DI_ReferenceTrig | DI_ReferenceTrig.
DO_StartTrig | DO_StartTrig.
CI_0_StartTrig | CI0_StartTrig.
CI_1_StartTrig | CI1_StartTrig.
CI_2_StartTrig | CI2_StartTrig.
CI_3_StartTrig | CI3_StartTrig.
CO_0_StartTrig | CO0_StartTrig.
CO_1_StartTrig | CO0_StartTrig.
CO_2_StartTrig | CO0_StartTrig.
CO_3_StartTrig | CO0_StartTrig.
CO_0_Output | CO_0_Output.
CO_1_Output | CO_1_Output.
CO_2_Output | CO_2_Output.
CO_3_Output | CO_3_Output.

◆ AOMode

enum class JY5113CoreOO::AOMode
strong
Enumerator
Single | Single.
Finite | Finite.
ContinuousNoWrapping | ContinuousNoWrapping.
ContinuousWrapping | ContinuousWrapping.

◆ AOSampleClockSource

enum class JY5113CoreOO::AOSampleClockSource
strong

AO Sample Clock Source.

Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ AOSignalExportSource

enum class JY5113CoreOO::AOSignalExportSource
strong

SourceSignal.

Enumerator
StartTrig | AO_StartTrig.
SampleClock | AO_SampleClock.

◆ AOTriggerType

enum class JY5113CoreOO::AOTriggerType
strong

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ CIDigitalTriggerEdge

enum class JY5113CoreOO::CIDigitalTriggerEdge
strong

CI Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ CIDigitalTriggerSource

enum class JY5113CoreOO::CIDigitalTriggerSource
strong

CI Digital trigger source.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PFI8 | PFI_8.
PFI9 | PFI_9.
PFI10 | PFI_10.
PFI11 | PFI_11.
PFI12 | PFI_12.
PFI13 | PFI_13.
PFI14 | PFI_14.
PFI15 | PFI_15.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
DI_StartTrig | DI_StartTrig.
DI_ReferenceTrig | DI_ReferenceTrig.
AO_StartTrig | AO_StartTrig.
DO_StartTrig | AO_StartTrig.
CIO_0_StartTrig | CI0_StartTrig.
CIO_1_StartTrig | CI1_StartTrig.

◆ CIMode

enum class JY5113CoreOO::CIMode
strong

CIMode.

Enumerator
Single | Single.
Finite | Finite.
Continuous | Continuous.

◆ CISampleClockSource

enum class JY5113CoreOO::CISampleClockSource
strong

CI Sample Clock Source.

Enumerator
Implicit | Implicit.
Internal | Internal.
External | External.

◆ CISignalExportSource

enum class JY5113CoreOO::CISignalExportSource
strong

SourceSignal.

Enumerator
StartTrig | CI_StartTrig.
SampleClock | CI_SampleClock.

◆ CITimebaseSource

enum class JY5113CoreOO::CITimebaseSource
strong

Timebase source.

Enumerator
Internal100MHz | 内部100MHz时基 Internal 100MHz Timebase
Internal5MHz | 内部5MHz时基 Internal 5MHz Timebase
Internal100kHz | 内部100kHz时基 Internal 100kHz Timebase
External | 外部时基 External Timebase

◆ CITriggerType

enum class JY5113CoreOO::CITriggerType
strong

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ CIType

enum class JY5113CoreOO::CIType
strong

Counter Input Application Type.

Enumerator
EdgeCounting | Edge Counting.
Period | Period Measure.
Frequency | Frequenc Measure.
Pulse | Pulse Measure.
SemiPeriod | SemiPeriod Measure.
TwoEdgeSeparation | TwoEdgeSeparation Measure.
QuadEncoder | QuadEncoder.
TwoPulseEncoder | EncoderTwoPulse.

◆ ClockTerminal

enum class JY5113CoreOO::ClockTerminal
strong
Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PFI8 | PFI_8.
PFI9 | PFI_9.
PFI10 | PFI_10.
PFI11 | PFI_11.
PFI12 | PFI_12.
PFI13 | PFI_13.
PFI14 | PFI_14.
PFI15 | PFI_15.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
AI_SampleClock | AI SampleClock.
AO_SampleClock | AO SampleClock.
DI_SampleClock | DI SampleClock.
DO_SampleClock | DO SampleClock.
CI0_SampleClock | CI0_SampleClock.
CI1_SampleClock | CI1_SampleClock.
CI2_SampleClock | CI2_SampleClock.
CI3_SampleClock | CI3_SampleClock.
CO0_Output | CO0_Output.
CO1_Output | CO1_Output.
CO2_Output | CO2_Output.
CO3_Output | CO3_Output.

◆ CODigitalTriggerEdge

enum class JY5113CoreOO::CODigitalTriggerEdge
strong

CO Digital Trigger Edge.

Enumerator
Rising | Rising Edge.
Falling | Falling Edge.

◆ CODigitalTriggerSource

enum class JY5113CoreOO::CODigitalTriggerSource
strong

CO Digital trigger source.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PFI8 | PFI_8.
PFI9 | PFI_9.
PFI10 | PFI_10.
PFI11 | PFI_11.
PFI12 | PFI_12.
PFI13 | PFI_13.
PFI14 | PFI_14.
PFI15 | PFI_15.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
DI_StartTrig | DI_StartTrig.
DI_ReferenceTrig | DI_ReferenceTrig.
AO_StartTrig | AO_StartTrig.
DO_StartTrig | AO_StartTrig.
CIO_0_StartTrig | CI0_StartTrig.
CIO_1_StartTrig | CI1_StartTrig.
CO_0_Out | CI0_StartTrig.
CO_1_Out | CI1_StartTrig.

◆ COIdleState

enum class JY5113CoreOO::COIdleState
strong

Idle state when pulse output before start and after stop.

Enumerator
HighLevel | Idle state is high level.
LowLevel | Idle state is low level.

◆ COMode

enum class JY5113CoreOO::COMode
strong
Enumerator
Single | Single pulse output.
Finite | Finite.
ContinuousNoWrapping | ContinuousNoWrapping.
ContinuousWrapping | ContinuousWrapping.

◆ COPulseType

enum class JY5113CoreOO::COPulseType
strong

Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick.

Enumerator
DutyCycleFrequency | Configure CO output pulse according to its DutyCycle and Freqency.
HighLowTime | Configure CO output pulse according to duration of its high/low voltage levels.
HighLowTick | Configure CO output pulse according to its high/low tick level.

◆ COSignalExportSource

enum class JY5113CoreOO::COSignalExportSource
strong

SourceSignal.

Enumerator
StartTrig | CI_StartTrig.
Output | CO_Output.

◆ COTimebaseSource

enum class JY5113CoreOO::COTimebaseSource
strong

Timebase source.

Enumerator
Internal100MHz | 内部100MHz时基 Internal 100MHz Timebase
Internal5MHz | 内部5MHz时基 Internal 5MHz Timebase
Internal100kHz | 内部100kHz时基 Internal 100kHz Timebase
External | 外部时基 External Timebase

◆ COTriggerType

enum class JY5113CoreOO::COTriggerType
strong

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ CountDirection

enum class JY5113CoreOO::CountDirection
strong

Counter direction.

enum Up/Down/External

Enumerator
Up | Counter increases.
Down | Counter decreases.
External | External signal control counter direction. If External signal is highlevel counter increases, or lowlevel counter decreases.

◆ DIDigitalTriggerEdge

enum class JY5113CoreOO::DIDigitalTriggerEdge
strong

DI Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ DIDigitalTriggerSource

enum class JY5113CoreOO::DIDigitalTriggerSource
strong

DI Digital trigger source.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PFI8 | PFI_8.
PFI9 | PFI_9.
PFI10 | PFI_10.
PFI11 | PFI_11.
PFI12 | PFI_12.
PFI13 | PFI_13.
PFI14 | PFI_14.
PFI15 | PFI_15.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
DI_StartTrig | DI_StartTrig.
DI_ReferenceTrig | DI_ReferenceTrig.
AO_StartTrig | AO_StartTrig.
DO_StartTrig | AO_StartTrig.
CIO_0_StartTrig | CI0_StartTrig.
CIO_1_StartTrig | CI1_StartTrig.
CO_0_Out | CI0_StartTrig.
CO_1_Out | CI1_StartTrig.

◆ DIMode

enum class JY5113CoreOO::DIMode
strong

DIMode.

Enumerator
Single | Single.
Finite | Finite.
Continuous | Continuous.

◆ DISampleClockSource

enum class JY5113CoreOO::DISampleClockSource
strong

DI Sample Clock Source.

Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ DISignalExportSource

enum class JY5113CoreOO::DISignalExportSource
strong

SourceSignal.

Enumerator
StartTrig | DI_StartTrig.
ReferenceTrig | DI_ReferenceTrig.
SampleClock | DI_SampleClock.

◆ DITriggerMode

enum class JY5113CoreOO::DITriggerMode
strong

DI Trigger Mode.

Enumerator
Start | Start Trigger.
Reference | Reference Trigger，only for finite acquisition mode.

◆ DITriggerType

enum class JY5113CoreOO::DITriggerType
strong

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ DODigitalTriggerEdge

enum class JY5113CoreOO::DODigitalTriggerEdge
strong

DO Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ DODigitalTriggerSource

enum class JY5113CoreOO::DODigitalTriggerSource
strong

DO Digital trigger source.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PFI8 | PFI_8.
PFI9 | PFI_9.
PFI10 | PFI_10.
PFI11 | PFI_11.
PFI12 | PFI_12.
PFI13 | PFI_13.
PFI14 | PFI_14.
PFI15 | PFI_15.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
DI_StartTrig | DI_StartTrig.
DI_ReferenceTrig | DI_ReferenceTrig.
AO_StartTrig | AO_StartTrig.
DO_StartTrig | AO_StartTrig.
CIO_0_StartTrig | CI0_StartTrig.
CIO_1_StartTrig | CI1_StartTrig.
CO_0_Out | CI0_StartTrig.
CO_1_Out | CI1_StartTrig.

◆ DOMode

enum class JY5113CoreOO::DOMode
strong

DOMode.

Enumerator
Single | Single.
Finite | Finite.
ContinuousWrapping | ContinuousNoWrapping.
ContinuousNoWrapping | ContinuousWrapping.

◆ DOSampleClockSource

enum class JY5113CoreOO::DOSampleClockSource
strong

DO Sample Clock Source.

Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ DOSignalExportSource

enum class JY5113CoreOO::DOSignalExportSource
strong

SourceSignal.

Enumerator
StartTrig | DO_StartTrig.
SampleClock | DO_SampleClock.

◆ DOTriggerType

enum class JY5113CoreOO::DOTriggerType
strong

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ EdgeCntOunEvtIdleState

enum class JY5113CoreOO::EdgeCntOunEvtIdleState
strong

Output idle state when the event has not occurred.

Enumerator
LowLevel | Idle state is low level.
HighLevel | Idle state is high level.

◆ EdgeType

enum class JY5113CoreOO::EdgeType
strong

Edge Type.

Enumerator
Rising | Rising Edge.
Falling | Falling Edge.
Any | Any Edge.

◆ ExternalReferenceClockTerminal

enum class JY5113CoreOO::ExternalReferenceClockTerminal
strong
Enumerator
PXIe_Clk100

PXIe_Clk100.

◆ FileFormat

enum class JY5113CoreOO::FileFormat
strong

Streaming file format.

enum BIN.

Enumerator
Bin

BIN。

BIN.

◆ InputTerminal

enum class JY5113CoreOO::InputTerminal
strong

Cunter Input Terminal.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PFI8 | PFI_8.
PFI9 | PFI_9.
PFI10 | PFI_10.
PFI11 | PFI_11.
PFI12 | PFI_12.
PFI13 | PFI_13.
PFI14 | PFI_14.
PFI15 | PFI_15.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
AI_SampleClock | AI SampleClock.
AO_SampleClock | AO SampleClock.
DI_SampleClock | DI SampleClock.
DO_SampleClock | DO SampleClock.
CO_0_OutPut | CO_0_OutPut.
CO_1_OutPut | CO_1_OutPut.
CO_2_OutPut | CO_2_OutPut.
CO_3_OutPut | CO_3_OutPut.
Timebase_100MHz | Timebase_100MHz.
Timebase_5MHz | Timebase_5MHz.
Timebase_100kHz | Timebase_100kHz.

◆ IOTerminal

enum class JY5113CoreOO::IOTerminal
strong

Cunter IO Terminal.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PFI8 | PFI_8.
PFI9 | PFI_9.
PFI10 | PFI_10.
PFI11 | PFI_11.
PFI12 | PFI_12.
PFI13 | PFI_13.
PFI14 | PFI_14.
PFI15 | PFI_15.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
None | None.

◆ JY5113CoreOOLogLevel

enum class JY5113CoreOO::JY5113CoreOOLogLevel
strong
Enumerator
DEBUG_LOG_LEVEL
INFO_LOG_LEVEL
WARN_LOG_LEVEL
ERROR_LOG_LEVEL
FATAL_LOG_LEVEL

◆ JY5113CoreOOPropertyType

enum class JY5113CoreOO::JY5113CoreOOPropertyType
strong
Enumerator
READ_ONLY
WRITE_ONLY
READ_WRITE

◆ JYDriverExceptionPublic

enum class JY5113CoreOO::JYDriverExceptionPublic
strong
Enumerator
UnKnown | JYDriverExceptionPublic.
OpenDeviceFailed | JYDriverExceptionPublic.
CloseDeviceFailed | JYDriverExceptionPublic.
ResetDeviceFailed | JYDriverExceptionPublic.
GetDevicePropertyFailed | JYDriverExceptionPublic.
SetDevicePropertyFailed | JYDriverExceptionPublic.
HardwareResourceIsReserved | JYDriverExceptionPublic.
MethodNotPermitedToCallWhenCurrentStatus | JYDriverExceptionPublic.
InvalidUserDataBuffer | JYDriverExceptionPublic.
NoChannelAdded | JYDriverExceptionPublic.
NotSupportOperationForCurrentDevice | JYDriverExceptionPublic.
CreatTaskFailed | JYDriverExceptionPublic.
StartTaskFailed | JYDriverExceptionPublic.
StopTaskFailed | JYDriverExceptionPublic.
TaskHasNotStarted | JYDriverExceptionPublic.
TaskHasStartedCannotPerformTheSetOperation | JYDriverExceptionPublic.
ChannelNumberParameterInvalid | JYDriverExceptionPublic.
ChannelInputRangeParameterInvalid | JYDriverExceptionPublic.
ChannelTerminalParameterInvalid | JYDriverExceptionPublic.
ChannelCouplingParameterInvalid | JYDriverExceptionPublic.
SampeleModeParameterInvalid | JYDriverExceptionPublic.
SampleClockParameterInvalid | JYDriverExceptionPublic.
SampleRateParameterInvalid | JYDriverExceptionPublic.
UpdateRateParameterInvalid | JYDriverExceptionPublic.
TriggerParameterInvalid | JYDriverExceptionPublic.
ReferenceTriggerDoesNotMatchWithSampleMode | JYDriverExceptionPublic.
PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint | JYDriverExceptionPublic.
ReadDataFailed | JYDriverExceptionPublic.
ReadDataTimeout | JYDriverExceptionPublic.
WriteDataFailed | JYDriverExceptionPublic.
WriteDataTimeout | JYDriverExceptionPublic.
WriteDataLengthCannotBeLessThanN | JYDriverExceptionPublic.
BufferDataOverflow | JYDriverExceptionPublic.
BufferDataDownflow | JYDriverExceptionPublic.
CheckBufferFailed | JYDriverExceptionPublic.
PointInvalidInFiniteMode | JYDriverExceptionPublic.
ReadPointInvalid | JYDriverExceptionPublic.
OnlySupportRecordMode | JYDriverExceptionPublic.
SendSoftTirggerFailed | JYDriverExceptionPublic.
TaskTimeout | JYDriverExceptionPublic.
CounterParametersInvalid | JYDriverExceptionPublic.
WritePointInvalid | JYDriverExceptionPublic.
SignalExportDestinationInvalid | JYDriverExceptionPublic.
InvalidParameter | 无效参数。 Invalid parameter.

◆ LevelPolarity

enum class JY5113CoreOO::LevelPolarity
strong

Level Polarity.

Enumerator
LowLevel | Low level.
HighLevel | High level.
None | No active polarity.

◆ OutputCompleteState

enum class JY5113CoreOO::OutputCompleteState
strong

Output Complete State.

Enumerator
Zero | Output Complete Zero.
Hold | Output Complete Hold in The last point.

◆ PFITerminal

enum class JY5113CoreOO::PFITerminal
strong

Input/Output Terminal of PFI.

Enumerator
PFI0 | PFI 0.
PFI1 | PFI 1.
PFI2 | PFI 2.
PFI3 | PFI 3.
PFI4 | PFI 4.
PFI5 | PFI 5.
PFI6 | PFI 6.
PFI7 | PFI 7.
PFI8 | PFI 8.
PFI9 | PFI 9.
PFI10 | PFI 10.
PFI11 | PFI 11.
PFI12 | PFI 12.
PFI13 | PFI 13.
PFI14 | PFI 14.
PFI15 | PFI 15.

◆ PowerLineFrequency

enum class JY5113CoreOO::PowerLineFrequency
strong
Enumerator
_50Hz | 50 Hz AC Power Frequency
_60Hz | 60 Hz AC Power Frequency

◆ QuadEncodingType

enum class JY5113CoreOO::QuadEncodingType
strong

Quadrature Encoding Type.

Enumerator
X1 | X1.
X2 | X2.
X4 | X4.

◆ RecordMode

enum class JY5113CoreOO::RecordMode
strong

stream mode .enum Finite/Infinite

Enumerator
Finite | Finite Streaming.
Infinite | Infinite Streaming.

◆ ReferenceClockSource

enum class JY5113CoreOO::ReferenceClockSource
strong
Enumerator
Internal | Internal on board 25MHz Clock.
External | External Reference Clock Source.

◆ SignalExportDestination

enum class JY5113CoreOO::SignalExportDestination
strong
Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11.
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.

◆ SyncPulseRouting

enum class JY5113CoreOO::SyncPulseRouting
strong

Synchronous signal routing (the master card routes the synchronous signal to this port, and the slave card receives the synchronous signal from this port) 同步信号路由(主卡将同步信号路由到该端口，从卡从该端口接收同步信号)

Enumerator
NONE | Default NONE.
PXI_Trig0 | PXI Trig0.
PXI_Trig1 | PXI Trig1.
PXI_Trig2 | PXI Trig2.
PXI_Trig3 | PXI Trig3.
PXI_Trig4 | PXI Trig4.
PXI_Trig5 | PXI Trig5.
PXI_Trig6 | PXI Trig6.
PXI_Trig7 | PXI Trig7.

◆ SyncTriggerRouting

enum class JY5113CoreOO::SyncTriggerRouting
strong

Master card trigger signal routing (Master card routes trigger signal to this port) 主控卡触发信号路由(主控卡将触发信号路由到此端口)

Enumerator
NONE | Default NONE.
PXI_Trig0 | PXI Trig0.
PXI_Trig1 | PXI Trig1.
PXI_Trig2 | PXI Trig2.
PXI_Trig3 | PXI Trig3.
PXI_Trig4 | PXI Trig4.
PXI_Trig5 | PXI Trig5.
PXI_Trig6 | PXI Trig6.
PXI_Trig7 | PXI Trig7.

◆ ValueReturnMode

enum class JY5113CoreOO::ValueReturnMode
strong

TwoEdgeSeparation value return mode.only for TwoEdgeSeparation type.

Enumerator
TwoValue | Return two data simultaneously. first data is gate to aux edge separation, second data is aux to gate edge separation.
OneValue | only return gate to aux edge separation

Function Documentation

◆ GetSignalExportDestinationString()

std::string JY5113CoreOO::GetSignalExportDestinationString ( SignalExportDestination destination )
inline


5113 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOAOTask.h File Reference

  • File List
  • File Members
  • COO
  • 5113
Classes | Namespaces | Enumerations
JY5113CoreOOAOTask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JY5113CoreOOCommon.h"
#include "JY5113CoreOODevice.h"

Classes

class | JY5113CoreOO::JY5113CoreOOAOTask
class | JY5113CoreOO::AOChannel
class | JY5113CoreOO::AOExternalSampleClock
External Sample Clock Configuration Class. More...
class | JY5113CoreOO::AOSampleClock
AO Sample clock configuration class. More...
class | JY5113CoreOO::AOTrigger
Constructor to create an AOTrigger task object. More...
class | JY5113CoreOO::AODigitalTrigger
AO Digital trigger . More...
class | JY5113CoreOO::AOSignalExport
AO Signal Export Class. More...

Namespaces

namespace JY5113CoreOO

Enumerations

enum class | JY5113CoreOO::AOMode { JY5113CoreOO::Single = 3 , JY5113CoreOO::Finite = 0 , JY5113CoreOO::ContinuousNoWrapping = 2 , JY5113CoreOO::ContinuousWrapping = 1 }
enum class | JY5113CoreOO::AODigitalTriggerEdge { JY5113CoreOO::Rising , JY5113CoreOO::Falling }
AO Digital Trigger Edge. More...
enum class JY5113CoreOO::AODigitalTriggerSource {
JY5113CoreOO::PFI0 , JY5113CoreOO::PFI1 , JY5113CoreOO::PFI2 , JY5113CoreOO::PFI3 ,
JY5113CoreOO::PFI4 , JY5113CoreOO::PFI5 , JY5113CoreOO::PFI6 , JY5113CoreOO::PFI7 ,
JY5113CoreOO::PFI8 , JY5113CoreOO::PFI9 , JY5113CoreOO::PFI10 , JY5113CoreOO::PFI11 ,
JY5113CoreOO::PFI12 , JY5113CoreOO::PFI13 , JY5113CoreOO::PFI14 , JY5113CoreOO::PFI15 ,
JY5113CoreOO::PXI_Trig0 = 40 , JY5113CoreOO::PXI_Trig1 = 41 , JY5113CoreOO::PXI_Trig2 = 42 , JY5113CoreOO::PXI_Trig3 = 43 ,
JY5113CoreOO::PXI_Trig4 = 44 , JY5113CoreOO::PXI_Trig5 = 45 , JY5113CoreOO::PXI_Trig6 = 46 , JY5113CoreOO::PXI_Trig7 = 47 ,
JY5113CoreOO::AI_StartTrig = 16 , JY5113CoreOO::AI_ReferenceTrig = 17 , JY5113CoreOO::DI_StartTrig = 22 , JY5113CoreOO::DI_ReferenceTrig = 23 ,
JY5113CoreOO::DO_StartTrig = 29 , JY5113CoreOO::CI_0_StartTrig = 68 , JY5113CoreOO::CI_1_StartTrig = 73 , JY5113CoreOO::CI_2_StartTrig = 76 ,
JY5113CoreOO::CI_3_StartTrig = 79 , JY5113CoreOO::CO_0_StartTrig = 69 , JY5113CoreOO::CO_1_StartTrig = 74 , JY5113CoreOO::CO_2_StartTrig = 77 ,
JY5113CoreOO::CO_3_StartTrig = 80 , JY5113CoreOO::CO_0_Output = 37 , JY5113CoreOO::CO_1_Output = 51 , JY5113CoreOO::CO_2_Output = 60 ,
JY5113CoreOO::CO_3_Output = 66
}
AO Digital trigger source. More...
enum class | JY5113CoreOO::AOSampleClockSource { JY5113CoreOO::Internal , JY5113CoreOO::External }
AO Sample Clock Source. More...
enum class | JY5113CoreOO::AOSignalExportSource { JY5113CoreOO::StartTrig = 28 , JY5113CoreOO::SampleClock = 35 }
SourceSignal. More...
enum class | JY5113CoreOO::AOTriggerType { JY5113CoreOO::Immediate = 0x0 , JY5113CoreOO::Digital = 0x1 , JY5113CoreOO::Soft = 0x3 }
TriggerType Digital/Immediate/Soft. More...


5113 C++ Programming Manual: JY5113CoreOO::JY5113CoreOOAOTask Class Reference

  • JY5113CoreOOAOTask
Public Member Functions | Public Attributes | List of all members
JY5113CoreOO::JY5113CoreOOAOTask Class Reference

#include <JY5113CoreOOAOTask.h>

Public Member Functions

JY5113CoreOOAOTask (int slotNum)
JY5113CoreOOAOTask (std::string boardName)
void | AddChannel (int chnId, double rangeLow=-10, double rangeHigh=10)
Add one channel.
void | AddChannel (std::vector< int > chnsId, double rangeLow=-10, double rangeHigh=10)
Add a group of channels.
void | AddChannel (std::vector< int > chnsId, std::vector< double > rangeLow, std::vector< double > rangeHigh)
Add a group of channels.
void | RemoveChannel (int chnId)
Delete the specified channel number.
void | WriteData (double *pBuf, int samplesPerChannel, int timeout=10000)
Write to AO buffer one or multi-channel data.
void | WriteRawData (int16_t *pBuf, int samplesPerChannel, int timeout=10000)
Write to AO buffer one or multi-channel raw data.
void | WriteSinglePoint (std::vector< double > writeValues)
write one sample to all channels in register .
void | WriteSinglePoint (double writeValue, int channel)
Write one sample to the specified channel in register.Available when Mode is AOMode.Single
void | WriteRawSinglePoint (std::vector< int16_t > writeValues)
write one raw sample to all channels in register .
void | WriteRawSinglePoint (int16_t writeValue, int channel)
Write one raw sample to the specified channel in register.Available when Mode is AOMode.Single
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.
void | Start ()
Start AO task .
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Stop ()
Stop AO task .
~JY5113CoreOOAOTask ()
析构函数

Public Attributes

std::list< AOChannel * > | Channels
List of AI channels,(5113 support 4 channels)
AOMode Mode
Mode of AO Task.
JY5113CoreOOProperty< JY5113CoreOOAOTask, double, JY5113CoreOOPropertyType::READ_WRITE > | UpdateRate
Update rate per channel.
int | SamplesToUpdate
Number of output samples to write per channel , Only valid when Mode is AOMode.Finite.
JY5113CoreOOProperty< JY5113CoreOOAOTask, int, JY5113CoreOOPropertyType::READ_ONLY > | BufLenInSamples
Number of samples per channel can be storage in the buffer, the PropretySamplesToUpdate must be less than or equal to this value.
JY5113CoreOOProperty< JY5113CoreOOAOTask, uint32_t, JY5113CoreOOPropertyType::READ_ONLY > | AvaliableLenInSamples
Number of output samples per channel that can be write in AO buffuer.
OutputCompleteState CompleteState
AO Output Complete State, Valid when Mode is NOT OMode.Single.
JY5113CoreOOProperty< JY5113CoreOOAOTask, uint64_t, JY5113CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
AOSampleClock * SampleClock
AO Sample Clock Configuration.
AOTrigger * Trigger
AO Trigger Configuration.
AOSignalExport * SignalExport
Export AO Signal.
JY5113CoreOODevice * Device
bool | DisableCalibration

Constructor & Destructor Documentation

◆ JY5113CoreOOAOTask() [1/2]

JY5113CoreOO::JY5113CoreOOAOTask::JY5113CoreOOAOTask ( int slotNum )

◆ JY5113CoreOOAOTask() [2/2]

JY5113CoreOO::JY5113CoreOOAOTask::JY5113CoreOOAOTask ( std::string boardName )

◆ ~JY5113CoreOOAOTask()

JY5113CoreOO::JY5113CoreOOAOTask::~JY5113CoreOOAOTask ( )

析构函数

Member Function Documentation

◆ AddChannel() [1/3]

void JY5113CoreOO::JY5113CoreOOAOTask::AddChannel | ( | int | chnId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10 )

Add one channel.

Parameters
chnId | channel's physical number ，chnId=-1, add all channels。（5113 support 4 channels）
rangeLow | lower range limit for the channel，-10V defalut -10
rangeHigh | higher range limit for the channel，10V defalut 10

◆ AddChannel() [2/3]

void JY5113CoreOO::JY5113CoreOOAOTask::AddChannel | ( | std::vector< int > | chnsId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10 )

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers。（5113 support 4 channels）
rangeLow | lower range limit for the channel，-10V defalut -10
rangeHigh | higher range limit for the channel，10V defalut 10

◆ AddChannel() [3/3]

void JY5113CoreOO::JY5113CoreOOAOTask::AddChannel | ( | std::vector< int > | chnsId,
 |  | std::vector< double > | rangeLow,
 |  | std::vector< double > | rangeHigh )

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers。（5113 support 4 channels）
rangeLow | lower range limit for the channel，-10V
rangeHigh | higher range limit for the channel，10V

◆ RemoveChannel()

void JY5113CoreOO::JY5113CoreOOAOTask::RemoveChannel ( int chnId )

Delete the specified channel number.

If it is -1, delete all channels.

Parameters
chnId Specified channel ID.

◆ SendSoftwareTrigger()

void JY5113CoreOO::JY5113CoreOOAOTask::SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5113CoreOO::JY5113CoreOOAOTask::Start ( )

Start AO task .

◆ Stop()

void JY5113CoreOO::JY5113CoreOOAOTask::Stop ( )

Stop AO task .

◆ WaitUntilDone()

bool JY5113CoreOO::JY5113CoreOOAOTask::WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Available when Mode is AOMode.Finite

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteData()

void JY5113CoreOO::JY5113CoreOOAOTask::WriteData | ( | double * | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Write to AO buffer one or multi-channel data.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | data buffer.
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawData()

void JY5113CoreOO::JY5113CoreOOAOTask::WriteRawData | ( | int16_t * | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Write to AO buffer one or multi-channel raw data.

Parameters
buf | data buffer.
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawSinglePoint() [1/2]

void JY5113CoreOO::JY5113CoreOOAOTask::WriteRawSinglePoint | ( | int16_t | writeValue,
 |  | int | channel )

Write one raw sample to the specified channel in register.Available when Mode is AOMode.Single

Parameters
writeValue | Write value.
channel | Specified channel.

◆ WriteRawSinglePoint() [2/2]

void JY5113CoreOO::JY5113CoreOOAOTask::WriteRawSinglePoint ( std::vector< int16_t > writeValues )

write one raw sample to all channels in register .

Available when Mode is AOMode.Single

Parameters
writeValues Write values. Array length >= Channels.Count.

◆ WriteSinglePoint() [1/2]

void JY5113CoreOO::JY5113CoreOOAOTask::WriteSinglePoint | ( | double | writeValue,
 |  | int | channel )

Write one sample to the specified channel in register.Available when Mode is AOMode.Single

Parameters
writeValue | Write value.
channel | Specified channel.

◆ WriteSinglePoint() [2/2]

void JY5113CoreOO::JY5113CoreOOAOTask::WriteSinglePoint ( std::vector< double > writeValues )

write one sample to all channels in register .

Available when Mode is AOMode.Single

Parameters
writeValues Write values. Array length >= Channels.Count.

Member Data Documentation

◆ AvaliableLenInSamples

JY5113CoreOOProperty<JY5113CoreOOAOTask, uint32_t, JY5113CoreOOPropertyType::READ_ONLY> JY5113CoreOO::JY5113CoreOOAOTask::AvaliableLenInSamples

Number of output samples per channel that can be write in AO buffuer.

◆ BufLenInSamples

JY5113CoreOOProperty<JY5113CoreOOAOTask, int, JY5113CoreOOPropertyType::READ_ONLY> JY5113CoreOO::JY5113CoreOOAOTask::BufLenInSamples

Number of samples per channel can be storage in the buffer, the PropretySamplesToUpdate must be less than or equal to this value.

◆ Channels

std::list<AOChannel*> JY5113CoreOO::JY5113CoreOOAOTask::Channels

List of AI channels,(5113 support 4 channels)

◆ CompleteState

OutputCompleteState JY5113CoreOO::JY5113CoreOOAOTask::CompleteState

AO Output Complete State, Valid when Mode is NOT OMode.Single.

Default is Zero.

◆ Device

JY5113CoreOODevice* JY5113CoreOO::JY5113CoreOOAOTask::Device

◆ DisableCalibration

bool JY5113CoreOO::JY5113CoreOOAOTask::DisableCalibration

◆ Mode

AOMode JY5113CoreOO::JY5113CoreOOAOTask::Mode

Mode of AO Task.

Select AO Mode from enum:ContinuousNoWrapping/ContinuousWrapping/Finite/Single.

◆ SampleClock

AOSampleClock* JY5113CoreOO::JY5113CoreOOAOTask::SampleClock

AO Sample Clock Configuration.

◆ SamplesToUpdate

int JY5113CoreOO::JY5113CoreOOAOTask::SamplesToUpdate

Number of output samples to write per channel , Only valid when Mode is AOMode.Finite.

◆ SignalExport

AOSignalExport* JY5113CoreOO::JY5113CoreOOAOTask::SignalExport

Export AO Signal.

◆ TransferedSamples

JY5113CoreOOProperty<JY5113CoreOOAOTask, uint64_t, JY5113CoreOOPropertyType::READ_ONLY> JY5113CoreOO::JY5113CoreOOAOTask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT AOMode.Single.

◆ Trigger

AOTrigger* JY5113CoreOO::JY5113CoreOOAOTask::Trigger

AO Trigger Configuration.

◆ UpdateRate

JY5113CoreOOProperty<JY5113CoreOOAOTask, double, JY5113CoreOOPropertyType::READ_WRITE> JY5113CoreOO::JY5113CoreOOAOTask::UpdateRate

Update rate per channel.

Maximum update rate is 2.86M for single channel, 2M for two channels, 1.54M for three channels, 1.25M for four channels. The defalut sample rate = 1000000 You can read this property to obtain the update rate that will actually take effect in the current configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOAOTask.h


5113 C++ Programming Manual: JY5113CoreOO::AOChannel Class Reference

  • AOChannel
Public Member Functions | Public Attributes | List of all members
JY5113CoreOO::AOChannel Class Reference

#include <JY5113CoreOOAOTask.h>

Public Member Functions

AOChannel (int channelId, double rangeLow, double rangeHigh)

Public Attributes

int | ChannelID
double | RangeLow
double | RangeHigh

Constructor & Destructor Documentation

◆ AOChannel()

JY5113CoreOO::AOChannel::AOChannel | ( | int | channelId,
 |  | double | rangeLow,
 |  | double | rangeHigh )
 inline

Member Data Documentation

◆ ChannelID

int JY5113CoreOO::AOChannel::ChannelID

◆ RangeHigh

double JY5113CoreOO::AOChannel::RangeHigh

◆ RangeLow

double JY5113CoreOO::AOChannel::RangeLow
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOAOTask.h


5113 C++ Programming Manual: JY5113CoreOO::AOExternalSampleClock Class Reference

  • AOExternalSampleClock
Public Attributes | List of all members
JY5113CoreOO::AOExternalSampleClock Class Reference

External Sample Clock Configuration Class. More...

#include <JY5113CoreOOAOTask.h>

Public Attributes

ClockTerminal Terminal
External Sample Clock Input Terminal.
double ExpectedRate
Expected External Sample Clock Rate.

Detailed Description

External Sample Clock Configuration Class.

Member Data Documentation

◆ ExpectedRate

double JY5113CoreOO::AOExternalSampleClock::ExpectedRate

Expected External Sample Clock Rate.

◆ Terminal

ClockTerminal JY5113CoreOO::AOExternalSampleClock::Terminal

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOAOTask.h


5113 C++ Programming Manual: JY5113CoreOO::AOSampleClock Class Reference

  • AOSampleClock
Public Attributes | Friends | List of all members
JY5113CoreOO::AOSampleClock Class Reference

AO Sample clock configuration class. More...

#include <JY5113CoreOOAOTask.h>

Public Attributes

AOSampleClockSource Source
Clock Source.
AOExternalSampleClock * External
External Sample Clock Configuration,Valid when Source is AOSampleClockSource::External.

Friends

class JY5113CoreOOAOTask

Detailed Description

AO Sample clock configuration class.

Friends And Related Symbol Documentation

◆ JY5113CoreOOAOTask

friend class JY5113CoreOOAOTask
friend

Member Data Documentation

◆ External

AOExternalSampleClock* JY5113CoreOO::AOSampleClock::External

External Sample Clock Configuration,Valid when Source is AOSampleClockSource::External.

◆ Source

AOSampleClockSource JY5113CoreOO::AOSampleClock::Source

Clock Source.

enum Internal/External,The default value is AOSampleClockSource.Internal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOAOTask.h


5113 C++ Programming Manual: JY5113CoreOO::AOTrigger Class Reference

  • AOTrigger
Public Attributes | List of all members
JY5113CoreOO::AOTrigger Class Reference

Constructor to create an AOTrigger task object. More...

#include <JY5113CoreOOAOTask.h>

Public Attributes

AOTriggerType Type
AO trigger type.
AODigitalTrigger * Digital
AO Digital Trigger.

Detailed Description

Constructor to create an AOTrigger task object.

Used to build AO Trigger

Member Data Documentation

◆ Digital

AODigitalTrigger* JY5113CoreOO::AOTrigger::Digital

AO Digital Trigger.

Valid when Type is AOTriggerType.Digital.

◆ Type

AOTriggerType JY5113CoreOO::AOTrigger::Type

AO trigger type.

enum Immediate/Digital/Soft.The default value is AOTriggerType.Immediate.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOAOTask.h


5113 C++ Programming Manual: JY5113CoreOO::AODigitalTrigger Class Reference

  • AODigitalTrigger
Public Attributes | List of all members
JY5113CoreOO::AODigitalTrigger Class Reference

AO Digital trigger . More...

#include <JY5113CoreOOAOTask.h>

Public Attributes

AODigitalTriggerSource Source
AO Digital Trigger source.
AODigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Detailed Description

AO Digital trigger .

Member Data Documentation

◆ Edge

AODigitalTriggerEdge JY5113CoreOO::AODigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

AODigitalTriggerSource JY5113CoreOO::AODigitalTrigger::Source

AO Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOAOTask.h


5113 C++ Programming Manual: JY5113CoreOO::AOSignalExport Class Reference

  • AOSignalExport
Public Member Functions | List of all members
JY5113CoreOO::AOSignalExport Class Reference

AO Signal Export Class. More...

#include <JY5113CoreOOAOTask.h>

Public Member Functions

void | Add (AOSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (AOSignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

AO Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY5113CoreOO::AOSignalExport::Add | ( | AOSignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | AO Signal Source
destination | Export Desination

◆ Add() [2/2]

void JY5113CoreOO::AOSignalExport::Add | ( | AOSignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | AO Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JY5113CoreOO::AOSignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5113CoreOO::AOSignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOAOTask.h


5113 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOCITask.h File Reference

  • File List
  • File Members
  • COO
  • 5113
Classes | Namespaces | Enumerations
JY5113CoreOOCITask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JY5113CoreOOCommon.h"
#include "JY5113CoreOODevice.h"

Classes

class | JY5113CoreOO::JY5113CoreOOCITask
class | JY5113CoreOO::CIInternalSampleClock
CI Internal Sample Clock Configuration Class. More...
class | JY5113CoreOO::CIImplicitSampleClock
CI Implicit Sample Clock class. More...
class | JY5113CoreOO::CIExternalSampleClock
CI Implicit Sample Clock class. More...
class | JY5113CoreOO::CISampleClock
CI Sample Clock class. More...
class | JY5113CoreOO::EdgeCounting
Configure CI EdgeCounting. More...
class | JY5113CoreOO::FrequencyMeas
Configure CI Measure. More...
class | JY5113CoreOO::PeriodMeas
Configure CI Measure. More...
class | JY5113CoreOO::PulseMeas
Configure CI Measure. More...
class | JY5113CoreOO::SemiPeriodMeas
Configure CI Measure. More...
class | JY5113CoreOO::TwoEdgeSeparation
Configure CI Measure. More...
class | JY5113CoreOO::QuadEncoder
Configure CI Measure. More...
class | JY5113CoreOO::TwoPulseEncoder
Configure CI Measure. More...
class | JY5113CoreOO::CITrigger
Constructor to create an CITrigger task object. More...
class | JY5113CoreOO::CIDigitalTrigger
CI Digital trigger . More...
class | JY5113CoreOO::EdgeCountingOutEvent
Edge counting output event configuration class. More...
class | JY5113CoreOO::CIExternalTimebase
class | JY5113CoreOO::CITimebase
Timebase configuration class. More...
class | JY5113CoreOO::CISignalExport
CI Signal Export Class. More...

Namespaces

namespace JY5113CoreOO

Enumerations

enum class | JY5113CoreOO::CountDirection { JY5113CoreOO::Up = 0x0 , JY5113CoreOO::Down = 0x1 , JY5113CoreOO::External = 0x2 }
Counter direction. More...
enum class | JY5113CoreOO::CIMode { JY5113CoreOO::Single = 2 , JY5113CoreOO::Finite = 0 , JY5113CoreOO::Continuous = 1 }
CIMode. More...
enum class JY5113CoreOO::CIType {
JY5113CoreOO::EdgeCounting , JY5113CoreOO::Period , JY5113CoreOO::Frequency , JY5113CoreOO::Pulse ,
JY5113CoreOO::SemiPeriod , JY5113CoreOO::TwoEdgeSeparation , JY5113CoreOO::QuadEncoder , JY5113CoreOO::TwoPulseEncoder
}
Counter Input Application Type. More...
enum class | JY5113CoreOO::CISampleClockSource { JY5113CoreOO::Implicit = 0x0 , JY5113CoreOO::Internal = 0x1 , JY5113CoreOO::External = 0x2 }
CI Sample Clock Source. More...
enum class | JY5113CoreOO::EdgeType { JY5113CoreOO::Rising , JY5113CoreOO::Falling , JY5113CoreOO::Any }
Edge Type. More...
enum class | JY5113CoreOO::ValueReturnMode { JY5113CoreOO::TwoValue , JY5113CoreOO::OneValue }
TwoEdgeSeparation value return mode.only for TwoEdgeSeparation type. More...
enum class | JY5113CoreOO::QuadEncodingType { JY5113CoreOO::X1 , JY5113CoreOO::X2 , JY5113CoreOO::X4 }
Quadrature Encoding Type. More...
enum class | JY5113CoreOO::CITriggerType { JY5113CoreOO::Immediate = 0x0 , JY5113CoreOO::Digital = 0x1 , JY5113CoreOO::Soft = 0x3 }
TriggerType Digital/Immediate/Soft. More...
enum class JY5113CoreOO::CIDigitalTriggerSource {
JY5113CoreOO::PFI0 , JY5113CoreOO::PFI1 , JY5113CoreOO::PFI2 , JY5113CoreOO::PFI3 ,
JY5113CoreOO::PFI4 , JY5113CoreOO::PFI5 , JY5113CoreOO::PFI6 , JY5113CoreOO::PFI7 ,
JY5113CoreOO::PFI8 , JY5113CoreOO::PFI9 , JY5113CoreOO::PFI10 , JY5113CoreOO::PFI11 ,
JY5113CoreOO::PFI12 , JY5113CoreOO::PFI13 , JY5113CoreOO::PFI14 , JY5113CoreOO::PFI15 ,
JY5113CoreOO::PXI_Trig0 , JY5113CoreOO::PXI_Trig1 , JY5113CoreOO::PXI_Trig2 , JY5113CoreOO::PXI_Trig3 ,
JY5113CoreOO::PXI_Trig4 , JY5113CoreOO::PXI_Trig5 , JY5113CoreOO::PXI_Trig6 , JY5113CoreOO::PXI_Trig7 ,
JY5113CoreOO::AI_StartTrig , JY5113CoreOO::AI_ReferenceTrig , JY5113CoreOO::DI_StartTrig , JY5113CoreOO::DI_ReferenceTrig ,
JY5113CoreOO::AO_StartTrig , JY5113CoreOO::DO_StartTrig , JY5113CoreOO::CIO_0_StartTrig , JY5113CoreOO::CIO_1_StartTrig
}
CI Digital trigger source. More...
enum class | JY5113CoreOO::CIDigitalTriggerEdge { JY5113CoreOO::Rising , JY5113CoreOO::Falling }
CI Digital Trigger Edge. More...
enum class | JY5113CoreOO::EdgeCntOunEvtIdleState { JY5113CoreOO::LowLevel = 0 , JY5113CoreOO::HighLevel = 1 }
Output idle state when the event has not occurred. More...
enum class | JY5113CoreOO::CISignalExportSource { JY5113CoreOO::StartTrig , JY5113CoreOO::SampleClock }
SourceSignal. More...
enum class | JY5113CoreOO::CITimebaseSource { JY5113CoreOO::Internal100MHz = 0 , JY5113CoreOO::Internal5MHz = 1 , JY5113CoreOO::Internal100kHz = 2 , JY5113CoreOO::External = 3 }
Timebase source. More...


5113 C++ Programming Manual: JY5113CoreOO::JY5113CoreOOCITask Class Reference

  • JY5113CoreOOCITask
Public Member Functions | Public Attributes | List of all members
JY5113CoreOO::JY5113CoreOOCITask Class Reference

#include <JY5113CoreOOCITask.h>

Public Member Functions

JY5113CoreOOCITask (int slotNum, int channel)
JY5113CoreOOCITask (std::string boardName, int channel)
~JY5113CoreOOCITask ()
void | Start ()
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Stop ()
Stop CI task .
void | ReadSinglePoint (uint32_t &count)
Read a signle count value from register, Available when Type is CIType.EdgeCounting, CIType.QuadEncoder or CIType.TwoPulseEncoder.
void | ReadData (uint32_t *pBufCount, int samplesToAcquire, int timeout=10000)
Read counter values from buffer.
void | ReadData (double *pBufMeasurement, int samplesToAcquire, int timeout=10000)
Read frequency value or period value from buffer.
void | ReadSinglePoint (double &measurement, int timeout=10000)
Read a signle frequency value or period value from register.
void | ReadSinglePoint (double &measurement1, double &measurement2, int timeout=10000)
Read a signle measurement of pulse's duration value, or two-edge separtion value (two results at a time) from register.
void | ReadData (double *pBufMeasurement1, double *pBufMeasurement2, int samplesToAcquire, int timeout=10000)
Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.

Public Attributes

CIType Type
CI Application types.
JY5113CoreOOProperty< JY5113CoreOOCITask, uint64_t, JY5113CoreOOPropertyType::READ_ONLY > | AvailableSamples
Number of points per channel that can be read in the buffer .
JY5113CoreOOProperty< JY5113CoreOOCITask, uint64_t, JY5113CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
CIMode Mode
CI Sampling mode，support Single/Finite/Continuous.
CISampleClock * SampleClock
Clock Source.
uint32_t | SamplesToAcquire
Number of samples to be read per channel.Only valid when Mode is CIMode.Finite.
JY5113CoreOO::EdgeCounting * EdgeCounting
Edge Counting Configuration.
JY5113CoreOO::FrequencyMeas * FrequencyMeas
Frequency Measurement Configuration.
JY5113CoreOO::PeriodMeas * PeriodMeas
Period Measurement Configuration.
JY5113CoreOO::SemiPeriodMeas * SemiPeriodMeas
SemiPeriodMeas Measurement Configuration.
JY5113CoreOO::PulseMeas * PulseMeas
Pulse Measurement Configuration.
JY5113CoreOO::TwoEdgeSeparation * TwoEdgeSeparation
TwoEdgeSeparation.
JY5113CoreOO::QuadEncoder * QuadEncoder
QuadEncoder.
JY5113CoreOO::TwoPulseEncoder * TwoPulseEncoder
TwoPulseEncoder.
CITrigger * Trigger
CI Trigger Configuration.
CISignalExport * SignalExport
Export CI Signal Configuration.
JY5113CoreOODevice * Device
Device.

Constructor & Destructor Documentation

◆ JY5113CoreOOCITask() [1/2]

JY5113CoreOO::JY5113CoreOOCITask::JY5113CoreOOCITask | ( | int | slotNum,
 |  | int | channel )

◆ JY5113CoreOOCITask() [2/2]

JY5113CoreOO::JY5113CoreOOCITask::JY5113CoreOOCITask | ( | std::string | boardName,
 |  | int | channel )

◆ ~JY5113CoreOOCITask()

JY5113CoreOO::JY5113CoreOOCITask::~JY5113CoreOOCITask ( )

Member Function Documentation

◆ ReadData() [1/3]

void JY5113CoreOO::JY5113CoreOOCITask::ReadData | ( | double * | pBufMeasurement,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read frequency value or period value from buffer.

Available when JY5113CITask.Mode is NOT CIMode.Single, and Type is CIType.Frequency or CIType.Period.

Parameters
bufMeasurement | Buffer for reading data. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period in seconds when Type is CIType.Period.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [2/3]

void JY5113CoreOO::JY5113CoreOOCITask::ReadData | ( | double * | pBufMeasurement1,
 |  | double * | pBufMeasurement2,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.

. Available when JY5113CITask.Mode is NOT CIMode.Single, Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
bufMeasurement1 | Buffer for reading data. Indicates high level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
bufMeasurement2 | Buffer for reading data. Indicates low level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [3/3]

void JY5113CoreOO::JY5113CoreOOCITask::ReadData | ( | uint32_t * | pBufCount,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read counter values from buffer.

Available when JY5113CITask.Mode is NOT CIMode.Single, and Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder

Parameters
bufCount | Buffer for reading data.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [1/3]

void JY5113CoreOO::JY5113CoreOOCITask::ReadSinglePoint | ( | double & | measurement,
 |  | int | timeout = 10000 )

Read a signle frequency value or period value from register.

Valid when Type is CIType.Frequency or CIType.Period.

Parameters
measurement Measurement value. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period is seconds when Type is CIType.Period.
timeout
Timeout (ms). Wait until the measurement is completed or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [2/3]

void JY5113CoreOO::JY5113CoreOOCITask::ReadSinglePoint | ( | double & | measurement1,
 |  | double & | measurement2,
 |  | int | timeout = 10000 )

Read a signle measurement of pulse's duration value, or two-edge separtion value (two results at a time) from register.

Available when Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
measurement1 | Measurement Value 1. Indicates low level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
measurement2 | Measurement Value 2. Indicates high level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
timeout
Timeout (ms). Wait until the measurement is completed or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [3/3]

void JY5113CoreOO::JY5113CoreOOCITask::ReadSinglePoint ( uint32_t & count )

Read a signle count value from register, Available when Type is CIType.EdgeCounting, CIType.QuadEncoder or CIType.TwoPulseEncoder.

Parameters
count counter value。

◆ SendSoftwareTrigger()

void JY5113CoreOO::JY5113CoreOOCITask::SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5113CoreOO::JY5113CoreOOCITask::Start ( )

◆ Stop()

void JY5113CoreOO::JY5113CoreOOCITask::Stop ( )

Stop CI task .

Member Data Documentation

◆ AvailableSamples

JY5113CoreOOProperty<JY5113CoreOOCITask, uint64_t, JY5113CoreOOPropertyType::READ_ONLY> JY5113CoreOO::JY5113CoreOOCITask::AvailableSamples

Number of points per channel that can be read in the buffer .

◆ Device

JY5113CoreOODevice* JY5113CoreOO::JY5113CoreOOCITask::Device

Device.

◆ EdgeCounting

JY5113CoreOO::EdgeCounting* JY5113CoreOO::JY5113CoreOOCITask::EdgeCounting

Edge Counting Configuration.

◆ FrequencyMeas

JY5113CoreOO::FrequencyMeas* JY5113CoreOO::JY5113CoreOOCITask::FrequencyMeas

Frequency Measurement Configuration.

◆ Mode

CIMode JY5113CoreOO::JY5113CoreOOCITask::Mode

CI Sampling mode，support Single/Finite/Continuous.

◆ PeriodMeas

JY5113CoreOO::PeriodMeas* JY5113CoreOO::JY5113CoreOOCITask::PeriodMeas

Period Measurement Configuration.

◆ PulseMeas

JY5113CoreOO::PulseMeas* JY5113CoreOO::JY5113CoreOOCITask::PulseMeas

Pulse Measurement Configuration.

◆ QuadEncoder

JY5113CoreOO::QuadEncoder* JY5113CoreOO::JY5113CoreOOCITask::QuadEncoder

QuadEncoder.

◆ SampleClock

CISampleClock* JY5113CoreOO::JY5113CoreOOCITask::SampleClock

Clock Source.

◆ SamplesToAcquire

uint32_t JY5113CoreOO::JY5113CoreOOCITask::SamplesToAcquire

Number of samples to be read per channel.Only valid when Mode is CIMode.Finite.

◆ SemiPeriodMeas

JY5113CoreOO::SemiPeriodMeas* JY5113CoreOO::JY5113CoreOOCITask::SemiPeriodMeas

SemiPeriodMeas Measurement Configuration.

◆ SignalExport

CISignalExport* JY5113CoreOO::JY5113CoreOOCITask::SignalExport

Export CI Signal Configuration.

◆ TransferedSamples

JY5113CoreOOProperty<JY5113CoreOOCITask, uint64_t, JY5113CoreOOPropertyType::READ_ONLY> JY5113CoreOO::JY5113CoreOOCITask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT CIMode.Single.

◆ Trigger

CITrigger* JY5113CoreOO::JY5113CoreOOCITask::Trigger

CI Trigger Configuration.

◆ TwoEdgeSeparation

JY5113CoreOO::TwoEdgeSeparation* JY5113CoreOO::JY5113CoreOOCITask::TwoEdgeSeparation

TwoEdgeSeparation.

◆ TwoPulseEncoder

JY5113CoreOO::TwoPulseEncoder* JY5113CoreOO::JY5113CoreOOCITask::TwoPulseEncoder

TwoPulseEncoder.

◆ Type

CIType JY5113CoreOO::JY5113CoreOOCITask::Type

CI Application types.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOCITask.h


5113 C++ Programming Manual: JY5113CoreOO::CIInternalSampleClock Class Reference

  • CIInternalSampleClock
Public Attributes | List of all members
JY5113CoreOO::CIInternalSampleClock Class Reference

CI Internal Sample Clock Configuration Class. More...

#include <JY5113CoreOOCITask.h>

Public Attributes

JY5113CoreOOProperty< CIInternalSampleClock, double, JY5113CoreOOPropertyType::READ_WRITE > | Rate
The rate of the internal sample clock (sample rate) which is generated by dividing the internal clock (100MHz).
bool | IgnoreFirstSampleClock
Ignore the first sample clock data.

Detailed Description

CI Internal Sample Clock Configuration Class.

Member Data Documentation

◆ IgnoreFirstSampleClock

bool JY5113CoreOO::CIInternalSampleClock::IgnoreFirstSampleClock

Ignore the first sample clock data.

◆ Rate

JY5113CoreOOProperty<CIInternalSampleClock, double, JY5113CoreOOPropertyType::READ_WRITE> JY5113CoreOO::CIInternalSampleClock::Rate

The rate of the internal sample clock (sample rate) which is generated by dividing the internal clock (100MHz).

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOCITask.h


5113 C++ Programming Manual: JY5113CoreOO::CIImplicitSampleClock Class Reference

  • CIImplicitSampleClock
Public Attributes | List of all members
JY5113CoreOO::CIImplicitSampleClock Class Reference

CI Implicit Sample Clock class. More...

#include <JY5113CoreOOCITask.h>

Public Attributes

double ExpectedRate
Expected Rate of Implicit Sample Clock.

Detailed Description

CI Implicit Sample Clock class.

Member Data Documentation

◆ ExpectedRate

double JY5113CoreOO::CIImplicitSampleClock::ExpectedRate

Expected Rate of Implicit Sample Clock.

Filling this parameter accurately would helps the driver to set a proper DDR write frequency internally.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOCITask.h


5113 C++ Programming Manual: JY5113CoreOO::CIExternalSampleClock Class Reference

  • CIExternalSampleClock
Public Attributes | List of all members
JY5113CoreOO::CIExternalSampleClock Class Reference

CI Implicit Sample Clock class. More...

#include <JY5113CoreOOCITask.h>

Public Attributes

ClockTerminal Terminal
External Sample Clock Input Terminal.
double ExpectedRate
Expected Rate of External Sample Clock.

Detailed Description

CI Implicit Sample Clock class.

Member Data Documentation

◆ ExpectedRate

double JY5113CoreOO::CIExternalSampleClock::ExpectedRate

Expected Rate of External Sample Clock.

Filling this parameter accurately would helps the driver to set a proper DDR write frequency internally.

◆ Terminal

ClockTerminal JY5113CoreOO::CIExternalSampleClock::Terminal

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOCITask.h


5113 C++ Programming Manual: JY5113CoreOO::CISampleClock Class Reference

  • CISampleClock
Public Attributes | List of all members
JY5113CoreOO::CISampleClock Class Reference

CI Sample Clock class. More...

#include <JY5113CoreOOCITask.h>

Public Attributes

CISampleClockSource Source
CI Sample Clock Source.
CIExternalSampleClock * External
CI External Sample Clock Configuration.
CIImplicitSampleClock * Implicit
CI Implicit Sample Clock Configuration.
CIInternalSampleClock * Internal
Internal Sample Clock Configuration.

Detailed Description

CI Sample Clock class.

Member Data Documentation

◆ External

CIExternalSampleClock* JY5113CoreOO::CISampleClock::External

CI External Sample Clock Configuration.

Valid when Source is CISampleClockSource.External.

◆ Implicit

CIImplicitSampleClock* JY5113CoreOO::CISampleClock::Implicit

CI Implicit Sample Clock Configuration.

Valid when Source is CISampleClockSource.Implicit.

◆ Internal

CIInternalSampleClock* JY5113CoreOO::CISampleClock::Internal

Internal Sample Clock Configuration.

Valid when Source is CISampleClockSource.Internal.

◆ Source

CISampleClockSource JY5113CoreOO::CISampleClock::Source

CI Sample Clock Source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOCITask.h


5113 C++ Programming Manual: JY5113CoreOO::EdgeCounting Class Reference

  • EdgeCounting
Public Attributes | List of all members
JY5113CoreOO::EdgeCounting Class Reference

Configure CI EdgeCounting. More...

#include <JY5113CoreOOCITask.h>

Public Attributes

int InitialCount
Initial Count.
CountDirection Direction
Counter direction.
EdgeType ActiveEdge
The avtive edge of the input signal, the counter will count up or down on this edge.
PauseTrigger * Pause
Pause Trigger Configuration.
EdgeCountingOutEvent * OutEvent
Edge counting output event.
JY5113CoreOO::InputTerminal DirTerminal
Terminal of External Count Diretion Control.
JY5113CoreOO::InputTerminal Input_Terminal
Input Terminal.

Detailed Description

Configure CI EdgeCounting.

Member Data Documentation

◆ ActiveEdge

EdgeType JY5113CoreOO::EdgeCounting::ActiveEdge

The avtive edge of the input signal, the counter will count up or down on this edge.

◆ Direction

CountDirection JY5113CoreOO::EdgeCounting::Direction

Counter direction.

enum Up/Down/External

◆ DirTerminal

JY5113CoreOO::InputTerminal JY5113CoreOO::EdgeCounting::DirTerminal

Terminal of External Count Diretion Control.

Valid when Direction is CountDirection.External

◆ InitialCount

int JY5113CoreOO::EdgeCounting::InitialCount

Initial Count.

◆ Input_Terminal

JY5113CoreOO::InputTerminal JY5113CoreOO::EdgeCounting::Input_Terminal

Input Terminal.

◆ OutEvent

EdgeCountingOutEvent* JY5113CoreOO::EdgeCounting::OutEvent

Edge counting output event.

A pulse will be generated when the count value reaches specified threshold

◆ Pause

PauseTrigger* JY5113CoreOO::EdgeCounting::Pause

Pause Trigger Configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOCITask.h


5113 C++ Programming Manual: JY5113CoreOO::FrequencyMeas Class Reference

  • FrequencyMeas
Public Attributes | List of all members
JY5113CoreOO::FrequencyMeas Class Reference

Configure CI Measure. More...

#include <JY5113CoreOOCITask.h>

Public Attributes

CITimebase * Timebase
Timebase configuration.
JY5113CoreOO::InputTerminal Input_Terminal
Input Terminal.

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ Input_Terminal

JY5113CoreOO::InputTerminal JY5113CoreOO::FrequencyMeas::Input_Terminal

Input Terminal.

◆ Timebase

CITimebase* JY5113CoreOO::FrequencyMeas::Timebase

Timebase configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOCITask.h


5113 C++ Programming Manual: JY5113CoreOO::PeriodMeas Class Reference

  • PeriodMeas
Public Attributes | List of all members
JY5113CoreOO::PeriodMeas Class Reference

Configure CI Measure. More...

#include <JY5113CoreOOCITask.h>

Public Attributes

CITimebase * Timebase
Timebase configuration.
JY5113CoreOO::InputTerminal Input_Terminal
Input Terminal.

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ Input_Terminal

JY5113CoreOO::InputTerminal JY5113CoreOO::PeriodMeas::Input_Terminal

Input Terminal.

◆ Timebase

CITimebase* JY5113CoreOO::PeriodMeas::Timebase

Timebase configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOCITask.h


5113 C++ Programming Manual: JY5113CoreOO::PulseMeas Class Reference

  • PulseMeas
Public Attributes | List of all members
JY5113CoreOO::PulseMeas Class Reference

Configure CI Measure. More...

#include <JY5113CoreOOCITask.h>

Public Attributes

CITimebase * Timebase
Timebase configuration.
EdgeType StartingEdge
JY5113CoreOO::InputTerminal Input_Terminal
Input Terminal.

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ Input_Terminal

JY5113CoreOO::InputTerminal JY5113CoreOO::PulseMeas::Input_Terminal

Input Terminal.

◆ StartingEdge

EdgeType JY5113CoreOO::PulseMeas::StartingEdge

◆ Timebase

CITimebase* JY5113CoreOO::PulseMeas::Timebase

Timebase configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOCITask.h


5113 C++ Programming Manual: JY5113CoreOO::SemiPeriodMeas Class Reference

  • SemiPeriodMeas
Public Attributes | Friends | List of all members
JY5113CoreOO::SemiPeriodMeas Class Reference

Configure CI Measure. More...

#include <JY5113CoreOOCITask.h>

Public Attributes

CITimebase * Timebase
Timebase configuration.
EdgeType StartingEdge
The start edge of the input signal, the counter will count up or down on this edge.
InputTerminal Input_Terminal
Input Terminal.

Friends

class JY5113CoreOOCITask

Detailed Description

Configure CI Measure.

Friends And Related Symbol Documentation

◆ JY5113CoreOOCITask

friend class JY5113CoreOOCITask
friend

Member Data Documentation

◆ Input_Terminal

InputTerminal JY5113CoreOO::SemiPeriodMeas::Input_Terminal

Input Terminal.

◆ StartingEdge

EdgeType JY5113CoreOO::SemiPeriodMeas::StartingEdge

The start edge of the input signal, the counter will count up or down on this edge.

◆ Timebase

CITimebase* JY5113CoreOO::SemiPeriodMeas::Timebase

Timebase configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOCITask.h


5113 C++ Programming Manual: JY5113CoreOO::TwoEdgeSeparation Class Reference

  • TwoEdgeSeparation
Public Attributes | List of all members
JY5113CoreOO::TwoEdgeSeparation Class Reference

Configure CI Measure. More...

#include <JY5113CoreOOCITask.h>

Public Attributes

CITimebase * Timebase
Timebase configuration.
InputTerminal FirstInputTerminal
Input Terminal.
InputTerminal SecondInputTerminal
Input Terminal.
ValueReturnMode EdgeSeparationMode

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ EdgeSeparationMode

ValueReturnMode JY5113CoreOO::TwoEdgeSeparation::EdgeSeparationMode

数据返回模式

data return mode

◆ FirstInputTerminal

InputTerminal JY5113CoreOO::TwoEdgeSeparation::FirstInputTerminal

Input Terminal.

◆ SecondInputTerminal

InputTerminal JY5113CoreOO::TwoEdgeSeparation::SecondInputTerminal

Input Terminal.

◆ Timebase

CITimebase* JY5113CoreOO::TwoEdgeSeparation::Timebase

Timebase configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOCITask.h


5113 C++ Programming Manual: JY5113CoreOO::QuadEncoder Class Reference

  • QuadEncoder
Public Attributes | List of all members
JY5113CoreOO::QuadEncoder Class Reference

Configure CI Measure. More...

#include <JY5113CoreOOCITask.h>

Public Attributes

QuadEncodingType EncodingType
Type of Encoding.
bool | ZReloadEnabled
In Encoder mode ,the Z signal enable.
int | InitialCount
Initial Count.
InputTerminal AInputTerminal
Input Terminal.
InputTerminal BInputTerminal
Input Terminal.
InputTerminal ZInputTerminal
Input Terminal.

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ AInputTerminal

InputTerminal JY5113CoreOO::QuadEncoder::AInputTerminal

Input Terminal.

◆ BInputTerminal

InputTerminal JY5113CoreOO::QuadEncoder::BInputTerminal

Input Terminal.

◆ EncodingType

QuadEncodingType JY5113CoreOO::QuadEncoder::EncodingType

Type of Encoding.

◆ InitialCount

int JY5113CoreOO::QuadEncoder::InitialCount

Initial Count.

◆ ZInputTerminal

InputTerminal JY5113CoreOO::QuadEncoder::ZInputTerminal

Input Terminal.

◆ ZReloadEnabled

bool JY5113CoreOO::QuadEncoder::ZReloadEnabled

In Encoder mode ,the Z signal enable.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOCITask.h


5113 C++ Programming Manual: JY5113CoreOO::TwoPulseEncoder Class Reference

  • TwoPulseEncoder
Public Attributes | List of all members
JY5113CoreOO::TwoPulseEncoder Class Reference

Configure CI Measure. More...

#include <JY5113CoreOOCITask.h>

Public Attributes

int InitialCount
Initial Count.
InputTerminal AInputTerminal
Input Terminal.
InputTerminal BInputTerminal
Input Terminal.

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ AInputTerminal

InputTerminal JY5113CoreOO::TwoPulseEncoder::AInputTerminal

Input Terminal.

◆ BInputTerminal

InputTerminal JY5113CoreOO::TwoPulseEncoder::BInputTerminal

Input Terminal.

◆ InitialCount

int JY5113CoreOO::TwoPulseEncoder::InitialCount

Initial Count.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOCITask.h


5113 C++ Programming Manual: JY5113CoreOO::CITrigger Class Reference

  • CITrigger
Public Attributes | List of all members
JY5113CoreOO::CITrigger Class Reference

Constructor to create an CITrigger task object. More...

#include <JY5113CoreOOCITask.h>

Public Attributes

CITriggerType Type
CI trigger type.
CIDigitalTrigger * Digital
CI Digital Trigger.

Detailed Description

Constructor to create an CITrigger task object.

Used to build CI Trigger

Member Data Documentation

◆ Digital

CIDigitalTrigger* JY5113CoreOO::CITrigger::Digital

CI Digital Trigger.

Valid when Type is CITriggerType.Digital

◆ Type

CITriggerType JY5113CoreOO::CITrigger::Type

CI trigger type.

enum Immediate/Digital/Soft.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOCITask.h


5113 C++ Programming Manual: JY5113CoreOO::CIDigitalTrigger Class Reference

  • CIDigitalTrigger
Public Attributes | List of all members
JY5113CoreOO::CIDigitalTrigger Class Reference

CI Digital trigger . More...

#include <JY5113CoreOOCITask.h>

Public Attributes

CIDigitalTriggerSource Source
CI Digital Trigger source.
CIDigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Detailed Description

CI Digital trigger .

Member Data Documentation

◆ Edge

CIDigitalTriggerEdge JY5113CoreOO::CIDigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

CIDigitalTriggerSource JY5113CoreOO::CIDigitalTrigger::Source

CI Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOCITask.h


5113 C++ Programming Manual: JY5113CoreOO::EdgeCountingOutEvent Class Reference

  • EdgeCountingOutEvent
Public Attributes | List of all members
JY5113CoreOO::EdgeCountingOutEvent Class Reference

Edge counting output event configuration class. More...

#include <JY5113CoreOOCITask.h>

Public Attributes

EdgeCntOunEvtIdleState IdleState
Output idle state when the event has not occurred.
uint32_t Threshold
Comparison threshold.
IOTerminal Terminal
Terminal.

Detailed Description

Edge counting output event configuration class.

Member Data Documentation

◆ IdleState

EdgeCntOunEvtIdleState JY5113CoreOO::EdgeCountingOutEvent::IdleState

Output idle state when the event has not occurred.

The default value is EdgeCntOunEvtIdleState.LowLevel

◆ Terminal

IOTerminal JY5113CoreOO::EdgeCountingOutEvent::Terminal

Terminal.

◆ Threshold

uint32_t JY5113CoreOO::EdgeCountingOutEvent::Threshold

Comparison threshold.

The default value is 2^32-1

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOCITask.h


5113 C++ Programming Manual: JY5113CoreOO::CIExternalTimebase Class Reference

  • CIExternalTimebase
Public Member Functions | Public Attributes | List of all members
JY5113CoreOO::CIExternalTimebase Class Reference

#include <JY5113CoreOOCITask.h>

Public Member Functions

CIExternalTimebase ()

Public Attributes

InputTerminal Terminal
double Frequency

Constructor & Destructor Documentation

◆ CIExternalTimebase()

JY5113CoreOO::CIExternalTimebase::CIExternalTimebase ( )
inline

Member Data Documentation

◆ Frequency

double JY5113CoreOO::CIExternalTimebase::Frequency

外部时基的频率

Frequency of The External Timebase

◆ Terminal

InputTerminal JY5113CoreOO::CIExternalTimebase::Terminal

外部时基的输入端口

External Timebase Input Terminal

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOCITask.h


5113 C++ Programming Manual: JY5113CoreOO::CITimebase Class Reference

  • CITimebase
Public Attributes | List of all members
JY5113CoreOO::CITimebase Class Reference

Timebase configuration class. More...

#include <JY5113CoreOOCITask.h>

Public Attributes

CITimebaseSource Source
Timebase Source.
CIExternalTimebase * External
JY5113CoreOOProperty< CITimebase, double, JY5113CoreOOPropertyType::READ_ONLY > ActualFreq

Detailed Description

Timebase configuration class.

Member Data Documentation

◆ ActualFreq

JY5113CoreOOProperty<CITimebase, double, JY5113CoreOOPropertyType::READ_ONLY> JY5113CoreOO::CITimebase::ActualFreq

◆ External

CIExternalTimebase* JY5113CoreOO::CITimebase::External

外部时基配置。当 CITimebase.Source 为 CITimebaseSource.External时有效。

External Timebase Configuration. Valid when CITimebase.Source is COTimebaseSource.External.

◆ Source

CITimebaseSource JY5113CoreOO::CITimebase::Source

Timebase Source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOCITask.h


5113 C++ Programming Manual: JY5113CoreOO::CISignalExport Class Reference

  • CISignalExport
Public Member Functions | List of all members
JY5113CoreOO::CISignalExport Class Reference

CI Signal Export Class. More...

#include <JY5113CoreOOCITask.h>

Public Member Functions

void | Add (CISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (CISignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

CI Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY5113CoreOO::CISignalExport::Add | ( | CISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | CI Signal Source
destination | Export Desination

◆ Add() [2/2]

void JY5113CoreOO::CISignalExport::Add | ( | CISignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | CI Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JY5113CoreOO::CISignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5113CoreOO::CISignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOCITask.h


5113 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOCommon.h File Reference

  • File List
  • File Members
  • COO
  • 5113
Classes | Namespaces | Macros | Enumerations | Functions
JY5113CoreOOCommon.h File Reference
#include <string>
#include <stdint.h>

Classes

class | JY5113CoreOO::JYDriverException
class | JY5113CoreOO::JY5113CoreOOProperty< ContainerClass, ValueType, propertyType >
属性模板类 More...
class | JY5113CoreOO::PauseTrigger
Pause trigger configuration class. More...

Namespaces

namespace JY5113CoreOO

Macros

#define | EXTERN_C extern
Windows.
#define | JY5113CoreOO_API

Enumerations

enum class | JY5113CoreOO::JY5113CoreOOPropertyType { JY5113CoreOO::READ_ONLY = 1 , JY5113CoreOO::WRITE_ONLY = 2 , JY5113CoreOO::READ_WRITE = 3 }
enum class JY5113CoreOO::JYDriverExceptionPublic {
JY5113CoreOO::UnKnown = 0 , JY5113CoreOO::OpenDeviceFailed = -10001 , JY5113CoreOO::CloseDeviceFailed = -10002 , JY5113CoreOO::ResetDeviceFailed = -10003 ,
JY5113CoreOO::GetDevicePropertyFailed = -10004 , JY5113CoreOO::SetDevicePropertyFailed = -10005 , JY5113CoreOO::HardwareResourceIsReserved = -10006 , JY5113CoreOO::MethodNotPermitedToCallWhenCurrentStatus = -10007 ,
JY5113CoreOO::InvalidUserDataBuffer = -10008 , JY5113CoreOO::NoChannelAdded = -10009 , JY5113CoreOO::NotSupportOperationForCurrentDevice = -10010 , JY5113CoreOO::CreatTaskFailed = -10100 ,
JY5113CoreOO::StartTaskFailed = -10101 , JY5113CoreOO::StopTaskFailed = -10102 , JY5113CoreOO::TaskHasNotStarted = -10103 , JY5113CoreOO::TaskHasStartedCannotPerformTheSetOperation = -10104 ,
JY5113CoreOO::ChannelNumberParameterInvalid = -10105 , JY5113CoreOO::ChannelInputRangeParameterInvalid = -10106 , JY5113CoreOO::ChannelTerminalParameterInvalid = -10107 , JY5113CoreOO::ChannelCouplingParameterInvalid = -10108 ,
JY5113CoreOO::SampeleModeParameterInvalid = -10109 , JY5113CoreOO::SampleClockParameterInvalid = -10110 , JY5113CoreOO::SampleRateParameterInvalid = -10111 , JY5113CoreOO::UpdateRateParameterInvalid = -10112 ,
JY5113CoreOO::TriggerParameterInvalid = -10113 , JY5113CoreOO::ReferenceTriggerDoesNotMatchWithSampleMode = -10114 , JY5113CoreOO::PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint = -10115 , JY5113CoreOO::ReadDataFailed = -10016 ,
JY5113CoreOO::ReadDataTimeout = -10017 , JY5113CoreOO::WriteDataFailed = -10018 , JY5113CoreOO::WriteDataTimeout = -10019 , JY5113CoreOO::WriteDataLengthCannotBeLessThanN = -10020 ,
JY5113CoreOO::BufferDataOverflow = -10021 , JY5113CoreOO::BufferDataDownflow = -10022 , JY5113CoreOO::CheckBufferFailed = -10023 , JY5113CoreOO::PointInvalidInFiniteMode = -10024 ,
JY5113CoreOO::ReadPointInvalid = -10025 , JY5113CoreOO::OnlySupportRecordMode = -10026 , JY5113CoreOO::SendSoftTirggerFailed = -10027 , JY5113CoreOO::TaskTimeout = -10028 ,
JY5113CoreOO::CounterParametersInvalid = -10029 , JY5113CoreOO::WritePointInvalid = -10030 , JY5113CoreOO::SignalExportDestinationInvalid = -10031 , JY5113CoreOO::InvalidParameter = -10033
}
enum class JY5113CoreOO::ClockTerminal {
JY5113CoreOO::PFI0 , JY5113CoreOO::PFI1 , JY5113CoreOO::PFI2 , JY5113CoreOO::PFI3 ,
JY5113CoreOO::PFI4 , JY5113CoreOO::PFI5 , JY5113CoreOO::PFI6 , JY5113CoreOO::PFI7 ,
JY5113CoreOO::PFI8 , JY5113CoreOO::PFI9 , JY5113CoreOO::PFI10 , JY5113CoreOO::PFI11 ,
JY5113CoreOO::PFI12 , JY5113CoreOO::PFI13 , JY5113CoreOO::PFI14 , JY5113CoreOO::PFI15 ,
JY5113CoreOO::PXI_Trig0 , JY5113CoreOO::PXI_Trig1 , JY5113CoreOO::PXI_Trig2 , JY5113CoreOO::PXI_Trig3 ,
JY5113CoreOO::PXI_Trig4 , JY5113CoreOO::PXI_Trig5 , JY5113CoreOO::PXI_Trig6 , JY5113CoreOO::PXI_Trig7 ,
JY5113CoreOO::AI_SampleClock , JY5113CoreOO::AO_SampleClock , JY5113CoreOO::DI_SampleClock , JY5113CoreOO::DO_SampleClock ,
JY5113CoreOO::CI0_SampleClock , JY5113CoreOO::CI1_SampleClock , JY5113CoreOO::CI2_SampleClock , JY5113CoreOO::CI3_SampleClock ,
JY5113CoreOO::CO0_Output , JY5113CoreOO::CO1_Output , JY5113CoreOO::CO2_Output , JY5113CoreOO::CO3_Output
}
enum class JY5113CoreOO::SignalExportDestination {
JY5113CoreOO::PFI0 , JY5113CoreOO::PFI1 , JY5113CoreOO::PFI2 , JY5113CoreOO::PFI3 ,
JY5113CoreOO::PFI4 , JY5113CoreOO::PFI5 , JY5113CoreOO::PFI6 , JY5113CoreOO::PFI7 ,
JY5113CoreOO::PFI8 , JY5113CoreOO::PFI9 , JY5113CoreOO::PFI10 , JY5113CoreOO::PFI11 ,
JY5113CoreOO::PFI12 , JY5113CoreOO::PFI13 , JY5113CoreOO::PFI14 , JY5113CoreOO::PFI15 ,
JY5113CoreOO::PXI_Trig0 , JY5113CoreOO::PXI_Trig1 , JY5113CoreOO::PXI_Trig2 , JY5113CoreOO::PXI_Trig3 = 29 ,
JY5113CoreOO::PXI_Trig4 = 20 , JY5113CoreOO::PXI_Trig5 , JY5113CoreOO::PXI_Trig6 , JY5113CoreOO::PXI_Trig7
}
enum class | JY5113CoreOO::OutputCompleteState { JY5113CoreOO::Zero , JY5113CoreOO::Hold }
Output Complete State. More...
enum class JY5113CoreOO::IOTerminal {
JY5113CoreOO::PFI0 , JY5113CoreOO::PFI1 , JY5113CoreOO::PFI2 , JY5113CoreOO::PFI3 ,
JY5113CoreOO::PFI4 , JY5113CoreOO::PFI5 , JY5113CoreOO::PFI6 , JY5113CoreOO::PFI7 ,
JY5113CoreOO::PFI8 , JY5113CoreOO::PFI9 , JY5113CoreOO::PFI10 , JY5113CoreOO::PFI11 ,
JY5113CoreOO::PFI12 , JY5113CoreOO::PFI13 , JY5113CoreOO::PFI14 , JY5113CoreOO::PFI15 ,
JY5113CoreOO::PXI_Trig0 , JY5113CoreOO::PXI_Trig1 , JY5113CoreOO::PXI_Trig2 , JY5113CoreOO::PXI_Trig3 ,
JY5113CoreOO::PXI_Trig4 , JY5113CoreOO::PXI_Trig5 , JY5113CoreOO::PXI_Trig6 , JY5113CoreOO::PXI_Trig7 ,
JY5113CoreOO::None
}
Cunter IO Terminal. More...
enum class | JY5113CoreOO::LevelPolarity { JY5113CoreOO::LowLevel = 0 , JY5113CoreOO::HighLevel = 1 , JY5113CoreOO::None = 2 }
Level Polarity. More...

Functions

std::string JY5113CoreOO::GetSignalExportDestinationString (SignalExportDestination destination)

Macro Definition Documentation

◆ EXTERN_C

#define EXTERN_C extern

Windows.

Linux

◆ JY5113CoreOO_API

#define JY5113CoreOO_API


5113 C++ Programming Manual: JY5113CoreOO::JYDriverException Class Reference

  • JYDriverException
Public Member Functions | Public Attributes | List of all members
JY5113CoreOO::JYDriverException Class Reference

#include <JY5113CoreOOCommon.h>

Public Member Functions

JYDriverException (JYDriverExceptionPublic exceptionCode, std::string msg="")
JYDriverException (int, std::string msg)

Public Attributes

std::string exceptionMessage
JYDriverExceptionPublic errorCode
JYDriverException * FollowingException

Constructor & Destructor Documentation

◆ JYDriverException() [1/2]

JY5113CoreOO::JYDriverException::JYDriverException | ( | JYDriverExceptionPublic | exceptionCode,
 |  | std::string | msg = "" )

◆ JYDriverException() [2/2]

JY5113CoreOO::JYDriverException::JYDriverException | ( | int | ,
 |  | std::string | msg )

Member Data Documentation

◆ errorCode

JYDriverExceptionPublic JY5113CoreOO::JYDriverException::errorCode

◆ exceptionMessage

std::string JY5113CoreOO::JYDriverException::exceptionMessage

◆ FollowingException

JYDriverException* JY5113CoreOO::JYDriverException::FollowingException
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOCommon.h


5113 C++ Programming Manual: JY5113CoreOO::JY5113CoreOOProperty< ContainerClass, ValueType, propertyType > Class Template Reference

  • JY5113CoreOOProperty
Public Member Functions | List of all members
JY5113CoreOO::JY5113CoreOOProperty< ContainerClass, ValueType, propertyType > Class Template Reference

属性模板类 More...

#include <JY5113CoreOOCommon.h>

Public Member Functions

JY5113CoreOOProperty ()
JY5113CoreOOProperty (ContainerClass *cObject, ValueType(ContainerClass::*pGet)(), void(ContainerClass::*pSet)(ValueType value))
JY5113CoreOOProperty (ValueType(*pGet)(), void(*pSet)(ValueType value))
ValueType operator= (const ValueType &value)
operator ValueType ()

Detailed Description

template<typename ContainerClass, typename ValueType, JY5113CoreOOPropertyType propertyType>
class JY5113CoreOO::JY5113CoreOOProperty< ContainerClass, ValueType, propertyType >

属性模板类

Constructor & Destructor Documentation

◆ JY5113CoreOOProperty() [1/3]

template<typename ContainerClass, typename ValueType, JY5113CoreOOPropertyType propertyType>
JY5113CoreOO::JY5113CoreOOProperty< ContainerClass, ValueType, propertyType >::JY5113CoreOOProperty ( )

◆ JY5113CoreOOProperty() [2/3]

template<typename ContainerClass, typename ValueType, JY5113CoreOOPropertyType propertyType>
JY5113CoreOO::JY5113CoreOOProperty< ContainerClass, ValueType, propertyType >::JY5113CoreOOProperty | ( | ContainerClass * | cObject,
 |  | ValueType(ContainerClass::* | pGet )(),
 |  | void(ContainerClass::* | pSet )(ValueType value) )

◆ JY5113CoreOOProperty() [3/3]

template<typename ContainerClass, typename ValueType, JY5113CoreOOPropertyType propertyType>
JY5113CoreOO::JY5113CoreOOProperty< ContainerClass, ValueType, propertyType >::JY5113CoreOOProperty | ( | ValueType(* | pGet )(),
 |  | void(* | pSet )(ValueType value) )

Member Function Documentation

◆ operator ValueType()

template<typename ContainerClass, typename ValueType, JY5113CoreOOPropertyType propertyType>
JY5113CoreOO::JY5113CoreOOProperty< ContainerClass, ValueType, propertyType >::operator ValueType ( )

◆ operator=()

template<typename ContainerClass, typename ValueType, JY5113CoreOOPropertyType propertyType>
ValueType JY5113CoreOO::JY5113CoreOOProperty< ContainerClass, ValueType, propertyType >::operator= ( const ValueType & value )
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOCommon.h


5113 C++ Programming Manual: JY5113CoreOO::PauseTrigger Class Reference

  • PauseTrigger
Public Attributes | List of all members
JY5113CoreOO::PauseTrigger Class Reference

Pause trigger configuration class. More...

#include <JY5113CoreOOCommon.h>

Public Attributes

LevelPolarity ActivePolarity
Pause trigger active polarity.
InputTerminal Terminal
Terminal.

Detailed Description

Pause trigger configuration class.

Member Data Documentation

◆ ActivePolarity

LevelPolarity JY5113CoreOO::PauseTrigger::ActivePolarity

Pause trigger active polarity.

The default value is LevelPolarity.None, means the pause trigger is disabled.

◆ Terminal

InputTerminal JY5113CoreOO::PauseTrigger::Terminal

Terminal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOCommon.h


5113 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOCOTask.h File Reference

  • File List
  • File Members
  • COO
  • 5113
Classes | Namespaces | Enumerations
JY5113CoreOOCOTask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JY5113CoreOOCommon.h"
#include "JY5113CoreOODevice.h"

Classes

class | JY5113CoreOO::JY5113CoreOOCOTask
class | JY5113CoreOO::CODigitalTrigger
CO Digital trigger . More...
class | JY5113CoreOO::COTrigger
Constructor to create an COTrigger task object. More...
class | JY5113CoreOO::COPulse
Pulse Parameter. More...
class | JY5113CoreOO::COExternalTimebase
class | JY5113CoreOO::COTimebase
Timebase configuration class. More...
class | JY5113CoreOO::COSignalExport
CO Signal Export Class. More...

Namespaces

namespace JY5113CoreOO

Enumerations

enum class | JY5113CoreOO::COIdleState { JY5113CoreOO::HighLevel = 0x1 , JY5113CoreOO::LowLevel = 0x0 }
Idle state when pulse output before start and after stop. More...
enum class | JY5113CoreOO::COMode { JY5113CoreOO::Single = 3 , JY5113CoreOO::Finite = 0 , JY5113CoreOO::ContinuousNoWrapping = 2 , JY5113CoreOO::ContinuousWrapping = 1 }
enum class | JY5113CoreOO::COTriggerType { JY5113CoreOO::Immediate = 0x0 , JY5113CoreOO::Digital = 0x1 , JY5113CoreOO::Soft = 0x3 }
TriggerType Digital/Immediate/Soft. More...
enum class JY5113CoreOO::CODigitalTriggerSource {
JY5113CoreOO::PFI0 , JY5113CoreOO::PFI1 , JY5113CoreOO::PFI2 , JY5113CoreOO::PFI3 ,
JY5113CoreOO::PFI4 , JY5113CoreOO::PFI5 , JY5113CoreOO::PFI6 , JY5113CoreOO::PFI7 ,
JY5113CoreOO::PFI8 , JY5113CoreOO::PFI9 , JY5113CoreOO::PFI10 , JY5113CoreOO::PFI11 ,
JY5113CoreOO::PFI12 , JY5113CoreOO::PFI13 , JY5113CoreOO::PFI14 , JY5113CoreOO::PFI15 ,
JY5113CoreOO::PXI_Trig0 , JY5113CoreOO::PXI_Trig1 , JY5113CoreOO::PXI_Trig2 , JY5113CoreOO::PXI_Trig3 ,
JY5113CoreOO::PXI_Trig4 , JY5113CoreOO::PXI_Trig5 , JY5113CoreOO::PXI_Trig6 , JY5113CoreOO::PXI_Trig7 ,
JY5113CoreOO::AI_StartTrig , JY5113CoreOO::AI_ReferenceTrig , JY5113CoreOO::DI_StartTrig , JY5113CoreOO::DI_ReferenceTrig ,
JY5113CoreOO::AO_StartTrig , JY5113CoreOO::DO_StartTrig , JY5113CoreOO::CIO_0_StartTrig , JY5113CoreOO::CIO_1_StartTrig = 31 ,
JY5113CoreOO::CO_0_Out = 34 , JY5113CoreOO::CO_1_Out = 35
}
CO Digital trigger source. More...
enum class | JY5113CoreOO::CODigitalTriggerEdge { JY5113CoreOO::Rising , JY5113CoreOO::Falling }
CO Digital Trigger Edge. More...
enum class | JY5113CoreOO::COPulseType { JY5113CoreOO::DutyCycleFrequency , JY5113CoreOO::HighLowTime , JY5113CoreOO::HighLowTick }
Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick. More...
enum class | JY5113CoreOO::COTimebaseSource { JY5113CoreOO::Internal100MHz = 0 , JY5113CoreOO::Internal5MHz = 1 , JY5113CoreOO::Internal100kHz = 2 , JY5113CoreOO::External = 3 }
Timebase source. More...
enum class | JY5113CoreOO::COSignalExportSource { JY5113CoreOO::StartTrig , JY5113CoreOO::Output }
SourceSignal. More...


5113 C++ Programming Manual: JY5113CoreOO::JY5113CoreOOCOTask Class Reference

  • JY5113CoreOOCOTask
Public Member Functions | Public Attributes | List of all members
JY5113CoreOO::JY5113CoreOOCOTask Class Reference

#include <JY5113CoreOOCOTask.h>

Public Member Functions

JY5113CoreOOCOTask (int slotNum, int channel)
JY5113CoreOOCOTask (std::string boardName, int channel)
~JY5113CoreOOCOTask ()
void | WriteSinglePoint (COPulse &pulse)
Write a single pulse parameter to the register.
void | WriteData (COPulse *pulsesGroup[], int samplesToWrite, int timeout=10000)
Write pulse parameters to be output to the buffer.
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Start ()
Start CO task .
void | Stop ()
Stop COtask .
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.

Public Attributes

COMode Mode
CO output mode.
IOTerminal OutputTerminal
PauseTrigger * Pause
COTimebase * Timebase
CO's time base.
double | InitialDelay
Counter output initial delay in seconds.
COIdleState IdleState
Idle state when pulse output before start and after stop.
uint32_t | SamplesToUpdate
有限频率输出
JY5113CoreOOProperty< JY5113CoreOOCOTask, uint32_t, JY5113CoreOOPropertyType::READ_ONLY > | AvailableSamples
Number of points per channel that can be read in the buffer .
JY5113CoreOOProperty< JY5113CoreOOCOTask, uint64_t, JY5113CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
JY5113CoreOOProperty< JY5113CoreOOCOTask, uint32_t, JY5113CoreOOPropertyType::READ_ONLY > | TransferedPulses
COTrigger * Trigger
CO trigger property configured by CO Trigger().
JY5113CoreOODevice * Device
Device.
COSignalExport * SignalExport
Export CO Signal Configuration.

Constructor & Destructor Documentation

◆ JY5113CoreOOCOTask() [1/2]

JY5113CoreOO::JY5113CoreOOCOTask::JY5113CoreOOCOTask | ( | int | slotNum,
 |  | int | channel )

◆ JY5113CoreOOCOTask() [2/2]

JY5113CoreOO::JY5113CoreOOCOTask::JY5113CoreOOCOTask | ( | std::string | boardName,
 |  | int | channel )

◆ ~JY5113CoreOOCOTask()

JY5113CoreOO::JY5113CoreOOCOTask::~JY5113CoreOOCOTask ( )

Member Function Documentation

◆ SendSoftwareTrigger()

void JY5113CoreOO::JY5113CoreOOCOTask::SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5113CoreOO::JY5113CoreOOCOTask::Start ( )

Start CO task .

◆ Stop()

void JY5113CoreOO::JY5113CoreOOCOTask::Stop ( )

Stop COtask .

◆ WaitUntilDone()

bool JY5113CoreOO::JY5113CoreOOCOTask::WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteData()

void JY5113CoreOO::JY5113CoreOOCOTask::WriteData | ( | COPulse * | pulsesGroup[],
 |  | int | samplesToWrite,
 |  | int | timeout = 10000 )

Write pulse parameters to be output to the buffer.

Valid when Mode is NOT COMode.Single. When Mode is COMode.Finite or COMode.ContinuousWrapping, this function can only be called once before starting the task.

Parameters
pulsesGroup | A group of pulse parameters
samplesToWrite | Number of samples to write. If Mode is COMode.ContinuousWrapping, you need to write at least 2 samples before starting the task
timeout | Timeout (ms). Wait until all data is written to buffer or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ WriteSinglePoint()

void JY5113CoreOO::JY5113CoreOOCOTask::WriteSinglePoint ( COPulse & pulse )

Write a single pulse parameter to the register.

Valid when Mode is COMode.Single. This function is also available after starting the task when the number of pulses being sent is infinite.

Parameters
pulse Pulse Parameter

Member Data Documentation

◆ AvailableSamples

JY5113CoreOOProperty<JY5113CoreOOCOTask, uint32_t, JY5113CoreOOPropertyType::READ_ONLY> JY5113CoreOO::JY5113CoreOOCOTask::AvailableSamples

Number of points per channel that can be read in the buffer .

◆ Device

JY5113CoreOODevice* JY5113CoreOO::JY5113CoreOOCOTask::Device

Device.

◆ IdleState

COIdleState JY5113CoreOO::JY5113CoreOOCOTask::IdleState

Idle state when pulse output before start and after stop.

◆ InitialDelay

double JY5113CoreOO::JY5113CoreOOCOTask::InitialDelay

Counter output initial delay in seconds.

There are five ticks of the timebase fixed delay in counter internal, so the total delay(s) = InitialDelay + (5 / timebase)

◆ Mode

COMode JY5113CoreOO::JY5113CoreOOCOTask::Mode

CO output mode.

◆ OutputTerminal

IOTerminal JY5113CoreOO::JY5113CoreOOCOTask::OutputTerminal

脉冲输出端口

Pulse Output Terminal

◆ Pause

PauseTrigger* JY5113CoreOO::JY5113CoreOOCOTask::Pause

暂停触发配置

Pause Trigger Configuration

◆ SamplesToUpdate

uint32_t JY5113CoreOO::JY5113CoreOOCOTask::SamplesToUpdate

有限频率输出

◆ SignalExport

COSignalExport* JY5113CoreOO::JY5113CoreOOCOTask::SignalExport

Export CO Signal Configuration.

◆ Timebase

COTimebase* JY5113CoreOO::JY5113CoreOOCOTask::Timebase

CO's time base.

◆ TransferedPulses

JY5113CoreOOProperty<JY5113CoreOOCOTask, uint32_t, JY5113CoreOOPropertyType::READ_ONLY> JY5113CoreOO::JY5113CoreOOCOTask::TransferedPulses

当前配置下已发送的脉冲的数量。

The number of pulses transfered under the current configuration.

◆ TransferedSamples

JY5113CoreOOProperty<JY5113CoreOOCOTask, uint64_t, JY5113CoreOOPropertyType::READ_ONLY> JY5113CoreOO::JY5113CoreOOCOTask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT CIMode.Single.

◆ Trigger

COTrigger* JY5113CoreOO::JY5113CoreOOCOTask::Trigger

CO trigger property configured by CO Trigger().

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOCOTask.h


5113 C++ Programming Manual: JY5113CoreOO::CODigitalTrigger Class Reference

  • CODigitalTrigger
Public Attributes | List of all members
JY5113CoreOO::CODigitalTrigger Class Reference

CO Digital trigger . More...

#include <JY5113CoreOOCOTask.h>

Public Attributes

CODigitalTriggerSource Source
CO Digital Trigger source.
CODigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Detailed Description

CO Digital trigger .

Member Data Documentation

◆ Edge

CODigitalTriggerEdge JY5113CoreOO::CODigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

CODigitalTriggerSource JY5113CoreOO::CODigitalTrigger::Source

CO Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOCOTask.h


5113 C++ Programming Manual: JY5113CoreOO::COTrigger Class Reference

  • COTrigger
Public Attributes | List of all members
JY5113CoreOO::COTrigger Class Reference

Constructor to create an COTrigger task object. More...

#include <JY5113CoreOOCOTask.h>

Public Attributes

COTriggerType Type
CO trigger type.
CODigitalTrigger * Digital
CO Digital Trigger.

Detailed Description

Constructor to create an COTrigger task object.

Used to build CO Trigger

Member Data Documentation

◆ Digital

CODigitalTrigger* JY5113CoreOO::COTrigger::Digital

CO Digital Trigger.

Valid when Type is COTriggerType.Digital

◆ Type

COTriggerType JY5113CoreOO::COTrigger::Type

CO trigger type.

enum Immediate/Digital/Soft.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOCOTask.h


5113 C++ Programming Manual: JY5113CoreOO::COPulse Class Reference

  • COPulse
Public Member Functions | List of all members
JY5113CoreOO::COPulse Class Reference

Pulse Parameter. More...

#include <JY5113CoreOOCOTask.h>

Public Member Functions

COPulse (COPulseType type, double param1, double param2, int count)
Pulse Parameter.
COPulse ()
~COPulse ()

Detailed Description

Pulse Parameter.

Constructor & Destructor Documentation

◆ COPulse() [1/2]

JY5113CoreOO::COPulse::COPulse | ( | COPulseType | type,
 |  | double | param1,
 |  | double | param2,
 |  | int | count )

Pulse Parameter.

Parameters
type | The pulse type characteristics.
param1 | Parameter 1. Frequency (Hz) when constructed as COPulseType.DutyCycleFrequency; High duration in seconds when constructed as COPulseType.HighLowTime; High ticks of the clock when constructed as COPulseType.HighLowTick.
param2 | Parameter 1. Duty cycle (greater than 0 and less than 1) when constructed as COPulseType.DutyCycleFrequency; Low duration in seconds when constructed as COPulseType.HighLowTime; Low ticks of the clock when constructed as COPulseType.HighLowTick.
count | Number of pulses. When the value is -1 (indicating that the number of pulses is infinite), pulses will be continuously sent until requested to stop.

◆ COPulse() [2/2]

JY5113CoreOO::COPulse::COPulse ( )

◆ ~COPulse()

JY5113CoreOO::COPulse::~COPulse ( )
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOCOTask.h


5113 C++ Programming Manual: JY5113CoreOO::COExternalTimebase Class Reference

  • COExternalTimebase
Public Member Functions | Public Attributes | List of all members
JY5113CoreOO::COExternalTimebase Class Reference

#include <JY5113CoreOOCOTask.h>

Public Member Functions

COExternalTimebase ()

Public Attributes

InputTerminal Terminal
double Frequency

Constructor & Destructor Documentation

◆ COExternalTimebase()

JY5113CoreOO::COExternalTimebase::COExternalTimebase ( )
inline

Member Data Documentation

◆ Frequency

double JY5113CoreOO::COExternalTimebase::Frequency

外部时基的频率

Frequency of The External Timebase

◆ Terminal

InputTerminal JY5113CoreOO::COExternalTimebase::Terminal

外部时基的输入端口

External Timebase Input Terminal

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOCOTask.h


5113 C++ Programming Manual: JY5113CoreOO::COTimebase Class Reference

  • COTimebase
Public Attributes | List of all members
JY5113CoreOO::COTimebase Class Reference

Timebase configuration class. More...

#include <JY5113CoreOOCOTask.h>

Public Attributes

COTimebaseSource Source
Timebase Source.
COExternalTimebase * External
JY5113CoreOOProperty< COTimebase, double, JY5113CoreOOPropertyType::READ_ONLY > ActualFreq

Detailed Description

Timebase configuration class.

Member Data Documentation

◆ ActualFreq

JY5113CoreOOProperty<COTimebase, double, JY5113CoreOOPropertyType::READ_ONLY> JY5113CoreOO::COTimebase::ActualFreq

◆ External

COExternalTimebase* JY5113CoreOO::COTimebase::External

外部时基配置。当 COTimebase.Source 为 COTimebaseSource.External时有效。

External Timebase Configuration. Valid when COTimebase.Source is COTimebaseSource.External.

◆ Source

COTimebaseSource JY5113CoreOO::COTimebase::Source

Timebase Source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOCOTask.h


5113 C++ Programming Manual: JY5113CoreOO::COSignalExport Class Reference

  • COSignalExport
Public Member Functions | List of all members
JY5113CoreOO::COSignalExport Class Reference

CO Signal Export Class. More...

#include <JY5113CoreOOCOTask.h>

Public Member Functions

void | Add (COSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (COSignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

CO Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY5113CoreOO::COSignalExport::Add | ( | COSignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | CI Signal Source
destination | Export Desination

◆ Add() [2/2]

void JY5113CoreOO::COSignalExport::Add | ( | COSignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | CI Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JY5113CoreOO::COSignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5113CoreOO::COSignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOCOTask.h


5113 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOODevice.h File Reference

  • File List
  • File Members
  • COO
  • 5113
Classes | Namespaces | Enumerations
JY5113CoreOODevice.h File Reference
#include <iostream>
#include <string>
#include <list>
#include <vector>
#include "JY5113CoreOOCommon.h"

Classes

class | JY5113CoreOO::JY5113CoreOODevice
class | JY5113CoreOO::PFIFilter
class | JY5113CoreOO::PFISetting
class | JY5113CoreOO::ExternalReferenceClock
class | JY5113CoreOO::JY5113CoreOOReferenceClock

Namespaces

namespace JY5113CoreOO

Enumerations

enum class | JY5113CoreOO::ExternalReferenceClockTerminal { JY5113CoreOO::PXIe_Clk100 = 0x1 }
enum class | JY5113CoreOO::ReferenceClockSource { JY5113CoreOO::Internal = 0x0 , JY5113CoreOO::External = 0x1 }
enum class JY5113CoreOO::PFITerminal {
JY5113CoreOO::PFI0 = 0 , JY5113CoreOO::PFI1 = 1 , JY5113CoreOO::PFI2 = 2 , JY5113CoreOO::PFI3 = 3 ,
JY5113CoreOO::PFI4 = 4 , JY5113CoreOO::PFI5 = 5 , JY5113CoreOO::PFI6 = 6 , JY5113CoreOO::PFI7 = 7 ,
JY5113CoreOO::PFI8 = 8 , JY5113CoreOO::PFI9 = 9 , JY5113CoreOO::PFI10 = 10 , JY5113CoreOO::PFI11 = 11 ,
JY5113CoreOO::PFI12 = 12 , JY5113CoreOO::PFI13 = 13 , JY5113CoreOO::PFI14 = 14 , JY5113CoreOO::PFI15 = 15
}
Input/Output Terminal of PFI. More...
enum class JY5113CoreOO::InputTerminal {
JY5113CoreOO::PFI0 , JY5113CoreOO::PFI1 , JY5113CoreOO::PFI2 , JY5113CoreOO::PFI3 ,
JY5113CoreOO::PFI4 , JY5113CoreOO::PFI5 , JY5113CoreOO::PFI6 , JY5113CoreOO::PFI7 ,
JY5113CoreOO::PFI8 , JY5113CoreOO::PFI9 , JY5113CoreOO::PFI10 , JY5113CoreOO::PFI11 ,
JY5113CoreOO::PFI12 , JY5113CoreOO::PFI13 , JY5113CoreOO::PFI14 , JY5113CoreOO::PFI15 ,
JY5113CoreOO::PXI_Trig0 , JY5113CoreOO::PXI_Trig1 , JY5113CoreOO::PXI_Trig2 , JY5113CoreOO::PXI_Trig3 ,
JY5113CoreOO::PXI_Trig4 , JY5113CoreOO::PXI_Trig5 , JY5113CoreOO::PXI_Trig6 , JY5113CoreOO::PXI_Trig7 ,
JY5113CoreOO::AI_SampleClock , JY5113CoreOO::AO_SampleClock , JY5113CoreOO::DI_SampleClock , JY5113CoreOO::DO_SampleClock ,
JY5113CoreOO::CO_0_OutPut , JY5113CoreOO::CO_1_OutPut , JY5113CoreOO::CO_2_OutPut , JY5113CoreOO::CO_3_OutPut ,
JY5113CoreOO::Timebase_100MHz , JY5113CoreOO::Timebase_5MHz , JY5113CoreOO::Timebase_100kHz
}
Cunter Input Terminal. More...


5113 C++ Programming Manual: JY5113CoreOO::JY5113CoreOODevice Class Reference

  • JY5113CoreOODevice
Static Public Member Functions | Public Attributes | List of all members
JY5113CoreOO::JY5113CoreOODevice Class Reference

#include <JY5113CoreOODevice.h>

Static Public Member Functions

static JY5113CoreOODevice * | GetInstance (int cardNum)
static JY5113CoreOODevice * | GetInstance (std::string aliasName)

Public Attributes

const double | BoardClockRate = 100e6
const double | MaxSampleRate = 1E6
const int | AIBufferSize = 128E6
const bool | IsAISync = false
const double | MaxUpdateRate = 2860000
const double | MaxUpdateRateSingleChannel = 500E3
const bool | IsAOSync = false
IsAOSync.
JY5113CoreOOProperty< JY5113CoreOODevice, int, JY5113CoreOOPropertyType::READ_ONLY > | DiffChannelCount
JY5113CoreOOProperty< JY5113CoreOODevice, int, JY5113CoreOOPropertyType::READ_ONLY > | SEChannelCount
JY5113CoreOOProperty< JY5113CoreOODevice, double, JY5113CoreOOPropertyType::READ_ONLY > | MaxSampleRateSingleChannel
JY5113CoreOOProperty< JY5113CoreOODevice, int, JY5113CoreOOPropertyType::READ_ONLY > | AOChannelCount
JY5113CoreOOProperty< JY5113CoreOODevice, std::string, JY5113CoreOOPropertyType::READ_ONLY > | SerialNumber
JY5113CoreOOProperty< JY5113CoreOODevice, int, JY5113CoreOOPropertyType::READ_ONLY > | DeviceID
JY5113CoreOOProperty< JY5113CoreOODevice, void *, JY5113CoreOOPropertyType::READ_ONLY > | Handle
PFISetting * PFI
JY5113CoreOOReferenceClock * ReferenceClock

Member Function Documentation

◆ GetInstance() [1/2]

static JY5113CoreOODevice * JY5113CoreOO::JY5113CoreOODevice::GetInstance ( int cardNum )
static

◆ GetInstance() [2/2]

static JY5113CoreOODevice * JY5113CoreOO::JY5113CoreOODevice::GetInstance ( std::string aliasName )
static

Member Data Documentation

◆ AIBufferSize

const int JY5113CoreOO::JY5113CoreOODevice::AIBufferSize = 128E6

◆ AOChannelCount

JY5113CoreOOProperty<JY5113CoreOODevice, int, JY5113CoreOOPropertyType::READ_ONLY> JY5113CoreOO::JY5113CoreOODevice::AOChannelCount

◆ BoardClockRate

const double JY5113CoreOO::JY5113CoreOODevice::BoardClockRate = 100e6

◆ DeviceID

JY5113CoreOOProperty<JY5113CoreOODevice, int, JY5113CoreOOPropertyType::READ_ONLY> JY5113CoreOO::JY5113CoreOODevice::DeviceID

◆ DiffChannelCount

JY5113CoreOOProperty<JY5113CoreOODevice, int, JY5113CoreOOPropertyType::READ_ONLY> JY5113CoreOO::JY5113CoreOODevice::DiffChannelCount

◆ Handle

JY5113CoreOOProperty<JY5113CoreOODevice, void*, JY5113CoreOOPropertyType::READ_ONLY> JY5113CoreOO::JY5113CoreOODevice::Handle

◆ IsAISync

const bool JY5113CoreOO::JY5113CoreOODevice::IsAISync = false

◆ IsAOSync

const bool JY5113CoreOO::JY5113CoreOODevice::IsAOSync = false

IsAOSync.

◆ MaxSampleRate

const double JY5113CoreOO::JY5113CoreOODevice::MaxSampleRate = 1E6

◆ MaxSampleRateSingleChannel

JY5113CoreOOProperty<JY5113CoreOODevice, double, JY5113CoreOOPropertyType::READ_ONLY> JY5113CoreOO::JY5113CoreOODevice::MaxSampleRateSingleChannel

◆ MaxUpdateRate

const double JY5113CoreOO::JY5113CoreOODevice::MaxUpdateRate = 2860000

◆ MaxUpdateRateSingleChannel

const double JY5113CoreOO::JY5113CoreOODevice::MaxUpdateRateSingleChannel = 500E3

◆ PFI

PFISetting* JY5113CoreOO::JY5113CoreOODevice::PFI

◆ ReferenceClock

JY5113CoreOOReferenceClock* JY5113CoreOO::JY5113CoreOODevice::ReferenceClock

◆ SEChannelCount

JY5113CoreOOProperty<JY5113CoreOODevice, int, JY5113CoreOOPropertyType::READ_ONLY> JY5113CoreOO::JY5113CoreOODevice::SEChannelCount

◆ SerialNumber

JY5113CoreOOProperty<JY5113CoreOODevice, std::string, JY5113CoreOOPropertyType::READ_ONLY> JY5113CoreOO::JY5113CoreOODevice::SerialNumber
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOODevice.h


5113 C++ Programming Manual: JY5113CoreOO::PFIFilter Class Reference

  • PFIFilter
Public Member Functions | List of all members
JY5113CoreOO::PFIFilter Class Reference

#include <JY5113CoreOODevice.h>

Public Member Functions

void | Enable (PFITerminal terminal, int minPulseWidth)
Enable the filter on the specified terminal and set the minimum pulse width.
void | Enable (std::vector< PFITerminal > terminals, int minPulseWidth)
Enable the filter on a group of terminals and set the minimum pulse width.
void | Enable (std::vector< PFITerminal > terminals, std::vector< int > minPulseWidth)
Enable the filter on a group of terminals and set the minimum pulse width separately.
void | Disable (PFITerminal terminal)
Disable the filter on the specified terminal.
void | Disable (std::vector< PFITerminal > terminals)
Disable the filter on a group terminal.
void | DisableAll ()
Disable the filter on all the terminals.

Member Function Documentation

◆ Disable() [1/2]

void JY5113CoreOO::PFIFilter::Disable ( PFITerminal terminal )

Disable the filter on the specified terminal.

Parameters
terminal Specified Terminal

◆ Disable() [2/2]

void JY5113CoreOO::PFIFilter::Disable ( std::vector< PFITerminal > terminals )

Disable the filter on a group terminal.

Parameters
terminals Specified Group of Terminal

◆ DisableAll()

void JY5113CoreOO::PFIFilter::DisableAll ( )

Disable the filter on all the terminals.

◆ Enable() [1/3]

void JY5113CoreOO::PFIFilter::Enable | ( | PFITerminal | terminal,
 |  | int | minPulseWidth )

Enable the filter on the specified terminal and set the minimum pulse width.

Parameters
terminal | Specified Terminal
minPulseWidth | Minimum pulse width in ns, bounce less than this length will be ignored. The smallest step in the range of 10 ns to 2550 ns is 10 ns, the smallest step in the range of 2550 ns to 40800 ns is 160 ns, and the smallest step in the range of 40800 ns to 652800 ns The step is 2560 ns

◆ Enable() [2/3]

void JY5113CoreOO::PFIFilter::Enable | ( | std::vector< PFITerminal > | terminals,
 |  | int | minPulseWidth )

Enable the filter on a group of terminals and set the minimum pulse width.

Parameters
terminals | Specified Group of Terminals
minPulseWidth | Minimum pulse width in ns, bounce less than this length will be ignored. The smallest step in the range of 10 ns to 2550 ns is 10 ns, the smallest step in the range of 2550 ns to 40800 ns is 160 ns, and the smallest step in the range of 40800 ns to 652800 ns The step is 2560 ns

◆ Enable() [3/3]

void JY5113CoreOO::PFIFilter::Enable | ( | std::vector< PFITerminal > | terminals,
 |  | std::vector< int > | minPulseWidth )

Enable the filter on a group of terminals and set the minimum pulse width separately.

Parameters
terminals | Specified Group of Terminals
minPulseWidth | Minimum pulse width in ns, bounce less than this length will be ignored. The smallest step in the range of 10 ns to 2550 ns is 10 ns, the smallest step in the range of 2550 ns to 40800 ns is 160 ns, and the smallest step in the range of 40800 ns to 652800 ns The step is 2560 ns
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOODevice.h


5113 C++ Programming Manual: JY5113CoreOO::PFISetting Class Reference

  • PFISetting
Public Attributes | List of all members
JY5113CoreOO::PFISetting Class Reference

#include <JY5113CoreOODevice.h>

Public Attributes

PFIFilter * Filter
PFI Filter Setting.

Member Data Documentation

◆ Filter

PFIFilter* JY5113CoreOO::PFISetting::Filter

PFI Filter Setting.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOODevice.h


5113 C++ Programming Manual: JY5113CoreOO::ExternalReferenceClock Class Reference

  • ExternalReferenceClock
Public Attributes | List of all members
JY5113CoreOO::ExternalReferenceClock Class Reference

#include <JY5113CoreOODevice.h>

Public Attributes

ExternalReferenceClockTerminal Terminal

Member Data Documentation

◆ Terminal

ExternalReferenceClockTerminal JY5113CoreOO::ExternalReferenceClock::Terminal
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOODevice.h


5113 C++ Programming Manual: JY5113CoreOO::JY5113CoreOOReferenceClock Class Reference

  • JY5113CoreOOReferenceClock
Public Member Functions | Public Attributes | List of all members
JY5113CoreOO::JY5113CoreOOReferenceClock Class Reference

#include <JY5113CoreOODevice.h>

Public Member Functions

void Commit ()
Commit configuration.

Public Attributes

ReferenceClockSource Source
ExternalReferenceClock * External
External Reference Clock Source.

Member Function Documentation

◆ Commit()

void JY5113CoreOO::JY5113CoreOOReferenceClock::Commit ( )

Commit configuration.

Available only when the device is idle. WARNING: Incorrect parameters will cause the PLL to be unable to lock the reference clock and cannot be recovered until shutdown and restart.

Member Data Documentation

◆ External

ExternalReferenceClock* JY5113CoreOO::JY5113CoreOOReferenceClock::External

External Reference Clock Source.

Required when ReferenceClock.Source is ReferenceClockSource.External

◆ Source

ReferenceClockSource JY5113CoreOO::JY5113CoreOOReferenceClock::Source
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOODevice.h


5113 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOODITask.h File Reference

  • File List
  • File Members
  • COO
  • 5113
Classes | Namespaces | Enumerations
JY5113CoreOODITask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JY5113CoreOOCommon.h"
#include "JY5113CoreOODevice.h"

Classes

class | JY5113CoreOO::JY5113CoreOODITask
class | JY5113CoreOO::DIChannel
DI Channel parameter class . More...
class | JY5113CoreOO::DISampleClock
Sample clock configuration class. More...
class | JY5113CoreOO::DIExternalSampleClock
External Sample Clock Configuration Class. More...
class | JY5113CoreOO::DISignalExport
DI Signal Export Class. More...
class | JY5113CoreOO::DITrigger
Constructor to create an DITrigger task object. More...
class | JY5113CoreOO::DIDigitalTrigger
DI Digital trigger . More...

Namespaces

namespace JY5113CoreOO

Enumerations

enum class | JY5113CoreOO::DISampleClockSource { JY5113CoreOO::Internal , JY5113CoreOO::External }
DI Sample Clock Source. More...
enum class | JY5113CoreOO::DIMode { JY5113CoreOO::Single = 2 , JY5113CoreOO::Finite = 0 , JY5113CoreOO::Continuous = 1 }
DIMode. More...
enum class | JY5113CoreOO::DISignalExportSource { JY5113CoreOO::StartTrig = 26 , JY5113CoreOO::ReferenceTrig = 27 , JY5113CoreOO::SampleClock = 36 }
SourceSignal. More...
enum class | JY5113CoreOO::DITriggerMode { JY5113CoreOO::Start , JY5113CoreOO::Reference }
DI Trigger Mode. More...
enum class | JY5113CoreOO::DITriggerType { JY5113CoreOO::Immediate = 0 , JY5113CoreOO::Digital = 1 , JY5113CoreOO::Soft = 3 }
TriggerType Digital/Immediate/Soft. More...
enum class JY5113CoreOO::DIDigitalTriggerSource {
JY5113CoreOO::PFI0 , JY5113CoreOO::PFI1 , JY5113CoreOO::PFI2 , JY5113CoreOO::PFI3 ,
JY5113CoreOO::PFI4 , JY5113CoreOO::PFI5 , JY5113CoreOO::PFI6 , JY5113CoreOO::PFI7 ,
JY5113CoreOO::PFI8 , JY5113CoreOO::PFI9 , JY5113CoreOO::PFI10 , JY5113CoreOO::PFI11 ,
JY5113CoreOO::PFI12 , JY5113CoreOO::PFI13 , JY5113CoreOO::PFI14 , JY5113CoreOO::PFI15 ,
JY5113CoreOO::PXI_Trig0 , JY5113CoreOO::PXI_Trig1 , JY5113CoreOO::PXI_Trig2 , JY5113CoreOO::PXI_Trig3 ,
JY5113CoreOO::PXI_Trig4 , JY5113CoreOO::PXI_Trig5 , JY5113CoreOO::PXI_Trig6 , JY5113CoreOO::PXI_Trig7 ,
JY5113CoreOO::AI_StartTrig , JY5113CoreOO::AI_ReferenceTrig , JY5113CoreOO::DI_StartTrig , JY5113CoreOO::DI_ReferenceTrig ,
JY5113CoreOO::AO_StartTrig , JY5113CoreOO::DO_StartTrig , JY5113CoreOO::CIO_0_StartTrig , JY5113CoreOO::CIO_1_StartTrig ,
JY5113CoreOO::CO_0_Out = 34 , JY5113CoreOO::CO_1_Out = 35
}
DI Digital trigger source. More...
enum class | JY5113CoreOO::DIDigitalTriggerEdge { JY5113CoreOO::Rising , JY5113CoreOO::Falling }
DI Digital Trigger Edge. More...


5113 C++ Programming Manual: JY5113CoreOO::JY5113CoreOODITask Class Reference

  • JY5113CoreOODITask
Public Member Functions | Public Attributes | List of all members
JY5113CoreOO::JY5113CoreOODITask Class Reference

#include <JY5113CoreOODITask.h>

Public Member Functions

JY5113CoreOODITask (int slotNum)
JY5113CoreOODITask (std::string boardName)
~JY5113CoreOODITask ()
void | AddChannel (int portNum)
Add one channel.
void | AddChannel (std::vector< int > portsNum)
Add a group of channel.
void | RemoveChannel (int portNum)
Delete the specified port number .If it is -1, delete all ports.
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Start ()
Start DI task .
void | Stop ()
Stop DI task .
void | ReadSinglePoint (bool *readValues, int line)
Specify the line reads the latest line.
void | ReadSinglePoint (std::vector< bool > &readValues)
Each line reads the latest point.
void | ReadSinglePoint (bool readValues[])
Each line reads the latest point.
void | ReadData (unsigned short dataBuffer[], unsigned int samplesToAcquire, int timeOut)
Read the unsigned short data from 16 Line.

Public Attributes

std::list< DIChannel * > | Channels
List of DI channels,(5113 support 16 Line)
DIMode Mode
DI acquisition mode，support Single/ Finite/Continuous.
JY5113CoreOOProperty< JY5113CoreOODITask, double, JY5113CoreOOPropertyType::READ_WRITE > | SampleRate
Sample rate per channel.
int | SamplesToAcquire
Number of samples to be read per channel.
DISampleClock * SampleClock
DI Sample Clock Configuration.
JY5113CoreOOProperty< JY5113CoreOODITask, int, JY5113CoreOOPropertyType::READ_ONLY > | BufLenInSamples
Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.
JY5113CoreOOProperty< JY5113CoreOODITask, uint64_t, JY5113CoreOOPropertyType::READ_ONLY > | AvailableSamples
Number of samples per channel that can be read in the buffer.
JY5113CoreOOProperty< JY5113CoreOODITask, uint64_t, JY5113CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
DITrigger * Trigger
DI Trigger Configuration.
DISignalExport * SignalExport
Export DI Signal.
JY5113CoreOODevice * Device
Device.

Constructor & Destructor Documentation

◆ JY5113CoreOODITask() [1/2]

JY5113CoreOO::JY5113CoreOODITask::JY5113CoreOODITask ( int slotNum )

◆ JY5113CoreOODITask() [2/2]

JY5113CoreOO::JY5113CoreOODITask::JY5113CoreOODITask ( std::string boardName )

◆ ~JY5113CoreOODITask()

JY5113CoreOO::JY5113CoreOODITask::~JY5113CoreOODITask ( )

Member Function Documentation

◆ AddChannel() [1/2]

void JY5113CoreOO::JY5113CoreOODITask::AddChannel ( int portNum )

Add one channel.

Parameters
portNum port number to be added.

◆ AddChannel() [2/2]

void JY5113CoreOO::JY5113CoreOODITask::AddChannel ( std::vector< int > portsNum )

Add a group of channel.

Parameters
portsNum an array of port numbers of added ports.

◆ ReadData()

void JY5113CoreOO::JY5113CoreOODITask::ReadData | ( | unsigned short | dataBuffer[],
 |  | unsigned int | samplesToAcquire,
 |  | int | timeOut )

Read the unsigned short data from 16 Line.

Each has 16 lines from 0 to 15. Each bit from low to high represents one line.

Parameters
dataBuffer | Data buffer
samplesToAcquire | Number of samples per Line to be read
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadSinglePoint() [1/3]

void JY5113CoreOO::JY5113CoreOODITask::ReadSinglePoint | ( | bool * | readValues,
 |  | int | line )

Specify the line reads the latest line.

Parameters
readValue | User buffer array
line | Specify the line to read

◆ ReadSinglePoint() [2/3]

void JY5113CoreOO::JY5113CoreOODITask::ReadSinglePoint ( bool readValues[] )

Each line reads the latest point.

Parameters
readValues User buffer array

◆ ReadSinglePoint() [3/3]

void JY5113CoreOO::JY5113CoreOODITask::ReadSinglePoint ( std::vector< bool > & readValues )

Each line reads the latest point.

Parameters
readValues User buffer array

◆ RemoveChannel()

void JY5113CoreOO::JY5113CoreOODITask::RemoveChannel ( int portNum )

Delete the specified port number .If it is -1, delete all ports.

Parameters
portNum port number to be delete.

◆ SendSoftwareTrigger()

void JY5113CoreOO::JY5113CoreOODITask::SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5113CoreOO::JY5113CoreOODITask::Start ( )

Start DI task .

◆ Stop()

void JY5113CoreOO::JY5113CoreOODITask::Stop ( )

Stop DI task .

Member Data Documentation

◆ AvailableSamples

JY5113CoreOOProperty<JY5113CoreOODITask, uint64_t, JY5113CoreOOPropertyType::READ_ONLY> JY5113CoreOO::JY5113CoreOODITask::AvailableSamples

Number of samples per channel that can be read in the buffer.

◆ BufLenInSamples

JY5113CoreOOProperty<JY5113CoreOODITask, int, JY5113CoreOOPropertyType::READ_ONLY> JY5113CoreOO::JY5113CoreOODITask::BufLenInSamples

Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.

◆ Channels

std::list<DIChannel*> JY5113CoreOO::JY5113CoreOODITask::Channels

List of DI channels,(5113 support 16 Line)

◆ Device

JY5113CoreOODevice* JY5113CoreOO::JY5113CoreOODITask::Device

Device.

◆ Mode

DIMode JY5113CoreOO::JY5113CoreOODITask::Mode

DI acquisition mode，support Single/ Finite/Continuous.

◆ SampleClock

DISampleClock* JY5113CoreOO::JY5113CoreOODITask::SampleClock

DI Sample Clock Configuration.

◆ SampleRate

JY5113CoreOOProperty<JY5113CoreOODITask, double, JY5113CoreOOPropertyType::READ_WRITE> JY5113CoreOO::JY5113CoreOODITask::SampleRate

Sample rate per channel.

Maximum sample rate is 10M The defalut sample rate = 10k You can read this property to obtain the sample rate that will actually take effect in the current configuration.

◆ SamplesToAcquire

int JY5113CoreOO::JY5113CoreOODITask::SamplesToAcquire

Number of samples to be read per channel.

Only valid when Mode is DIMode.Finite.

◆ SignalExport

DISignalExport* JY5113CoreOO::JY5113CoreOODITask::SignalExport

Export DI Signal.

◆ TransferedSamples

JY5113CoreOOProperty<JY5113CoreOODITask, uint64_t, JY5113CoreOOPropertyType::READ_ONLY> JY5113CoreOO::JY5113CoreOODITask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT DIMode::Single.

◆ Trigger

DITrigger* JY5113CoreOO::JY5113CoreOODITask::Trigger

DI Trigger Configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOODITask.h


5113 C++ Programming Manual: JY5113CoreOO::DIChannel Class Reference

  • DIChannel
Public Attributes | List of all members
JY5113CoreOO::DIChannel Class Reference

DI Channel parameter class . More...

#include <JY5113CoreOODITask.h>

Public Attributes

int LineNum
port number.

Detailed Description

DI Channel parameter class .

Member Data Documentation

◆ LineNum

int JY5113CoreOO::DIChannel::LineNum

port number.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOODITask.h


5113 C++ Programming Manual: JY5113CoreOO::DISampleClock Class Reference

  • DISampleClock
Public Attributes | List of all members
JY5113CoreOO::DISampleClock Class Reference

Sample clock configuration class. More...

#include <JY5113CoreOODITask.h>

Public Attributes

DISampleClockSource Source
Clock Source.
DIExternalSampleClock * External
External Sample Clock, Valid when Source is DISampleClockSource.External.

Detailed Description

Sample clock configuration class.

Member Data Documentation

◆ External

DIExternalSampleClock* JY5113CoreOO::DISampleClock::External

External Sample Clock, Valid when Source is DISampleClockSource.External.

◆ Source

DISampleClockSource JY5113CoreOO::DISampleClock::Source

Clock Source.

enum Internal/External

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOODITask.h


5113 C++ Programming Manual: JY5113CoreOO::DIExternalSampleClock Class Reference

  • DIExternalSampleClock
Public Attributes | List of all members
JY5113CoreOO::DIExternalSampleClock Class Reference

External Sample Clock Configuration Class. More...

#include <JY5113CoreOODITask.h>

Public Attributes

ClockTerminal Terminal
External Sample Clock Input Terminal.
double ExpectedRate
Expected External Sample Clock Rate.

Detailed Description

External Sample Clock Configuration Class.

Member Data Documentation

◆ ExpectedRate

double JY5113CoreOO::DIExternalSampleClock::ExpectedRate

Expected External Sample Clock Rate.

◆ Terminal

ClockTerminal JY5113CoreOO::DIExternalSampleClock::Terminal

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOODITask.h


5113 C++ Programming Manual: JY5113CoreOO::DISignalExport Class Reference

  • DISignalExport
Public Member Functions | List of all members
JY5113CoreOO::DISignalExport Class Reference

DI Signal Export Class. More...

#include <JY5113CoreOODITask.h>

Public Member Functions

void | Add (DISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (DISignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

DI Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY5113CoreOO::DISignalExport::Add | ( | DISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | CI Signal Source
destination | Export Desination

◆ Add() [2/2]

void JY5113CoreOO::DISignalExport::Add | ( | DISignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | CI Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JY5113CoreOO::DISignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5113CoreOO::DISignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOODITask.h


5113 C++ Programming Manual: JY5113CoreOO::DITrigger Class Reference

  • DITrigger
Public Attributes | List of all members
JY5113CoreOO::DITrigger Class Reference

Constructor to create an DITrigger task object. More...

#include <JY5113CoreOODITask.h>

Public Attributes

DITriggerType Type
DI trigger type.
DITriggerMode Mode
DI trigger mode.
DIDigitalTrigger * Digital
DI Digital Trigger.Valid when Type is DITriggerType.Digital.
uint32_t PreTriggerSamples
Pretrigger Samples, must be less than or equal to JY5113DITask.SamplesToAcquire.

Detailed Description

Constructor to create an DITrigger task object.

Used to build DI Trigger

Member Data Documentation

◆ Digital

DIDigitalTrigger* JY5113CoreOO::DITrigger::Digital

DI Digital Trigger.Valid when Type is DITriggerType.Digital.

◆ Mode

DITriggerMode JY5113CoreOO::DITrigger::Mode

DI trigger mode.

enum Start/Reference.

◆ PreTriggerSamples

uint32_t JY5113CoreOO::DITrigger::PreTriggerSamples

Pretrigger Samples, must be less than or equal to JY5113DITask.SamplesToAcquire.

Valid when Mode is DITriggerMode.Reference. Pretrigger samples, must be greater than 1. Valid when Type is DITriggerType.Digital.

◆ Type

DITriggerType JY5113CoreOO::DITrigger::Type

DI trigger type.

enum Digital/Immediate/Soft.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOODITask.h


5113 C++ Programming Manual: JY5113CoreOO::DIDigitalTrigger Class Reference

  • DIDigitalTrigger
Public Attributes | List of all members
JY5113CoreOO::DIDigitalTrigger Class Reference

DI Digital trigger . More...

#include <JY5113CoreOODITask.h>

Public Attributes

DIDigitalTriggerSource Source
DI Digital Trigger source.
DIDigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Detailed Description

DI Digital trigger .

Member Data Documentation

◆ Edge

DIDigitalTriggerEdge JY5113CoreOO::DIDigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

DIDigitalTriggerSource JY5113CoreOO::DIDigitalTrigger::Source

DI Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOODITask.h


5113 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOODOTask.h File Reference

  • File List
  • File Members
  • COO
  • 5113
Classes | Namespaces | Enumerations
JY5113CoreOODOTask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JY5113CoreOOCommon.h"
#include "JY5113CoreOODevice.h"

Classes

class | JY5113CoreOO::JY5113CoreOODOTask
class | JY5113CoreOO::DOChannel
DO Channel parameter class . More...
class | JY5113CoreOO::DOSampleClock
Sample clock configuration class. More...
class | JY5113CoreOO::DOExternalSampleClock
External Sample Clock Configuration Class. More...
class | JY5113CoreOO::DODigitalTrigger
DO Digital trigger. More...
class | JY5113CoreOO::DOTrigger
Constructor to create an DOTrigger task object. More...
class | JY5113CoreOO::DOSignalExport
DO Signal Export Class. More...

Namespaces

namespace JY5113CoreOO

Enumerations

enum class | JY5113CoreOO::DOSampleClockSource { JY5113CoreOO::Internal , JY5113CoreOO::External }
DO Sample Clock Source. More...
enum class | JY5113CoreOO::DOMode { JY5113CoreOO::Single = 3 , JY5113CoreOO::Finite = 0 , JY5113CoreOO::ContinuousWrapping = 1 , JY5113CoreOO::ContinuousNoWrapping = 2 }
DOMode. More...
enum class | JY5113CoreOO::DODigitalTriggerEdge { JY5113CoreOO::Rising , JY5113CoreOO::Falling }
DO Digital Trigger Edge. More...
enum class JY5113CoreOO::DODigitalTriggerSource {
JY5113CoreOO::PFI0 , JY5113CoreOO::PFI1 , JY5113CoreOO::PFI2 , JY5113CoreOO::PFI3 ,
JY5113CoreOO::PFI4 , JY5113CoreOO::PFI5 , JY5113CoreOO::PFI6 , JY5113CoreOO::PFI7 ,
JY5113CoreOO::PFI8 , JY5113CoreOO::PFI9 , JY5113CoreOO::PFI10 , JY5113CoreOO::PFI11 ,
JY5113CoreOO::PFI12 , JY5113CoreOO::PFI13 , JY5113CoreOO::PFI14 , JY5113CoreOO::PFI15 ,
JY5113CoreOO::PXI_Trig0 , JY5113CoreOO::PXI_Trig1 , JY5113CoreOO::PXI_Trig2 , JY5113CoreOO::PXI_Trig3 ,
JY5113CoreOO::PXI_Trig4 , JY5113CoreOO::PXI_Trig5 , JY5113CoreOO::PXI_Trig6 , JY5113CoreOO::PXI_Trig7 ,
JY5113CoreOO::AI_StartTrig , JY5113CoreOO::AI_ReferenceTrig , JY5113CoreOO::DI_StartTrig , JY5113CoreOO::DI_ReferenceTrig ,
JY5113CoreOO::AO_StartTrig , JY5113CoreOO::DO_StartTrig , JY5113CoreOO::CIO_0_StartTrig , JY5113CoreOO::CIO_1_StartTrig ,
JY5113CoreOO::CO_0_Out = 34 , JY5113CoreOO::CO_1_Out = 35
}
DO Digital trigger source. More...
enum class | JY5113CoreOO::DOTriggerType { JY5113CoreOO::Immediate = 0 , JY5113CoreOO::Digital = 1 , JY5113CoreOO::Soft = 3 }
TriggerType Digital/Immediate/Soft. More...
enum class | JY5113CoreOO::DOSignalExportSource { JY5113CoreOO::StartTrig = 29 , JY5113CoreOO::SampleClock = 37 }
SourceSignal. More...


5113 C++ Programming Manual: JY5113CoreOO::JY5113CoreOODOTask Class Reference

  • JY5113CoreOODOTask
Public Member Functions | Public Attributes | List of all members
JY5113CoreOO::JY5113CoreOODOTask Class Reference

#include <JY5113CoreOODOTask.h>

Public Member Functions

JY5113CoreOODOTask (int slotNum)
JY5113CoreOODOTask (std::string boardName)
~JY5113CoreOODOTask ()
void | AddChannel (int portNum)
Add one channel.
void | AddChannel (std::vector< int > portsNum)
Add a group of channel.
void | RemoveChannel (int portNum)
Delete the specified port number .If it is -1, delete all ports.
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Start ()
Start DO task .
void | Stop ()
Stop DO task .
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.
void | WriteSinglePoint (bool writeValues, int line)
Write one sample to the specified port in register.Available when Mode is DOMode.Single when the line is -1, write all enabled lines values.
void | WriteSinglePoint (std::vector< bool > &writeValues)
Write one sample for all line in register .
void | WriteData (unsigned short dataBuffer[], unsigned int samplesToUpdate, int timeOut)
Write the byte data for one line or multi-lines.

Public Attributes

std::list< DOChannel * > | Channels
List of DO channels,(5113 support 16 Line)
DOMode Mode
DO acquisition mode，support Single/ Finite/Continuous.
JY5113CoreOOProperty< JY5113CoreOODOTask, double, JY5113CoreOOPropertyType::READ_WRITE > | UpdateRate
Sample rate per channel.
int | SamplesToUpdate
Number of output samples to write per channel , Only valid when Mode is DOMode::Finite.
DOSampleClock * SampleClock
DO Sample Clock Configuration.
JY5113CoreOOProperty< JY5113CoreOODOTask, int, JY5113CoreOOPropertyType::READ_ONLY > | BufLenInSamples
Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.
JY5113CoreOOProperty< JY5113CoreOODOTask, uint64_t, JY5113CoreOOPropertyType::READ_ONLY > | AvaliableLenInSamples
Number of output samples per channel avaliable to write in DO buffuer.
JY5113CoreOOProperty< JY5113CoreOODOTask, uint64_t, JY5113CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
OutputCompleteState CompleteState
DO Output Complete State, Valid when Mode is NOT DOMode.Single.Default is Zero.
DOTrigger * Trigger
DO Trigger Configuration.
DOSignalExport * SignalExport
Export DO Signal.
JY5113CoreOODevice * Device
Device.

Constructor & Destructor Documentation

◆ JY5113CoreOODOTask() [1/2]

JY5113CoreOO::JY5113CoreOODOTask::JY5113CoreOODOTask ( int slotNum )

◆ JY5113CoreOODOTask() [2/2]

JY5113CoreOO::JY5113CoreOODOTask::JY5113CoreOODOTask ( std::string boardName )

◆ ~JY5113CoreOODOTask()

JY5113CoreOO::JY5113CoreOODOTask::~JY5113CoreOODOTask ( )

Member Function Documentation

◆ AddChannel() [1/2]

void JY5113CoreOO::JY5113CoreOODOTask::AddChannel ( int portNum )

Add one channel.

Parameters
portNum port number to be added.

◆ AddChannel() [2/2]

void JY5113CoreOO::JY5113CoreOODOTask::AddChannel ( std::vector< int > portsNum )

Add a group of channel.

Parameters
portsNum an array of port numbers of added ports.

◆ RemoveChannel()

void JY5113CoreOO::JY5113CoreOODOTask::RemoveChannel ( int portNum )

Delete the specified port number .If it is -1, delete all ports.

Parameters
portNum port number to be delete.

◆ SendSoftwareTrigger()

void JY5113CoreOO::JY5113CoreOODOTask::SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5113CoreOO::JY5113CoreOODOTask::Start ( )

Start DO task .

◆ Stop()

void JY5113CoreOO::JY5113CoreOODOTask::Stop ( )

Stop DO task .

◆ WaitUntilDone()

bool JY5113CoreOO::JY5113CoreOODOTask::WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Available when Mode is DOMode.Finite

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteData()

void JY5113CoreOO::JY5113CoreOODOTask::WriteData | ( | unsigned short | dataBuffer[],
 |  | unsigned int | samplesToUpdate,
 |  | int | timeOut )

Write the byte data for one line or multi-lines.

There are 16 lines, from 0 to 15. Each bit from low to high represents one line.

Parameters
dataBuffer | Data buffer
samplesToUpdate | Number of samples per Line to be write
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteSinglePoint() [1/2]

void JY5113CoreOO::JY5113CoreOODOTask::WriteSinglePoint | ( | bool | writeValues,
 |  | int | line )

Write one sample to the specified port in register.Available when Mode is DOMode.Single when the line is -1, write all enabled lines values.

Parameters
writeValues | values write
port | Specified port numbers.

◆ WriteSinglePoint() [2/2]

void JY5113CoreOO::JY5113CoreOODOTask::WriteSinglePoint ( std::vector< bool > & writeValues )

Write one sample for all line in register .

Available when Mode is DIMode.Single

Parameters
readValues Values read. Buffer size = number of Line.

Member Data Documentation

◆ AvaliableLenInSamples

JY5113CoreOOProperty<JY5113CoreOODOTask, uint64_t, JY5113CoreOOPropertyType::READ_ONLY> JY5113CoreOO::JY5113CoreOODOTask::AvaliableLenInSamples

Number of output samples per channel avaliable to write in DO buffuer.

◆ BufLenInSamples

JY5113CoreOOProperty<JY5113CoreOODOTask, int, JY5113CoreOOPropertyType::READ_ONLY> JY5113CoreOO::JY5113CoreOODOTask::BufLenInSamples

Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.

◆ Channels

std::list<DOChannel*> JY5113CoreOO::JY5113CoreOODOTask::Channels

List of DO channels,(5113 support 16 Line)

◆ CompleteState

OutputCompleteState JY5113CoreOO::JY5113CoreOODOTask::CompleteState

DO Output Complete State, Valid when Mode is NOT DOMode.Single.Default is Zero.

◆ Device

JY5113CoreOODevice* JY5113CoreOO::JY5113CoreOODOTask::Device

Device.

◆ Mode

DOMode JY5113CoreOO::JY5113CoreOODOTask::Mode

DO acquisition mode，support Single/ Finite/Continuous.

◆ SampleClock

DOSampleClock* JY5113CoreOO::JY5113CoreOODOTask::SampleClock

DO Sample Clock Configuration.

◆ SamplesToUpdate

int JY5113CoreOO::JY5113CoreOODOTask::SamplesToUpdate

Number of output samples to write per channel , Only valid when Mode is DOMode::Finite.

◆ SignalExport

DOSignalExport* JY5113CoreOO::JY5113CoreOODOTask::SignalExport

Export DO Signal.

◆ TransferedSamples

JY5113CoreOOProperty<JY5113CoreOODOTask, uint64_t, JY5113CoreOOPropertyType::READ_ONLY> JY5113CoreOO::JY5113CoreOODOTask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT DIMode::Single.

◆ Trigger

DOTrigger* JY5113CoreOO::JY5113CoreOODOTask::Trigger

DO Trigger Configuration.

◆ UpdateRate

JY5113CoreOOProperty<JY5113CoreOODOTask, double, JY5113CoreOOPropertyType::READ_WRITE> JY5113CoreOO::JY5113CoreOODOTask::UpdateRate

Sample rate per channel.

Maximum sample rate is 10M The defalut sample rate = 10k You can read this property to obtain the sample rate that will actually take effect in the current configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOODOTask.h


5113 C++ Programming Manual: JY5113CoreOO::DOChannel Class Reference

  • DOChannel
Public Attributes | List of all members
JY5113CoreOO::DOChannel Class Reference

DO Channel parameter class . More...

#include <JY5113CoreOODOTask.h>

Public Attributes

int LineNum
port number.

Detailed Description

DO Channel parameter class .

Member Data Documentation

◆ LineNum

int JY5113CoreOO::DOChannel::LineNum

port number.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOODOTask.h


5113 C++ Programming Manual: JY5113CoreOO::DOSampleClock Class Reference

  • DOSampleClock
Public Attributes | List of all members
JY5113CoreOO::DOSampleClock Class Reference

Sample clock configuration class. More...

#include <JY5113CoreOODOTask.h>

Public Attributes

DOSampleClockSource Source
Clock Source.
DOExternalSampleClock * External
External Sample Clock.Valid when Source is DOSampleClockSource.External.

Detailed Description

Sample clock configuration class.

Member Data Documentation

◆ External

DOExternalSampleClock* JY5113CoreOO::DOSampleClock::External

External Sample Clock.Valid when Source is DOSampleClockSource.External.

◆ Source

DOSampleClockSource JY5113CoreOO::DOSampleClock::Source

Clock Source.

enum Internal/External

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOODOTask.h


5113 C++ Programming Manual: JY5113CoreOO::DOExternalSampleClock Class Reference

  • DOExternalSampleClock
Public Attributes | List of all members
JY5113CoreOO::DOExternalSampleClock Class Reference

External Sample Clock Configuration Class. More...

#include <JY5113CoreOODOTask.h>

Public Attributes

ClockTerminal Terminal
External Sample Clock Input Terminal.
double ExpectedRate
Expected External Sample Clock Rate.

Detailed Description

External Sample Clock Configuration Class.

Member Data Documentation

◆ ExpectedRate

double JY5113CoreOO::DOExternalSampleClock::ExpectedRate

Expected External Sample Clock Rate.

◆ Terminal

ClockTerminal JY5113CoreOO::DOExternalSampleClock::Terminal

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOODOTask.h


5113 C++ Programming Manual: JY5113CoreOO::DODigitalTrigger Class Reference

  • DODigitalTrigger
Public Attributes | List of all members
JY5113CoreOO::DODigitalTrigger Class Reference

DO Digital trigger. More...

#include <JY5113CoreOODOTask.h>

Public Attributes

DODigitalTriggerSource Source
DO Digital Trigger source.
DODigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Detailed Description

DO Digital trigger.

Member Data Documentation

◆ Edge

DODigitalTriggerEdge JY5113CoreOO::DODigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

DODigitalTriggerSource JY5113CoreOO::DODigitalTrigger::Source

DO Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOODOTask.h


5113 C++ Programming Manual: JY5113CoreOO::DOTrigger Class Reference

  • DOTrigger
Public Attributes | List of all members
JY5113CoreOO::DOTrigger Class Reference

Constructor to create an DOTrigger task object. More...

#include <JY5113CoreOODOTask.h>

Public Attributes

DOTriggerType Type
DO trigger type.
DODigitalTrigger * Digital
DO Digital Trigger.Valid when Type is DOTriggerType.Digital.

Detailed Description

Constructor to create an DOTrigger task object.

Used to build DO Trigger

Member Data Documentation

◆ Digital

DODigitalTrigger* JY5113CoreOO::DOTrigger::Digital

DO Digital Trigger.Valid when Type is DOTriggerType.Digital.

◆ Type

DOTriggerType JY5113CoreOO::DOTrigger::Type

DO trigger type.

enum Digital/Immediate/Soft.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOODOTask.h


5113 C++ Programming Manual: JY5113CoreOO::DOSignalExport Class Reference

  • DOSignalExport
Public Member Functions | List of all members
JY5113CoreOO::DOSignalExport Class Reference

DO Signal Export Class. More...

#include <JY5113CoreOODOTask.h>

Public Member Functions

void | Add (DOSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (DOSignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

DO Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY5113CoreOO::DOSignalExport::Add | ( | DOSignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | CI Signal Source
destination | Export Desination

◆ Add() [2/2]

void JY5113CoreOO::DOSignalExport::Add | ( | DOSignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | CI Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JY5113CoreOO::DOSignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5113CoreOO::DOSignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOODOTask.h


5113 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOLog.h File Reference

  • File List
  • File Members
  • COO
  • 5113
Classes | Namespaces | Enumerations
JY5113CoreOOLog.h File Reference
#include <queue>
#include <string>
#include <thread>
#include "JY5113CoreOOCommon.h"

Classes

class JY5113CoreOO::JY5113CoreOOLog

Namespaces

namespace JY5113CoreOO

Enumerations

enum class JY5113CoreOO::JY5113CoreOOLogLevel {
JY5113CoreOO::DEBUG_LOG_LEVEL , JY5113CoreOO::INFO_LOG_LEVEL , JY5113CoreOO::WARN_LOG_LEVEL , JY5113CoreOO::ERROR_LOG_LEVEL ,
JY5113CoreOO::FATAL_LOG_LEVEL
}


5113 C++ Programming Manual: JY5113CoreOO::JY5113CoreOOLog Class Reference

  • JY5113CoreOOLog
Static Public Member Functions | Static Public Attributes | List of all members
JY5113CoreOO::JY5113CoreOOLog Class Reference

#include <JY5113CoreOOLog.h>

Static Public Member Functions

static void | Print (const char *format,...)
static void | Print (JY5113CoreOOLogLevel logLevel, const char *format,...)
static void | Flush ()

Static Public Attributes

static JY5113CoreOOLogLevel | LogLevel
static JY5113CoreOOProperty< JY5113CoreOOLog, bool, JY5113CoreOOPropertyType::READ_WRITE > | EnableLog

Member Function Documentation

◆ Flush()

static void JY5113CoreOO::JY5113CoreOOLog::Flush ( )
static

◆ Print() [1/2]

static void JY5113CoreOO::JY5113CoreOOLog::Print | ( | const char * | format,
 |  |  | ... )
 static

◆ Print() [2/2]

static void JY5113CoreOO::JY5113CoreOOLog::Print | ( | JY5113CoreOOLogLevel | logLevel,
 |  | const char * | format,
 |  |  | ... )
 static

Member Data Documentation

◆ EnableLog

JY5113CoreOOProperty<JY5113CoreOOLog, bool, JY5113CoreOOPropertyType::READ_WRITE> JY5113CoreOO::JY5113CoreOOLog::EnableLog
static

◆ LogLevel

JY5113CoreOOLogLevel JY5113CoreOO::JY5113CoreOOLog::LogLevel
static
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOLog.h


5113 C++ Programming Manual: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
▼N JY5113CoreOO |
C AIAdvanced | AI Advance parameter
C AIAnalogEdgeComparator | AI Analog Edge Comparator
C AIAnalogHysteresisComparator | AI Analog Hysteresis Comparatorr
C AIAnalogTrigger | AI analog trigger
C AIAnalogWindowComparator | AI Analog Window Comparatorr
C AIChannel |
C AIDigitalTrigger | AI Digital trigger class
C AIDSMode |
C AIExternalSampleClock | Sample clock configuration class
C AIRecord | AI Record Parameters
C AISampleClock | Sample clock configuration class
C AISignalExport | AI Signal Export Class
C AITrigger | Constructor to create an AITrigger task object
C AOChannel |
C AODigitalTrigger | AO Digital trigger
C AOExternalSampleClock | External Sample Clock Configuration Class
C AOSampleClock | AO Sample clock configuration class
C AOSignalExport | AO Signal Export Class
C AOTrigger | Constructor to create an AOTrigger task object
C CIDigitalTrigger | CI Digital trigger
C CIExternalSampleClock | CI Implicit Sample Clock class
C CIExternalTimebase |
C CIImplicitSampleClock | CI Implicit Sample Clock class
C CIInternalSampleClock | CI Internal Sample Clock Configuration Class
C CISampleClock | CI Sample Clock class
C CISignalExport | CI Signal Export Class
C CITimebase | Timebase configuration class
C CITrigger | Constructor to create an CITrigger task object
C CODigitalTrigger | CO Digital trigger
C COExternalTimebase |
C COPulse | Pulse Parameter
C COSignalExport | CO Signal Export Class
C COTimebase | Timebase configuration class
C COTrigger | Constructor to create an COTrigger task object
C DIChannel | DI Channel parameter class
C DIDigitalTrigger | DI Digital trigger
C DIExternalSampleClock | External Sample Clock Configuration Class
C DISampleClock | Sample clock configuration class
C DISignalExport | DI Signal Export Class
C DITrigger | Constructor to create an DITrigger task object
C DOChannel | DO Channel parameter class
C DODigitalTrigger | DO Digital trigger
C DOExternalSampleClock | External Sample Clock Configuration Class
C DOSampleClock | Sample clock configuration class
C DOSignalExport | DO Signal Export Class
C DOTrigger | Constructor to create an DOTrigger task object
C EdgeCounting | Configure CI EdgeCounting
C EdgeCountingOutEvent | Edge counting output event configuration class
C ExternalReferenceClock |
C FrequencyMeas | Configure CI Measure
C JY5113CoreOOAITask | AITask类
C JY5113CoreOOAOTask |
C JY5113CoreOOCITask |
C JY5113CoreOOCOTask |
C JY5113CoreOODevice |
C JY5113CoreOODITask |
C JY5113CoreOODOTask |
C JY5113CoreOOLog |
C JY5113CoreOOProperty | 属性模板类
C JY5113CoreOOReferenceClock |
C JYDriverException |
C PauseTrigger | Pause trigger configuration class
C PeriodMeas | Configure CI Measure
C PFIFilter |
C PFISetting |
C PulseMeas | Configure CI Measure
C QuadEncoder | Configure CI Measure
C SemiPeriodMeas | Configure CI Measure
C TwoEdgeSeparation | Configure CI Measure
C TwoPulseEncoder | Configure CI Measure
C AOMode | AIMode
C JY5113CoreOOAIMode | AIMode


5113 C++ Programming Manual: AOMode Class Reference

AOMode Class Reference

AIMode. More...

#include <JY5113CoreOOAOTask.h>

Detailed Description

AIMode.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOAOTask.h


5113 C++ Programming Manual: Member List

  • AIAdvanced
JY5113CoreOO::AIAdvanced Member List

This is the complete list of members for JY5113CoreOO::AIAdvanced, including all inherited members.

ConvertRate | JY5113CoreOO::AIAdvanced
DSMode | JY5113CoreOO::AIAdvanced


5113 C++ Programming Manual: Member List

  • AIAnalogEdgeComparator
JY5113CoreOO::AIAnalogEdgeComparator Member List

This is the complete list of members for JY5113CoreOO::AIAnalogEdgeComparator, including all inherited members.

Slope | JY5113CoreOO::AIAnalogEdgeComparator
Threshold | JY5113CoreOO::AIAnalogEdgeComparator


5113 C++ Programming Manual: Member List

  • AIAnalogHysteresisComparator
JY5113CoreOO::AIAnalogHysteresisComparator Member List

This is the complete list of members for JY5113CoreOO::AIAnalogHysteresisComparator, including all inherited members.

HighThreshold | JY5113CoreOO::AIAnalogHysteresisComparator
LowThreshold | JY5113CoreOO::AIAnalogHysteresisComparator
Slope | JY5113CoreOO::AIAnalogHysteresisComparator


5113 C++ Programming Manual: Member List

  • AIAnalogTrigger
JY5113CoreOO::AIAnalogTrigger Member List

This is the complete list of members for JY5113CoreOO::AIAnalogTrigger, including all inherited members.

Comparator | JY5113CoreOO::AIAnalogTrigger
Edge | JY5113CoreOO::AIAnalogTrigger
Hysteresis | JY5113CoreOO::AIAnalogTrigger
Source | JY5113CoreOO::AIAnalogTrigger
Window | JY5113CoreOO::AIAnalogTrigger


5113 C++ Programming Manual: Member List

  • AIAnalogWindowComparator
JY5113CoreOO::AIAnalogWindowComparator Member List

This is the complete list of members for JY5113CoreOO::AIAnalogWindowComparator, including all inherited members.

Condition | JY5113CoreOO::AIAnalogWindowComparator
HighThreshold | JY5113CoreOO::AIAnalogWindowComparator
LowThreshold | JY5113CoreOO::AIAnalogWindowComparator


5113 C++ Programming Manual: Member List

  • AIChannel
JY5113CoreOO::AIChannel Member List

This is the complete list of members for JY5113CoreOO::AIChannel, including all inherited members.

AIChannel(int channelId, double rangeLow, double rangeHigh, AITerminal terminalCfg=AITerminal::NRSE, AIBandWidth bandWidth=AIBandWidth::_80KHz) | JY5113CoreOO::AIChannel | inline
BandWidth | JY5113CoreOO::AIChannel |
ChannelID | JY5113CoreOO::AIChannel |
RangeHigh | JY5113CoreOO::AIChannel |
RangeLow | JY5113CoreOO::AIChannel |
Terminal | JY5113CoreOO::AIChannel |


5113 C++ Programming Manual: Member List

  • AIDSMode
JY5113CoreOO::AIDSMode Member List

This is the complete list of members for JY5113CoreOO::AIDSMode, including all inherited members.

Enable JY5113CoreOO::AIDSMode


5113 C++ Programming Manual: Member List

  • AIDigitalTrigger
JY5113CoreOO::AIDigitalTrigger Member List

This is the complete list of members for JY5113CoreOO::AIDigitalTrigger, including all inherited members.

Edge | JY5113CoreOO::AIDigitalTrigger
Source | JY5113CoreOO::AIDigitalTrigger


5113 C++ Programming Manual: Member List

  • AIExternalSampleClock
JY5113CoreOO::AIExternalSampleClock Member List

This is the complete list of members for JY5113CoreOO::AIExternalSampleClock, including all inherited members.

ExpectedRate | JY5113CoreOO::AIExternalSampleClock
Terminal | JY5113CoreOO::AIExternalSampleClock


5113 C++ Programming Manual: Member List

  • AIRecord
JY5113CoreOO::AIRecord Member List

This is the complete list of members for JY5113CoreOO::AIRecord, including all inherited members.

File_Format | JY5113CoreOO::AIRecord
FilePath | JY5113CoreOO::AIRecord
Length | JY5113CoreOO::AIRecord
Mode | JY5113CoreOO::AIRecord


5113 C++ Programming Manual: Member List

  • AISampleClock
JY5113CoreOO::AISampleClock Member List

This is the complete list of members for JY5113CoreOO::AISampleClock, including all inherited members.

External | JY5113CoreOO::AISampleClock
Source | JY5113CoreOO::AISampleClock


5113 C++ Programming Manual: Member List

  • AISignalExport
JY5113CoreOO::AISignalExport Member List

This is the complete list of members for JY5113CoreOO::AISignalExport, including all inherited members.

Add(AISignalExportSource source, SignalExportDestination destination) | JY5113CoreOO::AISignalExport
Add(AISignalExportSource source, std::list< SignalExportDestination > destinations) | JY5113CoreOO::AISignalExport
Clear(SignalExportDestination destination) | JY5113CoreOO::AISignalExport
ClearAll() | JY5113CoreOO::AISignalExport


5113 C++ Programming Manual: Member List

  • AITrigger
JY5113CoreOO::AITrigger Member List

This is the complete list of members for JY5113CoreOO::AITrigger, including all inherited members.

Analog | JY5113CoreOO::AITrigger
Digital | JY5113CoreOO::AITrigger
Mode | JY5113CoreOO::AITrigger
PreTriggerSamples | JY5113CoreOO::AITrigger
ReTriggerCount | JY5113CoreOO::AITrigger
Type | JY5113CoreOO::AITrigger


5113 C++ Programming Manual: Member List

  • AOChannel
JY5113CoreOO::AOChannel Member List

This is the complete list of members for JY5113CoreOO::AOChannel, including all inherited members.

AOChannel(int channelId, double rangeLow, double rangeHigh) | JY5113CoreOO::AOChannel | inline
ChannelID | JY5113CoreOO::AOChannel |
RangeHigh | JY5113CoreOO::AOChannel |
RangeLow | JY5113CoreOO::AOChannel |


5113 C++ Programming Manual: Member List

  • AODigitalTrigger
JY5113CoreOO::AODigitalTrigger Member List

This is the complete list of members for JY5113CoreOO::AODigitalTrigger, including all inherited members.

Edge | JY5113CoreOO::AODigitalTrigger
Source | JY5113CoreOO::AODigitalTrigger


5113 C++ Programming Manual: Member List

  • AOExternalSampleClock
JY5113CoreOO::AOExternalSampleClock Member List

This is the complete list of members for JY5113CoreOO::AOExternalSampleClock, including all inherited members.

ExpectedRate | JY5113CoreOO::AOExternalSampleClock
Terminal | JY5113CoreOO::AOExternalSampleClock


5113 C++ Programming Manual: Member List

  • AOSampleClock
JY5113CoreOO::AOSampleClock Member List

This is the complete list of members for JY5113CoreOO::AOSampleClock, including all inherited members.

External | JY5113CoreOO::AOSampleClock |
JY5113CoreOOAOTask class | JY5113CoreOO::AOSampleClock | friend
Source | JY5113CoreOO::AOSampleClock |


5113 C++ Programming Manual: Member List

  • AOSignalExport
JY5113CoreOO::AOSignalExport Member List

This is the complete list of members for JY5113CoreOO::AOSignalExport, including all inherited members.

Add(AOSignalExportSource source, SignalExportDestination destination) | JY5113CoreOO::AOSignalExport
Add(AOSignalExportSource source, std::list< SignalExportDestination > destinations) | JY5113CoreOO::AOSignalExport
Clear(SignalExportDestination destination) | JY5113CoreOO::AOSignalExport
ClearAll() | JY5113CoreOO::AOSignalExport


5113 C++ Programming Manual: Member List

  • AOTrigger
JY5113CoreOO::AOTrigger Member List

This is the complete list of members for JY5113CoreOO::AOTrigger, including all inherited members.

Digital | JY5113CoreOO::AOTrigger
Type | JY5113CoreOO::AOTrigger


5113 C++ Programming Manual: Member List

  • CIDigitalTrigger
JY5113CoreOO::CIDigitalTrigger Member List

This is the complete list of members for JY5113CoreOO::CIDigitalTrigger, including all inherited members.

Edge | JY5113CoreOO::CIDigitalTrigger
Source | JY5113CoreOO::CIDigitalTrigger


5113 C++ Programming Manual: Member List

  • CIExternalSampleClock
JY5113CoreOO::CIExternalSampleClock Member List

This is the complete list of members for JY5113CoreOO::CIExternalSampleClock, including all inherited members.

ExpectedRate | JY5113CoreOO::CIExternalSampleClock
Terminal | JY5113CoreOO::CIExternalSampleClock


5113 C++ Programming Manual: Member List

  • CIExternalTimebase
JY5113CoreOO::CIExternalTimebase Member List

This is the complete list of members for JY5113CoreOO::CIExternalTimebase, including all inherited members.

CIExternalTimebase() | JY5113CoreOO::CIExternalTimebase | inline
Frequency | JY5113CoreOO::CIExternalTimebase |
Terminal | JY5113CoreOO::CIExternalTimebase |


5113 C++ Programming Manual: Member List

  • CIImplicitSampleClock
JY5113CoreOO::CIImplicitSampleClock Member List

This is the complete list of members for JY5113CoreOO::CIImplicitSampleClock, including all inherited members.

ExpectedRate JY5113CoreOO::CIImplicitSampleClock


5113 C++ Programming Manual: Member List

  • CIInternalSampleClock
JY5113CoreOO::CIInternalSampleClock Member List

This is the complete list of members for JY5113CoreOO::CIInternalSampleClock, including all inherited members.

IgnoreFirstSampleClock | JY5113CoreOO::CIInternalSampleClock
Rate | JY5113CoreOO::CIInternalSampleClock


5113 C++ Programming Manual: Member List

  • CISampleClock
JY5113CoreOO::CISampleClock Member List

This is the complete list of members for JY5113CoreOO::CISampleClock, including all inherited members.

External | JY5113CoreOO::CISampleClock
Implicit | JY5113CoreOO::CISampleClock
Internal | JY5113CoreOO::CISampleClock
Source | JY5113CoreOO::CISampleClock


5113 C++ Programming Manual: Member List

  • CISignalExport
JY5113CoreOO::CISignalExport Member List

This is the complete list of members for JY5113CoreOO::CISignalExport, including all inherited members.

Add(CISignalExportSource source, SignalExportDestination destination) | JY5113CoreOO::CISignalExport
Add(CISignalExportSource source, std::list< SignalExportDestination > destinations) | JY5113CoreOO::CISignalExport
Clear(SignalExportDestination destination) | JY5113CoreOO::CISignalExport
ClearAll() | JY5113CoreOO::CISignalExport


5113 C++ Programming Manual: Member List

  • CITimebase
JY5113CoreOO::CITimebase Member List

This is the complete list of members for JY5113CoreOO::CITimebase, including all inherited members.

ActualFreq | JY5113CoreOO::CITimebase
External | JY5113CoreOO::CITimebase
Source | JY5113CoreOO::CITimebase


5113 C++ Programming Manual: Member List

  • CITrigger
JY5113CoreOO::CITrigger Member List

This is the complete list of members for JY5113CoreOO::CITrigger, including all inherited members.

Digital | JY5113CoreOO::CITrigger
Type | JY5113CoreOO::CITrigger


5113 C++ Programming Manual: Member List

  • CODigitalTrigger
JY5113CoreOO::CODigitalTrigger Member List

This is the complete list of members for JY5113CoreOO::CODigitalTrigger, including all inherited members.

Edge | JY5113CoreOO::CODigitalTrigger
Source | JY5113CoreOO::CODigitalTrigger


5113 C++ Programming Manual: Member List

  • COExternalTimebase
JY5113CoreOO::COExternalTimebase Member List

This is the complete list of members for JY5113CoreOO::COExternalTimebase, including all inherited members.

COExternalTimebase() | JY5113CoreOO::COExternalTimebase | inline
Frequency | JY5113CoreOO::COExternalTimebase |
Terminal | JY5113CoreOO::COExternalTimebase |


5113 C++ Programming Manual: Member List

  • COPulse
JY5113CoreOO::COPulse Member List

This is the complete list of members for JY5113CoreOO::COPulse, including all inherited members.

COPulse(COPulseType type, double param1, double param2, int count) | JY5113CoreOO::COPulse
COPulse() | JY5113CoreOO::COPulse
~COPulse() | JY5113CoreOO::COPulse


5113 C++ Programming Manual: Member List

  • COSignalExport
JY5113CoreOO::COSignalExport Member List

This is the complete list of members for JY5113CoreOO::COSignalExport, including all inherited members.

Add(COSignalExportSource source, SignalExportDestination destination) | JY5113CoreOO::COSignalExport
Add(COSignalExportSource source, std::list< SignalExportDestination > destinations) | JY5113CoreOO::COSignalExport
Clear(SignalExportDestination destination) | JY5113CoreOO::COSignalExport
ClearAll() | JY5113CoreOO::COSignalExport


5113 C++ Programming Manual: Member List

  • COTimebase
JY5113CoreOO::COTimebase Member List

This is the complete list of members for JY5113CoreOO::COTimebase, including all inherited members.

ActualFreq | JY5113CoreOO::COTimebase
External | JY5113CoreOO::COTimebase
Source | JY5113CoreOO::COTimebase


5113 C++ Programming Manual: Member List

  • COTrigger
JY5113CoreOO::COTrigger Member List

This is the complete list of members for JY5113CoreOO::COTrigger, including all inherited members.

Digital | JY5113CoreOO::COTrigger
Type | JY5113CoreOO::COTrigger


5113 C++ Programming Manual: Member List

  • DIChannel
JY5113CoreOO::DIChannel Member List

This is the complete list of members for JY5113CoreOO::DIChannel, including all inherited members.

LineNum JY5113CoreOO::DIChannel


5113 C++ Programming Manual: Member List

  • DIDigitalTrigger
JY5113CoreOO::DIDigitalTrigger Member List

This is the complete list of members for JY5113CoreOO::DIDigitalTrigger, including all inherited members.

Edge | JY5113CoreOO::DIDigitalTrigger
Source | JY5113CoreOO::DIDigitalTrigger


5113 C++ Programming Manual: Member List

  • DIExternalSampleClock
JY5113CoreOO::DIExternalSampleClock Member List

This is the complete list of members for JY5113CoreOO::DIExternalSampleClock, including all inherited members.

ExpectedRate | JY5113CoreOO::DIExternalSampleClock
Terminal | JY5113CoreOO::DIExternalSampleClock


5113 C++ Programming Manual: Member List

  • DISampleClock
JY5113CoreOO::DISampleClock Member List

This is the complete list of members for JY5113CoreOO::DISampleClock, including all inherited members.

External | JY5113CoreOO::DISampleClock
Source | JY5113CoreOO::DISampleClock


5113 C++ Programming Manual: Member List

  • DISignalExport
JY5113CoreOO::DISignalExport Member List

This is the complete list of members for JY5113CoreOO::DISignalExport, including all inherited members.

Add(DISignalExportSource source, SignalExportDestination destination) | JY5113CoreOO::DISignalExport
Add(DISignalExportSource source, std::list< SignalExportDestination > destinations) | JY5113CoreOO::DISignalExport
Clear(SignalExportDestination destination) | JY5113CoreOO::DISignalExport
ClearAll() | JY5113CoreOO::DISignalExport


5113 C++ Programming Manual: Member List

  • DITrigger
JY5113CoreOO::DITrigger Member List

This is the complete list of members for JY5113CoreOO::DITrigger, including all inherited members.

Digital | JY5113CoreOO::DITrigger
Mode | JY5113CoreOO::DITrigger
PreTriggerSamples | JY5113CoreOO::DITrigger
Type | JY5113CoreOO::DITrigger


5113 C++ Programming Manual: Member List

  • DOChannel
JY5113CoreOO::DOChannel Member List

This is the complete list of members for JY5113CoreOO::DOChannel, including all inherited members.

LineNum JY5113CoreOO::DOChannel


5113 C++ Programming Manual: Member List

  • DODigitalTrigger
JY5113CoreOO::DODigitalTrigger Member List

This is the complete list of members for JY5113CoreOO::DODigitalTrigger, including all inherited members.

Edge | JY5113CoreOO::DODigitalTrigger
Source | JY5113CoreOO::DODigitalTrigger


5113 C++ Programming Manual: Member List

  • DOExternalSampleClock
JY5113CoreOO::DOExternalSampleClock Member List

This is the complete list of members for JY5113CoreOO::DOExternalSampleClock, including all inherited members.

ExpectedRate | JY5113CoreOO::DOExternalSampleClock
Terminal | JY5113CoreOO::DOExternalSampleClock


5113 C++ Programming Manual: Member List

  • DOSampleClock
JY5113CoreOO::DOSampleClock Member List

This is the complete list of members for JY5113CoreOO::DOSampleClock, including all inherited members.

External | JY5113CoreOO::DOSampleClock
Source | JY5113CoreOO::DOSampleClock


5113 C++ Programming Manual: Member List

  • DOSignalExport
JY5113CoreOO::DOSignalExport Member List

This is the complete list of members for JY5113CoreOO::DOSignalExport, including all inherited members.

Add(DOSignalExportSource source, SignalExportDestination destination) | JY5113CoreOO::DOSignalExport
Add(DOSignalExportSource source, std::list< SignalExportDestination > destinations) | JY5113CoreOO::DOSignalExport
Clear(SignalExportDestination destination) | JY5113CoreOO::DOSignalExport
ClearAll() | JY5113CoreOO::DOSignalExport


5113 C++ Programming Manual: Member List

  • DOTrigger
JY5113CoreOO::DOTrigger Member List

This is the complete list of members for JY5113CoreOO::DOTrigger, including all inherited members.

Digital | JY5113CoreOO::DOTrigger
Type | JY5113CoreOO::DOTrigger


5113 C++ Programming Manual: Member List

  • EdgeCounting
JY5113CoreOO::EdgeCounting Member List

This is the complete list of members for JY5113CoreOO::EdgeCounting, including all inherited members.

ActiveEdge | JY5113CoreOO::EdgeCounting
Direction | JY5113CoreOO::EdgeCounting
DirTerminal | JY5113CoreOO::EdgeCounting
InitialCount | JY5113CoreOO::EdgeCounting
Input_Terminal | JY5113CoreOO::EdgeCounting
OutEvent | JY5113CoreOO::EdgeCounting
Pause | JY5113CoreOO::EdgeCounting


5113 C++ Programming Manual: Member List

  • EdgeCountingOutEvent
JY5113CoreOO::EdgeCountingOutEvent Member List

This is the complete list of members for JY5113CoreOO::EdgeCountingOutEvent, including all inherited members.

IdleState | JY5113CoreOO::EdgeCountingOutEvent
Terminal | JY5113CoreOO::EdgeCountingOutEvent
Threshold | JY5113CoreOO::EdgeCountingOutEvent


5113 C++ Programming Manual: Member List

  • ExternalReferenceClock
JY5113CoreOO::ExternalReferenceClock Member List

This is the complete list of members for JY5113CoreOO::ExternalReferenceClock, including all inherited members.

Terminal JY5113CoreOO::ExternalReferenceClock


5113 C++ Programming Manual: Member List

  • FrequencyMeas
JY5113CoreOO::FrequencyMeas Member List

This is the complete list of members for JY5113CoreOO::FrequencyMeas, including all inherited members.

Input_Terminal | JY5113CoreOO::FrequencyMeas
Timebase | JY5113CoreOO::FrequencyMeas


5113 C++ Programming Manual: Member List

  • JY5113CoreOOAITask
JY5113CoreOO::JY5113CoreOOAITask Member List

This is the complete list of members for JY5113CoreOO::JY5113CoreOOAITask, including all inherited members.

AddChannel(int chnId, double rangeLow=-10, double rangeHigh=10, AITerminal terminalCfg=AITerminal::RSE, AIBandWidth bandWidth=AIBandWidth::_80KHz) | JY5113CoreOO::JY5113CoreOOAITask |
AddChannel(std::vector< int > chnsId, double rangeLow=-10, double rangeHigh=10, AITerminal terminalCfg=AITerminal::RSE, AIBandWidth bandWidth=AIBandWidth::_80KHz) | JY5113CoreOO::JY5113CoreOOAITask |
AddChannel(std::vector< int > chnsId, std::vector< double > rangeLow, std::vector< double > rangeHigh, AITerminal terminalCfg=AITerminal::RSE, AIBandWidth bandWidth=AIBandWidth::_80KHz) | JY5113CoreOO::JY5113CoreOOAITask |
Advanced | JY5113CoreOO::JY5113CoreOOAITask |
AvailableSamples | JY5113CoreOO::JY5113CoreOOAITask |
BufLenInSamples | JY5113CoreOO::JY5113CoreOOAITask |
Channels | JY5113CoreOO::JY5113CoreOOAITask |
Device | JY5113CoreOO::JY5113CoreOOAITask |
DisableCalibration | JY5113CoreOO::JY5113CoreOOAITask |
GetRecordPreviewData(double *buf, int samplesPerChannel, int timeout) | JY5113CoreOO::JY5113CoreOOAITask |
GetRecordStatus(double &recordedLength, bool &recordDone) | JY5113CoreOO::JY5113CoreOOAITask |
JY5113CoreOOAITask(int slotNum) | JY5113CoreOO::JY5113CoreOOAITask |
JY5113CoreOOAITask(std::string boardName) | JY5113CoreOO::JY5113CoreOOAITask |
Mode | JY5113CoreOO::JY5113CoreOOAITask |
ReadData(double *pBuf, int samplesPerChannel, int timeout=-1) | JY5113CoreOO::JY5113CoreOOAITask |
ReadRawData(short *pBuf, int samplesPerChannel, int timeout=-1) | JY5113CoreOO::JY5113CoreOOAITask |
ReadRawSinglePoint(int &readValue, int channel) | JY5113CoreOO::JY5113CoreOOAITask |
ReadRawSinglePoint(std::vector< uint32_t > &readValues) | JY5113CoreOO::JY5113CoreOOAITask |
ReadSinglePoint(double &readValue, int channel) | JY5113CoreOO::JY5113CoreOOAITask |
ReadSinglePoint(std::vector< double > &readValues) | JY5113CoreOO::JY5113CoreOOAITask |
Record | JY5113CoreOO::JY5113CoreOOAITask |
RemoveChannel(int chnId) | JY5113CoreOO::JY5113CoreOOAITask |
SampleClock | JY5113CoreOO::JY5113CoreOOAITask |
SampleRate | JY5113CoreOO::JY5113CoreOOAITask |
SamplesToAcquire | JY5113CoreOO::JY5113CoreOOAITask |
SendSoftwareTrigger() | JY5113CoreOO::JY5113CoreOOAITask |
SignalExport | JY5113CoreOO::JY5113CoreOOAITask |
Start() | JY5113CoreOO::JY5113CoreOOAITask |
Stop() | JY5113CoreOO::JY5113CoreOOAITask |
TransferedSamples | JY5113CoreOO::JY5113CoreOOAITask |
Trigger | JY5113CoreOO::JY5113CoreOOAITask |
WaitUntilDone(int timeout=-1) | JY5113CoreOO::JY5113CoreOOAITask | inline


5113 C++ Programming Manual: Member List

  • JY5113CoreOOAOTask
JY5113CoreOO::JY5113CoreOOAOTask Member List

This is the complete list of members for JY5113CoreOO::JY5113CoreOOAOTask, including all inherited members.

AddChannel(int chnId, double rangeLow=-10, double rangeHigh=10) | JY5113CoreOO::JY5113CoreOOAOTask
AddChannel(std::vector< int > chnsId, double rangeLow=-10, double rangeHigh=10) | JY5113CoreOO::JY5113CoreOOAOTask
AddChannel(std::vector< int > chnsId, std::vector< double > rangeLow, std::vector< double > rangeHigh) | JY5113CoreOO::JY5113CoreOOAOTask
AvaliableLenInSamples | JY5113CoreOO::JY5113CoreOOAOTask
BufLenInSamples | JY5113CoreOO::JY5113CoreOOAOTask
Channels | JY5113CoreOO::JY5113CoreOOAOTask
CompleteState | JY5113CoreOO::JY5113CoreOOAOTask
Device | JY5113CoreOO::JY5113CoreOOAOTask
DisableCalibration | JY5113CoreOO::JY5113CoreOOAOTask
JY5113CoreOOAOTask(int slotNum) | JY5113CoreOO::JY5113CoreOOAOTask
JY5113CoreOOAOTask(std::string boardName) | JY5113CoreOO::JY5113CoreOOAOTask
Mode | JY5113CoreOO::JY5113CoreOOAOTask
RemoveChannel(int chnId) | JY5113CoreOO::JY5113CoreOOAOTask
SampleClock | JY5113CoreOO::JY5113CoreOOAOTask
SamplesToUpdate | JY5113CoreOO::JY5113CoreOOAOTask
SendSoftwareTrigger() | JY5113CoreOO::JY5113CoreOOAOTask
SignalExport | JY5113CoreOO::JY5113CoreOOAOTask
Start() | JY5113CoreOO::JY5113CoreOOAOTask
Stop() | JY5113CoreOO::JY5113CoreOOAOTask
TransferedSamples | JY5113CoreOO::JY5113CoreOOAOTask
Trigger | JY5113CoreOO::JY5113CoreOOAOTask
UpdateRate | JY5113CoreOO::JY5113CoreOOAOTask
WaitUntilDone(int timeout=-1) | JY5113CoreOO::JY5113CoreOOAOTask
WriteData(double *pBuf, int samplesPerChannel, int timeout=10000) | JY5113CoreOO::JY5113CoreOOAOTask
WriteRawData(int16_t *pBuf, int samplesPerChannel, int timeout=10000) | JY5113CoreOO::JY5113CoreOOAOTask
WriteRawSinglePoint(std::vector< int16_t > writeValues) | JY5113CoreOO::JY5113CoreOOAOTask
WriteRawSinglePoint(int16_t writeValue, int channel) | JY5113CoreOO::JY5113CoreOOAOTask
WriteSinglePoint(std::vector< double > writeValues) | JY5113CoreOO::JY5113CoreOOAOTask
WriteSinglePoint(double writeValue, int channel) | JY5113CoreOO::JY5113CoreOOAOTask
~JY5113CoreOOAOTask() | JY5113CoreOO::JY5113CoreOOAOTask


5113 C++ Programming Manual: Member List

  • JY5113CoreOOCITask
JY5113CoreOO::JY5113CoreOOCITask Member List

This is the complete list of members for JY5113CoreOO::JY5113CoreOOCITask, including all inherited members.

AvailableSamples | JY5113CoreOO::JY5113CoreOOCITask
Device | JY5113CoreOO::JY5113CoreOOCITask
EdgeCounting | JY5113CoreOO::JY5113CoreOOCITask
FrequencyMeas | JY5113CoreOO::JY5113CoreOOCITask
JY5113CoreOOCITask(int slotNum, int channel) | JY5113CoreOO::JY5113CoreOOCITask
JY5113CoreOOCITask(std::string boardName, int channel) | JY5113CoreOO::JY5113CoreOOCITask
Mode | JY5113CoreOO::JY5113CoreOOCITask
PeriodMeas | JY5113CoreOO::JY5113CoreOOCITask
PulseMeas | JY5113CoreOO::JY5113CoreOOCITask
QuadEncoder | JY5113CoreOO::JY5113CoreOOCITask
ReadData(uint32_t *pBufCount, int samplesToAcquire, int timeout=10000) | JY5113CoreOO::JY5113CoreOOCITask
ReadData(double *pBufMeasurement, int samplesToAcquire, int timeout=10000) | JY5113CoreOO::JY5113CoreOOCITask
ReadData(double *pBufMeasurement1, double *pBufMeasurement2, int samplesToAcquire, int timeout=10000) | JY5113CoreOO::JY5113CoreOOCITask
ReadSinglePoint(uint32_t &count) | JY5113CoreOO::JY5113CoreOOCITask
ReadSinglePoint(double &measurement, int timeout=10000) | JY5113CoreOO::JY5113CoreOOCITask
ReadSinglePoint(double &measurement1, double &measurement2, int timeout=10000) | JY5113CoreOO::JY5113CoreOOCITask
SampleClock | JY5113CoreOO::JY5113CoreOOCITask
SamplesToAcquire | JY5113CoreOO::JY5113CoreOOCITask
SemiPeriodMeas | JY5113CoreOO::JY5113CoreOOCITask
SendSoftwareTrigger() | JY5113CoreOO::JY5113CoreOOCITask
SignalExport | JY5113CoreOO::JY5113CoreOOCITask
Start() | JY5113CoreOO::JY5113CoreOOCITask
Stop() | JY5113CoreOO::JY5113CoreOOCITask
TransferedSamples | JY5113CoreOO::JY5113CoreOOCITask
Trigger | JY5113CoreOO::JY5113CoreOOCITask
TwoEdgeSeparation | JY5113CoreOO::JY5113CoreOOCITask
TwoPulseEncoder | JY5113CoreOO::JY5113CoreOOCITask
Type | JY5113CoreOO::JY5113CoreOOCITask
~JY5113CoreOOCITask() | JY5113CoreOO::JY5113CoreOOCITask


5113 C++ Programming Manual: Member List

  • JY5113CoreOOCOTask
JY5113CoreOO::JY5113CoreOOCOTask Member List

This is the complete list of members for JY5113CoreOO::JY5113CoreOOCOTask, including all inherited members.

AvailableSamples | JY5113CoreOO::JY5113CoreOOCOTask
Device | JY5113CoreOO::JY5113CoreOOCOTask
IdleState | JY5113CoreOO::JY5113CoreOOCOTask
InitialDelay | JY5113CoreOO::JY5113CoreOOCOTask
JY5113CoreOOCOTask(int slotNum, int channel) | JY5113CoreOO::JY5113CoreOOCOTask
JY5113CoreOOCOTask(std::string boardName, int channel) | JY5113CoreOO::JY5113CoreOOCOTask
Mode | JY5113CoreOO::JY5113CoreOOCOTask
OutputTerminal | JY5113CoreOO::JY5113CoreOOCOTask
Pause | JY5113CoreOO::JY5113CoreOOCOTask
SamplesToUpdate | JY5113CoreOO::JY5113CoreOOCOTask
SendSoftwareTrigger() | JY5113CoreOO::JY5113CoreOOCOTask
SignalExport | JY5113CoreOO::JY5113CoreOOCOTask
Start() | JY5113CoreOO::JY5113CoreOOCOTask
Stop() | JY5113CoreOO::JY5113CoreOOCOTask
Timebase | JY5113CoreOO::JY5113CoreOOCOTask
TransferedPulses | JY5113CoreOO::JY5113CoreOOCOTask
TransferedSamples | JY5113CoreOO::JY5113CoreOOCOTask
Trigger | JY5113CoreOO::JY5113CoreOOCOTask
WaitUntilDone(int timeout=-1) | JY5113CoreOO::JY5113CoreOOCOTask
WriteData(COPulse *pulsesGroup[], int samplesToWrite, int timeout=10000) | JY5113CoreOO::JY5113CoreOOCOTask
WriteSinglePoint(COPulse &pulse) | JY5113CoreOO::JY5113CoreOOCOTask
~JY5113CoreOOCOTask() | JY5113CoreOO::JY5113CoreOOCOTask


5113 C++ Programming Manual: Member List

  • JY5113CoreOODITask
JY5113CoreOO::JY5113CoreOODITask Member List

This is the complete list of members for JY5113CoreOO::JY5113CoreOODITask, including all inherited members.

AddChannel(int portNum) | JY5113CoreOO::JY5113CoreOODITask
AddChannel(std::vector< int > portsNum) | JY5113CoreOO::JY5113CoreOODITask
AvailableSamples | JY5113CoreOO::JY5113CoreOODITask
BufLenInSamples | JY5113CoreOO::JY5113CoreOODITask
Channels | JY5113CoreOO::JY5113CoreOODITask
Device | JY5113CoreOO::JY5113CoreOODITask
JY5113CoreOODITask(int slotNum) | JY5113CoreOO::JY5113CoreOODITask
JY5113CoreOODITask(std::string boardName) | JY5113CoreOO::JY5113CoreOODITask
Mode | JY5113CoreOO::JY5113CoreOODITask
ReadData(unsigned short dataBuffer[], unsigned int samplesToAcquire, int timeOut) | JY5113CoreOO::JY5113CoreOODITask
ReadSinglePoint(bool *readValues, int line) | JY5113CoreOO::JY5113CoreOODITask
ReadSinglePoint(std::vector< bool > &readValues) | JY5113CoreOO::JY5113CoreOODITask
ReadSinglePoint(bool readValues[]) | JY5113CoreOO::JY5113CoreOODITask
RemoveChannel(int portNum) | JY5113CoreOO::JY5113CoreOODITask
SampleClock | JY5113CoreOO::JY5113CoreOODITask
SampleRate | JY5113CoreOO::JY5113CoreOODITask
SamplesToAcquire | JY5113CoreOO::JY5113CoreOODITask
SendSoftwareTrigger() | JY5113CoreOO::JY5113CoreOODITask
SignalExport | JY5113CoreOO::JY5113CoreOODITask
Start() | JY5113CoreOO::JY5113CoreOODITask
Stop() | JY5113CoreOO::JY5113CoreOODITask
TransferedSamples | JY5113CoreOO::JY5113CoreOODITask
Trigger | JY5113CoreOO::JY5113CoreOODITask
~JY5113CoreOODITask() | JY5113CoreOO::JY5113CoreOODITask


5113 C++ Programming Manual: Member List

  • JY5113CoreOODOTask
JY5113CoreOO::JY5113CoreOODOTask Member List

This is the complete list of members for JY5113CoreOO::JY5113CoreOODOTask, including all inherited members.

AddChannel(int portNum) | JY5113CoreOO::JY5113CoreOODOTask
AddChannel(std::vector< int > portsNum) | JY5113CoreOO::JY5113CoreOODOTask
AvaliableLenInSamples | JY5113CoreOO::JY5113CoreOODOTask
BufLenInSamples | JY5113CoreOO::JY5113CoreOODOTask
Channels | JY5113CoreOO::JY5113CoreOODOTask
CompleteState | JY5113CoreOO::JY5113CoreOODOTask
Device | JY5113CoreOO::JY5113CoreOODOTask
JY5113CoreOODOTask(int slotNum) | JY5113CoreOO::JY5113CoreOODOTask
JY5113CoreOODOTask(std::string boardName) | JY5113CoreOO::JY5113CoreOODOTask
Mode | JY5113CoreOO::JY5113CoreOODOTask
RemoveChannel(int portNum) | JY5113CoreOO::JY5113CoreOODOTask
SampleClock | JY5113CoreOO::JY5113CoreOODOTask
SamplesToUpdate | JY5113CoreOO::JY5113CoreOODOTask
SendSoftwareTrigger() | JY5113CoreOO::JY5113CoreOODOTask
SignalExport | JY5113CoreOO::JY5113CoreOODOTask
Start() | JY5113CoreOO::JY5113CoreOODOTask
Stop() | JY5113CoreOO::JY5113CoreOODOTask
TransferedSamples | JY5113CoreOO::JY5113CoreOODOTask
Trigger | JY5113CoreOO::JY5113CoreOODOTask
UpdateRate | JY5113CoreOO::JY5113CoreOODOTask
WaitUntilDone(int timeout=-1) | JY5113CoreOO::JY5113CoreOODOTask
WriteData(unsigned short dataBuffer[], unsigned int samplesToUpdate, int timeOut) | JY5113CoreOO::JY5113CoreOODOTask
WriteSinglePoint(bool writeValues, int line) | JY5113CoreOO::JY5113CoreOODOTask
WriteSinglePoint(std::vector< bool > &writeValues) | JY5113CoreOO::JY5113CoreOODOTask
~JY5113CoreOODOTask() | JY5113CoreOO::JY5113CoreOODOTask


5113 C++ Programming Manual: Member List

  • JY5113CoreOODevice
JY5113CoreOO::JY5113CoreOODevice Member List

This is the complete list of members for JY5113CoreOO::JY5113CoreOODevice, including all inherited members.

AIBufferSize | JY5113CoreOO::JY5113CoreOODevice |
AOChannelCount | JY5113CoreOO::JY5113CoreOODevice |
BoardClockRate | JY5113CoreOO::JY5113CoreOODevice |
DeviceID | JY5113CoreOO::JY5113CoreOODevice |
DiffChannelCount | JY5113CoreOO::JY5113CoreOODevice |
GetInstance(int cardNum) | JY5113CoreOO::JY5113CoreOODevice | static
GetInstance(std::string aliasName) | JY5113CoreOO::JY5113CoreOODevice | static
Handle | JY5113CoreOO::JY5113CoreOODevice |
IsAISync | JY5113CoreOO::JY5113CoreOODevice |
IsAOSync | JY5113CoreOO::JY5113CoreOODevice |
MaxSampleRate | JY5113CoreOO::JY5113CoreOODevice |
MaxSampleRateSingleChannel | JY5113CoreOO::JY5113CoreOODevice |
MaxUpdateRate | JY5113CoreOO::JY5113CoreOODevice |
MaxUpdateRateSingleChannel | JY5113CoreOO::JY5113CoreOODevice |
PFI | JY5113CoreOO::JY5113CoreOODevice |
ReferenceClock | JY5113CoreOO::JY5113CoreOODevice |
SEChannelCount | JY5113CoreOO::JY5113CoreOODevice |
SerialNumber | JY5113CoreOO::JY5113CoreOODevice |


5113 C++ Programming Manual: Member List

  • JY5113CoreOOLog
JY5113CoreOO::JY5113CoreOOLog Member List

This is the complete list of members for JY5113CoreOO::JY5113CoreOOLog, including all inherited members.

EnableLog | JY5113CoreOO::JY5113CoreOOLog | static
Flush() | JY5113CoreOO::JY5113CoreOOLog | static
LogLevel | JY5113CoreOO::JY5113CoreOOLog | static
Print(const char *format,...) | JY5113CoreOO::JY5113CoreOOLog | static
Print(JY5113CoreOOLogLevel logLevel, const char *format,...) | JY5113CoreOO::JY5113CoreOOLog | static


5113 C++ Programming Manual: Member List

  • JY5113CoreOOProperty
JY5113CoreOO::JY5113CoreOOProperty< ContainerClass, ValueType, propertyType > Member List

This is the complete list of members for JY5113CoreOO::JY5113CoreOOProperty< ContainerClass, ValueType, propertyType >, including all inherited members.

JY5113CoreOOProperty() | JY5113CoreOO::JY5113CoreOOProperty< ContainerClass, ValueType, propertyType >
JY5113CoreOOProperty(ContainerClass *cObject, ValueType(ContainerClass::*pGet)(), void(ContainerClass::*pSet)(ValueType value)) | JY5113CoreOO::JY5113CoreOOProperty< ContainerClass, ValueType, propertyType >
JY5113CoreOOProperty(ValueType(*pGet)(), void(*pSet)(ValueType value)) | JY5113CoreOO::JY5113CoreOOProperty< ContainerClass, ValueType, propertyType >
operator ValueType() | JY5113CoreOO::JY5113CoreOOProperty< ContainerClass, ValueType, propertyType >
operator=(const ValueType &value) | JY5113CoreOO::JY5113CoreOOProperty< ContainerClass, ValueType, propertyType >


5113 C++ Programming Manual: Member List

  • JY5113CoreOOReferenceClock
JY5113CoreOO::JY5113CoreOOReferenceClock Member List

This is the complete list of members for JY5113CoreOO::JY5113CoreOOReferenceClock, including all inherited members.

Commit() | JY5113CoreOO::JY5113CoreOOReferenceClock
External | JY5113CoreOO::JY5113CoreOOReferenceClock
Source | JY5113CoreOO::JY5113CoreOOReferenceClock


5113 C++ Programming Manual: Member List

  • JYDriverException
JY5113CoreOO::JYDriverException Member List

This is the complete list of members for JY5113CoreOO::JYDriverException, including all inherited members.

errorCode | JY5113CoreOO::JYDriverException
exceptionMessage | JY5113CoreOO::JYDriverException
FollowingException | JY5113CoreOO::JYDriverException
JYDriverException(JYDriverExceptionPublic exceptionCode, std::string msg="") | JY5113CoreOO::JYDriverException
JYDriverException(int, std::string msg) | JY5113CoreOO::JYDriverException


5113 C++ Programming Manual: Member List

  • PFIFilter
JY5113CoreOO::PFIFilter Member List

This is the complete list of members for JY5113CoreOO::PFIFilter, including all inherited members.

Disable(PFITerminal terminal) | JY5113CoreOO::PFIFilter
Disable(std::vector< PFITerminal > terminals) | JY5113CoreOO::PFIFilter
DisableAll() | JY5113CoreOO::PFIFilter
Enable(PFITerminal terminal, int minPulseWidth) | JY5113CoreOO::PFIFilter
Enable(std::vector< PFITerminal > terminals, int minPulseWidth) | JY5113CoreOO::PFIFilter
Enable(std::vector< PFITerminal > terminals, std::vector< int > minPulseWidth) | JY5113CoreOO::PFIFilter


5113 C++ Programming Manual: Member List

  • PFISetting
JY5113CoreOO::PFISetting Member List

This is the complete list of members for JY5113CoreOO::PFISetting, including all inherited members.

Filter JY5113CoreOO::PFISetting


5113 C++ Programming Manual: Member List

  • PauseTrigger
JY5113CoreOO::PauseTrigger Member List

This is the complete list of members for JY5113CoreOO::PauseTrigger, including all inherited members.

ActivePolarity | JY5113CoreOO::PauseTrigger
Terminal | JY5113CoreOO::PauseTrigger


5113 C++ Programming Manual: Member List

  • PeriodMeas
JY5113CoreOO::PeriodMeas Member List

This is the complete list of members for JY5113CoreOO::PeriodMeas, including all inherited members.

Input_Terminal | JY5113CoreOO::PeriodMeas
Timebase | JY5113CoreOO::PeriodMeas


5113 C++ Programming Manual: Member List

  • PulseMeas
JY5113CoreOO::PulseMeas Member List

This is the complete list of members for JY5113CoreOO::PulseMeas, including all inherited members.

Input_Terminal | JY5113CoreOO::PulseMeas
StartingEdge | JY5113CoreOO::PulseMeas
Timebase | JY5113CoreOO::PulseMeas


5113 C++ Programming Manual: Member List

  • QuadEncoder
JY5113CoreOO::QuadEncoder Member List

This is the complete list of members for JY5113CoreOO::QuadEncoder, including all inherited members.

AInputTerminal | JY5113CoreOO::QuadEncoder
BInputTerminal | JY5113CoreOO::QuadEncoder
EncodingType | JY5113CoreOO::QuadEncoder
InitialCount | JY5113CoreOO::QuadEncoder
ZInputTerminal | JY5113CoreOO::QuadEncoder
ZReloadEnabled | JY5113CoreOO::QuadEncoder


5113 C++ Programming Manual: Member List

  • SemiPeriodMeas
JY5113CoreOO::SemiPeriodMeas Member List

This is the complete list of members for JY5113CoreOO::SemiPeriodMeas, including all inherited members.

Input_Terminal | JY5113CoreOO::SemiPeriodMeas |
JY5113CoreOOCITask class | JY5113CoreOO::SemiPeriodMeas | friend
StartingEdge | JY5113CoreOO::SemiPeriodMeas |
Timebase | JY5113CoreOO::SemiPeriodMeas |


5113 C++ Programming Manual: Member List

  • TwoEdgeSeparation
JY5113CoreOO::TwoEdgeSeparation Member List

This is the complete list of members for JY5113CoreOO::TwoEdgeSeparation, including all inherited members.

EdgeSeparationMode | JY5113CoreOO::TwoEdgeSeparation
FirstInputTerminal | JY5113CoreOO::TwoEdgeSeparation
SecondInputTerminal | JY5113CoreOO::TwoEdgeSeparation
Timebase | JY5113CoreOO::TwoEdgeSeparation


5113 C++ Programming Manual: Member List

  • TwoPulseEncoder
JY5113CoreOO::TwoPulseEncoder Member List

This is the complete list of members for JY5113CoreOO::TwoPulseEncoder, including all inherited members.

AInputTerminal | JY5113CoreOO::TwoPulseEncoder
BInputTerminal | JY5113CoreOO::TwoPulseEncoder
InitialCount | JY5113CoreOO::TwoPulseEncoder


5113 C++ Programming Manual: JY5113CoreOOAIMode Class Reference

JY5113CoreOOAIMode Class Reference

AIMode. More...

#include <JY5113CoreOOAITask.h>

Detailed Description

AIMode.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5113/JY5113CoreOOAITask.h


5113 C++ Programming Manual: Class Index

Class Index
A | C | D | E | F | J | P | Q | S | T
A
AIAdvanced (JY5113CoreOO)
AIAnalogEdgeComparator (JY5113CoreOO)
AIAnalogHysteresisComparator (JY5113CoreOO)
AIAnalogTrigger (JY5113CoreOO)
AIAnalogWindowComparator (JY5113CoreOO)
AIChannel (JY5113CoreOO)
AIDigitalTrigger (JY5113CoreOO)
AIDSMode (JY5113CoreOO)
AIExternalSampleClock (JY5113CoreOO)
AIRecord (JY5113CoreOO)
AISampleClock (JY5113CoreOO)
AISignalExport (JY5113CoreOO)
AITrigger (JY5113CoreOO)
AOChannel (JY5113CoreOO)
AODigitalTrigger (JY5113CoreOO)
AOExternalSampleClock (JY5113CoreOO)
AOMode
AOSampleClock (JY5113CoreOO)
AOSignalExport (JY5113CoreOO)
AOTrigger (JY5113CoreOO)
C
CIDigitalTrigger (JY5113CoreOO)
CIExternalSampleClock (JY5113CoreOO)
CIExternalTimebase (JY5113CoreOO)
CIImplicitSampleClock (JY5113CoreOO)
CIInternalSampleClock (JY5113CoreOO)
CISampleClock (JY5113CoreOO)
CISignalExport (JY5113CoreOO)
CITimebase (JY5113CoreOO)
CITrigger (JY5113CoreOO)
CODigitalTrigger (JY5113CoreOO)
COExternalTimebase (JY5113CoreOO)
COPulse (JY5113CoreOO)
COSignalExport (JY5113CoreOO)
COTimebase (JY5113CoreOO)
COTrigger (JY5113CoreOO)
D
DIChannel (JY5113CoreOO)
DIDigitalTrigger (JY5113CoreOO)
DIExternalSampleClock (JY5113CoreOO)
DISampleClock (JY5113CoreOO)
DISignalExport (JY5113CoreOO)
DITrigger (JY5113CoreOO)
DOChannel (JY5113CoreOO)
DODigitalTrigger (JY5113CoreOO)
DOExternalSampleClock (JY5113CoreOO)
DOSampleClock (JY5113CoreOO)
DOSignalExport (JY5113CoreOO)
DOTrigger (JY5113CoreOO)
E
EdgeCounting (JY5113CoreOO)
EdgeCountingOutEvent (JY5113CoreOO)
ExternalReferenceClock (JY5113CoreOO)
F
FrequencyMeas (JY5113CoreOO)
J
JY5113CoreOOAIMode
JY5113CoreOOAITask (JY5113CoreOO)
JY5113CoreOOAOTask (JY5113CoreOO)
JY5113CoreOOCITask (JY5113CoreOO)
JY5113CoreOOCOTask (JY5113CoreOO)
JY5113CoreOODevice (JY5113CoreOO)
JY5113CoreOODITask (JY5113CoreOO)
JY5113CoreOODOTask (JY5113CoreOO)
JY5113CoreOOLog (JY5113CoreOO)
JY5113CoreOOProperty (JY5113CoreOO)
JY5113CoreOOReferenceClock (JY5113CoreOO)
JYDriverException (JY5113CoreOO)
P
PauseTrigger (JY5113CoreOO)
PeriodMeas (JY5113CoreOO)
PFIFilter (JY5113CoreOO)
PFISetting (JY5113CoreOO)
PulseMeas (JY5113CoreOO)
Q
QuadEncoder (JY5113CoreOO)
S
SemiPeriodMeas (JY5113CoreOO)
T
TwoEdgeSeparation (JY5113CoreOO)
TwoPulseEncoder (JY5113CoreOO)


5113 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO Directory Reference

  • File List
  • File Members
  • COO
COO Directory Reference

Directories

5113


5113 C++ Programming Manual: File List

  • File List
  • File Members
File List
Here is a list of all files with brief descriptions:
[detail level 123]
▼ COO
▼ 5113
JY5113CoreOOAITask.h
JY5113CoreOOAOTask.h
JY5113CoreOOCITask.h
JY5113CoreOOCommon.h
JY5113CoreOOCOTask.h
JY5113CoreOODevice.h
JY5113CoreOODITask.h
JY5113CoreOODOTask.h
JY5113CoreOOLog.h


5113 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- a -

  • ActiveEdge : JY5113CoreOO::EdgeCounting
  • ActivePolarity : JY5113CoreOO::PauseTrigger
  • ActualFreq : JY5113CoreOO::CITimebase, JY5113CoreOO::COTimebase
  • Add() : JY5113CoreOO::AISignalExport, JY5113CoreOO::AOSignalExport, JY5113CoreOO::CISignalExport, JY5113CoreOO::COSignalExport, JY5113CoreOO::DISignalExport, JY5113CoreOO::DOSignalExport
  • AddChannel() : JY5113CoreOO::JY5113CoreOOAITask, JY5113CoreOO::JY5113CoreOOAOTask, JY5113CoreOO::JY5113CoreOODITask, JY5113CoreOO::JY5113CoreOODOTask
  • Advanced : JY5113CoreOO::JY5113CoreOOAITask
  • AIBufferSize : JY5113CoreOO::JY5113CoreOODevice
  • AIChannel() : JY5113CoreOO::AIChannel
  • AInputTerminal : JY5113CoreOO::QuadEncoder, JY5113CoreOO::TwoPulseEncoder
  • Analog : JY5113CoreOO::AITrigger
  • AOChannel() : JY5113CoreOO::AOChannel
  • AOChannelCount : JY5113CoreOO::JY5113CoreOODevice
  • AvailableSamples : JY5113CoreOO::JY5113CoreOOAITask, JY5113CoreOO::JY5113CoreOOCITask, JY5113CoreOO::JY5113CoreOOCOTask, JY5113CoreOO::JY5113CoreOODITask
  • AvaliableLenInSamples : JY5113CoreOO::JY5113CoreOOAOTask, JY5113CoreOO::JY5113CoreOODOTask


5113 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- b -

  • BandWidth : JY5113CoreOO::AIChannel
  • BInputTerminal : JY5113CoreOO::QuadEncoder, JY5113CoreOO::TwoPulseEncoder
  • BoardClockRate : JY5113CoreOO::JY5113CoreOODevice
  • BufLenInSamples : JY5113CoreOO::JY5113CoreOOAITask, JY5113CoreOO::JY5113CoreOOAOTask, JY5113CoreOO::JY5113CoreOODITask, JY5113CoreOO::JY5113CoreOODOTask


5113 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- c -

  • ChannelID : JY5113CoreOO::AIChannel, JY5113CoreOO::AOChannel
  • Channels : JY5113CoreOO::JY5113CoreOOAITask, JY5113CoreOO::JY5113CoreOOAOTask, JY5113CoreOO::JY5113CoreOODITask, JY5113CoreOO::JY5113CoreOODOTask
  • CIExternalTimebase() : JY5113CoreOO::CIExternalTimebase
  • Clear() : JY5113CoreOO::AISignalExport, JY5113CoreOO::AOSignalExport, JY5113CoreOO::CISignalExport, JY5113CoreOO::COSignalExport, JY5113CoreOO::DISignalExport, JY5113CoreOO::DOSignalExport
  • ClearAll() : JY5113CoreOO::AISignalExport, JY5113CoreOO::AOSignalExport, JY5113CoreOO::CISignalExport, JY5113CoreOO::COSignalExport, JY5113CoreOO::DISignalExport, JY5113CoreOO::DOSignalExport
  • COExternalTimebase() : JY5113CoreOO::COExternalTimebase
  • Commit() : JY5113CoreOO::JY5113CoreOOReferenceClock
  • Comparator : JY5113CoreOO::AIAnalogTrigger
  • CompleteState : JY5113CoreOO::JY5113CoreOOAOTask, JY5113CoreOO::JY5113CoreOODOTask
  • Condition : JY5113CoreOO::AIAnalogWindowComparator
  • ConvertRate : JY5113CoreOO::AIAdvanced
  • COPulse() : JY5113CoreOO::COPulse


5113 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- d -

  • Device : JY5113CoreOO::JY5113CoreOOAITask, JY5113CoreOO::JY5113CoreOOAOTask, JY5113CoreOO::JY5113CoreOOCITask, JY5113CoreOO::JY5113CoreOOCOTask, JY5113CoreOO::JY5113CoreOODITask, JY5113CoreOO::JY5113CoreOODOTask
  • DeviceID : JY5113CoreOO::JY5113CoreOODevice
  • DiffChannelCount : JY5113CoreOO::JY5113CoreOODevice
  • Digital : JY5113CoreOO::AITrigger, JY5113CoreOO::AOTrigger, JY5113CoreOO::CITrigger, JY5113CoreOO::COTrigger, JY5113CoreOO::DITrigger, JY5113CoreOO::DOTrigger
  • Direction : JY5113CoreOO::EdgeCounting
  • DirTerminal : JY5113CoreOO::EdgeCounting
  • Disable() : JY5113CoreOO::PFIFilter
  • DisableAll() : JY5113CoreOO::PFIFilter
  • DisableCalibration : JY5113CoreOO::JY5113CoreOOAITask, JY5113CoreOO::JY5113CoreOOAOTask
  • DSMode : JY5113CoreOO::AIAdvanced


5113 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- e -

  • Edge : JY5113CoreOO::AIAnalogTrigger, JY5113CoreOO::AIDigitalTrigger, JY5113CoreOO::AODigitalTrigger, JY5113CoreOO::CIDigitalTrigger, JY5113CoreOO::CODigitalTrigger, JY5113CoreOO::DIDigitalTrigger, JY5113CoreOO::DODigitalTrigger
  • EdgeCounting : JY5113CoreOO::JY5113CoreOOCITask
  • EdgeSeparationMode : JY5113CoreOO::TwoEdgeSeparation
  • Enable : JY5113CoreOO::AIDSMode, JY5113CoreOO::PFIFilter
  • EnableLog : JY5113CoreOO::JY5113CoreOOLog
  • EncodingType : JY5113CoreOO::QuadEncoder
  • errorCode : JY5113CoreOO::JYDriverException
  • exceptionMessage : JY5113CoreOO::JYDriverException
  • ExpectedRate : JY5113CoreOO::AIExternalSampleClock, JY5113CoreOO::AOExternalSampleClock, JY5113CoreOO::CIExternalSampleClock, JY5113CoreOO::CIImplicitSampleClock, JY5113CoreOO::DIExternalSampleClock, JY5113CoreOO::DOExternalSampleClock
  • External : JY5113CoreOO::AISampleClock, JY5113CoreOO::AOSampleClock, JY5113CoreOO::CISampleClock, JY5113CoreOO::CITimebase, JY5113CoreOO::COTimebase, JY5113CoreOO::DISampleClock, JY5113CoreOO::DOSampleClock, JY5113CoreOO::JY5113CoreOOReferenceClock


5113 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- f -

  • File_Format : JY5113CoreOO::AIRecord
  • FilePath : JY5113CoreOO::AIRecord
  • Filter : JY5113CoreOO::PFISetting
  • FirstInputTerminal : JY5113CoreOO::TwoEdgeSeparation
  • Flush() : JY5113CoreOO::JY5113CoreOOLog
  • FollowingException : JY5113CoreOO::JYDriverException
  • Frequency : JY5113CoreOO::CIExternalTimebase, JY5113CoreOO::COExternalTimebase
  • FrequencyMeas : JY5113CoreOO::JY5113CoreOOCITask


5113 C++ Programming Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • c
  • d
  • e
  • f
  • g
  • j
  • o
  • p
  • r
  • s
  • w
  • ~
Here is a list of all functions with links to the classes they belong to:

- a -

  • Add() : JY5113CoreOO::AISignalExport, JY5113CoreOO::AOSignalExport, JY5113CoreOO::CISignalExport, JY5113CoreOO::COSignalExport, JY5113CoreOO::DISignalExport, JY5113CoreOO::DOSignalExport
  • AddChannel() : JY5113CoreOO::JY5113CoreOOAITask, JY5113CoreOO::JY5113CoreOOAOTask, JY5113CoreOO::JY5113CoreOODITask, JY5113CoreOO::JY5113CoreOODOTask
  • AIChannel() : JY5113CoreOO::AIChannel
  • AOChannel() : JY5113CoreOO::AOChannel

- c -

  • CIExternalTimebase() : JY5113CoreOO::CIExternalTimebase
  • Clear() : JY5113CoreOO::AISignalExport, JY5113CoreOO::AOSignalExport, JY5113CoreOO::CISignalExport, JY5113CoreOO::COSignalExport, JY5113CoreOO::DISignalExport, JY5113CoreOO::DOSignalExport
  • ClearAll() : JY5113CoreOO::AISignalExport, JY5113CoreOO::AOSignalExport, JY5113CoreOO::CISignalExport, JY5113CoreOO::COSignalExport, JY5113CoreOO::DISignalExport, JY5113CoreOO::DOSignalExport
  • COExternalTimebase() : JY5113CoreOO::COExternalTimebase
  • Commit() : JY5113CoreOO::JY5113CoreOOReferenceClock
  • COPulse() : JY5113CoreOO::COPulse

- d -

  • Disable() : JY5113CoreOO::PFIFilter
  • DisableAll() : JY5113CoreOO::PFIFilter

- e -

  • Enable() : JY5113CoreOO::PFIFilter

- f -

  • Flush() : JY5113CoreOO::JY5113CoreOOLog

- g -

  • GetInstance() : JY5113CoreOO::JY5113CoreOODevice
  • GetRecordPreviewData() : JY5113CoreOO::JY5113CoreOOAITask
  • GetRecordStatus() : JY5113CoreOO::JY5113CoreOOAITask

- j -

  • JY5113CoreOOAITask() : JY5113CoreOO::JY5113CoreOOAITask
  • JY5113CoreOOAOTask() : JY5113CoreOO::JY5113CoreOOAOTask
  • JY5113CoreOOCITask() : JY5113CoreOO::JY5113CoreOOCITask
  • JY5113CoreOOCOTask() : JY5113CoreOO::JY5113CoreOOCOTask
  • JY5113CoreOODITask() : JY5113CoreOO::JY5113CoreOODITask
  • JY5113CoreOODOTask() : JY5113CoreOO::JY5113CoreOODOTask
  • JY5113CoreOOProperty() : JY5113CoreOO::JY5113CoreOOProperty< ContainerClass, ValueType, propertyType >
  • JYDriverException() : JY5113CoreOO::JYDriverException

- o -

  • operator ValueType() : JY5113CoreOO::JY5113CoreOOProperty< ContainerClass, ValueType, propertyType >
  • operator=() : JY5113CoreOO::JY5113CoreOOProperty< ContainerClass, ValueType, propertyType >

- p -

  • Print() : JY5113CoreOO::JY5113CoreOOLog

- r -

  • ReadData() : JY5113CoreOO::JY5113CoreOOAITask, JY5113CoreOO::JY5113CoreOOCITask, JY5113CoreOO::JY5113CoreOODITask
  • ReadRawData() : JY5113CoreOO::JY5113CoreOOAITask
  • ReadRawSinglePoint() : JY5113CoreOO::JY5113CoreOOAITask
  • ReadSinglePoint() : JY5113CoreOO::JY5113CoreOOAITask, JY5113CoreOO::JY5113CoreOOCITask, JY5113CoreOO::JY5113CoreOODITask
  • RemoveChannel() : JY5113CoreOO::JY5113CoreOOAITask, JY5113CoreOO::JY5113CoreOOAOTask, JY5113CoreOO::JY5113CoreOODITask, JY5113CoreOO::JY5113CoreOODOTask

- s -

  • SendSoftwareTrigger() : JY5113CoreOO::JY5113CoreOOAITask, JY5113CoreOO::JY5113CoreOOAOTask, JY5113CoreOO::JY5113CoreOOCITask, JY5113CoreOO::JY5113CoreOOCOTask, JY5113CoreOO::JY5113CoreOODITask, JY5113CoreOO::JY5113CoreOODOTask
  • Start() : JY5113CoreOO::JY5113CoreOOAITask, JY5113CoreOO::JY5113CoreOOAOTask, JY5113CoreOO::JY5113CoreOOCITask, JY5113CoreOO::JY5113CoreOOCOTask, JY5113CoreOO::JY5113CoreOODITask, JY5113CoreOO::JY5113CoreOODOTask
  • Stop() : JY5113CoreOO::JY5113CoreOOAITask, JY5113CoreOO::JY5113CoreOOAOTask, JY5113CoreOO::JY5113CoreOOCITask, JY5113CoreOO::JY5113CoreOOCOTask, JY5113CoreOO::JY5113CoreOODITask, JY5113CoreOO::JY5113CoreOODOTask

- w -

  • WaitUntilDone() : JY5113CoreOO::JY5113CoreOOAITask, JY5113CoreOO::JY5113CoreOOAOTask, JY5113CoreOO::JY5113CoreOOCOTask, JY5113CoreOO::JY5113CoreOODOTask
  • WriteData() : JY5113CoreOO::JY5113CoreOOAOTask, JY5113CoreOO::JY5113CoreOOCOTask, JY5113CoreOO::JY5113CoreOODOTask
  • WriteRawData() : JY5113CoreOO::JY5113CoreOOAOTask
  • WriteRawSinglePoint() : JY5113CoreOO::JY5113CoreOOAOTask
  • WriteSinglePoint() : JY5113CoreOO::JY5113CoreOOAOTask, JY5113CoreOO::JY5113CoreOOCOTask, JY5113CoreOO::JY5113CoreOODOTask

- ~ -

  • ~COPulse() : JY5113CoreOO::COPulse
  • ~JY5113CoreOOAOTask() : JY5113CoreOO::JY5113CoreOOAOTask
  • ~JY5113CoreOOCITask() : JY5113CoreOO::JY5113CoreOOCITask
  • ~JY5113CoreOOCOTask() : JY5113CoreOO::JY5113CoreOOCOTask
  • ~JY5113CoreOODITask() : JY5113CoreOO::JY5113CoreOODITask
  • ~JY5113CoreOODOTask() : JY5113CoreOO::JY5113CoreOODOTask


5113 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- g -

  • GetInstance() : JY5113CoreOO::JY5113CoreOODevice
  • GetRecordPreviewData() : JY5113CoreOO::JY5113CoreOOAITask
  • GetRecordStatus() : JY5113CoreOO::JY5113CoreOOAITask


5113 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- h -

  • Handle : JY5113CoreOO::JY5113CoreOODevice
  • HighThreshold : JY5113CoreOO::AIAnalogHysteresisComparator, JY5113CoreOO::AIAnalogWindowComparator
  • Hysteresis : JY5113CoreOO::AIAnalogTrigger


5113 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- i -

  • IdleState : JY5113CoreOO::EdgeCountingOutEvent, JY5113CoreOO::JY5113CoreOOCOTask
  • IgnoreFirstSampleClock : JY5113CoreOO::CIInternalSampleClock
  • Implicit : JY5113CoreOO::CISampleClock
  • InitialCount : JY5113CoreOO::EdgeCounting, JY5113CoreOO::QuadEncoder, JY5113CoreOO::TwoPulseEncoder
  • InitialDelay : JY5113CoreOO::JY5113CoreOOCOTask
  • Input_Terminal : JY5113CoreOO::EdgeCounting, JY5113CoreOO::FrequencyMeas, JY5113CoreOO::PeriodMeas, JY5113CoreOO::PulseMeas, JY5113CoreOO::SemiPeriodMeas
  • Internal : JY5113CoreOO::CISampleClock
  • IsAISync : JY5113CoreOO::JY5113CoreOODevice
  • IsAOSync : JY5113CoreOO::JY5113CoreOODevice


5113 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- j -

  • JY5113CoreOOAITask() : JY5113CoreOO::JY5113CoreOOAITask
  • JY5113CoreOOAOTask : JY5113CoreOO::AOSampleClock, JY5113CoreOO::JY5113CoreOOAOTask
  • JY5113CoreOOCITask() : JY5113CoreOO::JY5113CoreOOCITask, JY5113CoreOO::SemiPeriodMeas
  • JY5113CoreOOCOTask() : JY5113CoreOO::JY5113CoreOOCOTask
  • JY5113CoreOODITask() : JY5113CoreOO::JY5113CoreOODITask
  • JY5113CoreOODOTask() : JY5113CoreOO::JY5113CoreOODOTask
  • JY5113CoreOOProperty() : JY5113CoreOO::JY5113CoreOOProperty< ContainerClass, ValueType, propertyType >
  • JYDriverException() : JY5113CoreOO::JYDriverException


5113 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- l -

  • Length : JY5113CoreOO::AIRecord
  • LineNum : JY5113CoreOO::DIChannel, JY5113CoreOO::DOChannel
  • LogLevel : JY5113CoreOO::JY5113CoreOOLog
  • LowThreshold : JY5113CoreOO::AIAnalogHysteresisComparator, JY5113CoreOO::AIAnalogWindowComparator


5113 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- m -

  • MaxSampleRate : JY5113CoreOO::JY5113CoreOODevice
  • MaxSampleRateSingleChannel : JY5113CoreOO::JY5113CoreOODevice
  • MaxUpdateRate : JY5113CoreOO::JY5113CoreOODevice
  • MaxUpdateRateSingleChannel : JY5113CoreOO::JY5113CoreOODevice
  • Mode : JY5113CoreOO::AIRecord, JY5113CoreOO::AITrigger, JY5113CoreOO::DITrigger, JY5113CoreOO::JY5113CoreOOAITask, JY5113CoreOO::JY5113CoreOOAOTask, JY5113CoreOO::JY5113CoreOOCITask, JY5113CoreOO::JY5113CoreOOCOTask, JY5113CoreOO::JY5113CoreOODITask, JY5113CoreOO::JY5113CoreOODOTask


5113 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- o -

  • operator ValueType() : JY5113CoreOO::JY5113CoreOOProperty< ContainerClass, ValueType, propertyType >
  • operator=() : JY5113CoreOO::JY5113CoreOOProperty< ContainerClass, ValueType, propertyType >
  • OutEvent : JY5113CoreOO::EdgeCounting
  • OutputTerminal : JY5113CoreOO::JY5113CoreOOCOTask


5113 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- p -

  • Pause : JY5113CoreOO::EdgeCounting, JY5113CoreOO::JY5113CoreOOCOTask
  • PeriodMeas : JY5113CoreOO::JY5113CoreOOCITask
  • PFI : JY5113CoreOO::JY5113CoreOODevice
  • PreTriggerSamples : JY5113CoreOO::AITrigger, JY5113CoreOO::DITrigger
  • Print() : JY5113CoreOO::JY5113CoreOOLog
  • PulseMeas : JY5113CoreOO::JY5113CoreOOCITask


5113 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- q -

  • QuadEncoder : JY5113CoreOO::JY5113CoreOOCITask


5113 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- r -

  • RangeHigh : JY5113CoreOO::AIChannel, JY5113CoreOO::AOChannel
  • RangeLow : JY5113CoreOO::AIChannel, JY5113CoreOO::AOChannel
  • Rate : JY5113CoreOO::CIInternalSampleClock
  • ReadData() : JY5113CoreOO::JY5113CoreOOAITask, JY5113CoreOO::JY5113CoreOOCITask, JY5113CoreOO::JY5113CoreOODITask
  • ReadRawData() : JY5113CoreOO::JY5113CoreOOAITask
  • ReadRawSinglePoint() : JY5113CoreOO::JY5113CoreOOAITask
  • ReadSinglePoint() : JY5113CoreOO::JY5113CoreOOAITask, JY5113CoreOO::JY5113CoreOOCITask, JY5113CoreOO::JY5113CoreOODITask
  • Record : JY5113CoreOO::JY5113CoreOOAITask
  • ReferenceClock : JY5113CoreOO::JY5113CoreOODevice
  • RemoveChannel() : JY5113CoreOO::JY5113CoreOOAITask, JY5113CoreOO::JY5113CoreOOAOTask, JY5113CoreOO::JY5113CoreOODITask, JY5113CoreOO::JY5113CoreOODOTask
  • ReTriggerCount : JY5113CoreOO::AITrigger


5113 C++ Programming Manual: Class Members - Related Symbols

  • All
  • Functions
  • Variables
  • Related Symbols
Here is a list of all related symbols with links to the classes they belong to:
  • JY5113CoreOOAOTask : JY5113CoreOO::AOSampleClock
  • JY5113CoreOOCITask : JY5113CoreOO::SemiPeriodMeas


5113 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- s -

  • SampleClock : JY5113CoreOO::JY5113CoreOOAITask, JY5113CoreOO::JY5113CoreOOAOTask, JY5113CoreOO::JY5113CoreOOCITask, JY5113CoreOO::JY5113CoreOODITask, JY5113CoreOO::JY5113CoreOODOTask
  • SampleRate : JY5113CoreOO::JY5113CoreOOAITask, JY5113CoreOO::JY5113CoreOODITask
  • SamplesToAcquire : JY5113CoreOO::JY5113CoreOOAITask, JY5113CoreOO::JY5113CoreOOCITask, JY5113CoreOO::JY5113CoreOODITask
  • SamplesToUpdate : JY5113CoreOO::JY5113CoreOOAOTask, JY5113CoreOO::JY5113CoreOOCOTask, JY5113CoreOO::JY5113CoreOODOTask
  • SEChannelCount : JY5113CoreOO::JY5113CoreOODevice
  • SecondInputTerminal : JY5113CoreOO::TwoEdgeSeparation
  • SemiPeriodMeas : JY5113CoreOO::JY5113CoreOOCITask
  • SendSoftwareTrigger() : JY5113CoreOO::JY5113CoreOOAITask, JY5113CoreOO::JY5113CoreOOAOTask, JY5113CoreOO::JY5113CoreOOCITask, JY5113CoreOO::JY5113CoreOOCOTask, JY5113CoreOO::JY5113CoreOODITask, JY5113CoreOO::JY5113CoreOODOTask
  • SerialNumber : JY5113CoreOO::JY5113CoreOODevice
  • SignalExport : JY5113CoreOO::JY5113CoreOOAITask, JY5113CoreOO::JY5113CoreOOAOTask, JY5113CoreOO::JY5113CoreOOCITask, JY5113CoreOO::JY5113CoreOOCOTask, JY5113CoreOO::JY5113CoreOODITask, JY5113CoreOO::JY5113CoreOODOTask
  • Slope : JY5113CoreOO::AIAnalogEdgeComparator, JY5113CoreOO::AIAnalogHysteresisComparator
  • Source : JY5113CoreOO::AIAnalogTrigger, JY5113CoreOO::AIDigitalTrigger, JY5113CoreOO::AISampleClock, JY5113CoreOO::AODigitalTrigger, JY5113CoreOO::AOSampleClock, JY5113CoreOO::CIDigitalTrigger, JY5113CoreOO::CISampleClock, JY5113CoreOO::CITimebase, JY5113CoreOO::CODigitalTrigger, JY5113CoreOO::COTimebase, JY5113CoreOO::DIDigitalTrigger, JY5113CoreOO::DISampleClock, JY5113CoreOO::DODigitalTrigger, JY5113CoreOO::DOSampleClock, JY5113CoreOO::JY5113CoreOOReferenceClock
  • Start() : JY5113CoreOO::JY5113CoreOOAITask, JY5113CoreOO::JY5113CoreOOAOTask, JY5113CoreOO::JY5113CoreOOCITask, JY5113CoreOO::JY5113CoreOOCOTask, JY5113CoreOO::JY5113CoreOODITask, JY5113CoreOO::JY5113CoreOODOTask
  • StartingEdge : JY5113CoreOO::PulseMeas, JY5113CoreOO::SemiPeriodMeas
  • Stop() : JY5113CoreOO::JY5113CoreOOAITask, JY5113CoreOO::JY5113CoreOOAOTask, JY5113CoreOO::JY5113CoreOOCITask, JY5113CoreOO::JY5113CoreOOCOTask, JY5113CoreOO::JY5113CoreOODITask, JY5113CoreOO::JY5113CoreOODOTask


5113 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- t -

  • Terminal : JY5113CoreOO::AIChannel, JY5113CoreOO::AIExternalSampleClock, JY5113CoreOO::AOExternalSampleClock, JY5113CoreOO::CIExternalSampleClock, JY5113CoreOO::CIExternalTimebase, JY5113CoreOO::COExternalTimebase, JY5113CoreOO::DIExternalSampleClock, JY5113CoreOO::DOExternalSampleClock, JY5113CoreOO::EdgeCountingOutEvent, JY5113CoreOO::ExternalReferenceClock, JY5113CoreOO::PauseTrigger
  • Threshold : JY5113CoreOO::AIAnalogEdgeComparator, JY5113CoreOO::EdgeCountingOutEvent
  • Timebase : JY5113CoreOO::FrequencyMeas, JY5113CoreOO::JY5113CoreOOCOTask, JY5113CoreOO::PeriodMeas, JY5113CoreOO::PulseMeas, JY5113CoreOO::SemiPeriodMeas, JY5113CoreOO::TwoEdgeSeparation
  • TransferedPulses : JY5113CoreOO::JY5113CoreOOCOTask
  • TransferedSamples : JY5113CoreOO::JY5113CoreOOAITask, JY5113CoreOO::JY5113CoreOOAOTask, JY5113CoreOO::JY5113CoreOOCITask, JY5113CoreOO::JY5113CoreOOCOTask, JY5113CoreOO::JY5113CoreOODITask, JY5113CoreOO::JY5113CoreOODOTask
  • Trigger : JY5113CoreOO::JY5113CoreOOAITask, JY5113CoreOO::JY5113CoreOOAOTask, JY5113CoreOO::JY5113CoreOOCITask, JY5113CoreOO::JY5113CoreOOCOTask, JY5113CoreOO::JY5113CoreOODITask, JY5113CoreOO::JY5113CoreOODOTask
  • TwoEdgeSeparation : JY5113CoreOO::JY5113CoreOOCITask
  • TwoPulseEncoder : JY5113CoreOO::JY5113CoreOOCITask
  • Type : JY5113CoreOO::AITrigger, JY5113CoreOO::AOTrigger, JY5113CoreOO::CITrigger, JY5113CoreOO::COTrigger, JY5113CoreOO::DITrigger, JY5113CoreOO::DOTrigger, JY5113CoreOO::JY5113CoreOOCITask


5113 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- u -

  • UpdateRate : JY5113CoreOO::JY5113CoreOOAOTask, JY5113CoreOO::JY5113CoreOODOTask


5113 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- a -

  • ActiveEdge : JY5113CoreOO::EdgeCounting
  • ActivePolarity : JY5113CoreOO::PauseTrigger
  • ActualFreq : JY5113CoreOO::CITimebase, JY5113CoreOO::COTimebase
  • Advanced : JY5113CoreOO::JY5113CoreOOAITask
  • AIBufferSize : JY5113CoreOO::JY5113CoreOODevice
  • AInputTerminal : JY5113CoreOO::QuadEncoder, JY5113CoreOO::TwoPulseEncoder
  • Analog : JY5113CoreOO::AITrigger
  • AOChannelCount : JY5113CoreOO::JY5113CoreOODevice
  • AvailableSamples : JY5113CoreOO::JY5113CoreOOAITask, JY5113CoreOO::JY5113CoreOOCITask, JY5113CoreOO::JY5113CoreOOCOTask, JY5113CoreOO::JY5113CoreOODITask
  • AvaliableLenInSamples : JY5113CoreOO::JY5113CoreOOAOTask, JY5113CoreOO::JY5113CoreOODOTask


5113 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- b -

  • BandWidth : JY5113CoreOO::AIChannel
  • BInputTerminal : JY5113CoreOO::QuadEncoder, JY5113CoreOO::TwoPulseEncoder
  • BoardClockRate : JY5113CoreOO::JY5113CoreOODevice
  • BufLenInSamples : JY5113CoreOO::JY5113CoreOOAITask, JY5113CoreOO::JY5113CoreOOAOTask, JY5113CoreOO::JY5113CoreOODITask, JY5113CoreOO::JY5113CoreOODOTask


5113 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- c -

  • ChannelID : JY5113CoreOO::AIChannel, JY5113CoreOO::AOChannel
  • Channels : JY5113CoreOO::JY5113CoreOOAITask, JY5113CoreOO::JY5113CoreOOAOTask, JY5113CoreOO::JY5113CoreOODITask, JY5113CoreOO::JY5113CoreOODOTask
  • Comparator : JY5113CoreOO::AIAnalogTrigger
  • CompleteState : JY5113CoreOO::JY5113CoreOOAOTask, JY5113CoreOO::JY5113CoreOODOTask
  • Condition : JY5113CoreOO::AIAnalogWindowComparator
  • ConvertRate : JY5113CoreOO::AIAdvanced


5113 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- d -

  • Device : JY5113CoreOO::JY5113CoreOOAITask, JY5113CoreOO::JY5113CoreOOAOTask, JY5113CoreOO::JY5113CoreOOCITask, JY5113CoreOO::JY5113CoreOOCOTask, JY5113CoreOO::JY5113CoreOODITask, JY5113CoreOO::JY5113CoreOODOTask
  • DeviceID : JY5113CoreOO::JY5113CoreOODevice
  • DiffChannelCount : JY5113CoreOO::JY5113CoreOODevice
  • Digital : JY5113CoreOO::AITrigger, JY5113CoreOO::AOTrigger, JY5113CoreOO::CITrigger, JY5113CoreOO::COTrigger, JY5113CoreOO::DITrigger, JY5113CoreOO::DOTrigger
  • Direction : JY5113CoreOO::EdgeCounting
  • DirTerminal : JY5113CoreOO::EdgeCounting
  • DisableCalibration : JY5113CoreOO::JY5113CoreOOAITask, JY5113CoreOO::JY5113CoreOOAOTask
  • DSMode : JY5113CoreOO::AIAdvanced


5113 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- e -

  • Edge : JY5113CoreOO::AIAnalogTrigger, JY5113CoreOO::AIDigitalTrigger, JY5113CoreOO::AODigitalTrigger, JY5113CoreOO::CIDigitalTrigger, JY5113CoreOO::CODigitalTrigger, JY5113CoreOO::DIDigitalTrigger, JY5113CoreOO::DODigitalTrigger
  • EdgeCounting : JY5113CoreOO::JY5113CoreOOCITask
  • EdgeSeparationMode : JY5113CoreOO::TwoEdgeSeparation
  • Enable : JY5113CoreOO::AIDSMode
  • EnableLog : JY5113CoreOO::JY5113CoreOOLog
  • EncodingType : JY5113CoreOO::QuadEncoder
  • errorCode : JY5113CoreOO::JYDriverException
  • exceptionMessage : JY5113CoreOO::JYDriverException
  • ExpectedRate : JY5113CoreOO::AIExternalSampleClock, JY5113CoreOO::AOExternalSampleClock, JY5113CoreOO::CIExternalSampleClock, JY5113CoreOO::CIImplicitSampleClock, JY5113CoreOO::DIExternalSampleClock, JY5113CoreOO::DOExternalSampleClock
  • External : JY5113CoreOO::AISampleClock, JY5113CoreOO::AOSampleClock, JY5113CoreOO::CISampleClock, JY5113CoreOO::CITimebase, JY5113CoreOO::COTimebase, JY5113CoreOO::DISampleClock, JY5113CoreOO::DOSampleClock, JY5113CoreOO::JY5113CoreOOReferenceClock


5113 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- f -

  • File_Format : JY5113CoreOO::AIRecord
  • FilePath : JY5113CoreOO::AIRecord
  • Filter : JY5113CoreOO::PFISetting
  • FirstInputTerminal : JY5113CoreOO::TwoEdgeSeparation
  • FollowingException : JY5113CoreOO::JYDriverException
  • Frequency : JY5113CoreOO::CIExternalTimebase, JY5113CoreOO::COExternalTimebase
  • FrequencyMeas : JY5113CoreOO::JY5113CoreOOCITask


5113 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- h -

  • Handle : JY5113CoreOO::JY5113CoreOODevice
  • HighThreshold : JY5113CoreOO::AIAnalogHysteresisComparator, JY5113CoreOO::AIAnalogWindowComparator
  • Hysteresis : JY5113CoreOO::AIAnalogTrigger


5113 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- i -

  • IdleState : JY5113CoreOO::EdgeCountingOutEvent, JY5113CoreOO::JY5113CoreOOCOTask
  • IgnoreFirstSampleClock : JY5113CoreOO::CIInternalSampleClock
  • Implicit : JY5113CoreOO::CISampleClock
  • InitialCount : JY5113CoreOO::EdgeCounting, JY5113CoreOO::QuadEncoder, JY5113CoreOO::TwoPulseEncoder
  • InitialDelay : JY5113CoreOO::JY5113CoreOOCOTask
  • Input_Terminal : JY5113CoreOO::EdgeCounting, JY5113CoreOO::FrequencyMeas, JY5113CoreOO::PeriodMeas, JY5113CoreOO::PulseMeas, JY5113CoreOO::SemiPeriodMeas
  • Internal : JY5113CoreOO::CISampleClock
  • IsAISync : JY5113CoreOO::JY5113CoreOODevice
  • IsAOSync : JY5113CoreOO::JY5113CoreOODevice


5113 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- l -

  • Length : JY5113CoreOO::AIRecord
  • LineNum : JY5113CoreOO::DIChannel, JY5113CoreOO::DOChannel
  • LogLevel : JY5113CoreOO::JY5113CoreOOLog
  • LowThreshold : JY5113CoreOO::AIAnalogHysteresisComparator, JY5113CoreOO::AIAnalogWindowComparator


5113 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- m -

  • MaxSampleRate : JY5113CoreOO::JY5113CoreOODevice
  • MaxSampleRateSingleChannel : JY5113CoreOO::JY5113CoreOODevice
  • MaxUpdateRate : JY5113CoreOO::JY5113CoreOODevice
  • MaxUpdateRateSingleChannel : JY5113CoreOO::JY5113CoreOODevice
  • Mode : JY5113CoreOO::AIRecord, JY5113CoreOO::AITrigger, JY5113CoreOO::DITrigger, JY5113CoreOO::JY5113CoreOOAITask, JY5113CoreOO::JY5113CoreOOAOTask, JY5113CoreOO::JY5113CoreOOCITask, JY5113CoreOO::JY5113CoreOOCOTask, JY5113CoreOO::JY5113CoreOODITask, JY5113CoreOO::JY5113CoreOODOTask


5113 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- o -

  • OutEvent : JY5113CoreOO::EdgeCounting
  • OutputTerminal : JY5113CoreOO::JY5113CoreOOCOTask


5113 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- p -

  • Pause : JY5113CoreOO::EdgeCounting, JY5113CoreOO::JY5113CoreOOCOTask
  • PeriodMeas : JY5113CoreOO::JY5113CoreOOCITask
  • PFI : JY5113CoreOO::JY5113CoreOODevice
  • PreTriggerSamples : JY5113CoreOO::AITrigger, JY5113CoreOO::DITrigger
  • PulseMeas : JY5113CoreOO::JY5113CoreOOCITask


5113 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- q -

  • QuadEncoder : JY5113CoreOO::JY5113CoreOOCITask


5113 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- r -

  • RangeHigh : JY5113CoreOO::AIChannel, JY5113CoreOO::AOChannel
  • RangeLow : JY5113CoreOO::AIChannel, JY5113CoreOO::AOChannel
  • Rate : JY5113CoreOO::CIInternalSampleClock
  • Record : JY5113CoreOO::JY5113CoreOOAITask
  • ReferenceClock : JY5113CoreOO::JY5113CoreOODevice
  • ReTriggerCount : JY5113CoreOO::AITrigger


5113 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- s -

  • SampleClock : JY5113CoreOO::JY5113CoreOOAITask, JY5113CoreOO::JY5113CoreOOAOTask, JY5113CoreOO::JY5113CoreOOCITask, JY5113CoreOO::JY5113CoreOODITask, JY5113CoreOO::JY5113CoreOODOTask
  • SampleRate : JY5113CoreOO::JY5113CoreOOAITask, JY5113CoreOO::JY5113CoreOODITask
  • SamplesToAcquire : JY5113CoreOO::JY5113CoreOOAITask, JY5113CoreOO::JY5113CoreOOCITask, JY5113CoreOO::JY5113CoreOODITask
  • SamplesToUpdate : JY5113CoreOO::JY5113CoreOOAOTask, JY5113CoreOO::JY5113CoreOOCOTask, JY5113CoreOO::JY5113CoreOODOTask
  • SEChannelCount : JY5113CoreOO::JY5113CoreOODevice
  • SecondInputTerminal : JY5113CoreOO::TwoEdgeSeparation
  • SemiPeriodMeas : JY5113CoreOO::JY5113CoreOOCITask
  • SerialNumber : JY5113CoreOO::JY5113CoreOODevice
  • SignalExport : JY5113CoreOO::JY5113CoreOOAITask, JY5113CoreOO::JY5113CoreOOAOTask, JY5113CoreOO::JY5113CoreOOCITask, JY5113CoreOO::JY5113CoreOOCOTask, JY5113CoreOO::JY5113CoreOODITask, JY5113CoreOO::JY5113CoreOODOTask
  • Slope : JY5113CoreOO::AIAnalogEdgeComparator, JY5113CoreOO::AIAnalogHysteresisComparator
  • Source : JY5113CoreOO::AIAnalogTrigger, JY5113CoreOO::AIDigitalTrigger, JY5113CoreOO::AISampleClock, JY5113CoreOO::AODigitalTrigger, JY5113CoreOO::AOSampleClock, JY5113CoreOO::CIDigitalTrigger, JY5113CoreOO::CISampleClock, JY5113CoreOO::CITimebase, JY5113CoreOO::CODigitalTrigger, JY5113CoreOO::COTimebase, JY5113CoreOO::DIDigitalTrigger, JY5113CoreOO::DISampleClock, JY5113CoreOO::DODigitalTrigger, JY5113CoreOO::DOSampleClock, JY5113CoreOO::JY5113CoreOOReferenceClock
  • StartingEdge : JY5113CoreOO::PulseMeas, JY5113CoreOO::SemiPeriodMeas


5113 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- t -

  • Terminal : JY5113CoreOO::AIChannel, JY5113CoreOO::AIExternalSampleClock, JY5113CoreOO::AOExternalSampleClock, JY5113CoreOO::CIExternalSampleClock, JY5113CoreOO::CIExternalTimebase, JY5113CoreOO::COExternalTimebase, JY5113CoreOO::DIExternalSampleClock, JY5113CoreOO::DOExternalSampleClock, JY5113CoreOO::EdgeCountingOutEvent, JY5113CoreOO::ExternalReferenceClock, JY5113CoreOO::PauseTrigger
  • Threshold : JY5113CoreOO::AIAnalogEdgeComparator, JY5113CoreOO::EdgeCountingOutEvent
  • Timebase : JY5113CoreOO::FrequencyMeas, JY5113CoreOO::JY5113CoreOOCOTask, JY5113CoreOO::PeriodMeas, JY5113CoreOO::PulseMeas, JY5113CoreOO::SemiPeriodMeas, JY5113CoreOO::TwoEdgeSeparation
  • TransferedPulses : JY5113CoreOO::JY5113CoreOOCOTask
  • TransferedSamples : JY5113CoreOO::JY5113CoreOOAITask, JY5113CoreOO::JY5113CoreOOAOTask, JY5113CoreOO::JY5113CoreOOCITask, JY5113CoreOO::JY5113CoreOOCOTask, JY5113CoreOO::JY5113CoreOODITask, JY5113CoreOO::JY5113CoreOODOTask
  • Trigger : JY5113CoreOO::JY5113CoreOOAITask, JY5113CoreOO::JY5113CoreOOAOTask, JY5113CoreOO::JY5113CoreOOCITask, JY5113CoreOO::JY5113CoreOOCOTask, JY5113CoreOO::JY5113CoreOODITask, JY5113CoreOO::JY5113CoreOODOTask
  • TwoEdgeSeparation : JY5113CoreOO::JY5113CoreOOCITask
  • TwoPulseEncoder : JY5113CoreOO::JY5113CoreOOCITask
  • Type : JY5113CoreOO::AITrigger, JY5113CoreOO::AOTrigger, JY5113CoreOO::CITrigger, JY5113CoreOO::COTrigger, JY5113CoreOO::DITrigger, JY5113CoreOO::DOTrigger, JY5113CoreOO::JY5113CoreOOCITask


5113 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- u -

  • UpdateRate : JY5113CoreOO::JY5113CoreOOAOTask, JY5113CoreOO::JY5113CoreOODOTask


5113 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- w -

  • Window : JY5113CoreOO::AIAnalogTrigger


5113 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- z -

  • ZInputTerminal : JY5113CoreOO::QuadEncoder
  • ZReloadEnabled : JY5113CoreOO::QuadEncoder


5113 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- w -

  • WaitUntilDone() : JY5113CoreOO::JY5113CoreOOAITask, JY5113CoreOO::JY5113CoreOOAOTask, JY5113CoreOO::JY5113CoreOOCOTask, JY5113CoreOO::JY5113CoreOODOTask
  • Window : JY5113CoreOO::AIAnalogTrigger
  • WriteData() : JY5113CoreOO::JY5113CoreOOAOTask, JY5113CoreOO::JY5113CoreOOCOTask, JY5113CoreOO::JY5113CoreOODOTask
  • WriteRawData() : JY5113CoreOO::JY5113CoreOOAOTask
  • WriteRawSinglePoint() : JY5113CoreOO::JY5113CoreOOAOTask
  • WriteSinglePoint() : JY5113CoreOO::JY5113CoreOOAOTask, JY5113CoreOO::JY5113CoreOOCOTask, JY5113CoreOO::JY5113CoreOODOTask


5113 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- z -

  • ZInputTerminal : JY5113CoreOO::QuadEncoder
  • ZReloadEnabled : JY5113CoreOO::QuadEncoder


5113 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- ~ -

  • ~COPulse() : JY5113CoreOO::COPulse
  • ~JY5113CoreOOAOTask() : JY5113CoreOO::JY5113CoreOOAOTask
  • ~JY5113CoreOOCITask() : JY5113CoreOO::JY5113CoreOOCITask
  • ~JY5113CoreOOCOTask() : JY5113CoreOO::JY5113CoreOOCOTask
  • ~JY5113CoreOODITask() : JY5113CoreOO::JY5113CoreOODITask
  • ~JY5113CoreOODOTask() : JY5113CoreOO::JY5113CoreOODOTask


5113 C++ Programming Manual: File Members

  • File List
  • File Members
  • All
  • Macros
Here is a list of all file members with links to the files they belong to:
  • EXTERN_C : JY5113CoreOOCommon.h
  • JY5113CoreOO_API : JY5113CoreOOCommon.h


5113 C++ Programming Manual: File Members

  • File List
  • File Members
  • All
  • Macros
Here is a list of all macros with links to the files they belong to:
  • EXTERN_C : JY5113CoreOOCommon.h
  • JY5113CoreOO_API : JY5113CoreOOCommon.h


5113 C++ Programming Manual: Main Page

5113 C++ Programming Manual Documentation


5113 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • l
  • o
  • p
  • q
  • r
  • s
  • v
Here is a list of all namespace members with links to the namespace documentation for each member:

- a -

  • AIAnalogTriggerComparator : JY5113CoreOO
  • AIAnalogTriggerEdge : JY5113CoreOO
  • AIAnalogTriggerSource : JY5113CoreOO
  • AIAnalogWindowCondition : JY5113CoreOO
  • AIBandWidth : JY5113CoreOO
  • AIDigitalTriggerEdge : JY5113CoreOO
  • AIDigitalTriggerSource : JY5113CoreOO
  • AIMode : JY5113CoreOO
  • AISampleClockSource : JY5113CoreOO
  • AISignalExportSource : JY5113CoreOO
  • AITerminal : JY5113CoreOO
  • AITriggerMode : JY5113CoreOO
  • AITriggerType : JY5113CoreOO
  • AODigitalTriggerEdge : JY5113CoreOO
  • AODigitalTriggerSource : JY5113CoreOO
  • AOMode : JY5113CoreOO
  • AOSampleClockSource : JY5113CoreOO
  • AOSignalExportSource : JY5113CoreOO
  • AOTriggerType : JY5113CoreOO

- c -

  • CIDigitalTriggerEdge : JY5113CoreOO
  • CIDigitalTriggerSource : JY5113CoreOO
  • CIMode : JY5113CoreOO
  • CISampleClockSource : JY5113CoreOO
  • CISignalExportSource : JY5113CoreOO
  • CITimebaseSource : JY5113CoreOO
  • CITriggerType : JY5113CoreOO
  • CIType : JY5113CoreOO
  • ClockTerminal : JY5113CoreOO
  • CODigitalTriggerEdge : JY5113CoreOO
  • CODigitalTriggerSource : JY5113CoreOO
  • COIdleState : JY5113CoreOO
  • COMode : JY5113CoreOO
  • COPulseType : JY5113CoreOO
  • COSignalExportSource : JY5113CoreOO
  • COTimebaseSource : JY5113CoreOO
  • COTriggerType : JY5113CoreOO
  • CountDirection : JY5113CoreOO

- d -

  • DIDigitalTriggerEdge : JY5113CoreOO
  • DIDigitalTriggerSource : JY5113CoreOO
  • DIMode : JY5113CoreOO
  • DISampleClockSource : JY5113CoreOO
  • DISignalExportSource : JY5113CoreOO
  • DITriggerMode : JY5113CoreOO
  • DITriggerType : JY5113CoreOO
  • DODigitalTriggerEdge : JY5113CoreOO
  • DODigitalTriggerSource : JY5113CoreOO
  • DOMode : JY5113CoreOO
  • DOSampleClockSource : JY5113CoreOO
  • DOSignalExportSource : JY5113CoreOO
  • DOTriggerType : JY5113CoreOO

- e -

  • EdgeCntOunEvtIdleState : JY5113CoreOO
  • EdgeType : JY5113CoreOO
  • ExternalReferenceClockTerminal : JY5113CoreOO

- f -

  • FileFormat : JY5113CoreOO

- g -

  • GetSignalExportDestinationString() : JY5113CoreOO

- i -

  • InputTerminal : JY5113CoreOO
  • IOTerminal : JY5113CoreOO

- j -

  • JY5113CoreOOLogLevel : JY5113CoreOO
  • JY5113CoreOOPropertyType : JY5113CoreOO
  • JYDriverExceptionPublic : JY5113CoreOO

- l -

  • LevelPolarity : JY5113CoreOO

- o -

  • OutputCompleteState : JY5113CoreOO

- p -

  • PFITerminal : JY5113CoreOO
  • PowerLineFrequency : JY5113CoreOO

- q -

  • QuadEncodingType : JY5113CoreOO

- r -

  • RecordMode : JY5113CoreOO
  • ReferenceClockSource : JY5113CoreOO

- s -

  • SignalExportDestination : JY5113CoreOO
  • SyncPulseRouting : JY5113CoreOO
  • SyncTriggerRouting : JY5113CoreOO

- v -

  • ValueReturnMode : JY5113CoreOO


5113 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • a
  • c
  • d
  • e
  • f
  • i
  • j
  • l
  • o
  • p
  • q
  • r
  • s
  • v
Here is a list of all namespace enums with links to the namespace documentation for each enum:

- a -

  • AIAnalogTriggerComparator : JY5113CoreOO
  • AIAnalogTriggerEdge : JY5113CoreOO
  • AIAnalogTriggerSource : JY5113CoreOO
  • AIAnalogWindowCondition : JY5113CoreOO
  • AIBandWidth : JY5113CoreOO
  • AIDigitalTriggerEdge : JY5113CoreOO
  • AIDigitalTriggerSource : JY5113CoreOO
  • AIMode : JY5113CoreOO
  • AISampleClockSource : JY5113CoreOO
  • AISignalExportSource : JY5113CoreOO
  • AITerminal : JY5113CoreOO
  • AITriggerMode : JY5113CoreOO
  • AITriggerType : JY5113CoreOO
  • AODigitalTriggerEdge : JY5113CoreOO
  • AODigitalTriggerSource : JY5113CoreOO
  • AOMode : JY5113CoreOO
  • AOSampleClockSource : JY5113CoreOO
  • AOSignalExportSource : JY5113CoreOO
  • AOTriggerType : JY5113CoreOO

- c -

  • CIDigitalTriggerEdge : JY5113CoreOO
  • CIDigitalTriggerSource : JY5113CoreOO
  • CIMode : JY5113CoreOO
  • CISampleClockSource : JY5113CoreOO
  • CISignalExportSource : JY5113CoreOO
  • CITimebaseSource : JY5113CoreOO
  • CITriggerType : JY5113CoreOO
  • CIType : JY5113CoreOO
  • ClockTerminal : JY5113CoreOO
  • CODigitalTriggerEdge : JY5113CoreOO
  • CODigitalTriggerSource : JY5113CoreOO
  • COIdleState : JY5113CoreOO
  • COMode : JY5113CoreOO
  • COPulseType : JY5113CoreOO
  • COSignalExportSource : JY5113CoreOO
  • COTimebaseSource : JY5113CoreOO
  • COTriggerType : JY5113CoreOO
  • CountDirection : JY5113CoreOO

- d -

  • DIDigitalTriggerEdge : JY5113CoreOO
  • DIDigitalTriggerSource : JY5113CoreOO
  • DIMode : JY5113CoreOO
  • DISampleClockSource : JY5113CoreOO
  • DISignalExportSource : JY5113CoreOO
  • DITriggerMode : JY5113CoreOO
  • DITriggerType : JY5113CoreOO
  • DODigitalTriggerEdge : JY5113CoreOO
  • DODigitalTriggerSource : JY5113CoreOO
  • DOMode : JY5113CoreOO
  • DOSampleClockSource : JY5113CoreOO
  • DOSignalExportSource : JY5113CoreOO
  • DOTriggerType : JY5113CoreOO

- e -

  • EdgeCntOunEvtIdleState : JY5113CoreOO
  • EdgeType : JY5113CoreOO
  • ExternalReferenceClockTerminal : JY5113CoreOO

- f -

  • FileFormat : JY5113CoreOO

- i -

  • InputTerminal : JY5113CoreOO
  • IOTerminal : JY5113CoreOO

- j -

  • JY5113CoreOOLogLevel : JY5113CoreOO
  • JY5113CoreOOPropertyType : JY5113CoreOO
  • JYDriverExceptionPublic : JY5113CoreOO

- l -

  • LevelPolarity : JY5113CoreOO

- o -

  • OutputCompleteState : JY5113CoreOO

- p -

  • PFITerminal : JY5113CoreOO
  • PowerLineFrequency : JY5113CoreOO

- q -

  • QuadEncodingType : JY5113CoreOO

- r -

  • RecordMode : JY5113CoreOO
  • ReferenceClockSource : JY5113CoreOO

- s -

  • SignalExportDestination : JY5113CoreOO
  • SyncPulseRouting : JY5113CoreOO
  • SyncTriggerRouting : JY5113CoreOO

- v -

  • ValueReturnMode : JY5113CoreOO


5113 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
Here is a list of all namespace functions with links to the namespace documentation for each function:
  • GetSignalExportDestinationString() : JY5113CoreOO


5113 C++ Programming Manual: Namespace List

  • Namespace List
  • Namespace Members
Namespace List
Here is a list of all namespaces with brief descriptions:
N JY5113CoreOO