5211 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5211 Directory Reference

5211 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 5211
5211 Directory Reference

Files

JY5211CoreOOCITask.h
JY5211CoreOOCommon.h
JY5211CoreOOCOTask.h
JY5211CoreOODevice.h
JY5211CoreOODITask.h
JY5211CoreOODOTask.h
JY5211CoreOOLog.h
Generated by doxygen 1.13.2


5211 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOOCITask.h File Reference

  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 5211
Classes | Namespaces | Enumerations
JY5211CoreOOCITask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JY5211CoreOOCommon.h"
#include "JY5211CoreOODevice.h"

Classes

class | JY5211CoreOO::JY5211CoreOOCITask
class | JY5211CoreOO::CIInternalSampleClock
CI Internal Sample Clock Configuration Class. More...
class | JY5211CoreOO::CIImplicitSampleClock
CI Implicit Sample Clock class. More...
class | JY5211CoreOO::CIExternalSampleClock
CI Implicit Sample Clock class. More...
class | JY5211CoreOO::CISampleClock
CI Sample Clock class. More...
class | JY5211CoreOO::EdgeCounting
Configure CI EdgeCounting. More...
class | JY5211CoreOO::FrequencyMeas
Configure CI Measure. More...
class | JY5211CoreOO::PeriodMeas
Configure CI Measure. More...
class | JY5211CoreOO::PulseMeas
Configure CI Measure. More...
class | JY5211CoreOO::SemiPeriodMeas
Configure CI SemiPeriodMeas. More...
class | JY5211CoreOO::TwoEdgeSeparation
Configure CI Measure. More...
class | JY5211CoreOO::QuadEncoder
Configure CI Measure. More...
class | JY5211CoreOO::TwoPulseEncoder
Configure CI Measure. More...
class | JY5211CoreOO::CITrigger
Constructor to create an CITrigger task object. More...
class | JY5211CoreOO::CIDigitalTrigger
CI Digital trigger . More...
class | JY5211CoreOO::EdgeCountingOutEvent
Edge counting output event configuration class. More...
class | JY5211CoreOO::CIExternalTimebase
class | JY5211CoreOO::CITimebase
Timebase configuration class. More...
class | JY5211CoreOO::CISignalExport
CI Signal Export Class. More...

Namespaces

namespace JY5211CoreOO

Enumerations

enum class | JY5211CoreOO::CountDirection { JY5211CoreOO::Up = 0x0 , JY5211CoreOO::Down = 0x1 , JY5211CoreOO::External = 0x2 }
Counter direction. More...
enum class | JY5211CoreOO::CIMode { JY5211CoreOO::Single = 0 , JY5211CoreOO::Finite = 1 , JY5211CoreOO::Continuous = 2 }
CIMode. More...
enum class JY5211CoreOO::CIType {
JY5211CoreOO::EdgeCounting , JY5211CoreOO::Period , JY5211CoreOO::Frequency , JY5211CoreOO::Pulse ,
JY5211CoreOO::SemiPeriod , JY5211CoreOO::TwoEdgeSeparation , JY5211CoreOO::QuadEncoder , JY5211CoreOO::TwoPulseEncoder
}
Counter Input Application Type. More...
enum class | JY5211CoreOO::CISampleClockSource { JY5211CoreOO::Implicit = 0x0 , JY5211CoreOO::Internal = 0x1 , JY5211CoreOO::External = 0x2 }
CI Sample Clock Source. More...
enum class | JY5211CoreOO::EdgeType { JY5211CoreOO::Rising , JY5211CoreOO::Falling , JY5211CoreOO::Any }
Edge Type. More...
enum class | JY5211CoreOO::ValueReturnMode { JY5211CoreOO::TwoValue , JY5211CoreOO::OneValue }
TwoEdgeSeparation value return mode.only for TwoEdgeSeparation type. More...
enum class | JY5211CoreOO::QuadEncodingType { JY5211CoreOO::X1 , JY5211CoreOO::X2 , JY5211CoreOO::X4 }
Quadrature Encoding Type. More...
enum class | JY5211CoreOO::CITriggerType { JY5211CoreOO::Immediate = 0x0 , JY5211CoreOO::Digital = 0x1 , JY5211CoreOO::Soft = 0x3 }
TriggerType Digital/Immediate/Soft. More...
enum class JY5211CoreOO::CIDigitalTriggerSource {
JY5211CoreOO::PFI0 , JY5211CoreOO::PFI1 , JY5211CoreOO::PFI2 , JY5211CoreOO::PFI3 ,
JY5211CoreOO::PFI4 , JY5211CoreOO::PFI5 , JY5211CoreOO::PFI6 , JY5211CoreOO::PFI7 ,
JY5211CoreOO::PFI8 , JY5211CoreOO::PFI9 , JY5211CoreOO::PFI10 , JY5211CoreOO::PFI11 ,
JY5211CoreOO::PFI12 , JY5211CoreOO::PFI13 , JY5211CoreOO::PFI14 , JY5211CoreOO::PFI15 ,
JY5211CoreOO::PFI16 , JY5211CoreOO::PFI17 , JY5211CoreOO::PFI18 , JY5211CoreOO::PFI19 ,
JY5211CoreOO::PFI20 , JY5211CoreOO::PFI21 , JY5211CoreOO::PFI22 , JY5211CoreOO::PFI23 ,
JY5211CoreOO::PFI24 , JY5211CoreOO::PFI25 , JY5211CoreOO::PFI26 , JY5211CoreOO::PFI27 ,
JY5211CoreOO::PFI28 , JY5211CoreOO::PFI29 , JY5211CoreOO::PFI130 , JY5211CoreOO::PFI131 ,
JY5211CoreOO::PFI132 , JY5211CoreOO::PFI133 , JY5211CoreOO::PFI134 , JY5211CoreOO::PFI135 ,
JY5211CoreOO::PFI136 , JY5211CoreOO::PFI137 , JY5211CoreOO::PFI138 , JY5211CoreOO::PFI139
}
CI Digital trigger source. More...
enum class | JY5211CoreOO::CIDigitalTriggerEdge { JY5211CoreOO::Rising , JY5211CoreOO::Falling }
CI Digital Trigger Edge. More...
enum class | JY5211CoreOO::EdgeCntOunEvtIdleState { JY5211CoreOO::LowLevel = 0 , JY5211CoreOO::HighLevel = 1 }
Output idle state when the event has not occurred. More...
enum class JY5211CoreOO::CISignalExportSource {
JY5211CoreOO::StartTrig = 0 , JY5211CoreOO::SampleClock = 1 , JY5211CoreOO::Internal_Counter_100K = 34 , JY5211CoreOO::Internal_Counter_5M = 33 ,
JY5211CoreOO::Internal_Counter_100M = 32
}
SourceSignal. More...
enum class | JY5211CoreOO::CITimebaseSource { JY5211CoreOO::Internal100MHz = 0 , JY5211CoreOO::Internal5MHz = 1 , JY5211CoreOO::Internal100kHz = 2 , JY5211CoreOO::External = 3 }
Timebase source. More...


5211 C++ Programming Manual: JY5211CoreOO::JY5211CoreOOCITask Class Reference

  • Class List
  • Class Index
  • Class Members
  • JY5211CoreOO
  • JY5211CoreOOCITask
Public Member Functions | Public Attributes | List of all members
JY5211CoreOO::JY5211CoreOOCITask Class Reference

#include <JY5211CoreOOCITask.h>

Public Member Functions

JY5211CoreOOCITask (int slotNum, int channel)
JY5211CoreOOCITask (std::string boardName, int channel)
~JY5211CoreOOCITask ()
void | Start ()
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Stop ()
Stop CI task .
void | ReadSinglePoint (uint32_t &count)
Read a signle count value from register, Available when Type is CIType.EdgeCounting, CIType.QuadEncoder or CIType.TwoPulseEncoder.
void | ReadData (uint32_t *pBufCount, int samplesToAcquire, int timeout=10000)
Read counter values from buffer.
void | ReadData (double *pBufMeasurement, int samplesToAcquire, int timeout=10000)
Read frequency value or period value from buffer.
void | ReadSinglePoint (double &measurement, int timeout=10000)
Read a signle frequency value or period value from register.
void | ReadSinglePoint (double &measurement1, double &measurement2, int timeout=10000)
Read a signle measurement of pulse's duration value, or two-edge separtion value (two results at a time) from register.
void | ReadData (double *pBufMeasurement1, double *pBufMeasurement2, int samplesToAcquire, int timeout=10000)
Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.

Public Attributes

CIType Type
CI Application types.
JY5211CoreOOProperty< JY5211CoreOOCITask, uint64_t, JY5211CoreOOPropertyType::READ_ONLY > | AvailableSamples
Number of points per channel that can be read in the buffer .
JY5211CoreOOProperty< JY5211CoreOOCITask, uint64_t, JY5211CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
CIMode Mode
CI Sampling mode，support Single/Finite/Continuous.
CISampleClock * SampleClock
Clock Source.
uint32_t | SamplesToAcquire
Number of samples to be read per channel.Only valid when Mode is CIMode.Finite.
JY5211CoreOO::EdgeCounting * EdgeCounting
Edge Counting Configuration.
JY5211CoreOO::FrequencyMeas * FrequencyMeas
Frequency Measurement Configuration.
JY5211CoreOO::PeriodMeas * PeriodMeas
Period Measurement Configuration.
JY5211CoreOO::PulseMeas * PulseMeas
Pulse Measurement Configuration.
JY5211CoreOO::SemiPeriodMeas * SemiPeriodMeas
SemiPeriodMeas Measurement Configuration.
JY5211CoreOO::TwoEdgeSeparation * TwoEdgeSeparation
TwoEdgeSeparation.
JY5211CoreOO::QuadEncoder * QuadEncoder
QuadEncoder.
JY5211CoreOO::TwoPulseEncoder * TwoPulseEncoder
TwoPulseEncoder.
CITrigger * Trigger
CI Trigger Configuration.
CISignalExport * SignalExport
Export CI Signal Configuration.
JY5211CoreOODevice * Device
Device.
CITimebase * timeBase
timeBase

Constructor & Destructor Documentation

◆ JY5211CoreOOCITask() [1/2]

JY5211CoreOO::JY5211CoreOOCITask::JY5211CoreOOCITask | ( | int | slotNum,
 |  | int | channel )

◆ JY5211CoreOOCITask() [2/2]

JY5211CoreOO::JY5211CoreOOCITask::JY5211CoreOOCITask | ( | std::string | boardName,
 |  | int | channel )

◆ ~JY5211CoreOOCITask()

JY5211CoreOO::JY5211CoreOOCITask::~JY5211CoreOOCITask ( )

Member Function Documentation

◆ ReadData() [1/3]

void JY5211CoreOO::JY5211CoreOOCITask::ReadData | ( | double * | pBufMeasurement,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read frequency value or period value from buffer.

Available when JY5211CITask.Mode is NOT CIMode.Single, and Type is CIType.Frequency or CIType.Period.

Parameters
bufMeasurement | Buffer for reading data. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period in seconds when Type is CIType.Period.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [2/3]

void JY5211CoreOO::JY5211CoreOOCITask::ReadData | ( | double * | pBufMeasurement1,
 |  | double * | pBufMeasurement2,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.

. Available when JY5211CITask.Mode is NOT CIMode.Single, Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
bufMeasurement1 | Buffer for reading data. Indicates high level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
bufMeasurement2 | Buffer for reading data. Indicates low level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [3/3]

void JY5211CoreOO::JY5211CoreOOCITask::ReadData | ( | uint32_t * | pBufCount,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read counter values from buffer.

Available when JY5211CITask.Mode is NOT CIMode.Single, and Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder

Parameters
bufCount | Buffer for reading data.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [1/3]

void JY5211CoreOO::JY5211CoreOOCITask::ReadSinglePoint | ( | double & | measurement,
 |  | int | timeout = 10000 )

Read a signle frequency value or period value from register.

Valid when Type is CIType.Frequency or CIType.Period.

Parameters
measurement Measurement value. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period is seconds when Type is CIType.Period.
timeout
Timeout (ms). Wait until the measurement is completed or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [2/3]

void JY5211CoreOO::JY5211CoreOOCITask::ReadSinglePoint | ( | double & | measurement1,
 |  | double & | measurement2,
 |  | int | timeout = 10000 )

Read a signle measurement of pulse's duration value, or two-edge separtion value (two results at a time) from register.

Available when Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
measurement1 | Measurement Value 1. Indicates low level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
measurement2 | Measurement Value 2. Indicates high level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
timeout
Timeout (ms). Wait until the measurement is completed or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [3/3]

void JY5211CoreOO::JY5211CoreOOCITask::ReadSinglePoint ( uint32_t & count )

Read a signle count value from register, Available when Type is CIType.EdgeCounting, CIType.QuadEncoder or CIType.TwoPulseEncoder.

Parameters
count counter value。

◆ SendSoftwareTrigger()

void JY5211CoreOO::JY5211CoreOOCITask::SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5211CoreOO::JY5211CoreOOCITask::Start ( )

◆ Stop()

void JY5211CoreOO::JY5211CoreOOCITask::Stop ( )

Stop CI task .

Member Data Documentation

◆ AvailableSamples

JY5211CoreOOProperty<JY5211CoreOOCITask, uint64_t, JY5211CoreOOPropertyType::READ_ONLY> JY5211CoreOO::JY5211CoreOOCITask::AvailableSamples

Number of points per channel that can be read in the buffer .

◆ Device

JY5211CoreOODevice* JY5211CoreOO::JY5211CoreOOCITask::Device

Device.

◆ EdgeCounting

JY5211CoreOO::EdgeCounting* JY5211CoreOO::JY5211CoreOOCITask::EdgeCounting

Edge Counting Configuration.

◆ FrequencyMeas

JY5211CoreOO::FrequencyMeas* JY5211CoreOO::JY5211CoreOOCITask::FrequencyMeas

Frequency Measurement Configuration.

◆ Mode

CIMode JY5211CoreOO::JY5211CoreOOCITask::Mode

CI Sampling mode，support Single/Finite/Continuous.

◆ PeriodMeas

JY5211CoreOO::PeriodMeas* JY5211CoreOO::JY5211CoreOOCITask::PeriodMeas

Period Measurement Configuration.

◆ PulseMeas

JY5211CoreOO::PulseMeas* JY5211CoreOO::JY5211CoreOOCITask::PulseMeas

Pulse Measurement Configuration.

◆ QuadEncoder

JY5211CoreOO::QuadEncoder* JY5211CoreOO::JY5211CoreOOCITask::QuadEncoder

QuadEncoder.

◆ SampleClock

CISampleClock* JY5211CoreOO::JY5211CoreOOCITask::SampleClock

Clock Source.

◆ SamplesToAcquire

uint32_t JY5211CoreOO::JY5211CoreOOCITask::SamplesToAcquire

Number of samples to be read per channel.Only valid when Mode is CIMode.Finite.

◆ SemiPeriodMeas

JY5211CoreOO::SemiPeriodMeas* JY5211CoreOO::JY5211CoreOOCITask::SemiPeriodMeas

SemiPeriodMeas Measurement Configuration.

◆ SignalExport

CISignalExport* JY5211CoreOO::JY5211CoreOOCITask::SignalExport

Export CI Signal Configuration.

◆ timeBase

CITimebase* JY5211CoreOO::JY5211CoreOOCITask::timeBase

timeBase

◆ TransferedSamples

JY5211CoreOOProperty<JY5211CoreOOCITask, uint64_t, JY5211CoreOOPropertyType::READ_ONLY> JY5211CoreOO::JY5211CoreOOCITask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT CIMode.Single.

◆ Trigger

CITrigger* JY5211CoreOO::JY5211CoreOOCITask::Trigger

CI Trigger Configuration.

◆ TwoEdgeSeparation

JY5211CoreOO::TwoEdgeSeparation* JY5211CoreOO::JY5211CoreOOCITask::TwoEdgeSeparation

TwoEdgeSeparation.

◆ TwoPulseEncoder

JY5211CoreOO::TwoPulseEncoder* JY5211CoreOO::JY5211CoreOOCITask::TwoPulseEncoder

TwoPulseEncoder.

◆ Type

CIType JY5211CoreOO::JY5211CoreOOCITask::Type

CI Application types.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOOCITask.h


5211 C++ Programming Manual: JY5211CoreOO::CIInternalSampleClock Class Reference

  • JY5211CoreOO
  • CIInternalSampleClock
Public Attributes | List of all members
JY5211CoreOO::CIInternalSampleClock Class Reference

CI Internal Sample Clock Configuration Class. More...

#include <JY5211CoreOOCITask.h>

Public Attributes

JY5211CoreOOProperty< CIInternalSampleClock, double, JY5211CoreOOPropertyType::READ_WRITE > | Rate
The rate of the internal sample clock (sample rate) which is generated by dividing the internal clock (200MHz).
JY5211CoreOOProperty< CIInternalSampleClock, bool, JY5211CoreOOPropertyType::READ_WRITE > | IgnoreFirstSampleClock
IgnoreFirstSampleClock.

Detailed Description

CI Internal Sample Clock Configuration Class.

Member Data Documentation

◆ IgnoreFirstSampleClock

JY5211CoreOOProperty<CIInternalSampleClock, bool, JY5211CoreOOPropertyType::READ_WRITE> JY5211CoreOO::CIInternalSampleClock::IgnoreFirstSampleClock

IgnoreFirstSampleClock.

◆ Rate

JY5211CoreOOProperty<CIInternalSampleClock, double, JY5211CoreOOPropertyType::READ_WRITE> JY5211CoreOO::CIInternalSampleClock::Rate

The rate of the internal sample clock (sample rate) which is generated by dividing the internal clock (200MHz).

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOOCITask.h


5211 C++ Programming Manual: JY5211CoreOO::CIImplicitSampleClock Class Reference

  • CIImplicitSampleClock
Public Attributes | List of all members
JY5211CoreOO::CIImplicitSampleClock Class Reference

CI Implicit Sample Clock class. More...

#include <JY5211CoreOOCITask.h>

Public Attributes

double ExpectedRate
Expected Rate of Implicit Sample Clock.

Detailed Description

CI Implicit Sample Clock class.

Member Data Documentation

◆ ExpectedRate

double JY5211CoreOO::CIImplicitSampleClock::ExpectedRate

Expected Rate of Implicit Sample Clock.

Filling this parameter accurately would helps the driver to set a proper DDR write frequency internally.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOOCITask.h


5211 C++ Programming Manual: JY5211CoreOO::CIExternalSampleClock Class Reference

  • CIExternalSampleClock
Public Attributes | List of all members
JY5211CoreOO::CIExternalSampleClock Class Reference

CI Implicit Sample Clock class. More...

#include <JY5211CoreOOCITask.h>

Public Attributes

ClockTerminal Terminal
External Sample Clock Input Terminal.
double | ExpectedRate
Expected Rate of External Sample Clock.
JY5211CoreOOProperty< CIExternalSampleClock, bool, JY5211CoreOOPropertyType::READ_WRITE > | IgnoreFirstSampleClock
IgnoreFirstSampleClock.

Detailed Description

CI Implicit Sample Clock class.

Member Data Documentation

◆ ExpectedRate

double JY5211CoreOO::CIExternalSampleClock::ExpectedRate

Expected Rate of External Sample Clock.

Filling this parameter accurately would helps the driver to set a proper DDR write frequency internally.

◆ IgnoreFirstSampleClock

JY5211CoreOOProperty<CIExternalSampleClock, bool, JY5211CoreOOPropertyType::READ_WRITE> JY5211CoreOO::CIExternalSampleClock::IgnoreFirstSampleClock

IgnoreFirstSampleClock.

◆ Terminal

ClockTerminal JY5211CoreOO::CIExternalSampleClock::Terminal

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOOCITask.h


5211 C++ Programming Manual: JY5211CoreOO::CISampleClock Class Reference

  • CISampleClock
Public Attributes | List of all members
JY5211CoreOO::CISampleClock Class Reference

CI Sample Clock class. More...

#include <JY5211CoreOOCITask.h>

Public Attributes

CISampleClockSource Source
CI Sample Clock Source.
CIExternalSampleClock * External
CI External Sample Clock Configuration.
CIImplicitSampleClock * Implicit
CI Implicit Sample Clock Configuration.
CIInternalSampleClock * Internal
Internal Sample Clock Configuration.

Detailed Description

CI Sample Clock class.

Member Data Documentation

◆ External

CIExternalSampleClock* JY5211CoreOO::CISampleClock::External

CI External Sample Clock Configuration.

Valid when Source is CISampleClockSource.External.

◆ Implicit

CIImplicitSampleClock* JY5211CoreOO::CISampleClock::Implicit

CI Implicit Sample Clock Configuration.

Valid when Source is CISampleClockSource.Implicit.

◆ Internal

CIInternalSampleClock* JY5211CoreOO::CISampleClock::Internal

Internal Sample Clock Configuration.

Valid when Source is CISampleClockSource.Internal.

◆ Source

CISampleClockSource JY5211CoreOO::CISampleClock::Source

CI Sample Clock Source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOOCITask.h


5211 C++ Programming Manual: JY5211CoreOO::EdgeCounting Class Reference

  • EdgeCounting
Public Attributes | List of all members
JY5211CoreOO::EdgeCounting Class Reference

Configure CI EdgeCounting. More...

#include <JY5211CoreOOCITask.h>

Public Attributes

int InitialCount
Initial Count.
CountDirection Direction
Counter direction.
EdgeType ActiveEdge
The avtive edge of the input signal, the counter will count up or down on this edge.
PauseTrigger * Pause
Pause Trigger Configuration.
EdgeCountingOutEvent * OutEvent
Edge counting output event.
JY5211CoreOO::InputTerminal DirTerminal
Terminal of External Count Diretion Control.
JY5211CoreOO::InputTerminal Input_Terminal
Input Terminal.

Detailed Description

Configure CI EdgeCounting.

Member Data Documentation

◆ ActiveEdge

EdgeType JY5211CoreOO::EdgeCounting::ActiveEdge

The avtive edge of the input signal, the counter will count up or down on this edge.

◆ Direction

CountDirection JY5211CoreOO::EdgeCounting::Direction

Counter direction.

enum Up/Down/External

◆ DirTerminal

JY5211CoreOO::InputTerminal JY5211CoreOO::EdgeCounting::DirTerminal

Terminal of External Count Diretion Control.

Valid when Direction is CountDirection.External

◆ InitialCount

int JY5211CoreOO::EdgeCounting::InitialCount

Initial Count.

◆ Input_Terminal

JY5211CoreOO::InputTerminal JY5211CoreOO::EdgeCounting::Input_Terminal

Input Terminal.

◆ OutEvent

EdgeCountingOutEvent* JY5211CoreOO::EdgeCounting::OutEvent

Edge counting output event.

A pulse will be generated when the count value reaches specified threshold

◆ Pause

PauseTrigger* JY5211CoreOO::EdgeCounting::Pause

Pause Trigger Configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOOCITask.h


5211 C++ Programming Manual: JY5211CoreOO::FrequencyMeas Class Reference

  • FrequencyMeas
Public Attributes | List of all members
JY5211CoreOO::FrequencyMeas Class Reference

Configure CI Measure. More...

#include <JY5211CoreOOCITask.h>

Public Attributes

CITimebase * Timebase
Timebase configuration.
JY5211CoreOO::InputTerminal Input_Terminal
Input Terminal.

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ Input_Terminal

JY5211CoreOO::InputTerminal JY5211CoreOO::FrequencyMeas::Input_Terminal

Input Terminal.

◆ Timebase

CITimebase* JY5211CoreOO::FrequencyMeas::Timebase

Timebase configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOOCITask.h


5211 C++ Programming Manual: JY5211CoreOO::PeriodMeas Class Reference

  • PeriodMeas
Public Attributes | List of all members
JY5211CoreOO::PeriodMeas Class Reference

Configure CI Measure. More...

#include <JY5211CoreOOCITask.h>

Public Attributes

CITimebase * Timebase
Timebase configuration.
JY5211CoreOO::InputTerminal Input_Terminal
Input Terminal.

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ Input_Terminal

JY5211CoreOO::InputTerminal JY5211CoreOO::PeriodMeas::Input_Terminal

Input Terminal.

◆ Timebase

CITimebase* JY5211CoreOO::PeriodMeas::Timebase

Timebase configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOOCITask.h


5211 C++ Programming Manual: JY5211CoreOO::PulseMeas Class Reference

  • PulseMeas
Public Attributes | List of all members
JY5211CoreOO::PulseMeas Class Reference

Configure CI Measure. More...

#include <JY5211CoreOOCITask.h>

Public Attributes

CITimebase * Timebase
Timebase configuration.
JY5211CoreOO::EdgeType StartingEdge
The start edge of the input signal, the counter will count up or down on this edge.
JY5211CoreOO::InputTerminal Input_Terminal
Input Terminal.

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ Input_Terminal

JY5211CoreOO::InputTerminal JY5211CoreOO::PulseMeas::Input_Terminal

Input Terminal.

◆ StartingEdge

JY5211CoreOO::EdgeType JY5211CoreOO::PulseMeas::StartingEdge

The start edge of the input signal, the counter will count up or down on this edge.

◆ Timebase

CITimebase* JY5211CoreOO::PulseMeas::Timebase

Timebase configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOOCITask.h


5211 C++ Programming Manual: JY5211CoreOO::SemiPeriodMeas Class Reference

  • SemiPeriodMeas
Public Attributes | List of all members
JY5211CoreOO::SemiPeriodMeas Class Reference

Configure CI SemiPeriodMeas. More...

#include <JY5211CoreOOCITask.h>

Public Attributes

CITimebase * Timebase
Timebase configuration.
JY5211CoreOO::EdgeType StartingEdge
The start edge of the input signal, the counter will count up or down on this edge.
JY5211CoreOO::InputTerminal Input_Terminal
Input Terminal.

Detailed Description

Configure CI SemiPeriodMeas.

Member Data Documentation

◆ Input_Terminal

JY5211CoreOO::InputTerminal JY5211CoreOO::SemiPeriodMeas::Input_Terminal

Input Terminal.

◆ StartingEdge

JY5211CoreOO::EdgeType JY5211CoreOO::SemiPeriodMeas::StartingEdge

The start edge of the input signal, the counter will count up or down on this edge.

◆ Timebase

CITimebase* JY5211CoreOO::SemiPeriodMeas::Timebase

Timebase configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOOCITask.h


5211 C++ Programming Manual: JY5211CoreOO::TwoEdgeSeparation Class Reference

  • TwoEdgeSeparation
Public Attributes | List of all members
JY5211CoreOO::TwoEdgeSeparation Class Reference

Configure CI Measure. More...

#include <JY5211CoreOOCITask.h>

Public Attributes

CITimebase * Timebase
Timebase configuration.
InputTerminal FirstInputTerminal
Input Terminal.
InputTerminal SecondInputTerminal
Input Terminal.
ValueReturnMode EdgeSeparationMode

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ EdgeSeparationMode

ValueReturnMode JY5211CoreOO::TwoEdgeSeparation::EdgeSeparationMode

数据返回模式

data return mode

◆ FirstInputTerminal

InputTerminal JY5211CoreOO::TwoEdgeSeparation::FirstInputTerminal

Input Terminal.

◆ SecondInputTerminal

InputTerminal JY5211CoreOO::TwoEdgeSeparation::SecondInputTerminal

Input Terminal.

◆ Timebase

CITimebase* JY5211CoreOO::TwoEdgeSeparation::Timebase

Timebase configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOOCITask.h


5211 C++ Programming Manual: JY5211CoreOO::QuadEncoder Class Reference

  • QuadEncoder
Public Attributes | List of all members
JY5211CoreOO::QuadEncoder Class Reference

Configure CI Measure. More...

#include <JY5211CoreOOCITask.h>

Public Attributes

QuadEncodingType EncodingType
Type of Encoding.
bool | ZReloadEnabled
In Encoder mode ,the Z signal enable.
int | InitialCount
Initial Count.
InputTerminal AInputTerminal
Input Terminal.
InputTerminal BInputTerminal
Input Terminal.
InputTerminal ZInputTerminal
Input Terminal.

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ AInputTerminal

InputTerminal JY5211CoreOO::QuadEncoder::AInputTerminal

Input Terminal.

◆ BInputTerminal

InputTerminal JY5211CoreOO::QuadEncoder::BInputTerminal

Input Terminal.

◆ EncodingType

QuadEncodingType JY5211CoreOO::QuadEncoder::EncodingType

Type of Encoding.

◆ InitialCount

int JY5211CoreOO::QuadEncoder::InitialCount

Initial Count.

◆ ZInputTerminal

InputTerminal JY5211CoreOO::QuadEncoder::ZInputTerminal

Input Terminal.

◆ ZReloadEnabled

bool JY5211CoreOO::QuadEncoder::ZReloadEnabled

In Encoder mode ,the Z signal enable.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOOCITask.h


5211 C++ Programming Manual: JY5211CoreOO::TwoPulseEncoder Class Reference

  • TwoPulseEncoder
Public Attributes | List of all members
JY5211CoreOO::TwoPulseEncoder Class Reference

Configure CI Measure. More...

#include <JY5211CoreOOCITask.h>

Public Attributes

int InitialCount
Initial Count.
InputTerminal AInputTerminal
Input Terminal.
InputTerminal BInputTerminal
Input Terminal.

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ AInputTerminal

InputTerminal JY5211CoreOO::TwoPulseEncoder::AInputTerminal

Input Terminal.

◆ BInputTerminal

InputTerminal JY5211CoreOO::TwoPulseEncoder::BInputTerminal

Input Terminal.

◆ InitialCount

int JY5211CoreOO::TwoPulseEncoder::InitialCount

Initial Count.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOOCITask.h


5211 C++ Programming Manual: JY5211CoreOO::CITrigger Class Reference

  • CITrigger
Public Attributes | List of all members
JY5211CoreOO::CITrigger Class Reference

Constructor to create an CITrigger task object. More...

#include <JY5211CoreOOCITask.h>

Public Attributes

CITriggerType Type
CI trigger type.
CIDigitalTrigger * Digital
CI Digital Trigger.

Detailed Description

Constructor to create an CITrigger task object.

Used to build CI Trigger

Member Data Documentation

◆ Digital

CIDigitalTrigger* JY5211CoreOO::CITrigger::Digital

CI Digital Trigger.

Valid when Type is CITriggerType.Digital

◆ Type

CITriggerType JY5211CoreOO::CITrigger::Type

CI trigger type.

enum Immediate/Digital/Soft.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOOCITask.h


5211 C++ Programming Manual: JY5211CoreOO::CIDigitalTrigger Class Reference

  • CIDigitalTrigger
Public Attributes | List of all members
JY5211CoreOO::CIDigitalTrigger Class Reference

CI Digital trigger . More...

#include <JY5211CoreOOCITask.h>

Public Attributes

CIDigitalTriggerSource Source
CI Digital Trigger source.
CIDigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Detailed Description

CI Digital trigger .

Member Data Documentation

◆ Edge

CIDigitalTriggerEdge JY5211CoreOO::CIDigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

CIDigitalTriggerSource JY5211CoreOO::CIDigitalTrigger::Source

CI Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOOCITask.h


5211 C++ Programming Manual: JY5211CoreOO::EdgeCountingOutEvent Class Reference

  • EdgeCountingOutEvent
Public Attributes | List of all members
JY5211CoreOO::EdgeCountingOutEvent Class Reference

Edge counting output event configuration class. More...

#include <JY5211CoreOOCITask.h>

Public Attributes

EdgeCntOunEvtIdleState IdleState
Output idle state when the event has not occurred.
uint32_t Threshold
Comparison threshold.
IOTerminal Terminal
Terminal.

Detailed Description

Edge counting output event configuration class.

Member Data Documentation

◆ IdleState

EdgeCntOunEvtIdleState JY5211CoreOO::EdgeCountingOutEvent::IdleState

Output idle state when the event has not occurred.

The default value is EdgeCntOunEvtIdleState.LowLevel

◆ Terminal

IOTerminal JY5211CoreOO::EdgeCountingOutEvent::Terminal

Terminal.

◆ Threshold

uint32_t JY5211CoreOO::EdgeCountingOutEvent::Threshold

Comparison threshold.

The default value is 2^32-1

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOOCITask.h


5211 C++ Programming Manual: JY5211CoreOO::CIExternalTimebase Class Reference

  • CIExternalTimebase
Public Attributes | List of all members
JY5211CoreOO::CIExternalTimebase Class Reference

#include <JY5211CoreOOCITask.h>

Public Attributes

ClockTerminal Terminal
double Frequency

Detailed Description

外部时基配置类

External timebase configuration class

Member Data Documentation

◆ Frequency

double JY5211CoreOO::CIExternalTimebase::Frequency

外部时基的频率

Frequency of The External Timebase

◆ Terminal

ClockTerminal JY5211CoreOO::CIExternalTimebase::Terminal

外部时基的输入端口

External Timebase Input Terminal

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOOCITask.h


5211 C++ Programming Manual: JY5211CoreOO::CITimebase Class Reference

  • CITimebase
Public Attributes | List of all members
JY5211CoreOO::CITimebase Class Reference

Timebase configuration class. More...

#include <JY5211CoreOOCITask.h>

Public Attributes

CITimebaseSource Source
Timebase Source.
CIExternalTimebase External
External Timebase.

Detailed Description

Timebase configuration class.

Member Data Documentation

◆ External

CIExternalTimebase JY5211CoreOO::CITimebase::External

External Timebase.

◆ Source

CITimebaseSource JY5211CoreOO::CITimebase::Source

Timebase Source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOOCITask.h


5211 C++ Programming Manual: JY5211CoreOO::CISignalExport Class Reference

  • CISignalExport
Public Member Functions | List of all members
JY5211CoreOO::CISignalExport Class Reference

CI Signal Export Class. More...

#include <JY5211CoreOOCITask.h>

Public Member Functions

void | Add (CISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (CISignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

CI Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY5211CoreOO::CISignalExport::Add | ( | CISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | CI Signal Source
destination | Export Desination

◆ Add() [2/2]

void JY5211CoreOO::CISignalExport::Add | ( | CISignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | CI Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JY5211CoreOO::CISignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5211CoreOO::CISignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOOCITask.h


5211 C++ Programming Manual: JY5211CoreOO Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Enumerations | Functions
JY5211CoreOO Namespace Reference

Classes

class | CIDigitalTrigger
CI Digital trigger . More...
class | CIExternalSampleClock
CI Implicit Sample Clock class. More...
class | CIExternalTimebase
class | CIImplicitSampleClock
CI Implicit Sample Clock class. More...
class | CIInternalSampleClock
CI Internal Sample Clock Configuration Class. More...
class | CISampleClock
CI Sample Clock class. More...
class | CISignalExport
CI Signal Export Class. More...
class | CITimebase
Timebase configuration class. More...
class | CITrigger
Constructor to create an CITrigger task object. More...
class | CODigitalTrigger
CO Digital trigger . More...
class | COExternalTimebase
class | COPulse
Pulse Parameter. More...
class | COSignalExport
CO Signal Export Class. More...
class | COTimebase
Timebase configuration class. More...
class | COTrigger
Constructor to create an COTrigger task object. More...
class | EdgeCounting
Configure CI EdgeCounting. More...
class | EdgeCountingOutEvent
Edge counting output event configuration class. More...
class | ExternalReferenceClock
class | FrequencyMeas
Configure CI Measure. More...
class | JY5211CoreOOCITask
class | JY5211CoreOOCOTask
class | JY5211CoreOODevice
class | JY5211CoreOODITask
class | JY5211CoreOODOTask
class | JY5211CoreOOLog
class | JY5211CoreOOProperty
属性模板类 More...
class | JY5211CoreOOReferenceClock
class | JYDriverException
class | PauseTrigger
Pause trigger configuration class. More...
class | PeriodMeas
Configure CI Measure. More...
class | PFIFilter
class | PFISetting
class | PulseMeas
Configure CI Measure. More...
class | QuadEncoder
Configure CI Measure. More...
class | SemiPeriodMeas
Configure CI SemiPeriodMeas. More...
class | TwoEdgeSeparation
Configure CI Measure. More...
class | TwoPulseEncoder
Configure CI Measure. More...

Enumerations

enum class | CountDirection { Up = 0x0 , Down = 0x1 , External = 0x2 }
Counter direction. More...
enum class | CIMode { Single = 0 , Finite = 1 , Continuous = 2 }
CIMode. More...
enum class CIType {
EdgeCounting , Period , Frequency , Pulse ,
SemiPeriod , TwoEdgeSeparation , QuadEncoder , TwoPulseEncoder
}
Counter Input Application Type. More...
enum class | CISampleClockSource { Implicit = 0x0 , Internal = 0x1 , External = 0x2 }
CI Sample Clock Source. More...
enum class | EdgeType { Rising , Falling , Any }
Edge Type. More...
enum class | ValueReturnMode { TwoValue , OneValue }
TwoEdgeSeparation value return mode.only for TwoEdgeSeparation type. More...
enum class | QuadEncodingType { X1 , X2 , X4 }
Quadrature Encoding Type. More...
enum class | CITriggerType { Immediate = 0x0 , Digital = 0x1 , Soft = 0x3 }
TriggerType Digital/Immediate/Soft. More...
enum class CIDigitalTriggerSource {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PFI8 , PFI9 , PFI10 , PFI11 ,
PFI12 , PFI13 , PFI14 , PFI15 ,
PFI16 , PFI17 , PFI18 , PFI19 ,
PFI20 , PFI21 , PFI22 , PFI23 ,
PFI24 , PFI25 , PFI26 , PFI27 ,
PFI28 , PFI29 , PFI130 , PFI131 ,
PFI132 , PFI133 , PFI134 , PFI135 ,
PFI136 , PFI137 , PFI138 , PFI139
}
CI Digital trigger source. More...
enum class | CIDigitalTriggerEdge { Rising , Falling }
CI Digital Trigger Edge. More...
enum class | EdgeCntOunEvtIdleState { LowLevel = 0 , HighLevel = 1 }
Output idle state when the event has not occurred. More...
enum class CISignalExportSource {
StartTrig = 0 , SampleClock = 1 , Internal_Counter_100K = 34 , Internal_Counter_5M = 33 ,
Internal_Counter_100M = 32
}
SourceSignal. More...
enum class | CITimebaseSource { Internal100MHz = 0 , Internal5MHz = 1 , Internal100kHz = 2 , External = 3 }
Timebase source. More...
enum class | JY5211CoreOOPropertyType { READ_ONLY = 1 , WRITE_ONLY = 2 , READ_WRITE = 3 }
enum class JYErrorCode {
NoError = 0 , TimeOut = -10001 , ErrorParam = -10002 , IncorrectCallOrder = -10003 ,
CannotCall = -10004 , UserBufferError = -10005 , BufferOverflow = -10006 , BufferDownflow = -10007 ,
HardwareResourceReserved = -10008 , aiIsStart = -10009 , ErrorParam1 = -10010
}
错误代码的定义 More...
enum class JYDriverExceptionPublic {
UnKnown = 0 , OpenDeviceFailed = -10001 , CloseDeviceFailed = -10002 , ResetDeviceFailed = -10003 ,
GetDevicePropertyFailed = -10004 , SetDevicePropertyFailed = -10005 , HardwareResourceIsReserved = -10006 , MethodNotPermitedToCallWhenCurrentStatus = -10007 ,
InvalidUserDataBuffer = -10008 , NoChannelAdded = -10009 , NotSupportOperationForCurrentDevice = -10010 , CreatTaskFailed = -10100 ,
StartTaskFailed = -10101 , StopTaskFailed = -10102 , TaskHasNotStarted = -10103 , TaskHasStartedCannotPerformTheSetOperation = -10104 ,
ChannelNumberParameterInvalid = -10105 , ChannelInputRangeParameterInvalid = -10106 , ChannelTerminalParameterInvalid = -10107 , ChannelCouplingParameterInvalid = -10108 ,
SampeleModeParameterInvalid = -10109 , SampleClockParameterInvalid = -10110 , SampleRateParameterInvalid = -10111 , UpdateRateParameterInvalid = -10112 ,
TriggerParameterInvalid = -10113 , ReferenceTriggerDoesNotMatchWithSampleMode = -10114 , PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint = -10115 , ReadDataFailed = -10016 ,
ReadDataTimeout = -10017 , WriteDataFailed = -10018 , WriteDataTimeout = -10019 , WriteDataLengthCannotBeLessThanN = -10020 ,
BufferDataOverflow = -10021 , BufferDataDownflow = -10022 , CheckBufferFailed = -10023 , PointInvalidInFiniteMode = -10024 ,
ReadPointInvalid = -10025 , OnlySupportRecordMode = -10026 , SendSoftTirggerFailed = -10027 , TaskTimeout = -10028 ,
CounterParametersInvalid = -10029 , WritePointInvalid = -10030 , SignalExportDestinationInvalid = -10031 , InvalidParameter = -10033
}
enum class ClockTerminal {
PFI0 = 0x00 , PFI1 = 0x01 , PFI2 = 0x02 , PFI3 = 0x03 ,
PFI4 = 0x04 , PFI5 = 0x05 , PFI6 = 0x06 , PFI7 = 0x07 ,
PFI8 = 0x08 , PFI9 = 0x09 , PFI10 = 0xA , PFI11 = 0xB ,
PFI12 = 0xC , PFI13 = 0xD , PFI14 = 0xE , PFI15 = 0xF ,
PFI16 = 0x10 , PFI17 = 0x11 , PFI18 = 0x12 , PFI19 = 0x13 ,
PFI20 = 0x14 , PFI21 = 0x15 , PFI22 = 0x16 , PFI23 = 0x17 ,
PFI24 = 0x18 , PFI25 = 0x19 , PFI26 = 0x1A , PFI27 = 0x1B ,
PFI28 = 0x1C , PFI29 = 0x1D , PFI30 = 0x1E , PFI31 = 0x1F ,
PFI32 = 0x20 , PFI33 = 0x21 , PFI34 = 0x22 , PFI35 = 0x23 ,
PFI36 = 0x24 , PFI37 = 0x25 , PFI38 = 0x26 , PFI39 = 0x27 ,
PXI_Trig0 = 0x28 , PXI_Trig1 = 0x29 , PXI_Trig2 = 0x2A , PXI_Trig3 = 0x2B ,
PXI_Trig4 = 0x2C , PXI_Trig5 = 0x2D , PXI_Trig6 = 0x2E , PXI_Trig7 = 0x2F ,
CO_0_Out = 49 , CO_1_Out = 50 , CO_2_Out =51 , CO_3_Out = 52 ,
CO_4_Out = 53 , CO_5_Out = 54 , CO_6_Out = 55 , CO_7_Out = 56 ,
CI_0_SampelClock = 57 , CI_1_SampelClock = 58 , CI_2_SampelClock = 59 , CI_3_SampelClock = 60 ,
CI_4_SampelClock = 61 , CI_5_SampelClock = 62 , CI_6_SampelClock =63 , CI_7_SampelClock = 64
}
enum class | SyncTopology { Independent , Master , Slave }
enum class SyncTriggerRouting {
NONE = -1 , PFI0 , PFI1 , PFI2 ,
PFI3 , PFI4 , PFI5 , PFI6 ,
PFI7 , PXI_Trig0 = 8 , PXI_Trig1 = 9 , PXI_Trig2 = 10 ,
PXI_Trig3 = 11 , PXI_Trig4 = 12 , PXI_Trig5 = 13 , PXI_Trig6 = 14 ,
PXI_Trig7 = 15
}
enum class SignalExportDestination {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PXI_Trig0 = 8 , PXI_Trig1 = 9 , PXI_Trig2 = 10 , PXI_Trig3 = 11 ,
PXI_Trig4 = 12 , PXI_Trig5 = 13 , PXI_Trig6 = 14 , PXI_Trig7 = 15
}
enum class | OutputCompleteState { Zero , Hold }
Output Complete State. More...
enum class | LevelPolarity { LowLevel = 0 , HighLevel = 1 , None = 2 }
Level Polarity. More...
enum class | OutputState { HoldOn = 0 , HighLevel = 1 , LowLevel = 2 }
enum class IOTerminal {
PFI0 = 0x0 , PFI1 = 0x1 , PFI2 = 0x2 , PFI3 = 0x3 ,
PFI4 = 0x4 , PFI5 = 0x5 , PFI6 = 0x6 , PFI7 = 0x7 ,
PFI8 = 0x8 , PFI9 = 0x9 , PFI10 = 0xA , PFI11 = 0xB ,
PFI12 = 0xC , PFI13 = 0xD , PFI14 = 0xE , PFI15 = 0xF ,
PFI16 = 0x10 , PFI17 = 0x11 , PFI18 = 0x12 , PFI19 = 0x13 ,
PFI20 = 0x14 , PFI21 = 0x15 , PFI22 = 0x16 , PFI23 = 0x17 ,
PFI24 = 0x18 , PFI25 = 0x19 , PFI26 = 0x1A , PFI27 = 0x1B ,
PFI28 = 0x1C , PFI29 = 0x1D , PFI30 = 0x1E , PFI31 = 0x1F ,
PFI32 = 0x20 , PFI33 = 0x21 , PFI34 = 0x22 , PFI35 = 0x23 ,
PFI36 = 0x24 , PFI37 = 0x25 , PFI38 = 0x26 , PFI39 = 0x27 ,
PXI_Trig0 = 0x28 , PXI_Trig1 = 0x29 , PXI_Trig2 = 0x2A , PXI_Trig3 = 0x2B ,
PXI_Trig4 = 0x2C , PXI_Trig5 = 0x2D , PXI_Trig6 = 0x2E , PXI_Trig7 = 0x2F ,
PXI_Star = 0x30
}
enum class InputTerminal {
PFI0 = 0x0 , PFI1 = 0x1 , PFI2 = 0x2 , PFI3 = 0x3 ,
PFI4 = 0x4 , PFI5 = 0x5 , PFI6 = 0x6 , PFI7 = 0x7 ,
PFI8 = 0x8 , PFI9 = 0x9 , PFI10 = 0xA , PFI11 = 0xB ,
PFI12 = 0xC , PFI13 = 0xD , PFI14 = 0xE , PFI15 = 0xF ,
PFI16 = 0x10 , PFI17 = 0x11 , PFI18 = 0x12 , PFI19 = 0x13 ,
PFI20 = 0x14 , PFI21 = 0x15 , PFI22 = 0x16 , PFI23 = 0x17 ,
PFI24 = 0x18 , PFI25 = 0x19 , PFI26 = 0x1A , PFI27 = 0x1B ,
PFI28 = 0x1C , PFI29 = 0x1D , PFI30 = 0x1E , PFI31 = 0x1F ,
PFI32 = 0x20 , PFI33 = 0x21 , PFI34 = 0x22 , PFI35 = 0x23 ,
PFI36 = 0x24 , PFI37 = 0x25 , PFI38 = 0x26 , PFI39 = 0x27 ,
PXI_Trig0 = 0x28 , PXI_Trig1 = 0x29 , PXI_Trig2 = 0x2A , PXI_Trig3 = 0x2B ,
PXI_Trig4 = 0x2C , PXI_Trig5 = 0x2D , PXI_Trig6 = 0x2E , PXI_Trig7 = 0x2F ,
PXI_Star = 0x30 , Internal_50M = 0x31 , Internal_5M = 0x32 , Internal_100K = 0x33 ,
Internal_CO_0_Out = 0x34 , Internal_CO_1_Out = 0x35 , Internal_CO_2_Out = 0x36 , Internal_CO_3_Out = 0x37 ,
Internal_CO_4_Out = 0x38 , Internal_CO_5_Out = 0x39 , Internal_CO_6_Out = 0x3A , Internal_CO_7_Out = 0x3B
}
Cunter Input Terminal. More...
enum class | COIdleState { HighLevel = 0x1 , LowLevel = 0x0 }
Idle state when pulse output before start and after stop. More...
enum class | COMode { Single = 0 , Finite = 1 , ContinuousNoWrapping = 2 , ContinuousWrapping = 3 }
enum class | COTriggerType { Immediate = 0x0 , Digital = 0x1 , Soft = 0x3 }
TriggerType Digital/Immediate/Soft. More...
enum class CODigitalTriggerSource {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PFI8 , PFI9 , PFI10 , PFI11 ,
PFI12 , PFI13 , PFI14 , PFI15 ,
PFI16 , PFI17 , PFI18 , PFI19 ,
PFI20 , PFI21 , PFI22 , PFI23 ,
PFI24 , PFI25 , PFI26 , PFI27 ,
PFI28 , PFI29 , PFI130 , PFI131 ,
PFI132 , PFI133 , PFI134 , PFI135 ,
PFI136 , PFI137 , PFI138 , PFI139
}
CO Digital trigger source. More...
enum class | CODigitalTriggerEdge { Rising , Falling }
CO Digital Trigger Edge. More...
enum class | COPulseType { DutyCycleFrequency , HighLowTime , HighLowTick }
Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick. More...
enum class | COTimebaseSource { Internal100MHz = 0 , Internal5MHz = 1 , Internal100kHz = 2 , External = 3 }
Timebase source. More...
enum class COSignalExportSource {
StartTrig , Output , Internal_Counter_100K = 34 , Internal_Counter_5M = 33 ,
Internal_Counter_100M = 32
}
SourceSignal. More...
enum class | ReferenceClockSource { Internal = 0x0 , External = 0x1 }
enum class | ExternalReferenceClockTerminal { PXIe_Clk100 = 0 , PXIe_DStarA = 1 }
enum class PFITerminal {
PFI0 = 0 , PFI1 = 1 , PFI2 = 2 , PFI3 = 3 ,
PFI4 = 4 , PFI5 = 5 , PFI6 = 6 , PFI7 = 7 ,
PFI8 = 8 , PFI9 = 9 , PFI10 = 10 , PFI11 = 11 ,
PFI12 = 12 , PFI13 = 13 , PFI14 = 14 , PFI15 = 15
}
Input/Output Terminal of PFI. More...
enum class JY5211CoreOOLogLevel {
DEBUG_LOG_LEVEL , INFO_LOG_LEVEL , WARN_LOG_LEVEL , ERROR_LOG_LEVEL ,
FATAL_LOG_LEVEL
}

Functions

std::string GetSignalExportDestinationString (SignalExportDestination destination)

Enumeration Type Documentation

◆ CIDigitalTriggerEdge

enum class JY5211CoreOO::CIDigitalTriggerEdge
strong

CI Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ CIDigitalTriggerSource

enum class JY5211CoreOO::CIDigitalTriggerSource
strong

CI Digital trigger source.

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI6.
PFI9 | PFI7.
PFI10 | PFI0.
PFI11 | PFI1.
PFI12 | PFI2.
PFI13 | PFI3.
PFI14 | PFI4.
PFI15 | PFI5.
PFI16 | PFI6.
PFI17 | PFI7.
PFI18 | PFI6.
PFI19 | PFI7.
PFI20 | PFI20.
PFI21 | PFI21.
PFI22 | PFI22.
PFI23 | PFI23.
PFI24 | PFI24.
PFI25 | PFI25.
PFI26 | PFI26.
PFI27 | PFI27.
PFI28 | PFI28.
PFI29 | PFI29.
PFI130 | PFI30.
PFI131 | PFI31.
PFI132 | PFI32.
PFI133 | PFI33.
PFI134 | PFI34.
PFI135 | PFI35.
PFI136 | PFI36.
PFI137 | PFI37.
PFI138 | PFI38.
PFI139 | PFI39.

◆ CIMode

enum class JY5211CoreOO::CIMode
strong

CIMode.

Enumerator
Single | Single.
Finite | Finite.
Continuous | Continuous.

◆ CISampleClockSource

enum class JY5211CoreOO::CISampleClockSource
strong

CI Sample Clock Source.

Enumerator
Implicit | Implicit.
Internal | Internal.
External | External.

◆ CISignalExportSource

enum class JY5211CoreOO::CISignalExportSource
strong

SourceSignal.

Enumerator
StartTrig | CI_StartTrig.
SampleClock | CI_SampleClock.
Internal_Counter_100K | Internal Counte 100K timebase.
Internal_Counter_5M | Internal Counte 5M timebase.
Internal_Counter_100M | Internal Counte 100Mtimebase.

◆ CITimebaseSource

enum class JY5211CoreOO::CITimebaseSource
strong

Timebase source.

Enumerator
Internal100MHz | 内部100MHz时基 Internal 100MHz Timebase
Internal5MHz | 内部5MHz时基 Internal 5MHz Timebase
Internal100kHz | 内部100kHz时基 Internal 100kHz Timebase
External | 外部时基 External Timebase

◆ CITriggerType

enum class JY5211CoreOO::CITriggerType
strong

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ CIType

enum class JY5211CoreOO::CIType
strong

Counter Input Application Type.

Enumerator
EdgeCounting | Edge Counting.
Period | Period Measure.
Frequency | Frequenc Measure.
Pulse | Pulse Measure.
SemiPeriod | SemiPeriod Measure.
TwoEdgeSeparation | TwoEdgeSeparation Measure.
QuadEncoder | QuadEncoder.
TwoPulseEncoder | EncoderTwoPulse.

◆ ClockTerminal

enum class JY5211CoreOO::ClockTerminal
strong
Enumerator
PFI0 | PFI 0.
PFI1 | PFI 1.
PFI2 | PFI 2.
PFI3 | PFI 3.
PFI4 | PFI 4.
PFI5 | PFI 5.
PFI6 | PFI 6.
PFI7 | PFI 7.
PFI8 | PFI 8.
PFI9 | PFI 9.
PFI10 | PFI 10.
PFI11 | PFI 11.
PFI12 | PFI 12.
PFI13 | PFI 13.
PFI14 | PFI 14.
PFI15 | PFI 15.
PFI16 | PFI 16.
PFI17 | PFI 17.
PFI18 | PFI 18.
PFI19 | PFI 19.
PFI20 | PFI 20.
PFI21 | PFI 21.
PFI22 | PFI 22.
PFI23 | PFI 23.
PFI24 | PFI 24.
PFI25 | PFI 25.
PFI26 | PFI 26.
PFI27 | PFI 27.
PFI28 | PFI 28.
PFI29 | PFI 29.
PFI30 | PFI 30.
PFI31 | PFI 31.
PFI32 | PFI 32.
PFI33 | PFI 33.
PFI34 | PFI 34.
PFI35 | PFI 35.
PFI36 | PFI 36.
PFI37 | PFI 37.
PFI38 | PFI 38.
PFI39 | PFI 39.
PXI_Trig0 | PXI Trigger 0.
PXI_Trig1 | PXI Trigger 1.
PXI_Trig2 | PXI Trigger 2.
PXI_Trig3 | PXI Trigger 3.
PXI_Trig4 | PXI Trigger 4.
PXI_Trig5 | PXI Trigger 5.
PXI_Trig6 | PXI Trigger 6.
PXI_Trig7 | PXI Trigger 7.
CO_0_Out | CO_0_Out.
CO_1_Out | CO_1_Out.
CO_2_Out | CO_2_Out.
CO_3_Out | CO_3_Out.
CO_4_Out | CO_4_Out.
CO_5_Out | CO_5_Out.
CO_6_Out | CO_6_Out.
CO_7_Out | CO_7_Out.
CI_0_SampelClock | CI_0_SampelClock.
CI_1_SampelClock | CI_1_SampelClock.
CI_2_SampelClock | CI_2_SampelClock.
CI_3_SampelClock | CI_3_SampelClock.
CI_4_SampelClock | CI_4_SampelClock.
CI_5_SampelClock | CI_5_SampelClock.
CI_6_SampelClock | CI_6_SampelClock.
CI_7_SampelClock | CI_7_SampelClock.

◆ CODigitalTriggerEdge

enum class JY5211CoreOO::CODigitalTriggerEdge
strong

CO Digital Trigger Edge.

Enumerator
Rising | Rising Edge.
Falling | Falling Edge.

◆ CODigitalTriggerSource

enum class JY5211CoreOO::CODigitalTriggerSource
strong

CO Digital trigger source.

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI6.
PFI9 | PFI7.
PFI10 | PFI0.
PFI11 | PFI1.
PFI12 | PFI2.
PFI13 | PFI3.
PFI14 | PFI4.
PFI15 | PFI5.
PFI16 | PFI6.
PFI17 | PFI7.
PFI18 | PFI6.
PFI19 | PFI7.
PFI20 | PFI20.
PFI21 | PFI21.
PFI22 | PFI22.
PFI23 | PFI23.
PFI24 | PFI24.
PFI25 | PFI25.
PFI26 | PFI26.
PFI27 | PFI27.
PFI28 | PFI28.
PFI29 | PFI29.
PFI130 | PFI30.
PFI131 | PFI31.
PFI132 | PFI32.
PFI133 | PFI33.
PFI134 | PFI34.
PFI135 | PFI35.
PFI136 | PFI36.
PFI137 | PFI37.
PFI138 | PFI38.
PFI139 | PFI39.

◆ COIdleState

enum class JY5211CoreOO::COIdleState
strong

Idle state when pulse output before start and after stop.

Enumerator
HighLevel | Idle state is high level.
LowLevel | Idle state is low level.

◆ COMode

enum class JY5211CoreOO::COMode
strong
Enumerator
Single | Single pulse output.
Finite | Finite.
ContinuousNoWrapping | ContinuousNoWrapping.
ContinuousWrapping | ContinuousWrapping.

◆ COPulseType

enum class JY5211CoreOO::COPulseType
strong

Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick.

Enumerator
DutyCycleFrequency | Configure CO output pulse according to its DutyCycle and Freqency.
HighLowTime | Configure CO output pulse according to duration of its high/low voltage levels.
HighLowTick | Configure CO output pulse according to its high/low tick level.

◆ COSignalExportSource

enum class JY5211CoreOO::COSignalExportSource
strong

SourceSignal.

Enumerator
StartTrig | CI_StartTrig.
Output | CO_Output.
Internal_Counter_100K | Internal Counte 100K timebase.
Internal_Counter_5M | Internal Counte 5M timebase.
Internal_Counter_100M | Internal Counte 100Mtimebase.

◆ COTimebaseSource

enum class JY5211CoreOO::COTimebaseSource
strong

Timebase source.

Enumerator
Internal100MHz | 内部100MHz时基 Internal 100MHz Timebase
Internal5MHz | 内部5MHz时基 Internal 5MHz Timebase
Internal100kHz | 内部100kHz时基 Internal 100kHz Timebase
External | 外部时基 External Timebase

◆ COTriggerType

enum class JY5211CoreOO::COTriggerType
strong

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ CountDirection

enum class JY5211CoreOO::CountDirection
strong

Counter direction.

enum Up/Down/External

Enumerator
Up | Counter increases.
Down | Counter decreases.
External | External signal control counter direction. If External signal is highlevel counter increases, or lowlevel counter decreases.

◆ EdgeCntOunEvtIdleState

enum class JY5211CoreOO::EdgeCntOunEvtIdleState
strong

Output idle state when the event has not occurred.

Enumerator
LowLevel | Idle state is low level.
HighLevel | Idle state is high level.

◆ EdgeType

enum class JY5211CoreOO::EdgeType
strong

Edge Type.

Enumerator
Rising | Rising Edge.
Falling | Falling Edge.
Any | Any Edge.

◆ ExternalReferenceClockTerminal

enum class JY5211CoreOO::ExternalReferenceClockTerminal
strong

外部参考时钟输入端口

External Reference Clcok Terminal

Enumerator
PXIe_Clk100 | PXIe CLK100 PXIe CLK100
PXIe_DStarA | PXIe_DStarA PXIe_DStarA

◆ InputTerminal

enum class JY5211CoreOO::InputTerminal
strong

Cunter Input Terminal.

Enumerator
PFI0 | PFI 0.
PFI1 | PFI 1.
PFI2 | PFI 2.
PFI3 | PFI 3.
PFI4 | PFI 4.
PFI5 | PFI 5.
PFI6 | PFI 6.
PFI7 | PFI 7.
PFI8 | PFI 8.
PFI9 | PFI 9.
PFI10 | PFI 10.
PFI11 | PFI 11.
PFI12 | PFI 12.
PFI13 | PFI 13.
PFI14 | PFI 14.
PFI15 | PFI 15.
PFI16 | PFI 16.
PFI17 | PFI 17.
PFI18 | PFI 18.
PFI19 | PFI 19.
PFI20 | PFI 20.
PFI21 | PFI 21.
PFI22 | PFI 22.
PFI23 | PFI 23.
PFI24 | PFI 24.
PFI25 | PFI 25.
PFI26 | PFI 26.
PFI27 | PFI 27.
PFI28 | PFI 28.
PFI29 | PFI 29.
PFI30 | PFI 30.
PFI31 | PFI 31.
PFI32 | PFI 32.
PFI33 | PFI 33.
PFI34 | PFI 34.
PFI35 | PFI 35.
PFI36 | PFI 36.
PFI37 | PFI 37.
PFI38 | PFI 38.
PFI39 | PFI 39.
PXI_Trig0 | PXI Trigger 0.
PXI_Trig1 | PXI Trigger 1.
PXI_Trig2 | PXI Trigger 2.
PXI_Trig3 | PXI Trigger 3.
PXI_Trig4 | PXI Trigger 4.
PXI_Trig5 | PXI Trigger 5.
PXI_Trig6 | PXI Trigger 6.
PXI_Trig7 | PXI Trigger 7.
PXI_Star | PXI STAR.
Internal_50M | Internal_50M.
Internal_5M | Internal_5M.
Internal_100K | Internal_100K.
Internal_CO_0_Out | CO_0_Out.
Internal_CO_1_Out | CO_1_Out.
Internal_CO_2_Out | CO_2_Out.
Internal_CO_3_Out | CO_3_Out.
Internal_CO_4_Out | CO_4_Out.
Internal_CO_5_Out | CO_5_Out.
Internal_CO_6_Out | CO_6_Out.
Internal_CO_7_Out | CO_7_Out.

◆ IOTerminal

enum class JY5211CoreOO::IOTerminal
strong

输入输出接口

Input/Output Terminal

Enumerator
PFI0 | PFI 0.
PFI1 | PFI 1.
PFI2 | PFI 2.
PFI3 | PFI 3.
PFI4 | PFI 4.
PFI5 | PFI 5.
PFI6 | PFI 6.
PFI7 | PFI 7.
PFI8 | PFI 8.
PFI9 | PFI 9.
PFI10 | PFI 10.
PFI11 | PFI 11.
PFI12 | PFI 12.
PFI13 | PFI 13.
PFI14 | PFI 14.
PFI15 | PFI 15.
PFI16 | PFI 16.
PFI17 | PFI 17.
PFI18 | PFI 18.
PFI19 | PFI 19.
PFI20 | PFI 20.
PFI21 | PFI 21.
PFI22 | PFI 22.
PFI23 | PFI 23.
PFI24 | PFI 24.
PFI25 | PFI 25.
PFI26 | PFI 26.
PFI27 | PFI 27.
PFI28 | PFI 28.
PFI29 | PFI 29.
PFI30 | PFI 30.
PFI31 | PFI 31.
PFI32 | PFI 32.
PFI33 | PFI 33.
PFI34 | PFI 34.
PFI35 | PFI 35.
PFI36 | PFI 36.
PFI37 | PFI 37.
PFI38 | PFI 38.
PFI39 | PFI 39.
PXI_Trig0 | PXI Trigger 0.
PXI_Trig1 | PXI Trigger 1.
PXI_Trig2 | PXI Trigger 2.
PXI_Trig3 | PXI Trigger 3.
PXI_Trig4 | PXI Trigger 4.
PXI_Trig5 | PXI Trigger 5.
PXI_Trig6 | PXI Trigger 6.
PXI_Trig7 | PXI Trigger 7.
PXI_Star | PXI STAR.

◆ JY5211CoreOOLogLevel

enum class JY5211CoreOO::JY5211CoreOOLogLevel
strong
Enumerator
DEBUG_LOG_LEVEL
INFO_LOG_LEVEL
WARN_LOG_LEVEL
ERROR_LOG_LEVEL
FATAL_LOG_LEVEL

◆ JY5211CoreOOPropertyType

enum class JY5211CoreOO::JY5211CoreOOPropertyType
strong
Enumerator
READ_ONLY
WRITE_ONLY
READ_WRITE

◆ JYDriverExceptionPublic

enum class JY5211CoreOO::JYDriverExceptionPublic
strong
Enumerator
UnKnown | JYDriverExceptionPublic.
OpenDeviceFailed | JYDriverExceptionPublic.
CloseDeviceFailed | JYDriverExceptionPublic.
ResetDeviceFailed | JYDriverExceptionPublic.
GetDevicePropertyFailed | JYDriverExceptionPublic.
SetDevicePropertyFailed | JYDriverExceptionPublic.
HardwareResourceIsReserved | JYDriverExceptionPublic.
MethodNotPermitedToCallWhenCurrentStatus | JYDriverExceptionPublic.
InvalidUserDataBuffer | JYDriverExceptionPublic.
NoChannelAdded | JYDriverExceptionPublic.
NotSupportOperationForCurrentDevice | JYDriverExceptionPublic.
CreatTaskFailed | JYDriverExceptionPublic.
StartTaskFailed | JYDriverExceptionPublic.
StopTaskFailed | JYDriverExceptionPublic.
TaskHasNotStarted | JYDriverExceptionPublic.
TaskHasStartedCannotPerformTheSetOperation | JYDriverExceptionPublic.
ChannelNumberParameterInvalid | JYDriverExceptionPublic.
ChannelInputRangeParameterInvalid | JYDriverExceptionPublic.
ChannelTerminalParameterInvalid | JYDriverExceptionPublic.
ChannelCouplingParameterInvalid | JYDriverExceptionPublic.
SampeleModeParameterInvalid | JYDriverExceptionPublic.
SampleClockParameterInvalid | JYDriverExceptionPublic.
SampleRateParameterInvalid | JYDriverExceptionPublic.
UpdateRateParameterInvalid | JYDriverExceptionPublic.
TriggerParameterInvalid | JYDriverExceptionPublic.
ReferenceTriggerDoesNotMatchWithSampleMode | JYDriverExceptionPublic.
PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint | JYDriverExceptionPublic.
ReadDataFailed | JYDriverExceptionPublic.
ReadDataTimeout | JYDriverExceptionPublic.
WriteDataFailed | JYDriverExceptionPublic.
WriteDataTimeout | JYDriverExceptionPublic.
WriteDataLengthCannotBeLessThanN | JYDriverExceptionPublic.
BufferDataOverflow | JYDriverExceptionPublic.
BufferDataDownflow | JYDriverExceptionPublic.
CheckBufferFailed | JYDriverExceptionPublic.
PointInvalidInFiniteMode | JYDriverExceptionPublic.
ReadPointInvalid | JYDriverExceptionPublic.
OnlySupportRecordMode | JYDriverExceptionPublic.
SendSoftTirggerFailed | JYDriverExceptionPublic.
TaskTimeout | JYDriverExceptionPublic.
CounterParametersInvalid | JYDriverExceptionPublic.
WritePointInvalid | JYDriverExceptionPublic.
SignalExportDestinationInvalid | JYDriverExceptionPublic.
InvalidParameter | 无效参数。 Invaild parameter.

◆ JYErrorCode

enum class JY5211CoreOO::JYErrorCode
strong

错误代码的定义

Enumerator
NoError | 无错误
TimeOut | 超时
ErrorParam | 参数错误
IncorrectCallOrder | 调用顺序不正确
CannotCall | 当前配置不能调用该方法
UserBufferError | 用户缓冲区错误
BufferOverflow | 缓冲区溢出
BufferDownflow | 缓冲区下溢出
HardwareResourceReserved | 硬件资源已被占用
aiIsStart | AI已经启动，不用添加通道
ErrorParam1 | 输入幅值范围不正确,范围最大值和最小值

◆ LevelPolarity

enum class JY5211CoreOO::LevelPolarity
strong

Level Polarity.

Enumerator
LowLevel | Low level.
HighLevel | High level.
None | No active polarity.

◆ OutputCompleteState

enum class JY5211CoreOO::OutputCompleteState
strong

Output Complete State.

Enumerator
Zero | Output Complete Zero.
Hold | Output Complete Hold in The last point.

◆ OutputState

enum class JY5211CoreOO::OutputState
strong
Enumerator
HoldOn | output hold on
HighLevel | output HighLevel
LowLevel | output LowLevel

◆ PFITerminal

enum class JY5211CoreOO::PFITerminal
strong

Input/Output Terminal of PFI.

Enumerator
PFI0 | PFI 0.
PFI1 | PFI 1.
PFI2 | PFI 2.
PFI3 | PFI 3.
PFI4 | PFI 4.
PFI5 | PFI 5.
PFI6 | PFI 6.
PFI7 | PFI 7.
PFI8 | PFI 8.
PFI9 | PFI 9.
PFI10 | PFI 10.
PFI11 | PFI 11.
PFI12 | PFI 12.
PFI13 | PFI 13.
PFI14 | PFI 14.
PFI15 | PFI 15.

◆ QuadEncodingType

enum class JY5211CoreOO::QuadEncodingType
strong

Quadrature Encoding Type.

Enumerator
X1 | X1.
X2 | X2.
X4 | X4.

◆ ReferenceClockSource

enum class JY5211CoreOO::ReferenceClockSource
strong

参考时钟源

Reference Clock Source

Enumerator
Internal | Internal on board 25MHz Clock.
External | External Reference Clock Source.

◆ SignalExportDestination

enum class JY5211CoreOO::SignalExportDestination
strong
Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.

◆ SyncTopology

enum class JY5211CoreOO::SyncTopology
strong
Enumerator
Independent | Independent, synchronization not supported
Master | master card
Slave | slave card

◆ SyncTriggerRouting

enum class JY5211CoreOO::SyncTriggerRouting
strong
Enumerator
NONE | Default NONE.
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.

◆ ValueReturnMode

enum class JY5211CoreOO::ValueReturnMode
strong

TwoEdgeSeparation value return mode.only for TwoEdgeSeparation type.

Enumerator
TwoValue | Return two data simultaneously. first data is gate to aux edge separation, second data is aux to gate edge separation.
OneValue | only return gate to aux edge separation

Function Documentation

◆ GetSignalExportDestinationString()

std::string JY5211CoreOO::GetSignalExportDestinationString ( SignalExportDestination destination )
inline


5211 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOOCommon.h File Reference

  • File List
  • File Members
  • COO
  • 5211
Classes | Namespaces | Macros | Enumerations | Functions
JY5211CoreOOCommon.h File Reference
#include <string>
#include <stdint.h>

Classes

class | JY5211CoreOO::JYDriverException
class | JY5211CoreOO::JY5211CoreOOProperty< ContainerClass, ValueType, propertyType >
属性模板类 More...
class | JY5211CoreOO::PauseTrigger
Pause trigger configuration class. More...

Namespaces

namespace JY5211CoreOO

Macros

#define | EXTERN_C extern
Windows.
#define | JY5211CoreOO_API

Enumerations

enum class | JY5211CoreOO::JY5211CoreOOPropertyType { JY5211CoreOO::READ_ONLY = 1 , JY5211CoreOO::WRITE_ONLY = 2 , JY5211CoreOO::READ_WRITE = 3 }
enum class JY5211CoreOO::JYErrorCode {
JY5211CoreOO::NoError = 0 , JY5211CoreOO::TimeOut = -10001 , JY5211CoreOO::ErrorParam = -10002 , JY5211CoreOO::IncorrectCallOrder = -10003 ,
JY5211CoreOO::CannotCall = -10004 , JY5211CoreOO::UserBufferError = -10005 , JY5211CoreOO::BufferOverflow = -10006 , JY5211CoreOO::BufferDownflow = -10007 ,
JY5211CoreOO::HardwareResourceReserved = -10008 , JY5211CoreOO::aiIsStart = -10009 , JY5211CoreOO::ErrorParam1 = -10010
}
错误代码的定义 More...
enum class JY5211CoreOO::JYDriverExceptionPublic {
JY5211CoreOO::UnKnown = 0 , JY5211CoreOO::OpenDeviceFailed = -10001 , JY5211CoreOO::CloseDeviceFailed = -10002 , JY5211CoreOO::ResetDeviceFailed = -10003 ,
JY5211CoreOO::GetDevicePropertyFailed = -10004 , JY5211CoreOO::SetDevicePropertyFailed = -10005 , JY5211CoreOO::HardwareResourceIsReserved = -10006 , JY5211CoreOO::MethodNotPermitedToCallWhenCurrentStatus = -10007 ,
JY5211CoreOO::InvalidUserDataBuffer = -10008 , JY5211CoreOO::NoChannelAdded = -10009 , JY5211CoreOO::NotSupportOperationForCurrentDevice = -10010 , JY5211CoreOO::CreatTaskFailed = -10100 ,
JY5211CoreOO::StartTaskFailed = -10101 , JY5211CoreOO::StopTaskFailed = -10102 , JY5211CoreOO::TaskHasNotStarted = -10103 , JY5211CoreOO::TaskHasStartedCannotPerformTheSetOperation = -10104 ,
JY5211CoreOO::ChannelNumberParameterInvalid = -10105 , JY5211CoreOO::ChannelInputRangeParameterInvalid = -10106 , JY5211CoreOO::ChannelTerminalParameterInvalid = -10107 , JY5211CoreOO::ChannelCouplingParameterInvalid = -10108 ,
JY5211CoreOO::SampeleModeParameterInvalid = -10109 , JY5211CoreOO::SampleClockParameterInvalid = -10110 , JY5211CoreOO::SampleRateParameterInvalid = -10111 , JY5211CoreOO::UpdateRateParameterInvalid = -10112 ,
JY5211CoreOO::TriggerParameterInvalid = -10113 , JY5211CoreOO::ReferenceTriggerDoesNotMatchWithSampleMode = -10114 , JY5211CoreOO::PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint = -10115 , JY5211CoreOO::ReadDataFailed = -10016 ,
JY5211CoreOO::ReadDataTimeout = -10017 , JY5211CoreOO::WriteDataFailed = -10018 , JY5211CoreOO::WriteDataTimeout = -10019 , JY5211CoreOO::WriteDataLengthCannotBeLessThanN = -10020 ,
JY5211CoreOO::BufferDataOverflow = -10021 , JY5211CoreOO::BufferDataDownflow = -10022 , JY5211CoreOO::CheckBufferFailed = -10023 , JY5211CoreOO::PointInvalidInFiniteMode = -10024 ,
JY5211CoreOO::ReadPointInvalid = -10025 , JY5211CoreOO::OnlySupportRecordMode = -10026 , JY5211CoreOO::SendSoftTirggerFailed = -10027 , JY5211CoreOO::TaskTimeout = -10028 ,
JY5211CoreOO::CounterParametersInvalid = -10029 , JY5211CoreOO::WritePointInvalid = -10030 , JY5211CoreOO::SignalExportDestinationInvalid = -10031 , JY5211CoreOO::InvalidParameter = -10033
}
enum class JY5211CoreOO::ClockTerminal {
JY5211CoreOO::PFI0 = 0x00 , JY5211CoreOO::PFI1 = 0x01 , JY5211CoreOO::PFI2 = 0x02 , JY5211CoreOO::PFI3 = 0x03 ,
JY5211CoreOO::PFI4 = 0x04 , JY5211CoreOO::PFI5 = 0x05 , JY5211CoreOO::PFI6 = 0x06 , JY5211CoreOO::PFI7 = 0x07 ,
JY5211CoreOO::PFI8 = 0x08 , JY5211CoreOO::PFI9 = 0x09 , JY5211CoreOO::PFI10 = 0xA , JY5211CoreOO::PFI11 = 0xB ,
JY5211CoreOO::PFI12 = 0xC , JY5211CoreOO::PFI13 = 0xD , JY5211CoreOO::PFI14 = 0xE , JY5211CoreOO::PFI15 = 0xF ,
JY5211CoreOO::PFI16 = 0x10 , JY5211CoreOO::PFI17 = 0x11 , JY5211CoreOO::PFI18 = 0x12 , JY5211CoreOO::PFI19 = 0x13 ,
JY5211CoreOO::PFI20 = 0x14 , JY5211CoreOO::PFI21 = 0x15 , JY5211CoreOO::PFI22 = 0x16 , JY5211CoreOO::PFI23 = 0x17 ,
JY5211CoreOO::PFI24 = 0x18 , JY5211CoreOO::PFI25 = 0x19 , JY5211CoreOO::PFI26 = 0x1A , JY5211CoreOO::PFI27 = 0x1B ,
JY5211CoreOO::PFI28 = 0x1C , JY5211CoreOO::PFI29 = 0x1D , JY5211CoreOO::PFI30 = 0x1E , JY5211CoreOO::PFI31 = 0x1F ,
JY5211CoreOO::PFI32 = 0x20 , JY5211CoreOO::PFI33 = 0x21 , JY5211CoreOO::PFI34 = 0x22 , JY5211CoreOO::PFI35 = 0x23 ,
JY5211CoreOO::PFI36 = 0x24 , JY5211CoreOO::PFI37 = 0x25 , JY5211CoreOO::PFI38 = 0x26 , JY5211CoreOO::PFI39 = 0x27 ,
JY5211CoreOO::PXI_Trig0 = 0x28 , JY5211CoreOO::PXI_Trig1 = 0x29 , JY5211CoreOO::PXI_Trig2 = 0x2A , JY5211CoreOO::PXI_Trig3 = 0x2B ,
JY5211CoreOO::PXI_Trig4 = 0x2C , JY5211CoreOO::PXI_Trig5 = 0x2D , JY5211CoreOO::PXI_Trig6 = 0x2E , JY5211CoreOO::PXI_Trig7 = 0x2F ,
JY5211CoreOO::CO_0_Out = 49 , JY5211CoreOO::CO_1_Out = 50 , JY5211CoreOO::CO_2_Out =51 , JY5211CoreOO::CO_3_Out = 52 ,
JY5211CoreOO::CO_4_Out = 53 , JY5211CoreOO::CO_5_Out = 54 , JY5211CoreOO::CO_6_Out = 55 , JY5211CoreOO::CO_7_Out = 56 ,
JY5211CoreOO::CI_0_SampelClock = 57 , JY5211CoreOO::CI_1_SampelClock = 58 , JY5211CoreOO::CI_2_SampelClock = 59 , JY5211CoreOO::CI_3_SampelClock = 60 ,
JY5211CoreOO::CI_4_SampelClock = 61 , JY5211CoreOO::CI_5_SampelClock = 62 , JY5211CoreOO::CI_6_SampelClock =63 , JY5211CoreOO::CI_7_SampelClock = 64
}
enum class | JY5211CoreOO::SyncTopology { JY5211CoreOO::Independent , JY5211CoreOO::Master , JY5211CoreOO::Slave }
enum class JY5211CoreOO::SyncTriggerRouting {
JY5211CoreOO::NONE = -1 , JY5211CoreOO::PFI0 , JY5211CoreOO::PFI1 , JY5211CoreOO::PFI2 ,
JY5211CoreOO::PFI3 , JY5211CoreOO::PFI4 , JY5211CoreOO::PFI5 , JY5211CoreOO::PFI6 ,
JY5211CoreOO::PFI7 , JY5211CoreOO::PXI_Trig0 = 8 , JY5211CoreOO::PXI_Trig1 = 9 , JY5211CoreOO::PXI_Trig2 = 10 ,
JY5211CoreOO::PXI_Trig3 = 11 , JY5211CoreOO::PXI_Trig4 = 12 , JY5211CoreOO::PXI_Trig5 = 13 , JY5211CoreOO::PXI_Trig6 = 14 ,
JY5211CoreOO::PXI_Trig7 = 15
}
enum class JY5211CoreOO::SignalExportDestination {
JY5211CoreOO::PFI0 , JY5211CoreOO::PFI1 , JY5211CoreOO::PFI2 , JY5211CoreOO::PFI3 ,
JY5211CoreOO::PFI4 , JY5211CoreOO::PFI5 , JY5211CoreOO::PFI6 , JY5211CoreOO::PFI7 ,
JY5211CoreOO::PXI_Trig0 = 8 , JY5211CoreOO::PXI_Trig1 = 9 , JY5211CoreOO::PXI_Trig2 = 10 , JY5211CoreOO::PXI_Trig3 = 11 ,
JY5211CoreOO::PXI_Trig4 = 12 , JY5211CoreOO::PXI_Trig5 = 13 , JY5211CoreOO::PXI_Trig6 = 14 , JY5211CoreOO::PXI_Trig7 = 15
}
enum class | JY5211CoreOO::OutputCompleteState { JY5211CoreOO::Zero , JY5211CoreOO::Hold }
Output Complete State. More...
enum class | JY5211CoreOO::LevelPolarity { JY5211CoreOO::LowLevel = 0 , JY5211CoreOO::HighLevel = 1 , JY5211CoreOO::None = 2 }
Level Polarity. More...
enum class | JY5211CoreOO::OutputState { JY5211CoreOO::HoldOn = 0 , JY5211CoreOO::HighLevel = 1 , JY5211CoreOO::LowLevel = 2 }
enum class JY5211CoreOO::IOTerminal {
JY5211CoreOO::PFI0 = 0x0 , JY5211CoreOO::PFI1 = 0x1 , JY5211CoreOO::PFI2 = 0x2 , JY5211CoreOO::PFI3 = 0x3 ,
JY5211CoreOO::PFI4 = 0x4 , JY5211CoreOO::PFI5 = 0x5 , JY5211CoreOO::PFI6 = 0x6 , JY5211CoreOO::PFI7 = 0x7 ,
JY5211CoreOO::PFI8 = 0x8 , JY5211CoreOO::PFI9 = 0x9 , JY5211CoreOO::PFI10 = 0xA , JY5211CoreOO::PFI11 = 0xB ,
JY5211CoreOO::PFI12 = 0xC , JY5211CoreOO::PFI13 = 0xD , JY5211CoreOO::PFI14 = 0xE , JY5211CoreOO::PFI15 = 0xF ,
JY5211CoreOO::PFI16 = 0x10 , JY5211CoreOO::PFI17 = 0x11 , JY5211CoreOO::PFI18 = 0x12 , JY5211CoreOO::PFI19 = 0x13 ,
JY5211CoreOO::PFI20 = 0x14 , JY5211CoreOO::PFI21 = 0x15 , JY5211CoreOO::PFI22 = 0x16 , JY5211CoreOO::PFI23 = 0x17 ,
JY5211CoreOO::PFI24 = 0x18 , JY5211CoreOO::PFI25 = 0x19 , JY5211CoreOO::PFI26 = 0x1A , JY5211CoreOO::PFI27 = 0x1B ,
JY5211CoreOO::PFI28 = 0x1C , JY5211CoreOO::PFI29 = 0x1D , JY5211CoreOO::PFI30 = 0x1E , JY5211CoreOO::PFI31 = 0x1F ,
JY5211CoreOO::PFI32 = 0x20 , JY5211CoreOO::PFI33 = 0x21 , JY5211CoreOO::PFI34 = 0x22 , JY5211CoreOO::PFI35 = 0x23 ,
JY5211CoreOO::PFI36 = 0x24 , JY5211CoreOO::PFI37 = 0x25 , JY5211CoreOO::PFI38 = 0x26 , JY5211CoreOO::PFI39 = 0x27 ,
JY5211CoreOO::PXI_Trig0 = 0x28 , JY5211CoreOO::PXI_Trig1 = 0x29 , JY5211CoreOO::PXI_Trig2 = 0x2A , JY5211CoreOO::PXI_Trig3 = 0x2B ,
JY5211CoreOO::PXI_Trig4 = 0x2C , JY5211CoreOO::PXI_Trig5 = 0x2D , JY5211CoreOO::PXI_Trig6 = 0x2E , JY5211CoreOO::PXI_Trig7 = 0x2F ,
JY5211CoreOO::PXI_Star = 0x30
}
enum class JY5211CoreOO::InputTerminal {
JY5211CoreOO::PFI0 = 0x0 , JY5211CoreOO::PFI1 = 0x1 , JY5211CoreOO::PFI2 = 0x2 , JY5211CoreOO::PFI3 = 0x3 ,
JY5211CoreOO::PFI4 = 0x4 , JY5211CoreOO::PFI5 = 0x5 , JY5211CoreOO::PFI6 = 0x6 , JY5211CoreOO::PFI7 = 0x7 ,
JY5211CoreOO::PFI8 = 0x8 , JY5211CoreOO::PFI9 = 0x9 , JY5211CoreOO::PFI10 = 0xA , JY5211CoreOO::PFI11 = 0xB ,
JY5211CoreOO::PFI12 = 0xC , JY5211CoreOO::PFI13 = 0xD , JY5211CoreOO::PFI14 = 0xE , JY5211CoreOO::PFI15 = 0xF ,
JY5211CoreOO::PFI16 = 0x10 , JY5211CoreOO::PFI17 = 0x11 , JY5211CoreOO::PFI18 = 0x12 , JY5211CoreOO::PFI19 = 0x13 ,
JY5211CoreOO::PFI20 = 0x14 , JY5211CoreOO::PFI21 = 0x15 , JY5211CoreOO::PFI22 = 0x16 , JY5211CoreOO::PFI23 = 0x17 ,
JY5211CoreOO::PFI24 = 0x18 , JY5211CoreOO::PFI25 = 0x19 , JY5211CoreOO::PFI26 = 0x1A , JY5211CoreOO::PFI27 = 0x1B ,
JY5211CoreOO::PFI28 = 0x1C , JY5211CoreOO::PFI29 = 0x1D , JY5211CoreOO::PFI30 = 0x1E , JY5211CoreOO::PFI31 = 0x1F ,
JY5211CoreOO::PFI32 = 0x20 , JY5211CoreOO::PFI33 = 0x21 , JY5211CoreOO::PFI34 = 0x22 , JY5211CoreOO::PFI35 = 0x23 ,
JY5211CoreOO::PFI36 = 0x24 , JY5211CoreOO::PFI37 = 0x25 , JY5211CoreOO::PFI38 = 0x26 , JY5211CoreOO::PFI39 = 0x27 ,
JY5211CoreOO::PXI_Trig0 = 0x28 , JY5211CoreOO::PXI_Trig1 = 0x29 , JY5211CoreOO::PXI_Trig2 = 0x2A , JY5211CoreOO::PXI_Trig3 = 0x2B ,
JY5211CoreOO::PXI_Trig4 = 0x2C , JY5211CoreOO::PXI_Trig5 = 0x2D , JY5211CoreOO::PXI_Trig6 = 0x2E , JY5211CoreOO::PXI_Trig7 = 0x2F ,
JY5211CoreOO::PXI_Star = 0x30 , JY5211CoreOO::Internal_50M = 0x31 , JY5211CoreOO::Internal_5M = 0x32 , JY5211CoreOO::Internal_100K = 0x33 ,
JY5211CoreOO::Internal_CO_0_Out = 0x34 , JY5211CoreOO::Internal_CO_1_Out = 0x35 , JY5211CoreOO::Internal_CO_2_Out = 0x36 , JY5211CoreOO::Internal_CO_3_Out = 0x37 ,
JY5211CoreOO::Internal_CO_4_Out = 0x38 , JY5211CoreOO::Internal_CO_5_Out = 0x39 , JY5211CoreOO::Internal_CO_6_Out = 0x3A , JY5211CoreOO::Internal_CO_7_Out = 0x3B
}
Cunter Input Terminal. More...

Functions

std::string JY5211CoreOO::GetSignalExportDestinationString (SignalExportDestination destination)

Macro Definition Documentation

◆ EXTERN_C

#define EXTERN_C extern

Windows.

Linux

◆ JY5211CoreOO_API

#define JY5211CoreOO_API


5211 C++ Programming Manual: JY5211CoreOO::JYDriverException Class Reference

  • JYDriverException
Public Member Functions | Public Attributes | List of all members
JY5211CoreOO::JYDriverException Class Reference

#include <JY5211CoreOOCommon.h>

Public Member Functions

JYDriverException (JYDriverExceptionPublic exceptionCode, std::string msg="")
JYDriverException (JYErrorCode exceptionCode, std::string msg="")
JYDriverException (int, std::string msg)

Public Attributes

std::string exceptionMessage
JYDriverExceptionPublic errorCode
JYDriverException * FollowingException

Constructor & Destructor Documentation

◆ JYDriverException() [1/3]

JY5211CoreOO::JYDriverException::JYDriverException | ( | JYDriverExceptionPublic | exceptionCode,
 |  | std::string | msg = "" )

◆ JYDriverException() [2/3]

JY5211CoreOO::JYDriverException::JYDriverException | ( | JYErrorCode | exceptionCode,
 |  | std::string | msg = "" )

◆ JYDriverException() [3/3]

JY5211CoreOO::JYDriverException::JYDriverException | ( | int | ,
 |  | std::string | msg )

Member Data Documentation

◆ errorCode

JYDriverExceptionPublic JY5211CoreOO::JYDriverException::errorCode

◆ exceptionMessage

std::string JY5211CoreOO::JYDriverException::exceptionMessage

◆ FollowingException

JYDriverException* JY5211CoreOO::JYDriverException::FollowingException
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOOCommon.h


5211 C++ Programming Manual: JY5211CoreOO::JY5211CoreOOProperty< ContainerClass, ValueType, propertyType > Class Template Reference

  • JY5211CoreOOProperty
Public Member Functions | List of all members
JY5211CoreOO::JY5211CoreOOProperty< ContainerClass, ValueType, propertyType > Class Template Reference

属性模板类 More...

#include <JY5211CoreOOCommon.h>

Public Member Functions

JY5211CoreOOProperty ()
JY5211CoreOOProperty (ContainerClass *cObject, ValueType(ContainerClass::*pGet)(), void(ContainerClass::*pSet)(ValueType value))
JY5211CoreOOProperty (ValueType(*pGet)(), void(*pSet)(ValueType value))
ValueType operator= (const ValueType &value)
operator ValueType ()

Detailed Description

template<typename ContainerClass, typename ValueType, JY5211CoreOOPropertyType propertyType>
class JY5211CoreOO::JY5211CoreOOProperty< ContainerClass, ValueType, propertyType >

属性模板类

Constructor & Destructor Documentation

◆ JY5211CoreOOProperty() [1/3]

template<typename ContainerClass, typename ValueType, JY5211CoreOOPropertyType propertyType>
JY5211CoreOO::JY5211CoreOOProperty< ContainerClass, ValueType, propertyType >::JY5211CoreOOProperty ( )

◆ JY5211CoreOOProperty() [2/3]

template<typename ContainerClass, typename ValueType, JY5211CoreOOPropertyType propertyType>
JY5211CoreOO::JY5211CoreOOProperty< ContainerClass, ValueType, propertyType >::JY5211CoreOOProperty | ( | ContainerClass * | cObject,
 |  | ValueType(ContainerClass::* | pGet )(),
 |  | void(ContainerClass::* | pSet )(ValueType value) )

◆ JY5211CoreOOProperty() [3/3]

template<typename ContainerClass, typename ValueType, JY5211CoreOOPropertyType propertyType>
JY5211CoreOO::JY5211CoreOOProperty< ContainerClass, ValueType, propertyType >::JY5211CoreOOProperty | ( | ValueType(* | pGet )(),
 |  | void(* | pSet )(ValueType value) )

Member Function Documentation

◆ operator ValueType()

template<typename ContainerClass, typename ValueType, JY5211CoreOOPropertyType propertyType>
JY5211CoreOO::JY5211CoreOOProperty< ContainerClass, ValueType, propertyType >::operator ValueType ( )

◆ operator=()

template<typename ContainerClass, typename ValueType, JY5211CoreOOPropertyType propertyType>
ValueType JY5211CoreOO::JY5211CoreOOProperty< ContainerClass, ValueType, propertyType >::operator= ( const ValueType & value )
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOOCommon.h


5211 C++ Programming Manual: JY5211CoreOO::PauseTrigger Class Reference

  • PauseTrigger
Public Attributes | List of all members
JY5211CoreOO::PauseTrigger Class Reference

Pause trigger configuration class. More...

#include <JY5211CoreOOCommon.h>

Public Attributes

LevelPolarity ActivePolarity
Pause trigger active polarity.
InputTerminal Terminal
Terminal.
OutputState Output_State

Detailed Description

Pause trigger configuration class.

Member Data Documentation

◆ ActivePolarity

LevelPolarity JY5211CoreOO::PauseTrigger::ActivePolarity

Pause trigger active polarity.

The default value is LevelPolarity.None, means the pause trigger is disabled.

◆ Output_State

OutputState JY5211CoreOO::PauseTrigger::Output_State

◆ Terminal

InputTerminal JY5211CoreOO::PauseTrigger::Terminal

Terminal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOOCommon.h


5211 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOOCOTask.h File Reference

  • File List
  • File Members
  • COO
  • 5211
Classes | Namespaces | Enumerations
JY5211CoreOOCOTask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JY5211CoreOOCommon.h"
#include "JY5211CoreOODevice.h"

Classes

class | JY5211CoreOO::JY5211CoreOOCOTask
class | JY5211CoreOO::CODigitalTrigger
CO Digital trigger . More...
class | JY5211CoreOO::COTrigger
Constructor to create an COTrigger task object. More...
class | JY5211CoreOO::COPulse
Pulse Parameter. More...
class | JY5211CoreOO::COExternalTimebase
class | JY5211CoreOO::COTimebase
Timebase configuration class. More...
class | JY5211CoreOO::COSignalExport
CO Signal Export Class. More...

Namespaces

namespace JY5211CoreOO

Enumerations

enum class | JY5211CoreOO::COIdleState { JY5211CoreOO::HighLevel = 0x1 , JY5211CoreOO::LowLevel = 0x0 }
Idle state when pulse output before start and after stop. More...
enum class | JY5211CoreOO::COMode { JY5211CoreOO::Single = 0 , JY5211CoreOO::Finite = 1 , JY5211CoreOO::ContinuousNoWrapping = 2 , JY5211CoreOO::ContinuousWrapping = 3 }
enum class | JY5211CoreOO::COTriggerType { JY5211CoreOO::Immediate = 0x0 , JY5211CoreOO::Digital = 0x1 , JY5211CoreOO::Soft = 0x3 }
TriggerType Digital/Immediate/Soft. More...
enum class JY5211CoreOO::CODigitalTriggerSource {
JY5211CoreOO::PFI0 , JY5211CoreOO::PFI1 , JY5211CoreOO::PFI2 , JY5211CoreOO::PFI3 ,
JY5211CoreOO::PFI4 , JY5211CoreOO::PFI5 , JY5211CoreOO::PFI6 , JY5211CoreOO::PFI7 ,
JY5211CoreOO::PFI8 , JY5211CoreOO::PFI9 , JY5211CoreOO::PFI10 , JY5211CoreOO::PFI11 ,
JY5211CoreOO::PFI12 , JY5211CoreOO::PFI13 , JY5211CoreOO::PFI14 , JY5211CoreOO::PFI15 ,
JY5211CoreOO::PFI16 , JY5211CoreOO::PFI17 , JY5211CoreOO::PFI18 , JY5211CoreOO::PFI19 ,
JY5211CoreOO::PFI20 , JY5211CoreOO::PFI21 , JY5211CoreOO::PFI22 , JY5211CoreOO::PFI23 ,
JY5211CoreOO::PFI24 , JY5211CoreOO::PFI25 , JY5211CoreOO::PFI26 , JY5211CoreOO::PFI27 ,
JY5211CoreOO::PFI28 , JY5211CoreOO::PFI29 , JY5211CoreOO::PFI130 , JY5211CoreOO::PFI131 ,
JY5211CoreOO::PFI132 , JY5211CoreOO::PFI133 , JY5211CoreOO::PFI134 , JY5211CoreOO::PFI135 ,
JY5211CoreOO::PFI136 , JY5211CoreOO::PFI137 , JY5211CoreOO::PFI138 , JY5211CoreOO::PFI139
}
CO Digital trigger source. More...
enum class | JY5211CoreOO::CODigitalTriggerEdge { JY5211CoreOO::Rising , JY5211CoreOO::Falling }
CO Digital Trigger Edge. More...
enum class | JY5211CoreOO::COPulseType { JY5211CoreOO::DutyCycleFrequency , JY5211CoreOO::HighLowTime , JY5211CoreOO::HighLowTick }
Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick. More...
enum class | JY5211CoreOO::COTimebaseSource { JY5211CoreOO::Internal100MHz = 0 , JY5211CoreOO::Internal5MHz = 1 , JY5211CoreOO::Internal100kHz = 2 , JY5211CoreOO::External = 3 }
Timebase source. More...
enum class JY5211CoreOO::COSignalExportSource {
JY5211CoreOO::StartTrig , JY5211CoreOO::Output , JY5211CoreOO::Internal_Counter_100K = 34 , JY5211CoreOO::Internal_Counter_5M = 33 ,
JY5211CoreOO::Internal_Counter_100M = 32
}
SourceSignal. More...


5211 C++ Programming Manual: JY5211CoreOO::JY5211CoreOOCOTask Class Reference

  • JY5211CoreOOCOTask
Public Member Functions | Public Attributes | List of all members
JY5211CoreOO::JY5211CoreOOCOTask Class Reference

#include <JY5211CoreOOCOTask.h>

Public Member Functions

JY5211CoreOOCOTask (int slotNum, int channel)
JY5211CoreOOCOTask (std::string boardName, int channel)
~JY5211CoreOOCOTask ()
void | WriteSinglePoint (COPulse &pulse)
Write a single pulse parameter to the register.
void | WriteData (COPulse *pulsesGroup[], int samplesToWrite, int timeout=10000)
Write pulse parameters to be output to the buffer.
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Start ()
Start CO task .
void | Stop ()
Stop COtask .
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.

Public Attributes

COMode Mode
CO output mode.
IOTerminal OutputTerminal
PauseTrigger * Pause
COTimebase * TimeBase
CO's time base.
double | InitialDelay
Counter output initial delay in seconds.
int | plcount
int | _samplesToWrite
Mode不为COMode.Single时生效的待写入Sample长度，用于暂时缓存用户在调用 JY5211COTask.Start 前使用 JY5211COTask.WriteData(COPulse[], int, int) 写入的参数
int | _samplesToUpdate
COIdleState IdleState
Idle state when pulse output before start and after stop.
uint32_t | SamplesToUpdate
有限频率输出
JY5211CoreOOProperty< JY5211CoreOOCOTask, int, JY5211CoreOOPropertyType::READ_ONLY > | BufLenInSamples
Number of samples per channel can be storage in the buffer, the Property SamplesToAcquire must be less than or equal to this value.
JY5211CoreOOProperty< JY5211CoreOOCOTask, uint32_t, JY5211CoreOOPropertyType::READ_ONLY > | AvaliableLenInSamples
Number of points per channel that can be read in the buffer .
JY5211CoreOOProperty< JY5211CoreOOCOTask, uint64_t, JY5211CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
JY5211CoreOOProperty< JY5211CoreOOCOTask, uint32_t, JY5211CoreOOPropertyType::READ_ONLY > | TransferedPulses
COTrigger * Trigger
CO trigger property configured by CO Trigger().
JY5211CoreOODevice * Device
Device.
COSignalExport * SignalExport
Export CO Signal Configuration.

Constructor & Destructor Documentation

◆ JY5211CoreOOCOTask() [1/2]

JY5211CoreOO::JY5211CoreOOCOTask::JY5211CoreOOCOTask | ( | int | slotNum,
 |  | int | channel )

◆ JY5211CoreOOCOTask() [2/2]

JY5211CoreOO::JY5211CoreOOCOTask::JY5211CoreOOCOTask | ( | std::string | boardName,
 |  | int | channel )

◆ ~JY5211CoreOOCOTask()

JY5211CoreOO::JY5211CoreOOCOTask::~JY5211CoreOOCOTask ( )

Member Function Documentation

◆ SendSoftwareTrigger()

void JY5211CoreOO::JY5211CoreOOCOTask::SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5211CoreOO::JY5211CoreOOCOTask::Start ( )

Start CO task .

◆ Stop()

void JY5211CoreOO::JY5211CoreOOCOTask::Stop ( )

Stop COtask .

◆ WaitUntilDone()

bool JY5211CoreOO::JY5211CoreOOCOTask::WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteData()

void JY5211CoreOO::JY5211CoreOOCOTask::WriteData | ( | COPulse * | pulsesGroup[],
 |  | int | samplesToWrite,
 |  | int | timeout = 10000 )

Write pulse parameters to be output to the buffer.

Valid when Mode is NOT COMode.Single. When Mode is COMode.Finite or COMode.ContinuousWrapping, this function can only be called once before starting the task.

Parameters
pulsesGroup | A group of pulse parameters
samplesToWrite | Number of samples to write. If Mode is COMode.ContinuousWrapping, you need to write at least 2 samples before starting the task
timeout | Timeout (ms). Wait until all data is written to buffer or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ WriteSinglePoint()

void JY5211CoreOO::JY5211CoreOOCOTask::WriteSinglePoint ( COPulse & pulse )

Write a single pulse parameter to the register.

Valid when Mode is COMode.Single. This function is also available after starting the task when the number of pulses being sent is infinite.

Parameters
pulse Pulse Parameter

Member Data Documentation

◆ _samplesToUpdate

int JY5211CoreOO::JY5211CoreOOCOTask::_samplesToUpdate

◆ _samplesToWrite

int JY5211CoreOO::JY5211CoreOOCOTask::_samplesToWrite

Mode不为COMode.Single时生效的待写入Sample长度，用于暂时缓存用户在调用 JY5211COTask.Start 前使用 JY5211COTask.WriteData(COPulse[], int, int) 写入的参数

◆ AvaliableLenInSamples

JY5211CoreOOProperty<JY5211CoreOOCOTask, uint32_t, JY5211CoreOOPropertyType::READ_ONLY> JY5211CoreOO::JY5211CoreOOCOTask::AvaliableLenInSamples

Number of points per channel that can be read in the buffer .

◆ BufLenInSamples

JY5211CoreOOProperty<JY5211CoreOOCOTask, int, JY5211CoreOOPropertyType::READ_ONLY> JY5211CoreOO::JY5211CoreOOCOTask::BufLenInSamples

Number of samples per channel can be storage in the buffer, the Property SamplesToAcquire must be less than or equal to this value.

◆ Device

JY5211CoreOODevice* JY5211CoreOO::JY5211CoreOOCOTask::Device

Device.

◆ IdleState

COIdleState JY5211CoreOO::JY5211CoreOOCOTask::IdleState

Idle state when pulse output before start and after stop.

◆ InitialDelay

double JY5211CoreOO::JY5211CoreOOCOTask::InitialDelay

Counter output initial delay in seconds.

There are five ticks of the timebase fixed delay in counter internal, so the total delay(s) = InitialDelay + (5 / timebase)

◆ Mode

COMode JY5211CoreOO::JY5211CoreOOCOTask::Mode

CO output mode.

◆ OutputTerminal

IOTerminal JY5211CoreOO::JY5211CoreOOCOTask::OutputTerminal

脉冲输出端口

Pulse Output Terminal

◆ Pause

PauseTrigger* JY5211CoreOO::JY5211CoreOOCOTask::Pause

暂停触发配置

Pause Trigger Configuration

◆ plcount

int JY5211CoreOO::JY5211CoreOOCOTask::plcount

◆ SamplesToUpdate

uint32_t JY5211CoreOO::JY5211CoreOOCOTask::SamplesToUpdate

有限频率输出

◆ SignalExport

COSignalExport* JY5211CoreOO::JY5211CoreOOCOTask::SignalExport

Export CO Signal Configuration.

◆ TimeBase

COTimebase* JY5211CoreOO::JY5211CoreOOCOTask::TimeBase

CO's time base.

◆ TransferedPulses

JY5211CoreOOProperty<JY5211CoreOOCOTask, uint32_t, JY5211CoreOOPropertyType::READ_ONLY> JY5211CoreOO::JY5211CoreOOCOTask::TransferedPulses

当前配置下已发送的脉冲的数量。

The number of pulses transfered under the current configuration.

◆ TransferedSamples

JY5211CoreOOProperty<JY5211CoreOOCOTask, uint64_t, JY5211CoreOOPropertyType::READ_ONLY> JY5211CoreOO::JY5211CoreOOCOTask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT CIMode.Single.

◆ Trigger

COTrigger* JY5211CoreOO::JY5211CoreOOCOTask::Trigger

CO trigger property configured by CO Trigger().

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOOCOTask.h


5211 C++ Programming Manual: JY5211CoreOO::CODigitalTrigger Class Reference

  • CODigitalTrigger
Public Attributes | List of all members
JY5211CoreOO::CODigitalTrigger Class Reference

CO Digital trigger . More...

#include <JY5211CoreOOCOTask.h>

Public Attributes

CODigitalTriggerSource Source
CO Digital Trigger source.
CODigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Detailed Description

CO Digital trigger .

Member Data Documentation

◆ Edge

CODigitalTriggerEdge JY5211CoreOO::CODigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

CODigitalTriggerSource JY5211CoreOO::CODigitalTrigger::Source

CO Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOOCOTask.h


5211 C++ Programming Manual: JY5211CoreOO::COTrigger Class Reference

  • COTrigger
Public Attributes | List of all members
JY5211CoreOO::COTrigger Class Reference

Constructor to create an COTrigger task object. More...

#include <JY5211CoreOOCOTask.h>

Public Attributes

COTriggerType Type
CO trigger type.
CODigitalTrigger * Digital
CO Digital Trigger.

Detailed Description

Constructor to create an COTrigger task object.

Used to build CO Trigger

Member Data Documentation

◆ Digital

CODigitalTrigger* JY5211CoreOO::COTrigger::Digital

CO Digital Trigger.

Valid when Type is COTriggerType.Digital

◆ Type

COTriggerType JY5211CoreOO::COTrigger::Type

CO trigger type.

enum Immediate/Digital/Soft.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOOCOTask.h


5211 C++ Programming Manual: JY5211CoreOO::COPulse Class Reference

  • COPulse
Public Member Functions | List of all members
JY5211CoreOO::COPulse Class Reference

Pulse Parameter. More...

#include <JY5211CoreOOCOTask.h>

Public Member Functions

COPulse (COPulseType type, double param1, double param2, int count)
Pulse Parameter.

Detailed Description

Pulse Parameter.

Constructor & Destructor Documentation

◆ COPulse()

JY5211CoreOO::COPulse::COPulse | ( | COPulseType | type,
 |  | double | param1,
 |  | double | param2,
 |  | int | count )

Pulse Parameter.

Parameters
type | The pulse type characteristics.
param1 | Parameter 1. Frequency (Hz) when constructed as COPulseType.DutyCycleFrequency; High duration in seconds when constructed as COPulseType.HighLowTime; High ticks of the clock when constructed as COPulseType.HighLowTick.
param2 | Parameter 1. Duty cycle (greater than 0 and less than 1) when constructed as COPulseType.DutyCycleFrequency; Low duration in seconds when constructed as COPulseType.HighLowTime; Low ticks of the clock when constructed as COPulseType.HighLowTick.
count | Number of pulses. When the value is -1 (indicating that the number of pulses is infinite), pulses will be continuously sent until requested to stop.
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOOCOTask.h


5211 C++ Programming Manual: JY5211CoreOO::COExternalTimebase Class Reference

  • COExternalTimebase
Public Attributes | List of all members
JY5211CoreOO::COExternalTimebase Class Reference

#include <JY5211CoreOOCOTask.h>

Public Attributes

InputTerminal Terminal
double Frequency

Detailed Description

外部时基配置类

External timebase configuration class

Member Data Documentation

◆ Frequency

double JY5211CoreOO::COExternalTimebase::Frequency

外部时基的频率

Frequency of The External Timebase

◆ Terminal

InputTerminal JY5211CoreOO::COExternalTimebase::Terminal

外部时基的输入端口

External Timebase Input Terminal

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOOCOTask.h


5211 C++ Programming Manual: JY5211CoreOO::COTimebase Class Reference

  • COTimebase
Public Attributes | List of all members
JY5211CoreOO::COTimebase Class Reference

Timebase configuration class. More...

#include <JY5211CoreOOCOTask.h>

Public Attributes

COTimebaseSource Source
Timebase Source.
COExternalTimebase * External
Timebase External.
JY5211CoreOOProperty< COTimebase, double, JY5211CoreOOPropertyType::READ_ONLY > ActualFreq
The number of samples that have been transfered from the local buffer (per channel).

Detailed Description

Timebase configuration class.

Member Data Documentation

◆ ActualFreq

JY5211CoreOOProperty<COTimebase, double, JY5211CoreOOPropertyType::READ_ONLY> JY5211CoreOO::COTimebase::ActualFreq

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT COMode.Single.

◆ External

COExternalTimebase* JY5211CoreOO::COTimebase::External

Timebase External.

◆ Source

COTimebaseSource JY5211CoreOO::COTimebase::Source

Timebase Source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOOCOTask.h


5211 C++ Programming Manual: JY5211CoreOO::COSignalExport Class Reference

  • COSignalExport
Public Member Functions | List of all members
JY5211CoreOO::COSignalExport Class Reference

CO Signal Export Class. More...

#include <JY5211CoreOOCOTask.h>

Public Member Functions

void | Add (COSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (COSignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

CO Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY5211CoreOO::COSignalExport::Add | ( | COSignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | CI Signal Source
destination | Export Desination

◆ Add() [2/2]

void JY5211CoreOO::COSignalExport::Add | ( | COSignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | CI Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JY5211CoreOO::COSignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5211CoreOO::COSignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOOCOTask.h


5211 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOODevice.h File Reference

  • File List
  • File Members
  • COO
  • 5211
Classes | Namespaces | Enumerations
JY5211CoreOODevice.h File Reference
#include <iostream>
#include <string>
#include <list>
#include <vector>
#include "JY5211CoreOOCommon.h"

Classes

class | JY5211CoreOO::JY5211CoreOODevice
class | JY5211CoreOO::PFIFilter
class | JY5211CoreOO::PFISetting
class | JY5211CoreOO::ExternalReferenceClock
class | JY5211CoreOO::JY5211CoreOOReferenceClock

Namespaces

namespace JY5211CoreOO

Enumerations

enum class | JY5211CoreOO::ReferenceClockSource { JY5211CoreOO::Internal = 0x0 , JY5211CoreOO::External = 0x1 }
enum class | JY5211CoreOO::ExternalReferenceClockTerminal { JY5211CoreOO::PXIe_Clk100 = 0 , JY5211CoreOO::PXIe_DStarA = 1 }
enum class JY5211CoreOO::PFITerminal {
JY5211CoreOO::PFI0 = 0 , JY5211CoreOO::PFI1 = 1 , JY5211CoreOO::PFI2 = 2 , JY5211CoreOO::PFI3 = 3 ,
JY5211CoreOO::PFI4 = 4 , JY5211CoreOO::PFI5 = 5 , JY5211CoreOO::PFI6 = 6 , JY5211CoreOO::PFI7 = 7 ,
JY5211CoreOO::PFI8 = 8 , JY5211CoreOO::PFI9 = 9 , JY5211CoreOO::PFI10 = 10 , JY5211CoreOO::PFI11 = 11 ,
JY5211CoreOO::PFI12 = 12 , JY5211CoreOO::PFI13 = 13 , JY5211CoreOO::PFI14 = 14 , JY5211CoreOO::PFI15 = 15
}
Input/Output Terminal of PFI. More...


5211 C++ Programming Manual: JY5211CoreOO::JY5211CoreOODevice Class Reference

  • JY5211CoreOODevice
Public Types | Static Public Member Functions | Public Attributes | List of all members
JY5211CoreOO::JY5211CoreOODevice Class Reference

#include <JY5211CoreOODevice.h>

Public Types

enum class CounterInterface { Source , Gate , Aux , Out }

Static Public Member Functions

static unsigned | GetDefautTerminal (CounterInterface counterInterface, unsigned channelID)
static JY5211CoreOODevice * | GetInstance (int cardNum)
static JY5211CoreOODevice * | GetInstance (std::string aliasName)

Public Attributes

const int | DIOLineCount = 40
JY5211CoreOOProperty< JY5211CoreOODevice, std::string, JY5211CoreOOPropertyType::READ_ONLY > | SerialNumber
JY5211CoreOOProperty< JY5211CoreOODevice, int, JY5211CoreOOPropertyType::READ_ONLY > | DeviceID
JY5211CoreOOProperty< JY5211CoreOODevice, void *, JY5211CoreOOPropertyType::READ_ONLY > | Handle
PFISetting * PFI
JY5211CoreOOReferenceClock * ReferenceClock

Member Enumeration Documentation

◆ CounterInterface

enum class JY5211CoreOO::JY5211CoreOODevice::CounterInterface
strong
Enumerator
Source
Gate
Aux
Out

Member Function Documentation

◆ GetDefautTerminal()

static unsigned JY5211CoreOO::JY5211CoreOODevice::GetDefautTerminal | ( | CounterInterface | counterInterface,
 |  | unsigned | channelID )
 static

◆ GetInstance() [1/2]

static JY5211CoreOODevice * JY5211CoreOO::JY5211CoreOODevice::GetInstance ( int cardNum )
static

◆ GetInstance() [2/2]

static JY5211CoreOODevice * JY5211CoreOO::JY5211CoreOODevice::GetInstance ( std::string aliasName )
static

Member Data Documentation

◆ DeviceID

JY5211CoreOOProperty<JY5211CoreOODevice, int, JY5211CoreOOPropertyType::READ_ONLY> JY5211CoreOO::JY5211CoreOODevice::DeviceID

◆ DIOLineCount

const int JY5211CoreOO::JY5211CoreOODevice::DIOLineCount = 40

◆ Handle

JY5211CoreOOProperty<JY5211CoreOODevice, void*, JY5211CoreOOPropertyType::READ_ONLY> JY5211CoreOO::JY5211CoreOODevice::Handle

◆ PFI

PFISetting* JY5211CoreOO::JY5211CoreOODevice::PFI

◆ ReferenceClock

JY5211CoreOOReferenceClock* JY5211CoreOO::JY5211CoreOODevice::ReferenceClock

◆ SerialNumber

JY5211CoreOOProperty<JY5211CoreOODevice, std::string, JY5211CoreOOPropertyType::READ_ONLY> JY5211CoreOO::JY5211CoreOODevice::SerialNumber
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOODevice.h


5211 C++ Programming Manual: JY5211CoreOO::PFIFilter Class Reference

  • PFIFilter
Public Member Functions | List of all members
JY5211CoreOO::PFIFilter Class Reference

#include <JY5211CoreOODevice.h>

Public Member Functions

void | Enable (PFITerminal terminal, int minPulseWidth)
Enable the filter on the specified terminal and set the minimum pulse width.
void | Enable (std::vector< PFITerminal > terminals, int minPulseWidth)
Enable the filter on a group of terminals and set the minimum pulse width.
void | Enable (std::vector< PFITerminal > terminals, std::vector< int > minPulseWidth)
Enable the filter on a group of terminals and set the minimum pulse width separately.
void | Disable (PFITerminal terminal)
Disable the filter on the specified terminal.
void | Disable (std::vector< PFITerminal > terminals)
Disable the filter on a group terminal.
void | DisableAll ()
Disable the filter on all the terminals.

Member Function Documentation

◆ Disable() [1/2]

void JY5211CoreOO::PFIFilter::Disable ( PFITerminal terminal )

Disable the filter on the specified terminal.

Parameters
terminal Specified Terminal

◆ Disable() [2/2]

void JY5211CoreOO::PFIFilter::Disable ( std::vector< PFITerminal > terminals )

Disable the filter on a group terminal.

Parameters
terminals Specified Group of Terminal

◆ DisableAll()

void JY5211CoreOO::PFIFilter::DisableAll ( )

Disable the filter on all the terminals.

◆ Enable() [1/3]

void JY5211CoreOO::PFIFilter::Enable | ( | PFITerminal | terminal,
 |  | int | minPulseWidth )

Enable the filter on the specified terminal and set the minimum pulse width.

Parameters
terminal | Specified Terminal
minPulseWidth | Minimum pulse width in ns, bounce less than this length will be ignored. The smallest step in the range of 10 ns to 2550 ns is 10 ns, the smallest step in the range of 2550 ns to 40800 ns is 160 ns, and the smallest step in the range of 40800 ns to 652800 ns The step is 2560 ns

◆ Enable() [2/3]

void JY5211CoreOO::PFIFilter::Enable | ( | std::vector< PFITerminal > | terminals,
 |  | int | minPulseWidth )

Enable the filter on a group of terminals and set the minimum pulse width.

Parameters
terminals | Specified Group of Terminals
minPulseWidth | Minimum pulse width in ns, bounce less than this length will be ignored. The smallest step in the range of 10 ns to 2550 ns is 10 ns, the smallest step in the range of 2550 ns to 40800 ns is 160 ns, and the smallest step in the range of 40800 ns to 652800 ns The step is 2560 ns

◆ Enable() [3/3]

void JY5211CoreOO::PFIFilter::Enable | ( | std::vector< PFITerminal > | terminals,
 |  | std::vector< int > | minPulseWidth )

Enable the filter on a group of terminals and set the minimum pulse width separately.

Parameters
terminals | Specified Group of Terminals
minPulseWidth | Minimum pulse width in ns, bounce less than this length will be ignored. The smallest step in the range of 10 ns to 2550 ns is 10 ns, the smallest step in the range of 2550 ns to 40800 ns is 160 ns, and the smallest step in the range of 40800 ns to 652800 ns The step is 2560 ns
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOODevice.h


5211 C++ Programming Manual: JY5211CoreOO::PFISetting Class Reference

  • PFISetting
Public Attributes | List of all members
JY5211CoreOO::PFISetting Class Reference

#include <JY5211CoreOODevice.h>

Public Attributes

PFIFilter * Filter
PFI Filter Setting.

Member Data Documentation

◆ Filter

PFIFilter* JY5211CoreOO::PFISetting::Filter

PFI Filter Setting.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOODevice.h


5211 C++ Programming Manual: JY5211CoreOO::ExternalReferenceClock Class Reference

  • ExternalReferenceClock
Public Attributes | List of all members
JY5211CoreOO::ExternalReferenceClock Class Reference

#include <JY5211CoreOODevice.h>

Public Attributes

ExternalReferenceClockTerminal Terminal
int Frequency

Member Data Documentation

◆ Frequency

int JY5211CoreOO::ExternalReferenceClock::Frequency

◆ Terminal

ExternalReferenceClockTerminal JY5211CoreOO::ExternalReferenceClock::Terminal
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOODevice.h


5211 C++ Programming Manual: JY5211CoreOO::JY5211CoreOOReferenceClock Class Reference

  • JY5211CoreOOReferenceClock
Public Member Functions | Public Attributes | List of all members
JY5211CoreOO::JY5211CoreOOReferenceClock Class Reference

#include <JY5211CoreOODevice.h>

Public Member Functions

void Commit ()
Commit configuration.

Public Attributes

ReferenceClockSource Source
ExternalReferenceClock * External
External Reference Clock Source.
bool Locked = false

Member Function Documentation

◆ Commit()

void JY5211CoreOO::JY5211CoreOOReferenceClock::Commit ( )

Commit configuration.

Available only when the device is idle. WARNING: Incorrect parameters will cause the PLL to be unable to lock the reference clock and cannot be recovered until shutdown and restart.

Member Data Documentation

◆ External

ExternalReferenceClock* JY5211CoreOO::JY5211CoreOOReferenceClock::External

External Reference Clock Source.

Required when ReferenceClock.Source is ReferenceClockSource.External

◆ Locked

bool JY5211CoreOO::JY5211CoreOOReferenceClock::Locked = false

◆ Source

ReferenceClockSource JY5211CoreOO::JY5211CoreOOReferenceClock::Source
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOODevice.h


5211 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOODITask.h File Reference

  • File List
  • File Members
  • COO
  • 5211
Classes | Namespaces
JY5211CoreOODITask.h File Reference
#include "JY5211CoreOOCommon.h"
#include "JY5211CoreOODevice.h"

Classes

class JY5211CoreOO::JY5211CoreOODITask

Namespaces

namespace JY5211CoreOO


5211 C++ Programming Manual: JY5211CoreOO::JY5211CoreOODITask Class Reference

  • JY5211CoreOODITask
Public Member Functions | Public Attributes | List of all members
JY5211CoreOO::JY5211CoreOODITask Class Reference

#include <JY5211CoreOODITask.h>

Public Member Functions

JY5211CoreOODITask (int slotNum)
JY5211CoreOODITask (std::string boardName)
~JY5211CoreOODITask ()
void | AddLine (IOTerminal lineNum)
Add one line.
void | AddLine (std::vector< IOTerminal > linesNum)
Add a group of line.
void | RemoveChannel (IOTerminal lineNum)
Delete the specified line number.
void | Start ()
Start DI task .
void | Stop ()
Stop DI task .
void | ReadSinglePoint (std::vector< bool > &returnstate)
Read data from all added lines.
void | ReadSinglePoint (IOTerminal line, bool &readValue)
Read data from a specified line.

Public Attributes

std::list< IOTerminal > Channels
List of DI channels,((5211 support 0~39Line )
JY5211CoreOODevice * Device
Device.

Constructor & Destructor Documentation

◆ JY5211CoreOODITask() [1/2]

JY5211CoreOO::JY5211CoreOODITask::JY5211CoreOODITask ( int slotNum )

◆ JY5211CoreOODITask() [2/2]

JY5211CoreOO::JY5211CoreOODITask::JY5211CoreOODITask ( std::string boardName )

◆ ~JY5211CoreOODITask()

JY5211CoreOO::JY5211CoreOODITask::~JY5211CoreOODITask ( )

Member Function Documentation

◆ AddLine() [1/2]

void JY5211CoreOO::JY5211CoreOODITask::AddLine ( IOTerminal lineNum )

Add one line.

Parameters
lineNum line number

◆ AddLine() [2/2]

void JY5211CoreOO::JY5211CoreOODITask::AddLine ( std::vector< IOTerminal > linesNum )

Add a group of line.

Parameters
linesNum line number

◆ ReadSinglePoint() [1/2]

void JY5211CoreOO::JY5211CoreOODITask::ReadSinglePoint | ( | IOTerminal | line,
 |  | bool & | readValue )

Read data from a specified line.

◆ ReadSinglePoint() [2/2]

void JY5211CoreOO::JY5211CoreOODITask::ReadSinglePoint ( std::vector< bool > & returnstate )

Read data from all added lines.

◆ RemoveChannel()

void JY5211CoreOO::JY5211CoreOODITask::RemoveChannel ( IOTerminal lineNum )

Delete the specified line number.

Parameters
lineNum line number

◆ Start()

void JY5211CoreOO::JY5211CoreOODITask::Start ( )

Start DI task .

◆ Stop()

void JY5211CoreOO::JY5211CoreOODITask::Stop ( )

Stop DI task .

Member Data Documentation

◆ Channels

std::list<IOTerminal> JY5211CoreOO::JY5211CoreOODITask::Channels

List of DI channels,((5211 support 0~39Line )

◆ Device

JY5211CoreOODevice* JY5211CoreOO::JY5211CoreOODITask::Device

Device.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOODITask.h


5211 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOODOTask.h File Reference

  • File List
  • File Members
  • COO
  • 5211
Classes | Namespaces
JY5211CoreOODOTask.h File Reference
#include "JY5211CoreOOCommon.h"
#include "JY5211CoreOODevice.h"

Classes

class JY5211CoreOO::JY5211CoreOODOTask

Namespaces

namespace JY5211CoreOO


5211 C++ Programming Manual: JY5211CoreOO::JY5211CoreOODOTask Class Reference

  • JY5211CoreOODOTask
Public Member Functions | Public Attributes | List of all members
JY5211CoreOO::JY5211CoreOODOTask Class Reference

#include <JY5211CoreOODOTask.h>

Public Member Functions

JY5211CoreOODOTask (int slotNum)
JY5211CoreOODOTask (std::string boardName)
~JY5211CoreOODOTask ()
void | AddLine (IOTerminal lineNum)
Add one line.
void | AddLine (std::vector< IOTerminal > linesNum)
Add a group of line.
void | RemoveChannel (IOTerminal lineNum)
Delete the specified line number.
void | Start ()
Start DO task .
void | Stop ()
Stop DO task .
void | WriteSinglePoint (std::vector< bool > &writeValues)
Read one sample for all line in register .
void | WriteSinglePoint (bool &writeValues, IOTerminal line)
Read one sample for one line in register .

Public Attributes

std::list< IOTerminal > Channels
List of DO channels,((5211 support 0~39Line )
JY5211CoreOODevice * Device
Device.

Constructor & Destructor Documentation

◆ JY5211CoreOODOTask() [1/2]

JY5211CoreOO::JY5211CoreOODOTask::JY5211CoreOODOTask ( int slotNum )

◆ JY5211CoreOODOTask() [2/2]

JY5211CoreOO::JY5211CoreOODOTask::JY5211CoreOODOTask ( std::string boardName )

◆ ~JY5211CoreOODOTask()

JY5211CoreOO::JY5211CoreOODOTask::~JY5211CoreOODOTask ( )

Member Function Documentation

◆ AddLine() [1/2]

void JY5211CoreOO::JY5211CoreOODOTask::AddLine ( IOTerminal lineNum )

Add one line.

Parameters
lineNum line number

◆ AddLine() [2/2]

void JY5211CoreOO::JY5211CoreOODOTask::AddLine ( std::vector< IOTerminal > linesNum )

Add a group of line.

Parameters
linesNum line number

◆ RemoveChannel()

void JY5211CoreOO::JY5211CoreOODOTask::RemoveChannel ( IOTerminal lineNum )

Delete the specified line number.

Parameters
lineNum line number

◆ Start()

void JY5211CoreOO::JY5211CoreOODOTask::Start ( )

Start DO task .

◆ Stop()

void JY5211CoreOO::JY5211CoreOODOTask::Stop ( )

Stop DO task .

◆ WriteSinglePoint() [1/2]

void JY5211CoreOO::JY5211CoreOODOTask::WriteSinglePoint | ( | bool & | writeValues,
 |  | IOTerminal | line )

Read one sample for one line in register .

Available when Mode is DIMode.Single

Parameters
readValues Values write. Buffer size== 1.

◆ WriteSinglePoint() [2/2]

void JY5211CoreOO::JY5211CoreOODOTask::WriteSinglePoint ( std::vector< bool > & writeValues )

Read one sample for all line in register .

Available when Mode is DIMode.Single

Parameters
writeValues Values write. Buffer size >= number of ports * 8.

Member Data Documentation

◆ Channels

std::list<IOTerminal> JY5211CoreOO::JY5211CoreOODOTask::Channels

List of DO channels,((5211 support 0~39Line )

◆ Device

JY5211CoreOODevice* JY5211CoreOO::JY5211CoreOODOTask::Device

Device.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOODOTask.h


5211 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOOLog.h File Reference

  • File List
  • File Members
  • COO
  • 5211
Classes | Namespaces | Enumerations
JY5211CoreOOLog.h File Reference
#include <queue>
#include <string>
#include <thread>
#include "JY5211CoreOOCommon.h"

Classes

class JY5211CoreOO::JY5211CoreOOLog

Namespaces

namespace JY5211CoreOO

Enumerations

enum class JY5211CoreOO::JY5211CoreOOLogLevel {
JY5211CoreOO::DEBUG_LOG_LEVEL , JY5211CoreOO::INFO_LOG_LEVEL , JY5211CoreOO::WARN_LOG_LEVEL , JY5211CoreOO::ERROR_LOG_LEVEL ,
JY5211CoreOO::FATAL_LOG_LEVEL
}


5211 C++ Programming Manual: JY5211CoreOO::JY5211CoreOOLog Class Reference

  • JY5211CoreOOLog
Static Public Member Functions | Static Public Attributes | List of all members
JY5211CoreOO::JY5211CoreOOLog Class Reference

#include <JY5211CoreOOLog.h>

Static Public Member Functions

static void | Print (const char *format,...)
static void | Print (JY5211CoreOOLogLevel logLevel, const char *format,...)
static void | Flush ()

Static Public Attributes

static JY5211CoreOOLogLevel | LogLevel
static JY5211CoreOOProperty< JY5211CoreOOLog, bool, JY5211CoreOOPropertyType::READ_WRITE > | EnableLog

Member Function Documentation

◆ Flush()

static void JY5211CoreOO::JY5211CoreOOLog::Flush ( )
static

◆ Print() [1/2]

static void JY5211CoreOO::JY5211CoreOOLog::Print | ( | const char * | format,
 |  |  | ... )
 static

◆ Print() [2/2]

static void JY5211CoreOO::JY5211CoreOOLog::Print | ( | JY5211CoreOOLogLevel | logLevel,
 |  | const char * | format,
 |  |  | ... )
 static

Member Data Documentation

◆ EnableLog

JY5211CoreOOProperty<JY5211CoreOOLog, bool, JY5211CoreOOPropertyType::READ_WRITE> JY5211CoreOO::JY5211CoreOOLog::EnableLog
static

◆ LogLevel

JY5211CoreOOLogLevel JY5211CoreOO::JY5211CoreOOLog::LogLevel
static
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5211/JY5211CoreOOLog.h


5211 C++ Programming Manual: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
▼N JY5211CoreOO |
C CIDigitalTrigger | CI Digital trigger
C CIExternalSampleClock | CI Implicit Sample Clock class
C CIExternalTimebase |
C CIImplicitSampleClock | CI Implicit Sample Clock class
C CIInternalSampleClock | CI Internal Sample Clock Configuration Class
C CISampleClock | CI Sample Clock class
C CISignalExport | CI Signal Export Class
C CITimebase | Timebase configuration class
C CITrigger | Constructor to create an CITrigger task object
C CODigitalTrigger | CO Digital trigger
C COExternalTimebase |
C COPulse | Pulse Parameter
C COSignalExport | CO Signal Export Class
C COTimebase | Timebase configuration class
C COTrigger | Constructor to create an COTrigger task object
C EdgeCounting | Configure CI EdgeCounting
C EdgeCountingOutEvent | Edge counting output event configuration class
C ExternalReferenceClock |
C FrequencyMeas | Configure CI Measure
C JY5211CoreOOCITask |
C JY5211CoreOOCOTask |
C JY5211CoreOODevice |
C JY5211CoreOODITask |
C JY5211CoreOODOTask |
C JY5211CoreOOLog |
C JY5211CoreOOProperty | 属性模板类
C JY5211CoreOOReferenceClock |
C JYDriverException |
C PauseTrigger | Pause trigger configuration class
C PeriodMeas | Configure CI Measure
C PFIFilter |
C PFISetting |
C PulseMeas | Configure CI Measure
C QuadEncoder | Configure CI Measure
C SemiPeriodMeas | Configure CI SemiPeriodMeas
C TwoEdgeSeparation | Configure CI Measure
C TwoPulseEncoder | Configure CI Measure


5211 C++ Programming Manual: Member List

  • CIDigitalTrigger
JY5211CoreOO::CIDigitalTrigger Member List

This is the complete list of members for JY5211CoreOO::CIDigitalTrigger, including all inherited members.

Edge | JY5211CoreOO::CIDigitalTrigger
Source | JY5211CoreOO::CIDigitalTrigger


5211 C++ Programming Manual: Member List

  • CIExternalSampleClock
JY5211CoreOO::CIExternalSampleClock Member List

This is the complete list of members for JY5211CoreOO::CIExternalSampleClock, including all inherited members.

ExpectedRate | JY5211CoreOO::CIExternalSampleClock
IgnoreFirstSampleClock | JY5211CoreOO::CIExternalSampleClock
Terminal | JY5211CoreOO::CIExternalSampleClock


5211 C++ Programming Manual: Member List

  • CIExternalTimebase
JY5211CoreOO::CIExternalTimebase Member List

This is the complete list of members for JY5211CoreOO::CIExternalTimebase, including all inherited members.

Frequency | JY5211CoreOO::CIExternalTimebase
Terminal | JY5211CoreOO::CIExternalTimebase


5211 C++ Programming Manual: Member List

  • CIImplicitSampleClock
JY5211CoreOO::CIImplicitSampleClock Member List

This is the complete list of members for JY5211CoreOO::CIImplicitSampleClock, including all inherited members.

ExpectedRate JY5211CoreOO::CIImplicitSampleClock


5211 C++ Programming Manual: Member List

  • CIInternalSampleClock
JY5211CoreOO::CIInternalSampleClock Member List

This is the complete list of members for JY5211CoreOO::CIInternalSampleClock, including all inherited members.

IgnoreFirstSampleClock | JY5211CoreOO::CIInternalSampleClock
Rate | JY5211CoreOO::CIInternalSampleClock


5211 C++ Programming Manual: Member List

  • CISampleClock
JY5211CoreOO::CISampleClock Member List

This is the complete list of members for JY5211CoreOO::CISampleClock, including all inherited members.

External | JY5211CoreOO::CISampleClock
Implicit | JY5211CoreOO::CISampleClock
Internal | JY5211CoreOO::CISampleClock
Source | JY5211CoreOO::CISampleClock


5211 C++ Programming Manual: Member List

  • CISignalExport
JY5211CoreOO::CISignalExport Member List

This is the complete list of members for JY5211CoreOO::CISignalExport, including all inherited members.

Add(CISignalExportSource source, SignalExportDestination destination) | JY5211CoreOO::CISignalExport
Add(CISignalExportSource source, std::list< SignalExportDestination > destinations) | JY5211CoreOO::CISignalExport
Clear(SignalExportDestination destination) | JY5211CoreOO::CISignalExport
ClearAll() | JY5211CoreOO::CISignalExport


5211 C++ Programming Manual: Member List

  • CITimebase
JY5211CoreOO::CITimebase Member List

This is the complete list of members for JY5211CoreOO::CITimebase, including all inherited members.

External | JY5211CoreOO::CITimebase
Source | JY5211CoreOO::CITimebase


5211 C++ Programming Manual: Member List

  • CITrigger
JY5211CoreOO::CITrigger Member List

This is the complete list of members for JY5211CoreOO::CITrigger, including all inherited members.

Digital | JY5211CoreOO::CITrigger
Type | JY5211CoreOO::CITrigger


5211 C++ Programming Manual: Member List

  • CODigitalTrigger
JY5211CoreOO::CODigitalTrigger Member List

This is the complete list of members for JY5211CoreOO::CODigitalTrigger, including all inherited members.

Edge | JY5211CoreOO::CODigitalTrigger
Source | JY5211CoreOO::CODigitalTrigger


5211 C++ Programming Manual: Member List

  • COExternalTimebase
JY5211CoreOO::COExternalTimebase Member List

This is the complete list of members for JY5211CoreOO::COExternalTimebase, including all inherited members.

Frequency | JY5211CoreOO::COExternalTimebase
Terminal | JY5211CoreOO::COExternalTimebase


5211 C++ Programming Manual: Member List

  • COPulse
JY5211CoreOO::COPulse Member List

This is the complete list of members for JY5211CoreOO::COPulse, including all inherited members.

COPulse(COPulseType type, double param1, double param2, int count) JY5211CoreOO::COPulse


5211 C++ Programming Manual: Member List

  • COSignalExport
JY5211CoreOO::COSignalExport Member List

This is the complete list of members for JY5211CoreOO::COSignalExport, including all inherited members.

Add(COSignalExportSource source, SignalExportDestination destination) | JY5211CoreOO::COSignalExport
Add(COSignalExportSource source, std::list< SignalExportDestination > destinations) | JY5211CoreOO::COSignalExport
Clear(SignalExportDestination destination) | JY5211CoreOO::COSignalExport
ClearAll() | JY5211CoreOO::COSignalExport


5211 C++ Programming Manual: Member List

  • COTimebase
JY5211CoreOO::COTimebase Member List

This is the complete list of members for JY5211CoreOO::COTimebase, including all inherited members.

ActualFreq | JY5211CoreOO::COTimebase
External | JY5211CoreOO::COTimebase
Source | JY5211CoreOO::COTimebase


5211 C++ Programming Manual: Member List

  • COTrigger
JY5211CoreOO::COTrigger Member List

This is the complete list of members for JY5211CoreOO::COTrigger, including all inherited members.

Digital | JY5211CoreOO::COTrigger
Type | JY5211CoreOO::COTrigger


5211 C++ Programming Manual: Member List

  • EdgeCounting
JY5211CoreOO::EdgeCounting Member List

This is the complete list of members for JY5211CoreOO::EdgeCounting, including all inherited members.

ActiveEdge | JY5211CoreOO::EdgeCounting
Direction | JY5211CoreOO::EdgeCounting
DirTerminal | JY5211CoreOO::EdgeCounting
InitialCount | JY5211CoreOO::EdgeCounting
Input_Terminal | JY5211CoreOO::EdgeCounting
OutEvent | JY5211CoreOO::EdgeCounting
Pause | JY5211CoreOO::EdgeCounting


5211 C++ Programming Manual: Member List

  • EdgeCountingOutEvent
JY5211CoreOO::EdgeCountingOutEvent Member List

This is the complete list of members for JY5211CoreOO::EdgeCountingOutEvent, including all inherited members.

IdleState | JY5211CoreOO::EdgeCountingOutEvent
Terminal | JY5211CoreOO::EdgeCountingOutEvent
Threshold | JY5211CoreOO::EdgeCountingOutEvent


5211 C++ Programming Manual: Member List

  • ExternalReferenceClock
JY5211CoreOO::ExternalReferenceClock Member List

This is the complete list of members for JY5211CoreOO::ExternalReferenceClock, including all inherited members.

Frequency | JY5211CoreOO::ExternalReferenceClock
Terminal | JY5211CoreOO::ExternalReferenceClock


5211 C++ Programming Manual: Member List

  • FrequencyMeas
JY5211CoreOO::FrequencyMeas Member List

This is the complete list of members for JY5211CoreOO::FrequencyMeas, including all inherited members.

Input_Terminal | JY5211CoreOO::FrequencyMeas
Timebase | JY5211CoreOO::FrequencyMeas


5211 C++ Programming Manual: Member List

  • JY5211CoreOOCITask
JY5211CoreOO::JY5211CoreOOCITask Member List

This is the complete list of members for JY5211CoreOO::JY5211CoreOOCITask, including all inherited members.

AvailableSamples | JY5211CoreOO::JY5211CoreOOCITask
Device | JY5211CoreOO::JY5211CoreOOCITask
EdgeCounting | JY5211CoreOO::JY5211CoreOOCITask
FrequencyMeas | JY5211CoreOO::JY5211CoreOOCITask
JY5211CoreOOCITask(int slotNum, int channel) | JY5211CoreOO::JY5211CoreOOCITask
JY5211CoreOOCITask(std::string boardName, int channel) | JY5211CoreOO::JY5211CoreOOCITask
Mode | JY5211CoreOO::JY5211CoreOOCITask
PeriodMeas | JY5211CoreOO::JY5211CoreOOCITask
PulseMeas | JY5211CoreOO::JY5211CoreOOCITask
QuadEncoder | JY5211CoreOO::JY5211CoreOOCITask
ReadData(uint32_t *pBufCount, int samplesToAcquire, int timeout=10000) | JY5211CoreOO::JY5211CoreOOCITask
ReadData(double *pBufMeasurement, int samplesToAcquire, int timeout=10000) | JY5211CoreOO::JY5211CoreOOCITask
ReadData(double *pBufMeasurement1, double *pBufMeasurement2, int samplesToAcquire, int timeout=10000) | JY5211CoreOO::JY5211CoreOOCITask
ReadSinglePoint(uint32_t &count) | JY5211CoreOO::JY5211CoreOOCITask
ReadSinglePoint(double &measurement, int timeout=10000) | JY5211CoreOO::JY5211CoreOOCITask
ReadSinglePoint(double &measurement1, double &measurement2, int timeout=10000) | JY5211CoreOO::JY5211CoreOOCITask
SampleClock | JY5211CoreOO::JY5211CoreOOCITask
SamplesToAcquire | JY5211CoreOO::JY5211CoreOOCITask
SemiPeriodMeas | JY5211CoreOO::JY5211CoreOOCITask
SendSoftwareTrigger() | JY5211CoreOO::JY5211CoreOOCITask
SignalExport | JY5211CoreOO::JY5211CoreOOCITask
Start() | JY5211CoreOO::JY5211CoreOOCITask
Stop() | JY5211CoreOO::JY5211CoreOOCITask
timeBase | JY5211CoreOO::JY5211CoreOOCITask
TransferedSamples | JY5211CoreOO::JY5211CoreOOCITask
Trigger | JY5211CoreOO::JY5211CoreOOCITask
TwoEdgeSeparation | JY5211CoreOO::JY5211CoreOOCITask
TwoPulseEncoder | JY5211CoreOO::JY5211CoreOOCITask
Type | JY5211CoreOO::JY5211CoreOOCITask
~JY5211CoreOOCITask() | JY5211CoreOO::JY5211CoreOOCITask


5211 C++ Programming Manual: Member List

  • JY5211CoreOOCOTask
JY5211CoreOO::JY5211CoreOOCOTask Member List

This is the complete list of members for JY5211CoreOO::JY5211CoreOOCOTask, including all inherited members.

_samplesToUpdate | JY5211CoreOO::JY5211CoreOOCOTask
_samplesToWrite | JY5211CoreOO::JY5211CoreOOCOTask
AvaliableLenInSamples | JY5211CoreOO::JY5211CoreOOCOTask
BufLenInSamples | JY5211CoreOO::JY5211CoreOOCOTask
Device | JY5211CoreOO::JY5211CoreOOCOTask
IdleState | JY5211CoreOO::JY5211CoreOOCOTask
InitialDelay | JY5211CoreOO::JY5211CoreOOCOTask
JY5211CoreOOCOTask(int slotNum, int channel) | JY5211CoreOO::JY5211CoreOOCOTask
JY5211CoreOOCOTask(std::string boardName, int channel) | JY5211CoreOO::JY5211CoreOOCOTask
Mode | JY5211CoreOO::JY5211CoreOOCOTask
OutputTerminal | JY5211CoreOO::JY5211CoreOOCOTask
Pause | JY5211CoreOO::JY5211CoreOOCOTask
plcount | JY5211CoreOO::JY5211CoreOOCOTask
SamplesToUpdate | JY5211CoreOO::JY5211CoreOOCOTask
SendSoftwareTrigger() | JY5211CoreOO::JY5211CoreOOCOTask
SignalExport | JY5211CoreOO::JY5211CoreOOCOTask
Start() | JY5211CoreOO::JY5211CoreOOCOTask
Stop() | JY5211CoreOO::JY5211CoreOOCOTask
TimeBase | JY5211CoreOO::JY5211CoreOOCOTask
TransferedPulses | JY5211CoreOO::JY5211CoreOOCOTask
TransferedSamples | JY5211CoreOO::JY5211CoreOOCOTask
Trigger | JY5211CoreOO::JY5211CoreOOCOTask
WaitUntilDone(int timeout=-1) | JY5211CoreOO::JY5211CoreOOCOTask
WriteData(COPulse *pulsesGroup[], int samplesToWrite, int timeout=10000) | JY5211CoreOO::JY5211CoreOOCOTask
WriteSinglePoint(COPulse &pulse) | JY5211CoreOO::JY5211CoreOOCOTask
~JY5211CoreOOCOTask() | JY5211CoreOO::JY5211CoreOOCOTask


5211 C++ Programming Manual: Member List

  • JY5211CoreOODITask
JY5211CoreOO::JY5211CoreOODITask Member List

This is the complete list of members for JY5211CoreOO::JY5211CoreOODITask, including all inherited members.

AddLine(IOTerminal lineNum) | JY5211CoreOO::JY5211CoreOODITask
AddLine(std::vector< IOTerminal > linesNum) | JY5211CoreOO::JY5211CoreOODITask
Channels | JY5211CoreOO::JY5211CoreOODITask
Device | JY5211CoreOO::JY5211CoreOODITask
JY5211CoreOODITask(int slotNum) | JY5211CoreOO::JY5211CoreOODITask
JY5211CoreOODITask(std::string boardName) | JY5211CoreOO::JY5211CoreOODITask
ReadSinglePoint(std::vector< bool > &returnstate) | JY5211CoreOO::JY5211CoreOODITask
ReadSinglePoint(IOTerminal line, bool &readValue) | JY5211CoreOO::JY5211CoreOODITask
RemoveChannel(IOTerminal lineNum) | JY5211CoreOO::JY5211CoreOODITask
Start() | JY5211CoreOO::JY5211CoreOODITask
Stop() | JY5211CoreOO::JY5211CoreOODITask
~JY5211CoreOODITask() | JY5211CoreOO::JY5211CoreOODITask


5211 C++ Programming Manual: Member List

  • JY5211CoreOODOTask
JY5211CoreOO::JY5211CoreOODOTask Member List

This is the complete list of members for JY5211CoreOO::JY5211CoreOODOTask, including all inherited members.

AddLine(IOTerminal lineNum) | JY5211CoreOO::JY5211CoreOODOTask
AddLine(std::vector< IOTerminal > linesNum) | JY5211CoreOO::JY5211CoreOODOTask
Channels | JY5211CoreOO::JY5211CoreOODOTask
Device | JY5211CoreOO::JY5211CoreOODOTask
JY5211CoreOODOTask(int slotNum) | JY5211CoreOO::JY5211CoreOODOTask
JY5211CoreOODOTask(std::string boardName) | JY5211CoreOO::JY5211CoreOODOTask
RemoveChannel(IOTerminal lineNum) | JY5211CoreOO::JY5211CoreOODOTask
Start() | JY5211CoreOO::JY5211CoreOODOTask
Stop() | JY5211CoreOO::JY5211CoreOODOTask
WriteSinglePoint(std::vector< bool > &writeValues) | JY5211CoreOO::JY5211CoreOODOTask
WriteSinglePoint(bool &writeValues, IOTerminal line) | JY5211CoreOO::JY5211CoreOODOTask
~JY5211CoreOODOTask() | JY5211CoreOO::JY5211CoreOODOTask


5211 C++ Programming Manual: Member List

  • JY5211CoreOODevice
JY5211CoreOO::JY5211CoreOODevice Member List

This is the complete list of members for JY5211CoreOO::JY5211CoreOODevice, including all inherited members.

CounterInterface enum name | JY5211CoreOO::JY5211CoreOODevice |
DeviceID | JY5211CoreOO::JY5211CoreOODevice |
DIOLineCount | JY5211CoreOO::JY5211CoreOODevice |
GetDefautTerminal(CounterInterface counterInterface, unsigned channelID) | JY5211CoreOO::JY5211CoreOODevice | static
GetInstance(int cardNum) | JY5211CoreOO::JY5211CoreOODevice | static
GetInstance(std::string aliasName) | JY5211CoreOO::JY5211CoreOODevice | static
Handle | JY5211CoreOO::JY5211CoreOODevice |
PFI | JY5211CoreOO::JY5211CoreOODevice |
ReferenceClock | JY5211CoreOO::JY5211CoreOODevice |
SerialNumber | JY5211CoreOO::JY5211CoreOODevice |


5211 C++ Programming Manual: Member List

  • JY5211CoreOOLog
JY5211CoreOO::JY5211CoreOOLog Member List

This is the complete list of members for JY5211CoreOO::JY5211CoreOOLog, including all inherited members.

EnableLog | JY5211CoreOO::JY5211CoreOOLog | static
Flush() | JY5211CoreOO::JY5211CoreOOLog | static
LogLevel | JY5211CoreOO::JY5211CoreOOLog | static
Print(const char *format,...) | JY5211CoreOO::JY5211CoreOOLog | static
Print(JY5211CoreOOLogLevel logLevel, const char *format,...) | JY5211CoreOO::JY5211CoreOOLog | static


5211 C++ Programming Manual: Member List

  • JY5211CoreOOProperty
JY5211CoreOO::JY5211CoreOOProperty< ContainerClass, ValueType, propertyType > Member List

This is the complete list of members for JY5211CoreOO::JY5211CoreOOProperty< ContainerClass, ValueType, propertyType >, including all inherited members.

JY5211CoreOOProperty() | JY5211CoreOO::JY5211CoreOOProperty< ContainerClass, ValueType, propertyType >
JY5211CoreOOProperty(ContainerClass *cObject, ValueType(ContainerClass::*pGet)(), void(ContainerClass::*pSet)(ValueType value)) | JY5211CoreOO::JY5211CoreOOProperty< ContainerClass, ValueType, propertyType >
JY5211CoreOOProperty(ValueType(*pGet)(), void(*pSet)(ValueType value)) | JY5211CoreOO::JY5211CoreOOProperty< ContainerClass, ValueType, propertyType >
operator ValueType() | JY5211CoreOO::JY5211CoreOOProperty< ContainerClass, ValueType, propertyType >
operator=(const ValueType &value) | JY5211CoreOO::JY5211CoreOOProperty< ContainerClass, ValueType, propertyType >


5211 C++ Programming Manual: Member List

  • JY5211CoreOOReferenceClock
JY5211CoreOO::JY5211CoreOOReferenceClock Member List

This is the complete list of members for JY5211CoreOO::JY5211CoreOOReferenceClock, including all inherited members.

Commit() | JY5211CoreOO::JY5211CoreOOReferenceClock
External | JY5211CoreOO::JY5211CoreOOReferenceClock
Locked | JY5211CoreOO::JY5211CoreOOReferenceClock
Source | JY5211CoreOO::JY5211CoreOOReferenceClock


5211 C++ Programming Manual: Member List

  • JYDriverException
JY5211CoreOO::JYDriverException Member List

This is the complete list of members for JY5211CoreOO::JYDriverException, including all inherited members.

errorCode | JY5211CoreOO::JYDriverException
exceptionMessage | JY5211CoreOO::JYDriverException
FollowingException | JY5211CoreOO::JYDriverException
JYDriverException(JYDriverExceptionPublic exceptionCode, std::string msg="") | JY5211CoreOO::JYDriverException
JYDriverException(JYErrorCode exceptionCode, std::string msg="") | JY5211CoreOO::JYDriverException
JYDriverException(int, std::string msg) | JY5211CoreOO::JYDriverException


5211 C++ Programming Manual: Member List

  • PFIFilter
JY5211CoreOO::PFIFilter Member List

This is the complete list of members for JY5211CoreOO::PFIFilter, including all inherited members.

Disable(PFITerminal terminal) | JY5211CoreOO::PFIFilter
Disable(std::vector< PFITerminal > terminals) | JY5211CoreOO::PFIFilter
DisableAll() | JY5211CoreOO::PFIFilter
Enable(PFITerminal terminal, int minPulseWidth) | JY5211CoreOO::PFIFilter
Enable(std::vector< PFITerminal > terminals, int minPulseWidth) | JY5211CoreOO::PFIFilter
Enable(std::vector< PFITerminal > terminals, std::vector< int > minPulseWidth) | JY5211CoreOO::PFIFilter


5211 C++ Programming Manual: Member List

  • PFISetting
JY5211CoreOO::PFISetting Member List

This is the complete list of members for JY5211CoreOO::PFISetting, including all inherited members.

Filter JY5211CoreOO::PFISetting


5211 C++ Programming Manual: Member List

  • PauseTrigger
JY5211CoreOO::PauseTrigger Member List

This is the complete list of members for JY5211CoreOO::PauseTrigger, including all inherited members.

ActivePolarity | JY5211CoreOO::PauseTrigger
Output_State | JY5211CoreOO::PauseTrigger
Terminal | JY5211CoreOO::PauseTrigger


5211 C++ Programming Manual: Member List

  • PeriodMeas
JY5211CoreOO::PeriodMeas Member List

This is the complete list of members for JY5211CoreOO::PeriodMeas, including all inherited members.

Input_Terminal | JY5211CoreOO::PeriodMeas
Timebase | JY5211CoreOO::PeriodMeas


5211 C++ Programming Manual: Member List

  • PulseMeas
JY5211CoreOO::PulseMeas Member List

This is the complete list of members for JY5211CoreOO::PulseMeas, including all inherited members.

Input_Terminal | JY5211CoreOO::PulseMeas
StartingEdge | JY5211CoreOO::PulseMeas
Timebase | JY5211CoreOO::PulseMeas


5211 C++ Programming Manual: Member List

  • QuadEncoder
JY5211CoreOO::QuadEncoder Member List

This is the complete list of members for JY5211CoreOO::QuadEncoder, including all inherited members.

AInputTerminal | JY5211CoreOO::QuadEncoder
BInputTerminal | JY5211CoreOO::QuadEncoder
EncodingType | JY5211CoreOO::QuadEncoder
InitialCount | JY5211CoreOO::QuadEncoder
ZInputTerminal | JY5211CoreOO::QuadEncoder
ZReloadEnabled | JY5211CoreOO::QuadEncoder


5211 C++ Programming Manual: Member List

  • SemiPeriodMeas
JY5211CoreOO::SemiPeriodMeas Member List

This is the complete list of members for JY5211CoreOO::SemiPeriodMeas, including all inherited members.

Input_Terminal | JY5211CoreOO::SemiPeriodMeas
StartingEdge | JY5211CoreOO::SemiPeriodMeas
Timebase | JY5211CoreOO::SemiPeriodMeas


5211 C++ Programming Manual: Member List

  • TwoEdgeSeparation
JY5211CoreOO::TwoEdgeSeparation Member List

This is the complete list of members for JY5211CoreOO::TwoEdgeSeparation, including all inherited members.

EdgeSeparationMode | JY5211CoreOO::TwoEdgeSeparation
FirstInputTerminal | JY5211CoreOO::TwoEdgeSeparation
SecondInputTerminal | JY5211CoreOO::TwoEdgeSeparation
Timebase | JY5211CoreOO::TwoEdgeSeparation


5211 C++ Programming Manual: Member List

  • TwoPulseEncoder
JY5211CoreOO::TwoPulseEncoder Member List

This is the complete list of members for JY5211CoreOO::TwoPulseEncoder, including all inherited members.

AInputTerminal | JY5211CoreOO::TwoPulseEncoder
BInputTerminal | JY5211CoreOO::TwoPulseEncoder
InitialCount | JY5211CoreOO::TwoPulseEncoder


5211 C++ Programming Manual: Class Index

Class Index
C | E | F | J | P | Q | S | T
C
CIDigitalTrigger (JY5211CoreOO)
CIExternalSampleClock (JY5211CoreOO)
CIExternalTimebase (JY5211CoreOO)
CIImplicitSampleClock (JY5211CoreOO)
CIInternalSampleClock (JY5211CoreOO)
CISampleClock (JY5211CoreOO)
CISignalExport (JY5211CoreOO)
CITimebase (JY5211CoreOO)
CITrigger (JY5211CoreOO)
CODigitalTrigger (JY5211CoreOO)
COExternalTimebase (JY5211CoreOO)
COPulse (JY5211CoreOO)
COSignalExport (JY5211CoreOO)
COTimebase (JY5211CoreOO)
COTrigger (JY5211CoreOO)
E
EdgeCounting (JY5211CoreOO)
EdgeCountingOutEvent (JY5211CoreOO)
ExternalReferenceClock (JY5211CoreOO)
F
FrequencyMeas (JY5211CoreOO)
J
JY5211CoreOOCITask (JY5211CoreOO)
JY5211CoreOOCOTask (JY5211CoreOO)
JY5211CoreOODevice (JY5211CoreOO)
JY5211CoreOODITask (JY5211CoreOO)
JY5211CoreOODOTask (JY5211CoreOO)
JY5211CoreOOLog (JY5211CoreOO)
JY5211CoreOOProperty (JY5211CoreOO)
JY5211CoreOOReferenceClock (JY5211CoreOO)
JYDriverException (JY5211CoreOO)
P
PauseTrigger (JY5211CoreOO)
PeriodMeas (JY5211CoreOO)
PFIFilter (JY5211CoreOO)
PFISetting (JY5211CoreOO)
PulseMeas (JY5211CoreOO)
Q
QuadEncoder (JY5211CoreOO)
S
SemiPeriodMeas (JY5211CoreOO)
T
TwoEdgeSeparation (JY5211CoreOO)
TwoPulseEncoder (JY5211CoreOO)


5211 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO Directory Reference

  • File List
  • File Members
  • COO
COO Directory Reference

Directories

5211


5211 C++ Programming Manual: File List

  • File List
  • File Members
File List
Here is a list of all files with brief descriptions:
[detail level 123]
▼ COO
▼ 5211
JY5211CoreOOCITask.h
JY5211CoreOOCommon.h
JY5211CoreOOCOTask.h
JY5211CoreOODevice.h
JY5211CoreOODITask.h
JY5211CoreOODOTask.h
JY5211CoreOOLog.h


5211 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- _ -

  • _samplesToUpdate : JY5211CoreOO::JY5211CoreOOCOTask
  • _samplesToWrite : JY5211CoreOO::JY5211CoreOOCOTask

- a -

  • ActiveEdge : JY5211CoreOO::EdgeCounting
  • ActivePolarity : JY5211CoreOO::PauseTrigger
  • ActualFreq : JY5211CoreOO::COTimebase
  • Add() : JY5211CoreOO::CISignalExport, JY5211CoreOO::COSignalExport
  • AddLine() : JY5211CoreOO::JY5211CoreOODITask, JY5211CoreOO::JY5211CoreOODOTask
  • AInputTerminal : JY5211CoreOO::QuadEncoder, JY5211CoreOO::TwoPulseEncoder
  • AvailableSamples : JY5211CoreOO::JY5211CoreOOCITask
  • AvaliableLenInSamples : JY5211CoreOO::JY5211CoreOOCOTask

- b -

  • BInputTerminal : JY5211CoreOO::QuadEncoder, JY5211CoreOO::TwoPulseEncoder
  • BufLenInSamples : JY5211CoreOO::JY5211CoreOOCOTask

- c -

  • Channels : JY5211CoreOO::JY5211CoreOODITask, JY5211CoreOO::JY5211CoreOODOTask
  • Clear() : JY5211CoreOO::CISignalExport, JY5211CoreOO::COSignalExport
  • ClearAll() : JY5211CoreOO::CISignalExport, JY5211CoreOO::COSignalExport
  • Commit() : JY5211CoreOO::JY5211CoreOOReferenceClock
  • COPulse() : JY5211CoreOO::COPulse
  • CounterInterface : JY5211CoreOO::JY5211CoreOODevice

- d -

  • Device : JY5211CoreOO::JY5211CoreOOCITask, JY5211CoreOO::JY5211CoreOOCOTask, JY5211CoreOO::JY5211CoreOODITask, JY5211CoreOO::JY5211CoreOODOTask
  • DeviceID : JY5211CoreOO::JY5211CoreOODevice
  • Digital : JY5211CoreOO::CITrigger, JY5211CoreOO::COTrigger
  • DIOLineCount : JY5211CoreOO::JY5211CoreOODevice
  • Direction : JY5211CoreOO::EdgeCounting
  • DirTerminal : JY5211CoreOO::EdgeCounting
  • Disable() : JY5211CoreOO::PFIFilter
  • DisableAll() : JY5211CoreOO::PFIFilter

- e -

  • Edge : JY5211CoreOO::CIDigitalTrigger, JY5211CoreOO::CODigitalTrigger
  • EdgeCounting : JY5211CoreOO::JY5211CoreOOCITask
  • EdgeSeparationMode : JY5211CoreOO::TwoEdgeSeparation
  • Enable() : JY5211CoreOO::PFIFilter
  • EnableLog : JY5211CoreOO::JY5211CoreOOLog
  • EncodingType : JY5211CoreOO::QuadEncoder
  • errorCode : JY5211CoreOO::JYDriverException
  • exceptionMessage : JY5211CoreOO::JYDriverException
  • ExpectedRate : JY5211CoreOO::CIExternalSampleClock, JY5211CoreOO::CIImplicitSampleClock
  • External : JY5211CoreOO::CISampleClock, JY5211CoreOO::CITimebase, JY5211CoreOO::COTimebase, JY5211CoreOO::JY5211CoreOOReferenceClock

- f -

  • Filter : JY5211CoreOO::PFISetting
  • FirstInputTerminal : JY5211CoreOO::TwoEdgeSeparation
  • Flush() : JY5211CoreOO::JY5211CoreOOLog
  • FollowingException : JY5211CoreOO::JYDriverException
  • Frequency : JY5211CoreOO::CIExternalTimebase, JY5211CoreOO::COExternalTimebase, JY5211CoreOO::ExternalReferenceClock
  • FrequencyMeas : JY5211CoreOO::JY5211CoreOOCITask

- g -

  • GetDefautTerminal() : JY5211CoreOO::JY5211CoreOODevice
  • GetInstance() : JY5211CoreOO::JY5211CoreOODevice

- h -

  • Handle : JY5211CoreOO::JY5211CoreOODevice

- i -

  • IdleState : JY5211CoreOO::EdgeCountingOutEvent, JY5211CoreOO::JY5211CoreOOCOTask
  • IgnoreFirstSampleClock : JY5211CoreOO::CIExternalSampleClock, JY5211CoreOO::CIInternalSampleClock
  • Implicit : JY5211CoreOO::CISampleClock
  • InitialCount : JY5211CoreOO::EdgeCounting, JY5211CoreOO::QuadEncoder, JY5211CoreOO::TwoPulseEncoder
  • InitialDelay : JY5211CoreOO::JY5211CoreOOCOTask
  • Input_Terminal : JY5211CoreOO::EdgeCounting, JY5211CoreOO::FrequencyMeas, JY5211CoreOO::PeriodMeas, JY5211CoreOO::PulseMeas, JY5211CoreOO::SemiPeriodMeas
  • Internal : JY5211CoreOO::CISampleClock

- j -

  • JY5211CoreOOCITask() : JY5211CoreOO::JY5211CoreOOCITask
  • JY5211CoreOOCOTask() : JY5211CoreOO::JY5211CoreOOCOTask
  • JY5211CoreOODITask() : JY5211CoreOO::JY5211CoreOODITask
  • JY5211CoreOODOTask() : JY5211CoreOO::JY5211CoreOODOTask
  • JY5211CoreOOProperty() : JY5211CoreOO::JY5211CoreOOProperty< ContainerClass, ValueType, propertyType >
  • JYDriverException() : JY5211CoreOO::JYDriverException

- l -

  • Locked : JY5211CoreOO::JY5211CoreOOReferenceClock
  • LogLevel : JY5211CoreOO::JY5211CoreOOLog

- m -

  • Mode : JY5211CoreOO::JY5211CoreOOCITask, JY5211CoreOO::JY5211CoreOOCOTask

- o -

  • operator ValueType() : JY5211CoreOO::JY5211CoreOOProperty< ContainerClass, ValueType, propertyType >
  • operator=() : JY5211CoreOO::JY5211CoreOOProperty< ContainerClass, ValueType, propertyType >
  • OutEvent : JY5211CoreOO::EdgeCounting
  • Output_State : JY5211CoreOO::PauseTrigger
  • OutputTerminal : JY5211CoreOO::JY5211CoreOOCOTask

- p -

  • Pause : JY5211CoreOO::EdgeCounting, JY5211CoreOO::JY5211CoreOOCOTask
  • PeriodMeas : JY5211CoreOO::JY5211CoreOOCITask
  • PFI : JY5211CoreOO::JY5211CoreOODevice
  • plcount : JY5211CoreOO::JY5211CoreOOCOTask
  • Print() : JY5211CoreOO::JY5211CoreOOLog
  • PulseMeas : JY5211CoreOO::JY5211CoreOOCITask

- q -

  • QuadEncoder : JY5211CoreOO::JY5211CoreOOCITask

- r -

  • Rate : JY5211CoreOO::CIInternalSampleClock
  • ReadData() : JY5211CoreOO::JY5211CoreOOCITask
  • ReadSinglePoint() : JY5211CoreOO::JY5211CoreOOCITask, JY5211CoreOO::JY5211CoreOODITask
  • ReferenceClock : JY5211CoreOO::JY5211CoreOODevice
  • RemoveChannel() : JY5211CoreOO::JY5211CoreOODITask, JY5211CoreOO::JY5211CoreOODOTask

- s -

  • SampleClock : JY5211CoreOO::JY5211CoreOOCITask
  • SamplesToAcquire : JY5211CoreOO::JY5211CoreOOCITask
  • SamplesToUpdate : JY5211CoreOO::JY5211CoreOOCOTask
  • SecondInputTerminal : JY5211CoreOO::TwoEdgeSeparation
  • SemiPeriodMeas : JY5211CoreOO::JY5211CoreOOCITask
  • SendSoftwareTrigger() : JY5211CoreOO::JY5211CoreOOCITask, JY5211CoreOO::JY5211CoreOOCOTask
  • SerialNumber : JY5211CoreOO::JY5211CoreOODevice
  • SignalExport : JY5211CoreOO::JY5211CoreOOCITask, JY5211CoreOO::JY5211CoreOOCOTask
  • Source : JY5211CoreOO::CIDigitalTrigger, JY5211CoreOO::CISampleClock, JY5211CoreOO::CITimebase, JY5211CoreOO::CODigitalTrigger, JY5211CoreOO::COTimebase, JY5211CoreOO::JY5211CoreOOReferenceClock
  • Start() : JY5211CoreOO::JY5211CoreOOCITask, JY5211CoreOO::JY5211CoreOOCOTask, JY5211CoreOO::JY5211CoreOODITask, JY5211CoreOO::JY5211CoreOODOTask
  • StartingEdge : JY5211CoreOO::PulseMeas, JY5211CoreOO::SemiPeriodMeas
  • Stop() : JY5211CoreOO::JY5211CoreOOCITask, JY5211CoreOO::JY5211CoreOOCOTask, JY5211CoreOO::JY5211CoreOODITask, JY5211CoreOO::JY5211CoreOODOTask

- t -

  • Terminal : JY5211CoreOO::CIExternalSampleClock, JY5211CoreOO::CIExternalTimebase, JY5211CoreOO::COExternalTimebase, JY5211CoreOO::EdgeCountingOutEvent, JY5211CoreOO::ExternalReferenceClock, JY5211CoreOO::PauseTrigger
  • Threshold : JY5211CoreOO::EdgeCountingOutEvent
  • TimeBase : JY5211CoreOO::JY5211CoreOOCOTask
  • Timebase : JY5211CoreOO::FrequencyMeas, JY5211CoreOO::PeriodMeas, JY5211CoreOO::PulseMeas, JY5211CoreOO::SemiPeriodMeas, JY5211CoreOO::TwoEdgeSeparation
  • timeBase : JY5211CoreOO::JY5211CoreOOCITask
  • TransferedPulses : JY5211CoreOO::JY5211CoreOOCOTask
  • TransferedSamples : JY5211CoreOO::JY5211CoreOOCITask, JY5211CoreOO::JY5211CoreOOCOTask
  • Trigger : JY5211CoreOO::JY5211CoreOOCITask, JY5211CoreOO::JY5211CoreOOCOTask
  • TwoEdgeSeparation : JY5211CoreOO::JY5211CoreOOCITask
  • TwoPulseEncoder : JY5211CoreOO::JY5211CoreOOCITask
  • Type : JY5211CoreOO::CITrigger, JY5211CoreOO::COTrigger, JY5211CoreOO::JY5211CoreOOCITask

- w -

  • WaitUntilDone() : JY5211CoreOO::JY5211CoreOOCOTask
  • WriteData() : JY5211CoreOO::JY5211CoreOOCOTask
  • WriteSinglePoint() : JY5211CoreOO::JY5211CoreOOCOTask, JY5211CoreOO::JY5211CoreOODOTask

- z -

  • ZInputTerminal : JY5211CoreOO::QuadEncoder
  • ZReloadEnabled : JY5211CoreOO::QuadEncoder

- ~ -

  • ~JY5211CoreOOCITask() : JY5211CoreOO::JY5211CoreOOCITask
  • ~JY5211CoreOOCOTask() : JY5211CoreOO::JY5211CoreOOCOTask
  • ~JY5211CoreOODITask() : JY5211CoreOO::JY5211CoreOODITask
  • ~JY5211CoreOODOTask() : JY5211CoreOO::JY5211CoreOODOTask


5211 C++ Programming Manual: Class Members - Enumerations

  • All
  • Functions
  • Variables
  • Enumerations
Here is a list of all enums with links to the classes they belong to:
  • CounterInterface : JY5211CoreOO::JY5211CoreOODevice


5211 C++ Programming Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • a
  • c
  • d
  • e
  • f
  • g
  • j
  • o
  • p
  • r
  • s
  • w
  • ~
Here is a list of all functions with links to the classes they belong to:

- a -

  • Add() : JY5211CoreOO::CISignalExport, JY5211CoreOO::COSignalExport
  • AddLine() : JY5211CoreOO::JY5211CoreOODITask, JY5211CoreOO::JY5211CoreOODOTask

- c -

  • Clear() : JY5211CoreOO::CISignalExport, JY5211CoreOO::COSignalExport
  • ClearAll() : JY5211CoreOO::CISignalExport, JY5211CoreOO::COSignalExport
  • Commit() : JY5211CoreOO::JY5211CoreOOReferenceClock
  • COPulse() : JY5211CoreOO::COPulse

- d -

  • Disable() : JY5211CoreOO::PFIFilter
  • DisableAll() : JY5211CoreOO::PFIFilter

- e -

  • Enable() : JY5211CoreOO::PFIFilter

- f -

  • Flush() : JY5211CoreOO::JY5211CoreOOLog

- g -

  • GetDefautTerminal() : JY5211CoreOO::JY5211CoreOODevice
  • GetInstance() : JY5211CoreOO::JY5211CoreOODevice

- j -

  • JY5211CoreOOCITask() : JY5211CoreOO::JY5211CoreOOCITask
  • JY5211CoreOOCOTask() : JY5211CoreOO::JY5211CoreOOCOTask
  • JY5211CoreOODITask() : JY5211CoreOO::JY5211CoreOODITask
  • JY5211CoreOODOTask() : JY5211CoreOO::JY5211CoreOODOTask
  • JY5211CoreOOProperty() : JY5211CoreOO::JY5211CoreOOProperty< ContainerClass, ValueType, propertyType >
  • JYDriverException() : JY5211CoreOO::JYDriverException

- o -

  • operator ValueType() : JY5211CoreOO::JY5211CoreOOProperty< ContainerClass, ValueType, propertyType >
  • operator=() : JY5211CoreOO::JY5211CoreOOProperty< ContainerClass, ValueType, propertyType >

- p -

  • Print() : JY5211CoreOO::JY5211CoreOOLog

- r -

  • ReadData() : JY5211CoreOO::JY5211CoreOOCITask
  • ReadSinglePoint() : JY5211CoreOO::JY5211CoreOOCITask, JY5211CoreOO::JY5211CoreOODITask
  • RemoveChannel() : JY5211CoreOO::JY5211CoreOODITask, JY5211CoreOO::JY5211CoreOODOTask

- s -

  • SendSoftwareTrigger() : JY5211CoreOO::JY5211CoreOOCITask, JY5211CoreOO::JY5211CoreOOCOTask
  • Start() : JY5211CoreOO::JY5211CoreOOCITask, JY5211CoreOO::JY5211CoreOOCOTask, JY5211CoreOO::JY5211CoreOODITask, JY5211CoreOO::JY5211CoreOODOTask
  • Stop() : JY5211CoreOO::JY5211CoreOOCITask, JY5211CoreOO::JY5211CoreOOCOTask, JY5211CoreOO::JY5211CoreOODITask, JY5211CoreOO::JY5211CoreOODOTask

- w -

  • WaitUntilDone() : JY5211CoreOO::JY5211CoreOOCOTask
  • WriteData() : JY5211CoreOO::JY5211CoreOOCOTask
  • WriteSinglePoint() : JY5211CoreOO::JY5211CoreOOCOTask, JY5211CoreOO::JY5211CoreOODOTask

- ~ -

  • ~JY5211CoreOOCITask() : JY5211CoreOO::JY5211CoreOOCITask
  • ~JY5211CoreOOCOTask() : JY5211CoreOO::JY5211CoreOOCOTask
  • ~JY5211CoreOODITask() : JY5211CoreOO::JY5211CoreOODITask
  • ~JY5211CoreOODOTask() : JY5211CoreOO::JY5211CoreOODOTask


5211 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • z
Here is a list of all variables with links to the classes they belong to:

- _ -

  • _samplesToUpdate : JY5211CoreOO::JY5211CoreOOCOTask
  • _samplesToWrite : JY5211CoreOO::JY5211CoreOOCOTask

- a -

  • ActiveEdge : JY5211CoreOO::EdgeCounting
  • ActivePolarity : JY5211CoreOO::PauseTrigger
  • ActualFreq : JY5211CoreOO::COTimebase
  • AInputTerminal : JY5211CoreOO::QuadEncoder, JY5211CoreOO::TwoPulseEncoder
  • AvailableSamples : JY5211CoreOO::JY5211CoreOOCITask
  • AvaliableLenInSamples : JY5211CoreOO::JY5211CoreOOCOTask

- b -

  • BInputTerminal : JY5211CoreOO::QuadEncoder, JY5211CoreOO::TwoPulseEncoder
  • BufLenInSamples : JY5211CoreOO::JY5211CoreOOCOTask

- c -

  • Channels : JY5211CoreOO::JY5211CoreOODITask, JY5211CoreOO::JY5211CoreOODOTask

- d -

  • Device : JY5211CoreOO::JY5211CoreOOCITask, JY5211CoreOO::JY5211CoreOOCOTask, JY5211CoreOO::JY5211CoreOODITask, JY5211CoreOO::JY5211CoreOODOTask
  • DeviceID : JY5211CoreOO::JY5211CoreOODevice
  • Digital : JY5211CoreOO::CITrigger, JY5211CoreOO::COTrigger
  • DIOLineCount : JY5211CoreOO::JY5211CoreOODevice
  • Direction : JY5211CoreOO::EdgeCounting
  • DirTerminal : JY5211CoreOO::EdgeCounting

- e -

  • Edge : JY5211CoreOO::CIDigitalTrigger, JY5211CoreOO::CODigitalTrigger
  • EdgeCounting : JY5211CoreOO::JY5211CoreOOCITask
  • EdgeSeparationMode : JY5211CoreOO::TwoEdgeSeparation
  • EnableLog : JY5211CoreOO::JY5211CoreOOLog
  • EncodingType : JY5211CoreOO::QuadEncoder
  • errorCode : JY5211CoreOO::JYDriverException
  • exceptionMessage : JY5211CoreOO::JYDriverException
  • ExpectedRate : JY5211CoreOO::CIExternalSampleClock, JY5211CoreOO::CIImplicitSampleClock
  • External : JY5211CoreOO::CISampleClock, JY5211CoreOO::CITimebase, JY5211CoreOO::COTimebase, JY5211CoreOO::JY5211CoreOOReferenceClock

- f -

  • Filter : JY5211CoreOO::PFISetting
  • FirstInputTerminal : JY5211CoreOO::TwoEdgeSeparation
  • FollowingException : JY5211CoreOO::JYDriverException
  • Frequency : JY5211CoreOO::CIExternalTimebase, JY5211CoreOO::COExternalTimebase, JY5211CoreOO::ExternalReferenceClock
  • FrequencyMeas : JY5211CoreOO::JY5211CoreOOCITask

- h -

  • Handle : JY5211CoreOO::JY5211CoreOODevice

- i -

  • IdleState : JY5211CoreOO::EdgeCountingOutEvent, JY5211CoreOO::JY5211CoreOOCOTask
  • IgnoreFirstSampleClock : JY5211CoreOO::CIExternalSampleClock, JY5211CoreOO::CIInternalSampleClock
  • Implicit : JY5211CoreOO::CISampleClock
  • InitialCount : JY5211CoreOO::EdgeCounting, JY5211CoreOO::QuadEncoder, JY5211CoreOO::TwoPulseEncoder
  • InitialDelay : JY5211CoreOO::JY5211CoreOOCOTask
  • Input_Terminal : JY5211CoreOO::EdgeCounting, JY5211CoreOO::FrequencyMeas, JY5211CoreOO::PeriodMeas, JY5211CoreOO::PulseMeas, JY5211CoreOO::SemiPeriodMeas
  • Internal : JY5211CoreOO::CISampleClock

- l -

  • Locked : JY5211CoreOO::JY5211CoreOOReferenceClock
  • LogLevel : JY5211CoreOO::JY5211CoreOOLog

- m -

  • Mode : JY5211CoreOO::JY5211CoreOOCITask, JY5211CoreOO::JY5211CoreOOCOTask

- o -

  • OutEvent : JY5211CoreOO::EdgeCounting
  • Output_State : JY5211CoreOO::PauseTrigger
  • OutputTerminal : JY5211CoreOO::JY5211CoreOOCOTask

- p -

  • Pause : JY5211CoreOO::EdgeCounting, JY5211CoreOO::JY5211CoreOOCOTask
  • PeriodMeas : JY5211CoreOO::JY5211CoreOOCITask
  • PFI : JY5211CoreOO::JY5211CoreOODevice
  • plcount : JY5211CoreOO::JY5211CoreOOCOTask
  • PulseMeas : JY5211CoreOO::JY5211CoreOOCITask

- q -

  • QuadEncoder : JY5211CoreOO::JY5211CoreOOCITask

- r -

  • Rate : JY5211CoreOO::CIInternalSampleClock
  • ReferenceClock : JY5211CoreOO::JY5211CoreOODevice

- s -

  • SampleClock : JY5211CoreOO::JY5211CoreOOCITask
  • SamplesToAcquire : JY5211CoreOO::JY5211CoreOOCITask
  • SamplesToUpdate : JY5211CoreOO::JY5211CoreOOCOTask
  • SecondInputTerminal : JY5211CoreOO::TwoEdgeSeparation
  • SemiPeriodMeas : JY5211CoreOO::JY5211CoreOOCITask
  • SerialNumber : JY5211CoreOO::JY5211CoreOODevice
  • SignalExport : JY5211CoreOO::JY5211CoreOOCITask, JY5211CoreOO::JY5211CoreOOCOTask
  • Source : JY5211CoreOO::CIDigitalTrigger, JY5211CoreOO::CISampleClock, JY5211CoreOO::CITimebase, JY5211CoreOO::CODigitalTrigger, JY5211CoreOO::COTimebase, JY5211CoreOO::JY5211CoreOOReferenceClock
  • StartingEdge : JY5211CoreOO::PulseMeas, JY5211CoreOO::SemiPeriodMeas

- t -

  • Terminal : JY5211CoreOO::CIExternalSampleClock, JY5211CoreOO::CIExternalTimebase, JY5211CoreOO::COExternalTimebase, JY5211CoreOO::EdgeCountingOutEvent, JY5211CoreOO::ExternalReferenceClock, JY5211CoreOO::PauseTrigger
  • Threshold : JY5211CoreOO::EdgeCountingOutEvent
  • TimeBase : JY5211CoreOO::JY5211CoreOOCOTask
  • Timebase : JY5211CoreOO::FrequencyMeas, JY5211CoreOO::PeriodMeas, JY5211CoreOO::PulseMeas, JY5211CoreOO::SemiPeriodMeas, JY5211CoreOO::TwoEdgeSeparation
  • timeBase : JY5211CoreOO::JY5211CoreOOCITask
  • TransferedPulses : JY5211CoreOO::JY5211CoreOOCOTask
  • TransferedSamples : JY5211CoreOO::JY5211CoreOOCITask, JY5211CoreOO::JY5211CoreOOCOTask
  • Trigger : JY5211CoreOO::JY5211CoreOOCITask, JY5211CoreOO::JY5211CoreOOCOTask
  • TwoEdgeSeparation : JY5211CoreOO::JY5211CoreOOCITask
  • TwoPulseEncoder : JY5211CoreOO::JY5211CoreOOCITask
  • Type : JY5211CoreOO::CITrigger, JY5211CoreOO::COTrigger, JY5211CoreOO::JY5211CoreOOCITask

- z -

  • ZInputTerminal : JY5211CoreOO::QuadEncoder
  • ZReloadEnabled : JY5211CoreOO::QuadEncoder


5211 C++ Programming Manual: File Members

  • File List
  • File Members
  • All
  • Macros
Here is a list of all file members with links to the files they belong to:
  • EXTERN_C : JY5211CoreOOCommon.h
  • JY5211CoreOO_API : JY5211CoreOOCommon.h


5211 C++ Programming Manual: File Members

  • File List
  • File Members
  • All
  • Macros
Here is a list of all macros with links to the files they belong to:
  • EXTERN_C : JY5211CoreOOCommon.h
  • JY5211CoreOO_API : JY5211CoreOOCommon.h


5211 C++ Programming Manual: Main Page

5211 C++ Programming Manual Documentation


5211 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • c
  • e
  • g
  • i
  • j
  • l
  • o
  • p
  • q
  • r
  • s
  • v
Here is a list of all namespace members with links to the namespace documentation for each member:

- c -

  • CIDigitalTriggerEdge : JY5211CoreOO
  • CIDigitalTriggerSource : JY5211CoreOO
  • CIMode : JY5211CoreOO
  • CISampleClockSource : JY5211CoreOO
  • CISignalExportSource : JY5211CoreOO
  • CITimebaseSource : JY5211CoreOO
  • CITriggerType : JY5211CoreOO
  • CIType : JY5211CoreOO
  • ClockTerminal : JY5211CoreOO
  • CODigitalTriggerEdge : JY5211CoreOO
  • CODigitalTriggerSource : JY5211CoreOO
  • COIdleState : JY5211CoreOO
  • COMode : JY5211CoreOO
  • COPulseType : JY5211CoreOO
  • COSignalExportSource : JY5211CoreOO
  • COTimebaseSource : JY5211CoreOO
  • COTriggerType : JY5211CoreOO
  • CountDirection : JY5211CoreOO

- e -

  • EdgeCntOunEvtIdleState : JY5211CoreOO
  • EdgeType : JY5211CoreOO
  • ExternalReferenceClockTerminal : JY5211CoreOO

- g -

  • GetSignalExportDestinationString() : JY5211CoreOO

- i -

  • InputTerminal : JY5211CoreOO
  • IOTerminal : JY5211CoreOO

- j -

  • JY5211CoreOOLogLevel : JY5211CoreOO
  • JY5211CoreOOPropertyType : JY5211CoreOO
  • JYDriverExceptionPublic : JY5211CoreOO
  • JYErrorCode : JY5211CoreOO

- l -

  • LevelPolarity : JY5211CoreOO

- o -

  • OutputCompleteState : JY5211CoreOO
  • OutputState : JY5211CoreOO

- p -

  • PFITerminal : JY5211CoreOO

- q -

  • QuadEncodingType : JY5211CoreOO

- r -

  • ReferenceClockSource : JY5211CoreOO

- s -

  • SignalExportDestination : JY5211CoreOO
  • SyncTopology : JY5211CoreOO
  • SyncTriggerRouting : JY5211CoreOO

- v -

  • ValueReturnMode : JY5211CoreOO


5211 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • c
  • e
  • i
  • j
  • l
  • o
  • p
  • q
  • r
  • s
  • v
Here is a list of all namespace enums with links to the namespace documentation for each enum:

- c -

  • CIDigitalTriggerEdge : JY5211CoreOO
  • CIDigitalTriggerSource : JY5211CoreOO
  • CIMode : JY5211CoreOO
  • CISampleClockSource : JY5211CoreOO
  • CISignalExportSource : JY5211CoreOO
  • CITimebaseSource : JY5211CoreOO
  • CITriggerType : JY5211CoreOO
  • CIType : JY5211CoreOO
  • ClockTerminal : JY5211CoreOO
  • CODigitalTriggerEdge : JY5211CoreOO
  • CODigitalTriggerSource : JY5211CoreOO
  • COIdleState : JY5211CoreOO
  • COMode : JY5211CoreOO
  • COPulseType : JY5211CoreOO
  • COSignalExportSource : JY5211CoreOO
  • COTimebaseSource : JY5211CoreOO
  • COTriggerType : JY5211CoreOO
  • CountDirection : JY5211CoreOO

- e -

  • EdgeCntOunEvtIdleState : JY5211CoreOO
  • EdgeType : JY5211CoreOO
  • ExternalReferenceClockTerminal : JY5211CoreOO

- i -

  • InputTerminal : JY5211CoreOO
  • IOTerminal : JY5211CoreOO

- j -

  • JY5211CoreOOLogLevel : JY5211CoreOO
  • JY5211CoreOOPropertyType : JY5211CoreOO
  • JYDriverExceptionPublic : JY5211CoreOO
  • JYErrorCode : JY5211CoreOO

- l -

  • LevelPolarity : JY5211CoreOO

- o -

  • OutputCompleteState : JY5211CoreOO
  • OutputState : JY5211CoreOO

- p -

  • PFITerminal : JY5211CoreOO

- q -

  • QuadEncodingType : JY5211CoreOO

- r -

  • ReferenceClockSource : JY5211CoreOO

- s -

  • SignalExportDestination : JY5211CoreOO
  • SyncTopology : JY5211CoreOO
  • SyncTriggerRouting : JY5211CoreOO

- v -

  • ValueReturnMode : JY5211CoreOO


5211 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
Here is a list of all namespace functions with links to the namespace documentation for each function:
  • GetSignalExportDestinationString() : JY5211CoreOO


5211 C++ Programming Manual: Namespace List

  • Namespace List
  • Namespace Members
Namespace List
Here is a list of all namespaces with brief descriptions:
N JY5211CoreOO