5310 C++ Programming Manual: 5310C++ Directory Reference

5310 C++ Programming Manual
  • 5310C++
5310C++ Directory Reference

Files

file JY5310.h
@SectionBegin JY5310FileHead
Generated by doxygen 1.9.1


5310 C++ Programming Manual: 5310C++/JY5310.h File Reference

  • 5310C++
Typedefs | Enumerations | Functions
JY5310.h File Reference

@SectionBegin JY5310FileHead More...

Typedefs

typedef void * JY5310_DeviceHandle
Windows. More...

Enumerations

enum | JY5310_AI_SampleMode { JY5310_AI_Finite = 0x0 , JY5310_AI_Continuous = 0x1 , JY5310_AI_Single = 0x2 }
enum | JY5310_TriggerMode { JY5310_StartTrigger = 0x0 , JY5310_ReferenceTrigger = 0x1 }
enum | JY5310_AI_TriggerType { JY5310_AI_Immediately = 0x0 , JY5310_AI_Digital = 0x1 , JY5310_AI_Analog = 0x2 , JY5310_AI_Soft = 0x3 }
enum | JY5310_DigitalTriggerEdge { JY5310_Rising = 0x0 , JY5310_Falling = 0x1 }
enum | JY5310_AnalogTriggerCondition { JY5310_RisingHysteresis = 0x0 , JY5310_FallingHysteresis = 0x1 , JY5310_EnteringWindow = 0x2 , JY5310_LeavingWindow = 0x3 }
enum | JY5310_AI_ClockSource { JY5310_AI_InternalClock = 0x0 , JY5310_AI_ExternalClock = 0x1 }
enum JY5310_AI_ExternalClockTerminal {
JY5310_Clock_PXI_Trig_0 = 0 , JY5310_Clock_PXI_Trig_1 = 1 , JY5310_Clock_PXI_Trig_2 = 2 , JY5310_Clock_PXI_Trig_3 = 3 ,
JY5310_Clock_PXI_Trig_4 = 4 , JY5310_Clock_PXI_Trig_5 = 5 , JY5310_Clock_PXI_Trig_6 = 6 , JY5310_Clock_PXI_Trig_7 = 7 ,
JY5310_Clock_PFI_0 = 16 , JY5310_Clock_PFI_1 = 17 , JY5310_Clock_PFI_2 = 18 , JY5310_Clock_PFI_3 = 19 ,
JY5310_Clock_PFI_4 = 20 , JY5310_Clock_PFI_5 = 21 , JY5310_Clock_PFI_6 = 22 , JY5310_Clock_PFI_7 = 23 ,
JY5310_Clock_PFI_8 = 24 , JY5310_Clock_PFI_9 = 25 , JY5310_Clock_PFI_10 = 26 , JY5310_Clock_PFI_11 = 27 ,
JY5310_Clock_PFI_12 = 28 , JY5310_Clock_PFI_13 = 29 , JY5310_Clock_PFI_14 = 30 , JY5310_Clock_PFI_15 = 31
}
enum | JY5310_DeviceProperty { JY5310_Independent = 0 , JY5310_MASTER = 1 , JY5310_SLAVE = 3 }
enum JY5310_Signal_Source {
JY5310_RM_IN_RX_AI_START_TRIGGER_OUT =11 , JY5310_RM_IN_RX_AI_REF_TRIGGER_OUT =12 , JY5310_RM_IN_RX_AI_AD_TRIGGER_OUT =13 , JY5310_RM_IN_RX_AI_END_OF_RECORD =14 ,
JY5310_RM_IN_RX_AI_END_OF_ACQUISITION =15 , JY5310_RM_IN_PFI_0 = 16 , JY5310_RM_IN_PFI_1 = 17 , JY5310_RM_IN_PFI_2 = 18 ,
JY5310_RM_IN_PFI_3 = 19 , JY5310_RM_IN_PFI_4 = 20 , JY5310_RM_IN_PFI_5 = 21 , JY5310_RM_IN_PFI_6 = 22 ,
JY5310_RM_IN_PFI_7 = 23 , JY5310_RM_IN_PFI_8 = 24 , JY5310_RM_IN_PFI_9 = 25 , JY5310_RM_IN_PFI_10 = 26 ,
JY5310_RM_IN_PFI_11 = 27 , JY5310_RM_IN_PFI_12 = 28 , JY5310_RM_IN_PFI_13 = 29 , JY5310_RM_IN_PFI_14 = 30 ,
JY5310_RM_IN_PFI_15 = 31 , JY5310_RM_IN_RX_DI_START_TRIGGER_OUT = 48 , JY5310_RM_IN_RX_DI_REF_TRIGGER_OUT = 49 , JY5310_RM_IN_RX_DI_AD_TRIGGER_OUT = 50 ,
JY5310_RM_IN_TX_DO_START_TRIGGER_OUT =51 , JY5310_RM_IN_TX_DO_GENERATION_DONE =52 , JY5310_RM_IN_ANALOG_TRIGGER_OUT =55 , JY5310_RM_IN_CLOCK_MANAGER_MASTER_TRIGGER_OUT =56 ,
JY5310_RM_IN_AI_SAMPLE_CLOCK_OUTPUT = 59 , JY5310_RM_IN_PXITRIGGER0 = 64 , JY5310_RM_IN_PXITRIGGER1 = 65 , JY5310_RM_IN_PXITRIGGER2 = 66 ,
JY5310_RM_IN_PXITRIGGER3 = 67 , JY5310_RM_IN_PXITRIGGER4 = 68 , JY5310_RM_IN_PXITRIGGER5 = 69 , JY5310_RM_IN_PXITRIGGER6 = 70 ,
JY5310_RM_IN_PXITRIGGER7 = 71
}
enum JY5310_Signal_Destination {
JY5310_RM_OUT_PXITRIGGER0 = 0 , JY5310_RM_OUT_PXITRIGGER1 = 1 , JY5310_RM_OUT_PXITRIGGER2 = 2 , JY5310_RM_OUT_PXITRIGGER3 = 3 ,
JY5310_RM_OUT_PXITRIGGER4 = 4 , JY5310_RM_OUT_PXITRIGGER5 = 5 , JY5310_RM_OUT_PXITRIGGER6 = 6 , JY5310_RM_OUT_PXITRIGGER7 = 7 ,
JY5310_RM_OUT_RX_AI_START_TRIGGER_IN = 8 , JY5310_RM_OUT_RX_AI_REF_TRIGGER_IN = 9 , JY5310_RM_OUT_RX_AI_AD_TRIGGER_IN = 10 , JY5310_RM_OUT_RX_DI_START_TRIGGER_IN = 13 ,
JY5310_RM_OUT_RX_DI_REF_TRIGGER_IN = 14 , JY5310_RM_OUT_RX_DI_AD_TRIGGER_IN = 15 , JY5310_RM_OUT_PFI_0 = 16 , JY5310_RM_OUT_PFI_1 = 17 ,
JY5310_RM_OUT_PFI_2 = 18 , JY5310_RM_OUT_PFI_3 = 19 , JY5310_RM_OUT_PFI_4 = 20 , JY5310_RM_OUT_PFI_5 = 21 ,
JY5310_RM_OUT_PFI_6 = 22 , JY5310_RM_OUT_PFI_7 = 23 , JY5310_RM_OUT_PFI_8 = 24 , JY5310_RM_OUT_PFI_9 = 25 ,
JY5310_RM_OUT_PFI_10 = 26 , JY5310_RM_OUT_PFI_11 = 27 , JY5310_RM_OUT_PFI_12 = 28 , JY5310_RM_OUT_PFI_13 = 29 ,
JY5310_RM_OUT_PFI_14 = 30 , JY5310_RM_OUT_PFI_15 = 31 , JY5310_RM_IN_TX_DO_START_TRIGGER_IN = 32 , JY5310_RM_IN_PARALLEL_DI_EXT_CLK = 33 ,
JY5310_RM_OUT_PARALLEL_DO_EXT_CLK = 34 , JY5310_RM_OUT_CLOCK_MANAGER_TRIGGER_IN = 35 , JT5310_AI_SAMPLE_CLOCK_INPUT = 36
}
enum | DeviceTimeBaseSource { ReferenceOnboard_25M = 0 , ReferencePXIeCLK_100M = 1 }

Functions

JY5310API int | JY5310_Open (int slotNumber, JY5310_DeviceHandle *hDevice)
打开板卡资源 More...
JY5310API int | JY5310_OpenByAliasName (const char *aliasName, JY5310_DeviceHandle *hDevice)
打开板卡资源 More...
JY5310API int | JY5310_Close (JY5310_DeviceHandle hDevice)
关闭板卡资源 More...
JY5310API int | JY5310_SetDeviceProperty (JY5310_DeviceHandle hDevice, JY5310_DeviceProperty devicePrepety)
JY5310API int | JY5310_SetDeviceTimeBase (JY5310_DeviceHandle hDevice, DeviceTimeBaseSource timeBaseSource, double phase, int clockDelay)
JY5310API int | JY5310_SignalRouting (JY5310_DeviceHandle hDevice, JY5310_Signal_Source sourceSignal, JY5310_Signal_Destination distination)
JY5310API int | JY5310_DisconnectSignalRouting (JY5310_DeviceHandle hDevice, JY5310_Signal_Source source, JY5310_Signal_Destination destination)
JY5310API int | JY5310_AI_EnableChannel (JY5310_DeviceHandle hDevice, unsigned int channelCount, unsigned char *channels, double *lowRegion, double *highRegion)
使能通道 More...
JY5310API int | JY5310_AI_SetMode (JY5310_DeviceHandle hDevice, JY5310_AI_SampleMode mode)
配置AI采集模式 More...
JY5310API int | JY5310_AI_SetSampleRate (JY5310_DeviceHandle hDevice, double sampleRate, double *actualSampleRate)
配置AI采样速率 More...
JY5310API int | JY5310_AI_SetSamplesToAcquire (JY5310_DeviceHandle hDevice, unsigned int sampleToAcquire)
配置AI有限采集点数 More...
JY5310API int | JY5310_AI_Start (JY5310_DeviceHandle hDevice)
启动AI More...
JY5310API int | JY5310_AI_ReadData (JY5310_DeviceHandle hDevice, double *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
读取数据 More...
JY5310API int | JY5310_AI_Stop (JY5310_DeviceHandle hDevice)
停止AI More...
JY5310API int | JY5310_AI_ReadRawData (JY5310_DeviceHandle hDevice, short *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
读取原始数据 More...
JY5310API int | JY5310_AI_SetClockSource (JY5310_DeviceHandle hDevice, JY5310_AI_ClockSource clockSource, JY5310_AI_ExternalClockTerminal terminal, double expectedRate)
设置AI采样时钟 More...
JY5310API int | JY5310_AI_ReadSinglePoint (JY5310_DeviceHandle hDevice, double *dataBuffer, unsigned int channelCount)
读取单点值 More...
JY5310API int | JY5310_AI_SetTriggerMode (JY5310_DeviceHandle hDevice, JY5310_TriggerMode triggerMode)
读取单点值 More...
JY5310API int | JY5310_AI_SetStartTriggerType (JY5310_DeviceHandle hDevice, JY5310_AI_TriggerType triggerType)
设置开始触发模式 More...
JY5310API int | JY5310_AI_SetDigitalStartTrigger (JY5310_DeviceHandle hDevice, JY5310_Signal_Source triggerSource, JY5310_DigitalTriggerEdge triggerEdge)
数字开始触发 More...
JY5310API int | JY5310_AI_SetAnalogStartTrigger (JY5310_DeviceHandle hDevice, int triggerSource, JY5310_AnalogTriggerCondition triggerCondition, double highThreshold, double lowThreshold)
模拟开始触发 AnalogTriggerSource 16 channals, every channel can be a trigger source, triggerSource 0-15 More...
JY5310API int | JY5310_AI_SetReferenceTriggerType (JY5310_DeviceHandle hDevice, JY5310_AI_TriggerType triggerType)
设置参考触发模式 More...
JY5310API int | JY5310_AI_SetDigitalReferenceTrigger (JY5310_DeviceHandle hDevice, JY5310_Signal_Source triggerSource, JY5310_DigitalTriggerEdge triggerEdge)
数字参考触发 More...
JY5310API int | JY5310_AI_SetAnalogReferenceTrigger (JY5310_DeviceHandle hDevice, int triggerSource, JY5310_AnalogTriggerCondition triggerCondition, double highThreshold, double lowThreshold)
模拟参考触发 AnalogTriggerSource 16 channals, every channel can be a trigger source, triggerSource 0-15 More...
JY5310API int | JY5310_AI_SetPreTriggerSamples (JY5310_DeviceHandle hDevice, unsigned int preTriggerSamples)
设置预触发点数 More...
JY5310API int | JY5310_AI_SetReTriggerCount (JY5310_DeviceHandle hDevice, unsigned long long reTriggerCount)
设置重复触发次数 More...
JY5310API int | JY5310_AI_SendSoftTrigger (JY5310_DeviceHandle hDevice, JY5310_TriggerMode triggerMode)
发送软件触发 More...
JY5310API int | JY5310_AI_WaitUntilDone (JY5310_DeviceHandle hDevice, bool *done)
有限采集是否完成 More...
JY5310API int | JY5310_AI_SetBufferSize (JY5310_DeviceHandle hDevice, unsigned long bufferSize)
设置缓冲区大小 More...
JY5310API int | JY5310_AI_CheckBufferStatus (JY5310_DeviceHandle hDevice, unsigned long long *avaliableSamples, bool *overrun)
获取缓冲区状态 More...
JY5310API int | JY5310_DisableDigitalTriggerDelay (JY5310_DeviceHandle hDevice, bool enable)
JY5310API int | JY5310_DI_AddLines (JY5310_DeviceHandle hDevice, unsigned int *port, unsigned int portCount)
添加DI通道 More...
JY5310API int | JY5310_DI_ReadSinglePoint (JY5310_DeviceHandle hDevice, unsigned int *dataBuffer)
DI读取单点数据 More...
JY5310API int | JY5310_DI_Start (JY5310_DeviceHandle hDevice)
DI开始 More...
JY5310API int | JY5310_DI_Stop (JY5310_DeviceHandle hDevice)
DI停止 More...
JY5310API int | JY5310_DO_AddLines (JY5310_DeviceHandle hDevice, unsigned int *port, unsigned int portCount)
添加DO通道 More...
JY5310API int | JY5310_DO_WriteSinglePoint (JY5310_DeviceHandle hDevice, unsigned int dataBuffer)
D0写入单点数据 More...
JY5310API int | JY5310_DO_WriteSinglePortPoint (JY5310_DeviceHandle hDevice, unsigned int dataBuffer, int port)
D0写入单点数据 More...
JY5310API int | JY5310_DO_Start (JY5310_DeviceHandle hDevice)
DO开始 More...
JY5310API int | JY5310_DO_Stop (JY5310_DeviceHandle hDevice)
DO停止 More...
JY5310API int | JY5310_DisableAICalibration (JY5310_DeviceHandle hDevice, bool DisableCalibration)
JY5310API int | JY5310_GetAICalibration (JY5310_DeviceHandle hDevice)

Detailed Description

@SectionBegin JY5310FileHead

COPYRIGHT NOTICE(版权声明)
Copyright (c) 2018, JYTEK
All rights reserved.
Author
JYTEK wenlin.li
Version
0.0.1
Date
2018-2-23

定义了JY5310的API，在应用程序中可以通过引用该头文件来 使用该数据采集卡API

修订说明：

Typedef Documentation

◆ JY5310_DeviceHandle

typedef void* JY5310_DeviceHandle

Windows.

Linux

Enumeration Type Documentation

◆ DeviceTimeBaseSource

enum DeviceTimeBaseSource
Enumerator
ReferenceOnboard_25M
ReferencePXIeCLK_100M

◆ JY5310_AI_ClockSource

enum JY5310_AI_ClockSource
Enumerator
JY5310_AI_InternalClock
JY5310_AI_ExternalClock

◆ JY5310_AI_ExternalClockTerminal

enum JY5310_AI_ExternalClockTerminal
Enumerator
JY5310_Clock_PXI_Trig_0
JY5310_Clock_PXI_Trig_1
JY5310_Clock_PXI_Trig_2
JY5310_Clock_PXI_Trig_3
JY5310_Clock_PXI_Trig_4
JY5310_Clock_PXI_Trig_5
JY5310_Clock_PXI_Trig_6
JY5310_Clock_PXI_Trig_7
JY5310_Clock_PFI_0
JY5310_Clock_PFI_1
JY5310_Clock_PFI_2
JY5310_Clock_PFI_3
JY5310_Clock_PFI_4
JY5310_Clock_PFI_5
JY5310_Clock_PFI_6
JY5310_Clock_PFI_7
JY5310_Clock_PFI_8
JY5310_Clock_PFI_9
JY5310_Clock_PFI_10
JY5310_Clock_PFI_11
JY5310_Clock_PFI_12
JY5310_Clock_PFI_13
JY5310_Clock_PFI_14
JY5310_Clock_PFI_15

◆ JY5310_AI_SampleMode

enum JY5310_AI_SampleMode
Enumerator
JY5310_AI_Finite
JY5310_AI_Continuous
JY5310_AI_Single

◆ JY5310_AI_TriggerType

enum JY5310_AI_TriggerType
Enumerator
JY5310_AI_Immediately
JY5310_AI_Digital
JY5310_AI_Analog
JY5310_AI_Soft

◆ JY5310_AnalogTriggerCondition

enum JY5310_AnalogTriggerCondition
Enumerator
JY5310_RisingHysteresis
JY5310_FallingHysteresis
JY5310_EnteringWindow
JY5310_LeavingWindow

◆ JY5310_DeviceProperty

enum JY5310_DeviceProperty
Enumerator
JY5310_Independent
JY5310_MASTER
JY5310_SLAVE

◆ JY5310_DigitalTriggerEdge

enum JY5310_DigitalTriggerEdge
Enumerator
JY5310_Rising
JY5310_Falling

◆ JY5310_Signal_Destination

enum JY5310_Signal_Destination
Enumerator
JY5310_RM_OUT_PXITRIGGER0
JY5310_RM_OUT_PXITRIGGER1
JY5310_RM_OUT_PXITRIGGER2
JY5310_RM_OUT_PXITRIGGER3
JY5310_RM_OUT_PXITRIGGER4
JY5310_RM_OUT_PXITRIGGER5
JY5310_RM_OUT_PXITRIGGER6
JY5310_RM_OUT_PXITRIGGER7
JY5310_RM_OUT_RX_AI_START_TRIGGER_IN
JY5310_RM_OUT_RX_AI_REF_TRIGGER_IN
JY5310_RM_OUT_RX_AI_AD_TRIGGER_IN
JY5310_RM_OUT_RX_DI_START_TRIGGER_IN
JY5310_RM_OUT_RX_DI_REF_TRIGGER_IN
JY5310_RM_OUT_RX_DI_AD_TRIGGER_IN
JY5310_RM_OUT_PFI_0
JY5310_RM_OUT_PFI_1
JY5310_RM_OUT_PFI_2
JY5310_RM_OUT_PFI_3
JY5310_RM_OUT_PFI_4
JY5310_RM_OUT_PFI_5
JY5310_RM_OUT_PFI_6
JY5310_RM_OUT_PFI_7
JY5310_RM_OUT_PFI_8
JY5310_RM_OUT_PFI_9
JY5310_RM_OUT_PFI_10
JY5310_RM_OUT_PFI_11
JY5310_RM_OUT_PFI_12
JY5310_RM_OUT_PFI_13
JY5310_RM_OUT_PFI_14
JY5310_RM_OUT_PFI_15
JY5310_RM_IN_TX_DO_START_TRIGGER_IN
JY5310_RM_IN_PARALLEL_DI_EXT_CLK
JY5310_RM_OUT_PARALLEL_DO_EXT_CLK
JY5310_RM_OUT_CLOCK_MANAGER_TRIGGER_IN
JT5310_AI_SAMPLE_CLOCK_INPUT

◆ JY5310_Signal_Source

enum JY5310_Signal_Source
Enumerator
JY5310_RM_IN_RX_AI_START_TRIGGER_OUT
JY5310_RM_IN_RX_AI_REF_TRIGGER_OUT
JY5310_RM_IN_RX_AI_AD_TRIGGER_OUT
JY5310_RM_IN_RX_AI_END_OF_RECORD
JY5310_RM_IN_RX_AI_END_OF_ACQUISITION
JY5310_RM_IN_PFI_0
JY5310_RM_IN_PFI_1
JY5310_RM_IN_PFI_2
JY5310_RM_IN_PFI_3
JY5310_RM_IN_PFI_4
JY5310_RM_IN_PFI_5
JY5310_RM_IN_PFI_6
JY5310_RM_IN_PFI_7
JY5310_RM_IN_PFI_8
JY5310_RM_IN_PFI_9
JY5310_RM_IN_PFI_10
JY5310_RM_IN_PFI_11
JY5310_RM_IN_PFI_12
JY5310_RM_IN_PFI_13
JY5310_RM_IN_PFI_14
JY5310_RM_IN_PFI_15
JY5310_RM_IN_RX_DI_START_TRIGGER_OUT
JY5310_RM_IN_RX_DI_REF_TRIGGER_OUT
JY5310_RM_IN_RX_DI_AD_TRIGGER_OUT
JY5310_RM_IN_TX_DO_START_TRIGGER_OUT
JY5310_RM_IN_TX_DO_GENERATION_DONE
JY5310_RM_IN_ANALOG_TRIGGER_OUT
JY5310_RM_IN_CLOCK_MANAGER_MASTER_TRIGGER_OUT
JY5310_RM_IN_AI_SAMPLE_CLOCK_OUTPUT
JY5310_RM_IN_PXITRIGGER0
JY5310_RM_IN_PXITRIGGER1
JY5310_RM_IN_PXITRIGGER2
JY5310_RM_IN_PXITRIGGER3
JY5310_RM_IN_PXITRIGGER4
JY5310_RM_IN_PXITRIGGER5
JY5310_RM_IN_PXITRIGGER6
JY5310_RM_IN_PXITRIGGER7

◆ JY5310_TriggerMode

enum JY5310_TriggerMode
Enumerator
JY5310_StartTrigger
JY5310_ReferenceTrigger

Function Documentation

◆ JY5310_AI_CheckBufferStatus()

JY5310API int JY5310_AI_CheckBufferStatus | ( | JY5310_DeviceHandle | hDevice,
 |  | unsigned long long * | avaliableSamples,
 |  | bool * | overrun
 | ) |  |

获取缓冲区状态

◆ JY5310_AI_EnableChannel()

JY5310API int JY5310_AI_EnableChannel | ( | JY5310_DeviceHandle | hDevice,
 |  | unsigned int | channelCount,
 |  | unsigned char * | channels,
 |  | double * | lowRegion,
 |  | double * | highRegion
 | ) |  |

使能通道

◆ JY5310_AI_ReadData()

JY5310API int JY5310_AI_ReadData | ( | JY5310_DeviceHandle | hDevice,
 |  | double * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength
 | ) |  |

读取数据

◆ JY5310_AI_ReadRawData()

JY5310API int JY5310_AI_ReadRawData | ( | JY5310_DeviceHandle | hDevice,
 |  | short * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength
 | ) |  |

读取原始数据

◆ JY5310_AI_ReadSinglePoint()

JY5310API int JY5310_AI_ReadSinglePoint | ( | JY5310_DeviceHandle | hDevice,
 |  | double * | dataBuffer,
 |  | unsigned int | channelCount
 | ) |  |

读取单点值

◆ JY5310_AI_SendSoftTrigger()

JY5310API int JY5310_AI_SendSoftTrigger | ( | JY5310_DeviceHandle | hDevice,
 |  | JY5310_TriggerMode | triggerMode
 | ) |  |

发送软件触发

◆ JY5310_AI_SetAnalogReferenceTrigger()

JY5310API int JY5310_AI_SetAnalogReferenceTrigger | ( | JY5310_DeviceHandle | hDevice,
 |  | int | triggerSource,
 |  | JY5310_AnalogTriggerCondition | triggerCondition,
 |  | double | highThreshold,
 |  | double | lowThreshold
 | ) |  |

模拟参考触发 AnalogTriggerSource 16 channals, every channel can be a trigger source, triggerSource 0-15

◆ JY5310_AI_SetAnalogStartTrigger()

JY5310API int JY5310_AI_SetAnalogStartTrigger | ( | JY5310_DeviceHandle | hDevice,
 |  | int | triggerSource,
 |  | JY5310_AnalogTriggerCondition | triggerCondition,
 |  | double | highThreshold,
 |  | double | lowThreshold
 | ) |  |

模拟开始触发 AnalogTriggerSource 16 channals, every channel can be a trigger source, triggerSource 0-15

◆ JY5310_AI_SetBufferSize()

JY5310API int JY5310_AI_SetBufferSize | ( | JY5310_DeviceHandle | hDevice,
 |  | unsigned long | bufferSize
 | ) |  |

设置缓冲区大小

◆ JY5310_AI_SetClockSource()

JY5310API int JY5310_AI_SetClockSource | ( | JY5310_DeviceHandle | hDevice,
 |  | JY5310_AI_ClockSource | clockSource,
 |  | JY5310_AI_ExternalClockTerminal | terminal,
 |  | double | expectedRate
 | ) |  |

设置AI采样时钟

◆ JY5310_AI_SetDigitalReferenceTrigger()

JY5310API int JY5310_AI_SetDigitalReferenceTrigger | ( | JY5310_DeviceHandle | hDevice,
 |  | JY5310_Signal_Source | triggerSource,
 |  | JY5310_DigitalTriggerEdge | triggerEdge
 | ) |  |

数字参考触发

◆ JY5310_AI_SetDigitalStartTrigger()

JY5310API int JY5310_AI_SetDigitalStartTrigger | ( | JY5310_DeviceHandle | hDevice,
 |  | JY5310_Signal_Source | triggerSource,
 |  | JY5310_DigitalTriggerEdge | triggerEdge
 | ) |  |

数字开始触发

◆ JY5310_AI_SetMode()

JY5310API int JY5310_AI_SetMode | ( | JY5310_DeviceHandle | hDevice,
 |  | JY5310_AI_SampleMode | mode
 | ) |  |

配置AI采集模式

◆ JY5310_AI_SetPreTriggerSamples()

JY5310API int JY5310_AI_SetPreTriggerSamples | ( | JY5310_DeviceHandle | hDevice,
 |  | unsigned int | preTriggerSamples
 | ) |  |

设置预触发点数

◆ JY5310_AI_SetReferenceTriggerType()

JY5310API int JY5310_AI_SetReferenceTriggerType | ( | JY5310_DeviceHandle | hDevice,
 |  | JY5310_AI_TriggerType | triggerType
 | ) |  |

设置参考触发模式

◆ JY5310_AI_SetReTriggerCount()

JY5310API int JY5310_AI_SetReTriggerCount | ( | JY5310_DeviceHandle | hDevice,
 |  | unsigned long long | reTriggerCount
 | ) |  |

设置重复触发次数

◆ JY5310_AI_SetSampleRate()

JY5310API int JY5310_AI_SetSampleRate | ( | JY5310_DeviceHandle | hDevice,
 |  | double | sampleRate,
 |  | double * | actualSampleRate
 | ) |  |

配置AI采样速率

◆ JY5310_AI_SetSamplesToAcquire()

JY5310API int JY5310_AI_SetSamplesToAcquire | ( | JY5310_DeviceHandle | hDevice,
 |  | unsigned int | sampleToAcquire
 | ) |  |

配置AI有限采集点数

◆ JY5310_AI_SetStartTriggerType()

JY5310API int JY5310_AI_SetStartTriggerType | ( | JY5310_DeviceHandle | hDevice,
 |  | JY5310_AI_TriggerType | triggerType
 | ) |  |

设置开始触发模式

◆ JY5310_AI_SetTriggerMode()

JY5310API int JY5310_AI_SetTriggerMode | ( | JY5310_DeviceHandle | hDevice,
 |  | JY5310_TriggerMode | triggerMode
 | ) |  |

读取单点值

◆ JY5310_AI_Start()

JY5310API int JY5310_AI_Start ( JY5310_DeviceHandle hDevice )

启动AI

◆ JY5310_AI_Stop()

JY5310API int JY5310_AI_Stop ( JY5310_DeviceHandle hDevice )

停止AI

◆ JY5310_AI_WaitUntilDone()

JY5310API int JY5310_AI_WaitUntilDone | ( | JY5310_DeviceHandle | hDevice,
 |  | bool * | done
 | ) |  |

有限采集是否完成

◆ JY5310_Close()

JY5310API int JY5310_Close ( JY5310_DeviceHandle hDevice )

关闭板卡资源

◆ JY5310_DI_AddLines()

JY5310API int JY5310_DI_AddLines | ( | JY5310_DeviceHandle | hDevice,
 |  | unsigned int * | port,
 |  | unsigned int | portCount
 | ) |  |

添加DI通道

◆ JY5310_DI_ReadSinglePoint()

JY5310API int JY5310_DI_ReadSinglePoint | ( | JY5310_DeviceHandle | hDevice,
 |  | unsigned int * | dataBuffer
 | ) |  |

DI读取单点数据

◆ JY5310_DI_Start()

JY5310API int JY5310_DI_Start ( JY5310_DeviceHandle hDevice )

DI开始

◆ JY5310_DI_Stop()

JY5310API int JY5310_DI_Stop ( JY5310_DeviceHandle hDevice )

DI停止

◆ JY5310_DisableAICalibration()

JY5310API int JY5310_DisableAICalibration | ( | JY5310_DeviceHandle | hDevice,
 |  | bool | DisableCalibration
 | ) |  |

◆ JY5310_DisableDigitalTriggerDelay()

JY5310API int JY5310_DisableDigitalTriggerDelay | ( | JY5310_DeviceHandle | hDevice,
 |  | bool | enable
 | ) |  |

◆ JY5310_DisconnectSignalRouting()

JY5310API int JY5310_DisconnectSignalRouting | ( | JY5310_DeviceHandle | hDevice,
 |  | JY5310_Signal_Source | source,
 |  | JY5310_Signal_Destination | destination
 | ) |  |

◆ JY5310_DO_AddLines()

JY5310API int JY5310_DO_AddLines | ( | JY5310_DeviceHandle | hDevice,
 |  | unsigned int * | port,
 |  | unsigned int | portCount
 | ) |  |

添加DO通道

◆ JY5310_DO_Start()

JY5310API int JY5310_DO_Start ( JY5310_DeviceHandle hDevice )

DO开始

◆ JY5310_DO_Stop()

JY5310API int JY5310_DO_Stop ( JY5310_DeviceHandle hDevice )

DO停止

◆ JY5310_DO_WriteSinglePoint()

JY5310API int JY5310_DO_WriteSinglePoint | ( | JY5310_DeviceHandle | hDevice,
 |  | unsigned int | dataBuffer
 | ) |  |

D0写入单点数据

◆ JY5310_DO_WriteSinglePortPoint()

JY5310API int JY5310_DO_WriteSinglePortPoint | ( | JY5310_DeviceHandle | hDevice,
 |  | unsigned int | dataBuffer,
 |  | int | port
 | ) |  |

D0写入单点数据

◆ JY5310_GetAICalibration()

JY5310API int JY5310_GetAICalibration ( JY5310_DeviceHandle hDevice )

◆ JY5310_Open()

JY5310API int JY5310_Open | ( | int | slotNumber,
 |  | JY5310_DeviceHandle * | hDevice
 | ) |  |

打开板卡资源

◆ JY5310_OpenByAliasName()

JY5310API int JY5310_OpenByAliasName | ( | const char * | aliasName,
 |  | JY5310_DeviceHandle * | hDevice
 | ) |  |

打开板卡资源

◆ JY5310_SetDeviceProperty()

JY5310API int JY5310_SetDeviceProperty | ( | JY5310_DeviceHandle | hDevice,
 |  | JY5310_DeviceProperty | devicePrepety
 | ) |  |

◆ JY5310_SetDeviceTimeBase()

JY5310API int JY5310_SetDeviceTimeBase | ( | JY5310_DeviceHandle | hDevice,
 |  | DeviceTimeBaseSource | timeBaseSource,
 |  | double | phase,
 |  | int | clockDelay
 | ) |  |

◆ JY5310_SignalRouting()

JY5310API int JY5310_SignalRouting | ( | JY5310_DeviceHandle | hDevice,
 |  | JY5310_Signal_Source | sourceSignal,
 |  | JY5310_Signal_Destination | distination
 | ) |  |


5310 C++ Programming Manual: File List

File List
Here is a list of all files with brief descriptions:
[detail level 12]
▼ 5310C++ |
JY5310.h | @SectionBegin JY5310FileHead


5310 C++ Programming Manual: File Members

Here is a list of all file members with links to the files they belong to:

- d -

  • DeviceTimeBaseSource : JY5310.h

- j -

  • JT5310_AI_SAMPLE_CLOCK_INPUT : JY5310.h
  • JY5310_AI_Analog : JY5310.h
  • JY5310_AI_CheckBufferStatus() : JY5310.h
  • JY5310_AI_ClockSource : JY5310.h
  • JY5310_AI_Continuous : JY5310.h
  • JY5310_AI_Digital : JY5310.h
  • JY5310_AI_EnableChannel() : JY5310.h
  • JY5310_AI_ExternalClock : JY5310.h
  • JY5310_AI_ExternalClockTerminal : JY5310.h
  • JY5310_AI_Finite : JY5310.h
  • JY5310_AI_Immediately : JY5310.h
  • JY5310_AI_InternalClock : JY5310.h
  • JY5310_AI_ReadData() : JY5310.h
  • JY5310_AI_ReadRawData() : JY5310.h
  • JY5310_AI_ReadSinglePoint() : JY5310.h
  • JY5310_AI_SampleMode : JY5310.h
  • JY5310_AI_SendSoftTrigger() : JY5310.h
  • JY5310_AI_SetAnalogReferenceTrigger() : JY5310.h
  • JY5310_AI_SetAnalogStartTrigger() : JY5310.h
  • JY5310_AI_SetBufferSize() : JY5310.h
  • JY5310_AI_SetClockSource() : JY5310.h
  • JY5310_AI_SetDigitalReferenceTrigger() : JY5310.h
  • JY5310_AI_SetDigitalStartTrigger() : JY5310.h
  • JY5310_AI_SetMode() : JY5310.h
  • JY5310_AI_SetPreTriggerSamples() : JY5310.h
  • JY5310_AI_SetReferenceTriggerType() : JY5310.h
  • JY5310_AI_SetReTriggerCount() : JY5310.h
  • JY5310_AI_SetSampleRate() : JY5310.h
  • JY5310_AI_SetSamplesToAcquire() : JY5310.h
  • JY5310_AI_SetStartTriggerType() : JY5310.h
  • JY5310_AI_SetTriggerMode() : JY5310.h
  • JY5310_AI_Single : JY5310.h
  • JY5310_AI_Soft : JY5310.h
  • JY5310_AI_Start() : JY5310.h
  • JY5310_AI_Stop() : JY5310.h
  • JY5310_AI_TriggerType : JY5310.h
  • JY5310_AI_WaitUntilDone() : JY5310.h
  • JY5310_AnalogTriggerCondition : JY5310.h
  • JY5310_Clock_PFI_0 : JY5310.h
  • JY5310_Clock_PFI_1 : JY5310.h
  • JY5310_Clock_PFI_10 : JY5310.h
  • JY5310_Clock_PFI_11 : JY5310.h
  • JY5310_Clock_PFI_12 : JY5310.h
  • JY5310_Clock_PFI_13 : JY5310.h
  • JY5310_Clock_PFI_14 : JY5310.h
  • JY5310_Clock_PFI_15 : JY5310.h
  • JY5310_Clock_PFI_2 : JY5310.h
  • JY5310_Clock_PFI_3 : JY5310.h
  • JY5310_Clock_PFI_4 : JY5310.h
  • JY5310_Clock_PFI_5 : JY5310.h
  • JY5310_Clock_PFI_6 : JY5310.h
  • JY5310_Clock_PFI_7 : JY5310.h
  • JY5310_Clock_PFI_8 : JY5310.h
  • JY5310_Clock_PFI_9 : JY5310.h
  • JY5310_Clock_PXI_Trig_0 : JY5310.h
  • JY5310_Clock_PXI_Trig_1 : JY5310.h
  • JY5310_Clock_PXI_Trig_2 : JY5310.h
  • JY5310_Clock_PXI_Trig_3 : JY5310.h
  • JY5310_Clock_PXI_Trig_4 : JY5310.h
  • JY5310_Clock_PXI_Trig_5 : JY5310.h
  • JY5310_Clock_PXI_Trig_6 : JY5310.h
  • JY5310_Clock_PXI_Trig_7 : JY5310.h
  • JY5310_Close() : JY5310.h
  • JY5310_DeviceHandle : JY5310.h
  • JY5310_DeviceProperty : JY5310.h
  • JY5310_DI_AddLines() : JY5310.h
  • JY5310_DI_ReadSinglePoint() : JY5310.h
  • JY5310_DI_Start() : JY5310.h
  • JY5310_DI_Stop() : JY5310.h
  • JY5310_DigitalTriggerEdge : JY5310.h
  • JY5310_DisableAICalibration() : JY5310.h
  • JY5310_DisableDigitalTriggerDelay() : JY5310.h
  • JY5310_DisconnectSignalRouting() : JY5310.h
  • JY5310_DO_AddLines() : JY5310.h
  • JY5310_DO_Start() : JY5310.h
  • JY5310_DO_Stop() : JY5310.h
  • JY5310_DO_WriteSinglePoint() : JY5310.h
  • JY5310_DO_WriteSinglePortPoint() : JY5310.h
  • JY5310_EnteringWindow : JY5310.h
  • JY5310_Falling : JY5310.h
  • JY5310_FallingHysteresis : JY5310.h
  • JY5310_GetAICalibration() : JY5310.h
  • JY5310_Independent : JY5310.h
  • JY5310_LeavingWindow : JY5310.h
  • JY5310_MASTER : JY5310.h
  • JY5310_Open() : JY5310.h
  • JY5310_OpenByAliasName() : JY5310.h
  • JY5310_ReferenceTrigger : JY5310.h
  • JY5310_Rising : JY5310.h
  • JY5310_RisingHysteresis : JY5310.h
  • JY5310_RM_IN_AI_SAMPLE_CLOCK_OUTPUT : JY5310.h
  • JY5310_RM_IN_ANALOG_TRIGGER_OUT : JY5310.h
  • JY5310_RM_IN_CLOCK_MANAGER_MASTER_TRIGGER_OUT : JY5310.h
  • JY5310_RM_IN_PARALLEL_DI_EXT_CLK : JY5310.h
  • JY5310_RM_IN_PFI_0 : JY5310.h
  • JY5310_RM_IN_PFI_1 : JY5310.h
  • JY5310_RM_IN_PFI_10 : JY5310.h
  • JY5310_RM_IN_PFI_11 : JY5310.h
  • JY5310_RM_IN_PFI_12 : JY5310.h
  • JY5310_RM_IN_PFI_13 : JY5310.h
  • JY5310_RM_IN_PFI_14 : JY5310.h
  • JY5310_RM_IN_PFI_15 : JY5310.h
  • JY5310_RM_IN_PFI_2 : JY5310.h
  • JY5310_RM_IN_PFI_3 : JY5310.h
  • JY5310_RM_IN_PFI_4 : JY5310.h
  • JY5310_RM_IN_PFI_5 : JY5310.h
  • JY5310_RM_IN_PFI_6 : JY5310.h
  • JY5310_RM_IN_PFI_7 : JY5310.h
  • JY5310_RM_IN_PFI_8 : JY5310.h
  • JY5310_RM_IN_PFI_9 : JY5310.h
  • JY5310_RM_IN_PXITRIGGER0 : JY5310.h
  • JY5310_RM_IN_PXITRIGGER1 : JY5310.h
  • JY5310_RM_IN_PXITRIGGER2 : JY5310.h
  • JY5310_RM_IN_PXITRIGGER3 : JY5310.h
  • JY5310_RM_IN_PXITRIGGER4 : JY5310.h
  • JY5310_RM_IN_PXITRIGGER5 : JY5310.h
  • JY5310_RM_IN_PXITRIGGER6 : JY5310.h
  • JY5310_RM_IN_PXITRIGGER7 : JY5310.h
  • JY5310_RM_IN_RX_AI_AD_TRIGGER_OUT : JY5310.h
  • JY5310_RM_IN_RX_AI_END_OF_ACQUISITION : JY5310.h
  • JY5310_RM_IN_RX_AI_END_OF_RECORD : JY5310.h
  • JY5310_RM_IN_RX_AI_REF_TRIGGER_OUT : JY5310.h
  • JY5310_RM_IN_RX_AI_START_TRIGGER_OUT : JY5310.h
  • JY5310_RM_IN_RX_DI_AD_TRIGGER_OUT : JY5310.h
  • JY5310_RM_IN_RX_DI_REF_TRIGGER_OUT : JY5310.h
  • JY5310_RM_IN_RX_DI_START_TRIGGER_OUT : JY5310.h
  • JY5310_RM_IN_TX_DO_GENERATION_DONE : JY5310.h
  • JY5310_RM_IN_TX_DO_START_TRIGGER_IN : JY5310.h
  • JY5310_RM_IN_TX_DO_START_TRIGGER_OUT : JY5310.h
  • JY5310_RM_OUT_CLOCK_MANAGER_TRIGGER_IN : JY5310.h
  • JY5310_RM_OUT_PARALLEL_DO_EXT_CLK : JY5310.h
  • JY5310_RM_OUT_PFI_0 : JY5310.h
  • JY5310_RM_OUT_PFI_1 : JY5310.h
  • JY5310_RM_OUT_PFI_10 : JY5310.h
  • JY5310_RM_OUT_PFI_11 : JY5310.h
  • JY5310_RM_OUT_PFI_12 : JY5310.h
  • JY5310_RM_OUT_PFI_13 : JY5310.h
  • JY5310_RM_OUT_PFI_14 : JY5310.h
  • JY5310_RM_OUT_PFI_15 : JY5310.h
  • JY5310_RM_OUT_PFI_2 : JY5310.h
  • JY5310_RM_OUT_PFI_3 : JY5310.h
  • JY5310_RM_OUT_PFI_4 : JY5310.h
  • JY5310_RM_OUT_PFI_5 : JY5310.h
  • JY5310_RM_OUT_PFI_6 : JY5310.h
  • JY5310_RM_OUT_PFI_7 : JY5310.h
  • JY5310_RM_OUT_PFI_8 : JY5310.h
  • JY5310_RM_OUT_PFI_9 : JY5310.h
  • JY5310_RM_OUT_PXITRIGGER0 : JY5310.h
  • JY5310_RM_OUT_PXITRIGGER1 : JY5310.h
  • JY5310_RM_OUT_PXITRIGGER2 : JY5310.h
  • JY5310_RM_OUT_PXITRIGGER3 : JY5310.h
  • JY5310_RM_OUT_PXITRIGGER4 : JY5310.h
  • JY5310_RM_OUT_PXITRIGGER5 : JY5310.h
  • JY5310_RM_OUT_PXITRIGGER6 : JY5310.h
  • JY5310_RM_OUT_PXITRIGGER7 : JY5310.h
  • JY5310_RM_OUT_RX_AI_AD_TRIGGER_IN : JY5310.h
  • JY5310_RM_OUT_RX_AI_REF_TRIGGER_IN : JY5310.h
  • JY5310_RM_OUT_RX_AI_START_TRIGGER_IN : JY5310.h
  • JY5310_RM_OUT_RX_DI_AD_TRIGGER_IN : JY5310.h
  • JY5310_RM_OUT_RX_DI_REF_TRIGGER_IN : JY5310.h
  • JY5310_RM_OUT_RX_DI_START_TRIGGER_IN : JY5310.h
  • JY5310_SetDeviceProperty() : JY5310.h
  • JY5310_SetDeviceTimeBase() : JY5310.h
  • JY5310_Signal_Destination : JY5310.h
  • JY5310_Signal_Source : JY5310.h
  • JY5310_SignalRouting() : JY5310.h
  • JY5310_SLAVE : JY5310.h
  • JY5310_StartTrigger : JY5310.h
  • JY5310_TriggerMode : JY5310.h

- r -

  • ReferenceOnboard_25M : JY5310.h
  • ReferencePXIeCLK_100M : JY5310.h


  • DeviceTimeBaseSource : JY5310.h
  • JY5310_AI_ClockSource : JY5310.h
  • JY5310_AI_ExternalClockTerminal : JY5310.h
  • JY5310_AI_SampleMode : JY5310.h
  • JY5310_AI_TriggerType : JY5310.h
  • JY5310_AnalogTriggerCondition : JY5310.h
  • JY5310_DeviceProperty : JY5310.h
  • JY5310_DigitalTriggerEdge : JY5310.h
  • JY5310_Signal_Destination : JY5310.h
  • JY5310_Signal_Source : JY5310.h
  • JY5310_TriggerMode : JY5310.h


- j -

  • JT5310_AI_SAMPLE_CLOCK_INPUT : JY5310.h
  • JY5310_AI_Analog : JY5310.h
  • JY5310_AI_Continuous : JY5310.h
  • JY5310_AI_Digital : JY5310.h
  • JY5310_AI_ExternalClock : JY5310.h
  • JY5310_AI_Finite : JY5310.h
  • JY5310_AI_Immediately : JY5310.h
  • JY5310_AI_InternalClock : JY5310.h
  • JY5310_AI_Single : JY5310.h
  • JY5310_AI_Soft : JY5310.h
  • JY5310_Clock_PFI_0 : JY5310.h
  • JY5310_Clock_PFI_1 : JY5310.h
  • JY5310_Clock_PFI_10 : JY5310.h
  • JY5310_Clock_PFI_11 : JY5310.h
  • JY5310_Clock_PFI_12 : JY5310.h
  • JY5310_Clock_PFI_13 : JY5310.h
  • JY5310_Clock_PFI_14 : JY5310.h
  • JY5310_Clock_PFI_15 : JY5310.h
  • JY5310_Clock_PFI_2 : JY5310.h
  • JY5310_Clock_PFI_3 : JY5310.h
  • JY5310_Clock_PFI_4 : JY5310.h
  • JY5310_Clock_PFI_5 : JY5310.h
  • JY5310_Clock_PFI_6 : JY5310.h
  • JY5310_Clock_PFI_7 : JY5310.h
  • JY5310_Clock_PFI_8 : JY5310.h
  • JY5310_Clock_PFI_9 : JY5310.h
  • JY5310_Clock_PXI_Trig_0 : JY5310.h
  • JY5310_Clock_PXI_Trig_1 : JY5310.h
  • JY5310_Clock_PXI_Trig_2 : JY5310.h
  • JY5310_Clock_PXI_Trig_3 : JY5310.h
  • JY5310_Clock_PXI_Trig_4 : JY5310.h
  • JY5310_Clock_PXI_Trig_5 : JY5310.h
  • JY5310_Clock_PXI_Trig_6 : JY5310.h
  • JY5310_Clock_PXI_Trig_7 : JY5310.h
  • JY5310_EnteringWindow : JY5310.h
  • JY5310_Falling : JY5310.h
  • JY5310_FallingHysteresis : JY5310.h
  • JY5310_Independent : JY5310.h
  • JY5310_LeavingWindow : JY5310.h
  • JY5310_MASTER : JY5310.h
  • JY5310_ReferenceTrigger : JY5310.h
  • JY5310_Rising : JY5310.h
  • JY5310_RisingHysteresis : JY5310.h
  • JY5310_RM_IN_AI_SAMPLE_CLOCK_OUTPUT : JY5310.h
  • JY5310_RM_IN_ANALOG_TRIGGER_OUT : JY5310.h
  • JY5310_RM_IN_CLOCK_MANAGER_MASTER_TRIGGER_OUT : JY5310.h
  • JY5310_RM_IN_PARALLEL_DI_EXT_CLK : JY5310.h
  • JY5310_RM_IN_PFI_0 : JY5310.h
  • JY5310_RM_IN_PFI_1 : JY5310.h
  • JY5310_RM_IN_PFI_10 : JY5310.h
  • JY5310_RM_IN_PFI_11 : JY5310.h
  • JY5310_RM_IN_PFI_12 : JY5310.h
  • JY5310_RM_IN_PFI_13 : JY5310.h
  • JY5310_RM_IN_PFI_14 : JY5310.h
  • JY5310_RM_IN_PFI_15 : JY5310.h
  • JY5310_RM_IN_PFI_2 : JY5310.h
  • JY5310_RM_IN_PFI_3 : JY5310.h
  • JY5310_RM_IN_PFI_4 : JY5310.h
  • JY5310_RM_IN_PFI_5 : JY5310.h
  • JY5310_RM_IN_PFI_6 : JY5310.h
  • JY5310_RM_IN_PFI_7 : JY5310.h
  • JY5310_RM_IN_PFI_8 : JY5310.h
  • JY5310_RM_IN_PFI_9 : JY5310.h
  • JY5310_RM_IN_PXITRIGGER0 : JY5310.h
  • JY5310_RM_IN_PXITRIGGER1 : JY5310.h
  • JY5310_RM_IN_PXITRIGGER2 : JY5310.h
  • JY5310_RM_IN_PXITRIGGER3 : JY5310.h
  • JY5310_RM_IN_PXITRIGGER4 : JY5310.h
  • JY5310_RM_IN_PXITRIGGER5 : JY5310.h
  • JY5310_RM_IN_PXITRIGGER6 : JY5310.h
  • JY5310_RM_IN_PXITRIGGER7 : JY5310.h
  • JY5310_RM_IN_RX_AI_AD_TRIGGER_OUT : JY5310.h
  • JY5310_RM_IN_RX_AI_END_OF_ACQUISITION : JY5310.h
  • JY5310_RM_IN_RX_AI_END_OF_RECORD : JY5310.h
  • JY5310_RM_IN_RX_AI_REF_TRIGGER_OUT : JY5310.h
  • JY5310_RM_IN_RX_AI_START_TRIGGER_OUT : JY5310.h
  • JY5310_RM_IN_RX_DI_AD_TRIGGER_OUT : JY5310.h
  • JY5310_RM_IN_RX_DI_REF_TRIGGER_OUT : JY5310.h
  • JY5310_RM_IN_RX_DI_START_TRIGGER_OUT : JY5310.h
  • JY5310_RM_IN_TX_DO_GENERATION_DONE : JY5310.h
  • JY5310_RM_IN_TX_DO_START_TRIGGER_IN : JY5310.h
  • JY5310_RM_IN_TX_DO_START_TRIGGER_OUT : JY5310.h
  • JY5310_RM_OUT_CLOCK_MANAGER_TRIGGER_IN : JY5310.h
  • JY5310_RM_OUT_PARALLEL_DO_EXT_CLK : JY5310.h
  • JY5310_RM_OUT_PFI_0 : JY5310.h
  • JY5310_RM_OUT_PFI_1 : JY5310.h
  • JY5310_RM_OUT_PFI_10 : JY5310.h
  • JY5310_RM_OUT_PFI_11 : JY5310.h
  • JY5310_RM_OUT_PFI_12 : JY5310.h
  • JY5310_RM_OUT_PFI_13 : JY5310.h
  • JY5310_RM_OUT_PFI_14 : JY5310.h
  • JY5310_RM_OUT_PFI_15 : JY5310.h
  • JY5310_RM_OUT_PFI_2 : JY5310.h
  • JY5310_RM_OUT_PFI_3 : JY5310.h
  • JY5310_RM_OUT_PFI_4 : JY5310.h
  • JY5310_RM_OUT_PFI_5 : JY5310.h
  • JY5310_RM_OUT_PFI_6 : JY5310.h
  • JY5310_RM_OUT_PFI_7 : JY5310.h
  • JY5310_RM_OUT_PFI_8 : JY5310.h
  • JY5310_RM_OUT_PFI_9 : JY5310.h
  • JY5310_RM_OUT_PXITRIGGER0 : JY5310.h
  • JY5310_RM_OUT_PXITRIGGER1 : JY5310.h
  • JY5310_RM_OUT_PXITRIGGER2 : JY5310.h
  • JY5310_RM_OUT_PXITRIGGER3 : JY5310.h
  • JY5310_RM_OUT_PXITRIGGER4 : JY5310.h
  • JY5310_RM_OUT_PXITRIGGER5 : JY5310.h
  • JY5310_RM_OUT_PXITRIGGER6 : JY5310.h
  • JY5310_RM_OUT_PXITRIGGER7 : JY5310.h
  • JY5310_RM_OUT_RX_AI_AD_TRIGGER_IN : JY5310.h
  • JY5310_RM_OUT_RX_AI_REF_TRIGGER_IN : JY5310.h
  • JY5310_RM_OUT_RX_AI_START_TRIGGER_IN : JY5310.h
  • JY5310_RM_OUT_RX_DI_AD_TRIGGER_IN : JY5310.h
  • JY5310_RM_OUT_RX_DI_REF_TRIGGER_IN : JY5310.h
  • JY5310_RM_OUT_RX_DI_START_TRIGGER_IN : JY5310.h
  • JY5310_SLAVE : JY5310.h
  • JY5310_StartTrigger : JY5310.h

- r -

  • ReferenceOnboard_25M : JY5310.h
  • ReferencePXIeCLK_100M : JY5310.h


- j -

  • JY5310_AI_CheckBufferStatus() : JY5310.h
  • JY5310_AI_EnableChannel() : JY5310.h
  • JY5310_AI_ReadData() : JY5310.h
  • JY5310_AI_ReadRawData() : JY5310.h
  • JY5310_AI_ReadSinglePoint() : JY5310.h
  • JY5310_AI_SendSoftTrigger() : JY5310.h
  • JY5310_AI_SetAnalogReferenceTrigger() : JY5310.h
  • JY5310_AI_SetAnalogStartTrigger() : JY5310.h
  • JY5310_AI_SetBufferSize() : JY5310.h
  • JY5310_AI_SetClockSource() : JY5310.h
  • JY5310_AI_SetDigitalReferenceTrigger() : JY5310.h
  • JY5310_AI_SetDigitalStartTrigger() : JY5310.h
  • JY5310_AI_SetMode() : JY5310.h
  • JY5310_AI_SetPreTriggerSamples() : JY5310.h
  • JY5310_AI_SetReferenceTriggerType() : JY5310.h
  • JY5310_AI_SetReTriggerCount() : JY5310.h
  • JY5310_AI_SetSampleRate() : JY5310.h
  • JY5310_AI_SetSamplesToAcquire() : JY5310.h
  • JY5310_AI_SetStartTriggerType() : JY5310.h
  • JY5310_AI_SetTriggerMode() : JY5310.h
  • JY5310_AI_Start() : JY5310.h
  • JY5310_AI_Stop() : JY5310.h
  • JY5310_AI_WaitUntilDone() : JY5310.h
  • JY5310_Close() : JY5310.h
  • JY5310_DI_AddLines() : JY5310.h
  • JY5310_DI_ReadSinglePoint() : JY5310.h
  • JY5310_DI_Start() : JY5310.h
  • JY5310_DI_Stop() : JY5310.h
  • JY5310_DisableAICalibration() : JY5310.h
  • JY5310_DisableDigitalTriggerDelay() : JY5310.h
  • JY5310_DisconnectSignalRouting() : JY5310.h
  • JY5310_DO_AddLines() : JY5310.h
  • JY5310_DO_Start() : JY5310.h
  • JY5310_DO_Stop() : JY5310.h
  • JY5310_DO_WriteSinglePoint() : JY5310.h
  • JY5310_DO_WriteSinglePortPoint() : JY5310.h
  • JY5310_GetAICalibration() : JY5310.h
  • JY5310_Open() : JY5310.h
  • JY5310_OpenByAliasName() : JY5310.h
  • JY5310_SetDeviceProperty() : JY5310.h
  • JY5310_SetDeviceTimeBase() : JY5310.h
  • JY5310_SignalRouting() : JY5310.h


  • JY5310_DeviceHandle : JY5310.h


5310 C++ Programming Manual: Main Page

5310 C++ Programming Manual Documentation