5310 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5310 Directory Reference

5310 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 5310
5310 Directory Reference

Files

JY5310CoreOOAITask.h
JY5310CoreOOCommon.h
JY5310CoreOODevice.h
JY5310CoreOODITask.h
JY5310CoreOODOTask.h
JY5310CoreOOLog.h
Generated by doxygen 1.13.2


5310 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5310/JY5310CoreOOAITask.h File Reference

  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 5310
Classes | Namespaces | Enumerations
JY5310CoreOOAITask.h File Reference
#include <memory>
#include <mutex>
#include <map>
#include <fstream>
#include <thread>
#include <cstring>
#include <cstddef>
#include "JY5310CoreOOCommon.h"
#include "JY5310CoreOODevice.h"

Classes

class | JY5310CoreOO::JY5310CoreOOAITask
AITask类 More...
class | JY5310CoreOO::AIChannel
class | JY5310CoreOO::AIExternalSampleClock
class | JY5310CoreOO::AISampleClock
class | JY5310CoreOO::AITrigger
class | JY5310CoreOO::AIDigitalTrigger
class | JY5310CoreOO::AIAnalogHysteresisComparator
class | JY5310CoreOO::AIAnalogWindowComparator
class | JY5310CoreOO::AIAnalogEdgeComparator
class | JY5310CoreOO::AIAnalogTrigger
class | JY5310CoreOO::AISignalExport
class | JY5310CoreOO::AIRecord
class | JY5310CoreOO::AISync

Namespaces

namespace JY5310CoreOO

Enumerations

enum class | JY5310CoreOO::AIMode { JY5310CoreOO::Finite = 0x0 , JY5310CoreOO::Continuous = 0x1 , JY5310CoreOO::Record = 0x3 }
enum class | JY5310CoreOO::AISampleClockSource { JY5310CoreOO::Internal , JY5310CoreOO::External }
enum class | JY5310CoreOO::AITriggerType { JY5310CoreOO::Immediate = 0x0 , JY5310CoreOO::Digital = 0x1 , JY5310CoreOO::Analog = 0x2 , JY5310CoreOO::Soft = 0x3 }
enum class | JY5310CoreOO::AITriggerMode { JY5310CoreOO::Start , JY5310CoreOO::Reference }
enum class JY5310CoreOO::AIAnalogTriggerSource {
JY5310CoreOO::Channel_0 , JY5310CoreOO::Channel_1 , JY5310CoreOO::Channel_2 , JY5310CoreOO::Channel_3 ,
JY5310CoreOO::Channel_4 , JY5310CoreOO::Channel_5 , JY5310CoreOO::Channel_6 , JY5310CoreOO::Channel_7 ,
JY5310CoreOO::Channel_8 , JY5310CoreOO::Channel_9 , JY5310CoreOO::Channel_10 , JY5310CoreOO::Channel_11 ,
JY5310CoreOO::Channel_12 , JY5310CoreOO::Channel_13 , JY5310CoreOO::Channel_14 , JY5310CoreOO::Channel_15
}
enum class JY5310CoreOO::AIDigitalTriggerSource {
JY5310CoreOO::PFI0 = 16 , JY5310CoreOO::PFI1 = 17 , JY5310CoreOO::PFI2 = 18 , JY5310CoreOO::PFI3 = 19 ,
JY5310CoreOO::PFI4 = 20 , JY5310CoreOO::PFI5 = 21 , JY5310CoreOO::PFI6 = 22 , JY5310CoreOO::PFI7 = 23 ,
JY5310CoreOO::PFI8 = 24 , JY5310CoreOO::PFI9 = 25 , JY5310CoreOO::PFI10 = 26 , JY5310CoreOO::PFI11 = 27 ,
JY5310CoreOO::PFI12 = 28 , JY5310CoreOO::PFI13 = 29 , JY5310CoreOO::PFI14 = 30 , JY5310CoreOO::PFI15 = 31 ,
JY5310CoreOO::DI_StartTrig = 48 , JY5310CoreOO::DI_ReferencetTrig = 49 , JY5310CoreOO::DO_StartTrig = 51 , JY5310CoreOO::PXI_Trig0 = 64 ,
JY5310CoreOO::PXI_Trig1 = 65 , JY5310CoreOO::PXI_Trig2 = 66 , JY5310CoreOO::PXI_Trig3 = 67 , JY5310CoreOO::PXI_Trig4 = 68 ,
JY5310CoreOO::PXI_Trig5 = 69 , JY5310CoreOO::PXI_Trig6 = 70 , JY5310CoreOO::PXI_Trig7 = 71
}
enum class | JY5310CoreOO::AIDigitalTriggerEdge { JY5310CoreOO::Rising = 0x0 , JY5310CoreOO::Falling = 0x1 }
enum class | JY5310CoreOO::AIAnalogTriggerEdge { JY5310CoreOO::Rising , JY5310CoreOO::Falling }
enum class | JY5310CoreOO::AIAnalogWindowCondition { JY5310CoreOO::Entering , JY5310CoreOO::Leaving }
AI Analog Window Trigger Condition. More...
enum class | JY5310CoreOO::AIAnalogTriggerComparator { JY5310CoreOO::Edge , JY5310CoreOO::Hysteresis , JY5310CoreOO::Window }
AI Analog Trigger Comparator. More...
enum class | JY5310CoreOO::AISignalExportSource { JY5310CoreOO::StartTrig = 16 , JY5310CoreOO::ReferenceTrig = 17 , JY5310CoreOO::SampleClock = 20 }
enum class | JY5310CoreOO::FileFormat { JY5310CoreOO::Bin }
enum class | JY5310CoreOO::RecordMode { JY5310CoreOO::Finite , JY5310CoreOO::Infinite }
enum class | JY5310CoreOO::SyncTopology { JY5310CoreOO::Independent , JY5310CoreOO::Master , JY5310CoreOO::Slave }
Synchronization board configuration. More...
enum class JY5310CoreOO::SyncTriggerRouting {
JY5310CoreOO::NONE = -1 , JY5310CoreOO::PXI_Trig0 = 64 , JY5310CoreOO::PXI_Trig1 = 65 , JY5310CoreOO::PXI_Trig2 = 66 ,
JY5310CoreOO::PXI_Trig3 = 67 , JY5310CoreOO::PXI_Trig4 = 68 , JY5310CoreOO::PXI_Trig5 = 69 , JY5310CoreOO::PXI_Trig6 = 70 ,
JY5310CoreOO::PXI_Trig7 = 71
}
enum class JY5310CoreOO::SyncPulseRouting {
JY5310CoreOO::NONE = -1 , JY5310CoreOO::PXI_Trig0 = 64 , JY5310CoreOO::PXI_Trig1 = 65 , JY5310CoreOO::PXI_Trig2 = 66 ,
JY5310CoreOO::PXI_Trig3 = 67 , JY5310CoreOO::PXI_Trig4 = 68 , JY5310CoreOO::PXI_Trig5 = 69 , JY5310CoreOO::PXI_Trig6 = 70 ,
JY5310CoreOO::PXI_Trig7 = 71
}


5310 C++ Programming Manual: JY5310CoreOO::JY5310CoreOOAITask Class Reference

  • Class List
  • Class Index
  • Class Members
  • JY5310CoreOO
  • JY5310CoreOOAITask
Public Member Functions | Public Attributes | List of all members
JY5310CoreOO::JY5310CoreOOAITask Class Reference

AITask类 More...

#include <JY5310CoreOOAITask.h>

Public Member Functions

JY5310CoreOOAITask (int slotNum)
Constructor.
JY5310CoreOOAITask (std::string boardName)
Constructor.
void | AddChannel (int chnId, double rangeLow=-10, double rangeHigh=10)
Add one channel.
void | AddChannel (std::vector< int > chnsId, double rangeLow=-10, double rangeHigh=10)
Add a group of channels.
void | AddChannel (std::vector< int > chnsId, std::vector< double > rangeLow, std::vector< double > rangeHigh)
Add a group of channels, each channel range can be set differently.
void | RemoveChannel (int chnId)
Delete the channel with the specified channel number.
void | ReadData (double *pBuf, int samplesPerChannel, int timeout=1000)
Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.
void | ReadRawData (short *pBuf, int samplesPerChannel, int timeout=1000)
Read one or multi-channel raw data by columns and store it in a data buffer.
void | GetRecordPreviewData (double *buf, int samplesPerChannel, int timeout=1000)
Preview one channel data when streaming is in progress.
void | GetRecordStatus (double *recordedLength, bool *recordDone)
Get the streaming status.
void | Start ()
Start Task.
void | SendSoftwareTrigger ()
Generate a software trigger signal generate a software trigger signal.
void | Stop ()
Stop Task.
~JY5310CoreOOAITask ()

Public Attributes

std::list< AIChannel * > | Channels
List of AI channels,(5312 5315 support 16 Diff channel)
JY5310CoreOOProperty< JY5310CoreOOAITask, double, JY5310CoreOOPropertyType::READ_WRITE > | SampleRate
Sample rate per channel.
int | SamplesToAcquire
Number of samples to be read per channel.
JY5310CoreOOProperty< JY5310CoreOOAITask, int, JY5310CoreOOPropertyType::READ_ONLY > | BufLenInSamples
Number of samples per channel can be storage in the buffer, the Property SamplesToAcquire must be less than or equal to this value.
JY5310CoreOOProperty< JY5310CoreOOAITask, uint64_t, JY5310CoreOOPropertyType::READ_ONLY > | AvailableSamples
Number of samples per channel that can be read in the buffer .
JY5310CoreOOProperty< JY5310CoreOOAITask, uint64_t, JY5310CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
AIMode Mode
AI acquisition mode, support Finite/Continuous/Record *.
AISampleClock * SampleClock
AI Sample Clock.
AITrigger * Trigger
AI Trigger Configuration.
AIRecord * Record
AI Data streaming Configuration.
AISignalExport * SignalExport
Export AI Signal Configuration.
AISync * Sync
Multi card synchronous configuration.
JY5310CoreOODevice * Device
Device.

Detailed Description

AITask类

Constructor & Destructor Documentation

◆ JY5310CoreOOAITask() [1/2]

JY5310CoreOO::JY5310CoreOOAITask::JY5310CoreOOAITask ( int slotNum )

Constructor.

Used to create an AI task by a slot number

Parameters
slotNum Card slot number.

◆ JY5310CoreOOAITask() [2/2]

JY5310CoreOO::JY5310CoreOOAITask::JY5310CoreOOAITask ( std::string boardName )

Constructor.

Used to create an AI task by a slot number

Parameters
slotNum Card slot number.

◆ ~JY5310CoreOOAITask()

JY5310CoreOO::JY5310CoreOOAITask::~JY5310CoreOOAITask ( )

Member Function Documentation

◆ AddChannel() [1/3]

void JY5310CoreOO::JY5310CoreOOAITask::AddChannel | ( | int | chnId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10 )

Add one channel.

Parameters
chnId | channel's physical number ，chnId=-1, add all channels
rangeLow | lower range limit for the channel，-10V,-5V,-2V，-1V,default -10
rangeHigh | higher range limit for the channel,10V,5V,2V，1V,default 10

◆ AddChannel() [2/3]

void JY5310CoreOO::JY5310CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10 )

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers
rangeLow | lower range limit for the channel，-10V,-5V,-2V，-1V,default -10
rangeHigh | higher range limit for the channel,10V,5V,2V，1V,default 10

◆ AddChannel() [3/3]

void JY5310CoreOO::JY5310CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | std::vector< double > | rangeLow,
 |  | std::vector< double > | rangeHigh )

Add a group of channels, each channel range can be set differently.

Parameters
chnsId | a group of channel physical numbers,different mode 0-15
rangeLow | lower range limit for the channel，-10V,-5V,-2V，-1V
rangeHigh | higher range limit for the channel,10V,5V,2V，1V

◆ GetRecordPreviewData()

void JY5310CoreOO::JY5310CoreOOAITask::GetRecordPreviewData | ( | double * | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 1000 )

Preview one channel data when streaming is in progress.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ GetRecordStatus()

void JY5310CoreOO::JY5310CoreOOAITask::GetRecordStatus | ( | double * | recordedLength,
 |  | bool * | recordDone )

Get the streaming status.

Parameters
recordedLength | Length of the streamed, unit s
recordDone | recordDone = false :streaming is not over.recordDone = true :streaming is over

◆ ReadData()

void JY5310CoreOO::JY5310CoreOOAITask::ReadData | ( | double * | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 1000 )

Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.

param name="pBuf">Data buffer

Parameters
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish

◆ ReadRawData()

void JY5310CoreOO::JY5310CoreOOAITask::ReadRawData | ( | short * | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 1000 )

Read one or multi-channel raw data by columns and store it in a data buffer.

The buffer is pointed by C/C++ data type short.

Parameters
pBuf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ RemoveChannel()

void JY5310CoreOO::JY5310CoreOOAITask::RemoveChannel ( int chnId )

Delete the channel with the specified channel number.

chnId=- 1, all channels will be deleted

Parameters
chnId Channel number of the channel to be deleted

◆ SendSoftwareTrigger()

void JY5310CoreOO::JY5310CoreOOAITask::SendSoftwareTrigger ( )

Generate a software trigger signal generate a software trigger signal.

Returns

◆ Start()

void JY5310CoreOO::JY5310CoreOOAITask::Start ( )

Start Task.

Parameters

return void

Exceptions
JYDriverException When startup fails

◆ Stop()

void JY5310CoreOO::JY5310CoreOOAITask::Stop ( )

Stop Task.

Parameters

return void

Exceptions
JYDriverException When stop fails

Member Data Documentation

◆ AvailableSamples

JY5310CoreOOProperty<JY5310CoreOOAITask, uint64_t, JY5310CoreOOPropertyType::READ_ONLY> JY5310CoreOO::JY5310CoreOOAITask::AvailableSamples

Number of samples per channel that can be read in the buffer .

Valid when Mode is NOT AIMode.Single.

◆ BufLenInSamples

JY5310CoreOOProperty<JY5310CoreOOAITask, int, JY5310CoreOOPropertyType::READ_ONLY> JY5310CoreOO::JY5310CoreOOAITask::BufLenInSamples

Number of samples per channel can be storage in the buffer, the Property SamplesToAcquire must be less than or equal to this value.

◆ Channels

std::list<AIChannel*> JY5310CoreOO::JY5310CoreOOAITask::Channels

List of AI channels,(5312 5315 support 16 Diff channel)

◆ Device

JY5310CoreOODevice* JY5310CoreOO::JY5310CoreOOAITask::Device

Device.

◆ Mode

AIMode JY5310CoreOO::JY5310CoreOOAITask::Mode

AI acquisition mode, support Finite/Continuous/Record *.

◆ Record

AIRecord* JY5310CoreOO::JY5310CoreOOAITask::Record

AI Data streaming Configuration.

◆ SampleClock

AISampleClock* JY5310CoreOO::JY5310CoreOOAITask::SampleClock

AI Sample Clock.

◆ SampleRate

JY5310CoreOOProperty<JY5310CoreOOAITask, double, JY5310CoreOOPropertyType::READ_WRITE> JY5310CoreOO::JY5310CoreOOAITask::SampleRate

Sample rate per channel.

Maximum sample rate:5312 is 2M,5315 is 5M The defalut sample rate = 5M You can read this property to obtain the sample rate that will actually take effect in the current configuration.

Exceptions
JYDriverException

◆ SamplesToAcquire

int JY5310CoreOO::JY5310CoreOOAITask::SamplesToAcquire

Number of samples to be read per channel.

Only valid when Mode is Finite*

◆ SignalExport

AISignalExport* JY5310CoreOO::JY5310CoreOOAITask::SignalExport

Export AI Signal Configuration.

◆ Sync

AISync* JY5310CoreOO::JY5310CoreOOAITask::Sync

Multi card synchronous configuration.

◆ TransferedSamples

JY5310CoreOOProperty<JY5310CoreOOAITask, uint64_t, JY5310CoreOOPropertyType::READ_ONLY> JY5310CoreOO::JY5310CoreOOAITask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT AIMode.Single.

◆ Trigger

AITrigger* JY5310CoreOO::JY5310CoreOOAITask::Trigger

AI Trigger Configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5310/JY5310CoreOOAITask.h


5310 C++ Programming Manual: JY5310CoreOO::AIChannel Class Reference

  • JY5310CoreOO
  • AIChannel
Public Member Functions | Public Attributes | List of all members
JY5310CoreOO::AIChannel Class Reference

#include <JY5310CoreOOAITask.h>

Public Member Functions

AIChannel (int channelId, double rangeLow, double rangeHigh)

Public Attributes

int | ChannelID
double | RangeLow
double | RangeHigh

Constructor & Destructor Documentation

◆ AIChannel()

JY5310CoreOO::AIChannel::AIChannel | ( | int | channelId,
 |  | double | rangeLow,
 |  | double | rangeHigh )
 inline

Member Data Documentation

◆ ChannelID

int JY5310CoreOO::AIChannel::ChannelID

◆ RangeHigh

double JY5310CoreOO::AIChannel::RangeHigh

◆ RangeLow

double JY5310CoreOO::AIChannel::RangeLow
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5310/JY5310CoreOOAITask.h


5310 C++ Programming Manual: JY5310CoreOO::AIExternalSampleClock Class Reference

  • AIExternalSampleClock
Public Attributes | List of all members
JY5310CoreOO::AIExternalSampleClock Class Reference

#include <JY5310CoreOOAITask.h>

Public Attributes

ClockTerminal Terminal
External Sample Clock Input Terminal.
double ExpectedRate
Expected External Sample Clock Rate.

Member Data Documentation

◆ ExpectedRate

double JY5310CoreOO::AIExternalSampleClock::ExpectedRate

Expected External Sample Clock Rate.

◆ Terminal

ClockTerminal JY5310CoreOO::AIExternalSampleClock::Terminal

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5310/JY5310CoreOOAITask.h


5310 C++ Programming Manual: JY5310CoreOO::AISampleClock Class Reference

  • AISampleClock
Public Attributes | List of all members
JY5310CoreOO::AISampleClock Class Reference

#include <JY5310CoreOOAITask.h>

Public Attributes

AISampleClockSource Source
AI Sample Clock Source.
AIExternalSampleClock * External
External Sample Clock Configuration.

Member Data Documentation

◆ External

AIExternalSampleClock* JY5310CoreOO::AISampleClock::External

External Sample Clock Configuration.

Valid when Source is AISampleClockSource.External.

◆ Source

AISampleClockSource JY5310CoreOO::AISampleClock::Source

AI Sample Clock Source.

enum Internal/External. The default value is AISampleClockSource.Internal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5310/JY5310CoreOOAITask.h


5310 C++ Programming Manual: JY5310CoreOO::AITrigger Class Reference

  • AITrigger
Public Attributes | List of all members
JY5310CoreOO::AITrigger Class Reference

#include <JY5310CoreOOAITask.h>

Public Attributes

AITriggerType Type
AI trigger type.
AITriggerMode Mode
AI trigger mode.
AIDigitalTrigger * Digital
Digital Trigger Congfiguration.
AIAnalogTrigger * Analog
AI Analog Trigger.
int | ReTriggerCount
Number of repeat triggers.
unsigned int | PreTriggerSamples
AI pretrigger samples, must be less than or equal to JY5310AITask.SamplesToAcquire.

Member Data Documentation

◆ Analog

AIAnalogTrigger* JY5310CoreOO::AITrigger::Analog

AI Analog Trigger.

Valid when Type is AITriggerType.Analog.

◆ Digital

AIDigitalTrigger* JY5310CoreOO::AITrigger::Digital

Digital Trigger Congfiguration.

Valid when Type is AITriggerType.Digital.

◆ Mode

AITriggerMode JY5310CoreOO::AITrigger::Mode

AI trigger mode.

enum Start/Reference. The default value is AITriggerMode.Start.

◆ PreTriggerSamples

unsigned int JY5310CoreOO::AITrigger::PreTriggerSamples

AI pretrigger samples, must be less than or equal to JY5310AITask.SamplesToAcquire.

Valid when Mode is AITriggerMode.Reference. Pretrigger samples, must be greater than 0. Valid when Type is AITriggerType.Analog. Pretrigger samples, must be greater than 1. Valid when Type is AITriggerType.Digital.

◆ ReTriggerCount

int JY5310CoreOO::AITrigger::ReTriggerCount

Number of repeat triggers.

When 0 or 1 only trigger once, When -1 continuous retrigger until stop.

◆ Type

AITriggerType JY5310CoreOO::AITrigger::Type

AI trigger type.

enum Analog/Digital/Immediate/Soft. The default value is AITriggerType.Immediate.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5310/JY5310CoreOOAITask.h


5310 C++ Programming Manual: JY5310CoreOO::AIDigitalTrigger Class Reference

  • AIDigitalTrigger
Public Attributes | List of all members
JY5310CoreOO::AIDigitalTrigger Class Reference

#include <JY5310CoreOOAITask.h>

Public Attributes

AIDigitalTriggerSource Source
AI Digital Trigger source.
AIDigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Member Data Documentation

◆ Edge

AIDigitalTriggerEdge JY5310CoreOO::AIDigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

AIDigitalTriggerSource JY5310CoreOO::AIDigitalTrigger::Source

AI Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5310/JY5310CoreOOAITask.h


5310 C++ Programming Manual: JY5310CoreOO::AIAnalogHysteresisComparator Class Reference

  • AIAnalogHysteresisComparator
Public Attributes | List of all members
JY5310CoreOO::AIAnalogHysteresisComparator Class Reference

#include <JY5310CoreOOAITask.h>

Public Attributes

AIAnalogTriggerEdge Slope
AI Analog Trigger Edge.
double | HighThreshold
High Threshold.
double | LowThreshold
Low Threshold.

Member Data Documentation

◆ HighThreshold

double JY5310CoreOO::AIAnalogHysteresisComparator::HighThreshold

High Threshold.

◆ LowThreshold

double JY5310CoreOO::AIAnalogHysteresisComparator::LowThreshold

Low Threshold.

◆ Slope

AIAnalogTriggerEdge JY5310CoreOO::AIAnalogHysteresisComparator::Slope

AI Analog Trigger Edge.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5310/JY5310CoreOOAITask.h


5310 C++ Programming Manual: JY5310CoreOO::AIAnalogWindowComparator Class Reference

  • AIAnalogWindowComparator
Public Attributes | List of all members
JY5310CoreOO::AIAnalogWindowComparator Class Reference

#include <JY5310CoreOOAITask.h>

Public Attributes

AIAnalogWindowCondition Condition
AI Analog Window Condition.
double | HighThreshold
High Threshold.
double | LowThreshold
Low Threshold.

Member Data Documentation

◆ Condition

AIAnalogWindowCondition JY5310CoreOO::AIAnalogWindowComparator::Condition

AI Analog Window Condition.

◆ HighThreshold

double JY5310CoreOO::AIAnalogWindowComparator::HighThreshold

High Threshold.

◆ LowThreshold

double JY5310CoreOO::AIAnalogWindowComparator::LowThreshold

Low Threshold.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5310/JY5310CoreOOAITask.h


5310 C++ Programming Manual: JY5310CoreOO::AIAnalogEdgeComparator Class Reference

  • AIAnalogEdgeComparator
Public Attributes | List of all members
JY5310CoreOO::AIAnalogEdgeComparator Class Reference

#include <JY5310CoreOOAITask.h>

Public Attributes

AIAnalogTriggerEdge Slope
AI Analog Trigger Edge.
double Threshold
Threshold.

Member Data Documentation

◆ Slope

AIAnalogTriggerEdge JY5310CoreOO::AIAnalogEdgeComparator::Slope

AI Analog Trigger Edge.

◆ Threshold

double JY5310CoreOO::AIAnalogEdgeComparator::Threshold

Threshold.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5310/JY5310CoreOOAITask.h


5310 C++ Programming Manual: JY5310CoreOO::AIAnalogTrigger Class Reference

  • AIAnalogTrigger
Public Attributes | List of all members
JY5310CoreOO::AIAnalogTrigger Class Reference

#include <JY5310CoreOOAITask.h>

Public Attributes

AIAnalogTriggerSource Source
Analog Trigger source.
AIAnalogTriggerComparator Comparator
AI Analog Trigger Comparator.
AIAnalogEdgeComparator * Edge
AI Analog Edge Comparator.
AIAnalogHysteresisComparator * Hysteresis
AI Analog Hysteresis Comparatorr.
AIAnalogWindowComparator * Window
AI Analog Window Comparatorr.

Member Data Documentation

◆ Comparator

AIAnalogTriggerComparator JY5310CoreOO::AIAnalogTrigger::Comparator

AI Analog Trigger Comparator.

◆ Edge

AIAnalogEdgeComparator* JY5310CoreOO::AIAnalogTrigger::Edge

AI Analog Edge Comparator.

◆ Hysteresis

AIAnalogHysteresisComparator* JY5310CoreOO::AIAnalogTrigger::Hysteresis

AI Analog Hysteresis Comparatorr.

◆ Source

AIAnalogTriggerSource JY5310CoreOO::AIAnalogTrigger::Source

Analog Trigger source.

◆ Window

AIAnalogWindowComparator* JY5310CoreOO::AIAnalogTrigger::Window

AI Analog Window Comparatorr.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5310/JY5310CoreOOAITask.h


5310 C++ Programming Manual: JY5310CoreOO::AISignalExport Class Reference

  • AISignalExport
Public Member Functions | List of all members
JY5310CoreOO::AISignalExport Class Reference

#include <JY5310CoreOOAITask.h>

Public Member Functions

void | Add (AISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (AISignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Member Function Documentation

◆ Add() [1/2]

void JY5310CoreOO::AISignalExport::Add | ( | AISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | AI Signal Source
destination | Export Desination

◆ Add() [2/2]

void JY5310CoreOO::AISignalExport::Add | ( | AISignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | AI Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JY5310CoreOO::AISignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5310CoreOO::AISignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5310/JY5310CoreOOAITask.h


5310 C++ Programming Manual: JY5310CoreOO::AIRecord Class Reference

  • AIRecord
Public Attributes | List of all members
JY5310CoreOO::AIRecord Class Reference

#include <JY5310CoreOOAITask.h>

Public Attributes

std::string | FilePath
User specified file path.
FileFormat File_Format
Streaming file format.
RecordMode Mode
stream mode .
double | Length
User specified stream length in second.

Member Data Documentation

◆ File_Format

FileFormat JY5310CoreOO::AIRecord::File_Format

Streaming file format.

enum BIN.

◆ FilePath

std::string JY5310CoreOO::AIRecord::FilePath

User specified file path.

◆ Length

double JY5310CoreOO::AIRecord::Length

User specified stream length in second.

Only when Mode is RecordMode.Finite.

◆ Mode

RecordMode JY5310CoreOO::AIRecord::Mode

stream mode .

enum Finite/Infinite.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5310/JY5310CoreOOAITask.h


5310 C++ Programming Manual: JY5310CoreOO::AISync Class Reference

  • AISync
Public Attributes | List of all members
JY5310CoreOO::AISync Class Reference

#include <JY5310CoreOOAITask.h>

Public Attributes

SyncTopology Topology
SyncTriggerRouting TriggerRouting
SyncPulseRouting PulseRouting

Member Data Documentation

◆ PulseRouting

SyncPulseRouting JY5310CoreOO::AISync::PulseRouting

◆ Topology

SyncTopology JY5310CoreOO::AISync::Topology

◆ TriggerRouting

SyncTriggerRouting JY5310CoreOO::AISync::TriggerRouting
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5310/JY5310CoreOOAITask.h


5310 C++ Programming Manual: JY5310CoreOO Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Enumerations | Functions
JY5310CoreOO Namespace Reference

Classes

class | AIAnalogEdgeComparator
class | AIAnalogHysteresisComparator
class | AIAnalogTrigger
class | AIAnalogWindowComparator
class | AIChannel
class | AIDigitalTrigger
class | AIExternalSampleClock
class | AIRecord
class | AISampleClock
class | AISignalExport
class | AISync
class | AITrigger
class | DIChannel
DI Channel parameter class . More...
class | DIDigitalTrigger
DI Digital trigger . More...
class | DIExternalSampleClock
External Sample Clock Configuration Class. More...
class | DISampleClock
Sample clock configuration class. More...
class | DISignalExport
DI Signal Export Class. More...
class | DITrigger
Constructor to create an DITrigger task object. More...
class | DOChannel
DO Channel parameter class . More...
class | DODigitalTrigger
DO Digital trigger. More...
class | DOExternalSampleClock
External Sample Clock Configuration Class. More...
class | DOSampleClock
Sample clock configuration class. More...
class | DOSignalExport
DO Signal Export Class. More...
class | DOTrigger
Constructor to create an DOTrigger task object. More...
class | ExternalReferenceClock
External Reference Clcok Terminal. More...
class | JY5310CoreOOAITask
AITask类 More...
class | JY5310CoreOODevice
class | JY5310CoreOODITask
class | JY5310CoreOODOTask
class | JY5310CoreOOLog
class | JY5310CoreOOProperty
属性模板类 More...
class | JY5310CoreOOReferenceClock
class | JYDriverException
class | PauseTrigger
Pause trigger configuration class. More...

Enumerations

enum class | AIMode { Finite = 0x0 , Continuous = 0x1 , Record = 0x3 }
enum class | AISampleClockSource { Internal , External }
enum class | AITriggerType { Immediate = 0x0 , Digital = 0x1 , Analog = 0x2 , Soft = 0x3 }
enum class | AITriggerMode { Start , Reference }
enum class AIAnalogTriggerSource {
Channel_0 , Channel_1 , Channel_2 , Channel_3 ,
Channel_4 , Channel_5 , Channel_6 , Channel_7 ,
Channel_8 , Channel_9 , Channel_10 , Channel_11 ,
Channel_12 , Channel_13 , Channel_14 , Channel_15
}
enum class AIDigitalTriggerSource {
PFI0 = 16 , PFI1 = 17 , PFI2 = 18 , PFI3 = 19 ,
PFI4 = 20 , PFI5 = 21 , PFI6 = 22 , PFI7 = 23 ,
PFI8 = 24 , PFI9 = 25 , PFI10 = 26 , PFI11 = 27 ,
PFI12 = 28 , PFI13 = 29 , PFI14 = 30 , PFI15 = 31 ,
DI_StartTrig = 48 , DI_ReferencetTrig = 49 , DO_StartTrig = 51 , PXI_Trig0 = 64 ,
PXI_Trig1 = 65 , PXI_Trig2 = 66 , PXI_Trig3 = 67 , PXI_Trig4 = 68 ,
PXI_Trig5 = 69 , PXI_Trig6 = 70 , PXI_Trig7 = 71
}
enum class | AIDigitalTriggerEdge { Rising = 0x0 , Falling = 0x1 }
enum class | AIAnalogTriggerEdge { Rising , Falling }
enum class | AIAnalogWindowCondition { Entering , Leaving }
AI Analog Window Trigger Condition. More...
enum class | AIAnalogTriggerComparator { Edge , Hysteresis , Window }
AI Analog Trigger Comparator. More...
enum class | AISignalExportSource { StartTrig = 16 , ReferenceTrig = 17 , SampleClock = 20 }
enum class | FileFormat { Bin }
enum class | RecordMode { Finite , Infinite }
enum class | SyncTopology { Independent , Master , Slave }
Synchronization board configuration. More...
enum class SyncTriggerRouting {
NONE = -1 , PXI_Trig0 = 64 , PXI_Trig1 = 65 , PXI_Trig2 = 66 ,
PXI_Trig3 = 67 , PXI_Trig4 = 68 , PXI_Trig5 = 69 , PXI_Trig6 = 70 ,
PXI_Trig7 = 71
}
enum class SyncPulseRouting {
NONE = -1 , PXI_Trig0 = 64 , PXI_Trig1 = 65 , PXI_Trig2 = 66 ,
PXI_Trig3 = 67 , PXI_Trig4 = 68 , PXI_Trig5 = 69 , PXI_Trig6 = 70 ,
PXI_Trig7 = 71
}
enum class | JY5310CoreOOPropertyType { READ_ONLY = 1 , WRITE_ONLY = 2 , READ_WRITE = 3 }
enum class JYDriverExceptionPublic {
UnKnown = 0 , OpenDeviceFailed = -10001 , CloseDeviceFailed = -10002 , ResetDeviceFailed = -10003 ,
GetDevicePropertyFailed = -10004 , SetDevicePropertyFailed = -10005 , HardwareResourceIsReserved = -10006 , MethodNotPermitedToCallWhenCurrentStatus = -10007 ,
InvalidUserDataBuffer = -10008 , NoChannelAdded = -10009 , NotSupportOperationForCurrentDevice = -10010 , CreatTaskFailed = -10100 ,
StartTaskFailed = -10101 , StopTaskFailed = -10102 , TaskHasNotStarted = -10103 , TaskHasStartedCannotPerformTheSetOperation = -10104 ,
ChannelNumberParameterInvalid = -10105 , ChannelInputRangeParameterInvalid = -10106 , ChannelTerminalParameterInvalid = -10107 , ChannelCouplingParameterInvalid = -10108 ,
SampeleModeParameterInvalid = -10109 , SampleClockParameterInvalid = -10110 , SampleRateParameterInvalid = -10111 , UpdateRateParameterInvalid = -10112 ,
TriggerParameterInvalid = -10113 , ReferenceTriggerDoesNotMatchWithSampleMode = -10114 , PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint = -10115 , ReadDataFailed = -10016 ,
ReadDataTimeout = -10017 , WriteDataFailed = -10018 , WriteDataTimeout = -10019 , WriteDataLengthCannotBeLessThanN = -10020 ,
BufferDataOverflow = -10021 , BufferDataDownflow = -10022 , CheckBufferFailed = -10023 , PointInvalidInFiniteMode = -10024 ,
ReadPointInvalid = -10025 , OnlySupportRecordMode = -10026 , SendSoftTirggerFailed = -10027 , TaskTimeout = -10028 ,
CounterParametersInvalid = -10029 , WritePointInvalid = -10030 , SignalExportDestinationInvalid = -10031 , InvalidParameter = -10033
}
enum class ClockTerminal {
ECLK = 10000 , PFI0 = 0 , PFI1 = 1 , PFI2 = 2 ,
PFI3 = 3 , PFI4 = 4 , PFI5 = 5 , PFI6 = 6 ,
PFI7 = 7 , PFI8 = 8 , PFI9 = 9 , PFI10 = 10 ,
PFI11 = 11 , PFI12 = 12 , PFI13 = 13 , PFI14 = 14 ,
PFI15 = 15 , PXI_Trig0 = 40 , PXI_Trig1 = 41 , PXI_Trig2 = 42 ,
PXI_Trig3 = 43 , PXI_Trig4 = 44 , PXI_Trig5 = 45 , PXI_Trig6 = 46 ,
PXI_Trig7 = 47 , AI_SampleClock = 20 , AO_SampleClock = 28 , DI_SampleClock = 53 ,
DO_SampleClock = 54 , CI0_SampleClock = 36 , CI1_SampleClock = 50 , CI2_SampleClock = 59 ,
CI3_SampleClock = 65 , CO_0_Output = 37 , CO_1_Output = 51 , CO_2_Output = 60 ,
CO_3_Output = 66
}
enum class SignalExportDestination {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PFI8 , PFI9 , PFI10 , PFI11 ,
PFI12 , PFI13 , PFI14 , PFI15 ,
PXI_Trig0 = 0x20 , PXI_Trig1 = 0x21 , PXI_Trig2 = 0x22 , PXI_Trig3 = 0x23 ,
PXI_Trig4 = 0x24 , PXI_Trig5 = 0x25 , PXI_Trig6 = 0x26 , PXI_Trig7 = 0x27
}
enum class IOTerminal {
Default = 0 , PXI_Trig0 = 0x20 , PXI_Trig1 = 0x21 , PXI_Trig2 = 0x22 ,
PXI_Trig3 = 0x23 , PXI_Trig4 = 0x24 , PXI_Trig5 = 0x25 , PXI_Trig6 = 0x26 ,
PXI_Trig7 = 0x27
}
Cunter IO Terminal. More...
enum class | LevelPolarity { LowLevel = 0 , HighLevel = 1 , None = 2 }
Level Polarity. More...
enum class InputTerminal {
Default = 0 , PXI_Trig0 = 40 , PXI_Trig1 = 41 , PXI_Trig2 = 42 ,
PXI_Trig3 = 43 , PXI_Trig4 = 44 , PXI_Trig5 = 45 , PXI_Trig6 = 46 ,
PXI_Trig7 = 47 , CI_0_OutPut = 37 , CI_1_OutPut = 51 , CI_2_OutPut = 60 ,
CI_3_OutPut = 66
}
Cunter Input Terminal. More...
enum class | ExternalReferenceClockTerminal { PXIe_Clk100 = 0x1 }
enum class | ReferenceClockSource { Internal = 0x0 , External = 0x1 }
enum class | DISampleClockSource { Internal , External }
DI Sample Clock Source. More...
enum class | DIMode { Single = 2 , Finite = 0 , Continuous = 1 }
DIMode. More...
enum class | DISignalExportSource { StartTrig = 22 , ReferenceTrig = 23 , SampleClock = 53 }
SourceSignal. More...
enum class | DITriggerMode { Start , Reference }
DI Trigger Mode. More...
enum class | DITriggerType { Immediate = 0 , Digital = 1 , Soft = 3 }
TriggerType Digital/Immediate/Soft. More...
enum class DIDigitalTriggerSource {
PFI0 = 0x10 , PFI1 = 0x11 , PFI2 = 0x12 , PFI3 = 0x13 ,
PFI4 = 0x14 , PFI5 = 0x15 , PFI6 = 0x16 , PFI7 = 0x17 ,
PFI8 = 0x18 , PFI9 = 0x19 , PFI10 = 0x1A , PFI11 = 0x1B ,
PFI12 = 0x1C , PFI13 = 0x1D , PFI14 = 0x1E , PFI15 = 0x1F ,
PXI_Trig0 = 64 , PXI_Trig1 = 65 , PXI_Trig2 = 66 , PXI_Trig3 = 67 ,
PXI_Trig4 = 68 , PXI_Trig5 = 69 , PXI_Trig6 = 70 , PXI_Trig7 = 71 ,
AI_StartTrig = 11 , AI_ReferenceTrig = 12 , DO_StartTrig = 51
}
DI Digital trigger source. More...
enum class | DIDigitalTriggerEdge { Rising , Falling }
DI Digital Trigger Edge. More...
enum class | DOSampleClockSource { Internal , External }
DO Sample Clock Source. More...
enum class | DOMode { Single = 3 , Finite = 0 , ContinuousWrapping = 1 , ContinuousNoWrapping = 2 }
DOMode. More...
enum class | DODigitalTriggerEdge { Rising , Falling }
DO Digital Trigger Edge. More...
enum class DODigitalTriggerSource {
PFI0 = 0x10 , PFI1 = 0x11 , PFI2 = 0x12 , PFI3 = 0x13 ,
PFI4 = 0x14 , PFI5 = 0x15 , PFI6 = 0x16 , PFI7 = 0x17 ,
PFI8 = 0x18 , PFI9 = 0x19 , PFI10 = 0x1A , PFI11 = 0x1B ,
PFI12 = 0x1C , PFI13 = 0x1D , PFI14 = 0x1E , PFI15 = 0x1F ,
PXI_Trig0 = 64 , PXI_Trig1 = 65 , PXI_Trig2 = 66 , PXI_Trig3 = 67 ,
PXI_Trig4 = 68 , PXI_Trig5 = 69 , PXI_Trig6 = 70 , PXI_Trig7 = 71 ,
AT_StartTrig = 11 , AI_ReferencetTrig = 12 , DI_StartTrig = 48 , DI_ReferencetTrig = 49
}
DO Digital trigger source. More...
enum class | DOTriggerType { Immediate = 0 , Digital = 1 , Soft = 3 }
TriggerType Digital/Immediate/Soft. More...
enum class | DOSignalExportSource { StartTrig = 51 , SampleClock = 54 }
SourceSignal. More...
enum class JY5310CoreOOLogLevel {
DEBUG_LOG_LEVEL , INFO_LOG_LEVEL , WARN_LOG_LEVEL , ERROR_LOG_LEVEL ,
FATAL_LOG_LEVEL
}

Functions

std::string GetSignalExportDestinationString (SignalExportDestination destination)

Enumeration Type Documentation

◆ AIAnalogTriggerComparator

enum class JY5310CoreOO::AIAnalogTriggerComparator
strong

AI Analog Trigger Comparator.

Enumerator
Edge | Edge Comparator.
Hysteresis | Hysteresis Comparator.
Window | Window Comparator.

◆ AIAnalogTriggerEdge

enum class JY5310CoreOO::AIAnalogTriggerEdge
strong
Enumerator
Rising | Rising.
Falling | Falling.

◆ AIAnalogTriggerSource

enum class JY5310CoreOO::AIAnalogTriggerSource
strong
Enumerator
Channel_0 | Channel_0 as the trigger source.
Channel_1 | Channel_1 as the trigger source.
Channel_2 | Channel_2 as the trigger source.
Channel_3 | Channel_3 as the trigger source.
Channel_4 | Channel_4 as the trigger source.
Channel_5 | Channel_5 as the trigger source.
Channel_6 | Channel_6 as the trigger source.
Channel_7 | Channel_7 as the trigger source.
Channel_8 | Channel_8 as the trigger source.
Channel_9 | Channel_9 as the trigger source.
Channel_10 | Channel_10 as the trigger source.
Channel_11 | Channel_11 as the trigger source.
Channel_12 | Channel_12 as the trigger source.
Channel_13 | Channel_13 as the trigger source.
Channel_14 | Channel_14 as the trigger source.
Channel_15 | Channel_15 as the trigger source.

◆ AIAnalogWindowCondition

enum class JY5310CoreOO::AIAnalogWindowCondition
strong

AI Analog Window Trigger Condition.

Enumerator
Entering | Rising.
Leaving | Falling.

◆ AIDigitalTriggerEdge

enum class JY5310CoreOO::AIDigitalTriggerEdge
strong
Enumerator
Rising | Rising.
Falling | Falling.

◆ AIDigitalTriggerSource

enum class JY5310CoreOO::AIDigitalTriggerSource
strong
Enumerator
PFI0
PFI1
PFI2
PFI3
PFI4
PFI5
PFI6
PFI7
PFI8
PFI9
PFI10
PFI11
PFI12
PFI13
PFI14
PFI15
DI_StartTrig
DI_ReferencetTrig
DO_StartTrig
PXI_Trig0
PXI_Trig1
PXI_Trig2
PXI_Trig3
PXI_Trig4
PXI_Trig5
PXI_Trig6
PXI_Trig7

◆ AIMode

enum class JY5310CoreOO::AIMode
strong
Enumerator
Finite
Continuous
Record

◆ AISampleClockSource

enum class JY5310CoreOO::AISampleClockSource
strong
Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ AISignalExportSource

enum class JY5310CoreOO::AISignalExportSource
strong
Enumerator
StartTrig | AI_StartTrig.
ReferenceTrig | AI_ReferenceTrig.
SampleClock | AI_SampleClock.

◆ AITriggerMode

enum class JY5310CoreOO::AITriggerMode
strong
Enumerator
Start | Start Trigger.
Reference | Reference Trigger，Valid when JY5310AITask.Mode is AIMode.Finite

◆ AITriggerType

enum class JY5310CoreOO::AITriggerType
strong
Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Analog | Analog Trigger.
Soft | Soft Trigger.

◆ ClockTerminal

enum class JY5310CoreOO::ClockTerminal
strong
Enumerator
ECLK | Extetnal Clock Terminal by Pin Define.
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11.
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PXI_Trig0 | PXITrigger_0.
PXI_Trig1 | PXITrigger_1.
PXI_Trig2 | PXITrigger_2.
PXI_Trig3 | PXITrigger_3.
PXI_Trig4 | PXITrigger_4.
PXI_Trig5 | PXITrigger_5.
PXI_Trig6 | PXITrigger_6.
PXI_Trig7 | PXITrigger_7.
AI_SampleClock | AI_SampleClock.
AO_SampleClock | AO_SampleClock.
DI_SampleClock | DI_SampleClock.
DO_SampleClock | DO_SampleClock.
CI0_SampleClock | CI0_SampleClock.
CI1_SampleClock | CI1_SampleClock.
CI2_SampleClock | CI2_SampleClock.
CI3_SampleClock | CI3_SampleClock.
CO_0_Output | CO_0_Output.
CO_1_Output | CO_1_Output.
CO_2_Output | CO_2_Output.
CO_3_Output | CO_3_Output.

◆ DIDigitalTriggerEdge

enum class JY5310CoreOO::DIDigitalTriggerEdge
strong

DI Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ DIDigitalTriggerSource

enum class JY5310CoreOO::DIDigitalTriggerSource
strong

DI Digital trigger source.

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11.
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
DO_StartTrig | DO_StartTrig.

◆ DIMode

enum class JY5310CoreOO::DIMode
strong

DIMode.

Enumerator
Single | Single.
Finite | Finite.
Continuous | Continuous.

◆ DISampleClockSource

enum class JY5310CoreOO::DISampleClockSource
strong

DI Sample Clock Source.

Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ DISignalExportSource

enum class JY5310CoreOO::DISignalExportSource
strong

SourceSignal.

Enumerator
StartTrig | DI_StartTrig.
ReferenceTrig | DI_ReferenceTrig.
SampleClock | DI_SampleClock.

◆ DITriggerMode

enum class JY5310CoreOO::DITriggerMode
strong

DI Trigger Mode.

Enumerator
Start | Start Trigger.
Reference | Reference Trigger，only for finite acquisition mode.

◆ DITriggerType

enum class JY5310CoreOO::DITriggerType
strong

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ DODigitalTriggerEdge

enum class JY5310CoreOO::DODigitalTriggerEdge
strong

DO Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ DODigitalTriggerSource

enum class JY5310CoreOO::DODigitalTriggerSource
strong

DO Digital trigger source.

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11.
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.
AT_StartTrig | AI_StartTrig.
AI_ReferencetTrig | AI_ReferencetTrig.
DI_StartTrig | DI_StartTrig.
DI_ReferencetTrig | DI_ReferencetTrig.

◆ DOMode

enum class JY5310CoreOO::DOMode
strong

DOMode.

Enumerator
Single | Single.
Finite | Finite.
ContinuousWrapping | ContinuousNoWrapping.
ContinuousNoWrapping | ContinuousWrapping.

◆ DOSampleClockSource

enum class JY5310CoreOO::DOSampleClockSource
strong

DO Sample Clock Source.

Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ DOSignalExportSource

enum class JY5310CoreOO::DOSignalExportSource
strong

SourceSignal.

Enumerator
StartTrig | DO_StartTrig.
SampleClock | DO_SampleClock.

◆ DOTriggerType

enum class JY5310CoreOO::DOTriggerType
strong

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ ExternalReferenceClockTerminal

enum class JY5310CoreOO::ExternalReferenceClockTerminal
strong
Enumerator
PXIe_Clk100

PXIe_Clk100.

◆ FileFormat

enum class JY5310CoreOO::FileFormat
strong
Enumerator
Bin

BIN。

BIN.

◆ InputTerminal

enum class JY5310CoreOO::InputTerminal
strong

Cunter Input Terminal.

Enumerator
Default | Default PFI pin by pin define.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
CI_0_OutPut | CI0_StartTrig.
CI_1_OutPut | CI1_StartTrig.
CI_2_OutPut | CI0_StartTrig.
CI_3_OutPut | CI1_StartTrig.

◆ IOTerminal

enum class JY5310CoreOO::IOTerminal
strong

Cunter IO Terminal.

Enumerator
Default | Default PFI pin by pin define.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.

◆ JY5310CoreOOLogLevel

enum class JY5310CoreOO::JY5310CoreOOLogLevel
strong
Enumerator
DEBUG_LOG_LEVEL
INFO_LOG_LEVEL
WARN_LOG_LEVEL
ERROR_LOG_LEVEL
FATAL_LOG_LEVEL

◆ JY5310CoreOOPropertyType

enum class JY5310CoreOO::JY5310CoreOOPropertyType
strong
Enumerator
READ_ONLY
WRITE_ONLY
READ_WRITE

◆ JYDriverExceptionPublic

enum class JY5310CoreOO::JYDriverExceptionPublic
strong
Enumerator
UnKnown | JYDriverExceptionPublic.
OpenDeviceFailed | JYDriverExceptionPublic.
CloseDeviceFailed | JYDriverExceptionPublic.
ResetDeviceFailed | JYDriverExceptionPublic.
GetDevicePropertyFailed | JYDriverExceptionPublic.
SetDevicePropertyFailed | JYDriverExceptionPublic.
HardwareResourceIsReserved | JYDriverExceptionPublic.
MethodNotPermitedToCallWhenCurrentStatus | JYDriverExceptionPublic.
InvalidUserDataBuffer | JYDriverExceptionPublic.
NoChannelAdded | JYDriverExceptionPublic.
NotSupportOperationForCurrentDevice | JYDriverExceptionPublic.
CreatTaskFailed | JYDriverExceptionPublic.
StartTaskFailed | JYDriverExceptionPublic.
StopTaskFailed | JYDriverExceptionPublic.
TaskHasNotStarted | JYDriverExceptionPublic.
TaskHasStartedCannotPerformTheSetOperation | JYDriverExceptionPublic.
ChannelNumberParameterInvalid | JYDriverExceptionPublic.
ChannelInputRangeParameterInvalid | JYDriverExceptionPublic.
ChannelTerminalParameterInvalid | JYDriverExceptionPublic.
ChannelCouplingParameterInvalid | JYDriverExceptionPublic.
SampeleModeParameterInvalid | JYDriverExceptionPublic.
SampleClockParameterInvalid | JYDriverExceptionPublic.
SampleRateParameterInvalid | JYDriverExceptionPublic.
UpdateRateParameterInvalid | JYDriverExceptionPublic.
TriggerParameterInvalid | JYDriverExceptionPublic.
ReferenceTriggerDoesNotMatchWithSampleMode | JYDriverExceptionPublic.
PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint | JYDriverExceptionPublic.
ReadDataFailed | JYDriverExceptionPublic.
ReadDataTimeout | JYDriverExceptionPublic.
WriteDataFailed | JYDriverExceptionPublic.
WriteDataTimeout | JYDriverExceptionPublic.
WriteDataLengthCannotBeLessThanN | JYDriverExceptionPublic.
BufferDataOverflow | JYDriverExceptionPublic.
BufferDataDownflow | JYDriverExceptionPublic.
CheckBufferFailed | JYDriverExceptionPublic.
PointInvalidInFiniteMode | JYDriverExceptionPublic.
ReadPointInvalid | JYDriverExceptionPublic.
OnlySupportRecordMode | JYDriverExceptionPublic.
SendSoftTirggerFailed | JYDriverExceptionPublic.
TaskTimeout | JYDriverExceptionPublic.
CounterParametersInvalid | JYDriverExceptionPublic.
WritePointInvalid | JYDriverExceptionPublic.
SignalExportDestinationInvalid | JYDriverExceptionPublic.
InvalidParameter | 无效参数。 Invalid parameter.

◆ LevelPolarity

enum class JY5310CoreOO::LevelPolarity
strong

Level Polarity.

Enumerator
LowLevel | Low level.
HighLevel | High level.
None | No active polarity.

◆ RecordMode

enum class JY5310CoreOO::RecordMode
strong
Enumerator
Finite | Finite Streaming.
Infinite | Infinite Streaming.

◆ ReferenceClockSource

enum class JY5310CoreOO::ReferenceClockSource
strong
Enumerator
Internal | Internal on board 25MHz Clock.
External | External Reference Clock Source.

◆ SignalExportDestination

enum class JY5310CoreOO::SignalExportDestination
strong
Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11.
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.

◆ SyncPulseRouting

enum class JY5310CoreOO::SyncPulseRouting
strong
Enumerator
NONE | Default NONE.
PXI_Trig0 | PXI Trig0.
PXI_Trig1 | PXI Trig1.
PXI_Trig2 | PXI Trig2.
PXI_Trig3 | PXI Trig3.
PXI_Trig4 | PXI Trig4.
PXI_Trig5 | PXI Trig5.
PXI_Trig6 | PXI Trig6.
PXI_Trig7 | PXI Trig7.

◆ SyncTopology

enum class JY5310CoreOO::SyncTopology
strong

Synchronization board configuration.

Enumerator
Independent | Independent, synchronization not supported
Master | master card
Slave | slave card

◆ SyncTriggerRouting

enum class JY5310CoreOO::SyncTriggerRouting
strong
Enumerator
NONE | Default NONE.
PXI_Trig0 | PXI Trig0.
PXI_Trig1 | PXI Trig1.
PXI_Trig2 | PXI Trig2.
PXI_Trig3 | PXI Trig3.
PXI_Trig4 | PXI Trig4.
PXI_Trig5 | PXI Trig5.
PXI_Trig6 | PXI Trig6.
PXI_Trig7 | PXI Trig7.

Function Documentation

◆ GetSignalExportDestinationString()

std::string JY5310CoreOO::GetSignalExportDestinationString ( SignalExportDestination destination )
inline


5310 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5310/JY5310CoreOOCommon.h File Reference

  • File List
  • File Members
  • COO
  • 5310
Classes | Namespaces | Macros | Enumerations | Functions
JY5310CoreOOCommon.h File Reference
#include <string>
#include <stdint.h>

Classes

class | JY5310CoreOO::JYDriverException
class | JY5310CoreOO::JY5310CoreOOProperty< ContainerClass, ValueType, propertyType >
属性模板类 More...
class | JY5310CoreOO::PauseTrigger
Pause trigger configuration class. More...

Namespaces

namespace JY5310CoreOO

Macros

#define | EXTERN_C extern
Windows.
#define | JY5310CoreOO_API

Enumerations

enum class | JY5310CoreOO::JY5310CoreOOPropertyType { JY5310CoreOO::READ_ONLY = 1 , JY5310CoreOO::WRITE_ONLY = 2 , JY5310CoreOO::READ_WRITE = 3 }
enum class JY5310CoreOO::JYDriverExceptionPublic {
JY5310CoreOO::UnKnown = 0 , JY5310CoreOO::OpenDeviceFailed = -10001 , JY5310CoreOO::CloseDeviceFailed = -10002 , JY5310CoreOO::ResetDeviceFailed = -10003 ,
JY5310CoreOO::GetDevicePropertyFailed = -10004 , JY5310CoreOO::SetDevicePropertyFailed = -10005 , JY5310CoreOO::HardwareResourceIsReserved = -10006 , JY5310CoreOO::MethodNotPermitedToCallWhenCurrentStatus = -10007 ,
JY5310CoreOO::InvalidUserDataBuffer = -10008 , JY5310CoreOO::NoChannelAdded = -10009 , JY5310CoreOO::NotSupportOperationForCurrentDevice = -10010 , JY5310CoreOO::CreatTaskFailed = -10100 ,
JY5310CoreOO::StartTaskFailed = -10101 , JY5310CoreOO::StopTaskFailed = -10102 , JY5310CoreOO::TaskHasNotStarted = -10103 , JY5310CoreOO::TaskHasStartedCannotPerformTheSetOperation = -10104 ,
JY5310CoreOO::ChannelNumberParameterInvalid = -10105 , JY5310CoreOO::ChannelInputRangeParameterInvalid = -10106 , JY5310CoreOO::ChannelTerminalParameterInvalid = -10107 , JY5310CoreOO::ChannelCouplingParameterInvalid = -10108 ,
JY5310CoreOO::SampeleModeParameterInvalid = -10109 , JY5310CoreOO::SampleClockParameterInvalid = -10110 , JY5310CoreOO::SampleRateParameterInvalid = -10111 , JY5310CoreOO::UpdateRateParameterInvalid = -10112 ,
JY5310CoreOO::TriggerParameterInvalid = -10113 , JY5310CoreOO::ReferenceTriggerDoesNotMatchWithSampleMode = -10114 , JY5310CoreOO::PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint = -10115 , JY5310CoreOO::ReadDataFailed = -10016 ,
JY5310CoreOO::ReadDataTimeout = -10017 , JY5310CoreOO::WriteDataFailed = -10018 , JY5310CoreOO::WriteDataTimeout = -10019 , JY5310CoreOO::WriteDataLengthCannotBeLessThanN = -10020 ,
JY5310CoreOO::BufferDataOverflow = -10021 , JY5310CoreOO::BufferDataDownflow = -10022 , JY5310CoreOO::CheckBufferFailed = -10023 , JY5310CoreOO::PointInvalidInFiniteMode = -10024 ,
JY5310CoreOO::ReadPointInvalid = -10025 , JY5310CoreOO::OnlySupportRecordMode = -10026 , JY5310CoreOO::SendSoftTirggerFailed = -10027 , JY5310CoreOO::TaskTimeout = -10028 ,
JY5310CoreOO::CounterParametersInvalid = -10029 , JY5310CoreOO::WritePointInvalid = -10030 , JY5310CoreOO::SignalExportDestinationInvalid = -10031 , JY5310CoreOO::InvalidParameter = -10033
}
enum class JY5310CoreOO::ClockTerminal {
JY5310CoreOO::ECLK = 10000 , JY5310CoreOO::PFI0 = 0 , JY5310CoreOO::PFI1 = 1 , JY5310CoreOO::PFI2 = 2 ,
JY5310CoreOO::PFI3 = 3 , JY5310CoreOO::PFI4 = 4 , JY5310CoreOO::PFI5 = 5 , JY5310CoreOO::PFI6 = 6 ,
JY5310CoreOO::PFI7 = 7 , JY5310CoreOO::PFI8 = 8 , JY5310CoreOO::PFI9 = 9 , JY5310CoreOO::PFI10 = 10 ,
JY5310CoreOO::PFI11 = 11 , JY5310CoreOO::PFI12 = 12 , JY5310CoreOO::PFI13 = 13 , JY5310CoreOO::PFI14 = 14 ,
JY5310CoreOO::PFI15 = 15 , JY5310CoreOO::PXI_Trig0 = 40 , JY5310CoreOO::PXI_Trig1 = 41 , JY5310CoreOO::PXI_Trig2 = 42 ,
JY5310CoreOO::PXI_Trig3 = 43 , JY5310CoreOO::PXI_Trig4 = 44 , JY5310CoreOO::PXI_Trig5 = 45 , JY5310CoreOO::PXI_Trig6 = 46 ,
JY5310CoreOO::PXI_Trig7 = 47 , JY5310CoreOO::AI_SampleClock = 20 , JY5310CoreOO::AO_SampleClock = 28 , JY5310CoreOO::DI_SampleClock = 53 ,
JY5310CoreOO::DO_SampleClock = 54 , JY5310CoreOO::CI0_SampleClock = 36 , JY5310CoreOO::CI1_SampleClock = 50 , JY5310CoreOO::CI2_SampleClock = 59 ,
JY5310CoreOO::CI3_SampleClock = 65 , JY5310CoreOO::CO_0_Output = 37 , JY5310CoreOO::CO_1_Output = 51 , JY5310CoreOO::CO_2_Output = 60 ,
JY5310CoreOO::CO_3_Output = 66
}
enum class JY5310CoreOO::SignalExportDestination {
JY5310CoreOO::PFI0 , JY5310CoreOO::PFI1 , JY5310CoreOO::PFI2 , JY5310CoreOO::PFI3 ,
JY5310CoreOO::PFI4 , JY5310CoreOO::PFI5 , JY5310CoreOO::PFI6 , JY5310CoreOO::PFI7 ,
JY5310CoreOO::PFI8 , JY5310CoreOO::PFI9 , JY5310CoreOO::PFI10 , JY5310CoreOO::PFI11 ,
JY5310CoreOO::PFI12 , JY5310CoreOO::PFI13 , JY5310CoreOO::PFI14 , JY5310CoreOO::PFI15 ,
JY5310CoreOO::PXI_Trig0 = 0x20 , JY5310CoreOO::PXI_Trig1 = 0x21 , JY5310CoreOO::PXI_Trig2 = 0x22 , JY5310CoreOO::PXI_Trig3 = 0x23 ,
JY5310CoreOO::PXI_Trig4 = 0x24 , JY5310CoreOO::PXI_Trig5 = 0x25 , JY5310CoreOO::PXI_Trig6 = 0x26 , JY5310CoreOO::PXI_Trig7 = 0x27
}
enum class JY5310CoreOO::IOTerminal {
JY5310CoreOO::Default = 0 , JY5310CoreOO::PXI_Trig0 = 0x20 , JY5310CoreOO::PXI_Trig1 = 0x21 , JY5310CoreOO::PXI_Trig2 = 0x22 ,
JY5310CoreOO::PXI_Trig3 = 0x23 , JY5310CoreOO::PXI_Trig4 = 0x24 , JY5310CoreOO::PXI_Trig5 = 0x25 , JY5310CoreOO::PXI_Trig6 = 0x26 ,
JY5310CoreOO::PXI_Trig7 = 0x27
}
Cunter IO Terminal. More...
enum class | JY5310CoreOO::LevelPolarity { JY5310CoreOO::LowLevel = 0 , JY5310CoreOO::HighLevel = 1 , JY5310CoreOO::None = 2 }
Level Polarity. More...
enum class JY5310CoreOO::InputTerminal {
JY5310CoreOO::Default = 0 , JY5310CoreOO::PXI_Trig0 = 40 , JY5310CoreOO::PXI_Trig1 = 41 , JY5310CoreOO::PXI_Trig2 = 42 ,
JY5310CoreOO::PXI_Trig3 = 43 , JY5310CoreOO::PXI_Trig4 = 44 , JY5310CoreOO::PXI_Trig5 = 45 , JY5310CoreOO::PXI_Trig6 = 46 ,
JY5310CoreOO::PXI_Trig7 = 47 , JY5310CoreOO::CI_0_OutPut = 37 , JY5310CoreOO::CI_1_OutPut = 51 , JY5310CoreOO::CI_2_OutPut = 60 ,
JY5310CoreOO::CI_3_OutPut = 66
}
Cunter Input Terminal. More...

Functions

std::string JY5310CoreOO::GetSignalExportDestinationString (SignalExportDestination destination)

Macro Definition Documentation

◆ EXTERN_C

#define EXTERN_C extern

Windows.

Linux

◆ JY5310CoreOO_API

#define JY5310CoreOO_API


5310 C++ Programming Manual: JY5310CoreOO::JYDriverException Class Reference

  • JYDriverException
Public Member Functions | Public Attributes | List of all members
JY5310CoreOO::JYDriverException Class Reference

#include <JY5310CoreOOCommon.h>

Public Member Functions

JYDriverException (JYDriverExceptionPublic exceptionCode, std::string msg="")
JYDriverException (int, std::string msg)

Public Attributes

std::string exceptionMessage
JYDriverExceptionPublic errorCode
JYDriverException * FollowingException

Constructor & Destructor Documentation

◆ JYDriverException() [1/2]

JY5310CoreOO::JYDriverException::JYDriverException | ( | JYDriverExceptionPublic | exceptionCode,
 |  | std::string | msg = "" )

◆ JYDriverException() [2/2]

JY5310CoreOO::JYDriverException::JYDriverException | ( | int | ,
 |  | std::string | msg )

Member Data Documentation

◆ errorCode

JYDriverExceptionPublic JY5310CoreOO::JYDriverException::errorCode

◆ exceptionMessage

std::string JY5310CoreOO::JYDriverException::exceptionMessage

◆ FollowingException

JYDriverException* JY5310CoreOO::JYDriverException::FollowingException
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5310/JY5310CoreOOCommon.h


5310 C++ Programming Manual: JY5310CoreOO::JY5310CoreOOProperty< ContainerClass, ValueType, propertyType > Class Template Reference

  • JY5310CoreOOProperty
Public Member Functions | List of all members
JY5310CoreOO::JY5310CoreOOProperty< ContainerClass, ValueType, propertyType > Class Template Reference

属性模板类 More...

#include <JY5310CoreOOCommon.h>

Public Member Functions

JY5310CoreOOProperty ()
JY5310CoreOOProperty (ContainerClass *cObject, ValueType(ContainerClass::*pGet)(), void(ContainerClass::*pSet)(ValueType value))
JY5310CoreOOProperty (ValueType(*pGet)(), void(*pSet)(ValueType value))
ValueType operator= (const ValueType &value)
operator ValueType ()

Detailed Description

template<typename ContainerClass, typename ValueType, JY5310CoreOOPropertyType propertyType>
class JY5310CoreOO::JY5310CoreOOProperty< ContainerClass, ValueType, propertyType >

属性模板类

Constructor & Destructor Documentation

◆ JY5310CoreOOProperty() [1/3]

template<typename ContainerClass, typename ValueType, JY5310CoreOOPropertyType propertyType>
JY5310CoreOO::JY5310CoreOOProperty< ContainerClass, ValueType, propertyType >::JY5310CoreOOProperty ( )

◆ JY5310CoreOOProperty() [2/3]

template<typename ContainerClass, typename ValueType, JY5310CoreOOPropertyType propertyType>
JY5310CoreOO::JY5310CoreOOProperty< ContainerClass, ValueType, propertyType >::JY5310CoreOOProperty | ( | ContainerClass * | cObject,
 |  | ValueType(ContainerClass::* | pGet )(),
 |  | void(ContainerClass::* | pSet )(ValueType value) )

◆ JY5310CoreOOProperty() [3/3]

template<typename ContainerClass, typename ValueType, JY5310CoreOOPropertyType propertyType>
JY5310CoreOO::JY5310CoreOOProperty< ContainerClass, ValueType, propertyType >::JY5310CoreOOProperty | ( | ValueType(* | pGet )(),
 |  | void(* | pSet )(ValueType value) )

Member Function Documentation

◆ operator ValueType()

template<typename ContainerClass, typename ValueType, JY5310CoreOOPropertyType propertyType>
JY5310CoreOO::JY5310CoreOOProperty< ContainerClass, ValueType, propertyType >::operator ValueType ( )

◆ operator=()

template<typename ContainerClass, typename ValueType, JY5310CoreOOPropertyType propertyType>
ValueType JY5310CoreOO::JY5310CoreOOProperty< ContainerClass, ValueType, propertyType >::operator= ( const ValueType & value )
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5310/JY5310CoreOOCommon.h


5310 C++ Programming Manual: JY5310CoreOO::PauseTrigger Class Reference

  • PauseTrigger
Public Attributes | List of all members
JY5310CoreOO::PauseTrigger Class Reference

Pause trigger configuration class. More...

#include <JY5310CoreOOCommon.h>

Public Attributes

LevelPolarity ActivePolarity
Pause trigger active polarity.
InputTerminal Terminal
Terminal.

Detailed Description

Pause trigger configuration class.

Member Data Documentation

◆ ActivePolarity

LevelPolarity JY5310CoreOO::PauseTrigger::ActivePolarity

Pause trigger active polarity.

The default value is LevelPolarity.None, means the pause trigger is disabled.

◆ Terminal

InputTerminal JY5310CoreOO::PauseTrigger::Terminal

Terminal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5310/JY5310CoreOOCommon.h


5310 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5310/JY5310CoreOODevice.h File Reference

  • File List
  • File Members
  • COO
  • 5310
Classes | Namespaces | Enumerations
JY5310CoreOODevice.h File Reference
#include <iostream>
#include <list>
#include <vector>
#include "JY5310CoreOOCommon.h"

Classes

class | JY5310CoreOO::JY5310CoreOODevice
class | JY5310CoreOO::ExternalReferenceClock
External Reference Clcok Terminal. More...
class | JY5310CoreOO::JY5310CoreOOReferenceClock

Namespaces

namespace JY5310CoreOO

Enumerations

enum class | JY5310CoreOO::ExternalReferenceClockTerminal { JY5310CoreOO::PXIe_Clk100 = 0x1 }
enum class | JY5310CoreOO::ReferenceClockSource { JY5310CoreOO::Internal = 0x0 , JY5310CoreOO::External = 0x1 }


5310 C++ Programming Manual: JY5310CoreOO::JY5310CoreOODevice Class Reference

  • JY5310CoreOODevice
Static Public Member Functions | Public Attributes | List of all members
JY5310CoreOO::JY5310CoreOODevice Class Reference

#include <JY5310CoreOODevice.h>

Static Public Member Functions

static JY5310CoreOODevice * | GetInstance (int cardNum)
The operation instance is obtained according to the board number to ensure that there is only one registered instance for each board.
static JY5310CoreOODevice * | GetInstance (std::string aliasName)
The operation instance is obtained according to aliasName to ensure that there is only one registration instance for each board.

Public Attributes

const double | BoardClockRate = 200000000
Board Clock Rate.
const double | MaxSampleRateMutilChannel = 1000000
const int | AIBufferSize = 0x100000 * 256
AI Buffer Size.
const bool | IsAISync = true
const bool | IsAOSync = true
IsAOSync.
const int | LineCountPerPort = 2
DIOLineCountPerPort.
const int | DIOPortCount = 8
DIOPortCount.
JY5310CoreOOProperty< JY5310CoreOODevice, int, JY5310CoreOOPropertyType::READ_ONLY > | DiffChannelCount
JY5310CoreOOProperty< JY5310CoreOODevice, double, JY5310CoreOOPropertyType::READ_ONLY > | MaxSampleRateSingleChannel
JY5310CoreOOProperty< JY5310CoreOODevice, std::string, JY5310CoreOOPropertyType::READ_ONLY > | SerialNumber
JY5310CoreOOProperty< JY5310CoreOODevice, int, JY5310CoreOOPropertyType::READ_ONLY > | DeviceID
JY5310CoreOOProperty< JY5310CoreOODevice, void *, JY5310CoreOOPropertyType::READ_ONLY > | Handle
JY5310CoreOOReferenceClock * ReferenceClock
Reference Clock Configuration.

Member Function Documentation

◆ GetInstance() [1/2]

static JY5310CoreOODevice * JY5310CoreOO::JY5310CoreOODevice::GetInstance ( int cardNum )
static

The operation instance is obtained according to the board number to ensure that there is only one registered instance for each board.

Parameters
cardNum
Returns

◆ GetInstance() [2/2]

static JY5310CoreOODevice * JY5310CoreOO::JY5310CoreOODevice::GetInstance ( std::string aliasName )
static

The operation instance is obtained according to aliasName to ensure that there is only one registration instance for each board.

Parameters
aliasName
Returns

Member Data Documentation

◆ AIBufferSize

const int JY5310CoreOO::JY5310CoreOODevice::AIBufferSize = 0x100000 * 256

AI Buffer Size.

◆ BoardClockRate

const double JY5310CoreOO::JY5310CoreOODevice::BoardClockRate = 200000000

Board Clock Rate.

◆ DeviceID

JY5310CoreOOProperty<JY5310CoreOODevice, int, JY5310CoreOOPropertyType::READ_ONLY> JY5310CoreOO::JY5310CoreOODevice::DeviceID

◆ DiffChannelCount

JY5310CoreOOProperty<JY5310CoreOODevice, int, JY5310CoreOOPropertyType::READ_ONLY> JY5310CoreOO::JY5310CoreOODevice::DiffChannelCount

◆ DIOPortCount

const int JY5310CoreOO::JY5310CoreOODevice::DIOPortCount = 8

DIOPortCount.

◆ Handle

JY5310CoreOOProperty<JY5310CoreOODevice, void*, JY5310CoreOOPropertyType::READ_ONLY> JY5310CoreOO::JY5310CoreOODevice::Handle

◆ IsAISync

const bool JY5310CoreOO::JY5310CoreOODevice::IsAISync = true

◆ IsAOSync

const bool JY5310CoreOO::JY5310CoreOODevice::IsAOSync = true

IsAOSync.

◆ LineCountPerPort

const int JY5310CoreOO::JY5310CoreOODevice::LineCountPerPort = 2

DIOLineCountPerPort.

◆ MaxSampleRateMutilChannel

const double JY5310CoreOO::JY5310CoreOODevice::MaxSampleRateMutilChannel = 1000000

◆ MaxSampleRateSingleChannel

JY5310CoreOOProperty<JY5310CoreOODevice, double, JY5310CoreOOPropertyType::READ_ONLY> JY5310CoreOO::JY5310CoreOODevice::MaxSampleRateSingleChannel

◆ ReferenceClock

JY5310CoreOOReferenceClock* JY5310CoreOO::JY5310CoreOODevice::ReferenceClock

Reference Clock Configuration.

◆ SerialNumber

JY5310CoreOOProperty<JY5310CoreOODevice, std::string, JY5310CoreOOPropertyType::READ_ONLY> JY5310CoreOO::JY5310CoreOODevice::SerialNumber
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5310/JY5310CoreOODevice.h


5310 C++ Programming Manual: JY5310CoreOO::ExternalReferenceClock Class Reference

  • ExternalReferenceClock
Public Attributes | List of all members
JY5310CoreOO::ExternalReferenceClock Class Reference

External Reference Clcok Terminal. More...

#include <JY5310CoreOODevice.h>

Public Attributes

ExternalReferenceClockTerminal Terminal

Detailed Description

External Reference Clcok Terminal.

Member Data Documentation

◆ Terminal

ExternalReferenceClockTerminal JY5310CoreOO::ExternalReferenceClock::Terminal
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5310/JY5310CoreOODevice.h


5310 C++ Programming Manual: JY5310CoreOO::JY5310CoreOOReferenceClock Class Reference

  • JY5310CoreOOReferenceClock
Public Member Functions | Public Attributes | List of all members
JY5310CoreOO::JY5310CoreOOReferenceClock Class Reference

#include <JY5310CoreOODevice.h>

Public Member Functions

void Commit ()
Commit configuration.

Public Attributes

ReferenceClockSource Source
ExternalReferenceClock * External
External Reference Clock Source.

Member Function Documentation

◆ Commit()

void JY5310CoreOO::JY5310CoreOOReferenceClock::Commit ( )

Commit configuration.

Available only when the device is idle. WARNING: Incorrect parameters will cause the PLL to be unable to lock the reference clock and cannot be recovered until shutdown and restart.

Member Data Documentation

◆ External

ExternalReferenceClock* JY5310CoreOO::JY5310CoreOOReferenceClock::External

External Reference Clock Source.

Required when ReferenceClock.Source is ReferenceClockSource.External

◆ Source

ReferenceClockSource JY5310CoreOO::JY5310CoreOOReferenceClock::Source
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5310/JY5310CoreOODevice.h


5310 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5310/JY5310CoreOODITask.h File Reference

  • File List
  • File Members
  • COO
  • 5310
Classes | Namespaces | Enumerations
JY5310CoreOODITask.h File Reference
#include <map>
#include <mutex>
#include "JY5310CoreOOCommon.h"
#include "JY5310CoreOODevice.h"

Classes

class | JY5310CoreOO::JY5310CoreOODITask
class | JY5310CoreOO::DIChannel
DI Channel parameter class . More...
class | JY5310CoreOO::DISampleClock
Sample clock configuration class. More...
class | JY5310CoreOO::DIExternalSampleClock
External Sample Clock Configuration Class. More...
class | JY5310CoreOO::DISignalExport
DI Signal Export Class. More...
class | JY5310CoreOO::DITrigger
Constructor to create an DITrigger task object. More...
class | JY5310CoreOO::DIDigitalTrigger
DI Digital trigger . More...

Namespaces

namespace JY5310CoreOO

Enumerations

enum class | JY5310CoreOO::DISampleClockSource { JY5310CoreOO::Internal , JY5310CoreOO::External }
DI Sample Clock Source. More...
enum class | JY5310CoreOO::DIMode { JY5310CoreOO::Single = 2 , JY5310CoreOO::Finite = 0 , JY5310CoreOO::Continuous = 1 }
DIMode. More...
enum class | JY5310CoreOO::DISignalExportSource { JY5310CoreOO::StartTrig = 22 , JY5310CoreOO::ReferenceTrig = 23 , JY5310CoreOO::SampleClock = 53 }
SourceSignal. More...
enum class | JY5310CoreOO::DITriggerMode { JY5310CoreOO::Start , JY5310CoreOO::Reference }
DI Trigger Mode. More...
enum class | JY5310CoreOO::DITriggerType { JY5310CoreOO::Immediate = 0 , JY5310CoreOO::Digital = 1 , JY5310CoreOO::Soft = 3 }
TriggerType Digital/Immediate/Soft. More...
enum class JY5310CoreOO::DIDigitalTriggerSource {
JY5310CoreOO::PFI0 = 0x10 , JY5310CoreOO::PFI1 = 0x11 , JY5310CoreOO::PFI2 = 0x12 , JY5310CoreOO::PFI3 = 0x13 ,
JY5310CoreOO::PFI4 = 0x14 , JY5310CoreOO::PFI5 = 0x15 , JY5310CoreOO::PFI6 = 0x16 , JY5310CoreOO::PFI7 = 0x17 ,
JY5310CoreOO::PFI8 = 0x18 , JY5310CoreOO::PFI9 = 0x19 , JY5310CoreOO::PFI10 = 0x1A , JY5310CoreOO::PFI11 = 0x1B ,
JY5310CoreOO::PFI12 = 0x1C , JY5310CoreOO::PFI13 = 0x1D , JY5310CoreOO::PFI14 = 0x1E , JY5310CoreOO::PFI15 = 0x1F ,
JY5310CoreOO::PXI_Trig0 = 64 , JY5310CoreOO::PXI_Trig1 = 65 , JY5310CoreOO::PXI_Trig2 = 66 , JY5310CoreOO::PXI_Trig3 = 67 ,
JY5310CoreOO::PXI_Trig4 = 68 , JY5310CoreOO::PXI_Trig5 = 69 , JY5310CoreOO::PXI_Trig6 = 70 , JY5310CoreOO::PXI_Trig7 = 71 ,
JY5310CoreOO::AI_StartTrig = 11 , JY5310CoreOO::AI_ReferenceTrig = 12 , JY5310CoreOO::DO_StartTrig = 51
}
DI Digital trigger source. More...
enum class | JY5310CoreOO::DIDigitalTriggerEdge { JY5310CoreOO::Rising , JY5310CoreOO::Falling }
DI Digital Trigger Edge. More...


5310 C++ Programming Manual: JY5310CoreOO::JY5310CoreOODITask Class Reference

  • JY5310CoreOODITask
Public Member Functions | Public Attributes | List of all members
JY5310CoreOO::JY5310CoreOODITask Class Reference

#include <JY5310CoreOODITask.h>

Public Member Functions

JY5310CoreOODITask (int slotNum)
JY5310CoreOODITask (std::string boardName)
~JY5310CoreOODITask ()
void | AddChannel (int portNum)
Add one channel.
void | AddChannel (std::vector< int > portsNum)
Add a group of channel.
void | RemoveChannel (int portNum)
Delete the specified port number .If it is -1, delete all ports.
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Start ()
Start DI task .
void | Stop ()
Stop DI task .
void | ReadSinglePoint (std::vector< bool > &readValues, int port)
Read one sample for specified channel in register.
void | ReadData (uint16_t dataBuffer[], uint32_t samplesToAcquire, int timeOut=10000)
Write the uint data from one port or multi-ports.
void | ReadData (uint8_t dataBuffer[], uint32_t samplesToAcquire, int timeOut=10000)
Read the byte data from one port.

Public Attributes

std::list< DIChannel * > | Channels
List of DI channels,(5312 5515 support 8 ports)
DIMode Mode
DI acquisition mode，support Single/ Finite/Continuous.
JY5310CoreOOProperty< JY5310CoreOODITask, double, JY5310CoreOOPropertyType::READ_WRITE > | SampleRate
Sample rate per channel.
int | SamplesToAcquire
Number of samples to be read per channel.
DISampleClock * SampleClock
DI Sample Clock Configuration.
JY5310CoreOOProperty< JY5310CoreOODITask, int, JY5310CoreOOPropertyType::READ_ONLY > | BufLenInSamples
Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.
JY5310CoreOOProperty< JY5310CoreOODITask, uint64_t, JY5310CoreOOPropertyType::READ_ONLY > | AvailableSamples
Number of samples per channel that can be read in the buffer.
JY5310CoreOOProperty< JY5310CoreOODITask, uint64_t, JY5310CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
DITrigger * Trigger
DI Trigger Configuration.
DISignalExport * SignalExport
Export DI Signal.
JY5310CoreOODevice * Device
Device.

Constructor & Destructor Documentation

◆ JY5310CoreOODITask() [1/2]

JY5310CoreOO::JY5310CoreOODITask::JY5310CoreOODITask ( int slotNum )

◆ JY5310CoreOODITask() [2/2]

JY5310CoreOO::JY5310CoreOODITask::JY5310CoreOODITask ( std::string boardName )

◆ ~JY5310CoreOODITask()

JY5310CoreOO::JY5310CoreOODITask::~JY5310CoreOODITask ( )

Member Function Documentation

◆ AddChannel() [1/2]

void JY5310CoreOO::JY5310CoreOODITask::AddChannel ( int portNum )

Add one channel.

Parameters
portNum port number to be added.

◆ AddChannel() [2/2]

void JY5310CoreOO::JY5310CoreOODITask::AddChannel ( std::vector< int > portsNum )

Add a group of channel.

Parameters
portsNum an array of port numbers of added ports.

◆ ReadData() [1/2]

void JY5310CoreOO::JY5310CoreOODITask::ReadData | ( | uint16_t | dataBuffer[],
 |  | uint32_t | samplesToAcquire,
 |  | int | timeOut = 10000 )

Write the uint data from one port or multi-ports.

There are 8 ports, from 0 to 7. Each port has 2 lines, from 0 to 1. There are a total of 16 lines from 0 to 15. Each bit from low to high represents one line.

Parameters
dataBuffer | Data buffer
samplesToAcquire | Number of samples per port to be read
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadData() [2/2]

void JY5310CoreOO::JY5310CoreOODITask::ReadData | ( | uint8_t | dataBuffer[],
 |  | uint32_t | samplesToAcquire,
 |  | int | timeOut = 10000 )

Read the byte data from one port.

Each port has 2 lines from 0 to 1. Each bit from low to high represents one line.

Parameters
dataBuffer | Data buffer
samplesToAcquire | Number of samples per port to be read
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadSinglePoint()

void JY5310CoreOO::JY5310CoreOODITask::ReadSinglePoint | ( | std::vector< bool > & | readValues,
 |  | int | port )

Read one sample for specified channel in register.

. Available when Mode is DIMode.Single

Parameters
readValues | vector<bool>
port | Specified port numbers or -1.when port is -1,Each port reads the latest point

◆ RemoveChannel()

void JY5310CoreOO::JY5310CoreOODITask::RemoveChannel ( int portNum )

Delete the specified port number .If it is -1, delete all ports.

Parameters
portNum port number to be delete.

◆ SendSoftwareTrigger()

void JY5310CoreOO::JY5310CoreOODITask::SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5310CoreOO::JY5310CoreOODITask::Start ( )

Start DI task .

◆ Stop()

void JY5310CoreOO::JY5310CoreOODITask::Stop ( )

Stop DI task .

Member Data Documentation

◆ AvailableSamples

JY5310CoreOOProperty<JY5310CoreOODITask, uint64_t, JY5310CoreOOPropertyType::READ_ONLY> JY5310CoreOO::JY5310CoreOODITask::AvailableSamples

Number of samples per channel that can be read in the buffer.

◆ BufLenInSamples

JY5310CoreOOProperty<JY5310CoreOODITask, int, JY5310CoreOOPropertyType::READ_ONLY> JY5310CoreOO::JY5310CoreOODITask::BufLenInSamples

Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.

◆ Channels

std::list<DIChannel*> JY5310CoreOO::JY5310CoreOODITask::Channels

List of DI channels,(5312 5515 support 8 ports)

◆ Device

JY5310CoreOODevice* JY5310CoreOO::JY5310CoreOODITask::Device

Device.

◆ Mode

DIMode JY5310CoreOO::JY5310CoreOODITask::Mode

DI acquisition mode，support Single/ Finite/Continuous.

◆ SampleClock

DISampleClock* JY5310CoreOO::JY5310CoreOODITask::SampleClock

DI Sample Clock Configuration.

◆ SampleRate

JY5310CoreOOProperty<JY5310CoreOODITask, double, JY5310CoreOOPropertyType::READ_WRITE> JY5310CoreOO::JY5310CoreOODITask::SampleRate

Sample rate per channel.

Maximum sample rate is 10M The defalut sample rate = 10k You can read this property to obtain the sample rate that will actually take effect in the current configuration.

◆ SamplesToAcquire

int JY5310CoreOO::JY5310CoreOODITask::SamplesToAcquire

Number of samples to be read per channel.

Only valid when Mode is DIMode.Finite.

◆ SignalExport

DISignalExport* JY5310CoreOO::JY5310CoreOODITask::SignalExport

Export DI Signal.

◆ TransferedSamples

JY5310CoreOOProperty<JY5310CoreOODITask, uint64_t, JY5310CoreOOPropertyType::READ_ONLY> JY5310CoreOO::JY5310CoreOODITask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT DIMode::Single.

◆ Trigger

DITrigger* JY5310CoreOO::JY5310CoreOODITask::Trigger

DI Trigger Configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5310/JY5310CoreOODITask.h


5310 C++ Programming Manual: JY5310CoreOO::DIChannel Class Reference

  • DIChannel
Public Attributes | List of all members
JY5310CoreOO::DIChannel Class Reference

DI Channel parameter class . More...

#include <JY5310CoreOODITask.h>

Public Attributes

int PortNum
port number.

Detailed Description

DI Channel parameter class .

Member Data Documentation

◆ PortNum

int JY5310CoreOO::DIChannel::PortNum

port number.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5310/JY5310CoreOODITask.h


5310 C++ Programming Manual: JY5310CoreOO::DISampleClock Class Reference

  • DISampleClock
Public Attributes | List of all members
JY5310CoreOO::DISampleClock Class Reference

Sample clock configuration class. More...

#include <JY5310CoreOODITask.h>

Public Attributes

DISampleClockSource Source
Clock Source.
DIExternalSampleClock * External
External Sample Clock, Valid when Source is DISampleClockSource.External.

Detailed Description

Sample clock configuration class.

Member Data Documentation

◆ External

DIExternalSampleClock* JY5310CoreOO::DISampleClock::External

External Sample Clock, Valid when Source is DISampleClockSource.External.

◆ Source

DISampleClockSource JY5310CoreOO::DISampleClock::Source

Clock Source.

enum Internal/External

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5310/JY5310CoreOODITask.h


5310 C++ Programming Manual: JY5310CoreOO::DIExternalSampleClock Class Reference

  • DIExternalSampleClock
Public Attributes | List of all members
JY5310CoreOO::DIExternalSampleClock Class Reference

External Sample Clock Configuration Class. More...

#include <JY5310CoreOODITask.h>

Public Attributes

ClockTerminal Terminal
External Sample Clock Input Terminal.
double ExpectedRate
Expected External Sample Clock Rate.

Detailed Description

External Sample Clock Configuration Class.

Member Data Documentation

◆ ExpectedRate

double JY5310CoreOO::DIExternalSampleClock::ExpectedRate

Expected External Sample Clock Rate.

◆ Terminal

ClockTerminal JY5310CoreOO::DIExternalSampleClock::Terminal

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5310/JY5310CoreOODITask.h


5310 C++ Programming Manual: JY5310CoreOO::DISignalExport Class Reference

  • DISignalExport
Public Member Functions | List of all members
JY5310CoreOO::DISignalExport Class Reference

DI Signal Export Class. More...

#include <JY5310CoreOODITask.h>

Public Member Functions

void | Add (DISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (DISignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

DI Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY5310CoreOO::DISignalExport::Add | ( | DISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | CI Signal Source
destination | Export Desination

◆ Add() [2/2]

void JY5310CoreOO::DISignalExport::Add | ( | DISignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | CI Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JY5310CoreOO::DISignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5310CoreOO::DISignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5310/JY5310CoreOODITask.h


5310 C++ Programming Manual: JY5310CoreOO::DITrigger Class Reference

  • DITrigger
Public Attributes | List of all members
JY5310CoreOO::DITrigger Class Reference

Constructor to create an DITrigger task object. More...

#include <JY5310CoreOODITask.h>

Public Attributes

DITriggerType Type
DI trigger type.
DITriggerMode Mode
DI trigger mode.
DIDigitalTrigger * Digital
DI Digital Trigger.Valid when Type is DITriggerType.Digital.
uint32_t PreTriggerSamples
Pretrigger Samples, must be less than or equal to JY5310DITask.SamplesToAcquire.

Detailed Description

Constructor to create an DITrigger task object.

Used to build DI Trigger

Member Data Documentation

◆ Digital

DIDigitalTrigger* JY5310CoreOO::DITrigger::Digital

DI Digital Trigger.Valid when Type is DITriggerType.Digital.

◆ Mode

DITriggerMode JY5310CoreOO::DITrigger::Mode

DI trigger mode.

enum Start/Reference.

◆ PreTriggerSamples

uint32_t JY5310CoreOO::DITrigger::PreTriggerSamples

Pretrigger Samples, must be less than or equal to JY5310DITask.SamplesToAcquire.

Valid when Mode is DITriggerMode.Reference. Pretrigger samples, must be greater than 1. Valid when Type is DITriggerType.Digital.

◆ Type

DITriggerType JY5310CoreOO::DITrigger::Type

DI trigger type.

enum Digital/Immediate/Soft.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5310/JY5310CoreOODITask.h


5310 C++ Programming Manual: JY5310CoreOO::DIDigitalTrigger Class Reference

  • DIDigitalTrigger
Public Attributes | List of all members
JY5310CoreOO::DIDigitalTrigger Class Reference

DI Digital trigger . More...

#include <JY5310CoreOODITask.h>

Public Attributes

DIDigitalTriggerSource Source
DI Digital Trigger source.
DIDigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Detailed Description

DI Digital trigger .

Member Data Documentation

◆ Edge

DIDigitalTriggerEdge JY5310CoreOO::DIDigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

DIDigitalTriggerSource JY5310CoreOO::DIDigitalTrigger::Source

DI Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5310/JY5310CoreOODITask.h


5310 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5310/JY5310CoreOODOTask.h File Reference

  • File List
  • File Members
  • COO
  • 5310
Classes | Namespaces | Enumerations
JY5310CoreOODOTask.h File Reference
#include <map>
#include <mutex>
#include "JY5310CoreOOCommon.h"
#include "JY5310CoreOODevice.h"

Classes

class | JY5310CoreOO::JY5310CoreOODOTask
class | JY5310CoreOO::DOChannel
DO Channel parameter class . More...
class | JY5310CoreOO::DOSampleClock
Sample clock configuration class. More...
class | JY5310CoreOO::DOExternalSampleClock
External Sample Clock Configuration Class. More...
class | JY5310CoreOO::DODigitalTrigger
DO Digital trigger. More...
class | JY5310CoreOO::DOTrigger
Constructor to create an DOTrigger task object. More...
class | JY5310CoreOO::DOSignalExport
DO Signal Export Class. More...

Namespaces

namespace JY5310CoreOO

Enumerations

enum class | JY5310CoreOO::DOSampleClockSource { JY5310CoreOO::Internal , JY5310CoreOO::External }
DO Sample Clock Source. More...
enum class | JY5310CoreOO::DOMode { JY5310CoreOO::Single = 3 , JY5310CoreOO::Finite = 0 , JY5310CoreOO::ContinuousWrapping = 1 , JY5310CoreOO::ContinuousNoWrapping = 2 }
DOMode. More...
enum class | JY5310CoreOO::DODigitalTriggerEdge { JY5310CoreOO::Rising , JY5310CoreOO::Falling }
DO Digital Trigger Edge. More...
enum class JY5310CoreOO::DODigitalTriggerSource {
JY5310CoreOO::PFI0 = 0x10 , JY5310CoreOO::PFI1 = 0x11 , JY5310CoreOO::PFI2 = 0x12 , JY5310CoreOO::PFI3 = 0x13 ,
JY5310CoreOO::PFI4 = 0x14 , JY5310CoreOO::PFI5 = 0x15 , JY5310CoreOO::PFI6 = 0x16 , JY5310CoreOO::PFI7 = 0x17 ,
JY5310CoreOO::PFI8 = 0x18 , JY5310CoreOO::PFI9 = 0x19 , JY5310CoreOO::PFI10 = 0x1A , JY5310CoreOO::PFI11 = 0x1B ,
JY5310CoreOO::PFI12 = 0x1C , JY5310CoreOO::PFI13 = 0x1D , JY5310CoreOO::PFI14 = 0x1E , JY5310CoreOO::PFI15 = 0x1F ,
JY5310CoreOO::PXI_Trig0 = 64 , JY5310CoreOO::PXI_Trig1 = 65 , JY5310CoreOO::PXI_Trig2 = 66 , JY5310CoreOO::PXI_Trig3 = 67 ,
JY5310CoreOO::PXI_Trig4 = 68 , JY5310CoreOO::PXI_Trig5 = 69 , JY5310CoreOO::PXI_Trig6 = 70 , JY5310CoreOO::PXI_Trig7 = 71 ,
JY5310CoreOO::AT_StartTrig = 11 , JY5310CoreOO::AI_ReferencetTrig = 12 , JY5310CoreOO::DI_StartTrig = 48 , JY5310CoreOO::DI_ReferencetTrig = 49
}
DO Digital trigger source. More...
enum class | JY5310CoreOO::DOTriggerType { JY5310CoreOO::Immediate = 0 , JY5310CoreOO::Digital = 1 , JY5310CoreOO::Soft = 3 }
TriggerType Digital/Immediate/Soft. More...
enum class | JY5310CoreOO::DOSignalExportSource { JY5310CoreOO::StartTrig = 51 , JY5310CoreOO::SampleClock = 54 }
SourceSignal. More...


5310 C++ Programming Manual: JY5310CoreOO::JY5310CoreOODOTask Class Reference

  • JY5310CoreOODOTask
Public Member Functions | Public Attributes | List of all members
JY5310CoreOO::JY5310CoreOODOTask Class Reference

#include <JY5310CoreOODOTask.h>

Public Member Functions

JY5310CoreOODOTask (int slotNum)
JY5310CoreOODOTask (std::string boardName)
~JY5310CoreOODOTask ()
void | AddChannel (int portNum)
Add one channel.
void | AddChannel (std::vector< int > portsNum)
Add a group of channel.
void | RemoveChannel (int portNum)
Delete the specified port number .If it is -1, delete all ports.
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Start ()
Start DO task .
void | Stop ()
Stop DO task .
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.
void | WriteSinglePoint (std::vector< bool > &writeValues, int port)
Write one sample to the specified port in register.Available when Mode is DOMode.Single when the portID is -1, write all enabled ports values,the writeValues Length must equal to 2(In function JY5310_DO_AddLines defined), and the values store in the add order of ports, in one port, the order is form line 0 to line 1.
void | WriteSinglePoint (std::vector< bool > &writeValues)
Write one sample for all ports in register .
void | WriteData (uint16_t dataBuffer[], uint32_t samplesToUpdate, int timeOut=10000)
Write the uint data from one port or multi-ports.
void | WriteData (uint8_t dataBuffer[], uint32_t samplesToUpdate, int timeOut)
wirte the byte data to one port.

Public Attributes

std::list< DOChannel * > | Channels
List of DO channels,(5312 5515 support 8 ports)
DOMode Mode
DO acquisition mode，support Single/ Finite/ContinuousWrapping/ContinuousNoWrapping.
JY5310CoreOOProperty< JY5310CoreOODOTask, double, JY5310CoreOOPropertyType::READ_WRITE > | UpdateRate
Update rate per channel.
int | SamplesToUpdate
Number of output samples to write per channel , Only valid when Mode is DOMode::Finite.
DOSampleClock * SampleClock
DO Sample Clock Configuration.
JY5310CoreOOProperty< JY5310CoreOODOTask, int, JY5310CoreOOPropertyType::READ_ONLY > | BufLenInSamples
Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.
JY5310CoreOOProperty< JY5310CoreOODOTask, uint64_t, JY5310CoreOOPropertyType::READ_ONLY > | AvaliableLenInSamples
Number of output samples per channel avaliable to write in DO buffuer.
JY5310CoreOOProperty< JY5310CoreOODOTask, uint64_t, JY5310CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
DOTrigger * Trigger
DO Trigger Configuration.
DOSignalExport * SignalExport
Export DO Signal.
JY5310CoreOODevice * Device
Device.

Constructor & Destructor Documentation

◆ JY5310CoreOODOTask() [1/2]

JY5310CoreOO::JY5310CoreOODOTask::JY5310CoreOODOTask ( int slotNum )

◆ JY5310CoreOODOTask() [2/2]

JY5310CoreOO::JY5310CoreOODOTask::JY5310CoreOODOTask ( std::string boardName )

◆ ~JY5310CoreOODOTask()

JY5310CoreOO::JY5310CoreOODOTask::~JY5310CoreOODOTask ( )

Member Function Documentation

◆ AddChannel() [1/2]

void JY5310CoreOO::JY5310CoreOODOTask::AddChannel ( int portNum )

Add one channel.

Parameters
portNum port number to be added.

◆ AddChannel() [2/2]

void JY5310CoreOO::JY5310CoreOODOTask::AddChannel ( std::vector< int > portsNum )

Add a group of channel.

Parameters
portsNum an array of port numbers of added ports.

◆ RemoveChannel()

void JY5310CoreOO::JY5310CoreOODOTask::RemoveChannel ( int portNum )

Delete the specified port number .If it is -1, delete all ports.

Parameters
portNum port number to be delete.

◆ SendSoftwareTrigger()

void JY5310CoreOO::JY5310CoreOODOTask::SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5310CoreOO::JY5310CoreOODOTask::Start ( )

Start DO task .

◆ Stop()

void JY5310CoreOO::JY5310CoreOODOTask::Stop ( )

Stop DO task .

◆ WaitUntilDone()

bool JY5310CoreOO::JY5310CoreOODOTask::WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Available when Mode is DOMode.Finite

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteData() [1/2]

void JY5310CoreOO::JY5310CoreOODOTask::WriteData | ( | uint16_t | dataBuffer[],
 |  | uint32_t | samplesToUpdate,
 |  | int | timeOut = 10000 )

Write the uint data from one port or multi-ports.

There are 8 ports, from 0 to 7. Each port has 2 lines, from 0 to 1. There are a total of 16 lines from 0 to 15. Each bit from low to high represents one line.

Parameters
dataBuffer | Data buffer
samplesToUpdate | Number of samples per port to be write
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [2/2]

void JY5310CoreOO::JY5310CoreOODOTask::WriteData | ( | uint8_t | dataBuffer[],
 |  | uint32_t | samplesToUpdate,
 |  | int | timeOut )

wirte the byte data to one port.

Each port has 2 lines from 0 to 1. Each bit from low to high represents one line.

Parameters
dataBuffer | Data buffer
samplesToUpdate | Number of samples per port to be write
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteSinglePoint() [1/2]

void JY5310CoreOO::JY5310CoreOODOTask::WriteSinglePoint ( std::vector< bool > & writeValues )

Write one sample for all ports in register .

Available when Mode is DIMode.Single

Parameters
readValues Values read. Buffer size = number of ports * 2.

◆ WriteSinglePoint() [2/2]

void JY5310CoreOO::JY5310CoreOODOTask::WriteSinglePoint | ( | std::vector< bool > & | writeValues,
 |  | int | port )

Write one sample to the specified port in register.Available when Mode is DOMode.Single when the portID is -1, write all enabled ports values,the writeValues Length must equal to 2(In function JY5310_DO_AddLines defined), and the values store in the add order of ports, in one port, the order is form line 0 to line 1.

Parameters
writeValues | values write,. Buffer size = 2
port | Specified port numbers.

Member Data Documentation

◆ AvaliableLenInSamples

JY5310CoreOOProperty<JY5310CoreOODOTask, uint64_t, JY5310CoreOOPropertyType::READ_ONLY> JY5310CoreOO::JY5310CoreOODOTask::AvaliableLenInSamples

Number of output samples per channel avaliable to write in DO buffuer.

◆ BufLenInSamples

JY5310CoreOOProperty<JY5310CoreOODOTask, int, JY5310CoreOOPropertyType::READ_ONLY> JY5310CoreOO::JY5310CoreOODOTask::BufLenInSamples

Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.

◆ Channels

std::list<DOChannel*> JY5310CoreOO::JY5310CoreOODOTask::Channels

List of DO channels,(5312 5515 support 8 ports)

◆ Device

JY5310CoreOODevice* JY5310CoreOO::JY5310CoreOODOTask::Device

Device.

◆ Mode

DOMode JY5310CoreOO::JY5310CoreOODOTask::Mode

DO acquisition mode，support Single/ Finite/ContinuousWrapping/ContinuousNoWrapping.

◆ SampleClock

DOSampleClock* JY5310CoreOO::JY5310CoreOODOTask::SampleClock

DO Sample Clock Configuration.

◆ SamplesToUpdate

int JY5310CoreOO::JY5310CoreOODOTask::SamplesToUpdate

Number of output samples to write per channel , Only valid when Mode is DOMode::Finite.

◆ SignalExport

DOSignalExport* JY5310CoreOO::JY5310CoreOODOTask::SignalExport

Export DO Signal.

◆ TransferedSamples

JY5310CoreOOProperty<JY5310CoreOODOTask, uint64_t, JY5310CoreOOPropertyType::READ_ONLY> JY5310CoreOO::JY5310CoreOODOTask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT DIMode::Single.

◆ Trigger

DOTrigger* JY5310CoreOO::JY5310CoreOODOTask::Trigger

DO Trigger Configuration.

◆ UpdateRate

JY5310CoreOOProperty<JY5310CoreOODOTask, double, JY5310CoreOOPropertyType::READ_WRITE> JY5310CoreOO::JY5310CoreOODOTask::UpdateRate

Update rate per channel.

Maximum update rate is 10M . The defalut sample rate = 10000 You can read this property to obtain the update rate that will actually take effect in the current configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5310/JY5310CoreOODOTask.h


5310 C++ Programming Manual: JY5310CoreOO::DOChannel Class Reference

  • DOChannel
Public Attributes | List of all members
JY5310CoreOO::DOChannel Class Reference

DO Channel parameter class . More...

#include <JY5310CoreOODOTask.h>

Public Attributes

int PortNum
port number.

Detailed Description

DO Channel parameter class .

Member Data Documentation

◆ PortNum

int JY5310CoreOO::DOChannel::PortNum

port number.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5310/JY5310CoreOODOTask.h


5310 C++ Programming Manual: JY5310CoreOO::DOSampleClock Class Reference

  • DOSampleClock
Public Attributes | List of all members
JY5310CoreOO::DOSampleClock Class Reference

Sample clock configuration class. More...

#include <JY5310CoreOODOTask.h>

Public Attributes

DOSampleClockSource Source
Clock Source.
DOExternalSampleClock * External
External Sample Clock.Valid when Source is DOSampleClockSource.External.

Detailed Description

Sample clock configuration class.

Member Data Documentation

◆ External

DOExternalSampleClock* JY5310CoreOO::DOSampleClock::External

External Sample Clock.Valid when Source is DOSampleClockSource.External.

◆ Source

DOSampleClockSource JY5310CoreOO::DOSampleClock::Source

Clock Source.

enum Internal/External

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5310/JY5310CoreOODOTask.h


5310 C++ Programming Manual: JY5310CoreOO::DOExternalSampleClock Class Reference

  • DOExternalSampleClock
Public Attributes | List of all members
JY5310CoreOO::DOExternalSampleClock Class Reference

External Sample Clock Configuration Class. More...

#include <JY5310CoreOODOTask.h>

Public Attributes

ClockTerminal Terminal
External Sample Clock Input Terminal.
double ExpectedRate
Expected External Sample Clock Rate.

Detailed Description

External Sample Clock Configuration Class.

Member Data Documentation

◆ ExpectedRate

double JY5310CoreOO::DOExternalSampleClock::ExpectedRate

Expected External Sample Clock Rate.

◆ Terminal

ClockTerminal JY5310CoreOO::DOExternalSampleClock::Terminal

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5310/JY5310CoreOODOTask.h


5310 C++ Programming Manual: JY5310CoreOO::DODigitalTrigger Class Reference

  • DODigitalTrigger
Public Attributes | List of all members
JY5310CoreOO::DODigitalTrigger Class Reference

DO Digital trigger. More...

#include <JY5310CoreOODOTask.h>

Public Attributes

DODigitalTriggerSource Source
DO Digital Trigger source.
DODigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Detailed Description

DO Digital trigger.

Member Data Documentation

◆ Edge

DODigitalTriggerEdge JY5310CoreOO::DODigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

DODigitalTriggerSource JY5310CoreOO::DODigitalTrigger::Source

DO Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5310/JY5310CoreOODOTask.h


5310 C++ Programming Manual: JY5310CoreOO::DOTrigger Class Reference

  • DOTrigger
Public Attributes | List of all members
JY5310CoreOO::DOTrigger Class Reference

Constructor to create an DOTrigger task object. More...

#include <JY5310CoreOODOTask.h>

Public Attributes

DOTriggerType Type
DO trigger type.
DODigitalTrigger * Digital
DO Digital Trigger.Valid when Type is DOTriggerType.Digital.

Detailed Description

Constructor to create an DOTrigger task object.

Used to build DO Trigger

Member Data Documentation

◆ Digital

DODigitalTrigger* JY5310CoreOO::DOTrigger::Digital

DO Digital Trigger.Valid when Type is DOTriggerType.Digital.

◆ Type

DOTriggerType JY5310CoreOO::DOTrigger::Type

DO trigger type.

enum Digital/Immediate/Soft.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5310/JY5310CoreOODOTask.h


5310 C++ Programming Manual: JY5310CoreOO::DOSignalExport Class Reference

  • DOSignalExport
Public Member Functions | List of all members
JY5310CoreOO::DOSignalExport Class Reference

DO Signal Export Class. More...

#include <JY5310CoreOODOTask.h>

Public Member Functions

void | Add (DOSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (DOSignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

DO Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY5310CoreOO::DOSignalExport::Add | ( | DOSignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | CI Signal Source
destination | Export Desination

◆ Add() [2/2]

void JY5310CoreOO::DOSignalExport::Add | ( | DOSignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | CI Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JY5310CoreOO::DOSignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5310CoreOO::DOSignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5310/JY5310CoreOODOTask.h


5310 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5310/JY5310CoreOOLog.h File Reference

  • File List
  • File Members
  • COO
  • 5310
Classes | Namespaces | Enumerations
JY5310CoreOOLog.h File Reference
#include <queue>
#include <thread>
#include "JY5310CoreOOCommon.h"

Classes

class JY5310CoreOO::JY5310CoreOOLog

Namespaces

namespace JY5310CoreOO

Enumerations

enum class JY5310CoreOO::JY5310CoreOOLogLevel {
JY5310CoreOO::DEBUG_LOG_LEVEL , JY5310CoreOO::INFO_LOG_LEVEL , JY5310CoreOO::WARN_LOG_LEVEL , JY5310CoreOO::ERROR_LOG_LEVEL ,
JY5310CoreOO::FATAL_LOG_LEVEL
}


5310 C++ Programming Manual: JY5310CoreOO::JY5310CoreOOLog Class Reference

  • JY5310CoreOOLog
Static Public Member Functions | Static Public Attributes | List of all members
JY5310CoreOO::JY5310CoreOOLog Class Reference

#include <JY5310CoreOOLog.h>

Static Public Member Functions

static void | Print (const char *format,...)
static void | Print (JY5310CoreOOLogLevel logLevel, const char *format,...)
static void | Flush ()

Static Public Attributes

static JY5310CoreOOLogLevel | LogLevel
static JY5310CoreOOProperty< JY5310CoreOOLog, bool, JY5310CoreOOPropertyType::READ_WRITE > | EnableLog

Member Function Documentation

◆ Flush()

static void JY5310CoreOO::JY5310CoreOOLog::Flush ( )
static

◆ Print() [1/2]

static void JY5310CoreOO::JY5310CoreOOLog::Print | ( | const char * | format,
 |  |  | ... )
 static

◆ Print() [2/2]

static void JY5310CoreOO::JY5310CoreOOLog::Print | ( | JY5310CoreOOLogLevel | logLevel,
 |  | const char * | format,
 |  |  | ... )
 static

Member Data Documentation

◆ EnableLog

JY5310CoreOOProperty<JY5310CoreOOLog, bool, JY5310CoreOOPropertyType::READ_WRITE> JY5310CoreOO::JY5310CoreOOLog::EnableLog
static

◆ LogLevel

JY5310CoreOOLogLevel JY5310CoreOO::JY5310CoreOOLog::LogLevel
static
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5310/JY5310CoreOOLog.h


5310 C++ Programming Manual: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
▼N JY5310CoreOO |
C AIAnalogEdgeComparator |
C AIAnalogHysteresisComparator |
C AIAnalogTrigger |
C AIAnalogWindowComparator |
C AIChannel |
C AIDigitalTrigger |
C AIExternalSampleClock |
C AIRecord |
C AISampleClock |
C AISignalExport |
C AISync |
C AITrigger |
C DIChannel | DI Channel parameter class
C DIDigitalTrigger | DI Digital trigger
C DIExternalSampleClock | External Sample Clock Configuration Class
C DISampleClock | Sample clock configuration class
C DISignalExport | DI Signal Export Class
C DITrigger | Constructor to create an DITrigger task object
C DOChannel | DO Channel parameter class
C DODigitalTrigger | DO Digital trigger
C DOExternalSampleClock | External Sample Clock Configuration Class
C DOSampleClock | Sample clock configuration class
C DOSignalExport | DO Signal Export Class
C DOTrigger | Constructor to create an DOTrigger task object
C ExternalReferenceClock | External Reference Clcok Terminal
C JY5310CoreOOAITask | AITask类
C JY5310CoreOODevice |
C JY5310CoreOODITask |
C JY5310CoreOODOTask |
C JY5310CoreOOLog |
C JY5310CoreOOProperty | 属性模板类
C JY5310CoreOOReferenceClock |
C JYDriverException |
C PauseTrigger | Pause trigger configuration class
C JY5310CoreOOAIMode | AIMode


5310 C++ Programming Manual: Member List

  • AIAnalogEdgeComparator
JY5310CoreOO::AIAnalogEdgeComparator Member List

This is the complete list of members for JY5310CoreOO::AIAnalogEdgeComparator, including all inherited members.

Slope | JY5310CoreOO::AIAnalogEdgeComparator
Threshold | JY5310CoreOO::AIAnalogEdgeComparator


5310 C++ Programming Manual: Member List

  • AIAnalogHysteresisComparator
JY5310CoreOO::AIAnalogHysteresisComparator Member List

This is the complete list of members for JY5310CoreOO::AIAnalogHysteresisComparator, including all inherited members.

HighThreshold | JY5310CoreOO::AIAnalogHysteresisComparator
LowThreshold | JY5310CoreOO::AIAnalogHysteresisComparator
Slope | JY5310CoreOO::AIAnalogHysteresisComparator


5310 C++ Programming Manual: Member List

  • AIAnalogTrigger
JY5310CoreOO::AIAnalogTrigger Member List

This is the complete list of members for JY5310CoreOO::AIAnalogTrigger, including all inherited members.

Comparator | JY5310CoreOO::AIAnalogTrigger
Edge | JY5310CoreOO::AIAnalogTrigger
Hysteresis | JY5310CoreOO::AIAnalogTrigger
Source | JY5310CoreOO::AIAnalogTrigger
Window | JY5310CoreOO::AIAnalogTrigger


5310 C++ Programming Manual: Member List

  • AIAnalogWindowComparator
JY5310CoreOO::AIAnalogWindowComparator Member List

This is the complete list of members for JY5310CoreOO::AIAnalogWindowComparator, including all inherited members.

Condition | JY5310CoreOO::AIAnalogWindowComparator
HighThreshold | JY5310CoreOO::AIAnalogWindowComparator
LowThreshold | JY5310CoreOO::AIAnalogWindowComparator


5310 C++ Programming Manual: Member List

  • AIChannel
JY5310CoreOO::AIChannel Member List

This is the complete list of members for JY5310CoreOO::AIChannel, including all inherited members.

AIChannel(int channelId, double rangeLow, double rangeHigh) | JY5310CoreOO::AIChannel | inline
ChannelID | JY5310CoreOO::AIChannel |
RangeHigh | JY5310CoreOO::AIChannel |
RangeLow | JY5310CoreOO::AIChannel |


5310 C++ Programming Manual: Member List

  • AIDigitalTrigger
JY5310CoreOO::AIDigitalTrigger Member List

This is the complete list of members for JY5310CoreOO::AIDigitalTrigger, including all inherited members.

Edge | JY5310CoreOO::AIDigitalTrigger
Source | JY5310CoreOO::AIDigitalTrigger


5310 C++ Programming Manual: Member List

  • AIExternalSampleClock
JY5310CoreOO::AIExternalSampleClock Member List

This is the complete list of members for JY5310CoreOO::AIExternalSampleClock, including all inherited members.

ExpectedRate | JY5310CoreOO::AIExternalSampleClock
Terminal | JY5310CoreOO::AIExternalSampleClock


5310 C++ Programming Manual: Member List

  • AIRecord
JY5310CoreOO::AIRecord Member List

This is the complete list of members for JY5310CoreOO::AIRecord, including all inherited members.

File_Format | JY5310CoreOO::AIRecord
FilePath | JY5310CoreOO::AIRecord
Length | JY5310CoreOO::AIRecord
Mode | JY5310CoreOO::AIRecord


5310 C++ Programming Manual: Member List

  • AISampleClock
JY5310CoreOO::AISampleClock Member List

This is the complete list of members for JY5310CoreOO::AISampleClock, including all inherited members.

External | JY5310CoreOO::AISampleClock
Source | JY5310CoreOO::AISampleClock


5310 C++ Programming Manual: Member List

  • AISignalExport
JY5310CoreOO::AISignalExport Member List

This is the complete list of members for JY5310CoreOO::AISignalExport, including all inherited members.

Add(AISignalExportSource source, SignalExportDestination destination) | JY5310CoreOO::AISignalExport
Add(AISignalExportSource source, std::list< SignalExportDestination > destinations) | JY5310CoreOO::AISignalExport
Clear(SignalExportDestination destination) | JY5310CoreOO::AISignalExport
ClearAll() | JY5310CoreOO::AISignalExport


5310 C++ Programming Manual: Member List

  • AISync
JY5310CoreOO::AISync Member List

This is the complete list of members for JY5310CoreOO::AISync, including all inherited members.

PulseRouting | JY5310CoreOO::AISync
Topology | JY5310CoreOO::AISync
TriggerRouting | JY5310CoreOO::AISync


5310 C++ Programming Manual: Member List

  • AITrigger
JY5310CoreOO::AITrigger Member List

This is the complete list of members for JY5310CoreOO::AITrigger, including all inherited members.

Analog | JY5310CoreOO::AITrigger
Digital | JY5310CoreOO::AITrigger
Mode | JY5310CoreOO::AITrigger
PreTriggerSamples | JY5310CoreOO::AITrigger
ReTriggerCount | JY5310CoreOO::AITrigger
Type | JY5310CoreOO::AITrigger


5310 C++ Programming Manual: Member List

  • DIChannel
JY5310CoreOO::DIChannel Member List

This is the complete list of members for JY5310CoreOO::DIChannel, including all inherited members.

PortNum JY5310CoreOO::DIChannel


5310 C++ Programming Manual: Member List

  • DIDigitalTrigger
JY5310CoreOO::DIDigitalTrigger Member List

This is the complete list of members for JY5310CoreOO::DIDigitalTrigger, including all inherited members.

Edge | JY5310CoreOO::DIDigitalTrigger
Source | JY5310CoreOO::DIDigitalTrigger


5310 C++ Programming Manual: Member List

  • DIExternalSampleClock
JY5310CoreOO::DIExternalSampleClock Member List

This is the complete list of members for JY5310CoreOO::DIExternalSampleClock, including all inherited members.

ExpectedRate | JY5310CoreOO::DIExternalSampleClock
Terminal | JY5310CoreOO::DIExternalSampleClock


5310 C++ Programming Manual: Member List

  • DISampleClock
JY5310CoreOO::DISampleClock Member List

This is the complete list of members for JY5310CoreOO::DISampleClock, including all inherited members.

External | JY5310CoreOO::DISampleClock
Source | JY5310CoreOO::DISampleClock


5310 C++ Programming Manual: Member List

  • DISignalExport
JY5310CoreOO::DISignalExport Member List

This is the complete list of members for JY5310CoreOO::DISignalExport, including all inherited members.

Add(DISignalExportSource source, SignalExportDestination destination) | JY5310CoreOO::DISignalExport
Add(DISignalExportSource source, std::list< SignalExportDestination > destinations) | JY5310CoreOO::DISignalExport
Clear(SignalExportDestination destination) | JY5310CoreOO::DISignalExport
ClearAll() | JY5310CoreOO::DISignalExport


5310 C++ Programming Manual: Member List

  • DITrigger
JY5310CoreOO::DITrigger Member List

This is the complete list of members for JY5310CoreOO::DITrigger, including all inherited members.

Digital | JY5310CoreOO::DITrigger
Mode | JY5310CoreOO::DITrigger
PreTriggerSamples | JY5310CoreOO::DITrigger
Type | JY5310CoreOO::DITrigger


5310 C++ Programming Manual: Member List

  • DOChannel
JY5310CoreOO::DOChannel Member List

This is the complete list of members for JY5310CoreOO::DOChannel, including all inherited members.

PortNum JY5310CoreOO::DOChannel


5310 C++ Programming Manual: Member List

  • DODigitalTrigger
JY5310CoreOO::DODigitalTrigger Member List

This is the complete list of members for JY5310CoreOO::DODigitalTrigger, including all inherited members.

Edge | JY5310CoreOO::DODigitalTrigger
Source | JY5310CoreOO::DODigitalTrigger


5310 C++ Programming Manual: Member List

  • DOExternalSampleClock
JY5310CoreOO::DOExternalSampleClock Member List

This is the complete list of members for JY5310CoreOO::DOExternalSampleClock, including all inherited members.

ExpectedRate | JY5310CoreOO::DOExternalSampleClock
Terminal | JY5310CoreOO::DOExternalSampleClock


5310 C++ Programming Manual: Member List

  • DOSampleClock
JY5310CoreOO::DOSampleClock Member List

This is the complete list of members for JY5310CoreOO::DOSampleClock, including all inherited members.

External | JY5310CoreOO::DOSampleClock
Source | JY5310CoreOO::DOSampleClock


5310 C++ Programming Manual: Member List

  • DOSignalExport
JY5310CoreOO::DOSignalExport Member List

This is the complete list of members for JY5310CoreOO::DOSignalExport, including all inherited members.

Add(DOSignalExportSource source, SignalExportDestination destination) | JY5310CoreOO::DOSignalExport
Add(DOSignalExportSource source, std::list< SignalExportDestination > destinations) | JY5310CoreOO::DOSignalExport
Clear(SignalExportDestination destination) | JY5310CoreOO::DOSignalExport
ClearAll() | JY5310CoreOO::DOSignalExport


5310 C++ Programming Manual: Member List

  • DOTrigger
JY5310CoreOO::DOTrigger Member List

This is the complete list of members for JY5310CoreOO::DOTrigger, including all inherited members.

Digital | JY5310CoreOO::DOTrigger
Type | JY5310CoreOO::DOTrigger


5310 C++ Programming Manual: Member List

  • ExternalReferenceClock
JY5310CoreOO::ExternalReferenceClock Member List

This is the complete list of members for JY5310CoreOO::ExternalReferenceClock, including all inherited members.

Terminal JY5310CoreOO::ExternalReferenceClock


5310 C++ Programming Manual: Member List

  • JY5310CoreOOAITask
JY5310CoreOO::JY5310CoreOOAITask Member List

This is the complete list of members for JY5310CoreOO::JY5310CoreOOAITask, including all inherited members.

AddChannel(int chnId, double rangeLow=-10, double rangeHigh=10) | JY5310CoreOO::JY5310CoreOOAITask
AddChannel(std::vector< int > chnsId, double rangeLow=-10, double rangeHigh=10) | JY5310CoreOO::JY5310CoreOOAITask
AddChannel(std::vector< int > chnsId, std::vector< double > rangeLow, std::vector< double > rangeHigh) | JY5310CoreOO::JY5310CoreOOAITask
AvailableSamples | JY5310CoreOO::JY5310CoreOOAITask
BufLenInSamples | JY5310CoreOO::JY5310CoreOOAITask
Channels | JY5310CoreOO::JY5310CoreOOAITask
Device | JY5310CoreOO::JY5310CoreOOAITask
GetRecordPreviewData(double *buf, int samplesPerChannel, int timeout=1000) | JY5310CoreOO::JY5310CoreOOAITask
GetRecordStatus(double *recordedLength, bool *recordDone) | JY5310CoreOO::JY5310CoreOOAITask
JY5310CoreOOAITask(int slotNum) | JY5310CoreOO::JY5310CoreOOAITask
JY5310CoreOOAITask(std::string boardName) | JY5310CoreOO::JY5310CoreOOAITask
Mode | JY5310CoreOO::JY5310CoreOOAITask
ReadData(double *pBuf, int samplesPerChannel, int timeout=1000) | JY5310CoreOO::JY5310CoreOOAITask
ReadRawData(short *pBuf, int samplesPerChannel, int timeout=1000) | JY5310CoreOO::JY5310CoreOOAITask
Record | JY5310CoreOO::JY5310CoreOOAITask
RemoveChannel(int chnId) | JY5310CoreOO::JY5310CoreOOAITask
SampleClock | JY5310CoreOO::JY5310CoreOOAITask
SampleRate | JY5310CoreOO::JY5310CoreOOAITask
SamplesToAcquire | JY5310CoreOO::JY5310CoreOOAITask
SendSoftwareTrigger() | JY5310CoreOO::JY5310CoreOOAITask
SignalExport | JY5310CoreOO::JY5310CoreOOAITask
Start() | JY5310CoreOO::JY5310CoreOOAITask
Stop() | JY5310CoreOO::JY5310CoreOOAITask
Sync | JY5310CoreOO::JY5310CoreOOAITask
TransferedSamples | JY5310CoreOO::JY5310CoreOOAITask
Trigger | JY5310CoreOO::JY5310CoreOOAITask
~JY5310CoreOOAITask() | JY5310CoreOO::JY5310CoreOOAITask


5310 C++ Programming Manual: Member List

  • JY5310CoreOODITask
JY5310CoreOO::JY5310CoreOODITask Member List

This is the complete list of members for JY5310CoreOO::JY5310CoreOODITask, including all inherited members.

AddChannel(int portNum) | JY5310CoreOO::JY5310CoreOODITask
AddChannel(std::vector< int > portsNum) | JY5310CoreOO::JY5310CoreOODITask
AvailableSamples | JY5310CoreOO::JY5310CoreOODITask
BufLenInSamples | JY5310CoreOO::JY5310CoreOODITask
Channels | JY5310CoreOO::JY5310CoreOODITask
Device | JY5310CoreOO::JY5310CoreOODITask
JY5310CoreOODITask(int slotNum) | JY5310CoreOO::JY5310CoreOODITask
JY5310CoreOODITask(std::string boardName) | JY5310CoreOO::JY5310CoreOODITask
Mode | JY5310CoreOO::JY5310CoreOODITask
ReadData(uint16_t dataBuffer[], uint32_t samplesToAcquire, int timeOut=10000) | JY5310CoreOO::JY5310CoreOODITask
ReadData(uint8_t dataBuffer[], uint32_t samplesToAcquire, int timeOut=10000) | JY5310CoreOO::JY5310CoreOODITask
ReadSinglePoint(std::vector< bool > &readValues, int port) | JY5310CoreOO::JY5310CoreOODITask
RemoveChannel(int portNum) | JY5310CoreOO::JY5310CoreOODITask
SampleClock | JY5310CoreOO::JY5310CoreOODITask
SampleRate | JY5310CoreOO::JY5310CoreOODITask
SamplesToAcquire | JY5310CoreOO::JY5310CoreOODITask
SendSoftwareTrigger() | JY5310CoreOO::JY5310CoreOODITask
SignalExport | JY5310CoreOO::JY5310CoreOODITask
Start() | JY5310CoreOO::JY5310CoreOODITask
Stop() | JY5310CoreOO::JY5310CoreOODITask
TransferedSamples | JY5310CoreOO::JY5310CoreOODITask
Trigger | JY5310CoreOO::JY5310CoreOODITask
~JY5310CoreOODITask() | JY5310CoreOO::JY5310CoreOODITask


5310 C++ Programming Manual: Member List

  • JY5310CoreOODOTask
JY5310CoreOO::JY5310CoreOODOTask Member List

This is the complete list of members for JY5310CoreOO::JY5310CoreOODOTask, including all inherited members.

AddChannel(int portNum) | JY5310CoreOO::JY5310CoreOODOTask
AddChannel(std::vector< int > portsNum) | JY5310CoreOO::JY5310CoreOODOTask
AvaliableLenInSamples | JY5310CoreOO::JY5310CoreOODOTask
BufLenInSamples | JY5310CoreOO::JY5310CoreOODOTask
Channels | JY5310CoreOO::JY5310CoreOODOTask
Device | JY5310CoreOO::JY5310CoreOODOTask
JY5310CoreOODOTask(int slotNum) | JY5310CoreOO::JY5310CoreOODOTask
JY5310CoreOODOTask(std::string boardName) | JY5310CoreOO::JY5310CoreOODOTask
Mode | JY5310CoreOO::JY5310CoreOODOTask
RemoveChannel(int portNum) | JY5310CoreOO::JY5310CoreOODOTask
SampleClock | JY5310CoreOO::JY5310CoreOODOTask
SamplesToUpdate | JY5310CoreOO::JY5310CoreOODOTask
SendSoftwareTrigger() | JY5310CoreOO::JY5310CoreOODOTask
SignalExport | JY5310CoreOO::JY5310CoreOODOTask
Start() | JY5310CoreOO::JY5310CoreOODOTask
Stop() | JY5310CoreOO::JY5310CoreOODOTask
TransferedSamples | JY5310CoreOO::JY5310CoreOODOTask
Trigger | JY5310CoreOO::JY5310CoreOODOTask
UpdateRate | JY5310CoreOO::JY5310CoreOODOTask
WaitUntilDone(int timeout=-1) | JY5310CoreOO::JY5310CoreOODOTask
WriteData(uint16_t dataBuffer[], uint32_t samplesToUpdate, int timeOut=10000) | JY5310CoreOO::JY5310CoreOODOTask
WriteData(uint8_t dataBuffer[], uint32_t samplesToUpdate, int timeOut) | JY5310CoreOO::JY5310CoreOODOTask
WriteSinglePoint(std::vector< bool > &writeValues, int port) | JY5310CoreOO::JY5310CoreOODOTask
WriteSinglePoint(std::vector< bool > &writeValues) | JY5310CoreOO::JY5310CoreOODOTask
~JY5310CoreOODOTask() | JY5310CoreOO::JY5310CoreOODOTask


5310 C++ Programming Manual: Member List

  • JY5310CoreOODevice
JY5310CoreOO::JY5310CoreOODevice Member List

This is the complete list of members for JY5310CoreOO::JY5310CoreOODevice, including all inherited members.

AIBufferSize | JY5310CoreOO::JY5310CoreOODevice |
BoardClockRate | JY5310CoreOO::JY5310CoreOODevice |
DeviceID | JY5310CoreOO::JY5310CoreOODevice |
DiffChannelCount | JY5310CoreOO::JY5310CoreOODevice |
DIOPortCount | JY5310CoreOO::JY5310CoreOODevice |
GetInstance(int cardNum) | JY5310CoreOO::JY5310CoreOODevice | static
GetInstance(std::string aliasName) | JY5310CoreOO::JY5310CoreOODevice | static
Handle | JY5310CoreOO::JY5310CoreOODevice |
IsAISync | JY5310CoreOO::JY5310CoreOODevice |
IsAOSync | JY5310CoreOO::JY5310CoreOODevice |
LineCountPerPort | JY5310CoreOO::JY5310CoreOODevice |
MaxSampleRateMutilChannel | JY5310CoreOO::JY5310CoreOODevice |
MaxSampleRateSingleChannel | JY5310CoreOO::JY5310CoreOODevice |
ReferenceClock | JY5310CoreOO::JY5310CoreOODevice |
SerialNumber | JY5310CoreOO::JY5310CoreOODevice |


5310 C++ Programming Manual: Member List

  • JY5310CoreOOLog
JY5310CoreOO::JY5310CoreOOLog Member List

This is the complete list of members for JY5310CoreOO::JY5310CoreOOLog, including all inherited members.

EnableLog | JY5310CoreOO::JY5310CoreOOLog | static
Flush() | JY5310CoreOO::JY5310CoreOOLog | static
LogLevel | JY5310CoreOO::JY5310CoreOOLog | static
Print(const char *format,...) | JY5310CoreOO::JY5310CoreOOLog | static
Print(JY5310CoreOOLogLevel logLevel, const char *format,...) | JY5310CoreOO::JY5310CoreOOLog | static


5310 C++ Programming Manual: Member List

  • JY5310CoreOOProperty
JY5310CoreOO::JY5310CoreOOProperty< ContainerClass, ValueType, propertyType > Member List

This is the complete list of members for JY5310CoreOO::JY5310CoreOOProperty< ContainerClass, ValueType, propertyType >, including all inherited members.

JY5310CoreOOProperty() | JY5310CoreOO::JY5310CoreOOProperty< ContainerClass, ValueType, propertyType >
JY5310CoreOOProperty(ContainerClass *cObject, ValueType(ContainerClass::*pGet)(), void(ContainerClass::*pSet)(ValueType value)) | JY5310CoreOO::JY5310CoreOOProperty< ContainerClass, ValueType, propertyType >
JY5310CoreOOProperty(ValueType(*pGet)(), void(*pSet)(ValueType value)) | JY5310CoreOO::JY5310CoreOOProperty< ContainerClass, ValueType, propertyType >
operator ValueType() | JY5310CoreOO::JY5310CoreOOProperty< ContainerClass, ValueType, propertyType >
operator=(const ValueType &value) | JY5310CoreOO::JY5310CoreOOProperty< ContainerClass, ValueType, propertyType >


5310 C++ Programming Manual: Member List

  • JY5310CoreOOReferenceClock
JY5310CoreOO::JY5310CoreOOReferenceClock Member List

This is the complete list of members for JY5310CoreOO::JY5310CoreOOReferenceClock, including all inherited members.

Commit() | JY5310CoreOO::JY5310CoreOOReferenceClock
External | JY5310CoreOO::JY5310CoreOOReferenceClock
Source | JY5310CoreOO::JY5310CoreOOReferenceClock


5310 C++ Programming Manual: Member List

  • JYDriverException
JY5310CoreOO::JYDriverException Member List

This is the complete list of members for JY5310CoreOO::JYDriverException, including all inherited members.

errorCode | JY5310CoreOO::JYDriverException
exceptionMessage | JY5310CoreOO::JYDriverException
FollowingException | JY5310CoreOO::JYDriverException
JYDriverException(JYDriverExceptionPublic exceptionCode, std::string msg="") | JY5310CoreOO::JYDriverException
JYDriverException(int, std::string msg) | JY5310CoreOO::JYDriverException


5310 C++ Programming Manual: Member List

  • PauseTrigger
JY5310CoreOO::PauseTrigger Member List

This is the complete list of members for JY5310CoreOO::PauseTrigger, including all inherited members.

ActivePolarity | JY5310CoreOO::PauseTrigger
Terminal | JY5310CoreOO::PauseTrigger


5310 C++ Programming Manual: JY5310CoreOOAIMode Class Reference

JY5310CoreOOAIMode Class Reference

AIMode. More...

#include <JY5310CoreOOAITask.h>

Detailed Description

AIMode.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5310/JY5310CoreOOAITask.h


5310 C++ Programming Manual: Class Index

Class Index
A | D | E | J | P
A
AIAnalogEdgeComparator (JY5310CoreOO)
AIAnalogHysteresisComparator (JY5310CoreOO)
AIAnalogTrigger (JY5310CoreOO)
AIAnalogWindowComparator (JY5310CoreOO)
AIChannel (JY5310CoreOO)
AIDigitalTrigger (JY5310CoreOO)
AIExternalSampleClock (JY5310CoreOO)
AIRecord (JY5310CoreOO)
AISampleClock (JY5310CoreOO)
AISignalExport (JY5310CoreOO)
AISync (JY5310CoreOO)
AITrigger (JY5310CoreOO)
D
DIChannel (JY5310CoreOO)
DIDigitalTrigger (JY5310CoreOO)
DIExternalSampleClock (JY5310CoreOO)
DISampleClock (JY5310CoreOO)
DISignalExport (JY5310CoreOO)
DITrigger (JY5310CoreOO)
DOChannel (JY5310CoreOO)
DODigitalTrigger (JY5310CoreOO)
DOExternalSampleClock (JY5310CoreOO)
DOSampleClock (JY5310CoreOO)
DOSignalExport (JY5310CoreOO)
DOTrigger (JY5310CoreOO)
E
ExternalReferenceClock (JY5310CoreOO)
J
JY5310CoreOOAIMode
JY5310CoreOOAITask (JY5310CoreOO)
JY5310CoreOODevice (JY5310CoreOO)
JY5310CoreOODITask (JY5310CoreOO)
JY5310CoreOODOTask (JY5310CoreOO)
JY5310CoreOOLog (JY5310CoreOO)
JY5310CoreOOProperty (JY5310CoreOO)
JY5310CoreOOReferenceClock (JY5310CoreOO)
JYDriverException (JY5310CoreOO)
P
PauseTrigger (JY5310CoreOO)


5310 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO Directory Reference

  • File List
  • File Members
  • COO
COO Directory Reference

Directories

5310


5310 C++ Programming Manual: File List

  • File List
  • File Members
File List
Here is a list of all files with brief descriptions:
[detail level 123]
▼ COO
▼ 5310
JY5310CoreOOAITask.h
JY5310CoreOOCommon.h
JY5310CoreOODevice.h
JY5310CoreOODITask.h
JY5310CoreOODOTask.h
JY5310CoreOOLog.h


5310 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- a -

  • ActivePolarity : JY5310CoreOO::PauseTrigger
  • Add() : JY5310CoreOO::AISignalExport, JY5310CoreOO::DISignalExport, JY5310CoreOO::DOSignalExport
  • AddChannel() : JY5310CoreOO::JY5310CoreOOAITask, JY5310CoreOO::JY5310CoreOODITask, JY5310CoreOO::JY5310CoreOODOTask
  • AIBufferSize : JY5310CoreOO::JY5310CoreOODevice
  • AIChannel() : JY5310CoreOO::AIChannel
  • Analog : JY5310CoreOO::AITrigger
  • AvailableSamples : JY5310CoreOO::JY5310CoreOOAITask, JY5310CoreOO::JY5310CoreOODITask
  • AvaliableLenInSamples : JY5310CoreOO::JY5310CoreOODOTask

- b -

  • BoardClockRate : JY5310CoreOO::JY5310CoreOODevice
  • BufLenInSamples : JY5310CoreOO::JY5310CoreOOAITask, JY5310CoreOO::JY5310CoreOODITask, JY5310CoreOO::JY5310CoreOODOTask

- c -

  • ChannelID : JY5310CoreOO::AIChannel
  • Channels : JY5310CoreOO::JY5310CoreOOAITask, JY5310CoreOO::JY5310CoreOODITask, JY5310CoreOO::JY5310CoreOODOTask
  • Clear() : JY5310CoreOO::AISignalExport, JY5310CoreOO::DISignalExport, JY5310CoreOO::DOSignalExport
  • ClearAll() : JY5310CoreOO::AISignalExport, JY5310CoreOO::DISignalExport, JY5310CoreOO::DOSignalExport
  • Commit() : JY5310CoreOO::JY5310CoreOOReferenceClock
  • Comparator : JY5310CoreOO::AIAnalogTrigger
  • Condition : JY5310CoreOO::AIAnalogWindowComparator

- d -

  • Device : JY5310CoreOO::JY5310CoreOOAITask, JY5310CoreOO::JY5310CoreOODITask, JY5310CoreOO::JY5310CoreOODOTask
  • DeviceID : JY5310CoreOO::JY5310CoreOODevice
  • DiffChannelCount : JY5310CoreOO::JY5310CoreOODevice
  • Digital : JY5310CoreOO::AITrigger, JY5310CoreOO::DITrigger, JY5310CoreOO::DOTrigger
  • DIOPortCount : JY5310CoreOO::JY5310CoreOODevice

- e -

  • Edge : JY5310CoreOO::AIAnalogTrigger, JY5310CoreOO::AIDigitalTrigger, JY5310CoreOO::DIDigitalTrigger, JY5310CoreOO::DODigitalTrigger
  • EnableLog : JY5310CoreOO::JY5310CoreOOLog
  • errorCode : JY5310CoreOO::JYDriverException
  • exceptionMessage : JY5310CoreOO::JYDriverException
  • ExpectedRate : JY5310CoreOO::AIExternalSampleClock, JY5310CoreOO::DIExternalSampleClock, JY5310CoreOO::DOExternalSampleClock
  • External : JY5310CoreOO::AISampleClock, JY5310CoreOO::DISampleClock, JY5310CoreOO::DOSampleClock, JY5310CoreOO::JY5310CoreOOReferenceClock

- f -

  • File_Format : JY5310CoreOO::AIRecord
  • FilePath : JY5310CoreOO::AIRecord
  • Flush() : JY5310CoreOO::JY5310CoreOOLog
  • FollowingException : JY5310CoreOO::JYDriverException

- g -

  • GetInstance() : JY5310CoreOO::JY5310CoreOODevice
  • GetRecordPreviewData() : JY5310CoreOO::JY5310CoreOOAITask
  • GetRecordStatus() : JY5310CoreOO::JY5310CoreOOAITask

- h -

  • Handle : JY5310CoreOO::JY5310CoreOODevice
  • HighThreshold : JY5310CoreOO::AIAnalogHysteresisComparator, JY5310CoreOO::AIAnalogWindowComparator
  • Hysteresis : JY5310CoreOO::AIAnalogTrigger

- i -

  • IsAISync : JY5310CoreOO::JY5310CoreOODevice
  • IsAOSync : JY5310CoreOO::JY5310CoreOODevice

- j -

  • JY5310CoreOOAITask() : JY5310CoreOO::JY5310CoreOOAITask
  • JY5310CoreOODITask() : JY5310CoreOO::JY5310CoreOODITask
  • JY5310CoreOODOTask() : JY5310CoreOO::JY5310CoreOODOTask
  • JY5310CoreOOProperty() : JY5310CoreOO::JY5310CoreOOProperty< ContainerClass, ValueType, propertyType >
  • JYDriverException() : JY5310CoreOO::JYDriverException

- l -

  • Length : JY5310CoreOO::AIRecord
  • LineCountPerPort : JY5310CoreOO::JY5310CoreOODevice
  • LogLevel : JY5310CoreOO::JY5310CoreOOLog
  • LowThreshold : JY5310CoreOO::AIAnalogHysteresisComparator, JY5310CoreOO::AIAnalogWindowComparator

- m -

  • MaxSampleRateMutilChannel : JY5310CoreOO::JY5310CoreOODevice
  • MaxSampleRateSingleChannel : JY5310CoreOO::JY5310CoreOODevice
  • Mode : JY5310CoreOO::AIRecord, JY5310CoreOO::AITrigger, JY5310CoreOO::DITrigger, JY5310CoreOO::JY5310CoreOOAITask, JY5310CoreOO::JY5310CoreOODITask, JY5310CoreOO::JY5310CoreOODOTask

- o -

  • operator ValueType() : JY5310CoreOO::JY5310CoreOOProperty< ContainerClass, ValueType, propertyType >
  • operator=() : JY5310CoreOO::JY5310CoreOOProperty< ContainerClass, ValueType, propertyType >

- p -

  • PortNum : JY5310CoreOO::DIChannel, JY5310CoreOO::DOChannel
  • PreTriggerSamples : JY5310CoreOO::AITrigger, JY5310CoreOO::DITrigger
  • Print() : JY5310CoreOO::JY5310CoreOOLog
  • PulseRouting : JY5310CoreOO::AISync

- r -

  • RangeHigh : JY5310CoreOO::AIChannel
  • RangeLow : JY5310CoreOO::AIChannel
  • ReadData() : JY5310CoreOO::JY5310CoreOOAITask, JY5310CoreOO::JY5310CoreOODITask
  • ReadRawData() : JY5310CoreOO::JY5310CoreOOAITask
  • ReadSinglePoint() : JY5310CoreOO::JY5310CoreOODITask
  • Record : JY5310CoreOO::JY5310CoreOOAITask
  • ReferenceClock : JY5310CoreOO::JY5310CoreOODevice
  • RemoveChannel() : JY5310CoreOO::JY5310CoreOOAITask, JY5310CoreOO::JY5310CoreOODITask, JY5310CoreOO::JY5310CoreOODOTask
  • ReTriggerCount : JY5310CoreOO::AITrigger

- s -

  • SampleClock : JY5310CoreOO::JY5310CoreOOAITask, JY5310CoreOO::JY5310CoreOODITask, JY5310CoreOO::JY5310CoreOODOTask
  • SampleRate : JY5310CoreOO::JY5310CoreOOAITask, JY5310CoreOO::JY5310CoreOODITask
  • SamplesToAcquire : JY5310CoreOO::JY5310CoreOOAITask, JY5310CoreOO::JY5310CoreOODITask
  • SamplesToUpdate : JY5310CoreOO::JY5310CoreOODOTask
  • SendSoftwareTrigger() : JY5310CoreOO::JY5310CoreOOAITask, JY5310CoreOO::JY5310CoreOODITask, JY5310CoreOO::JY5310CoreOODOTask
  • SerialNumber : JY5310CoreOO::JY5310CoreOODevice
  • SignalExport : JY5310CoreOO::JY5310CoreOOAITask, JY5310CoreOO::JY5310CoreOODITask, JY5310CoreOO::JY5310CoreOODOTask
  • Slope : JY5310CoreOO::AIAnalogEdgeComparator, JY5310CoreOO::AIAnalogHysteresisComparator
  • Source : JY5310CoreOO::AIAnalogTrigger, JY5310CoreOO::AIDigitalTrigger, JY5310CoreOO::AISampleClock, JY5310CoreOO::DIDigitalTrigger, JY5310CoreOO::DISampleClock, JY5310CoreOO::DODigitalTrigger, JY5310CoreOO::DOSampleClock, JY5310CoreOO::JY5310CoreOOReferenceClock
  • Start() : JY5310CoreOO::JY5310CoreOOAITask, JY5310CoreOO::JY5310CoreOODITask, JY5310CoreOO::JY5310CoreOODOTask
  • Stop() : JY5310CoreOO::JY5310CoreOOAITask, JY5310CoreOO::JY5310CoreOODITask, JY5310CoreOO::JY5310CoreOODOTask
  • Sync : JY5310CoreOO::JY5310CoreOOAITask

- t -

  • Terminal : JY5310CoreOO::AIExternalSampleClock, JY5310CoreOO::DIExternalSampleClock, JY5310CoreOO::DOExternalSampleClock, JY5310CoreOO::ExternalReferenceClock, JY5310CoreOO::PauseTrigger
  • Threshold : JY5310CoreOO::AIAnalogEdgeComparator
  • Topology : JY5310CoreOO::AISync
  • TransferedSamples : JY5310CoreOO::JY5310CoreOOAITask, JY5310CoreOO::JY5310CoreOODITask, JY5310CoreOO::JY5310CoreOODOTask
  • Trigger : JY5310CoreOO::JY5310CoreOOAITask, JY5310CoreOO::JY5310CoreOODITask, JY5310CoreOO::JY5310CoreOODOTask
  • TriggerRouting : JY5310CoreOO::AISync
  • Type : JY5310CoreOO::AITrigger, JY5310CoreOO::DITrigger, JY5310CoreOO::DOTrigger

- u -

  • UpdateRate : JY5310CoreOO::JY5310CoreOODOTask

- w -

  • WaitUntilDone() : JY5310CoreOO::JY5310CoreOODOTask
  • Window : JY5310CoreOO::AIAnalogTrigger
  • WriteData() : JY5310CoreOO::JY5310CoreOODOTask
  • WriteSinglePoint() : JY5310CoreOO::JY5310CoreOODOTask

- ~ -

  • ~JY5310CoreOOAITask() : JY5310CoreOO::JY5310CoreOOAITask
  • ~JY5310CoreOODITask() : JY5310CoreOO::JY5310CoreOODITask
  • ~JY5310CoreOODOTask() : JY5310CoreOO::JY5310CoreOODOTask


5310 C++ Programming Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • c
  • f
  • g
  • j
  • o
  • p
  • r
  • s
  • w
  • ~
Here is a list of all functions with links to the classes they belong to:

- a -

  • Add() : JY5310CoreOO::AISignalExport, JY5310CoreOO::DISignalExport, JY5310CoreOO::DOSignalExport
  • AddChannel() : JY5310CoreOO::JY5310CoreOOAITask, JY5310CoreOO::JY5310CoreOODITask, JY5310CoreOO::JY5310CoreOODOTask
  • AIChannel() : JY5310CoreOO::AIChannel

- c -

  • Clear() : JY5310CoreOO::AISignalExport, JY5310CoreOO::DISignalExport, JY5310CoreOO::DOSignalExport
  • ClearAll() : JY5310CoreOO::AISignalExport, JY5310CoreOO::DISignalExport, JY5310CoreOO::DOSignalExport
  • Commit() : JY5310CoreOO::JY5310CoreOOReferenceClock

- f -

  • Flush() : JY5310CoreOO::JY5310CoreOOLog

- g -

  • GetInstance() : JY5310CoreOO::JY5310CoreOODevice
  • GetRecordPreviewData() : JY5310CoreOO::JY5310CoreOOAITask
  • GetRecordStatus() : JY5310CoreOO::JY5310CoreOOAITask

- j -

  • JY5310CoreOOAITask() : JY5310CoreOO::JY5310CoreOOAITask
  • JY5310CoreOODITask() : JY5310CoreOO::JY5310CoreOODITask
  • JY5310CoreOODOTask() : JY5310CoreOO::JY5310CoreOODOTask
  • JY5310CoreOOProperty() : JY5310CoreOO::JY5310CoreOOProperty< ContainerClass, ValueType, propertyType >
  • JYDriverException() : JY5310CoreOO::JYDriverException

- o -

  • operator ValueType() : JY5310CoreOO::JY5310CoreOOProperty< ContainerClass, ValueType, propertyType >
  • operator=() : JY5310CoreOO::JY5310CoreOOProperty< ContainerClass, ValueType, propertyType >

- p -

  • Print() : JY5310CoreOO::JY5310CoreOOLog

- r -

  • ReadData() : JY5310CoreOO::JY5310CoreOOAITask, JY5310CoreOO::JY5310CoreOODITask
  • ReadRawData() : JY5310CoreOO::JY5310CoreOOAITask
  • ReadSinglePoint() : JY5310CoreOO::JY5310CoreOODITask
  • RemoveChannel() : JY5310CoreOO::JY5310CoreOOAITask, JY5310CoreOO::JY5310CoreOODITask, JY5310CoreOO::JY5310CoreOODOTask

- s -

  • SendSoftwareTrigger() : JY5310CoreOO::JY5310CoreOOAITask, JY5310CoreOO::JY5310CoreOODITask, JY5310CoreOO::JY5310CoreOODOTask
  • Start() : JY5310CoreOO::JY5310CoreOOAITask, JY5310CoreOO::JY5310CoreOODITask, JY5310CoreOO::JY5310CoreOODOTask
  • Stop() : JY5310CoreOO::JY5310CoreOOAITask, JY5310CoreOO::JY5310CoreOODITask, JY5310CoreOO::JY5310CoreOODOTask

- w -

  • WaitUntilDone() : JY5310CoreOO::JY5310CoreOODOTask
  • WriteData() : JY5310CoreOO::JY5310CoreOODOTask
  • WriteSinglePoint() : JY5310CoreOO::JY5310CoreOODOTask

- ~ -

  • ~JY5310CoreOOAITask() : JY5310CoreOO::JY5310CoreOOAITask
  • ~JY5310CoreOODITask() : JY5310CoreOO::JY5310CoreOODITask
  • ~JY5310CoreOODOTask() : JY5310CoreOO::JY5310CoreOODOTask


5310 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all variables with links to the classes they belong to:

- a -

  • ActivePolarity : JY5310CoreOO::PauseTrigger
  • AIBufferSize : JY5310CoreOO::JY5310CoreOODevice
  • Analog : JY5310CoreOO::AITrigger
  • AvailableSamples : JY5310CoreOO::JY5310CoreOOAITask, JY5310CoreOO::JY5310CoreOODITask
  • AvaliableLenInSamples : JY5310CoreOO::JY5310CoreOODOTask

- b -

  • BoardClockRate : JY5310CoreOO::JY5310CoreOODevice
  • BufLenInSamples : JY5310CoreOO::JY5310CoreOOAITask, JY5310CoreOO::JY5310CoreOODITask, JY5310CoreOO::JY5310CoreOODOTask

- c -

  • ChannelID : JY5310CoreOO::AIChannel
  • Channels : JY5310CoreOO::JY5310CoreOOAITask, JY5310CoreOO::JY5310CoreOODITask, JY5310CoreOO::JY5310CoreOODOTask
  • Comparator : JY5310CoreOO::AIAnalogTrigger
  • Condition : JY5310CoreOO::AIAnalogWindowComparator

- d -

  • Device : JY5310CoreOO::JY5310CoreOOAITask, JY5310CoreOO::JY5310CoreOODITask, JY5310CoreOO::JY5310CoreOODOTask
  • DeviceID : JY5310CoreOO::JY5310CoreOODevice
  • DiffChannelCount : JY5310CoreOO::JY5310CoreOODevice
  • Digital : JY5310CoreOO::AITrigger, JY5310CoreOO::DITrigger, JY5310CoreOO::DOTrigger
  • DIOPortCount : JY5310CoreOO::JY5310CoreOODevice

- e -

  • Edge : JY5310CoreOO::AIAnalogTrigger, JY5310CoreOO::AIDigitalTrigger, JY5310CoreOO::DIDigitalTrigger, JY5310CoreOO::DODigitalTrigger
  • EnableLog : JY5310CoreOO::JY5310CoreOOLog
  • errorCode : JY5310CoreOO::JYDriverException
  • exceptionMessage : JY5310CoreOO::JYDriverException
  • ExpectedRate : JY5310CoreOO::AIExternalSampleClock, JY5310CoreOO::DIExternalSampleClock, JY5310CoreOO::DOExternalSampleClock
  • External : JY5310CoreOO::AISampleClock, JY5310CoreOO::DISampleClock, JY5310CoreOO::DOSampleClock, JY5310CoreOO::JY5310CoreOOReferenceClock

- f -

  • File_Format : JY5310CoreOO::AIRecord
  • FilePath : JY5310CoreOO::AIRecord
  • FollowingException : JY5310CoreOO::JYDriverException

- h -

  • Handle : JY5310CoreOO::JY5310CoreOODevice
  • HighThreshold : JY5310CoreOO::AIAnalogHysteresisComparator, JY5310CoreOO::AIAnalogWindowComparator
  • Hysteresis : JY5310CoreOO::AIAnalogTrigger

- i -

  • IsAISync : JY5310CoreOO::JY5310CoreOODevice
  • IsAOSync : JY5310CoreOO::JY5310CoreOODevice

- l -

  • Length : JY5310CoreOO::AIRecord
  • LineCountPerPort : JY5310CoreOO::JY5310CoreOODevice
  • LogLevel : JY5310CoreOO::JY5310CoreOOLog
  • LowThreshold : JY5310CoreOO::AIAnalogHysteresisComparator, JY5310CoreOO::AIAnalogWindowComparator

- m -

  • MaxSampleRateMutilChannel : JY5310CoreOO::JY5310CoreOODevice
  • MaxSampleRateSingleChannel : JY5310CoreOO::JY5310CoreOODevice
  • Mode : JY5310CoreOO::AIRecord, JY5310CoreOO::AITrigger, JY5310CoreOO::DITrigger, JY5310CoreOO::JY5310CoreOOAITask, JY5310CoreOO::JY5310CoreOODITask, JY5310CoreOO::JY5310CoreOODOTask

- p -

  • PortNum : JY5310CoreOO::DIChannel, JY5310CoreOO::DOChannel
  • PreTriggerSamples : JY5310CoreOO::AITrigger, JY5310CoreOO::DITrigger
  • PulseRouting : JY5310CoreOO::AISync

- r -

  • RangeHigh : JY5310CoreOO::AIChannel
  • RangeLow : JY5310CoreOO::AIChannel
  • Record : JY5310CoreOO::JY5310CoreOOAITask
  • ReferenceClock : JY5310CoreOO::JY5310CoreOODevice
  • ReTriggerCount : JY5310CoreOO::AITrigger

- s -

  • SampleClock : JY5310CoreOO::JY5310CoreOOAITask, JY5310CoreOO::JY5310CoreOODITask, JY5310CoreOO::JY5310CoreOODOTask
  • SampleRate : JY5310CoreOO::JY5310CoreOOAITask, JY5310CoreOO::JY5310CoreOODITask
  • SamplesToAcquire : JY5310CoreOO::JY5310CoreOOAITask, JY5310CoreOO::JY5310CoreOODITask
  • SamplesToUpdate : JY5310CoreOO::JY5310CoreOODOTask
  • SerialNumber : JY5310CoreOO::JY5310CoreOODevice
  • SignalExport : JY5310CoreOO::JY5310CoreOOAITask, JY5310CoreOO::JY5310CoreOODITask, JY5310CoreOO::JY5310CoreOODOTask
  • Slope : JY5310CoreOO::AIAnalogEdgeComparator, JY5310CoreOO::AIAnalogHysteresisComparator
  • Source : JY5310CoreOO::AIAnalogTrigger, JY5310CoreOO::AIDigitalTrigger, JY5310CoreOO::AISampleClock, JY5310CoreOO::DIDigitalTrigger, JY5310CoreOO::DISampleClock, JY5310CoreOO::DODigitalTrigger, JY5310CoreOO::DOSampleClock, JY5310CoreOO::JY5310CoreOOReferenceClock
  • Sync : JY5310CoreOO::JY5310CoreOOAITask

- t -

  • Terminal : JY5310CoreOO::AIExternalSampleClock, JY5310CoreOO::DIExternalSampleClock, JY5310CoreOO::DOExternalSampleClock, JY5310CoreOO::ExternalReferenceClock, JY5310CoreOO::PauseTrigger
  • Threshold : JY5310CoreOO::AIAnalogEdgeComparator
  • Topology : JY5310CoreOO::AISync
  • TransferedSamples : JY5310CoreOO::JY5310CoreOOAITask, JY5310CoreOO::JY5310CoreOODITask, JY5310CoreOO::JY5310CoreOODOTask
  • Trigger : JY5310CoreOO::JY5310CoreOOAITask, JY5310CoreOO::JY5310CoreOODITask, JY5310CoreOO::JY5310CoreOODOTask
  • TriggerRouting : JY5310CoreOO::AISync
  • Type : JY5310CoreOO::AITrigger, JY5310CoreOO::DITrigger, JY5310CoreOO::DOTrigger

- u -

  • UpdateRate : JY5310CoreOO::JY5310CoreOODOTask

- w -

  • Window : JY5310CoreOO::AIAnalogTrigger


5310 C++ Programming Manual: File Members

  • File List
  • File Members
  • All
  • Macros
Here is a list of all file members with links to the files they belong to:
  • EXTERN_C : JY5310CoreOOCommon.h
  • JY5310CoreOO_API : JY5310CoreOOCommon.h


5310 C++ Programming Manual: File Members

  • File List
  • File Members
  • All
  • Macros
Here is a list of all macros with links to the files they belong to:
  • EXTERN_C : JY5310CoreOOCommon.h
  • JY5310CoreOO_API : JY5310CoreOOCommon.h


5310 C++ Programming Manual: Main Page

5310 C++ Programming Manual Documentation


5310 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • l
  • r
  • s
Here is a list of all namespace members with links to the namespace documentation for each member:

- a -

  • AIAnalogTriggerComparator : JY5310CoreOO
  • AIAnalogTriggerEdge : JY5310CoreOO
  • AIAnalogTriggerSource : JY5310CoreOO
  • AIAnalogWindowCondition : JY5310CoreOO
  • AIDigitalTriggerEdge : JY5310CoreOO
  • AIDigitalTriggerSource : JY5310CoreOO
  • AIMode : JY5310CoreOO
  • AISampleClockSource : JY5310CoreOO
  • AISignalExportSource : JY5310CoreOO
  • AITriggerMode : JY5310CoreOO
  • AITriggerType : JY5310CoreOO

- c -

  • ClockTerminal : JY5310CoreOO

- d -

  • DIDigitalTriggerEdge : JY5310CoreOO
  • DIDigitalTriggerSource : JY5310CoreOO
  • DIMode : JY5310CoreOO
  • DISampleClockSource : JY5310CoreOO
  • DISignalExportSource : JY5310CoreOO
  • DITriggerMode : JY5310CoreOO
  • DITriggerType : JY5310CoreOO
  • DODigitalTriggerEdge : JY5310CoreOO
  • DODigitalTriggerSource : JY5310CoreOO
  • DOMode : JY5310CoreOO
  • DOSampleClockSource : JY5310CoreOO
  • DOSignalExportSource : JY5310CoreOO
  • DOTriggerType : JY5310CoreOO

- e -

  • ExternalReferenceClockTerminal : JY5310CoreOO

- f -

  • FileFormat : JY5310CoreOO

- g -

  • GetSignalExportDestinationString() : JY5310CoreOO

- i -

  • InputTerminal : JY5310CoreOO
  • IOTerminal : JY5310CoreOO

- j -

  • JY5310CoreOOLogLevel : JY5310CoreOO
  • JY5310CoreOOPropertyType : JY5310CoreOO
  • JYDriverExceptionPublic : JY5310CoreOO

- l -

  • LevelPolarity : JY5310CoreOO

- r -

  • RecordMode : JY5310CoreOO
  • ReferenceClockSource : JY5310CoreOO

- s -

  • SignalExportDestination : JY5310CoreOO
  • SyncPulseRouting : JY5310CoreOO
  • SyncTopology : JY5310CoreOO
  • SyncTriggerRouting : JY5310CoreOO


5310 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • a
  • c
  • d
  • e
  • f
  • i
  • j
  • l
  • r
  • s
Here is a list of all namespace enums with links to the namespace documentation for each enum:

- a -

  • AIAnalogTriggerComparator : JY5310CoreOO
  • AIAnalogTriggerEdge : JY5310CoreOO
  • AIAnalogTriggerSource : JY5310CoreOO
  • AIAnalogWindowCondition : JY5310CoreOO
  • AIDigitalTriggerEdge : JY5310CoreOO
  • AIDigitalTriggerSource : JY5310CoreOO
  • AIMode : JY5310CoreOO
  • AISampleClockSource : JY5310CoreOO
  • AISignalExportSource : JY5310CoreOO
  • AITriggerMode : JY5310CoreOO
  • AITriggerType : JY5310CoreOO

- c -

  • ClockTerminal : JY5310CoreOO

- d -

  • DIDigitalTriggerEdge : JY5310CoreOO
  • DIDigitalTriggerSource : JY5310CoreOO
  • DIMode : JY5310CoreOO
  • DISampleClockSource : JY5310CoreOO
  • DISignalExportSource : JY5310CoreOO
  • DITriggerMode : JY5310CoreOO
  • DITriggerType : JY5310CoreOO
  • DODigitalTriggerEdge : JY5310CoreOO
  • DODigitalTriggerSource : JY5310CoreOO
  • DOMode : JY5310CoreOO
  • DOSampleClockSource : JY5310CoreOO
  • DOSignalExportSource : JY5310CoreOO
  • DOTriggerType : JY5310CoreOO

- e -

  • ExternalReferenceClockTerminal : JY5310CoreOO

- f -

  • FileFormat : JY5310CoreOO

- i -

  • InputTerminal : JY5310CoreOO
  • IOTerminal : JY5310CoreOO

- j -

  • JY5310CoreOOLogLevel : JY5310CoreOO
  • JY5310CoreOOPropertyType : JY5310CoreOO
  • JYDriverExceptionPublic : JY5310CoreOO

- l -

  • LevelPolarity : JY5310CoreOO

- r -

  • RecordMode : JY5310CoreOO
  • ReferenceClockSource : JY5310CoreOO

- s -

  • SignalExportDestination : JY5310CoreOO
  • SyncPulseRouting : JY5310CoreOO
  • SyncTopology : JY5310CoreOO
  • SyncTriggerRouting : JY5310CoreOO


5310 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
Here is a list of all namespace functions with links to the namespace documentation for each function:
  • GetSignalExportDestinationString() : JY5310CoreOO


5310 C++ Programming Manual: Namespace List

  • Namespace List
  • Namespace Members
Namespace List
Here is a list of all namespaces with brief descriptions:
N JY5310CoreOO