5310 C# Programming Manual: C:/Users/wukeping/Desktop/5310 Directory Reference

5310 C# Programming Manual
  • 5310
5310 Directory Reference

Directories

directory C#
Generated by doxygen 1.9.1


5310 C# Programming Manual: C:/Users/wukeping/Desktop/5310/C#/JY5310AITask.cs File Reference

  • 5310
  • C#
Classes | Namespaces | Enumerations
JY5310AITask.cs File Reference

Classes

class | JY5310.JY5310AITask
JY5310 Analog Input Task. More...
class | JY5310.AIChannel
AI Channel parameter class More...
class | JY5310.AIAnalogHysteresisComparator
AI Analog Hysteresis Comparatorr More...
class | JY5310.AIAnalogWindowComparator
AI Analog Window Comparatorr More...
class | JY5310.AIAnalogEdgeComparator
AI Analog Edge Comparator More...
class | JY5310.AISampleClock
Sample clock configuration class More...
class | JY5310.AIExternalSampleClock
External Sample Clock Configuration Class More...
class | JY5310.AITrigger
AI Trigger class More...
class | JY5310.AIDigitalTrigger
AI Digital Trigger More...
class | JY5310.AIAnalogTrigger
AI Analog Trigger More...
class | JY5310.AIRecord
AI Record class More...
class | JY5310.AISync
Configure sync signal More...
class | JY5310.AISignalExport
AI Signal Export Class More...

Namespaces

namespace JY5310

Enumerations

enum class | JY5310.AITriggerType { JY5310.Immediate = JY5310Import.JY5310_TriggerType_Immediately , JY5310.Digital = JY5310Import.JY5310_TriggerType_Digital , JY5310.Analog = JY5310Import.JY5310_TriggerType_Analog , JY5310.Soft = JY5310Import.JY5310_TriggerType_Soft }
Trigger Type: Digital/Analog/Immediate More...
enum class | JY5310.AIDigitalTriggerEdge { JY5310.Rising = JY5310Import.JY5310_DigitalTriggerEdge_Rising , JY5310.Falling = JY5310Import.JY5310_DigitalTriggerEdge_Falling }
AI Digital Trigger Edge More...
enum class | JY5310.AIAnalogTriggerEdge { JY5310.Rising , JY5310.Falling }
AI Analog Trigger Edge More...
enum class | JY5310.AIAnalogWindowCondition { JY5310.Entering , JY5310.Leaving }
AI Analog Window Trigger Condition More...
enum class | JY5310.AIAnalogTriggerComparator { JY5310.Edge , JY5310.Hysteresis , JY5310.Window }
AI Analog Trigger Comparator More...
enum class | JY5310.AIMode { JY5310.Finite = JY5310Import.JY5310_AI_Finite , JY5310.Continuous = JY5310Import.JY5310_AI_Continuous , JY5310.Record = 0x3 }
AIMode More...
enum class | JY5310.AISampleClockSource { JY5310.Internal = JY5310Import.JY5310_AI_InternalClock , JY5310.External = JY5310Import.JY5310_AI_ExternalClock }
AIClockSource Type More...
enum class JY5310.ClockTerminal {
JY5310.PFI0 = JY5310Import.JY5310_DigitalTriggerSource_PFI_0 , JY5310.PFI1 = JY5310Import.JY5310_DigitalTriggerSource_PFI_1 , JY5310.PFI2 = JY5310Import.JY5310_DigitalTriggerSource_PFI_2 , JY5310.PFI3 = JY5310Import.JY5310_DigitalTriggerSource_PFI_3 ,
JY5310.PFI4 = JY5310Import.JY5310_DigitalTriggerSource_PFI_4 , JY5310.PFI5 = JY5310Import.JY5310_DigitalTriggerSource_PFI_5 , JY5310.PFI6 = JY5310Import.JY5310_DigitalTriggerSource_PFI_6 , JY5310.PFI7 = JY5310Import.JY5310_DigitalTriggerSource_PFI_7 ,
JY5310.PFI8 = JY5310Import.JY5310_DigitalTriggerSource_PFI_8 , JY5310.PFI9 = JY5310Import.JY5310_DigitalTriggerSource_PFI_9 , JY5310.PFI10 = JY5310Import.JY5310_DigitalTriggerSource_PFI_10 , JY5310.PFI11 = JY5310Import.JY5310_DigitalTriggerSource_PFI_11 ,
JY5310.PFI12 = JY5310Import.JY5310_DigitalTriggerSource_PFI_12 , JY5310.PFI13 = JY5310Import.JY5310_DigitalTriggerSource_PFI_13 , JY5310.PFI14 = JY5310Import.JY5310_DigitalTriggerSource_PFI_14 , JY5310.PFI15 = JY5310Import.JY5310_DigitalTriggerSource_PFI_15 ,
JY5310.PXI_Trig0 = JY5310Import.JY5310_DigitalTriggerSource_PXI_0 , JY5310.PXI_Trig1 = JY5310Import.JY5310_DigitalTriggerSource_PXI_1 , JY5310.PXI_Trig2 = JY5310Import.JY5310_DigitalTriggerSource_PXI_2 , JY5310.PXI_Trig3 = JY5310Import.JY5310_DigitalTriggerSource_PXI_3 ,
JY5310.PXI_Trig4 = JY5310Import.JY5310_DigitalTriggerSource_PXI_4 , JY5310.PXI_Trig5 = JY5310Import.JY5310_DigitalTriggerSource_PXI_5 , JY5310.PXI_Trig6 = JY5310Import.JY5310_DigitalTriggerSource_PXI_6 , JY5310.PXI_Trig7 = JY5310Import.JY5310_DigitalTriggerSource_PXI_7 ,
JY5310.AI_SampleClock = JY5310Import.JY5310_AI_SampleClock , JY5310.DI_SampleClock = JY5310Import.JY5310_DI_SampleClock , JY5310.DO_SampleClock = JY5310Import.JY5310_DO_SampleClock
}
External Sample Clock Terminal More...
enum class | JY5310.AITriggerMode { JY5310.Start , JY5310.Reference }
AI Trigger Mode More...
enum class JY5310.AIAnalogTriggerSource {
JY5310.Channel_0 , JY5310.Channel_1 , JY5310.Channel_2 , JY5310.Channel_3 ,
JY5310.Channel_4 , JY5310.Channel_5 , JY5310.Channel_6 , JY5310.Channel_7 ,
JY5310.Channel_8 , JY5310.Channel_9 , JY5310.Channel_10 , JY5310.Channel_11 ,
JY5310.Channel_12 , JY5310.Channel_13 , JY5310.Channel_14 , JY5310.Channel_15
}
AI Analog Trigger Source More...
enum class JY5310.AIDigitalTriggerSource {
JY5310.PFI0 = JY5310Import.JY5310_DigitalTriggerSource_PFI_0 , JY5310.PFI1 = JY5310Import.JY5310_DigitalTriggerSource_PFI_1 , JY5310.PFI2 = JY5310Import.JY5310_DigitalTriggerSource_PFI_2 , JY5310.PFI3 = JY5310Import.JY5310_DigitalTriggerSource_PFI_3 ,
JY5310.PFI4 = JY5310Import.JY5310_DigitalTriggerSource_PFI_4 , JY5310.PFI5 = JY5310Import.JY5310_DigitalTriggerSource_PFI_5 , JY5310.PFI6 = JY5310Import.JY5310_DigitalTriggerSource_PFI_6 , JY5310.PFI7 = JY5310Import.JY5310_DigitalTriggerSource_PFI_7 ,
JY5310.PFI8 = JY5310Import.JY5310_DigitalTriggerSource_PFI_8 , JY5310.PFI9 = JY5310Import.JY5310_DigitalTriggerSource_PFI_9 , JY5310.PFI10 = JY5310Import.JY5310_DigitalTriggerSource_PFI_10 , JY5310.PFI11 = JY5310Import.JY5310_DigitalTriggerSource_PFI_11 ,
JY5310.PFI12 = JY5310Import.JY5310_DigitalTriggerSource_PFI_12 , JY5310.PFI13 = JY5310Import.JY5310_DigitalTriggerSource_PFI_13 , JY5310.PFI14 = JY5310Import.JY5310_DigitalTriggerSource_PFI_14 , JY5310.PFI15 = JY5310Import.JY5310_DigitalTriggerSource_PFI_15 ,
JY5310.PXI_Trig0 = JY5310Import.JY5310_DigitalTriggerSource_PXI_0 , JY5310.PXI_Trig1 = JY5310Import.JY5310_DigitalTriggerSource_PXI_1 , JY5310.PXI_Trig2 = JY5310Import.JY5310_DigitalTriggerSource_PXI_2 , JY5310.PXI_Trig3 = JY5310Import.JY5310_DigitalTriggerSource_PXI_3 ,
JY5310.PXI_Trig4 = JY5310Import.JY5310_DigitalTriggerSource_PXI_4 , JY5310.PXI_Trig5 = JY5310Import.JY5310_DigitalTriggerSource_PXI_5 , JY5310.PXI_Trig6 = JY5310Import.JY5310_DigitalTriggerSource_PXI_6 , JY5310.PXI_Trig7 = JY5310Import.JY5310_DigitalTriggerSource_PXI_7 ,
JY5310.DO_StartTrig = JY5310Import.JY5310_DO_StartTrig , JY5310.DI_StartTrig = JY5310Import.JY5310_DI_StartTrig , JY5310.DI_ReferencetTrig = JY5310Import.JY5310_DI_ReferenceTrig
}
AI Digital Trigger Source More...
enum class | JY5310.FileFormat { JY5310.Bin }
Streaming file format More...
enum class | JY5310.RecordMode { JY5310.Finite , JY5310.Infinite }
Two stream mode from enum Finite/Infinite More...
enum class | JY5310.SyncTopology { JY5310.Independent , JY5310.Master , JY5310.Slave }
Synchronization board configuration More...
enum class JY5310.SyncTriggerRouting {
JY5310.NONE = -1 , JY5310.PXI_Trig0 = JY5310Import.JY5310_DigitalTriggerSource_PXI_0 , JY5310.PXI_Trig1 = JY5310Import.JY5310_DigitalTriggerSource_PXI_1 , JY5310.PXI_Trig2 = JY5310Import.JY5310_DigitalTriggerSource_PXI_2 ,
JY5310.PXI_Trig3 = JY5310Import.JY5310_DigitalTriggerSource_PXI_3 , JY5310.PXI_Trig4 = JY5310Import.JY5310_DigitalTriggerSource_PXI_4 , JY5310.PXI_Trig5 = JY5310Import.JY5310_DigitalTriggerSource_PXI_5 , JY5310.PXI_Trig6 = JY5310Import.JY5310_DigitalTriggerSource_PXI_6 ,
JY5310.PXI_Trig7 = JY5310Import.JY5310_DigitalTriggerSource_PXI_7
}
Master card trigger signal routing (Master card routes trigger signal to this port) More...
enum class JY5310.SyncPulseRouting {
JY5310.NONE = -1 , JY5310.PXI_Trig0 = JY5310Import.JY5310_DigitalTriggerSource_PXI_0 , JY5310.PXI_Trig1 = JY5310Import.JY5310_DigitalTriggerSource_PXI_1 , JY5310.PXI_Trig2 = JY5310Import.JY5310_DigitalTriggerSource_PXI_2 ,
JY5310.PXI_Trig3 = JY5310Import.JY5310_DigitalTriggerSource_PXI_3 , JY5310.PXI_Trig4 = JY5310Import.JY5310_DigitalTriggerSource_PXI_4 , JY5310.PXI_Trig5 = JY5310Import.JY5310_DigitalTriggerSource_PXI_5 , JY5310.PXI_Trig6 = JY5310Import.JY5310_DigitalTriggerSource_PXI_6 ,
JY5310.PXI_Trig7 = JY5310Import.JY5310_DigitalTriggerSource_PXI_7
}
Synchronous signal routing (the master card routes the synchronous signal to this port, and the slave card receives the synchronous signal from this port) More...
enum class | JY5310.AISignalExportSource { JY5310.StartTrig = 11 , JY5310.ReferenceTrig = 12 , JY5310.SampleClock = 59 }
AI Signal Export Source More...
enum class JY5310.SignalExportDestination {
JY5310.PFI0 = 16 , JY5310.PFI1 = 17 , JY5310.PFI2 = 18 , JY5310.PFI3 = 19 ,
JY5310.PFI4 = 20 , JY5310.PFI5 = 21 , JY5310.PFI6 = 22 , JY5310.PFI7 = 23 ,
JY5310.PFI8 = 24 , JY5310.PFI9 = 25 , JY5310.PFI10 = 26 , JY5310.PFI11 = 27 ,
JY5310.PFI12 = 28 , JY5310.PFI13 = 29 , JY5310.PFI14 = 30 , JY5310.PFI15 = 31 ,
JY5310.PXI_Trig0 = 0 , JY5310.PXI_Trig1 = 1 , JY5310.PXI_Trig2 = 2 , JY5310.PXI_Trig3 = 3 ,
JY5310.PXI_Trig4 = 4 , JY5310.PXI_Trig5 = 5 , JY5310.PXI_Trig6 = 6 , JY5310.PXI_Trig7 = 7
}
Output DestinationTerminal More...


5310 C# Programming Manual: JY5310.JY5310AITask Class Reference

  • JY5310
  • JY5310AITask
Classes | Public Member Functions | Properties | List of all members
JY5310.JY5310AITask Class Reference

JY5310 Analog Input Task. More...

Public Member Functions

JY5310AITask (int slotNum)
Constructor. More...
JY5310AITask (string boardName)
Constructor. More...
void | GetCalibration ()
GetAICalibration More...
void | AddChannel (int chnId, double rangeLow=-10, double rangeHigh=10)
Add one channel More...
void | AddChannel (int[] chnsId, double rangeLow=-10, double rangeHigh=10)
Add a group of channels. More...
void | AddChannel (int[] chnsId, double[] rangeLow, double[] rangeHigh)
Add a group of channels, each channel range can be set differently More...
void | RemoveChannel (int chnId)
Delete the channel with the specified channel number. More...
void | ReadData (ref double[,] buf, int samplesPerChannel, int timeout=10000)
Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data. More...
void | ReadData (IntPtr buf, int samplesPerChannel, int timeout=10000)
Read one or multi-channel data by columns and store it in a data buffer. More...
void | ReadData (ref double[,] buf, int timeout=10000)
Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data. More...
void | ReadData (ref double[] buf, int samplesPerChannel, int timeout=10000)
Read the one channel data and store it in a data buffer. More...
void | ReadData (ref double[] buf, int timeout=10000)
Read the one channel data and store it in a data buffer. More...
void | ReadRawData (ref short[,] buf, int samplesPerChannel, int timeout=10000)
Read the multi-channel raw data by columns and store it in a data buffer,Each channel is represented by one column of data More...
void | ReadRawData (ref short[,] buf, int timeout=10000)
Read the multi-channel raw data by columns and store it in a data buffer,Each channel is represented by one column of data More...
void | ReadRawData (IntPtr buf, int samplesPerChannel, int timeout=10000)
Read one or multi-channel raw data by columns and store it in a data buffer. More...
void | ReadRawData (ref short[] buf, int samplesPerChannel, int timeout=10000)
Read the one channel raw data and store it in a data buffer. More...
void | ReadRawData (ref short[] buf, int timeout=10000)
Read the one channel raw data and store it in a data buffer. More...
void | GetRecordPreviewData (ref double[,] buf, int samplesPerChannel, int timeout=1000)
Preview multi-channel data when streaming is in progress. More...
void | GetRecordPreviewData (ref double[,] buf, int timeout=1000)
Preview multi-channel data when streaming is in progress. More...
void | GetRecordPreviewData (ref double[] buf, int samplesPerChannel, int timeout=1000)
Preview one channel data when streaming is in progress. More...
void | GetRecordPreviewData (ref double[] buf, int timeout=1000)
Preview one channel data when streaming is in progress. More...
void | GetRecordStatus (out double recordedLength, out bool recordDone)
Get the streaming status More...
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete More...
void | Start ()
Start AITask More...
void | SendSoftwareTrigger ()
Generate a software trigger signal generate a software trigger signal More...
void | Stop ()
Stop AI Task More...

Properties

JY5310Device | Device [get]
Device Handle More...
List< AIChannel > | Channels [get]
List of AI channels,support 16 Different More...
AIMode | Mode [get, set]
AI acquisition mode，support Finite/Continuous/Record More...
double | SampleRate [get, set]
Sample rate per channel. More...
int | SamplesToAcquire [get, set]
Number of samples to be read per channel. More...
int | BufLenInSamples [get]
Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value. More...
ulong | AvailableSamples [get]
Number of samples per channel that can be read in the buffer More...
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel). More...
AISampleClock | SampleClock [get, set]
AI Sample Clock Configuration More...
AITrigger | Trigger [get, set]
时钟沿。仅在外部时钟时有效。 More...
AIRecord | Record = new AIRecord() [get]
Data streaming Configuration More...
bool | DisableCalibration [get, set]
Disalble calibration More...
AISync | Sync [get]
Multi card synchronous configuration More...
AISignalExport | SignalExport [get, set]
Export AI Signal Configuration More...

Detailed Description

JY5310 Analog Input Task.

Constructor & Destructor Documentation

◆ JY5310AITask() [1/2]

JY5310.JY5310AITask.JY5310AITask ( int slotNum )

Constructor.

Used to create an AI task by a slot number

Parameters
slotNum Card slot number.

◆ JY5310AITask() [2/2]

JY5310.JY5310AITask.JY5310AITask ( string boardName )

Constructor.

Used to create an AI task by a board name.

Parameters
boardName Board name(device alias), set by device manager

Member Function Documentation

◆ AddChannel() [1/3]

void JY5310.JY5310AITask.AddChannel | ( | int | chnId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10
 | ) |  |

Add one channel

Parameters
chnId | channel's physical number ，chnId=-1, add all channels
rangeLow | lower range limit for the channel，-10V,-5V,-2V，-1V,default -10
rangeHigh | higher range limit for the channel,10V,5V,2V，1V,default 10

◆ AddChannel() [2/3]

void JY5310.JY5310AITask.AddChannel | ( | int[] | chnsId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10
 | ) |  |

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers
rangeLow | lower range limit for the channel，-10V,-5V,-2V，-1V,default -10
rangeHigh | higher range limit for the channel,10V,5V,2V，1V,default 10

◆ AddChannel() [3/3]

void JY5310.JY5310AITask.AddChannel | ( | int[] | chnsId,
 |  | double[] | rangeLow,
 |  | double[] | rangeHigh
 | ) |  |

Add a group of channels, each channel range can be set differently

Parameters
chnsId | a group of channel physical numbers,different mode 0-15
rangeLow | lower range limit for the channel，-10V,-5V,-2V，-1V
rangeHigh | higher range limit for the channel,10V,5V,2V，1V

◆ GetCalibration()

void JY5310.JY5310AITask.GetCalibration ( )

GetAICalibration

◆ GetRecordPreviewData() [1/4]

void JY5310.JY5310AITask.GetRecordPreviewData | ( | ref double | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout = 1000
 | ) |  |

Preview multi-channel data when streaming is in progress.

Each column represents one channel.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ GetRecordPreviewData() [2/4]

void JY5310.JY5310AITask.GetRecordPreviewData | ( | ref double | buf[,],
 |  | int | timeout = 1000
 | ) |  |

Preview multi-channel data when streaming is in progress.

Each column represents one channel.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms
Returns

◆ GetRecordPreviewData() [3/4]

void JY5310.JY5310AITask.GetRecordPreviewData | ( | ref double[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 1000
 | ) |  |

Preview one channel data when streaming is in progress.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ GetRecordPreviewData() [4/4]

void JY5310.JY5310AITask.GetRecordPreviewData | ( | ref double[] | buf,
 |  | int | timeout = 1000
 | ) |  |

Preview one channel data when streaming is in progress.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms

◆ GetRecordStatus()

void JY5310.JY5310AITask.GetRecordStatus | ( | out double | recordedLength,
 |  | out bool | recordDone
 | ) |  |

Get the streaming status

Parameters
recordedLength | Length of the streamed, unit s
recordDone | recordDone = false :streaming is not over.recordDone = true :streaming is over

◆ ReadData() [1/5]

void JY5310.JY5310AITask.ReadData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000
 | ) |  |

Read one or multi-channel data by columns and store it in a data buffer.

The buffer is pointed by C# data type IntPtr.

param name="buf">Data buffer

Parameters
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish

◆ ReadData() [2/5]

void JY5310.JY5310AITask.ReadData | ( | ref double | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000
 | ) |  |

Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.

param name="buf">Data buffer

Parameters
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish

◆ ReadData() [3/5]

void JY5310.JY5310AITask.ReadData | ( | ref double | buf[,],
 |  | int | timeout = 10000
 | ) |  |

Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.

param name="buf">Data buffer

Parameters
timeout timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish

◆ ReadData() [4/5]

void JY5310.JY5310AITask.ReadData | ( | ref double[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000
 | ) |  |

Read the one channel data and store it in a data buffer.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ ReadData() [5/5]

void JY5310.JY5310AITask.ReadData | ( | ref double[] | buf,
 |  | int | timeout = 10000
 | ) |  |

Read the one channel data and store it in a data buffer.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [1/5]

void JY5310.JY5310AITask.ReadRawData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000
 | ) |  |

Read one or multi-channel raw data by columns and store it in a data buffer.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [2/5]

void JY5310.JY5310AITask.ReadRawData | ( | ref short | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000
 | ) |  |

Read the multi-channel raw data by columns and store it in a data buffer,Each channel is represented by one column of data

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [3/5]

void JY5310.JY5310AITask.ReadRawData | ( | ref short | buf[,],
 |  | int | timeout = 10000
 | ) |  |

Read the multi-channel raw data by columns and store it in a data buffer,Each channel is represented by one column of data

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [4/5]

void JY5310.JY5310AITask.ReadRawData | ( | ref short[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000
 | ) |  |

Read the one channel raw data and store it in a data buffer.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [5/5]

void JY5310.JY5310AITask.ReadRawData | ( | ref short[] | buf,
 |  | int | timeout = 10000
 | ) |  |

Read the one channel raw data and store it in a data buffer.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms

◆ RemoveChannel()

void JY5310.JY5310AITask.RemoveChannel ( int chnId )

Delete the channel with the specified channel number.

chnId=- 1, all channels will be deleted

Parameters
chnId Channel number of the channel to be deleted

◆ SendSoftwareTrigger()

void JY5310.JY5310AITask.SendSoftwareTrigger ( )

Generate a software trigger signal generate a software trigger signal

Returns

◆ Start()

void JY5310.JY5310AITask.Start ( )

Start AITask

◆ Stop()

void JY5310.JY5310AITask.Stop ( )

Stop AI Task

◆ WaitUntilDone()

bool JY5310.JY5310AITask.WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate
Returns
True: task end, false: timeout

Property Documentation

◆ AvailableSamples

ulong JY5310.JY5310AITask.AvailableSamples
get

Number of samples per channel that can be read in the buffer

◆ BufLenInSamples

int JY5310.JY5310AITask.BufLenInSamples
get

Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.

◆ Channels

List<AIChannel> JY5310.JY5310AITask.Channels
get

List of AI channels,support 16 Different

◆ Device

JY5310Device JY5310.JY5310AITask.Device
get

Device Handle

◆ DisableCalibration

bool JY5310.JY5310AITask.DisableCalibration
getset

Disalble calibration

◆ Mode

AIMode JY5310.JY5310AITask.Mode
getset

AI acquisition mode，support Finite/Continuous/Record

◆ Record

AIRecord JY5310.JY5310AITask.Record = new AIRecord()
get

Data streaming Configuration

◆ SampleClock

AISampleClock JY5310.JY5310AITask.SampleClock
getset

AI Sample Clock Configuration

◆ SampleRate

double JY5310.JY5310AITask.SampleRate
getset

Sample rate per channel.

Maximum sample rate is 2M for 5312 and 5M for 5310 The defalut sample rate = 100k You can read this property to obtain the sample rate that will actually take effect in the current configuration.

◆ SamplesToAcquire

int JY5310.JY5310AITask.SamplesToAcquire
getset

Number of samples to be read per channel.

Only valid when Mode is AIMode.Finite.

◆ SignalExport

AISignalExport JY5310.JY5310AITask.SignalExport
getset

Export AI Signal Configuration

◆ Sync

AISync JY5310.JY5310AITask.Sync
get

Multi card synchronous configuration

◆ TransferedSamples

ulong JY5310.JY5310AITask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

◆ Trigger

AITrigger JY5310.JY5310AITask.Trigger
getset

时钟沿。仅在外部时钟时有效。

AI Trigger Configuration

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5310/C#/JY5310AITask.cs


5310 C# Programming Manual: JY5310.AIChannel Class Reference

  • AIChannel
Public Member Functions | Properties | List of all members
JY5310.AIChannel Class Reference

AI Channel parameter class More...

Public Member Functions

AIChannel (int channelId, double rangeLow, double rangeHigh)
Constructor to create an AIChnParam task object. More...

Properties

int | ChannelID [get]
AI channel ID. More...
double | RangeLow [get, set]
Low range limit an AI channel，-10V,-5V,-2V，-1V More...
double | RangeHigh [get, set]
High range limit an AI channel，10V,5V,2V，1V More...

Detailed Description

AI Channel parameter class

Constructor & Destructor Documentation

◆ AIChannel()

JY5310.AIChannel.AIChannel | ( | int | channelId,
 |  | double | rangeLow,
 |  | double | rangeHigh
 | ) |  |

Constructor to create an AIChnParam task object.

Parameters
channelId | AI channel ID.
rangeLow | Low range limit an AI channel.
rangeHigh | High range limit an AI channel.

Property Documentation

◆ ChannelID

int JY5310.AIChannel.ChannelID
get

AI channel ID.

◆ RangeHigh

double JY5310.AIChannel.RangeHigh
getset

High range limit an AI channel，10V,5V,2V，1V

◆ RangeLow

double JY5310.AIChannel.RangeLow
getset

Low range limit an AI channel，-10V,-5V,-2V，-1V

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5310/C#/JY5310AITask.cs


5310 C# Programming Manual: JY5310.AIAnalogHysteresisComparator Class Reference

  • AIAnalogHysteresisComparator
Public Attributes | Properties | List of all members
JY5310.AIAnalogHysteresisComparator Class Reference

AI Analog Hysteresis Comparatorr More...

Public Attributes

double | HighThreshold
High Threshold More...
double | LowThreshold
Low Threshold More...

Properties

AIAnalogTriggerEdge Slope [get, set]
AI Analog Trigger Edge More...

Detailed Description

AI Analog Hysteresis Comparatorr

Member Data Documentation

◆ HighThreshold

double JY5310.AIAnalogHysteresisComparator.HighThreshold

High Threshold

◆ LowThreshold

double JY5310.AIAnalogHysteresisComparator.LowThreshold

Low Threshold

Property Documentation

◆ Slope

AIAnalogTriggerEdge JY5310.AIAnalogHysteresisComparator.Slope
getset

AI Analog Trigger Edge

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5310/C#/JY5310AITask.cs


5310 C# Programming Manual: JY5310.AIAnalogWindowComparator Class Reference

  • AIAnalogWindowComparator
Public Attributes | Properties | List of all members
JY5310.AIAnalogWindowComparator Class Reference

AI Analog Window Comparatorr More...

Public Attributes

double | HighThreshold
High Threshold More...
double | LowThreshold
Low Threshold More...

Properties

AIAnalogWindowCondition Condition [get, set]
AI Analog Window Condition More...

Detailed Description

AI Analog Window Comparatorr

Member Data Documentation

◆ HighThreshold

double JY5310.AIAnalogWindowComparator.HighThreshold

High Threshold

◆ LowThreshold

double JY5310.AIAnalogWindowComparator.LowThreshold

Low Threshold

Property Documentation

◆ Condition

AIAnalogWindowCondition JY5310.AIAnalogWindowComparator.Condition
getset

AI Analog Window Condition

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5310/C#/JY5310AITask.cs


5310 C# Programming Manual: JY5310.AIAnalogEdgeComparator Class Reference

  • AIAnalogEdgeComparator
Public Attributes | Properties | List of all members
JY5310.AIAnalogEdgeComparator Class Reference

AI Analog Edge Comparator More...

Public Attributes

double Threshold
Threshold More...

Properties

AIAnalogTriggerEdge Slope [get, set]
AI Analog Trigger Edge More...

Detailed Description

AI Analog Edge Comparator

Member Data Documentation

◆ Threshold

double JY5310.AIAnalogEdgeComparator.Threshold

Threshold

Property Documentation

◆ Slope

AIAnalogTriggerEdge JY5310.AIAnalogEdgeComparator.Slope
getset

AI Analog Trigger Edge

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5310/C#/JY5310AITask.cs


5310 C# Programming Manual: JY5310.AISampleClock Class Reference

  • AISampleClock
Properties | List of all members
JY5310.AISampleClock Class Reference

Sample clock configuration class More...

Properties

AISampleClockSource | Source [get, set]
Clock Source. More...
AIExternalSampleClock | External [get, set]
External Sample Clock， Valid when Source is AISampleClockSource.External. More...

Detailed Description

Sample clock configuration class

Property Documentation

◆ External

AIExternalSampleClock JY5310.AISampleClock.External
getset

External Sample Clock， Valid when Source is AISampleClockSource.External.

◆ Source

AISampleClockSource JY5310.AISampleClock.Source
getset

Clock Source.

enum Internal/External,The default value is AISampleClockSource.Internal.

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5310/C#/JY5310AITask.cs


5310 C# Programming Manual: JY5310.AIExternalSampleClock Class Reference

  • AIExternalSampleClock
Properties | List of all members
JY5310.AIExternalSampleClock Class Reference

External Sample Clock Configuration Class More...

Properties

ClockTerminal | Terminal [get, set]
External Sample Clock Input Terminal More...
double | ExpectedRate [get, set]
Expected External Sample Clock Rate More...

Detailed Description

External Sample Clock Configuration Class

Property Documentation

◆ ExpectedRate

double JY5310.AIExternalSampleClock.ExpectedRate
getset

Expected External Sample Clock Rate

◆ Terminal

ClockTerminal JY5310.AIExternalSampleClock.Terminal
getset

External Sample Clock Input Terminal

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5310/C#/JY5310AITask.cs


5310 C# Programming Manual: JY5310.AITrigger Class Reference

  • AITrigger
Properties | List of all members
JY5310.AITrigger Class Reference

AI Trigger class More...

Properties

AITriggerType | Type [get, set]
AI Trigger Type,enum Analog/Digital/Immediate/Soft. More...
AITriggerMode | Mode [get, set]
AI Trigger Mode. More...
AIDigitalTrigger | Digital [get, set]
Digital Trigger Congfiguration. More...
AIAnalogTrigger | Analog [get, set]
AI Analog Trigger. More...
int | ReTriggerCount [get, set]
Number of repeat triggers. More...
uint | PreTriggerSamples [get, set]
AI pretrigger samples, must be less than or equal to JY5310AITask.SamplesToAcquire. More...

Detailed Description

AI Trigger class

Property Documentation

◆ Analog

AIAnalogTrigger JY5310.AITrigger.Analog
getset

AI Analog Trigger.

Valid when Type is AITriggerType.Analog.

◆ Digital

AIDigitalTrigger JY5310.AITrigger.Digital
getset

Digital Trigger Congfiguration.

Valid when Type is AITriggerType.Digital.

◆ Mode

AITriggerMode JY5310.AITrigger.Mode
getset

AI Trigger Mode.

enum Start/Reference. The default value is AITriggerMode.Start.

◆ PreTriggerSamples

uint JY5310.AITrigger.PreTriggerSamples
getset

AI pretrigger samples, must be less than or equal to JY5310AITask.SamplesToAcquire.

Valid when Mode is AITriggerMode.Reference.

◆ ReTriggerCount

int JY5310.AITrigger.ReTriggerCount
getset

Number of repeat triggers.

When 0 or 1 only trigger once, When -1 continuous retrigger until stop.

◆ Type

AITriggerType JY5310.AITrigger.Type
getset

AI Trigger Type,enum Analog/Digital/Immediate/Soft.

The default value is AITriggerType.Immediate.

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5310/C#/JY5310AITask.cs


5310 C# Programming Manual: JY5310.AIDigitalTrigger Class Reference

  • AIDigitalTrigger
Properties | List of all members
JY5310.AIDigitalTrigger Class Reference

AI Digital Trigger More...

Properties

AIDigitalTriggerSource | Source [get, set]
AI Digital Trigger Source More...
AIDigitalTriggerEdge | Edge [get, set]
AI Digital Trigger Edge，Rising/Falling More...

Detailed Description

AI Digital Trigger

Property Documentation

◆ Edge

AIDigitalTriggerEdge JY5310.AIDigitalTrigger.Edge
getset

AI Digital Trigger Edge，Rising/Falling

◆ Source

AIDigitalTriggerSource JY5310.AIDigitalTrigger.Source
getset

AI Digital Trigger Source

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5310/C#/JY5310AITask.cs


5310 C# Programming Manual: JY5310.AIAnalogTrigger Class Reference

  • AIAnalogTrigger
Properties | List of all members
JY5310.AIAnalogTrigger Class Reference

AI Analog Trigger More...

Properties

AIAnalogTriggerSource | Source [get, set]
Analog Trigger source More...
AIAnalogTriggerComparator | Comparator [get, set]
AI Analog Trigger Comparator More...
AIAnalogEdgeComparator | Edge [get, set]
AI Analog Edge Comparator More...
AIAnalogHysteresisComparator | Hysteresis [get, set]
AI Analog Hysteresis Comparatorr More...
AIAnalogWindowComparator | Window [get, set]
AI Analog Window Comparatorr More...

Detailed Description

AI Analog Trigger

Property Documentation

◆ Comparator

AIAnalogTriggerComparator JY5310.AIAnalogTrigger.Comparator
getset

AI Analog Trigger Comparator

◆ Edge

AIAnalogEdgeComparator JY5310.AIAnalogTrigger.Edge
getset

AI Analog Edge Comparator

◆ Hysteresis

AIAnalogHysteresisComparator JY5310.AIAnalogTrigger.Hysteresis
getset

AI Analog Hysteresis Comparatorr

◆ Source

AIAnalogTriggerSource JY5310.AIAnalogTrigger.Source
getset

Analog Trigger source

◆ Window

AIAnalogWindowComparator JY5310.AIAnalogTrigger.Window
getset

AI Analog Window Comparatorr

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5310/C#/JY5310AITask.cs


5310 C# Programming Manual: JY5310.AIRecord Class Reference

  • AIRecord
Properties | List of all members
JY5310.AIRecord Class Reference

AI Record class More...

Properties

string | FilePath [get, set]
Path of streaming file,including filePath and filename More...
FileFormat | FileFormat [get]
Streaming file format More...
RecordMode | Mode [get, set]
Two stream mode from enum Finite/Infinite More...
double | Length [get, set]
User specified stream length in second. More...

Detailed Description

AI Record class

Property Documentation

◆ FileFormat

FileFormat JY5310.AIRecord.FileFormat
get

Streaming file format

◆ FilePath

string JY5310.AIRecord.FilePath
getset

Path of streaming file,including filePath and filename

◆ Length

double JY5310.AIRecord.Length
getset

User specified stream length in second.

Only valid in the Finite mode

◆ Mode

RecordMode JY5310.AIRecord.Mode
getset

Two stream mode from enum Finite/Infinite

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5310/C#/JY5310AITask.cs


5310 C# Programming Manual: JY5310.AISync Class Reference

  • AISync
Properties | List of all members
JY5310.AISync Class Reference

Configure sync signal More...

Properties

SyncTopology | Topology [get, set]
Configure sync signal More...
SyncTriggerRouting | TriggerRouting [get, set]
trigger signal Routing, default routing PXITrig0 More...
SyncPulseRouting | PulseRouting [get, set]
Sync Pulse signal Routing, default routing PXITrig1 More...

Detailed Description

Configure sync signal

Property Documentation

◆ PulseRouting

SyncPulseRouting JY5310.AISync.PulseRouting
getset

Sync Pulse signal Routing, default routing PXITrig1

◆ Topology

SyncTopology JY5310.AISync.Topology
getset

Configure sync signal

◆ TriggerRouting

SyncTriggerRouting JY5310.AISync.TriggerRouting
getset

trigger signal Routing, default routing PXITrig0

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5310/C#/JY5310AITask.cs


5310 C# Programming Manual: JY5310.AISignalExport Class Reference

  • AISignalExport
Public Member Functions | List of all members
JY5310.AISignalExport Class Reference

AI Signal Export Class More...

Public Member Functions

void | Add (AISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination More...
void | Add (AISignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination More...
void | Clear (SignalExportDestination destination)
Clear one Signal Export More...
void | ClearAll ()
Clear All Signal Export More...

Detailed Description

AI Signal Export Class

Member Function Documentation

◆ Add() [1/2]

void JY5310.AISignalExport.Add | ( | AISignalExportSource | source,
 |  | List< SignalExportDestination > | destinations
 | ) |  |

Export one Signal to Mutil Desination

Parameters
source | AI Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY5310.AISignalExport.Add | ( | AISignalExportSource | source,
 |  | SignalExportDestination | destination
 | ) |  |

Export one Signal to Desination

Parameters
source | AI Signal Source
destination | Export Desination

◆ Clear()

void JY5310.AISignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export

Parameters
destination Export Desination

◆ ClearAll()

void JY5310.AISignalExport.ClearAll ( )

Clear All Signal Export

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5310/C#/JY5310AITask.cs


5310 C# Programming Manual: C:/Users/wukeping/Desktop/5310/C#/JY5310DOTask.cs File Reference

  • 5310
  • C#
Classes | Namespaces | Enumerations
JY5310DOTask.cs File Reference

Classes

class | JY5310.JY5310DOTask
JY5310 DOTask More...
class | JY5310.DOChannel
DOChannel class More...
class | JY5310.DOTrigger
Constructor to create an DOTrigger task object. More...
class | JY5310.DODigitalTrigger
DO Digital trigger More...
class | JY5310.DOSampleClock
Sample clock configuration class More...
class | JY5310.DOExternalSampleClock
External Sample Clock Configuration Class More...
class | JY5310.DOSignalExport
DO Signal Export Class More...

Namespaces

namespace JY5310

Enumerations

enum class | JY5310.DOTriggerType { JY5310.Immediate = JY5310Import.JY5310_TriggerType_Immediately , JY5310.Digital = JY5310Import.JY5310_TriggerType_Digital , JY5310.Soft = JY5310Import.JY5310_TriggerType_Soft }
TriggerType Digital/Immediate/Soft More...
enum class JY5310.DODigitalTriggerSource {
JY5310.PFI0 = 0x10 , JY5310.PFI1 = 0x11 , JY5310.PFI2 = 0x12 , JY5310.PFI3 = 0x13 ,
JY5310.PFI4 = 0x14 , JY5310.PFI5 = 0x15 , JY5310.PFI6 = 0x16 , JY5310.PFI7 = 0x17 ,
JY5310.PFI8 = 0x18 , JY5310.PFI9 = 0x19 , JY5310.PFI10 = 0x1A , JY5310.PFI11 = 0x1B ,
JY5310.PFI12 = 0x1C , JY5310.PFI13 = 0x1D , JY5310.PFI14 = 0x1E , JY5310.PFI15 = 0x1F ,
JY5310.PXI_Trig0 = 64 , JY5310.PXI_Trig1 = 65 , JY5310.PXI_Trig2 = 66 , JY5310.PXI_Trig3 = 67 ,
JY5310.PXI_Trig4 = 68 , JY5310.PXI_Trig5 = 69 , JY5310.PXI_Trig6 = 70 , JY5310.PXI_Trig7 = 71 ,
JY5310.AT_StartTrig = JY5310Import.JY5310_AI_StartTrig , JY5310.AI_ReferencetTrig = JY5310Import.JY5310_AI_ReferenceTrig , JY5310.DI_StartTrig = JY5310Import.JY5310_DI_StartTrig , JY5310.DI_ReferencetTrig = JY5310Import.JY5310_DI_ReferenceTrig
}
DO Digital trigger source More...
enum class | JY5310.DODigitalTriggerEdge { JY5310.Rising , JY5310.Falling }
DO Digital Trigger Edge More...
enum class | JY5310.DOSampleClockSource { JY5310.Internal , JY5310.External }
DO Sample Clock Source More...
enum class | JY5310.DOSignalExportSource { JY5310.StartTrig = JY5310Import.JY5310_DO_StartTrig , JY5310.SampleClock = JY5310Import.JY5310_DO_SampleClock }
SourceSignal More...
enum class | JY5310.DOMode { JY5310.Single = 3 , JY5310.Finite = 0 , JY5310.ContinuousWrapping = 1 , JY5310.ContinuousNoWrapping = 2 }
DOMode More...


5310 C# Programming Manual: JY5310.JY5310DOTask Class Reference

  • JY5310DOTask
Public Member Functions | Properties | List of all members
JY5310.JY5310DOTask Class Reference

JY5310 DOTask More...

Public Member Functions

JY5310DOTask (int slotNum)
Constructor. More...
JY5310DOTask (string aliasName)
Constructor. More...
void | AddChannel (int portNum)
Add one port More...
void | AddChannel (int[] portsNum)
Add mulitiple port More...
void | RemoveChannel (int portNum)
delete the specified port number More...
void | Start ()
Start DOTask More...
void | Stop ()
Stop DOTask More...
void | WriteSinglePoint (bool[] writeValues, int port)
write the latest point of Specify port More...
void | WriteSinglePoint (bool[] writeValues)
write the latest point More...
void | SendSoftwareTrigger ()
Generate a software trigger. More...
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete. More...
void | WriteData (ushort[] dataBuffer, uint samplesToUpdate, int timeOut=10000)
Write the ushort data for one port or multi-ports. More...
void | WriteData (byte[] dataBuffer, uint samplesToUpdate, int timeOut=10000)
Wirte the byte data to one port. More...
void | WriteData (byte[,] dataBuffer, uint samplesToUpdate, int timeOut=10000)
write the port byte data to the ports. More...

Properties

JY5310Device | Device [get]
Device Handle More...
List< DOChannel > | Channels [get]
List of DO channels More...
double | UpdateRate [get, set]
Update rate per channel. More...
int | SamplesToUpdate [get, set]
Number of output samples to write per channel , Only valid when Mode is DOMode.Finite. More...
DOTrigger | Trigger [get, set]
DO Trigger Configuration. More...
DOSampleClock | SampleClock [get, set]
DO Sample Clock Configuration . More...
DOSignalExport | SignalExport [get, set]
Export DO Signal More...
DOMode | Mode [get, set]
DO acquisition mode.Select DO Mode from enum:ContinuousNoWrapping/ContinuousWrapping/Finite/Single More...
int | BufLenInSamples [get]
Number of samples per channel can be storage in the buffer, the PropretySamplesToUpdate must be less than or equal to this value. More...
uint | AvaliableLenInSamples [get]
Number of output samples per channel avaliable to write in DO buffuer. More...
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel). More...

Detailed Description

JY5310 DOTask

Constructor & Destructor Documentation

◆ JY5310DOTask() [1/2]

JY5310.JY5310DOTask.JY5310DOTask ( int slotNum )

Constructor.

Used to create an DOtask object

Parameters
slotNum slot Number

◆ JY5310DOTask() [2/2]

JY5310.JY5310DOTask.JY5310DOTask ( string aliasName )

Constructor.

Used to create an DOtask object

Parameters
aliasName AliasName

Member Function Documentation

◆ AddChannel() [1/2]

void JY5310.JY5310DOTask.AddChannel ( int portNum )

Add one port

Parameters
portNum port number

◆ AddChannel() [2/2]

void JY5310.JY5310DOTask.AddChannel ( int[] portsNum )

Add mulitiple port

Parameters
portsNum port number

◆ RemoveChannel()

void JY5310.JY5310DOTask.RemoveChannel ( int portNum )

delete the specified port number

Parameters
portNum port number

◆ SendSoftwareTrigger()

void JY5310.JY5310DOTask.SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5310.JY5310DOTask.Start ( )

Start DOTask

◆ Stop()

void JY5310.JY5310DOTask.Stop ( )

Stop DOTask

◆ WaitUntilDone()

bool JY5310.JY5310DOTask.WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Available when Mode is DOMode.Finite

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteData() [1/3]

void JY5310.JY5310DOTask.WriteData | ( | byte | dataBuffer[,],
 |  | uint | samplesToUpdate,
 |  | int | timeOut = 10000
 | ) |  |

write the port byte data to the ports.

Each column represents one port. Each port has 8 lines from 0 to 7. Each bit from low to high represents one line.

Parameters
dataBuffer | Data buffer
samplesToUpdate | Number of samples per port to be write
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [2/3]

void JY5310.JY5310DOTask.WriteData | ( | byte[] | dataBuffer,
 |  | uint | samplesToUpdate,
 |  | int | timeOut = 10000
 | ) |  |

Wirte the byte data to one port.

Each port has 2 lines from 0 to 1. Each bit from low to high represents one line.

Parameters
dataBuffer | Data buffer
samplesToUpdate | Number of samples per port to be write
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [3/3]

void JY5310.JY5310DOTask.WriteData | ( | ushort[] | dataBuffer,
 |  | uint | samplesToUpdate,
 |  | int | timeOut = 10000
 | ) |  |

Write the ushort data for one port or multi-ports.

There are 8 ports, from 0 to 7. Each port has 2 lines, from 0 to 1. There are a total of 16 lines from 0 to 15. Each bit from low to high represents one line.

Parameters
dataBuffer | Data buffer
samplesToUpdate | Number of samples per port to be write
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteSinglePoint() [1/2]

void JY5310.JY5310DOTask.WriteSinglePoint ( bool[] writeValues )

write the latest point

Parameters
writeValues User buffer array

◆ WriteSinglePoint() [2/2]

void JY5310.JY5310DOTask.WriteSinglePoint | ( | bool[] | writeValues,
 |  | int | port
 | ) |  |

write the latest point of Specify port

Parameters
writeValues | User buffer array
port | Specify the port to write

Property Documentation

◆ AvaliableLenInSamples

uint JY5310.JY5310DOTask.AvaliableLenInSamples
get

Number of output samples per channel avaliable to write in DO buffuer.

◆ BufLenInSamples

int JY5310.JY5310DOTask.BufLenInSamples
get

Number of samples per channel can be storage in the buffer, the PropretySamplesToUpdate must be less than or equal to this value.

◆ Channels

List<DOChannel> JY5310.JY5310DOTask.Channels
get

List of DO channels

◆ Device

JY5310Device JY5310.JY5310DOTask.Device
get

Device Handle

◆ Mode

DOMode JY5310.JY5310DOTask.Mode
getset

DO acquisition mode.Select DO Mode from enum:ContinuousNoWrapping/ContinuousWrapping/Finite/Single

◆ SampleClock

DOSampleClock JY5310.JY5310DOTask.SampleClock
getset

DO Sample Clock Configuration .

◆ SamplesToUpdate

int JY5310.JY5310DOTask.SamplesToUpdate
getset

Number of output samples to write per channel , Only valid when Mode is DOMode.Finite.

◆ SignalExport

DOSignalExport JY5310.JY5310DOTask.SignalExport
getset

Export DO Signal

◆ TransferedSamples

ulong JY5310.JY5310DOTask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT DOMode.Single.

◆ Trigger

DOTrigger JY5310.JY5310DOTask.Trigger
getset

DO Trigger Configuration.

◆ UpdateRate

double JY5310.JY5310DOTask.UpdateRate
getset

Update rate per channel.

Maximum update rate is 10M . The defalut sample rate = 10000 You can read this property to obtain the update rate that will actually take effect in the current configuration.

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5310/C#/JY5310DOTask.cs


5310 C# Programming Manual: JY5310.DOChannel Class Reference

  • DOChannel
Properties | List of all members
JY5310.DOChannel Class Reference

DOChannel class More...

Properties

int PortNum [get, set]
port Number More...

Detailed Description

DOChannel class

Property Documentation

◆ PortNum

int JY5310.DOChannel.PortNum
getset

port Number

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5310/C#/JY5310DOTask.cs


5310 C# Programming Manual: JY5310.DOTrigger Class Reference

  • DOTrigger
Properties | List of all members
JY5310.DOTrigger Class Reference

Constructor to create an DOTrigger task object. More...

Properties

DOTriggerType | Type [get, set]
DO trigger type. More...
DODigitalTrigger | Digital [get, set]
DO Digital Trigger.Valid when Type is DOTriggerType.Digital. More...

Detailed Description

Constructor to create an DOTrigger task object.

Used to build DO Trigger

Property Documentation

◆ Digital

DODigitalTrigger JY5310.DOTrigger.Digital
getset

DO Digital Trigger.Valid when Type is DOTriggerType.Digital.

◆ Type

DOTriggerType JY5310.DOTrigger.Type
getset

DO trigger type.

enum Digital/Immediate/Soft.

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5310/C#/JY5310DOTask.cs


5310 C# Programming Manual: JY5310.DODigitalTrigger Class Reference

  • DODigitalTrigger
Properties | List of all members
JY5310.DODigitalTrigger Class Reference

DO Digital trigger More...

Properties

DODigitalTriggerSource | Source [get, set]
DO Digital Trigger source. More...
DODigitalTriggerEdge | Edge [get, set]
Digital Trigger edge，Rising/Falling. More...

Detailed Description

DO Digital trigger

Property Documentation

◆ Edge

DODigitalTriggerEdge JY5310.DODigitalTrigger.Edge
getset

Digital Trigger edge，Rising/Falling.

◆ Source

DODigitalTriggerSource JY5310.DODigitalTrigger.Source
getset

DO Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5310/C#/JY5310DOTask.cs


5310 C# Programming Manual: JY5310.DOSampleClock Class Reference

  • DOSampleClock
Properties | List of all members
JY5310.DOSampleClock Class Reference

Sample clock configuration class More...

Properties

DOSampleClockSource | Source [get, set]
Clock Source. More...
DOExternalSampleClock | External [get, set]
External Sample Clock.Valid when Source is DOSampleClockSource.External. More...

Detailed Description

Sample clock configuration class

Property Documentation

◆ External

DOExternalSampleClock JY5310.DOSampleClock.External
getset

External Sample Clock.Valid when Source is DOSampleClockSource.External.

◆ Source

DOSampleClockSource JY5310.DOSampleClock.Source
getset

Clock Source.

enum Internal/External

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5310/C#/JY5310DOTask.cs


5310 C# Programming Manual: JY5310.DOExternalSampleClock Class Reference

  • DOExternalSampleClock
Properties | List of all members
JY5310.DOExternalSampleClock Class Reference

External Sample Clock Configuration Class More...

Properties

ClockTerminal | Terminal [get, set]
External Sample Clock Input Terminal More...
double | ExpectedRate [get, set]
Expected External Sample Clock Rate More...

Detailed Description

External Sample Clock Configuration Class

Property Documentation

◆ ExpectedRate

double JY5310.DOExternalSampleClock.ExpectedRate
getset

Expected External Sample Clock Rate

◆ Terminal

ClockTerminal JY5310.DOExternalSampleClock.Terminal
getset

External Sample Clock Input Terminal

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5310/C#/JY5310DOTask.cs


5310 C# Programming Manual: JY5310.DOSignalExport Class Reference

  • DOSignalExport
Public Member Functions | List of all members
JY5310.DOSignalExport Class Reference

DO Signal Export Class More...

Public Member Functions

void | Add (DOSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination More...
void | Add (DOSignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination More...
void | Clear (SignalExportDestination destination)
Clear one Signal Export More...
void | ClearAll ()
Clear All Signal Export More...

Detailed Description

DO Signal Export Class

Member Function Documentation

◆ Add() [1/2]

void JY5310.DOSignalExport.Add | ( | DOSignalExportSource | source,
 |  | List< SignalExportDestination > | destinations
 | ) |  |

Export one Signal to Mutil Desination

Parameters
source | DO Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY5310.DOSignalExport.Add | ( | DOSignalExportSource | source,
 |  | SignalExportDestination | destination
 | ) |  |

Export one Signal to Desination

Parameters
source | DO Signal Source
destination | Export Desination

◆ Clear()

void JY5310.DOSignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export

Parameters
destination Export Desination

◆ ClearAll()

void JY5310.DOSignalExport.ClearAll ( )

Clear All Signal Export

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5310/C#/JY5310DOTask.cs


5310 C# Programming Manual: C:/Users/wukeping/Desktop/5310/C#/JY5310DITask.cs File Reference

  • 5310
  • C#
Classes | Namespaces | Enumerations
JY5310DITask.cs File Reference

Classes

class | JY5310.JY5310DITask
JY5310DITask Class More...
class | JY5310.DIChannel
DI Channel parameter class More...
class | JY5310.DITrigger
Constructor to create an DITrigger task object. More...
class | JY5310.DIDigitalTrigger
DI Digital trigger . More...
class | JY5310.DISampleClock
Sample clock configuration class More...
class | JY5310.DIExternalSampleClock
External Sample Clock Configuration Class More...
class | JY5310.DISignalExport
DI Signal Export Class More...

Namespaces

namespace JY5310

Enumerations

enum class | JY5310.DITriggerMode { JY5310.Start , JY5310.Reference }
DI Trigger Mode More...
enum class | JY5310.DITriggerType { JY5310.Immediate = JY5310Import.JY5310_TriggerType_Immediately , JY5310.Digital = JY5310Import.JY5310_TriggerType_Digital , JY5310.Soft = JY5310Import.JY5310_TriggerType_Soft }
TriggerType Digital/Immediate/Soft More...
enum class JY5310.DIDigitalTriggerSource {
JY5310.PFI0 = 0x10 , JY5310.PFI1 = 0x11 , JY5310.PFI2 =0x12 , JY5310.PFI3 = 0x13 ,
JY5310.PFI4 = 0x14 , JY5310.PFI5 = 0x15 , JY5310.PFI6 = 0x16 , JY5310.PFI7 = 0x17 ,
JY5310.PFI8 = 0x18 , JY5310.PFI9 = 0x19 , JY5310.PFI10 = 0x1A , JY5310.PFI11 = 0x1B ,
JY5310.PFI12 = 0x1C , JY5310.PFI13 = 0x1D , JY5310.PFI14 = 0x1E , JY5310.PFI15 = 0x1F ,
JY5310.PXI_Trig0 = 64 , JY5310.PXI_Trig1 = 65 , JY5310.PXI_Trig2 = 66 , JY5310.PXI_Trig3 = 67 ,
JY5310.PXI_Trig4 = 68 , JY5310.PXI_Trig5 = 69 , JY5310.PXI_Trig6 = 70 , JY5310.PXI_Trig7 = 71 ,
JY5310.DO_StartTrig = JY5310Import.JY5310_DO_StartTrig , JY5310.AT_StartTrig = JY5310Import.JY5310_AI_StartTrig , JY5310.AI_ReferencetTrig = JY5310Import.JY5310_AI_ReferenceTrig
}
DI Digital trigger source. More...
enum class | JY5310.DIDigitalTriggerEdge { JY5310.Rising , JY5310.Falling }
DI Digital Trigger Edge More...
enum class | JY5310.DISampleClockSource { JY5310.Internal , JY5310.External }
DI Sample Clock Source More...
enum class | JY5310.DIMode { JY5310.Single = 2 , JY5310.Finite = 0 , JY5310.Continuous = 1 }
DIMode More...
enum class | JY5310.DISignalExportSource { JY5310.StartTrig = JY5310Import.JY5310_DI_StartTrig , JY5310.ReferenceTrig = JY5310Import.JY5310_DI_ReferenceTrig , JY5310.SampleClock = JY5310Import.JY5310_DI_SampleClock }
SourceSignal More...


5310 C# Programming Manual: JY5310.JY5310DITask Class Reference

  • JY5310DITask
Public Member Functions | Properties | List of all members
JY5310.JY5310DITask Class Reference

JY5310DITask Class More...

Public Member Functions

JY5310DITask (int slotNum)
Constructor. More...
JY5310DITask (string aliasName)
Constructor. More...
void | AddChannel (int portNum)
Add one port More...
void | AddChannel (int[] portsNum)
Add a group of port More...
void | RemoveChannel (int portNum)
Delete the specified port number More...
void | SendSoftwareTrigger ()
Generate a software trigger. More...
void | Start ()
Start DITask More...
void | Stop ()
Stop DITask More...
void | ReadSinglePoint (ref bool[] readValues, int port)
Specify the port reads the latest point More...
void | ReadSinglePoint (ref bool[] readValues)
Each port reads the latest point More...
void | ReadData (ref ushort[] dataBuffer, uint samplesToAcquire, int timeOut=10000)
Read the ushort data from one port or multi-ports. More...
void | ReadData (ref byte[] dataBuffer, uint samplesToAcquire, int timeOut=10000)
Read the byte data from one port. More...
void | ReadData (ref byte[,] dataBuffer, uint samplesToAcquire, int timeOut=10000)
Read the port byte data from the ports. More...

Properties

JY5310Device | Device [get]
Device Handle More...
List< DIChannel > | Channels [get]
List of DI channels More...
double | SampleRate [get, set]
Sample rate per channel. More...
int | SamplesToAcquire [get, set]
Number of samples to be read per channel. More...
DITrigger | Trigger [get, set]
DI Trigger Configuration More...
DISampleClock | SampleClock [get, set]
DI Sample Clock Configuration More...
int | BufLenInSamples [get]
Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value. More...
DIMode | Mode [get, set]
DI acquisition mode，support Single/ Finite/Continuous More...
ulong | AvailableSamples [get]
Number of samples per channel that can be read in the buffer More...
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel). More...
DISignalExport | SignalExport [get, set]
Export DI Signal More...

Detailed Description

JY5310DITask Class

Constructor & Destructor Documentation

◆ JY5310DITask() [1/2]

JY5310.JY5310DITask.JY5310DITask ( int slotNum )

Constructor.

Used to create an DItask object

Parameters
slotNum Card slot number

◆ JY5310DITask() [2/2]

JY5310.JY5310DITask.JY5310DITask ( string aliasName )

Constructor.

Used to create an DItask object

Parameters
aliasName AliasName

Member Function Documentation

◆ AddChannel() [1/2]

void JY5310.JY5310DITask.AddChannel ( int portNum )

Add one port

Parameters
portNum port number

◆ AddChannel() [2/2]

void JY5310.JY5310DITask.AddChannel ( int[] portsNum )

Add a group of port

Parameters
portsNum port number

◆ ReadData() [1/3]

void JY5310.JY5310DITask.ReadData | ( | ref byte | dataBuffer[,],
 |  | uint | samplesToAcquire,
 |  | int | timeOut = 10000
 | ) |  |

Read the port byte data from the ports.

Each column represents one port. Each port has 2 lines from 0 to 1. Each bit from low to high represents one line.

Parameters
dataBuffer | Data buffer
samplesToAcquire | Number of samples per port to be read
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadData() [2/3]

void JY5310.JY5310DITask.ReadData | ( | ref byte[] | dataBuffer,
 |  | uint | samplesToAcquire,
 |  | int | timeOut = 10000
 | ) |  |

Read the byte data from one port.

Each port has 2 lines from 0 to 1. Each bit from low to high represents one line.

Parameters
dataBuffer | Data buffer
samplesToAcquire | Number of samples per port to be read
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadData() [3/3]

void JY5310.JY5310DITask.ReadData | ( | ref ushort[] | dataBuffer,
 |  | uint | samplesToAcquire,
 |  | int | timeOut = 10000
 | ) |  |

Read the ushort data from one port or multi-ports.

There are 8 ports, from 0 to 7. Each port has 2 lines, from 0 to 1. There are a total of 16 lines from 0 to 15. Each bit from low to high represents one line.

Parameters
dataBuffer | Data buffer
samplesToAcquire | Number of samples per port to be read
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadSinglePoint() [1/2]

void JY5310.JY5310DITask.ReadSinglePoint ( ref bool[] readValues )

Each port reads the latest point

Parameters
readValues User buffer array

◆ ReadSinglePoint() [2/2]

void JY5310.JY5310DITask.ReadSinglePoint | ( | ref bool[] | readValues,
 |  | int | port
 | ) |  |

Specify the port reads the latest point

Parameters
readValues | User buffer array
port | Specify the port to read

◆ RemoveChannel()

void JY5310.JY5310DITask.RemoveChannel ( int portNum )

Delete the specified port number

Parameters
portNum port number

◆ SendSoftwareTrigger()

void JY5310.JY5310DITask.SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5310.JY5310DITask.Start ( )

Start DITask

◆ Stop()

void JY5310.JY5310DITask.Stop ( )

Stop DITask

Property Documentation

◆ AvailableSamples

ulong JY5310.JY5310DITask.AvailableSamples
get

Number of samples per channel that can be read in the buffer

◆ BufLenInSamples

int JY5310.JY5310DITask.BufLenInSamples
get

Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.

◆ Channels

List<DIChannel> JY5310.JY5310DITask.Channels
get

List of DI channels

◆ Device

JY5310Device JY5310.JY5310DITask.Device
get

Device Handle

◆ Mode

DIMode JY5310.JY5310DITask.Mode
getset

DI acquisition mode，support Single/ Finite/Continuous

◆ SampleClock

DISampleClock JY5310.JY5310DITask.SampleClock
getset

DI Sample Clock Configuration

◆ SampleRate

double JY5310.JY5310DITask.SampleRate
getset

Sample rate per channel.

Maximum sample rate is 10M The defalut sample rate = 10k You can read this property to obtain the sample rate that will actually take effect in the current configuration.

◆ SamplesToAcquire

int JY5310.JY5310DITask.SamplesToAcquire
getset

Number of samples to be read per channel.

Only valid when Mode is DIMode.Finite.

◆ SignalExport

DISignalExport JY5310.JY5310DITask.SignalExport
getset

Export DI Signal

◆ TransferedSamples

ulong JY5310.JY5310DITask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT DIMode.Single.

◆ Trigger

DITrigger JY5310.JY5310DITask.Trigger
getset

DI Trigger Configuration

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5310/C#/JY5310DITask.cs


5310 C# Programming Manual: JY5310.DIChannel Class Reference

  • DIChannel
Properties | List of all members
JY5310.DIChannel Class Reference

DI Channel parameter class More...

Properties

int PortNum [get, set]
Port Number More...

Detailed Description

DI Channel parameter class

Property Documentation

◆ PortNum

int JY5310.DIChannel.PortNum
getset

Port Number

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5310/C#/JY5310DITask.cs


5310 C# Programming Manual: JY5310.DITrigger Class Reference

  • DITrigger
Properties | List of all members
JY5310.DITrigger Class Reference

Constructor to create an DITrigger task object. More...

Properties

DITriggerType | Type [get, set]
DI trigger type. More...
DITriggerMode | Mode [get, set]
DI trigger mode. More...
DIDigitalTrigger | Digital [get, set]
DI Digital Trigger.Valid when Type is DITriggerType.Digital. More...
uint | PreTriggerSamples [get, set]
Pretrigger Samples, must be less than or equal to JY5310DITask.SamplesToAcquire. More...

Detailed Description

Constructor to create an DITrigger task object.

Used to build DI Trigger

Property Documentation

◆ Digital

DIDigitalTrigger JY5310.DITrigger.Digital
getset

DI Digital Trigger.Valid when Type is DITriggerType.Digital.

◆ Mode

DITriggerMode JY5310.DITrigger.Mode
getset

DI trigger mode.

enum Start/Reference.

◆ PreTriggerSamples

uint JY5310.DITrigger.PreTriggerSamples
getset

Pretrigger Samples, must be less than or equal to JY5310DITask.SamplesToAcquire.

Valid when Mode is DITriggerMode.Reference. Pretrigger samples, must be greater than 1. Valid when Type is DITriggerType.Digital.

◆ Type

DITriggerType JY5310.DITrigger.Type
getset

DI trigger type.

enum Digital/Immediate/Soft.

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5310/C#/JY5310DITask.cs


5310 C# Programming Manual: JY5310.DIDigitalTrigger Class Reference

  • DIDigitalTrigger
Properties | List of all members
JY5310.DIDigitalTrigger Class Reference

DI Digital trigger . More...

Properties

DIDigitalTriggerSource | Source [get, set]
DI Digital Trigger source. More...
DIDigitalTriggerEdge | Edge [get, set]
Digital Trigger edge，Rising/Falling. More...

Detailed Description

DI Digital trigger .

Property Documentation

◆ Edge

DIDigitalTriggerEdge JY5310.DIDigitalTrigger.Edge
getset

Digital Trigger edge，Rising/Falling.

◆ Source

DIDigitalTriggerSource JY5310.DIDigitalTrigger.Source
getset

DI Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5310/C#/JY5310DITask.cs


5310 C# Programming Manual: JY5310.DISampleClock Class Reference

  • DISampleClock
Properties | List of all members
JY5310.DISampleClock Class Reference

Sample clock configuration class More...

Properties

DISampleClockSource | Source [get, set]
Clock Source. More...
DIExternalSampleClock | External [get, set]
External Sample Clock, Valid when Source is DISampleClockSource.External. More...

Detailed Description

Sample clock configuration class

Property Documentation

◆ External

DIExternalSampleClock JY5310.DISampleClock.External
getset

External Sample Clock, Valid when Source is DISampleClockSource.External.

◆ Source

DISampleClockSource JY5310.DISampleClock.Source
getset

Clock Source.

enum Internal/External

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5310/C#/JY5310DITask.cs


5310 C# Programming Manual: JY5310.DIExternalSampleClock Class Reference

  • DIExternalSampleClock
Properties | List of all members
JY5310.DIExternalSampleClock Class Reference

External Sample Clock Configuration Class More...

Properties

ClockTerminal | Terminal [get, set]
External Sample Clock Input Terminal More...
double | ExpectedRate [get, set]
Expected External Sample Clock Rate More...

Detailed Description

External Sample Clock Configuration Class

Property Documentation

◆ ExpectedRate

double JY5310.DIExternalSampleClock.ExpectedRate
getset

Expected External Sample Clock Rate

◆ Terminal

ClockTerminal JY5310.DIExternalSampleClock.Terminal
getset

External Sample Clock Input Terminal

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5310/C#/JY5310DITask.cs


5310 C# Programming Manual: JY5310.DISignalExport Class Reference

  • DISignalExport
Public Member Functions | List of all members
JY5310.DISignalExport Class Reference

DI Signal Export Class More...

Public Member Functions

void | Add (DISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination More...
void | Add (DISignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination More...
void | Clear (SignalExportDestination destination)
Clear one Signal Export More...
void | ClearAll ()
Clear All Signal Export More...

Detailed Description

DI Signal Export Class

Member Function Documentation

◆ Add() [1/2]

void JY5310.DISignalExport.Add | ( | DISignalExportSource | source,
 |  | List< SignalExportDestination > | destinations
 | ) |  |

Export one Signal to Mutil Desination

Parameters
source | DI Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY5310.DISignalExport.Add | ( | DISignalExportSource | source,
 |  | SignalExportDestination | destination
 | ) |  |

Export one Signal to Desination

Parameters
source | DI Signal Source
destination | Export Desination

◆ Clear()

void JY5310.DISignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export

Parameters
destination Export Desination

◆ ClearAll()

void JY5310.DISignalExport.ClearAll ( )

Clear All Signal Export

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5310/C#/JY5310DITask.cs


5310 C# Programming Manual: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
▼N JY5310 |
C JY5310AITask | JY5310 Analog Input Task
C AIChannel | AI Channel parameter class
C AIAnalogHysteresisComparator | AI Analog Hysteresis Comparatorr
C AIAnalogWindowComparator | AI Analog Window Comparatorr
C AIAnalogEdgeComparator | AI Analog Edge Comparator
C AISampleClock | Sample clock configuration class
C AIExternalSampleClock | External Sample Clock Configuration Class
C AITrigger | AI Trigger class
C AIDigitalTrigger | AI Digital Trigger
C AIAnalogTrigger | AI Analog Trigger
C AIRecord | AI Record class
C AISync | Configure sync signal
C AISignalExport | AI Signal Export Class
C JY5310DITask | JY5310DITask Class
C DIChannel | DI Channel parameter class
C DITrigger | Constructor to create an DITrigger task object
C DIDigitalTrigger | DI Digital trigger
C DISampleClock | Sample clock configuration class
C DIExternalSampleClock | External Sample Clock Configuration Class
C DISignalExport | DI Signal Export Class
C JY5310DOTask | JY5310 DOTask
C DOChannel | DOChannel class
C DOTrigger | Constructor to create an DOTrigger task object
C DODigitalTrigger | DO Digital trigger
C DOSampleClock | Sample clock configuration class
C DOExternalSampleClock | External Sample Clock Configuration Class
C DOSignalExport | DO Signal Export Class


5310 C# Programming Manual: Member List

  • AIAnalogEdgeComparator
JY5310.AIAnalogEdgeComparator Member List

This is the complete list of members for JY5310.AIAnalogEdgeComparator, including all inherited members.

Slope | JY5310.AIAnalogEdgeComparator
Threshold | JY5310.AIAnalogEdgeComparator


5310 C# Programming Manual: Member List

  • AIAnalogHysteresisComparator
JY5310.AIAnalogHysteresisComparator Member List

This is the complete list of members for JY5310.AIAnalogHysteresisComparator, including all inherited members.

HighThreshold | JY5310.AIAnalogHysteresisComparator
LowThreshold | JY5310.AIAnalogHysteresisComparator
Slope | JY5310.AIAnalogHysteresisComparator


5310 C# Programming Manual: Member List

  • AIAnalogTrigger
JY5310.AIAnalogTrigger Member List

This is the complete list of members for JY5310.AIAnalogTrigger, including all inherited members.

Comparator | JY5310.AIAnalogTrigger
Edge | JY5310.AIAnalogTrigger
Hysteresis | JY5310.AIAnalogTrigger
Source | JY5310.AIAnalogTrigger
Window | JY5310.AIAnalogTrigger


5310 C# Programming Manual: Member List

  • AIAnalogWindowComparator
JY5310.AIAnalogWindowComparator Member List

This is the complete list of members for JY5310.AIAnalogWindowComparator, including all inherited members.

Condition | JY5310.AIAnalogWindowComparator
HighThreshold | JY5310.AIAnalogWindowComparator
LowThreshold | JY5310.AIAnalogWindowComparator


5310 C# Programming Manual: Member List

  • AIChannel
JY5310.AIChannel Member List

This is the complete list of members for JY5310.AIChannel, including all inherited members.

AIChannel(int channelId, double rangeLow, double rangeHigh) | JY5310.AIChannel
ChannelID | JY5310.AIChannel
RangeHigh | JY5310.AIChannel
RangeLow | JY5310.AIChannel


5310 C# Programming Manual: Member List

  • AIDigitalTrigger
JY5310.AIDigitalTrigger Member List

This is the complete list of members for JY5310.AIDigitalTrigger, including all inherited members.

Edge | JY5310.AIDigitalTrigger
Source | JY5310.AIDigitalTrigger


5310 C# Programming Manual: Member List

  • AIExternalSampleClock
JY5310.AIExternalSampleClock Member List

This is the complete list of members for JY5310.AIExternalSampleClock, including all inherited members.

ExpectedRate | JY5310.AIExternalSampleClock
Terminal | JY5310.AIExternalSampleClock


5310 C# Programming Manual: Member List

  • AIRecord
JY5310.AIRecord Member List

This is the complete list of members for JY5310.AIRecord, including all inherited members.

FileFormat | JY5310.AIRecord
FilePath | JY5310.AIRecord
Length | JY5310.AIRecord
Mode | JY5310.AIRecord


5310 C# Programming Manual: Member List

  • AISampleClock
JY5310.AISampleClock Member List

This is the complete list of members for JY5310.AISampleClock, including all inherited members.

External | JY5310.AISampleClock
Source | JY5310.AISampleClock


5310 C# Programming Manual: Member List

  • AISignalExport
JY5310.AISignalExport Member List

This is the complete list of members for JY5310.AISignalExport, including all inherited members.

Add(AISignalExportSource source, SignalExportDestination destination) | JY5310.AISignalExport
Add(AISignalExportSource source, List< SignalExportDestination > destinations) | JY5310.AISignalExport
Clear(SignalExportDestination destination) | JY5310.AISignalExport
ClearAll() | JY5310.AISignalExport


5310 C# Programming Manual: Member List

  • AISync
JY5310.AISync Member List

This is the complete list of members for JY5310.AISync, including all inherited members.

PulseRouting | JY5310.AISync
Topology | JY5310.AISync
TriggerRouting | JY5310.AISync


5310 C# Programming Manual: Member List

  • AITrigger
JY5310.AITrigger Member List

This is the complete list of members for JY5310.AITrigger, including all inherited members.

Analog | JY5310.AITrigger
Digital | JY5310.AITrigger
Mode | JY5310.AITrigger
PreTriggerSamples | JY5310.AITrigger
ReTriggerCount | JY5310.AITrigger
Type | JY5310.AITrigger


5310 C# Programming Manual: Member List

  • DIChannel
JY5310.DIChannel Member List

This is the complete list of members for JY5310.DIChannel, including all inherited members.

PortNum JY5310.DIChannel


5310 C# Programming Manual: Member List

  • DIDigitalTrigger
JY5310.DIDigitalTrigger Member List

This is the complete list of members for JY5310.DIDigitalTrigger, including all inherited members.

Edge | JY5310.DIDigitalTrigger
Source | JY5310.DIDigitalTrigger


5310 C# Programming Manual: Member List

  • DIExternalSampleClock
JY5310.DIExternalSampleClock Member List

This is the complete list of members for JY5310.DIExternalSampleClock, including all inherited members.

ExpectedRate | JY5310.DIExternalSampleClock
Terminal | JY5310.DIExternalSampleClock


5310 C# Programming Manual: Member List

  • DISampleClock
JY5310.DISampleClock Member List

This is the complete list of members for JY5310.DISampleClock, including all inherited members.

External | JY5310.DISampleClock
Source | JY5310.DISampleClock


5310 C# Programming Manual: Member List

  • DISignalExport
JY5310.DISignalExport Member List

This is the complete list of members for JY5310.DISignalExport, including all inherited members.

Add(DISignalExportSource source, SignalExportDestination destination) | JY5310.DISignalExport
Add(DISignalExportSource source, List< SignalExportDestination > destinations) | JY5310.DISignalExport
Clear(SignalExportDestination destination) | JY5310.DISignalExport
ClearAll() | JY5310.DISignalExport


5310 C# Programming Manual: Member List

  • DITrigger
JY5310.DITrigger Member List

This is the complete list of members for JY5310.DITrigger, including all inherited members.

Digital | JY5310.DITrigger
Mode | JY5310.DITrigger
PreTriggerSamples | JY5310.DITrigger
Type | JY5310.DITrigger


5310 C# Programming Manual: Member List

  • DOChannel
JY5310.DOChannel Member List

This is the complete list of members for JY5310.DOChannel, including all inherited members.

PortNum JY5310.DOChannel


5310 C# Programming Manual: Member List

  • DODigitalTrigger
JY5310.DODigitalTrigger Member List

This is the complete list of members for JY5310.DODigitalTrigger, including all inherited members.

Edge | JY5310.DODigitalTrigger
Source | JY5310.DODigitalTrigger


5310 C# Programming Manual: Member List

  • DOExternalSampleClock
JY5310.DOExternalSampleClock Member List

This is the complete list of members for JY5310.DOExternalSampleClock, including all inherited members.

ExpectedRate | JY5310.DOExternalSampleClock
Terminal | JY5310.DOExternalSampleClock


5310 C# Programming Manual: Member List

  • DOSampleClock
JY5310.DOSampleClock Member List

This is the complete list of members for JY5310.DOSampleClock, including all inherited members.

External | JY5310.DOSampleClock
Source | JY5310.DOSampleClock


5310 C# Programming Manual: Member List

  • DOSignalExport
JY5310.DOSignalExport Member List

This is the complete list of members for JY5310.DOSignalExport, including all inherited members.

Add(DOSignalExportSource source, SignalExportDestination destination) | JY5310.DOSignalExport
Add(DOSignalExportSource source, List< SignalExportDestination > destinations) | JY5310.DOSignalExport
Clear(SignalExportDestination destination) | JY5310.DOSignalExport
ClearAll() | JY5310.DOSignalExport


5310 C# Programming Manual: Member List

  • DOTrigger
JY5310.DOTrigger Member List

This is the complete list of members for JY5310.DOTrigger, including all inherited members.

Digital | JY5310.DOTrigger
Type | JY5310.DOTrigger


5310 C# Programming Manual: Member List

  • JY5310AITask
JY5310.JY5310AITask Member List

This is the complete list of members for JY5310.JY5310AITask, including all inherited members.

AddChannel(int chnId, double rangeLow=-10, double rangeHigh=10) | JY5310.JY5310AITask
AddChannel(int[] chnsId, double rangeLow=-10, double rangeHigh=10) | JY5310.JY5310AITask
AddChannel(int[] chnsId, double[] rangeLow, double[] rangeHigh) | JY5310.JY5310AITask
AvailableSamples | JY5310.JY5310AITask
BufLenInSamples | JY5310.JY5310AITask
Channels | JY5310.JY5310AITask
Device | JY5310.JY5310AITask
DisableCalibration | JY5310.JY5310AITask
GetCalibration() | JY5310.JY5310AITask
GetRecordPreviewData(ref double[,] buf, int samplesPerChannel, int timeout=1000) | JY5310.JY5310AITask
GetRecordPreviewData(ref double[,] buf, int timeout=1000) | JY5310.JY5310AITask
GetRecordPreviewData(ref double[] buf, int samplesPerChannel, int timeout=1000) | JY5310.JY5310AITask
GetRecordPreviewData(ref double[] buf, int timeout=1000) | JY5310.JY5310AITask
GetRecordStatus(out double recordedLength, out bool recordDone) | JY5310.JY5310AITask
JY5310AITask(int slotNum) | JY5310.JY5310AITask
JY5310AITask(string boardName) | JY5310.JY5310AITask
Mode | JY5310.JY5310AITask
ReadData(ref double[,] buf, int samplesPerChannel, int timeout=10000) | JY5310.JY5310AITask
ReadData(IntPtr buf, int samplesPerChannel, int timeout=10000) | JY5310.JY5310AITask
ReadData(ref double[,] buf, int timeout=10000) | JY5310.JY5310AITask
ReadData(ref double[] buf, int samplesPerChannel, int timeout=10000) | JY5310.JY5310AITask
ReadData(ref double[] buf, int timeout=10000) | JY5310.JY5310AITask
ReadRawData(ref short[,] buf, int samplesPerChannel, int timeout=10000) | JY5310.JY5310AITask
ReadRawData(ref short[,] buf, int timeout=10000) | JY5310.JY5310AITask
ReadRawData(IntPtr buf, int samplesPerChannel, int timeout=10000) | JY5310.JY5310AITask
ReadRawData(ref short[] buf, int samplesPerChannel, int timeout=10000) | JY5310.JY5310AITask
ReadRawData(ref short[] buf, int timeout=10000) | JY5310.JY5310AITask
Record | JY5310.JY5310AITask
RemoveChannel(int chnId) | JY5310.JY5310AITask
SampleClock | JY5310.JY5310AITask
SampleRate | JY5310.JY5310AITask
SamplesToAcquire | JY5310.JY5310AITask
SendSoftwareTrigger() | JY5310.JY5310AITask
SignalExport | JY5310.JY5310AITask
Start() | JY5310.JY5310AITask
Stop() | JY5310.JY5310AITask
Sync | JY5310.JY5310AITask
TransferedSamples | JY5310.JY5310AITask
Trigger | JY5310.JY5310AITask
WaitUntilDone(int timeout=-1) | JY5310.JY5310AITask


5310 C# Programming Manual: Member List

  • JY5310DITask
JY5310.JY5310DITask Member List

This is the complete list of members for JY5310.JY5310DITask, including all inherited members.

AddChannel(int portNum) | JY5310.JY5310DITask
AddChannel(int[] portsNum) | JY5310.JY5310DITask
AvailableSamples | JY5310.JY5310DITask
BufLenInSamples | JY5310.JY5310DITask
Channels | JY5310.JY5310DITask
Device | JY5310.JY5310DITask
JY5310DITask(int slotNum) | JY5310.JY5310DITask
JY5310DITask(string aliasName) | JY5310.JY5310DITask
Mode | JY5310.JY5310DITask
ReadData(ref ushort[] dataBuffer, uint samplesToAcquire, int timeOut=10000) | JY5310.JY5310DITask
ReadData(ref byte[] dataBuffer, uint samplesToAcquire, int timeOut=10000) | JY5310.JY5310DITask
ReadData(ref byte[,] dataBuffer, uint samplesToAcquire, int timeOut=10000) | JY5310.JY5310DITask
ReadSinglePoint(ref bool[] readValues, int port) | JY5310.JY5310DITask
ReadSinglePoint(ref bool[] readValues) | JY5310.JY5310DITask
RemoveChannel(int portNum) | JY5310.JY5310DITask
SampleClock | JY5310.JY5310DITask
SampleRate | JY5310.JY5310DITask
SamplesToAcquire | JY5310.JY5310DITask
SendSoftwareTrigger() | JY5310.JY5310DITask
SignalExport | JY5310.JY5310DITask
Start() | JY5310.JY5310DITask
Stop() | JY5310.JY5310DITask
TransferedSamples | JY5310.JY5310DITask
Trigger | JY5310.JY5310DITask


5310 C# Programming Manual: Member List

  • JY5310DOTask
JY5310.JY5310DOTask Member List

This is the complete list of members for JY5310.JY5310DOTask, including all inherited members.

AddChannel(int portNum) | JY5310.JY5310DOTask
AddChannel(int[] portsNum) | JY5310.JY5310DOTask
AvaliableLenInSamples | JY5310.JY5310DOTask
BufLenInSamples | JY5310.JY5310DOTask
Channels | JY5310.JY5310DOTask
Device | JY5310.JY5310DOTask
JY5310DOTask(int slotNum) | JY5310.JY5310DOTask
JY5310DOTask(string aliasName) | JY5310.JY5310DOTask
Mode | JY5310.JY5310DOTask
RemoveChannel(int portNum) | JY5310.JY5310DOTask
SampleClock | JY5310.JY5310DOTask
SamplesToUpdate | JY5310.JY5310DOTask
SendSoftwareTrigger() | JY5310.JY5310DOTask
SignalExport | JY5310.JY5310DOTask
Start() | JY5310.JY5310DOTask
Stop() | JY5310.JY5310DOTask
TransferedSamples | JY5310.JY5310DOTask
Trigger | JY5310.JY5310DOTask
UpdateRate | JY5310.JY5310DOTask
WaitUntilDone(int timeout=-1) | JY5310.JY5310DOTask
WriteData(ushort[] dataBuffer, uint samplesToUpdate, int timeOut=10000) | JY5310.JY5310DOTask
WriteData(byte[] dataBuffer, uint samplesToUpdate, int timeOut=10000) | JY5310.JY5310DOTask
WriteData(byte[,] dataBuffer, uint samplesToUpdate, int timeOut=10000) | JY5310.JY5310DOTask
WriteSinglePoint(bool[] writeValues, int port) | JY5310.JY5310DOTask
WriteSinglePoint(bool[] writeValues) | JY5310.JY5310DOTask


5310 C# Programming Manual: Class Index

Class Index
A | D | J
A
AIAnalogEdgeComparator (JY5310)
AIAnalogHysteresisComparator (JY5310)
AIAnalogTrigger (JY5310)
AIAnalogWindowComparator (JY5310)
AIChannel (JY5310)
AIDigitalTrigger (JY5310)
AIExternalSampleClock (JY5310)
AIRecord (JY5310)
AISampleClock (JY5310)
AISignalExport (JY5310)
AISync (JY5310)
AITrigger (JY5310)
D
DIChannel (JY5310)
DIDigitalTrigger (JY5310)
DIExternalSampleClock (JY5310)
DISampleClock (JY5310)
DISignalExport (JY5310)
DITrigger (JY5310)
DOChannel (JY5310)
DODigitalTrigger (JY5310)
DOExternalSampleClock (JY5310)
DOSampleClock (JY5310)
DOSignalExport (JY5310)
DOTrigger (JY5310)
J
JY5310AITask (JY5310)
JY5310DITask (JY5310)
JY5310DOTask (JY5310)


5310 C# Programming Manual: C:/Users/wukeping/Desktop/5310/C# Directory Reference

  • 5310
  • C#
C# Directory Reference

Files

file | JY5310AITask.cs
file | JY5310DITask.cs
file | JY5310DOTask.cs


5310 C# Programming Manual: File List

File List
Here is a list of all files with brief descriptions:
[detail level 123]
▼ 5310
▼ C#
JY5310AITask.cs
JY5310DITask.cs
JY5310DOTask.cs


5310 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- a -

  • Add() : JY5310.AISignalExport , JY5310.DISignalExport , JY5310.DOSignalExport
  • AddChannel() : JY5310.JY5310AITask , JY5310.JY5310DITask , JY5310.JY5310DOTask
  • AIChannel() : JY5310.AIChannel
  • Analog : JY5310.AITrigger
  • AvailableSamples : JY5310.JY5310AITask , JY5310.JY5310DITask
  • AvaliableLenInSamples : JY5310.JY5310DOTask

- b -

  • BufLenInSamples : JY5310.JY5310AITask , JY5310.JY5310DITask , JY5310.JY5310DOTask

- c -

  • ChannelID : JY5310.AIChannel
  • Channels : JY5310.JY5310AITask , JY5310.JY5310DITask , JY5310.JY5310DOTask
  • Clear() : JY5310.AISignalExport , JY5310.DISignalExport , JY5310.DOSignalExport
  • ClearAll() : JY5310.AISignalExport , JY5310.DISignalExport , JY5310.DOSignalExport
  • Comparator : JY5310.AIAnalogTrigger
  • Condition : JY5310.AIAnalogWindowComparator

- d -

  • Device : JY5310.JY5310AITask , JY5310.JY5310DITask , JY5310.JY5310DOTask
  • Digital : JY5310.AITrigger , JY5310.DITrigger , JY5310.DOTrigger
  • DisableCalibration : JY5310.JY5310AITask

- e -

  • Edge : JY5310.AIAnalogTrigger , JY5310.AIDigitalTrigger , JY5310.DIDigitalTrigger , JY5310.DODigitalTrigger
  • ExpectedRate : JY5310.AIExternalSampleClock , JY5310.DIExternalSampleClock , JY5310.DOExternalSampleClock
  • External : JY5310.AISampleClock , JY5310.DISampleClock , JY5310.DOSampleClock

- f -

  • FileFormat : JY5310.AIRecord
  • FilePath : JY5310.AIRecord

- g -

  • GetCalibration() : JY5310.JY5310AITask
  • GetRecordPreviewData() : JY5310.JY5310AITask
  • GetRecordStatus() : JY5310.JY5310AITask

- h -

  • HighThreshold : JY5310.AIAnalogHysteresisComparator , JY5310.AIAnalogWindowComparator
  • Hysteresis : JY5310.AIAnalogTrigger

- j -

  • JY5310AITask() : JY5310.JY5310AITask
  • JY5310DITask() : JY5310.JY5310DITask
  • JY5310DOTask() : JY5310.JY5310DOTask

- l -

  • Length : JY5310.AIRecord
  • LowThreshold : JY5310.AIAnalogHysteresisComparator , JY5310.AIAnalogWindowComparator

- m -

  • Mode : JY5310.AIRecord , JY5310.AITrigger , JY5310.DITrigger , JY5310.JY5310AITask , JY5310.JY5310DITask , JY5310.JY5310DOTask

- p -

  • PortNum : JY5310.DIChannel , JY5310.DOChannel
  • PreTriggerSamples : JY5310.AITrigger , JY5310.DITrigger
  • PulseRouting : JY5310.AISync

- r -

  • RangeHigh : JY5310.AIChannel
  • RangeLow : JY5310.AIChannel
  • ReadData() : JY5310.JY5310AITask , JY5310.JY5310DITask
  • ReadRawData() : JY5310.JY5310AITask
  • ReadSinglePoint() : JY5310.JY5310DITask
  • Record : JY5310.JY5310AITask
  • RemoveChannel() : JY5310.JY5310AITask , JY5310.JY5310DITask , JY5310.JY5310DOTask
  • ReTriggerCount : JY5310.AITrigger

- s -

  • SampleClock : JY5310.JY5310AITask , JY5310.JY5310DITask , JY5310.JY5310DOTask
  • SampleRate : JY5310.JY5310AITask , JY5310.JY5310DITask
  • SamplesToAcquire : JY5310.JY5310AITask , JY5310.JY5310DITask
  • SamplesToUpdate : JY5310.JY5310DOTask
  • SendSoftwareTrigger() : JY5310.JY5310AITask , JY5310.JY5310DITask , JY5310.JY5310DOTask
  • SignalExport : JY5310.JY5310AITask , JY5310.JY5310DITask , JY5310.JY5310DOTask
  • Slope : JY5310.AIAnalogEdgeComparator , JY5310.AIAnalogHysteresisComparator
  • Source : JY5310.AIAnalogTrigger , JY5310.AIDigitalTrigger , JY5310.AISampleClock , JY5310.DIDigitalTrigger , JY5310.DISampleClock , JY5310.DODigitalTrigger , JY5310.DOSampleClock
  • Start() : JY5310.JY5310AITask , JY5310.JY5310DITask , JY5310.JY5310DOTask
  • Stop() : JY5310.JY5310AITask , JY5310.JY5310DITask , JY5310.JY5310DOTask
  • Sync : JY5310.JY5310AITask

- t -

  • Terminal : JY5310.AIExternalSampleClock , JY5310.DIExternalSampleClock , JY5310.DOExternalSampleClock
  • Threshold : JY5310.AIAnalogEdgeComparator
  • Topology : JY5310.AISync
  • TransferedSamples : JY5310.JY5310AITask , JY5310.JY5310DITask , JY5310.JY5310DOTask
  • Trigger : JY5310.JY5310AITask , JY5310.JY5310DITask , JY5310.JY5310DOTask
  • TriggerRouting : JY5310.AISync
  • Type : JY5310.AITrigger , JY5310.DITrigger , JY5310.DOTrigger

- u -

  • UpdateRate : JY5310.JY5310DOTask

- w -

  • WaitUntilDone() : JY5310.JY5310AITask , JY5310.JY5310DOTask
  • Window : JY5310.AIAnalogTrigger
  • WriteData() : JY5310.JY5310DOTask
  • WriteSinglePoint() : JY5310.JY5310DOTask


5310 C# Programming Manual: Class Members - Functions

- a -

  • Add() : JY5310.AISignalExport , JY5310.DISignalExport , JY5310.DOSignalExport
  • AddChannel() : JY5310.JY5310AITask , JY5310.JY5310DITask , JY5310.JY5310DOTask
  • AIChannel() : JY5310.AIChannel

- c -

  • Clear() : JY5310.AISignalExport , JY5310.DISignalExport , JY5310.DOSignalExport
  • ClearAll() : JY5310.AISignalExport , JY5310.DISignalExport , JY5310.DOSignalExport

- g -

  • GetCalibration() : JY5310.JY5310AITask
  • GetRecordPreviewData() : JY5310.JY5310AITask
  • GetRecordStatus() : JY5310.JY5310AITask

- j -

  • JY5310AITask() : JY5310.JY5310AITask
  • JY5310DITask() : JY5310.JY5310DITask
  • JY5310DOTask() : JY5310.JY5310DOTask

- r -

  • ReadData() : JY5310.JY5310AITask , JY5310.JY5310DITask
  • ReadRawData() : JY5310.JY5310AITask
  • ReadSinglePoint() : JY5310.JY5310DITask
  • RemoveChannel() : JY5310.JY5310AITask , JY5310.JY5310DITask , JY5310.JY5310DOTask

- s -

  • SendSoftwareTrigger() : JY5310.JY5310AITask , JY5310.JY5310DITask , JY5310.JY5310DOTask
  • Start() : JY5310.JY5310AITask , JY5310.JY5310DITask , JY5310.JY5310DOTask
  • Stop() : JY5310.JY5310AITask , JY5310.JY5310DITask , JY5310.JY5310DOTask

- w -

  • WaitUntilDone() : JY5310.JY5310AITask , JY5310.JY5310DOTask
  • WriteData() : JY5310.JY5310DOTask
  • WriteSinglePoint() : JY5310.JY5310DOTask


5310 C# Programming Manual: Class Members - Properties

- a -

  • Analog : JY5310.AITrigger
  • AvailableSamples : JY5310.JY5310AITask , JY5310.JY5310DITask
  • AvaliableLenInSamples : JY5310.JY5310DOTask

- b -

  • BufLenInSamples : JY5310.JY5310AITask , JY5310.JY5310DITask , JY5310.JY5310DOTask

- c -

  • ChannelID : JY5310.AIChannel
  • Channels : JY5310.JY5310AITask , JY5310.JY5310DITask , JY5310.JY5310DOTask
  • Comparator : JY5310.AIAnalogTrigger
  • Condition : JY5310.AIAnalogWindowComparator

- d -

  • Device : JY5310.JY5310AITask , JY5310.JY5310DITask , JY5310.JY5310DOTask
  • Digital : JY5310.AITrigger , JY5310.DITrigger , JY5310.DOTrigger
  • DisableCalibration : JY5310.JY5310AITask

- e -

  • Edge : JY5310.AIAnalogTrigger , JY5310.AIDigitalTrigger , JY5310.DIDigitalTrigger , JY5310.DODigitalTrigger
  • ExpectedRate : JY5310.AIExternalSampleClock , JY5310.DIExternalSampleClock , JY5310.DOExternalSampleClock
  • External : JY5310.AISampleClock , JY5310.DISampleClock , JY5310.DOSampleClock

- f -

  • FileFormat : JY5310.AIRecord
  • FilePath : JY5310.AIRecord

- h -

  • Hysteresis : JY5310.AIAnalogTrigger

- l -

  • Length : JY5310.AIRecord

- m -

  • Mode : JY5310.AIRecord , JY5310.AITrigger , JY5310.DITrigger , JY5310.JY5310AITask , JY5310.JY5310DITask , JY5310.JY5310DOTask

- p -

  • PortNum : JY5310.DIChannel , JY5310.DOChannel
  • PreTriggerSamples : JY5310.AITrigger , JY5310.DITrigger
  • PulseRouting : JY5310.AISync

- r -

  • RangeHigh : JY5310.AIChannel
  • RangeLow : JY5310.AIChannel
  • Record : JY5310.JY5310AITask
  • ReTriggerCount : JY5310.AITrigger

- s -

  • SampleClock : JY5310.JY5310AITask , JY5310.JY5310DITask , JY5310.JY5310DOTask
  • SampleRate : JY5310.JY5310AITask , JY5310.JY5310DITask
  • SamplesToAcquire : JY5310.JY5310AITask , JY5310.JY5310DITask
  • SamplesToUpdate : JY5310.JY5310DOTask
  • SignalExport : JY5310.JY5310AITask , JY5310.JY5310DITask , JY5310.JY5310DOTask
  • Slope : JY5310.AIAnalogEdgeComparator , JY5310.AIAnalogHysteresisComparator
  • Source : JY5310.AIAnalogTrigger , JY5310.AIDigitalTrigger , JY5310.AISampleClock , JY5310.DIDigitalTrigger , JY5310.DISampleClock , JY5310.DODigitalTrigger , JY5310.DOSampleClock
  • Sync : JY5310.JY5310AITask

- t -

  • Terminal : JY5310.AIExternalSampleClock , JY5310.DIExternalSampleClock , JY5310.DOExternalSampleClock
  • Topology : JY5310.AISync
  • TransferedSamples : JY5310.JY5310AITask , JY5310.JY5310DITask , JY5310.JY5310DOTask
  • Trigger : JY5310.JY5310AITask , JY5310.JY5310DITask , JY5310.JY5310DOTask
  • TriggerRouting : JY5310.AISync
  • Type : JY5310.AITrigger , JY5310.DITrigger , JY5310.DOTrigger

- u -

  • UpdateRate : JY5310.JY5310DOTask

- w -

  • Window : JY5310.AIAnalogTrigger


5310 C# Programming Manual: Class Members - Variables

  • HighThreshold : JY5310.AIAnalogHysteresisComparator , JY5310.AIAnalogWindowComparator
  • LowThreshold : JY5310.AIAnalogHysteresisComparator , JY5310.AIAnalogWindowComparator
  • Threshold : JY5310.AIAnalogEdgeComparator


5310 C# Programming Manual: Main Page

5310 C# Programming Manual Documentation


5310 C# Programming Manual: JY5310 Namespace Reference

Classes | Enumerations
JY5310 Namespace Reference

Classes

class | JY5310AITask
JY5310 Analog Input Task. More...
class | AIChannel
AI Channel parameter class More...
class | AIAnalogHysteresisComparator
AI Analog Hysteresis Comparatorr More...
class | AIAnalogWindowComparator
AI Analog Window Comparatorr More...
class | AIAnalogEdgeComparator
AI Analog Edge Comparator More...
class | AISampleClock
Sample clock configuration class More...
class | AIExternalSampleClock
External Sample Clock Configuration Class More...
class | AITrigger
AI Trigger class More...
class | AIDigitalTrigger
AI Digital Trigger More...
class | AIAnalogTrigger
AI Analog Trigger More...
class | AIRecord
AI Record class More...
class | AISync
Configure sync signal More...
class | AISignalExport
AI Signal Export Class More...
class | JY5310DITask
JY5310DITask Class More...
class | DIChannel
DI Channel parameter class More...
class | DITrigger
Constructor to create an DITrigger task object. More...
class | DIDigitalTrigger
DI Digital trigger . More...
class | DISampleClock
Sample clock configuration class More...
class | DIExternalSampleClock
External Sample Clock Configuration Class More...
class | DISignalExport
DI Signal Export Class More...
class | JY5310DOTask
JY5310 DOTask More...
class | DOChannel
DOChannel class More...
class | DOTrigger
Constructor to create an DOTrigger task object. More...
class | DODigitalTrigger
DO Digital trigger More...
class | DOSampleClock
Sample clock configuration class More...
class | DOExternalSampleClock
External Sample Clock Configuration Class More...
class | DOSignalExport
DO Signal Export Class More...

Enumerations

enum class | AITriggerType { Immediate = JY5310Import.JY5310_TriggerType_Immediately , Digital = JY5310Import.JY5310_TriggerType_Digital , Analog = JY5310Import.JY5310_TriggerType_Analog , Soft = JY5310Import.JY5310_TriggerType_Soft }
Trigger Type: Digital/Analog/Immediate More...
enum class | AIDigitalTriggerEdge { Rising = JY5310Import.JY5310_DigitalTriggerEdge_Rising , Falling = JY5310Import.JY5310_DigitalTriggerEdge_Falling }
AI Digital Trigger Edge More...
enum class | AIAnalogTriggerEdge { Rising , Falling }
AI Analog Trigger Edge More...
enum class | AIAnalogWindowCondition { Entering , Leaving }
AI Analog Window Trigger Condition More...
enum class | AIAnalogTriggerComparator { Edge , Hysteresis , Window }
AI Analog Trigger Comparator More...
enum class | AIMode { Finite = JY5310Import.JY5310_AI_Finite , Continuous = JY5310Import.JY5310_AI_Continuous , Record = 0x3 }
AIMode More...
enum class | AISampleClockSource { Internal = JY5310Import.JY5310_AI_InternalClock , External = JY5310Import.JY5310_AI_ExternalClock }
AIClockSource Type More...
enum class ClockTerminal {
PFI0 = JY5310Import.JY5310_DigitalTriggerSource_PFI_0 , PFI1 = JY5310Import.JY5310_DigitalTriggerSource_PFI_1 , PFI2 = JY5310Import.JY5310_DigitalTriggerSource_PFI_2 , PFI3 = JY5310Import.JY5310_DigitalTriggerSource_PFI_3 ,
PFI4 = JY5310Import.JY5310_DigitalTriggerSource_PFI_4 , PFI5 = JY5310Import.JY5310_DigitalTriggerSource_PFI_5 , PFI6 = JY5310Import.JY5310_DigitalTriggerSource_PFI_6 , PFI7 = JY5310Import.JY5310_DigitalTriggerSource_PFI_7 ,
PFI8 = JY5310Import.JY5310_DigitalTriggerSource_PFI_8 , PFI9 = JY5310Import.JY5310_DigitalTriggerSource_PFI_9 , PFI10 = JY5310Import.JY5310_DigitalTriggerSource_PFI_10 , PFI11 = JY5310Import.JY5310_DigitalTriggerSource_PFI_11 ,
PFI12 = JY5310Import.JY5310_DigitalTriggerSource_PFI_12 , PFI13 = JY5310Import.JY5310_DigitalTriggerSource_PFI_13 , PFI14 = JY5310Import.JY5310_DigitalTriggerSource_PFI_14 , PFI15 = JY5310Import.JY5310_DigitalTriggerSource_PFI_15 ,
PXI_Trig0 = JY5310Import.JY5310_DigitalTriggerSource_PXI_0 , PXI_Trig1 = JY5310Import.JY5310_DigitalTriggerSource_PXI_1 , PXI_Trig2 = JY5310Import.JY5310_DigitalTriggerSource_PXI_2 , PXI_Trig3 = JY5310Import.JY5310_DigitalTriggerSource_PXI_3 ,
PXI_Trig4 = JY5310Import.JY5310_DigitalTriggerSource_PXI_4 , PXI_Trig5 = JY5310Import.JY5310_DigitalTriggerSource_PXI_5 , PXI_Trig6 = JY5310Import.JY5310_DigitalTriggerSource_PXI_6 , PXI_Trig7 = JY5310Import.JY5310_DigitalTriggerSource_PXI_7 ,
AI_SampleClock = JY5310Import.JY5310_AI_SampleClock , DI_SampleClock = JY5310Import.JY5310_DI_SampleClock , DO_SampleClock = JY5310Import.JY5310_DO_SampleClock
}
External Sample Clock Terminal More...
enum class | AITriggerMode { Start , Reference }
AI Trigger Mode More...
enum class AIAnalogTriggerSource {
Channel_0 , Channel_1 , Channel_2 , Channel_3 ,
Channel_4 , Channel_5 , Channel_6 , Channel_7 ,
Channel_8 , Channel_9 , Channel_10 , Channel_11 ,
Channel_12 , Channel_13 , Channel_14 , Channel_15
}
AI Analog Trigger Source More...
enum class AIDigitalTriggerSource {
PFI0 = JY5310Import.JY5310_DigitalTriggerSource_PFI_0 , PFI1 = JY5310Import.JY5310_DigitalTriggerSource_PFI_1 , PFI2 = JY5310Import.JY5310_DigitalTriggerSource_PFI_2 , PFI3 = JY5310Import.JY5310_DigitalTriggerSource_PFI_3 ,
PFI4 = JY5310Import.JY5310_DigitalTriggerSource_PFI_4 , PFI5 = JY5310Import.JY5310_DigitalTriggerSource_PFI_5 , PFI6 = JY5310Import.JY5310_DigitalTriggerSource_PFI_6 , PFI7 = JY5310Import.JY5310_DigitalTriggerSource_PFI_7 ,
PFI8 = JY5310Import.JY5310_DigitalTriggerSource_PFI_8 , PFI9 = JY5310Import.JY5310_DigitalTriggerSource_PFI_9 , PFI10 = JY5310Import.JY5310_DigitalTriggerSource_PFI_10 , PFI11 = JY5310Import.JY5310_DigitalTriggerSource_PFI_11 ,
PFI12 = JY5310Import.JY5310_DigitalTriggerSource_PFI_12 , PFI13 = JY5310Import.JY5310_DigitalTriggerSource_PFI_13 , PFI14 = JY5310Import.JY5310_DigitalTriggerSource_PFI_14 , PFI15 = JY5310Import.JY5310_DigitalTriggerSource_PFI_15 ,
PXI_Trig0 = JY5310Import.JY5310_DigitalTriggerSource_PXI_0 , PXI_Trig1 = JY5310Import.JY5310_DigitalTriggerSource_PXI_1 , PXI_Trig2 = JY5310Import.JY5310_DigitalTriggerSource_PXI_2 , PXI_Trig3 = JY5310Import.JY5310_DigitalTriggerSource_PXI_3 ,
PXI_Trig4 = JY5310Import.JY5310_DigitalTriggerSource_PXI_4 , PXI_Trig5 = JY5310Import.JY5310_DigitalTriggerSource_PXI_5 , PXI_Trig6 = JY5310Import.JY5310_DigitalTriggerSource_PXI_6 , PXI_Trig7 = JY5310Import.JY5310_DigitalTriggerSource_PXI_7 ,
DO_StartTrig = JY5310Import.JY5310_DO_StartTrig , DI_StartTrig = JY5310Import.JY5310_DI_StartTrig , DI_ReferencetTrig = JY5310Import.JY5310_DI_ReferenceTrig
}
AI Digital Trigger Source More...
enum class | FileFormat { Bin }
Streaming file format More...
enum class | RecordMode { Finite , Infinite }
Two stream mode from enum Finite/Infinite More...
enum class | SyncTopology { Independent , Master , Slave }
Synchronization board configuration More...
enum class SyncTriggerRouting {
NONE = -1 , PXI_Trig0 = JY5310Import.JY5310_DigitalTriggerSource_PXI_0 , PXI_Trig1 = JY5310Import.JY5310_DigitalTriggerSource_PXI_1 , PXI_Trig2 = JY5310Import.JY5310_DigitalTriggerSource_PXI_2 ,
PXI_Trig3 = JY5310Import.JY5310_DigitalTriggerSource_PXI_3 , PXI_Trig4 = JY5310Import.JY5310_DigitalTriggerSource_PXI_4 , PXI_Trig5 = JY5310Import.JY5310_DigitalTriggerSource_PXI_5 , PXI_Trig6 = JY5310Import.JY5310_DigitalTriggerSource_PXI_6 ,
PXI_Trig7 = JY5310Import.JY5310_DigitalTriggerSource_PXI_7
}
Master card trigger signal routing (Master card routes trigger signal to this port) More...
enum class SyncPulseRouting {
NONE = -1 , PXI_Trig0 = JY5310Import.JY5310_DigitalTriggerSource_PXI_0 , PXI_Trig1 = JY5310Import.JY5310_DigitalTriggerSource_PXI_1 , PXI_Trig2 = JY5310Import.JY5310_DigitalTriggerSource_PXI_2 ,
PXI_Trig3 = JY5310Import.JY5310_DigitalTriggerSource_PXI_3 , PXI_Trig4 = JY5310Import.JY5310_DigitalTriggerSource_PXI_4 , PXI_Trig5 = JY5310Import.JY5310_DigitalTriggerSource_PXI_5 , PXI_Trig6 = JY5310Import.JY5310_DigitalTriggerSource_PXI_6 ,
PXI_Trig7 = JY5310Import.JY5310_DigitalTriggerSource_PXI_7
}
Synchronous signal routing (the master card routes the synchronous signal to this port, and the slave card receives the synchronous signal from this port) More...
enum class | AISignalExportSource { StartTrig = 11 , ReferenceTrig = 12 , SampleClock = 59 }
AI Signal Export Source More...
enum class SignalExportDestination {
PFI0 = 16 , PFI1 = 17 , PFI2 = 18 , PFI3 = 19 ,
PFI4 = 20 , PFI5 = 21 , PFI6 = 22 , PFI7 = 23 ,
PFI8 = 24 , PFI9 = 25 , PFI10 = 26 , PFI11 = 27 ,
PFI12 = 28 , PFI13 = 29 , PFI14 = 30 , PFI15 = 31 ,
PXI_Trig0 = 0 , PXI_Trig1 = 1 , PXI_Trig2 = 2 , PXI_Trig3 = 3 ,
PXI_Trig4 = 4 , PXI_Trig5 = 5 , PXI_Trig6 = 6 , PXI_Trig7 = 7
}
Output DestinationTerminal More...
enum class | DITriggerMode { Start , Reference }
DI Trigger Mode More...
enum class | DITriggerType { Immediate = JY5310Import.JY5310_TriggerType_Immediately , Digital = JY5310Import.JY5310_TriggerType_Digital , Soft = JY5310Import.JY5310_TriggerType_Soft }
TriggerType Digital/Immediate/Soft More...
enum class DIDigitalTriggerSource {
PFI0 = 0x10 , PFI1 = 0x11 , PFI2 =0x12 , PFI3 = 0x13 ,
PFI4 = 0x14 , PFI5 = 0x15 , PFI6 = 0x16 , PFI7 = 0x17 ,
PFI8 = 0x18 , PFI9 = 0x19 , PFI10 = 0x1A , PFI11 = 0x1B ,
PFI12 = 0x1C , PFI13 = 0x1D , PFI14 = 0x1E , PFI15 = 0x1F ,
PXI_Trig0 = 64 , PXI_Trig1 = 65 , PXI_Trig2 = 66 , PXI_Trig3 = 67 ,
PXI_Trig4 = 68 , PXI_Trig5 = 69 , PXI_Trig6 = 70 , PXI_Trig7 = 71 ,
DO_StartTrig = JY5310Import.JY5310_DO_StartTrig , AT_StartTrig = JY5310Import.JY5310_AI_StartTrig , AI_ReferencetTrig = JY5310Import.JY5310_AI_ReferenceTrig
}
DI Digital trigger source. More...
enum class | DIDigitalTriggerEdge { Rising , Falling }
DI Digital Trigger Edge More...
enum class | DISampleClockSource { Internal , External }
DI Sample Clock Source More...
enum class | DIMode { Single = 2 , Finite = 0 , Continuous = 1 }
DIMode More...
enum class | DISignalExportSource { StartTrig = JY5310Import.JY5310_DI_StartTrig , ReferenceTrig = JY5310Import.JY5310_DI_ReferenceTrig , SampleClock = JY5310Import.JY5310_DI_SampleClock }
SourceSignal More...
enum class | DOTriggerType { Immediate = JY5310Import.JY5310_TriggerType_Immediately , Digital = JY5310Import.JY5310_TriggerType_Digital , Soft = JY5310Import.JY5310_TriggerType_Soft }
TriggerType Digital/Immediate/Soft More...
enum class DODigitalTriggerSource {
PFI0 = 0x10 , PFI1 = 0x11 , PFI2 = 0x12 , PFI3 = 0x13 ,
PFI4 = 0x14 , PFI5 = 0x15 , PFI6 = 0x16 , PFI7 = 0x17 ,
PFI8 = 0x18 , PFI9 = 0x19 , PFI10 = 0x1A , PFI11 = 0x1B ,
PFI12 = 0x1C , PFI13 = 0x1D , PFI14 = 0x1E , PFI15 = 0x1F ,
PXI_Trig0 = 64 , PXI_Trig1 = 65 , PXI_Trig2 = 66 , PXI_Trig3 = 67 ,
PXI_Trig4 = 68 , PXI_Trig5 = 69 , PXI_Trig6 = 70 , PXI_Trig7 = 71 ,
AT_StartTrig = JY5310Import.JY5310_AI_StartTrig , AI_ReferencetTrig = JY5310Import.JY5310_AI_ReferenceTrig , DI_StartTrig = JY5310Import.JY5310_DI_StartTrig , DI_ReferencetTrig = JY5310Import.JY5310_DI_ReferenceTrig
}
DO Digital trigger source More...
enum class | DODigitalTriggerEdge { Rising , Falling }
DO Digital Trigger Edge More...
enum class | DOSampleClockSource { Internal , External }
DO Sample Clock Source More...
enum class | DOSignalExportSource { StartTrig = JY5310Import.JY5310_DO_StartTrig , SampleClock = JY5310Import.JY5310_DO_SampleClock }
SourceSignal More...
enum class | DOMode { Single = 3 , Finite = 0 , ContinuousWrapping = 1 , ContinuousNoWrapping = 2 }
DOMode More...

Enumeration Type Documentation

◆ AIAnalogTriggerComparator

enum JY5310.AIAnalogTriggerComparator
strong

AI Analog Trigger Comparator

Enumerator
Edge | Edge Comparator
Hysteresis | Hysteresis Comparator
Window | Window Comparator

◆ AIAnalogTriggerEdge

enum JY5310.AIAnalogTriggerEdge
strong

AI Analog Trigger Edge

Enumerator
Rising | Rising
Falling | Falling

◆ AIAnalogTriggerSource

enum JY5310.AIAnalogTriggerSource
strong

AI Analog Trigger Source

Enumerator
Channel_0 | channel 0
Channel_1 | channel 1
Channel_2 | channel 2
Channel_3 | channel 3
Channel_4 | channel 4
Channel_5 | channel 5
Channel_6 | channel 6
Channel_7 | channel 7
Channel_8 | channel 8
Channel_9 | channel 9
Channel_10 | channel 10
Channel_11 | channel 11
Channel_12 | channel 12
Channel_13 | channel 13
Channel_14 | channel 14
Channel_15 | channel 15

◆ AIAnalogWindowCondition

enum JY5310.AIAnalogWindowCondition
strong

AI Analog Window Trigger Condition

Enumerator
Entering | Rising
Leaving | Falling

◆ AIDigitalTriggerEdge

enum JY5310.AIDigitalTriggerEdge
strong

AI Digital Trigger Edge

Enumerator
Rising | Rising
Falling | Falling

◆ AIDigitalTriggerSource

enum JY5310.AIDigitalTriggerSource
strong

AI Digital Trigger Source

Enumerator
PFI0 | PFI_0
PFI1 | PFI_1
PFI2 | PFI_2
PFI3 | PFI_3
PFI4 | PFI_4
PFI5 | PFI_5
PFI6 | PFI_6
PFI7 | PFI_7
PFI8 | PFI_8
PFI9 | PFI_9
PFI10 | PFI_10
PFI11 | PFI_11
PFI12 | PFI_12
PFI13 | PFI_13
PFI14 | PFI_14
PFI15 | PFI_15
PXI_Trig0 | PXI Trig 0
PXI_Trig1 | PXI Trig 1
PXI_Trig2 | PXI Trig 2
PXI_Trig3 | PXI Trig 3
PXI_Trig4 | PXI Trig 4
PXI_Trig5 | PXI Trig 5
PXI_Trig6 | PXI Trig 6
PXI_Trig7 | PXI Trig 7
DO_StartTrig | DO_StartTrig
DI_StartTrig | DI_StartTrig
DI_ReferencetTrig | DI_ReferencetTrig

◆ AIMode

enum JY5310.AIMode
strong

AIMode

Enumerator
Finite | 单点模式 Finite
Continuous | Continuous
Record | Record

◆ AISampleClockSource

enum JY5310.AISampleClockSource
strong

AIClockSource Type

Enumerator
Internal | Internal
External | External //外部时钟采集有问题，暂时禁用，待新固件发布后再开放20200908

◆ AISignalExportSource

enum JY5310.AISignalExportSource
strong

AI Signal Export Source

Enumerator
StartTrig | AI_StartTrig
ReferenceTrig | AI_ReferenceTrig
SampleClock | AI_SampleClock

◆ AITriggerMode

enum JY5310.AITriggerMode
strong

AI Trigger Mode

Enumerator
Start | Start Trigger Mode
Reference | Reference Trigger Mode，Valid when JY5310AITask.Mode is AIMode.Finite

◆ AITriggerType

enum JY5310.AITriggerType
strong

Trigger Type: Digital/Analog/Immediate

Enumerator
Immediate | Immediate Trigger
Digital | Digital Trigger
Analog | Analog Trigger
Soft | Soft Trigger

◆ ClockTerminal

enum JY5310.ClockTerminal
strong

External Sample Clock Terminal

Enumerator
PFI0 | PFI_0
PFI1 | PFI_1
PFI2 | PFI_2
PFI3 | PFI_3
PFI4 | PFI_4
PFI5 | PFI_5
PFI6 | PFI_6
PFI7 | PFI_7
PFI8 | PFI_8
PFI9 | PFI_9
PFI10 | PFI_10
PFI11 | PFI_11
PFI12 | PFI_12
PFI13 | PFI_13
PFI14 | PFI_14
PFI15 | PFI_15
PXI_Trig0 | PXI Trig 0
PXI_Trig1 | PXI Trig 1
PXI_Trig2 | PXI Trig 2
PXI_Trig3 | PXI Trig 3
PXI_Trig4 | PXI Trig 4
PXI_Trig5 | PXI Trig 5
PXI_Trig6 | PXI Trig 6
PXI_Trig7 | PXI Trig 7
AI_SampleClock | AI_SampleClock
DI_SampleClock | DI_SampleClock
DO_SampleClock | DO_SampleClock

◆ DIDigitalTriggerEdge

enum JY5310.DIDigitalTriggerEdge
strong

DI Digital Trigger Edge

Enumerator
Rising | RisingEdge
Falling | FallingEdge

◆ DIDigitalTriggerSource

enum JY5310.DIDigitalTriggerSource
strong

DI Digital trigger source.

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.
DO_StartTrig | DO_StartTrig
AT_StartTrig | AI_StartTrig
AI_ReferencetTrig | AI_ReferencetTrig

◆ DIMode

enum JY5310.DIMode
strong

DIMode

Enumerator
Single | Single
Finite | Finite
Continuous | Continuous

◆ DISampleClockSource

enum JY5310.DISampleClockSource
strong

DI Sample Clock Source

Enumerator
Internal | Internal Clock Source
External | External Clock Source

◆ DISignalExportSource

enum JY5310.DISignalExportSource
strong

SourceSignal

Enumerator
StartTrig | DI_StartTrig
ReferenceTrig | DI_ReferenceTrig
SampleClock | DI_SampleClock

◆ DITriggerMode

enum JY5310.DITriggerMode
strong

DI Trigger Mode

Enumerator
Start | Start Trigger
Reference | Reference Trigger，only for finite acquisition mode

◆ DITriggerType

enum JY5310.DITriggerType
strong

TriggerType Digital/Immediate/Soft

Enumerator
Immediate | Immediate Trigger
Digital | Digital Trigger
Soft | Soft Trigger

◆ DODigitalTriggerEdge

enum JY5310.DODigitalTriggerEdge
strong

DO Digital Trigger Edge

Enumerator
Rising | RisingEdge
Falling | FallingEdge

◆ DODigitalTriggerSource

enum JY5310.DODigitalTriggerSource
strong

DO Digital trigger source

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.
AT_StartTrig | AI_StartTrig
AI_ReferencetTrig | AI_ReferencetTrig
DI_StartTrig | DI_StartTrig
DI_ReferencetTrig | DI_ReferencetTrig

◆ DOMode

enum JY5310.DOMode
strong

DOMode

Enumerator
Single | Single
Finite | Finite
ContinuousWrapping | ContinuousNoWrapping
ContinuousNoWrapping | ContinuousWrapping

◆ DOSampleClockSource

enum JY5310.DOSampleClockSource
strong

DO Sample Clock Source

Enumerator
Internal | Internal Clock Source
External | External Clock Source

◆ DOSignalExportSource

enum JY5310.DOSignalExportSource
strong

SourceSignal

Enumerator
StartTrig | DO_StartTrig
SampleClock | DO_SampleClock

◆ DOTriggerType

enum JY5310.DOTriggerType
strong

TriggerType Digital/Immediate/Soft

Enumerator
Immediate | Immediate Trigger
Digital | Digital Trigger
Soft | Soft Trigger

◆ FileFormat

enum JY5310.FileFormat
strong

Streaming file format

Enumerator
Bin

Binary file format

◆ RecordMode

enum JY5310.RecordMode
strong

Two stream mode from enum Finite/Infinite

Enumerator
Finite | Finite Streaming
Infinite | InFinite Streaming

◆ SignalExportDestination

enum JY5310.SignalExportDestination
strong

Output DestinationTerminal

Enumerator
PFI0 | PFI0
PFI1 | PFI1
PFI2 | PFI2
PFI3 | PFI3
PFI4 | PFI4
PFI5 | PFI5
PFI6 | PFI6
PFI7 | PFI7
PFI8 | PFI8
PFI9 | PFI9
PFI10 | PFI10
PFI11 | PFI11
PFI12 | PFI12
PFI13 | PFI13
PFI14 | PFI14
PFI15 | PFI15
PXI_Trig0 | PXI_Trig0
PXI_Trig1 | PXI_Trig1
PXI_Trig2 | PXI_Trig2
PXI_Trig3 | PXI_Trig3
PXI_Trig4 | PXI_Trig4
PXI_Trig5 | PXI_Trig5
PXI_Trig6 | PXI_Trig6
PXI_Trig7 | PXI_Trig7

◆ SyncPulseRouting

enum JY5310.SyncPulseRouting
strong

Synchronous signal routing (the master card routes the synchronous signal to this port, and the slave card receives the synchronous signal from this port)

Enumerator
NONE | Default NONE
PXI_Trig0 | PXI Trig0
PXI_Trig1 | PXI Trig1
PXI_Trig2 | PXI Trig2
PXI_Trig3 | PXI Trig3
PXI_Trig4 | PXI Trig4
PXI_Trig5 | PXI Trig5
PXI_Trig6 | PXI Trig6
PXI_Trig7 | PXI Trig7

◆ SyncTopology

enum JY5310.SyncTopology
strong

Synchronization board configuration

Enumerator
Independent | Independent, synchronization not supported
Master | master card
Slave | slave card

◆ SyncTriggerRouting

enum JY5310.SyncTriggerRouting
strong

Master card trigger signal routing (Master card routes trigger signal to this port)

Enumerator
NONE | Default NONE
PXI_Trig0 | PXI Trig0
PXI_Trig1 | PXI Trig1
PXI_Trig2 | PXI Trig2
PXI_Trig3 | PXI Trig3
PXI_Trig4 | PXI Trig4
PXI_Trig5 | PXI Trig5
PXI_Trig6 | PXI Trig6
PXI_Trig7 | PXI Trig7


5310 C# Programming Manual: Package Functions

Here is a list of all namespace members with links to the namespace documentation for each member:

- a -

  • AIAnalogTriggerComparator : JY5310
  • AIAnalogTriggerEdge : JY5310
  • AIAnalogTriggerSource : JY5310
  • AIAnalogWindowCondition : JY5310
  • AIDigitalTriggerEdge : JY5310
  • AIDigitalTriggerSource : JY5310
  • AIMode : JY5310
  • AISampleClockSource : JY5310
  • AISignalExportSource : JY5310
  • AITriggerMode : JY5310
  • AITriggerType : JY5310

- c -

  • ClockTerminal : JY5310

- d -

  • DIDigitalTriggerEdge : JY5310
  • DIDigitalTriggerSource : JY5310
  • DIMode : JY5310
  • DISampleClockSource : JY5310
  • DISignalExportSource : JY5310
  • DITriggerMode : JY5310
  • DITriggerType : JY5310
  • DODigitalTriggerEdge : JY5310
  • DODigitalTriggerSource : JY5310
  • DOMode : JY5310
  • DOSampleClockSource : JY5310
  • DOSignalExportSource : JY5310
  • DOTriggerType : JY5310

- f -

  • FileFormat : JY5310

- r -

  • RecordMode : JY5310

- s -

  • SignalExportDestination : JY5310
  • SyncPulseRouting : JY5310
  • SyncTopology : JY5310
  • SyncTriggerRouting : JY5310


5310 C# Programming Manual: Package Functions

- a -

  • AIAnalogTriggerComparator : JY5310
  • AIAnalogTriggerEdge : JY5310
  • AIAnalogTriggerSource : JY5310
  • AIAnalogWindowCondition : JY5310
  • AIDigitalTriggerEdge : JY5310
  • AIDigitalTriggerSource : JY5310
  • AIMode : JY5310
  • AISampleClockSource : JY5310
  • AISignalExportSource : JY5310
  • AITriggerMode : JY5310
  • AITriggerType : JY5310

- c -

  • ClockTerminal : JY5310

- d -

  • DIDigitalTriggerEdge : JY5310
  • DIDigitalTriggerSource : JY5310
  • DIMode : JY5310
  • DISampleClockSource : JY5310
  • DISignalExportSource : JY5310
  • DITriggerMode : JY5310
  • DITriggerType : JY5310
  • DODigitalTriggerEdge : JY5310
  • DODigitalTriggerSource : JY5310
  • DOMode : JY5310
  • DOSampleClockSource : JY5310
  • DOSignalExportSource : JY5310
  • DOTriggerType : JY5310

- f -

  • FileFormat : JY5310

- r -

  • RecordMode : JY5310

- s -

  • SignalExportDestination : JY5310
  • SyncPulseRouting : JY5310
  • SyncTopology : JY5310
  • SyncTriggerRouting : JY5310


5310 C# Programming Manual: Packages

Packages
Here are the packages with brief descriptions (if available):
[detail level 12]
▼N JY5310 |
C JY5310AITask | JY5310 Analog Input Task
C AIChannel | AI Channel parameter class
C AIAnalogHysteresisComparator | AI Analog Hysteresis Comparatorr
C AIAnalogWindowComparator | AI Analog Window Comparatorr
C AIAnalogEdgeComparator | AI Analog Edge Comparator
C AISampleClock | Sample clock configuration class
C AIExternalSampleClock | External Sample Clock Configuration Class
C AITrigger | AI Trigger class
C AIDigitalTrigger | AI Digital Trigger
C AIAnalogTrigger | AI Analog Trigger
C AIRecord | AI Record class
C AISync | Configure sync signal
C AISignalExport | AI Signal Export Class
C JY5310DITask | JY5310DITask Class
C DIChannel | DI Channel parameter class
C DITrigger | Constructor to create an DITrigger task object
C DIDigitalTrigger | DI Digital trigger
C DISampleClock | Sample clock configuration class
C DIExternalSampleClock | External Sample Clock Configuration Class
C DISignalExport | DI Signal Export Class
C JY5310DOTask | JY5310 DOTask
C DOChannel | DOChannel class
C DOTrigger | Constructor to create an DOTrigger task object
C DODigitalTrigger | DO Digital trigger
C DOSampleClock | Sample clock configuration class
C DOExternalSampleClock | External Sample Clock Configuration Class
C DOSignalExport | DO Signal Export Class