5320 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5320 Directory Reference

5320 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 5320
5320 Directory Reference

Files

JY5320CoreOOAITask.h
JY5320CoreOOCITask.h
JY5320CoreOOCommon.h
JY5320CoreOOCOTask.h
JY5320CoreOODevice.h
JY5320CoreOODITask.h
JY5320CoreOODOTask.h
JY5320CoreOOLog.h
Generated by doxygen 1.13.2


5320 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOAITask.h File Reference

  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 5320
Classes | Namespaces | Macros | Enumerations
JY5320CoreOOAITask.h File Reference
#include <memory>
#include <mutex>
#include <map>
#include <fstream>
#include <thread>
#include <cstring>
#include <cstddef>
#include "JY5320CoreOOCommon.h"
#include "JY5320CoreOODevice.h"

Classes

class | JY5320CoreOO::JY5320CoreOOAITask
aiTask类 More...
class | JY5320CoreOO::AIChannel
class | JY5320CoreOO::AIExternalSampleClock
class | JY5320CoreOO::AISampleClock
class | JY5320CoreOO::AITrigger
class | JY5320CoreOO::AIDigitalTrigger
class | JY5320CoreOO::AIAnalogHysteresisComparator
class | JY5320CoreOO::AIAnalogWindowComparator
class | JY5320CoreOO::AIAnalogEdgeComparator
class | JY5320CoreOO::AIAnalogTrigger
class | JY5320CoreOO::AIMultiChannelAnalogTrigger
class | JY5320CoreOO::AISignalExport
class | JY5320CoreOO::AIRecord
class | JY5320CoreOO::AIDSMode
class | JY5320CoreOO::AIAdvanced
class | JY5320CoreOO::AISync
Configure sync signal. More...

Namespaces

namespace JY5320CoreOO

Macros

#define _CRT_SECURE_NO_WARNINGS

Enumerations

enum class | JY5320CoreOO::AIMode { JY5320CoreOO::Single = 0x2 , JY5320CoreOO::Finite = 0x0 , JY5320CoreOO::Continuous = 0x1 , JY5320CoreOO::Record = 0x3 }
enum class | JY5320CoreOO::AIBandWidth { JY5320CoreOO::_25KHz = JY5320Import::JY5320_AI_BandWidth_25K , JY5320CoreOO::_220KHz = JY5320Import::JY5320_AI_BandWidth_220K }
AI BandWidth. More...
enum class | JY5320CoreOO::MultiChannelCompositionLogic { JY5320CoreOO::Or = 0 , JY5320CoreOO::And = 1 }
Multichannel composition logic. More...
enum class | JY5320CoreOO::AISampleClockSource { JY5320CoreOO::Internal , JY5320CoreOO::External }
enum class JY5320CoreOO::AITriggerType {
JY5320CoreOO::Immediate = 0x0 , JY5320CoreOO::Digital = 0x1 , JY5320CoreOO::Analog = 0x2 , JY5320CoreOO::Soft = 0x3 ,
JY5320CoreOO::MultiChannelAanlog = 0x4
}
enum class | JY5320CoreOO::AITriggerMode { JY5320CoreOO::Start , JY5320CoreOO::Reference }
enum class JY5320CoreOO::AIAnalogTriggerSource {
JY5320CoreOO::Channel_0 , JY5320CoreOO::Channel_1 , JY5320CoreOO::Channel_2 , JY5320CoreOO::Channel_3 ,
JY5320CoreOO::Channel_4 , JY5320CoreOO::Channel_5 , JY5320CoreOO::Channel_6 , JY5320CoreOO::Channel_7 ,
JY5320CoreOO::Channel_8 , JY5320CoreOO::Channel_9 , JY5320CoreOO::Channel_10 , JY5320CoreOO::Channel_11 ,
JY5320CoreOO::Channel_12 , JY5320CoreOO::Channel_13 , JY5320CoreOO::Channel_14 , JY5320CoreOO::Channel_15 ,
JY5320CoreOO::Channel_16 , JY5320CoreOO::Channel_17 , JY5320CoreOO::Channel_18 , JY5320CoreOO::Channel_19 ,
JY5320CoreOO::Channel_20 , JY5320CoreOO::Channel_21 , JY5320CoreOO::Channel_22 , JY5320CoreOO::Channel_23 ,
JY5320CoreOO::Channel_24 , JY5320CoreOO::Channel_25 , JY5320CoreOO::Channel_26 , JY5320CoreOO::Channel_27 ,
JY5320CoreOO::Channel_28 , JY5320CoreOO::Channel_29 , JY5320CoreOO::Channel_30 , JY5320CoreOO::Channel_31
}
enum class JY5320CoreOO::AIDigitalTriggerSource {
JY5320CoreOO::PFI0 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_0 , JY5320CoreOO::PFI1 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_1 , JY5320CoreOO::PFI2 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_2 , JY5320CoreOO::PFI3 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_3 ,
JY5320CoreOO::PFI4 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_4 , JY5320CoreOO::PFI5 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_5 , JY5320CoreOO::PFI6 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_6 , JY5320CoreOO::PFI7 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_7 ,
JY5320CoreOO::PFI8 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_8 , JY5320CoreOO::PFI9 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_9 , JY5320CoreOO::PFI10 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_10 , JY5320CoreOO::PFI11 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_11 ,
JY5320CoreOO::PFI12 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_12 , JY5320CoreOO::PFI13 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_13 , JY5320CoreOO::PFI14 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_14 , JY5320CoreOO::PFI15 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_15 ,
JY5320CoreOO::PXI_Trig0 = (int)JY5320Import::JY5320_DigitalTriggerSource_PXI_0 , JY5320CoreOO::PXI_Trig1 = (int)JY5320Import::JY5320_DigitalTriggerSource_PXI_1 , JY5320CoreOO::PXI_Trig2 = (int)JY5320Import::JY5320_DigitalTriggerSource_PXI_2 , JY5320CoreOO::PXI_Trig3 = (int)JY5320Import::JY5320_DigitalTriggerSource_PXI_3 ,
JY5320CoreOO::PXI_Trig4 = (int)JY5320Import::JY5320_DigitalTriggerSource_PXI_4 , JY5320CoreOO::PXI_Trig5 = (int)JY5320Import::JY5320_DigitalTriggerSource_PXI_5 , JY5320CoreOO::PXI_Trig6 = (int)JY5320Import::JY5320_DigitalTriggerSource_PXI_6 , JY5320CoreOO::PXI_Trig7 = (int)JY5320Import::JY5320_DigitalTriggerSource_PXI_7 ,
JY5320CoreOO::CIO_0_StartTrig = (int)JY5320Import::JY5320_DigitalTriggerSource_Inter_CIO_0_StartTrig , JY5320CoreOO::CIO_1_StartTrig = (int)JY5320Import::JY5320_DigitalTriggerSource_Inter_CIO_1_StartTrig , JY5320CoreOO::CI_0_OutPut = (int)JY5320Import::JY5320_DigitalTriggerSource_Inter_Counter_0_Output , JY5320CoreOO::CI_1_OutPut = (int)JY5320Import::JY5320_DigitalTriggerSource_Inter_Counter_1_Output
}
enum class | JY5320CoreOO::AIDigitalTriggerEdge { JY5320CoreOO::Rising = 0x0 , JY5320CoreOO::Falling = 0x1 }
enum class | JY5320CoreOO::AIAnalogTriggerEdge { JY5320CoreOO::Rising = (int)JY5320Import::JY5320_AnalogTriggerEdge_RisingSlope , JY5320CoreOO::Falling = (int)JY5320Import::JY5320_AnalogTriggerEdge_FallingSlope }
enum class | JY5320CoreOO::AIAnalogWindowCondition { JY5320CoreOO::Entering = (int)JY5320Import::JY5320_AnalogTriggerCondition_EnteringWindow , JY5320CoreOO::Leaving = (int)JY5320Import::JY5320_AnaloglTriggerCondition_LeavingWindow }
AI Analog Window Trigger Condition. More...
enum class | JY5320CoreOO::AIAnalogTriggerComparator { JY5320CoreOO::Edge , JY5320CoreOO::Hysteresis , JY5320CoreOO::Window }
AI Analog Trigger Comparator. More...
enum class | JY5320CoreOO::AISignalExportSource { JY5320CoreOO::StartTrig = JY5320Import::JY5320_AI_StartTrig , JY5320CoreOO::ReferenceTrig = JY5320Import::JY5320_AI_ReferenceTrig , JY5320CoreOO::SampleClock = JY5320Import::JY5320_AI_SampleClock }
enum class | JY5320CoreOO::FileFormat { JY5320CoreOO::Bin }
enum class | JY5320CoreOO::RecordMode { JY5320CoreOO::Finite , JY5320CoreOO::Infinite }
enum class | JY5320CoreOO::SyncTopology { JY5320CoreOO::Independent , JY5320CoreOO::Master , JY5320CoreOO::Slave }
Synchronization board configuration. More...
enum class JY5320CoreOO::SyncTriggerRouting {
JY5320CoreOO::NONE = -1 , JY5320CoreOO::PFI0 = JY5320Import::JY5320_PFI0_OUT , JY5320CoreOO::PFI1 = JY5320Import::JY5320_PFI1_OUT , JY5320CoreOO::PFI2 = JY5320Import::JY5320_PFI2_OUT ,
JY5320CoreOO::PFI3 = JY5320Import::JY5320_PFI3_OUT , JY5320CoreOO::PFI4 = JY5320Import::JY5320_PFI4_OUT , JY5320CoreOO::PFI5 = JY5320Import::JY5320_PFI5_OUT , JY5320CoreOO::PFI6 = JY5320Import::JY5320_PFI6_OUT ,
JY5320CoreOO::PFI7 = JY5320Import::JY5320_PFI7_OUT , JY5320CoreOO::PFI8 = JY5320Import::JY5320_PFI8_OUT , JY5320CoreOO::PFI9 = JY5320Import::JY5320_PFI9_OUT , JY5320CoreOO::PFI10 = JY5320Import::JY5320_PFI10_OUT ,
JY5320CoreOO::PFI11 = JY5320Import::JY5320_PFI11_OUT , JY5320CoreOO::PFI12 = JY5320Import::JY5320_PFI12_OUT , JY5320CoreOO::PFI13 = JY5320Import::JY5320_PFI13_OUT , JY5320CoreOO::PFI14 = JY5320Import::JY5320_PFI14_OUT ,
JY5320CoreOO::PFI15 = JY5320Import::JY5320_PFI15_OUT , JY5320CoreOO::PXI_Trig0 = JY5320Import::JY5320_PXITrig0_OUT , JY5320CoreOO::PXI_Trig1 = JY5320Import::JY5320_PXITrig1_OUT , JY5320CoreOO::PXI_Trig2 = JY5320Import::JY5320_PXITrig2_OUT ,
JY5320CoreOO::PXI_Trig3 = JY5320Import::JY5320_PXITrig3_OUT , JY5320CoreOO::PXI_Trig4 = JY5320Import::JY5320_PXITrig4_OUT , JY5320CoreOO::PXI_Trig5 = JY5320Import::JY5320_PXITrig5_OUT , JY5320CoreOO::PXI_Trig6 = JY5320Import::JY5320_PXITrig6_OUT ,
JY5320CoreOO::PXI_Trig7 = JY5320Import::JY5320_PXITrig7_OUT
}
enum class JY5320CoreOO::SyncPulseRouting {
JY5320CoreOO::NONE = -1 , JY5320CoreOO::PFI0 = JY5320Import::JY5320_PFI0_OUT , JY5320CoreOO::PFI1 = JY5320Import::JY5320_PFI1_OUT , JY5320CoreOO::PFI2 = JY5320Import::JY5320_PFI2_OUT ,
JY5320CoreOO::PFI3 = JY5320Import::JY5320_PFI3_OUT , JY5320CoreOO::PFI4 = JY5320Import::JY5320_PFI4_OUT , JY5320CoreOO::PFI5 = JY5320Import::JY5320_PFI5_OUT , JY5320CoreOO::PFI6 = JY5320Import::JY5320_PFI6_OUT ,
JY5320CoreOO::PFI7 = JY5320Import::JY5320_PFI7_OUT , JY5320CoreOO::PFI8 = JY5320Import::JY5320_PFI8_OUT , JY5320CoreOO::PFI9 = JY5320Import::JY5320_PFI9_OUT , JY5320CoreOO::PFI10 = JY5320Import::JY5320_PFI10_OUT ,
JY5320CoreOO::PFI11 = JY5320Import::JY5320_PFI11_OUT , JY5320CoreOO::PFI12 = JY5320Import::JY5320_PFI12_OUT , JY5320CoreOO::PFI13 = JY5320Import::JY5320_PFI13_OUT , JY5320CoreOO::PFI14 = JY5320Import::JY5320_PFI14_OUT ,
JY5320CoreOO::PFI15 = JY5320Import::JY5320_PFI15_OUT , JY5320CoreOO::PXI_Trig0 = JY5320Import::JY5320_PXITrig0_OUT , JY5320CoreOO::PXI_Trig1 = JY5320Import::JY5320_PXITrig1_OUT , JY5320CoreOO::PXI_Trig2 = JY5320Import::JY5320_PXITrig2_OUT ,
JY5320CoreOO::PXI_Trig3 = JY5320Import::JY5320_PXITrig3_OUT , JY5320CoreOO::PXI_Trig4 = JY5320Import::JY5320_PXITrig4_OUT , JY5320CoreOO::PXI_Trig5 = JY5320Import::JY5320_PXITrig5_OUT , JY5320CoreOO::PXI_Trig6 = JY5320Import::JY5320_PXITrig6_OUT ,
JY5320CoreOO::PXI_Trig7 = JY5320Import::JY5320_PXITrig7_OUT
}

Macro Definition Documentation

◆ _CRT_SECURE_NO_WARNINGS

#define _CRT_SECURE_NO_WARNINGS


5320 C++ Programming Manual: JY5320CoreOO::JY5320CoreOOAITask Class Reference

  • Class List
  • Class Index
  • Class Members
  • JY5320CoreOO
  • JY5320CoreOOAITask
Public Member Functions | Public Attributes | List of all members
JY5320CoreOO::JY5320CoreOOAITask Class Reference

aiTask类 More...

#include <JY5320CoreOOAITask.h>

Public Member Functions

JY5320CoreOOAITask (int slotNum)
Constructor.
JY5320CoreOOAITask (std::string boardName)
Constructor.
void | AddChannel (int chnId, AIBandWidth bandWidth, double rangeLow=-10, double rangeHigh=10)
Add one channel.
void | AddChannel (int chnId, double rangeLow=-10, double rangeHigh=10)
Add one channel.
void | AddChannel (std::vector< int > chnsId, AIBandWidth bandWidth, double rangeLow=-10, double rangeHigh=10)
Add a group of channels.
void | AddChannel (std::vector< int > chnsId, double rangeLow=-10, double rangeHigh=10)
Add a group of channels.
void | AddChannel (std::vector< int > chnsId, std::vector< double > rangeLow, std::vector< double > rangeHigh, std::vector< AIBandWidth > bandWidth)
Add a group of channels, each channel range can be set differently.
void | AddChannel (std::vector< int > chnsId, std::vector< double > rangeLow, std::vector< double > rangeHigh)
Add a group of channels, each channel range can be set differently.
void | RemoveChannel (int chnId)
Delete the channel with the specified channel number.
void | ReadData (double *pBuf, int samplesPerChannel, int timeout=-1)
Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.
void | ReadData (std::vector< double > &pBuf, int samplesPerChannel, int timeout=-1)
Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.
void | ReadRawData (short *pBuf, int samplesPerChannel, int timeout=-1)
Read one or multi-channel raw data by columns and store it in a data buffer.
void | ReadRawData (std::vector< short > &pBuf, int samplesPerChannel, int timeout=-1)
Read one or multi-channel raw data by columns and store it in a data buffer.
void | ReadSinglePoint (double &readValue, int channel)
Read one sample for specified channel in register.
void | ReadSinglePoint (std::vector< double > &readValues)
Read raw one sample for all channels in register .
void | GetRecordPreviewData (double *buf, int samplesPerChannel, int timeout=1000)
Preview one channel data when streaming is in progress.
void | GetRecordPreviewData (std::vector< double > &buf, int samplesPerChannel, int timeout=1000)
Preview one channel data when streaming is in progress.
void | GetRecordStatus (double *recordedLength, bool *recordDone)
Get the streaming status.
void | GetRecordStatus (double &recordedLength, bool &recordDone)
Get the streaming status.
void | Start ()
Start Task.
void | SendSoftwareTrigger ()
Generate a software trigger signal generate a software trigger signal.
void | Stop ()
Stop Task.
~JY5320CoreOOAITask ()

Public Attributes

std::list< AIChannel * > | Channels
List of AI channels,(5322 5324 support 16 Diff channel，5321 5323 support 32 Diff channel)
JY5320CoreOOProperty< JY5320CoreOOAITask, double, JY5320CoreOOPropertyType::READ_WRITE > | SampleRate
Sample rate per channel.
unsigned int | SamplesToAcquire
Number of samples to be read per channel.
JY5320CoreOOProperty< JY5320CoreOOAITask, int, JY5320CoreOOPropertyType::READ_ONLY > | BufLenInSamples
Number of samples per channel can be storage in the buffer, the Property SamplesToAcquire must be less than or equal to this value.
JY5320CoreOOProperty< JY5320CoreOOAITask, uint64_t, JY5320CoreOOPropertyType::READ_ONLY > | AvailableSamples
Number of samples per channel that can be read in the buffer .
JY5320CoreOOProperty< JY5320CoreOOAITask, uint64_t, JY5320CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
AIMode Mode
AI acquisition mode, support Finite/Continuous/Record *.
AISampleClock * SampleClock
AI Sample Clock.
AITrigger * Trigger
AI Trigger Configuration.
AIAdvanced * Advanced
AI Trigger Configuration.
AIRecord * Record
AI Data streaming Configuration.
AISignalExport * SignalExport
Export AI Signal Configuration.
bool | DisableDigitalTriggerDelay
Disalble calibration Enable.
AISync * Sync
Multi card synchronous configuration.
JY5320CoreOODevice * Device
Device.

Detailed Description

aiTask类

Constructor & Destructor Documentation

◆ JY5320CoreOOAITask() [1/2]

JY5320CoreOO::JY5320CoreOOAITask::JY5320CoreOOAITask ( int slotNum )

Constructor.

Used to create an AI task by a slot number

Parameters
slotNum Card slot number.

◆ JY5320CoreOOAITask() [2/2]

JY5320CoreOO::JY5320CoreOOAITask::JY5320CoreOOAITask ( std::string boardName )

Constructor.

Used to create an AI task by a slot number

Parameters
slotNum Card slot number.

◆ ~JY5320CoreOOAITask()

JY5320CoreOO::JY5320CoreOOAITask::~JY5320CoreOOAITask ( )

Member Function Documentation

◆ AddChannel() [1/6]

void JY5320CoreOO::JY5320CoreOOAITask::AddChannel | ( | int | chnId,
 |  | AIBandWidth | bandWidth,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10 )

Add one channel.

Parameters
chnId | channel's physical number ，chnId=-1, add all channels,if 5322 5324 channel is 0 - 15. if 5321 5323 channel is 0 -31
rangeLow | lower range limit for the channel，-60V, -50V, -10V,-5V,-1V, -0.5V,5323/5324:-10,-5,-2,-1,-0.5,-0.25,default -10
rangeHigh | higher range limit for the channel,60V,50V,10V,5V,1V, 0.5V,5323/5324:10,5,2,1,0.5,0.25,default 10
bandWidth | AI Bandwidth ,default 25KHz

◆ AddChannel() [2/6]

void JY5320CoreOO::JY5320CoreOOAITask::AddChannel | ( | int | chnId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10 )

Add one channel.

Parameters
chnId | channel's physical number ，chnId=-1, add all channels,if 5322 5324 channel is 0 - 15. if 5321 5323 channel is 0 -31
rangeLow | lower range limit for the channel，-60V, -50V,-10V,-5V,-1V, -0.5V,5323/5324:-10,-5,-2,-1,-0.5,-0.25,default -10
rangeHigh | higher range limit for the channel,60V,50V,10V,5V,1V, 0.5V,5323/5324:10,5,2,1,0.5,0.25,default 10

◆ AddChannel() [3/6]

void JY5320CoreOO::JY5320CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | AIBandWidth | bandWidth,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10 )

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers,if 5322 5324 channel is 0 - 15. if 5321 5323 channel is 0 -31
rangeLow | lower range limit for the channel，-60V, -50V,-10V,-5V,-1V, -0.5V,5323/5324:-10,-5,-2,-1,-0.5,-0.25,default -10
rangeHigh | higher range limit for the channel,60V,50V,10V,5V,1V, 0.5V,5323/5324:10,5,2,1,0.5,0.25,default 10
bandWidth | AI Bandwidth ,default 25KHz

◆ AddChannel() [4/6]

void JY5320CoreOO::JY5320CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10 )

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers,if 5322 5324 channel is 0 - 15. if 5321 5323 channel is 0 -31
rangeLow | lower range limit for the channel，-60V, -50V,-10V,-5V,-1V, -0.5V,5323/5324:-10,-5,-2,-1,-0.5,-0.25,default -10
rangeHigh | higher range limit for the channel,60V,50V,10V,5V,1V, 0.5V,5323/5324:10,5,2,1,0.5,0.25,default 10

◆ AddChannel() [5/6]

void JY5320CoreOO::JY5320CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | std::vector< double > | rangeLow,
 |  | std::vector< double > | rangeHigh )

Add a group of channels, each channel range can be set differently.

Parameters
chnsId | a group of channel physical numbers,if 5322 5324 channel is 0 - 15. if 5321 5323 channel is 0 -31
rangeLow | lower range limit for the channel，-60V, -50V,-10V,-5V,-1V, -0.5V,5323/5324:-10,-5,-2,-1,-0.5,-0.25,default -10
rangeHigh | higher range limit for the channel,60V,50V,10V,5V,1V, 0.5V,5323/5324:10,5,2,1,0.5,0.25,default 10

◆ AddChannel() [6/6]

void JY5320CoreOO::JY5320CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | std::vector< double > | rangeLow,
 |  | std::vector< double > | rangeHigh,
 |  | std::vector< AIBandWidth > | bandWidth )

Add a group of channels, each channel range can be set differently.

Parameters
chnsId | a group of channel physical numbers,if 5322 5324 channel is 0 - 15. if 5321 5323 channel is 0 -31
rangeLow | lower range limit for the channel，-60V, -50V,-10V,-5V,-1V, -0.5V,5323/5324:-10,-5,-2,-1,-0.5,-0.25,default -10
rangeHigh | higher range limit for the channel,60V,50V,10V,5V,1V, 0.5V,5323/5324:10,5,2,1,0.5,0.25,default 10
bandWidth | AI Bandwidth ,default 25KHz

◆ GetRecordPreviewData() [1/2]

void JY5320CoreOO::JY5320CoreOOAITask::GetRecordPreviewData | ( | double * | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 1000 )

Preview one channel data when streaming is in progress.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ GetRecordPreviewData() [2/2]

void JY5320CoreOO::JY5320CoreOOAITask::GetRecordPreviewData | ( | std::vector< double > & | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 1000 )

Preview one channel data when streaming is in progress.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ GetRecordStatus() [1/2]

void JY5320CoreOO::JY5320CoreOOAITask::GetRecordStatus | ( | double & | recordedLength,
 |  | bool & | recordDone )

Get the streaming status.

Parameters
recordedLength | Length of the streamed, unit s
recordDone | recordDone = false :streaming is not over.recordDone = true :streaming is over

◆ GetRecordStatus() [2/2]

void JY5320CoreOO::JY5320CoreOOAITask::GetRecordStatus | ( | double * | recordedLength,
 |  | bool * | recordDone )

Get the streaming status.

Parameters
recordedLength | Length of the streamed, unit s
recordDone | recordDone = false :streaming is not over.recordDone = true :streaming is over

◆ ReadData() [1/2]

void JY5320CoreOO::JY5320CoreOOAITask::ReadData | ( | double * | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = -1 )

Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.

param name="pBuf">Data buffer

Parameters
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish

◆ ReadData() [2/2]

void JY5320CoreOO::JY5320CoreOOAITask::ReadData | ( | std::vector< double > & | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = -1 )

Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.

param name="pBuf">Data buffer

Parameters
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish

◆ ReadRawData() [1/2]

void JY5320CoreOO::JY5320CoreOOAITask::ReadRawData | ( | short * | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = -1 )

Read one or multi-channel raw data by columns and store it in a data buffer.

The buffer is pointed by C/C++ data type short.

Parameters
pBuf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [2/2]

void JY5320CoreOO::JY5320CoreOOAITask::ReadRawData | ( | std::vector< short > & | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = -1 )

Read one or multi-channel raw data by columns and store it in a data buffer.

The buffer is pointed by C/C++ data type short.

Parameters
pBuf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ ReadSinglePoint() [1/2]

void JY5320CoreOO::JY5320CoreOOAITask::ReadSinglePoint | ( | double & | readValue,
 |  | int | channel )

Read one sample for specified channel in register.

Available when Mode is AIMode.Single

Parameters
readValue | value read
channel | Specified channel numbers.

◆ ReadSinglePoint() [2/2]

void JY5320CoreOO::JY5320CoreOOAITask::ReadSinglePoint ( std::vector< double > & readValues )

Read raw one sample for all channels in register .

Available when Mode is AIMode.Single

Parameters
readValues Values read. Array length >= Channels.Count.

◆ RemoveChannel()

void JY5320CoreOO::JY5320CoreOOAITask::RemoveChannel ( int chnId )

Delete the channel with the specified channel number.

chnId=- 1, all channels will be deleted

Parameters
chnId Channel number of the channel to be deleted

◆ SendSoftwareTrigger()

void JY5320CoreOO::JY5320CoreOOAITask::SendSoftwareTrigger ( )

Generate a software trigger signal generate a software trigger signal.

Returns

◆ Start()

void JY5320CoreOO::JY5320CoreOOAITask::Start ( )

Start Task.

Parameters

return void

Exceptions
JYDriverException When startup fails

◆ Stop()

void JY5320CoreOO::JY5320CoreOOAITask::Stop ( )

Stop Task.

Parameters

return void

Exceptions
JYDriverException When stop fails

Member Data Documentation

◆ Advanced

AIAdvanced* JY5320CoreOO::JY5320CoreOOAITask::Advanced

AI Trigger Configuration.

◆ AvailableSamples

JY5320CoreOOProperty<JY5320CoreOOAITask, uint64_t, JY5320CoreOOPropertyType::READ_ONLY> JY5320CoreOO::JY5320CoreOOAITask::AvailableSamples

Number of samples per channel that can be read in the buffer .

Valid when Mode is NOT AIMode.Single.

◆ BufLenInSamples

JY5320CoreOOProperty<JY5320CoreOOAITask, int, JY5320CoreOOPropertyType::READ_ONLY> JY5320CoreOO::JY5320CoreOOAITask::BufLenInSamples

Number of samples per channel can be storage in the buffer, the Property SamplesToAcquire must be less than or equal to this value.

◆ Channels

std::list<AIChannel*> JY5320CoreOO::JY5320CoreOOAITask::Channels

List of AI channels,(5322 5324 support 16 Diff channel，5321 5323 support 32 Diff channel)

◆ Device

JY5320CoreOODevice* JY5320CoreOO::JY5320CoreOOAITask::Device

Device.

◆ DisableDigitalTriggerDelay

bool JY5320CoreOO::JY5320CoreOOAITask::DisableDigitalTriggerDelay

Disalble calibration Enable.

◆ Mode

AIMode JY5320CoreOO::JY5320CoreOOAITask::Mode

AI acquisition mode, support Finite/Continuous/Record *.

◆ Record

AIRecord* JY5320CoreOO::JY5320CoreOOAITask::Record

AI Data streaming Configuration.

◆ SampleClock

AISampleClock* JY5320CoreOO::JY5320CoreOOAITask::SampleClock

AI Sample Clock.

◆ SampleRate

JY5320CoreOOProperty<JY5320CoreOOAITask, double, JY5320CoreOOPropertyType::READ_WRITE> JY5320CoreOO::JY5320CoreOOAITask::SampleRate

Sample rate per channel.

Maximum sample rate:5323 5324 is 200k,5321 5322 is 1M The defalut sample rate = 1M You can read this property to obtain the sample rate that will actually take effect in the current configuration.

Exceptions
JYDriverException

◆ SamplesToAcquire

unsigned int JY5320CoreOO::JY5320CoreOOAITask::SamplesToAcquire

Number of samples to be read per channel.

Only valid when Mode is Finite*

◆ SignalExport

AISignalExport* JY5320CoreOO::JY5320CoreOOAITask::SignalExport

Export AI Signal Configuration.

◆ Sync

AISync* JY5320CoreOO::JY5320CoreOOAITask::Sync

Multi card synchronous configuration.

◆ TransferedSamples

JY5320CoreOOProperty<JY5320CoreOOAITask, uint64_t, JY5320CoreOOPropertyType::READ_ONLY> JY5320CoreOO::JY5320CoreOOAITask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT AIMode.Single.

◆ Trigger

AITrigger* JY5320CoreOO::JY5320CoreOOAITask::Trigger

AI Trigger Configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOAITask.h


5320 C++ Programming Manual: JY5320CoreOO::AIChannel Class Reference

  • JY5320CoreOO
  • AIChannel
Public Member Functions | Public Attributes | List of all members
JY5320CoreOO::AIChannel Class Reference

#include <JY5320CoreOOAITask.h>

Public Member Functions

AIChannel (int channelId, double rangeLow, double rangeHigh, AIBandWidth bandWidth)

Public Attributes

int | ChannelID
double | RangeLow
double | RangeHigh
AIBandWidth BandWidth

Constructor & Destructor Documentation

◆ AIChannel()

JY5320CoreOO::AIChannel::AIChannel | ( | int | channelId,
 |  | double | rangeLow,
 |  | double | rangeHigh,
 |  | AIBandWidth | bandWidth )
 inline

Member Data Documentation

◆ BandWidth

AIBandWidth JY5320CoreOO::AIChannel::BandWidth

◆ ChannelID

int JY5320CoreOO::AIChannel::ChannelID

◆ RangeHigh

double JY5320CoreOO::AIChannel::RangeHigh

◆ RangeLow

double JY5320CoreOO::AIChannel::RangeLow
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOAITask.h


5320 C++ Programming Manual: JY5320CoreOO::AIExternalSampleClock Class Reference

  • AIExternalSampleClock
Public Attributes | List of all members
JY5320CoreOO::AIExternalSampleClock Class Reference

#include <JY5320CoreOOAITask.h>

Public Attributes

ClockTerminal Terminal
External Sample Clock Input Terminal.
double ExpectedRate
Expected External Sample Clock Rate.

Member Data Documentation

◆ ExpectedRate

double JY5320CoreOO::AIExternalSampleClock::ExpectedRate

Expected External Sample Clock Rate.

◆ Terminal

ClockTerminal JY5320CoreOO::AIExternalSampleClock::Terminal

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOAITask.h


5320 C++ Programming Manual: JY5320CoreOO::AISampleClock Class Reference

  • AISampleClock
Public Attributes | List of all members
JY5320CoreOO::AISampleClock Class Reference

#include <JY5320CoreOOAITask.h>

Public Attributes

AISampleClockSource Source
AI Sample Clock Source.
AIExternalSampleClock * External
External Sample Clock Configuration.

Member Data Documentation

◆ External

AIExternalSampleClock* JY5320CoreOO::AISampleClock::External

External Sample Clock Configuration.

Valid when Source is AISampleClockSource.External.

◆ Source

AISampleClockSource JY5320CoreOO::AISampleClock::Source

AI Sample Clock Source.

enum Internal/External. The default value is AISampleClockSource.Internal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOAITask.h


5320 C++ Programming Manual: JY5320CoreOO::AITrigger Class Reference

  • AITrigger
Public Attributes | List of all members
JY5320CoreOO::AITrigger Class Reference

#include <JY5320CoreOOAITask.h>

Public Attributes

AITriggerType Type
AI trigger type.
AITriggerMode Mode
AI trigger mode.
AIDigitalTrigger * Digital
Digital Trigger Congfiguration.
AIAnalogTrigger * Analog
AI Analog Trigger.
AIMultiChannelAnalogTrigger * MultiChannel
AI Analog Trigger.
int | ReTriggerCount
Number of repeat triggers.
unsigned int | PreTriggerSamples
AI pretrigger samples, must be less than or equal to JY5320aiTask.SamplesToAcquire.

Member Data Documentation

◆ Analog

AIAnalogTrigger* JY5320CoreOO::AITrigger::Analog

AI Analog Trigger.

Valid when Type is AITriggerType.Analog.

◆ Digital

AIDigitalTrigger* JY5320CoreOO::AITrigger::Digital

Digital Trigger Congfiguration.

Valid when Type is AITriggerType.Digital.

◆ Mode

AITriggerMode JY5320CoreOO::AITrigger::Mode

AI trigger mode.

enum Start/Reference. The default value is AITriggerMode.Start.

◆ MultiChannel

AIMultiChannelAnalogTrigger* JY5320CoreOO::AITrigger::MultiChannel

AI Analog Trigger.

Valid when Type is AITriggerType.Analog.

◆ PreTriggerSamples

unsigned int JY5320CoreOO::AITrigger::PreTriggerSamples

AI pretrigger samples, must be less than or equal to JY5320aiTask.SamplesToAcquire.

Valid when Mode is AITriggerMode.Reference. Pretrigger samples, must be greater than 0. Valid when Type is AITriggerType.Analog. Pretrigger samples, must be greater than 1. Valid when Type is AITriggerType.Digital.

◆ ReTriggerCount

int JY5320CoreOO::AITrigger::ReTriggerCount

Number of repeat triggers.

When 0 or 1 only trigger once, When -1 continuous retrigger until stop.

◆ Type

AITriggerType JY5320CoreOO::AITrigger::Type

AI trigger type.

enum Analog/Digital/Immediate/Soft. The default value is AITriggerType.Immediate.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOAITask.h


5320 C++ Programming Manual: JY5320CoreOO::AIDigitalTrigger Class Reference

  • AIDigitalTrigger
Public Attributes | List of all members
JY5320CoreOO::AIDigitalTrigger Class Reference

#include <JY5320CoreOOAITask.h>

Public Attributes

AIDigitalTriggerSource Source
AI Digital Trigger source.
AIDigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Member Data Documentation

◆ Edge

AIDigitalTriggerEdge JY5320CoreOO::AIDigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

AIDigitalTriggerSource JY5320CoreOO::AIDigitalTrigger::Source

AI Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOAITask.h


5320 C++ Programming Manual: JY5320CoreOO::AIAnalogHysteresisComparator Class Reference

  • AIAnalogHysteresisComparator
Public Attributes | List of all members
JY5320CoreOO::AIAnalogHysteresisComparator Class Reference

#include <JY5320CoreOOAITask.h>

Public Attributes

AIAnalogTriggerEdge Slope
AI Analog Trigger Edge.
double | HighThreshold
High Threshold.
double | LowThreshold
Low Threshold.

Member Data Documentation

◆ HighThreshold

double JY5320CoreOO::AIAnalogHysteresisComparator::HighThreshold

High Threshold.

◆ LowThreshold

double JY5320CoreOO::AIAnalogHysteresisComparator::LowThreshold

Low Threshold.

◆ Slope

AIAnalogTriggerEdge JY5320CoreOO::AIAnalogHysteresisComparator::Slope

AI Analog Trigger Edge.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOAITask.h


5320 C++ Programming Manual: JY5320CoreOO::AIAnalogWindowComparator Class Reference

  • AIAnalogWindowComparator
Public Attributes | List of all members
JY5320CoreOO::AIAnalogWindowComparator Class Reference

#include <JY5320CoreOOAITask.h>

Public Attributes

AIAnalogWindowCondition Condition
AI Analog Window Condition.
double | HighThreshold
High Threshold.
double | LowThreshold
Low Threshold.

Member Data Documentation

◆ Condition

AIAnalogWindowCondition JY5320CoreOO::AIAnalogWindowComparator::Condition

AI Analog Window Condition.

◆ HighThreshold

double JY5320CoreOO::AIAnalogWindowComparator::HighThreshold

High Threshold.

◆ LowThreshold

double JY5320CoreOO::AIAnalogWindowComparator::LowThreshold

Low Threshold.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOAITask.h


5320 C++ Programming Manual: JY5320CoreOO::AIAnalogEdgeComparator Class Reference

  • AIAnalogEdgeComparator
Public Attributes | List of all members
JY5320CoreOO::AIAnalogEdgeComparator Class Reference

#include <JY5320CoreOOAITask.h>

Public Attributes

AIAnalogTriggerEdge Slope
AI Analog Trigger Edge.
double Threshold
Threshold.

Member Data Documentation

◆ Slope

AIAnalogTriggerEdge JY5320CoreOO::AIAnalogEdgeComparator::Slope

AI Analog Trigger Edge.

◆ Threshold

double JY5320CoreOO::AIAnalogEdgeComparator::Threshold

Threshold.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOAITask.h


5320 C++ Programming Manual: JY5320CoreOO::AIAnalogTrigger Class Reference

  • AIAnalogTrigger
Public Member Functions | Public Attributes | List of all members
JY5320CoreOO::AIAnalogTrigger Class Reference

#include <JY5320CoreOOAITask.h>

Public Member Functions

AIAnalogTrigger ()
AIAnalogTrigger (AIAnalogTriggerSource src, AIAnalogTriggerComparator comparator)
~AIAnalogTrigger ()

Public Attributes

AIAnalogTriggerSource Source
Analog Trigger source.
AIAnalogTriggerComparator Comparator
AI Analog Trigger Comparator.
AIAnalogEdgeComparator * Edge
AI Analog Edge Comparator.
AIAnalogHysteresisComparator * Hysteresis
AI Analog Hysteresis Comparatorr.
AIAnalogWindowComparator * Window
AI Analog Window Comparatorr.

Constructor & Destructor Documentation

◆ AIAnalogTrigger() [1/2]

JY5320CoreOO::AIAnalogTrigger::AIAnalogTrigger ( )

◆ AIAnalogTrigger() [2/2]

JY5320CoreOO::AIAnalogTrigger::AIAnalogTrigger | ( | AIAnalogTriggerSource | src,
 |  | AIAnalogTriggerComparator | comparator )

◆ ~AIAnalogTrigger()

JY5320CoreOO::AIAnalogTrigger::~AIAnalogTrigger ( )

Member Data Documentation

◆ Comparator

AIAnalogTriggerComparator JY5320CoreOO::AIAnalogTrigger::Comparator

AI Analog Trigger Comparator.

◆ Edge

AIAnalogEdgeComparator* JY5320CoreOO::AIAnalogTrigger::Edge

AI Analog Edge Comparator.

◆ Hysteresis

AIAnalogHysteresisComparator* JY5320CoreOO::AIAnalogTrigger::Hysteresis

AI Analog Hysteresis Comparatorr.

◆ Source

AIAnalogTriggerSource JY5320CoreOO::AIAnalogTrigger::Source

Analog Trigger source.

◆ Window

AIAnalogWindowComparator* JY5320CoreOO::AIAnalogTrigger::Window

AI Analog Window Comparatorr.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOAITask.h


5320 C++ Programming Manual: JY5320CoreOO::AIMultiChannelAnalogTrigger Class Reference

  • AIMultiChannelAnalogTrigger
Public Attributes | List of all members
JY5320CoreOO::AIMultiChannelAnalogTrigger Class Reference

#include <JY5320CoreOOAITask.h>

Public Attributes

MultiChannelCompositionLogic Logic
Multichannel composition logic, and / or.
std::list< AIAnalogTrigger > Analog
Analog Trigger Config.

Member Data Documentation

◆ Analog

std::list<AIAnalogTrigger> JY5320CoreOO::AIMultiChannelAnalogTrigger::Analog

Analog Trigger Config.

◆ Logic

MultiChannelCompositionLogic JY5320CoreOO::AIMultiChannelAnalogTrigger::Logic

Multichannel composition logic, and / or.

defalut or.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOAITask.h


5320 C++ Programming Manual: JY5320CoreOO::AISignalExport Class Reference

  • AISignalExport
Public Member Functions | List of all members
JY5320CoreOO::AISignalExport Class Reference

#include <JY5320CoreOOAITask.h>

Public Member Functions

void | Add (AISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (AISignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Member Function Documentation

◆ Add() [1/2]

void JY5320CoreOO::AISignalExport::Add | ( | AISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | AI Signal Source
destination | Export Desination

◆ Add() [2/2]

void JY5320CoreOO::AISignalExport::Add | ( | AISignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | AI Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JY5320CoreOO::AISignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5320CoreOO::AISignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOAITask.h


5320 C++ Programming Manual: JY5320CoreOO::AIRecord Class Reference

  • AIRecord
Public Attributes | List of all members
JY5320CoreOO::AIRecord Class Reference

#include <JY5320CoreOOAITask.h>

Public Attributes

std::string | FilePath
User specified file path.
FileFormat File_Format
Streaming file format.
RecordMode Mode
stream mode .
double | Length
User specified stream length in second.

Member Data Documentation

◆ File_Format

FileFormat JY5320CoreOO::AIRecord::File_Format

Streaming file format.

enum BIN.

◆ FilePath

std::string JY5320CoreOO::AIRecord::FilePath

User specified file path.

◆ Length

double JY5320CoreOO::AIRecord::Length

User specified stream length in second.

Only when Mode is RecordMode.Finite.

◆ Mode

RecordMode JY5320CoreOO::AIRecord::Mode

stream mode .

enum Finite/Infinite.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOAITask.h


5320 C++ Programming Manual: JY5320CoreOO::AIDSMode Class Reference

  • AIDSMode
Public Attributes | List of all members
JY5320CoreOO::AIDSMode Class Reference

#include <JY5320CoreOOAITask.h>

Public Attributes

bool Enable
Enable DSMode.

Member Data Documentation

◆ Enable

bool JY5320CoreOO::AIDSMode::Enable

Enable DSMode.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOAITask.h


5320 C++ Programming Manual: JY5320CoreOO::AIAdvanced Class Reference

  • AIAdvanced
Public Attributes | List of all members
JY5320CoreOO::AIAdvanced Class Reference

#include <JY5320CoreOOAITask.h>

Public Attributes

AIDSMode * DSMode
DSMode Config.

Member Data Documentation

◆ DSMode

AIDSMode* JY5320CoreOO::AIAdvanced::DSMode

DSMode Config.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOAITask.h


5320 C++ Programming Manual: JY5320CoreOO::AISync Class Reference

  • AISync
Public Attributes | List of all members
JY5320CoreOO::AISync Class Reference

Configure sync signal. More...

#include <JY5320CoreOOAITask.h>

Public Attributes

SyncTopology Topology
SyncTriggerRouting TriggerRouting
SyncPulseRouting PulseRouting

Detailed Description

Configure sync signal.

Member Data Documentation

◆ PulseRouting

SyncPulseRouting JY5320CoreOO::AISync::PulseRouting

◆ Topology

SyncTopology JY5320CoreOO::AISync::Topology

◆ TriggerRouting

SyncTriggerRouting JY5320CoreOO::AISync::TriggerRouting
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOAITask.h


5320 C++ Programming Manual: JY5320CoreOO Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Enumerations | Functions
JY5320CoreOO Namespace Reference

Classes

class | AIAdvanced
class | AIAnalogEdgeComparator
class | AIAnalogHysteresisComparator
class | AIAnalogTrigger
class | AIAnalogWindowComparator
class | AIChannel
class | AIDigitalTrigger
class | AIDSMode
class | AIExternalSampleClock
class | AIMultiChannelAnalogTrigger
class | AIRecord
class | AISampleClock
class | AISignalExport
class | AISync
Configure sync signal. More...
class | AITrigger
class | CIDigitalTrigger
CI Digital trigger . More...
class | CIExternalSampleClock
CI Implicit Sample Clock class. More...
class | CIExternalTimebase
class | CIImplicitSampleClock
CI Implicit Sample Clock class. More...
class | CIInternalSampleClock
CI Internal Sample Clock Configuration Class. More...
class | CISampleClock
CI Sample Clock class. More...
class | CISignalExport
CI Signal Export Class. More...
class | CITimebase
Timebase configuration class. More...
class | CITrigger
Constructor to create an CITrigger task object. More...
class | CODigitalTrigger
CO Digital trigger . More...
class | COExternalTimebase
class | COPulse
Pulse Parameter. More...
class | COSignalExport
CO Signal Export Class. More...
class | COTimebase
class | COTrigger
Constructor to create an COTrigger task object. More...
class | DIChannel
DI Channel parameter class . More...
class | DOChannel
DO Channel parameter class . More...
class | EdgeCounting
Configure CI EdgeCounting. More...
class | EdgeCountingOutEvent
Edge counting output event configuration class. More...
class | ExternalReferenceClock
External Reference Clcok Terminal. More...
class | FrequencyMeas
Configure CI Measure. More...
class | JY5320CoreOOAITask
aiTask类 More...
class | JY5320CoreOOCITask
class | JY5320CoreOOCOTask
class | JY5320CoreOODevice
class | JY5320CoreOODITask
class | JY5320CoreOODOTask
class | JY5320CoreOOLog
class | JY5320CoreOOProperty
属性模板类 More...
class | JY5320CoreOOReferenceClock
class | JYDriverException
class | PauseTrigger
Pause trigger configuration class. More...
class | PeriodMeas
Configure CI Measure. More...
class | PulseMeas
Configure CI Measure. More...
class | QuadEncoder
Configure CI Measure. More...
class | SemiPeriodMeas
class | TwoEdgeSeparation
Configure CI Measure. More...
class | TwoPulseEncoder
Configure CI Measure. More...

Enumerations

enum class | AIMode { Single = 0x2 , Finite = 0x0 , Continuous = 0x1 , Record = 0x3 }
enum class | AIBandWidth { _25KHz = JY5320Import::JY5320_AI_BandWidth_25K , _220KHz = JY5320Import::JY5320_AI_BandWidth_220K }
AI BandWidth. More...
enum class | MultiChannelCompositionLogic { Or = 0 , And = 1 }
Multichannel composition logic. More...
enum class | AISampleClockSource { Internal , External }
enum class AITriggerType {
Immediate = 0x0 , Digital = 0x1 , Analog = 0x2 , Soft = 0x3 ,
MultiChannelAanlog = 0x4
}
enum class | AITriggerMode { Start , Reference }
enum class AIAnalogTriggerSource {
Channel_0 , Channel_1 , Channel_2 , Channel_3 ,
Channel_4 , Channel_5 , Channel_6 , Channel_7 ,
Channel_8 , Channel_9 , Channel_10 , Channel_11 ,
Channel_12 , Channel_13 , Channel_14 , Channel_15 ,
Channel_16 , Channel_17 , Channel_18 , Channel_19 ,
Channel_20 , Channel_21 , Channel_22 , Channel_23 ,
Channel_24 , Channel_25 , Channel_26 , Channel_27 ,
Channel_28 , Channel_29 , Channel_30 , Channel_31
}
enum class AIDigitalTriggerSource {
PFI0 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_0 , PFI1 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_1 , PFI2 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_2 , PFI3 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_3 ,
PFI4 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_4 , PFI5 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_5 , PFI6 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_6 , PFI7 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_7 ,
PFI8 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_8 , PFI9 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_9 , PFI10 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_10 , PFI11 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_11 ,
PFI12 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_12 , PFI13 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_13 , PFI14 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_14 , PFI15 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_15 ,
PXI_Trig0 = (int)JY5320Import::JY5320_DigitalTriggerSource_PXI_0 , PXI_Trig1 = (int)JY5320Import::JY5320_DigitalTriggerSource_PXI_1 , PXI_Trig2 = (int)JY5320Import::JY5320_DigitalTriggerSource_PXI_2 , PXI_Trig3 = (int)JY5320Import::JY5320_DigitalTriggerSource_PXI_3 ,
PXI_Trig4 = (int)JY5320Import::JY5320_DigitalTriggerSource_PXI_4 , PXI_Trig5 = (int)JY5320Import::JY5320_DigitalTriggerSource_PXI_5 , PXI_Trig6 = (int)JY5320Import::JY5320_DigitalTriggerSource_PXI_6 , PXI_Trig7 = (int)JY5320Import::JY5320_DigitalTriggerSource_PXI_7 ,
CIO_0_StartTrig = (int)JY5320Import::JY5320_DigitalTriggerSource_Inter_CIO_0_StartTrig , CIO_1_StartTrig = (int)JY5320Import::JY5320_DigitalTriggerSource_Inter_CIO_1_StartTrig , CI_0_OutPut = (int)JY5320Import::JY5320_DigitalTriggerSource_Inter_Counter_0_Output , CI_1_OutPut = (int)JY5320Import::JY5320_DigitalTriggerSource_Inter_Counter_1_Output
}
enum class | AIDigitalTriggerEdge { Rising = 0x0 , Falling = 0x1 }
enum class | AIAnalogTriggerEdge { Rising = (int)JY5320Import::JY5320_AnalogTriggerEdge_RisingSlope , Falling = (int)JY5320Import::JY5320_AnalogTriggerEdge_FallingSlope }
enum class | AIAnalogWindowCondition { Entering = (int)JY5320Import::JY5320_AnalogTriggerCondition_EnteringWindow , Leaving = (int)JY5320Import::JY5320_AnaloglTriggerCondition_LeavingWindow }
AI Analog Window Trigger Condition. More...
enum class | AIAnalogTriggerComparator { Edge , Hysteresis , Window }
AI Analog Trigger Comparator. More...
enum class | AISignalExportSource { StartTrig = JY5320Import::JY5320_AI_StartTrig , ReferenceTrig = JY5320Import::JY5320_AI_ReferenceTrig , SampleClock = JY5320Import::JY5320_AI_SampleClock }
enum class | FileFormat { Bin }
enum class | RecordMode { Finite , Infinite }
enum class | SyncTopology { Independent , Master , Slave }
Synchronization board configuration. More...
enum class SyncTriggerRouting {
NONE = -1 , PFI0 = JY5320Import::JY5320_PFI0_OUT , PFI1 = JY5320Import::JY5320_PFI1_OUT , PFI2 = JY5320Import::JY5320_PFI2_OUT ,
PFI3 = JY5320Import::JY5320_PFI3_OUT , PFI4 = JY5320Import::JY5320_PFI4_OUT , PFI5 = JY5320Import::JY5320_PFI5_OUT , PFI6 = JY5320Import::JY5320_PFI6_OUT ,
PFI7 = JY5320Import::JY5320_PFI7_OUT , PFI8 = JY5320Import::JY5320_PFI8_OUT , PFI9 = JY5320Import::JY5320_PFI9_OUT , PFI10 = JY5320Import::JY5320_PFI10_OUT ,
PFI11 = JY5320Import::JY5320_PFI11_OUT , PFI12 = JY5320Import::JY5320_PFI12_OUT , PFI13 = JY5320Import::JY5320_PFI13_OUT , PFI14 = JY5320Import::JY5320_PFI14_OUT ,
PFI15 = JY5320Import::JY5320_PFI15_OUT , PXI_Trig0 = JY5320Import::JY5320_PXITrig0_OUT , PXI_Trig1 = JY5320Import::JY5320_PXITrig1_OUT , PXI_Trig2 = JY5320Import::JY5320_PXITrig2_OUT ,
PXI_Trig3 = JY5320Import::JY5320_PXITrig3_OUT , PXI_Trig4 = JY5320Import::JY5320_PXITrig4_OUT , PXI_Trig5 = JY5320Import::JY5320_PXITrig5_OUT , PXI_Trig6 = JY5320Import::JY5320_PXITrig6_OUT ,
PXI_Trig7 = JY5320Import::JY5320_PXITrig7_OUT
}
enum class SyncPulseRouting {
NONE = -1 , PFI0 = JY5320Import::JY5320_PFI0_OUT , PFI1 = JY5320Import::JY5320_PFI1_OUT , PFI2 = JY5320Import::JY5320_PFI2_OUT ,
PFI3 = JY5320Import::JY5320_PFI3_OUT , PFI4 = JY5320Import::JY5320_PFI4_OUT , PFI5 = JY5320Import::JY5320_PFI5_OUT , PFI6 = JY5320Import::JY5320_PFI6_OUT ,
PFI7 = JY5320Import::JY5320_PFI7_OUT , PFI8 = JY5320Import::JY5320_PFI8_OUT , PFI9 = JY5320Import::JY5320_PFI9_OUT , PFI10 = JY5320Import::JY5320_PFI10_OUT ,
PFI11 = JY5320Import::JY5320_PFI11_OUT , PFI12 = JY5320Import::JY5320_PFI12_OUT , PFI13 = JY5320Import::JY5320_PFI13_OUT , PFI14 = JY5320Import::JY5320_PFI14_OUT ,
PFI15 = JY5320Import::JY5320_PFI15_OUT , PXI_Trig0 = JY5320Import::JY5320_PXITrig0_OUT , PXI_Trig1 = JY5320Import::JY5320_PXITrig1_OUT , PXI_Trig2 = JY5320Import::JY5320_PXITrig2_OUT ,
PXI_Trig3 = JY5320Import::JY5320_PXITrig3_OUT , PXI_Trig4 = JY5320Import::JY5320_PXITrig4_OUT , PXI_Trig5 = JY5320Import::JY5320_PXITrig5_OUT , PXI_Trig6 = JY5320Import::JY5320_PXITrig6_OUT ,
PXI_Trig7 = JY5320Import::JY5320_PXITrig7_OUT
}
enum class | CountDirection { Up = 0x0 , Down = 0x1 , External = 0x2 }
Counter direction. More...
enum class | CIMode { Single = (int)JY5320Import::JY5320_CI_Single , Finite = (int)JY5320Import::JY5320_CI_Finite , Continuous = (int)JY5320Import::JY5320_CI_Continuous }
CIMode. More...
enum class CIType {
EdgeCounting , Period , Frequency , Pulse ,
SemiPeriod , TwoEdgeSeparation , QuadEncoder , TwoPulseEncoder
}
Counter Input Application Type. More...
enum class | CISampleClockSource { Implicit = 0x0 , Internal = 0x1 , External = 0x2 }
CI Sample Clock Source. More...
enum class | EdgeType { Rising , Falling }
Edge Type. More...
enum class | ValueReturnMode { TwoValue = (int)JY5320Import::JY5320_CI_ReturnTwoValue , OneValue = (int)JY5320Import::JY5320_CI_ReturnOneValue }
enum class | QuadEncodingType { X1 , X2 , X4 }
Quadrature Encoding Type. More...
enum class | CITriggerType { Immediate = 0x0 , Soft = 0x1 , Digital = 0x2 }
TriggerType Digital/Immediate/Soft. More...
enum class CIDigitalTriggerSource {
PFI0 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_0 , PFI1 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_1 , PFI2 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_2 , PFI3 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_3 ,
PFI4 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_4 , PFI5 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_5 , PFI6 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_6 , PFI7 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_7 ,
PFI8 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_8 , PFI9 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_9 , PFI10 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_10 , PFI11 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_11 ,
PFI12 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_12 , PFI13 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_13 , PFI14 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_14 , PFI15 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_15 ,
PXI_Trig0 = (int)JY5320Import::JY5320_DigitalTriggerSource_PXI_0 , PXI_Trig1 = (int)JY5320Import::JY5320_DigitalTriggerSource_PXI_1 , PXI_Trig2 = (int)JY5320Import::JY5320_DigitalTriggerSource_PXI_2 , PXI_Trig3 = (int)JY5320Import::JY5320_DigitalTriggerSource_PXI_3 ,
PXI_Trig4 = (int)JY5320Import::JY5320_DigitalTriggerSource_PXI_4 , PXI_Trig5 = (int)JY5320Import::JY5320_DigitalTriggerSource_PXI_5 , PXI_Trig6 = (int)JY5320Import::JY5320_DigitalTriggerSource_PXI_6 , PXI_Trig7 = (int)JY5320Import::JY5320_DigitalTriggerSource_PXI_7 ,
AI_StartTrig = (int)JY5320Import::JY5320_DigitalTriggerSource_Inter_AI_StartTrig , AI_ReferenceTrig = (int)JY5320Import::JY5320_DigitalTriggerSource_Inter_AI_ReferenceTrig , CI_0_StartTrig = (int)JY5320Import::JY5320_DigitalTriggerSource_Inter_CIO_0_StartTrig , CI_1_StartTrig = (int)JY5320Import::JY5320_DigitalTriggerSource_Inter_CIO_1_StartTrig ,
CI_0_OutPut = (int)JY5320Import::JY5320_DigitalTriggerSource_Inter_Counter_0_Output , CI_1_OutPut = (int)JY5320Import::JY5320_DigitalTriggerSource_Inter_Counter_1_Output
}
CI Digital trigger source. More...
enum class | CIDigitalTriggerEdge { Rising , Falling }
CI Digital Trigger Edge. More...
enum class InputTerminal {
PFI0 = (int)JY5320Import::JY5320_IN_PFI0 , PFI1 = (int)JY5320Import::JY5320_IN_PFI1 , PFI2 = (int)JY5320Import::JY5320_IN_PFI2 , PFI3 = (int)JY5320Import::JY5320_IN_PFI3 ,
PFI4 = (int)JY5320Import::JY5320_IN_PFI4 , PFI5 = (int)JY5320Import::JY5320_IN_PFI5 , PFI6 = (int)JY5320Import::JY5320_IN_PFI6 , PFI7 = (int)JY5320Import::JY5320_IN_PFI7 ,
PFI8 = (int)JY5320Import::JY5320_IN_PFI8 , PFI9 = (int)JY5320Import::JY5320_IN_PFI9 , PFI10 = (int)JY5320Import::JY5320_IN_PFI10 , PFI11 = (int)JY5320Import::JY5320_IN_PFI11 ,
PFI12 = (int)JY5320Import::JY5320_IN_PFI12 , PFI13 = (int)JY5320Import::JY5320_IN_PFI13 , PFI14 = (int)JY5320Import::JY5320_IN_PFI14 , PFI15 = (int)JY5320Import::JY5320_IN_PFI15 ,
PXI_Trig0 = (int)JY5320Import::JY5320_IN_PXI_Trig0 , PXI_Trig1 = (int)JY5320Import::JY5320_IN_PXI_Trig1 , PXI_Trig2 = (int)JY5320Import::JY5320_IN_PXI_Trig2 , PXI_Trig3 = (int)JY5320Import::JY5320_IN_PXI_Trig3 ,
PXI_Trig4 = (int)JY5320Import::JY5320_IN_PXI_Trig4 , PXI_Trig5 = (int)JY5320Import::JY5320_IN_PXI_Trig5 , PXI_Trig6 = (int)JY5320Import::JY5320_IN_PXI_Trig6 , PXI_Trig7 = (int)JY5320Import::JY5320_IN_PXI_Trig7 ,
AI_SampleClock = (int)JY5320Import::JY5320_IN_AI_SampleClock , CI_0_OutPut = (int)JY5320Import::JY5320_IN_CO_0_Output , CI_1_OutPut = (int)JY5320Import::JY5320_IN_CO_1_Output , Timebase_100MHz = (int)JY5320Import::JY5320_IN_CIO_100MHz ,
Timebase_5MHz = (int)JY5320Import::JY5320_IN_CIO_5MHz , Timebase_100kHz = (int)JY5320Import::JY5320_IN_CIO_100kHz
}
enum class | EdgeCntOunEvtIdleState { LowLevel = 0 , HighLevel = 1 }
Output idle state when the event has not occurred. More...
enum class | CISignalExportSource { StartTrig , SampleClock }
SourceSignal. More...
enum class | CITimebaseSource { Internal100MHz = (int)JY5320Import::JY5320_Internal_Timebase_100M , Internal5MHz = (int)JY5320Import::JY5320_Internal_Timebase_5M , Internal100kHz = (int)JY5320Import::JY5320_Internal_Timebase_100K , External = (int)JY5320Import::JY5320_External_Timebase }
Timebase source. More...
enum class | JY5320CoreOOPropertyType { READ_ONLY = 1 , WRITE_ONLY = 2 , READ_WRITE = 3 }
enum class JYDriverExceptionPublic {
UnKnown = 0 , OpenDeviceFailed = -10001 , CloseDeviceFailed = -10002 , ResetDeviceFailed = -10003 ,
GetDevicePropertyFailed = -10004 , SetDevicePropertyFailed = -10005 , HardwareResourceIsReserved = -10006 , MethodNotPermitedToCallWhenCurrentStatus = -10007 ,
InvalidUserDataBuffer = -10008 , NoChannelAdded = -10009 , NotSupportOperationForCurrentDevice = -10010 , CreatTaskFailed = -10100 ,
StartTaskFailed = -10101 , StopTaskFailed = -10102 , TaskHasNotStarted = -10103 , TaskHasStartedCannotPerformTheSetOperation = -10104 ,
ChannelNumberParameterInvalid = -10105 , ChannelInputRangeParameterInvalid = -10106 , ChannelTerminalParameterInvalid = -10107 , ChannelCouplingParameterInvalid = -10108 ,
SampeleModeParameterInvalid = -10109 , SampleClockParameterInvalid = -10110 , SampleRateParameterInvalid = -10111 , UpdateRateParameterInvalid = -10112 ,
TriggerParameterInvalid = -10113 , ReferenceTriggerDoesNotMatchWithSampleMode = -10114 , PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint = -10115 , ReadDataFailed = -10016 ,
ReadDataTimeout = -10017 , WriteDataFailed = -10018 , WriteDataTimeout = -10019 , WriteDataLengthCannotBeLessThanN = -10020 ,
BufferDataOverflow = -10021 , BufferDataDownflow = -10022 , CheckBufferFailed = -10023 , PointInvalidInFiniteMode = -10024 ,
ReadPointInvalid = -10025 , OnlySupportRecordMode = -10026 , SendSoftTirggerFailed = -10027 , TaskTimeout = -10028 ,
CounterParametersInvalid = -10029 , WritePointInvalid = -10030 , SignalExportDestinationInvalid = -10031 , InvalidParameter = -10033
}
enum class ClockTerminal {
PFI0 = JY5320Import::JY5320_Clock_PFI_0 , PFI1 = JY5320Import::JY5320_Clock_PFI_1 , PFI2 = JY5320Import::JY5320_Clock_PFI_2 , PFI3 = JY5320Import::JY5320_Clock_PFI_3 ,
PFI4 = JY5320Import::JY5320_Clock_PFI_4 , PFI5 = JY5320Import::JY5320_Clock_PFI_5 , PFI6 = JY5320Import::JY5320_Clock_PFI_6 , PFI7 = JY5320Import::JY5320_Clock_PFI_7 ,
PFI8 = JY5320Import::JY5320_Clock_PFI_8 , PFI9 = JY5320Import::JY5320_Clock_PFI_9 , PFI10 = JY5320Import::JY5320_Clock_PFI_10 , PFI11 = JY5320Import::JY5320_Clock_PFI_11 ,
PFI12 = JY5320Import::JY5320_Clock_PFI_12 , PFI13 = JY5320Import::JY5320_Clock_PFI_13 , PFI14 = JY5320Import::JY5320_Clock_PFI_14 , PFI15 = JY5320Import::JY5320_Clock_PFI_15 ,
PXI_Trig0 = JY5320Import::JY5320_Clock_PXI_Trig_0 , PXI_Trig1 = JY5320Import::JY5320_Clock_PXI_Trig_1 , PXI_Trig2 = JY5320Import::JY5320_Clock_PXI_Trig_2 , PXI_Trig3 = JY5320Import::JY5320_Clock_PXI_Trig_3 ,
PXI_Trig4 = JY5320Import::JY5320_Clock_PXI_Trig_4 , PXI_Trig5 = JY5320Import::JY5320_Clock_PXI_Trig_5 , PXI_Trig6 = JY5320Import::JY5320_Clock_PXI_Trig_6 , PXI_Trig7 = JY5320Import::JY5320_Clock_PXI_Trig_7 ,
AI_SampleClock = JY5320Import::JY5320_Inter_AI_SampleClock , CI0_SampleClock = JY5320Import::JY5320_Inter_CI_0_SampleClock , CI1_SampleClock = JY5320Import::JY5320_Inter_CI_1_SampleClock , CO0_Output = JY5320Import::JY5320_Inter_CO_0_Output ,
CO1_Output = JY5320Import::JY5320_Inter_CO_1_Output
}
enum class IOTerminal {
PFI0 = JY5320Import::JY5320_IN_PFI0 , PFI1 = JY5320Import::JY5320_IN_PFI1 , PFI2 = JY5320Import::JY5320_IN_PFI2 , PFI3 = JY5320Import::JY5320_IN_PFI3 ,
PFI4 = JY5320Import::JY5320_IN_PFI4 , PFI5 = JY5320Import::JY5320_IN_PFI5 , PFI6 = JY5320Import::JY5320_IN_PFI6 , PFI7 = JY5320Import::JY5320_IN_PFI7 ,
PFI8 = JY5320Import::JY5320_IN_PFI8 , PFI9 = JY5320Import::JY5320_IN_PFI9 , PFI10 = JY5320Import::JY5320_IN_PFI10 , PFI11 = JY5320Import::JY5320_IN_PFI11 ,
PFI12 = JY5320Import::JY5320_IN_PFI12 , PFI13 = JY5320Import::JY5320_IN_PFI13 , PFI14 = JY5320Import::JY5320_IN_PFI14 , PFI15 = JY5320Import::JY5320_IN_PFI15 ,
PXI_Trig0 = JY5320Import::JY5320_IN_PXI_Trig0 , PXI_Trig1 = JY5320Import::JY5320_IN_PXI_Trig1 , PXI_Trig2 = JY5320Import::JY5320_IN_PXI_Trig2 , PXI_Trig3 = JY5320Import::JY5320_IN_PXI_Trig3 ,
PXI_Trig4 = JY5320Import::JY5320_IN_PXI_Trig4 , PXI_Trig5 = JY5320Import::JY5320_IN_PXI_Trig5 , PXI_Trig6 = JY5320Import::JY5320_IN_PXI_Trig6 , PXI_Trig7 = JY5320Import::JY5320_IN_PXI_Trig7 ,
None = 25
}
enum class SignalExportDestination {
PFI0 = JY5320Import::JY5320_PFI0_OUT , PFI1 = JY5320Import::JY5320_PFI1_OUT , PFI2 = JY5320Import::JY5320_PFI2_OUT , PFI3 = JY5320Import::JY5320_PFI3_OUT ,
PFI4 = JY5320Import::JY5320_PFI4_OUT , PFI5 = JY5320Import::JY5320_PFI5_OUT , PFI6 = JY5320Import::JY5320_PFI6_OUT , PFI7 = JY5320Import::JY5320_PFI7_OUT ,
PFI8 = JY5320Import::JY5320_PFI8_OUT , PFI9 = JY5320Import::JY5320_PFI9_OUT , PFI10 = JY5320Import::JY5320_PFI10_OUT , PFI11 = JY5320Import::JY5320_PFI11_OUT ,
PFI12 = JY5320Import::JY5320_PFI12_OUT , PFI13 = JY5320Import::JY5320_PFI13_OUT , PFI14 = JY5320Import::JY5320_PFI14_OUT , PFI15 = JY5320Import::JY5320_PFI15_OUT ,
PXI_Trig0 = JY5320Import::JY5320_PXITrig0_OUT , PXI_Trig1 = JY5320Import::JY5320_PXITrig1_OUT , PXI_Trig2 = JY5320Import::JY5320_PXITrig2_OUT , PXI_Trig3 = JY5320Import::JY5320_PXITrig3_OUT ,
PXI_Trig4 = JY5320Import::JY5320_PXITrig4_OUT , PXI_Trig5 = JY5320Import::JY5320_PXITrig5_OUT , PXI_Trig6 = JY5320Import::JY5320_PXITrig6_OUT , PXI_Trig7 = JY5320Import::JY5320_PXITrig7_OUT
}
enum class | OutputCompleteState { Zero , Hold }
Output Complete State. More...
enum class | LevelPolarity { LowLevel = 0 , HighLevel = 1 , None = 2 }
Level Polarity. More...
enum class | COIdleState { HighLevel = 0x1 , LowLevel = 0x0 }
Idle state when pulse output before start and after stop. More...
enum class | COMode { Single = 3 , Finite = 0 , ContinuousNoWrapping = 2 , ContinuousWrapping = 1 }
enum class | COTriggerType { Immediate = JY5320Import::JY5320_CIO_Immediately , Soft = JY5320Import::JY5320_CIO_Soft , Digital = JY5320Import::JY5320_CIO_Digital }
TriggerType Digital/Immediate/Soft. More...
enum class CODigitalTriggerSource {
PFI0 = JY5320Import::JY5320_DigitalTriggerSource_PFI_0 , PFI1 = JY5320Import::JY5320_DigitalTriggerSource_PFI_1 , PFI2 = JY5320Import::JY5320_DigitalTriggerSource_PFI_2 , PFI3 = JY5320Import::JY5320_DigitalTriggerSource_PFI_3 ,
PFI4 = JY5320Import::JY5320_DigitalTriggerSource_PFI_4 , PFI5 = JY5320Import::JY5320_DigitalTriggerSource_PFI_5 , PFI6 = JY5320Import::JY5320_DigitalTriggerSource_PFI_6 , PFI7 = JY5320Import::JY5320_DigitalTriggerSource_PFI_7 ,
PFI8 = JY5320Import::JY5320_DigitalTriggerSource_PFI_8 , PFI9 = JY5320Import::JY5320_DigitalTriggerSource_PFI_9 , PFI10 = JY5320Import::JY5320_DigitalTriggerSource_PFI_10 , PFI11 = JY5320Import::JY5320_DigitalTriggerSource_PFI_11 ,
PFI12 = JY5320Import::JY5320_DigitalTriggerSource_PFI_12 , PFI13 = JY5320Import::JY5320_DigitalTriggerSource_PFI_13 , PFI14 = JY5320Import::JY5320_DigitalTriggerSource_PFI_14 , PFI15 = JY5320Import::JY5320_DigitalTriggerSource_PFI_15 ,
PXI_Trig0 = JY5320Import::JY5320_DigitalTriggerSource_PXI_0 , PXI_Trig1 = JY5320Import::JY5320_DigitalTriggerSource_PXI_1 , PXI_Trig2 = JY5320Import::JY5320_DigitalTriggerSource_PXI_2 , PXI_Trig3 = JY5320Import::JY5320_DigitalTriggerSource_PXI_3 ,
PXI_Trig4 = JY5320Import::JY5320_DigitalTriggerSource_PXI_4 , PXI_Trig5 = JY5320Import::JY5320_DigitalTriggerSource_PXI_5 , PXI_Trig6 = JY5320Import::JY5320_DigitalTriggerSource_PXI_6 , PXI_Trig7 = JY5320Import::JY5320_DigitalTriggerSource_PXI_7 ,
AI_StartTrig = JY5320Import::JY5320_DigitalTriggerSource_Inter_AI_StartTrig , AI_ReferenceTrig = JY5320Import::JY5320_DigitalTriggerSource_Inter_AI_ReferenceTrig , CI_0_StartTrig = JY5320Import::JY5320_DigitalTriggerSource_Inter_CIO_0_StartTrig , CI_1_StartTrig = JY5320Import::JY5320_DigitalTriggerSource_Inter_CIO_1_StartTrig ,
CI_0_OutPut = JY5320Import::JY5320_DigitalTriggerSource_Inter_Counter_0_Output , CI_1_OutPut = JY5320Import::JY5320_DigitalTriggerSource_Inter_Counter_1_Output
}
CO Digital trigger source. More...
enum class | CODigitalTriggerEdge { Rising , Falling }
CO Digital Trigger Edge. More...
enum class | COPulseType { DutyCycleFrequency , HighLowTime , HighLowTick }
Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick. More...
enum class | COTimebaseSource { Internal100MHz = 0 , Internal5MHz = 1 , Internal100kHz = 2 , External = 3 }
Timebase source. More...
enum class | COSignalExportSource { StartTrig , Output }
SourceSignal. More...
enum class | ExternalReferenceClockTerminal { PXIe_Clk100 = 0x1 }
enum class CounterInterface {
Source , Gate , Aux , SampleClock ,
Out
}
enum class | ReferenceClockSource { Internal = 0x0 , External = 0x1 }
enum class | DISampleClockSource { Internal , External }
DI Sample Clock Source. More...
enum class JY5320CoreOOLogLevel {
DEBUG_LOG_LEVEL , INFO_LOG_LEVEL , WARN_LOG_LEVEL , ERROR_LOG_LEVEL ,
FATAL_LOG_LEVEL
}

Functions

std::string GetSignalExportDestinationString (SignalExportDestination destination)

Enumeration Type Documentation

◆ AIAnalogTriggerComparator

enum class JY5320CoreOO::AIAnalogTriggerComparator
strong

AI Analog Trigger Comparator.

Enumerator
Edge | Edge Comparator.
Hysteresis | Hysteresis Comparator.
Window | Window Comparator.

◆ AIAnalogTriggerEdge

enum class JY5320CoreOO::AIAnalogTriggerEdge
strong
Enumerator
Rising | Rising.
Falling | Falling.

◆ AIAnalogTriggerSource

enum class JY5320CoreOO::AIAnalogTriggerSource
strong
Enumerator
Channel_0 | channel 0
Channel_1 | channel 1
Channel_2 | channel 2
Channel_3 | channel 3
Channel_4 | channel 4
Channel_5 | channel 5
Channel_6 | channel 6
Channel_7 | channel 7
Channel_8 | channel 8
Channel_9 | channel 9
Channel_10 | channel 10
Channel_11 | channel 11
Channel_12 | channel 12
Channel_13 | channel 13
Channel_14 | channel 14
Channel_15 | channel 15
Channel_16 | channel 16
Channel_17 | channel 17
Channel_18 | channel 18
Channel_19 | channel 19
Channel_20 | channel 20
Channel_21 | channel 21
Channel_22 | channel 22
Channel_23 | channel 23
Channel_24 | channel 24
Channel_25 | channel 25
Channel_26 | channel 26
Channel_27 | channel 27
Channel_28 | channel 28
Channel_29 | channel 29
Channel_30 | channel 30
Channel_31 | channel 31

◆ AIAnalogWindowCondition

enum class JY5320CoreOO::AIAnalogWindowCondition
strong

AI Analog Window Trigger Condition.

Enumerator
Entering | Rising.
Leaving | Falling.

◆ AIBandWidth

enum class JY5320CoreOO::AIBandWidth
strong

AI BandWidth.

Enumerator
_25KHz | 25KHz BandWidth
_220KHz | 220KHz BandWidth

◆ AIDigitalTriggerEdge

enum class JY5320CoreOO::AIDigitalTriggerEdge
strong
Enumerator
Rising | Rising.
Falling | Falling.

◆ AIDigitalTriggerSource

enum class JY5320CoreOO::AIDigitalTriggerSource
strong
Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PFI8 | PFI_8.
PFI9 | PFI_9.
PFI10 | PFI_10.
PFI11 | PFI_11.
PFI12 | PFI_12.
PFI13 | PFI_13.
PFI14 | PFI_14.
PFI15 | PFI_15.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
CIO_0_StartTrig | CI0_StartTrig.
CIO_1_StartTrig | CI1_StartTrig.
CI_0_OutPut | CI0_StartTrig.
CI_1_OutPut | CI1_StartTrig.

◆ AIMode

enum class JY5320CoreOO::AIMode
strong
Enumerator
Single
Finite
Continuous
Record

◆ AISampleClockSource

enum class JY5320CoreOO::AISampleClockSource
strong
Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ AISignalExportSource

enum class JY5320CoreOO::AISignalExportSource
strong
Enumerator
StartTrig | AI_StartTrig.
ReferenceTrig | AI_ReferenceTrig.
SampleClock | AI_SampleClock.

◆ AITriggerMode

enum class JY5320CoreOO::AITriggerMode
strong
Enumerator
Start | Start Trigger.
Reference | Reference Trigger，Valid when JY5320aiTask.Mode is AIMode.Finite

◆ AITriggerType

enum class JY5320CoreOO::AITriggerType
strong
Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Analog | Analog Trigger.
Soft | Soft Trigger.
MultiChannelAanlog | Multi Channel Aanlog Trigger.

◆ CIDigitalTriggerEdge

enum class JY5320CoreOO::CIDigitalTriggerEdge
strong

CI Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ CIDigitalTriggerSource

enum class JY5320CoreOO::CIDigitalTriggerSource
strong

CI Digital trigger source.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PFI8 | PFI_8.
PFI9 | PFI_9.
PFI10 | PFI_10.
PFI11 | PFI_11.
PFI12 | PFI_12.
PFI13 | PFI_13.
PFI14 | PFI_14.
PFI15 | PFI_15.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
CI_0_StartTrig | CI0_StartTrig.
CI_1_StartTrig | CI1_StartTrig.
CI_0_OutPut | CI0_StartTrig.
CI_1_OutPut | CI1_StartTrig.

◆ CIMode

enum class JY5320CoreOO::CIMode
strong

CIMode.

Enumerator
Single | Single.
Finite | Finite.
Continuous | Continuous.

◆ CISampleClockSource

enum class JY5320CoreOO::CISampleClockSource
strong

CI Sample Clock Source.

Enumerator
Implicit | Implicit.
Internal | Internal.
External | External.

◆ CISignalExportSource

enum class JY5320CoreOO::CISignalExportSource
strong

SourceSignal.

Enumerator
StartTrig | CI_StartTrig.
SampleClock | CI_SampleClock.

◆ CITimebaseSource

enum class JY5320CoreOO::CITimebaseSource
strong

Timebase source.

Enumerator
Internal100MHz | 内部100MHz时基 Internal 100MHz Timebase
Internal5MHz | 内部5MHz时基 Internal 5MHz Timebase
Internal100kHz | 内部100kHz时基 Internal 100kHz Timebase
External | 外部时基 External Timebase

◆ CITriggerType

enum class JY5320CoreOO::CITriggerType
strong

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Soft | Digital Trigger.
Digital | Soft Trigger.

◆ CIType

enum class JY5320CoreOO::CIType
strong

Counter Input Application Type.

Enumerator
EdgeCounting | Edge Counting.
Period | Period Measure.
Frequency | Frequenc Measure.
Pulse | Pulse Measure.
SemiPeriod | SemiPeriod Measure.
TwoEdgeSeparation | TwoEdgeSeparation Measure.
QuadEncoder | QuadEncoder.
TwoPulseEncoder | EncoderTwoPulse.

◆ ClockTerminal

enum class JY5320CoreOO::ClockTerminal
strong
Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PFI8 | PFI_8.
PFI9 | PFI_9.
PFI10 | PFI_10.
PFI11 | PFI_11.
PFI12 | PFI_12.
PFI13 | PFI_13.
PFI14 | PFI_14.
PFI15 | PFI_15.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
AI_SampleClock | AI_SampleClock.
CI0_SampleClock | AI_SampleClock.
CI1_SampleClock | AI_SampleClock.
CO0_Output | AI_SampleClock.
CO1_Output | AI_SampleClock.

◆ CODigitalTriggerEdge

enum class JY5320CoreOO::CODigitalTriggerEdge
strong

CO Digital Trigger Edge.

Enumerator
Rising | Rising Edge.
Falling | Falling Edge.

◆ CODigitalTriggerSource

enum class JY5320CoreOO::CODigitalTriggerSource
strong

CO Digital trigger source.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PFI8 | PFI_8.
PFI9 | PFI_9.
PFI10 | PFI_10.
PFI11 | PFI_11.
PFI12 | PFI_12.
PFI13 | PFI_13.
PFI14 | PFI_14.
PFI15 | PFI_15.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
CI_0_StartTrig | CI0_StartTrig.
CI_1_StartTrig | CI1_StartTrig.
CI_0_OutPut | CI0_StartTrig.
CI_1_OutPut | CI1_StartTrig.

◆ COIdleState

enum class JY5320CoreOO::COIdleState
strong

Idle state when pulse output before start and after stop.

Enumerator
HighLevel | Idle state is high level.
LowLevel | Idle state is low level.

◆ COMode

enum class JY5320CoreOO::COMode
strong
Enumerator
Single | Single pulse output.
Finite | Finite.
ContinuousNoWrapping | ContinuousNoWrapping.
ContinuousWrapping | ContinuousWrapping.

◆ COPulseType

enum class JY5320CoreOO::COPulseType
strong

Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick.

Enumerator
DutyCycleFrequency | Configure CO output pulse according to its DutyCycle and Freqency.
HighLowTime | Configure CO output pulse according to duration of its high/low voltage levels.
HighLowTick | Configure CO output pulse according to its high/low tick level.

◆ COSignalExportSource

enum class JY5320CoreOO::COSignalExportSource
strong

SourceSignal.

Enumerator
StartTrig | CI_StartTrig.
Output | CO_Output.

◆ COTimebaseSource

enum class JY5320CoreOO::COTimebaseSource
strong

Timebase source.

Enumerator
Internal100MHz | 内部100MHz时基 Internal 100MHz Timebase
Internal5MHz | 内部5MHz时基 Internal 5MHz Timebase
Internal100kHz | 内部100kHz时基 Internal 100kHz Timebase
External | 外部时基 External Timebase

◆ COTriggerType

enum class JY5320CoreOO::COTriggerType
strong

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Soft | Soft Trigger.
Digital | Digital Trigger.

◆ CountDirection

enum class JY5320CoreOO::CountDirection
strong

Counter direction.

enum Up/Down/External

Enumerator
Up | Counter increases.
Down | Counter decreases.
External | External signal control counter direction. If External signal is highlevel counter increases, or lowlevel counter decreases.

◆ CounterInterface

enum class JY5320CoreOO::CounterInterface
strong
Enumerator
Source
Gate
Aux
SampleClock
Out

◆ DISampleClockSource

enum class JY5320CoreOO::DISampleClockSource
strong

DI Sample Clock Source.

Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ EdgeCntOunEvtIdleState

enum class JY5320CoreOO::EdgeCntOunEvtIdleState
strong

Output idle state when the event has not occurred.

Enumerator
LowLevel | Idle state is low level.
HighLevel | Idle state is high level.

◆ EdgeType

enum class JY5320CoreOO::EdgeType
strong

Edge Type.

Enumerator
Rising | Rising Edge.
Falling | Falling Edge.

◆ ExternalReferenceClockTerminal

enum class JY5320CoreOO::ExternalReferenceClockTerminal
strong
Enumerator
PXIe_Clk100

PXIe_Clk100.

◆ FileFormat

enum class JY5320CoreOO::FileFormat
strong
Enumerator
Bin

BIN。

BIN.

◆ InputTerminal

enum class JY5320CoreOO::InputTerminal
strong
Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PFI8 | PFI_8.
PFI9 | PFI_9.
PFI10 | PFI_10.
PFI11 | PFI_11.
PFI12 | PFI_12.
PFI13 | PFI_13.
PFI14 | PFI_14.
PFI15 | PFI_15.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
AI_SampleClock | PXI Trig 7.
CI_0_OutPut | CI0_StartTrig.
CI_1_OutPut | CI1_StartTrig.
Timebase_100MHz | Timebase_100MHz.
Timebase_5MHz | Timebase_5MHz.
Timebase_100kHz | Timebase_100kHz.

◆ IOTerminal

enum class JY5320CoreOO::IOTerminal
strong
Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PFI8 | PFI_8.
PFI9 | PFI_9.
PFI10 | PFI_10.
PFI11 | PFI_11.
PFI12 | PFI_12.
PFI13 | PFI_13.
PFI14 | PFI_14.
PFI15 | PFI_15.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
None | None.

◆ JY5320CoreOOLogLevel

enum class JY5320CoreOO::JY5320CoreOOLogLevel
strong
Enumerator
DEBUG_LOG_LEVEL
INFO_LOG_LEVEL
WARN_LOG_LEVEL
ERROR_LOG_LEVEL
FATAL_LOG_LEVEL

◆ JY5320CoreOOPropertyType

enum class JY5320CoreOO::JY5320CoreOOPropertyType
strong
Enumerator
READ_ONLY
WRITE_ONLY
READ_WRITE

◆ JYDriverExceptionPublic

enum class JY5320CoreOO::JYDriverExceptionPublic
strong
Enumerator
UnKnown | JYDriverExceptionPublic.
OpenDeviceFailed | JYDriverExceptionPublic.
CloseDeviceFailed | JYDriverExceptionPublic.
ResetDeviceFailed | JYDriverExceptionPublic.
GetDevicePropertyFailed | JYDriverExceptionPublic.
SetDevicePropertyFailed | JYDriverExceptionPublic.
HardwareResourceIsReserved | JYDriverExceptionPublic.
MethodNotPermitedToCallWhenCurrentStatus | JYDriverExceptionPublic.
InvalidUserDataBuffer | JYDriverExceptionPublic.
NoChannelAdded | JYDriverExceptionPublic.
NotSupportOperationForCurrentDevice | JYDriverExceptionPublic.
CreatTaskFailed | JYDriverExceptionPublic.
StartTaskFailed | JYDriverExceptionPublic.
StopTaskFailed | JYDriverExceptionPublic.
TaskHasNotStarted | JYDriverExceptionPublic.
TaskHasStartedCannotPerformTheSetOperation | JYDriverExceptionPublic.
ChannelNumberParameterInvalid | JYDriverExceptionPublic.
ChannelInputRangeParameterInvalid | JYDriverExceptionPublic.
ChannelTerminalParameterInvalid | JYDriverExceptionPublic.
ChannelCouplingParameterInvalid | JYDriverExceptionPublic.
SampeleModeParameterInvalid | JYDriverExceptionPublic.
SampleClockParameterInvalid | JYDriverExceptionPublic.
SampleRateParameterInvalid | JYDriverExceptionPublic.
UpdateRateParameterInvalid | JYDriverExceptionPublic.
TriggerParameterInvalid | JYDriverExceptionPublic.
ReferenceTriggerDoesNotMatchWithSampleMode | JYDriverExceptionPublic.
PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint | JYDriverExceptionPublic.
ReadDataFailed | JYDriverExceptionPublic.
ReadDataTimeout | JYDriverExceptionPublic.
WriteDataFailed | JYDriverExceptionPublic.
WriteDataTimeout | JYDriverExceptionPublic.
WriteDataLengthCannotBeLessThanN | JYDriverExceptionPublic.
BufferDataOverflow | JYDriverExceptionPublic.
BufferDataDownflow | JYDriverExceptionPublic.
CheckBufferFailed | JYDriverExceptionPublic.
PointInvalidInFiniteMode | JYDriverExceptionPublic.
ReadPointInvalid | JYDriverExceptionPublic.
OnlySupportRecordMode | JYDriverExceptionPublic.
SendSoftTirggerFailed | JYDriverExceptionPublic.
TaskTimeout | JYDriverExceptionPublic.
CounterParametersInvalid | JYDriverExceptionPublic.
WritePointInvalid | JYDriverExceptionPublic.
SignalExportDestinationInvalid | JYDriverExceptionPublic.
InvalidParameter | 无效参数。 Invalid parameter.

◆ LevelPolarity

enum class JY5320CoreOO::LevelPolarity
strong

Level Polarity.

Enumerator
LowLevel | Low level.
HighLevel | High level.
None | No active polarity.

◆ MultiChannelCompositionLogic

enum class JY5320CoreOO::MultiChannelCompositionLogic
strong

Multichannel composition logic.

Enumerator
Or | Multichannel result take or.
And | Multichannel results take and.

◆ OutputCompleteState

enum class JY5320CoreOO::OutputCompleteState
strong

Output Complete State.

Enumerator
Zero | Output Complete Zero.
Hold | Output Complete Hold in The last point.

◆ QuadEncodingType

enum class JY5320CoreOO::QuadEncodingType
strong

Quadrature Encoding Type.

Enumerator
X1 | X1.
X2 | X2.
X4 | X4.

◆ RecordMode

enum class JY5320CoreOO::RecordMode
strong
Enumerator
Finite | Finite Streaming.
Infinite | Infinite Streaming.

◆ ReferenceClockSource

enum class JY5320CoreOO::ReferenceClockSource
strong
Enumerator
Internal | Internal on board 25MHz Clock.
External | External Reference Clock Source.

◆ SignalExportDestination

enum class JY5320CoreOO::SignalExportDestination
strong
Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PFI8 | PFI_8.
PFI9 | PFI_9.
PFI10 | PFI_10.
PFI11 | PFI_11.
PFI12 | PFI_12.
PFI13 | PFI_13.
PFI14 | PFI_14.
PFI15 | PFI_15.
PXI_Trig0 | PXI Trig0.
PXI_Trig1 | PXI Trig1.
PXI_Trig2 | PXI Trig2.
PXI_Trig3 | PXI Trig3.
PXI_Trig4 | PXI Trig4.
PXI_Trig5 | PXI Trig5.
PXI_Trig6 | PXI Trig6.
PXI_Trig7 | PXI Trig7.

◆ SyncPulseRouting

enum class JY5320CoreOO::SyncPulseRouting
strong
Enumerator
NONE | Default NONE.
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PFI8 | PFI_8.
PFI9 | PFI_9.
PFI10 | PFI_10.
PFI11 | PFI_11.
PFI12 | PFI_12.
PFI13 | PFI_13.
PFI14 | PFI_14.
PFI15 | PFI_15.
PXI_Trig0 | PXI Trig0.
PXI_Trig1 | PXI Trig1.
PXI_Trig2 | PXI Trig2.
PXI_Trig3 | PXI Trig3.
PXI_Trig4 | PXI Trig4.
PXI_Trig5 | PXI Trig5.
PXI_Trig6 | PXI Trig6.
PXI_Trig7 | PXI Trig7.

◆ SyncTopology

enum class JY5320CoreOO::SyncTopology
strong

Synchronization board configuration.

Enumerator
Independent | Independent, synchronization not supported
Master | master card
Slave | slave card

◆ SyncTriggerRouting

enum class JY5320CoreOO::SyncTriggerRouting
strong
Enumerator
NONE | Default NONE.
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PFI8 | PFI_8.
PFI9 | PFI_9.
PFI10 | PFI_10.
PFI11 | PFI_11.
PFI12 | PFI_12.
PFI13 | PFI_13.
PFI14 | PFI_14.
PFI15 | PFI_15.
PXI_Trig0 | PXI Trig0.
PXI_Trig1 | PXI Trig1.
PXI_Trig2 | PXI Trig2.
PXI_Trig3 | PXI Trig3.
PXI_Trig4 | PXI Trig4.
PXI_Trig5 | PXI Trig5.
PXI_Trig6 | PXI Trig6.
PXI_Trig7 | PXI Trig7.

◆ ValueReturnMode

enum class JY5320CoreOO::ValueReturnMode
strong
Enumerator
TwoValue | Return two data simultaneously. first data is gate to aux edge separation, second data is aux to gate edge separation.
OneValue | only return gate to aux edge separation

Function Documentation

◆ GetSignalExportDestinationString()

std::string JY5320CoreOO::GetSignalExportDestinationString ( SignalExportDestination destination )
inline


5320 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOCITask.h File Reference

  • File List
  • File Members
  • COO
  • 5320
Classes | Namespaces | Macros | Enumerations
JY5320CoreOOCITask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JY5320CoreOOCommon.h"
#include "JY5320CoreOODevice.h"

Classes

class | JY5320CoreOO::JY5320CoreOOCITask
class | JY5320CoreOO::CIInternalSampleClock
CI Internal Sample Clock Configuration Class. More...
class | JY5320CoreOO::CIImplicitSampleClock
CI Implicit Sample Clock class. More...
class | JY5320CoreOO::CIExternalSampleClock
CI Implicit Sample Clock class. More...
class | JY5320CoreOO::CISampleClock
CI Sample Clock class. More...
class | JY5320CoreOO::EdgeCounting
Configure CI EdgeCounting. More...
class | JY5320CoreOO::FrequencyMeas
Configure CI Measure. More...
class | JY5320CoreOO::PeriodMeas
Configure CI Measure. More...
class | JY5320CoreOO::PulseMeas
Configure CI Measure. More...
class | JY5320CoreOO::SemiPeriodMeas
class | JY5320CoreOO::TwoEdgeSeparation
Configure CI Measure. More...
class | JY5320CoreOO::QuadEncoder
Configure CI Measure. More...
class | JY5320CoreOO::TwoPulseEncoder
Configure CI Measure. More...
class | JY5320CoreOO::CITrigger
Constructor to create an CITrigger task object. More...
class | JY5320CoreOO::CIDigitalTrigger
CI Digital trigger . More...
class | JY5320CoreOO::EdgeCountingOutEvent
Edge counting output event configuration class. More...
class | JY5320CoreOO::CIExternalTimebase
class | JY5320CoreOO::CITimebase
Timebase configuration class. More...
class | JY5320CoreOO::CISignalExport
CI Signal Export Class. More...

Namespaces

namespace JY5320CoreOO

Macros

#define __JY5320_CORE_OO_CITASK_H__

Enumerations

enum class | JY5320CoreOO::CountDirection { JY5320CoreOO::Up = 0x0 , JY5320CoreOO::Down = 0x1 , JY5320CoreOO::External = 0x2 }
Counter direction. More...
enum class | JY5320CoreOO::CIMode { JY5320CoreOO::Single = (int)JY5320Import::JY5320_CI_Single , JY5320CoreOO::Finite = (int)JY5320Import::JY5320_CI_Finite , JY5320CoreOO::Continuous = (int)JY5320Import::JY5320_CI_Continuous }
CIMode. More...
enum class JY5320CoreOO::CIType {
JY5320CoreOO::EdgeCounting , JY5320CoreOO::Period , JY5320CoreOO::Frequency , JY5320CoreOO::Pulse ,
JY5320CoreOO::SemiPeriod , JY5320CoreOO::TwoEdgeSeparation , JY5320CoreOO::QuadEncoder , JY5320CoreOO::TwoPulseEncoder
}
Counter Input Application Type. More...
enum class | JY5320CoreOO::CISampleClockSource { JY5320CoreOO::Implicit = 0x0 , JY5320CoreOO::Internal = 0x1 , JY5320CoreOO::External = 0x2 }
CI Sample Clock Source. More...
enum class | JY5320CoreOO::EdgeType { JY5320CoreOO::Rising , JY5320CoreOO::Falling }
Edge Type. More...
enum class | JY5320CoreOO::ValueReturnMode { JY5320CoreOO::TwoValue = (int)JY5320Import::JY5320_CI_ReturnTwoValue , JY5320CoreOO::OneValue = (int)JY5320Import::JY5320_CI_ReturnOneValue }
enum class | JY5320CoreOO::QuadEncodingType { JY5320CoreOO::X1 , JY5320CoreOO::X2 , JY5320CoreOO::X4 }
Quadrature Encoding Type. More...
enum class | JY5320CoreOO::CITriggerType { JY5320CoreOO::Immediate = 0x0 , JY5320CoreOO::Soft = 0x1 , JY5320CoreOO::Digital = 0x2 }
TriggerType Digital/Immediate/Soft. More...
enum class JY5320CoreOO::CIDigitalTriggerSource {
JY5320CoreOO::PFI0 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_0 , JY5320CoreOO::PFI1 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_1 , JY5320CoreOO::PFI2 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_2 , JY5320CoreOO::PFI3 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_3 ,
JY5320CoreOO::PFI4 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_4 , JY5320CoreOO::PFI5 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_5 , JY5320CoreOO::PFI6 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_6 , JY5320CoreOO::PFI7 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_7 ,
JY5320CoreOO::PFI8 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_8 , JY5320CoreOO::PFI9 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_9 , JY5320CoreOO::PFI10 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_10 , JY5320CoreOO::PFI11 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_11 ,
JY5320CoreOO::PFI12 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_12 , JY5320CoreOO::PFI13 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_13 , JY5320CoreOO::PFI14 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_14 , JY5320CoreOO::PFI15 = (int)JY5320Import::JY5320_DigitalTriggerSource_PFI_15 ,
JY5320CoreOO::PXI_Trig0 = (int)JY5320Import::JY5320_DigitalTriggerSource_PXI_0 , JY5320CoreOO::PXI_Trig1 = (int)JY5320Import::JY5320_DigitalTriggerSource_PXI_1 , JY5320CoreOO::PXI_Trig2 = (int)JY5320Import::JY5320_DigitalTriggerSource_PXI_2 , JY5320CoreOO::PXI_Trig3 = (int)JY5320Import::JY5320_DigitalTriggerSource_PXI_3 ,
JY5320CoreOO::PXI_Trig4 = (int)JY5320Import::JY5320_DigitalTriggerSource_PXI_4 , JY5320CoreOO::PXI_Trig5 = (int)JY5320Import::JY5320_DigitalTriggerSource_PXI_5 , JY5320CoreOO::PXI_Trig6 = (int)JY5320Import::JY5320_DigitalTriggerSource_PXI_6 , JY5320CoreOO::PXI_Trig7 = (int)JY5320Import::JY5320_DigitalTriggerSource_PXI_7 ,
JY5320CoreOO::AI_StartTrig = (int)JY5320Import::JY5320_DigitalTriggerSource_Inter_AI_StartTrig , JY5320CoreOO::AI_ReferenceTrig = (int)JY5320Import::JY5320_DigitalTriggerSource_Inter_AI_ReferenceTrig , JY5320CoreOO::CI_0_StartTrig = (int)JY5320Import::JY5320_DigitalTriggerSource_Inter_CIO_0_StartTrig , JY5320CoreOO::CI_1_StartTrig = (int)JY5320Import::JY5320_DigitalTriggerSource_Inter_CIO_1_StartTrig ,
JY5320CoreOO::CI_0_OutPut = (int)JY5320Import::JY5320_DigitalTriggerSource_Inter_Counter_0_Output , JY5320CoreOO::CI_1_OutPut = (int)JY5320Import::JY5320_DigitalTriggerSource_Inter_Counter_1_Output
}
CI Digital trigger source. More...
enum class | JY5320CoreOO::CIDigitalTriggerEdge { JY5320CoreOO::Rising , JY5320CoreOO::Falling }
CI Digital Trigger Edge. More...
enum class JY5320CoreOO::InputTerminal {
JY5320CoreOO::PFI0 = (int)JY5320Import::JY5320_IN_PFI0 , JY5320CoreOO::PFI1 = (int)JY5320Import::JY5320_IN_PFI1 , JY5320CoreOO::PFI2 = (int)JY5320Import::JY5320_IN_PFI2 , JY5320CoreOO::PFI3 = (int)JY5320Import::JY5320_IN_PFI3 ,
JY5320CoreOO::PFI4 = (int)JY5320Import::JY5320_IN_PFI4 , JY5320CoreOO::PFI5 = (int)JY5320Import::JY5320_IN_PFI5 , JY5320CoreOO::PFI6 = (int)JY5320Import::JY5320_IN_PFI6 , JY5320CoreOO::PFI7 = (int)JY5320Import::JY5320_IN_PFI7 ,
JY5320CoreOO::PFI8 = (int)JY5320Import::JY5320_IN_PFI8 , JY5320CoreOO::PFI9 = (int)JY5320Import::JY5320_IN_PFI9 , JY5320CoreOO::PFI10 = (int)JY5320Import::JY5320_IN_PFI10 , JY5320CoreOO::PFI11 = (int)JY5320Import::JY5320_IN_PFI11 ,
JY5320CoreOO::PFI12 = (int)JY5320Import::JY5320_IN_PFI12 , JY5320CoreOO::PFI13 = (int)JY5320Import::JY5320_IN_PFI13 , JY5320CoreOO::PFI14 = (int)JY5320Import::JY5320_IN_PFI14 , JY5320CoreOO::PFI15 = (int)JY5320Import::JY5320_IN_PFI15 ,
JY5320CoreOO::PXI_Trig0 = (int)JY5320Import::JY5320_IN_PXI_Trig0 , JY5320CoreOO::PXI_Trig1 = (int)JY5320Import::JY5320_IN_PXI_Trig1 , JY5320CoreOO::PXI_Trig2 = (int)JY5320Import::JY5320_IN_PXI_Trig2 , JY5320CoreOO::PXI_Trig3 = (int)JY5320Import::JY5320_IN_PXI_Trig3 ,
JY5320CoreOO::PXI_Trig4 = (int)JY5320Import::JY5320_IN_PXI_Trig4 , JY5320CoreOO::PXI_Trig5 = (int)JY5320Import::JY5320_IN_PXI_Trig5 , JY5320CoreOO::PXI_Trig6 = (int)JY5320Import::JY5320_IN_PXI_Trig6 , JY5320CoreOO::PXI_Trig7 = (int)JY5320Import::JY5320_IN_PXI_Trig7 ,
JY5320CoreOO::AI_SampleClock = (int)JY5320Import::JY5320_IN_AI_SampleClock , JY5320CoreOO::CI_0_OutPut = (int)JY5320Import::JY5320_IN_CO_0_Output , JY5320CoreOO::CI_1_OutPut = (int)JY5320Import::JY5320_IN_CO_1_Output , JY5320CoreOO::Timebase_100MHz = (int)JY5320Import::JY5320_IN_CIO_100MHz ,
JY5320CoreOO::Timebase_5MHz = (int)JY5320Import::JY5320_IN_CIO_5MHz , JY5320CoreOO::Timebase_100kHz = (int)JY5320Import::JY5320_IN_CIO_100kHz
}
enum class | JY5320CoreOO::EdgeCntOunEvtIdleState { JY5320CoreOO::LowLevel = 0 , JY5320CoreOO::HighLevel = 1 }
Output idle state when the event has not occurred. More...
enum class | JY5320CoreOO::CISignalExportSource { JY5320CoreOO::StartTrig , JY5320CoreOO::SampleClock }
SourceSignal. More...
enum class | JY5320CoreOO::CITimebaseSource { JY5320CoreOO::Internal100MHz = (int)JY5320Import::JY5320_Internal_Timebase_100M , JY5320CoreOO::Internal5MHz = (int)JY5320Import::JY5320_Internal_Timebase_5M , JY5320CoreOO::Internal100kHz = (int)JY5320Import::JY5320_Internal_Timebase_100K , JY5320CoreOO::External = (int)JY5320Import::JY5320_External_Timebase }
Timebase source. More...

Macro Definition Documentation

◆ __JY5320_CORE_OO_CITASK_H__

#define __JY5320_CORE_OO_CITASK_H__


5320 C++ Programming Manual: JY5320CoreOO::JY5320CoreOOCITask Class Reference

  • JY5320CoreOOCITask
Public Member Functions | Public Attributes | List of all members
JY5320CoreOO::JY5320CoreOOCITask Class Reference

#include <JY5320CoreOOCITask.h>

Public Member Functions

JY5320CoreOOCITask (int slotNum, int channel)
Constructor.
JY5320CoreOOCITask (std::string boardName, int channel)
Constructor.
~JY5320CoreOOCITask ()
void | Start ()
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Stop ()
Stop CI task .
void | ReadSinglePoint (uint32_t &count)
Read a signle count value from register, Available when Type is CIType.EdgeCounting, CIType.QuadEncoder or CIType.TwoPulseEncoder.
void | ReadData (uint32_t *pBufCount, int samplesToAcquire, int timeout=10000)
Read counter values from buffer.
void | ReadData (std::vector< uint32_t > &pBufCount, int samplesToAcquire, int timeout=10000)
Read counter values from buffer.
void | ReadData (double *pBufMeasurement, int samplesToAcquire, int timeout=10000)
Read frequency value or period value from buffer.
void | ReadData (std::vector< double > &pBufMeasurement, int samplesToAcquire, int timeout=10000)
Read frequency value or period value from buffer.
void | ReadSinglePoint (double &measurement, int timeout=10000)
Read a signle frequency value or period value from register.
void | ReadSinglePoint (double &measurement1, double &measurement2, int timeout=10000)
Read a signle measurement of pulse's duration value, or two-edge separtion value (two results at a time) from register.
void | ReadData (double *pBufMeasurement1, double *pBufMeasurement2, int samplesToAcquire, int timeout=10000)
Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.
void | ReadData (std::vector< double > &pBufMeasurement1, std::vector< double > &pBufMeasurement2, int samplesToAcquire, int timeout=10000)
Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.

Public Attributes

JY5320CoreOOProperty< JY5320CoreOOCITask, uint64_t, JY5320CoreOOPropertyType::READ_ONLY > | AvailableSamples
Number of points per channel that can be read in the buffer .
JY5320CoreOOProperty< JY5320CoreOOCITask, uint64_t, JY5320CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
CIType Type
CI Application types.
CIMode Mode
CI Sampling mode，support Single/Finite/Continuous.
CISampleClock * SampleClock
Clock Source.
uint32_t | SamplesToAcquire
Number of samples to be read per channel.Only valid when Mode is CIMode.Finite.
JY5320CoreOO::EdgeCounting * EdgeCounting
Edge Counting Configuration.
JY5320CoreOO::FrequencyMeas * FrequencyMeas
Frequency Measurement Configuration.
JY5320CoreOO::PeriodMeas * PeriodMeas
Period Measurement Configuration.
JY5320CoreOO::SemiPeriodMeas * SemiPeriodMeas
SemiPeriodMeas Measurement Configuration.
JY5320CoreOO::PulseMeas * PulseMeas
Pulse Measurement Configuration.
JY5320CoreOO::TwoEdgeSeparation * TwoEdgeSeparation
TwoEdgeSeparation.
JY5320CoreOO::QuadEncoder * QuadEncoder
QuadEncoder.
JY5320CoreOO::TwoPulseEncoder * TwoPulseEncoder
TwoPulseEncoder.
CITrigger * Trigger
CI Trigger Configuration.
CISignalExport * SignalExport
Export CI Signal Configuration.
JY5320CoreOODevice * Device
Device.

Constructor & Destructor Documentation

◆ JY5320CoreOOCITask() [1/2]

JY5320CoreOO::JY5320CoreOOCITask::JY5320CoreOOCITask | ( | int | slotNum,
 |  | int | channel )

Constructor.

Used to create an CI task by a slot number and Channel ID

Parameters
slotNum | Card slot number.
channel | Channel ID（5321/5323 support0-1,5322/5324 suppor0).

◆ JY5320CoreOOCITask() [2/2]

JY5320CoreOO::JY5320CoreOOCITask::JY5320CoreOOCITask | ( | std::string | boardName,
 |  | int | channel )

Constructor.

Used to create an CI task by a slot number and Channel ID

Parameters
slotNum | Card slot number.
channel | Channel ID（5321/5323 support0-1,5322/5324 suppor0).

◆ ~JY5320CoreOOCITask()

JY5320CoreOO::JY5320CoreOOCITask::~JY5320CoreOOCITask ( )

Member Function Documentation

◆ ReadData() [1/6]

void JY5320CoreOO::JY5320CoreOOCITask::ReadData | ( | double * | pBufMeasurement,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read frequency value or period value from buffer.

Available when JY5320CITask.Mode is NOT CIMode.Single, and Type is CIType.Frequency or CIType.Period.

Parameters
bufMeasurement | Buffer for reading data. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period in seconds when Type is CIType.Period.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [2/6]

void JY5320CoreOO::JY5320CoreOOCITask::ReadData | ( | double * | pBufMeasurement1,
 |  | double * | pBufMeasurement2,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.

. Available when JY5320CITask.Mode is NOT CIMode.Single, Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
bufMeasurement1 | Buffer for reading data. Indicates high level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
bufMeasurement2 | Buffer for reading data. Indicates low level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [3/6]

void JY5320CoreOO::JY5320CoreOOCITask::ReadData | ( | std::vector< double > & | pBufMeasurement,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read frequency value or period value from buffer.

Available when JY5320CITask.Mode is NOT CIMode.Single, and Type is CIType.Frequency or CIType.Period.

Parameters
bufMeasurement | Buffer for reading data. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period in seconds when Type is CIType.Period.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [4/6]

void JY5320CoreOO::JY5320CoreOOCITask::ReadData | ( | std::vector< double > & | pBufMeasurement1,
 |  | std::vector< double > & | pBufMeasurement2,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.

. Available when JY5320CITask.Mode is NOT CIMode.Single, Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
bufMeasurement1 | Buffer for reading data. Indicates high level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
bufMeasurement2 | Buffer for reading data. Indicates low level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [5/6]

void JY5320CoreOO::JY5320CoreOOCITask::ReadData | ( | std::vector< uint32_t > & | pBufCount,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read counter values from buffer.

Available when JY5320CITask.Mode is NOT CIMode.Single, and Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder

Parameters
bufCount | Buffer for reading data.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [6/6]

void JY5320CoreOO::JY5320CoreOOCITask::ReadData | ( | uint32_t * | pBufCount,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read counter values from buffer.

Available when JY5320CITask.Mode is NOT CIMode.Single, and Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder

Parameters
bufCount | Buffer for reading data.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [1/3]

void JY5320CoreOO::JY5320CoreOOCITask::ReadSinglePoint | ( | double & | measurement,
 |  | int | timeout = 10000 )

Read a signle frequency value or period value from register.

Valid when Type is CIType.Frequency or CIType.Period.

Parameters
measurement Measurement value. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period is seconds when Type is CIType.Period.
timeout
Timeout (ms). Wait until the measurement is completed or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [2/3]

void JY5320CoreOO::JY5320CoreOOCITask::ReadSinglePoint | ( | double & | measurement1,
 |  | double & | measurement2,
 |  | int | timeout = 10000 )

Read a signle measurement of pulse's duration value, or two-edge separtion value (two results at a time) from register.

Available when Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
measurement1 | Measurement Value 1. Indicates low level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
measurement2 | Measurement Value 2. Indicates high level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
timeout
Timeout (ms). Wait until the measurement is completed or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [3/3]

void JY5320CoreOO::JY5320CoreOOCITask::ReadSinglePoint ( uint32_t & count )

Read a signle count value from register, Available when Type is CIType.EdgeCounting, CIType.QuadEncoder or CIType.TwoPulseEncoder.

Parameters
count counter value。

◆ SendSoftwareTrigger()

void JY5320CoreOO::JY5320CoreOOCITask::SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5320CoreOO::JY5320CoreOOCITask::Start ( )

◆ Stop()

void JY5320CoreOO::JY5320CoreOOCITask::Stop ( )

Stop CI task .

Member Data Documentation

◆ AvailableSamples

JY5320CoreOOProperty<JY5320CoreOOCITask, uint64_t, JY5320CoreOOPropertyType::READ_ONLY> JY5320CoreOO::JY5320CoreOOCITask::AvailableSamples

Number of points per channel that can be read in the buffer .

◆ Device

JY5320CoreOODevice* JY5320CoreOO::JY5320CoreOOCITask::Device

Device.

◆ EdgeCounting

JY5320CoreOO::EdgeCounting* JY5320CoreOO::JY5320CoreOOCITask::EdgeCounting

Edge Counting Configuration.

◆ FrequencyMeas

JY5320CoreOO::FrequencyMeas* JY5320CoreOO::JY5320CoreOOCITask::FrequencyMeas

Frequency Measurement Configuration.

◆ Mode

CIMode JY5320CoreOO::JY5320CoreOOCITask::Mode

CI Sampling mode，support Single/Finite/Continuous.

◆ PeriodMeas

JY5320CoreOO::PeriodMeas* JY5320CoreOO::JY5320CoreOOCITask::PeriodMeas

Period Measurement Configuration.

◆ PulseMeas

JY5320CoreOO::PulseMeas* JY5320CoreOO::JY5320CoreOOCITask::PulseMeas

Pulse Measurement Configuration.

◆ QuadEncoder

JY5320CoreOO::QuadEncoder* JY5320CoreOO::JY5320CoreOOCITask::QuadEncoder

QuadEncoder.

◆ SampleClock

CISampleClock* JY5320CoreOO::JY5320CoreOOCITask::SampleClock

Clock Source.

◆ SamplesToAcquire

uint32_t JY5320CoreOO::JY5320CoreOOCITask::SamplesToAcquire

Number of samples to be read per channel.Only valid when Mode is CIMode.Finite.

◆ SemiPeriodMeas

JY5320CoreOO::SemiPeriodMeas* JY5320CoreOO::JY5320CoreOOCITask::SemiPeriodMeas

SemiPeriodMeas Measurement Configuration.

◆ SignalExport

CISignalExport* JY5320CoreOO::JY5320CoreOOCITask::SignalExport

Export CI Signal Configuration.

◆ TransferedSamples

JY5320CoreOOProperty<JY5320CoreOOCITask, uint64_t, JY5320CoreOOPropertyType::READ_ONLY> JY5320CoreOO::JY5320CoreOOCITask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT CIMode.Single.

◆ Trigger

CITrigger* JY5320CoreOO::JY5320CoreOOCITask::Trigger

CI Trigger Configuration.

◆ TwoEdgeSeparation

JY5320CoreOO::TwoEdgeSeparation* JY5320CoreOO::JY5320CoreOOCITask::TwoEdgeSeparation

TwoEdgeSeparation.

◆ TwoPulseEncoder

JY5320CoreOO::TwoPulseEncoder* JY5320CoreOO::JY5320CoreOOCITask::TwoPulseEncoder

TwoPulseEncoder.

◆ Type

CIType JY5320CoreOO::JY5320CoreOOCITask::Type

CI Application types.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOCITask.h


5320 C++ Programming Manual: JY5320CoreOO::CIInternalSampleClock Class Reference

  • CIInternalSampleClock
Public Member Functions | Public Attributes | List of all members
JY5320CoreOO::CIInternalSampleClock Class Reference

CI Internal Sample Clock Configuration Class. More...

#include <JY5320CoreOOCITask.h>

Public Member Functions

CIInternalSampleClock ()

Public Attributes

JY5320CoreOOProperty< CIInternalSampleClock, double, JY5320CoreOOPropertyType::READ_WRITE > | Rate
The rate of the internal sample clock (sample rate) which is generated by dividing the internal clock (200MHz).
bool | IgnoreFirstSampleClock

Detailed Description

CI Internal Sample Clock Configuration Class.

Constructor & Destructor Documentation

◆ CIInternalSampleClock()

JY5320CoreOO::CIInternalSampleClock::CIInternalSampleClock ( )

Member Data Documentation

◆ IgnoreFirstSampleClock

bool JY5320CoreOO::CIInternalSampleClock::IgnoreFirstSampleClock

◆ Rate

JY5320CoreOOProperty<CIInternalSampleClock, double, JY5320CoreOOPropertyType::READ_WRITE> JY5320CoreOO::CIInternalSampleClock::Rate

The rate of the internal sample clock (sample rate) which is generated by dividing the internal clock (200MHz).

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOCITask.h


5320 C++ Programming Manual: JY5320CoreOO::CIImplicitSampleClock Class Reference

  • CIImplicitSampleClock
Public Attributes | List of all members
JY5320CoreOO::CIImplicitSampleClock Class Reference

CI Implicit Sample Clock class. More...

#include <JY5320CoreOOCITask.h>

Public Attributes

double ExpectedRate
Expected Rate of Implicit Sample Clock.

Detailed Description

CI Implicit Sample Clock class.

Member Data Documentation

◆ ExpectedRate

double JY5320CoreOO::CIImplicitSampleClock::ExpectedRate

Expected Rate of Implicit Sample Clock.

Filling this parameter accurately would helps the driver to set a proper DDR write frequency internally.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOCITask.h


5320 C++ Programming Manual: JY5320CoreOO::CIExternalSampleClock Class Reference

  • CIExternalSampleClock
Public Attributes | List of all members
JY5320CoreOO::CIExternalSampleClock Class Reference

CI Implicit Sample Clock class. More...

#include <JY5320CoreOOCITask.h>

Public Attributes

ClockTerminal Terminal
External Sample Clock Input Terminal.
double | ExpectedRate
Expected Rate of External Sample Clock.
bool | IgnoreFirstSampleClock

Detailed Description

CI Implicit Sample Clock class.

Member Data Documentation

◆ ExpectedRate

double JY5320CoreOO::CIExternalSampleClock::ExpectedRate

Expected Rate of External Sample Clock.

Filling this parameter accurately would helps the driver to set a proper DDR write frequency internally.

◆ IgnoreFirstSampleClock

bool JY5320CoreOO::CIExternalSampleClock::IgnoreFirstSampleClock

◆ Terminal

ClockTerminal JY5320CoreOO::CIExternalSampleClock::Terminal

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOCITask.h


5320 C++ Programming Manual: JY5320CoreOO::CISampleClock Class Reference

  • CISampleClock
Public Attributes | List of all members
JY5320CoreOO::CISampleClock Class Reference

CI Sample Clock class. More...

#include <JY5320CoreOOCITask.h>

Public Attributes

CISampleClockSource Source
CI Sample Clock Source.
CIExternalSampleClock * External
CI External Sample Clock Configuration.
CIImplicitSampleClock * Implicit
CI Implicit Sample Clock Configuration.
CIInternalSampleClock * Internal
Internal Sample Clock Configuration.

Detailed Description

CI Sample Clock class.

Member Data Documentation

◆ External

CIExternalSampleClock* JY5320CoreOO::CISampleClock::External

CI External Sample Clock Configuration.

Valid when Source is CISampleClockSource.External.

◆ Implicit

CIImplicitSampleClock* JY5320CoreOO::CISampleClock::Implicit

CI Implicit Sample Clock Configuration.

Valid when Source is CISampleClockSource.Implicit.

◆ Internal

CIInternalSampleClock* JY5320CoreOO::CISampleClock::Internal

Internal Sample Clock Configuration.

Valid when Source is CISampleClockSource.Internal.

◆ Source

CISampleClockSource JY5320CoreOO::CISampleClock::Source

CI Sample Clock Source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOCITask.h


5320 C++ Programming Manual: JY5320CoreOO::EdgeCounting Class Reference

  • EdgeCounting
Public Attributes | List of all members
JY5320CoreOO::EdgeCounting Class Reference

Configure CI EdgeCounting. More...

#include <JY5320CoreOOCITask.h>

Public Attributes

int InitialCount
Initial Count.
CountDirection Direction
Counter direction.
EdgeType ActiveEdge
The avtive edge of the input signal, the counter will count up or down on this edge.
PauseTrigger * Pause
Pause Trigger Configuration.
EdgeCountingOutEvent * OutEvent
Edge counting output event.
JY5320CoreOO::InputTerminal DirTerminal
Terminal of External Count Diretion Control.
JY5320CoreOO::InputTerminal Input_Terminal
Input Terminal.

Detailed Description

Configure CI EdgeCounting.

Member Data Documentation

◆ ActiveEdge

EdgeType JY5320CoreOO::EdgeCounting::ActiveEdge

The avtive edge of the input signal, the counter will count up or down on this edge.

◆ Direction

CountDirection JY5320CoreOO::EdgeCounting::Direction

Counter direction.

enum Up/Down/External

◆ DirTerminal

JY5320CoreOO::InputTerminal JY5320CoreOO::EdgeCounting::DirTerminal

Terminal of External Count Diretion Control.

Valid when Direction is CountDirection.External

◆ InitialCount

int JY5320CoreOO::EdgeCounting::InitialCount

Initial Count.

◆ Input_Terminal

JY5320CoreOO::InputTerminal JY5320CoreOO::EdgeCounting::Input_Terminal

Input Terminal.

◆ OutEvent

EdgeCountingOutEvent* JY5320CoreOO::EdgeCounting::OutEvent

Edge counting output event.

A pulse will be generated when the count value reaches specified threshold

◆ Pause

PauseTrigger* JY5320CoreOO::EdgeCounting::Pause

Pause Trigger Configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOCITask.h


5320 C++ Programming Manual: JY5320CoreOO::FrequencyMeas Class Reference

  • FrequencyMeas
Public Attributes | List of all members
JY5320CoreOO::FrequencyMeas Class Reference

Configure CI Measure. More...

#include <JY5320CoreOOCITask.h>

Public Attributes

CITimebase * Timebase
Timebase configuration.
JY5320CoreOO::InputTerminal Input_Terminal
Input Terminal.

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ Input_Terminal

JY5320CoreOO::InputTerminal JY5320CoreOO::FrequencyMeas::Input_Terminal

Input Terminal.

◆ Timebase

CITimebase* JY5320CoreOO::FrequencyMeas::Timebase

Timebase configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOCITask.h


5320 C++ Programming Manual: JY5320CoreOO::PeriodMeas Class Reference

  • PeriodMeas
Public Attributes | List of all members
JY5320CoreOO::PeriodMeas Class Reference

Configure CI Measure. More...

#include <JY5320CoreOOCITask.h>

Public Attributes

CITimebase * Timebase
Timebase configuration.
EdgeType StartingEdge
The start edge of the input signal, the counter will count up or down on this edge.
JY5320CoreOO::InputTerminal Input_Terminal
Input Terminal.

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ Input_Terminal

JY5320CoreOO::InputTerminal JY5320CoreOO::PeriodMeas::Input_Terminal

Input Terminal.

◆ StartingEdge

EdgeType JY5320CoreOO::PeriodMeas::StartingEdge

The start edge of the input signal, the counter will count up or down on this edge.

◆ Timebase

CITimebase* JY5320CoreOO::PeriodMeas::Timebase

Timebase configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOCITask.h


5320 C++ Programming Manual: JY5320CoreOO::PulseMeas Class Reference

  • PulseMeas
Public Attributes | List of all members
JY5320CoreOO::PulseMeas Class Reference

Configure CI Measure. More...

#include <JY5320CoreOOCITask.h>

Public Attributes

CITimebase * Timebase
Timebase configuration.
EdgeType StartingEdge
The start edge of the input signal, the counter will count up or down on this edge.
JY5320CoreOO::InputTerminal Input_Terminal
Input Terminal.

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ Input_Terminal

JY5320CoreOO::InputTerminal JY5320CoreOO::PulseMeas::Input_Terminal

Input Terminal.

◆ StartingEdge

EdgeType JY5320CoreOO::PulseMeas::StartingEdge

The start edge of the input signal, the counter will count up or down on this edge.

◆ Timebase

CITimebase* JY5320CoreOO::PulseMeas::Timebase

Timebase configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOCITask.h


5320 C++ Programming Manual: JY5320CoreOO::SemiPeriodMeas Class Reference

  • SemiPeriodMeas
Public Attributes | List of all members
JY5320CoreOO::SemiPeriodMeas Class Reference

#include <JY5320CoreOOCITask.h>

Public Attributes

CITimebase * Timebase
Timebase configuration.
EdgeType StartingEdge
The start edge of the input signal, the counter will count up or down on this edge.
InputTerminal Inputterminal
Input Terminal.

Member Data Documentation

◆ Inputterminal

InputTerminal JY5320CoreOO::SemiPeriodMeas::Inputterminal

Input Terminal.

◆ StartingEdge

EdgeType JY5320CoreOO::SemiPeriodMeas::StartingEdge

The start edge of the input signal, the counter will count up or down on this edge.

◆ Timebase

CITimebase* JY5320CoreOO::SemiPeriodMeas::Timebase

Timebase configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOCITask.h


5320 C++ Programming Manual: JY5320CoreOO::TwoEdgeSeparation Class Reference

  • TwoEdgeSeparation
Public Attributes | List of all members
JY5320CoreOO::TwoEdgeSeparation Class Reference

Configure CI Measure. More...

#include <JY5320CoreOOCITask.h>

Public Attributes

CITimebase * Timebase
Timebase configuration.
InputTerminal FirstInputTerminal
Input Terminal.
InputTerminal SecondInputTerminal
Input Terminal.
ValueReturnMode EdgeSeparationMode

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ EdgeSeparationMode

ValueReturnMode JY5320CoreOO::TwoEdgeSeparation::EdgeSeparationMode

数据返回模式

data return mode

◆ FirstInputTerminal

InputTerminal JY5320CoreOO::TwoEdgeSeparation::FirstInputTerminal

Input Terminal.

◆ SecondInputTerminal

InputTerminal JY5320CoreOO::TwoEdgeSeparation::SecondInputTerminal

Input Terminal.

◆ Timebase

CITimebase* JY5320CoreOO::TwoEdgeSeparation::Timebase

Timebase configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOCITask.h


5320 C++ Programming Manual: JY5320CoreOO::QuadEncoder Class Reference

  • QuadEncoder
Public Attributes | List of all members
JY5320CoreOO::QuadEncoder Class Reference

Configure CI Measure. More...

#include <JY5320CoreOOCITask.h>

Public Attributes

QuadEncodingType EncodingType
Type of Encoding.
bool | ZReloadEnabled
In Encoder mode ,the Z signal enable.
int | InitialCount
Initial Count.
InputTerminal AInputTerminal
Input Terminal.
InputTerminal BInputTerminal
Input Terminal.
InputTerminal ZInputTerminal
Input Terminal.

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ AInputTerminal

InputTerminal JY5320CoreOO::QuadEncoder::AInputTerminal

Input Terminal.

◆ BInputTerminal

InputTerminal JY5320CoreOO::QuadEncoder::BInputTerminal

Input Terminal.

◆ EncodingType

QuadEncodingType JY5320CoreOO::QuadEncoder::EncodingType

Type of Encoding.

◆ InitialCount

int JY5320CoreOO::QuadEncoder::InitialCount

Initial Count.

◆ ZInputTerminal

InputTerminal JY5320CoreOO::QuadEncoder::ZInputTerminal

Input Terminal.

◆ ZReloadEnabled

bool JY5320CoreOO::QuadEncoder::ZReloadEnabled

In Encoder mode ,the Z signal enable.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOCITask.h


5320 C++ Programming Manual: JY5320CoreOO::TwoPulseEncoder Class Reference

  • TwoPulseEncoder
Public Attributes | List of all members
JY5320CoreOO::TwoPulseEncoder Class Reference

Configure CI Measure. More...

#include <JY5320CoreOOCITask.h>

Public Attributes

int InitialCount
Initial Count.
InputTerminal AInputTerminal
Input Terminal.
InputTerminal BInputTerminal
Input Terminal.

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ AInputTerminal

InputTerminal JY5320CoreOO::TwoPulseEncoder::AInputTerminal

Input Terminal.

◆ BInputTerminal

InputTerminal JY5320CoreOO::TwoPulseEncoder::BInputTerminal

Input Terminal.

◆ InitialCount

int JY5320CoreOO::TwoPulseEncoder::InitialCount

Initial Count.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOCITask.h


5320 C++ Programming Manual: JY5320CoreOO::CITrigger Class Reference

  • CITrigger
Public Attributes | List of all members
JY5320CoreOO::CITrigger Class Reference

Constructor to create an CITrigger task object. More...

#include <JY5320CoreOOCITask.h>

Public Attributes

CITriggerType Type
CI trigger type.
CIDigitalTrigger * Digital
CI Digital Trigger.

Detailed Description

Constructor to create an CITrigger task object.

Used to build CI Trigger

Member Data Documentation

◆ Digital

CIDigitalTrigger* JY5320CoreOO::CITrigger::Digital

CI Digital Trigger.

Valid when Type is CITriggerType.Digital

◆ Type

CITriggerType JY5320CoreOO::CITrigger::Type

CI trigger type.

enum Immediate/Digital/Soft.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOCITask.h


5320 C++ Programming Manual: JY5320CoreOO::CIDigitalTrigger Class Reference

  • CIDigitalTrigger
Public Attributes | List of all members
JY5320CoreOO::CIDigitalTrigger Class Reference

CI Digital trigger . More...

#include <JY5320CoreOOCITask.h>

Public Attributes

CIDigitalTriggerSource Source
CI Digital Trigger source.
CIDigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Detailed Description

CI Digital trigger .

Member Data Documentation

◆ Edge

CIDigitalTriggerEdge JY5320CoreOO::CIDigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

CIDigitalTriggerSource JY5320CoreOO::CIDigitalTrigger::Source

CI Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOCITask.h


5320 C++ Programming Manual: JY5320CoreOO::EdgeCountingOutEvent Class Reference

  • EdgeCountingOutEvent
Public Attributes | List of all members
JY5320CoreOO::EdgeCountingOutEvent Class Reference

Edge counting output event configuration class. More...

#include <JY5320CoreOOCITask.h>

Public Attributes

EdgeCntOunEvtIdleState IdleState
Output idle state when the event has not occurred.
uint32_t Threshold
Comparison threshold.
IOTerminal Terminal
Terminal.

Detailed Description

Edge counting output event configuration class.

Member Data Documentation

◆ IdleState

EdgeCntOunEvtIdleState JY5320CoreOO::EdgeCountingOutEvent::IdleState

Output idle state when the event has not occurred.

The default value is EdgeCntOunEvtIdleState.LowLevel

◆ Terminal

IOTerminal JY5320CoreOO::EdgeCountingOutEvent::Terminal

Terminal.

◆ Threshold

uint32_t JY5320CoreOO::EdgeCountingOutEvent::Threshold

Comparison threshold.

The default value is 2^32-1

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOCITask.h


5320 C++ Programming Manual: JY5320CoreOO::CIExternalTimebase Class Reference

  • CIExternalTimebase
Public Attributes | List of all members
JY5320CoreOO::CIExternalTimebase Class Reference

#include <JY5320CoreOOCITask.h>

Public Attributes

InputTerminal Terminal
double Frequency

Member Data Documentation

◆ Frequency

double JY5320CoreOO::CIExternalTimebase::Frequency

外部时基的频率

Frequency of The External Timebase

◆ Terminal

InputTerminal JY5320CoreOO::CIExternalTimebase::Terminal

外部时基的输入端口

External Timebase Input Terminal

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOCITask.h


5320 C++ Programming Manual: JY5320CoreOO::CITimebase Class Reference

  • CITimebase
Public Member Functions | Public Attributes | List of all members
JY5320CoreOO::CITimebase Class Reference

Timebase configuration class. More...

#include <JY5320CoreOOCITask.h>

Public Member Functions

CITimebase ()
~CITimebase ()

Public Attributes

CITimebaseSource Source
Timebase Source.
CIExternalTimebase * External
JY5320CoreOOProperty< CITimebase, double, JY5320CoreOOPropertyType::READ_ONLY > ActualFreq

Detailed Description

Timebase configuration class.

Constructor & Destructor Documentation

◆ CITimebase()

JY5320CoreOO::CITimebase::CITimebase ( )

◆ ~CITimebase()

JY5320CoreOO::CITimebase::~CITimebase ( )

Member Data Documentation

◆ ActualFreq

JY5320CoreOOProperty<CITimebase, double, JY5320CoreOOPropertyType::READ_ONLY> JY5320CoreOO::CITimebase::ActualFreq

◆ External

CIExternalTimebase* JY5320CoreOO::CITimebase::External

外部时基配置。当 CITimebase.Source 为 CITimebaseSource.External时有效。

External Timebase Configuration. Valid when CITimebase.Source is COTimebaseSource.External.

◆ Source

CITimebaseSource JY5320CoreOO::CITimebase::Source

Timebase Source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOCITask.h


5320 C++ Programming Manual: JY5320CoreOO::CISignalExport Class Reference

  • CISignalExport
Public Member Functions | List of all members
JY5320CoreOO::CISignalExport Class Reference

CI Signal Export Class. More...

#include <JY5320CoreOOCITask.h>

Public Member Functions

void | Add (CISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (CISignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

CI Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY5320CoreOO::CISignalExport::Add | ( | CISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | CI Signal Source
destination | Export Desination

◆ Add() [2/2]

void JY5320CoreOO::CISignalExport::Add | ( | CISignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | CI Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JY5320CoreOO::CISignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5320CoreOO::CISignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOCITask.h


5320 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOCommon.h File Reference

  • File List
  • File Members
  • COO
  • 5320
Classes | Namespaces | Macros | Enumerations | Functions | Variables
JY5320CoreOOCommon.h File Reference
#include <string>
#include <stdint.h>

Classes

class | JY5320CoreOO::JYDriverException
class | JY5320CoreOO::JY5320CoreOOProperty< ContainerClass, ValueType, propertyType >
属性模板类 More...
class | JY5320CoreOO::PauseTrigger
Pause trigger configuration class. More...

Namespaces

namespace | JY5320Import
namespace | JY5320CoreOO

Macros

#define | EXTERN_C extern
Windows.
#define | JY5320CoreOO_API

Enumerations

enum class | JY5320CoreOO::JY5320CoreOOPropertyType { JY5320CoreOO::READ_ONLY = 1 , JY5320CoreOO::WRITE_ONLY = 2 , JY5320CoreOO::READ_WRITE = 3 }
enum class JY5320CoreOO::JYDriverExceptionPublic {
JY5320CoreOO::UnKnown = 0 , JY5320CoreOO::OpenDeviceFailed = -10001 , JY5320CoreOO::CloseDeviceFailed = -10002 , JY5320CoreOO::ResetDeviceFailed = -10003 ,
JY5320CoreOO::GetDevicePropertyFailed = -10004 , JY5320CoreOO::SetDevicePropertyFailed = -10005 , JY5320CoreOO::HardwareResourceIsReserved = -10006 , JY5320CoreOO::MethodNotPermitedToCallWhenCurrentStatus = -10007 ,
JY5320CoreOO::InvalidUserDataBuffer = -10008 , JY5320CoreOO::NoChannelAdded = -10009 , JY5320CoreOO::NotSupportOperationForCurrentDevice = -10010 , JY5320CoreOO::CreatTaskFailed = -10100 ,
JY5320CoreOO::StartTaskFailed = -10101 , JY5320CoreOO::StopTaskFailed = -10102 , JY5320CoreOO::TaskHasNotStarted = -10103 , JY5320CoreOO::TaskHasStartedCannotPerformTheSetOperation = -10104 ,
JY5320CoreOO::ChannelNumberParameterInvalid = -10105 , JY5320CoreOO::ChannelInputRangeParameterInvalid = -10106 , JY5320CoreOO::ChannelTerminalParameterInvalid = -10107 , JY5320CoreOO::ChannelCouplingParameterInvalid = -10108 ,
JY5320CoreOO::SampeleModeParameterInvalid = -10109 , JY5320CoreOO::SampleClockParameterInvalid = -10110 , JY5320CoreOO::SampleRateParameterInvalid = -10111 , JY5320CoreOO::UpdateRateParameterInvalid = -10112 ,
JY5320CoreOO::TriggerParameterInvalid = -10113 , JY5320CoreOO::ReferenceTriggerDoesNotMatchWithSampleMode = -10114 , JY5320CoreOO::PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint = -10115 , JY5320CoreOO::ReadDataFailed = -10016 ,
JY5320CoreOO::ReadDataTimeout = -10017 , JY5320CoreOO::WriteDataFailed = -10018 , JY5320CoreOO::WriteDataTimeout = -10019 , JY5320CoreOO::WriteDataLengthCannotBeLessThanN = -10020 ,
JY5320CoreOO::BufferDataOverflow = -10021 , JY5320CoreOO::BufferDataDownflow = -10022 , JY5320CoreOO::CheckBufferFailed = -10023 , JY5320CoreOO::PointInvalidInFiniteMode = -10024 ,
JY5320CoreOO::ReadPointInvalid = -10025 , JY5320CoreOO::OnlySupportRecordMode = -10026 , JY5320CoreOO::SendSoftTirggerFailed = -10027 , JY5320CoreOO::TaskTimeout = -10028 ,
JY5320CoreOO::CounterParametersInvalid = -10029 , JY5320CoreOO::WritePointInvalid = -10030 , JY5320CoreOO::SignalExportDestinationInvalid = -10031 , JY5320CoreOO::InvalidParameter = -10033
}
enum class JY5320CoreOO::ClockTerminal {
JY5320CoreOO::PFI0 = JY5320Import::JY5320_Clock_PFI_0 , JY5320CoreOO::PFI1 = JY5320Import::JY5320_Clock_PFI_1 , JY5320CoreOO::PFI2 = JY5320Import::JY5320_Clock_PFI_2 , JY5320CoreOO::PFI3 = JY5320Import::JY5320_Clock_PFI_3 ,
JY5320CoreOO::PFI4 = JY5320Import::JY5320_Clock_PFI_4 , JY5320CoreOO::PFI5 = JY5320Import::JY5320_Clock_PFI_5 , JY5320CoreOO::PFI6 = JY5320Import::JY5320_Clock_PFI_6 , JY5320CoreOO::PFI7 = JY5320Import::JY5320_Clock_PFI_7 ,
JY5320CoreOO::PFI8 = JY5320Import::JY5320_Clock_PFI_8 , JY5320CoreOO::PFI9 = JY5320Import::JY5320_Clock_PFI_9 , JY5320CoreOO::PFI10 = JY5320Import::JY5320_Clock_PFI_10 , JY5320CoreOO::PFI11 = JY5320Import::JY5320_Clock_PFI_11 ,
JY5320CoreOO::PFI12 = JY5320Import::JY5320_Clock_PFI_12 , JY5320CoreOO::PFI13 = JY5320Import::JY5320_Clock_PFI_13 , JY5320CoreOO::PFI14 = JY5320Import::JY5320_Clock_PFI_14 , JY5320CoreOO::PFI15 = JY5320Import::JY5320_Clock_PFI_15 ,
JY5320CoreOO::PXI_Trig0 = JY5320Import::JY5320_Clock_PXI_Trig_0 , JY5320CoreOO::PXI_Trig1 = JY5320Import::JY5320_Clock_PXI_Trig_1 , JY5320CoreOO::PXI_Trig2 = JY5320Import::JY5320_Clock_PXI_Trig_2 , JY5320CoreOO::PXI_Trig3 = JY5320Import::JY5320_Clock_PXI_Trig_3 ,
JY5320CoreOO::PXI_Trig4 = JY5320Import::JY5320_Clock_PXI_Trig_4 , JY5320CoreOO::PXI_Trig5 = JY5320Import::JY5320_Clock_PXI_Trig_5 , JY5320CoreOO::PXI_Trig6 = JY5320Import::JY5320_Clock_PXI_Trig_6 , JY5320CoreOO::PXI_Trig7 = JY5320Import::JY5320_Clock_PXI_Trig_7 ,
JY5320CoreOO::AI_SampleClock = JY5320Import::JY5320_Inter_AI_SampleClock , JY5320CoreOO::CI0_SampleClock = JY5320Import::JY5320_Inter_CI_0_SampleClock , JY5320CoreOO::CI1_SampleClock = JY5320Import::JY5320_Inter_CI_1_SampleClock , JY5320CoreOO::CO0_Output = JY5320Import::JY5320_Inter_CO_0_Output ,
JY5320CoreOO::CO1_Output = JY5320Import::JY5320_Inter_CO_1_Output
}
enum class JY5320CoreOO::IOTerminal {
JY5320CoreOO::PFI0 = JY5320Import::JY5320_IN_PFI0 , JY5320CoreOO::PFI1 = JY5320Import::JY5320_IN_PFI1 , JY5320CoreOO::PFI2 = JY5320Import::JY5320_IN_PFI2 , JY5320CoreOO::PFI3 = JY5320Import::JY5320_IN_PFI3 ,
JY5320CoreOO::PFI4 = JY5320Import::JY5320_IN_PFI4 , JY5320CoreOO::PFI5 = JY5320Import::JY5320_IN_PFI5 , JY5320CoreOO::PFI6 = JY5320Import::JY5320_IN_PFI6 , JY5320CoreOO::PFI7 = JY5320Import::JY5320_IN_PFI7 ,
JY5320CoreOO::PFI8 = JY5320Import::JY5320_IN_PFI8 , JY5320CoreOO::PFI9 = JY5320Import::JY5320_IN_PFI9 , JY5320CoreOO::PFI10 = JY5320Import::JY5320_IN_PFI10 , JY5320CoreOO::PFI11 = JY5320Import::JY5320_IN_PFI11 ,
JY5320CoreOO::PFI12 = JY5320Import::JY5320_IN_PFI12 , JY5320CoreOO::PFI13 = JY5320Import::JY5320_IN_PFI13 , JY5320CoreOO::PFI14 = JY5320Import::JY5320_IN_PFI14 , JY5320CoreOO::PFI15 = JY5320Import::JY5320_IN_PFI15 ,
JY5320CoreOO::PXI_Trig0 = JY5320Import::JY5320_IN_PXI_Trig0 , JY5320CoreOO::PXI_Trig1 = JY5320Import::JY5320_IN_PXI_Trig1 , JY5320CoreOO::PXI_Trig2 = JY5320Import::JY5320_IN_PXI_Trig2 , JY5320CoreOO::PXI_Trig3 = JY5320Import::JY5320_IN_PXI_Trig3 ,
JY5320CoreOO::PXI_Trig4 = JY5320Import::JY5320_IN_PXI_Trig4 , JY5320CoreOO::PXI_Trig5 = JY5320Import::JY5320_IN_PXI_Trig5 , JY5320CoreOO::PXI_Trig6 = JY5320Import::JY5320_IN_PXI_Trig6 , JY5320CoreOO::PXI_Trig7 = JY5320Import::JY5320_IN_PXI_Trig7 ,
JY5320CoreOO::None = 25
}
enum class JY5320CoreOO::SignalExportDestination {
JY5320CoreOO::PFI0 = JY5320Import::JY5320_PFI0_OUT , JY5320CoreOO::PFI1 = JY5320Import::JY5320_PFI1_OUT , JY5320CoreOO::PFI2 = JY5320Import::JY5320_PFI2_OUT , JY5320CoreOO::PFI3 = JY5320Import::JY5320_PFI3_OUT ,
JY5320CoreOO::PFI4 = JY5320Import::JY5320_PFI4_OUT , JY5320CoreOO::PFI5 = JY5320Import::JY5320_PFI5_OUT , JY5320CoreOO::PFI6 = JY5320Import::JY5320_PFI6_OUT , JY5320CoreOO::PFI7 = JY5320Import::JY5320_PFI7_OUT ,
JY5320CoreOO::PFI8 = JY5320Import::JY5320_PFI8_OUT , JY5320CoreOO::PFI9 = JY5320Import::JY5320_PFI9_OUT , JY5320CoreOO::PFI10 = JY5320Import::JY5320_PFI10_OUT , JY5320CoreOO::PFI11 = JY5320Import::JY5320_PFI11_OUT ,
JY5320CoreOO::PFI12 = JY5320Import::JY5320_PFI12_OUT , JY5320CoreOO::PFI13 = JY5320Import::JY5320_PFI13_OUT , JY5320CoreOO::PFI14 = JY5320Import::JY5320_PFI14_OUT , JY5320CoreOO::PFI15 = JY5320Import::JY5320_PFI15_OUT ,
JY5320CoreOO::PXI_Trig0 = JY5320Import::JY5320_PXITrig0_OUT , JY5320CoreOO::PXI_Trig1 = JY5320Import::JY5320_PXITrig1_OUT , JY5320CoreOO::PXI_Trig2 = JY5320Import::JY5320_PXITrig2_OUT , JY5320CoreOO::PXI_Trig3 = JY5320Import::JY5320_PXITrig3_OUT ,
JY5320CoreOO::PXI_Trig4 = JY5320Import::JY5320_PXITrig4_OUT , JY5320CoreOO::PXI_Trig5 = JY5320Import::JY5320_PXITrig5_OUT , JY5320CoreOO::PXI_Trig6 = JY5320Import::JY5320_PXITrig6_OUT , JY5320CoreOO::PXI_Trig7 = JY5320Import::JY5320_PXITrig7_OUT
}
enum class | JY5320CoreOO::OutputCompleteState { JY5320CoreOO::Zero , JY5320CoreOO::Hold }
Output Complete State. More...
enum class | JY5320CoreOO::LevelPolarity { JY5320CoreOO::LowLevel = 0 , JY5320CoreOO::HighLevel = 1 , JY5320CoreOO::None = 2 }
Level Polarity. More...

Functions

std::string JY5320CoreOO::GetSignalExportDestinationString (SignalExportDestination destination)

Variables

const int | JY5320Import::JY5320_AI_BandWidth_25K = 0x0
const int | JY5320Import::JY5320_AI_BandWidth_220K = 0x1
const int | JY5320Import::JY5320_AI_Finite = 0x00
const int | JY5320Import::JY5320_AI_Continuous = 0x01
const int | JY5320Import::JY5320_AI_Single = 0x02
const int | JY5320Import::JY5320_CI_Finite = 0
const int | JY5320Import::JY5320_CI_Continuous = 1
const int | JY5320Import::JY5320_CI_Single = 2
const int | JY5320Import::JY5320_CO_Finite = 0x0
const int | JY5320Import::JY5320_CO_ContinuousWrapping = 0x1
const int | JY5320Import::JY5320_CO_ContinuousNoWrapping = 0x2
const int | JY5320Import::JY5320_CO_Single = 0x3
const int | JY5320Import::JY5320_TriggerType_Immediately = 0x0
const int | JY5320Import::JY5320_TriggerType_Digital = 0x1
const int | JY5320Import::JY5320_TriggerType_Analog = 0x2
const int | JY5320Import::JY5320_TriggerType_Soft = 0x3
const int | JY5320Import::JY5320_CIO_Immediately = 0x0
const int | JY5320Import::JY5320_CIO_Soft = 0x1
const int | JY5320Import::JY5320_CIO_Digital = 0x2
const int | JY5320Import::JY5320_StartTrigger = 0x0
const int | JY5320Import::JY5320_ReferenceTrigger = 0x1
const int | JY5320Import::JY5320_DigitalTriggerEdge_Rising = 0x0
const int | JY5320Import::JY5320_DigitalTriggerEdge_Falling = 0x1
const int | JY5320Import::JY5320_DigitalTriggerSource_PFI_0 = 0
const int | JY5320Import::JY5320_DigitalTriggerSource_PFI_1 = 1
const int | JY5320Import::JY5320_DigitalTriggerSource_PFI_2 = 2
const int | JY5320Import::JY5320_DigitalTriggerSource_PFI_3 = 3
const int | JY5320Import::JY5320_DigitalTriggerSource_PFI_4 = 4
const int | JY5320Import::JY5320_DigitalTriggerSource_PFI_5 = 5
const int | JY5320Import::JY5320_DigitalTriggerSource_PFI_6 = 6
const int | JY5320Import::JY5320_DigitalTriggerSource_PFI_7 = 7
const int | JY5320Import::JY5320_DigitalTriggerSource_PFI_8 = 8
const int | JY5320Import::JY5320_DigitalTriggerSource_PFI_9 = 9
const int | JY5320Import::JY5320_DigitalTriggerSource_PFI_10 = 10
const int | JY5320Import::JY5320_DigitalTriggerSource_PFI_11 = 11
const int | JY5320Import::JY5320_DigitalTriggerSource_PFI_12 = 12
const int | JY5320Import::JY5320_DigitalTriggerSource_PFI_13 = 13
const int | JY5320Import::JY5320_DigitalTriggerSource_PFI_14 = 14
const int | JY5320Import::JY5320_DigitalTriggerSource_PFI_15 = 15
const int | JY5320Import::JY5320_DigitalTriggerSource_PXI_0 = 16
const int | JY5320Import::JY5320_DigitalTriggerSource_PXI_1 = 17
const int | JY5320Import::JY5320_DigitalTriggerSource_PXI_2 = 18
const int | JY5320Import::JY5320_DigitalTriggerSource_PXI_3 = 19
const int | JY5320Import::JY5320_DigitalTriggerSource_PXI_4 = 20
const int | JY5320Import::JY5320_DigitalTriggerSource_PXI_5 = 21
const int | JY5320Import::JY5320_DigitalTriggerSource_PXI_6 = 22
const int | JY5320Import::JY5320_DigitalTriggerSource_PXI_7 = 23
const int | JY5320Import::JY5320_DigitalTriggerSource_Inter_AI_StartTrig = 24
const int | JY5320Import::JY5320_DigitalTriggerSource_Inter_AI_ReferenceTrig = 25
const int | JY5320Import::JY5320_DigitalTriggerSource_Inter_CIO_0_StartTrig = 26
const int | JY5320Import::JY5320_DigitalTriggerSource_Inter_CIO_1_StartTrig = 27
const int | JY5320Import::JY5320_DigitalTriggerSource_Inter_Counter_0_Output = 28
const int | JY5320Import::JY5320_DigitalTriggerSource_Inter_Counter_1_Output = 29
const int | JY5320Import::Or = 0
const int | JY5320Import::And = 1
const int | JY5320Import::JY5320_AnalogTriggerCondition_EnteringWindow = 0x0
const int | JY5320Import::JY5320_AnaloglTriggerCondition_LeavingWindow = 0x1
const int | JY5320Import::JY5320_AnalogTriggerEdge_RisingSlope = 0x0
const int | JY5320Import::JY5320_AnalogTriggerEdge_FallingSlope = 0x1
const int | JY5320Import::JY5320_AI_InternalClock = 0x0
const int | JY5320Import::JY5320_AI_ExternalClock = 0x1
const int | JY5320Import::JY5320_Clock_PFI_0 = 0
const int | JY5320Import::JY5320_Clock_PFI_1 = 1
const int | JY5320Import::JY5320_Clock_PFI_2 = 2
const int | JY5320Import::JY5320_Clock_PFI_3 = 3
const int | JY5320Import::JY5320_Clock_PFI_4 = 4
const int | JY5320Import::JY5320_Clock_PFI_5 = 5
const int | JY5320Import::JY5320_Clock_PFI_6 = 6
const int | JY5320Import::JY5320_Clock_PFI_7 = 7
const int | JY5320Import::JY5320_Clock_PFI_8 = 8
const int | JY5320Import::JY5320_Clock_PFI_9 = 9
const int | JY5320Import::JY5320_Clock_PFI_10 = 10
const int | JY5320Import::JY5320_Clock_PFI_11 = 11
const int | JY5320Import::JY5320_Clock_PFI_12 = 12
const int | JY5320Import::JY5320_Clock_PFI_13 = 13
const int | JY5320Import::JY5320_Clock_PFI_14 = 14
const int | JY5320Import::JY5320_Clock_PFI_15 = 15
const int | JY5320Import::JY5320_Clock_PXI_Trig_0 = 16
const int | JY5320Import::JY5320_Clock_PXI_Trig_1 = 17
const int | JY5320Import::JY5320_Clock_PXI_Trig_2 = 18
const int | JY5320Import::JY5320_Clock_PXI_Trig_3 = 19
const int | JY5320Import::JY5320_Clock_PXI_Trig_4 = 20
const int | JY5320Import::JY5320_Clock_PXI_Trig_5 = 21
const int | JY5320Import::JY5320_Clock_PXI_Trig_6 = 22
const int | JY5320Import::JY5320_Clock_PXI_Trig_7 = 23
const int | JY5320Import::JY5320_Inter_AI_SampleClock = 24
const int | JY5320Import::JY5320_Inter_CI_0_SampleClock = 25
const int | JY5320Import::JY5320_Inter_CI_1_SampleClock = 26
const int | JY5320Import::JY5320_Inter_CO_0_Output = 27
const int | JY5320Import::JY5320_Inter_CO_1_Output = 28
const int | JY5320Import::JY5320_Independent = 0x0
const int | JY5320Import::JY5320_MASTER = 0x1
const int | JY5320Import::JY5320_SLAVE = 0x3
const int | JY5320Import::JY5320_Signal_PFI_0 = 0
const int | JY5320Import::JY5320_Signal_PFI_1 = 1
const int | JY5320Import::JY5320_Signal_PFI_2 = 2
const int | JY5320Import::JY5320_Signal_PFI_3 = 3
const int | JY5320Import::JY5320_Signal_PFI_4 = 4
const int | JY5320Import::JY5320_Signal_PFI_5 = 5
const int | JY5320Import::JY5320_Signal_PFI_6 = 6
const int | JY5320Import::JY5320_Signal_PFI_7 = 7
const int | JY5320Import::JY5320_Signal_PFI_8 = 8
const int | JY5320Import::JY5320_Signal_PFI_9 = 9
const int | JY5320Import::JY5320_Signal_PFI_10 = 10
const int | JY5320Import::JY5320_Signal_PFI_11 = 11
const int | JY5320Import::JY5320_Signal_PFI_12 = 12
const int | JY5320Import::JY5320_Signal_PFI_14 = 14
const int | JY5320Import::JY5320_Signal_PFI_15 = 15
const int | JY5320Import::JY5320_Signal_PXI_Trig_0 = 16
const int | JY5320Import::JY5320_Signal_PXI_Trig_1 = 17
const int | JY5320Import::JY5320_Signal_PXI_Trig_2 = 18
const int | JY5320Import::JY5320_Signal_PXI_Trig_3 = 19
const int | JY5320Import::JY5320_Signal_PXI_Trig_4 = 20
const int | JY5320Import::JY5320_Signal_PXI_Trig_5 = 21
const int | JY5320Import::JY5320_Signal_PXI_Trig_6 = 22
const int | JY5320Import::JY5320_Signal_PXI_Trig_7 = 23
const int | JY5320Import::JY5320_AI_StartTrig = 24
const int | JY5320Import::JY5320_AI_ReferenceTrig = 25
const int | JY5320Import::JY5320_AI_SyncSignal = 26
const int | JY5320Import::JY5320_AI_SampleClock = 27
const int | JY5320Import::JY5320_CIO_0_StartTrig = 28
const int | JY5320Import::JY5320_CIO_1_StartTrig = 29
const int | JY5320Import::JY5320_CI0_SampleClock = 30
const int | JY5320Import::JY5320_CI1_SampleClock = 31
const int | JY5320Import::JY5320_CO_0_Output = 32
const int | JY5320Import::JY5320_CO_1_Output = 33
const int | JY5320Import::JY5320_CIO_100MHz = 34
const int | JY5320Import::JY5320_CIO_5MHz = 35
const int | JY5320Import::JY5320_CIO_100kHz = 36
const int | JY5320Import::JY5320_PFI0_OUT = 0
const int | JY5320Import::JY5320_PFI1_OUT = 1
const int | JY5320Import::JY5320_PFI2_OUT = 2
const int | JY5320Import::JY5320_PFI3_OUT = 3
const int | JY5320Import::JY5320_PFI4_OUT = 4
const int | JY5320Import::JY5320_PFI5_OUT = 5
const int | JY5320Import::JY5320_PFI6_OUT = 6
const int | JY5320Import::JY5320_PFI7_OUT = 7
const int | JY5320Import::JY5320_PFI8_OUT = 8
const int | JY5320Import::JY5320_PFI9_OUT = 9
const int | JY5320Import::JY5320_PFI10_OUT = 10
const int | JY5320Import::JY5320_PFI11_OUT = 11
const int | JY5320Import::JY5320_PFI12_OUT = 12
const int | JY5320Import::JY5320_PFI13_OUT = 13
const int | JY5320Import::JY5320_PFI14_OUT = 14
const int | JY5320Import::JY5320_PFI15_OUT = 15
const int | JY5320Import::JY5320_PXITrig0_OUT = 16
const int | JY5320Import::JY5320_PXITrig1_OUT = 17
const int | JY5320Import::JY5320_PXITrig2_OUT = 18
const int | JY5320Import::JY5320_PXITrig3_OUT = 19
const int | JY5320Import::JY5320_PXITrig4_OUT = 20
const int | JY5320Import::JY5320_PXITrig5_OUT = 21
const int | JY5320Import::JY5320_PXITrig6_OUT = 22
const int | JY5320Import::JY5320_PXITrig7_OUT = 23
const int | JY5320Import::JY5320_AI_SyncSignal_OUT = 24
const int | JY5320Import::JY5320_Internal_Timebase_100M = 0x0
const int | JY5320Import::JY5320_Internal_Timebase_5M = 0x1
const int | JY5320Import::JY5320_Internal_Timebase_100K = 0x2
const int | JY5320Import::JY5320_External_Timebase = 0x3
const int | JY5320Import::JY5320_CI_Count_Up = 0
const int | JY5320Import::JY5320_CI_Count_Down = 1
const int | JY5320Import::JY5320_CI_Count_External = 2
const int | JY5320Import::JY5320_CI_EdgeCount = 0
const int | JY5320Import::JY5320_CI_Measure_FrequencyOrPeriod = 1
const int | JY5320Import::JY5320_CI_Measure_PulseWidth = 2
const int | JY5320Import::JY5320_CI_Measure_SemiPeriod = 3
const int | JY5320Import::JY5320_CI_Measure_EdgeSeparation = 4
const int | JY5320Import::JY5320_CI_EncoderX1 = 5
const int | JY5320Import::JY5320_CI_EncoderX2 = 6
const int | JY5320Import::JY5320_CI_EncoderX4 = 7
const int | JY5320Import::JY5320_CI_EncoderTwoPulse = 8
const int | JY5320Import::JY5320_IN_PFI0 = 0
const int | JY5320Import::JY5320_IN_PFI1 = 1
const int | JY5320Import::JY5320_IN_PFI2 = 2
const int | JY5320Import::JY5320_IN_PFI3 = 3
const int | JY5320Import::JY5320_IN_PFI4 = 4
const int | JY5320Import::JY5320_IN_PFI5 = 5
const int | JY5320Import::JY5320_IN_PFI6 = 6
const int | JY5320Import::JY5320_IN_PFI7 = 7
const int | JY5320Import::JY5320_IN_PFI8 = 8
const int | JY5320Import::JY5320_IN_PFI9 = 9
const int | JY5320Import::JY5320_IN_PFI10 = 10
const int | JY5320Import::JY5320_IN_PFI11 = 11
const int | JY5320Import::JY5320_IN_PFI12 = 12
const int | JY5320Import::JY5320_IN_PFI13 = 13
const int | JY5320Import::JY5320_IN_PFI14 = 14
const int | JY5320Import::JY5320_IN_PFI15 = 15
const int | JY5320Import::JY5320_IN_PXI_Trig0 = 16
const int | JY5320Import::JY5320_IN_PXI_Trig1 = 17
const int | JY5320Import::JY5320_IN_PXI_Trig2 = 18
const int | JY5320Import::JY5320_IN_PXI_Trig3 = 19
const int | JY5320Import::JY5320_IN_PXI_Trig4 = 20
const int | JY5320Import::JY5320_IN_PXI_Trig5 = 21
const int | JY5320Import::JY5320_IN_PXI_Trig6 = 22
const int | JY5320Import::JY5320_IN_PXI_Trig7 = 23
const int | JY5320Import::JY5320_IN_AI_SampleClock = 24
const int | JY5320Import::JY5320_IN_CO_0_Output = 25
const int | JY5320Import::JY5320_IN_CO_1_Output = 26
const int | JY5320Import::JY5320_IN_CIO_100MHz = 27
const int | JY5320Import::JY5320_IN_CIO_5MHz = 28
const int | JY5320Import::JY5320_IN_CIO_100kHz = 29
const int | JY5320Import::JY5320_CI_ImplicitClock = 0
const int | JY5320Import::JY5320_CI_InternalClock = 1
const int | JY5320Import::JY5320_CI_ExternalClock = 2
const int | JY5320Import::JY5320_CI_CounterEventSignalIdleState_Low = 0
const int | JY5320Import::JY5320_CI_CounterEventSignalIdleState_High = 1
const int | JY5320Import::JY5320_LowLevel = 0
const int | JY5320Import::JY5320_HighLevel = 1
const int | JY5320Import::JY5320_CI_ReturnTwoValue = 0
const int | JY5320Import::JY5320_CI_ReturnOneValue = 1
const int | JY5320Import::JY5320_RisingEdge = 0
const int | JY5320Import::JY5320_FallingEdge = 1
const int | JY5320Import::JY5320_AnyEdge = 2
const int | JY5320Import::JY5320_CO_LowLevel = 0
CO Idle State.
const int | JY5320Import::JY5320_CO_HighLevel = 1
const int | JY5320Import::ReferenceOnboard_25M = 0x0
const int | JY5320Import::ReferencePXIeCLK_100M = 0x1
const int | JY5320Import::JY5320_1M_18Bit = 0x0
const int | JY5320Import::JY5320_1M_16Bit = 0x1
const int | JY5320Import::JY5320_200K_16Bit = 0x2
const int | JY5320Import::JY5320_32CH = 0x0
const int | JY5320Import::JY5320_16CH = 0x1

Macro Definition Documentation

◆ EXTERN_C

#define EXTERN_C extern

Windows.

Linux

◆ JY5320CoreOO_API

#define JY5320CoreOO_API


5320 C++ Programming Manual: JY5320CoreOO::JYDriverException Class Reference

  • JYDriverException
Public Member Functions | Public Attributes | List of all members
JY5320CoreOO::JYDriverException Class Reference

#include <JY5320CoreOOCommon.h>

Public Member Functions

JYDriverException (JYDriverExceptionPublic exceptionCode, std::string msg="")
JYDriverException (int, std::string msg)

Public Attributes

std::string exceptionMessage
JYDriverExceptionPublic errorCode
JYDriverException * FollowingException

Constructor & Destructor Documentation

◆ JYDriverException() [1/2]

JY5320CoreOO::JYDriverException::JYDriverException | ( | JYDriverExceptionPublic | exceptionCode,
 |  | std::string | msg = "" )

◆ JYDriverException() [2/2]

JY5320CoreOO::JYDriverException::JYDriverException | ( | int | ,
 |  | std::string | msg )

Member Data Documentation

◆ errorCode

JYDriverExceptionPublic JY5320CoreOO::JYDriverException::errorCode

◆ exceptionMessage

std::string JY5320CoreOO::JYDriverException::exceptionMessage

◆ FollowingException

JYDriverException* JY5320CoreOO::JYDriverException::FollowingException
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOCommon.h


5320 C++ Programming Manual: JY5320CoreOO::JY5320CoreOOProperty< ContainerClass, ValueType, propertyType > Class Template Reference

  • JY5320CoreOOProperty
Public Member Functions | List of all members
JY5320CoreOO::JY5320CoreOOProperty< ContainerClass, ValueType, propertyType > Class Template Reference

属性模板类 More...

#include <JY5320CoreOOCommon.h>

Public Member Functions

JY5320CoreOOProperty ()
JY5320CoreOOProperty (ContainerClass *cObject, ValueType(ContainerClass::*pGet)(), void(ContainerClass::*pSet)(ValueType value))
JY5320CoreOOProperty (ValueType(*pGet)(), void(*pSet)(ValueType value))
ValueType operator= (const ValueType &value)
operator ValueType ()

Detailed Description

template<typename ContainerClass, typename ValueType, JY5320CoreOOPropertyType propertyType>
class JY5320CoreOO::JY5320CoreOOProperty< ContainerClass, ValueType, propertyType >

属性模板类

Constructor & Destructor Documentation

◆ JY5320CoreOOProperty() [1/3]

template<typename ContainerClass, typename ValueType, JY5320CoreOOPropertyType propertyType>
JY5320CoreOO::JY5320CoreOOProperty< ContainerClass, ValueType, propertyType >::JY5320CoreOOProperty ( )

◆ JY5320CoreOOProperty() [2/3]

template<typename ContainerClass, typename ValueType, JY5320CoreOOPropertyType propertyType>
JY5320CoreOO::JY5320CoreOOProperty< ContainerClass, ValueType, propertyType >::JY5320CoreOOProperty | ( | ContainerClass * | cObject,
 |  | ValueType(ContainerClass::* | pGet )(),
 |  | void(ContainerClass::* | pSet )(ValueType value) )

◆ JY5320CoreOOProperty() [3/3]

template<typename ContainerClass, typename ValueType, JY5320CoreOOPropertyType propertyType>
JY5320CoreOO::JY5320CoreOOProperty< ContainerClass, ValueType, propertyType >::JY5320CoreOOProperty | ( | ValueType(* | pGet )(),
 |  | void(* | pSet )(ValueType value) )

Member Function Documentation

◆ operator ValueType()

template<typename ContainerClass, typename ValueType, JY5320CoreOOPropertyType propertyType>
JY5320CoreOO::JY5320CoreOOProperty< ContainerClass, ValueType, propertyType >::operator ValueType ( )

◆ operator=()

template<typename ContainerClass, typename ValueType, JY5320CoreOOPropertyType propertyType>
ValueType JY5320CoreOO::JY5320CoreOOProperty< ContainerClass, ValueType, propertyType >::operator= ( const ValueType & value )
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOCommon.h


5320 C++ Programming Manual: JY5320CoreOO::PauseTrigger Class Reference

  • PauseTrigger
Public Attributes | List of all members
JY5320CoreOO::PauseTrigger Class Reference

Pause trigger configuration class. More...

#include <JY5320CoreOOCommon.h>

Public Attributes

LevelPolarity ActivePolarity
Pause trigger active polarity.
InputTerminal Terminal
Terminal.

Detailed Description

Pause trigger configuration class.

Member Data Documentation

◆ ActivePolarity

LevelPolarity JY5320CoreOO::PauseTrigger::ActivePolarity

Pause trigger active polarity.

The default value is LevelPolarity.None, means the pause trigger is disabled.

◆ Terminal

InputTerminal JY5320CoreOO::PauseTrigger::Terminal

Terminal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOCommon.h


5320 C++ Programming Manual: JY5320Import Namespace Reference

  • Namespace List
  • Namespace Members
Variables
JY5320Import Namespace Reference

Variables

const int | JY5320_AI_BandWidth_25K = 0x0
const int | JY5320_AI_BandWidth_220K = 0x1
const int | JY5320_AI_Finite = 0x00
const int | JY5320_AI_Continuous = 0x01
const int | JY5320_AI_Single = 0x02
const int | JY5320_CI_Finite = 0
const int | JY5320_CI_Continuous = 1
const int | JY5320_CI_Single = 2
const int | JY5320_CO_Finite = 0x0
const int | JY5320_CO_ContinuousWrapping = 0x1
const int | JY5320_CO_ContinuousNoWrapping = 0x2
const int | JY5320_CO_Single = 0x3
const int | JY5320_TriggerType_Immediately = 0x0
const int | JY5320_TriggerType_Digital = 0x1
const int | JY5320_TriggerType_Analog = 0x2
const int | JY5320_TriggerType_Soft = 0x3
const int | JY5320_CIO_Immediately = 0x0
const int | JY5320_CIO_Soft = 0x1
const int | JY5320_CIO_Digital = 0x2
const int | JY5320_StartTrigger = 0x0
const int | JY5320_ReferenceTrigger = 0x1
const int | JY5320_DigitalTriggerEdge_Rising = 0x0
const int | JY5320_DigitalTriggerEdge_Falling = 0x1
const int | JY5320_DigitalTriggerSource_PFI_0 = 0
const int | JY5320_DigitalTriggerSource_PFI_1 = 1
const int | JY5320_DigitalTriggerSource_PFI_2 = 2
const int | JY5320_DigitalTriggerSource_PFI_3 = 3
const int | JY5320_DigitalTriggerSource_PFI_4 = 4
const int | JY5320_DigitalTriggerSource_PFI_5 = 5
const int | JY5320_DigitalTriggerSource_PFI_6 = 6
const int | JY5320_DigitalTriggerSource_PFI_7 = 7
const int | JY5320_DigitalTriggerSource_PFI_8 = 8
const int | JY5320_DigitalTriggerSource_PFI_9 = 9
const int | JY5320_DigitalTriggerSource_PFI_10 = 10
const int | JY5320_DigitalTriggerSource_PFI_11 = 11
const int | JY5320_DigitalTriggerSource_PFI_12 = 12
const int | JY5320_DigitalTriggerSource_PFI_13 = 13
const int | JY5320_DigitalTriggerSource_PFI_14 = 14
const int | JY5320_DigitalTriggerSource_PFI_15 = 15
const int | JY5320_DigitalTriggerSource_PXI_0 = 16
const int | JY5320_DigitalTriggerSource_PXI_1 = 17
const int | JY5320_DigitalTriggerSource_PXI_2 = 18
const int | JY5320_DigitalTriggerSource_PXI_3 = 19
const int | JY5320_DigitalTriggerSource_PXI_4 = 20
const int | JY5320_DigitalTriggerSource_PXI_5 = 21
const int | JY5320_DigitalTriggerSource_PXI_6 = 22
const int | JY5320_DigitalTriggerSource_PXI_7 = 23
const int | JY5320_DigitalTriggerSource_Inter_AI_StartTrig = 24
const int | JY5320_DigitalTriggerSource_Inter_AI_ReferenceTrig = 25
const int | JY5320_DigitalTriggerSource_Inter_CIO_0_StartTrig = 26
const int | JY5320_DigitalTriggerSource_Inter_CIO_1_StartTrig = 27
const int | JY5320_DigitalTriggerSource_Inter_Counter_0_Output = 28
const int | JY5320_DigitalTriggerSource_Inter_Counter_1_Output = 29
const int | Or = 0
const int | And = 1
const int | JY5320_AnalogTriggerCondition_EnteringWindow = 0x0
const int | JY5320_AnaloglTriggerCondition_LeavingWindow = 0x1
const int | JY5320_AnalogTriggerEdge_RisingSlope = 0x0
const int | JY5320_AnalogTriggerEdge_FallingSlope = 0x1
const int | JY5320_AI_InternalClock = 0x0
const int | JY5320_AI_ExternalClock = 0x1
const int | JY5320_Clock_PFI_0 = 0
const int | JY5320_Clock_PFI_1 = 1
const int | JY5320_Clock_PFI_2 = 2
const int | JY5320_Clock_PFI_3 = 3
const int | JY5320_Clock_PFI_4 = 4
const int | JY5320_Clock_PFI_5 = 5
const int | JY5320_Clock_PFI_6 = 6
const int | JY5320_Clock_PFI_7 = 7
const int | JY5320_Clock_PFI_8 = 8
const int | JY5320_Clock_PFI_9 = 9
const int | JY5320_Clock_PFI_10 = 10
const int | JY5320_Clock_PFI_11 = 11
const int | JY5320_Clock_PFI_12 = 12
const int | JY5320_Clock_PFI_13 = 13
const int | JY5320_Clock_PFI_14 = 14
const int | JY5320_Clock_PFI_15 = 15
const int | JY5320_Clock_PXI_Trig_0 = 16
const int | JY5320_Clock_PXI_Trig_1 = 17
const int | JY5320_Clock_PXI_Trig_2 = 18
const int | JY5320_Clock_PXI_Trig_3 = 19
const int | JY5320_Clock_PXI_Trig_4 = 20
const int | JY5320_Clock_PXI_Trig_5 = 21
const int | JY5320_Clock_PXI_Trig_6 = 22
const int | JY5320_Clock_PXI_Trig_7 = 23
const int | JY5320_Inter_AI_SampleClock = 24
const int | JY5320_Inter_CI_0_SampleClock = 25
const int | JY5320_Inter_CI_1_SampleClock = 26
const int | JY5320_Inter_CO_0_Output = 27
const int | JY5320_Inter_CO_1_Output = 28
const int | JY5320_Independent = 0x0
const int | JY5320_MASTER = 0x1
const int | JY5320_SLAVE = 0x3
const int | JY5320_Signal_PFI_0 = 0
const int | JY5320_Signal_PFI_1 = 1
const int | JY5320_Signal_PFI_2 = 2
const int | JY5320_Signal_PFI_3 = 3
const int | JY5320_Signal_PFI_4 = 4
const int | JY5320_Signal_PFI_5 = 5
const int | JY5320_Signal_PFI_6 = 6
const int | JY5320_Signal_PFI_7 = 7
const int | JY5320_Signal_PFI_8 = 8
const int | JY5320_Signal_PFI_9 = 9
const int | JY5320_Signal_PFI_10 = 10
const int | JY5320_Signal_PFI_11 = 11
const int | JY5320_Signal_PFI_12 = 12
const int | JY5320_Signal_PFI_14 = 14
const int | JY5320_Signal_PFI_15 = 15
const int | JY5320_Signal_PXI_Trig_0 = 16
const int | JY5320_Signal_PXI_Trig_1 = 17
const int | JY5320_Signal_PXI_Trig_2 = 18
const int | JY5320_Signal_PXI_Trig_3 = 19
const int | JY5320_Signal_PXI_Trig_4 = 20
const int | JY5320_Signal_PXI_Trig_5 = 21
const int | JY5320_Signal_PXI_Trig_6 = 22
const int | JY5320_Signal_PXI_Trig_7 = 23
const int | JY5320_AI_StartTrig = 24
const int | JY5320_AI_ReferenceTrig = 25
const int | JY5320_AI_SyncSignal = 26
const int | JY5320_AI_SampleClock = 27
const int | JY5320_CIO_0_StartTrig = 28
const int | JY5320_CIO_1_StartTrig = 29
const int | JY5320_CI0_SampleClock = 30
const int | JY5320_CI1_SampleClock = 31
const int | JY5320_CO_0_Output = 32
const int | JY5320_CO_1_Output = 33
const int | JY5320_CIO_100MHz = 34
const int | JY5320_CIO_5MHz = 35
const int | JY5320_CIO_100kHz = 36
const int | JY5320_PFI0_OUT = 0
const int | JY5320_PFI1_OUT = 1
const int | JY5320_PFI2_OUT = 2
const int | JY5320_PFI3_OUT = 3
const int | JY5320_PFI4_OUT = 4
const int | JY5320_PFI5_OUT = 5
const int | JY5320_PFI6_OUT = 6
const int | JY5320_PFI7_OUT = 7
const int | JY5320_PFI8_OUT = 8
const int | JY5320_PFI9_OUT = 9
const int | JY5320_PFI10_OUT = 10
const int | JY5320_PFI11_OUT = 11
const int | JY5320_PFI12_OUT = 12
const int | JY5320_PFI13_OUT = 13
const int | JY5320_PFI14_OUT = 14
const int | JY5320_PFI15_OUT = 15
const int | JY5320_PXITrig0_OUT = 16
const int | JY5320_PXITrig1_OUT = 17
const int | JY5320_PXITrig2_OUT = 18
const int | JY5320_PXITrig3_OUT = 19
const int | JY5320_PXITrig4_OUT = 20
const int | JY5320_PXITrig5_OUT = 21
const int | JY5320_PXITrig6_OUT = 22
const int | JY5320_PXITrig7_OUT = 23
const int | JY5320_AI_SyncSignal_OUT = 24
const int | JY5320_Internal_Timebase_100M = 0x0
const int | JY5320_Internal_Timebase_5M = 0x1
const int | JY5320_Internal_Timebase_100K = 0x2
const int | JY5320_External_Timebase = 0x3
const int | JY5320_CI_Count_Up = 0
const int | JY5320_CI_Count_Down = 1
const int | JY5320_CI_Count_External = 2
const int | JY5320_CI_EdgeCount = 0
const int | JY5320_CI_Measure_FrequencyOrPeriod = 1
const int | JY5320_CI_Measure_PulseWidth = 2
const int | JY5320_CI_Measure_SemiPeriod = 3
const int | JY5320_CI_Measure_EdgeSeparation = 4
const int | JY5320_CI_EncoderX1 = 5
const int | JY5320_CI_EncoderX2 = 6
const int | JY5320_CI_EncoderX4 = 7
const int | JY5320_CI_EncoderTwoPulse = 8
const int | JY5320_IN_PFI0 = 0
const int | JY5320_IN_PFI1 = 1
const int | JY5320_IN_PFI2 = 2
const int | JY5320_IN_PFI3 = 3
const int | JY5320_IN_PFI4 = 4
const int | JY5320_IN_PFI5 = 5
const int | JY5320_IN_PFI6 = 6
const int | JY5320_IN_PFI7 = 7
const int | JY5320_IN_PFI8 = 8
const int | JY5320_IN_PFI9 = 9
const int | JY5320_IN_PFI10 = 10
const int | JY5320_IN_PFI11 = 11
const int | JY5320_IN_PFI12 = 12
const int | JY5320_IN_PFI13 = 13
const int | JY5320_IN_PFI14 = 14
const int | JY5320_IN_PFI15 = 15
const int | JY5320_IN_PXI_Trig0 = 16
const int | JY5320_IN_PXI_Trig1 = 17
const int | JY5320_IN_PXI_Trig2 = 18
const int | JY5320_IN_PXI_Trig3 = 19
const int | JY5320_IN_PXI_Trig4 = 20
const int | JY5320_IN_PXI_Trig5 = 21
const int | JY5320_IN_PXI_Trig6 = 22
const int | JY5320_IN_PXI_Trig7 = 23
const int | JY5320_IN_AI_SampleClock = 24
const int | JY5320_IN_CO_0_Output = 25
const int | JY5320_IN_CO_1_Output = 26
const int | JY5320_IN_CIO_100MHz = 27
const int | JY5320_IN_CIO_5MHz = 28
const int | JY5320_IN_CIO_100kHz = 29
const int | JY5320_CI_ImplicitClock = 0
const int | JY5320_CI_InternalClock = 1
const int | JY5320_CI_ExternalClock = 2
const int | JY5320_CI_CounterEventSignalIdleState_Low = 0
const int | JY5320_CI_CounterEventSignalIdleState_High = 1
const int | JY5320_LowLevel = 0
const int | JY5320_HighLevel = 1
const int | JY5320_CI_ReturnTwoValue = 0
const int | JY5320_CI_ReturnOneValue = 1
const int | JY5320_RisingEdge = 0
const int | JY5320_FallingEdge = 1
const int | JY5320_AnyEdge = 2
const int | JY5320_CO_LowLevel = 0
CO Idle State.
const int | JY5320_CO_HighLevel = 1
const int | ReferenceOnboard_25M = 0x0
const int | ReferencePXIeCLK_100M = 0x1
const int | JY5320_1M_18Bit = 0x0
const int | JY5320_1M_16Bit = 0x1
const int | JY5320_200K_16Bit = 0x2
const int | JY5320_32CH = 0x0
const int | JY5320_16CH = 0x1

Variable Documentation

◆ And

const int JY5320Import::And = 1

◆ JY5320_16CH

const int JY5320Import::JY5320_16CH = 0x1

◆ JY5320_1M_16Bit

const int JY5320Import::JY5320_1M_16Bit = 0x1

◆ JY5320_1M_18Bit

const int JY5320Import::JY5320_1M_18Bit = 0x0

◆ JY5320_200K_16Bit

const int JY5320Import::JY5320_200K_16Bit = 0x2

◆ JY5320_32CH

const int JY5320Import::JY5320_32CH = 0x0

◆ JY5320_AI_BandWidth_220K

const int JY5320Import::JY5320_AI_BandWidth_220K = 0x1

◆ JY5320_AI_BandWidth_25K

const int JY5320Import::JY5320_AI_BandWidth_25K = 0x0

◆ JY5320_AI_Continuous

const int JY5320Import::JY5320_AI_Continuous = 0x01

◆ JY5320_AI_ExternalClock

const int JY5320Import::JY5320_AI_ExternalClock = 0x1

◆ JY5320_AI_Finite

const int JY5320Import::JY5320_AI_Finite = 0x00

◆ JY5320_AI_InternalClock

const int JY5320Import::JY5320_AI_InternalClock = 0x0

◆ JY5320_AI_ReferenceTrig

const int JY5320Import::JY5320_AI_ReferenceTrig = 25

◆ JY5320_AI_SampleClock

const int JY5320Import::JY5320_AI_SampleClock = 27

◆ JY5320_AI_Single

const int JY5320Import::JY5320_AI_Single = 0x02

◆ JY5320_AI_StartTrig

const int JY5320Import::JY5320_AI_StartTrig = 24

◆ JY5320_AI_SyncSignal

const int JY5320Import::JY5320_AI_SyncSignal = 26

◆ JY5320_AI_SyncSignal_OUT

const int JY5320Import::JY5320_AI_SyncSignal_OUT = 24

◆ JY5320_AnaloglTriggerCondition_LeavingWindow

const int JY5320Import::JY5320_AnaloglTriggerCondition_LeavingWindow = 0x1

◆ JY5320_AnalogTriggerCondition_EnteringWindow

const int JY5320Import::JY5320_AnalogTriggerCondition_EnteringWindow = 0x0

◆ JY5320_AnalogTriggerEdge_FallingSlope

const int JY5320Import::JY5320_AnalogTriggerEdge_FallingSlope = 0x1

◆ JY5320_AnalogTriggerEdge_RisingSlope

const int JY5320Import::JY5320_AnalogTriggerEdge_RisingSlope = 0x0

◆ JY5320_AnyEdge

const int JY5320Import::JY5320_AnyEdge = 2

◆ JY5320_CI0_SampleClock

const int JY5320Import::JY5320_CI0_SampleClock = 30

◆ JY5320_CI1_SampleClock

const int JY5320Import::JY5320_CI1_SampleClock = 31

◆ JY5320_CI_Continuous

const int JY5320Import::JY5320_CI_Continuous = 1

◆ JY5320_CI_Count_Down

const int JY5320Import::JY5320_CI_Count_Down = 1

◆ JY5320_CI_Count_External

const int JY5320Import::JY5320_CI_Count_External = 2

◆ JY5320_CI_Count_Up

const int JY5320Import::JY5320_CI_Count_Up = 0

◆ JY5320_CI_CounterEventSignalIdleState_High

const int JY5320Import::JY5320_CI_CounterEventSignalIdleState_High = 1

◆ JY5320_CI_CounterEventSignalIdleState_Low

const int JY5320Import::JY5320_CI_CounterEventSignalIdleState_Low = 0

◆ JY5320_CI_EdgeCount

const int JY5320Import::JY5320_CI_EdgeCount = 0

◆ JY5320_CI_EncoderTwoPulse

const int JY5320Import::JY5320_CI_EncoderTwoPulse = 8

◆ JY5320_CI_EncoderX1

const int JY5320Import::JY5320_CI_EncoderX1 = 5

◆ JY5320_CI_EncoderX2

const int JY5320Import::JY5320_CI_EncoderX2 = 6

◆ JY5320_CI_EncoderX4

const int JY5320Import::JY5320_CI_EncoderX4 = 7

◆ JY5320_CI_ExternalClock

const int JY5320Import::JY5320_CI_ExternalClock = 2

◆ JY5320_CI_Finite

const int JY5320Import::JY5320_CI_Finite = 0

◆ JY5320_CI_ImplicitClock

const int JY5320Import::JY5320_CI_ImplicitClock = 0

◆ JY5320_CI_InternalClock

const int JY5320Import::JY5320_CI_InternalClock = 1

◆ JY5320_CI_Measure_EdgeSeparation

const int JY5320Import::JY5320_CI_Measure_EdgeSeparation = 4

◆ JY5320_CI_Measure_FrequencyOrPeriod

const int JY5320Import::JY5320_CI_Measure_FrequencyOrPeriod = 1

◆ JY5320_CI_Measure_PulseWidth

const int JY5320Import::JY5320_CI_Measure_PulseWidth = 2

◆ JY5320_CI_Measure_SemiPeriod

const int JY5320Import::JY5320_CI_Measure_SemiPeriod = 3

◆ JY5320_CI_ReturnOneValue

const int JY5320Import::JY5320_CI_ReturnOneValue = 1

◆ JY5320_CI_ReturnTwoValue

const int JY5320Import::JY5320_CI_ReturnTwoValue = 0

◆ JY5320_CI_Single

const int JY5320Import::JY5320_CI_Single = 2

◆ JY5320_CIO_0_StartTrig

const int JY5320Import::JY5320_CIO_0_StartTrig = 28

◆ JY5320_CIO_100kHz

const int JY5320Import::JY5320_CIO_100kHz = 36

◆ JY5320_CIO_100MHz

const int JY5320Import::JY5320_CIO_100MHz = 34

◆ JY5320_CIO_1_StartTrig

const int JY5320Import::JY5320_CIO_1_StartTrig = 29

◆ JY5320_CIO_5MHz

const int JY5320Import::JY5320_CIO_5MHz = 35

◆ JY5320_CIO_Digital

const int JY5320Import::JY5320_CIO_Digital = 0x2

◆ JY5320_CIO_Immediately

const int JY5320Import::JY5320_CIO_Immediately = 0x0

◆ JY5320_CIO_Soft

const int JY5320Import::JY5320_CIO_Soft = 0x1

◆ JY5320_Clock_PFI_0

const int JY5320Import::JY5320_Clock_PFI_0 = 0

◆ JY5320_Clock_PFI_1

const int JY5320Import::JY5320_Clock_PFI_1 = 1

◆ JY5320_Clock_PFI_10

const int JY5320Import::JY5320_Clock_PFI_10 = 10

◆ JY5320_Clock_PFI_11

const int JY5320Import::JY5320_Clock_PFI_11 = 11

◆ JY5320_Clock_PFI_12

const int JY5320Import::JY5320_Clock_PFI_12 = 12

◆ JY5320_Clock_PFI_13

const int JY5320Import::JY5320_Clock_PFI_13 = 13

◆ JY5320_Clock_PFI_14

const int JY5320Import::JY5320_Clock_PFI_14 = 14

◆ JY5320_Clock_PFI_15

const int JY5320Import::JY5320_Clock_PFI_15 = 15

◆ JY5320_Clock_PFI_2

const int JY5320Import::JY5320_Clock_PFI_2 = 2

◆ JY5320_Clock_PFI_3

const int JY5320Import::JY5320_Clock_PFI_3 = 3

◆ JY5320_Clock_PFI_4

const int JY5320Import::JY5320_Clock_PFI_4 = 4

◆ JY5320_Clock_PFI_5

const int JY5320Import::JY5320_Clock_PFI_5 = 5

◆ JY5320_Clock_PFI_6

const int JY5320Import::JY5320_Clock_PFI_6 = 6

◆ JY5320_Clock_PFI_7

const int JY5320Import::JY5320_Clock_PFI_7 = 7

◆ JY5320_Clock_PFI_8

const int JY5320Import::JY5320_Clock_PFI_8 = 8

◆ JY5320_Clock_PFI_9

const int JY5320Import::JY5320_Clock_PFI_9 = 9

◆ JY5320_Clock_PXI_Trig_0

const int JY5320Import::JY5320_Clock_PXI_Trig_0 = 16

◆ JY5320_Clock_PXI_Trig_1

const int JY5320Import::JY5320_Clock_PXI_Trig_1 = 17

◆ JY5320_Clock_PXI_Trig_2

const int JY5320Import::JY5320_Clock_PXI_Trig_2 = 18

◆ JY5320_Clock_PXI_Trig_3

const int JY5320Import::JY5320_Clock_PXI_Trig_3 = 19

◆ JY5320_Clock_PXI_Trig_4

const int JY5320Import::JY5320_Clock_PXI_Trig_4 = 20

◆ JY5320_Clock_PXI_Trig_5

const int JY5320Import::JY5320_Clock_PXI_Trig_5 = 21

◆ JY5320_Clock_PXI_Trig_6

const int JY5320Import::JY5320_Clock_PXI_Trig_6 = 22

◆ JY5320_Clock_PXI_Trig_7

const int JY5320Import::JY5320_Clock_PXI_Trig_7 = 23

◆ JY5320_CO_0_Output

const int JY5320Import::JY5320_CO_0_Output = 32

◆ JY5320_CO_1_Output

const int JY5320Import::JY5320_CO_1_Output = 33

◆ JY5320_CO_ContinuousNoWrapping

const int JY5320Import::JY5320_CO_ContinuousNoWrapping = 0x2

◆ JY5320_CO_ContinuousWrapping

const int JY5320Import::JY5320_CO_ContinuousWrapping = 0x1

◆ JY5320_CO_Finite

const int JY5320Import::JY5320_CO_Finite = 0x0

◆ JY5320_CO_HighLevel

const int JY5320Import::JY5320_CO_HighLevel = 1

◆ JY5320_CO_LowLevel

const int JY5320Import::JY5320_CO_LowLevel = 0

CO Idle State.

◆ JY5320_CO_Single

const int JY5320Import::JY5320_CO_Single = 0x3

◆ JY5320_DigitalTriggerEdge_Falling

const int JY5320Import::JY5320_DigitalTriggerEdge_Falling = 0x1

◆ JY5320_DigitalTriggerEdge_Rising

const int JY5320Import::JY5320_DigitalTriggerEdge_Rising = 0x0

◆ JY5320_DigitalTriggerSource_Inter_AI_ReferenceTrig

const int JY5320Import::JY5320_DigitalTriggerSource_Inter_AI_ReferenceTrig = 25

◆ JY5320_DigitalTriggerSource_Inter_AI_StartTrig

const int JY5320Import::JY5320_DigitalTriggerSource_Inter_AI_StartTrig = 24

◆ JY5320_DigitalTriggerSource_Inter_CIO_0_StartTrig

const int JY5320Import::JY5320_DigitalTriggerSource_Inter_CIO_0_StartTrig = 26

◆ JY5320_DigitalTriggerSource_Inter_CIO_1_StartTrig

const int JY5320Import::JY5320_DigitalTriggerSource_Inter_CIO_1_StartTrig = 27

◆ JY5320_DigitalTriggerSource_Inter_Counter_0_Output

const int JY5320Import::JY5320_DigitalTriggerSource_Inter_Counter_0_Output = 28

◆ JY5320_DigitalTriggerSource_Inter_Counter_1_Output

const int JY5320Import::JY5320_DigitalTriggerSource_Inter_Counter_1_Output = 29

◆ JY5320_DigitalTriggerSource_PFI_0

const int JY5320Import::JY5320_DigitalTriggerSource_PFI_0 = 0

◆ JY5320_DigitalTriggerSource_PFI_1

const int JY5320Import::JY5320_DigitalTriggerSource_PFI_1 = 1

◆ JY5320_DigitalTriggerSource_PFI_10

const int JY5320Import::JY5320_DigitalTriggerSource_PFI_10 = 10

◆ JY5320_DigitalTriggerSource_PFI_11

const int JY5320Import::JY5320_DigitalTriggerSource_PFI_11 = 11

◆ JY5320_DigitalTriggerSource_PFI_12

const int JY5320Import::JY5320_DigitalTriggerSource_PFI_12 = 12

◆ JY5320_DigitalTriggerSource_PFI_13

const int JY5320Import::JY5320_DigitalTriggerSource_PFI_13 = 13

◆ JY5320_DigitalTriggerSource_PFI_14

const int JY5320Import::JY5320_DigitalTriggerSource_PFI_14 = 14

◆ JY5320_DigitalTriggerSource_PFI_15

const int JY5320Import::JY5320_DigitalTriggerSource_PFI_15 = 15

◆ JY5320_DigitalTriggerSource_PFI_2

const int JY5320Import::JY5320_DigitalTriggerSource_PFI_2 = 2

◆ JY5320_DigitalTriggerSource_PFI_3

const int JY5320Import::JY5320_DigitalTriggerSource_PFI_3 = 3

◆ JY5320_DigitalTriggerSource_PFI_4

const int JY5320Import::JY5320_DigitalTriggerSource_PFI_4 = 4

◆ JY5320_DigitalTriggerSource_PFI_5

const int JY5320Import::JY5320_DigitalTriggerSource_PFI_5 = 5

◆ JY5320_DigitalTriggerSource_PFI_6

const int JY5320Import::JY5320_DigitalTriggerSource_PFI_6 = 6

◆ JY5320_DigitalTriggerSource_PFI_7

const int JY5320Import::JY5320_DigitalTriggerSource_PFI_7 = 7

◆ JY5320_DigitalTriggerSource_PFI_8

const int JY5320Import::JY5320_DigitalTriggerSource_PFI_8 = 8

◆ JY5320_DigitalTriggerSource_PFI_9

const int JY5320Import::JY5320_DigitalTriggerSource_PFI_9 = 9

◆ JY5320_DigitalTriggerSource_PXI_0

const int JY5320Import::JY5320_DigitalTriggerSource_PXI_0 = 16

◆ JY5320_DigitalTriggerSource_PXI_1

const int JY5320Import::JY5320_DigitalTriggerSource_PXI_1 = 17

◆ JY5320_DigitalTriggerSource_PXI_2

const int JY5320Import::JY5320_DigitalTriggerSource_PXI_2 = 18

◆ JY5320_DigitalTriggerSource_PXI_3

const int JY5320Import::JY5320_DigitalTriggerSource_PXI_3 = 19

◆ JY5320_DigitalTriggerSource_PXI_4

const int JY5320Import::JY5320_DigitalTriggerSource_PXI_4 = 20

◆ JY5320_DigitalTriggerSource_PXI_5

const int JY5320Import::JY5320_DigitalTriggerSource_PXI_5 = 21

◆ JY5320_DigitalTriggerSource_PXI_6

const int JY5320Import::JY5320_DigitalTriggerSource_PXI_6 = 22

◆ JY5320_DigitalTriggerSource_PXI_7

const int JY5320Import::JY5320_DigitalTriggerSource_PXI_7 = 23

◆ JY5320_External_Timebase

const int JY5320Import::JY5320_External_Timebase = 0x3

◆ JY5320_FallingEdge

const int JY5320Import::JY5320_FallingEdge = 1

◆ JY5320_HighLevel

const int JY5320Import::JY5320_HighLevel = 1

◆ JY5320_IN_AI_SampleClock

const int JY5320Import::JY5320_IN_AI_SampleClock = 24

◆ JY5320_IN_CIO_100kHz

const int JY5320Import::JY5320_IN_CIO_100kHz = 29

◆ JY5320_IN_CIO_100MHz

const int JY5320Import::JY5320_IN_CIO_100MHz = 27

◆ JY5320_IN_CIO_5MHz

const int JY5320Import::JY5320_IN_CIO_5MHz = 28

◆ JY5320_IN_CO_0_Output

const int JY5320Import::JY5320_IN_CO_0_Output = 25

◆ JY5320_IN_CO_1_Output

const int JY5320Import::JY5320_IN_CO_1_Output = 26

◆ JY5320_IN_PFI0

const int JY5320Import::JY5320_IN_PFI0 = 0

◆ JY5320_IN_PFI1

const int JY5320Import::JY5320_IN_PFI1 = 1

◆ JY5320_IN_PFI10

const int JY5320Import::JY5320_IN_PFI10 = 10

◆ JY5320_IN_PFI11

const int JY5320Import::JY5320_IN_PFI11 = 11

◆ JY5320_IN_PFI12

const int JY5320Import::JY5320_IN_PFI12 = 12

◆ JY5320_IN_PFI13

const int JY5320Import::JY5320_IN_PFI13 = 13

◆ JY5320_IN_PFI14

const int JY5320Import::JY5320_IN_PFI14 = 14

◆ JY5320_IN_PFI15

const int JY5320Import::JY5320_IN_PFI15 = 15

◆ JY5320_IN_PFI2

const int JY5320Import::JY5320_IN_PFI2 = 2

◆ JY5320_IN_PFI3

const int JY5320Import::JY5320_IN_PFI3 = 3

◆ JY5320_IN_PFI4

const int JY5320Import::JY5320_IN_PFI4 = 4

◆ JY5320_IN_PFI5

const int JY5320Import::JY5320_IN_PFI5 = 5

◆ JY5320_IN_PFI6

const int JY5320Import::JY5320_IN_PFI6 = 6

◆ JY5320_IN_PFI7

const int JY5320Import::JY5320_IN_PFI7 = 7

◆ JY5320_IN_PFI8

const int JY5320Import::JY5320_IN_PFI8 = 8

◆ JY5320_IN_PFI9

const int JY5320Import::JY5320_IN_PFI9 = 9

◆ JY5320_IN_PXI_Trig0

const int JY5320Import::JY5320_IN_PXI_Trig0 = 16

◆ JY5320_IN_PXI_Trig1

const int JY5320Import::JY5320_IN_PXI_Trig1 = 17

◆ JY5320_IN_PXI_Trig2

const int JY5320Import::JY5320_IN_PXI_Trig2 = 18

◆ JY5320_IN_PXI_Trig3

const int JY5320Import::JY5320_IN_PXI_Trig3 = 19

◆ JY5320_IN_PXI_Trig4

const int JY5320Import::JY5320_IN_PXI_Trig4 = 20

◆ JY5320_IN_PXI_Trig5

const int JY5320Import::JY5320_IN_PXI_Trig5 = 21

◆ JY5320_IN_PXI_Trig6

const int JY5320Import::JY5320_IN_PXI_Trig6 = 22

◆ JY5320_IN_PXI_Trig7

const int JY5320Import::JY5320_IN_PXI_Trig7 = 23

◆ JY5320_Independent

const int JY5320Import::JY5320_Independent = 0x0

◆ JY5320_Inter_AI_SampleClock

const int JY5320Import::JY5320_Inter_AI_SampleClock = 24

◆ JY5320_Inter_CI_0_SampleClock

const int JY5320Import::JY5320_Inter_CI_0_SampleClock = 25

◆ JY5320_Inter_CI_1_SampleClock

const int JY5320Import::JY5320_Inter_CI_1_SampleClock = 26

◆ JY5320_Inter_CO_0_Output

const int JY5320Import::JY5320_Inter_CO_0_Output = 27

◆ JY5320_Inter_CO_1_Output

const int JY5320Import::JY5320_Inter_CO_1_Output = 28

◆ JY5320_Internal_Timebase_100K

const int JY5320Import::JY5320_Internal_Timebase_100K = 0x2

◆ JY5320_Internal_Timebase_100M

const int JY5320Import::JY5320_Internal_Timebase_100M = 0x0

◆ JY5320_Internal_Timebase_5M

const int JY5320Import::JY5320_Internal_Timebase_5M = 0x1

◆ JY5320_LowLevel

const int JY5320Import::JY5320_LowLevel = 0

◆ JY5320_MASTER

const int JY5320Import::JY5320_MASTER = 0x1

◆ JY5320_PFI0_OUT

const int JY5320Import::JY5320_PFI0_OUT = 0

◆ JY5320_PFI10_OUT

const int JY5320Import::JY5320_PFI10_OUT = 10

◆ JY5320_PFI11_OUT

const int JY5320Import::JY5320_PFI11_OUT = 11

◆ JY5320_PFI12_OUT

const int JY5320Import::JY5320_PFI12_OUT = 12

◆ JY5320_PFI13_OUT

const int JY5320Import::JY5320_PFI13_OUT = 13

◆ JY5320_PFI14_OUT

const int JY5320Import::JY5320_PFI14_OUT = 14

◆ JY5320_PFI15_OUT

const int JY5320Import::JY5320_PFI15_OUT = 15

◆ JY5320_PFI1_OUT

const int JY5320Import::JY5320_PFI1_OUT = 1

◆ JY5320_PFI2_OUT

const int JY5320Import::JY5320_PFI2_OUT = 2

◆ JY5320_PFI3_OUT

const int JY5320Import::JY5320_PFI3_OUT = 3

◆ JY5320_PFI4_OUT

const int JY5320Import::JY5320_PFI4_OUT = 4

◆ JY5320_PFI5_OUT

const int JY5320Import::JY5320_PFI5_OUT = 5

◆ JY5320_PFI6_OUT

const int JY5320Import::JY5320_PFI6_OUT = 6

◆ JY5320_PFI7_OUT

const int JY5320Import::JY5320_PFI7_OUT = 7

◆ JY5320_PFI8_OUT

const int JY5320Import::JY5320_PFI8_OUT = 8

◆ JY5320_PFI9_OUT

const int JY5320Import::JY5320_PFI9_OUT = 9

◆ JY5320_PXITrig0_OUT

const int JY5320Import::JY5320_PXITrig0_OUT = 16

◆ JY5320_PXITrig1_OUT

const int JY5320Import::JY5320_PXITrig1_OUT = 17

◆ JY5320_PXITrig2_OUT

const int JY5320Import::JY5320_PXITrig2_OUT = 18

◆ JY5320_PXITrig3_OUT

const int JY5320Import::JY5320_PXITrig3_OUT = 19

◆ JY5320_PXITrig4_OUT

const int JY5320Import::JY5320_PXITrig4_OUT = 20

◆ JY5320_PXITrig5_OUT

const int JY5320Import::JY5320_PXITrig5_OUT = 21

◆ JY5320_PXITrig6_OUT

const int JY5320Import::JY5320_PXITrig6_OUT = 22

◆ JY5320_PXITrig7_OUT

const int JY5320Import::JY5320_PXITrig7_OUT = 23

◆ JY5320_ReferenceTrigger

const int JY5320Import::JY5320_ReferenceTrigger = 0x1

◆ JY5320_RisingEdge

const int JY5320Import::JY5320_RisingEdge = 0

◆ JY5320_Signal_PFI_0

const int JY5320Import::JY5320_Signal_PFI_0 = 0

◆ JY5320_Signal_PFI_1

const int JY5320Import::JY5320_Signal_PFI_1 = 1

◆ JY5320_Signal_PFI_10

const int JY5320Import::JY5320_Signal_PFI_10 = 10

◆ JY5320_Signal_PFI_11

const int JY5320Import::JY5320_Signal_PFI_11 = 11

◆ JY5320_Signal_PFI_12

const int JY5320Import::JY5320_Signal_PFI_12 = 12

◆ JY5320_Signal_PFI_14

const int JY5320Import::JY5320_Signal_PFI_14 = 14

◆ JY5320_Signal_PFI_15

const int JY5320Import::JY5320_Signal_PFI_15 = 15

◆ JY5320_Signal_PFI_2

const int JY5320Import::JY5320_Signal_PFI_2 = 2

◆ JY5320_Signal_PFI_3

const int JY5320Import::JY5320_Signal_PFI_3 = 3

◆ JY5320_Signal_PFI_4

const int JY5320Import::JY5320_Signal_PFI_4 = 4

◆ JY5320_Signal_PFI_5

const int JY5320Import::JY5320_Signal_PFI_5 = 5

◆ JY5320_Signal_PFI_6

const int JY5320Import::JY5320_Signal_PFI_6 = 6

◆ JY5320_Signal_PFI_7

const int JY5320Import::JY5320_Signal_PFI_7 = 7

◆ JY5320_Signal_PFI_8

const int JY5320Import::JY5320_Signal_PFI_8 = 8

◆ JY5320_Signal_PFI_9

const int JY5320Import::JY5320_Signal_PFI_9 = 9

◆ JY5320_Signal_PXI_Trig_0

const int JY5320Import::JY5320_Signal_PXI_Trig_0 = 16

◆ JY5320_Signal_PXI_Trig_1

const int JY5320Import::JY5320_Signal_PXI_Trig_1 = 17

◆ JY5320_Signal_PXI_Trig_2

const int JY5320Import::JY5320_Signal_PXI_Trig_2 = 18

◆ JY5320_Signal_PXI_Trig_3

const int JY5320Import::JY5320_Signal_PXI_Trig_3 = 19

◆ JY5320_Signal_PXI_Trig_4

const int JY5320Import::JY5320_Signal_PXI_Trig_4 = 20

◆ JY5320_Signal_PXI_Trig_5

const int JY5320Import::JY5320_Signal_PXI_Trig_5 = 21

◆ JY5320_Signal_PXI_Trig_6

const int JY5320Import::JY5320_Signal_PXI_Trig_6 = 22

◆ JY5320_Signal_PXI_Trig_7

const int JY5320Import::JY5320_Signal_PXI_Trig_7 = 23

◆ JY5320_SLAVE

const int JY5320Import::JY5320_SLAVE = 0x3

◆ JY5320_StartTrigger

const int JY5320Import::JY5320_StartTrigger = 0x0

◆ JY5320_TriggerType_Analog

const int JY5320Import::JY5320_TriggerType_Analog = 0x2

◆ JY5320_TriggerType_Digital

const int JY5320Import::JY5320_TriggerType_Digital = 0x1

◆ JY5320_TriggerType_Immediately

const int JY5320Import::JY5320_TriggerType_Immediately = 0x0

◆ JY5320_TriggerType_Soft

const int JY5320Import::JY5320_TriggerType_Soft = 0x3

◆ Or

const int JY5320Import::Or = 0

◆ ReferenceOnboard_25M

const int JY5320Import::ReferenceOnboard_25M = 0x0

◆ ReferencePXIeCLK_100M

const int JY5320Import::ReferencePXIeCLK_100M = 0x1


5320 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOCOTask.h File Reference

  • File List
  • File Members
  • COO
  • 5320
Classes | Namespaces | Enumerations
JY5320CoreOOCOTask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JY5320CoreOOCommon.h"
#include "JY5320CoreOODevice.h"

Classes

class | JY5320CoreOO::JY5320CoreOOCOTask
class | JY5320CoreOO::CODigitalTrigger
CO Digital trigger . More...
class | JY5320CoreOO::COTrigger
Constructor to create an COTrigger task object. More...
class | JY5320CoreOO::COPulse
Pulse Parameter. More...
class | JY5320CoreOO::COExternalTimebase
class | JY5320CoreOO::COTimebase
class | JY5320CoreOO::COSignalExport
CO Signal Export Class. More...

Namespaces

namespace JY5320CoreOO

Enumerations

enum class | JY5320CoreOO::COIdleState { JY5320CoreOO::HighLevel = 0x1 , JY5320CoreOO::LowLevel = 0x0 }
Idle state when pulse output before start and after stop. More...
enum class | JY5320CoreOO::COMode { JY5320CoreOO::Single = 3 , JY5320CoreOO::Finite = 0 , JY5320CoreOO::ContinuousNoWrapping = 2 , JY5320CoreOO::ContinuousWrapping = 1 }
enum class | JY5320CoreOO::COTriggerType { JY5320CoreOO::Immediate = JY5320Import::JY5320_CIO_Immediately , JY5320CoreOO::Soft = JY5320Import::JY5320_CIO_Soft , JY5320CoreOO::Digital = JY5320Import::JY5320_CIO_Digital }
TriggerType Digital/Immediate/Soft. More...
enum class JY5320CoreOO::CODigitalTriggerSource {
JY5320CoreOO::PFI0 = JY5320Import::JY5320_DigitalTriggerSource_PFI_0 , JY5320CoreOO::PFI1 = JY5320Import::JY5320_DigitalTriggerSource_PFI_1 , JY5320CoreOO::PFI2 = JY5320Import::JY5320_DigitalTriggerSource_PFI_2 , JY5320CoreOO::PFI3 = JY5320Import::JY5320_DigitalTriggerSource_PFI_3 ,
JY5320CoreOO::PFI4 = JY5320Import::JY5320_DigitalTriggerSource_PFI_4 , JY5320CoreOO::PFI5 = JY5320Import::JY5320_DigitalTriggerSource_PFI_5 , JY5320CoreOO::PFI6 = JY5320Import::JY5320_DigitalTriggerSource_PFI_6 , JY5320CoreOO::PFI7 = JY5320Import::JY5320_DigitalTriggerSource_PFI_7 ,
JY5320CoreOO::PFI8 = JY5320Import::JY5320_DigitalTriggerSource_PFI_8 , JY5320CoreOO::PFI9 = JY5320Import::JY5320_DigitalTriggerSource_PFI_9 , JY5320CoreOO::PFI10 = JY5320Import::JY5320_DigitalTriggerSource_PFI_10 , JY5320CoreOO::PFI11 = JY5320Import::JY5320_DigitalTriggerSource_PFI_11 ,
JY5320CoreOO::PFI12 = JY5320Import::JY5320_DigitalTriggerSource_PFI_12 , JY5320CoreOO::PFI13 = JY5320Import::JY5320_DigitalTriggerSource_PFI_13 , JY5320CoreOO::PFI14 = JY5320Import::JY5320_DigitalTriggerSource_PFI_14 , JY5320CoreOO::PFI15 = JY5320Import::JY5320_DigitalTriggerSource_PFI_15 ,
JY5320CoreOO::PXI_Trig0 = JY5320Import::JY5320_DigitalTriggerSource_PXI_0 , JY5320CoreOO::PXI_Trig1 = JY5320Import::JY5320_DigitalTriggerSource_PXI_1 , JY5320CoreOO::PXI_Trig2 = JY5320Import::JY5320_DigitalTriggerSource_PXI_2 , JY5320CoreOO::PXI_Trig3 = JY5320Import::JY5320_DigitalTriggerSource_PXI_3 ,
JY5320CoreOO::PXI_Trig4 = JY5320Import::JY5320_DigitalTriggerSource_PXI_4 , JY5320CoreOO::PXI_Trig5 = JY5320Import::JY5320_DigitalTriggerSource_PXI_5 , JY5320CoreOO::PXI_Trig6 = JY5320Import::JY5320_DigitalTriggerSource_PXI_6 , JY5320CoreOO::PXI_Trig7 = JY5320Import::JY5320_DigitalTriggerSource_PXI_7 ,
JY5320CoreOO::AI_StartTrig = JY5320Import::JY5320_DigitalTriggerSource_Inter_AI_StartTrig , JY5320CoreOO::AI_ReferenceTrig = JY5320Import::JY5320_DigitalTriggerSource_Inter_AI_ReferenceTrig , JY5320CoreOO::CI_0_StartTrig = JY5320Import::JY5320_DigitalTriggerSource_Inter_CIO_0_StartTrig , JY5320CoreOO::CI_1_StartTrig = JY5320Import::JY5320_DigitalTriggerSource_Inter_CIO_1_StartTrig ,
JY5320CoreOO::CI_0_OutPut = JY5320Import::JY5320_DigitalTriggerSource_Inter_Counter_0_Output , JY5320CoreOO::CI_1_OutPut = JY5320Import::JY5320_DigitalTriggerSource_Inter_Counter_1_Output
}
CO Digital trigger source. More...
enum class | JY5320CoreOO::CODigitalTriggerEdge { JY5320CoreOO::Rising , JY5320CoreOO::Falling }
CO Digital Trigger Edge. More...
enum class | JY5320CoreOO::COPulseType { JY5320CoreOO::DutyCycleFrequency , JY5320CoreOO::HighLowTime , JY5320CoreOO::HighLowTick }
Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick. More...
enum class | JY5320CoreOO::COTimebaseSource { JY5320CoreOO::Internal100MHz = 0 , JY5320CoreOO::Internal5MHz = 1 , JY5320CoreOO::Internal100kHz = 2 , JY5320CoreOO::External = 3 }
Timebase source. More...
enum class | JY5320CoreOO::COSignalExportSource { JY5320CoreOO::StartTrig , JY5320CoreOO::Output }
SourceSignal. More...


5320 C++ Programming Manual: JY5320CoreOO::JY5320CoreOOCOTask Class Reference

  • JY5320CoreOOCOTask
Public Member Functions | Public Attributes | List of all members
JY5320CoreOO::JY5320CoreOOCOTask Class Reference

#include <JY5320CoreOOCOTask.h>

Public Member Functions

JY5320CoreOOCOTask (int slotNum, int channel)
Constructor.
JY5320CoreOOCOTask (std::string boardName, int channel)
Constructor.
void | WriteSinglePoint (COPulse &pulse)
Write a single pulse parameter to the register.
void | WriteData (COPulse *pulsesGroup[], int samplesToWrite, int timeout=10000)
Write pulse parameters to be output to the buffer.
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Start ()
Start CO task .
void | Stop ()
Stop COtask .
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.

Public Attributes

COMode Mode
CO output mode.
IOTerminal OutputTerminal
Pulse Output Terminal.
PauseTrigger * Pause
Pause Trigger Configuration.
COTimebase * TimeBase
CO's time base.
double | InitialDelay
Counter output initial delay in seconds.
COIdleState IdleState
Idle state when pulse output before start and after stop.
uint32_t | SamplesToUpdate
Finite frequency output.
JY5320CoreOOProperty< JY5320CoreOOCOTask, uint32_t, JY5320CoreOOPropertyType::READ_ONLY > | AvaliableLenInSamples
Number of points per channel that can be read in the buffer .
JY5320CoreOOProperty< JY5320CoreOOCOTask, uint64_t, JY5320CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
JY5320CoreOOProperty< JY5320CoreOOCOTask, uint32_t, JY5320CoreOOPropertyType::READ_ONLY > | TransferedPulses
The number of pulses transfered under the current configuration.
COTrigger * Trigger
CO trigger property configured by CO Trigger().
JY5320CoreOODevice * Device
Device.
COSignalExport * SignalExport
Export CO Signal Configuration.

Constructor & Destructor Documentation

◆ JY5320CoreOOCOTask() [1/2]

JY5320CoreOO::JY5320CoreOOCOTask::JY5320CoreOOCOTask | ( | int | slotNum,
 |  | int | channel )

Constructor.

Used to create an CO task by a slot number and Channel ID

Parameters
slotNum | Card slot number.
channel | Channel ID（5321/5323 support0-1,5322/5324 suppor0).

◆ JY5320CoreOOCOTask() [2/2]

JY5320CoreOO::JY5320CoreOOCOTask::JY5320CoreOOCOTask | ( | std::string | boardName,
 |  | int | channel )

Constructor.

Used to create an CO task by a slot number and Channel ID

Parameters
slotNum | Card slot number.
channel | Channel ID（5321/5323 support0-1,5322/5324 suppor0).

Member Function Documentation

◆ SendSoftwareTrigger()

void JY5320CoreOO::JY5320CoreOOCOTask::SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5320CoreOO::JY5320CoreOOCOTask::Start ( )

Start CO task .

◆ Stop()

void JY5320CoreOO::JY5320CoreOOCOTask::Stop ( )

Stop COtask .

◆ WaitUntilDone()

bool JY5320CoreOO::JY5320CoreOOCOTask::WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteData()

void JY5320CoreOO::JY5320CoreOOCOTask::WriteData | ( | COPulse * | pulsesGroup[],
 |  | int | samplesToWrite,
 |  | int | timeout = 10000 )

Write pulse parameters to be output to the buffer.

Valid when Mode is NOT COMode.Single. When Mode is COMode.Finite or COMode.ContinuousWrapping, this function can only be called once before starting the task.

Parameters
pulsesGroup | A group of pulse parameters
samplesToWrite | Number of samples to write. If Mode is COMode.ContinuousWrapping, you need to write at least 2 samples before starting the task
timeout | Timeout (ms). Wait until all data is written to buffer or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ WriteSinglePoint()

void JY5320CoreOO::JY5320CoreOOCOTask::WriteSinglePoint ( COPulse & pulse )

Write a single pulse parameter to the register.

Valid when Mode is COMode.Single. This function is also available after starting the task when the number of pulses being sent is infinite.

Parameters
pulse Pulse Parameter

Member Data Documentation

◆ AvaliableLenInSamples

JY5320CoreOOProperty<JY5320CoreOOCOTask, uint32_t, JY5320CoreOOPropertyType::READ_ONLY> JY5320CoreOO::JY5320CoreOOCOTask::AvaliableLenInSamples

Number of points per channel that can be read in the buffer .

◆ Device

JY5320CoreOODevice* JY5320CoreOO::JY5320CoreOOCOTask::Device

Device.

◆ IdleState

COIdleState JY5320CoreOO::JY5320CoreOOCOTask::IdleState

Idle state when pulse output before start and after stop.

◆ InitialDelay

double JY5320CoreOO::JY5320CoreOOCOTask::InitialDelay

Counter output initial delay in seconds.

There are five ticks of the timebase fixed delay in counter internal, so the total delay(s) = InitialDelay + (5 / timebase)

◆ Mode

COMode JY5320CoreOO::JY5320CoreOOCOTask::Mode

CO output mode.

◆ OutputTerminal

IOTerminal JY5320CoreOO::JY5320CoreOOCOTask::OutputTerminal

Pulse Output Terminal.

◆ Pause

PauseTrigger* JY5320CoreOO::JY5320CoreOOCOTask::Pause

Pause Trigger Configuration.

◆ SamplesToUpdate

uint32_t JY5320CoreOO::JY5320CoreOOCOTask::SamplesToUpdate

Finite frequency output.

◆ SignalExport

COSignalExport* JY5320CoreOO::JY5320CoreOOCOTask::SignalExport

Export CO Signal Configuration.

◆ TimeBase

COTimebase* JY5320CoreOO::JY5320CoreOOCOTask::TimeBase

CO's time base.

◆ TransferedPulses

JY5320CoreOOProperty<JY5320CoreOOCOTask, uint32_t, JY5320CoreOOPropertyType::READ_ONLY> JY5320CoreOO::JY5320CoreOOCOTask::TransferedPulses

The number of pulses transfered under the current configuration.

◆ TransferedSamples

JY5320CoreOOProperty<JY5320CoreOOCOTask, uint64_t, JY5320CoreOOPropertyType::READ_ONLY> JY5320CoreOO::JY5320CoreOOCOTask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT CIMode.Single.

◆ Trigger

COTrigger* JY5320CoreOO::JY5320CoreOOCOTask::Trigger

CO trigger property configured by CO Trigger().

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOCOTask.h


5320 C++ Programming Manual: JY5320CoreOO::CODigitalTrigger Class Reference

  • CODigitalTrigger
Public Attributes | List of all members
JY5320CoreOO::CODigitalTrigger Class Reference

CO Digital trigger . More...

#include <JY5320CoreOOCOTask.h>

Public Attributes

CODigitalTriggerSource Source
CO Digital Trigger source.
CODigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Detailed Description

CO Digital trigger .

Member Data Documentation

◆ Edge

CODigitalTriggerEdge JY5320CoreOO::CODigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

CODigitalTriggerSource JY5320CoreOO::CODigitalTrigger::Source

CO Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOCOTask.h


5320 C++ Programming Manual: JY5320CoreOO::COTrigger Class Reference

  • COTrigger
Public Attributes | List of all members
JY5320CoreOO::COTrigger Class Reference

Constructor to create an COTrigger task object. More...

#include <JY5320CoreOOCOTask.h>

Public Attributes

COTriggerType Type
CO trigger type.
CODigitalTrigger * Digital
CO Digital Trigger.

Detailed Description

Constructor to create an COTrigger task object.

Used to build CO Trigger

Member Data Documentation

◆ Digital

CODigitalTrigger* JY5320CoreOO::COTrigger::Digital

CO Digital Trigger.

Valid when Type is COTriggerType.Digital

◆ Type

COTriggerType JY5320CoreOO::COTrigger::Type

CO trigger type.

enum Immediate/Digital/Soft.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOCOTask.h


5320 C++ Programming Manual: JY5320CoreOO::COPulse Class Reference

  • COPulse
Public Member Functions | List of all members
JY5320CoreOO::COPulse Class Reference

Pulse Parameter. More...

#include <JY5320CoreOOCOTask.h>

Public Member Functions

COPulse (COPulseType type, double param1, double param2, int count)
Pulse Parameter.

Detailed Description

Pulse Parameter.

Constructor & Destructor Documentation

◆ COPulse()

JY5320CoreOO::COPulse::COPulse | ( | COPulseType | type,
 |  | double | param1,
 |  | double | param2,
 |  | int | count )

Pulse Parameter.

Parameters
type | The pulse type characteristics.
param1 | Parameter 1. Frequency (Hz) when constructed as COPulseType.DutyCycleFrequency; High duration in seconds when constructed as COPulseType.HighLowTime; High ticks of the clock when constructed as COPulseType.HighLowTick.
param2 | Parameter 1. Duty cycle (greater than 0 and less than 1) when constructed as COPulseType.DutyCycleFrequency; Low duration in seconds when constructed as COPulseType.HighLowTime; Low ticks of the clock when constructed as COPulseType.HighLowTick.
count | Number of pulses. When the value is -1 (indicating that the number of pulses is infinite), pulses will be continuously sent until requested to stop.
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOCOTask.h


5320 C++ Programming Manual: JY5320CoreOO::COExternalTimebase Class Reference

  • COExternalTimebase
Public Member Functions | Public Attributes | List of all members
JY5320CoreOO::COExternalTimebase Class Reference

#include <JY5320CoreOOCOTask.h>

Public Member Functions

COExternalTimebase ()

Public Attributes

InputTerminal Terminal
double Frequency

Constructor & Destructor Documentation

◆ COExternalTimebase()

JY5320CoreOO::COExternalTimebase::COExternalTimebase ( )
inline

Member Data Documentation

◆ Frequency

double JY5320CoreOO::COExternalTimebase::Frequency

外部时基的频率

Frequency of The External Timebase

◆ Terminal

InputTerminal JY5320CoreOO::COExternalTimebase::Terminal

外部时基的输入端口

External Timebase Input Terminal

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOCOTask.h


5320 C++ Programming Manual: JY5320CoreOO::COTimebase Class Reference

  • COTimebase
Public Attributes | List of all members
JY5320CoreOO::COTimebase Class Reference

#include <JY5320CoreOOCOTask.h>

Public Attributes

COTimebaseSource Source
COExternalTimebase * External
JY5320CoreOOProperty< COTimebase, double, JY5320CoreOOPropertyType::READ_ONLY > ActualFreq

Member Data Documentation

◆ ActualFreq

JY5320CoreOOProperty<COTimebase, double, JY5320CoreOOPropertyType::READ_ONLY> JY5320CoreOO::COTimebase::ActualFreq

◆ External

COExternalTimebase* JY5320CoreOO::COTimebase::External

外部时基配置。当 COTimebase.Source 为 COTimebaseSource.External时有效。

External Timebase Configuration. Valid when COTimebase.Source is COTimebaseSource.External.

◆ Source

COTimebaseSource JY5320CoreOO::COTimebase::Source

时基源。默认值为 COTimebaseSource.Internal100MHz。

Timebase Source. The default value is COTimebaseSource.Internal100MHz.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOCOTask.h


5320 C++ Programming Manual: JY5320CoreOO::COSignalExport Class Reference

  • COSignalExport
Public Member Functions | List of all members
JY5320CoreOO::COSignalExport Class Reference

CO Signal Export Class. More...

#include <JY5320CoreOOCOTask.h>

Public Member Functions

void | Add (COSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (COSignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

CO Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY5320CoreOO::COSignalExport::Add | ( | COSignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | CI Signal Source
destination | Export Desination

◆ Add() [2/2]

void JY5320CoreOO::COSignalExport::Add | ( | COSignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | CI Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JY5320CoreOO::COSignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5320CoreOO::COSignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOCOTask.h


5320 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOODevice.h File Reference

  • File List
  • File Members
  • COO
  • 5320
Classes | Namespaces | Enumerations
JY5320CoreOODevice.h File Reference
#include <iostream>
#include <list>
#include <vector>
#include "JY5320CoreOOCommon.h"

Classes

class | JY5320CoreOO::JY5320CoreOODevice
class | JY5320CoreOO::ExternalReferenceClock
External Reference Clcok Terminal. More...
class | JY5320CoreOO::JY5320CoreOOReferenceClock

Namespaces

namespace JY5320CoreOO

Enumerations

enum class | JY5320CoreOO::ExternalReferenceClockTerminal { JY5320CoreOO::PXIe_Clk100 = 0x1 }
enum class JY5320CoreOO::CounterInterface {
JY5320CoreOO::Source , JY5320CoreOO::Gate , JY5320CoreOO::Aux , JY5320CoreOO::SampleClock ,
JY5320CoreOO::Out
}
enum class | JY5320CoreOO::ReferenceClockSource { JY5320CoreOO::Internal = 0x0 , JY5320CoreOO::External = 0x1 }


5320 C++ Programming Manual: JY5320CoreOO::JY5320CoreOODevice Class Reference

  • JY5320CoreOODevice
Static Public Member Functions | Public Attributes | List of all members
JY5320CoreOO::JY5320CoreOODevice Class Reference

#include <JY5320CoreOODevice.h>

Static Public Member Functions

static JY5320CoreOODevice * | GetInstance (int cardNum)
The operation instance is obtained according to the board number to ensure that there is only one registered instance for each board.
static JY5320CoreOODevice * | GetInstance (std::string aliasName)
The operation instance is obtained according to aliasName to ensure that there is only one registration instance for each board.
static unsigned | GetDefautTerminal (CounterInterface counterInterface, unsigned channelID)

Public Attributes

const double | BoardClockRate = 100000000
Board Clock Rate.
int | SubCardADCType
Sub Card ADC Type.
int | SubCardADCChannelNum
Sub Card Channel Number.
uint32_t | AIBufferSize = 0x100000 * 240
AI Buffer Size.
const bool | IsAISync = true
const bool | IsAOSync = true
IsAOSync.
const int | LineCountPerPort = 2
DIOLineCountPerPort.
JY5320CoreOOProperty< JY5320CoreOODevice, int, JY5320CoreOOPropertyType::READ_ONLY > | DiffChannelCount
JY5320CoreOOProperty< JY5320CoreOODevice, int, JY5320CoreOOPropertyType::READ_ONLY > | DIOPortCount
JY5320CoreOOProperty< JY5320CoreOODevice, double, JY5320CoreOOPropertyType::READ_ONLY > | MaxSampleRateSingleChannel
JY5320CoreOOProperty< JY5320CoreOODevice, std::string, JY5320CoreOOPropertyType::READ_ONLY > | SerialNumber
JY5320CoreOOProperty< JY5320CoreOODevice, int, JY5320CoreOOPropertyType::READ_ONLY > | DeviceID
JY5320CoreOOProperty< JY5320CoreOODevice, void *, JY5320CoreOOPropertyType::READ_ONLY > | Handle
JY5320CoreOOReferenceClock * ReferenceClock
Reference Clock Configuration.

Member Function Documentation

◆ GetDefautTerminal()

static unsigned JY5320CoreOO::JY5320CoreOODevice::GetDefautTerminal | ( | CounterInterface | counterInterface,
 |  | unsigned | channelID )
 static

◆ GetInstance() [1/2]

static JY5320CoreOODevice * JY5320CoreOO::JY5320CoreOODevice::GetInstance ( int cardNum )
static

The operation instance is obtained according to the board number to ensure that there is only one registered instance for each board.

Parameters
cardNum
Returns

◆ GetInstance() [2/2]

static JY5320CoreOODevice * JY5320CoreOO::JY5320CoreOODevice::GetInstance ( std::string aliasName )
static

The operation instance is obtained according to aliasName to ensure that there is only one registration instance for each board.

Parameters
aliasName
Returns

Member Data Documentation

◆ AIBufferSize

uint32_t JY5320CoreOO::JY5320CoreOODevice::AIBufferSize = 0x100000 * 240

AI Buffer Size.

◆ BoardClockRate

const double JY5320CoreOO::JY5320CoreOODevice::BoardClockRate = 100000000

Board Clock Rate.

◆ DeviceID

JY5320CoreOOProperty<JY5320CoreOODevice, int, JY5320CoreOOPropertyType::READ_ONLY> JY5320CoreOO::JY5320CoreOODevice::DeviceID

◆ DiffChannelCount

JY5320CoreOOProperty<JY5320CoreOODevice, int, JY5320CoreOOPropertyType::READ_ONLY> JY5320CoreOO::JY5320CoreOODevice::DiffChannelCount

◆ DIOPortCount

JY5320CoreOOProperty<JY5320CoreOODevice, int, JY5320CoreOOPropertyType::READ_ONLY> JY5320CoreOO::JY5320CoreOODevice::DIOPortCount

◆ Handle

JY5320CoreOOProperty<JY5320CoreOODevice, void*, JY5320CoreOOPropertyType::READ_ONLY> JY5320CoreOO::JY5320CoreOODevice::Handle

◆ IsAISync

const bool JY5320CoreOO::JY5320CoreOODevice::IsAISync = true

◆ IsAOSync

const bool JY5320CoreOO::JY5320CoreOODevice::IsAOSync = true

IsAOSync.

◆ LineCountPerPort

const int JY5320CoreOO::JY5320CoreOODevice::LineCountPerPort = 2

DIOLineCountPerPort.

◆ MaxSampleRateSingleChannel

JY5320CoreOOProperty<JY5320CoreOODevice, double, JY5320CoreOOPropertyType::READ_ONLY> JY5320CoreOO::JY5320CoreOODevice::MaxSampleRateSingleChannel

◆ ReferenceClock

JY5320CoreOOReferenceClock* JY5320CoreOO::JY5320CoreOODevice::ReferenceClock

Reference Clock Configuration.

◆ SerialNumber

JY5320CoreOOProperty<JY5320CoreOODevice, std::string, JY5320CoreOOPropertyType::READ_ONLY> JY5320CoreOO::JY5320CoreOODevice::SerialNumber

◆ SubCardADCChannelNum

int JY5320CoreOO::JY5320CoreOODevice::SubCardADCChannelNum

Sub Card Channel Number.

◆ SubCardADCType

int JY5320CoreOO::JY5320CoreOODevice::SubCardADCType

Sub Card ADC Type.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOODevice.h


5320 C++ Programming Manual: JY5320CoreOO::ExternalReferenceClock Class Reference

  • ExternalReferenceClock
Public Attributes | List of all members
JY5320CoreOO::ExternalReferenceClock Class Reference

External Reference Clcok Terminal. More...

#include <JY5320CoreOODevice.h>

Public Attributes

ExternalReferenceClockTerminal Terminal

Detailed Description

External Reference Clcok Terminal.

Member Data Documentation

◆ Terminal

ExternalReferenceClockTerminal JY5320CoreOO::ExternalReferenceClock::Terminal
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOODevice.h


5320 C++ Programming Manual: JY5320CoreOO::JY5320CoreOOReferenceClock Class Reference

  • JY5320CoreOOReferenceClock
Public Member Functions | Public Attributes | List of all members
JY5320CoreOO::JY5320CoreOOReferenceClock Class Reference

#include <JY5320CoreOODevice.h>

Public Member Functions

void Commit ()
Commit configuration.

Public Attributes

ReferenceClockSource Source
ExternalReferenceClock * External
External Reference Clock Source.

Member Function Documentation

◆ Commit()

void JY5320CoreOO::JY5320CoreOOReferenceClock::Commit ( )

Commit configuration.

Available only when the device is idle. WARNING: Incorrect parameters will cause the PLL to be unable to lock the reference clock and cannot be recovered until shutdown and restart.

Member Data Documentation

◆ External

ExternalReferenceClock* JY5320CoreOO::JY5320CoreOOReferenceClock::External

External Reference Clock Source.

Required when ReferenceClock.Source is ReferenceClockSource.External

◆ Source

ReferenceClockSource JY5320CoreOO::JY5320CoreOOReferenceClock::Source
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOODevice.h


5320 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOODITask.h File Reference

  • File List
  • File Members
  • COO
  • 5320
Classes | Namespaces | Enumerations
JY5320CoreOODITask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JY5320CoreOOCommon.h"
#include "JY5320CoreOODevice.h"

Classes

class | JY5320CoreOO::JY5320CoreOODITask
class | JY5320CoreOO::DIChannel
DI Channel parameter class . More...

Namespaces

namespace JY5320CoreOO

Enumerations

enum class JY5320CoreOO::DISampleClockSource { JY5320CoreOO::Internal , JY5320CoreOO::External }
DI Sample Clock Source. More...


5320 C++ Programming Manual: JY5320CoreOO::JY5320CoreOODITask Class Reference

  • JY5320CoreOODITask
Public Member Functions | Public Attributes | List of all members
JY5320CoreOO::JY5320CoreOODITask Class Reference

#include <JY5320CoreOODITask.h>

Public Member Functions

JY5320CoreOODITask (int slotNum)
JY5320CoreOODITask (std::string boardName)
void | AddChannel (int portNum)
Add one channel.
void | AddChannel (std::vector< int > portsNum)
Add a group of channel.
void | RemoveChannel (int portNum)
Delete the specified port number .If it is -1, delete all ports.
void | Start ()
Start DI task .
void | Stop ()
Stop DI task .
void | ReadSinglePoint (std::vector< bool > &readValues, int port)
Read one sample for specified channel in register.

Public Attributes

std::list< DIChannel * > Channels
List of DI channels.
JY5320CoreOODevice * Device
Device.

Constructor & Destructor Documentation

◆ JY5320CoreOODITask() [1/2]

JY5320CoreOO::JY5320CoreOODITask::JY5320CoreOODITask ( int slotNum )

◆ JY5320CoreOODITask() [2/2]

JY5320CoreOO::JY5320CoreOODITask::JY5320CoreOODITask ( std::string boardName )

Member Function Documentation

◆ AddChannel() [1/2]

void JY5320CoreOO::JY5320CoreOODITask::AddChannel ( int portNum )

Add one channel.

Parameters
portNum port number to be added.

◆ AddChannel() [2/2]

void JY5320CoreOO::JY5320CoreOODITask::AddChannel ( std::vector< int > portsNum )

Add a group of channel.

Parameters
portsNum an array of port numbers of added ports.

◆ ReadSinglePoint()

void JY5320CoreOO::JY5320CoreOODITask::ReadSinglePoint | ( | std::vector< bool > & | readValues,
 |  | int | port )

Read one sample for specified channel in register.

. Available when Mode is DIMode.Single when the portID is -1, read all enabled ports values /summary>

Parameters
readValues | values read,. Buffer size >= 8
port | Specified port numbers.

◆ RemoveChannel()

void JY5320CoreOO::JY5320CoreOODITask::RemoveChannel ( int portNum )

Delete the specified port number .If it is -1, delete all ports.

Parameters
portNum port number to be delete.

◆ Start()

void JY5320CoreOO::JY5320CoreOODITask::Start ( )

Start DI task .

◆ Stop()

void JY5320CoreOO::JY5320CoreOODITask::Stop ( )

Stop DI task .

Member Data Documentation

◆ Channels

std::list<DIChannel*> JY5320CoreOO::JY5320CoreOODITask::Channels

List of DI channels.

(JY5321,JY5323 support 8 ports)(JY5322,JY5324 support 4 ports)

◆ Device

JY5320CoreOODevice* JY5320CoreOO::JY5320CoreOODITask::Device

Device.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOODITask.h


5320 C++ Programming Manual: JY5320CoreOO::DIChannel Class Reference

  • DIChannel
Public Attributes | List of all members
JY5320CoreOO::DIChannel Class Reference

DI Channel parameter class . More...

#include <JY5320CoreOODITask.h>

Public Attributes

int PortNum
port number.

Detailed Description

DI Channel parameter class .

Member Data Documentation

◆ PortNum

int JY5320CoreOO::DIChannel::PortNum

port number.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOODITask.h


5320 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOODOTask.h File Reference

  • File List
  • File Members
  • COO
  • 5320
Classes | Namespaces
JY5320CoreOODOTask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JY5320CoreOOCommon.h"
#include "JY5320CoreOODevice.h"

Classes

class | JY5320CoreOO::JY5320CoreOODOTask
class | JY5320CoreOO::DOChannel
DO Channel parameter class . More...

Namespaces

namespace JY5320CoreOO


5320 C++ Programming Manual: JY5320CoreOO::JY5320CoreOODOTask Class Reference

  • JY5320CoreOODOTask
Public Member Functions | Public Attributes | List of all members
JY5320CoreOO::JY5320CoreOODOTask Class Reference

#include <JY5320CoreOODOTask.h>

Public Member Functions

JY5320CoreOODOTask (int slotNum)
JY5320CoreOODOTask (std::string boardName)
~JY5320CoreOODOTask ()
void | AddChannel (int portNum)
Add one channel.
void | AddChannel (std::vector< int > portsNum)
Add a group of channel.
void | RemoveChannel (int portNum)
Delete the specified port number .If it is -1, delete all ports.
void | Start ()
Start DO task .
void | Stop ()
Stop DO task .
void | WriteSinglePoint (std::vector< bool > &writeValues, int port)
Write one sample to the specified port in register.Available when Mode is DOMode.Single when the portID is -1, write all enabled ports values,the writeValues Length must equal to 2(In function JY5320_DO_AddLines defined), and the values store in the add order of ports, in one port, the order is form line 0 to line 1.
void | WriteSinglePoint (std::vector< bool > &writeValues)
Write one sample for all ports in register .

Public Attributes

std::list< DOChannel * > Channels
List of DO channels.
JY5320CoreOODevice * Device
Device.

Constructor & Destructor Documentation

◆ JY5320CoreOODOTask() [1/2]

JY5320CoreOO::JY5320CoreOODOTask::JY5320CoreOODOTask ( int slotNum )

◆ JY5320CoreOODOTask() [2/2]

JY5320CoreOO::JY5320CoreOODOTask::JY5320CoreOODOTask ( std::string boardName )

◆ ~JY5320CoreOODOTask()

JY5320CoreOO::JY5320CoreOODOTask::~JY5320CoreOODOTask ( )

Member Function Documentation

◆ AddChannel() [1/2]

void JY5320CoreOO::JY5320CoreOODOTask::AddChannel ( int portNum )

Add one channel.

Parameters
portNum port number to be added.

◆ AddChannel() [2/2]

void JY5320CoreOO::JY5320CoreOODOTask::AddChannel ( std::vector< int > portsNum )

Add a group of channel.

Parameters
portsNum an array of port numbers of added ports.

◆ RemoveChannel()

void JY5320CoreOO::JY5320CoreOODOTask::RemoveChannel ( int portNum )

Delete the specified port number .If it is -1, delete all ports.

Parameters
portNum port number to be delete.

◆ Start()

void JY5320CoreOO::JY5320CoreOODOTask::Start ( )

Start DO task .

◆ Stop()

void JY5320CoreOO::JY5320CoreOODOTask::Stop ( )

Stop DO task .

◆ WriteSinglePoint() [1/2]

void JY5320CoreOO::JY5320CoreOODOTask::WriteSinglePoint ( std::vector< bool > & writeValues )

Write one sample for all ports in register .

Available when Mode is DIMode.Single

Parameters
readValues Values read. Buffer size = number of ports * 2.

◆ WriteSinglePoint() [2/2]

void JY5320CoreOO::JY5320CoreOODOTask::WriteSinglePoint | ( | std::vector< bool > & | writeValues,
 |  | int | port )

Write one sample to the specified port in register.Available when Mode is DOMode.Single when the portID is -1, write all enabled ports values,the writeValues Length must equal to 2(In function JY5320_DO_AddLines defined), and the values store in the add order of ports, in one port, the order is form line 0 to line 1.

Parameters
writeValues | values write,. Buffer size = 2
port | Specified port numbers.

Member Data Documentation

◆ Channels

std::list<DOChannel*> JY5320CoreOO::JY5320CoreOODOTask::Channels

List of DO channels.

(JY5321,JY5323 support 8 ports)(JY5322,JY5324 support 4 ports)

◆ Device

JY5320CoreOODevice* JY5320CoreOO::JY5320CoreOODOTask::Device

Device.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOODOTask.h


5320 C++ Programming Manual: JY5320CoreOO::DOChannel Class Reference

  • DOChannel
Public Attributes | List of all members
JY5320CoreOO::DOChannel Class Reference

DO Channel parameter class . More...

#include <JY5320CoreOODOTask.h>

Public Attributes

int PortNum
port number.

Detailed Description

DO Channel parameter class .

Member Data Documentation

◆ PortNum

int JY5320CoreOO::DOChannel::PortNum

port number.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOODOTask.h


5320 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOLog.h File Reference

  • File List
  • File Members
  • COO
  • 5320
Classes | Namespaces | Enumerations
JY5320CoreOOLog.h File Reference
#include <queue>
#include <thread>
#include "JY5320CoreOOCommon.h"

Classes

class JY5320CoreOO::JY5320CoreOOLog

Namespaces

namespace JY5320CoreOO

Enumerations

enum class JY5320CoreOO::JY5320CoreOOLogLevel {
JY5320CoreOO::DEBUG_LOG_LEVEL , JY5320CoreOO::INFO_LOG_LEVEL , JY5320CoreOO::WARN_LOG_LEVEL , JY5320CoreOO::ERROR_LOG_LEVEL ,
JY5320CoreOO::FATAL_LOG_LEVEL
}


5320 C++ Programming Manual: JY5320CoreOO::JY5320CoreOOLog Class Reference

  • JY5320CoreOOLog
Static Public Member Functions | Static Public Attributes | List of all members
JY5320CoreOO::JY5320CoreOOLog Class Reference

#include <JY5320CoreOOLog.h>

Static Public Member Functions

static void | Print (const char *format,...)
static void | Print (JY5320CoreOOLogLevel logLevel, const char *format,...)
static void | Flush ()

Static Public Attributes

static JY5320CoreOOLogLevel | LogLevel
static JY5320CoreOOProperty< JY5320CoreOOLog, bool, JY5320CoreOOPropertyType::READ_WRITE > | EnableLog

Member Function Documentation

◆ Flush()

static void JY5320CoreOO::JY5320CoreOOLog::Flush ( )
static

◆ Print() [1/2]

static void JY5320CoreOO::JY5320CoreOOLog::Print | ( | const char * | format,
 |  |  | ... )
 static

◆ Print() [2/2]

static void JY5320CoreOO::JY5320CoreOOLog::Print | ( | JY5320CoreOOLogLevel | logLevel,
 |  | const char * | format,
 |  |  | ... )
 static

Member Data Documentation

◆ EnableLog

JY5320CoreOOProperty<JY5320CoreOOLog, bool, JY5320CoreOOPropertyType::READ_WRITE> JY5320CoreOO::JY5320CoreOOLog::EnableLog
static

◆ LogLevel

JY5320CoreOOLogLevel JY5320CoreOO::JY5320CoreOOLog::LogLevel
static
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOLog.h


5320 C++ Programming Manual: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
▼N JY5320CoreOO |
C AIAdvanced |
C AIAnalogEdgeComparator |
C AIAnalogHysteresisComparator |
C AIAnalogTrigger |
C AIAnalogWindowComparator |
C AIChannel |
C AIDigitalTrigger |
C AIDSMode |
C AIExternalSampleClock |
C AIMultiChannelAnalogTrigger |
C AIRecord |
C AISampleClock |
C AISignalExport |
C AISync | Configure sync signal
C AITrigger |
C CIDigitalTrigger | CI Digital trigger
C CIExternalSampleClock | CI Implicit Sample Clock class
C CIExternalTimebase |
C CIImplicitSampleClock | CI Implicit Sample Clock class
C CIInternalSampleClock | CI Internal Sample Clock Configuration Class
C CISampleClock | CI Sample Clock class
C CISignalExport | CI Signal Export Class
C CITimebase | Timebase configuration class
C CITrigger | Constructor to create an CITrigger task object
C CODigitalTrigger | CO Digital trigger
C COExternalTimebase |
C COPulse | Pulse Parameter
C COSignalExport | CO Signal Export Class
C COTimebase |
C COTrigger | Constructor to create an COTrigger task object
C DIChannel | DI Channel parameter class
C DOChannel | DO Channel parameter class
C EdgeCounting | Configure CI EdgeCounting
C EdgeCountingOutEvent | Edge counting output event configuration class
C ExternalReferenceClock | External Reference Clcok Terminal
C FrequencyMeas | Configure CI Measure
C JY5320CoreOOAITask | AiTask类
C JY5320CoreOOCITask |
C JY5320CoreOOCOTask |
C JY5320CoreOODevice |
C JY5320CoreOODITask |
C JY5320CoreOODOTask |
C JY5320CoreOOLog |
C JY5320CoreOOProperty | 属性模板类
C JY5320CoreOOReferenceClock |
C JYDriverException |
C PauseTrigger | Pause trigger configuration class
C PeriodMeas | Configure CI Measure
C PulseMeas | Configure CI Measure
C QuadEncoder | Configure CI Measure
C SemiPeriodMeas |
C TwoEdgeSeparation | Configure CI Measure
C TwoPulseEncoder | Configure CI Measure
C JY5320CoreOOAIMode | AIMode


5320 C++ Programming Manual: Member List

  • AIAdvanced
JY5320CoreOO::AIAdvanced Member List

This is the complete list of members for JY5320CoreOO::AIAdvanced, including all inherited members.

DSMode JY5320CoreOO::AIAdvanced


5320 C++ Programming Manual: Member List

  • AIAnalogEdgeComparator
JY5320CoreOO::AIAnalogEdgeComparator Member List

This is the complete list of members for JY5320CoreOO::AIAnalogEdgeComparator, including all inherited members.

Slope | JY5320CoreOO::AIAnalogEdgeComparator
Threshold | JY5320CoreOO::AIAnalogEdgeComparator


5320 C++ Programming Manual: Member List

  • AIAnalogHysteresisComparator
JY5320CoreOO::AIAnalogHysteresisComparator Member List

This is the complete list of members for JY5320CoreOO::AIAnalogHysteresisComparator, including all inherited members.

HighThreshold | JY5320CoreOO::AIAnalogHysteresisComparator
LowThreshold | JY5320CoreOO::AIAnalogHysteresisComparator
Slope | JY5320CoreOO::AIAnalogHysteresisComparator


5320 C++ Programming Manual: Member List

  • AIAnalogTrigger
JY5320CoreOO::AIAnalogTrigger Member List

This is the complete list of members for JY5320CoreOO::AIAnalogTrigger, including all inherited members.

AIAnalogTrigger() | JY5320CoreOO::AIAnalogTrigger
AIAnalogTrigger(AIAnalogTriggerSource src, AIAnalogTriggerComparator comparator) | JY5320CoreOO::AIAnalogTrigger
Comparator | JY5320CoreOO::AIAnalogTrigger
Edge | JY5320CoreOO::AIAnalogTrigger
Hysteresis | JY5320CoreOO::AIAnalogTrigger
Source | JY5320CoreOO::AIAnalogTrigger
Window | JY5320CoreOO::AIAnalogTrigger
~AIAnalogTrigger() | JY5320CoreOO::AIAnalogTrigger


5320 C++ Programming Manual: Member List

  • AIAnalogWindowComparator
JY5320CoreOO::AIAnalogWindowComparator Member List

This is the complete list of members for JY5320CoreOO::AIAnalogWindowComparator, including all inherited members.

Condition | JY5320CoreOO::AIAnalogWindowComparator
HighThreshold | JY5320CoreOO::AIAnalogWindowComparator
LowThreshold | JY5320CoreOO::AIAnalogWindowComparator


5320 C++ Programming Manual: Member List

  • AIChannel
JY5320CoreOO::AIChannel Member List

This is the complete list of members for JY5320CoreOO::AIChannel, including all inherited members.

AIChannel(int channelId, double rangeLow, double rangeHigh, AIBandWidth bandWidth) | JY5320CoreOO::AIChannel | inline
BandWidth | JY5320CoreOO::AIChannel |
ChannelID | JY5320CoreOO::AIChannel |
RangeHigh | JY5320CoreOO::AIChannel |
RangeLow | JY5320CoreOO::AIChannel |


5320 C++ Programming Manual: Member List

  • AIDSMode
JY5320CoreOO::AIDSMode Member List

This is the complete list of members for JY5320CoreOO::AIDSMode, including all inherited members.

Enable JY5320CoreOO::AIDSMode


5320 C++ Programming Manual: Member List

  • AIDigitalTrigger
JY5320CoreOO::AIDigitalTrigger Member List

This is the complete list of members for JY5320CoreOO::AIDigitalTrigger, including all inherited members.

Edge | JY5320CoreOO::AIDigitalTrigger
Source | JY5320CoreOO::AIDigitalTrigger


5320 C++ Programming Manual: Member List

  • AIExternalSampleClock
JY5320CoreOO::AIExternalSampleClock Member List

This is the complete list of members for JY5320CoreOO::AIExternalSampleClock, including all inherited members.

ExpectedRate | JY5320CoreOO::AIExternalSampleClock
Terminal | JY5320CoreOO::AIExternalSampleClock


5320 C++ Programming Manual: Member List

  • AIMultiChannelAnalogTrigger
JY5320CoreOO::AIMultiChannelAnalogTrigger Member List

This is the complete list of members for JY5320CoreOO::AIMultiChannelAnalogTrigger, including all inherited members.

Analog | JY5320CoreOO::AIMultiChannelAnalogTrigger
Logic | JY5320CoreOO::AIMultiChannelAnalogTrigger


5320 C++ Programming Manual: Member List

  • AIRecord
JY5320CoreOO::AIRecord Member List

This is the complete list of members for JY5320CoreOO::AIRecord, including all inherited members.

File_Format | JY5320CoreOO::AIRecord
FilePath | JY5320CoreOO::AIRecord
Length | JY5320CoreOO::AIRecord
Mode | JY5320CoreOO::AIRecord


5320 C++ Programming Manual: Member List

  • AISampleClock
JY5320CoreOO::AISampleClock Member List

This is the complete list of members for JY5320CoreOO::AISampleClock, including all inherited members.

External | JY5320CoreOO::AISampleClock
Source | JY5320CoreOO::AISampleClock


5320 C++ Programming Manual: Member List

  • AISignalExport
JY5320CoreOO::AISignalExport Member List

This is the complete list of members for JY5320CoreOO::AISignalExport, including all inherited members.

Add(AISignalExportSource source, SignalExportDestination destination) | JY5320CoreOO::AISignalExport
Add(AISignalExportSource source, std::list< SignalExportDestination > destinations) | JY5320CoreOO::AISignalExport
Clear(SignalExportDestination destination) | JY5320CoreOO::AISignalExport
ClearAll() | JY5320CoreOO::AISignalExport


5320 C++ Programming Manual: Member List

  • AISync
JY5320CoreOO::AISync Member List

This is the complete list of members for JY5320CoreOO::AISync, including all inherited members.

PulseRouting | JY5320CoreOO::AISync
Topology | JY5320CoreOO::AISync
TriggerRouting | JY5320CoreOO::AISync


5320 C++ Programming Manual: Member List

  • AITrigger
JY5320CoreOO::AITrigger Member List

This is the complete list of members for JY5320CoreOO::AITrigger, including all inherited members.

Analog | JY5320CoreOO::AITrigger
Digital | JY5320CoreOO::AITrigger
Mode | JY5320CoreOO::AITrigger
MultiChannel | JY5320CoreOO::AITrigger
PreTriggerSamples | JY5320CoreOO::AITrigger
ReTriggerCount | JY5320CoreOO::AITrigger
Type | JY5320CoreOO::AITrigger


5320 C++ Programming Manual: Member List

  • CIDigitalTrigger
JY5320CoreOO::CIDigitalTrigger Member List

This is the complete list of members for JY5320CoreOO::CIDigitalTrigger, including all inherited members.

Edge | JY5320CoreOO::CIDigitalTrigger
Source | JY5320CoreOO::CIDigitalTrigger


5320 C++ Programming Manual: Member List

  • CIExternalSampleClock
JY5320CoreOO::CIExternalSampleClock Member List

This is the complete list of members for JY5320CoreOO::CIExternalSampleClock, including all inherited members.

ExpectedRate | JY5320CoreOO::CIExternalSampleClock
IgnoreFirstSampleClock | JY5320CoreOO::CIExternalSampleClock
Terminal | JY5320CoreOO::CIExternalSampleClock


5320 C++ Programming Manual: Member List

  • CIExternalTimebase
JY5320CoreOO::CIExternalTimebase Member List

This is the complete list of members for JY5320CoreOO::CIExternalTimebase, including all inherited members.

Frequency | JY5320CoreOO::CIExternalTimebase
Terminal | JY5320CoreOO::CIExternalTimebase


5320 C++ Programming Manual: Member List

  • CIImplicitSampleClock
JY5320CoreOO::CIImplicitSampleClock Member List

This is the complete list of members for JY5320CoreOO::CIImplicitSampleClock, including all inherited members.

ExpectedRate JY5320CoreOO::CIImplicitSampleClock


5320 C++ Programming Manual: Member List

  • CIInternalSampleClock
JY5320CoreOO::CIInternalSampleClock Member List

This is the complete list of members for JY5320CoreOO::CIInternalSampleClock, including all inherited members.

CIInternalSampleClock() | JY5320CoreOO::CIInternalSampleClock
IgnoreFirstSampleClock | JY5320CoreOO::CIInternalSampleClock
Rate | JY5320CoreOO::CIInternalSampleClock


5320 C++ Programming Manual: Member List

  • CISampleClock
JY5320CoreOO::CISampleClock Member List

This is the complete list of members for JY5320CoreOO::CISampleClock, including all inherited members.

External | JY5320CoreOO::CISampleClock
Implicit | JY5320CoreOO::CISampleClock
Internal | JY5320CoreOO::CISampleClock
Source | JY5320CoreOO::CISampleClock


5320 C++ Programming Manual: Member List

  • CISignalExport
JY5320CoreOO::CISignalExport Member List

This is the complete list of members for JY5320CoreOO::CISignalExport, including all inherited members.

Add(CISignalExportSource source, SignalExportDestination destination) | JY5320CoreOO::CISignalExport
Add(CISignalExportSource source, std::list< SignalExportDestination > destinations) | JY5320CoreOO::CISignalExport
Clear(SignalExportDestination destination) | JY5320CoreOO::CISignalExport
ClearAll() | JY5320CoreOO::CISignalExport


5320 C++ Programming Manual: Member List

  • CITimebase
JY5320CoreOO::CITimebase Member List

This is the complete list of members for JY5320CoreOO::CITimebase, including all inherited members.

ActualFreq | JY5320CoreOO::CITimebase
CITimebase() | JY5320CoreOO::CITimebase
External | JY5320CoreOO::CITimebase
Source | JY5320CoreOO::CITimebase
~CITimebase() | JY5320CoreOO::CITimebase


5320 C++ Programming Manual: Member List

  • CITrigger
JY5320CoreOO::CITrigger Member List

This is the complete list of members for JY5320CoreOO::CITrigger, including all inherited members.

Digital | JY5320CoreOO::CITrigger
Type | JY5320CoreOO::CITrigger


5320 C++ Programming Manual: Member List

  • CODigitalTrigger
JY5320CoreOO::CODigitalTrigger Member List

This is the complete list of members for JY5320CoreOO::CODigitalTrigger, including all inherited members.

Edge | JY5320CoreOO::CODigitalTrigger
Source | JY5320CoreOO::CODigitalTrigger


5320 C++ Programming Manual: Member List

  • COExternalTimebase
JY5320CoreOO::COExternalTimebase Member List

This is the complete list of members for JY5320CoreOO::COExternalTimebase, including all inherited members.

COExternalTimebase() | JY5320CoreOO::COExternalTimebase | inline
Frequency | JY5320CoreOO::COExternalTimebase |
Terminal | JY5320CoreOO::COExternalTimebase |


5320 C++ Programming Manual: Member List

  • COPulse
JY5320CoreOO::COPulse Member List

This is the complete list of members for JY5320CoreOO::COPulse, including all inherited members.

COPulse(COPulseType type, double param1, double param2, int count) JY5320CoreOO::COPulse


5320 C++ Programming Manual: Member List

  • COSignalExport
JY5320CoreOO::COSignalExport Member List

This is the complete list of members for JY5320CoreOO::COSignalExport, including all inherited members.

Add(COSignalExportSource source, SignalExportDestination destination) | JY5320CoreOO::COSignalExport
Add(COSignalExportSource source, std::list< SignalExportDestination > destinations) | JY5320CoreOO::COSignalExport
Clear(SignalExportDestination destination) | JY5320CoreOO::COSignalExport
ClearAll() | JY5320CoreOO::COSignalExport


5320 C++ Programming Manual: Member List

  • COTimebase
JY5320CoreOO::COTimebase Member List

This is the complete list of members for JY5320CoreOO::COTimebase, including all inherited members.

ActualFreq | JY5320CoreOO::COTimebase
External | JY5320CoreOO::COTimebase
Source | JY5320CoreOO::COTimebase


5320 C++ Programming Manual: Member List

  • COTrigger
JY5320CoreOO::COTrigger Member List

This is the complete list of members for JY5320CoreOO::COTrigger, including all inherited members.

Digital | JY5320CoreOO::COTrigger
Type | JY5320CoreOO::COTrigger


5320 C++ Programming Manual: Member List

  • DIChannel
JY5320CoreOO::DIChannel Member List

This is the complete list of members for JY5320CoreOO::DIChannel, including all inherited members.

PortNum JY5320CoreOO::DIChannel


5320 C++ Programming Manual: Member List

  • DOChannel
JY5320CoreOO::DOChannel Member List

This is the complete list of members for JY5320CoreOO::DOChannel, including all inherited members.

PortNum JY5320CoreOO::DOChannel


5320 C++ Programming Manual: Member List

  • EdgeCounting
JY5320CoreOO::EdgeCounting Member List

This is the complete list of members for JY5320CoreOO::EdgeCounting, including all inherited members.

ActiveEdge | JY5320CoreOO::EdgeCounting
Direction | JY5320CoreOO::EdgeCounting
DirTerminal | JY5320CoreOO::EdgeCounting
InitialCount | JY5320CoreOO::EdgeCounting
Input_Terminal | JY5320CoreOO::EdgeCounting
OutEvent | JY5320CoreOO::EdgeCounting
Pause | JY5320CoreOO::EdgeCounting


5320 C++ Programming Manual: Member List

  • EdgeCountingOutEvent
JY5320CoreOO::EdgeCountingOutEvent Member List

This is the complete list of members for JY5320CoreOO::EdgeCountingOutEvent, including all inherited members.

IdleState | JY5320CoreOO::EdgeCountingOutEvent
Terminal | JY5320CoreOO::EdgeCountingOutEvent
Threshold | JY5320CoreOO::EdgeCountingOutEvent


5320 C++ Programming Manual: Member List

  • ExternalReferenceClock
JY5320CoreOO::ExternalReferenceClock Member List

This is the complete list of members for JY5320CoreOO::ExternalReferenceClock, including all inherited members.

Terminal JY5320CoreOO::ExternalReferenceClock


5320 C++ Programming Manual: Member List

  • FrequencyMeas
JY5320CoreOO::FrequencyMeas Member List

This is the complete list of members for JY5320CoreOO::FrequencyMeas, including all inherited members.

Input_Terminal | JY5320CoreOO::FrequencyMeas
Timebase | JY5320CoreOO::FrequencyMeas


5320 C++ Programming Manual: Member List

  • JY5320CoreOOAITask
JY5320CoreOO::JY5320CoreOOAITask Member List

This is the complete list of members for JY5320CoreOO::JY5320CoreOOAITask, including all inherited members.

AddChannel(int chnId, AIBandWidth bandWidth, double rangeLow=-10, double rangeHigh=10) | JY5320CoreOO::JY5320CoreOOAITask
AddChannel(int chnId, double rangeLow=-10, double rangeHigh=10) | JY5320CoreOO::JY5320CoreOOAITask
AddChannel(std::vector< int > chnsId, AIBandWidth bandWidth, double rangeLow=-10, double rangeHigh=10) | JY5320CoreOO::JY5320CoreOOAITask
AddChannel(std::vector< int > chnsId, double rangeLow=-10, double rangeHigh=10) | JY5320CoreOO::JY5320CoreOOAITask
AddChannel(std::vector< int > chnsId, std::vector< double > rangeLow, std::vector< double > rangeHigh, std::vector< AIBandWidth > bandWidth) | JY5320CoreOO::JY5320CoreOOAITask
AddChannel(std::vector< int > chnsId, std::vector< double > rangeLow, std::vector< double > rangeHigh) | JY5320CoreOO::JY5320CoreOOAITask
Advanced | JY5320CoreOO::JY5320CoreOOAITask
AvailableSamples | JY5320CoreOO::JY5320CoreOOAITask
BufLenInSamples | JY5320CoreOO::JY5320CoreOOAITask
Channels | JY5320CoreOO::JY5320CoreOOAITask
Device | JY5320CoreOO::JY5320CoreOOAITask
DisableDigitalTriggerDelay | JY5320CoreOO::JY5320CoreOOAITask
GetRecordPreviewData(double *buf, int samplesPerChannel, int timeout=1000) | JY5320CoreOO::JY5320CoreOOAITask
GetRecordPreviewData(std::vector< double > &buf, int samplesPerChannel, int timeout=1000) | JY5320CoreOO::JY5320CoreOOAITask
GetRecordStatus(double *recordedLength, bool *recordDone) | JY5320CoreOO::JY5320CoreOOAITask
GetRecordStatus(double &recordedLength, bool &recordDone) | JY5320CoreOO::JY5320CoreOOAITask
JY5320CoreOOAITask(int slotNum) | JY5320CoreOO::JY5320CoreOOAITask
JY5320CoreOOAITask(std::string boardName) | JY5320CoreOO::JY5320CoreOOAITask
Mode | JY5320CoreOO::JY5320CoreOOAITask
ReadData(double *pBuf, int samplesPerChannel, int timeout=-1) | JY5320CoreOO::JY5320CoreOOAITask
ReadData(std::vector< double > &pBuf, int samplesPerChannel, int timeout=-1) | JY5320CoreOO::JY5320CoreOOAITask
ReadRawData(short *pBuf, int samplesPerChannel, int timeout=-1) | JY5320CoreOO::JY5320CoreOOAITask
ReadRawData(std::vector< short > &pBuf, int samplesPerChannel, int timeout=-1) | JY5320CoreOO::JY5320CoreOOAITask
ReadSinglePoint(double &readValue, int channel) | JY5320CoreOO::JY5320CoreOOAITask
ReadSinglePoint(std::vector< double > &readValues) | JY5320CoreOO::JY5320CoreOOAITask
Record | JY5320CoreOO::JY5320CoreOOAITask
RemoveChannel(int chnId) | JY5320CoreOO::JY5320CoreOOAITask
SampleClock | JY5320CoreOO::JY5320CoreOOAITask
SampleRate | JY5320CoreOO::JY5320CoreOOAITask
SamplesToAcquire | JY5320CoreOO::JY5320CoreOOAITask
SendSoftwareTrigger() | JY5320CoreOO::JY5320CoreOOAITask
SignalExport | JY5320CoreOO::JY5320CoreOOAITask
Start() | JY5320CoreOO::JY5320CoreOOAITask
Stop() | JY5320CoreOO::JY5320CoreOOAITask
Sync | JY5320CoreOO::JY5320CoreOOAITask
TransferedSamples | JY5320CoreOO::JY5320CoreOOAITask
Trigger | JY5320CoreOO::JY5320CoreOOAITask
~JY5320CoreOOAITask() | JY5320CoreOO::JY5320CoreOOAITask


5320 C++ Programming Manual: Member List

  • JY5320CoreOOCITask
JY5320CoreOO::JY5320CoreOOCITask Member List

This is the complete list of members for JY5320CoreOO::JY5320CoreOOCITask, including all inherited members.

AvailableSamples | JY5320CoreOO::JY5320CoreOOCITask
Device | JY5320CoreOO::JY5320CoreOOCITask
EdgeCounting | JY5320CoreOO::JY5320CoreOOCITask
FrequencyMeas | JY5320CoreOO::JY5320CoreOOCITask
JY5320CoreOOCITask(int slotNum, int channel) | JY5320CoreOO::JY5320CoreOOCITask
JY5320CoreOOCITask(std::string boardName, int channel) | JY5320CoreOO::JY5320CoreOOCITask
Mode | JY5320CoreOO::JY5320CoreOOCITask
PeriodMeas | JY5320CoreOO::JY5320CoreOOCITask
PulseMeas | JY5320CoreOO::JY5320CoreOOCITask
QuadEncoder | JY5320CoreOO::JY5320CoreOOCITask
ReadData(uint32_t *pBufCount, int samplesToAcquire, int timeout=10000) | JY5320CoreOO::JY5320CoreOOCITask
ReadData(std::vector< uint32_t > &pBufCount, int samplesToAcquire, int timeout=10000) | JY5320CoreOO::JY5320CoreOOCITask
ReadData(double *pBufMeasurement, int samplesToAcquire, int timeout=10000) | JY5320CoreOO::JY5320CoreOOCITask
ReadData(std::vector< double > &pBufMeasurement, int samplesToAcquire, int timeout=10000) | JY5320CoreOO::JY5320CoreOOCITask
ReadData(double *pBufMeasurement1, double *pBufMeasurement2, int samplesToAcquire, int timeout=10000) | JY5320CoreOO::JY5320CoreOOCITask
ReadData(std::vector< double > &pBufMeasurement1, std::vector< double > &pBufMeasurement2, int samplesToAcquire, int timeout=10000) | JY5320CoreOO::JY5320CoreOOCITask
ReadSinglePoint(uint32_t &count) | JY5320CoreOO::JY5320CoreOOCITask
ReadSinglePoint(double &measurement, int timeout=10000) | JY5320CoreOO::JY5320CoreOOCITask
ReadSinglePoint(double &measurement1, double &measurement2, int timeout=10000) | JY5320CoreOO::JY5320CoreOOCITask
SampleClock | JY5320CoreOO::JY5320CoreOOCITask
SamplesToAcquire | JY5320CoreOO::JY5320CoreOOCITask
SemiPeriodMeas | JY5320CoreOO::JY5320CoreOOCITask
SendSoftwareTrigger() | JY5320CoreOO::JY5320CoreOOCITask
SignalExport | JY5320CoreOO::JY5320CoreOOCITask
Start() | JY5320CoreOO::JY5320CoreOOCITask
Stop() | JY5320CoreOO::JY5320CoreOOCITask
TransferedSamples | JY5320CoreOO::JY5320CoreOOCITask
Trigger | JY5320CoreOO::JY5320CoreOOCITask
TwoEdgeSeparation | JY5320CoreOO::JY5320CoreOOCITask
TwoPulseEncoder | JY5320CoreOO::JY5320CoreOOCITask
Type | JY5320CoreOO::JY5320CoreOOCITask
~JY5320CoreOOCITask() | JY5320CoreOO::JY5320CoreOOCITask


5320 C++ Programming Manual: Member List

  • JY5320CoreOOCOTask
JY5320CoreOO::JY5320CoreOOCOTask Member List

This is the complete list of members for JY5320CoreOO::JY5320CoreOOCOTask, including all inherited members.

AvaliableLenInSamples | JY5320CoreOO::JY5320CoreOOCOTask
Device | JY5320CoreOO::JY5320CoreOOCOTask
IdleState | JY5320CoreOO::JY5320CoreOOCOTask
InitialDelay | JY5320CoreOO::JY5320CoreOOCOTask
JY5320CoreOOCOTask(int slotNum, int channel) | JY5320CoreOO::JY5320CoreOOCOTask
JY5320CoreOOCOTask(std::string boardName, int channel) | JY5320CoreOO::JY5320CoreOOCOTask
Mode | JY5320CoreOO::JY5320CoreOOCOTask
OutputTerminal | JY5320CoreOO::JY5320CoreOOCOTask
Pause | JY5320CoreOO::JY5320CoreOOCOTask
SamplesToUpdate | JY5320CoreOO::JY5320CoreOOCOTask
SendSoftwareTrigger() | JY5320CoreOO::JY5320CoreOOCOTask
SignalExport | JY5320CoreOO::JY5320CoreOOCOTask
Start() | JY5320CoreOO::JY5320CoreOOCOTask
Stop() | JY5320CoreOO::JY5320CoreOOCOTask
TimeBase | JY5320CoreOO::JY5320CoreOOCOTask
TransferedPulses | JY5320CoreOO::JY5320CoreOOCOTask
TransferedSamples | JY5320CoreOO::JY5320CoreOOCOTask
Trigger | JY5320CoreOO::JY5320CoreOOCOTask
WaitUntilDone(int timeout=-1) | JY5320CoreOO::JY5320CoreOOCOTask
WriteData(COPulse *pulsesGroup[], int samplesToWrite, int timeout=10000) | JY5320CoreOO::JY5320CoreOOCOTask
WriteSinglePoint(COPulse &pulse) | JY5320CoreOO::JY5320CoreOOCOTask


5320 C++ Programming Manual: Member List

  • JY5320CoreOODITask
JY5320CoreOO::JY5320CoreOODITask Member List

This is the complete list of members for JY5320CoreOO::JY5320CoreOODITask, including all inherited members.

AddChannel(int portNum) | JY5320CoreOO::JY5320CoreOODITask
AddChannel(std::vector< int > portsNum) | JY5320CoreOO::JY5320CoreOODITask
Channels | JY5320CoreOO::JY5320CoreOODITask
Device | JY5320CoreOO::JY5320CoreOODITask
JY5320CoreOODITask(int slotNum) | JY5320CoreOO::JY5320CoreOODITask
JY5320CoreOODITask(std::string boardName) | JY5320CoreOO::JY5320CoreOODITask
ReadSinglePoint(std::vector< bool > &readValues, int port) | JY5320CoreOO::JY5320CoreOODITask
RemoveChannel(int portNum) | JY5320CoreOO::JY5320CoreOODITask
Start() | JY5320CoreOO::JY5320CoreOODITask
Stop() | JY5320CoreOO::JY5320CoreOODITask


5320 C++ Programming Manual: Member List

  • JY5320CoreOODOTask
JY5320CoreOO::JY5320CoreOODOTask Member List

This is the complete list of members for JY5320CoreOO::JY5320CoreOODOTask, including all inherited members.

AddChannel(int portNum) | JY5320CoreOO::JY5320CoreOODOTask
AddChannel(std::vector< int > portsNum) | JY5320CoreOO::JY5320CoreOODOTask
Channels | JY5320CoreOO::JY5320CoreOODOTask
Device | JY5320CoreOO::JY5320CoreOODOTask
JY5320CoreOODOTask(int slotNum) | JY5320CoreOO::JY5320CoreOODOTask
JY5320CoreOODOTask(std::string boardName) | JY5320CoreOO::JY5320CoreOODOTask
RemoveChannel(int portNum) | JY5320CoreOO::JY5320CoreOODOTask
Start() | JY5320CoreOO::JY5320CoreOODOTask
Stop() | JY5320CoreOO::JY5320CoreOODOTask
WriteSinglePoint(std::vector< bool > &writeValues, int port) | JY5320CoreOO::JY5320CoreOODOTask
WriteSinglePoint(std::vector< bool > &writeValues) | JY5320CoreOO::JY5320CoreOODOTask
~JY5320CoreOODOTask() | JY5320CoreOO::JY5320CoreOODOTask


5320 C++ Programming Manual: Member List

  • JY5320CoreOODevice
JY5320CoreOO::JY5320CoreOODevice Member List

This is the complete list of members for JY5320CoreOO::JY5320CoreOODevice, including all inherited members.

AIBufferSize | JY5320CoreOO::JY5320CoreOODevice |
BoardClockRate | JY5320CoreOO::JY5320CoreOODevice |
DeviceID | JY5320CoreOO::JY5320CoreOODevice |
DiffChannelCount | JY5320CoreOO::JY5320CoreOODevice |
DIOPortCount | JY5320CoreOO::JY5320CoreOODevice |
GetDefautTerminal(CounterInterface counterInterface, unsigned channelID) | JY5320CoreOO::JY5320CoreOODevice | static
GetInstance(int cardNum) | JY5320CoreOO::JY5320CoreOODevice | static
GetInstance(std::string aliasName) | JY5320CoreOO::JY5320CoreOODevice | static
Handle | JY5320CoreOO::JY5320CoreOODevice |
IsAISync | JY5320CoreOO::JY5320CoreOODevice |
IsAOSync | JY5320CoreOO::JY5320CoreOODevice |
LineCountPerPort | JY5320CoreOO::JY5320CoreOODevice |
MaxSampleRateSingleChannel | JY5320CoreOO::JY5320CoreOODevice |
ReferenceClock | JY5320CoreOO::JY5320CoreOODevice |
SerialNumber | JY5320CoreOO::JY5320CoreOODevice |
SubCardADCChannelNum | JY5320CoreOO::JY5320CoreOODevice |
SubCardADCType | JY5320CoreOO::JY5320CoreOODevice |


5320 C++ Programming Manual: Member List

  • JY5320CoreOOLog
JY5320CoreOO::JY5320CoreOOLog Member List

This is the complete list of members for JY5320CoreOO::JY5320CoreOOLog, including all inherited members.

EnableLog | JY5320CoreOO::JY5320CoreOOLog | static
Flush() | JY5320CoreOO::JY5320CoreOOLog | static
LogLevel | JY5320CoreOO::JY5320CoreOOLog | static
Print(const char *format,...) | JY5320CoreOO::JY5320CoreOOLog | static
Print(JY5320CoreOOLogLevel logLevel, const char *format,...) | JY5320CoreOO::JY5320CoreOOLog | static


5320 C++ Programming Manual: Member List

  • JY5320CoreOOProperty
JY5320CoreOO::JY5320CoreOOProperty< ContainerClass, ValueType, propertyType > Member List

This is the complete list of members for JY5320CoreOO::JY5320CoreOOProperty< ContainerClass, ValueType, propertyType >, including all inherited members.

JY5320CoreOOProperty() | JY5320CoreOO::JY5320CoreOOProperty< ContainerClass, ValueType, propertyType >
JY5320CoreOOProperty(ContainerClass *cObject, ValueType(ContainerClass::*pGet)(), void(ContainerClass::*pSet)(ValueType value)) | JY5320CoreOO::JY5320CoreOOProperty< ContainerClass, ValueType, propertyType >
JY5320CoreOOProperty(ValueType(*pGet)(), void(*pSet)(ValueType value)) | JY5320CoreOO::JY5320CoreOOProperty< ContainerClass, ValueType, propertyType >
operator ValueType() | JY5320CoreOO::JY5320CoreOOProperty< ContainerClass, ValueType, propertyType >
operator=(const ValueType &value) | JY5320CoreOO::JY5320CoreOOProperty< ContainerClass, ValueType, propertyType >


5320 C++ Programming Manual: Member List

  • JY5320CoreOOReferenceClock
JY5320CoreOO::JY5320CoreOOReferenceClock Member List

This is the complete list of members for JY5320CoreOO::JY5320CoreOOReferenceClock, including all inherited members.

Commit() | JY5320CoreOO::JY5320CoreOOReferenceClock
External | JY5320CoreOO::JY5320CoreOOReferenceClock
Source | JY5320CoreOO::JY5320CoreOOReferenceClock


5320 C++ Programming Manual: Member List

  • JYDriverException
JY5320CoreOO::JYDriverException Member List

This is the complete list of members for JY5320CoreOO::JYDriverException, including all inherited members.

errorCode | JY5320CoreOO::JYDriverException
exceptionMessage | JY5320CoreOO::JYDriverException
FollowingException | JY5320CoreOO::JYDriverException
JYDriverException(JYDriverExceptionPublic exceptionCode, std::string msg="") | JY5320CoreOO::JYDriverException
JYDriverException(int, std::string msg) | JY5320CoreOO::JYDriverException


5320 C++ Programming Manual: Member List

  • PauseTrigger
JY5320CoreOO::PauseTrigger Member List

This is the complete list of members for JY5320CoreOO::PauseTrigger, including all inherited members.

ActivePolarity | JY5320CoreOO::PauseTrigger
Terminal | JY5320CoreOO::PauseTrigger


5320 C++ Programming Manual: Member List

  • PeriodMeas
JY5320CoreOO::PeriodMeas Member List

This is the complete list of members for JY5320CoreOO::PeriodMeas, including all inherited members.

Input_Terminal | JY5320CoreOO::PeriodMeas
StartingEdge | JY5320CoreOO::PeriodMeas
Timebase | JY5320CoreOO::PeriodMeas


5320 C++ Programming Manual: Member List

  • PulseMeas
JY5320CoreOO::PulseMeas Member List

This is the complete list of members for JY5320CoreOO::PulseMeas, including all inherited members.

Input_Terminal | JY5320CoreOO::PulseMeas
StartingEdge | JY5320CoreOO::PulseMeas
Timebase | JY5320CoreOO::PulseMeas


5320 C++ Programming Manual: Member List

  • QuadEncoder
JY5320CoreOO::QuadEncoder Member List

This is the complete list of members for JY5320CoreOO::QuadEncoder, including all inherited members.

AInputTerminal | JY5320CoreOO::QuadEncoder
BInputTerminal | JY5320CoreOO::QuadEncoder
EncodingType | JY5320CoreOO::QuadEncoder
InitialCount | JY5320CoreOO::QuadEncoder
ZInputTerminal | JY5320CoreOO::QuadEncoder
ZReloadEnabled | JY5320CoreOO::QuadEncoder


5320 C++ Programming Manual: Member List

  • SemiPeriodMeas
JY5320CoreOO::SemiPeriodMeas Member List

This is the complete list of members for JY5320CoreOO::SemiPeriodMeas, including all inherited members.

Inputterminal | JY5320CoreOO::SemiPeriodMeas
StartingEdge | JY5320CoreOO::SemiPeriodMeas
Timebase | JY5320CoreOO::SemiPeriodMeas


5320 C++ Programming Manual: Member List

  • TwoEdgeSeparation
JY5320CoreOO::TwoEdgeSeparation Member List

This is the complete list of members for JY5320CoreOO::TwoEdgeSeparation, including all inherited members.

EdgeSeparationMode | JY5320CoreOO::TwoEdgeSeparation
FirstInputTerminal | JY5320CoreOO::TwoEdgeSeparation
SecondInputTerminal | JY5320CoreOO::TwoEdgeSeparation
Timebase | JY5320CoreOO::TwoEdgeSeparation


5320 C++ Programming Manual: Member List

  • TwoPulseEncoder
JY5320CoreOO::TwoPulseEncoder Member List

This is the complete list of members for JY5320CoreOO::TwoPulseEncoder, including all inherited members.

AInputTerminal | JY5320CoreOO::TwoPulseEncoder
BInputTerminal | JY5320CoreOO::TwoPulseEncoder
InitialCount | JY5320CoreOO::TwoPulseEncoder


5320 C++ Programming Manual: JY5320CoreOOAIMode Class Reference

JY5320CoreOOAIMode Class Reference

AIMode. More...

#include <JY5320CoreOOAITask.h>

Detailed Description

AIMode.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5320/JY5320CoreOOAITask.h


5320 C++ Programming Manual: Class Index

Class Index
A | C | D | E | F | J | P | Q | S | T
A
AIAdvanced (JY5320CoreOO)
AIAnalogEdgeComparator (JY5320CoreOO)
AIAnalogHysteresisComparator (JY5320CoreOO)
AIAnalogTrigger (JY5320CoreOO)
AIAnalogWindowComparator (JY5320CoreOO)
AIChannel (JY5320CoreOO)
AIDigitalTrigger (JY5320CoreOO)
AIDSMode (JY5320CoreOO)
AIExternalSampleClock (JY5320CoreOO)
AIMultiChannelAnalogTrigger (JY5320CoreOO)
AIRecord (JY5320CoreOO)
AISampleClock (JY5320CoreOO)
AISignalExport (JY5320CoreOO)
AISync (JY5320CoreOO)
AITrigger (JY5320CoreOO)
C
CIDigitalTrigger (JY5320CoreOO)
CIExternalSampleClock (JY5320CoreOO)
CIExternalTimebase (JY5320CoreOO)
CIImplicitSampleClock (JY5320CoreOO)
CIInternalSampleClock (JY5320CoreOO)
CISampleClock (JY5320CoreOO)
CISignalExport (JY5320CoreOO)
CITimebase (JY5320CoreOO)
CITrigger (JY5320CoreOO)
CODigitalTrigger (JY5320CoreOO)
COExternalTimebase (JY5320CoreOO)
COPulse (JY5320CoreOO)
COSignalExport (JY5320CoreOO)
COTimebase (JY5320CoreOO)
COTrigger (JY5320CoreOO)
D
DIChannel (JY5320CoreOO)
DOChannel (JY5320CoreOO)
E
EdgeCounting (JY5320CoreOO)
EdgeCountingOutEvent (JY5320CoreOO)
ExternalReferenceClock (JY5320CoreOO)
F
FrequencyMeas (JY5320CoreOO)
J
JY5320CoreOOAIMode
JY5320CoreOOAITask (JY5320CoreOO)
JY5320CoreOOCITask (JY5320CoreOO)
JY5320CoreOOCOTask (JY5320CoreOO)
JY5320CoreOODevice (JY5320CoreOO)
JY5320CoreOODITask (JY5320CoreOO)
JY5320CoreOODOTask (JY5320CoreOO)
JY5320CoreOOLog (JY5320CoreOO)
JY5320CoreOOProperty (JY5320CoreOO)
JY5320CoreOOReferenceClock (JY5320CoreOO)
JYDriverException (JY5320CoreOO)
P
PauseTrigger (JY5320CoreOO)
PeriodMeas (JY5320CoreOO)
PulseMeas (JY5320CoreOO)
Q
QuadEncoder (JY5320CoreOO)
S
SemiPeriodMeas (JY5320CoreOO)
T
TwoEdgeSeparation (JY5320CoreOO)
TwoPulseEncoder (JY5320CoreOO)


5320 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO Directory Reference

  • File List
  • File Members
  • COO
COO Directory Reference

Directories

5320


5320 C++ Programming Manual: File List

  • File List
  • File Members
File List
Here is a list of all files with brief descriptions:
[detail level 123]
▼ COO
▼ 5320
JY5320CoreOOAITask.h
JY5320CoreOOCITask.h
JY5320CoreOOCommon.h
JY5320CoreOOCOTask.h
JY5320CoreOODevice.h
JY5320CoreOODITask.h
JY5320CoreOODOTask.h
JY5320CoreOOLog.h


5320 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- a -

  • ActiveEdge : JY5320CoreOO::EdgeCounting
  • ActivePolarity : JY5320CoreOO::PauseTrigger
  • ActualFreq : JY5320CoreOO::CITimebase, JY5320CoreOO::COTimebase
  • Add() : JY5320CoreOO::AISignalExport, JY5320CoreOO::CISignalExport, JY5320CoreOO::COSignalExport
  • AddChannel() : JY5320CoreOO::JY5320CoreOOAITask, JY5320CoreOO::JY5320CoreOODITask, JY5320CoreOO::JY5320CoreOODOTask
  • Advanced : JY5320CoreOO::JY5320CoreOOAITask
  • AIAnalogTrigger() : JY5320CoreOO::AIAnalogTrigger
  • AIBufferSize : JY5320CoreOO::JY5320CoreOODevice
  • AIChannel() : JY5320CoreOO::AIChannel
  • AInputTerminal : JY5320CoreOO::QuadEncoder, JY5320CoreOO::TwoPulseEncoder
  • Analog : JY5320CoreOO::AIMultiChannelAnalogTrigger, JY5320CoreOO::AITrigger
  • AvailableSamples : JY5320CoreOO::JY5320CoreOOAITask, JY5320CoreOO::JY5320CoreOOCITask
  • AvaliableLenInSamples : JY5320CoreOO::JY5320CoreOOCOTask


5320 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- b -

  • BandWidth : JY5320CoreOO::AIChannel
  • BInputTerminal : JY5320CoreOO::QuadEncoder, JY5320CoreOO::TwoPulseEncoder
  • BoardClockRate : JY5320CoreOO::JY5320CoreOODevice
  • BufLenInSamples : JY5320CoreOO::JY5320CoreOOAITask


5320 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- c -

  • ChannelID : JY5320CoreOO::AIChannel
  • Channels : JY5320CoreOO::JY5320CoreOOAITask, JY5320CoreOO::JY5320CoreOODITask, JY5320CoreOO::JY5320CoreOODOTask
  • CIInternalSampleClock() : JY5320CoreOO::CIInternalSampleClock
  • CITimebase() : JY5320CoreOO::CITimebase
  • Clear() : JY5320CoreOO::AISignalExport, JY5320CoreOO::CISignalExport, JY5320CoreOO::COSignalExport
  • ClearAll() : JY5320CoreOO::AISignalExport, JY5320CoreOO::CISignalExport, JY5320CoreOO::COSignalExport
  • COExternalTimebase() : JY5320CoreOO::COExternalTimebase
  • Commit() : JY5320CoreOO::JY5320CoreOOReferenceClock
  • Comparator : JY5320CoreOO::AIAnalogTrigger
  • Condition : JY5320CoreOO::AIAnalogWindowComparator
  • COPulse() : JY5320CoreOO::COPulse


5320 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- d -

  • Device : JY5320CoreOO::JY5320CoreOOAITask, JY5320CoreOO::JY5320CoreOOCITask, JY5320CoreOO::JY5320CoreOOCOTask, JY5320CoreOO::JY5320CoreOODITask, JY5320CoreOO::JY5320CoreOODOTask
  • DeviceID : JY5320CoreOO::JY5320CoreOODevice
  • DiffChannelCount : JY5320CoreOO::JY5320CoreOODevice
  • Digital : JY5320CoreOO::AITrigger, JY5320CoreOO::CITrigger, JY5320CoreOO::COTrigger
  • DIOPortCount : JY5320CoreOO::JY5320CoreOODevice
  • Direction : JY5320CoreOO::EdgeCounting
  • DirTerminal : JY5320CoreOO::EdgeCounting
  • DisableDigitalTriggerDelay : JY5320CoreOO::JY5320CoreOOAITask
  • DSMode : JY5320CoreOO::AIAdvanced


5320 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- e -

  • Edge : JY5320CoreOO::AIAnalogTrigger, JY5320CoreOO::AIDigitalTrigger, JY5320CoreOO::CIDigitalTrigger, JY5320CoreOO::CODigitalTrigger
  • EdgeCounting : JY5320CoreOO::JY5320CoreOOCITask
  • EdgeSeparationMode : JY5320CoreOO::TwoEdgeSeparation
  • Enable : JY5320CoreOO::AIDSMode
  • EnableLog : JY5320CoreOO::JY5320CoreOOLog
  • EncodingType : JY5320CoreOO::QuadEncoder
  • errorCode : JY5320CoreOO::JYDriverException
  • exceptionMessage : JY5320CoreOO::JYDriverException
  • ExpectedRate : JY5320CoreOO::AIExternalSampleClock, JY5320CoreOO::CIExternalSampleClock, JY5320CoreOO::CIImplicitSampleClock
  • External : JY5320CoreOO::AISampleClock, JY5320CoreOO::CISampleClock, JY5320CoreOO::CITimebase, JY5320CoreOO::COTimebase, JY5320CoreOO::JY5320CoreOOReferenceClock


5320 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- f -

  • File_Format : JY5320CoreOO::AIRecord
  • FilePath : JY5320CoreOO::AIRecord
  • FirstInputTerminal : JY5320CoreOO::TwoEdgeSeparation
  • Flush() : JY5320CoreOO::JY5320CoreOOLog
  • FollowingException : JY5320CoreOO::JYDriverException
  • Frequency : JY5320CoreOO::CIExternalTimebase, JY5320CoreOO::COExternalTimebase
  • FrequencyMeas : JY5320CoreOO::JY5320CoreOOCITask


5320 C++ Programming Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • c
  • f
  • g
  • j
  • o
  • p
  • r
  • s
  • w
  • ~
Here is a list of all functions with links to the classes they belong to:

- a -

  • Add() : JY5320CoreOO::AISignalExport, JY5320CoreOO::CISignalExport, JY5320CoreOO::COSignalExport
  • AddChannel() : JY5320CoreOO::JY5320CoreOOAITask, JY5320CoreOO::JY5320CoreOODITask, JY5320CoreOO::JY5320CoreOODOTask
  • AIAnalogTrigger() : JY5320CoreOO::AIAnalogTrigger
  • AIChannel() : JY5320CoreOO::AIChannel

- c -

  • CIInternalSampleClock() : JY5320CoreOO::CIInternalSampleClock
  • CITimebase() : JY5320CoreOO::CITimebase
  • Clear() : JY5320CoreOO::AISignalExport, JY5320CoreOO::CISignalExport, JY5320CoreOO::COSignalExport
  • ClearAll() : JY5320CoreOO::AISignalExport, JY5320CoreOO::CISignalExport, JY5320CoreOO::COSignalExport
  • COExternalTimebase() : JY5320CoreOO::COExternalTimebase
  • Commit() : JY5320CoreOO::JY5320CoreOOReferenceClock
  • COPulse() : JY5320CoreOO::COPulse

- f -

  • Flush() : JY5320CoreOO::JY5320CoreOOLog

- g -

  • GetDefautTerminal() : JY5320CoreOO::JY5320CoreOODevice
  • GetInstance() : JY5320CoreOO::JY5320CoreOODevice
  • GetRecordPreviewData() : JY5320CoreOO::JY5320CoreOOAITask
  • GetRecordStatus() : JY5320CoreOO::JY5320CoreOOAITask

- j -

  • JY5320CoreOOAITask() : JY5320CoreOO::JY5320CoreOOAITask
  • JY5320CoreOOCITask() : JY5320CoreOO::JY5320CoreOOCITask
  • JY5320CoreOOCOTask() : JY5320CoreOO::JY5320CoreOOCOTask
  • JY5320CoreOODITask() : JY5320CoreOO::JY5320CoreOODITask
  • JY5320CoreOODOTask() : JY5320CoreOO::JY5320CoreOODOTask
  • JY5320CoreOOProperty() : JY5320CoreOO::JY5320CoreOOProperty< ContainerClass, ValueType, propertyType >
  • JYDriverException() : JY5320CoreOO::JYDriverException

- o -

  • operator ValueType() : JY5320CoreOO::JY5320CoreOOProperty< ContainerClass, ValueType, propertyType >
  • operator=() : JY5320CoreOO::JY5320CoreOOProperty< ContainerClass, ValueType, propertyType >

- p -

  • Print() : JY5320CoreOO::JY5320CoreOOLog

- r -

  • ReadData() : JY5320CoreOO::JY5320CoreOOAITask, JY5320CoreOO::JY5320CoreOOCITask
  • ReadRawData() : JY5320CoreOO::JY5320CoreOOAITask
  • ReadSinglePoint() : JY5320CoreOO::JY5320CoreOOAITask, JY5320CoreOO::JY5320CoreOOCITask, JY5320CoreOO::JY5320CoreOODITask
  • RemoveChannel() : JY5320CoreOO::JY5320CoreOOAITask, JY5320CoreOO::JY5320CoreOODITask, JY5320CoreOO::JY5320CoreOODOTask

- s -

  • SendSoftwareTrigger() : JY5320CoreOO::JY5320CoreOOAITask, JY5320CoreOO::JY5320CoreOOCITask, JY5320CoreOO::JY5320CoreOOCOTask
  • Start() : JY5320CoreOO::JY5320CoreOOAITask, JY5320CoreOO::JY5320CoreOOCITask, JY5320CoreOO::JY5320CoreOOCOTask, JY5320CoreOO::JY5320CoreOODITask, JY5320CoreOO::JY5320CoreOODOTask
  • Stop() : JY5320CoreOO::JY5320CoreOOAITask, JY5320CoreOO::JY5320CoreOOCITask, JY5320CoreOO::JY5320CoreOOCOTask, JY5320CoreOO::JY5320CoreOODITask, JY5320CoreOO::JY5320CoreOODOTask

- w -

  • WaitUntilDone() : JY5320CoreOO::JY5320CoreOOCOTask
  • WriteData() : JY5320CoreOO::JY5320CoreOOCOTask
  • WriteSinglePoint() : JY5320CoreOO::JY5320CoreOOCOTask, JY5320CoreOO::JY5320CoreOODOTask

- ~ -

  • ~AIAnalogTrigger() : JY5320CoreOO::AIAnalogTrigger
  • ~CITimebase() : JY5320CoreOO::CITimebase
  • ~JY5320CoreOOAITask() : JY5320CoreOO::JY5320CoreOOAITask
  • ~JY5320CoreOOCITask() : JY5320CoreOO::JY5320CoreOOCITask
  • ~JY5320CoreOODOTask() : JY5320CoreOO::JY5320CoreOODOTask


5320 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- g -

  • GetDefautTerminal() : JY5320CoreOO::JY5320CoreOODevice
  • GetInstance() : JY5320CoreOO::JY5320CoreOODevice
  • GetRecordPreviewData() : JY5320CoreOO::JY5320CoreOOAITask
  • GetRecordStatus() : JY5320CoreOO::JY5320CoreOOAITask


5320 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- h -

  • Handle : JY5320CoreOO::JY5320CoreOODevice
  • HighThreshold : JY5320CoreOO::AIAnalogHysteresisComparator, JY5320CoreOO::AIAnalogWindowComparator
  • Hysteresis : JY5320CoreOO::AIAnalogTrigger


5320 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- i -

  • IdleState : JY5320CoreOO::EdgeCountingOutEvent, JY5320CoreOO::JY5320CoreOOCOTask
  • IgnoreFirstSampleClock : JY5320CoreOO::CIExternalSampleClock, JY5320CoreOO::CIInternalSampleClock
  • Implicit : JY5320CoreOO::CISampleClock
  • InitialCount : JY5320CoreOO::EdgeCounting, JY5320CoreOO::QuadEncoder, JY5320CoreOO::TwoPulseEncoder
  • InitialDelay : JY5320CoreOO::JY5320CoreOOCOTask
  • Input_Terminal : JY5320CoreOO::EdgeCounting, JY5320CoreOO::FrequencyMeas, JY5320CoreOO::PeriodMeas, JY5320CoreOO::PulseMeas
  • Inputterminal : JY5320CoreOO::SemiPeriodMeas
  • Internal : JY5320CoreOO::CISampleClock
  • IsAISync : JY5320CoreOO::JY5320CoreOODevice
  • IsAOSync : JY5320CoreOO::JY5320CoreOODevice


5320 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- j -

  • JY5320CoreOOAITask() : JY5320CoreOO::JY5320CoreOOAITask
  • JY5320CoreOOCITask() : JY5320CoreOO::JY5320CoreOOCITask
  • JY5320CoreOOCOTask() : JY5320CoreOO::JY5320CoreOOCOTask
  • JY5320CoreOODITask() : JY5320CoreOO::JY5320CoreOODITask
  • JY5320CoreOODOTask() : JY5320CoreOO::JY5320CoreOODOTask
  • JY5320CoreOOProperty() : JY5320CoreOO::JY5320CoreOOProperty< ContainerClass, ValueType, propertyType >
  • JYDriverException() : JY5320CoreOO::JYDriverException


5320 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- l -

  • Length : JY5320CoreOO::AIRecord
  • LineCountPerPort : JY5320CoreOO::JY5320CoreOODevice
  • Logic : JY5320CoreOO::AIMultiChannelAnalogTrigger
  • LogLevel : JY5320CoreOO::JY5320CoreOOLog
  • LowThreshold : JY5320CoreOO::AIAnalogHysteresisComparator, JY5320CoreOO::AIAnalogWindowComparator


5320 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- m -

  • MaxSampleRateSingleChannel : JY5320CoreOO::JY5320CoreOODevice
  • Mode : JY5320CoreOO::AIRecord, JY5320CoreOO::AITrigger, JY5320CoreOO::JY5320CoreOOAITask, JY5320CoreOO::JY5320CoreOOCITask, JY5320CoreOO::JY5320CoreOOCOTask
  • MultiChannel : JY5320CoreOO::AITrigger


5320 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- o -

  • operator ValueType() : JY5320CoreOO::JY5320CoreOOProperty< ContainerClass, ValueType, propertyType >
  • operator=() : JY5320CoreOO::JY5320CoreOOProperty< ContainerClass, ValueType, propertyType >
  • OutEvent : JY5320CoreOO::EdgeCounting
  • OutputTerminal : JY5320CoreOO::JY5320CoreOOCOTask


5320 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- p -

  • Pause : JY5320CoreOO::EdgeCounting, JY5320CoreOO::JY5320CoreOOCOTask
  • PeriodMeas : JY5320CoreOO::JY5320CoreOOCITask
  • PortNum : JY5320CoreOO::DIChannel, JY5320CoreOO::DOChannel
  • PreTriggerSamples : JY5320CoreOO::AITrigger
  • Print() : JY5320CoreOO::JY5320CoreOOLog
  • PulseMeas : JY5320CoreOO::JY5320CoreOOCITask
  • PulseRouting : JY5320CoreOO::AISync


5320 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- q -

  • QuadEncoder : JY5320CoreOO::JY5320CoreOOCITask


5320 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- r -

  • RangeHigh : JY5320CoreOO::AIChannel
  • RangeLow : JY5320CoreOO::AIChannel
  • Rate : JY5320CoreOO::CIInternalSampleClock
  • ReadData() : JY5320CoreOO::JY5320CoreOOAITask, JY5320CoreOO::JY5320CoreOOCITask
  • ReadRawData() : JY5320CoreOO::JY5320CoreOOAITask
  • ReadSinglePoint() : JY5320CoreOO::JY5320CoreOOAITask, JY5320CoreOO::JY5320CoreOOCITask, JY5320CoreOO::JY5320CoreOODITask
  • Record : JY5320CoreOO::JY5320CoreOOAITask
  • ReferenceClock : JY5320CoreOO::JY5320CoreOODevice
  • RemoveChannel() : JY5320CoreOO::JY5320CoreOOAITask, JY5320CoreOO::JY5320CoreOODITask, JY5320CoreOO::JY5320CoreOODOTask
  • ReTriggerCount : JY5320CoreOO::AITrigger


5320 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- s -

  • SampleClock : JY5320CoreOO::JY5320CoreOOAITask, JY5320CoreOO::JY5320CoreOOCITask
  • SampleRate : JY5320CoreOO::JY5320CoreOOAITask
  • SamplesToAcquire : JY5320CoreOO::JY5320CoreOOAITask, JY5320CoreOO::JY5320CoreOOCITask
  • SamplesToUpdate : JY5320CoreOO::JY5320CoreOOCOTask
  • SecondInputTerminal : JY5320CoreOO::TwoEdgeSeparation
  • SemiPeriodMeas : JY5320CoreOO::JY5320CoreOOCITask
  • SendSoftwareTrigger() : JY5320CoreOO::JY5320CoreOOAITask, JY5320CoreOO::JY5320CoreOOCITask, JY5320CoreOO::JY5320CoreOOCOTask
  • SerialNumber : JY5320CoreOO::JY5320CoreOODevice
  • SignalExport : JY5320CoreOO::JY5320CoreOOAITask, JY5320CoreOO::JY5320CoreOOCITask, JY5320CoreOO::JY5320CoreOOCOTask
  • Slope : JY5320CoreOO::AIAnalogEdgeComparator, JY5320CoreOO::AIAnalogHysteresisComparator
  • Source : JY5320CoreOO::AIAnalogTrigger, JY5320CoreOO::AIDigitalTrigger, JY5320CoreOO::AISampleClock, JY5320CoreOO::CIDigitalTrigger, JY5320CoreOO::CISampleClock, JY5320CoreOO::CITimebase, JY5320CoreOO::CODigitalTrigger, JY5320CoreOO::COTimebase, JY5320CoreOO::JY5320CoreOOReferenceClock
  • Start() : JY5320CoreOO::JY5320CoreOOAITask, JY5320CoreOO::JY5320CoreOOCITask, JY5320CoreOO::JY5320CoreOOCOTask, JY5320CoreOO::JY5320CoreOODITask, JY5320CoreOO::JY5320CoreOODOTask
  • StartingEdge : JY5320CoreOO::PeriodMeas, JY5320CoreOO::PulseMeas, JY5320CoreOO::SemiPeriodMeas
  • Stop() : JY5320CoreOO::JY5320CoreOOAITask, JY5320CoreOO::JY5320CoreOOCITask, JY5320CoreOO::JY5320CoreOOCOTask, JY5320CoreOO::JY5320CoreOODITask, JY5320CoreOO::JY5320CoreOODOTask
  • SubCardADCChannelNum : JY5320CoreOO::JY5320CoreOODevice
  • SubCardADCType : JY5320CoreOO::JY5320CoreOODevice
  • Sync : JY5320CoreOO::JY5320CoreOOAITask


5320 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- t -

  • Terminal : JY5320CoreOO::AIExternalSampleClock, JY5320CoreOO::CIExternalSampleClock, JY5320CoreOO::CIExternalTimebase, JY5320CoreOO::COExternalTimebase, JY5320CoreOO::EdgeCountingOutEvent, JY5320CoreOO::ExternalReferenceClock, JY5320CoreOO::PauseTrigger
  • Threshold : JY5320CoreOO::AIAnalogEdgeComparator, JY5320CoreOO::EdgeCountingOutEvent
  • TimeBase : JY5320CoreOO::JY5320CoreOOCOTask
  • Timebase : JY5320CoreOO::FrequencyMeas, JY5320CoreOO::PeriodMeas, JY5320CoreOO::PulseMeas, JY5320CoreOO::SemiPeriodMeas, JY5320CoreOO::TwoEdgeSeparation
  • Topology : JY5320CoreOO::AISync
  • TransferedPulses : JY5320CoreOO::JY5320CoreOOCOTask
  • TransferedSamples : JY5320CoreOO::JY5320CoreOOAITask, JY5320CoreOO::JY5320CoreOOCITask, JY5320CoreOO::JY5320CoreOOCOTask
  • Trigger : JY5320CoreOO::JY5320CoreOOAITask, JY5320CoreOO::JY5320CoreOOCITask, JY5320CoreOO::JY5320CoreOOCOTask
  • TriggerRouting : JY5320CoreOO::AISync
  • TwoEdgeSeparation : JY5320CoreOO::JY5320CoreOOCITask
  • TwoPulseEncoder : JY5320CoreOO::JY5320CoreOOCITask
  • Type : JY5320CoreOO::AITrigger, JY5320CoreOO::CITrigger, JY5320CoreOO::COTrigger, JY5320CoreOO::JY5320CoreOOCITask


5320 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- a -

  • ActiveEdge : JY5320CoreOO::EdgeCounting
  • ActivePolarity : JY5320CoreOO::PauseTrigger
  • ActualFreq : JY5320CoreOO::CITimebase, JY5320CoreOO::COTimebase
  • Advanced : JY5320CoreOO::JY5320CoreOOAITask
  • AIBufferSize : JY5320CoreOO::JY5320CoreOODevice
  • AInputTerminal : JY5320CoreOO::QuadEncoder, JY5320CoreOO::TwoPulseEncoder
  • Analog : JY5320CoreOO::AIMultiChannelAnalogTrigger, JY5320CoreOO::AITrigger
  • AvailableSamples : JY5320CoreOO::JY5320CoreOOAITask, JY5320CoreOO::JY5320CoreOOCITask
  • AvaliableLenInSamples : JY5320CoreOO::JY5320CoreOOCOTask

- b -

  • BandWidth : JY5320CoreOO::AIChannel
  • BInputTerminal : JY5320CoreOO::QuadEncoder, JY5320CoreOO::TwoPulseEncoder
  • BoardClockRate : JY5320CoreOO::JY5320CoreOODevice
  • BufLenInSamples : JY5320CoreOO::JY5320CoreOOAITask

- c -

  • ChannelID : JY5320CoreOO::AIChannel
  • Channels : JY5320CoreOO::JY5320CoreOOAITask, JY5320CoreOO::JY5320CoreOODITask, JY5320CoreOO::JY5320CoreOODOTask
  • Comparator : JY5320CoreOO::AIAnalogTrigger
  • Condition : JY5320CoreOO::AIAnalogWindowComparator

- d -

  • Device : JY5320CoreOO::JY5320CoreOOAITask, JY5320CoreOO::JY5320CoreOOCITask, JY5320CoreOO::JY5320CoreOOCOTask, JY5320CoreOO::JY5320CoreOODITask, JY5320CoreOO::JY5320CoreOODOTask
  • DeviceID : JY5320CoreOO::JY5320CoreOODevice
  • DiffChannelCount : JY5320CoreOO::JY5320CoreOODevice
  • Digital : JY5320CoreOO::AITrigger, JY5320CoreOO::CITrigger, JY5320CoreOO::COTrigger
  • DIOPortCount : JY5320CoreOO::JY5320CoreOODevice
  • Direction : JY5320CoreOO::EdgeCounting
  • DirTerminal : JY5320CoreOO::EdgeCounting
  • DisableDigitalTriggerDelay : JY5320CoreOO::JY5320CoreOOAITask
  • DSMode : JY5320CoreOO::AIAdvanced

- e -

  • Edge : JY5320CoreOO::AIAnalogTrigger, JY5320CoreOO::AIDigitalTrigger, JY5320CoreOO::CIDigitalTrigger, JY5320CoreOO::CODigitalTrigger
  • EdgeCounting : JY5320CoreOO::JY5320CoreOOCITask
  • EdgeSeparationMode : JY5320CoreOO::TwoEdgeSeparation
  • Enable : JY5320CoreOO::AIDSMode
  • EnableLog : JY5320CoreOO::JY5320CoreOOLog
  • EncodingType : JY5320CoreOO::QuadEncoder
  • errorCode : JY5320CoreOO::JYDriverException
  • exceptionMessage : JY5320CoreOO::JYDriverException
  • ExpectedRate : JY5320CoreOO::AIExternalSampleClock, JY5320CoreOO::CIExternalSampleClock, JY5320CoreOO::CIImplicitSampleClock
  • External : JY5320CoreOO::AISampleClock, JY5320CoreOO::CISampleClock, JY5320CoreOO::CITimebase, JY5320CoreOO::COTimebase, JY5320CoreOO::JY5320CoreOOReferenceClock

- f -

  • File_Format : JY5320CoreOO::AIRecord
  • FilePath : JY5320CoreOO::AIRecord
  • FirstInputTerminal : JY5320CoreOO::TwoEdgeSeparation
  • FollowingException : JY5320CoreOO::JYDriverException
  • Frequency : JY5320CoreOO::CIExternalTimebase, JY5320CoreOO::COExternalTimebase
  • FrequencyMeas : JY5320CoreOO::JY5320CoreOOCITask

- h -

  • Handle : JY5320CoreOO::JY5320CoreOODevice
  • HighThreshold : JY5320CoreOO::AIAnalogHysteresisComparator, JY5320CoreOO::AIAnalogWindowComparator
  • Hysteresis : JY5320CoreOO::AIAnalogTrigger

- i -

  • IdleState : JY5320CoreOO::EdgeCountingOutEvent, JY5320CoreOO::JY5320CoreOOCOTask
  • IgnoreFirstSampleClock : JY5320CoreOO::CIExternalSampleClock, JY5320CoreOO::CIInternalSampleClock
  • Implicit : JY5320CoreOO::CISampleClock
  • InitialCount : JY5320CoreOO::EdgeCounting, JY5320CoreOO::QuadEncoder, JY5320CoreOO::TwoPulseEncoder
  • InitialDelay : JY5320CoreOO::JY5320CoreOOCOTask
  • Input_Terminal : JY5320CoreOO::EdgeCounting, JY5320CoreOO::FrequencyMeas, JY5320CoreOO::PeriodMeas, JY5320CoreOO::PulseMeas
  • Inputterminal : JY5320CoreOO::SemiPeriodMeas
  • Internal : JY5320CoreOO::CISampleClock
  • IsAISync : JY5320CoreOO::JY5320CoreOODevice
  • IsAOSync : JY5320CoreOO::JY5320CoreOODevice

- l -

  • Length : JY5320CoreOO::AIRecord
  • LineCountPerPort : JY5320CoreOO::JY5320CoreOODevice
  • Logic : JY5320CoreOO::AIMultiChannelAnalogTrigger
  • LogLevel : JY5320CoreOO::JY5320CoreOOLog
  • LowThreshold : JY5320CoreOO::AIAnalogHysteresisComparator, JY5320CoreOO::AIAnalogWindowComparator

- m -

  • MaxSampleRateSingleChannel : JY5320CoreOO::JY5320CoreOODevice
  • Mode : JY5320CoreOO::AIRecord, JY5320CoreOO::AITrigger, JY5320CoreOO::JY5320CoreOOAITask, JY5320CoreOO::JY5320CoreOOCITask, JY5320CoreOO::JY5320CoreOOCOTask
  • MultiChannel : JY5320CoreOO::AITrigger

- o -

  • OutEvent : JY5320CoreOO::EdgeCounting
  • OutputTerminal : JY5320CoreOO::JY5320CoreOOCOTask

- p -

  • Pause : JY5320CoreOO::EdgeCounting, JY5320CoreOO::JY5320CoreOOCOTask
  • PeriodMeas : JY5320CoreOO::JY5320CoreOOCITask
  • PortNum : JY5320CoreOO::DIChannel, JY5320CoreOO::DOChannel
  • PreTriggerSamples : JY5320CoreOO::AITrigger
  • PulseMeas : JY5320CoreOO::JY5320CoreOOCITask
  • PulseRouting : JY5320CoreOO::AISync

- q -

  • QuadEncoder : JY5320CoreOO::JY5320CoreOOCITask

- r -

  • RangeHigh : JY5320CoreOO::AIChannel
  • RangeLow : JY5320CoreOO::AIChannel
  • Rate : JY5320CoreOO::CIInternalSampleClock
  • Record : JY5320CoreOO::JY5320CoreOOAITask
  • ReferenceClock : JY5320CoreOO::JY5320CoreOODevice
  • ReTriggerCount : JY5320CoreOO::AITrigger

- s -

  • SampleClock : JY5320CoreOO::JY5320CoreOOAITask, JY5320CoreOO::JY5320CoreOOCITask
  • SampleRate : JY5320CoreOO::JY5320CoreOOAITask
  • SamplesToAcquire : JY5320CoreOO::JY5320CoreOOAITask, JY5320CoreOO::JY5320CoreOOCITask
  • SamplesToUpdate : JY5320CoreOO::JY5320CoreOOCOTask
  • SecondInputTerminal : JY5320CoreOO::TwoEdgeSeparation
  • SemiPeriodMeas : JY5320CoreOO::JY5320CoreOOCITask
  • SerialNumber : JY5320CoreOO::JY5320CoreOODevice
  • SignalExport : JY5320CoreOO::JY5320CoreOOAITask, JY5320CoreOO::JY5320CoreOOCITask, JY5320CoreOO::JY5320CoreOOCOTask
  • Slope : JY5320CoreOO::AIAnalogEdgeComparator, JY5320CoreOO::AIAnalogHysteresisComparator
  • Source : JY5320CoreOO::AIAnalogTrigger, JY5320CoreOO::AIDigitalTrigger, JY5320CoreOO::AISampleClock, JY5320CoreOO::CIDigitalTrigger, JY5320CoreOO::CISampleClock, JY5320CoreOO::CITimebase, JY5320CoreOO::CODigitalTrigger, JY5320CoreOO::COTimebase, JY5320CoreOO::JY5320CoreOOReferenceClock
  • StartingEdge : JY5320CoreOO::PeriodMeas, JY5320CoreOO::PulseMeas, JY5320CoreOO::SemiPeriodMeas
  • SubCardADCChannelNum : JY5320CoreOO::JY5320CoreOODevice
  • SubCardADCType : JY5320CoreOO::JY5320CoreOODevice
  • Sync : JY5320CoreOO::JY5320CoreOOAITask

- t -

  • Terminal : JY5320CoreOO::AIExternalSampleClock, JY5320CoreOO::CIExternalSampleClock, JY5320CoreOO::CIExternalTimebase, JY5320CoreOO::COExternalTimebase, JY5320CoreOO::EdgeCountingOutEvent, JY5320CoreOO::ExternalReferenceClock, JY5320CoreOO::PauseTrigger
  • Threshold : JY5320CoreOO::AIAnalogEdgeComparator, JY5320CoreOO::EdgeCountingOutEvent
  • TimeBase : JY5320CoreOO::JY5320CoreOOCOTask
  • Timebase : JY5320CoreOO::FrequencyMeas, JY5320CoreOO::PeriodMeas, JY5320CoreOO::PulseMeas, JY5320CoreOO::SemiPeriodMeas, JY5320CoreOO::TwoEdgeSeparation
  • Topology : JY5320CoreOO::AISync
  • TransferedPulses : JY5320CoreOO::JY5320CoreOOCOTask
  • TransferedSamples : JY5320CoreOO::JY5320CoreOOAITask, JY5320CoreOO::JY5320CoreOOCITask, JY5320CoreOO::JY5320CoreOOCOTask
  • Trigger : JY5320CoreOO::JY5320CoreOOAITask, JY5320CoreOO::JY5320CoreOOCITask, JY5320CoreOO::JY5320CoreOOCOTask
  • TriggerRouting : JY5320CoreOO::AISync
  • TwoEdgeSeparation : JY5320CoreOO::JY5320CoreOOCITask
  • TwoPulseEncoder : JY5320CoreOO::JY5320CoreOOCITask
  • Type : JY5320CoreOO::AITrigger, JY5320CoreOO::CITrigger, JY5320CoreOO::COTrigger, JY5320CoreOO::JY5320CoreOOCITask

- w -

  • Window : JY5320CoreOO::AIAnalogTrigger

- z -

  • ZInputTerminal : JY5320CoreOO::QuadEncoder
  • ZReloadEnabled : JY5320CoreOO::QuadEncoder


5320 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- w -

  • WaitUntilDone() : JY5320CoreOO::JY5320CoreOOCOTask
  • Window : JY5320CoreOO::AIAnalogTrigger
  • WriteData() : JY5320CoreOO::JY5320CoreOOCOTask
  • WriteSinglePoint() : JY5320CoreOO::JY5320CoreOOCOTask, JY5320CoreOO::JY5320CoreOODOTask


5320 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- z -

  • ZInputTerminal : JY5320CoreOO::QuadEncoder
  • ZReloadEnabled : JY5320CoreOO::QuadEncoder


5320 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- ~ -

  • ~AIAnalogTrigger() : JY5320CoreOO::AIAnalogTrigger
  • ~CITimebase() : JY5320CoreOO::CITimebase
  • ~JY5320CoreOOAITask() : JY5320CoreOO::JY5320CoreOOAITask
  • ~JY5320CoreOOCITask() : JY5320CoreOO::JY5320CoreOOCITask
  • ~JY5320CoreOODOTask() : JY5320CoreOO::JY5320CoreOODOTask


5320 C++ Programming Manual: File Members

  • File List
  • File Members
  • All
  • Macros
Here is a list of all file members with links to the files they belong to:
  • __JY5320_CORE_OO_CITASK_H__ : JY5320CoreOOCITask.h
  • _CRT_SECURE_NO_WARNINGS : JY5320CoreOOAITask.h
  • EXTERN_C : JY5320CoreOOCommon.h
  • JY5320CoreOO_API : JY5320CoreOOCommon.h


5320 C++ Programming Manual: File Members

  • File List
  • File Members
  • All
  • Macros
Here is a list of all macros with links to the files they belong to:
  • __JY5320_CORE_OO_CITASK_H__ : JY5320CoreOOCITask.h
  • _CRT_SECURE_NO_WARNINGS : JY5320CoreOOAITask.h
  • EXTERN_C : JY5320CoreOOCommon.h
  • JY5320CoreOO_API : JY5320CoreOOCommon.h


5320 C++ Programming Manual: Main Page

5320 C++ Programming Manual Documentation


5320 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • l
  • m
  • o
  • q
  • r
  • s
  • v
Here is a list of all namespace members with links to the namespace documentation for each member:

- a -

  • AIAnalogTriggerComparator : JY5320CoreOO
  • AIAnalogTriggerEdge : JY5320CoreOO
  • AIAnalogTriggerSource : JY5320CoreOO
  • AIAnalogWindowCondition : JY5320CoreOO
  • AIBandWidth : JY5320CoreOO
  • AIDigitalTriggerEdge : JY5320CoreOO
  • AIDigitalTriggerSource : JY5320CoreOO
  • AIMode : JY5320CoreOO
  • AISampleClockSource : JY5320CoreOO
  • AISignalExportSource : JY5320CoreOO
  • AITriggerMode : JY5320CoreOO
  • AITriggerType : JY5320CoreOO
  • And : JY5320Import


5320 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • l
  • m
  • o
  • q
  • r
  • s
  • v
Here is a list of all namespace members with links to the namespace documentation for each member:

- c -

  • CIDigitalTriggerEdge : JY5320CoreOO
  • CIDigitalTriggerSource : JY5320CoreOO
  • CIMode : JY5320CoreOO
  • CISampleClockSource : JY5320CoreOO
  • CISignalExportSource : JY5320CoreOO
  • CITimebaseSource : JY5320CoreOO
  • CITriggerType : JY5320CoreOO
  • CIType : JY5320CoreOO
  • ClockTerminal : JY5320CoreOO
  • CODigitalTriggerEdge : JY5320CoreOO
  • CODigitalTriggerSource : JY5320CoreOO
  • COIdleState : JY5320CoreOO
  • COMode : JY5320CoreOO
  • COPulseType : JY5320CoreOO
  • COSignalExportSource : JY5320CoreOO
  • COTimebaseSource : JY5320CoreOO
  • COTriggerType : JY5320CoreOO
  • CountDirection : JY5320CoreOO
  • CounterInterface : JY5320CoreOO


5320 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • l
  • m
  • o
  • q
  • r
  • s
  • v
Here is a list of all namespace members with links to the namespace documentation for each member:

- d -

  • DISampleClockSource : JY5320CoreOO


5320 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • l
  • m
  • o
  • q
  • r
  • s
  • v
Here is a list of all namespace members with links to the namespace documentation for each member:

- e -

  • EdgeCntOunEvtIdleState : JY5320CoreOO
  • EdgeType : JY5320CoreOO
  • ExternalReferenceClockTerminal : JY5320CoreOO


5320 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
  • a
  • c
  • d
  • e
  • f
  • i
  • j
  • l
  • m
  • o
  • q
  • r
  • s
  • v
Here is a list of all namespace enums with links to the namespace documentation for each enum:

- a -

  • AIAnalogTriggerComparator : JY5320CoreOO
  • AIAnalogTriggerEdge : JY5320CoreOO
  • AIAnalogTriggerSource : JY5320CoreOO
  • AIAnalogWindowCondition : JY5320CoreOO
  • AIBandWidth : JY5320CoreOO
  • AIDigitalTriggerEdge : JY5320CoreOO
  • AIDigitalTriggerSource : JY5320CoreOO
  • AIMode : JY5320CoreOO
  • AISampleClockSource : JY5320CoreOO
  • AISignalExportSource : JY5320CoreOO
  • AITriggerMode : JY5320CoreOO
  • AITriggerType : JY5320CoreOO

- c -

  • CIDigitalTriggerEdge : JY5320CoreOO
  • CIDigitalTriggerSource : JY5320CoreOO
  • CIMode : JY5320CoreOO
  • CISampleClockSource : JY5320CoreOO
  • CISignalExportSource : JY5320CoreOO
  • CITimebaseSource : JY5320CoreOO
  • CITriggerType : JY5320CoreOO
  • CIType : JY5320CoreOO
  • ClockTerminal : JY5320CoreOO
  • CODigitalTriggerEdge : JY5320CoreOO
  • CODigitalTriggerSource : JY5320CoreOO
  • COIdleState : JY5320CoreOO
  • COMode : JY5320CoreOO
  • COPulseType : JY5320CoreOO
  • COSignalExportSource : JY5320CoreOO
  • COTimebaseSource : JY5320CoreOO
  • COTriggerType : JY5320CoreOO
  • CountDirection : JY5320CoreOO
  • CounterInterface : JY5320CoreOO

- d -

  • DISampleClockSource : JY5320CoreOO

- e -

  • EdgeCntOunEvtIdleState : JY5320CoreOO
  • EdgeType : JY5320CoreOO
  • ExternalReferenceClockTerminal : JY5320CoreOO

- f -

  • FileFormat : JY5320CoreOO

- i -

  • InputTerminal : JY5320CoreOO
  • IOTerminal : JY5320CoreOO

- j -

  • JY5320CoreOOLogLevel : JY5320CoreOO
  • JY5320CoreOOPropertyType : JY5320CoreOO
  • JYDriverExceptionPublic : JY5320CoreOO

- l -

  • LevelPolarity : JY5320CoreOO

- m -

  • MultiChannelCompositionLogic : JY5320CoreOO

- o -

  • OutputCompleteState : JY5320CoreOO

- q -

  • QuadEncodingType : JY5320CoreOO

- r -

  • RecordMode : JY5320CoreOO
  • ReferenceClockSource : JY5320CoreOO

- s -

  • SignalExportDestination : JY5320CoreOO
  • SyncPulseRouting : JY5320CoreOO
  • SyncTopology : JY5320CoreOO
  • SyncTriggerRouting : JY5320CoreOO

- v -

  • ValueReturnMode : JY5320CoreOO


5320 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • l
  • m
  • o
  • q
  • r
  • s
  • v
Here is a list of all namespace members with links to the namespace documentation for each member:

- f -

  • FileFormat : JY5320CoreOO


5320 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
Here is a list of all namespace functions with links to the namespace documentation for each function:
  • GetSignalExportDestinationString() : JY5320CoreOO


5320 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • l
  • m
  • o
  • q
  • r
  • s
  • v
Here is a list of all namespace members with links to the namespace documentation for each member:

- g -

  • GetSignalExportDestinationString() : JY5320CoreOO


5320 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • l
  • m
  • o
  • q
  • r
  • s
  • v
Here is a list of all namespace members with links to the namespace documentation for each member:

- i -

  • InputTerminal : JY5320CoreOO
  • IOTerminal : JY5320CoreOO


5320 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • l
  • m
  • o
  • q
  • r
  • s
  • v
Here is a list of all namespace members with links to the namespace documentation for each member:

- j -

  • JY5320_16CH : JY5320Import
  • JY5320_1M_16Bit : JY5320Import
  • JY5320_1M_18Bit : JY5320Import
  • JY5320_200K_16Bit : JY5320Import
  • JY5320_32CH : JY5320Import
  • JY5320_AI_BandWidth_220K : JY5320Import
  • JY5320_AI_BandWidth_25K : JY5320Import
  • JY5320_AI_Continuous : JY5320Import
  • JY5320_AI_ExternalClock : JY5320Import
  • JY5320_AI_Finite : JY5320Import
  • JY5320_AI_InternalClock : JY5320Import
  • JY5320_AI_ReferenceTrig : JY5320Import
  • JY5320_AI_SampleClock : JY5320Import
  • JY5320_AI_Single : JY5320Import
  • JY5320_AI_StartTrig : JY5320Import
  • JY5320_AI_SyncSignal : JY5320Import
  • JY5320_AI_SyncSignal_OUT : JY5320Import
  • JY5320_AnaloglTriggerCondition_LeavingWindow : JY5320Import
  • JY5320_AnalogTriggerCondition_EnteringWindow : JY5320Import
  • JY5320_AnalogTriggerEdge_FallingSlope : JY5320Import
  • JY5320_AnalogTriggerEdge_RisingSlope : JY5320Import
  • JY5320_AnyEdge : JY5320Import
  • JY5320_CI0_SampleClock : JY5320Import
  • JY5320_CI1_SampleClock : JY5320Import
  • JY5320_CI_Continuous : JY5320Import
  • JY5320_CI_Count_Down : JY5320Import
  • JY5320_CI_Count_External : JY5320Import
  • JY5320_CI_Count_Up : JY5320Import
  • JY5320_CI_CounterEventSignalIdleState_High : JY5320Import
  • JY5320_CI_CounterEventSignalIdleState_Low : JY5320Import
  • JY5320_CI_EdgeCount : JY5320Import
  • JY5320_CI_EncoderTwoPulse : JY5320Import
  • JY5320_CI_EncoderX1 : JY5320Import
  • JY5320_CI_EncoderX2 : JY5320Import
  • JY5320_CI_EncoderX4 : JY5320Import
  • JY5320_CI_ExternalClock : JY5320Import
  • JY5320_CI_Finite : JY5320Import
  • JY5320_CI_ImplicitClock : JY5320Import
  • JY5320_CI_InternalClock : JY5320Import
  • JY5320_CI_Measure_EdgeSeparation : JY5320Import
  • JY5320_CI_Measure_FrequencyOrPeriod : JY5320Import
  • JY5320_CI_Measure_PulseWidth : JY5320Import
  • JY5320_CI_Measure_SemiPeriod : JY5320Import
  • JY5320_CI_ReturnOneValue : JY5320Import
  • JY5320_CI_ReturnTwoValue : JY5320Import
  • JY5320_CI_Single : JY5320Import
  • JY5320_CIO_0_StartTrig : JY5320Import
  • JY5320_CIO_100kHz : JY5320Import
  • JY5320_CIO_100MHz : JY5320Import
  • JY5320_CIO_1_StartTrig : JY5320Import
  • JY5320_CIO_5MHz : JY5320Import
  • JY5320_CIO_Digital : JY5320Import
  • JY5320_CIO_Immediately : JY5320Import
  • JY5320_CIO_Soft : JY5320Import
  • JY5320_Clock_PFI_0 : JY5320Import
  • JY5320_Clock_PFI_1 : JY5320Import
  • JY5320_Clock_PFI_10 : JY5320Import
  • JY5320_Clock_PFI_11 : JY5320Import
  • JY5320_Clock_PFI_12 : JY5320Import
  • JY5320_Clock_PFI_13 : JY5320Import
  • JY5320_Clock_PFI_14 : JY5320Import
  • JY5320_Clock_PFI_15 : JY5320Import
  • JY5320_Clock_PFI_2 : JY5320Import
  • JY5320_Clock_PFI_3 : JY5320Import
  • JY5320_Clock_PFI_4 : JY5320Import
  • JY5320_Clock_PFI_5 : JY5320Import
  • JY5320_Clock_PFI_6 : JY5320Import
  • JY5320_Clock_PFI_7 : JY5320Import
  • JY5320_Clock_PFI_8 : JY5320Import
  • JY5320_Clock_PFI_9 : JY5320Import
  • JY5320_Clock_PXI_Trig_0 : JY5320Import
  • JY5320_Clock_PXI_Trig_1 : JY5320Import
  • JY5320_Clock_PXI_Trig_2 : JY5320Import
  • JY5320_Clock_PXI_Trig_3 : JY5320Import
  • JY5320_Clock_PXI_Trig_4 : JY5320Import
  • JY5320_Clock_PXI_Trig_5 : JY5320Import
  • JY5320_Clock_PXI_Trig_6 : JY5320Import
  • JY5320_Clock_PXI_Trig_7 : JY5320Import
  • JY5320_CO_0_Output : JY5320Import
  • JY5320_CO_1_Output : JY5320Import
  • JY5320_CO_ContinuousNoWrapping : JY5320Import
  • JY5320_CO_ContinuousWrapping : JY5320Import
  • JY5320_CO_Finite : JY5320Import
  • JY5320_CO_HighLevel : JY5320Import
  • JY5320_CO_LowLevel : JY5320Import
  • JY5320_CO_Single : JY5320Import
  • JY5320_DigitalTriggerEdge_Falling : JY5320Import
  • JY5320_DigitalTriggerEdge_Rising : JY5320Import
  • JY5320_DigitalTriggerSource_Inter_AI_ReferenceTrig : JY5320Import
  • JY5320_DigitalTriggerSource_Inter_AI_StartTrig : JY5320Import
  • JY5320_DigitalTriggerSource_Inter_CIO_0_StartTrig : JY5320Import
  • JY5320_DigitalTriggerSource_Inter_CIO_1_StartTrig : JY5320Import
  • JY5320_DigitalTriggerSource_Inter_Counter_0_Output : JY5320Import
  • JY5320_DigitalTriggerSource_Inter_Counter_1_Output : JY5320Import
  • JY5320_DigitalTriggerSource_PFI_0 : JY5320Import
  • JY5320_DigitalTriggerSource_PFI_1 : JY5320Import
  • JY5320_DigitalTriggerSource_PFI_10 : JY5320Import
  • JY5320_DigitalTriggerSource_PFI_11 : JY5320Import
  • JY5320_DigitalTriggerSource_PFI_12 : JY5320Import
  • JY5320_DigitalTriggerSource_PFI_13 : JY5320Import
  • JY5320_DigitalTriggerSource_PFI_14 : JY5320Import
  • JY5320_DigitalTriggerSource_PFI_15 : JY5320Import
  • JY5320_DigitalTriggerSource_PFI_2 : JY5320Import
  • JY5320_DigitalTriggerSource_PFI_3 : JY5320Import
  • JY5320_DigitalTriggerSource_PFI_4 : JY5320Import
  • JY5320_DigitalTriggerSource_PFI_5 : JY5320Import
  • JY5320_DigitalTriggerSource_PFI_6 : JY5320Import
  • JY5320_DigitalTriggerSource_PFI_7 : JY5320Import
  • JY5320_DigitalTriggerSource_PFI_8 : JY5320Import
  • JY5320_DigitalTriggerSource_PFI_9 : JY5320Import
  • JY5320_DigitalTriggerSource_PXI_0 : JY5320Import
  • JY5320_DigitalTriggerSource_PXI_1 : JY5320Import
  • JY5320_DigitalTriggerSource_PXI_2 : JY5320Import
  • JY5320_DigitalTriggerSource_PXI_3 : JY5320Import
  • JY5320_DigitalTriggerSource_PXI_4 : JY5320Import
  • JY5320_DigitalTriggerSource_PXI_5 : JY5320Import
  • JY5320_DigitalTriggerSource_PXI_6 : JY5320Import
  • JY5320_DigitalTriggerSource_PXI_7 : JY5320Import
  • JY5320_External_Timebase : JY5320Import
  • JY5320_FallingEdge : JY5320Import
  • JY5320_HighLevel : JY5320Import
  • JY5320_IN_AI_SampleClock : JY5320Import
  • JY5320_IN_CIO_100kHz : JY5320Import
  • JY5320_IN_CIO_100MHz : JY5320Import
  • JY5320_IN_CIO_5MHz : JY5320Import
  • JY5320_IN_CO_0_Output : JY5320Import
  • JY5320_IN_CO_1_Output : JY5320Import
  • JY5320_IN_PFI0 : JY5320Import
  • JY5320_IN_PFI1 : JY5320Import
  • JY5320_IN_PFI10 : JY5320Import
  • JY5320_IN_PFI11 : JY5320Import
  • JY5320_IN_PFI12 : JY5320Import
  • JY5320_IN_PFI13 : JY5320Import
  • JY5320_IN_PFI14 : JY5320Import
  • JY5320_IN_PFI15 : JY5320Import
  • JY5320_IN_PFI2 : JY5320Import
  • JY5320_IN_PFI3 : JY5320Import
  • JY5320_IN_PFI4 : JY5320Import
  • JY5320_IN_PFI5 : JY5320Import
  • JY5320_IN_PFI6 : JY5320Import
  • JY5320_IN_PFI7 : JY5320Import
  • JY5320_IN_PFI8 : JY5320Import
  • JY5320_IN_PFI9 : JY5320Import
  • JY5320_IN_PXI_Trig0 : JY5320Import
  • JY5320_IN_PXI_Trig1 : JY5320Import
  • JY5320_IN_PXI_Trig2 : JY5320Import
  • JY5320_IN_PXI_Trig3 : JY5320Import
  • JY5320_IN_PXI_Trig4 : JY5320Import
  • JY5320_IN_PXI_Trig5 : JY5320Import
  • JY5320_IN_PXI_Trig6 : JY5320Import
  • JY5320_IN_PXI_Trig7 : JY5320Import
  • JY5320_Independent : JY5320Import
  • JY5320_Inter_AI_SampleClock : JY5320Import
  • JY5320_Inter_CI_0_SampleClock : JY5320Import
  • JY5320_Inter_CI_1_SampleClock : JY5320Import
  • JY5320_Inter_CO_0_Output : JY5320Import
  • JY5320_Inter_CO_1_Output : JY5320Import
  • JY5320_Internal_Timebase_100K : JY5320Import
  • JY5320_Internal_Timebase_100M : JY5320Import
  • JY5320_Internal_Timebase_5M : JY5320Import
  • JY5320_LowLevel : JY5320Import
  • JY5320_MASTER : JY5320Import
  • JY5320_PFI0_OUT : JY5320Import
  • JY5320_PFI10_OUT : JY5320Import
  • JY5320_PFI11_OUT : JY5320Import
  • JY5320_PFI12_OUT : JY5320Import
  • JY5320_PFI13_OUT : JY5320Import
  • JY5320_PFI14_OUT : JY5320Import
  • JY5320_PFI15_OUT : JY5320Import
  • JY5320_PFI1_OUT : JY5320Import
  • JY5320_PFI2_OUT : JY5320Import
  • JY5320_PFI3_OUT : JY5320Import
  • JY5320_PFI4_OUT : JY5320Import
  • JY5320_PFI5_OUT : JY5320Import
  • JY5320_PFI6_OUT : JY5320Import
  • JY5320_PFI7_OUT : JY5320Import
  • JY5320_PFI8_OUT : JY5320Import
  • JY5320_PFI9_OUT : JY5320Import
  • JY5320_PXITrig0_OUT : JY5320Import
  • JY5320_PXITrig1_OUT : JY5320Import
  • JY5320_PXITrig2_OUT : JY5320Import
  • JY5320_PXITrig3_OUT : JY5320Import
  • JY5320_PXITrig4_OUT : JY5320Import
  • JY5320_PXITrig5_OUT : JY5320Import
  • JY5320_PXITrig6_OUT : JY5320Import
  • JY5320_PXITrig7_OUT : JY5320Import
  • JY5320_ReferenceTrigger : JY5320Import
  • JY5320_RisingEdge : JY5320Import
  • JY5320_Signal_PFI_0 : JY5320Import
  • JY5320_Signal_PFI_1 : JY5320Import
  • JY5320_Signal_PFI_10 : JY5320Import
  • JY5320_Signal_PFI_11 : JY5320Import
  • JY5320_Signal_PFI_12 : JY5320Import
  • JY5320_Signal_PFI_14 : JY5320Import
  • JY5320_Signal_PFI_15 : JY5320Import
  • JY5320_Signal_PFI_2 : JY5320Import
  • JY5320_Signal_PFI_3 : JY5320Import
  • JY5320_Signal_PFI_4 : JY5320Import
  • JY5320_Signal_PFI_5 : JY5320Import
  • JY5320_Signal_PFI_6 : JY5320Import
  • JY5320_Signal_PFI_7 : JY5320Import
  • JY5320_Signal_PFI_8 : JY5320Import
  • JY5320_Signal_PFI_9 : JY5320Import
  • JY5320_Signal_PXI_Trig_0 : JY5320Import
  • JY5320_Signal_PXI_Trig_1 : JY5320Import
  • JY5320_Signal_PXI_Trig_2 : JY5320Import
  • JY5320_Signal_PXI_Trig_3 : JY5320Import
  • JY5320_Signal_PXI_Trig_4 : JY5320Import
  • JY5320_Signal_PXI_Trig_5 : JY5320Import
  • JY5320_Signal_PXI_Trig_6 : JY5320Import
  • JY5320_Signal_PXI_Trig_7 : JY5320Import
  • JY5320_SLAVE : JY5320Import
  • JY5320_StartTrigger : JY5320Import
  • JY5320_TriggerType_Analog : JY5320Import
  • JY5320_TriggerType_Digital : JY5320Import
  • JY5320_TriggerType_Immediately : JY5320Import
  • JY5320_TriggerType_Soft : JY5320Import
  • JY5320CoreOOLogLevel : JY5320CoreOO
  • JY5320CoreOOPropertyType : JY5320CoreOO
  • JYDriverExceptionPublic : JY5320CoreOO


5320 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • l
  • m
  • o
  • q
  • r
  • s
  • v
Here is a list of all namespace members with links to the namespace documentation for each member:

- l -

  • LevelPolarity : JY5320CoreOO


5320 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • l
  • m
  • o
  • q
  • r
  • s
  • v
Here is a list of all namespace members with links to the namespace documentation for each member:

- m -

  • MultiChannelCompositionLogic : JY5320CoreOO


5320 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • l
  • m
  • o
  • q
  • r
  • s
  • v
Here is a list of all namespace members with links to the namespace documentation for each member:

- o -

  • Or : JY5320Import
  • OutputCompleteState : JY5320CoreOO


5320 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • l
  • m
  • o
  • q
  • r
  • s
  • v
Here is a list of all namespace members with links to the namespace documentation for each member:

- q -

  • QuadEncodingType : JY5320CoreOO


5320 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • l
  • m
  • o
  • q
  • r
  • s
  • v
Here is a list of all namespace members with links to the namespace documentation for each member:

- r -

  • RecordMode : JY5320CoreOO
  • ReferenceClockSource : JY5320CoreOO
  • ReferenceOnboard_25M : JY5320Import
  • ReferencePXIeCLK_100M : JY5320Import


5320 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • l
  • m
  • o
  • q
  • r
  • s
  • v
Here is a list of all namespace members with links to the namespace documentation for each member:

- s -

  • SignalExportDestination : JY5320CoreOO
  • SyncPulseRouting : JY5320CoreOO
  • SyncTopology : JY5320CoreOO
  • SyncTriggerRouting : JY5320CoreOO


5320 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • l
  • m
  • o
  • q
  • r
  • s
  • v
Here is a list of all namespace members with links to the namespace documentation for each member:

- v -

  • ValueReturnMode : JY5320CoreOO


5320 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
  • a
  • j
  • o
  • r
Here is a list of all namespace variables with links to the namespace documentation for each variable:

- a -

  • And : JY5320Import


5320 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
  • a
  • j
  • o
  • r
Here is a list of all namespace variables with links to the namespace documentation for each variable:

- j -

  • JY5320_16CH : JY5320Import
  • JY5320_1M_16Bit : JY5320Import
  • JY5320_1M_18Bit : JY5320Import
  • JY5320_200K_16Bit : JY5320Import
  • JY5320_32CH : JY5320Import
  • JY5320_AI_BandWidth_220K : JY5320Import
  • JY5320_AI_BandWidth_25K : JY5320Import
  • JY5320_AI_Continuous : JY5320Import
  • JY5320_AI_ExternalClock : JY5320Import
  • JY5320_AI_Finite : JY5320Import
  • JY5320_AI_InternalClock : JY5320Import
  • JY5320_AI_ReferenceTrig : JY5320Import
  • JY5320_AI_SampleClock : JY5320Import
  • JY5320_AI_Single : JY5320Import
  • JY5320_AI_StartTrig : JY5320Import
  • JY5320_AI_SyncSignal : JY5320Import
  • JY5320_AI_SyncSignal_OUT : JY5320Import
  • JY5320_AnaloglTriggerCondition_LeavingWindow : JY5320Import
  • JY5320_AnalogTriggerCondition_EnteringWindow : JY5320Import
  • JY5320_AnalogTriggerEdge_FallingSlope : JY5320Import
  • JY5320_AnalogTriggerEdge_RisingSlope : JY5320Import
  • JY5320_AnyEdge : JY5320Import
  • JY5320_CI0_SampleClock : JY5320Import
  • JY5320_CI1_SampleClock : JY5320Import
  • JY5320_CI_Continuous : JY5320Import
  • JY5320_CI_Count_Down : JY5320Import
  • JY5320_CI_Count_External : JY5320Import
  • JY5320_CI_Count_Up : JY5320Import
  • JY5320_CI_CounterEventSignalIdleState_High : JY5320Import
  • JY5320_CI_CounterEventSignalIdleState_Low : JY5320Import
  • JY5320_CI_EdgeCount : JY5320Import
  • JY5320_CI_EncoderTwoPulse : JY5320Import
  • JY5320_CI_EncoderX1 : JY5320Import
  • JY5320_CI_EncoderX2 : JY5320Import
  • JY5320_CI_EncoderX4 : JY5320Import
  • JY5320_CI_ExternalClock : JY5320Import
  • JY5320_CI_Finite : JY5320Import
  • JY5320_CI_ImplicitClock : JY5320Import
  • JY5320_CI_InternalClock : JY5320Import
  • JY5320_CI_Measure_EdgeSeparation : JY5320Import
  • JY5320_CI_Measure_FrequencyOrPeriod : JY5320Import
  • JY5320_CI_Measure_PulseWidth : JY5320Import
  • JY5320_CI_Measure_SemiPeriod : JY5320Import
  • JY5320_CI_ReturnOneValue : JY5320Import
  • JY5320_CI_ReturnTwoValue : JY5320Import
  • JY5320_CI_Single : JY5320Import
  • JY5320_CIO_0_StartTrig : JY5320Import
  • JY5320_CIO_100kHz : JY5320Import
  • JY5320_CIO_100MHz : JY5320Import
  • JY5320_CIO_1_StartTrig : JY5320Import
  • JY5320_CIO_5MHz : JY5320Import
  • JY5320_CIO_Digital : JY5320Import
  • JY5320_CIO_Immediately : JY5320Import
  • JY5320_CIO_Soft : JY5320Import
  • JY5320_Clock_PFI_0 : JY5320Import
  • JY5320_Clock_PFI_1 : JY5320Import
  • JY5320_Clock_PFI_10 : JY5320Import
  • JY5320_Clock_PFI_11 : JY5320Import
  • JY5320_Clock_PFI_12 : JY5320Import
  • JY5320_Clock_PFI_13 : JY5320Import
  • JY5320_Clock_PFI_14 : JY5320Import
  • JY5320_Clock_PFI_15 : JY5320Import
  • JY5320_Clock_PFI_2 : JY5320Import
  • JY5320_Clock_PFI_3 : JY5320Import
  • JY5320_Clock_PFI_4 : JY5320Import
  • JY5320_Clock_PFI_5 : JY5320Import
  • JY5320_Clock_PFI_6 : JY5320Import
  • JY5320_Clock_PFI_7 : JY5320Import
  • JY5320_Clock_PFI_8 : JY5320Import
  • JY5320_Clock_PFI_9 : JY5320Import
  • JY5320_Clock_PXI_Trig_0 : JY5320Import
  • JY5320_Clock_PXI_Trig_1 : JY5320Import
  • JY5320_Clock_PXI_Trig_2 : JY5320Import
  • JY5320_Clock_PXI_Trig_3 : JY5320Import
  • JY5320_Clock_PXI_Trig_4 : JY5320Import
  • JY5320_Clock_PXI_Trig_5 : JY5320Import
  • JY5320_Clock_PXI_Trig_6 : JY5320Import
  • JY5320_Clock_PXI_Trig_7 : JY5320Import
  • JY5320_CO_0_Output : JY5320Import
  • JY5320_CO_1_Output : JY5320Import
  • JY5320_CO_ContinuousNoWrapping : JY5320Import
  • JY5320_CO_ContinuousWrapping : JY5320Import
  • JY5320_CO_Finite : JY5320Import
  • JY5320_CO_HighLevel : JY5320Import
  • JY5320_CO_LowLevel : JY5320Import
  • JY5320_CO_Single : JY5320Import
  • JY5320_DigitalTriggerEdge_Falling : JY5320Import
  • JY5320_DigitalTriggerEdge_Rising : JY5320Import
  • JY5320_DigitalTriggerSource_Inter_AI_ReferenceTrig : JY5320Import
  • JY5320_DigitalTriggerSource_Inter_AI_StartTrig : JY5320Import
  • JY5320_DigitalTriggerSource_Inter_CIO_0_StartTrig : JY5320Import
  • JY5320_DigitalTriggerSource_Inter_CIO_1_StartTrig : JY5320Import
  • JY5320_DigitalTriggerSource_Inter_Counter_0_Output : JY5320Import
  • JY5320_DigitalTriggerSource_Inter_Counter_1_Output : JY5320Import
  • JY5320_DigitalTriggerSource_PFI_0 : JY5320Import
  • JY5320_DigitalTriggerSource_PFI_1 : JY5320Import
  • JY5320_DigitalTriggerSource_PFI_10 : JY5320Import
  • JY5320_DigitalTriggerSource_PFI_11 : JY5320Import
  • JY5320_DigitalTriggerSource_PFI_12 : JY5320Import
  • JY5320_DigitalTriggerSource_PFI_13 : JY5320Import
  • JY5320_DigitalTriggerSource_PFI_14 : JY5320Import
  • JY5320_DigitalTriggerSource_PFI_15 : JY5320Import
  • JY5320_DigitalTriggerSource_PFI_2 : JY5320Import
  • JY5320_DigitalTriggerSource_PFI_3 : JY5320Import
  • JY5320_DigitalTriggerSource_PFI_4 : JY5320Import
  • JY5320_DigitalTriggerSource_PFI_5 : JY5320Import
  • JY5320_DigitalTriggerSource_PFI_6 : JY5320Import
  • JY5320_DigitalTriggerSource_PFI_7 : JY5320Import
  • JY5320_DigitalTriggerSource_PFI_8 : JY5320Import
  • JY5320_DigitalTriggerSource_PFI_9 : JY5320Import
  • JY5320_DigitalTriggerSource_PXI_0 : JY5320Import
  • JY5320_DigitalTriggerSource_PXI_1 : JY5320Import
  • JY5320_DigitalTriggerSource_PXI_2 : JY5320Import
  • JY5320_DigitalTriggerSource_PXI_3 : JY5320Import
  • JY5320_DigitalTriggerSource_PXI_4 : JY5320Import
  • JY5320_DigitalTriggerSource_PXI_5 : JY5320Import
  • JY5320_DigitalTriggerSource_PXI_6 : JY5320Import
  • JY5320_DigitalTriggerSource_PXI_7 : JY5320Import
  • JY5320_External_Timebase : JY5320Import
  • JY5320_FallingEdge : JY5320Import
  • JY5320_HighLevel : JY5320Import
  • JY5320_IN_AI_SampleClock : JY5320Import
  • JY5320_IN_CIO_100kHz : JY5320Import
  • JY5320_IN_CIO_100MHz : JY5320Import
  • JY5320_IN_CIO_5MHz : JY5320Import
  • JY5320_IN_CO_0_Output : JY5320Import
  • JY5320_IN_CO_1_Output : JY5320Import
  • JY5320_IN_PFI0 : JY5320Import
  • JY5320_IN_PFI1 : JY5320Import
  • JY5320_IN_PFI10 : JY5320Import
  • JY5320_IN_PFI11 : JY5320Import
  • JY5320_IN_PFI12 : JY5320Import
  • JY5320_IN_PFI13 : JY5320Import
  • JY5320_IN_PFI14 : JY5320Import
  • JY5320_IN_PFI15 : JY5320Import
  • JY5320_IN_PFI2 : JY5320Import
  • JY5320_IN_PFI3 : JY5320Import
  • JY5320_IN_PFI4 : JY5320Import
  • JY5320_IN_PFI5 : JY5320Import
  • JY5320_IN_PFI6 : JY5320Import
  • JY5320_IN_PFI7 : JY5320Import
  • JY5320_IN_PFI8 : JY5320Import
  • JY5320_IN_PFI9 : JY5320Import
  • JY5320_IN_PXI_Trig0 : JY5320Import
  • JY5320_IN_PXI_Trig1 : JY5320Import
  • JY5320_IN_PXI_Trig2 : JY5320Import
  • JY5320_IN_PXI_Trig3 : JY5320Import
  • JY5320_IN_PXI_Trig4 : JY5320Import
  • JY5320_IN_PXI_Trig5 : JY5320Import
  • JY5320_IN_PXI_Trig6 : JY5320Import
  • JY5320_IN_PXI_Trig7 : JY5320Import
  • JY5320_Independent : JY5320Import
  • JY5320_Inter_AI_SampleClock : JY5320Import
  • JY5320_Inter_CI_0_SampleClock : JY5320Import
  • JY5320_Inter_CI_1_SampleClock : JY5320Import
  • JY5320_Inter_CO_0_Output : JY5320Import
  • JY5320_Inter_CO_1_Output : JY5320Import
  • JY5320_Internal_Timebase_100K : JY5320Import
  • JY5320_Internal_Timebase_100M : JY5320Import
  • JY5320_Internal_Timebase_5M : JY5320Import
  • JY5320_LowLevel : JY5320Import
  • JY5320_MASTER : JY5320Import
  • JY5320_PFI0_OUT : JY5320Import
  • JY5320_PFI10_OUT : JY5320Import
  • JY5320_PFI11_OUT : JY5320Import
  • JY5320_PFI12_OUT : JY5320Import
  • JY5320_PFI13_OUT : JY5320Import
  • JY5320_PFI14_OUT : JY5320Import
  • JY5320_PFI15_OUT : JY5320Import
  • JY5320_PFI1_OUT : JY5320Import
  • JY5320_PFI2_OUT : JY5320Import
  • JY5320_PFI3_OUT : JY5320Import
  • JY5320_PFI4_OUT : JY5320Import
  • JY5320_PFI5_OUT : JY5320Import
  • JY5320_PFI6_OUT : JY5320Import
  • JY5320_PFI7_OUT : JY5320Import
  • JY5320_PFI8_OUT : JY5320Import
  • JY5320_PFI9_OUT : JY5320Import
  • JY5320_PXITrig0_OUT : JY5320Import
  • JY5320_PXITrig1_OUT : JY5320Import
  • JY5320_PXITrig2_OUT : JY5320Import
  • JY5320_PXITrig3_OUT : JY5320Import
  • JY5320_PXITrig4_OUT : JY5320Import
  • JY5320_PXITrig5_OUT : JY5320Import
  • JY5320_PXITrig6_OUT : JY5320Import
  • JY5320_PXITrig7_OUT : JY5320Import
  • JY5320_ReferenceTrigger : JY5320Import
  • JY5320_RisingEdge : JY5320Import
  • JY5320_Signal_PFI_0 : JY5320Import
  • JY5320_Signal_PFI_1 : JY5320Import
  • JY5320_Signal_PFI_10 : JY5320Import
  • JY5320_Signal_PFI_11 : JY5320Import
  • JY5320_Signal_PFI_12 : JY5320Import
  • JY5320_Signal_PFI_14 : JY5320Import
  • JY5320_Signal_PFI_15 : JY5320Import
  • JY5320_Signal_PFI_2 : JY5320Import
  • JY5320_Signal_PFI_3 : JY5320Import
  • JY5320_Signal_PFI_4 : JY5320Import
  • JY5320_Signal_PFI_5 : JY5320Import
  • JY5320_Signal_PFI_6 : JY5320Import
  • JY5320_Signal_PFI_7 : JY5320Import
  • JY5320_Signal_PFI_8 : JY5320Import
  • JY5320_Signal_PFI_9 : JY5320Import
  • JY5320_Signal_PXI_Trig_0 : JY5320Import
  • JY5320_Signal_PXI_Trig_1 : JY5320Import
  • JY5320_Signal_PXI_Trig_2 : JY5320Import
  • JY5320_Signal_PXI_Trig_3 : JY5320Import
  • JY5320_Signal_PXI_Trig_4 : JY5320Import
  • JY5320_Signal_PXI_Trig_5 : JY5320Import
  • JY5320_Signal_PXI_Trig_6 : JY5320Import
  • JY5320_Signal_PXI_Trig_7 : JY5320Import
  • JY5320_SLAVE : JY5320Import
  • JY5320_StartTrigger : JY5320Import
  • JY5320_TriggerType_Analog : JY5320Import
  • JY5320_TriggerType_Digital : JY5320Import
  • JY5320_TriggerType_Immediately : JY5320Import
  • JY5320_TriggerType_Soft : JY5320Import


5320 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
  • a
  • j
  • o
  • r
Here is a list of all namespace variables with links to the namespace documentation for each variable:

- o -

  • Or : JY5320Import


5320 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
  • a
  • j
  • o
  • r
Here is a list of all namespace variables with links to the namespace documentation for each variable:

- r -

  • ReferenceOnboard_25M : JY5320Import
  • ReferencePXIeCLK_100M : JY5320Import


5320 C++ Programming Manual: Namespace List

  • Namespace List
  • Namespace Members
Namespace List
Here is a list of all namespaces with brief descriptions:
N JY5320CoreOO
N JY5320Import