5325 C++ Programming Manual: D:/5325/C++/JY5325.h File Reference

5325 C++ Programming Manual
  • Main Page
  • Files
  • File List
  • File Members
  • 5325
  • C++
Typedefs | Enumerations | Functions
JY5325.h File Reference

@SectionBegin JY5325FileHead More...

Typedefs

typedef void * JY5325_DeviceHandle
Windows.

Enumerations

enum | JY5325_AI_SampleMode { JY5325_AI_Finite = 0x0 , JY5325_AI_Continuous = 0x1 }
enum | JY5325_AO_UpdateMode { JY5325_AO_Finite = 0x0 , JY5325_AO_ContinuousWrapping = 0x1 , JY5325_AO_ContinuousNoWrapping = 0x2 , JY5325_AO_Single = 0x3 }
enum | JY5325_AI_TriggerType { JY5325_AI_Immediately = 0x0 , JY5325_AI_Digital = 0x1 , JY5325_AI_Analog = 0x2 , JY5325_AI_Soft = 0x3 }
enum | JY5325_AO_TriggerType { JY5325_AO_Immediately = 0x0 , JY5325_AO_Digital = 0x1 , JY5325_AO_Soft = 0x3 }
enum | JY5325_TriggerMode { JY5325_StartTrigger = 0x0 , JY5325_ReferenceTrigger = 0x1 }
enum | JY5325_DigitalTriggerEdge { JY5325_Rising = 0x0 , JY5325_Falling = 0x1 }
enum JY5325_DigitalTriggerSource {
JY5325_PFI0 = 0 , JY5325_PFI1 = 1 , JY5325_PFI2 = 2 , JY5325_PFI3 = 3 ,
JY5325_PFI4 = 4 , JY5325_PFI5 = 5 , JY5325_PFI6 = 6 , JY5325_PFI7 = 7 ,
JY5325_PXI_Trig0 = 8 , JY5325_PXI_Trig1 = 9 , JY5325_PXI_Trig2 = 10 , JY5325_PXI_Trig3 = 11 ,
JY5325_PXI_Trig4 = 12 , JY5325_PXI_Trig5 = 13 , JY5325_PXI_Trig6 = 14 , JY5325_PXI_Trig7 = 15 ,
JY5325_Inter_AI_StartTrig = 16 , JY5325_Inter_AI_ReferenceTrig = 17 , JY5325_Inter_AO_StartTrig = 18 , JY5325_Inter_DI_StartTrig = 19 ,
JY5325_Inter_DI_ReferenceTrig =20 , JY5325_Inter_DO_StartTrig = 21 , JY5325_Inter_Counter_0_StartTrig = 22 , JY5325_Inter_Counter_1_StartTrig = 23 ,
JY5325_Inter_Counter_0_Out = 24 , JY5325_Inter_Counter_1_Out = 25
}
enum JY5325_AnalogTriggerSource {
JY5325_Channel_0 = 0 , JY5325_Channel_1 = 1 , JY5325_Channel_2 = 2 , JY5325_Channel_3 = 3 ,
JY5325_Channel_4 = 4 , JY5325_Channel_5 = 5 , JY5325_Channel_6 = 6 , JY5325_Channel_7 = 7
}
enum | JY5325_AnalogWindowCondition { JY5325_Entering = 0x0 , JY5325_Leaving = 0x1 }
enum | JY5325_AnalogTriggerEdge { JY5325_RisingSlope = 0x0 , JY5325_FallingSlope = 0x1 }
enum JY5325_ExternalClockTerminal {
JY5325_Clock_PFI_0 = 0 , JY5325_Clock_PFI_1 = 1 , JY5325_Clock_PFI_2 = 2 , JY5325_Clock_PFI_3 = 3 ,
JY5325_Clock_PFI_4 = 4 , JY5325_Clock_PFI_5 = 5 , JY5325_Clock_PFI_6 = 6 , JY5325_Clock_PFI_7 = 7 ,
JY5325_Clock_PXI_Trig_0 = 8 , JY5325_Clock_PXI_Trig_1 = 9 , JY5325_Clock_PXI_Trig_2 = 10 , JY5325_Clock_PXI_Trig_3 = 11 ,
JY5325_Clock_PXI_Trig_4 = 12 , JY5325_Clock_PXI_Trig_5 = 13 , JY5325_Clock_PXI_Trig_6 = 14 , JY5325_Clock_PXI_Trig_7 = 15 ,
JY5325_Inter_Clock_DI_SampleClock = 16 , JY5325_Inter_Clock_DO_SampleClock = 17 , JY5325_Inter_CI_0_SampleClock = 18 , JY5325_Inter_CI_1_SampleClock = 19 ,
JY5325_Inter_CO_0_Output = 20 , JY5325_Inter_CO_1_Output = 21
}
enum | JY5325_DeviceProperty { JY5325_Independent = 0 , JY5325_MASTER = 1 , JY5325_SLAVE = 3 }
enum JY5325_Signal_Source {
JY5325_Signal_PFI0 = 0 , JY5325_Signal_PFI1 = 1 , JY5325_Signal_PFI2 = 2 , JY5325_Signal_PFI3 = 3 ,
JY5325_Signal_PFI4 = 4 , JY5325_Signal_PFI5 = 5 , JY5325_Signal_PFI6 = 6 , JY5325_Signal_PFI7 = 7 ,
JY5325_Signal_PXI_Trig0 = 8 , JY5325_Signal_PXI_Trig1 = 9 , JY5325_Signal_PXI_Trig2 = 10 , JY5325_Signal_PXI_Trig3 = 11 ,
JY5325_Signal_PXI_Trig4 = 12 , JY5325_Signal_PXI_Trig5 = 13 , JY5325_Signal_PXI_Trig6 = 14 , JY5325_Signal_PXI_Trig7 = 15 ,
JY5325_Signal_AI_StartTrig =16 , JY5325_Signal_AI_ReferenceTrig =17 , JY5325_Signal_AO_StartTrig = 18 , JY5325_Signal_DI_StartTrig = 19 ,
JY5325_Signal_DI_ReferenceTrig = 20 , JY5325_Signal_DI_SampleClock = 21 , JY5325_Signal_DO_StartTrig = 22 , JY5325_Signal_DO_SampleClock = 23 ,
JY5325_Signal_CI_0_SampleClock = 24 , JY5325_Signal_CI_1_SampleClock = 25 , JY5325_Signal_CO_0_Output = 26 , JY5325_Signal_CO_1_Output = 27 ,
JY5325_Signal_Counter_0_StartTrig = 28 , JY5325_Signal_Counter_1_StartTrig = 29 , JY5325_Signal_CIO_100MHz = 30 , JY5325_Signal_CIO_5MHz = 31 ,
JY5325_Signal_CIO_100kHz = 32
}
enum JY5325_Signal_Destination {
JY5325_PFI0_OUT = 0 , JY5325_PFI1_OUT = 1 , JY5325_PFI2_OUT = 2 , JY5325_PFI3_OUT = 3 ,
JY5325_PFI4_OUT = 4 , JY5325_PFI5_OUT = 5 , JY5325_PFI6_OUT = 6 , JY5325_PFI7_OUT = 7 ,
JY5325_PXITrig0_OUT = 8 , JY5325_PXITrig1_OUT = 9 , JY5325_PXITrig2_OUT = 10 , JY5325_PXITrig3_OUT = 11 ,
JY5325_PXITrig4_OUT = 12 , JY5325_PXITrig5_OUT = 13 , JY5325_PXITrig6_OUT = 14 , JY5325_PXITrig7_OUT = 15 ,
JY5325_None = 16
}
enum | JY5325_ReferenceClock { JY5325_Internal = 0 , JY5325_PXIe_Clk100 = 1 }
enum | JY5325_ClockSource { JY5325_InternalClock = 0x0 , JY5325_ExternalClock = 0x1 }
enum | JY5325_DI_SampleMode { JY5325_DI_Finite = 0x0 , JY5325_DI_Continuous = 0x1 , JY5325_DI_Single = 0x2 }
enum | JY5325_DI_TriggerType { JY5325_DI_Immediately = 0x0 , JY5325_DI_Digital = 0x1 , JY5325_DI_Soft = 0x3 }
enum | JY5325_DO_TriggerType { JY5325_DO_Immediately = 0x0 , JY5325_DO_Digital = 0x1 , JY5325_DO_Soft = 0x3 }
enum | JY5325_DO_UpdateMode { JY5325_DO_Finite = 0x0 , JY5325_DO_ContinuousWrapping = 0x1 , JY5325_DO_ContinuousNoWrapping = 0x2 , JY5325_DO_Single = 0x3 }
enum | JY5325_OutputCompleteState { JY5325_Zero = 0x0 , JY5325_Hold = 0x1 }
enum | JY5325_CI_SampleMode { JY5325_CI_Finite = 0x0 , JY5325_CI_Continuous = 0x1 , JY5325_CI_Single = 0x2 }
enum JY5325_CI_MeasureType {
JY5325_CI_EdgeCount = 0 , JY5325_CI_Measure_FrequencyOrPeriod = 1 , JY5325_CI_Measure_PulseWidth = 2 , JY5325_CI_Measure_SemiPeriod = 3 ,
JY5325_CI_Measure_EdgeSeparation = 4 , JY5325_CI_EncoderX1 = 5 , JY5325_CI_EncoderX2 = 6 , JY5325_CI_EncoderX4 = 7 ,
JY5325_CI_EncoderTwoPulse = 8
}
enum | JY5325_CountDirection { JY5325_CI_Count_Up , JY5325_CI_Count_Down , JY5325_CI_Count_External }
enum | JY5325_CI_SampleClock { JY5325_CI_ImplicitClock , JY5325_CI_InternalClock , JY5325_CI_ExternalClock }
enum | JY5325_CI_CounterEventSignalIdleState { JY5325_CI_CounterEventSignalIdleState_Low = 0 , JY5325_CI_CounterEventSignalIdleState_High = 1 }
enum | JY5325_CI_ValueReturnMode { JY5325_CI_ReturnTwoValue = 0 , JY5325_CI_ReturnOneValue = 1 }
enum | JY5325_LevelState { JY5325_LowLevel = 0 , JY5325_HighLevel = 1 }
enum | JY5325_CI_StartingEdge { JY5325_RisingEdge = 0 , JY5325_FallingEdge = 1 , JY5325_AnyEdge = 2 }
enum JY5325_InputTerminal {
JY5325_PFI0_Input = 0 , JY5325_PFI1_Input = 1 , JY5325_PFI2_Input = 2 , JY5325_PFI3_Input = 3 ,
JY5325_PFI4_Input = 4 , JY5325_PFI5_Input = 5 , JY5325_PFI6_Input = 6 , JY5325_PFI7_Input = 7 ,
JY5325_PXI_Trig0_Input = 8 , JY5325_PXI_Trig1_Input = 9 , JY5325_PXI_Trig2_Input = 10 , JY5325_PXI_Trig3_Input = 11 ,
JY5325_PXI_Trig4_Input = 12 , JY5325_PXI_Trig5_Input = 13 , JY5325_PXI_Trig6_Input = 14 , JY5325_PXI_Trig7_Input = 15 ,
JY5325_IN_AI_SampleClock = 16 , JY5325_IN_AO_SampleClock = 17 , JY5325_IN_DI_SampleClock = 18 , JY5325_IN_DO_SampleClock = 19 ,
JY5325_IN_CO_0_Output = 20 , JY5325_IN_CO_1_Output = 21 , JY5325_IN_CIO_100MHz = 22 , JY5325_IN_CIO_5MHz = 23 ,
JY5325_IN_CIO_100kHz = 24
}
enum | JY5325_CO_OutMode { JY5325_CO_Finite = 0x0 , JY5325_CO_ContinuousWrapping = 0x1 , JY5325_CO_ContinuousNoWrapping = 0x2 , JY5325_CO_Single = 0x3 }
enum | JY5325_CO_IdleState { JY5325_CO_LowLevel = 0 , JY5325_CO_HighLevel = 1 }
enum | JY5325_CountTimeBase { JY5325_Internal_Timebase_100M = 0x0 , JY5325_Internal_Timebase_5M = 0x1 , JY5325_Internal_Timebase_100K = 0x2 , JY5325_External_Timebase = 0x3 }
enum | JY5325_CIO_TriggerType { JY5325_CIO_Immediately = 0x0 , JY5325_CIO_Digital = 0x1 , JY5325_CIO_Soft = 0x3 }

Functions

JY5325API int STDCALL | JY5325_Open (int slotNumber, JY5325_DeviceHandle *hDevice)
Open the 5611 series boards using the slot number or the board serial number.
JY5325API int STDCALL | JY5325_OpenByAliasName (const char *aliasName, JY5325_DeviceHandle *hDevice)
Open this 5611 series boards using the board alias name which is set by JYTEK utility JYDM.
JY5325API int STDCALL | JY5325_Close (JY5325_DeviceHandle hDevice)
Close this 5611 board.
JY5325API int STDCALL | JY5325_GetDeviceID (JY5325_DeviceHandle hDevice, int *deviceID)
Obtain the board ID.
JY5325API int STDCALL | JY5325_GetDeviceSerialNumber (JY5325_DeviceHandle hDevice, char *serialNumber, int length)
Obtain the device serialNumber.
JY5325API int STDCALL | JY5325_SetDeviceProperty (JY5325_DeviceHandle hDevice, JY5325_DeviceProperty devicePrepety)
Set Device Property,this API must be used in Sync function.
JY5325API int STDCALL | JY5325_SetDeviceReferenceClock (JY5325_DeviceHandle hDevice, JY5325_ReferenceClock clockSource)
Set Reference Clock for the device.There are two ReferenceClock, 25MHz from this device or 100MHz from the PXIe chassis.
JY5325API int STDCALL | JY5325_SignalRouting (JY5325_DeviceHandle hDevice, JY5325_Signal_Source sourceSignal, JY5325_Signal_Destination distination)
Route a singal from source to destination.
JY5325API int STDCALL | JY5325_DisconnectSignalRouting (JY5325_DeviceHandle hDevice, JY5325_Signal_Destination destination)
Disconnect an established routing.
JY5325API int STDCALL | JY5325_SetDeviceStatusLed (JY5325_DeviceHandle hDevice, bool enable, unsigned int frequency)
Control Front Panel Status Led.
JY5325API int STDCALL | JY5325_AI_EnableChannel (JY5325_DeviceHandle hDevice, unsigned int channelCount, unsigned char *channels, double *lowRegion, double *highRegion)
Enable AI channels.
JY5325API int STDCALL | JY5325_AI_SetMode (JY5325_DeviceHandle hDevice, JY5325_AI_SampleMode mode)
Set AI sampling mode.
JY5325API int STDCALL | JY5325_AI_SetSampleRate (JY5325_DeviceHandle hDevice, double sampleRate, double *actualSampleRate)
Set sampling rate.
JY5325API int STDCALL | JY5325_AI_SetSamplesToAcquire (JY5325_DeviceHandle hDevice, unsigned int sampleToAcquire)
Set AI samples to acquire for each channel in finite mode.The samples range is 1 to 256M samples / channelCount.
JY5325API int STDCALL | JY5325_AI_Start (JY5325_DeviceHandle hDevice)
Start AI acquisition.
JY5325API int STDCALL | JY5325_AI_ReadData (JY5325_DeviceHandle hDevice, double *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
Read AI data to user defined data buffer.
JY5325API int STDCALL | JY5325_AI_Stop (JY5325_DeviceHandle hDevice)
Stop AI acquisition.
JY5325API int STDCALL | JY5325_AI_ReadRawData (JY5325_DeviceHandle hDevice, short *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
Read AI raw data to user defined data buffer.
JY5325API int STDCALL | JY5325_AI_SetSampleClock (JY5325_DeviceHandle hDevice, JY5325_ClockSource clockSource, JY5325_ExternalClockTerminal terminal, double expectedRate)
Set AI sampling clock.
JY5325API int STDCALL | JY5325_AI_SetStartTriggerType (JY5325_DeviceHandle hDevice, JY5325_AI_TriggerType triggerType)
Set AI start trigger type,the triggerType is defined by enum JY5325_AI_TriggerType.
JY5325API int STDCALL | JY5325_AI_SetDigitalStartTrigger (JY5325_DeviceHandle hDevice, JY5325_DigitalTriggerSource triggerSource, JY5325_DigitalTriggerEdge triggerEdge)
Set AI digital start trigger,the triggerSource is defined by enum JY5325_DigitalTriggerSource, the triggerEdge is defined by enum JY5325_DigitalTriggerEdge.
JY5325API int STDCALL | JY5325_AI_SetAnalogWindowStartTrigger (JY5325_DeviceHandle hDevice, JY5325_AnalogTriggerSource triggerSource, JY5325_AnalogWindowCondition triggerCondition, double highThreshold, double lowThreshold)
Set AI analog window start trigger,the triggerSource is defined by enum JY5325_AnalogTriggerSource, the triggerCondition is defined by enum JY5325_AnalogWindowCondition.
JY5325API int STDCALL | JY5325_AI_SetAnalogHysteresisStartTrigger (JY5325_DeviceHandle hDevice, JY5325_AnalogTriggerSource triggerSource, JY5325_AnalogTriggerEdge triggerEdge, double highThreshold, double lowThreshold)
Set AI analog hysteresis start trigger,the triggerSource is defined by enum JY5325_AnalogTriggerSource, the triggerEdge is defined by enum JY5325_AnalogTriggerEdge.
JY5325API int STDCALL | JY5325_AI_SetAnalogEdgeStartTrigger (JY5325_DeviceHandle hDevice, JY5325_AnalogTriggerSource triggerSource, JY5325_AnalogTriggerEdge triggerEdge, double threshold)
Set AI analog edge start trigger,the triggerSource is defined by enum JY5325_AnalogTriggerSource, the triggerEdge is defined by enum JY5325_AnalogTriggerEdge.
JY5325API int STDCALL | JY5325_AI_SetReferenceTriggerType (JY5325_DeviceHandle hDevice, JY5325_AI_TriggerType triggerType)
Set AI reference trigger type,the triggerType is defined by enum JY5325_AI_TriggerType.
JY5325API int STDCALL | JY5325_AI_SetDigitalReferenceTrigger (JY5325_DeviceHandle hDevice, JY5325_DigitalTriggerSource triggerSource, JY5325_DigitalTriggerEdge triggerEdge)
Set AI digital reference trigger.the triggerSource is defined by enum JY5325_DigitalTriggerSource, the triggerEdge is defined by enum JY5325_DigitalTriggerEdge.
JY5325API int STDCALL | JY5325_AI_SetAnalogWindowReferenceTrigger (JY5325_DeviceHandle hDevice, JY5325_AnalogTriggerSource triggerSource, JY5325_AnalogWindowCondition triggerCondition, double highThreshold, double lowThreshold)
Set AI analog window reference trigger,the triggerSource is defined by enum JY5325_AnalogTriggerSource, the triggerCondition is defined by enum JY5325_AnalogTriggerCondition.
JY5325API int STDCALL | JY5325_AI_SetAnalogHysteresisReferenceTrigger (JY5325_DeviceHandle hDevice, JY5325_AnalogTriggerSource triggerSource, JY5325_AnalogTriggerEdge triggerEdge, double highThreshold, double lowThreshold)
Set AI analog hysteresis reference trigger,the triggerSource is defined by enum JY5325_AnalogTriggerSource, the triggerEdge is defined by enum JY5325_AnalogTriggerEdge.
JY5325API int STDCALL | JY5325_AI_SetAnalogEdgeReferenceTrigger (JY5325_DeviceHandle hDevice, JY5325_AnalogTriggerSource triggerSource, JY5325_AnalogTriggerEdge triggerEdge, double threshold)
Set AI analog edge reference trigger,the triggerSource is defined by enum JY5325_AnalogTriggerSource, the triggerEdge is defined by enum JY5325_AnalogTriggerEdge.
JY5325API int STDCALL | JY5325_AI_SetPreTriggerSamples (JY5325_DeviceHandle hDevice, unsigned int preTriggerSamples)
Set AI pretrigger samples, the samples must greater than 0.
JY5325API int STDCALL | JY5325_AI_SetReTriggerCount (JY5325_DeviceHandle hDevice, unsigned long long reTriggerCount)
Set AI retrigger count.
JY5325API int STDCALL | JY5325_AI_SendSoftTrigger (JY5325_DeviceHandle hDevice, JY5325_TriggerMode triggerMode)
Send the software trigger signal for AI.
JY5325API int STDCALL | JY5325_AI_WaitUntilDone (JY5325_DeviceHandle hDevice, bool *done)
Check if AI acquisition is completed in finite mode.
JY5325API int STDCALL | JY5325_AI_CheckBufferStatus (JY5325_DeviceHandle hDevice, unsigned long long *avaliableSamples, unsigned long long *transferedSamples, bool *overrun)
Check AI device buffer status.
JY5325API int STDCALL | JY5325_DI_AddLines (JY5325_DeviceHandle hDevice, unsigned int *line, unsigned int lineCount)
Enabled DI channels.
JY5325API int STDCALL | JY5325_DI_SetMode (JY5325_DeviceHandle hDevice, JY5325_DI_SampleMode mode)
Set DI sampling mode.The mode defined by enum JY5325_DI_SampleMode.
JY5325API int | JY5325_DI_SetSamplesToAcquire (JY5325_DeviceHandle hDevice, int samplesToAcquire)
Set DI samples to acquire for each channel in finite mode.The samples range is 1 to 16M samples.
JY5325API int STDCALL | JY5325_DI_CheckBufferStatus (JY5325_DeviceHandle hDevice, unsigned long long *avaliableSamples, unsigned long long *transferedSamples, bool *overrun)
Check DI device buffer status.
JY5325API int STDCALL | JY5325_DI_SetStartTriggerType (JY5325_DeviceHandle hDevice, JY5325_DI_TriggerType triggerType)
Set DI start trigger type,the triggerType is defined by enum JY5325_DI_TriggerType.
JY5325API int STDCALL | JY5325_DI_SetDigitalStartTrigger (JY5325_DeviceHandle hDevice, JY5325_DigitalTriggerSource triggerSource, JY5325_DigitalTriggerEdge triggerEdge)
Set DI digital start trigger,the triggerSource is defined by enum JY5325_DigitalTriggerSource, the triggerEdge is defined by enum JY5325_DigitalTriggerEdge.
JY5325API int STDCALL | JY5325_DI_SetReferenceTriggerType (JY5325_DeviceHandle hDevice, JY5325_DI_TriggerType triggerType)
Set DI reference trigger type,the triggerType is defined by enum JY5325_DI_TriggerType.
JY5325API int STDCALL | JY5325_DI_SetDigitalReferenceTrigger (JY5325_DeviceHandle hDevice, JY5325_DigitalTriggerSource triggerSource, JY5325_DigitalTriggerEdge triggerEdge)
Set AI digital reference trigger,the triggerSource is defined by enum JY5325_DigitalTriggerSource, the triggerEdge is defined by enum JY5325_DigitalTriggerEdge.
JY5325API int STDCALL | JY5325_DI_SetPreTriggerSamples (JY5325_DeviceHandle hDevice, unsigned int preTriggerSamples)
Set DI pretrigger samples, the samples must greater than 0.
JY5325API int STDCALL | JY5325_DI_SendSoftTrigger (JY5325_DeviceHandle hDevice, JY5325_TriggerMode triggerMode)
Send the software trigger signal.
JY5325API int STDCALL | JY5325_DI_SetSampleClock (JY5325_DeviceHandle hDevice, JY5325_ClockSource clockSource, JY5325_ExternalClockTerminal terminal, double expectedRate)
Set DI sampling clock source.
JY5325API int STDCALL | JY5325_DI_SetSampleRate (JY5325_DeviceHandle hDevice, double sampleRate, double *actualSampleRate)
Set DI sampling rate.
JY5325API int STDCALL | JY5325_DI_WaitUntilDone (JY5325_DeviceHandle hDevice, bool *done)
Check if DI acquisition is completed in finite mode.
JY5325API int STDCALL | JY5325_DI_ReadSinglePoint_U8 (JY5325_DeviceHandle hDevice, unsigned char *readValue)
Read DI single point.The data type is uchar.
JY5325API int STDCALL | JY5325_DI_ReadSinglePoint (JY5325_DeviceHandle hDevice, bool *readValues, int lineID)
Read DI single point.The data type is bool.
JY5325API int STDCALL | JY5325_DI_ReadData (JY5325_DeviceHandle hDevice, unsigned char *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
Read DI data.
JY5325API int STDCALL | JY5325_DI_Start (JY5325_DeviceHandle hDevice)
Start DI acquisition.
JY5325API int STDCALL | JY5325_DI_Stop (JY5325_DeviceHandle hDevice)
Stop DI acquisition.
JY5325API int STDCALL | JY5325_DO_AddLines (JY5325_DeviceHandle hDevice, unsigned int *line, unsigned int lineCount)
Enabled DO channels.
JY5325API int STDCALL | JY5325_DO_WriteSinglePoint_U8 (JY5325_DeviceHandle hDevice, unsigned char writeValue)
Write DO single point.The data type is uchar.
JY5325API int STDCALL | JY5325_DO_WriteSinglePoint (JY5325_DeviceHandle hDevice, bool *writeValues, int lineID)
Write DO single point.The data type is bool.
JY5325API int STDCALL | JY5325_DO_Start (JY5325_DeviceHandle hDevice)
Start digital signal output.
JY5325API int STDCALL | JY5325_DO_Stop (JY5325_DeviceHandle hDevice)
Stop digital signal output.
JY5325API int STDCALL | JY5325_DO_WriteData (JY5325_DeviceHandle hDevice, unsigned char *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualWriteLength)
DO write data.The data type is uchar.
JY5325API int STDCALL | JY5325_DO_SetUpdateRate (JY5325_DeviceHandle hDevice, double sampleRate, double *actualSampleRate)
Set DO update rate.The update rate is the same for all channels.
JY5325API int STDCALL | JY5325_DO_SetMode (JY5325_DeviceHandle hDevice, JY5325_DO_UpdateMode mode)
Set digital signal output mode, the mode defined by enum JY5325_AO_UpdateMode.
JY5325API int STDCALL | JY5325_DO_SetSampleClock (JY5325_DeviceHandle hDevice, JY5325_ClockSource clockSource, JY5325_ExternalClockTerminal terminal, double expectedRate)
Set DO sampling clock source.
JY5325API int | JY5325_DO_SetSamplesToUpdate (JY5325_DeviceHandle hDevice, int samplesToUpdate)
Set digital signal output samples for each channel in finite mode.The samples range is 1 to 64M samples.
JY5325API int STDCALL | JY5325_DO_WaitUntilDone (JY5325_DeviceHandle hDevice, bool *done, int timeOut)
Check finite digital signal output is complete.
JY5325API int STDCALL | JY5325_DisableAICalibration (JY5325_DeviceHandle hDevice, bool DisableCalibration)
Disable AI calibration coefficient, default false.
JY5325API int STDCALL | JY5325_DI_CheckBufferStatusEx (JY5325_DeviceHandle hDevice, unsigned long long *avaliableSamples, unsigned long long *transferedSamples, bool *overrun)
Check DI device buffer status.
JY5325API int STDCALL | JY5325_DO_CheckBufferStatus (JY5325_DeviceHandle hDevice, unsigned long *avaliableSamples, unsigned long long *transferedSamples, bool *overrun)
Check DO device buffer status.
JY5325API int STDCALL | JY5325_DO_SetDigitalStartTrigger (JY5325_DeviceHandle hDevice, JY5325_DigitalTriggerSource triggerSource, JY5325_DigitalTriggerEdge triggerEdge)
Set DO digital start trigger,the triggerSource is defined by enum JY5325_DigitalTriggerSource, the triggerEdge is defined by enum JY5325_DigitalTriggerEdge.
JY5325API int STDCALL | JY5325_DO_SetStartTriggerType (JY5325_DeviceHandle hDevice, JY5325_DO_TriggerType triggerType)
Set DO start trigger type,the triggerType is defined by enum JY5325_DO_TriggerType.
JY5325API int STDCALL | JY5325_DO_SendSoftTrigger (JY5325_DeviceHandle hDevice)
Send the software trigger signal.
JY5325API int STDCALL | JY5325_AO_EnableChannel (JY5325_DeviceHandle hDevice, unsigned int channelCount, unsigned char *channels, double *lowRegion, double *highRegion)
Enables AO channels.
JY5325API int STDCALL | JY5325_AO_SetUpdateRate (JY5325_DeviceHandle hDevice, double updateRate, double *actualUpdateRate)
Set AO update rate for each channel.
JY5325API int STDCALL | JY5325_AO_SetMode (JY5325_DeviceHandle hDevice, JY5325_AO_UpdateMode mode)
Set digital signal output mode, the mode defined by enum JY5325_AO_UpdateMode.
JY5325API int STDCALL | JY5325_AO_SetSamplesToUpdate (JY5325_DeviceHandle hDevice, unsigned int sampleToUpdate)
Set digital signal output samples for each channel in the finite mode.The sample range is from 1 to 256M / channelCount.
JY5325API int STDCALL | JY5325_AO_Start (JY5325_DeviceHandle hDevice)
Start digital signal output.
JY5325API int STDCALL | JY5325_AO_WriteRawData (JY5325_DeviceHandle hDevice, short *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualWriteLength)
AO write raw data.The data is interleaved in the buffer in channel order for multi-channel.
JY5325API int STDCALL | JY5325_AO_WriteData (JY5325_DeviceHandle hDevice, double *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualWriteLength)
AO writes data.The data is interleaved in the buffer the order defined by JY5325_AO_EnableChannel.
JY5325API int STDCALL | JY5325_AO_Stop (JY5325_DeviceHandle hDevice)
Stop digital signal output.
JY5325API int STDCALL | JY5325_AO_SetSampleClock (JY5325_DeviceHandle hDevice, JY5325_ClockSource clockSource, JY5325_ExternalClockTerminal terminal, double expectedRate)
Set AO sampling clock.
JY5325API int STDCALL | JY5325_AO_WriteRawSinglePoint (JY5325_DeviceHandle hDevice, short *writeValues, int channelID)
AO write single point data to the defined channel by channelID, if channelID == -1, write all enable channel.
JY5325API int STDCALL | JY5325_AO_WriteSinglePoint (JY5325_DeviceHandle hDevice, double *writeValues, int channelID)
AO write single point data to the defined channel by channelID, if channelID == -1, write all enable channel.
JY5325API int STDCALL | JY5325_AO_SetStartTriggerType (JY5325_DeviceHandle hDevice, JY5325_AO_TriggerType triggerTyp)
Set AO start trigger type,the triggerType is defined by enum JY5325_AO_TriggerType.
JY5325API int STDCALL | JY5325_AO_SetDigitalStartTrigger (JY5325_DeviceHandle hDevice, JY5325_DigitalTriggerSource triggerSource, JY5325_DigitalTriggerEdge triggerEdge)
Set AO digital start trigger,the triggerSource is defined by enum JY5325_DigitalTriggerSource, the triggerEdge is defined by enum JY5325_DigitalTriggerEdge.
JY5325API int STDCALL | JY5325_AO_WaitUntilDone (JY5325_DeviceHandle hDevice, bool *done, int timeOut)
Check finite analog signal output is complete.
JY5325API int STDCALL | JY5325_AO_CheckBufferStatus (JY5325_DeviceHandle hDevice, unsigned long *availableSamples, unsigned long long *transferedSamples, bool *overrun)
Check AO device buffer status.
JY5325API int STDCALL | JY5325_AO_SendSoftTrigger (JY5325_DeviceHandle hDevice)
Send the software trigger signal.
JY5325API int STDCALL | JY5325_AO_SetOutputCompleteState (JY5325_DeviceHandle hDevice, JY5325_OutputCompleteState State)
Set AO Output complete state, only in Finite/ ContinuousWrapping/ ContinuousNoWrapping Mode,Default is Zero.
JY5325API int STDCALL | JY5325_DisableAOCalibration (JY5325_DeviceHandle hDevice, bool DisableCalibration)
Disable AO calibration coefficient, default enable calibration coefficient.
JY5325API int STDCALL | JY5325_CI_EnableChannel (JY5325_DeviceHandle hDevice, unsigned int channel)
Enables CI channel.There are 2 counter,from 0 and 1.
JY5325API int STDCALL | JY5325_CI_SetCounterType (JY5325_DeviceHandle hDevice, unsigned int channel, JY5325_CI_MeasureType measureType)
Set CI measure type.
JY5325API int STDCALL | JY5325_CI_SetSignalReverse (JY5325_DeviceHandle hDevice, unsigned int channel, int signalReverse)
Set the Signal Reverse terminal.
JY5325API int STDCALL | JY5325_CI_SetCounterParament (JY5325_DeviceHandle hDevice, unsigned int channel, int initCount, JY5325_CountDirection countDirection)
Set CI count parameter.
JY5325API int STDCALL | JY5325_CI_SetZReloadEnabled (JY5325_DeviceHandle hDevice, unsigned int channel, bool zReloadEnabled)
Set the Z signal enable in Encoder mode.
JY5325API int STDCALL | JY5325_CI_SetMode (JY5325_DeviceHandle hDevice, unsigned int channel, JY5325_CI_SampleMode mode)
Set counter input mode, the mode is defined by enum JY5325_CI_SampleMode.
JY5325API int STDCALL | JY5325_CI_SetSampleClock (JY5325_DeviceHandle hDevice, unsigned int channel, JY5325_CI_SampleClock clock, JY5325_ExternalClockTerminal terminal, double rate)
Set counter input sampling clock source.
JY5325API int STDCALL | JY5325_CI_SetSamplesToAcquire (JY5325_DeviceHandle hDevice, unsigned int channel, unsigned int samplesToAcquire)
Set samples to acquire in finite mode.The samples range is 1 to 4M.
JY5325API int STDCALL | JY5325_CI_SetEdgeCountEvent (JY5325_DeviceHandle hDevice, unsigned int channel, JY5325_CI_CounterEventSignalIdleState idleState, unsigned int threshold)
Set the counter threshold, and when the count reaches this threshold, output a single pulse at the output terminal.
JY5325API int STDCALL | JY5325_CI_SetPauseTriggerLevel (JY5325_DeviceHandle hDevice, unsigned int channel, bool enable, JY5325_LevelState pauseTriggerActiveLevel)
Config CI pause trigger.
JY5325API int STDCALL | JY5325_CI_SetPauseTriggerTerminal (JY5325_DeviceHandle hDevice, int channel, JY5325_InputTerminal pauseTriggerTerminal)
Set CI Pause Trigger Terminal ,Only valid in EdgeCounting mode.
JY5325API int STDCALL | JY5325_CI_ReadSingleCountValue (JY5325_DeviceHandle hDevice, unsigned int channel, unsigned int *countValue)
Counter reads a single count value, this API supports the CI Type: JY5325_CI_EdgeCount、JY5325_CI_EncoderX1、 JY5325_CI_EncoderX2 、 JY5325_CI_EncoderX4 、JY5325_CI_EncoderTwoPulse.
JY5325API int STDCALL | JY5325_CI_ReadSingleMeasureValue (JY5325_DeviceHandle hDevice, unsigned int channel, double *measureValue1, double *measureValue2, int timeOut)
Reads a single counter measurement as follows.
JY5325API int STDCALL | JY5325_CI_ReadCountValues (JY5325_DeviceHandle hDevice, unsigned int channel, unsigned int *countValues, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
Counter reads the count values, this API is supprot CI Type ：JY5325_CI_EdgeCount、JY5325_CI_EncoderX1、 JY5325_CI_EncoderX2 、 JY5325_CI_EncoderX4 、JY5325_CI_EncoderTwoPulse.
JY5325API int STDCALL | JY5325_CI_ReadMeasureValues (JY5325_DeviceHandle hDevice, unsigned int channel, double *measureValues1, double *measureValues2, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
Counter reads the measured values, this API only support CI Type for JY5325_CI_Measure_EdgeSeparation JY5325_CI_Measure_Pulse JY5325_CI_Measure_Frequency JY5325_CI_Measure_Period for JY5325_CI_Measure_EdgeSeparation type, the measureValues1 is the Gate signel to the Aux signal interval, the measureValues2 is the Aux signel to the Gate signal interval, the unit is s.
JY5325API int STDCALL | JY5325_CI_Start (JY5325_DeviceHandle hDevice, unsigned int channel)
Start Counter input.
JY5325API int STDCALL | JY5325_CI_Stop (JY5325_DeviceHandle hDevice, unsigned int channel)
Stop Counter input.
JY5325API int STDCALL | JY5325_CI_SetValueReturnMode (JY5325_DeviceHandle hDevice, unsigned int channel, JY5325_CI_ValueReturnMode mode)
Config CI return value mode, only for JY5325_CI_Measure_EdgeSeparation type.
JY5325API int STDCALL | JY5325_CI_CheckBufferStatus (JY5325_DeviceHandle hDevice, unsigned int channel, unsigned long long *avaliableSamples, unsigned long long *transferedSamples, bool *overrun)
Check CI task buffer status.
JY5325API int STDCALL | JY5325_CI_SetTimeBase (JY5325_DeviceHandle hDevice, unsigned int channel, JY5325_CountTimeBase timebaseSrc, JY5325_InputTerminal externalTimebaseTerminal, double externalTimebaseFreq, double *actualTimebaseFreq)
Set counter input time base,the time base defined by enum JY5325_CountTimeBase.
JY5325API int STDCALL | JY5325_CI_SetSourceTerminal (JY5325_DeviceHandle hDevice, int channel, JY5325_InputTerminal sourceTerminal)
Set source terminal.
JY5325API int STDCALL | JY5325_CI_SetGateTerminal (JY5325_DeviceHandle hDevice, int channel, JY5325_InputTerminal gateTerminal)
Set gate terminal.
JY5325API int STDCALL | JY5325_CI_SetAuxTerminal (JY5325_DeviceHandle hDevice, int channel, JY5325_InputTerminal auxTerminal)
Set aux terminal.
JY5325API int STDCALL | JY5325_CI_SetOutTerminal (JY5325_DeviceHandle hDevice, int channel, JY5325_Signal_Destination outTerminal)
Set out terminal.
JY5325API int STDCALL | JY5325_CI_SendSoftTrigger (JY5325_DeviceHandle hDevice, int channel)
Send the software trigger signal for CI.
JY5325API int STDCALL | JY5325_CI_SetStartingEdge (JY5325_DeviceHandle hDevice, unsigned int channel, JY5325_CI_StartingEdge startingEdge)
Set starting edge.
JY5325API int STDCALL | JY5325_CI_SetFirstSampleClock (JY5325_DeviceHandle hDevice, unsigned int channel, bool ignore)
Set the first sample clock data ignore or not.
JY5325API int STDCALL | JY5325_CI_SetStartTriggerType (JY5325_DeviceHandle hDevice, int channel, JY5325_CIO_TriggerType triggerTyp)
Set CI start trigger type,the triggerType is defined by enum JY5325_CI_TriggerType.
JY5325API int STDCALL | JY5325_CI_SetDigitalStartTrigger (JY5325_DeviceHandle hDevice, int channel, JY5325_DigitalTriggerSource triggerSource, JY5325_DigitalTriggerEdge triggerEdge)
Set CI digital start trigger.the triggerSource is defined by enum JY5325_DigitalTriggerSource, the triggerEdge is defined by enum JY5325_DigitalTriggerEdge.
JY5325API int STDCALL | JY5325_CO_EnableChannel (JY5325_DeviceHandle hDevice, unsigned int channel)
Enabled counter output channel.
JY5325API int STDCALL | JY5325_CO_SetOutTerminal (JY5325_DeviceHandle hDevice, int channel, JY5325_Signal_Destination outTerminal)
Set out terminal.
JY5325API int STDCALL | JY5325_CO_SetCounterParament (JY5325_DeviceHandle hDevice, unsigned int channel, int pulseCount, JY5325_CO_IdleState IdleState, double delay)
Set CO parameter.
JY5325API int STDCALL | JY5325_CO_SetFrequency (JY5325_DeviceHandle hDevice, unsigned int channel, unsigned int highTicks, unsigned int lowTicks)
Set counter output pulse frequency,After the output starts, you can call this interface to modify the pulse frequency in real time.
JY5325API int STDCALL | JY5325_CO_WriteData (JY5325_DeviceHandle hDevice, int channel, unsigned int *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualWriteLength)
CO write data.One sampling point consists of three datas, high level ticks, low level ticks, and number of pulses.
JY5325API int STDCALL | JY5325_CO_CheckBufferStatus (JY5325_DeviceHandle hDevice, unsigned int channel, unsigned long *avaliableSamples, unsigned long long *transferedSamples, bool *overrun)
Check CO task buffer status.
JY5325API int STDCALL | JY5325_CO_CheckCounterStatus (JY5325_DeviceHandle hDevice, unsigned int channel, unsigned int *pulseTransfered, bool *underflow)
Check counter output status.
JY5325API int STDCALL | JY5325_CO_WaitUntilDone (JY5325_DeviceHandle hDevice, unsigned int channel, bool *done)
Check counter output complete status.
JY5325API int STDCALL | JY5325_CO_SetSamplesToUpdate (JY5325_DeviceHandle hDevice, unsigned int channel, unsigned int samplesToUpdate)
Set CO samples for each channel in the finite mode.The sample range is from 1 to 4M samples.
JY5325API int STDCALL | JY5325_CO_Start (JY5325_DeviceHandle hDevice, unsigned int channel)
Start counter output.
JY5325API int STDCALL | JY5325_CO_Stop (JY5325_DeviceHandle hDevice, unsigned int channel)
Stop counter output.
JY5325API int STDCALL | JY5325_CO_SetPauseTriggerTerminal (JY5325_DeviceHandle hDevice, int channel, JY5325_InputTerminal pauseTriggerTerminal)
Set CO Pause Trigger Terminal.
JY5325API int STDCALL | JY5325_CO_SetPauseTriggerLevel (JY5325_DeviceHandle hDevice, unsigned int channel, bool enable, JY5325_LevelState pauseTriggerActiveLevel)
Config CO pause trigger.
JY5325API int STDCALL | JY5325_CO_SetTimeBase (JY5325_DeviceHandle hDevice, unsigned int channel, JY5325_CountTimeBase timebaseSrc, JY5325_InputTerminal externalTimebaseTerminal, double externalTimebaseFreq, double *actualTimebaseFreq)
Set CO timebase source.
JY5325API int STDCALL | JY5325_CO_SendSoftTrigger (JY5325_DeviceHandle hDevice, int channel)
Send the software trigger signal.
JY5325API int STDCALL | JY5325_CO_SetMode (JY5325_DeviceHandle hDevice, unsigned int channel, JY5325_CO_OutMode mode)
Set counter output mode, the mode defined by enum JY5325_CO_UpdateMode.
JY5325API int STDCALL | JY5325_CO_SetStartTriggerType (JY5325_DeviceHandle hDevice, int channel, JY5325_CIO_TriggerType triggerTyp)
Set CO start trigger type,the triggerType is defined by enum JY5325_AI_TriggerType.
JY5325API int STDCALL | JY5325_CO_SetDigitalStartTrigger (JY5325_DeviceHandle hDevice, int channel, JY5325_DigitalTriggerSource triggerSource, JY5325_DigitalTriggerEdge triggerEdge)
Set CO digital start trigger,the triggerSource is defined by enum JY5325_DigitalTriggerSource, the triggerEdge is defined by enum JY5325_DigitalTriggerEdge.
JY5325API int STDCALL | JY5325_ReadRegister (JY5325_DeviceHandle hDevice, int offset, int *data)
read the register from fpga logic
JY5325API int STDCALL | JY5325_WriteRegister (JY5325_DeviceHandle hDevice, int offset, int data)
write the register to fpga logic

Detailed Description

@SectionBegin JY5325FileHead

COPYRIGHT NOTICE
Copyright (c) 2018, JYTEK
All rights reserved.
Author
JYTEK
Version
1.0.0
Date
2022-6-28

This header file defines C/C++ API and enums used in the JY5325 driver.

Typedef Documentation

◆ JY5325_DeviceHandle

typedef void* JY5325_DeviceHandle

Windows.

Linux

Enumeration Type Documentation

◆ JY5325_AI_SampleMode

enum JY5325_AI_SampleMode
Enumerator
JY5325_AI_Finite | AI Finite mode.
JY5325_AI_Continuous | AI Continuous mode.

◆ JY5325_AI_TriggerType

enum JY5325_AI_TriggerType
Enumerator
JY5325_AI_Immediately | AI Immediately trigger.
JY5325_AI_Digital | AI Digital trigger.
JY5325_AI_Analog | AI Analog trigger.
JY5325_AI_Soft | AI Soft trigger.

◆ JY5325_AnalogTriggerEdge

enum JY5325_AnalogTriggerEdge
Enumerator
JY5325_RisingSlope | Rsing edge for Analog trigger.
JY5325_FallingSlope | Falling edge for Analog trigger.

◆ JY5325_AnalogTriggerSource

enum JY5325_AnalogTriggerSource
Enumerator
JY5325_Channel_0
JY5325_Channel_1
JY5325_Channel_2
JY5325_Channel_3
JY5325_Channel_4
JY5325_Channel_5
JY5325_Channel_6
JY5325_Channel_7

◆ JY5325_AnalogWindowCondition

enum JY5325_AnalogWindowCondition
Enumerator
JY5325_Entering | Analog Window trigger condition is Entering.
JY5325_Leaving | Analog Window trigger condition is Leaving.

◆ JY5325_AO_TriggerType

enum JY5325_AO_TriggerType
Enumerator
JY5325_AO_Immediately | AO Immediately trigger.
JY5325_AO_Digital | AO Digital trigger.
JY5325_AO_Soft | AO Soft trigger.

◆ JY5325_AO_UpdateMode

enum JY5325_AO_UpdateMode
Enumerator
JY5325_AO_Finite | AO Finite mode.
JY5325_AO_ContinuousWrapping | AO ContinuousWrapping mode.
JY5325_AO_ContinuousNoWrapping | AO ContinuousNoWrapping mode.
JY5325_AO_Single | AO Single mode.

◆ JY5325_CI_CounterEventSignalIdleState

enum JY5325_CI_CounterEventSignalIdleState
Enumerator
JY5325_CI_CounterEventSignalIdleState_Low
JY5325_CI_CounterEventSignalIdleState_High

◆ JY5325_CI_MeasureType

enum JY5325_CI_MeasureType
Enumerator
JY5325_CI_EdgeCount
JY5325_CI_Measure_FrequencyOrPeriod
JY5325_CI_Measure_PulseWidth
JY5325_CI_Measure_SemiPeriod
JY5325_CI_Measure_EdgeSeparation
JY5325_CI_EncoderX1
JY5325_CI_EncoderX2
JY5325_CI_EncoderX4
JY5325_CI_EncoderTwoPulse

◆ JY5325_CI_SampleClock

enum JY5325_CI_SampleClock
Enumerator
JY5325_CI_ImplicitClock
JY5325_CI_InternalClock
JY5325_CI_ExternalClock

◆ JY5325_CI_SampleMode

enum JY5325_CI_SampleMode
Enumerator
JY5325_CI_Finite
JY5325_CI_Continuous
JY5325_CI_Single

◆ JY5325_CI_StartingEdge

enum JY5325_CI_StartingEdge
Enumerator
JY5325_RisingEdge
JY5325_FallingEdge
JY5325_AnyEdge

◆ JY5325_CI_ValueReturnMode

enum JY5325_CI_ValueReturnMode
Enumerator
JY5325_CI_ReturnTwoValue
JY5325_CI_ReturnOneValue

◆ JY5325_CIO_TriggerType

enum JY5325_CIO_TriggerType
Enumerator
JY5325_CIO_Immediately
JY5325_CIO_Digital
JY5325_CIO_Soft

◆ JY5325_ClockSource

enum JY5325_ClockSource
Enumerator
JY5325_InternalClock | Internal Clock Source.
JY5325_ExternalClock | External Clock Source.

◆ JY5325_CO_IdleState

enum JY5325_CO_IdleState
Enumerator
JY5325_CO_LowLevel
JY5325_CO_HighLevel

◆ JY5325_CO_OutMode

enum JY5325_CO_OutMode
Enumerator
JY5325_CO_Finite
JY5325_CO_ContinuousWrapping
JY5325_CO_ContinuousNoWrapping
JY5325_CO_Single

◆ JY5325_CountDirection

enum JY5325_CountDirection
Enumerator
JY5325_CI_Count_Up
JY5325_CI_Count_Down
JY5325_CI_Count_External

◆ JY5325_CountTimeBase

enum JY5325_CountTimeBase
Enumerator
JY5325_Internal_Timebase_100M
JY5325_Internal_Timebase_5M
JY5325_Internal_Timebase_100K
JY5325_External_Timebase

◆ JY5325_DeviceProperty

enum JY5325_DeviceProperty
Enumerator
JY5325_Independent |
JY5325_MASTER | Device as independent.
JY5325_SLAVE | Device as master.

◆ JY5325_DI_SampleMode

enum JY5325_DI_SampleMode
Enumerator
JY5325_DI_Finite | DI Finite mode.
JY5325_DI_Continuous | DI Continuous mode.
JY5325_DI_Single | DI Single mode.

◆ JY5325_DI_TriggerType

enum JY5325_DI_TriggerType
Enumerator
JY5325_DI_Immediately | DI Immediately trigger.
JY5325_DI_Digital | DI Digital trigger.
JY5325_DI_Soft | DI Soft trigger.

◆ JY5325_DigitalTriggerEdge

enum JY5325_DigitalTriggerEdge
Enumerator
JY5325_Rising | Rsing edge for digital trigger.
JY5325_Falling | Falling edge for digital trigger.

◆ JY5325_DigitalTriggerSource

enum JY5325_DigitalTriggerSource
Enumerator
JY5325_PFI0 | PFI_0 as the digital trigger source.
JY5325_PFI1 | PFI_1 as the digital trigger source.
JY5325_PFI2 | PFI_2 as the digital trigger source.
JY5325_PFI3 | PFI_3 as the digital trigger source.
JY5325_PFI4 | PFI_4 as the digital trigger source.
JY5325_PFI5 | PFI_5 as the digital trigger source.
JY5325_PFI6 | PFI_6 as the digital trigger source.
JY5325_PFI7 | PFI_7 as the digital trigger source.
JY5325_PXI_Trig0 | PXI_Trig0 as the digital trigger source.
JY5325_PXI_Trig1 | PXI_Trig1 as the digital trigger source.
JY5325_PXI_Trig2 | PXI_Trig2 as the digital trigger source.
JY5325_PXI_Trig3 | PXI_Trig3 as the digital trigger source.
JY5325_PXI_Trig4 | PXI_Trig4 as the digital trigger source.
JY5325_PXI_Trig5 | PXI_Trig5 as the digital trigger source.
JY5325_PXI_Trig6 | PXI_Trig6 as the digital trigger source.
JY5325_PXI_Trig7 | PXI_Trig7 as the digital trigger source.
JY5325_Inter_AI_StartTrig |
JY5325_Inter_AI_ReferenceTrig | AI_StartTrig as the digital trigger source.
JY5325_Inter_AO_StartTrig | AI_ReferenceTrig as the digital trigger source.
JY5325_Inter_DI_StartTrig | AO_StartTrig as the digital trigger source.
JY5325_Inter_DI_ReferenceTrig | DI_StartTrig as the digital trigger source.
JY5325_Inter_DO_StartTrig | DI_ReferenceTrig as the digital trigger source.
JY5325_Inter_Counter_0_StartTrig | DO_StartTrig as the digital trigger source.
JY5325_Inter_Counter_1_StartTrig |
JY5325_Inter_Counter_0_Out |
JY5325_Inter_Counter_1_Out |

◆ JY5325_DO_TriggerType

enum JY5325_DO_TriggerType
Enumerator
JY5325_DO_Immediately | DI Immediately trigger.
JY5325_DO_Digital | DI Digital trigger.
JY5325_DO_Soft | DI Soft trigger.

◆ JY5325_DO_UpdateMode

enum JY5325_DO_UpdateMode
Enumerator
JY5325_DO_Finite | DO Finite mode.
JY5325_DO_ContinuousWrapping | DO ContinuousWrapping mode.
JY5325_DO_ContinuousNoWrapping | DO ContinuousNoWrapping mode.
JY5325_DO_Single | DO Single mode.

◆ JY5325_ExternalClockTerminal

enum JY5325_ExternalClockTerminal
Enumerator
JY5325_Clock_PFI_0 | PFI0 as External Clock Source.
JY5325_Clock_PFI_1 | PFI1 as External Clock Source.
JY5325_Clock_PFI_2 | PFI2 as External Clock Source.
JY5325_Clock_PFI_3 | PFI3 as External Clock Source.
JY5325_Clock_PFI_4 | PFI4 as External Clock Source.
JY5325_Clock_PFI_5 | PFI5 as External Clock Source.
JY5325_Clock_PFI_6 | PFI6 as External Clock Source.
JY5325_Clock_PFI_7 | PFI7 as External Clock Source.
JY5325_Clock_PXI_Trig_0 | PXI_Trig0 as External Clock Source.
JY5325_Clock_PXI_Trig_1 | PXI_Trig1 as External Clock Source.
JY5325_Clock_PXI_Trig_2 | PXI_Trig2 as External Clock Source.
JY5325_Clock_PXI_Trig_3 | PXI_Trig3 as External Clock Source.
JY5325_Clock_PXI_Trig_4 | PXI_Trig4 as External Clock Source.
JY5325_Clock_PXI_Trig_5 | PXI_Trig5 as External Clock Source.
JY5325_Clock_PXI_Trig_6 | PXI_Trig6 as External Clock Source.
JY5325_Clock_PXI_Trig_7 | PXI_Trig7 as External Clock Source.
JY5325_Inter_Clock_DI_SampleClock | DI_SampleClock as other task External Clock Source.
JY5325_Inter_Clock_DO_SampleClock | DO_SampleClock as other task External Clock Source.
JY5325_Inter_CI_0_SampleClock |
JY5325_Inter_CI_1_SampleClock |
JY5325_Inter_CO_0_Output |
JY5325_Inter_CO_1_Output |

◆ JY5325_InputTerminal

enum JY5325_InputTerminal
Enumerator
JY5325_PFI0_Input
JY5325_PFI1_Input
JY5325_PFI2_Input
JY5325_PFI3_Input
JY5325_PFI4_Input
JY5325_PFI5_Input
JY5325_PFI6_Input
JY5325_PFI7_Input
JY5325_PXI_Trig0_Input
JY5325_PXI_Trig1_Input
JY5325_PXI_Trig2_Input
JY5325_PXI_Trig3_Input
JY5325_PXI_Trig4_Input
JY5325_PXI_Trig5_Input
JY5325_PXI_Trig6_Input
JY5325_PXI_Trig7_Input
JY5325_IN_AI_SampleClock
JY5325_IN_AO_SampleClock
JY5325_IN_DI_SampleClock
JY5325_IN_DO_SampleClock
JY5325_IN_CO_0_Output
JY5325_IN_CO_1_Output
JY5325_IN_CIO_100MHz
JY5325_IN_CIO_5MHz
JY5325_IN_CIO_100kHz

◆ JY5325_LevelState

enum JY5325_LevelState
Enumerator
JY5325_LowLevel
JY5325_HighLevel

◆ JY5325_OutputCompleteState

enum JY5325_OutputCompleteState
Enumerator
JY5325_Zero | Output Zero.
JY5325_Hold | Output Hold.

◆ JY5325_ReferenceClock

enum JY5325_ReferenceClock
Enumerator
JY5325_Internal | The onboard 25 MHz as JY5325_ReferenceClock.
JY5325_PXIe_Clk100 | The PXIe chassis 100MHz as JY5325_ReferenceClock, only for PXIe module.

◆ JY5325_Signal_Destination

enum JY5325_Signal_Destination
Enumerator
JY5325_PFI0_OUT |
JY5325_PFI1_OUT | PFI0 as the signal desition to rout.
JY5325_PFI2_OUT | PFI1 as the signal desition to rout.
JY5325_PFI3_OUT | PFI2 as the signal desition to rout.
JY5325_PFI4_OUT | PFI3 as the signal desition to rout.
JY5325_PFI5_OUT | PFI4 as the signal desition to rout.
JY5325_PFI6_OUT | PFI5 as the signal desition to rout.
JY5325_PFI7_OUT | PFI6 as the signal desition to rout.
JY5325_PXITrig0_OUT | PFI7 as the signal desition to rout.
JY5325_PXITrig1_OUT | PXITrig0 as the signal desition to rout.
JY5325_PXITrig2_OUT | PXITrig1 as the signal desition to rout.
JY5325_PXITrig3_OUT | PXITrig2 as the signal desition to rout.
JY5325_PXITrig4_OUT | PXITrig3 as the signal desition to rout.
JY5325_PXITrig5_OUT | PXITrig4 as the signal desition to rout.
JY5325_PXITrig6_OUT | PXITrig5 as the signal desition to rout.
JY5325_PXITrig7_OUT | PXITrig6 as the signal desition to rout.
JY5325_None | PXITrig7 as the signal desition to rout.

◆ JY5325_Signal_Source

enum JY5325_Signal_Source
Enumerator
JY5325_Signal_PFI0 | PFI_0 as the source signal to rout.
JY5325_Signal_PFI1 | PFI_1 as the source signal to rout.
JY5325_Signal_PFI2 | PFI_2 as the source signal to rout.
JY5325_Signal_PFI3 | PFI_3 as the source signal to rout.
JY5325_Signal_PFI4 | PFI_4 as the source signal to rout.
JY5325_Signal_PFI5 | PFI_5 as the source signal to rout.
JY5325_Signal_PFI6 | PFI_6 as the source signal to rout.
JY5325_Signal_PFI7 | PFI_7 as the source signal to rout.
JY5325_Signal_PXI_Trig0 | PXI_Trig0 as the source signal to rout.
JY5325_Signal_PXI_Trig1 | PXI_Trig1 as the source signal to rout.
JY5325_Signal_PXI_Trig2 | PXI_Trig2 as the source signal to rout.
JY5325_Signal_PXI_Trig3 | PXI_Trig3 as the source signal to rout.
JY5325_Signal_PXI_Trig4 | PXI_Trig4 as the source signal to rout.
JY5325_Signal_PXI_Trig5 | PXI_Trig5 as the source signal to rout.
JY5325_Signal_PXI_Trig6 | PXI_Trig6 as the source signal to rout.
JY5325_Signal_PXI_Trig7 | PXI_Trig7 as the source signal to rout.
JY5325_Signal_AI_StartTrig |
JY5325_Signal_AI_ReferenceTrig | AI_StartTrig as the source signal to rout.
JY5325_Signal_AO_StartTrig | AI_ReferenceTrig as the source signal to rout.
JY5325_Signal_DI_StartTrig | AO_StartTrig as the source signal to rout.
JY5325_Signal_DI_ReferenceTrig | DI_StartTrig as the source signal to rout.
JY5325_Signal_DI_SampleClock | DI_StartTrig as the source signal to rout.
JY5325_Signal_DO_StartTrig | DI_SampleClock as the source signal to rout.
JY5325_Signal_DO_SampleClock | DO_StartTrig as the source signal to rout.
JY5325_Signal_CI_0_SampleClock | DO_SampleClock as the source signal to rout.
JY5325_Signal_CI_1_SampleClock |
JY5325_Signal_CO_0_Output |
JY5325_Signal_CO_1_Output |
JY5325_Signal_Counter_0_StartTrig |
JY5325_Signal_Counter_1_StartTrig |
JY5325_Signal_CIO_100MHz |
JY5325_Signal_CIO_5MHz |
JY5325_Signal_CIO_100kHz |

◆ JY5325_TriggerMode

enum JY5325_TriggerMode
Enumerator
JY5325_StartTrigger | Start trigger mode.
JY5325_ReferenceTrigger | Reference trigger mode.

Function Documentation

◆ JY5325_AI_CheckBufferStatus()

JY5325API int STDCALL JY5325_AI_CheckBufferStatus | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned long long * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun )

Check AI device buffer status.

Parameters
hDevice | device handle
avaliableSamples | number of samples per channel in the device buffer
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5325_AI_EnableChannel()

JY5325API int STDCALL JY5325_AI_EnableChannel | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned int | channelCount,
 |  | unsigned char * | channels,
 |  | double * | lowRegion,
 |  | double * | highRegion )

Enable AI channels.

Each channel can be independently configured

Parameters
hDevice | device handle
channelCount | number of channels to be enabled
channels | array[channelCount] containing channel IDs
lowRegion | array[channelCount] of lower limit numbers for each channel,typically in volts.
highRegion | array[channelCount] of higher limit numbers for each channel, typcially in volts.
Returns
0 if success or other error code

◆ JY5325_AI_ReadData()

JY5325API int STDCALL JY5325_AI_ReadData | ( | JY5325_DeviceHandle | hDevice,
 |  | double * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength )

Read AI data to user defined data buffer.

For the multi-channel acquisition, the data is interleaved in the order defined by JY5325_AI_EnableChannel.

Parameters
hDevice | device handle
dataBuffer | user buffer,the buffer size must be greater than or equal to dataLength*channelCount.
dataLength | number of samples per channel
timeOut | timeout time in microsecond
actualReadLength | returns the number of samples per channel actually read
Returns
0 if success or other error code

◆ JY5325_AI_ReadRawData()

JY5325API int STDCALL JY5325_AI_ReadRawData | ( | JY5325_DeviceHandle | hDevice,
 |  | short * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength )

Read AI raw data to user defined data buffer.

For the multi-channel acquisition, the data is interleaved in the order defined by JY5325_AI_EnableChannel.

Parameters
hDevice | device handle
dataBuffer | user buffer, The size of dataBuffer must be greater than or equal to dataLength*channelCount.
dataLength | number of samples per channel
timeOut | timeout time in microsecond
actualReadLength | return the number of samples per channel actually read
Returns
0 if success or other error code

◆ JY5325_AI_SendSoftTrigger()

JY5325API int STDCALL JY5325_AI_SendSoftTrigger | ( | JY5325_DeviceHandle | hDevice,
 |  | JY5325_TriggerMode | triggerMode )

Send the software trigger signal for AI.

Parameters
hDevice | device handle
triggerMode | software trigger mode. Options: start trigger or reference trigger.
Returns
0 if success or other error code

◆ JY5325_AI_SetAnalogEdgeReferenceTrigger()

JY5325API int STDCALL JY5325_AI_SetAnalogEdgeReferenceTrigger | ( | JY5325_DeviceHandle | hDevice,
 |  | JY5325_AnalogTriggerSource | triggerSource,
 |  | JY5325_AnalogTriggerEdge | triggerEdge,
 |  | double | threshold )

Set AI analog edge reference trigger,the triggerSource is defined by enum JY5325_AnalogTriggerSource, the triggerEdge is defined by enum JY5325_AnalogTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source,0-16<
triggerCondition | AI analog trigger conditions
threshold | threshold
Returns
0 if success or other error code

◆ JY5325_AI_SetAnalogEdgeStartTrigger()

JY5325API int STDCALL JY5325_AI_SetAnalogEdgeStartTrigger | ( | JY5325_DeviceHandle | hDevice,
 |  | JY5325_AnalogTriggerSource | triggerSource,
 |  | JY5325_AnalogTriggerEdge | triggerEdge,
 |  | double | threshold )

Set AI analog edge start trigger,the triggerSource is defined by enum JY5325_AnalogTriggerSource, the triggerEdge is defined by enum JY5325_AnalogTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source,0-16<
triggerCondition | AI analog trigger conditions
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY5325_AI_SetAnalogHysteresisReferenceTrigger()

JY5325API int STDCALL JY5325_AI_SetAnalogHysteresisReferenceTrigger | ( | JY5325_DeviceHandle | hDevice,
 |  | JY5325_AnalogTriggerSource | triggerSource,
 |  | JY5325_AnalogTriggerEdge | triggerEdge,
 |  | double | highThreshold,
 |  | double | lowThreshold )

Set AI analog hysteresis reference trigger,the triggerSource is defined by enum JY5325_AnalogTriggerSource, the triggerEdge is defined by enum JY5325_AnalogTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source,0-16<
triggerCondition | AI analog trigger conditions
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY5325_AI_SetAnalogHysteresisStartTrigger()

JY5325API int STDCALL JY5325_AI_SetAnalogHysteresisStartTrigger | ( | JY5325_DeviceHandle | hDevice,
 |  | JY5325_AnalogTriggerSource | triggerSource,
 |  | JY5325_AnalogTriggerEdge | triggerEdge,
 |  | double | highThreshold,
 |  | double | lowThreshold )

Set AI analog hysteresis start trigger,the triggerSource is defined by enum JY5325_AnalogTriggerSource, the triggerEdge is defined by enum JY5325_AnalogTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source,0-16<
triggerCondition | AI analog trigger conditions
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY5325_AI_SetAnalogWindowReferenceTrigger()

JY5325API int STDCALL JY5325_AI_SetAnalogWindowReferenceTrigger | ( | JY5325_DeviceHandle | hDevice,
 |  | JY5325_AnalogTriggerSource | triggerSource,
 |  | JY5325_AnalogWindowCondition | triggerCondition,
 |  | double | highThreshold,
 |  | double | lowThreshold )

Set AI analog window reference trigger,the triggerSource is defined by enum JY5325_AnalogTriggerSource, the triggerCondition is defined by enum JY5325_AnalogTriggerCondition.

Parameters
hDevice | device handle
triggerSource | AI reference trigger source,0-16<
triggerCondition | AI analog trigger conditions
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY5325_AI_SetAnalogWindowStartTrigger()

JY5325API int STDCALL JY5325_AI_SetAnalogWindowStartTrigger | ( | JY5325_DeviceHandle | hDevice,
 |  | JY5325_AnalogTriggerSource | triggerSource,
 |  | JY5325_AnalogWindowCondition | triggerCondition,
 |  | double | highThreshold,
 |  | double | lowThreshold )

Set AI analog window start trigger,the triggerSource is defined by enum JY5325_AnalogTriggerSource, the triggerCondition is defined by enum JY5325_AnalogWindowCondition.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source,0-16
triggerCondition | AI analog trigger conditions
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY5325_AI_SetDigitalReferenceTrigger()

JY5325API int STDCALL JY5325_AI_SetDigitalReferenceTrigger | ( | JY5325_DeviceHandle | hDevice,
 |  | JY5325_DigitalTriggerSource | triggerSource,
 |  | JY5325_DigitalTriggerEdge | triggerEdge )

Set AI digital reference trigger.the triggerSource is defined by enum JY5325_DigitalTriggerSource, the triggerEdge is defined by enum JY5325_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI reference trigger source
triggerEdge | AI reference to the trigger edge. Options: rising or falling edge
Returns
0 if success or other error code

◆ JY5325_AI_SetDigitalStartTrigger()

JY5325API int STDCALL JY5325_AI_SetDigitalStartTrigger | ( | JY5325_DeviceHandle | hDevice,
 |  | JY5325_DigitalTriggerSource | triggerSource,
 |  | JY5325_DigitalTriggerEdge | triggerEdge )

Set AI digital start trigger,the triggerSource is defined by enum JY5325_DigitalTriggerSource, the triggerEdge is defined by enum JY5325_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI digital start trigger source
triggerEdge | AI digital start trigger edge. Options: rising or falling edge
Returns
0 if success or other error code

◆ JY5325_AI_SetMode()

JY5325API int STDCALL JY5325_AI_SetMode | ( | JY5325_DeviceHandle | hDevice,
 |  | JY5325_AI_SampleMode | mode )

Set AI sampling mode.

Parameters
hDevice | device handle
mode | AI sampling mode defined by enum JY5325_AI_SampleMode.
Returns
0 if success or other error code

◆ JY5325_AI_SetPreTriggerSamples()

JY5325API int STDCALL JY5325_AI_SetPreTriggerSamples | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned int | preTriggerSamples )

Set AI pretrigger samples, the samples must greater than 0.

Parameters
hDevice | device handle
preTriggerSamples | AI pretrigger samples, valid only in reference trigger mode.
Returns
0 if success or other error code

◆ JY5325_AI_SetReferenceTriggerType()

JY5325API int STDCALL JY5325_AI_SetReferenceTriggerType | ( | JY5325_DeviceHandle | hDevice,
 |  | JY5325_AI_TriggerType | triggerType )

Set AI reference trigger type,the triggerType is defined by enum JY5325_AI_TriggerType.

Parameters
hDevice | device handle
triggerType | AI reference trigger type.Options: immediate trigger, software trigger, digital trigger or analog trigger.
Returns
0 if success or other error code

◆ JY5325_AI_SetReTriggerCount()

JY5325API int STDCALL JY5325_AI_SetReTriggerCount | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned long long | reTriggerCount )

Set AI retrigger count.

The device will be triggered reTriggerCount times.

Parameters
hDevice | device handle
reTriggerCount | AI retrigger count
Returns
0 if success or other error code

◆ JY5325_AI_SetSampleClock()

JY5325API int STDCALL JY5325_AI_SetSampleClock | ( | JY5325_DeviceHandle | hDevice,
 |  | JY5325_ClockSource | clockSource,
 |  | JY5325_ExternalClockTerminal | terminal,
 |  | double | expectedRate )

Set AI sampling clock.

the source of the sampling clock defined by enum JY5325_ClockSource. If the clock source is external, external clock terminal and external clock frequency must be configured.

Parameters
hDevice | device handle
clockSource | AI sampling clock source
terminal | external terminal
expectedRate | AI external clock frequency
Returns
0 if success or other error code

◆ JY5325_AI_SetSampleRate()

JY5325API int STDCALL JY5325_AI_SetSampleRate | ( | JY5325_DeviceHandle | hDevice,
 |  | double | sampleRate,
 |  | double * | actualSampleRate )

Set sampling rate.

The sampling rate is the same for all channels.

Parameters
hDevice | device handle
sampleRate | AI sampling rate to be set per channel
actualSampleRate | actual sampling rate set by this device,which may be different from the desired sampleRate.
Returns
0 if success or other error code

◆ JY5325_AI_SetSamplesToAcquire()

JY5325API int STDCALL JY5325_AI_SetSamplesToAcquire | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned int | sampleToAcquire )

Set AI samples to acquire for each channel in finite mode.The samples range is 1 to 256M samples / channelCount.

Parameters
hDevice | device handle
sampleToAcquire | AI finite samples to acquire for each channel, samples range:1 to 256M samples / channelCount.
Returns
0 if success or other error code

◆ JY5325_AI_SetStartTriggerType()

JY5325API int STDCALL JY5325_AI_SetStartTriggerType | ( | JY5325_DeviceHandle | hDevice,
 |  | JY5325_AI_TriggerType | triggerType )

Set AI start trigger type,the triggerType is defined by enum JY5325_AI_TriggerType.

Parameters
hDevice | device handle
triggerType | AI start trigger type. Options:immediate trigger, software trigger, digital trigger or analog trigger.
Returns
0 if success or other error code

◆ JY5325_AI_Start()

JY5325API int STDCALL JY5325_AI_Start ( JY5325_DeviceHandle hDevice )

Start AI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5325_AI_Stop()

JY5325API int STDCALL JY5325_AI_Stop ( JY5325_DeviceHandle hDevice )

Stop AI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5325_AI_WaitUntilDone()

JY5325API int STDCALL JY5325_AI_WaitUntilDone | ( | JY5325_DeviceHandle | hDevice,
 |  | bool * | done )

Check if AI acquisition is completed in finite mode.

Parameters
hDevice | device handle
done | true:completed, false:not yet completed.
Returns
0 if success or other error code

◆ JY5325_AO_CheckBufferStatus()

JY5325API int STDCALL JY5325_AO_CheckBufferStatus | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned long * | availableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun )

Check AO device buffer status.

Parameters
hDevice | device handle
avaliableSamples | number of AO points per channel user can write
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5325_AO_EnableChannel()

JY5325API int STDCALL JY5325_AO_EnableChannel | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned int | channelCount,
 |  | unsigned char * | channels,
 |  | double * | lowRegion,
 |  | double * | highRegion )

Enables AO channels.

Parameters
hDevice | device handle
channelCount | number of channels to be enabled
channels | array[channelCount] containing channelIDs
lowRegion | array[channelCount] of lower limit numbers for each channel,typically in volts.
highRegion | array[channelCount] of higher limit numbers for each channel, typcially in volts.
Returns
0 if success or other error code

◆ JY5325_AO_SendSoftTrigger()

JY5325API int STDCALL JY5325_AO_SendSoftTrigger ( JY5325_DeviceHandle hDevice )

Send the software trigger signal.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5325_AO_SetDigitalStartTrigger()

JY5325API int STDCALL JY5325_AO_SetDigitalStartTrigger | ( | JY5325_DeviceHandle | hDevice,
 |  | JY5325_DigitalTriggerSource | triggerSource,
 |  | JY5325_DigitalTriggerEdge | triggerEdge )

Set AO digital start trigger,the triggerSource is defined by enum JY5325_DigitalTriggerSource, the triggerEdge is defined by enum JY5325_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AO digital start trigger source
triggerEdge | AO digital start trigger edge. Options: rising or falling edge
Returns
0 if success or other error code

◆ JY5325_AO_SetMode()

JY5325API int STDCALL JY5325_AO_SetMode | ( | JY5325_DeviceHandle | hDevice,
 |  | JY5325_AO_UpdateMode | mode )

Set digital signal output mode, the mode defined by enum JY5325_AO_UpdateMode.

Parameters
hDevice | device handle
mode | digital signal output mode.Options: Single,Finite,ContinuousWrapping,ContinuousNoWrapping
Returns
0 if success or other error code

◆ JY5325_AO_SetOutputCompleteState()

JY5325API int STDCALL JY5325_AO_SetOutputCompleteState | ( | JY5325_DeviceHandle | hDevice,
 |  | JY5325_OutputCompleteState | State )

Set AO Output complete state, only in Finite/ ContinuousWrapping/ ContinuousNoWrapping Mode,Default is Zero.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5325_AO_SetSampleClock()

JY5325API int STDCALL JY5325_AO_SetSampleClock | ( | JY5325_DeviceHandle | hDevice,
 |  | JY5325_ClockSource | clockSource,
 |  | JY5325_ExternalClockTerminal | terminal,
 |  | double | expectedRate )

Set AO sampling clock.

the source of the sampling clock defined by enum JY5325_ClockSource. If the clock source is external, need to configure external clock terminal and external clock frequency.

Parameters
hDevice | device handle
clockSource | AO sampling clock source
terminal | external clock terminal,defined by enum JY5325_ExternalClockTerminal
expectedRate | external clock frequency
Returns
0 if success or other error code

◆ JY5325_AO_SetSamplesToUpdate()

JY5325API int STDCALL JY5325_AO_SetSamplesToUpdate | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned int | sampleToUpdate )

Set digital signal output samples for each channel in the finite mode.The sample range is from 1 to 256M / channelCount.

Parameters
hDevice | device handle
sampleToUpdate | number of digital signal output samples per channel. Data range:1 to 256M / channelCount samples.
Returns
0 if success or other error code

◆ JY5325_AO_SetStartTriggerType()

JY5325API int STDCALL JY5325_AO_SetStartTriggerType | ( | JY5325_DeviceHandle | hDevice,
 |  | JY5325_AO_TriggerType | triggerTyp )

Set AO start trigger type,the triggerType is defined by enum JY5325_AO_TriggerType.

Parameters
hDevice | device handle
triggerType | AO start trigger type. Options: immediate trigger, software trigger, digital trigger .
Returns
0 if success or other error code

◆ JY5325_AO_SetUpdateRate()

JY5325API int STDCALL JY5325_AO_SetUpdateRate | ( | JY5325_DeviceHandle | hDevice,
 |  | double | updateRate,
 |  | double * | actualUpdateRate )

Set AO update rate for each channel.

Parameters
hDevice | device handle
updateRate | AO update rate to be set per channel
actualUpdateRate | AO update rate actually set. The actual update rate set by this device,which may be different from the desired updata rate.
Returns
0 if success or other error code

◆ JY5325_AO_Start()

JY5325API int STDCALL JY5325_AO_Start ( JY5325_DeviceHandle hDevice )

Start digital signal output.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5325_AO_Stop()

JY5325API int STDCALL JY5325_AO_Stop ( JY5325_DeviceHandle hDevice )

Stop digital signal output.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5325_AO_WaitUntilDone()

JY5325API int STDCALL JY5325_AO_WaitUntilDone | ( | JY5325_DeviceHandle | hDevice,
 |  | bool * | done,
 |  | int | timeOut )

Check finite analog signal output is complete.

Parameters
hDevice | device handle
done | true if completed, false if not yet completed.
timeOut | timeout time in microsecond
Returns
0 if success or other error code

◆ JY5325_AO_WriteData()

JY5325API int STDCALL JY5325_AO_WriteData | ( | JY5325_DeviceHandle | hDevice,
 |  | double * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualWriteLength )

AO writes data.The data is interleaved in the buffer the order defined by JY5325_AO_EnableChannel.

Parameters
hDevice | device handle
dataBuffer | user buffer of output data.The buffer size must be greater than or equal to dataLength*number of enabled channels.
dataLength | total number of output data for all channels
timeOut | timeout time in microsecond
actualWriteLength | the number of points per channel actually write
Returns
0 if success or other error code

◆ JY5325_AO_WriteRawData()

JY5325API int STDCALL JY5325_AO_WriteRawData | ( | JY5325_DeviceHandle | hDevice,
 |  | short * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualWriteLength )

AO write raw data.The data is interleaved in the buffer in channel order for multi-channel.

Parameters
hDevice | device handle
dataBuffer | user buffer, the buffer size must be greater than or equal to dataLength*number of enabled channels.
dataLength | total number of output data for all channels
timeOut | timeout time in microsecond
actualWriteLength | the number of points per channel actually write
Returns
0 if success or other error code

◆ JY5325_AO_WriteRawSinglePoint()

JY5325API int STDCALL JY5325_AO_WriteRawSinglePoint | ( | JY5325_DeviceHandle | hDevice,
 |  | short * | writeValues,
 |  | int | channelID )

AO write single point data to the defined channel by channelID, if channelID == -1, write all enable channel.

Parameters
hDevice | device handle
writeValues | write value for each enable channel,when channelID == -1, the writeValue length must equal to channelCount
channelID | defined channelID
Returns
0 if success or other error code

◆ JY5325_AO_WriteSinglePoint()

JY5325API int STDCALL JY5325_AO_WriteSinglePoint | ( | JY5325_DeviceHandle | hDevice,
 |  | double * | writeValues,
 |  | int | channelID )

AO write single point data to the defined channel by channelID, if channelID == -1, write all enable channel.

Parameters
hDevice | device handle
writeValues | write value for each enable channel,when channelID == -1 the writeValue length must equal to channelCount
channelID | defined channel, if channelID == -1, write all enable channel
Returns
0 if success or other error code

◆ JY5325_CI_CheckBufferStatus()

JY5325API int STDCALL JY5325_CI_CheckBufferStatus | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned long long * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun )

Check CI task buffer status.

Parameters
hDevice | device handle
channel | counter input channel
avaliableSamples | number of samples that the device buffer can read
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5325_CI_EnableChannel()

JY5325API int STDCALL JY5325_CI_EnableChannel | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned int | channel )

Enables CI channel.There are 2 counter,from 0 and 1.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if success or other error code

◆ JY5325_CI_ReadCountValues()

JY5325API int STDCALL JY5325_CI_ReadCountValues | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int * | countValues,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength )

Counter reads the count values, this API is supprot CI Type ：JY5325_CI_EdgeCount、JY5325_CI_EncoderX1、 JY5325_CI_EncoderX2 、 JY5325_CI_EncoderX4 、JY5325_CI_EncoderTwoPulse.

Parameters
hDevice | device handle
channel | counter input channel
countValues | user buffer,the buffer size must be greater than or equal to dataLength
dataLength | read data length
timeOut | timeout time in microsecond
actualReadLength | return value, the actual length of the data read.
Returns
0 if success or other error code

◆ JY5325_CI_ReadMeasureValues()

JY5325API int STDCALL JY5325_CI_ReadMeasureValues | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | double * | measureValues1,
 |  | double * | measureValues2,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength )

Counter reads the measured values, this API only support CI Type for JY5325_CI_Measure_EdgeSeparation JY5325_CI_Measure_Pulse JY5325_CI_Measure_Frequency JY5325_CI_Measure_Period for JY5325_CI_Measure_EdgeSeparation type, the measureValues1 is the Gate signel to the Aux signal interval, the measureValues2 is the Aux signel to the Gate signal interval, the unit is s.

for JY5325_CI_Measure_Pulse type, the measureValues1 is the Low level signal time, the measureValues2 is the Highe level signal time, the unit is s. for JY5325_CI_Measure_Frequency type, the measureValues1 is signal frequency, the unit is Hz. for JY5325_CI_Measure_Period type, the measureValues2 is signal period, the unit is s. The JY5325_CI_Measure_Period type and JY5325_CI_Measure_Frequency type is same time measurement, user need to read both measurements simultaneously.

Parameters
hDevice | device handle
channel | counter input channel
measureValues | user buffer.The buffer size must be greater than or equal to dataLength
dataLength | read data length
timeOut | measure timeout time in microsecond
actualReadLength | reture the actual length of the data read
Returns
0 if success or other error code

◆ JY5325_CI_ReadSingleCountValue()

JY5325API int STDCALL JY5325_CI_ReadSingleCountValue | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int * | countValue )

Counter reads a single count value, this API supports the CI Type: JY5325_CI_EdgeCount、JY5325_CI_EncoderX1、 JY5325_CI_EncoderX2 、 JY5325_CI_EncoderX4 、JY5325_CI_EncoderTwoPulse.

Parameters
hDevice | device handle
channel | counter input channel. An integer counter number, eg, 0 for counter 0.
countValue | return the current count value of counter.
Returns
0 if success or other error code

◆ JY5325_CI_ReadSingleMeasureValue()

JY5325API int STDCALL JY5325_CI_ReadSingleMeasureValue | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | double * | measureValue1,
 |  | double * | measureValue2,
 |  | int | timeOut )

Reads a single counter measurement as follows.

for JY5325_CI_Measure_EdgeSeparation type, measureValues1 is the Gate signel to the Aux signal interval, the measureValues2 is the Aux signel to the Gate signal interval, the unit is in s. for JY5325_CI_Measure_Pulse type, measureValues1 is the Low level signal time, the measureValues2 is the high level signal time, the unit is in second. for JY5325_CI_Measure_Frequency type, measureValues1 is signal frequency in Hz, measureValue2 has no meaning. for JY5325_CI_Measure_Period type, measureValues2 is signal period in second; measureValue1 has no meaning.

Parameters
hDevice | device handle
channel | Counter input channel
measureValue1 | current measure value of counter
measureValue2 | current measure value of counter
timeOut | timeout time in microsecond
Returns
0 if success or other error code

◆ JY5325_CI_SendSoftTrigger()

JY5325API int STDCALL JY5325_CI_SendSoftTrigger | ( | JY5325_DeviceHandle | hDevice,
 |  | int | channel )

Send the software trigger signal for CI.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if success or other error code

◆ JY5325_CI_SetAuxTerminal()

JY5325API int STDCALL JY5325_CI_SetAuxTerminal | ( | JY5325_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5325_InputTerminal | auxTerminal )

Set aux terminal.

Parameters
hDevice | device handle
channel | counter output channel
auxTerminal | aux terminal
Returns
0 if success or other error code

◆ JY5325_CI_SetCounterParament()

JY5325API int STDCALL JY5325_CI_SetCounterParament | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | int | initCount,
 |  | JY5325_CountDirection | countDirection )

Set CI count parameter.

Parameters
hDevice | device handle
channel | counter input channel
initCount | counter initial value
countDirection | counting direction of the counter defined by enum JY5325_CountDirection
Returns
0 if success or other error code

◆ JY5325_CI_SetCounterType()

JY5325API int STDCALL JY5325_CI_SetCounterType | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5325_CI_MeasureType | measureType )

Set CI measure type.

Parameters
hDevice | device handle
channel | counter input channel
measureType | measure type. defined by enum JY5325_CI_MeasureType
Returns
0 if success or other error code

◆ JY5325_CI_SetDigitalStartTrigger()

JY5325API int STDCALL JY5325_CI_SetDigitalStartTrigger | ( | JY5325_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5325_DigitalTriggerSource | triggerSource,
 |  | JY5325_DigitalTriggerEdge | triggerEdge )

Set CI digital start trigger.the triggerSource is defined by enum JY5325_DigitalTriggerSource, the triggerEdge is defined by enum JY5325_DigitalTriggerEdge.

Parameters
hDevice | device handle
channel | counter input channel
triggerSource | CI digital start trigger source
triggerEdge | CI digital start trigger edge. Options: rising or falling edge.
Returns
0 if success or other error code

◆ JY5325_CI_SetEdgeCountEvent()

JY5325API int STDCALL JY5325_CI_SetEdgeCountEvent | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5325_CI_CounterEventSignalIdleState | idleState,
 |  | unsigned int | threshold )

Set the counter threshold, and when the count reaches this threshold, output a single pulse at the output terminal.

Parameters
hDevice | device handle
channel | counter input channel
idleState | output terminal idle state
threshold | threshold
Returns
0 if success or other error code

◆ JY5325_CI_SetFirstSampleClock()

JY5325API int STDCALL JY5325_CI_SetFirstSampleClock | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool | ignore )

Set the first sample clock data ignore or not.

Parameters
hDevice | device handle
channel | counter input channel
ignore | ignore the first sample clock data. true : ignore; false: not ignore
Returns
0 if success or other error code

◆ JY5325_CI_SetGateTerminal()

JY5325API int STDCALL JY5325_CI_SetGateTerminal | ( | JY5325_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5325_InputTerminal | gateTerminal )

Set gate terminal.

Parameters
hDevice | device handle
channel | counter output channel
gateTerminal | gate terminal
Returns
0 if success or other error code

◆ JY5325_CI_SetMode()

JY5325API int STDCALL JY5325_CI_SetMode | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5325_CI_SampleMode | mode )

Set counter input mode, the mode is defined by enum JY5325_CI_SampleMode.

Parameters
hDevice | device handle
channel | counter input channel
mode | counter input mode, Options: single,finite,continuous.
Returns
0 if success or other error code

◆ JY5325_CI_SetOutTerminal()

JY5325API int STDCALL JY5325_CI_SetOutTerminal | ( | JY5325_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5325_Signal_Destination | outTerminal )

Set out terminal.

Parameters
hDevice | device handle
channel | counter output channel
outTerminal | source terminal
Returns
0 if success or other error code

◆ JY5325_CI_SetPauseTriggerLevel()

JY5325API int STDCALL JY5325_CI_SetPauseTriggerLevel | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool | enable,
 |  | JY5325_LevelState | pauseTriggerActiveLevel )

Config CI pause trigger.

Only valid in EdgeCounting mode.

Parameters
hDevice | Device handle
channel | Counter channel
enable | Enable pasue trigger
pauseTriggerActiveLevel | Pause trigger active level.
Returns
Succeed: 0 , Error: !=0

◆ JY5325_CI_SetPauseTriggerTerminal()

JY5325API int STDCALL JY5325_CI_SetPauseTriggerTerminal | ( | JY5325_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5325_InputTerminal | pauseTriggerTerminal )

Set CI Pause Trigger Terminal ,Only valid in EdgeCounting mode.

Parameters
hDevice | device handle
channel | counter output channel
pauseTriggerTerminal | pause Trigge terminal
Returns
0 if success or other error code

◆ JY5325_CI_SetSampleClock()

JY5325API int STDCALL JY5325_CI_SetSampleClock | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5325_CI_SampleClock | clock,
 |  | JY5325_ExternalClockTerminal | terminal,
 |  | double | rate )

Set counter input sampling clock source.

If the clockType is internal, user need to define sampleRate, if the clockType is JY5325_CI_ImplicitClk, the sample rate determine by the measuer signal.

Parameters
hDevice | device handle
channel | counter input channel
clock | counter input clock type. Option: internal clock 、 implicit clock、external clock.
terminal | external clock terminal,defined by enum JY5325_ExternalClockTerminal
rate | clock frequency,when clockType is implicit clock or external clock. when clockType is Internal clock, the rate is internal sample rate
Returns
0 if success or other error code

◆ JY5325_CI_SetSamplesToAcquire()

JY5325API int STDCALL JY5325_CI_SetSamplesToAcquire | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int | samplesToAcquire )

Set samples to acquire in finite mode.The samples range is 1 to 4M.

Parameters
hDevice | device handle
channel | counter input channel
samplesToAcquire | CI finite samples to acquire, samples range:1 to 4M samples.
Returns
0 if success or other error code

◆ JY5325_CI_SetSignalReverse()

JY5325API int STDCALL JY5325_CI_SetSignalReverse | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | int | signalReverse )

Set the Signal Reverse terminal.

Parameters
hDevice | device handle
channel | counter input channel
signalReverse | The lower 4bit is valid. 0bit represents Source, 1bit represents Gate, 2bit represents Aux, and 3bit represents Extclk
Returns
0 if success or other error code

◆ JY5325_CI_SetSourceTerminal()

JY5325API int STDCALL JY5325_CI_SetSourceTerminal | ( | JY5325_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5325_InputTerminal | sourceTerminal )

Set source terminal.

Parameters
hDevice | device handle
channel | counter output channel
sourceTerminal | source terminal
Returns
0 if success or other error code

◆ JY5325_CI_SetStartingEdge()

JY5325API int STDCALL JY5325_CI_SetStartingEdge | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5325_CI_StartingEdge | startingEdge )

Set starting edge.

Parameters
hDevice | device handle
channel | counter input channel
startingEdge | starting edge.
Returns
0 if success or other error code

◆ JY5325_CI_SetStartTriggerType()

JY5325API int STDCALL JY5325_CI_SetStartTriggerType | ( | JY5325_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5325_CIO_TriggerType | triggerTyp )

Set CI start trigger type,the triggerType is defined by enum JY5325_CI_TriggerType.

Parameters
hDevice | device handle
channel | counter input channel
triggerType | CI start trigger type. Options: immediate trigger, software trigger, digital trigger.
Returns
0 if success or other error code

◆ JY5325_CI_SetTimeBase()

JY5325API int STDCALL JY5325_CI_SetTimeBase | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5325_CountTimeBase | timebaseSrc,
 |  | JY5325_InputTerminal | externalTimebaseTerminal,
 |  | double | externalTimebaseFreq,
 |  | double * | actualTimebaseFreq )

Set counter input time base,the time base defined by enum JY5325_CountTimeBase.

Parameters
hDevice | device handle
channel | counter channel
timebaseSrc | counter time base source.defined by emun JY5325_CountTimeBase.Options:JY5325_TimeBase_100M
externalTimebaseTerminal | counter external time base terminal.defined by emun JY5325_InputTerminal.
externalTimebaseFreq | counter external time base frequency.
actualTimebaseFreq | counter actual time base frequency.
Returns
0 if success or other error code

◆ JY5325_CI_SetValueReturnMode()

JY5325API int STDCALL JY5325_CI_SetValueReturnMode | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5325_CI_ValueReturnMode | mode )

Config CI return value mode, only for JY5325_CI_Measure_EdgeSeparation type.

Parameters
hDevice | Device handle
channel | Counter channel
mode | Counter return value mode
Returns
Succeed: 0 , Error: !=0

◆ JY5325_CI_SetZReloadEnabled()

JY5325API int STDCALL JY5325_CI_SetZReloadEnabled | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool | zReloadEnabled )

Set the Z signal enable in Encoder mode.

Parameters
hDevice | device handle
channel | counter input channel
zReloadEnabled | enable z signal. True: enabled; False: disabled.Valid only under encoder mode.
Returns
0 if success or other error code

◆ JY5325_CI_Start()

JY5325API int STDCALL JY5325_CI_Start | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned int | channel )

Start Counter input.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if success or other error code

◆ JY5325_CI_Stop()

JY5325API int STDCALL JY5325_CI_Stop | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned int | channel )

Stop Counter input.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if success or other error code

◆ JY5325_Close()

JY5325API int STDCALL JY5325_Close ( JY5325_DeviceHandle hDevice )

Close this 5611 board.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5325_CO_CheckBufferStatus()

JY5325API int STDCALL JY5325_CO_CheckBufferStatus | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned long * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun )

Check CO task buffer status.

Parameters
hDevice | device handle
channel | counter output channel
avaliableSamples | number of CO samples per channel user can write
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5325_CO_CheckCounterStatus()

JY5325API int STDCALL JY5325_CO_CheckCounterStatus | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int * | pulseTransfered,
 |  | bool * | underflow )

Check counter output status.

Parameters
hDevice | device handle
channel | counter output channel
pulseTransfered | The number of pulse that have been transfered
overrun | true:overflow, false:not overflow.
Returns
0 if success or other error code

◆ JY5325_CO_EnableChannel()

JY5325API int STDCALL JY5325_CO_EnableChannel | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned int | channel )

Enabled counter output channel.

Parameters
hDevice | device handle
channel | counter output channel
Returns
0 if success or other error code

◆ JY5325_CO_SendSoftTrigger()

JY5325API int STDCALL JY5325_CO_SendSoftTrigger | ( | JY5325_DeviceHandle | hDevice,
 |  | int | channel )

Send the software trigger signal.

Parameters
hDevice | device handle
channel | counter channel
Returns
0 if success or other error code

◆ JY5325_CO_SetCounterParament()

JY5325API int STDCALL JY5325_CO_SetCounterParament | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | int | pulseCount,
 |  | JY5325_CO_IdleState | IdleState,
 |  | double | delay )

Set CO parameter.

Parameters
hDevice | device handle
channel | counter output channel
pulseCount | counter output pulse number, if pulseCount = -1 ,the device always responds to output until the user stops it.
IdleState | counter output idle state
delay | counter output delay, unit:s. There are five ticks of the timebase fixed delay in counter internal, so the total delay(s) = delay + (5 / timebase)
Returns
0 if success or other error code

◆ JY5325_CO_SetDigitalStartTrigger()

JY5325API int STDCALL JY5325_CO_SetDigitalStartTrigger | ( | JY5325_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5325_DigitalTriggerSource | triggerSource,
 |  | JY5325_DigitalTriggerEdge | triggerEdge )

Set CO digital start trigger,the triggerSource is defined by enum JY5325_DigitalTriggerSource, the triggerEdge is defined by enum JY5325_DigitalTriggerEdge.

Parameters
hDevice | device handle
channel | counter channel
triggerSource | CO digital start trigger source
triggerEdge | CO digital start trigger edge. Options: rising or falling edge.
Returns
0 if success or other error code

◆ JY5325_CO_SetFrequency()

JY5325API int STDCALL JY5325_CO_SetFrequency | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int | highTicks,
 |  | unsigned int | lowTicks )

Set counter output pulse frequency,After the output starts, you can call this interface to modify the pulse frequency in real time.

Parameters
hDevice | device handle
channel | counter output channel
highTicks | the number of ticks for the high pulse, default:timebase is 100MHz.
lowTicks | the number of ticks for the low pulse, default:timebase is 100MHz.
Returns
0 if success or other error code

◆ JY5325_CO_SetMode()

JY5325API int STDCALL JY5325_CO_SetMode | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5325_CO_OutMode | mode )

Set counter output mode, the mode defined by enum JY5325_CO_UpdateMode.

Parameters
hDevice | device handle
mode | CO mode.Options: Single,Finite,ContinuousWrapping,ContinuousNoWrapping mode.
Returns
0 if success or other error code

◆ JY5325_CO_SetOutTerminal()

JY5325API int STDCALL JY5325_CO_SetOutTerminal | ( | JY5325_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5325_Signal_Destination | outTerminal )

Set out terminal.

Parameters
hDevice | device handle
channel | counter output channel
outTerminal | source terminal
Returns
0 if success or other error code

◆ JY5325_CO_SetPauseTriggerLevel()

JY5325API int STDCALL JY5325_CO_SetPauseTriggerLevel | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool | enable,
 |  | JY5325_LevelState | pauseTriggerActiveLevel )

Config CO pause trigger.

Parameters
hDevice | Device handle
channel | Counter channel
enable | Enable pasue trigger
pauseTriggerActiveLevel | Pause trigger active level.
Returns
Succeed: 0 , Error: !=0

◆ JY5325_CO_SetPauseTriggerTerminal()

JY5325API int STDCALL JY5325_CO_SetPauseTriggerTerminal | ( | JY5325_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5325_InputTerminal | pauseTriggerTerminal )

Set CO Pause Trigger Terminal.

Parameters
hDevice | device handle
channel | counter output channel
pauseTriggerTerminal | pause Trigge terminal
Returns
0 if success or other error code

◆ JY5325_CO_SetSamplesToUpdate()

JY5325API int STDCALL JY5325_CO_SetSamplesToUpdate | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int | samplesToUpdate )

Set CO samples for each channel in the finite mode.The sample range is from 1 to 4M samples.

Parameters
hDevice | device handle
channel | counter output channel
sampleToUpdate | number of CO samples per channel. Data range:1 to 4M samples.
Returns
0 if success or other error code

◆ JY5325_CO_SetStartTriggerType()

JY5325API int STDCALL JY5325_CO_SetStartTriggerType | ( | JY5325_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY5325_CIO_TriggerType | triggerTyp )

Set CO start trigger type,the triggerType is defined by enum JY5325_AI_TriggerType.

Parameters
hDevice | device handle
channel | counter channel
triggerType | CO start trigger type. Options:immediate trigger, software trigger, digital trigger.
Returns
0 if success or other error code

◆ JY5325_CO_SetTimeBase()

JY5325API int STDCALL JY5325_CO_SetTimeBase | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY5325_CountTimeBase | timebaseSrc,
 |  | JY5325_InputTerminal | externalTimebaseTerminal,
 |  | double | externalTimebaseFreq,
 |  | double * | actualTimebaseFreq )

Set CO timebase source.

Parameters
hDevice | device handle
channel | counter channel
timebaseSrc | counter time base source.defined by emun JY5325_CountTimeBase.Options:JY5325_TimeBase_100M
externalTimebaseTerminal | counter external time base terminal.defined by emun JY5325_InputTerminal.
externalTimebaseFreq | counter external time base frequency.
actualTimebaseFreq | counter actual time base frequency.
Returns
0 if success or other error code

◆ JY5325_CO_Start()

JY5325API int STDCALL JY5325_CO_Start | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned int | channel )

Start counter output.

Parameters
hDevice | device handle
channel | counter output channel
Returns
0 if success or other error code

◆ JY5325_CO_Stop()

JY5325API int STDCALL JY5325_CO_Stop | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned int | channel )

Stop counter output.

Parameters
hDevice | device handle
channel | counter output channel
Returns
0 if success or other error code

◆ JY5325_CO_WaitUntilDone()

JY5325API int STDCALL JY5325_CO_WaitUntilDone | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool * | done )

Check counter output complete status.

Parameters
hDevice | device handle
channel | counter output channel
done | true :counter output complete, false:counter output not complete
Returns
0 if success or other error code

◆ JY5325_CO_WriteData()

JY5325API int STDCALL JY5325_CO_WriteData | ( | JY5325_DeviceHandle | hDevice,
 |  | int | channel,
 |  | unsigned int * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualWriteLength )

CO write data.One sampling point consists of three datas, high level ticks, low level ticks, and number of pulses.

Parameters
hDevice | device handle
channel | counter output channel
dataBuffer | user buffer, the buffer size must be greater than or equal to dataLength*3.
dataLength | length of pulse output
timeOut | timeout time in microsecond
actualWriteLength | the number of samples per channel actually write
Returns
0 if success or other error code

◆ JY5325_DI_AddLines()

JY5325API int STDCALL JY5325_DI_AddLines | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned int * | line,
 |  | unsigned int | lineCount )

Enabled DI channels.

Parameters
hDevice | device handle
line | array[lineCount] containing line IDs
lineCount | number of lines to be enabled
Returns
0 if success or other error code

◆ JY5325_DI_CheckBufferStatus()

JY5325API int STDCALL JY5325_DI_CheckBufferStatus | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned long long * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun )

Check DI device buffer status.

Parameters
hDevice | device handle
avaliableSamples | number of samples per channel in the device buffer
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5325_DI_CheckBufferStatusEx()

JY5325API int STDCALL JY5325_DI_CheckBufferStatusEx | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned long long * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun )

Check DI device buffer status.

Parameters
hDevice | device handle
avaliableSamples | number of samples per channel in the device buffer
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5325_DI_ReadData()

JY5325API int STDCALL JY5325_DI_ReadData | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned char * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength )

Read DI data.

The data type is uchar. There are a total of 8 lines from 0 to 7. Each bit from low to high represents one line.

Parameters
hDevice | device handle
dataBuffer | user buffer, the size of dataBuffer must be greater than or equal to dataLength.
dataLength | number of samples per channel
timeOut | timeout time in microsecond
actualReadLength | the actual length of the data read
Returns
0 if success or other error code

The data type is uint. There are 2 ports(0~3)for 5312 and 5315, Each port has 8 lines, from 0 to 7. There are a total of 32 lines from 0 to 31. Each bit from low to high represents one line.

Parameters
hDevice | device handle
dataBuffer | user buffer, the size of dataBuffer must be greater than or equal to dataLength.
dataLength | number of samples per channel
timeOut | timeout time in microsecond
actualReadLength | the actual length of the data read
Returns
0 if success or other error code

◆ JY5325_DI_ReadSinglePoint()

JY5325API int STDCALL JY5325_DI_ReadSinglePoint | ( | JY5325_DeviceHandle | hDevice,
 |  | bool * | readValues,
 |  | int | lineID )

Read DI single point.The data type is bool.

one bool defined one line status.

Parameters
hDevice | device handle
readValues | read the specified line value. when the lineID is -1, read all enabled lines values,the readValues Length must equal to lineCount(In function JY5325_DI_AddLines defined), and the values store in the add order of lines.
lineID | line number
Returns
0 if success or other error code

◆ JY5325_DI_ReadSinglePoint_U8()

JY5325API int STDCALL JY5325_DI_ReadSinglePoint_U8 | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned char * | readValue )

Read DI single point.The data type is uchar.

There are 8 lines from 0 to 7. Each bit represents one line.

Parameters
hDevice device handle
readValue read all port values. each bit from low to high represents one line.
Returns
0 if success or other error code

◆ JY5325_DI_SendSoftTrigger()

JY5325API int STDCALL JY5325_DI_SendSoftTrigger | ( | JY5325_DeviceHandle | hDevice,
 |  | JY5325_TriggerMode | triggerMode )

Send the software trigger signal.

Parameters
hDevice | device handle
triggerMode | software trigger mode. Options: start trigger or reference trigger
Returns
0 if success or other error code

◆ JY5325_DI_SetDigitalReferenceTrigger()

JY5325API int STDCALL JY5325_DI_SetDigitalReferenceTrigger | ( | JY5325_DeviceHandle | hDevice,
 |  | JY5325_DigitalTriggerSource | triggerSource,
 |  | JY5325_DigitalTriggerEdge | triggerEdge )

Set AI digital reference trigger,the triggerSource is defined by enum JY5325_DigitalTriggerSource, the triggerEdge is defined by enum JY5325_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | DI reference trigger source
triggerEdge | DI reference to the trigger edge. Options: rising or falling edge
Returns
0 if success or other error code

◆ JY5325_DI_SetDigitalStartTrigger()

JY5325API int STDCALL JY5325_DI_SetDigitalStartTrigger | ( | JY5325_DeviceHandle | hDevice,
 |  | JY5325_DigitalTriggerSource | triggerSource,
 |  | JY5325_DigitalTriggerEdge | triggerEdge )

Set DI digital start trigger,the triggerSource is defined by enum JY5325_DigitalTriggerSource, the triggerEdge is defined by enum JY5325_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | DI digital start trigger source
triggerEdge | DI digital start trigger edge. Options: rising or falling edge
Returns
0 if success or other error code

◆ JY5325_DI_SetMode()

JY5325API int STDCALL JY5325_DI_SetMode | ( | JY5325_DeviceHandle | hDevice,
 |  | JY5325_DI_SampleMode | mode )

Set DI sampling mode.The mode defined by enum JY5325_DI_SampleMode.

Parameters
hDevice | device handle
mode | DI sampling mode.Options: single,finite,continuous.
Returns
0 if success or other error code

◆ JY5325_DI_SetPreTriggerSamples()

JY5325API int STDCALL JY5325_DI_SetPreTriggerSamples | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned int | preTriggerSamples )

Set DI pretrigger samples, the samples must greater than 0.

Parameters
hDevice | device handle
preTriggerSamples | DI pretrigger samples, valid only in reference trigger mode.
Returns
0 if success or other error code

◆ JY5325_DI_SetReferenceTriggerType()

JY5325API int STDCALL JY5325_DI_SetReferenceTriggerType | ( | JY5325_DeviceHandle | hDevice,
 |  | JY5325_DI_TriggerType | triggerType )

Set DI reference trigger type,the triggerType is defined by enum JY5325_DI_TriggerType.

Parameters
hDevice | device handle
triggerType | DI reference trigger type. Options: immediate trigger, software trigger, digital trigger or analog trigger.
Returns
0 if success or other error code

◆ JY5325_DI_SetSampleClock()

JY5325API int STDCALL JY5325_DI_SetSampleClock | ( | JY5325_DeviceHandle | hDevice,
 |  | JY5325_ClockSource | clockSource,
 |  | JY5325_ExternalClockTerminal | terminal,
 |  | double | expectedRate )

Set DI sampling clock source.

the source of the sampling clock defined by enum JY5325_ClockSource If the clock source is external, need to configure external clock terminal and external clock frequency..

Parameters
hDevice | device handle
clockSource | DI sampling clock source
terminal | external clock terminal,defined by enum JY5325_ExternalClockTerminal.
expectedRate | external clock frequency
Returns
0 if success or other error code

◆ JY5325_DI_SetSampleRate()

JY5325API int STDCALL JY5325_DI_SetSampleRate | ( | JY5325_DeviceHandle | hDevice,
 |  | double | sampleRate,
 |  | double * | actualSampleRate )

Set DI sampling rate.

The sampling rate is the same for all channels.

Parameters
hDevice | device handle
sampleRate | DI sampling rate to be set per channel
actualSampleRate | actually set DI sampling rate.actual sampling rate set by this device,which may be different from the desired sampleRate.
Returns
0 if success or other error code

◆ JY5325_DI_SetSamplesToAcquire()

JY5325API int JY5325_DI_SetSamplesToAcquire | ( | JY5325_DeviceHandle | hDevice,
 |  | int | samplesToAcquire )

Set DI samples to acquire for each channel in finite mode.The samples range is 1 to 16M samples.

Parameters
hDevice | device handle
samplesToAcquire | DI finite samples to acquire for each channelsamples range:1 to 16M samples
Returns
0 if success or other error code

◆ JY5325_DI_SetStartTriggerType()

JY5325API int STDCALL JY5325_DI_SetStartTriggerType | ( | JY5325_DeviceHandle | hDevice,
 |  | JY5325_DI_TriggerType | triggerType )

Set DI start trigger type,the triggerType is defined by enum JY5325_DI_TriggerType.

Parameters
hDevice | device handle
triggerType | DI start trigger type. Options: immediate trigger, software trigger, digital trigger.
Returns
0 if success or other error code

◆ JY5325_DI_Start()

JY5325API int STDCALL JY5325_DI_Start ( JY5325_DeviceHandle hDevice )

Start DI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5325_DI_Stop()

JY5325API int STDCALL JY5325_DI_Stop ( JY5325_DeviceHandle hDevice )

Stop DI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5325_DI_WaitUntilDone()

JY5325API int STDCALL JY5325_DI_WaitUntilDone | ( | JY5325_DeviceHandle | hDevice,
 |  | bool * | done )

Check if DI acquisition is completed in finite mode.

Parameters
hDevice | device handle
done | true if completed, false if not yet completed.
Returns
0 if success or other error code

◆ JY5325_DisableAICalibration()

JY5325API int STDCALL JY5325_DisableAICalibration | ( | JY5325_DeviceHandle | hDevice,
 |  | bool | DisableCalibration )

Disable AI calibration coefficient, default false.

Parameters
hDevice | device handle
DisableCalibration | true if disabled, false if not disabled.
Returns
0 if success or other error code

◆ JY5325_DisableAOCalibration()

JY5325API int STDCALL JY5325_DisableAOCalibration | ( | JY5325_DeviceHandle | hDevice,
 |  | bool | DisableCalibration )

Disable AO calibration coefficient, default enable calibration coefficient.

Parameters
hDevice | device handle
DisableCalibration | true if disabled, false if not disabled.
Returns
0 if success or other error code

◆ JY5325_DisconnectSignalRouting()

JY5325API int STDCALL JY5325_DisconnectSignalRouting | ( | JY5325_DeviceHandle | hDevice,
 |  | JY5325_Signal_Destination | destination )

Disconnect an established routing.

Parameters
hDevice | device handle
destination | destination of the signal defined by enum JY5325_DestinationSignal
Returns
0 if success or other error code

◆ JY5325_DO_AddLines()

JY5325API int STDCALL JY5325_DO_AddLines | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned int * | line,
 |  | unsigned int | lineCount )

Enabled DO channels.

Parameters
hDevice | device handle
line | array[lineCount] containing line IDs.
lineCount | number of lines to be enabled
Returns
0 if success or other error code

◆ JY5325_DO_CheckBufferStatus()

JY5325API int STDCALL JY5325_DO_CheckBufferStatus | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned long * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun )

Check DO device buffer status.

Parameters
hDevice | device handle
avaliableSamples | number of samples that the buffer can write
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY5325_DO_SendSoftTrigger()

JY5325API int STDCALL JY5325_DO_SendSoftTrigger ( JY5325_DeviceHandle hDevice )

Send the software trigger signal.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5325_DO_SetDigitalStartTrigger()

JY5325API int STDCALL JY5325_DO_SetDigitalStartTrigger | ( | JY5325_DeviceHandle | hDevice,
 |  | JY5325_DigitalTriggerSource | triggerSource,
 |  | JY5325_DigitalTriggerEdge | triggerEdge )

Set DO digital start trigger,the triggerSource is defined by enum JY5325_DigitalTriggerSource, the triggerEdge is defined by enum JY5325_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | DO digital start trigger source
triggerEdge | DO digital start trigger edge. Options: rising or falling edge.
Returns
0 if success or other error code

◆ JY5325_DO_SetMode()

JY5325API int STDCALL JY5325_DO_SetMode | ( | JY5325_DeviceHandle | hDevice,
 |  | JY5325_DO_UpdateMode | mode )

Set digital signal output mode, the mode defined by enum JY5325_AO_UpdateMode.

Parameters
hDevice | device handle
mode | DO output mode.Options: Single,Finite,ContinuousWrapping,ContinuousNoWrapping mode.
Returns
0 if success or other error code

◆ JY5325_DO_SetSampleClock()

JY5325API int STDCALL JY5325_DO_SetSampleClock | ( | JY5325_DeviceHandle | hDevice,
 |  | JY5325_ClockSource | clockSource,
 |  | JY5325_ExternalClockTerminal | terminal,
 |  | double | expectedRate )

Set DO sampling clock source.

the source of the sampling clock defined by enum JY5325_ClockSource. If the clock source is external, need to configure external clock terminal and external clock frequency.

Parameters
hDevice | device handle
clockSource | DO sampling clock source
terminal | external terminal, defined by enum JY5325_ExternalClockTerminal
expectedRate | DO external clock frequency

◆ JY5325_DO_SetSamplesToUpdate()

JY5325API int JY5325_DO_SetSamplesToUpdate | ( | JY5325_DeviceHandle | hDevice,
 |  | int | samplesToUpdate )

Set digital signal output samples for each channel in finite mode.The samples range is 1 to 64M samples.

Set digital signal output samples for each channel in finite mode.The samples range is 1 to 16M samples.

128M bytes buffer

Parameters
hDevice | device handle
sampleToUpdate | DO finite output samples, data range:1 to 64M sample.
Returns
0 if success or other error code
Parameters
hDevice | device handle
sampleToUpdate | DO finite output samples, data range:1 to 16M sample.
Returns
0 if success or other error code

◆ JY5325_DO_SetStartTriggerType()

JY5325API int STDCALL JY5325_DO_SetStartTriggerType | ( | JY5325_DeviceHandle | hDevice,
 |  | JY5325_DO_TriggerType | triggerType )

Set DO start trigger type,the triggerType is defined by enum JY5325_DO_TriggerType.

Parameters
hDevice | device handle
triggerType | DO start trigger type. Options: immediate trigger, software trigger, digital trigger.
Returns
0 if success or other error code

◆ JY5325_DO_SetUpdateRate()

JY5325API int STDCALL JY5325_DO_SetUpdateRate | ( | JY5325_DeviceHandle | hDevice,
 |  | double | sampleRate,
 |  | double * | actualSampleRate )

Set DO update rate.The update rate is the same for all channels.

Parameters
hDevice | device handle
sampleRate | DO update rate to be set per channel
actualSampleRate | actually set DO update rate,actual update rate set by this device,which may be different from the desired updata rate.
Returns
0 if success or other error code

◆ JY5325_DO_Start()

JY5325API int STDCALL JY5325_DO_Start ( JY5325_DeviceHandle hDevice )

Start digital signal output.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5325_DO_Stop()

JY5325API int STDCALL JY5325_DO_Stop ( JY5325_DeviceHandle hDevice )

Stop digital signal output.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY5325_DO_WaitUntilDone()

JY5325API int STDCALL JY5325_DO_WaitUntilDone | ( | JY5325_DeviceHandle | hDevice,
 |  | bool * | done,
 |  | int | timeOut )

Check finite digital signal output is complete.

Parameters
hDevice | device handle
done | true if completed, false if not yet completed.
timeOut | timeout time in microsecond,this parament not valid in current version
Returns
0 if success or other error code

◆ JY5325_DO_WriteData()

JY5325API int STDCALL JY5325_DO_WriteData | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned char * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualWriteLength )

DO write data.The data type is uchar.

There are a total of 8 lines from 0 to 7. Each bit from low to high represents one line.

Parameters
hDevice | device handle
dataBuffer | user buffer,the buffer size must be greater than or equal to dataLength.
dataLength | number of samples per channel
timeOut | timeout time in microsecond
actualWriteLength | Return value, the actual length of the data write
Returns
0 if success or other error code

◆ JY5325_DO_WriteSinglePoint()

JY5325API int STDCALL JY5325_DO_WriteSinglePoint | ( | JY5325_DeviceHandle | hDevice,
 |  | bool * | writeValues,
 |  | int | lineID )

Write DO single point.The data type is bool.

one bool defined one line status.

Parameters
hDevice | device handle
writeValues | write the specified line value. when the lineID is -1, write all enabled lines values,the writeValues Length must equal to lineCount(In function JY5325_DO_AddLines defined), and the values store in the add order of lines.
lineID | line number
Returns
0 if success or other error code

◆ JY5325_DO_WriteSinglePoint_U8()

JY5325API int STDCALL JY5325_DO_WriteSinglePoint_U8 | ( | JY5325_DeviceHandle | hDevice,
 |  | unsigned char | writeValue )

Write DO single point.The data type is uchar.

There are 8 lines, from 0 to 7. Each bit represents one line.

Parameters
hDevice device handle
writeValue wirte the all port values. each bit from low to high represents one line.
Returns
0 if success or other error code

◆ JY5325_GetDeviceID()

JY5325API int STDCALL JY5325_GetDeviceID | ( | JY5325_DeviceHandle | hDevice,
 |  | int * | deviceID )

Obtain the board ID.

The 5611 is a series of boards. The PXIe-5315 board ID is Ox5315, PXIe-5312 board ID is Ox5312. The PCIe-5515 board ID is OxA315, PCIe-5312 board ID is OxA312.

Parameters
hDevice | device handle
deviceID | board ID
Returns
0 if success or other error code

◆ JY5325_GetDeviceSerialNumber()

JY5325API int STDCALL JY5325_GetDeviceSerialNumber | ( | JY5325_DeviceHandle | hDevice,
 |  | char * | serialNumber,
 |  | int | length )

Obtain the device serialNumber.

Parameters
hDevice | device handle
serialNumber | Pointer to a buffer receiving the serial number. The length of the serial number is 10.
length | serial Number length ,length is 10
Returns
0 if success or other error code

◆ JY5325_Open()

JY5325API int STDCALL JY5325_Open | ( | int | slotNumber,
 |  | JY5325_DeviceHandle * | hDevice )

Open the 5611 series boards using the slot number or the board serial number.

PXIe slot number is predefined by the PXIe chassis. PCIe slot number is defined by the DIP switch. The board serial number is defined by the system starting from 0. It's your responsibility to know the number. For a single board, the serial number is 0.

Parameters
slotNumber | slot number or board serial number
hDevice | device handle. All other functions uses hDevice to represent this device.
Returns
0 if success or other error code

◆ JY5325_OpenByAliasName()

JY5325API int STDCALL JY5325_OpenByAliasName | ( | const char * | aliasName,
 |  | JY5325_DeviceHandle * | hDevice )

Open this 5611 series boards using the board alias name which is set by JYTEK utility JYDM.

You can change the name using JYDM.

Parameters
cardName | board alias name
hDevice | device handle
Returns
0 if success or other error code

◆ JY5325_ReadRegister()

JY5325API int STDCALL JY5325_ReadRegister | ( | JY5325_DeviceHandle | hDevice,
 |  | int | offset,
 |  | int * | data )

read the register from fpga logic

Parameters
hDevice | device handle
offset | register offset
data | data value
Returns
0 if success or other error code

◆ JY5325_SetDeviceProperty()

JY5325API int STDCALL JY5325_SetDeviceProperty | ( | JY5325_DeviceHandle | hDevice,
 |  | JY5325_DeviceProperty | devicePrepety )

Set Device Property,this API must be used in Sync function.

Parameters
hDevice | device handle
devicePrepety | defined by enum JY5325_DeviceProperty
Returns
0 if success or other error code

◆ JY5325_SetDeviceReferenceClock()

JY5325API int STDCALL JY5325_SetDeviceReferenceClock | ( | JY5325_DeviceHandle | hDevice,
 |  | JY5325_ReferenceClock | clockSource )

Set Reference Clock for the device.There are two ReferenceClock, 25MHz from this device or 100MHz from the PXIe chassis.

PCIe device only supports 25MHz timebase.

Parameters
hDevice | device handle
clkSource | ReferenceClock source defined by enum JY5325_ReferenceClock
Returns
0 if success or other error code

◆ JY5325_SetDeviceStatusLed()

JY5325API int STDCALL JY5325_SetDeviceStatusLed | ( | JY5325_DeviceHandle | hDevice,
 |  | bool | enable,
 |  | unsigned int | frequency )

Control Front Panel Status Led.

Parameters
hDevice | device handle
enable | enable front panel status led blink, true: blink, false: not blink
frequency | when enable is ture, the led blink speed by frequency define
Returns
0 if success or other error code

◆ JY5325_SignalRouting()

JY5325API int STDCALL JY5325_SignalRouting | ( | JY5325_DeviceHandle | hDevice,
 |  | JY5325_Signal_Source | sourceSignal,
 |  | JY5325_Signal_Destination | distination )

Route a singal from source to destination.

Both source and destination are defined by the corresponding enum Y5500_SourceSignal and JY5325_DestinationSignal. One source signal may be routed to multiple destinations.

Parameters
hDevice | device handle
source | source of the signal defined by enum JY5325_SourceSignal
destination | destination of the signal defined by enum JY5325_DestinationSignal
Returns
0 if success or other error code

◆ JY5325_WriteRegister()

JY5325API int STDCALL JY5325_WriteRegister | ( | JY5325_DeviceHandle | hDevice,
 |  | int | offset,
 |  | int | data )

write the register to fpga logic

Parameters
hDevice | device handle
offset | register offset
data | data value
Returns
0 if success or other error code
Generated by doxygen 1.12.0


5325 C++ Programming Manual: D:/5325/C++ Directory Reference

  • 5325
  • C++
C++ Directory Reference

Files

JY5325.h
@SectionBegin JY5325FileHead


5325 C++ Programming Manual: D:/5325 Directory Reference

  • 5325
5325 Directory Reference

Directories

C++


5325 C++ Programming Manual: File List

File List
Here is a list of all files with brief descriptions:
[detail level 123]
▼ 5325 |
▼ C++ |
JY5325.h | @SectionBegin JY5325FileHead


5325 C++ Programming Manual: File Members

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • j
Here is a list of all file members with links to the files they belong to:

- j -

  • JY5325_AI_Analog : JY5325.h
  • JY5325_AI_CheckBufferStatus() : JY5325.h
  • JY5325_AI_Continuous : JY5325.h
  • JY5325_AI_Digital : JY5325.h
  • JY5325_AI_EnableChannel() : JY5325.h
  • JY5325_AI_Finite : JY5325.h
  • JY5325_AI_Immediately : JY5325.h
  • JY5325_AI_ReadData() : JY5325.h
  • JY5325_AI_ReadRawData() : JY5325.h
  • JY5325_AI_SampleMode : JY5325.h
  • JY5325_AI_SendSoftTrigger() : JY5325.h
  • JY5325_AI_SetAnalogEdgeReferenceTrigger() : JY5325.h
  • JY5325_AI_SetAnalogEdgeStartTrigger() : JY5325.h
  • JY5325_AI_SetAnalogHysteresisReferenceTrigger() : JY5325.h
  • JY5325_AI_SetAnalogHysteresisStartTrigger() : JY5325.h
  • JY5325_AI_SetAnalogWindowReferenceTrigger() : JY5325.h
  • JY5325_AI_SetAnalogWindowStartTrigger() : JY5325.h
  • JY5325_AI_SetDigitalReferenceTrigger() : JY5325.h
  • JY5325_AI_SetDigitalStartTrigger() : JY5325.h
  • JY5325_AI_SetMode() : JY5325.h
  • JY5325_AI_SetPreTriggerSamples() : JY5325.h
  • JY5325_AI_SetReferenceTriggerType() : JY5325.h
  • JY5325_AI_SetReTriggerCount() : JY5325.h
  • JY5325_AI_SetSampleClock() : JY5325.h
  • JY5325_AI_SetSampleRate() : JY5325.h
  • JY5325_AI_SetSamplesToAcquire() : JY5325.h
  • JY5325_AI_SetStartTriggerType() : JY5325.h
  • JY5325_AI_Soft : JY5325.h
  • JY5325_AI_Start() : JY5325.h
  • JY5325_AI_Stop() : JY5325.h
  • JY5325_AI_TriggerType : JY5325.h
  • JY5325_AI_WaitUntilDone() : JY5325.h
  • JY5325_AnalogTriggerEdge : JY5325.h
  • JY5325_AnalogTriggerSource : JY5325.h
  • JY5325_AnalogWindowCondition : JY5325.h
  • JY5325_AnyEdge : JY5325.h
  • JY5325_AO_CheckBufferStatus() : JY5325.h
  • JY5325_AO_ContinuousNoWrapping : JY5325.h
  • JY5325_AO_ContinuousWrapping : JY5325.h
  • JY5325_AO_Digital : JY5325.h
  • JY5325_AO_EnableChannel() : JY5325.h
  • JY5325_AO_Finite : JY5325.h
  • JY5325_AO_Immediately : JY5325.h
  • JY5325_AO_SendSoftTrigger() : JY5325.h
  • JY5325_AO_SetDigitalStartTrigger() : JY5325.h
  • JY5325_AO_SetMode() : JY5325.h
  • JY5325_AO_SetOutputCompleteState() : JY5325.h
  • JY5325_AO_SetSampleClock() : JY5325.h
  • JY5325_AO_SetSamplesToUpdate() : JY5325.h
  • JY5325_AO_SetStartTriggerType() : JY5325.h
  • JY5325_AO_SetUpdateRate() : JY5325.h
  • JY5325_AO_Single : JY5325.h
  • JY5325_AO_Soft : JY5325.h
  • JY5325_AO_Start() : JY5325.h
  • JY5325_AO_Stop() : JY5325.h
  • JY5325_AO_TriggerType : JY5325.h
  • JY5325_AO_UpdateMode : JY5325.h
  • JY5325_AO_WaitUntilDone() : JY5325.h
  • JY5325_AO_WriteData() : JY5325.h
  • JY5325_AO_WriteRawData() : JY5325.h
  • JY5325_AO_WriteRawSinglePoint() : JY5325.h
  • JY5325_AO_WriteSinglePoint() : JY5325.h
  • JY5325_Channel_0 : JY5325.h
  • JY5325_Channel_1 : JY5325.h
  • JY5325_Channel_2 : JY5325.h
  • JY5325_Channel_3 : JY5325.h
  • JY5325_Channel_4 : JY5325.h
  • JY5325_Channel_5 : JY5325.h
  • JY5325_Channel_6 : JY5325.h
  • JY5325_Channel_7 : JY5325.h
  • JY5325_CI_CheckBufferStatus() : JY5325.h
  • JY5325_CI_Continuous : JY5325.h
  • JY5325_CI_Count_Down : JY5325.h
  • JY5325_CI_Count_External : JY5325.h
  • JY5325_CI_Count_Up : JY5325.h
  • JY5325_CI_CounterEventSignalIdleState : JY5325.h
  • JY5325_CI_CounterEventSignalIdleState_High : JY5325.h
  • JY5325_CI_CounterEventSignalIdleState_Low : JY5325.h
  • JY5325_CI_EdgeCount : JY5325.h
  • JY5325_CI_EnableChannel() : JY5325.h
  • JY5325_CI_EncoderTwoPulse : JY5325.h
  • JY5325_CI_EncoderX1 : JY5325.h
  • JY5325_CI_EncoderX2 : JY5325.h
  • JY5325_CI_EncoderX4 : JY5325.h
  • JY5325_CI_ExternalClock : JY5325.h
  • JY5325_CI_Finite : JY5325.h
  • JY5325_CI_ImplicitClock : JY5325.h
  • JY5325_CI_InternalClock : JY5325.h
  • JY5325_CI_Measure_EdgeSeparation : JY5325.h
  • JY5325_CI_Measure_FrequencyOrPeriod : JY5325.h
  • JY5325_CI_Measure_PulseWidth : JY5325.h
  • JY5325_CI_Measure_SemiPeriod : JY5325.h
  • JY5325_CI_MeasureType : JY5325.h
  • JY5325_CI_ReadCountValues() : JY5325.h
  • JY5325_CI_ReadMeasureValues() : JY5325.h
  • JY5325_CI_ReadSingleCountValue() : JY5325.h
  • JY5325_CI_ReadSingleMeasureValue() : JY5325.h
  • JY5325_CI_ReturnOneValue : JY5325.h
  • JY5325_CI_ReturnTwoValue : JY5325.h
  • JY5325_CI_SampleClock : JY5325.h
  • JY5325_CI_SampleMode : JY5325.h
  • JY5325_CI_SendSoftTrigger() : JY5325.h
  • JY5325_CI_SetAuxTerminal() : JY5325.h
  • JY5325_CI_SetCounterParament() : JY5325.h
  • JY5325_CI_SetCounterType() : JY5325.h
  • JY5325_CI_SetDigitalStartTrigger() : JY5325.h
  • JY5325_CI_SetEdgeCountEvent() : JY5325.h
  • JY5325_CI_SetFirstSampleClock() : JY5325.h
  • JY5325_CI_SetGateTerminal() : JY5325.h
  • JY5325_CI_SetMode() : JY5325.h
  • JY5325_CI_SetOutTerminal() : JY5325.h
  • JY5325_CI_SetPauseTriggerLevel() : JY5325.h
  • JY5325_CI_SetPauseTriggerTerminal() : JY5325.h
  • JY5325_CI_SetSampleClock() : JY5325.h
  • JY5325_CI_SetSamplesToAcquire() : JY5325.h
  • JY5325_CI_SetSignalReverse() : JY5325.h
  • JY5325_CI_SetSourceTerminal() : JY5325.h
  • JY5325_CI_SetStartingEdge() : JY5325.h
  • JY5325_CI_SetStartTriggerType() : JY5325.h
  • JY5325_CI_SetTimeBase() : JY5325.h
  • JY5325_CI_SetValueReturnMode() : JY5325.h
  • JY5325_CI_SetZReloadEnabled() : JY5325.h
  • JY5325_CI_Single : JY5325.h
  • JY5325_CI_Start() : JY5325.h
  • JY5325_CI_StartingEdge : JY5325.h
  • JY5325_CI_Stop() : JY5325.h
  • JY5325_CI_ValueReturnMode : JY5325.h
  • JY5325_CIO_Digital : JY5325.h
  • JY5325_CIO_Immediately : JY5325.h
  • JY5325_CIO_Soft : JY5325.h
  • JY5325_CIO_TriggerType : JY5325.h
  • JY5325_Clock_PFI_0 : JY5325.h
  • JY5325_Clock_PFI_1 : JY5325.h
  • JY5325_Clock_PFI_2 : JY5325.h
  • JY5325_Clock_PFI_3 : JY5325.h
  • JY5325_Clock_PFI_4 : JY5325.h
  • JY5325_Clock_PFI_5 : JY5325.h
  • JY5325_Clock_PFI_6 : JY5325.h
  • JY5325_Clock_PFI_7 : JY5325.h
  • JY5325_Clock_PXI_Trig_0 : JY5325.h
  • JY5325_Clock_PXI_Trig_1 : JY5325.h
  • JY5325_Clock_PXI_Trig_2 : JY5325.h
  • JY5325_Clock_PXI_Trig_3 : JY5325.h
  • JY5325_Clock_PXI_Trig_4 : JY5325.h
  • JY5325_Clock_PXI_Trig_5 : JY5325.h
  • JY5325_Clock_PXI_Trig_6 : JY5325.h
  • JY5325_Clock_PXI_Trig_7 : JY5325.h
  • JY5325_ClockSource : JY5325.h
  • JY5325_Close() : JY5325.h
  • JY5325_CO_CheckBufferStatus() : JY5325.h
  • JY5325_CO_CheckCounterStatus() : JY5325.h
  • JY5325_CO_ContinuousNoWrapping : JY5325.h
  • JY5325_CO_ContinuousWrapping : JY5325.h
  • JY5325_CO_EnableChannel() : JY5325.h
  • JY5325_CO_Finite : JY5325.h
  • JY5325_CO_HighLevel : JY5325.h
  • JY5325_CO_IdleState : JY5325.h
  • JY5325_CO_LowLevel : JY5325.h
  • JY5325_CO_OutMode : JY5325.h
  • JY5325_CO_SendSoftTrigger() : JY5325.h
  • JY5325_CO_SetCounterParament() : JY5325.h
  • JY5325_CO_SetDigitalStartTrigger() : JY5325.h
  • JY5325_CO_SetFrequency() : JY5325.h
  • JY5325_CO_SetMode() : JY5325.h
  • JY5325_CO_SetOutTerminal() : JY5325.h
  • JY5325_CO_SetPauseTriggerLevel() : JY5325.h
  • JY5325_CO_SetPauseTriggerTerminal() : JY5325.h
  • JY5325_CO_SetSamplesToUpdate() : JY5325.h
  • JY5325_CO_SetStartTriggerType() : JY5325.h
  • JY5325_CO_SetTimeBase() : JY5325.h
  • JY5325_CO_Single : JY5325.h
  • JY5325_CO_Start() : JY5325.h
  • JY5325_CO_Stop() : JY5325.h
  • JY5325_CO_WaitUntilDone() : JY5325.h
  • JY5325_CO_WriteData() : JY5325.h
  • JY5325_CountDirection : JY5325.h
  • JY5325_CountTimeBase : JY5325.h
  • JY5325_DeviceHandle : JY5325.h
  • JY5325_DeviceProperty : JY5325.h
  • JY5325_DI_AddLines() : JY5325.h
  • JY5325_DI_CheckBufferStatus() : JY5325.h
  • JY5325_DI_CheckBufferStatusEx() : JY5325.h
  • JY5325_DI_Continuous : JY5325.h
  • JY5325_DI_Digital : JY5325.h
  • JY5325_DI_Finite : JY5325.h
  • JY5325_DI_Immediately : JY5325.h
  • JY5325_DI_ReadData() : JY5325.h
  • JY5325_DI_ReadSinglePoint() : JY5325.h
  • JY5325_DI_ReadSinglePoint_U8() : JY5325.h
  • JY5325_DI_SampleMode : JY5325.h
  • JY5325_DI_SendSoftTrigger() : JY5325.h
  • JY5325_DI_SetDigitalReferenceTrigger() : JY5325.h
  • JY5325_DI_SetDigitalStartTrigger() : JY5325.h
  • JY5325_DI_SetMode() : JY5325.h
  • JY5325_DI_SetPreTriggerSamples() : JY5325.h
  • JY5325_DI_SetReferenceTriggerType() : JY5325.h
  • JY5325_DI_SetSampleClock() : JY5325.h
  • JY5325_DI_SetSampleRate() : JY5325.h
  • JY5325_DI_SetSamplesToAcquire() : JY5325.h
  • JY5325_DI_SetStartTriggerType() : JY5325.h
  • JY5325_DI_Single : JY5325.h
  • JY5325_DI_Soft : JY5325.h
  • JY5325_DI_Start() : JY5325.h
  • JY5325_DI_Stop() : JY5325.h
  • JY5325_DI_TriggerType : JY5325.h
  • JY5325_DI_WaitUntilDone() : JY5325.h
  • JY5325_DigitalTriggerEdge : JY5325.h
  • JY5325_DigitalTriggerSource : JY5325.h
  • JY5325_DisableAICalibration() : JY5325.h
  • JY5325_DisableAOCalibration() : JY5325.h
  • JY5325_DisconnectSignalRouting() : JY5325.h
  • JY5325_DO_AddLines() : JY5325.h
  • JY5325_DO_CheckBufferStatus() : JY5325.h
  • JY5325_DO_ContinuousNoWrapping : JY5325.h
  • JY5325_DO_ContinuousWrapping : JY5325.h
  • JY5325_DO_Digital : JY5325.h
  • JY5325_DO_Finite : JY5325.h
  • JY5325_DO_Immediately : JY5325.h
  • JY5325_DO_SendSoftTrigger() : JY5325.h
  • JY5325_DO_SetDigitalStartTrigger() : JY5325.h
  • JY5325_DO_SetMode() : JY5325.h
  • JY5325_DO_SetSampleClock() : JY5325.h
  • JY5325_DO_SetSamplesToUpdate() : JY5325.h
  • JY5325_DO_SetStartTriggerType() : JY5325.h
  • JY5325_DO_SetUpdateRate() : JY5325.h
  • JY5325_DO_Single : JY5325.h
  • JY5325_DO_Soft : JY5325.h
  • JY5325_DO_Start() : JY5325.h
  • JY5325_DO_Stop() : JY5325.h
  • JY5325_DO_TriggerType : JY5325.h
  • JY5325_DO_UpdateMode : JY5325.h
  • JY5325_DO_WaitUntilDone() : JY5325.h
  • JY5325_DO_WriteData() : JY5325.h
  • JY5325_DO_WriteSinglePoint() : JY5325.h
  • JY5325_DO_WriteSinglePoint_U8() : JY5325.h
  • JY5325_Entering : JY5325.h
  • JY5325_External_Timebase : JY5325.h
  • JY5325_ExternalClock : JY5325.h
  • JY5325_ExternalClockTerminal : JY5325.h
  • JY5325_Falling : JY5325.h
  • JY5325_FallingEdge : JY5325.h
  • JY5325_FallingSlope : JY5325.h
  • JY5325_GetDeviceID() : JY5325.h
  • JY5325_GetDeviceSerialNumber() : JY5325.h
  • JY5325_HighLevel : JY5325.h
  • JY5325_Hold : JY5325.h
  • JY5325_IN_AI_SampleClock : JY5325.h
  • JY5325_IN_AO_SampleClock : JY5325.h
  • JY5325_IN_CIO_100kHz : JY5325.h
  • JY5325_IN_CIO_100MHz : JY5325.h
  • JY5325_IN_CIO_5MHz : JY5325.h
  • JY5325_IN_CO_0_Output : JY5325.h
  • JY5325_IN_CO_1_Output : JY5325.h
  • JY5325_IN_DI_SampleClock : JY5325.h
  • JY5325_IN_DO_SampleClock : JY5325.h
  • JY5325_Independent : JY5325.h
  • JY5325_InputTerminal : JY5325.h
  • JY5325_Inter_AI_ReferenceTrig : JY5325.h
  • JY5325_Inter_AI_StartTrig : JY5325.h
  • JY5325_Inter_AO_StartTrig : JY5325.h
  • JY5325_Inter_CI_0_SampleClock : JY5325.h
  • JY5325_Inter_CI_1_SampleClock : JY5325.h
  • JY5325_Inter_Clock_DI_SampleClock : JY5325.h
  • JY5325_Inter_Clock_DO_SampleClock : JY5325.h
  • JY5325_Inter_CO_0_Output : JY5325.h
  • JY5325_Inter_CO_1_Output : JY5325.h
  • JY5325_Inter_Counter_0_Out : JY5325.h
  • JY5325_Inter_Counter_0_StartTrig : JY5325.h
  • JY5325_Inter_Counter_1_Out : JY5325.h
  • JY5325_Inter_Counter_1_StartTrig : JY5325.h
  • JY5325_Inter_DI_ReferenceTrig : JY5325.h
  • JY5325_Inter_DI_StartTrig : JY5325.h
  • JY5325_Inter_DO_StartTrig : JY5325.h
  • JY5325_Internal : JY5325.h
  • JY5325_Internal_Timebase_100K : JY5325.h
  • JY5325_Internal_Timebase_100M : JY5325.h
  • JY5325_Internal_Timebase_5M : JY5325.h
  • JY5325_InternalClock : JY5325.h
  • JY5325_Leaving : JY5325.h
  • JY5325_LevelState : JY5325.h
  • JY5325_LowLevel : JY5325.h
  • JY5325_MASTER : JY5325.h
  • JY5325_None : JY5325.h
  • JY5325_Open() : JY5325.h
  • JY5325_OpenByAliasName() : JY5325.h
  • JY5325_OutputCompleteState : JY5325.h
  • JY5325_PFI0 : JY5325.h
  • JY5325_PFI0_Input : JY5325.h
  • JY5325_PFI0_OUT : JY5325.h
  • JY5325_PFI1 : JY5325.h
  • JY5325_PFI1_Input : JY5325.h
  • JY5325_PFI1_OUT : JY5325.h
  • JY5325_PFI2 : JY5325.h
  • JY5325_PFI2_Input : JY5325.h
  • JY5325_PFI2_OUT : JY5325.h
  • JY5325_PFI3 : JY5325.h
  • JY5325_PFI3_Input : JY5325.h
  • JY5325_PFI3_OUT : JY5325.h
  • JY5325_PFI4 : JY5325.h
  • JY5325_PFI4_Input : JY5325.h
  • JY5325_PFI4_OUT : JY5325.h
  • JY5325_PFI5 : JY5325.h
  • JY5325_PFI5_Input : JY5325.h
  • JY5325_PFI5_OUT : JY5325.h
  • JY5325_PFI6 : JY5325.h
  • JY5325_PFI6_Input : JY5325.h
  • JY5325_PFI6_OUT : JY5325.h
  • JY5325_PFI7 : JY5325.h
  • JY5325_PFI7_Input : JY5325.h
  • JY5325_PFI7_OUT : JY5325.h
  • JY5325_PXI_Trig0 : JY5325.h
  • JY5325_PXI_Trig0_Input : JY5325.h
  • JY5325_PXI_Trig1 : JY5325.h
  • JY5325_PXI_Trig1_Input : JY5325.h
  • JY5325_PXI_Trig2 : JY5325.h
  • JY5325_PXI_Trig2_Input : JY5325.h
  • JY5325_PXI_Trig3 : JY5325.h
  • JY5325_PXI_Trig3_Input : JY5325.h
  • JY5325_PXI_Trig4 : JY5325.h
  • JY5325_PXI_Trig4_Input : JY5325.h
  • JY5325_PXI_Trig5 : JY5325.h
  • JY5325_PXI_Trig5_Input : JY5325.h
  • JY5325_PXI_Trig6 : JY5325.h
  • JY5325_PXI_Trig6_Input : JY5325.h
  • JY5325_PXI_Trig7 : JY5325.h
  • JY5325_PXI_Trig7_Input : JY5325.h
  • JY5325_PXIe_Clk100 : JY5325.h
  • JY5325_PXITrig0_OUT : JY5325.h
  • JY5325_PXITrig1_OUT : JY5325.h
  • JY5325_PXITrig2_OUT : JY5325.h
  • JY5325_PXITrig3_OUT : JY5325.h
  • JY5325_PXITrig4_OUT : JY5325.h
  • JY5325_PXITrig5_OUT : JY5325.h
  • JY5325_PXITrig6_OUT : JY5325.h
  • JY5325_PXITrig7_OUT : JY5325.h
  • JY5325_ReadRegister() : JY5325.h
  • JY5325_ReferenceClock : JY5325.h
  • JY5325_ReferenceTrigger : JY5325.h
  • JY5325_Rising : JY5325.h
  • JY5325_RisingEdge : JY5325.h
  • JY5325_RisingSlope : JY5325.h
  • JY5325_SetDeviceProperty() : JY5325.h
  • JY5325_SetDeviceReferenceClock() : JY5325.h
  • JY5325_SetDeviceStatusLed() : JY5325.h
  • JY5325_Signal_AI_ReferenceTrig : JY5325.h
  • JY5325_Signal_AI_StartTrig : JY5325.h
  • JY5325_Signal_AO_StartTrig : JY5325.h
  • JY5325_Signal_CI_0_SampleClock : JY5325.h
  • JY5325_Signal_CI_1_SampleClock : JY5325.h
  • JY5325_Signal_CIO_100kHz : JY5325.h
  • JY5325_Signal_CIO_100MHz : JY5325.h
  • JY5325_Signal_CIO_5MHz : JY5325.h
  • JY5325_Signal_CO_0_Output : JY5325.h
  • JY5325_Signal_CO_1_Output : JY5325.h
  • JY5325_Signal_Counter_0_StartTrig : JY5325.h
  • JY5325_Signal_Counter_1_StartTrig : JY5325.h
  • JY5325_Signal_Destination : JY5325.h
  • JY5325_Signal_DI_ReferenceTrig : JY5325.h
  • JY5325_Signal_DI_SampleClock : JY5325.h
  • JY5325_Signal_DI_StartTrig : JY5325.h
  • JY5325_Signal_DO_SampleClock : JY5325.h
  • JY5325_Signal_DO_StartTrig : JY5325.h
  • JY5325_Signal_PFI0 : JY5325.h
  • JY5325_Signal_PFI1 : JY5325.h
  • JY5325_Signal_PFI2 : JY5325.h
  • JY5325_Signal_PFI3 : JY5325.h
  • JY5325_Signal_PFI4 : JY5325.h
  • JY5325_Signal_PFI5 : JY5325.h
  • JY5325_Signal_PFI6 : JY5325.h
  • JY5325_Signal_PFI7 : JY5325.h
  • JY5325_Signal_PXI_Trig0 : JY5325.h
  • JY5325_Signal_PXI_Trig1 : JY5325.h
  • JY5325_Signal_PXI_Trig2 : JY5325.h
  • JY5325_Signal_PXI_Trig3 : JY5325.h
  • JY5325_Signal_PXI_Trig4 : JY5325.h
  • JY5325_Signal_PXI_Trig5 : JY5325.h
  • JY5325_Signal_PXI_Trig6 : JY5325.h
  • JY5325_Signal_PXI_Trig7 : JY5325.h
  • JY5325_Signal_Source : JY5325.h
  • JY5325_SignalRouting() : JY5325.h
  • JY5325_SLAVE : JY5325.h
  • JY5325_StartTrigger : JY5325.h
  • JY5325_TriggerMode : JY5325.h
  • JY5325_WriteRegister() : JY5325.h
  • JY5325_Zero : JY5325.h


  • Enumerations
  • Enumerator
  • j
Here is a list of all enums with links to the files they belong to:

- j -

  • JY5325_AI_SampleMode : JY5325.h
  • JY5325_AI_TriggerType : JY5325.h
  • JY5325_AnalogTriggerEdge : JY5325.h
  • JY5325_AnalogTriggerSource : JY5325.h
  • JY5325_AnalogWindowCondition : JY5325.h
  • JY5325_AO_TriggerType : JY5325.h
  • JY5325_AO_UpdateMode : JY5325.h
  • JY5325_CI_CounterEventSignalIdleState : JY5325.h
  • JY5325_CI_MeasureType : JY5325.h
  • JY5325_CI_SampleClock : JY5325.h
  • JY5325_CI_SampleMode : JY5325.h
  • JY5325_CI_StartingEdge : JY5325.h
  • JY5325_CI_ValueReturnMode : JY5325.h
  • JY5325_CIO_TriggerType : JY5325.h
  • JY5325_ClockSource : JY5325.h
  • JY5325_CO_IdleState : JY5325.h
  • JY5325_CO_OutMode : JY5325.h
  • JY5325_CountDirection : JY5325.h
  • JY5325_CountTimeBase : JY5325.h
  • JY5325_DeviceProperty : JY5325.h
  • JY5325_DI_SampleMode : JY5325.h
  • JY5325_DI_TriggerType : JY5325.h
  • JY5325_DigitalTriggerEdge : JY5325.h
  • JY5325_DigitalTriggerSource : JY5325.h
  • JY5325_DO_TriggerType : JY5325.h
  • JY5325_DO_UpdateMode : JY5325.h
  • JY5325_ExternalClockTerminal : JY5325.h
  • JY5325_InputTerminal : JY5325.h
  • JY5325_LevelState : JY5325.h
  • JY5325_OutputCompleteState : JY5325.h
  • JY5325_ReferenceClock : JY5325.h
  • JY5325_Signal_Destination : JY5325.h
  • JY5325_Signal_Source : JY5325.h
  • JY5325_TriggerMode : JY5325.h


  • Enumerations
  • Enumerator
  • j
Here is a list of all enum values with links to the files they belong to:

- j -

  • JY5325_AI_Analog : JY5325.h
  • JY5325_AI_Continuous : JY5325.h
  • JY5325_AI_Digital : JY5325.h
  • JY5325_AI_Finite : JY5325.h
  • JY5325_AI_Immediately : JY5325.h
  • JY5325_AI_Soft : JY5325.h
  • JY5325_AnyEdge : JY5325.h
  • JY5325_AO_ContinuousNoWrapping : JY5325.h
  • JY5325_AO_ContinuousWrapping : JY5325.h
  • JY5325_AO_Digital : JY5325.h
  • JY5325_AO_Finite : JY5325.h
  • JY5325_AO_Immediately : JY5325.h
  • JY5325_AO_Single : JY5325.h
  • JY5325_AO_Soft : JY5325.h
  • JY5325_Channel_0 : JY5325.h
  • JY5325_Channel_1 : JY5325.h
  • JY5325_Channel_2 : JY5325.h
  • JY5325_Channel_3 : JY5325.h
  • JY5325_Channel_4 : JY5325.h
  • JY5325_Channel_5 : JY5325.h
  • JY5325_Channel_6 : JY5325.h
  • JY5325_Channel_7 : JY5325.h
  • JY5325_CI_Continuous : JY5325.h
  • JY5325_CI_Count_Down : JY5325.h
  • JY5325_CI_Count_External : JY5325.h
  • JY5325_CI_Count_Up : JY5325.h
  • JY5325_CI_CounterEventSignalIdleState_High : JY5325.h
  • JY5325_CI_CounterEventSignalIdleState_Low : JY5325.h
  • JY5325_CI_EdgeCount : JY5325.h
  • JY5325_CI_EncoderTwoPulse : JY5325.h
  • JY5325_CI_EncoderX1 : JY5325.h
  • JY5325_CI_EncoderX2 : JY5325.h
  • JY5325_CI_EncoderX4 : JY5325.h
  • JY5325_CI_ExternalClock : JY5325.h
  • JY5325_CI_Finite : JY5325.h
  • JY5325_CI_ImplicitClock : JY5325.h
  • JY5325_CI_InternalClock : JY5325.h
  • JY5325_CI_Measure_EdgeSeparation : JY5325.h
  • JY5325_CI_Measure_FrequencyOrPeriod : JY5325.h
  • JY5325_CI_Measure_PulseWidth : JY5325.h
  • JY5325_CI_Measure_SemiPeriod : JY5325.h
  • JY5325_CI_ReturnOneValue : JY5325.h
  • JY5325_CI_ReturnTwoValue : JY5325.h
  • JY5325_CI_Single : JY5325.h
  • JY5325_CIO_Digital : JY5325.h
  • JY5325_CIO_Immediately : JY5325.h
  • JY5325_CIO_Soft : JY5325.h
  • JY5325_Clock_PFI_0 : JY5325.h
  • JY5325_Clock_PFI_1 : JY5325.h
  • JY5325_Clock_PFI_2 : JY5325.h
  • JY5325_Clock_PFI_3 : JY5325.h
  • JY5325_Clock_PFI_4 : JY5325.h
  • JY5325_Clock_PFI_5 : JY5325.h
  • JY5325_Clock_PFI_6 : JY5325.h
  • JY5325_Clock_PFI_7 : JY5325.h
  • JY5325_Clock_PXI_Trig_0 : JY5325.h
  • JY5325_Clock_PXI_Trig_1 : JY5325.h
  • JY5325_Clock_PXI_Trig_2 : JY5325.h
  • JY5325_Clock_PXI_Trig_3 : JY5325.h
  • JY5325_Clock_PXI_Trig_4 : JY5325.h
  • JY5325_Clock_PXI_Trig_5 : JY5325.h
  • JY5325_Clock_PXI_Trig_6 : JY5325.h
  • JY5325_Clock_PXI_Trig_7 : JY5325.h
  • JY5325_CO_ContinuousNoWrapping : JY5325.h
  • JY5325_CO_ContinuousWrapping : JY5325.h
  • JY5325_CO_Finite : JY5325.h
  • JY5325_CO_HighLevel : JY5325.h
  • JY5325_CO_LowLevel : JY5325.h
  • JY5325_CO_Single : JY5325.h
  • JY5325_DI_Continuous : JY5325.h
  • JY5325_DI_Digital : JY5325.h
  • JY5325_DI_Finite : JY5325.h
  • JY5325_DI_Immediately : JY5325.h
  • JY5325_DI_Single : JY5325.h
  • JY5325_DI_Soft : JY5325.h
  • JY5325_DO_ContinuousNoWrapping : JY5325.h
  • JY5325_DO_ContinuousWrapping : JY5325.h
  • JY5325_DO_Digital : JY5325.h
  • JY5325_DO_Finite : JY5325.h
  • JY5325_DO_Immediately : JY5325.h
  • JY5325_DO_Single : JY5325.h
  • JY5325_DO_Soft : JY5325.h
  • JY5325_Entering : JY5325.h
  • JY5325_External_Timebase : JY5325.h
  • JY5325_ExternalClock : JY5325.h
  • JY5325_Falling : JY5325.h
  • JY5325_FallingEdge : JY5325.h
  • JY5325_FallingSlope : JY5325.h
  • JY5325_HighLevel : JY5325.h
  • JY5325_Hold : JY5325.h
  • JY5325_IN_AI_SampleClock : JY5325.h
  • JY5325_IN_AO_SampleClock : JY5325.h
  • JY5325_IN_CIO_100kHz : JY5325.h
  • JY5325_IN_CIO_100MHz : JY5325.h
  • JY5325_IN_CIO_5MHz : JY5325.h
  • JY5325_IN_CO_0_Output : JY5325.h
  • JY5325_IN_CO_1_Output : JY5325.h
  • JY5325_IN_DI_SampleClock : JY5325.h
  • JY5325_IN_DO_SampleClock : JY5325.h
  • JY5325_Independent : JY5325.h
  • JY5325_Inter_AI_ReferenceTrig : JY5325.h
  • JY5325_Inter_AI_StartTrig : JY5325.h
  • JY5325_Inter_AO_StartTrig : JY5325.h
  • JY5325_Inter_CI_0_SampleClock : JY5325.h
  • JY5325_Inter_CI_1_SampleClock : JY5325.h
  • JY5325_Inter_Clock_DI_SampleClock : JY5325.h
  • JY5325_Inter_Clock_DO_SampleClock : JY5325.h
  • JY5325_Inter_CO_0_Output : JY5325.h
  • JY5325_Inter_CO_1_Output : JY5325.h
  • JY5325_Inter_Counter_0_Out : JY5325.h
  • JY5325_Inter_Counter_0_StartTrig : JY5325.h
  • JY5325_Inter_Counter_1_Out : JY5325.h
  • JY5325_Inter_Counter_1_StartTrig : JY5325.h
  • JY5325_Inter_DI_ReferenceTrig : JY5325.h
  • JY5325_Inter_DI_StartTrig : JY5325.h
  • JY5325_Inter_DO_StartTrig : JY5325.h
  • JY5325_Internal : JY5325.h
  • JY5325_Internal_Timebase_100K : JY5325.h
  • JY5325_Internal_Timebase_100M : JY5325.h
  • JY5325_Internal_Timebase_5M : JY5325.h
  • JY5325_InternalClock : JY5325.h
  • JY5325_Leaving : JY5325.h
  • JY5325_LowLevel : JY5325.h
  • JY5325_MASTER : JY5325.h
  • JY5325_None : JY5325.h
  • JY5325_PFI0 : JY5325.h
  • JY5325_PFI0_Input : JY5325.h
  • JY5325_PFI0_OUT : JY5325.h
  • JY5325_PFI1 : JY5325.h
  • JY5325_PFI1_Input : JY5325.h
  • JY5325_PFI1_OUT : JY5325.h
  • JY5325_PFI2 : JY5325.h
  • JY5325_PFI2_Input : JY5325.h
  • JY5325_PFI2_OUT : JY5325.h
  • JY5325_PFI3 : JY5325.h
  • JY5325_PFI3_Input : JY5325.h
  • JY5325_PFI3_OUT : JY5325.h
  • JY5325_PFI4 : JY5325.h
  • JY5325_PFI4_Input : JY5325.h
  • JY5325_PFI4_OUT : JY5325.h
  • JY5325_PFI5 : JY5325.h
  • JY5325_PFI5_Input : JY5325.h
  • JY5325_PFI5_OUT : JY5325.h
  • JY5325_PFI6 : JY5325.h
  • JY5325_PFI6_Input : JY5325.h
  • JY5325_PFI6_OUT : JY5325.h
  • JY5325_PFI7 : JY5325.h
  • JY5325_PFI7_Input : JY5325.h
  • JY5325_PFI7_OUT : JY5325.h
  • JY5325_PXI_Trig0 : JY5325.h
  • JY5325_PXI_Trig0_Input : JY5325.h
  • JY5325_PXI_Trig1 : JY5325.h
  • JY5325_PXI_Trig1_Input : JY5325.h
  • JY5325_PXI_Trig2 : JY5325.h
  • JY5325_PXI_Trig2_Input : JY5325.h
  • JY5325_PXI_Trig3 : JY5325.h
  • JY5325_PXI_Trig3_Input : JY5325.h
  • JY5325_PXI_Trig4 : JY5325.h
  • JY5325_PXI_Trig4_Input : JY5325.h
  • JY5325_PXI_Trig5 : JY5325.h
  • JY5325_PXI_Trig5_Input : JY5325.h
  • JY5325_PXI_Trig6 : JY5325.h
  • JY5325_PXI_Trig6_Input : JY5325.h
  • JY5325_PXI_Trig7 : JY5325.h
  • JY5325_PXI_Trig7_Input : JY5325.h
  • JY5325_PXIe_Clk100 : JY5325.h
  • JY5325_PXITrig0_OUT : JY5325.h
  • JY5325_PXITrig1_OUT : JY5325.h
  • JY5325_PXITrig2_OUT : JY5325.h
  • JY5325_PXITrig3_OUT : JY5325.h
  • JY5325_PXITrig4_OUT : JY5325.h
  • JY5325_PXITrig5_OUT : JY5325.h
  • JY5325_PXITrig6_OUT : JY5325.h
  • JY5325_PXITrig7_OUT : JY5325.h
  • JY5325_ReferenceTrigger : JY5325.h
  • JY5325_Rising : JY5325.h
  • JY5325_RisingEdge : JY5325.h
  • JY5325_RisingSlope : JY5325.h
  • JY5325_Signal_AI_ReferenceTrig : JY5325.h
  • JY5325_Signal_AI_StartTrig : JY5325.h
  • JY5325_Signal_AO_StartTrig : JY5325.h
  • JY5325_Signal_CI_0_SampleClock : JY5325.h
  • JY5325_Signal_CI_1_SampleClock : JY5325.h
  • JY5325_Signal_CIO_100kHz : JY5325.h
  • JY5325_Signal_CIO_100MHz : JY5325.h
  • JY5325_Signal_CIO_5MHz : JY5325.h
  • JY5325_Signal_CO_0_Output : JY5325.h
  • JY5325_Signal_CO_1_Output : JY5325.h
  • JY5325_Signal_Counter_0_StartTrig : JY5325.h
  • JY5325_Signal_Counter_1_StartTrig : JY5325.h
  • JY5325_Signal_DI_ReferenceTrig : JY5325.h
  • JY5325_Signal_DI_SampleClock : JY5325.h
  • JY5325_Signal_DI_StartTrig : JY5325.h
  • JY5325_Signal_DO_SampleClock : JY5325.h
  • JY5325_Signal_DO_StartTrig : JY5325.h
  • JY5325_Signal_PFI0 : JY5325.h
  • JY5325_Signal_PFI1 : JY5325.h
  • JY5325_Signal_PFI2 : JY5325.h
  • JY5325_Signal_PFI3 : JY5325.h
  • JY5325_Signal_PFI4 : JY5325.h
  • JY5325_Signal_PFI5 : JY5325.h
  • JY5325_Signal_PFI6 : JY5325.h
  • JY5325_Signal_PFI7 : JY5325.h
  • JY5325_Signal_PXI_Trig0 : JY5325.h
  • JY5325_Signal_PXI_Trig1 : JY5325.h
  • JY5325_Signal_PXI_Trig2 : JY5325.h
  • JY5325_Signal_PXI_Trig3 : JY5325.h
  • JY5325_Signal_PXI_Trig4 : JY5325.h
  • JY5325_Signal_PXI_Trig5 : JY5325.h
  • JY5325_Signal_PXI_Trig6 : JY5325.h
  • JY5325_Signal_PXI_Trig7 : JY5325.h
  • JY5325_SLAVE : JY5325.h
  • JY5325_StartTrigger : JY5325.h
  • JY5325_Zero : JY5325.h


  • Enumerations
  • Enumerator
  • j
Here is a list of all functions with links to the files they belong to:

- j -

  • JY5325_AI_CheckBufferStatus() : JY5325.h
  • JY5325_AI_EnableChannel() : JY5325.h
  • JY5325_AI_ReadData() : JY5325.h
  • JY5325_AI_ReadRawData() : JY5325.h
  • JY5325_AI_SendSoftTrigger() : JY5325.h
  • JY5325_AI_SetAnalogEdgeReferenceTrigger() : JY5325.h
  • JY5325_AI_SetAnalogEdgeStartTrigger() : JY5325.h
  • JY5325_AI_SetAnalogHysteresisReferenceTrigger() : JY5325.h
  • JY5325_AI_SetAnalogHysteresisStartTrigger() : JY5325.h
  • JY5325_AI_SetAnalogWindowReferenceTrigger() : JY5325.h
  • JY5325_AI_SetAnalogWindowStartTrigger() : JY5325.h
  • JY5325_AI_SetDigitalReferenceTrigger() : JY5325.h
  • JY5325_AI_SetDigitalStartTrigger() : JY5325.h
  • JY5325_AI_SetMode() : JY5325.h
  • JY5325_AI_SetPreTriggerSamples() : JY5325.h
  • JY5325_AI_SetReferenceTriggerType() : JY5325.h
  • JY5325_AI_SetReTriggerCount() : JY5325.h
  • JY5325_AI_SetSampleClock() : JY5325.h
  • JY5325_AI_SetSampleRate() : JY5325.h
  • JY5325_AI_SetSamplesToAcquire() : JY5325.h
  • JY5325_AI_SetStartTriggerType() : JY5325.h
  • JY5325_AI_Start() : JY5325.h
  • JY5325_AI_Stop() : JY5325.h
  • JY5325_AI_WaitUntilDone() : JY5325.h
  • JY5325_AO_CheckBufferStatus() : JY5325.h
  • JY5325_AO_EnableChannel() : JY5325.h
  • JY5325_AO_SendSoftTrigger() : JY5325.h
  • JY5325_AO_SetDigitalStartTrigger() : JY5325.h
  • JY5325_AO_SetMode() : JY5325.h
  • JY5325_AO_SetOutputCompleteState() : JY5325.h
  • JY5325_AO_SetSampleClock() : JY5325.h
  • JY5325_AO_SetSamplesToUpdate() : JY5325.h
  • JY5325_AO_SetStartTriggerType() : JY5325.h
  • JY5325_AO_SetUpdateRate() : JY5325.h
  • JY5325_AO_Start() : JY5325.h
  • JY5325_AO_Stop() : JY5325.h
  • JY5325_AO_WaitUntilDone() : JY5325.h
  • JY5325_AO_WriteData() : JY5325.h
  • JY5325_AO_WriteRawData() : JY5325.h
  • JY5325_AO_WriteRawSinglePoint() : JY5325.h
  • JY5325_AO_WriteSinglePoint() : JY5325.h
  • JY5325_CI_CheckBufferStatus() : JY5325.h
  • JY5325_CI_EnableChannel() : JY5325.h
  • JY5325_CI_ReadCountValues() : JY5325.h
  • JY5325_CI_ReadMeasureValues() : JY5325.h
  • JY5325_CI_ReadSingleCountValue() : JY5325.h
  • JY5325_CI_ReadSingleMeasureValue() : JY5325.h
  • JY5325_CI_SendSoftTrigger() : JY5325.h
  • JY5325_CI_SetAuxTerminal() : JY5325.h
  • JY5325_CI_SetCounterParament() : JY5325.h
  • JY5325_CI_SetCounterType() : JY5325.h
  • JY5325_CI_SetDigitalStartTrigger() : JY5325.h
  • JY5325_CI_SetEdgeCountEvent() : JY5325.h
  • JY5325_CI_SetFirstSampleClock() : JY5325.h
  • JY5325_CI_SetGateTerminal() : JY5325.h
  • JY5325_CI_SetMode() : JY5325.h
  • JY5325_CI_SetOutTerminal() : JY5325.h
  • JY5325_CI_SetPauseTriggerLevel() : JY5325.h
  • JY5325_CI_SetPauseTriggerTerminal() : JY5325.h
  • JY5325_CI_SetSampleClock() : JY5325.h
  • JY5325_CI_SetSamplesToAcquire() : JY5325.h
  • JY5325_CI_SetSignalReverse() : JY5325.h
  • JY5325_CI_SetSourceTerminal() : JY5325.h
  • JY5325_CI_SetStartingEdge() : JY5325.h
  • JY5325_CI_SetStartTriggerType() : JY5325.h
  • JY5325_CI_SetTimeBase() : JY5325.h
  • JY5325_CI_SetValueReturnMode() : JY5325.h
  • JY5325_CI_SetZReloadEnabled() : JY5325.h
  • JY5325_CI_Start() : JY5325.h
  • JY5325_CI_Stop() : JY5325.h
  • JY5325_Close() : JY5325.h
  • JY5325_CO_CheckBufferStatus() : JY5325.h
  • JY5325_CO_CheckCounterStatus() : JY5325.h
  • JY5325_CO_EnableChannel() : JY5325.h
  • JY5325_CO_SendSoftTrigger() : JY5325.h
  • JY5325_CO_SetCounterParament() : JY5325.h
  • JY5325_CO_SetDigitalStartTrigger() : JY5325.h
  • JY5325_CO_SetFrequency() : JY5325.h
  • JY5325_CO_SetMode() : JY5325.h
  • JY5325_CO_SetOutTerminal() : JY5325.h
  • JY5325_CO_SetPauseTriggerLevel() : JY5325.h
  • JY5325_CO_SetPauseTriggerTerminal() : JY5325.h
  • JY5325_CO_SetSamplesToUpdate() : JY5325.h
  • JY5325_CO_SetStartTriggerType() : JY5325.h
  • JY5325_CO_SetTimeBase() : JY5325.h
  • JY5325_CO_Start() : JY5325.h
  • JY5325_CO_Stop() : JY5325.h
  • JY5325_CO_WaitUntilDone() : JY5325.h
  • JY5325_CO_WriteData() : JY5325.h
  • JY5325_DI_AddLines() : JY5325.h
  • JY5325_DI_CheckBufferStatus() : JY5325.h
  • JY5325_DI_CheckBufferStatusEx() : JY5325.h
  • JY5325_DI_ReadData() : JY5325.h
  • JY5325_DI_ReadSinglePoint() : JY5325.h
  • JY5325_DI_ReadSinglePoint_U8() : JY5325.h
  • JY5325_DI_SendSoftTrigger() : JY5325.h
  • JY5325_DI_SetDigitalReferenceTrigger() : JY5325.h
  • JY5325_DI_SetDigitalStartTrigger() : JY5325.h
  • JY5325_DI_SetMode() : JY5325.h
  • JY5325_DI_SetPreTriggerSamples() : JY5325.h
  • JY5325_DI_SetReferenceTriggerType() : JY5325.h
  • JY5325_DI_SetSampleClock() : JY5325.h
  • JY5325_DI_SetSampleRate() : JY5325.h
  • JY5325_DI_SetSamplesToAcquire() : JY5325.h
  • JY5325_DI_SetStartTriggerType() : JY5325.h
  • JY5325_DI_Start() : JY5325.h
  • JY5325_DI_Stop() : JY5325.h
  • JY5325_DI_WaitUntilDone() : JY5325.h
  • JY5325_DisableAICalibration() : JY5325.h
  • JY5325_DisableAOCalibration() : JY5325.h
  • JY5325_DisconnectSignalRouting() : JY5325.h
  • JY5325_DO_AddLines() : JY5325.h
  • JY5325_DO_CheckBufferStatus() : JY5325.h
  • JY5325_DO_SendSoftTrigger() : JY5325.h
  • JY5325_DO_SetDigitalStartTrigger() : JY5325.h
  • JY5325_DO_SetMode() : JY5325.h
  • JY5325_DO_SetSampleClock() : JY5325.h
  • JY5325_DO_SetSamplesToUpdate() : JY5325.h
  • JY5325_DO_SetStartTriggerType() : JY5325.h
  • JY5325_DO_SetUpdateRate() : JY5325.h
  • JY5325_DO_Start() : JY5325.h
  • JY5325_DO_Stop() : JY5325.h
  • JY5325_DO_WaitUntilDone() : JY5325.h
  • JY5325_DO_WriteData() : JY5325.h
  • JY5325_DO_WriteSinglePoint() : JY5325.h
  • JY5325_DO_WriteSinglePoint_U8() : JY5325.h
  • JY5325_GetDeviceID() : JY5325.h
  • JY5325_GetDeviceSerialNumber() : JY5325.h
  • JY5325_Open() : JY5325.h
  • JY5325_OpenByAliasName() : JY5325.h
  • JY5325_ReadRegister() : JY5325.h
  • JY5325_SetDeviceProperty() : JY5325.h
  • JY5325_SetDeviceReferenceClock() : JY5325.h
  • JY5325_SetDeviceStatusLed() : JY5325.h
  • JY5325_SignalRouting() : JY5325.h
  • JY5325_WriteRegister() : JY5325.h


  • Enumerations
  • Enumerator
Here is a list of all typedefs with links to the files they belong to:
  • JY5325_DeviceHandle : JY5325.h


5325 C++ Programming Manual: Main Page

5325 C++ Programming Manual Documentation