5325 C++ Programming Manual: COO/5325 Directory Reference

5325 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 5325
5325 Directory Reference

Files

JY5325CoreOOAITask.h
JY5325CoreOOAOTask.h
JY5325CoreOOCITask.h
JY5325CoreOOCommon.h
JY5325CoreOOCOTask.h
JY5325CoreOODevice.h
JY5325CoreOODITask.h
JY5325CoreOODOTask.h
JY5325CoreOOLog.h
Generated by doxygen 1.13.2


5325 C++ Programming Manual: COO/5325/JY5325CoreOOAITask.h File Reference

  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 5325
Classes | Namespaces | Enumerations
JY5325CoreOOAITask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JY5325CoreOOCommon.h"
#include "JY5325CoreOODevice.h"

Classes

class | JY5325CoreOO::JY5325CoreOOAITask
AITask类 More...
class | JY5325CoreOO::AIChannel
class | JY5325CoreOO::AIExternalSampleClock
class | JY5325CoreOO::AISampleClock
class | JY5325CoreOO::AITrigger
Constructor to create an AITrigger task object. More...
class | JY5325CoreOO::AISync
class | JY5325CoreOO::AIDigitalTrigger
class | JY5325CoreOO::AIAnalogHysteresisComparator
class | JY5325CoreOO::AIAnalogWindowComparator
class | JY5325CoreOO::AIAnalogEdgeComparator
class | JY5325CoreOO::AIAnalogTrigger
class | JY5325CoreOO::AIRecord
class | JY5325CoreOO::AISignalExport

Namespaces

namespace JY5325CoreOO

Enumerations

enum class | JY5325CoreOO::AIMode { JY5325CoreOO::Finite = 0x0 , JY5325CoreOO::Continuous = 0x1 , JY5325CoreOO::Record = 0x3 }
enum class | JY5325CoreOO::AISampleClockSource { JY5325CoreOO::Internal }
enum class | JY5325CoreOO::AITriggerType { JY5325CoreOO::Immediate = 0x0 , JY5325CoreOO::Digital = 0x1 , JY5325CoreOO::Analog = 0x2 , JY5325CoreOO::Soft = 0x3 }
enum class | JY5325CoreOO::AITriggerMode { JY5325CoreOO::Start , JY5325CoreOO::Reference }
enum class JY5325CoreOO::AIAnalogTriggerSource {
JY5325CoreOO::Channel_0 , JY5325CoreOO::Channel_1 , JY5325CoreOO::Channel_2 , JY5325CoreOO::Channel_3 ,
JY5325CoreOO::Channel_4 , JY5325CoreOO::Channel_5 , JY5325CoreOO::Channel_6 , JY5325CoreOO::Channel_7
}
enum class JY5325CoreOO::AIDigitalTriggerSource {
JY5325CoreOO::PFI0 , JY5325CoreOO::PFI1 , JY5325CoreOO::PFI2 , JY5325CoreOO::PFI3 ,
JY5325CoreOO::PFI4 , JY5325CoreOO::PFI5 , JY5325CoreOO::PFI6 , JY5325CoreOO::PFI7 ,
JY5325CoreOO::PXI_Trig0 = 8 , JY5325CoreOO::PXI_Trig1 = 9 , JY5325CoreOO::PXI_Trig2 = 10 , JY5325CoreOO::PXI_Trig3 = 11 ,
JY5325CoreOO::PXI_Trig4 = 12 , JY5325CoreOO::PXI_Trig5 = 13 , JY5325CoreOO::PXI_Trig6 = 14 , JY5325CoreOO::PXI_Trig7 = 15 ,
JY5325CoreOO::AO_StartTrig = 18 , JY5325CoreOO::DI_StartTrig = 19 , JY5325CoreOO::DI_ReferenceTrig = 20 , JY5325CoreOO::DO_StartTrig = 21 ,
JY5325CoreOO::CIO_0_StartTrig = 22 , JY5325CoreOO::CIO_1_StartTrig = 23 , JY5325CoreOO::CO_0_Out = 24 , JY5325CoreOO::CO_1_Out = 25
}
enum class | JY5325CoreOO::AIDigitalTriggerEdge { JY5325CoreOO::Rising = 0x0 , JY5325CoreOO::Falling = 0x1 }
enum class | JY5325CoreOO::AIAnalogTriggerEdge { JY5325CoreOO::Rising , JY5325CoreOO::Falling }
enum class | JY5325CoreOO::AIAnalogWindowCondition { JY5325CoreOO::Entering , JY5325CoreOO::Leaving }
AI Analog Window Trigger Condition. More...
enum class | JY5325CoreOO::AIAnalogTriggerComparator { JY5325CoreOO::Edge , JY5325CoreOO::Hysteresis , JY5325CoreOO::Window }
AI Analog Trigger Comparator. More...
enum class JY5325CoreOO::AISignalExportSource {
JY5325CoreOO::StartTrig = 16 , JY5325CoreOO::ReferenceTrig = 17 , JY5325CoreOO::Internal_Counter_100K = 34 , JY5325CoreOO::Internal_Counter_5M = 33 ,
JY5325CoreOO::Internal_Counter_100M = 32
}
enum class | JY5325CoreOO::FileFormat { JY5325CoreOO::Bin }
enum class | JY5325CoreOO::RecordMode { JY5325CoreOO::Finite , JY5325CoreOO::Infinite }


5325 C++ Programming Manual: JY5325CoreOO::JY5325CoreOOAITask Class Reference

  • Class List
  • Class Index
  • Class Members
  • JY5325CoreOO
  • JY5325CoreOOAITask
Public Member Functions | Public Attributes | List of all members
JY5325CoreOO::JY5325CoreOOAITask Class Reference

AITask类 More...

#include <JY5325CoreOOAOTask.h>

Public Member Functions

JY5325CoreOOAITask (int slotNum)
JY5325CoreOOAITask (std::string boardName)
void | AddChannel (int chnId, double rangeLow=-10, double rangeHigh=10)
Add one channel.
void | AddChannel (std::vector< int > chnsId, double rangeLow=-10, double rangeHigh=10)
Add a group of channels.
void | AddChannel (std::vector< int > chnsId, std::vector< double > rangeLow, std::vector< double > rangeHigh)
Add a group of channels.
void | RemoveChannel (int chnId)
void | ReadData (double *pBuf, int samplesPerChannel, int timeout=-1)
Read the multi-channel data by columns and store it in a data buffer.
void | ReadRawData (short *pBuf, int samplesPerChannel, int timeout=-1)
void | GetRecordPreviewData (double *buf, int samplesPerChannel, int timeout)
void | GetRecordStatus (double &recordedLength, bool &recordDone)
bool | WaitUntilDone (int timeout=-1)
void | Start ()
启动Task
void | SendSoftwareTrigger ()
void | Stop ()
~JY5325CoreOOAITask ()

Public Attributes

std::list< AIChannel * > | Channels
List of AI channels,(5325 support 8 channel Differential)
JY5325CoreOOProperty< JY5325CoreOOAITask, double, JY5325CoreOOPropertyType::READ_WRITE > | SampleRate
Sample rate per channel.
int | SamplesToAcquire
Number of samples to be read per channel.
JY5325CoreOOProperty< JY5325CoreOOAITask, int, JY5325CoreOOPropertyType::READ_ONLY > | BufLenInSamples
Number of samples per channel can be storage in the buffer, the Property SamplesToAcquire must be less than or equal to this value.
JY5325CoreOOProperty< JY5325CoreOOAITask, uint64_t, JY5325CoreOOPropertyType::READ_ONLY > | AvailableSamples
Number of samples per channel that can be read in the buffer .
JY5325CoreOOProperty< JY5325CoreOOAITask, uint64_t, JY5325CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
AIMode Mode
AI acquisition mode, support Finite/Continuous/Record *.
AISampleClock * SampleClock
AI Sample Clock.
AITrigger * Trigger
AI Trigger Configuration.
AIAdvanced * | Advanced
AI Trigger Configuration.
AIRecord * Record
ai Data streaming Configuration
bool | DisableDigitalTriggerDelay
Disalble Digital Trigger Delay Enable.
AISync * Sync
Multi card synchronous configuration.
AISignalExport * SignalExport
Export AI Signal Configuration.
JY5325CoreOODevice * Device
Device.

Detailed Description

AITask类

Constructor & Destructor Documentation

◆ JY5325CoreOOAITask() [1/2]

JY5325CoreOO::JY5325CoreOOAITask::JY5325CoreOOAITask ( int slotNum )

◆ JY5325CoreOOAITask() [2/2]

JY5325CoreOO::JY5325CoreOOAITask::JY5325CoreOOAITask ( std::string boardName )

◆ ~JY5325CoreOOAITask()

JY5325CoreOO::JY5325CoreOOAITask::~JY5325CoreOOAITask ( )

Member Function Documentation

◆ AddChannel() [1/3]

void JY5325CoreOO::JY5325CoreOOAITask::AddChannel | ( | int | chnId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10 )

Add one channel.

Parameters
chnId | channel's physical number ，chnId=-1, add all channels。（5325 0-7）
rangeLow | lower range limit for the channel，-10V,-5V,-2V，-1V defalut -10
rangeHigh | higher range limit for the channel，10V,5V,2V，1V defalut 10

◆ AddChannel() [2/3]

void JY5325CoreOO::JY5325CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10 )

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers （5325 0-7）
rangeLow | lower range limit for the channel，-10V,-5V,-2V，-1V defalut -10
rangeHigh | higher range limit for the channel，10V,5V,2V，1V defalut 10

◆ AddChannel() [3/3]

void JY5325CoreOO::JY5325CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | std::vector< double > | rangeLow,
 |  | std::vector< double > | rangeHigh )

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers （5325 0-7）
rangeLow | lower range limit for the channel，-10V,-5V,-2V，-1V
rangeHigh | higher range limit for the channel，10V,5V,2V，1V

◆ GetRecordPreviewData()

void JY5325CoreOO::JY5325CoreOOAITask::GetRecordPreviewData | ( | double * | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

◆ GetRecordStatus()

void JY5325CoreOO::JY5325CoreOOAITask::GetRecordStatus | ( | double & | recordedLength,
 |  | bool & | recordDone )

◆ ReadData()

void JY5325CoreOO::JY5325CoreOOAITask::ReadData | ( | double * | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = -1 )

Read the multi-channel data by columns and store it in a data buffer.

Each channel is represented by one column of data.

Parameters
pBuf | Data buffer
samplesPerChannel | Number of samples per channel to read
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadRawData()

void JY5325CoreOO::JY5325CoreOOAITask::ReadRawData | ( | short * | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = -1 )

◆ RemoveChannel()

void JY5325CoreOO::JY5325CoreOOAITask::RemoveChannel ( int chnId )

◆ SendSoftwareTrigger()

void JY5325CoreOO::JY5325CoreOOAITask::SendSoftwareTrigger ( )

◆ Start()

void JY5325CoreOO::JY5325CoreOOAITask::Start ( )

启动Task

Parameters

return void

Exceptions
JYDriverException 如果启动失败

◆ Stop()

void JY5325CoreOO::JY5325CoreOOAITask::Stop ( )

◆ WaitUntilDone()

bool JY5325CoreOO::JY5325CoreOOAITask::WaitUntilDone ( int timeout = -1 )
inline

Member Data Documentation

◆ Advanced

AIAdvanced* JY5325CoreOO::JY5325CoreOOAITask::Advanced

AI Trigger Configuration.

◆ AvailableSamples

JY5325CoreOOProperty<JY5325CoreOOAITask, uint64_t, JY5325CoreOOPropertyType::READ_ONLY> JY5325CoreOO::JY5325CoreOOAITask::AvailableSamples

Number of samples per channel that can be read in the buffer .

Valid when Mode is NOT AIMode.Single.

◆ BufLenInSamples

JY5325CoreOOProperty<JY5325CoreOOAITask, int, JY5325CoreOOPropertyType::READ_ONLY> JY5325CoreOO::JY5325CoreOOAITask::BufLenInSamples

Number of samples per channel can be storage in the buffer, the Property SamplesToAcquire must be less than or equal to this value.

◆ Channels

std::list<AIChannel*> JY5325CoreOO::JY5325CoreOOAITask::Channels

List of AI channels,(5325 support 8 channel Differential)

◆ Device

JY5325CoreOODevice* JY5325CoreOO::JY5325CoreOOAITask::Device

Device.

◆ DisableDigitalTriggerDelay

bool JY5325CoreOO::JY5325CoreOOAITask::DisableDigitalTriggerDelay

Disalble Digital Trigger Delay Enable.

◆ Mode

AIMode JY5325CoreOO::JY5325CoreOOAITask::Mode

AI acquisition mode, support Finite/Continuous/Record *.

◆ Record

AIRecord* JY5325CoreOO::JY5325CoreOOAITask::Record

ai Data streaming Configuration

◆ SampleClock

AISampleClock* JY5325CoreOO::JY5325CoreOOAITask::SampleClock

AI Sample Clock.

◆ SampleRate

JY5325CoreOOProperty<JY5325CoreOOAITask, double, JY5325CoreOOPropertyType::READ_WRITE> JY5325CoreOO::JY5325CoreOOAITask::SampleRate

Sample rate per channel.

Maximum sample rate is 5M for single channel The default sample rate = 10k You can read this property to obtain the sample rate that will actually take effect in the current configuration.

Exceptions
JYDriverException

◆ SamplesToAcquire

int JY5325CoreOO::JY5325CoreOOAITask::SamplesToAcquire

Number of samples to be read per channel.

Only valid when Mode is Finite*

◆ SignalExport

AISignalExport* JY5325CoreOO::JY5325CoreOOAITask::SignalExport

Export AI Signal Configuration.

◆ Sync

AISync* JY5325CoreOO::JY5325CoreOOAITask::Sync

Multi card synchronous configuration.

◆ TransferedSamples

JY5325CoreOOProperty<JY5325CoreOOAITask, uint64_t, JY5325CoreOOPropertyType::READ_ONLY> JY5325CoreOO::JY5325CoreOOAITask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT AIMode.Single.

◆ Trigger

AITrigger* JY5325CoreOO::JY5325CoreOOAITask::Trigger

AI Trigger Configuration.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOAITask.h


5325 C++ Programming Manual: JY5325CoreOO::AIChannel Class Reference

  • JY5325CoreOO
  • AIChannel
Public Member Functions | Public Attributes | List of all members
JY5325CoreOO::AIChannel Class Reference

#include <JY5325CoreOOAITask.h>

Public Member Functions

AIChannel (int channelId, double rangeLow, double rangeHigh)

Public Attributes

int | ChannelID
double | RangeLow
double | RangeHigh

Constructor & Destructor Documentation

◆ AIChannel()

JY5325CoreOO::AIChannel::AIChannel | ( | int | channelId,
 |  | double | rangeLow,
 |  | double | rangeHigh )
 inline

Member Data Documentation

◆ ChannelID

int JY5325CoreOO::AIChannel::ChannelID

◆ RangeHigh

double JY5325CoreOO::AIChannel::RangeHigh

◆ RangeLow

double JY5325CoreOO::AIChannel::RangeLow
The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOAITask.h


5325 C++ Programming Manual: JY5325CoreOO::AIExternalSampleClock Class Reference

  • AIExternalSampleClock
Public Attributes | List of all members
JY5325CoreOO::AIExternalSampleClock Class Reference

#include <JY5325CoreOOAITask.h>

Public Attributes

ClockTerminal Terminal
External Sample Clock Input Terminal.
double ExpectedRate
Expected External Sample Clock Rate.

Member Data Documentation

◆ ExpectedRate

double JY5325CoreOO::AIExternalSampleClock::ExpectedRate

Expected External Sample Clock Rate.

◆ Terminal

ClockTerminal JY5325CoreOO::AIExternalSampleClock::Terminal

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOAITask.h


5325 C++ Programming Manual: JY5325CoreOO::AISampleClock Class Reference

  • AISampleClock
Public Attributes | List of all members
JY5325CoreOO::AISampleClock Class Reference

#include <JY5325CoreOOAITask.h>

Public Attributes

AISampleClockSource Source
AI Sample Clock Source.

Member Data Documentation

◆ Source

AISampleClockSource JY5325CoreOO::AISampleClock::Source

AI Sample Clock Source.

enum Internal/External. The default value is AISampleClockSource.Internal.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOAITask.h


5325 C++ Programming Manual: JY5325CoreOO::AITrigger Class Reference

  • AITrigger
Public Attributes | List of all members
JY5325CoreOO::AITrigger Class Reference

Constructor to create an AITrigger task object. More...

#include <JY5325CoreOOAITask.h>

Public Attributes

AITriggerType Type
AI trigger type.
AITriggerMode Mode
AI trigger mode.
AIDigitalTrigger * Digital
Digital Trigger Congfiguration.
AIAnalogTrigger * Analog
AI Analog Trigger.
int | ReTriggerCount
Number of repeat triggers.
unsigned int | PreTriggerSamples
AI pretrigger samples, must be less than or equal to JYPCIe5111AITask.SamplesToAcquire.

Detailed Description

Constructor to create an AITrigger task object.

Used to build AI Trigger

Member Data Documentation

◆ Analog

AIAnalogTrigger* JY5325CoreOO::AITrigger::Analog

AI Analog Trigger.

Valid when Type is AITriggerType.Analog.

◆ Digital

AIDigitalTrigger* JY5325CoreOO::AITrigger::Digital

Digital Trigger Congfiguration.

Valid when Type is AITriggerType.Digital.

◆ Mode

AITriggerMode JY5325CoreOO::AITrigger::Mode

AI trigger mode.

enum Start/Reference. The default value is AITriggerMode.Start.

◆ PreTriggerSamples

unsigned int JY5325CoreOO::AITrigger::PreTriggerSamples

AI pretrigger samples, must be less than or equal to JYPCIe5111AITask.SamplesToAcquire.

Valid when Mode is AITriggerMode.Reference. Pretrigger samples, must be greater than 0. Valid when Type is AITriggerType.Analog. Pretrigger samples, must be greater than 1. Valid when Type is AITriggerType.Digital.

◆ ReTriggerCount

int JY5325CoreOO::AITrigger::ReTriggerCount

Number of repeat triggers.

When 0 or 1 only trigger once, When -1 continuous retrigger until stop.

◆ Type

AITriggerType JY5325CoreOO::AITrigger::Type

AI trigger type.

enum Analog/Digital/Immediate/Soft. The default value is AITriggerType.Immediate.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOAITask.h


5325 C++ Programming Manual: JY5325CoreOO::AISync Class Reference

  • AISync
Public Attributes | List of all members
JY5325CoreOO::AISync Class Reference

#include <JY5325CoreOOAITask.h>

Public Attributes

SyncTopology Topology
Configure sync signal.
SyncTriggerRouting TriggerRouting
trigger signal Routing, default routing PXITrig0

Member Data Documentation

◆ Topology

SyncTopology JY5325CoreOO::AISync::Topology

Configure sync signal.

◆ TriggerRouting

SyncTriggerRouting JY5325CoreOO::AISync::TriggerRouting

trigger signal Routing, default routing PXITrig0

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOAITask.h


5325 C++ Programming Manual: JY5325CoreOO::AIDigitalTrigger Class Reference

  • AIDigitalTrigger
Public Attributes | List of all members
JY5325CoreOO::AIDigitalTrigger Class Reference

#include <JY5325CoreOOAITask.h>

Public Attributes

AIDigitalTriggerSource Source
AI Digital Trigger source.
AIDigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Member Data Documentation

◆ Edge

AIDigitalTriggerEdge JY5325CoreOO::AIDigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

AIDigitalTriggerSource JY5325CoreOO::AIDigitalTrigger::Source

AI Digital Trigger source.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOAITask.h


5325 C++ Programming Manual: JY5325CoreOO::AIAnalogHysteresisComparator Class Reference

  • AIAnalogHysteresisComparator
Public Attributes | List of all members
JY5325CoreOO::AIAnalogHysteresisComparator Class Reference

#include <JY5325CoreOOAITask.h>

Public Attributes

AIAnalogTriggerEdge Slope
AI Analog Trigger Edge.
double | HighThreshold
High Threshold.
double | LowThreshold
Low Threshold.

Member Data Documentation

◆ HighThreshold

double JY5325CoreOO::AIAnalogHysteresisComparator::HighThreshold

High Threshold.

◆ LowThreshold

double JY5325CoreOO::AIAnalogHysteresisComparator::LowThreshold

Low Threshold.

◆ Slope

AIAnalogTriggerEdge JY5325CoreOO::AIAnalogHysteresisComparator::Slope

AI Analog Trigger Edge.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOAITask.h


5325 C++ Programming Manual: JY5325CoreOO::AIAnalogWindowComparator Class Reference

  • AIAnalogWindowComparator
Public Attributes | List of all members
JY5325CoreOO::AIAnalogWindowComparator Class Reference

#include <JY5325CoreOOAITask.h>

Public Attributes

AIAnalogWindowCondition Condition
AI Analog Window Condition.
double | HighThreshold
High Threshold.
double | LowThreshold
Low Threshold.

Member Data Documentation

◆ Condition

AIAnalogWindowCondition JY5325CoreOO::AIAnalogWindowComparator::Condition

AI Analog Window Condition.

◆ HighThreshold

double JY5325CoreOO::AIAnalogWindowComparator::HighThreshold

High Threshold.

◆ LowThreshold

double JY5325CoreOO::AIAnalogWindowComparator::LowThreshold

Low Threshold.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOAITask.h


5325 C++ Programming Manual: JY5325CoreOO::AIAnalogEdgeComparator Class Reference

  • AIAnalogEdgeComparator
Public Attributes | List of all members
JY5325CoreOO::AIAnalogEdgeComparator Class Reference

#include <JY5325CoreOOAITask.h>

Public Attributes

AIAnalogTriggerEdge Slope
AI Analog Trigger Edge.
double Threshold
Threshold.

Member Data Documentation

◆ Slope

AIAnalogTriggerEdge JY5325CoreOO::AIAnalogEdgeComparator::Slope

AI Analog Trigger Edge.

◆ Threshold

double JY5325CoreOO::AIAnalogEdgeComparator::Threshold

Threshold.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOAITask.h


5325 C++ Programming Manual: JY5325CoreOO::AIAnalogTrigger Class Reference

  • AIAnalogTrigger
Public Attributes | List of all members
JY5325CoreOO::AIAnalogTrigger Class Reference

#include <JY5325CoreOOAITask.h>

Public Attributes

AIAnalogTriggerSource Source
Analog Trigger source.
AIAnalogTriggerComparator Comparator
AI Analog Trigger Comparator.
AIAnalogEdgeComparator * Edge
AI Analog Edge Comparator.
AIAnalogHysteresisComparator * Hysteresis
AI Analog Hysteresis Comparatorr.
AIAnalogWindowComparator * Window
AI Analog Window Comparatorr.

Member Data Documentation

◆ Comparator

AIAnalogTriggerComparator JY5325CoreOO::AIAnalogTrigger::Comparator

AI Analog Trigger Comparator.

◆ Edge

AIAnalogEdgeComparator* JY5325CoreOO::AIAnalogTrigger::Edge

AI Analog Edge Comparator.

◆ Hysteresis

AIAnalogHysteresisComparator* JY5325CoreOO::AIAnalogTrigger::Hysteresis

AI Analog Hysteresis Comparatorr.

◆ Source

AIAnalogTriggerSource JY5325CoreOO::AIAnalogTrigger::Source

Analog Trigger source.

◆ Window

AIAnalogWindowComparator* JY5325CoreOO::AIAnalogTrigger::Window

AI Analog Window Comparatorr.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOAITask.h


5325 C++ Programming Manual: JY5325CoreOO::AIRecord Class Reference

  • AIRecord
Public Attributes | List of all members
JY5325CoreOO::AIRecord Class Reference

#include <JY5325CoreOOAITask.h>

Public Attributes

std::string | FilePath
User specified file path.
JY5325CoreOO::FileFormat File_Format
Streaming file format.
RecordMode Mode
stream mode .
double | Length
User specified stream length in second.

Member Data Documentation

◆ File_Format

JY5325CoreOO::FileFormat JY5325CoreOO::AIRecord::File_Format

Streaming file format.

enum BIN.

◆ FilePath

std::string JY5325CoreOO::AIRecord::FilePath

User specified file path.

◆ Length

double JY5325CoreOO::AIRecord::Length

User specified stream length in second.

Only when Mode is RecordMode.Finite.

◆ Mode

RecordMode JY5325CoreOO::AIRecord::Mode

stream mode .

enum Finite/Infinite.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOAITask.h


5325 C++ Programming Manual: JY5325CoreOO::AISignalExport Class Reference

  • AISignalExport
Public Member Functions | List of all members
JY5325CoreOO::AISignalExport Class Reference

#include <JY5325CoreOOAITask.h>

Public Member Functions

void | Add (AISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (AISignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Member Function Documentation

◆ Add() [1/2]

void JY5325CoreOO::AISignalExport::Add | ( | AISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | AI Signal Source
destination | Export Desination

◆ Add() [2/2]

void JY5325CoreOO::AISignalExport::Add | ( | AISignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | AI Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JY5325CoreOO::AISignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5325CoreOO::AISignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOAITask.h


5325 C++ Programming Manual: JY5325CoreOO Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Enumerations | Functions
JY5325CoreOO Namespace Reference

Classes

class | AIAnalogEdgeComparator
class | AIAnalogHysteresisComparator
class | AIAnalogTrigger
class | AIAnalogWindowComparator
class | AIChannel
class | AIDigitalTrigger
class | AIExternalSampleClock
class | AIRecord
class | AISampleClock
class | AISignalExport
class | AISync
class | AITrigger
Constructor to create an AITrigger task object. More...
class | AOChannel
class | AODigitalTrigger
AO Digital trigger . More...
class | AOSampleClock
External Sample Clock Configuration Class. More...
class | AOTrigger
Constructor to create an AOTrigger task object. More...
class | CIDigitalTrigger
CI Digital trigger . More...
class | CIExternalSampleClock
CI Implicit Sample Clock class. More...
class | CIExternalTimebase
class | CIImplicitSampleClock
CI Implicit Sample Clock class. More...
class | CIInternalSampleClock
CI Internal Sample Clock Configuration Class. More...
class | CISampleClock
CI Sample Clock class. More...
class | CISignalExport
CI Signal Export Class. More...
class | CITimebase
Timebase configuration class. More...
class | CITrigger
Constructor to create an CITrigger task object. More...
class | CODigitalTrigger
CO Digital trigger . More...
class | COExternalTimebase
class | COPulse
Pulse Parameter. More...
class | COSignalExport
CO Signal Export Class. More...
class | COTimebase
Timebase configuration class. More...
class | COTrigger
Constructor to create an COTrigger task object. More...
class | DIChannel
DI Channel parameter class . More...
class | DIDigitalTrigger
DI Digital trigger . More...
class | DIExternalSampleClock
External Sample Clock Configuration Class. More...
class | DISampleClock
Sample clock configuration class. More...
class | DISignalExport
DI Signal Export Class. More...
class | DITrigger
Constructor to create an DITrigger task object. More...
class | DOChannel
DO Channel parameter class . More...
class | DODigitalTrigger
DO Digital trigger. More...
class | DOExternalSampleClock
External Sample Clock Configuration Class. More...
class | DOSampleClock
Sample clock configuration class. More...
class | DOSignalExport
DO Signal Export Class. More...
class | DOTrigger
Constructor to create an DOTrigger task object. More...
class | EdgeCounting
Configure CI EdgeCounting. More...
class | EdgeCountingOutEvent
Edge counting output event configuration class. More...
class | ExternalReferenceClock
class | FrequencyMeas
Configure CI Measure. More...
class | JY5325CoreOOAITask
AITask类 More...
class | JY5325CoreOOAOTask
class | JY5325CoreOOCITask
class | JY5325CoreOOCOTask
class | JY5325CoreOODevice
class | JY5325CoreOODITask
class | JY5325CoreOODOTask
class | JY5325CoreOOLog
class | JY5325CoreOOProperty
属性模板类 More...
class | JY5325CoreOOReferenceClock
class | JYDriverException
class | PauseTrigger
Pause trigger configuration class. More...
class | PeriodMeas
Configure CI Measure. More...
class | PFIFilter
class | PFISetting
class | PulseMeas
Configure CI Measure. More...
class | QuadEncoder
Configure CI Measure. More...
class | SemiPeriodMeas
Configure CI SemiPeriodMeas. More...
class | TwoEdgeSeparation
Configure CI Measure. More...
class | TwoPulseEncoder
Configure CI Measure. More...

Enumerations

enum class | AIMode { Finite = 0x0 , Continuous = 0x1 , Record = 0x3 }
enum class | AISampleClockSource { Internal }
enum class | AITriggerType { Immediate = 0x0 , Digital = 0x1 , Analog = 0x2 , Soft = 0x3 }
enum class | AITriggerMode { Start , Reference }
enum class AIAnalogTriggerSource {
Channel_0 , Channel_1 , Channel_2 , Channel_3 ,
Channel_4 , Channel_5 , Channel_6 , Channel_7
}
enum class AIDigitalTriggerSource {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PXI_Trig0 = 8 , PXI_Trig1 = 9 , PXI_Trig2 = 10 , PXI_Trig3 = 11 ,
PXI_Trig4 = 12 , PXI_Trig5 = 13 , PXI_Trig6 = 14 , PXI_Trig7 = 15 ,
AO_StartTrig = 18 , DI_StartTrig = 19 , DI_ReferenceTrig = 20 , DO_StartTrig = 21 ,
CIO_0_StartTrig = 22 , CIO_1_StartTrig = 23 , CO_0_Out = 24 , CO_1_Out = 25
}
enum class | AIDigitalTriggerEdge { Rising = 0x0 , Falling = 0x1 }
enum class | AIAnalogTriggerEdge { Rising , Falling }
enum class | AIAnalogWindowCondition { Entering , Leaving }
AI Analog Window Trigger Condition. More...
enum class | AIAnalogTriggerComparator { Edge , Hysteresis , Window }
AI Analog Trigger Comparator. More...
enum class AISignalExportSource {
StartTrig = 16 , ReferenceTrig = 17 , Internal_Counter_100K = 34 , Internal_Counter_5M = 33 ,
Internal_Counter_100M = 32
}
enum class | FileFormat { Bin }
enum class | RecordMode { Finite , Infinite }
enum class | AOMode { Single = 3 , Finite = 0 , ContinuousNoWrapping = 2 , ContinuousWrapping = 1 }
enum class | AODigitalTriggerEdge { Rising , Falling }
AO Digital Trigger Edge. More...
enum class AODigitalTriggerSource {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PXI_Trig0 = 8 , PXI_Trig1 = 9 , PXI_Trig2 = 10 , PXI_Trig3 = 11 ,
PXI_Trig4 = 12 , PXI_Trig5 = 13 , PXI_Trig6 = 14 , PXI_Trig7 = 15 ,
AI_StartTrig = 16 , AI_ReferenceTrig = 17 , DI_StartTrig = 19 , DI_ReferenceTrig = 20 ,
DO_StartTrig = 21 , CIO_0_StartTrig = 22 , CIO_1_StartTrig = 23 , CO_0_Out = 24 ,
CO_1_Out = 25
}
AO Digital trigger source. More...
enum class | AOSampleClockSource { Internal }
AO Sample Clock Source. More...
enum class | AOSignalExportSource { StartTrig = 19 , Internal_Counter_100K = 34 , Internal_Counter_5M = 33 , Internal_Counter_100M = 32 }
SourceSignal. More...
enum class | AOTriggerType { Immediate = 0x0 , Digital = 0x1 , Soft = 0x3 }
TriggerType Digital/Immediate/Soft. More...
enum class | CountDirection { Up = 0x0 , Down = 0x1 , External = 0x2 }
Counter direction. More...
enum class | CIMode { Single = 2 , Finite = 0 , Continuous = 1 }
CIMode. More...
enum class CIType {
EdgeCounting , Period , Frequency , Pulse ,
SemiPeriod , TwoEdgeSeparation , QuadEncoder , TwoPulseEncoder
}
Counter Input Application Type. More...
enum class | CISampleClockSource { Implicit = 0x0 , Internal = 0x1 , External = 0x2 }
CI Sample Clock Source. More...
enum class | EdgeType { Rising , Falling , Any }
Edge Type. More...
enum class | ValueReturnMode { TwoValue , OneValue }
TwoEdgeSeparation value return mode.only for TwoEdgeSeparation type. More...
enum class | QuadEncodingType { X1 , X2 , X4 }
Quadrature Encoding Type. More...
enum class | CITriggerType { Immediate = 0x0 , Digital = 0x1 , Soft = 0x3 }
TriggerType Digital/Immediate/Soft. More...
enum class CIDigitalTriggerSource {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PXI_Trig0 = 8 , PXI_Trig1 = 9 , PXI_Trig2 = 10 , PXI_Trig3 = 11 ,
PXI_Trig4 = 12 , PXI_Trig5 = 13 , PXI_Trig6 = 14 , PXI_Trig7 = 15 ,
AI_StartTrig = 16 , AI_ReferenceTrig = 17 , AO_StartTrig = 18 , DI_StartTrig = 19 ,
DI_ReferenceTrig = 20 , DO_StartTrig = 21 , CIO_0_StartTrig = 22 , CIO_1_StartTrig = 23 ,
CO_0_Out = 24 , CO_1_Out = 25
}
CI Digital trigger source. More...
enum class | CIDigitalTriggerEdge { Rising , Falling }
CI Digital Trigger Edge. More...
enum class | EdgeCntOunEvtIdleState { LowLevel = 0 , HighLevel = 1 }
Output idle state when the event has not occurred. More...
enum class CISignalExportSource {
StartTrig = 0 , SampleClock = 1 , Internal_Counter_100K = 34 , Internal_Counter_5M = 33 ,
Internal_Counter_100M = 32
}
SourceSignal. More...
enum class | CITimebaseSource { Internal100MHz = 0 , Internal5MHz = 1 , Internal100kHz = 2 , External = 3 }
Timebase source. More...
enum class | JY5325CoreOOPropertyType { READ_ONLY = 1 , WRITE_ONLY = 2 , READ_WRITE = 3 }
enum class JYErrorCode {
NoError = 0 , TimeOut = -10001 , ErrorParam = -10002 , IncorrectCallOrder = -10003 ,
CannotCall = -10004 , UserBufferError = -10005 , BufferOverflow = -10006 , BufferDownflow = -10007 ,
HardwareResourceReserved = -10008 , aiIsStart = -10009 , ErrorParam1 = -10010
}
错误代码的定义 More...
enum class JYDriverExceptionPublic {
UnKnown = 0 , OpenDeviceFailed = -10001 , CloseDeviceFailed = -10002 , ResetDeviceFailed = -10003 ,
GetDevicePropertyFailed = -10004 , SetDevicePropertyFailed = -10005 , HardwareResourceIsReserved = -10006 , MethodNotPermitedToCallWhenCurrentStatus = -10007 ,
InvalidUserDataBuffer = -10008 , NoChannelAdded = -10009 , NotSupportOperationForCurrentDevice = -10010 , CreatTaskFailed = -10100 ,
StartTaskFailed = -10101 , StopTaskFailed = -10102 , TaskHasNotStarted = -10103 , TaskHasStartedCannotPerformTheSetOperation = -10104 ,
ChannelNumberParameterInvalid = -10105 , ChannelInputRangeParameterInvalid = -10106 , ChannelTerminalParameterInvalid = -10107 , ChannelCouplingParameterInvalid = -10108 ,
SampeleModeParameterInvalid = -10109 , SampleClockParameterInvalid = -10110 , SampleRateParameterInvalid = -10111 , UpdateRateParameterInvalid = -10112 ,
TriggerParameterInvalid = -10113 , ReferenceTriggerDoesNotMatchWithSampleMode = -10114 , PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint = -10115 , ReadDataFailed = -10016 ,
ReadDataTimeout = -10017 , WriteDataFailed = -10018 , WriteDataTimeout = -10019 , WriteDataLengthCannotBeLessThanN = -10020 ,
BufferDataOverflow = -10021 , BufferDataDownflow = -10022 , CheckBufferFailed = -10023 , PointInvalidInFiniteMode = -10024 ,
ReadPointInvalid = -10025 , OnlySupportRecordMode = -10026 , SendSoftTirggerFailed = -10027 , TaskTimeout = -10028 ,
CounterParametersInvalid = -10029 , WritePointInvalid = -10030 , SignalExportDestinationInvalid = -10031 , InvalidParameter = -10033
}
enum class ClockTerminal {
PFI0 = 0 , PFI1 = 1 , PFI2 = 2 , PFI3 = 3 ,
PFI4 = 4 , PFI5 = 5 , PFI6 = 6 , PFI7 = 7 ,
PXI_Trig0 = 8 , PXI_Trig1 = 9 , PXI_Trig2 = 10 , PXI_Trig3 = 11 ,
PXI_Trig4 = 12 , PXI_Trig5 = 13 , PXI_Trig6 = 14 , PXI_Trig7 = 15 ,
DI_SampleClock = 18 , DO_SampleClock = 19 , CI_0_SampleClock = 20 , CI_1_SampleClock = 21 ,
CO_0_Output = 22 , CO_1_Output = 23
}
enum class | SyncTopology { Independent , Master , Slave }
enum class SyncTriggerRouting {
NONE = -1 , PFI0 , PFI1 , PFI2 ,
PFI3 , PFI4 , PFI5 , PFI6 ,
PFI7 , PXI_Trig0 = 8 , PXI_Trig1 = 9 , PXI_Trig2 = 10 ,
PXI_Trig3 = 11 , PXI_Trig4 = 12 , PXI_Trig5 = 13 , PXI_Trig6 = 14 ,
PXI_Trig7 = 15
}
enum class SignalExportDestination {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PXI_Trig0 = 8 , PXI_Trig1 = 9 , PXI_Trig2 = 10 , PXI_Trig3 = 11 ,
PXI_Trig4 = 12 , PXI_Trig5 = 13 , PXI_Trig6 = 14 , PXI_Trig7 = 15
}
enum class | OutputCompleteState { Zero , Hold }
Output Complete State. More...
enum class IOTerminal {
PFI0 = 0 , PFI1 = 1 , PFI2 = 2 , PFI3 = 3 ,
PFI4 = 4 , PFI5 = 5 , PFI6 = 6 , PFI7 = 7 ,
PXI_Trig0 = 8 , PXI_Trig1 = 9 , PXI_Trig2 = 10 , PXI_Trig3 = 11 ,
PXI_Trig4 = 12 , PXI_Trig5 = 13 , PXI_Trig6 = 14 , PXI_Trig7 = 15 ,
None = 16
}
Cunter IO Terminal. More...
enum class | LevelPolarity { LowLevel = 0 , HighLevel = 1 , None = 2 }
Level Polarity. More...
enum class InputTerminal {
PFI0 = 0 , PFI1 = 1 , PFI2 = 2 , PFI3 = 3 ,
PFI4 = 4 , PFI5 = 5 , PFI6 = 6 , PFI7 = 7 ,
PXI_Trig0 = 8 , PXI_Trig1 = 9 , PXI_Trig2 = 10 , PXI_Trig3 = 11 ,
PXI_Trig4 = 12 , PXI_Trig5 = 13 , PXI_Trig6 = 14 , PXI_Trig7 = 15 ,
AI_SampleClock = 16 , AO_SampleClock = 17 , DI_SampleClock = 18 , DO_SampleClock = 19 ,
CO_0_OutPut = 20 , CO_1_OutPut = 21 , Timebase_100MHz = 22 , Timebase_5MHz = 23 ,
Timebase_100kHz = 24
}
Cunter Input Terminal. More...
enum class | COIdleState { HighLevel = 0x1 , LowLevel = 0x0 }
Idle state when pulse output before start and after stop. More...
enum class | COMode { Single = 3 , Finite = 0 , ContinuousNoWrapping = 2 , ContinuousWrapping = 1 }
enum class | COTriggerType { Immediate = 0x0 , Digital = 0x1 , Soft = 0x3 }
TriggerType Digital/Immediate/Soft. More...
enum class CODigitalTriggerSource {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PXI_Trig0 = 8 , PXI_Trig1 = 9 , PXI_Trig2 = 10 , PXI_Trig3 = 11 ,
PXI_Trig4 = 12 , PXI_Trig5 = 13 , PXI_Trig6 = 14 , PXI_Trig7 = 15 ,
AI_StartTrig = 16 , AI_ReferenceTrig = 17 , AO_StartTrig = 18 , DI_StartTrig = 19 ,
DI_ReferenceTrig = 20 , DO_StartTrig = 21 , CIO_0_StartTrig = 22 , CIO_1_StartTrig = 23 ,
CO_0_Out = 24 , CO_1_Out = 25
}
CO Digital trigger source. More...
enum class | CODigitalTriggerEdge { Rising , Falling }
CO Digital Trigger Edge. More...
enum class | COPulseType { DutyCycleFrequency , HighLowTime , HighLowTick }
Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick. More...
enum class | COTimebaseSource { Internal100MHz = 0 , Internal5MHz = 1 , Internal100kHz = 2 , External = 3 }
Timebase source. More...
enum class COSignalExportSource {
StartTrig , Output , Internal_Counter_100K = 34 , Internal_Counter_5M = 33 ,
Internal_Counter_100M = 32
}
SourceSignal. More...
enum class | ExternalReferenceClockTerminal { PXIe_Clk100 = 0x1 }
enum class | ReferenceClockSource { Internal = 0x0 , External = 0x1 }
enum class PFITerminal {
PFI0 = 0 , PFI1 = 1 , PFI2 = 2 , PFI3 = 3 ,
PFI4 = 4 , PFI5 = 5 , PFI6 = 6 , PFI7 = 7 ,
PFI8 = 8 , PFI9 = 9 , PFI10 = 10 , PFI11 = 11 ,
PFI12 = 12 , PFI13 = 13 , PFI14 = 14 , PFI15 = 15
}
Input/Output Terminal of PFI. More...
enum class | DISampleClockSource { Internal , External }
DI Sample Clock Source. More...
enum class | DIMode { Single = 2 , Finite = 0 , Continuous = 1 }
DIMode. More...
enum class DISignalExportSource {
StartTrig = 21 , ReferenceTrig = 22 , SampleClock = 23 , Internal_Counter_100K = 34 ,
Internal_Counter_5M = 33 , Internal_Counter_100M = 32
}
SourceSignal. More...
enum class | DITriggerMode { Start , Reference }
DI Trigger Mode. More...
enum class | DITriggerType { Immediate = 0 , Digital = 1 , Soft = 3 }
TriggerType Digital/Immediate/Soft. More...
enum class DIDigitalTriggerSource {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PXI_Trig0 = 8 , PXI_Trig1 = 9 , PXI_Trig2 = 10 , PXI_Trig3 = 11 ,
PXI_Trig4 = 12 , PXI_Trig5 = 13 , PXI_Trig6 = 14 , PXI_Trig7 = 15 ,
AI_StartTrig = 16 , AI_ReferenceTrig = 17 , AO_StartTrig = 18 , DO_StartTrig = 21 ,
CIO_0_StartTrig = 22 , CIO_1_StartTrig = 23 , CO_0_Out = 24 , CO_1_Out = 25
}
DI Digital trigger source. More...
enum class | DIDigitalTriggerEdge { Rising , Falling }
DI Digital Trigger Edge. More...
enum class | DOSampleClockSource { Internal , External }
DO Sample Clock Source. More...
enum class | DOMode { Single = 3 , Finite = 0 , ContinuousWrapping = 1 , ContinuousNoWrapping = 2 }
DOMode. More...
enum class | DODigitalTriggerEdge { Rising , Falling }
DO Digital Trigger Edge. More...
enum class DODigitalTriggerSource {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PXI_Trig0 = 8 , PXI_Trig1 = 9 , PXI_Trig2 = 10 , PXI_Trig3 = 11 ,
PXI_Trig4 = 12 , PXI_Trig5 = 13 , PXI_Trig6 = 14 , PXI_Trig7 = 15 ,
AI_StartTrig = 16 , AI_ReferenceTrig = 17 , AO_StartTrig = 18 , DI_StartTrig = 19 ,
DI_ReferenceTrig = 20 , CIO_0_StartTrig = 22 , CIO_1_StartTrig = 23 , CO_0_Out = 24 ,
CO_1_Out = 25
}
DO Digital trigger source. More...
enum class | DOTriggerType { Immediate = 0 , Digital = 1 , Soft = 3 }
TriggerType Digital/Immediate/Soft. More...
enum class DOSignalExportSource {
StartTrig = 24 , SampleClock = 25 , Internal_Counter_100K = 34 , Internal_Counter_5M = 33 ,
Internal_Counter_100M = 32
}
SourceSignal. More...
enum class JY5325CoreOOLogLevel {
DEBUG_LOG_LEVEL , INFO_LOG_LEVEL , WARN_LOG_LEVEL , ERROR_LOG_LEVEL ,
FATAL_LOG_LEVEL
}

Functions

std::string GetSignalExportDestinationString (SignalExportDestination destination)

Enumeration Type Documentation

◆ AIAnalogTriggerComparator

enum class JY5325CoreOO::AIAnalogTriggerComparator
strong

AI Analog Trigger Comparator.

Enumerator
Edge | Edge Comparator.
Hysteresis | Hysteresis Comparator.
Window | Window Comparator.

◆ AIAnalogTriggerEdge

enum class JY5325CoreOO::AIAnalogTriggerEdge
strong
Enumerator
Rising | Rising.
Falling | Falling.

◆ AIAnalogTriggerSource

enum class JY5325CoreOO::AIAnalogTriggerSource
strong
Enumerator
Channel_0 | Channel_0 as the trigger source.
Channel_1 | Channel_1 as the trigger source.
Channel_2 | Channel_2 as the trigger source.
Channel_3 | Channel_3 as the trigger source.
Channel_4 | Channel_4 as the trigger source.
Channel_5 | Channel_5 as the trigger source.
Channel_6 | Channel_6 as the trigger source.
Channel_7 | Channel_7 as the trigger source.

◆ AIAnalogWindowCondition

enum class JY5325CoreOO::AIAnalogWindowCondition
strong

AI Analog Window Trigger Condition.

Enumerator
Entering | Rising.
Leaving | Falling.

◆ AIDigitalTriggerEdge

enum class JY5325CoreOO::AIDigitalTriggerEdge
strong
Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ AIDigitalTriggerSource

enum class JY5325CoreOO::AIDigitalTriggerSource
strong
Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.
AO_StartTrig | AO_StartTrig.
DI_StartTrig | DI_StartTrig.
DI_ReferenceTrig | DI_ReferenceTrig.
DO_StartTrig | AO_StartTrig.
CIO_0_StartTrig | CI0_StartTrig.
CIO_1_StartTrig | CI1_StartTrig.
CO_0_Out | CI0_StartTrig.
CO_1_Out | CI1_StartTrig.

◆ AIMode

enum class JY5325CoreOO::AIMode
strong
Enumerator
Finite
Continuous
Record

◆ AISampleClockSource

enum class JY5325CoreOO::AISampleClockSource
strong
Enumerator
Internal

Internal Clock Source.

◆ AISignalExportSource

enum class JY5325CoreOO::AISignalExportSource
strong
Enumerator
StartTrig | AI_StartTrig.
ReferenceTrig | AI_ReferenceTrig.
Internal_Counter_100K | Internal Counte 100K timebase.
Internal_Counter_5M | Internal Counte 5M timebase.
Internal_Counter_100M | Internal Counte 100Mtimebase.

◆ AITriggerMode

enum class JY5325CoreOO::AITriggerMode
strong
Enumerator
Start | Start Trigger.
Reference | Reference Trigger，Valid when JY5325AITask.Mode is AIMode.Finite

◆ AITriggerType

enum class JY5325CoreOO::AITriggerType
strong
Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Analog | Analog Trigger.
Soft | Soft Trigger.

◆ AODigitalTriggerEdge

enum class JY5325CoreOO::AODigitalTriggerEdge
strong

AO Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ AODigitalTriggerSource

enum class JY5325CoreOO::AODigitalTriggerSource
strong

AO Digital trigger source.

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.
AI_StartTrig | AO_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
DI_StartTrig | DI_StartTrig.
DI_ReferenceTrig | DI_ReferenceTrig.
DO_StartTrig | AO_StartTrig.
CIO_0_StartTrig | CI0_StartTrig.
CIO_1_StartTrig | CI1_StartTrig.
CO_0_Out | CI0_StartTrig.
CO_1_Out | CI1_StartTrig.

◆ AOMode

enum class JY5325CoreOO::AOMode
strong
Enumerator
Single | Single.
Finite | Finite.
ContinuousNoWrapping | ContinuousNoWrapping.
ContinuousWrapping | ContinuousWrapping.

◆ AOSampleClockSource

enum class JY5325CoreOO::AOSampleClockSource
strong

AO Sample Clock Source.

Enumerator
Internal

Internal Clock Source.

◆ AOSignalExportSource

enum class JY5325CoreOO::AOSignalExportSource
strong

SourceSignal.

Enumerator
StartTrig | AO_StartTrig.
Internal_Counter_100K | Internal Counte 100K timebase.
Internal_Counter_5M | Internal Counte 5M timebase.
Internal_Counter_100M | Internal Counte 100Mtimebase.

◆ AOTriggerType

enum class JY5325CoreOO::AOTriggerType
strong

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ CIDigitalTriggerEdge

enum class JY5325CoreOO::CIDigitalTriggerEdge
strong

CI Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ CIDigitalTriggerSource

enum class JY5325CoreOO::CIDigitalTriggerSource
strong

CI Digital trigger source.

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
AO_StartTrig | AO_StartTrig.
DI_StartTrig | DI_StartTrig.
DI_ReferenceTrig | DI_ReferenceTrig.
DO_StartTrig | AO_StartTrig.
CIO_0_StartTrig | CI0_StartTrig.
CIO_1_StartTrig | CI1_StartTrig.
CO_0_Out | CI0_StartTrig.
CO_1_Out | CI1_StartTrig.

◆ CIMode

enum class JY5325CoreOO::CIMode
strong

CIMode.

Enumerator
Single | Single.
Finite | Finite.
Continuous | Continuous.

◆ CISampleClockSource

enum class JY5325CoreOO::CISampleClockSource
strong

CI Sample Clock Source.

Enumerator
Implicit | Implicit.
Internal | Internal.
External | External.

◆ CISignalExportSource

enum class JY5325CoreOO::CISignalExportSource
strong

SourceSignal.

Enumerator
StartTrig | CI_StartTrig.
SampleClock | CI_SampleClock.
Internal_Counter_100K | Internal Counte 100K timebase.
Internal_Counter_5M | Internal Counte 5M timebase.
Internal_Counter_100M | Internal Counte 100Mtimebase.

◆ CITimebaseSource

enum class JY5325CoreOO::CITimebaseSource
strong

Timebase source.

Enumerator
Internal100MHz | 内部100MHz时基 Internal 100MHz Timebase
Internal5MHz | 内部5MHz时基 Internal 5MHz Timebase
Internal100kHz | 内部100kHz时基 Internal 100kHz Timebase
External | 外部时基 External Timebase

◆ CITriggerType

enum class JY5325CoreOO::CITriggerType
strong

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ CIType

enum class JY5325CoreOO::CIType
strong

Counter Input Application Type.

Enumerator
EdgeCounting | Edge Counting.
Period | Period Measure.
Frequency | Frequenc Measure.
Pulse | Pulse Measure.
SemiPeriod | SemiPeriod Measure.
TwoEdgeSeparation | TwoEdgeSeparation Measure.
QuadEncoder | QuadEncoder.
TwoPulseEncoder | EncoderTwoPulse.

◆ ClockTerminal

enum class JY5325CoreOO::ClockTerminal
strong
Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PXI_Trig0 | PXITrigger_0.
PXI_Trig1 | PXITrigger_1.
PXI_Trig2 | PXITrigger_2.
PXI_Trig3 | PXITrigger_3.
PXI_Trig4 | PXITrigger_4.
PXI_Trig5 | PXITrigger_5.
PXI_Trig6 | PXITrigger_6.
PXI_Trig7 | PXITrigger_7.
DI_SampleClock | DI_SampleClock.
DO_SampleClock | DO_SampleClock.
CI_0_SampleClock | CI_0_SampleClock.
CI_1_SampleClock | CI_1_SampleClock.
CO_0_Output | CO_0_Output.
CO_1_Output | CO_1_Output.

◆ CODigitalTriggerEdge

enum class JY5325CoreOO::CODigitalTriggerEdge
strong

CO Digital Trigger Edge.

Enumerator
Rising | Rising Edge.
Falling | Falling Edge.

◆ CODigitalTriggerSource

enum class JY5325CoreOO::CODigitalTriggerSource
strong

CO Digital trigger source.

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
AO_StartTrig | AO_StartTrig.
DI_StartTrig | DI_StartTrig.
DI_ReferenceTrig | DI_ReferenceTrig.
DO_StartTrig | AO_StartTrig.
CIO_0_StartTrig | CI0_StartTrig.
CIO_1_StartTrig | CI1_StartTrig.
CO_0_Out | CI0_StartTrig.
CO_1_Out | CI1_StartTrig.

◆ COIdleState

enum class JY5325CoreOO::COIdleState
strong

Idle state when pulse output before start and after stop.

Enumerator
HighLevel | Idle state is high level.
LowLevel | Idle state is low level.

◆ COMode

enum class JY5325CoreOO::COMode
strong
Enumerator
Single | Single pulse output.
Finite | Finite.
ContinuousNoWrapping | ContinuousNoWrapping.
ContinuousWrapping | ContinuousWrapping.

◆ COPulseType

enum class JY5325CoreOO::COPulseType
strong

Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick.

Enumerator
DutyCycleFrequency | Configure CO output pulse according to its DutyCycle and Freqency.
HighLowTime | Configure CO output pulse according to duration of its high/low voltage levels.
HighLowTick | Configure CO output pulse according to its high/low tick level.

◆ COSignalExportSource

enum class JY5325CoreOO::COSignalExportSource
strong

SourceSignal.

Enumerator
StartTrig | CI_StartTrig.
Output | CO_Output.
Internal_Counter_100K | Internal Counte 100K timebase.
Internal_Counter_5M | Internal Counte 5M timebase.
Internal_Counter_100M | Internal Counte 100Mtimebase.

◆ COTimebaseSource

enum class JY5325CoreOO::COTimebaseSource
strong

Timebase source.

Enumerator
Internal100MHz | 内部100MHz时基 Internal 100MHz Timebase
Internal5MHz | 内部5MHz时基 Internal 5MHz Timebase
Internal100kHz | 内部100kHz时基 Internal 100kHz Timebase
External | 外部时基 External Timebase

◆ COTriggerType

enum class JY5325CoreOO::COTriggerType
strong

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ CountDirection

enum class JY5325CoreOO::CountDirection
strong

Counter direction.

enum Up/Down/External

Enumerator
Up | Counter increases.
Down | Counter decreases.
External | External signal control counter direction. If External signal is highlevel counter increases, or lowlevel counter decreases.

◆ DIDigitalTriggerEdge

enum class JY5325CoreOO::DIDigitalTriggerEdge
strong

DI Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ DIDigitalTriggerSource

enum class JY5325CoreOO::DIDigitalTriggerSource
strong

DI Digital trigger source.

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
AO_StartTrig | AO_StartTrig.
DO_StartTrig | AO_StartTrig.
CIO_0_StartTrig | CI0_StartTrig.
CIO_1_StartTrig | CI1_StartTrig.
CO_0_Out | CI0_StartTrig.
CO_1_Out | CI1_StartTrig.

◆ DIMode

enum class JY5325CoreOO::DIMode
strong

DIMode.

Enumerator
Single | Single.
Finite | Finite.
Continuous | Continuous.

◆ DISampleClockSource

enum class JY5325CoreOO::DISampleClockSource
strong

DI Sample Clock Source.

Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ DISignalExportSource

enum class JY5325CoreOO::DISignalExportSource
strong

SourceSignal.

Enumerator
StartTrig | DI_StartTrig.
ReferenceTrig | DI_ReferenceTrig.
SampleClock | DI_SampleClock.
Internal_Counter_100K | Internal Counte 100K timebase.
Internal_Counter_5M | Internal Counte 5M timebase.
Internal_Counter_100M | Internal Counte 100Mtimebase.

◆ DITriggerMode

enum class JY5325CoreOO::DITriggerMode
strong

DI Trigger Mode.

Enumerator
Start | Start Trigger.
Reference | Reference Trigger，only for finite acquisition mode.

◆ DITriggerType

enum class JY5325CoreOO::DITriggerType
strong

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ DODigitalTriggerEdge

enum class JY5325CoreOO::DODigitalTriggerEdge
strong

DO Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ DODigitalTriggerSource

enum class JY5325CoreOO::DODigitalTriggerSource
strong

DO Digital trigger source.

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
AO_StartTrig | AO_StartTrig.
DI_StartTrig | DI_StartTrig.
DI_ReferenceTrig | DI_ReferenceTrig.
CIO_0_StartTrig | CI0_StartTrig.
CIO_1_StartTrig | CI1_StartTrig.
CO_0_Out | CI0_StartTrig.
CO_1_Out | CI1_StartTrig.

◆ DOMode

enum class JY5325CoreOO::DOMode
strong

DOMode.

Enumerator
Single | Single.
Finite | Finite.
ContinuousWrapping | ContinuousNoWrapping.
ContinuousNoWrapping | ContinuousWrapping.

◆ DOSampleClockSource

enum class JY5325CoreOO::DOSampleClockSource
strong

DO Sample Clock Source.

Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ DOSignalExportSource

enum class JY5325CoreOO::DOSignalExportSource
strong

SourceSignal.

Enumerator
StartTrig | DO_StartTrig.
SampleClock | DO_SampleClock.
Internal_Counter_100K | Internal Counte 100K timebase.
Internal_Counter_5M | Internal Counte 5M timebase.
Internal_Counter_100M | Internal Counte 100Mtimebase.

◆ DOTriggerType

enum class JY5325CoreOO::DOTriggerType
strong

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ EdgeCntOunEvtIdleState

enum class JY5325CoreOO::EdgeCntOunEvtIdleState
strong

Output idle state when the event has not occurred.

Enumerator
LowLevel | Idle state is low level.
HighLevel | Idle state is high level.

◆ EdgeType

enum class JY5325CoreOO::EdgeType
strong

Edge Type.

Enumerator
Rising | Rising Edge.
Falling | Falling Edge.
Any | Any Edge.

◆ ExternalReferenceClockTerminal

enum class JY5325CoreOO::ExternalReferenceClockTerminal
strong
Enumerator
PXIe_Clk100

PXIe_Clk100.

◆ FileFormat

enum class JY5325CoreOO::FileFormat
strong
Enumerator
Bin

BIN。

BIN.

◆ InputTerminal

enum class JY5325CoreOO::InputTerminal
strong

Cunter Input Terminal.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
AI_SampleClock | AI SampleClock.
AO_SampleClock | AO SampleClock.
DI_SampleClock | DI SampleClock.
DO_SampleClock | DO SampleClock.
CO_0_OutPut | CO_0_OutPut.
CO_1_OutPut | CO_1_OutPut.
Timebase_100MHz | Timebase_100MHz.
Timebase_5MHz | Timebase_5MHz.
Timebase_100kHz | Timebase_100kHz.

◆ IOTerminal

enum class JY5325CoreOO::IOTerminal
strong

Cunter IO Terminal.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
None | None.

◆ JY5325CoreOOLogLevel

enum class JY5325CoreOO::JY5325CoreOOLogLevel
strong
Enumerator
DEBUG_LOG_LEVEL
INFO_LOG_LEVEL
WARN_LOG_LEVEL
ERROR_LOG_LEVEL
FATAL_LOG_LEVEL

◆ JY5325CoreOOPropertyType

enum class JY5325CoreOO::JY5325CoreOOPropertyType
strong
Enumerator
READ_ONLY
WRITE_ONLY
READ_WRITE

◆ JYDriverExceptionPublic

enum class JY5325CoreOO::JYDriverExceptionPublic
strong
Enumerator
UnKnown | JYDriverExceptionPublic.
OpenDeviceFailed | JYDriverExceptionPublic.
CloseDeviceFailed | JYDriverExceptionPublic.
ResetDeviceFailed | JYDriverExceptionPublic.
GetDevicePropertyFailed | JYDriverExceptionPublic.
SetDevicePropertyFailed | JYDriverExceptionPublic.
HardwareResourceIsReserved | JYDriverExceptionPublic.
MethodNotPermitedToCallWhenCurrentStatus | JYDriverExceptionPublic.
InvalidUserDataBuffer | JYDriverExceptionPublic.
NoChannelAdded | JYDriverExceptionPublic.
NotSupportOperationForCurrentDevice | JYDriverExceptionPublic.
CreatTaskFailed | JYDriverExceptionPublic.
StartTaskFailed | JYDriverExceptionPublic.
StopTaskFailed | JYDriverExceptionPublic.
TaskHasNotStarted | JYDriverExceptionPublic.
TaskHasStartedCannotPerformTheSetOperation | JYDriverExceptionPublic.
ChannelNumberParameterInvalid | JYDriverExceptionPublic.
ChannelInputRangeParameterInvalid | JYDriverExceptionPublic.
ChannelTerminalParameterInvalid | JYDriverExceptionPublic.
ChannelCouplingParameterInvalid | JYDriverExceptionPublic.
SampeleModeParameterInvalid | JYDriverExceptionPublic.
SampleClockParameterInvalid | JYDriverExceptionPublic.
SampleRateParameterInvalid | JYDriverExceptionPublic.
UpdateRateParameterInvalid | JYDriverExceptionPublic.
TriggerParameterInvalid | JYDriverExceptionPublic.
ReferenceTriggerDoesNotMatchWithSampleMode | JYDriverExceptionPublic.
PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint | JYDriverExceptionPublic.
ReadDataFailed | JYDriverExceptionPublic.
ReadDataTimeout | JYDriverExceptionPublic.
WriteDataFailed | JYDriverExceptionPublic.
WriteDataTimeout | JYDriverExceptionPublic.
WriteDataLengthCannotBeLessThanN | JYDriverExceptionPublic.
BufferDataOverflow | JYDriverExceptionPublic.
BufferDataDownflow | JYDriverExceptionPublic.
CheckBufferFailed | JYDriverExceptionPublic.
PointInvalidInFiniteMode | JYDriverExceptionPublic.
ReadPointInvalid | JYDriverExceptionPublic.
OnlySupportRecordMode | JYDriverExceptionPublic.
SendSoftTirggerFailed | JYDriverExceptionPublic.
TaskTimeout | JYDriverExceptionPublic.
CounterParametersInvalid | JYDriverExceptionPublic.
WritePointInvalid | JYDriverExceptionPublic.
SignalExportDestinationInvalid | JYDriverExceptionPublic.
InvalidParameter | 无效参数。 Invaild parameter.

◆ JYErrorCode

enum class JY5325CoreOO::JYErrorCode
strong

错误代码的定义

Enumerator
NoError | 无错误
TimeOut | 超时
ErrorParam | 参数错误
IncorrectCallOrder | 调用顺序不正确
CannotCall | 当前配置不能调用该方法
UserBufferError | 用户缓冲区错误
BufferOverflow | 缓冲区溢出
BufferDownflow | 缓冲区下溢出
HardwareResourceReserved | 硬件资源已被占用
aiIsStart | AI已经启动，不用添加通道
ErrorParam1 | 输入幅值范围不正确,范围最大值和最小值

◆ LevelPolarity

enum class JY5325CoreOO::LevelPolarity
strong

Level Polarity.

Enumerator
LowLevel | Low level.
HighLevel | High level.
None | No active polarity.

◆ OutputCompleteState

enum class JY5325CoreOO::OutputCompleteState
strong

Output Complete State.

Enumerator
Zero | Output Complete Zero.
Hold | Output Complete Hold in The last point.

◆ PFITerminal

enum class JY5325CoreOO::PFITerminal
strong

Input/Output Terminal of PFI.

Enumerator
PFI0 | PFI 0.
PFI1 | PFI 1.
PFI2 | PFI 2.
PFI3 | PFI 3.
PFI4 | PFI 4.
PFI5 | PFI 5.
PFI6 | PFI 6.
PFI7 | PFI 7.
PFI8 | PFI 8.
PFI9 | PFI 9.
PFI10 | PFI 10.
PFI11 | PFI 11.
PFI12 | PFI 12.
PFI13 | PFI 13.
PFI14 | PFI 14.
PFI15 | PFI 15.

◆ QuadEncodingType

enum class JY5325CoreOO::QuadEncodingType
strong

Quadrature Encoding Type.

Enumerator
X1 | X1.
X2 | X2.
X4 | X4.

◆ RecordMode

enum class JY5325CoreOO::RecordMode
strong
Enumerator
Finite | Finite Streaming.
Infinite | Infinite Streaming.

◆ ReferenceClockSource

enum class JY5325CoreOO::ReferenceClockSource
strong
Enumerator
Internal | Internal on board 25MHz Clock.
External | External Reference Clock Source.

◆ SignalExportDestination

enum class JY5325CoreOO::SignalExportDestination
strong
Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.

◆ SyncTopology

enum class JY5325CoreOO::SyncTopology
strong
Enumerator
Independent | Independent, synchronization not supported
Master | master card
Slave | slave card

◆ SyncTriggerRouting

enum class JY5325CoreOO::SyncTriggerRouting
strong
Enumerator
NONE | Default NONE.
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.

◆ ValueReturnMode

enum class JY5325CoreOO::ValueReturnMode
strong

TwoEdgeSeparation value return mode.only for TwoEdgeSeparation type.

Enumerator
TwoValue | Return two data simultaneously. first data is gate to aux edge separation, second data is aux to gate edge separation.
OneValue | only return gate to aux edge separation

Function Documentation

◆ GetSignalExportDestinationString()

std::string JY5325CoreOO::GetSignalExportDestinationString ( SignalExportDestination destination )
inline


5325 C++ Programming Manual: COO/5325/JY5325CoreOOAOTask.h File Reference

  • File List
  • File Members
  • COO
  • 5325
Classes | Namespaces | Enumerations
JY5325CoreOOAOTask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JY5325CoreOOCommon.h"
#include "JY5325CoreOODevice.h"

Classes

class | JY5325CoreOO::JY5325CoreOOAOTask
class | JY5325CoreOO::AOChannel
class | JY5325CoreOO::AOSampleClock
External Sample Clock Configuration Class. More...
class | JY5325CoreOO::AOTrigger
Constructor to create an AOTrigger task object. More...
class | JY5325CoreOO::AODigitalTrigger
AO Digital trigger . More...

Namespaces

namespace JY5325CoreOO

Enumerations

enum class | JY5325CoreOO::AOMode { JY5325CoreOO::Single = 3 , JY5325CoreOO::Finite = 0 , JY5325CoreOO::ContinuousNoWrapping = 2 , JY5325CoreOO::ContinuousWrapping = 1 }
enum class | JY5325CoreOO::AODigitalTriggerEdge { JY5325CoreOO::Rising , JY5325CoreOO::Falling }
AO Digital Trigger Edge. More...
enum class JY5325CoreOO::AODigitalTriggerSource {
JY5325CoreOO::PFI0 , JY5325CoreOO::PFI1 , JY5325CoreOO::PFI2 , JY5325CoreOO::PFI3 ,
JY5325CoreOO::PFI4 , JY5325CoreOO::PFI5 , JY5325CoreOO::PFI6 , JY5325CoreOO::PFI7 ,
JY5325CoreOO::PXI_Trig0 = 8 , JY5325CoreOO::PXI_Trig1 = 9 , JY5325CoreOO::PXI_Trig2 = 10 , JY5325CoreOO::PXI_Trig3 = 11 ,
JY5325CoreOO::PXI_Trig4 = 12 , JY5325CoreOO::PXI_Trig5 = 13 , JY5325CoreOO::PXI_Trig6 = 14 , JY5325CoreOO::PXI_Trig7 = 15 ,
JY5325CoreOO::AI_StartTrig = 16 , JY5325CoreOO::AI_ReferenceTrig = 17 , JY5325CoreOO::DI_StartTrig = 19 , JY5325CoreOO::DI_ReferenceTrig = 20 ,
JY5325CoreOO::DO_StartTrig = 21 , JY5325CoreOO::CIO_0_StartTrig = 22 , JY5325CoreOO::CIO_1_StartTrig = 23 , JY5325CoreOO::CO_0_Out = 24 ,
JY5325CoreOO::CO_1_Out = 25
}
AO Digital trigger source. More...
enum class | JY5325CoreOO::AOSampleClockSource { JY5325CoreOO::Internal }
AO Sample Clock Source. More...
enum class | JY5325CoreOO::AOSignalExportSource { JY5325CoreOO::StartTrig = 19 , JY5325CoreOO::Internal_Counter_100K = 34 , JY5325CoreOO::Internal_Counter_5M = 33 , JY5325CoreOO::Internal_Counter_100M = 32 }
SourceSignal. More...
enum class | JY5325CoreOO::AOTriggerType { JY5325CoreOO::Immediate = 0x0 , JY5325CoreOO::Digital = 0x1 , JY5325CoreOO::Soft = 0x3 }
TriggerType Digital/Immediate/Soft. More...


5325 C++ Programming Manual: JY5325CoreOO::JY5325CoreOOAOTask Class Reference

  • JY5325CoreOOAOTask
Public Member Functions | Public Attributes | List of all members
JY5325CoreOO::JY5325CoreOOAOTask Class Reference

#include <JY5325CoreOOAOTask.h>

Public Member Functions

JY5325CoreOOAOTask (int slotNum)
JY5325CoreOOAOTask (std::string boardName)
void | AddChannel (int chnId, double rangeLow=-10, double rangeHigh=10)
Add one channel.
void | AddChannel (std::vector< int > chnsId, double rangeLow=-10, double rangeHigh=10)
Add a group of channels.
void | AddChannel (std::vector< int > chnsId, std::vector< double > rangeLow, std::vector< double > rangeHigh)
Add a group of channels.
void | RemoveChannel (int chnId)
Delete the specified channel number.
void | WriteData (double *pBuf, int samplesPerChannel, int timeout=10000)
Write to AO buffer one or multi-channel data.
void | WriteRawData (int16_t *pBuf, int samplesPerChannel, int timeout=10000)
Write to AO buffer one or multi-channel raw data.
void | WriteSinglePoint (std::vector< double > writeValues)
write one sample to all channels in register .
void | WriteSinglePoint (double writeValue, int channel)
Write one sample to the specified channel in register.Available when Mode is AOMode.Single
void | WriteRawSinglePoint (std::vector< int16_t > writeValues)
write one raw sample to all channels in register .
void | WriteRawSinglePoint (int16_t writeValue, int channel)
Write one raw sample to the specified channel in register.Available when Mode is AOMode.Single
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.
void | Start ()
Start AO task .
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Stop ()
Stop AO task .
~JY5325CoreOOAOTask ()
析构函数

Public Attributes

std::list< AOChannel * > | Channels
List of AO channels,(5325 support 8 channel)
AOMode Mode
Mode of AO Task.
JY5325CoreOOProperty< JY5325CoreOOAOTask, double, JY5325CoreOOPropertyType::READ_WRITE > | UpdateRate
/
int | SamplesToUpdate
Number of output samples to write per channel , Only valid when Mode is AOMode.Finite.
JY5325CoreOOProperty< JY5325CoreOOAOTask, int, JY5325CoreOOPropertyType::READ_ONLY > | BufLenInSamples
Number of samples per channel can be storage in the buffer, the PropretySamplesToUpdate must be less than or equal to this value.
JY5325CoreOOProperty< JY5325CoreOOAOTask, uint32_t, JY5325CoreOOPropertyType::READ_ONLY > | AvaliableLenInSamples
Number of output samples per channel that can be write in AO buffuer.
OutputCompleteState CompleteState
AO Output Complete State, Valid when Mode is NOT AOMode.Single.
JY5325CoreOOProperty< JY5325CoreOOAOTask, uint64_t, JY5325CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
bool | DisableCalibration
AOSampleClock * SampleClock
AO Sample Clock Configuration.
AOTrigger * Trigger
AO Trigger Configuration.
AOSignalExport * | SignalExport
Export AO Signal.
JY5325CoreOODevice * Device

Constructor & Destructor Documentation

◆ JY5325CoreOOAOTask() [1/2]

JY5325CoreOO::JY5325CoreOOAOTask::JY5325CoreOOAOTask ( int slotNum )

◆ JY5325CoreOOAOTask() [2/2]

JY5325CoreOO::JY5325CoreOOAOTask::JY5325CoreOOAOTask ( std::string boardName )

◆ ~JY5325CoreOOAOTask()

JY5325CoreOO::JY5325CoreOOAOTask::~JY5325CoreOOAOTask ( )

析构函数

Member Function Documentation

◆ AddChannel() [1/3]

void JY5325CoreOO::JY5325CoreOOAOTask::AddChannel | ( | int | chnId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10 )

Add one channel.

Parameters
chnId | channel's physical number ，chnId=-1, add all channels。(5325 support 8 channel)
rangeLow | lower range limit for the channel，-10V defalut -10
rangeHigh | higher range limit for the channel，10V defalut 10

◆ AddChannel() [2/3]

void JY5325CoreOO::JY5325CoreOOAOTask::AddChannel | ( | std::vector< int > | chnsId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10 )

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers。(5325 support 8 channel)
rangeLow | lower range limit for the channel，-10V defalut -10
rangeHigh | higher range limit for the channel，10V defalut 10

◆ AddChannel() [3/3]

void JY5325CoreOO::JY5325CoreOOAOTask::AddChannel | ( | std::vector< int > | chnsId,
 |  | std::vector< double > | rangeLow,
 |  | std::vector< double > | rangeHigh )

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers。(5325 support 8 channel)
rangeLow | lower range limit for the channel，-10V
rangeHigh | higher range limit for the channel，10V

◆ RemoveChannel()

void JY5325CoreOO::JY5325CoreOOAOTask::RemoveChannel ( int chnId )

Delete the specified channel number.

If it is -1, delete all channels.

Parameters
chnId Specified channel ID.

◆ SendSoftwareTrigger()

void JY5325CoreOO::JY5325CoreOOAOTask::SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5325CoreOO::JY5325CoreOOAOTask::Start ( )

Start AO task .

◆ Stop()

void JY5325CoreOO::JY5325CoreOOAOTask::Stop ( )

Stop AO task .

◆ WaitUntilDone()

bool JY5325CoreOO::JY5325CoreOOAOTask::WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Available when Mode is AOMode.Finite

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteData()

void JY5325CoreOO::JY5325CoreOOAOTask::WriteData | ( | double * | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Write to AO buffer one or multi-channel data.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | data buffer.
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawData()

void JY5325CoreOO::JY5325CoreOOAOTask::WriteRawData | ( | int16_t * | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Write to AO buffer one or multi-channel raw data.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | data buffer.
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawSinglePoint() [1/2]

void JY5325CoreOO::JY5325CoreOOAOTask::WriteRawSinglePoint | ( | int16_t | writeValue,
 |  | int | channel )

Write one raw sample to the specified channel in register.Available when Mode is AOMode.Single

Parameters
writeValue | Write value.
channel | Specified channel.

◆ WriteRawSinglePoint() [2/2]

void JY5325CoreOO::JY5325CoreOOAOTask::WriteRawSinglePoint ( std::vector< int16_t > writeValues )

write one raw sample to all channels in register .

Available when Mode is AOMode.Single

Parameters
writeValues Write values. Array length >= Channels.Count.

◆ WriteSinglePoint() [1/2]

void JY5325CoreOO::JY5325CoreOOAOTask::WriteSinglePoint | ( | double | writeValue,
 |  | int | channel )

Write one sample to the specified channel in register.Available when Mode is AOMode.Single

Parameters
writeValue | Write value.
channel | Specified channel.

◆ WriteSinglePoint() [2/2]

void JY5325CoreOO::JY5325CoreOOAOTask::WriteSinglePoint ( std::vector< double > writeValues )

write one sample to all channels in register .

Available when Mode is AOMode.Single

Parameters
writeValues Write values. Array length >= Channels.Count.

Member Data Documentation

◆ AvaliableLenInSamples

JY5325CoreOOProperty<JY5325CoreOOAOTask, uint32_t, JY5325CoreOOPropertyType::READ_ONLY> JY5325CoreOO::JY5325CoreOOAOTask::AvaliableLenInSamples

Number of output samples per channel that can be write in AO buffuer.

◆ BufLenInSamples

JY5325CoreOOProperty<JY5325CoreOOAOTask, int, JY5325CoreOOPropertyType::READ_ONLY> JY5325CoreOO::JY5325CoreOOAOTask::BufLenInSamples

Number of samples per channel can be storage in the buffer, the PropretySamplesToUpdate must be less than or equal to this value.

◆ Channels

std::list<AOChannel*> JY5325CoreOO::JY5325CoreOOAOTask::Channels

List of AO channels,(5325 support 8 channel)

◆ CompleteState

OutputCompleteState JY5325CoreOO::JY5325CoreOOAOTask::CompleteState

AO Output Complete State, Valid when Mode is NOT AOMode.Single.

Default is Zero.

◆ Device

JY5325CoreOODevice* JY5325CoreOO::JY5325CoreOOAOTask::Device

◆ DisableCalibration

bool JY5325CoreOO::JY5325CoreOOAOTask::DisableCalibration

◆ Mode

AOMode JY5325CoreOO::JY5325CoreOOAOTask::Mode

Mode of AO Task.

Select AO Mode from enum:ContinuousNoWrapping/ContinuousWrapping/Finite/Single.

◆ SampleClock

AOSampleClock* JY5325CoreOO::JY5325CoreOOAOTask::SampleClock

AO Sample Clock Configuration.

◆ SamplesToUpdate

int JY5325CoreOO::JY5325CoreOOAOTask::SamplesToUpdate

Number of output samples to write per channel , Only valid when Mode is AOMode.Finite.

◆ SignalExport

AOSignalExport* JY5325CoreOO::JY5325CoreOOAOTask::SignalExport

Export AO Signal.

◆ TransferedSamples

JY5325CoreOOProperty<JY5325CoreOOAOTask, uint64_t, JY5325CoreOOPropertyType::READ_ONLY> JY5325CoreOO::JY5325CoreOOAOTask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT AOMode.Single.

◆ Trigger

AOTrigger* JY5325CoreOO::JY5325CoreOOAOTask::Trigger

AO Trigger Configuration.

◆ UpdateRate

JY5325CoreOOProperty<JY5325CoreOOAOTask, double, JY5325CoreOOPropertyType::READ_WRITE> JY5325CoreOO::JY5325CoreOOAOTask::UpdateRate

/

/ if the number of channels in any bank is greater than 1, the Maximum update rate(2 ch) is 2MS/s, the Maximum update rate(8 ch) is 1MS/s. /

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOAOTask.h


5325 C++ Programming Manual: JY5325CoreOO::AOChannel Class Reference

  • AOChannel
Public Member Functions | Public Attributes | List of all members
JY5325CoreOO::AOChannel Class Reference

#include <JY5325CoreOOAOTask.h>

Public Member Functions

AOChannel (int channelId, double rangeLow, double rangeHigh)

Public Attributes

int | ChannelID
double | RangeLow
double | RangeHigh

Constructor & Destructor Documentation

◆ AOChannel()

JY5325CoreOO::AOChannel::AOChannel | ( | int | channelId,
 |  | double | rangeLow,
 |  | double | rangeHigh )
 inline

Member Data Documentation

◆ ChannelID

int JY5325CoreOO::AOChannel::ChannelID

◆ RangeHigh

double JY5325CoreOO::AOChannel::RangeHigh

◆ RangeLow

double JY5325CoreOO::AOChannel::RangeLow
The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOAOTask.h


5325 C++ Programming Manual: JY5325CoreOO::AOSampleClock Class Reference

  • AOSampleClock
Public Attributes | Friends | List of all members
JY5325CoreOO::AOSampleClock Class Reference

External Sample Clock Configuration Class. More...

#include <JY5325CoreOOAOTask.h>

Public Attributes

AOSampleClockSource Source
Clock Source.

Friends

class JY5325CoreOOAOTask
External Sample Clock Configuration,Valid when Source is AOSampleClockSource::External.

Detailed Description

External Sample Clock Configuration Class.

AO Sample clock configuration class

Friends And Related Symbol Documentation

◆ JY5325CoreOOAOTask

friend class JY5325CoreOOAOTask
friend

External Sample Clock Configuration,Valid when Source is AOSampleClockSource::External.

Member Data Documentation

◆ Source

AOSampleClockSource JY5325CoreOO::AOSampleClock::Source

Clock Source.

enum Internal/External,The default value is AOSampleClockSource.Internal.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOAOTask.h


5325 C++ Programming Manual: JY5325CoreOO::AOTrigger Class Reference

  • AOTrigger
Public Attributes | List of all members
JY5325CoreOO::AOTrigger Class Reference

Constructor to create an AOTrigger task object. More...

#include <JY5325CoreOOAOTask.h>

Public Attributes

AOTriggerType Type
AO trigger type.
AODigitalTrigger * Digital
AO Digital Trigger.

Detailed Description

Constructor to create an AOTrigger task object.

Used to build AO Trigger

Member Data Documentation

◆ Digital

AODigitalTrigger* JY5325CoreOO::AOTrigger::Digital

AO Digital Trigger.

Valid when Type is AOTriggerType.Digital.

◆ Type

AOTriggerType JY5325CoreOO::AOTrigger::Type

AO trigger type.

enum Immediate/Digital/Soft.The default value is AOTriggerType.Immediate.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOAOTask.h


5325 C++ Programming Manual: JY5325CoreOO::AODigitalTrigger Class Reference

  • AODigitalTrigger
Public Attributes | List of all members
JY5325CoreOO::AODigitalTrigger Class Reference

AO Digital trigger . More...

#include <JY5325CoreOOAOTask.h>

Public Attributes

AODigitalTriggerSource Source
AO Digital Trigger source.
AODigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Detailed Description

AO Digital trigger .

Member Data Documentation

◆ Edge

AODigitalTriggerEdge JY5325CoreOO::AODigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

AODigitalTriggerSource JY5325CoreOO::AODigitalTrigger::Source

AO Digital Trigger source.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOAOTask.h


5325 C++ Programming Manual: COO/5325/JY5325CoreOOCITask.h File Reference

  • File List
  • File Members
  • COO
  • 5325
Classes | Namespaces | Enumerations
JY5325CoreOOCITask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JY5325CoreOOCommon.h"
#include "JY5325CoreOODevice.h"

Classes

class | JY5325CoreOO::JY5325CoreOOCITask
class | JY5325CoreOO::CIInternalSampleClock
CI Internal Sample Clock Configuration Class. More...
class | JY5325CoreOO::CIImplicitSampleClock
CI Implicit Sample Clock class. More...
class | JY5325CoreOO::CIExternalSampleClock
CI Implicit Sample Clock class. More...
class | JY5325CoreOO::CISampleClock
CI Sample Clock class. More...
class | JY5325CoreOO::EdgeCounting
Configure CI EdgeCounting. More...
class | JY5325CoreOO::FrequencyMeas
Configure CI Measure. More...
class | JY5325CoreOO::PeriodMeas
Configure CI Measure. More...
class | JY5325CoreOO::PulseMeas
Configure CI Measure. More...
class | JY5325CoreOO::SemiPeriodMeas
Configure CI SemiPeriodMeas. More...
class | JY5325CoreOO::TwoEdgeSeparation
Configure CI Measure. More...
class | JY5325CoreOO::QuadEncoder
Configure CI Measure. More...
class | JY5325CoreOO::TwoPulseEncoder
Configure CI Measure. More...
class | JY5325CoreOO::CITrigger
Constructor to create an CITrigger task object. More...
class | JY5325CoreOO::CIDigitalTrigger
CI Digital trigger . More...
class | JY5325CoreOO::EdgeCountingOutEvent
Edge counting output event configuration class. More...
class | JY5325CoreOO::CIExternalTimebase
class | JY5325CoreOO::CITimebase
Timebase configuration class. More...
class | JY5325CoreOO::CISignalExport
CI Signal Export Class. More...

Namespaces

namespace JY5325CoreOO

Enumerations

enum class | JY5325CoreOO::CountDirection { JY5325CoreOO::Up = 0x0 , JY5325CoreOO::Down = 0x1 , JY5325CoreOO::External = 0x2 }
Counter direction. More...
enum class | JY5325CoreOO::CIMode { JY5325CoreOO::Single = 2 , JY5325CoreOO::Finite = 0 , JY5325CoreOO::Continuous = 1 }
CIMode. More...
enum class JY5325CoreOO::CIType {
JY5325CoreOO::EdgeCounting , JY5325CoreOO::Period , JY5325CoreOO::Frequency , JY5325CoreOO::Pulse ,
JY5325CoreOO::SemiPeriod , JY5325CoreOO::TwoEdgeSeparation , JY5325CoreOO::QuadEncoder , JY5325CoreOO::TwoPulseEncoder
}
Counter Input Application Type. More...
enum class | JY5325CoreOO::CISampleClockSource { JY5325CoreOO::Implicit = 0x0 , JY5325CoreOO::Internal = 0x1 , JY5325CoreOO::External = 0x2 }
CI Sample Clock Source. More...
enum class | JY5325CoreOO::EdgeType { JY5325CoreOO::Rising , JY5325CoreOO::Falling , JY5325CoreOO::Any }
Edge Type. More...
enum class | JY5325CoreOO::ValueReturnMode { JY5325CoreOO::TwoValue , JY5325CoreOO::OneValue }
TwoEdgeSeparation value return mode.only for TwoEdgeSeparation type. More...
enum class | JY5325CoreOO::QuadEncodingType { JY5325CoreOO::X1 , JY5325CoreOO::X2 , JY5325CoreOO::X4 }
Quadrature Encoding Type. More...
enum class | JY5325CoreOO::CITriggerType { JY5325CoreOO::Immediate = 0x0 , JY5325CoreOO::Digital = 0x1 , JY5325CoreOO::Soft = 0x3 }
TriggerType Digital/Immediate/Soft. More...
enum class JY5325CoreOO::CIDigitalTriggerSource {
JY5325CoreOO::PFI0 , JY5325CoreOO::PFI1 , JY5325CoreOO::PFI2 , JY5325CoreOO::PFI3 ,
JY5325CoreOO::PFI4 , JY5325CoreOO::PFI5 , JY5325CoreOO::PFI6 , JY5325CoreOO::PFI7 ,
JY5325CoreOO::PXI_Trig0 = 8 , JY5325CoreOO::PXI_Trig1 = 9 , JY5325CoreOO::PXI_Trig2 = 10 , JY5325CoreOO::PXI_Trig3 = 11 ,
JY5325CoreOO::PXI_Trig4 = 12 , JY5325CoreOO::PXI_Trig5 = 13 , JY5325CoreOO::PXI_Trig6 = 14 , JY5325CoreOO::PXI_Trig7 = 15 ,
JY5325CoreOO::AI_StartTrig = 16 , JY5325CoreOO::AI_ReferenceTrig = 17 , JY5325CoreOO::AO_StartTrig = 18 , JY5325CoreOO::DI_StartTrig = 19 ,
JY5325CoreOO::DI_ReferenceTrig = 20 , JY5325CoreOO::DO_StartTrig = 21 , JY5325CoreOO::CIO_0_StartTrig = 22 , JY5325CoreOO::CIO_1_StartTrig = 23 ,
JY5325CoreOO::CO_0_Out = 24 , JY5325CoreOO::CO_1_Out = 25
}
CI Digital trigger source. More...
enum class | JY5325CoreOO::CIDigitalTriggerEdge { JY5325CoreOO::Rising , JY5325CoreOO::Falling }
CI Digital Trigger Edge. More...
enum class | JY5325CoreOO::EdgeCntOunEvtIdleState { JY5325CoreOO::LowLevel = 0 , JY5325CoreOO::HighLevel = 1 }
Output idle state when the event has not occurred. More...
enum class JY5325CoreOO::CISignalExportSource {
JY5325CoreOO::StartTrig = 0 , JY5325CoreOO::SampleClock = 1 , JY5325CoreOO::Internal_Counter_100K = 34 , JY5325CoreOO::Internal_Counter_5M = 33 ,
JY5325CoreOO::Internal_Counter_100M = 32
}
SourceSignal. More...
enum class | JY5325CoreOO::CITimebaseSource { JY5325CoreOO::Internal100MHz = 0 , JY5325CoreOO::Internal5MHz = 1 , JY5325CoreOO::Internal100kHz = 2 , JY5325CoreOO::External = 3 }
Timebase source. More...


5325 C++ Programming Manual: JY5325CoreOO::JY5325CoreOOCITask Class Reference

  • JY5325CoreOOCITask
Public Member Functions | Public Attributes | List of all members
JY5325CoreOO::JY5325CoreOOCITask Class Reference

#include <JY5325CoreOOCITask.h>

Public Member Functions

JY5325CoreOOCITask (int slotNum, int channel)
JY5325CoreOOCITask (std::string boardName, int channel)
~JY5325CoreOOCITask ()
void | Start ()
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Stop ()
Stop CI task .
void | ReadSinglePoint (uint32_t &count)
Read a signle count value from register, Available when Type is CIType.EdgeCounting, CIType.QuadEncoder or CIType.TwoPulseEncoder.
void | ReadData (uint32_t *pBufCount, int samplesToAcquire, int timeout=10000)
Read counter values from buffer.
void | ReadData (double *pBufMeasurement, int samplesToAcquire, int timeout=10000)
Read frequency value or period value from buffer.
void | ReadSinglePoint (double &measurement, int timeout=10000)
Read a signle frequency value or period value from register.
void | ReadSinglePoint (double &measurement1, double &measurement2, int timeout=10000)
Read a signle measurement of pulse's duration value, or two-edge separtion value (two results at a time) from register.
void | ReadData (double *pBufMeasurement1, double *pBufMeasurement2, int samplesToAcquire, int timeout=10000)
Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.

Public Attributes

CIType Type
CI Application types.
JY5325CoreOOProperty< JY5325CoreOOCITask, uint64_t, JY5325CoreOOPropertyType::READ_ONLY > | AvailableSamples
Number of points per channel that can be read in the buffer .
JY5325CoreOOProperty< JY5325CoreOOCITask, uint64_t, JY5325CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
CIMode Mode
CI Sampling mode，support Single/Finite/Continuous.
CISampleClock * SampleClock
Clock Source.
uint32_t | SamplesToAcquire
Number of samples to be read per channel.Only valid when Mode is CIMode.Finite.
JY5325CoreOO::EdgeCounting * EdgeCounting
Edge Counting Configuration.
JY5325CoreOO::FrequencyMeas * FrequencyMeas
Frequency Measurement Configuration.
JY5325CoreOO::PeriodMeas * PeriodMeas
Period Measurement Configuration.
JY5325CoreOO::PulseMeas * PulseMeas
Pulse Measurement Configuration.
JY5325CoreOO::SemiPeriodMeas * SemiPeriodMeas
SemiPeriodMeas Measurement Configuration.
JY5325CoreOO::TwoEdgeSeparation * TwoEdgeSeparation
TwoEdgeSeparation.
JY5325CoreOO::QuadEncoder * QuadEncoder
QuadEncoder.
JY5325CoreOO::TwoPulseEncoder * TwoPulseEncoder
TwoPulseEncoder.
CITrigger * Trigger
CI Trigger Configuration.
CISignalExport * SignalExport
Export CI Signal Configuration.
JY5325CoreOODevice * Device
Device.
CITimebase * timeBase
timeBase

Constructor & Destructor Documentation

◆ JY5325CoreOOCITask() [1/2]

JY5325CoreOO::JY5325CoreOOCITask::JY5325CoreOOCITask | ( | int | slotNum,
 |  | int | channel )

◆ JY5325CoreOOCITask() [2/2]

JY5325CoreOO::JY5325CoreOOCITask::JY5325CoreOOCITask | ( | std::string | boardName,
 |  | int | channel )

◆ ~JY5325CoreOOCITask()

JY5325CoreOO::JY5325CoreOOCITask::~JY5325CoreOOCITask ( )

Member Function Documentation

◆ ReadData() [1/3]

void JY5325CoreOO::JY5325CoreOOCITask::ReadData | ( | double * | pBufMeasurement,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read frequency value or period value from buffer.

Available when JY5325CITask.Mode is NOT CIMode.Single, and Type is CIType.Frequency or CIType.Period.

Parameters
bufMeasurement | Buffer for reading data. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period in seconds when Type is CIType.Period.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [2/3]

void JY5325CoreOO::JY5325CoreOOCITask::ReadData | ( | double * | pBufMeasurement1,
 |  | double * | pBufMeasurement2,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.

. Available when JY5325CITask.Mode is NOT CIMode.Single, Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
bufMeasurement1 | Buffer for reading data. Indicates high level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
bufMeasurement2 | Buffer for reading data. Indicates low level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [3/3]

void JY5325CoreOO::JY5325CoreOOCITask::ReadData | ( | uint32_t * | pBufCount,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read counter values from buffer.

Available when JY5325CITask.Mode is NOT CIMode.Single, and Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder

Parameters
bufCount | Buffer for reading data.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [1/3]

void JY5325CoreOO::JY5325CoreOOCITask::ReadSinglePoint | ( | double & | measurement,
 |  | int | timeout = 10000 )

Read a signle frequency value or period value from register.

Valid when Type is CIType.Frequency or CIType.Period.

Parameters
measurement Measurement value. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period is seconds when Type is CIType.Period.
timeout
Timeout (ms). Wait until the measurement is completed or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [2/3]

void JY5325CoreOO::JY5325CoreOOCITask::ReadSinglePoint | ( | double & | measurement1,
 |  | double & | measurement2,
 |  | int | timeout = 10000 )

Read a signle measurement of pulse's duration value, or two-edge separtion value (two results at a time) from register.

Available when Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
measurement1 | Measurement Value 1. Indicates low level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
measurement2 | Measurement Value 2. Indicates high level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
timeout
Timeout (ms). Wait until the measurement is completed or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [3/3]

void JY5325CoreOO::JY5325CoreOOCITask::ReadSinglePoint ( uint32_t & count )

Read a signle count value from register, Available when Type is CIType.EdgeCounting, CIType.QuadEncoder or CIType.TwoPulseEncoder.

Parameters
count counter value。

◆ SendSoftwareTrigger()

void JY5325CoreOO::JY5325CoreOOCITask::SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5325CoreOO::JY5325CoreOOCITask::Start ( )

◆ Stop()

void JY5325CoreOO::JY5325CoreOOCITask::Stop ( )

Stop CI task .

Member Data Documentation

◆ AvailableSamples

JY5325CoreOOProperty<JY5325CoreOOCITask, uint64_t, JY5325CoreOOPropertyType::READ_ONLY> JY5325CoreOO::JY5325CoreOOCITask::AvailableSamples

Number of points per channel that can be read in the buffer .

◆ Device

JY5325CoreOODevice* JY5325CoreOO::JY5325CoreOOCITask::Device

Device.

◆ EdgeCounting

JY5325CoreOO::EdgeCounting* JY5325CoreOO::JY5325CoreOOCITask::EdgeCounting

Edge Counting Configuration.

◆ FrequencyMeas

JY5325CoreOO::FrequencyMeas* JY5325CoreOO::JY5325CoreOOCITask::FrequencyMeas

Frequency Measurement Configuration.

◆ Mode

CIMode JY5325CoreOO::JY5325CoreOOCITask::Mode

CI Sampling mode，support Single/Finite/Continuous.

◆ PeriodMeas

JY5325CoreOO::PeriodMeas* JY5325CoreOO::JY5325CoreOOCITask::PeriodMeas

Period Measurement Configuration.

◆ PulseMeas

JY5325CoreOO::PulseMeas* JY5325CoreOO::JY5325CoreOOCITask::PulseMeas

Pulse Measurement Configuration.

◆ QuadEncoder

JY5325CoreOO::QuadEncoder* JY5325CoreOO::JY5325CoreOOCITask::QuadEncoder

QuadEncoder.

◆ SampleClock

CISampleClock* JY5325CoreOO::JY5325CoreOOCITask::SampleClock

Clock Source.

◆ SamplesToAcquire

uint32_t JY5325CoreOO::JY5325CoreOOCITask::SamplesToAcquire

Number of samples to be read per channel.Only valid when Mode is CIMode.Finite.

◆ SemiPeriodMeas

JY5325CoreOO::SemiPeriodMeas* JY5325CoreOO::JY5325CoreOOCITask::SemiPeriodMeas

SemiPeriodMeas Measurement Configuration.

◆ SignalExport

CISignalExport* JY5325CoreOO::JY5325CoreOOCITask::SignalExport

Export CI Signal Configuration.

◆ timeBase

CITimebase* JY5325CoreOO::JY5325CoreOOCITask::timeBase

timeBase

◆ TransferedSamples

JY5325CoreOOProperty<JY5325CoreOOCITask, uint64_t, JY5325CoreOOPropertyType::READ_ONLY> JY5325CoreOO::JY5325CoreOOCITask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT CIMode.Single.

◆ Trigger

CITrigger* JY5325CoreOO::JY5325CoreOOCITask::Trigger

CI Trigger Configuration.

◆ TwoEdgeSeparation

JY5325CoreOO::TwoEdgeSeparation* JY5325CoreOO::JY5325CoreOOCITask::TwoEdgeSeparation

TwoEdgeSeparation.

◆ TwoPulseEncoder

JY5325CoreOO::TwoPulseEncoder* JY5325CoreOO::JY5325CoreOOCITask::TwoPulseEncoder

TwoPulseEncoder.

◆ Type

CIType JY5325CoreOO::JY5325CoreOOCITask::Type

CI Application types.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOCITask.h


5325 C++ Programming Manual: JY5325CoreOO::CIInternalSampleClock Class Reference

  • CIInternalSampleClock
Public Attributes | List of all members
JY5325CoreOO::CIInternalSampleClock Class Reference

CI Internal Sample Clock Configuration Class. More...

#include <JY5325CoreOOCITask.h>

Public Attributes

JY5325CoreOOProperty< CIInternalSampleClock, double, JY5325CoreOOPropertyType::READ_WRITE > | Rate
The rate of the internal sample clock (sample rate) which is generated by dividing the internal clock (100MHz).
JY5325CoreOOProperty< CIInternalSampleClock, bool, JY5325CoreOOPropertyType::READ_WRITE > | IgnoreFirstSampleClock
IgnoreFirstSampleClock.

Detailed Description

CI Internal Sample Clock Configuration Class.

Member Data Documentation

◆ IgnoreFirstSampleClock

JY5325CoreOOProperty<CIInternalSampleClock, bool, JY5325CoreOOPropertyType::READ_WRITE> JY5325CoreOO::CIInternalSampleClock::IgnoreFirstSampleClock

IgnoreFirstSampleClock.

◆ Rate

JY5325CoreOOProperty<CIInternalSampleClock, double, JY5325CoreOOPropertyType::READ_WRITE> JY5325CoreOO::CIInternalSampleClock::Rate

The rate of the internal sample clock (sample rate) which is generated by dividing the internal clock (100MHz).

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOCITask.h


5325 C++ Programming Manual: JY5325CoreOO::CIImplicitSampleClock Class Reference

  • CIImplicitSampleClock
Public Attributes | Friends | List of all members
JY5325CoreOO::CIImplicitSampleClock Class Reference

CI Implicit Sample Clock class. More...

#include <JY5325CoreOOCITask.h>

Public Attributes

double ExpectedRate
Expected Rate of Implicit Sample Clock.

Friends

class CISampleClock

Detailed Description

CI Implicit Sample Clock class.

Friends And Related Symbol Documentation

◆ CISampleClock

friend class CISampleClock
friend

Member Data Documentation

◆ ExpectedRate

double JY5325CoreOO::CIImplicitSampleClock::ExpectedRate

Expected Rate of Implicit Sample Clock.

Filling this parameter accurately would helps the driver to set a proper DDR write frequency internally.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOCITask.h


5325 C++ Programming Manual: JY5325CoreOO::CIExternalSampleClock Class Reference

  • CIExternalSampleClock
Public Attributes | List of all members
JY5325CoreOO::CIExternalSampleClock Class Reference

CI Implicit Sample Clock class. More...

#include <JY5325CoreOOCITask.h>

Public Attributes

ClockTerminal Terminal
External Sample Clock Input Terminal.
double | ExpectedRate
Expected Rate of External Sample Clock.
JY5325CoreOOProperty< CIExternalSampleClock, bool, JY5325CoreOOPropertyType::READ_WRITE > | IgnoreFirstSampleClock
IgnoreFirstSampleClock.

Detailed Description

CI Implicit Sample Clock class.

Member Data Documentation

◆ ExpectedRate

double JY5325CoreOO::CIExternalSampleClock::ExpectedRate

Expected Rate of External Sample Clock.

Filling this parameter accurately would helps the driver to set a proper DDR write frequency internally.

◆ IgnoreFirstSampleClock

JY5325CoreOOProperty<CIExternalSampleClock, bool, JY5325CoreOOPropertyType::READ_WRITE> JY5325CoreOO::CIExternalSampleClock::IgnoreFirstSampleClock

IgnoreFirstSampleClock.

◆ Terminal

ClockTerminal JY5325CoreOO::CIExternalSampleClock::Terminal

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOCITask.h


5325 C++ Programming Manual: JY5325CoreOO::CISampleClock Class Reference

  • CISampleClock
Public Attributes | List of all members
JY5325CoreOO::CISampleClock Class Reference

CI Sample Clock class. More...

#include <JY5325CoreOOCITask.h>

Public Attributes

CISampleClockSource Source
CI Sample Clock Source.
CIExternalSampleClock * External
CI External Sample Clock Configuration.
CIImplicitSampleClock * Implicit
CI Implicit Sample Clock Configuration.
CIInternalSampleClock * Internal
Internal Sample Clock Configuration.

Detailed Description

CI Sample Clock class.

Member Data Documentation

◆ External

CIExternalSampleClock* JY5325CoreOO::CISampleClock::External

CI External Sample Clock Configuration.

Valid when Source is CISampleClockSource.External.

◆ Implicit

CIImplicitSampleClock* JY5325CoreOO::CISampleClock::Implicit

CI Implicit Sample Clock Configuration.

Valid when Source is CISampleClockSource.Implicit.

◆ Internal

CIInternalSampleClock* JY5325CoreOO::CISampleClock::Internal

Internal Sample Clock Configuration.

Valid when Source is CISampleClockSource.Internal.

◆ Source

CISampleClockSource JY5325CoreOO::CISampleClock::Source

CI Sample Clock Source.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOCITask.h


5325 C++ Programming Manual: JY5325CoreOO::EdgeCounting Class Reference

  • EdgeCounting
Public Attributes | List of all members
JY5325CoreOO::EdgeCounting Class Reference

Configure CI EdgeCounting. More...

#include <JY5325CoreOOCITask.h>

Public Attributes

int InitialCount
Initial Count.
CountDirection Direction
Counter direction.
EdgeType ActiveEdge
The avtive edge of the input signal, the counter will count up or down on this edge.
PauseTrigger * Pause
Pause Trigger Configuration.
EdgeCountingOutEvent * OutEvent
Edge counting output event.
JY5325CoreOO::InputTerminal DirTerminal
Terminal of External Count Diretion Control.
JY5325CoreOO::InputTerminal Input_Terminal
Input Terminal.

Detailed Description

Configure CI EdgeCounting.

Member Data Documentation

◆ ActiveEdge

EdgeType JY5325CoreOO::EdgeCounting::ActiveEdge

The avtive edge of the input signal, the counter will count up or down on this edge.

◆ Direction

CountDirection JY5325CoreOO::EdgeCounting::Direction

Counter direction.

enum Up/Down/External

◆ DirTerminal

JY5325CoreOO::InputTerminal JY5325CoreOO::EdgeCounting::DirTerminal

Terminal of External Count Diretion Control.

Valid when Direction is CountDirection.External

◆ InitialCount

int JY5325CoreOO::EdgeCounting::InitialCount

Initial Count.

◆ Input_Terminal

JY5325CoreOO::InputTerminal JY5325CoreOO::EdgeCounting::Input_Terminal

Input Terminal.

◆ OutEvent

EdgeCountingOutEvent* JY5325CoreOO::EdgeCounting::OutEvent

Edge counting output event.

A pulse will be generated when the count value reaches specified threshold

◆ Pause

PauseTrigger* JY5325CoreOO::EdgeCounting::Pause

Pause Trigger Configuration.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOCITask.h


5325 C++ Programming Manual: JY5325CoreOO::FrequencyMeas Class Reference

  • FrequencyMeas
Public Attributes | List of all members
JY5325CoreOO::FrequencyMeas Class Reference

Configure CI Measure. More...

#include <JY5325CoreOOCITask.h>

Public Attributes

CITimebase * Timebase
Timebase configuration.
JY5325CoreOO::InputTerminal Input_Terminal
Input Terminal.

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ Input_Terminal

JY5325CoreOO::InputTerminal JY5325CoreOO::FrequencyMeas::Input_Terminal

Input Terminal.

◆ Timebase

CITimebase* JY5325CoreOO::FrequencyMeas::Timebase

Timebase configuration.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOCITask.h


5325 C++ Programming Manual: JY5325CoreOO::PeriodMeas Class Reference

  • PeriodMeas
Public Attributes | List of all members
JY5325CoreOO::PeriodMeas Class Reference

Configure CI Measure. More...

#include <JY5325CoreOOCITask.h>

Public Attributes

CITimebase * Timebase
Timebase configuration.
JY5325CoreOO::InputTerminal Input_Terminal
Input Terminal.

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ Input_Terminal

JY5325CoreOO::InputTerminal JY5325CoreOO::PeriodMeas::Input_Terminal

Input Terminal.

◆ Timebase

CITimebase* JY5325CoreOO::PeriodMeas::Timebase

Timebase configuration.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOCITask.h


5325 C++ Programming Manual: JY5325CoreOO::PulseMeas Class Reference

  • PulseMeas
Public Attributes | List of all members
JY5325CoreOO::PulseMeas Class Reference

Configure CI Measure. More...

#include <JY5325CoreOOCITask.h>

Public Attributes

CITimebase * Timebase
Timebase configuration.
JY5325CoreOO::EdgeType StartingEdge
The start edge of the input signal, the counter will count up or down on this edge.
JY5325CoreOO::InputTerminal Input_Terminal
Input Terminal.

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ Input_Terminal

JY5325CoreOO::InputTerminal JY5325CoreOO::PulseMeas::Input_Terminal

Input Terminal.

◆ StartingEdge

JY5325CoreOO::EdgeType JY5325CoreOO::PulseMeas::StartingEdge

The start edge of the input signal, the counter will count up or down on this edge.

◆ Timebase

CITimebase* JY5325CoreOO::PulseMeas::Timebase

Timebase configuration.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOCITask.h


5325 C++ Programming Manual: JY5325CoreOO::SemiPeriodMeas Class Reference

  • SemiPeriodMeas
Public Attributes | List of all members
JY5325CoreOO::SemiPeriodMeas Class Reference

Configure CI SemiPeriodMeas. More...

#include <JY5325CoreOOCITask.h>

Public Attributes

CITimebase * Timebase
Timebase configuration.
JY5325CoreOO::EdgeType StartingEdge
The start edge of the input signal, the counter will count up or down on this edge.
JY5325CoreOO::InputTerminal Input_Terminal
Input Terminal.

Detailed Description

Configure CI SemiPeriodMeas.

Member Data Documentation

◆ Input_Terminal

JY5325CoreOO::InputTerminal JY5325CoreOO::SemiPeriodMeas::Input_Terminal

Input Terminal.

◆ StartingEdge

JY5325CoreOO::EdgeType JY5325CoreOO::SemiPeriodMeas::StartingEdge

The start edge of the input signal, the counter will count up or down on this edge.

◆ Timebase

CITimebase* JY5325CoreOO::SemiPeriodMeas::Timebase

Timebase configuration.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOCITask.h


5325 C++ Programming Manual: JY5325CoreOO::TwoEdgeSeparation Class Reference

  • TwoEdgeSeparation
Public Attributes | List of all members
JY5325CoreOO::TwoEdgeSeparation Class Reference

Configure CI Measure. More...

#include <JY5325CoreOOCITask.h>

Public Attributes

CITimebase * Timebase
Timebase configuration.
InputTerminal FirstInputTerminal
Input Terminal.
InputTerminal SecondInputTerminal
Input Terminal.
ValueReturnMode EdgeSeparationMode

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ EdgeSeparationMode

ValueReturnMode JY5325CoreOO::TwoEdgeSeparation::EdgeSeparationMode

数据返回模式

data return mode

◆ FirstInputTerminal

InputTerminal JY5325CoreOO::TwoEdgeSeparation::FirstInputTerminal

Input Terminal.

◆ SecondInputTerminal

InputTerminal JY5325CoreOO::TwoEdgeSeparation::SecondInputTerminal

Input Terminal.

◆ Timebase

CITimebase* JY5325CoreOO::TwoEdgeSeparation::Timebase

Timebase configuration.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOCITask.h


5325 C++ Programming Manual: JY5325CoreOO::QuadEncoder Class Reference

  • QuadEncoder
Public Attributes | List of all members
JY5325CoreOO::QuadEncoder Class Reference

Configure CI Measure. More...

#include <JY5325CoreOOCITask.h>

Public Attributes

QuadEncodingType EncodingType
Type of Encoding.
bool | ZReloadEnabled
In Encoder mode ,the Z signal enable.
int | InitialCount
Initial Count.
InputTerminal AInputTerminal
Input Terminal.
InputTerminal BInputTerminal
Input Terminal.
InputTerminal ZInputTerminal
Input Terminal.

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ AInputTerminal

InputTerminal JY5325CoreOO::QuadEncoder::AInputTerminal

Input Terminal.

◆ BInputTerminal

InputTerminal JY5325CoreOO::QuadEncoder::BInputTerminal

Input Terminal.

◆ EncodingType

QuadEncodingType JY5325CoreOO::QuadEncoder::EncodingType

Type of Encoding.

◆ InitialCount

int JY5325CoreOO::QuadEncoder::InitialCount

Initial Count.

◆ ZInputTerminal

InputTerminal JY5325CoreOO::QuadEncoder::ZInputTerminal

Input Terminal.

◆ ZReloadEnabled

bool JY5325CoreOO::QuadEncoder::ZReloadEnabled

In Encoder mode ,the Z signal enable.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOCITask.h


5325 C++ Programming Manual: JY5325CoreOO::TwoPulseEncoder Class Reference

  • TwoPulseEncoder
Public Attributes | List of all members
JY5325CoreOO::TwoPulseEncoder Class Reference

Configure CI Measure. More...

#include <JY5325CoreOOCITask.h>

Public Attributes

int InitialCount
Initial Count.
InputTerminal AInputTerminal
Input Terminal.
InputTerminal BInputTerminal
Input Terminal.

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ AInputTerminal

InputTerminal JY5325CoreOO::TwoPulseEncoder::AInputTerminal

Input Terminal.

◆ BInputTerminal

InputTerminal JY5325CoreOO::TwoPulseEncoder::BInputTerminal

Input Terminal.

◆ InitialCount

int JY5325CoreOO::TwoPulseEncoder::InitialCount

Initial Count.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOCITask.h


5325 C++ Programming Manual: JY5325CoreOO::CITrigger Class Reference

  • CITrigger
Public Attributes | List of all members
JY5325CoreOO::CITrigger Class Reference

Constructor to create an CITrigger task object. More...

#include <JY5325CoreOOCITask.h>

Public Attributes

CITriggerType Type
CI trigger type.
CIDigitalTrigger * Digital
CI Digital Trigger.

Detailed Description

Constructor to create an CITrigger task object.

Used to build CI Trigger

Member Data Documentation

◆ Digital

CIDigitalTrigger* JY5325CoreOO::CITrigger::Digital

CI Digital Trigger.

Valid when Type is CITriggerType.Digital

◆ Type

CITriggerType JY5325CoreOO::CITrigger::Type

CI trigger type.

enum Immediate/Digital/Soft.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOCITask.h


5325 C++ Programming Manual: JY5325CoreOO::CIDigitalTrigger Class Reference

  • CIDigitalTrigger
Public Attributes | List of all members
JY5325CoreOO::CIDigitalTrigger Class Reference

CI Digital trigger . More...

#include <JY5325CoreOOCITask.h>

Public Attributes

CIDigitalTriggerSource Source
CI Digital Trigger source.
CIDigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Detailed Description

CI Digital trigger .

Member Data Documentation

◆ Edge

CIDigitalTriggerEdge JY5325CoreOO::CIDigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

CIDigitalTriggerSource JY5325CoreOO::CIDigitalTrigger::Source

CI Digital Trigger source.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOCITask.h


5325 C++ Programming Manual: JY5325CoreOO::EdgeCountingOutEvent Class Reference

  • EdgeCountingOutEvent
Public Attributes | List of all members
JY5325CoreOO::EdgeCountingOutEvent Class Reference

Edge counting output event configuration class. More...

#include <JY5325CoreOOCITask.h>

Public Attributes

EdgeCntOunEvtIdleState IdleState
Output idle state when the event has not occurred.
uint32_t Threshold
Comparison threshold.
IOTerminal Terminal
Terminal.

Detailed Description

Edge counting output event configuration class.

Member Data Documentation

◆ IdleState

EdgeCntOunEvtIdleState JY5325CoreOO::EdgeCountingOutEvent::IdleState

Output idle state when the event has not occurred.

The default value is EdgeCntOunEvtIdleState.LowLevel

◆ Terminal

IOTerminal JY5325CoreOO::EdgeCountingOutEvent::Terminal

Terminal.

◆ Threshold

uint32_t JY5325CoreOO::EdgeCountingOutEvent::Threshold

Comparison threshold.

The default value is 2^32-1

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOCITask.h


5325 C++ Programming Manual: JY5325CoreOO::CIExternalTimebase Class Reference

  • CIExternalTimebase
Public Attributes | Friends | List of all members
JY5325CoreOO::CIExternalTimebase Class Reference

#include <JY5325CoreOOCITask.h>

Public Attributes

InputTerminal Terminal
double Frequency

Friends

class CITimebase

Detailed Description

外部时基配置类

External timebase configuration class

Friends And Related Symbol Documentation

◆ CITimebase

friend class CITimebase
friend

Member Data Documentation

◆ Frequency

double JY5325CoreOO::CIExternalTimebase::Frequency

外部时基的频率

Frequency of The External Timebase

◆ Terminal

InputTerminal JY5325CoreOO::CIExternalTimebase::Terminal

外部时基的输入端口

External Timebase Input Terminal

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOCITask.h


5325 C++ Programming Manual: JY5325CoreOO::CITimebase Class Reference

  • CITimebase
Public Attributes | List of all members
JY5325CoreOO::CITimebase Class Reference

Timebase configuration class. More...

#include <JY5325CoreOOCITask.h>

Public Attributes

CITimebaseSource Source
Timebase Source.
CIExternalTimebase * External
External Timebase.
JY5325CoreOOProperty< CITimebase, double, JY5325CoreOOPropertyType::READ_ONLY > ActualFreq
The number of samples that have been transfered from the local buffer (per channel).

Detailed Description

Timebase configuration class.

Member Data Documentation

◆ ActualFreq

JY5325CoreOOProperty<CITimebase, double, JY5325CoreOOPropertyType::READ_ONLY> JY5325CoreOO::CITimebase::ActualFreq

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT CIMode.Single.

◆ External

CIExternalTimebase* JY5325CoreOO::CITimebase::External

External Timebase.

◆ Source

CITimebaseSource JY5325CoreOO::CITimebase::Source

Timebase Source.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOCITask.h


5325 C++ Programming Manual: JY5325CoreOO::CISignalExport Class Reference

  • CISignalExport
Public Member Functions | List of all members
JY5325CoreOO::CISignalExport Class Reference

CI Signal Export Class. More...

#include <JY5325CoreOOCITask.h>

Public Member Functions

void | Add (CISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (CISignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

CI Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY5325CoreOO::CISignalExport::Add | ( | CISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | CI Signal Source
destination | Export Desination

◆ Add() [2/2]

void JY5325CoreOO::CISignalExport::Add | ( | CISignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | CI Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JY5325CoreOO::CISignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5325CoreOO::CISignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOCITask.h


5325 C++ Programming Manual: COO/5325/JY5325CoreOOCommon.h File Reference

  • File List
  • File Members
  • COO
  • 5325
Classes | Namespaces | Macros | Enumerations | Functions
JY5325CoreOOCommon.h File Reference
#include <string>
#include <stdint.h>

Classes

class | JY5325CoreOO::JYDriverException
class | JY5325CoreOO::JY5325CoreOOProperty< ContainerClass, ValueType, propertyType >
属性模板类 More...
class | JY5325CoreOO::PauseTrigger
Pause trigger configuration class. More...

Namespaces

namespace JY5325CoreOO

Macros

#define | EXTERN_C extern
Windows.
#define | JY5325CoreOO_API

Enumerations

enum class | JY5325CoreOO::JY5325CoreOOPropertyType { JY5325CoreOO::READ_ONLY = 1 , JY5325CoreOO::WRITE_ONLY = 2 , JY5325CoreOO::READ_WRITE = 3 }
enum class JY5325CoreOO::JYErrorCode {
JY5325CoreOO::NoError = 0 , JY5325CoreOO::TimeOut = -10001 , JY5325CoreOO::ErrorParam = -10002 , JY5325CoreOO::IncorrectCallOrder = -10003 ,
JY5325CoreOO::CannotCall = -10004 , JY5325CoreOO::UserBufferError = -10005 , JY5325CoreOO::BufferOverflow = -10006 , JY5325CoreOO::BufferDownflow = -10007 ,
JY5325CoreOO::HardwareResourceReserved = -10008 , JY5325CoreOO::aiIsStart = -10009 , JY5325CoreOO::ErrorParam1 = -10010
}
错误代码的定义 More...
enum class JY5325CoreOO::JYDriverExceptionPublic {
JY5325CoreOO::UnKnown = 0 , JY5325CoreOO::OpenDeviceFailed = -10001 , JY5325CoreOO::CloseDeviceFailed = -10002 , JY5325CoreOO::ResetDeviceFailed = -10003 ,
JY5325CoreOO::GetDevicePropertyFailed = -10004 , JY5325CoreOO::SetDevicePropertyFailed = -10005 , JY5325CoreOO::HardwareResourceIsReserved = -10006 , JY5325CoreOO::MethodNotPermitedToCallWhenCurrentStatus = -10007 ,
JY5325CoreOO::InvalidUserDataBuffer = -10008 , JY5325CoreOO::NoChannelAdded = -10009 , JY5325CoreOO::NotSupportOperationForCurrentDevice = -10010 , JY5325CoreOO::CreatTaskFailed = -10100 ,
JY5325CoreOO::StartTaskFailed = -10101 , JY5325CoreOO::StopTaskFailed = -10102 , JY5325CoreOO::TaskHasNotStarted = -10103 , JY5325CoreOO::TaskHasStartedCannotPerformTheSetOperation = -10104 ,
JY5325CoreOO::ChannelNumberParameterInvalid = -10105 , JY5325CoreOO::ChannelInputRangeParameterInvalid = -10106 , JY5325CoreOO::ChannelTerminalParameterInvalid = -10107 , JY5325CoreOO::ChannelCouplingParameterInvalid = -10108 ,
JY5325CoreOO::SampeleModeParameterInvalid = -10109 , JY5325CoreOO::SampleClockParameterInvalid = -10110 , JY5325CoreOO::SampleRateParameterInvalid = -10111 , JY5325CoreOO::UpdateRateParameterInvalid = -10112 ,
JY5325CoreOO::TriggerParameterInvalid = -10113 , JY5325CoreOO::ReferenceTriggerDoesNotMatchWithSampleMode = -10114 , JY5325CoreOO::PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint = -10115 , JY5325CoreOO::ReadDataFailed = -10016 ,
JY5325CoreOO::ReadDataTimeout = -10017 , JY5325CoreOO::WriteDataFailed = -10018 , JY5325CoreOO::WriteDataTimeout = -10019 , JY5325CoreOO::WriteDataLengthCannotBeLessThanN = -10020 ,
JY5325CoreOO::BufferDataOverflow = -10021 , JY5325CoreOO::BufferDataDownflow = -10022 , JY5325CoreOO::CheckBufferFailed = -10023 , JY5325CoreOO::PointInvalidInFiniteMode = -10024 ,
JY5325CoreOO::ReadPointInvalid = -10025 , JY5325CoreOO::OnlySupportRecordMode = -10026 , JY5325CoreOO::SendSoftTirggerFailed = -10027 , JY5325CoreOO::TaskTimeout = -10028 ,
JY5325CoreOO::CounterParametersInvalid = -10029 , JY5325CoreOO::WritePointInvalid = -10030 , JY5325CoreOO::SignalExportDestinationInvalid = -10031 , JY5325CoreOO::InvalidParameter = -10033
}
enum class JY5325CoreOO::ClockTerminal {
JY5325CoreOO::PFI0 = 0 , JY5325CoreOO::PFI1 = 1 , JY5325CoreOO::PFI2 = 2 , JY5325CoreOO::PFI3 = 3 ,
JY5325CoreOO::PFI4 = 4 , JY5325CoreOO::PFI5 = 5 , JY5325CoreOO::PFI6 = 6 , JY5325CoreOO::PFI7 = 7 ,
JY5325CoreOO::PXI_Trig0 = 8 , JY5325CoreOO::PXI_Trig1 = 9 , JY5325CoreOO::PXI_Trig2 = 10 , JY5325CoreOO::PXI_Trig3 = 11 ,
JY5325CoreOO::PXI_Trig4 = 12 , JY5325CoreOO::PXI_Trig5 = 13 , JY5325CoreOO::PXI_Trig6 = 14 , JY5325CoreOO::PXI_Trig7 = 15 ,
JY5325CoreOO::DI_SampleClock = 18 , JY5325CoreOO::DO_SampleClock = 19 , JY5325CoreOO::CI_0_SampleClock = 20 , JY5325CoreOO::CI_1_SampleClock = 21 ,
JY5325CoreOO::CO_0_Output = 22 , JY5325CoreOO::CO_1_Output = 23
}
enum class | JY5325CoreOO::SyncTopology { JY5325CoreOO::Independent , JY5325CoreOO::Master , JY5325CoreOO::Slave }
enum class JY5325CoreOO::SyncTriggerRouting {
JY5325CoreOO::NONE = -1 , JY5325CoreOO::PFI0 , JY5325CoreOO::PFI1 , JY5325CoreOO::PFI2 ,
JY5325CoreOO::PFI3 , JY5325CoreOO::PFI4 , JY5325CoreOO::PFI5 , JY5325CoreOO::PFI6 ,
JY5325CoreOO::PFI7 , JY5325CoreOO::PXI_Trig0 = 8 , JY5325CoreOO::PXI_Trig1 = 9 , JY5325CoreOO::PXI_Trig2 = 10 ,
JY5325CoreOO::PXI_Trig3 = 11 , JY5325CoreOO::PXI_Trig4 = 12 , JY5325CoreOO::PXI_Trig5 = 13 , JY5325CoreOO::PXI_Trig6 = 14 ,
JY5325CoreOO::PXI_Trig7 = 15
}
enum class JY5325CoreOO::SignalExportDestination {
JY5325CoreOO::PFI0 , JY5325CoreOO::PFI1 , JY5325CoreOO::PFI2 , JY5325CoreOO::PFI3 ,
JY5325CoreOO::PFI4 , JY5325CoreOO::PFI5 , JY5325CoreOO::PFI6 , JY5325CoreOO::PFI7 ,
JY5325CoreOO::PXI_Trig0 = 8 , JY5325CoreOO::PXI_Trig1 = 9 , JY5325CoreOO::PXI_Trig2 = 10 , JY5325CoreOO::PXI_Trig3 = 11 ,
JY5325CoreOO::PXI_Trig4 = 12 , JY5325CoreOO::PXI_Trig5 = 13 , JY5325CoreOO::PXI_Trig6 = 14 , JY5325CoreOO::PXI_Trig7 = 15
}
enum class | JY5325CoreOO::OutputCompleteState { JY5325CoreOO::Zero , JY5325CoreOO::Hold }
Output Complete State. More...
enum class JY5325CoreOO::IOTerminal {
JY5325CoreOO::PFI0 = 0 , JY5325CoreOO::PFI1 = 1 , JY5325CoreOO::PFI2 = 2 , JY5325CoreOO::PFI3 = 3 ,
JY5325CoreOO::PFI4 = 4 , JY5325CoreOO::PFI5 = 5 , JY5325CoreOO::PFI6 = 6 , JY5325CoreOO::PFI7 = 7 ,
JY5325CoreOO::PXI_Trig0 = 8 , JY5325CoreOO::PXI_Trig1 = 9 , JY5325CoreOO::PXI_Trig2 = 10 , JY5325CoreOO::PXI_Trig3 = 11 ,
JY5325CoreOO::PXI_Trig4 = 12 , JY5325CoreOO::PXI_Trig5 = 13 , JY5325CoreOO::PXI_Trig6 = 14 , JY5325CoreOO::PXI_Trig7 = 15 ,
JY5325CoreOO::None = 16
}
Cunter IO Terminal. More...
enum class | JY5325CoreOO::LevelPolarity { JY5325CoreOO::LowLevel = 0 , JY5325CoreOO::HighLevel = 1 , JY5325CoreOO::None = 2 }
Level Polarity. More...
enum class JY5325CoreOO::InputTerminal {
JY5325CoreOO::PFI0 = 0 , JY5325CoreOO::PFI1 = 1 , JY5325CoreOO::PFI2 = 2 , JY5325CoreOO::PFI3 = 3 ,
JY5325CoreOO::PFI4 = 4 , JY5325CoreOO::PFI5 = 5 , JY5325CoreOO::PFI6 = 6 , JY5325CoreOO::PFI7 = 7 ,
JY5325CoreOO::PXI_Trig0 = 8 , JY5325CoreOO::PXI_Trig1 = 9 , JY5325CoreOO::PXI_Trig2 = 10 , JY5325CoreOO::PXI_Trig3 = 11 ,
JY5325CoreOO::PXI_Trig4 = 12 , JY5325CoreOO::PXI_Trig5 = 13 , JY5325CoreOO::PXI_Trig6 = 14 , JY5325CoreOO::PXI_Trig7 = 15 ,
JY5325CoreOO::AI_SampleClock = 16 , JY5325CoreOO::AO_SampleClock = 17 , JY5325CoreOO::DI_SampleClock = 18 , JY5325CoreOO::DO_SampleClock = 19 ,
JY5325CoreOO::CO_0_OutPut = 20 , JY5325CoreOO::CO_1_OutPut = 21 , JY5325CoreOO::Timebase_100MHz = 22 , JY5325CoreOO::Timebase_5MHz = 23 ,
JY5325CoreOO::Timebase_100kHz = 24
}
Cunter Input Terminal. More...

Functions

std::string JY5325CoreOO::GetSignalExportDestinationString (SignalExportDestination destination)

Macro Definition Documentation

◆ EXTERN_C

#define EXTERN_C extern

Windows.

Linux

◆ JY5325CoreOO_API

#define JY5325CoreOO_API


5325 C++ Programming Manual: JY5325CoreOO::JYDriverException Class Reference

  • JYDriverException
Public Member Functions | Public Attributes | List of all members
JY5325CoreOO::JYDriverException Class Reference

#include <JY5325CoreOOCommon.h>

Public Member Functions

JYDriverException (JYDriverExceptionPublic exceptionCode, std::string msg="")
JYDriverException (JYErrorCode exceptionCode, std::string msg="")
JYDriverException (int, std::string msg)

Public Attributes

std::string exceptionMessage
JYDriverExceptionPublic errorCode
JYDriverException * FollowingException

Constructor & Destructor Documentation

◆ JYDriverException() [1/3]

JY5325CoreOO::JYDriverException::JYDriverException | ( | JYDriverExceptionPublic | exceptionCode,
 |  | std::string | msg = "" )

◆ JYDriverException() [2/3]

JY5325CoreOO::JYDriverException::JYDriverException | ( | JYErrorCode | exceptionCode,
 |  | std::string | msg = "" )

◆ JYDriverException() [3/3]

JY5325CoreOO::JYDriverException::JYDriverException | ( | int | ,
 |  | std::string | msg )

Member Data Documentation

◆ errorCode

JYDriverExceptionPublic JY5325CoreOO::JYDriverException::errorCode

◆ exceptionMessage

std::string JY5325CoreOO::JYDriverException::exceptionMessage

◆ FollowingException

JYDriverException* JY5325CoreOO::JYDriverException::FollowingException
The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOCommon.h


5325 C++ Programming Manual: JY5325CoreOO::JY5325CoreOOProperty< ContainerClass, ValueType, propertyType > Class Template Reference

  • JY5325CoreOOProperty
Public Member Functions | List of all members
JY5325CoreOO::JY5325CoreOOProperty< ContainerClass, ValueType, propertyType > Class Template Reference

属性模板类 More...

#include <JY5325CoreOOCommon.h>

Public Member Functions

JY5325CoreOOProperty ()
JY5325CoreOOProperty (ContainerClass *cObject, ValueType(ContainerClass::*pGet)(), void(ContainerClass::*pSet)(ValueType value))
JY5325CoreOOProperty (ValueType(*pGet)(), void(*pSet)(ValueType value))
ValueType operator= (const ValueType &value)
operator ValueType ()

Detailed Description

template<typename ContainerClass, typename ValueType, JY5325CoreOOPropertyType propertyType>
class JY5325CoreOO::JY5325CoreOOProperty< ContainerClass, ValueType, propertyType >

属性模板类

Constructor & Destructor Documentation

◆ JY5325CoreOOProperty() [1/3]

template<typename ContainerClass, typename ValueType, JY5325CoreOOPropertyType propertyType>
JY5325CoreOO::JY5325CoreOOProperty< ContainerClass, ValueType, propertyType >::JY5325CoreOOProperty ( )

◆ JY5325CoreOOProperty() [2/3]

template<typename ContainerClass, typename ValueType, JY5325CoreOOPropertyType propertyType>
JY5325CoreOO::JY5325CoreOOProperty< ContainerClass, ValueType, propertyType >::JY5325CoreOOProperty | ( | ContainerClass * | cObject,
 |  | ValueType(ContainerClass::* | pGet )(),
 |  | void(ContainerClass::* | pSet )(ValueType value) )

◆ JY5325CoreOOProperty() [3/3]

template<typename ContainerClass, typename ValueType, JY5325CoreOOPropertyType propertyType>
JY5325CoreOO::JY5325CoreOOProperty< ContainerClass, ValueType, propertyType >::JY5325CoreOOProperty | ( | ValueType(* | pGet )(),
 |  | void(* | pSet )(ValueType value) )

Member Function Documentation

◆ operator ValueType()

template<typename ContainerClass, typename ValueType, JY5325CoreOOPropertyType propertyType>
JY5325CoreOO::JY5325CoreOOProperty< ContainerClass, ValueType, propertyType >::operator ValueType ( )

◆ operator=()

template<typename ContainerClass, typename ValueType, JY5325CoreOOPropertyType propertyType>
ValueType JY5325CoreOO::JY5325CoreOOProperty< ContainerClass, ValueType, propertyType >::operator= ( const ValueType & value )
The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOCommon.h


5325 C++ Programming Manual: JY5325CoreOO::PauseTrigger Class Reference

  • PauseTrigger
Public Attributes | List of all members
JY5325CoreOO::PauseTrigger Class Reference

Pause trigger configuration class. More...

#include <JY5325CoreOOCommon.h>

Public Attributes

LevelPolarity ActivePolarity
Pause trigger active polarity.
InputTerminal Terminal
Terminal.

Detailed Description

Pause trigger configuration class.

Member Data Documentation

◆ ActivePolarity

LevelPolarity JY5325CoreOO::PauseTrigger::ActivePolarity

Pause trigger active polarity.

The default value is LevelPolarity.None, means the pause trigger is disabled.

◆ Terminal

InputTerminal JY5325CoreOO::PauseTrigger::Terminal

Terminal.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOCommon.h


5325 C++ Programming Manual: COO/5325/JY5325CoreOOCOTask.h File Reference

  • File List
  • File Members
  • COO
  • 5325
Classes | Namespaces | Enumerations
JY5325CoreOOCOTask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JY5325CoreOOCommon.h"
#include "JY5325CoreOODevice.h"

Classes

class | JY5325CoreOO::JY5325CoreOOCOTask
class | JY5325CoreOO::CODigitalTrigger
CO Digital trigger . More...
class | JY5325CoreOO::COTrigger
Constructor to create an COTrigger task object. More...
class | JY5325CoreOO::COPulse
Pulse Parameter. More...
class | JY5325CoreOO::COExternalTimebase
class | JY5325CoreOO::COTimebase
Timebase configuration class. More...
class | JY5325CoreOO::COSignalExport
CO Signal Export Class. More...

Namespaces

namespace JY5325CoreOO

Enumerations

enum class | JY5325CoreOO::COIdleState { JY5325CoreOO::HighLevel = 0x1 , JY5325CoreOO::LowLevel = 0x0 }
Idle state when pulse output before start and after stop. More...
enum class | JY5325CoreOO::COMode { JY5325CoreOO::Single = 3 , JY5325CoreOO::Finite = 0 , JY5325CoreOO::ContinuousNoWrapping = 2 , JY5325CoreOO::ContinuousWrapping = 1 }
enum class | JY5325CoreOO::COTriggerType { JY5325CoreOO::Immediate = 0x0 , JY5325CoreOO::Digital = 0x1 , JY5325CoreOO::Soft = 0x3 }
TriggerType Digital/Immediate/Soft. More...
enum class JY5325CoreOO::CODigitalTriggerSource {
JY5325CoreOO::PFI0 , JY5325CoreOO::PFI1 , JY5325CoreOO::PFI2 , JY5325CoreOO::PFI3 ,
JY5325CoreOO::PFI4 , JY5325CoreOO::PFI5 , JY5325CoreOO::PFI6 , JY5325CoreOO::PFI7 ,
JY5325CoreOO::PXI_Trig0 = 8 , JY5325CoreOO::PXI_Trig1 = 9 , JY5325CoreOO::PXI_Trig2 = 10 , JY5325CoreOO::PXI_Trig3 = 11 ,
JY5325CoreOO::PXI_Trig4 = 12 , JY5325CoreOO::PXI_Trig5 = 13 , JY5325CoreOO::PXI_Trig6 = 14 , JY5325CoreOO::PXI_Trig7 = 15 ,
JY5325CoreOO::AI_StartTrig = 16 , JY5325CoreOO::AI_ReferenceTrig = 17 , JY5325CoreOO::AO_StartTrig = 18 , JY5325CoreOO::DI_StartTrig = 19 ,
JY5325CoreOO::DI_ReferenceTrig = 20 , JY5325CoreOO::DO_StartTrig = 21 , JY5325CoreOO::CIO_0_StartTrig = 22 , JY5325CoreOO::CIO_1_StartTrig = 23 ,
JY5325CoreOO::CO_0_Out = 24 , JY5325CoreOO::CO_1_Out = 25
}
CO Digital trigger source. More...
enum class | JY5325CoreOO::CODigitalTriggerEdge { JY5325CoreOO::Rising , JY5325CoreOO::Falling }
CO Digital Trigger Edge. More...
enum class | JY5325CoreOO::COPulseType { JY5325CoreOO::DutyCycleFrequency , JY5325CoreOO::HighLowTime , JY5325CoreOO::HighLowTick }
Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick. More...
enum class | JY5325CoreOO::COTimebaseSource { JY5325CoreOO::Internal100MHz = 0 , JY5325CoreOO::Internal5MHz = 1 , JY5325CoreOO::Internal100kHz = 2 , JY5325CoreOO::External = 3 }
Timebase source. More...
enum class JY5325CoreOO::COSignalExportSource {
JY5325CoreOO::StartTrig , JY5325CoreOO::Output , JY5325CoreOO::Internal_Counter_100K = 34 , JY5325CoreOO::Internal_Counter_5M = 33 ,
JY5325CoreOO::Internal_Counter_100M = 32
}
SourceSignal. More...


5325 C++ Programming Manual: JY5325CoreOO::JY5325CoreOOCOTask Class Reference

  • JY5325CoreOOCOTask
Public Member Functions | Public Attributes | List of all members
JY5325CoreOO::JY5325CoreOOCOTask Class Reference

#include <JY5325CoreOOCOTask.h>

Public Member Functions

JY5325CoreOOCOTask (int slotNum, int channel)
JY5325CoreOOCOTask (std::string boardName, int channel)
~JY5325CoreOOCOTask ()
void | WriteSinglePoint (COPulse &pulse)
Write a single pulse parameter to the register.
void | WriteData (COPulse *pulsesGroup[], int samplesToWrite, int timeout=10000)
Write pulse parameters to be output to the buffer.
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Start ()
Start CO task .
void | Stop ()
Stop COtask .
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.

Public Attributes

COMode Mode
CO output mode.
IOTerminal OutputTerminal
PauseTrigger * Pause
COTimebase * TimeBase
CO's time base.
double | InitialDelay
Counter output initial delay in seconds.
COIdleState IdleState
Idle state when pulse output before start and after stop.
uint32_t | SamplesToUpdate
有限频率输出
JY5325CoreOOProperty< JY5325CoreOOCOTask, int, JY5325CoreOOPropertyType::READ_ONLY > | BufLenInSamples
Number of samples per channel can be storage in the buffer, the Property SamplesToAcquire must be less than or equal to this value.
JY5325CoreOOProperty< JY5325CoreOOCOTask, uint32_t, JY5325CoreOOPropertyType::READ_ONLY > | AvailableSamples
Number of points per channel that can be read in the buffer .
JY5325CoreOOProperty< JY5325CoreOOCOTask, uint64_t, JY5325CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
JY5325CoreOOProperty< JY5325CoreOOCOTask, uint32_t, JY5325CoreOOPropertyType::READ_ONLY > | TransferedPulses
COTrigger * Trigger
CO trigger property configured by CO Trigger().
JY5325CoreOODevice * Device
Device.
COSignalExport * SignalExport
Export CO Signal Configuration.

Constructor & Destructor Documentation

◆ JY5325CoreOOCOTask() [1/2]

JY5325CoreOO::JY5325CoreOOCOTask::JY5325CoreOOCOTask | ( | int | slotNum,
 |  | int | channel )

◆ JY5325CoreOOCOTask() [2/2]

JY5325CoreOO::JY5325CoreOOCOTask::JY5325CoreOOCOTask | ( | std::string | boardName,
 |  | int | channel )

◆ ~JY5325CoreOOCOTask()

JY5325CoreOO::JY5325CoreOOCOTask::~JY5325CoreOOCOTask ( )

Member Function Documentation

◆ SendSoftwareTrigger()

void JY5325CoreOO::JY5325CoreOOCOTask::SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5325CoreOO::JY5325CoreOOCOTask::Start ( )

Start CO task .

◆ Stop()

void JY5325CoreOO::JY5325CoreOOCOTask::Stop ( )

Stop COtask .

◆ WaitUntilDone()

bool JY5325CoreOO::JY5325CoreOOCOTask::WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteData()

void JY5325CoreOO::JY5325CoreOOCOTask::WriteData | ( | COPulse * | pulsesGroup[],
 |  | int | samplesToWrite,
 |  | int | timeout = 10000 )

Write pulse parameters to be output to the buffer.

Valid when Mode is NOT COMode.Single. When Mode is COMode.Finite or COMode.ContinuousWrapping, this function can only be called once before starting the task.

Parameters
pulsesGroup | A group of pulse parameters
samplesToWrite | Number of samples to write. If Mode is COMode.ContinuousWrapping, you need to write at least 2 samples before starting the task
timeout | Timeout (ms). Wait until all data is written to buffer or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ WriteSinglePoint()

void JY5325CoreOO::JY5325CoreOOCOTask::WriteSinglePoint ( COPulse & pulse )

Write a single pulse parameter to the register.

Valid when Mode is COMode.Single. This function is also available after starting the task when the number of pulses being sent is infinite.

Parameters
pulse Pulse Parameter

Member Data Documentation

◆ AvailableSamples

JY5325CoreOOProperty<JY5325CoreOOCOTask, uint32_t, JY5325CoreOOPropertyType::READ_ONLY> JY5325CoreOO::JY5325CoreOOCOTask::AvailableSamples

Number of points per channel that can be read in the buffer .

◆ BufLenInSamples

JY5325CoreOOProperty<JY5325CoreOOCOTask, int, JY5325CoreOOPropertyType::READ_ONLY> JY5325CoreOO::JY5325CoreOOCOTask::BufLenInSamples

Number of samples per channel can be storage in the buffer, the Property SamplesToAcquire must be less than or equal to this value.

◆ Device

JY5325CoreOODevice* JY5325CoreOO::JY5325CoreOOCOTask::Device

Device.

◆ IdleState

COIdleState JY5325CoreOO::JY5325CoreOOCOTask::IdleState

Idle state when pulse output before start and after stop.

◆ InitialDelay

double JY5325CoreOO::JY5325CoreOOCOTask::InitialDelay

Counter output initial delay in seconds.

There are five ticks of the timebase fixed delay in counter internal, so the total delay(s) = InitialDelay + (5 / timebase)

◆ Mode

COMode JY5325CoreOO::JY5325CoreOOCOTask::Mode

CO output mode.

◆ OutputTerminal

IOTerminal JY5325CoreOO::JY5325CoreOOCOTask::OutputTerminal

脉冲输出端口

Pulse Output Terminal

◆ Pause

PauseTrigger* JY5325CoreOO::JY5325CoreOOCOTask::Pause

暂停触发配置

Pause Trigger Configuration

◆ SamplesToUpdate

uint32_t JY5325CoreOO::JY5325CoreOOCOTask::SamplesToUpdate

有限频率输出

◆ SignalExport

COSignalExport* JY5325CoreOO::JY5325CoreOOCOTask::SignalExport

Export CO Signal Configuration.

◆ TimeBase

COTimebase* JY5325CoreOO::JY5325CoreOOCOTask::TimeBase

CO's time base.

◆ TransferedPulses

JY5325CoreOOProperty<JY5325CoreOOCOTask, uint32_t, JY5325CoreOOPropertyType::READ_ONLY> JY5325CoreOO::JY5325CoreOOCOTask::TransferedPulses

当前配置下已发送的脉冲的数量。

The number of pulses transfered under the current configuration.

◆ TransferedSamples

JY5325CoreOOProperty<JY5325CoreOOCOTask, uint64_t, JY5325CoreOOPropertyType::READ_ONLY> JY5325CoreOO::JY5325CoreOOCOTask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT CIMode.Single.

◆ Trigger

COTrigger* JY5325CoreOO::JY5325CoreOOCOTask::Trigger

CO trigger property configured by CO Trigger().

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOCOTask.h


5325 C++ Programming Manual: JY5325CoreOO::CODigitalTrigger Class Reference

  • CODigitalTrigger
Public Attributes | List of all members
JY5325CoreOO::CODigitalTrigger Class Reference

CO Digital trigger . More...

#include <JY5325CoreOOCOTask.h>

Public Attributes

CODigitalTriggerSource Source
CO Digital Trigger source.
CODigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Detailed Description

CO Digital trigger .

Member Data Documentation

◆ Edge

CODigitalTriggerEdge JY5325CoreOO::CODigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

CODigitalTriggerSource JY5325CoreOO::CODigitalTrigger::Source

CO Digital Trigger source.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOCOTask.h


5325 C++ Programming Manual: JY5325CoreOO::COTrigger Class Reference

  • COTrigger
Public Attributes | List of all members
JY5325CoreOO::COTrigger Class Reference

Constructor to create an COTrigger task object. More...

#include <JY5325CoreOOCOTask.h>

Public Attributes

COTriggerType Type
CO trigger type.
CODigitalTrigger * Digital
CO Digital Trigger.

Detailed Description

Constructor to create an COTrigger task object.

Used to build CO Trigger

Member Data Documentation

◆ Digital

CODigitalTrigger* JY5325CoreOO::COTrigger::Digital

CO Digital Trigger.

Valid when Type is COTriggerType.Digital

◆ Type

COTriggerType JY5325CoreOO::COTrigger::Type

CO trigger type.

enum Immediate/Digital/Soft.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOCOTask.h


5325 C++ Programming Manual: JY5325CoreOO::COPulse Class Reference

  • COPulse
Public Member Functions | List of all members
JY5325CoreOO::COPulse Class Reference

Pulse Parameter. More...

#include <JY5325CoreOOCOTask.h>

Public Member Functions

COPulse (COPulseType type, double param1, double param2, int count)
Pulse Parameter.

Detailed Description

Pulse Parameter.

Constructor & Destructor Documentation

◆ COPulse()

JY5325CoreOO::COPulse::COPulse | ( | COPulseType | type,
 |  | double | param1,
 |  | double | param2,
 |  | int | count )

Pulse Parameter.

Parameters
type | The pulse type characteristics.
param1 | Parameter 1. Frequency (Hz) when constructed as COPulseType.DutyCycleFrequency; High duration in seconds when constructed as COPulseType.HighLowTime; High ticks of the clock when constructed as COPulseType.HighLowTick.
param2 | Parameter 1. Duty cycle (greater than 0 and less than 1) when constructed as COPulseType.DutyCycleFrequency; Low duration in seconds when constructed as COPulseType.HighLowTime; Low ticks of the clock when constructed as COPulseType.HighLowTick.
count | Number of pulses. When the value is -1 (indicating that the number of pulses is infinite), pulses will be continuously sent until requested to stop.
The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOCOTask.h


5325 C++ Programming Manual: JY5325CoreOO::COExternalTimebase Class Reference

  • COExternalTimebase
Public Attributes | Friends | List of all members
JY5325CoreOO::COExternalTimebase Class Reference

#include <JY5325CoreOOCOTask.h>

Public Attributes

InputTerminal Terminal
double Frequency

Friends

class COTimebase

Detailed Description

外部时基配置类

External timebase configuration class

Friends And Related Symbol Documentation

◆ COTimebase

friend class COTimebase
friend

Member Data Documentation

◆ Frequency

double JY5325CoreOO::COExternalTimebase::Frequency

外部时基的频率

Frequency of The External Timebase

◆ Terminal

InputTerminal JY5325CoreOO::COExternalTimebase::Terminal

外部时基的输入端口

External Timebase Input Terminal

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOCOTask.h


5325 C++ Programming Manual: JY5325CoreOO::COTimebase Class Reference

  • COTimebase
Public Attributes | List of all members
JY5325CoreOO::COTimebase Class Reference

Timebase configuration class. More...

#include <JY5325CoreOOCOTask.h>

Public Attributes

COTimebaseSource Source
Timebase Source.
COExternalTimebase * External
Timebase External.
JY5325CoreOOProperty< COTimebase, double, JY5325CoreOOPropertyType::READ_ONLY > ActualFreq
The number of samples that have been transfered from the local buffer (per channel).

Detailed Description

Timebase configuration class.

Member Data Documentation

◆ ActualFreq

JY5325CoreOOProperty<COTimebase, double, JY5325CoreOOPropertyType::READ_ONLY> JY5325CoreOO::COTimebase::ActualFreq

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT COMode.Single.

◆ External

COExternalTimebase* JY5325CoreOO::COTimebase::External

Timebase External.

◆ Source

COTimebaseSource JY5325CoreOO::COTimebase::Source

Timebase Source.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOCOTask.h


5325 C++ Programming Manual: JY5325CoreOO::COSignalExport Class Reference

  • COSignalExport
Public Member Functions | List of all members
JY5325CoreOO::COSignalExport Class Reference

CO Signal Export Class. More...

#include <JY5325CoreOOCOTask.h>

Public Member Functions

void | Add (COSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (COSignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

CO Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY5325CoreOO::COSignalExport::Add | ( | COSignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | CI Signal Source
destination | Export Desination

◆ Add() [2/2]

void JY5325CoreOO::COSignalExport::Add | ( | COSignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | CI Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JY5325CoreOO::COSignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5325CoreOO::COSignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOCOTask.h


5325 C++ Programming Manual: COO/5325/JY5325CoreOODevice.h File Reference

  • File List
  • File Members
  • COO
  • 5325
Classes | Namespaces | Enumerations
JY5325CoreOODevice.h File Reference
#include <iostream>
#include <string>
#include <list>
#include <vector>
#include "JY5325CoreOOCommon.h"

Classes

class | JY5325CoreOO::JY5325CoreOODevice
class | JY5325CoreOO::PFIFilter
class | JY5325CoreOO::PFISetting
class | JY5325CoreOO::ExternalReferenceClock
class | JY5325CoreOO::JY5325CoreOOReferenceClock

Namespaces

namespace JY5325CoreOO

Enumerations

enum class | JY5325CoreOO::ExternalReferenceClockTerminal { JY5325CoreOO::PXIe_Clk100 = 0x1 }
enum class | JY5325CoreOO::ReferenceClockSource { JY5325CoreOO::Internal = 0x0 , JY5325CoreOO::External = 0x1 }
enum class JY5325CoreOO::PFITerminal {
JY5325CoreOO::PFI0 = 0 , JY5325CoreOO::PFI1 = 1 , JY5325CoreOO::PFI2 = 2 , JY5325CoreOO::PFI3 = 3 ,
JY5325CoreOO::PFI4 = 4 , JY5325CoreOO::PFI5 = 5 , JY5325CoreOO::PFI6 = 6 , JY5325CoreOO::PFI7 = 7 ,
JY5325CoreOO::PFI8 = 8 , JY5325CoreOO::PFI9 = 9 , JY5325CoreOO::PFI10 = 10 , JY5325CoreOO::PFI11 = 11 ,
JY5325CoreOO::PFI12 = 12 , JY5325CoreOO::PFI13 = 13 , JY5325CoreOO::PFI14 = 14 , JY5325CoreOO::PFI15 = 15
}
Input/Output Terminal of PFI. More...


5325 C++ Programming Manual: JY5325CoreOO::JY5325CoreOODevice Class Reference

  • JY5325CoreOODevice
Public Types | Static Public Member Functions | Public Attributes | List of all members
JY5325CoreOO::JY5325CoreOODevice Class Reference

#include <JY5325CoreOODevice.h>

Public Types

enum class CounterInterface {
Source , Gate , Aux , SampleClock ,
Out
}

Static Public Member Functions

static unsigned | GetDefautTerminal (CounterInterface counterInterface, unsigned channelID)
static JY5325CoreOODevice * | GetInstance (int cardNum)
static JY5325CoreOODevice * | GetInstance (std::string aliasName)

Public Attributes

const double | BoardClockRate = 200000000
const double | MaxSampleRate = 5e6
const double | MaxSampleRateMutilChannel = 1000000
const int | AIBufferSize = 0x100000 * 256
const int | DIOLineCount = 8
const bool | IsAISync = false
const double | MaxUpdateRateSingleChannel = 2860000
AOMaxUpdateRateSingleChannel.
const double | MaxUpdateRateTwoChannel = 2000000
AOMaxUpdateRateTwoChannel.
const double | MaxUpdateRateThreeChannel = 1540000
AOMaxUpdateRateThreeChannel.
const double | MaxUpdateRateFourChannel = 1250000
AOMaxUpdateRateFourChannel.
const bool | IsAOSync = true
IsAOSync.
JY5325CoreOOProperty< JY5325CoreOODevice, int, JY5325CoreOOPropertyType::READ_ONLY > | DiffChannelCount
JY5325CoreOOProperty< JY5325CoreOODevice, double, JY5325CoreOOPropertyType::READ_ONLY > | MaxSampleRateSingleChannel
JY5325CoreOOProperty< JY5325CoreOODevice, int, JY5325CoreOOPropertyType::READ_ONLY > | AOChannelCount
JY5325CoreOOProperty< JY5325CoreOODevice, std::string, JY5325CoreOOPropertyType::READ_ONLY > | SerialNumber
JY5325CoreOOProperty< JY5325CoreOODevice, int, JY5325CoreOOPropertyType::READ_ONLY > | DeviceID
JY5325CoreOOProperty< JY5325CoreOODevice, void *, JY5325CoreOOPropertyType::READ_ONLY > | Handle
PFISetting * PFI
JY5325CoreOOReferenceClock * ReferenceClock

Member Enumeration Documentation

◆ CounterInterface

enum class JY5325CoreOO::JY5325CoreOODevice::CounterInterface
strong
Enumerator
Source
Gate
Aux
SampleClock
Out

Member Function Documentation

◆ GetDefautTerminal()

static unsigned JY5325CoreOO::JY5325CoreOODevice::GetDefautTerminal | ( | CounterInterface | counterInterface,
 |  | unsigned | channelID )
 static

◆ GetInstance() [1/2]

static JY5325CoreOODevice * JY5325CoreOO::JY5325CoreOODevice::GetInstance ( int cardNum )
static

◆ GetInstance() [2/2]

static JY5325CoreOODevice * JY5325CoreOO::JY5325CoreOODevice::GetInstance ( std::string aliasName )
static

Member Data Documentation

◆ AIBufferSize

const int JY5325CoreOO::JY5325CoreOODevice::AIBufferSize = 0x100000 * 256

◆ AOChannelCount

JY5325CoreOOProperty<JY5325CoreOODevice, int, JY5325CoreOOPropertyType::READ_ONLY> JY5325CoreOO::JY5325CoreOODevice::AOChannelCount

◆ BoardClockRate

const double JY5325CoreOO::JY5325CoreOODevice::BoardClockRate = 200000000

◆ DeviceID

JY5325CoreOOProperty<JY5325CoreOODevice, int, JY5325CoreOOPropertyType::READ_ONLY> JY5325CoreOO::JY5325CoreOODevice::DeviceID

◆ DiffChannelCount

JY5325CoreOOProperty<JY5325CoreOODevice, int, JY5325CoreOOPropertyType::READ_ONLY> JY5325CoreOO::JY5325CoreOODevice::DiffChannelCount

◆ DIOLineCount

const int JY5325CoreOO::JY5325CoreOODevice::DIOLineCount = 8

◆ Handle

JY5325CoreOOProperty<JY5325CoreOODevice, void*, JY5325CoreOOPropertyType::READ_ONLY> JY5325CoreOO::JY5325CoreOODevice::Handle

◆ IsAISync

const bool JY5325CoreOO::JY5325CoreOODevice::IsAISync = false

◆ IsAOSync

const bool JY5325CoreOO::JY5325CoreOODevice::IsAOSync = true

IsAOSync.

◆ MaxSampleRate

const double JY5325CoreOO::JY5325CoreOODevice::MaxSampleRate = 5e6

◆ MaxSampleRateMutilChannel

const double JY5325CoreOO::JY5325CoreOODevice::MaxSampleRateMutilChannel = 1000000

◆ MaxSampleRateSingleChannel

JY5325CoreOOProperty<JY5325CoreOODevice, double, JY5325CoreOOPropertyType::READ_ONLY> JY5325CoreOO::JY5325CoreOODevice::MaxSampleRateSingleChannel

◆ MaxUpdateRateFourChannel

const double JY5325CoreOO::JY5325CoreOODevice::MaxUpdateRateFourChannel = 1250000

AOMaxUpdateRateFourChannel.

◆ MaxUpdateRateSingleChannel

const double JY5325CoreOO::JY5325CoreOODevice::MaxUpdateRateSingleChannel = 2860000

AOMaxUpdateRateSingleChannel.

◆ MaxUpdateRateThreeChannel

const double JY5325CoreOO::JY5325CoreOODevice::MaxUpdateRateThreeChannel = 1540000

AOMaxUpdateRateThreeChannel.

◆ MaxUpdateRateTwoChannel

const double JY5325CoreOO::JY5325CoreOODevice::MaxUpdateRateTwoChannel = 2000000

AOMaxUpdateRateTwoChannel.

◆ PFI

PFISetting* JY5325CoreOO::JY5325CoreOODevice::PFI

◆ ReferenceClock

JY5325CoreOOReferenceClock* JY5325CoreOO::JY5325CoreOODevice::ReferenceClock

◆ SerialNumber

JY5325CoreOOProperty<JY5325CoreOODevice, std::string, JY5325CoreOOPropertyType::READ_ONLY> JY5325CoreOO::JY5325CoreOODevice::SerialNumber
The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOODevice.h


5325 C++ Programming Manual: JY5325CoreOO::PFIFilter Class Reference

  • PFIFilter
Public Member Functions | List of all members
JY5325CoreOO::PFIFilter Class Reference

#include <JY5325CoreOODevice.h>

Public Member Functions

void | Enable (PFITerminal terminal, int minPulseWidth)
Enable the filter on the specified terminal and set the minimum pulse width.
void | Enable (std::vector< PFITerminal > terminals, int minPulseWidth)
Enable the filter on a group of terminals and set the minimum pulse width.
void | Enable (std::vector< PFITerminal > terminals, std::vector< int > minPulseWidth)
Enable the filter on a group of terminals and set the minimum pulse width separately.
void | Disable (PFITerminal terminal)
Disable the filter on the specified terminal.
void | Disable (std::vector< PFITerminal > terminals)
Disable the filter on a group terminal.
void | DisableAll ()
Disable the filter on all the terminals.

Member Function Documentation

◆ Disable() [1/2]

void JY5325CoreOO::PFIFilter::Disable ( PFITerminal terminal )

Disable the filter on the specified terminal.

Parameters
terminal Specified Terminal

◆ Disable() [2/2]

void JY5325CoreOO::PFIFilter::Disable ( std::vector< PFITerminal > terminals )

Disable the filter on a group terminal.

Parameters
terminals Specified Group of Terminal

◆ DisableAll()

void JY5325CoreOO::PFIFilter::DisableAll ( )

Disable the filter on all the terminals.

◆ Enable() [1/3]

void JY5325CoreOO::PFIFilter::Enable | ( | PFITerminal | terminal,
 |  | int | minPulseWidth )

Enable the filter on the specified terminal and set the minimum pulse width.

Parameters
terminal | Specified Terminal
minPulseWidth | Minimum pulse width in ns, bounce less than this length will be ignored. The smallest step in the range of 10 ns to 2550 ns is 10 ns, the smallest step in the range of 2550 ns to 40800 ns is 160 ns, and the smallest step in the range of 40800 ns to 652800 ns The step is 2560 ns

◆ Enable() [2/3]

void JY5325CoreOO::PFIFilter::Enable | ( | std::vector< PFITerminal > | terminals,
 |  | int | minPulseWidth )

Enable the filter on a group of terminals and set the minimum pulse width.

Parameters
terminals | Specified Group of Terminals
minPulseWidth | Minimum pulse width in ns, bounce less than this length will be ignored. The smallest step in the range of 10 ns to 2550 ns is 10 ns, the smallest step in the range of 2550 ns to 40800 ns is 160 ns, and the smallest step in the range of 40800 ns to 652800 ns The step is 2560 ns

◆ Enable() [3/3]

void JY5325CoreOO::PFIFilter::Enable | ( | std::vector< PFITerminal > | terminals,
 |  | std::vector< int > | minPulseWidth )

Enable the filter on a group of terminals and set the minimum pulse width separately.

Parameters
terminals | Specified Group of Terminals
minPulseWidth | Minimum pulse width in ns, bounce less than this length will be ignored. The smallest step in the range of 10 ns to 2550 ns is 10 ns, the smallest step in the range of 2550 ns to 40800 ns is 160 ns, and the smallest step in the range of 40800 ns to 652800 ns The step is 2560 ns
The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOODevice.h


5325 C++ Programming Manual: JY5325CoreOO::PFISetting Class Reference

  • PFISetting
Public Attributes | List of all members
JY5325CoreOO::PFISetting Class Reference

#include <JY5325CoreOODevice.h>

Public Attributes

PFIFilter * Filter
PFI Filter Setting.

Member Data Documentation

◆ Filter

PFIFilter* JY5325CoreOO::PFISetting::Filter

PFI Filter Setting.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOODevice.h


5325 C++ Programming Manual: JY5325CoreOO::ExternalReferenceClock Class Reference

  • ExternalReferenceClock
Public Attributes | List of all members
JY5325CoreOO::ExternalReferenceClock Class Reference

#include <JY5325CoreOODevice.h>

Public Attributes

ExternalReferenceClockTerminal Terminal

Member Data Documentation

◆ Terminal

ExternalReferenceClockTerminal JY5325CoreOO::ExternalReferenceClock::Terminal
The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOODevice.h


5325 C++ Programming Manual: JY5325CoreOO::JY5325CoreOOReferenceClock Class Reference

  • JY5325CoreOOReferenceClock
Public Member Functions | Public Attributes | Friends | List of all members
JY5325CoreOO::JY5325CoreOOReferenceClock Class Reference

#include <JY5325CoreOODevice.h>

Public Member Functions

void Commit ()
Commit configuration.

Public Attributes

ReferenceClockSource Source
ExternalReferenceClock * External
External Reference Clock Source.

Friends

class JY5325CoreOODevice

Member Function Documentation

◆ Commit()

void JY5325CoreOO::JY5325CoreOOReferenceClock::Commit ( )

Commit configuration.

Available only when the device is idle. WARNING: Incorrect parameters will cause the PLL to be unable to lock the reference clock and cannot be recovered until shutdown and restart.

Friends And Related Symbol Documentation

◆ JY5325CoreOODevice

friend class JY5325CoreOODevice
friend

Member Data Documentation

◆ External

ExternalReferenceClock* JY5325CoreOO::JY5325CoreOOReferenceClock::External

External Reference Clock Source.

Required when ReferenceClock.Source is ReferenceClockSource.External

◆ Source

ReferenceClockSource JY5325CoreOO::JY5325CoreOOReferenceClock::Source
The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOODevice.h


5325 C++ Programming Manual: COO/5325/JY5325CoreOODITask.h File Reference

  • File List
  • File Members
  • COO
  • 5325
Classes | Namespaces | Enumerations
JY5325CoreOODITask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JY5325CoreOOCommon.h"
#include "JY5325CoreOODevice.h"

Classes

class | JY5325CoreOO::JY5325CoreOODITask
class | JY5325CoreOO::DIChannel
DI Channel parameter class . More...
class | JY5325CoreOO::DISampleClock
Sample clock configuration class. More...
class | JY5325CoreOO::DIExternalSampleClock
External Sample Clock Configuration Class. More...
class | JY5325CoreOO::DISignalExport
DI Signal Export Class. More...
class | JY5325CoreOO::DITrigger
Constructor to create an DITrigger task object. More...
class | JY5325CoreOO::DIDigitalTrigger
DI Digital trigger . More...

Namespaces

namespace JY5325CoreOO

Enumerations

enum class | JY5325CoreOO::DISampleClockSource { JY5325CoreOO::Internal , JY5325CoreOO::External }
DI Sample Clock Source. More...
enum class | JY5325CoreOO::DIMode { JY5325CoreOO::Single = 2 , JY5325CoreOO::Finite = 0 , JY5325CoreOO::Continuous = 1 }
DIMode. More...
enum class JY5325CoreOO::DISignalExportSource {
JY5325CoreOO::StartTrig = 21 , JY5325CoreOO::ReferenceTrig = 22 , JY5325CoreOO::SampleClock = 23 , JY5325CoreOO::Internal_Counter_100K = 34 ,
JY5325CoreOO::Internal_Counter_5M = 33 , JY5325CoreOO::Internal_Counter_100M = 32
}
SourceSignal. More...
enum class | JY5325CoreOO::DITriggerMode { JY5325CoreOO::Start , JY5325CoreOO::Reference }
DI Trigger Mode. More...
enum class | JY5325CoreOO::DITriggerType { JY5325CoreOO::Immediate = 0 , JY5325CoreOO::Digital = 1 , JY5325CoreOO::Soft = 3 }
TriggerType Digital/Immediate/Soft. More...
enum class JY5325CoreOO::DIDigitalTriggerSource {
JY5325CoreOO::PFI0 , JY5325CoreOO::PFI1 , JY5325CoreOO::PFI2 , JY5325CoreOO::PFI3 ,
JY5325CoreOO::PFI4 , JY5325CoreOO::PFI5 , JY5325CoreOO::PFI6 , JY5325CoreOO::PFI7 ,
JY5325CoreOO::PXI_Trig0 = 8 , JY5325CoreOO::PXI_Trig1 = 9 , JY5325CoreOO::PXI_Trig2 = 10 , JY5325CoreOO::PXI_Trig3 = 11 ,
JY5325CoreOO::PXI_Trig4 = 12 , JY5325CoreOO::PXI_Trig5 = 13 , JY5325CoreOO::PXI_Trig6 = 14 , JY5325CoreOO::PXI_Trig7 = 15 ,
JY5325CoreOO::AI_StartTrig = 16 , JY5325CoreOO::AI_ReferenceTrig = 17 , JY5325CoreOO::AO_StartTrig = 18 , JY5325CoreOO::DO_StartTrig = 21 ,
JY5325CoreOO::CIO_0_StartTrig = 22 , JY5325CoreOO::CIO_1_StartTrig = 23 , JY5325CoreOO::CO_0_Out = 24 , JY5325CoreOO::CO_1_Out = 25
}
DI Digital trigger source. More...
enum class | JY5325CoreOO::DIDigitalTriggerEdge { JY5325CoreOO::Rising , JY5325CoreOO::Falling }
DI Digital Trigger Edge. More...


5325 C++ Programming Manual: JY5325CoreOO::JY5325CoreOODITask Class Reference

  • JY5325CoreOODITask
Public Member Functions | Public Attributes | List of all members
JY5325CoreOO::JY5325CoreOODITask Class Reference

#include <JY5325CoreOODITask.h>

Public Member Functions

JY5325CoreOODITask (int slotNum)
JY5325CoreOODITask (std::string boardName)
~JY5325CoreOODITask ()
void | AddChannel (int lineNum)
Add one line.
void | AddChannel (std::vector< int > linesNum)
Add a group of line.
void | RemoveChannel (int lineNum)
Delete the specified line number.
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Start ()
Start DI task .
void | Stop ()
Stop DI task .
void | ReadSinglePoint (bool *readValues, int line)
Specify the line reads the latest line.
void | ReadSinglePoint (std::vector< bool > &readValues)
Each line reads the latest point.
void | ReadSinglePoint (bool readValues[])
Each line reads the latest point.
void | ReadData (unsigned char dataBuffer[], uint32_t samplesToAcquire, int timeOut=10000)
Read the uint8_t data from 8 Line.

Public Attributes

std::list< DIChannel * > | Channels
List of DI channels,(5325 support 8 lines)
DIMode Mode
DI acquisition mode，support Single/ Finite/Continuous.
JY5325CoreOOProperty< JY5325CoreOODITask, double, JY5325CoreOOPropertyType::READ_WRITE > | SampleRate
Sample rate per channel.
int | SamplesToAcquire
Number of samples to be read per channel.
DISampleClock * SampleClock
DI Sample Clock Configuration.
JY5325CoreOOProperty< JY5325CoreOODITask, int, JY5325CoreOOPropertyType::READ_ONLY > | BufLenInSamples
Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.
JY5325CoreOOProperty< JY5325CoreOODITask, uint64_t, JY5325CoreOOPropertyType::READ_ONLY > | AvailableSamples
Number of samples per channel that can be read in the buffer.
JY5325CoreOOProperty< JY5325CoreOODITask, uint64_t, JY5325CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
DITrigger * Trigger
DI Trigger Configuration.
DISignalExport * SignalExport
Export DI Signal.
JY5325CoreOODevice * Device
Device.

Constructor & Destructor Documentation

◆ JY5325CoreOODITask() [1/2]

JY5325CoreOO::JY5325CoreOODITask::JY5325CoreOODITask ( int slotNum )

◆ JY5325CoreOODITask() [2/2]

JY5325CoreOO::JY5325CoreOODITask::JY5325CoreOODITask ( std::string boardName )

◆ ~JY5325CoreOODITask()

JY5325CoreOO::JY5325CoreOODITask::~JY5325CoreOODITask ( )

Member Function Documentation

◆ AddChannel() [1/2]

void JY5325CoreOO::JY5325CoreOODITask::AddChannel ( int lineNum )

Add one line.

Parameters
lineNum line number

◆ AddChannel() [2/2]

void JY5325CoreOO::JY5325CoreOODITask::AddChannel ( std::vector< int > linesNum )

Add a group of line.

Parameters
linesNum line number

Add a group of line

Parameters
linesNum line number

◆ ReadData()

void JY5325CoreOO::JY5325CoreOODITask::ReadData | ( | unsigned char | dataBuffer[],
 |  | uint32_t | samplesToAcquire,
 |  | int | timeOut = 10000 )

Read the uint8_t data from 8 Line.

Each has 8 lines from 0 to 7. Each bit from low to high represents one line.

Parameters
dataBuffer | Data buffer
samplesToAcquire | Number of samples per Line to be read
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadSinglePoint() [1/3]

void JY5325CoreOO::JY5325CoreOODITask::ReadSinglePoint | ( | bool * | readValues,
 |  | int | line )

Specify the line reads the latest line.

Parameters
readValue | User buffer array
line | Specify the line to read

◆ ReadSinglePoint() [2/3]

void JY5325CoreOO::JY5325CoreOODITask::ReadSinglePoint ( bool readValues[] )

Each line reads the latest point.

Parameters
readValues User buffer array

◆ ReadSinglePoint() [3/3]

void JY5325CoreOO::JY5325CoreOODITask::ReadSinglePoint ( std::vector< bool > & readValues )

Each line reads the latest point.

Parameters
readValues User buffer array

◆ RemoveChannel()

void JY5325CoreOO::JY5325CoreOODITask::RemoveChannel ( int lineNum )

Delete the specified line number.

Parameters
lineNum line number

◆ SendSoftwareTrigger()

void JY5325CoreOO::JY5325CoreOODITask::SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5325CoreOO::JY5325CoreOODITask::Start ( )

Start DI task .

◆ Stop()

void JY5325CoreOO::JY5325CoreOODITask::Stop ( )

Stop DI task .

Member Data Documentation

◆ AvailableSamples

JY5325CoreOOProperty<JY5325CoreOODITask, uint64_t, JY5325CoreOOPropertyType::READ_ONLY> JY5325CoreOO::JY5325CoreOODITask::AvailableSamples

Number of samples per channel that can be read in the buffer.

◆ BufLenInSamples

JY5325CoreOOProperty<JY5325CoreOODITask, int, JY5325CoreOOPropertyType::READ_ONLY> JY5325CoreOO::JY5325CoreOODITask::BufLenInSamples

Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.

◆ Channels

std::list<DIChannel*> JY5325CoreOO::JY5325CoreOODITask::Channels

List of DI channels,(5325 support 8 lines)

◆ Device

JY5325CoreOODevice* JY5325CoreOO::JY5325CoreOODITask::Device

Device.

◆ Mode

DIMode JY5325CoreOO::JY5325CoreOODITask::Mode

DI acquisition mode，support Single/ Finite/Continuous.

◆ SampleClock

DISampleClock* JY5325CoreOO::JY5325CoreOODITask::SampleClock

DI Sample Clock Configuration.

◆ SampleRate

JY5325CoreOOProperty<JY5325CoreOODITask, double, JY5325CoreOOPropertyType::READ_WRITE> JY5325CoreOO::JY5325CoreOODITask::SampleRate

Sample rate per channel.

Maximum sample rate is 10M The defalut sample rate = 10k You can read this property to obtain the sample rate that will actually take effect in the current configuration.

◆ SamplesToAcquire

int JY5325CoreOO::JY5325CoreOODITask::SamplesToAcquire

Number of samples to be read per channel.

Only valid when Mode is DIMode.Finite.

◆ SignalExport

DISignalExport* JY5325CoreOO::JY5325CoreOODITask::SignalExport

Export DI Signal.

◆ TransferedSamples

JY5325CoreOOProperty<JY5325CoreOODITask, uint64_t, JY5325CoreOOPropertyType::READ_ONLY> JY5325CoreOO::JY5325CoreOODITask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT DIMode::Single.

◆ Trigger

DITrigger* JY5325CoreOO::JY5325CoreOODITask::Trigger

DI Trigger Configuration.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOODITask.h


5325 C++ Programming Manual: JY5325CoreOO::DIChannel Class Reference

  • DIChannel
Public Attributes | List of all members
JY5325CoreOO::DIChannel Class Reference

DI Channel parameter class . More...

#include <JY5325CoreOODITask.h>

Public Attributes

int LineNum
port number.

Detailed Description

DI Channel parameter class .

Member Data Documentation

◆ LineNum

int JY5325CoreOO::DIChannel::LineNum

port number.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOODITask.h


5325 C++ Programming Manual: JY5325CoreOO::DISampleClock Class Reference

  • DISampleClock
Public Attributes | List of all members
JY5325CoreOO::DISampleClock Class Reference

Sample clock configuration class. More...

#include <JY5325CoreOODITask.h>

Public Attributes

DISampleClockSource Source
Clock Source.
DIExternalSampleClock * External
External Sample Clock, Valid when Source is DISampleClockSource.External.

Detailed Description

Sample clock configuration class.

Member Data Documentation

◆ External

DIExternalSampleClock* JY5325CoreOO::DISampleClock::External

External Sample Clock, Valid when Source is DISampleClockSource.External.

◆ Source

DISampleClockSource JY5325CoreOO::DISampleClock::Source

Clock Source.

enum Internal/External

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOODITask.h


5325 C++ Programming Manual: JY5325CoreOO::DIExternalSampleClock Class Reference

  • DIExternalSampleClock
Public Attributes | List of all members
JY5325CoreOO::DIExternalSampleClock Class Reference

External Sample Clock Configuration Class. More...

#include <JY5325CoreOODITask.h>

Public Attributes

ClockTerminal Terminal
External Sample Clock Input Terminal.
double ExpectedRate
Expected External Sample Clock Rate.

Detailed Description

External Sample Clock Configuration Class.

Member Data Documentation

◆ ExpectedRate

double JY5325CoreOO::DIExternalSampleClock::ExpectedRate

Expected External Sample Clock Rate.

◆ Terminal

ClockTerminal JY5325CoreOO::DIExternalSampleClock::Terminal

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOODITask.h


5325 C++ Programming Manual: JY5325CoreOO::DISignalExport Class Reference

  • DISignalExport
Public Member Functions | List of all members
JY5325CoreOO::DISignalExport Class Reference

DI Signal Export Class. More...

#include <JY5325CoreOODITask.h>

Public Member Functions

void | Add (DISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (DISignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

DI Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY5325CoreOO::DISignalExport::Add | ( | DISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | CI Signal Source
destination | Export Desination

◆ Add() [2/2]

void JY5325CoreOO::DISignalExport::Add | ( | DISignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | CI Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JY5325CoreOO::DISignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5325CoreOO::DISignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOODITask.h


5325 C++ Programming Manual: JY5325CoreOO::DITrigger Class Reference

  • DITrigger
Public Attributes | List of all members
JY5325CoreOO::DITrigger Class Reference

Constructor to create an DITrigger task object. More...

#include <JY5325CoreOODITask.h>

Public Attributes

DITriggerType Type
DI trigger type.
DITriggerMode Mode
DI trigger mode.
DIDigitalTrigger * Digital
DI Digital Trigger.Valid when Type is DITriggerType.Digital.
uint32_t PreTriggerSamples
Pretrigger Samples, must be less than or equal to JY5325DITask.SamplesToAcquire.

Detailed Description

Constructor to create an DITrigger task object.

Used to build DI Trigger

Member Data Documentation

◆ Digital

DIDigitalTrigger* JY5325CoreOO::DITrigger::Digital

DI Digital Trigger.Valid when Type is DITriggerType.Digital.

◆ Mode

DITriggerMode JY5325CoreOO::DITrigger::Mode

DI trigger mode.

enum Start/Reference.

◆ PreTriggerSamples

uint32_t JY5325CoreOO::DITrigger::PreTriggerSamples

Pretrigger Samples, must be less than or equal to JY5325DITask.SamplesToAcquire.

Valid when Mode is DITriggerMode.Reference. Pretrigger samples, must be greater than 1. Valid when Type is DITriggerType.Digital.

◆ Type

DITriggerType JY5325CoreOO::DITrigger::Type

DI trigger type.

enum Digital/Immediate/Soft.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOODITask.h


5325 C++ Programming Manual: JY5325CoreOO::DIDigitalTrigger Class Reference

  • DIDigitalTrigger
Public Attributes | List of all members
JY5325CoreOO::DIDigitalTrigger Class Reference

DI Digital trigger . More...

#include <JY5325CoreOODITask.h>

Public Attributes

DIDigitalTriggerSource Source
DI Digital Trigger source.
DIDigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Detailed Description

DI Digital trigger .

Member Data Documentation

◆ Edge

DIDigitalTriggerEdge JY5325CoreOO::DIDigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

DIDigitalTriggerSource JY5325CoreOO::DIDigitalTrigger::Source

DI Digital Trigger source.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOODITask.h


5325 C++ Programming Manual: COO/5325/JY5325CoreOODOTask.h File Reference

  • File List
  • File Members
  • COO
  • 5325
Classes | Namespaces | Enumerations
JY5325CoreOODOTask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JY5325CoreOOCommon.h"
#include "JY5325CoreOODevice.h"

Classes

class | JY5325CoreOO::JY5325CoreOODOTask
class | JY5325CoreOO::DOChannel
DO Channel parameter class . More...
class | JY5325CoreOO::DOSampleClock
Sample clock configuration class. More...
class | JY5325CoreOO::DOExternalSampleClock
External Sample Clock Configuration Class. More...
class | JY5325CoreOO::DODigitalTrigger
DO Digital trigger. More...
class | JY5325CoreOO::DOTrigger
Constructor to create an DOTrigger task object. More...
class | JY5325CoreOO::DOSignalExport
DO Signal Export Class. More...

Namespaces

namespace JY5325CoreOO

Enumerations

enum class | JY5325CoreOO::DOSampleClockSource { JY5325CoreOO::Internal , JY5325CoreOO::External }
DO Sample Clock Source. More...
enum class | JY5325CoreOO::DOMode { JY5325CoreOO::Single = 3 , JY5325CoreOO::Finite = 0 , JY5325CoreOO::ContinuousWrapping = 1 , JY5325CoreOO::ContinuousNoWrapping = 2 }
DOMode. More...
enum class | JY5325CoreOO::DODigitalTriggerEdge { JY5325CoreOO::Rising , JY5325CoreOO::Falling }
DO Digital Trigger Edge. More...
enum class JY5325CoreOO::DODigitalTriggerSource {
JY5325CoreOO::PFI0 , JY5325CoreOO::PFI1 , JY5325CoreOO::PFI2 , JY5325CoreOO::PFI3 ,
JY5325CoreOO::PFI4 , JY5325CoreOO::PFI5 , JY5325CoreOO::PFI6 , JY5325CoreOO::PFI7 ,
JY5325CoreOO::PXI_Trig0 = 8 , JY5325CoreOO::PXI_Trig1 = 9 , JY5325CoreOO::PXI_Trig2 = 10 , JY5325CoreOO::PXI_Trig3 = 11 ,
JY5325CoreOO::PXI_Trig4 = 12 , JY5325CoreOO::PXI_Trig5 = 13 , JY5325CoreOO::PXI_Trig6 = 14 , JY5325CoreOO::PXI_Trig7 = 15 ,
JY5325CoreOO::AI_StartTrig = 16 , JY5325CoreOO::AI_ReferenceTrig = 17 , JY5325CoreOO::AO_StartTrig = 18 , JY5325CoreOO::DI_StartTrig = 19 ,
JY5325CoreOO::DI_ReferenceTrig = 20 , JY5325CoreOO::CIO_0_StartTrig = 22 , JY5325CoreOO::CIO_1_StartTrig = 23 , JY5325CoreOO::CO_0_Out = 24 ,
JY5325CoreOO::CO_1_Out = 25
}
DO Digital trigger source. More...
enum class | JY5325CoreOO::DOTriggerType { JY5325CoreOO::Immediate = 0 , JY5325CoreOO::Digital = 1 , JY5325CoreOO::Soft = 3 }
TriggerType Digital/Immediate/Soft. More...
enum class JY5325CoreOO::DOSignalExportSource {
JY5325CoreOO::StartTrig = 24 , JY5325CoreOO::SampleClock = 25 , JY5325CoreOO::Internal_Counter_100K = 34 , JY5325CoreOO::Internal_Counter_5M = 33 ,
JY5325CoreOO::Internal_Counter_100M = 32
}
SourceSignal. More...


5325 C++ Programming Manual: JY5325CoreOO::JY5325CoreOODOTask Class Reference

  • JY5325CoreOODOTask
Public Member Functions | Public Attributes | List of all members
JY5325CoreOO::JY5325CoreOODOTask Class Reference

#include <JY5325CoreOODOTask.h>

Public Member Functions

JY5325CoreOODOTask (int slotNum)
JY5325CoreOODOTask (std::string boardName)
~JY5325CoreOODOTask ()
void | AddChannel (int lineNum)
Add one line.
void | AddChannel (std::vector< int > linesNum)
Add mulitiple line.
void | RemoveChannel (int lineNum)
delete the specified line number
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Start ()
Start DO task .
void | Stop ()
Stop DO task .
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.
void | WriteSinglePoint (bool writeValues, int line)
Write one sample to the specified port in register.Available when Mode is DOMode.Single when the line is -1, write all enabled lines values.
void | WriteSinglePoint (std::vector< bool > &writeValues)
Write one sample for all line in register .
void | WriteData (unsigned char dataBuffer[], unsigned int samplesToUpdate, int timeOut)
Write the byte data for one line or multi-lines.

Public Attributes

std::list< DOChannel * > | Channels
List of DO channels,(5325 support 8 lines)
DOMode Mode
DO acquisition mode，support Single/ Finite/Continuous.
JY5325CoreOOProperty< JY5325CoreOODOTask, double, JY5325CoreOOPropertyType::READ_WRITE > | UpdateRate
Sample rate per channel.
int | SamplesToUpdate
Number of output samples to write per channel , Only valid when Mode is DOMode::Finite.
DOSampleClock * SampleClock
DO Sample Clock Configuration.
JY5325CoreOOProperty< JY5325CoreOODOTask, int, JY5325CoreOOPropertyType::READ_ONLY > | BufLenInSamples
Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.
JY5325CoreOOProperty< JY5325CoreOODOTask, uint64_t, JY5325CoreOOPropertyType::READ_ONLY > | AvaliableLenInSamples
Number of output samples per channel avaliable to write in DO buffuer.
JY5325CoreOOProperty< JY5325CoreOODOTask, uint64_t, JY5325CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
DOTrigger * Trigger
DO Trigger Configuration.
DOSignalExport * SignalExport
Export DO Signal.
JY5325CoreOODevice * Device
Device.

Constructor & Destructor Documentation

◆ JY5325CoreOODOTask() [1/2]

JY5325CoreOO::JY5325CoreOODOTask::JY5325CoreOODOTask ( int slotNum )

◆ JY5325CoreOODOTask() [2/2]

JY5325CoreOO::JY5325CoreOODOTask::JY5325CoreOODOTask ( std::string boardName )

◆ ~JY5325CoreOODOTask()

JY5325CoreOO::JY5325CoreOODOTask::~JY5325CoreOODOTask ( )

Member Function Documentation

◆ AddChannel() [1/2]

void JY5325CoreOO::JY5325CoreOODOTask::AddChannel ( int lineNum )

Add one line.

Parameters
lineNum line number

◆ AddChannel() [2/2]

void JY5325CoreOO::JY5325CoreOODOTask::AddChannel ( std::vector< int > linesNum )

Add mulitiple line.

Parameters
linesNum line number

◆ RemoveChannel()

void JY5325CoreOO::JY5325CoreOODOTask::RemoveChannel ( int lineNum )

delete the specified line number

Parameters
lineNum line number

◆ SendSoftwareTrigger()

void JY5325CoreOO::JY5325CoreOODOTask::SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5325CoreOO::JY5325CoreOODOTask::Start ( )

Start DO task .

◆ Stop()

void JY5325CoreOO::JY5325CoreOODOTask::Stop ( )

Stop DO task .

◆ WaitUntilDone()

bool JY5325CoreOO::JY5325CoreOODOTask::WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Available when Mode is DOMode.Finite

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteData()

void JY5325CoreOO::JY5325CoreOODOTask::WriteData | ( | unsigned char | dataBuffer[],
 |  | unsigned int | samplesToUpdate,
 |  | int | timeOut )

Write the byte data for one line or multi-lines.

There are 8 lines, from 0 to 7. Each bit from low to high represents one line.

Parameters
dataBuffer | Data buffer
samplesToUpdate | Number of samples per Line to be write
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteSinglePoint() [1/2]

void JY5325CoreOO::JY5325CoreOODOTask::WriteSinglePoint | ( | bool | writeValues,
 |  | int | line )

Write one sample to the specified port in register.Available when Mode is DOMode.Single when the line is -1, write all enabled lines values.

Parameters
writeValues | values write
port | Specified port numbers.

◆ WriteSinglePoint() [2/2]

void JY5325CoreOO::JY5325CoreOODOTask::WriteSinglePoint ( std::vector< bool > & writeValues )

Write one sample for all line in register .

Available when Mode is DIMode.Single

Parameters
readValues Values read. Buffer size = number of Line.

Member Data Documentation

◆ AvaliableLenInSamples

JY5325CoreOOProperty<JY5325CoreOODOTask, uint64_t, JY5325CoreOOPropertyType::READ_ONLY> JY5325CoreOO::JY5325CoreOODOTask::AvaliableLenInSamples

Number of output samples per channel avaliable to write in DO buffuer.

◆ BufLenInSamples

JY5325CoreOOProperty<JY5325CoreOODOTask, int, JY5325CoreOOPropertyType::READ_ONLY> JY5325CoreOO::JY5325CoreOODOTask::BufLenInSamples

Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.

◆ Channels

std::list<DOChannel*> JY5325CoreOO::JY5325CoreOODOTask::Channels

List of DO channels,(5325 support 8 lines)

◆ Device

JY5325CoreOODevice* JY5325CoreOO::JY5325CoreOODOTask::Device

Device.

◆ Mode

DOMode JY5325CoreOO::JY5325CoreOODOTask::Mode

DO acquisition mode，support Single/ Finite/Continuous.

◆ SampleClock

DOSampleClock* JY5325CoreOO::JY5325CoreOODOTask::SampleClock

DO Sample Clock Configuration.

◆ SamplesToUpdate

int JY5325CoreOO::JY5325CoreOODOTask::SamplesToUpdate

Number of output samples to write per channel , Only valid when Mode is DOMode::Finite.

◆ SignalExport

DOSignalExport* JY5325CoreOO::JY5325CoreOODOTask::SignalExport

Export DO Signal.

◆ TransferedSamples

JY5325CoreOOProperty<JY5325CoreOODOTask, uint64_t, JY5325CoreOOPropertyType::READ_ONLY> JY5325CoreOO::JY5325CoreOODOTask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT DIMode::Single.

◆ Trigger

DOTrigger* JY5325CoreOO::JY5325CoreOODOTask::Trigger

DO Trigger Configuration.

◆ UpdateRate

JY5325CoreOOProperty<JY5325CoreOODOTask, double, JY5325CoreOOPropertyType::READ_WRITE> JY5325CoreOO::JY5325CoreOODOTask::UpdateRate

Sample rate per channel.

Maximum sample rate is 10M The defalut sample rate = 10k You can read this property to obtain the sample rate that will actually take effect in the current configuration.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOODOTask.h


5325 C++ Programming Manual: JY5325CoreOO::DOChannel Class Reference

  • DOChannel
Public Attributes | List of all members
JY5325CoreOO::DOChannel Class Reference

DO Channel parameter class . More...

#include <JY5325CoreOODOTask.h>

Public Attributes

int LineNum
port number.

Detailed Description

DO Channel parameter class .

Member Data Documentation

◆ LineNum

int JY5325CoreOO::DOChannel::LineNum

port number.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOODOTask.h


5325 C++ Programming Manual: JY5325CoreOO::DOSampleClock Class Reference

  • DOSampleClock
Public Attributes | List of all members
JY5325CoreOO::DOSampleClock Class Reference

Sample clock configuration class. More...

#include <JY5325CoreOODOTask.h>

Public Attributes

DOSampleClockSource Source
Clock Source.
DOExternalSampleClock * External
External Sample Clock.Valid when Source is DOSampleClockSource.External.

Detailed Description

Sample clock configuration class.

Member Data Documentation

◆ External

DOExternalSampleClock* JY5325CoreOO::DOSampleClock::External

External Sample Clock.Valid when Source is DOSampleClockSource.External.

◆ Source

DOSampleClockSource JY5325CoreOO::DOSampleClock::Source

Clock Source.

enum Internal/External

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOODOTask.h


5325 C++ Programming Manual: JY5325CoreOO::DOExternalSampleClock Class Reference

  • DOExternalSampleClock
Public Attributes | List of all members
JY5325CoreOO::DOExternalSampleClock Class Reference

External Sample Clock Configuration Class. More...

#include <JY5325CoreOODOTask.h>

Public Attributes

ClockTerminal Terminal
External Sample Clock Input Terminal.
double ExpectedRate
Expected External Sample Clock Rate.

Detailed Description

External Sample Clock Configuration Class.

Member Data Documentation

◆ ExpectedRate

double JY5325CoreOO::DOExternalSampleClock::ExpectedRate

Expected External Sample Clock Rate.

◆ Terminal

ClockTerminal JY5325CoreOO::DOExternalSampleClock::Terminal

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOODOTask.h


5325 C++ Programming Manual: JY5325CoreOO::DODigitalTrigger Class Reference

  • DODigitalTrigger
Public Attributes | List of all members
JY5325CoreOO::DODigitalTrigger Class Reference

DO Digital trigger. More...

#include <JY5325CoreOODOTask.h>

Public Attributes

DODigitalTriggerSource Source
DO Digital Trigger source.
DODigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Detailed Description

DO Digital trigger.

Member Data Documentation

◆ Edge

DODigitalTriggerEdge JY5325CoreOO::DODigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

DODigitalTriggerSource JY5325CoreOO::DODigitalTrigger::Source

DO Digital Trigger source.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOODOTask.h


5325 C++ Programming Manual: JY5325CoreOO::DOTrigger Class Reference

  • DOTrigger
Public Attributes | List of all members
JY5325CoreOO::DOTrigger Class Reference

Constructor to create an DOTrigger task object. More...

#include <JY5325CoreOODOTask.h>

Public Attributes

DOTriggerType Type
DO trigger type.
DODigitalTrigger * Digital
DO Digital Trigger.Valid when Type is DOTriggerType.Digital.

Detailed Description

Constructor to create an DOTrigger task object.

Used to build DO Trigger

Member Data Documentation

◆ Digital

DODigitalTrigger* JY5325CoreOO::DOTrigger::Digital

DO Digital Trigger.Valid when Type is DOTriggerType.Digital.

◆ Type

DOTriggerType JY5325CoreOO::DOTrigger::Type

DO trigger type.

enum Digital/Immediate/Soft.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOODOTask.h


5325 C++ Programming Manual: JY5325CoreOO::DOSignalExport Class Reference

  • DOSignalExport
Public Member Functions | List of all members
JY5325CoreOO::DOSignalExport Class Reference

DO Signal Export Class. More...

#include <JY5325CoreOODOTask.h>

Public Member Functions

void | Add (DOSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (DOSignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

DO Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY5325CoreOO::DOSignalExport::Add | ( | DOSignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | CI Signal Source
destination | Export Desination

◆ Add() [2/2]

void JY5325CoreOO::DOSignalExport::Add | ( | DOSignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | CI Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JY5325CoreOO::DOSignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5325CoreOO::DOSignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOODOTask.h


5325 C++ Programming Manual: COO/5325/JY5325CoreOOLog.h File Reference

  • File List
  • File Members
  • COO
  • 5325
Classes | Namespaces | Enumerations
JY5325CoreOOLog.h File Reference
#include <queue>
#include <string>
#include <thread>
#include "JY5325CoreOOCommon.h"

Classes

class JY5325CoreOO::JY5325CoreOOLog

Namespaces

namespace JY5325CoreOO

Enumerations

enum class JY5325CoreOO::JY5325CoreOOLogLevel {
JY5325CoreOO::DEBUG_LOG_LEVEL , JY5325CoreOO::INFO_LOG_LEVEL , JY5325CoreOO::WARN_LOG_LEVEL , JY5325CoreOO::ERROR_LOG_LEVEL ,
JY5325CoreOO::FATAL_LOG_LEVEL
}


5325 C++ Programming Manual: JY5325CoreOO::JY5325CoreOOLog Class Reference

  • JY5325CoreOOLog
Static Public Member Functions | Static Public Attributes | List of all members
JY5325CoreOO::JY5325CoreOOLog Class Reference

#include <JY5325CoreOOLog.h>

Static Public Member Functions

static void | Print (const char *format,...)
static void | Print (JY5325CoreOOLogLevel logLevel, const char *format,...)
static void | Flush ()

Static Public Attributes

static JY5325CoreOOLogLevel | LogLevel
static JY5325CoreOOProperty< JY5325CoreOOLog, bool, JY5325CoreOOPropertyType::READ_WRITE > | EnableLog

Member Function Documentation

◆ Flush()

static void JY5325CoreOO::JY5325CoreOOLog::Flush ( )
static

◆ Print() [1/2]

static void JY5325CoreOO::JY5325CoreOOLog::Print | ( | const char * | format,
 |  |  | ... )
 static

◆ Print() [2/2]

static void JY5325CoreOO::JY5325CoreOOLog::Print | ( | JY5325CoreOOLogLevel | logLevel,
 |  | const char * | format,
 |  |  | ... )
 static

Member Data Documentation

◆ EnableLog

JY5325CoreOOProperty<JY5325CoreOOLog, bool, JY5325CoreOOPropertyType::READ_WRITE> JY5325CoreOO::JY5325CoreOOLog::EnableLog
static

◆ LogLevel

JY5325CoreOOLogLevel JY5325CoreOO::JY5325CoreOOLog::LogLevel
static
The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOLog.h


5325 C++ Programming Manual: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
▼N JY5325CoreOO |
C AIAnalogEdgeComparator |
C AIAnalogHysteresisComparator |
C AIAnalogTrigger |
C AIAnalogWindowComparator |
C AIChannel |
C AIDigitalTrigger |
C AIExternalSampleClock |
C AIRecord |
C AISampleClock |
C AISignalExport |
C AISync |
C AITrigger | Constructor to create an AITrigger task object
C AOChannel |
C AODigitalTrigger | AO Digital trigger
C AOSampleClock | External Sample Clock Configuration Class
C AOTrigger | Constructor to create an AOTrigger task object
C CIDigitalTrigger | CI Digital trigger
C CIExternalSampleClock | CI Implicit Sample Clock class
C CIExternalTimebase |
C CIImplicitSampleClock | CI Implicit Sample Clock class
C CIInternalSampleClock | CI Internal Sample Clock Configuration Class
C CISampleClock | CI Sample Clock class
C CISignalExport | CI Signal Export Class
C CITimebase | Timebase configuration class
C CITrigger | Constructor to create an CITrigger task object
C CODigitalTrigger | CO Digital trigger
C COExternalTimebase |
C COPulse | Pulse Parameter
C COSignalExport | CO Signal Export Class
C COTimebase | Timebase configuration class
C COTrigger | Constructor to create an COTrigger task object
C DIChannel | DI Channel parameter class
C DIDigitalTrigger | DI Digital trigger
C DIExternalSampleClock | External Sample Clock Configuration Class
C DISampleClock | Sample clock configuration class
C DISignalExport | DI Signal Export Class
C DITrigger | Constructor to create an DITrigger task object
C DOChannel | DO Channel parameter class
C DODigitalTrigger | DO Digital trigger
C DOExternalSampleClock | External Sample Clock Configuration Class
C DOSampleClock | Sample clock configuration class
C DOSignalExport | DO Signal Export Class
C DOTrigger | Constructor to create an DOTrigger task object
C EdgeCounting | Configure CI EdgeCounting
C EdgeCountingOutEvent | Edge counting output event configuration class
C ExternalReferenceClock |
C FrequencyMeas | Configure CI Measure
C JY5325CoreOOAITask | AITask类
C JY5325CoreOOAOTask |
C JY5325CoreOOCITask |
C JY5325CoreOOCOTask |
C JY5325CoreOODevice |
C JY5325CoreOODITask |
C JY5325CoreOODOTask |
C JY5325CoreOOLog |
C JY5325CoreOOProperty | 属性模板类
C JY5325CoreOOReferenceClock |
C JYDriverException |
C PauseTrigger | Pause trigger configuration class
C PeriodMeas | Configure CI Measure
C PFIFilter |
C PFISetting |
C PulseMeas | Configure CI Measure
C QuadEncoder | Configure CI Measure
C SemiPeriodMeas | Configure CI SemiPeriodMeas
C TwoEdgeSeparation | Configure CI Measure
C TwoPulseEncoder | Configure CI Measure
C AOMode | AIMode
C JY5325CoreOOAIMode | AIMode


5325 C++ Programming Manual: AOMode Class Reference

AOMode Class Reference

AIMode. More...

#include <JY5325CoreOOAOTask.h>

Detailed Description

AIMode.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOAOTask.h


5325 C++ Programming Manual: Member List

  • AIAnalogEdgeComparator
JY5325CoreOO::AIAnalogEdgeComparator Member List

This is the complete list of members for JY5325CoreOO::AIAnalogEdgeComparator, including all inherited members.

Slope | JY5325CoreOO::AIAnalogEdgeComparator
Threshold | JY5325CoreOO::AIAnalogEdgeComparator


5325 C++ Programming Manual: Member List

  • AIAnalogHysteresisComparator
JY5325CoreOO::AIAnalogHysteresisComparator Member List

This is the complete list of members for JY5325CoreOO::AIAnalogHysteresisComparator, including all inherited members.

HighThreshold | JY5325CoreOO::AIAnalogHysteresisComparator
LowThreshold | JY5325CoreOO::AIAnalogHysteresisComparator
Slope | JY5325CoreOO::AIAnalogHysteresisComparator


5325 C++ Programming Manual: Member List

  • AIAnalogTrigger
JY5325CoreOO::AIAnalogTrigger Member List

This is the complete list of members for JY5325CoreOO::AIAnalogTrigger, including all inherited members.

Comparator | JY5325CoreOO::AIAnalogTrigger
Edge | JY5325CoreOO::AIAnalogTrigger
Hysteresis | JY5325CoreOO::AIAnalogTrigger
Source | JY5325CoreOO::AIAnalogTrigger
Window | JY5325CoreOO::AIAnalogTrigger


5325 C++ Programming Manual: Member List

  • AIAnalogWindowComparator
JY5325CoreOO::AIAnalogWindowComparator Member List

This is the complete list of members for JY5325CoreOO::AIAnalogWindowComparator, including all inherited members.

Condition | JY5325CoreOO::AIAnalogWindowComparator
HighThreshold | JY5325CoreOO::AIAnalogWindowComparator
LowThreshold | JY5325CoreOO::AIAnalogWindowComparator


5325 C++ Programming Manual: Member List

  • AIChannel
JY5325CoreOO::AIChannel Member List

This is the complete list of members for JY5325CoreOO::AIChannel, including all inherited members.

AIChannel(int channelId, double rangeLow, double rangeHigh) | JY5325CoreOO::AIChannel | inline
ChannelID | JY5325CoreOO::AIChannel |
RangeHigh | JY5325CoreOO::AIChannel |
RangeLow | JY5325CoreOO::AIChannel |


5325 C++ Programming Manual: Member List

  • AIDigitalTrigger
JY5325CoreOO::AIDigitalTrigger Member List

This is the complete list of members for JY5325CoreOO::AIDigitalTrigger, including all inherited members.

Edge | JY5325CoreOO::AIDigitalTrigger
Source | JY5325CoreOO::AIDigitalTrigger


5325 C++ Programming Manual: Member List

  • AIExternalSampleClock
JY5325CoreOO::AIExternalSampleClock Member List

This is the complete list of members for JY5325CoreOO::AIExternalSampleClock, including all inherited members.

ExpectedRate | JY5325CoreOO::AIExternalSampleClock
Terminal | JY5325CoreOO::AIExternalSampleClock


5325 C++ Programming Manual: Member List

  • AIRecord
JY5325CoreOO::AIRecord Member List

This is the complete list of members for JY5325CoreOO::AIRecord, including all inherited members.

File_Format | JY5325CoreOO::AIRecord
FilePath | JY5325CoreOO::AIRecord
Length | JY5325CoreOO::AIRecord
Mode | JY5325CoreOO::AIRecord


5325 C++ Programming Manual: Member List

  • AISampleClock
JY5325CoreOO::AISampleClock Member List

This is the complete list of members for JY5325CoreOO::AISampleClock, including all inherited members.

Source JY5325CoreOO::AISampleClock


5325 C++ Programming Manual: Member List

  • AISignalExport
JY5325CoreOO::AISignalExport Member List

This is the complete list of members for JY5325CoreOO::AISignalExport, including all inherited members.

Add(AISignalExportSource source, SignalExportDestination destination) | JY5325CoreOO::AISignalExport
Add(AISignalExportSource source, std::list< SignalExportDestination > destinations) | JY5325CoreOO::AISignalExport
Clear(SignalExportDestination destination) | JY5325CoreOO::AISignalExport
ClearAll() | JY5325CoreOO::AISignalExport


5325 C++ Programming Manual: Member List

  • AISync
JY5325CoreOO::AISync Member List

This is the complete list of members for JY5325CoreOO::AISync, including all inherited members.

Topology | JY5325CoreOO::AISync
TriggerRouting | JY5325CoreOO::AISync


5325 C++ Programming Manual: Member List

  • AITrigger
JY5325CoreOO::AITrigger Member List

This is the complete list of members for JY5325CoreOO::AITrigger, including all inherited members.

Analog | JY5325CoreOO::AITrigger
Digital | JY5325CoreOO::AITrigger
Mode | JY5325CoreOO::AITrigger
PreTriggerSamples | JY5325CoreOO::AITrigger
ReTriggerCount | JY5325CoreOO::AITrigger
Type | JY5325CoreOO::AITrigger


5325 C++ Programming Manual: Member List

  • AOChannel
JY5325CoreOO::AOChannel Member List

This is the complete list of members for JY5325CoreOO::AOChannel, including all inherited members.

AOChannel(int channelId, double rangeLow, double rangeHigh) | JY5325CoreOO::AOChannel | inline
ChannelID | JY5325CoreOO::AOChannel |
RangeHigh | JY5325CoreOO::AOChannel |
RangeLow | JY5325CoreOO::AOChannel |


5325 C++ Programming Manual: Member List

  • AODigitalTrigger
JY5325CoreOO::AODigitalTrigger Member List

This is the complete list of members for JY5325CoreOO::AODigitalTrigger, including all inherited members.

Edge | JY5325CoreOO::AODigitalTrigger
Source | JY5325CoreOO::AODigitalTrigger


5325 C++ Programming Manual: Member List

  • AOSampleClock
JY5325CoreOO::AOSampleClock Member List

This is the complete list of members for JY5325CoreOO::AOSampleClock, including all inherited members.

JY5325CoreOOAOTask class | JY5325CoreOO::AOSampleClock | friend
Source | JY5325CoreOO::AOSampleClock |


5325 C++ Programming Manual: Member List

  • AOTrigger
JY5325CoreOO::AOTrigger Member List

This is the complete list of members for JY5325CoreOO::AOTrigger, including all inherited members.

Digital | JY5325CoreOO::AOTrigger
Type | JY5325CoreOO::AOTrigger


5325 C++ Programming Manual: Member List

  • CIDigitalTrigger
JY5325CoreOO::CIDigitalTrigger Member List

This is the complete list of members for JY5325CoreOO::CIDigitalTrigger, including all inherited members.

Edge | JY5325CoreOO::CIDigitalTrigger
Source | JY5325CoreOO::CIDigitalTrigger


5325 C++ Programming Manual: Member List

  • CIExternalSampleClock
JY5325CoreOO::CIExternalSampleClock Member List

This is the complete list of members for JY5325CoreOO::CIExternalSampleClock, including all inherited members.

ExpectedRate | JY5325CoreOO::CIExternalSampleClock
IgnoreFirstSampleClock | JY5325CoreOO::CIExternalSampleClock
Terminal | JY5325CoreOO::CIExternalSampleClock


5325 C++ Programming Manual: Member List

  • CIExternalTimebase
JY5325CoreOO::CIExternalTimebase Member List

This is the complete list of members for JY5325CoreOO::CIExternalTimebase, including all inherited members.

CITimebase class | JY5325CoreOO::CIExternalTimebase | friend
Frequency | JY5325CoreOO::CIExternalTimebase |
Terminal | JY5325CoreOO::CIExternalTimebase |


5325 C++ Programming Manual: Member List

  • CIImplicitSampleClock
JY5325CoreOO::CIImplicitSampleClock Member List

This is the complete list of members for JY5325CoreOO::CIImplicitSampleClock, including all inherited members.

CISampleClock class | JY5325CoreOO::CIImplicitSampleClock | friend
ExpectedRate | JY5325CoreOO::CIImplicitSampleClock |


5325 C++ Programming Manual: Member List

  • CIInternalSampleClock
JY5325CoreOO::CIInternalSampleClock Member List

This is the complete list of members for JY5325CoreOO::CIInternalSampleClock, including all inherited members.

IgnoreFirstSampleClock | JY5325CoreOO::CIInternalSampleClock
Rate | JY5325CoreOO::CIInternalSampleClock


5325 C++ Programming Manual: Member List

  • CISampleClock
JY5325CoreOO::CISampleClock Member List

This is the complete list of members for JY5325CoreOO::CISampleClock, including all inherited members.

External | JY5325CoreOO::CISampleClock
Implicit | JY5325CoreOO::CISampleClock
Internal | JY5325CoreOO::CISampleClock
Source | JY5325CoreOO::CISampleClock


5325 C++ Programming Manual: Member List

  • CISignalExport
JY5325CoreOO::CISignalExport Member List

This is the complete list of members for JY5325CoreOO::CISignalExport, including all inherited members.

Add(CISignalExportSource source, SignalExportDestination destination) | JY5325CoreOO::CISignalExport
Add(CISignalExportSource source, std::list< SignalExportDestination > destinations) | JY5325CoreOO::CISignalExport
Clear(SignalExportDestination destination) | JY5325CoreOO::CISignalExport
ClearAll() | JY5325CoreOO::CISignalExport


5325 C++ Programming Manual: Member List

  • CITimebase
JY5325CoreOO::CITimebase Member List

This is the complete list of members for JY5325CoreOO::CITimebase, including all inherited members.

ActualFreq | JY5325CoreOO::CITimebase
External | JY5325CoreOO::CITimebase
Source | JY5325CoreOO::CITimebase


5325 C++ Programming Manual: Member List

  • CITrigger
JY5325CoreOO::CITrigger Member List

This is the complete list of members for JY5325CoreOO::CITrigger, including all inherited members.

Digital | JY5325CoreOO::CITrigger
Type | JY5325CoreOO::CITrigger


5325 C++ Programming Manual: Member List

  • CODigitalTrigger
JY5325CoreOO::CODigitalTrigger Member List

This is the complete list of members for JY5325CoreOO::CODigitalTrigger, including all inherited members.

Edge | JY5325CoreOO::CODigitalTrigger
Source | JY5325CoreOO::CODigitalTrigger


5325 C++ Programming Manual: Member List

  • COExternalTimebase
JY5325CoreOO::COExternalTimebase Member List

This is the complete list of members for JY5325CoreOO::COExternalTimebase, including all inherited members.

COTimebase class | JY5325CoreOO::COExternalTimebase | friend
Frequency | JY5325CoreOO::COExternalTimebase |
Terminal | JY5325CoreOO::COExternalTimebase |


5325 C++ Programming Manual: Member List

  • COPulse
JY5325CoreOO::COPulse Member List

This is the complete list of members for JY5325CoreOO::COPulse, including all inherited members.

COPulse(COPulseType type, double param1, double param2, int count) JY5325CoreOO::COPulse


5325 C++ Programming Manual: Member List

  • COSignalExport
JY5325CoreOO::COSignalExport Member List

This is the complete list of members for JY5325CoreOO::COSignalExport, including all inherited members.

Add(COSignalExportSource source, SignalExportDestination destination) | JY5325CoreOO::COSignalExport
Add(COSignalExportSource source, std::list< SignalExportDestination > destinations) | JY5325CoreOO::COSignalExport
Clear(SignalExportDestination destination) | JY5325CoreOO::COSignalExport
ClearAll() | JY5325CoreOO::COSignalExport


5325 C++ Programming Manual: Member List

  • COTimebase
JY5325CoreOO::COTimebase Member List

This is the complete list of members for JY5325CoreOO::COTimebase, including all inherited members.

ActualFreq | JY5325CoreOO::COTimebase
External | JY5325CoreOO::COTimebase
Source | JY5325CoreOO::COTimebase


5325 C++ Programming Manual: Member List

  • COTrigger
JY5325CoreOO::COTrigger Member List

This is the complete list of members for JY5325CoreOO::COTrigger, including all inherited members.

Digital | JY5325CoreOO::COTrigger
Type | JY5325CoreOO::COTrigger


5325 C++ Programming Manual: Member List

  • DIChannel
JY5325CoreOO::DIChannel Member List

This is the complete list of members for JY5325CoreOO::DIChannel, including all inherited members.

LineNum JY5325CoreOO::DIChannel


5325 C++ Programming Manual: Member List

  • DIDigitalTrigger
JY5325CoreOO::DIDigitalTrigger Member List

This is the complete list of members for JY5325CoreOO::DIDigitalTrigger, including all inherited members.

Edge | JY5325CoreOO::DIDigitalTrigger
Source | JY5325CoreOO::DIDigitalTrigger


5325 C++ Programming Manual: Member List

  • DIExternalSampleClock
JY5325CoreOO::DIExternalSampleClock Member List

This is the complete list of members for JY5325CoreOO::DIExternalSampleClock, including all inherited members.

ExpectedRate | JY5325CoreOO::DIExternalSampleClock
Terminal | JY5325CoreOO::DIExternalSampleClock


5325 C++ Programming Manual: Member List

  • DISampleClock
JY5325CoreOO::DISampleClock Member List

This is the complete list of members for JY5325CoreOO::DISampleClock, including all inherited members.

External | JY5325CoreOO::DISampleClock
Source | JY5325CoreOO::DISampleClock


5325 C++ Programming Manual: Member List

  • DISignalExport
JY5325CoreOO::DISignalExport Member List

This is the complete list of members for JY5325CoreOO::DISignalExport, including all inherited members.

Add(DISignalExportSource source, SignalExportDestination destination) | JY5325CoreOO::DISignalExport
Add(DISignalExportSource source, std::list< SignalExportDestination > destinations) | JY5325CoreOO::DISignalExport
Clear(SignalExportDestination destination) | JY5325CoreOO::DISignalExport
ClearAll() | JY5325CoreOO::DISignalExport


5325 C++ Programming Manual: Member List

  • DITrigger
JY5325CoreOO::DITrigger Member List

This is the complete list of members for JY5325CoreOO::DITrigger, including all inherited members.

Digital | JY5325CoreOO::DITrigger
Mode | JY5325CoreOO::DITrigger
PreTriggerSamples | JY5325CoreOO::DITrigger
Type | JY5325CoreOO::DITrigger


5325 C++ Programming Manual: Member List

  • DOChannel
JY5325CoreOO::DOChannel Member List

This is the complete list of members for JY5325CoreOO::DOChannel, including all inherited members.

LineNum JY5325CoreOO::DOChannel


5325 C++ Programming Manual: Member List

  • DODigitalTrigger
JY5325CoreOO::DODigitalTrigger Member List

This is the complete list of members for JY5325CoreOO::DODigitalTrigger, including all inherited members.

Edge | JY5325CoreOO::DODigitalTrigger
Source | JY5325CoreOO::DODigitalTrigger


5325 C++ Programming Manual: Member List

  • DOExternalSampleClock
JY5325CoreOO::DOExternalSampleClock Member List

This is the complete list of members for JY5325CoreOO::DOExternalSampleClock, including all inherited members.

ExpectedRate | JY5325CoreOO::DOExternalSampleClock
Terminal | JY5325CoreOO::DOExternalSampleClock


5325 C++ Programming Manual: Member List

  • DOSampleClock
JY5325CoreOO::DOSampleClock Member List

This is the complete list of members for JY5325CoreOO::DOSampleClock, including all inherited members.

External | JY5325CoreOO::DOSampleClock
Source | JY5325CoreOO::DOSampleClock


5325 C++ Programming Manual: Member List

  • DOSignalExport
JY5325CoreOO::DOSignalExport Member List

This is the complete list of members for JY5325CoreOO::DOSignalExport, including all inherited members.

Add(DOSignalExportSource source, SignalExportDestination destination) | JY5325CoreOO::DOSignalExport
Add(DOSignalExportSource source, std::list< SignalExportDestination > destinations) | JY5325CoreOO::DOSignalExport
Clear(SignalExportDestination destination) | JY5325CoreOO::DOSignalExport
ClearAll() | JY5325CoreOO::DOSignalExport


5325 C++ Programming Manual: Member List

  • DOTrigger
JY5325CoreOO::DOTrigger Member List

This is the complete list of members for JY5325CoreOO::DOTrigger, including all inherited members.

Digital | JY5325CoreOO::DOTrigger
Type | JY5325CoreOO::DOTrigger


5325 C++ Programming Manual: Member List

  • EdgeCounting
JY5325CoreOO::EdgeCounting Member List

This is the complete list of members for JY5325CoreOO::EdgeCounting, including all inherited members.

ActiveEdge | JY5325CoreOO::EdgeCounting
Direction | JY5325CoreOO::EdgeCounting
DirTerminal | JY5325CoreOO::EdgeCounting
InitialCount | JY5325CoreOO::EdgeCounting
Input_Terminal | JY5325CoreOO::EdgeCounting
OutEvent | JY5325CoreOO::EdgeCounting
Pause | JY5325CoreOO::EdgeCounting


5325 C++ Programming Manual: Member List

  • EdgeCountingOutEvent
JY5325CoreOO::EdgeCountingOutEvent Member List

This is the complete list of members for JY5325CoreOO::EdgeCountingOutEvent, including all inherited members.

IdleState | JY5325CoreOO::EdgeCountingOutEvent
Terminal | JY5325CoreOO::EdgeCountingOutEvent
Threshold | JY5325CoreOO::EdgeCountingOutEvent


5325 C++ Programming Manual: Member List

  • ExternalReferenceClock
JY5325CoreOO::ExternalReferenceClock Member List

This is the complete list of members for JY5325CoreOO::ExternalReferenceClock, including all inherited members.

Terminal JY5325CoreOO::ExternalReferenceClock


5325 C++ Programming Manual: Member List

  • FrequencyMeas
JY5325CoreOO::FrequencyMeas Member List

This is the complete list of members for JY5325CoreOO::FrequencyMeas, including all inherited members.

Input_Terminal | JY5325CoreOO::FrequencyMeas
Timebase | JY5325CoreOO::FrequencyMeas


5325 C++ Programming Manual: Member List

  • JY5325CoreOOAITask
JY5325CoreOO::JY5325CoreOOAITask Member List

This is the complete list of members for JY5325CoreOO::JY5325CoreOOAITask, including all inherited members.

AddChannel(int chnId, double rangeLow=-10, double rangeHigh=10) | JY5325CoreOO::JY5325CoreOOAITask |
AddChannel(std::vector< int > chnsId, double rangeLow=-10, double rangeHigh=10) | JY5325CoreOO::JY5325CoreOOAITask |
AddChannel(std::vector< int > chnsId, std::vector< double > rangeLow, std::vector< double > rangeHigh) | JY5325CoreOO::JY5325CoreOOAITask |
Advanced | JY5325CoreOO::JY5325CoreOOAITask |
AvailableSamples | JY5325CoreOO::JY5325CoreOOAITask |
BufLenInSamples | JY5325CoreOO::JY5325CoreOOAITask |
Channels | JY5325CoreOO::JY5325CoreOOAITask |
Device | JY5325CoreOO::JY5325CoreOOAITask |
DisableDigitalTriggerDelay | JY5325CoreOO::JY5325CoreOOAITask |
GetRecordPreviewData(double *buf, int samplesPerChannel, int timeout) | JY5325CoreOO::JY5325CoreOOAITask |
GetRecordStatus(double &recordedLength, bool &recordDone) | JY5325CoreOO::JY5325CoreOOAITask |
JY5325CoreOOAITask(int slotNum) | JY5325CoreOO::JY5325CoreOOAITask |
JY5325CoreOOAITask(std::string boardName) | JY5325CoreOO::JY5325CoreOOAITask |
Mode | JY5325CoreOO::JY5325CoreOOAITask |
ReadData(double *pBuf, int samplesPerChannel, int timeout=-1) | JY5325CoreOO::JY5325CoreOOAITask |
ReadRawData(short *pBuf, int samplesPerChannel, int timeout=-1) | JY5325CoreOO::JY5325CoreOOAITask |
Record | JY5325CoreOO::JY5325CoreOOAITask |
RemoveChannel(int chnId) | JY5325CoreOO::JY5325CoreOOAITask |
SampleClock | JY5325CoreOO::JY5325CoreOOAITask |
SampleRate | JY5325CoreOO::JY5325CoreOOAITask |
SamplesToAcquire | JY5325CoreOO::JY5325CoreOOAITask |
SendSoftwareTrigger() | JY5325CoreOO::JY5325CoreOOAITask |
SignalExport | JY5325CoreOO::JY5325CoreOOAITask |
Start() | JY5325CoreOO::JY5325CoreOOAITask |
Stop() | JY5325CoreOO::JY5325CoreOOAITask |
Sync | JY5325CoreOO::JY5325CoreOOAITask |
TransferedSamples | JY5325CoreOO::JY5325CoreOOAITask |
Trigger | JY5325CoreOO::JY5325CoreOOAITask |
WaitUntilDone(int timeout=-1) | JY5325CoreOO::JY5325CoreOOAITask | inline
~JY5325CoreOOAITask() | JY5325CoreOO::JY5325CoreOOAITask |


5325 C++ Programming Manual: Member List

  • JY5325CoreOOAOTask
JY5325CoreOO::JY5325CoreOOAOTask Member List

This is the complete list of members for JY5325CoreOO::JY5325CoreOOAOTask, including all inherited members.

AddChannel(int chnId, double rangeLow=-10, double rangeHigh=10) | JY5325CoreOO::JY5325CoreOOAOTask
AddChannel(std::vector< int > chnsId, double rangeLow=-10, double rangeHigh=10) | JY5325CoreOO::JY5325CoreOOAOTask
AddChannel(std::vector< int > chnsId, std::vector< double > rangeLow, std::vector< double > rangeHigh) | JY5325CoreOO::JY5325CoreOOAOTask
AvaliableLenInSamples | JY5325CoreOO::JY5325CoreOOAOTask
BufLenInSamples | JY5325CoreOO::JY5325CoreOOAOTask
Channels | JY5325CoreOO::JY5325CoreOOAOTask
CompleteState | JY5325CoreOO::JY5325CoreOOAOTask
Device | JY5325CoreOO::JY5325CoreOOAOTask
DisableCalibration | JY5325CoreOO::JY5325CoreOOAOTask
JY5325CoreOOAOTask(int slotNum) | JY5325CoreOO::JY5325CoreOOAOTask
JY5325CoreOOAOTask(std::string boardName) | JY5325CoreOO::JY5325CoreOOAOTask
Mode | JY5325CoreOO::JY5325CoreOOAOTask
RemoveChannel(int chnId) | JY5325CoreOO::JY5325CoreOOAOTask
SampleClock | JY5325CoreOO::JY5325CoreOOAOTask
SamplesToUpdate | JY5325CoreOO::JY5325CoreOOAOTask
SendSoftwareTrigger() | JY5325CoreOO::JY5325CoreOOAOTask
SignalExport | JY5325CoreOO::JY5325CoreOOAOTask
Start() | JY5325CoreOO::JY5325CoreOOAOTask
Stop() | JY5325CoreOO::JY5325CoreOOAOTask
TransferedSamples | JY5325CoreOO::JY5325CoreOOAOTask
Trigger | JY5325CoreOO::JY5325CoreOOAOTask
UpdateRate | JY5325CoreOO::JY5325CoreOOAOTask
WaitUntilDone(int timeout=-1) | JY5325CoreOO::JY5325CoreOOAOTask
WriteData(double *pBuf, int samplesPerChannel, int timeout=10000) | JY5325CoreOO::JY5325CoreOOAOTask
WriteRawData(int16_t *pBuf, int samplesPerChannel, int timeout=10000) | JY5325CoreOO::JY5325CoreOOAOTask
WriteRawSinglePoint(std::vector< int16_t > writeValues) | JY5325CoreOO::JY5325CoreOOAOTask
WriteRawSinglePoint(int16_t writeValue, int channel) | JY5325CoreOO::JY5325CoreOOAOTask
WriteSinglePoint(std::vector< double > writeValues) | JY5325CoreOO::JY5325CoreOOAOTask
WriteSinglePoint(double writeValue, int channel) | JY5325CoreOO::JY5325CoreOOAOTask
~JY5325CoreOOAOTask() | JY5325CoreOO::JY5325CoreOOAOTask


5325 C++ Programming Manual: Member List

  • JY5325CoreOOCITask
JY5325CoreOO::JY5325CoreOOCITask Member List

This is the complete list of members for JY5325CoreOO::JY5325CoreOOCITask, including all inherited members.

AvailableSamples | JY5325CoreOO::JY5325CoreOOCITask
Device | JY5325CoreOO::JY5325CoreOOCITask
EdgeCounting | JY5325CoreOO::JY5325CoreOOCITask
FrequencyMeas | JY5325CoreOO::JY5325CoreOOCITask
JY5325CoreOOCITask(int slotNum, int channel) | JY5325CoreOO::JY5325CoreOOCITask
JY5325CoreOOCITask(std::string boardName, int channel) | JY5325CoreOO::JY5325CoreOOCITask
Mode | JY5325CoreOO::JY5325CoreOOCITask
PeriodMeas | JY5325CoreOO::JY5325CoreOOCITask
PulseMeas | JY5325CoreOO::JY5325CoreOOCITask
QuadEncoder | JY5325CoreOO::JY5325CoreOOCITask
ReadData(uint32_t *pBufCount, int samplesToAcquire, int timeout=10000) | JY5325CoreOO::JY5325CoreOOCITask
ReadData(double *pBufMeasurement, int samplesToAcquire, int timeout=10000) | JY5325CoreOO::JY5325CoreOOCITask
ReadData(double *pBufMeasurement1, double *pBufMeasurement2, int samplesToAcquire, int timeout=10000) | JY5325CoreOO::JY5325CoreOOCITask
ReadSinglePoint(uint32_t &count) | JY5325CoreOO::JY5325CoreOOCITask
ReadSinglePoint(double &measurement, int timeout=10000) | JY5325CoreOO::JY5325CoreOOCITask
ReadSinglePoint(double &measurement1, double &measurement2, int timeout=10000) | JY5325CoreOO::JY5325CoreOOCITask
SampleClock | JY5325CoreOO::JY5325CoreOOCITask
SamplesToAcquire | JY5325CoreOO::JY5325CoreOOCITask
SemiPeriodMeas | JY5325CoreOO::JY5325CoreOOCITask
SendSoftwareTrigger() | JY5325CoreOO::JY5325CoreOOCITask
SignalExport | JY5325CoreOO::JY5325CoreOOCITask
Start() | JY5325CoreOO::JY5325CoreOOCITask
Stop() | JY5325CoreOO::JY5325CoreOOCITask
timeBase | JY5325CoreOO::JY5325CoreOOCITask
TransferedSamples | JY5325CoreOO::JY5325CoreOOCITask
Trigger | JY5325CoreOO::JY5325CoreOOCITask
TwoEdgeSeparation | JY5325CoreOO::JY5325CoreOOCITask
TwoPulseEncoder | JY5325CoreOO::JY5325CoreOOCITask
Type | JY5325CoreOO::JY5325CoreOOCITask
~JY5325CoreOOCITask() | JY5325CoreOO::JY5325CoreOOCITask


5325 C++ Programming Manual: Member List

  • JY5325CoreOOCOTask
JY5325CoreOO::JY5325CoreOOCOTask Member List

This is the complete list of members for JY5325CoreOO::JY5325CoreOOCOTask, including all inherited members.

AvailableSamples | JY5325CoreOO::JY5325CoreOOCOTask
BufLenInSamples | JY5325CoreOO::JY5325CoreOOCOTask
Device | JY5325CoreOO::JY5325CoreOOCOTask
IdleState | JY5325CoreOO::JY5325CoreOOCOTask
InitialDelay | JY5325CoreOO::JY5325CoreOOCOTask
JY5325CoreOOCOTask(int slotNum, int channel) | JY5325CoreOO::JY5325CoreOOCOTask
JY5325CoreOOCOTask(std::string boardName, int channel) | JY5325CoreOO::JY5325CoreOOCOTask
Mode | JY5325CoreOO::JY5325CoreOOCOTask
OutputTerminal | JY5325CoreOO::JY5325CoreOOCOTask
Pause | JY5325CoreOO::JY5325CoreOOCOTask
SamplesToUpdate | JY5325CoreOO::JY5325CoreOOCOTask
SendSoftwareTrigger() | JY5325CoreOO::JY5325CoreOOCOTask
SignalExport | JY5325CoreOO::JY5325CoreOOCOTask
Start() | JY5325CoreOO::JY5325CoreOOCOTask
Stop() | JY5325CoreOO::JY5325CoreOOCOTask
TimeBase | JY5325CoreOO::JY5325CoreOOCOTask
TransferedPulses | JY5325CoreOO::JY5325CoreOOCOTask
TransferedSamples | JY5325CoreOO::JY5325CoreOOCOTask
Trigger | JY5325CoreOO::JY5325CoreOOCOTask
WaitUntilDone(int timeout=-1) | JY5325CoreOO::JY5325CoreOOCOTask
WriteData(COPulse *pulsesGroup[], int samplesToWrite, int timeout=10000) | JY5325CoreOO::JY5325CoreOOCOTask
WriteSinglePoint(COPulse &pulse) | JY5325CoreOO::JY5325CoreOOCOTask
~JY5325CoreOOCOTask() | JY5325CoreOO::JY5325CoreOOCOTask


5325 C++ Programming Manual: Member List

  • JY5325CoreOODITask
JY5325CoreOO::JY5325CoreOODITask Member List

This is the complete list of members for JY5325CoreOO::JY5325CoreOODITask, including all inherited members.

AddChannel(int lineNum) | JY5325CoreOO::JY5325CoreOODITask
AddChannel(std::vector< int > linesNum) | JY5325CoreOO::JY5325CoreOODITask
AvailableSamples | JY5325CoreOO::JY5325CoreOODITask
BufLenInSamples | JY5325CoreOO::JY5325CoreOODITask
Channels | JY5325CoreOO::JY5325CoreOODITask
Device | JY5325CoreOO::JY5325CoreOODITask
JY5325CoreOODITask(int slotNum) | JY5325CoreOO::JY5325CoreOODITask
JY5325CoreOODITask(std::string boardName) | JY5325CoreOO::JY5325CoreOODITask
Mode | JY5325CoreOO::JY5325CoreOODITask
ReadData(unsigned char dataBuffer[], uint32_t samplesToAcquire, int timeOut=10000) | JY5325CoreOO::JY5325CoreOODITask
ReadSinglePoint(bool *readValues, int line) | JY5325CoreOO::JY5325CoreOODITask
ReadSinglePoint(std::vector< bool > &readValues) | JY5325CoreOO::JY5325CoreOODITask
ReadSinglePoint(bool readValues[]) | JY5325CoreOO::JY5325CoreOODITask
RemoveChannel(int lineNum) | JY5325CoreOO::JY5325CoreOODITask
SampleClock | JY5325CoreOO::JY5325CoreOODITask
SampleRate | JY5325CoreOO::JY5325CoreOODITask
SamplesToAcquire | JY5325CoreOO::JY5325CoreOODITask
SendSoftwareTrigger() | JY5325CoreOO::JY5325CoreOODITask
SignalExport | JY5325CoreOO::JY5325CoreOODITask
Start() | JY5325CoreOO::JY5325CoreOODITask
Stop() | JY5325CoreOO::JY5325CoreOODITask
TransferedSamples | JY5325CoreOO::JY5325CoreOODITask
Trigger | JY5325CoreOO::JY5325CoreOODITask
~JY5325CoreOODITask() | JY5325CoreOO::JY5325CoreOODITask


5325 C++ Programming Manual: Member List

  • JY5325CoreOODOTask
JY5325CoreOO::JY5325CoreOODOTask Member List

This is the complete list of members for JY5325CoreOO::JY5325CoreOODOTask, including all inherited members.

AddChannel(int lineNum) | JY5325CoreOO::JY5325CoreOODOTask
AddChannel(std::vector< int > linesNum) | JY5325CoreOO::JY5325CoreOODOTask
AvaliableLenInSamples | JY5325CoreOO::JY5325CoreOODOTask
BufLenInSamples | JY5325CoreOO::JY5325CoreOODOTask
Channels | JY5325CoreOO::JY5325CoreOODOTask
Device | JY5325CoreOO::JY5325CoreOODOTask
JY5325CoreOODOTask(int slotNum) | JY5325CoreOO::JY5325CoreOODOTask
JY5325CoreOODOTask(std::string boardName) | JY5325CoreOO::JY5325CoreOODOTask
Mode | JY5325CoreOO::JY5325CoreOODOTask
RemoveChannel(int lineNum) | JY5325CoreOO::JY5325CoreOODOTask
SampleClock | JY5325CoreOO::JY5325CoreOODOTask
SamplesToUpdate | JY5325CoreOO::JY5325CoreOODOTask
SendSoftwareTrigger() | JY5325CoreOO::JY5325CoreOODOTask
SignalExport | JY5325CoreOO::JY5325CoreOODOTask
Start() | JY5325CoreOO::JY5325CoreOODOTask
Stop() | JY5325CoreOO::JY5325CoreOODOTask
TransferedSamples | JY5325CoreOO::JY5325CoreOODOTask
Trigger | JY5325CoreOO::JY5325CoreOODOTask
UpdateRate | JY5325CoreOO::JY5325CoreOODOTask
WaitUntilDone(int timeout=-1) | JY5325CoreOO::JY5325CoreOODOTask
WriteData(unsigned char dataBuffer[], unsigned int samplesToUpdate, int timeOut) | JY5325CoreOO::JY5325CoreOODOTask
WriteSinglePoint(bool writeValues, int line) | JY5325CoreOO::JY5325CoreOODOTask
WriteSinglePoint(std::vector< bool > &writeValues) | JY5325CoreOO::JY5325CoreOODOTask
~JY5325CoreOODOTask() | JY5325CoreOO::JY5325CoreOODOTask


5325 C++ Programming Manual: Member List

  • JY5325CoreOODevice
JY5325CoreOO::JY5325CoreOODevice Member List

This is the complete list of members for JY5325CoreOO::JY5325CoreOODevice, including all inherited members.

AIBufferSize | JY5325CoreOO::JY5325CoreOODevice |
AOChannelCount | JY5325CoreOO::JY5325CoreOODevice |
BoardClockRate | JY5325CoreOO::JY5325CoreOODevice |
CounterInterface enum name | JY5325CoreOO::JY5325CoreOODevice |
DeviceID | JY5325CoreOO::JY5325CoreOODevice |
DiffChannelCount | JY5325CoreOO::JY5325CoreOODevice |
DIOLineCount | JY5325CoreOO::JY5325CoreOODevice |
GetDefautTerminal(CounterInterface counterInterface, unsigned channelID) | JY5325CoreOO::JY5325CoreOODevice | static
GetInstance(int cardNum) | JY5325CoreOO::JY5325CoreOODevice | static
GetInstance(std::string aliasName) | JY5325CoreOO::JY5325CoreOODevice | static
Handle | JY5325CoreOO::JY5325CoreOODevice |
IsAISync | JY5325CoreOO::JY5325CoreOODevice |
IsAOSync | JY5325CoreOO::JY5325CoreOODevice |
MaxSampleRate | JY5325CoreOO::JY5325CoreOODevice |
MaxSampleRateMutilChannel | JY5325CoreOO::JY5325CoreOODevice |
MaxSampleRateSingleChannel | JY5325CoreOO::JY5325CoreOODevice |
MaxUpdateRateFourChannel | JY5325CoreOO::JY5325CoreOODevice |
MaxUpdateRateSingleChannel | JY5325CoreOO::JY5325CoreOODevice |
MaxUpdateRateThreeChannel | JY5325CoreOO::JY5325CoreOODevice |
MaxUpdateRateTwoChannel | JY5325CoreOO::JY5325CoreOODevice |
PFI | JY5325CoreOO::JY5325CoreOODevice |
ReferenceClock | JY5325CoreOO::JY5325CoreOODevice |
SerialNumber | JY5325CoreOO::JY5325CoreOODevice |


5325 C++ Programming Manual: Member List

  • JY5325CoreOOLog
JY5325CoreOO::JY5325CoreOOLog Member List

This is the complete list of members for JY5325CoreOO::JY5325CoreOOLog, including all inherited members.

EnableLog | JY5325CoreOO::JY5325CoreOOLog | static
Flush() | JY5325CoreOO::JY5325CoreOOLog | static
LogLevel | JY5325CoreOO::JY5325CoreOOLog | static
Print(const char *format,...) | JY5325CoreOO::JY5325CoreOOLog | static
Print(JY5325CoreOOLogLevel logLevel, const char *format,...) | JY5325CoreOO::JY5325CoreOOLog | static


5325 C++ Programming Manual: Member List

  • JY5325CoreOOProperty
JY5325CoreOO::JY5325CoreOOProperty< ContainerClass, ValueType, propertyType > Member List

This is the complete list of members for JY5325CoreOO::JY5325CoreOOProperty< ContainerClass, ValueType, propertyType >, including all inherited members.

JY5325CoreOOProperty() | JY5325CoreOO::JY5325CoreOOProperty< ContainerClass, ValueType, propertyType >
JY5325CoreOOProperty(ContainerClass *cObject, ValueType(ContainerClass::*pGet)(), void(ContainerClass::*pSet)(ValueType value)) | JY5325CoreOO::JY5325CoreOOProperty< ContainerClass, ValueType, propertyType >
JY5325CoreOOProperty(ValueType(*pGet)(), void(*pSet)(ValueType value)) | JY5325CoreOO::JY5325CoreOOProperty< ContainerClass, ValueType, propertyType >
operator ValueType() | JY5325CoreOO::JY5325CoreOOProperty< ContainerClass, ValueType, propertyType >
operator=(const ValueType &value) | JY5325CoreOO::JY5325CoreOOProperty< ContainerClass, ValueType, propertyType >


5325 C++ Programming Manual: Member List

  • JY5325CoreOOReferenceClock
JY5325CoreOO::JY5325CoreOOReferenceClock Member List

This is the complete list of members for JY5325CoreOO::JY5325CoreOOReferenceClock, including all inherited members.

Commit() | JY5325CoreOO::JY5325CoreOOReferenceClock |
External | JY5325CoreOO::JY5325CoreOOReferenceClock |
JY5325CoreOODevice class | JY5325CoreOO::JY5325CoreOOReferenceClock | friend
Source | JY5325CoreOO::JY5325CoreOOReferenceClock |


5325 C++ Programming Manual: Member List

  • JYDriverException
JY5325CoreOO::JYDriverException Member List

This is the complete list of members for JY5325CoreOO::JYDriverException, including all inherited members.

errorCode | JY5325CoreOO::JYDriverException
exceptionMessage | JY5325CoreOO::JYDriverException
FollowingException | JY5325CoreOO::JYDriverException
JYDriverException(JYDriverExceptionPublic exceptionCode, std::string msg="") | JY5325CoreOO::JYDriverException
JYDriverException(JYErrorCode exceptionCode, std::string msg="") | JY5325CoreOO::JYDriverException
JYDriverException(int, std::string msg) | JY5325CoreOO::JYDriverException


5325 C++ Programming Manual: Member List

  • PFIFilter
JY5325CoreOO::PFIFilter Member List

This is the complete list of members for JY5325CoreOO::PFIFilter, including all inherited members.

Disable(PFITerminal terminal) | JY5325CoreOO::PFIFilter
Disable(std::vector< PFITerminal > terminals) | JY5325CoreOO::PFIFilter
DisableAll() | JY5325CoreOO::PFIFilter
Enable(PFITerminal terminal, int minPulseWidth) | JY5325CoreOO::PFIFilter
Enable(std::vector< PFITerminal > terminals, int minPulseWidth) | JY5325CoreOO::PFIFilter
Enable(std::vector< PFITerminal > terminals, std::vector< int > minPulseWidth) | JY5325CoreOO::PFIFilter


5325 C++ Programming Manual: Member List

  • PFISetting
JY5325CoreOO::PFISetting Member List

This is the complete list of members for JY5325CoreOO::PFISetting, including all inherited members.

Filter JY5325CoreOO::PFISetting


5325 C++ Programming Manual: Member List

  • PauseTrigger
JY5325CoreOO::PauseTrigger Member List

This is the complete list of members for JY5325CoreOO::PauseTrigger, including all inherited members.

ActivePolarity | JY5325CoreOO::PauseTrigger
Terminal | JY5325CoreOO::PauseTrigger


5325 C++ Programming Manual: Member List

  • PeriodMeas
JY5325CoreOO::PeriodMeas Member List

This is the complete list of members for JY5325CoreOO::PeriodMeas, including all inherited members.

Input_Terminal | JY5325CoreOO::PeriodMeas
Timebase | JY5325CoreOO::PeriodMeas


5325 C++ Programming Manual: Member List

  • PulseMeas
JY5325CoreOO::PulseMeas Member List

This is the complete list of members for JY5325CoreOO::PulseMeas, including all inherited members.

Input_Terminal | JY5325CoreOO::PulseMeas
StartingEdge | JY5325CoreOO::PulseMeas
Timebase | JY5325CoreOO::PulseMeas


5325 C++ Programming Manual: Member List

  • QuadEncoder
JY5325CoreOO::QuadEncoder Member List

This is the complete list of members for JY5325CoreOO::QuadEncoder, including all inherited members.

AInputTerminal | JY5325CoreOO::QuadEncoder
BInputTerminal | JY5325CoreOO::QuadEncoder
EncodingType | JY5325CoreOO::QuadEncoder
InitialCount | JY5325CoreOO::QuadEncoder
ZInputTerminal | JY5325CoreOO::QuadEncoder
ZReloadEnabled | JY5325CoreOO::QuadEncoder


5325 C++ Programming Manual: Member List

  • SemiPeriodMeas
JY5325CoreOO::SemiPeriodMeas Member List

This is the complete list of members for JY5325CoreOO::SemiPeriodMeas, including all inherited members.

Input_Terminal | JY5325CoreOO::SemiPeriodMeas
StartingEdge | JY5325CoreOO::SemiPeriodMeas
Timebase | JY5325CoreOO::SemiPeriodMeas


5325 C++ Programming Manual: Member List

  • TwoEdgeSeparation
JY5325CoreOO::TwoEdgeSeparation Member List

This is the complete list of members for JY5325CoreOO::TwoEdgeSeparation, including all inherited members.

EdgeSeparationMode | JY5325CoreOO::TwoEdgeSeparation
FirstInputTerminal | JY5325CoreOO::TwoEdgeSeparation
SecondInputTerminal | JY5325CoreOO::TwoEdgeSeparation
Timebase | JY5325CoreOO::TwoEdgeSeparation


5325 C++ Programming Manual: Member List

  • TwoPulseEncoder
JY5325CoreOO::TwoPulseEncoder Member List

This is the complete list of members for JY5325CoreOO::TwoPulseEncoder, including all inherited members.

AInputTerminal | JY5325CoreOO::TwoPulseEncoder
BInputTerminal | JY5325CoreOO::TwoPulseEncoder
InitialCount | JY5325CoreOO::TwoPulseEncoder


5325 C++ Programming Manual: JY5325CoreOOAIMode Class Reference

JY5325CoreOOAIMode Class Reference

AIMode. More...

#include <JY5325CoreOOAITask.h>

Detailed Description

AIMode.

The documentation for this class was generated from the following file:
  • COO/5325/JY5325CoreOOAITask.h


5325 C++ Programming Manual: Class Index

Class Index
A | C | D | E | F | J | P | Q | S | T
A
AIAnalogEdgeComparator (JY5325CoreOO)
AIAnalogHysteresisComparator (JY5325CoreOO)
AIAnalogTrigger (JY5325CoreOO)
AIAnalogWindowComparator (JY5325CoreOO)
AIChannel (JY5325CoreOO)
AIDigitalTrigger (JY5325CoreOO)
AIExternalSampleClock (JY5325CoreOO)
AIRecord (JY5325CoreOO)
AISampleClock (JY5325CoreOO)
AISignalExport (JY5325CoreOO)
AISync (JY5325CoreOO)
AITrigger (JY5325CoreOO)
AOChannel (JY5325CoreOO)
AODigitalTrigger (JY5325CoreOO)
AOMode
AOSampleClock (JY5325CoreOO)
AOTrigger (JY5325CoreOO)
C
CIDigitalTrigger (JY5325CoreOO)
CIExternalSampleClock (JY5325CoreOO)
CIExternalTimebase (JY5325CoreOO)
CIImplicitSampleClock (JY5325CoreOO)
CIInternalSampleClock (JY5325CoreOO)
CISampleClock (JY5325CoreOO)
CISignalExport (JY5325CoreOO)
CITimebase (JY5325CoreOO)
CITrigger (JY5325CoreOO)
CODigitalTrigger (JY5325CoreOO)
COExternalTimebase (JY5325CoreOO)
COPulse (JY5325CoreOO)
COSignalExport (JY5325CoreOO)
COTimebase (JY5325CoreOO)
COTrigger (JY5325CoreOO)
D
DIChannel (JY5325CoreOO)
DIDigitalTrigger (JY5325CoreOO)
DIExternalSampleClock (JY5325CoreOO)
DISampleClock (JY5325CoreOO)
DISignalExport (JY5325CoreOO)
DITrigger (JY5325CoreOO)
DOChannel (JY5325CoreOO)
DODigitalTrigger (JY5325CoreOO)
DOExternalSampleClock (JY5325CoreOO)
DOSampleClock (JY5325CoreOO)
DOSignalExport (JY5325CoreOO)
DOTrigger (JY5325CoreOO)
E
EdgeCounting (JY5325CoreOO)
EdgeCountingOutEvent (JY5325CoreOO)
ExternalReferenceClock (JY5325CoreOO)
F
FrequencyMeas (JY5325CoreOO)
J
JY5325CoreOOAIMode
JY5325CoreOOAITask (JY5325CoreOO)
JY5325CoreOOAOTask (JY5325CoreOO)
JY5325CoreOOCITask (JY5325CoreOO)
JY5325CoreOOCOTask (JY5325CoreOO)
JY5325CoreOODevice (JY5325CoreOO)
JY5325CoreOODITask (JY5325CoreOO)
JY5325CoreOODOTask (JY5325CoreOO)
JY5325CoreOOLog (JY5325CoreOO)
JY5325CoreOOProperty (JY5325CoreOO)
JY5325CoreOOReferenceClock (JY5325CoreOO)
JYDriverException (JY5325CoreOO)
P
PauseTrigger (JY5325CoreOO)
PeriodMeas (JY5325CoreOO)
PFIFilter (JY5325CoreOO)
PFISetting (JY5325CoreOO)
PulseMeas (JY5325CoreOO)
Q
QuadEncoder (JY5325CoreOO)
S
SemiPeriodMeas (JY5325CoreOO)
T
TwoEdgeSeparation (JY5325CoreOO)
TwoPulseEncoder (JY5325CoreOO)


5325 C++ Programming Manual: COO Directory Reference

  • File List
  • File Members
  • COO
COO Directory Reference

Directories

5325


5325 C++ Programming Manual: File List

  • File List
  • File Members
File List
Here is a list of all files with brief descriptions:
[detail level 123]
▼ COO
▼ 5325
JY5325CoreOOAITask.h
JY5325CoreOOAOTask.h
JY5325CoreOOCITask.h
JY5325CoreOOCommon.h
JY5325CoreOOCOTask.h
JY5325CoreOODevice.h
JY5325CoreOODITask.h
JY5325CoreOODOTask.h
JY5325CoreOOLog.h


5325 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- a -

  • ActiveEdge : JY5325CoreOO::EdgeCounting
  • ActivePolarity : JY5325CoreOO::PauseTrigger
  • ActualFreq : JY5325CoreOO::CITimebase, JY5325CoreOO::COTimebase
  • Add() : JY5325CoreOO::AISignalExport, JY5325CoreOO::CISignalExport, JY5325CoreOO::COSignalExport, JY5325CoreOO::DISignalExport, JY5325CoreOO::DOSignalExport
  • AddChannel() : JY5325CoreOO::JY5325CoreOOAITask, JY5325CoreOO::JY5325CoreOOAOTask, JY5325CoreOO::JY5325CoreOODITask, JY5325CoreOO::JY5325CoreOODOTask
  • Advanced : JY5325CoreOO::JY5325CoreOOAITask
  • AIBufferSize : JY5325CoreOO::JY5325CoreOODevice
  • AIChannel() : JY5325CoreOO::AIChannel
  • AInputTerminal : JY5325CoreOO::QuadEncoder, JY5325CoreOO::TwoPulseEncoder
  • Analog : JY5325CoreOO::AITrigger
  • AOChannel() : JY5325CoreOO::AOChannel
  • AOChannelCount : JY5325CoreOO::JY5325CoreOODevice
  • AvailableSamples : JY5325CoreOO::JY5325CoreOOAITask, JY5325CoreOO::JY5325CoreOOCITask, JY5325CoreOO::JY5325CoreOOCOTask, JY5325CoreOO::JY5325CoreOODITask
  • AvaliableLenInSamples : JY5325CoreOO::JY5325CoreOOAOTask, JY5325CoreOO::JY5325CoreOODOTask


5325 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- b -

  • BInputTerminal : JY5325CoreOO::QuadEncoder, JY5325CoreOO::TwoPulseEncoder
  • BoardClockRate : JY5325CoreOO::JY5325CoreOODevice
  • BufLenInSamples : JY5325CoreOO::JY5325CoreOOAITask, JY5325CoreOO::JY5325CoreOOAOTask, JY5325CoreOO::JY5325CoreOOCOTask, JY5325CoreOO::JY5325CoreOODITask, JY5325CoreOO::JY5325CoreOODOTask


5325 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- c -

  • ChannelID : JY5325CoreOO::AIChannel, JY5325CoreOO::AOChannel
  • Channels : JY5325CoreOO::JY5325CoreOOAITask, JY5325CoreOO::JY5325CoreOOAOTask, JY5325CoreOO::JY5325CoreOODITask, JY5325CoreOO::JY5325CoreOODOTask
  • CISampleClock : JY5325CoreOO::CIImplicitSampleClock
  • CITimebase : JY5325CoreOO::CIExternalTimebase
  • Clear() : JY5325CoreOO::AISignalExport, JY5325CoreOO::CISignalExport, JY5325CoreOO::COSignalExport, JY5325CoreOO::DISignalExport, JY5325CoreOO::DOSignalExport
  • ClearAll() : JY5325CoreOO::AISignalExport, JY5325CoreOO::CISignalExport, JY5325CoreOO::COSignalExport, JY5325CoreOO::DISignalExport, JY5325CoreOO::DOSignalExport
  • Commit() : JY5325CoreOO::JY5325CoreOOReferenceClock
  • Comparator : JY5325CoreOO::AIAnalogTrigger
  • CompleteState : JY5325CoreOO::JY5325CoreOOAOTask
  • Condition : JY5325CoreOO::AIAnalogWindowComparator
  • COPulse() : JY5325CoreOO::COPulse
  • COTimebase : JY5325CoreOO::COExternalTimebase
  • CounterInterface : JY5325CoreOO::JY5325CoreOODevice


5325 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- d -

  • Device : JY5325CoreOO::JY5325CoreOOAITask, JY5325CoreOO::JY5325CoreOOAOTask, JY5325CoreOO::JY5325CoreOOCITask, JY5325CoreOO::JY5325CoreOOCOTask, JY5325CoreOO::JY5325CoreOODITask, JY5325CoreOO::JY5325CoreOODOTask
  • DeviceID : JY5325CoreOO::JY5325CoreOODevice
  • DiffChannelCount : JY5325CoreOO::JY5325CoreOODevice
  • Digital : JY5325CoreOO::AITrigger, JY5325CoreOO::AOTrigger, JY5325CoreOO::CITrigger, JY5325CoreOO::COTrigger, JY5325CoreOO::DITrigger, JY5325CoreOO::DOTrigger
  • DIOLineCount : JY5325CoreOO::JY5325CoreOODevice
  • Direction : JY5325CoreOO::EdgeCounting
  • DirTerminal : JY5325CoreOO::EdgeCounting
  • Disable() : JY5325CoreOO::PFIFilter
  • DisableAll() : JY5325CoreOO::PFIFilter
  • DisableCalibration : JY5325CoreOO::JY5325CoreOOAOTask
  • DisableDigitalTriggerDelay : JY5325CoreOO::JY5325CoreOOAITask


5325 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- e -

  • Edge : JY5325CoreOO::AIAnalogTrigger, JY5325CoreOO::AIDigitalTrigger, JY5325CoreOO::AODigitalTrigger, JY5325CoreOO::CIDigitalTrigger, JY5325CoreOO::CODigitalTrigger, JY5325CoreOO::DIDigitalTrigger, JY5325CoreOO::DODigitalTrigger
  • EdgeCounting : JY5325CoreOO::JY5325CoreOOCITask
  • EdgeSeparationMode : JY5325CoreOO::TwoEdgeSeparation
  • Enable() : JY5325CoreOO::PFIFilter
  • EnableLog : JY5325CoreOO::JY5325CoreOOLog
  • EncodingType : JY5325CoreOO::QuadEncoder
  • errorCode : JY5325CoreOO::JYDriverException
  • exceptionMessage : JY5325CoreOO::JYDriverException
  • ExpectedRate : JY5325CoreOO::AIExternalSampleClock, JY5325CoreOO::CIExternalSampleClock, JY5325CoreOO::CIImplicitSampleClock, JY5325CoreOO::DIExternalSampleClock, JY5325CoreOO::DOExternalSampleClock
  • External : JY5325CoreOO::CISampleClock, JY5325CoreOO::CITimebase, JY5325CoreOO::COTimebase, JY5325CoreOO::DISampleClock, JY5325CoreOO::DOSampleClock, JY5325CoreOO::JY5325CoreOOReferenceClock


5325 C++ Programming Manual: Class Members - Enumerations

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
Here is a list of all enums with links to the classes they belong to:
  • CounterInterface : JY5325CoreOO::JY5325CoreOODevice


5325 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- f -

  • File_Format : JY5325CoreOO::AIRecord
  • FilePath : JY5325CoreOO::AIRecord
  • Filter : JY5325CoreOO::PFISetting
  • FirstInputTerminal : JY5325CoreOO::TwoEdgeSeparation
  • Flush() : JY5325CoreOO::JY5325CoreOOLog
  • FollowingException : JY5325CoreOO::JYDriverException
  • Frequency : JY5325CoreOO::CIExternalTimebase, JY5325CoreOO::COExternalTimebase
  • FrequencyMeas : JY5325CoreOO::JY5325CoreOOCITask


5325 C++ Programming Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • c
  • d
  • e
  • f
  • g
  • j
  • o
  • p
  • r
  • s
  • w
  • ~
Here is a list of all functions with links to the classes they belong to:

- a -

  • Add() : JY5325CoreOO::AISignalExport, JY5325CoreOO::CISignalExport, JY5325CoreOO::COSignalExport, JY5325CoreOO::DISignalExport, JY5325CoreOO::DOSignalExport
  • AddChannel() : JY5325CoreOO::JY5325CoreOOAITask, JY5325CoreOO::JY5325CoreOOAOTask, JY5325CoreOO::JY5325CoreOODITask, JY5325CoreOO::JY5325CoreOODOTask
  • AIChannel() : JY5325CoreOO::AIChannel
  • AOChannel() : JY5325CoreOO::AOChannel

- c -

  • Clear() : JY5325CoreOO::AISignalExport, JY5325CoreOO::CISignalExport, JY5325CoreOO::COSignalExport, JY5325CoreOO::DISignalExport, JY5325CoreOO::DOSignalExport
  • ClearAll() : JY5325CoreOO::AISignalExport, JY5325CoreOO::CISignalExport, JY5325CoreOO::COSignalExport, JY5325CoreOO::DISignalExport, JY5325CoreOO::DOSignalExport
  • Commit() : JY5325CoreOO::JY5325CoreOOReferenceClock
  • COPulse() : JY5325CoreOO::COPulse

- d -

  • Disable() : JY5325CoreOO::PFIFilter
  • DisableAll() : JY5325CoreOO::PFIFilter

- e -

  • Enable() : JY5325CoreOO::PFIFilter

- f -

  • Flush() : JY5325CoreOO::JY5325CoreOOLog

- g -

  • GetDefautTerminal() : JY5325CoreOO::JY5325CoreOODevice
  • GetInstance() : JY5325CoreOO::JY5325CoreOODevice
  • GetRecordPreviewData() : JY5325CoreOO::JY5325CoreOOAITask
  • GetRecordStatus() : JY5325CoreOO::JY5325CoreOOAITask

- j -

  • JY5325CoreOOAITask() : JY5325CoreOO::JY5325CoreOOAITask
  • JY5325CoreOOAOTask() : JY5325CoreOO::JY5325CoreOOAOTask
  • JY5325CoreOOCITask() : JY5325CoreOO::JY5325CoreOOCITask
  • JY5325CoreOOCOTask() : JY5325CoreOO::JY5325CoreOOCOTask
  • JY5325CoreOODITask() : JY5325CoreOO::JY5325CoreOODITask
  • JY5325CoreOODOTask() : JY5325CoreOO::JY5325CoreOODOTask
  • JY5325CoreOOProperty() : JY5325CoreOO::JY5325CoreOOProperty< ContainerClass, ValueType, propertyType >
  • JYDriverException() : JY5325CoreOO::JYDriverException

- o -

  • operator ValueType() : JY5325CoreOO::JY5325CoreOOProperty< ContainerClass, ValueType, propertyType >
  • operator=() : JY5325CoreOO::JY5325CoreOOProperty< ContainerClass, ValueType, propertyType >

- p -

  • Print() : JY5325CoreOO::JY5325CoreOOLog

- r -

  • ReadData() : JY5325CoreOO::JY5325CoreOOAITask, JY5325CoreOO::JY5325CoreOOCITask, JY5325CoreOO::JY5325CoreOODITask
  • ReadRawData() : JY5325CoreOO::JY5325CoreOOAITask
  • ReadSinglePoint() : JY5325CoreOO::JY5325CoreOOCITask, JY5325CoreOO::JY5325CoreOODITask
  • RemoveChannel() : JY5325CoreOO::JY5325CoreOOAITask, JY5325CoreOO::JY5325CoreOOAOTask, JY5325CoreOO::JY5325CoreOODITask, JY5325CoreOO::JY5325CoreOODOTask

- s -

  • SendSoftwareTrigger() : JY5325CoreOO::JY5325CoreOOAITask, JY5325CoreOO::JY5325CoreOOAOTask, JY5325CoreOO::JY5325CoreOOCITask, JY5325CoreOO::JY5325CoreOOCOTask, JY5325CoreOO::JY5325CoreOODITask, JY5325CoreOO::JY5325CoreOODOTask
  • Start() : JY5325CoreOO::JY5325CoreOOAITask, JY5325CoreOO::JY5325CoreOOAOTask, JY5325CoreOO::JY5325CoreOOCITask, JY5325CoreOO::JY5325CoreOOCOTask, JY5325CoreOO::JY5325CoreOODITask, JY5325CoreOO::JY5325CoreOODOTask
  • Stop() : JY5325CoreOO::JY5325CoreOOAITask, JY5325CoreOO::JY5325CoreOOAOTask, JY5325CoreOO::JY5325CoreOOCITask, JY5325CoreOO::JY5325CoreOOCOTask, JY5325CoreOO::JY5325CoreOODITask, JY5325CoreOO::JY5325CoreOODOTask

- w -

  • WaitUntilDone() : JY5325CoreOO::JY5325CoreOOAITask, JY5325CoreOO::JY5325CoreOOAOTask, JY5325CoreOO::JY5325CoreOOCOTask, JY5325CoreOO::JY5325CoreOODOTask
  • WriteData() : JY5325CoreOO::JY5325CoreOOAOTask, JY5325CoreOO::JY5325CoreOOCOTask, JY5325CoreOO::JY5325CoreOODOTask
  • WriteRawData() : JY5325CoreOO::JY5325CoreOOAOTask
  • WriteRawSinglePoint() : JY5325CoreOO::JY5325CoreOOAOTask
  • WriteSinglePoint() : JY5325CoreOO::JY5325CoreOOAOTask, JY5325CoreOO::JY5325CoreOOCOTask, JY5325CoreOO::JY5325CoreOODOTask

- ~ -

  • ~JY5325CoreOOAITask() : JY5325CoreOO::JY5325CoreOOAITask
  • ~JY5325CoreOOAOTask() : JY5325CoreOO::JY5325CoreOOAOTask
  • ~JY5325CoreOOCITask() : JY5325CoreOO::JY5325CoreOOCITask
  • ~JY5325CoreOOCOTask() : JY5325CoreOO::JY5325CoreOOCOTask
  • ~JY5325CoreOODITask() : JY5325CoreOO::JY5325CoreOODITask
  • ~JY5325CoreOODOTask() : JY5325CoreOO::JY5325CoreOODOTask


5325 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- g -

  • GetDefautTerminal() : JY5325CoreOO::JY5325CoreOODevice
  • GetInstance() : JY5325CoreOO::JY5325CoreOODevice
  • GetRecordPreviewData() : JY5325CoreOO::JY5325CoreOOAITask
  • GetRecordStatus() : JY5325CoreOO::JY5325CoreOOAITask


5325 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- h -

  • Handle : JY5325CoreOO::JY5325CoreOODevice
  • HighThreshold : JY5325CoreOO::AIAnalogHysteresisComparator, JY5325CoreOO::AIAnalogWindowComparator
  • Hysteresis : JY5325CoreOO::AIAnalogTrigger


5325 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- i -

  • IdleState : JY5325CoreOO::EdgeCountingOutEvent, JY5325CoreOO::JY5325CoreOOCOTask
  • IgnoreFirstSampleClock : JY5325CoreOO::CIExternalSampleClock, JY5325CoreOO::CIInternalSampleClock
  • Implicit : JY5325CoreOO::CISampleClock
  • InitialCount : JY5325CoreOO::EdgeCounting, JY5325CoreOO::QuadEncoder, JY5325CoreOO::TwoPulseEncoder
  • InitialDelay : JY5325CoreOO::JY5325CoreOOCOTask
  • Input_Terminal : JY5325CoreOO::EdgeCounting, JY5325CoreOO::FrequencyMeas, JY5325CoreOO::PeriodMeas, JY5325CoreOO::PulseMeas, JY5325CoreOO::SemiPeriodMeas
  • Internal : JY5325CoreOO::CISampleClock
  • IsAISync : JY5325CoreOO::JY5325CoreOODevice
  • IsAOSync : JY5325CoreOO::JY5325CoreOODevice


5325 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- j -

  • JY5325CoreOOAITask() : JY5325CoreOO::JY5325CoreOOAITask
  • JY5325CoreOOAOTask : JY5325CoreOO::AOSampleClock, JY5325CoreOO::JY5325CoreOOAOTask
  • JY5325CoreOOCITask() : JY5325CoreOO::JY5325CoreOOCITask
  • JY5325CoreOOCOTask() : JY5325CoreOO::JY5325CoreOOCOTask
  • JY5325CoreOODevice : JY5325CoreOO::JY5325CoreOOReferenceClock
  • JY5325CoreOODITask() : JY5325CoreOO::JY5325CoreOODITask
  • JY5325CoreOODOTask() : JY5325CoreOO::JY5325CoreOODOTask
  • JY5325CoreOOProperty() : JY5325CoreOO::JY5325CoreOOProperty< ContainerClass, ValueType, propertyType >
  • JYDriverException() : JY5325CoreOO::JYDriverException


5325 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- l -

  • Length : JY5325CoreOO::AIRecord
  • LineNum : JY5325CoreOO::DIChannel, JY5325CoreOO::DOChannel
  • LogLevel : JY5325CoreOO::JY5325CoreOOLog
  • LowThreshold : JY5325CoreOO::AIAnalogHysteresisComparator, JY5325CoreOO::AIAnalogWindowComparator


5325 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- m -

  • MaxSampleRate : JY5325CoreOO::JY5325CoreOODevice
  • MaxSampleRateMutilChannel : JY5325CoreOO::JY5325CoreOODevice
  • MaxSampleRateSingleChannel : JY5325CoreOO::JY5325CoreOODevice
  • MaxUpdateRateFourChannel : JY5325CoreOO::JY5325CoreOODevice
  • MaxUpdateRateSingleChannel : JY5325CoreOO::JY5325CoreOODevice
  • MaxUpdateRateThreeChannel : JY5325CoreOO::JY5325CoreOODevice
  • MaxUpdateRateTwoChannel : JY5325CoreOO::JY5325CoreOODevice
  • Mode : JY5325CoreOO::AIRecord, JY5325CoreOO::AITrigger, JY5325CoreOO::DITrigger, JY5325CoreOO::JY5325CoreOOAITask, JY5325CoreOO::JY5325CoreOOAOTask, JY5325CoreOO::JY5325CoreOOCITask, JY5325CoreOO::JY5325CoreOOCOTask, JY5325CoreOO::JY5325CoreOODITask, JY5325CoreOO::JY5325CoreOODOTask


5325 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- o -

  • operator ValueType() : JY5325CoreOO::JY5325CoreOOProperty< ContainerClass, ValueType, propertyType >
  • operator=() : JY5325CoreOO::JY5325CoreOOProperty< ContainerClass, ValueType, propertyType >
  • OutEvent : JY5325CoreOO::EdgeCounting
  • OutputTerminal : JY5325CoreOO::JY5325CoreOOCOTask


5325 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- p -

  • Pause : JY5325CoreOO::EdgeCounting, JY5325CoreOO::JY5325CoreOOCOTask
  • PeriodMeas : JY5325CoreOO::JY5325CoreOOCITask
  • PFI : JY5325CoreOO::JY5325CoreOODevice
  • PreTriggerSamples : JY5325CoreOO::AITrigger, JY5325CoreOO::DITrigger
  • Print() : JY5325CoreOO::JY5325CoreOOLog
  • PulseMeas : JY5325CoreOO::JY5325CoreOOCITask


5325 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- q -

  • QuadEncoder : JY5325CoreOO::JY5325CoreOOCITask


5325 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- r -

  • RangeHigh : JY5325CoreOO::AIChannel, JY5325CoreOO::AOChannel
  • RangeLow : JY5325CoreOO::AIChannel, JY5325CoreOO::AOChannel
  • Rate : JY5325CoreOO::CIInternalSampleClock
  • ReadData() : JY5325CoreOO::JY5325CoreOOAITask, JY5325CoreOO::JY5325CoreOOCITask, JY5325CoreOO::JY5325CoreOODITask
  • ReadRawData() : JY5325CoreOO::JY5325CoreOOAITask
  • ReadSinglePoint() : JY5325CoreOO::JY5325CoreOOCITask, JY5325CoreOO::JY5325CoreOODITask
  • Record : JY5325CoreOO::JY5325CoreOOAITask
  • ReferenceClock : JY5325CoreOO::JY5325CoreOODevice
  • RemoveChannel() : JY5325CoreOO::JY5325CoreOOAITask, JY5325CoreOO::JY5325CoreOOAOTask, JY5325CoreOO::JY5325CoreOODITask, JY5325CoreOO::JY5325CoreOODOTask
  • ReTriggerCount : JY5325CoreOO::AITrigger


5325 C++ Programming Manual: Class Members - Related Symbols

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
Here is a list of all related symbols with links to the classes they belong to:
  • CISampleClock : JY5325CoreOO::CIImplicitSampleClock
  • CITimebase : JY5325CoreOO::CIExternalTimebase
  • COTimebase : JY5325CoreOO::COExternalTimebase
  • JY5325CoreOOAOTask : JY5325CoreOO::AOSampleClock
  • JY5325CoreOODevice : JY5325CoreOO::JY5325CoreOOReferenceClock


5325 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- s -

  • SampleClock : JY5325CoreOO::JY5325CoreOOAITask, JY5325CoreOO::JY5325CoreOOAOTask, JY5325CoreOO::JY5325CoreOOCITask, JY5325CoreOO::JY5325CoreOODITask, JY5325CoreOO::JY5325CoreOODOTask
  • SampleRate : JY5325CoreOO::JY5325CoreOOAITask, JY5325CoreOO::JY5325CoreOODITask
  • SamplesToAcquire : JY5325CoreOO::JY5325CoreOOAITask, JY5325CoreOO::JY5325CoreOOCITask, JY5325CoreOO::JY5325CoreOODITask
  • SamplesToUpdate : JY5325CoreOO::JY5325CoreOOAOTask, JY5325CoreOO::JY5325CoreOOCOTask, JY5325CoreOO::JY5325CoreOODOTask
  • SecondInputTerminal : JY5325CoreOO::TwoEdgeSeparation
  • SemiPeriodMeas : JY5325CoreOO::JY5325CoreOOCITask
  • SendSoftwareTrigger() : JY5325CoreOO::JY5325CoreOOAITask, JY5325CoreOO::JY5325CoreOOAOTask, JY5325CoreOO::JY5325CoreOOCITask, JY5325CoreOO::JY5325CoreOOCOTask, JY5325CoreOO::JY5325CoreOODITask, JY5325CoreOO::JY5325CoreOODOTask
  • SerialNumber : JY5325CoreOO::JY5325CoreOODevice
  • SignalExport : JY5325CoreOO::JY5325CoreOOAITask, JY5325CoreOO::JY5325CoreOOAOTask, JY5325CoreOO::JY5325CoreOOCITask, JY5325CoreOO::JY5325CoreOOCOTask, JY5325CoreOO::JY5325CoreOODITask, JY5325CoreOO::JY5325CoreOODOTask
  • Slope : JY5325CoreOO::AIAnalogEdgeComparator, JY5325CoreOO::AIAnalogHysteresisComparator
  • Source : JY5325CoreOO::AIAnalogTrigger, JY5325CoreOO::AIDigitalTrigger, JY5325CoreOO::AISampleClock, JY5325CoreOO::AODigitalTrigger, JY5325CoreOO::AOSampleClock, JY5325CoreOO::CIDigitalTrigger, JY5325CoreOO::CISampleClock, JY5325CoreOO::CITimebase, JY5325CoreOO::CODigitalTrigger, JY5325CoreOO::COTimebase, JY5325CoreOO::DIDigitalTrigger, JY5325CoreOO::DISampleClock, JY5325CoreOO::DODigitalTrigger, JY5325CoreOO::DOSampleClock, JY5325CoreOO::JY5325CoreOOReferenceClock
  • Start() : JY5325CoreOO::JY5325CoreOOAITask, JY5325CoreOO::JY5325CoreOOAOTask, JY5325CoreOO::JY5325CoreOOCITask, JY5325CoreOO::JY5325CoreOOCOTask, JY5325CoreOO::JY5325CoreOODITask, JY5325CoreOO::JY5325CoreOODOTask
  • StartingEdge : JY5325CoreOO::PulseMeas, JY5325CoreOO::SemiPeriodMeas
  • Stop() : JY5325CoreOO::JY5325CoreOOAITask, JY5325CoreOO::JY5325CoreOOAOTask, JY5325CoreOO::JY5325CoreOOCITask, JY5325CoreOO::JY5325CoreOOCOTask, JY5325CoreOO::JY5325CoreOODITask, JY5325CoreOO::JY5325CoreOODOTask
  • Sync : JY5325CoreOO::JY5325CoreOOAITask


5325 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- t -

  • Terminal : JY5325CoreOO::AIExternalSampleClock, JY5325CoreOO::CIExternalSampleClock, JY5325CoreOO::CIExternalTimebase, JY5325CoreOO::COExternalTimebase, JY5325CoreOO::DIExternalSampleClock, JY5325CoreOO::DOExternalSampleClock, JY5325CoreOO::EdgeCountingOutEvent, JY5325CoreOO::ExternalReferenceClock, JY5325CoreOO::PauseTrigger
  • Threshold : JY5325CoreOO::AIAnalogEdgeComparator, JY5325CoreOO::EdgeCountingOutEvent
  • TimeBase : JY5325CoreOO::JY5325CoreOOCOTask
  • Timebase : JY5325CoreOO::FrequencyMeas, JY5325CoreOO::PeriodMeas, JY5325CoreOO::PulseMeas, JY5325CoreOO::SemiPeriodMeas, JY5325CoreOO::TwoEdgeSeparation
  • timeBase : JY5325CoreOO::JY5325CoreOOCITask
  • Topology : JY5325CoreOO::AISync
  • TransferedPulses : JY5325CoreOO::JY5325CoreOOCOTask
  • TransferedSamples : JY5325CoreOO::JY5325CoreOOAITask, JY5325CoreOO::JY5325CoreOOAOTask, JY5325CoreOO::JY5325CoreOOCITask, JY5325CoreOO::JY5325CoreOOCOTask, JY5325CoreOO::JY5325CoreOODITask, JY5325CoreOO::JY5325CoreOODOTask
  • Trigger : JY5325CoreOO::JY5325CoreOOAITask, JY5325CoreOO::JY5325CoreOOAOTask, JY5325CoreOO::JY5325CoreOOCITask, JY5325CoreOO::JY5325CoreOOCOTask, JY5325CoreOO::JY5325CoreOODITask, JY5325CoreOO::JY5325CoreOODOTask
  • TriggerRouting : JY5325CoreOO::AISync
  • TwoEdgeSeparation : JY5325CoreOO::JY5325CoreOOCITask
  • TwoPulseEncoder : JY5325CoreOO::JY5325CoreOOCITask
  • Type : JY5325CoreOO::AITrigger, JY5325CoreOO::AOTrigger, JY5325CoreOO::CITrigger, JY5325CoreOO::COTrigger, JY5325CoreOO::DITrigger, JY5325CoreOO::DOTrigger, JY5325CoreOO::JY5325CoreOOCITask


5325 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- u -

  • UpdateRate : JY5325CoreOO::JY5325CoreOOAOTask, JY5325CoreOO::JY5325CoreOODOTask


5325 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- a -

  • ActiveEdge : JY5325CoreOO::EdgeCounting
  • ActivePolarity : JY5325CoreOO::PauseTrigger
  • ActualFreq : JY5325CoreOO::CITimebase, JY5325CoreOO::COTimebase
  • Advanced : JY5325CoreOO::JY5325CoreOOAITask
  • AIBufferSize : JY5325CoreOO::JY5325CoreOODevice
  • AInputTerminal : JY5325CoreOO::QuadEncoder, JY5325CoreOO::TwoPulseEncoder
  • Analog : JY5325CoreOO::AITrigger
  • AOChannelCount : JY5325CoreOO::JY5325CoreOODevice
  • AvailableSamples : JY5325CoreOO::JY5325CoreOOAITask, JY5325CoreOO::JY5325CoreOOCITask, JY5325CoreOO::JY5325CoreOOCOTask, JY5325CoreOO::JY5325CoreOODITask
  • AvaliableLenInSamples : JY5325CoreOO::JY5325CoreOOAOTask, JY5325CoreOO::JY5325CoreOODOTask


5325 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- b -

  • BInputTerminal : JY5325CoreOO::QuadEncoder, JY5325CoreOO::TwoPulseEncoder
  • BoardClockRate : JY5325CoreOO::JY5325CoreOODevice
  • BufLenInSamples : JY5325CoreOO::JY5325CoreOOAITask, JY5325CoreOO::JY5325CoreOOAOTask, JY5325CoreOO::JY5325CoreOOCOTask, JY5325CoreOO::JY5325CoreOODITask, JY5325CoreOO::JY5325CoreOODOTask


5325 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- c -

  • ChannelID : JY5325CoreOO::AIChannel, JY5325CoreOO::AOChannel
  • Channels : JY5325CoreOO::JY5325CoreOOAITask, JY5325CoreOO::JY5325CoreOOAOTask, JY5325CoreOO::JY5325CoreOODITask, JY5325CoreOO::JY5325CoreOODOTask
  • Comparator : JY5325CoreOO::AIAnalogTrigger
  • CompleteState : JY5325CoreOO::JY5325CoreOOAOTask
  • Condition : JY5325CoreOO::AIAnalogWindowComparator


5325 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- d -

  • Device : JY5325CoreOO::JY5325CoreOOAITask, JY5325CoreOO::JY5325CoreOOAOTask, JY5325CoreOO::JY5325CoreOOCITask, JY5325CoreOO::JY5325CoreOOCOTask, JY5325CoreOO::JY5325CoreOODITask, JY5325CoreOO::JY5325CoreOODOTask
  • DeviceID : JY5325CoreOO::JY5325CoreOODevice
  • DiffChannelCount : JY5325CoreOO::JY5325CoreOODevice
  • Digital : JY5325CoreOO::AITrigger, JY5325CoreOO::AOTrigger, JY5325CoreOO::CITrigger, JY5325CoreOO::COTrigger, JY5325CoreOO::DITrigger, JY5325CoreOO::DOTrigger
  • DIOLineCount : JY5325CoreOO::JY5325CoreOODevice
  • Direction : JY5325CoreOO::EdgeCounting
  • DirTerminal : JY5325CoreOO::EdgeCounting
  • DisableCalibration : JY5325CoreOO::JY5325CoreOOAOTask
  • DisableDigitalTriggerDelay : JY5325CoreOO::JY5325CoreOOAITask


5325 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- e -

  • Edge : JY5325CoreOO::AIAnalogTrigger, JY5325CoreOO::AIDigitalTrigger, JY5325CoreOO::AODigitalTrigger, JY5325CoreOO::CIDigitalTrigger, JY5325CoreOO::CODigitalTrigger, JY5325CoreOO::DIDigitalTrigger, JY5325CoreOO::DODigitalTrigger
  • EdgeCounting : JY5325CoreOO::JY5325CoreOOCITask
  • EdgeSeparationMode : JY5325CoreOO::TwoEdgeSeparation
  • EnableLog : JY5325CoreOO::JY5325CoreOOLog
  • EncodingType : JY5325CoreOO::QuadEncoder
  • errorCode : JY5325CoreOO::JYDriverException
  • exceptionMessage : JY5325CoreOO::JYDriverException
  • ExpectedRate : JY5325CoreOO::AIExternalSampleClock, JY5325CoreOO::CIExternalSampleClock, JY5325CoreOO::CIImplicitSampleClock, JY5325CoreOO::DIExternalSampleClock, JY5325CoreOO::DOExternalSampleClock
  • External : JY5325CoreOO::CISampleClock, JY5325CoreOO::CITimebase, JY5325CoreOO::COTimebase, JY5325CoreOO::DISampleClock, JY5325CoreOO::DOSampleClock, JY5325CoreOO::JY5325CoreOOReferenceClock


5325 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- f -

  • File_Format : JY5325CoreOO::AIRecord
  • FilePath : JY5325CoreOO::AIRecord
  • Filter : JY5325CoreOO::PFISetting
  • FirstInputTerminal : JY5325CoreOO::TwoEdgeSeparation
  • FollowingException : JY5325CoreOO::JYDriverException
  • Frequency : JY5325CoreOO::CIExternalTimebase, JY5325CoreOO::COExternalTimebase
  • FrequencyMeas : JY5325CoreOO::JY5325CoreOOCITask


5325 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- h -

  • Handle : JY5325CoreOO::JY5325CoreOODevice
  • HighThreshold : JY5325CoreOO::AIAnalogHysteresisComparator, JY5325CoreOO::AIAnalogWindowComparator
  • Hysteresis : JY5325CoreOO::AIAnalogTrigger


5325 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- i -

  • IdleState : JY5325CoreOO::EdgeCountingOutEvent, JY5325CoreOO::JY5325CoreOOCOTask
  • IgnoreFirstSampleClock : JY5325CoreOO::CIExternalSampleClock, JY5325CoreOO::CIInternalSampleClock
  • Implicit : JY5325CoreOO::CISampleClock
  • InitialCount : JY5325CoreOO::EdgeCounting, JY5325CoreOO::QuadEncoder, JY5325CoreOO::TwoPulseEncoder
  • InitialDelay : JY5325CoreOO::JY5325CoreOOCOTask
  • Input_Terminal : JY5325CoreOO::EdgeCounting, JY5325CoreOO::FrequencyMeas, JY5325CoreOO::PeriodMeas, JY5325CoreOO::PulseMeas, JY5325CoreOO::SemiPeriodMeas
  • Internal : JY5325CoreOO::CISampleClock
  • IsAISync : JY5325CoreOO::JY5325CoreOODevice
  • IsAOSync : JY5325CoreOO::JY5325CoreOODevice


5325 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- l -

  • Length : JY5325CoreOO::AIRecord
  • LineNum : JY5325CoreOO::DIChannel, JY5325CoreOO::DOChannel
  • LogLevel : JY5325CoreOO::JY5325CoreOOLog
  • LowThreshold : JY5325CoreOO::AIAnalogHysteresisComparator, JY5325CoreOO::AIAnalogWindowComparator


5325 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- m -

  • MaxSampleRate : JY5325CoreOO::JY5325CoreOODevice
  • MaxSampleRateMutilChannel : JY5325CoreOO::JY5325CoreOODevice
  • MaxSampleRateSingleChannel : JY5325CoreOO::JY5325CoreOODevice
  • MaxUpdateRateFourChannel : JY5325CoreOO::JY5325CoreOODevice
  • MaxUpdateRateSingleChannel : JY5325CoreOO::JY5325CoreOODevice
  • MaxUpdateRateThreeChannel : JY5325CoreOO::JY5325CoreOODevice
  • MaxUpdateRateTwoChannel : JY5325CoreOO::JY5325CoreOODevice
  • Mode : JY5325CoreOO::AIRecord, JY5325CoreOO::AITrigger, JY5325CoreOO::DITrigger, JY5325CoreOO::JY5325CoreOOAITask, JY5325CoreOO::JY5325CoreOOAOTask, JY5325CoreOO::JY5325CoreOOCITask, JY5325CoreOO::JY5325CoreOOCOTask, JY5325CoreOO::JY5325CoreOODITask, JY5325CoreOO::JY5325CoreOODOTask


5325 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- o -

  • OutEvent : JY5325CoreOO::EdgeCounting
  • OutputTerminal : JY5325CoreOO::JY5325CoreOOCOTask


5325 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- p -

  • Pause : JY5325CoreOO::EdgeCounting, JY5325CoreOO::JY5325CoreOOCOTask
  • PeriodMeas : JY5325CoreOO::JY5325CoreOOCITask
  • PFI : JY5325CoreOO::JY5325CoreOODevice
  • PreTriggerSamples : JY5325CoreOO::AITrigger, JY5325CoreOO::DITrigger
  • PulseMeas : JY5325CoreOO::JY5325CoreOOCITask


5325 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- q -

  • QuadEncoder : JY5325CoreOO::JY5325CoreOOCITask


5325 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- r -

  • RangeHigh : JY5325CoreOO::AIChannel, JY5325CoreOO::AOChannel
  • RangeLow : JY5325CoreOO::AIChannel, JY5325CoreOO::AOChannel
  • Rate : JY5325CoreOO::CIInternalSampleClock
  • Record : JY5325CoreOO::JY5325CoreOOAITask
  • ReferenceClock : JY5325CoreOO::JY5325CoreOODevice
  • ReTriggerCount : JY5325CoreOO::AITrigger


5325 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- s -

  • SampleClock : JY5325CoreOO::JY5325CoreOOAITask, JY5325CoreOO::JY5325CoreOOAOTask, JY5325CoreOO::JY5325CoreOOCITask, JY5325CoreOO::JY5325CoreOODITask, JY5325CoreOO::JY5325CoreOODOTask
  • SampleRate : JY5325CoreOO::JY5325CoreOOAITask, JY5325CoreOO::JY5325CoreOODITask
  • SamplesToAcquire : JY5325CoreOO::JY5325CoreOOAITask, JY5325CoreOO::JY5325CoreOOCITask, JY5325CoreOO::JY5325CoreOODITask
  • SamplesToUpdate : JY5325CoreOO::JY5325CoreOOAOTask, JY5325CoreOO::JY5325CoreOOCOTask, JY5325CoreOO::JY5325CoreOODOTask
  • SecondInputTerminal : JY5325CoreOO::TwoEdgeSeparation
  • SemiPeriodMeas : JY5325CoreOO::JY5325CoreOOCITask
  • SerialNumber : JY5325CoreOO::JY5325CoreOODevice
  • SignalExport : JY5325CoreOO::JY5325CoreOOAITask, JY5325CoreOO::JY5325CoreOOAOTask, JY5325CoreOO::JY5325CoreOOCITask, JY5325CoreOO::JY5325CoreOOCOTask, JY5325CoreOO::JY5325CoreOODITask, JY5325CoreOO::JY5325CoreOODOTask
  • Slope : JY5325CoreOO::AIAnalogEdgeComparator, JY5325CoreOO::AIAnalogHysteresisComparator
  • Source : JY5325CoreOO::AIAnalogTrigger, JY5325CoreOO::AIDigitalTrigger, JY5325CoreOO::AISampleClock, JY5325CoreOO::AODigitalTrigger, JY5325CoreOO::AOSampleClock, JY5325CoreOO::CIDigitalTrigger, JY5325CoreOO::CISampleClock, JY5325CoreOO::CITimebase, JY5325CoreOO::CODigitalTrigger, JY5325CoreOO::COTimebase, JY5325CoreOO::DIDigitalTrigger, JY5325CoreOO::DISampleClock, JY5325CoreOO::DODigitalTrigger, JY5325CoreOO::DOSampleClock, JY5325CoreOO::JY5325CoreOOReferenceClock
  • StartingEdge : JY5325CoreOO::PulseMeas, JY5325CoreOO::SemiPeriodMeas
  • Sync : JY5325CoreOO::JY5325CoreOOAITask


5325 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- t -

  • Terminal : JY5325CoreOO::AIExternalSampleClock, JY5325CoreOO::CIExternalSampleClock, JY5325CoreOO::CIExternalTimebase, JY5325CoreOO::COExternalTimebase, JY5325CoreOO::DIExternalSampleClock, JY5325CoreOO::DOExternalSampleClock, JY5325CoreOO::EdgeCountingOutEvent, JY5325CoreOO::ExternalReferenceClock, JY5325CoreOO::PauseTrigger
  • Threshold : JY5325CoreOO::AIAnalogEdgeComparator, JY5325CoreOO::EdgeCountingOutEvent
  • TimeBase : JY5325CoreOO::JY5325CoreOOCOTask
  • Timebase : JY5325CoreOO::FrequencyMeas, JY5325CoreOO::PeriodMeas, JY5325CoreOO::PulseMeas, JY5325CoreOO::SemiPeriodMeas, JY5325CoreOO::TwoEdgeSeparation
  • timeBase : JY5325CoreOO::JY5325CoreOOCITask
  • Topology : JY5325CoreOO::AISync
  • TransferedPulses : JY5325CoreOO::JY5325CoreOOCOTask
  • TransferedSamples : JY5325CoreOO::JY5325CoreOOAITask, JY5325CoreOO::JY5325CoreOOAOTask, JY5325CoreOO::JY5325CoreOOCITask, JY5325CoreOO::JY5325CoreOOCOTask, JY5325CoreOO::JY5325CoreOODITask, JY5325CoreOO::JY5325CoreOODOTask
  • Trigger : JY5325CoreOO::JY5325CoreOOAITask, JY5325CoreOO::JY5325CoreOOAOTask, JY5325CoreOO::JY5325CoreOOCITask, JY5325CoreOO::JY5325CoreOOCOTask, JY5325CoreOO::JY5325CoreOODITask, JY5325CoreOO::JY5325CoreOODOTask
  • TriggerRouting : JY5325CoreOO::AISync
  • TwoEdgeSeparation : JY5325CoreOO::JY5325CoreOOCITask
  • TwoPulseEncoder : JY5325CoreOO::JY5325CoreOOCITask
  • Type : JY5325CoreOO::AITrigger, JY5325CoreOO::AOTrigger, JY5325CoreOO::CITrigger, JY5325CoreOO::COTrigger, JY5325CoreOO::DITrigger, JY5325CoreOO::DOTrigger, JY5325CoreOO::JY5325CoreOOCITask


5325 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- u -

  • UpdateRate : JY5325CoreOO::JY5325CoreOOAOTask, JY5325CoreOO::JY5325CoreOODOTask


5325 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- w -

  • Window : JY5325CoreOO::AIAnalogTrigger


5325 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- z -

  • ZInputTerminal : JY5325CoreOO::QuadEncoder
  • ZReloadEnabled : JY5325CoreOO::QuadEncoder


5325 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- w -

  • WaitUntilDone() : JY5325CoreOO::JY5325CoreOOAITask, JY5325CoreOO::JY5325CoreOOAOTask, JY5325CoreOO::JY5325CoreOOCOTask, JY5325CoreOO::JY5325CoreOODOTask
  • Window : JY5325CoreOO::AIAnalogTrigger
  • WriteData() : JY5325CoreOO::JY5325CoreOOAOTask, JY5325CoreOO::JY5325CoreOOCOTask, JY5325CoreOO::JY5325CoreOODOTask
  • WriteRawData() : JY5325CoreOO::JY5325CoreOOAOTask
  • WriteRawSinglePoint() : JY5325CoreOO::JY5325CoreOOAOTask
  • WriteSinglePoint() : JY5325CoreOO::JY5325CoreOOAOTask, JY5325CoreOO::JY5325CoreOOCOTask, JY5325CoreOO::JY5325CoreOODOTask


5325 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- z -

  • ZInputTerminal : JY5325CoreOO::QuadEncoder
  • ZReloadEnabled : JY5325CoreOO::QuadEncoder


5325 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- ~ -

  • ~JY5325CoreOOAITask() : JY5325CoreOO::JY5325CoreOOAITask
  • ~JY5325CoreOOAOTask() : JY5325CoreOO::JY5325CoreOOAOTask
  • ~JY5325CoreOOCITask() : JY5325CoreOO::JY5325CoreOOCITask
  • ~JY5325CoreOOCOTask() : JY5325CoreOO::JY5325CoreOOCOTask
  • ~JY5325CoreOODITask() : JY5325CoreOO::JY5325CoreOODITask
  • ~JY5325CoreOODOTask() : JY5325CoreOO::JY5325CoreOODOTask


5325 C++ Programming Manual: File Members

  • File List
  • File Members
  • All
  • Macros
Here is a list of all file members with links to the files they belong to:
  • EXTERN_C : JY5325CoreOOCommon.h
  • JY5325CoreOO_API : JY5325CoreOOCommon.h


5325 C++ Programming Manual: File Members

  • File List
  • File Members
  • All
  • Macros
Here is a list of all macros with links to the files they belong to:
  • EXTERN_C : JY5325CoreOOCommon.h
  • JY5325CoreOO_API : JY5325CoreOOCommon.h


5325 C++ Programming Manual: Main Page

5325 C++ Programming Manual Documentation


5325 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • l
  • o
  • p
  • q
  • r
  • s
  • v
Here is a list of all namespace members with links to the namespace documentation for each member:

- a -

  • AIAnalogTriggerComparator : JY5325CoreOO
  • AIAnalogTriggerEdge : JY5325CoreOO
  • AIAnalogTriggerSource : JY5325CoreOO
  • AIAnalogWindowCondition : JY5325CoreOO
  • AIDigitalTriggerEdge : JY5325CoreOO
  • AIDigitalTriggerSource : JY5325CoreOO
  • AIMode : JY5325CoreOO
  • AISampleClockSource : JY5325CoreOO
  • AISignalExportSource : JY5325CoreOO
  • AITriggerMode : JY5325CoreOO
  • AITriggerType : JY5325CoreOO
  • AODigitalTriggerEdge : JY5325CoreOO
  • AODigitalTriggerSource : JY5325CoreOO
  • AOMode : JY5325CoreOO
  • AOSampleClockSource : JY5325CoreOO
  • AOSignalExportSource : JY5325CoreOO
  • AOTriggerType : JY5325CoreOO

- c -

  • CIDigitalTriggerEdge : JY5325CoreOO
  • CIDigitalTriggerSource : JY5325CoreOO
  • CIMode : JY5325CoreOO
  • CISampleClockSource : JY5325CoreOO
  • CISignalExportSource : JY5325CoreOO
  • CITimebaseSource : JY5325CoreOO
  • CITriggerType : JY5325CoreOO
  • CIType : JY5325CoreOO
  • ClockTerminal : JY5325CoreOO
  • CODigitalTriggerEdge : JY5325CoreOO
  • CODigitalTriggerSource : JY5325CoreOO
  • COIdleState : JY5325CoreOO
  • COMode : JY5325CoreOO
  • COPulseType : JY5325CoreOO
  • COSignalExportSource : JY5325CoreOO
  • COTimebaseSource : JY5325CoreOO
  • COTriggerType : JY5325CoreOO
  • CountDirection : JY5325CoreOO

- d -

  • DIDigitalTriggerEdge : JY5325CoreOO
  • DIDigitalTriggerSource : JY5325CoreOO
  • DIMode : JY5325CoreOO
  • DISampleClockSource : JY5325CoreOO
  • DISignalExportSource : JY5325CoreOO
  • DITriggerMode : JY5325CoreOO
  • DITriggerType : JY5325CoreOO
  • DODigitalTriggerEdge : JY5325CoreOO
  • DODigitalTriggerSource : JY5325CoreOO
  • DOMode : JY5325CoreOO
  • DOSampleClockSource : JY5325CoreOO
  • DOSignalExportSource : JY5325CoreOO
  • DOTriggerType : JY5325CoreOO

- e -

  • EdgeCntOunEvtIdleState : JY5325CoreOO
  • EdgeType : JY5325CoreOO
  • ExternalReferenceClockTerminal : JY5325CoreOO

- f -

  • FileFormat : JY5325CoreOO

- g -

  • GetSignalExportDestinationString() : JY5325CoreOO

- i -

  • InputTerminal : JY5325CoreOO
  • IOTerminal : JY5325CoreOO

- j -

  • JY5325CoreOOLogLevel : JY5325CoreOO
  • JY5325CoreOOPropertyType : JY5325CoreOO
  • JYDriverExceptionPublic : JY5325CoreOO
  • JYErrorCode : JY5325CoreOO

- l -

  • LevelPolarity : JY5325CoreOO

- o -

  • OutputCompleteState : JY5325CoreOO

- p -

  • PFITerminal : JY5325CoreOO

- q -

  • QuadEncodingType : JY5325CoreOO

- r -

  • RecordMode : JY5325CoreOO
  • ReferenceClockSource : JY5325CoreOO

- s -

  • SignalExportDestination : JY5325CoreOO
  • SyncTopology : JY5325CoreOO
  • SyncTriggerRouting : JY5325CoreOO

- v -

  • ValueReturnMode : JY5325CoreOO


5325 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • a
  • c
  • d
  • e
  • f
  • i
  • j
  • l
  • o
  • p
  • q
  • r
  • s
  • v
Here is a list of all namespace enums with links to the namespace documentation for each enum:

- a -

  • AIAnalogTriggerComparator : JY5325CoreOO
  • AIAnalogTriggerEdge : JY5325CoreOO
  • AIAnalogTriggerSource : JY5325CoreOO
  • AIAnalogWindowCondition : JY5325CoreOO
  • AIDigitalTriggerEdge : JY5325CoreOO
  • AIDigitalTriggerSource : JY5325CoreOO
  • AIMode : JY5325CoreOO
  • AISampleClockSource : JY5325CoreOO
  • AISignalExportSource : JY5325CoreOO
  • AITriggerMode : JY5325CoreOO
  • AITriggerType : JY5325CoreOO
  • AODigitalTriggerEdge : JY5325CoreOO
  • AODigitalTriggerSource : JY5325CoreOO
  • AOMode : JY5325CoreOO
  • AOSampleClockSource : JY5325CoreOO
  • AOSignalExportSource : JY5325CoreOO
  • AOTriggerType : JY5325CoreOO

- c -

  • CIDigitalTriggerEdge : JY5325CoreOO
  • CIDigitalTriggerSource : JY5325CoreOO
  • CIMode : JY5325CoreOO
  • CISampleClockSource : JY5325CoreOO
  • CISignalExportSource : JY5325CoreOO
  • CITimebaseSource : JY5325CoreOO
  • CITriggerType : JY5325CoreOO
  • CIType : JY5325CoreOO
  • ClockTerminal : JY5325CoreOO
  • CODigitalTriggerEdge : JY5325CoreOO
  • CODigitalTriggerSource : JY5325CoreOO
  • COIdleState : JY5325CoreOO
  • COMode : JY5325CoreOO
  • COPulseType : JY5325CoreOO
  • COSignalExportSource : JY5325CoreOO
  • COTimebaseSource : JY5325CoreOO
  • COTriggerType : JY5325CoreOO
  • CountDirection : JY5325CoreOO

- d -

  • DIDigitalTriggerEdge : JY5325CoreOO
  • DIDigitalTriggerSource : JY5325CoreOO
  • DIMode : JY5325CoreOO
  • DISampleClockSource : JY5325CoreOO
  • DISignalExportSource : JY5325CoreOO
  • DITriggerMode : JY5325CoreOO
  • DITriggerType : JY5325CoreOO
  • DODigitalTriggerEdge : JY5325CoreOO
  • DODigitalTriggerSource : JY5325CoreOO
  • DOMode : JY5325CoreOO
  • DOSampleClockSource : JY5325CoreOO
  • DOSignalExportSource : JY5325CoreOO
  • DOTriggerType : JY5325CoreOO

- e -

  • EdgeCntOunEvtIdleState : JY5325CoreOO
  • EdgeType : JY5325CoreOO
  • ExternalReferenceClockTerminal : JY5325CoreOO

- f -

  • FileFormat : JY5325CoreOO

- i -

  • InputTerminal : JY5325CoreOO
  • IOTerminal : JY5325CoreOO

- j -

  • JY5325CoreOOLogLevel : JY5325CoreOO
  • JY5325CoreOOPropertyType : JY5325CoreOO
  • JYDriverExceptionPublic : JY5325CoreOO
  • JYErrorCode : JY5325CoreOO

- l -

  • LevelPolarity : JY5325CoreOO

- o -

  • OutputCompleteState : JY5325CoreOO

- p -

  • PFITerminal : JY5325CoreOO

- q -

  • QuadEncodingType : JY5325CoreOO

- r -

  • RecordMode : JY5325CoreOO
  • ReferenceClockSource : JY5325CoreOO

- s -

  • SignalExportDestination : JY5325CoreOO
  • SyncTopology : JY5325CoreOO
  • SyncTriggerRouting : JY5325CoreOO

- v -

  • ValueReturnMode : JY5325CoreOO


5325 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
Here is a list of all namespace functions with links to the namespace documentation for each function:
  • GetSignalExportDestinationString() : JY5325CoreOO


5325 C++ Programming Manual: Namespace List

  • Namespace List
  • Namespace Members
Namespace List
Here is a list of all namespaces with brief descriptions:
N JY5325CoreOO