5325 C# Programming Manual: D:/5325/C# Directory Reference

5325 C# Programming Manual
55325 C# Programming Manual
  • Main Page
  • Packages
  • Classes
  • Files
  • File List
  • 5325
  • C#
C# Directory Reference

Files

JY5325AITask.cs
JY5325AOTask.cs
JY5325CITask.cs
JY5325COTask.cs
JY5325DITask.cs
JY5325DOTask.cs
Generated by doxygen 1.12.0


5325 C# Programming Manual: D:/5325/C#/JY5325AITask.cs File Reference

  • Packages
  • Classes
  • Files
  • File List
  • 5325
  • C#
Classes | Namespaces | Enumerations
JY5325AITask.cs File Reference

Classes

class | JY5325.JY5325AITask
JY5325 Analog Input Task. More...
class | JY5325.AIChannel
AI Channel parameter class. More...
class | JY5325.AIAnalogHysteresisComparator
AI Analog Hysteresis Comparatorr. More...
class | JY5325.AIAnalogWindowComparator
AI Analog Window Comparatorr. More...
class | JY5325.AIAnalogEdgeComparator
AI Analog Edge Comparator. More...
class | JY5325.AISampleClock
Sample clock configuration class. More...
class | JY5325.AITrigger
AI Trigger class. More...
class | JY5325.AIDigitalTrigger
AI Digital Trigger. More...
class | JY5325.AIAnalogTrigger
AI Analog Trigger. More...
class | JY5325.AIRecord
AI Record class. More...
class | JY5325.AISync
Configure sync signal. More...
class | JY5325.AISignalExport
AI Signal Export Class. More...

Namespaces

namespace JY5325

Enumerations

enum | JY5325.AITriggerType { JY5325.Immediate = JY5325Import.JY5325_AI_Immediately , JY5325.Digital = JY5325Import.JY5325_AI_Digital , JY5325.Analog = JY5325Import.JY5325_AI_Analog , JY5325.Soft = JY5325Import.JY5325_AI_Soft }
Trigger Type: Digital/Analog/Immediate. More...
enum | JY5325.AIDigitalTriggerEdge { JY5325.Rising = JY5325Import.JY5325_Rising , JY5325.Falling = JY5325Import.JY5325_Falling }
AI Digital Trigger Edge. More...
enum | JY5325.AIAnalogTriggerEdge { JY5325.Rising , JY5325.Falling }
AI Analog Trigger Edge. More...
enum | JY5325.AIAnalogWindowCondition { JY5325.Entering , JY5325.Leaving }
AI Analog Window Trigger Condition. More...
enum | JY5325.AIAnalogTriggerComparator { JY5325.Edge , JY5325.Hysteresis , JY5325.Window }
AI Analog Trigger Comparator. More...
enum | JY5325.AIMode { JY5325.Finite = JY5325Import.JY5325_AI_Finite , JY5325.Continuous = JY5325Import.JY5325_AI_Continuous , JY5325.Record = 0x3 }
AIMode. More...
enum | JY5325.AISampleClockSource { JY5325.Internal = JY5325Import.JY5325_InternalClock }
AIClockSource Type. More...
enum JY5325.ClockTerminal {
JY5325.PFI0 = JY5325Import.JY5325_Clock_PFI_0 , JY5325.PFI1 = JY5325Import.JY5325_Clock_PFI_1 , JY5325.PFI2 = JY5325Import.JY5325_Clock_PFI_2 , JY5325.PFI3 = JY5325Import.JY5325_Clock_PFI_3 ,
JY5325.PFI4 = JY5325Import.JY5325_Clock_PFI_4 , JY5325.PFI5 = JY5325Import.JY5325_Clock_PFI_5 , JY5325.PFI6 = JY5325Import.JY5325_Clock_PFI_6 , JY5325.PFI7 = JY5325Import.JY5325_Clock_PFI_7 ,
JY5325.PXI_Trig0 = JY5325Import.JY5325_Clock_PXI_Trig_0 , JY5325.PXI_Trig1 = JY5325Import.JY5325_Clock_PXI_Trig_1 , JY5325.PXI_Trig2 = JY5325Import.JY5325_Clock_PXI_Trig_2 , JY5325.PXI_Trig3 = JY5325Import.JY5325_Clock_PXI_Trig_3 ,
JY5325.PXI_Trig4 = JY5325Import.JY5325_Clock_PXI_Trig_4 , JY5325.PXI_Trig5 = JY5325Import.JY5325_Clock_PXI_Trig_5 , JY5325.PXI_Trig6 = JY5325Import.JY5325_Clock_PXI_Trig_6 , JY5325.PXI_Trig7 = JY5325Import.JY5325_Clock_PXI_Trig_7 ,
JY5325.DI_SampleClock = JY5325Import.JY5325_Inter_Clock_DI_SampleClock , JY5325.DO_SampleClock = JY5325Import.JY5325_Inter_Clock_DO_SampleClock , JY5325.CI_0_SampleClock = JY5325Import.JY5325_Inter_CI_0_SampleClock , JY5325.CI_1_SampleClock = JY5325Import.JY5325_Inter_CI_1_SampleClock ,
JY5325.CO_0_Output = JY5325Import.JY5325_Inter_CO_0_Output , JY5325.CO_1_Output = JY5325Import.JY5325_Inter_CO_1_Output
}
External Sample Clock Terminal. More...
enum | JY5325.AITriggerMode { JY5325.Start , JY5325.Reference }
AI Trigger Mode. More...
enum JY5325.AIAnalogTriggerSource {
JY5325.Channel_0 , JY5325.Channel_1 , JY5325.Channel_2 , JY5325.Channel_3 ,
JY5325.Channel_4 , JY5325.Channel_5 , JY5325.Channel_6 , JY5325.Channel_7
}
AI Analog Trigger Source. More...
enum JY5325.AIDigitalTriggerSource {
JY5325.PFI0 = JY5325Import.JY5325_PFI0 , JY5325.PFI1 = JY5325Import.JY5325_PFI1 , JY5325.PFI2 = JY5325Import.JY5325_PFI2 , JY5325.PFI3 = JY5325Import.JY5325_PFI3 ,
JY5325.PFI4 = JY5325Import.JY5325_PFI4 , JY5325.PFI5 = JY5325Import.JY5325_PFI5 , JY5325.PFI6 = JY5325Import.JY5325_PFI6 , JY5325.PFI7 = JY5325Import.JY5325_PFI7 ,
JY5325.PXI_Trig0 = JY5325Import.JY5325_PXI_Trig0 , JY5325.PXI_Trig1 = JY5325Import.JY5325_PXI_Trig1 , JY5325.PXI_Trig2 = JY5325Import.JY5325_PXI_Trig2 , JY5325.PXI_Trig3 = JY5325Import.JY5325_PXI_Trig3 ,
JY5325.PXI_Trig4 = JY5325Import.JY5325_PXI_Trig4 , JY5325.PXI_Trig5 = JY5325Import.JY5325_PXI_Trig5 , JY5325.PXI_Trig6 = JY5325Import.JY5325_PXI_Trig6 , JY5325.PXI_Trig7 = JY5325Import.JY5325_PXI_Trig7 ,
JY5325.AO_StartTrig = JY5325Import.JY5325_Inter_AO_StartTrig , JY5325.DI_StartTrig = JY5325Import.JY5325_Inter_DI_StartTrig , JY5325.DI_ReferenceTrig = JY5325Import.JY5325_Inter_DI_ReferenceTrig , JY5325.DO_StartTrig = JY5325Import.JY5325_Inter_DO_StartTrig ,
JY5325.CIO_0_StartTrig = JY5325Import.JY5325_Inter_Counter_0_StartTrig , JY5325.CIO_1_StartTrig = JY5325Import.JY5325_Inter_Counter_1_StartTrig , JY5325.CO_0_Out = JY5325Import.JY5325_Inter_Counter_0_Out , JY5325.CO_1_Out = JY5325Import.JY5325_Inter_Counter_1_Out
}
AI Digital Trigger Source. More...
enum | JY5325.FileFormat { JY5325.Bin }
Streaming file format. More...
enum | JY5325.RecordMode { JY5325.Finite , JY5325.Infinite }
Two stream mode from enum Finite/Infinite. More...
enum | JY5325.SyncTopology { JY5325.Independent , JY5325.Master , JY5325.Slave }
Synchronization board configuration. More...
enum JY5325.SyncTriggerRouting {
JY5325.NONE = -1 , JY5325.PFI0 = JY5325Import.JY5325_PFI0_Input , JY5325.PFI1 = JY5325Import.JY5325_PFI1_Input , JY5325.PFI2 = JY5325Import.JY5325_PFI2_Input ,
JY5325.PFI3 = JY5325Import.JY5325_PFI3_Input , JY5325.PFI4 = JY5325Import.JY5325_PFI4_Input , JY5325.PFI5 = JY5325Import.JY5325_PFI5_Input , JY5325.PFI6 = JY5325Import.JY5325_PFI6_Input ,
JY5325.PFI7 = JY5325Import.JY5325_PFI7_Input , JY5325.PXI_Trig0 = JY5325Import.JY5325_PXI_Trig0_Input , JY5325.PXI_Trig1 = JY5325Import.JY5325_PXI_Trig1_Input , JY5325.PXI_Trig2 = JY5325Import.JY5325_PXI_Trig2_Input ,
JY5325.PXI_Trig3 = JY5325Import.JY5325_PXI_Trig3_Input , JY5325.PXI_Trig4 = JY5325Import.JY5325_PXI_Trig4_Input , JY5325.PXI_Trig5 = JY5325Import.JY5325_PXI_Trig5_Input , JY5325.PXI_Trig6 = JY5325Import.JY5325_PXI_Trig6_Input ,
JY5325.PXI_Trig7 = JY5325Import.JY5325_PXI_Trig7_Input
}
Master card trigger signal routing (Master card routes trigger signal to this port) More...
enum JY5325.AISignalExportSource {
JY5325.StartTrig = JY5325Import.JY5325_Signal_AI_StartTrig , JY5325.ReferenceTrig = JY5325Import.JY5325_Signal_AI_ReferenceTrig , JY5325.Internal_Counter_100K = JY5325Import.JY5325_Signal_CIO_100kHz , JY5325.Internal_Counter_5M = JY5325Import.JY5325_Signal_CIO_5MHz ,
JY5325.Internal_Counter_100M = JY5325Import.JY5325_Signal_CIO_100MHz
}
AI Signal Export Source. More...
enum JY5325.SignalExportDestination {
JY5325.PFI0 = JY5325Import.JY5325_PFI0_OUT , JY5325.PFI1 = JY5325Import.JY5325_PFI1_OUT , JY5325.PFI2 = JY5325Import.JY5325_PFI2_OUT , JY5325.PFI3 = JY5325Import.JY5325_PFI3_OUT ,
JY5325.PFI4 = JY5325Import.JY5325_PFI4_OUT , JY5325.PFI5 = JY5325Import.JY5325_PFI5_OUT , JY5325.PFI6 = JY5325Import.JY5325_PFI6_OUT , JY5325.PFI7 = JY5325Import.JY5325_PFI7_OUT ,
JY5325.PXI_Trig0 = JY5325Import.JY5325_PXITrig0_OUT , JY5325.PXI_Trig1 = JY5325Import.JY5325_PXITrig1_OUT , JY5325.PXI_Trig2 = JY5325Import.JY5325_PXITrig2_OUT , JY5325.PXI_Trig3 = JY5325Import.JY5325_PXITrig3_OUT ,
JY5325.PXI_Trig4 = JY5325Import.JY5325_PXITrig4_OUT , JY5325.PXI_Trig5 = JY5325Import.JY5325_PXITrig5_OUT , JY5325.PXI_Trig6 = JY5325Import.JY5325_PXITrig6_OUT , JY5325.PXI_Trig7 = JY5325Import.JY5325_PXITrig7_OUT
}
Output DestinationTerminal. More...


5325 C# Programming Manual: JY5325.JY5325AITask Class Reference

  • Class List
  • Class Index
  • Class Members
  • JY5325
  • JY5325AITask
Public Member Functions | Properties | List of all members
JY5325.JY5325AITask Class Referencesealed

JY5325 Analog Input Task. More...

Public Member Functions

JY5325AITask (int slotNum)
Constructor.
JY5325AITask (string boardName)
Constructor.
void | AddChannel (int chnId, double rangeLow=-10, double rangeHigh=10)
Add one channel.
void | AddChannel (int[] chnsId, double rangeLow=-10, double rangeHigh=10)
Add a group of channels.
void | AddChannel (int[] chnsId, double[] rangeLow, double[] rangeHigh)
Add a group of channels, each channel range can be set differently.
void | RemoveChannel (int chnId)
Delete the channel with the specified channel number.
void | ReadData (IntPtr buf, int samplesPerChannel, int timeout=10000)
Read one or multi-channel data by columns and store it in a data buffer.
void | ReadData (ref double[,] buf, int samplesPerChannel, int timeout=10000)
Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.
void | ReadData (ref double[,] buf, int timeout=10000)
Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.
void | ReadData (ref double[] buf, int samplesPerChannel, int timeout=10000)
Read the one channel data and store it in a data buffer.
void | ReadData (ref double[] buf, int timeout=10000)
Read the one channel data and store it in a data buffer.
void | ReadRawData (IntPtr buf, int samplesPerChannel, int timeout=10000)
Read one or multi-channel raw data by columns and store it in a data buffer.
void | ReadRawData (ref short[,] buf, int samplesPerChannel, int timeout=10000)
Read the multi-channel raw data by columns and store it in a data buffer,Each channel is represented by one column of data.
void | ReadRawData (ref short[,] buf, int timeout=10000)
Read the multi-channel raw data by columns and store it in a data buffer,Each channel is represented by one column of data.
void | ReadRawData (ref short[] buf, int samplesPerChannel, int timeout=10000)
Read the one channel raw data and store it in a data buffer.
void | ReadRawData (ref short[] buf, int timeout=10000)
Read the one channel raw data and store it in a data buffer.
void | GetRecordPreviewData (ref double[,] buf, int samplesPerChannel, int timeout=1000)
Preview multi-channel data when streaming is in progress.
void | GetRecordPreviewData (ref double[,] buf, int timeout=1000)
Preview multi-channel data when streaming is in progress.
void | GetRecordPreviewData (ref double[] buf, int samplesPerChannel, int timeout=1000)
Preview one channel data when streaming is in progress.
void | GetRecordPreviewData (ref double[] buf, int timeout=1000)
Preview one channel data when streaming is in progress.
void | GetRecordStatus (out double recordedLength, out bool recordDone)
Get the streaming status.
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.
void | Start ()
Start AITask.
void | SendSoftwareTrigger ()
Generate a software trigger signal generate a software trigger signal.
void | Stop ()
Stop AI Task.

Properties

JY5325Device | Device [get]
Device Handle.
List< AIChannel > | Channels [get]
List of AI channels,support 16 Different.
AIMode | Mode [get, set]
AI acquisition mode，support Finite/Continuous/Record.
double | SampleRate [get, set]
Sample rate per channel.
int | SamplesToAcquire [get, set]
Number of samples to be read per channel.
int | BufLenInSamples [get]
Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.
ulong | AvailableSamples [get]
Number of samples per channel that can be read in the buffer.
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel).
AISampleClock | SampleClock [get, set]
AI Sample Clock Configuration.
AITrigger | Trigger [get, set]
时钟沿。仅在外部时钟时有效。
AIRecord | Record = new AIRecord() [get]
Data streaming Configuration.
bool | DisableCalibration [get, set]
Disalble calibration.
AISync | Sync [get]
Multi card synchronous configuration.
AISignalExport | SignalExport [get, set]
Export AI Signal Configuration.
bool | DisableDigitalTriggerDelay [get, set]
Disable DigitalTrigger Delay.

Detailed Description

JY5325 Analog Input Task.

Constructor & Destructor Documentation

◆ JY5325AITask() [1/2]

JY5325.JY5325AITask.JY5325AITask ( int slotNum )

Constructor.

Used to create an AI task by a slot number

Parameters
slotNum Card slot number.

◆ JY5325AITask() [2/2]

JY5325.JY5325AITask.JY5325AITask ( string boardName )

Constructor.

Used to create an AI task by a board name.

Parameters
boardName Board name(device alias), set by device manager

Member Function Documentation

◆ AddChannel() [1/3]

void JY5325.JY5325AITask.AddChannel | ( | int | chnId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10 )

Add one channel.

Parameters
chnId | channel's physical number ，chnId=-1, add all channels
rangeLow | lower range limit for the channel，-10V,-5V,-2V，-1V,default -10
rangeHigh | higher range limit for the channel,10V,5V,2V，1V,default 10

◆ AddChannel() [2/3]

void JY5325.JY5325AITask.AddChannel | ( | int[] | chnsId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10 )

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers
rangeLow | lower range limit for the channel，-10V,-5V,-2V，-1V,default -10
rangeHigh | higher range limit for the channel,10V,5V,2V，1V,default 10

◆ AddChannel() [3/3]

void JY5325.JY5325AITask.AddChannel | ( | int[] | chnsId,
 |  | double[] | rangeLow,
 |  | double[] | rangeHigh )

Add a group of channels, each channel range can be set differently.

Parameters
chnsId | a group of channel physical numbers,different mode 0-15
rangeLow | lower range limit for the channel，-10V,-5V,-2V，-1V
rangeHigh | higher range limit for the channel,10V,5V,2V，1V

◆ GetRecordPreviewData() [1/4]

void JY5325.JY5325AITask.GetRecordPreviewData | ( | ref double | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout = 1000 )

Preview multi-channel data when streaming is in progress.

Each column represents one channel.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ GetRecordPreviewData() [2/4]

void JY5325.JY5325AITask.GetRecordPreviewData | ( | ref double | buf[,],
 |  | int | timeout = 1000 )

Preview multi-channel data when streaming is in progress.

Each column represents one channel.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms
Returns

◆ GetRecordPreviewData() [3/4]

void JY5325.JY5325AITask.GetRecordPreviewData | ( | ref double[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 1000 )

Preview one channel data when streaming is in progress.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ GetRecordPreviewData() [4/4]

void JY5325.JY5325AITask.GetRecordPreviewData | ( | ref double[] | buf,
 |  | int | timeout = 1000 )

Preview one channel data when streaming is in progress.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms

◆ GetRecordStatus()

void JY5325.JY5325AITask.GetRecordStatus | ( | out double | recordedLength,
 |  | out bool | recordDone )

Get the streaming status.

Parameters
recordedLength | Length of the streamed, unit s
recordDone | recordDone = false :streaming is not over.recordDone = true :streaming is over

◆ ReadData() [1/5]

void JY5325.JY5325AITask.ReadData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Read one or multi-channel data by columns and store it in a data buffer.

The buffer is pointed by C# data type IntPtr.

param name="buf">Data buffer

Parameters
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish

◆ ReadData() [2/5]

void JY5325.JY5325AITask.ReadData | ( | ref double | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.

param name="buf">Data buffer

Parameters
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish

◆ ReadData() [3/5]

void JY5325.JY5325AITask.ReadData | ( | ref double | buf[,],
 |  | int | timeout = 10000 )

Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.

param name="buf">Data buffer

Parameters
timeout timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish

◆ ReadData() [4/5]

void JY5325.JY5325AITask.ReadData | ( | ref double[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Read the one channel data and store it in a data buffer.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ ReadData() [5/5]

void JY5325.JY5325AITask.ReadData | ( | ref double[] | buf,
 |  | int | timeout = 10000 )

Read the one channel data and store it in a data buffer.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [1/5]

void JY5325.JY5325AITask.ReadRawData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Read one or multi-channel raw data by columns and store it in a data buffer.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [2/5]

void JY5325.JY5325AITask.ReadRawData | ( | ref short | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Read the multi-channel raw data by columns and store it in a data buffer,Each channel is represented by one column of data.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [3/5]

void JY5325.JY5325AITask.ReadRawData | ( | ref short | buf[,],
 |  | int | timeout = 10000 )

Read the multi-channel raw data by columns and store it in a data buffer,Each channel is represented by one column of data.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [4/5]

void JY5325.JY5325AITask.ReadRawData | ( | ref short[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Read the one channel raw data and store it in a data buffer.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [5/5]

void JY5325.JY5325AITask.ReadRawData | ( | ref short[] | buf,
 |  | int | timeout = 10000 )

Read the one channel raw data and store it in a data buffer.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms

◆ RemoveChannel()

void JY5325.JY5325AITask.RemoveChannel ( int chnId )

Delete the channel with the specified channel number.

chnId=- 1, all channels will be deleted

Parameters
chnId Channel number of the channel to be deleted

◆ SendSoftwareTrigger()

void JY5325.JY5325AITask.SendSoftwareTrigger ( )

Generate a software trigger signal generate a software trigger signal.

Returns

◆ Start()

void JY5325.JY5325AITask.Start ( )

Start AITask.

◆ Stop()

void JY5325.JY5325AITask.Stop ( )

Stop AI Task.

◆ WaitUntilDone()

bool JY5325.JY5325AITask.WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate
Returns
True: task end, false: timeout

Property Documentation

◆ AvailableSamples

ulong JY5325.JY5325AITask.AvailableSamples
get

Number of samples per channel that can be read in the buffer.

◆ BufLenInSamples

int JY5325.JY5325AITask.BufLenInSamples
get

Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.

◆ Channels

List<AIChannel> JY5325.JY5325AITask.Channels
get

List of AI channels,support 16 Different.

◆ Device

JY5325Device JY5325.JY5325AITask.Device
get

Device Handle.

◆ DisableCalibration

bool JY5325.JY5325AITask.DisableCalibration
getset

Disalble calibration.

◆ DisableDigitalTriggerDelay

bool JY5325.JY5325AITask.DisableDigitalTriggerDelay
getset

Disable DigitalTrigger Delay.

◆ Mode

AIMode JY5325.JY5325AITask.Mode
getset

AI acquisition mode，support Finite/Continuous/Record.

◆ Record

AIRecord JY5325.JY5325AITask.Record = new AIRecord()
get

Data streaming Configuration.

◆ SampleClock

AISampleClock JY5325.JY5325AITask.SampleClock
getset

AI Sample Clock Configuration.

◆ SampleRate

double JY5325.JY5325AITask.SampleRate
getset

Sample rate per channel.

Maximum sample rate is 5M The defalut sample rate = 100k You can read this property to obtain the sample rate that will actually take effect in the current configuration.

◆ SamplesToAcquire

int JY5325.JY5325AITask.SamplesToAcquire
getset

Number of samples to be read per channel.

Only valid when Mode is AIMode.Finite.

◆ SignalExport

AISignalExport JY5325.JY5325AITask.SignalExport
getset

Export AI Signal Configuration.

◆ Sync

AISync JY5325.JY5325AITask.Sync
get

Multi card synchronous configuration.

◆ TransferedSamples

ulong JY5325.JY5325AITask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

◆ Trigger

AITrigger JY5325.JY5325AITask.Trigger
getset

时钟沿。仅在外部时钟时有效。

AI Trigger Configuration

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325AITask.cs


5325 C# Programming Manual: JY5325.AIChannel Class Reference

  • JY5325
  • AIChannel
Public Member Functions | Properties | List of all members
JY5325.AIChannel Class Referencesealed

AI Channel parameter class. More...

Public Member Functions

AIChannel (int channelId, double rangeLow, double rangeHigh)
Constructor to create an AIChnParam task object.

Properties

int | ChannelID [get]
AI channel ID.
double | RangeLow [get, set]
Low range limit an AI channel，-10V,-5V,-2V，-1V.
double | RangeHigh [get, set]
High range limit an AI channel，10V,5V,2V，1V.

Detailed Description

AI Channel parameter class.

Constructor & Destructor Documentation

◆ AIChannel()

JY5325.AIChannel.AIChannel | ( | int | channelId,
 |  | double | rangeLow,
 |  | double | rangeHigh )

Constructor to create an AIChnParam task object.

Parameters
channelId | AI channel ID.
rangeLow | Low range limit an AI channel.
rangeHigh | High range limit an AI channel.

Property Documentation

◆ ChannelID

int JY5325.AIChannel.ChannelID
get

AI channel ID.

◆ RangeHigh

double JY5325.AIChannel.RangeHigh
getset

High range limit an AI channel，10V,5V,2V，1V.

◆ RangeLow

double JY5325.AIChannel.RangeLow
getset

Low range limit an AI channel，-10V,-5V,-2V，-1V.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325AITask.cs


5325 C# Programming Manual: JY5325.AIAnalogHysteresisComparator Class Reference

  • AIAnalogHysteresisComparator
Public Attributes | Properties | List of all members
JY5325.AIAnalogHysteresisComparator Class Reference

AI Analog Hysteresis Comparatorr. More...

Public Attributes

double | HighThreshold
High Threshold.
double | LowThreshold
Low Threshold.

Properties

AIAnalogTriggerEdge Slope [get, set]
AI Analog Trigger Edge.

Detailed Description

AI Analog Hysteresis Comparatorr.

Member Data Documentation

◆ HighThreshold

double JY5325.AIAnalogHysteresisComparator.HighThreshold

High Threshold.

◆ LowThreshold

double JY5325.AIAnalogHysteresisComparator.LowThreshold

Low Threshold.

Property Documentation

◆ Slope

AIAnalogTriggerEdge JY5325.AIAnalogHysteresisComparator.Slope
getset

AI Analog Trigger Edge.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325AITask.cs


5325 C# Programming Manual: JY5325.AIAnalogWindowComparator Class Reference

  • AIAnalogWindowComparator
Public Attributes | Properties | List of all members
JY5325.AIAnalogWindowComparator Class Reference

AI Analog Window Comparatorr. More...

Public Attributes

double | HighThreshold
High Threshold.
double | LowThreshold
Low Threshold.

Properties

AIAnalogWindowCondition Condition [get, set]
AI Analog Window Condition.

Detailed Description

AI Analog Window Comparatorr.

Member Data Documentation

◆ HighThreshold

double JY5325.AIAnalogWindowComparator.HighThreshold

High Threshold.

◆ LowThreshold

double JY5325.AIAnalogWindowComparator.LowThreshold

Low Threshold.

Property Documentation

◆ Condition

AIAnalogWindowCondition JY5325.AIAnalogWindowComparator.Condition
getset

AI Analog Window Condition.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325AITask.cs


5325 C# Programming Manual: JY5325.AIAnalogEdgeComparator Class Reference

  • AIAnalogEdgeComparator
Public Attributes | Properties | List of all members
JY5325.AIAnalogEdgeComparator Class Reference

AI Analog Edge Comparator. More...

Public Attributes

double Threshold
Threshold.

Properties

AIAnalogTriggerEdge Slope [get, set]
AI Analog Trigger Edge.

Detailed Description

AI Analog Edge Comparator.

Member Data Documentation

◆ Threshold

double JY5325.AIAnalogEdgeComparator.Threshold

Threshold.

Property Documentation

◆ Slope

AIAnalogTriggerEdge JY5325.AIAnalogEdgeComparator.Slope
getset

AI Analog Trigger Edge.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325AITask.cs


5325 C# Programming Manual: JY5325.AISampleClock Class Reference

  • AISampleClock
Properties | List of all members
JY5325.AISampleClock Class Reference

Sample clock configuration class. More...

Properties

AISampleClockSource Source [get, set]
Clock Source.

Detailed Description

Sample clock configuration class.

Property Documentation

◆ Source

AISampleClockSource JY5325.AISampleClock.Source
getset

Clock Source.

enum Internal/External,The default value is AISampleClockSource.Internal.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325AITask.cs


5325 C# Programming Manual: JY5325.AITrigger Class Reference

  • AITrigger
Properties | List of all members
JY5325.AITrigger Class Referencesealed

AI Trigger class. More...

Properties

AITriggerType | Type [get, set]
AI Trigger Type,enum Analog/Digital/Immediate/Soft.
AITriggerMode | Mode [get, set]
AI Trigger Mode.
AIDigitalTrigger | Digital [get, set]
Digital Trigger Congfiguration.
AIAnalogTrigger | Analog [get, set]
AI Analog Trigger.
int | ReTriggerCount [get, set]
Number of repeat triggers.
uint | PreTriggerSamples [get, set]
AI pretrigger samples, must be less than or equal to JY5325AITask.SamplesToAcquire.

Detailed Description

AI Trigger class.

Property Documentation

◆ Analog

AIAnalogTrigger JY5325.AITrigger.Analog
getset

AI Analog Trigger.

Valid when Type is AITriggerType.Analog.

◆ Digital

AIDigitalTrigger JY5325.AITrigger.Digital
getset

Digital Trigger Congfiguration.

Valid when Type is AITriggerType.Digital.

◆ Mode

AITriggerMode JY5325.AITrigger.Mode
getset

AI Trigger Mode.

enum Start/Reference. The default value is AITriggerMode.Start.

◆ PreTriggerSamples

uint JY5325.AITrigger.PreTriggerSamples
getset

AI pretrigger samples, must be less than or equal to JY5325AITask.SamplesToAcquire.

Valid when Mode is AITriggerMode.Reference.

◆ ReTriggerCount

int JY5325.AITrigger.ReTriggerCount
getset

Number of repeat triggers.

When 0 or 1 only trigger once, When -1 continuous retrigger until stop.

◆ Type

AITriggerType JY5325.AITrigger.Type
getset

AI Trigger Type,enum Analog/Digital/Immediate/Soft.

The default value is AITriggerType.Immediate.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325AITask.cs


5325 C# Programming Manual: JY5325.AIDigitalTrigger Class Reference

  • AIDigitalTrigger
Properties | List of all members
JY5325.AIDigitalTrigger Class Referencesealed

AI Digital Trigger. More...

Properties

AIDigitalTriggerSource | Source [get, set]
AI Digital Trigger Source.
AIDigitalTriggerEdge | Edge [get, set]
AI Digital Trigger Edge，Rising/Falling.

Detailed Description

AI Digital Trigger.

Property Documentation

◆ Edge

AIDigitalTriggerEdge JY5325.AIDigitalTrigger.Edge
getset

AI Digital Trigger Edge，Rising/Falling.

◆ Source

AIDigitalTriggerSource JY5325.AIDigitalTrigger.Source
getset

AI Digital Trigger Source.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325AITask.cs


5325 C# Programming Manual: JY5325.AIAnalogTrigger Class Reference

  • AIAnalogTrigger
Properties | List of all members
JY5325.AIAnalogTrigger Class Referencesealed

AI Analog Trigger. More...

Properties

AIAnalogTriggerSource | Source [get, set]
Analog Trigger source.
AIAnalogTriggerComparator | Comparator [get, set]
AI Analog Trigger Comparator.
AIAnalogEdgeComparator | Edge [get, set]
AI Analog Edge Comparator.
AIAnalogHysteresisComparator | Hysteresis [get, set]
AI Analog Hysteresis Comparatorr.
AIAnalogWindowComparator | Window [get, set]
AI Analog Window Comparatorr.

Detailed Description

AI Analog Trigger.

Property Documentation

◆ Comparator

AIAnalogTriggerComparator JY5325.AIAnalogTrigger.Comparator
getset

AI Analog Trigger Comparator.

◆ Edge

AIAnalogEdgeComparator JY5325.AIAnalogTrigger.Edge
getset

AI Analog Edge Comparator.

◆ Hysteresis

AIAnalogHysteresisComparator JY5325.AIAnalogTrigger.Hysteresis
getset

AI Analog Hysteresis Comparatorr.

◆ Source

AIAnalogTriggerSource JY5325.AIAnalogTrigger.Source
getset

Analog Trigger source.

◆ Window

AIAnalogWindowComparator JY5325.AIAnalogTrigger.Window
getset

AI Analog Window Comparatorr.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325AITask.cs


5325 C# Programming Manual: JY5325.AIRecord Class Reference

  • AIRecord
Properties | List of all members
JY5325.AIRecord Class Referencesealed

AI Record class. More...

Properties

string | FilePath [get, set]
Path of streaming file,including filePath and filename.
FileFormat | FileFormat [get]
Streaming file format.
RecordMode | Mode [get, set]
Two stream mode from enum Finite/Infinite.
double | Length [get, set]
User specified stream length in second.

Detailed Description

AI Record class.

Property Documentation

◆ FileFormat

FileFormat JY5325.AIRecord.FileFormat
get

Streaming file format.

◆ FilePath

string JY5325.AIRecord.FilePath
getset

Path of streaming file,including filePath and filename.

◆ Length

double JY5325.AIRecord.Length
getset

User specified stream length in second.

Only valid in the Finite mode

◆ Mode

RecordMode JY5325.AIRecord.Mode
getset

Two stream mode from enum Finite/Infinite.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325AITask.cs


5325 C# Programming Manual: JY5325.AISync Class Reference

  • AISync
Properties | List of all members
JY5325.AISync Class Referencesealed

Configure sync signal. More...

Properties

SyncTopology | Topology [get, set]
Configure sync signal.
SyncTriggerRouting | TriggerRouting [get, set]
trigger signal Routing, default routing PXITrig0

Detailed Description

Configure sync signal.

Property Documentation

◆ Topology

SyncTopology JY5325.AISync.Topology
getset

Configure sync signal.

◆ TriggerRouting

SyncTriggerRouting JY5325.AISync.TriggerRouting
getset

trigger signal Routing, default routing PXITrig0

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325AITask.cs


5325 C# Programming Manual: JY5325.AISignalExport Class Reference

  • AISignalExport
Public Member Functions | List of all members
JY5325.AISignalExport Class Reference

AI Signal Export Class. More...

Public Member Functions

void | Add (AISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (AISignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

AI Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY5325.AISignalExport.Add | ( | AISignalExportSource | source,
 |  | List< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | AI Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY5325.AISignalExport.Add | ( | AISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | AI Signal Source
destination | Export Desination

◆ Clear()

void JY5325.AISignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5325.AISignalExport.ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325AITask.cs


5325 C# Programming Manual: D:/5325/C#/JY5325AOTask.cs File Reference

  • File List
  • 5325
  • C#
Classes | Namespaces | Enumerations
JY5325AOTask.cs File Reference

Classes

class | JY5325.JY5325AOTask
JY5325 Analog Ouput Task. More...
class | JY5325.AOChannel
AO Channel parameter class . More...
class | JY5325.AOSampleClock
AO Sample clock configuration class. More...
class | JY5325.AOTrigger
Constructor to create an AOTrigger task object. More...
class | JY5325.AODigitalTrigger
AO Digital trigger . More...
class | JY5325.AOSignalExport
AO Signal Export Class. More...

Namespaces

namespace JY5325

Enumerations

enum | JY5325.AODigitalTriggerEdge { JY5325.Rising = JY5325Import.JY5325_Rising , JY5325.Falling = JY5325Import.JY5325_Falling }
AO Digital Trigger Edge. More...
enum JY5325.AODigitalTriggerSource {
JY5325.PFI0 = JY5325Import.JY5325_PFI0 , JY5325.PFI1 = JY5325Import.JY5325_PFI1 , JY5325.PFI2 = JY5325Import.JY5325_PFI2 , JY5325.PFI3 = JY5325Import.JY5325_PFI3 ,
JY5325.PFI4 = JY5325Import.JY5325_PFI4 , JY5325.PFI5 = JY5325Import.JY5325_PFI5 , JY5325.PFI6 = JY5325Import.JY5325_PFI6 , JY5325.PFI7 = JY5325Import.JY5325_PFI7 ,
JY5325.PXI_Trig0 = JY5325Import.JY5325_PXI_Trig0 , JY5325.PXI_Trig1 = JY5325Import.JY5325_PXI_Trig1 , JY5325.PXI_Trig2 = JY5325Import.JY5325_PXI_Trig2 , JY5325.PXI_Trig3 = JY5325Import.JY5325_PXI_Trig3 ,
JY5325.PXI_Trig4 = JY5325Import.JY5325_PXI_Trig4 , JY5325.PXI_Trig5 = JY5325Import.JY5325_PXI_Trig5 , JY5325.PXI_Trig6 = JY5325Import.JY5325_PXI_Trig6 , JY5325.PXI_Trig7 = JY5325Import.JY5325_PXI_Trig7 ,
JY5325.AI_StartTrig = JY5325Import.JY5325_Inter_AI_StartTrig , JY5325.AI_ReferenceTrig = JY5325Import.JY5325_Inter_AI_ReferenceTrig , JY5325.DI_StartTrig = JY5325Import.JY5325_Inter_DI_StartTrig , JY5325.DI_ReferenceTrig = JY5325Import.JY5325_Inter_DI_ReferenceTrig ,
JY5325.DO_StartTrig = JY5325Import.JY5325_Inter_DO_StartTrig , JY5325.CIO_0_StartTrig = JY5325Import.JY5325_Inter_Counter_0_StartTrig , JY5325.CIO_1_StartTrig = JY5325Import.JY5325_Inter_Counter_1_StartTrig , JY5325.CO_0_Out = JY5325Import.JY5325_Inter_Counter_0_Out ,
JY5325.CO_1_Out = JY5325Import.JY5325_Inter_Counter_1_Out
}
AO Digital trigger source. More...
enum | JY5325.AOMode { JY5325.Single = JY5325Import.JY5325_AO_Single , JY5325.Finite = JY5325Import.JY5325_AO_Finite , JY5325.ContinuousNoWrapping = JY5325Import.JY5325_AO_ContinuousNoWrapping , JY5325.ContinuousWrapping = JY5325Import.JY5325_AO_ContinuousWrapping }
AOMode. More...
enum | JY5325.AOSampleClockSource { JY5325.Internal = JY5325Import.JY5325_InternalClock }
AO Sample Clock Source. More...
enum | JY5325.AOSignalExportSource { JY5325.StartTrig = JY5325Import.JY5325_Signal_AO_StartTrig , JY5325.Internal_Counter_100K = JY5325Import.JY5325_Signal_CIO_100kHz , JY5325.Internal_Counter_5M = JY5325Import.JY5325_Signal_CIO_5MHz , JY5325.Internal_Counter_100M = JY5325Import.JY5325_Signal_CIO_100MHz }
SourceSignal. More...
enum | JY5325.AOTriggerType { JY5325.Immediate = JY5325Import.JY5325_AO_Immediately , JY5325.Digital = JY5325Import.JY5325_AO_Digital , JY5325.Soft = JY5325Import.JY5325_AO_Soft }
TriggerType Digital/Immediate/Soft. More...
enum | JY5325.OutputCompleteState { JY5325.Zero , JY5325.Hold }
Output Complete State. More...


5325 C# Programming Manual: JY5325.JY5325AOTask Class Reference

  • JY5325AOTask
Public Member Functions | Properties | List of all members
JY5325.JY5325AOTask Class Referencesealed

JY5325 Analog Ouput Task. More...

Public Member Functions

JY5325AOTask (int slotNum)
Constructor, Used to create an AO task by a slot number.
JY5325AOTask (string boardName)
Constructor.
void | AddChannel (int chnId)
Add one channel.
void | AddChannel (int[] chnsId)
Add a group of channels.
void | RemoveChannel (int chnId)
Delete the specified channel number.
void | WriteData (IntPtr buf, int samplesPerChannel, int timeout=10000)
Write to AO buffer one or multi-channel data.
void | WriteData (double[,] buf, int timeout=10000)
Write multi-channel data to AO buffer, Each column represents one channel.
void | WriteData (double[] buf, int timeout=10000)
Write one channel data to AO buffer.
void | WriteRawData (IntPtr buf, int samplesPerChannel, int timeout=10000)
Write to AO buffer one or multi-channel raw data.
void | WriteRawData (short[,] buf, int timeout=10000)
Write multi-channel raw data to AO buffer, Each column represents one channel.
void | WriteRawData (short[] buf, int timeout=10000)
Write one channel raw Data to AO buffer.
void | WriteSinglePoint (double[] writeValues)
write one sample to all channels in register .
void | WriteSinglePoint (double writeValue, int channel)
Write one sample to the specified channel in register.Available when Mode is AOMode.Single
void | WriteRawSinglePoint (short[] writeValues)
write one raw sample to all channels in register .
void | WriteRawSinglePoint (short writeValue, int channel)
Write one raw sample to the specified channel in register.Available when Mode is AOMode.Single
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.
void | Start ()
Start AO task .
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Stop ()
Stop AO task .

Properties

List< AOChannel > | Channels [get]
List of AO channels,(5325 support 8 channels)
AOMode | Mode [get, set]
Mode of AO Task.
double | UpdateRate [get, set]
if the number of channels in any bank is greater than 1, the maximum AO update rate is 2M
int | SamplesToUpdate [get, set]
Number of output samples to write per channel , Only valid when Mode is AOMode.Finite.
int | BufLenInSamples [get]
Number of samples per channel can be storage in the buffer, the PropretySamplesToUpdate must be less than or equal to this value.
uint | AvaliableLenInSamples [get]
Number of output samples per channel that can be write in AO buffuer.
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel).
OutputCompleteState | CompleteState [get, set]
AO Output Complete State, Valid when Mode is NOT AOMode.Single.
AOSampleClock | SampleClock [get, set]
AO Sample Clock Configuration .
AOTrigger | Trigger = new AOTrigger() [get, set]
AO Trigger Configuration.
bool | DisableCalibration [get, set]
Disalble calibration.
AOSignalExport | SignalExport [get, set]
Export AO Signal.
JY5325Device | Device [get]
Device.

Detailed Description

JY5325 Analog Ouput Task.

Constructor & Destructor Documentation

◆ JY5325AOTask() [1/2]

JY5325.JY5325AOTask.JY5325AOTask ( int slotNum )

Constructor, Used to create an AO task by a slot number.

Parameters
slotNum Card slot number.

◆ JY5325AOTask() [2/2]

JY5325.JY5325AOTask.JY5325AOTask ( string boardName )

Constructor.

Used to create an AO task by a board name.

Parameters
boardName Board name(device alias), set by device manager

Member Function Documentation

◆ AddChannel() [1/2]

void JY5325.JY5325AOTask.AddChannel ( int chnId )

Add one channel.

Parameters
chnId channel's physical number ，chnId=-1, add all channels。（5325 support 8 channels）

◆ AddChannel() [2/2]

void JY5325.JY5325AOTask.AddChannel ( int[] chnsId )

Add a group of channels.

Parameters
chnsId a group of channel physical numbers。（5325 support 8 channels）

◆ RemoveChannel()

void JY5325.JY5325AOTask.RemoveChannel ( int chnId )

Delete the specified channel number.

If it is -1, delete all channels.

Parameters
chnId Specified channel ID.

◆ SendSoftwareTrigger()

void JY5325.JY5325AOTask.SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5325.JY5325AOTask.Start ( )

Start AO task .

◆ Stop()

void JY5325.JY5325AOTask.Stop ( )

Stop AO task .

◆ WaitUntilDone()

bool JY5325.JY5325AOTask.WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Available when Mode is AOMode.Finite

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteData() [1/3]

void JY5325.JY5325AOTask.WriteData | ( | double | buf[,],
 |  | int | timeout = 10000 )

Write multi-channel data to AO buffer, Each column represents one channel.

Parameters
buf | AO buffer for data.
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [2/3]

void JY5325.JY5325AOTask.WriteData | ( | double[] | buf,
 |  | int | timeout = 10000 )

Write one channel data to AO buffer.

Parameters
buf | AO buffer for data.
timeout | >timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [3/3]

void JY5325.JY5325AOTask.WriteData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Write to AO buffer one or multi-channel data.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | data buffer.
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawData() [1/3]

void JY5325.JY5325AOTask.WriteRawData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Write to AO buffer one or multi-channel raw data.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | data buffer.
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawData() [2/3]

void JY5325.JY5325AOTask.WriteRawData | ( | short | buf[,],
 |  | int | timeout = 10000 )

Write multi-channel raw data to AO buffer, Each column represents one channel.

Parameters
buf | AO buffer for data.
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawData() [3/3]

void JY5325.JY5325AOTask.WriteRawData | ( | short[] | buf,
 |  | int | timeout = 10000 )

Write one channel raw Data to AO buffer.

Parameters
buf | AO buffer for data.
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawSinglePoint() [1/2]

void JY5325.JY5325AOTask.WriteRawSinglePoint | ( | short | writeValue,
 |  | int | channel )

Write one raw sample to the specified channel in register.Available when Mode is AOMode.Single

Parameters
writeValue | Write value.
channel | Specified channel.

◆ WriteRawSinglePoint() [2/2]

void JY5325.JY5325AOTask.WriteRawSinglePoint ( short[] writeValues )

write one raw sample to all channels in register .

Available when Mode is AOMode.Single

Parameters
writeValues Write values. Array length >= Channels.Count.

◆ WriteSinglePoint() [1/2]

void JY5325.JY5325AOTask.WriteSinglePoint | ( | double | writeValue,
 |  | int | channel )

Write one sample to the specified channel in register.Available when Mode is AOMode.Single

Parameters
writeValue | Write value.
channel | Specified channel.

◆ WriteSinglePoint() [2/2]

void JY5325.JY5325AOTask.WriteSinglePoint ( double[] writeValues )

write one sample to all channels in register .

Available when Mode is AOMode.Single

Parameters
writeValues Write values. Array length >= Channels.Count.

Property Documentation

◆ AvaliableLenInSamples

uint JY5325.JY5325AOTask.AvaliableLenInSamples
get

Number of output samples per channel that can be write in AO buffuer.

◆ BufLenInSamples

int JY5325.JY5325AOTask.BufLenInSamples
get

Number of samples per channel can be storage in the buffer, the PropretySamplesToUpdate must be less than or equal to this value.

◆ Channels

List<AOChannel> JY5325.JY5325AOTask.Channels
get

List of AO channels,(5325 support 8 channels)

◆ CompleteState

OutputCompleteState JY5325.JY5325AOTask.CompleteState
getset

AO Output Complete State, Valid when Mode is NOT AOMode.Single.

Default is Zero.

◆ Device

JY5325Device JY5325.JY5325AOTask.Device
get

Device.

◆ DisableCalibration

bool JY5325.JY5325AOTask.DisableCalibration
getset

Disalble calibration.

◆ Mode

AOMode JY5325.JY5325AOTask.Mode
getset

Mode of AO Task.

Select AO Mode from enum:ContinuousNoWrapping/ContinuousWrapping/Finite/Single.

◆ SampleClock

AOSampleClock JY5325.JY5325AOTask.SampleClock
getset

AO Sample Clock Configuration .

◆ SamplesToUpdate

int JY5325.JY5325AOTask.SamplesToUpdate
getset

Number of output samples to write per channel , Only valid when Mode is AOMode.Finite.

◆ SignalExport

AOSignalExport JY5325.JY5325AOTask.SignalExport
getset

Export AO Signal.

◆ TransferedSamples

ulong JY5325.JY5325AOTask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT AOMode.Single.

◆ Trigger

AOTrigger JY5325.JY5325AOTask.Trigger = new AOTrigger()
getset

AO Trigger Configuration.

◆ UpdateRate

double JY5325.JY5325AOTask.UpdateRate
getset

if the number of channels in any bank is greater than 1, the maximum AO update rate is 2M

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325AOTask.cs


5325 C# Programming Manual: JY5325.AOChannel Class Reference

  • AOChannel
Properties | List of all members
JY5325.AOChannel Class Referencesealed

AO Channel parameter class . More...

Properties

int ChannelID [get]
AO channel ID.

Detailed Description

AO Channel parameter class .

Property Documentation

◆ ChannelID

int JY5325.AOChannel.ChannelID
get

AO channel ID.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325AOTask.cs


5325 C# Programming Manual: JY5325.AOSampleClock Class Reference

  • AOSampleClock
Properties | List of all members
JY5325.AOSampleClock Class Reference

AO Sample clock configuration class. More...

Properties

AOSampleClockSource Source [get, set]
Clock Source.

Detailed Description

AO Sample clock configuration class.

Property Documentation

◆ Source

AOSampleClockSource JY5325.AOSampleClock.Source
getset

Clock Source.

enum Internal/External,The default value is AOSampleClockSource.Internal.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325AOTask.cs


5325 C# Programming Manual: JY5325.AOTrigger Class Reference

  • AOTrigger
Properties | List of all members
JY5325.AOTrigger Class Referencesealed

Constructor to create an AOTrigger task object. More...

Properties

AOTriggerType | Type [get, set]
AO trigger type.
AODigitalTrigger | Digital [get, set]
AO Digital Trigger.

Detailed Description

Constructor to create an AOTrigger task object.

Used to build AO Trigger

Property Documentation

◆ Digital

AODigitalTrigger JY5325.AOTrigger.Digital
getset

AO Digital Trigger.

Valid when Type is AOTriggerType.Digital.

◆ Type

AOTriggerType JY5325.AOTrigger.Type
getset

AO trigger type.

enum Immediate/Digital/Soft.The default value is AOTriggerType.Immediate.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325AOTask.cs


5325 C# Programming Manual: JY5325.AODigitalTrigger Class Reference

  • AODigitalTrigger
Properties | List of all members
JY5325.AODigitalTrigger Class Referencesealed

AO Digital trigger . More...

Properties

AODigitalTriggerSource | Source [get, set]
AO Digital Trigger source.
AODigitalTriggerEdge | Edge [get, set]
Digital Trigger edge，Rising/Falling.

Detailed Description

AO Digital trigger .

Property Documentation

◆ Edge

AODigitalTriggerEdge JY5325.AODigitalTrigger.Edge
getset

Digital Trigger edge，Rising/Falling.

◆ Source

AODigitalTriggerSource JY5325.AODigitalTrigger.Source
getset

AO Digital Trigger source.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325AOTask.cs


5325 C# Programming Manual: JY5325.AOSignalExport Class Reference

  • AOSignalExport
Public Member Functions | List of all members
JY5325.AOSignalExport Class Reference

AO Signal Export Class. More...

Public Member Functions

void | Add (AOSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (AOSignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

AO Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY5325.AOSignalExport.Add | ( | AOSignalExportSource | source,
 |  | List< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | AO Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY5325.AOSignalExport.Add | ( | AOSignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | AO Signal Source
destination | Export Desination

◆ Clear()

void JY5325.AOSignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5325.AOSignalExport.ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325AOTask.cs


5325 C# Programming Manual: D:/5325/C#/JY5325CITask.cs File Reference

  • File List
  • 5325
  • C#
Classes | Namespaces | Enumerations
JY5325CITask.cs File Reference

Classes

class | JY5325.JY5325CITask
JY5325 Counter Input Task. More...
class | JY5325.CISampleClock
CI Sample Clock class. More...
class | JY5325.CIInternalSampleClock
CI Internal Sample Clock Configuration Class. More...
class | JY5325.CIImplicitSampleClock
CI Implicit Sample Clock class. More...
class | JY5325.CIExternalSampleClock
CI Implicit Sample Clock class. More...
class | JY5325.CIExternalTimebase
class | JY5325.CITimebase
class | JY5325.EdgeCounting
Configure CI EdgeCounting. More...
class | JY5325.EdgeCountingOutEvent
Edge counting output event configuration class. More...
class | JY5325.PauseTrigger
Pause trigger configuration class. More...
class | JY5325.FrequencyMeas
Configure CI Measure. More...
class | JY5325.PeriodMeas
Configure CI Measure. More...
class | JY5325.PulseMeas
Configure CI Measure. More...
class | JY5325.SemiPeriodMeas
Configure CI Measure. More...
class | JY5325.TwoEdgeSeparation
Configure CI Measure. More...
class | JY5325.QuadEncoder
Configure CI Measure. More...
class | JY5325.TwoPulseEncoder
Configure CI Measure. More...
class | JY5325.CITrigger
Constructor to create an CITrigger task object. More...
class | JY5325.CIDigitalTrigger
CI Digital trigger . More...
class | JY5325.CISignalExport
CI Signal Export Class. More...

Namespaces

namespace JY5325

Enumerations

enum | JY5325.CountDirection { JY5325.Up = JY5325Import.JY5325_CI_Count_Up , JY5325.Down = JY5325Import.JY5325_CI_Count_Down , JY5325.External = JY5325Import.JY5325_CI_Count_External }
Counter direction. More...
enum | JY5325.CIMode { JY5325.Single = 2 , JY5325.Finite = 0 , JY5325.Continuous = 1 }
CIMode. More...
enum JY5325.CIType {
JY5325.EdgeCounting , JY5325.Period , JY5325.Frequency , JY5325.Pulse ,
JY5325.SemiPeriod , JY5325.TwoEdgeSeparation , JY5325.QuadEncoder , JY5325.TwoPulseEncoder
}
Counter Input Application Type. More...
enum | JY5325.CISampleClockSource { JY5325.Implicit = JY5325Import.JY5325_CI_ImplicitClock , JY5325.Internal = JY5325Import.JY5325_CI_InternalClock , JY5325.External = JY5325Import.JY5325_CI_ExternalClock }
CI Sample Clock Source. More...
enum | JY5325.EdgeType { JY5325.Rising , JY5325.Falling , JY5325.Any }
Edge Type. More...
enum | JY5325.CITimebaseSource { JY5325.Internal100MHz = 0 , JY5325.Internal5MHz = 1 , JY5325.Internal100kHz = 2 , JY5325.External = 3 }
enum | JY5325.EdgeCntOunEvtIdleState { JY5325.LowLevel = 0 , JY5325.HighLevel = 1 }
Output idle state when the event has not occurred. More...
enum | JY5325.LevelPolarity { JY5325.LowLevel = 0 , JY5325.HighLevel = 1 , JY5325.None = 2 }
Level Polarity. More...
enum | JY5325.ValueReturnMode { JY5325.TwoValue , JY5325.OneValue }
TwoEdgeSeparation value return mode.only for TwoEdgeSeparation type. More...
enum | JY5325.QuadEncodingType { JY5325.X1 , JY5325.X2 , JY5325.X4 }
Quadrature Encoding Type. More...
enum | JY5325.CITriggerType { JY5325.Immediate = JY5325Import.JY5325_CIO_Immediately , JY5325.Digital = JY5325Import.JY5325_CIO_Digital , JY5325.Soft = JY5325Import.JY5325_CIO_Soft }
TriggerType Digital/Immediate/Soft. More...
enum JY5325.CIDigitalTriggerSource {
JY5325.PFI0 = JY5325Import.JY5325_PFI0 , JY5325.PFI1 = JY5325Import.JY5325_PFI1 , JY5325.PFI2 = JY5325Import.JY5325_PFI2 , JY5325.PFI3 = JY5325Import.JY5325_PFI3 ,
JY5325.PFI4 = JY5325Import.JY5325_PFI4 , JY5325.PFI5 = JY5325Import.JY5325_PFI5 , JY5325.PFI6 = JY5325Import.JY5325_PFI6 , JY5325.PFI7 = JY5325Import.JY5325_PFI7 ,
JY5325.PXI_Trig0 = JY5325Import.JY5325_PXI_Trig0 , JY5325.PXI_Trig1 = JY5325Import.JY5325_PXI_Trig1 , JY5325.PXI_Trig2 = JY5325Import.JY5325_PXI_Trig2 , JY5325.PXI_Trig3 = JY5325Import.JY5325_PXI_Trig3 ,
JY5325.PXI_Trig4 = JY5325Import.JY5325_PXI_Trig4 , JY5325.PXI_Trig5 = JY5325Import.JY5325_PXI_Trig5 , JY5325.PXI_Trig6 = JY5325Import.JY5325_PXI_Trig6 , JY5325.PXI_Trig7 = JY5325Import.JY5325_PXI_Trig7 ,
JY5325.AI_StartTrig = JY5325Import.JY5325_Inter_AI_StartTrig , JY5325.AI_ReferenceTrig = JY5325Import.JY5325_Inter_AI_ReferenceTrig , JY5325.AO_StartTrig = JY5325Import.JY5325_Inter_AO_StartTrig , JY5325.DI_StartTrig = JY5325Import.JY5325_Inter_DI_StartTrig ,
JY5325.DI_ReferenceTrig = JY5325Import.JY5325_Inter_DI_ReferenceTrig , JY5325.DO_StartTrig = JY5325Import.JY5325_Inter_DO_StartTrig , JY5325.CIO_0_StartTrig = JY5325Import.JY5325_Inter_Counter_0_StartTrig , JY5325.CIO_1_StartTrig = JY5325Import.JY5325_Inter_Counter_1_StartTrig ,
JY5325.CO_0_Out = JY5325Import.JY5325_Inter_Counter_0_Out , JY5325.CO_1_Out = JY5325Import.JY5325_Inter_Counter_1_Out
}
CI Digital trigger source. More...
enum | JY5325.CIDigitalTriggerEdge { JY5325.Rising = JY5325Import.JY5325_Rising , JY5325.Falling = JY5325Import.JY5325_Falling }
CI Digital Trigger Edge. More...
enum JY5325.InputTerminal {
JY5325.PFI0 = JY5325Import.JY5325_PFI0_Input , JY5325.PFI1 = JY5325Import.JY5325_PFI1_Input , JY5325.PFI2 = JY5325Import.JY5325_PFI2_Input , JY5325.PFI3 = JY5325Import.JY5325_PFI3_Input ,
JY5325.PFI4 = JY5325Import.JY5325_PFI4_Input , JY5325.PFI5 = JY5325Import.JY5325_PFI5_Input , JY5325.PFI6 = JY5325Import.JY5325_PFI6_Input , JY5325.PFI7 = JY5325Import.JY5325_PFI7_Input ,
JY5325.PXI_Trig0 = JY5325Import.JY5325_PXI_Trig0_Input , JY5325.PXI_Trig1 = JY5325Import.JY5325_PXI_Trig1_Input , JY5325.PXI_Trig2 = JY5325Import.JY5325_PXI_Trig2_Input , JY5325.PXI_Trig3 = JY5325Import.JY5325_PXI_Trig3_Input ,
JY5325.PXI_Trig4 = JY5325Import.JY5325_PXI_Trig4_Input , JY5325.PXI_Trig5 = JY5325Import.JY5325_PXI_Trig5_Input , JY5325.PXI_Trig6 = JY5325Import.JY5325_PXI_Trig6_Input , JY5325.PXI_Trig7 = JY5325Import.JY5325_PXI_Trig7_Input ,
JY5325.AI_SampleClock = JY5325Import.JY5325_IN_AI_SampleClock , JY5325.AO_SampleClock = JY5325Import.JY5325_IN_AO_SampleClock , JY5325.DI_SampleClock = JY5325Import.JY5325_IN_DI_SampleClock , JY5325.DO_SampleClock = JY5325Import.JY5325_IN_DO_SampleClock ,
JY5325.CO_0_OutPut = JY5325Import.JY5325_IN_CO_0_Output , JY5325.CO_1_OutPut = JY5325Import.JY5325_IN_CO_1_Output , JY5325.Timebase_100MHz = JY5325Import.JY5325_IN_CIO_100MHz , JY5325.Timebase_5MHz = JY5325Import.JY5325_IN_CIO_5MHz ,
JY5325.Timebase_100kHz = JY5325Import.JY5325_IN_CIO_100kHz
}
Input Terminal. More...
enum JY5325.IOTerminal {
JY5325.PFI0 = JY5325Import.JY5325_PFI0_OUT , JY5325.PFI1 = JY5325Import.JY5325_PFI1_OUT , JY5325.PFI2 = JY5325Import.JY5325_PFI2_OUT , JY5325.PFI3 = JY5325Import.JY5325_PFI3_OUT ,
JY5325.PFI4 = JY5325Import.JY5325_PFI4_OUT , JY5325.PFI5 = JY5325Import.JY5325_PFI5_OUT , JY5325.PFI6 = JY5325Import.JY5325_PFI6_OUT , JY5325.PFI7 = JY5325Import.JY5325_PFI7_OUT ,
JY5325.PXI_Trig0 = JY5325Import.JY5325_PXITrig0_OUT , JY5325.PXI_Trig1 = JY5325Import.JY5325_PXITrig1_OUT , JY5325.PXI_Trig2 = JY5325Import.JY5325_PXITrig2_OUT , JY5325.PXI_Trig3 = JY5325Import.JY5325_PXITrig3_OUT ,
JY5325.PXI_Trig4 = JY5325Import.JY5325_PXITrig4_OUT , JY5325.PXI_Trig5 = JY5325Import.JY5325_PXITrig5_OUT , JY5325.PXI_Trig6 = JY5325Import.JY5325_PXITrig6_OUT , JY5325.PXI_Trig7 = JY5325Import.JY5325_PXITrig7_OUT ,
JY5325.None = 16
}
Out terminal. More...
enum JY5325.CISignalExportSource {
JY5325.StartTrig , JY5325.SampleClock , JY5325.Internal_Counter_100K = JY5325Import.JY5325_Signal_CIO_100kHz , JY5325.Internal_Counter_5M = JY5325Import.JY5325_Signal_CIO_5MHz ,
JY5325.Internal_Counter_100M = JY5325Import.JY5325_Signal_CIO_100MHz
}
SourceSignal. More...


5325 C# Programming Manual: JY5325.JY5325CITask Class Reference

  • JY5325CITask
Public Member Functions | Properties | List of all members
JY5325.JY5325CITask Class Referencesealed

JY5325 Counter Input Task. More...

Public Member Functions

JY5325CITask (int slotNum, int channel)
Constructor.
JY5325CITask (string boardName, int channel)
Constructor.
void | Start ()
Start CI task .
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Stop ()
Stop CI task .
void | ReadSinglePoint (ref uint count)
Read a signle count value from register, Available when Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder
void | ReadData (ref uint[] bufCount, int samplesToAcquire, int timeout=10000)
Read counter values from buffer.
void | ReadData (ref uint[] bufCount, int timeout=10000)
Read counter values from buffer.
void | ReadData (ref double[] bufMeasurement, int samplesToAcquire, int timeout=10000)
Read frequency value or period value from buffer.
void | ReadData (ref double[] bufMeasurement, int timeout=10000)
Read frequency value or period value from buffer.
void | ReadSinglePoint (ref double measurement, int timeout=10000)
Read a signle frequency value or period value from register.
void | ReadSinglePoint (ref double measurement1, ref double measurement2, int timeout=10000)
Read a signle measurement of pulse's duration value, or two-edge separtion value (two results at a time) from register.
void | ReadData (ref double[] bufMeasurement1, ref double[] bufMeasurement2, int samplesToAcquire, int timeout=10000)
Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.
void | ReadData (ref double[] bufMeasurement1, ref double[] bufMeasurement2, int timeout=10000)
Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.

Properties

CIType | Type [get, set]
CI Application types.
int | BufLenInSamples [get]
Number of samples can be storage in the buffer, the PropretySamplesToAcquire must be less than or equal to this value.
ulong | AvailableSamples [get]
Number of points per channel that can be read in the buffer .
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel).
CIMode | Mode [get, set]
CI Sampling mode，support Single/Finite/Continuous.
CISampleClock | SampleClock [get, set]
Clock Source.
uint | SamplesToAcquire [get, set]
Number of samples to be read per channel.Only valid when Mode is CIMode.Finite.
EdgeCounting | EdgeCounting [get, set]
Edge Counting Configuration.
FrequencyMeas | FrequencyMeas [get, set]
Frequency Measurement Configuration.
PeriodMeas | PeriodMeas [get, set]
Period Measurement Configuration.
SemiPeriodMeas | SemiPeriodMeas [get, set]
SemiPeriodMeas Measurement Configuration.
PulseMeas | PulseMeas [get, set]
Pulse Measurement Configuration.
TwoEdgeSeparation | TwoEdgeSeparation [get, set]
TwoEdgeSeparation.
QuadEncoder | QuadEncoder [get, set]
QuadEncoder.
TwoPulseEncoder | TwoPulseEncoder [get, set]
TwoPulseEncoder.
CITrigger | Trigger = new CITrigger() [get, set]
CI Trigger Configuration.
CISignalExport | SignalExport [get, set]
Export CI Signal Configuration.
JY5325Device | Device [get]
Device.

Detailed Description

JY5325 Counter Input Task.

Constructor & Destructor Documentation

◆ JY5325CITask() [1/2]

JY5325.JY5325CITask.JY5325CITask | ( | int | slotNum,
 |  | int | channel )

Constructor.

Used to create an CI task by a slot number.

Parameters
slotNum | Card slot number.
channel | Counter channel suppor0-1

◆ JY5325CITask() [2/2]

JY5325.JY5325CITask.JY5325CITask | ( | string | boardName,
 |  | int | channel )

Constructor.

Used to create an m task by a board name.

Parameters
boardName | Board name(device alias), set by device manager
channel | Counter channel suppor0-1.

Member Function Documentation

◆ ReadData() [1/6]

void JY5325.JY5325CITask.ReadData | ( | ref double[] | bufMeasurement,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read frequency value or period value from buffer.

Available when JY5325CITask.Mode is NOT CIMode.Single, and Type is CIType.Frequency or CIType.Period.

Parameters
bufMeasurement | Buffer for reading data. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period in seconds when Type is CIType.Period.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [2/6]

void JY5325.JY5325CITask.ReadData | ( | ref double[] | bufMeasurement,
 |  | int | timeout = 10000 )

Read frequency value or period value from buffer.

Available when JY5325CITask.Mode is NOT CIMode.Single, and Type is CIType.Frequency or CIType.Period.

Parameters
bufMeasurement | Buffer for reading data. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period in seconds when Type is CIType.Period.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [3/6]

void JY5325.JY5325CITask.ReadData | ( | ref double[] | bufMeasurement1,
 |  | ref double[] | bufMeasurement2,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.

. Available when JY5325CITask.Mode is NOT CIMode.Single, Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
bufMeasurement1 | Buffer for reading data. Indicates high level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
bufMeasurement2 | Buffer for reading data. Indicates low level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [4/6]

void JY5325.JY5325CITask.ReadData | ( | ref double[] | bufMeasurement1,
 |  | ref double[] | bufMeasurement2,
 |  | int | timeout = 10000 )

Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.

. Available when JY5325CITask.Mode is NOT CIMode.Single, Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
bufMeasurement1 | Buffer for reading data. Indicates high level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
bufMeasurement2 | Buffer for reading data. Indicates low level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [5/6]

void JY5325.JY5325CITask.ReadData | ( | ref uint[] | bufCount,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read counter values from buffer.

Available when JY5325CITask.Mode is NOT CIMode.Single, and Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder

Parameters
bufCount | Buffer for reading data.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [6/6]

void JY5325.JY5325CITask.ReadData | ( | ref uint[] | bufCount,
 |  | int | timeout = 10000 )

Read counter values from buffer.

Available when JY5325CITask.Mode is NOT CIMode.Single, and Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder

Parameters
bufCount | Buffer for reading data.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [1/3]

void JY5325.JY5325CITask.ReadSinglePoint | ( | ref double | measurement,
 |  | int | timeout = 10000 )

Read a signle frequency value or period value from register.

Valid when Type is CIType.Frequency or CIType.Period.

Parameters
measurement Measurement value. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period is seconds when Type is CIType.Period.
timeout
Timeout (ms). Wait until the measurement is completed or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [2/3]

void JY5325.JY5325CITask.ReadSinglePoint | ( | ref double | measurement1,
 |  | ref double | measurement2,
 |  | int | timeout = 10000 )

Read a signle measurement of pulse's duration value, or two-edge separtion value (two results at a time) from register.

Available when Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
measurement1 | Measurement Value 1. Indicates low level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
measurement2 | Measurement Value 2. Indicates high level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
timeout
Timeout (ms). Wait until the measurement is completed or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [3/3]

void JY5325.JY5325CITask.ReadSinglePoint ( ref uint count )

Read a signle count value from register, Available when Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder

Parameters
count counter value。

◆ SendSoftwareTrigger()

void JY5325.JY5325CITask.SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5325.JY5325CITask.Start ( )

Start CI task .

◆ Stop()

void JY5325.JY5325CITask.Stop ( )

Stop CI task .

Property Documentation

◆ AvailableSamples

ulong JY5325.JY5325CITask.AvailableSamples
get

Number of points per channel that can be read in the buffer .

◆ BufLenInSamples

int JY5325.JY5325CITask.BufLenInSamples
get

Number of samples can be storage in the buffer, the PropretySamplesToAcquire must be less than or equal to this value.

◆ Device

JY5325Device JY5325.JY5325CITask.Device
get

Device.

◆ EdgeCounting

EdgeCounting JY5325.JY5325CITask.EdgeCounting
getset

Edge Counting Configuration.

◆ FrequencyMeas

FrequencyMeas JY5325.JY5325CITask.FrequencyMeas
getset

Frequency Measurement Configuration.

◆ Mode

CIMode JY5325.JY5325CITask.Mode
getset

CI Sampling mode，support Single/Finite/Continuous.

◆ PeriodMeas

PeriodMeas JY5325.JY5325CITask.PeriodMeas
getset

Period Measurement Configuration.

◆ PulseMeas

PulseMeas JY5325.JY5325CITask.PulseMeas
getset

Pulse Measurement Configuration.

◆ QuadEncoder

QuadEncoder JY5325.JY5325CITask.QuadEncoder
getset

QuadEncoder.

◆ SampleClock

CISampleClock JY5325.JY5325CITask.SampleClock
getset

Clock Source.

◆ SamplesToAcquire

uint JY5325.JY5325CITask.SamplesToAcquire
getset

Number of samples to be read per channel.Only valid when Mode is CIMode.Finite.

◆ SemiPeriodMeas

SemiPeriodMeas JY5325.JY5325CITask.SemiPeriodMeas
getset

SemiPeriodMeas Measurement Configuration.

◆ SignalExport

CISignalExport JY5325.JY5325CITask.SignalExport
getset

Export CI Signal Configuration.

◆ TransferedSamples

ulong JY5325.JY5325CITask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT CIMode.Single.

◆ Trigger

CITrigger JY5325.JY5325CITask.Trigger = new CITrigger()
getset

CI Trigger Configuration.

◆ TwoEdgeSeparation

TwoEdgeSeparation JY5325.JY5325CITask.TwoEdgeSeparation
getset

TwoEdgeSeparation.

◆ TwoPulseEncoder

TwoPulseEncoder JY5325.JY5325CITask.TwoPulseEncoder
getset

TwoPulseEncoder.

◆ Type

CIType JY5325.JY5325CITask.Type
getset

CI Application types.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325CITask.cs


5325 C# Programming Manual: JY5325.CISampleClock Class Reference

  • CISampleClock
Properties | List of all members
JY5325.CISampleClock Class Reference

CI Sample Clock class. More...

Properties

CISampleClockSource | Source [get, set]
CI Sample Clock Source.
CIExternalSampleClock | External [get, set]
CI External Sample Clock Configuration.
CIImplicitSampleClock | Implicit [get, set]
CI Implicit Sample Clock Configuration.
CIInternalSampleClock | Internal [get]
Internal Sample Clock Configuration.

Detailed Description

CI Sample Clock class.

Property Documentation

◆ External

CIExternalSampleClock JY5325.CISampleClock.External
getset

CI External Sample Clock Configuration.

Valid when Source is CISampleClockSource.External.

◆ Implicit

CIImplicitSampleClock JY5325.CISampleClock.Implicit
getset

CI Implicit Sample Clock Configuration.

Valid when Source is CISampleClockSource.Implicit.

◆ Internal

CIInternalSampleClock JY5325.CISampleClock.Internal
get

Internal Sample Clock Configuration.

Valid when Source is CISampleClockSource.Internal.

◆ Source

CISampleClockSource JY5325.CISampleClock.Source
getset

CI Sample Clock Source.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325CITask.cs


5325 C# Programming Manual: JY5325.CIInternalSampleClock Class Reference

  • CIInternalSampleClock
Properties | List of all members
JY5325.CIInternalSampleClock Class Reference

CI Internal Sample Clock Configuration Class. More...

Properties

double | Rate [get, set]
The rate of the internal sample clock (sample rate) which is generated by dividing the internal clock (200MHz).
bool | IgnoreFirstSampleClock [get, set]
Ignore the first sample clock data.

Detailed Description

CI Internal Sample Clock Configuration Class.

Property Documentation

◆ IgnoreFirstSampleClock

bool JY5325.CIInternalSampleClock.IgnoreFirstSampleClock
getset

Ignore the first sample clock data.

◆ Rate

double JY5325.CIInternalSampleClock.Rate
getset

The rate of the internal sample clock (sample rate) which is generated by dividing the internal clock (200MHz).

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325CITask.cs


5325 C# Programming Manual: JY5325.CIImplicitSampleClock Class Reference

  • CIImplicitSampleClock
Properties | List of all members
JY5325.CIImplicitSampleClock Class Reference

CI Implicit Sample Clock class. More...

Properties

double ExpectedRate [get, set]
Expected Rate of Implicit Sample Clock.

Detailed Description

CI Implicit Sample Clock class.

Property Documentation

◆ ExpectedRate

double JY5325.CIImplicitSampleClock.ExpectedRate
getset

Expected Rate of Implicit Sample Clock.

Filling this parameter accurately would helps the driver to set a proper DDR write frequency internally.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325CITask.cs


5325 C# Programming Manual: JY5325.CIExternalSampleClock Class Reference

  • CIExternalSampleClock
Properties | List of all members
JY5325.CIExternalSampleClock Class Reference

CI Implicit Sample Clock class. More...

Properties

ClockTerminal | Terminal [get, set]
External Sample Clock Input Terminal.
double | ExpectedRate [get, set]
Expected Rate of External Sample Clock.
bool | IgnoreFirstSampleClock [get, set]
Ignore the first sample clock data.

Detailed Description

CI Implicit Sample Clock class.

Property Documentation

◆ ExpectedRate

double JY5325.CIExternalSampleClock.ExpectedRate
getset

Expected Rate of External Sample Clock.

Filling this parameter accurately would helps the driver to set a proper DDR write frequency internally.

◆ IgnoreFirstSampleClock

bool JY5325.CIExternalSampleClock.IgnoreFirstSampleClock
getset

Ignore the first sample clock data.

◆ Terminal

ClockTerminal JY5325.CIExternalSampleClock.Terminal
getset

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325CITask.cs


5325 C# Programming Manual: JY5325.CIExternalTimebase Class Reference

  • CIExternalTimebase
Properties | List of all members
JY5325.CIExternalTimebase Class Referencesealed

Properties

InputTerminal | Terminal [get, set]
double | Frequency [get, set]

Detailed Description

外部时基配置类

External timebase configuration class

Property Documentation

◆ Frequency

double JY5325.CIExternalTimebase.Frequency
getset

外部时基的频率

Frequency of The External Timebase

◆ Terminal

InputTerminal JY5325.CIExternalTimebase.Terminal
getset

外部时基的输入端口

External Timebase Input Terminal

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325CITask.cs


5325 C# Programming Manual: JY5325.CITimebase Class Reference

  • CITimebase
Properties | List of all members
JY5325.CITimebase Class Referencesealed

Properties

CITimebaseSource | Source [get, set]
CIExternalTimebase | External [get, set]

Detailed Description

时基配置类

Timebase configuration class

Property Documentation

◆ External

CIExternalTimebase JY5325.CITimebase.External
getset

外部时基配置。当 CITimebase.Source 为 CITimebaseSource.External时有效。

External Timebase Configuration. Valid when CITimebase.Source is COTimebaseSource.External.

◆ Source

CITimebaseSource JY5325.CITimebase.Source
getset

时基源。默认值为 CITimebaseSource.Internal100MHz。

Timebase Source. The default value is CITimebaseSource.Internal100MHz.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325CITask.cs


5325 C# Programming Manual: JY5325.EdgeCounting Class Reference

  • EdgeCounting
Properties | List of all members
JY5325.EdgeCounting Class Referencesealed

Configure CI EdgeCounting. More...

Properties

int | InitialCount [get, set]
Initial Count.
CountDirection | Direction [get, set]
Counter direction.
EdgeType | ActiveEdge [get, set]
The avtive edge of the input signal, the counter will count up or down on this edge.
PauseTrigger | Pause [get, set]
Pause Trigger Configuration.
EdgeCountingOutEvent | OutEvent [get, set]
Edge counting output event.
InputTerminal | InputTerminal [get, set]
Input Terminal.
InputTerminal | DirTerminal [get, set]
Terminal of External Count Diretion Control.

Detailed Description

Configure CI EdgeCounting.

Property Documentation

◆ ActiveEdge

EdgeType JY5325.EdgeCounting.ActiveEdge
getset

The avtive edge of the input signal, the counter will count up or down on this edge.

◆ Direction

CountDirection JY5325.EdgeCounting.Direction
getset

Counter direction.

enum Up/Down/External

◆ DirTerminal

InputTerminal JY5325.EdgeCounting.DirTerminal
getset

Terminal of External Count Diretion Control.

Valid when Direction is CountDirection.External

◆ InitialCount

int JY5325.EdgeCounting.InitialCount
getset

Initial Count.

◆ InputTerminal

InputTerminal JY5325.EdgeCounting.InputTerminal
getset

Input Terminal.

◆ OutEvent

EdgeCountingOutEvent JY5325.EdgeCounting.OutEvent
getset

Edge counting output event.

A pulse will be generated when the count value reaches specified threshold

◆ Pause

PauseTrigger JY5325.EdgeCounting.Pause
getset

Pause Trigger Configuration.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325CITask.cs


5325 C# Programming Manual: JY5325.EdgeCountingOutEvent Class Reference

  • EdgeCountingOutEvent
Properties | List of all members
JY5325.EdgeCountingOutEvent Class Reference

Edge counting output event configuration class. More...

Properties

EdgeCntOunEvtIdleState | IdleState [get, set]
Output idle state when the event has not occurred.
uint | Threshold [get, set]
Comparison threshold.
IOTerminal | Terminal [get, set]
Terminal.

Detailed Description

Edge counting output event configuration class.

Property Documentation

◆ IdleState

EdgeCntOunEvtIdleState JY5325.EdgeCountingOutEvent.IdleState
getset

Output idle state when the event has not occurred.

The default value is EdgeCntOunEvtIdleState.LowLevel

◆ Terminal

IOTerminal JY5325.EdgeCountingOutEvent.Terminal
getset

Terminal.

◆ Threshold

uint JY5325.EdgeCountingOutEvent.Threshold
getset

Comparison threshold.

The default value is 2^32-1

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325CITask.cs


5325 C# Programming Manual: JY5325.PauseTrigger Class Reference

  • PauseTrigger
Properties | List of all members
JY5325.PauseTrigger Class Referencesealed

Pause trigger configuration class. More...

Properties

LevelPolarity | ActivePolarity [get, set]
Pause trigger active polarity.
InputTerminal | Terminal [get, set]
Terminal.

Detailed Description

Pause trigger configuration class.

Property Documentation

◆ ActivePolarity

LevelPolarity JY5325.PauseTrigger.ActivePolarity
getset

Pause trigger active polarity.

The default value is LevelPolarity.None, means the pause trigger is disabled.

◆ Terminal

InputTerminal JY5325.PauseTrigger.Terminal
getset

Terminal.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325CITask.cs


5325 C# Programming Manual: JY5325.FrequencyMeas Class Reference

  • FrequencyMeas
Properties | List of all members
JY5325.FrequencyMeas Class Referencesealed

Configure CI Measure. More...

Properties

CITimebase | Timebase [get, set]
Timebase configuration.
InputTerminal | InputTerminal [get, set]
Input Terminal.

Detailed Description

Configure CI Measure.

Property Documentation

◆ InputTerminal

InputTerminal JY5325.FrequencyMeas.InputTerminal
getset

Input Terminal.

◆ Timebase

CITimebase JY5325.FrequencyMeas.Timebase
getset

Timebase configuration.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325CITask.cs


5325 C# Programming Manual: JY5325.PeriodMeas Class Reference

  • PeriodMeas
Properties | List of all members
JY5325.PeriodMeas Class Referencesealed

Configure CI Measure. More...

Properties

CITimebase | Timebase [get, set]
Timebase configuration.
InputTerminal | InputTerminal [get, set]
Input Terminal.

Detailed Description

Configure CI Measure.

Property Documentation

◆ InputTerminal

InputTerminal JY5325.PeriodMeas.InputTerminal
getset

Input Terminal.

◆ Timebase

CITimebase JY5325.PeriodMeas.Timebase
getset

Timebase configuration.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325CITask.cs


5325 C# Programming Manual: JY5325.PulseMeas Class Reference

  • PulseMeas
Properties | List of all members
JY5325.PulseMeas Class Referencesealed

Configure CI Measure. More...

Properties

CITimebase | Timebase [get, set]
Timebase configuration.
EdgeType | StartingEdge [get, set]
The start edge of the input signal, the counter will count up or down on this edge.
InputTerminal | InputTerminal [get, set]
Input Terminal.

Detailed Description

Configure CI Measure.

Property Documentation

◆ InputTerminal

InputTerminal JY5325.PulseMeas.InputTerminal
getset

Input Terminal.

◆ StartingEdge

EdgeType JY5325.PulseMeas.StartingEdge
getset

The start edge of the input signal, the counter will count up or down on this edge.

◆ Timebase

CITimebase JY5325.PulseMeas.Timebase
getset

Timebase configuration.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325CITask.cs


5325 C# Programming Manual: JY5325.SemiPeriodMeas Class Reference

  • SemiPeriodMeas
Properties | List of all members
JY5325.SemiPeriodMeas Class Referencesealed

Configure CI Measure. More...

Properties

CITimebase | Timebase [get, set]
Timebase configuration.
EdgeType | StartingEdge [get, set]
The start edge of the input signal, the counter will count up or down on this edge.
InputTerminal | InputTerminal [get, set]
Input Terminal.

Detailed Description

Configure CI Measure.

Property Documentation

◆ InputTerminal

InputTerminal JY5325.SemiPeriodMeas.InputTerminal
getset

Input Terminal.

◆ StartingEdge

EdgeType JY5325.SemiPeriodMeas.StartingEdge
getset

The start edge of the input signal, the counter will count up or down on this edge.

◆ Timebase

CITimebase JY5325.SemiPeriodMeas.Timebase
getset

Timebase configuration.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325CITask.cs


5325 C# Programming Manual: JY5325.TwoEdgeSeparation Class Reference

  • TwoEdgeSeparation
Properties | List of all members
JY5325.TwoEdgeSeparation Class Referencesealed

Configure CI Measure. More...

Properties

CITimebase | Timebase [get, set]
Timebase configuration.
InputTerminal | FirstInputTerminal [get, set]
Input Terminal.
InputTerminal | SecondInputTerminal [get, set]
Input Terminal.
ValueReturnMode | EdgeSeparationMode [get, set]

Detailed Description

Configure CI Measure.

Property Documentation

◆ EdgeSeparationMode

ValueReturnMode JY5325.TwoEdgeSeparation.EdgeSeparationMode
getset

数据返回模式

data return mode

◆ FirstInputTerminal

InputTerminal JY5325.TwoEdgeSeparation.FirstInputTerminal
getset

Input Terminal.

◆ SecondInputTerminal

InputTerminal JY5325.TwoEdgeSeparation.SecondInputTerminal
getset

Input Terminal.

◆ Timebase

CITimebase JY5325.TwoEdgeSeparation.Timebase
getset

Timebase configuration.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325CITask.cs


5325 C# Programming Manual: JY5325.QuadEncoder Class Reference

  • QuadEncoder
Properties | List of all members
JY5325.QuadEncoder Class Referencesealed

Configure CI Measure. More...

Properties

QuadEncodingType | EncodingType [get, set]
Type of Encoding.
bool | ZReloadEnabled [get, set]
In Encoder mode ,the Z signal enable.
int | InitialCount [get, set]
Initial Count.
InputTerminal | AInputTerminal [get, set]
Input Terminal.
InputTerminal | BInputTerminal [get, set]
Input Terminal.
InputTerminal | ZInputTerminal [get, set]
Input Terminal.

Detailed Description

Configure CI Measure.

Property Documentation

◆ AInputTerminal

InputTerminal JY5325.QuadEncoder.AInputTerminal
getset

Input Terminal.

◆ BInputTerminal

InputTerminal JY5325.QuadEncoder.BInputTerminal
getset

Input Terminal.

◆ EncodingType

QuadEncodingType JY5325.QuadEncoder.EncodingType
getset

Type of Encoding.

◆ InitialCount

int JY5325.QuadEncoder.InitialCount
getset

Initial Count.

◆ ZInputTerminal

InputTerminal JY5325.QuadEncoder.ZInputTerminal
getset

Input Terminal.

◆ ZReloadEnabled

bool JY5325.QuadEncoder.ZReloadEnabled
getset

In Encoder mode ,the Z signal enable.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325CITask.cs


5325 C# Programming Manual: JY5325.TwoPulseEncoder Class Reference

  • TwoPulseEncoder
Properties | List of all members
JY5325.TwoPulseEncoder Class Referencesealed

Configure CI Measure. More...

Properties

int | InitialCount [get, set]
Initial Count.
InputTerminal | AInputTerminal [get, set]
Input Terminal.
InputTerminal | BInputTerminal [get, set]
Input Terminal.

Detailed Description

Configure CI Measure.

Property Documentation

◆ AInputTerminal

InputTerminal JY5325.TwoPulseEncoder.AInputTerminal
getset

Input Terminal.

◆ BInputTerminal

InputTerminal JY5325.TwoPulseEncoder.BInputTerminal
getset

Input Terminal.

◆ InitialCount

int JY5325.TwoPulseEncoder.InitialCount
getset

Initial Count.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325CITask.cs


5325 C# Programming Manual: JY5325.CITrigger Class Reference

  • CITrigger
Properties | List of all members
JY5325.CITrigger Class Referencesealed

Constructor to create an CITrigger task object. More...

Properties

CITriggerType | Type [get, set]
CI trigger type.
CIDigitalTrigger | Digital [get, set]
CI Digital Trigger.

Detailed Description

Constructor to create an CITrigger task object.

Used to build CI Trigger

Property Documentation

◆ Digital

CIDigitalTrigger JY5325.CITrigger.Digital
getset

CI Digital Trigger.

Valid when Type is CITriggerType.Digital

◆ Type

CITriggerType JY5325.CITrigger.Type
getset

CI trigger type.

enum Immediate/Digital/Soft.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325CITask.cs


5325 C# Programming Manual: JY5325.CIDigitalTrigger Class Reference

  • CIDigitalTrigger
Properties | List of all members
JY5325.CIDigitalTrigger Class Referencesealed

CI Digital trigger . More...

Properties

CIDigitalTriggerSource | Source [get, set]
CI Digital Trigger source.
CIDigitalTriggerEdge | Edge [get, set]
Digital Trigger edge，Rising/Falling.

Detailed Description

CI Digital trigger .

Property Documentation

◆ Edge

CIDigitalTriggerEdge JY5325.CIDigitalTrigger.Edge
getset

Digital Trigger edge，Rising/Falling.

◆ Source

CIDigitalTriggerSource JY5325.CIDigitalTrigger.Source
getset

CI Digital Trigger source.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325CITask.cs


5325 C# Programming Manual: JY5325.CISignalExport Class Reference

  • CISignalExport
Public Member Functions | List of all members
JY5325.CISignalExport Class Reference

CI Signal Export Class. More...

Public Member Functions

void | Add (CISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (CISignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

CI Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY5325.CISignalExport.Add | ( | CISignalExportSource | source,
 |  | List< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | CI Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY5325.CISignalExport.Add | ( | CISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | CI Signal Source
destination | Export Desination

◆ Clear()

void JY5325.CISignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5325.CISignalExport.ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325CITask.cs


5325 C# Programming Manual: D:/5325/C#/JY5325COTask.cs File Reference

  • File List
  • 5325
  • C#
Classes | Namespaces | Enumerations
JY5325COTask.cs File Reference

Classes

class | JY5325.JY5325COTask
JY5325 Counter Output Task. More...
class | JY5325.COTrigger
Constructor to create an COTrigger task object. More...
class | JY5325.CODigitalTrigger
CO Digital trigger . More...
class | JY5325.COPulse
Pulse Parameter. More...
class | JY5325.COExternalTimebase
class | JY5325.COTimebase
class | JY5325.COSignalExport
CO Signal Export Class. More...

Namespaces

namespace JY5325

Enumerations

enum | JY5325.COIdleState { JY5325.HighLevel = JY5325Import.JY5325_HighLevel , JY5325.LowLevel = JY5325Import.JY5325_LowLevel }
Idle state when pulse output before start and after stop. More...
enum | JY5325.COMode { JY5325.Single = JY5325Import.JY5325_CO_Single , JY5325.Finite = JY5325Import.JY5325_CO_Finite , JY5325.ContinuousNoWrapping = JY5325Import.JY5325_CO_ContinuousNoWrapping , JY5325.ContinuousWrapping = JY5325Import.JY5325_CO_ContinuousWrapping }
CO output mode. More...
enum | JY5325.COTriggerType { JY5325.Immediate = JY5325Import.JY5325_CIO_Immediately , JY5325.Digital = JY5325Import.JY5325_CIO_Digital , JY5325.Soft = JY5325Import.JY5325_CIO_Soft }
TriggerType Digital/Immediate/Soft. More...
enum JY5325.CODigitalTriggerSource {
JY5325.PFI0 = JY5325Import.JY5325_PFI0 , JY5325.PFI1 = JY5325Import.JY5325_PFI1 , JY5325.PFI2 = JY5325Import.JY5325_PFI2 , JY5325.PFI3 = JY5325Import.JY5325_PFI3 ,
JY5325.PFI4 = JY5325Import.JY5325_PFI4 , JY5325.PFI5 = JY5325Import.JY5325_PFI5 , JY5325.PFI6 = JY5325Import.JY5325_PFI6 , JY5325.PFI7 = JY5325Import.JY5325_PFI7 ,
JY5325.PXI_Trig0 = JY5325Import.JY5325_PXI_Trig0 , JY5325.PXI_Trig1 = JY5325Import.JY5325_PXI_Trig1 , JY5325.PXI_Trig2 = JY5325Import.JY5325_PXI_Trig2 , JY5325.PXI_Trig3 = JY5325Import.JY5325_PXI_Trig3 ,
JY5325.PXI_Trig4 = JY5325Import.JY5325_PXI_Trig4 , JY5325.PXI_Trig5 = JY5325Import.JY5325_PXI_Trig5 , JY5325.PXI_Trig6 = JY5325Import.JY5325_PXI_Trig6 , JY5325.PXI_Trig7 = JY5325Import.JY5325_PXI_Trig7 ,
JY5325.AI_StartTrig = JY5325Import.JY5325_Inter_AI_StartTrig , JY5325.AI_ReferenceTrig = JY5325Import.JY5325_Inter_AI_ReferenceTrig , JY5325.AO_StartTrig = JY5325Import.JY5325_Inter_AO_StartTrig , JY5325.DI_StartTrig = JY5325Import.JY5325_Inter_DI_StartTrig ,
JY5325.DI_ReferenceTrig = JY5325Import.JY5325_Inter_DI_ReferenceTrig , JY5325.DO_StartTrig = JY5325Import.JY5325_Inter_DO_StartTrig , JY5325.CIO_0_StartTrig = JY5325Import.JY5325_Inter_Counter_0_StartTrig , JY5325.CIO_1_StartTrig = JY5325Import.JY5325_Inter_Counter_1_StartTrig ,
JY5325.CO_0_Out = JY5325Import.JY5325_Inter_Counter_0_Out , JY5325.CO_1_Out = JY5325Import.JY5325_Inter_Counter_1_Out
}
CO Digital trigger source. More...
enum | JY5325.CODigitalTriggerEdge { JY5325.Rising = JY5325Import.JY5325_Rising , JY5325.Falling = JY5325Import.JY5325_Falling }
CO Digital Trigger Edge. More...
enum | JY5325.COPulseType { JY5325.DutyCycleFrequency , JY5325.HighLowTime , JY5325.HighLowTick }
Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick. More...
enum | JY5325.COTimebaseSource { JY5325.Internal100MHz = 0 , JY5325.Internal5MHz = 1 , JY5325.Internal100kHz = 2 , JY5325.External = 3 }
enum JY5325.COSignalExportSource {
JY5325.StartTrig , JY5325.Output , JY5325.Internal_Counter_100K = JY5325Import.JY5325_Signal_CIO_100kHz , JY5325.Internal_Counter_5M = JY5325Import.JY5325_Signal_CIO_5MHz ,
JY5325.Internal_Counter_100M = JY5325Import.JY5325_Signal_CIO_100MHz
}
SourceSignal. More...


5325 C# Programming Manual: JY5325.JY5325COTask Class Reference

  • JY5325COTask
Public Member Functions | Properties | List of all members
JY5325.JY5325COTask Class Referencesealed

JY5325 Counter Output Task. More...

Public Member Functions

JY5325COTask (int slotNum, int channel)
Constructor.
JY5325COTask (string boardName, int channel)
Constructor.
void | WriteSinglePoint (COPulse pulse)
Write a single pulse parameter to the register.
void | WriteData (COPulse[] pulsesGroup, int samplesToWrite, int timeout=10000)
Write pulse parameters to be output to the buffer.
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Start ()
Start CO task .
void | Stop ()
Stop COtask .
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.

Properties

COMode | Mode [get, set]
CO output mode.
IOTerminal | OutputTerminal [get, set]
Pulse Output Terminal.
PauseTrigger | Pause [get, set]
Pause Trigger Configuration.
COTimebase | Timebase [get, set]
CO's time base.
double | InitialDelay [get, set]
Counter output initial delay in seconds.
COIdleState | IdleState [get, set]
Idle state when pulse output before start and after stop.
uint | SamplesToUpdate [get, set]
Number of output samples to write, Only valid when Mode is COMode.Finite.
int | BufLenInSamples [get]
Number of samples can be storage in the buffer, the PropretySamplesToUpdate must be less than or equal to this value.
uint | AvaliableLenInSamples [get]
Number of output samples per channel that can be write in buffuer.
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel).
uint | TransferedPulses [get]
The number of pulses transfered under the current configuration.
COTrigger | Trigger = new COTrigger() [get, set]
CO trigger property configured by CO Trigger().
JY5325Device | Device [get]
Device.
COSignalExport | SignalExport [get, set]
Export CO Signal Configuration.

Detailed Description

JY5325 Counter Output Task.

Constructor & Destructor Documentation

◆ JY5325COTask() [1/2]

JY5325.JY5325COTask.JY5325COTask | ( | int | slotNum,
 |  | int | channel )

Constructor.

Used to create an CO task by a slot number.

Parameters
slotNum | Card slot number.
channel | Counter channel suppor0-1.

◆ JY5325COTask() [2/2]

JY5325.JY5325COTask.JY5325COTask | ( | string | boardName,
 |  | int | channel )

Constructor.

Used to create an CO task by a board name.

Parameters
boardName | Board name(device alias), set by device manager
channel | Counter channel suppor0-1.

Member Function Documentation

◆ SendSoftwareTrigger()

void JY5325.JY5325COTask.SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5325.JY5325COTask.Start ( )

Start CO task .

◆ Stop()

void JY5325.JY5325COTask.Stop ( )

Stop COtask .

◆ WaitUntilDone()

bool JY5325.JY5325COTask.WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteData()

void JY5325.JY5325COTask.WriteData | ( | COPulse[] | pulsesGroup,
 |  | int | samplesToWrite,
 |  | int | timeout = 10000 )

Write pulse parameters to be output to the buffer.

Valid when Mode is NOT COMode.Single. When Mode is COMode.Finite or COMode.ContinuousWrapping, this function can only be called once before starting the task.

Parameters
pulsesGroup | A group of pulse parameters
samplesToWrite | Number of samples to write. If Mode is COMode.ContinuousWrapping, you need to write at least 2 samples before starting the task
timeout | Timeout (ms). Wait until all data is written to buffer or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ WriteSinglePoint()

void JY5325.JY5325COTask.WriteSinglePoint ( COPulse pulse )

Write a single pulse parameter to the register.

Valid when Mode is COMode.Single. This function is also available after starting the task when the number of pulses being sent is infinite.

Parameters
pulse Pulse Parameter

Property Documentation

◆ AvaliableLenInSamples

uint JY5325.JY5325COTask.AvaliableLenInSamples
get

Number of output samples per channel that can be write in buffuer.

◆ BufLenInSamples

int JY5325.JY5325COTask.BufLenInSamples
get

Number of samples can be storage in the buffer, the PropretySamplesToUpdate must be less than or equal to this value.

◆ Device

JY5325Device JY5325.JY5325COTask.Device
get

Device.

◆ IdleState

COIdleState JY5325.JY5325COTask.IdleState
getset

Idle state when pulse output before start and after stop.

◆ InitialDelay

double JY5325.JY5325COTask.InitialDelay
getset

Counter output initial delay in seconds.

There are five ticks of the timebase fixed delay in counter internal, so the total delay(s) = InitialDelay + (5 / timebase)

◆ Mode

COMode JY5325.JY5325COTask.Mode
getset

CO output mode.

◆ OutputTerminal

IOTerminal JY5325.JY5325COTask.OutputTerminal
getset

Pulse Output Terminal.

◆ Pause

PauseTrigger JY5325.JY5325COTask.Pause
getset

Pause Trigger Configuration.

◆ SamplesToUpdate

uint JY5325.JY5325COTask.SamplesToUpdate
getset

Number of output samples to write, Only valid when Mode is COMode.Finite.

◆ SignalExport

COSignalExport JY5325.JY5325COTask.SignalExport
getset

Export CO Signal Configuration.

◆ Timebase

COTimebase JY5325.JY5325COTask.Timebase
getset

CO's time base.

◆ TransferedPulses

uint JY5325.JY5325COTask.TransferedPulses
get

The number of pulses transfered under the current configuration.

◆ TransferedSamples

ulong JY5325.JY5325COTask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT COMode.Single.

◆ Trigger

COTrigger JY5325.JY5325COTask.Trigger = new COTrigger()
getset

CO trigger property configured by CO Trigger().

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325COTask.cs


5325 C# Programming Manual: JY5325.COTrigger Class Reference

  • COTrigger
Properties | List of all members
JY5325.COTrigger Class Referencesealed

Constructor to create an COTrigger task object. More...

Properties

COTriggerType | Type [get, set]
CO trigger type.
CODigitalTrigger | Digital [get, set]
CO Digital Trigger.

Detailed Description

Constructor to create an COTrigger task object.

Used to build CO Trigger

Property Documentation

◆ Digital

CODigitalTrigger JY5325.COTrigger.Digital
getset

CO Digital Trigger.

Valid when Type is COTriggerType.Digital

◆ Type

COTriggerType JY5325.COTrigger.Type
getset

CO trigger type.

enum Immediate/Digital/Soft.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325COTask.cs


5325 C# Programming Manual: JY5325.CODigitalTrigger Class Reference

  • CODigitalTrigger
Properties | List of all members
JY5325.CODigitalTrigger Class Referencesealed

CO Digital trigger . More...

Properties

CODigitalTriggerSource | Source [get, set]
CO Digital Trigger source.
CODigitalTriggerEdge | Edge [get, set]
Digital Trigger edge，Rising/Falling.

Detailed Description

CO Digital trigger .

Property Documentation

◆ Edge

CODigitalTriggerEdge JY5325.CODigitalTrigger.Edge
getset

Digital Trigger edge，Rising/Falling.

◆ Source

CODigitalTriggerSource JY5325.CODigitalTrigger.Source
getset

CO Digital Trigger source.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325COTask.cs


5325 C# Programming Manual: JY5325.COPulse Class Reference

  • COPulse
Public Member Functions | List of all members
JY5325.COPulse Class Reference

Pulse Parameter. More...

Public Member Functions

COPulse (COPulseType type, double param1, double param2, int count)
Pulse Parameter.

Detailed Description

Pulse Parameter.

Constructor & Destructor Documentation

◆ COPulse()

JY5325.COPulse.COPulse | ( | COPulseType | type,
 |  | double | param1,
 |  | double | param2,
 |  | int | count )

Pulse Parameter.

Parameters
type | The pulse type characteristics.
param1 | Parameter 1. Frequency (Hz) when constructed as COPulseType.DutyCycleFrequency; High duration in seconds when constructed as COPulseType.HighLowTime; High ticks of the clock when constructed as COPulseType.HighLowTick.
param2 | Parameter 1. Duty cycle (greater than 0 and less than 1) when constructed as COPulseType.DutyCycleFrequency; Low duration in seconds when constructed as COPulseType.HighLowTime; Low ticks of the clock when constructed as COPulseType.HighLowTick.
count | Number of pulses. When the value is -1 (indicating that the number of pulses is infinite), pulses will be continuously sent until requested to stop.
The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325COTask.cs


5325 C# Programming Manual: JY5325.COExternalTimebase Class Reference

  • COExternalTimebase
Properties | List of all members
JY5325.COExternalTimebase Class Referencesealed

Properties

InputTerminal | Terminal [get, set]
double | Frequency [get, set]

Detailed Description

外部时基配置类

External timebase configuration class

Property Documentation

◆ Frequency

double JY5325.COExternalTimebase.Frequency
getset

外部时基的频率

Frequency of The External Timebase

◆ Terminal

InputTerminal JY5325.COExternalTimebase.Terminal
getset

外部时基的输入端口

External Timebase Input Terminal

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325COTask.cs


5325 C# Programming Manual: JY5325.COTimebase Class Reference

  • COTimebase
Properties | List of all members
JY5325.COTimebase Class Referencesealed

Properties

COTimebaseSource | Source [get, set]
COExternalTimebase | External [get, set]

Detailed Description

时基配置类

Timebase configuration class

Property Documentation

◆ External

COExternalTimebase JY5325.COTimebase.External
getset

外部时基配置。当 COTimebase.Source 为 COTimebaseSource.External时有效。

External Timebase Configuration. Valid when COTimebase.Source is COTimebaseSource.External.

◆ Source

COTimebaseSource JY5325.COTimebase.Source
getset

时基源。默认值为 COTimebaseSource.Internal100MHz。

Timebase Source. The default value is COTimebaseSource.Internal100MHz.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325COTask.cs


5325 C# Programming Manual: JY5325.COSignalExport Class Reference

  • COSignalExport
Public Member Functions | List of all members
JY5325.COSignalExport Class Reference

CO Signal Export Class. More...

Public Member Functions

void | Add (COSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (COSignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

CO Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY5325.COSignalExport.Add | ( | COSignalExportSource | source,
 |  | List< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | CO Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY5325.COSignalExport.Add | ( | COSignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | CO Signal Source
destination | Export Desination

◆ Clear()

void JY5325.COSignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5325.COSignalExport.ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325COTask.cs


5325 C# Programming Manual: D:/5325/C#/JY5325DITask.cs File Reference

  • File List
  • 5325
  • C#
Classes | Namespaces | Enumerations
JY5325DITask.cs File Reference

Classes

class | JY5325.JY5325DITask
JY5325DITask Class. More...
class | JY5325.DIChannel
DI Channel parameter class. More...
class | JY5325.DITrigger
Constructor to create an DITrigger task object. More...
class | JY5325.DIDigitalTrigger
DI Digital trigger . More...
class | JY5325.DISampleClock
Sample clock configuration class. More...
class | JY5325.DIExternalSampleClock
External Sample Clock Configuration Class. More...
class | JY5325.DISignalExport
DI Signal Export Class. More...

Namespaces

namespace JY5325

Enumerations

enum | JY5325.DITriggerMode { JY5325.Start , JY5325.Reference }
DI Trigger Mode. More...
enum | JY5325.DITriggerType { JY5325.Immediate = JY5325Import.JY5325_DI_Immediately , JY5325.Digital = JY5325Import.JY5325_DI_Digital , JY5325.Soft = JY5325Import.JY5325_DI_Soft }
TriggerType Digital/Immediate/Soft. More...
enum JY5325.DIDigitalTriggerSource {
JY5325.PFI0 = JY5325Import.JY5325_PFI0 , JY5325.PFI1 = JY5325Import.JY5325_PFI1 , JY5325.PFI2 = JY5325Import.JY5325_PFI2 , JY5325.PFI3 = JY5325Import.JY5325_PFI3 ,
JY5325.PFI4 = JY5325Import.JY5325_PFI4 , JY5325.PFI5 = JY5325Import.JY5325_PFI5 , JY5325.PFI6 = JY5325Import.JY5325_PFI6 , JY5325.PFI7 = JY5325Import.JY5325_PFI7 ,
JY5325.PXI_Trig0 = JY5325Import.JY5325_PXI_Trig0 , JY5325.PXI_Trig1 = JY5325Import.JY5325_PXI_Trig1 , JY5325.PXI_Trig2 = JY5325Import.JY5325_PXI_Trig2 , JY5325.PXI_Trig3 = JY5325Import.JY5325_PXI_Trig3 ,
JY5325.PXI_Trig4 = JY5325Import.JY5325_PXI_Trig4 , JY5325.PXI_Trig5 = JY5325Import.JY5325_PXI_Trig5 , JY5325.PXI_Trig6 = JY5325Import.JY5325_PXI_Trig6 , JY5325.PXI_Trig7 = JY5325Import.JY5325_PXI_Trig7 ,
JY5325.AI_StartTrig = JY5325Import.JY5325_Inter_AI_StartTrig , JY5325.AI_ReferenceTrig = JY5325Import.JY5325_Inter_AI_ReferenceTrig , JY5325.AO_StartTrig = JY5325Import.JY5325_Inter_AO_StartTrig , JY5325.DO_StartTrig = JY5325Import.JY5325_Inter_DO_StartTrig ,
JY5325.CIO_0_StartTrig = JY5325Import.JY5325_Inter_Counter_0_StartTrig , JY5325.CIO_1_StartTrig = JY5325Import.JY5325_Inter_Counter_1_StartTrig , JY5325.CO_0_Out = JY5325Import.JY5325_Inter_Counter_0_Out , JY5325.CO_1_Out = JY5325Import.JY5325_Inter_Counter_1_Out
}
DI Digital trigger source. More...
enum | JY5325.DIDigitalTriggerEdge { JY5325.Rising = JY5325Import.JY5325_Rising , JY5325.Falling = JY5325Import.JY5325_Falling }
DI Digital Trigger Edge. More...
enum | JY5325.DISampleClockSource { JY5325.Internal = JY5325Import.JY5325_InternalClock , JY5325.External = JY5325Import.JY5325_ExternalClock }
DI Sample Clock Source. More...
enum | JY5325.DIMode { JY5325.Single = JY5325Import.JY5325_DI_Single , JY5325.Finite = JY5325Import.JY5325_DI_Finite , JY5325.Continuous = JY5325Import.JY5325_DI_Continuous }
DIMode. More...
enum JY5325.DISignalExportSource {
JY5325.StartTrig = JY5325Import.JY5325_Signal_DI_StartTrig , JY5325.ReferenceTrig = JY5325Import.JY5325_Signal_DI_ReferenceTrig , JY5325.SampleClock = JY5325Import.JY5325_Signal_DI_SampleClock , JY5325.Internal_Counter_100K = JY5325Import.JY5325_Signal_CIO_100kHz ,
JY5325.Internal_Counter_5M = JY5325Import.JY5325_Signal_CIO_5MHz , JY5325.Internal_Counter_100M = JY5325Import.JY5325_Signal_CIO_100MHz
}
SourceSignal. More...


5325 C# Programming Manual: JY5325.JY5325DITask Class Reference

  • JY5325DITask
Public Member Functions | Properties | List of all members
JY5325.JY5325DITask Class Referencesealed

JY5325DITask Class. More...

Public Member Functions

JY5325DITask (int slotNum)
Constructor.
JY5325DITask (string aliasName)
Constructor.
void | AddChannel (int lineNum)
Add one line.
void | AddChannel (int[] linesNum)
Add a group of line.
void | RemoveChannel (int lineNum)
Delete the specified line number.
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Start ()
Start DITask.
void | Stop ()
Stop DITask.
void | ReadSinglePoint (ref bool readValue, int line)
Specify the port reads the latest point.
void | ReadSinglePoint (ref bool[] readValues)
Each line reads the latest point.
void | ReadData (ref byte[] dataBuffer, uint samplesToAcquire, int timeOut=10000)
Read the byte data from one line or multi-lines.
void | ReadData (ref byte[,] dataBuffer, uint samplesToAcquire, int timeOut=10000)
Read the line byte data from the lines.

Properties

JY5325Device | Device [get]
Device Handle.
List< DIChannel > | Channels [get]
List of DI channels.
double | SampleRate [get, set]
Sample rate per channel.
int | SamplesToAcquire [get, set]
Number of samples to be read per channel.
DITrigger | Trigger [get, set]
DI Trigger Configuration.
DISampleClock | SampleClock [get, set]
DI Sample Clock Configuration.
int | BufLenInSamples [get]
Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.
DIMode | Mode [get, set]
DI acquisition mode，support Single/ Finite/Continuous.
ulong | AvailableSamples [get]
Number of samples per channel that can be read in the buffer.
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel).
DISignalExport | SignalExport [get, set]
Export DI Signal.

Detailed Description

JY5325DITask Class.

Constructor & Destructor Documentation

◆ JY5325DITask() [1/2]

JY5325.JY5325DITask.JY5325DITask ( int slotNum )

Constructor.

Used to create an DItask object

Parameters
slotNum Card slot number

◆ JY5325DITask() [2/2]

JY5325.JY5325DITask.JY5325DITask ( string aliasName )

Constructor.

Used to create an DItask object

Parameters
aliasName AliasName

Member Function Documentation

◆ AddChannel() [1/2]

void JY5325.JY5325DITask.AddChannel ( int lineNum )

Add one line.

Parameters
lineNum line number

◆ AddChannel() [2/2]

void JY5325.JY5325DITask.AddChannel ( int[] linesNum )

Add a group of line.

Parameters
linesNum line number

◆ ReadData() [1/2]

void JY5325.JY5325DITask.ReadData | ( | ref byte | dataBuffer[,],
 |  | uint | samplesToAcquire,
 |  | int | timeOut = 10000 )

Read the line byte data from the lines.

Each column represents one line.

Parameters
dataBuffer | Data buffer
samplesToAcquire | Number of samples per port to be read
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadData() [2/2]

void JY5325.JY5325DITask.ReadData | ( | ref byte[] | dataBuffer,
 |  | uint | samplesToAcquire,
 |  | int | timeOut = 10000 )

Read the byte data from one line or multi-lines.

There are 8 lines, from 0 to 7. Each bit from low to high represents one line.

Parameters
dataBuffer | Data buffer
samplesToAcquire | Number of samples per port to be read
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadSinglePoint() [1/2]

void JY5325.JY5325DITask.ReadSinglePoint | ( | ref bool | readValue,
 |  | int | line )

Specify the port reads the latest point.

Parameters
readValue | User buffer array
line | Specify the line to read

◆ ReadSinglePoint() [2/2]

void JY5325.JY5325DITask.ReadSinglePoint ( ref bool[] readValues )

Each line reads the latest point.

Parameters
readValues User buffer array

◆ RemoveChannel()

void JY5325.JY5325DITask.RemoveChannel ( int lineNum )

Delete the specified line number.

Parameters
lineNum line number

◆ SendSoftwareTrigger()

void JY5325.JY5325DITask.SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5325.JY5325DITask.Start ( )

Start DITask.

◆ Stop()

void JY5325.JY5325DITask.Stop ( )

Stop DITask.

Property Documentation

◆ AvailableSamples

ulong JY5325.JY5325DITask.AvailableSamples
get

Number of samples per channel that can be read in the buffer.

◆ BufLenInSamples

int JY5325.JY5325DITask.BufLenInSamples
get

Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.

◆ Channels

List<DIChannel> JY5325.JY5325DITask.Channels
get

List of DI channels.

◆ Device

JY5325Device JY5325.JY5325DITask.Device
get

Device Handle.

◆ Mode

DIMode JY5325.JY5325DITask.Mode
getset

DI acquisition mode，support Single/ Finite/Continuous.

◆ SampleClock

DISampleClock JY5325.JY5325DITask.SampleClock
getset

DI Sample Clock Configuration.

◆ SampleRate

double JY5325.JY5325DITask.SampleRate
getset

Sample rate per channel.

Maximum sample rate is 10M The defalut sample rate = 10k You can read this property to obtain the sample rate that will actually take effect in the current configuration.

◆ SamplesToAcquire

int JY5325.JY5325DITask.SamplesToAcquire
getset

Number of samples to be read per channel.

Only valid when Mode is DIMode.Finite.

◆ SignalExport

DISignalExport JY5325.JY5325DITask.SignalExport
getset

Export DI Signal.

◆ TransferedSamples

ulong JY5325.JY5325DITask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT DIMode.Single.

◆ Trigger

DITrigger JY5325.JY5325DITask.Trigger
getset

DI Trigger Configuration.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325DITask.cs


5325 C# Programming Manual: JY5325.DIChannel Class Reference

  • DIChannel
Properties | List of all members
JY5325.DIChannel Class Referencesealed

DI Channel parameter class. More...

Properties

int LineNum [get, set]
line Number

Detailed Description

DI Channel parameter class.

Property Documentation

◆ LineNum

int JY5325.DIChannel.LineNum
getset

line Number

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325DITask.cs


5325 C# Programming Manual: JY5325.DITrigger Class Reference

  • DITrigger
Properties | List of all members
JY5325.DITrigger Class Referencesealed

Constructor to create an DITrigger task object. More...

Properties

DITriggerType | Type [get, set]
DI trigger type.
DITriggerMode | Mode [get, set]
DI trigger mode.
DIDigitalTrigger | Digital [get, set]
DI Digital Trigger.Valid when Type is DITriggerType.Digital.
uint | PreTriggerSamples [get, set]
Pretrigger Samples, must be less than or equal to JY5325DITask.SamplesToAcquire.

Detailed Description

Constructor to create an DITrigger task object.

Used to build DI Trigger

Property Documentation

◆ Digital

DIDigitalTrigger JY5325.DITrigger.Digital
getset

DI Digital Trigger.Valid when Type is DITriggerType.Digital.

◆ Mode

DITriggerMode JY5325.DITrigger.Mode
getset

DI trigger mode.

enum Start/Reference.

◆ PreTriggerSamples

uint JY5325.DITrigger.PreTriggerSamples
getset

Pretrigger Samples, must be less than or equal to JY5325DITask.SamplesToAcquire.

Valid when Mode is DITriggerMode.Reference. Pretrigger samples, must be greater than 1. Valid when Type is DITriggerType.Digital.

◆ Type

DITriggerType JY5325.DITrigger.Type
getset

DI trigger type.

enum Digital/Immediate/Soft.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325DITask.cs


5325 C# Programming Manual: JY5325.DIDigitalTrigger Class Reference

  • DIDigitalTrigger
Properties | List of all members
JY5325.DIDigitalTrigger Class Referencesealed

DI Digital trigger . More...

Properties

DIDigitalTriggerSource | Source [get, set]
DI Digital Trigger source.
DIDigitalTriggerEdge | Edge [get, set]
Digital Trigger edge，Rising/Falling.

Detailed Description

DI Digital trigger .

Property Documentation

◆ Edge

DIDigitalTriggerEdge JY5325.DIDigitalTrigger.Edge
getset

Digital Trigger edge，Rising/Falling.

◆ Source

DIDigitalTriggerSource JY5325.DIDigitalTrigger.Source
getset

DI Digital Trigger source.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325DITask.cs


5325 C# Programming Manual: JY5325.DISampleClock Class Reference

  • DISampleClock
Properties | List of all members
JY5325.DISampleClock Class Reference

Sample clock configuration class. More...

Properties

DISampleClockSource | Source [get, set]
Clock Source.
DIExternalSampleClock | External [get, set]
External Sample Clock, Valid when Source is DISampleClockSource.External.

Detailed Description

Sample clock configuration class.

Property Documentation

◆ External

DIExternalSampleClock JY5325.DISampleClock.External
getset

External Sample Clock, Valid when Source is DISampleClockSource.External.

◆ Source

DISampleClockSource JY5325.DISampleClock.Source
getset

Clock Source.

enum Internal/External

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325DITask.cs


5325 C# Programming Manual: JY5325.DIExternalSampleClock Class Reference

  • DIExternalSampleClock
Properties | List of all members
JY5325.DIExternalSampleClock Class Reference

External Sample Clock Configuration Class. More...

Properties

ClockTerminal | Terminal [get, set]
External Sample Clock Input Terminal.
double | ExpectedRate [get, set]
Expected External Sample Clock Rate.

Detailed Description

External Sample Clock Configuration Class.

Property Documentation

◆ ExpectedRate

double JY5325.DIExternalSampleClock.ExpectedRate
getset

Expected External Sample Clock Rate.

◆ Terminal

ClockTerminal JY5325.DIExternalSampleClock.Terminal
getset

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325DITask.cs


5325 C# Programming Manual: JY5325.DISignalExport Class Reference

  • DISignalExport
Public Member Functions | List of all members
JY5325.DISignalExport Class Reference

DI Signal Export Class. More...

Public Member Functions

void | Add (DISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (DISignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

DI Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY5325.DISignalExport.Add | ( | DISignalExportSource | source,
 |  | List< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | DI Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY5325.DISignalExport.Add | ( | DISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | DI Signal Source
destination | Export Desination

◆ Clear()

void JY5325.DISignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5325.DISignalExport.ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325DITask.cs


5325 C# Programming Manual: D:/5325/C#/JY5325DOTask.cs File Reference

  • File List
  • 5325
  • C#
Classes | Namespaces | Enumerations
JY5325DOTask.cs File Reference

Classes

class | JY5325.JY5325DOTask
JY5325 DOTask. More...
class | JY5325.DOChannel
DOChannel class. More...
class | JY5325.DOTrigger
Constructor to create an DOTrigger task object. More...
class | JY5325.DODigitalTrigger
DO Digital trigger. More...
class | JY5325.DOSampleClock
Sample clock configuration class. More...
class | JY5325.DOExternalSampleClock
External Sample Clock Configuration Class. More...
class | JY5325.DOSignalExport
DO Signal Export Class. More...

Namespaces

namespace JY5325

Enumerations

enum | JY5325.DOTriggerType { JY5325.Immediate = JY5325Import.JY5325_DO_Immediately , JY5325.Digital = JY5325Import.JY5325_DO_Digital , JY5325.Soft = JY5325Import.JY5325_DO_Soft }
TriggerType Digital/Immediate/Soft. More...
enum JY5325.DODigitalTriggerSource {
JY5325.PFI0 = JY5325Import.JY5325_PFI0 , JY5325.PFI1 = JY5325Import.JY5325_PFI1 , JY5325.PFI2 = JY5325Import.JY5325_PFI2 , JY5325.PFI3 = JY5325Import.JY5325_PFI3 ,
JY5325.PFI4 = JY5325Import.JY5325_PFI4 , JY5325.PFI5 = JY5325Import.JY5325_PFI5 , JY5325.PFI6 = JY5325Import.JY5325_PFI6 , JY5325.PFI7 = JY5325Import.JY5325_PFI7 ,
JY5325.PXI_Trig0 = JY5325Import.JY5325_PXI_Trig0 , JY5325.PXI_Trig1 = JY5325Import.JY5325_PXI_Trig1 , JY5325.PXI_Trig2 = JY5325Import.JY5325_PXI_Trig2 , JY5325.PXI_Trig3 = JY5325Import.JY5325_PXI_Trig3 ,
JY5325.PXI_Trig4 = JY5325Import.JY5325_PXI_Trig4 , JY5325.PXI_Trig5 = JY5325Import.JY5325_PXI_Trig5 , JY5325.PXI_Trig6 = JY5325Import.JY5325_PXI_Trig6 , JY5325.PXI_Trig7 = JY5325Import.JY5325_PXI_Trig7 ,
JY5325.AI_StartTrig = JY5325Import.JY5325_Inter_AI_StartTrig , JY5325.AI_ReferenceTrig = JY5325Import.JY5325_Inter_AI_ReferenceTrig , JY5325.AO_StartTrig = JY5325Import.JY5325_Inter_AO_StartTrig , JY5325.DI_StartTrig = JY5325Import.JY5325_Inter_DI_StartTrig ,
JY5325.DI_ReferenceTrig = JY5325Import.JY5325_Inter_DI_ReferenceTrig , JY5325.CIO_0_StartTrig = JY5325Import.JY5325_Inter_Counter_0_StartTrig , JY5325.CIO_1_StartTrig = JY5325Import.JY5325_Inter_Counter_1_StartTrig , JY5325.CO_0_Out = JY5325Import.JY5325_Inter_Counter_0_Out ,
JY5325.CO_1_Out = JY5325Import.JY5325_Inter_Counter_1_Out
}
DO Digital trigger source. More...
enum | JY5325.DODigitalTriggerEdge { JY5325.Rising = JY5325Import.JY5325_Rising , JY5325.Falling = JY5325Import.JY5325_Falling }
DO Digital Trigger Edge. More...
enum | JY5325.DOSampleClockSource { JY5325.Internal = JY5325Import.JY5325_InternalClock , JY5325.External = JY5325Import.JY5325_ExternalClock }
DO Sample Clock Source. More...
enum JY5325.DOSignalExportSource {
JY5325.StartTrig = JY5325Import.JY5325_Signal_DO_StartTrig , JY5325.SampleClock = JY5325Import.JY5325_Signal_DO_SampleClock , JY5325.Internal_Counter_100K = JY5325Import.JY5325_Signal_CIO_100kHz , JY5325.Internal_Counter_5M = JY5325Import.JY5325_Signal_CIO_5MHz ,
JY5325.Internal_Counter_100M = JY5325Import.JY5325_Signal_CIO_100MHz
}
SourceSignal. More...
enum | JY5325.DOMode { JY5325.Single = JY5325Import.JY5325_DO_Single , JY5325.Finite = JY5325Import.JY5325_DO_Finite , JY5325.ContinuousWrapping = JY5325Import.JY5325_DO_ContinuousWrapping , JY5325.ContinuousNoWrapping = JY5325Import.JY5325_DO_ContinuousNoWrapping }
DOMode. More...


5325 C# Programming Manual: JY5325.JY5325DOTask Class Reference

  • JY5325DOTask
Public Member Functions | Properties | List of all members
JY5325.JY5325DOTask Class Referencesealed

JY5325 DOTask. More...

Public Member Functions

JY5325DOTask (int slotNum)
Constructor.
JY5325DOTask (string aliasName)
Constructor.
void | AddChannel (int lineNum)
Add one line.
void | AddChannel (int[] linesNum)
Add mulitiple line.
void | RemoveChannel (int lineNum)
delete the specified line number
void | Start ()
Start DOTask.
void | Stop ()
Stop DOTask.
void | WriteSinglePoint (bool writeValues, int line)
write the latest point of Specify port
void | WriteSinglePoint (bool[] writeValues)
write the latest point
void | SendSoftwareTrigger ()
Generate a software trigger.
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.
void | WriteData (byte[] dataBuffer, uint samplesToUpdate, int timeOut=10000)
Write the byte data for one line or multi-lines.
void | WriteData (byte[,] dataBuffer, uint samplesToUpdate, int timeOut=10000)
write the line byte data to the lines.

Properties

JY5325Device | Device [get]
Device Handle.
List< DOChannel > | Channels [get]
List of DO channels.
double | UpdateRate [get, set]
Update rate per channel.
int | SamplesToUpdate [get, set]
Number of output samples to write per channel , Only valid when Mode is DOMode.Finite.
DOTrigger | Trigger [get, set]
DO Trigger Configuration.
DOSampleClock | SampleClock [get, set]
DO Sample Clock Configuration .
DOSignalExport | SignalExport [get, set]
Export DO Signal.
DOMode | Mode [get, set]
DO acquisition mode.Select DO Mode from enum:ContinuousNoWrapping/ContinuousWrapping/Finite/Single.
int | BufLenInSamples [get]
Number of samples per channel can be storage in the buffer, the PropretySamplesToUpdate must be less than or equal to this value.
uint | AvaliableLenInSamples [get]
Number of output samples per channel avaliable to write in DO buffuer.
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel).

Detailed Description

JY5325 DOTask.

Constructor & Destructor Documentation

◆ JY5325DOTask() [1/2]

JY5325.JY5325DOTask.JY5325DOTask ( int slotNum )

Constructor.

Used to create an DOtask object

Parameters
slotNum slot Number

◆ JY5325DOTask() [2/2]

JY5325.JY5325DOTask.JY5325DOTask ( string aliasName )

Constructor.

Used to create an DOtask object

Parameters
aliasName AliasName

Member Function Documentation

◆ AddChannel() [1/2]

void JY5325.JY5325DOTask.AddChannel ( int lineNum )

Add one line.

Parameters
lineNum line number

◆ AddChannel() [2/2]

void JY5325.JY5325DOTask.AddChannel ( int[] linesNum )

Add mulitiple line.

Parameters
linesNum line number

◆ RemoveChannel()

void JY5325.JY5325DOTask.RemoveChannel ( int lineNum )

delete the specified line number

Parameters
lineNum line number

◆ SendSoftwareTrigger()

void JY5325.JY5325DOTask.SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5325.JY5325DOTask.Start ( )

Start DOTask.

◆ Stop()

void JY5325.JY5325DOTask.Stop ( )

Stop DOTask.

◆ WaitUntilDone()

bool JY5325.JY5325DOTask.WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Available when Mode is DOMode.Finite

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteData() [1/2]

void JY5325.JY5325DOTask.WriteData | ( | byte | dataBuffer[,],
 |  | uint | samplesToUpdate,
 |  | int | timeOut = 10000 )

write the line byte data to the lines.

Each column represents one line.

Parameters
dataBuffer | Data buffer
samplesToUpdate | Number of samples per port to be write
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [2/2]

void JY5325.JY5325DOTask.WriteData | ( | byte[] | dataBuffer,
 |  | uint | samplesToUpdate,
 |  | int | timeOut = 10000 )

Write the byte data for one line or multi-lines.

There are 8 lines, from 0 to 7. Each bit from low to high represents one line.

Parameters
dataBuffer | Data buffer
samplesToUpdate | Number of samples per port to be write
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteSinglePoint() [1/2]

void JY5325.JY5325DOTask.WriteSinglePoint | ( | bool | writeValues,
 |  | int | line )

write the latest point of Specify port

Parameters
writeValues | User buffer array
line | Specify the line to write

◆ WriteSinglePoint() [2/2]

void JY5325.JY5325DOTask.WriteSinglePoint ( bool[] writeValues )

write the latest point

Parameters
writeValues User buffer array

Property Documentation

◆ AvaliableLenInSamples

uint JY5325.JY5325DOTask.AvaliableLenInSamples
get

Number of output samples per channel avaliable to write in DO buffuer.

◆ BufLenInSamples

int JY5325.JY5325DOTask.BufLenInSamples
get

Number of samples per channel can be storage in the buffer, the PropretySamplesToUpdate must be less than or equal to this value.

◆ Channels

List<DOChannel> JY5325.JY5325DOTask.Channels
get

List of DO channels.

◆ Device

JY5325Device JY5325.JY5325DOTask.Device
get

Device Handle.

◆ Mode

DOMode JY5325.JY5325DOTask.Mode
getset

DO acquisition mode.Select DO Mode from enum:ContinuousNoWrapping/ContinuousWrapping/Finite/Single.

◆ SampleClock

DOSampleClock JY5325.JY5325DOTask.SampleClock
getset

DO Sample Clock Configuration .

◆ SamplesToUpdate

int JY5325.JY5325DOTask.SamplesToUpdate
getset

Number of output samples to write per channel , Only valid when Mode is DOMode.Finite.

◆ SignalExport

DOSignalExport JY5325.JY5325DOTask.SignalExport
getset

Export DO Signal.

◆ TransferedSamples

ulong JY5325.JY5325DOTask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT DOMode.Single.

◆ Trigger

DOTrigger JY5325.JY5325DOTask.Trigger
getset

DO Trigger Configuration.

◆ UpdateRate

double JY5325.JY5325DOTask.UpdateRate
getset

Update rate per channel.

Maximum update rate is 10M . The defalut sample rate = 10000 You can read this property to obtain the update rate that will actually take effect in the current configuration.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325DOTask.cs


5325 C# Programming Manual: JY5325.DOChannel Class Reference

  • DOChannel
Properties | List of all members
JY5325.DOChannel Class Referencesealed

DOChannel class. More...

Properties

int LineNum [get, set]
line Number

Detailed Description

DOChannel class.

Property Documentation

◆ LineNum

int JY5325.DOChannel.LineNum
getset

line Number

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325DOTask.cs


5325 C# Programming Manual: JY5325.DOTrigger Class Reference

  • DOTrigger
Properties | List of all members
JY5325.DOTrigger Class Referencesealed

Constructor to create an DOTrigger task object. More...

Properties

DOTriggerType | Type [get, set]
DO trigger type.
DODigitalTrigger | Digital [get, set]
DO Digital Trigger.Valid when Type is DOTriggerType.Digital.

Detailed Description

Constructor to create an DOTrigger task object.

Used to build DO Trigger

Property Documentation

◆ Digital

DODigitalTrigger JY5325.DOTrigger.Digital
getset

DO Digital Trigger.Valid when Type is DOTriggerType.Digital.

◆ Type

DOTriggerType JY5325.DOTrigger.Type
getset

DO trigger type.

enum Digital/Immediate/Soft.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325DOTask.cs


5325 C# Programming Manual: JY5325.DODigitalTrigger Class Reference

  • DODigitalTrigger
Properties | List of all members
JY5325.DODigitalTrigger Class Referencesealed

DO Digital trigger. More...

Properties

DODigitalTriggerSource | Source [get, set]
DO Digital Trigger source.
DODigitalTriggerEdge | Edge [get, set]
Digital Trigger edge，Rising/Falling.

Detailed Description

DO Digital trigger.

Property Documentation

◆ Edge

DODigitalTriggerEdge JY5325.DODigitalTrigger.Edge
getset

Digital Trigger edge，Rising/Falling.

◆ Source

DODigitalTriggerSource JY5325.DODigitalTrigger.Source
getset

DO Digital Trigger source.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325DOTask.cs


5325 C# Programming Manual: JY5325.DOSampleClock Class Reference

  • DOSampleClock
Properties | List of all members
JY5325.DOSampleClock Class Reference

Sample clock configuration class. More...

Properties

DOSampleClockSource | Source [get, set]
Clock Source.
DOExternalSampleClock | External [get, set]
External Sample Clock.Valid when Source is DOSampleClockSource.External.

Detailed Description

Sample clock configuration class.

Property Documentation

◆ External

DOExternalSampleClock JY5325.DOSampleClock.External
getset

External Sample Clock.Valid when Source is DOSampleClockSource.External.

◆ Source

DOSampleClockSource JY5325.DOSampleClock.Source
getset

Clock Source.

enum Internal/External

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325DOTask.cs


5325 C# Programming Manual: JY5325.DOExternalSampleClock Class Reference

  • DOExternalSampleClock
Properties | List of all members
JY5325.DOExternalSampleClock Class Reference

External Sample Clock Configuration Class. More...

Properties

ClockTerminal | Terminal [get, set]
External Sample Clock Input Terminal.
double | ExpectedRate [get, set]
Expected External Sample Clock Rate.

Detailed Description

External Sample Clock Configuration Class.

Property Documentation

◆ ExpectedRate

double JY5325.DOExternalSampleClock.ExpectedRate
getset

Expected External Sample Clock Rate.

◆ Terminal

ClockTerminal JY5325.DOExternalSampleClock.Terminal
getset

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325DOTask.cs


5325 C# Programming Manual: JY5325.DOSignalExport Class Reference

  • DOSignalExport
Public Member Functions | List of all members
JY5325.DOSignalExport Class Reference

DO Signal Export Class. More...

Public Member Functions

void | Add (DOSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (DOSignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

DO Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY5325.DOSignalExport.Add | ( | DOSignalExportSource | source,
 |  | List< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | DO Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY5325.DOSignalExport.Add | ( | DOSignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | DO Signal Source
destination | Export Desination

◆ Clear()

void JY5325.DOSignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5325.DOSignalExport.ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • D:/5325/C#/JY5325DOTask.cs


5325 C# Programming Manual: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
▼N JY5325 |
C AIAnalogEdgeComparator | AI Analog Edge Comparator
C AIAnalogHysteresisComparator | AI Analog Hysteresis Comparatorr
C AIAnalogTrigger | AI Analog Trigger
C AIAnalogWindowComparator | AI Analog Window Comparatorr
C AIChannel | AI Channel parameter class
C AIDigitalTrigger | AI Digital Trigger
C AIRecord | AI Record class
C AISampleClock | Sample clock configuration class
C AISignalExport | AI Signal Export Class
C AISync | Configure sync signal
C AITrigger | AI Trigger class
C AOChannel | AO Channel parameter class
C AODigitalTrigger | AO Digital trigger
C AOSampleClock | AO Sample clock configuration class
C AOSignalExport | AO Signal Export Class
C AOTrigger | Constructor to create an AOTrigger task object
C CIDigitalTrigger | CI Digital trigger
C CIExternalSampleClock | CI Implicit Sample Clock class
C CIExternalTimebase |
C CIImplicitSampleClock | CI Implicit Sample Clock class
C CIInternalSampleClock | CI Internal Sample Clock Configuration Class
C CISampleClock | CI Sample Clock class
C CISignalExport | CI Signal Export Class
C CITimebase |
C CITrigger | Constructor to create an CITrigger task object
C CODigitalTrigger | CO Digital trigger
C COExternalTimebase |
C COPulse | Pulse Parameter
C COSignalExport | CO Signal Export Class
C COTimebase |
C COTrigger | Constructor to create an COTrigger task object
C DIChannel | DI Channel parameter class
C DIDigitalTrigger | DI Digital trigger
C DIExternalSampleClock | External Sample Clock Configuration Class
C DISampleClock | Sample clock configuration class
C DISignalExport | DI Signal Export Class
C DITrigger | Constructor to create an DITrigger task object
C DOChannel | DOChannel class
C DODigitalTrigger | DO Digital trigger
C DOExternalSampleClock | External Sample Clock Configuration Class
C DOSampleClock | Sample clock configuration class
C DOSignalExport | DO Signal Export Class
C DOTrigger | Constructor to create an DOTrigger task object
C EdgeCounting | Configure CI EdgeCounting
C EdgeCountingOutEvent | Edge counting output event configuration class
C FrequencyMeas | Configure CI Measure
C JY5325AITask | JY5325 Analog Input Task
C JY5325AOTask | JY5325 Analog Ouput Task
C JY5325CITask | JY5325 Counter Input Task
C JY5325COTask | JY5325 Counter Output Task
C JY5325DITask | JY5325DITask Class
C JY5325DOTask | JY5325 DOTask
C PauseTrigger | Pause trigger configuration class
C PeriodMeas | Configure CI Measure
C PulseMeas | Configure CI Measure
C QuadEncoder | Configure CI Measure
C SemiPeriodMeas | Configure CI Measure
C TwoEdgeSeparation | Configure CI Measure
C TwoPulseEncoder | Configure CI Measure


5325 C# Programming Manual: Member List

  • AIAnalogEdgeComparator
JY5325.AIAnalogEdgeComparator Member List

This is the complete list of members for JY5325.AIAnalogEdgeComparator, including all inherited members.

Slope | JY5325.AIAnalogEdgeComparator
Threshold | JY5325.AIAnalogEdgeComparator


5325 C# Programming Manual: Member List

  • AIAnalogHysteresisComparator
JY5325.AIAnalogHysteresisComparator Member List

This is the complete list of members for JY5325.AIAnalogHysteresisComparator, including all inherited members.

HighThreshold | JY5325.AIAnalogHysteresisComparator
LowThreshold | JY5325.AIAnalogHysteresisComparator
Slope | JY5325.AIAnalogHysteresisComparator


5325 C# Programming Manual: Member List

  • AIAnalogTrigger
JY5325.AIAnalogTrigger Member List

This is the complete list of members for JY5325.AIAnalogTrigger, including all inherited members.

Comparator | JY5325.AIAnalogTrigger
Edge | JY5325.AIAnalogTrigger
Hysteresis | JY5325.AIAnalogTrigger
Source | JY5325.AIAnalogTrigger
Window | JY5325.AIAnalogTrigger


5325 C# Programming Manual: Member List

  • AIAnalogWindowComparator
JY5325.AIAnalogWindowComparator Member List

This is the complete list of members for JY5325.AIAnalogWindowComparator, including all inherited members.

Condition | JY5325.AIAnalogWindowComparator
HighThreshold | JY5325.AIAnalogWindowComparator
LowThreshold | JY5325.AIAnalogWindowComparator


5325 C# Programming Manual: Member List

  • AIChannel
JY5325.AIChannel Member List

This is the complete list of members for JY5325.AIChannel, including all inherited members.

AIChannel(int channelId, double rangeLow, double rangeHigh) | JY5325.AIChannel
ChannelID | JY5325.AIChannel
RangeHigh | JY5325.AIChannel
RangeLow | JY5325.AIChannel


5325 C# Programming Manual: Member List

  • AIDigitalTrigger
JY5325.AIDigitalTrigger Member List

This is the complete list of members for JY5325.AIDigitalTrigger, including all inherited members.

Edge | JY5325.AIDigitalTrigger
Source | JY5325.AIDigitalTrigger


5325 C# Programming Manual: Member List

  • AIRecord
JY5325.AIRecord Member List

This is the complete list of members for JY5325.AIRecord, including all inherited members.

FileFormat | JY5325.AIRecord
FilePath | JY5325.AIRecord
Length | JY5325.AIRecord
Mode | JY5325.AIRecord


5325 C# Programming Manual: Member List

  • AISampleClock
JY5325.AISampleClock Member List

This is the complete list of members for JY5325.AISampleClock, including all inherited members.

Source JY5325.AISampleClock


5325 C# Programming Manual: Member List

  • AISignalExport
JY5325.AISignalExport Member List

This is the complete list of members for JY5325.AISignalExport, including all inherited members.

Add(AISignalExportSource source, SignalExportDestination destination) | JY5325.AISignalExport
Add(AISignalExportSource source, List< SignalExportDestination > destinations) | JY5325.AISignalExport
Clear(SignalExportDestination destination) | JY5325.AISignalExport
ClearAll() | JY5325.AISignalExport


5325 C# Programming Manual: Member List

  • AISync
JY5325.AISync Member List

This is the complete list of members for JY5325.AISync, including all inherited members.

Topology | JY5325.AISync
TriggerRouting | JY5325.AISync


5325 C# Programming Manual: Member List

  • AITrigger
JY5325.AITrigger Member List

This is the complete list of members for JY5325.AITrigger, including all inherited members.

Analog | JY5325.AITrigger
Digital | JY5325.AITrigger
Mode | JY5325.AITrigger
PreTriggerSamples | JY5325.AITrigger
ReTriggerCount | JY5325.AITrigger
Type | JY5325.AITrigger


5325 C# Programming Manual: Member List

  • AOChannel
JY5325.AOChannel Member List

This is the complete list of members for JY5325.AOChannel, including all inherited members.

ChannelID JY5325.AOChannel


5325 C# Programming Manual: Member List

  • AODigitalTrigger
JY5325.AODigitalTrigger Member List

This is the complete list of members for JY5325.AODigitalTrigger, including all inherited members.

Edge | JY5325.AODigitalTrigger
Source | JY5325.AODigitalTrigger


5325 C# Programming Manual: Member List

  • AOSampleClock
JY5325.AOSampleClock Member List

This is the complete list of members for JY5325.AOSampleClock, including all inherited members.

Source JY5325.AOSampleClock


5325 C# Programming Manual: Member List

  • AOSignalExport
JY5325.AOSignalExport Member List

This is the complete list of members for JY5325.AOSignalExport, including all inherited members.

Add(AOSignalExportSource source, SignalExportDestination destination) | JY5325.AOSignalExport
Add(AOSignalExportSource source, List< SignalExportDestination > destinations) | JY5325.AOSignalExport
Clear(SignalExportDestination destination) | JY5325.AOSignalExport
ClearAll() | JY5325.AOSignalExport


5325 C# Programming Manual: Member List

  • AOTrigger
JY5325.AOTrigger Member List

This is the complete list of members for JY5325.AOTrigger, including all inherited members.

Digital | JY5325.AOTrigger
Type | JY5325.AOTrigger


5325 C# Programming Manual: Member List

  • CIDigitalTrigger
JY5325.CIDigitalTrigger Member List

This is the complete list of members for JY5325.CIDigitalTrigger, including all inherited members.

Edge | JY5325.CIDigitalTrigger
Source | JY5325.CIDigitalTrigger


5325 C# Programming Manual: Member List

  • CIExternalSampleClock
JY5325.CIExternalSampleClock Member List

This is the complete list of members for JY5325.CIExternalSampleClock, including all inherited members.

ExpectedRate | JY5325.CIExternalSampleClock
IgnoreFirstSampleClock | JY5325.CIExternalSampleClock
Terminal | JY5325.CIExternalSampleClock


5325 C# Programming Manual: Member List

  • CIExternalTimebase
JY5325.CIExternalTimebase Member List

This is the complete list of members for JY5325.CIExternalTimebase, including all inherited members.

Frequency | JY5325.CIExternalTimebase
Terminal | JY5325.CIExternalTimebase


5325 C# Programming Manual: Member List

  • CIImplicitSampleClock
JY5325.CIImplicitSampleClock Member List

This is the complete list of members for JY5325.CIImplicitSampleClock, including all inherited members.

ExpectedRate JY5325.CIImplicitSampleClock


5325 C# Programming Manual: Member List

  • CIInternalSampleClock
JY5325.CIInternalSampleClock Member List

This is the complete list of members for JY5325.CIInternalSampleClock, including all inherited members.

IgnoreFirstSampleClock | JY5325.CIInternalSampleClock
Rate | JY5325.CIInternalSampleClock


5325 C# Programming Manual: Member List

  • CISampleClock
JY5325.CISampleClock Member List

This is the complete list of members for JY5325.CISampleClock, including all inherited members.

External | JY5325.CISampleClock
Implicit | JY5325.CISampleClock
Internal | JY5325.CISampleClock
Source | JY5325.CISampleClock


5325 C# Programming Manual: Member List

  • CISignalExport
JY5325.CISignalExport Member List

This is the complete list of members for JY5325.CISignalExport, including all inherited members.

Add(CISignalExportSource source, SignalExportDestination destination) | JY5325.CISignalExport
Add(CISignalExportSource source, List< SignalExportDestination > destinations) | JY5325.CISignalExport
Clear(SignalExportDestination destination) | JY5325.CISignalExport
ClearAll() | JY5325.CISignalExport


5325 C# Programming Manual: Member List

  • CITimebase
JY5325.CITimebase Member List

This is the complete list of members for JY5325.CITimebase, including all inherited members.

External | JY5325.CITimebase
Source | JY5325.CITimebase


5325 C# Programming Manual: Member List

  • CITrigger
JY5325.CITrigger Member List

This is the complete list of members for JY5325.CITrigger, including all inherited members.

Digital | JY5325.CITrigger
Type | JY5325.CITrigger


5325 C# Programming Manual: Member List

  • CODigitalTrigger
JY5325.CODigitalTrigger Member List

This is the complete list of members for JY5325.CODigitalTrigger, including all inherited members.

Edge | JY5325.CODigitalTrigger
Source | JY5325.CODigitalTrigger


5325 C# Programming Manual: Member List

  • COExternalTimebase
JY5325.COExternalTimebase Member List

This is the complete list of members for JY5325.COExternalTimebase, including all inherited members.

Frequency | JY5325.COExternalTimebase
Terminal | JY5325.COExternalTimebase


5325 C# Programming Manual: Member List

  • COPulse
JY5325.COPulse Member List

This is the complete list of members for JY5325.COPulse, including all inherited members.

COPulse(COPulseType type, double param1, double param2, int count) JY5325.COPulse


5325 C# Programming Manual: Member List

  • COSignalExport
JY5325.COSignalExport Member List

This is the complete list of members for JY5325.COSignalExport, including all inherited members.

Add(COSignalExportSource source, SignalExportDestination destination) | JY5325.COSignalExport
Add(COSignalExportSource source, List< SignalExportDestination > destinations) | JY5325.COSignalExport
Clear(SignalExportDestination destination) | JY5325.COSignalExport
ClearAll() | JY5325.COSignalExport


5325 C# Programming Manual: Member List

  • COTimebase
JY5325.COTimebase Member List

This is the complete list of members for JY5325.COTimebase, including all inherited members.

External | JY5325.COTimebase
Source | JY5325.COTimebase


5325 C# Programming Manual: Member List

  • COTrigger
JY5325.COTrigger Member List

This is the complete list of members for JY5325.COTrigger, including all inherited members.

Digital | JY5325.COTrigger
Type | JY5325.COTrigger


5325 C# Programming Manual: Member List

  • DIChannel
JY5325.DIChannel Member List

This is the complete list of members for JY5325.DIChannel, including all inherited members.

LineNum JY5325.DIChannel


5325 C# Programming Manual: Member List

  • DIDigitalTrigger
JY5325.DIDigitalTrigger Member List

This is the complete list of members for JY5325.DIDigitalTrigger, including all inherited members.

Edge | JY5325.DIDigitalTrigger
Source | JY5325.DIDigitalTrigger


5325 C# Programming Manual: Member List

  • DIExternalSampleClock
JY5325.DIExternalSampleClock Member List

This is the complete list of members for JY5325.DIExternalSampleClock, including all inherited members.

ExpectedRate | JY5325.DIExternalSampleClock
Terminal | JY5325.DIExternalSampleClock


5325 C# Programming Manual: Member List

  • DISampleClock
JY5325.DISampleClock Member List

This is the complete list of members for JY5325.DISampleClock, including all inherited members.

External | JY5325.DISampleClock
Source | JY5325.DISampleClock


5325 C# Programming Manual: Member List

  • DISignalExport
JY5325.DISignalExport Member List

This is the complete list of members for JY5325.DISignalExport, including all inherited members.

Add(DISignalExportSource source, SignalExportDestination destination) | JY5325.DISignalExport
Add(DISignalExportSource source, List< SignalExportDestination > destinations) | JY5325.DISignalExport
Clear(SignalExportDestination destination) | JY5325.DISignalExport
ClearAll() | JY5325.DISignalExport


5325 C# Programming Manual: Member List

  • DITrigger
JY5325.DITrigger Member List

This is the complete list of members for JY5325.DITrigger, including all inherited members.

Digital | JY5325.DITrigger
Mode | JY5325.DITrigger
PreTriggerSamples | JY5325.DITrigger
Type | JY5325.DITrigger


5325 C# Programming Manual: Member List

  • DOChannel
JY5325.DOChannel Member List

This is the complete list of members for JY5325.DOChannel, including all inherited members.

LineNum JY5325.DOChannel


5325 C# Programming Manual: Member List

  • DODigitalTrigger
JY5325.DODigitalTrigger Member List

This is the complete list of members for JY5325.DODigitalTrigger, including all inherited members.

Edge | JY5325.DODigitalTrigger
Source | JY5325.DODigitalTrigger


5325 C# Programming Manual: Member List

  • DOExternalSampleClock
JY5325.DOExternalSampleClock Member List

This is the complete list of members for JY5325.DOExternalSampleClock, including all inherited members.

ExpectedRate | JY5325.DOExternalSampleClock
Terminal | JY5325.DOExternalSampleClock


5325 C# Programming Manual: Member List

  • DOSampleClock
JY5325.DOSampleClock Member List

This is the complete list of members for JY5325.DOSampleClock, including all inherited members.

External | JY5325.DOSampleClock
Source | JY5325.DOSampleClock


5325 C# Programming Manual: Member List

  • DOSignalExport
JY5325.DOSignalExport Member List

This is the complete list of members for JY5325.DOSignalExport, including all inherited members.

Add(DOSignalExportSource source, SignalExportDestination destination) | JY5325.DOSignalExport
Add(DOSignalExportSource source, List< SignalExportDestination > destinations) | JY5325.DOSignalExport
Clear(SignalExportDestination destination) | JY5325.DOSignalExport
ClearAll() | JY5325.DOSignalExport


5325 C# Programming Manual: Member List

  • DOTrigger
JY5325.DOTrigger Member List

This is the complete list of members for JY5325.DOTrigger, including all inherited members.

Digital | JY5325.DOTrigger
Type | JY5325.DOTrigger


5325 C# Programming Manual: Member List

  • EdgeCounting
JY5325.EdgeCounting Member List

This is the complete list of members for JY5325.EdgeCounting, including all inherited members.

ActiveEdge | JY5325.EdgeCounting
Direction | JY5325.EdgeCounting
DirTerminal | JY5325.EdgeCounting
InitialCount | JY5325.EdgeCounting
InputTerminal | JY5325.EdgeCounting
OutEvent | JY5325.EdgeCounting
Pause | JY5325.EdgeCounting


5325 C# Programming Manual: Member List

  • EdgeCountingOutEvent
JY5325.EdgeCountingOutEvent Member List

This is the complete list of members for JY5325.EdgeCountingOutEvent, including all inherited members.

IdleState | JY5325.EdgeCountingOutEvent
Terminal | JY5325.EdgeCountingOutEvent
Threshold | JY5325.EdgeCountingOutEvent


5325 C# Programming Manual: Member List

  • FrequencyMeas
JY5325.FrequencyMeas Member List

This is the complete list of members for JY5325.FrequencyMeas, including all inherited members.

InputTerminal | JY5325.FrequencyMeas
Timebase | JY5325.FrequencyMeas


5325 C# Programming Manual: Member List

  • JY5325AITask
JY5325.JY5325AITask Member List

This is the complete list of members for JY5325.JY5325AITask, including all inherited members.

AddChannel(int chnId, double rangeLow=-10, double rangeHigh=10) | JY5325.JY5325AITask
AddChannel(int[] chnsId, double rangeLow=-10, double rangeHigh=10) | JY5325.JY5325AITask
AddChannel(int[] chnsId, double[] rangeLow, double[] rangeHigh) | JY5325.JY5325AITask
AvailableSamples | JY5325.JY5325AITask
BufLenInSamples | JY5325.JY5325AITask
Channels | JY5325.JY5325AITask
Device | JY5325.JY5325AITask
DisableCalibration | JY5325.JY5325AITask
DisableDigitalTriggerDelay | JY5325.JY5325AITask
GetRecordPreviewData(ref double[,] buf, int samplesPerChannel, int timeout=1000) | JY5325.JY5325AITask
GetRecordPreviewData(ref double[,] buf, int timeout=1000) | JY5325.JY5325AITask
GetRecordPreviewData(ref double[] buf, int samplesPerChannel, int timeout=1000) | JY5325.JY5325AITask
GetRecordPreviewData(ref double[] buf, int timeout=1000) | JY5325.JY5325AITask
GetRecordStatus(out double recordedLength, out bool recordDone) | JY5325.JY5325AITask
JY5325AITask(int slotNum) | JY5325.JY5325AITask
JY5325AITask(string boardName) | JY5325.JY5325AITask
Mode | JY5325.JY5325AITask
ReadData(IntPtr buf, int samplesPerChannel, int timeout=10000) | JY5325.JY5325AITask
ReadData(ref double[,] buf, int samplesPerChannel, int timeout=10000) | JY5325.JY5325AITask
ReadData(ref double[,] buf, int timeout=10000) | JY5325.JY5325AITask
ReadData(ref double[] buf, int samplesPerChannel, int timeout=10000) | JY5325.JY5325AITask
ReadData(ref double[] buf, int timeout=10000) | JY5325.JY5325AITask
ReadRawData(IntPtr buf, int samplesPerChannel, int timeout=10000) | JY5325.JY5325AITask
ReadRawData(ref short[,] buf, int samplesPerChannel, int timeout=10000) | JY5325.JY5325AITask
ReadRawData(ref short[,] buf, int timeout=10000) | JY5325.JY5325AITask
ReadRawData(ref short[] buf, int samplesPerChannel, int timeout=10000) | JY5325.JY5325AITask
ReadRawData(ref short[] buf, int timeout=10000) | JY5325.JY5325AITask
Record | JY5325.JY5325AITask
RemoveChannel(int chnId) | JY5325.JY5325AITask
SampleClock | JY5325.JY5325AITask
SampleRate | JY5325.JY5325AITask
SamplesToAcquire | JY5325.JY5325AITask
SendSoftwareTrigger() | JY5325.JY5325AITask
SignalExport | JY5325.JY5325AITask
Start() | JY5325.JY5325AITask
Stop() | JY5325.JY5325AITask
Sync | JY5325.JY5325AITask
TransferedSamples | JY5325.JY5325AITask
Trigger | JY5325.JY5325AITask
WaitUntilDone(int timeout=-1) | JY5325.JY5325AITask


5325 C# Programming Manual: Member List

  • JY5325AOTask
JY5325.JY5325AOTask Member List

This is the complete list of members for JY5325.JY5325AOTask, including all inherited members.

AddChannel(int chnId) | JY5325.JY5325AOTask
AddChannel(int[] chnsId) | JY5325.JY5325AOTask
AvaliableLenInSamples | JY5325.JY5325AOTask
BufLenInSamples | JY5325.JY5325AOTask
Channels | JY5325.JY5325AOTask
CompleteState | JY5325.JY5325AOTask
Device | JY5325.JY5325AOTask
DisableCalibration | JY5325.JY5325AOTask
JY5325AOTask(int slotNum) | JY5325.JY5325AOTask
JY5325AOTask(string boardName) | JY5325.JY5325AOTask
Mode | JY5325.JY5325AOTask
RemoveChannel(int chnId) | JY5325.JY5325AOTask
SampleClock | JY5325.JY5325AOTask
SamplesToUpdate | JY5325.JY5325AOTask
SendSoftwareTrigger() | JY5325.JY5325AOTask
SignalExport | JY5325.JY5325AOTask
Start() | JY5325.JY5325AOTask
Stop() | JY5325.JY5325AOTask
TransferedSamples | JY5325.JY5325AOTask
Trigger | JY5325.JY5325AOTask
UpdateRate | JY5325.JY5325AOTask
WaitUntilDone(int timeout=-1) | JY5325.JY5325AOTask
WriteData(IntPtr buf, int samplesPerChannel, int timeout=10000) | JY5325.JY5325AOTask
WriteData(double[,] buf, int timeout=10000) | JY5325.JY5325AOTask
WriteData(double[] buf, int timeout=10000) | JY5325.JY5325AOTask
WriteRawData(IntPtr buf, int samplesPerChannel, int timeout=10000) | JY5325.JY5325AOTask
WriteRawData(short[,] buf, int timeout=10000) | JY5325.JY5325AOTask
WriteRawData(short[] buf, int timeout=10000) | JY5325.JY5325AOTask
WriteRawSinglePoint(short[] writeValues) | JY5325.JY5325AOTask
WriteRawSinglePoint(short writeValue, int channel) | JY5325.JY5325AOTask
WriteSinglePoint(double[] writeValues) | JY5325.JY5325AOTask
WriteSinglePoint(double writeValue, int channel) | JY5325.JY5325AOTask


5325 C# Programming Manual: Member List

  • JY5325CITask
JY5325.JY5325CITask Member List

This is the complete list of members for JY5325.JY5325CITask, including all inherited members.

AvailableSamples | JY5325.JY5325CITask
BufLenInSamples | JY5325.JY5325CITask
Device | JY5325.JY5325CITask
EdgeCounting | JY5325.JY5325CITask
FrequencyMeas | JY5325.JY5325CITask
JY5325CITask(int slotNum, int channel) | JY5325.JY5325CITask
JY5325CITask(string boardName, int channel) | JY5325.JY5325CITask
Mode | JY5325.JY5325CITask
PeriodMeas | JY5325.JY5325CITask
PulseMeas | JY5325.JY5325CITask
QuadEncoder | JY5325.JY5325CITask
ReadData(ref uint[] bufCount, int samplesToAcquire, int timeout=10000) | JY5325.JY5325CITask
ReadData(ref uint[] bufCount, int timeout=10000) | JY5325.JY5325CITask
ReadData(ref double[] bufMeasurement, int samplesToAcquire, int timeout=10000) | JY5325.JY5325CITask
ReadData(ref double[] bufMeasurement, int timeout=10000) | JY5325.JY5325CITask
ReadData(ref double[] bufMeasurement1, ref double[] bufMeasurement2, int samplesToAcquire, int timeout=10000) | JY5325.JY5325CITask
ReadData(ref double[] bufMeasurement1, ref double[] bufMeasurement2, int timeout=10000) | JY5325.JY5325CITask
ReadSinglePoint(ref uint count) | JY5325.JY5325CITask
ReadSinglePoint(ref double measurement, int timeout=10000) | JY5325.JY5325CITask
ReadSinglePoint(ref double measurement1, ref double measurement2, int timeout=10000) | JY5325.JY5325CITask
SampleClock | JY5325.JY5325CITask
SamplesToAcquire | JY5325.JY5325CITask
SemiPeriodMeas | JY5325.JY5325CITask
SendSoftwareTrigger() | JY5325.JY5325CITask
SignalExport | JY5325.JY5325CITask
Start() | JY5325.JY5325CITask
Stop() | JY5325.JY5325CITask
TransferedSamples | JY5325.JY5325CITask
Trigger | JY5325.JY5325CITask
TwoEdgeSeparation | JY5325.JY5325CITask
TwoPulseEncoder | JY5325.JY5325CITask
Type | JY5325.JY5325CITask


5325 C# Programming Manual: Member List

  • JY5325COTask
JY5325.JY5325COTask Member List

This is the complete list of members for JY5325.JY5325COTask, including all inherited members.

AvaliableLenInSamples | JY5325.JY5325COTask
BufLenInSamples | JY5325.JY5325COTask
Device | JY5325.JY5325COTask
IdleState | JY5325.JY5325COTask
InitialDelay | JY5325.JY5325COTask
JY5325COTask(int slotNum, int channel) | JY5325.JY5325COTask
JY5325COTask(string boardName, int channel) | JY5325.JY5325COTask
Mode | JY5325.JY5325COTask
OutputTerminal | JY5325.JY5325COTask
Pause | JY5325.JY5325COTask
SamplesToUpdate | JY5325.JY5325COTask
SendSoftwareTrigger() | JY5325.JY5325COTask
SignalExport | JY5325.JY5325COTask
Start() | JY5325.JY5325COTask
Stop() | JY5325.JY5325COTask
Timebase | JY5325.JY5325COTask
TransferedPulses | JY5325.JY5325COTask
TransferedSamples | JY5325.JY5325COTask
Trigger | JY5325.JY5325COTask
WaitUntilDone(int timeout=-1) | JY5325.JY5325COTask
WriteData(COPulse[] pulsesGroup, int samplesToWrite, int timeout=10000) | JY5325.JY5325COTask
WriteSinglePoint(COPulse pulse) | JY5325.JY5325COTask


5325 C# Programming Manual: Member List

  • JY5325DITask
JY5325.JY5325DITask Member List

This is the complete list of members for JY5325.JY5325DITask, including all inherited members.

AddChannel(int lineNum) | JY5325.JY5325DITask
AddChannel(int[] linesNum) | JY5325.JY5325DITask
AvailableSamples | JY5325.JY5325DITask
BufLenInSamples | JY5325.JY5325DITask
Channels | JY5325.JY5325DITask
Device | JY5325.JY5325DITask
JY5325DITask(int slotNum) | JY5325.JY5325DITask
JY5325DITask(string aliasName) | JY5325.JY5325DITask
Mode | JY5325.JY5325DITask
ReadData(ref byte[] dataBuffer, uint samplesToAcquire, int timeOut=10000) | JY5325.JY5325DITask
ReadData(ref byte[,] dataBuffer, uint samplesToAcquire, int timeOut=10000) | JY5325.JY5325DITask
ReadSinglePoint(ref bool readValue, int line) | JY5325.JY5325DITask
ReadSinglePoint(ref bool[] readValues) | JY5325.JY5325DITask
RemoveChannel(int lineNum) | JY5325.JY5325DITask
SampleClock | JY5325.JY5325DITask
SampleRate | JY5325.JY5325DITask
SamplesToAcquire | JY5325.JY5325DITask
SendSoftwareTrigger() | JY5325.JY5325DITask
SignalExport | JY5325.JY5325DITask
Start() | JY5325.JY5325DITask
Stop() | JY5325.JY5325DITask
TransferedSamples | JY5325.JY5325DITask
Trigger | JY5325.JY5325DITask


5325 C# Programming Manual: Member List

  • JY5325DOTask
JY5325.JY5325DOTask Member List

This is the complete list of members for JY5325.JY5325DOTask, including all inherited members.

AddChannel(int lineNum) | JY5325.JY5325DOTask
AddChannel(int[] linesNum) | JY5325.JY5325DOTask
AvaliableLenInSamples | JY5325.JY5325DOTask
BufLenInSamples | JY5325.JY5325DOTask
Channels | JY5325.JY5325DOTask
Device | JY5325.JY5325DOTask
JY5325DOTask(int slotNum) | JY5325.JY5325DOTask
JY5325DOTask(string aliasName) | JY5325.JY5325DOTask
Mode | JY5325.JY5325DOTask
RemoveChannel(int lineNum) | JY5325.JY5325DOTask
SampleClock | JY5325.JY5325DOTask
SamplesToUpdate | JY5325.JY5325DOTask
SendSoftwareTrigger() | JY5325.JY5325DOTask
SignalExport | JY5325.JY5325DOTask
Start() | JY5325.JY5325DOTask
Stop() | JY5325.JY5325DOTask
TransferedSamples | JY5325.JY5325DOTask
Trigger | JY5325.JY5325DOTask
UpdateRate | JY5325.JY5325DOTask
WaitUntilDone(int timeout=-1) | JY5325.JY5325DOTask
WriteData(byte[] dataBuffer, uint samplesToUpdate, int timeOut=10000) | JY5325.JY5325DOTask
WriteData(byte[,] dataBuffer, uint samplesToUpdate, int timeOut=10000) | JY5325.JY5325DOTask
WriteSinglePoint(bool writeValues, int line) | JY5325.JY5325DOTask
WriteSinglePoint(bool[] writeValues) | JY5325.JY5325DOTask


5325 C# Programming Manual: Member List

  • PauseTrigger
JY5325.PauseTrigger Member List

This is the complete list of members for JY5325.PauseTrigger, including all inherited members.

ActivePolarity | JY5325.PauseTrigger
Terminal | JY5325.PauseTrigger


5325 C# Programming Manual: Member List

  • PeriodMeas
JY5325.PeriodMeas Member List

This is the complete list of members for JY5325.PeriodMeas, including all inherited members.

InputTerminal | JY5325.PeriodMeas
Timebase | JY5325.PeriodMeas


5325 C# Programming Manual: Member List

  • PulseMeas
JY5325.PulseMeas Member List

This is the complete list of members for JY5325.PulseMeas, including all inherited members.

InputTerminal | JY5325.PulseMeas
StartingEdge | JY5325.PulseMeas
Timebase | JY5325.PulseMeas


5325 C# Programming Manual: Member List

  • QuadEncoder
JY5325.QuadEncoder Member List

This is the complete list of members for JY5325.QuadEncoder, including all inherited members.

AInputTerminal | JY5325.QuadEncoder
BInputTerminal | JY5325.QuadEncoder
EncodingType | JY5325.QuadEncoder
InitialCount | JY5325.QuadEncoder
ZInputTerminal | JY5325.QuadEncoder
ZReloadEnabled | JY5325.QuadEncoder


5325 C# Programming Manual: Member List

  • SemiPeriodMeas
JY5325.SemiPeriodMeas Member List

This is the complete list of members for JY5325.SemiPeriodMeas, including all inherited members.

InputTerminal | JY5325.SemiPeriodMeas
StartingEdge | JY5325.SemiPeriodMeas
Timebase | JY5325.SemiPeriodMeas


5325 C# Programming Manual: Member List

  • TwoEdgeSeparation
JY5325.TwoEdgeSeparation Member List

This is the complete list of members for JY5325.TwoEdgeSeparation, including all inherited members.

EdgeSeparationMode | JY5325.TwoEdgeSeparation
FirstInputTerminal | JY5325.TwoEdgeSeparation
SecondInputTerminal | JY5325.TwoEdgeSeparation
Timebase | JY5325.TwoEdgeSeparation


5325 C# Programming Manual: Member List

  • TwoPulseEncoder
JY5325.TwoPulseEncoder Member List

This is the complete list of members for JY5325.TwoPulseEncoder, including all inherited members.

AInputTerminal | JY5325.TwoPulseEncoder
BInputTerminal | JY5325.TwoPulseEncoder
InitialCount | JY5325.TwoPulseEncoder


5325 C# Programming Manual: Class Index

Class Index
A | C | D | E | F | J | P | Q | S | T
A
AIAnalogEdgeComparator (JY5325)
AIAnalogHysteresisComparator (JY5325)
AIAnalogTrigger (JY5325)
AIAnalogWindowComparator (JY5325)
AIChannel (JY5325)
AIDigitalTrigger (JY5325)
AIRecord (JY5325)
AISampleClock (JY5325)
AISignalExport (JY5325)
AISync (JY5325)
AITrigger (JY5325)
AOChannel (JY5325)
AODigitalTrigger (JY5325)
AOSampleClock (JY5325)
AOSignalExport (JY5325)
AOTrigger (JY5325)
C
CIDigitalTrigger (JY5325)
CIExternalSampleClock (JY5325)
CIExternalTimebase (JY5325)
CIImplicitSampleClock (JY5325)
CIInternalSampleClock (JY5325)
CISampleClock (JY5325)
CISignalExport (JY5325)
CITimebase (JY5325)
CITrigger (JY5325)
CODigitalTrigger (JY5325)
COExternalTimebase (JY5325)
COPulse (JY5325)
COSignalExport (JY5325)
COTimebase (JY5325)
COTrigger (JY5325)
D
DIChannel (JY5325)
DIDigitalTrigger (JY5325)
DIExternalSampleClock (JY5325)
DISampleClock (JY5325)
DISignalExport (JY5325)
DITrigger (JY5325)
DOChannel (JY5325)
DODigitalTrigger (JY5325)
DOExternalSampleClock (JY5325)
DOSampleClock (JY5325)
DOSignalExport (JY5325)
DOTrigger (JY5325)
E
EdgeCounting (JY5325)
EdgeCountingOutEvent (JY5325)
F
FrequencyMeas (JY5325)
J
JY5325AITask (JY5325)
JY5325AOTask (JY5325)
JY5325CITask (JY5325)
JY5325COTask (JY5325)
JY5325DITask (JY5325)
JY5325DOTask (JY5325)
P
PauseTrigger (JY5325)
PeriodMeas (JY5325)
PulseMeas (JY5325)
Q
QuadEncoder (JY5325)
S
SemiPeriodMeas (JY5325)
T
TwoEdgeSeparation (JY5325)
TwoPulseEncoder (JY5325)


5325 C# Programming Manual: D:/5325 Directory Reference

  • File List
  • 5325
5325 Directory Reference

Directories

C#


5325 C# Programming Manual: File List

  • File List
File List
Here is a list of all files with brief descriptions:
[detail level 123]
▼ 5325
▼ C#
JY5325AITask.cs
JY5325AOTask.cs
JY5325CITask.cs
JY5325COTask.cs
JY5325DITask.cs
JY5325DOTask.cs


5325 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- a -

  • ActiveEdge : JY5325.EdgeCounting
  • ActivePolarity : JY5325.PauseTrigger
  • Add() : JY5325.AISignalExport, JY5325.AOSignalExport, JY5325.CISignalExport, JY5325.COSignalExport, JY5325.DISignalExport, JY5325.DOSignalExport
  • AddChannel() : JY5325.JY5325AITask, JY5325.JY5325AOTask, JY5325.JY5325DITask, JY5325.JY5325DOTask
  • AIChannel() : JY5325.AIChannel
  • AInputTerminal : JY5325.QuadEncoder, JY5325.TwoPulseEncoder
  • Analog : JY5325.AITrigger
  • AvailableSamples : JY5325.JY5325AITask, JY5325.JY5325CITask, JY5325.JY5325DITask
  • AvaliableLenInSamples : JY5325.JY5325AOTask, JY5325.JY5325COTask, JY5325.JY5325DOTask


5325 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- b -

  • BInputTerminal : JY5325.QuadEncoder, JY5325.TwoPulseEncoder
  • BufLenInSamples : JY5325.JY5325AITask, JY5325.JY5325AOTask, JY5325.JY5325CITask, JY5325.JY5325COTask, JY5325.JY5325DITask, JY5325.JY5325DOTask


5325 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- c -

  • ChannelID : JY5325.AIChannel, JY5325.AOChannel
  • Channels : JY5325.JY5325AITask, JY5325.JY5325AOTask, JY5325.JY5325DITask, JY5325.JY5325DOTask
  • Clear() : JY5325.AISignalExport, JY5325.AOSignalExport, JY5325.CISignalExport, JY5325.COSignalExport, JY5325.DISignalExport, JY5325.DOSignalExport
  • ClearAll() : JY5325.AISignalExport, JY5325.AOSignalExport, JY5325.CISignalExport, JY5325.COSignalExport, JY5325.DISignalExport, JY5325.DOSignalExport
  • Comparator : JY5325.AIAnalogTrigger
  • CompleteState : JY5325.JY5325AOTask
  • Condition : JY5325.AIAnalogWindowComparator
  • COPulse() : JY5325.COPulse


5325 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- d -

  • Device : JY5325.JY5325AITask, JY5325.JY5325AOTask, JY5325.JY5325CITask, JY5325.JY5325COTask, JY5325.JY5325DITask, JY5325.JY5325DOTask
  • Digital : JY5325.AITrigger, JY5325.AOTrigger, JY5325.CITrigger, JY5325.COTrigger, JY5325.DITrigger, JY5325.DOTrigger
  • Direction : JY5325.EdgeCounting
  • DirTerminal : JY5325.EdgeCounting
  • DisableCalibration : JY5325.JY5325AITask, JY5325.JY5325AOTask
  • DisableDigitalTriggerDelay : JY5325.JY5325AITask


5325 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- e -

  • Edge : JY5325.AIAnalogTrigger, JY5325.AIDigitalTrigger, JY5325.AODigitalTrigger, JY5325.CIDigitalTrigger, JY5325.CODigitalTrigger, JY5325.DIDigitalTrigger, JY5325.DODigitalTrigger
  • EdgeCounting : JY5325.JY5325CITask
  • EdgeSeparationMode : JY5325.TwoEdgeSeparation
  • EncodingType : JY5325.QuadEncoder
  • ExpectedRate : JY5325.CIExternalSampleClock, JY5325.CIImplicitSampleClock, JY5325.DIExternalSampleClock, JY5325.DOExternalSampleClock
  • External : JY5325.CISampleClock, JY5325.CITimebase, JY5325.COTimebase, JY5325.DISampleClock, JY5325.DOSampleClock


5325 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- f -

  • FileFormat : JY5325.AIRecord
  • FilePath : JY5325.AIRecord
  • FirstInputTerminal : JY5325.TwoEdgeSeparation
  • Frequency : JY5325.CIExternalTimebase, JY5325.COExternalTimebase
  • FrequencyMeas : JY5325.JY5325CITask


5325 C# Programming Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • Properties
  • a
  • c
  • g
  • j
  • r
  • s
  • w
Here is a list of all functions with links to the classes they belong to:

- a -

  • Add() : JY5325.AISignalExport, JY5325.AOSignalExport, JY5325.CISignalExport, JY5325.COSignalExport, JY5325.DISignalExport, JY5325.DOSignalExport
  • AddChannel() : JY5325.JY5325AITask, JY5325.JY5325AOTask, JY5325.JY5325DITask, JY5325.JY5325DOTask
  • AIChannel() : JY5325.AIChannel

- c -

  • Clear() : JY5325.AISignalExport, JY5325.AOSignalExport, JY5325.CISignalExport, JY5325.COSignalExport, JY5325.DISignalExport, JY5325.DOSignalExport
  • ClearAll() : JY5325.AISignalExport, JY5325.AOSignalExport, JY5325.CISignalExport, JY5325.COSignalExport, JY5325.DISignalExport, JY5325.DOSignalExport
  • COPulse() : JY5325.COPulse

- g -

  • GetRecordPreviewData() : JY5325.JY5325AITask
  • GetRecordStatus() : JY5325.JY5325AITask

- j -

  • JY5325AITask() : JY5325.JY5325AITask
  • JY5325AOTask() : JY5325.JY5325AOTask
  • JY5325CITask() : JY5325.JY5325CITask
  • JY5325COTask() : JY5325.JY5325COTask
  • JY5325DITask() : JY5325.JY5325DITask
  • JY5325DOTask() : JY5325.JY5325DOTask

- r -

  • ReadData() : JY5325.JY5325AITask, JY5325.JY5325CITask, JY5325.JY5325DITask
  • ReadRawData() : JY5325.JY5325AITask
  • ReadSinglePoint() : JY5325.JY5325CITask, JY5325.JY5325DITask
  • RemoveChannel() : JY5325.JY5325AITask, JY5325.JY5325AOTask, JY5325.JY5325DITask, JY5325.JY5325DOTask

- s -

  • SendSoftwareTrigger() : JY5325.JY5325AITask, JY5325.JY5325AOTask, JY5325.JY5325CITask, JY5325.JY5325COTask, JY5325.JY5325DITask, JY5325.JY5325DOTask
  • Start() : JY5325.JY5325AITask, JY5325.JY5325AOTask, JY5325.JY5325CITask, JY5325.JY5325COTask, JY5325.JY5325DITask, JY5325.JY5325DOTask
  • Stop() : JY5325.JY5325AITask, JY5325.JY5325AOTask, JY5325.JY5325CITask, JY5325.JY5325COTask, JY5325.JY5325DITask, JY5325.JY5325DOTask

- w -

  • WaitUntilDone() : JY5325.JY5325AITask, JY5325.JY5325AOTask, JY5325.JY5325COTask, JY5325.JY5325DOTask
  • WriteData() : JY5325.JY5325AOTask, JY5325.JY5325COTask, JY5325.JY5325DOTask
  • WriteRawData() : JY5325.JY5325AOTask
  • WriteRawSinglePoint() : JY5325.JY5325AOTask
  • WriteSinglePoint() : JY5325.JY5325AOTask, JY5325.JY5325COTask, JY5325.JY5325DOTask


5325 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- g -

  • GetRecordPreviewData() : JY5325.JY5325AITask
  • GetRecordStatus() : JY5325.JY5325AITask


5325 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- h -

  • HighThreshold : JY5325.AIAnalogHysteresisComparator, JY5325.AIAnalogWindowComparator
  • Hysteresis : JY5325.AIAnalogTrigger


5325 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- i -

  • IdleState : JY5325.EdgeCountingOutEvent, JY5325.JY5325COTask
  • IgnoreFirstSampleClock : JY5325.CIExternalSampleClock, JY5325.CIInternalSampleClock
  • Implicit : JY5325.CISampleClock
  • InitialCount : JY5325.EdgeCounting, JY5325.QuadEncoder, JY5325.TwoPulseEncoder
  • InitialDelay : JY5325.JY5325COTask
  • InputTerminal : JY5325.EdgeCounting, JY5325.FrequencyMeas, JY5325.PeriodMeas, JY5325.PulseMeas, JY5325.SemiPeriodMeas
  • Internal : JY5325.CISampleClock


5325 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- j -

  • JY5325AITask() : JY5325.JY5325AITask
  • JY5325AOTask() : JY5325.JY5325AOTask
  • JY5325CITask() : JY5325.JY5325CITask
  • JY5325COTask() : JY5325.JY5325COTask
  • JY5325DITask() : JY5325.JY5325DITask
  • JY5325DOTask() : JY5325.JY5325DOTask


5325 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- l -

  • Length : JY5325.AIRecord
  • LineNum : JY5325.DIChannel, JY5325.DOChannel
  • LowThreshold : JY5325.AIAnalogHysteresisComparator, JY5325.AIAnalogWindowComparator


5325 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- m -

  • Mode : JY5325.AIRecord, JY5325.AITrigger, JY5325.DITrigger, JY5325.JY5325AITask, JY5325.JY5325AOTask, JY5325.JY5325CITask, JY5325.JY5325COTask, JY5325.JY5325DITask, JY5325.JY5325DOTask


5325 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- o -

  • OutEvent : JY5325.EdgeCounting
  • OutputTerminal : JY5325.JY5325COTask


5325 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- p -

  • Pause : JY5325.EdgeCounting, JY5325.JY5325COTask
  • PeriodMeas : JY5325.JY5325CITask
  • PreTriggerSamples : JY5325.AITrigger, JY5325.DITrigger
  • PulseMeas : JY5325.JY5325CITask


5325 C# Programming Manual: Class Members - Properties

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all properties with links to the classes they belong to:

- a -

  • ActiveEdge : JY5325.EdgeCounting
  • ActivePolarity : JY5325.PauseTrigger
  • AInputTerminal : JY5325.QuadEncoder, JY5325.TwoPulseEncoder
  • Analog : JY5325.AITrigger
  • AvailableSamples : JY5325.JY5325AITask, JY5325.JY5325CITask, JY5325.JY5325DITask
  • AvaliableLenInSamples : JY5325.JY5325AOTask, JY5325.JY5325COTask, JY5325.JY5325DOTask

- b -

  • BInputTerminal : JY5325.QuadEncoder, JY5325.TwoPulseEncoder
  • BufLenInSamples : JY5325.JY5325AITask, JY5325.JY5325AOTask, JY5325.JY5325CITask, JY5325.JY5325COTask, JY5325.JY5325DITask, JY5325.JY5325DOTask

- c -

  • ChannelID : JY5325.AIChannel, JY5325.AOChannel
  • Channels : JY5325.JY5325AITask, JY5325.JY5325AOTask, JY5325.JY5325DITask, JY5325.JY5325DOTask
  • Comparator : JY5325.AIAnalogTrigger
  • CompleteState : JY5325.JY5325AOTask
  • Condition : JY5325.AIAnalogWindowComparator

- d -

  • Device : JY5325.JY5325AITask, JY5325.JY5325AOTask, JY5325.JY5325CITask, JY5325.JY5325COTask, JY5325.JY5325DITask, JY5325.JY5325DOTask
  • Digital : JY5325.AITrigger, JY5325.AOTrigger, JY5325.CITrigger, JY5325.COTrigger, JY5325.DITrigger, JY5325.DOTrigger
  • Direction : JY5325.EdgeCounting
  • DirTerminal : JY5325.EdgeCounting
  • DisableCalibration : JY5325.JY5325AITask, JY5325.JY5325AOTask
  • DisableDigitalTriggerDelay : JY5325.JY5325AITask

- e -

  • Edge : JY5325.AIAnalogTrigger, JY5325.AIDigitalTrigger, JY5325.AODigitalTrigger, JY5325.CIDigitalTrigger, JY5325.CODigitalTrigger, JY5325.DIDigitalTrigger, JY5325.DODigitalTrigger
  • EdgeCounting : JY5325.JY5325CITask
  • EdgeSeparationMode : JY5325.TwoEdgeSeparation
  • EncodingType : JY5325.QuadEncoder
  • ExpectedRate : JY5325.CIExternalSampleClock, JY5325.CIImplicitSampleClock, JY5325.DIExternalSampleClock, JY5325.DOExternalSampleClock
  • External : JY5325.CISampleClock, JY5325.CITimebase, JY5325.COTimebase, JY5325.DISampleClock, JY5325.DOSampleClock

- f -

  • FileFormat : JY5325.AIRecord
  • FilePath : JY5325.AIRecord
  • FirstInputTerminal : JY5325.TwoEdgeSeparation
  • Frequency : JY5325.CIExternalTimebase, JY5325.COExternalTimebase
  • FrequencyMeas : JY5325.JY5325CITask

- h -

  • Hysteresis : JY5325.AIAnalogTrigger

- i -

  • IdleState : JY5325.EdgeCountingOutEvent, JY5325.JY5325COTask
  • IgnoreFirstSampleClock : JY5325.CIExternalSampleClock, JY5325.CIInternalSampleClock
  • Implicit : JY5325.CISampleClock
  • InitialCount : JY5325.EdgeCounting, JY5325.QuadEncoder, JY5325.TwoPulseEncoder
  • InitialDelay : JY5325.JY5325COTask
  • InputTerminal : JY5325.EdgeCounting, JY5325.FrequencyMeas, JY5325.PeriodMeas, JY5325.PulseMeas, JY5325.SemiPeriodMeas
  • Internal : JY5325.CISampleClock

- l -

  • Length : JY5325.AIRecord
  • LineNum : JY5325.DIChannel, JY5325.DOChannel

- m -

  • Mode : JY5325.AIRecord, JY5325.AITrigger, JY5325.DITrigger, JY5325.JY5325AITask, JY5325.JY5325AOTask, JY5325.JY5325CITask, JY5325.JY5325COTask, JY5325.JY5325DITask, JY5325.JY5325DOTask

- o -

  • OutEvent : JY5325.EdgeCounting
  • OutputTerminal : JY5325.JY5325COTask

- p -

  • Pause : JY5325.EdgeCounting, JY5325.JY5325COTask
  • PeriodMeas : JY5325.JY5325CITask
  • PreTriggerSamples : JY5325.AITrigger, JY5325.DITrigger
  • PulseMeas : JY5325.JY5325CITask

- q -

  • QuadEncoder : JY5325.JY5325CITask

- r -

  • RangeHigh : JY5325.AIChannel
  • RangeLow : JY5325.AIChannel
  • Rate : JY5325.CIInternalSampleClock
  • Record : JY5325.JY5325AITask
  • ReTriggerCount : JY5325.AITrigger

- s -

  • SampleClock : JY5325.JY5325AITask, JY5325.JY5325AOTask, JY5325.JY5325CITask, JY5325.JY5325DITask, JY5325.JY5325DOTask
  • SampleRate : JY5325.JY5325AITask, JY5325.JY5325DITask
  • SamplesToAcquire : JY5325.JY5325AITask, JY5325.JY5325CITask, JY5325.JY5325DITask
  • SamplesToUpdate : JY5325.JY5325AOTask, JY5325.JY5325COTask, JY5325.JY5325DOTask
  • SecondInputTerminal : JY5325.TwoEdgeSeparation
  • SemiPeriodMeas : JY5325.JY5325CITask
  • SignalExport : JY5325.JY5325AITask, JY5325.JY5325AOTask, JY5325.JY5325CITask, JY5325.JY5325COTask, JY5325.JY5325DITask, JY5325.JY5325DOTask
  • Slope : JY5325.AIAnalogEdgeComparator, JY5325.AIAnalogHysteresisComparator
  • Source : JY5325.AIAnalogTrigger, JY5325.AIDigitalTrigger, JY5325.AISampleClock, JY5325.AODigitalTrigger, JY5325.AOSampleClock, JY5325.CIDigitalTrigger, JY5325.CISampleClock, JY5325.CITimebase, JY5325.CODigitalTrigger, JY5325.COTimebase, JY5325.DIDigitalTrigger, JY5325.DISampleClock, JY5325.DODigitalTrigger, JY5325.DOSampleClock
  • StartingEdge : JY5325.PulseMeas, JY5325.SemiPeriodMeas
  • Sync : JY5325.JY5325AITask

- t -

  • Terminal : JY5325.CIExternalSampleClock, JY5325.CIExternalTimebase, JY5325.COExternalTimebase, JY5325.DIExternalSampleClock, JY5325.DOExternalSampleClock, JY5325.EdgeCountingOutEvent, JY5325.PauseTrigger
  • Threshold : JY5325.EdgeCountingOutEvent
  • Timebase : JY5325.FrequencyMeas, JY5325.JY5325COTask, JY5325.PeriodMeas, JY5325.PulseMeas, JY5325.SemiPeriodMeas, JY5325.TwoEdgeSeparation
  • Topology : JY5325.AISync
  • TransferedPulses : JY5325.JY5325COTask
  • TransferedSamples : JY5325.JY5325AITask, JY5325.JY5325AOTask, JY5325.JY5325CITask, JY5325.JY5325COTask, JY5325.JY5325DITask, JY5325.JY5325DOTask
  • Trigger : JY5325.JY5325AITask, JY5325.JY5325AOTask, JY5325.JY5325CITask, JY5325.JY5325COTask, JY5325.JY5325DITask, JY5325.JY5325DOTask
  • TriggerRouting : JY5325.AISync
  • TwoEdgeSeparation : JY5325.JY5325CITask
  • TwoPulseEncoder : JY5325.JY5325CITask
  • Type : JY5325.AITrigger, JY5325.AOTrigger, JY5325.CITrigger, JY5325.COTrigger, JY5325.DITrigger, JY5325.DOTrigger, JY5325.JY5325CITask

- u -

  • UpdateRate : JY5325.JY5325AOTask, JY5325.JY5325DOTask

- w -

  • Window : JY5325.AIAnalogTrigger

- z -

  • ZInputTerminal : JY5325.QuadEncoder
  • ZReloadEnabled : JY5325.QuadEncoder


5325 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- q -

  • QuadEncoder : JY5325.JY5325CITask


5325 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- r -

  • RangeHigh : JY5325.AIChannel
  • RangeLow : JY5325.AIChannel
  • Rate : JY5325.CIInternalSampleClock
  • ReadData() : JY5325.JY5325AITask, JY5325.JY5325CITask, JY5325.JY5325DITask
  • ReadRawData() : JY5325.JY5325AITask
  • ReadSinglePoint() : JY5325.JY5325CITask, JY5325.JY5325DITask
  • Record : JY5325.JY5325AITask
  • RemoveChannel() : JY5325.JY5325AITask, JY5325.JY5325AOTask, JY5325.JY5325DITask, JY5325.JY5325DOTask
  • ReTriggerCount : JY5325.AITrigger


5325 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- s -

  • SampleClock : JY5325.JY5325AITask, JY5325.JY5325AOTask, JY5325.JY5325CITask, JY5325.JY5325DITask, JY5325.JY5325DOTask
  • SampleRate : JY5325.JY5325AITask, JY5325.JY5325DITask
  • SamplesToAcquire : JY5325.JY5325AITask, JY5325.JY5325CITask, JY5325.JY5325DITask
  • SamplesToUpdate : JY5325.JY5325AOTask, JY5325.JY5325COTask, JY5325.JY5325DOTask
  • SecondInputTerminal : JY5325.TwoEdgeSeparation
  • SemiPeriodMeas : JY5325.JY5325CITask
  • SendSoftwareTrigger() : JY5325.JY5325AITask, JY5325.JY5325AOTask, JY5325.JY5325CITask, JY5325.JY5325COTask, JY5325.JY5325DITask, JY5325.JY5325DOTask
  • SignalExport : JY5325.JY5325AITask, JY5325.JY5325AOTask, JY5325.JY5325CITask, JY5325.JY5325COTask, JY5325.JY5325DITask, JY5325.JY5325DOTask
  • Slope : JY5325.AIAnalogEdgeComparator, JY5325.AIAnalogHysteresisComparator
  • Source : JY5325.AIAnalogTrigger, JY5325.AIDigitalTrigger, JY5325.AISampleClock, JY5325.AODigitalTrigger, JY5325.AOSampleClock, JY5325.CIDigitalTrigger, JY5325.CISampleClock, JY5325.CITimebase, JY5325.CODigitalTrigger, JY5325.COTimebase, JY5325.DIDigitalTrigger, JY5325.DISampleClock, JY5325.DODigitalTrigger, JY5325.DOSampleClock
  • Start() : JY5325.JY5325AITask, JY5325.JY5325AOTask, JY5325.JY5325CITask, JY5325.JY5325COTask, JY5325.JY5325DITask, JY5325.JY5325DOTask
  • StartingEdge : JY5325.PulseMeas, JY5325.SemiPeriodMeas
  • Stop() : JY5325.JY5325AITask, JY5325.JY5325AOTask, JY5325.JY5325CITask, JY5325.JY5325COTask, JY5325.JY5325DITask, JY5325.JY5325DOTask
  • Sync : JY5325.JY5325AITask


5325 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- t -

  • Terminal : JY5325.CIExternalSampleClock, JY5325.CIExternalTimebase, JY5325.COExternalTimebase, JY5325.DIExternalSampleClock, JY5325.DOExternalSampleClock, JY5325.EdgeCountingOutEvent, JY5325.PauseTrigger
  • Threshold : JY5325.AIAnalogEdgeComparator, JY5325.EdgeCountingOutEvent
  • Timebase : JY5325.FrequencyMeas, JY5325.JY5325COTask, JY5325.PeriodMeas, JY5325.PulseMeas, JY5325.SemiPeriodMeas, JY5325.TwoEdgeSeparation
  • Topology : JY5325.AISync
  • TransferedPulses : JY5325.JY5325COTask
  • TransferedSamples : JY5325.JY5325AITask, JY5325.JY5325AOTask, JY5325.JY5325CITask, JY5325.JY5325COTask, JY5325.JY5325DITask, JY5325.JY5325DOTask
  • Trigger : JY5325.JY5325AITask, JY5325.JY5325AOTask, JY5325.JY5325CITask, JY5325.JY5325COTask, JY5325.JY5325DITask, JY5325.JY5325DOTask
  • TriggerRouting : JY5325.AISync
  • TwoEdgeSeparation : JY5325.JY5325CITask
  • TwoPulseEncoder : JY5325.JY5325CITask
  • Type : JY5325.AITrigger, JY5325.AOTrigger, JY5325.CITrigger, JY5325.COTrigger, JY5325.DITrigger, JY5325.DOTrigger, JY5325.JY5325CITask


5325 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- u -

  • UpdateRate : JY5325.JY5325AOTask, JY5325.JY5325DOTask


5325 C# Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Properties
Here is a list of all variables with links to the classes they belong to:
  • HighThreshold : JY5325.AIAnalogHysteresisComparator, JY5325.AIAnalogWindowComparator
  • LowThreshold : JY5325.AIAnalogHysteresisComparator, JY5325.AIAnalogWindowComparator
  • Threshold : JY5325.AIAnalogEdgeComparator


5325 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- w -

  • WaitUntilDone() : JY5325.JY5325AITask, JY5325.JY5325AOTask, JY5325.JY5325COTask, JY5325.JY5325DOTask
  • Window : JY5325.AIAnalogTrigger
  • WriteData() : JY5325.JY5325AOTask, JY5325.JY5325COTask, JY5325.JY5325DOTask
  • WriteRawData() : JY5325.JY5325AOTask
  • WriteRawSinglePoint() : JY5325.JY5325AOTask
  • WriteSinglePoint() : JY5325.JY5325AOTask, JY5325.JY5325COTask, JY5325.JY5325DOTask


5325 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- z -

  • ZInputTerminal : JY5325.QuadEncoder
  • ZReloadEnabled : JY5325.QuadEncoder


5325 C# Programming Manual: Main Page

5325 C# Programming Manual Documentation


5325 C# Programming Manual: JY5325 Namespace Reference

  • Package List
  • Package Members
Classes | Enumerations
JY5325 Namespace Reference

Classes

class | AIAnalogEdgeComparator
AI Analog Edge Comparator. More...
class | AIAnalogHysteresisComparator
AI Analog Hysteresis Comparatorr. More...
class | AIAnalogTrigger
AI Analog Trigger. More...
class | AIAnalogWindowComparator
AI Analog Window Comparatorr. More...
class | AIChannel
AI Channel parameter class. More...
class | AIDigitalTrigger
AI Digital Trigger. More...
class | AIRecord
AI Record class. More...
class | AISampleClock
Sample clock configuration class. More...
class | AISignalExport
AI Signal Export Class. More...
class | AISync
Configure sync signal. More...
class | AITrigger
AI Trigger class. More...
class | AOChannel
AO Channel parameter class . More...
class | AODigitalTrigger
AO Digital trigger . More...
class | AOSampleClock
AO Sample clock configuration class. More...
class | AOSignalExport
AO Signal Export Class. More...
class | AOTrigger
Constructor to create an AOTrigger task object. More...
class | CIDigitalTrigger
CI Digital trigger . More...
class | CIExternalSampleClock
CI Implicit Sample Clock class. More...
class | CIExternalTimebase
class | CIImplicitSampleClock
CI Implicit Sample Clock class. More...
class | CIInternalSampleClock
CI Internal Sample Clock Configuration Class. More...
class | CISampleClock
CI Sample Clock class. More...
class | CISignalExport
CI Signal Export Class. More...
class | CITimebase
class | CITrigger
Constructor to create an CITrigger task object. More...
class | CODigitalTrigger
CO Digital trigger . More...
class | COExternalTimebase
class | COPulse
Pulse Parameter. More...
class | COSignalExport
CO Signal Export Class. More...
class | COTimebase
class | COTrigger
Constructor to create an COTrigger task object. More...
class | DIChannel
DI Channel parameter class. More...
class | DIDigitalTrigger
DI Digital trigger . More...
class | DIExternalSampleClock
External Sample Clock Configuration Class. More...
class | DISampleClock
Sample clock configuration class. More...
class | DISignalExport
DI Signal Export Class. More...
class | DITrigger
Constructor to create an DITrigger task object. More...
class | DOChannel
DOChannel class. More...
class | DODigitalTrigger
DO Digital trigger. More...
class | DOExternalSampleClock
External Sample Clock Configuration Class. More...
class | DOSampleClock
Sample clock configuration class. More...
class | DOSignalExport
DO Signal Export Class. More...
class | DOTrigger
Constructor to create an DOTrigger task object. More...
class | EdgeCounting
Configure CI EdgeCounting. More...
class | EdgeCountingOutEvent
Edge counting output event configuration class. More...
class | FrequencyMeas
Configure CI Measure. More...
class | JY5325AITask
JY5325 Analog Input Task. More...
class | JY5325AOTask
JY5325 Analog Ouput Task. More...
class | JY5325CITask
JY5325 Counter Input Task. More...
class | JY5325COTask
JY5325 Counter Output Task. More...
class | JY5325DITask
JY5325DITask Class. More...
class | JY5325DOTask
JY5325 DOTask. More...
class | PauseTrigger
Pause trigger configuration class. More...
class | PeriodMeas
Configure CI Measure. More...
class | PulseMeas
Configure CI Measure. More...
class | QuadEncoder
Configure CI Measure. More...
class | SemiPeriodMeas
Configure CI Measure. More...
class | TwoEdgeSeparation
Configure CI Measure. More...
class | TwoPulseEncoder
Configure CI Measure. More...

Enumerations

enum | AITriggerType { Immediate = JY5325Import.JY5325_AI_Immediately , Digital = JY5325Import.JY5325_AI_Digital , Analog = JY5325Import.JY5325_AI_Analog , Soft = JY5325Import.JY5325_AI_Soft }
Trigger Type: Digital/Analog/Immediate. More...
enum | AIDigitalTriggerEdge { Rising = JY5325Import.JY5325_Rising , Falling = JY5325Import.JY5325_Falling }
AI Digital Trigger Edge. More...
enum | AIAnalogTriggerEdge { Rising , Falling }
AI Analog Trigger Edge. More...
enum | AIAnalogWindowCondition { Entering , Leaving }
AI Analog Window Trigger Condition. More...
enum | AIAnalogTriggerComparator { Edge , Hysteresis , Window }
AI Analog Trigger Comparator. More...
enum | AIMode { Finite = JY5325Import.JY5325_AI_Finite , Continuous = JY5325Import.JY5325_AI_Continuous , Record = 0x3 }
AIMode. More...
enum | AISampleClockSource { Internal = JY5325Import.JY5325_InternalClock }
AIClockSource Type. More...
enum ClockTerminal {
PFI0 = JY5325Import.JY5325_Clock_PFI_0 , PFI1 = JY5325Import.JY5325_Clock_PFI_1 , PFI2 = JY5325Import.JY5325_Clock_PFI_2 , PFI3 = JY5325Import.JY5325_Clock_PFI_3 ,
PFI4 = JY5325Import.JY5325_Clock_PFI_4 , PFI5 = JY5325Import.JY5325_Clock_PFI_5 , PFI6 = JY5325Import.JY5325_Clock_PFI_6 , PFI7 = JY5325Import.JY5325_Clock_PFI_7 ,
PXI_Trig0 = JY5325Import.JY5325_Clock_PXI_Trig_0 , PXI_Trig1 = JY5325Import.JY5325_Clock_PXI_Trig_1 , PXI_Trig2 = JY5325Import.JY5325_Clock_PXI_Trig_2 , PXI_Trig3 = JY5325Import.JY5325_Clock_PXI_Trig_3 ,
PXI_Trig4 = JY5325Import.JY5325_Clock_PXI_Trig_4 , PXI_Trig5 = JY5325Import.JY5325_Clock_PXI_Trig_5 , PXI_Trig6 = JY5325Import.JY5325_Clock_PXI_Trig_6 , PXI_Trig7 = JY5325Import.JY5325_Clock_PXI_Trig_7 ,
DI_SampleClock = JY5325Import.JY5325_Inter_Clock_DI_SampleClock , DO_SampleClock = JY5325Import.JY5325_Inter_Clock_DO_SampleClock , CI_0_SampleClock = JY5325Import.JY5325_Inter_CI_0_SampleClock , CI_1_SampleClock = JY5325Import.JY5325_Inter_CI_1_SampleClock ,
CO_0_Output = JY5325Import.JY5325_Inter_CO_0_Output , CO_1_Output = JY5325Import.JY5325_Inter_CO_1_Output
}
External Sample Clock Terminal. More...
enum | AITriggerMode { Start , Reference }
AI Trigger Mode. More...
enum AIAnalogTriggerSource {
Channel_0 , Channel_1 , Channel_2 , Channel_3 ,
Channel_4 , Channel_5 , Channel_6 , Channel_7
}
AI Analog Trigger Source. More...
enum AIDigitalTriggerSource {
PFI0 = JY5325Import.JY5325_PFI0 , PFI1 = JY5325Import.JY5325_PFI1 , PFI2 = JY5325Import.JY5325_PFI2 , PFI3 = JY5325Import.JY5325_PFI3 ,
PFI4 = JY5325Import.JY5325_PFI4 , PFI5 = JY5325Import.JY5325_PFI5 , PFI6 = JY5325Import.JY5325_PFI6 , PFI7 = JY5325Import.JY5325_PFI7 ,
PXI_Trig0 = JY5325Import.JY5325_PXI_Trig0 , PXI_Trig1 = JY5325Import.JY5325_PXI_Trig1 , PXI_Trig2 = JY5325Import.JY5325_PXI_Trig2 , PXI_Trig3 = JY5325Import.JY5325_PXI_Trig3 ,
PXI_Trig4 = JY5325Import.JY5325_PXI_Trig4 , PXI_Trig5 = JY5325Import.JY5325_PXI_Trig5 , PXI_Trig6 = JY5325Import.JY5325_PXI_Trig6 , PXI_Trig7 = JY5325Import.JY5325_PXI_Trig7 ,
AO_StartTrig = JY5325Import.JY5325_Inter_AO_StartTrig , DI_StartTrig = JY5325Import.JY5325_Inter_DI_StartTrig , DI_ReferenceTrig = JY5325Import.JY5325_Inter_DI_ReferenceTrig , DO_StartTrig = JY5325Import.JY5325_Inter_DO_StartTrig ,
CIO_0_StartTrig = JY5325Import.JY5325_Inter_Counter_0_StartTrig , CIO_1_StartTrig = JY5325Import.JY5325_Inter_Counter_1_StartTrig , CO_0_Out = JY5325Import.JY5325_Inter_Counter_0_Out , CO_1_Out = JY5325Import.JY5325_Inter_Counter_1_Out
}
AI Digital Trigger Source. More...
enum | FileFormat { Bin }
Streaming file format. More...
enum | RecordMode { Finite , Infinite }
Two stream mode from enum Finite/Infinite. More...
enum | SyncTopology { Independent , Master , Slave }
Synchronization board configuration. More...
enum SyncTriggerRouting {
NONE = -1 , PFI0 = JY5325Import.JY5325_PFI0_Input , PFI1 = JY5325Import.JY5325_PFI1_Input , PFI2 = JY5325Import.JY5325_PFI2_Input ,
PFI3 = JY5325Import.JY5325_PFI3_Input , PFI4 = JY5325Import.JY5325_PFI4_Input , PFI5 = JY5325Import.JY5325_PFI5_Input , PFI6 = JY5325Import.JY5325_PFI6_Input ,
PFI7 = JY5325Import.JY5325_PFI7_Input , PXI_Trig0 = JY5325Import.JY5325_PXI_Trig0_Input , PXI_Trig1 = JY5325Import.JY5325_PXI_Trig1_Input , PXI_Trig2 = JY5325Import.JY5325_PXI_Trig2_Input ,
PXI_Trig3 = JY5325Import.JY5325_PXI_Trig3_Input , PXI_Trig4 = JY5325Import.JY5325_PXI_Trig4_Input , PXI_Trig5 = JY5325Import.JY5325_PXI_Trig5_Input , PXI_Trig6 = JY5325Import.JY5325_PXI_Trig6_Input ,
PXI_Trig7 = JY5325Import.JY5325_PXI_Trig7_Input
}
Master card trigger signal routing (Master card routes trigger signal to this port) More...
enum AISignalExportSource {
StartTrig = JY5325Import.JY5325_Signal_AI_StartTrig , ReferenceTrig = JY5325Import.JY5325_Signal_AI_ReferenceTrig , Internal_Counter_100K = JY5325Import.JY5325_Signal_CIO_100kHz , Internal_Counter_5M = JY5325Import.JY5325_Signal_CIO_5MHz ,
Internal_Counter_100M = JY5325Import.JY5325_Signal_CIO_100MHz
}
AI Signal Export Source. More...
enum SignalExportDestination {
PFI0 = JY5325Import.JY5325_PFI0_OUT , PFI1 = JY5325Import.JY5325_PFI1_OUT , PFI2 = JY5325Import.JY5325_PFI2_OUT , PFI3 = JY5325Import.JY5325_PFI3_OUT ,
PFI4 = JY5325Import.JY5325_PFI4_OUT , PFI5 = JY5325Import.JY5325_PFI5_OUT , PFI6 = JY5325Import.JY5325_PFI6_OUT , PFI7 = JY5325Import.JY5325_PFI7_OUT ,
PXI_Trig0 = JY5325Import.JY5325_PXITrig0_OUT , PXI_Trig1 = JY5325Import.JY5325_PXITrig1_OUT , PXI_Trig2 = JY5325Import.JY5325_PXITrig2_OUT , PXI_Trig3 = JY5325Import.JY5325_PXITrig3_OUT ,
PXI_Trig4 = JY5325Import.JY5325_PXITrig4_OUT , PXI_Trig5 = JY5325Import.JY5325_PXITrig5_OUT , PXI_Trig6 = JY5325Import.JY5325_PXITrig6_OUT , PXI_Trig7 = JY5325Import.JY5325_PXITrig7_OUT
}
Output DestinationTerminal. More...
enum | AODigitalTriggerEdge { Rising = JY5325Import.JY5325_Rising , Falling = JY5325Import.JY5325_Falling }
AO Digital Trigger Edge. More...
enum AODigitalTriggerSource {
PFI0 = JY5325Import.JY5325_PFI0 , PFI1 = JY5325Import.JY5325_PFI1 , PFI2 = JY5325Import.JY5325_PFI2 , PFI3 = JY5325Import.JY5325_PFI3 ,
PFI4 = JY5325Import.JY5325_PFI4 , PFI5 = JY5325Import.JY5325_PFI5 , PFI6 = JY5325Import.JY5325_PFI6 , PFI7 = JY5325Import.JY5325_PFI7 ,
PXI_Trig0 = JY5325Import.JY5325_PXI_Trig0 , PXI_Trig1 = JY5325Import.JY5325_PXI_Trig1 , PXI_Trig2 = JY5325Import.JY5325_PXI_Trig2 , PXI_Trig3 = JY5325Import.JY5325_PXI_Trig3 ,
PXI_Trig4 = JY5325Import.JY5325_PXI_Trig4 , PXI_Trig5 = JY5325Import.JY5325_PXI_Trig5 , PXI_Trig6 = JY5325Import.JY5325_PXI_Trig6 , PXI_Trig7 = JY5325Import.JY5325_PXI_Trig7 ,
AI_StartTrig = JY5325Import.JY5325_Inter_AI_StartTrig , AI_ReferenceTrig = JY5325Import.JY5325_Inter_AI_ReferenceTrig , DI_StartTrig = JY5325Import.JY5325_Inter_DI_StartTrig , DI_ReferenceTrig = JY5325Import.JY5325_Inter_DI_ReferenceTrig ,
DO_StartTrig = JY5325Import.JY5325_Inter_DO_StartTrig , CIO_0_StartTrig = JY5325Import.JY5325_Inter_Counter_0_StartTrig , CIO_1_StartTrig = JY5325Import.JY5325_Inter_Counter_1_StartTrig , CO_0_Out = JY5325Import.JY5325_Inter_Counter_0_Out ,
CO_1_Out = JY5325Import.JY5325_Inter_Counter_1_Out
}
AO Digital trigger source. More...
enum | AOMode { Single = JY5325Import.JY5325_AO_Single , Finite = JY5325Import.JY5325_AO_Finite , ContinuousNoWrapping = JY5325Import.JY5325_AO_ContinuousNoWrapping , ContinuousWrapping = JY5325Import.JY5325_AO_ContinuousWrapping }
AOMode. More...
enum | AOSampleClockSource { Internal = JY5325Import.JY5325_InternalClock }
AO Sample Clock Source. More...
enum | AOSignalExportSource { StartTrig = JY5325Import.JY5325_Signal_AO_StartTrig , Internal_Counter_100K = JY5325Import.JY5325_Signal_CIO_100kHz , Internal_Counter_5M = JY5325Import.JY5325_Signal_CIO_5MHz , Internal_Counter_100M = JY5325Import.JY5325_Signal_CIO_100MHz }
SourceSignal. More...
enum | AOTriggerType { Immediate = JY5325Import.JY5325_AO_Immediately , Digital = JY5325Import.JY5325_AO_Digital , Soft = JY5325Import.JY5325_AO_Soft }
TriggerType Digital/Immediate/Soft. More...
enum | OutputCompleteState { Zero , Hold }
Output Complete State. More...
enum | CountDirection { Up = JY5325Import.JY5325_CI_Count_Up , Down = JY5325Import.JY5325_CI_Count_Down , External = JY5325Import.JY5325_CI_Count_External }
Counter direction. More...
enum | CIMode { Single = 2 , Finite = 0 , Continuous = 1 }
CIMode. More...
enum CIType {
EdgeCounting , Period , Frequency , Pulse ,
SemiPeriod , TwoEdgeSeparation , QuadEncoder , TwoPulseEncoder
}
Counter Input Application Type. More...
enum | CISampleClockSource { Implicit = JY5325Import.JY5325_CI_ImplicitClock , Internal = JY5325Import.JY5325_CI_InternalClock , External = JY5325Import.JY5325_CI_ExternalClock }
CI Sample Clock Source. More...
enum | EdgeType { Rising , Falling , Any }
Edge Type. More...
enum | CITimebaseSource { Internal100MHz = 0 , Internal5MHz = 1 , Internal100kHz = 2 , External = 3 }
enum | EdgeCntOunEvtIdleState { LowLevel = 0 , HighLevel = 1 }
Output idle state when the event has not occurred. More...
enum | LevelPolarity { LowLevel = 0 , HighLevel = 1 , None = 2 }
Level Polarity. More...
enum | ValueReturnMode { TwoValue , OneValue }
TwoEdgeSeparation value return mode.only for TwoEdgeSeparation type. More...
enum | QuadEncodingType { X1 , X2 , X4 }
Quadrature Encoding Type. More...
enum | CITriggerType { Immediate = JY5325Import.JY5325_CIO_Immediately , Digital = JY5325Import.JY5325_CIO_Digital , Soft = JY5325Import.JY5325_CIO_Soft }
TriggerType Digital/Immediate/Soft. More...
enum CIDigitalTriggerSource {
PFI0 = JY5325Import.JY5325_PFI0 , PFI1 = JY5325Import.JY5325_PFI1 , PFI2 = JY5325Import.JY5325_PFI2 , PFI3 = JY5325Import.JY5325_PFI3 ,
PFI4 = JY5325Import.JY5325_PFI4 , PFI5 = JY5325Import.JY5325_PFI5 , PFI6 = JY5325Import.JY5325_PFI6 , PFI7 = JY5325Import.JY5325_PFI7 ,
PXI_Trig0 = JY5325Import.JY5325_PXI_Trig0 , PXI_Trig1 = JY5325Import.JY5325_PXI_Trig1 , PXI_Trig2 = JY5325Import.JY5325_PXI_Trig2 , PXI_Trig3 = JY5325Import.JY5325_PXI_Trig3 ,
PXI_Trig4 = JY5325Import.JY5325_PXI_Trig4 , PXI_Trig5 = JY5325Import.JY5325_PXI_Trig5 , PXI_Trig6 = JY5325Import.JY5325_PXI_Trig6 , PXI_Trig7 = JY5325Import.JY5325_PXI_Trig7 ,
AI_StartTrig = JY5325Import.JY5325_Inter_AI_StartTrig , AI_ReferenceTrig = JY5325Import.JY5325_Inter_AI_ReferenceTrig , AO_StartTrig = JY5325Import.JY5325_Inter_AO_StartTrig , DI_StartTrig = JY5325Import.JY5325_Inter_DI_StartTrig ,
DI_ReferenceTrig = JY5325Import.JY5325_Inter_DI_ReferenceTrig , DO_StartTrig = JY5325Import.JY5325_Inter_DO_StartTrig , CIO_0_StartTrig = JY5325Import.JY5325_Inter_Counter_0_StartTrig , CIO_1_StartTrig = JY5325Import.JY5325_Inter_Counter_1_StartTrig ,
CO_0_Out = JY5325Import.JY5325_Inter_Counter_0_Out , CO_1_Out = JY5325Import.JY5325_Inter_Counter_1_Out
}
CI Digital trigger source. More...
enum | CIDigitalTriggerEdge { Rising = JY5325Import.JY5325_Rising , Falling = JY5325Import.JY5325_Falling }
CI Digital Trigger Edge. More...
enum InputTerminal {
PFI0 = JY5325Import.JY5325_PFI0_Input , PFI1 = JY5325Import.JY5325_PFI1_Input , PFI2 = JY5325Import.JY5325_PFI2_Input , PFI3 = JY5325Import.JY5325_PFI3_Input ,
PFI4 = JY5325Import.JY5325_PFI4_Input , PFI5 = JY5325Import.JY5325_PFI5_Input , PFI6 = JY5325Import.JY5325_PFI6_Input , PFI7 = JY5325Import.JY5325_PFI7_Input ,
PXI_Trig0 = JY5325Import.JY5325_PXI_Trig0_Input , PXI_Trig1 = JY5325Import.JY5325_PXI_Trig1_Input , PXI_Trig2 = JY5325Import.JY5325_PXI_Trig2_Input , PXI_Trig3 = JY5325Import.JY5325_PXI_Trig3_Input ,
PXI_Trig4 = JY5325Import.JY5325_PXI_Trig4_Input , PXI_Trig5 = JY5325Import.JY5325_PXI_Trig5_Input , PXI_Trig6 = JY5325Import.JY5325_PXI_Trig6_Input , PXI_Trig7 = JY5325Import.JY5325_PXI_Trig7_Input ,
AI_SampleClock = JY5325Import.JY5325_IN_AI_SampleClock , AO_SampleClock = JY5325Import.JY5325_IN_AO_SampleClock , DI_SampleClock = JY5325Import.JY5325_IN_DI_SampleClock , DO_SampleClock = JY5325Import.JY5325_IN_DO_SampleClock ,
CO_0_OutPut = JY5325Import.JY5325_IN_CO_0_Output , CO_1_OutPut = JY5325Import.JY5325_IN_CO_1_Output , Timebase_100MHz = JY5325Import.JY5325_IN_CIO_100MHz , Timebase_5MHz = JY5325Import.JY5325_IN_CIO_5MHz ,
Timebase_100kHz = JY5325Import.JY5325_IN_CIO_100kHz
}
Input Terminal. More...
enum IOTerminal {
PFI0 = JY5325Import.JY5325_PFI0_OUT , PFI1 = JY5325Import.JY5325_PFI1_OUT , PFI2 = JY5325Import.JY5325_PFI2_OUT , PFI3 = JY5325Import.JY5325_PFI3_OUT ,
PFI4 = JY5325Import.JY5325_PFI4_OUT , PFI5 = JY5325Import.JY5325_PFI5_OUT , PFI6 = JY5325Import.JY5325_PFI6_OUT , PFI7 = JY5325Import.JY5325_PFI7_OUT ,
PXI_Trig0 = JY5325Import.JY5325_PXITrig0_OUT , PXI_Trig1 = JY5325Import.JY5325_PXITrig1_OUT , PXI_Trig2 = JY5325Import.JY5325_PXITrig2_OUT , PXI_Trig3 = JY5325Import.JY5325_PXITrig3_OUT ,
PXI_Trig4 = JY5325Import.JY5325_PXITrig4_OUT , PXI_Trig5 = JY5325Import.JY5325_PXITrig5_OUT , PXI_Trig6 = JY5325Import.JY5325_PXITrig6_OUT , PXI_Trig7 = JY5325Import.JY5325_PXITrig7_OUT ,
None = 16
}
Out terminal. More...
enum CISignalExportSource {
StartTrig , SampleClock , Internal_Counter_100K = JY5325Import.JY5325_Signal_CIO_100kHz , Internal_Counter_5M = JY5325Import.JY5325_Signal_CIO_5MHz ,
Internal_Counter_100M = JY5325Import.JY5325_Signal_CIO_100MHz
}
SourceSignal. More...
enum | COIdleState { HighLevel = JY5325Import.JY5325_HighLevel , LowLevel = JY5325Import.JY5325_LowLevel }
Idle state when pulse output before start and after stop. More...
enum | COMode { Single = JY5325Import.JY5325_CO_Single , Finite = JY5325Import.JY5325_CO_Finite , ContinuousNoWrapping = JY5325Import.JY5325_CO_ContinuousNoWrapping , ContinuousWrapping = JY5325Import.JY5325_CO_ContinuousWrapping }
CO output mode. More...
enum | COTriggerType { Immediate = JY5325Import.JY5325_CIO_Immediately , Digital = JY5325Import.JY5325_CIO_Digital , Soft = JY5325Import.JY5325_CIO_Soft }
TriggerType Digital/Immediate/Soft. More...
enum CODigitalTriggerSource {
PFI0 = JY5325Import.JY5325_PFI0 , PFI1 = JY5325Import.JY5325_PFI1 , PFI2 = JY5325Import.JY5325_PFI2 , PFI3 = JY5325Import.JY5325_PFI3 ,
PFI4 = JY5325Import.JY5325_PFI4 , PFI5 = JY5325Import.JY5325_PFI5 , PFI6 = JY5325Import.JY5325_PFI6 , PFI7 = JY5325Import.JY5325_PFI7 ,
PXI_Trig0 = JY5325Import.JY5325_PXI_Trig0 , PXI_Trig1 = JY5325Import.JY5325_PXI_Trig1 , PXI_Trig2 = JY5325Import.JY5325_PXI_Trig2 , PXI_Trig3 = JY5325Import.JY5325_PXI_Trig3 ,
PXI_Trig4 = JY5325Import.JY5325_PXI_Trig4 , PXI_Trig5 = JY5325Import.JY5325_PXI_Trig5 , PXI_Trig6 = JY5325Import.JY5325_PXI_Trig6 , PXI_Trig7 = JY5325Import.JY5325_PXI_Trig7 ,
AI_StartTrig = JY5325Import.JY5325_Inter_AI_StartTrig , AI_ReferenceTrig = JY5325Import.JY5325_Inter_AI_ReferenceTrig , AO_StartTrig = JY5325Import.JY5325_Inter_AO_StartTrig , DI_StartTrig = JY5325Import.JY5325_Inter_DI_StartTrig ,
DI_ReferenceTrig = JY5325Import.JY5325_Inter_DI_ReferenceTrig , DO_StartTrig = JY5325Import.JY5325_Inter_DO_StartTrig , CIO_0_StartTrig = JY5325Import.JY5325_Inter_Counter_0_StartTrig , CIO_1_StartTrig = JY5325Import.JY5325_Inter_Counter_1_StartTrig ,
CO_0_Out = JY5325Import.JY5325_Inter_Counter_0_Out , CO_1_Out = JY5325Import.JY5325_Inter_Counter_1_Out
}
CO Digital trigger source. More...
enum | CODigitalTriggerEdge { Rising = JY5325Import.JY5325_Rising , Falling = JY5325Import.JY5325_Falling }
CO Digital Trigger Edge. More...
enum | COPulseType { DutyCycleFrequency , HighLowTime , HighLowTick }
Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick. More...
enum | COTimebaseSource { Internal100MHz = 0 , Internal5MHz = 1 , Internal100kHz = 2 , External = 3 }
enum COSignalExportSource {
StartTrig , Output , Internal_Counter_100K = JY5325Import.JY5325_Signal_CIO_100kHz , Internal_Counter_5M = JY5325Import.JY5325_Signal_CIO_5MHz ,
Internal_Counter_100M = JY5325Import.JY5325_Signal_CIO_100MHz
}
SourceSignal. More...
enum | DITriggerMode { Start , Reference }
DI Trigger Mode. More...
enum | DITriggerType { Immediate = JY5325Import.JY5325_DI_Immediately , Digital = JY5325Import.JY5325_DI_Digital , Soft = JY5325Import.JY5325_DI_Soft }
TriggerType Digital/Immediate/Soft. More...
enum DIDigitalTriggerSource {
PFI0 = JY5325Import.JY5325_PFI0 , PFI1 = JY5325Import.JY5325_PFI1 , PFI2 = JY5325Import.JY5325_PFI2 , PFI3 = JY5325Import.JY5325_PFI3 ,
PFI4 = JY5325Import.JY5325_PFI4 , PFI5 = JY5325Import.JY5325_PFI5 , PFI6 = JY5325Import.JY5325_PFI6 , PFI7 = JY5325Import.JY5325_PFI7 ,
PXI_Trig0 = JY5325Import.JY5325_PXI_Trig0 , PXI_Trig1 = JY5325Import.JY5325_PXI_Trig1 , PXI_Trig2 = JY5325Import.JY5325_PXI_Trig2 , PXI_Trig3 = JY5325Import.JY5325_PXI_Trig3 ,
PXI_Trig4 = JY5325Import.JY5325_PXI_Trig4 , PXI_Trig5 = JY5325Import.JY5325_PXI_Trig5 , PXI_Trig6 = JY5325Import.JY5325_PXI_Trig6 , PXI_Trig7 = JY5325Import.JY5325_PXI_Trig7 ,
AI_StartTrig = JY5325Import.JY5325_Inter_AI_StartTrig , AI_ReferenceTrig = JY5325Import.JY5325_Inter_AI_ReferenceTrig , AO_StartTrig = JY5325Import.JY5325_Inter_AO_StartTrig , DO_StartTrig = JY5325Import.JY5325_Inter_DO_StartTrig ,
CIO_0_StartTrig = JY5325Import.JY5325_Inter_Counter_0_StartTrig , CIO_1_StartTrig = JY5325Import.JY5325_Inter_Counter_1_StartTrig , CO_0_Out = JY5325Import.JY5325_Inter_Counter_0_Out , CO_1_Out = JY5325Import.JY5325_Inter_Counter_1_Out
}
DI Digital trigger source. More...
enum | DIDigitalTriggerEdge { Rising = JY5325Import.JY5325_Rising , Falling = JY5325Import.JY5325_Falling }
DI Digital Trigger Edge. More...
enum | DISampleClockSource { Internal = JY5325Import.JY5325_InternalClock , External = JY5325Import.JY5325_ExternalClock }
DI Sample Clock Source. More...
enum | DIMode { Single = JY5325Import.JY5325_DI_Single , Finite = JY5325Import.JY5325_DI_Finite , Continuous = JY5325Import.JY5325_DI_Continuous }
DIMode. More...
enum DISignalExportSource {
StartTrig = JY5325Import.JY5325_Signal_DI_StartTrig , ReferenceTrig = JY5325Import.JY5325_Signal_DI_ReferenceTrig , SampleClock = JY5325Import.JY5325_Signal_DI_SampleClock , Internal_Counter_100K = JY5325Import.JY5325_Signal_CIO_100kHz ,
Internal_Counter_5M = JY5325Import.JY5325_Signal_CIO_5MHz , Internal_Counter_100M = JY5325Import.JY5325_Signal_CIO_100MHz
}
SourceSignal. More...
enum | DOTriggerType { Immediate = JY5325Import.JY5325_DO_Immediately , Digital = JY5325Import.JY5325_DO_Digital , Soft = JY5325Import.JY5325_DO_Soft }
TriggerType Digital/Immediate/Soft. More...
enum DODigitalTriggerSource {
PFI0 = JY5325Import.JY5325_PFI0 , PFI1 = JY5325Import.JY5325_PFI1 , PFI2 = JY5325Import.JY5325_PFI2 , PFI3 = JY5325Import.JY5325_PFI3 ,
PFI4 = JY5325Import.JY5325_PFI4 , PFI5 = JY5325Import.JY5325_PFI5 , PFI6 = JY5325Import.JY5325_PFI6 , PFI7 = JY5325Import.JY5325_PFI7 ,
PXI_Trig0 = JY5325Import.JY5325_PXI_Trig0 , PXI_Trig1 = JY5325Import.JY5325_PXI_Trig1 , PXI_Trig2 = JY5325Import.JY5325_PXI_Trig2 , PXI_Trig3 = JY5325Import.JY5325_PXI_Trig3 ,
PXI_Trig4 = JY5325Import.JY5325_PXI_Trig4 , PXI_Trig5 = JY5325Import.JY5325_PXI_Trig5 , PXI_Trig6 = JY5325Import.JY5325_PXI_Trig6 , PXI_Trig7 = JY5325Import.JY5325_PXI_Trig7 ,
AI_StartTrig = JY5325Import.JY5325_Inter_AI_StartTrig , AI_ReferenceTrig = JY5325Import.JY5325_Inter_AI_ReferenceTrig , AO_StartTrig = JY5325Import.JY5325_Inter_AO_StartTrig , DI_StartTrig = JY5325Import.JY5325_Inter_DI_StartTrig ,
DI_ReferenceTrig = JY5325Import.JY5325_Inter_DI_ReferenceTrig , CIO_0_StartTrig = JY5325Import.JY5325_Inter_Counter_0_StartTrig , CIO_1_StartTrig = JY5325Import.JY5325_Inter_Counter_1_StartTrig , CO_0_Out = JY5325Import.JY5325_Inter_Counter_0_Out ,
CO_1_Out = JY5325Import.JY5325_Inter_Counter_1_Out
}
DO Digital trigger source. More...
enum | DODigitalTriggerEdge { Rising = JY5325Import.JY5325_Rising , Falling = JY5325Import.JY5325_Falling }
DO Digital Trigger Edge. More...
enum | DOSampleClockSource { Internal = JY5325Import.JY5325_InternalClock , External = JY5325Import.JY5325_ExternalClock }
DO Sample Clock Source. More...
enum DOSignalExportSource {
StartTrig = JY5325Import.JY5325_Signal_DO_StartTrig , SampleClock = JY5325Import.JY5325_Signal_DO_SampleClock , Internal_Counter_100K = JY5325Import.JY5325_Signal_CIO_100kHz , Internal_Counter_5M = JY5325Import.JY5325_Signal_CIO_5MHz ,
Internal_Counter_100M = JY5325Import.JY5325_Signal_CIO_100MHz
}
SourceSignal. More...
enum | DOMode { Single = JY5325Import.JY5325_DO_Single , Finite = JY5325Import.JY5325_DO_Finite , ContinuousWrapping = JY5325Import.JY5325_DO_ContinuousWrapping , ContinuousNoWrapping = JY5325Import.JY5325_DO_ContinuousNoWrapping }
DOMode. More...

Enumeration Type Documentation

◆ AIAnalogTriggerComparator

enum JY5325.AIAnalogTriggerComparator

AI Analog Trigger Comparator.

Enumerator
Edge | Edge Comparator.
Hysteresis | Hysteresis Comparator.
Window | Window Comparator.

◆ AIAnalogTriggerEdge

enum JY5325.AIAnalogTriggerEdge

AI Analog Trigger Edge.

Enumerator
Rising | Rising.
Falling | Falling.

◆ AIAnalogTriggerSource

enum JY5325.AIAnalogTriggerSource

AI Analog Trigger Source.

Enumerator
Channel_0 | channel 0
Channel_1 | channel 1
Channel_2 | channel 2
Channel_3 | channel 3
Channel_4 | channel 4
Channel_5 | channel 5
Channel_6 | channel 6
Channel_7 | channel 7

◆ AIAnalogWindowCondition

enum JY5325.AIAnalogWindowCondition

AI Analog Window Trigger Condition.

Enumerator
Entering | Rising.
Leaving | Falling.

◆ AIDigitalTriggerEdge

enum JY5325.AIDigitalTriggerEdge

AI Digital Trigger Edge.

Enumerator
Rising | Rising.
Falling | Falling.

◆ AIDigitalTriggerSource

enum JY5325.AIDigitalTriggerSource

AI Digital Trigger Source.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
AO_StartTrig | AO_StartTrig.
DI_StartTrig | DI_StartTrig.
DI_ReferenceTrig | DI_ReferenceTrig.
DO_StartTrig | AO_StartTrig.
CIO_0_StartTrig | CI0_StartTrig.
CIO_1_StartTrig | CI1_StartTrig.
CO_0_Out | CI0_StartTrig.
CO_1_Out | CI1_StartTrig.

◆ AIMode

enum JY5325.AIMode

AIMode.

Enumerator
Finite | 单点模式 Finite
Continuous | Continuous.
Record | Record.

◆ AISampleClockSource

enum JY5325.AISampleClockSource

AIClockSource Type.

Enumerator
Internal

Internal.

◆ AISignalExportSource

enum JY5325.AISignalExportSource

AI Signal Export Source.

Enumerator
StartTrig | AI_StartTrig.
ReferenceTrig | AI_ReferenceTrig.
Internal_Counter_100K | Internal Counte 100K timebase.
Internal_Counter_5M | Internal Counte 5M timebase.
Internal_Counter_100M | Internal Counte 100Mtimebase.

◆ AITriggerMode

enum JY5325.AITriggerMode

AI Trigger Mode.

Enumerator
Start | Start Trigger Mode.
Reference | Reference Trigger Mode，Valid when JY5325AITask.Mode is AIMode.Finite

◆ AITriggerType

enum JY5325.AITriggerType

Trigger Type: Digital/Analog/Immediate.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Analog | Analog Trigger.
Soft | Soft Trigger.

◆ AODigitalTriggerEdge

enum JY5325.AODigitalTriggerEdge

AO Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ AODigitalTriggerSource

enum JY5325.AODigitalTriggerSource

AO Digital trigger source.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
DI_StartTrig | DI_StartTrig.
DI_ReferenceTrig | DI_ReferenceTrig.
DO_StartTrig | AO_StartTrig.
CIO_0_StartTrig | CI0_StartTrig.
CIO_1_StartTrig | CI1_StartTrig.
CO_0_Out | CI0_StartTrig.
CO_1_Out | CI1_StartTrig.

◆ AOMode

enum JY5325.AOMode

AOMode.

Enumerator
Single | Single.
Finite | Finite.
ContinuousNoWrapping | ContinuousNoWrapping.
ContinuousWrapping | ContinuousWrapping.

◆ AOSampleClockSource

enum JY5325.AOSampleClockSource

AO Sample Clock Source.

Enumerator
Internal

Internal Clock Source.

◆ AOSignalExportSource

enum JY5325.AOSignalExportSource

SourceSignal.

Enumerator
StartTrig | AO_StartTrig.
Internal_Counter_100K | Internal Counte 100K timebase.
Internal_Counter_5M | Internal Counte 5M timebase.
Internal_Counter_100M | Internal Counte 100Mtimebase.

◆ AOTriggerType

enum JY5325.AOTriggerType

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ CIDigitalTriggerEdge

enum JY5325.CIDigitalTriggerEdge

CI Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ CIDigitalTriggerSource

enum JY5325.CIDigitalTriggerSource

CI Digital trigger source.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
AO_StartTrig | AO_StartTrig.
DI_StartTrig | DI_StartTrig.
DI_ReferenceTrig | DI_ReferenceTrig.
DO_StartTrig | AO_StartTrig.
CIO_0_StartTrig | CI0_StartTrig.
CIO_1_StartTrig | CI1_StartTrig.
CO_0_Out | CI0_StartTrig.
CO_1_Out | CI1_StartTrig.

◆ CIMode

enum JY5325.CIMode

CIMode.

Enumerator
Single | Single.
Finite | Finite.
Continuous | Continuous.

◆ CISampleClockSource

enum JY5325.CISampleClockSource

CI Sample Clock Source.

Enumerator
Implicit | Implicit.
Internal | Internal.
External | External.

◆ CISignalExportSource

enum JY5325.CISignalExportSource

SourceSignal.

Enumerator
StartTrig | CI_StartTrig.
SampleClock | CI_SampleClock.
Internal_Counter_100K | Internal Counte 100K timebase.
Internal_Counter_5M | Internal Counte 5M timebase.
Internal_Counter_100M | Internal Counte 100Mtimebase.

◆ CITimebaseSource

enum JY5325.CITimebaseSource

时基源

Timebase source

Enumerator
Internal100MHz | 内部100MHz时基 Internal 100MHz Timebase
Internal5MHz | 内部5MHz时基 Internal 5MHz Timebase
Internal100kHz | 内部100kHz时基 Internal 100kHz Timebase
External | 外部时基 External Timebase

◆ CITriggerType

enum JY5325.CITriggerType

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ CIType

enum JY5325.CIType

Counter Input Application Type.

Enumerator
EdgeCounting | Edge Counting.
Period | Period Measure.
Frequency | Frequenc Measure.
Pulse | Pulse Measure.
SemiPeriod | SemiPeriod Measure.
TwoEdgeSeparation | TwoEdgeSeparation Measure.
QuadEncoder | QuadEncoder.
TwoPulseEncoder | EncoderTwoPulse.

◆ ClockTerminal

enum JY5325.ClockTerminal

External Sample Clock Terminal.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
DI_SampleClock | DI_SampleClock.
DO_SampleClock | DO_SampleClock.
CI_0_SampleClock | CI_0_SampleClock.
CI_1_SampleClock | CI_1_SampleClock.
CO_0_Output | CO_0_Output.
CO_1_Output | CO_1_Output.

◆ CODigitalTriggerEdge

enum JY5325.CODigitalTriggerEdge

CO Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ CODigitalTriggerSource

enum JY5325.CODigitalTriggerSource

CO Digital trigger source.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
AO_StartTrig | AO_StartTrig.
DI_StartTrig | DI_StartTrig.
DI_ReferenceTrig | DI_ReferenceTrig.
DO_StartTrig | AO_StartTrig.
CIO_0_StartTrig | CI0_StartTrig.
CIO_1_StartTrig | CI1_StartTrig.
CO_0_Out | CI0_StartTrig.
CO_1_Out | CI1_StartTrig.

◆ COIdleState

enum JY5325.COIdleState

Idle state when pulse output before start and after stop.

Enumerator
HighLevel | Idle state is high level.
LowLevel | Idle state is low level.

◆ COMode

enum JY5325.COMode

CO output mode.

Enumerator
Single | Single pulse output.
Finite | Finite.
ContinuousNoWrapping | ContinuousNoWrapping.
ContinuousWrapping | ContinuousWrapping.

◆ COPulseType

enum JY5325.COPulseType

Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick.

Enumerator
DutyCycleFrequency | Configure CO output pulse according to its DutyCycle and Freqency.
HighLowTime | Configure CO output pulse according to duration of its high/low voltage levels.
HighLowTick | Configure CO output pulse according to its high/low tick level.

◆ COSignalExportSource

enum JY5325.COSignalExportSource

SourceSignal.

Enumerator
StartTrig | CI_StartTrig.
Output | CO_Output.
Internal_Counter_100K | Internal Counte 100K timebase.
Internal_Counter_5M | Internal Counte 5M timebase.
Internal_Counter_100M | Internal Counte 100Mtimebase.

◆ COTimebaseSource

enum JY5325.COTimebaseSource

时基源

Timebase source

Enumerator
Internal100MHz | 内部100MHz时基 Internal 100MHz Timebase
Internal5MHz | 内部5MHz时基 Internal 5MHz Timebase
Internal100kHz | 内部100kHz时基 Internal 100kHz Timebase
External | 外部时基 External Timebase

◆ COTriggerType

enum JY5325.COTriggerType

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ CountDirection

enum JY5325.CountDirection

Counter direction.

enum Up/Down/External

Enumerator
Up | Counter increases.
Down | Counter decreases.
External | External signal control counter direction. If External signal is highlevel counter increases, or lowlevel counter decreases.

◆ DIDigitalTriggerEdge

enum JY5325.DIDigitalTriggerEdge

DI Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ DIDigitalTriggerSource

enum JY5325.DIDigitalTriggerSource

DI Digital trigger source.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
AO_StartTrig | AO_StartTrig.
DO_StartTrig | AO_StartTrig.
CIO_0_StartTrig | CI0_StartTrig.
CIO_1_StartTrig | CI1_StartTrig.
CO_0_Out | CI0_StartTrig.
CO_1_Out | CI1_StartTrig.

◆ DIMode

enum JY5325.DIMode

DIMode.

Enumerator
Single | Single.
Finite | Finite.
Continuous | Continuous.

◆ DISampleClockSource

enum JY5325.DISampleClockSource

DI Sample Clock Source.

Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ DISignalExportSource

enum JY5325.DISignalExportSource

SourceSignal.

Enumerator
StartTrig | DI_StartTrig.
ReferenceTrig | DI_ReferenceTrig.
SampleClock | DI_SampleClock.
Internal_Counter_100K | Internal Counte 100K timebase.
Internal_Counter_5M | Internal Counte 5M timebase.
Internal_Counter_100M | Internal Counte 100Mtimebase.

◆ DITriggerMode

enum JY5325.DITriggerMode

DI Trigger Mode.

Enumerator
Start | Start Trigger.
Reference | Reference Trigger，only for finite acquisition mode.

◆ DITriggerType

enum JY5325.DITriggerType

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ DODigitalTriggerEdge

enum JY5325.DODigitalTriggerEdge

DO Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ DODigitalTriggerSource

enum JY5325.DODigitalTriggerSource

DO Digital trigger source.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
AO_StartTrig | AO_StartTrig.
DI_StartTrig | DI_StartTrig.
DI_ReferenceTrig | DI_ReferenceTrig.
CIO_0_StartTrig | CI0_StartTrig.
CIO_1_StartTrig | CI1_StartTrig.
CO_0_Out | CI0_StartTrig.
CO_1_Out | CI1_StartTrig.

◆ DOMode

enum JY5325.DOMode

DOMode.

Enumerator
Single | Single.
Finite | Finite.
ContinuousWrapping | ContinuousNoWrapping.
ContinuousNoWrapping | ContinuousWrapping.

◆ DOSampleClockSource

enum JY5325.DOSampleClockSource

DO Sample Clock Source.

Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ DOSignalExportSource

enum JY5325.DOSignalExportSource

SourceSignal.

Enumerator
StartTrig | DO_StartTrig.
SampleClock | DO_SampleClock.
Internal_Counter_100K | Internal Counte 100K timebase.
Internal_Counter_5M | Internal Counte 5M timebase.
Internal_Counter_100M | Internal Counte 100Mtimebase.

◆ DOTriggerType

enum JY5325.DOTriggerType

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ EdgeCntOunEvtIdleState

enum JY5325.EdgeCntOunEvtIdleState

Output idle state when the event has not occurred.

Enumerator
LowLevel | Idle state is low level.
HighLevel | Idle state is high level.

◆ EdgeType

enum JY5325.EdgeType

Edge Type.

Enumerator
Rising | Rising Edge.
Falling | Falling Edge.
Any | Any Edge.

◆ FileFormat

enum JY5325.FileFormat

Streaming file format.

Enumerator
Bin

Binary file format.

◆ InputTerminal

enum JY5325.InputTerminal

Input Terminal.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
AI_SampleClock | AI SampleClock.
AO_SampleClock | AO SampleClock.
DI_SampleClock | DI SampleClock.
DO_SampleClock | DO SampleClock.
CO_0_OutPut | CO_0_OutPut.
CO_1_OutPut | CO_1_OutPut.
Timebase_100MHz | Timebase_100MHz.
Timebase_5MHz | Timebase_5MHz.
Timebase_100kHz | Timebase_100kHz.

◆ IOTerminal

enum JY5325.IOTerminal

Out terminal.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
None | None.

◆ LevelPolarity

enum JY5325.LevelPolarity

Level Polarity.

Enumerator
LowLevel | Low level.
HighLevel | High level.
None | No active polarity.

◆ OutputCompleteState

enum JY5325.OutputCompleteState

Output Complete State.

Enumerator
Zero | Output Complete Zero.
Hold | Output Complete Hold in The last point.

◆ QuadEncodingType

enum JY5325.QuadEncodingType

Quadrature Encoding Type.

Enumerator
X1 | X1.
X2 | X2.
X4 | X4.

◆ RecordMode

enum JY5325.RecordMode

Two stream mode from enum Finite/Infinite.

Enumerator
Finite | Finite Streaming.
Infinite | InFinite Streaming.

◆ SignalExportDestination

enum JY5325.SignalExportDestination

Output DestinationTerminal.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.

◆ SyncTopology

enum JY5325.SyncTopology

Synchronization board configuration.

Enumerator
Independent | Independent, synchronization not supported
Master | master card
Slave | slave card

◆ SyncTriggerRouting

enum JY5325.SyncTriggerRouting

Master card trigger signal routing (Master card routes trigger signal to this port)

Enumerator
NONE | Default NONE.
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PFI3 | PFI_3.
PFI4 | PFI_4.
PFI5 | PFI_5.
PFI6 | PFI_6.
PFI7 | PFI_7.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.

◆ ValueReturnMode

enum JY5325.ValueReturnMode

TwoEdgeSeparation value return mode.only for TwoEdgeSeparation type.

Enumerator
TwoValue | Return two data simultaneously. first data is gate to aux edge separation, second data is aux to gate edge separation.
OneValue | only return gate to aux edge separation


5325 C# Programming Manual: Package Members

  • Package List
  • Package Members
  • All
  • Enumerations
  • a
  • c
  • d
  • e
  • f
  • i
  • l
  • o
  • q
  • r
  • s
  • v
Here is a list of all namespace members with links to the namespace documentation for each member:

- a -

  • AIAnalogTriggerComparator : JY5325
  • AIAnalogTriggerEdge : JY5325
  • AIAnalogTriggerSource : JY5325
  • AIAnalogWindowCondition : JY5325
  • AIDigitalTriggerEdge : JY5325
  • AIDigitalTriggerSource : JY5325
  • AIMode : JY5325
  • AISampleClockSource : JY5325
  • AISignalExportSource : JY5325
  • AITriggerMode : JY5325
  • AITriggerType : JY5325
  • AODigitalTriggerEdge : JY5325
  • AODigitalTriggerSource : JY5325
  • AOMode : JY5325
  • AOSampleClockSource : JY5325
  • AOSignalExportSource : JY5325
  • AOTriggerType : JY5325

- c -

  • CIDigitalTriggerEdge : JY5325
  • CIDigitalTriggerSource : JY5325
  • CIMode : JY5325
  • CISampleClockSource : JY5325
  • CISignalExportSource : JY5325
  • CITimebaseSource : JY5325
  • CITriggerType : JY5325
  • CIType : JY5325
  • ClockTerminal : JY5325
  • CODigitalTriggerEdge : JY5325
  • CODigitalTriggerSource : JY5325
  • COIdleState : JY5325
  • COMode : JY5325
  • COPulseType : JY5325
  • COSignalExportSource : JY5325
  • COTimebaseSource : JY5325
  • COTriggerType : JY5325
  • CountDirection : JY5325

- d -

  • DIDigitalTriggerEdge : JY5325
  • DIDigitalTriggerSource : JY5325
  • DIMode : JY5325
  • DISampleClockSource : JY5325
  • DISignalExportSource : JY5325
  • DITriggerMode : JY5325
  • DITriggerType : JY5325
  • DODigitalTriggerEdge : JY5325
  • DODigitalTriggerSource : JY5325
  • DOMode : JY5325
  • DOSampleClockSource : JY5325
  • DOSignalExportSource : JY5325
  • DOTriggerType : JY5325

- e -

  • EdgeCntOunEvtIdleState : JY5325
  • EdgeType : JY5325

- f -

  • FileFormat : JY5325

- i -

  • InputTerminal : JY5325
  • IOTerminal : JY5325

- l -

  • LevelPolarity : JY5325

- o -

  • OutputCompleteState : JY5325

- q -

  • QuadEncodingType : JY5325

- r -

  • RecordMode : JY5325

- s -

  • SignalExportDestination : JY5325
  • SyncTopology : JY5325
  • SyncTriggerRouting : JY5325

- v -

  • ValueReturnMode : JY5325


5325 C# Programming Manual: Package Members

  • Package List
  • Package Members
  • All
  • Enumerations
  • a
  • c
  • d
  • e
  • f
  • i
  • l
  • o
  • q
  • r
  • s
  • v
Here is a list of all namespace enums with links to the namespace documentation for each enum:

- a -

  • AIAnalogTriggerComparator : JY5325
  • AIAnalogTriggerEdge : JY5325
  • AIAnalogTriggerSource : JY5325
  • AIAnalogWindowCondition : JY5325
  • AIDigitalTriggerEdge : JY5325
  • AIDigitalTriggerSource : JY5325
  • AIMode : JY5325
  • AISampleClockSource : JY5325
  • AISignalExportSource : JY5325
  • AITriggerMode : JY5325
  • AITriggerType : JY5325
  • AODigitalTriggerEdge : JY5325
  • AODigitalTriggerSource : JY5325
  • AOMode : JY5325
  • AOSampleClockSource : JY5325
  • AOSignalExportSource : JY5325
  • AOTriggerType : JY5325

- c -

  • CIDigitalTriggerEdge : JY5325
  • CIDigitalTriggerSource : JY5325
  • CIMode : JY5325
  • CISampleClockSource : JY5325
  • CISignalExportSource : JY5325
  • CITimebaseSource : JY5325
  • CITriggerType : JY5325
  • CIType : JY5325
  • ClockTerminal : JY5325
  • CODigitalTriggerEdge : JY5325
  • CODigitalTriggerSource : JY5325
  • COIdleState : JY5325
  • COMode : JY5325
  • COPulseType : JY5325
  • COSignalExportSource : JY5325
  • COTimebaseSource : JY5325
  • COTriggerType : JY5325
  • CountDirection : JY5325

- d -

  • DIDigitalTriggerEdge : JY5325
  • DIDigitalTriggerSource : JY5325
  • DIMode : JY5325
  • DISampleClockSource : JY5325
  • DISignalExportSource : JY5325
  • DITriggerMode : JY5325
  • DITriggerType : JY5325
  • DODigitalTriggerEdge : JY5325
  • DODigitalTriggerSource : JY5325
  • DOMode : JY5325
  • DOSampleClockSource : JY5325
  • DOSignalExportSource : JY5325
  • DOTriggerType : JY5325

- e -

  • EdgeCntOunEvtIdleState : JY5325
  • EdgeType : JY5325

- f -

  • FileFormat : JY5325

- i -

  • InputTerminal : JY5325
  • IOTerminal : JY5325

- l -

  • LevelPolarity : JY5325

- o -

  • OutputCompleteState : JY5325

- q -

  • QuadEncodingType : JY5325

- r -

  • RecordMode : JY5325

- s -

  • SignalExportDestination : JY5325
  • SyncTopology : JY5325
  • SyncTriggerRouting : JY5325

- v -

  • ValueReturnMode : JY5325


5325 C# Programming Manual: Package List

  • Package List
  • Package Members
Package List
Here are the packages with brief descriptions (if available):
N JY5325