5411 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5411 Directory Reference

5411 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 5411
5411 Directory Reference

Files

JY5411CoreOOCommon.h
JY5411CoreOODevice.h
JY5411CoreOODITask.h
JY5411CoreOODOTask.h
JY5411CoreOOLog.h
Generated by doxygen 1.13.2


5411 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5411/JY5411CoreOOCommon.h File Reference

  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 5411
Classes | Namespaces | Macros | Enumerations | Functions
JY5411CoreOOCommon.h File Reference
#include <string>
#include <stdint.h>

Classes

class | JY5411CoreOO::JYDriverException
class | JY5411CoreOO::JY5411CoreOOProperty< ContainerClass, ValueType, propertyType >
属性模板类 More...
class | JY5411CoreOO::PauseTrigger
Pause trigger configuration class. More...

Namespaces

namespace JY5411CoreOO

Macros

#define | EXTERN_C extern
Windows.
#define | JY5411CoreOO_API

Enumerations

enum class | JY5411CoreOO::JY5411CoreOOPropertyType { JY5411CoreOO::READ_ONLY = 1 , JY5411CoreOO::WRITE_ONLY = 2 , JY5411CoreOO::READ_WRITE = 3 }
enum class JY5411CoreOO::JYErrorCode {
JY5411CoreOO::NoError = 0 , JY5411CoreOO::TimeOut = -10001 , JY5411CoreOO::ErrorParam = -10002 , JY5411CoreOO::IncorrectCallOrder = -10003 ,
JY5411CoreOO::CannotCall = -10004 , JY5411CoreOO::UserBufferError = -10005 , JY5411CoreOO::BufferOverflow = -10006 , JY5411CoreOO::BufferDownflow = -10007 ,
JY5411CoreOO::HardwareResourceReserved = -10008 , JY5411CoreOO::aiIsStart = -10009 , JY5411CoreOO::ErrorParam1 = -10010
}
错误代码的定义 More...
enum class JY5411CoreOO::JYDriverExceptionPublic {
JY5411CoreOO::UnKnown = 0 , JY5411CoreOO::OpenDeviceFailed = -10001 , JY5411CoreOO::CloseDeviceFailed = -10002 , JY5411CoreOO::ResetDeviceFailed = -10003 ,
JY5411CoreOO::GetDevicePropertyFailed = -10004 , JY5411CoreOO::SetDevicePropertyFailed = -10005 , JY5411CoreOO::HardwareResourceIsReserved = -10006 , JY5411CoreOO::MethodNotPermitedToCallWhenCurrentStatus = -10007 ,
JY5411CoreOO::InvalidUserDataBuffer = -10008 , JY5411CoreOO::NoChannelAdded = -10009 , JY5411CoreOO::NotSupportOperationForCurrentDevice = -10010 , JY5411CoreOO::CreatTaskFailed = -10100 ,
JY5411CoreOO::StartTaskFailed = -10101 , JY5411CoreOO::StopTaskFailed = -10102 , JY5411CoreOO::TaskHasNotStarted = -10103 , JY5411CoreOO::TaskHasStartedCannotPerformTheSetOperation = -10104 ,
JY5411CoreOO::ChannelNumberParameterInvalid = -10105 , JY5411CoreOO::ChannelInputRangeParameterInvalid = -10106 , JY5411CoreOO::ChannelTerminalParameterInvalid = -10107 , JY5411CoreOO::ChannelCouplingParameterInvalid = -10108 ,
JY5411CoreOO::SampeleModeParameterInvalid = -10109 , JY5411CoreOO::SampleClockParameterInvalid = -10110 , JY5411CoreOO::SampleRateParameterInvalid = -10111 , JY5411CoreOO::UpdateRateParameterInvalid = -10112 ,
JY5411CoreOO::TriggerParameterInvalid = -10113 , JY5411CoreOO::ReferenceTriggerDoesNotMatchWithSampleMode = -10114 , JY5411CoreOO::PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint = -10115 , JY5411CoreOO::ReadDataFailed = -10016 ,
JY5411CoreOO::ReadDataTimeout = -10017 , JY5411CoreOO::WriteDataFailed = -10018 , JY5411CoreOO::WriteDataTimeout = -10019 , JY5411CoreOO::WriteDataLengthCannotBeLessThanN = -10020 ,
JY5411CoreOO::BufferDataOverflow = -10021 , JY5411CoreOO::BufferDataDownflow = -10022 , JY5411CoreOO::CheckBufferFailed = -10023 , JY5411CoreOO::PointInvalidInFiniteMode = -10024 ,
JY5411CoreOO::ReadPointInvalid = -10025 , JY5411CoreOO::OnlySupportRecordMode = -10026 , JY5411CoreOO::SendSoftTirggerFailed = -10027 , JY5411CoreOO::TaskTimeout = -10028 ,
JY5411CoreOO::CounterParametersInvalid = -10029 , JY5411CoreOO::WritePointInvalid = -10030 , JY5411CoreOO::SignalExportDestinationInvalid = -10031 , JY5411CoreOO::InvalidParameter = -10033
}
enum class JY5411CoreOO::ClockTerminal {
JY5411CoreOO::PXIe_DStarA = 1 , JY5411CoreOO::PXIe_DStarB = 2 , JY5411CoreOO::PXI_Star = 3 , JY5411CoreOO::PXIe_Sync100 = 5 ,
JY5411CoreOO::PXI_Trig0 = 18 , JY5411CoreOO::PXI_Trig1 = 19 , JY5411CoreOO::PXI_Trig2 = 20 , JY5411CoreOO::PXI_Trig3 = 21 ,
JY5411CoreOO::PXI_Trig4 = 22 , JY5411CoreOO::PXI_Trig5 = 23 , JY5411CoreOO::PXI_Trig6 = 24 , JY5411CoreOO::PXI_Trig7 = 25 ,
JY5411CoreOO::PFI0 = 10 , JY5411CoreOO::PFI1 = 11 , JY5411CoreOO::PFI2 = 12 , JY5411CoreOO::PFI3 = 13 ,
JY5411CoreOO::PFI4 = 14 , JY5411CoreOO::PFI5 = 15 , JY5411CoreOO::PFI6 = 16 , JY5411CoreOO::PFI7 = 17 ,
JY5411CoreOO::DI_SampleClock = 84 , JY5411CoreOO::DO_SampleClock = 83
}
enum class JY5411CoreOO::SignalExportDestination {
JY5411CoreOO::PFI0 =32 , JY5411CoreOO::PFI1 =33 , JY5411CoreOO::PFI2 =34 , JY5411CoreOO::PFI3 =35 ,
JY5411CoreOO::PFI4 = 36 , JY5411CoreOO::PFI5 =37 , JY5411CoreOO::PFI6 =38 , JY5411CoreOO::PFI7 =39 ,
JY5411CoreOO::PXI_Trig0 = 40 , JY5411CoreOO::PXI_Trig1 = 41 , JY5411CoreOO::PXI_Trig2 = 42 , JY5411CoreOO::PXI_Trig3 = 43 ,
JY5411CoreOO::PXI_Trig4 = 44 , JY5411CoreOO::PXI_Trig5 = 45 , JY5411CoreOO::PXI_Trig6 = 46 , JY5411CoreOO::PXI_Trig7 = 47
}
enum class | JY5411CoreOO::OutputCompleteState { JY5411CoreOO::Zero , JY5411CoreOO::Hold }
Output Complete State. More...
enum class | JY5411CoreOO::LevelPolarity { JY5411CoreOO::LowLevel = 0 , JY5411CoreOO::HighLevel = 1 , JY5411CoreOO::None = 2 }
Level Polarity. More...

Functions

std::string JY5411CoreOO::GetSignalExportDestinationString (SignalExportDestination destination)

Macro Definition Documentation

◆ EXTERN_C

#define EXTERN_C extern

Windows.

Linux

◆ JY5411CoreOO_API

#define JY5411CoreOO_API


5411 C++ Programming Manual: JY5411CoreOO::JYDriverException Class Reference

  • Class List
  • Class Index
  • Class Members
  • JY5411CoreOO
  • JYDriverException
Public Member Functions | Public Attributes | List of all members
JY5411CoreOO::JYDriverException Class Reference

#include <JY5411CoreOOCommon.h>

Public Member Functions

JYDriverException (JYDriverExceptionPublic exceptionCode, std::string msg="")
JYDriverException (JYErrorCode exceptionCode, std::string msg="")
JYDriverException (int, std::string msg)

Public Attributes

std::string exceptionMessage
JYDriverExceptionPublic errorCode
JYDriverException * FollowingException

Constructor & Destructor Documentation

◆ JYDriverException() [1/3]

JY5411CoreOO::JYDriverException::JYDriverException | ( | JYDriverExceptionPublic | exceptionCode,
 |  | std::string | msg = "" )

◆ JYDriverException() [2/3]

JY5411CoreOO::JYDriverException::JYDriverException | ( | JYErrorCode | exceptionCode,
 |  | std::string | msg = "" )

◆ JYDriverException() [3/3]

JY5411CoreOO::JYDriverException::JYDriverException | ( | int | ,
 |  | std::string | msg )

Member Data Documentation

◆ errorCode

JYDriverExceptionPublic JY5411CoreOO::JYDriverException::errorCode

◆ exceptionMessage

std::string JY5411CoreOO::JYDriverException::exceptionMessage

◆ FollowingException

JYDriverException* JY5411CoreOO::JYDriverException::FollowingException
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5411/JY5411CoreOOCommon.h


5411 C++ Programming Manual: JY5411CoreOO::JY5411CoreOOProperty< ContainerClass, ValueType, propertyType > Class Template Reference

  • JY5411CoreOO
  • JY5411CoreOOProperty
Public Member Functions | List of all members
JY5411CoreOO::JY5411CoreOOProperty< ContainerClass, ValueType, propertyType > Class Template Reference

属性模板类 More...

#include <JY5411CoreOOCommon.h>

Public Member Functions

JY5411CoreOOProperty ()
JY5411CoreOOProperty (ContainerClass *cObject, ValueType(ContainerClass::*pGet)(), void(ContainerClass::*pSet)(ValueType value))
JY5411CoreOOProperty (ValueType(*pGet)(), void(*pSet)(ValueType value))
ValueType operator= (const ValueType &value)
operator ValueType ()

Detailed Description

template<typename ContainerClass, typename ValueType, JY5411CoreOOPropertyType propertyType>
class JY5411CoreOO::JY5411CoreOOProperty< ContainerClass, ValueType, propertyType >

属性模板类

Constructor & Destructor Documentation

◆ JY5411CoreOOProperty() [1/3]

template<typename ContainerClass, typename ValueType, JY5411CoreOOPropertyType propertyType>
JY5411CoreOO::JY5411CoreOOProperty< ContainerClass, ValueType, propertyType >::JY5411CoreOOProperty ( )

◆ JY5411CoreOOProperty() [2/3]

template<typename ContainerClass, typename ValueType, JY5411CoreOOPropertyType propertyType>
JY5411CoreOO::JY5411CoreOOProperty< ContainerClass, ValueType, propertyType >::JY5411CoreOOProperty | ( | ContainerClass * | cObject,
 |  | ValueType(ContainerClass::* | pGet )(),
 |  | void(ContainerClass::* | pSet )(ValueType value) )

◆ JY5411CoreOOProperty() [3/3]

template<typename ContainerClass, typename ValueType, JY5411CoreOOPropertyType propertyType>
JY5411CoreOO::JY5411CoreOOProperty< ContainerClass, ValueType, propertyType >::JY5411CoreOOProperty | ( | ValueType(* | pGet )(),
 |  | void(* | pSet )(ValueType value) )

Member Function Documentation

◆ operator ValueType()

template<typename ContainerClass, typename ValueType, JY5411CoreOOPropertyType propertyType>
JY5411CoreOO::JY5411CoreOOProperty< ContainerClass, ValueType, propertyType >::operator ValueType ( )

◆ operator=()

template<typename ContainerClass, typename ValueType, JY5411CoreOOPropertyType propertyType>
ValueType JY5411CoreOO::JY5411CoreOOProperty< ContainerClass, ValueType, propertyType >::operator= ( const ValueType & value )
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5411/JY5411CoreOOCommon.h


5411 C++ Programming Manual: JY5411CoreOO::PauseTrigger Class Reference

  • PauseTrigger
Public Attributes | List of all members
JY5411CoreOO::PauseTrigger Class Reference

Pause trigger configuration class. More...

#include <JY5411CoreOOCommon.h>

Public Attributes

LevelPolarity ActivePolarity
Pause trigger active polarity.

Detailed Description

Pause trigger configuration class.

Member Data Documentation

◆ ActivePolarity

LevelPolarity JY5411CoreOO::PauseTrigger::ActivePolarity

Pause trigger active polarity.

The default value is LevelPolarity.None, means the pause trigger is disabled.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5411/JY5411CoreOOCommon.h


5411 C++ Programming Manual: JY5411CoreOO Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Enumerations | Functions
JY5411CoreOO Namespace Reference

Classes

class | DIChannel
DI Channel parameter class . More...
class | DIDigitalTrigger
DI Digital trigger . More...
class | DIExternalSampleClock
External Sample Clock Configuration Class. More...
class | DIRecord
class | DISampleClock
Sample clock configuration class. More...
class | DISignalExport
DI Signal Export Class. More...
class | DITrigger
Constructor to create an DITrigger task object. More...
class | DOChannel
DO Channel parameter class . More...
class | DODigitalTrigger
DO Digital trigger. More...
class | DOExternalSampleClock
External Sample Clock Configuration Class. More...
class | DOSampleClock
Sample clock configuration class. More...
class | DOSignalExport
DO Signal Export Class. More...
class | DOTrigger
Constructor to create an DOTrigger task object. More...
class | ExternalReferenceClock
class | JY5411CoreOODevice
class | JY5411CoreOODITask
class | JY5411CoreOODOTask
class | JY5411CoreOOLog
class | JY5411CoreOOProperty
属性模板类 More...
class | JY5411CoreOOReferenceClock
class | JYDriverException
class | PauseTrigger
Pause trigger configuration class. More...
class | PFIFilter
class | PFISetting

Enumerations

enum class | JY5411CoreOOPropertyType { READ_ONLY = 1 , WRITE_ONLY = 2 , READ_WRITE = 3 }
enum class JYErrorCode {
NoError = 0 , TimeOut = -10001 , ErrorParam = -10002 , IncorrectCallOrder = -10003 ,
CannotCall = -10004 , UserBufferError = -10005 , BufferOverflow = -10006 , BufferDownflow = -10007 ,
HardwareResourceReserved = -10008 , aiIsStart = -10009 , ErrorParam1 = -10010
}
错误代码的定义 More...
enum class JYDriverExceptionPublic {
UnKnown = 0 , OpenDeviceFailed = -10001 , CloseDeviceFailed = -10002 , ResetDeviceFailed = -10003 ,
GetDevicePropertyFailed = -10004 , SetDevicePropertyFailed = -10005 , HardwareResourceIsReserved = -10006 , MethodNotPermitedToCallWhenCurrentStatus = -10007 ,
InvalidUserDataBuffer = -10008 , NoChannelAdded = -10009 , NotSupportOperationForCurrentDevice = -10010 , CreatTaskFailed = -10100 ,
StartTaskFailed = -10101 , StopTaskFailed = -10102 , TaskHasNotStarted = -10103 , TaskHasStartedCannotPerformTheSetOperation = -10104 ,
ChannelNumberParameterInvalid = -10105 , ChannelInputRangeParameterInvalid = -10106 , ChannelTerminalParameterInvalid = -10107 , ChannelCouplingParameterInvalid = -10108 ,
SampeleModeParameterInvalid = -10109 , SampleClockParameterInvalid = -10110 , SampleRateParameterInvalid = -10111 , UpdateRateParameterInvalid = -10112 ,
TriggerParameterInvalid = -10113 , ReferenceTriggerDoesNotMatchWithSampleMode = -10114 , PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint = -10115 , ReadDataFailed = -10016 ,
ReadDataTimeout = -10017 , WriteDataFailed = -10018 , WriteDataTimeout = -10019 , WriteDataLengthCannotBeLessThanN = -10020 ,
BufferDataOverflow = -10021 , BufferDataDownflow = -10022 , CheckBufferFailed = -10023 , PointInvalidInFiniteMode = -10024 ,
ReadPointInvalid = -10025 , OnlySupportRecordMode = -10026 , SendSoftTirggerFailed = -10027 , TaskTimeout = -10028 ,
CounterParametersInvalid = -10029 , WritePointInvalid = -10030 , SignalExportDestinationInvalid = -10031 , InvalidParameter = -10033
}
enum class ClockTerminal {
PXIe_DStarA = 1 , PXIe_DStarB = 2 , PXI_Star = 3 , PXIe_Sync100 = 5 ,
PXI_Trig0 = 18 , PXI_Trig1 = 19 , PXI_Trig2 = 20 , PXI_Trig3 = 21 ,
PXI_Trig4 = 22 , PXI_Trig5 = 23 , PXI_Trig6 = 24 , PXI_Trig7 = 25 ,
PFI0 = 10 , PFI1 = 11 , PFI2 = 12 , PFI3 = 13 ,
PFI4 = 14 , PFI5 = 15 , PFI6 = 16 , PFI7 = 17 ,
DI_SampleClock = 84 , DO_SampleClock = 83
}
enum class SignalExportDestination {
PFI0 =32 , PFI1 =33 , PFI2 =34 , PFI3 =35 ,
PFI4 = 36 , PFI5 =37 , PFI6 =38 , PFI7 =39 ,
PXI_Trig0 = 40 , PXI_Trig1 = 41 , PXI_Trig2 = 42 , PXI_Trig3 = 43 ,
PXI_Trig4 = 44 , PXI_Trig5 = 45 , PXI_Trig6 = 46 , PXI_Trig7 = 47
}
enum class | OutputCompleteState { Zero , Hold }
Output Complete State. More...
enum class | LevelPolarity { LowLevel = 0 , HighLevel = 1 , None = 2 }
Level Polarity. More...
enum class | ReferenceClockSource { Internal = 0x1 , External = 0x4 }
enum class | PowerLevel { Level_1p8 = 0x0 , Level_2p5 = 0x1 , Level_3p3 = 0x2 , Level_5p0 = 0x03 }
enum class | ExternalReferenceClockTerminal { PXIe_Clk100 = 0 , PXIe_DStarA = 1 }
enum class PFITerminal {
PFI0 = 0 , PFI1 = 1 , PFI2 = 2 , PFI3 = 3 ,
PFI4 = 4 , PFI5 = 5 , PFI6 = 6 , PFI7 = 7 ,
PFI8 = 8 , PFI9 = 9 , PFI10 = 10 , PFI11 = 11 ,
PFI12 = 12 , PFI13 = 13 , PFI14 = 14 , PFI15 = 15
}
Input/Output Terminal of PFI. More...
enum class | FileFormat { Bin }
enum class | DISampleClockSource { Internal , External }
DI Sample Clock Source. More...
enum class | ClockEdge { Rising = 1 , Falling = 2 }
ClockEdge enumeration type. More...
enum class | DIMode { Single = 0 , Finite = 1 , Continuous =2 , Record = 0x3 }
DIMode. More...
enum class | DISignalExportSource { SampleClock = 84 , StartTrig = 89 , ReferenceTrig = 91 }
SourceSignal. More...
enum class | DITriggerMode { Start , Reference }
DI Trigger Mode. More...
enum class | DITriggerType { Immediate = 0x0 , Digital = 0x01 , Soft = 0x2 }
TriggerType Digital/Immediate/Soft. More...
enum class DIDigitalTriggerSource {
PFI0 = 0x0 , PFI1 = 0x1 , PFI2 = 0x2 , PFI3 = 0x3 ,
PFI4 = 0x04 , PFI5 = 0x05 , PFI6 = 0x6 , PFI7 = 0x7 ,
PXI_Trig0 = 0x8 , PXI_Trig1 = 0x9 , PXI_Trig2 = 10 , PXI_Trig3 = 11 ,
PXI_Trig4 = 12 , PXI_Trig5 = 13 , PXI_Trig6 = 14 , PXI_Trig7 = 15 ,
DO_StartTrig = 95
}
DI Digital trigger source. More...
enum class | DIDigitalTriggerEdge { Rising , Falling }
DI Digital Trigger Edge. More...
enum class | RecordMode { Finite , Infinite }
enum class | DOSampleClockSource { Internal , External }
DO Sample Clock Source. More...
enum class | DOClockEdge { Rising = 1 , Falling = 2 }
ClockEdge enumeration type. More...
enum class | DOMode { Single = 0 , Finite = 1 , ContinuousWrapping = 2 , ContinuousNoWrapping = 3 }
DOMode. More...
enum class | DODigitalTriggerEdge { Rising , Falling }
DO Digital Trigger Edge. More...
enum class DODigitalTriggerSource {
PFI0 = 0x0 , PFI1 = 0x1 , PFI2 = 0x2 , PFI3 = 0x3 ,
PFI4 = 0x04 , PFI5 = 0x05 , PFI6 = 0x6 , PFI7 = 0x7 ,
PXI_Trig0 = 0x8 , PXI_Trig1 = 0x9 , PXI_Trig2 = 10 , PXI_Trig3 = 11 ,
PXI_Trig4 = 12 , PXI_Trig5 = 13 , PXI_Trig6 = 14 , PXI_Trig7 = 15 ,
DI_StartTrig =89 , DI_ReferenceTrig = 91
}
DO Digital trigger source. More...
enum class | DOTriggerType { Immediate = 0 , Digital = 1 , Soft = 2 }
TriggerType Digital/Immediate/Soft. More...
enum class DOSignalExportSource {
DO_0 = 0 , DO_1 = 1 , DO_2 = 2 , DO_3 = 3 ,
DO_4 = 4 , DO_5 = 5 , DO_6 = 6 , DO_7 = 7 ,
DO_8 = 8 , DO_9 = 9 , DO_10 = 10 , DO_11 = 11 ,
DO_12 = 12 , DO_13 = 13 , DO_14 = 14 , DO_15 = 15 ,
DO_16 = 16 , DO_17 = 17 , DO_18 = 18 , DO_19 = 19 ,
DO_20 = 20 , DO_21 = 21 , DO_22 = 22 , DO_23 = 23 ,
DO_24 = 24 , DO_25 = 25 , DO_26 = 26 , DO_27 = 27 ,
DO_28 = 28 , DO_29 = 29 , DO_30 = 30 , DO_31 = 31 ,
SampleClock = 83 , StartTrig = 95
}
SourceSignal. More...
enum class JY5411CoreOOLogLevel {
DEBUG_LOG_LEVEL , INFO_LOG_LEVEL , WARN_LOG_LEVEL , ERROR_LOG_LEVEL ,
FATAL_LOG_LEVEL
}

Functions

std::string GetSignalExportDestinationString (SignalExportDestination destination)

Enumeration Type Documentation

◆ ClockEdge

enum class JY5411CoreOO::ClockEdge
strong

ClockEdge enumeration type.

Enumerator
Rising | Rising.
Falling | Falling.

◆ ClockTerminal

enum class JY5411CoreOO::ClockTerminal
strong
Enumerator
PXIe_DStarA | PXIeDStarA.
PXIe_DStarB | PXIeDStarB.
PXI_Star | PXIStar.
PXIe_Sync100 | SYNC100.
PXI_Trig0 | External clock PXITriggerBus0.
PXI_Trig1 | External clock PXITriggerBus1.
PXI_Trig2 | External clock PXITriggerBus2.
PXI_Trig3 | External clock PXITriggerBus3.
PXI_Trig4 | External clock PXITriggerBus4.
PXI_Trig5 | External clock PXITriggerBus5.
PXI_Trig6 | External clock PXITriggerBus6.
PXI_Trig7 | External clock PXITriggerBus7.
PFI0 | External clock PXITriggerPFI0.
PFI1 | External clock PXITriggerPFI1.
PFI2 | External clock PXITriggerPFI2.
PFI3 | External clock PXITriggerPFI3.
PFI4 | External clock PXITriggerPFI4.
PFI5 | External clock PXITriggerPFI5.
PFI6 | External clock PXITriggerPFI6.
PFI7 | External clock PXITriggerPFI7.
DI_SampleClock | DI_SampleClock.
DO_SampleClock | DO_SampleClock.

◆ DIDigitalTriggerEdge

enum class JY5411CoreOO::DIDigitalTriggerEdge
strong

DI Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ DIDigitalTriggerSource

enum class JY5411CoreOO::DIDigitalTriggerSource
strong

DI Digital trigger source.

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.
DO_StartTrig | DO_StartTrig.

◆ DIMode

enum class JY5411CoreOO::DIMode
strong

DIMode.

Enumerator
Single | Single 单点模式
Finite | Finite 有限点模式
Continuous | Continuous 连续模式
Record | 流盘

◆ DISampleClockSource

enum class JY5411CoreOO::DISampleClockSource
strong

DI Sample Clock Source.

Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ DISignalExportSource

enum class JY5411CoreOO::DISignalExportSource
strong

SourceSignal.

Enumerator
SampleClock | DI_SampleClock.
StartTrig | DI_Start_trigger.
ReferenceTrig | DI_Reference_trigger.

◆ DITriggerMode

enum class JY5411CoreOO::DITriggerMode
strong

DI Trigger Mode.

Enumerator
Start | Start Trigger.
Reference | Reference Trigger，only for finite acquisition mode.

◆ DITriggerType

enum class JY5411CoreOO::DITriggerType
strong

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ DOClockEdge

enum class JY5411CoreOO::DOClockEdge
strong

ClockEdge enumeration type.

Enumerator
Rising | Rising.
Falling | Falling.

◆ DODigitalTriggerEdge

enum class JY5411CoreOO::DODigitalTriggerEdge
strong

DO Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ DODigitalTriggerSource

enum class JY5411CoreOO::DODigitalTriggerSource
strong

DO Digital trigger source.

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.
DI_StartTrig | DI_Start_Trig.
DI_ReferenceTrig | DI_Reference_Trig.

◆ DOMode

enum class JY5411CoreOO::DOMode
strong

DOMode.

Enumerator
Single | Single.
Finite | Finite.
ContinuousWrapping | ContinuousNoWrapping.
ContinuousNoWrapping | ContinuousWrapping.

◆ DOSampleClockSource

enum class JY5411CoreOO::DOSampleClockSource
strong

DO Sample Clock Source.

Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ DOSignalExportSource

enum class JY5411CoreOO::DOSignalExportSource
strong

SourceSignal.

Enumerator
DO_0 | DO_0 signal.
DO_1 | DO_1 signal.
DO_2 | DO_2 signal.
DO_3 | DO_3 signal.
DO_4 | DO_4 signal.
DO_5 | DO_5 signal.
DO_6 | DO_6 signal.
DO_7 | DO_7 signal.
DO_8 | DO_8 signal.
DO_9 | DO_9 signal.
DO_10 | DO_10 signal.
DO_11 | DO_11 signal.
DO_12 | DO_12 signal.
DO_13 | DO_13 signal.
DO_14 | DO_14 signal.
DO_15 | DO_15 signal.
DO_16 | DO_16 signal.
DO_17 | DO_17 signal.
DO_18 | DO_18 signal.
DO_19 | DO_19 signal.
DO_20 | DO_20 signal.
DO_21 | DO_1 signal.
DO_22 | DO_22 signal.
DO_23 | DO_23 signal.
DO_24 | DO_24 signal.
DO_25 | DO_25 signal.
DO_26 | DO_26 signal.
DO_27 | DO_27 signal.
DO_28 | DO_28 signal.
DO_29 | DO_29 signal.
DO_30 | DO_30 signal.
DO_31 | DO_31 signal.
SampleClock | DO_SampleCLK_Out.
StartTrig | DO_Start_trigger_out.

◆ DOTriggerType

enum class JY5411CoreOO::DOTriggerType
strong

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ ExternalReferenceClockTerminal

enum class JY5411CoreOO::ExternalReferenceClockTerminal
strong

澶栭儴鍙傝€冩椂閽熻緭鍏ョ鍙?/para>

External Reference Clcok Terminal

Enumerator
PXIe_Clk100 | PXIe CLK100 PXIe CLK100
PXIe_DStarA | PXIe_DStarA PXIe_DStarA

◆ FileFormat

enum class JY5411CoreOO::FileFormat
strong
Enumerator
Bin

BIN。

BIN.

◆ JY5411CoreOOLogLevel

enum class JY5411CoreOO::JY5411CoreOOLogLevel
strong
Enumerator
DEBUG_LOG_LEVEL
INFO_LOG_LEVEL
WARN_LOG_LEVEL
ERROR_LOG_LEVEL
FATAL_LOG_LEVEL

◆ JY5411CoreOOPropertyType

enum class JY5411CoreOO::JY5411CoreOOPropertyType
strong
Enumerator
READ_ONLY
WRITE_ONLY
READ_WRITE

◆ JYDriverExceptionPublic

enum class JY5411CoreOO::JYDriverExceptionPublic
strong
Enumerator
UnKnown | JYDriverExceptionPublic.
OpenDeviceFailed | JYDriverExceptionPublic.
CloseDeviceFailed | JYDriverExceptionPublic.
ResetDeviceFailed | JYDriverExceptionPublic.
GetDevicePropertyFailed | JYDriverExceptionPublic.
SetDevicePropertyFailed | JYDriverExceptionPublic.
HardwareResourceIsReserved | JYDriverExceptionPublic.
MethodNotPermitedToCallWhenCurrentStatus | JYDriverExceptionPublic.
InvalidUserDataBuffer | JYDriverExceptionPublic.
NoChannelAdded | JYDriverExceptionPublic.
NotSupportOperationForCurrentDevice | JYDriverExceptionPublic.
CreatTaskFailed | JYDriverExceptionPublic.
StartTaskFailed | JYDriverExceptionPublic.
StopTaskFailed | JYDriverExceptionPublic.
TaskHasNotStarted | JYDriverExceptionPublic.
TaskHasStartedCannotPerformTheSetOperation | JYDriverExceptionPublic.
ChannelNumberParameterInvalid | JYDriverExceptionPublic.
ChannelInputRangeParameterInvalid | JYDriverExceptionPublic.
ChannelTerminalParameterInvalid | JYDriverExceptionPublic.
ChannelCouplingParameterInvalid | JYDriverExceptionPublic.
SampeleModeParameterInvalid | JYDriverExceptionPublic.
SampleClockParameterInvalid | JYDriverExceptionPublic.
SampleRateParameterInvalid | JYDriverExceptionPublic.
UpdateRateParameterInvalid | JYDriverExceptionPublic.
TriggerParameterInvalid | JYDriverExceptionPublic.
ReferenceTriggerDoesNotMatchWithSampleMode | JYDriverExceptionPublic.
PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint | JYDriverExceptionPublic.
ReadDataFailed | JYDriverExceptionPublic.
ReadDataTimeout | JYDriverExceptionPublic.
WriteDataFailed | JYDriverExceptionPublic.
WriteDataTimeout | JYDriverExceptionPublic.
WriteDataLengthCannotBeLessThanN | JYDriverExceptionPublic.
BufferDataOverflow | JYDriverExceptionPublic.
BufferDataDownflow | JYDriverExceptionPublic.
CheckBufferFailed | JYDriverExceptionPublic.
PointInvalidInFiniteMode | JYDriverExceptionPublic.
ReadPointInvalid | JYDriverExceptionPublic.
OnlySupportRecordMode | JYDriverExceptionPublic.
SendSoftTirggerFailed | JYDriverExceptionPublic.
TaskTimeout | JYDriverExceptionPublic.
CounterParametersInvalid | JYDriverExceptionPublic.
WritePointInvalid | JYDriverExceptionPublic.
SignalExportDestinationInvalid | JYDriverExceptionPublic.
InvalidParameter | 无效参数。 Invaild parameter.

◆ JYErrorCode

enum class JY5411CoreOO::JYErrorCode
strong

错误代码的定义

Enumerator
NoError | 无错误
TimeOut | 超时
ErrorParam | 参数错误
IncorrectCallOrder | 调用顺序不正确
CannotCall | 当前配置不能调用该方法
UserBufferError | 用户缓冲区错误
BufferOverflow | 缓冲区溢出
BufferDownflow | 缓冲区下溢出
HardwareResourceReserved | 硬件资源已被占用
aiIsStart | AI已经启动，不用添加通道
ErrorParam1 | 输入幅值范围不正确,范围最大值和最小值

◆ LevelPolarity

enum class JY5411CoreOO::LevelPolarity
strong

Level Polarity.

Enumerator
LowLevel | Low level.
HighLevel | High level.
None | No active polarity.

◆ OutputCompleteState

enum class JY5411CoreOO::OutputCompleteState
strong

Output Complete State.

Enumerator
Zero | Output Complete Zero.
Hold | Output Complete Hold in The last point.

◆ PFITerminal

enum class JY5411CoreOO::PFITerminal
strong

Input/Output Terminal of PFI.

Enumerator
PFI0 | PFI 0.
PFI1 | PFI 1.
PFI2 | PFI 2.
PFI3 | PFI 3.
PFI4 | PFI 4.
PFI5 | PFI 5.
PFI6 | PFI 6.
PFI7 | PFI 7.
PFI8 | PFI 8.
PFI9 | PFI 9.
PFI10 | PFI 10.
PFI11 | PFI 11.
PFI12 | PFI 12.
PFI13 | PFI 13.
PFI14 | PFI 14.
PFI15 | PFI 15.

◆ PowerLevel

enum class JY5411CoreOO::PowerLevel
strong
Enumerator
Level_1p8 | 1.8V
Level_2p5 | 2.5V
Level_3p3 | 3.3V
Level_5p0 | 5V

◆ RecordMode

enum class JY5411CoreOO::RecordMode
strong
Enumerator
Finite | Finite Streaming.
Infinite | Infinite Streaming.

◆ ReferenceClockSource

enum class JY5411CoreOO::ReferenceClockSource
strong

鍙傝€冩椂閽熸簮

Reference Clock Source

Enumerator
Internal | 鏉胯浇10MHz鏃堕挓锛圱XCO锛?/para> Onboard 10MHz Clock (TXCO)
External | 澶栭儴杈撳叆鐨勬椂閽?/para> Reference Clock Source

◆ SignalExportDestination

enum class JY5411CoreOO::SignalExportDestination
strong
Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.

Function Documentation

◆ GetSignalExportDestinationString()

std::string JY5411CoreOO::GetSignalExportDestinationString ( SignalExportDestination destination )
inline


5411 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5411/JY5411CoreOODevice.h File Reference

  • File List
  • File Members
  • COO
  • 5411
Classes | Namespaces | Enumerations
JY5411CoreOODevice.h File Reference
#include <iostream>
#include <string>
#include <list>
#include <vector>
#include "JY5411CoreOOCommon.h"

Classes

class | JY5411CoreOO::JY5411CoreOODevice
class | JY5411CoreOO::PFIFilter
class | JY5411CoreOO::PFISetting
class | JY5411CoreOO::ExternalReferenceClock
class | JY5411CoreOO::JY5411CoreOOReferenceClock

Namespaces

namespace JY5411CoreOO

Enumerations

enum class | JY5411CoreOO::ReferenceClockSource { JY5411CoreOO::Internal = 0x1 , JY5411CoreOO::External = 0x4 }
enum class | JY5411CoreOO::PowerLevel { JY5411CoreOO::Level_1p8 = 0x0 , JY5411CoreOO::Level_2p5 = 0x1 , JY5411CoreOO::Level_3p3 = 0x2 , JY5411CoreOO::Level_5p0 = 0x03 }
enum class | JY5411CoreOO::ExternalReferenceClockTerminal { JY5411CoreOO::PXIe_Clk100 = 0 , JY5411CoreOO::PXIe_DStarA = 1 }
enum class JY5411CoreOO::PFITerminal {
JY5411CoreOO::PFI0 = 0 , JY5411CoreOO::PFI1 = 1 , JY5411CoreOO::PFI2 = 2 , JY5411CoreOO::PFI3 = 3 ,
JY5411CoreOO::PFI4 = 4 , JY5411CoreOO::PFI5 = 5 , JY5411CoreOO::PFI6 = 6 , JY5411CoreOO::PFI7 = 7 ,
JY5411CoreOO::PFI8 = 8 , JY5411CoreOO::PFI9 = 9 , JY5411CoreOO::PFI10 = 10 , JY5411CoreOO::PFI11 = 11 ,
JY5411CoreOO::PFI12 = 12 , JY5411CoreOO::PFI13 = 13 , JY5411CoreOO::PFI14 = 14 , JY5411CoreOO::PFI15 = 15
}
Input/Output Terminal of PFI. More...


5411 C++ Programming Manual: JY5411CoreOO::JY5411CoreOODevice Class Reference

  • JY5411CoreOODevice
Public Types | Static Public Member Functions | Public Attributes | List of all members
JY5411CoreOO::JY5411CoreOODevice Class Reference

#include <JY5411CoreOODevice.h>

Public Types

enum class CounterInterface { Source , Gate , Aux , Out }

Static Public Member Functions

static JY5411CoreOODevice * | GetInstance (int cardNum)
static JY5411CoreOODevice * | GetInstance (std::string aliasName)

Public Attributes

const double | BoardClockRate = 200000000
const double | MaxSampleRate = 50000000
const int | DIOLineCount = 32
const bool | IsAISync = false
const bool | IsAOSync = true
IsAOSync.
JY5411CoreOOProperty< JY5411CoreOODevice, int, JY5411CoreOOPropertyType::READ_ONLY > | DiffChannelCount
JY5411CoreOOProperty< JY5411CoreOODevice, int, JY5411CoreOOPropertyType::READ_ONLY > | SEChannelCount
JY5411CoreOOProperty< JY5411CoreOODevice, std::string, JY5411CoreOOPropertyType::READ_ONLY > | SerialNumber
JY5411CoreOOProperty< JY5411CoreOODevice, int, JY5411CoreOOPropertyType::READ_ONLY > | DeviceID
JY5411CoreOOProperty< JY5411CoreOODevice, void *, JY5411CoreOOPropertyType::READ_ONLY > | Handle
PFISetting * PFI
JY5411CoreOOReferenceClock * ReferenceClock

Member Enumeration Documentation

◆ CounterInterface

enum class JY5411CoreOO::JY5411CoreOODevice::CounterInterface
strong
Enumerator
Source
Gate
Aux
Out

Member Function Documentation

◆ GetInstance() [1/2]

static JY5411CoreOODevice * JY5411CoreOO::JY5411CoreOODevice::GetInstance ( int cardNum )
static

◆ GetInstance() [2/2]

static JY5411CoreOODevice * JY5411CoreOO::JY5411CoreOODevice::GetInstance ( std::string aliasName )
static

Member Data Documentation

◆ BoardClockRate

const double JY5411CoreOO::JY5411CoreOODevice::BoardClockRate = 200000000

◆ DeviceID

JY5411CoreOOProperty<JY5411CoreOODevice, int, JY5411CoreOOPropertyType::READ_ONLY> JY5411CoreOO::JY5411CoreOODevice::DeviceID

◆ DiffChannelCount

JY5411CoreOOProperty<JY5411CoreOODevice, int, JY5411CoreOOPropertyType::READ_ONLY> JY5411CoreOO::JY5411CoreOODevice::DiffChannelCount

◆ DIOLineCount

const int JY5411CoreOO::JY5411CoreOODevice::DIOLineCount = 32

◆ Handle

JY5411CoreOOProperty<JY5411CoreOODevice, void*, JY5411CoreOOPropertyType::READ_ONLY> JY5411CoreOO::JY5411CoreOODevice::Handle

◆ IsAISync

const bool JY5411CoreOO::JY5411CoreOODevice::IsAISync = false

◆ IsAOSync

const bool JY5411CoreOO::JY5411CoreOODevice::IsAOSync = true

IsAOSync.

◆ MaxSampleRate

const double JY5411CoreOO::JY5411CoreOODevice::MaxSampleRate = 50000000

◆ PFI

PFISetting* JY5411CoreOO::JY5411CoreOODevice::PFI

◆ ReferenceClock

JY5411CoreOOReferenceClock* JY5411CoreOO::JY5411CoreOODevice::ReferenceClock

◆ SEChannelCount

JY5411CoreOOProperty<JY5411CoreOODevice, int, JY5411CoreOOPropertyType::READ_ONLY> JY5411CoreOO::JY5411CoreOODevice::SEChannelCount

◆ SerialNumber

JY5411CoreOOProperty<JY5411CoreOODevice, std::string, JY5411CoreOOPropertyType::READ_ONLY> JY5411CoreOO::JY5411CoreOODevice::SerialNumber
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5411/JY5411CoreOODevice.h


5411 C++ Programming Manual: JY5411CoreOO::PFIFilter Class Reference

  • PFIFilter
Public Member Functions | List of all members
JY5411CoreOO::PFIFilter Class Reference

#include <JY5411CoreOODevice.h>

Public Member Functions

void | Enable (PFITerminal terminal, int minPulseWidth)
Enable the filter on the specified terminal and set the minimum pulse width.
void | Enable (std::vector< PFITerminal > terminals, int minPulseWidth)
Enable the filter on a group of terminals and set the minimum pulse width.
void | Enable (std::vector< PFITerminal > terminals, std::vector< int > minPulseWidth)
Enable the filter on a group of terminals and set the minimum pulse width separately.
void | Disable (PFITerminal terminal)
Disable the filter on the specified terminal.
void | Disable (std::vector< PFITerminal > terminals)
Disable the filter on a group terminal.
void | DisableAll ()
Disable the filter on all the terminals.

Member Function Documentation

◆ Disable() [1/2]

void JY5411CoreOO::PFIFilter::Disable ( PFITerminal terminal )

Disable the filter on the specified terminal.

Parameters
terminal Specified Terminal

◆ Disable() [2/2]

void JY5411CoreOO::PFIFilter::Disable ( std::vector< PFITerminal > terminals )

Disable the filter on a group terminal.

Parameters
terminals Specified Group of Terminal

◆ DisableAll()

void JY5411CoreOO::PFIFilter::DisableAll ( )

Disable the filter on all the terminals.

◆ Enable() [1/3]

void JY5411CoreOO::PFIFilter::Enable | ( | PFITerminal | terminal,
 |  | int | minPulseWidth )

Enable the filter on the specified terminal and set the minimum pulse width.

Parameters
terminal | Specified Terminal
minPulseWidth | Minimum pulse width in ns, bounce less than this length will be ignored. The smallest step in the range of 10 ns to 2550 ns is 10 ns, the smallest step in the range of 2550 ns to 40800 ns is 160 ns, and the smallest step in the range of 40800 ns to 652800 ns The step is 2560 ns

◆ Enable() [2/3]

void JY5411CoreOO::PFIFilter::Enable | ( | std::vector< PFITerminal > | terminals,
 |  | int | minPulseWidth )

Enable the filter on a group of terminals and set the minimum pulse width.

Parameters
terminals | Specified Group of Terminals
minPulseWidth | Minimum pulse width in ns, bounce less than this length will be ignored. The smallest step in the range of 10 ns to 2550 ns is 10 ns, the smallest step in the range of 2550 ns to 40800 ns is 160 ns, and the smallest step in the range of 40800 ns to 652800 ns The step is 2560 ns

◆ Enable() [3/3]

void JY5411CoreOO::PFIFilter::Enable | ( | std::vector< PFITerminal > | terminals,
 |  | std::vector< int > | minPulseWidth )

Enable the filter on a group of terminals and set the minimum pulse width separately.

Parameters
terminals | Specified Group of Terminals
minPulseWidth | Minimum pulse width in ns, bounce less than this length will be ignored. The smallest step in the range of 10 ns to 2550 ns is 10 ns, the smallest step in the range of 2550 ns to 40800 ns is 160 ns, and the smallest step in the range of 40800 ns to 652800 ns The step is 2560 ns
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5411/JY5411CoreOODevice.h


5411 C++ Programming Manual: JY5411CoreOO::PFISetting Class Reference

  • PFISetting
Public Attributes | List of all members
JY5411CoreOO::PFISetting Class Reference

#include <JY5411CoreOODevice.h>

Public Attributes

PFIFilter * Filter
PFI Filter Setting.
PowerLevel LogicLevel

Member Data Documentation

◆ Filter

PFIFilter* JY5411CoreOO::PFISetting::Filter

PFI Filter Setting.

◆ LogicLevel

PowerLevel JY5411CoreOO::PFISetting::LogicLevel
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5411/JY5411CoreOODevice.h


5411 C++ Programming Manual: JY5411CoreOO::ExternalReferenceClock Class Reference

  • ExternalReferenceClock
Public Attributes | List of all members
JY5411CoreOO::ExternalReferenceClock Class Reference

#include <JY5411CoreOODevice.h>

Public Attributes

ExternalReferenceClockTerminal Terminal
int Frequency

Member Data Documentation

◆ Frequency

int JY5411CoreOO::ExternalReferenceClock::Frequency

◆ Terminal

ExternalReferenceClockTerminal JY5411CoreOO::ExternalReferenceClock::Terminal
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5411/JY5411CoreOODevice.h


5411 C++ Programming Manual: JY5411CoreOO::JY5411CoreOOReferenceClock Class Reference

  • JY5411CoreOOReferenceClock
Public Member Functions | Public Attributes | List of all members
JY5411CoreOO::JY5411CoreOOReferenceClock Class Reference

#include <JY5411CoreOODevice.h>

Public Member Functions

void Commit ()
Commit configuration.

Public Attributes

ReferenceClockSource Source
ExternalReferenceClock * External
External Reference Clock Source.
bool Locked = false

Member Function Documentation

◆ Commit()

void JY5411CoreOO::JY5411CoreOOReferenceClock::Commit ( )

Commit configuration.

Available only when the device is idle. WARNING: Incorrect parameters will cause the PLL to be unable to lock the reference clock and cannot be recovered until shutdown and restart.

Member Data Documentation

◆ External

ExternalReferenceClock* JY5411CoreOO::JY5411CoreOOReferenceClock::External

External Reference Clock Source.

Required when ReferenceClock.Source is ReferenceClockSource.External

◆ Locked

bool JY5411CoreOO::JY5411CoreOOReferenceClock::Locked = false

◆ Source

ReferenceClockSource JY5411CoreOO::JY5411CoreOOReferenceClock::Source
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5411/JY5411CoreOODevice.h


5411 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5411/JY5411CoreOODITask.h File Reference

  • File List
  • File Members
  • COO
  • 5411
Classes | Namespaces | Enumerations
JY5411CoreOODITask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JY5411CoreOOCommon.h"
#include "JY5411CoreOODevice.h"

Classes

class | JY5411CoreOO::JY5411CoreOODITask
class | JY5411CoreOO::DIChannel
DI Channel parameter class . More...
class | JY5411CoreOO::DIRecord
class | JY5411CoreOO::DISampleClock
Sample clock configuration class. More...
class | JY5411CoreOO::DIExternalSampleClock
External Sample Clock Configuration Class. More...
class | JY5411CoreOO::DISignalExport
DI Signal Export Class. More...
class | JY5411CoreOO::DITrigger
Constructor to create an DITrigger task object. More...
class | JY5411CoreOO::DIDigitalTrigger
DI Digital trigger . More...

Namespaces

namespace JY5411CoreOO

Enumerations

enum class | JY5411CoreOO::FileFormat { JY5411CoreOO::Bin }
enum class | JY5411CoreOO::DISampleClockSource { JY5411CoreOO::Internal , JY5411CoreOO::External }
DI Sample Clock Source. More...
enum class | JY5411CoreOO::ClockEdge { JY5411CoreOO::Rising = 1 , JY5411CoreOO::Falling = 2 }
ClockEdge enumeration type. More...
enum class | JY5411CoreOO::DIMode { JY5411CoreOO::Single = 0 , JY5411CoreOO::Finite = 1 , JY5411CoreOO::Continuous =2 , JY5411CoreOO::Record = 0x3 }
DIMode. More...
enum class | JY5411CoreOO::DISignalExportSource { JY5411CoreOO::SampleClock = 84 , JY5411CoreOO::StartTrig = 89 , JY5411CoreOO::ReferenceTrig = 91 }
SourceSignal. More...
enum class | JY5411CoreOO::DITriggerMode { JY5411CoreOO::Start , JY5411CoreOO::Reference }
DI Trigger Mode. More...
enum class | JY5411CoreOO::DITriggerType { JY5411CoreOO::Immediate = 0x0 , JY5411CoreOO::Digital = 0x01 , JY5411CoreOO::Soft = 0x2 }
TriggerType Digital/Immediate/Soft. More...
enum class JY5411CoreOO::DIDigitalTriggerSource {
JY5411CoreOO::PFI0 = 0x0 , JY5411CoreOO::PFI1 = 0x1 , JY5411CoreOO::PFI2 = 0x2 , JY5411CoreOO::PFI3 = 0x3 ,
JY5411CoreOO::PFI4 = 0x04 , JY5411CoreOO::PFI5 = 0x05 , JY5411CoreOO::PFI6 = 0x6 , JY5411CoreOO::PFI7 = 0x7 ,
JY5411CoreOO::PXI_Trig0 = 0x8 , JY5411CoreOO::PXI_Trig1 = 0x9 , JY5411CoreOO::PXI_Trig2 = 10 , JY5411CoreOO::PXI_Trig3 = 11 ,
JY5411CoreOO::PXI_Trig4 = 12 , JY5411CoreOO::PXI_Trig5 = 13 , JY5411CoreOO::PXI_Trig6 = 14 , JY5411CoreOO::PXI_Trig7 = 15 ,
JY5411CoreOO::DO_StartTrig = 95
}
DI Digital trigger source. More...
enum class | JY5411CoreOO::DIDigitalTriggerEdge { JY5411CoreOO::Rising , JY5411CoreOO::Falling }
DI Digital Trigger Edge. More...
enum class | JY5411CoreOO::RecordMode { JY5411CoreOO::Finite , JY5411CoreOO::Infinite }


5411 C++ Programming Manual: JY5411CoreOO::JY5411CoreOODITask Class Reference

  • JY5411CoreOODITask
Public Member Functions | Public Attributes | List of all members
JY5411CoreOO::JY5411CoreOODITask Class Reference

#include <JY5411CoreOODITask.h>

Public Member Functions

JY5411CoreOODITask (int slotNum)
JY5411CoreOODITask (std::string boardName)
~JY5411CoreOODITask ()
void | AddChannel (int lineNum)
Add one line.
void | AddChannel (std::vector< int > linesNum)
Add a group of line.
void | RemoveChannel (int lineNum)
Delete the specified line number.
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Start ()
Start DI task .
void | Stop ()
Stop DI task .
void | ReadSinglePoint (bool &readValues, int line)
Specify the line reads the latest line.Available when Type is DIMode.Single.
void | ReadSinglePoint (bool *readValues)
Read the sample point value from the register.Available when Type is DIMode.Single.
void | ReadData (unsigned int *buf, unsigned int samplesToAcquire, int timeOut=10000)
Read the uint data from one line or multi-lines

Parameters
buf readValue
Parameters
samplesToAcquire Number of samples per line to be read
Parameters
timeOut timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

void | GetRecordPreviewData (uint64_t &filelen, bool &recordDone)

Public Attributes

std::list< DIChannel * > | Channels
List of DI channels.
DIMode Mode
DI acquisition mode，support Single/ Finite/Continuous.
JY5411CoreOOProperty< JY5411CoreOODITask, double, JY5411CoreOOPropertyType::READ_WRITE > | SampleRate
int | SamplesToAcquire
Number of samples to be read per channel.
DISampleClock * SampleClock
DI Sample Clock Configuration.
JY5411CoreOOProperty< JY5411CoreOODITask, int, JY5411CoreOOPropertyType::READ_ONLY > | BufLenInSamples
Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.
JY5411CoreOOProperty< JY5411CoreOODITask, uint64_t, JY5411CoreOOPropertyType::READ_ONLY > | AvailableSamples
Number of samples per channel that can be read in the buffer.
JY5411CoreOOProperty< JY5411CoreOODITask, uint64_t, JY5411CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
DITrigger * Trigger
DI Trigger Configuration.
DISignalExport * SignalExport
Export DI Signal.
JY5411CoreOODevice * Device
Device.
DIRecord * Record
ai Data streaming Configuration

Constructor & Destructor Documentation

◆ JY5411CoreOODITask() [1/2]

JY5411CoreOO::JY5411CoreOODITask::JY5411CoreOODITask ( int slotNum )

◆ JY5411CoreOODITask() [2/2]

JY5411CoreOO::JY5411CoreOODITask::JY5411CoreOODITask ( std::string boardName )

◆ ~JY5411CoreOODITask()

JY5411CoreOO::JY5411CoreOODITask::~JY5411CoreOODITask ( )

Member Function Documentation

◆ AddChannel() [1/2]

void JY5411CoreOO::JY5411CoreOODITask::AddChannel ( int lineNum )

Add one line.

Parameters
lineNum line number

◆ AddChannel() [2/2]

void JY5411CoreOO::JY5411CoreOODITask::AddChannel ( std::vector< int > linesNum )

Add a group of line.

Parameters
linesNum line number

Add a group of line

Parameters
linesNum line number

◆ GetRecordPreviewData()

void JY5411CoreOO::JY5411CoreOODITask::GetRecordPreviewData | ( | uint64_t & | filelen,
 |  | bool & | recordDone )

预览uint类型样点值

Preview multi-channel data when streaming is in progress. Each column represents one channel.

Parameters
buf | 样点值readValue
samplesPerChannel | 采样点数Number of samples per line to be read
timeOut 超时时间
Parameters
timeOut timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadData()

void JY5411CoreOO::JY5411CoreOODITask::ReadData | ( | unsigned int * | buf,
 |  | unsigned int | samplesToAcquire,
 |  | int | timeOut = 10000 )

Read the uint data from one line or multi-lines

Parameters
buf readValue
Parameters
samplesToAcquire Number of samples per line to be read
Parameters
timeOut timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadSinglePoint() [1/2]

void JY5411CoreOO::JY5411CoreOODITask::ReadSinglePoint | ( | bool & | readValues,
 |  | int | line )

Specify the line reads the latest line.Available when Type is DIMode.Single.

Parameters
readValue | User buffer array
line | Specify the line to read

◆ ReadSinglePoint() [2/2]

void JY5411CoreOO::JY5411CoreOODITask::ReadSinglePoint ( bool * readValues )

Read the sample point value from the register.Available when Type is DIMode.Single.

Parameters
readValues Values read. Buffer size >= number of channels.

◆ RemoveChannel()

void JY5411CoreOO::JY5411CoreOODITask::RemoveChannel ( int lineNum )

Delete the specified line number.

Parameters
lineNum line number

◆ SendSoftwareTrigger()

void JY5411CoreOO::JY5411CoreOODITask::SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5411CoreOO::JY5411CoreOODITask::Start ( )

Start DI task .

◆ Stop()

void JY5411CoreOO::JY5411CoreOODITask::Stop ( )

Stop DI task .

Member Data Documentation

◆ AvailableSamples

JY5411CoreOOProperty<JY5411CoreOODITask, uint64_t, JY5411CoreOOPropertyType::READ_ONLY> JY5411CoreOO::JY5411CoreOODITask::AvailableSamples

Number of samples per channel that can be read in the buffer.

◆ BufLenInSamples

JY5411CoreOOProperty<JY5411CoreOODITask, int, JY5411CoreOOPropertyType::READ_ONLY> JY5411CoreOO::JY5411CoreOODITask::BufLenInSamples

Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.

◆ Channels

std::list<DIChannel*> JY5411CoreOO::JY5411CoreOODITask::Channels

List of DI channels.

◆ Device

JY5411CoreOODevice* JY5411CoreOO::JY5411CoreOODITask::Device

Device.

◆ Mode

DIMode JY5411CoreOO::JY5411CoreOODITask::Mode

DI acquisition mode，support Single/ Finite/Continuous.

◆ Record

DIRecord* JY5411CoreOO::JY5411CoreOODITask::Record

ai Data streaming Configuration

◆ SampleClock

DISampleClock* JY5411CoreOO::JY5411CoreOODITask::SampleClock

DI Sample Clock Configuration.

◆ SampleRate

JY5411CoreOOProperty<JY5411CoreOODITask, double, JY5411CoreOOPropertyType::READ_WRITE> JY5411CoreOO::JY5411CoreOODITask::SampleRate

采样率

Sample rate per channel, maximum sampling rate is 50MHz

◆ SamplesToAcquire

int JY5411CoreOO::JY5411CoreOODITask::SamplesToAcquire

Number of samples to be read per channel.

Only valid when Mode is DIMode.Finite.

◆ SignalExport

DISignalExport* JY5411CoreOO::JY5411CoreOODITask::SignalExport

Export DI Signal.

◆ TransferedSamples

JY5411CoreOOProperty<JY5411CoreOODITask, uint64_t, JY5411CoreOOPropertyType::READ_ONLY> JY5411CoreOO::JY5411CoreOODITask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT DIMode::Single.

◆ Trigger

DITrigger* JY5411CoreOO::JY5411CoreOODITask::Trigger

DI Trigger Configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5411/JY5411CoreOODITask.h


5411 C++ Programming Manual: JY5411CoreOO::DIChannel Class Reference

  • DIChannel
Public Attributes | List of all members
JY5411CoreOO::DIChannel Class Reference

DI Channel parameter class . More...

#include <JY5411CoreOODITask.h>

Public Attributes

int LineNum
Line number.

Detailed Description

DI Channel parameter class .

Member Data Documentation

◆ LineNum

int JY5411CoreOO::DIChannel::LineNum

Line number.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5411/JY5411CoreOODITask.h


5411 C++ Programming Manual: JY5411CoreOO::DIRecord Class Reference

  • DIRecord
Public Attributes | List of all members
JY5411CoreOO::DIRecord Class Reference

#include <JY5411CoreOODITask.h>

Public Attributes

std::string | FilePath =""
User specified file path.
JY5411CoreOO::FileFormat File_Format
Streaming file format.
RecordMode Mode
stream mode .
double | Length
User specified stream length in second.

Member Data Documentation

◆ File_Format

JY5411CoreOO::FileFormat JY5411CoreOO::DIRecord::File_Format

Streaming file format.

enum BIN.

◆ FilePath

std::string JY5411CoreOO::DIRecord::FilePath =""

User specified file path.

◆ Length

double JY5411CoreOO::DIRecord::Length

User specified stream length in second.

Only when Mode is RecordMode.Finite.

◆ Mode

RecordMode JY5411CoreOO::DIRecord::Mode

stream mode .

enum Finite/Infinite.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5411/JY5411CoreOODITask.h


5411 C++ Programming Manual: JY5411CoreOO::DISampleClock Class Reference

  • DISampleClock
Public Attributes | List of all members
JY5411CoreOO::DISampleClock Class Reference

Sample clock configuration class. More...

#include <JY5411CoreOODITask.h>

Public Attributes

DISampleClockSource Source
Clock Source.
DIExternalSampleClock * External
External Sample Clock, Valid when Source is DISampleClockSource.External.
ClockEdge Edge
Clock Edge.

Detailed Description

Sample clock configuration class.

Member Data Documentation

◆ Edge

ClockEdge JY5411CoreOO::DISampleClock::Edge

Clock Edge.

◆ External

DIExternalSampleClock* JY5411CoreOO::DISampleClock::External

External Sample Clock, Valid when Source is DISampleClockSource.External.

◆ Source

DISampleClockSource JY5411CoreOO::DISampleClock::Source

Clock Source.

enum Internal/External

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5411/JY5411CoreOODITask.h


5411 C++ Programming Manual: JY5411CoreOO::DIExternalSampleClock Class Reference

  • DIExternalSampleClock
Public Attributes | List of all members
JY5411CoreOO::DIExternalSampleClock Class Reference

External Sample Clock Configuration Class. More...

#include <JY5411CoreOODITask.h>

Public Attributes

ClockTerminal Terminal
External Sample Clock Input Terminal.
double ExpectedRate
Expected External Sample Clock Rate.

Detailed Description

External Sample Clock Configuration Class.

Member Data Documentation

◆ ExpectedRate

double JY5411CoreOO::DIExternalSampleClock::ExpectedRate

Expected External Sample Clock Rate.

◆ Terminal

ClockTerminal JY5411CoreOO::DIExternalSampleClock::Terminal

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5411/JY5411CoreOODITask.h


5411 C++ Programming Manual: JY5411CoreOO::DISignalExport Class Reference

  • DISignalExport
Public Member Functions | List of all members
JY5411CoreOO::DISignalExport Class Reference

DI Signal Export Class. More...

#include <JY5411CoreOODITask.h>

Public Member Functions

void | Add (DISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (DISignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

DI Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY5411CoreOO::DISignalExport::Add | ( | DISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | CI Signal Source
destination | Export Desination

◆ Add() [2/2]

void JY5411CoreOO::DISignalExport::Add | ( | DISignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | CI Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JY5411CoreOO::DISignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5411CoreOO::DISignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5411/JY5411CoreOODITask.h


5411 C++ Programming Manual: JY5411CoreOO::DITrigger Class Reference

  • DITrigger
Public Attributes | List of all members
JY5411CoreOO::DITrigger Class Reference

Constructor to create an DITrigger task object. More...

#include <JY5411CoreOODITask.h>

Public Attributes

DITriggerType Type
DI trigger type.
DITriggerMode Mode
DI trigger mode.
DIDigitalTrigger * Digital
DI Digital Trigger.Valid when Type is DITriggerType.Digital.
uint32_t | PreTriggerSamples
Pretrigger Samples, must be less than or equal to JY5411DITask.SamplesToAcquire.
int | Delay =0
int | ReTriggerCount = 0

Detailed Description

Constructor to create an DITrigger task object.

Used to build DI Trigger

Member Data Documentation

◆ Delay

int JY5411CoreOO::DITrigger::Delay =0

◆ Digital

DIDigitalTrigger* JY5411CoreOO::DITrigger::Digital

DI Digital Trigger.Valid when Type is DITriggerType.Digital.

◆ Mode

DITriggerMode JY5411CoreOO::DITrigger::Mode

DI trigger mode.

enum Start/Reference.

◆ PreTriggerSamples

uint32_t JY5411CoreOO::DITrigger::PreTriggerSamples

Pretrigger Samples, must be less than or equal to JY5411DITask.SamplesToAcquire.

Valid when Mode is DITriggerMode.Reference. Pretrigger samples, must be greater than 1. Valid when Type is DITriggerType.Digital.

◆ ReTriggerCount

int JY5411CoreOO::DITrigger::ReTriggerCount = 0

◆ Type

DITriggerType JY5411CoreOO::DITrigger::Type

DI trigger type.

enum Digital/Immediate/Soft.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5411/JY5411CoreOODITask.h


5411 C++ Programming Manual: JY5411CoreOO::DIDigitalTrigger Class Reference

  • DIDigitalTrigger
Public Attributes | List of all members
JY5411CoreOO::DIDigitalTrigger Class Reference

DI Digital trigger . More...

#include <JY5411CoreOODITask.h>

Public Attributes

DIDigitalTriggerSource Source
DI Digital Trigger source.
DIDigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Detailed Description

DI Digital trigger .

Member Data Documentation

◆ Edge

DIDigitalTriggerEdge JY5411CoreOO::DIDigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

DIDigitalTriggerSource JY5411CoreOO::DIDigitalTrigger::Source

DI Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5411/JY5411CoreOODITask.h


5411 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5411/JY5411CoreOODOTask.h File Reference

  • File List
  • File Members
  • COO
  • 5411
Classes | Namespaces | Enumerations
JY5411CoreOODOTask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JY5411CoreOOCommon.h"
#include "JY5411CoreOODevice.h"

Classes

class | JY5411CoreOO::JY5411CoreOODOTask
class | JY5411CoreOO::DOChannel
DO Channel parameter class . More...
class | JY5411CoreOO::DOSampleClock
Sample clock configuration class. More...
class | JY5411CoreOO::DOExternalSampleClock
External Sample Clock Configuration Class. More...
class | JY5411CoreOO::DODigitalTrigger
DO Digital trigger. More...
class | JY5411CoreOO::DOTrigger
Constructor to create an DOTrigger task object. More...
class | JY5411CoreOO::DOSignalExport
DO Signal Export Class. More...

Namespaces

namespace JY5411CoreOO

Enumerations

enum class | JY5411CoreOO::DOSampleClockSource { JY5411CoreOO::Internal , JY5411CoreOO::External }
DO Sample Clock Source. More...
enum class | JY5411CoreOO::DOClockEdge { JY5411CoreOO::Rising = 1 , JY5411CoreOO::Falling = 2 }
ClockEdge enumeration type. More...
enum class | JY5411CoreOO::DOMode { JY5411CoreOO::Single = 0 , JY5411CoreOO::Finite = 1 , JY5411CoreOO::ContinuousWrapping = 2 , JY5411CoreOO::ContinuousNoWrapping = 3 }
DOMode. More...
enum class | JY5411CoreOO::DODigitalTriggerEdge { JY5411CoreOO::Rising , JY5411CoreOO::Falling }
DO Digital Trigger Edge. More...
enum class JY5411CoreOO::DODigitalTriggerSource {
JY5411CoreOO::PFI0 = 0x0 , JY5411CoreOO::PFI1 = 0x1 , JY5411CoreOO::PFI2 = 0x2 , JY5411CoreOO::PFI3 = 0x3 ,
JY5411CoreOO::PFI4 = 0x04 , JY5411CoreOO::PFI5 = 0x05 , JY5411CoreOO::PFI6 = 0x6 , JY5411CoreOO::PFI7 = 0x7 ,
JY5411CoreOO::PXI_Trig0 = 0x8 , JY5411CoreOO::PXI_Trig1 = 0x9 , JY5411CoreOO::PXI_Trig2 = 10 , JY5411CoreOO::PXI_Trig3 = 11 ,
JY5411CoreOO::PXI_Trig4 = 12 , JY5411CoreOO::PXI_Trig5 = 13 , JY5411CoreOO::PXI_Trig6 = 14 , JY5411CoreOO::PXI_Trig7 = 15 ,
JY5411CoreOO::DI_StartTrig =89 , JY5411CoreOO::DI_ReferenceTrig = 91
}
DO Digital trigger source. More...
enum class | JY5411CoreOO::DOTriggerType { JY5411CoreOO::Immediate = 0 , JY5411CoreOO::Digital = 1 , JY5411CoreOO::Soft = 2 }
TriggerType Digital/Immediate/Soft. More...
enum class JY5411CoreOO::DOSignalExportSource {
JY5411CoreOO::DO_0 = 0 , JY5411CoreOO::DO_1 = 1 , JY5411CoreOO::DO_2 = 2 , JY5411CoreOO::DO_3 = 3 ,
JY5411CoreOO::DO_4 = 4 , JY5411CoreOO::DO_5 = 5 , JY5411CoreOO::DO_6 = 6 , JY5411CoreOO::DO_7 = 7 ,
JY5411CoreOO::DO_8 = 8 , JY5411CoreOO::DO_9 = 9 , JY5411CoreOO::DO_10 = 10 , JY5411CoreOO::DO_11 = 11 ,
JY5411CoreOO::DO_12 = 12 , JY5411CoreOO::DO_13 = 13 , JY5411CoreOO::DO_14 = 14 , JY5411CoreOO::DO_15 = 15 ,
JY5411CoreOO::DO_16 = 16 , JY5411CoreOO::DO_17 = 17 , JY5411CoreOO::DO_18 = 18 , JY5411CoreOO::DO_19 = 19 ,
JY5411CoreOO::DO_20 = 20 , JY5411CoreOO::DO_21 = 21 , JY5411CoreOO::DO_22 = 22 , JY5411CoreOO::DO_23 = 23 ,
JY5411CoreOO::DO_24 = 24 , JY5411CoreOO::DO_25 = 25 , JY5411CoreOO::DO_26 = 26 , JY5411CoreOO::DO_27 = 27 ,
JY5411CoreOO::DO_28 = 28 , JY5411CoreOO::DO_29 = 29 , JY5411CoreOO::DO_30 = 30 , JY5411CoreOO::DO_31 = 31 ,
JY5411CoreOO::SampleClock = 83 , JY5411CoreOO::StartTrig = 95
}
SourceSignal. More...


5411 C++ Programming Manual: JY5411CoreOO::JY5411CoreOODOTask Class Reference

  • JY5411CoreOODOTask
Public Member Functions | Public Attributes | List of all members
JY5411CoreOO::JY5411CoreOODOTask Class Reference

#include <JY5411CoreOODOTask.h>

Public Member Functions

JY5411CoreOODOTask (int slotNum)
JY5411CoreOODOTask (std::string boardName)
~JY5411CoreOODOTask ()
void | AddChannel (int lineNum)
Add one line.
void | AddChannel (std::vector< int > linesNum)
Add mulitiple line.
void | RemoveChannel (int lineNum)
delete the specified line number
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Start ()
Start DO task .
void | Stop ()
Stop DO task .
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.
void | WriteSinglePoint (bool writeValues, int line)
write the latest point of Specify port
void | WriteSinglePoint (std::vector< bool > &writeValues)
Read one sample for all ports in register .
void | WriteData (bool *dataBuffer, unsigned int samplesToUpdate, int timeOut=10000)
Write the bool data from one line or multi-lines.
void | WriteData (unsigned int *dataBuffer, unsigned int samplesToUpdate, int timeOut=10000)
Write the unsigned int data from one line or multi-lines.

Public Attributes

std::list< DOChannel * > | Channels
List of DO channels.
DOMode Mode
DO acquisition mode，support Single/ Finite/Continuous.
JY5411CoreOOProperty< JY5411CoreOODOTask, double, JY5411CoreOOPropertyType::READ_WRITE > | UpdateRate
Update rate per channel, maximum is 50MHz.
int | SamplesToUpdate
The number of samples output per channel when finite point output.
DOSampleClock * SampleClock
DO Sample Clock Configuration.
JY5411CoreOOProperty< JY5411CoreOODOTask, int, JY5411CoreOOPropertyType::READ_ONLY > | BufLenInSamples
Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.
JY5411CoreOOProperty< JY5411CoreOODOTask, uint64_t, JY5411CoreOOPropertyType::READ_ONLY > | AvaliableLenInSamples
Number of output samples per channel avaliable to write in DO buffuer.
JY5411CoreOOProperty< JY5411CoreOODOTask, uint64_t, JY5411CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
DOTrigger * Trigger
DO Trigger Configuration.
DOSignalExport * SignalExport
Export DO Signal.
JY5411CoreOODevice * Device
Device.

Constructor & Destructor Documentation

◆ JY5411CoreOODOTask() [1/2]

JY5411CoreOO::JY5411CoreOODOTask::JY5411CoreOODOTask ( int slotNum )

◆ JY5411CoreOODOTask() [2/2]

JY5411CoreOO::JY5411CoreOODOTask::JY5411CoreOODOTask ( std::string boardName )

◆ ~JY5411CoreOODOTask()

JY5411CoreOO::JY5411CoreOODOTask::~JY5411CoreOODOTask ( )

Member Function Documentation

◆ AddChannel() [1/2]

void JY5411CoreOO::JY5411CoreOODOTask::AddChannel ( int lineNum )

Add one line.

Parameters
lineNum line number

◆ AddChannel() [2/2]

void JY5411CoreOO::JY5411CoreOODOTask::AddChannel ( std::vector< int > linesNum )

Add mulitiple line.

Parameters
linesNum line number

◆ RemoveChannel()

void JY5411CoreOO::JY5411CoreOODOTask::RemoveChannel ( int lineNum )

delete the specified line number

Parameters
lineNum line number

◆ SendSoftwareTrigger()

void JY5411CoreOO::JY5411CoreOODOTask::SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5411CoreOO::JY5411CoreOODOTask::Start ( )

Start DO task .

◆ Stop()

void JY5411CoreOO::JY5411CoreOODOTask::Stop ( )

Stop DO task .

◆ WaitUntilDone()

bool JY5411CoreOO::JY5411CoreOODOTask::WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Available when Mode is DOMode.Finite

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteData() [1/2]

void JY5411CoreOO::JY5411CoreOODOTask::WriteData | ( | bool * | dataBuffer,
 |  | unsigned int | samplesToUpdate,
 |  | int | timeOut = 10000 )

Write the bool data from one line or multi-lines.

Parameters
dataBuffer | Data buffer
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [2/2]

void JY5411CoreOO::JY5411CoreOODOTask::WriteData | ( | unsigned int * | dataBuffer,
 |  | unsigned int | samplesToUpdate,
 |  | int | timeOut = 10000 )

Write the unsigned int data from one line or multi-lines.

Parameters
dataBuffer | Data buffer.Each unsigned integer variable contains the data of one or more lines
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteSinglePoint() [1/2]

void JY5411CoreOO::JY5411CoreOODOTask::WriteSinglePoint | ( | bool | writeValues,
 |  | int | line )

write the latest point of Specify port

Parameters
writeValues | User buffer array
line | Specify the line to write

◆ WriteSinglePoint() [2/2]

void JY5411CoreOO::JY5411CoreOODOTask::WriteSinglePoint ( std::vector< bool > & writeValues )

Read one sample for all ports in register .

Available when Mode is DIMode.Single

Parameters
readValues Values read. Buffer size >= number of ports * 8.

Member Data Documentation

◆ AvaliableLenInSamples

JY5411CoreOOProperty<JY5411CoreOODOTask, uint64_t, JY5411CoreOOPropertyType::READ_ONLY> JY5411CoreOO::JY5411CoreOODOTask::AvaliableLenInSamples

Number of output samples per channel avaliable to write in DO buffuer.

◆ BufLenInSamples

JY5411CoreOOProperty<JY5411CoreOODOTask, int, JY5411CoreOOPropertyType::READ_ONLY> JY5411CoreOO::JY5411CoreOODOTask::BufLenInSamples

Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.

◆ Channels

std::list<DOChannel*> JY5411CoreOO::JY5411CoreOODOTask::Channels

List of DO channels.

◆ Device

JY5411CoreOODevice* JY5411CoreOO::JY5411CoreOODOTask::Device

Device.

◆ Mode

DOMode JY5411CoreOO::JY5411CoreOODOTask::Mode

DO acquisition mode，support Single/ Finite/Continuous.

◆ SampleClock

DOSampleClock* JY5411CoreOO::JY5411CoreOODOTask::SampleClock

DO Sample Clock Configuration.

◆ SamplesToUpdate

int JY5411CoreOO::JY5411CoreOODOTask::SamplesToUpdate

The number of samples output per channel when finite point output.

◆ SignalExport

DOSignalExport* JY5411CoreOO::JY5411CoreOODOTask::SignalExport

Export DO Signal.

◆ TransferedSamples

JY5411CoreOOProperty<JY5411CoreOODOTask, uint64_t, JY5411CoreOOPropertyType::READ_ONLY> JY5411CoreOO::JY5411CoreOODOTask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT DIMode::Single.

◆ Trigger

DOTrigger* JY5411CoreOO::JY5411CoreOODOTask::Trigger

DO Trigger Configuration.

◆ UpdateRate

JY5411CoreOOProperty<JY5411CoreOODOTask, double, JY5411CoreOOPropertyType::READ_WRITE> JY5411CoreOO::JY5411CoreOODOTask::UpdateRate

Update rate per channel, maximum is 50MHz.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5411/JY5411CoreOODOTask.h


5411 C++ Programming Manual: JY5411CoreOO::DOChannel Class Reference

  • DOChannel
Public Attributes | List of all members
JY5411CoreOO::DOChannel Class Reference

DO Channel parameter class . More...

#include <JY5411CoreOODOTask.h>

Public Attributes

int LineNum
Line number.

Detailed Description

DO Channel parameter class .

Member Data Documentation

◆ LineNum

int JY5411CoreOO::DOChannel::LineNum

Line number.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5411/JY5411CoreOODOTask.h


5411 C++ Programming Manual: JY5411CoreOO::DOSampleClock Class Reference

  • DOSampleClock
Public Attributes | List of all members
JY5411CoreOO::DOSampleClock Class Reference

Sample clock configuration class. More...

#include <JY5411CoreOODOTask.h>

Public Attributes

DOSampleClockSource Source
Clock Source.
DOExternalSampleClock * External
External Sample Clock.Valid when Source is DOSampleClockSource.External.
DOClockEdge Edge

Detailed Description

Sample clock configuration class.

Member Data Documentation

◆ Edge

DOClockEdge JY5411CoreOO::DOSampleClock::Edge

◆ External

DOExternalSampleClock* JY5411CoreOO::DOSampleClock::External

External Sample Clock.Valid when Source is DOSampleClockSource.External.

◆ Source

DOSampleClockSource JY5411CoreOO::DOSampleClock::Source

Clock Source.

enum Internal/External

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5411/JY5411CoreOODOTask.h


5411 C++ Programming Manual: JY5411CoreOO::DOExternalSampleClock Class Reference

  • DOExternalSampleClock
Public Attributes | List of all members
JY5411CoreOO::DOExternalSampleClock Class Reference

External Sample Clock Configuration Class. More...

#include <JY5411CoreOODOTask.h>

Public Attributes

ClockTerminal Terminal
External Sample Clock Input Terminal.
double ExpectedRate
Expected External Sample Clock Rate.

Detailed Description

External Sample Clock Configuration Class.

Member Data Documentation

◆ ExpectedRate

double JY5411CoreOO::DOExternalSampleClock::ExpectedRate

Expected External Sample Clock Rate.

◆ Terminal

ClockTerminal JY5411CoreOO::DOExternalSampleClock::Terminal

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5411/JY5411CoreOODOTask.h


5411 C++ Programming Manual: JY5411CoreOO::DODigitalTrigger Class Reference

  • DODigitalTrigger
Public Member Functions | Public Attributes | List of all members
JY5411CoreOO::DODigitalTrigger Class Reference

DO Digital trigger. More...

#include <JY5411CoreOODOTask.h>

Public Member Functions

DODigitalTrigger ()
DODigitalTrigger (DODigitalTriggerEdge edge)

Public Attributes

DODigitalTriggerSource Source
DO Digital Trigger source.
DODigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Detailed Description

DO Digital trigger.

Constructor & Destructor Documentation

◆ DODigitalTrigger() [1/2]

JY5411CoreOO::DODigitalTrigger::DODigitalTrigger ( )

◆ DODigitalTrigger() [2/2]

JY5411CoreOO::DODigitalTrigger::DODigitalTrigger ( DODigitalTriggerEdge edge )

Member Data Documentation

◆ Edge

DODigitalTriggerEdge JY5411CoreOO::DODigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

DODigitalTriggerSource JY5411CoreOO::DODigitalTrigger::Source

DO Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5411/JY5411CoreOODOTask.h


5411 C++ Programming Manual: JY5411CoreOO::DOTrigger Class Reference

  • DOTrigger
Public Attributes | List of all members
JY5411CoreOO::DOTrigger Class Reference

Constructor to create an DOTrigger task object. More...

#include <JY5411CoreOODOTask.h>

Public Attributes

DOTriggerType Type
DO trigger type.
DODigitalTrigger * Digital
DO Digital Trigger.Valid when Type is DOTriggerType.Digital.
int Delay = 0
DODigitalTrigger delay，Unit:Sample.

Detailed Description

Constructor to create an DOTrigger task object.

Used to build DO Trigger

Member Data Documentation

◆ Delay

int JY5411CoreOO::DOTrigger::Delay = 0

DODigitalTrigger delay，Unit:Sample.

◆ Digital

DODigitalTrigger* JY5411CoreOO::DOTrigger::Digital

DO Digital Trigger.Valid when Type is DOTriggerType.Digital.

◆ Type

DOTriggerType JY5411CoreOO::DOTrigger::Type

DO trigger type.

enum Digital/Immediate/Soft.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5411/JY5411CoreOODOTask.h


5411 C++ Programming Manual: JY5411CoreOO::DOSignalExport Class Reference

  • DOSignalExport
Public Member Functions | List of all members
JY5411CoreOO::DOSignalExport Class Reference

DO Signal Export Class. More...

#include <JY5411CoreOODOTask.h>

Public Member Functions

void | Add (DOSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (DOSignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

DO Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY5411CoreOO::DOSignalExport::Add | ( | DOSignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | DO Signal Source
destination | Export Desination

◆ Add() [2/2]

void JY5411CoreOO::DOSignalExport::Add | ( | DOSignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | DO Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JY5411CoreOO::DOSignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5411CoreOO::DOSignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5411/JY5411CoreOODOTask.h


5411 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5411/JY5411CoreOOLog.h File Reference

  • File List
  • File Members
  • COO
  • 5411
Classes | Namespaces | Enumerations
JY5411CoreOOLog.h File Reference
#include <queue>
#include <string>
#include <thread>
#include "JY5411CoreOOCommon.h"

Classes

class JY5411CoreOO::JY5411CoreOOLog

Namespaces

namespace JY5411CoreOO

Enumerations

enum class JY5411CoreOO::JY5411CoreOOLogLevel {
JY5411CoreOO::DEBUG_LOG_LEVEL , JY5411CoreOO::INFO_LOG_LEVEL , JY5411CoreOO::WARN_LOG_LEVEL , JY5411CoreOO::ERROR_LOG_LEVEL ,
JY5411CoreOO::FATAL_LOG_LEVEL
}


5411 C++ Programming Manual: JY5411CoreOO::JY5411CoreOOLog Class Reference

  • JY5411CoreOOLog
Static Public Member Functions | Static Public Attributes | List of all members
JY5411CoreOO::JY5411CoreOOLog Class Reference

#include <JY5411CoreOOLog.h>

Static Public Member Functions

static void | Print (const char *format,...)
static void | Print (JY5411CoreOOLogLevel logLevel, const char *format,...)
static void | Flush ()

Static Public Attributes

static JY5411CoreOOLogLevel | LogLevel
static JY5411CoreOOProperty< JY5411CoreOOLog, bool, JY5411CoreOOPropertyType::READ_WRITE > | EnableLog

Member Function Documentation

◆ Flush()

static void JY5411CoreOO::JY5411CoreOOLog::Flush ( )
static

◆ Print() [1/2]

static void JY5411CoreOO::JY5411CoreOOLog::Print | ( | const char * | format,
 |  |  | ... )
 static

◆ Print() [2/2]

static void JY5411CoreOO::JY5411CoreOOLog::Print | ( | JY5411CoreOOLogLevel | logLevel,
 |  | const char * | format,
 |  |  | ... )
 static

Member Data Documentation

◆ EnableLog

JY5411CoreOOProperty<JY5411CoreOOLog, bool, JY5411CoreOOPropertyType::READ_WRITE> JY5411CoreOO::JY5411CoreOOLog::EnableLog
static

◆ LogLevel

JY5411CoreOOLogLevel JY5411CoreOO::JY5411CoreOOLog::LogLevel
static
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5411/JY5411CoreOOLog.h


5411 C++ Programming Manual: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
▼N JY5411CoreOO |
C DIChannel | DI Channel parameter class
C DIDigitalTrigger | DI Digital trigger
C DIExternalSampleClock | External Sample Clock Configuration Class
C DIRecord |
C DISampleClock | Sample clock configuration class
C DISignalExport | DI Signal Export Class
C DITrigger | Constructor to create an DITrigger task object
C DOChannel | DO Channel parameter class
C DODigitalTrigger | DO Digital trigger
C DOExternalSampleClock | External Sample Clock Configuration Class
C DOSampleClock | Sample clock configuration class
C DOSignalExport | DO Signal Export Class
C DOTrigger | Constructor to create an DOTrigger task object
C ExternalReferenceClock |
C JY5411CoreOODevice |
C JY5411CoreOODITask |
C JY5411CoreOODOTask |
C JY5411CoreOOLog |
C JY5411CoreOOProperty | 属性模板类
C JY5411CoreOOReferenceClock |
C JYDriverException |
C PauseTrigger | Pause trigger configuration class
C PFIFilter |
C PFISetting |


5411 C++ Programming Manual: Member List

  • DIChannel
JY5411CoreOO::DIChannel Member List

This is the complete list of members for JY5411CoreOO::DIChannel, including all inherited members.

LineNum JY5411CoreOO::DIChannel


5411 C++ Programming Manual: Member List

  • DIDigitalTrigger
JY5411CoreOO::DIDigitalTrigger Member List

This is the complete list of members for JY5411CoreOO::DIDigitalTrigger, including all inherited members.

Edge | JY5411CoreOO::DIDigitalTrigger
Source | JY5411CoreOO::DIDigitalTrigger


5411 C++ Programming Manual: Member List

  • DIExternalSampleClock
JY5411CoreOO::DIExternalSampleClock Member List

This is the complete list of members for JY5411CoreOO::DIExternalSampleClock, including all inherited members.

ExpectedRate | JY5411CoreOO::DIExternalSampleClock
Terminal | JY5411CoreOO::DIExternalSampleClock


5411 C++ Programming Manual: Member List

  • DIRecord
JY5411CoreOO::DIRecord Member List

This is the complete list of members for JY5411CoreOO::DIRecord, including all inherited members.

File_Format | JY5411CoreOO::DIRecord
FilePath | JY5411CoreOO::DIRecord
Length | JY5411CoreOO::DIRecord
Mode | JY5411CoreOO::DIRecord


5411 C++ Programming Manual: Member List

  • DISampleClock
JY5411CoreOO::DISampleClock Member List

This is the complete list of members for JY5411CoreOO::DISampleClock, including all inherited members.

Edge | JY5411CoreOO::DISampleClock
External | JY5411CoreOO::DISampleClock
Source | JY5411CoreOO::DISampleClock


5411 C++ Programming Manual: Member List

  • DISignalExport
JY5411CoreOO::DISignalExport Member List

This is the complete list of members for JY5411CoreOO::DISignalExport, including all inherited members.

Add(DISignalExportSource source, SignalExportDestination destination) | JY5411CoreOO::DISignalExport
Add(DISignalExportSource source, std::list< SignalExportDestination > destinations) | JY5411CoreOO::DISignalExport
Clear(SignalExportDestination destination) | JY5411CoreOO::DISignalExport
ClearAll() | JY5411CoreOO::DISignalExport


5411 C++ Programming Manual: Member List

  • DITrigger
JY5411CoreOO::DITrigger Member List

This is the complete list of members for JY5411CoreOO::DITrigger, including all inherited members.

Delay | JY5411CoreOO::DITrigger
Digital | JY5411CoreOO::DITrigger
Mode | JY5411CoreOO::DITrigger
PreTriggerSamples | JY5411CoreOO::DITrigger
ReTriggerCount | JY5411CoreOO::DITrigger
Type | JY5411CoreOO::DITrigger


5411 C++ Programming Manual: Member List

  • DOChannel
JY5411CoreOO::DOChannel Member List

This is the complete list of members for JY5411CoreOO::DOChannel, including all inherited members.

LineNum JY5411CoreOO::DOChannel


5411 C++ Programming Manual: Member List

  • DODigitalTrigger
JY5411CoreOO::DODigitalTrigger Member List

This is the complete list of members for JY5411CoreOO::DODigitalTrigger, including all inherited members.

DODigitalTrigger() | JY5411CoreOO::DODigitalTrigger
DODigitalTrigger(DODigitalTriggerEdge edge) | JY5411CoreOO::DODigitalTrigger
Edge | JY5411CoreOO::DODigitalTrigger
Source | JY5411CoreOO::DODigitalTrigger


5411 C++ Programming Manual: Member List

  • DOExternalSampleClock
JY5411CoreOO::DOExternalSampleClock Member List

This is the complete list of members for JY5411CoreOO::DOExternalSampleClock, including all inherited members.

ExpectedRate | JY5411CoreOO::DOExternalSampleClock
Terminal | JY5411CoreOO::DOExternalSampleClock


5411 C++ Programming Manual: Member List

  • DOSampleClock
JY5411CoreOO::DOSampleClock Member List

This is the complete list of members for JY5411CoreOO::DOSampleClock, including all inherited members.

Edge | JY5411CoreOO::DOSampleClock
External | JY5411CoreOO::DOSampleClock
Source | JY5411CoreOO::DOSampleClock


5411 C++ Programming Manual: Member List

  • DOSignalExport
JY5411CoreOO::DOSignalExport Member List

This is the complete list of members for JY5411CoreOO::DOSignalExport, including all inherited members.

Add(DOSignalExportSource source, SignalExportDestination destination) | JY5411CoreOO::DOSignalExport
Add(DOSignalExportSource source, std::list< SignalExportDestination > destinations) | JY5411CoreOO::DOSignalExport
Clear(SignalExportDestination destination) | JY5411CoreOO::DOSignalExport
ClearAll() | JY5411CoreOO::DOSignalExport


5411 C++ Programming Manual: Member List

  • DOTrigger
JY5411CoreOO::DOTrigger Member List

This is the complete list of members for JY5411CoreOO::DOTrigger, including all inherited members.

Delay | JY5411CoreOO::DOTrigger
Digital | JY5411CoreOO::DOTrigger
Type | JY5411CoreOO::DOTrigger


5411 C++ Programming Manual: Member List

  • ExternalReferenceClock
JY5411CoreOO::ExternalReferenceClock Member List

This is the complete list of members for JY5411CoreOO::ExternalReferenceClock, including all inherited members.

Frequency | JY5411CoreOO::ExternalReferenceClock
Terminal | JY5411CoreOO::ExternalReferenceClock


5411 C++ Programming Manual: Member List

  • JY5411CoreOODITask
JY5411CoreOO::JY5411CoreOODITask Member List

This is the complete list of members for JY5411CoreOO::JY5411CoreOODITask, including all inherited members.

AddChannel(int lineNum) | JY5411CoreOO::JY5411CoreOODITask
AddChannel(std::vector< int > linesNum) | JY5411CoreOO::JY5411CoreOODITask
AvailableSamples | JY5411CoreOO::JY5411CoreOODITask
BufLenInSamples | JY5411CoreOO::JY5411CoreOODITask
Channels | JY5411CoreOO::JY5411CoreOODITask
Device | JY5411CoreOO::JY5411CoreOODITask
GetRecordPreviewData(uint64_t &filelen, bool &recordDone) | JY5411CoreOO::JY5411CoreOODITask
JY5411CoreOODITask(int slotNum) | JY5411CoreOO::JY5411CoreOODITask
JY5411CoreOODITask(std::string boardName) | JY5411CoreOO::JY5411CoreOODITask
Mode | JY5411CoreOO::JY5411CoreOODITask
ReadData(unsigned int *buf, unsigned int samplesToAcquire, int timeOut=10000) | JY5411CoreOO::JY5411CoreOODITask
ReadSinglePoint(bool &readValues, int line) | JY5411CoreOO::JY5411CoreOODITask
ReadSinglePoint(bool *readValues) | JY5411CoreOO::JY5411CoreOODITask
Record | JY5411CoreOO::JY5411CoreOODITask
RemoveChannel(int lineNum) | JY5411CoreOO::JY5411CoreOODITask
SampleClock | JY5411CoreOO::JY5411CoreOODITask
SampleRate | JY5411CoreOO::JY5411CoreOODITask
SamplesToAcquire | JY5411CoreOO::JY5411CoreOODITask
SendSoftwareTrigger() | JY5411CoreOO::JY5411CoreOODITask
SignalExport | JY5411CoreOO::JY5411CoreOODITask
Start() | JY5411CoreOO::JY5411CoreOODITask
Stop() | JY5411CoreOO::JY5411CoreOODITask
TransferedSamples | JY5411CoreOO::JY5411CoreOODITask
Trigger | JY5411CoreOO::JY5411CoreOODITask
~JY5411CoreOODITask() | JY5411CoreOO::JY5411CoreOODITask


5411 C++ Programming Manual: Member List

  • JY5411CoreOODOTask
JY5411CoreOO::JY5411CoreOODOTask Member List

This is the complete list of members for JY5411CoreOO::JY5411CoreOODOTask, including all inherited members.

AddChannel(int lineNum) | JY5411CoreOO::JY5411CoreOODOTask
AddChannel(std::vector< int > linesNum) | JY5411CoreOO::JY5411CoreOODOTask
AvaliableLenInSamples | JY5411CoreOO::JY5411CoreOODOTask
BufLenInSamples | JY5411CoreOO::JY5411CoreOODOTask
Channels | JY5411CoreOO::JY5411CoreOODOTask
Device | JY5411CoreOO::JY5411CoreOODOTask
JY5411CoreOODOTask(int slotNum) | JY5411CoreOO::JY5411CoreOODOTask
JY5411CoreOODOTask(std::string boardName) | JY5411CoreOO::JY5411CoreOODOTask
Mode | JY5411CoreOO::JY5411CoreOODOTask
RemoveChannel(int lineNum) | JY5411CoreOO::JY5411CoreOODOTask
SampleClock | JY5411CoreOO::JY5411CoreOODOTask
SamplesToUpdate | JY5411CoreOO::JY5411CoreOODOTask
SendSoftwareTrigger() | JY5411CoreOO::JY5411CoreOODOTask
SignalExport | JY5411CoreOO::JY5411CoreOODOTask
Start() | JY5411CoreOO::JY5411CoreOODOTask
Stop() | JY5411CoreOO::JY5411CoreOODOTask
TransferedSamples | JY5411CoreOO::JY5411CoreOODOTask
Trigger | JY5411CoreOO::JY5411CoreOODOTask
UpdateRate | JY5411CoreOO::JY5411CoreOODOTask
WaitUntilDone(int timeout=-1) | JY5411CoreOO::JY5411CoreOODOTask
WriteData(bool *dataBuffer, unsigned int samplesToUpdate, int timeOut=10000) | JY5411CoreOO::JY5411CoreOODOTask
WriteData(unsigned int *dataBuffer, unsigned int samplesToUpdate, int timeOut=10000) | JY5411CoreOO::JY5411CoreOODOTask
WriteSinglePoint(bool writeValues, int line) | JY5411CoreOO::JY5411CoreOODOTask
WriteSinglePoint(std::vector< bool > &writeValues) | JY5411CoreOO::JY5411CoreOODOTask
~JY5411CoreOODOTask() | JY5411CoreOO::JY5411CoreOODOTask


5411 C++ Programming Manual: Member List

  • JY5411CoreOODevice
JY5411CoreOO::JY5411CoreOODevice Member List

This is the complete list of members for JY5411CoreOO::JY5411CoreOODevice, including all inherited members.

BoardClockRate | JY5411CoreOO::JY5411CoreOODevice |
CounterInterface enum name | JY5411CoreOO::JY5411CoreOODevice |
DeviceID | JY5411CoreOO::JY5411CoreOODevice |
DiffChannelCount | JY5411CoreOO::JY5411CoreOODevice |
DIOLineCount | JY5411CoreOO::JY5411CoreOODevice |
GetInstance(int cardNum) | JY5411CoreOO::JY5411CoreOODevice | static
GetInstance(std::string aliasName) | JY5411CoreOO::JY5411CoreOODevice | static
Handle | JY5411CoreOO::JY5411CoreOODevice |
IsAISync | JY5411CoreOO::JY5411CoreOODevice |
IsAOSync | JY5411CoreOO::JY5411CoreOODevice |
MaxSampleRate | JY5411CoreOO::JY5411CoreOODevice |
PFI | JY5411CoreOO::JY5411CoreOODevice |
ReferenceClock | JY5411CoreOO::JY5411CoreOODevice |
SEChannelCount | JY5411CoreOO::JY5411CoreOODevice |
SerialNumber | JY5411CoreOO::JY5411CoreOODevice |


5411 C++ Programming Manual: Member List

  • JY5411CoreOOLog
JY5411CoreOO::JY5411CoreOOLog Member List

This is the complete list of members for JY5411CoreOO::JY5411CoreOOLog, including all inherited members.

EnableLog | JY5411CoreOO::JY5411CoreOOLog | static
Flush() | JY5411CoreOO::JY5411CoreOOLog | static
LogLevel | JY5411CoreOO::JY5411CoreOOLog | static
Print(const char *format,...) | JY5411CoreOO::JY5411CoreOOLog | static
Print(JY5411CoreOOLogLevel logLevel, const char *format,...) | JY5411CoreOO::JY5411CoreOOLog | static


5411 C++ Programming Manual: Member List

  • JY5411CoreOOProperty
JY5411CoreOO::JY5411CoreOOProperty< ContainerClass, ValueType, propertyType > Member List

This is the complete list of members for JY5411CoreOO::JY5411CoreOOProperty< ContainerClass, ValueType, propertyType >, including all inherited members.

JY5411CoreOOProperty() | JY5411CoreOO::JY5411CoreOOProperty< ContainerClass, ValueType, propertyType >
JY5411CoreOOProperty(ContainerClass *cObject, ValueType(ContainerClass::*pGet)(), void(ContainerClass::*pSet)(ValueType value)) | JY5411CoreOO::JY5411CoreOOProperty< ContainerClass, ValueType, propertyType >
JY5411CoreOOProperty(ValueType(*pGet)(), void(*pSet)(ValueType value)) | JY5411CoreOO::JY5411CoreOOProperty< ContainerClass, ValueType, propertyType >
operator ValueType() | JY5411CoreOO::JY5411CoreOOProperty< ContainerClass, ValueType, propertyType >
operator=(const ValueType &value) | JY5411CoreOO::JY5411CoreOOProperty< ContainerClass, ValueType, propertyType >


5411 C++ Programming Manual: Member List

  • JY5411CoreOOReferenceClock
JY5411CoreOO::JY5411CoreOOReferenceClock Member List

This is the complete list of members for JY5411CoreOO::JY5411CoreOOReferenceClock, including all inherited members.

Commit() | JY5411CoreOO::JY5411CoreOOReferenceClock
External | JY5411CoreOO::JY5411CoreOOReferenceClock
Locked | JY5411CoreOO::JY5411CoreOOReferenceClock
Source | JY5411CoreOO::JY5411CoreOOReferenceClock


5411 C++ Programming Manual: Member List

  • JYDriverException
JY5411CoreOO::JYDriverException Member List

This is the complete list of members for JY5411CoreOO::JYDriverException, including all inherited members.

errorCode | JY5411CoreOO::JYDriverException
exceptionMessage | JY5411CoreOO::JYDriverException
FollowingException | JY5411CoreOO::JYDriverException
JYDriverException(JYDriverExceptionPublic exceptionCode, std::string msg="") | JY5411CoreOO::JYDriverException
JYDriverException(JYErrorCode exceptionCode, std::string msg="") | JY5411CoreOO::JYDriverException
JYDriverException(int, std::string msg) | JY5411CoreOO::JYDriverException


5411 C++ Programming Manual: Member List

  • PFIFilter
JY5411CoreOO::PFIFilter Member List

This is the complete list of members for JY5411CoreOO::PFIFilter, including all inherited members.

Disable(PFITerminal terminal) | JY5411CoreOO::PFIFilter
Disable(std::vector< PFITerminal > terminals) | JY5411CoreOO::PFIFilter
DisableAll() | JY5411CoreOO::PFIFilter
Enable(PFITerminal terminal, int minPulseWidth) | JY5411CoreOO::PFIFilter
Enable(std::vector< PFITerminal > terminals, int minPulseWidth) | JY5411CoreOO::PFIFilter
Enable(std::vector< PFITerminal > terminals, std::vector< int > minPulseWidth) | JY5411CoreOO::PFIFilter


5411 C++ Programming Manual: Member List

  • PFISetting
JY5411CoreOO::PFISetting Member List

This is the complete list of members for JY5411CoreOO::PFISetting, including all inherited members.

Filter | JY5411CoreOO::PFISetting
LogicLevel | JY5411CoreOO::PFISetting


5411 C++ Programming Manual: Member List

  • PauseTrigger
JY5411CoreOO::PauseTrigger Member List

This is the complete list of members for JY5411CoreOO::PauseTrigger, including all inherited members.

ActivePolarity JY5411CoreOO::PauseTrigger


5411 C++ Programming Manual: Class Index

Class Index
D | E | J | P
D
DIChannel (JY5411CoreOO)
DIDigitalTrigger (JY5411CoreOO)
DIExternalSampleClock (JY5411CoreOO)
DIRecord (JY5411CoreOO)
DISampleClock (JY5411CoreOO)
DISignalExport (JY5411CoreOO)
DITrigger (JY5411CoreOO)
DOChannel (JY5411CoreOO)
DODigitalTrigger (JY5411CoreOO)
DOExternalSampleClock (JY5411CoreOO)
DOSampleClock (JY5411CoreOO)
DOSignalExport (JY5411CoreOO)
DOTrigger (JY5411CoreOO)
E
ExternalReferenceClock (JY5411CoreOO)
J
JY5411CoreOODevice (JY5411CoreOO)
JY5411CoreOODITask (JY5411CoreOO)
JY5411CoreOODOTask (JY5411CoreOO)
JY5411CoreOOLog (JY5411CoreOO)
JY5411CoreOOProperty (JY5411CoreOO)
JY5411CoreOOReferenceClock (JY5411CoreOO)
JYDriverException (JY5411CoreOO)
P
PauseTrigger (JY5411CoreOO)
PFIFilter (JY5411CoreOO)
PFISetting (JY5411CoreOO)


5411 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO Directory Reference

  • File List
  • File Members
  • COO
COO Directory Reference

Directories

5411


5411 C++ Programming Manual: File List

  • File List
  • File Members
File List
Here is a list of all files with brief descriptions:
[detail level 123]
▼ COO
▼ 5411
JY5411CoreOOCommon.h
JY5411CoreOODevice.h
JY5411CoreOODITask.h
JY5411CoreOODOTask.h
JY5411CoreOOLog.h


5411 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- a -

  • ActivePolarity : JY5411CoreOO::PauseTrigger
  • Add() : JY5411CoreOO::DISignalExport, JY5411CoreOO::DOSignalExport
  • AddChannel() : JY5411CoreOO::JY5411CoreOODITask, JY5411CoreOO::JY5411CoreOODOTask
  • AvailableSamples : JY5411CoreOO::JY5411CoreOODITask
  • AvaliableLenInSamples : JY5411CoreOO::JY5411CoreOODOTask

- b -

  • BoardClockRate : JY5411CoreOO::JY5411CoreOODevice
  • BufLenInSamples : JY5411CoreOO::JY5411CoreOODITask, JY5411CoreOO::JY5411CoreOODOTask

- c -

  • Channels : JY5411CoreOO::JY5411CoreOODITask, JY5411CoreOO::JY5411CoreOODOTask
  • Clear() : JY5411CoreOO::DISignalExport, JY5411CoreOO::DOSignalExport
  • ClearAll() : JY5411CoreOO::DISignalExport, JY5411CoreOO::DOSignalExport
  • Commit() : JY5411CoreOO::JY5411CoreOOReferenceClock
  • CounterInterface : JY5411CoreOO::JY5411CoreOODevice

- d -

  • Delay : JY5411CoreOO::DITrigger, JY5411CoreOO::DOTrigger
  • Device : JY5411CoreOO::JY5411CoreOODITask, JY5411CoreOO::JY5411CoreOODOTask
  • DeviceID : JY5411CoreOO::JY5411CoreOODevice
  • DiffChannelCount : JY5411CoreOO::JY5411CoreOODevice
  • Digital : JY5411CoreOO::DITrigger, JY5411CoreOO::DOTrigger
  • DIOLineCount : JY5411CoreOO::JY5411CoreOODevice
  • Disable() : JY5411CoreOO::PFIFilter
  • DisableAll() : JY5411CoreOO::PFIFilter
  • DODigitalTrigger() : JY5411CoreOO::DODigitalTrigger

- e -

  • Edge : JY5411CoreOO::DIDigitalTrigger, JY5411CoreOO::DISampleClock, JY5411CoreOO::DODigitalTrigger, JY5411CoreOO::DOSampleClock
  • Enable() : JY5411CoreOO::PFIFilter
  • EnableLog : JY5411CoreOO::JY5411CoreOOLog
  • errorCode : JY5411CoreOO::JYDriverException
  • exceptionMessage : JY5411CoreOO::JYDriverException
  • ExpectedRate : JY5411CoreOO::DIExternalSampleClock, JY5411CoreOO::DOExternalSampleClock
  • External : JY5411CoreOO::DISampleClock, JY5411CoreOO::DOSampleClock, JY5411CoreOO::JY5411CoreOOReferenceClock

- f -

  • File_Format : JY5411CoreOO::DIRecord
  • FilePath : JY5411CoreOO::DIRecord
  • Filter : JY5411CoreOO::PFISetting
  • Flush() : JY5411CoreOO::JY5411CoreOOLog
  • FollowingException : JY5411CoreOO::JYDriverException
  • Frequency : JY5411CoreOO::ExternalReferenceClock

- g -

  • GetInstance() : JY5411CoreOO::JY5411CoreOODevice
  • GetRecordPreviewData() : JY5411CoreOO::JY5411CoreOODITask

- h -

  • Handle : JY5411CoreOO::JY5411CoreOODevice

- i -

  • IsAISync : JY5411CoreOO::JY5411CoreOODevice
  • IsAOSync : JY5411CoreOO::JY5411CoreOODevice

- j -

  • JY5411CoreOODITask() : JY5411CoreOO::JY5411CoreOODITask
  • JY5411CoreOODOTask() : JY5411CoreOO::JY5411CoreOODOTask
  • JY5411CoreOOProperty() : JY5411CoreOO::JY5411CoreOOProperty< ContainerClass, ValueType, propertyType >
  • JYDriverException() : JY5411CoreOO::JYDriverException

- l -

  • Length : JY5411CoreOO::DIRecord
  • LineNum : JY5411CoreOO::DIChannel, JY5411CoreOO::DOChannel
  • Locked : JY5411CoreOO::JY5411CoreOOReferenceClock
  • LogicLevel : JY5411CoreOO::PFISetting
  • LogLevel : JY5411CoreOO::JY5411CoreOOLog

- m -

  • MaxSampleRate : JY5411CoreOO::JY5411CoreOODevice
  • Mode : JY5411CoreOO::DIRecord, JY5411CoreOO::DITrigger, JY5411CoreOO::JY5411CoreOODITask, JY5411CoreOO::JY5411CoreOODOTask

- o -

  • operator ValueType() : JY5411CoreOO::JY5411CoreOOProperty< ContainerClass, ValueType, propertyType >
  • operator=() : JY5411CoreOO::JY5411CoreOOProperty< ContainerClass, ValueType, propertyType >

- p -

  • PFI : JY5411CoreOO::JY5411CoreOODevice
  • PreTriggerSamples : JY5411CoreOO::DITrigger
  • Print() : JY5411CoreOO::JY5411CoreOOLog

- r -

  • ReadData() : JY5411CoreOO::JY5411CoreOODITask
  • ReadSinglePoint() : JY5411CoreOO::JY5411CoreOODITask
  • Record : JY5411CoreOO::JY5411CoreOODITask
  • ReferenceClock : JY5411CoreOO::JY5411CoreOODevice
  • RemoveChannel() : JY5411CoreOO::JY5411CoreOODITask, JY5411CoreOO::JY5411CoreOODOTask
  • ReTriggerCount : JY5411CoreOO::DITrigger

- s -

  • SampleClock : JY5411CoreOO::JY5411CoreOODITask, JY5411CoreOO::JY5411CoreOODOTask
  • SampleRate : JY5411CoreOO::JY5411CoreOODITask
  • SamplesToAcquire : JY5411CoreOO::JY5411CoreOODITask
  • SamplesToUpdate : JY5411CoreOO::JY5411CoreOODOTask
  • SEChannelCount : JY5411CoreOO::JY5411CoreOODevice
  • SendSoftwareTrigger() : JY5411CoreOO::JY5411CoreOODITask, JY5411CoreOO::JY5411CoreOODOTask
  • SerialNumber : JY5411CoreOO::JY5411CoreOODevice
  • SignalExport : JY5411CoreOO::JY5411CoreOODITask, JY5411CoreOO::JY5411CoreOODOTask
  • Source : JY5411CoreOO::DIDigitalTrigger, JY5411CoreOO::DISampleClock, JY5411CoreOO::DODigitalTrigger, JY5411CoreOO::DOSampleClock, JY5411CoreOO::JY5411CoreOOReferenceClock
  • Start() : JY5411CoreOO::JY5411CoreOODITask, JY5411CoreOO::JY5411CoreOODOTask
  • Stop() : JY5411CoreOO::JY5411CoreOODITask, JY5411CoreOO::JY5411CoreOODOTask

- t -

  • Terminal : JY5411CoreOO::DIExternalSampleClock, JY5411CoreOO::DOExternalSampleClock, JY5411CoreOO::ExternalReferenceClock
  • TransferedSamples : JY5411CoreOO::JY5411CoreOODITask, JY5411CoreOO::JY5411CoreOODOTask
  • Trigger : JY5411CoreOO::JY5411CoreOODITask, JY5411CoreOO::JY5411CoreOODOTask
  • Type : JY5411CoreOO::DITrigger, JY5411CoreOO::DOTrigger

- u -

  • UpdateRate : JY5411CoreOO::JY5411CoreOODOTask

- w -

  • WaitUntilDone() : JY5411CoreOO::JY5411CoreOODOTask
  • WriteData() : JY5411CoreOO::JY5411CoreOODOTask
  • WriteSinglePoint() : JY5411CoreOO::JY5411CoreOODOTask

- ~ -

  • ~JY5411CoreOODITask() : JY5411CoreOO::JY5411CoreOODITask
  • ~JY5411CoreOODOTask() : JY5411CoreOO::JY5411CoreOODOTask


5411 C++ Programming Manual: Class Members - Enumerations

  • All
  • Functions
  • Variables
  • Enumerations
Here is a list of all enums with links to the classes they belong to:
  • CounterInterface : JY5411CoreOO::JY5411CoreOODevice


5411 C++ Programming Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • a
  • c
  • d
  • e
  • f
  • g
  • j
  • o
  • p
  • r
  • s
  • w
  • ~
Here is a list of all functions with links to the classes they belong to:

- a -

  • Add() : JY5411CoreOO::DISignalExport, JY5411CoreOO::DOSignalExport
  • AddChannel() : JY5411CoreOO::JY5411CoreOODITask, JY5411CoreOO::JY5411CoreOODOTask

- c -

  • Clear() : JY5411CoreOO::DISignalExport, JY5411CoreOO::DOSignalExport
  • ClearAll() : JY5411CoreOO::DISignalExport, JY5411CoreOO::DOSignalExport
  • Commit() : JY5411CoreOO::JY5411CoreOOReferenceClock

- d -

  • Disable() : JY5411CoreOO::PFIFilter
  • DisableAll() : JY5411CoreOO::PFIFilter
  • DODigitalTrigger() : JY5411CoreOO::DODigitalTrigger

- e -

  • Enable() : JY5411CoreOO::PFIFilter

- f -

  • Flush() : JY5411CoreOO::JY5411CoreOOLog

- g -

  • GetInstance() : JY5411CoreOO::JY5411CoreOODevice
  • GetRecordPreviewData() : JY5411CoreOO::JY5411CoreOODITask

- j -

  • JY5411CoreOODITask() : JY5411CoreOO::JY5411CoreOODITask
  • JY5411CoreOODOTask() : JY5411CoreOO::JY5411CoreOODOTask
  • JY5411CoreOOProperty() : JY5411CoreOO::JY5411CoreOOProperty< ContainerClass, ValueType, propertyType >
  • JYDriverException() : JY5411CoreOO::JYDriverException

- o -

  • operator ValueType() : JY5411CoreOO::JY5411CoreOOProperty< ContainerClass, ValueType, propertyType >
  • operator=() : JY5411CoreOO::JY5411CoreOOProperty< ContainerClass, ValueType, propertyType >

- p -

  • Print() : JY5411CoreOO::JY5411CoreOOLog

- r -

  • ReadData() : JY5411CoreOO::JY5411CoreOODITask
  • ReadSinglePoint() : JY5411CoreOO::JY5411CoreOODITask
  • RemoveChannel() : JY5411CoreOO::JY5411CoreOODITask, JY5411CoreOO::JY5411CoreOODOTask

- s -

  • SendSoftwareTrigger() : JY5411CoreOO::JY5411CoreOODITask, JY5411CoreOO::JY5411CoreOODOTask
  • Start() : JY5411CoreOO::JY5411CoreOODITask, JY5411CoreOO::JY5411CoreOODOTask
  • Stop() : JY5411CoreOO::JY5411CoreOODITask, JY5411CoreOO::JY5411CoreOODOTask

- w -

  • WaitUntilDone() : JY5411CoreOO::JY5411CoreOODOTask
  • WriteData() : JY5411CoreOO::JY5411CoreOODOTask
  • WriteSinglePoint() : JY5411CoreOO::JY5411CoreOODOTask

- ~ -

  • ~JY5411CoreOODITask() : JY5411CoreOO::JY5411CoreOODITask
  • ~JY5411CoreOODOTask() : JY5411CoreOO::JY5411CoreOODOTask


5411 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • u
Here is a list of all variables with links to the classes they belong to:

- a -

  • ActivePolarity : JY5411CoreOO::PauseTrigger
  • AvailableSamples : JY5411CoreOO::JY5411CoreOODITask
  • AvaliableLenInSamples : JY5411CoreOO::JY5411CoreOODOTask

- b -

  • BoardClockRate : JY5411CoreOO::JY5411CoreOODevice
  • BufLenInSamples : JY5411CoreOO::JY5411CoreOODITask, JY5411CoreOO::JY5411CoreOODOTask

- c -

  • Channels : JY5411CoreOO::JY5411CoreOODITask, JY5411CoreOO::JY5411CoreOODOTask

- d -

  • Delay : JY5411CoreOO::DITrigger, JY5411CoreOO::DOTrigger
  • Device : JY5411CoreOO::JY5411CoreOODITask, JY5411CoreOO::JY5411CoreOODOTask
  • DeviceID : JY5411CoreOO::JY5411CoreOODevice
  • DiffChannelCount : JY5411CoreOO::JY5411CoreOODevice
  • Digital : JY5411CoreOO::DITrigger, JY5411CoreOO::DOTrigger
  • DIOLineCount : JY5411CoreOO::JY5411CoreOODevice

- e -

  • Edge : JY5411CoreOO::DIDigitalTrigger, JY5411CoreOO::DISampleClock, JY5411CoreOO::DODigitalTrigger, JY5411CoreOO::DOSampleClock
  • EnableLog : JY5411CoreOO::JY5411CoreOOLog
  • errorCode : JY5411CoreOO::JYDriverException
  • exceptionMessage : JY5411CoreOO::JYDriverException
  • ExpectedRate : JY5411CoreOO::DIExternalSampleClock, JY5411CoreOO::DOExternalSampleClock
  • External : JY5411CoreOO::DISampleClock, JY5411CoreOO::DOSampleClock, JY5411CoreOO::JY5411CoreOOReferenceClock

- f -

  • File_Format : JY5411CoreOO::DIRecord
  • FilePath : JY5411CoreOO::DIRecord
  • Filter : JY5411CoreOO::PFISetting
  • FollowingException : JY5411CoreOO::JYDriverException
  • Frequency : JY5411CoreOO::ExternalReferenceClock

- h -

  • Handle : JY5411CoreOO::JY5411CoreOODevice

- i -

  • IsAISync : JY5411CoreOO::JY5411CoreOODevice
  • IsAOSync : JY5411CoreOO::JY5411CoreOODevice

- l -

  • Length : JY5411CoreOO::DIRecord
  • LineNum : JY5411CoreOO::DIChannel, JY5411CoreOO::DOChannel
  • Locked : JY5411CoreOO::JY5411CoreOOReferenceClock
  • LogicLevel : JY5411CoreOO::PFISetting
  • LogLevel : JY5411CoreOO::JY5411CoreOOLog

- m -

  • MaxSampleRate : JY5411CoreOO::JY5411CoreOODevice
  • Mode : JY5411CoreOO::DIRecord, JY5411CoreOO::DITrigger, JY5411CoreOO::JY5411CoreOODITask, JY5411CoreOO::JY5411CoreOODOTask

- p -

  • PFI : JY5411CoreOO::JY5411CoreOODevice
  • PreTriggerSamples : JY5411CoreOO::DITrigger

- r -

  • Record : JY5411CoreOO::JY5411CoreOODITask
  • ReferenceClock : JY5411CoreOO::JY5411CoreOODevice
  • ReTriggerCount : JY5411CoreOO::DITrigger

- s -

  • SampleClock : JY5411CoreOO::JY5411CoreOODITask, JY5411CoreOO::JY5411CoreOODOTask
  • SampleRate : JY5411CoreOO::JY5411CoreOODITask
  • SamplesToAcquire : JY5411CoreOO::JY5411CoreOODITask
  • SamplesToUpdate : JY5411CoreOO::JY5411CoreOODOTask
  • SEChannelCount : JY5411CoreOO::JY5411CoreOODevice
  • SerialNumber : JY5411CoreOO::JY5411CoreOODevice
  • SignalExport : JY5411CoreOO::JY5411CoreOODITask, JY5411CoreOO::JY5411CoreOODOTask
  • Source : JY5411CoreOO::DIDigitalTrigger, JY5411CoreOO::DISampleClock, JY5411CoreOO::DODigitalTrigger, JY5411CoreOO::DOSampleClock, JY5411CoreOO::JY5411CoreOOReferenceClock

- t -

  • Terminal : JY5411CoreOO::DIExternalSampleClock, JY5411CoreOO::DOExternalSampleClock, JY5411CoreOO::ExternalReferenceClock
  • TransferedSamples : JY5411CoreOO::JY5411CoreOODITask, JY5411CoreOO::JY5411CoreOODOTask
  • Trigger : JY5411CoreOO::JY5411CoreOODITask, JY5411CoreOO::JY5411CoreOODOTask
  • Type : JY5411CoreOO::DITrigger, JY5411CoreOO::DOTrigger

- u -

  • UpdateRate : JY5411CoreOO::JY5411CoreOODOTask


5411 C++ Programming Manual: File Members

  • File List
  • File Members
  • All
  • Macros
Here is a list of all file members with links to the files they belong to:
  • EXTERN_C : JY5411CoreOOCommon.h
  • JY5411CoreOO_API : JY5411CoreOOCommon.h


5411 C++ Programming Manual: File Members

  • File List
  • File Members
  • All
  • Macros
Here is a list of all macros with links to the files they belong to:
  • EXTERN_C : JY5411CoreOOCommon.h
  • JY5411CoreOO_API : JY5411CoreOOCommon.h


5411 C++ Programming Manual: Main Page

5411 C++ Programming Manual Documentation


5411 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
Here is a list of all namespace members with links to the namespace documentation for each member:
  • ClockEdge : JY5411CoreOO
  • ClockTerminal : JY5411CoreOO
  • DIDigitalTriggerEdge : JY5411CoreOO
  • DIDigitalTriggerSource : JY5411CoreOO
  • DIMode : JY5411CoreOO
  • DISampleClockSource : JY5411CoreOO
  • DISignalExportSource : JY5411CoreOO
  • DITriggerMode : JY5411CoreOO
  • DITriggerType : JY5411CoreOO
  • DOClockEdge : JY5411CoreOO
  • DODigitalTriggerEdge : JY5411CoreOO
  • DODigitalTriggerSource : JY5411CoreOO
  • DOMode : JY5411CoreOO
  • DOSampleClockSource : JY5411CoreOO
  • DOSignalExportSource : JY5411CoreOO
  • DOTriggerType : JY5411CoreOO
  • ExternalReferenceClockTerminal : JY5411CoreOO
  • FileFormat : JY5411CoreOO
  • GetSignalExportDestinationString() : JY5411CoreOO
  • JY5411CoreOOLogLevel : JY5411CoreOO
  • JY5411CoreOOPropertyType : JY5411CoreOO
  • JYDriverExceptionPublic : JY5411CoreOO
  • JYErrorCode : JY5411CoreOO
  • LevelPolarity : JY5411CoreOO
  • OutputCompleteState : JY5411CoreOO
  • PFITerminal : JY5411CoreOO
  • PowerLevel : JY5411CoreOO
  • RecordMode : JY5411CoreOO
  • ReferenceClockSource : JY5411CoreOO
  • SignalExportDestination : JY5411CoreOO


5411 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
Here is a list of all namespace enums with links to the namespace documentation for each enum:
  • ClockEdge : JY5411CoreOO
  • ClockTerminal : JY5411CoreOO
  • DIDigitalTriggerEdge : JY5411CoreOO
  • DIDigitalTriggerSource : JY5411CoreOO
  • DIMode : JY5411CoreOO
  • DISampleClockSource : JY5411CoreOO
  • DISignalExportSource : JY5411CoreOO
  • DITriggerMode : JY5411CoreOO
  • DITriggerType : JY5411CoreOO
  • DOClockEdge : JY5411CoreOO
  • DODigitalTriggerEdge : JY5411CoreOO
  • DODigitalTriggerSource : JY5411CoreOO
  • DOMode : JY5411CoreOO
  • DOSampleClockSource : JY5411CoreOO
  • DOSignalExportSource : JY5411CoreOO
  • DOTriggerType : JY5411CoreOO
  • ExternalReferenceClockTerminal : JY5411CoreOO
  • FileFormat : JY5411CoreOO
  • JY5411CoreOOLogLevel : JY5411CoreOO
  • JY5411CoreOOPropertyType : JY5411CoreOO
  • JYDriverExceptionPublic : JY5411CoreOO
  • JYErrorCode : JY5411CoreOO
  • LevelPolarity : JY5411CoreOO
  • OutputCompleteState : JY5411CoreOO
  • PFITerminal : JY5411CoreOO
  • PowerLevel : JY5411CoreOO
  • RecordMode : JY5411CoreOO
  • ReferenceClockSource : JY5411CoreOO
  • SignalExportDestination : JY5411CoreOO


5411 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
Here is a list of all namespace functions with links to the namespace documentation for each function:
  • GetSignalExportDestinationString() : JY5411CoreOO


5411 C++ Programming Manual: Namespace List

  • Namespace List
  • Namespace Members
Namespace List
Here is a list of all namespaces with brief descriptions:
N JY5411CoreOO