5500 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5500 Directory Reference

5500 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 5500
5500 Directory Reference

Files

JY5500CoreOOAITask.h
JY5500CoreOOAOTask.h
JY5500CoreOOCITask.h
JY5500CoreOOCommon.h
JY5500CoreOOCOTask.h
JY5500CoreOODevice.h
JY5500CoreOODITask.h
JY5500CoreOODOTask.h
JY5500CoreOOLog.h
Generated by doxygen 1.13.2


5500 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOAITask.h File Reference

  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 5500
Classes | Namespaces | Enumerations
JY5500CoreOOAITask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JY5500CoreOOCommon.h"
#include "JY5500CoreOODevice.h"

Classes

class | JY5500CoreOO::JY5500CoreOOAITask
AITask类 More...
class | JY5500CoreOO::AIChannel
class | JY5500CoreOO::AIExternalSampleClock
class | JY5500CoreOO::AISampleClock
class | JY5500CoreOO::AITrigger
class | JY5500CoreOO::AIDigitalTrigger
class | JY5500CoreOO::AIAnalogHysteresisComparator
class | JY5500CoreOO::AIAnalogWindowComparator
class | JY5500CoreOO::AIAnalogEdgeComparator
class | JY5500CoreOO::AIAnalogTrigger
class | JY5500CoreOO::AIRecord
class | JY5500CoreOO::AIDSMode
class | JY5500CoreOO::AIAdvanced
class | JY5500CoreOO::AISignalExport

Namespaces

namespace JY5500CoreOO

Enumerations

enum class | JY5500CoreOO::AITerminal { JY5500CoreOO::RSE = 0x0 , JY5500CoreOO::NRSE = 0x1 , JY5500CoreOO::Differential = 0x2 }
enum class | JY5500CoreOO::AIMode { JY5500CoreOO::Single = 0x2 , JY5500CoreOO::Finite = 0x0 , JY5500CoreOO::Continuous = 0x1 , JY5500CoreOO::Record = 0x3 }
enum class | JY5500CoreOO::AISampleClockSource { JY5500CoreOO::Internal , JY5500CoreOO::External }
enum class | JY5500CoreOO::AITriggerType { JY5500CoreOO::Immediate = 0x0 , JY5500CoreOO::Digital = 0x1 , JY5500CoreOO::Analog = 0x2 , JY5500CoreOO::Soft = 0x3 }
enum class | JY5500CoreOO::AITriggerMode { JY5500CoreOO::Start , JY5500CoreOO::Reference }
enum class JY5500CoreOO::AIAnalogTriggerSource {
JY5500CoreOO::Channel_0 , JY5500CoreOO::Channel_1 , JY5500CoreOO::Channel_2 , JY5500CoreOO::Channel_3 ,
JY5500CoreOO::Channel_4 , JY5500CoreOO::Channel_5 , JY5500CoreOO::Channel_6 , JY5500CoreOO::Channel_7 ,
JY5500CoreOO::Channel_8 , JY5500CoreOO::Channel_9 , JY5500CoreOO::Channel_10 , JY5500CoreOO::Channel_11 ,
JY5500CoreOO::Channel_12 , JY5500CoreOO::Channel_13 , JY5500CoreOO::Channel_14 , JY5500CoreOO::Channel_15 ,
JY5500CoreOO::Channel_16 , JY5500CoreOO::Channel_17 , JY5500CoreOO::Channel_18 , JY5500CoreOO::Channel_19 ,
JY5500CoreOO::Channel_20 , JY5500CoreOO::Channel_21 , JY5500CoreOO::Channel_22 , JY5500CoreOO::Channel_23 ,
JY5500CoreOO::Channel_24 , JY5500CoreOO::Channel_25 , JY5500CoreOO::Channel_26 , JY5500CoreOO::Channel_27 ,
JY5500CoreOO::Channel_28 , JY5500CoreOO::Channel_29 , JY5500CoreOO::Channel_30 , JY5500CoreOO::Channel_31
}
enum class JY5500CoreOO::AIDigitalTriggerSource {
JY5500CoreOO::PFI0 , JY5500CoreOO::PFI1 , JY5500CoreOO::PFI2 , JY5500CoreOO::PFI3 ,
JY5500CoreOO::PFI4 , JY5500CoreOO::PFI5 , JY5500CoreOO::PFI6 , JY5500CoreOO::PFI7 ,
JY5500CoreOO::PFI8 , JY5500CoreOO::PFI9 , JY5500CoreOO::PFI10 , JY5500CoreOO::PFI11 ,
JY5500CoreOO::PFI12 , JY5500CoreOO::PFI13 , JY5500CoreOO::PFI14 , JY5500CoreOO::PFI15 ,
JY5500CoreOO::PXI_Trig0 = 40 , JY5500CoreOO::PXI_Trig1 = 41 , JY5500CoreOO::PXI_Trig2 = 42 , JY5500CoreOO::PXI_Trig3 = 43 ,
JY5500CoreOO::PXI_Trig4 = 44 , JY5500CoreOO::PXI_Trig5 = 45 , JY5500CoreOO::PXI_Trig6 = 46 , JY5500CoreOO::PXI_Trig7 = 47 ,
JY5500CoreOO::AO_StartTrig = 26 , JY5500CoreOO::DI_StartTrig = 22 , JY5500CoreOO::DI_ReferenceTrig = 23 , JY5500CoreOO::DO_StartTrig = 29 ,
JY5500CoreOO::CI_0_StartTrig = 68 , JY5500CoreOO::CI_1_StartTrig = 73 , JY5500CoreOO::CI_2_StartTrig = 76 , JY5500CoreOO::CI_3_StartTrig = 79 ,
JY5500CoreOO::CO_0_StartTrig = 69 , JY5500CoreOO::CO_1_StartTrig = 74 , JY5500CoreOO::CO_2_StartTrig = 77 , JY5500CoreOO::CO_3_StartTrig = 80 ,
JY5500CoreOO::CO_0_Output = 37 , JY5500CoreOO::CO_1_Output = 51 , JY5500CoreOO::CO_2_Output = 60 , JY5500CoreOO::CO_3_Output = 66
}
enum class | JY5500CoreOO::AIDigitalTriggerEdge { JY5500CoreOO::Rising = 0x0 , JY5500CoreOO::Falling = 0x1 }
enum class | JY5500CoreOO::AIAnalogTriggerEdge { JY5500CoreOO::Rising , JY5500CoreOO::Falling }
enum class | JY5500CoreOO::AIAnalogWindowCondition { JY5500CoreOO::Entering , JY5500CoreOO::Leaving }
AI Analog Window Trigger Condition. More...
enum class | JY5500CoreOO::AIAnalogTriggerComparator { JY5500CoreOO::Edge , JY5500CoreOO::Hysteresis , JY5500CoreOO::Window }
AI Analog Trigger Comparator. More...
enum class | JY5500CoreOO::AISignalExportSource { JY5500CoreOO::StartTrig = 16 , JY5500CoreOO::ReferenceTrig = 17 , JY5500CoreOO::SampleClock = 20 }
enum class | JY5500CoreOO::FileFormat { JY5500CoreOO::Bin }
enum class | JY5500CoreOO::RecordMode { JY5500CoreOO::Finite , JY5500CoreOO::Infinite }
enum class | JY5500CoreOO::PowerLineFrequency { JY5500CoreOO::_50Hz , JY5500CoreOO::_60Hz }


5500 C++ Programming Manual: JY5500CoreOO::JY5500CoreOOAITask Class Reference

  • Class List
  • Class Index
  • Class Members
  • JY5500CoreOO
  • JY5500CoreOOAITask
Public Member Functions | Public Attributes | List of all members
JY5500CoreOO::JY5500CoreOOAITask Class Reference

AITask类 More...

#include <JY5500CoreOOAOTask.h>

Public Member Functions

JY5500CoreOOAITask (int slotNum)
JY5500CoreOOAITask (std::string boardName)
void | AddChannel (int chnId, double rangeLow=-10, double rangeHigh=10, AITerminal terminalCfg=AITerminal::RSE)
Add one channel.
void | AddChannel (std::vector< int > chnsId, double rangeLow=-10, double rangeHigh=10, AITerminal terminalCfg=AITerminal::RSE)
Add a group of channels.
void | AddChannel (std::vector< int > chnsId, std::vector< double > rangeLow, std::vector< double > rangeHigh, AITerminal terminalCfg=AITerminal::RSE)
Add a group of channels.
void | RemoveChannel (int chnId)
Delete the channel with the specified channel number.
void | ReadData (double *pBuf, int samplesPerChannel, int timeout=-1)
Read the multi-channel data by columns and store it in a data buffer.
void | ReadData (std::vector< double > &pBuf, int samplesPerChannel, int timeout=-1)
Read the multi-channel data by columns and store it in a data buffer.
void | ReadRawData (int *pBuf, int samplesPerChannel, int timeout=-1)
Read one or multi-channel raw data by columns and store it in a data buffer.
void | ReadRawData (std::vector< int > &pBuf, int samplesPerChannel, int timeout=-1)
Read one or multi-channel raw data by columns and store it in a data buffer.
void | ReadSinglePoint (double &readValue, int channel)
Read one sample for specified channel in register.
void | ReadSinglePoint (std::vector< double > &readValues)
Read one sample for all channels in register .
void | ReadRawSinglePoint (int &readValue, int channel)
Read row one sample for specified channel in register.
void | ReadRawSinglePoint (std::vector< int > &readValues)
Read row one sample for all channels in register .
void | GetRecordPreviewData (double *buf, int samplesPerChannel, int timeout)
Preview one channel data when streaming is in progress.
void | GetRecordPreviewData (std::vector< double > &buf, int samplesPerChannel, int timeout)
Preview one channel data when streaming is in progress.
void | GetRecordStatus (double &recordedLength, bool &recordDone)
Get the streaming status.
void | Start ()
Start AI task .
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Stop ()
Stop AI task .
~JY5500CoreOOAITask ()
析构函数

Public Attributes

std::list< AIChannel * > | Channels
List of AI channels,(5510 5511 support 32 SE/16 Diff channel)(5515 5516 support16 SE/8 Diff channel)
JY5500CoreOOProperty< JY5500CoreOOAITask, double, JY5500CoreOOPropertyType::READ_WRITE > | SampleRate
Sample rate per channel.
int | SamplesToAcquire
Number of samples to be read per channel.
JY5500CoreOOProperty< JY5500CoreOOAITask, int, JY5500CoreOOPropertyType::READ_ONLY > | BufLenInSamples
Number of samples per channel can be storage in the buffer, the Property SamplesToAcquire must be less than or equal to this value.
JY5500CoreOOProperty< JY5500CoreOOAITask, uint64_t, JY5500CoreOOPropertyType::READ_ONLY > | AvailableSamples
Number of samples per channel that can be read in the buffer .
JY5500CoreOOProperty< JY5500CoreOOAITask, uint64_t, JY5500CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
AIMode Mode
AI acquisition mode, support Single/Finite/Continuous/Record *.
AISampleClock * SampleClock
AI Sample Clock.
AITrigger * Trigger
AI Trigger Configuration.
AIAdvanced * Advanced
AI Trigger Configuration.
AIRecord * Record
ai Data streaming Configuration
AISignalExport * SignalExport
Export AI Signal Configuration.
JY5500CoreOODevice * Device
Device.

Detailed Description

AITask类

Constructor & Destructor Documentation

◆ JY5500CoreOOAITask() [1/2]

JY5500CoreOO::JY5500CoreOOAITask::JY5500CoreOOAITask ( int slotNum )

◆ JY5500CoreOOAITask() [2/2]

JY5500CoreOO::JY5500CoreOOAITask::JY5500CoreOOAITask ( std::string boardName )

◆ ~JY5500CoreOOAITask()

JY5500CoreOO::JY5500CoreOOAITask::~JY5500CoreOOAITask ( )

析构函数

Member Function Documentation

◆ AddChannel() [1/3]

void JY5500CoreOO::JY5500CoreOOAITask::AddChannel | ( | int | chnId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10,
 |  | AITerminal | terminalCfg = AITerminal::RSE )

Add one channel.

Parameters
chnId | channel's physical number ，chnId=-1, add all channels。（5510 5511 SE 0-31, Differential 0-7or 16-23）（5515 5516 SE 0-16, Differential 0-7）
rangeLow | lower range limit for the channel，-10V,-5V,-2V，-1V,-0.5V，-0.2V，-0.1V defalut -10
rangeHigh | higher range limit for the channel，10V,5V,2V，1V,0.5V，0.2V，0.1V defalut 10
terminalCfg | terminal input mode configuration，RSE/NRSE/Differential.Default RSE

◆ AddChannel() [2/3]

void JY5500CoreOO::JY5500CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10,
 |  | AITerminal | terminalCfg = AITerminal::RSE )

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers （5510 5511 SE 0-31, Differential 0-7or 16-23）（5515 5516 SE 0-16, Differential 0-7）
rangeLow | lower range limit for the channel，-10V,-5V,-2V，-1V,-0.5V，-0.2V，-0.1V defalut -10
rangeHigh | higher range limit for the channel，10V,5V,2V，1V,0.5V，0.2V，0.1V defalut 10
terminalCfg | terminal input mode configuration，RSE/NRSE/Differential.Default RSE

◆ AddChannel() [3/3]

void JY5500CoreOO::JY5500CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | std::vector< double > | rangeLow,
 |  | std::vector< double > | rangeHigh,
 |  | AITerminal | terminalCfg = AITerminal::RSE )

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers （5510 5511 SE 0-31, Differential 0-7or 16-23）（5515 5516 SE 0-16, Differential 0-7）
rangeLow | lower range limit for the channel，-10V,-5V,-2V，-1V,-0.5V，-0.2V，-0.1V
rangeHigh | higher range limit for the channel，10V,5V,2V，1V,0.5V，0.2V，0.1V
terminalCfg | terminal input mode configuration，RSE/NRSE/Differential.Default RSE

◆ GetRecordPreviewData() [1/2]

void JY5500CoreOO::JY5500CoreOOAITask::GetRecordPreviewData | ( | double * | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Preview one channel data when streaming is in progress.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ GetRecordPreviewData() [2/2]

void JY5500CoreOO::JY5500CoreOOAITask::GetRecordPreviewData | ( | std::vector< double > & | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Preview one channel data when streaming is in progress.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ GetRecordStatus()

void JY5500CoreOO::JY5500CoreOOAITask::GetRecordStatus | ( | double & | recordedLength,
 |  | bool & | recordDone )

Get the streaming status.

Parameters
recordedLength | Length of the streamed, unit s
recordDone | recordDone = false :streaming is not over.recordDone = true :streaming is over

◆ ReadData() [1/2]

void JY5500CoreOO::JY5500CoreOOAITask::ReadData | ( | double * | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = -1 )

Read the multi-channel data by columns and store it in a data buffer.

Each channel is represented by one column of data.

Parameters
pBuf | Data buffer
samplesPerChannel | Number of samples per channel to read
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadData() [2/2]

void JY5500CoreOO::JY5500CoreOOAITask::ReadData | ( | std::vector< double > & | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = -1 )

Read the multi-channel data by columns and store it in a data buffer.

Each channel is represented by one column of data.

Parameters
pBuf | Data buffer
samplesPerChannel | Number of samples per channel to read
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadRawData() [1/2]

void JY5500CoreOO::JY5500CoreOOAITask::ReadRawData | ( | int * | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = -1 )

Read one or multi-channel raw data by columns and store it in a data buffer.

The buffer is pointed by C/C++ data type short.

Parameters
pBuf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [2/2]

void JY5500CoreOO::JY5500CoreOOAITask::ReadRawData | ( | std::vector< int > & | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = -1 )

Read one or multi-channel raw data by columns and store it in a data buffer.

The buffer is pointed by C/C++ data type short.

Parameters
pBuf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ ReadRawSinglePoint() [1/2]

void JY5500CoreOO::JY5500CoreOOAITask::ReadRawSinglePoint | ( | int & | readValue,
 |  | int | channel )

Read row one sample for specified channel in register.

Available when Mode is AIMode.Single

Parameters
readValue | value read
channel | Specified channel numbers.

◆ ReadRawSinglePoint() [2/2]

void JY5500CoreOO::JY5500CoreOOAITask::ReadRawSinglePoint ( std::vector< int > & readValues )

Read row one sample for all channels in register .

Available when Mode is AIMode.Single

Parameters
readValues Values read. Array length >= Channels.Count.

◆ ReadSinglePoint() [1/2]

void JY5500CoreOO::JY5500CoreOOAITask::ReadSinglePoint | ( | double & | readValue,
 |  | int | channel )

Read one sample for specified channel in register.

Available when Mode is AIMode.Single

Parameters
readValue | value read
channel | Specified channel numbers.

◆ ReadSinglePoint() [2/2]

void JY5500CoreOO::JY5500CoreOOAITask::ReadSinglePoint ( std::vector< double > & readValues )

Read one sample for all channels in register .

Available when Mode is AIMode.Single

Parameters
readValues Values read. Array length >= Channels.Count.

◆ RemoveChannel()

void JY5500CoreOO::JY5500CoreOOAITask::RemoveChannel ( int chnId )

Delete the channel with the specified channel number.

chnId=- 1, all channels will be deleted

Parameters
chnId Channel number of the channel to be deleted

◆ SendSoftwareTrigger()

void JY5500CoreOO::JY5500CoreOOAITask::SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5500CoreOO::JY5500CoreOOAITask::Start ( )

Start AI task .

◆ Stop()

void JY5500CoreOO::JY5500CoreOOAITask::Stop ( )

Stop AI task .

Member Data Documentation

◆ Advanced

AIAdvanced* JY5500CoreOO::JY5500CoreOOAITask::Advanced

AI Trigger Configuration.

◆ AvailableSamples

JY5500CoreOOProperty<JY5500CoreOOAITask, uint64_t, JY5500CoreOOPropertyType::READ_ONLY> JY5500CoreOO::JY5500CoreOOAITask::AvailableSamples

Number of samples per channel that can be read in the buffer .

Valid when Mode is NOT AIMode.Single.

◆ BufLenInSamples

JY5500CoreOOProperty<JY5500CoreOOAITask, int, JY5500CoreOOPropertyType::READ_ONLY> JY5500CoreOO::JY5500CoreOOAITask::BufLenInSamples

Number of samples per channel can be storage in the buffer, the Property SamplesToAcquire must be less than or equal to this value.

◆ Channels

std::list<AIChannel*> JY5500CoreOO::JY5500CoreOOAITask::Channels

List of AI channels,(5510 5511 support 32 SE/16 Diff channel)(5515 5516 support16 SE/8 Diff channel)

◆ Device

JY5500CoreOODevice* JY5500CoreOO::JY5500CoreOOAITask::Device

Device.

◆ Mode

AIMode JY5500CoreOO::JY5500CoreOOAITask::Mode

AI acquisition mode, support Single/Finite/Continuous/Record *.

◆ Record

AIRecord* JY5500CoreOO::JY5500CoreOOAITask::Record

ai Data streaming Configuration

◆ SampleClock

AISampleClock* JY5500CoreOO::JY5500CoreOOAITask::SampleClock

AI Sample Clock.

◆ SampleRate

JY5500CoreOOProperty<JY5500CoreOOAITask, double, JY5500CoreOOPropertyType::READ_WRITE> JY5500CoreOO::JY5500CoreOOAITask::SampleRate

Sample rate per channel.

Maximum sample rate is 2M for single channel, 1M/N for multichannel (N) The default sample rate = 30k You can read this property to obtain the sample rate that will actually take effect in the current configuration.

Exceptions
JYDriverException

◆ SamplesToAcquire

int JY5500CoreOO::JY5500CoreOOAITask::SamplesToAcquire

Number of samples to be read per channel.

Only valid when Mode is Finite*

◆ SignalExport

AISignalExport* JY5500CoreOO::JY5500CoreOOAITask::SignalExport

Export AI Signal Configuration.

◆ TransferedSamples

JY5500CoreOOProperty<JY5500CoreOOAITask, uint64_t, JY5500CoreOOPropertyType::READ_ONLY> JY5500CoreOO::JY5500CoreOOAITask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT AIMode.Single.

◆ Trigger

AITrigger* JY5500CoreOO::JY5500CoreOOAITask::Trigger

AI Trigger Configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOAITask.h


5500 C++ Programming Manual: JY5500CoreOO::AIChannel Class Reference

  • JY5500CoreOO
  • AIChannel
Public Member Functions | Public Attributes | List of all members
JY5500CoreOO::AIChannel Class Reference

#include <JY5500CoreOOAITask.h>

Public Member Functions

AIChannel (int channelId, double rangeLow, double rangeHigh, AITerminal terminalCfg=AITerminal::NRSE)

Public Attributes

int | ChannelID
double | RangeLow
double | RangeHigh
AITerminal Terminal

Constructor & Destructor Documentation

◆ AIChannel()

JY5500CoreOO::AIChannel::AIChannel | ( | int | channelId,
 |  | double | rangeLow,
 |  | double | rangeHigh,
 |  | AITerminal | terminalCfg = AITerminal::NRSE )
 inline

Member Data Documentation

◆ ChannelID

int JY5500CoreOO::AIChannel::ChannelID

◆ RangeHigh

double JY5500CoreOO::AIChannel::RangeHigh

◆ RangeLow

double JY5500CoreOO::AIChannel::RangeLow

◆ Terminal

AITerminal JY5500CoreOO::AIChannel::Terminal
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOAITask.h


5500 C++ Programming Manual: JY5500CoreOO::AIExternalSampleClock Class Reference

  • AIExternalSampleClock
Public Attributes | List of all members
JY5500CoreOO::AIExternalSampleClock Class Reference

#include <JY5500CoreOOAITask.h>

Public Attributes

ClockTerminal Terminal
External Sample Clock Input Terminal.
double ExpectedRate
Expected External Sample Clock Rate.

Member Data Documentation

◆ ExpectedRate

double JY5500CoreOO::AIExternalSampleClock::ExpectedRate

Expected External Sample Clock Rate.

◆ Terminal

ClockTerminal JY5500CoreOO::AIExternalSampleClock::Terminal

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOAITask.h


5500 C++ Programming Manual: JY5500CoreOO::AISampleClock Class Reference

  • AISampleClock
Public Attributes | List of all members
JY5500CoreOO::AISampleClock Class Reference

#include <JY5500CoreOOAITask.h>

Public Attributes

AISampleClockSource Source
AI Sample Clock Source.
AIExternalSampleClock * External
External Sample Clock Configuration.

Member Data Documentation

◆ External

AIExternalSampleClock* JY5500CoreOO::AISampleClock::External

External Sample Clock Configuration.

Valid when Source is AISampleClockSource.External.

◆ Source

AISampleClockSource JY5500CoreOO::AISampleClock::Source

AI Sample Clock Source.

enum Internal/External. The default value is AISampleClockSource.Internal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOAITask.h


5500 C++ Programming Manual: JY5500CoreOO::AITrigger Class Reference

  • AITrigger
Public Attributes | List of all members
JY5500CoreOO::AITrigger Class Reference

#include <JY5500CoreOOAITask.h>

Public Attributes

AITriggerType Type
AI trigger type.
AITriggerMode Mode
AI trigger mode.
AIDigitalTrigger * Digital
Digital Trigger Congfiguration.
AIAnalogTrigger * Analog
AI Analog Trigger.
int | ReTriggerCount
Number of repeat triggers.
unsigned int | PreTriggerSamples
AI pretrigger samples, must be less than or equal to JY5500AITask.SamplesToAcquire.

Member Data Documentation

◆ Analog

AIAnalogTrigger* JY5500CoreOO::AITrigger::Analog

AI Analog Trigger.

Valid when Type is AITriggerType.Analog.

◆ Digital

AIDigitalTrigger* JY5500CoreOO::AITrigger::Digital

Digital Trigger Congfiguration.

Valid when Type is AITriggerType.Digital.

◆ Mode

AITriggerMode JY5500CoreOO::AITrigger::Mode

AI trigger mode.

enum Start/Reference. The default value is AITriggerMode.Start.

◆ PreTriggerSamples

unsigned int JY5500CoreOO::AITrigger::PreTriggerSamples

AI pretrigger samples, must be less than or equal to JY5500AITask.SamplesToAcquire.

Valid when Mode is AITriggerMode.Reference. Pretrigger samples, must be greater than 0. Valid when Type is AITriggerType.Analog. Pretrigger samples, must be greater than 1. Valid when Type is AITriggerType.Digital.

◆ ReTriggerCount

int JY5500CoreOO::AITrigger::ReTriggerCount

Number of repeat triggers.

When 0 or 1 only trigger once, When -1 continuous retrigger until stop.

◆ Type

AITriggerType JY5500CoreOO::AITrigger::Type

AI trigger type.

enum Analog/Digital/Immediate/Soft. The default value is AITriggerType.Immediate.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOAITask.h


5500 C++ Programming Manual: JY5500CoreOO::AIDigitalTrigger Class Reference

  • AIDigitalTrigger
Public Attributes | List of all members
JY5500CoreOO::AIDigitalTrigger Class Reference

#include <JY5500CoreOOAITask.h>

Public Attributes

AIDigitalTriggerSource Source
AI Digital Trigger source.
AIDigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Member Data Documentation

◆ Edge

AIDigitalTriggerEdge JY5500CoreOO::AIDigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

AIDigitalTriggerSource JY5500CoreOO::AIDigitalTrigger::Source

AI Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOAITask.h


5500 C++ Programming Manual: JY5500CoreOO::AIAnalogHysteresisComparator Class Reference

  • AIAnalogHysteresisComparator
Public Attributes | List of all members
JY5500CoreOO::AIAnalogHysteresisComparator Class Reference

#include <JY5500CoreOOAITask.h>

Public Attributes

AIAnalogTriggerEdge Slope
AI Analog Trigger Edge.
double | HighThreshold
High Threshold.
double | LowThreshold
Low Threshold.

Member Data Documentation

◆ HighThreshold

double JY5500CoreOO::AIAnalogHysteresisComparator::HighThreshold

High Threshold.

◆ LowThreshold

double JY5500CoreOO::AIAnalogHysteresisComparator::LowThreshold

Low Threshold.

◆ Slope

AIAnalogTriggerEdge JY5500CoreOO::AIAnalogHysteresisComparator::Slope

AI Analog Trigger Edge.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOAITask.h


5500 C++ Programming Manual: JY5500CoreOO::AIAnalogWindowComparator Class Reference

  • AIAnalogWindowComparator
Public Attributes | List of all members
JY5500CoreOO::AIAnalogWindowComparator Class Reference

#include <JY5500CoreOOAITask.h>

Public Attributes

AIAnalogWindowCondition Condition
AI Analog Window Condition.
double | HighThreshold
High Threshold.
double | LowThreshold
Low Threshold.

Member Data Documentation

◆ Condition

AIAnalogWindowCondition JY5500CoreOO::AIAnalogWindowComparator::Condition

AI Analog Window Condition.

◆ HighThreshold

double JY5500CoreOO::AIAnalogWindowComparator::HighThreshold

High Threshold.

◆ LowThreshold

double JY5500CoreOO::AIAnalogWindowComparator::LowThreshold

Low Threshold.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOAITask.h


5500 C++ Programming Manual: JY5500CoreOO::AIAnalogEdgeComparator Class Reference

  • AIAnalogEdgeComparator
Public Attributes | List of all members
JY5500CoreOO::AIAnalogEdgeComparator Class Reference

#include <JY5500CoreOOAITask.h>

Public Attributes

AIAnalogTriggerEdge Slope
AI Analog Trigger Edge.
double Threshold
Threshold.

Member Data Documentation

◆ Slope

AIAnalogTriggerEdge JY5500CoreOO::AIAnalogEdgeComparator::Slope

AI Analog Trigger Edge.

◆ Threshold

double JY5500CoreOO::AIAnalogEdgeComparator::Threshold

Threshold.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOAITask.h


5500 C++ Programming Manual: JY5500CoreOO::AIAnalogTrigger Class Reference

  • AIAnalogTrigger
Public Attributes | List of all members
JY5500CoreOO::AIAnalogTrigger Class Reference

#include <JY5500CoreOOAITask.h>

Public Attributes

AIAnalogTriggerSource Source
Analog Trigger source.
AIAnalogTriggerComparator Comparator
AI Analog Trigger Comparator.
AIAnalogEdgeComparator * Edge
AI Analog Edge Comparator.
AIAnalogHysteresisComparator * Hysteresis
AI Analog Hysteresis Comparatorr.
AIAnalogWindowComparator * Window
AI Analog Window Comparatorr.

Member Data Documentation

◆ Comparator

AIAnalogTriggerComparator JY5500CoreOO::AIAnalogTrigger::Comparator

AI Analog Trigger Comparator.

◆ Edge

AIAnalogEdgeComparator* JY5500CoreOO::AIAnalogTrigger::Edge

AI Analog Edge Comparator.

◆ Hysteresis

AIAnalogHysteresisComparator* JY5500CoreOO::AIAnalogTrigger::Hysteresis

AI Analog Hysteresis Comparatorr.

◆ Source

AIAnalogTriggerSource JY5500CoreOO::AIAnalogTrigger::Source

Analog Trigger source.

◆ Window

AIAnalogWindowComparator* JY5500CoreOO::AIAnalogTrigger::Window

AI Analog Window Comparatorr.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOAITask.h


5500 C++ Programming Manual: JY5500CoreOO::AIRecord Class Reference

  • AIRecord
Public Attributes | List of all members
JY5500CoreOO::AIRecord Class Reference

#include <JY5500CoreOOAITask.h>

Public Attributes

std::string | FilePath
User specified file path.
JY5500CoreOO::FileFormat File_Format
Streaming file format.
RecordMode Mode
stream mode .
double | Length
User specified stream length in second.

Member Data Documentation

◆ File_Format

JY5500CoreOO::FileFormat JY5500CoreOO::AIRecord::File_Format

Streaming file format.

enum BIN.

◆ FilePath

std::string JY5500CoreOO::AIRecord::FilePath

User specified file path.

◆ Length

double JY5500CoreOO::AIRecord::Length

User specified stream length in second.

Only when Mode is RecordMode.Finite.

◆ Mode

RecordMode JY5500CoreOO::AIRecord::Mode

stream mode .

enum Finite/Infinite.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOAITask.h


5500 C++ Programming Manual: JY5500CoreOO::AIDSMode Class Reference

  • AIDSMode
Public Attributes | List of all members
JY5500CoreOO::AIDSMode Class Reference

#include <JY5500CoreOOAITask.h>

Public Attributes

bool Enable
Enable DSMode.
JY5500CoreOO::PowerLineFrequency PowerLine_Frequency
AC Power Frequency.

Member Data Documentation

◆ Enable

bool JY5500CoreOO::AIDSMode::Enable

Enable DSMode.

◆ PowerLine_Frequency

JY5500CoreOO::PowerLineFrequency JY5500CoreOO::AIDSMode::PowerLine_Frequency

AC Power Frequency.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOAITask.h


5500 C++ Programming Manual: JY5500CoreOO::AIAdvanced Class Reference

  • AIAdvanced
Public Attributes | List of all members
JY5500CoreOO::AIAdvanced Class Reference

#include <JY5500CoreOOAITask.h>

Public Attributes

double ConvertRate
the convert rate of ADC.
AIDSMode * DSMode
DSMode Config.

Member Data Documentation

◆ ConvertRate

double JY5500CoreOO::AIAdvanced::ConvertRate

the convert rate of ADC.

◆ DSMode

AIDSMode* JY5500CoreOO::AIAdvanced::DSMode

DSMode Config.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOAITask.h


5500 C++ Programming Manual: JY5500CoreOO::AISignalExport Class Reference

  • AISignalExport
Public Member Functions | List of all members
JY5500CoreOO::AISignalExport Class Reference

#include <JY5500CoreOOAITask.h>

Public Member Functions

void | Add (AISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (AISignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Member Function Documentation

◆ Add() [1/2]

void JY5500CoreOO::AISignalExport::Add | ( | AISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | AI Signal Source
destination | Export Desination

◆ Add() [2/2]

void JY5500CoreOO::AISignalExport::Add | ( | AISignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | AI Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JY5500CoreOO::AISignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5500CoreOO::AISignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOAITask.h


5500 C++ Programming Manual: JY5500CoreOO Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Enumerations | Functions
JY5500CoreOO Namespace Reference

Classes

class | AIAdvanced
class | AIAnalogEdgeComparator
class | AIAnalogHysteresisComparator
class | AIAnalogTrigger
class | AIAnalogWindowComparator
class | AIChannel
class | AIDigitalTrigger
class | AIDSMode
class | AIExternalSampleClock
class | AIRecord
class | AISampleClock
class | AISignalExport
class | AITrigger
class | AOChannel
class | AODigitalTrigger
AO Digital trigger . More...
class | AOExternalSampleClock
External Sample Clock Configuration Class. More...
class | AOSampleClock
AO Sample clock configuration class. More...
class | AOSignalExport
AO Signal Export Class. More...
class | AOTrigger
Constructor to create an AOTrigger task object. More...
class | CIDigitalTrigger
CI Digital trigger . More...
class | CIExternalSampleClock
CI Implicit Sample Clock class. More...
class | CIImplicitSampleClock
CI Implicit Sample Clock class. More...
class | CIInternalSampleClock
CI Internal Sample Clock Configuration Class. More...
class | CISampleClock
CI Sample Clock class. More...
class | CISignalExport
CI Signal Export Class. More...
class | CITimebase
Timebase configuration class. More...
class | CITrigger
Constructor to create an CITrigger task object. More...
class | CODigitalTrigger
CO Digital trigger . More...
class | COPulse
Pulse Parameter. More...
class | COSignalExport
CO Signal Export Class. More...
class | COTimebase
Timebase configuration class. More...
class | COTrigger
Constructor to create an COTrigger task object. More...
class | DIChannel
DI Channel parameter class . More...
class | DIDigitalTrigger
DI Digital trigger . More...
class | DIExternalSampleClock
External Sample Clock Configuration Class. More...
class | DISampleClock
Sample clock configuration class. More...
class | DISignalExport
DI Signal Export Class. More...
class | DITrigger
Constructor to create an DITrigger task object. More...
class | DOChannel
DO Channel parameter class . More...
class | DODigitalTrigger
DO Digital trigger. More...
class | DOExternalSampleClock
External Sample Clock Configuration Class. More...
class | DOSampleClock
Sample clock configuration class. More...
class | DOSignalExport
DO Signal Export Class. More...
class | DOTrigger
Constructor to create an DOTrigger task object. More...
class | EdgeCounting
Configure CI EdgeCounting. More...
class | EdgeCountingOutEvent
Edge counting output event configuration class. More...
class | ExternalReferenceClock
class | FrequencyMeas
Configure CI Measure. More...
class | JY5500CoreOOAITask
AITask类 More...
class | JY5500CoreOOAOTask
class | JY5500CoreOOCITask
class | JY5500CoreOOCOTask
class | JY5500CoreOODevice
class | JY5500CoreOODITask
class | JY5500CoreOODOTask
class | JY5500CoreOOLog
class | JY5500CoreOOProperty
属性模板类 More...
class | JY5500CoreOOReferenceClock
class | JYDriverException
class | PauseTrigger
Pause trigger configuration class. More...
class | PeriodMeas
Configure CI Measure. More...
class | PFIFilter
class | PFISetting
class | PulseMeas
Configure CI Measure. More...
class | QuadEncoder
Configure CI Measure. More...
class | TwoEdgeSeparation
Configure CI Measure. More...
class | TwoPulseEncoder
Configure CI Measure. More...

Enumerations

enum class | AITerminal { RSE = 0x0 , NRSE = 0x1 , Differential = 0x2 }
enum class | AIMode { Single = 0x2 , Finite = 0x0 , Continuous = 0x1 , Record = 0x3 }
enum class | AISampleClockSource { Internal , External }
enum class | AITriggerType { Immediate = 0x0 , Digital = 0x1 , Analog = 0x2 , Soft = 0x3 }
enum class | AITriggerMode { Start , Reference }
enum class AIAnalogTriggerSource {
Channel_0 , Channel_1 , Channel_2 , Channel_3 ,
Channel_4 , Channel_5 , Channel_6 , Channel_7 ,
Channel_8 , Channel_9 , Channel_10 , Channel_11 ,
Channel_12 , Channel_13 , Channel_14 , Channel_15 ,
Channel_16 , Channel_17 , Channel_18 , Channel_19 ,
Channel_20 , Channel_21 , Channel_22 , Channel_23 ,
Channel_24 , Channel_25 , Channel_26 , Channel_27 ,
Channel_28 , Channel_29 , Channel_30 , Channel_31
}
enum class AIDigitalTriggerSource {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PFI8 , PFI9 , PFI10 , PFI11 ,
PFI12 , PFI13 , PFI14 , PFI15 ,
PXI_Trig0 = 40 , PXI_Trig1 = 41 , PXI_Trig2 = 42 , PXI_Trig3 = 43 ,
PXI_Trig4 = 44 , PXI_Trig5 = 45 , PXI_Trig6 = 46 , PXI_Trig7 = 47 ,
AO_StartTrig = 26 , DI_StartTrig = 22 , DI_ReferenceTrig = 23 , DO_StartTrig = 29 ,
CI_0_StartTrig = 68 , CI_1_StartTrig = 73 , CI_2_StartTrig = 76 , CI_3_StartTrig = 79 ,
CO_0_StartTrig = 69 , CO_1_StartTrig = 74 , CO_2_StartTrig = 77 , CO_3_StartTrig = 80 ,
CO_0_Output = 37 , CO_1_Output = 51 , CO_2_Output = 60 , CO_3_Output = 66
}
enum class | AIDigitalTriggerEdge { Rising = 0x0 , Falling = 0x1 }
enum class | AIAnalogTriggerEdge { Rising , Falling }
enum class | AIAnalogWindowCondition { Entering , Leaving }
AI Analog Window Trigger Condition. More...
enum class | AIAnalogTriggerComparator { Edge , Hysteresis , Window }
AI Analog Trigger Comparator. More...
enum class | AISignalExportSource { StartTrig = 16 , ReferenceTrig = 17 , SampleClock = 20 }
enum class | FileFormat { Bin }
enum class | RecordMode { Finite , Infinite }
enum class | PowerLineFrequency { _50Hz , _60Hz }
enum class | AOMode { Single = 3 , Finite = 0 , ContinuousNoWrapping = 2 , ContinuousWrapping = 1 }
enum class | AODigitalTriggerEdge { Rising , Falling }
AO Digital Trigger Edge. More...
enum class AODigitalTriggerSource {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PFI8 , PFI9 , PFI10 , PFI11 ,
PFI12 , PFI13 , PFI14 , PFI15 ,
PXI_Trig0 = 40 , PXI_Trig1 = 41 , PXI_Trig2 = 42 , PXI_Trig3 = 43 ,
PXI_Trig4 = 44 , PXI_Trig5 = 45 , PXI_Trig6 = 46 , PXI_Trig7 = 47 ,
AI_StartTrig = 16 , AI_ReferenceTrig = 17 , DI_StartTrig = 22 , DI_ReferenceTrig = 23 ,
DO_StartTrig = 29 , CI_0_StartTrig = 68 , CI_1_StartTrig = 73 , CI_2_StartTrig = 76 ,
CI_3_StartTrig = 79 , CO_0_StartTrig = 69 , CO_1_StartTrig = 74 , CO_2_StartTrig = 77 ,
CO_3_StartTrig = 80 , CO_0_Output = 37 , CO_1_Output = 51 , CO_2_Output = 60 ,
CO_3_Output = 66
}
AO Digital trigger source. More...
enum class | AOSampleClockSource { Internal , External }
AO Sample Clock Source. More...
enum class | AOSignalExportSource { StartTrig = 26 , SampleClock = 28 }
SourceSignal. More...
enum class | AOTriggerType { Immediate = 0x0 , Digital = 0x1 , Soft = 0x3 }
TriggerType Digital/Immediate/Soft. More...
enum class | CountDirection { Up = 0x0 , Down = 0x1 , External = 0x2 }
Counter direction. More...
enum class | CIMode { Single = 2 , Finite = 0 , Continuous = 1 }
CIMode. More...
enum class CIType {
EdgeCounting , Period , Frequency , Pulse ,
TwoEdgeSeparation , QuadEncoder , TwoPulseEncoder
}
Counter Input Application Type. More...
enum class | CISampleClockSource { Implicit = 0x0 , Internal = 0x1 , External = 0x2 }
CI Sample Clock Source. More...
enum class | EdgeType { Rising , Falling }
Edge Type. More...
enum class | QuadEncodingType { X1 , X2 , X4 }
Quadrature Encoding Type. More...
enum class | CITriggerType { Immediate = 0x0 , Digital = 0x1 , Soft = 0x3 }
TriggerType Digital/Immediate/Soft. More...
enum class CIDigitalTriggerSource {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PFI8 , PFI9 , PFI10 , PFI11 ,
PFI12 , PFI13 , PFI14 , PFI15 ,
PXI_Trig0 = 40 , PXI_Trig1 = 41 , PXI_Trig2 = 42 , PXI_Trig3 = 43 ,
PXI_Trig4 = 44 , PXI_Trig5 = 45 , PXI_Trig6 = 46 , PXI_Trig7 = 47 ,
AI_StartTrig = 16 , AI_ReferenceTrig = 17 , AO_StartTrig = 26 , DI_StartTrig = 22 ,
DI_ReferenceTrig = 23 , DO_StartTrig = 29 , CI_0_StartTrig = 68 , CI_1_StartTrig = 73 ,
CI_2_StartTrig = 76 , CI_3_StartTrig = 79 , CO_0_StartTrig = 69 , CO_1_StartTrig = 74 ,
CO_2_StartTrig = 77 , CO_3_StartTrig = 80 , CO_0_Output = 37 , CO_1_Output = 51 ,
CO_2_Output = 60 , CO_3_Output = 66
}
CI Digital trigger source. More...
enum class | CIDigitalTriggerEdge { Rising , Falling }
CI Digital Trigger Edge. More...
enum class | EdgeCntOunEvtIdleState { LowLevel = 0 , HighLevel = 1 }
Output idle state when the event has not occurred. More...
enum class | CISignalExportSource { StartTrig , SampleClock }
SourceSignal. More...
enum class | CITimebaseSource { Internal200MHz }
Timebase source. More...
enum class | JY5500CoreOOPropertyType { READ_ONLY = 1 , WRITE_ONLY = 2 , READ_WRITE = 3 }
enum class JYDriverExceptionPublic {
UnKnown = 0 , OpenDeviceFailed = -10001 , CloseDeviceFailed = -10002 , ResetDeviceFailed = -10003 ,
GetDevicePropertyFailed = -10004 , SetDevicePropertyFailed = -10005 , HardwareResourceIsReserved = -10006 , MethodNotPermitedToCallWhenCurrentStatus = -10007 ,
InvalidUserDataBuffer = -10008 , NoChannelAdded = -10009 , NotSupportOperationForCurrentDevice = -10010 , CreatTaskFailed = -10100 ,
StartTaskFailed = -10101 , StopTaskFailed = -10102 , TaskHasNotStarted = -10103 , TaskHasStartedCannotPerformTheSetOperation = -10104 ,
ChannelNumberParameterInvalid = -10105 , ChannelInputRangeParameterInvalid = -10106 , ChannelTerminalParameterInvalid = -10107 , ChannelCouplingParameterInvalid = -10108 ,
SampeleModeParameterInvalid = -10109 , SampleClockParameterInvalid = -10110 , SampleRateParameterInvalid = -10111 , UpdateRateParameterInvalid = -10112 ,
TriggerParameterInvalid = -10113 , ReferenceTriggerDoesNotMatchWithSampleMode = -10114 , PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint = -10115 , ReadDataFailed = -10016 ,
ReadDataTimeout = -10017 , WriteDataFailed = -10018 , WriteDataTimeout = -10019 , WriteDataLengthCannotBeLessThanN = -10020 ,
BufferDataOverflow = -10021 , BufferDataDownflow = -10022 , CheckBufferFailed = -10023 , PointInvalidInFiniteMode = -10024 ,
ReadPointInvalid = -10025 , OnlySupportRecordMode = -10026 , SendSoftTirggerFailed = -10027 , TaskTimeout = -10028 ,
CounterParametersInvalid = -10029 , WritePointInvalid = -10030 , SignalExportDestinationInvalid = -10031 , InvalidParameter = -10033
}
enum class ClockTerminal {
ECLK = 10000 , PFI0 = 0 , PFI1 = 1 , PFI2 = 2 ,
PFI3 = 3 , PFI4 = 4 , PFI5 = 5 , PFI6 = 6 ,
PFI7 = 7 , PFI8 = 8 , PFI9 = 9 , PFI10 = 10 ,
PFI11 = 11 , PFI12 = 12 , PFI13 = 13 , PFI14 = 14 ,
PFI15 = 15 , PXI_Trig0 = 40 , PXI_Trig1 = 41 , PXI_Trig2 = 42 ,
PXI_Trig3 = 43 , PXI_Trig4 = 44 , PXI_Trig5 = 45 , PXI_Trig6 = 46 ,
PXI_Trig7 = 47 , AI_SampleClock = 20 , AO_SampleClock = 28 , DI_SampleClock = 53 ,
DO_SampleClock = 54 , CI0_SampleClock = 36 , CI1_SampleClock = 50 , CI2_SampleClock = 59 ,
CI3_SampleClock = 65 , CO_0_Output = 37 , CO_1_Output = 51 , CO_2_Output = 60 ,
CO_3_Output = 66
}
enum class SignalExportDestination {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PFI8 , PFI9 , PFI10 , PFI11 ,
PFI12 , PFI13 , PFI14 , PFI15 ,
PXI_Trig0 = 0x20 , PXI_Trig1 = 0x21 , PXI_Trig2 = 0x22 , PXI_Trig3 = 0x23 ,
PXI_Trig4 = 0x24 , PXI_Trig5 = 0x25 , PXI_Trig6 = 0x26 , PXI_Trig7 = 0x27
}
enum class | OutputCompleteState { Zero , Hold }
Output Complete State. More...
enum class IOTerminal {
Default = 0 , PXI_Trig0 = 0x20 , PXI_Trig1 = 0x21 , PXI_Trig2 = 0x22 ,
PXI_Trig3 = 0x23 , PXI_Trig4 = 0x24 , PXI_Trig5 = 0x25 , PXI_Trig6 = 0x26 ,
PXI_Trig7 = 0x27
}
Cunter IO Terminal. More...
enum class | LevelPolarity { LowLevel = 0 , HighLevel = 1 , None = 2 }
Level Polarity. More...
enum class InputTerminal {
Default = 0 , PXI_Trig0 = 40 , PXI_Trig1 = 41 , PXI_Trig2 = 42 ,
PXI_Trig3 = 43 , PXI_Trig4 = 44 , PXI_Trig5 = 45 , PXI_Trig6 = 46 ,
PXI_Trig7 = 47 , CI_0_OutPut = 37 , CI_1_OutPut = 51 , CI_2_OutPut = 60 ,
CI_3_OutPut = 66
}
Cunter Input Terminal. More...
enum class | COIdleState { HighLevel = 0x1 , LowLevel = 0x0 }
Idle state when pulse output before start and after stop. More...
enum class | COMode { Single = 3 , Finite = 0 , ContinuousNoWrapping = 2 , ContinuousWrapping = 1 }
enum class | COTriggerType { Immediate = 0x0 , Digital = 0x1 , Soft = 0x3 }
TriggerType Digital/Immediate/Soft. More...
enum class CODigitalTriggerSource {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PFI8 , PFI9 , PFI10 , PFI11 ,
PFI12 , PFI13 , PFI14 , PFI15 ,
PXI_Trig0 = 40 , PXI_Trig1 = 41 , PXI_Trig2 = 42 , PXI_Trig3 = 43 ,
PXI_Trig4 = 44 , PXI_Trig5 = 45 , PXI_Trig6 = 46 , PXI_Trig7 = 47 ,
AI_StartTrig = 16 , AI_ReferenceTrig = 17 , AO_StartTrig = 26 , DI_StartTrig = 22 ,
DI_ReferenceTrig = 23 , DO_StartTrig = 29 , CI_0_StartTrig = 68 , CI_1_StartTrig = 73 ,
CI_2_StartTrig = 76 , CI_3_StartTrig = 79 , CO_0_StartTrig = 69 , CO_1_StartTrig = 74 ,
CO_2_StartTrig = 77 , CO_3_StartTrig = 80
}
CO Digital trigger source. More...
enum class | CODigitalTriggerEdge { Rising , Falling }
CO Digital Trigger Edge. More...
enum class | COPulseType { DutyCycleFrequency , HighLowTime , HighLowTick }
Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick. More...
enum class | COTimebaseSource { Internal200MHz }
Timebase source. More...
enum class | COSignalExportSource { StartTrig , Output }
SourceSignal. More...
enum class | ExternalReferenceClockTerminal { PXIe_Clk100 = 0x1 }
enum class | ReferenceClockSource { Internal = 0x0 , External = 0x1 }
enum class PFITerminal {
PFI0 = 0 , PFI1 = 1 , PFI2 = 2 , PFI3 = 3 ,
PFI4 = 4 , PFI5 = 5 , PFI6 = 6 , PFI7 = 7 ,
PFI8 = 8 , PFI9 = 9 , PFI10 = 10 , PFI11 = 11 ,
PFI12 = 12 , PFI13 = 13 , PFI14 = 14 , PFI15 = 15
}
Input/Output Terminal of PFI. More...
enum class | DISampleClockSource { Internal , External }
DI Sample Clock Source. More...
enum class | DIMode { Single = 2 , Finite = 0 , Continuous = 1 }
DIMode. More...
enum class | DISignalExportSource { StartTrig = 22 , ReferenceTrig = 23 , SampleClock = 53 }
SourceSignal. More...
enum class | DITriggerMode { Start , Reference }
DI Trigger Mode. More...
enum class | DITriggerType { Immediate = 0 , Digital = 1 , Soft = 3 }
TriggerType Digital/Immediate/Soft. More...
enum class DIDigitalTriggerSource {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PFI8 , PFI9 , PFI10 , PFI11 ,
PFI12 , PFI13 , PFI14 , PFI15 ,
PXI_Trig0 = 40 , PXI_Trig1 = 41 , PXI_Trig2 = 42 , PXI_Trig3 = 43 ,
PXI_Trig4 = 44 , PXI_Trig5 = 45 , PXI_Trig6 = 46 , PXI_Trig7 = 47 ,
AI_StartTrig = 16 , AI_ReferenceTrig = 17 , AO_StartTrig = 26 , DO_StartTrig = 29 ,
CI_0_StartTrig = 68 , CI_1_StartTrig = 73 , CI_2_StartTrig = 73 , CI_3_StartTrig = 73 ,
CO_0_StartTrig = 69 , CO_1_StartTrig = 74 , CO2_StartTrig = 77 , CO_3_StartTrig = 80 ,
CO_0_Output = 37 , CO_1_Output = 51 , CO_2_Output = 60 , CO_3_Output = 66
}
DI Digital trigger source. More...
enum class | DIDigitalTriggerEdge { Rising , Falling }
DI Digital Trigger Edge. More...
enum class | DOSampleClockSource { Internal , External }
DO Sample Clock Source. More...
enum class | DOMode { Single = 3 , Finite = 0 , ContinuousWrapping = 1 , ContinuousNoWrapping = 2 }
DOMode. More...
enum class | DODigitalTriggerEdge { Rising , Falling }
DO Digital Trigger Edge. More...
enum class DODigitalTriggerSource {
PFI0 , PFI1 , PFI2 , PFI3 ,
PFI4 , PFI5 , PFI6 , PFI7 ,
PFI8 , PFI9 , PFI10 , PFI11 ,
PFI12 , PFI13 , PFI14 , PFI15 ,
PXI_Trig0 = 40 , PXI_Trig1 = 41 , PXI_Trig2 = 42 , PXI_Trig3 = 43 ,
PXI_Trig4 = 44 , PXI_Trig5 = 45 , PXI_Trig6 = 46 , PXI_Trig7 = 47 ,
AI_StartTrig = 16 , AI_ReferenceTrig = 17 , AO_StartTrig = 26 , DI_StartTrig = 22 ,
DI_ReferenceTrig = 23 , CI_0_StartTrig = 68 , CI_1_StartTrig = 73 , CI_2_StartTrig = 76 ,
CI_3_StartTrig = 79 , CO_0_StartTrig = 69 , CO_1_StartTrig = 74 , CO_2_StartTrig = 77 ,
CO_3_StartTrig = 80 , CO_0_Output = 37 , CO_1_Output = 51 , CO_2_Output = 60 ,
CO_3_Output = 66
}
DO Digital trigger source. More...
enum class | DOTriggerType { Immediate = 0 , Digital = 1 , Soft = 3 }
TriggerType Digital/Immediate/Soft. More...
enum class | DOSignalExportSource { StartTrig = 29 , SampleClock = 54 }
SourceSignal. More...
enum class JY5500CoreOOLogLevel {
DEBUG_LOG_LEVEL , INFO_LOG_LEVEL , WARN_LOG_LEVEL , ERROR_LOG_LEVEL ,
FATAL_LOG_LEVEL
}

Functions

std::string GetSignalExportDestinationString (SignalExportDestination destination)

Enumeration Type Documentation

◆ AIAnalogTriggerComparator

enum class JY5500CoreOO::AIAnalogTriggerComparator
strong

AI Analog Trigger Comparator.

Enumerator
Edge | Edge Comparator.
Hysteresis | Hysteresis Comparator.
Window | Window Comparator.

◆ AIAnalogTriggerEdge

enum class JY5500CoreOO::AIAnalogTriggerEdge
strong
Enumerator
Rising | Rising.
Falling | Falling.

◆ AIAnalogTriggerSource

enum class JY5500CoreOO::AIAnalogTriggerSource
strong
Enumerator
Channel_0 | Channel_0 as the trigger source.
Channel_1 | Channel_1 as the trigger source.
Channel_2 | Channel_2 as the trigger source.
Channel_3 | Channel_3 as the trigger source.
Channel_4 | Channel_4 as the trigger source.
Channel_5 | Channel_5 as the trigger source.
Channel_6 | Channel_6 as the trigger source.
Channel_7 | Channel_7 as the trigger source.
Channel_8 | Channel_8 as the trigger source.
Channel_9 | Channel_9 as the trigger source.
Channel_10 | Channel_10 as the trigger source.
Channel_11 | Channel_11 as the trigger source.
Channel_12 | Channel_12 as the trigger source.
Channel_13 | Channel_13 as the trigger source.
Channel_14 | Channel_14 as the trigger source.
Channel_15 | Channel_15 as the trigger source.
Channel_16 | Channel_16 as the trigger source.
Channel_17 | Channel_17 as the trigger source.
Channel_18 | Channel_18 as the trigger source.
Channel_19 | Channe_l9 as the trigger source.
Channel_20 | Channel_20 as the trigger source.
Channel_21 | Channel_21 as the trigger source.
Channel_22 | Channel_22 as the trigger source.
Channel_23 | Channel_23 as the trigger source.
Channel_24 | Channel_24 as the trigger source.
Channel_25 | Channel_25 as the trigger source.
Channel_26 | Channel_26 as the trigger source.
Channel_27 | Channel_27 as the trigger source.
Channel_28 | Channel_28 as the trigger source.
Channel_29 | Channel_29 as the trigger source.
Channel_30 | Channel_30 as the trigger source.
Channel_31 | Channel_31 as the trigger source.

◆ AIAnalogWindowCondition

enum class JY5500CoreOO::AIAnalogWindowCondition
strong

AI Analog Window Trigger Condition.

Enumerator
Entering | Rising.
Leaving | Falling.

◆ AIDigitalTriggerEdge

enum class JY5500CoreOO::AIDigitalTriggerEdge
strong
Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ AIDigitalTriggerSource

enum class JY5500CoreOO::AIDigitalTriggerSource
strong
Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11.
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.
AO_StartTrig | AO_StartTrig.
DI_StartTrig | DI_StartTrig.
DI_ReferenceTrig | DI_ReferenceTrig.
DO_StartTrig | DO_StartTrig.
CI_0_StartTrig | CI0_StartTrig.
CI_1_StartTrig | CI1_StartTrig.
CI_2_StartTrig | CI2_StartTrig.
CI_3_StartTrig | CI3_StartTrig.
CO_0_StartTrig | CO0_StartTrig.
CO_1_StartTrig | CO0_StartTrig.
CO_2_StartTrig | CO0_StartTrig.
CO_3_StartTrig | CO0_StartTrig.
CO_0_Output | CO_0_Output.
CO_1_Output | CO_1_Output.
CO_2_Output | CO_2_Output.
CO_3_Output | CO_3_Output.

◆ AIMode

enum class JY5500CoreOO::AIMode
strong
Enumerator
Single
Finite
Continuous
Record

◆ AISampleClockSource

enum class JY5500CoreOO::AISampleClockSource
strong
Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ AISignalExportSource

enum class JY5500CoreOO::AISignalExportSource
strong
Enumerator
StartTrig | AI_StartTrig.
ReferenceTrig | AI_ReferenceTrig.
SampleClock | AI_SampleClock.

◆ AITerminal

enum class JY5500CoreOO::AITerminal
strong
Enumerator
RSE
NRSE
Differential

◆ AITriggerMode

enum class JY5500CoreOO::AITriggerMode
strong
Enumerator
Start | Start Trigger.
Reference | Reference Trigger，Valid when JY5500AITask.Mode is AIMode.Finite

◆ AITriggerType

enum class JY5500CoreOO::AITriggerType
strong
Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Analog | Analog Trigger.
Soft | Soft Trigger.

◆ AODigitalTriggerEdge

enum class JY5500CoreOO::AODigitalTriggerEdge
strong

AO Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ AODigitalTriggerSource

enum class JY5500CoreOO::AODigitalTriggerSource
strong

AO Digital trigger source.

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11.
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
DI_StartTrig | DI_StartTrig.
DI_ReferenceTrig | DI_ReferenceTrig.
DO_StartTrig | DO_StartTrig.
CI_0_StartTrig | CI0_StartTrig.
CI_1_StartTrig | CI1_StartTrig.
CI_2_StartTrig | CI2_StartTrig.
CI_3_StartTrig | CI3_StartTrig.
CO_0_StartTrig | CO0_StartTrig.
CO_1_StartTrig | CO0_StartTrig.
CO_2_StartTrig | CO0_StartTrig.
CO_3_StartTrig | CO0_StartTrig.
CO_0_Output | CO_0_Output.
CO_1_Output | CO_1_Output.
CO_2_Output | CO_2_Output.
CO_3_Output | CO_3_Output.

◆ AOMode

enum class JY5500CoreOO::AOMode
strong
Enumerator
Single | Single.
Finite | Finite.
ContinuousNoWrapping | ContinuousNoWrapping.
ContinuousWrapping | ContinuousWrapping.

◆ AOSampleClockSource

enum class JY5500CoreOO::AOSampleClockSource
strong

AO Sample Clock Source.

Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ AOSignalExportSource

enum class JY5500CoreOO::AOSignalExportSource
strong

SourceSignal.

Enumerator
StartTrig | AO_StartTrig.
SampleClock | AO_SampleClock.

◆ AOTriggerType

enum class JY5500CoreOO::AOTriggerType
strong

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ CIDigitalTriggerEdge

enum class JY5500CoreOO::CIDigitalTriggerEdge
strong

CI Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ CIDigitalTriggerSource

enum class JY5500CoreOO::CIDigitalTriggerSource
strong

CI Digital trigger source.

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11.
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
AO_StartTrig | AO_StartTrig.
DI_StartTrig | DI_StartTrig.
DI_ReferenceTrig | DI_ReferenceTrig.
DO_StartTrig | DO_StartTrig.
CI_0_StartTrig | CI0_StartTrig.
CI_1_StartTrig | CI1_StartTrig.
CI_2_StartTrig | CI2_StartTrig.
CI_3_StartTrig | CI3_StartTrig.
CO_0_StartTrig | CO0_StartTrig.
CO_1_StartTrig | CO0_StartTrig.
CO_2_StartTrig | CO0_StartTrig.
CO_3_StartTrig | CO0_StartTrig.
CO_0_Output | CO_0_Output.
CO_1_Output | CO_1_Output.
CO_2_Output | CO_2_Output.
CO_3_Output | CO_3_Output.

◆ CIMode

enum class JY5500CoreOO::CIMode
strong

CIMode.

Enumerator
Single | Single.
Finite | Finite.
Continuous | Continuous.

◆ CISampleClockSource

enum class JY5500CoreOO::CISampleClockSource
strong

CI Sample Clock Source.

Enumerator
Implicit | Implicit.
Internal | Internal.
External | External.

◆ CISignalExportSource

enum class JY5500CoreOO::CISignalExportSource
strong

SourceSignal.

Enumerator
StartTrig | CI_StartTrig.
SampleClock | CI_SampleClock.

◆ CITimebaseSource

enum class JY5500CoreOO::CITimebaseSource
strong

Timebase source.

Enumerator
Internal200MHz

Internal 200MHz Timebase.

◆ CITriggerType

enum class JY5500CoreOO::CITriggerType
strong

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ CIType

enum class JY5500CoreOO::CIType
strong

Counter Input Application Type.

Enumerator
EdgeCounting | Edge Counting.
Period | Period Measure.
Frequency | Frequenc Measure.
Pulse | Pulse Measure.
TwoEdgeSeparation | TwoEdgeSeparation Measure.
QuadEncoder | QuadEncoder.
TwoPulseEncoder | EncoderTwoPulse.

◆ ClockTerminal

enum class JY5500CoreOO::ClockTerminal
strong
Enumerator
ECLK | Extetnal Clock Terminal by Pin Define.
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11.
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PXI_Trig0 | PXITrigger_0.
PXI_Trig1 | PXITrigger_1.
PXI_Trig2 | PXITrigger_2.
PXI_Trig3 | PXITrigger_3.
PXI_Trig4 | PXITrigger_4.
PXI_Trig5 | PXITrigger_5.
PXI_Trig6 | PXITrigger_6.
PXI_Trig7 | PXITrigger_7.
AI_SampleClock | AI_SampleClock.
AO_SampleClock | AO_SampleClock.
DI_SampleClock | DI_SampleClock.
DO_SampleClock | DO_SampleClock.
CI0_SampleClock | CI0_SampleClock.
CI1_SampleClock | CI1_SampleClock.
CI2_SampleClock | CI2_SampleClock.
CI3_SampleClock | CI3_SampleClock.
CO_0_Output | CO_0_Output.
CO_1_Output | CO_1_Output.
CO_2_Output | CO_2_Output.
CO_3_Output | CO_3_Output.

◆ CODigitalTriggerEdge

enum class JY5500CoreOO::CODigitalTriggerEdge
strong

CO Digital Trigger Edge.

Enumerator
Rising | Rising Edge.
Falling | Falling Edge.

◆ CODigitalTriggerSource

enum class JY5500CoreOO::CODigitalTriggerSource
strong

CO Digital trigger source.

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11.
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
AO_StartTrig | AO_StartTrig.
DI_StartTrig | DI_StartTrig.
DI_ReferenceTrig | DI_ReferenceTrig.
DO_StartTrig | DO_StartTrig.
CI_0_StartTrig | CI0_StartTrig.
CI_1_StartTrig | CI1_StartTrig.
CI_2_StartTrig | CI2_StartTrig.
CI_3_StartTrig | CI3_StartTrig.
CO_0_StartTrig | CO0_StartTrig.
CO_1_StartTrig | CO0_StartTrig.
CO_2_StartTrig | CO0_StartTrig.
CO_3_StartTrig | CO0_StartTrig.

◆ COIdleState

enum class JY5500CoreOO::COIdleState
strong

Idle state when pulse output before start and after stop.

Enumerator
HighLevel | Idle state is high level.
LowLevel | Idle state is low level.

◆ COMode

enum class JY5500CoreOO::COMode
strong
Enumerator
Single | Single pulse output.
Finite | Finite.
ContinuousNoWrapping | ContinuousNoWrapping.
ContinuousWrapping | ContinuousWrapping.

◆ COPulseType

enum class JY5500CoreOO::COPulseType
strong

Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick.

Enumerator
DutyCycleFrequency | Configure CO output pulse according to its DutyCycle and Freqency.
HighLowTime | Configure CO output pulse according to duration of its high/low voltage levels.
HighLowTick | Configure CO output pulse according to its high/low tick level.

◆ COSignalExportSource

enum class JY5500CoreOO::COSignalExportSource
strong

SourceSignal.

Enumerator
StartTrig | CI_StartTrig.
Output | CO_Output.

◆ COTimebaseSource

enum class JY5500CoreOO::COTimebaseSource
strong

Timebase source.

Enumerator
Internal200MHz

Internal 200MHz Timebase.

◆ COTriggerType

enum class JY5500CoreOO::COTriggerType
strong

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ CountDirection

enum class JY5500CoreOO::CountDirection
strong

Counter direction.

enum Up/Down/External

Enumerator
Up | Counter increases.
Down | Counter decreases.
External | External signal control counter direction. If External signal is highlevel counter increases, or lowlevel counter decreases.

◆ DIDigitalTriggerEdge

enum class JY5500CoreOO::DIDigitalTriggerEdge
strong

DI Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ DIDigitalTriggerSource

enum class JY5500CoreOO::DIDigitalTriggerSource
strong

DI Digital trigger source.

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11.
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
AO_StartTrig | AO_StartTrig.
DO_StartTrig | DO_StartTrig.
CI_0_StartTrig | CI0_StartTrig.
CI_1_StartTrig | CI1_StartTrig.
CI_2_StartTrig | CI2_StartTrig.
CI_3_StartTrig | CI3_StartTrig.
CO_0_StartTrig | CO0_StartTrig.
CO_1_StartTrig | CO0_StartTrig.
CO2_StartTrig | CO0_StartTrig.
CO_3_StartTrig | CO0_StartTrig.
CO_0_Output | CO_0_Output.
CO_1_Output | CO_1_Output.
CO_2_Output | CO_2_Output.
CO_3_Output | CO_3_Output.

◆ DIMode

enum class JY5500CoreOO::DIMode
strong

DIMode.

Enumerator
Single | Single.
Finite | Finite.
Continuous | Continuous.

◆ DISampleClockSource

enum class JY5500CoreOO::DISampleClockSource
strong

DI Sample Clock Source.

Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ DISignalExportSource

enum class JY5500CoreOO::DISignalExportSource
strong

SourceSignal.

Enumerator
StartTrig | DI_StartTrig.
ReferenceTrig | DI_ReferenceTrig.
SampleClock | DI_SampleClock.

◆ DITriggerMode

enum class JY5500CoreOO::DITriggerMode
strong

DI Trigger Mode.

Enumerator
Start | Start Trigger.
Reference | Reference Trigger，only for finite acquisition mode.

◆ DITriggerType

enum class JY5500CoreOO::DITriggerType
strong

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ DODigitalTriggerEdge

enum class JY5500CoreOO::DODigitalTriggerEdge
strong

DO Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ DODigitalTriggerSource

enum class JY5500CoreOO::DODigitalTriggerSource
strong

DO Digital trigger source.

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11.
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.
AO_StartTrig | AO_StartTrig.
DI_StartTrig | DI_StartTrig.
DI_ReferenceTrig | DI_ReferenceTrig.
CI_0_StartTrig | CI0_StartTrig.
CI_1_StartTrig | CI1_StartTrig.
CI_2_StartTrig | CI2_StartTrig.
CI_3_StartTrig | CI3_StartTrig.
CO_0_StartTrig | CO0_StartTrig.
CO_1_StartTrig | CO0_StartTrig.
CO_2_StartTrig | CO0_StartTrig.
CO_3_StartTrig | CO0_StartTrig.
CO_0_Output | CO_0_Output.
CO_1_Output | CO_1_Output.
CO_2_Output | CO_2_Output.
CO_3_Output | CO_3_Output.

◆ DOMode

enum class JY5500CoreOO::DOMode
strong

DOMode.

Enumerator
Single | Single.
Finite | Finite.
ContinuousWrapping | ContinuousNoWrapping.
ContinuousNoWrapping | ContinuousWrapping.

◆ DOSampleClockSource

enum class JY5500CoreOO::DOSampleClockSource
strong

DO Sample Clock Source.

Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ DOSignalExportSource

enum class JY5500CoreOO::DOSignalExportSource
strong

SourceSignal.

Enumerator
StartTrig | DO_StartTrig.
SampleClock | DO_SampleClock.

◆ DOTriggerType

enum class JY5500CoreOO::DOTriggerType
strong

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ EdgeCntOunEvtIdleState

enum class JY5500CoreOO::EdgeCntOunEvtIdleState
strong

Output idle state when the event has not occurred.

Enumerator
LowLevel | Idle state is low level.
HighLevel | Idle state is high level.

◆ EdgeType

enum class JY5500CoreOO::EdgeType
strong

Edge Type.

Enumerator
Rising | Rising Edge.
Falling | Falling Edge.

◆ ExternalReferenceClockTerminal

enum class JY5500CoreOO::ExternalReferenceClockTerminal
strong
Enumerator
PXIe_Clk100

PXIe_Clk100.

◆ FileFormat

enum class JY5500CoreOO::FileFormat
strong
Enumerator
Bin

BIN。

BIN.

◆ InputTerminal

enum class JY5500CoreOO::InputTerminal
strong

Cunter Input Terminal.

Enumerator
Default | Default PFI pin by pin define.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
CI_0_OutPut | CI0_StartTrig.
CI_1_OutPut | CI1_StartTrig.
CI_2_OutPut | CI0_StartTrig.
CI_3_OutPut | CI1_StartTrig.

◆ IOTerminal

enum class JY5500CoreOO::IOTerminal
strong

Cunter IO Terminal.

Enumerator
Default | Default PFI pin by pin define.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.

◆ JY5500CoreOOLogLevel

enum class JY5500CoreOO::JY5500CoreOOLogLevel
strong
Enumerator
DEBUG_LOG_LEVEL
INFO_LOG_LEVEL
WARN_LOG_LEVEL
ERROR_LOG_LEVEL
FATAL_LOG_LEVEL

◆ JY5500CoreOOPropertyType

enum class JY5500CoreOO::JY5500CoreOOPropertyType
strong
Enumerator
READ_ONLY
WRITE_ONLY
READ_WRITE

◆ JYDriverExceptionPublic

enum class JY5500CoreOO::JYDriverExceptionPublic
strong
Enumerator
UnKnown | JYDriverExceptionPublic.
OpenDeviceFailed | JYDriverExceptionPublic.
CloseDeviceFailed | JYDriverExceptionPublic.
ResetDeviceFailed | JYDriverExceptionPublic.
GetDevicePropertyFailed | JYDriverExceptionPublic.
SetDevicePropertyFailed | JYDriverExceptionPublic.
HardwareResourceIsReserved | JYDriverExceptionPublic.
MethodNotPermitedToCallWhenCurrentStatus | JYDriverExceptionPublic.
InvalidUserDataBuffer | JYDriverExceptionPublic.
NoChannelAdded | JYDriverExceptionPublic.
NotSupportOperationForCurrentDevice | JYDriverExceptionPublic.
CreatTaskFailed | JYDriverExceptionPublic.
StartTaskFailed | JYDriverExceptionPublic.
StopTaskFailed | JYDriverExceptionPublic.
TaskHasNotStarted | JYDriverExceptionPublic.
TaskHasStartedCannotPerformTheSetOperation | JYDriverExceptionPublic.
ChannelNumberParameterInvalid | JYDriverExceptionPublic.
ChannelInputRangeParameterInvalid | JYDriverExceptionPublic.
ChannelTerminalParameterInvalid | JYDriverExceptionPublic.
ChannelCouplingParameterInvalid | JYDriverExceptionPublic.
SampeleModeParameterInvalid | JYDriverExceptionPublic.
SampleClockParameterInvalid | JYDriverExceptionPublic.
SampleRateParameterInvalid | JYDriverExceptionPublic.
UpdateRateParameterInvalid | JYDriverExceptionPublic.
TriggerParameterInvalid | JYDriverExceptionPublic.
ReferenceTriggerDoesNotMatchWithSampleMode | JYDriverExceptionPublic.
PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint | JYDriverExceptionPublic.
ReadDataFailed | JYDriverExceptionPublic.
ReadDataTimeout | JYDriverExceptionPublic.
WriteDataFailed | JYDriverExceptionPublic.
WriteDataTimeout | JYDriverExceptionPublic.
WriteDataLengthCannotBeLessThanN | JYDriverExceptionPublic.
BufferDataOverflow | JYDriverExceptionPublic.
BufferDataDownflow | JYDriverExceptionPublic.
CheckBufferFailed | JYDriverExceptionPublic.
PointInvalidInFiniteMode | JYDriverExceptionPublic.
ReadPointInvalid | JYDriverExceptionPublic.
OnlySupportRecordMode | JYDriverExceptionPublic.
SendSoftTirggerFailed | JYDriverExceptionPublic.
TaskTimeout | JYDriverExceptionPublic.
CounterParametersInvalid | JYDriverExceptionPublic.
WritePointInvalid | JYDriverExceptionPublic.
SignalExportDestinationInvalid | JYDriverExceptionPublic.
InvalidParameter | 无效参数。 Invalid parameter.

◆ LevelPolarity

enum class JY5500CoreOO::LevelPolarity
strong

Level Polarity.

Enumerator
LowLevel | Low level.
HighLevel | High level.
None | No active polarity.

◆ OutputCompleteState

enum class JY5500CoreOO::OutputCompleteState
strong

Output Complete State.

Enumerator
Zero | Output Complete Zero.
Hold | Output Complete Hold in The last point.

◆ PFITerminal

enum class JY5500CoreOO::PFITerminal
strong

Input/Output Terminal of PFI.

Enumerator
PFI0 | PFI 0.
PFI1 | PFI 1.
PFI2 | PFI 2.
PFI3 | PFI 3.
PFI4 | PFI 4.
PFI5 | PFI 5.
PFI6 | PFI 6.
PFI7 | PFI 7.
PFI8 | PFI 8.
PFI9 | PFI 9.
PFI10 | PFI 10.
PFI11 | PFI 11.
PFI12 | PFI 12.
PFI13 | PFI 13.
PFI14 | PFI 14.
PFI15 | PFI 15.

◆ PowerLineFrequency

enum class JY5500CoreOO::PowerLineFrequency
strong
Enumerator
_50Hz | 50 Hz AC Power Frequency
_60Hz | 60 Hz AC Power Frequency

◆ QuadEncodingType

enum class JY5500CoreOO::QuadEncodingType
strong

Quadrature Encoding Type.

Enumerator
X1 | X1.
X2 | X2.
X4 | X4.

◆ RecordMode

enum class JY5500CoreOO::RecordMode
strong
Enumerator
Finite | Finite Streaming.
Infinite | Infinite Streaming.

◆ ReferenceClockSource

enum class JY5500CoreOO::ReferenceClockSource
strong
Enumerator
Internal | Internal on board 25MHz Clock.
External | External Reference Clock Source.

◆ SignalExportDestination

enum class JY5500CoreOO::SignalExportDestination
strong
Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.
PFI8 | PFI8.
PFI9 | PFI9.
PFI10 | PFI10.
PFI11 | PFI11.
PFI12 | PFI12.
PFI13 | PFI13.
PFI14 | PFI14.
PFI15 | PFI15.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.

Function Documentation

◆ GetSignalExportDestinationString()

std::string JY5500CoreOO::GetSignalExportDestinationString ( SignalExportDestination destination )
inline


5500 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOAOTask.h File Reference

  • File List
  • File Members
  • COO
  • 5500
Classes | Namespaces | Enumerations
JY5500CoreOOAOTask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JY5500CoreOOCommon.h"
#include "JY5500CoreOODevice.h"

Classes

class | JY5500CoreOO::JY5500CoreOOAOTask
class | JY5500CoreOO::AOChannel
class | JY5500CoreOO::AOExternalSampleClock
External Sample Clock Configuration Class. More...
class | JY5500CoreOO::AOSampleClock
AO Sample clock configuration class. More...
class | JY5500CoreOO::AOTrigger
Constructor to create an AOTrigger task object. More...
class | JY5500CoreOO::AODigitalTrigger
AO Digital trigger . More...
class | JY5500CoreOO::AOSignalExport
AO Signal Export Class. More...

Namespaces

namespace JY5500CoreOO

Enumerations

enum class | JY5500CoreOO::AOMode { JY5500CoreOO::Single = 3 , JY5500CoreOO::Finite = 0 , JY5500CoreOO::ContinuousNoWrapping = 2 , JY5500CoreOO::ContinuousWrapping = 1 }
enum class | JY5500CoreOO::AODigitalTriggerEdge { JY5500CoreOO::Rising , JY5500CoreOO::Falling }
AO Digital Trigger Edge. More...
enum class JY5500CoreOO::AODigitalTriggerSource {
JY5500CoreOO::PFI0 , JY5500CoreOO::PFI1 , JY5500CoreOO::PFI2 , JY5500CoreOO::PFI3 ,
JY5500CoreOO::PFI4 , JY5500CoreOO::PFI5 , JY5500CoreOO::PFI6 , JY5500CoreOO::PFI7 ,
JY5500CoreOO::PFI8 , JY5500CoreOO::PFI9 , JY5500CoreOO::PFI10 , JY5500CoreOO::PFI11 ,
JY5500CoreOO::PFI12 , JY5500CoreOO::PFI13 , JY5500CoreOO::PFI14 , JY5500CoreOO::PFI15 ,
JY5500CoreOO::PXI_Trig0 = 40 , JY5500CoreOO::PXI_Trig1 = 41 , JY5500CoreOO::PXI_Trig2 = 42 , JY5500CoreOO::PXI_Trig3 = 43 ,
JY5500CoreOO::PXI_Trig4 = 44 , JY5500CoreOO::PXI_Trig5 = 45 , JY5500CoreOO::PXI_Trig6 = 46 , JY5500CoreOO::PXI_Trig7 = 47 ,
JY5500CoreOO::AI_StartTrig = 16 , JY5500CoreOO::AI_ReferenceTrig = 17 , JY5500CoreOO::DI_StartTrig = 22 , JY5500CoreOO::DI_ReferenceTrig = 23 ,
JY5500CoreOO::DO_StartTrig = 29 , JY5500CoreOO::CI_0_StartTrig = 68 , JY5500CoreOO::CI_1_StartTrig = 73 , JY5500CoreOO::CI_2_StartTrig = 76 ,
JY5500CoreOO::CI_3_StartTrig = 79 , JY5500CoreOO::CO_0_StartTrig = 69 , JY5500CoreOO::CO_1_StartTrig = 74 , JY5500CoreOO::CO_2_StartTrig = 77 ,
JY5500CoreOO::CO_3_StartTrig = 80 , JY5500CoreOO::CO_0_Output = 37 , JY5500CoreOO::CO_1_Output = 51 , JY5500CoreOO::CO_2_Output = 60 ,
JY5500CoreOO::CO_3_Output = 66
}
AO Digital trigger source. More...
enum class | JY5500CoreOO::AOSampleClockSource { JY5500CoreOO::Internal , JY5500CoreOO::External }
AO Sample Clock Source. More...
enum class | JY5500CoreOO::AOSignalExportSource { JY5500CoreOO::StartTrig = 26 , JY5500CoreOO::SampleClock = 28 }
SourceSignal. More...
enum class | JY5500CoreOO::AOTriggerType { JY5500CoreOO::Immediate = 0x0 , JY5500CoreOO::Digital = 0x1 , JY5500CoreOO::Soft = 0x3 }
TriggerType Digital/Immediate/Soft. More...


5500 C++ Programming Manual: JY5500CoreOO::JY5500CoreOOAOTask Class Reference

  • JY5500CoreOOAOTask
Public Member Functions | Public Attributes | List of all members
JY5500CoreOO::JY5500CoreOOAOTask Class Reference

#include <JY5500CoreOOAOTask.h>

Public Member Functions

JY5500CoreOOAOTask (int slotNum)
JY5500CoreOOAOTask (std::string boardName)
void | AddChannel (int chnId, double rangeLow=-10, double rangeHigh=10)
Add one channel.
void | AddChannel (std::vector< int > chnsId, double rangeLow=-10, double rangeHigh=10)
Add a group of channels.
void | AddChannel (std::vector< int > chnsId, std::vector< double > rangeLow, std::vector< double > rangeHigh)
Add a group of channels.
void | RemoveChannel (int chnId)
Delete the specified channel number.
void | WriteData (double *pBuf, int samplesPerChannel, int timeout=10000)
Write to AO buffer one or multi-channel data.
void | WriteData (std::vector< double > &pBuf, int samplesPerChannel, int timeout=10000)
Write to AO buffer one or multi-channel data.
void | WriteRawData (int16_t *pBuf, int samplesPerChannel, int timeout=10000)
Write to AO buffer one or multi-channel raw data.
void | WriteRawData (std::vector< int16_t > &pBuf, int samplesPerChannel, int timeout=10000)
Write to AO buffer one or multi-channel raw data.
void | WriteSinglePoint (std::vector< double > writeValues)
write one sample to all channels in register .
void | WriteSinglePoint (double writeValue, int channel)
Write one sample to the specified channel in register.Available when Mode is AOMode.Single
void | WriteRawSinglePoint (std::vector< int16_t > &writeValues)
write one raw sample to all channels in register .
void | WriteRawSinglePoint (int16_t writeValue, int channel)
Write one raw sample to the specified channel in register.Available when Mode is AOMode.Single
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.
void | Start ()
Start AO task .
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Stop ()
Stop AO task .
~JY5500CoreOOAOTask ()
析构函数

Public Attributes

std::list< AOChannel * > | Channels
List of AI channels,(5510 5511 support 32 SE/16 Diff channel)(5515 5516 support16 SE/8 Diff channel)
AOMode Mode
Mode of AO Task.
JY5500CoreOOProperty< JY5500CoreOOAOTask, double, JY5500CoreOOPropertyType::READ_WRITE > | UpdateRate
Update rate per channel.
int | SamplesToUpdate
Number of output samples to write per channel , Only valid when Mode is AOMode.Finite.
JY5500CoreOOProperty< JY5500CoreOOAOTask, int, JY5500CoreOOPropertyType::READ_ONLY > | BufLenInSamples
Number of samples per channel can be storage in the buffer, the PropretySamplesToUpdate must be less than or equal to this value.
JY5500CoreOOProperty< JY5500CoreOOAOTask, uint32_t, JY5500CoreOOPropertyType::READ_ONLY > | AvaliableLenInSamples
Number of output samples per channel that can be write in AO buffuer.
OutputCompleteState CompleteState
AO Output Complete State, Valid when Mode is NOT OMode.Single.
JY5500CoreOOProperty< JY5500CoreOOAOTask, uint64_t, JY5500CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
AOSampleClock * SampleClock
AO Sample Clock Configuration.
AOTrigger * Trigger
AO Trigger Configuration.
AOSignalExport * SignalExport
Export AO Signal.
JY5500CoreOODevice * Device

Constructor & Destructor Documentation

◆ JY5500CoreOOAOTask() [1/2]

JY5500CoreOO::JY5500CoreOOAOTask::JY5500CoreOOAOTask ( int slotNum )

◆ JY5500CoreOOAOTask() [2/2]

JY5500CoreOO::JY5500CoreOOAOTask::JY5500CoreOOAOTask ( std::string boardName )

◆ ~JY5500CoreOOAOTask()

JY5500CoreOO::JY5500CoreOOAOTask::~JY5500CoreOOAOTask ( )

析构函数

Member Function Documentation

◆ AddChannel() [1/3]

void JY5500CoreOO::JY5500CoreOOAOTask::AddChannel | ( | int | chnId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10 )

Add one channel.

Parameters
chnId | channel's physical number ，chnId=-1, add all channels。（5510 5511 support 4 channels）（5515 5516 support 2 channels）
rangeLow | lower range limit for the channel，-10V,-5V defalut -10
rangeHigh | higher range limit for the channel，10V,5V defalut 10

◆ AddChannel() [2/3]

void JY5500CoreOO::JY5500CoreOOAOTask::AddChannel | ( | std::vector< int > | chnsId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10 )

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers。（5510 5511 support 4 channels）（5515 5516 support 2 channels）
rangeLow | lower range limit for the channel，-10V,-5V defalut -10
rangeHigh | higher range limit for the channel，10V,5V defalut 10

◆ AddChannel() [3/3]

void JY5500CoreOO::JY5500CoreOOAOTask::AddChannel | ( | std::vector< int > | chnsId,
 |  | std::vector< double > | rangeLow,
 |  | std::vector< double > | rangeHigh )

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers。（5510 5511 support 4 channels）（5515 5516 support 2 channels）
rangeLow | lower range limit for the channel，-10V,-5V
rangeHigh | higher range limit for the channel，10V,5V

◆ RemoveChannel()

void JY5500CoreOO::JY5500CoreOOAOTask::RemoveChannel ( int chnId )

Delete the specified channel number.

If it is -1, delete all channels.

Parameters
chnId Specified channel ID.

◆ SendSoftwareTrigger()

void JY5500CoreOO::JY5500CoreOOAOTask::SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5500CoreOO::JY5500CoreOOAOTask::Start ( )

Start AO task .

◆ Stop()

void JY5500CoreOO::JY5500CoreOOAOTask::Stop ( )

Stop AO task .

◆ WaitUntilDone()

bool JY5500CoreOO::JY5500CoreOOAOTask::WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Available when Mode is AOMode.Finite

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteData() [1/2]

void JY5500CoreOO::JY5500CoreOOAOTask::WriteData | ( | double * | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Write to AO buffer one or multi-channel data.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | data buffer.
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [2/2]

void JY5500CoreOO::JY5500CoreOOAOTask::WriteData | ( | std::vector< double > & | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Write to AO buffer one or multi-channel data.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | data buffer.
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawData() [1/2]

void JY5500CoreOO::JY5500CoreOOAOTask::WriteRawData | ( | int16_t * | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Write to AO buffer one or multi-channel raw data.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | data buffer.
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawData() [2/2]

void JY5500CoreOO::JY5500CoreOOAOTask::WriteRawData | ( | std::vector< int16_t > & | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Write to AO buffer one or multi-channel raw data.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | data buffer.
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawSinglePoint() [1/2]

void JY5500CoreOO::JY5500CoreOOAOTask::WriteRawSinglePoint | ( | int16_t | writeValue,
 |  | int | channel )

Write one raw sample to the specified channel in register.Available when Mode is AOMode.Single

Parameters
writeValue | Write value.
channel | Specified channel.

◆ WriteRawSinglePoint() [2/2]

void JY5500CoreOO::JY5500CoreOOAOTask::WriteRawSinglePoint ( std::vector< int16_t > & writeValues )

write one raw sample to all channels in register .

Available when Mode is AOMode.Single

Parameters
writeValues Write values. Array length >= Channels.Count.

◆ WriteSinglePoint() [1/2]

void JY5500CoreOO::JY5500CoreOOAOTask::WriteSinglePoint | ( | double | writeValue,
 |  | int | channel )

Write one sample to the specified channel in register.Available when Mode is AOMode.Single

Parameters
writeValue | Write value.
channel | Specified channel.

◆ WriteSinglePoint() [2/2]

void JY5500CoreOO::JY5500CoreOOAOTask::WriteSinglePoint ( std::vector< double > writeValues )

write one sample to all channels in register .

Available when Mode is AOMode.Single

Parameters
writeValues Write values. Array length >= Channels.Count.

Member Data Documentation

◆ AvaliableLenInSamples

JY5500CoreOOProperty<JY5500CoreOOAOTask, uint32_t, JY5500CoreOOPropertyType::READ_ONLY> JY5500CoreOO::JY5500CoreOOAOTask::AvaliableLenInSamples

Number of output samples per channel that can be write in AO buffuer.

◆ BufLenInSamples

JY5500CoreOOProperty<JY5500CoreOOAOTask, int, JY5500CoreOOPropertyType::READ_ONLY> JY5500CoreOO::JY5500CoreOOAOTask::BufLenInSamples

Number of samples per channel can be storage in the buffer, the PropretySamplesToUpdate must be less than or equal to this value.

◆ Channels

std::list<AOChannel*> JY5500CoreOO::JY5500CoreOOAOTask::Channels

List of AI channels,(5510 5511 support 32 SE/16 Diff channel)(5515 5516 support16 SE/8 Diff channel)

◆ CompleteState

OutputCompleteState JY5500CoreOO::JY5500CoreOOAOTask::CompleteState

AO Output Complete State, Valid when Mode is NOT OMode.Single.

Default is Zero.

◆ Device

JY5500CoreOODevice* JY5500CoreOO::JY5500CoreOOAOTask::Device

◆ Mode

AOMode JY5500CoreOO::JY5500CoreOOAOTask::Mode

Mode of AO Task.

Select AO Mode from enum:ContinuousNoWrapping/ContinuousWrapping/Finite/Single.

◆ SampleClock

AOSampleClock* JY5500CoreOO::JY5500CoreOOAOTask::SampleClock

AO Sample Clock Configuration.

◆ SamplesToUpdate

int JY5500CoreOO::JY5500CoreOOAOTask::SamplesToUpdate

Number of output samples to write per channel , Only valid when Mode is AOMode.Finite.

◆ SignalExport

AOSignalExport* JY5500CoreOO::JY5500CoreOOAOTask::SignalExport

Export AO Signal.

◆ TransferedSamples

JY5500CoreOOProperty<JY5500CoreOOAOTask, uint64_t, JY5500CoreOOPropertyType::READ_ONLY> JY5500CoreOO::JY5500CoreOOAOTask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT AOMode.Single.

◆ Trigger

AOTrigger* JY5500CoreOO::JY5500CoreOOAOTask::Trigger

AO Trigger Configuration.

◆ UpdateRate

JY5500CoreOOProperty<JY5500CoreOOAOTask, double, JY5500CoreOOPropertyType::READ_WRITE> JY5500CoreOO::JY5500CoreOOAOTask::UpdateRate

Update rate per channel.

Maximum update rate is 2.86M for single channel, 2M for two channels, 1.5M for three channels, 1.25M for four channels. The defalut sample rate = 1000000 You can read this property to obtain the update rate that will actually take effect in the current configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOAOTask.h


5500 C++ Programming Manual: JY5500CoreOO::AOChannel Class Reference

  • AOChannel
Public Member Functions | Public Attributes | List of all members
JY5500CoreOO::AOChannel Class Reference

#include <JY5500CoreOOAOTask.h>

Public Member Functions

AOChannel (int channelId, double rangeLow, double rangeHigh)

Public Attributes

int | ChannelID
double | RangeLow
double | RangeHigh

Constructor & Destructor Documentation

◆ AOChannel()

JY5500CoreOO::AOChannel::AOChannel | ( | int | channelId,
 |  | double | rangeLow,
 |  | double | rangeHigh )
 inline

Member Data Documentation

◆ ChannelID

int JY5500CoreOO::AOChannel::ChannelID

◆ RangeHigh

double JY5500CoreOO::AOChannel::RangeHigh

◆ RangeLow

double JY5500CoreOO::AOChannel::RangeLow
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOAOTask.h


5500 C++ Programming Manual: JY5500CoreOO::AOExternalSampleClock Class Reference

  • AOExternalSampleClock
Public Attributes | List of all members
JY5500CoreOO::AOExternalSampleClock Class Reference

External Sample Clock Configuration Class. More...

#include <JY5500CoreOOAOTask.h>

Public Attributes

ClockTerminal Terminal
External Sample Clock Input Terminal.
double ExpectedRate
Expected External Sample Clock Rate.

Detailed Description

External Sample Clock Configuration Class.

Member Data Documentation

◆ ExpectedRate

double JY5500CoreOO::AOExternalSampleClock::ExpectedRate

Expected External Sample Clock Rate.

◆ Terminal

ClockTerminal JY5500CoreOO::AOExternalSampleClock::Terminal

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOAOTask.h


5500 C++ Programming Manual: JY5500CoreOO::AOSampleClock Class Reference

  • AOSampleClock
Public Attributes | List of all members
JY5500CoreOO::AOSampleClock Class Reference

AO Sample clock configuration class. More...

#include <JY5500CoreOOAOTask.h>

Public Attributes

AOSampleClockSource Source
Clock Source.
AOExternalSampleClock * External
External Sample Clock Configuration,Valid when Source is AOSampleClockSource::External.

Detailed Description

AO Sample clock configuration class.

Member Data Documentation

◆ External

AOExternalSampleClock* JY5500CoreOO::AOSampleClock::External

External Sample Clock Configuration,Valid when Source is AOSampleClockSource::External.

◆ Source

AOSampleClockSource JY5500CoreOO::AOSampleClock::Source

Clock Source.

enum Internal/External,The default value is AOSampleClockSource.Internal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOAOTask.h


5500 C++ Programming Manual: JY5500CoreOO::AOTrigger Class Reference

  • AOTrigger
Public Attributes | List of all members
JY5500CoreOO::AOTrigger Class Reference

Constructor to create an AOTrigger task object. More...

#include <JY5500CoreOOAOTask.h>

Public Attributes

AOTriggerType Type
AO trigger type.
AODigitalTrigger * Digital
AO Digital Trigger.

Detailed Description

Constructor to create an AOTrigger task object.

Used to build AO Trigger

Member Data Documentation

◆ Digital

AODigitalTrigger* JY5500CoreOO::AOTrigger::Digital

AO Digital Trigger.

Valid when Type is AOTriggerType.Digital.

◆ Type

AOTriggerType JY5500CoreOO::AOTrigger::Type

AO trigger type.

enum Immediate/Digital/Soft.The default value is AOTriggerType.Immediate.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOAOTask.h


5500 C++ Programming Manual: JY5500CoreOO::AODigitalTrigger Class Reference

  • AODigitalTrigger
Public Attributes | List of all members
JY5500CoreOO::AODigitalTrigger Class Reference

AO Digital trigger . More...

#include <JY5500CoreOOAOTask.h>

Public Attributes

AODigitalTriggerSource Source
AO Digital Trigger source.
AODigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Detailed Description

AO Digital trigger .

Member Data Documentation

◆ Edge

AODigitalTriggerEdge JY5500CoreOO::AODigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

AODigitalTriggerSource JY5500CoreOO::AODigitalTrigger::Source

AO Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOAOTask.h


5500 C++ Programming Manual: JY5500CoreOO::AOSignalExport Class Reference

  • AOSignalExport
Public Member Functions | List of all members
JY5500CoreOO::AOSignalExport Class Reference

AO Signal Export Class. More...

#include <JY5500CoreOOAOTask.h>

Public Member Functions

void | Add (AOSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (AOSignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

AO Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY5500CoreOO::AOSignalExport::Add | ( | AOSignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | AO Signal Source
destination | Export Desination

◆ Add() [2/2]

void JY5500CoreOO::AOSignalExport::Add | ( | AOSignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | AO Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JY5500CoreOO::AOSignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5500CoreOO::AOSignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOAOTask.h


5500 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOCITask.h File Reference

  • File List
  • File Members
  • COO
  • 5500
Classes | Namespaces | Enumerations
JY5500CoreOOCITask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JY5500CoreOOCommon.h"
#include "JY5500CoreOODevice.h"

Classes

class | JY5500CoreOO::JY5500CoreOOCITask
class | JY5500CoreOO::CIInternalSampleClock
CI Internal Sample Clock Configuration Class. More...
class | JY5500CoreOO::CIImplicitSampleClock
CI Implicit Sample Clock class. More...
class | JY5500CoreOO::CIExternalSampleClock
CI Implicit Sample Clock class. More...
class | JY5500CoreOO::CISampleClock
CI Sample Clock class. More...
class | JY5500CoreOO::EdgeCounting
Configure CI EdgeCounting. More...
class | JY5500CoreOO::FrequencyMeas
Configure CI Measure. More...
class | JY5500CoreOO::PeriodMeas
Configure CI Measure. More...
class | JY5500CoreOO::PulseMeas
Configure CI Measure. More...
class | JY5500CoreOO::TwoEdgeSeparation
Configure CI Measure. More...
class | JY5500CoreOO::QuadEncoder
Configure CI Measure. More...
class | JY5500CoreOO::TwoPulseEncoder
Configure CI Measure. More...
class | JY5500CoreOO::CITrigger
Constructor to create an CITrigger task object. More...
class | JY5500CoreOO::CIDigitalTrigger
CI Digital trigger . More...
class | JY5500CoreOO::EdgeCountingOutEvent
Edge counting output event configuration class. More...
class | JY5500CoreOO::CITimebase
Timebase configuration class. More...
class | JY5500CoreOO::CISignalExport
CI Signal Export Class. More...

Namespaces

namespace JY5500CoreOO

Enumerations

enum class | JY5500CoreOO::CountDirection { JY5500CoreOO::Up = 0x0 , JY5500CoreOO::Down = 0x1 , JY5500CoreOO::External = 0x2 }
Counter direction. More...
enum class | JY5500CoreOO::CIMode { JY5500CoreOO::Single = 2 , JY5500CoreOO::Finite = 0 , JY5500CoreOO::Continuous = 1 }
CIMode. More...
enum class JY5500CoreOO::CIType {
JY5500CoreOO::EdgeCounting , JY5500CoreOO::Period , JY5500CoreOO::Frequency , JY5500CoreOO::Pulse ,
JY5500CoreOO::TwoEdgeSeparation , JY5500CoreOO::QuadEncoder , JY5500CoreOO::TwoPulseEncoder
}
Counter Input Application Type. More...
enum class | JY5500CoreOO::CISampleClockSource { JY5500CoreOO::Implicit = 0x0 , JY5500CoreOO::Internal = 0x1 , JY5500CoreOO::External = 0x2 }
CI Sample Clock Source. More...
enum class | JY5500CoreOO::EdgeType { JY5500CoreOO::Rising , JY5500CoreOO::Falling }
Edge Type. More...
enum class | JY5500CoreOO::QuadEncodingType { JY5500CoreOO::X1 , JY5500CoreOO::X2 , JY5500CoreOO::X4 }
Quadrature Encoding Type. More...
enum class | JY5500CoreOO::CITriggerType { JY5500CoreOO::Immediate = 0x0 , JY5500CoreOO::Digital = 0x1 , JY5500CoreOO::Soft = 0x3 }
TriggerType Digital/Immediate/Soft. More...
enum class JY5500CoreOO::CIDigitalTriggerSource {
JY5500CoreOO::PFI0 , JY5500CoreOO::PFI1 , JY5500CoreOO::PFI2 , JY5500CoreOO::PFI3 ,
JY5500CoreOO::PFI4 , JY5500CoreOO::PFI5 , JY5500CoreOO::PFI6 , JY5500CoreOO::PFI7 ,
JY5500CoreOO::PFI8 , JY5500CoreOO::PFI9 , JY5500CoreOO::PFI10 , JY5500CoreOO::PFI11 ,
JY5500CoreOO::PFI12 , JY5500CoreOO::PFI13 , JY5500CoreOO::PFI14 , JY5500CoreOO::PFI15 ,
JY5500CoreOO::PXI_Trig0 = 40 , JY5500CoreOO::PXI_Trig1 = 41 , JY5500CoreOO::PXI_Trig2 = 42 , JY5500CoreOO::PXI_Trig3 = 43 ,
JY5500CoreOO::PXI_Trig4 = 44 , JY5500CoreOO::PXI_Trig5 = 45 , JY5500CoreOO::PXI_Trig6 = 46 , JY5500CoreOO::PXI_Trig7 = 47 ,
JY5500CoreOO::AI_StartTrig = 16 , JY5500CoreOO::AI_ReferenceTrig = 17 , JY5500CoreOO::AO_StartTrig = 26 , JY5500CoreOO::DI_StartTrig = 22 ,
JY5500CoreOO::DI_ReferenceTrig = 23 , JY5500CoreOO::DO_StartTrig = 29 , JY5500CoreOO::CI_0_StartTrig = 68 , JY5500CoreOO::CI_1_StartTrig = 73 ,
JY5500CoreOO::CI_2_StartTrig = 76 , JY5500CoreOO::CI_3_StartTrig = 79 , JY5500CoreOO::CO_0_StartTrig = 69 , JY5500CoreOO::CO_1_StartTrig = 74 ,
JY5500CoreOO::CO_2_StartTrig = 77 , JY5500CoreOO::CO_3_StartTrig = 80 , JY5500CoreOO::CO_0_Output = 37 , JY5500CoreOO::CO_1_Output = 51 ,
JY5500CoreOO::CO_2_Output = 60 , JY5500CoreOO::CO_3_Output = 66
}
CI Digital trigger source. More...
enum class | JY5500CoreOO::CIDigitalTriggerEdge { JY5500CoreOO::Rising , JY5500CoreOO::Falling }
CI Digital Trigger Edge. More...
enum class | JY5500CoreOO::EdgeCntOunEvtIdleState { JY5500CoreOO::LowLevel = 0 , JY5500CoreOO::HighLevel = 1 }
Output idle state when the event has not occurred. More...
enum class | JY5500CoreOO::CISignalExportSource { JY5500CoreOO::StartTrig , JY5500CoreOO::SampleClock }
SourceSignal. More...
enum class | JY5500CoreOO::CITimebaseSource { JY5500CoreOO::Internal200MHz }
Timebase source. More...


5500 C++ Programming Manual: JY5500CoreOO::JY5500CoreOOCITask Class Reference

  • JY5500CoreOOCITask
Public Member Functions | Public Attributes | List of all members
JY5500CoreOO::JY5500CoreOOCITask Class Reference

#include <JY5500CoreOOCITask.h>

Public Member Functions

JY5500CoreOOCITask (int slotNum, int channel)
JY5500CoreOOCITask (std::string boardName, int channel)
~JY5500CoreOOCITask ()
void | Start ()
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Stop ()
Stop CI task .
void | ReadSinglePoint (uint32_t &count)
Read a signle count value from register, Available when Type is CIType.EdgeCounting, CIType.QuadEncoder or CIType.TwoPulseEncoder.
void | ReadData (uint32_t *pBufCount, int samplesToAcquire, int timeout=10000)
Read counter values from buffer.
void | ReadData (std::vector< uint32_t > &pBufCount, int samplesToAcquire, int timeout=10000)
Read counter values from buffer.
void | ReadData (double *pBufMeasurement, int samplesToAcquire, int timeout=10000)
Read frequency value or period value from buffer.
void | ReadData (std::vector< double > &pBufMeasurement, int samplesToAcquire, int timeout=10000)
Read frequency value or period value from buffer.
void | ReadSinglePoint (double &measurement, int timeout=10000)
Read a signle frequency value or period value from register.
void | ReadSinglePoint (double &measurement1, double &measurement2, int timeout=10000)
Read a signle measurement of pulse's duration value, or two-edge separtion value (two results at a time) from register.
void | ReadData (double *pBufMeasurement1, double *pBufMeasurement2, int samplesToAcquire, int timeout=10000)
Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.
void | ReadData (std::vector< double > &pBufMeasurement1, std::vector< double > &pBufMeasurement2, int samplesToAcquire, int timeout=10000)
Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.

Public Attributes

CIType Type
CI Application types.
JY5500CoreOOProperty< JY5500CoreOOCITask, uint64_t, JY5500CoreOOPropertyType::READ_ONLY > | AvailableSamples
Number of points per channel that can be read in the buffer .
JY5500CoreOOProperty< JY5500CoreOOCITask, uint64_t, JY5500CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
CIMode Mode
CI Sampling mode，support Single/Finite/Continuous.
CISampleClock * SampleClock
Clock Source.
uint32_t | SamplesToAcquire
Number of samples to be read per channel.Only valid when Mode is CIMode.Finite.
JY5500CoreOO::EdgeCounting * EdgeCounting
Edge Counting Configuration.
JY5500CoreOO::FrequencyMeas * FrequencyMeas
Frequency Measurement Configuration.
JY5500CoreOO::PeriodMeas * PeriodMeas
Period Measurement Configuration.
JY5500CoreOO::PulseMeas * PulseMeas
Pulse Measurement Configuration.
JY5500CoreOO::TwoEdgeSeparation * TwoEdgeSeparation
TwoEdgeSeparation.
JY5500CoreOO::QuadEncoder * QuadEncoder
QuadEncoder.
JY5500CoreOO::TwoPulseEncoder * TwoPulseEncoder
TwoPulseEncoder.
CITrigger * Trigger
CI Trigger Configuration.
CISignalExport * SignalExport
Export CI Signal Configuration.
JY5500CoreOODevice * Device
Device.

Constructor & Destructor Documentation

◆ JY5500CoreOOCITask() [1/2]

JY5500CoreOO::JY5500CoreOOCITask::JY5500CoreOOCITask | ( | int | slotNum,
 |  | int | channel )

◆ JY5500CoreOOCITask() [2/2]

JY5500CoreOO::JY5500CoreOOCITask::JY5500CoreOOCITask | ( | std::string | boardName,
 |  | int | channel )

◆ ~JY5500CoreOOCITask()

JY5500CoreOO::JY5500CoreOOCITask::~JY5500CoreOOCITask ( )

Member Function Documentation

◆ ReadData() [1/6]

void JY5500CoreOO::JY5500CoreOOCITask::ReadData | ( | double * | pBufMeasurement,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read frequency value or period value from buffer.

Available when JY5500CITask.Mode is NOT CIMode.Single, and Type is CIType.Frequency or CIType.Period.

Parameters
bufMeasurement | Buffer for reading data. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period in seconds when Type is CIType.Period.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [2/6]

void JY5500CoreOO::JY5500CoreOOCITask::ReadData | ( | double * | pBufMeasurement1,
 |  | double * | pBufMeasurement2,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.

. Available when JY5500CITask.Mode is NOT CIMode.Single, Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
bufMeasurement1 | Buffer for reading data. Indicates high level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
bufMeasurement2 | Buffer for reading data. Indicates low level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [3/6]

void JY5500CoreOO::JY5500CoreOOCITask::ReadData | ( | std::vector< double > & | pBufMeasurement,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read frequency value or period value from buffer.

Available when JY5500CITask.Mode is NOT CIMode.Single, and Type is CIType.Frequency or CIType.Period.

Parameters
bufMeasurement | Buffer for reading data. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period in seconds when Type is CIType.Period.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [4/6]

void JY5500CoreOO::JY5500CoreOOCITask::ReadData | ( | std::vector< double > & | pBufMeasurement1,
 |  | std::vector< double > & | pBufMeasurement2,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.

. Available when JY5500CITask.Mode is NOT CIMode.Single, Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
bufMeasurement1 | Buffer for reading data. Indicates high level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
bufMeasurement2 | Buffer for reading data. Indicates low level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [5/6]

void JY5500CoreOO::JY5500CoreOOCITask::ReadData | ( | std::vector< uint32_t > & | pBufCount,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read counter values from buffer.

Available when JY5500CITask.Mode is NOT CIMode.Single, and Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder

Parameters
bufCount | Buffer for reading data.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [6/6]

void JY5500CoreOO::JY5500CoreOOCITask::ReadData | ( | uint32_t * | pBufCount,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read counter values from buffer.

Available when JY5500CITask.Mode is NOT CIMode.Single, and Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder

Parameters
bufCount | Buffer for reading data.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [1/3]

void JY5500CoreOO::JY5500CoreOOCITask::ReadSinglePoint | ( | double & | measurement,
 |  | int | timeout = 10000 )

Read a signle frequency value or period value from register.

Valid when Type is CIType.Frequency or CIType.Period.

Parameters
measurement Measurement value. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period is seconds when Type is CIType.Period.
timeout
Timeout (ms). Wait until the measurement is completed or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [2/3]

void JY5500CoreOO::JY5500CoreOOCITask::ReadSinglePoint | ( | double & | measurement1,
 |  | double & | measurement2,
 |  | int | timeout = 10000 )

Read a signle measurement of pulse's duration value, or two-edge separtion value (two results at a time) from register.

Available when Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
measurement1 | Measurement Value 1. Indicates low level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
measurement2 | Measurement Value 2. Indicates high level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
timeout
Timeout (ms). Wait until the measurement is completed or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [3/3]

void JY5500CoreOO::JY5500CoreOOCITask::ReadSinglePoint ( uint32_t & count )

Read a signle count value from register, Available when Type is CIType.EdgeCounting, CIType.QuadEncoder or CIType.TwoPulseEncoder.

Parameters
count counter value。

◆ SendSoftwareTrigger()

void JY5500CoreOO::JY5500CoreOOCITask::SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5500CoreOO::JY5500CoreOOCITask::Start ( )

◆ Stop()

void JY5500CoreOO::JY5500CoreOOCITask::Stop ( )

Stop CI task .

Member Data Documentation

◆ AvailableSamples

JY5500CoreOOProperty<JY5500CoreOOCITask, uint64_t, JY5500CoreOOPropertyType::READ_ONLY> JY5500CoreOO::JY5500CoreOOCITask::AvailableSamples

Number of points per channel that can be read in the buffer .

◆ Device

JY5500CoreOODevice* JY5500CoreOO::JY5500CoreOOCITask::Device

Device.

◆ EdgeCounting

JY5500CoreOO::EdgeCounting* JY5500CoreOO::JY5500CoreOOCITask::EdgeCounting

Edge Counting Configuration.

◆ FrequencyMeas

JY5500CoreOO::FrequencyMeas* JY5500CoreOO::JY5500CoreOOCITask::FrequencyMeas

Frequency Measurement Configuration.

◆ Mode

CIMode JY5500CoreOO::JY5500CoreOOCITask::Mode

CI Sampling mode，support Single/Finite/Continuous.

◆ PeriodMeas

JY5500CoreOO::PeriodMeas* JY5500CoreOO::JY5500CoreOOCITask::PeriodMeas

Period Measurement Configuration.

◆ PulseMeas

JY5500CoreOO::PulseMeas* JY5500CoreOO::JY5500CoreOOCITask::PulseMeas

Pulse Measurement Configuration.

◆ QuadEncoder

JY5500CoreOO::QuadEncoder* JY5500CoreOO::JY5500CoreOOCITask::QuadEncoder

QuadEncoder.

◆ SampleClock

CISampleClock* JY5500CoreOO::JY5500CoreOOCITask::SampleClock

Clock Source.

◆ SamplesToAcquire

uint32_t JY5500CoreOO::JY5500CoreOOCITask::SamplesToAcquire

Number of samples to be read per channel.Only valid when Mode is CIMode.Finite.

◆ SignalExport

CISignalExport* JY5500CoreOO::JY5500CoreOOCITask::SignalExport

Export CI Signal Configuration.

◆ TransferedSamples

JY5500CoreOOProperty<JY5500CoreOOCITask, uint64_t, JY5500CoreOOPropertyType::READ_ONLY> JY5500CoreOO::JY5500CoreOOCITask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT CIMode.Single.

◆ Trigger

CITrigger* JY5500CoreOO::JY5500CoreOOCITask::Trigger

CI Trigger Configuration.

◆ TwoEdgeSeparation

JY5500CoreOO::TwoEdgeSeparation* JY5500CoreOO::JY5500CoreOOCITask::TwoEdgeSeparation

TwoEdgeSeparation.

◆ TwoPulseEncoder

JY5500CoreOO::TwoPulseEncoder* JY5500CoreOO::JY5500CoreOOCITask::TwoPulseEncoder

TwoPulseEncoder.

◆ Type

CIType JY5500CoreOO::JY5500CoreOOCITask::Type

CI Application types.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOCITask.h


5500 C++ Programming Manual: JY5500CoreOO::CIInternalSampleClock Class Reference

  • CIInternalSampleClock
Public Attributes | List of all members
JY5500CoreOO::CIInternalSampleClock Class Reference

CI Internal Sample Clock Configuration Class. More...

#include <JY5500CoreOOCITask.h>

Public Attributes

JY5500CoreOOProperty< CIInternalSampleClock, double, JY5500CoreOOPropertyType::READ_WRITE > Rate
The rate of the internal sample clock (sample rate) which is generated by dividing the internal clock (200MHz).

Detailed Description

CI Internal Sample Clock Configuration Class.

Member Data Documentation

◆ Rate

JY5500CoreOOProperty<CIInternalSampleClock, double, JY5500CoreOOPropertyType::READ_WRITE> JY5500CoreOO::CIInternalSampleClock::Rate

The rate of the internal sample clock (sample rate) which is generated by dividing the internal clock (200MHz).

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOCITask.h


5500 C++ Programming Manual: JY5500CoreOO::CIImplicitSampleClock Class Reference

  • CIImplicitSampleClock
Public Attributes | List of all members
JY5500CoreOO::CIImplicitSampleClock Class Reference

CI Implicit Sample Clock class. More...

#include <JY5500CoreOOCITask.h>

Public Attributes

double ExpectedRate
Expected Rate of Implicit Sample Clock.

Detailed Description

CI Implicit Sample Clock class.

Member Data Documentation

◆ ExpectedRate

double JY5500CoreOO::CIImplicitSampleClock::ExpectedRate

Expected Rate of Implicit Sample Clock.

Filling this parameter accurately would helps the driver to set a proper DDR write frequency internally.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOCITask.h


5500 C++ Programming Manual: JY5500CoreOO::CIExternalSampleClock Class Reference

  • CIExternalSampleClock
Public Attributes | List of all members
JY5500CoreOO::CIExternalSampleClock Class Reference

CI Implicit Sample Clock class. More...

#include <JY5500CoreOOCITask.h>

Public Attributes

ClockTerminal Terminal
External Sample Clock Input Terminal.
double ExpectedRate
Expected Rate of External Sample Clock.

Detailed Description

CI Implicit Sample Clock class.

Member Data Documentation

◆ ExpectedRate

double JY5500CoreOO::CIExternalSampleClock::ExpectedRate

Expected Rate of External Sample Clock.

Filling this parameter accurately would helps the driver to set a proper DDR write frequency internally.

◆ Terminal

ClockTerminal JY5500CoreOO::CIExternalSampleClock::Terminal

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOCITask.h


5500 C++ Programming Manual: JY5500CoreOO::CISampleClock Class Reference

  • CISampleClock
Public Attributes | List of all members
JY5500CoreOO::CISampleClock Class Reference

CI Sample Clock class. More...

#include <JY5500CoreOOCITask.h>

Public Attributes

CISampleClockSource Source
CI Sample Clock Source.
CIExternalSampleClock * External
CI External Sample Clock Configuration.
CIImplicitSampleClock * Implicit
CI Implicit Sample Clock Configuration.
CIInternalSampleClock * Internal
Internal Sample Clock Configuration.

Detailed Description

CI Sample Clock class.

Member Data Documentation

◆ External

CIExternalSampleClock* JY5500CoreOO::CISampleClock::External

CI External Sample Clock Configuration.

Valid when Source is CISampleClockSource.External.

◆ Implicit

CIImplicitSampleClock* JY5500CoreOO::CISampleClock::Implicit

CI Implicit Sample Clock Configuration.

Valid when Source is CISampleClockSource.Implicit.

◆ Internal

CIInternalSampleClock* JY5500CoreOO::CISampleClock::Internal

Internal Sample Clock Configuration.

Valid when Source is CISampleClockSource.Internal.

◆ Source

CISampleClockSource JY5500CoreOO::CISampleClock::Source

CI Sample Clock Source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOCITask.h


5500 C++ Programming Manual: JY5500CoreOO::EdgeCounting Class Reference

  • EdgeCounting
Public Attributes | List of all members
JY5500CoreOO::EdgeCounting Class Reference

Configure CI EdgeCounting. More...

#include <JY5500CoreOOCITask.h>

Public Attributes

int InitialCount
Initial Count.
CountDirection Direction
Counter direction.
EdgeType ActiveEdge
The avtive edge of the input signal, the counter will count up or down on this edge.
PauseTrigger * Pause
Pause Trigger Configuration.
EdgeCountingOutEvent * OutEvent
Edge counting output event.
JY5500CoreOO::InputTerminal DirTerminal
Terminal of External Count Diretion Control.
JY5500CoreOO::InputTerminal Input_Terminal
Input Terminal.

Detailed Description

Configure CI EdgeCounting.

Member Data Documentation

◆ ActiveEdge

EdgeType JY5500CoreOO::EdgeCounting::ActiveEdge

The avtive edge of the input signal, the counter will count up or down on this edge.

◆ Direction

CountDirection JY5500CoreOO::EdgeCounting::Direction

Counter direction.

enum Up/Down/External

◆ DirTerminal

JY5500CoreOO::InputTerminal JY5500CoreOO::EdgeCounting::DirTerminal

Terminal of External Count Diretion Control.

Valid when Direction is CountDirection.External

◆ InitialCount

int JY5500CoreOO::EdgeCounting::InitialCount

Initial Count.

◆ Input_Terminal

JY5500CoreOO::InputTerminal JY5500CoreOO::EdgeCounting::Input_Terminal

Input Terminal.

◆ OutEvent

EdgeCountingOutEvent* JY5500CoreOO::EdgeCounting::OutEvent

Edge counting output event.

A pulse will be generated when the count value reaches specified threshold

◆ Pause

PauseTrigger* JY5500CoreOO::EdgeCounting::Pause

Pause Trigger Configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOCITask.h


5500 C++ Programming Manual: JY5500CoreOO::FrequencyMeas Class Reference

  • FrequencyMeas
Public Attributes | List of all members
JY5500CoreOO::FrequencyMeas Class Reference

Configure CI Measure. More...

#include <JY5500CoreOOCITask.h>

Public Attributes

CITimebase * Timebase
Timebase configuration.
JY5500CoreOO::InputTerminal Input_Terminal
Input Terminal.

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ Input_Terminal

JY5500CoreOO::InputTerminal JY5500CoreOO::FrequencyMeas::Input_Terminal

Input Terminal.

◆ Timebase

CITimebase* JY5500CoreOO::FrequencyMeas::Timebase

Timebase configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOCITask.h


5500 C++ Programming Manual: JY5500CoreOO::PeriodMeas Class Reference

  • PeriodMeas
Public Attributes | List of all members
JY5500CoreOO::PeriodMeas Class Reference

Configure CI Measure. More...

#include <JY5500CoreOOCITask.h>

Public Attributes

CITimebase * Timebase
Timebase configuration.
JY5500CoreOO::InputTerminal Input_Terminal
Input Terminal.

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ Input_Terminal

JY5500CoreOO::InputTerminal JY5500CoreOO::PeriodMeas::Input_Terminal

Input Terminal.

◆ Timebase

CITimebase* JY5500CoreOO::PeriodMeas::Timebase

Timebase configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOCITask.h


5500 C++ Programming Manual: JY5500CoreOO::PulseMeas Class Reference

  • PulseMeas
Public Attributes | List of all members
JY5500CoreOO::PulseMeas Class Reference

Configure CI Measure. More...

#include <JY5500CoreOOCITask.h>

Public Attributes

CITimebase * Timebase
Timebase configuration.
JY5500CoreOO::InputTerminal Input_Terminal
Input Terminal.

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ Input_Terminal

JY5500CoreOO::InputTerminal JY5500CoreOO::PulseMeas::Input_Terminal

Input Terminal.

◆ Timebase

CITimebase* JY5500CoreOO::PulseMeas::Timebase

Timebase configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOCITask.h


5500 C++ Programming Manual: JY5500CoreOO::TwoEdgeSeparation Class Reference

  • TwoEdgeSeparation
Public Attributes | List of all members
JY5500CoreOO::TwoEdgeSeparation Class Reference

Configure CI Measure. More...

#include <JY5500CoreOOCITask.h>

Public Attributes

CITimebase * Timebase
Timebase configuration.
InputTerminal FirstInputTerminal
Input Terminal.
InputTerminal SecondInputTerminal
Input Terminal.

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ FirstInputTerminal

InputTerminal JY5500CoreOO::TwoEdgeSeparation::FirstInputTerminal

Input Terminal.

◆ SecondInputTerminal

InputTerminal JY5500CoreOO::TwoEdgeSeparation::SecondInputTerminal

Input Terminal.

◆ Timebase

CITimebase* JY5500CoreOO::TwoEdgeSeparation::Timebase

Timebase configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOCITask.h


5500 C++ Programming Manual: JY5500CoreOO::QuadEncoder Class Reference

  • QuadEncoder
Public Attributes | List of all members
JY5500CoreOO::QuadEncoder Class Reference

Configure CI Measure. More...

#include <JY5500CoreOOCITask.h>

Public Attributes

QuadEncodingType EncodingType
Type of Encoding.
bool | ZReloadEnabled
In Encoder mode ,the Z signal enable.
int | InitialCount
Initial Count.
InputTerminal AInputTerminal
Input Terminal.
InputTerminal BInputTerminal
Input Terminal.
InputTerminal ZInputTerminal
Input Terminal.

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ AInputTerminal

InputTerminal JY5500CoreOO::QuadEncoder::AInputTerminal

Input Terminal.

◆ BInputTerminal

InputTerminal JY5500CoreOO::QuadEncoder::BInputTerminal

Input Terminal.

◆ EncodingType

QuadEncodingType JY5500CoreOO::QuadEncoder::EncodingType

Type of Encoding.

◆ InitialCount

int JY5500CoreOO::QuadEncoder::InitialCount

Initial Count.

◆ ZInputTerminal

InputTerminal JY5500CoreOO::QuadEncoder::ZInputTerminal

Input Terminal.

◆ ZReloadEnabled

bool JY5500CoreOO::QuadEncoder::ZReloadEnabled

In Encoder mode ,the Z signal enable.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOCITask.h


5500 C++ Programming Manual: JY5500CoreOO::TwoPulseEncoder Class Reference

  • TwoPulseEncoder
Public Attributes | List of all members
JY5500CoreOO::TwoPulseEncoder Class Reference

Configure CI Measure. More...

#include <JY5500CoreOOCITask.h>

Public Attributes

int InitialCount
Initial Count.
InputTerminal AInputTerminal
Input Terminal.
InputTerminal BInputTerminal
Input Terminal.

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ AInputTerminal

InputTerminal JY5500CoreOO::TwoPulseEncoder::AInputTerminal

Input Terminal.

◆ BInputTerminal

InputTerminal JY5500CoreOO::TwoPulseEncoder::BInputTerminal

Input Terminal.

◆ InitialCount

int JY5500CoreOO::TwoPulseEncoder::InitialCount

Initial Count.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOCITask.h


5500 C++ Programming Manual: JY5500CoreOO::CITrigger Class Reference

  • CITrigger
Public Attributes | List of all members
JY5500CoreOO::CITrigger Class Reference

Constructor to create an CITrigger task object. More...

#include <JY5500CoreOOCITask.h>

Public Attributes

CITriggerType Type
CI trigger type.
CIDigitalTrigger * Digital
CI Digital Trigger.

Detailed Description

Constructor to create an CITrigger task object.

Used to build CI Trigger

Member Data Documentation

◆ Digital

CIDigitalTrigger* JY5500CoreOO::CITrigger::Digital

CI Digital Trigger.

Valid when Type is CITriggerType.Digital

◆ Type

CITriggerType JY5500CoreOO::CITrigger::Type

CI trigger type.

enum Immediate/Digital/Soft.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOCITask.h


5500 C++ Programming Manual: JY5500CoreOO::CIDigitalTrigger Class Reference

  • CIDigitalTrigger
Public Attributes | List of all members
JY5500CoreOO::CIDigitalTrigger Class Reference

CI Digital trigger . More...

#include <JY5500CoreOOCITask.h>

Public Attributes

CIDigitalTriggerSource Source
CI Digital Trigger source.
CIDigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Detailed Description

CI Digital trigger .

Member Data Documentation

◆ Edge

CIDigitalTriggerEdge JY5500CoreOO::CIDigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

CIDigitalTriggerSource JY5500CoreOO::CIDigitalTrigger::Source

CI Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOCITask.h


5500 C++ Programming Manual: JY5500CoreOO::EdgeCountingOutEvent Class Reference

  • EdgeCountingOutEvent
Public Attributes | List of all members
JY5500CoreOO::EdgeCountingOutEvent Class Reference

Edge counting output event configuration class. More...

#include <JY5500CoreOOCITask.h>

Public Attributes

EdgeCntOunEvtIdleState IdleState
Output idle state when the event has not occurred.
uint32_t Threshold
Comparison threshold.
IOTerminal Terminal
Terminal.

Detailed Description

Edge counting output event configuration class.

Member Data Documentation

◆ IdleState

EdgeCntOunEvtIdleState JY5500CoreOO::EdgeCountingOutEvent::IdleState

Output idle state when the event has not occurred.

The default value is EdgeCntOunEvtIdleState.LowLevel

◆ Terminal

IOTerminal JY5500CoreOO::EdgeCountingOutEvent::Terminal

Terminal.

◆ Threshold

uint32_t JY5500CoreOO::EdgeCountingOutEvent::Threshold

Comparison threshold.

The default value is 2^32-1

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOCITask.h


5500 C++ Programming Manual: JY5500CoreOO::CITimebase Class Reference

  • CITimebase
Public Attributes | List of all members
JY5500CoreOO::CITimebase Class Reference

Timebase configuration class. More...

#include <JY5500CoreOOCITask.h>

Public Attributes

CITimebaseSource Source
Timebase Source.

Detailed Description

Timebase configuration class.

Member Data Documentation

◆ Source

CITimebaseSource JY5500CoreOO::CITimebase::Source

Timebase Source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOCITask.h


5500 C++ Programming Manual: JY5500CoreOO::CISignalExport Class Reference

  • CISignalExport
Public Member Functions | List of all members
JY5500CoreOO::CISignalExport Class Reference

CI Signal Export Class. More...

#include <JY5500CoreOOCITask.h>

Public Member Functions

void | Add (CISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (CISignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

CI Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY5500CoreOO::CISignalExport::Add | ( | CISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | CI Signal Source
destination | Export Desination

◆ Add() [2/2]

void JY5500CoreOO::CISignalExport::Add | ( | CISignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | CI Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JY5500CoreOO::CISignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5500CoreOO::CISignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOCITask.h


5500 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOCommon.h File Reference

  • File List
  • File Members
  • COO
  • 5500
Classes | Namespaces | Macros | Enumerations | Functions
JY5500CoreOOCommon.h File Reference
#include <string>
#include <stdint.h>

Classes

class | JY5500CoreOO::JYDriverException
class | JY5500CoreOO::JY5500CoreOOProperty< ContainerClass, ValueType, propertyType >
属性模板类 More...
class | JY5500CoreOO::PauseTrigger
Pause trigger configuration class. More...

Namespaces

namespace JY5500CoreOO

Macros

#define | EXTERN_C extern
Windows.
#define | JY5500CoreOO_API

Enumerations

enum class | JY5500CoreOO::JY5500CoreOOPropertyType { JY5500CoreOO::READ_ONLY = 1 , JY5500CoreOO::WRITE_ONLY = 2 , JY5500CoreOO::READ_WRITE = 3 }
enum class JY5500CoreOO::JYDriverExceptionPublic {
JY5500CoreOO::UnKnown = 0 , JY5500CoreOO::OpenDeviceFailed = -10001 , JY5500CoreOO::CloseDeviceFailed = -10002 , JY5500CoreOO::ResetDeviceFailed = -10003 ,
JY5500CoreOO::GetDevicePropertyFailed = -10004 , JY5500CoreOO::SetDevicePropertyFailed = -10005 , JY5500CoreOO::HardwareResourceIsReserved = -10006 , JY5500CoreOO::MethodNotPermitedToCallWhenCurrentStatus = -10007 ,
JY5500CoreOO::InvalidUserDataBuffer = -10008 , JY5500CoreOO::NoChannelAdded = -10009 , JY5500CoreOO::NotSupportOperationForCurrentDevice = -10010 , JY5500CoreOO::CreatTaskFailed = -10100 ,
JY5500CoreOO::StartTaskFailed = -10101 , JY5500CoreOO::StopTaskFailed = -10102 , JY5500CoreOO::TaskHasNotStarted = -10103 , JY5500CoreOO::TaskHasStartedCannotPerformTheSetOperation = -10104 ,
JY5500CoreOO::ChannelNumberParameterInvalid = -10105 , JY5500CoreOO::ChannelInputRangeParameterInvalid = -10106 , JY5500CoreOO::ChannelTerminalParameterInvalid = -10107 , JY5500CoreOO::ChannelCouplingParameterInvalid = -10108 ,
JY5500CoreOO::SampeleModeParameterInvalid = -10109 , JY5500CoreOO::SampleClockParameterInvalid = -10110 , JY5500CoreOO::SampleRateParameterInvalid = -10111 , JY5500CoreOO::UpdateRateParameterInvalid = -10112 ,
JY5500CoreOO::TriggerParameterInvalid = -10113 , JY5500CoreOO::ReferenceTriggerDoesNotMatchWithSampleMode = -10114 , JY5500CoreOO::PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint = -10115 , JY5500CoreOO::ReadDataFailed = -10016 ,
JY5500CoreOO::ReadDataTimeout = -10017 , JY5500CoreOO::WriteDataFailed = -10018 , JY5500CoreOO::WriteDataTimeout = -10019 , JY5500CoreOO::WriteDataLengthCannotBeLessThanN = -10020 ,
JY5500CoreOO::BufferDataOverflow = -10021 , JY5500CoreOO::BufferDataDownflow = -10022 , JY5500CoreOO::CheckBufferFailed = -10023 , JY5500CoreOO::PointInvalidInFiniteMode = -10024 ,
JY5500CoreOO::ReadPointInvalid = -10025 , JY5500CoreOO::OnlySupportRecordMode = -10026 , JY5500CoreOO::SendSoftTirggerFailed = -10027 , JY5500CoreOO::TaskTimeout = -10028 ,
JY5500CoreOO::CounterParametersInvalid = -10029 , JY5500CoreOO::WritePointInvalid = -10030 , JY5500CoreOO::SignalExportDestinationInvalid = -10031 , JY5500CoreOO::InvalidParameter = -10033
}
enum class JY5500CoreOO::ClockTerminal {
JY5500CoreOO::ECLK = 10000 , JY5500CoreOO::PFI0 = 0 , JY5500CoreOO::PFI1 = 1 , JY5500CoreOO::PFI2 = 2 ,
JY5500CoreOO::PFI3 = 3 , JY5500CoreOO::PFI4 = 4 , JY5500CoreOO::PFI5 = 5 , JY5500CoreOO::PFI6 = 6 ,
JY5500CoreOO::PFI7 = 7 , JY5500CoreOO::PFI8 = 8 , JY5500CoreOO::PFI9 = 9 , JY5500CoreOO::PFI10 = 10 ,
JY5500CoreOO::PFI11 = 11 , JY5500CoreOO::PFI12 = 12 , JY5500CoreOO::PFI13 = 13 , JY5500CoreOO::PFI14 = 14 ,
JY5500CoreOO::PFI15 = 15 , JY5500CoreOO::PXI_Trig0 = 40 , JY5500CoreOO::PXI_Trig1 = 41 , JY5500CoreOO::PXI_Trig2 = 42 ,
JY5500CoreOO::PXI_Trig3 = 43 , JY5500CoreOO::PXI_Trig4 = 44 , JY5500CoreOO::PXI_Trig5 = 45 , JY5500CoreOO::PXI_Trig6 = 46 ,
JY5500CoreOO::PXI_Trig7 = 47 , JY5500CoreOO::AI_SampleClock = 20 , JY5500CoreOO::AO_SampleClock = 28 , JY5500CoreOO::DI_SampleClock = 53 ,
JY5500CoreOO::DO_SampleClock = 54 , JY5500CoreOO::CI0_SampleClock = 36 , JY5500CoreOO::CI1_SampleClock = 50 , JY5500CoreOO::CI2_SampleClock = 59 ,
JY5500CoreOO::CI3_SampleClock = 65 , JY5500CoreOO::CO_0_Output = 37 , JY5500CoreOO::CO_1_Output = 51 , JY5500CoreOO::CO_2_Output = 60 ,
JY5500CoreOO::CO_3_Output = 66
}
enum class JY5500CoreOO::SignalExportDestination {
JY5500CoreOO::PFI0 , JY5500CoreOO::PFI1 , JY5500CoreOO::PFI2 , JY5500CoreOO::PFI3 ,
JY5500CoreOO::PFI4 , JY5500CoreOO::PFI5 , JY5500CoreOO::PFI6 , JY5500CoreOO::PFI7 ,
JY5500CoreOO::PFI8 , JY5500CoreOO::PFI9 , JY5500CoreOO::PFI10 , JY5500CoreOO::PFI11 ,
JY5500CoreOO::PFI12 , JY5500CoreOO::PFI13 , JY5500CoreOO::PFI14 , JY5500CoreOO::PFI15 ,
JY5500CoreOO::PXI_Trig0 = 0x20 , JY5500CoreOO::PXI_Trig1 = 0x21 , JY5500CoreOO::PXI_Trig2 = 0x22 , JY5500CoreOO::PXI_Trig3 = 0x23 ,
JY5500CoreOO::PXI_Trig4 = 0x24 , JY5500CoreOO::PXI_Trig5 = 0x25 , JY5500CoreOO::PXI_Trig6 = 0x26 , JY5500CoreOO::PXI_Trig7 = 0x27
}
enum class | JY5500CoreOO::OutputCompleteState { JY5500CoreOO::Zero , JY5500CoreOO::Hold }
Output Complete State. More...
enum class JY5500CoreOO::IOTerminal {
JY5500CoreOO::Default = 0 , JY5500CoreOO::PXI_Trig0 = 0x20 , JY5500CoreOO::PXI_Trig1 = 0x21 , JY5500CoreOO::PXI_Trig2 = 0x22 ,
JY5500CoreOO::PXI_Trig3 = 0x23 , JY5500CoreOO::PXI_Trig4 = 0x24 , JY5500CoreOO::PXI_Trig5 = 0x25 , JY5500CoreOO::PXI_Trig6 = 0x26 ,
JY5500CoreOO::PXI_Trig7 = 0x27
}
Cunter IO Terminal. More...
enum class | JY5500CoreOO::LevelPolarity { JY5500CoreOO::LowLevel = 0 , JY5500CoreOO::HighLevel = 1 , JY5500CoreOO::None = 2 }
Level Polarity. More...
enum class JY5500CoreOO::InputTerminal {
JY5500CoreOO::Default = 0 , JY5500CoreOO::PXI_Trig0 = 40 , JY5500CoreOO::PXI_Trig1 = 41 , JY5500CoreOO::PXI_Trig2 = 42 ,
JY5500CoreOO::PXI_Trig3 = 43 , JY5500CoreOO::PXI_Trig4 = 44 , JY5500CoreOO::PXI_Trig5 = 45 , JY5500CoreOO::PXI_Trig6 = 46 ,
JY5500CoreOO::PXI_Trig7 = 47 , JY5500CoreOO::CI_0_OutPut = 37 , JY5500CoreOO::CI_1_OutPut = 51 , JY5500CoreOO::CI_2_OutPut = 60 ,
JY5500CoreOO::CI_3_OutPut = 66
}
Cunter Input Terminal. More...

Functions

std::string JY5500CoreOO::GetSignalExportDestinationString (SignalExportDestination destination)

Macro Definition Documentation

◆ EXTERN_C

#define EXTERN_C extern

Windows.

Linux

◆ JY5500CoreOO_API

#define JY5500CoreOO_API


5500 C++ Programming Manual: JY5500CoreOO::JYDriverException Class Reference

  • JYDriverException
Public Member Functions | Public Attributes | List of all members
JY5500CoreOO::JYDriverException Class Reference

#include <JY5500CoreOOCommon.h>

Public Member Functions

JYDriverException (JYDriverExceptionPublic exceptionCode, std::string msg="")
JYDriverException (int, std::string msg)

Public Attributes

std::string exceptionMessage
JYDriverExceptionPublic errorCode
JYDriverException * FollowingException

Constructor & Destructor Documentation

◆ JYDriverException() [1/2]

JY5500CoreOO::JYDriverException::JYDriverException | ( | JYDriverExceptionPublic | exceptionCode,
 |  | std::string | msg = "" )

◆ JYDriverException() [2/2]

JY5500CoreOO::JYDriverException::JYDriverException | ( | int | ,
 |  | std::string | msg )

Member Data Documentation

◆ errorCode

JYDriverExceptionPublic JY5500CoreOO::JYDriverException::errorCode

◆ exceptionMessage

std::string JY5500CoreOO::JYDriverException::exceptionMessage

◆ FollowingException

JYDriverException* JY5500CoreOO::JYDriverException::FollowingException
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOCommon.h


5500 C++ Programming Manual: JY5500CoreOO::JY5500CoreOOProperty< ContainerClass, ValueType, propertyType > Class Template Reference

  • JY5500CoreOOProperty
Public Member Functions | List of all members
JY5500CoreOO::JY5500CoreOOProperty< ContainerClass, ValueType, propertyType > Class Template Reference

属性模板类 More...

#include <JY5500CoreOOCommon.h>

Public Member Functions

JY5500CoreOOProperty ()
JY5500CoreOOProperty (ContainerClass *cObject, ValueType(ContainerClass::*pGet)(), void(ContainerClass::*pSet)(ValueType value))
JY5500CoreOOProperty (ValueType(*pGet)(), void(*pSet)(ValueType value))
ValueType operator= (const ValueType &value)
operator ValueType ()

Detailed Description

template<typename ContainerClass, typename ValueType, JY5500CoreOOPropertyType propertyType>
class JY5500CoreOO::JY5500CoreOOProperty< ContainerClass, ValueType, propertyType >

属性模板类

Constructor & Destructor Documentation

◆ JY5500CoreOOProperty() [1/3]

template<typename ContainerClass, typename ValueType, JY5500CoreOOPropertyType propertyType>
JY5500CoreOO::JY5500CoreOOProperty< ContainerClass, ValueType, propertyType >::JY5500CoreOOProperty ( )

◆ JY5500CoreOOProperty() [2/3]

template<typename ContainerClass, typename ValueType, JY5500CoreOOPropertyType propertyType>
JY5500CoreOO::JY5500CoreOOProperty< ContainerClass, ValueType, propertyType >::JY5500CoreOOProperty | ( | ContainerClass * | cObject,
 |  | ValueType(ContainerClass::* | pGet )(),
 |  | void(ContainerClass::* | pSet )(ValueType value) )

◆ JY5500CoreOOProperty() [3/3]

template<typename ContainerClass, typename ValueType, JY5500CoreOOPropertyType propertyType>
JY5500CoreOO::JY5500CoreOOProperty< ContainerClass, ValueType, propertyType >::JY5500CoreOOProperty | ( | ValueType(* | pGet )(),
 |  | void(* | pSet )(ValueType value) )

Member Function Documentation

◆ operator ValueType()

template<typename ContainerClass, typename ValueType, JY5500CoreOOPropertyType propertyType>
JY5500CoreOO::JY5500CoreOOProperty< ContainerClass, ValueType, propertyType >::operator ValueType ( )

◆ operator=()

template<typename ContainerClass, typename ValueType, JY5500CoreOOPropertyType propertyType>
ValueType JY5500CoreOO::JY5500CoreOOProperty< ContainerClass, ValueType, propertyType >::operator= ( const ValueType & value )
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOCommon.h


5500 C++ Programming Manual: JY5500CoreOO::PauseTrigger Class Reference

  • PauseTrigger
Public Attributes | List of all members
JY5500CoreOO::PauseTrigger Class Reference

Pause trigger configuration class. More...

#include <JY5500CoreOOCommon.h>

Public Attributes

LevelPolarity ActivePolarity
Pause trigger active polarity.
InputTerminal Terminal
Terminal.

Detailed Description

Pause trigger configuration class.

Member Data Documentation

◆ ActivePolarity

LevelPolarity JY5500CoreOO::PauseTrigger::ActivePolarity

Pause trigger active polarity.

The default value is LevelPolarity.None, means the pause trigger is disabled.

◆ Terminal

InputTerminal JY5500CoreOO::PauseTrigger::Terminal

Terminal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOCommon.h


5500 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOCOTask.h File Reference

  • File List
  • File Members
  • COO
  • 5500
Classes | Namespaces | Enumerations
JY5500CoreOOCOTask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JY5500CoreOOCommon.h"
#include "JY5500CoreOODevice.h"

Classes

class | JY5500CoreOO::JY5500CoreOOCOTask
class | JY5500CoreOO::CODigitalTrigger
CO Digital trigger . More...
class | JY5500CoreOO::COTrigger
Constructor to create an COTrigger task object. More...
class | JY5500CoreOO::COPulse
Pulse Parameter. More...
class | JY5500CoreOO::COTimebase
Timebase configuration class. More...
class | JY5500CoreOO::COSignalExport
CO Signal Export Class. More...

Namespaces

namespace JY5500CoreOO

Enumerations

enum class | JY5500CoreOO::COIdleState { JY5500CoreOO::HighLevel = 0x1 , JY5500CoreOO::LowLevel = 0x0 }
Idle state when pulse output before start and after stop. More...
enum class | JY5500CoreOO::COMode { JY5500CoreOO::Single = 3 , JY5500CoreOO::Finite = 0 , JY5500CoreOO::ContinuousNoWrapping = 2 , JY5500CoreOO::ContinuousWrapping = 1 }
enum class | JY5500CoreOO::COTriggerType { JY5500CoreOO::Immediate = 0x0 , JY5500CoreOO::Digital = 0x1 , JY5500CoreOO::Soft = 0x3 }
TriggerType Digital/Immediate/Soft. More...
enum class JY5500CoreOO::CODigitalTriggerSource {
JY5500CoreOO::PFI0 , JY5500CoreOO::PFI1 , JY5500CoreOO::PFI2 , JY5500CoreOO::PFI3 ,
JY5500CoreOO::PFI4 , JY5500CoreOO::PFI5 , JY5500CoreOO::PFI6 , JY5500CoreOO::PFI7 ,
JY5500CoreOO::PFI8 , JY5500CoreOO::PFI9 , JY5500CoreOO::PFI10 , JY5500CoreOO::PFI11 ,
JY5500CoreOO::PFI12 , JY5500CoreOO::PFI13 , JY5500CoreOO::PFI14 , JY5500CoreOO::PFI15 ,
JY5500CoreOO::PXI_Trig0 = 40 , JY5500CoreOO::PXI_Trig1 = 41 , JY5500CoreOO::PXI_Trig2 = 42 , JY5500CoreOO::PXI_Trig3 = 43 ,
JY5500CoreOO::PXI_Trig4 = 44 , JY5500CoreOO::PXI_Trig5 = 45 , JY5500CoreOO::PXI_Trig6 = 46 , JY5500CoreOO::PXI_Trig7 = 47 ,
JY5500CoreOO::AI_StartTrig = 16 , JY5500CoreOO::AI_ReferenceTrig = 17 , JY5500CoreOO::AO_StartTrig = 26 , JY5500CoreOO::DI_StartTrig = 22 ,
JY5500CoreOO::DI_ReferenceTrig = 23 , JY5500CoreOO::DO_StartTrig = 29 , JY5500CoreOO::CI_0_StartTrig = 68 , JY5500CoreOO::CI_1_StartTrig = 73 ,
JY5500CoreOO::CI_2_StartTrig = 76 , JY5500CoreOO::CI_3_StartTrig = 79 , JY5500CoreOO::CO_0_StartTrig = 69 , JY5500CoreOO::CO_1_StartTrig = 74 ,
JY5500CoreOO::CO_2_StartTrig = 77 , JY5500CoreOO::CO_3_StartTrig = 80
}
CO Digital trigger source. More...
enum class | JY5500CoreOO::CODigitalTriggerEdge { JY5500CoreOO::Rising , JY5500CoreOO::Falling }
CO Digital Trigger Edge. More...
enum class | JY5500CoreOO::COPulseType { JY5500CoreOO::DutyCycleFrequency , JY5500CoreOO::HighLowTime , JY5500CoreOO::HighLowTick }
Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick. More...
enum class | JY5500CoreOO::COTimebaseSource { JY5500CoreOO::Internal200MHz }
Timebase source. More...
enum class | JY5500CoreOO::COSignalExportSource { JY5500CoreOO::StartTrig , JY5500CoreOO::Output }
SourceSignal. More...


5500 C++ Programming Manual: JY5500CoreOO::JY5500CoreOOCOTask Class Reference

  • JY5500CoreOOCOTask
Public Member Functions | Public Attributes | List of all members
JY5500CoreOO::JY5500CoreOOCOTask Class Reference

#include <JY5500CoreOOCOTask.h>

Public Member Functions

JY5500CoreOOCOTask (int slotNum, int channel)
JY5500CoreOOCOTask (std::string boardName, int channel)
~JY5500CoreOOCOTask ()
void | WriteSinglePoint (COPulse &pulse)
Write a single pulse parameter to the register.
void | WriteData (COPulse *pulsesGroup[], int samplesToWrite, int timeout=10000)
Write pulse parameters to be output to the buffer.
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Start ()
Start CO task .
void | Stop ()
Stop COtask .
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.

Public Attributes

COMode Mode
CO output mode.
IOTerminal OutputTerminal
PauseTrigger * Pause
COTimebase * TimeBase
CO's time base.
double | InitialDelay
Counter output initial delay in seconds.
COIdleState IdleState
Idle state when pulse output before start and after stop.
uint32_t | SamplesToUpdate
有限频率输出
JY5500CoreOOProperty< JY5500CoreOOCOTask, uint32_t, JY5500CoreOOPropertyType::READ_ONLY > | AvailableSamples
Number of points per channel that can be read in the buffer .
JY5500CoreOOProperty< JY5500CoreOOCOTask, uint64_t, JY5500CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
JY5500CoreOOProperty< JY5500CoreOOCOTask, uint32_t, JY5500CoreOOPropertyType::READ_ONLY > | TransferedPulses
COTrigger * Trigger
CO trigger property configured by CO Trigger().
JY5500CoreOODevice * Device
Device.
COSignalExport * SignalExport
Export CO Signal Configuration.

Constructor & Destructor Documentation

◆ JY5500CoreOOCOTask() [1/2]

JY5500CoreOO::JY5500CoreOOCOTask::JY5500CoreOOCOTask | ( | int | slotNum,
 |  | int | channel )

◆ JY5500CoreOOCOTask() [2/2]

JY5500CoreOO::JY5500CoreOOCOTask::JY5500CoreOOCOTask | ( | std::string | boardName,
 |  | int | channel )

◆ ~JY5500CoreOOCOTask()

JY5500CoreOO::JY5500CoreOOCOTask::~JY5500CoreOOCOTask ( )

Member Function Documentation

◆ SendSoftwareTrigger()

void JY5500CoreOO::JY5500CoreOOCOTask::SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5500CoreOO::JY5500CoreOOCOTask::Start ( )

Start CO task .

◆ Stop()

void JY5500CoreOO::JY5500CoreOOCOTask::Stop ( )

Stop COtask .

◆ WaitUntilDone()

bool JY5500CoreOO::JY5500CoreOOCOTask::WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteData()

void JY5500CoreOO::JY5500CoreOOCOTask::WriteData | ( | COPulse * | pulsesGroup[],
 |  | int | samplesToWrite,
 |  | int | timeout = 10000 )

Write pulse parameters to be output to the buffer.

Valid when Mode is NOT COMode.Single. When Mode is COMode.Finite or COMode.ContinuousWrapping, this function can only be called once before starting the task.

Parameters
pulsesGroup | A group of pulse parameters
samplesToWrite | Number of samples to write. If Mode is COMode.ContinuousWrapping, you need to write at least 2 samples before starting the task
timeout | Timeout (ms). Wait until all data is written to buffer or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ WriteSinglePoint()

void JY5500CoreOO::JY5500CoreOOCOTask::WriteSinglePoint ( COPulse & pulse )

Write a single pulse parameter to the register.

Valid when Mode is COMode.Single. This function is also available after starting the task when the number of pulses being sent is infinite.

Parameters
pulse Pulse Parameter

Member Data Documentation

◆ AvailableSamples

JY5500CoreOOProperty<JY5500CoreOOCOTask, uint32_t, JY5500CoreOOPropertyType::READ_ONLY> JY5500CoreOO::JY5500CoreOOCOTask::AvailableSamples

Number of points per channel that can be read in the buffer .

◆ Device

JY5500CoreOODevice* JY5500CoreOO::JY5500CoreOOCOTask::Device

Device.

◆ IdleState

COIdleState JY5500CoreOO::JY5500CoreOOCOTask::IdleState

Idle state when pulse output before start and after stop.

◆ InitialDelay

double JY5500CoreOO::JY5500CoreOOCOTask::InitialDelay

Counter output initial delay in seconds.

There are five ticks of the timebase fixed delay in counter internal, so the total delay(s) = InitialDelay + (5 / timebase)

◆ Mode

COMode JY5500CoreOO::JY5500CoreOOCOTask::Mode

CO output mode.

◆ OutputTerminal

IOTerminal JY5500CoreOO::JY5500CoreOOCOTask::OutputTerminal

脉冲输出端口

Pulse Output Terminal

◆ Pause

PauseTrigger* JY5500CoreOO::JY5500CoreOOCOTask::Pause

暂停触发配置

Pause Trigger Configuration

◆ SamplesToUpdate

uint32_t JY5500CoreOO::JY5500CoreOOCOTask::SamplesToUpdate

有限频率输出

◆ SignalExport

COSignalExport* JY5500CoreOO::JY5500CoreOOCOTask::SignalExport

Export CO Signal Configuration.

◆ TimeBase

COTimebase* JY5500CoreOO::JY5500CoreOOCOTask::TimeBase

CO's time base.

◆ TransferedPulses

JY5500CoreOOProperty<JY5500CoreOOCOTask, uint32_t, JY5500CoreOOPropertyType::READ_ONLY> JY5500CoreOO::JY5500CoreOOCOTask::TransferedPulses

当前配置下已发送的脉冲的数量。

The number of pulses transfered under the current configuration.

◆ TransferedSamples

JY5500CoreOOProperty<JY5500CoreOOCOTask, uint64_t, JY5500CoreOOPropertyType::READ_ONLY> JY5500CoreOO::JY5500CoreOOCOTask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT CIMode.Single.

◆ Trigger

COTrigger* JY5500CoreOO::JY5500CoreOOCOTask::Trigger

CO trigger property configured by CO Trigger().

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOCOTask.h


5500 C++ Programming Manual: JY5500CoreOO::CODigitalTrigger Class Reference

  • CODigitalTrigger
Public Attributes | List of all members
JY5500CoreOO::CODigitalTrigger Class Reference

CO Digital trigger . More...

#include <JY5500CoreOOCOTask.h>

Public Attributes

CODigitalTriggerSource Source
CO Digital Trigger source.
CODigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Detailed Description

CO Digital trigger .

Member Data Documentation

◆ Edge

CODigitalTriggerEdge JY5500CoreOO::CODigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

CODigitalTriggerSource JY5500CoreOO::CODigitalTrigger::Source

CO Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOCOTask.h


5500 C++ Programming Manual: JY5500CoreOO::COTrigger Class Reference

  • COTrigger
Public Attributes | List of all members
JY5500CoreOO::COTrigger Class Reference

Constructor to create an COTrigger task object. More...

#include <JY5500CoreOOCOTask.h>

Public Attributes

COTriggerType Type
CO trigger type.
CODigitalTrigger * Digital
CO Digital Trigger.

Detailed Description

Constructor to create an COTrigger task object.

Used to build CO Trigger

Member Data Documentation

◆ Digital

CODigitalTrigger* JY5500CoreOO::COTrigger::Digital

CO Digital Trigger.

Valid when Type is COTriggerType.Digital

◆ Type

COTriggerType JY5500CoreOO::COTrigger::Type

CO trigger type.

enum Immediate/Digital/Soft.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOCOTask.h


5500 C++ Programming Manual: JY5500CoreOO::COPulse Class Reference

  • COPulse
Public Member Functions | List of all members
JY5500CoreOO::COPulse Class Reference

Pulse Parameter. More...

#include <JY5500CoreOOCOTask.h>

Public Member Functions

COPulse (COPulseType type, double param1, double param2, int count)
Pulse Parameter.

Detailed Description

Pulse Parameter.

Constructor & Destructor Documentation

◆ COPulse()

JY5500CoreOO::COPulse::COPulse | ( | COPulseType | type,
 |  | double | param1,
 |  | double | param2,
 |  | int | count )

Pulse Parameter.

Parameters
type | The pulse type characteristics.
param1 | Parameter 1. Frequency (Hz) when constructed as COPulseType.DutyCycleFrequency; High duration in seconds when constructed as COPulseType.HighLowTime; High ticks of the clock when constructed as COPulseType.HighLowTick.
param2 | Parameter 1. Duty cycle (greater than 0 and less than 1) when constructed as COPulseType.DutyCycleFrequency; Low duration in seconds when constructed as COPulseType.HighLowTime; Low ticks of the clock when constructed as COPulseType.HighLowTick.
count | Number of pulses. When the value is -1 (indicating that the number of pulses is infinite), pulses will be continuously sent until requested to stop.
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOCOTask.h


5500 C++ Programming Manual: JY5500CoreOO::COTimebase Class Reference

  • COTimebase
Public Attributes | List of all members
JY5500CoreOO::COTimebase Class Reference

Timebase configuration class. More...

#include <JY5500CoreOOCOTask.h>

Public Attributes

COTimebaseSource Source
Timebase Source.

Detailed Description

Timebase configuration class.

Member Data Documentation

◆ Source

COTimebaseSource JY5500CoreOO::COTimebase::Source

Timebase Source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOCOTask.h


5500 C++ Programming Manual: JY5500CoreOO::COSignalExport Class Reference

  • COSignalExport
Public Member Functions | List of all members
JY5500CoreOO::COSignalExport Class Reference

CO Signal Export Class. More...

#include <JY5500CoreOOCOTask.h>

Public Member Functions

void | Add (COSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (COSignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

CO Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY5500CoreOO::COSignalExport::Add | ( | COSignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | CI Signal Source
destination | Export Desination

◆ Add() [2/2]

void JY5500CoreOO::COSignalExport::Add | ( | COSignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | CI Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JY5500CoreOO::COSignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5500CoreOO::COSignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOCOTask.h


5500 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOODevice.h File Reference

  • File List
  • File Members
  • COO
  • 5500
Classes | Namespaces | Enumerations
JY5500CoreOODevice.h File Reference
#include <iostream>
#include <string>
#include <list>
#include <vector>
#include "JY5500CoreOOCommon.h"

Classes

class | JY5500CoreOO::JY5500CoreOODevice
class | JY5500CoreOO::PFIFilter
class | JY5500CoreOO::PFISetting
class | JY5500CoreOO::ExternalReferenceClock
class | JY5500CoreOO::JY5500CoreOOReferenceClock

Namespaces

namespace JY5500CoreOO

Enumerations

enum class | JY5500CoreOO::ExternalReferenceClockTerminal { JY5500CoreOO::PXIe_Clk100 = 0x1 }
enum class | JY5500CoreOO::ReferenceClockSource { JY5500CoreOO::Internal = 0x0 , JY5500CoreOO::External = 0x1 }
enum class JY5500CoreOO::PFITerminal {
JY5500CoreOO::PFI0 = 0 , JY5500CoreOO::PFI1 = 1 , JY5500CoreOO::PFI2 = 2 , JY5500CoreOO::PFI3 = 3 ,
JY5500CoreOO::PFI4 = 4 , JY5500CoreOO::PFI5 = 5 , JY5500CoreOO::PFI6 = 6 , JY5500CoreOO::PFI7 = 7 ,
JY5500CoreOO::PFI8 = 8 , JY5500CoreOO::PFI9 = 9 , JY5500CoreOO::PFI10 = 10 , JY5500CoreOO::PFI11 = 11 ,
JY5500CoreOO::PFI12 = 12 , JY5500CoreOO::PFI13 = 13 , JY5500CoreOO::PFI14 = 14 , JY5500CoreOO::PFI15 = 15
}
Input/Output Terminal of PFI. More...


5500 C++ Programming Manual: JY5500CoreOO::JY5500CoreOODevice Class Reference

  • JY5500CoreOODevice
Static Public Member Functions | Public Attributes | List of all members
JY5500CoreOO::JY5500CoreOODevice Class Reference

#include <JY5500CoreOODevice.h>

Static Public Member Functions

static JY5500CoreOODevice * | GetInstance (int cardNum)
static JY5500CoreOODevice * | GetInstance (std::string aliasName)

Public Attributes

const double | BoardClockRate = 100e6
const double | MaxSampleRateMutilChannel = 1000000
const int | AIBufferSize = 0x100000 * 64
const bool | IsAISync = false
const double | MaxUpdateRateSingleChannel = 2860000
AOMaxUpdateRateSingleChannel.
const double | MaxUpdateRateTwoChannel = 2000000
AOMaxUpdateRateTwoChannel.
const double | MaxUpdateRateThreeChannel = 1540000
AOMaxUpdateRateThreeChannel.
const double | MaxUpdateRateFourChannel = 1250000
AOMaxUpdateRateFourChannel.
const bool | IsAOSync = true
IsAOSync.
JY5500CoreOOProperty< JY5500CoreOODevice, int, JY5500CoreOOPropertyType::READ_ONLY > | DiffChannelCount
JY5500CoreOOProperty< JY5500CoreOODevice, int, JY5500CoreOOPropertyType::READ_ONLY > | SEChannelCount
JY5500CoreOOProperty< JY5500CoreOODevice, double, JY5500CoreOOPropertyType::READ_ONLY > | MaxSampleRateSingleChannel
JY5500CoreOOProperty< JY5500CoreOODevice, int, JY5500CoreOOPropertyType::READ_ONLY > | AOChannelCount
JY5500CoreOOProperty< JY5500CoreOODevice, std::string, JY5500CoreOOPropertyType::READ_ONLY > | SerialNumber
JY5500CoreOOProperty< JY5500CoreOODevice, int, JY5500CoreOOPropertyType::READ_ONLY > | DeviceID
JY5500CoreOOProperty< JY5500CoreOODevice, void *, JY5500CoreOOPropertyType::READ_ONLY > | Handle
PFISetting * PFI
JY5500CoreOOReferenceClock * ReferenceClock

Member Function Documentation

◆ GetInstance() [1/2]

static JY5500CoreOODevice * JY5500CoreOO::JY5500CoreOODevice::GetInstance ( int cardNum )
static

◆ GetInstance() [2/2]

static JY5500CoreOODevice * JY5500CoreOO::JY5500CoreOODevice::GetInstance ( std::string aliasName )
static

Member Data Documentation

◆ AIBufferSize

const int JY5500CoreOO::JY5500CoreOODevice::AIBufferSize = 0x100000 * 64

◆ AOChannelCount

JY5500CoreOOProperty<JY5500CoreOODevice, int, JY5500CoreOOPropertyType::READ_ONLY> JY5500CoreOO::JY5500CoreOODevice::AOChannelCount

◆ BoardClockRate

const double JY5500CoreOO::JY5500CoreOODevice::BoardClockRate = 100e6

◆ DeviceID

JY5500CoreOOProperty<JY5500CoreOODevice, int, JY5500CoreOOPropertyType::READ_ONLY> JY5500CoreOO::JY5500CoreOODevice::DeviceID

◆ DiffChannelCount

JY5500CoreOOProperty<JY5500CoreOODevice, int, JY5500CoreOOPropertyType::READ_ONLY> JY5500CoreOO::JY5500CoreOODevice::DiffChannelCount

◆ Handle

JY5500CoreOOProperty<JY5500CoreOODevice, void*, JY5500CoreOOPropertyType::READ_ONLY> JY5500CoreOO::JY5500CoreOODevice::Handle

◆ IsAISync

const bool JY5500CoreOO::JY5500CoreOODevice::IsAISync = false

◆ IsAOSync

const bool JY5500CoreOO::JY5500CoreOODevice::IsAOSync = true

IsAOSync.

◆ MaxSampleRateMutilChannel

const double JY5500CoreOO::JY5500CoreOODevice::MaxSampleRateMutilChannel = 1000000

◆ MaxSampleRateSingleChannel

JY5500CoreOOProperty<JY5500CoreOODevice, double, JY5500CoreOOPropertyType::READ_ONLY> JY5500CoreOO::JY5500CoreOODevice::MaxSampleRateSingleChannel

◆ MaxUpdateRateFourChannel

const double JY5500CoreOO::JY5500CoreOODevice::MaxUpdateRateFourChannel = 1250000

AOMaxUpdateRateFourChannel.

◆ MaxUpdateRateSingleChannel

const double JY5500CoreOO::JY5500CoreOODevice::MaxUpdateRateSingleChannel = 2860000

AOMaxUpdateRateSingleChannel.

◆ MaxUpdateRateThreeChannel

const double JY5500CoreOO::JY5500CoreOODevice::MaxUpdateRateThreeChannel = 1540000

AOMaxUpdateRateThreeChannel.

◆ MaxUpdateRateTwoChannel

const double JY5500CoreOO::JY5500CoreOODevice::MaxUpdateRateTwoChannel = 2000000

AOMaxUpdateRateTwoChannel.

◆ PFI

PFISetting* JY5500CoreOO::JY5500CoreOODevice::PFI

◆ ReferenceClock

JY5500CoreOOReferenceClock* JY5500CoreOO::JY5500CoreOODevice::ReferenceClock

◆ SEChannelCount

JY5500CoreOOProperty<JY5500CoreOODevice, int, JY5500CoreOOPropertyType::READ_ONLY> JY5500CoreOO::JY5500CoreOODevice::SEChannelCount

◆ SerialNumber

JY5500CoreOOProperty<JY5500CoreOODevice, std::string, JY5500CoreOOPropertyType::READ_ONLY> JY5500CoreOO::JY5500CoreOODevice::SerialNumber
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOODevice.h


5500 C++ Programming Manual: JY5500CoreOO::PFIFilter Class Reference

  • PFIFilter
Public Member Functions | List of all members
JY5500CoreOO::PFIFilter Class Reference

#include <JY5500CoreOODevice.h>

Public Member Functions

void | Enable (PFITerminal terminal, int minPulseWidth)
Enable the filter on the specified terminal and set the minimum pulse width.
void | Enable (std::vector< PFITerminal > terminals, int minPulseWidth)
Enable the filter on a group of terminals and set the minimum pulse width.
void | Enable (std::vector< PFITerminal > terminals, std::vector< int > minPulseWidth)
Enable the filter on a group of terminals and set the minimum pulse width separately.
void | Disable (PFITerminal terminal)
Disable the filter on the specified terminal.
void | Disable (std::vector< PFITerminal > terminals)
Disable the filter on a group terminal.
void | DisableAll ()
Disable the filter on all the terminals.

Member Function Documentation

◆ Disable() [1/2]

void JY5500CoreOO::PFIFilter::Disable ( PFITerminal terminal )

Disable the filter on the specified terminal.

Parameters
terminal Specified Terminal

◆ Disable() [2/2]

void JY5500CoreOO::PFIFilter::Disable ( std::vector< PFITerminal > terminals )

Disable the filter on a group terminal.

Parameters
terminals Specified Group of Terminal

◆ DisableAll()

void JY5500CoreOO::PFIFilter::DisableAll ( )

Disable the filter on all the terminals.

◆ Enable() [1/3]

void JY5500CoreOO::PFIFilter::Enable | ( | PFITerminal | terminal,
 |  | int | minPulseWidth )

Enable the filter on the specified terminal and set the minimum pulse width.

Parameters
terminal | Specified Terminal
minPulseWidth | Minimum pulse width in ns, bounce less than this length will be ignored. The smallest step in the range of 10 ns to 2550 ns is 10 ns, the smallest step in the range of 2550 ns to 40800 ns is 160 ns, and the smallest step in the range of 40800 ns to 652800 ns The step is 2560 ns

◆ Enable() [2/3]

void JY5500CoreOO::PFIFilter::Enable | ( | std::vector< PFITerminal > | terminals,
 |  | int | minPulseWidth )

Enable the filter on a group of terminals and set the minimum pulse width.

Parameters
terminals | Specified Group of Terminals
minPulseWidth | Minimum pulse width in ns, bounce less than this length will be ignored. The smallest step in the range of 10 ns to 2550 ns is 10 ns, the smallest step in the range of 2550 ns to 40800 ns is 160 ns, and the smallest step in the range of 40800 ns to 652800 ns The step is 2560 ns

◆ Enable() [3/3]

void JY5500CoreOO::PFIFilter::Enable | ( | std::vector< PFITerminal > | terminals,
 |  | std::vector< int > | minPulseWidth )

Enable the filter on a group of terminals and set the minimum pulse width separately.

Parameters
terminals | Specified Group of Terminals
minPulseWidth | Minimum pulse width in ns, bounce less than this length will be ignored. The smallest step in the range of 10 ns to 2550 ns is 10 ns, the smallest step in the range of 2550 ns to 40800 ns is 160 ns, and the smallest step in the range of 40800 ns to 652800 ns The step is 2560 ns
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOODevice.h


5500 C++ Programming Manual: JY5500CoreOO::PFISetting Class Reference

  • PFISetting
Public Attributes | List of all members
JY5500CoreOO::PFISetting Class Reference

#include <JY5500CoreOODevice.h>

Public Attributes

PFIFilter * Filter
PFI Filter Setting.

Member Data Documentation

◆ Filter

PFIFilter* JY5500CoreOO::PFISetting::Filter

PFI Filter Setting.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOODevice.h


5500 C++ Programming Manual: JY5500CoreOO::ExternalReferenceClock Class Reference

  • ExternalReferenceClock
Public Attributes | List of all members
JY5500CoreOO::ExternalReferenceClock Class Reference

#include <JY5500CoreOODevice.h>

Public Attributes

ExternalReferenceClockTerminal Terminal

Member Data Documentation

◆ Terminal

ExternalReferenceClockTerminal JY5500CoreOO::ExternalReferenceClock::Terminal
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOODevice.h


5500 C++ Programming Manual: JY5500CoreOO::JY5500CoreOOReferenceClock Class Reference

  • JY5500CoreOOReferenceClock
Public Member Functions | Public Attributes | List of all members
JY5500CoreOO::JY5500CoreOOReferenceClock Class Reference

#include <JY5500CoreOODevice.h>

Public Member Functions

void Commit ()
Commit configuration.

Public Attributes

ReferenceClockSource Source
ExternalReferenceClock * External
External Reference Clock Source.

Member Function Documentation

◆ Commit()

void JY5500CoreOO::JY5500CoreOOReferenceClock::Commit ( )

Commit configuration.

Available only when the device is idle. WARNING: Incorrect parameters will cause the PLL to be unable to lock the reference clock and cannot be recovered until shutdown and restart.

Member Data Documentation

◆ External

ExternalReferenceClock* JY5500CoreOO::JY5500CoreOOReferenceClock::External

External Reference Clock Source.

Required when ReferenceClock.Source is ReferenceClockSource.External

◆ Source

ReferenceClockSource JY5500CoreOO::JY5500CoreOOReferenceClock::Source
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOODevice.h


5500 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOODITask.h File Reference

  • File List
  • File Members
  • COO
  • 5500
Classes | Namespaces | Enumerations
JY5500CoreOODITask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JY5500CoreOOCommon.h"
#include "JY5500CoreOODevice.h"

Classes

class | JY5500CoreOO::JY5500CoreOODITask
class | JY5500CoreOO::DIChannel
DI Channel parameter class . More...
class | JY5500CoreOO::DISampleClock
Sample clock configuration class. More...
class | JY5500CoreOO::DIExternalSampleClock
External Sample Clock Configuration Class. More...
class | JY5500CoreOO::DISignalExport
DI Signal Export Class. More...
class | JY5500CoreOO::DITrigger
Constructor to create an DITrigger task object. More...
class | JY5500CoreOO::DIDigitalTrigger
DI Digital trigger . More...

Namespaces

namespace JY5500CoreOO

Enumerations

enum class | JY5500CoreOO::DISampleClockSource { JY5500CoreOO::Internal , JY5500CoreOO::External }
DI Sample Clock Source. More...
enum class | JY5500CoreOO::DIMode { JY5500CoreOO::Single = 2 , JY5500CoreOO::Finite = 0 , JY5500CoreOO::Continuous = 1 }
DIMode. More...
enum class | JY5500CoreOO::DISignalExportSource { JY5500CoreOO::StartTrig = 22 , JY5500CoreOO::ReferenceTrig = 23 , JY5500CoreOO::SampleClock = 53 }
SourceSignal. More...
enum class | JY5500CoreOO::DITriggerMode { JY5500CoreOO::Start , JY5500CoreOO::Reference }
DI Trigger Mode. More...
enum class | JY5500CoreOO::DITriggerType { JY5500CoreOO::Immediate = 0 , JY5500CoreOO::Digital = 1 , JY5500CoreOO::Soft = 3 }
TriggerType Digital/Immediate/Soft. More...
enum class JY5500CoreOO::DIDigitalTriggerSource {
JY5500CoreOO::PFI0 , JY5500CoreOO::PFI1 , JY5500CoreOO::PFI2 , JY5500CoreOO::PFI3 ,
JY5500CoreOO::PFI4 , JY5500CoreOO::PFI5 , JY5500CoreOO::PFI6 , JY5500CoreOO::PFI7 ,
JY5500CoreOO::PFI8 , JY5500CoreOO::PFI9 , JY5500CoreOO::PFI10 , JY5500CoreOO::PFI11 ,
JY5500CoreOO::PFI12 , JY5500CoreOO::PFI13 , JY5500CoreOO::PFI14 , JY5500CoreOO::PFI15 ,
JY5500CoreOO::PXI_Trig0 = 40 , JY5500CoreOO::PXI_Trig1 = 41 , JY5500CoreOO::PXI_Trig2 = 42 , JY5500CoreOO::PXI_Trig3 = 43 ,
JY5500CoreOO::PXI_Trig4 = 44 , JY5500CoreOO::PXI_Trig5 = 45 , JY5500CoreOO::PXI_Trig6 = 46 , JY5500CoreOO::PXI_Trig7 = 47 ,
JY5500CoreOO::AI_StartTrig = 16 , JY5500CoreOO::AI_ReferenceTrig = 17 , JY5500CoreOO::AO_StartTrig = 26 , JY5500CoreOO::DO_StartTrig = 29 ,
JY5500CoreOO::CI_0_StartTrig = 68 , JY5500CoreOO::CI_1_StartTrig = 73 , JY5500CoreOO::CI_2_StartTrig = 73 , JY5500CoreOO::CI_3_StartTrig = 73 ,
JY5500CoreOO::CO_0_StartTrig = 69 , JY5500CoreOO::CO_1_StartTrig = 74 , JY5500CoreOO::CO2_StartTrig = 77 , JY5500CoreOO::CO_3_StartTrig = 80 ,
JY5500CoreOO::CO_0_Output = 37 , JY5500CoreOO::CO_1_Output = 51 , JY5500CoreOO::CO_2_Output = 60 , JY5500CoreOO::CO_3_Output = 66
}
DI Digital trigger source. More...
enum class | JY5500CoreOO::DIDigitalTriggerEdge { JY5500CoreOO::Rising , JY5500CoreOO::Falling }
DI Digital Trigger Edge. More...


5500 C++ Programming Manual: JY5500CoreOO::JY5500CoreOODITask Class Reference

  • JY5500CoreOODITask
Public Member Functions | Public Attributes | List of all members
JY5500CoreOO::JY5500CoreOODITask Class Reference

#include <JY5500CoreOODITask.h>

Public Member Functions

JY5500CoreOODITask (int slotNum)
JY5500CoreOODITask (std::string boardName)
~JY5500CoreOODITask ()
void | AddChannel (int portNum)
Add one channel.
void | AddChannel (std::vector< int > portsNum)
Add a group of channel.
void | RemoveChannel (int portNum)
Delete the specified port number .If it is -1, delete all ports.
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Start ()
Start DI task .
void | Stop ()
Stop DI task .
void | ReadSinglePoint (std::vector< bool > &readValues, int port)
Read one sample for specified channel in register.
void | ReadSinglePoint (std::vector< bool > &readValues)
Read one sample for all ports in register .
void | ReadSinglePoint (bool readValues[])
Read one sample for all ports in register .
void | ReadData (uint32_t dataBuffer[], uint32_t samplesToAcquire, int timeOut=10000)
Read the uint data from one port or multi-ports.
void | ReadData (uint8_t dataBuffer[], uint32_t samplesToAcquire, int timeOut=10000)
Read the byte data from one port.

Public Attributes

std::list< DIChannel * > | Channels
List of DI channels,(5510 5511 support 6 ports)(5515 5516 support 3 ports)
DIMode Mode
DI acquisition mode，support Single/ Finite/Continuous.
JY5500CoreOOProperty< JY5500CoreOODITask, double, JY5500CoreOOPropertyType::READ_WRITE > | SampleRate
Sample rate per channel.
int | SamplesToAcquire
Number of samples to be read per channel.
DISampleClock * SampleClock
DI Sample Clock Configuration.
JY5500CoreOOProperty< JY5500CoreOODITask, int, JY5500CoreOOPropertyType::READ_ONLY > | BufLenInSamples
Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.
JY5500CoreOOProperty< JY5500CoreOODITask, uint64_t, JY5500CoreOOPropertyType::READ_ONLY > | AvailableSamples
Number of samples per channel that can be read in the buffer.
JY5500CoreOOProperty< JY5500CoreOODITask, uint64_t, JY5500CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
DITrigger * Trigger
DI Trigger Configuration.
DISignalExport * SignalExport
Export DI Signal.
JY5500CoreOODevice * Device
Device.

Constructor & Destructor Documentation

◆ JY5500CoreOODITask() [1/2]

JY5500CoreOO::JY5500CoreOODITask::JY5500CoreOODITask ( int slotNum )

◆ JY5500CoreOODITask() [2/2]

JY5500CoreOO::JY5500CoreOODITask::JY5500CoreOODITask ( std::string boardName )

◆ ~JY5500CoreOODITask()

JY5500CoreOO::JY5500CoreOODITask::~JY5500CoreOODITask ( )

Member Function Documentation

◆ AddChannel() [1/2]

void JY5500CoreOO::JY5500CoreOODITask::AddChannel ( int portNum )

Add one channel.

Parameters
portNum port number to be added.

◆ AddChannel() [2/2]

void JY5500CoreOO::JY5500CoreOODITask::AddChannel ( std::vector< int > portsNum )

Add a group of channel.

Parameters
portsNum an array of port numbers of added ports.

◆ ReadData() [1/2]

void JY5500CoreOO::JY5500CoreOODITask::ReadData | ( | uint32_t | dataBuffer[],
 |  | uint32_t | samplesToAcquire,
 |  | int | timeOut = 10000 )

Read the uint data from one port or multi-ports.

There are 4 ports, from 0 to 3. Each port has 8 lines, from 0 to 7. There are a total of 32 lines from 0 to 31. Each bit from low to high represents one line.

Parameters
dataBuffer | Data buffer
samplesToAcquire | Number of samples per port to be read
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadData() [2/2]

void JY5500CoreOO::JY5500CoreOODITask::ReadData | ( | uint8_t | dataBuffer[],
 |  | uint32_t | samplesToAcquire,
 |  | int | timeOut = 10000 )

Read the byte data from one port.

Each port has 8 lines from 0 to 7. Each bit from low to high represents one line.

Parameters
dataBuffer | Data buffer
samplesToAcquire | Number of samples per port to be read
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadSinglePoint() [1/3]

void JY5500CoreOO::JY5500CoreOODITask::ReadSinglePoint ( bool readValues[] )

Read one sample for all ports in register .

Available when Mode is DIMode.Single

Parameters
readValues Values read. Buffer size >= number of ports * 8.

◆ ReadSinglePoint() [2/3]

void JY5500CoreOO::JY5500CoreOODITask::ReadSinglePoint ( std::vector< bool > & readValues )

Read one sample for all ports in register .

Available when Mode is DIMode.Single

Parameters
readValues Values read. Buffer size >= number of ports * 8.

◆ ReadSinglePoint() [3/3]

void JY5500CoreOO::JY5500CoreOODITask::ReadSinglePoint | ( | std::vector< bool > & | readValues,
 |  | int | port )

Read one sample for specified channel in register.

. Available when Mode is DIMode.Single

Parameters
readValues | values read,. Buffer size >= 8
port | Specified port numbers.

◆ RemoveChannel()

void JY5500CoreOO::JY5500CoreOODITask::RemoveChannel ( int portNum )

Delete the specified port number .If it is -1, delete all ports.

Parameters
portNum port number to be delete.

◆ SendSoftwareTrigger()

void JY5500CoreOO::JY5500CoreOODITask::SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5500CoreOO::JY5500CoreOODITask::Start ( )

Start DI task .

◆ Stop()

void JY5500CoreOO::JY5500CoreOODITask::Stop ( )

Stop DI task .

Member Data Documentation

◆ AvailableSamples

JY5500CoreOOProperty<JY5500CoreOODITask, uint64_t, JY5500CoreOOPropertyType::READ_ONLY> JY5500CoreOO::JY5500CoreOODITask::AvailableSamples

Number of samples per channel that can be read in the buffer.

◆ BufLenInSamples

JY5500CoreOOProperty<JY5500CoreOODITask, int, JY5500CoreOOPropertyType::READ_ONLY> JY5500CoreOO::JY5500CoreOODITask::BufLenInSamples

Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.

◆ Channels

std::list<DIChannel*> JY5500CoreOO::JY5500CoreOODITask::Channels

List of DI channels,(5510 5511 support 6 ports)(5515 5516 support 3 ports)

◆ Device

JY5500CoreOODevice* JY5500CoreOO::JY5500CoreOODITask::Device

Device.

◆ Mode

DIMode JY5500CoreOO::JY5500CoreOODITask::Mode

DI acquisition mode，support Single/ Finite/Continuous.

◆ SampleClock

DISampleClock* JY5500CoreOO::JY5500CoreOODITask::SampleClock

DI Sample Clock Configuration.

◆ SampleRate

JY5500CoreOOProperty<JY5500CoreOODITask, double, JY5500CoreOOPropertyType::READ_WRITE> JY5500CoreOO::JY5500CoreOODITask::SampleRate

Sample rate per channel.

Maximum sample rate is 10M The defalut sample rate = 10k You can read this property to obtain the sample rate that will actually take effect in the current configuration.

◆ SamplesToAcquire

int JY5500CoreOO::JY5500CoreOODITask::SamplesToAcquire

Number of samples to be read per channel.

Only valid when Mode is DIMode.Finite.

◆ SignalExport

DISignalExport* JY5500CoreOO::JY5500CoreOODITask::SignalExport

Export DI Signal.

◆ TransferedSamples

JY5500CoreOOProperty<JY5500CoreOODITask, uint64_t, JY5500CoreOOPropertyType::READ_ONLY> JY5500CoreOO::JY5500CoreOODITask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT DIMode::Single.

◆ Trigger

DITrigger* JY5500CoreOO::JY5500CoreOODITask::Trigger

DI Trigger Configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOODITask.h


5500 C++ Programming Manual: JY5500CoreOO::DIChannel Class Reference

  • DIChannel
Public Attributes | List of all members
JY5500CoreOO::DIChannel Class Reference

DI Channel parameter class . More...

#include <JY5500CoreOODITask.h>

Public Attributes

int PortNum
port number.

Detailed Description

DI Channel parameter class .

Member Data Documentation

◆ PortNum

int JY5500CoreOO::DIChannel::PortNum

port number.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOODITask.h


5500 C++ Programming Manual: JY5500CoreOO::DISampleClock Class Reference

  • DISampleClock
Public Attributes | List of all members
JY5500CoreOO::DISampleClock Class Reference

Sample clock configuration class. More...

#include <JY5500CoreOODITask.h>

Public Attributes

DISampleClockSource Source
Clock Source.
DIExternalSampleClock * External
External Sample Clock, Valid when Source is DISampleClockSource.External.

Detailed Description

Sample clock configuration class.

Member Data Documentation

◆ External

DIExternalSampleClock* JY5500CoreOO::DISampleClock::External

External Sample Clock, Valid when Source is DISampleClockSource.External.

◆ Source

DISampleClockSource JY5500CoreOO::DISampleClock::Source

Clock Source.

enum Internal/External

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOODITask.h


5500 C++ Programming Manual: JY5500CoreOO::DIExternalSampleClock Class Reference

  • DIExternalSampleClock
Public Attributes | List of all members
JY5500CoreOO::DIExternalSampleClock Class Reference

External Sample Clock Configuration Class. More...

#include <JY5500CoreOODITask.h>

Public Attributes

ClockTerminal Terminal
External Sample Clock Input Terminal.
double ExpectedRate
Expected External Sample Clock Rate.

Detailed Description

External Sample Clock Configuration Class.

Member Data Documentation

◆ ExpectedRate

double JY5500CoreOO::DIExternalSampleClock::ExpectedRate

Expected External Sample Clock Rate.

◆ Terminal

ClockTerminal JY5500CoreOO::DIExternalSampleClock::Terminal

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOODITask.h


5500 C++ Programming Manual: JY5500CoreOO::DISignalExport Class Reference

  • DISignalExport
Public Member Functions | List of all members
JY5500CoreOO::DISignalExport Class Reference

DI Signal Export Class. More...

#include <JY5500CoreOODITask.h>

Public Member Functions

void | Add (DISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (DISignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

DI Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY5500CoreOO::DISignalExport::Add | ( | DISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | CI Signal Source
destination | Export Desination

◆ Add() [2/2]

void JY5500CoreOO::DISignalExport::Add | ( | DISignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | CI Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JY5500CoreOO::DISignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5500CoreOO::DISignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOODITask.h


5500 C++ Programming Manual: JY5500CoreOO::DITrigger Class Reference

  • DITrigger
Public Attributes | List of all members
JY5500CoreOO::DITrigger Class Reference

Constructor to create an DITrigger task object. More...

#include <JY5500CoreOODITask.h>

Public Attributes

DITriggerType Type
DI trigger type.
DITriggerMode Mode
DI trigger mode.
DIDigitalTrigger * Digital
DI Digital Trigger.Valid when Type is DITriggerType.Digital.
uint32_t PreTriggerSamples
Pretrigger Samples, must be less than or equal to JY5500DITask.SamplesToAcquire.

Detailed Description

Constructor to create an DITrigger task object.

Used to build DI Trigger

Member Data Documentation

◆ Digital

DIDigitalTrigger* JY5500CoreOO::DITrigger::Digital

DI Digital Trigger.Valid when Type is DITriggerType.Digital.

◆ Mode

DITriggerMode JY5500CoreOO::DITrigger::Mode

DI trigger mode.

enum Start/Reference.

◆ PreTriggerSamples

uint32_t JY5500CoreOO::DITrigger::PreTriggerSamples

Pretrigger Samples, must be less than or equal to JY5500DITask.SamplesToAcquire.

Valid when Mode is DITriggerMode.Reference. Pretrigger samples, must be greater than 1. Valid when Type is DITriggerType.Digital.

◆ Type

DITriggerType JY5500CoreOO::DITrigger::Type

DI trigger type.

enum Digital/Immediate/Soft.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOODITask.h


5500 C++ Programming Manual: JY5500CoreOO::DIDigitalTrigger Class Reference

  • DIDigitalTrigger
Public Attributes | List of all members
JY5500CoreOO::DIDigitalTrigger Class Reference

DI Digital trigger . More...

#include <JY5500CoreOODITask.h>

Public Attributes

DIDigitalTriggerSource Source
DI Digital Trigger source.
DIDigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Detailed Description

DI Digital trigger .

Member Data Documentation

◆ Edge

DIDigitalTriggerEdge JY5500CoreOO::DIDigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

DIDigitalTriggerSource JY5500CoreOO::DIDigitalTrigger::Source

DI Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOODITask.h


5500 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOODOTask.h File Reference

  • File List
  • File Members
  • COO
  • 5500
Classes | Namespaces | Enumerations
JY5500CoreOODOTask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JY5500CoreOOCommon.h"
#include "JY5500CoreOODevice.h"

Classes

class | JY5500CoreOO::JY5500CoreOODOTask
class | JY5500CoreOO::DOChannel
DO Channel parameter class . More...
class | JY5500CoreOO::DOSampleClock
Sample clock configuration class. More...
class | JY5500CoreOO::DOExternalSampleClock
External Sample Clock Configuration Class. More...
class | JY5500CoreOO::DODigitalTrigger
DO Digital trigger. More...
class | JY5500CoreOO::DOTrigger
Constructor to create an DOTrigger task object. More...
class | JY5500CoreOO::DOSignalExport
DO Signal Export Class. More...

Namespaces

namespace JY5500CoreOO

Enumerations

enum class | JY5500CoreOO::DOSampleClockSource { JY5500CoreOO::Internal , JY5500CoreOO::External }
DO Sample Clock Source. More...
enum class | JY5500CoreOO::DOMode { JY5500CoreOO::Single = 3 , JY5500CoreOO::Finite = 0 , JY5500CoreOO::ContinuousWrapping = 1 , JY5500CoreOO::ContinuousNoWrapping = 2 }
DOMode. More...
enum class | JY5500CoreOO::DODigitalTriggerEdge { JY5500CoreOO::Rising , JY5500CoreOO::Falling }
DO Digital Trigger Edge. More...
enum class JY5500CoreOO::DODigitalTriggerSource {
JY5500CoreOO::PFI0 , JY5500CoreOO::PFI1 , JY5500CoreOO::PFI2 , JY5500CoreOO::PFI3 ,
JY5500CoreOO::PFI4 , JY5500CoreOO::PFI5 , JY5500CoreOO::PFI6 , JY5500CoreOO::PFI7 ,
JY5500CoreOO::PFI8 , JY5500CoreOO::PFI9 , JY5500CoreOO::PFI10 , JY5500CoreOO::PFI11 ,
JY5500CoreOO::PFI12 , JY5500CoreOO::PFI13 , JY5500CoreOO::PFI14 , JY5500CoreOO::PFI15 ,
JY5500CoreOO::PXI_Trig0 = 40 , JY5500CoreOO::PXI_Trig1 = 41 , JY5500CoreOO::PXI_Trig2 = 42 , JY5500CoreOO::PXI_Trig3 = 43 ,
JY5500CoreOO::PXI_Trig4 = 44 , JY5500CoreOO::PXI_Trig5 = 45 , JY5500CoreOO::PXI_Trig6 = 46 , JY5500CoreOO::PXI_Trig7 = 47 ,
JY5500CoreOO::AI_StartTrig = 16 , JY5500CoreOO::AI_ReferenceTrig = 17 , JY5500CoreOO::AO_StartTrig = 26 , JY5500CoreOO::DI_StartTrig = 22 ,
JY5500CoreOO::DI_ReferenceTrig = 23 , JY5500CoreOO::CI_0_StartTrig = 68 , JY5500CoreOO::CI_1_StartTrig = 73 , JY5500CoreOO::CI_2_StartTrig = 76 ,
JY5500CoreOO::CI_3_StartTrig = 79 , JY5500CoreOO::CO_0_StartTrig = 69 , JY5500CoreOO::CO_1_StartTrig = 74 , JY5500CoreOO::CO_2_StartTrig = 77 ,
JY5500CoreOO::CO_3_StartTrig = 80 , JY5500CoreOO::CO_0_Output = 37 , JY5500CoreOO::CO_1_Output = 51 , JY5500CoreOO::CO_2_Output = 60 ,
JY5500CoreOO::CO_3_Output = 66
}
DO Digital trigger source. More...
enum class | JY5500CoreOO::DOTriggerType { JY5500CoreOO::Immediate = 0 , JY5500CoreOO::Digital = 1 , JY5500CoreOO::Soft = 3 }
TriggerType Digital/Immediate/Soft. More...
enum class | JY5500CoreOO::DOSignalExportSource { JY5500CoreOO::StartTrig = 29 , JY5500CoreOO::SampleClock = 54 }
SourceSignal. More...


5500 C++ Programming Manual: JY5500CoreOO::JY5500CoreOODOTask Class Reference

  • JY5500CoreOODOTask
Public Member Functions | Public Attributes | List of all members
JY5500CoreOO::JY5500CoreOODOTask Class Reference

#include <JY5500CoreOODOTask.h>

Public Member Functions

JY5500CoreOODOTask (int slotNum)
JY5500CoreOODOTask (std::string boardName)
~JY5500CoreOODOTask ()
void | AddChannel (int portNum)
Add one channel.
void | AddChannel (std::vector< int > portsNum)
Add a group of channel.
void | RemoveChannel (int portNum)
Delete the specified port number .If it is -1, delete all ports.
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Start ()
Start DO task .
void | Stop ()
Stop DO task .
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.
void | WriteSinglePoint (std::vector< bool > &writeValues, int port)
Write one sample to the specified port in register.Available when Mode is DOMode.Single
void | WriteSinglePoint (std::vector< bool > &writeValues)
Read one sample for all ports in register .
void | WriteData (uint32_t dataBuffer[], uint32_t samplesToUpdate, int timeOut=10000)
Write the uint data from one port or multi-ports.
void | WriteData (std::vector< uint32_t > &dataBuffer, uint32_t samplesToUpdate, int timeOut=10000)
Write the uint data from one port or multi-ports.
void | WriteData (uint8_t dataBuffer[], uint32_t samplesToUpdate, int timeOut=10000)
wirte the byte data to one port.
void | WriteData (std::vector< uint8_t > &dataBuffer, uint32_t samplesToUpdate, int timeOut=10000)
wirte the byte data to one port.

Public Attributes

std::list< DOChannel * > | Channels
List of DO channels,(5510 5511 support 6 ports)(5515 5516 support 3 ports)
DOMode Mode
DO acquisition mode，support Single/ Finite/Continuous.
JY5500CoreOOProperty< JY5500CoreOODOTask, double, JY5500CoreOOPropertyType::READ_WRITE > | UpdateRate
Sample rate per channel.
int | SamplesToUpdate
Number of output samples to write per channel , Only valid when Mode is DOMode::Finite.
DOSampleClock * SampleClock
DO Sample Clock Configuration.
JY5500CoreOOProperty< JY5500CoreOODOTask, int, JY5500CoreOOPropertyType::READ_ONLY > | BufLenInSamples
Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.
JY5500CoreOOProperty< JY5500CoreOODOTask, uint64_t, JY5500CoreOOPropertyType::READ_ONLY > | AvaliableLenInSamples
Number of output samples per channel avaliable to write in DO buffuer.
JY5500CoreOOProperty< JY5500CoreOODOTask, uint64_t, JY5500CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
OutputCompleteState CompleteState
DO Output Complete State, Valid when Mode is NOT DOMode.Single.Default is Zero.
DOTrigger * Trigger
DO Trigger Configuration.
DOSignalExport * SignalExport
Export DO Signal.
JY5500CoreOODevice * Device
Device.

Constructor & Destructor Documentation

◆ JY5500CoreOODOTask() [1/2]

JY5500CoreOO::JY5500CoreOODOTask::JY5500CoreOODOTask ( int slotNum )

◆ JY5500CoreOODOTask() [2/2]

JY5500CoreOO::JY5500CoreOODOTask::JY5500CoreOODOTask ( std::string boardName )

◆ ~JY5500CoreOODOTask()

JY5500CoreOO::JY5500CoreOODOTask::~JY5500CoreOODOTask ( )

Member Function Documentation

◆ AddChannel() [1/2]

void JY5500CoreOO::JY5500CoreOODOTask::AddChannel ( int portNum )

Add one channel.

Parameters
portNum port number to be added.

◆ AddChannel() [2/2]

void JY5500CoreOO::JY5500CoreOODOTask::AddChannel ( std::vector< int > portsNum )

Add a group of channel.

Parameters
portsNum an array of port numbers of added ports.

◆ RemoveChannel()

void JY5500CoreOO::JY5500CoreOODOTask::RemoveChannel ( int portNum )

Delete the specified port number .If it is -1, delete all ports.

Parameters
portNum port number to be delete.

◆ SendSoftwareTrigger()

void JY5500CoreOO::JY5500CoreOODOTask::SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5500CoreOO::JY5500CoreOODOTask::Start ( )

Start DO task .

◆ Stop()

void JY5500CoreOO::JY5500CoreOODOTask::Stop ( )

Stop DO task .

◆ WaitUntilDone()

bool JY5500CoreOO::JY5500CoreOODOTask::WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Available when Mode is DOMode.Finite

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteData() [1/4]

void JY5500CoreOO::JY5500CoreOODOTask::WriteData | ( | std::vector< uint32_t > & | dataBuffer,
 |  | uint32_t | samplesToUpdate,
 |  | int | timeOut = 10000 )

Write the uint data from one port or multi-ports.

There are 4 ports, from 0 to 3. Each port has 8 lines, from 0 to 7. There are a total of 32 lines from 0 to 31. Each bit from low to high represents one line.

Parameters
dataBuffer | Data buffer
samplesToUpdate | Number of samples per port to be write
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [2/4]

void JY5500CoreOO::JY5500CoreOODOTask::WriteData | ( | std::vector< uint8_t > & | dataBuffer,
 |  | uint32_t | samplesToUpdate,
 |  | int | timeOut = 10000 )

wirte the byte data to one port.

Each port has 8 lines from 0 to 7. Each bit from low to high represents one line.

Parameters
dataBuffer | Data buffer
samplesToUpdate | Number of samples per port to be write
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [3/4]

void JY5500CoreOO::JY5500CoreOODOTask::WriteData | ( | uint32_t | dataBuffer[],
 |  | uint32_t | samplesToUpdate,
 |  | int | timeOut = 10000 )

Write the uint data from one port or multi-ports.

There are 4 ports, from 0 to 3. Each port has 8 lines, from 0 to 7. There are a total of 32 lines from 0 to 31. Each bit from low to high represents one line.

Parameters
dataBuffer | Data buffer
samplesToUpdate | Number of samples per port to be write
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [4/4]

void JY5500CoreOO::JY5500CoreOODOTask::WriteData | ( | uint8_t | dataBuffer[],
 |  | uint32_t | samplesToUpdate,
 |  | int | timeOut = 10000 )

wirte the byte data to one port.

Each port has 8 lines from 0 to 7. Each bit from low to high represents one line.

Parameters
dataBuffer | Data buffer
samplesToUpdate | Number of samples per port to be write
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteSinglePoint() [1/2]

void JY5500CoreOO::JY5500CoreOODOTask::WriteSinglePoint ( std::vector< bool > & writeValues )

Read one sample for all ports in register .

Available when Mode is DIMode.Single

Parameters
readValues Values read. Buffer size >= number of ports * 8.

◆ WriteSinglePoint() [2/2]

void JY5500CoreOO::JY5500CoreOODOTask::WriteSinglePoint | ( | std::vector< bool > & | writeValues,
 |  | int | port )

Write one sample to the specified port in register.Available when Mode is DOMode.Single

Parameters
writeValues | values read,. Buffer size >= 8
port | Specified port numbers.

Member Data Documentation

◆ AvaliableLenInSamples

JY5500CoreOOProperty<JY5500CoreOODOTask, uint64_t, JY5500CoreOOPropertyType::READ_ONLY> JY5500CoreOO::JY5500CoreOODOTask::AvaliableLenInSamples

Number of output samples per channel avaliable to write in DO buffuer.

◆ BufLenInSamples

JY5500CoreOOProperty<JY5500CoreOODOTask, int, JY5500CoreOOPropertyType::READ_ONLY> JY5500CoreOO::JY5500CoreOODOTask::BufLenInSamples

Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.

◆ Channels

std::list<DOChannel*> JY5500CoreOO::JY5500CoreOODOTask::Channels

List of DO channels,(5510 5511 support 6 ports)(5515 5516 support 3 ports)

◆ CompleteState

OutputCompleteState JY5500CoreOO::JY5500CoreOODOTask::CompleteState

DO Output Complete State, Valid when Mode is NOT DOMode.Single.Default is Zero.

◆ Device

JY5500CoreOODevice* JY5500CoreOO::JY5500CoreOODOTask::Device

Device.

◆ Mode

DOMode JY5500CoreOO::JY5500CoreOODOTask::Mode

DO acquisition mode，support Single/ Finite/Continuous.

◆ SampleClock

DOSampleClock* JY5500CoreOO::JY5500CoreOODOTask::SampleClock

DO Sample Clock Configuration.

◆ SamplesToUpdate

int JY5500CoreOO::JY5500CoreOODOTask::SamplesToUpdate

Number of output samples to write per channel , Only valid when Mode is DOMode::Finite.

◆ SignalExport

DOSignalExport* JY5500CoreOO::JY5500CoreOODOTask::SignalExport

Export DO Signal.

◆ TransferedSamples

JY5500CoreOOProperty<JY5500CoreOODOTask, uint64_t, JY5500CoreOOPropertyType::READ_ONLY> JY5500CoreOO::JY5500CoreOODOTask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT DIMode::Single.

◆ Trigger

DOTrigger* JY5500CoreOO::JY5500CoreOODOTask::Trigger

DO Trigger Configuration.

◆ UpdateRate

JY5500CoreOOProperty<JY5500CoreOODOTask, double, JY5500CoreOOPropertyType::READ_WRITE> JY5500CoreOO::JY5500CoreOODOTask::UpdateRate

Sample rate per channel.

Maximum sample rate is 10M The defalut sample rate = 10k You can read this property to obtain the sample rate that will actually take effect in the current configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOODOTask.h


5500 C++ Programming Manual: JY5500CoreOO::DOChannel Class Reference

  • DOChannel
Public Attributes | List of all members
JY5500CoreOO::DOChannel Class Reference

DO Channel parameter class . More...

#include <JY5500CoreOODOTask.h>

Public Attributes

int PortNum
port number.

Detailed Description

DO Channel parameter class .

Member Data Documentation

◆ PortNum

int JY5500CoreOO::DOChannel::PortNum

port number.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOODOTask.h


5500 C++ Programming Manual: JY5500CoreOO::DOSampleClock Class Reference

  • DOSampleClock
Public Attributes | List of all members
JY5500CoreOO::DOSampleClock Class Reference

Sample clock configuration class. More...

#include <JY5500CoreOODOTask.h>

Public Attributes

DOSampleClockSource Source
Clock Source.
DOExternalSampleClock * External
External Sample Clock.Valid when Source is DOSampleClockSource.External.

Detailed Description

Sample clock configuration class.

Member Data Documentation

◆ External

DOExternalSampleClock* JY5500CoreOO::DOSampleClock::External

External Sample Clock.Valid when Source is DOSampleClockSource.External.

◆ Source

DOSampleClockSource JY5500CoreOO::DOSampleClock::Source

Clock Source.

enum Internal/External

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOODOTask.h


5500 C++ Programming Manual: JY5500CoreOO::DOExternalSampleClock Class Reference

  • DOExternalSampleClock
Public Attributes | List of all members
JY5500CoreOO::DOExternalSampleClock Class Reference

External Sample Clock Configuration Class. More...

#include <JY5500CoreOODOTask.h>

Public Attributes

ClockTerminal Terminal
External Sample Clock Input Terminal.
double ExpectedRate
Expected External Sample Clock Rate.

Detailed Description

External Sample Clock Configuration Class.

Member Data Documentation

◆ ExpectedRate

double JY5500CoreOO::DOExternalSampleClock::ExpectedRate

Expected External Sample Clock Rate.

◆ Terminal

ClockTerminal JY5500CoreOO::DOExternalSampleClock::Terminal

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOODOTask.h


5500 C++ Programming Manual: JY5500CoreOO::DODigitalTrigger Class Reference

  • DODigitalTrigger
Public Attributes | List of all members
JY5500CoreOO::DODigitalTrigger Class Reference

DO Digital trigger. More...

#include <JY5500CoreOODOTask.h>

Public Attributes

DODigitalTriggerSource Source
DO Digital Trigger source.
DODigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Detailed Description

DO Digital trigger.

Member Data Documentation

◆ Edge

DODigitalTriggerEdge JY5500CoreOO::DODigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

DODigitalTriggerSource JY5500CoreOO::DODigitalTrigger::Source

DO Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOODOTask.h


5500 C++ Programming Manual: JY5500CoreOO::DOTrigger Class Reference

  • DOTrigger
Public Attributes | List of all members
JY5500CoreOO::DOTrigger Class Reference

Constructor to create an DOTrigger task object. More...

#include <JY5500CoreOODOTask.h>

Public Attributes

DOTriggerType Type
DO trigger type.
DODigitalTrigger * Digital
DO Digital Trigger.Valid when Type is DOTriggerType.Digital.

Detailed Description

Constructor to create an DOTrigger task object.

Used to build DO Trigger

Member Data Documentation

◆ Digital

DODigitalTrigger* JY5500CoreOO::DOTrigger::Digital

DO Digital Trigger.Valid when Type is DOTriggerType.Digital.

◆ Type

DOTriggerType JY5500CoreOO::DOTrigger::Type

DO trigger type.

enum Digital/Immediate/Soft.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOODOTask.h


5500 C++ Programming Manual: JY5500CoreOO::DOSignalExport Class Reference

  • DOSignalExport
Public Member Functions | List of all members
JY5500CoreOO::DOSignalExport Class Reference

DO Signal Export Class. More...

#include <JY5500CoreOODOTask.h>

Public Member Functions

void | Add (DOSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (DOSignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

DO Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY5500CoreOO::DOSignalExport::Add | ( | DOSignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | CI Signal Source
destination | Export Desination

◆ Add() [2/2]

void JY5500CoreOO::DOSignalExport::Add | ( | DOSignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | CI Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JY5500CoreOO::DOSignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5500CoreOO::DOSignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOODOTask.h


5500 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOLog.h File Reference

  • File List
  • File Members
  • COO
  • 5500
Classes | Namespaces | Enumerations
JY5500CoreOOLog.h File Reference
#include <queue>
#include <string>
#include <thread>
#include "JY5500CoreOOCommon.h"

Classes

class JY5500CoreOO::JY5500CoreOOLog

Namespaces

namespace JY5500CoreOO

Enumerations

enum class JY5500CoreOO::JY5500CoreOOLogLevel {
JY5500CoreOO::DEBUG_LOG_LEVEL , JY5500CoreOO::INFO_LOG_LEVEL , JY5500CoreOO::WARN_LOG_LEVEL , JY5500CoreOO::ERROR_LOG_LEVEL ,
JY5500CoreOO::FATAL_LOG_LEVEL
}


5500 C++ Programming Manual: JY5500CoreOO::JY5500CoreOOLog Class Reference

  • JY5500CoreOOLog
Static Public Member Functions | Static Public Attributes | List of all members
JY5500CoreOO::JY5500CoreOOLog Class Reference

#include <JY5500CoreOOLog.h>

Static Public Member Functions

static void | Print (const char *format,...)
static void | Print (JY5500CoreOOLogLevel logLevel, const char *format,...)
static void | Flush ()

Static Public Attributes

static JY5500CoreOOLogLevel | LogLevel
static JY5500CoreOOProperty< JY5500CoreOOLog, bool, JY5500CoreOOPropertyType::READ_WRITE > | EnableLog

Member Function Documentation

◆ Flush()

static void JY5500CoreOO::JY5500CoreOOLog::Flush ( )
static

◆ Print() [1/2]

static void JY5500CoreOO::JY5500CoreOOLog::Print | ( | const char * | format,
 |  |  | ... )
 static

◆ Print() [2/2]

static void JY5500CoreOO::JY5500CoreOOLog::Print | ( | JY5500CoreOOLogLevel | logLevel,
 |  | const char * | format,
 |  |  | ... )
 static

Member Data Documentation

◆ EnableLog

JY5500CoreOOProperty<JY5500CoreOOLog, bool, JY5500CoreOOPropertyType::READ_WRITE> JY5500CoreOO::JY5500CoreOOLog::EnableLog
static

◆ LogLevel

JY5500CoreOOLogLevel JY5500CoreOO::JY5500CoreOOLog::LogLevel
static
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOLog.h


5500 C++ Programming Manual: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
▼N JY5500CoreOO |
C AIAdvanced |
C AIAnalogEdgeComparator |
C AIAnalogHysteresisComparator |
C AIAnalogTrigger |
C AIAnalogWindowComparator |
C AIChannel |
C AIDigitalTrigger |
C AIDSMode |
C AIExternalSampleClock |
C AIRecord |
C AISampleClock |
C AISignalExport |
C AITrigger |
C AOChannel |
C AODigitalTrigger | AO Digital trigger
C AOExternalSampleClock | External Sample Clock Configuration Class
C AOSampleClock | AO Sample clock configuration class
C AOSignalExport | AO Signal Export Class
C AOTrigger | Constructor to create an AOTrigger task object
C CIDigitalTrigger | CI Digital trigger
C CIExternalSampleClock | CI Implicit Sample Clock class
C CIImplicitSampleClock | CI Implicit Sample Clock class
C CIInternalSampleClock | CI Internal Sample Clock Configuration Class
C CISampleClock | CI Sample Clock class
C CISignalExport | CI Signal Export Class
C CITimebase | Timebase configuration class
C CITrigger | Constructor to create an CITrigger task object
C CODigitalTrigger | CO Digital trigger
C COPulse | Pulse Parameter
C COSignalExport | CO Signal Export Class
C COTimebase | Timebase configuration class
C COTrigger | Constructor to create an COTrigger task object
C DIChannel | DI Channel parameter class
C DIDigitalTrigger | DI Digital trigger
C DIExternalSampleClock | External Sample Clock Configuration Class
C DISampleClock | Sample clock configuration class
C DISignalExport | DI Signal Export Class
C DITrigger | Constructor to create an DITrigger task object
C DOChannel | DO Channel parameter class
C DODigitalTrigger | DO Digital trigger
C DOExternalSampleClock | External Sample Clock Configuration Class
C DOSampleClock | Sample clock configuration class
C DOSignalExport | DO Signal Export Class
C DOTrigger | Constructor to create an DOTrigger task object
C EdgeCounting | Configure CI EdgeCounting
C EdgeCountingOutEvent | Edge counting output event configuration class
C ExternalReferenceClock |
C FrequencyMeas | Configure CI Measure
C JY5500CoreOOAITask | AITask类
C JY5500CoreOOAOTask |
C JY5500CoreOOCITask |
C JY5500CoreOOCOTask |
C JY5500CoreOODevice |
C JY5500CoreOODITask |
C JY5500CoreOODOTask |
C JY5500CoreOOLog |
C JY5500CoreOOProperty | 属性模板类
C JY5500CoreOOReferenceClock |
C JYDriverException |
C PauseTrigger | Pause trigger configuration class
C PeriodMeas | Configure CI Measure
C PFIFilter |
C PFISetting |
C PulseMeas | Configure CI Measure
C QuadEncoder | Configure CI Measure
C TwoEdgeSeparation | Configure CI Measure
C TwoPulseEncoder | Configure CI Measure
C AOMode | AIMode
C JY5500CoreOOAIMode | AIMode


5500 C++ Programming Manual: AOMode Class Reference

AOMode Class Reference

AIMode. More...

#include <JY5500CoreOOAOTask.h>

Detailed Description

AIMode.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOAOTask.h


5500 C++ Programming Manual: Member List

  • AIAdvanced
JY5500CoreOO::AIAdvanced Member List

This is the complete list of members for JY5500CoreOO::AIAdvanced, including all inherited members.

ConvertRate | JY5500CoreOO::AIAdvanced
DSMode | JY5500CoreOO::AIAdvanced


5500 C++ Programming Manual: Member List

  • AIAnalogEdgeComparator
JY5500CoreOO::AIAnalogEdgeComparator Member List

This is the complete list of members for JY5500CoreOO::AIAnalogEdgeComparator, including all inherited members.

Slope | JY5500CoreOO::AIAnalogEdgeComparator
Threshold | JY5500CoreOO::AIAnalogEdgeComparator


5500 C++ Programming Manual: Member List

  • AIAnalogHysteresisComparator
JY5500CoreOO::AIAnalogHysteresisComparator Member List

This is the complete list of members for JY5500CoreOO::AIAnalogHysteresisComparator, including all inherited members.

HighThreshold | JY5500CoreOO::AIAnalogHysteresisComparator
LowThreshold | JY5500CoreOO::AIAnalogHysteresisComparator
Slope | JY5500CoreOO::AIAnalogHysteresisComparator


5500 C++ Programming Manual: Member List

  • AIAnalogTrigger
JY5500CoreOO::AIAnalogTrigger Member List

This is the complete list of members for JY5500CoreOO::AIAnalogTrigger, including all inherited members.

Comparator | JY5500CoreOO::AIAnalogTrigger
Edge | JY5500CoreOO::AIAnalogTrigger
Hysteresis | JY5500CoreOO::AIAnalogTrigger
Source | JY5500CoreOO::AIAnalogTrigger
Window | JY5500CoreOO::AIAnalogTrigger


5500 C++ Programming Manual: Member List

  • AIAnalogWindowComparator
JY5500CoreOO::AIAnalogWindowComparator Member List

This is the complete list of members for JY5500CoreOO::AIAnalogWindowComparator, including all inherited members.

Condition | JY5500CoreOO::AIAnalogWindowComparator
HighThreshold | JY5500CoreOO::AIAnalogWindowComparator
LowThreshold | JY5500CoreOO::AIAnalogWindowComparator


5500 C++ Programming Manual: Member List

  • AIChannel
JY5500CoreOO::AIChannel Member List

This is the complete list of members for JY5500CoreOO::AIChannel, including all inherited members.

AIChannel(int channelId, double rangeLow, double rangeHigh, AITerminal terminalCfg=AITerminal::NRSE) | JY5500CoreOO::AIChannel | inline
ChannelID | JY5500CoreOO::AIChannel |
RangeHigh | JY5500CoreOO::AIChannel |
RangeLow | JY5500CoreOO::AIChannel |
Terminal | JY5500CoreOO::AIChannel |


5500 C++ Programming Manual: Member List

  • AIDSMode
JY5500CoreOO::AIDSMode Member List

This is the complete list of members for JY5500CoreOO::AIDSMode, including all inherited members.

Enable | JY5500CoreOO::AIDSMode
PowerLine_Frequency | JY5500CoreOO::AIDSMode


5500 C++ Programming Manual: Member List

  • AIDigitalTrigger
JY5500CoreOO::AIDigitalTrigger Member List

This is the complete list of members for JY5500CoreOO::AIDigitalTrigger, including all inherited members.

Edge | JY5500CoreOO::AIDigitalTrigger
Source | JY5500CoreOO::AIDigitalTrigger


5500 C++ Programming Manual: Member List

  • AIExternalSampleClock
JY5500CoreOO::AIExternalSampleClock Member List

This is the complete list of members for JY5500CoreOO::AIExternalSampleClock, including all inherited members.

ExpectedRate | JY5500CoreOO::AIExternalSampleClock
Terminal | JY5500CoreOO::AIExternalSampleClock


5500 C++ Programming Manual: Member List

  • AIRecord
JY5500CoreOO::AIRecord Member List

This is the complete list of members for JY5500CoreOO::AIRecord, including all inherited members.

File_Format | JY5500CoreOO::AIRecord
FilePath | JY5500CoreOO::AIRecord
Length | JY5500CoreOO::AIRecord
Mode | JY5500CoreOO::AIRecord


5500 C++ Programming Manual: Member List

  • AISampleClock
JY5500CoreOO::AISampleClock Member List

This is the complete list of members for JY5500CoreOO::AISampleClock, including all inherited members.

External | JY5500CoreOO::AISampleClock
Source | JY5500CoreOO::AISampleClock


5500 C++ Programming Manual: Member List

  • AISignalExport
JY5500CoreOO::AISignalExport Member List

This is the complete list of members for JY5500CoreOO::AISignalExport, including all inherited members.

Add(AISignalExportSource source, SignalExportDestination destination) | JY5500CoreOO::AISignalExport
Add(AISignalExportSource source, std::list< SignalExportDestination > destinations) | JY5500CoreOO::AISignalExport
Clear(SignalExportDestination destination) | JY5500CoreOO::AISignalExport
ClearAll() | JY5500CoreOO::AISignalExport


5500 C++ Programming Manual: Member List

  • AITrigger
JY5500CoreOO::AITrigger Member List

This is the complete list of members for JY5500CoreOO::AITrigger, including all inherited members.

Analog | JY5500CoreOO::AITrigger
Digital | JY5500CoreOO::AITrigger
Mode | JY5500CoreOO::AITrigger
PreTriggerSamples | JY5500CoreOO::AITrigger
ReTriggerCount | JY5500CoreOO::AITrigger
Type | JY5500CoreOO::AITrigger


5500 C++ Programming Manual: Member List

  • AOChannel
JY5500CoreOO::AOChannel Member List

This is the complete list of members for JY5500CoreOO::AOChannel, including all inherited members.

AOChannel(int channelId, double rangeLow, double rangeHigh) | JY5500CoreOO::AOChannel | inline
ChannelID | JY5500CoreOO::AOChannel |
RangeHigh | JY5500CoreOO::AOChannel |
RangeLow | JY5500CoreOO::AOChannel |


5500 C++ Programming Manual: Member List

  • AODigitalTrigger
JY5500CoreOO::AODigitalTrigger Member List

This is the complete list of members for JY5500CoreOO::AODigitalTrigger, including all inherited members.

Edge | JY5500CoreOO::AODigitalTrigger
Source | JY5500CoreOO::AODigitalTrigger


5500 C++ Programming Manual: Member List

  • AOExternalSampleClock
JY5500CoreOO::AOExternalSampleClock Member List

This is the complete list of members for JY5500CoreOO::AOExternalSampleClock, including all inherited members.

ExpectedRate | JY5500CoreOO::AOExternalSampleClock
Terminal | JY5500CoreOO::AOExternalSampleClock


5500 C++ Programming Manual: Member List

  • AOSampleClock
JY5500CoreOO::AOSampleClock Member List

This is the complete list of members for JY5500CoreOO::AOSampleClock, including all inherited members.

External | JY5500CoreOO::AOSampleClock
Source | JY5500CoreOO::AOSampleClock


5500 C++ Programming Manual: Member List

  • AOSignalExport
JY5500CoreOO::AOSignalExport Member List

This is the complete list of members for JY5500CoreOO::AOSignalExport, including all inherited members.

Add(AOSignalExportSource source, SignalExportDestination destination) | JY5500CoreOO::AOSignalExport
Add(AOSignalExportSource source, std::list< SignalExportDestination > destinations) | JY5500CoreOO::AOSignalExport
Clear(SignalExportDestination destination) | JY5500CoreOO::AOSignalExport
ClearAll() | JY5500CoreOO::AOSignalExport


5500 C++ Programming Manual: Member List

  • AOTrigger
JY5500CoreOO::AOTrigger Member List

This is the complete list of members for JY5500CoreOO::AOTrigger, including all inherited members.

Digital | JY5500CoreOO::AOTrigger
Type | JY5500CoreOO::AOTrigger


5500 C++ Programming Manual: Member List

  • CIDigitalTrigger
JY5500CoreOO::CIDigitalTrigger Member List

This is the complete list of members for JY5500CoreOO::CIDigitalTrigger, including all inherited members.

Edge | JY5500CoreOO::CIDigitalTrigger
Source | JY5500CoreOO::CIDigitalTrigger


5500 C++ Programming Manual: Member List

  • CIExternalSampleClock
JY5500CoreOO::CIExternalSampleClock Member List

This is the complete list of members for JY5500CoreOO::CIExternalSampleClock, including all inherited members.

ExpectedRate | JY5500CoreOO::CIExternalSampleClock
Terminal | JY5500CoreOO::CIExternalSampleClock


5500 C++ Programming Manual: Member List

  • CIImplicitSampleClock
JY5500CoreOO::CIImplicitSampleClock Member List

This is the complete list of members for JY5500CoreOO::CIImplicitSampleClock, including all inherited members.

ExpectedRate JY5500CoreOO::CIImplicitSampleClock


5500 C++ Programming Manual: Member List

  • CIInternalSampleClock
JY5500CoreOO::CIInternalSampleClock Member List

This is the complete list of members for JY5500CoreOO::CIInternalSampleClock, including all inherited members.

Rate JY5500CoreOO::CIInternalSampleClock


5500 C++ Programming Manual: Member List

  • CISampleClock
JY5500CoreOO::CISampleClock Member List

This is the complete list of members for JY5500CoreOO::CISampleClock, including all inherited members.

External | JY5500CoreOO::CISampleClock
Implicit | JY5500CoreOO::CISampleClock
Internal | JY5500CoreOO::CISampleClock
Source | JY5500CoreOO::CISampleClock


5500 C++ Programming Manual: Member List

  • CISignalExport
JY5500CoreOO::CISignalExport Member List

This is the complete list of members for JY5500CoreOO::CISignalExport, including all inherited members.

Add(CISignalExportSource source, SignalExportDestination destination) | JY5500CoreOO::CISignalExport
Add(CISignalExportSource source, std::list< SignalExportDestination > destinations) | JY5500CoreOO::CISignalExport
Clear(SignalExportDestination destination) | JY5500CoreOO::CISignalExport
ClearAll() | JY5500CoreOO::CISignalExport


5500 C++ Programming Manual: Member List

  • CITimebase
JY5500CoreOO::CITimebase Member List

This is the complete list of members for JY5500CoreOO::CITimebase, including all inherited members.

Source JY5500CoreOO::CITimebase


5500 C++ Programming Manual: Member List

  • CITrigger
JY5500CoreOO::CITrigger Member List

This is the complete list of members for JY5500CoreOO::CITrigger, including all inherited members.

Digital | JY5500CoreOO::CITrigger
Type | JY5500CoreOO::CITrigger


5500 C++ Programming Manual: Member List

  • CODigitalTrigger
JY5500CoreOO::CODigitalTrigger Member List

This is the complete list of members for JY5500CoreOO::CODigitalTrigger, including all inherited members.

Edge | JY5500CoreOO::CODigitalTrigger
Source | JY5500CoreOO::CODigitalTrigger


5500 C++ Programming Manual: Member List

  • COPulse
JY5500CoreOO::COPulse Member List

This is the complete list of members for JY5500CoreOO::COPulse, including all inherited members.

COPulse(COPulseType type, double param1, double param2, int count) JY5500CoreOO::COPulse


5500 C++ Programming Manual: Member List

  • COSignalExport
JY5500CoreOO::COSignalExport Member List

This is the complete list of members for JY5500CoreOO::COSignalExport, including all inherited members.

Add(COSignalExportSource source, SignalExportDestination destination) | JY5500CoreOO::COSignalExport
Add(COSignalExportSource source, std::list< SignalExportDestination > destinations) | JY5500CoreOO::COSignalExport
Clear(SignalExportDestination destination) | JY5500CoreOO::COSignalExport
ClearAll() | JY5500CoreOO::COSignalExport


5500 C++ Programming Manual: Member List

  • COTimebase
JY5500CoreOO::COTimebase Member List

This is the complete list of members for JY5500CoreOO::COTimebase, including all inherited members.

Source JY5500CoreOO::COTimebase


5500 C++ Programming Manual: Member List

  • COTrigger
JY5500CoreOO::COTrigger Member List

This is the complete list of members for JY5500CoreOO::COTrigger, including all inherited members.

Digital | JY5500CoreOO::COTrigger
Type | JY5500CoreOO::COTrigger


5500 C++ Programming Manual: Member List

  • DIChannel
JY5500CoreOO::DIChannel Member List

This is the complete list of members for JY5500CoreOO::DIChannel, including all inherited members.

PortNum JY5500CoreOO::DIChannel


5500 C++ Programming Manual: Member List

  • DIDigitalTrigger
JY5500CoreOO::DIDigitalTrigger Member List

This is the complete list of members for JY5500CoreOO::DIDigitalTrigger, including all inherited members.

Edge | JY5500CoreOO::DIDigitalTrigger
Source | JY5500CoreOO::DIDigitalTrigger


5500 C++ Programming Manual: Member List

  • DIExternalSampleClock
JY5500CoreOO::DIExternalSampleClock Member List

This is the complete list of members for JY5500CoreOO::DIExternalSampleClock, including all inherited members.

ExpectedRate | JY5500CoreOO::DIExternalSampleClock
Terminal | JY5500CoreOO::DIExternalSampleClock


5500 C++ Programming Manual: Member List

  • DISampleClock
JY5500CoreOO::DISampleClock Member List

This is the complete list of members for JY5500CoreOO::DISampleClock, including all inherited members.

External | JY5500CoreOO::DISampleClock
Source | JY5500CoreOO::DISampleClock


5500 C++ Programming Manual: Member List

  • DISignalExport
JY5500CoreOO::DISignalExport Member List

This is the complete list of members for JY5500CoreOO::DISignalExport, including all inherited members.

Add(DISignalExportSource source, SignalExportDestination destination) | JY5500CoreOO::DISignalExport
Add(DISignalExportSource source, std::list< SignalExportDestination > destinations) | JY5500CoreOO::DISignalExport
Clear(SignalExportDestination destination) | JY5500CoreOO::DISignalExport
ClearAll() | JY5500CoreOO::DISignalExport


5500 C++ Programming Manual: Member List

  • DITrigger
JY5500CoreOO::DITrigger Member List

This is the complete list of members for JY5500CoreOO::DITrigger, including all inherited members.

Digital | JY5500CoreOO::DITrigger
Mode | JY5500CoreOO::DITrigger
PreTriggerSamples | JY5500CoreOO::DITrigger
Type | JY5500CoreOO::DITrigger


5500 C++ Programming Manual: Member List

  • DOChannel
JY5500CoreOO::DOChannel Member List

This is the complete list of members for JY5500CoreOO::DOChannel, including all inherited members.

PortNum JY5500CoreOO::DOChannel


5500 C++ Programming Manual: Member List

  • DODigitalTrigger
JY5500CoreOO::DODigitalTrigger Member List

This is the complete list of members for JY5500CoreOO::DODigitalTrigger, including all inherited members.

Edge | JY5500CoreOO::DODigitalTrigger
Source | JY5500CoreOO::DODigitalTrigger


5500 C++ Programming Manual: Member List

  • DOExternalSampleClock
JY5500CoreOO::DOExternalSampleClock Member List

This is the complete list of members for JY5500CoreOO::DOExternalSampleClock, including all inherited members.

ExpectedRate | JY5500CoreOO::DOExternalSampleClock
Terminal | JY5500CoreOO::DOExternalSampleClock


5500 C++ Programming Manual: Member List

  • DOSampleClock
JY5500CoreOO::DOSampleClock Member List

This is the complete list of members for JY5500CoreOO::DOSampleClock, including all inherited members.

External | JY5500CoreOO::DOSampleClock
Source | JY5500CoreOO::DOSampleClock


5500 C++ Programming Manual: Member List

  • DOSignalExport
JY5500CoreOO::DOSignalExport Member List

This is the complete list of members for JY5500CoreOO::DOSignalExport, including all inherited members.

Add(DOSignalExportSource source, SignalExportDestination destination) | JY5500CoreOO::DOSignalExport
Add(DOSignalExportSource source, std::list< SignalExportDestination > destinations) | JY5500CoreOO::DOSignalExport
Clear(SignalExportDestination destination) | JY5500CoreOO::DOSignalExport
ClearAll() | JY5500CoreOO::DOSignalExport


5500 C++ Programming Manual: Member List

  • DOTrigger
JY5500CoreOO::DOTrigger Member List

This is the complete list of members for JY5500CoreOO::DOTrigger, including all inherited members.

Digital | JY5500CoreOO::DOTrigger
Type | JY5500CoreOO::DOTrigger


5500 C++ Programming Manual: Member List

  • EdgeCounting
JY5500CoreOO::EdgeCounting Member List

This is the complete list of members for JY5500CoreOO::EdgeCounting, including all inherited members.

ActiveEdge | JY5500CoreOO::EdgeCounting
Direction | JY5500CoreOO::EdgeCounting
DirTerminal | JY5500CoreOO::EdgeCounting
InitialCount | JY5500CoreOO::EdgeCounting
Input_Terminal | JY5500CoreOO::EdgeCounting
OutEvent | JY5500CoreOO::EdgeCounting
Pause | JY5500CoreOO::EdgeCounting


5500 C++ Programming Manual: Member List

  • EdgeCountingOutEvent
JY5500CoreOO::EdgeCountingOutEvent Member List

This is the complete list of members for JY5500CoreOO::EdgeCountingOutEvent, including all inherited members.

IdleState | JY5500CoreOO::EdgeCountingOutEvent
Terminal | JY5500CoreOO::EdgeCountingOutEvent
Threshold | JY5500CoreOO::EdgeCountingOutEvent


5500 C++ Programming Manual: Member List

  • ExternalReferenceClock
JY5500CoreOO::ExternalReferenceClock Member List

This is the complete list of members for JY5500CoreOO::ExternalReferenceClock, including all inherited members.

Terminal JY5500CoreOO::ExternalReferenceClock


5500 C++ Programming Manual: Member List

  • FrequencyMeas
JY5500CoreOO::FrequencyMeas Member List

This is the complete list of members for JY5500CoreOO::FrequencyMeas, including all inherited members.

Input_Terminal | JY5500CoreOO::FrequencyMeas
Timebase | JY5500CoreOO::FrequencyMeas


5500 C++ Programming Manual: Member List

  • JY5500CoreOOAITask
JY5500CoreOO::JY5500CoreOOAITask Member List

This is the complete list of members for JY5500CoreOO::JY5500CoreOOAITask, including all inherited members.

AddChannel(int chnId, double rangeLow=-10, double rangeHigh=10, AITerminal terminalCfg=AITerminal::RSE) | JY5500CoreOO::JY5500CoreOOAITask
AddChannel(std::vector< int > chnsId, double rangeLow=-10, double rangeHigh=10, AITerminal terminalCfg=AITerminal::RSE) | JY5500CoreOO::JY5500CoreOOAITask
AddChannel(std::vector< int > chnsId, std::vector< double > rangeLow, std::vector< double > rangeHigh, AITerminal terminalCfg=AITerminal::RSE) | JY5500CoreOO::JY5500CoreOOAITask
Advanced | JY5500CoreOO::JY5500CoreOOAITask
AvailableSamples | JY5500CoreOO::JY5500CoreOOAITask
BufLenInSamples | JY5500CoreOO::JY5500CoreOOAITask
Channels | JY5500CoreOO::JY5500CoreOOAITask
Device | JY5500CoreOO::JY5500CoreOOAITask
GetRecordPreviewData(double *buf, int samplesPerChannel, int timeout) | JY5500CoreOO::JY5500CoreOOAITask
GetRecordPreviewData(std::vector< double > &buf, int samplesPerChannel, int timeout) | JY5500CoreOO::JY5500CoreOOAITask
GetRecordStatus(double &recordedLength, bool &recordDone) | JY5500CoreOO::JY5500CoreOOAITask
JY5500CoreOOAITask(int slotNum) | JY5500CoreOO::JY5500CoreOOAITask
JY5500CoreOOAITask(std::string boardName) | JY5500CoreOO::JY5500CoreOOAITask
Mode | JY5500CoreOO::JY5500CoreOOAITask
ReadData(double *pBuf, int samplesPerChannel, int timeout=-1) | JY5500CoreOO::JY5500CoreOOAITask
ReadData(std::vector< double > &pBuf, int samplesPerChannel, int timeout=-1) | JY5500CoreOO::JY5500CoreOOAITask
ReadRawData(int *pBuf, int samplesPerChannel, int timeout=-1) | JY5500CoreOO::JY5500CoreOOAITask
ReadRawData(std::vector< int > &pBuf, int samplesPerChannel, int timeout=-1) | JY5500CoreOO::JY5500CoreOOAITask
ReadRawSinglePoint(int &readValue, int channel) | JY5500CoreOO::JY5500CoreOOAITask
ReadRawSinglePoint(std::vector< int > &readValues) | JY5500CoreOO::JY5500CoreOOAITask
ReadSinglePoint(double &readValue, int channel) | JY5500CoreOO::JY5500CoreOOAITask
ReadSinglePoint(std::vector< double > &readValues) | JY5500CoreOO::JY5500CoreOOAITask
Record | JY5500CoreOO::JY5500CoreOOAITask
RemoveChannel(int chnId) | JY5500CoreOO::JY5500CoreOOAITask
SampleClock | JY5500CoreOO::JY5500CoreOOAITask
SampleRate | JY5500CoreOO::JY5500CoreOOAITask
SamplesToAcquire | JY5500CoreOO::JY5500CoreOOAITask
SendSoftwareTrigger() | JY5500CoreOO::JY5500CoreOOAITask
SignalExport | JY5500CoreOO::JY5500CoreOOAITask
Start() | JY5500CoreOO::JY5500CoreOOAITask
Stop() | JY5500CoreOO::JY5500CoreOOAITask
TransferedSamples | JY5500CoreOO::JY5500CoreOOAITask
Trigger | JY5500CoreOO::JY5500CoreOOAITask
~JY5500CoreOOAITask() | JY5500CoreOO::JY5500CoreOOAITask


5500 C++ Programming Manual: Member List

  • JY5500CoreOOAOTask
JY5500CoreOO::JY5500CoreOOAOTask Member List

This is the complete list of members for JY5500CoreOO::JY5500CoreOOAOTask, including all inherited members.

AddChannel(int chnId, double rangeLow=-10, double rangeHigh=10) | JY5500CoreOO::JY5500CoreOOAOTask
AddChannel(std::vector< int > chnsId, double rangeLow=-10, double rangeHigh=10) | JY5500CoreOO::JY5500CoreOOAOTask
AddChannel(std::vector< int > chnsId, std::vector< double > rangeLow, std::vector< double > rangeHigh) | JY5500CoreOO::JY5500CoreOOAOTask
AvaliableLenInSamples | JY5500CoreOO::JY5500CoreOOAOTask
BufLenInSamples | JY5500CoreOO::JY5500CoreOOAOTask
Channels | JY5500CoreOO::JY5500CoreOOAOTask
CompleteState | JY5500CoreOO::JY5500CoreOOAOTask
Device | JY5500CoreOO::JY5500CoreOOAOTask
JY5500CoreOOAOTask(int slotNum) | JY5500CoreOO::JY5500CoreOOAOTask
JY5500CoreOOAOTask(std::string boardName) | JY5500CoreOO::JY5500CoreOOAOTask
Mode | JY5500CoreOO::JY5500CoreOOAOTask
RemoveChannel(int chnId) | JY5500CoreOO::JY5500CoreOOAOTask
SampleClock | JY5500CoreOO::JY5500CoreOOAOTask
SamplesToUpdate | JY5500CoreOO::JY5500CoreOOAOTask
SendSoftwareTrigger() | JY5500CoreOO::JY5500CoreOOAOTask
SignalExport | JY5500CoreOO::JY5500CoreOOAOTask
Start() | JY5500CoreOO::JY5500CoreOOAOTask
Stop() | JY5500CoreOO::JY5500CoreOOAOTask
TransferedSamples | JY5500CoreOO::JY5500CoreOOAOTask
Trigger | JY5500CoreOO::JY5500CoreOOAOTask
UpdateRate | JY5500CoreOO::JY5500CoreOOAOTask
WaitUntilDone(int timeout=-1) | JY5500CoreOO::JY5500CoreOOAOTask
WriteData(double *pBuf, int samplesPerChannel, int timeout=10000) | JY5500CoreOO::JY5500CoreOOAOTask
WriteData(std::vector< double > &pBuf, int samplesPerChannel, int timeout=10000) | JY5500CoreOO::JY5500CoreOOAOTask
WriteRawData(int16_t *pBuf, int samplesPerChannel, int timeout=10000) | JY5500CoreOO::JY5500CoreOOAOTask
WriteRawData(std::vector< int16_t > &pBuf, int samplesPerChannel, int timeout=10000) | JY5500CoreOO::JY5500CoreOOAOTask
WriteRawSinglePoint(std::vector< int16_t > &writeValues) | JY5500CoreOO::JY5500CoreOOAOTask
WriteRawSinglePoint(int16_t writeValue, int channel) | JY5500CoreOO::JY5500CoreOOAOTask
WriteSinglePoint(std::vector< double > writeValues) | JY5500CoreOO::JY5500CoreOOAOTask
WriteSinglePoint(double writeValue, int channel) | JY5500CoreOO::JY5500CoreOOAOTask
~JY5500CoreOOAOTask() | JY5500CoreOO::JY5500CoreOOAOTask


5500 C++ Programming Manual: Member List

  • JY5500CoreOOCITask
JY5500CoreOO::JY5500CoreOOCITask Member List

This is the complete list of members for JY5500CoreOO::JY5500CoreOOCITask, including all inherited members.

AvailableSamples | JY5500CoreOO::JY5500CoreOOCITask
Device | JY5500CoreOO::JY5500CoreOOCITask
EdgeCounting | JY5500CoreOO::JY5500CoreOOCITask
FrequencyMeas | JY5500CoreOO::JY5500CoreOOCITask
JY5500CoreOOCITask(int slotNum, int channel) | JY5500CoreOO::JY5500CoreOOCITask
JY5500CoreOOCITask(std::string boardName, int channel) | JY5500CoreOO::JY5500CoreOOCITask
Mode | JY5500CoreOO::JY5500CoreOOCITask
PeriodMeas | JY5500CoreOO::JY5500CoreOOCITask
PulseMeas | JY5500CoreOO::JY5500CoreOOCITask
QuadEncoder | JY5500CoreOO::JY5500CoreOOCITask
ReadData(uint32_t *pBufCount, int samplesToAcquire, int timeout=10000) | JY5500CoreOO::JY5500CoreOOCITask
ReadData(std::vector< uint32_t > &pBufCount, int samplesToAcquire, int timeout=10000) | JY5500CoreOO::JY5500CoreOOCITask
ReadData(double *pBufMeasurement, int samplesToAcquire, int timeout=10000) | JY5500CoreOO::JY5500CoreOOCITask
ReadData(std::vector< double > &pBufMeasurement, int samplesToAcquire, int timeout=10000) | JY5500CoreOO::JY5500CoreOOCITask
ReadData(double *pBufMeasurement1, double *pBufMeasurement2, int samplesToAcquire, int timeout=10000) | JY5500CoreOO::JY5500CoreOOCITask
ReadData(std::vector< double > &pBufMeasurement1, std::vector< double > &pBufMeasurement2, int samplesToAcquire, int timeout=10000) | JY5500CoreOO::JY5500CoreOOCITask
ReadSinglePoint(uint32_t &count) | JY5500CoreOO::JY5500CoreOOCITask
ReadSinglePoint(double &measurement, int timeout=10000) | JY5500CoreOO::JY5500CoreOOCITask
ReadSinglePoint(double &measurement1, double &measurement2, int timeout=10000) | JY5500CoreOO::JY5500CoreOOCITask
SampleClock | JY5500CoreOO::JY5500CoreOOCITask
SamplesToAcquire | JY5500CoreOO::JY5500CoreOOCITask
SendSoftwareTrigger() | JY5500CoreOO::JY5500CoreOOCITask
SignalExport | JY5500CoreOO::JY5500CoreOOCITask
Start() | JY5500CoreOO::JY5500CoreOOCITask
Stop() | JY5500CoreOO::JY5500CoreOOCITask
TransferedSamples | JY5500CoreOO::JY5500CoreOOCITask
Trigger | JY5500CoreOO::JY5500CoreOOCITask
TwoEdgeSeparation | JY5500CoreOO::JY5500CoreOOCITask
TwoPulseEncoder | JY5500CoreOO::JY5500CoreOOCITask
Type | JY5500CoreOO::JY5500CoreOOCITask
~JY5500CoreOOCITask() | JY5500CoreOO::JY5500CoreOOCITask


5500 C++ Programming Manual: Member List

  • JY5500CoreOOCOTask
JY5500CoreOO::JY5500CoreOOCOTask Member List

This is the complete list of members for JY5500CoreOO::JY5500CoreOOCOTask, including all inherited members.

AvailableSamples | JY5500CoreOO::JY5500CoreOOCOTask
Device | JY5500CoreOO::JY5500CoreOOCOTask
IdleState | JY5500CoreOO::JY5500CoreOOCOTask
InitialDelay | JY5500CoreOO::JY5500CoreOOCOTask
JY5500CoreOOCOTask(int slotNum, int channel) | JY5500CoreOO::JY5500CoreOOCOTask
JY5500CoreOOCOTask(std::string boardName, int channel) | JY5500CoreOO::JY5500CoreOOCOTask
Mode | JY5500CoreOO::JY5500CoreOOCOTask
OutputTerminal | JY5500CoreOO::JY5500CoreOOCOTask
Pause | JY5500CoreOO::JY5500CoreOOCOTask
SamplesToUpdate | JY5500CoreOO::JY5500CoreOOCOTask
SendSoftwareTrigger() | JY5500CoreOO::JY5500CoreOOCOTask
SignalExport | JY5500CoreOO::JY5500CoreOOCOTask
Start() | JY5500CoreOO::JY5500CoreOOCOTask
Stop() | JY5500CoreOO::JY5500CoreOOCOTask
TimeBase | JY5500CoreOO::JY5500CoreOOCOTask
TransferedPulses | JY5500CoreOO::JY5500CoreOOCOTask
TransferedSamples | JY5500CoreOO::JY5500CoreOOCOTask
Trigger | JY5500CoreOO::JY5500CoreOOCOTask
WaitUntilDone(int timeout=-1) | JY5500CoreOO::JY5500CoreOOCOTask
WriteData(COPulse *pulsesGroup[], int samplesToWrite, int timeout=10000) | JY5500CoreOO::JY5500CoreOOCOTask
WriteSinglePoint(COPulse &pulse) | JY5500CoreOO::JY5500CoreOOCOTask
~JY5500CoreOOCOTask() | JY5500CoreOO::JY5500CoreOOCOTask


5500 C++ Programming Manual: Member List

  • JY5500CoreOODITask
JY5500CoreOO::JY5500CoreOODITask Member List

This is the complete list of members for JY5500CoreOO::JY5500CoreOODITask, including all inherited members.

AddChannel(int portNum) | JY5500CoreOO::JY5500CoreOODITask
AddChannel(std::vector< int > portsNum) | JY5500CoreOO::JY5500CoreOODITask
AvailableSamples | JY5500CoreOO::JY5500CoreOODITask
BufLenInSamples | JY5500CoreOO::JY5500CoreOODITask
Channels | JY5500CoreOO::JY5500CoreOODITask
Device | JY5500CoreOO::JY5500CoreOODITask
JY5500CoreOODITask(int slotNum) | JY5500CoreOO::JY5500CoreOODITask
JY5500CoreOODITask(std::string boardName) | JY5500CoreOO::JY5500CoreOODITask
Mode | JY5500CoreOO::JY5500CoreOODITask
ReadData(uint32_t dataBuffer[], uint32_t samplesToAcquire, int timeOut=10000) | JY5500CoreOO::JY5500CoreOODITask
ReadData(uint8_t dataBuffer[], uint32_t samplesToAcquire, int timeOut=10000) | JY5500CoreOO::JY5500CoreOODITask
ReadSinglePoint(std::vector< bool > &readValues, int port) | JY5500CoreOO::JY5500CoreOODITask
ReadSinglePoint(std::vector< bool > &readValues) | JY5500CoreOO::JY5500CoreOODITask
ReadSinglePoint(bool readValues[]) | JY5500CoreOO::JY5500CoreOODITask
RemoveChannel(int portNum) | JY5500CoreOO::JY5500CoreOODITask
SampleClock | JY5500CoreOO::JY5500CoreOODITask
SampleRate | JY5500CoreOO::JY5500CoreOODITask
SamplesToAcquire | JY5500CoreOO::JY5500CoreOODITask
SendSoftwareTrigger() | JY5500CoreOO::JY5500CoreOODITask
SignalExport | JY5500CoreOO::JY5500CoreOODITask
Start() | JY5500CoreOO::JY5500CoreOODITask
Stop() | JY5500CoreOO::JY5500CoreOODITask
TransferedSamples | JY5500CoreOO::JY5500CoreOODITask
Trigger | JY5500CoreOO::JY5500CoreOODITask
~JY5500CoreOODITask() | JY5500CoreOO::JY5500CoreOODITask


5500 C++ Programming Manual: Member List

  • JY5500CoreOODOTask
JY5500CoreOO::JY5500CoreOODOTask Member List

This is the complete list of members for JY5500CoreOO::JY5500CoreOODOTask, including all inherited members.

AddChannel(int portNum) | JY5500CoreOO::JY5500CoreOODOTask
AddChannel(std::vector< int > portsNum) | JY5500CoreOO::JY5500CoreOODOTask
AvaliableLenInSamples | JY5500CoreOO::JY5500CoreOODOTask
BufLenInSamples | JY5500CoreOO::JY5500CoreOODOTask
Channels | JY5500CoreOO::JY5500CoreOODOTask
CompleteState | JY5500CoreOO::JY5500CoreOODOTask
Device | JY5500CoreOO::JY5500CoreOODOTask
JY5500CoreOODOTask(int slotNum) | JY5500CoreOO::JY5500CoreOODOTask
JY5500CoreOODOTask(std::string boardName) | JY5500CoreOO::JY5500CoreOODOTask
Mode | JY5500CoreOO::JY5500CoreOODOTask
RemoveChannel(int portNum) | JY5500CoreOO::JY5500CoreOODOTask
SampleClock | JY5500CoreOO::JY5500CoreOODOTask
SamplesToUpdate | JY5500CoreOO::JY5500CoreOODOTask
SendSoftwareTrigger() | JY5500CoreOO::JY5500CoreOODOTask
SignalExport | JY5500CoreOO::JY5500CoreOODOTask
Start() | JY5500CoreOO::JY5500CoreOODOTask
Stop() | JY5500CoreOO::JY5500CoreOODOTask
TransferedSamples | JY5500CoreOO::JY5500CoreOODOTask
Trigger | JY5500CoreOO::JY5500CoreOODOTask
UpdateRate | JY5500CoreOO::JY5500CoreOODOTask
WaitUntilDone(int timeout=-1) | JY5500CoreOO::JY5500CoreOODOTask
WriteData(uint32_t dataBuffer[], uint32_t samplesToUpdate, int timeOut=10000) | JY5500CoreOO::JY5500CoreOODOTask
WriteData(std::vector< uint32_t > &dataBuffer, uint32_t samplesToUpdate, int timeOut=10000) | JY5500CoreOO::JY5500CoreOODOTask
WriteData(uint8_t dataBuffer[], uint32_t samplesToUpdate, int timeOut=10000) | JY5500CoreOO::JY5500CoreOODOTask
WriteData(std::vector< uint8_t > &dataBuffer, uint32_t samplesToUpdate, int timeOut=10000) | JY5500CoreOO::JY5500CoreOODOTask
WriteSinglePoint(std::vector< bool > &writeValues, int port) | JY5500CoreOO::JY5500CoreOODOTask
WriteSinglePoint(std::vector< bool > &writeValues) | JY5500CoreOO::JY5500CoreOODOTask
~JY5500CoreOODOTask() | JY5500CoreOO::JY5500CoreOODOTask


5500 C++ Programming Manual: Member List

  • JY5500CoreOODevice
JY5500CoreOO::JY5500CoreOODevice Member List

This is the complete list of members for JY5500CoreOO::JY5500CoreOODevice, including all inherited members.

AIBufferSize | JY5500CoreOO::JY5500CoreOODevice |
AOChannelCount | JY5500CoreOO::JY5500CoreOODevice |
BoardClockRate | JY5500CoreOO::JY5500CoreOODevice |
DeviceID | JY5500CoreOO::JY5500CoreOODevice |
DiffChannelCount | JY5500CoreOO::JY5500CoreOODevice |
GetInstance(int cardNum) | JY5500CoreOO::JY5500CoreOODevice | static
GetInstance(std::string aliasName) | JY5500CoreOO::JY5500CoreOODevice | static
Handle | JY5500CoreOO::JY5500CoreOODevice |
IsAISync | JY5500CoreOO::JY5500CoreOODevice |
IsAOSync | JY5500CoreOO::JY5500CoreOODevice |
MaxSampleRateMutilChannel | JY5500CoreOO::JY5500CoreOODevice |
MaxSampleRateSingleChannel | JY5500CoreOO::JY5500CoreOODevice |
MaxUpdateRateFourChannel | JY5500CoreOO::JY5500CoreOODevice |
MaxUpdateRateSingleChannel | JY5500CoreOO::JY5500CoreOODevice |
MaxUpdateRateThreeChannel | JY5500CoreOO::JY5500CoreOODevice |
MaxUpdateRateTwoChannel | JY5500CoreOO::JY5500CoreOODevice |
PFI | JY5500CoreOO::JY5500CoreOODevice |
ReferenceClock | JY5500CoreOO::JY5500CoreOODevice |
SEChannelCount | JY5500CoreOO::JY5500CoreOODevice |
SerialNumber | JY5500CoreOO::JY5500CoreOODevice |


5500 C++ Programming Manual: Member List

  • JY5500CoreOOLog
JY5500CoreOO::JY5500CoreOOLog Member List

This is the complete list of members for JY5500CoreOO::JY5500CoreOOLog, including all inherited members.

EnableLog | JY5500CoreOO::JY5500CoreOOLog | static
Flush() | JY5500CoreOO::JY5500CoreOOLog | static
LogLevel | JY5500CoreOO::JY5500CoreOOLog | static
Print(const char *format,...) | JY5500CoreOO::JY5500CoreOOLog | static
Print(JY5500CoreOOLogLevel logLevel, const char *format,...) | JY5500CoreOO::JY5500CoreOOLog | static


5500 C++ Programming Manual: Member List

  • JY5500CoreOOProperty
JY5500CoreOO::JY5500CoreOOProperty< ContainerClass, ValueType, propertyType > Member List

This is the complete list of members for JY5500CoreOO::JY5500CoreOOProperty< ContainerClass, ValueType, propertyType >, including all inherited members.

JY5500CoreOOProperty() | JY5500CoreOO::JY5500CoreOOProperty< ContainerClass, ValueType, propertyType >
JY5500CoreOOProperty(ContainerClass *cObject, ValueType(ContainerClass::*pGet)(), void(ContainerClass::*pSet)(ValueType value)) | JY5500CoreOO::JY5500CoreOOProperty< ContainerClass, ValueType, propertyType >
JY5500CoreOOProperty(ValueType(*pGet)(), void(*pSet)(ValueType value)) | JY5500CoreOO::JY5500CoreOOProperty< ContainerClass, ValueType, propertyType >
operator ValueType() | JY5500CoreOO::JY5500CoreOOProperty< ContainerClass, ValueType, propertyType >
operator=(const ValueType &value) | JY5500CoreOO::JY5500CoreOOProperty< ContainerClass, ValueType, propertyType >


5500 C++ Programming Manual: Member List

  • JY5500CoreOOReferenceClock
JY5500CoreOO::JY5500CoreOOReferenceClock Member List

This is the complete list of members for JY5500CoreOO::JY5500CoreOOReferenceClock, including all inherited members.

Commit() | JY5500CoreOO::JY5500CoreOOReferenceClock
External | JY5500CoreOO::JY5500CoreOOReferenceClock
Source | JY5500CoreOO::JY5500CoreOOReferenceClock


5500 C++ Programming Manual: Member List

  • JYDriverException
JY5500CoreOO::JYDriverException Member List

This is the complete list of members for JY5500CoreOO::JYDriverException, including all inherited members.

errorCode | JY5500CoreOO::JYDriverException
exceptionMessage | JY5500CoreOO::JYDriverException
FollowingException | JY5500CoreOO::JYDriverException
JYDriverException(JYDriverExceptionPublic exceptionCode, std::string msg="") | JY5500CoreOO::JYDriverException
JYDriverException(int, std::string msg) | JY5500CoreOO::JYDriverException


5500 C++ Programming Manual: Member List

  • PFIFilter
JY5500CoreOO::PFIFilter Member List

This is the complete list of members for JY5500CoreOO::PFIFilter, including all inherited members.

Disable(PFITerminal terminal) | JY5500CoreOO::PFIFilter
Disable(std::vector< PFITerminal > terminals) | JY5500CoreOO::PFIFilter
DisableAll() | JY5500CoreOO::PFIFilter
Enable(PFITerminal terminal, int minPulseWidth) | JY5500CoreOO::PFIFilter
Enable(std::vector< PFITerminal > terminals, int minPulseWidth) | JY5500CoreOO::PFIFilter
Enable(std::vector< PFITerminal > terminals, std::vector< int > minPulseWidth) | JY5500CoreOO::PFIFilter


5500 C++ Programming Manual: Member List

  • PFISetting
JY5500CoreOO::PFISetting Member List

This is the complete list of members for JY5500CoreOO::PFISetting, including all inherited members.

Filter JY5500CoreOO::PFISetting


5500 C++ Programming Manual: Member List

  • PauseTrigger
JY5500CoreOO::PauseTrigger Member List

This is the complete list of members for JY5500CoreOO::PauseTrigger, including all inherited members.

ActivePolarity | JY5500CoreOO::PauseTrigger
Terminal | JY5500CoreOO::PauseTrigger


5500 C++ Programming Manual: Member List

  • PeriodMeas
JY5500CoreOO::PeriodMeas Member List

This is the complete list of members for JY5500CoreOO::PeriodMeas, including all inherited members.

Input_Terminal | JY5500CoreOO::PeriodMeas
Timebase | JY5500CoreOO::PeriodMeas


5500 C++ Programming Manual: Member List

  • PulseMeas
JY5500CoreOO::PulseMeas Member List

This is the complete list of members for JY5500CoreOO::PulseMeas, including all inherited members.

Input_Terminal | JY5500CoreOO::PulseMeas
Timebase | JY5500CoreOO::PulseMeas


5500 C++ Programming Manual: Member List

  • QuadEncoder
JY5500CoreOO::QuadEncoder Member List

This is the complete list of members for JY5500CoreOO::QuadEncoder, including all inherited members.

AInputTerminal | JY5500CoreOO::QuadEncoder
BInputTerminal | JY5500CoreOO::QuadEncoder
EncodingType | JY5500CoreOO::QuadEncoder
InitialCount | JY5500CoreOO::QuadEncoder
ZInputTerminal | JY5500CoreOO::QuadEncoder
ZReloadEnabled | JY5500CoreOO::QuadEncoder


5500 C++ Programming Manual: Member List

  • TwoEdgeSeparation
JY5500CoreOO::TwoEdgeSeparation Member List

This is the complete list of members for JY5500CoreOO::TwoEdgeSeparation, including all inherited members.

FirstInputTerminal | JY5500CoreOO::TwoEdgeSeparation
SecondInputTerminal | JY5500CoreOO::TwoEdgeSeparation
Timebase | JY5500CoreOO::TwoEdgeSeparation


5500 C++ Programming Manual: Member List

  • TwoPulseEncoder
JY5500CoreOO::TwoPulseEncoder Member List

This is the complete list of members for JY5500CoreOO::TwoPulseEncoder, including all inherited members.

AInputTerminal | JY5500CoreOO::TwoPulseEncoder
BInputTerminal | JY5500CoreOO::TwoPulseEncoder
InitialCount | JY5500CoreOO::TwoPulseEncoder


5500 C++ Programming Manual: JY5500CoreOOAIMode Class Reference

JY5500CoreOOAIMode Class Reference

AIMode. More...

#include <JY5500CoreOOAITask.h>

Detailed Description

AIMode.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5500/JY5500CoreOOAITask.h


5500 C++ Programming Manual: Class Index

Class Index
A | C | D | E | F | J | P | Q | T
A
AIAdvanced (JY5500CoreOO)
AIAnalogEdgeComparator (JY5500CoreOO)
AIAnalogHysteresisComparator (JY5500CoreOO)
AIAnalogTrigger (JY5500CoreOO)
AIAnalogWindowComparator (JY5500CoreOO)
AIChannel (JY5500CoreOO)
AIDigitalTrigger (JY5500CoreOO)
AIDSMode (JY5500CoreOO)
AIExternalSampleClock (JY5500CoreOO)
AIRecord (JY5500CoreOO)
AISampleClock (JY5500CoreOO)
AISignalExport (JY5500CoreOO)
AITrigger (JY5500CoreOO)
AOChannel (JY5500CoreOO)
AODigitalTrigger (JY5500CoreOO)
AOExternalSampleClock (JY5500CoreOO)
AOMode
AOSampleClock (JY5500CoreOO)
AOSignalExport (JY5500CoreOO)
AOTrigger (JY5500CoreOO)
C
CIDigitalTrigger (JY5500CoreOO)
CIExternalSampleClock (JY5500CoreOO)
CIImplicitSampleClock (JY5500CoreOO)
CIInternalSampleClock (JY5500CoreOO)
CISampleClock (JY5500CoreOO)
CISignalExport (JY5500CoreOO)
CITimebase (JY5500CoreOO)
CITrigger (JY5500CoreOO)
CODigitalTrigger (JY5500CoreOO)
COPulse (JY5500CoreOO)
COSignalExport (JY5500CoreOO)
COTimebase (JY5500CoreOO)
COTrigger (JY5500CoreOO)
D
DIChannel (JY5500CoreOO)
DIDigitalTrigger (JY5500CoreOO)
DIExternalSampleClock (JY5500CoreOO)
DISampleClock (JY5500CoreOO)
DISignalExport (JY5500CoreOO)
DITrigger (JY5500CoreOO)
DOChannel (JY5500CoreOO)
DODigitalTrigger (JY5500CoreOO)
DOExternalSampleClock (JY5500CoreOO)
DOSampleClock (JY5500CoreOO)
DOSignalExport (JY5500CoreOO)
DOTrigger (JY5500CoreOO)
E
EdgeCounting (JY5500CoreOO)
EdgeCountingOutEvent (JY5500CoreOO)
ExternalReferenceClock (JY5500CoreOO)
F
FrequencyMeas (JY5500CoreOO)
J
JY5500CoreOOAIMode
JY5500CoreOOAITask (JY5500CoreOO)
JY5500CoreOOAOTask (JY5500CoreOO)
JY5500CoreOOCITask (JY5500CoreOO)
JY5500CoreOOCOTask (JY5500CoreOO)
JY5500CoreOODevice (JY5500CoreOO)
JY5500CoreOODITask (JY5500CoreOO)
JY5500CoreOODOTask (JY5500CoreOO)
JY5500CoreOOLog (JY5500CoreOO)
JY5500CoreOOProperty (JY5500CoreOO)
JY5500CoreOOReferenceClock (JY5500CoreOO)
JYDriverException (JY5500CoreOO)
P
PauseTrigger (JY5500CoreOO)
PeriodMeas (JY5500CoreOO)
PFIFilter (JY5500CoreOO)
PFISetting (JY5500CoreOO)
PulseMeas (JY5500CoreOO)
Q
QuadEncoder (JY5500CoreOO)
T
TwoEdgeSeparation (JY5500CoreOO)
TwoPulseEncoder (JY5500CoreOO)


5500 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO Directory Reference

  • File List
  • File Members
  • COO
COO Directory Reference

Directories

5500


5500 C++ Programming Manual: File List

  • File List
  • File Members
File List
Here is a list of all files with brief descriptions:
[detail level 123]
▼ COO
▼ 5500
JY5500CoreOOAITask.h
JY5500CoreOOAOTask.h
JY5500CoreOOCITask.h
JY5500CoreOOCommon.h
JY5500CoreOOCOTask.h
JY5500CoreOODevice.h
JY5500CoreOODITask.h
JY5500CoreOODOTask.h
JY5500CoreOOLog.h


5500 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- a -

  • ActiveEdge : JY5500CoreOO::EdgeCounting
  • ActivePolarity : JY5500CoreOO::PauseTrigger
  • Add() : JY5500CoreOO::AISignalExport, JY5500CoreOO::AOSignalExport, JY5500CoreOO::CISignalExport, JY5500CoreOO::COSignalExport, JY5500CoreOO::DISignalExport, JY5500CoreOO::DOSignalExport
  • AddChannel() : JY5500CoreOO::JY5500CoreOOAITask, JY5500CoreOO::JY5500CoreOOAOTask, JY5500CoreOO::JY5500CoreOODITask, JY5500CoreOO::JY5500CoreOODOTask
  • Advanced : JY5500CoreOO::JY5500CoreOOAITask
  • AIBufferSize : JY5500CoreOO::JY5500CoreOODevice
  • AIChannel() : JY5500CoreOO::AIChannel
  • AInputTerminal : JY5500CoreOO::QuadEncoder, JY5500CoreOO::TwoPulseEncoder
  • Analog : JY5500CoreOO::AITrigger
  • AOChannel() : JY5500CoreOO::AOChannel
  • AOChannelCount : JY5500CoreOO::JY5500CoreOODevice
  • AvailableSamples : JY5500CoreOO::JY5500CoreOOAITask, JY5500CoreOO::JY5500CoreOOCITask, JY5500CoreOO::JY5500CoreOOCOTask, JY5500CoreOO::JY5500CoreOODITask
  • AvaliableLenInSamples : JY5500CoreOO::JY5500CoreOOAOTask, JY5500CoreOO::JY5500CoreOODOTask


5500 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- b -

  • BInputTerminal : JY5500CoreOO::QuadEncoder, JY5500CoreOO::TwoPulseEncoder
  • BoardClockRate : JY5500CoreOO::JY5500CoreOODevice
  • BufLenInSamples : JY5500CoreOO::JY5500CoreOOAITask, JY5500CoreOO::JY5500CoreOOAOTask, JY5500CoreOO::JY5500CoreOODITask, JY5500CoreOO::JY5500CoreOODOTask


5500 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- c -

  • ChannelID : JY5500CoreOO::AIChannel, JY5500CoreOO::AOChannel
  • Channels : JY5500CoreOO::JY5500CoreOOAITask, JY5500CoreOO::JY5500CoreOOAOTask, JY5500CoreOO::JY5500CoreOODITask, JY5500CoreOO::JY5500CoreOODOTask
  • Clear() : JY5500CoreOO::AISignalExport, JY5500CoreOO::AOSignalExport, JY5500CoreOO::CISignalExport, JY5500CoreOO::COSignalExport, JY5500CoreOO::DISignalExport, JY5500CoreOO::DOSignalExport
  • ClearAll() : JY5500CoreOO::AISignalExport, JY5500CoreOO::AOSignalExport, JY5500CoreOO::CISignalExport, JY5500CoreOO::COSignalExport, JY5500CoreOO::DISignalExport, JY5500CoreOO::DOSignalExport
  • Commit() : JY5500CoreOO::JY5500CoreOOReferenceClock
  • Comparator : JY5500CoreOO::AIAnalogTrigger
  • CompleteState : JY5500CoreOO::JY5500CoreOOAOTask, JY5500CoreOO::JY5500CoreOODOTask
  • Condition : JY5500CoreOO::AIAnalogWindowComparator
  • ConvertRate : JY5500CoreOO::AIAdvanced
  • COPulse() : JY5500CoreOO::COPulse


5500 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- d -

  • Device : JY5500CoreOO::JY5500CoreOOAITask, JY5500CoreOO::JY5500CoreOOAOTask, JY5500CoreOO::JY5500CoreOOCITask, JY5500CoreOO::JY5500CoreOOCOTask, JY5500CoreOO::JY5500CoreOODITask, JY5500CoreOO::JY5500CoreOODOTask
  • DeviceID : JY5500CoreOO::JY5500CoreOODevice
  • DiffChannelCount : JY5500CoreOO::JY5500CoreOODevice
  • Digital : JY5500CoreOO::AITrigger, JY5500CoreOO::AOTrigger, JY5500CoreOO::CITrigger, JY5500CoreOO::COTrigger, JY5500CoreOO::DITrigger, JY5500CoreOO::DOTrigger
  • Direction : JY5500CoreOO::EdgeCounting
  • DirTerminal : JY5500CoreOO::EdgeCounting
  • Disable() : JY5500CoreOO::PFIFilter
  • DisableAll() : JY5500CoreOO::PFIFilter
  • DSMode : JY5500CoreOO::AIAdvanced


5500 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- e -

  • Edge : JY5500CoreOO::AIAnalogTrigger, JY5500CoreOO::AIDigitalTrigger, JY5500CoreOO::AODigitalTrigger, JY5500CoreOO::CIDigitalTrigger, JY5500CoreOO::CODigitalTrigger, JY5500CoreOO::DIDigitalTrigger, JY5500CoreOO::DODigitalTrigger
  • EdgeCounting : JY5500CoreOO::JY5500CoreOOCITask
  • Enable : JY5500CoreOO::AIDSMode, JY5500CoreOO::PFIFilter
  • EnableLog : JY5500CoreOO::JY5500CoreOOLog
  • EncodingType : JY5500CoreOO::QuadEncoder
  • errorCode : JY5500CoreOO::JYDriverException
  • exceptionMessage : JY5500CoreOO::JYDriverException
  • ExpectedRate : JY5500CoreOO::AIExternalSampleClock, JY5500CoreOO::AOExternalSampleClock, JY5500CoreOO::CIExternalSampleClock, JY5500CoreOO::CIImplicitSampleClock, JY5500CoreOO::DIExternalSampleClock, JY5500CoreOO::DOExternalSampleClock
  • External : JY5500CoreOO::AISampleClock, JY5500CoreOO::AOSampleClock, JY5500CoreOO::CISampleClock, JY5500CoreOO::DISampleClock, JY5500CoreOO::DOSampleClock, JY5500CoreOO::JY5500CoreOOReferenceClock


5500 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- f -

  • File_Format : JY5500CoreOO::AIRecord
  • FilePath : JY5500CoreOO::AIRecord
  • Filter : JY5500CoreOO::PFISetting
  • FirstInputTerminal : JY5500CoreOO::TwoEdgeSeparation
  • Flush() : JY5500CoreOO::JY5500CoreOOLog
  • FollowingException : JY5500CoreOO::JYDriverException
  • FrequencyMeas : JY5500CoreOO::JY5500CoreOOCITask


5500 C++ Programming Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • c
  • d
  • e
  • f
  • g
  • j
  • o
  • p
  • r
  • s
  • w
  • ~
Here is a list of all functions with links to the classes they belong to:

- a -

  • Add() : JY5500CoreOO::AISignalExport, JY5500CoreOO::AOSignalExport, JY5500CoreOO::CISignalExport, JY5500CoreOO::COSignalExport, JY5500CoreOO::DISignalExport, JY5500CoreOO::DOSignalExport
  • AddChannel() : JY5500CoreOO::JY5500CoreOOAITask, JY5500CoreOO::JY5500CoreOOAOTask, JY5500CoreOO::JY5500CoreOODITask, JY5500CoreOO::JY5500CoreOODOTask
  • AIChannel() : JY5500CoreOO::AIChannel
  • AOChannel() : JY5500CoreOO::AOChannel

- c -

  • Clear() : JY5500CoreOO::AISignalExport, JY5500CoreOO::AOSignalExport, JY5500CoreOO::CISignalExport, JY5500CoreOO::COSignalExport, JY5500CoreOO::DISignalExport, JY5500CoreOO::DOSignalExport
  • ClearAll() : JY5500CoreOO::AISignalExport, JY5500CoreOO::AOSignalExport, JY5500CoreOO::CISignalExport, JY5500CoreOO::COSignalExport, JY5500CoreOO::DISignalExport, JY5500CoreOO::DOSignalExport
  • Commit() : JY5500CoreOO::JY5500CoreOOReferenceClock
  • COPulse() : JY5500CoreOO::COPulse

- d -

  • Disable() : JY5500CoreOO::PFIFilter
  • DisableAll() : JY5500CoreOO::PFIFilter

- e -

  • Enable() : JY5500CoreOO::PFIFilter

- f -

  • Flush() : JY5500CoreOO::JY5500CoreOOLog

- g -

  • GetInstance() : JY5500CoreOO::JY5500CoreOODevice
  • GetRecordPreviewData() : JY5500CoreOO::JY5500CoreOOAITask
  • GetRecordStatus() : JY5500CoreOO::JY5500CoreOOAITask

- j -

  • JY5500CoreOOAITask() : JY5500CoreOO::JY5500CoreOOAITask
  • JY5500CoreOOAOTask() : JY5500CoreOO::JY5500CoreOOAOTask
  • JY5500CoreOOCITask() : JY5500CoreOO::JY5500CoreOOCITask
  • JY5500CoreOOCOTask() : JY5500CoreOO::JY5500CoreOOCOTask
  • JY5500CoreOODITask() : JY5500CoreOO::JY5500CoreOODITask
  • JY5500CoreOODOTask() : JY5500CoreOO::JY5500CoreOODOTask
  • JY5500CoreOOProperty() : JY5500CoreOO::JY5500CoreOOProperty< ContainerClass, ValueType, propertyType >
  • JYDriverException() : JY5500CoreOO::JYDriverException

- o -

  • operator ValueType() : JY5500CoreOO::JY5500CoreOOProperty< ContainerClass, ValueType, propertyType >
  • operator=() : JY5500CoreOO::JY5500CoreOOProperty< ContainerClass, ValueType, propertyType >

- p -

  • Print() : JY5500CoreOO::JY5500CoreOOLog

- r -

  • ReadData() : JY5500CoreOO::JY5500CoreOOAITask, JY5500CoreOO::JY5500CoreOOCITask, JY5500CoreOO::JY5500CoreOODITask
  • ReadRawData() : JY5500CoreOO::JY5500CoreOOAITask
  • ReadRawSinglePoint() : JY5500CoreOO::JY5500CoreOOAITask
  • ReadSinglePoint() : JY5500CoreOO::JY5500CoreOOAITask, JY5500CoreOO::JY5500CoreOOCITask, JY5500CoreOO::JY5500CoreOODITask
  • RemoveChannel() : JY5500CoreOO::JY5500CoreOOAITask, JY5500CoreOO::JY5500CoreOOAOTask, JY5500CoreOO::JY5500CoreOODITask, JY5500CoreOO::JY5500CoreOODOTask

- s -

  • SendSoftwareTrigger() : JY5500CoreOO::JY5500CoreOOAITask, JY5500CoreOO::JY5500CoreOOAOTask, JY5500CoreOO::JY5500CoreOOCITask, JY5500CoreOO::JY5500CoreOOCOTask, JY5500CoreOO::JY5500CoreOODITask, JY5500CoreOO::JY5500CoreOODOTask
  • Start() : JY5500CoreOO::JY5500CoreOOAITask, JY5500CoreOO::JY5500CoreOOAOTask, JY5500CoreOO::JY5500CoreOOCITask, JY5500CoreOO::JY5500CoreOOCOTask, JY5500CoreOO::JY5500CoreOODITask, JY5500CoreOO::JY5500CoreOODOTask
  • Stop() : JY5500CoreOO::JY5500CoreOOAITask, JY5500CoreOO::JY5500CoreOOAOTask, JY5500CoreOO::JY5500CoreOOCITask, JY5500CoreOO::JY5500CoreOOCOTask, JY5500CoreOO::JY5500CoreOODITask, JY5500CoreOO::JY5500CoreOODOTask

- w -

  • WaitUntilDone() : JY5500CoreOO::JY5500CoreOOAOTask, JY5500CoreOO::JY5500CoreOOCOTask, JY5500CoreOO::JY5500CoreOODOTask
  • WriteData() : JY5500CoreOO::JY5500CoreOOAOTask, JY5500CoreOO::JY5500CoreOOCOTask, JY5500CoreOO::JY5500CoreOODOTask
  • WriteRawData() : JY5500CoreOO::JY5500CoreOOAOTask
  • WriteRawSinglePoint() : JY5500CoreOO::JY5500CoreOOAOTask
  • WriteSinglePoint() : JY5500CoreOO::JY5500CoreOOAOTask, JY5500CoreOO::JY5500CoreOOCOTask, JY5500CoreOO::JY5500CoreOODOTask

- ~ -

  • ~JY5500CoreOOAITask() : JY5500CoreOO::JY5500CoreOOAITask
  • ~JY5500CoreOOAOTask() : JY5500CoreOO::JY5500CoreOOAOTask
  • ~JY5500CoreOOCITask() : JY5500CoreOO::JY5500CoreOOCITask
  • ~JY5500CoreOOCOTask() : JY5500CoreOO::JY5500CoreOOCOTask
  • ~JY5500CoreOODITask() : JY5500CoreOO::JY5500CoreOODITask
  • ~JY5500CoreOODOTask() : JY5500CoreOO::JY5500CoreOODOTask


5500 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- g -

  • GetInstance() : JY5500CoreOO::JY5500CoreOODevice
  • GetRecordPreviewData() : JY5500CoreOO::JY5500CoreOOAITask
  • GetRecordStatus() : JY5500CoreOO::JY5500CoreOOAITask


5500 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- h -

  • Handle : JY5500CoreOO::JY5500CoreOODevice
  • HighThreshold : JY5500CoreOO::AIAnalogHysteresisComparator, JY5500CoreOO::AIAnalogWindowComparator
  • Hysteresis : JY5500CoreOO::AIAnalogTrigger


5500 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- i -

  • IdleState : JY5500CoreOO::EdgeCountingOutEvent, JY5500CoreOO::JY5500CoreOOCOTask
  • Implicit : JY5500CoreOO::CISampleClock
  • InitialCount : JY5500CoreOO::EdgeCounting, JY5500CoreOO::QuadEncoder, JY5500CoreOO::TwoPulseEncoder
  • InitialDelay : JY5500CoreOO::JY5500CoreOOCOTask
  • Input_Terminal : JY5500CoreOO::EdgeCounting, JY5500CoreOO::FrequencyMeas, JY5500CoreOO::PeriodMeas, JY5500CoreOO::PulseMeas
  • Internal : JY5500CoreOO::CISampleClock
  • IsAISync : JY5500CoreOO::JY5500CoreOODevice
  • IsAOSync : JY5500CoreOO::JY5500CoreOODevice


5500 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- j -

  • JY5500CoreOOAITask() : JY5500CoreOO::JY5500CoreOOAITask
  • JY5500CoreOOAOTask() : JY5500CoreOO::JY5500CoreOOAOTask
  • JY5500CoreOOCITask() : JY5500CoreOO::JY5500CoreOOCITask
  • JY5500CoreOOCOTask() : JY5500CoreOO::JY5500CoreOOCOTask
  • JY5500CoreOODITask() : JY5500CoreOO::JY5500CoreOODITask
  • JY5500CoreOODOTask() : JY5500CoreOO::JY5500CoreOODOTask
  • JY5500CoreOOProperty() : JY5500CoreOO::JY5500CoreOOProperty< ContainerClass, ValueType, propertyType >
  • JYDriverException() : JY5500CoreOO::JYDriverException


5500 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- l -

  • Length : JY5500CoreOO::AIRecord
  • LogLevel : JY5500CoreOO::JY5500CoreOOLog
  • LowThreshold : JY5500CoreOO::AIAnalogHysteresisComparator, JY5500CoreOO::AIAnalogWindowComparator


5500 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- m -

  • MaxSampleRateMutilChannel : JY5500CoreOO::JY5500CoreOODevice
  • MaxSampleRateSingleChannel : JY5500CoreOO::JY5500CoreOODevice
  • MaxUpdateRateFourChannel : JY5500CoreOO::JY5500CoreOODevice
  • MaxUpdateRateSingleChannel : JY5500CoreOO::JY5500CoreOODevice
  • MaxUpdateRateThreeChannel : JY5500CoreOO::JY5500CoreOODevice
  • MaxUpdateRateTwoChannel : JY5500CoreOO::JY5500CoreOODevice
  • Mode : JY5500CoreOO::AIRecord, JY5500CoreOO::AITrigger, JY5500CoreOO::DITrigger, JY5500CoreOO::JY5500CoreOOAITask, JY5500CoreOO::JY5500CoreOOAOTask, JY5500CoreOO::JY5500CoreOOCITask, JY5500CoreOO::JY5500CoreOOCOTask, JY5500CoreOO::JY5500CoreOODITask, JY5500CoreOO::JY5500CoreOODOTask


5500 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- o -

  • operator ValueType() : JY5500CoreOO::JY5500CoreOOProperty< ContainerClass, ValueType, propertyType >
  • operator=() : JY5500CoreOO::JY5500CoreOOProperty< ContainerClass, ValueType, propertyType >
  • OutEvent : JY5500CoreOO::EdgeCounting
  • OutputTerminal : JY5500CoreOO::JY5500CoreOOCOTask


5500 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- p -

  • Pause : JY5500CoreOO::EdgeCounting, JY5500CoreOO::JY5500CoreOOCOTask
  • PeriodMeas : JY5500CoreOO::JY5500CoreOOCITask
  • PFI : JY5500CoreOO::JY5500CoreOODevice
  • PortNum : JY5500CoreOO::DIChannel, JY5500CoreOO::DOChannel
  • PowerLine_Frequency : JY5500CoreOO::AIDSMode
  • PreTriggerSamples : JY5500CoreOO::AITrigger, JY5500CoreOO::DITrigger
  • Print() : JY5500CoreOO::JY5500CoreOOLog
  • PulseMeas : JY5500CoreOO::JY5500CoreOOCITask


5500 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- q -

  • QuadEncoder : JY5500CoreOO::JY5500CoreOOCITask


5500 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- r -

  • RangeHigh : JY5500CoreOO::AIChannel, JY5500CoreOO::AOChannel
  • RangeLow : JY5500CoreOO::AIChannel, JY5500CoreOO::AOChannel
  • Rate : JY5500CoreOO::CIInternalSampleClock
  • ReadData() : JY5500CoreOO::JY5500CoreOOAITask, JY5500CoreOO::JY5500CoreOOCITask, JY5500CoreOO::JY5500CoreOODITask
  • ReadRawData() : JY5500CoreOO::JY5500CoreOOAITask
  • ReadRawSinglePoint() : JY5500CoreOO::JY5500CoreOOAITask
  • ReadSinglePoint() : JY5500CoreOO::JY5500CoreOOAITask, JY5500CoreOO::JY5500CoreOOCITask, JY5500CoreOO::JY5500CoreOODITask
  • Record : JY5500CoreOO::JY5500CoreOOAITask
  • ReferenceClock : JY5500CoreOO::JY5500CoreOODevice
  • RemoveChannel() : JY5500CoreOO::JY5500CoreOOAITask, JY5500CoreOO::JY5500CoreOOAOTask, JY5500CoreOO::JY5500CoreOODITask, JY5500CoreOO::JY5500CoreOODOTask
  • ReTriggerCount : JY5500CoreOO::AITrigger


5500 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- s -

  • SampleClock : JY5500CoreOO::JY5500CoreOOAITask, JY5500CoreOO::JY5500CoreOOAOTask, JY5500CoreOO::JY5500CoreOOCITask, JY5500CoreOO::JY5500CoreOODITask, JY5500CoreOO::JY5500CoreOODOTask
  • SampleRate : JY5500CoreOO::JY5500CoreOOAITask, JY5500CoreOO::JY5500CoreOODITask
  • SamplesToAcquire : JY5500CoreOO::JY5500CoreOOAITask, JY5500CoreOO::JY5500CoreOOCITask, JY5500CoreOO::JY5500CoreOODITask
  • SamplesToUpdate : JY5500CoreOO::JY5500CoreOOAOTask, JY5500CoreOO::JY5500CoreOOCOTask, JY5500CoreOO::JY5500CoreOODOTask
  • SEChannelCount : JY5500CoreOO::JY5500CoreOODevice
  • SecondInputTerminal : JY5500CoreOO::TwoEdgeSeparation
  • SendSoftwareTrigger() : JY5500CoreOO::JY5500CoreOOAITask, JY5500CoreOO::JY5500CoreOOAOTask, JY5500CoreOO::JY5500CoreOOCITask, JY5500CoreOO::JY5500CoreOOCOTask, JY5500CoreOO::JY5500CoreOODITask, JY5500CoreOO::JY5500CoreOODOTask
  • SerialNumber : JY5500CoreOO::JY5500CoreOODevice
  • SignalExport : JY5500CoreOO::JY5500CoreOOAITask, JY5500CoreOO::JY5500CoreOOAOTask, JY5500CoreOO::JY5500CoreOOCITask, JY5500CoreOO::JY5500CoreOOCOTask, JY5500CoreOO::JY5500CoreOODITask, JY5500CoreOO::JY5500CoreOODOTask
  • Slope : JY5500CoreOO::AIAnalogEdgeComparator, JY5500CoreOO::AIAnalogHysteresisComparator
  • Source : JY5500CoreOO::AIAnalogTrigger, JY5500CoreOO::AIDigitalTrigger, JY5500CoreOO::AISampleClock, JY5500CoreOO::AODigitalTrigger, JY5500CoreOO::AOSampleClock, JY5500CoreOO::CIDigitalTrigger, JY5500CoreOO::CISampleClock, JY5500CoreOO::CITimebase, JY5500CoreOO::CODigitalTrigger, JY5500CoreOO::COTimebase, JY5500CoreOO::DIDigitalTrigger, JY5500CoreOO::DISampleClock, JY5500CoreOO::DODigitalTrigger, JY5500CoreOO::DOSampleClock, JY5500CoreOO::JY5500CoreOOReferenceClock
  • Start() : JY5500CoreOO::JY5500CoreOOAITask, JY5500CoreOO::JY5500CoreOOAOTask, JY5500CoreOO::JY5500CoreOOCITask, JY5500CoreOO::JY5500CoreOOCOTask, JY5500CoreOO::JY5500CoreOODITask, JY5500CoreOO::JY5500CoreOODOTask
  • Stop() : JY5500CoreOO::JY5500CoreOOAITask, JY5500CoreOO::JY5500CoreOOAOTask, JY5500CoreOO::JY5500CoreOOCITask, JY5500CoreOO::JY5500CoreOOCOTask, JY5500CoreOO::JY5500CoreOODITask, JY5500CoreOO::JY5500CoreOODOTask


5500 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- t -

  • Terminal : JY5500CoreOO::AIChannel, JY5500CoreOO::AIExternalSampleClock, JY5500CoreOO::AOExternalSampleClock, JY5500CoreOO::CIExternalSampleClock, JY5500CoreOO::DIExternalSampleClock, JY5500CoreOO::DOExternalSampleClock, JY5500CoreOO::EdgeCountingOutEvent, JY5500CoreOO::ExternalReferenceClock, JY5500CoreOO::PauseTrigger
  • Threshold : JY5500CoreOO::AIAnalogEdgeComparator, JY5500CoreOO::EdgeCountingOutEvent
  • TimeBase : JY5500CoreOO::JY5500CoreOOCOTask
  • Timebase : JY5500CoreOO::FrequencyMeas, JY5500CoreOO::PeriodMeas, JY5500CoreOO::PulseMeas, JY5500CoreOO::TwoEdgeSeparation
  • TransferedPulses : JY5500CoreOO::JY5500CoreOOCOTask
  • TransferedSamples : JY5500CoreOO::JY5500CoreOOAITask, JY5500CoreOO::JY5500CoreOOAOTask, JY5500CoreOO::JY5500CoreOOCITask, JY5500CoreOO::JY5500CoreOOCOTask, JY5500CoreOO::JY5500CoreOODITask, JY5500CoreOO::JY5500CoreOODOTask
  • Trigger : JY5500CoreOO::JY5500CoreOOAITask, JY5500CoreOO::JY5500CoreOOAOTask, JY5500CoreOO::JY5500CoreOOCITask, JY5500CoreOO::JY5500CoreOOCOTask, JY5500CoreOO::JY5500CoreOODITask, JY5500CoreOO::JY5500CoreOODOTask
  • TwoEdgeSeparation : JY5500CoreOO::JY5500CoreOOCITask
  • TwoPulseEncoder : JY5500CoreOO::JY5500CoreOOCITask
  • Type : JY5500CoreOO::AITrigger, JY5500CoreOO::AOTrigger, JY5500CoreOO::CITrigger, JY5500CoreOO::COTrigger, JY5500CoreOO::DITrigger, JY5500CoreOO::DOTrigger, JY5500CoreOO::JY5500CoreOOCITask


5500 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- u -

  • UpdateRate : JY5500CoreOO::JY5500CoreOOAOTask, JY5500CoreOO::JY5500CoreOODOTask


5500 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- a -

  • ActiveEdge : JY5500CoreOO::EdgeCounting
  • ActivePolarity : JY5500CoreOO::PauseTrigger
  • Advanced : JY5500CoreOO::JY5500CoreOOAITask
  • AIBufferSize : JY5500CoreOO::JY5500CoreOODevice
  • AInputTerminal : JY5500CoreOO::QuadEncoder, JY5500CoreOO::TwoPulseEncoder
  • Analog : JY5500CoreOO::AITrigger
  • AOChannelCount : JY5500CoreOO::JY5500CoreOODevice
  • AvailableSamples : JY5500CoreOO::JY5500CoreOOAITask, JY5500CoreOO::JY5500CoreOOCITask, JY5500CoreOO::JY5500CoreOOCOTask, JY5500CoreOO::JY5500CoreOODITask
  • AvaliableLenInSamples : JY5500CoreOO::JY5500CoreOOAOTask, JY5500CoreOO::JY5500CoreOODOTask


5500 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- b -

  • BInputTerminal : JY5500CoreOO::QuadEncoder, JY5500CoreOO::TwoPulseEncoder
  • BoardClockRate : JY5500CoreOO::JY5500CoreOODevice
  • BufLenInSamples : JY5500CoreOO::JY5500CoreOOAITask, JY5500CoreOO::JY5500CoreOOAOTask, JY5500CoreOO::JY5500CoreOODITask, JY5500CoreOO::JY5500CoreOODOTask


5500 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- c -

  • ChannelID : JY5500CoreOO::AIChannel, JY5500CoreOO::AOChannel
  • Channels : JY5500CoreOO::JY5500CoreOOAITask, JY5500CoreOO::JY5500CoreOOAOTask, JY5500CoreOO::JY5500CoreOODITask, JY5500CoreOO::JY5500CoreOODOTask
  • Comparator : JY5500CoreOO::AIAnalogTrigger
  • CompleteState : JY5500CoreOO::JY5500CoreOOAOTask, JY5500CoreOO::JY5500CoreOODOTask
  • Condition : JY5500CoreOO::AIAnalogWindowComparator
  • ConvertRate : JY5500CoreOO::AIAdvanced


5500 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- d -

  • Device : JY5500CoreOO::JY5500CoreOOAITask, JY5500CoreOO::JY5500CoreOOAOTask, JY5500CoreOO::JY5500CoreOOCITask, JY5500CoreOO::JY5500CoreOOCOTask, JY5500CoreOO::JY5500CoreOODITask, JY5500CoreOO::JY5500CoreOODOTask
  • DeviceID : JY5500CoreOO::JY5500CoreOODevice
  • DiffChannelCount : JY5500CoreOO::JY5500CoreOODevice
  • Digital : JY5500CoreOO::AITrigger, JY5500CoreOO::AOTrigger, JY5500CoreOO::CITrigger, JY5500CoreOO::COTrigger, JY5500CoreOO::DITrigger, JY5500CoreOO::DOTrigger
  • Direction : JY5500CoreOO::EdgeCounting
  • DirTerminal : JY5500CoreOO::EdgeCounting
  • DSMode : JY5500CoreOO::AIAdvanced


5500 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- e -

  • Edge : JY5500CoreOO::AIAnalogTrigger, JY5500CoreOO::AIDigitalTrigger, JY5500CoreOO::AODigitalTrigger, JY5500CoreOO::CIDigitalTrigger, JY5500CoreOO::CODigitalTrigger, JY5500CoreOO::DIDigitalTrigger, JY5500CoreOO::DODigitalTrigger
  • EdgeCounting : JY5500CoreOO::JY5500CoreOOCITask
  • Enable : JY5500CoreOO::AIDSMode
  • EnableLog : JY5500CoreOO::JY5500CoreOOLog
  • EncodingType : JY5500CoreOO::QuadEncoder
  • errorCode : JY5500CoreOO::JYDriverException
  • exceptionMessage : JY5500CoreOO::JYDriverException
  • ExpectedRate : JY5500CoreOO::AIExternalSampleClock, JY5500CoreOO::AOExternalSampleClock, JY5500CoreOO::CIExternalSampleClock, JY5500CoreOO::CIImplicitSampleClock, JY5500CoreOO::DIExternalSampleClock, JY5500CoreOO::DOExternalSampleClock
  • External : JY5500CoreOO::AISampleClock, JY5500CoreOO::AOSampleClock, JY5500CoreOO::CISampleClock, JY5500CoreOO::DISampleClock, JY5500CoreOO::DOSampleClock, JY5500CoreOO::JY5500CoreOOReferenceClock


5500 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- f -

  • File_Format : JY5500CoreOO::AIRecord
  • FilePath : JY5500CoreOO::AIRecord
  • Filter : JY5500CoreOO::PFISetting
  • FirstInputTerminal : JY5500CoreOO::TwoEdgeSeparation
  • FollowingException : JY5500CoreOO::JYDriverException
  • FrequencyMeas : JY5500CoreOO::JY5500CoreOOCITask


5500 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- h -

  • Handle : JY5500CoreOO::JY5500CoreOODevice
  • HighThreshold : JY5500CoreOO::AIAnalogHysteresisComparator, JY5500CoreOO::AIAnalogWindowComparator
  • Hysteresis : JY5500CoreOO::AIAnalogTrigger


5500 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- i -

  • IdleState : JY5500CoreOO::EdgeCountingOutEvent, JY5500CoreOO::JY5500CoreOOCOTask
  • Implicit : JY5500CoreOO::CISampleClock
  • InitialCount : JY5500CoreOO::EdgeCounting, JY5500CoreOO::QuadEncoder, JY5500CoreOO::TwoPulseEncoder
  • InitialDelay : JY5500CoreOO::JY5500CoreOOCOTask
  • Input_Terminal : JY5500CoreOO::EdgeCounting, JY5500CoreOO::FrequencyMeas, JY5500CoreOO::PeriodMeas, JY5500CoreOO::PulseMeas
  • Internal : JY5500CoreOO::CISampleClock
  • IsAISync : JY5500CoreOO::JY5500CoreOODevice
  • IsAOSync : JY5500CoreOO::JY5500CoreOODevice


5500 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- l -

  • Length : JY5500CoreOO::AIRecord
  • LogLevel : JY5500CoreOO::JY5500CoreOOLog
  • LowThreshold : JY5500CoreOO::AIAnalogHysteresisComparator, JY5500CoreOO::AIAnalogWindowComparator


5500 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- m -

  • MaxSampleRateMutilChannel : JY5500CoreOO::JY5500CoreOODevice
  • MaxSampleRateSingleChannel : JY5500CoreOO::JY5500CoreOODevice
  • MaxUpdateRateFourChannel : JY5500CoreOO::JY5500CoreOODevice
  • MaxUpdateRateSingleChannel : JY5500CoreOO::JY5500CoreOODevice
  • MaxUpdateRateThreeChannel : JY5500CoreOO::JY5500CoreOODevice
  • MaxUpdateRateTwoChannel : JY5500CoreOO::JY5500CoreOODevice
  • Mode : JY5500CoreOO::AIRecord, JY5500CoreOO::AITrigger, JY5500CoreOO::DITrigger, JY5500CoreOO::JY5500CoreOOAITask, JY5500CoreOO::JY5500CoreOOAOTask, JY5500CoreOO::JY5500CoreOOCITask, JY5500CoreOO::JY5500CoreOOCOTask, JY5500CoreOO::JY5500CoreOODITask, JY5500CoreOO::JY5500CoreOODOTask


5500 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- o -

  • OutEvent : JY5500CoreOO::EdgeCounting
  • OutputTerminal : JY5500CoreOO::JY5500CoreOOCOTask


5500 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- p -

  • Pause : JY5500CoreOO::EdgeCounting, JY5500CoreOO::JY5500CoreOOCOTask
  • PeriodMeas : JY5500CoreOO::JY5500CoreOOCITask
  • PFI : JY5500CoreOO::JY5500CoreOODevice
  • PortNum : JY5500CoreOO::DIChannel, JY5500CoreOO::DOChannel
  • PowerLine_Frequency : JY5500CoreOO::AIDSMode
  • PreTriggerSamples : JY5500CoreOO::AITrigger, JY5500CoreOO::DITrigger
  • PulseMeas : JY5500CoreOO::JY5500CoreOOCITask


5500 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- q -

  • QuadEncoder : JY5500CoreOO::JY5500CoreOOCITask


5500 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- r -

  • RangeHigh : JY5500CoreOO::AIChannel, JY5500CoreOO::AOChannel
  • RangeLow : JY5500CoreOO::AIChannel, JY5500CoreOO::AOChannel
  • Rate : JY5500CoreOO::CIInternalSampleClock
  • Record : JY5500CoreOO::JY5500CoreOOAITask
  • ReferenceClock : JY5500CoreOO::JY5500CoreOODevice
  • ReTriggerCount : JY5500CoreOO::AITrigger


5500 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- s -

  • SampleClock : JY5500CoreOO::JY5500CoreOOAITask, JY5500CoreOO::JY5500CoreOOAOTask, JY5500CoreOO::JY5500CoreOOCITask, JY5500CoreOO::JY5500CoreOODITask, JY5500CoreOO::JY5500CoreOODOTask
  • SampleRate : JY5500CoreOO::JY5500CoreOOAITask, JY5500CoreOO::JY5500CoreOODITask
  • SamplesToAcquire : JY5500CoreOO::JY5500CoreOOAITask, JY5500CoreOO::JY5500CoreOOCITask, JY5500CoreOO::JY5500CoreOODITask
  • SamplesToUpdate : JY5500CoreOO::JY5500CoreOOAOTask, JY5500CoreOO::JY5500CoreOOCOTask, JY5500CoreOO::JY5500CoreOODOTask
  • SEChannelCount : JY5500CoreOO::JY5500CoreOODevice
  • SecondInputTerminal : JY5500CoreOO::TwoEdgeSeparation
  • SerialNumber : JY5500CoreOO::JY5500CoreOODevice
  • SignalExport : JY5500CoreOO::JY5500CoreOOAITask, JY5500CoreOO::JY5500CoreOOAOTask, JY5500CoreOO::JY5500CoreOOCITask, JY5500CoreOO::JY5500CoreOOCOTask, JY5500CoreOO::JY5500CoreOODITask, JY5500CoreOO::JY5500CoreOODOTask
  • Slope : JY5500CoreOO::AIAnalogEdgeComparator, JY5500CoreOO::AIAnalogHysteresisComparator
  • Source : JY5500CoreOO::AIAnalogTrigger, JY5500CoreOO::AIDigitalTrigger, JY5500CoreOO::AISampleClock, JY5500CoreOO::AODigitalTrigger, JY5500CoreOO::AOSampleClock, JY5500CoreOO::CIDigitalTrigger, JY5500CoreOO::CISampleClock, JY5500CoreOO::CITimebase, JY5500CoreOO::CODigitalTrigger, JY5500CoreOO::COTimebase, JY5500CoreOO::DIDigitalTrigger, JY5500CoreOO::DISampleClock, JY5500CoreOO::DODigitalTrigger, JY5500CoreOO::DOSampleClock, JY5500CoreOO::JY5500CoreOOReferenceClock


5500 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- t -

  • Terminal : JY5500CoreOO::AIChannel, JY5500CoreOO::AIExternalSampleClock, JY5500CoreOO::AOExternalSampleClock, JY5500CoreOO::CIExternalSampleClock, JY5500CoreOO::DIExternalSampleClock, JY5500CoreOO::DOExternalSampleClock, JY5500CoreOO::EdgeCountingOutEvent, JY5500CoreOO::ExternalReferenceClock, JY5500CoreOO::PauseTrigger
  • Threshold : JY5500CoreOO::AIAnalogEdgeComparator, JY5500CoreOO::EdgeCountingOutEvent
  • TimeBase : JY5500CoreOO::JY5500CoreOOCOTask
  • Timebase : JY5500CoreOO::FrequencyMeas, JY5500CoreOO::PeriodMeas, JY5500CoreOO::PulseMeas, JY5500CoreOO::TwoEdgeSeparation
  • TransferedPulses : JY5500CoreOO::JY5500CoreOOCOTask
  • TransferedSamples : JY5500CoreOO::JY5500CoreOOAITask, JY5500CoreOO::JY5500CoreOOAOTask, JY5500CoreOO::JY5500CoreOOCITask, JY5500CoreOO::JY5500CoreOOCOTask, JY5500CoreOO::JY5500CoreOODITask, JY5500CoreOO::JY5500CoreOODOTask
  • Trigger : JY5500CoreOO::JY5500CoreOOAITask, JY5500CoreOO::JY5500CoreOOAOTask, JY5500CoreOO::JY5500CoreOOCITask, JY5500CoreOO::JY5500CoreOOCOTask, JY5500CoreOO::JY5500CoreOODITask, JY5500CoreOO::JY5500CoreOODOTask
  • TwoEdgeSeparation : JY5500CoreOO::JY5500CoreOOCITask
  • TwoPulseEncoder : JY5500CoreOO::JY5500CoreOOCITask
  • Type : JY5500CoreOO::AITrigger, JY5500CoreOO::AOTrigger, JY5500CoreOO::CITrigger, JY5500CoreOO::COTrigger, JY5500CoreOO::DITrigger, JY5500CoreOO::DOTrigger, JY5500CoreOO::JY5500CoreOOCITask


5500 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- u -

  • UpdateRate : JY5500CoreOO::JY5500CoreOOAOTask, JY5500CoreOO::JY5500CoreOODOTask


5500 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- w -

  • Window : JY5500CoreOO::AIAnalogTrigger


5500 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
Here is a list of all variables with links to the classes they belong to:

- z -

  • ZInputTerminal : JY5500CoreOO::QuadEncoder
  • ZReloadEnabled : JY5500CoreOO::QuadEncoder


5500 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- w -

  • WaitUntilDone() : JY5500CoreOO::JY5500CoreOOAOTask, JY5500CoreOO::JY5500CoreOOCOTask, JY5500CoreOO::JY5500CoreOODOTask
  • Window : JY5500CoreOO::AIAnalogTrigger
  • WriteData() : JY5500CoreOO::JY5500CoreOOAOTask, JY5500CoreOO::JY5500CoreOOCOTask, JY5500CoreOO::JY5500CoreOODOTask
  • WriteRawData() : JY5500CoreOO::JY5500CoreOOAOTask
  • WriteRawSinglePoint() : JY5500CoreOO::JY5500CoreOOAOTask
  • WriteSinglePoint() : JY5500CoreOO::JY5500CoreOOAOTask, JY5500CoreOO::JY5500CoreOOCOTask, JY5500CoreOO::JY5500CoreOODOTask


5500 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- z -

  • ZInputTerminal : JY5500CoreOO::QuadEncoder
  • ZReloadEnabled : JY5500CoreOO::QuadEncoder


5500 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- ~ -

  • ~JY5500CoreOOAITask() : JY5500CoreOO::JY5500CoreOOAITask
  • ~JY5500CoreOOAOTask() : JY5500CoreOO::JY5500CoreOOAOTask
  • ~JY5500CoreOOCITask() : JY5500CoreOO::JY5500CoreOOCITask
  • ~JY5500CoreOOCOTask() : JY5500CoreOO::JY5500CoreOOCOTask
  • ~JY5500CoreOODITask() : JY5500CoreOO::JY5500CoreOODITask
  • ~JY5500CoreOODOTask() : JY5500CoreOO::JY5500CoreOODOTask


5500 C++ Programming Manual: File Members

  • File List
  • File Members
  • All
  • Macros
Here is a list of all file members with links to the files they belong to:
  • EXTERN_C : JY5500CoreOOCommon.h
  • JY5500CoreOO_API : JY5500CoreOOCommon.h


5500 C++ Programming Manual: File Members

  • File List
  • File Members
  • All
  • Macros
Here is a list of all macros with links to the files they belong to:
  • EXTERN_C : JY5500CoreOOCommon.h
  • JY5500CoreOO_API : JY5500CoreOOCommon.h


5500 C++ Programming Manual: Main Page

5500 C++ Programming Manual Documentation


5500 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • a
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • l
  • o
  • p
  • q
  • r
  • s
Here is a list of all namespace members with links to the namespace documentation for each member:

- a -

  • AIAnalogTriggerComparator : JY5500CoreOO
  • AIAnalogTriggerEdge : JY5500CoreOO
  • AIAnalogTriggerSource : JY5500CoreOO
  • AIAnalogWindowCondition : JY5500CoreOO
  • AIDigitalTriggerEdge : JY5500CoreOO
  • AIDigitalTriggerSource : JY5500CoreOO
  • AIMode : JY5500CoreOO
  • AISampleClockSource : JY5500CoreOO
  • AISignalExportSource : JY5500CoreOO
  • AITerminal : JY5500CoreOO
  • AITriggerMode : JY5500CoreOO
  • AITriggerType : JY5500CoreOO
  • AODigitalTriggerEdge : JY5500CoreOO
  • AODigitalTriggerSource : JY5500CoreOO
  • AOMode : JY5500CoreOO
  • AOSampleClockSource : JY5500CoreOO
  • AOSignalExportSource : JY5500CoreOO
  • AOTriggerType : JY5500CoreOO

- c -

  • CIDigitalTriggerEdge : JY5500CoreOO
  • CIDigitalTriggerSource : JY5500CoreOO
  • CIMode : JY5500CoreOO
  • CISampleClockSource : JY5500CoreOO
  • CISignalExportSource : JY5500CoreOO
  • CITimebaseSource : JY5500CoreOO
  • CITriggerType : JY5500CoreOO
  • CIType : JY5500CoreOO
  • ClockTerminal : JY5500CoreOO
  • CODigitalTriggerEdge : JY5500CoreOO
  • CODigitalTriggerSource : JY5500CoreOO
  • COIdleState : JY5500CoreOO
  • COMode : JY5500CoreOO
  • COPulseType : JY5500CoreOO
  • COSignalExportSource : JY5500CoreOO
  • COTimebaseSource : JY5500CoreOO
  • COTriggerType : JY5500CoreOO
  • CountDirection : JY5500CoreOO

- d -

  • DIDigitalTriggerEdge : JY5500CoreOO
  • DIDigitalTriggerSource : JY5500CoreOO
  • DIMode : JY5500CoreOO
  • DISampleClockSource : JY5500CoreOO
  • DISignalExportSource : JY5500CoreOO
  • DITriggerMode : JY5500CoreOO
  • DITriggerType : JY5500CoreOO
  • DODigitalTriggerEdge : JY5500CoreOO
  • DODigitalTriggerSource : JY5500CoreOO
  • DOMode : JY5500CoreOO
  • DOSampleClockSource : JY5500CoreOO
  • DOSignalExportSource : JY5500CoreOO
  • DOTriggerType : JY5500CoreOO

- e -

  • EdgeCntOunEvtIdleState : JY5500CoreOO
  • EdgeType : JY5500CoreOO
  • ExternalReferenceClockTerminal : JY5500CoreOO

- f -

  • FileFormat : JY5500CoreOO

- g -

  • GetSignalExportDestinationString() : JY5500CoreOO

- i -

  • InputTerminal : JY5500CoreOO
  • IOTerminal : JY5500CoreOO

- j -

  • JY5500CoreOOLogLevel : JY5500CoreOO
  • JY5500CoreOOPropertyType : JY5500CoreOO
  • JYDriverExceptionPublic : JY5500CoreOO

- l -

  • LevelPolarity : JY5500CoreOO

- o -

  • OutputCompleteState : JY5500CoreOO

- p -

  • PFITerminal : JY5500CoreOO
  • PowerLineFrequency : JY5500CoreOO

- q -

  • QuadEncodingType : JY5500CoreOO

- r -

  • RecordMode : JY5500CoreOO
  • ReferenceClockSource : JY5500CoreOO

- s -

  • SignalExportDestination : JY5500CoreOO


5500 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • a
  • c
  • d
  • e
  • f
  • i
  • j
  • l
  • o
  • p
  • q
  • r
  • s
Here is a list of all namespace enums with links to the namespace documentation for each enum:

- a -

  • AIAnalogTriggerComparator : JY5500CoreOO
  • AIAnalogTriggerEdge : JY5500CoreOO
  • AIAnalogTriggerSource : JY5500CoreOO
  • AIAnalogWindowCondition : JY5500CoreOO
  • AIDigitalTriggerEdge : JY5500CoreOO
  • AIDigitalTriggerSource : JY5500CoreOO
  • AIMode : JY5500CoreOO
  • AISampleClockSource : JY5500CoreOO
  • AISignalExportSource : JY5500CoreOO
  • AITerminal : JY5500CoreOO
  • AITriggerMode : JY5500CoreOO
  • AITriggerType : JY5500CoreOO
  • AODigitalTriggerEdge : JY5500CoreOO
  • AODigitalTriggerSource : JY5500CoreOO
  • AOMode : JY5500CoreOO
  • AOSampleClockSource : JY5500CoreOO
  • AOSignalExportSource : JY5500CoreOO
  • AOTriggerType : JY5500CoreOO

- c -

  • CIDigitalTriggerEdge : JY5500CoreOO
  • CIDigitalTriggerSource : JY5500CoreOO
  • CIMode : JY5500CoreOO
  • CISampleClockSource : JY5500CoreOO
  • CISignalExportSource : JY5500CoreOO
  • CITimebaseSource : JY5500CoreOO
  • CITriggerType : JY5500CoreOO
  • CIType : JY5500CoreOO
  • ClockTerminal : JY5500CoreOO
  • CODigitalTriggerEdge : JY5500CoreOO
  • CODigitalTriggerSource : JY5500CoreOO
  • COIdleState : JY5500CoreOO
  • COMode : JY5500CoreOO
  • COPulseType : JY5500CoreOO
  • COSignalExportSource : JY5500CoreOO
  • COTimebaseSource : JY5500CoreOO
  • COTriggerType : JY5500CoreOO
  • CountDirection : JY5500CoreOO

- d -

  • DIDigitalTriggerEdge : JY5500CoreOO
  • DIDigitalTriggerSource : JY5500CoreOO
  • DIMode : JY5500CoreOO
  • DISampleClockSource : JY5500CoreOO
  • DISignalExportSource : JY5500CoreOO
  • DITriggerMode : JY5500CoreOO
  • DITriggerType : JY5500CoreOO
  • DODigitalTriggerEdge : JY5500CoreOO
  • DODigitalTriggerSource : JY5500CoreOO
  • DOMode : JY5500CoreOO
  • DOSampleClockSource : JY5500CoreOO
  • DOSignalExportSource : JY5500CoreOO
  • DOTriggerType : JY5500CoreOO

- e -

  • EdgeCntOunEvtIdleState : JY5500CoreOO
  • EdgeType : JY5500CoreOO
  • ExternalReferenceClockTerminal : JY5500CoreOO

- f -

  • FileFormat : JY5500CoreOO

- i -

  • InputTerminal : JY5500CoreOO
  • IOTerminal : JY5500CoreOO

- j -

  • JY5500CoreOOLogLevel : JY5500CoreOO
  • JY5500CoreOOPropertyType : JY5500CoreOO
  • JYDriverExceptionPublic : JY5500CoreOO

- l -

  • LevelPolarity : JY5500CoreOO

- o -

  • OutputCompleteState : JY5500CoreOO

- p -

  • PFITerminal : JY5500CoreOO
  • PowerLineFrequency : JY5500CoreOO

- q -

  • QuadEncodingType : JY5500CoreOO

- r -

  • RecordMode : JY5500CoreOO
  • ReferenceClockSource : JY5500CoreOO

- s -

  • SignalExportDestination : JY5500CoreOO


5500 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
Here is a list of all namespace functions with links to the namespace documentation for each function:
  • GetSignalExportDestinationString() : JY5500CoreOO


5500 C++ Programming Manual: Namespace List

  • Namespace List
  • Namespace Members
Namespace List
Here is a list of all namespaces with brief descriptions:
N JY5500CoreOO