5710 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5710 Directory Reference

5710 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 5710
5710 Directory Reference

Files

JY5710CoreOOAOTask.h
JY5710CoreOOCommon.h
JY5710CoreOODevice.h
JY5710CoreOODITask.h
JY5710CoreOODOTask.h
JY5710CoreOOLog.h
Generated by doxygen 1.13.2


5710 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5710/JY5710CoreOOAOTask.h File Reference

  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 5710
Classes | Namespaces | Enumerations
JY5710CoreOOAOTask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JY5710CoreOOCommon.h"
#include "JY5710CoreOODevice.h"

Classes

class | JY5710CoreOO::JY5710CoreOOAOTask
AOTask类 More...
class | JY5710CoreOO::AOChannel
class | JY5710CoreOO::AOExternalSampleClock
External Sample Clock Configuration Class. More...
class | JY5710CoreOO::AOSampleClock
AO Sample clock configuration class. More...
class | JY5710CoreOO::AOTrigger
Constructor to create an AOTrigger task object. More...
class | JY5710CoreOO::AODigitalTrigger
AO Digital trigger . More...
class | JY5710CoreOO::AOSignalExport
AO Signal Export Class. More...

Namespaces

namespace JY5710CoreOO

Enumerations

enum class | JY5710CoreOO::AODigitalTriggerEdge { JY5710CoreOO::Rising , JY5710CoreOO::Falling }
AO Digital Trigger Edge. More...
enum class JY5710CoreOO::AODigitalTriggerSource {
JY5710CoreOO::PFI0 = 1 , JY5710CoreOO::PFI1 = 2 , JY5710CoreOO::PFI2 = 3 , JY5710CoreOO::PXI_Trig0 = 8 ,
JY5710CoreOO::PXI_Trig1 = 9 , JY5710CoreOO::PXI_Trig2 = 10 , JY5710CoreOO::PXI_Trig3 = 11 , JY5710CoreOO::PXI_Trig4 = 12 ,
JY5710CoreOO::PXI_Trig5 = 13 , JY5710CoreOO::PXI_Trig6 = 14 , JY5710CoreOO::PXI_Trig7 = 15
}
AO Digital trigger source. More...
enum class | JY5710CoreOO::AOMode { JY5710CoreOO::Single = 3 , JY5710CoreOO::Finite = 0 , JY5710CoreOO::ContinuousNoWrapping = 2 , JY5710CoreOO::ContinuousWrapping = 1 }
enum class | JY5710CoreOO::AOSampleClockSource { JY5710CoreOO::Internal , JY5710CoreOO::External }
AO Sample Clock Source. More...
enum class | JY5710CoreOO::AOSignalExportSource { JY5710CoreOO::StartTrig = JY5710Import::JY5710_AO_StartTrig , JY5710CoreOO::SampleClock = JY5710Import::JY5710_AO_SampleClock }
SourceSignal. More...
enum class | JY5710CoreOO::AOTriggerType { JY5710CoreOO::Immediate = JY5710Import::JY5710_TriggerType_Immediately , JY5710CoreOO::Digital = JY5710Import::JY5710_TriggerType_Digital , JY5710CoreOO::Soft = JY5710Import::JY5710_TriggerType_Soft }
TriggerType Digital/Immediate/Soft. More...
enum class | JY5710CoreOO::OutputCompleteState { JY5710CoreOO::Zero , JY5710CoreOO::Hold }
Output Complete State. More...


5710 C++ Programming Manual: JY5710CoreOO::JY5710CoreOOAOTask Class Reference

  • Class List
  • Class Index
  • Class Members
  • JY5710CoreOO
  • JY5710CoreOOAOTask
Public Member Functions | Public Attributes | List of all members
JY5710CoreOO::JY5710CoreOOAOTask Class Reference

AOTask类 More...

#include <JY5710CoreOOAOTask.h>

Public Member Functions

JY5710CoreOOAOTask (int slotNum)
JY5710CoreOOAOTask (std::string boardName)
~JY5710CoreOOAOTask ()
void | AddChannel (int chnId)
Add one channel.
void | AddChannel (std::vector< int > chnsId)
Add a group of channels.
void | RemoveChannel (int chnId)
Delete the specified channel number.
void | WriteData (double *pBuf, int samplesPerChannel, int timeout=10000)
Write to AO buffer one or multi-channel data.
void | WriteRawData (int16_t *pBuf, int samplesPerChannel, int timeout=10000)
Write to AO buffer one or multi-channel raw data.The buffer is pointed by C++ data type int16_t.
void | WriteSinglePoint (std::vector< double > writeValues)
write one sample to all channels in register .
void | WriteSinglePoint (double writeValue, int channel)
Write one sample to the specified channel in register.Available when Mode is AOMode.Single
void | WriteRawSinglePoint (std::vector< int16_t > writeValues)
write one raw sample to all channels in register .
void | WriteRawSinglePoint (int16_t writeValue, int channel)
Write one raw sample to the specified channel in register.Available when Mode is AOMode.Single
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.
void | Start ()
Start AO task .
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Stop ()
Stop AO task .

Public Attributes

std::list< AOChannel * > | Channels
List of AO channels,(5710 support 32 Diff channel)
AOMode Mode
Mode of AO Task.
JY5710CoreOOProperty< JY5710CoreOOAOTask, double, JY5710CoreOOPropertyType::READ_WRITE > | UpdateRate
Update rate per channel.
unsigned int | SamplesToUpdate
Number of output samples to write per channel , Only valid when Mode is AOMode.Finite.
JY5710CoreOOProperty< JY5710CoreOOAOTask, int, JY5710CoreOOPropertyType::READ_ONLY > | BufLenInSamples
Number of samples per channel can be storage in the buffer, the PropretySamplesToUpdate must be less than or equal to this value.
JY5710CoreOOProperty< JY5710CoreOOAOTask, uint32_t, JY5710CoreOOPropertyType::READ_ONLY > | AvaliableLenInSamples
Number of output samples per channel that can be write in AO buffuer.
OutputCompleteState CompleteState
AO Output Complete State, Valid when Mode is NOT OMode.Single.
JY5710CoreOOProperty< JY5710CoreOOAOTask, uint64_t, JY5710CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
AOSampleClock * SampleClock
AO Sample Clock Configuration.
AOTrigger * Trigger
AO Trigger Configuration.
AOSignalExport * SignalExport
Export AO Signal.
JY5710CoreOODevice * Device

Detailed Description

AOTask类

Constructor & Destructor Documentation

◆ JY5710CoreOOAOTask() [1/2]

JY5710CoreOO::JY5710CoreOOAOTask::JY5710CoreOOAOTask ( int slotNum )

◆ JY5710CoreOOAOTask() [2/2]

JY5710CoreOO::JY5710CoreOOAOTask::JY5710CoreOOAOTask ( std::string boardName )

◆ ~JY5710CoreOOAOTask()

JY5710CoreOO::JY5710CoreOOAOTask::~JY5710CoreOOAOTask ( )

Member Function Documentation

◆ AddChannel() [1/2]

void JY5710CoreOO::JY5710CoreOOAOTask::AddChannel ( int chnId )

Add one channel.

Parameters
chnId channel's physical number ，chnId=-1, add all channels。（5710 support 32 channels)

◆ AddChannel() [2/2]

void JY5710CoreOO::JY5710CoreOOAOTask::AddChannel ( std::vector< int > chnsId )

Add a group of channels.

Parameters
chnsId a group of channel physical numbers。（5710 support 32 channels）

◆ RemoveChannel()

void JY5710CoreOO::JY5710CoreOOAOTask::RemoveChannel ( int chnId )

Delete the specified channel number.

If it is -1, delete all channels.

Parameters
chnId Specified channel ID.

◆ SendSoftwareTrigger()

void JY5710CoreOO::JY5710CoreOOAOTask::SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5710CoreOO::JY5710CoreOOAOTask::Start ( )

Start AO task .

◆ Stop()

void JY5710CoreOO::JY5710CoreOOAOTask::Stop ( )

Stop AO task .

◆ WaitUntilDone()

bool JY5710CoreOO::JY5710CoreOOAOTask::WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Available when Mode is AOMode.Finite

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteData()

void JY5710CoreOO::JY5710CoreOOAOTask::WriteData | ( | double * | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Write to AO buffer one or multi-channel data.

The buffer is pointed by C++ data type double.

Parameters
buf | data buffer.
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawData()

void JY5710CoreOO::JY5710CoreOOAOTask::WriteRawData | ( | int16_t * | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Write to AO buffer one or multi-channel raw data.The buffer is pointed by C++ data type int16_t.

Parameters
buf | data buffer.
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawSinglePoint() [1/2]

void JY5710CoreOO::JY5710CoreOOAOTask::WriteRawSinglePoint | ( | int16_t | writeValue,
 |  | int | channel )

Write one raw sample to the specified channel in register.Available when Mode is AOMode.Single

Parameters
writeValue | Write value.
channel | Specified channel.

◆ WriteRawSinglePoint() [2/2]

void JY5710CoreOO::JY5710CoreOOAOTask::WriteRawSinglePoint ( std::vector< int16_t > writeValues )

write one raw sample to all channels in register .

Available when Mode is AOMode.Single

Parameters
writeValues Write values. Array length >= Channels.Count.

◆ WriteSinglePoint() [1/2]

void JY5710CoreOO::JY5710CoreOOAOTask::WriteSinglePoint | ( | double | writeValue,
 |  | int | channel )

Write one sample to the specified channel in register.Available when Mode is AOMode.Single

Parameters
writeValue | Write value.
channel | Specified channel.

◆ WriteSinglePoint() [2/2]

void JY5710CoreOO::JY5710CoreOOAOTask::WriteSinglePoint ( std::vector< double > writeValues )

write one sample to all channels in register .

Available when Mode is AOMode.Single

Parameters
writeValues Write values. Array length >= Channels.Count.

Member Data Documentation

◆ AvaliableLenInSamples

JY5710CoreOOProperty<JY5710CoreOOAOTask, uint32_t, JY5710CoreOOPropertyType::READ_ONLY> JY5710CoreOO::JY5710CoreOOAOTask::AvaliableLenInSamples

Number of output samples per channel that can be write in AO buffuer.

◆ BufLenInSamples

JY5710CoreOOProperty<JY5710CoreOOAOTask, int, JY5710CoreOOPropertyType::READ_ONLY> JY5710CoreOO::JY5710CoreOOAOTask::BufLenInSamples

Number of samples per channel can be storage in the buffer, the PropretySamplesToUpdate must be less than or equal to this value.

◆ Channels

std::list<AOChannel*> JY5710CoreOO::JY5710CoreOOAOTask::Channels

List of AO channels,(5710 support 32 Diff channel)

◆ CompleteState

OutputCompleteState JY5710CoreOO::JY5710CoreOOAOTask::CompleteState

AO Output Complete State, Valid when Mode is NOT OMode.Single.

Default is Zero.

◆ Device

JY5710CoreOODevice* JY5710CoreOO::JY5710CoreOOAOTask::Device

◆ Mode

AOMode JY5710CoreOO::JY5710CoreOOAOTask::Mode

Mode of AO Task.

Select AO Mode from enum:ContinuousNoWrapping/ContinuousWrapping/Finite/Single.

◆ SampleClock

AOSampleClock* JY5710CoreOO::JY5710CoreOOAOTask::SampleClock

AO Sample Clock Configuration.

◆ SamplesToUpdate

unsigned int JY5710CoreOO::JY5710CoreOOAOTask::SamplesToUpdate

Number of output samples to write per channel , Only valid when Mode is AOMode.Finite.

◆ SignalExport

AOSignalExport* JY5710CoreOO::JY5710CoreOOAOTask::SignalExport

Export AO Signal.

◆ TransferedSamples

JY5710CoreOOProperty<JY5710CoreOOAOTask, uint64_t, JY5710CoreOOPropertyType::READ_ONLY> JY5710CoreOO::JY5710CoreOOAOTask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT AOMode.Single.

◆ Trigger

AOTrigger* JY5710CoreOO::JY5710CoreOOAOTask::Trigger

AO Trigger Configuration.

◆ UpdateRate

JY5710CoreOOProperty<JY5710CoreOOAOTask, double, JY5710CoreOOPropertyType::READ_WRITE> JY5710CoreOO::JY5710CoreOOAOTask::UpdateRate

Update rate per channel.

Maximum update rate is 2M for single~eight channel, 1M for ThirtyTow channels. The defalut sample rate = 1000000 You can read this property to obtain the update rate that will actually take effect in the current configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5710/JY5710CoreOOAOTask.h


5710 C++ Programming Manual: JY5710CoreOO::AOChannel Class Reference

  • JY5710CoreOO
  • AOChannel
Public Member Functions | Public Attributes | List of all members
JY5710CoreOO::AOChannel Class Reference

#include <JY5710CoreOOAOTask.h>

Public Member Functions

AOChannel (int channelId)

Public Attributes

int ChannelID

Constructor & Destructor Documentation

◆ AOChannel()

JY5710CoreOO::AOChannel::AOChannel ( int channelId )
inline

Member Data Documentation

◆ ChannelID

int JY5710CoreOO::AOChannel::ChannelID
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5710/JY5710CoreOOAOTask.h


5710 C++ Programming Manual: JY5710CoreOO::AOExternalSampleClock Class Reference

  • AOExternalSampleClock
Public Attributes | List of all members
JY5710CoreOO::AOExternalSampleClock Class Reference

External Sample Clock Configuration Class. More...

#include <JY5710CoreOOAOTask.h>

Public Attributes

ClockTerminal Terminal
External Sample Clock Input Terminal.
double ExpectedRate
Expected External Sample Clock Rate.

Detailed Description

External Sample Clock Configuration Class.

Member Data Documentation

◆ ExpectedRate

double JY5710CoreOO::AOExternalSampleClock::ExpectedRate

Expected External Sample Clock Rate.

◆ Terminal

ClockTerminal JY5710CoreOO::AOExternalSampleClock::Terminal

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5710/JY5710CoreOOAOTask.h


5710 C++ Programming Manual: JY5710CoreOO::AOSampleClock Class Reference

  • AOSampleClock
Public Attributes | List of all members
JY5710CoreOO::AOSampleClock Class Reference

AO Sample clock configuration class. More...

#include <JY5710CoreOOAOTask.h>

Public Attributes

AOSampleClockSource Source
Clock Source.
AOExternalSampleClock * External
External Sample Clock Configuration,Valid when Source is AOSampleClockSource::External.

Detailed Description

AO Sample clock configuration class.

Member Data Documentation

◆ External

AOExternalSampleClock* JY5710CoreOO::AOSampleClock::External

External Sample Clock Configuration,Valid when Source is AOSampleClockSource::External.

◆ Source

AOSampleClockSource JY5710CoreOO::AOSampleClock::Source

Clock Source.

enum Internal/External,The default value is AOSampleClockSource.Internal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5710/JY5710CoreOOAOTask.h


5710 C++ Programming Manual: JY5710CoreOO::AOTrigger Class Reference

  • AOTrigger
Public Attributes | List of all members
JY5710CoreOO::AOTrigger Class Reference

Constructor to create an AOTrigger task object. More...

#include <JY5710CoreOOAOTask.h>

Public Attributes

AOTriggerType Type
AO trigger type.
AODigitalTrigger * Digital
AO Digital Trigger.

Detailed Description

Constructor to create an AOTrigger task object.

Used to build AO Trigger

Member Data Documentation

◆ Digital

AODigitalTrigger* JY5710CoreOO::AOTrigger::Digital

AO Digital Trigger.

Valid when Type is AOTriggerType.Digital.

◆ Type

AOTriggerType JY5710CoreOO::AOTrigger::Type

AO trigger type.

enum Immediate/Digital/Soft.The default value is AOTriggerType.Immediate.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5710/JY5710CoreOOAOTask.h


5710 C++ Programming Manual: JY5710CoreOO::AODigitalTrigger Class Reference

  • AODigitalTrigger
Public Attributes | List of all members
JY5710CoreOO::AODigitalTrigger Class Reference

AO Digital trigger . More...

#include <JY5710CoreOOAOTask.h>

Public Attributes

AODigitalTriggerSource Source
AO Digital Trigger source.
AODigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Detailed Description

AO Digital trigger .

Member Data Documentation

◆ Edge

AODigitalTriggerEdge JY5710CoreOO::AODigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

AODigitalTriggerSource JY5710CoreOO::AODigitalTrigger::Source

AO Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5710/JY5710CoreOOAOTask.h


5710 C++ Programming Manual: JY5710CoreOO::AOSignalExport Class Reference

  • AOSignalExport
Public Member Functions | List of all members
JY5710CoreOO::AOSignalExport Class Reference

AO Signal Export Class. More...

#include <JY5710CoreOOAOTask.h>

Public Member Functions

void | Add (AOSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (AOSignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

AO Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY5710CoreOO::AOSignalExport::Add | ( | AOSignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | AO Signal Source
destination | Export Desination

◆ Add() [2/2]

void JY5710CoreOO::AOSignalExport::Add | ( | AOSignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | AO Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JY5710CoreOO::AOSignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY5710CoreOO::AOSignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5710/JY5710CoreOOAOTask.h


5710 C++ Programming Manual: JY5710CoreOO Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Enumerations | Functions
JY5710CoreOO Namespace Reference

Classes

class | AOChannel
class | AODigitalTrigger
AO Digital trigger . More...
class | AOExternalSampleClock
External Sample Clock Configuration Class. More...
class | AOSampleClock
AO Sample clock configuration class. More...
class | AOSignalExport
AO Signal Export Class. More...
class | AOTrigger
Constructor to create an AOTrigger task object. More...
class | DIChannel
DI Channel parameter class . More...
class | DOChannel
DO Channel parameter class . More...
class | ExternalReferenceClock
class | JY5710CoreOOAOTask
AOTask类 More...
class | JY5710CoreOODevice
class | JY5710CoreOODITask
DITask类 More...
class | JY5710CoreOODOTask
DOTask类 More...
class | JY5710CoreOOLog
class | JY5710CoreOOProperty
属性模板类 More...
class | JY5710CoreOOReferenceClock
class | JYDriverException
class | PauseTrigger
Pause trigger configuration class. More...

Enumerations

enum class | AODigitalTriggerEdge { Rising , Falling }
AO Digital Trigger Edge. More...
enum class AODigitalTriggerSource {
PFI0 = 1 , PFI1 = 2 , PFI2 = 3 , PXI_Trig0 = 8 ,
PXI_Trig1 = 9 , PXI_Trig2 = 10 , PXI_Trig3 = 11 , PXI_Trig4 = 12 ,
PXI_Trig5 = 13 , PXI_Trig6 = 14 , PXI_Trig7 = 15
}
AO Digital trigger source. More...
enum class | AOMode { Single = 3 , Finite = 0 , ContinuousNoWrapping = 2 , ContinuousWrapping = 1 }
enum class | AOSampleClockSource { Internal , External }
AO Sample Clock Source. More...
enum class | AOSignalExportSource { StartTrig = JY5710Import::JY5710_AO_StartTrig , SampleClock = JY5710Import::JY5710_AO_SampleClock }
SourceSignal. More...
enum class | AOTriggerType { Immediate = JY5710Import::JY5710_TriggerType_Immediately , Digital = JY5710Import::JY5710_TriggerType_Digital , Soft = JY5710Import::JY5710_TriggerType_Soft }
TriggerType Digital/Immediate/Soft. More...
enum class | OutputCompleteState { Zero , Hold }
Output Complete State. More...
enum class | JY5710CoreOOPropertyType { READ_ONLY = 1 , WRITE_ONLY = 2 , READ_WRITE = 3 }
enum class JYDriverExceptionPublic {
UnKnown = 0 , OpenDeviceFailed = -10001 , CloseDeviceFailed = -10002 , ResetDeviceFailed = -10003 ,
GetDevicePropertyFailed = -10004 , SetDevicePropertyFailed = -10005 , HardwareResourceIsReserved = -10006 , MethodNotPermitedToCallWhenCurrentStatus = -10007 ,
InvalidUserDataBuffer = -10008 , NoChannelAdded = -10009 , NotSupportOperationForCurrentDevice = -10010 , CreatTaskFailed = -10100 ,
StartTaskFailed = -10101 , StopTaskFailed = -10102 , TaskHasNotStarted = -10103 , TaskHasStartedCannotPerformTheSetOperation = -10104 ,
ChannelNumberParameterInvalid = -10105 , ChannelInputRangeParameterInvalid = -10106 , ChannelTerminalParameterInvalid = -10107 , ChannelCouplingParameterInvalid = -10108 ,
SampeleModeParameterInvalid = -10109 , SampleClockParameterInvalid = -10110 , SampleRateParameterInvalid = -10111 , UpdateRateParameterInvalid = -10112 ,
TriggerParameterInvalid = -10113 , ReferenceTriggerDoesNotMatchWithSampleMode = -10114 , PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint = -10115 , ReadDataFailed = -10016 ,
ReadDataTimeout = -10017 , WriteDataFailed = -10018 , WriteDataTimeout = -10019 , WriteDataLengthCannotBeLessThanN = -10020 ,
BufferDataOverflow = -10021 , BufferDataDownflow = -10022 , CheckBufferFailed = -10023 , PointInvalidInFiniteMode = -10024 ,
ReadPointInvalid = -10025 , OnlySupportRecordMode = -10026 , SendSoftTirggerFailed = -10027 , TaskTimeout = -10028 ,
CounterParametersInvalid = -10029 , WritePointInvalid = -10030 , SignalExportDestinationInvalid = -10031 , InvalidParameter = -10033
}
enum class ClockTerminal {
PFI0 = 1 , PFI1 = 2 , PFI2 = 3 , PXI_Trig0 = 8 ,
PXI_Trig1 = 9 , PXI_Trig2 = 10 , PXI_Trig3 = 11 , PXI_Trig4 = 12 ,
PXI_Trig5 = 13 , PXI_Trig6 = 14 , PXI_Trig7 = 15
}
enum class SignalExportDestination {
PFI0 = JY5710Import::JY5710_PFI0_OUT , PFI1 = JY5710Import::JY5710_PFI1_OUT , PFI2 = JY5710Import::JY5710_PFI2_OUT , PXI_Trig0 = JY5710Import::JY5710_PXITrig0_OUT ,
PXI_Trig1 = JY5710Import::JY5710_PXITrig1_OUT , PXI_Trig2 = JY5710Import::JY5710_PXITrig2_OUT , PXI_Trig3 = JY5710Import::JY5710_PXITrig3_OUT , PXI_Trig4 = JY5710Import::JY5710_PXITrig4_OUT ,
PXI_Trig5 = JY5710Import::JY5710_PXITrig5_OUT , PXI_Trig6 = JY5710Import::JY5710_PXITrig6_OUT , PXI_Trig7 = JY5710Import::JY5710_PXITrig7_OUT
}
enum class IOTerminal {
Default = 0 , PXI_Trig0 = 0x20 , PXI_Trig1 = 0x21 , PXI_Trig2 = 0x22 ,
PXI_Trig3 = 0x23 , PXI_Trig4 = 0x24 , PXI_Trig5 = 0x25 , PXI_Trig6 = 0x26 ,
PXI_Trig7 = 0x27
}
Cunter IO Terminal. More...
enum class | LevelPolarity { LowLevel = 0 , HighLevel = 1 , None = 2 }
Level Polarity. More...
enum class InputTerminal {
Default = 0 , PXI_Trig0 = 40 , PXI_Trig1 = 41 , PXI_Trig2 = 42 ,
PXI_Trig3 = 43 , PXI_Trig4 = 44 , PXI_Trig5 = 45 , PXI_Trig6 = 46 ,
PXI_Trig7 = 47 , CI_0_OutPut = 37 , CI_1_OutPut = 51 , CI_2_OutPut = 60 ,
CI_3_OutPut = 66
}
Cunter Input Terminal. More...
enum class | ExternalReferenceClockTerminal { PXIe_Clk100 = JY5710Import::ReferencePXIeCLK_100M }
enum class | ReferenceClockSource { Internal = JY5710Import::ReferenceOnboard_25M , External = JY5710Import::ReferencePXIeCLK_100M }
enum class JY5710CoreOOLogLevel {
DEBUG_LOG_LEVEL , INFO_LOG_LEVEL , WARN_LOG_LEVEL , ERROR_LOG_LEVEL ,
FATAL_LOG_LEVEL
}

Functions

std::string GetSignalExportDestinationString (SignalExportDestination destination)

Enumeration Type Documentation

◆ AODigitalTriggerEdge

enum class JY5710CoreOO::AODigitalTriggerEdge
strong

AO Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ AODigitalTriggerSource

enum class JY5710CoreOO::AODigitalTriggerSource
strong

AO Digital trigger source.

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.

◆ AOMode

enum class JY5710CoreOO::AOMode
strong
Enumerator
Single | Single.
Finite | Finite.
ContinuousNoWrapping | ContinuousNoWrapping.
ContinuousWrapping | ContinuousWrapping.

◆ AOSampleClockSource

enum class JY5710CoreOO::AOSampleClockSource
strong

AO Sample Clock Source.

Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ AOSignalExportSource

enum class JY5710CoreOO::AOSignalExportSource
strong

SourceSignal.

Enumerator
StartTrig | AO_StartTrig.
SampleClock | AO_SampleClock.

◆ AOTriggerType

enum class JY5710CoreOO::AOTriggerType
strong

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ ClockTerminal

enum class JY5710CoreOO::ClockTerminal
strong
Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PXI_Trig0 | PXITrigger_0.
PXI_Trig1 | PXITrigger_1.
PXI_Trig2 | PXITrigger_2.
PXI_Trig3 | PXITrigger_3.
PXI_Trig4 | PXITrigger_4.
PXI_Trig5 | PXITrigger_5.
PXI_Trig6 | PXITrigger_6.
PXI_Trig7 | PXITrigger_7.

◆ ExternalReferenceClockTerminal

enum class JY5710CoreOO::ExternalReferenceClockTerminal
strong
Enumerator
PXIe_Clk100

PXIe_Clk100.

◆ InputTerminal

enum class JY5710CoreOO::InputTerminal
strong

Cunter Input Terminal.

Enumerator
Default | Default PFI pin by pin define.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
CI_0_OutPut | CI0_StartTrig.
CI_1_OutPut | CI1_StartTrig.
CI_2_OutPut | CI0_StartTrig.
CI_3_OutPut | CI1_StartTrig.

◆ IOTerminal

enum class JY5710CoreOO::IOTerminal
strong

Cunter IO Terminal.

Enumerator
Default | Default PFI pin by pin define.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.

◆ JY5710CoreOOLogLevel

enum class JY5710CoreOO::JY5710CoreOOLogLevel
strong
Enumerator
DEBUG_LOG_LEVEL
INFO_LOG_LEVEL
WARN_LOG_LEVEL
ERROR_LOG_LEVEL
FATAL_LOG_LEVEL

◆ JY5710CoreOOPropertyType

enum class JY5710CoreOO::JY5710CoreOOPropertyType
strong
Enumerator
READ_ONLY
WRITE_ONLY
READ_WRITE

◆ JYDriverExceptionPublic

enum class JY5710CoreOO::JYDriverExceptionPublic
strong
Enumerator
UnKnown | JYDriverExceptionPublic.
OpenDeviceFailed | JYDriverExceptionPublic.
CloseDeviceFailed | JYDriverExceptionPublic.
ResetDeviceFailed | JYDriverExceptionPublic.
GetDevicePropertyFailed | JYDriverExceptionPublic.
SetDevicePropertyFailed | JYDriverExceptionPublic.
HardwareResourceIsReserved | JYDriverExceptionPublic.
MethodNotPermitedToCallWhenCurrentStatus | JYDriverExceptionPublic.
InvalidUserDataBuffer | JYDriverExceptionPublic.
NoChannelAdded | JYDriverExceptionPublic.
NotSupportOperationForCurrentDevice | JYDriverExceptionPublic.
CreatTaskFailed | JYDriverExceptionPublic.
StartTaskFailed | JYDriverExceptionPublic.
StopTaskFailed | JYDriverExceptionPublic.
TaskHasNotStarted | JYDriverExceptionPublic.
TaskHasStartedCannotPerformTheSetOperation | JYDriverExceptionPublic.
ChannelNumberParameterInvalid | JYDriverExceptionPublic.
ChannelInputRangeParameterInvalid | JYDriverExceptionPublic.
ChannelTerminalParameterInvalid | JYDriverExceptionPublic.
ChannelCouplingParameterInvalid | JYDriverExceptionPublic.
SampeleModeParameterInvalid | JYDriverExceptionPublic.
SampleClockParameterInvalid | JYDriverExceptionPublic.
SampleRateParameterInvalid | JYDriverExceptionPublic.
UpdateRateParameterInvalid | JYDriverExceptionPublic.
TriggerParameterInvalid | JYDriverExceptionPublic.
ReferenceTriggerDoesNotMatchWithSampleMode | JYDriverExceptionPublic.
PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint | JYDriverExceptionPublic.
ReadDataFailed | JYDriverExceptionPublic.
ReadDataTimeout | JYDriverExceptionPublic.
WriteDataFailed | JYDriverExceptionPublic.
WriteDataTimeout | JYDriverExceptionPublic.
WriteDataLengthCannotBeLessThanN | JYDriverExceptionPublic.
BufferDataOverflow | JYDriverExceptionPublic.
BufferDataDownflow | JYDriverExceptionPublic.
CheckBufferFailed | JYDriverExceptionPublic.
PointInvalidInFiniteMode | JYDriverExceptionPublic.
ReadPointInvalid | JYDriverExceptionPublic.
OnlySupportRecordMode | JYDriverExceptionPublic.
SendSoftTirggerFailed | JYDriverExceptionPublic.
TaskTimeout | JYDriverExceptionPublic.
CounterParametersInvalid | JYDriverExceptionPublic.
WritePointInvalid | JYDriverExceptionPublic.
SignalExportDestinationInvalid | JYDriverExceptionPublic.
InvalidParameter | 无效参数。 Invalid parameter.

◆ LevelPolarity

enum class JY5710CoreOO::LevelPolarity
strong

Level Polarity.

Enumerator
LowLevel | Low level.
HighLevel | High level.
None | No active polarity.

◆ OutputCompleteState

enum class JY5710CoreOO::OutputCompleteState
strong

Output Complete State.

Enumerator
Zero | Output Complete Zero.
Hold | Output Complete Hold in The last point.

◆ ReferenceClockSource

enum class JY5710CoreOO::ReferenceClockSource
strong
Enumerator
Internal | Internal Onboard 25MHz Clock.
External | External Reference Clock Source.

◆ SignalExportDestination

enum class JY5710CoreOO::SignalExportDestination
strong
Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.

Function Documentation

◆ GetSignalExportDestinationString()

std::string JY5710CoreOO::GetSignalExportDestinationString ( SignalExportDestination destination )
inline


5710 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5710/JY5710CoreOOCommon.h File Reference

  • File List
  • File Members
  • COO
  • 5710
Classes | Namespaces | Macros | Enumerations | Functions | Variables
JY5710CoreOOCommon.h File Reference
#include <string>
#include <stdint.h>

Classes

class | JY5710CoreOO::JYDriverException
class | JY5710CoreOO::JY5710CoreOOProperty< ContainerClass, ValueType, propertyType >
属性模板类 More...
class | JY5710CoreOO::PauseTrigger
Pause trigger configuration class. More...

Namespaces

namespace | JY5710Import
namespace | JY5710CoreOO

Macros

#define | EXTERN_C extern
Windows.
#define | JY5710CoreOO_API

Enumerations

enum class | JY5710CoreOO::JY5710CoreOOPropertyType { JY5710CoreOO::READ_ONLY = 1 , JY5710CoreOO::WRITE_ONLY = 2 , JY5710CoreOO::READ_WRITE = 3 }
enum class JY5710CoreOO::JYDriverExceptionPublic {
JY5710CoreOO::UnKnown = 0 , JY5710CoreOO::OpenDeviceFailed = -10001 , JY5710CoreOO::CloseDeviceFailed = -10002 , JY5710CoreOO::ResetDeviceFailed = -10003 ,
JY5710CoreOO::GetDevicePropertyFailed = -10004 , JY5710CoreOO::SetDevicePropertyFailed = -10005 , JY5710CoreOO::HardwareResourceIsReserved = -10006 , JY5710CoreOO::MethodNotPermitedToCallWhenCurrentStatus = -10007 ,
JY5710CoreOO::InvalidUserDataBuffer = -10008 , JY5710CoreOO::NoChannelAdded = -10009 , JY5710CoreOO::NotSupportOperationForCurrentDevice = -10010 , JY5710CoreOO::CreatTaskFailed = -10100 ,
JY5710CoreOO::StartTaskFailed = -10101 , JY5710CoreOO::StopTaskFailed = -10102 , JY5710CoreOO::TaskHasNotStarted = -10103 , JY5710CoreOO::TaskHasStartedCannotPerformTheSetOperation = -10104 ,
JY5710CoreOO::ChannelNumberParameterInvalid = -10105 , JY5710CoreOO::ChannelInputRangeParameterInvalid = -10106 , JY5710CoreOO::ChannelTerminalParameterInvalid = -10107 , JY5710CoreOO::ChannelCouplingParameterInvalid = -10108 ,
JY5710CoreOO::SampeleModeParameterInvalid = -10109 , JY5710CoreOO::SampleClockParameterInvalid = -10110 , JY5710CoreOO::SampleRateParameterInvalid = -10111 , JY5710CoreOO::UpdateRateParameterInvalid = -10112 ,
JY5710CoreOO::TriggerParameterInvalid = -10113 , JY5710CoreOO::ReferenceTriggerDoesNotMatchWithSampleMode = -10114 , JY5710CoreOO::PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint = -10115 , JY5710CoreOO::ReadDataFailed = -10016 ,
JY5710CoreOO::ReadDataTimeout = -10017 , JY5710CoreOO::WriteDataFailed = -10018 , JY5710CoreOO::WriteDataTimeout = -10019 , JY5710CoreOO::WriteDataLengthCannotBeLessThanN = -10020 ,
JY5710CoreOO::BufferDataOverflow = -10021 , JY5710CoreOO::BufferDataDownflow = -10022 , JY5710CoreOO::CheckBufferFailed = -10023 , JY5710CoreOO::PointInvalidInFiniteMode = -10024 ,
JY5710CoreOO::ReadPointInvalid = -10025 , JY5710CoreOO::OnlySupportRecordMode = -10026 , JY5710CoreOO::SendSoftTirggerFailed = -10027 , JY5710CoreOO::TaskTimeout = -10028 ,
JY5710CoreOO::CounterParametersInvalid = -10029 , JY5710CoreOO::WritePointInvalid = -10030 , JY5710CoreOO::SignalExportDestinationInvalid = -10031 , JY5710CoreOO::InvalidParameter = -10033
}
enum class JY5710CoreOO::ClockTerminal {
JY5710CoreOO::PFI0 = 1 , JY5710CoreOO::PFI1 = 2 , JY5710CoreOO::PFI2 = 3 , JY5710CoreOO::PXI_Trig0 = 8 ,
JY5710CoreOO::PXI_Trig1 = 9 , JY5710CoreOO::PXI_Trig2 = 10 , JY5710CoreOO::PXI_Trig3 = 11 , JY5710CoreOO::PXI_Trig4 = 12 ,
JY5710CoreOO::PXI_Trig5 = 13 , JY5710CoreOO::PXI_Trig6 = 14 , JY5710CoreOO::PXI_Trig7 = 15
}
enum class JY5710CoreOO::SignalExportDestination {
JY5710CoreOO::PFI0 = JY5710Import::JY5710_PFI0_OUT , JY5710CoreOO::PFI1 = JY5710Import::JY5710_PFI1_OUT , JY5710CoreOO::PFI2 = JY5710Import::JY5710_PFI2_OUT , JY5710CoreOO::PXI_Trig0 = JY5710Import::JY5710_PXITrig0_OUT ,
JY5710CoreOO::PXI_Trig1 = JY5710Import::JY5710_PXITrig1_OUT , JY5710CoreOO::PXI_Trig2 = JY5710Import::JY5710_PXITrig2_OUT , JY5710CoreOO::PXI_Trig3 = JY5710Import::JY5710_PXITrig3_OUT , JY5710CoreOO::PXI_Trig4 = JY5710Import::JY5710_PXITrig4_OUT ,
JY5710CoreOO::PXI_Trig5 = JY5710Import::JY5710_PXITrig5_OUT , JY5710CoreOO::PXI_Trig6 = JY5710Import::JY5710_PXITrig6_OUT , JY5710CoreOO::PXI_Trig7 = JY5710Import::JY5710_PXITrig7_OUT
}
enum class JY5710CoreOO::IOTerminal {
JY5710CoreOO::Default = 0 , JY5710CoreOO::PXI_Trig0 = 0x20 , JY5710CoreOO::PXI_Trig1 = 0x21 , JY5710CoreOO::PXI_Trig2 = 0x22 ,
JY5710CoreOO::PXI_Trig3 = 0x23 , JY5710CoreOO::PXI_Trig4 = 0x24 , JY5710CoreOO::PXI_Trig5 = 0x25 , JY5710CoreOO::PXI_Trig6 = 0x26 ,
JY5710CoreOO::PXI_Trig7 = 0x27
}
Cunter IO Terminal. More...
enum class | JY5710CoreOO::LevelPolarity { JY5710CoreOO::LowLevel = 0 , JY5710CoreOO::HighLevel = 1 , JY5710CoreOO::None = 2 }
Level Polarity. More...
enum class JY5710CoreOO::InputTerminal {
JY5710CoreOO::Default = 0 , JY5710CoreOO::PXI_Trig0 = 40 , JY5710CoreOO::PXI_Trig1 = 41 , JY5710CoreOO::PXI_Trig2 = 42 ,
JY5710CoreOO::PXI_Trig3 = 43 , JY5710CoreOO::PXI_Trig4 = 44 , JY5710CoreOO::PXI_Trig5 = 45 , JY5710CoreOO::PXI_Trig6 = 46 ,
JY5710CoreOO::PXI_Trig7 = 47 , JY5710CoreOO::CI_0_OutPut = 37 , JY5710CoreOO::CI_1_OutPut = 51 , JY5710CoreOO::CI_2_OutPut = 60 ,
JY5710CoreOO::CI_3_OutPut = 66
}
Cunter Input Terminal. More...

Functions

std::string JY5710CoreOO::GetSignalExportDestinationString (SignalExportDestination destination)

Variables

const int | JY5710Import::JY5710_AO_Finite = 0x00
const int | JY5710Import::JY5710_AO_ContinuousWrapping = 0x01
const int | JY5710Import::JY5710_AO_ContinuousNoWrapping = 0x02
const int | JY5710Import::JY5710_AO_Single = 0x03
const int | JY5710Import::JY5710_DI_Finite = 0x00
const int | JY5710Import::JY5710_DI_Continuous = 0x01
const int | JY5710Import::JY5710_DI_Single = 0x02
const int | JY5710Import::JY5710_DO_Finite = 0x00
const int | JY5710Import::JY5710_DO_ContinuousWrapping = 0x01
const int | JY5710Import::JY5710_DO_ContinuousNoWrapping = 0x02
const int | JY5710Import::JY5710_DO_Single = 0x03
const int | JY5710Import::JY5710_TriggerType_Immediately = 0x0
const int | JY5710Import::JY5710_TriggerType_Digital = 0x1
const int | JY5710Import::JY5710_TriggerType_Analog = 0x2
const int | JY5710Import::JY5710_TriggerType_Soft = 0x3
const int | JY5710Import::JY5710_DigitalTriggerEdge_Rising = 0x0
const int | JY5710Import::JY5710_DigitalTriggerEdge_Falling = 0x1
const int | JY5710Import::JY5710_DigitalTriggerSource_PFI_0 = 0x1
const int | JY5710Import::JY5710_DigitalTriggerSource_PFI_1 = 0x2
const int | JY5710Import::JY5710_DigitalTriggerSource_PFI_2 = 0x3
const int | JY5710Import::JY5710_DI_StartTrig = 22
const int | JY5710Import::JY5710_DI_ReferenceTrig = 23
const int | JY5710Import::JY5710_AO_StartTrig = 18
const int | JY5710Import::JY5710_DO_StartTrig = 29
const int | JY5710Import::JY5710_AO_SampleClock = 19
const int | JY5710Import::JY5710_PFI0_OUT = 0x1
const int | JY5710Import::JY5710_PFI1_OUT = 0x2
const int | JY5710Import::JY5710_PFI2_OUT = 0x3
const int | JY5710Import::JY5710_PXITrig0_OUT = 8
const int | JY5710Import::JY5710_PXITrig1_OUT = 9
const int | JY5710Import::JY5710_PXITrig2_OUT = 10
const int | JY5710Import::JY5710_PXITrig3_OUT = 11
const int | JY5710Import::JY5710_PXITrig4_OUT = 12
const int | JY5710Import::JY5710_PXITrig5_OUT = 13
const int | JY5710Import::JY5710_PXITrig6_OUT = 14
const int | JY5710Import::JY5710_PXITrig7_OUT = 15
const int | JY5710Import::JY5710_TimeBase_200M = 0x0
const int | JY5710Import::JY5710_TimeBase_5M = 0x1
const int | JY5710Import::JY5710_TimeBase_100K = 0x2
const int | JY5710Import::ReferenceOnboard_25M = 0x0
const int | JY5710Import::ReferencePXIeCLK_100M = 0x1

Macro Definition Documentation

◆ EXTERN_C

#define EXTERN_C extern

Windows.

Linux

◆ JY5710CoreOO_API

#define JY5710CoreOO_API


5710 C++ Programming Manual: JY5710CoreOO::JYDriverException Class Reference

  • JYDriverException
Public Member Functions | Public Attributes | List of all members
JY5710CoreOO::JYDriverException Class Reference

#include <JY5710CoreOOCommon.h>

Public Member Functions

JYDriverException (JYDriverExceptionPublic exceptionCode, std::string msg="")
JYDriverException (int, std::string msg)

Public Attributes

std::string exceptionMessage
JYDriverExceptionPublic errorCode
JYDriverException * FollowingException

Constructor & Destructor Documentation

◆ JYDriverException() [1/2]

JY5710CoreOO::JYDriverException::JYDriverException | ( | JYDriverExceptionPublic | exceptionCode,
 |  | std::string | msg = "" )

◆ JYDriverException() [2/2]

JY5710CoreOO::JYDriverException::JYDriverException | ( | int | ,
 |  | std::string | msg )

Member Data Documentation

◆ errorCode

JYDriverExceptionPublic JY5710CoreOO::JYDriverException::errorCode

◆ exceptionMessage

std::string JY5710CoreOO::JYDriverException::exceptionMessage

◆ FollowingException

JYDriverException* JY5710CoreOO::JYDriverException::FollowingException
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5710/JY5710CoreOOCommon.h


5710 C++ Programming Manual: JY5710CoreOO::JY5710CoreOOProperty< ContainerClass, ValueType, propertyType > Class Template Reference

  • JY5710CoreOOProperty
Public Member Functions | List of all members
JY5710CoreOO::JY5710CoreOOProperty< ContainerClass, ValueType, propertyType > Class Template Reference

属性模板类 More...

#include <JY5710CoreOOCommon.h>

Public Member Functions

JY5710CoreOOProperty ()
JY5710CoreOOProperty (ContainerClass *cObject, ValueType(ContainerClass::*pGet)(), void(ContainerClass::*pSet)(ValueType value))
JY5710CoreOOProperty (ValueType(*pGet)(), void(*pSet)(ValueType value))
ValueType operator= (const ValueType &value)
operator ValueType ()

Detailed Description

template<typename ContainerClass, typename ValueType, JY5710CoreOOPropertyType propertyType>
class JY5710CoreOO::JY5710CoreOOProperty< ContainerClass, ValueType, propertyType >

属性模板类

Constructor & Destructor Documentation

◆ JY5710CoreOOProperty() [1/3]

template<typename ContainerClass, typename ValueType, JY5710CoreOOPropertyType propertyType>
JY5710CoreOO::JY5710CoreOOProperty< ContainerClass, ValueType, propertyType >::JY5710CoreOOProperty ( )

◆ JY5710CoreOOProperty() [2/3]

template<typename ContainerClass, typename ValueType, JY5710CoreOOPropertyType propertyType>
JY5710CoreOO::JY5710CoreOOProperty< ContainerClass, ValueType, propertyType >::JY5710CoreOOProperty | ( | ContainerClass * | cObject,
 |  | ValueType(ContainerClass::* | pGet )(),
 |  | void(ContainerClass::* | pSet )(ValueType value) )

◆ JY5710CoreOOProperty() [3/3]

template<typename ContainerClass, typename ValueType, JY5710CoreOOPropertyType propertyType>
JY5710CoreOO::JY5710CoreOOProperty< ContainerClass, ValueType, propertyType >::JY5710CoreOOProperty | ( | ValueType(* | pGet )(),
 |  | void(* | pSet )(ValueType value) )

Member Function Documentation

◆ operator ValueType()

template<typename ContainerClass, typename ValueType, JY5710CoreOOPropertyType propertyType>
JY5710CoreOO::JY5710CoreOOProperty< ContainerClass, ValueType, propertyType >::operator ValueType ( )

◆ operator=()

template<typename ContainerClass, typename ValueType, JY5710CoreOOPropertyType propertyType>
ValueType JY5710CoreOO::JY5710CoreOOProperty< ContainerClass, ValueType, propertyType >::operator= ( const ValueType & value )
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5710/JY5710CoreOOCommon.h


5710 C++ Programming Manual: JY5710CoreOO::PauseTrigger Class Reference

  • PauseTrigger
Public Attributes | List of all members
JY5710CoreOO::PauseTrigger Class Reference

Pause trigger configuration class. More...

#include <JY5710CoreOOCommon.h>

Public Attributes

LevelPolarity ActivePolarity
Pause trigger active polarity.
InputTerminal Terminal
Terminal.

Detailed Description

Pause trigger configuration class.

Member Data Documentation

◆ ActivePolarity

LevelPolarity JY5710CoreOO::PauseTrigger::ActivePolarity

Pause trigger active polarity.

The default value is LevelPolarity.None, means the pause trigger is disabled.

◆ Terminal

InputTerminal JY5710CoreOO::PauseTrigger::Terminal

Terminal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5710/JY5710CoreOOCommon.h


5710 C++ Programming Manual: JY5710Import Namespace Reference

  • Namespace List
  • Namespace Members
Variables
JY5710Import Namespace Reference

Variables

const int | JY5710_AO_Finite = 0x00
const int | JY5710_AO_ContinuousWrapping = 0x01
const int | JY5710_AO_ContinuousNoWrapping = 0x02
const int | JY5710_AO_Single = 0x03
const int | JY5710_DI_Finite = 0x00
const int | JY5710_DI_Continuous = 0x01
const int | JY5710_DI_Single = 0x02
const int | JY5710_DO_Finite = 0x00
const int | JY5710_DO_ContinuousWrapping = 0x01
const int | JY5710_DO_ContinuousNoWrapping = 0x02
const int | JY5710_DO_Single = 0x03
const int | JY5710_TriggerType_Immediately = 0x0
const int | JY5710_TriggerType_Digital = 0x1
const int | JY5710_TriggerType_Analog = 0x2
const int | JY5710_TriggerType_Soft = 0x3
const int | JY5710_DigitalTriggerEdge_Rising = 0x0
const int | JY5710_DigitalTriggerEdge_Falling = 0x1
const int | JY5710_DigitalTriggerSource_PFI_0 = 0x1
const int | JY5710_DigitalTriggerSource_PFI_1 = 0x2
const int | JY5710_DigitalTriggerSource_PFI_2 = 0x3
const int | JY5710_DI_StartTrig = 22
const int | JY5710_DI_ReferenceTrig = 23
const int | JY5710_AO_StartTrig = 18
const int | JY5710_DO_StartTrig = 29
const int | JY5710_AO_SampleClock = 19
const int | JY5710_PFI0_OUT = 0x1
const int | JY5710_PFI1_OUT = 0x2
const int | JY5710_PFI2_OUT = 0x3
const int | JY5710_PXITrig0_OUT = 8
const int | JY5710_PXITrig1_OUT = 9
const int | JY5710_PXITrig2_OUT = 10
const int | JY5710_PXITrig3_OUT = 11
const int | JY5710_PXITrig4_OUT = 12
const int | JY5710_PXITrig5_OUT = 13
const int | JY5710_PXITrig6_OUT = 14
const int | JY5710_PXITrig7_OUT = 15
const int | JY5710_TimeBase_200M = 0x0
const int | JY5710_TimeBase_5M = 0x1
const int | JY5710_TimeBase_100K = 0x2
const int | ReferenceOnboard_25M = 0x0
const int | ReferencePXIeCLK_100M = 0x1

Variable Documentation

◆ JY5710_AO_ContinuousNoWrapping

const int JY5710Import::JY5710_AO_ContinuousNoWrapping = 0x02

◆ JY5710_AO_ContinuousWrapping

const int JY5710Import::JY5710_AO_ContinuousWrapping = 0x01

◆ JY5710_AO_Finite

const int JY5710Import::JY5710_AO_Finite = 0x00

◆ JY5710_AO_SampleClock

const int JY5710Import::JY5710_AO_SampleClock = 19

◆ JY5710_AO_Single

const int JY5710Import::JY5710_AO_Single = 0x03

◆ JY5710_AO_StartTrig

const int JY5710Import::JY5710_AO_StartTrig = 18

◆ JY5710_DI_Continuous

const int JY5710Import::JY5710_DI_Continuous = 0x01

◆ JY5710_DI_Finite

const int JY5710Import::JY5710_DI_Finite = 0x00

◆ JY5710_DI_ReferenceTrig

const int JY5710Import::JY5710_DI_ReferenceTrig = 23

◆ JY5710_DI_Single

const int JY5710Import::JY5710_DI_Single = 0x02

◆ JY5710_DI_StartTrig

const int JY5710Import::JY5710_DI_StartTrig = 22

◆ JY5710_DigitalTriggerEdge_Falling

const int JY5710Import::JY5710_DigitalTriggerEdge_Falling = 0x1

◆ JY5710_DigitalTriggerEdge_Rising

const int JY5710Import::JY5710_DigitalTriggerEdge_Rising = 0x0

◆ JY5710_DigitalTriggerSource_PFI_0

const int JY5710Import::JY5710_DigitalTriggerSource_PFI_0 = 0x1

◆ JY5710_DigitalTriggerSource_PFI_1

const int JY5710Import::JY5710_DigitalTriggerSource_PFI_1 = 0x2

◆ JY5710_DigitalTriggerSource_PFI_2

const int JY5710Import::JY5710_DigitalTriggerSource_PFI_2 = 0x3

◆ JY5710_DO_ContinuousNoWrapping

const int JY5710Import::JY5710_DO_ContinuousNoWrapping = 0x02

◆ JY5710_DO_ContinuousWrapping

const int JY5710Import::JY5710_DO_ContinuousWrapping = 0x01

◆ JY5710_DO_Finite

const int JY5710Import::JY5710_DO_Finite = 0x00

◆ JY5710_DO_Single

const int JY5710Import::JY5710_DO_Single = 0x03

◆ JY5710_DO_StartTrig

const int JY5710Import::JY5710_DO_StartTrig = 29

◆ JY5710_PFI0_OUT

const int JY5710Import::JY5710_PFI0_OUT = 0x1

◆ JY5710_PFI1_OUT

const int JY5710Import::JY5710_PFI1_OUT = 0x2

◆ JY5710_PFI2_OUT

const int JY5710Import::JY5710_PFI2_OUT = 0x3

◆ JY5710_PXITrig0_OUT

const int JY5710Import::JY5710_PXITrig0_OUT = 8

◆ JY5710_PXITrig1_OUT

const int JY5710Import::JY5710_PXITrig1_OUT = 9

◆ JY5710_PXITrig2_OUT

const int JY5710Import::JY5710_PXITrig2_OUT = 10

◆ JY5710_PXITrig3_OUT

const int JY5710Import::JY5710_PXITrig3_OUT = 11

◆ JY5710_PXITrig4_OUT

const int JY5710Import::JY5710_PXITrig4_OUT = 12

◆ JY5710_PXITrig5_OUT

const int JY5710Import::JY5710_PXITrig5_OUT = 13

◆ JY5710_PXITrig6_OUT

const int JY5710Import::JY5710_PXITrig6_OUT = 14

◆ JY5710_PXITrig7_OUT

const int JY5710Import::JY5710_PXITrig7_OUT = 15

◆ JY5710_TimeBase_100K

const int JY5710Import::JY5710_TimeBase_100K = 0x2

◆ JY5710_TimeBase_200M

const int JY5710Import::JY5710_TimeBase_200M = 0x0

◆ JY5710_TimeBase_5M

const int JY5710Import::JY5710_TimeBase_5M = 0x1

◆ JY5710_TriggerType_Analog

const int JY5710Import::JY5710_TriggerType_Analog = 0x2

◆ JY5710_TriggerType_Digital

const int JY5710Import::JY5710_TriggerType_Digital = 0x1

◆ JY5710_TriggerType_Immediately

const int JY5710Import::JY5710_TriggerType_Immediately = 0x0

◆ JY5710_TriggerType_Soft

const int JY5710Import::JY5710_TriggerType_Soft = 0x3

◆ ReferenceOnboard_25M

const int JY5710Import::ReferenceOnboard_25M = 0x0

◆ ReferencePXIeCLK_100M

const int JY5710Import::ReferencePXIeCLK_100M = 0x1


5710 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5710/JY5710CoreOODevice.h File Reference

  • File List
  • File Members
  • COO
  • 5710
Classes | Namespaces | Enumerations
JY5710CoreOODevice.h File Reference
#include <iostream>
#include <string>
#include <list>
#include <vector>
#include "JY5710CoreOOCommon.h"

Classes

class | JY5710CoreOO::JY5710CoreOODevice
class | JY5710CoreOO::ExternalReferenceClock
class | JY5710CoreOO::JY5710CoreOOReferenceClock

Namespaces

namespace JY5710CoreOO

Enumerations

enum class | JY5710CoreOO::ExternalReferenceClockTerminal { JY5710CoreOO::PXIe_Clk100 = JY5710Import::ReferencePXIeCLK_100M }
enum class | JY5710CoreOO::ReferenceClockSource { JY5710CoreOO::Internal = JY5710Import::ReferenceOnboard_25M , JY5710CoreOO::External = JY5710Import::ReferencePXIeCLK_100M }


5710 C++ Programming Manual: JY5710CoreOO::JY5710CoreOODevice Class Reference

  • JY5710CoreOODevice
Static Public Member Functions | Public Attributes | List of all members
JY5710CoreOO::JY5710CoreOODevice Class Reference

#include <JY5710CoreOODevice.h>

Static Public Member Functions

static JY5710CoreOODevice * | GetInstance (int cardNum)
static JY5710CoreOODevice * | GetInstance (std::string aliasName)

Public Attributes

const double | BoardClockRate = 200e6
const double | MaxSampleRateMutilChannel = 1000000
const int | AIBufferSize = 0x100000 * 64
const bool | IsAISync = false
const double | MaxUpdateRateSingletoEightChannel = 2000000
AOMaxUpdateRateSingletoEightChannel.
const double | MaxUpdateRateThirtyTowChannel = 1000000
AOMaxUpdateRateThreeChannel.
const bool | IsAOSync = true
IsAOSync.
const int | AOChannelCount = 32
JY5710CoreOOProperty< JY5710CoreOODevice, int, JY5710CoreOOPropertyType::READ_ONLY > | DiffChannelCount
JY5710CoreOOProperty< JY5710CoreOODevice, int, JY5710CoreOOPropertyType::READ_ONLY > | SEChannelCount
JY5710CoreOOProperty< JY5710CoreOODevice, double, JY5710CoreOOPropertyType::READ_ONLY > | MaxSampleRateSingleChannel
JY5710CoreOOProperty< JY5710CoreOODevice, std::string, JY5710CoreOOPropertyType::READ_ONLY > | SerialNumber
JY5710CoreOOProperty< JY5710CoreOODevice, int, JY5710CoreOOPropertyType::READ_ONLY > | DeviceID
JY5710CoreOOProperty< JY5710CoreOODevice, void *, JY5710CoreOOPropertyType::READ_ONLY > | Handle
JY5710CoreOOReferenceClock * ReferenceClock

Member Function Documentation

◆ GetInstance() [1/2]

static JY5710CoreOODevice * JY5710CoreOO::JY5710CoreOODevice::GetInstance ( int cardNum )
static

◆ GetInstance() [2/2]

static JY5710CoreOODevice * JY5710CoreOO::JY5710CoreOODevice::GetInstance ( std::string aliasName )
static

Member Data Documentation

◆ AIBufferSize

const int JY5710CoreOO::JY5710CoreOODevice::AIBufferSize = 0x100000 * 64

◆ AOChannelCount

const int JY5710CoreOO::JY5710CoreOODevice::AOChannelCount = 32

◆ BoardClockRate

const double JY5710CoreOO::JY5710CoreOODevice::BoardClockRate = 200e6

◆ DeviceID

JY5710CoreOOProperty<JY5710CoreOODevice, int, JY5710CoreOOPropertyType::READ_ONLY> JY5710CoreOO::JY5710CoreOODevice::DeviceID

◆ DiffChannelCount

JY5710CoreOOProperty<JY5710CoreOODevice, int, JY5710CoreOOPropertyType::READ_ONLY> JY5710CoreOO::JY5710CoreOODevice::DiffChannelCount

◆ Handle

JY5710CoreOOProperty<JY5710CoreOODevice, void*, JY5710CoreOOPropertyType::READ_ONLY> JY5710CoreOO::JY5710CoreOODevice::Handle

◆ IsAISync

const bool JY5710CoreOO::JY5710CoreOODevice::IsAISync = false

◆ IsAOSync

const bool JY5710CoreOO::JY5710CoreOODevice::IsAOSync = true

IsAOSync.

◆ MaxSampleRateMutilChannel

const double JY5710CoreOO::JY5710CoreOODevice::MaxSampleRateMutilChannel = 1000000

◆ MaxSampleRateSingleChannel

JY5710CoreOOProperty<JY5710CoreOODevice, double, JY5710CoreOOPropertyType::READ_ONLY> JY5710CoreOO::JY5710CoreOODevice::MaxSampleRateSingleChannel

◆ MaxUpdateRateSingletoEightChannel

const double JY5710CoreOO::JY5710CoreOODevice::MaxUpdateRateSingletoEightChannel = 2000000

AOMaxUpdateRateSingletoEightChannel.

◆ MaxUpdateRateThirtyTowChannel

const double JY5710CoreOO::JY5710CoreOODevice::MaxUpdateRateThirtyTowChannel = 1000000

AOMaxUpdateRateThreeChannel.

◆ ReferenceClock

JY5710CoreOOReferenceClock* JY5710CoreOO::JY5710CoreOODevice::ReferenceClock

◆ SEChannelCount

JY5710CoreOOProperty<JY5710CoreOODevice, int, JY5710CoreOOPropertyType::READ_ONLY> JY5710CoreOO::JY5710CoreOODevice::SEChannelCount

◆ SerialNumber

JY5710CoreOOProperty<JY5710CoreOODevice, std::string, JY5710CoreOOPropertyType::READ_ONLY> JY5710CoreOO::JY5710CoreOODevice::SerialNumber
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5710/JY5710CoreOODevice.h


5710 C++ Programming Manual: JY5710CoreOO::ExternalReferenceClock Class Reference

  • ExternalReferenceClock
Public Attributes | List of all members
JY5710CoreOO::ExternalReferenceClock Class Reference

#include <JY5710CoreOODevice.h>

Public Attributes

ExternalReferenceClockTerminal Terminal

Member Data Documentation

◆ Terminal

ExternalReferenceClockTerminal JY5710CoreOO::ExternalReferenceClock::Terminal
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5710/JY5710CoreOODevice.h


5710 C++ Programming Manual: JY5710CoreOO::JY5710CoreOOReferenceClock Class Reference

  • JY5710CoreOOReferenceClock
Public Member Functions | Public Attributes | List of all members
JY5710CoreOO::JY5710CoreOOReferenceClock Class Reference

#include <JY5710CoreOODevice.h>

Public Member Functions

void Commit ()
Commit configuration.

Public Attributes

ReferenceClockSource Source
ExternalReferenceClock * External
External Reference Clock Source.

Member Function Documentation

◆ Commit()

void JY5710CoreOO::JY5710CoreOOReferenceClock::Commit ( )

Commit configuration.

Available only when the device is idle. WARNING: Incorrect parameters will cause the PLL to be unable to lock the reference clock and cannot be recovered until shutdown and restart.

Member Data Documentation

◆ External

ExternalReferenceClock* JY5710CoreOO::JY5710CoreOOReferenceClock::External

External Reference Clock Source.

Required when ReferenceClock.Source is ReferenceClockSource.External

◆ Source

ReferenceClockSource JY5710CoreOO::JY5710CoreOOReferenceClock::Source
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5710/JY5710CoreOODevice.h


5710 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5710/JY5710CoreOODITask.h File Reference

  • File List
  • File Members
  • COO
  • 5710
Classes | Namespaces
JY5710CoreOODITask.h File Reference
#include <map>
#include <mutex>
#include "JY5710CoreOOCommon.h"
#include "JY5710CoreOODevice.h"

Classes

class | JY5710CoreOO::JY5710CoreOODITask
DITask类 More...
class | JY5710CoreOO::DIChannel
DI Channel parameter class . More...

Namespaces

namespace JY5710CoreOO


5710 C++ Programming Manual: JY5710CoreOO::JY5710CoreOODITask Class Reference

  • JY5710CoreOODITask
Public Member Functions | Public Attributes | List of all members
JY5710CoreOO::JY5710CoreOODITask Class Reference

DITask类 More...

#include <JY5710CoreOODITask.h>

Public Member Functions

JY5710CoreOODITask (int slotNum)
JY5710CoreOODITask (std::string boardName)
~JY5710CoreOODITask ()
void | AddChannel (int lineNum)
Add one channel.
void | AddChannel (std::vector< int > lineNum)
Add a group of channel.
void | RemoveChannel (int lineNum)
Delete the specified port number .If it is -1, delete all ports.
void | Start ()
Start DI task .
void | Stop ()
Stop DI task .
void | ReadSinglePoint (std::vector< bool > &readValues, int lineNum)
Read one sample for specified channel in register.

Public Attributes

std::list< DIChannel * > Channels
List of DI channels,(5710 support 3 ports)
JY5710CoreOODevice * Device
Device.

Detailed Description

DITask类

Constructor & Destructor Documentation

◆ JY5710CoreOODITask() [1/2]

JY5710CoreOO::JY5710CoreOODITask::JY5710CoreOODITask ( int slotNum )

◆ JY5710CoreOODITask() [2/2]

JY5710CoreOO::JY5710CoreOODITask::JY5710CoreOODITask ( std::string boardName )

◆ ~JY5710CoreOODITask()

JY5710CoreOO::JY5710CoreOODITask::~JY5710CoreOODITask ( )

Member Function Documentation

◆ AddChannel() [1/2]

void JY5710CoreOO::JY5710CoreOODITask::AddChannel ( int lineNum )

Add one channel.

Parameters
portNum port number to be added.

◆ AddChannel() [2/2]

void JY5710CoreOO::JY5710CoreOODITask::AddChannel ( std::vector< int > lineNum )

Add a group of channel.

Parameters
portsNum an array of port numbers of added ports.

◆ ReadSinglePoint()

void JY5710CoreOO::JY5710CoreOODITask::ReadSinglePoint | ( | std::vector< bool > & | readValues,
 |  | int | lineNum )

Read one sample for specified channel in register.

. Available when Mode is DIMode.Single

Parameters
readValues | vector<bool>
port | Specified port numbers or -1.when port is -1,Each port reads the latest point

◆ RemoveChannel()

void JY5710CoreOO::JY5710CoreOODITask::RemoveChannel ( int lineNum )

Delete the specified port number .If it is -1, delete all ports.

Parameters
portNum port number to be delete.

◆ Start()

void JY5710CoreOO::JY5710CoreOODITask::Start ( )

Start DI task .

◆ Stop()

void JY5710CoreOO::JY5710CoreOODITask::Stop ( )

Stop DI task .

Member Data Documentation

◆ Channels

std::list<DIChannel*> JY5710CoreOO::JY5710CoreOODITask::Channels

List of DI channels,(5710 support 3 ports)

◆ Device

JY5710CoreOODevice* JY5710CoreOO::JY5710CoreOODITask::Device

Device.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5710/JY5710CoreOODITask.h


5710 C++ Programming Manual: JY5710CoreOO::DIChannel Class Reference

  • DIChannel
Public Attributes | List of all members
JY5710CoreOO::DIChannel Class Reference

DI Channel parameter class . More...

#include <JY5710CoreOODITask.h>

Public Attributes

int LineNum
line number.

Detailed Description

DI Channel parameter class .

Member Data Documentation

◆ LineNum

int JY5710CoreOO::DIChannel::LineNum

line number.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5710/JY5710CoreOODITask.h


5710 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5710/JY5710CoreOODOTask.h File Reference

  • File List
  • File Members
  • COO
  • 5710
Classes | Namespaces
JY5710CoreOODOTask.h File Reference
#include <map>
#include <mutex>
#include "JY5710CoreOOCommon.h"
#include "JY5710CoreOODevice.h"

Classes

class | JY5710CoreOO::JY5710CoreOODOTask
DOTask类 More...
class | JY5710CoreOO::DOChannel
DO Channel parameter class . More...

Namespaces

namespace JY5710CoreOO


5710 C++ Programming Manual: JY5710CoreOO::JY5710CoreOODOTask Class Reference

  • JY5710CoreOODOTask
Public Member Functions | Public Attributes | List of all members
JY5710CoreOO::JY5710CoreOODOTask Class Reference

DOTask类 More...

#include <JY5710CoreOODOTask.h>

Public Member Functions

JY5710CoreOODOTask (int slotNum)
JY5710CoreOODOTask (std::string boardName)
~JY5710CoreOODOTask ()
void | AddChannel (int portNum)
Add one channel.
void | AddChannel (std::vector< int > portsNum)
Add a group of channel.
void | RemoveChannel (int portNum)
Delete the specified port number .If it is -1, delete all ports.
void | Start ()
Start DO task .
void | Stop ()
Stop DO task .
void | WriteSinglePoint (bool writeValues, int port)
Write one sample to the specified port in register.Available when Mode is DOMode.Single
void | WriteSinglePoint (std::vector< bool > &writeValues)
Read one sample for all ports in register .

Public Attributes

std::list< DOChannel * > Channels
List of DO channels,(5710 support 3 ports)
JY5710CoreOODevice * Device
Device.

Detailed Description

DOTask类

Constructor & Destructor Documentation

◆ JY5710CoreOODOTask() [1/2]

JY5710CoreOO::JY5710CoreOODOTask::JY5710CoreOODOTask ( int slotNum )

◆ JY5710CoreOODOTask() [2/2]

JY5710CoreOO::JY5710CoreOODOTask::JY5710CoreOODOTask ( std::string boardName )

◆ ~JY5710CoreOODOTask()

JY5710CoreOO::JY5710CoreOODOTask::~JY5710CoreOODOTask ( )

Member Function Documentation

◆ AddChannel() [1/2]

void JY5710CoreOO::JY5710CoreOODOTask::AddChannel ( int portNum )

Add one channel.

Parameters
portNum port number to be added.

◆ AddChannel() [2/2]

void JY5710CoreOO::JY5710CoreOODOTask::AddChannel ( std::vector< int > portsNum )

Add a group of channel.

Parameters
portsNum an array of port numbers of added ports.

◆ RemoveChannel()

void JY5710CoreOO::JY5710CoreOODOTask::RemoveChannel ( int portNum )

Delete the specified port number .If it is -1, delete all ports.

Parameters
portNum port number to be delete.

◆ Start()

void JY5710CoreOO::JY5710CoreOODOTask::Start ( )

Start DO task .

◆ Stop()

void JY5710CoreOO::JY5710CoreOODOTask::Stop ( )

Stop DO task .

◆ WriteSinglePoint() [1/2]

void JY5710CoreOO::JY5710CoreOODOTask::WriteSinglePoint | ( | bool | writeValues,
 |  | int | port )

Write one sample to the specified port in register.Available when Mode is DOMode.Single

Parameters
readValues | values write Buffer
port | Specified port numbers.

◆ WriteSinglePoint() [2/2]

void JY5710CoreOO::JY5710CoreOODOTask::WriteSinglePoint ( std::vector< bool > & writeValues )

Read one sample for all ports in register .

Available when Mode is DIMode.Single

Parameters
readValues Values write Buffer size == number of ports.

Member Data Documentation

◆ Channels

std::list<DOChannel*> JY5710CoreOO::JY5710CoreOODOTask::Channels

List of DO channels,(5710 support 3 ports)

◆ Device

JY5710CoreOODevice* JY5710CoreOO::JY5710CoreOODOTask::Device

Device.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5710/JY5710CoreOODOTask.h


5710 C++ Programming Manual: JY5710CoreOO::DOChannel Class Reference

  • DOChannel
Public Attributes | List of all members
JY5710CoreOO::DOChannel Class Reference

DO Channel parameter class . More...

#include <JY5710CoreOODOTask.h>

Public Attributes

int LineNum
port number.

Detailed Description

DO Channel parameter class .

Member Data Documentation

◆ LineNum

int JY5710CoreOO::DOChannel::LineNum

port number.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5710/JY5710CoreOODOTask.h


5710 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/5710/JY5710CoreOOLog.h File Reference

  • File List
  • File Members
  • COO
  • 5710
Classes | Namespaces | Enumerations
JY5710CoreOOLog.h File Reference
#include <queue>
#include <thread>
#include "JY5710CoreOOCommon.h"

Classes

class JY5710CoreOO::JY5710CoreOOLog

Namespaces

namespace JY5710CoreOO

Enumerations

enum class JY5710CoreOO::JY5710CoreOOLogLevel {
JY5710CoreOO::DEBUG_LOG_LEVEL , JY5710CoreOO::INFO_LOG_LEVEL , JY5710CoreOO::WARN_LOG_LEVEL , JY5710CoreOO::ERROR_LOG_LEVEL ,
JY5710CoreOO::FATAL_LOG_LEVEL
}


5710 C++ Programming Manual: JY5710CoreOO::JY5710CoreOOLog Class Reference

  • JY5710CoreOOLog
Static Public Member Functions | Static Public Attributes | List of all members
JY5710CoreOO::JY5710CoreOOLog Class Reference

#include <JY5710CoreOOLog.h>

Static Public Member Functions

static void | Print (const char *format,...)
static void | Print (JY5710CoreOOLogLevel logLevel, const char *format,...)
static void | Flush ()

Static Public Attributes

static JY5710CoreOOLogLevel | LogLevel
static JY5710CoreOOProperty< JY5710CoreOOLog, bool, JY5710CoreOOPropertyType::READ_WRITE > | EnableLog

Member Function Documentation

◆ Flush()

static void JY5710CoreOO::JY5710CoreOOLog::Flush ( )
static

◆ Print() [1/2]

static void JY5710CoreOO::JY5710CoreOOLog::Print | ( | const char * | format,
 |  |  | ... )
 static

◆ Print() [2/2]

static void JY5710CoreOO::JY5710CoreOOLog::Print | ( | JY5710CoreOOLogLevel | logLevel,
 |  | const char * | format,
 |  |  | ... )
 static

Member Data Documentation

◆ EnableLog

JY5710CoreOOProperty<JY5710CoreOOLog, bool, JY5710CoreOOPropertyType::READ_WRITE> JY5710CoreOO::JY5710CoreOOLog::EnableLog
static

◆ LogLevel

JY5710CoreOOLogLevel JY5710CoreOO::JY5710CoreOOLog::LogLevel
static
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/5710/JY5710CoreOOLog.h


5710 C++ Programming Manual: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
▼N JY5710CoreOO |
C AOChannel |
C AODigitalTrigger | AO Digital trigger
C AOExternalSampleClock | External Sample Clock Configuration Class
C AOSampleClock | AO Sample clock configuration class
C AOSignalExport | AO Signal Export Class
C AOTrigger | Constructor to create an AOTrigger task object
C DIChannel | DI Channel parameter class
C DOChannel | DO Channel parameter class
C ExternalReferenceClock |
C JY5710CoreOOAOTask | AOTask类
C JY5710CoreOODevice |
C JY5710CoreOODITask | DITask类
C JY5710CoreOODOTask | DOTask类
C JY5710CoreOOLog |
C JY5710CoreOOProperty | 属性模板类
C JY5710CoreOOReferenceClock |
C JYDriverException |
C PauseTrigger | Pause trigger configuration class


5710 C++ Programming Manual: Member List

  • AOChannel
JY5710CoreOO::AOChannel Member List

This is the complete list of members for JY5710CoreOO::AOChannel, including all inherited members.

AOChannel(int channelId) | JY5710CoreOO::AOChannel | inline
ChannelID | JY5710CoreOO::AOChannel |


5710 C++ Programming Manual: Member List

  • AODigitalTrigger
JY5710CoreOO::AODigitalTrigger Member List

This is the complete list of members for JY5710CoreOO::AODigitalTrigger, including all inherited members.

Edge | JY5710CoreOO::AODigitalTrigger
Source | JY5710CoreOO::AODigitalTrigger


5710 C++ Programming Manual: Member List

  • AOExternalSampleClock
JY5710CoreOO::AOExternalSampleClock Member List

This is the complete list of members for JY5710CoreOO::AOExternalSampleClock, including all inherited members.

ExpectedRate | JY5710CoreOO::AOExternalSampleClock
Terminal | JY5710CoreOO::AOExternalSampleClock


5710 C++ Programming Manual: Member List

  • AOSampleClock
JY5710CoreOO::AOSampleClock Member List

This is the complete list of members for JY5710CoreOO::AOSampleClock, including all inherited members.

External | JY5710CoreOO::AOSampleClock
Source | JY5710CoreOO::AOSampleClock


5710 C++ Programming Manual: Member List

  • AOSignalExport
JY5710CoreOO::AOSignalExport Member List

This is the complete list of members for JY5710CoreOO::AOSignalExport, including all inherited members.

Add(AOSignalExportSource source, SignalExportDestination destination) | JY5710CoreOO::AOSignalExport
Add(AOSignalExportSource source, std::list< SignalExportDestination > destinations) | JY5710CoreOO::AOSignalExport
Clear(SignalExportDestination destination) | JY5710CoreOO::AOSignalExport
ClearAll() | JY5710CoreOO::AOSignalExport


5710 C++ Programming Manual: Member List

  • AOTrigger
JY5710CoreOO::AOTrigger Member List

This is the complete list of members for JY5710CoreOO::AOTrigger, including all inherited members.

Digital | JY5710CoreOO::AOTrigger
Type | JY5710CoreOO::AOTrigger


5710 C++ Programming Manual: Member List

  • DIChannel
JY5710CoreOO::DIChannel Member List

This is the complete list of members for JY5710CoreOO::DIChannel, including all inherited members.

LineNum JY5710CoreOO::DIChannel


5710 C++ Programming Manual: Member List

  • DOChannel
JY5710CoreOO::DOChannel Member List

This is the complete list of members for JY5710CoreOO::DOChannel, including all inherited members.

LineNum JY5710CoreOO::DOChannel


5710 C++ Programming Manual: Member List

  • ExternalReferenceClock
JY5710CoreOO::ExternalReferenceClock Member List

This is the complete list of members for JY5710CoreOO::ExternalReferenceClock, including all inherited members.

Terminal JY5710CoreOO::ExternalReferenceClock


5710 C++ Programming Manual: Member List

  • JY5710CoreOOAOTask
JY5710CoreOO::JY5710CoreOOAOTask Member List

This is the complete list of members for JY5710CoreOO::JY5710CoreOOAOTask, including all inherited members.

AddChannel(int chnId) | JY5710CoreOO::JY5710CoreOOAOTask
AddChannel(std::vector< int > chnsId) | JY5710CoreOO::JY5710CoreOOAOTask
AvaliableLenInSamples | JY5710CoreOO::JY5710CoreOOAOTask
BufLenInSamples | JY5710CoreOO::JY5710CoreOOAOTask
Channels | JY5710CoreOO::JY5710CoreOOAOTask
CompleteState | JY5710CoreOO::JY5710CoreOOAOTask
Device | JY5710CoreOO::JY5710CoreOOAOTask
JY5710CoreOOAOTask(int slotNum) | JY5710CoreOO::JY5710CoreOOAOTask
JY5710CoreOOAOTask(std::string boardName) | JY5710CoreOO::JY5710CoreOOAOTask
Mode | JY5710CoreOO::JY5710CoreOOAOTask
RemoveChannel(int chnId) | JY5710CoreOO::JY5710CoreOOAOTask
SampleClock | JY5710CoreOO::JY5710CoreOOAOTask
SamplesToUpdate | JY5710CoreOO::JY5710CoreOOAOTask
SendSoftwareTrigger() | JY5710CoreOO::JY5710CoreOOAOTask
SignalExport | JY5710CoreOO::JY5710CoreOOAOTask
Start() | JY5710CoreOO::JY5710CoreOOAOTask
Stop() | JY5710CoreOO::JY5710CoreOOAOTask
TransferedSamples | JY5710CoreOO::JY5710CoreOOAOTask
Trigger | JY5710CoreOO::JY5710CoreOOAOTask
UpdateRate | JY5710CoreOO::JY5710CoreOOAOTask
WaitUntilDone(int timeout=-1) | JY5710CoreOO::JY5710CoreOOAOTask
WriteData(double *pBuf, int samplesPerChannel, int timeout=10000) | JY5710CoreOO::JY5710CoreOOAOTask
WriteRawData(int16_t *pBuf, int samplesPerChannel, int timeout=10000) | JY5710CoreOO::JY5710CoreOOAOTask
WriteRawSinglePoint(std::vector< int16_t > writeValues) | JY5710CoreOO::JY5710CoreOOAOTask
WriteRawSinglePoint(int16_t writeValue, int channel) | JY5710CoreOO::JY5710CoreOOAOTask
WriteSinglePoint(std::vector< double > writeValues) | JY5710CoreOO::JY5710CoreOOAOTask
WriteSinglePoint(double writeValue, int channel) | JY5710CoreOO::JY5710CoreOOAOTask
~JY5710CoreOOAOTask() | JY5710CoreOO::JY5710CoreOOAOTask


5710 C++ Programming Manual: Member List

  • JY5710CoreOODITask
JY5710CoreOO::JY5710CoreOODITask Member List

This is the complete list of members for JY5710CoreOO::JY5710CoreOODITask, including all inherited members.

AddChannel(int lineNum) | JY5710CoreOO::JY5710CoreOODITask
AddChannel(std::vector< int > lineNum) | JY5710CoreOO::JY5710CoreOODITask
Channels | JY5710CoreOO::JY5710CoreOODITask
Device | JY5710CoreOO::JY5710CoreOODITask
JY5710CoreOODITask(int slotNum) | JY5710CoreOO::JY5710CoreOODITask
JY5710CoreOODITask(std::string boardName) | JY5710CoreOO::JY5710CoreOODITask
ReadSinglePoint(std::vector< bool > &readValues, int lineNum) | JY5710CoreOO::JY5710CoreOODITask
RemoveChannel(int lineNum) | JY5710CoreOO::JY5710CoreOODITask
Start() | JY5710CoreOO::JY5710CoreOODITask
Stop() | JY5710CoreOO::JY5710CoreOODITask
~JY5710CoreOODITask() | JY5710CoreOO::JY5710CoreOODITask


5710 C++ Programming Manual: Member List

  • JY5710CoreOODOTask
JY5710CoreOO::JY5710CoreOODOTask Member List

This is the complete list of members for JY5710CoreOO::JY5710CoreOODOTask, including all inherited members.

AddChannel(int portNum) | JY5710CoreOO::JY5710CoreOODOTask
AddChannel(std::vector< int > portsNum) | JY5710CoreOO::JY5710CoreOODOTask
Channels | JY5710CoreOO::JY5710CoreOODOTask
Device | JY5710CoreOO::JY5710CoreOODOTask
JY5710CoreOODOTask(int slotNum) | JY5710CoreOO::JY5710CoreOODOTask
JY5710CoreOODOTask(std::string boardName) | JY5710CoreOO::JY5710CoreOODOTask
RemoveChannel(int portNum) | JY5710CoreOO::JY5710CoreOODOTask
Start() | JY5710CoreOO::JY5710CoreOODOTask
Stop() | JY5710CoreOO::JY5710CoreOODOTask
WriteSinglePoint(bool writeValues, int port) | JY5710CoreOO::JY5710CoreOODOTask
WriteSinglePoint(std::vector< bool > &writeValues) | JY5710CoreOO::JY5710CoreOODOTask
~JY5710CoreOODOTask() | JY5710CoreOO::JY5710CoreOODOTask


5710 C++ Programming Manual: Member List

  • JY5710CoreOODevice
JY5710CoreOO::JY5710CoreOODevice Member List

This is the complete list of members for JY5710CoreOO::JY5710CoreOODevice, including all inherited members.

AIBufferSize | JY5710CoreOO::JY5710CoreOODevice |
AOChannelCount | JY5710CoreOO::JY5710CoreOODevice |
BoardClockRate | JY5710CoreOO::JY5710CoreOODevice |
DeviceID | JY5710CoreOO::JY5710CoreOODevice |
DiffChannelCount | JY5710CoreOO::JY5710CoreOODevice |
GetInstance(int cardNum) | JY5710CoreOO::JY5710CoreOODevice | static
GetInstance(std::string aliasName) | JY5710CoreOO::JY5710CoreOODevice | static
Handle | JY5710CoreOO::JY5710CoreOODevice |
IsAISync | JY5710CoreOO::JY5710CoreOODevice |
IsAOSync | JY5710CoreOO::JY5710CoreOODevice |
MaxSampleRateMutilChannel | JY5710CoreOO::JY5710CoreOODevice |
MaxSampleRateSingleChannel | JY5710CoreOO::JY5710CoreOODevice |
MaxUpdateRateSingletoEightChannel | JY5710CoreOO::JY5710CoreOODevice |
MaxUpdateRateThirtyTowChannel | JY5710CoreOO::JY5710CoreOODevice |
ReferenceClock | JY5710CoreOO::JY5710CoreOODevice |
SEChannelCount | JY5710CoreOO::JY5710CoreOODevice |
SerialNumber | JY5710CoreOO::JY5710CoreOODevice |


5710 C++ Programming Manual: Member List

  • JY5710CoreOOLog
JY5710CoreOO::JY5710CoreOOLog Member List

This is the complete list of members for JY5710CoreOO::JY5710CoreOOLog, including all inherited members.

EnableLog | JY5710CoreOO::JY5710CoreOOLog | static
Flush() | JY5710CoreOO::JY5710CoreOOLog | static
LogLevel | JY5710CoreOO::JY5710CoreOOLog | static
Print(const char *format,...) | JY5710CoreOO::JY5710CoreOOLog | static
Print(JY5710CoreOOLogLevel logLevel, const char *format,...) | JY5710CoreOO::JY5710CoreOOLog | static


5710 C++ Programming Manual: Member List

  • JY5710CoreOOProperty
JY5710CoreOO::JY5710CoreOOProperty< ContainerClass, ValueType, propertyType > Member List

This is the complete list of members for JY5710CoreOO::JY5710CoreOOProperty< ContainerClass, ValueType, propertyType >, including all inherited members.

JY5710CoreOOProperty() | JY5710CoreOO::JY5710CoreOOProperty< ContainerClass, ValueType, propertyType >
JY5710CoreOOProperty(ContainerClass *cObject, ValueType(ContainerClass::*pGet)(), void(ContainerClass::*pSet)(ValueType value)) | JY5710CoreOO::JY5710CoreOOProperty< ContainerClass, ValueType, propertyType >
JY5710CoreOOProperty(ValueType(*pGet)(), void(*pSet)(ValueType value)) | JY5710CoreOO::JY5710CoreOOProperty< ContainerClass, ValueType, propertyType >
operator ValueType() | JY5710CoreOO::JY5710CoreOOProperty< ContainerClass, ValueType, propertyType >
operator=(const ValueType &value) | JY5710CoreOO::JY5710CoreOOProperty< ContainerClass, ValueType, propertyType >


5710 C++ Programming Manual: Member List

  • JY5710CoreOOReferenceClock
JY5710CoreOO::JY5710CoreOOReferenceClock Member List

This is the complete list of members for JY5710CoreOO::JY5710CoreOOReferenceClock, including all inherited members.

Commit() | JY5710CoreOO::JY5710CoreOOReferenceClock
External | JY5710CoreOO::JY5710CoreOOReferenceClock
Source | JY5710CoreOO::JY5710CoreOOReferenceClock


5710 C++ Programming Manual: Member List

  • JYDriverException
JY5710CoreOO::JYDriverException Member List

This is the complete list of members for JY5710CoreOO::JYDriverException, including all inherited members.

errorCode | JY5710CoreOO::JYDriverException
exceptionMessage | JY5710CoreOO::JYDriverException
FollowingException | JY5710CoreOO::JYDriverException
JYDriverException(JYDriverExceptionPublic exceptionCode, std::string msg="") | JY5710CoreOO::JYDriverException
JYDriverException(int, std::string msg) | JY5710CoreOO::JYDriverException


5710 C++ Programming Manual: Member List

  • PauseTrigger
JY5710CoreOO::PauseTrigger Member List

This is the complete list of members for JY5710CoreOO::PauseTrigger, including all inherited members.

ActivePolarity | JY5710CoreOO::PauseTrigger
Terminal | JY5710CoreOO::PauseTrigger


5710 C++ Programming Manual: Class Index

Class Index
A | D | E | J | P
A
AOChannel (JY5710CoreOO)
AODigitalTrigger (JY5710CoreOO)
AOExternalSampleClock (JY5710CoreOO)
AOSampleClock (JY5710CoreOO)
AOSignalExport (JY5710CoreOO)
AOTrigger (JY5710CoreOO)
D
DIChannel (JY5710CoreOO)
DOChannel (JY5710CoreOO)
E
ExternalReferenceClock (JY5710CoreOO)
J
JY5710CoreOOAOTask (JY5710CoreOO)
JY5710CoreOODevice (JY5710CoreOO)
JY5710CoreOODITask (JY5710CoreOO)
JY5710CoreOODOTask (JY5710CoreOO)
JY5710CoreOOLog (JY5710CoreOO)
JY5710CoreOOProperty (JY5710CoreOO)
JY5710CoreOOReferenceClock (JY5710CoreOO)
JYDriverException (JY5710CoreOO)
P
PauseTrigger (JY5710CoreOO)


5710 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO Directory Reference

  • File List
  • File Members
  • COO
COO Directory Reference

Directories

5710


5710 C++ Programming Manual: File List

  • File List
  • File Members
File List
Here is a list of all files with brief descriptions:
[detail level 123]
▼ COO
▼ 5710
JY5710CoreOOAOTask.h
JY5710CoreOOCommon.h
JY5710CoreOODevice.h
JY5710CoreOODITask.h
JY5710CoreOODOTask.h
JY5710CoreOOLog.h


5710 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- a -

  • ActivePolarity : JY5710CoreOO::PauseTrigger
  • Add() : JY5710CoreOO::AOSignalExport
  • AddChannel() : JY5710CoreOO::JY5710CoreOOAOTask, JY5710CoreOO::JY5710CoreOODITask, JY5710CoreOO::JY5710CoreOODOTask
  • AIBufferSize : JY5710CoreOO::JY5710CoreOODevice
  • AOChannel() : JY5710CoreOO::AOChannel
  • AOChannelCount : JY5710CoreOO::JY5710CoreOODevice
  • AvaliableLenInSamples : JY5710CoreOO::JY5710CoreOOAOTask

- b -

  • BoardClockRate : JY5710CoreOO::JY5710CoreOODevice
  • BufLenInSamples : JY5710CoreOO::JY5710CoreOOAOTask

- c -

  • ChannelID : JY5710CoreOO::AOChannel
  • Channels : JY5710CoreOO::JY5710CoreOOAOTask, JY5710CoreOO::JY5710CoreOODITask, JY5710CoreOO::JY5710CoreOODOTask
  • Clear() : JY5710CoreOO::AOSignalExport
  • ClearAll() : JY5710CoreOO::AOSignalExport
  • Commit() : JY5710CoreOO::JY5710CoreOOReferenceClock
  • CompleteState : JY5710CoreOO::JY5710CoreOOAOTask

- d -

  • Device : JY5710CoreOO::JY5710CoreOOAOTask, JY5710CoreOO::JY5710CoreOODITask, JY5710CoreOO::JY5710CoreOODOTask
  • DeviceID : JY5710CoreOO::JY5710CoreOODevice
  • DiffChannelCount : JY5710CoreOO::JY5710CoreOODevice
  • Digital : JY5710CoreOO::AOTrigger

- e -

  • Edge : JY5710CoreOO::AODigitalTrigger
  • EnableLog : JY5710CoreOO::JY5710CoreOOLog
  • errorCode : JY5710CoreOO::JYDriverException
  • exceptionMessage : JY5710CoreOO::JYDriverException
  • ExpectedRate : JY5710CoreOO::AOExternalSampleClock
  • External : JY5710CoreOO::AOSampleClock, JY5710CoreOO::JY5710CoreOOReferenceClock

- f -

  • Flush() : JY5710CoreOO::JY5710CoreOOLog
  • FollowingException : JY5710CoreOO::JYDriverException

- g -

  • GetInstance() : JY5710CoreOO::JY5710CoreOODevice

- h -

  • Handle : JY5710CoreOO::JY5710CoreOODevice

- i -

  • IsAISync : JY5710CoreOO::JY5710CoreOODevice
  • IsAOSync : JY5710CoreOO::JY5710CoreOODevice

- j -

  • JY5710CoreOOAOTask() : JY5710CoreOO::JY5710CoreOOAOTask
  • JY5710CoreOODITask() : JY5710CoreOO::JY5710CoreOODITask
  • JY5710CoreOODOTask() : JY5710CoreOO::JY5710CoreOODOTask
  • JY5710CoreOOProperty() : JY5710CoreOO::JY5710CoreOOProperty< ContainerClass, ValueType, propertyType >
  • JYDriverException() : JY5710CoreOO::JYDriverException

- l -

  • LineNum : JY5710CoreOO::DIChannel, JY5710CoreOO::DOChannel
  • LogLevel : JY5710CoreOO::JY5710CoreOOLog

- m -

  • MaxSampleRateMutilChannel : JY5710CoreOO::JY5710CoreOODevice
  • MaxSampleRateSingleChannel : JY5710CoreOO::JY5710CoreOODevice
  • MaxUpdateRateSingletoEightChannel : JY5710CoreOO::JY5710CoreOODevice
  • MaxUpdateRateThirtyTowChannel : JY5710CoreOO::JY5710CoreOODevice
  • Mode : JY5710CoreOO::JY5710CoreOOAOTask

- o -

  • operator ValueType() : JY5710CoreOO::JY5710CoreOOProperty< ContainerClass, ValueType, propertyType >
  • operator=() : JY5710CoreOO::JY5710CoreOOProperty< ContainerClass, ValueType, propertyType >

- p -

  • Print() : JY5710CoreOO::JY5710CoreOOLog

- r -

  • ReadSinglePoint() : JY5710CoreOO::JY5710CoreOODITask
  • ReferenceClock : JY5710CoreOO::JY5710CoreOODevice
  • RemoveChannel() : JY5710CoreOO::JY5710CoreOOAOTask, JY5710CoreOO::JY5710CoreOODITask, JY5710CoreOO::JY5710CoreOODOTask

- s -

  • SampleClock : JY5710CoreOO::JY5710CoreOOAOTask
  • SamplesToUpdate : JY5710CoreOO::JY5710CoreOOAOTask
  • SEChannelCount : JY5710CoreOO::JY5710CoreOODevice
  • SendSoftwareTrigger() : JY5710CoreOO::JY5710CoreOOAOTask
  • SerialNumber : JY5710CoreOO::JY5710CoreOODevice
  • SignalExport : JY5710CoreOO::JY5710CoreOOAOTask
  • Source : JY5710CoreOO::AODigitalTrigger, JY5710CoreOO::AOSampleClock, JY5710CoreOO::JY5710CoreOOReferenceClock
  • Start() : JY5710CoreOO::JY5710CoreOOAOTask, JY5710CoreOO::JY5710CoreOODITask, JY5710CoreOO::JY5710CoreOODOTask
  • Stop() : JY5710CoreOO::JY5710CoreOOAOTask, JY5710CoreOO::JY5710CoreOODITask, JY5710CoreOO::JY5710CoreOODOTask

- t -

  • Terminal : JY5710CoreOO::AOExternalSampleClock, JY5710CoreOO::ExternalReferenceClock, JY5710CoreOO::PauseTrigger
  • TransferedSamples : JY5710CoreOO::JY5710CoreOOAOTask
  • Trigger : JY5710CoreOO::JY5710CoreOOAOTask
  • Type : JY5710CoreOO::AOTrigger

- u -

  • UpdateRate : JY5710CoreOO::JY5710CoreOOAOTask

- w -

  • WaitUntilDone() : JY5710CoreOO::JY5710CoreOOAOTask
  • WriteData() : JY5710CoreOO::JY5710CoreOOAOTask
  • WriteRawData() : JY5710CoreOO::JY5710CoreOOAOTask
  • WriteRawSinglePoint() : JY5710CoreOO::JY5710CoreOOAOTask
  • WriteSinglePoint() : JY5710CoreOO::JY5710CoreOOAOTask, JY5710CoreOO::JY5710CoreOODOTask

- ~ -

  • ~JY5710CoreOOAOTask() : JY5710CoreOO::JY5710CoreOOAOTask
  • ~JY5710CoreOODITask() : JY5710CoreOO::JY5710CoreOODITask
  • ~JY5710CoreOODOTask() : JY5710CoreOO::JY5710CoreOODOTask


5710 C++ Programming Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • c
  • f
  • g
  • j
  • o
  • p
  • r
  • s
  • w
  • ~
Here is a list of all functions with links to the classes they belong to:

- a -

  • Add() : JY5710CoreOO::AOSignalExport
  • AddChannel() : JY5710CoreOO::JY5710CoreOOAOTask, JY5710CoreOO::JY5710CoreOODITask, JY5710CoreOO::JY5710CoreOODOTask
  • AOChannel() : JY5710CoreOO::AOChannel

- c -

  • Clear() : JY5710CoreOO::AOSignalExport
  • ClearAll() : JY5710CoreOO::AOSignalExport
  • Commit() : JY5710CoreOO::JY5710CoreOOReferenceClock

- f -

  • Flush() : JY5710CoreOO::JY5710CoreOOLog

- g -

  • GetInstance() : JY5710CoreOO::JY5710CoreOODevice

- j -

  • JY5710CoreOOAOTask() : JY5710CoreOO::JY5710CoreOOAOTask
  • JY5710CoreOODITask() : JY5710CoreOO::JY5710CoreOODITask
  • JY5710CoreOODOTask() : JY5710CoreOO::JY5710CoreOODOTask
  • JY5710CoreOOProperty() : JY5710CoreOO::JY5710CoreOOProperty< ContainerClass, ValueType, propertyType >
  • JYDriverException() : JY5710CoreOO::JYDriverException

- o -

  • operator ValueType() : JY5710CoreOO::JY5710CoreOOProperty< ContainerClass, ValueType, propertyType >
  • operator=() : JY5710CoreOO::JY5710CoreOOProperty< ContainerClass, ValueType, propertyType >

- p -

  • Print() : JY5710CoreOO::JY5710CoreOOLog

- r -

  • ReadSinglePoint() : JY5710CoreOO::JY5710CoreOODITask
  • RemoveChannel() : JY5710CoreOO::JY5710CoreOOAOTask, JY5710CoreOO::JY5710CoreOODITask, JY5710CoreOO::JY5710CoreOODOTask

- s -

  • SendSoftwareTrigger() : JY5710CoreOO::JY5710CoreOOAOTask
  • Start() : JY5710CoreOO::JY5710CoreOOAOTask, JY5710CoreOO::JY5710CoreOODITask, JY5710CoreOO::JY5710CoreOODOTask
  • Stop() : JY5710CoreOO::JY5710CoreOOAOTask, JY5710CoreOO::JY5710CoreOODITask, JY5710CoreOO::JY5710CoreOODOTask

- w -

  • WaitUntilDone() : JY5710CoreOO::JY5710CoreOOAOTask
  • WriteData() : JY5710CoreOO::JY5710CoreOOAOTask
  • WriteRawData() : JY5710CoreOO::JY5710CoreOOAOTask
  • WriteRawSinglePoint() : JY5710CoreOO::JY5710CoreOOAOTask
  • WriteSinglePoint() : JY5710CoreOO::JY5710CoreOOAOTask, JY5710CoreOO::JY5710CoreOODOTask

- ~ -

  • ~JY5710CoreOOAOTask() : JY5710CoreOO::JY5710CoreOOAOTask
  • ~JY5710CoreOODITask() : JY5710CoreOO::JY5710CoreOODITask
  • ~JY5710CoreOODOTask() : JY5710CoreOO::JY5710CoreOODOTask


5710 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • r
  • s
  • t
  • u
Here is a list of all variables with links to the classes they belong to:

- a -

  • ActivePolarity : JY5710CoreOO::PauseTrigger
  • AIBufferSize : JY5710CoreOO::JY5710CoreOODevice
  • AOChannelCount : JY5710CoreOO::JY5710CoreOODevice
  • AvaliableLenInSamples : JY5710CoreOO::JY5710CoreOOAOTask

- b -

  • BoardClockRate : JY5710CoreOO::JY5710CoreOODevice
  • BufLenInSamples : JY5710CoreOO::JY5710CoreOOAOTask

- c -

  • ChannelID : JY5710CoreOO::AOChannel
  • Channels : JY5710CoreOO::JY5710CoreOOAOTask, JY5710CoreOO::JY5710CoreOODITask, JY5710CoreOO::JY5710CoreOODOTask
  • CompleteState : JY5710CoreOO::JY5710CoreOOAOTask

- d -

  • Device : JY5710CoreOO::JY5710CoreOOAOTask, JY5710CoreOO::JY5710CoreOODITask, JY5710CoreOO::JY5710CoreOODOTask
  • DeviceID : JY5710CoreOO::JY5710CoreOODevice
  • DiffChannelCount : JY5710CoreOO::JY5710CoreOODevice
  • Digital : JY5710CoreOO::AOTrigger

- e -

  • Edge : JY5710CoreOO::AODigitalTrigger
  • EnableLog : JY5710CoreOO::JY5710CoreOOLog
  • errorCode : JY5710CoreOO::JYDriverException
  • exceptionMessage : JY5710CoreOO::JYDriverException
  • ExpectedRate : JY5710CoreOO::AOExternalSampleClock
  • External : JY5710CoreOO::AOSampleClock, JY5710CoreOO::JY5710CoreOOReferenceClock

- f -

  • FollowingException : JY5710CoreOO::JYDriverException

- h -

  • Handle : JY5710CoreOO::JY5710CoreOODevice

- i -

  • IsAISync : JY5710CoreOO::JY5710CoreOODevice
  • IsAOSync : JY5710CoreOO::JY5710CoreOODevice

- l -

  • LineNum : JY5710CoreOO::DIChannel, JY5710CoreOO::DOChannel
  • LogLevel : JY5710CoreOO::JY5710CoreOOLog

- m -

  • MaxSampleRateMutilChannel : JY5710CoreOO::JY5710CoreOODevice
  • MaxSampleRateSingleChannel : JY5710CoreOO::JY5710CoreOODevice
  • MaxUpdateRateSingletoEightChannel : JY5710CoreOO::JY5710CoreOODevice
  • MaxUpdateRateThirtyTowChannel : JY5710CoreOO::JY5710CoreOODevice
  • Mode : JY5710CoreOO::JY5710CoreOOAOTask

- r -

  • ReferenceClock : JY5710CoreOO::JY5710CoreOODevice

- s -

  • SampleClock : JY5710CoreOO::JY5710CoreOOAOTask
  • SamplesToUpdate : JY5710CoreOO::JY5710CoreOOAOTask
  • SEChannelCount : JY5710CoreOO::JY5710CoreOODevice
  • SerialNumber : JY5710CoreOO::JY5710CoreOODevice
  • SignalExport : JY5710CoreOO::JY5710CoreOOAOTask
  • Source : JY5710CoreOO::AODigitalTrigger, JY5710CoreOO::AOSampleClock, JY5710CoreOO::JY5710CoreOOReferenceClock

- t -

  • Terminal : JY5710CoreOO::AOExternalSampleClock, JY5710CoreOO::ExternalReferenceClock, JY5710CoreOO::PauseTrigger
  • TransferedSamples : JY5710CoreOO::JY5710CoreOOAOTask
  • Trigger : JY5710CoreOO::JY5710CoreOOAOTask
  • Type : JY5710CoreOO::AOTrigger

- u -

  • UpdateRate : JY5710CoreOO::JY5710CoreOOAOTask


5710 C++ Programming Manual: File Members

  • File List
  • File Members
  • All
  • Macros
Here is a list of all file members with links to the files they belong to:
  • EXTERN_C : JY5710CoreOOCommon.h
  • JY5710CoreOO_API : JY5710CoreOOCommon.h


5710 C++ Programming Manual: File Members

  • File List
  • File Members
  • All
  • Macros
Here is a list of all macros with links to the files they belong to:
  • EXTERN_C : JY5710CoreOOCommon.h
  • JY5710CoreOO_API : JY5710CoreOOCommon.h


5710 C++ Programming Manual: Main Page

5710 C++ Programming Manual Documentation


5710 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
  • a
  • c
  • e
  • g
  • i
  • j
  • l
  • o
  • r
  • s
Here is a list of all namespace members with links to the namespace documentation for each member:

- a -

  • AODigitalTriggerEdge : JY5710CoreOO
  • AODigitalTriggerSource : JY5710CoreOO
  • AOMode : JY5710CoreOO
  • AOSampleClockSource : JY5710CoreOO
  • AOSignalExportSource : JY5710CoreOO
  • AOTriggerType : JY5710CoreOO

- c -

  • ClockTerminal : JY5710CoreOO

- e -

  • ExternalReferenceClockTerminal : JY5710CoreOO

- g -

  • GetSignalExportDestinationString() : JY5710CoreOO

- i -

  • InputTerminal : JY5710CoreOO
  • IOTerminal : JY5710CoreOO

- j -

  • JY5710_AO_ContinuousNoWrapping : JY5710Import
  • JY5710_AO_ContinuousWrapping : JY5710Import
  • JY5710_AO_Finite : JY5710Import
  • JY5710_AO_SampleClock : JY5710Import
  • JY5710_AO_Single : JY5710Import
  • JY5710_AO_StartTrig : JY5710Import
  • JY5710_DI_Continuous : JY5710Import
  • JY5710_DI_Finite : JY5710Import
  • JY5710_DI_ReferenceTrig : JY5710Import
  • JY5710_DI_Single : JY5710Import
  • JY5710_DI_StartTrig : JY5710Import
  • JY5710_DigitalTriggerEdge_Falling : JY5710Import
  • JY5710_DigitalTriggerEdge_Rising : JY5710Import
  • JY5710_DigitalTriggerSource_PFI_0 : JY5710Import
  • JY5710_DigitalTriggerSource_PFI_1 : JY5710Import
  • JY5710_DigitalTriggerSource_PFI_2 : JY5710Import
  • JY5710_DO_ContinuousNoWrapping : JY5710Import
  • JY5710_DO_ContinuousWrapping : JY5710Import
  • JY5710_DO_Finite : JY5710Import
  • JY5710_DO_Single : JY5710Import
  • JY5710_DO_StartTrig : JY5710Import
  • JY5710_PFI0_OUT : JY5710Import
  • JY5710_PFI1_OUT : JY5710Import
  • JY5710_PFI2_OUT : JY5710Import
  • JY5710_PXITrig0_OUT : JY5710Import
  • JY5710_PXITrig1_OUT : JY5710Import
  • JY5710_PXITrig2_OUT : JY5710Import
  • JY5710_PXITrig3_OUT : JY5710Import
  • JY5710_PXITrig4_OUT : JY5710Import
  • JY5710_PXITrig5_OUT : JY5710Import
  • JY5710_PXITrig6_OUT : JY5710Import
  • JY5710_PXITrig7_OUT : JY5710Import
  • JY5710_TimeBase_100K : JY5710Import
  • JY5710_TimeBase_200M : JY5710Import
  • JY5710_TimeBase_5M : JY5710Import
  • JY5710_TriggerType_Analog : JY5710Import
  • JY5710_TriggerType_Digital : JY5710Import
  • JY5710_TriggerType_Immediately : JY5710Import
  • JY5710_TriggerType_Soft : JY5710Import
  • JY5710CoreOOLogLevel : JY5710CoreOO
  • JY5710CoreOOPropertyType : JY5710CoreOO
  • JYDriverExceptionPublic : JY5710CoreOO

- l -

  • LevelPolarity : JY5710CoreOO

- o -

  • OutputCompleteState : JY5710CoreOO

- r -

  • ReferenceClockSource : JY5710CoreOO
  • ReferenceOnboard_25M : JY5710Import
  • ReferencePXIeCLK_100M : JY5710Import

- s -

  • SignalExportDestination : JY5710CoreOO


5710 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
Here is a list of all namespace enums with links to the namespace documentation for each enum:
  • AODigitalTriggerEdge : JY5710CoreOO
  • AODigitalTriggerSource : JY5710CoreOO
  • AOMode : JY5710CoreOO
  • AOSampleClockSource : JY5710CoreOO
  • AOSignalExportSource : JY5710CoreOO
  • AOTriggerType : JY5710CoreOO
  • ClockTerminal : JY5710CoreOO
  • ExternalReferenceClockTerminal : JY5710CoreOO
  • InputTerminal : JY5710CoreOO
  • IOTerminal : JY5710CoreOO
  • JY5710CoreOOLogLevel : JY5710CoreOO
  • JY5710CoreOOPropertyType : JY5710CoreOO
  • JYDriverExceptionPublic : JY5710CoreOO
  • LevelPolarity : JY5710CoreOO
  • OutputCompleteState : JY5710CoreOO
  • ReferenceClockSource : JY5710CoreOO
  • SignalExportDestination : JY5710CoreOO


5710 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
Here is a list of all namespace functions with links to the namespace documentation for each function:
  • GetSignalExportDestinationString() : JY5710CoreOO


5710 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
  • j
  • r
Here is a list of all namespace variables with links to the namespace documentation for each variable:

- j -

  • JY5710_AO_ContinuousNoWrapping : JY5710Import
  • JY5710_AO_ContinuousWrapping : JY5710Import
  • JY5710_AO_Finite : JY5710Import
  • JY5710_AO_SampleClock : JY5710Import
  • JY5710_AO_Single : JY5710Import
  • JY5710_AO_StartTrig : JY5710Import
  • JY5710_DI_Continuous : JY5710Import
  • JY5710_DI_Finite : JY5710Import
  • JY5710_DI_ReferenceTrig : JY5710Import
  • JY5710_DI_Single : JY5710Import
  • JY5710_DI_StartTrig : JY5710Import
  • JY5710_DigitalTriggerEdge_Falling : JY5710Import
  • JY5710_DigitalTriggerEdge_Rising : JY5710Import
  • JY5710_DigitalTriggerSource_PFI_0 : JY5710Import
  • JY5710_DigitalTriggerSource_PFI_1 : JY5710Import
  • JY5710_DigitalTriggerSource_PFI_2 : JY5710Import
  • JY5710_DO_ContinuousNoWrapping : JY5710Import
  • JY5710_DO_ContinuousWrapping : JY5710Import
  • JY5710_DO_Finite : JY5710Import
  • JY5710_DO_Single : JY5710Import
  • JY5710_DO_StartTrig : JY5710Import
  • JY5710_PFI0_OUT : JY5710Import
  • JY5710_PFI1_OUT : JY5710Import
  • JY5710_PFI2_OUT : JY5710Import
  • JY5710_PXITrig0_OUT : JY5710Import
  • JY5710_PXITrig1_OUT : JY5710Import
  • JY5710_PXITrig2_OUT : JY5710Import
  • JY5710_PXITrig3_OUT : JY5710Import
  • JY5710_PXITrig4_OUT : JY5710Import
  • JY5710_PXITrig5_OUT : JY5710Import
  • JY5710_PXITrig6_OUT : JY5710Import
  • JY5710_PXITrig7_OUT : JY5710Import
  • JY5710_TimeBase_100K : JY5710Import
  • JY5710_TimeBase_200M : JY5710Import
  • JY5710_TimeBase_5M : JY5710Import
  • JY5710_TriggerType_Analog : JY5710Import
  • JY5710_TriggerType_Digital : JY5710Import
  • JY5710_TriggerType_Immediately : JY5710Import
  • JY5710_TriggerType_Soft : JY5710Import

- r -

  • ReferenceOnboard_25M : JY5710Import
  • ReferencePXIeCLK_100M : JY5710Import


5710 C++ Programming Manual: Namespace List

  • Namespace List
  • Namespace Members
Namespace List
Here is a list of all namespaces with brief descriptions:
N JY5710CoreOO
N JY5710Import