6311 C++ Programming Manual: D:/6311/C++/JY6311Core.h File Reference

6311 C++ Programming Manual
  • Main Page
  • Files
  • File List
  • File Members
  • 6311
  • C++
Typedefs | Enumerations | Functions
JY6311Core.h File Reference

Typedefs

typedef void * JY6311_DeviceHandle
Windows.

Enumerations

enum | JY6311_AI_SampleMode { JY6311_AI_Single = 0 , JY6311_AI_Finite = 1 , JY6311_AI_Continuous = 2 }
enum | JY6311_AI_RTDTerminalType { JY6311_AI_2Wire = 0 , JY6311_AI_3Wire = 1 , JY6311_AI_4Wire = 2 }
enum | JY6311_AI_RTDType { JY6311_AI_PT100 = 0 , JY6311_AI_PT1000 = 1 }
enum JY6311_AI_RTDTCRType {
JY6311_AI_Pt100_TCR3851 = 0 , JY6311_AI_Pt100_TCR3916 = 1 , JY6311_AI_Pt100_TCR3920 = 2 , JY6311_AI_Pt100_TCR3911 = 3 ,
JY6311_AI_Pt100_TCR3928 = 4 , JY6311_AI_Pt1000_TCR3851 = 5 , JY6311_AI_Pt1000_TCR3750 = 6
}
enum | JY6311_AI_TriggerType { JY6311_AI_Immediately = 0 , JY6311_AI_Digital = 1 , JY6311_AI_Soft = 2 }
enum | JY6311_AI_TriggerMode { JY6311_StartTrigger = 0 , JY6311_ReferenceTrigger = 1 }
enum | JY6311_DigitalTriggerEdge { JY6311_Rising = 0 , JY6311_Falling = 1 }
enum JY6311_DigitalTriggerSource {
JY6311_PFI0 = 0 , JY6311_PFI1 = 1 , JY6311_PFI2 = 2 , JY6311_PXI_Trig0 = 3 ,
JY6311_PXI_Trig1 = 4 , JY6311_PXI_Trig2 = 5 , JY6311_PXI_Trig3 = 6 , JY6311_PXI_Trig4 = 7 ,
JY6311_PXI_Trig5 = 8 , JY6311_PXI_Trig6 = 9 , JY6311_PXI_Trig7 = 10
}
enum JY6311_Signal_Source {
JY6311_PFI0_IN = 0 , JY6311_PFI1_IN = 1 , JY6311_PFI2_IN = 2 , JY6311_PXI_Trig0_IN = 3 ,
JY6311_PXI_Trig1_IN = 4 , JY6311_PXI_Trig2_IN = 5 , JY6311_PXI_Trig3_IN = 6 , JY6311_PXI_Trig4_IN = 7 ,
JY6311_PXI_Trig5_IN = 8 , JY6311_PXI_Trig6_IN = 9 , JY6311_PXI_Trig7_IN = 10 , JY6311_AI_AnalogTrig = 11 ,
JY6311_AI_SampleClock = 12 , JY6311_AI_StartTrig = 13 , JY6311_AI_ReferenceTrig = 14 , JY6311_AI_AdvanceTrig = 15
}
enum JY6311_Signal_Destination {
JY6311_PFI0_OUT = 0 , JY6311_PFI1_OUT = 1 , JY6311_PFI2_OUT = 2 , JY6311_PXI_Trig0_OUT = 3 ,
JY6311_PXI_Trig1_OUT = 4 , JY6311_PXI_Trig2_OUT = 5 , JY6311_PXI_Trig3_OUT = 6 , JY6311_PXI_Trig4_OUT = 7 ,
JY6311_PXI_Trig5_OUT = 8 , JY6311_PXI_Trig6_OUT = 9 , JY6311_PXI_Trig7_OUT = 10
}
enum | JY6311_AI_ClockSource { JY6311_AI_InternalClock = 0 , JY6311_AI_ExternalClock = 1 }
enum | JY6311_AI_PowerLineFrequency { JY6311_PowerLineFrequency_50Hz = 0 , JY6311_PowerLineFrequency_60Hz = 1 }
enum JY6311_ExternalClockTerminal {
JY6311_Clock_PFI0 = 0 , JY6311_Clock_PFI1 = 1 , JY6311_Clock_PFI2 = 2 , JY6311_Clock_PXI_Trig0 = 3 ,
JY6311_Clock_PXI_Trig1 = 4 , JY6311_Clock_PXI_Trig2 = 5 , JY6311_Clock_PXI_Trig3 = 6 , JY6311_Clock_PXI_Trig4 = 7 ,
JY6311_Clock_PXI_Trig5 = 8 , JY6311_Clock_PXI_Trig6 = 9 , JY6311_Clock_PXI_Trig7 = 10
}
enum | JY6311_AI_MeasurementType { JY6311_Resistance = 0 , JY6311_Temperature = 1 }

Functions

JY6311API int STDCALL | JY6311_Open (int slotNumber, JY6311_DeviceHandle *hDevice)
JY6311API int STDCALL | JY6311_OpenByName (const char *cardName, JY6311_DeviceHandle *hDevice)
JY6311API int STDCALL | JY6311_GetDeviceID (JY6311_DeviceHandle hDevice, int *deviceID)
JY6311API int STDCALL | JY6311_GetDeviceSerialNumber (JY6311_DeviceHandle hDevice, char *serialNumber, int length)
JY6311API int STDCALL | JY6311_SetDeviceStatusLed (JY6311_DeviceHandle hDevice, bool enable, unsigned int frequency)
Control Front Panel Status Led.
JY6311API int STDCALL | JY6311_Close (JY6311_DeviceHandle hDevice)
JY6311API int STDCALL | JY6311_AI_SetPowerLineFrequency (JY6311_DeviceHandle hDevice, JY6311_AI_PowerLineFrequency powerLineFrequency)
JY6311API int STDCALL | JY6311_AI_EnableChannel (JY6311_DeviceHandle hDevice, unsigned int channelsCount, unsigned char *channels, JY6311_AI_MeasurementType *measurementType, JY6311_AI_RTDType *type, JY6311_AI_RTDTerminalType *terminalType, JY6311_AI_RTDTCRType *rtdTCRType)
JY6311API int STDCALL | JY6311_AI_SetSampleClock (JY6311_DeviceHandle hDevice, JY6311_AI_ClockSource clockSource, JY6311_ExternalClockTerminal terminal, double expectedRate)
Set AI sampling clock.
JY6311API int STDCALL | JY6311_AI_SetSampleRate (JY6311_DeviceHandle hDevice, double sampleRate, double *actualSampleRate)
JY6311API int STDCALL | JY6311_AI_SetSamplesToAcquire (JY6311_DeviceHandle hDevice, unsigned int samplesToAcquire)
JY6311API int STDCALL | JY6311_AI_SetSampleMode (JY6311_DeviceHandle hDevice, JY6311_AI_SampleMode mode)
JY6311API int STDCALL | JY6311_AI_Start (JY6311_DeviceHandle hDevice)
JY6311API int STDCALL | JY6311_AI_Stop (JY6311_DeviceHandle hDevice)
JY6311API int STDCALL | JY6311_AI_ReadRawData (JY6311_DeviceHandle hDevice, int *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
JY6311API int STDCALL | JY6311_AI_ReadData (JY6311_DeviceHandle hDevice, double *dataBuffer, unsigned int dataLength, int timeout, unsigned int *actualReadLength)
JY6311API int STDCALL | JY6311_AI_ReadSinglePoint (JY6311_DeviceHandle hDevice, double *dataBuffer, int channelID)
JY6311API int STDCALL | JY6311_AI_WaitUntilDone (JY6311_DeviceHandle hDevice, int timeout, bool *done)
summary> Check AI device buffer status.
JY6311API int STDCALL | JY6311_AI_CheckBufferStatus (JY6311_DeviceHandle hDevice, unsigned long long *availableSamplesCount, unsigned long long *transferedSamples, bool *overflow)
JY6311API int STDCALL | JY6311_AI_SetStartTriggerType (JY6311_DeviceHandle hDevice, JY6311_AI_TriggerType triggerType)
JY6311API int STDCALL | JY6311_AI_SetDigitalStartTrigger (JY6311_DeviceHandle hDevice, JY6311_DigitalTriggerSource triggerSource, JY6311_DigitalTriggerEdge triggerEdge)
JY6311API int STDCALL | JY6311_AI_SetReferenceTriggerType (JY6311_DeviceHandle hDevice, JY6311_AI_TriggerType triggerType)
JY6311API int STDCALL | JY6311_AI_SetDigitalReferenceTrigger (JY6311_DeviceHandle hDevice, JY6311_DigitalTriggerSource triggerSource, JY6311_DigitalTriggerEdge triggerEdge)
JY6311API int STDCALL | JY6311_AI_SetPreTriggerSamples (JY6311_DeviceHandle hDevice, unsigned int preTriggerSamples)
Set AI pretrigger samples, the samples must greater than 0.
JY6311API int STDCALL | JY6311_AI_SetReTriggerCount (JY6311_DeviceHandle hDevice, unsigned int reTriggerCount)
Set AI retrigger count.
JY6311API int STDCALL | JY6311_AI_SendSoftTrigger (JY6311_DeviceHandle hDevice, JY6311_AI_TriggerMode triggerMode)
JY6311API int STDCALL | JY6311_SignalRouting (JY6311_DeviceHandle hDevice, JY6311_Signal_Source sourceSignal, JY6311_Signal_Destination distination)
Route a singal from source to destination.
JY6311API int STDCALL | JY6311_DisconnectSignalRouting (JY6311_DeviceHandle hDevice, JY6311_Signal_Destination destination)
Disconnect an established routing.
JY6311API int STDCALL | JY6311_DisableCalibration (JY6311_DeviceHandle hDevice, bool DisableCalibration)
Disable AI calibration coefficient, default enable calibration coefficient.
JY6311API int STDCALL | JY6311_DI_AddLines (JY6311_DeviceHandle hDevice, int *linesID, unsigned int lineCount)
Enabled DI channels.
JY6311API int STDCALL | JY6311_DI_ReadSinglePoint (JY6311_DeviceHandle hDevice, bool *readValues, int lineID)
read single data from a single line by lineID defined.if the lineID == -1,read all line data.The data type is bool, one bool defined one line status.
JY6311API int STDCALL | JY6311_DI_Start (JY6311_DeviceHandle hDevice)
Start DI acquisition.
JY6311API int STDCALL | JY6311_DI_Stop (JY6311_DeviceHandle hDevice)
Stop DI acquisition.
JY6311API int STDCALL | JY6311_DO_AddLines (JY6311_DeviceHandle hDevice, int *linesID, unsigned int lineCount)
Enabled DO channels.
JY6311API int STDCALL | JY6311_DO_WriteSinglePoint (JY6311_DeviceHandle hDevice, bool *writeValues, int lineID)
write single data to the line by lineID defined.if the lineID == -1,write all line data.
JY6311API int STDCALL | JY6311_DO_Start (JY6311_DeviceHandle hDevice)
Start DO output.
JY6311API int STDCALL | JY6311_DO_Stop (JY6311_DeviceHandle hDevice)
Stop DO output.

Typedef Documentation

◆ JY6311_DeviceHandle

typedef void* JY6311_DeviceHandle

Windows.

Linux

Enumeration Type Documentation

◆ JY6311_AI_ClockSource

enum JY6311_AI_ClockSource
Enumerator
JY6311_AI_InternalClock | AI Internal SampleClock.
JY6311_AI_ExternalClock | AI External SampleClock.

◆ JY6311_AI_MeasurementType

enum JY6311_AI_MeasurementType
Enumerator
JY6311_Resistance | AI Resistance Measure.
JY6311_Temperature | AI Temperature Measure.

◆ JY6311_AI_PowerLineFrequency

enum JY6311_AI_PowerLineFrequency
Enumerator
JY6311_PowerLineFrequency_50Hz | 50Hz
JY6311_PowerLineFrequency_60Hz | 60Hz

◆ JY6311_AI_RTDTCRType

enum JY6311_AI_RTDTCRType
Enumerator
JY6311_AI_Pt100_TCR3851 | RTD TCR = 3851 (Default)
JY6311_AI_Pt100_TCR3916 | RTD TCR = 3916.
JY6311_AI_Pt100_TCR3920 | RTD TCR = 3920.
JY6311_AI_Pt100_TCR3911 | RTD TCR = 3911.
JY6311_AI_Pt100_TCR3928 | RTD TCR = 3928.
JY6311_AI_Pt1000_TCR3851 |
JY6311_AI_Pt1000_TCR3750 |

◆ JY6311_AI_RTDTerminalType

enum JY6311_AI_RTDTerminalType
Enumerator
JY6311_AI_2Wire | AI 2WireRTD Terminal.
JY6311_AI_3Wire | AI 3WireRTD Terminal.
JY6311_AI_4Wire | AI 4WireRTD Terminal.

◆ JY6311_AI_RTDType

enum JY6311_AI_RTDType
Enumerator
JY6311_AI_PT100 |
JY6311_AI_PT1000 | PT100.

◆ JY6311_AI_SampleMode

enum JY6311_AI_SampleMode
Enumerator
JY6311_AI_Single | AI Single Mode.
JY6311_AI_Finite | AI Finite Mode.
JY6311_AI_Continuous | AI Continuous Mode.

◆ JY6311_AI_TriggerMode

enum JY6311_AI_TriggerMode
Enumerator
JY6311_StartTrigger | AI Start Trigger Mode.
JY6311_ReferenceTrigger | AI Reference Trigger Mode.

◆ JY6311_AI_TriggerType

enum JY6311_AI_TriggerType
Enumerator
JY6311_AI_Immediately | AI Immediately Trigger.
JY6311_AI_Digital | AI Digital Trigger.
JY6311_AI_Soft | AI Soft Trigger.

◆ JY6311_DigitalTriggerEdge

enum JY6311_DigitalTriggerEdge
Enumerator
JY6311_Rising | AI Rising edge for digital trigger.
JY6311_Falling | AI Falling edge for digital trigger.

◆ JY6311_DigitalTriggerSource

enum JY6311_DigitalTriggerSource
Enumerator
JY6311_PFI0 | PFI0 as the digital trigger source to rout.
JY6311_PFI1 | PFI1 as the digital trigger source to rout.
JY6311_PFI2 | PFI2 as the digital trigger source to rout.
JY6311_PXI_Trig0 | PXITrigger0 as the digital trigger source to rout.
JY6311_PXI_Trig1 | PXITrigger1 as the digital trigger source to rout.
JY6311_PXI_Trig2 | PXITrigger2 as the digital trigger source to rout.
JY6311_PXI_Trig3 | PXITrigger3 as the digital trigger source to rout.
JY6311_PXI_Trig4 | PXITrigger4 as the digital trigger source to rout.
JY6311_PXI_Trig5 | PXITrigger5 as the digital trigger source to rout.
JY6311_PXI_Trig6 | PXITrigger6 as the digital trigger source to rout.
JY6311_PXI_Trig7 | PXITrigger7 as the digital trigger source to rout.

◆ JY6311_ExternalClockTerminal

enum JY6311_ExternalClockTerminal
Enumerator
JY6311_Clock_PFI0 | PFI0 as the external sample clock to rout.
JY6311_Clock_PFI1 | PFI1 as the external sample clock to rout.
JY6311_Clock_PFI2 | PFI2 as the external sample clock to rout.
JY6311_Clock_PXI_Trig0 | PXITrigger0 as the external sample clock to rout.
JY6311_Clock_PXI_Trig1 | PXITrigger1 as the external sample clock to rout.
JY6311_Clock_PXI_Trig2 | PXITrigger2 as the external sample clock to rout.
JY6311_Clock_PXI_Trig3 | PXITrigger3 as the external sample clock to rout.
JY6311_Clock_PXI_Trig4 | PXITrigger4 as the external sample clock to rout.
JY6311_Clock_PXI_Trig5 | PXITrigger5 as the external sample clock to rout.
JY6311_Clock_PXI_Trig6 | PXITrigger6 as the external sample clock to rout.
JY6311_Clock_PXI_Trig7 | PXITrigger7 as the external sample clock to rout.

◆ JY6311_Signal_Destination

enum JY6311_Signal_Destination
Enumerator
JY6311_PFI0_OUT | PFI0 as the signal desition to rout.
JY6311_PFI1_OUT | PFI1 as the signal desition to rout.
JY6311_PFI2_OUT | PFI2 as the signal desition to rout.
JY6311_PXI_Trig0_OUT | PXITrigger0 as the signal desition to rout.
JY6311_PXI_Trig1_OUT | PXITrigger1 as the signal desition to rout.
JY6311_PXI_Trig2_OUT | PXITrigger2 as the signal desition to rout.
JY6311_PXI_Trig3_OUT | PXITrigger3 as the signal desition to rout.
JY6311_PXI_Trig4_OUT | PXITrigger4 as the signal desition to rout.
JY6311_PXI_Trig5_OUT | PXITrigger5 as the signal desition to rout.
JY6311_PXI_Trig6_OUT | PXITrigger6 as the signal desition to rout.
JY6311_PXI_Trig7_OUT | PXITrigger7 as the signal desition to rout.

◆ JY6311_Signal_Source

enum JY6311_Signal_Source
Enumerator
JY6311_PFI0_IN | PFI0 as the signal source to rout.
JY6311_PFI1_IN | PFI1 as the signal source to rout.
JY6311_PFI2_IN | PFI2 as the signal source to rout.
JY6311_PXI_Trig0_IN | PXITrigger0 as the signal source to rout.
JY6311_PXI_Trig1_IN | PXITrigger1 as the signal source to rout.
JY6311_PXI_Trig2_IN | PXITrigger2 as the signal source to rout.
JY6311_PXI_Trig3_IN | PXITrigger3 as the signal source to rout.
JY6311_PXI_Trig4_IN | PXITrigger4 as the signal source to rout.
JY6311_PXI_Trig5_IN | PXITrigger5 as the signal source to rout.
JY6311_PXI_Trig6_IN | PXITrigger6 as the signal source to rout.
JY6311_PXI_Trig7_IN | PXITrigger7 as the signal source to rout.
JY6311_AI_AnalogTrig |
JY6311_AI_SampleClock | AI_SampleClock as the signal source to rout.
JY6311_AI_StartTrig | AI_StartTrig as the signal source to rout.
JY6311_AI_ReferenceTrig | AI_ReferenceTrig as the signal source to rout.
JY6311_AI_AdvanceTrig | AI_AdvanceTrig as the signal source to rout.

Function Documentation

◆ JY6311_AI_CheckBufferStatus()

JY6311API int STDCALL JY6311_AI_CheckBufferStatus | ( | JY6311_DeviceHandle | hDevice,
 |  | unsigned long long * | availableSamplesCount,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overflow )

◆ JY6311_AI_EnableChannel()

JY6311API int STDCALL JY6311_AI_EnableChannel | ( | JY6311_DeviceHandle | hDevice,
 |  | unsigned int | channelsCount,
 |  | unsigned char * | channels,
 |  | JY6311_AI_MeasurementType * | measurementType,
 |  | JY6311_AI_RTDType * | type,
 |  | JY6311_AI_RTDTerminalType * | terminalType,
 |  | JY6311_AI_RTDTCRType * | rtdTCRType )

◆ JY6311_AI_ReadData()

JY6311API int STDCALL JY6311_AI_ReadData | ( | JY6311_DeviceHandle | hDevice,
 |  | double * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeout,
 |  | unsigned int * | actualReadLength )

◆ JY6311_AI_ReadRawData()

JY6311API int STDCALL JY6311_AI_ReadRawData | ( | JY6311_DeviceHandle | hDevice,
 |  | int * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength )

◆ JY6311_AI_ReadSinglePoint()

JY6311API int STDCALL JY6311_AI_ReadSinglePoint | ( | JY6311_DeviceHandle | hDevice,
 |  | double * | dataBuffer,
 |  | int | channelID )

◆ JY6311_AI_SendSoftTrigger()

JY6311API int STDCALL JY6311_AI_SendSoftTrigger | ( | JY6311_DeviceHandle | hDevice,
 |  | JY6311_AI_TriggerMode | triggerMode )

◆ JY6311_AI_SetDigitalReferenceTrigger()

JY6311API int STDCALL JY6311_AI_SetDigitalReferenceTrigger | ( | JY6311_DeviceHandle | hDevice,
 |  | JY6311_DigitalTriggerSource | triggerSource,
 |  | JY6311_DigitalTriggerEdge | triggerEdge )

◆ JY6311_AI_SetDigitalStartTrigger()

JY6311API int STDCALL JY6311_AI_SetDigitalStartTrigger | ( | JY6311_DeviceHandle | hDevice,
 |  | JY6311_DigitalTriggerSource | triggerSource,
 |  | JY6311_DigitalTriggerEdge | triggerEdge )

◆ JY6311_AI_SetPowerLineFrequency()

JY6311API int STDCALL JY6311_AI_SetPowerLineFrequency | ( | JY6311_DeviceHandle | hDevice,
 |  | JY6311_AI_PowerLineFrequency | powerLineFrequency )

◆ JY6311_AI_SetPreTriggerSamples()

JY6311API int STDCALL JY6311_AI_SetPreTriggerSamples | ( | JY6311_DeviceHandle | hDevice,
 |  | unsigned int | preTriggerSamples )

Set AI pretrigger samples, the samples must greater than 0.

Parameters
hDevice | device handle
preTriggerSamples | AI pretrigger samples, valid only in reference trigger mode.
Returns
0 if success or other error code

◆ JY6311_AI_SetReferenceTriggerType()

JY6311API int STDCALL JY6311_AI_SetReferenceTriggerType | ( | JY6311_DeviceHandle | hDevice,
 |  | JY6311_AI_TriggerType | triggerType )

◆ JY6311_AI_SetReTriggerCount()

JY6311API int STDCALL JY6311_AI_SetReTriggerCount | ( | JY6311_DeviceHandle | hDevice,
 |  | unsigned int | reTriggerCount )

Set AI retrigger count.

The device will be triggered reTriggerCount times.

Parameters
hDevice | device handle
reTriggerCount | AI retrigger count
Returns
0 if success or other error code

◆ JY6311_AI_SetSampleClock()

JY6311API int STDCALL JY6311_AI_SetSampleClock | ( | JY6311_DeviceHandle | hDevice,
 |  | JY6311_AI_ClockSource | clockSource,
 |  | JY6311_ExternalClockTerminal | terminal,
 |  | double | expectedRate )

Set AI sampling clock.

the source of the sampling clock defined by enum JY6311_ClockSource. If the clock source is external, external clock terminal and external clock frequency must be configured.

Parameters
hDevice | device handle
clockSource | AI sampling clock source
terminal | external terminal
expectedRate | AI external clock frequency
Returns
0 if success or other error code

◆ JY6311_AI_SetSampleMode()

JY6311API int STDCALL JY6311_AI_SetSampleMode | ( | JY6311_DeviceHandle | hDevice,
 |  | JY6311_AI_SampleMode | mode )

◆ JY6311_AI_SetSampleRate()

JY6311API int STDCALL JY6311_AI_SetSampleRate | ( | JY6311_DeviceHandle | hDevice,
 |  | double | sampleRate,
 |  | double * | actualSampleRate )

summary> Set sampling rate. The sampling rate is the same for all channels. /summary> param name="hDevice">device handle

param name="sampleRate">up to 800Sa/s can be set on each AD chip

Returns
0 if success or other error code

◆ JY6311_AI_SetSamplesToAcquire()

JY6311API int STDCALL JY6311_AI_SetSamplesToAcquire | ( | JY6311_DeviceHandle | hDevice,
 |  | unsigned int | samplesToAcquire )

◆ JY6311_AI_SetStartTriggerType()

JY6311API int STDCALL JY6311_AI_SetStartTriggerType | ( | JY6311_DeviceHandle | hDevice,
 |  | JY6311_AI_TriggerType | triggerType )

◆ JY6311_AI_Start()

JY6311API int STDCALL JY6311_AI_Start ( JY6311_DeviceHandle hDevice )

◆ JY6311_AI_Stop()

JY6311API int STDCALL JY6311_AI_Stop ( JY6311_DeviceHandle hDevice )

◆ JY6311_AI_WaitUntilDone()

JY6311API int STDCALL JY6311_AI_WaitUntilDone | ( | JY6311_DeviceHandle | hDevice,
 |  | int | timeout,
 |  | bool * | done )

summary> Check AI device buffer status.

/summary> param name="hDevice">device handle

param name="availableSamplesCount">number of samples per channel in the device buffer

param name="transferedSamples">The number of samples that have been transfered from the device buffer (per channel)

param name="overflow">true:overflow, false: not overflow.

returns>0 if success or other error code

◆ JY6311_Close()

JY6311API int STDCALL JY6311_Close ( JY6311_DeviceHandle hDevice )

◆ JY6311_DI_AddLines()

JY6311API int STDCALL JY6311_DI_AddLines | ( | JY6311_DeviceHandle | hDevice,
 |  | int * | linesID,
 |  | unsigned int | lineCount )

Enabled DI channels.

Parameters
hDevice | device handle
linesID | array[lineCount] containing line IDs
lineCount | number of lines to be enabled
Returns
0 if Success or other error code

◆ JY6311_DI_ReadSinglePoint()

JY6311API int STDCALL JY6311_DI_ReadSinglePoint | ( | JY6311_DeviceHandle | hDevice,
 |  | bool * | readValues,
 |  | int | lineID )

read single data from a single line by lineID defined.if the lineID == -1,read all line data.The data type is bool, one bool defined one line status.

Parameters
hDevice | device handle
readValues | read the specified line values. when the lineID is -1, read all enabled lines values.
lineID | line ID
Returns
0 if success or other error code

◆ JY6311_DI_Start()

JY6311API int STDCALL JY6311_DI_Start ( JY6311_DeviceHandle hDevice )

Start DI acquisition.

Parameters
hDevice device handle
Returns
0 if Success or other error code

◆ JY6311_DI_Stop()

JY6311API int STDCALL JY6311_DI_Stop ( JY6311_DeviceHandle hDevice )

Stop DI acquisition.

Parameters
hDevice device handle
Returns
0 if Success or other error code

◆ JY6311_DisableCalibration()

JY6311API int STDCALL JY6311_DisableCalibration | ( | JY6311_DeviceHandle | hDevice,
 |  | bool | DisableCalibration )

Disable AI calibration coefficient, default enable calibration coefficient.

Parameters
hDevice | device handle
DisableCalibration | true if disabled, false if not disabled.
Returns
0 if success or other error code

◆ JY6311_DisconnectSignalRouting()

JY6311API int STDCALL JY6311_DisconnectSignalRouting | ( | JY6311_DeviceHandle | hDevice,
 |  | JY6311_Signal_Destination | destination )

Disconnect an established routing.

Parameters
hDevice | device handle
destination | destination of the signal defined by enum JY6311_DestinationSignal
Returns
0 if success or other error code

◆ JY6311_DO_AddLines()

JY6311API int STDCALL JY6311_DO_AddLines | ( | JY6311_DeviceHandle | hDevice,
 |  | int * | linesID,
 |  | unsigned int | lineCount )

Enabled DO channels.

Parameters
hDevice | device handle
linesID | array[lineCount] containing line IDs.
lineCount | number of lines to be enabled
Returns
0 if Success or other error code

◆ JY6311_DO_Start()

JY6311API int STDCALL JY6311_DO_Start ( JY6311_DeviceHandle hDevice )

Start DO output.

Parameters
hDevice device handle
Returns
0 if Success or other error code

◆ JY6311_DO_Stop()

JY6311API int STDCALL JY6311_DO_Stop ( JY6311_DeviceHandle hDevice )

Stop DO output.

Parameters
hDevice device handle
Returns
0 if Success or other error code

◆ JY6311_DO_WriteSinglePoint()

JY6311API int STDCALL JY6311_DO_WriteSinglePoint | ( | JY6311_DeviceHandle | hDevice,
 |  | bool * | writeValues,
 |  | int | lineID )

write single data to the line by lineID defined.if the lineID == -1,write all line data.

Parameters
hDevice | device handle
writeValues | write the specified line values. when the lineID is -1, write all enabled lines values,
lineID | line ID
Returns
0 if success or other error code

◆ JY6311_GetDeviceID()

JY6311API int STDCALL JY6311_GetDeviceID | ( | JY6311_DeviceHandle | hDevice,
 |  | int * | deviceID )

◆ JY6311_GetDeviceSerialNumber()

JY6311API int STDCALL JY6311_GetDeviceSerialNumber | ( | JY6311_DeviceHandle | hDevice,
 |  | char * | serialNumber,
 |  | int | length )

summary> Get the device serialNumber. /summary> param name="hDevice">device handle

param name="serialNumber">Pointer to a buffer receiving the serial number. The length of the serial number is 10.

param name="length">serial Number length ,length is 10

returns>0 if success or other error code

◆ JY6311_Open()

JY6311API int STDCALL JY6311_Open | ( | int | slotNumber,
 |  | JY6311_DeviceHandle * | hDevice )

◆ JY6311_OpenByName()

JY6311API int STDCALL JY6311_OpenByName | ( | const char * | cardName,
 |  | JY6311_DeviceHandle * | hDevice )

◆ JY6311_SetDeviceStatusLed()

JY6311API int STDCALL JY6311_SetDeviceStatusLed | ( | JY6311_DeviceHandle | hDevice,
 |  | bool | enable,
 |  | unsigned int | frequency )

Control Front Panel Status Led.

Parameters
hDevice | device handle
enable | enable front panel status led blink, true: blink, false: not blink
frequency | when enable is ture, the led blink speed by frequency define
Returns
0 if success or other error code

◆ JY6311_SignalRouting()

JY6311API int STDCALL JY6311_SignalRouting | ( | JY6311_DeviceHandle | hDevice,
 |  | JY6311_Signal_Source | sourceSignal,
 |  | JY6311_Signal_Destination | distination )

Route a singal from source to destination.

Both source and destination are defined by the corresponding enum Y6311_SourceSignal and JY6311_DestinationSignal. One source signal may be routed to multiple destinations.

Parameters
hDevice | device handle
source | source of the signal defined by enum JY6311_SourceSignal
destination | destination of the signal defined by enum JY6311_DestinationSignal
Returns
0 if success or other error code
Generated by doxygen 1.12.0


6311 C++ Programming Manual: D:/6311 Directory Reference

  • 6311
6311 Directory Reference

Directories

C++


6311 C++ Programming Manual: D:/6311/C++ Directory Reference

  • 6311
  • C++
C++ Directory Reference

Files

JY6311Core.h


6311 C++ Programming Manual: File List

File List
Here is a list of all files with brief descriptions:
[detail level 123]
▼ 6311
▼ C++
JY6311Core.h


6311 C++ Programming Manual: File Members

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • j
Here is a list of all file members with links to the files they belong to:

- j -

  • JY6311_AI_2Wire : JY6311Core.h
  • JY6311_AI_3Wire : JY6311Core.h
  • JY6311_AI_4Wire : JY6311Core.h
  • JY6311_AI_AdvanceTrig : JY6311Core.h
  • JY6311_AI_AnalogTrig : JY6311Core.h
  • JY6311_AI_CheckBufferStatus() : JY6311Core.h
  • JY6311_AI_ClockSource : JY6311Core.h
  • JY6311_AI_Continuous : JY6311Core.h
  • JY6311_AI_Digital : JY6311Core.h
  • JY6311_AI_EnableChannel() : JY6311Core.h
  • JY6311_AI_ExternalClock : JY6311Core.h
  • JY6311_AI_Finite : JY6311Core.h
  • JY6311_AI_Immediately : JY6311Core.h
  • JY6311_AI_InternalClock : JY6311Core.h
  • JY6311_AI_MeasurementType : JY6311Core.h
  • JY6311_AI_PowerLineFrequency : JY6311Core.h
  • JY6311_AI_PT100 : JY6311Core.h
  • JY6311_AI_PT1000 : JY6311Core.h
  • JY6311_AI_Pt1000_TCR3750 : JY6311Core.h
  • JY6311_AI_Pt1000_TCR3851 : JY6311Core.h
  • JY6311_AI_Pt100_TCR3851 : JY6311Core.h
  • JY6311_AI_Pt100_TCR3911 : JY6311Core.h
  • JY6311_AI_Pt100_TCR3916 : JY6311Core.h
  • JY6311_AI_Pt100_TCR3920 : JY6311Core.h
  • JY6311_AI_Pt100_TCR3928 : JY6311Core.h
  • JY6311_AI_ReadData() : JY6311Core.h
  • JY6311_AI_ReadRawData() : JY6311Core.h
  • JY6311_AI_ReadSinglePoint() : JY6311Core.h
  • JY6311_AI_ReferenceTrig : JY6311Core.h
  • JY6311_AI_RTDTCRType : JY6311Core.h
  • JY6311_AI_RTDTerminalType : JY6311Core.h
  • JY6311_AI_RTDType : JY6311Core.h
  • JY6311_AI_SampleClock : JY6311Core.h
  • JY6311_AI_SampleMode : JY6311Core.h
  • JY6311_AI_SendSoftTrigger() : JY6311Core.h
  • JY6311_AI_SetDigitalReferenceTrigger() : JY6311Core.h
  • JY6311_AI_SetDigitalStartTrigger() : JY6311Core.h
  • JY6311_AI_SetPowerLineFrequency() : JY6311Core.h
  • JY6311_AI_SetPreTriggerSamples() : JY6311Core.h
  • JY6311_AI_SetReferenceTriggerType() : JY6311Core.h
  • JY6311_AI_SetReTriggerCount() : JY6311Core.h
  • JY6311_AI_SetSampleClock() : JY6311Core.h
  • JY6311_AI_SetSampleMode() : JY6311Core.h
  • JY6311_AI_SetSampleRate() : JY6311Core.h
  • JY6311_AI_SetSamplesToAcquire() : JY6311Core.h
  • JY6311_AI_SetStartTriggerType() : JY6311Core.h
  • JY6311_AI_Single : JY6311Core.h
  • JY6311_AI_Soft : JY6311Core.h
  • JY6311_AI_Start() : JY6311Core.h
  • JY6311_AI_StartTrig : JY6311Core.h
  • JY6311_AI_Stop() : JY6311Core.h
  • JY6311_AI_TriggerMode : JY6311Core.h
  • JY6311_AI_TriggerType : JY6311Core.h
  • JY6311_AI_WaitUntilDone() : JY6311Core.h
  • JY6311_Clock_PFI0 : JY6311Core.h
  • JY6311_Clock_PFI1 : JY6311Core.h
  • JY6311_Clock_PFI2 : JY6311Core.h
  • JY6311_Clock_PXI_Trig0 : JY6311Core.h
  • JY6311_Clock_PXI_Trig1 : JY6311Core.h
  • JY6311_Clock_PXI_Trig2 : JY6311Core.h
  • JY6311_Clock_PXI_Trig3 : JY6311Core.h
  • JY6311_Clock_PXI_Trig4 : JY6311Core.h
  • JY6311_Clock_PXI_Trig5 : JY6311Core.h
  • JY6311_Clock_PXI_Trig6 : JY6311Core.h
  • JY6311_Clock_PXI_Trig7 : JY6311Core.h
  • JY6311_Close() : JY6311Core.h
  • JY6311_DeviceHandle : JY6311Core.h
  • JY6311_DI_AddLines() : JY6311Core.h
  • JY6311_DI_ReadSinglePoint() : JY6311Core.h
  • JY6311_DI_Start() : JY6311Core.h
  • JY6311_DI_Stop() : JY6311Core.h
  • JY6311_DigitalTriggerEdge : JY6311Core.h
  • JY6311_DigitalTriggerSource : JY6311Core.h
  • JY6311_DisableCalibration() : JY6311Core.h
  • JY6311_DisconnectSignalRouting() : JY6311Core.h
  • JY6311_DO_AddLines() : JY6311Core.h
  • JY6311_DO_Start() : JY6311Core.h
  • JY6311_DO_Stop() : JY6311Core.h
  • JY6311_DO_WriteSinglePoint() : JY6311Core.h
  • JY6311_ExternalClockTerminal : JY6311Core.h
  • JY6311_Falling : JY6311Core.h
  • JY6311_GetDeviceID() : JY6311Core.h
  • JY6311_GetDeviceSerialNumber() : JY6311Core.h
  • JY6311_Open() : JY6311Core.h
  • JY6311_OpenByName() : JY6311Core.h
  • JY6311_PFI0 : JY6311Core.h
  • JY6311_PFI0_IN : JY6311Core.h
  • JY6311_PFI0_OUT : JY6311Core.h
  • JY6311_PFI1 : JY6311Core.h
  • JY6311_PFI1_IN : JY6311Core.h
  • JY6311_PFI1_OUT : JY6311Core.h
  • JY6311_PFI2 : JY6311Core.h
  • JY6311_PFI2_IN : JY6311Core.h
  • JY6311_PFI2_OUT : JY6311Core.h
  • JY6311_PowerLineFrequency_50Hz : JY6311Core.h
  • JY6311_PowerLineFrequency_60Hz : JY6311Core.h
  • JY6311_PXI_Trig0 : JY6311Core.h
  • JY6311_PXI_Trig0_IN : JY6311Core.h
  • JY6311_PXI_Trig0_OUT : JY6311Core.h
  • JY6311_PXI_Trig1 : JY6311Core.h
  • JY6311_PXI_Trig1_IN : JY6311Core.h
  • JY6311_PXI_Trig1_OUT : JY6311Core.h
  • JY6311_PXI_Trig2 : JY6311Core.h
  • JY6311_PXI_Trig2_IN : JY6311Core.h
  • JY6311_PXI_Trig2_OUT : JY6311Core.h
  • JY6311_PXI_Trig3 : JY6311Core.h
  • JY6311_PXI_Trig3_IN : JY6311Core.h
  • JY6311_PXI_Trig3_OUT : JY6311Core.h
  • JY6311_PXI_Trig4 : JY6311Core.h
  • JY6311_PXI_Trig4_IN : JY6311Core.h
  • JY6311_PXI_Trig4_OUT : JY6311Core.h
  • JY6311_PXI_Trig5 : JY6311Core.h
  • JY6311_PXI_Trig5_IN : JY6311Core.h
  • JY6311_PXI_Trig5_OUT : JY6311Core.h
  • JY6311_PXI_Trig6 : JY6311Core.h
  • JY6311_PXI_Trig6_IN : JY6311Core.h
  • JY6311_PXI_Trig6_OUT : JY6311Core.h
  • JY6311_PXI_Trig7 : JY6311Core.h
  • JY6311_PXI_Trig7_IN : JY6311Core.h
  • JY6311_PXI_Trig7_OUT : JY6311Core.h
  • JY6311_ReferenceTrigger : JY6311Core.h
  • JY6311_Resistance : JY6311Core.h
  • JY6311_Rising : JY6311Core.h
  • JY6311_SetDeviceStatusLed() : JY6311Core.h
  • JY6311_Signal_Destination : JY6311Core.h
  • JY6311_Signal_Source : JY6311Core.h
  • JY6311_SignalRouting() : JY6311Core.h
  • JY6311_StartTrigger : JY6311Core.h
  • JY6311_Temperature : JY6311Core.h


  • Enumerations
  • Enumerator
Here is a list of all enums with links to the files they belong to:
  • JY6311_AI_ClockSource : JY6311Core.h
  • JY6311_AI_MeasurementType : JY6311Core.h
  • JY6311_AI_PowerLineFrequency : JY6311Core.h
  • JY6311_AI_RTDTCRType : JY6311Core.h
  • JY6311_AI_RTDTerminalType : JY6311Core.h
  • JY6311_AI_RTDType : JY6311Core.h
  • JY6311_AI_SampleMode : JY6311Core.h
  • JY6311_AI_TriggerMode : JY6311Core.h
  • JY6311_AI_TriggerType : JY6311Core.h
  • JY6311_DigitalTriggerEdge : JY6311Core.h
  • JY6311_DigitalTriggerSource : JY6311Core.h
  • JY6311_ExternalClockTerminal : JY6311Core.h
  • JY6311_Signal_Destination : JY6311Core.h
  • JY6311_Signal_Source : JY6311Core.h


  • Enumerations
  • Enumerator
  • j
Here is a list of all enum values with links to the files they belong to:

- j -

  • JY6311_AI_2Wire : JY6311Core.h
  • JY6311_AI_3Wire : JY6311Core.h
  • JY6311_AI_4Wire : JY6311Core.h
  • JY6311_AI_AdvanceTrig : JY6311Core.h
  • JY6311_AI_AnalogTrig : JY6311Core.h
  • JY6311_AI_Continuous : JY6311Core.h
  • JY6311_AI_Digital : JY6311Core.h
  • JY6311_AI_ExternalClock : JY6311Core.h
  • JY6311_AI_Finite : JY6311Core.h
  • JY6311_AI_Immediately : JY6311Core.h
  • JY6311_AI_InternalClock : JY6311Core.h
  • JY6311_AI_PT100 : JY6311Core.h
  • JY6311_AI_PT1000 : JY6311Core.h
  • JY6311_AI_Pt1000_TCR3750 : JY6311Core.h
  • JY6311_AI_Pt1000_TCR3851 : JY6311Core.h
  • JY6311_AI_Pt100_TCR3851 : JY6311Core.h
  • JY6311_AI_Pt100_TCR3911 : JY6311Core.h
  • JY6311_AI_Pt100_TCR3916 : JY6311Core.h
  • JY6311_AI_Pt100_TCR3920 : JY6311Core.h
  • JY6311_AI_Pt100_TCR3928 : JY6311Core.h
  • JY6311_AI_ReferenceTrig : JY6311Core.h
  • JY6311_AI_SampleClock : JY6311Core.h
  • JY6311_AI_Single : JY6311Core.h
  • JY6311_AI_Soft : JY6311Core.h
  • JY6311_AI_StartTrig : JY6311Core.h
  • JY6311_Clock_PFI0 : JY6311Core.h
  • JY6311_Clock_PFI1 : JY6311Core.h
  • JY6311_Clock_PFI2 : JY6311Core.h
  • JY6311_Clock_PXI_Trig0 : JY6311Core.h
  • JY6311_Clock_PXI_Trig1 : JY6311Core.h
  • JY6311_Clock_PXI_Trig2 : JY6311Core.h
  • JY6311_Clock_PXI_Trig3 : JY6311Core.h
  • JY6311_Clock_PXI_Trig4 : JY6311Core.h
  • JY6311_Clock_PXI_Trig5 : JY6311Core.h
  • JY6311_Clock_PXI_Trig6 : JY6311Core.h
  • JY6311_Clock_PXI_Trig7 : JY6311Core.h
  • JY6311_Falling : JY6311Core.h
  • JY6311_PFI0 : JY6311Core.h
  • JY6311_PFI0_IN : JY6311Core.h
  • JY6311_PFI0_OUT : JY6311Core.h
  • JY6311_PFI1 : JY6311Core.h
  • JY6311_PFI1_IN : JY6311Core.h
  • JY6311_PFI1_OUT : JY6311Core.h
  • JY6311_PFI2 : JY6311Core.h
  • JY6311_PFI2_IN : JY6311Core.h
  • JY6311_PFI2_OUT : JY6311Core.h
  • JY6311_PowerLineFrequency_50Hz : JY6311Core.h
  • JY6311_PowerLineFrequency_60Hz : JY6311Core.h
  • JY6311_PXI_Trig0 : JY6311Core.h
  • JY6311_PXI_Trig0_IN : JY6311Core.h
  • JY6311_PXI_Trig0_OUT : JY6311Core.h
  • JY6311_PXI_Trig1 : JY6311Core.h
  • JY6311_PXI_Trig1_IN : JY6311Core.h
  • JY6311_PXI_Trig1_OUT : JY6311Core.h
  • JY6311_PXI_Trig2 : JY6311Core.h
  • JY6311_PXI_Trig2_IN : JY6311Core.h
  • JY6311_PXI_Trig2_OUT : JY6311Core.h
  • JY6311_PXI_Trig3 : JY6311Core.h
  • JY6311_PXI_Trig3_IN : JY6311Core.h
  • JY6311_PXI_Trig3_OUT : JY6311Core.h
  • JY6311_PXI_Trig4 : JY6311Core.h
  • JY6311_PXI_Trig4_IN : JY6311Core.h
  • JY6311_PXI_Trig4_OUT : JY6311Core.h
  • JY6311_PXI_Trig5 : JY6311Core.h
  • JY6311_PXI_Trig5_IN : JY6311Core.h
  • JY6311_PXI_Trig5_OUT : JY6311Core.h
  • JY6311_PXI_Trig6 : JY6311Core.h
  • JY6311_PXI_Trig6_IN : JY6311Core.h
  • JY6311_PXI_Trig6_OUT : JY6311Core.h
  • JY6311_PXI_Trig7 : JY6311Core.h
  • JY6311_PXI_Trig7_IN : JY6311Core.h
  • JY6311_PXI_Trig7_OUT : JY6311Core.h
  • JY6311_ReferenceTrigger : JY6311Core.h
  • JY6311_Resistance : JY6311Core.h
  • JY6311_Rising : JY6311Core.h
  • JY6311_StartTrigger : JY6311Core.h
  • JY6311_Temperature : JY6311Core.h


  • Enumerations
  • Enumerator
  • j
Here is a list of all functions with links to the files they belong to:

- j -

  • JY6311_AI_CheckBufferStatus() : JY6311Core.h
  • JY6311_AI_EnableChannel() : JY6311Core.h
  • JY6311_AI_ReadData() : JY6311Core.h
  • JY6311_AI_ReadRawData() : JY6311Core.h
  • JY6311_AI_ReadSinglePoint() : JY6311Core.h
  • JY6311_AI_SendSoftTrigger() : JY6311Core.h
  • JY6311_AI_SetDigitalReferenceTrigger() : JY6311Core.h
  • JY6311_AI_SetDigitalStartTrigger() : JY6311Core.h
  • JY6311_AI_SetPowerLineFrequency() : JY6311Core.h
  • JY6311_AI_SetPreTriggerSamples() : JY6311Core.h
  • JY6311_AI_SetReferenceTriggerType() : JY6311Core.h
  • JY6311_AI_SetReTriggerCount() : JY6311Core.h
  • JY6311_AI_SetSampleClock() : JY6311Core.h
  • JY6311_AI_SetSampleMode() : JY6311Core.h
  • JY6311_AI_SetSampleRate() : JY6311Core.h
  • JY6311_AI_SetSamplesToAcquire() : JY6311Core.h
  • JY6311_AI_SetStartTriggerType() : JY6311Core.h
  • JY6311_AI_Start() : JY6311Core.h
  • JY6311_AI_Stop() : JY6311Core.h
  • JY6311_AI_WaitUntilDone() : JY6311Core.h
  • JY6311_Close() : JY6311Core.h
  • JY6311_DI_AddLines() : JY6311Core.h
  • JY6311_DI_ReadSinglePoint() : JY6311Core.h
  • JY6311_DI_Start() : JY6311Core.h
  • JY6311_DI_Stop() : JY6311Core.h
  • JY6311_DisableCalibration() : JY6311Core.h
  • JY6311_DisconnectSignalRouting() : JY6311Core.h
  • JY6311_DO_AddLines() : JY6311Core.h
  • JY6311_DO_Start() : JY6311Core.h
  • JY6311_DO_Stop() : JY6311Core.h
  • JY6311_DO_WriteSinglePoint() : JY6311Core.h
  • JY6311_GetDeviceID() : JY6311Core.h
  • JY6311_GetDeviceSerialNumber() : JY6311Core.h
  • JY6311_Open() : JY6311Core.h
  • JY6311_OpenByName() : JY6311Core.h
  • JY6311_SetDeviceStatusLed() : JY6311Core.h
  • JY6311_SignalRouting() : JY6311Core.h


  • Enumerations
  • Enumerator
Here is a list of all typedefs with links to the files they belong to:
  • JY6311_DeviceHandle : JY6311Core.h


6311 C++ Programming Manual: Main Page

6311 C++ Programming Manual Documentation