6311 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/6311 Directory Reference

6311 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 6311
6311 Directory Reference

Files

JY6311CoreOOAITask.h
JY6311CoreOOCommon.h
JY6311CoreOODevice.h
JY6311CoreOODITask.h
JY6311CoreOODOTask.h
JY6311CoreOOLog.h
Generated by doxygen 1.13.2


6311 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/6311/JY6311CoreOOAITask.h File Reference

  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 6311
Classes | Namespaces | Enumerations
JY6311CoreOOAITask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include <algorithm>
#include "JY6311CoreOOCommon.h"
#include "JY6311CoreOODevice.h"

Classes

class | JY6311CoreOO::JY6311CoreOOAITask
AITask类 More...
class | JY6311CoreOO::AIChannel
AI channel class. More...
class | JY6311CoreOO::AIExternalSampleClock
External Sample Clock Configuration Class. More...
class | JY6311CoreOO::AISampleClock
Sample clock configuration class. More...
class | JY6311CoreOO::AITrigger
class | JY6311CoreOO::AIDigitalTrigger
class | JY6311CoreOO::AISignalExport
AI Signal Export Source. More...

Namespaces

namespace JY6311CoreOO

Enumerations

enum class | JY6311CoreOO::AIMode { JY6311CoreOO::Single = 0 , JY6311CoreOO::Finite = 1 , JY6311CoreOO::Continuous = 2 }
AI mode enum type. More...
enum class | JY6311CoreOO::RTDTerminal { JY6311CoreOO::TwoWire = 0 , JY6311CoreOO::ThreeWire = 1 , JY6311CoreOO::FourWire = 2 }
AI RTDTerminal type. More...
enum class | JY6311CoreOO::RTDType { JY6311CoreOO::PT100 = 0 , JY6311CoreOO::PT1000 = 1 }
RTDType. More...
enum class JY6311CoreOO::RTDTCRType {
JY6311CoreOO::Pt100_TCR3851 = 0 , JY6311CoreOO::Pt100_TCR3916 = 1 , JY6311CoreOO::Pt100_TCR3920 = 2 , JY6311CoreOO::Pt100_TCR3911 = 3 ,
JY6311CoreOO::Pt100_TCR3928 = 4 , JY6311CoreOO::Pt1000_TCR3851 = 5 , JY6311CoreOO::Pt1000_TCR3750 = 6
}
RTD types supported by 6311, differentiate by TCR(temperature coefficient of resistance) More...
enum class | JY6311CoreOO::MeasurementType { JY6311CoreOO::Resistance = 0 , JY6311CoreOO::Temperature = 1 , JY6311CoreOO::Voltage }
MeasurementType. More...
enum class | JY6311CoreOO::AISampleClockSource { JY6311CoreOO::Internal , JY6311CoreOO::External }
AI SampleClockSource Type. More...
enum class | JY6311CoreOO::AITriggerType { JY6311CoreOO::Immediate = 0x0 , JY6311CoreOO::Digital = 0x1 , JY6311CoreOO::Soft = 0x2 }
Trigger Type: Digital/Soft/Immediate. More...
enum class | JY6311CoreOO::AITriggerMode { JY6311CoreOO::Start , JY6311CoreOO::Reference }
AI Trigger Mode. More...
enum class JY6311CoreOO::AIDigitalTriggerSource {
JY6311CoreOO::PFI0 , JY6311CoreOO::PFI1 , JY6311CoreOO::PFI2 , JY6311CoreOO::PXI_Trig0 = 3 ,
JY6311CoreOO::PXI_Trig1 = 4 , JY6311CoreOO::PXI_Trig2 = 5 , JY6311CoreOO::PXI_Trig3 = 6 , JY6311CoreOO::PXI_Trig4 = 7 ,
JY6311CoreOO::PXI_Trig5 = 8 , JY6311CoreOO::PXI_Trig6 = 9 , JY6311CoreOO::PXI_Trig7 = 10
}
AI Digital Trigger Source. More...
enum class | JY6311CoreOO::AIDigitalTriggerEdge { JY6311CoreOO::Rising = 0x0 , JY6311CoreOO::Falling = 0x1 }
AI Digital Trigger Edge. More...
enum class | JY6311CoreOO::AISignalExportSource { JY6311CoreOO::StartTrig = 13 , JY6311CoreOO::ReferenceTrig = 14 , JY6311CoreOO::SampleClock = 12 }
AI Signal Export Source. More...
enum class | JY6311CoreOO::PowerLineFrequency { JY6311CoreOO::_50Hz , JY6311CoreOO::_60Hz }
AC Power Line Frquency. More...


6311 C++ Programming Manual: JY6311CoreOO::JY6311CoreOOAITask Class Reference

  • Class List
  • Class Index
  • Class Members
  • JY6311CoreOO
  • JY6311CoreOOAITask
Public Member Functions | Public Attributes | List of all members
JY6311CoreOO::JY6311CoreOOAITask Class Reference

AITask类 More...

#include <JY6311CoreOOAITask.h>

Public Member Functions

JY6311CoreOOAITask (int slotNum)
JY6311CoreOOAITask (std::string boardName)
void | AddChannel (int chnsId, RTDType rtdType, RTDTCRType rtdTCRType, RTDTerminal rtdTerminal)
Add one/all rtd input channel(s) for temperature measurement.
void | AddChannel (std::vector< int > chnsId, RTDType rtdType, RTDTCRType rtdTCRType, RTDTerminal rtdTerminal)
Add a group of channels for temperature measurement.
void | AddChannel (std::vector< int > chnsId, std::vector< RTDType > rtdType, std::vector< RTDTCRType > rtdTCRType, std::vector< RTDTerminal > rtdTerminal)
Add a group of channels for temperature measurement.
void | AddChannel (int chnsId, RTDType rtdType, RTDTerminal rtdTerminal)
Add one/all general resistance input channel for Resistance measurement.
void | AddChannel (std::vector< int > chnsId, RTDType rtdType, RTDTerminal rtdTerminal)
Add a group of channels for Resistance measurement.
void | AddChannel (std::vector< int > chnsId, std::vector< RTDType > rtdType, std::vector< RTDTerminal > rtdTerminal)
Add a group of channels for Resistance measurement.
void | AddChannel (int chnsId, double rangeLow, double rangeHigh)
Add one/all general resistance input channel for Voltage Measured.
void | AddChannel (std::vector< int > chnsId, double rangeLow, double rangeHigh)
Add one/all general voltage input channel(s).
void | AddChannel (std::vector< int > chnsId, std::vector< double > rangeLow, std::vector< double > rangeHigh)
Add one/all general voltage input channel(s).
void | RemoveChannel (int chnId)
Delete the channel with the specified channel number.
void | ReadData (double *pBuf, int samplesPerChannel, int timeout=-1)
Read the multi-channel data by columns and store it in a data buffer.
void | ReadRawData (int *pBuf, int samplesPerChannel, int timeout=-1)
Read one or multi-channel raw data and store it in a data buffer.
void | ReadSinglePoint (double &readValue, int channel)
Read temperature value in ℃ on all enabled channels in unbuffered reading.
void | ReadSinglePoint (std::vector< double > &readValues)
Read temperature value in ℃ on all enabled channels in unbuffered reading.
bool | WaitUntilDone (int timeout)
Check that the finite point acquisition is complete.
void | Start ()
Start AITask.
void | SendSoftwareTrigger ()
void | Stop ()
Stop AITask.
~JY6311CoreOOAITask ()

Public Attributes

std::list< AIChannel * > | Channels
List of AI channels,(6311 support 16 channel)
JY6311CoreOOProperty< JY6311CoreOOAITask, double, JY6311CoreOOPropertyType::READ_WRITE > | SampleRate
Sampling rate per channel (Sample/s).
int | SamplesToAcquire
Number of samples to be read per channel.
JY6311CoreOOProperty< JY6311CoreOOAITask, int, JY6311CoreOOPropertyType::READ_ONLY > | BufLenInSamples
Number of samples per channel can be storage in the buffer, the Property SamplesToAcquire must be less than or equal to this value.
JY6311CoreOOProperty< JY6311CoreOOAITask, uint64_t, JY6311CoreOOPropertyType::READ_ONLY > | AvailableSamples
Number of samples per channel that can be read in the buffer .
JY6311CoreOOProperty< JY6311CoreOOAITask, uint64_t, JY6311CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
AIMode Mode
AI acquisition mode, support Single/Finite/Continuous*.
AISampleClock * SampleClock
AI Sample Clock.
AITrigger * Trigger
AI Trigger Configuration.
bool | DisableCalibration
Disalble calibration Enable.
AISignalExport * SignalExport
Export AI Signal Configuration.
PowerLineFrequency PowerLine_Frequency
PowerLineFrequency.
JY6311CoreOODevice * Device
Device.

Detailed Description

AITask类

Constructor & Destructor Documentation

◆ JY6311CoreOOAITask() [1/2]

JY6311CoreOO::JY6311CoreOOAITask::JY6311CoreOOAITask ( int slotNum )

◆ JY6311CoreOOAITask() [2/2]

JY6311CoreOO::JY6311CoreOOAITask::JY6311CoreOOAITask ( std::string boardName )

◆ ~JY6311CoreOOAITask()

JY6311CoreOO::JY6311CoreOOAITask::~JY6311CoreOOAITask ( )

Member Function Documentation

◆ AddChannel() [1/9]

void JY6311CoreOO::JY6311CoreOOAITask::AddChannel | ( | int | chnsId,
 |  | double | rangeLow,
 |  | double | rangeHigh )

Add one/all general resistance input channel for Voltage Measured.

Parameters
channelID Channel's physical number. chnId = -1: add all channels.

◆ AddChannel() [2/9]

void JY6311CoreOO::JY6311CoreOOAITask::AddChannel | ( | int | chnsId,
 |  | RTDType | rtdType,
 |  | RTDTCRType | rtdTCRType,
 |  | RTDTerminal | rtdTerminal )

Add one/all rtd input channel(s) for temperature measurement.

Parameters
channelID | Channel's physical number. chnId = -1: add all channels.
rtdType | RTD Type
rtdTerminal | RTD Terminal
rtdTCRType | RTD TCR Type
MeasurementType | Measure data Type

◆ AddChannel() [3/9]

void JY6311CoreOO::JY6311CoreOOAITask::AddChannel | ( | int | chnsId,
 |  | RTDType | rtdType,
 |  | RTDTerminal | rtdTerminal )

Add one/all general resistance input channel for Resistance measurement.

Parameters
channelID | Channel's physical number. chnId = -1: add all channels.
rtdType | RTD Type
rtdTerminal | RTD Terminal

◆ AddChannel() [4/9]

void JY6311CoreOO::JY6311CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | double | rangeLow,
 |  | double | rangeHigh )

Add one/all general voltage input channel(s).

Parameters
chID | IDs of channels to add.
voltageRangeLow | Voltage input range low limit in V. -1.25V / -0.625V / -0.3125V / -0.1562V optional.
voltageRangeHigh | Voltage input range high limit in V. +1.25V / +0.625V / +0.3125V / +0.1562V optional.

◆ AddChannel() [5/9]

void JY6311CoreOO::JY6311CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | RTDType | rtdType,
 |  | RTDTCRType | rtdTCRType,
 |  | RTDTerminal | rtdTerminal )

Add a group of channels for temperature measurement.

Parameters
channelID | a group of channel physical numbers （6311 0-16）
rtdType | RTD Type
rtdTerminal | RTD Terminal
rtdTCRType | RTD TCR Type
MeasurementType | Measure data Type

◆ AddChannel() [6/9]

void JY6311CoreOO::JY6311CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | RTDType | rtdType,
 |  | RTDTerminal | rtdTerminal )

Add a group of channels for Resistance measurement.

Parameters
channelID | a group of channel physical numbers （6311 0-16）
rtdType | RTD Type
rtdTerminal | RTD Terminal

◆ AddChannel() [7/9]

void JY6311CoreOO::JY6311CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | std::vector< double > | rangeLow,
 |  | std::vector< double > | rangeHigh )

Add one/all general voltage input channel(s).

Parameters
chID | IDs of channels to add.
voltageRangeLow | Voltage input range low limit in V. -1.25V / -0.625V / -0.3125V / -0.1562V optional.
voltageRangeHigh | Voltage input range high limit in V. +1.25V / +0.625V / +0.3125V / +0.1562V optional.

◆ AddChannel() [8/9]

void JY6311CoreOO::JY6311CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | std::vector< RTDType > | rtdType,
 |  | std::vector< RTDTCRType > | rtdTCRType,
 |  | std::vector< RTDTerminal > | rtdTerminal )

Add a group of channels for temperature measurement.

Parameters
chnsId | a group of channel physical numbers （6311 0-16）
rtdType | a group of RTD Type
rtdTerminal | a group of RTD Terminal
rtdTCRType | a group of RTD TCR Type

◆ AddChannel() [9/9]

void JY6311CoreOO::JY6311CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | std::vector< RTDType > | rtdType,
 |  | std::vector< RTDTerminal > | rtdTerminal )

Add a group of channels for Resistance measurement.

Parameters
chnsId | a group of channel physical numbers （6311 0-16）
rtdType | a group of RTD Type
rtdTerminal | a group of RTD Terminal

◆ ReadData()

void JY6311CoreOO::JY6311CoreOOAITask::ReadData | ( | double * | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = -1 )

Read the multi-channel data by columns and store it in a data buffer.

Each channel is represented by one column of data.

Parameters
pBuf | Data buffer
samplesPerChannel | Number of samples per channel to read
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadRawData()

void JY6311CoreOO::JY6311CoreOOAITask::ReadRawData | ( | int * | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = -1 )

Read one or multi-channel raw data and store it in a data buffer.

Parameters
buf | Data buffer.Raw Data
samplesPerChannel | Number of samples per channel.
timeout | Timeout in ms before generating error message, timeout =-1 keep waiting until finish.

◆ ReadSinglePoint() [1/2]

void JY6311CoreOO::JY6311CoreOOAITask::ReadSinglePoint | ( | double & | readValue,
 |  | int | channel )

Read temperature value in ℃ on all enabled channels in unbuffered reading.

Parameters
buf Data buffer

◆ ReadSinglePoint() [2/2]

void JY6311CoreOO::JY6311CoreOOAITask::ReadSinglePoint ( std::vector< double > & readValues )

Read temperature value in ℃ on all enabled channels in unbuffered reading.

Parameters
buf Data buffer

◆ RemoveChannel()

void JY6311CoreOO::JY6311CoreOOAITask::RemoveChannel ( int chnId )

Delete the channel with the specified channel number.

Parameters
channelID Specified channel ID. chnId = -1: remove all channels.

◆ SendSoftwareTrigger()

void JY6311CoreOO::JY6311CoreOOAITask::SendSoftwareTrigger ( )

◆ Start()

void JY6311CoreOO::JY6311CoreOOAITask::Start ( )

Start AITask.

summary> Send software trigger /summary> param name="hDevice">device handle

param name="triggerMode">software trigger mode.Options:start trigger mode,reference trigger mode,advance trigger mode

Returns
0 if success or other error code

◆ Stop()

void JY6311CoreOO::JY6311CoreOOAITask::Stop ( )

Stop AITask.

◆ WaitUntilDone()

bool JY6311CoreOO::JY6311CoreOOAITask::WaitUntilDone ( int timeout )

Check that the finite point acquisition is complete.

Parameters
timeout timeout unit：ms

returns whether the finite point acquisition is complete(true/false)

Returns
0 if success or other error code

Member Data Documentation

◆ AvailableSamples

JY6311CoreOOProperty<JY6311CoreOOAITask, uint64_t, JY6311CoreOOPropertyType::READ_ONLY> JY6311CoreOO::JY6311CoreOOAITask::AvailableSamples

Number of samples per channel that can be read in the buffer .

Valid when Mode is NOT AIMode.Single.

◆ BufLenInSamples

JY6311CoreOOProperty<JY6311CoreOOAITask, int, JY6311CoreOOPropertyType::READ_ONLY> JY6311CoreOO::JY6311CoreOOAITask::BufLenInSamples

Number of samples per channel can be storage in the buffer, the Property SamplesToAcquire must be less than or equal to this value.

◆ Channels

std::list<AIChannel*> JY6311CoreOO::JY6311CoreOOAITask::Channels

List of AI channels,(6311 support 16 channel)

◆ Device

JY6311CoreOODevice* JY6311CoreOO::JY6311CoreOOAITask::Device

Device.

◆ DisableCalibration

bool JY6311CoreOO::JY6311CoreOOAITask::DisableCalibration

Disalble calibration Enable.

◆ Mode

AIMode JY6311CoreOO::JY6311CoreOOAITask::Mode

AI acquisition mode, support Single/Finite/Continuous*.

◆ PowerLine_Frequency

PowerLineFrequency JY6311CoreOO::JY6311CoreOOAITask::PowerLine_Frequency

PowerLineFrequency.

6311 can reject 50Hz or 60Hz components when the TOTAL sampling rate is less than or equal to 40Sa/s.

◆ SampleClock

AISampleClock* JY6311CoreOO::JY6311CoreOOAITask::SampleClock

AI Sample Clock.

◆ SampleRate

JY6311CoreOOProperty<JY6311CoreOOAITask, double, JY6311CoreOOPropertyType::READ_WRITE> JY6311CoreOO::JY6311CoreOOAITask::SampleRate

Sampling rate per channel (Sample/s).

The minimum is 0.275Sa/s and the maximum is 800Sa/s. The actual sampling rate is subject to the timing mode, the number of channels, and the rounding operation. You can read this property to obtain the sampling rate that will actually take effect in the current configuration. This property is invalid when JY6311AITask.Mode is AIMode.Single.

◆ SamplesToAcquire

int JY6311CoreOO::JY6311CoreOOAITask::SamplesToAcquire

Number of samples to be read per channel.

Only valid when Mode is Finite*

◆ SignalExport

AISignalExport* JY6311CoreOO::JY6311CoreOOAITask::SignalExport

Export AI Signal Configuration.

◆ TransferedSamples

JY6311CoreOOProperty<JY6311CoreOOAITask, uint64_t, JY6311CoreOOPropertyType::READ_ONLY> JY6311CoreOO::JY6311CoreOOAITask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT AIMode.Single.

◆ Trigger

AITrigger* JY6311CoreOO::JY6311CoreOOAITask::Trigger

AI Trigger Configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6311/JY6311CoreOOAITask.h


6311 C++ Programming Manual: JY6311CoreOO::AIChannel Class Reference

  • JY6311CoreOO
  • AIChannel
Public Member Functions | Public Attributes | List of all members
JY6311CoreOO::AIChannel Class Reference

AI channel class. More...

#include <JY6311CoreOOAITask.h>

Public Member Functions

AIChannel (int channelId, RTDType RTDtype=RTDType::PT100, RTDTCRType RTDTCRtype=RTDTCRType::Pt100_TCR3851, RTDTerminal terminalType=RTDTerminal::TwoWire)
Temperature Measured.
AIChannel (int channelId, RTDType RTDtype=RTDType::PT100, RTDTerminal terminalType=RTDTerminal::TwoWire)
Resistance Measured.
AIChannel (int channelId, double voltageRangeLow, double voltageRangeHigh)
Voltage Measured.

Public Attributes

int | ChannelID
MeasurementType MeasurementType1
RTDType RTDtype1
RTDTerminal terminalType1
RTDTCRType RTDTCRtype1
double | VoltageRangeLow
double | VoltageRangeHigh

Detailed Description

AI channel class.

Constructor & Destructor Documentation

◆ AIChannel() [1/3]

JY6311CoreOO::AIChannel::AIChannel | ( | int | channelId,
 |  | RTDType | RTDtype = RTDType::PT100,
 |  | RTDTCRType | RTDTCRtype = RTDTCRType::Pt100_TCR3851,
 |  | RTDTerminal | terminalType = RTDTerminal::TwoWire )

Temperature Measured.

◆ AIChannel() [2/3]

JY6311CoreOO::AIChannel::AIChannel | ( | int | channelId,
 |  | RTDType | RTDtype = RTDType::PT100,
 |  | RTDTerminal | terminalType = RTDTerminal::TwoWire )

Resistance Measured.

◆ AIChannel() [3/3]

JY6311CoreOO::AIChannel::AIChannel | ( | int | channelId,
 |  | double | voltageRangeLow,
 |  | double | voltageRangeHigh )

Voltage Measured.

Member Data Documentation

◆ ChannelID

int JY6311CoreOO::AIChannel::ChannelID

◆ MeasurementType1

MeasurementType JY6311CoreOO::AIChannel::MeasurementType1

◆ RTDTCRtype1

RTDTCRType JY6311CoreOO::AIChannel::RTDTCRtype1

◆ RTDtype1

RTDType JY6311CoreOO::AIChannel::RTDtype1

◆ terminalType1

RTDTerminal JY6311CoreOO::AIChannel::terminalType1

◆ VoltageRangeHigh

double JY6311CoreOO::AIChannel::VoltageRangeHigh

◆ VoltageRangeLow

double JY6311CoreOO::AIChannel::VoltageRangeLow
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6311/JY6311CoreOOAITask.h


6311 C++ Programming Manual: JY6311CoreOO::AIExternalSampleClock Class Reference

  • AIExternalSampleClock
Public Attributes | List of all members
JY6311CoreOO::AIExternalSampleClock Class Reference

External Sample Clock Configuration Class. More...

#include <JY6311CoreOOAITask.h>

Public Attributes

ClockTerminal Terminal
External Sample Clock Input Terminal.
double ExpectedRate
Expected External Sample Clock Rate.

Detailed Description

External Sample Clock Configuration Class.

Member Data Documentation

◆ ExpectedRate

double JY6311CoreOO::AIExternalSampleClock::ExpectedRate

Expected External Sample Clock Rate.

◆ Terminal

ClockTerminal JY6311CoreOO::AIExternalSampleClock::Terminal

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6311/JY6311CoreOOAITask.h


6311 C++ Programming Manual: JY6311CoreOO::AISampleClock Class Reference

  • AISampleClock
Public Attributes | List of all members
JY6311CoreOO::AISampleClock Class Reference

Sample clock configuration class. More...

#include <JY6311CoreOOAITask.h>

Public Attributes

AISampleClockSource Source
AI Sample Clock Source.
AIExternalSampleClock * External
External Sample Clock Configuration.

Detailed Description

Sample clock configuration class.

Member Data Documentation

◆ External

AIExternalSampleClock* JY6311CoreOO::AISampleClock::External

External Sample Clock Configuration.

Valid when Source is AISampleClockSource.External.

◆ Source

AISampleClockSource JY6311CoreOO::AISampleClock::Source

AI Sample Clock Source.

enum Internal/External. The default value is AISampleClockSource.Internal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6311/JY6311CoreOOAITask.h


6311 C++ Programming Manual: JY6311CoreOO::AITrigger Class Reference

  • AITrigger
Public Attributes | List of all members
JY6311CoreOO::AITrigger Class Reference

#include <JY6311CoreOOAITask.h>

Public Attributes

AITriggerType Type
AI trigger type.
AITriggerMode Mode
AI trigger mode.
AIDigitalTrigger * Digital
Digital Trigger Congfiguration.
int | ReTriggerCount
Number of repeat triggers.
unsigned int | PreTriggerSamples
AI pretrigger samples, must be less than or equal to JY6311AITask.SamplesToAcquire.

Member Data Documentation

◆ Digital

AIDigitalTrigger* JY6311CoreOO::AITrigger::Digital

Digital Trigger Congfiguration.

Valid when Type is AITriggerType.Digital.

◆ Mode

AITriggerMode JY6311CoreOO::AITrigger::Mode

AI trigger mode.

enum Start/Reference. The default value is AITriggerMode.Start.

◆ PreTriggerSamples

unsigned int JY6311CoreOO::AITrigger::PreTriggerSamples

AI pretrigger samples, must be less than or equal to JY6311AITask.SamplesToAcquire.

Valid when Mode is AITriggerMode.Reference. Pretrigger samples, must be greater than 1. Valid when Type is AITriggerType.Digital.

◆ ReTriggerCount

int JY6311CoreOO::AITrigger::ReTriggerCount

Number of repeat triggers.

When 0 or 1 only trigger once, When -1 continuous retrigger until stop.

◆ Type

AITriggerType JY6311CoreOO::AITrigger::Type

AI trigger type.

enum Digital/Immediate/Soft. The default value is AITriggerType.Immediate.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6311/JY6311CoreOOAITask.h


6311 C++ Programming Manual: JY6311CoreOO::AIDigitalTrigger Class Reference

  • AIDigitalTrigger
Public Attributes | List of all members
JY6311CoreOO::AIDigitalTrigger Class Reference

#include <JY6311CoreOOAITask.h>

Public Attributes

AIDigitalTriggerSource Source
AI Digital Trigger source.
AIDigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Member Data Documentation

◆ Edge

AIDigitalTriggerEdge JY6311CoreOO::AIDigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

AIDigitalTriggerSource JY6311CoreOO::AIDigitalTrigger::Source

AI Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6311/JY6311CoreOOAITask.h


6311 C++ Programming Manual: JY6311CoreOO::AISignalExport Class Reference

  • AISignalExport
Public Member Functions | List of all members
JY6311CoreOO::AISignalExport Class Reference

AI Signal Export Source. More...

#include <JY6311CoreOOAITask.h>

Public Member Functions

void | Add (AISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (AISignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

AI Signal Export Source.

Member Function Documentation

◆ Add() [1/2]

void JY6311CoreOO::AISignalExport::Add | ( | AISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | AI Signal Source
destination | Export Desination

◆ Add() [2/2]

void JY6311CoreOO::AISignalExport::Add | ( | AISignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | AI Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JY6311CoreOO::AISignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY6311CoreOO::AISignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6311/JY6311CoreOOAITask.h


6311 C++ Programming Manual: JY6311CoreOO Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Enumerations | Functions
JY6311CoreOO Namespace Reference

Classes

class | AIChannel
AI channel class. More...
class | AIDigitalTrigger
class | AIExternalSampleClock
External Sample Clock Configuration Class. More...
class | AISampleClock
Sample clock configuration class. More...
class | AISignalExport
AI Signal Export Source. More...
class | AITrigger
class | DIChannel
DI Channel parameter class . More...
class | DOChannel
DO Channel parameter class . More...
class | ExternalReferenceClock
class | JY6311CoreOOAITask
AITask类 More...
class | JY6311CoreOODevice
class | JY6311CoreOODITask
class | JY6311CoreOODOTask
class | JY6311CoreOOLog
class | JY6311CoreOOProperty
属性模板类 More...
class | JY6311CoreOOReferenceClock
class | JYDriverException
class | PauseTrigger
Pause trigger configuration class. More...
class | PFIFilter
class | PFISetting

Enumerations

enum class | AIMode { Single = 0 , Finite = 1 , Continuous = 2 }
AI mode enum type. More...
enum class | RTDTerminal { TwoWire = 0 , ThreeWire = 1 , FourWire = 2 }
AI RTDTerminal type. More...
enum class | RTDType { PT100 = 0 , PT1000 = 1 }
RTDType. More...
enum class RTDTCRType {
Pt100_TCR3851 = 0 , Pt100_TCR3916 = 1 , Pt100_TCR3920 = 2 , Pt100_TCR3911 = 3 ,
Pt100_TCR3928 = 4 , Pt1000_TCR3851 = 5 , Pt1000_TCR3750 = 6
}
RTD types supported by 6311, differentiate by TCR(temperature coefficient of resistance) More...
enum class | MeasurementType { Resistance = 0 , Temperature = 1 , Voltage }
MeasurementType. More...
enum class | AISampleClockSource { Internal , External }
AI SampleClockSource Type. More...
enum class | AITriggerType { Immediate = 0x0 , Digital = 0x1 , Soft = 0x2 }
Trigger Type: Digital/Soft/Immediate. More...
enum class | AITriggerMode { Start , Reference }
AI Trigger Mode. More...
enum class AIDigitalTriggerSource {
PFI0 , PFI1 , PFI2 , PXI_Trig0 = 3 ,
PXI_Trig1 = 4 , PXI_Trig2 = 5 , PXI_Trig3 = 6 , PXI_Trig4 = 7 ,
PXI_Trig5 = 8 , PXI_Trig6 = 9 , PXI_Trig7 = 10
}
AI Digital Trigger Source. More...
enum class | AIDigitalTriggerEdge { Rising = 0x0 , Falling = 0x1 }
AI Digital Trigger Edge. More...
enum class | AISignalExportSource { StartTrig = 13 , ReferenceTrig = 14 , SampleClock = 12 }
AI Signal Export Source. More...
enum class | PowerLineFrequency { _50Hz , _60Hz }
AC Power Line Frquency. More...
enum class | JY6311CoreOOPropertyType { READ_ONLY = 1 , WRITE_ONLY = 2 , READ_WRITE = 3 }
enum class JYDriverExceptionPublic {
UnKnown = 0 , OpenDeviceFailed = -10001 , CloseDeviceFailed = -10002 , ResetDeviceFailed = -10003 ,
GetDevicePropertyFailed = -10004 , SetDevicePropertyFailed = -10005 , HardwareResourceIsReserved = -10006 , MethodNotPermitedToCallWhenCurrentStatus = -10007 ,
InvalidUserDataBuffer = -10008 , NoChannelAdded = -10009 , NotSupportOperationForCurrentDevice = -10010 , CreatTaskFailed = -10100 ,
StartTaskFailed = -10101 , StopTaskFailed = -10102 , TaskHasNotStarted = -10103 , TaskHasStartedCannotPerformTheSetOperation = -10104 ,
ChannelNumberParameterInvalid = -10105 , ChannelInputRangeParameterInvalid = -10106 , ChannelTerminalParameterInvalid = -10107 , ChannelCouplingParameterInvalid = -10108 ,
SampeleModeParameterInvalid = -10109 , SampleClockParameterInvalid = -10110 , SampleRateParameterInvalid = -10111 , UpdateRateParameterInvalid = -10112 ,
TriggerParameterInvalid = -10113 , ReferenceTriggerDoesNotMatchWithSampleMode = -10114 , PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint = -10115 , ReadDataFailed = -10016 ,
ReadDataTimeout = -10017 , WriteDataFailed = -10018 , WriteDataTimeout = -10019 , WriteDataLengthCannotBeLessThanN = -10020 ,
BufferDataOverflow = -10021 , BufferDataDownflow = -10022 , CheckBufferFailed = -10023 , PointInvalidInFiniteMode = -10024 ,
ReadPointInvalid = -10025 , OnlySupportRecordMode = -10026 , SendSoftTirggerFailed = -10027 , TaskTimeout = -10028 ,
CounterParametersInvalid = -10029 , WritePointInvalid = -10030 , SignalExportDestinationInvalid = -10031 , InvalidParameter = -10033
}
enum class ClockTerminal {
PFI0 = 0 , PFI1 = 1 , PFI2 = 2 , PXI_Trig0 = 3 ,
PXI_Trig1 = 4 , PXI_Trig2 = 5 , PXI_Trig3 = 6 , PXI_Trig4 = 7 ,
PXI_Trig5 = 8 , PXI_Trig6 = 9 , PXI_Trig7 = 10
}
enum class SignalExportDestination {
PFI0 , PFI1 , PFI2 , PXI_Trig0 = 3 ,
PXI_Trig1 = 4 , PXI_Trig2 = 5 , PXI_Trig3 = 6 , PXI_Trig4 = 7 ,
PXI_Trig5 = 8 , PXI_Trig6 = 9 , PXI_Trig7 = 10
}
enum class | OutputCompleteState { Zero , Hold }
Output Complete State. More...
enum class IOTerminal {
Default = 0 , PXI_Trig0 = 0x20 , PXI_Trig1 = 0x21 , PXI_Trig2 = 0x22 ,
PXI_Trig3 = 0x23 , PXI_Trig4 = 0x24 , PXI_Trig5 = 0x25 , PXI_Trig6 = 0x26 ,
PXI_Trig7 = 0x27
}
Cunter IO Terminal. More...
enum class | LevelPolarity { LowLevel = 0 , HighLevel = 1 , None = 2 }
Level Polarity. More...
enum class InputTerminal {
Default = 0 , PXI_Trig0 = 3 , PXI_Trig1 = 4 , PXI_Trig2 = 5 ,
PXI_Trig3 = 6 , PXI_Trig4 = 7 , PXI_Trig5 = 8 , PXI_Trig6 = 9 ,
PXI_Trig7 = 10
}
Cunter Input Terminal. More...
enum class | ExternalReferenceClockTerminal { PXIe_Clk100 = 0x1 }
enum class | ReferenceClockSource { Internal = 0x0 , External = 0x1 }
enum class PFITerminal {
PFI0 = 0 , PFI1 = 1 , PFI2 = 2 , PFI3 = 3 ,
PFI4 = 4 , PFI5 = 5 , PFI6 = 6 , PFI7 = 7 ,
PFI8 = 8 , PFI9 = 9 , PFI10 = 10 , PFI11 = 11 ,
PFI12 = 12 , PFI13 = 13 , PFI14 = 14 , PFI15 = 15
}
Input/Output Terminal of PFI. More...
enum class JY6311CoreOOLogLevel {
DEBUG_LOG_LEVEL , INFO_LOG_LEVEL , WARN_LOG_LEVEL , ERROR_LOG_LEVEL ,
FATAL_LOG_LEVEL
}

Functions

std::string GetSignalExportDestinationString (SignalExportDestination destination)

Enumeration Type Documentation

◆ AIDigitalTriggerEdge

enum class JY6311CoreOO::AIDigitalTriggerEdge
strong

AI Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ AIDigitalTriggerSource

enum class JY6311CoreOO::AIDigitalTriggerSource
strong

AI Digital Trigger Source.

Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.

◆ AIMode

enum class JY6311CoreOO::AIMode
strong

AI mode enum type.

Enumerator
Single | Single point mode.
Finite | Finite mode.
Continuous | Continuous mode.

◆ AISampleClockSource

enum class JY6311CoreOO::AISampleClockSource
strong

AI SampleClockSource Type.

Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ AISignalExportSource

enum class JY6311CoreOO::AISignalExportSource
strong

AI Signal Export Source.

Enumerator
StartTrig | AI_StartTrig.
ReferenceTrig | AI_ReferenceTrig.
SampleClock | AI_SampleClock.

◆ AITriggerMode

enum class JY6311CoreOO::AITriggerMode
strong

AI Trigger Mode.

Enumerator
Start | Start Trigger.
Reference | Reference Trigger，Valid when JY6311AITask.Mode is AIMode.Finite

◆ AITriggerType

enum class JY6311CoreOO::AITriggerType
strong

Trigger Type: Digital/Soft/Immediate.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ ClockTerminal

enum class JY6311CoreOO::ClockTerminal
strong
Enumerator
PFI0 | PFI0 as the external sample clock to rout. PFI1 as the external sample clock to rout.
PFI1 | PFI2 as the external sample clock to rout.
PFI2 | PXITrigger0 as the external sample clock to rout.
PXI_Trig0 | PXITrigger1 as the external sample clock to rout.
PXI_Trig1 | PXITrigger2 as the external sample clock to rout.
PXI_Trig2 | PXITrigger3 as the external sample clock to rout.
PXI_Trig3 | PXITrigger4 as the external sample clock to rout.
PXI_Trig4 | PXITrigger5 as the external sample clock to rout.
PXI_Trig5 | PXITrigger6 as the external sample clock to rout.
PXI_Trig6 | PXITrigger7 as the external sample clock to rout.
PXI_Trig7 |

◆ ExternalReferenceClockTerminal

enum class JY6311CoreOO::ExternalReferenceClockTerminal
strong
Enumerator
PXIe_Clk100

PXIe_Clk100.

◆ InputTerminal

enum class JY6311CoreOO::InputTerminal
strong

Cunter Input Terminal.

Enumerator
Default | Default PFI pin by pin define.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.

◆ IOTerminal

enum class JY6311CoreOO::IOTerminal
strong

Cunter IO Terminal.

Enumerator
Default | Default PFI pin by pin define.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.

◆ JY6311CoreOOLogLevel

enum class JY6311CoreOO::JY6311CoreOOLogLevel
strong
Enumerator
DEBUG_LOG_LEVEL
INFO_LOG_LEVEL
WARN_LOG_LEVEL
ERROR_LOG_LEVEL
FATAL_LOG_LEVEL

◆ JY6311CoreOOPropertyType

enum class JY6311CoreOO::JY6311CoreOOPropertyType
strong
Enumerator
READ_ONLY
WRITE_ONLY
READ_WRITE

◆ JYDriverExceptionPublic

enum class JY6311CoreOO::JYDriverExceptionPublic
strong
Enumerator
UnKnown | JYDriverExceptionPublic.
OpenDeviceFailed | JYDriverExceptionPublic.
CloseDeviceFailed | JYDriverExceptionPublic.
ResetDeviceFailed | JYDriverExceptionPublic.
GetDevicePropertyFailed | JYDriverExceptionPublic.
SetDevicePropertyFailed | JYDriverExceptionPublic.
HardwareResourceIsReserved | JYDriverExceptionPublic.
MethodNotPermitedToCallWhenCurrentStatus | JYDriverExceptionPublic.
InvalidUserDataBuffer | JYDriverExceptionPublic.
NoChannelAdded | JYDriverExceptionPublic.
NotSupportOperationForCurrentDevice | JYDriverExceptionPublic.
CreatTaskFailed | JYDriverExceptionPublic.
StartTaskFailed | JYDriverExceptionPublic.
StopTaskFailed | JYDriverExceptionPublic.
TaskHasNotStarted | JYDriverExceptionPublic.
TaskHasStartedCannotPerformTheSetOperation | JYDriverExceptionPublic.
ChannelNumberParameterInvalid | JYDriverExceptionPublic.
ChannelInputRangeParameterInvalid | JYDriverExceptionPublic.
ChannelTerminalParameterInvalid | JYDriverExceptionPublic.
ChannelCouplingParameterInvalid | JYDriverExceptionPublic.
SampeleModeParameterInvalid | JYDriverExceptionPublic.
SampleClockParameterInvalid | JYDriverExceptionPublic.
SampleRateParameterInvalid | JYDriverExceptionPublic.
UpdateRateParameterInvalid | JYDriverExceptionPublic.
TriggerParameterInvalid | JYDriverExceptionPublic.
ReferenceTriggerDoesNotMatchWithSampleMode | JYDriverExceptionPublic.
PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint | JYDriverExceptionPublic.
ReadDataFailed | JYDriverExceptionPublic.
ReadDataTimeout | JYDriverExceptionPublic.
WriteDataFailed | JYDriverExceptionPublic.
WriteDataTimeout | JYDriverExceptionPublic.
WriteDataLengthCannotBeLessThanN | JYDriverExceptionPublic.
BufferDataOverflow | JYDriverExceptionPublic.
BufferDataDownflow | JYDriverExceptionPublic.
CheckBufferFailed | JYDriverExceptionPublic.
PointInvalidInFiniteMode | JYDriverExceptionPublic.
ReadPointInvalid | JYDriverExceptionPublic.
OnlySupportRecordMode | JYDriverExceptionPublic.
SendSoftTirggerFailed | JYDriverExceptionPublic.
TaskTimeout | JYDriverExceptionPublic.
CounterParametersInvalid | JYDriverExceptionPublic.
WritePointInvalid | JYDriverExceptionPublic.
SignalExportDestinationInvalid | JYDriverExceptionPublic.
InvalidParameter | 无效参数。 Invalid parameter.

◆ LevelPolarity

enum class JY6311CoreOO::LevelPolarity
strong

Level Polarity.

Enumerator
LowLevel | Low level.
HighLevel | High level.
None | No active polarity.

◆ MeasurementType

enum class JY6311CoreOO::MeasurementType
strong

MeasurementType.

Enumerator
Resistance | 电阻值
Temperature | 温度值
Voltage | 电压值

◆ OutputCompleteState

enum class JY6311CoreOO::OutputCompleteState
strong

Output Complete State.

Enumerator
Zero | Output Complete Zero.
Hold | Output Complete Hold in The last point.

◆ PFITerminal

enum class JY6311CoreOO::PFITerminal
strong

Input/Output Terminal of PFI.

Enumerator
PFI0 | PFI 0.
PFI1 | PFI 1.
PFI2 | PFI 2.
PFI3 | PFI 3.
PFI4 | PFI 4.
PFI5 | PFI 5.
PFI6 | PFI 6.
PFI7 | PFI 7.
PFI8 | PFI 8.
PFI9 | PFI 9.
PFI10 | PFI 10.
PFI11 | PFI 11.
PFI12 | PFI 12.
PFI13 | PFI 13.
PFI14 | PFI 14.
PFI15 | PFI 15.

◆ PowerLineFrequency

enum class JY6311CoreOO::PowerLineFrequency
strong

AC Power Line Frquency.

Enumerator
_50Hz | 50Hz
_60Hz | 60Hz

◆ ReferenceClockSource

enum class JY6311CoreOO::ReferenceClockSource
strong
Enumerator
Internal | Internal on board 25MHz Clock.
External | External Reference Clock Source.

◆ RTDTCRType

enum class JY6311CoreOO::RTDTCRType
strong

RTD types supported by 6311, differentiate by TCR(temperature coefficient of resistance)

Enumerator
Pt100_TCR3851 | TCR = 3951, R0 = 100ohm. Most common.
Pt100_TCR3916 | TCR = 3916, R0 = 100ohm.
Pt100_TCR3920 | TCR = 3920, R0 = 100ohm.
Pt100_TCR3911 | TCR = 3911, R0 = 100ohm.
Pt100_TCR3928 | TCR = 3928, R0 = 100ohm.
Pt1000_TCR3851 | Pt1000_TCR3851.
Pt1000_TCR3750 | Pt100_TCR3750.

◆ RTDTerminal

enum class JY6311CoreOO::RTDTerminal
strong

AI RTDTerminal type.

Enumerator
TwoWire | 2-wire terminal
ThreeWire | 3-wire terminal
FourWire | 4-wire terminal

◆ RTDType

enum class JY6311CoreOO::RTDType
strong

RTDType.

Enumerator
PT100 | PT100.
PT1000 | PT1000.

◆ SignalExportDestination

enum class JY6311CoreOO::SignalExportDestination
strong
Enumerator
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.

Function Documentation

◆ GetSignalExportDestinationString()

std::string JY6311CoreOO::GetSignalExportDestinationString ( SignalExportDestination destination )
inline


6311 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/6311/JY6311CoreOOCommon.h File Reference

  • File List
  • File Members
  • COO
  • 6311
Classes | Namespaces | Macros | Enumerations | Functions
JY6311CoreOOCommon.h File Reference
#include <string>
#include <stdint.h>

Classes

class | JY6311CoreOO::JYDriverException
class | JY6311CoreOO::JY6311CoreOOProperty< ContainerClass, ValueType, propertyType >
属性模板类 More...
class | JY6311CoreOO::PauseTrigger
Pause trigger configuration class. More...

Namespaces

namespace JY6311CoreOO

Macros

#define | EXTERN_C extern
Windows.
#define | JY6311CoreOO_API

Enumerations

enum class | JY6311CoreOO::JY6311CoreOOPropertyType { JY6311CoreOO::READ_ONLY = 1 , JY6311CoreOO::WRITE_ONLY = 2 , JY6311CoreOO::READ_WRITE = 3 }
enum class JY6311CoreOO::JYDriverExceptionPublic {
JY6311CoreOO::UnKnown = 0 , JY6311CoreOO::OpenDeviceFailed = -10001 , JY6311CoreOO::CloseDeviceFailed = -10002 , JY6311CoreOO::ResetDeviceFailed = -10003 ,
JY6311CoreOO::GetDevicePropertyFailed = -10004 , JY6311CoreOO::SetDevicePropertyFailed = -10005 , JY6311CoreOO::HardwareResourceIsReserved = -10006 , JY6311CoreOO::MethodNotPermitedToCallWhenCurrentStatus = -10007 ,
JY6311CoreOO::InvalidUserDataBuffer = -10008 , JY6311CoreOO::NoChannelAdded = -10009 , JY6311CoreOO::NotSupportOperationForCurrentDevice = -10010 , JY6311CoreOO::CreatTaskFailed = -10100 ,
JY6311CoreOO::StartTaskFailed = -10101 , JY6311CoreOO::StopTaskFailed = -10102 , JY6311CoreOO::TaskHasNotStarted = -10103 , JY6311CoreOO::TaskHasStartedCannotPerformTheSetOperation = -10104 ,
JY6311CoreOO::ChannelNumberParameterInvalid = -10105 , JY6311CoreOO::ChannelInputRangeParameterInvalid = -10106 , JY6311CoreOO::ChannelTerminalParameterInvalid = -10107 , JY6311CoreOO::ChannelCouplingParameterInvalid = -10108 ,
JY6311CoreOO::SampeleModeParameterInvalid = -10109 , JY6311CoreOO::SampleClockParameterInvalid = -10110 , JY6311CoreOO::SampleRateParameterInvalid = -10111 , JY6311CoreOO::UpdateRateParameterInvalid = -10112 ,
JY6311CoreOO::TriggerParameterInvalid = -10113 , JY6311CoreOO::ReferenceTriggerDoesNotMatchWithSampleMode = -10114 , JY6311CoreOO::PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint = -10115 , JY6311CoreOO::ReadDataFailed = -10016 ,
JY6311CoreOO::ReadDataTimeout = -10017 , JY6311CoreOO::WriteDataFailed = -10018 , JY6311CoreOO::WriteDataTimeout = -10019 , JY6311CoreOO::WriteDataLengthCannotBeLessThanN = -10020 ,
JY6311CoreOO::BufferDataOverflow = -10021 , JY6311CoreOO::BufferDataDownflow = -10022 , JY6311CoreOO::CheckBufferFailed = -10023 , JY6311CoreOO::PointInvalidInFiniteMode = -10024 ,
JY6311CoreOO::ReadPointInvalid = -10025 , JY6311CoreOO::OnlySupportRecordMode = -10026 , JY6311CoreOO::SendSoftTirggerFailed = -10027 , JY6311CoreOO::TaskTimeout = -10028 ,
JY6311CoreOO::CounterParametersInvalid = -10029 , JY6311CoreOO::WritePointInvalid = -10030 , JY6311CoreOO::SignalExportDestinationInvalid = -10031 , JY6311CoreOO::InvalidParameter = -10033
}
enum class JY6311CoreOO::ClockTerminal {
JY6311CoreOO::PFI0 = 0 , JY6311CoreOO::PFI1 = 1 , JY6311CoreOO::PFI2 = 2 , JY6311CoreOO::PXI_Trig0 = 3 ,
JY6311CoreOO::PXI_Trig1 = 4 , JY6311CoreOO::PXI_Trig2 = 5 , JY6311CoreOO::PXI_Trig3 = 6 , JY6311CoreOO::PXI_Trig4 = 7 ,
JY6311CoreOO::PXI_Trig5 = 8 , JY6311CoreOO::PXI_Trig6 = 9 , JY6311CoreOO::PXI_Trig7 = 10
}
enum class JY6311CoreOO::SignalExportDestination {
JY6311CoreOO::PFI0 , JY6311CoreOO::PFI1 , JY6311CoreOO::PFI2 , JY6311CoreOO::PXI_Trig0 = 3 ,
JY6311CoreOO::PXI_Trig1 = 4 , JY6311CoreOO::PXI_Trig2 = 5 , JY6311CoreOO::PXI_Trig3 = 6 , JY6311CoreOO::PXI_Trig4 = 7 ,
JY6311CoreOO::PXI_Trig5 = 8 , JY6311CoreOO::PXI_Trig6 = 9 , JY6311CoreOO::PXI_Trig7 = 10
}
enum class | JY6311CoreOO::OutputCompleteState { JY6311CoreOO::Zero , JY6311CoreOO::Hold }
Output Complete State. More...
enum class JY6311CoreOO::IOTerminal {
JY6311CoreOO::Default = 0 , JY6311CoreOO::PXI_Trig0 = 0x20 , JY6311CoreOO::PXI_Trig1 = 0x21 , JY6311CoreOO::PXI_Trig2 = 0x22 ,
JY6311CoreOO::PXI_Trig3 = 0x23 , JY6311CoreOO::PXI_Trig4 = 0x24 , JY6311CoreOO::PXI_Trig5 = 0x25 , JY6311CoreOO::PXI_Trig6 = 0x26 ,
JY6311CoreOO::PXI_Trig7 = 0x27
}
Cunter IO Terminal. More...
enum class | JY6311CoreOO::LevelPolarity { JY6311CoreOO::LowLevel = 0 , JY6311CoreOO::HighLevel = 1 , JY6311CoreOO::None = 2 }
Level Polarity. More...
enum class JY6311CoreOO::InputTerminal {
JY6311CoreOO::Default = 0 , JY6311CoreOO::PXI_Trig0 = 3 , JY6311CoreOO::PXI_Trig1 = 4 , JY6311CoreOO::PXI_Trig2 = 5 ,
JY6311CoreOO::PXI_Trig3 = 6 , JY6311CoreOO::PXI_Trig4 = 7 , JY6311CoreOO::PXI_Trig5 = 8 , JY6311CoreOO::PXI_Trig6 = 9 ,
JY6311CoreOO::PXI_Trig7 = 10
}
Cunter Input Terminal. More...

Functions

std::string JY6311CoreOO::GetSignalExportDestinationString (SignalExportDestination destination)

Macro Definition Documentation

◆ EXTERN_C

#define EXTERN_C extern

Windows.

Linux

◆ JY6311CoreOO_API

#define JY6311CoreOO_API


6311 C++ Programming Manual: JY6311CoreOO::JYDriverException Class Reference

  • JYDriverException
Public Member Functions | Public Attributes | List of all members
JY6311CoreOO::JYDriverException Class Reference

#include <JY6311CoreOOCommon.h>

Public Member Functions

JYDriverException (JYDriverExceptionPublic exceptionCode, std::string msg="")
JYDriverException (int, std::string msg)

Public Attributes

std::string exceptionMessage
JYDriverExceptionPublic errorCode
JYDriverException * FollowingException

Constructor & Destructor Documentation

◆ JYDriverException() [1/2]

JY6311CoreOO::JYDriverException::JYDriverException | ( | JYDriverExceptionPublic | exceptionCode,
 |  | std::string | msg = "" )

◆ JYDriverException() [2/2]

JY6311CoreOO::JYDriverException::JYDriverException | ( | int | ,
 |  | std::string | msg )

Member Data Documentation

◆ errorCode

JYDriverExceptionPublic JY6311CoreOO::JYDriverException::errorCode

◆ exceptionMessage

std::string JY6311CoreOO::JYDriverException::exceptionMessage

◆ FollowingException

JYDriverException* JY6311CoreOO::JYDriverException::FollowingException
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6311/JY6311CoreOOCommon.h


6311 C++ Programming Manual: JY6311CoreOO::JY6311CoreOOProperty< ContainerClass, ValueType, propertyType > Class Template Reference

  • JY6311CoreOOProperty
Public Member Functions | List of all members
JY6311CoreOO::JY6311CoreOOProperty< ContainerClass, ValueType, propertyType > Class Template Reference

属性模板类 More...

#include <JY6311CoreOOCommon.h>

Public Member Functions

JY6311CoreOOProperty ()
JY6311CoreOOProperty (ContainerClass *cObject, ValueType(ContainerClass::*pGet)(), void(ContainerClass::*pSet)(ValueType value))
JY6311CoreOOProperty (ValueType(*pGet)(), void(*pSet)(ValueType value))
ValueType operator= (const ValueType &value)
operator ValueType ()

Detailed Description

template<typename ContainerClass, typename ValueType, JY6311CoreOOPropertyType propertyType>
class JY6311CoreOO::JY6311CoreOOProperty< ContainerClass, ValueType, propertyType >

属性模板类

Constructor & Destructor Documentation

◆ JY6311CoreOOProperty() [1/3]

template<typename ContainerClass, typename ValueType, JY6311CoreOOPropertyType propertyType>
JY6311CoreOO::JY6311CoreOOProperty< ContainerClass, ValueType, propertyType >::JY6311CoreOOProperty ( )

◆ JY6311CoreOOProperty() [2/3]

template<typename ContainerClass, typename ValueType, JY6311CoreOOPropertyType propertyType>
JY6311CoreOO::JY6311CoreOOProperty< ContainerClass, ValueType, propertyType >::JY6311CoreOOProperty | ( | ContainerClass * | cObject,
 |  | ValueType(ContainerClass::* | pGet )(),
 |  | void(ContainerClass::* | pSet )(ValueType value) )

◆ JY6311CoreOOProperty() [3/3]

template<typename ContainerClass, typename ValueType, JY6311CoreOOPropertyType propertyType>
JY6311CoreOO::JY6311CoreOOProperty< ContainerClass, ValueType, propertyType >::JY6311CoreOOProperty | ( | ValueType(* | pGet )(),
 |  | void(* | pSet )(ValueType value) )

Member Function Documentation

◆ operator ValueType()

template<typename ContainerClass, typename ValueType, JY6311CoreOOPropertyType propertyType>
JY6311CoreOO::JY6311CoreOOProperty< ContainerClass, ValueType, propertyType >::operator ValueType ( )

◆ operator=()

template<typename ContainerClass, typename ValueType, JY6311CoreOOPropertyType propertyType>
ValueType JY6311CoreOO::JY6311CoreOOProperty< ContainerClass, ValueType, propertyType >::operator= ( const ValueType & value )
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6311/JY6311CoreOOCommon.h


6311 C++ Programming Manual: JY6311CoreOO::PauseTrigger Class Reference

  • PauseTrigger
Public Attributes | List of all members
JY6311CoreOO::PauseTrigger Class Reference

Pause trigger configuration class. More...

#include <JY6311CoreOOCommon.h>

Public Attributes

LevelPolarity ActivePolarity
Pause trigger active polarity.
InputTerminal Terminal
Terminal.

Detailed Description

Pause trigger configuration class.

Member Data Documentation

◆ ActivePolarity

LevelPolarity JY6311CoreOO::PauseTrigger::ActivePolarity

Pause trigger active polarity.

The default value is LevelPolarity.None, means the pause trigger is disabled.

◆ Terminal

InputTerminal JY6311CoreOO::PauseTrigger::Terminal

Terminal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6311/JY6311CoreOOCommon.h


6311 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/6311/JY6311CoreOODevice.h File Reference

  • File List
  • File Members
  • COO
  • 6311
Classes | Namespaces | Enumerations
JY6311CoreOODevice.h File Reference
#include <iostream>
#include <string>
#include <list>
#include <vector>
#include "JY6311CoreOOCommon.h"

Classes

class | JY6311CoreOO::JY6311CoreOODevice
class | JY6311CoreOO::PFIFilter
class | JY6311CoreOO::PFISetting
class | JY6311CoreOO::ExternalReferenceClock
class | JY6311CoreOO::JY6311CoreOOReferenceClock

Namespaces

namespace JY6311CoreOO

Enumerations

enum class | JY6311CoreOO::ExternalReferenceClockTerminal { JY6311CoreOO::PXIe_Clk100 = 0x1 }
enum class | JY6311CoreOO::ReferenceClockSource { JY6311CoreOO::Internal = 0x0 , JY6311CoreOO::External = 0x1 }
enum class JY6311CoreOO::PFITerminal {
JY6311CoreOO::PFI0 = 0 , JY6311CoreOO::PFI1 = 1 , JY6311CoreOO::PFI2 = 2 , JY6311CoreOO::PFI3 = 3 ,
JY6311CoreOO::PFI4 = 4 , JY6311CoreOO::PFI5 = 5 , JY6311CoreOO::PFI6 = 6 , JY6311CoreOO::PFI7 = 7 ,
JY6311CoreOO::PFI8 = 8 , JY6311CoreOO::PFI9 = 9 , JY6311CoreOO::PFI10 = 10 , JY6311CoreOO::PFI11 = 11 ,
JY6311CoreOO::PFI12 = 12 , JY6311CoreOO::PFI13 = 13 , JY6311CoreOO::PFI14 = 14 , JY6311CoreOO::PFI15 = 15
}
Input/Output Terminal of PFI. More...


6311 C++ Programming Manual: JY6311CoreOO::JY6311CoreOODevice Class Reference

  • JY6311CoreOODevice
Static Public Member Functions | Public Attributes | List of all members
JY6311CoreOO::JY6311CoreOODevice Class Reference

#include <JY6311CoreOODevice.h>

Static Public Member Functions

static JY6311CoreOODevice * | GetInstance (int cardNum)
static JY6311CoreOODevice * | GetInstance (std::string aliasName)

Public Attributes

const double | BoardClockRate = 100e6
A/D涓婄殑鏉胯浇鏃堕挓棰戠巼
const double | MaxSampleRate = 800
6311鐨勬渶澶ч噰鏍风巼锛?
const double | MinSampleRate = 0.275
6311鐨勬渶灏忛噰鏍风巼
const int | MinSamplesToAcquire = 1
鏈€灏忕殑寰呴噰鏍锋暟
const int | AIBufferSize = 0x100000 * 512
6311纭欢涓婄殑鏉胯浇鍐呭瓨澶у皬锛屽崟浣峛ytes
const bool | IsAISync = false
const double | MaxResistance_ForPT100 = 400
PT100鍙祴閲忕殑鏈€澶х數闃诲€?
const double | MaxResistance_ForPT1000 = 1600
PT1000鍙祴閲忕殑鏈€澶х數闃诲€?
const unsigned int | ChannelCount_Max = 16
鏈€澶ч€氶亾鏁?
const bool | IsAOSync = true
IsAOSync.
JY6311CoreOOProperty< JY6311CoreOODevice, int, JY6311CoreOOPropertyType::READ_ONLY > | MaxChannelCount
JY6311CoreOOProperty< JY6311CoreOODevice, double, JY6311CoreOOPropertyType::READ_ONLY > | MaxSampleRateSingleChannel
JY6311CoreOOProperty< JY6311CoreOODevice, int, JY6311CoreOOPropertyType::READ_ONLY > | AOChannelCount
JY6311CoreOOProperty< JY6311CoreOODevice, std::string, JY6311CoreOOPropertyType::READ_ONLY > | SerialNumber
JY6311CoreOOProperty< JY6311CoreOODevice, int, JY6311CoreOOPropertyType::READ_ONLY > | DeviceID
JY6311CoreOOProperty< JY6311CoreOODevice, void *, JY6311CoreOOPropertyType::READ_ONLY > | Handle
PFISetting * PFI
JY6311CoreOOReferenceClock * ReferenceClock

Member Function Documentation

◆ GetInstance() [1/2]

static JY6311CoreOODevice * JY6311CoreOO::JY6311CoreOODevice::GetInstance ( int cardNum )
static

◆ GetInstance() [2/2]

static JY6311CoreOODevice * JY6311CoreOO::JY6311CoreOODevice::GetInstance ( std::string aliasName )
static

Member Data Documentation

◆ AIBufferSize

const int JY6311CoreOO::JY6311CoreOODevice::AIBufferSize = 0x100000 * 512

6311纭欢涓婄殑鏉胯浇鍐呭瓨澶у皬锛屽崟浣峛ytes

◆ AOChannelCount

JY6311CoreOOProperty<JY6311CoreOODevice, int, JY6311CoreOOPropertyType::READ_ONLY> JY6311CoreOO::JY6311CoreOODevice::AOChannelCount

◆ BoardClockRate

const double JY6311CoreOO::JY6311CoreOODevice::BoardClockRate = 100e6

A/D涓婄殑鏉胯浇鏃堕挓棰戠巼

◆ ChannelCount_Max

const unsigned int JY6311CoreOO::JY6311CoreOODevice::ChannelCount_Max = 16

鏈€澶ч€氶亾鏁?

◆ DeviceID

JY6311CoreOOProperty<JY6311CoreOODevice, int, JY6311CoreOOPropertyType::READ_ONLY> JY6311CoreOO::JY6311CoreOODevice::DeviceID

◆ Handle

JY6311CoreOOProperty<JY6311CoreOODevice, void*, JY6311CoreOOPropertyType::READ_ONLY> JY6311CoreOO::JY6311CoreOODevice::Handle

◆ IsAISync

const bool JY6311CoreOO::JY6311CoreOODevice::IsAISync = false

◆ IsAOSync

const bool JY6311CoreOO::JY6311CoreOODevice::IsAOSync = true

IsAOSync.

◆ MaxChannelCount

JY6311CoreOOProperty<JY6311CoreOODevice, int, JY6311CoreOOPropertyType::READ_ONLY> JY6311CoreOO::JY6311CoreOODevice::MaxChannelCount

◆ MaxResistance_ForPT100

const double JY6311CoreOO::JY6311CoreOODevice::MaxResistance_ForPT100 = 400

PT100鍙祴閲忕殑鏈€澶х數闃诲€?

◆ MaxResistance_ForPT1000

const double JY6311CoreOO::JY6311CoreOODevice::MaxResistance_ForPT1000 = 1600

PT1000鍙祴閲忕殑鏈€澶х數闃诲€?

◆ MaxSampleRate

const double JY6311CoreOO::JY6311CoreOODevice::MaxSampleRate = 800

6311鐨勬渶澶ч噰鏍风巼锛?

涓狝/D涓婂彧鏈?涓€氶亾,鍏?6涓狝DC锛?

◆ MaxSampleRateSingleChannel

JY6311CoreOOProperty<JY6311CoreOODevice, double, JY6311CoreOOPropertyType::READ_ONLY> JY6311CoreOO::JY6311CoreOODevice::MaxSampleRateSingleChannel

◆ MinSampleRate

const double JY6311CoreOO::JY6311CoreOODevice::MinSampleRate = 0.275

6311鐨勬渶灏忛噰鏍风巼

◆ MinSamplesToAcquire

const int JY6311CoreOO::JY6311CoreOODevice::MinSamplesToAcquire = 1

鏈€灏忕殑寰呴噰鏍锋暟

◆ PFI

PFISetting* JY6311CoreOO::JY6311CoreOODevice::PFI

◆ ReferenceClock

JY6311CoreOOReferenceClock* JY6311CoreOO::JY6311CoreOODevice::ReferenceClock

◆ SerialNumber

JY6311CoreOOProperty<JY6311CoreOODevice, std::string, JY6311CoreOOPropertyType::READ_ONLY> JY6311CoreOO::JY6311CoreOODevice::SerialNumber
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6311/JY6311CoreOODevice.h


6311 C++ Programming Manual: JY6311CoreOO::PFIFilter Class Reference

  • PFIFilter
Public Member Functions | List of all members
JY6311CoreOO::PFIFilter Class Reference

#include <JY6311CoreOODevice.h>

Public Member Functions

void | Enable (PFITerminal terminal, int minPulseWidth)
Enable the filter on the specified terminal and set the minimum pulse width.
void | Enable (std::vector< PFITerminal > terminals, int minPulseWidth)
Enable the filter on a group of terminals and set the minimum pulse width.
void | Enable (std::vector< PFITerminal > terminals, std::vector< int > minPulseWidth)
Enable the filter on a group of terminals and set the minimum pulse width separately.
void | Disable (PFITerminal terminal)
Disable the filter on the specified terminal.
void | Disable (std::vector< PFITerminal > terminals)
Disable the filter on a group terminal.
void | DisableAll ()
Disable the filter on all the terminals.

Member Function Documentation

◆ Disable() [1/2]

void JY6311CoreOO::PFIFilter::Disable ( PFITerminal terminal )

Disable the filter on the specified terminal.

Parameters
terminal Specified Terminal

◆ Disable() [2/2]

void JY6311CoreOO::PFIFilter::Disable ( std::vector< PFITerminal > terminals )

Disable the filter on a group terminal.

Parameters
terminals Specified Group of Terminal

◆ DisableAll()

void JY6311CoreOO::PFIFilter::DisableAll ( )

Disable the filter on all the terminals.

◆ Enable() [1/3]

void JY6311CoreOO::PFIFilter::Enable | ( | PFITerminal | terminal,
 |  | int | minPulseWidth )

Enable the filter on the specified terminal and set the minimum pulse width.

Parameters
terminal | Specified Terminal
minPulseWidth | Minimum pulse width in ns, bounce less than this length will be ignored. The smallest step in the range of 10 ns to 2550 ns is 10 ns, the smallest step in the range of 2550 ns to 40800 ns is 160 ns, and the smallest step in the range of 40800 ns to 652800 ns The step is 2560 ns

◆ Enable() [2/3]

void JY6311CoreOO::PFIFilter::Enable | ( | std::vector< PFITerminal > | terminals,
 |  | int | minPulseWidth )

Enable the filter on a group of terminals and set the minimum pulse width.

Parameters
terminals | Specified Group of Terminals
minPulseWidth | Minimum pulse width in ns, bounce less than this length will be ignored. The smallest step in the range of 10 ns to 2550 ns is 10 ns, the smallest step in the range of 2550 ns to 40800 ns is 160 ns, and the smallest step in the range of 40800 ns to 652800 ns The step is 2560 ns

◆ Enable() [3/3]

void JY6311CoreOO::PFIFilter::Enable | ( | std::vector< PFITerminal > | terminals,
 |  | std::vector< int > | minPulseWidth )

Enable the filter on a group of terminals and set the minimum pulse width separately.

Parameters
terminals | Specified Group of Terminals
minPulseWidth | Minimum pulse width in ns, bounce less than this length will be ignored. The smallest step in the range of 10 ns to 2550 ns is 10 ns, the smallest step in the range of 2550 ns to 40800 ns is 160 ns, and the smallest step in the range of 40800 ns to 652800 ns The step is 2560 ns
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6311/JY6311CoreOODevice.h


6311 C++ Programming Manual: JY6311CoreOO::PFISetting Class Reference

  • PFISetting
Public Attributes | List of all members
JY6311CoreOO::PFISetting Class Reference

#include <JY6311CoreOODevice.h>

Public Attributes

PFIFilter * Filter
PFI Filter Setting.

Member Data Documentation

◆ Filter

PFIFilter* JY6311CoreOO::PFISetting::Filter

PFI Filter Setting.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6311/JY6311CoreOODevice.h


6311 C++ Programming Manual: JY6311CoreOO::ExternalReferenceClock Class Reference

  • ExternalReferenceClock
Public Attributes | List of all members
JY6311CoreOO::ExternalReferenceClock Class Reference

#include <JY6311CoreOODevice.h>

Public Attributes

ExternalReferenceClockTerminal Terminal

Member Data Documentation

◆ Terminal

ExternalReferenceClockTerminal JY6311CoreOO::ExternalReferenceClock::Terminal
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6311/JY6311CoreOODevice.h


6311 C++ Programming Manual: JY6311CoreOO::JY6311CoreOOReferenceClock Class Reference

  • JY6311CoreOOReferenceClock
Public Attributes | List of all members
JY6311CoreOO::JY6311CoreOOReferenceClock Class Reference

#include <JY6311CoreOODevice.h>

Public Attributes

ReferenceClockSource Source
ExternalReferenceClock * External
External Reference Clock Source.

Member Data Documentation

◆ External

ExternalReferenceClock* JY6311CoreOO::JY6311CoreOOReferenceClock::External

External Reference Clock Source.

Required when ReferenceClock.Source is ReferenceClockSource.External

◆ Source

ReferenceClockSource JY6311CoreOO::JY6311CoreOOReferenceClock::Source
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6311/JY6311CoreOODevice.h


6311 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/6311/JY6311CoreOODITask.h File Reference

  • File List
  • File Members
  • COO
  • 6311
Classes | Namespaces
JY6311CoreOODITask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JY6311CoreOOCommon.h"
#include "JY6311CoreOODevice.h"

Classes

class | JY6311CoreOO::JY6311CoreOODITask
class | JY6311CoreOO::DIChannel
DI Channel parameter class . More...

Namespaces

namespace JY6311CoreOO


6311 C++ Programming Manual: JY6311CoreOO::JY6311CoreOODITask Class Reference

  • JY6311CoreOODITask
Public Member Functions | Public Attributes | List of all members
JY6311CoreOO::JY6311CoreOODITask Class Reference

#include <JY6311CoreOODITask.h>

Public Member Functions

JY6311CoreOODITask (int slotNum)
JY6311CoreOODITask (std::string boardName)
void | AddChannel (int portNum)
Add one channel.
void | AddChannel (std::vector< int > portsNum)
Add a group of channel.
void | RemoveChannel (int portNum)
Delete the specified port number .If it is -1, delete all ports.
void | Start ()
Start DI task .
void | Stop ()
Stop DI task .
void | ReadSinglePoint (bool *readValues, int port)
read single data from a single port by portID defined.if the portID == -1,read all port data.The data type is bool, one bool defined one port status.
void | ReadSinglePoint (std::vector< bool > &readValues)
Read all port data.The data type is bool, one bool defined one port status.

Public Attributes

std::list< DIChannel * > Channels
List of DI channels,(6311 support 3 ports)
JY6311CoreOODevice * Device
Device.

Constructor & Destructor Documentation

◆ JY6311CoreOODITask() [1/2]

JY6311CoreOO::JY6311CoreOODITask::JY6311CoreOODITask ( int slotNum )

◆ JY6311CoreOODITask() [2/2]

JY6311CoreOO::JY6311CoreOODITask::JY6311CoreOODITask ( std::string boardName )

Member Function Documentation

◆ AddChannel() [1/2]

void JY6311CoreOO::JY6311CoreOODITask::AddChannel ( int portNum )

Add one channel.

Parameters
portNum port number to be added.

◆ AddChannel() [2/2]

void JY6311CoreOO::JY6311CoreOODITask::AddChannel ( std::vector< int > portsNum )

Add a group of channel.

Parameters
portsNum an array of port numbers of added ports.

◆ ReadSinglePoint() [1/2]

void JY6311CoreOO::JY6311CoreOODITask::ReadSinglePoint | ( | bool * | readValues,
 |  | int | port )

read single data from a single port by portID defined.if the portID == -1,read all port data.The data type is bool, one bool defined one port status.

Parameters
readValues | values read,. Buffer size >= channel count
port | Specified port numbers or -1.

◆ ReadSinglePoint() [2/2]

void JY6311CoreOO::JY6311CoreOODITask::ReadSinglePoint ( std::vector< bool > & readValues )

Read all port data.The data type is bool, one bool defined one port status.

Parameters
readValues values read,. Buffer size >= channel count

◆ RemoveChannel()

void JY6311CoreOO::JY6311CoreOODITask::RemoveChannel ( int portNum )

Delete the specified port number .If it is -1, delete all ports.

Parameters
portNum port number to be delete.

◆ Start()

void JY6311CoreOO::JY6311CoreOODITask::Start ( )

Start DI task .

◆ Stop()

void JY6311CoreOO::JY6311CoreOODITask::Stop ( )

Stop DI task .

Member Data Documentation

◆ Channels

std::list<DIChannel*> JY6311CoreOO::JY6311CoreOODITask::Channels

List of DI channels,(6311 support 3 ports)

◆ Device

JY6311CoreOODevice* JY6311CoreOO::JY6311CoreOODITask::Device

Device.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6311/JY6311CoreOODITask.h


6311 C++ Programming Manual: JY6311CoreOO::DIChannel Class Reference

  • DIChannel
Public Attributes | List of all members
JY6311CoreOO::DIChannel Class Reference

DI Channel parameter class . More...

#include <JY6311CoreOODITask.h>

Public Attributes

int PortNum
port number.

Detailed Description

DI Channel parameter class .

Member Data Documentation

◆ PortNum

int JY6311CoreOO::DIChannel::PortNum

port number.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6311/JY6311CoreOODITask.h


6311 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/6311/JY6311CoreOODOTask.h File Reference

  • File List
  • File Members
  • COO
  • 6311
Classes | Namespaces
JY6311CoreOODOTask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JY6311CoreOOCommon.h"
#include "JY6311CoreOODevice.h"

Classes

class | JY6311CoreOO::JY6311CoreOODOTask
class | JY6311CoreOO::DOChannel
DO Channel parameter class . More...

Namespaces

namespace JY6311CoreOO


6311 C++ Programming Manual: JY6311CoreOO::JY6311CoreOODOTask Class Reference

  • JY6311CoreOODOTask
Public Member Functions | Public Attributes | List of all members
JY6311CoreOO::JY6311CoreOODOTask Class Reference

#include <JY6311CoreOODOTask.h>

Public Member Functions

JY6311CoreOODOTask (int slotNum)
JY6311CoreOODOTask (std::string boardName)
void | AddChannel (int portNum)
Add one channel.
void | AddChannel (std::vector< int > portsNum)
Add a group of channel.
void | RemoveChannel (int portNum)
Delete the specified port number .If it is -1, delete all ports.
void | Start ()
Start DO task .
void | Stop ()
Stop DO task .
void | WriteSinglePoint (bool writeValues, int port)
Write one sample to the specified port in register.Available when Mode is DOMode.Single
void | WriteSinglePoint (std::vector< bool > &writeValues)
Read one sample for all ports in register .

Public Attributes

std::list< DOChannel * > Channels
List of DO channels,(6311 support 3 ports)
JY6311CoreOODevice * Device
Device.

Constructor & Destructor Documentation

◆ JY6311CoreOODOTask() [1/2]

JY6311CoreOO::JY6311CoreOODOTask::JY6311CoreOODOTask ( int slotNum )

◆ JY6311CoreOODOTask() [2/2]

JY6311CoreOO::JY6311CoreOODOTask::JY6311CoreOODOTask ( std::string boardName )

Member Function Documentation

◆ AddChannel() [1/2]

void JY6311CoreOO::JY6311CoreOODOTask::AddChannel ( int portNum )

Add one channel.

Parameters
portNum port number to be added.

◆ AddChannel() [2/2]

void JY6311CoreOO::JY6311CoreOODOTask::AddChannel ( std::vector< int > portsNum )

Add a group of channel.

Parameters
portsNum an array of port numbers of added ports.

◆ RemoveChannel()

void JY6311CoreOO::JY6311CoreOODOTask::RemoveChannel ( int portNum )

Delete the specified port number .If it is -1, delete all ports.

Parameters
portNum port number to be delete.

◆ Start()

void JY6311CoreOO::JY6311CoreOODOTask::Start ( )

Start DO task .

◆ Stop()

void JY6311CoreOO::JY6311CoreOODOTask::Stop ( )

Stop DO task .

◆ WriteSinglePoint() [1/2]

void JY6311CoreOO::JY6311CoreOODOTask::WriteSinglePoint | ( | bool | writeValues,
 |  | int | port )

Write one sample to the specified port in register.Available when Mode is DOMode.Single

Parameters
readValues | values write Buffer
port | Specified port numbers.

◆ WriteSinglePoint() [2/2]

void JY6311CoreOO::JY6311CoreOODOTask::WriteSinglePoint ( std::vector< bool > & writeValues )

Read one sample for all ports in register .

Available when Mode is DIMode.Single

Parameters
readValues Values write Buffer size == number of ports.

Member Data Documentation

◆ Channels

std::list<DOChannel*> JY6311CoreOO::JY6311CoreOODOTask::Channels

List of DO channels,(6311 support 3 ports)

◆ Device

JY6311CoreOODevice* JY6311CoreOO::JY6311CoreOODOTask::Device

Device.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6311/JY6311CoreOODOTask.h


6311 C++ Programming Manual: JY6311CoreOO::DOChannel Class Reference

  • DOChannel
Public Attributes | List of all members
JY6311CoreOO::DOChannel Class Reference

DO Channel parameter class . More...

#include <JY6311CoreOODOTask.h>

Public Attributes

int PortNum
port number.

Detailed Description

DO Channel parameter class .

Member Data Documentation

◆ PortNum

int JY6311CoreOO::DOChannel::PortNum

port number.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6311/JY6311CoreOODOTask.h


6311 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/6311/JY6311CoreOOLog.h File Reference

  • File List
  • File Members
  • COO
  • 6311
Classes | Namespaces | Enumerations
JY6311CoreOOLog.h File Reference
#include <queue>
#include <string>
#include <thread>
#include "JY6311CoreOOCommon.h"

Classes

class JY6311CoreOO::JY6311CoreOOLog

Namespaces

namespace JY6311CoreOO

Enumerations

enum class JY6311CoreOO::JY6311CoreOOLogLevel {
JY6311CoreOO::DEBUG_LOG_LEVEL , JY6311CoreOO::INFO_LOG_LEVEL , JY6311CoreOO::WARN_LOG_LEVEL , JY6311CoreOO::ERROR_LOG_LEVEL ,
JY6311CoreOO::FATAL_LOG_LEVEL
}


6311 C++ Programming Manual: JY6311CoreOO::JY6311CoreOOLog Class Reference

  • JY6311CoreOOLog
Static Public Member Functions | Static Public Attributes | List of all members
JY6311CoreOO::JY6311CoreOOLog Class Reference

#include <JY6311CoreOOLog.h>

Static Public Member Functions

static void | Print (const char *format,...)
static void | Print (JY6311CoreOOLogLevel logLevel, const char *format,...)
static void | Flush ()

Static Public Attributes

static JY6311CoreOOLogLevel | LogLevel
static JY6311CoreOOProperty< JY6311CoreOOLog, bool, JY6311CoreOOPropertyType::READ_WRITE > | EnableLog

Member Function Documentation

◆ Flush()

static void JY6311CoreOO::JY6311CoreOOLog::Flush ( )
static

◆ Print() [1/2]

static void JY6311CoreOO::JY6311CoreOOLog::Print | ( | const char * | format,
 |  |  | ... )
 static

◆ Print() [2/2]

static void JY6311CoreOO::JY6311CoreOOLog::Print | ( | JY6311CoreOOLogLevel | logLevel,
 |  | const char * | format,
 |  |  | ... )
 static

Member Data Documentation

◆ EnableLog

JY6311CoreOOProperty<JY6311CoreOOLog, bool, JY6311CoreOOPropertyType::READ_WRITE> JY6311CoreOO::JY6311CoreOOLog::EnableLog
static

◆ LogLevel

JY6311CoreOOLogLevel JY6311CoreOO::JY6311CoreOOLog::LogLevel
static
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6311/JY6311CoreOOLog.h


6311 C++ Programming Manual: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
▼N JY6311CoreOO |
C AIChannel | AI channel class
C AIDigitalTrigger |
C AIExternalSampleClock | External Sample Clock Configuration Class
C AISampleClock | Sample clock configuration class
C AISignalExport | AI Signal Export Source
C AITrigger |
C DIChannel | DI Channel parameter class
C DOChannel | DO Channel parameter class
C ExternalReferenceClock |
C JY6311CoreOOAITask | AITask类
C JY6311CoreOODevice |
C JY6311CoreOODITask |
C JY6311CoreOODOTask |
C JY6311CoreOOLog |
C JY6311CoreOOProperty | 属性模板类
C JY6311CoreOOReferenceClock |
C JYDriverException |
C PauseTrigger | Pause trigger configuration class
C PFIFilter |
C PFISetting |


6311 C++ Programming Manual: Member List

  • AIChannel
JY6311CoreOO::AIChannel Member List

This is the complete list of members for JY6311CoreOO::AIChannel, including all inherited members.

AIChannel(int channelId, RTDType RTDtype=RTDType::PT100, RTDTCRType RTDTCRtype=RTDTCRType::Pt100_TCR3851, RTDTerminal terminalType=RTDTerminal::TwoWire) | JY6311CoreOO::AIChannel
AIChannel(int channelId, RTDType RTDtype=RTDType::PT100, RTDTerminal terminalType=RTDTerminal::TwoWire) | JY6311CoreOO::AIChannel
AIChannel(int channelId, double voltageRangeLow, double voltageRangeHigh) | JY6311CoreOO::AIChannel
ChannelID | JY6311CoreOO::AIChannel
MeasurementType1 | JY6311CoreOO::AIChannel
RTDTCRtype1 | JY6311CoreOO::AIChannel
RTDtype1 | JY6311CoreOO::AIChannel
terminalType1 | JY6311CoreOO::AIChannel
VoltageRangeHigh | JY6311CoreOO::AIChannel
VoltageRangeLow | JY6311CoreOO::AIChannel


6311 C++ Programming Manual: Member List

  • AIDigitalTrigger
JY6311CoreOO::AIDigitalTrigger Member List

This is the complete list of members for JY6311CoreOO::AIDigitalTrigger, including all inherited members.

Edge | JY6311CoreOO::AIDigitalTrigger
Source | JY6311CoreOO::AIDigitalTrigger


6311 C++ Programming Manual: Member List

  • AIExternalSampleClock
JY6311CoreOO::AIExternalSampleClock Member List

This is the complete list of members for JY6311CoreOO::AIExternalSampleClock, including all inherited members.

ExpectedRate | JY6311CoreOO::AIExternalSampleClock
Terminal | JY6311CoreOO::AIExternalSampleClock


6311 C++ Programming Manual: Member List

  • AISampleClock
JY6311CoreOO::AISampleClock Member List

This is the complete list of members for JY6311CoreOO::AISampleClock, including all inherited members.

External | JY6311CoreOO::AISampleClock
Source | JY6311CoreOO::AISampleClock


6311 C++ Programming Manual: Member List

  • AISignalExport
JY6311CoreOO::AISignalExport Member List

This is the complete list of members for JY6311CoreOO::AISignalExport, including all inherited members.

Add(AISignalExportSource source, SignalExportDestination destination) | JY6311CoreOO::AISignalExport
Add(AISignalExportSource source, std::list< SignalExportDestination > destinations) | JY6311CoreOO::AISignalExport
Clear(SignalExportDestination destination) | JY6311CoreOO::AISignalExport
ClearAll() | JY6311CoreOO::AISignalExport


6311 C++ Programming Manual: Member List

  • AITrigger
JY6311CoreOO::AITrigger Member List

This is the complete list of members for JY6311CoreOO::AITrigger, including all inherited members.

Digital | JY6311CoreOO::AITrigger
Mode | JY6311CoreOO::AITrigger
PreTriggerSamples | JY6311CoreOO::AITrigger
ReTriggerCount | JY6311CoreOO::AITrigger
Type | JY6311CoreOO::AITrigger


6311 C++ Programming Manual: Member List

  • DIChannel
JY6311CoreOO::DIChannel Member List

This is the complete list of members for JY6311CoreOO::DIChannel, including all inherited members.

PortNum JY6311CoreOO::DIChannel


6311 C++ Programming Manual: Member List

  • DOChannel
JY6311CoreOO::DOChannel Member List

This is the complete list of members for JY6311CoreOO::DOChannel, including all inherited members.

PortNum JY6311CoreOO::DOChannel


6311 C++ Programming Manual: Member List

  • ExternalReferenceClock
JY6311CoreOO::ExternalReferenceClock Member List

This is the complete list of members for JY6311CoreOO::ExternalReferenceClock, including all inherited members.

Terminal JY6311CoreOO::ExternalReferenceClock


6311 C++ Programming Manual: Member List

  • JY6311CoreOOAITask
JY6311CoreOO::JY6311CoreOOAITask Member List

This is the complete list of members for JY6311CoreOO::JY6311CoreOOAITask, including all inherited members.

AddChannel(int chnsId, RTDType rtdType, RTDTCRType rtdTCRType, RTDTerminal rtdTerminal) | JY6311CoreOO::JY6311CoreOOAITask
AddChannel(std::vector< int > chnsId, RTDType rtdType, RTDTCRType rtdTCRType, RTDTerminal rtdTerminal) | JY6311CoreOO::JY6311CoreOOAITask
AddChannel(std::vector< int > chnsId, std::vector< RTDType > rtdType, std::vector< RTDTCRType > rtdTCRType, std::vector< RTDTerminal > rtdTerminal) | JY6311CoreOO::JY6311CoreOOAITask
AddChannel(int chnsId, RTDType rtdType, RTDTerminal rtdTerminal) | JY6311CoreOO::JY6311CoreOOAITask
AddChannel(std::vector< int > chnsId, RTDType rtdType, RTDTerminal rtdTerminal) | JY6311CoreOO::JY6311CoreOOAITask
AddChannel(std::vector< int > chnsId, std::vector< RTDType > rtdType, std::vector< RTDTerminal > rtdTerminal) | JY6311CoreOO::JY6311CoreOOAITask
AddChannel(int chnsId, double rangeLow, double rangeHigh) | JY6311CoreOO::JY6311CoreOOAITask
AddChannel(std::vector< int > chnsId, double rangeLow, double rangeHigh) | JY6311CoreOO::JY6311CoreOOAITask
AddChannel(std::vector< int > chnsId, std::vector< double > rangeLow, std::vector< double > rangeHigh) | JY6311CoreOO::JY6311CoreOOAITask
AvailableSamples | JY6311CoreOO::JY6311CoreOOAITask
BufLenInSamples | JY6311CoreOO::JY6311CoreOOAITask
Channels | JY6311CoreOO::JY6311CoreOOAITask
Device | JY6311CoreOO::JY6311CoreOOAITask
DisableCalibration | JY6311CoreOO::JY6311CoreOOAITask
JY6311CoreOOAITask(int slotNum) | JY6311CoreOO::JY6311CoreOOAITask
JY6311CoreOOAITask(std::string boardName) | JY6311CoreOO::JY6311CoreOOAITask
Mode | JY6311CoreOO::JY6311CoreOOAITask
PowerLine_Frequency | JY6311CoreOO::JY6311CoreOOAITask
ReadData(double *pBuf, int samplesPerChannel, int timeout=-1) | JY6311CoreOO::JY6311CoreOOAITask
ReadRawData(int *pBuf, int samplesPerChannel, int timeout=-1) | JY6311CoreOO::JY6311CoreOOAITask
ReadSinglePoint(double &readValue, int channel) | JY6311CoreOO::JY6311CoreOOAITask
ReadSinglePoint(std::vector< double > &readValues) | JY6311CoreOO::JY6311CoreOOAITask
RemoveChannel(int chnId) | JY6311CoreOO::JY6311CoreOOAITask
SampleClock | JY6311CoreOO::JY6311CoreOOAITask
SampleRate | JY6311CoreOO::JY6311CoreOOAITask
SamplesToAcquire | JY6311CoreOO::JY6311CoreOOAITask
SendSoftwareTrigger() | JY6311CoreOO::JY6311CoreOOAITask
SignalExport | JY6311CoreOO::JY6311CoreOOAITask
Start() | JY6311CoreOO::JY6311CoreOOAITask
Stop() | JY6311CoreOO::JY6311CoreOOAITask
TransferedSamples | JY6311CoreOO::JY6311CoreOOAITask
Trigger | JY6311CoreOO::JY6311CoreOOAITask
WaitUntilDone(int timeout) | JY6311CoreOO::JY6311CoreOOAITask
~JY6311CoreOOAITask() | JY6311CoreOO::JY6311CoreOOAITask


6311 C++ Programming Manual: Member List

  • JY6311CoreOODITask
JY6311CoreOO::JY6311CoreOODITask Member List

This is the complete list of members for JY6311CoreOO::JY6311CoreOODITask, including all inherited members.

AddChannel(int portNum) | JY6311CoreOO::JY6311CoreOODITask
AddChannel(std::vector< int > portsNum) | JY6311CoreOO::JY6311CoreOODITask
Channels | JY6311CoreOO::JY6311CoreOODITask
Device | JY6311CoreOO::JY6311CoreOODITask
JY6311CoreOODITask(int slotNum) | JY6311CoreOO::JY6311CoreOODITask
JY6311CoreOODITask(std::string boardName) | JY6311CoreOO::JY6311CoreOODITask
ReadSinglePoint(bool *readValues, int port) | JY6311CoreOO::JY6311CoreOODITask
ReadSinglePoint(std::vector< bool > &readValues) | JY6311CoreOO::JY6311CoreOODITask
RemoveChannel(int portNum) | JY6311CoreOO::JY6311CoreOODITask
Start() | JY6311CoreOO::JY6311CoreOODITask
Stop() | JY6311CoreOO::JY6311CoreOODITask


6311 C++ Programming Manual: Member List

  • JY6311CoreOODOTask
JY6311CoreOO::JY6311CoreOODOTask Member List

This is the complete list of members for JY6311CoreOO::JY6311CoreOODOTask, including all inherited members.

AddChannel(int portNum) | JY6311CoreOO::JY6311CoreOODOTask
AddChannel(std::vector< int > portsNum) | JY6311CoreOO::JY6311CoreOODOTask
Channels | JY6311CoreOO::JY6311CoreOODOTask
Device | JY6311CoreOO::JY6311CoreOODOTask
JY6311CoreOODOTask(int slotNum) | JY6311CoreOO::JY6311CoreOODOTask
JY6311CoreOODOTask(std::string boardName) | JY6311CoreOO::JY6311CoreOODOTask
RemoveChannel(int portNum) | JY6311CoreOO::JY6311CoreOODOTask
Start() | JY6311CoreOO::JY6311CoreOODOTask
Stop() | JY6311CoreOO::JY6311CoreOODOTask
WriteSinglePoint(bool writeValues, int port) | JY6311CoreOO::JY6311CoreOODOTask
WriteSinglePoint(std::vector< bool > &writeValues) | JY6311CoreOO::JY6311CoreOODOTask


6311 C++ Programming Manual: Member List

  • JY6311CoreOODevice
JY6311CoreOO::JY6311CoreOODevice Member List

This is the complete list of members for JY6311CoreOO::JY6311CoreOODevice, including all inherited members.

AIBufferSize | JY6311CoreOO::JY6311CoreOODevice |
AOChannelCount | JY6311CoreOO::JY6311CoreOODevice |
BoardClockRate | JY6311CoreOO::JY6311CoreOODevice |
ChannelCount_Max | JY6311CoreOO::JY6311CoreOODevice |
DeviceID | JY6311CoreOO::JY6311CoreOODevice |
GetInstance(int cardNum) | JY6311CoreOO::JY6311CoreOODevice | static
GetInstance(std::string aliasName) | JY6311CoreOO::JY6311CoreOODevice | static
Handle | JY6311CoreOO::JY6311CoreOODevice |
IsAISync | JY6311CoreOO::JY6311CoreOODevice |
IsAOSync | JY6311CoreOO::JY6311CoreOODevice |
MaxChannelCount | JY6311CoreOO::JY6311CoreOODevice |
MaxResistance_ForPT100 | JY6311CoreOO::JY6311CoreOODevice |
MaxResistance_ForPT1000 | JY6311CoreOO::JY6311CoreOODevice |
MaxSampleRate | JY6311CoreOO::JY6311CoreOODevice |
MaxSampleRateSingleChannel | JY6311CoreOO::JY6311CoreOODevice |
MinSampleRate | JY6311CoreOO::JY6311CoreOODevice |
MinSamplesToAcquire | JY6311CoreOO::JY6311CoreOODevice |
PFI | JY6311CoreOO::JY6311CoreOODevice |
ReferenceClock | JY6311CoreOO::JY6311CoreOODevice |
SerialNumber | JY6311CoreOO::JY6311CoreOODevice |


6311 C++ Programming Manual: Member List

  • JY6311CoreOOLog
JY6311CoreOO::JY6311CoreOOLog Member List

This is the complete list of members for JY6311CoreOO::JY6311CoreOOLog, including all inherited members.

EnableLog | JY6311CoreOO::JY6311CoreOOLog | static
Flush() | JY6311CoreOO::JY6311CoreOOLog | static
LogLevel | JY6311CoreOO::JY6311CoreOOLog | static
Print(const char *format,...) | JY6311CoreOO::JY6311CoreOOLog | static
Print(JY6311CoreOOLogLevel logLevel, const char *format,...) | JY6311CoreOO::JY6311CoreOOLog | static


6311 C++ Programming Manual: Member List

  • JY6311CoreOOProperty
JY6311CoreOO::JY6311CoreOOProperty< ContainerClass, ValueType, propertyType > Member List

This is the complete list of members for JY6311CoreOO::JY6311CoreOOProperty< ContainerClass, ValueType, propertyType >, including all inherited members.

JY6311CoreOOProperty() | JY6311CoreOO::JY6311CoreOOProperty< ContainerClass, ValueType, propertyType >
JY6311CoreOOProperty(ContainerClass *cObject, ValueType(ContainerClass::*pGet)(), void(ContainerClass::*pSet)(ValueType value)) | JY6311CoreOO::JY6311CoreOOProperty< ContainerClass, ValueType, propertyType >
JY6311CoreOOProperty(ValueType(*pGet)(), void(*pSet)(ValueType value)) | JY6311CoreOO::JY6311CoreOOProperty< ContainerClass, ValueType, propertyType >
operator ValueType() | JY6311CoreOO::JY6311CoreOOProperty< ContainerClass, ValueType, propertyType >
operator=(const ValueType &value) | JY6311CoreOO::JY6311CoreOOProperty< ContainerClass, ValueType, propertyType >


6311 C++ Programming Manual: Member List

  • JY6311CoreOOReferenceClock
JY6311CoreOO::JY6311CoreOOReferenceClock Member List

This is the complete list of members for JY6311CoreOO::JY6311CoreOOReferenceClock, including all inherited members.

External | JY6311CoreOO::JY6311CoreOOReferenceClock
Source | JY6311CoreOO::JY6311CoreOOReferenceClock


6311 C++ Programming Manual: Member List

  • JYDriverException
JY6311CoreOO::JYDriverException Member List

This is the complete list of members for JY6311CoreOO::JYDriverException, including all inherited members.

errorCode | JY6311CoreOO::JYDriverException
exceptionMessage | JY6311CoreOO::JYDriverException
FollowingException | JY6311CoreOO::JYDriverException
JYDriverException(JYDriverExceptionPublic exceptionCode, std::string msg="") | JY6311CoreOO::JYDriverException
JYDriverException(int, std::string msg) | JY6311CoreOO::JYDriverException


6311 C++ Programming Manual: Member List

  • PFIFilter
JY6311CoreOO::PFIFilter Member List

This is the complete list of members for JY6311CoreOO::PFIFilter, including all inherited members.

Disable(PFITerminal terminal) | JY6311CoreOO::PFIFilter
Disable(std::vector< PFITerminal > terminals) | JY6311CoreOO::PFIFilter
DisableAll() | JY6311CoreOO::PFIFilter
Enable(PFITerminal terminal, int minPulseWidth) | JY6311CoreOO::PFIFilter
Enable(std::vector< PFITerminal > terminals, int minPulseWidth) | JY6311CoreOO::PFIFilter
Enable(std::vector< PFITerminal > terminals, std::vector< int > minPulseWidth) | JY6311CoreOO::PFIFilter


6311 C++ Programming Manual: Member List

  • PFISetting
JY6311CoreOO::PFISetting Member List

This is the complete list of members for JY6311CoreOO::PFISetting, including all inherited members.

Filter JY6311CoreOO::PFISetting


6311 C++ Programming Manual: Member List

  • PauseTrigger
JY6311CoreOO::PauseTrigger Member List

This is the complete list of members for JY6311CoreOO::PauseTrigger, including all inherited members.

ActivePolarity | JY6311CoreOO::PauseTrigger
Terminal | JY6311CoreOO::PauseTrigger


6311 C++ Programming Manual: Class Index

Class Index
A | D | E | J | P
A
AIChannel (JY6311CoreOO)
AIDigitalTrigger (JY6311CoreOO)
AIExternalSampleClock (JY6311CoreOO)
AISampleClock (JY6311CoreOO)
AISignalExport (JY6311CoreOO)
AITrigger (JY6311CoreOO)
D
DIChannel (JY6311CoreOO)
DOChannel (JY6311CoreOO)
E
ExternalReferenceClock (JY6311CoreOO)
J
JY6311CoreOOAITask (JY6311CoreOO)
JY6311CoreOODevice (JY6311CoreOO)
JY6311CoreOODITask (JY6311CoreOO)
JY6311CoreOODOTask (JY6311CoreOO)
JY6311CoreOOLog (JY6311CoreOO)
JY6311CoreOOProperty (JY6311CoreOO)
JY6311CoreOOReferenceClock (JY6311CoreOO)
JYDriverException (JY6311CoreOO)
P
PauseTrigger (JY6311CoreOO)
PFIFilter (JY6311CoreOO)
PFISetting (JY6311CoreOO)


6311 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO Directory Reference

  • File List
  • File Members
  • COO
COO Directory Reference

Directories

6311


6311 C++ Programming Manual: File List

  • File List
  • File Members
File List
Here is a list of all files with brief descriptions:
[detail level 123]
▼ COO
▼ 6311
JY6311CoreOOAITask.h
JY6311CoreOOCommon.h
JY6311CoreOODevice.h
JY6311CoreOODITask.h
JY6311CoreOODOTask.h
JY6311CoreOOLog.h


6311 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- a -

  • ActivePolarity : JY6311CoreOO::PauseTrigger
  • Add() : JY6311CoreOO::AISignalExport
  • AddChannel() : JY6311CoreOO::JY6311CoreOOAITask, JY6311CoreOO::JY6311CoreOODITask, JY6311CoreOO::JY6311CoreOODOTask
  • AIBufferSize : JY6311CoreOO::JY6311CoreOODevice
  • AIChannel() : JY6311CoreOO::AIChannel
  • AOChannelCount : JY6311CoreOO::JY6311CoreOODevice
  • AvailableSamples : JY6311CoreOO::JY6311CoreOOAITask

- b -

  • BoardClockRate : JY6311CoreOO::JY6311CoreOODevice
  • BufLenInSamples : JY6311CoreOO::JY6311CoreOOAITask

- c -

  • ChannelCount_Max : JY6311CoreOO::JY6311CoreOODevice
  • ChannelID : JY6311CoreOO::AIChannel
  • Channels : JY6311CoreOO::JY6311CoreOOAITask, JY6311CoreOO::JY6311CoreOODITask, JY6311CoreOO::JY6311CoreOODOTask
  • Clear() : JY6311CoreOO::AISignalExport
  • ClearAll() : JY6311CoreOO::AISignalExport

- d -

  • Device : JY6311CoreOO::JY6311CoreOOAITask, JY6311CoreOO::JY6311CoreOODITask, JY6311CoreOO::JY6311CoreOODOTask
  • DeviceID : JY6311CoreOO::JY6311CoreOODevice
  • Digital : JY6311CoreOO::AITrigger
  • Disable() : JY6311CoreOO::PFIFilter
  • DisableAll() : JY6311CoreOO::PFIFilter
  • DisableCalibration : JY6311CoreOO::JY6311CoreOOAITask

- e -

  • Edge : JY6311CoreOO::AIDigitalTrigger
  • Enable() : JY6311CoreOO::PFIFilter
  • EnableLog : JY6311CoreOO::JY6311CoreOOLog
  • errorCode : JY6311CoreOO::JYDriverException
  • exceptionMessage : JY6311CoreOO::JYDriverException
  • ExpectedRate : JY6311CoreOO::AIExternalSampleClock
  • External : JY6311CoreOO::AISampleClock, JY6311CoreOO::JY6311CoreOOReferenceClock

- f -

  • Filter : JY6311CoreOO::PFISetting
  • Flush() : JY6311CoreOO::JY6311CoreOOLog
  • FollowingException : JY6311CoreOO::JYDriverException

- g -

  • GetInstance() : JY6311CoreOO::JY6311CoreOODevice

- h -

  • Handle : JY6311CoreOO::JY6311CoreOODevice

- i -

  • IsAISync : JY6311CoreOO::JY6311CoreOODevice
  • IsAOSync : JY6311CoreOO::JY6311CoreOODevice

- j -

  • JY6311CoreOOAITask() : JY6311CoreOO::JY6311CoreOOAITask
  • JY6311CoreOODITask() : JY6311CoreOO::JY6311CoreOODITask
  • JY6311CoreOODOTask() : JY6311CoreOO::JY6311CoreOODOTask
  • JY6311CoreOOProperty() : JY6311CoreOO::JY6311CoreOOProperty< ContainerClass, ValueType, propertyType >
  • JYDriverException() : JY6311CoreOO::JYDriverException

- l -

  • LogLevel : JY6311CoreOO::JY6311CoreOOLog

- m -

  • MaxChannelCount : JY6311CoreOO::JY6311CoreOODevice
  • MaxResistance_ForPT100 : JY6311CoreOO::JY6311CoreOODevice
  • MaxResistance_ForPT1000 : JY6311CoreOO::JY6311CoreOODevice
  • MaxSampleRate : JY6311CoreOO::JY6311CoreOODevice
  • MaxSampleRateSingleChannel : JY6311CoreOO::JY6311CoreOODevice
  • MeasurementType1 : JY6311CoreOO::AIChannel
  • MinSampleRate : JY6311CoreOO::JY6311CoreOODevice
  • MinSamplesToAcquire : JY6311CoreOO::JY6311CoreOODevice
  • Mode : JY6311CoreOO::AITrigger, JY6311CoreOO::JY6311CoreOOAITask

- o -

  • operator ValueType() : JY6311CoreOO::JY6311CoreOOProperty< ContainerClass, ValueType, propertyType >
  • operator=() : JY6311CoreOO::JY6311CoreOOProperty< ContainerClass, ValueType, propertyType >

- p -

  • PFI : JY6311CoreOO::JY6311CoreOODevice
  • PortNum : JY6311CoreOO::DIChannel, JY6311CoreOO::DOChannel
  • PowerLine_Frequency : JY6311CoreOO::JY6311CoreOOAITask
  • PreTriggerSamples : JY6311CoreOO::AITrigger
  • Print() : JY6311CoreOO::JY6311CoreOOLog

- r -

  • ReadData() : JY6311CoreOO::JY6311CoreOOAITask
  • ReadRawData() : JY6311CoreOO::JY6311CoreOOAITask
  • ReadSinglePoint() : JY6311CoreOO::JY6311CoreOOAITask, JY6311CoreOO::JY6311CoreOODITask
  • ReferenceClock : JY6311CoreOO::JY6311CoreOODevice
  • RemoveChannel() : JY6311CoreOO::JY6311CoreOOAITask, JY6311CoreOO::JY6311CoreOODITask, JY6311CoreOO::JY6311CoreOODOTask
  • ReTriggerCount : JY6311CoreOO::AITrigger
  • RTDTCRtype1 : JY6311CoreOO::AIChannel
  • RTDtype1 : JY6311CoreOO::AIChannel

- s -

  • SampleClock : JY6311CoreOO::JY6311CoreOOAITask
  • SampleRate : JY6311CoreOO::JY6311CoreOOAITask
  • SamplesToAcquire : JY6311CoreOO::JY6311CoreOOAITask
  • SendSoftwareTrigger() : JY6311CoreOO::JY6311CoreOOAITask
  • SerialNumber : JY6311CoreOO::JY6311CoreOODevice
  • SignalExport : JY6311CoreOO::JY6311CoreOOAITask
  • Source : JY6311CoreOO::AIDigitalTrigger, JY6311CoreOO::AISampleClock, JY6311CoreOO::JY6311CoreOOReferenceClock
  • Start() : JY6311CoreOO::JY6311CoreOOAITask, JY6311CoreOO::JY6311CoreOODITask, JY6311CoreOO::JY6311CoreOODOTask
  • Stop() : JY6311CoreOO::JY6311CoreOOAITask, JY6311CoreOO::JY6311CoreOODITask, JY6311CoreOO::JY6311CoreOODOTask

- t -

  • Terminal : JY6311CoreOO::AIExternalSampleClock, JY6311CoreOO::ExternalReferenceClock, JY6311CoreOO::PauseTrigger
  • terminalType1 : JY6311CoreOO::AIChannel
  • TransferedSamples : JY6311CoreOO::JY6311CoreOOAITask
  • Trigger : JY6311CoreOO::JY6311CoreOOAITask
  • Type : JY6311CoreOO::AITrigger

- v -

  • VoltageRangeHigh : JY6311CoreOO::AIChannel
  • VoltageRangeLow : JY6311CoreOO::AIChannel

- w -

  • WaitUntilDone() : JY6311CoreOO::JY6311CoreOOAITask
  • WriteSinglePoint() : JY6311CoreOO::JY6311CoreOODOTask

- ~ -

  • ~JY6311CoreOOAITask() : JY6311CoreOO::JY6311CoreOOAITask


6311 C++ Programming Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • c
  • d
  • e
  • f
  • g
  • j
  • o
  • p
  • r
  • s
  • w
  • ~
Here is a list of all functions with links to the classes they belong to:

- a -

  • Add() : JY6311CoreOO::AISignalExport
  • AddChannel() : JY6311CoreOO::JY6311CoreOOAITask, JY6311CoreOO::JY6311CoreOODITask, JY6311CoreOO::JY6311CoreOODOTask
  • AIChannel() : JY6311CoreOO::AIChannel

- c -

  • Clear() : JY6311CoreOO::AISignalExport
  • ClearAll() : JY6311CoreOO::AISignalExport

- d -

  • Disable() : JY6311CoreOO::PFIFilter
  • DisableAll() : JY6311CoreOO::PFIFilter

- e -

  • Enable() : JY6311CoreOO::PFIFilter

- f -

  • Flush() : JY6311CoreOO::JY6311CoreOOLog

- g -

  • GetInstance() : JY6311CoreOO::JY6311CoreOODevice

- j -

  • JY6311CoreOOAITask() : JY6311CoreOO::JY6311CoreOOAITask
  • JY6311CoreOODITask() : JY6311CoreOO::JY6311CoreOODITask
  • JY6311CoreOODOTask() : JY6311CoreOO::JY6311CoreOODOTask
  • JY6311CoreOOProperty() : JY6311CoreOO::JY6311CoreOOProperty< ContainerClass, ValueType, propertyType >
  • JYDriverException() : JY6311CoreOO::JYDriverException

- o -

  • operator ValueType() : JY6311CoreOO::JY6311CoreOOProperty< ContainerClass, ValueType, propertyType >
  • operator=() : JY6311CoreOO::JY6311CoreOOProperty< ContainerClass, ValueType, propertyType >

- p -

  • Print() : JY6311CoreOO::JY6311CoreOOLog

- r -

  • ReadData() : JY6311CoreOO::JY6311CoreOOAITask
  • ReadRawData() : JY6311CoreOO::JY6311CoreOOAITask
  • ReadSinglePoint() : JY6311CoreOO::JY6311CoreOOAITask, JY6311CoreOO::JY6311CoreOODITask
  • RemoveChannel() : JY6311CoreOO::JY6311CoreOOAITask, JY6311CoreOO::JY6311CoreOODITask, JY6311CoreOO::JY6311CoreOODOTask

- s -

  • SendSoftwareTrigger() : JY6311CoreOO::JY6311CoreOOAITask
  • Start() : JY6311CoreOO::JY6311CoreOOAITask, JY6311CoreOO::JY6311CoreOODITask, JY6311CoreOO::JY6311CoreOODOTask
  • Stop() : JY6311CoreOO::JY6311CoreOOAITask, JY6311CoreOO::JY6311CoreOODITask, JY6311CoreOO::JY6311CoreOODOTask

- w -

  • WaitUntilDone() : JY6311CoreOO::JY6311CoreOOAITask
  • WriteSinglePoint() : JY6311CoreOO::JY6311CoreOODOTask

- ~ -

  • ~JY6311CoreOOAITask() : JY6311CoreOO::JY6311CoreOOAITask


6311 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • v
Here is a list of all variables with links to the classes they belong to:

- a -

  • ActivePolarity : JY6311CoreOO::PauseTrigger
  • AIBufferSize : JY6311CoreOO::JY6311CoreOODevice
  • AOChannelCount : JY6311CoreOO::JY6311CoreOODevice
  • AvailableSamples : JY6311CoreOO::JY6311CoreOOAITask

- b -

  • BoardClockRate : JY6311CoreOO::JY6311CoreOODevice
  • BufLenInSamples : JY6311CoreOO::JY6311CoreOOAITask

- c -

  • ChannelCount_Max : JY6311CoreOO::JY6311CoreOODevice
  • ChannelID : JY6311CoreOO::AIChannel
  • Channels : JY6311CoreOO::JY6311CoreOOAITask, JY6311CoreOO::JY6311CoreOODITask, JY6311CoreOO::JY6311CoreOODOTask

- d -

  • Device : JY6311CoreOO::JY6311CoreOOAITask, JY6311CoreOO::JY6311CoreOODITask, JY6311CoreOO::JY6311CoreOODOTask
  • DeviceID : JY6311CoreOO::JY6311CoreOODevice
  • Digital : JY6311CoreOO::AITrigger
  • DisableCalibration : JY6311CoreOO::JY6311CoreOOAITask

- e -

  • Edge : JY6311CoreOO::AIDigitalTrigger
  • EnableLog : JY6311CoreOO::JY6311CoreOOLog
  • errorCode : JY6311CoreOO::JYDriverException
  • exceptionMessage : JY6311CoreOO::JYDriverException
  • ExpectedRate : JY6311CoreOO::AIExternalSampleClock
  • External : JY6311CoreOO::AISampleClock, JY6311CoreOO::JY6311CoreOOReferenceClock

- f -

  • Filter : JY6311CoreOO::PFISetting
  • FollowingException : JY6311CoreOO::JYDriverException

- h -

  • Handle : JY6311CoreOO::JY6311CoreOODevice

- i -

  • IsAISync : JY6311CoreOO::JY6311CoreOODevice
  • IsAOSync : JY6311CoreOO::JY6311CoreOODevice

- l -

  • LogLevel : JY6311CoreOO::JY6311CoreOOLog

- m -

  • MaxChannelCount : JY6311CoreOO::JY6311CoreOODevice
  • MaxResistance_ForPT100 : JY6311CoreOO::JY6311CoreOODevice
  • MaxResistance_ForPT1000 : JY6311CoreOO::JY6311CoreOODevice
  • MaxSampleRate : JY6311CoreOO::JY6311CoreOODevice
  • MaxSampleRateSingleChannel : JY6311CoreOO::JY6311CoreOODevice
  • MeasurementType1 : JY6311CoreOO::AIChannel
  • MinSampleRate : JY6311CoreOO::JY6311CoreOODevice
  • MinSamplesToAcquire : JY6311CoreOO::JY6311CoreOODevice
  • Mode : JY6311CoreOO::AITrigger, JY6311CoreOO::JY6311CoreOOAITask

- p -

  • PFI : JY6311CoreOO::JY6311CoreOODevice
  • PortNum : JY6311CoreOO::DIChannel, JY6311CoreOO::DOChannel
  • PowerLine_Frequency : JY6311CoreOO::JY6311CoreOOAITask
  • PreTriggerSamples : JY6311CoreOO::AITrigger

- r -

  • ReferenceClock : JY6311CoreOO::JY6311CoreOODevice
  • ReTriggerCount : JY6311CoreOO::AITrigger
  • RTDTCRtype1 : JY6311CoreOO::AIChannel
  • RTDtype1 : JY6311CoreOO::AIChannel

- s -

  • SampleClock : JY6311CoreOO::JY6311CoreOOAITask
  • SampleRate : JY6311CoreOO::JY6311CoreOOAITask
  • SamplesToAcquire : JY6311CoreOO::JY6311CoreOOAITask
  • SerialNumber : JY6311CoreOO::JY6311CoreOODevice
  • SignalExport : JY6311CoreOO::JY6311CoreOOAITask
  • Source : JY6311CoreOO::AIDigitalTrigger, JY6311CoreOO::AISampleClock, JY6311CoreOO::JY6311CoreOOReferenceClock

- t -

  • Terminal : JY6311CoreOO::AIExternalSampleClock, JY6311CoreOO::ExternalReferenceClock, JY6311CoreOO::PauseTrigger
  • terminalType1 : JY6311CoreOO::AIChannel
  • TransferedSamples : JY6311CoreOO::JY6311CoreOOAITask
  • Trigger : JY6311CoreOO::JY6311CoreOOAITask
  • Type : JY6311CoreOO::AITrigger

- v -

  • VoltageRangeHigh : JY6311CoreOO::AIChannel
  • VoltageRangeLow : JY6311CoreOO::AIChannel


6311 C++ Programming Manual: File Members

  • File List
  • File Members
  • All
  • Macros
Here is a list of all file members with links to the files they belong to:
  • EXTERN_C : JY6311CoreOOCommon.h
  • JY6311CoreOO_API : JY6311CoreOOCommon.h


6311 C++ Programming Manual: File Members

  • File List
  • File Members
  • All
  • Macros
Here is a list of all macros with links to the files they belong to:
  • EXTERN_C : JY6311CoreOOCommon.h
  • JY6311CoreOO_API : JY6311CoreOOCommon.h


6311 C++ Programming Manual: Main Page

6311 C++ Programming Manual Documentation


6311 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
Here is a list of all namespace members with links to the namespace documentation for each member:
  • AIDigitalTriggerEdge : JY6311CoreOO
  • AIDigitalTriggerSource : JY6311CoreOO
  • AIMode : JY6311CoreOO
  • AISampleClockSource : JY6311CoreOO
  • AISignalExportSource : JY6311CoreOO
  • AITriggerMode : JY6311CoreOO
  • AITriggerType : JY6311CoreOO
  • ClockTerminal : JY6311CoreOO
  • ExternalReferenceClockTerminal : JY6311CoreOO
  • GetSignalExportDestinationString() : JY6311CoreOO
  • InputTerminal : JY6311CoreOO
  • IOTerminal : JY6311CoreOO
  • JY6311CoreOOLogLevel : JY6311CoreOO
  • JY6311CoreOOPropertyType : JY6311CoreOO
  • JYDriverExceptionPublic : JY6311CoreOO
  • LevelPolarity : JY6311CoreOO
  • MeasurementType : JY6311CoreOO
  • OutputCompleteState : JY6311CoreOO
  • PFITerminal : JY6311CoreOO
  • PowerLineFrequency : JY6311CoreOO
  • ReferenceClockSource : JY6311CoreOO
  • RTDTCRType : JY6311CoreOO
  • RTDTerminal : JY6311CoreOO
  • RTDType : JY6311CoreOO
  • SignalExportDestination : JY6311CoreOO


6311 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
Here is a list of all namespace enums with links to the namespace documentation for each enum:
  • AIDigitalTriggerEdge : JY6311CoreOO
  • AIDigitalTriggerSource : JY6311CoreOO
  • AIMode : JY6311CoreOO
  • AISampleClockSource : JY6311CoreOO
  • AISignalExportSource : JY6311CoreOO
  • AITriggerMode : JY6311CoreOO
  • AITriggerType : JY6311CoreOO
  • ClockTerminal : JY6311CoreOO
  • ExternalReferenceClockTerminal : JY6311CoreOO
  • InputTerminal : JY6311CoreOO
  • IOTerminal : JY6311CoreOO
  • JY6311CoreOOLogLevel : JY6311CoreOO
  • JY6311CoreOOPropertyType : JY6311CoreOO
  • JYDriverExceptionPublic : JY6311CoreOO
  • LevelPolarity : JY6311CoreOO
  • MeasurementType : JY6311CoreOO
  • OutputCompleteState : JY6311CoreOO
  • PFITerminal : JY6311CoreOO
  • PowerLineFrequency : JY6311CoreOO
  • ReferenceClockSource : JY6311CoreOO
  • RTDTCRType : JY6311CoreOO
  • RTDTerminal : JY6311CoreOO
  • RTDType : JY6311CoreOO
  • SignalExportDestination : JY6311CoreOO


6311 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
Here is a list of all namespace functions with links to the namespace documentation for each function:
  • GetSignalExportDestinationString() : JY6311CoreOO


6311 C++ Programming Manual: Namespace List

  • Namespace List
  • Namespace Members
Namespace List
Here is a list of all namespaces with brief descriptions:
N JY6311CoreOO