6311 C# Programming Manual: D:/6311/C#/JY6311AITask.cs File Reference

6311 C# Programming Manual
  • Main Page
  • Packages
  • Classes
  • Files
  • File List
  • 6311
  • C#
Classes | Namespaces | Enumerations
JY6311AITask.cs File Reference

Classes

class | JY6311.JY6311AITask
JY6311 AI task class which applies to temperature measurements using the PT100, or resistance measurements up to 400Ω. More...
class | JY6311.AIChannel
AI channel class. More...
class | JY6311.AIExternalSampleClock
External Sample Clock Configuration Class. More...
class | JY6311.AISampleClock
Sample clock configuration class. More...
class | JY6311.AIDigitalTrigger
AI Digital Trigger. More...
class | JY6311.AITrigger
AI Trigger class. More...
class | JY6311.AISignalExport
AI Signal Export Class. More...

Namespaces

namespace JY6311

Enumerations

enum | JY6311.AIMode { JY6311.Single = JY6311Import.JY6311_AI_Single , JY6311.Finite = JY6311Import.JY6311_AI_Finite , JY6311.Continuous = JY6311Import.JY6311_AI_Continuous }
AI mode enum type. More...
enum | JY6311.RTDTerminal { JY6311.TwoWire = JY6311Import.JY6311_AI_2Wire , JY6311.ThreeWire = JY6311Import.JY6311_AI_3Wire , JY6311.FourWire = JY6311Import.JY6311_AI_4Wire }
AI RTDTerminal type. More...
enum | JY6311.RTDType { JY6311.PT100 = JY6311Import.JY6311_AI_PT100 , JY6311.PT1000 = JY6311Import.JY6311_AI_PT1000 }
RTDType. More...
enum JY6311.RTDTCRType {
JY6311.Pt100_TCR3851 = JY6311Import.JY6311_AI_Pt100_TCR3851 , JY6311.Pt100_TCR3916 = JY6311Import.JY6311_AI_Pt100_TCR3916 , JY6311.Pt100_TCR3920 = JY6311Import.JY6311_AI_Pt100_TCR3920 , JY6311.Pt100_TCR3911 = JY6311Import.JY6311_AI_Pt100_TCR3911 ,
JY6311.Pt100_TCR3928 = JY6311Import.JY6311_AI_Pt100_TCR3928 , JY6311.Pt1000_TCR3851 = JY6311Import.JY6311_AI_Pt1000_TCR3851 , JY6311.Pt1000_TCR3750 = JY6311Import.JY6311_AI_Pt1000_TCR3750
}
RTD types supported by 6311, differentiate by TCR(temperature coefficient of resistance) More...
enum | JY6311.MeasureDataType { JY6311.Resistance = JY6311Import.JY6311_ReadDataType_Resistance , JY6311.Temperature = JY6311Import.JY6311_ReadDataType_Temperature }
MeasureDataType. More...
enum | JY6311.AITriggerType { JY6311.Immediate = JY6311Import.JY6311_TriggerType_Immediately , JY6311.Digital = JY6311Import.JY6311_TriggerType_Digital , JY6311.Soft = JY6311Import.JY6311_TriggerType_Soft }
Trigger Type: Digital/Soft/Immediate. More...
enum | JY6311.AIDigitalTriggerEdge { JY6311.Rising = JY6311Import.JY6311_DigitalTriggerEdge_Rising , JY6311.Falling = JY6311Import.JY6311_DigitalTriggerEdge_Falling }
AI Digital Trigger Edge. More...
enum | JY6311.AISampleClockSource { JY6311.Internal = JY6311Import.JY6311_AI_InternalClock , JY6311.External = JY6311Import.JY6311_AI_ExternalClock }
AI SampleClockSource Type. More...
enum JY6311.ClockTerminal {
JY6311.PFI0 = JY6311Import.JY6311_Clock_PFI_0 , JY6311.PFI1 = JY6311Import.JY6311_Clock_PFI_1 , JY6311.PFI2 = JY6311Import.JY6311_Clock_PFI_2 , JY6311.PXI_Trig0 = JY6311Import.JY6311_Clock_PXI_Trig_0 ,
JY6311.PXI_Trig1 = JY6311Import.JY6311_Clock_PXI_Trig_1 , JY6311.PXI_Trig2 = JY6311Import.JY6311_Clock_PXI_Trig_2 , JY6311.PXI_Trig3 = JY6311Import.JY6311_Clock_PXI_Trig_3 , JY6311.PXI_Trig4 = JY6311Import.JY6311_Clock_PXI_Trig_4 ,
JY6311.PXI_Trig5 = JY6311Import.JY6311_Clock_PXI_Trig_5 , JY6311.PXI_Trig6 = JY6311Import.JY6311_Clock_PXI_Trig_6 , JY6311.PXI_Trig7 = JY6311Import.JY6311_Clock_PXI_Trig_7 , JY6311.AI_SampleClock = JY6311Import.JY6311_AI_SampleClock
}
External Sample Clock Terminal. More...
enum | JY6311.AITriggerMode { JY6311.Start = JY6311Import.JY6311_TriggerMode_StartTrigger , JY6311.Reference = JY6311Import.JY6311_TriggerMode_ReferenceTrigger }
AI Trigger Mode. More...
enum JY6311.AIDigitalTriggerSource {
JY6311.PFI0 = JY6311Import.JY6311_DigitalTriggerSource_PFI_0 , JY6311.PFI1 = JY6311Import.JY6311_DigitalTriggerSource_PFI_1 , JY6311.PFI2 = JY6311Import.JY6311_DigitalTriggerSource_PFI_2 , JY6311.PXI_Trig0 = JY6311Import.JY6311_DigitalTriggerSource_PXITrigger_0 ,
JY6311.PXI_Trig1 = JY6311Import.JY6311_DigitalTriggerSource_PXITrigger_1 , JY6311.PXI_Trig2 = JY6311Import.JY6311_DigitalTriggerSource_PXITrigger_2 , JY6311.PXI_Trig3 = JY6311Import.JY6311_DigitalTriggerSource_PXITrigger_3 , JY6311.PXI_Trig4 = JY6311Import.JY6311_DigitalTriggerSource_PXITrigger_4 ,
JY6311.PXI_Trig5 = JY6311Import.JY6311_DigitalTriggerSource_PXITrigger_5 , JY6311.PXI_Trig6 = JY6311Import.JY6311_DigitalTriggerSource_PXITrigger_6 , JY6311.PXI_Trig7 = JY6311Import.JY6311_DigitalTriggerSource_PXITrigger_7
}
AI Digital Trigger Source. More...
enum | JY6311.AISignalExportSource { JY6311.StartTrig = JY6311Import.JY6311_AI_StartTrig , JY6311.ReferenceTrig = JY6311Import.JY6311_AI_ReferenceTrig , JY6311.SampleClock = JY6311Import.JY6311_AI_SampleClock }
AI Signal Export Source. More...
enum JY6311.SignalExportDestination {
JY6311.PFI0 = JY6311Import.JY6311_PFI0_OUT , JY6311.PFI1 = JY6311Import.JY6311_PFI1_OUT , JY6311.PFI2 = JY6311Import.JY6311_PFI2_OUT , JY6311.PXI_Trig0 = JY6311Import.JY6311_PXITrig0_OUT ,
JY6311.PXI_Trig1 = JY6311Import.JY6311_PXITrig1_OUT , JY6311.PXI_Trig2 = JY6311Import.JY6311_PXITrig2_OUT , JY6311.PXI_Trig3 = JY6311Import.JY6311_PXITrig3_OUT , JY6311.PXI_Trig4 = JY6311Import.JY6311_PXITrig4_OUT ,
JY6311.PXI_Trig5 = JY6311Import.JY6311_PXITrig5_OUT , JY6311.PXI_Trig6 = JY6311Import.JY6311_PXITrig6_OUT , JY6311.PXI_Trig7 = JY6311Import.JY6311_PXITrig7_OUT
}
Output DestinationTerminal. More...
enum | JY6311.PowerLineFrequency { JY6311._50Hz = JY6311Import.JY6311_PowerLineFrequency_50Hz , JY6311._60Hz = JY6311Import.JY6311_PowerLineFrequency_60Hz }
AC Power Line Frquency. More...
Generated by doxygen 1.12.0


6311 C# Programming Manual: D:/6311/C#/JY6311DITask.cs File Reference

  • Packages
  • Classes
  • Files
  • File List
  • 6311
  • C#
Classes | Namespaces
JY6311DITask.cs File Reference

Classes

class | JY6311.JY6311DITask
JY6311 Digital Iuput Task. More...
class | JY6311.JY6311DITask.DIChannel
DI Channel parameter class . More...

Namespaces

namespace JY6311


6311 C# Programming Manual: D:/6311/C#/JY6311DOTask.cs File Reference

  • File List
  • 6311
  • C#
Classes | Namespaces
JY6311DOTask.cs File Reference

Classes

class | JY6311.JY6311DOTask
JY6311 DOgital Output Task. More...
class | JY6311.DOChannel
DO Channel parameter class . More...

Namespaces

namespace JY6311


6311 C# Programming Manual: Class List

  • Class List
  • Class Index
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 123]
▼N JY6311 |
C AIChannel | AI channel class
C AIDigitalTrigger | AI Digital Trigger
C AIExternalSampleClock | External Sample Clock Configuration Class
C AISampleClock | Sample clock configuration class
C AISignalExport | AI Signal Export Class
C AITrigger | AI Trigger class
C DOChannel | DO Channel parameter class
C JY6311AITask | JY6311 AI task class which applies to temperature measurements using the PT100, or resistance measurements up to 400Ω
▼C JY6311DITask | JY6311 Digital Iuput Task
C DIChannel | DI Channel parameter class
C JY6311DOTask | JY6311 DOgital Output Task


6311 C# Programming Manual: JY6311.AIChannel Class Reference

  • JY6311
  • AIChannel
Public Member Functions | Properties | List of all members
JY6311.AIChannel Class Referencesealed

AI channel class. More...

Public Member Functions

AIChannel (int channelId, MeasureDataType measureDataType=MeasureDataType.Temperature, RTDType rtdType=RTDType.PT100, RTDTerminal terminalType=RTDTerminal.FourWire, RTDTCRType rtdTCRType=RTDTCRType.Pt100_TCR3851)
Constructor to create an AI channel object.

Properties

int | ChannelID [get]
AI channel ID.
MeasureDataType | MeasureDataType [get, set]
测量数据类型
RTDType | RTDType [get, set]
RTDType.
RTDTerminal | TerminalType [get, set]
RTDTerminal.
RTDTCRType | RTDTCRType [get, set]
RTDType.

Detailed Description

AI channel class.

Constructor & Destructor Documentation

◆ AIChannel()

JY6311.AIChannel.AIChannel | ( | int | channelId,
 |  | MeasureDataType | measureDataType = MeasureDataType::Temperature,
 |  | RTDType | rtdType = RTDType::PT100,
 |  | RTDTerminal | terminalType = RTDTerminal::FourWire,
 |  | RTDTCRType | rtdTCRType = RTDTCRType::Pt100_TCR3851 )

Constructor to create an AI channel object.

Parameters
channelId | AI channel phsical ID.
measureDataType | AI Measure Data Type.
rtdType | AI RTD Type.
terminalType | AI RTD Terminal Type.
rtdTCRType | AI RTD TCR Type.

Property Documentation

◆ ChannelID

int JY6311.AIChannel.ChannelID
get

AI channel ID.

◆ MeasureDataType

MeasureDataType JY6311.AIChannel.MeasureDataType
getset

测量数据类型

◆ RTDTCRType

RTDTCRType JY6311.AIChannel.RTDTCRType
getset

RTDType.

◆ RTDType

RTDType JY6311.AIChannel.RTDType
getset

RTDType.

◆ TerminalType

RTDTerminal JY6311.AIChannel.TerminalType
getset

RTDTerminal.

The documentation for this class was generated from the following file:
  • D:/6311/C#/JY6311AITask.cs


6311 C# Programming Manual: Member List

  • AIChannel
JY6311.AIChannel Member List

This is the complete list of members for JY6311.AIChannel, including all inherited members.

AIChannel(int channelId, MeasureDataType measureDataType=MeasureDataType.Temperature, RTDType rtdType=RTDType.PT100, RTDTerminal terminalType=RTDTerminal.FourWire, RTDTCRType rtdTCRType=RTDTCRType.Pt100_TCR3851) | JY6311.AIChannel
ChannelID | JY6311.AIChannel
MeasureDataType | JY6311.AIChannel
RTDTCRType | JY6311.AIChannel
RTDType | JY6311.AIChannel
TerminalType | JY6311.AIChannel


6311 C# Programming Manual: JY6311.AIDigitalTrigger Class Reference

  • AIDigitalTrigger
Properties | List of all members
JY6311.AIDigitalTrigger Class Reference

AI Digital Trigger. More...

Properties

AIDigitalTriggerSource | Source [get, set]
AI Digital Trigger Source.
AIDigitalTriggerEdge | Edge [get, set]
AI Digital Trigger Edge，Rising/Falling.

Detailed Description

AI Digital Trigger.

Property Documentation

◆ Edge

AIDigitalTriggerEdge JY6311.AIDigitalTrigger.Edge
getset

AI Digital Trigger Edge，Rising/Falling.

◆ Source

AIDigitalTriggerSource JY6311.AIDigitalTrigger.Source
getset

AI Digital Trigger Source.

The documentation for this class was generated from the following file:
  • D:/6311/C#/JY6311AITask.cs


6311 C# Programming Manual: Member List

  • AIDigitalTrigger
JY6311.AIDigitalTrigger Member List

This is the complete list of members for JY6311.AIDigitalTrigger, including all inherited members.

Edge | JY6311.AIDigitalTrigger
Source | JY6311.AIDigitalTrigger


6311 C# Programming Manual: JY6311.AIExternalSampleClock Class Reference

  • AIExternalSampleClock
Properties | List of all members
JY6311.AIExternalSampleClock Class Reference

External Sample Clock Configuration Class. More...

Properties

ClockTerminal | Terminal [get, set]
External Sample Clock Input Terminal.
double | ExpectedRate [get, set]
Expected External Sample Clock Rate.

Detailed Description

External Sample Clock Configuration Class.

Property Documentation

◆ ExpectedRate

double JY6311.AIExternalSampleClock.ExpectedRate
getset

Expected External Sample Clock Rate.

◆ Terminal

ClockTerminal JY6311.AIExternalSampleClock.Terminal
getset

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • D:/6311/C#/JY6311AITask.cs


6311 C# Programming Manual: Member List

  • AIExternalSampleClock
JY6311.AIExternalSampleClock Member List

This is the complete list of members for JY6311.AIExternalSampleClock, including all inherited members.

ExpectedRate | JY6311.AIExternalSampleClock
Terminal | JY6311.AIExternalSampleClock


6311 C# Programming Manual: JY6311.AISampleClock Class Reference

  • AISampleClock
Properties | List of all members
JY6311.AISampleClock Class Reference

Sample clock configuration class. More...

Properties

AISampleClockSource | Source [get, set]
Clock Source.
AIExternalSampleClock | External [get, set]
External Sample Clock， Valid when Source is AISampleClockSource.External.

Detailed Description

Sample clock configuration class.

Property Documentation

◆ External

AIExternalSampleClock JY6311.AISampleClock.External
getset

External Sample Clock， Valid when Source is AISampleClockSource.External.

◆ Source

AISampleClockSource JY6311.AISampleClock.Source
getset

Clock Source.

enum Internal/External,The default value is AISampleClockSource.Internal.

The documentation for this class was generated from the following file:
  • D:/6311/C#/JY6311AITask.cs


6311 C# Programming Manual: Member List

  • AISampleClock
JY6311.AISampleClock Member List

This is the complete list of members for JY6311.AISampleClock, including all inherited members.

External | JY6311.AISampleClock
Source | JY6311.AISampleClock


6311 C# Programming Manual: JY6311.AISignalExport Class Reference

  • AISignalExport
Public Member Functions | List of all members
JY6311.AISignalExport Class Reference

AI Signal Export Class. More...

Public Member Functions

void | Add (AISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (AISignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

AI Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY6311.AISignalExport.Add | ( | AISignalExportSource | source,
 |  | List< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | AI Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY6311.AISignalExport.Add | ( | AISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | AI Signal Source
destination | Export Desination

◆ Clear()

void JY6311.AISignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY6311.AISignalExport.ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • D:/6311/C#/JY6311AITask.cs


6311 C# Programming Manual: Member List

  • AISignalExport
JY6311.AISignalExport Member List

This is the complete list of members for JY6311.AISignalExport, including all inherited members.

Add(AISignalExportSource source, SignalExportDestination destination) | JY6311.AISignalExport
Add(AISignalExportSource source, List< SignalExportDestination > destinations) | JY6311.AISignalExport
Clear(SignalExportDestination destination) | JY6311.AISignalExport
ClearAll() | JY6311.AISignalExport


6311 C# Programming Manual: JY6311.AITrigger Class Reference

  • AITrigger
Properties | List of all members
JY6311.AITrigger Class Reference

AI Trigger class. More...

Properties

AITriggerType | Type [get, set]
AI Trigger Type,enum Analog/Digital/Immediate/Soft.
AITriggerMode | Mode [get, set]
AI Trigger Mode.
AIDigitalTrigger | Digital [get, set]
Digital Trigger Congfiguration.
int | ReTriggerCount [get, set]
Number of repeat triggers.
uint | PreTriggerSamples [get, set]
AI pretrigger samples, must be less than or equal to JY6311AITask.SamplesToAcquire.

Detailed Description

AI Trigger class.

Property Documentation

◆ Digital

AIDigitalTrigger JY6311.AITrigger.Digital
getset

Digital Trigger Congfiguration.

Valid when Type is AITriggerType.Digital.

◆ Mode

AITriggerMode JY6311.AITrigger.Mode
getset

AI Trigger Mode.

enum Start/Reference. The default value is AITriggerMode.Start.

◆ PreTriggerSamples

uint JY6311.AITrigger.PreTriggerSamples
getset

AI pretrigger samples, must be less than or equal to JY6311AITask.SamplesToAcquire.

Valid when Mode is AITriggerMode.Reference.

◆ ReTriggerCount

int JY6311.AITrigger.ReTriggerCount
getset

Number of repeat triggers.

When 0 or 1 only trigger once, When -1 continuous retrigger until stop.

◆ Type

AITriggerType JY6311.AITrigger.Type
getset

AI Trigger Type,enum Analog/Digital/Immediate/Soft.

The default value is AITriggerType.Immediate.

The documentation for this class was generated from the following file:
  • D:/6311/C#/JY6311AITask.cs


6311 C# Programming Manual: Member List

  • AITrigger
JY6311.AITrigger Member List

This is the complete list of members for JY6311.AITrigger, including all inherited members.

Digital | JY6311.AITrigger
Mode | JY6311.AITrigger
PreTriggerSamples | JY6311.AITrigger
ReTriggerCount | JY6311.AITrigger
Type | JY6311.AITrigger


6311 C# Programming Manual: JY6311.DOChannel Class Reference

  • DOChannel
Properties | List of all members
JY6311.DOChannel Class Referencesealed

DO Channel parameter class . More...

Properties

int LineID [get, set]
port number.

Detailed Description

DO Channel parameter class .

Property Documentation

◆ LineID

int JY6311.DOChannel.LineID
getset

port number.

The documentation for this class was generated from the following file:
  • D:/6311/C#/JY6311DOTask.cs


6311 C# Programming Manual: Member List

  • DOChannel
JY6311.DOChannel Member List

This is the complete list of members for JY6311.DOChannel, including all inherited members.

LineID JY6311.DOChannel


6311 C# Programming Manual: JY6311.JY6311AITask Class Reference

  • JY6311AITask
Public Member Functions | Properties | List of all members
JY6311.JY6311AITask Class Referencesealed

JY6311 AI task class which applies to temperature measurements using the PT100, or resistance measurements up to 400Ω. More...

Public Member Functions

JY6311AITask (int boardNum)
Constructor.
JY6311AITask (string boardName)
Constructor.
void | AddChannel (int channelID, MeasureDataType measureDataType=MeasureDataType.Temperature, RTDType rtdType=RTDType.PT100, RTDTerminal rtdTerminal=RTDTerminal.FourWire, RTDTCRType rtdTCRType=RTDTCRType.Pt100_TCR3851)
Add one/all channel(s).
void | AddChannel (int[] channelsID, MeasureDataType measureDataType=MeasureDataType.Temperature, RTDType rtdType=RTDType.PT100, RTDTerminal rtdTerminal=RTDTerminal.FourWire, RTDTCRType rtdTCRType=RTDTCRType.Pt100_TCR3851)
Add a group of channels.
void | AddChannel (int[] channelsID, MeasureDataType[] measureDataType, RTDType[] rtdType, RTDTerminal[] rtdTerminal, RTDTCRType[] rtdTCRType)
Add a group of channels.
void | RemoveChannel (int channelID)
Delete the channel with the specified channel number.
void | ReadRawData (ref int[] buf, int samplesPerChannel, int timeout)
Read one or multi-channel raw data and store it in a data buffer.
void | ReadRawData (ref int[] buf, int timeout)
Read one or multi-channel data of resistance value in Ω and store it in a data buffer.
void | ReadRawData (ref int[,] buf, int samplesPerChannel, int timeout)
Read one or multi-channel data of resistance value in Ω by columns and store it in a data buffer.
void | ReadRawData (ref int[,] buf, int timeout)
Read one or multi-channel data of resistance value in Ω by columns and store it in a data buffer.
void | ReadRawData (IntPtr buf, int samplesPerChannel, int timeout)
Read one or multi-channel data of resistance value in Ω and store it in a unmannaged data buffer.
void | ReadData (ref double[] buf, int samplesPerChannel, int timeout)
Read one or multi-channel data of temperature value in ℃ and store it in a data buffer.
void | ReadData (ref double[,] buf, int timeout)
Read one or multi-channel data of temperature value in ℃ by columns and store it in a data buffer.
void | ReadData (ref double[,] buf, int samplesPerChannel, int timeout)
Read one or multi-channel data of temperature value in ℃ by columns and store it in a data buffer.
void | ReadData (ref double[] buf, int timeout=-1)
Read one or multi-channel data of temperature value in ℃ and store it in a data buffer.
void | ReadData (IntPtr buf, int samplesPerChannel, int timeout)
Read one or multi-channel data of temperature value in ℃ and store it in a unmannaged data buffer.
void | ReadSinglePoint (ref double[] buf)
Read temperature value in ℃ on all enabled channels in unbuffered reading.
void | ReadSinglePoint (IntPtr buf)
Read temperature value in ℃ on all enabled channels in unbuffered reading.
void | ReadSinglePoint (ref double readValue, int channelID)
Read temperature value in ℃ for one specified channel in unbuffered reading.
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.
void | Start ()
Start AI task.
void | Stop ()
Stop AI task.
void | SendSoftwareTrigger ()
Send a software trigger signal.

Properties

JY6311Device | Device [get]
The device instance called by this AI task instance.
PowerLineFrequency | PowerLineFrequency [get, set]
PowerLineFrequency.
AIMode | Mode [get, set]
AI Sample Mode.
double | SampleRate [get, set]
Sampling rate per channel (Sample/s).
int | SamplesToAcquire [get, set]
Number of samples to acquire per channel.
ulong | AvailableSamples [get]
Number of samples per channel that can be read in the buffer.
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel).
AISampleClock | SampleClock [get, set]
Sample Clock Configuration.
AITrigger | Trigger [get, set]
Trigger Configuration.
List< AIChannel > | Channels [get, set]
List of channels.
AISignalExport | SignalExport [get, set]
Signal Export Configuration.
bool | DisableCalibration [get, set]
Disalble calibration.

Detailed Description

JY6311 AI task class which applies to temperature measurements using the PT100, or resistance measurements up to 400Ω.

Constructor & Destructor Documentation

◆ JY6311AITask() [1/2]

JY6311.JY6311AITask.JY6311AITask ( int boardNum )

Constructor.

Used to create an AI task object by board number.

Parameters
boardNum The slot number where the board is located, the first board will be opened when 0 is given.

◆ JY6311AITask() [2/2]

JY6311.JY6311AITask.JY6311AITask ( string boardName )

Constructor.

Used to create an AI task object by board name.

Parameters
boardName Board name(device alias), set by device manager

Member Function Documentation

◆ AddChannel() [1/3]

void JY6311.JY6311AITask.AddChannel | ( | int | channelID,
 |  | MeasureDataType | measureDataType = MeasureDataType::Temperature,
 |  | RTDType | rtdType = RTDType::PT100,
 |  | RTDTerminal | rtdTerminal = RTDTerminal::FourWire,
 |  | RTDTCRType | rtdTCRType = RTDTCRType::Pt100_TCR3851 )

Add one/all channel(s).

Parameters
channelID | Channel's physical number. chnId = -1: add all channels.
measureDataType | Measure data Type
rtdType | RTD Type
rtdTerminal | RTD Terminal
rtdTCRType | RTD TCR Type

◆ AddChannel() [2/3]

void JY6311.JY6311AITask.AddChannel | ( | int[] | channelsID,
 |  | MeasureDataType | measureDataType = MeasureDataType::Temperature,
 |  | RTDType | rtdType = RTDType::PT100,
 |  | RTDTerminal | rtdTerminal = RTDTerminal::FourWire,
 |  | RTDTCRType | rtdTCRType = RTDTCRType::Pt100_TCR3851 )

Add a group of channels.

Parameters
channelsID | Channel's physical number.
measureDataType | Measure data Type
rtdType | RTD Type
rtdTerminal | RTD Terminal
rtdTCRType | RTD TCR Type

◆ AddChannel() [3/3]

void JY6311.JY6311AITask.AddChannel | ( | int[] | channelsID,
 |  | MeasureDataType[] | measureDataType,
 |  | RTDType[] | rtdType,
 |  | RTDTerminal[] | rtdTerminal,
 |  | RTDTCRType[] | rtdTCRType )

Add a group of channels.

Parameters
channelsID | Channel's physical number.
measureDataType | Channel's Measure data Type
rtdType | Channel's RTD Type
rtdTerminal | Channel's RTD Terminal
rtdTCRType | Channel's RTD TCR Type

◆ ReadData() [1/5]

void JY6311.JY6311AITask.ReadData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read one or multi-channel data of temperature value in ℃ and store it in a unmannaged data buffer.

Parameters
buf | Data buffer.
samplesPerChannel | Number of samples per channel.
timeout | Timeout in ms before generating error message, timeout =-1 keep waiting until finish.

◆ ReadData() [2/5]

void JY6311.JY6311AITask.ReadData | ( | ref double | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read one or multi-channel data of temperature value in ℃ by columns and store it in a data buffer.

Each channel is represented by one column of data.

Parameters
buf | Data buffer.
samplesPerChannel | Number of samples per channel.
timeout | Timeout in ms before generating error message, timeout =-1 keep waiting until finish.

◆ ReadData() [3/5]

void JY6311.JY6311AITask.ReadData | ( | ref double | buf[,],
 |  | int | timeout )

Read one or multi-channel data of temperature value in ℃ by columns and store it in a data buffer.

Each channel is represented by one column of data.

Parameters
buf | Data buffer.
timeout | Timeout in ms before generating error message, timeout =-1 keep waiting until finish.

◆ ReadData() [4/5]

void JY6311.JY6311AITask.ReadData | ( | ref double[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read one or multi-channel data of temperature value in ℃ and store it in a data buffer.

Parameters
buf | Data buffer.
samplesPerChannel | Number of samples per channel.
timeout | Timeout in ms before generating error message, timeout =-1 keep waiting until finish.

◆ ReadData() [5/5]

void JY6311.JY6311AITask.ReadData | ( | ref double[] | buf,
 |  | int | timeout = -1 )

Read one or multi-channel data of temperature value in ℃ and store it in a data buffer.

Parameters
buf | Data buffer.
timeout | Timeout in ms before generating error message, timeout = -1 keep waiting until finish.

◆ ReadRawData() [1/5]

void JY6311.JY6311AITask.ReadRawData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read one or multi-channel data of resistance value in Ω and store it in a unmannaged data buffer.

Parameters
buf | Data buffer.
samplesPerChannel | Number of samples per channel.
timeout | Timeout in ms before generating error message, timeout =-1 keep waiting until finish.

◆ ReadRawData() [2/5]

void JY6311.JY6311AITask.ReadRawData | ( | ref int | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read one or multi-channel data of resistance value in Ω by columns and store it in a data buffer.

Parameters
buf | Data buffer.
samplesPerChannel | Number of samples per channel.
timeout | Timeout in ms before generating error message, timeout =-1 keep waiting until finish.

◆ ReadRawData() [3/5]

void JY6311.JY6311AITask.ReadRawData | ( | ref int | buf[,],
 |  | int | timeout )

Read one or multi-channel data of resistance value in Ω by columns and store it in a data buffer.

Parameters
buf | Data buffer.
timeout | Timeout in ms before generating error message, timeout =-1 keep waiting until finish.

◆ ReadRawData() [4/5]

void JY6311.JY6311AITask.ReadRawData | ( | ref int[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read one or multi-channel raw data and store it in a data buffer.

Parameters
buf | Data buffer.原始数据
samplesPerChannel | Number of samples per channel.
timeout | Timeout in ms before generating error message, timeout =-1 keep waiting until finish.

◆ ReadRawData() [5/5]

void JY6311.JY6311AITask.ReadRawData | ( | ref int[] | buf,
 |  | int | timeout )

Read one or multi-channel data of resistance value in Ω and store it in a data buffer.

Parameters
buf | Data buffer.
timeout | Timeout in ms before generating error message, timeout =-1 keep waiting until finish.

◆ ReadSinglePoint() [1/3]

void JY6311.JY6311AITask.ReadSinglePoint ( IntPtr buf )

Read temperature value in ℃ on all enabled channels in unbuffered reading.

Parameters
buf Data buffer.

◆ ReadSinglePoint() [2/3]

void JY6311.JY6311AITask.ReadSinglePoint | ( | ref double | readValue,
 |  | int | channelID )

Read temperature value in ℃ for one specified channel in unbuffered reading.

Parameters
readValue Read value.
channelID

◆ ReadSinglePoint() [3/3]

void JY6311.JY6311AITask.ReadSinglePoint ( ref double[] buf )

Read temperature value in ℃ on all enabled channels in unbuffered reading.

Parameters
buf Data buffer

◆ RemoveChannel()

void JY6311.JY6311AITask.RemoveChannel ( int channelID )

Delete the channel with the specified channel number.

Parameters
channelID Specified channel ID. chnId = -1: remove all channels.

◆ SendSoftwareTrigger()

void JY6311.JY6311AITask.SendSoftwareTrigger ( )

Send a software trigger signal.

Returns

◆ Start()

void JY6311.JY6311AITask.Start ( )

Start AI task.

◆ Stop()

void JY6311.JY6311AITask.Stop ( )

Stop AI task.

◆ WaitUntilDone()

bool JY6311.JY6311AITask.WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Only valid in finite mode.

Parameters
timeout Timeout (ms). Wait until current task to be completed. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.
Returns
Whether the task has been completed

Property Documentation

◆ AvailableSamples

ulong JY6311.JY6311AITask.AvailableSamples
get

Number of samples per channel that can be read in the buffer.

◆ Channels

List<AIChannel> JY6311.JY6311AITask.Channels
getset

List of channels.

◆ Device

JY6311Device JY6311.JY6311AITask.Device
get

The device instance called by this AI task instance.

◆ DisableCalibration

bool JY6311.JY6311AITask.DisableCalibration
getset

Disalble calibration.

◆ Mode

AIMode JY6311.JY6311AITask.Mode
getset

AI Sample Mode.

◆ PowerLineFrequency

PowerLineFrequency JY6311.JY6311AITask.PowerLineFrequency
getset

PowerLineFrequency.

6311 can reject 50Hz or 60Hz components when the TOTAL sampling rate is less than or equal to 40Sa/s.

◆ SampleClock

AISampleClock JY6311.JY6311AITask.SampleClock
getset

Sample Clock Configuration.

◆ SampleRate

double JY6311.JY6311AITask.SampleRate
getset

Sampling rate per channel (Sample/s).

The minimum is 0.275Sa/s and the maximum is 800Sa/s. The actual sampling rate is subject to the timing mode, the number of channels, and the rounding operation. You can read this property to obtain the sampling rate that will actually take effect in the current configuration. This property is invalid when JY6311AITask.Mode is AIMode.Single.

◆ SamplesToAcquire

int JY6311.JY6311AITask.SamplesToAcquire
getset

Number of samples to acquire per channel.

Only valid when JY6311AITask.Mode is AIMode.Finite.

◆ SignalExport

AISignalExport JY6311.JY6311AITask.SignalExport
getset

Signal Export Configuration.

◆ TransferedSamples

ulong JY6311.JY6311AITask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT AIMode.Single.

◆ Trigger

AITrigger JY6311.JY6311AITask.Trigger
getset

Trigger Configuration.

The documentation for this class was generated from the following file:
  • D:/6311/C#/JY6311AITask.cs


6311 C# Programming Manual: Member List

  • JY6311AITask
JY6311.JY6311AITask Member List

This is the complete list of members for JY6311.JY6311AITask, including all inherited members.

AddChannel(int channelID, MeasureDataType measureDataType=MeasureDataType.Temperature, RTDType rtdType=RTDType.PT100, RTDTerminal rtdTerminal=RTDTerminal.FourWire, RTDTCRType rtdTCRType=RTDTCRType.Pt100_TCR3851) | JY6311.JY6311AITask
AddChannel(int[] channelsID, MeasureDataType measureDataType=MeasureDataType.Temperature, RTDType rtdType=RTDType.PT100, RTDTerminal rtdTerminal=RTDTerminal.FourWire, RTDTCRType rtdTCRType=RTDTCRType.Pt100_TCR3851) | JY6311.JY6311AITask
AddChannel(int[] channelsID, MeasureDataType[] measureDataType, RTDType[] rtdType, RTDTerminal[] rtdTerminal, RTDTCRType[] rtdTCRType) | JY6311.JY6311AITask
AvailableSamples | JY6311.JY6311AITask
Channels | JY6311.JY6311AITask
Device | JY6311.JY6311AITask
DisableCalibration | JY6311.JY6311AITask
JY6311AITask(int boardNum) | JY6311.JY6311AITask
JY6311AITask(string boardName) | JY6311.JY6311AITask
Mode | JY6311.JY6311AITask
PowerLineFrequency | JY6311.JY6311AITask
ReadData(ref double[] buf, int samplesPerChannel, int timeout) | JY6311.JY6311AITask
ReadData(ref double[,] buf, int timeout) | JY6311.JY6311AITask
ReadData(ref double[,] buf, int samplesPerChannel, int timeout) | JY6311.JY6311AITask
ReadData(ref double[] buf, int timeout=-1) | JY6311.JY6311AITask
ReadData(IntPtr buf, int samplesPerChannel, int timeout) | JY6311.JY6311AITask
ReadRawData(ref int[] buf, int samplesPerChannel, int timeout) | JY6311.JY6311AITask
ReadRawData(ref int[] buf, int timeout) | JY6311.JY6311AITask
ReadRawData(ref int[,] buf, int samplesPerChannel, int timeout) | JY6311.JY6311AITask
ReadRawData(ref int[,] buf, int timeout) | JY6311.JY6311AITask
ReadRawData(IntPtr buf, int samplesPerChannel, int timeout) | JY6311.JY6311AITask
ReadSinglePoint(ref double[] buf) | JY6311.JY6311AITask
ReadSinglePoint(IntPtr buf) | JY6311.JY6311AITask
ReadSinglePoint(ref double readValue, int channelID) | JY6311.JY6311AITask
RemoveChannel(int channelID) | JY6311.JY6311AITask
SampleClock | JY6311.JY6311AITask
SampleRate | JY6311.JY6311AITask
SamplesToAcquire | JY6311.JY6311AITask
SendSoftwareTrigger() | JY6311.JY6311AITask
SignalExport | JY6311.JY6311AITask
Start() | JY6311.JY6311AITask
Stop() | JY6311.JY6311AITask
TransferedSamples | JY6311.JY6311AITask
Trigger | JY6311.JY6311AITask
WaitUntilDone(int timeout=-1) | JY6311.JY6311AITask


6311 C# Programming Manual: JY6311.JY6311DITask Class Reference

  • JY6311DITask
Classes | Public Member Functions | Properties | List of all members
JY6311.JY6311DITask Class Referencesealed

JY6311 Digital Iuput Task. More...

Classes

class DIChannel
DI Channel parameter class . More...

Public Member Functions

JY6311DITask (int slotNum)
Constructor.
JY6311DITask (string boardName)
Constructor.
void | AddChannel (int lineID)
Add one channel.
void | AddChannel (int[] linesID)
Add a group of channel.
void | RemoveChannel (int lineID)
Delete the specified port number .If it is -1, delete all ports.
void | Start ()
Start DI task .
void | Stop ()
Stop DI task .
void | ReadSinglePoint (ref bool[] readValues)
ReadSinglePoint.
void | ReadSinglePoint (ref bool readValue, int lineNum)
ReadSinglePoint.

Properties

List< DIChannel > | Channels [get]
List of DI channels,(5111 support 3 ports)
JY6311Device | Device [get]
Device.

Detailed Description

JY6311 Digital Iuput Task.

Constructor & Destructor Documentation

◆ JY6311DITask() [1/2]

JY6311.JY6311DITask.JY6311DITask ( int slotNum )

Constructor.

Used to create an DItask by a slot number.

Parameters
slotNum Card slot number.

◆ JY6311DITask() [2/2]

JY6311.JY6311DITask.JY6311DITask ( string boardName )

Constructor.

Used to create an DI task by a board name.

Parameters
boardName Board name(device alias), set by device manager

Member Function Documentation

◆ AddChannel() [1/2]

void JY6311.JY6311DITask.AddChannel ( int lineID )

Add one channel.

Parameters
lineID port number to be added.

◆ AddChannel() [2/2]

void JY6311.JY6311DITask.AddChannel ( int[] linesID )

Add a group of channel.

Parameters
portsNum an array of port numbers of added ports.

◆ ReadSinglePoint() [1/2]

void JY6311.JY6311DITask.ReadSinglePoint | ( | ref bool | readValue,
 |  | int | lineNum )

ReadSinglePoint.

Parameters
readValue
lineNum

◆ ReadSinglePoint() [2/2]

void JY6311.JY6311DITask.ReadSinglePoint ( ref bool[] readValues )

ReadSinglePoint.

Parameters
readValues

◆ RemoveChannel()

void JY6311.JY6311DITask.RemoveChannel ( int lineID )

Delete the specified port number .If it is -1, delete all ports.

Parameters
lineID port number to be delete.

◆ Start()

void JY6311.JY6311DITask.Start ( )

Start DI task .

◆ Stop()

void JY6311.JY6311DITask.Stop ( )

Stop DI task .

Property Documentation

◆ Channels

List<DIChannel> JY6311.JY6311DITask.Channels
get

List of DI channels,(5111 support 3 ports)

◆ Device

JY6311Device JY6311.JY6311DITask.Device
get

Device.

The documentation for this class was generated from the following file:
  • D:/6311/C#/JY6311DITask.cs


6311 C# Programming Manual: Member List

  • JY6311DITask
JY6311.JY6311DITask Member List

This is the complete list of members for JY6311.JY6311DITask, including all inherited members.

AddChannel(int lineID) | JY6311.JY6311DITask
AddChannel(int[] linesID) | JY6311.JY6311DITask
Channels | JY6311.JY6311DITask
Device | JY6311.JY6311DITask
JY6311DITask(int slotNum) | JY6311.JY6311DITask
JY6311DITask(string boardName) | JY6311.JY6311DITask
ReadSinglePoint(ref bool[] readValues) | JY6311.JY6311DITask
ReadSinglePoint(ref bool readValue, int lineNum) | JY6311.JY6311DITask
RemoveChannel(int lineID) | JY6311.JY6311DITask
Start() | JY6311.JY6311DITask
Stop() | JY6311.JY6311DITask


6311 C# Programming Manual: JY6311.JY6311DITask.DIChannel Class Reference

  • JY6311DITask
  • DIChannel
Properties | List of all members
JY6311.JY6311DITask.DIChannel Class Referencesealed

DI Channel parameter class . More...

Properties

int LineID [get, set]
port number.

Detailed Description

DI Channel parameter class .

Property Documentation

◆ LineID

int JY6311.JY6311DITask.DIChannel.LineID
getset

port number.

The documentation for this class was generated from the following file:
  • D:/6311/C#/JY6311DITask.cs


6311 C# Programming Manual: Member List

  • JY6311DITask
  • DIChannel
JY6311.JY6311DITask.DIChannel Member List

This is the complete list of members for JY6311.JY6311DITask.DIChannel, including all inherited members.

LineID JY6311.JY6311DITask.DIChannel


6311 C# Programming Manual: JY6311.JY6311DOTask Class Reference

  • JY6311DOTask
Public Member Functions | Properties | List of all members
JY6311.JY6311DOTask Class Referencesealed

JY6311 DOgital Output Task. More...

Public Member Functions

JY6311DOTask (int slotNum)
Constructor.
JY6311DOTask (string boardName)
Constructor.
void | AddChannel (int lineID)
Add one channel.
void | AddChannel (int[] linesID)
Add a group of channel.
void | RemoveChannel (int lineID)
Delete the specified port number .If it is -1, delete all ports.
void | Start ()
Start DO task .
void | Stop ()
Stop DO task .
void | WriteSinglePoint (bool[] writeValues)
write one sample to multi lines in register .
void | WriteSinglePoint (bool writeValue, int lineID)
Write one sample to the specified line in register.Available when Mode is DOMode.Single

Properties

List< DOChannel > | Channels [get]
List of DO channels,(5111 support 3 ports)
JY6311Device | Device [get]
Device.

Detailed Description

JY6311 DOgital Output Task.

Constructor & Destructor Documentation

◆ JY6311DOTask() [1/2]

JY6311.JY6311DOTask.JY6311DOTask ( int slotNum )

Constructor.

Used to create an DOtask by a slot number.

Parameters
slotNum Card slot number.

◆ JY6311DOTask() [2/2]

JY6311.JY6311DOTask.JY6311DOTask ( string boardName )

Constructor.

Used to create an DO task by a board name.

Parameters
boardName Board name(device alias), set by device manager

Member Function Documentation

◆ AddChannel() [1/2]

void JY6311.JY6311DOTask.AddChannel ( int lineID )

Add one channel.

Parameters
lineID port number to be added.

◆ AddChannel() [2/2]

void JY6311.JY6311DOTask.AddChannel ( int[] linesID )

Add a group of channel.

Parameters
linesID an array of port numbers of added ports.

◆ RemoveChannel()

void JY6311.JY6311DOTask.RemoveChannel ( int lineID )

Delete the specified port number .If it is -1, delete all ports.

Parameters
lineID port number to be delete.

◆ Start()

void JY6311.JY6311DOTask.Start ( )

Start DO task .

◆ Stop()

void JY6311.JY6311DOTask.Stop ( )

Stop DO task .

◆ WriteSinglePoint() [1/2]

void JY6311.JY6311DOTask.WriteSinglePoint | ( | bool | writeValue,
 |  | int | lineID )

Write one sample to the specified line in register.Available when Mode is DOMode.Single

Parameters
writeValue | Write value.
lineID | Specified line.

◆ WriteSinglePoint() [2/2]

void JY6311.JY6311DOTask.WriteSinglePoint ( bool[] writeValues )

write one sample to multi lines in register .

Available when Mode is DOMode.Single

Parameters
writeValues write Values.Buffer size >= number of lines。

Property Documentation

◆ Channels

List<DOChannel> JY6311.JY6311DOTask.Channels
get

List of DO channels,(5111 support 3 ports)

◆ Device

JY6311Device JY6311.JY6311DOTask.Device
get

Device.

The documentation for this class was generated from the following file:
  • D:/6311/C#/JY6311DOTask.cs


6311 C# Programming Manual: Member List

  • JY6311DOTask
JY6311.JY6311DOTask Member List

This is the complete list of members for JY6311.JY6311DOTask, including all inherited members.

AddChannel(int lineID) | JY6311.JY6311DOTask
AddChannel(int[] linesID) | JY6311.JY6311DOTask
Channels | JY6311.JY6311DOTask
Device | JY6311.JY6311DOTask
JY6311DOTask(int slotNum) | JY6311.JY6311DOTask
JY6311DOTask(string boardName) | JY6311.JY6311DOTask
RemoveChannel(int lineID) | JY6311.JY6311DOTask
Start() | JY6311.JY6311DOTask
Stop() | JY6311.JY6311DOTask
WriteSinglePoint(bool[] writeValues) | JY6311.JY6311DOTask
WriteSinglePoint(bool writeValue, int lineID) | JY6311.JY6311DOTask


6311 C# Programming Manual: Class Index

Class Index
A | D | J
A
AIChannel (JY6311)
AIDigitalTrigger (JY6311)
AIExternalSampleClock (JY6311)
AISampleClock (JY6311)
AISignalExport (JY6311)
AITrigger (JY6311)
D
JY6311DITask.DIChannel (JY6311)
DOChannel (JY6311)
J
JY6311AITask (JY6311)
JY6311DITask (JY6311)
JY6311DOTask (JY6311)


6311 C# Programming Manual: D:/6311 Directory Reference

  • File List
  • 6311
6311 Directory Reference

Directories

C#


6311 C# Programming Manual: D:/6311/C# Directory Reference

  • File List
  • 6311
  • C#
C# Directory Reference

Files

JY6311AITask.cs
JY6311DITask.cs
JY6311DOTask.cs


6311 C# Programming Manual: File List

  • File List
File List
Here is a list of all files with brief descriptions:
[detail level 123]
▼ 6311
▼ C#
JY6311AITask.cs
JY6311DITask.cs
JY6311DOTask.cs


6311 C# Programming Manual: Class Members

  • All
  • Functions
  • Properties
  • a
  • c
  • d
  • e
  • j
  • l
  • m
  • p
  • r
  • s
  • t
  • w
Here is a list of all class members with links to the classes they belong to:

- a -

  • Add() : JY6311.AISignalExport
  • AddChannel() : JY6311.JY6311AITask, JY6311.JY6311DITask, JY6311.JY6311DOTask
  • AIChannel() : JY6311.AIChannel
  • AvailableSamples : JY6311.JY6311AITask

- c -

  • ChannelID : JY6311.AIChannel
  • Channels : JY6311.JY6311AITask, JY6311.JY6311DITask, JY6311.JY6311DOTask
  • Clear() : JY6311.AISignalExport
  • ClearAll() : JY6311.AISignalExport

- d -

  • Device : JY6311.JY6311AITask, JY6311.JY6311DITask, JY6311.JY6311DOTask
  • Digital : JY6311.AITrigger
  • DisableCalibration : JY6311.JY6311AITask

- e -

  • Edge : JY6311.AIDigitalTrigger
  • ExpectedRate : JY6311.AIExternalSampleClock
  • External : JY6311.AISampleClock

- j -

  • JY6311AITask() : JY6311.JY6311AITask
  • JY6311DITask() : JY6311.JY6311DITask
  • JY6311DOTask() : JY6311.JY6311DOTask

- l -

  • LineID : JY6311.DOChannel, JY6311.JY6311DITask.DIChannel

- m -

  • MeasureDataType : JY6311.AIChannel
  • Mode : JY6311.AITrigger, JY6311.JY6311AITask

- p -

  • PowerLineFrequency : JY6311.JY6311AITask
  • PreTriggerSamples : JY6311.AITrigger

- r -

  • ReadData() : JY6311.JY6311AITask
  • ReadRawData() : JY6311.JY6311AITask
  • ReadSinglePoint() : JY6311.JY6311AITask, JY6311.JY6311DITask
  • RemoveChannel() : JY6311.JY6311AITask, JY6311.JY6311DITask, JY6311.JY6311DOTask
  • ReTriggerCount : JY6311.AITrigger
  • RTDTCRType : JY6311.AIChannel
  • RTDType : JY6311.AIChannel

- s -

  • SampleClock : JY6311.JY6311AITask
  • SampleRate : JY6311.JY6311AITask
  • SamplesToAcquire : JY6311.JY6311AITask
  • SendSoftwareTrigger() : JY6311.JY6311AITask
  • SignalExport : JY6311.JY6311AITask
  • Source : JY6311.AIDigitalTrigger, JY6311.AISampleClock
  • Start() : JY6311.JY6311AITask, JY6311.JY6311DITask, JY6311.JY6311DOTask
  • Stop() : JY6311.JY6311AITask, JY6311.JY6311DITask, JY6311.JY6311DOTask

- t -

  • Terminal : JY6311.AIExternalSampleClock
  • TerminalType : JY6311.AIChannel
  • TransferedSamples : JY6311.JY6311AITask
  • Trigger : JY6311.JY6311AITask
  • Type : JY6311.AITrigger

- w -

  • WaitUntilDone() : JY6311.JY6311AITask
  • WriteSinglePoint() : JY6311.JY6311DOTask


6311 C# Programming Manual: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • c
  • j
  • r
  • s
  • w
Here is a list of all functions with links to the classes they belong to:

- a -

  • Add() : JY6311.AISignalExport
  • AddChannel() : JY6311.JY6311AITask, JY6311.JY6311DITask, JY6311.JY6311DOTask
  • AIChannel() : JY6311.AIChannel

- c -

  • Clear() : JY6311.AISignalExport
  • ClearAll() : JY6311.AISignalExport

- j -

  • JY6311AITask() : JY6311.JY6311AITask
  • JY6311DITask() : JY6311.JY6311DITask
  • JY6311DOTask() : JY6311.JY6311DOTask

- r -

  • ReadData() : JY6311.JY6311AITask
  • ReadRawData() : JY6311.JY6311AITask
  • ReadSinglePoint() : JY6311.JY6311AITask, JY6311.JY6311DITask
  • RemoveChannel() : JY6311.JY6311AITask, JY6311.JY6311DITask, JY6311.JY6311DOTask

- s -

  • SendSoftwareTrigger() : JY6311.JY6311AITask
  • Start() : JY6311.JY6311AITask, JY6311.JY6311DITask, JY6311.JY6311DOTask
  • Stop() : JY6311.JY6311AITask, JY6311.JY6311DITask, JY6311.JY6311DOTask

- w -

  • WaitUntilDone() : JY6311.JY6311AITask
  • WriteSinglePoint() : JY6311.JY6311DOTask


6311 C# Programming Manual: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • c
  • d
  • e
  • l
  • m
  • p
  • r
  • s
  • t
Here is a list of all properties with links to the classes they belong to:

- a -

  • AvailableSamples : JY6311.JY6311AITask

- c -

  • ChannelID : JY6311.AIChannel
  • Channels : JY6311.JY6311AITask, JY6311.JY6311DITask, JY6311.JY6311DOTask

- d -

  • Device : JY6311.JY6311AITask, JY6311.JY6311DITask, JY6311.JY6311DOTask
  • Digital : JY6311.AITrigger
  • DisableCalibration : JY6311.JY6311AITask

- e -

  • Edge : JY6311.AIDigitalTrigger
  • ExpectedRate : JY6311.AIExternalSampleClock
  • External : JY6311.AISampleClock

- l -

  • LineID : JY6311.DOChannel, JY6311.JY6311DITask.DIChannel

- m -

  • MeasureDataType : JY6311.AIChannel
  • Mode : JY6311.AITrigger, JY6311.JY6311AITask

- p -

  • PowerLineFrequency : JY6311.JY6311AITask
  • PreTriggerSamples : JY6311.AITrigger

- r -

  • ReTriggerCount : JY6311.AITrigger
  • RTDTCRType : JY6311.AIChannel
  • RTDType : JY6311.AIChannel

- s -

  • SampleClock : JY6311.JY6311AITask
  • SampleRate : JY6311.JY6311AITask
  • SamplesToAcquire : JY6311.JY6311AITask
  • SignalExport : JY6311.JY6311AITask
  • Source : JY6311.AIDigitalTrigger, JY6311.AISampleClock

- t -

  • Terminal : JY6311.AIExternalSampleClock
  • TerminalType : JY6311.AIChannel
  • TransferedSamples : JY6311.JY6311AITask
  • Trigger : JY6311.JY6311AITask
  • Type : JY6311.AITrigger


6311 C# Programming Manual: Main Page

6311 C# Programming Manual Documentation


6311 C# Programming Manual: JY6311 Namespace Reference

  • Package List
  • Package Members
Classes | Enumerations
JY6311 Namespace Reference

Classes

class | AIChannel
AI channel class. More...
class | AIDigitalTrigger
AI Digital Trigger. More...
class | AIExternalSampleClock
External Sample Clock Configuration Class. More...
class | AISampleClock
Sample clock configuration class. More...
class | AISignalExport
AI Signal Export Class. More...
class | AITrigger
AI Trigger class. More...
class | DOChannel
DO Channel parameter class . More...
class | JY6311AITask
JY6311 AI task class which applies to temperature measurements using the PT100, or resistance measurements up to 400Ω. More...
class | JY6311DITask
JY6311 Digital Iuput Task. More...
class | JY6311DOTask
JY6311 DOgital Output Task. More...

Enumerations

enum | AIMode { Single = JY6311Import.JY6311_AI_Single , Finite = JY6311Import.JY6311_AI_Finite , Continuous = JY6311Import.JY6311_AI_Continuous }
AI mode enum type. More...
enum | RTDTerminal { TwoWire = JY6311Import.JY6311_AI_2Wire , ThreeWire = JY6311Import.JY6311_AI_3Wire , FourWire = JY6311Import.JY6311_AI_4Wire }
AI RTDTerminal type. More...
enum | RTDType { PT100 = JY6311Import.JY6311_AI_PT100 , PT1000 = JY6311Import.JY6311_AI_PT1000 }
RTDType. More...
enum RTDTCRType {
Pt100_TCR3851 = JY6311Import.JY6311_AI_Pt100_TCR3851 , Pt100_TCR3916 = JY6311Import.JY6311_AI_Pt100_TCR3916 , Pt100_TCR3920 = JY6311Import.JY6311_AI_Pt100_TCR3920 , Pt100_TCR3911 = JY6311Import.JY6311_AI_Pt100_TCR3911 ,
Pt100_TCR3928 = JY6311Import.JY6311_AI_Pt100_TCR3928 , Pt1000_TCR3851 = JY6311Import.JY6311_AI_Pt1000_TCR3851 , Pt1000_TCR3750 = JY6311Import.JY6311_AI_Pt1000_TCR3750
}
RTD types supported by 6311, differentiate by TCR(temperature coefficient of resistance) More...
enum | MeasureDataType { Resistance = JY6311Import.JY6311_ReadDataType_Resistance , Temperature = JY6311Import.JY6311_ReadDataType_Temperature }
MeasureDataType. More...
enum | AITriggerType { Immediate = JY6311Import.JY6311_TriggerType_Immediately , Digital = JY6311Import.JY6311_TriggerType_Digital , Soft = JY6311Import.JY6311_TriggerType_Soft }
Trigger Type: Digital/Soft/Immediate. More...
enum | AIDigitalTriggerEdge { Rising = JY6311Import.JY6311_DigitalTriggerEdge_Rising , Falling = JY6311Import.JY6311_DigitalTriggerEdge_Falling }
AI Digital Trigger Edge. More...
enum | AISampleClockSource { Internal = JY6311Import.JY6311_AI_InternalClock , External = JY6311Import.JY6311_AI_ExternalClock }
AI SampleClockSource Type. More...
enum ClockTerminal {
PFI0 = JY6311Import.JY6311_Clock_PFI_0 , PFI1 = JY6311Import.JY6311_Clock_PFI_1 , PFI2 = JY6311Import.JY6311_Clock_PFI_2 , PXI_Trig0 = JY6311Import.JY6311_Clock_PXI_Trig_0 ,
PXI_Trig1 = JY6311Import.JY6311_Clock_PXI_Trig_1 , PXI_Trig2 = JY6311Import.JY6311_Clock_PXI_Trig_2 , PXI_Trig3 = JY6311Import.JY6311_Clock_PXI_Trig_3 , PXI_Trig4 = JY6311Import.JY6311_Clock_PXI_Trig_4 ,
PXI_Trig5 = JY6311Import.JY6311_Clock_PXI_Trig_5 , PXI_Trig6 = JY6311Import.JY6311_Clock_PXI_Trig_6 , PXI_Trig7 = JY6311Import.JY6311_Clock_PXI_Trig_7 , AI_SampleClock = JY6311Import.JY6311_AI_SampleClock
}
External Sample Clock Terminal. More...
enum | AITriggerMode { Start = JY6311Import.JY6311_TriggerMode_StartTrigger , Reference = JY6311Import.JY6311_TriggerMode_ReferenceTrigger }
AI Trigger Mode. More...
enum AIDigitalTriggerSource {
PFI0 = JY6311Import.JY6311_DigitalTriggerSource_PFI_0 , PFI1 = JY6311Import.JY6311_DigitalTriggerSource_PFI_1 , PFI2 = JY6311Import.JY6311_DigitalTriggerSource_PFI_2 , PXI_Trig0 = JY6311Import.JY6311_DigitalTriggerSource_PXITrigger_0 ,
PXI_Trig1 = JY6311Import.JY6311_DigitalTriggerSource_PXITrigger_1 , PXI_Trig2 = JY6311Import.JY6311_DigitalTriggerSource_PXITrigger_2 , PXI_Trig3 = JY6311Import.JY6311_DigitalTriggerSource_PXITrigger_3 , PXI_Trig4 = JY6311Import.JY6311_DigitalTriggerSource_PXITrigger_4 ,
PXI_Trig5 = JY6311Import.JY6311_DigitalTriggerSource_PXITrigger_5 , PXI_Trig6 = JY6311Import.JY6311_DigitalTriggerSource_PXITrigger_6 , PXI_Trig7 = JY6311Import.JY6311_DigitalTriggerSource_PXITrigger_7
}
AI Digital Trigger Source. More...
enum | AISignalExportSource { StartTrig = JY6311Import.JY6311_AI_StartTrig , ReferenceTrig = JY6311Import.JY6311_AI_ReferenceTrig , SampleClock = JY6311Import.JY6311_AI_SampleClock }
AI Signal Export Source. More...
enum SignalExportDestination {
PFI0 = JY6311Import.JY6311_PFI0_OUT , PFI1 = JY6311Import.JY6311_PFI1_OUT , PFI2 = JY6311Import.JY6311_PFI2_OUT , PXI_Trig0 = JY6311Import.JY6311_PXITrig0_OUT ,
PXI_Trig1 = JY6311Import.JY6311_PXITrig1_OUT , PXI_Trig2 = JY6311Import.JY6311_PXITrig2_OUT , PXI_Trig3 = JY6311Import.JY6311_PXITrig3_OUT , PXI_Trig4 = JY6311Import.JY6311_PXITrig4_OUT ,
PXI_Trig5 = JY6311Import.JY6311_PXITrig5_OUT , PXI_Trig6 = JY6311Import.JY6311_PXITrig6_OUT , PXI_Trig7 = JY6311Import.JY6311_PXITrig7_OUT
}
Output DestinationTerminal. More...
enum | PowerLineFrequency { _50Hz = JY6311Import.JY6311_PowerLineFrequency_50Hz , _60Hz = JY6311Import.JY6311_PowerLineFrequency_60Hz }
AC Power Line Frquency. More...

Enumeration Type Documentation

◆ AIDigitalTriggerEdge

enum JY6311.AIDigitalTriggerEdge

AI Digital Trigger Edge.

Enumerator
Rising | Rising.
Falling | Falling.

◆ AIDigitalTriggerSource

enum JY6311.AIDigitalTriggerSource

AI Digital Trigger Source.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.

◆ AIMode

enum JY6311.AIMode

AI mode enum type.

Enumerator
Single | Single point mode.
Finite | Finite mode.
Continuous | Continuous mode.

◆ AISampleClockSource

enum JY6311.AISampleClockSource

AI SampleClockSource Type.

Enumerator
Internal | Internal.
External | External

◆ AISignalExportSource

enum JY6311.AISignalExportSource

AI Signal Export Source.

Enumerator
StartTrig | AI_StartTrig.
ReferenceTrig | AI_ReferenceTrig.
SampleClock | AI_SampleClock.

◆ AITriggerMode

enum JY6311.AITriggerMode

AI Trigger Mode.

Enumerator
Start | Start Trigger Mode.
Reference | Reference Trigger Mode，Valid when JY6311AITask.Mode is AIMode.Finite

◆ AITriggerType

enum JY6311.AITriggerType

Trigger Type: Digital/Soft/Immediate.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ ClockTerminal

enum JY6311.ClockTerminal

External Sample Clock Terminal.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
AI_SampleClock | AI_SampleClock.

◆ MeasureDataType

enum JY6311.MeasureDataType

MeasureDataType.

Enumerator
Resistance | 电阻值
Temperature | 温度值

◆ PowerLineFrequency

enum JY6311.PowerLineFrequency

AC Power Line Frquency.

Enumerator
_50Hz | 50Hz
_60Hz | 60Hz

◆ RTDTCRType

enum JY6311.RTDTCRType

RTD types supported by 6311, differentiate by TCR(temperature coefficient of resistance)

Enumerator
Pt100_TCR3851 | TCR = 3951, R0 = 100ohm. Most common.
Pt100_TCR3916 | TCR = 3916, R0 = 100ohm.
Pt100_TCR3920 | TCR = 3920, R0 = 100ohm.
Pt100_TCR3911 | TCR = 3911, R0 = 100ohm.
Pt100_TCR3928 | TCR = 3928, R0 = 100ohm.
Pt1000_TCR3851 | Pt1000_TCR3851.
Pt1000_TCR3750 | Pt100_TCR3750.

◆ RTDTerminal

enum JY6311.RTDTerminal

AI RTDTerminal type.

Enumerator
TwoWire | 2-wire terminal
ThreeWire | 3-wire terminal
FourWire | 4-wire terminal

◆ RTDType

enum JY6311.RTDType

RTDType.

Enumerator
PT100 | PT100.
PT1000 | PT1000.

◆ SignalExportDestination

enum JY6311.SignalExportDestination

Output DestinationTerminal.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PFI2 | PFI_2.
PXI_Trig0 | PXI Trig0.
PXI_Trig1 | PXI Trig1.
PXI_Trig2 | PXI Trig2.
PXI_Trig3 | PXI Trig3.
PXI_Trig4 | PXI Trig4.
PXI_Trig5 | PXI Trig5.
PXI_Trig6 | PXI Trig6.
PXI_Trig7 | PXI Trig7.


6311 C# Programming Manual: Package Members

  • Package List
  • Package Members
  • All
  • Enumerations
Here is a list of all namespace members with links to the namespace documentation for each member:
  • AIDigitalTriggerEdge : JY6311
  • AIDigitalTriggerSource : JY6311
  • AIMode : JY6311
  • AISampleClockSource : JY6311
  • AISignalExportSource : JY6311
  • AITriggerMode : JY6311
  • AITriggerType : JY6311
  • ClockTerminal : JY6311
  • MeasureDataType : JY6311
  • PowerLineFrequency : JY6311
  • RTDTCRType : JY6311
  • RTDTerminal : JY6311
  • RTDType : JY6311
  • SignalExportDestination : JY6311


6311 C# Programming Manual: Package Members

  • Package List
  • Package Members
  • All
  • Enumerations
Here is a list of all namespace enums with links to the namespace documentation for each enum:
  • AIDigitalTriggerEdge : JY6311
  • AIDigitalTriggerSource : JY6311
  • AIMode : JY6311
  • AISampleClockSource : JY6311
  • AISignalExportSource : JY6311
  • AITriggerMode : JY6311
  • AITriggerType : JY6311
  • ClockTerminal : JY6311
  • MeasureDataType : JY6311
  • PowerLineFrequency : JY6311
  • RTDTCRType : JY6311
  • RTDTerminal : JY6311
  • RTDType : JY6311
  • SignalExportDestination : JY6311


6311 C# Programming Manual: Package List

  • Package List
  • Package Members
Package List
Here are the packages with brief descriptions (if available):
N JY6311