6312 C++ Programming Manual: D:/6312/C++/JY6312.h File Reference

6312 C++ Programming Manual
  • Main Page
  • Files
  • File List
  • File Members
  • 6312
  • C++
Typedefs | Enumerations | Functions
JY6312.h File Reference

Typedefs

typedef void * JY6312_DeviceHandle
Windows.

Enumerations

enum JY6312_AI_VoltageRange {
JY6312_AI_2p5V = 0 , JY6312_AI_1p25V = 1 , JY6312_AI_625mV = 2 , JY6312_AI_312p5mV = 3 ,
JY6312_AI_156p2mV = 4 , JY6312_AI_78p125mV = 5
}
enum | JY6312_AI_MeasurementType { JY6312_AI_Thermocouple = 0 , JY6312_AI_GeneralVoltage = 1 }
enum | JY6312_AI_SampleMode { JY6312_AI_Finite = 0 , JY6312_AI_Continuous = 1 , JY6312_AI_Single = 2 }
enum | JY6312_AI_TriggerType { JY6312_AI_Immediately = 0 , JY6312_AI_Digital = 1 , JY6312_AI_Software = 2 }
enum | JY6312_AI_TriggerSel { JY6312_AI_Trigger_Start = 0 , JY6312_AI_Trigger_Reference = 1 , JY6312_AI_Trigger_Advance = 2 }
enum | JY6312_DigitalTriggerEdge { JY6312_Rising = 0 , JY6312_Falling = 1 }
enum JY6312_IOTerminal {
JY6312_PFI_0 = 0 , JY6312_PFI_1 = 1 , JY6312_TriggerBus_0 = 4 , JY6312_TriggerBus_1 = 5 ,
JY6312_TriggerBus_2 = 6 , JY6312_TriggerBus_3 = 7 , JY6312_TriggerBus_4 = 8 , JY6312_TriggerBus_5 = 9 ,
JY6312_TriggerBus_6 = 10 , JY6312_TriggerBus_7 = 11 , JY6312_STAR = 12
}
enum | JY6312_SignalSource { JY6312_Export_SampleClock = 0 , JY6312_Export_TriggerOut = 1 , JY6312_Export_IsConverting = 2 }
enum | JY6312_SampleClockSource { JY6312_InternalSampleClock = 0 , JY6312_ExternalSampleClock = 1 }
enum JY6312_ThermocoupleType {
JY6312_TypeR = 0 , JY6312_TypeS = 1 , JY6312_TypeB = 2 , JY6312_TypeJ = 3 ,
JY6312_TypeT = 4 , JY6312_TypeE = 5 , JY6312_TypeK = 6 , JY6312_TypeN = 7 ,
JY6312_TypeC = 8 , JY6312_TypeA = 9 , JY6312_TypeG = 10 , JY6312_TypeD = 11
}
enum | JY6312_TCConnectionStatus { Normal = 0 , OpenCircuit = 1 , ShortCircuit = 2 }
enum | JY6312_PowerLineFreq { _50Hz = 0 , _60Hz = 1 }

Functions

JY6312API int | JY6312_Open (int slotNumber, JY6312_DeviceHandle *hDevice)
Open the 6312 series boards using the slot number or the board serial number.
JY6312API int | JY6312_OpenByName (const char *cardName, JY6312_DeviceHandle *hDevice)
Open this 6312 series boards using the board alias name which is set by JYTEK utility JYDM.
JY6312API int | JY6312_Close (JY6312_DeviceHandle hDevice)
JY6312API int | JY6312_GetDeviceInfo (JY6312_DeviceHandle hDevice, unsigned char *info)
Get device info.
JY6312API int | JY6312_GetDeviceID (JY6312_DeviceHandle hDevice, int *deviceID)
Get device id.
JY6312API int | JY6312_SignalRouting (JY6312_DeviceHandle hDevice, JY6312_IOTerminal destination, JY6312_SignalSource source)
JY6312API int | JY6312_DisconnectSignalRouting (JY6312_DeviceHandle hDevice, JY6312_IOTerminal destination)
JY6312API int | JY6312_AI_SetSampleClockSource (JY6312_DeviceHandle hDevice, JY6312_SampleClockSource sampleClockSource, JY6312_IOTerminal extSampleClockTerminal)
JY6312API int | JY6312_AI_SetSampleMode (JY6312_DeviceHandle hDevice, JY6312_AI_SampleMode mode)
JY6312API int | JY6312_AI_SetSampleRate (JY6312_DeviceHandle hDevice, double sampleRate, double *actualSampleRate)
Set sample rate.
JY6312API int | JY6312_AI_GetActualSampleRate (double sampleRate, JY6312_PowerLineFreq powerLineRejPreference, double *actualSampleRate, double *actualConversionTime, bool *rej50Hz, bool *rej60Hz)
Get acatual sample rate.
JY6312API int | JY6312_AI_SetSamplesToAcquire (JY6312_DeviceHandle hDevice, int samplesToAcquire)
Set samples to acquire.
JY6312API int | JY6312_AI_SetSinglePointModeConvertRateGrade (JY6312_DeviceHandle hDevice, int convertRateGrade)
Set the convert rate in single-point acquisition mode.
JY6312API int | JY6312_AI_SetPowerLineRejectionPreference (JY6312_DeviceHandle hDevice, JY6312_PowerLineFreq powerLineFreq)
Set power line rejection preference.
JY6312API int | JY6312_AI_EnableCalibration (JY6312_DeviceHandle hDevice, bool enabled)
Enable or disable calibration.
JY6312API int | JY6312_AI_EnableChannel (JY6312_DeviceHandle hDevice, unsigned int channelsCount, unsigned int *channelsID, JY6312_AI_MeasurementType *measurementType, JY6312_AI_VoltageRange *inputVoltageRange, JY6312_ThermocoupleType *thermocoupleType)
Enable AI channels.
JY6312API int | JY6312_AI_SetChannelAdvancedConfig (JY6312_DeviceHandle hDevice, int chID, bool vbiasEnabled, bool inputBufferEnabled)
Set advanced configuration on the specified channel.
JY6312API int | JY6312_AI_EnableCJUserData (JY6312_DeviceHandle hDevice, bool enable)
Enable/disable user-defined cold-junction temperature.
JY6312API int | JY6312_AI_SetUserCJTemperature (JY6312_DeviceHandle hDevice, unsigned int channelID, double referenceJunctionTemperature)
Sets user-defined cold-juntion temperature value for the specified channel.
JY6312API int | JY6312_AI_Start (JY6312_DeviceHandle hDevice)
Start AI task.
JY6312API int | JY6312_AI_Stop (JY6312_DeviceHandle hDevice)
Stop AI task.
JY6312API int | JY6312_AI_DetectOpenThermocouple (JY6312_DeviceHandle hDevice, JY6312_TCConnectionStatus *status)
Run open circuit detection.
JY6312API int | JY6312_AI_ReadRawSinglePoint (JY6312_DeviceHandle hDevice, double *hjVoltageData, double *cjTemperatureData)
Single-point reading of the voltage value (V) at the hot-junction and the temperature value (℃) at the cold-junction.
JY6312API int | JY6312_AI_ReadSinglePoint (JY6312_DeviceHandle hDevice, double *data)
Single-point reading of temperature values of all enabled channels that have already been compensated by the cold-junction.
JY6312API int | JY6312_AI_CheckBufferStatus (JY6312_DeviceHandle hDevice, unsigned long long *availableSamples, unsigned long long *transferedSamples, bool *overflow)
Check buffer status.
JY6312API int | JY6312_AI_ReadRawData (JY6312_DeviceHandle hDevice, double *hjVoltageDataBuffer, double *cjTemperatureDataBuffer, unsigned int dataLength, int timeout, unsigned int *actualReadLength)
Reading of the voltage value (V) at the hot-junction and the temperature value (℃) at the cold-junction.
JY6312API int | JY6312_AI_ReadData (JY6312_DeviceHandle hDevice, double *dataBuffer, unsigned int dataLength, int timeout, unsigned int *actualReadLength)
Reading of the compensated temperature value (℃) or voltage value (V).
JY6312API int | JY6312_AI_SetPreTriggerSamples (JY6312_DeviceHandle hDevice, unsigned int preTriggerSamples)
设置预触发点数
JY6312API int | JY6312_AI_SetReTriggerCount (JY6312_DeviceHandle hDevice, int reTriggerCount)
设置重触发次数
JY6312API int | JY6312_AI_SendSoftwareTrigger (JY6312_DeviceHandle hDevice, JY6312_AI_TriggerSel triggerSel)
发送软件触发
JY6312API int | JY6312_AI_SetStartTriggerType (JY6312_DeviceHandle hDevice, JY6312_AI_TriggerType triggerType)
设置StartTigger的触发模式
JY6312API int | JY6312_AI_SetDigitalStartTrigger (JY6312_DeviceHandle hDevice, JY6312_IOTerminal triggerSource, JY6312_DigitalTriggerEdge triggerEdge)
设置StartTrigger的数字触发源
JY6312API int | JY6312_AI_SetReferenceTriggerType (JY6312_DeviceHandle hDevice, JY6312_AI_TriggerType triggerType)
设置StartTigger的触发模式
JY6312API int | JY6312_AI_SetDigitalReferenceTrigger (JY6312_DeviceHandle hDevice, JY6312_IOTerminal triggerSource, JY6312_DigitalTriggerEdge triggerEdge)
设置ReferenceTrigger的数字触发源
JY6312API int | JY6312_AI_SetAdvanceTriggerType (JY6312_DeviceHandle hDevice, JY6312_AI_TriggerType triggerType)
设置AdvanceTrigger的触发模式
JY6312API int | JY6312_AI_SetDigitalAdvanceTrigger (JY6312_DeviceHandle hDevice, JY6312_IOTerminal triggerSource, JY6312_DigitalTriggerEdge triggerEdge)
设置AdvanceTrigger的数字触发源
JY6312API int | JY6312_EnableCJ (JY6312_DeviceHandle hDevice, bool enable)
Enable/disable TB68CJ on the specified Connector.
JY6312API int | JY6312_GetTerminalBlockConnectionStatus (JY6312_DeviceHandle hDevice, bool *terminalBlockConnected)
Gets the external TB68CJ connection status.
JY6312API int | JY6312_SetCJUpdateDataTimeout (JY6312_DeviceHandle hDevice, int timeout)
Sets the timeout for TB68CJ to update data.
JY6312API int | JY6312_SetCJUpdateInterval (JY6312_DeviceHandle hDevice, int interval)
Set the TB68CJ data update interval.
JY6312API int | JY6312_EnableCJDebouncedData (JY6312_DeviceHandle hDevice, bool enable)
Enables the cold junction temperature sensor data to de-jitter the data.
JY6312API int | JY6312_SetCJMaxBounce (JY6312_DeviceHandle hDevice, double bounceMax)
Set the maximum jitter value allowed when the TB68CJ output data is debounceed, and the amount of change beyond this limit will be forcibly compressed to the maximum jitter value.
JY6312API int | JY6312_GetCJMaxBounce (JY6312_DeviceHandle hDevice, double *bounceMax)
Gets the maximum jitter value allowed when the TB68CJ current output data is debounceed.
JY6312API int | JY6312_SetCJInvalidBounce (JY6312_DeviceHandle hDevice, double bounceInvalid)
Set the jitter value(TB68CJ remove jitter is judged to be invalid)
JY6312API int | JY6312_GetCJInvalidBounce (JY6312_DeviceHandle hDevice, double *bounceInvalid)
Set the jitter value(TB68CJ remove jitter is judged to be invalid)
JY6312API int | JY6312_GetCJDebouncingStatus (JY6312_DeviceHandle hDevice, bool *isNormal)
Gets the cold-junction data remove jitter state.
JY6312API int | JY6312_ResetDebouncer (JY6312_DeviceHandle hDevice)
Resets TB68CJ to remove jitter.
JY6312API double | JY6312_AI_ConvertEMFToTemperature (JY6312_ThermocoupleType type, double E, double referenceTemperture=25.0)
Convert Electromotive force to temperature.
JY6312API double | JY6312_AI_ConvertTemperatureToEMF (JY6312_ThermocoupleType type, double temperature)
Convert temperature to voltage.

Typedef Documentation

◆ JY6312_DeviceHandle

typedef void* JY6312_DeviceHandle

Windows.

Linux

Enumeration Type Documentation

◆ JY6312_AI_MeasurementType

enum JY6312_AI_MeasurementType
Enumerator
JY6312_AI_Thermocouple
JY6312_AI_GeneralVoltage

◆ JY6312_AI_SampleMode

enum JY6312_AI_SampleMode
Enumerator
JY6312_AI_Finite | AI Finite Mode.
JY6312_AI_Continuous | AI Continuous Mode.
JY6312_AI_Single | AI Single Mode.

◆ JY6312_AI_TriggerSel

enum JY6312_AI_TriggerSel
Enumerator
JY6312_AI_Trigger_Start | AI Start Trigger Mode.
JY6312_AI_Trigger_Reference | AI Reference Trigger Mode.
JY6312_AI_Trigger_Advance | AI Advance Trigger Mode.

◆ JY6312_AI_TriggerType

enum JY6312_AI_TriggerType
Enumerator
JY6312_AI_Immediately | AI Immediately Type.
JY6312_AI_Digital | AI Digital Type.
JY6312_AI_Software | AI Soft Type.

◆ JY6312_AI_VoltageRange

enum JY6312_AI_VoltageRange
Enumerator
JY6312_AI_2p5V
JY6312_AI_1p25V
JY6312_AI_625mV
JY6312_AI_312p5mV
JY6312_AI_156p2mV
JY6312_AI_78p125mV

◆ JY6312_DigitalTriggerEdge

enum JY6312_DigitalTriggerEdge
Enumerator
JY6312_Rising | AI Rising edge for digital trigger.
JY6312_Falling | AI Falling edge for digital trigger.

◆ JY6312_IOTerminal

enum JY6312_IOTerminal
Enumerator
JY6312_PFI_0 | PFI0 as the terminal.
JY6312_PFI_1 | PFI1 as the terminal.
JY6312_TriggerBus_0 | PXITrigger0 as the terminal.
JY6312_TriggerBus_1 | PXITrigger1 as the terminal.
JY6312_TriggerBus_2 | PXITrigger2 as the terminal.
JY6312_TriggerBus_3 | PXITrigger3 as the terminal.
JY6312_TriggerBus_4 | PXITrigger4 as the terminal.
JY6312_TriggerBus_5 | PXITrigger5 as the terminal.
JY6312_TriggerBus_6 | PXITrigger6 as the terminal.
JY6312_TriggerBus_7 | PXITrigger7 as the terminal.
JY6312_STAR | STAR as the terminal.

◆ JY6312_PowerLineFreq

enum JY6312_PowerLineFreq
Enumerator
_50Hz
_60Hz

◆ JY6312_SampleClockSource

enum JY6312_SampleClockSource
Enumerator
JY6312_InternalSampleClock | AI Internal SampleClock.
JY6312_ExternalSampleClock | AI External SampleClock.

◆ JY6312_SignalSource

enum JY6312_SignalSource
Enumerator
JY6312_Export_SampleClock | SampleClock as the source signal to rout.
JY6312_Export_TriggerOut | Trigger as the source signal to rout.
JY6312_Export_IsConverting |

◆ JY6312_TCConnectionStatus

enum JY6312_TCConnectionStatus
Enumerator
Normal
OpenCircuit
ShortCircuit

◆ JY6312_ThermocoupleType

enum JY6312_ThermocoupleType
Enumerator
JY6312_TypeR
JY6312_TypeS
JY6312_TypeB
JY6312_TypeJ
JY6312_TypeT
JY6312_TypeE
JY6312_TypeK
JY6312_TypeN
JY6312_TypeC
JY6312_TypeA
JY6312_TypeG
JY6312_TypeD

Function Documentation

◆ JY6312_AI_CheckBufferStatus()

JY6312API int JY6312_AI_CheckBufferStatus | ( | JY6312_DeviceHandle | hDevice,
 |  | unsigned long long * | availableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overflow )

Check buffer status.

Parameters
hDevice | Device handle
availableSamples | The amount of available data in samples.
transferedSamples | The amount of transfered data in samples.
overflow | Whether a data buffer overflow occurred.
Returns
0:succeed. other:error code.

◆ JY6312_AI_ConvertEMFToTemperature()

JY6312API double JY6312_AI_ConvertEMFToTemperature | ( | JY6312_ThermocoupleType | type,
 |  | double | E,
 |  | double | referenceTemperture = 25.0 )

Convert Electromotive force to temperature.

Parameters
type | Thermocouple type.
E | Electromotive force, expressed in microvolts(uV).
referenceTemperture | ITS-90 temperature at reference junction, expressed in degrees Celsius.
Returns
ITS-90 temperature, expressed in degrees Celsius.

◆ JY6312_AI_ConvertTemperatureToEMF()

JY6312API double JY6312_AI_ConvertTemperatureToEMF | ( | JY6312_ThermocoupleType | type,
 |  | double | temperature )

Convert temperature to voltage.

Parameters
type | Thermocouple type.
temperature | ITS-90 temperature, expressed in degrees Celsius.
Returns
Electromotive force, expressed in microvolts(uV).

◆ JY6312_AI_DetectOpenThermocouple()

JY6312API int JY6312_AI_DetectOpenThermocouple | ( | JY6312_DeviceHandle | hDevice,
 |  | JY6312_TCConnectionStatus * | status )

Run open circuit detection.

Parameters
hDevice | Device handle.
status | Thermocouple connection status.
Returns
0:succeed. other:error code.

◆ JY6312_AI_EnableCalibration()

JY6312API int JY6312_AI_EnableCalibration | ( | JY6312_DeviceHandle | hDevice,
 |  | bool | enabled )

Enable or disable calibration.

Parameters
hDevice | Device handle
enabled | Calibration enabled. When enabled, factory calibration coefficients are obtained from EEPROM and used in the task when starting the task.
Returns
0:succeed. other:error code.

◆ JY6312_AI_EnableChannel()

JY6312API int JY6312_AI_EnableChannel | ( | JY6312_DeviceHandle | hDevice,
 |  | unsigned int | channelsCount,
 |  | unsigned int * | channelsID,
 |  | JY6312_AI_MeasurementType * | measurementType,
 |  | JY6312_AI_VoltageRange * | inputVoltageRange,
 |  | JY6312_ThermocoupleType * | thermocoupleType )

Enable AI channels.

Each channel can be independently configured

Parameters
hDevice | Device Handle
channelCount | The Number of Channels to enable.
channelsID | The array of channles' ID.
measurementType | The array of channles' measurement type.
inputVoltageRange | The array of channles' input voltage range.
thermocoupleType | The array of channles' connected thermocouple type.
Returns
0:succeed. other:error code.

◆ JY6312_AI_EnableCJUserData()

JY6312API int JY6312_AI_EnableCJUserData | ( | JY6312_DeviceHandle | hDevice,
 |  | bool | enable )

Enable/disable user-defined cold-junction temperature.

Parameters
hDevice | Device handle
enable | Enable
Returns
0:succeed. other:error code.

◆ JY6312_AI_GetActualSampleRate()

JY6312API int JY6312_AI_GetActualSampleRate | ( | double | sampleRate,
 |  | JY6312_PowerLineFreq | powerLineRejPreference,
 |  | double * | actualSampleRate,
 |  | double * | actualConversionTime,
 |  | bool * | rej50Hz,
 |  | bool * | rej60Hz )

Get acatual sample rate.

Parameters
sampleRate | Required Sample Rate
powerLineRejPreference | Power Line Rejection Preference
actualSampleRate | Actual Sample Rate
actualConversionTime | Actual Conversion Time
rej50Hz | Whether additional rejection is currently provided at 50Hz.
rej60Hz | Whether additional rejection is currently provided at 60Hz.
Returns
0:succeed. other:error code.

◆ JY6312_AI_ReadData()

JY6312API int JY6312_AI_ReadData | ( | JY6312_DeviceHandle | hDevice,
 |  | double * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeout,
 |  | unsigned int * | actualReadLength )

Reading of the compensated temperature value (℃) or voltage value (V).

Parameters
hDevice | Device handle
dataBuffer | Buffer for reading the compensated temperature value (℃) or voltage value (V). The actual data unit is determined by the MeasurementType of channel.
dataLength | The length of the data to read in samples.
timeout | Timeout in ms. When equal to -1, it means never timeout.
actualReadLength | The length of the data actually read in samples.
Returns
0:succeed. other:error code.

◆ JY6312_AI_ReadRawData()

JY6312API int JY6312_AI_ReadRawData | ( | JY6312_DeviceHandle | hDevice,
 |  | double * | hjVoltageDataBuffer,
 |  | double * | cjTemperatureDataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeout,
 |  | unsigned int * | actualReadLength )

Reading of the voltage value (V) at the hot-junction and the temperature value (℃) at the cold-junction.

Parameters
hDevice | Device handle
hjVoltageData | Buffer for reading voltage value (V) at the hot-junction.
cjTemperatureData | Buffer for reading temperature value (℃) at the cold-junction.
dataLength | The length of the data to read in samples.
timeout | Timeout in ms. When equal to -1, it means never timeout.
actualReadLength | The length of the data actually read in samples.
Returns
0:succeed. other:error code.

◆ JY6312_AI_ReadRawSinglePoint()

JY6312API int JY6312_AI_ReadRawSinglePoint | ( | JY6312_DeviceHandle | hDevice,
 |  | double * | hjVoltageData,
 |  | double * | cjTemperatureData )

Single-point reading of the voltage value (V) at the hot-junction and the temperature value (℃) at the cold-junction.

Parameters
hDevice | Device handle
hjVoltageData | Buffer for reading voltage value (V) at the hot-junction.
cjTemperatureData | Buffer for reading temperature value (℃) at the cold-junction.
Returns
0:succeed. other:error code.

◆ JY6312_AI_ReadSinglePoint()

JY6312API int JY6312_AI_ReadSinglePoint | ( | JY6312_DeviceHandle | hDevice,
 |  | double * | data )

Single-point reading of temperature values of all enabled channels that have already been compensated by the cold-junction.

Parameters
hDevice | Device handle
dataBuffer | Buffer for reading compensated temperature value (℃) or voltage (V).
Returns
0:succeed. other:error code.

◆ JY6312_AI_SendSoftwareTrigger()

JY6312API int JY6312_AI_SendSoftwareTrigger | ( | JY6312_DeviceHandle | hDevice,
 |  | JY6312_AI_TriggerSel | triggerSel )

发送软件触发

Parameters
hDevice | 板卡句柄
triggerSel | 选择要作用的触发
Returns
0：无错误；其它：发生错误

◆ JY6312_AI_SetAdvanceTriggerType()

JY6312API int JY6312_AI_SetAdvanceTriggerType | ( | JY6312_DeviceHandle | hDevice,
 |  | JY6312_AI_TriggerType | triggerType )

设置AdvanceTrigger的触发模式

Parameters
hDevice 板卡句柄
availableSamplsCount 开始触发的工作模式(Immediate/Digital/Analog/Software)/param>
Returns
0：无错误；其它：发生错误

◆ JY6312_AI_SetChannelAdvancedConfig()

JY6312API int JY6312_AI_SetChannelAdvancedConfig | ( | JY6312_DeviceHandle | hDevice,
 |  | int | chID,
 |  | bool | vbiasEnabled,
 |  | bool | inputBufferEnabled )

Set advanced configuration on the specified channel.

If you are not sure what the bias voltage generator does, do not call this API.

Parameters
hDevice | Device Handle
chID | Channel ID. This channel must already enabled. Passing in -1 means setting on all enabled channels.
vbiasEnabled | Enables or disables bias voltage generators on the specified channel, default value is true.
vbiasEnabled | Enables or disables input buffer on the specified channel, default value is true. Buffer can only be disabled when the range is ±2.5V or ±1.25V, and is always enabled on other ranges.
Returns
0:succeed. other:error code.

◆ JY6312_AI_SetDigitalAdvanceTrigger()

JY6312API int JY6312_AI_SetDigitalAdvanceTrigger | ( | JY6312_DeviceHandle | hDevice,
 |  | JY6312_IOTerminal | triggerSource,
 |  | JY6312_DigitalTriggerEdge | triggerEdge )

设置AdvanceTrigger的数字触发源

Parameters
hDevice | 板卡句柄
triggerSource | 数字触发源通道选择
triggerEdge | 数字触发源触发条件选择
Returns
0：无错误；其它：发生错误

◆ JY6312_AI_SetDigitalReferenceTrigger()

JY6312API int JY6312_AI_SetDigitalReferenceTrigger | ( | JY6312_DeviceHandle | hDevice,
 |  | JY6312_IOTerminal | triggerSource,
 |  | JY6312_DigitalTriggerEdge | triggerEdge )

设置ReferenceTrigger的数字触发源

Parameters
hDevice | 板卡句柄
triggerSource | 数字触发源通道选择
triggerEdge | 数字触发源触发条件选择
Returns
0：无错误；其它：发生错误

◆ JY6312_AI_SetDigitalStartTrigger()

JY6312API int JY6312_AI_SetDigitalStartTrigger | ( | JY6312_DeviceHandle | hDevice,
 |  | JY6312_IOTerminal | triggerSource,
 |  | JY6312_DigitalTriggerEdge | triggerEdge )

设置StartTrigger的数字触发源

Parameters
hDevice | 板卡句柄
triggerSource | 数字触发源通道选择
triggerEdge | 数字触发源触发条件选择
Returns
0：无错误；其它：发生错误

◆ JY6312_AI_SetPowerLineRejectionPreference()

JY6312API int JY6312_AI_SetPowerLineRejectionPreference | ( | JY6312_DeviceHandle | hDevice,
 |  | JY6312_PowerLineFreq | powerLineFreq )

Set power line rejection preference.

Parameters
hDevice | Device handle
powerLineFreq | Reject at 50Hz or 60Hz
Returns
0:succeed. other:error code.

◆ JY6312_AI_SetPreTriggerSamples()

JY6312API int JY6312_AI_SetPreTriggerSamples | ( | JY6312_DeviceHandle | hDevice,
 |  | unsigned int | preTriggerSamples )

设置预触发点数

Parameters
hDevice | 板卡句柄
preTriggerSamples | 预触发点数
Returns
0：无错误；其它：发生错误

◆ JY6312_AI_SetReferenceTriggerType()

JY6312API int JY6312_AI_SetReferenceTriggerType | ( | JY6312_DeviceHandle | hDevice,
 |  | JY6312_AI_TriggerType | triggerType )

设置StartTigger的触发模式

Parameters
hDevice | 板卡句柄
triggerType | 参考触发的工作模式(Immediate/Digital/Analog/Software)
Returns
0：无错误；其它：发生错误

◆ JY6312_AI_SetReTriggerCount()

JY6312API int JY6312_AI_SetReTriggerCount | ( | JY6312_DeviceHandle | hDevice,
 |  | int | reTriggerCount )

设置重触发次数

Parameters
hDevice | 板卡句柄
reTriggerCount | 重触发次数
Returns
0：无错误；其它：发生错误

◆ JY6312_AI_SetSampleClockSource()

JY6312API int JY6312_AI_SetSampleClockSource | ( | JY6312_DeviceHandle | hDevice,
 |  | JY6312_SampleClockSource | sampleClockSource,
 |  | JY6312_IOTerminal | extSampleClockTerminal )

summary> Set sample clock source. When using an external clock, ensure that the frequency of the external sample clock is not greater than the set sample rate. /summary> param name="hDevice">Device handle

param name="sampleClockSource">Sample clock source

param name="extSampleClockTerminal">External sample clock input terminal

Returns
0:succeed. other:error code.

◆ JY6312_AI_SetSampleMode()

JY6312API int JY6312_AI_SetSampleMode | ( | JY6312_DeviceHandle | hDevice,
 |  | JY6312_AI_SampleMode | mode )

summary> Set sample mode. /summary> param name="hDevice">Device handle

param name="mode">Sample Mode

Returns
0:succeed. other:error code.

◆ JY6312_AI_SetSampleRate()

JY6312API int JY6312_AI_SetSampleRate | ( | JY6312_DeviceHandle | hDevice,
 |  | double | sampleRate,
 |  | double * | actualSampleRate )

Set sample rate.

Parameters
hDevice | Device handle
sampleRate | Required Sample Rate
actualSampleRate | Actual Sample Rate
Returns
0:succeed. other:error code.

◆ JY6312_AI_SetSamplesToAcquire()

JY6312API int JY6312_AI_SetSamplesToAcquire | ( | JY6312_DeviceHandle | hDevice,
 |  | int | samplesToAcquire )

Set samples to acquire.

Parameters
hDevice | Device handle
samplesToAcquire | Samples to Acquire
Returns
0:succeed. other:error code.

◆ JY6312_AI_SetSinglePointModeConvertRateGrade()

JY6312API int JY6312_AI_SetSinglePointModeConvertRateGrade | ( | JY6312_DeviceHandle | hDevice,
 |  | int | convertRateGrade )

Set the convert rate in single-point acquisition mode.

Parameters
hDevice | Device handle
convertRateGrade | Convert Rate Grade. 1-470Hz; 2-242Hz; 3-123Hz; 4-62Hz; 5-50Hz; 6-39Hz; 7-33.2Hz; 8-19.6Hz; 9-16.7Hz, reject at 50Hz; 10-16.7Hz, reject at 50Hz and 60Hz; 11-12.5Hz; 12-10Hz; 13-8.33Hz; 14-6.25Hz; 15-4.17Hz
Returns
0:succeed. other:error code.

◆ JY6312_AI_SetStartTriggerType()

JY6312API int JY6312_AI_SetStartTriggerType | ( | JY6312_DeviceHandle | hDevice,
 |  | JY6312_AI_TriggerType | triggerType )

设置StartTigger的触发模式

Parameters
hDevice | 板卡句柄
triggerType | 开始触发的工作模式(Immediate/Digital/Analog/Software)
Returns
0：无错误；其它：发生错误

◆ JY6312_AI_SetUserCJTemperature()

JY6312API int JY6312_AI_SetUserCJTemperature | ( | JY6312_DeviceHandle | hDevice,
 |  | unsigned int | channelID,
 |  | double | referenceJunctionTemperature )

Sets user-defined cold-juntion temperature value for the specified channel.

Valid only if CJ user data is enabled.

Parameters
hDevice | Device handle
channelIndex | The ID of the channel to set
referenceJunctionTemperature | The reference Terminals temperature value of the channel(℃)
Returns
0:succeed. other:error code.

◆ JY6312_AI_Start()

JY6312API int JY6312_AI_Start ( JY6312_DeviceHandle hDevice )

Start AI task.

Parameters
hDevice Device Handle
Returns
0:succeed. other:error code.

◆ JY6312_AI_Stop()

JY6312API int JY6312_AI_Stop ( JY6312_DeviceHandle hDevice )

Stop AI task.

Parameters
hDevice Device handle
Returns
0:succeed. other:error code.

◆ JY6312_Close()

JY6312API int JY6312_Close ( JY6312_DeviceHandle hDevice )

Close this 6312 board.

Parameters
hDevice Device handle
Returns
0:succeed. other:error code.

◆ JY6312_DisconnectSignalRouting()

JY6312API int JY6312_DisconnectSignalRouting | ( | JY6312_DeviceHandle | hDevice,
 |  | JY6312_IOTerminal | destination )

summary> Disconnects the specified port and the internal signal,resets to a low level /summary> param name="hDevice">Device handle

param name="destination">destination terminal

Returns
0:succeed. other:error code.

◆ JY6312_EnableCJ()

JY6312API int JY6312_EnableCJ | ( | JY6312_DeviceHandle | hDevice,
 |  | bool | enable )

Enable/disable TB68CJ on the specified Connector.

When disabled, the 6312 does not initiate I2C traffic

Parameters
hDevice | Device handle
enable | Enable/Disable flag
Returns
0:succeed. other:error code.

◆ JY6312_EnableCJDebouncedData()

JY6312API int JY6312_EnableCJDebouncedData | ( | JY6312_DeviceHandle | hDevice,
 |  | bool | enable )

Enables the cold junction temperature sensor data to de-jitter the data.

Parameters
hDevice | Device handle
enable | Enable/disable flag
Returns
0:succeed. other:error code.

◆ JY6312_GetCJDebouncingStatus()

JY6312API int JY6312_GetCJDebouncingStatus | ( | JY6312_DeviceHandle | hDevice,
 |  | bool * | isNormal )

Gets the cold-junction data remove jitter state.

Parameters
hDevice | Device handle
isNormal | normal/abnormal flag
Returns
0:succeed. other:error code.

◆ JY6312_GetCJInvalidBounce()

JY6312API int JY6312_GetCJInvalidBounce | ( | JY6312_DeviceHandle | hDevice,
 |  | double * | bounceInvalid )

Set the jitter value(TB68CJ remove jitter is judged to be invalid)

Parameters
hDevice | Device handle
bounceInvalid | Invalid jitter value(℃)
Returns
0:succeed. other:error code.

◆ JY6312_GetCJMaxBounce()

JY6312API int JY6312_GetCJMaxBounce | ( | JY6312_DeviceHandle | hDevice,
 |  | double * | bounceMax )

Gets the maximum jitter value allowed when the TB68CJ current output data is debounceed.

Parameters
hDevice | Device handle
bounceMax | Maximum jitter value,unit:℃
Returns
0:succeed. other:error code.

◆ JY6312_GetDeviceID()

JY6312API int JY6312_GetDeviceID | ( | JY6312_DeviceHandle | hDevice,
 |  | int * | deviceID )

Get device id.

Parameters
hDevice | Device handle
info | Device ID
Returns
0:succeed. other:error code.

◆ JY6312_GetDeviceInfo()

JY6312API int JY6312_GetDeviceInfo | ( | JY6312_DeviceHandle | hDevice,
 |  | unsigned char * | info )

Get device info.

Parameters
hDevice | Device handle
info | Device info
Returns
0:succeed. other:error code.

◆ JY6312_GetTerminalBlockConnectionStatus()

JY6312API int JY6312_GetTerminalBlockConnectionStatus | ( | JY6312_DeviceHandle | hDevice,
 |  | bool * | terminalBlockConnected )

Gets the external TB68CJ connection status.

Parameters
hDevice | Device handle
terminalBlockConnected | Whether the Connector is connected to TB68CJ
Returns
0:succeed. other:error code.

◆ JY6312_Open()

JY6312API int JY6312_Open | ( | int | slotNumber,
 |  | JY6312_DeviceHandle * | hDevice )

Open the 6312 series boards using the slot number or the board serial number.

PXIe slot number is predefined by the PXIe chassis. PCIe slot number is defined by the DIP switch. The board serial number is defined by the system starting from 0. It's your responsibility to know the number. For a single board, the serial number is 0.

Parameters
slotNumber | slot number or board serial number
hDevice | Device handle. All other functions uses hDevice to represent this device.
Returns
0:succeed. other:error code.

◆ JY6312_OpenByName()

JY6312API int JY6312_OpenByName | ( | const char * | cardName,
 |  | JY6312_DeviceHandle * | hDevice )

Open this 6312 series boards using the board alias name which is set by JYTEK utility JYDM.

You can change the name using JYDM.

Parameters
cardName | board alias name
hDevice | Device handle
Returns
0:succeed. other:error code.

◆ JY6312_ResetDebouncer()

JY6312API int JY6312_ResetDebouncer ( JY6312_DeviceHandle hDevice )

Resets TB68CJ to remove jitter.

After the reset, you need to wait at least 1 second to generate valid data

Parameters
hDevice Device handle
Returns
0:succeed. other:error code.

◆ JY6312_SetCJInvalidBounce()

JY6312API int JY6312_SetCJInvalidBounce | ( | JY6312_DeviceHandle | hDevice,
 |  | double | bounceInvalid )

Set the jitter value(TB68CJ remove jitter is judged to be invalid)

Parameters
hDevice | Device handle
bounceInvalid | Invalid jitter value (°C), must be greater than 0 and less than or equal to 100. Integer division error occurs when not an integer multiple of 0.0078125
Returns
0:succeed. other:error code.

◆ JY6312_SetCJMaxBounce()

JY6312API int JY6312_SetCJMaxBounce | ( | JY6312_DeviceHandle | hDevice,
 |  | double | bounceMax )

Set the maximum jitter value allowed when the TB68CJ output data is debounceed, and the amount of change beyond this limit will be forcibly compressed to the maximum jitter value.

Parameters
hDevice | Device handle
bounceMax | The maximum jitter value，unit:℃。Integer division error occurs when not an integer multiple of 0.0078125
Returns
0:succeed. other:error code.

◆ JY6312_SetCJUpdateDataTimeout()

JY6312API int JY6312_SetCJUpdateDataTimeout | ( | JY6312_DeviceHandle | hDevice,
 |  | int | timeout )

Sets the timeout for TB68CJ to update data.

When the data is not updated beyond this time, the corresponding error flag register will be set.

Parameters
hDevice | Device handle
timeout | Timeout unit:ms. Since the I2C communication itself takes less than 1ms, there is a certain error in the timeout.
Returns
0:succeed. other:error code.

◆ JY6312_SetCJUpdateInterval()

JY6312API int JY6312_SetCJUpdateInterval | ( | JY6312_DeviceHandle | hDevice,
 |  | int | interval )

Set the TB68CJ data update interval.

Parameters
hDevice | Device handle
timeout | Update interval unit:ms.
Returns
0:succeed. other:error code.

◆ JY6312_SignalRouting()

JY6312API int JY6312_SignalRouting | ( | JY6312_DeviceHandle | hDevice,
 |  | JY6312_IOTerminal | destination,
 |  | JY6312_SignalSource | source )

summary> Exports the internal signal to the specified port /summary> param name="hDevice">Device handle

param name="destination">destination terminal

param name="source">source terminal

Returns
0:succeed. other:error code.
Generated by doxygen 1.12.0


6312 C++ Programming Manual: D:/6312 Directory Reference

  • 6312
6312 Directory Reference

Directories

C++


6312 C++ Programming Manual: D:/6312/C++ Directory Reference

  • 6312
  • C++
C++ Directory Reference

Files

JY6312.h


6312 C++ Programming Manual: File List

File List
Here is a list of all files with brief descriptions:
[detail level 123]
▼ 6312
▼ C++
JY6312.h


6312 C++ Programming Manual: File Members

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • j
  • n
  • o
  • s
Here is a list of all file members with links to the files they belong to:

- _ -

  • _50Hz : JY6312.h
  • _60Hz : JY6312.h

- j -

  • JY6312_AI_156p2mV : JY6312.h
  • JY6312_AI_1p25V : JY6312.h
  • JY6312_AI_2p5V : JY6312.h
  • JY6312_AI_312p5mV : JY6312.h
  • JY6312_AI_625mV : JY6312.h
  • JY6312_AI_78p125mV : JY6312.h
  • JY6312_AI_CheckBufferStatus() : JY6312.h
  • JY6312_AI_Continuous : JY6312.h
  • JY6312_AI_ConvertEMFToTemperature() : JY6312.h
  • JY6312_AI_ConvertTemperatureToEMF() : JY6312.h
  • JY6312_AI_DetectOpenThermocouple() : JY6312.h
  • JY6312_AI_Digital : JY6312.h
  • JY6312_AI_EnableCalibration() : JY6312.h
  • JY6312_AI_EnableChannel() : JY6312.h
  • JY6312_AI_EnableCJUserData() : JY6312.h
  • JY6312_AI_Finite : JY6312.h
  • JY6312_AI_GeneralVoltage : JY6312.h
  • JY6312_AI_GetActualSampleRate() : JY6312.h
  • JY6312_AI_Immediately : JY6312.h
  • JY6312_AI_MeasurementType : JY6312.h
  • JY6312_AI_ReadData() : JY6312.h
  • JY6312_AI_ReadRawData() : JY6312.h
  • JY6312_AI_ReadRawSinglePoint() : JY6312.h
  • JY6312_AI_ReadSinglePoint() : JY6312.h
  • JY6312_AI_SampleMode : JY6312.h
  • JY6312_AI_SendSoftwareTrigger() : JY6312.h
  • JY6312_AI_SetAdvanceTriggerType() : JY6312.h
  • JY6312_AI_SetChannelAdvancedConfig() : JY6312.h
  • JY6312_AI_SetDigitalAdvanceTrigger() : JY6312.h
  • JY6312_AI_SetDigitalReferenceTrigger() : JY6312.h
  • JY6312_AI_SetDigitalStartTrigger() : JY6312.h
  • JY6312_AI_SetPowerLineRejectionPreference() : JY6312.h
  • JY6312_AI_SetPreTriggerSamples() : JY6312.h
  • JY6312_AI_SetReferenceTriggerType() : JY6312.h
  • JY6312_AI_SetReTriggerCount() : JY6312.h
  • JY6312_AI_SetSampleClockSource() : JY6312.h
  • JY6312_AI_SetSampleMode() : JY6312.h
  • JY6312_AI_SetSampleRate() : JY6312.h
  • JY6312_AI_SetSamplesToAcquire() : JY6312.h
  • JY6312_AI_SetSinglePointModeConvertRateGrade() : JY6312.h
  • JY6312_AI_SetStartTriggerType() : JY6312.h
  • JY6312_AI_SetUserCJTemperature() : JY6312.h
  • JY6312_AI_Single : JY6312.h
  • JY6312_AI_Software : JY6312.h
  • JY6312_AI_Start() : JY6312.h
  • JY6312_AI_Stop() : JY6312.h
  • JY6312_AI_Thermocouple : JY6312.h
  • JY6312_AI_Trigger_Advance : JY6312.h
  • JY6312_AI_Trigger_Reference : JY6312.h
  • JY6312_AI_Trigger_Start : JY6312.h
  • JY6312_AI_TriggerSel : JY6312.h
  • JY6312_AI_TriggerType : JY6312.h
  • JY6312_AI_VoltageRange : JY6312.h
  • JY6312_Close() : JY6312.h
  • JY6312_DeviceHandle : JY6312.h
  • JY6312_DigitalTriggerEdge : JY6312.h
  • JY6312_DisconnectSignalRouting() : JY6312.h
  • JY6312_EnableCJ() : JY6312.h
  • JY6312_EnableCJDebouncedData() : JY6312.h
  • JY6312_Export_IsConverting : JY6312.h
  • JY6312_Export_SampleClock : JY6312.h
  • JY6312_Export_TriggerOut : JY6312.h
  • JY6312_ExternalSampleClock : JY6312.h
  • JY6312_Falling : JY6312.h
  • JY6312_GetCJDebouncingStatus() : JY6312.h
  • JY6312_GetCJInvalidBounce() : JY6312.h
  • JY6312_GetCJMaxBounce() : JY6312.h
  • JY6312_GetDeviceID() : JY6312.h
  • JY6312_GetDeviceInfo() : JY6312.h
  • JY6312_GetTerminalBlockConnectionStatus() : JY6312.h
  • JY6312_InternalSampleClock : JY6312.h
  • JY6312_IOTerminal : JY6312.h
  • JY6312_Open() : JY6312.h
  • JY6312_OpenByName() : JY6312.h
  • JY6312_PFI_0 : JY6312.h
  • JY6312_PFI_1 : JY6312.h
  • JY6312_PowerLineFreq : JY6312.h
  • JY6312_ResetDebouncer() : JY6312.h
  • JY6312_Rising : JY6312.h
  • JY6312_SampleClockSource : JY6312.h
  • JY6312_SetCJInvalidBounce() : JY6312.h
  • JY6312_SetCJMaxBounce() : JY6312.h
  • JY6312_SetCJUpdateDataTimeout() : JY6312.h
  • JY6312_SetCJUpdateInterval() : JY6312.h
  • JY6312_SignalRouting() : JY6312.h
  • JY6312_SignalSource : JY6312.h
  • JY6312_STAR : JY6312.h
  • JY6312_TCConnectionStatus : JY6312.h
  • JY6312_ThermocoupleType : JY6312.h
  • JY6312_TriggerBus_0 : JY6312.h
  • JY6312_TriggerBus_1 : JY6312.h
  • JY6312_TriggerBus_2 : JY6312.h
  • JY6312_TriggerBus_3 : JY6312.h
  • JY6312_TriggerBus_4 : JY6312.h
  • JY6312_TriggerBus_5 : JY6312.h
  • JY6312_TriggerBus_6 : JY6312.h
  • JY6312_TriggerBus_7 : JY6312.h
  • JY6312_TypeA : JY6312.h
  • JY6312_TypeB : JY6312.h
  • JY6312_TypeC : JY6312.h
  • JY6312_TypeD : JY6312.h
  • JY6312_TypeE : JY6312.h
  • JY6312_TypeG : JY6312.h
  • JY6312_TypeJ : JY6312.h
  • JY6312_TypeK : JY6312.h
  • JY6312_TypeN : JY6312.h
  • JY6312_TypeR : JY6312.h
  • JY6312_TypeS : JY6312.h
  • JY6312_TypeT : JY6312.h

- n -

  • Normal : JY6312.h

- o -

  • OpenCircuit : JY6312.h

- s -

  • ShortCircuit : JY6312.h


  • Enumerations
  • Enumerator
Here is a list of all enums with links to the files they belong to:
  • JY6312_AI_MeasurementType : JY6312.h
  • JY6312_AI_SampleMode : JY6312.h
  • JY6312_AI_TriggerSel : JY6312.h
  • JY6312_AI_TriggerType : JY6312.h
  • JY6312_AI_VoltageRange : JY6312.h
  • JY6312_DigitalTriggerEdge : JY6312.h
  • JY6312_IOTerminal : JY6312.h
  • JY6312_PowerLineFreq : JY6312.h
  • JY6312_SampleClockSource : JY6312.h
  • JY6312_SignalSource : JY6312.h
  • JY6312_TCConnectionStatus : JY6312.h
  • JY6312_ThermocoupleType : JY6312.h


  • Enumerations
  • Enumerator
  • _
  • j
  • n
  • o
  • s
Here is a list of all enum values with links to the files they belong to:

- _ -

  • _50Hz : JY6312.h
  • _60Hz : JY6312.h

- j -

  • JY6312_AI_156p2mV : JY6312.h
  • JY6312_AI_1p25V : JY6312.h
  • JY6312_AI_2p5V : JY6312.h
  • JY6312_AI_312p5mV : JY6312.h
  • JY6312_AI_625mV : JY6312.h
  • JY6312_AI_78p125mV : JY6312.h
  • JY6312_AI_Continuous : JY6312.h
  • JY6312_AI_Digital : JY6312.h
  • JY6312_AI_Finite : JY6312.h
  • JY6312_AI_GeneralVoltage : JY6312.h
  • JY6312_AI_Immediately : JY6312.h
  • JY6312_AI_Single : JY6312.h
  • JY6312_AI_Software : JY6312.h
  • JY6312_AI_Thermocouple : JY6312.h
  • JY6312_AI_Trigger_Advance : JY6312.h
  • JY6312_AI_Trigger_Reference : JY6312.h
  • JY6312_AI_Trigger_Start : JY6312.h
  • JY6312_Export_IsConverting : JY6312.h
  • JY6312_Export_SampleClock : JY6312.h
  • JY6312_Export_TriggerOut : JY6312.h
  • JY6312_ExternalSampleClock : JY6312.h
  • JY6312_Falling : JY6312.h
  • JY6312_InternalSampleClock : JY6312.h
  • JY6312_PFI_0 : JY6312.h
  • JY6312_PFI_1 : JY6312.h
  • JY6312_Rising : JY6312.h
  • JY6312_STAR : JY6312.h
  • JY6312_TriggerBus_0 : JY6312.h
  • JY6312_TriggerBus_1 : JY6312.h
  • JY6312_TriggerBus_2 : JY6312.h
  • JY6312_TriggerBus_3 : JY6312.h
  • JY6312_TriggerBus_4 : JY6312.h
  • JY6312_TriggerBus_5 : JY6312.h
  • JY6312_TriggerBus_6 : JY6312.h
  • JY6312_TriggerBus_7 : JY6312.h
  • JY6312_TypeA : JY6312.h
  • JY6312_TypeB : JY6312.h
  • JY6312_TypeC : JY6312.h
  • JY6312_TypeD : JY6312.h
  • JY6312_TypeE : JY6312.h
  • JY6312_TypeG : JY6312.h
  • JY6312_TypeJ : JY6312.h
  • JY6312_TypeK : JY6312.h
  • JY6312_TypeN : JY6312.h
  • JY6312_TypeR : JY6312.h
  • JY6312_TypeS : JY6312.h
  • JY6312_TypeT : JY6312.h

- n -

  • Normal : JY6312.h

- o -

  • OpenCircuit : JY6312.h

- s -

  • ShortCircuit : JY6312.h


  • Enumerations
  • Enumerator
  • j
Here is a list of all functions with links to the files they belong to:

- j -

  • JY6312_AI_CheckBufferStatus() : JY6312.h
  • JY6312_AI_ConvertEMFToTemperature() : JY6312.h
  • JY6312_AI_ConvertTemperatureToEMF() : JY6312.h
  • JY6312_AI_DetectOpenThermocouple() : JY6312.h
  • JY6312_AI_EnableCalibration() : JY6312.h
  • JY6312_AI_EnableChannel() : JY6312.h
  • JY6312_AI_EnableCJUserData() : JY6312.h
  • JY6312_AI_GetActualSampleRate() : JY6312.h
  • JY6312_AI_ReadData() : JY6312.h
  • JY6312_AI_ReadRawData() : JY6312.h
  • JY6312_AI_ReadRawSinglePoint() : JY6312.h
  • JY6312_AI_ReadSinglePoint() : JY6312.h
  • JY6312_AI_SendSoftwareTrigger() : JY6312.h
  • JY6312_AI_SetAdvanceTriggerType() : JY6312.h
  • JY6312_AI_SetChannelAdvancedConfig() : JY6312.h
  • JY6312_AI_SetDigitalAdvanceTrigger() : JY6312.h
  • JY6312_AI_SetDigitalReferenceTrigger() : JY6312.h
  • JY6312_AI_SetDigitalStartTrigger() : JY6312.h
  • JY6312_AI_SetPowerLineRejectionPreference() : JY6312.h
  • JY6312_AI_SetPreTriggerSamples() : JY6312.h
  • JY6312_AI_SetReferenceTriggerType() : JY6312.h
  • JY6312_AI_SetReTriggerCount() : JY6312.h
  • JY6312_AI_SetSampleClockSource() : JY6312.h
  • JY6312_AI_SetSampleMode() : JY6312.h
  • JY6312_AI_SetSampleRate() : JY6312.h
  • JY6312_AI_SetSamplesToAcquire() : JY6312.h
  • JY6312_AI_SetSinglePointModeConvertRateGrade() : JY6312.h
  • JY6312_AI_SetStartTriggerType() : JY6312.h
  • JY6312_AI_SetUserCJTemperature() : JY6312.h
  • JY6312_AI_Start() : JY6312.h
  • JY6312_AI_Stop() : JY6312.h
  • JY6312_Close() : JY6312.h
  • JY6312_DisconnectSignalRouting() : JY6312.h
  • JY6312_EnableCJ() : JY6312.h
  • JY6312_EnableCJDebouncedData() : JY6312.h
  • JY6312_GetCJDebouncingStatus() : JY6312.h
  • JY6312_GetCJInvalidBounce() : JY6312.h
  • JY6312_GetCJMaxBounce() : JY6312.h
  • JY6312_GetDeviceID() : JY6312.h
  • JY6312_GetDeviceInfo() : JY6312.h
  • JY6312_GetTerminalBlockConnectionStatus() : JY6312.h
  • JY6312_Open() : JY6312.h
  • JY6312_OpenByName() : JY6312.h
  • JY6312_ResetDebouncer() : JY6312.h
  • JY6312_SetCJInvalidBounce() : JY6312.h
  • JY6312_SetCJMaxBounce() : JY6312.h
  • JY6312_SetCJUpdateDataTimeout() : JY6312.h
  • JY6312_SetCJUpdateInterval() : JY6312.h
  • JY6312_SignalRouting() : JY6312.h


  • Enumerations
  • Enumerator
Here is a list of all typedefs with links to the files they belong to:
  • JY6312_DeviceHandle : JY6312.h


6312 C++ Programming Manual: Main Page

6312 C++ Programming Manual Documentation