6312 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/6312 Directory Reference

6312 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 6312
6312 Directory Reference

Files

JY6312CoreOOAITask.h
JY6312CoreOOCommon.h
JY6312CoreOODevice.h
JY6312CoreOOLog.h
Generated by doxygen 1.13.2


6312 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/6312/JY6312CoreOOAITask.h File Reference

  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 6312
Classes | Namespaces | Enumerations
JY6312CoreOOAITask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include <fstream>
#include <math.h>
#include "JY6312CoreOOCommon.h"
#include "JY6312CoreOODevice.h"

Classes

class | JY6312CoreOO::JY6312CoreOOAITask
AITask类 More...
class | JY6312CoreOO::AIChannel
class | JY6312CoreOO::AIExternalSampleClock
class | JY6312CoreOO::AISampleClock
class | JY6312CoreOO::AITrigger
class | JY6312CoreOO::AIDigitalTrigger
class | JY6312CoreOO::AIChannelAdvanced
class | JY6312CoreOO::PowerLineRejection
class | JY6312CoreOO::AIAdvanced
class | JY6312CoreOO::AISignalExport
class | JY6312CoreOO::TC_Type
class | JY6312CoreOO::BuildInCJC
class | JY6312CoreOO::CJCAdvanced
class | JY6312CoreOO::CJDataDebouncing

Namespaces

namespace JY6312CoreOO

Enumerations

enum | JY6312CoreOO::ThermocoupleConnectionStatus { JY6312CoreOO::_Normal = 0 , JY6312CoreOO::_OpenCircuit = 1 , JY6312CoreOO::_ShortCircuit = 2 }
Thermocouple connection status. More...
enum class | JY6312CoreOO::AIMode { JY6312CoreOO::Finite = 0 , JY6312CoreOO::Continuous = 1 , JY6312CoreOO::Single = 2 }
enum JY6312CoreOO::ThermocoupleType {
JY6312CoreOO::TypeR = 0 , JY6312CoreOO::TypeS = 1 , JY6312CoreOO::TypeB = 2 , JY6312CoreOO::TypeJ = 3 ,
JY6312CoreOO::TypeT = 4 , JY6312CoreOO::TypeE = 5 , JY6312CoreOO::TypeK = 6 , JY6312CoreOO::TypeN = 7 ,
JY6312CoreOO::TypeC = 8 , JY6312CoreOO::TypeA = 9 , JY6312CoreOO::TypeG = 10 , JY6312CoreOO::TypeD = 11
}
enum JY6312CoreOO::AIRange {
JY6312CoreOO::_1p25V = 1 , JY6312CoreOO::_625mV = 2 , JY6312CoreOO::_312p5mV = 3 , JY6312CoreOO::_156p2mV = 4 ,
JY6312CoreOO::_78p125mV = 5
}
AI voltage range. More...
enum | JY6312CoreOO::MeasurementType { JY6312CoreOO::Thermocouple = 0 , JY6312CoreOO::GeneralVoltage = 1 }
Measurement Type Enum. More...
enum | JY6312CoreOO::CJSensorConnectionStatus { JY6312CoreOO::Normal = 0 , JY6312CoreOO::LostConnect = 1 , JY6312CoreOO::Closed = 2 }
Connection status enum between JY6312 and TB68CJ. More...
enum class | JY6312CoreOO::AISampleClockSource { JY6312CoreOO::Internal , JY6312CoreOO::External }
AI Sample Clock Source. More...
enum class | JY6312CoreOO::AITriggerType { JY6312CoreOO::Immediate = 0x0 , JY6312CoreOO::Digital = 0x1 , JY6312CoreOO::Soft = 0x2 }
enum class | JY6312CoreOO::AITriggerMode { JY6312CoreOO::Start , JY6312CoreOO::Reference }
enum class JY6312CoreOO::AIDigitalTriggerSource {
JY6312CoreOO::PFI0 = 0 , JY6312CoreOO::PFI1 = 1 , JY6312CoreOO::PXI_Trig0 = 4 , JY6312CoreOO::PXI_Trig1 = 5 ,
JY6312CoreOO::PXI_Trig2 = 6 , JY6312CoreOO::PXI_Trig3 = 7 , JY6312CoreOO::PXI_Trig4 = 8 , JY6312CoreOO::PXI_Trig5 = 9 ,
JY6312CoreOO::PXI_Trig6 = 10 , JY6312CoreOO::PXI_Trig7 = 11 , JY6312CoreOO::PXI_Star = 12
}
enum class | JY6312CoreOO::AIDigitalTriggerEdge { JY6312CoreOO::Rising = 0x0 , JY6312CoreOO::Falling = 0x1 }
enum class | JY6312CoreOO::AIAnalogTriggerEdge { JY6312CoreOO::Rising , JY6312CoreOO::Falling }
enum class | JY6312CoreOO::AISignalExportSource { JY6312CoreOO::SampleClock = 0 , JY6312CoreOO::TriggerOut = 1 , JY6312CoreOO::IsConverting = 2 }
enum class | JY6312CoreOO::PowerLineFrequency { JY6312CoreOO::_50Hz , JY6312CoreOO::_60Hz }


6312 C++ Programming Manual: JY6312CoreOO::JY6312CoreOOAITask Class Reference

  • Class List
  • Class Index
  • Class Members
  • JY6312CoreOO
  • JY6312CoreOOAITask
Public Member Functions | Public Attributes | List of all members
JY6312CoreOO::JY6312CoreOOAITask Class Reference

AITask类 More...

#include <JY6312CoreOOAITask.h>

Public Member Functions

JY6312CoreOOAITask (int slotNum)
JY6312CoreOOAITask (std::string boardName)
void | AddChannel (int chID, ThermocoupleType thermocoupleType)
Add one/all thermocouple input channel(s) for temperature measurement.
void | AddChannel (std::vector< int > chIDs, ThermocoupleType thermocoupleType)
Add a group of thermocouple input channel and set termocouple type uniformly.
void | AddChannel (std::vector< int > chIDs, std::vector< ThermocoupleType > thermocoupleType)
Add a group of thermocouple input channel and set termocouple type individually.
void | AddChannel (int chID, double voltageRangeLow, double voltageRangeHigh)
Add one/all general voltage input channel(s).
void | AddChannel (std::vector< int > chIDs, double voltageRangeLow, double voltageRangeHigh)
Add a group of general voltage input channel and set range uniformly.
void | AddChannel (std::vector< int > chIDs, std::vector< double > voltageRangeLow, std::vector< double > voltageRangeHigh)
Add a group of general voltage input channel and set range uniformly.
void | RemoveChannel (int chID)
Delete the channel with the specified channel ID.
void | ReadData (double *pBuf, int samplesPerChannel, int timeout=-1)
Read the multi-channel data by columns and store it in a data buffer.
void | ReadRawData (double *hjVoltageDataBuffer, double *cjTemperatureDataBuffer, int samplesPerChannel, int timeout=-1)
Read hot-junction voltage(V) and cold-junction temperature(℃) for single or multiple channels to 2-dimensional data buffer.
void | ReadSinglePoint (double *readValue, int channel)
Single-point readout compensated temperature(℃) or voltage value(V).
void | ReadRawSinglePoint (double *hjVoltageData, double *cjTemperatureData, int channel)
Single-point readout of hot junction voltage(V) and cold junction temperature(℃) to unmanaged memory pointer.
bool | WaitUntilDone (int timeout=-1)
void | SetCJTemperature (int chID, double temperature)
Set cold junction (reference junction) temperature with a specified channel ID.
void | SetCJTemperature (double temperature)
Set cold junction (reference junction) temperature to all channels that has been added.
void | ApplyUserCJTemperature ()
AIRange | MatchTheRange (double absVoltageMax)
double | GetVmax (ThermocoupleType type)
double | GetTmin (ThermocoupleType type)
double | GetAbsVmax (ThermocoupleType type)
std::map< int, ThermocoupleConnectionStatus > | DetectOpenThermocouple ()
void | InitTC_Type ()
void | Start ()
启动Task
void | SendSoftwareTrigger ()
void | Stop ()
~JY6312CoreOOAITask ()

Public Attributes

TC_Type * TC_TypeA {}
TC_Type * TC_TypeB {}
TC_Type * TC_TypeC {}
TC_Type * TC_TypeD {}
TC_Type * TC_TypeE {}
TC_Type * TC_TypeG {}
TC_Type * TC_TypeJ {}
TC_Type * TC_TypeK {}
TC_Type * TC_TypeN {}
TC_Type * TC_TypeR {}
TC_Type * TC_TypeS {}
TC_Type * TC_TypeT {}
std::list< AIChannel * > | Channels
List of AI channels,(5510 5511 support 32 SE/16 Diff channel)(5515 5516 support16 SE/8 Diff channel)
JY6312CoreOOProperty< JY6312CoreOOAITask, double, JY6312CoreOOPropertyType::READ_WRITE > | SampleRate
Sample rate per channel.
int | SamplesToAcquire
Number of samples to be read per channel.
bool | _allChannelVoltageInput
JY6312CoreOOProperty< JY6312CoreOOAITask, int, JY6312CoreOOPropertyType::READ_ONLY > | BufLenInSamples
Number of samples per channel can be storage in the buffer, the Property SamplesToAcquire must be less than or equal to this value.
JY6312CoreOOProperty< JY6312CoreOOAITask, uint64_t, JY6312CoreOOPropertyType::READ_ONLY > | AvailableSamples
Number of samples per channel that can be read in the buffer .
JY6312CoreOOProperty< JY6312CoreOOAITask, uint64_t, JY6312CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
AIMode Mode
AI acquisition mode, support Single/Finite/Continuous/Record *.
AISampleClock * SampleClock
AI Sample Clock.
AITrigger * Trigger
AI Trigger Configuration.
BuildInCJC * _buildInCJC
AI Trigger Configuration.
PowerLineRejection * _pwrLineRej
Power Line Rejection Parameters Class.
bool | DisableCalibration
Disalble calibration Enable.
AISignalExport * SignalExport
Export AI Signal Configuration.
JY6312CoreOODevice * Device {}
Device.

Detailed Description

AITask类

Constructor & Destructor Documentation

◆ JY6312CoreOOAITask() [1/2]

JY6312CoreOO::JY6312CoreOOAITask::JY6312CoreOOAITask ( int slotNum )

◆ JY6312CoreOOAITask() [2/2]

JY6312CoreOO::JY6312CoreOOAITask::JY6312CoreOOAITask ( std::string boardName )

◆ ~JY6312CoreOOAITask()

JY6312CoreOO::JY6312CoreOOAITask::~JY6312CoreOOAITask ( )

Member Function Documentation

◆ AddChannel() [1/6]

void JY6312CoreOO::JY6312CoreOOAITask::AddChannel | ( | int | chID,
 |  | double | voltageRangeLow,
 |  | double | voltageRangeHigh )

Add one/all general voltage input channel(s).

Parameters
chID | IDs of channels to add.
voltageRangeLow | Voltage input range low limit in V. -1.25V / -0.625V / -0.3125V / -0.1562V / -0.078125V / -0.03906V optional.
voltageRangeHigh | Voltage input range high limit in V. +1.25V / +0.625V / +0.3125V / +0.1562V / +0.078125V / +0.03906V optional.

◆ AddChannel() [2/6]

void JY6312CoreOO::JY6312CoreOOAITask::AddChannel | ( | int | chID,
 |  | ThermocoupleType | thermocoupleType )

Add one/all thermocouple input channel(s) for temperature measurement.

The input voltage range is automatically determine by the type of thermocouple.

Parameters
chID | Channel's physical number. chID = -1: add all channels.
thermocoupleType | The type of thermocouple connected to this channel.

◆ AddChannel() [3/6]

void JY6312CoreOO::JY6312CoreOOAITask::AddChannel | ( | std::vector< int > | chIDs,
 |  | double | voltageRangeLow,
 |  | double | voltageRangeHigh )

Add a group of general voltage input channel and set range uniformly.

Parameters
chIDs | IDs of channels to add.
voltageRangeLow | Voltage input range low limit in V. -1.25V / -0.625V / -0.3125V / -0.1562V / -0.078125V / -0.03906V optional.
voltageRangeHigh | Voltage input range high limit in V. +1.25V / +0.625V / +0.3125V / +0.1562V / +0.078125V / +0.03906V optional.

◆ AddChannel() [4/6]

void JY6312CoreOO::JY6312CoreOOAITask::AddChannel | ( | std::vector< int > | chIDs,
 |  | std::vector< double > | voltageRangeLow,
 |  | std::vector< double > | voltageRangeHigh )

Add a group of general voltage input channel and set range uniformly.

Parameters
chIDs | IDs of channels to add.
voltageRangeLow | Voltage input range low limit in V. -1.25V / -0.625V / -0.3125V / -0.1562V / -0.078125V / -0.03906V optional.
voltageRangeHigh | Voltage input range high limit in V. +1.25V / +0.625V / +0.3125V / +0.1562V / +0.078125V / +0.03906V optional.

◆ AddChannel() [5/6]

void JY6312CoreOO::JY6312CoreOOAITask::AddChannel | ( | std::vector< int > | chIDs,
 |  | std::vector< ThermocoupleType > | thermocoupleType )

Add a group of thermocouple input channel and set termocouple type individually.

The input voltage range is automatically determine by the type of thermocouple.

Parameters
chIDs | IDs of channels to add.
thermocoupleType | Thermocouple type of channels to add.

◆ AddChannel() [6/6]

void JY6312CoreOO::JY6312CoreOOAITask::AddChannel | ( | std::vector< int > | chIDs,
 |  | ThermocoupleType | thermocoupleType )

Add a group of thermocouple input channel and set termocouple type uniformly.

The input voltage range is automatically determine by the type of thermocouple.

Parameters
chIDs | IDs of channels to add.
thermocoupleType | Thermocouple type of channels to add.

◆ ApplyUserCJTemperature()

void JY6312CoreOO::JY6312CoreOOAITask::ApplyUserCJTemperature ( )

◆ DetectOpenThermocouple()

std::map< int, ThermocoupleConnectionStatus > JY6312CoreOO::JY6312CoreOOAITask::DetectOpenThermocouple ( )

◆ GetAbsVmax()

double JY6312CoreOO::JY6312CoreOOAITask::GetAbsVmax ( ThermocoupleType type )

◆ GetTmin()

double JY6312CoreOO::JY6312CoreOOAITask::GetTmin ( ThermocoupleType type )

◆ GetVmax()

double JY6312CoreOO::JY6312CoreOOAITask::GetVmax ( ThermocoupleType type )

◆ InitTC_Type()

void JY6312CoreOO::JY6312CoreOOAITask::InitTC_Type ( )

◆ MatchTheRange()

AIRange JY6312CoreOO::JY6312CoreOOAITask::MatchTheRange ( double absVoltageMax )

◆ ReadData()

void JY6312CoreOO::JY6312CoreOOAITask::ReadData | ( | double * | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = -1 )

Read the multi-channel data by columns and store it in a data buffer.

Each channel is represented by one column of data.

Parameters
pBuf | Data buffer
samplesPerChannel | Number of samples per channel to read
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadRawData()

void JY6312CoreOO::JY6312CoreOOAITask::ReadRawData | ( | double * | hjVoltageDataBuffer,
 |  | double * | cjTemperatureDataBuffer,
 |  | int | samplesPerChannel,
 |  | int | timeout = -1 )

Read hot-junction voltage(V) and cold-junction temperature(℃) for single or multiple channels to 2-dimensional data buffer.

Parameters
hjVoltageData | Hot-junction voltage in V
cjTemperatureData | Cold-junction temperature in ℃
samplesPerChannel | Number of samples to read per channel.
timeout | Timeout in ms before generate tiemout exception. When equal to -1, it never times out.

◆ ReadRawSinglePoint()

void JY6312CoreOO::JY6312CoreOOAITask::ReadRawSinglePoint | ( | double * | hjVoltageData,
 |  | double * | cjTemperatureData,
 |  | int | channel )

Single-point readout of hot junction voltage(V) and cold junction temperature(℃) to unmanaged memory pointer.

Parameters
hjVoltageData
cjTemperatureData

◆ ReadSinglePoint()

void JY6312CoreOO::JY6312CoreOOAITask::ReadSinglePoint | ( | double * | readValue,
 |  | int | channel )

Single-point readout compensated temperature(℃) or voltage value(V).

Parameters
dataBuffer Data buffer.

◆ RemoveChannel()

void JY6312CoreOO::JY6312CoreOOAITask::RemoveChannel ( int chID )

Delete the channel with the specified channel ID.

Parameters
chID Specified channel ID. chId = -1: remove all channels.

◆ SendSoftwareTrigger()

void JY6312CoreOO::JY6312CoreOOAITask::SendSoftwareTrigger ( )

◆ SetCJTemperature() [1/2]

void JY6312CoreOO::JY6312CoreOOAITask::SetCJTemperature ( double temperature )

Set cold junction (reference junction) temperature to all channels that has been added.

These parameter are only valid when buld-in cold-junction compensation disabled ( BuildInCJC.Enabled = false ).

Parameters
temperature Cold junction (reference juntion) temperature in ℃. The ordering of the elements must be the same as the order in which the channels are added.

◆ SetCJTemperature() [2/2]

void JY6312CoreOO::JY6312CoreOOAITask::SetCJTemperature | ( | int | chID,
 |  | double | temperature )

Set cold junction (reference junction) temperature with a specified channel ID.

These parameter are only valid when buld-in cold-junction compensation disabled ( BuildInCJC.Enabled = false ).

Parameters
chID | Specified channel ID, this channle must already has been added. chnId = -1: set this temperature to all channels that has been added.
temperature | Cold junction (reference juntion) temperature in ℃.

◆ Start()

void JY6312CoreOO::JY6312CoreOOAITask::Start ( )

启动Task

Parameters

return void

Exceptions
JYDriverException 如果启动失败

◆ Stop()

void JY6312CoreOO::JY6312CoreOOAITask::Stop ( )

◆ WaitUntilDone()

bool JY6312CoreOO::JY6312CoreOOAITask::WaitUntilDone ( int timeout = -1 )
inline

Member Data Documentation

◆ _allChannelVoltageInput

bool JY6312CoreOO::JY6312CoreOOAITask::_allChannelVoltageInput

◆ _buildInCJC

BuildInCJC* JY6312CoreOO::JY6312CoreOOAITask::_buildInCJC

AI Trigger Configuration.

◆ _pwrLineRej

PowerLineRejection* JY6312CoreOO::JY6312CoreOOAITask::_pwrLineRej

Power Line Rejection Parameters Class.

◆ AvailableSamples

JY6312CoreOOProperty<JY6312CoreOOAITask, uint64_t, JY6312CoreOOPropertyType::READ_ONLY> JY6312CoreOO::JY6312CoreOOAITask::AvailableSamples

Number of samples per channel that can be read in the buffer .

Valid when Mode is NOT AIMode.Single.

◆ BufLenInSamples

JY6312CoreOOProperty<JY6312CoreOOAITask, int, JY6312CoreOOPropertyType::READ_ONLY> JY6312CoreOO::JY6312CoreOOAITask::BufLenInSamples

Number of samples per channel can be storage in the buffer, the Property SamplesToAcquire must be less than or equal to this value.

◆ Channels

std::list<AIChannel*> JY6312CoreOO::JY6312CoreOOAITask::Channels

List of AI channels,(5510 5511 support 32 SE/16 Diff channel)(5515 5516 support16 SE/8 Diff channel)

◆ Device

JY6312CoreOODevice* JY6312CoreOO::JY6312CoreOOAITask::Device {}

Device.

◆ DisableCalibration

bool JY6312CoreOO::JY6312CoreOOAITask::DisableCalibration

Disalble calibration Enable.

◆ Mode

AIMode JY6312CoreOO::JY6312CoreOOAITask::Mode

AI acquisition mode, support Single/Finite/Continuous/Record *.

◆ SampleClock

AISampleClock* JY6312CoreOO::JY6312CoreOOAITask::SampleClock

AI Sample Clock.

◆ SampleRate

JY6312CoreOOProperty<JY6312CoreOOAITask, double, JY6312CoreOOPropertyType::READ_WRITE> JY6312CoreOO::JY6312CoreOOAITask::SampleRate

Sample rate per channel.

Maximum sample rate is 2M for single channel, 1M/N for multichannel (N) The default sample rate = 30k You can read this property to obtain the sample rate that will actually take effect in the current configuration.

Exceptions
JYDriverException

◆ SamplesToAcquire

int JY6312CoreOO::JY6312CoreOOAITask::SamplesToAcquire

Number of samples to be read per channel.

Only valid when Mode is Finite*

◆ SignalExport

AISignalExport* JY6312CoreOO::JY6312CoreOOAITask::SignalExport

Export AI Signal Configuration.

◆ TC_TypeA

TC_Type* JY6312CoreOO::JY6312CoreOOAITask::TC_TypeA {}

◆ TC_TypeB

TC_Type* JY6312CoreOO::JY6312CoreOOAITask::TC_TypeB {}

◆ TC_TypeC

TC_Type* JY6312CoreOO::JY6312CoreOOAITask::TC_TypeC {}

◆ TC_TypeD

TC_Type* JY6312CoreOO::JY6312CoreOOAITask::TC_TypeD {}

◆ TC_TypeE

TC_Type* JY6312CoreOO::JY6312CoreOOAITask::TC_TypeE {}

◆ TC_TypeG

TC_Type* JY6312CoreOO::JY6312CoreOOAITask::TC_TypeG {}

◆ TC_TypeJ

TC_Type* JY6312CoreOO::JY6312CoreOOAITask::TC_TypeJ {}

◆ TC_TypeK

TC_Type* JY6312CoreOO::JY6312CoreOOAITask::TC_TypeK {}

◆ TC_TypeN

TC_Type* JY6312CoreOO::JY6312CoreOOAITask::TC_TypeN {}

◆ TC_TypeR

TC_Type* JY6312CoreOO::JY6312CoreOOAITask::TC_TypeR {}

◆ TC_TypeS

TC_Type* JY6312CoreOO::JY6312CoreOOAITask::TC_TypeS {}

◆ TC_TypeT

TC_Type* JY6312CoreOO::JY6312CoreOOAITask::TC_TypeT {}

◆ TransferedSamples

JY6312CoreOOProperty<JY6312CoreOOAITask, uint64_t, JY6312CoreOOPropertyType::READ_ONLY> JY6312CoreOO::JY6312CoreOOAITask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT AIMode.Single.

◆ Trigger

AITrigger* JY6312CoreOO::JY6312CoreOOAITask::Trigger

AI Trigger Configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6312/JY6312CoreOOAITask.h


6312 C++ Programming Manual: JY6312CoreOO::AIChannel Class Reference

  • JY6312CoreOO
  • AIChannel
Public Attributes | List of all members
JY6312CoreOO::AIChannel Class Reference

#include <JY6312CoreOOAITask.h>

Public Attributes

int | ID
ThermocoupleType _ThermocoupleType
double | CustomCJTemperature
MeasurementType _MeasurementType
double | Gain = 0
double | RangeHigh = 0
double | RangeLow = 0
AIRange Range
AIChannelAdvanced * _AIChannelAdvanced

Member Data Documentation

◆ _AIChannelAdvanced

AIChannelAdvanced* JY6312CoreOO::AIChannel::_AIChannelAdvanced

◆ _MeasurementType

MeasurementType JY6312CoreOO::AIChannel::_MeasurementType

◆ _ThermocoupleType

ThermocoupleType JY6312CoreOO::AIChannel::_ThermocoupleType

◆ CustomCJTemperature

double JY6312CoreOO::AIChannel::CustomCJTemperature

◆ Gain

double JY6312CoreOO::AIChannel::Gain = 0

◆ ID

int JY6312CoreOO::AIChannel::ID

◆ Range

AIRange JY6312CoreOO::AIChannel::Range

◆ RangeHigh

double JY6312CoreOO::AIChannel::RangeHigh = 0

◆ RangeLow

double JY6312CoreOO::AIChannel::RangeLow = 0
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6312/JY6312CoreOOAITask.h


6312 C++ Programming Manual: JY6312CoreOO::AIExternalSampleClock Class Reference

  • AIExternalSampleClock
Public Attributes | List of all members
JY6312CoreOO::AIExternalSampleClock Class Reference

#include <JY6312CoreOOAITask.h>

Public Attributes

ClockTerminal Terminal
External Sample Clock Input Terminal.
double ExpectedRate
The expected external sampling clock rate, which is used to determine the appropriate AD conversion rate.

Member Data Documentation

◆ ExpectedRate

double JY6312CoreOO::AIExternalSampleClock::ExpectedRate

The expected external sampling clock rate, which is used to determine the appropriate AD conversion rate.

Make sure that the external actual sample clock rate is not larger than the setting value here.

◆ Terminal

ClockTerminal JY6312CoreOO::AIExternalSampleClock::Terminal

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6312/JY6312CoreOOAITask.h


6312 C++ Programming Manual: JY6312CoreOO::AISampleClock Class Reference

  • AISampleClock
Public Attributes | List of all members
JY6312CoreOO::AISampleClock Class Reference

#include <JY6312CoreOOAITask.h>

Public Attributes

AISampleClockSource Source
AI Sample Clock Source.
AIExternalSampleClock * External
External Sample Clock Configuration.

Member Data Documentation

◆ External

AIExternalSampleClock* JY6312CoreOO::AISampleClock::External

External Sample Clock Configuration.

Valid when Source is AISampleClockSource.External.

◆ Source

AISampleClockSource JY6312CoreOO::AISampleClock::Source

AI Sample Clock Source.

enum Internal/External. The default value is AISampleClockSource.Internal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6312/JY6312CoreOOAITask.h


6312 C++ Programming Manual: JY6312CoreOO::AITrigger Class Reference

  • AITrigger
Public Attributes | List of all members
JY6312CoreOO::AITrigger Class Reference

#include <JY6312CoreOOAITask.h>

Public Attributes

AITriggerType Type
AI trigger type.
AITriggerMode Mode
AI trigger mode.
AIDigitalTrigger * Digital
Digital Trigger Congfiguration.
AIAnalogTrigger * | Analog
AI Analog Trigger.
int | ReTriggerCount
Number of repeat triggers.
unsigned int | PreTriggerSamples
AI pretrigger samples, must be less than or equal to JY6312AITask.SamplesToAcquire.

Member Data Documentation

◆ Analog

AIAnalogTrigger* JY6312CoreOO::AITrigger::Analog

AI Analog Trigger.

Valid when Type is AITriggerType.Analog.

◆ Digital

AIDigitalTrigger* JY6312CoreOO::AITrigger::Digital

Digital Trigger Congfiguration.

Valid when Type is AITriggerType.Digital.

◆ Mode

AITriggerMode JY6312CoreOO::AITrigger::Mode

AI trigger mode.

enum Start/Reference. The default value is AITriggerMode.Start.

◆ PreTriggerSamples

unsigned int JY6312CoreOO::AITrigger::PreTriggerSamples

AI pretrigger samples, must be less than or equal to JY6312AITask.SamplesToAcquire.

Valid when Mode is AITriggerMode.Reference. Pretrigger samples, must be greater than 0. Valid when Type is AITriggerType.Analog. Pretrigger samples, must be greater than 1. Valid when Type is AITriggerType.Digital.

◆ ReTriggerCount

int JY6312CoreOO::AITrigger::ReTriggerCount

Number of repeat triggers.

When 0 or 1 only trigger once, When -1 continuous retrigger until stop.

◆ Type

AITriggerType JY6312CoreOO::AITrigger::Type

AI trigger type.

enum Analog/Digital/Immediate/Soft. The default value is AITriggerType.Immediate.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6312/JY6312CoreOOAITask.h


6312 C++ Programming Manual: JY6312CoreOO::AIDigitalTrigger Class Reference

  • AIDigitalTrigger
Public Attributes | List of all members
JY6312CoreOO::AIDigitalTrigger Class Reference

#include <JY6312CoreOOAITask.h>

Public Attributes

AIDigitalTriggerSource Source
AI Digital Trigger source.
AIDigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Member Data Documentation

◆ Edge

AIDigitalTriggerEdge JY6312CoreOO::AIDigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

AIDigitalTriggerSource JY6312CoreOO::AIDigitalTrigger::Source

AI Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6312/JY6312CoreOOAITask.h


6312 C++ Programming Manual: JY6312CoreOO::AIChannelAdvanced Class Reference

  • AIChannelAdvanced
Public Attributes | List of all members
JY6312CoreOO::AIChannelAdvanced Class Reference

#include <JY6312CoreOOAITask.h>

Public Attributes

AIRange Range
bool | VbiasEnabled = true
bool | InputBufferEnabled = true

Member Data Documentation

◆ InputBufferEnabled

bool JY6312CoreOO::AIChannelAdvanced::InputBufferEnabled = true

◆ Range

AIRange JY6312CoreOO::AIChannelAdvanced::Range

◆ VbiasEnabled

bool JY6312CoreOO::AIChannelAdvanced::VbiasEnabled = true
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6312/JY6312CoreOOAITask.h


6312 C++ Programming Manual: JY6312CoreOO::PowerLineRejection Class Reference

  • PowerLineRejection
Public Attributes | List of all members
JY6312CoreOO::PowerLineRejection Class Reference

#include <JY6312CoreOOAITask.h>

Public Attributes

bool | RejectAt50Hz
Enable DSMode.
bool | RejectAt60Hz
JY6312CoreOO::PowerLineFrequency Frequency
AC Power Frequency.

Member Data Documentation

◆ Frequency

JY6312CoreOO::PowerLineFrequency JY6312CoreOO::PowerLineRejection::Frequency

AC Power Frequency.

◆ RejectAt50Hz

bool JY6312CoreOO::PowerLineRejection::RejectAt50Hz

Enable DSMode.

◆ RejectAt60Hz

bool JY6312CoreOO::PowerLineRejection::RejectAt60Hz
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6312/JY6312CoreOOAITask.h


6312 C++ Programming Manual: JY6312CoreOO::AIAdvanced Class Reference

  • AIAdvanced
Public Attributes | List of all members
JY6312CoreOO::AIAdvanced Class Reference

#include <JY6312CoreOOAITask.h>

Public Attributes

double ConvertRate
the convert rate of ADC.

Member Data Documentation

◆ ConvertRate

double JY6312CoreOO::AIAdvanced::ConvertRate

the convert rate of ADC.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6312/JY6312CoreOOAITask.h


6312 C++ Programming Manual: JY6312CoreOO::AISignalExport Class Reference

  • AISignalExport
Public Member Functions | List of all members
JY6312CoreOO::AISignalExport Class Reference

#include <JY6312CoreOOAITask.h>

Public Member Functions

void | Add (AISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (AISignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Member Function Documentation

◆ Add() [1/2]

void JY6312CoreOO::AISignalExport::Add | ( | AISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | AI Signal Source
destination | Export Desination

◆ Add() [2/2]

void JY6312CoreOO::AISignalExport::Add | ( | AISignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | AI Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JY6312CoreOO::AISignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY6312CoreOO::AISignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6312/JY6312CoreOOAITask.h


6312 C++ Programming Manual: JY6312CoreOO::TC_Type Class Reference

  • TC_Type
Public Attributes | List of all members
JY6312CoreOO::TC_Type Class Reference

#include <JY6312CoreOOAITask.h>

Public Attributes

double | Vmin = 0
double | Vmax = 0
double | Tmin = 0
double | Tmax = 0

Member Data Documentation

◆ Tmax

double JY6312CoreOO::TC_Type::Tmax = 0

◆ Tmin

double JY6312CoreOO::TC_Type::Tmin = 0

◆ Vmax

double JY6312CoreOO::TC_Type::Vmax = 0

◆ Vmin

double JY6312CoreOO::TC_Type::Vmin = 0
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6312/JY6312CoreOOAITask.h


6312 C++ Programming Manual: JY6312CoreOO::BuildInCJC Class Reference

  • BuildInCJC
Public Member Functions | Public Attributes | List of all members
JY6312CoreOO::BuildInCJC Class Reference

#include <JY6312CoreOOAITask.h>

Public Member Functions

void | OpenSensorComminucation ()
Open the communication with cold-junction sensor and continuously update the cold(reference)-junction temperature.
void | Commit ()
void | ReportBuildInCJException (bool running, bool measureTC)

Public Attributes

bool Enabled
CJSensorConnectionStatus SensorStatus = CJSensorConnectionStatus::Normal
CJCAdvanced * Advanced {}
CJDataDebouncing * Debouncing {}

Member Function Documentation

◆ Commit()

void JY6312CoreOO::BuildInCJC::Commit ( )

◆ OpenSensorComminucation()

void JY6312CoreOO::BuildInCJC::OpenSensorComminucation ( )

Open the communication with cold-junction sensor and continuously update the cold(reference)-junction temperature.

◆ ReportBuildInCJException()

void JY6312CoreOO::BuildInCJC::ReportBuildInCJException | ( | bool | running,
 |  | bool | measureTC )

Member Data Documentation

◆ Advanced

CJCAdvanced* JY6312CoreOO::BuildInCJC::Advanced {}

◆ Debouncing

CJDataDebouncing* JY6312CoreOO::BuildInCJC::Debouncing {}

◆ Enabled

bool JY6312CoreOO::BuildInCJC::Enabled

◆ SensorStatus

CJSensorConnectionStatus JY6312CoreOO::BuildInCJC::SensorStatus = CJSensorConnectionStatus::Normal
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6312/JY6312CoreOOAITask.h


6312 C++ Programming Manual: JY6312CoreOO::CJCAdvanced Class Reference

  • CJCAdvanced
Public Attributes | List of all members
JY6312CoreOO::CJCAdvanced Class Reference

#include <JY6312CoreOOAITask.h>

Public Attributes

bool | IgnoreTimeoutException
int | UpdateTimeout
int | UpdateInterval

Member Data Documentation

◆ IgnoreTimeoutException

bool JY6312CoreOO::CJCAdvanced::IgnoreTimeoutException

◆ UpdateInterval

int JY6312CoreOO::CJCAdvanced::UpdateInterval

◆ UpdateTimeout

int JY6312CoreOO::CJCAdvanced::UpdateTimeout
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6312/JY6312CoreOOAITask.h


6312 C++ Programming Manual: JY6312CoreOO::CJDataDebouncing Class Reference

  • CJDataDebouncing
Public Member Functions | Public Attributes | List of all members
JY6312CoreOO::CJDataDebouncing Class Reference

#include <JY6312CoreOOAITask.h>

Public Member Functions

void Commit ()

Public Attributes

bool | Enabled
double | MaxBounce
double | ValidBounce

Member Function Documentation

◆ Commit()

void JY6312CoreOO::CJDataDebouncing::Commit ( )

Member Data Documentation

◆ Enabled

bool JY6312CoreOO::CJDataDebouncing::Enabled

◆ MaxBounce

double JY6312CoreOO::CJDataDebouncing::MaxBounce

◆ ValidBounce

double JY6312CoreOO::CJDataDebouncing::ValidBounce
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6312/JY6312CoreOOAITask.h


6312 C++ Programming Manual: JY6312CoreOO Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Enumerations | Functions
JY6312CoreOO Namespace Reference

Classes

class | AIAdvanced
class | AIChannel
class | AIChannelAdvanced
class | AIDigitalTrigger
class | AIExternalSampleClock
class | AISampleClock
class | AISignalExport
class | AITrigger
class | BuildInCJC
class | CJCAdvanced
class | CJDataDebouncing
class | ExternalReferenceClock
class | JY6312CoreOOAITask
AITask类 More...
class | JY6312CoreOODevice
class | JY6312CoreOOLog
class | JY6312CoreOOProperty
属性模板类 More...
class | JY6312CoreOOReferenceClock
class | JYDriverException
class | PowerLineRejection
class | TC_Type

Enumerations

enum | ThermocoupleConnectionStatus { _Normal = 0 , _OpenCircuit = 1 , _ShortCircuit = 2 }
Thermocouple connection status. More...
enum class | AIMode { Finite = 0 , Continuous = 1 , Single = 2 }
enum ThermocoupleType {
TypeR = 0 , TypeS = 1 , TypeB = 2 , TypeJ = 3 ,
TypeT = 4 , TypeE = 5 , TypeK = 6 , TypeN = 7 ,
TypeC = 8 , TypeA = 9 , TypeG = 10 , TypeD = 11
}
enum AIRange {
_1p25V = 1 , _625mV = 2 , _312p5mV = 3 , _156p2mV = 4 ,
_78p125mV = 5
}
AI voltage range. More...
enum | MeasurementType { Thermocouple = 0 , GeneralVoltage = 1 }
Measurement Type Enum. More...
enum | CJSensorConnectionStatus { Normal = 0 , LostConnect = 1 , Closed = 2 }
Connection status enum between JY6312 and TB68CJ. More...
enum class | AISampleClockSource { Internal , External }
AI Sample Clock Source. More...
enum class | AITriggerType { Immediate = 0x0 , Digital = 0x1 , Soft = 0x2 }
enum class | AITriggerMode { Start , Reference }
enum class AIDigitalTriggerSource {
PFI0 = 0 , PFI1 = 1 , PXI_Trig0 = 4 , PXI_Trig1 = 5 ,
PXI_Trig2 = 6 , PXI_Trig3 = 7 , PXI_Trig4 = 8 , PXI_Trig5 = 9 ,
PXI_Trig6 = 10 , PXI_Trig7 = 11 , PXI_Star = 12
}
enum class | AIDigitalTriggerEdge { Rising = 0x0 , Falling = 0x1 }
enum class | AIAnalogTriggerEdge { Rising , Falling }
enum class | AISignalExportSource { SampleClock = 0 , TriggerOut = 1 , IsConverting = 2 }
enum class | PowerLineFrequency { _50Hz , _60Hz }
enum class | JY6312CoreOOPropertyType { READ_ONLY = 1 , WRITE_ONLY = 2 , READ_WRITE = 3 }
enum class JYDriverExceptionPublic {
UnKnown = 0 , OpenDeviceFailed = -10001 , CloseDeviceFailed = -10002 , ResetDeviceFailed = -10003 ,
GetDevicePropertyFailed = -10004 , SetDevicePropertyFailed = -10005 , HardwareResourceIsReserved = -10006 , MethodNotPermitedToCallWhenCurrentStatus = -10007 ,
InvalidUserDataBuffer = -10008 , NoChannelAdded = -10009 , NotSupportOperationForCurrentDevice = -10010 , CreatTaskFailed = -10100 ,
StartTaskFailed = -10101 , StopTaskFailed = -10102 , TaskHasNotStarted = -10103 , TaskHasStartedCannotPerformTheSetOperation = -10104 ,
ChannelNumberParameterInvalid = -10105 , ChannelInputRangeParameterInvalid = -10106 , ChannelTerminalParameterInvalid = -10107 , ChannelCouplingParameterInvalid = -10108 ,
SampeleModeParameterInvalid = -10109 , SampleClockParameterInvalid = -10110 , SampleRateParameterInvalid = -10111 , UpdateRateParameterInvalid = -10112 ,
TriggerParameterInvalid = -10113 , ReferenceTriggerDoesNotMatchWithSampleMode = -10114 , PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint = -10115 , ReadDataFailed = -10016 ,
ReadDataTimeout = -10017 , WriteDataFailed = -10018 , WriteDataTimeout = -10019 , WriteDataLengthCannotBeLessThanN = -10020 ,
BufferDataOverflow = -10021 , BufferDataDownflow = -10022 , CheckBufferFailed = -10023 , PointInvalidInFiniteMode = -10024 ,
ReadPointInvalid = -10025 , OnlySupportRecordMode = -10026 , SendSoftTirggerFailed = -10027 , TaskTimeout = -10028 ,
CounterParametersInvalid = -10029 , WritePointInvalid = -10030 , SignalExportDestinationInvalid = -10031 , InvalidParameter = -10033
}
enum class ClockTerminal {
PFI0 = 0 , PFI1 = 1 , PXI_Trig0 = 4 , PXI_Trig1 = 5 ,
PXI_Trig2 = 6 , PXI_Trig3 = 7 , PXI_Trig4 = 8 , PXI_Trig5 = 9 ,
PXI_Trig6 = 10 , PXI_Trig7 = 11 , PXI_Star = 12
}
enum class SignalExportDestination {
PXI_Trig0 = 4 , PXI_Trig1 , PXI_Trig2 , PXI_Trig3 ,
PXI_Trig4 , PXI_Trig5 , PXI_Trig6 , PXI_Trig7 ,
PXI_Star
}
enum class | OutputCompleteState { Zero , Hold }
Output Complete State. More...
enum class IOTerminal {
PFI0 = 0 , PFI1 = 1 , PXI_Trig0 = 4 , PXI_Trig1 = 5 ,
PXI_Trig2 = 6 , PXI_Trig3 = 7 , PXI_Trig4 = 8 , PXI_Trig5 = 9 ,
PXI_Trig6 = 10 , PXI_Trig7 = 11 , PXI_Star = 12
}
Cunter IO Terminal. More...
enum class | ExternalReferenceClockTerminal { PXIe_Clk100 = 0x1 }
enum class | ReferenceClockSource { Internal = 0x0 , External = 0x1 }
enum class JY6312CoreOOLogLevel {
DEBUG_LOG_LEVEL , INFO_LOG_LEVEL , WARN_LOG_LEVEL , ERROR_LOG_LEVEL ,
FATAL_LOG_LEVEL
}

Functions

std::string GetSignalExportDestinationString (SignalExportDestination destination)

Enumeration Type Documentation

◆ AIAnalogTriggerEdge

enum class JY6312CoreOO::AIAnalogTriggerEdge
strong
Enumerator
Rising | Rising.
Falling | Falling.

◆ AIDigitalTriggerEdge

enum class JY6312CoreOO::AIDigitalTriggerEdge
strong
Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ AIDigitalTriggerSource

enum class JY6312CoreOO::AIDigitalTriggerSource
strong
Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PXI_Trig0 | PXITrig_0.
PXI_Trig1 | PXITrig_1.
PXI_Trig2 | PXITrig_2.
PXI_Trig3 | PXITrig_3.
PXI_Trig4 | PXITrig_4.
PXI_Trig5 | PXITrig_5.
PXI_Trig6 | PXITrig_6.
PXI_Trig7 | PXITrig_7.
PXI_Star | PXI STAR.

◆ AIMode

enum class JY6312CoreOO::AIMode
strong
Enumerator
Finite | Finite mode.
Continuous | Continuous mode.
Single | Single point mode.

◆ AIRange

enum JY6312CoreOO::AIRange

AI voltage range.

Enumerator
_1p25V | ±1.25V
_625mV | ±625mV
_312p5mV | ±312.5mV
_156p2mV | ±156.2mV
_78p125mV | ±78.125mV

◆ AISampleClockSource

enum class JY6312CoreOO::AISampleClockSource
strong

AI Sample Clock Source.

Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ AISignalExportSource

enum class JY6312CoreOO::AISignalExportSource
strong
Enumerator
SampleClock | Sample Clock.
TriggerOut | Trigger Out.
IsConverting | ADC is converting.

◆ AITriggerMode

enum class JY6312CoreOO::AITriggerMode
strong
Enumerator
Start | Start Trigger.
Reference | Reference Trigger，Valid when JY6312AITask.Mode is AIMode.Finite

◆ AITriggerType

enum class JY6312CoreOO::AITriggerType
strong
Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ CJSensorConnectionStatus

enum JY6312CoreOO::CJSensorConnectionStatus

Connection status enum between JY6312 and TB68CJ.

Enumerator
Normal | Normal.
LostConnect | The connection has been lost. The JY6312 has been unable to obtain sensor data for a while.
Closed | Communication has been closed.The JY6312 will not initiate I2C communication.

◆ ClockTerminal

enum class JY6312CoreOO::ClockTerminal
strong
Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PXI_Trig0 | PXITrig_0.
PXI_Trig1 | PXITrig_1.
PXI_Trig2 | PXITrig_2.
PXI_Trig3 | PXITrig_3.
PXI_Trig4 | PXITrig_4.
PXI_Trig5 | PXITrig_5.
PXI_Trig6 | PXITrig_6.
PXI_Trig7 | PXITrig_7.
PXI_Star | PXI STAR.

◆ ExternalReferenceClockTerminal

enum class JY6312CoreOO::ExternalReferenceClockTerminal
strong
Enumerator
PXIe_Clk100

PXIe_Clk100.

◆ IOTerminal

enum class JY6312CoreOO::IOTerminal
strong

Cunter IO Terminal.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PXI_Trig0 | PXITrig_0.
PXI_Trig1 | PXITrig_1.
PXI_Trig2 | PXITrig_2.
PXI_Trig3 | PXITrig_3.
PXI_Trig4 | PXITrig_4.
PXI_Trig5 | PXITrig_5.
PXI_Trig6 | PXITrig_6.
PXI_Trig7 | PXITrig_7.
PXI_Star | PXI STAR.

◆ JY6312CoreOOLogLevel

enum class JY6312CoreOO::JY6312CoreOOLogLevel
strong
Enumerator
DEBUG_LOG_LEVEL
INFO_LOG_LEVEL
WARN_LOG_LEVEL
ERROR_LOG_LEVEL
FATAL_LOG_LEVEL

◆ JY6312CoreOOPropertyType

enum class JY6312CoreOO::JY6312CoreOOPropertyType
strong
Enumerator
READ_ONLY
WRITE_ONLY
READ_WRITE

◆ JYDriverExceptionPublic

enum class JY6312CoreOO::JYDriverExceptionPublic
strong
Enumerator
UnKnown | JYDriverExceptionPublic.
OpenDeviceFailed | JYDriverExceptionPublic.
CloseDeviceFailed | JYDriverExceptionPublic.
ResetDeviceFailed | JYDriverExceptionPublic.
GetDevicePropertyFailed | JYDriverExceptionPublic.
SetDevicePropertyFailed | JYDriverExceptionPublic.
HardwareResourceIsReserved | JYDriverExceptionPublic.
MethodNotPermitedToCallWhenCurrentStatus | JYDriverExceptionPublic.
InvalidUserDataBuffer | JYDriverExceptionPublic.
NoChannelAdded | JYDriverExceptionPublic.
NotSupportOperationForCurrentDevice | JYDriverExceptionPublic.
CreatTaskFailed | JYDriverExceptionPublic.
StartTaskFailed | JYDriverExceptionPublic.
StopTaskFailed | JYDriverExceptionPublic.
TaskHasNotStarted | JYDriverExceptionPublic.
TaskHasStartedCannotPerformTheSetOperation | JYDriverExceptionPublic.
ChannelNumberParameterInvalid | JYDriverExceptionPublic.
ChannelInputRangeParameterInvalid | JYDriverExceptionPublic.
ChannelTerminalParameterInvalid | JYDriverExceptionPublic.
ChannelCouplingParameterInvalid | JYDriverExceptionPublic.
SampeleModeParameterInvalid | JYDriverExceptionPublic.
SampleClockParameterInvalid | JYDriverExceptionPublic.
SampleRateParameterInvalid | JYDriverExceptionPublic.
UpdateRateParameterInvalid | JYDriverExceptionPublic.
TriggerParameterInvalid | JYDriverExceptionPublic.
ReferenceTriggerDoesNotMatchWithSampleMode | JYDriverExceptionPublic.
PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint | JYDriverExceptionPublic.
ReadDataFailed | JYDriverExceptionPublic.
ReadDataTimeout | JYDriverExceptionPublic.
WriteDataFailed | JYDriverExceptionPublic.
WriteDataTimeout | JYDriverExceptionPublic.
WriteDataLengthCannotBeLessThanN | JYDriverExceptionPublic.
BufferDataOverflow | JYDriverExceptionPublic.
BufferDataDownflow | JYDriverExceptionPublic.
CheckBufferFailed | JYDriverExceptionPublic.
PointInvalidInFiniteMode | JYDriverExceptionPublic.
ReadPointInvalid | JYDriverExceptionPublic.
OnlySupportRecordMode | JYDriverExceptionPublic.
SendSoftTirggerFailed | JYDriverExceptionPublic.
TaskTimeout | JYDriverExceptionPublic.
CounterParametersInvalid | JYDriverExceptionPublic.
WritePointInvalid | JYDriverExceptionPublic.
SignalExportDestinationInvalid | JYDriverExceptionPublic.
InvalidParameter | 无效参数。 Invalid parameter.

◆ MeasurementType

enum JY6312CoreOO::MeasurementType

Measurement Type Enum.

Enumerator
Thermocouple | Measuring thermocouple. The data is temeprature in ℃.
GeneralVoltage | Measuring voltage. The data is voltage value in V.

◆ OutputCompleteState

enum class JY6312CoreOO::OutputCompleteState
strong

Output Complete State.

Enumerator
Zero | Output Complete Zero.
Hold | Output Complete Hold in The last point.

◆ PowerLineFrequency

enum class JY6312CoreOO::PowerLineFrequency
strong
Enumerator
_50Hz | 50 Hz AC Power Frequency
_60Hz | 60 Hz AC Power Frequency

◆ ReferenceClockSource

enum class JY6312CoreOO::ReferenceClockSource
strong
Enumerator
Internal | Internal on board 25MHz Clock.
External | External Reference Clock Source.

◆ SignalExportDestination

enum class JY6312CoreOO::SignalExportDestination
strong
Enumerator
PXI_Trig0 | PXITrig_0.
PXI_Trig1 | PXITrig_1.
PXI_Trig2 | PXITrig_2.
PXI_Trig3 | PXITrig_3.
PXI_Trig4 | PXITrig_4.
PXI_Trig5 | PXITrig_5.
PXI_Trig6 | PXITrig_6.
PXI_Trig7 | PXITrig_7.
PXI_Star | PXI STAR.

◆ ThermocoupleConnectionStatus

enum JY6312CoreOO::ThermocoupleConnectionStatus

Thermocouple connection status.

Enumerator
_Normal | Normal.
_OpenCircuit | Open circuit.
_ShortCircuit | Short circuit.

◆ ThermocoupleType

enum JY6312CoreOO::ThermocoupleType
Enumerator
TypeR | R-Type thermocouple. Positive condutor: Platinum - 13% rhodium; Negtive conductor: Platinum. Defiend by IEC 60584-1 2013.
TypeS | S-Type thermocouple. Positive condutor: Platinum - 10% rhodium; Negtive conductor: Platinum. Defiend by IEC 60584-1 2013.
TypeB | B-Type thermocouple. Positive condutor: Platinum - 30% rhodium; Negtive conductor: Platinum - 6% rhodium. Defiend by IEC 60584-1 2013.
TypeJ | J-Type thermocouple. Positive condutor: Iron; Negtive conductor: Copper - nickel. Defiend by IEC 60584-1 2013.
TypeT | T-Type thermocouple. Positive condutor: Copper; Negtive conductor: Copper - nickel. Defiend by IEC 60584-1 2013.
TypeE | E-Type thermocouple. Positive condutor: Nickel - chromium; Negtive conductor: Copper - nickel. Defiend by IEC 60584-1 2013.
TypeK | K-Type thermocouple. Positive condutor: Nickel - chromium; Negtive conductor: Nickel - aluminium. Defiend by IEC 60584-1 2013.
TypeN | N-Type thermocouple. Positive condutor: Nickel - chromium - silicon; Negtive conductor: Nickel - silicon. Defiend by IEC 60584-1 2013.
TypeC | C-Type thermocouple. Positive condutor: Tungsten - 5% rhenium; Negtive conductor: Tungsten - 26% rhenium. Defiend by IEC 60584-1 2013.
TypeA | A-Type thermocouple. Positive condutor: Tungsten - 5% rhenium; Negtive conductor: Tungsten - 20% rhenium. Defiend by IEC 60584-1 2013.
TypeG | G-Type thermocouple. Positive condutor: Tungsten - 3% rhenium; Negtive conductor: Tungsten - 26% rhenium. Defiend by ASTM E230.
TypeD | D-Type thermocouple. Positive condutor: Tungsten - 3% rhenium; Negtive conductor: Tungsten - 25% rhenium. Defiend by GB/T 29822-2013.

Function Documentation

◆ GetSignalExportDestinationString()

std::string JY6312CoreOO::GetSignalExportDestinationString ( SignalExportDestination destination )
inline


6312 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/6312/JY6312CoreOOCommon.h File Reference

  • File List
  • File Members
  • COO
  • 6312
Classes | Namespaces | Macros | Enumerations | Functions
JY6312CoreOOCommon.h File Reference
#include <string>
#include <stdint.h>

Classes

class | JY6312CoreOO::JYDriverException
class | JY6312CoreOO::JY6312CoreOOProperty< ContainerClass, ValueType, propertyType >
属性模板类 More...

Namespaces

namespace JY6312CoreOO

Macros

#define | EXTERN_C extern
Windows.
#define | JY6312CoreOO_API

Enumerations

enum class | JY6312CoreOO::JY6312CoreOOPropertyType { JY6312CoreOO::READ_ONLY = 1 , JY6312CoreOO::WRITE_ONLY = 2 , JY6312CoreOO::READ_WRITE = 3 }
enum class JY6312CoreOO::JYDriverExceptionPublic {
JY6312CoreOO::UnKnown = 0 , JY6312CoreOO::OpenDeviceFailed = -10001 , JY6312CoreOO::CloseDeviceFailed = -10002 , JY6312CoreOO::ResetDeviceFailed = -10003 ,
JY6312CoreOO::GetDevicePropertyFailed = -10004 , JY6312CoreOO::SetDevicePropertyFailed = -10005 , JY6312CoreOO::HardwareResourceIsReserved = -10006 , JY6312CoreOO::MethodNotPermitedToCallWhenCurrentStatus = -10007 ,
JY6312CoreOO::InvalidUserDataBuffer = -10008 , JY6312CoreOO::NoChannelAdded = -10009 , JY6312CoreOO::NotSupportOperationForCurrentDevice = -10010 , JY6312CoreOO::CreatTaskFailed = -10100 ,
JY6312CoreOO::StartTaskFailed = -10101 , JY6312CoreOO::StopTaskFailed = -10102 , JY6312CoreOO::TaskHasNotStarted = -10103 , JY6312CoreOO::TaskHasStartedCannotPerformTheSetOperation = -10104 ,
JY6312CoreOO::ChannelNumberParameterInvalid = -10105 , JY6312CoreOO::ChannelInputRangeParameterInvalid = -10106 , JY6312CoreOO::ChannelTerminalParameterInvalid = -10107 , JY6312CoreOO::ChannelCouplingParameterInvalid = -10108 ,
JY6312CoreOO::SampeleModeParameterInvalid = -10109 , JY6312CoreOO::SampleClockParameterInvalid = -10110 , JY6312CoreOO::SampleRateParameterInvalid = -10111 , JY6312CoreOO::UpdateRateParameterInvalid = -10112 ,
JY6312CoreOO::TriggerParameterInvalid = -10113 , JY6312CoreOO::ReferenceTriggerDoesNotMatchWithSampleMode = -10114 , JY6312CoreOO::PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint = -10115 , JY6312CoreOO::ReadDataFailed = -10016 ,
JY6312CoreOO::ReadDataTimeout = -10017 , JY6312CoreOO::WriteDataFailed = -10018 , JY6312CoreOO::WriteDataTimeout = -10019 , JY6312CoreOO::WriteDataLengthCannotBeLessThanN = -10020 ,
JY6312CoreOO::BufferDataOverflow = -10021 , JY6312CoreOO::BufferDataDownflow = -10022 , JY6312CoreOO::CheckBufferFailed = -10023 , JY6312CoreOO::PointInvalidInFiniteMode = -10024 ,
JY6312CoreOO::ReadPointInvalid = -10025 , JY6312CoreOO::OnlySupportRecordMode = -10026 , JY6312CoreOO::SendSoftTirggerFailed = -10027 , JY6312CoreOO::TaskTimeout = -10028 ,
JY6312CoreOO::CounterParametersInvalid = -10029 , JY6312CoreOO::WritePointInvalid = -10030 , JY6312CoreOO::SignalExportDestinationInvalid = -10031 , JY6312CoreOO::InvalidParameter = -10033
}
enum class JY6312CoreOO::ClockTerminal {
JY6312CoreOO::PFI0 = 0 , JY6312CoreOO::PFI1 = 1 , JY6312CoreOO::PXI_Trig0 = 4 , JY6312CoreOO::PXI_Trig1 = 5 ,
JY6312CoreOO::PXI_Trig2 = 6 , JY6312CoreOO::PXI_Trig3 = 7 , JY6312CoreOO::PXI_Trig4 = 8 , JY6312CoreOO::PXI_Trig5 = 9 ,
JY6312CoreOO::PXI_Trig6 = 10 , JY6312CoreOO::PXI_Trig7 = 11 , JY6312CoreOO::PXI_Star = 12
}
enum class JY6312CoreOO::SignalExportDestination {
JY6312CoreOO::PXI_Trig0 = 4 , JY6312CoreOO::PXI_Trig1 , JY6312CoreOO::PXI_Trig2 , JY6312CoreOO::PXI_Trig3 ,
JY6312CoreOO::PXI_Trig4 , JY6312CoreOO::PXI_Trig5 , JY6312CoreOO::PXI_Trig6 , JY6312CoreOO::PXI_Trig7 ,
JY6312CoreOO::PXI_Star
}
enum class | JY6312CoreOO::OutputCompleteState { JY6312CoreOO::Zero , JY6312CoreOO::Hold }
Output Complete State. More...
enum class JY6312CoreOO::IOTerminal {
JY6312CoreOO::PFI0 = 0 , JY6312CoreOO::PFI1 = 1 , JY6312CoreOO::PXI_Trig0 = 4 , JY6312CoreOO::PXI_Trig1 = 5 ,
JY6312CoreOO::PXI_Trig2 = 6 , JY6312CoreOO::PXI_Trig3 = 7 , JY6312CoreOO::PXI_Trig4 = 8 , JY6312CoreOO::PXI_Trig5 = 9 ,
JY6312CoreOO::PXI_Trig6 = 10 , JY6312CoreOO::PXI_Trig7 = 11 , JY6312CoreOO::PXI_Star = 12
}
Cunter IO Terminal. More...

Functions

std::string JY6312CoreOO::GetSignalExportDestinationString (SignalExportDestination destination)

Macro Definition Documentation

◆ EXTERN_C

#define EXTERN_C extern

Windows.

Linux

◆ JY6312CoreOO_API

#define JY6312CoreOO_API


6312 C++ Programming Manual: JY6312CoreOO::JYDriverException Class Reference

  • JYDriverException
Public Member Functions | Public Attributes | List of all members
JY6312CoreOO::JYDriverException Class Reference

#include <JY6312CoreOOCommon.h>

Public Member Functions

JYDriverException (JYDriverExceptionPublic exceptionCode, std::string msg="")
JYDriverException (int, std::string msg)

Public Attributes

std::string exceptionMessage
JYDriverExceptionPublic errorCode
JYDriverException * FollowingException

Constructor & Destructor Documentation

◆ JYDriverException() [1/2]

JY6312CoreOO::JYDriverException::JYDriverException | ( | JYDriverExceptionPublic | exceptionCode,
 |  | std::string | msg = "" )

◆ JYDriverException() [2/2]

JY6312CoreOO::JYDriverException::JYDriverException | ( | int | ,
 |  | std::string | msg )

Member Data Documentation

◆ errorCode

JYDriverExceptionPublic JY6312CoreOO::JYDriverException::errorCode

◆ exceptionMessage

std::string JY6312CoreOO::JYDriverException::exceptionMessage

◆ FollowingException

JYDriverException* JY6312CoreOO::JYDriverException::FollowingException
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6312/JY6312CoreOOCommon.h


6312 C++ Programming Manual: JY6312CoreOO::JY6312CoreOOProperty< ContainerClass, ValueType, propertyType > Class Template Reference

  • JY6312CoreOOProperty
Public Member Functions | List of all members
JY6312CoreOO::JY6312CoreOOProperty< ContainerClass, ValueType, propertyType > Class Template Reference

属性模板类 More...

#include <JY6312CoreOOCommon.h>

Public Member Functions

JY6312CoreOOProperty ()
JY6312CoreOOProperty (ContainerClass *cObject, ValueType(ContainerClass::*pGet)(), void(ContainerClass::*pSet)(ValueType value))
JY6312CoreOOProperty (ValueType(*pGet)(), void(*pSet)(ValueType value))
ValueType operator= (const ValueType &value)
operator ValueType ()

Detailed Description

template<typename ContainerClass, typename ValueType, JY6312CoreOOPropertyType propertyType>
class JY6312CoreOO::JY6312CoreOOProperty< ContainerClass, ValueType, propertyType >

属性模板类

Constructor & Destructor Documentation

◆ JY6312CoreOOProperty() [1/3]

template<typename ContainerClass, typename ValueType, JY6312CoreOOPropertyType propertyType>
JY6312CoreOO::JY6312CoreOOProperty< ContainerClass, ValueType, propertyType >::JY6312CoreOOProperty ( )

◆ JY6312CoreOOProperty() [2/3]

template<typename ContainerClass, typename ValueType, JY6312CoreOOPropertyType propertyType>
JY6312CoreOO::JY6312CoreOOProperty< ContainerClass, ValueType, propertyType >::JY6312CoreOOProperty | ( | ContainerClass * | cObject,
 |  | ValueType(ContainerClass::* | pGet )(),
 |  | void(ContainerClass::* | pSet )(ValueType value) )

◆ JY6312CoreOOProperty() [3/3]

template<typename ContainerClass, typename ValueType, JY6312CoreOOPropertyType propertyType>
JY6312CoreOO::JY6312CoreOOProperty< ContainerClass, ValueType, propertyType >::JY6312CoreOOProperty | ( | ValueType(* | pGet )(),
 |  | void(* | pSet )(ValueType value) )

Member Function Documentation

◆ operator ValueType()

template<typename ContainerClass, typename ValueType, JY6312CoreOOPropertyType propertyType>
JY6312CoreOO::JY6312CoreOOProperty< ContainerClass, ValueType, propertyType >::operator ValueType ( )

◆ operator=()

template<typename ContainerClass, typename ValueType, JY6312CoreOOPropertyType propertyType>
ValueType JY6312CoreOO::JY6312CoreOOProperty< ContainerClass, ValueType, propertyType >::operator= ( const ValueType & value )
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6312/JY6312CoreOOCommon.h


6312 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/6312/JY6312CoreOODevice.h File Reference

  • File List
  • File Members
  • COO
  • 6312
Classes | Namespaces | Enumerations
JY6312CoreOODevice.h File Reference
#include <iostream>
#include <string>
#include <list>
#include <vector>
#include "JY6312CoreOOCommon.h"

Classes

class | JY6312CoreOO::JY6312CoreOODevice
class | JY6312CoreOO::ExternalReferenceClock
class | JY6312CoreOO::JY6312CoreOOReferenceClock

Namespaces

namespace JY6312CoreOO

Enumerations

enum class | JY6312CoreOO::ExternalReferenceClockTerminal { JY6312CoreOO::PXIe_Clk100 = 0x1 }
enum class | JY6312CoreOO::ReferenceClockSource { JY6312CoreOO::Internal = 0x0 , JY6312CoreOO::External = 0x1 }


6312 C++ Programming Manual: JY6312CoreOO::JY6312CoreOODevice Class Reference

  • JY6312CoreOODevice
Static Public Member Functions | Public Attributes | List of all members
JY6312CoreOO::JY6312CoreOODevice Class Reference

#include <JY6312CoreOODevice.h>

Static Public Member Functions

static JY6312CoreOODevice * | GetInstance (int cardNum)
static JY6312CoreOODevice * | GetInstance (std::string aliasName)

Public Attributes

const double | BoardClockRate = 10e7
const int | BufferSize = 0x100000 * 512
Onboard memory size in bytes.
const double | MaxSampleRate = 160
Maximum sampling rate of JY6312.
const double | MinSampleRate = 0.25
Minimum sampling rate of 6312.
const int | MaxSamplesToAcquireSingleChannel = 64000000
Maximum samples to acquire when there's only 1 channel has been added.
const int | MinSamplesToAcquire = 1
Minimum samples to acquire.
const double | MaxVoltage = 2.5
Maximum input voltage in V.
const int | TotalNumberOfChannels = 16
Total number of channels.
JY6312CoreOOProperty< JY6312CoreOODevice, int, JY6312CoreOOPropertyType::READ_ONLY > | DiffChannelCount
JY6312CoreOOProperty< JY6312CoreOODevice, int, JY6312CoreOOPropertyType::READ_ONLY > | SEChannelCount
JY6312CoreOOProperty< JY6312CoreOODevice, double, JY6312CoreOOPropertyType::READ_ONLY > | MaxSampleRateSingleChannel
JY6312CoreOOProperty< JY6312CoreOODevice, int, JY6312CoreOOPropertyType::READ_ONLY > | AOChannelCount
JY6312CoreOOProperty< JY6312CoreOODevice, std::string, JY6312CoreOOPropertyType::READ_ONLY > | SerialNumber
JY6312CoreOOProperty< JY6312CoreOODevice, int, JY6312CoreOOPropertyType::READ_ONLY > | DeviceID
JY6312CoreOOProperty< JY6312CoreOODevice, void *, JY6312CoreOOPropertyType::READ_ONLY > | Handle
JY6312CoreOOReferenceClock * ReferenceClock

Member Function Documentation

◆ GetInstance() [1/2]

static JY6312CoreOODevice * JY6312CoreOO::JY6312CoreOODevice::GetInstance ( int cardNum )
static

◆ GetInstance() [2/2]

static JY6312CoreOODevice * JY6312CoreOO::JY6312CoreOODevice::GetInstance ( std::string aliasName )
static

Member Data Documentation

◆ AOChannelCount

JY6312CoreOOProperty<JY6312CoreOODevice, int, JY6312CoreOOPropertyType::READ_ONLY> JY6312CoreOO::JY6312CoreOODevice::AOChannelCount

◆ BoardClockRate

const double JY6312CoreOO::JY6312CoreOODevice::BoardClockRate = 10e7

◆ BufferSize

const int JY6312CoreOO::JY6312CoreOODevice::BufferSize = 0x100000 * 512

Onboard memory size in bytes.

◆ DeviceID

JY6312CoreOOProperty<JY6312CoreOODevice, int, JY6312CoreOOPropertyType::READ_ONLY> JY6312CoreOO::JY6312CoreOODevice::DeviceID

◆ DiffChannelCount

JY6312CoreOOProperty<JY6312CoreOODevice, int, JY6312CoreOOPropertyType::READ_ONLY> JY6312CoreOO::JY6312CoreOODevice::DiffChannelCount

◆ Handle

JY6312CoreOOProperty<JY6312CoreOODevice, void*, JY6312CoreOOPropertyType::READ_ONLY> JY6312CoreOO::JY6312CoreOODevice::Handle

◆ MaxSampleRate

const double JY6312CoreOO::JY6312CoreOODevice::MaxSampleRate = 160

Maximum sampling rate of JY6312.

◆ MaxSampleRateSingleChannel

JY6312CoreOOProperty<JY6312CoreOODevice, double, JY6312CoreOOPropertyType::READ_ONLY> JY6312CoreOO::JY6312CoreOODevice::MaxSampleRateSingleChannel

◆ MaxSamplesToAcquireSingleChannel

const int JY6312CoreOO::JY6312CoreOODevice::MaxSamplesToAcquireSingleChannel = 64000000

Maximum samples to acquire when there's only 1 channel has been added.

◆ MaxVoltage

const double JY6312CoreOO::JY6312CoreOODevice::MaxVoltage = 2.5

Maximum input voltage in V.

◆ MinSampleRate

const double JY6312CoreOO::JY6312CoreOODevice::MinSampleRate = 0.25

Minimum sampling rate of 6312.

◆ MinSamplesToAcquire

const int JY6312CoreOO::JY6312CoreOODevice::MinSamplesToAcquire = 1

Minimum samples to acquire.

◆ ReferenceClock

JY6312CoreOOReferenceClock* JY6312CoreOO::JY6312CoreOODevice::ReferenceClock

◆ SEChannelCount

JY6312CoreOOProperty<JY6312CoreOODevice, int, JY6312CoreOOPropertyType::READ_ONLY> JY6312CoreOO::JY6312CoreOODevice::SEChannelCount

◆ SerialNumber

JY6312CoreOOProperty<JY6312CoreOODevice, std::string, JY6312CoreOOPropertyType::READ_ONLY> JY6312CoreOO::JY6312CoreOODevice::SerialNumber

◆ TotalNumberOfChannels

const int JY6312CoreOO::JY6312CoreOODevice::TotalNumberOfChannels = 16

Total number of channels.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6312/JY6312CoreOODevice.h


6312 C++ Programming Manual: JY6312CoreOO::ExternalReferenceClock Class Reference

  • ExternalReferenceClock
Public Attributes | List of all members
JY6312CoreOO::ExternalReferenceClock Class Reference

#include <JY6312CoreOODevice.h>

Public Attributes

ExternalReferenceClockTerminal Terminal

Member Data Documentation

◆ Terminal

ExternalReferenceClockTerminal JY6312CoreOO::ExternalReferenceClock::Terminal
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6312/JY6312CoreOODevice.h


6312 C++ Programming Manual: JY6312CoreOO::JY6312CoreOOReferenceClock Class Reference

  • JY6312CoreOOReferenceClock
Public Member Functions | Public Attributes | List of all members
JY6312CoreOO::JY6312CoreOOReferenceClock Class Reference

#include <JY6312CoreOODevice.h>

Public Member Functions

void Commit ()
Commit configuration.

Public Attributes

ReferenceClockSource Source
ExternalReferenceClock * External
External Reference Clock Source.

Member Function Documentation

◆ Commit()

void JY6312CoreOO::JY6312CoreOOReferenceClock::Commit ( )

Commit configuration.

Available only when the device is idle. WARNING: Incorrect parameters will cause the PLL to be unable to lock the reference clock and cannot be recovered until shutdown and restart.

Member Data Documentation

◆ External

ExternalReferenceClock* JY6312CoreOO::JY6312CoreOOReferenceClock::External

External Reference Clock Source.

Required when ReferenceClock.Source is ReferenceClockSource.External

◆ Source

ReferenceClockSource JY6312CoreOO::JY6312CoreOOReferenceClock::Source
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6312/JY6312CoreOODevice.h


6312 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/6312/JY6312CoreOOLog.h File Reference

  • File List
  • File Members
  • COO
  • 6312
Classes | Namespaces | Enumerations
JY6312CoreOOLog.h File Reference
#include <queue>
#include <string>
#include <thread>
#include "JY6312CoreOOCommon.h"

Classes

class JY6312CoreOO::JY6312CoreOOLog

Namespaces

namespace JY6312CoreOO

Enumerations

enum class JY6312CoreOO::JY6312CoreOOLogLevel {
JY6312CoreOO::DEBUG_LOG_LEVEL , JY6312CoreOO::INFO_LOG_LEVEL , JY6312CoreOO::WARN_LOG_LEVEL , JY6312CoreOO::ERROR_LOG_LEVEL ,
JY6312CoreOO::FATAL_LOG_LEVEL
}


6312 C++ Programming Manual: JY6312CoreOO::JY6312CoreOOLog Class Reference

  • JY6312CoreOOLog
Static Public Member Functions | Static Public Attributes | List of all members
JY6312CoreOO::JY6312CoreOOLog Class Reference

#include <JY6312CoreOOLog.h>

Static Public Member Functions

static void | Print (const char *format,...)
static void | Print (JY6312CoreOOLogLevel logLevel, const char *format,...)
static void | Flush ()

Static Public Attributes

static JY6312CoreOOLogLevel | LogLevel
static JY6312CoreOOProperty< JY6312CoreOOLog, bool, JY6312CoreOOPropertyType::READ_WRITE > | EnableLog

Member Function Documentation

◆ Flush()

static void JY6312CoreOO::JY6312CoreOOLog::Flush ( )
static

◆ Print() [1/2]

static void JY6312CoreOO::JY6312CoreOOLog::Print | ( | const char * | format,
 |  |  | ... )
 static

◆ Print() [2/2]

static void JY6312CoreOO::JY6312CoreOOLog::Print | ( | JY6312CoreOOLogLevel | logLevel,
 |  | const char * | format,
 |  |  | ... )
 static

Member Data Documentation

◆ EnableLog

JY6312CoreOOProperty<JY6312CoreOOLog, bool, JY6312CoreOOPropertyType::READ_WRITE> JY6312CoreOO::JY6312CoreOOLog::EnableLog
static

◆ LogLevel

JY6312CoreOOLogLevel JY6312CoreOO::JY6312CoreOOLog::LogLevel
static
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6312/JY6312CoreOOLog.h


6312 C++ Programming Manual: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
▼N JY6312CoreOO |
C AIAdvanced |
C AIChannel |
C AIChannelAdvanced |
C AIDigitalTrigger |
C AIExternalSampleClock |
C AISampleClock |
C AISignalExport |
C AITrigger |
C BuildInCJC |
C CJCAdvanced |
C CJDataDebouncing |
C ExternalReferenceClock |
C JY6312CoreOOAITask | AITask类
C JY6312CoreOODevice |
C JY6312CoreOOLog |
C JY6312CoreOOProperty | 属性模板类
C JY6312CoreOOReferenceClock |
C JYDriverException |
C PowerLineRejection |
C TC_Type |
C JY6312CoreOOAIMode | AIMode


6312 C++ Programming Manual: Member List

  • AIAdvanced
JY6312CoreOO::AIAdvanced Member List

This is the complete list of members for JY6312CoreOO::AIAdvanced, including all inherited members.

ConvertRate JY6312CoreOO::AIAdvanced


6312 C++ Programming Manual: Member List

  • AIChannel
JY6312CoreOO::AIChannel Member List

This is the complete list of members for JY6312CoreOO::AIChannel, including all inherited members.

_AIChannelAdvanced | JY6312CoreOO::AIChannel
_MeasurementType | JY6312CoreOO::AIChannel
_ThermocoupleType | JY6312CoreOO::AIChannel
CustomCJTemperature | JY6312CoreOO::AIChannel
Gain | JY6312CoreOO::AIChannel
ID | JY6312CoreOO::AIChannel
Range | JY6312CoreOO::AIChannel
RangeHigh | JY6312CoreOO::AIChannel
RangeLow | JY6312CoreOO::AIChannel


6312 C++ Programming Manual: Member List

  • AIChannelAdvanced
JY6312CoreOO::AIChannelAdvanced Member List

This is the complete list of members for JY6312CoreOO::AIChannelAdvanced, including all inherited members.

InputBufferEnabled | JY6312CoreOO::AIChannelAdvanced
Range | JY6312CoreOO::AIChannelAdvanced
VbiasEnabled | JY6312CoreOO::AIChannelAdvanced


6312 C++ Programming Manual: Member List

  • AIDigitalTrigger
JY6312CoreOO::AIDigitalTrigger Member List

This is the complete list of members for JY6312CoreOO::AIDigitalTrigger, including all inherited members.

Edge | JY6312CoreOO::AIDigitalTrigger
Source | JY6312CoreOO::AIDigitalTrigger


6312 C++ Programming Manual: Member List

  • AIExternalSampleClock
JY6312CoreOO::AIExternalSampleClock Member List

This is the complete list of members for JY6312CoreOO::AIExternalSampleClock, including all inherited members.

ExpectedRate | JY6312CoreOO::AIExternalSampleClock
Terminal | JY6312CoreOO::AIExternalSampleClock


6312 C++ Programming Manual: Member List

  • AISampleClock
JY6312CoreOO::AISampleClock Member List

This is the complete list of members for JY6312CoreOO::AISampleClock, including all inherited members.

External | JY6312CoreOO::AISampleClock
Source | JY6312CoreOO::AISampleClock


6312 C++ Programming Manual: Member List

  • AISignalExport
JY6312CoreOO::AISignalExport Member List

This is the complete list of members for JY6312CoreOO::AISignalExport, including all inherited members.

Add(AISignalExportSource source, SignalExportDestination destination) | JY6312CoreOO::AISignalExport
Add(AISignalExportSource source, std::list< SignalExportDestination > destinations) | JY6312CoreOO::AISignalExport
Clear(SignalExportDestination destination) | JY6312CoreOO::AISignalExport
ClearAll() | JY6312CoreOO::AISignalExport


6312 C++ Programming Manual: Member List

  • AITrigger
JY6312CoreOO::AITrigger Member List

This is the complete list of members for JY6312CoreOO::AITrigger, including all inherited members.

Analog | JY6312CoreOO::AITrigger
Digital | JY6312CoreOO::AITrigger
Mode | JY6312CoreOO::AITrigger
PreTriggerSamples | JY6312CoreOO::AITrigger
ReTriggerCount | JY6312CoreOO::AITrigger
Type | JY6312CoreOO::AITrigger


6312 C++ Programming Manual: Member List

  • BuildInCJC
JY6312CoreOO::BuildInCJC Member List

This is the complete list of members for JY6312CoreOO::BuildInCJC, including all inherited members.

Advanced | JY6312CoreOO::BuildInCJC
Commit() | JY6312CoreOO::BuildInCJC
Debouncing | JY6312CoreOO::BuildInCJC
Enabled | JY6312CoreOO::BuildInCJC
OpenSensorComminucation() | JY6312CoreOO::BuildInCJC
ReportBuildInCJException(bool running, bool measureTC) | JY6312CoreOO::BuildInCJC
SensorStatus | JY6312CoreOO::BuildInCJC


6312 C++ Programming Manual: Member List

  • CJCAdvanced
JY6312CoreOO::CJCAdvanced Member List

This is the complete list of members for JY6312CoreOO::CJCAdvanced, including all inherited members.

IgnoreTimeoutException | JY6312CoreOO::CJCAdvanced
UpdateInterval | JY6312CoreOO::CJCAdvanced
UpdateTimeout | JY6312CoreOO::CJCAdvanced


6312 C++ Programming Manual: Member List

  • CJDataDebouncing
JY6312CoreOO::CJDataDebouncing Member List

This is the complete list of members for JY6312CoreOO::CJDataDebouncing, including all inherited members.

Commit() | JY6312CoreOO::CJDataDebouncing
Enabled | JY6312CoreOO::CJDataDebouncing
MaxBounce | JY6312CoreOO::CJDataDebouncing
ValidBounce | JY6312CoreOO::CJDataDebouncing


6312 C++ Programming Manual: Member List

  • ExternalReferenceClock
JY6312CoreOO::ExternalReferenceClock Member List

This is the complete list of members for JY6312CoreOO::ExternalReferenceClock, including all inherited members.

Terminal JY6312CoreOO::ExternalReferenceClock


6312 C++ Programming Manual: Member List

  • JY6312CoreOOAITask
JY6312CoreOO::JY6312CoreOOAITask Member List

This is the complete list of members for JY6312CoreOO::JY6312CoreOOAITask, including all inherited members.

_allChannelVoltageInput | JY6312CoreOO::JY6312CoreOOAITask |
_buildInCJC | JY6312CoreOO::JY6312CoreOOAITask |
_pwrLineRej | JY6312CoreOO::JY6312CoreOOAITask |
AddChannel(int chID, ThermocoupleType thermocoupleType) | JY6312CoreOO::JY6312CoreOOAITask |
AddChannel(std::vector< int > chIDs, ThermocoupleType thermocoupleType) | JY6312CoreOO::JY6312CoreOOAITask |
AddChannel(std::vector< int > chIDs, std::vector< ThermocoupleType > thermocoupleType) | JY6312CoreOO::JY6312CoreOOAITask |
AddChannel(int chID, double voltageRangeLow, double voltageRangeHigh) | JY6312CoreOO::JY6312CoreOOAITask |
AddChannel(std::vector< int > chIDs, double voltageRangeLow, double voltageRangeHigh) | JY6312CoreOO::JY6312CoreOOAITask |
AddChannel(std::vector< int > chIDs, std::vector< double > voltageRangeLow, std::vector< double > voltageRangeHigh) | JY6312CoreOO::JY6312CoreOOAITask |
ApplyUserCJTemperature() | JY6312CoreOO::JY6312CoreOOAITask |
AvailableSamples | JY6312CoreOO::JY6312CoreOOAITask |
BufLenInSamples | JY6312CoreOO::JY6312CoreOOAITask |
Channels | JY6312CoreOO::JY6312CoreOOAITask |
DetectOpenThermocouple() | JY6312CoreOO::JY6312CoreOOAITask |
Device | JY6312CoreOO::JY6312CoreOOAITask |
DisableCalibration | JY6312CoreOO::JY6312CoreOOAITask |
GetAbsVmax(ThermocoupleType type) | JY6312CoreOO::JY6312CoreOOAITask |
GetTmin(ThermocoupleType type) | JY6312CoreOO::JY6312CoreOOAITask |
GetVmax(ThermocoupleType type) | JY6312CoreOO::JY6312CoreOOAITask |
InitTC_Type() | JY6312CoreOO::JY6312CoreOOAITask |
JY6312CoreOOAITask(int slotNum) | JY6312CoreOO::JY6312CoreOOAITask |
JY6312CoreOOAITask(std::string boardName) | JY6312CoreOO::JY6312CoreOOAITask |
MatchTheRange(double absVoltageMax) | JY6312CoreOO::JY6312CoreOOAITask |
Mode | JY6312CoreOO::JY6312CoreOOAITask |
ReadData(double *pBuf, int samplesPerChannel, int timeout=-1) | JY6312CoreOO::JY6312CoreOOAITask |
ReadRawData(double *hjVoltageDataBuffer, double *cjTemperatureDataBuffer, int samplesPerChannel, int timeout=-1) | JY6312CoreOO::JY6312CoreOOAITask |
ReadRawSinglePoint(double *hjVoltageData, double *cjTemperatureData, int channel) | JY6312CoreOO::JY6312CoreOOAITask |
ReadSinglePoint(double *readValue, int channel) | JY6312CoreOO::JY6312CoreOOAITask |
RemoveChannel(int chID) | JY6312CoreOO::JY6312CoreOOAITask |
SampleClock | JY6312CoreOO::JY6312CoreOOAITask |
SampleRate | JY6312CoreOO::JY6312CoreOOAITask |
SamplesToAcquire | JY6312CoreOO::JY6312CoreOOAITask |
SendSoftwareTrigger() | JY6312CoreOO::JY6312CoreOOAITask |
SetCJTemperature(int chID, double temperature) | JY6312CoreOO::JY6312CoreOOAITask |
SetCJTemperature(double temperature) | JY6312CoreOO::JY6312CoreOOAITask |
SignalExport | JY6312CoreOO::JY6312CoreOOAITask |
Start() | JY6312CoreOO::JY6312CoreOOAITask |
Stop() | JY6312CoreOO::JY6312CoreOOAITask |
TC_TypeA | JY6312CoreOO::JY6312CoreOOAITask |
TC_TypeB | JY6312CoreOO::JY6312CoreOOAITask |
TC_TypeC | JY6312CoreOO::JY6312CoreOOAITask |
TC_TypeD | JY6312CoreOO::JY6312CoreOOAITask |
TC_TypeE | JY6312CoreOO::JY6312CoreOOAITask |
TC_TypeG | JY6312CoreOO::JY6312CoreOOAITask |
TC_TypeJ | JY6312CoreOO::JY6312CoreOOAITask |
TC_TypeK | JY6312CoreOO::JY6312CoreOOAITask |
TC_TypeN | JY6312CoreOO::JY6312CoreOOAITask |
TC_TypeR | JY6312CoreOO::JY6312CoreOOAITask |
TC_TypeS | JY6312CoreOO::JY6312CoreOOAITask |
TC_TypeT | JY6312CoreOO::JY6312CoreOOAITask |
TransferedSamples | JY6312CoreOO::JY6312CoreOOAITask |
Trigger | JY6312CoreOO::JY6312CoreOOAITask |
WaitUntilDone(int timeout=-1) | JY6312CoreOO::JY6312CoreOOAITask | inline
~JY6312CoreOOAITask() | JY6312CoreOO::JY6312CoreOOAITask |


6312 C++ Programming Manual: Member List

  • JY6312CoreOODevice
JY6312CoreOO::JY6312CoreOODevice Member List

This is the complete list of members for JY6312CoreOO::JY6312CoreOODevice, including all inherited members.

AOChannelCount | JY6312CoreOO::JY6312CoreOODevice |
BoardClockRate | JY6312CoreOO::JY6312CoreOODevice |
BufferSize | JY6312CoreOO::JY6312CoreOODevice |
DeviceID | JY6312CoreOO::JY6312CoreOODevice |
DiffChannelCount | JY6312CoreOO::JY6312CoreOODevice |
GetInstance(int cardNum) | JY6312CoreOO::JY6312CoreOODevice | static
GetInstance(std::string aliasName) | JY6312CoreOO::JY6312CoreOODevice | static
Handle | JY6312CoreOO::JY6312CoreOODevice |
MaxSampleRate | JY6312CoreOO::JY6312CoreOODevice |
MaxSampleRateSingleChannel | JY6312CoreOO::JY6312CoreOODevice |
MaxSamplesToAcquireSingleChannel | JY6312CoreOO::JY6312CoreOODevice |
MaxVoltage | JY6312CoreOO::JY6312CoreOODevice |
MinSampleRate | JY6312CoreOO::JY6312CoreOODevice |
MinSamplesToAcquire | JY6312CoreOO::JY6312CoreOODevice |
ReferenceClock | JY6312CoreOO::JY6312CoreOODevice |
SEChannelCount | JY6312CoreOO::JY6312CoreOODevice |
SerialNumber | JY6312CoreOO::JY6312CoreOODevice |
TotalNumberOfChannels | JY6312CoreOO::JY6312CoreOODevice |


6312 C++ Programming Manual: Member List

  • JY6312CoreOOLog
JY6312CoreOO::JY6312CoreOOLog Member List

This is the complete list of members for JY6312CoreOO::JY6312CoreOOLog, including all inherited members.

EnableLog | JY6312CoreOO::JY6312CoreOOLog | static
Flush() | JY6312CoreOO::JY6312CoreOOLog | static
LogLevel | JY6312CoreOO::JY6312CoreOOLog | static
Print(const char *format,...) | JY6312CoreOO::JY6312CoreOOLog | static
Print(JY6312CoreOOLogLevel logLevel, const char *format,...) | JY6312CoreOO::JY6312CoreOOLog | static


6312 C++ Programming Manual: Member List

  • JY6312CoreOOProperty
JY6312CoreOO::JY6312CoreOOProperty< ContainerClass, ValueType, propertyType > Member List

This is the complete list of members for JY6312CoreOO::JY6312CoreOOProperty< ContainerClass, ValueType, propertyType >, including all inherited members.

JY6312CoreOOProperty() | JY6312CoreOO::JY6312CoreOOProperty< ContainerClass, ValueType, propertyType >
JY6312CoreOOProperty(ContainerClass *cObject, ValueType(ContainerClass::*pGet)(), void(ContainerClass::*pSet)(ValueType value)) | JY6312CoreOO::JY6312CoreOOProperty< ContainerClass, ValueType, propertyType >
JY6312CoreOOProperty(ValueType(*pGet)(), void(*pSet)(ValueType value)) | JY6312CoreOO::JY6312CoreOOProperty< ContainerClass, ValueType, propertyType >
operator ValueType() | JY6312CoreOO::JY6312CoreOOProperty< ContainerClass, ValueType, propertyType >
operator=(const ValueType &value) | JY6312CoreOO::JY6312CoreOOProperty< ContainerClass, ValueType, propertyType >


6312 C++ Programming Manual: Member List

  • JY6312CoreOOReferenceClock
JY6312CoreOO::JY6312CoreOOReferenceClock Member List

This is the complete list of members for JY6312CoreOO::JY6312CoreOOReferenceClock, including all inherited members.

Commit() | JY6312CoreOO::JY6312CoreOOReferenceClock
External | JY6312CoreOO::JY6312CoreOOReferenceClock
Source | JY6312CoreOO::JY6312CoreOOReferenceClock


6312 C++ Programming Manual: Member List

  • JYDriverException
JY6312CoreOO::JYDriverException Member List

This is the complete list of members for JY6312CoreOO::JYDriverException, including all inherited members.

errorCode | JY6312CoreOO::JYDriverException
exceptionMessage | JY6312CoreOO::JYDriverException
FollowingException | JY6312CoreOO::JYDriverException
JYDriverException(JYDriverExceptionPublic exceptionCode, std::string msg="") | JY6312CoreOO::JYDriverException
JYDriverException(int, std::string msg) | JY6312CoreOO::JYDriverException


6312 C++ Programming Manual: Member List

  • PowerLineRejection
JY6312CoreOO::PowerLineRejection Member List

This is the complete list of members for JY6312CoreOO::PowerLineRejection, including all inherited members.

Frequency | JY6312CoreOO::PowerLineRejection
RejectAt50Hz | JY6312CoreOO::PowerLineRejection
RejectAt60Hz | JY6312CoreOO::PowerLineRejection


6312 C++ Programming Manual: Member List

  • TC_Type
JY6312CoreOO::TC_Type Member List

This is the complete list of members for JY6312CoreOO::TC_Type, including all inherited members.

Tmax | JY6312CoreOO::TC_Type
Tmin | JY6312CoreOO::TC_Type
Vmax | JY6312CoreOO::TC_Type
Vmin | JY6312CoreOO::TC_Type


6312 C++ Programming Manual: JY6312CoreOOAIMode Class Reference

JY6312CoreOOAIMode Class Reference

AIMode. More...

#include <JY6312CoreOOAITask.h>

Detailed Description

AIMode.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6312/JY6312CoreOOAITask.h


6312 C++ Programming Manual: Class Index

Class Index
A | B | C | E | J | P | T
A
AIAdvanced (JY6312CoreOO)
AIChannel (JY6312CoreOO)
AIChannelAdvanced (JY6312CoreOO)
AIDigitalTrigger (JY6312CoreOO)
AIExternalSampleClock (JY6312CoreOO)
AISampleClock (JY6312CoreOO)
AISignalExport (JY6312CoreOO)
AITrigger (JY6312CoreOO)
B
BuildInCJC (JY6312CoreOO)
C
CJCAdvanced (JY6312CoreOO)
CJDataDebouncing (JY6312CoreOO)
E
ExternalReferenceClock (JY6312CoreOO)
J
JY6312CoreOOAIMode
JY6312CoreOOAITask (JY6312CoreOO)
JY6312CoreOODevice (JY6312CoreOO)
JY6312CoreOOLog (JY6312CoreOO)
JY6312CoreOOProperty (JY6312CoreOO)
JY6312CoreOOReferenceClock (JY6312CoreOO)
JYDriverException (JY6312CoreOO)
P
PowerLineRejection (JY6312CoreOO)
T
TC_Type (JY6312CoreOO)


6312 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO Directory Reference

  • File List
  • File Members
  • COO
COO Directory Reference

Directories

6312


6312 C++ Programming Manual: File List

  • File List
  • File Members
File List
Here is a list of all files with brief descriptions:
[detail level 123]
▼ COO
▼ 6312
JY6312CoreOOAITask.h
JY6312CoreOOCommon.h
JY6312CoreOODevice.h
JY6312CoreOOLog.h


6312 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- _ -

  • _AIChannelAdvanced : JY6312CoreOO::AIChannel
  • _allChannelVoltageInput : JY6312CoreOO::JY6312CoreOOAITask
  • _buildInCJC : JY6312CoreOO::JY6312CoreOOAITask
  • _MeasurementType : JY6312CoreOO::AIChannel
  • _pwrLineRej : JY6312CoreOO::JY6312CoreOOAITask
  • _ThermocoupleType : JY6312CoreOO::AIChannel

- a -

  • Add() : JY6312CoreOO::AISignalExport
  • AddChannel() : JY6312CoreOO::JY6312CoreOOAITask
  • Advanced : JY6312CoreOO::BuildInCJC
  • Analog : JY6312CoreOO::AITrigger
  • AOChannelCount : JY6312CoreOO::JY6312CoreOODevice
  • ApplyUserCJTemperature() : JY6312CoreOO::JY6312CoreOOAITask
  • AvailableSamples : JY6312CoreOO::JY6312CoreOOAITask

- b -

  • BoardClockRate : JY6312CoreOO::JY6312CoreOODevice
  • BufferSize : JY6312CoreOO::JY6312CoreOODevice
  • BufLenInSamples : JY6312CoreOO::JY6312CoreOOAITask

- c -

  • Channels : JY6312CoreOO::JY6312CoreOOAITask
  • Clear() : JY6312CoreOO::AISignalExport
  • ClearAll() : JY6312CoreOO::AISignalExport
  • Commit() : JY6312CoreOO::BuildInCJC, JY6312CoreOO::CJDataDebouncing, JY6312CoreOO::JY6312CoreOOReferenceClock
  • ConvertRate : JY6312CoreOO::AIAdvanced
  • CustomCJTemperature : JY6312CoreOO::AIChannel

- d -

  • Debouncing : JY6312CoreOO::BuildInCJC
  • DetectOpenThermocouple() : JY6312CoreOO::JY6312CoreOOAITask
  • Device : JY6312CoreOO::JY6312CoreOOAITask
  • DeviceID : JY6312CoreOO::JY6312CoreOODevice
  • DiffChannelCount : JY6312CoreOO::JY6312CoreOODevice
  • Digital : JY6312CoreOO::AITrigger
  • DisableCalibration : JY6312CoreOO::JY6312CoreOOAITask

- e -

  • Edge : JY6312CoreOO::AIDigitalTrigger
  • Enabled : JY6312CoreOO::BuildInCJC, JY6312CoreOO::CJDataDebouncing
  • EnableLog : JY6312CoreOO::JY6312CoreOOLog
  • errorCode : JY6312CoreOO::JYDriverException
  • exceptionMessage : JY6312CoreOO::JYDriverException
  • ExpectedRate : JY6312CoreOO::AIExternalSampleClock
  • External : JY6312CoreOO::AISampleClock, JY6312CoreOO::JY6312CoreOOReferenceClock

- f -

  • Flush() : JY6312CoreOO::JY6312CoreOOLog
  • FollowingException : JY6312CoreOO::JYDriverException
  • Frequency : JY6312CoreOO::PowerLineRejection

- g -

  • Gain : JY6312CoreOO::AIChannel
  • GetAbsVmax() : JY6312CoreOO::JY6312CoreOOAITask
  • GetInstance() : JY6312CoreOO::JY6312CoreOODevice
  • GetTmin() : JY6312CoreOO::JY6312CoreOOAITask
  • GetVmax() : JY6312CoreOO::JY6312CoreOOAITask

- h -

  • Handle : JY6312CoreOO::JY6312CoreOODevice

- i -

  • ID : JY6312CoreOO::AIChannel
  • IgnoreTimeoutException : JY6312CoreOO::CJCAdvanced
  • InitTC_Type() : JY6312CoreOO::JY6312CoreOOAITask
  • InputBufferEnabled : JY6312CoreOO::AIChannelAdvanced

- j -

  • JY6312CoreOOAITask() : JY6312CoreOO::JY6312CoreOOAITask
  • JY6312CoreOOProperty() : JY6312CoreOO::JY6312CoreOOProperty< ContainerClass, ValueType, propertyType >
  • JYDriverException() : JY6312CoreOO::JYDriverException

- l -

  • LogLevel : JY6312CoreOO::JY6312CoreOOLog

- m -

  • MatchTheRange() : JY6312CoreOO::JY6312CoreOOAITask
  • MaxBounce : JY6312CoreOO::CJDataDebouncing
  • MaxSampleRate : JY6312CoreOO::JY6312CoreOODevice
  • MaxSampleRateSingleChannel : JY6312CoreOO::JY6312CoreOODevice
  • MaxSamplesToAcquireSingleChannel : JY6312CoreOO::JY6312CoreOODevice
  • MaxVoltage : JY6312CoreOO::JY6312CoreOODevice
  • MinSampleRate : JY6312CoreOO::JY6312CoreOODevice
  • MinSamplesToAcquire : JY6312CoreOO::JY6312CoreOODevice
  • Mode : JY6312CoreOO::AITrigger, JY6312CoreOO::JY6312CoreOOAITask

- o -

  • OpenSensorComminucation() : JY6312CoreOO::BuildInCJC
  • operator ValueType() : JY6312CoreOO::JY6312CoreOOProperty< ContainerClass, ValueType, propertyType >
  • operator=() : JY6312CoreOO::JY6312CoreOOProperty< ContainerClass, ValueType, propertyType >

- p -

  • PreTriggerSamples : JY6312CoreOO::AITrigger
  • Print() : JY6312CoreOO::JY6312CoreOOLog

- r -

  • Range : JY6312CoreOO::AIChannel, JY6312CoreOO::AIChannelAdvanced
  • RangeHigh : JY6312CoreOO::AIChannel
  • RangeLow : JY6312CoreOO::AIChannel
  • ReadData() : JY6312CoreOO::JY6312CoreOOAITask
  • ReadRawData() : JY6312CoreOO::JY6312CoreOOAITask
  • ReadRawSinglePoint() : JY6312CoreOO::JY6312CoreOOAITask
  • ReadSinglePoint() : JY6312CoreOO::JY6312CoreOOAITask
  • ReferenceClock : JY6312CoreOO::JY6312CoreOODevice
  • RejectAt50Hz : JY6312CoreOO::PowerLineRejection
  • RejectAt60Hz : JY6312CoreOO::PowerLineRejection
  • RemoveChannel() : JY6312CoreOO::JY6312CoreOOAITask
  • ReportBuildInCJException() : JY6312CoreOO::BuildInCJC
  • ReTriggerCount : JY6312CoreOO::AITrigger

- s -

  • SampleClock : JY6312CoreOO::JY6312CoreOOAITask
  • SampleRate : JY6312CoreOO::JY6312CoreOOAITask
  • SamplesToAcquire : JY6312CoreOO::JY6312CoreOOAITask
  • SEChannelCount : JY6312CoreOO::JY6312CoreOODevice
  • SendSoftwareTrigger() : JY6312CoreOO::JY6312CoreOOAITask
  • SensorStatus : JY6312CoreOO::BuildInCJC
  • SerialNumber : JY6312CoreOO::JY6312CoreOODevice
  • SetCJTemperature() : JY6312CoreOO::JY6312CoreOOAITask
  • SignalExport : JY6312CoreOO::JY6312CoreOOAITask
  • Source : JY6312CoreOO::AIDigitalTrigger, JY6312CoreOO::AISampleClock, JY6312CoreOO::JY6312CoreOOReferenceClock
  • Start() : JY6312CoreOO::JY6312CoreOOAITask
  • Stop() : JY6312CoreOO::JY6312CoreOOAITask

- t -

  • TC_TypeA : JY6312CoreOO::JY6312CoreOOAITask
  • TC_TypeB : JY6312CoreOO::JY6312CoreOOAITask
  • TC_TypeC : JY6312CoreOO::JY6312CoreOOAITask
  • TC_TypeD : JY6312CoreOO::JY6312CoreOOAITask
  • TC_TypeE : JY6312CoreOO::JY6312CoreOOAITask
  • TC_TypeG : JY6312CoreOO::JY6312CoreOOAITask
  • TC_TypeJ : JY6312CoreOO::JY6312CoreOOAITask
  • TC_TypeK : JY6312CoreOO::JY6312CoreOOAITask
  • TC_TypeN : JY6312CoreOO::JY6312CoreOOAITask
  • TC_TypeR : JY6312CoreOO::JY6312CoreOOAITask
  • TC_TypeS : JY6312CoreOO::JY6312CoreOOAITask
  • TC_TypeT : JY6312CoreOO::JY6312CoreOOAITask
  • Terminal : JY6312CoreOO::AIExternalSampleClock, JY6312CoreOO::ExternalReferenceClock
  • Tmax : JY6312CoreOO::TC_Type
  • Tmin : JY6312CoreOO::TC_Type
  • TotalNumberOfChannels : JY6312CoreOO::JY6312CoreOODevice
  • TransferedSamples : JY6312CoreOO::JY6312CoreOOAITask
  • Trigger : JY6312CoreOO::JY6312CoreOOAITask
  • Type : JY6312CoreOO::AITrigger

- u -

  • UpdateInterval : JY6312CoreOO::CJCAdvanced
  • UpdateTimeout : JY6312CoreOO::CJCAdvanced

- v -

  • ValidBounce : JY6312CoreOO::CJDataDebouncing
  • VbiasEnabled : JY6312CoreOO::AIChannelAdvanced
  • Vmax : JY6312CoreOO::TC_Type
  • Vmin : JY6312CoreOO::TC_Type

- w -

  • WaitUntilDone() : JY6312CoreOO::JY6312CoreOOAITask

- ~ -

  • ~JY6312CoreOOAITask() : JY6312CoreOO::JY6312CoreOOAITask


6312 C++ Programming Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • c
  • d
  • f
  • g
  • i
  • j
  • m
  • o
  • p
  • r
  • s
  • w
  • ~
Here is a list of all functions with links to the classes they belong to:

- a -

  • Add() : JY6312CoreOO::AISignalExport
  • AddChannel() : JY6312CoreOO::JY6312CoreOOAITask
  • ApplyUserCJTemperature() : JY6312CoreOO::JY6312CoreOOAITask

- c -

  • Clear() : JY6312CoreOO::AISignalExport
  • ClearAll() : JY6312CoreOO::AISignalExport
  • Commit() : JY6312CoreOO::BuildInCJC, JY6312CoreOO::CJDataDebouncing, JY6312CoreOO::JY6312CoreOOReferenceClock

- d -

  • DetectOpenThermocouple() : JY6312CoreOO::JY6312CoreOOAITask

- f -

  • Flush() : JY6312CoreOO::JY6312CoreOOLog

- g -

  • GetAbsVmax() : JY6312CoreOO::JY6312CoreOOAITask
  • GetInstance() : JY6312CoreOO::JY6312CoreOODevice
  • GetTmin() : JY6312CoreOO::JY6312CoreOOAITask
  • GetVmax() : JY6312CoreOO::JY6312CoreOOAITask

- i -

  • InitTC_Type() : JY6312CoreOO::JY6312CoreOOAITask

- j -

  • JY6312CoreOOAITask() : JY6312CoreOO::JY6312CoreOOAITask
  • JY6312CoreOOProperty() : JY6312CoreOO::JY6312CoreOOProperty< ContainerClass, ValueType, propertyType >
  • JYDriverException() : JY6312CoreOO::JYDriverException

- m -

  • MatchTheRange() : JY6312CoreOO::JY6312CoreOOAITask

- o -

  • OpenSensorComminucation() : JY6312CoreOO::BuildInCJC
  • operator ValueType() : JY6312CoreOO::JY6312CoreOOProperty< ContainerClass, ValueType, propertyType >
  • operator=() : JY6312CoreOO::JY6312CoreOOProperty< ContainerClass, ValueType, propertyType >

- p -

  • Print() : JY6312CoreOO::JY6312CoreOOLog

- r -

  • ReadData() : JY6312CoreOO::JY6312CoreOOAITask
  • ReadRawData() : JY6312CoreOO::JY6312CoreOOAITask
  • ReadRawSinglePoint() : JY6312CoreOO::JY6312CoreOOAITask
  • ReadSinglePoint() : JY6312CoreOO::JY6312CoreOOAITask
  • RemoveChannel() : JY6312CoreOO::JY6312CoreOOAITask
  • ReportBuildInCJException() : JY6312CoreOO::BuildInCJC

- s -

  • SendSoftwareTrigger() : JY6312CoreOO::JY6312CoreOOAITask
  • SetCJTemperature() : JY6312CoreOO::JY6312CoreOOAITask
  • Start() : JY6312CoreOO::JY6312CoreOOAITask
  • Stop() : JY6312CoreOO::JY6312CoreOOAITask

- w -

  • WaitUntilDone() : JY6312CoreOO::JY6312CoreOOAITask

- ~ -

  • ~JY6312CoreOOAITask() : JY6312CoreOO::JY6312CoreOOAITask


6312 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • u
  • v
Here is a list of all variables with links to the classes they belong to:

- _ -

  • _AIChannelAdvanced : JY6312CoreOO::AIChannel
  • _allChannelVoltageInput : JY6312CoreOO::JY6312CoreOOAITask
  • _buildInCJC : JY6312CoreOO::JY6312CoreOOAITask
  • _MeasurementType : JY6312CoreOO::AIChannel
  • _pwrLineRej : JY6312CoreOO::JY6312CoreOOAITask
  • _ThermocoupleType : JY6312CoreOO::AIChannel

- a -

  • Advanced : JY6312CoreOO::BuildInCJC
  • Analog : JY6312CoreOO::AITrigger
  • AOChannelCount : JY6312CoreOO::JY6312CoreOODevice
  • AvailableSamples : JY6312CoreOO::JY6312CoreOOAITask

- b -

  • BoardClockRate : JY6312CoreOO::JY6312CoreOODevice
  • BufferSize : JY6312CoreOO::JY6312CoreOODevice
  • BufLenInSamples : JY6312CoreOO::JY6312CoreOOAITask

- c -

  • Channels : JY6312CoreOO::JY6312CoreOOAITask
  • ConvertRate : JY6312CoreOO::AIAdvanced
  • CustomCJTemperature : JY6312CoreOO::AIChannel

- d -

  • Debouncing : JY6312CoreOO::BuildInCJC
  • Device : JY6312CoreOO::JY6312CoreOOAITask
  • DeviceID : JY6312CoreOO::JY6312CoreOODevice
  • DiffChannelCount : JY6312CoreOO::JY6312CoreOODevice
  • Digital : JY6312CoreOO::AITrigger
  • DisableCalibration : JY6312CoreOO::JY6312CoreOOAITask

- e -

  • Edge : JY6312CoreOO::AIDigitalTrigger
  • Enabled : JY6312CoreOO::BuildInCJC, JY6312CoreOO::CJDataDebouncing
  • EnableLog : JY6312CoreOO::JY6312CoreOOLog
  • errorCode : JY6312CoreOO::JYDriverException
  • exceptionMessage : JY6312CoreOO::JYDriverException
  • ExpectedRate : JY6312CoreOO::AIExternalSampleClock
  • External : JY6312CoreOO::AISampleClock, JY6312CoreOO::JY6312CoreOOReferenceClock

- f -

  • FollowingException : JY6312CoreOO::JYDriverException
  • Frequency : JY6312CoreOO::PowerLineRejection

- g -

  • Gain : JY6312CoreOO::AIChannel

- h -

  • Handle : JY6312CoreOO::JY6312CoreOODevice

- i -

  • ID : JY6312CoreOO::AIChannel
  • IgnoreTimeoutException : JY6312CoreOO::CJCAdvanced
  • InputBufferEnabled : JY6312CoreOO::AIChannelAdvanced

- l -

  • LogLevel : JY6312CoreOO::JY6312CoreOOLog

- m -

  • MaxBounce : JY6312CoreOO::CJDataDebouncing
  • MaxSampleRate : JY6312CoreOO::JY6312CoreOODevice
  • MaxSampleRateSingleChannel : JY6312CoreOO::JY6312CoreOODevice
  • MaxSamplesToAcquireSingleChannel : JY6312CoreOO::JY6312CoreOODevice
  • MaxVoltage : JY6312CoreOO::JY6312CoreOODevice
  • MinSampleRate : JY6312CoreOO::JY6312CoreOODevice
  • MinSamplesToAcquire : JY6312CoreOO::JY6312CoreOODevice
  • Mode : JY6312CoreOO::AITrigger, JY6312CoreOO::JY6312CoreOOAITask

- p -

  • PreTriggerSamples : JY6312CoreOO::AITrigger

- r -

  • Range : JY6312CoreOO::AIChannel, JY6312CoreOO::AIChannelAdvanced
  • RangeHigh : JY6312CoreOO::AIChannel
  • RangeLow : JY6312CoreOO::AIChannel
  • ReferenceClock : JY6312CoreOO::JY6312CoreOODevice
  • RejectAt50Hz : JY6312CoreOO::PowerLineRejection
  • RejectAt60Hz : JY6312CoreOO::PowerLineRejection
  • ReTriggerCount : JY6312CoreOO::AITrigger

- s -

  • SampleClock : JY6312CoreOO::JY6312CoreOOAITask
  • SampleRate : JY6312CoreOO::JY6312CoreOOAITask
  • SamplesToAcquire : JY6312CoreOO::JY6312CoreOOAITask
  • SEChannelCount : JY6312CoreOO::JY6312CoreOODevice
  • SensorStatus : JY6312CoreOO::BuildInCJC
  • SerialNumber : JY6312CoreOO::JY6312CoreOODevice
  • SignalExport : JY6312CoreOO::JY6312CoreOOAITask
  • Source : JY6312CoreOO::AIDigitalTrigger, JY6312CoreOO::AISampleClock, JY6312CoreOO::JY6312CoreOOReferenceClock

- t -

  • TC_TypeA : JY6312CoreOO::JY6312CoreOOAITask
  • TC_TypeB : JY6312CoreOO::JY6312CoreOOAITask
  • TC_TypeC : JY6312CoreOO::JY6312CoreOOAITask
  • TC_TypeD : JY6312CoreOO::JY6312CoreOOAITask
  • TC_TypeE : JY6312CoreOO::JY6312CoreOOAITask
  • TC_TypeG : JY6312CoreOO::JY6312CoreOOAITask
  • TC_TypeJ : JY6312CoreOO::JY6312CoreOOAITask
  • TC_TypeK : JY6312CoreOO::JY6312CoreOOAITask
  • TC_TypeN : JY6312CoreOO::JY6312CoreOOAITask
  • TC_TypeR : JY6312CoreOO::JY6312CoreOOAITask
  • TC_TypeS : JY6312CoreOO::JY6312CoreOOAITask
  • TC_TypeT : JY6312CoreOO::JY6312CoreOOAITask
  • Terminal : JY6312CoreOO::AIExternalSampleClock, JY6312CoreOO::ExternalReferenceClock
  • Tmax : JY6312CoreOO::TC_Type
  • Tmin : JY6312CoreOO::TC_Type
  • TotalNumberOfChannels : JY6312CoreOO::JY6312CoreOODevice
  • TransferedSamples : JY6312CoreOO::JY6312CoreOOAITask
  • Trigger : JY6312CoreOO::JY6312CoreOOAITask
  • Type : JY6312CoreOO::AITrigger

- u -

  • UpdateInterval : JY6312CoreOO::CJCAdvanced
  • UpdateTimeout : JY6312CoreOO::CJCAdvanced

- v -

  • ValidBounce : JY6312CoreOO::CJDataDebouncing
  • VbiasEnabled : JY6312CoreOO::AIChannelAdvanced
  • Vmax : JY6312CoreOO::TC_Type
  • Vmin : JY6312CoreOO::TC_Type


6312 C++ Programming Manual: File Members

  • File List
  • File Members
  • All
  • Macros
Here is a list of all file members with links to the files they belong to:
  • EXTERN_C : JY6312CoreOOCommon.h
  • JY6312CoreOO_API : JY6312CoreOOCommon.h


6312 C++ Programming Manual: File Members

  • File List
  • File Members
  • All
  • Macros
Here is a list of all macros with links to the files they belong to:
  • EXTERN_C : JY6312CoreOOCommon.h
  • JY6312CoreOO_API : JY6312CoreOOCommon.h


6312 C++ Programming Manual: Main Page

6312 C++ Programming Manual Documentation


6312 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
  • _
  • a
  • c
  • e
  • g
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
Here is a list of all namespace members with links to the namespace documentation for each member:

- _ -

  • _156p2mV : JY6312CoreOO
  • _1p25V : JY6312CoreOO
  • _312p5mV : JY6312CoreOO
  • _625mV : JY6312CoreOO
  • _78p125mV : JY6312CoreOO
  • _Normal : JY6312CoreOO
  • _OpenCircuit : JY6312CoreOO
  • _ShortCircuit : JY6312CoreOO

- a -

  • AIAnalogTriggerEdge : JY6312CoreOO
  • AIDigitalTriggerEdge : JY6312CoreOO
  • AIDigitalTriggerSource : JY6312CoreOO
  • AIMode : JY6312CoreOO
  • AIRange : JY6312CoreOO
  • AISampleClockSource : JY6312CoreOO
  • AISignalExportSource : JY6312CoreOO
  • AITriggerMode : JY6312CoreOO
  • AITriggerType : JY6312CoreOO

- c -

  • CJSensorConnectionStatus : JY6312CoreOO
  • ClockTerminal : JY6312CoreOO
  • Closed : JY6312CoreOO

- e -

  • ExternalReferenceClockTerminal : JY6312CoreOO

- g -

  • GeneralVoltage : JY6312CoreOO
  • GetSignalExportDestinationString() : JY6312CoreOO

- i -

  • IOTerminal : JY6312CoreOO

- j -

  • JY6312CoreOOLogLevel : JY6312CoreOO
  • JY6312CoreOOPropertyType : JY6312CoreOO
  • JYDriverExceptionPublic : JY6312CoreOO

- l -

  • LostConnect : JY6312CoreOO

- m -

  • MeasurementType : JY6312CoreOO

- n -

  • Normal : JY6312CoreOO

- o -

  • OutputCompleteState : JY6312CoreOO

- p -

  • PowerLineFrequency : JY6312CoreOO

- r -

  • ReferenceClockSource : JY6312CoreOO

- s -

  • SignalExportDestination : JY6312CoreOO

- t -

  • Thermocouple : JY6312CoreOO
  • ThermocoupleConnectionStatus : JY6312CoreOO
  • ThermocoupleType : JY6312CoreOO
  • TypeA : JY6312CoreOO
  • TypeB : JY6312CoreOO
  • TypeC : JY6312CoreOO
  • TypeD : JY6312CoreOO
  • TypeE : JY6312CoreOO
  • TypeG : JY6312CoreOO
  • TypeJ : JY6312CoreOO
  • TypeK : JY6312CoreOO
  • TypeN : JY6312CoreOO
  • TypeR : JY6312CoreOO
  • TypeS : JY6312CoreOO
  • TypeT : JY6312CoreOO


6312 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
Here is a list of all namespace enums with links to the namespace documentation for each enum:
  • AIAnalogTriggerEdge : JY6312CoreOO
  • AIDigitalTriggerEdge : JY6312CoreOO
  • AIDigitalTriggerSource : JY6312CoreOO
  • AIMode : JY6312CoreOO
  • AIRange : JY6312CoreOO
  • AISampleClockSource : JY6312CoreOO
  • AISignalExportSource : JY6312CoreOO
  • AITriggerMode : JY6312CoreOO
  • AITriggerType : JY6312CoreOO
  • CJSensorConnectionStatus : JY6312CoreOO
  • ClockTerminal : JY6312CoreOO
  • ExternalReferenceClockTerminal : JY6312CoreOO
  • IOTerminal : JY6312CoreOO
  • JY6312CoreOOLogLevel : JY6312CoreOO
  • JY6312CoreOOPropertyType : JY6312CoreOO
  • JYDriverExceptionPublic : JY6312CoreOO
  • MeasurementType : JY6312CoreOO
  • OutputCompleteState : JY6312CoreOO
  • PowerLineFrequency : JY6312CoreOO
  • ReferenceClockSource : JY6312CoreOO
  • SignalExportDestination : JY6312CoreOO
  • ThermocoupleConnectionStatus : JY6312CoreOO
  • ThermocoupleType : JY6312CoreOO


6312 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
Here is a list of all namespace enum values with links to the namespace documentation for each enum value:
  • _156p2mV : JY6312CoreOO
  • _1p25V : JY6312CoreOO
  • _312p5mV : JY6312CoreOO
  • _625mV : JY6312CoreOO
  • _78p125mV : JY6312CoreOO
  • _Normal : JY6312CoreOO
  • _OpenCircuit : JY6312CoreOO
  • _ShortCircuit : JY6312CoreOO
  • Closed : JY6312CoreOO
  • GeneralVoltage : JY6312CoreOO
  • LostConnect : JY6312CoreOO
  • Normal : JY6312CoreOO
  • Thermocouple : JY6312CoreOO
  • TypeA : JY6312CoreOO
  • TypeB : JY6312CoreOO
  • TypeC : JY6312CoreOO
  • TypeD : JY6312CoreOO
  • TypeE : JY6312CoreOO
  • TypeG : JY6312CoreOO
  • TypeJ : JY6312CoreOO
  • TypeK : JY6312CoreOO
  • TypeN : JY6312CoreOO
  • TypeR : JY6312CoreOO
  • TypeS : JY6312CoreOO
  • TypeT : JY6312CoreOO


6312 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • Enumerator
Here is a list of all namespace functions with links to the namespace documentation for each function:
  • GetSignalExportDestinationString() : JY6312CoreOO


6312 C++ Programming Manual: Namespace List

  • Namespace List
  • Namespace Members
Namespace List
Here is a list of all namespaces with brief descriptions:
N JY6312CoreOO