6312 C# Programming Manual: D:/6312/C#/AIAdvanced.cs File Reference

6312 C# Programming Manual
  • Main Page
  • Packages
  • Classes
  • Files
  • File List
  • 6312
  • C#
Classes | Namespaces
AIAdvanced.cs File Reference

Classes

class JY6312.AIAdvanced
Analog Input Advance Parameter Class. More...

Namespaces

namespace JY6312
Generated by doxygen 1.12.0


6312 C# Programming Manual: D:/6312/C#/AIChannel.cs File Reference

  • Packages
  • Classes
  • Files
  • File List
  • 6312
  • C#
Classes | Namespaces | Enumerations
AIChannel.cs File Reference

Classes

class | JY6312.AIChannel
AI channel class. More...
class | JY6312.AIChannelAdvanced
Analog Input Advance Parameter Class. More...

Namespaces

namespace JY6312

Enumerations

enum JY6312.AIRange {
JY6312._1p25V = 1 , JY6312._625mV = 2 , JY6312._312p5mV = 3 , JY6312._156p2mV = 4 ,
JY6312._78p125mV = 5
}
AI voltage range. More...
enum JY6312.MeasurementType { JY6312.Thermocouple = 0 , JY6312.GeneralVoltage = 1 }
Measurement Type Enum. More...


6312 C# Programming Manual: D:/6312/C#/AIClock.cs File Reference

  • File List
  • 6312
  • C#
Classes | Namespaces | Enumerations
AIClock.cs File Reference

Classes

class | JY6312.AISampleClock
Sample clock configuration class. More...
class | JY6312.AIExternalSampleClock
External Sample Clock Configuration Class. More...

Namespaces

namespace JY6312

Enumerations

enum JY6312.AISampleClockSource { JY6312.Internal = JY6312Import.JY6312_InternalSampleClock , JY6312.External = JY6312Import.JY6312_ExternalSampleClock }
AI Sample Clock Source. More...
enum JY6312.ClockTerminal {
JY6312.PFI0 = JY6312Import.JY6312_DigitalTriggerSource_PFI_0 , JY6312.PFI1 = JY6312Import.JY6312_DigitalTriggerSource_PFI_1 , JY6312.PXI_Trig0 = JY6312Import.JY6312_DigitalTriggerSource_BUS_0 , JY6312.PXI_Trig1 = JY6312Import.JY6312_DigitalTriggerSource_BUS_1 ,
JY6312.PXI_Trig2 = JY6312Import.JY6312_DigitalTriggerSource_BUS_2 , JY6312.PXI_Trig3 = JY6312Import.JY6312_DigitalTriggerSource_BUS_3 , JY6312.PXI_Trig4 = JY6312Import.JY6312_DigitalTriggerSource_BUS_4 , JY6312.PXI_Trig5 = JY6312Import.JY6312_DigitalTriggerSource_BUS_5 ,
JY6312.PXI_Trig6 = JY6312Import.JY6312_DigitalTriggerSource_BUS_6 , JY6312.PXI_Trig7 = JY6312Import.JY6312_DigitalTriggerSource_BUS_7 , JY6312.PXI_Star = JY6312Import.JY6312_DigitalTriggerSource_STAR
}
Clock Terminal. More...


6312 C# Programming Manual: D:/6312/C#/AISignalExport.cs File Reference

  • File List
  • 6312
  • C#
Classes | Namespaces
AISignalExport.cs File Reference

Classes

class JY6312.AISignalExport
AI Signal Export Class. More...

Namespaces

namespace JY6312


6312 C# Programming Manual: D:/6312/C#/AITrigger.cs File Reference

  • File List
  • 6312
  • C#
Classes | Namespaces | Enumerations
AITrigger.cs File Reference

Classes

class | JY6312.AIDigitalTrigger
AI Digital trigger params. More...
class | JY6312.AITrigger
AI Trigger params. More...

Namespaces

namespace JY6312

Enumerations

enum | JY6312.AITriggerMode { JY6312.Start , JY6312.Reference }
AI trigger mode enum type. More...
enum JY6312.AIDigitalTriggerSource {
JY6312.PFI0 = JY6312Import.JY6312_DigitalTriggerSource_PFI_0 , JY6312.PFI1 = JY6312Import.JY6312_DigitalTriggerSource_PFI_1 , JY6312.PXI_Trig0 = JY6312Import.JY6312_DigitalTriggerSource_BUS_0 , JY6312.PXI_Trig1 = JY6312Import.JY6312_DigitalTriggerSource_BUS_1 ,
JY6312.PXI_Trig2 = JY6312Import.JY6312_DigitalTriggerSource_BUS_2 , JY6312.PXI_Trig3 = JY6312Import.JY6312_DigitalTriggerSource_BUS_3 , JY6312.PXI_Trig4 = JY6312Import.JY6312_DigitalTriggerSource_BUS_4 , JY6312.PXI_Trig5 = JY6312Import.JY6312_DigitalTriggerSource_BUS_5 ,
JY6312.PXI_Trig6 = JY6312Import.JY6312_DigitalTriggerSource_BUS_6 , JY6312.PXI_Trig7 = JY6312Import.JY6312_DigitalTriggerSource_BUS_7 , JY6312.PXI_Star = JY6312Import.JY6312_DigitalTriggerSource_STAR
}
AI digital trigger source enum type. More...
enum | JY6312.AITriggerType { JY6312.Immediately = JY6312Import.JY6312_TriggerType_Immediately , JY6312.Digital = JY6312Import.JY6312_TriggerType_Digital , JY6312.Software = JY6312Import.JY6312_TriggerType_Software }
AI trigger type enum type. More...
enum | JY6312.AIDigitalTriggerEdge { JY6312.Rising = JY6312Import.JY6312_DigitalTriggerEdge_Rising , JY6312.Falling = JY6312Import.JY6312_DigitalTriggerEdge_Falling }
AI digital trigger edge enum type. More...


6312 C# Programming Manual: D:/6312/C#/JY6312AITask.cs File Reference

  • File List
  • 6312
  • C#
Classes | Namespaces | Enumerations
JY6312AITask.cs File Reference

Classes

class JY6312.JY6312AITask
JY6312 AI task class. More...

Namespaces

namespace JY6312

Enumerations

enum | JY6312.AIMode { JY6312.Finite = JY6312Import.JY6312_AI_Finite , JY6312.Continuous = JY6312Import.JY6312_AI_Continuous , JY6312.Single = JY6312Import.JY6312_AI_Single }
AI mode enum type. More...
enum | JY6312.ThermocoupleConnectionStatus { JY6312.Normal = JY6312Import.JY6312_TCConState_Normal , JY6312.OpenCircuit = JY6312Import.JY6312_TCConState_OpenCircuit , JY6312.ShortCircuit = JY6312Import.JY6312_TCConState_ShortCircuit }
Thermocouple connection status. More...


6312 C# Programming Manual: Class List

  • Class List
  • Class Index
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
▼N JY6312 |
C AIAdvanced | Analog Input Advance Parameter Class
C AIChannel | AI channel class
C AIChannelAdvanced | Analog Input Advance Parameter Class
C AIDigitalTrigger | AI Digital trigger params
C AIExternalSampleClock | External Sample Clock Configuration Class
C AISampleClock | Sample clock configuration class
C AISignalExport | AI Signal Export Class
C AITrigger | AI Trigger params
C JY6312AITask | JY6312 AI task class


6312 C# Programming Manual: JY6312.AIAdvanced Class Reference

  • JY6312
  • AIAdvanced
List of all members
JY6312.AIAdvanced Class Referencesealed

Analog Input Advance Parameter Class. More...

Detailed Description

Analog Input Advance Parameter Class.

The documentation for this class was generated from the following file:
  • D:/6312/C#/AIAdvanced.cs


6312 C# Programming Manual: Member List

  • JY6312
  • AIAdvanced
JY6312.AIAdvanced Member List

This is the complete list of members for JY6312.AIAdvanced, including all inherited members.


6312 C# Programming Manual: JY6312.AIChannel Class Reference

  • JY6312
  • AIChannel
Properties | List of all members
JY6312.AIChannel Class Referencesealed

AI channel class. More...

Properties

int | ID [get]
Channel ID.
ThermocoupleType | ThermocoupleType [get]
Thermocouple type.
double | CustomCJTemperature [get, set]
Custom cold junction (reference junction) temperature (℃) for compensation.
AIRange | Range [get]
Voltage input range.
double | Gain [get]
Input gain.
double | RangeHigh [get]
Upper limit of voltage input range in V.
double | RangeLow [get]
Lower limit of voltage input range in V.
MeasurementType | MeasurementType [get]
Measurement type of this channel.
AIChannelAdvanced | Advanced [get]
Advanced configuration.

Detailed Description

AI channel class.

Property Documentation

◆ Advanced

AIChannelAdvanced JY6312.AIChannel.Advanced
get

Advanced configuration.

If you are not sure what these parameters does, do not change these value.

◆ CustomCJTemperature

double JY6312.AIChannel.CustomCJTemperature
getset

Custom cold junction (reference junction) temperature (℃) for compensation.

This parameter is only valid when buld-in cold-junction compensation disabled and then take effect every time the ReadData method is called.

◆ Gain

double JY6312.AIChannel.Gain
get

Input gain.

◆ ID

int JY6312.AIChannel.ID
get

Channel ID.

◆ MeasurementType

MeasurementType JY6312.AIChannel.MeasurementType
get

Measurement type of this channel.

◆ Range

AIRange JY6312.AIChannel.Range
get

Voltage input range.

◆ RangeHigh

double JY6312.AIChannel.RangeHigh
get

Upper limit of voltage input range in V.

◆ RangeLow

double JY6312.AIChannel.RangeLow
get

Lower limit of voltage input range in V.

◆ ThermocoupleType

ThermocoupleType JY6312.AIChannel.ThermocoupleType
get

Thermocouple type.

The documentation for this class was generated from the following file:
  • D:/6312/C#/AIChannel.cs


6312 C# Programming Manual: Member List

  • JY6312
  • AIChannel
JY6312.AIChannel Member List

This is the complete list of members for JY6312.AIChannel, including all inherited members.

Advanced | JY6312.AIChannel
CustomCJTemperature | JY6312.AIChannel
Gain | JY6312.AIChannel
ID | JY6312.AIChannel
MeasurementType | JY6312.AIChannel
Range | JY6312.AIChannel
RangeHigh | JY6312.AIChannel
RangeLow | JY6312.AIChannel
ThermocoupleType | JY6312.AIChannel


6312 C# Programming Manual: JY6312.AIChannelAdvanced Class Reference

  • JY6312
  • AIChannelAdvanced
Properties | List of all members
JY6312.AIChannelAdvanced Class Referencesealed

Analog Input Advance Parameter Class. More...

Properties

bool | VbiasEnabled [get, set]
Biases the negative terminal of the selected input channel to AVDD/2.
bool | InputBufferEnabled [get, set]
Operates in buffered mode allowing the user to place source impedances on the front end without contributing gain errors to the system.

Detailed Description

Analog Input Advance Parameter Class.

Property Documentation

◆ InputBufferEnabled

bool JY6312.AIChannelAdvanced.InputBufferEnabled
getset

Operates in buffered mode allowing the user to place source impedances on the front end without contributing gain errors to the system.

The buffer can be disabled when the range is AIRange._1p25V. For lower ranges, the buffer is automatically enabled.

◆ VbiasEnabled

bool JY6312.AIChannelAdvanced.VbiasEnabled
getset

Biases the negative terminal of the selected input channel to AVDD/2.

This is necessary for thermocouple applications.

The documentation for this class was generated from the following file:
  • D:/6312/C#/AIChannel.cs


6312 C# Programming Manual: Member List

  • JY6312
  • AIChannelAdvanced
JY6312.AIChannelAdvanced Member List

This is the complete list of members for JY6312.AIChannelAdvanced, including all inherited members.

InputBufferEnabled | JY6312.AIChannelAdvanced
VbiasEnabled | JY6312.AIChannelAdvanced


6312 C# Programming Manual: JY6312.AIDigitalTrigger Class Reference

  • JY6312
  • AIDigitalTrigger
Properties | List of all members
JY6312.AIDigitalTrigger Class Referencesealed

AI Digital trigger params. More...

Properties

AIDigitalTriggerSource | Source [get, set]
AI digital trigger source.
AIDigitalTriggerEdge | Edge [get, set]
AI digital trigger effective edge.

Detailed Description

AI Digital trigger params.

Property Documentation

◆ Edge

AIDigitalTriggerEdge JY6312.AIDigitalTrigger.Edge
getset

AI digital trigger effective edge.

◆ Source

AIDigitalTriggerSource JY6312.AIDigitalTrigger.Source
getset

AI digital trigger source.

The documentation for this class was generated from the following file:
  • D:/6312/C#/AITrigger.cs


6312 C# Programming Manual: Member List

  • JY6312
  • AIDigitalTrigger
JY6312.AIDigitalTrigger Member List

This is the complete list of members for JY6312.AIDigitalTrigger, including all inherited members.

Edge | JY6312.AIDigitalTrigger
Source | JY6312.AIDigitalTrigger


6312 C# Programming Manual: JY6312.AIExternalSampleClock Class Reference

  • JY6312
  • AIExternalSampleClock
Properties | List of all members
JY6312.AIExternalSampleClock Class Reference

External Sample Clock Configuration Class. More...

Properties

ClockTerminal | Terminal [get, set]
External Sample Clock Input Terminal.
double | ExpectedRate [get, set]
The expected external sampling clock rate, which is used to determine the appropriate AD conversion rate.

Detailed Description

External Sample Clock Configuration Class.

Property Documentation

◆ ExpectedRate

double JY6312.AIExternalSampleClock.ExpectedRate
getset

The expected external sampling clock rate, which is used to determine the appropriate AD conversion rate.

Make sure that the external actual sample clock rate is not larger than the setting value here.

◆ Terminal

ClockTerminal JY6312.AIExternalSampleClock.Terminal
getset

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • D:/6312/C#/AIClock.cs


6312 C# Programming Manual: Member List

  • JY6312
  • AIExternalSampleClock
JY6312.AIExternalSampleClock Member List

This is the complete list of members for JY6312.AIExternalSampleClock, including all inherited members.

ExpectedRate | JY6312.AIExternalSampleClock
Terminal | JY6312.AIExternalSampleClock


6312 C# Programming Manual: JY6312.AISampleClock Class Reference

  • JY6312
  • AISampleClock
Properties | List of all members
JY6312.AISampleClock Class Reference

Sample clock configuration class. More...

Properties

AISampleClockSource | Source [get, set]
AI Sample Clock Source.
AIExternalSampleClock | External [get, set]
External Sample Clock Configuration.

Detailed Description

Sample clock configuration class.

Property Documentation

◆ External

AIExternalSampleClock JY6312.AISampleClock.External
getset

External Sample Clock Configuration.

Valid when Source is AISampleClockSource.External.

◆ Source

AISampleClockSource JY6312.AISampleClock.Source
getset

AI Sample Clock Source.

enum Internal/External. The default value is AISampleClockSource.Internal.

The documentation for this class was generated from the following file:
  • D:/6312/C#/AIClock.cs


6312 C# Programming Manual: Member List

  • JY6312
  • AISampleClock
JY6312.AISampleClock Member List

This is the complete list of members for JY6312.AISampleClock, including all inherited members.

External | JY6312.AISampleClock
Source | JY6312.AISampleClock


6312 C# Programming Manual: JY6312.AISignalExport Class Reference

  • JY6312
  • AISignalExport
Public Member Functions | List of all members
JY6312.AISignalExport Class Reference

AI Signal Export Class. More...

Public Member Functions

void | Add (AISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (AISignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

AI Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY6312.AISignalExport.Add | ( | AISignalExportSource | source,
 |  | List< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | AI Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY6312.AISignalExport.Add | ( | AISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | AI Signal Source
destination | Export Desination

◆ Clear()

void JY6312.AISignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY6312.AISignalExport.ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • D:/6312/C#/AISignalExport.cs


6312 C# Programming Manual: Member List

  • JY6312
  • AISignalExport
JY6312.AISignalExport Member List

This is the complete list of members for JY6312.AISignalExport, including all inherited members.

Add(AISignalExportSource source, SignalExportDestination destination) | JY6312.AISignalExport
Add(AISignalExportSource source, List< SignalExportDestination > destinations) | JY6312.AISignalExport
Clear(SignalExportDestination destination) | JY6312.AISignalExport
ClearAll() | JY6312.AISignalExport


6312 C# Programming Manual: JY6312.AITrigger Class Reference

  • JY6312
  • AITrigger
Properties | List of all members
JY6312.AITrigger Class Referencesealed

AI Trigger params. More...

Properties

AITriggerType | Type [get, set]
AI trigger type.
AITriggerMode | Mode [get, set]
AI trigger mode.
AIDigitalTrigger | Digital [get]
AI digital trigger params.
int | ReTriggerCount [get, set]
The number of retriggers.
uint | PreTriggerSamples [get, set]
AI pretrigger points.

Detailed Description

AI Trigger params.

Property Documentation

◆ Digital

AIDigitalTrigger JY6312.AITrigger.Digital
get

AI digital trigger params.

◆ Mode

AITriggerMode JY6312.AITrigger.Mode
getset

AI trigger mode.

enum Start/Reference.

◆ PreTriggerSamples

uint JY6312.AITrigger.PreTriggerSamples
getset

AI pretrigger points.

Only valid in the reference trigger mode.

◆ ReTriggerCount

int JY6312.AITrigger.ReTriggerCount
getset

The number of retriggers.

When it is 0 or 1, retriggering is disabled, that is, it is triggered only once; When -1, it is an infinite retrigger; When other value, is is the total number of retrigger count.

◆ Type

AITriggerType JY6312.AITrigger.Type
getset

AI trigger type.

enum Analog/Digital/Immediate/Soft.

The documentation for this class was generated from the following file:
  • D:/6312/C#/AITrigger.cs


6312 C# Programming Manual: Member List

  • JY6312
  • AITrigger
JY6312.AITrigger Member List

This is the complete list of members for JY6312.AITrigger, including all inherited members.

Digital | JY6312.AITrigger
Mode | JY6312.AITrigger
PreTriggerSamples | JY6312.AITrigger
ReTriggerCount | JY6312.AITrigger
Type | JY6312.AITrigger


6312 C# Programming Manual: JY6312.JY6312AITask Class Reference

  • JY6312
  • JY6312AITask
Public Member Functions | Properties | List of all members
JY6312.JY6312AITask Class Referencesealed

JY6312 AI task class. More...

Public Member Functions

JY6312AITask (int boardNum)
Constructor.
JY6312AITask (string boardName)
Constructor.
void | AddChannel (int chID, ThermocoupleType thermocoupleType)
Add one/all thermocouple input channel(s) for temperature measurement.
void | AddChannel (int[] chIDs, ThermocoupleType thermocoupleType)
Add a group of thermocouple input channel and set termocouple type uniformly.
void | AddChannel (int[] chIDs, ThermocoupleType[] thermocoupleType)
Add a group of thermocouple input channel and set termocouple type individually.
void | AddChannel (int chID, double voltageRangeLow, double voltageRangeHigh)
Add one/all general voltage input channel(s).
void | AddChannel (int[] chIDs, double voltageRangeLow, double voltageRangeHigh)
Add a group of general voltage input channel and set range uniformly.
void | AddChannel (int[] chIDs, double[] voltageRangeLow, double[] voltageRangeHigh)
Add a group of general voltage input channel and set range uniformly.
void | RemoveChannel (int chID)
Delete the channel with the specified channel ID.
void | RemoveChannel (int[] chIDs)
Delete a group of channels with the specified channel ID.
void | SetCJTemperature (int chID, double temperature)
Set cold junction (reference junction) temperature with a specified channel ID.
void | SetCJTemperature (double[] temperature)
Set cold junction (reference junction) temperature to all channels that has been added.
void | ReportBuildInCJException ()
Query connection status of the cold-junction terminal TB68CJ(s), if the necessary TB68CJ(s) is detected to be offline, an exception will be thrown.
void | ReadSinglePoint (ref double[] dataBuffer)
Single-point readout compensated temperature(℃) or voltage value(V).
void | ReadSinglePoint (IntPtr dataBuffer)
Single-point readout compensated temperature(℃) or voltage value(V).
void | ReadRawSinglePoint (ref double[] hjVoltageData, ref double[] cjTemperatureData)
Single-point readout of hot junction voltage(V) and cold junction temperature(℃) to unmanaged memory pointer.
void | ReadRawSinglePoint (IntPtr hjVoltageData, IntPtr cjTemperatureData)
Single-point readout of hot junction voltage(V) and cold junction temperature(℃) to unmanaged memory pointer.
void | ReadData (ref double[] dataBuffer, int samplesPerChannel, int timeout)
Read one or multi-channel data and store it in a data buffer.
void | ReadData (ref double[] dataBuffer, int timeout=-1)
Read one or multi-channel data and store it in a data buffer.
void | ReadData (ref double[,] dataBuffer, int samplesPerChannel, int timeout)
Read one or multi-channel data to 2-dimensional data buffer array.
void | ReadData (ref double[,] dataBuffer, int timeout=-1)
Read one or multi-channel data to 2-dimensional data buffer array.
void | ReadData (IntPtr dataBuffer, int samplesPerChannel, int timeout)
Read one or multi-channel data and store it in a unmannaged data buffer.
void | ReadRawData (ref double[] hjVoltageData, ref double[] cjTemperatureData, int samplesPerChannel, int timeout)
Read hot-junction voltage(V) and cold-junction temperature(℃) for single or multiple channels to data buffer.
void | ReadRawData (ref double[] hjVoltageData, ref double[] cjTemperatureData, int timeout=-1)
Read hot-junction voltage(V) and cold-junction temperature(℃) for single or multiple channels to data buffer.
void | ReadRawData (ref double[,] hjVoltageData, ref double[,] cjTemperatureData, int samplesPerChannel, int timeout)
Read hot-junction voltage(V) and cold-junction temperature(℃) for single or multiple channels to 2-dimensional data buffer.
void | ReadRawData (ref double[,] hjVoltageData, ref double[,] cjTemperatureData, int timeout)
Read hot-junction voltage(V) and cold-junction temperature(℃) for single or multiple channels to 2-dimensional data buffer.
void | ReadRawData (IntPtr EMFBuf, IntPtr coldJunctionTemperatureBuf, int samplesPerChannel, int timeout)
Read one or multi-channel raw data and store it in unmanaged memory pointer.
void | Start ()
Start AI task.
void | Stop ()
Stop AI task.
Dictionary< int, ThermocoupleConnectionStatus > | DetectOpenThermocouple ()
Perform open thermocouple detection (OTD) to determine if there are any enabled channels do not have a thermocouple connectecd to the module.
void | SendSoftwareTrigger ()
Send a software trigger.

Properties

JY6312Device | Device [get]
The device instance called by this AI task instance.
BuildInCJC | BuildInCJC [get]
Build-In Cold Junction Compensation Configuration.
PowerLineRejection | PowerLineRejection [get]
Power line rejection configuration.
List< AIChannel > | Channels [get]
List of enabled channels.
AIMode | Mode [get, set]
Sample Mode.
AITrigger | Trigger [get]
Trigger Configuration.
AISampleClock | SampleClock [get]
Sample Clock Configuration.
AISignalExport | SignalExport [get]
Signal Export.
double | SampleRate [get, set]
Sampling rate per channel (S/s).
double | ConversionTime [get]
The actual A/D conversion time in ms at the currently set JY6312AITask.SampleRate
int | SamplesToAcquire [get, set]
Number of samples to acquire per channel.
ulong | AvailableSamples [get]
Number of samples per channel that can be read in the buffer.
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel).
bool | DisableCalibration [get, set]
Calibration is disabled when this property is true.

Detailed Description

JY6312 AI task class.

Constructor & Destructor Documentation

◆ JY6312AITask() [1/2]

JY6312.JY6312AITask.JY6312AITask ( int boardNum )

Constructor.

Used to create an AI task object by board number.

Parameters
boardNum The slot number where the board is located, the first board will be opened when 0 is given.

◆ JY6312AITask() [2/2]

JY6312.JY6312AITask.JY6312AITask ( string boardName )

Constructor.

Used to create an AI task object by board name.

Parameters
boardName Board name(device alias), set by device manager

Member Function Documentation

◆ AddChannel() [1/6]

void JY6312.JY6312AITask.AddChannel | ( | int | chID,
 |  | double | voltageRangeLow,
 |  | double | voltageRangeHigh )

Add one/all general voltage input channel(s).

Parameters
chID | IDs of channels to add.
voltageRangeLow | Voltage input range low limit in V. -1.25V / -0.625V / -0.3125V / -0.1562V / -0.078125V / -0.03906V optional.
voltageRangeHigh | Voltage input range high limit in V. +1.25V / +0.625V / +0.3125V / +0.1562V / +0.078125V / +0.03906V optional.

◆ AddChannel() [2/6]

void JY6312.JY6312AITask.AddChannel | ( | int | chID,
 |  | ThermocoupleType | thermocoupleType )

Add one/all thermocouple input channel(s) for temperature measurement.

The input voltage range is automatically determine by the type of thermocouple.

Parameters
chID | Channel's physical number. chID = -1: add all channels.
thermocoupleType | The type of thermocouple connected to this channel.

◆ AddChannel() [3/6]

void JY6312.JY6312AITask.AddChannel | ( | int[] | chIDs,
 |  | double | voltageRangeLow,
 |  | double | voltageRangeHigh )

Add a group of general voltage input channel and set range uniformly.

Parameters
chIDs | IDs of channels to add.
voltageRangeLow | Voltage input range low limit in V. -1.25V / -0.625V / -0.3125V / -0.1562V / -0.078125V / -0.03906V optional.
voltageRangeHigh | Voltage input range high limit in V. +1.25V / +0.625V / +0.3125V / +0.1562V / +0.078125V / +0.03906V optional.

◆ AddChannel() [4/6]

void JY6312.JY6312AITask.AddChannel | ( | int[] | chIDs,
 |  | double[] | voltageRangeLow,
 |  | double[] | voltageRangeHigh )

Add a group of general voltage input channel and set range uniformly.

Parameters
chIDs | IDs of channels to add.
voltageRangeLow | Voltage input range low limit in V. -1.25V / -0.625V / -0.3125V / -0.1562V / -0.078125V / -0.03906V optional.
voltageRangeHigh | Voltage input range high limit in V. +1.25V / +0.625V / +0.3125V / +0.1562V / +0.078125V / +0.03906V optional.

◆ AddChannel() [5/6]

void JY6312.JY6312AITask.AddChannel | ( | int[] | chIDs,
 |  | ThermocoupleType | thermocoupleType )

Add a group of thermocouple input channel and set termocouple type uniformly.

The input voltage range is automatically determine by the type of thermocouple.

Parameters
chIDs | IDs of channels to add.
thermocoupleType | Thermocouple type of channels to add.

◆ AddChannel() [6/6]

void JY6312.JY6312AITask.AddChannel | ( | int[] | chIDs,
 |  | ThermocoupleType[] | thermocoupleType )

Add a group of thermocouple input channel and set termocouple type individually.

The input voltage range is automatically determine by the type of thermocouple.

Parameters
chIDs | IDs of channels to add.
thermocoupleType | Thermocouple type of channels to add.

◆ DetectOpenThermocouple()

Dictionary< int, ThermocoupleConnectionStatus > JY6312.JY6312AITask.DetectOpenThermocouple ( )

Perform open thermocouple detection (OTD) to determine if there are any enabled channels do not have a thermocouple connectecd to the module.

Parameters
currentValue Burnout current value.
Returns
OTD result. Dictionary's key: channel physical ID; value: thermocouple connection status.

◆ ReadData() [1/5]

void JY6312.JY6312AITask.ReadData | ( | IntPtr | dataBuffer,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read one or multi-channel data and store it in a unmannaged data buffer.

The data read is the compensated temperature(℃) or voltage value(V).

Parameters
dataBuffer | Data buffer.
samplesPerChannel | Number of samples per channel.
timeout | Timeout in ms before generate tiemout exception, timeout =-1 keep waiting until finish.

◆ ReadData() [2/5]

void JY6312.JY6312AITask.ReadData | ( | ref double | dataBuffer[,],
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read one or multi-channel data to 2-dimensional data buffer array.

The data read is the compensated temperature(℃) or voltage value(V).

Parameters
dataBuffer | Data buffer.
samplesPerChannel | Number of samples to read per channel.
timeout | Timeout in ms before generate tiemout exception. When equal to -1, it never times out.

◆ ReadData() [3/5]

void JY6312.JY6312AITask.ReadData | ( | ref double | dataBuffer[,],
 |  | int | timeout = -1 )

Read one or multi-channel data to 2-dimensional data buffer array.

The data read is the compensated temperature(℃) or voltage value(V).

Parameters
dataBuffer | Data buffer.
timeout | Timeout in ms before generate tiemout exception. When equal to -1, it never times out.

◆ ReadData() [4/5]

void JY6312.JY6312AITask.ReadData | ( | ref double[] | dataBuffer,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read one or multi-channel data and store it in a data buffer.

The data read is the compensated temperature(℃) or voltage value(V).

Parameters
dataBuffer | Data buffer.
samplesPerChannel | Number of samples to read per channel.
timeout | Timeout in ms before generate tiemout exception. When equal to -1, it never times out.

◆ ReadData() [5/5]

void JY6312.JY6312AITask.ReadData | ( | ref double[] | dataBuffer,
 |  | int | timeout = -1 )

Read one or multi-channel data and store it in a data buffer.

The data read is the compensated temperature(℃) or voltage value(V).

Parameters
dataBuffer | Data buffer.
timeout | Timeout in ms before generate tiemout exception. When equal to -1, it never times out.

◆ ReadRawData() [1/5]

void JY6312.JY6312AITask.ReadRawData | ( | IntPtr | EMFBuf,
 |  | IntPtr | coldJunctionTemperatureBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read one or multi-channel raw data and store it in unmanaged memory pointer.

This method will copy the data of hot-junction voltage(V) and the cold-junction temperature(℃) to user buffer respectively.

Parameters
EMFBuf | User buffer used to read measured electromotive force. Unit: V.
coldJunctionTemperatureBuf | User buffer used to read measured cold(reference) junction temperature. Unit: ℃.
samplesPerChannel | Number of samples per channel
timeout | Timeout in ms before generate tiemout exception, timeout =-1 keep waiting until finish.

◆ ReadRawData() [2/5]

void JY6312.JY6312AITask.ReadRawData | ( | ref double | hjVoltageData[,],
 |  | ref double | cjTemperatureData[,],
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read hot-junction voltage(V) and cold-junction temperature(℃) for single or multiple channels to 2-dimensional data buffer.

Parameters
hjVoltageData | Hot-junction voltage in V
cjTemperatureData | Cold-junction temperature in ℃
samplesPerChannel | Number of samples to read per channel.
timeout | Timeout in ms before generate tiemout exception. When equal to -1, it never times out.

◆ ReadRawData() [3/5]

void JY6312.JY6312AITask.ReadRawData | ( | ref double | hjVoltageData[,],
 |  | ref double | cjTemperatureData[,],
 |  | int | timeout )

Read hot-junction voltage(V) and cold-junction temperature(℃) for single or multiple channels to 2-dimensional data buffer.

Parameters
hjVoltageData | Hot-junction voltage in V
cjTemperatureData | Cold-junction temperature in ℃
timeout | Timeout in ms before generate tiemout exception. When equal to -1, it never times out.

◆ ReadRawData() [4/5]

void JY6312.JY6312AITask.ReadRawData | ( | ref double[] | hjVoltageData,
 |  | ref double[] | cjTemperatureData,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read hot-junction voltage(V) and cold-junction temperature(℃) for single or multiple channels to data buffer.

Parameters
hjVoltageData | Hot-junction voltage in V
cjTemperatureData | Cold-junction temperature in ℃
samplesPerChannel | Number of samples to read per channel.
timeout | Timeout in ms before generate tiemout exception. When equal to -1, it never times out.

◆ ReadRawData() [5/5]

void JY6312.JY6312AITask.ReadRawData | ( | ref double[] | hjVoltageData,
 |  | ref double[] | cjTemperatureData,
 |  | int | timeout = -1 )

Read hot-junction voltage(V) and cold-junction temperature(℃) for single or multiple channels to data buffer.

Parameters
hjVoltageData | Hot-junction voltage in V
cjTemperatureData | Cold-junction temperature in ℃
timeout | Timeout in ms before generate tiemout exception. When equal to -1, it never times out.

◆ ReadRawSinglePoint() [1/2]

void JY6312.JY6312AITask.ReadRawSinglePoint | ( | IntPtr | hjVoltageData,
 |  | IntPtr | cjTemperatureData )

Single-point readout of hot junction voltage(V) and cold junction temperature(℃) to unmanaged memory pointer.

Parameters
hjVoltageData
cjTemperatureData

◆ ReadRawSinglePoint() [2/2]

void JY6312.JY6312AITask.ReadRawSinglePoint | ( | ref double[] | hjVoltageData,
 |  | ref double[] | cjTemperatureData )

Single-point readout of hot junction voltage(V) and cold junction temperature(℃) to unmanaged memory pointer.

Parameters
hjVoltageData
cjTemperatureData

◆ ReadSinglePoint() [1/2]

void JY6312.JY6312AITask.ReadSinglePoint ( IntPtr dataBuffer )

Single-point readout compensated temperature(℃) or voltage value(V).

Parameters
dataBuffer Data buffer.

◆ ReadSinglePoint() [2/2]

void JY6312.JY6312AITask.ReadSinglePoint ( ref double[] dataBuffer )

Single-point readout compensated temperature(℃) or voltage value(V).

Parameters
dataBuffer Data buffer.

◆ RemoveChannel() [1/2]

void JY6312.JY6312AITask.RemoveChannel ( int chID )

Delete the channel with the specified channel ID.

Parameters
chID Specified channel ID. chId = -1: remove all channels.

◆ RemoveChannel() [2/2]

void JY6312.JY6312AITask.RemoveChannel ( int[] chIDs )

Delete a group of channels with the specified channel ID.

Parameters
chIDs IDs of channels to remove.

◆ ReportBuildInCJException()

void JY6312.JY6312AITask.ReportBuildInCJException ( )

Query connection status of the cold-junction terminal TB68CJ(s), if the necessary TB68CJ(s) is detected to be offline, an exception will be thrown.

◆ SendSoftwareTrigger()

void JY6312.JY6312AITask.SendSoftwareTrigger ( )

Send a software trigger.

Returns

◆ SetCJTemperature() [1/2]

void JY6312.JY6312AITask.SetCJTemperature ( double[] temperature )

Set cold junction (reference junction) temperature to all channels that has been added.

These parameter are only valid when buld-in cold-junction compensation disabled ( BuildInCJC.Enabled = false ).

Parameters
temperature Cold junction (reference juntion) temperature in ℃. The ordering of the elements must be the same as the order in which the channels are added.

◆ SetCJTemperature() [2/2]

void JY6312.JY6312AITask.SetCJTemperature | ( | int | chID,
 |  | double | temperature )

Set cold junction (reference junction) temperature with a specified channel ID.

These parameter are only valid when buld-in cold-junction compensation disabled ( BuildInCJC.Enabled = false ).

Parameters
chID | Specified channel ID, this channle must already has been added. chnId = -1: set this temperature to all channels that has been added.
temperature | Cold junction (reference juntion) temperature in ℃.

◆ Start()

void JY6312.JY6312AITask.Start ( )

Start AI task.

◆ Stop()

void JY6312.JY6312AITask.Stop ( )

Stop AI task.

Property Documentation

◆ AvailableSamples

ulong JY6312.JY6312AITask.AvailableSamples
get

Number of samples per channel that can be read in the buffer.

◆ BuildInCJC

BuildInCJC JY6312.JY6312AITask.BuildInCJC
get

Build-In Cold Junction Compensation Configuration.

◆ Channels

List<AIChannel> JY6312.JY6312AITask.Channels
get

List of enabled channels.

◆ ConversionTime

double JY6312.JY6312AITask.ConversionTime
get

The actual A/D conversion time in ms at the currently set JY6312AITask.SampleRate

◆ Device

JY6312Device JY6312.JY6312AITask.Device
get

The device instance called by this AI task instance.

◆ DisableCalibration

bool JY6312.JY6312AITask.DisableCalibration
getset

Calibration is disabled when this property is true.

The default value is false.

◆ Mode

AIMode JY6312.JY6312AITask.Mode
getset

Sample Mode.

◆ PowerLineRejection

PowerLineRejection JY6312.JY6312AITask.PowerLineRejection
get

Power line rejection configuration.

JY6312 can reject 50Hz and 60Hz components when the sampling rate is less than or equal to 8.0Sa/s.

◆ SampleClock

AISampleClock JY6312.JY6312AITask.SampleClock
get

Sample Clock Configuration.

◆ SampleRate

double JY6312.JY6312AITask.SampleRate
getset

Sampling rate per channel (S/s).

The minimum is 0.25Sa/s and the maximum is 160Sa/s. The actual sample rate is subject to the the number of channels, and the rounding operation. You can read this property to obtain the sampling rate that will actually take effect in the current configuration.

◆ SamplesToAcquire

int JY6312.JY6312AITask.SamplesToAcquire
getset

Number of samples to acquire per channel.

Only valid when Mode is AIMode.Finite.

◆ SignalExport

AISignalExport JY6312.JY6312AITask.SignalExport
get

Signal Export.

◆ TransferedSamples

ulong JY6312.JY6312AITask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT AIMode.Single.

◆ Trigger

AITrigger JY6312.JY6312AITask.Trigger
get

Trigger Configuration.

The documentation for this class was generated from the following file:
  • D:/6312/C#/JY6312AITask.cs


6312 C# Programming Manual: Member List

  • JY6312
  • JY6312AITask
JY6312.JY6312AITask Member List

This is the complete list of members for JY6312.JY6312AITask, including all inherited members.

AddChannel(int chID, ThermocoupleType thermocoupleType) | JY6312.JY6312AITask
AddChannel(int[] chIDs, ThermocoupleType thermocoupleType) | JY6312.JY6312AITask
AddChannel(int[] chIDs, ThermocoupleType[] thermocoupleType) | JY6312.JY6312AITask
AddChannel(int chID, double voltageRangeLow, double voltageRangeHigh) | JY6312.JY6312AITask
AddChannel(int[] chIDs, double voltageRangeLow, double voltageRangeHigh) | JY6312.JY6312AITask
AddChannel(int[] chIDs, double[] voltageRangeLow, double[] voltageRangeHigh) | JY6312.JY6312AITask
AvailableSamples | JY6312.JY6312AITask
BuildInCJC | JY6312.JY6312AITask
Channels | JY6312.JY6312AITask
ConversionTime | JY6312.JY6312AITask
DetectOpenThermocouple() | JY6312.JY6312AITask
Device | JY6312.JY6312AITask
DisableCalibration | JY6312.JY6312AITask
JY6312AITask(int boardNum) | JY6312.JY6312AITask
JY6312AITask(string boardName) | JY6312.JY6312AITask
Mode | JY6312.JY6312AITask
PowerLineRejection | JY6312.JY6312AITask
ReadData(ref double[] dataBuffer, int samplesPerChannel, int timeout) | JY6312.JY6312AITask
ReadData(ref double[] dataBuffer, int timeout=-1) | JY6312.JY6312AITask
ReadData(ref double[,] dataBuffer, int samplesPerChannel, int timeout) | JY6312.JY6312AITask
ReadData(ref double[,] dataBuffer, int timeout=-1) | JY6312.JY6312AITask
ReadData(IntPtr dataBuffer, int samplesPerChannel, int timeout) | JY6312.JY6312AITask
ReadRawData(ref double[] hjVoltageData, ref double[] cjTemperatureData, int samplesPerChannel, int timeout) | JY6312.JY6312AITask
ReadRawData(ref double[] hjVoltageData, ref double[] cjTemperatureData, int timeout=-1) | JY6312.JY6312AITask
ReadRawData(ref double[,] hjVoltageData, ref double[,] cjTemperatureData, int samplesPerChannel, int timeout) | JY6312.JY6312AITask
ReadRawData(ref double[,] hjVoltageData, ref double[,] cjTemperatureData, int timeout) | JY6312.JY6312AITask
ReadRawData(IntPtr EMFBuf, IntPtr coldJunctionTemperatureBuf, int samplesPerChannel, int timeout) | JY6312.JY6312AITask
ReadRawSinglePoint(ref double[] hjVoltageData, ref double[] cjTemperatureData) | JY6312.JY6312AITask
ReadRawSinglePoint(IntPtr hjVoltageData, IntPtr cjTemperatureData) | JY6312.JY6312AITask
ReadSinglePoint(ref double[] dataBuffer) | JY6312.JY6312AITask
ReadSinglePoint(IntPtr dataBuffer) | JY6312.JY6312AITask
RemoveChannel(int chID) | JY6312.JY6312AITask
RemoveChannel(int[] chIDs) | JY6312.JY6312AITask
ReportBuildInCJException() | JY6312.JY6312AITask
SampleClock | JY6312.JY6312AITask
SampleRate | JY6312.JY6312AITask
SamplesToAcquire | JY6312.JY6312AITask
SendSoftwareTrigger() | JY6312.JY6312AITask
SetCJTemperature(int chID, double temperature) | JY6312.JY6312AITask
SetCJTemperature(double[] temperature) | JY6312.JY6312AITask
SignalExport | JY6312.JY6312AITask
Start() | JY6312.JY6312AITask
Stop() | JY6312.JY6312AITask
TransferedSamples | JY6312.JY6312AITask
Trigger | JY6312.JY6312AITask


6312 C# Programming Manual: Class Index

Class Index
A | J
A
AIAdvanced (JY6312)
AIChannel (JY6312)
AIChannelAdvanced (JY6312)
AIDigitalTrigger (JY6312)
AIExternalSampleClock (JY6312)
AISampleClock (JY6312)
AISignalExport (JY6312)
AITrigger (JY6312)
J
JY6312AITask (JY6312)


6312 C# Programming Manual: D:/6312 Directory Reference

  • File List
  • 6312
6312 Directory Reference

Directories

C#


6312 C# Programming Manual: D:/6312/C# Directory Reference

  • File List
  • 6312
  • C#
C# Directory Reference

Files

AIAdvanced.cs
AIChannel.cs
AIClock.cs
AISignalExport.cs
AITrigger.cs
JY6312AITask.cs


6312 C# Programming Manual: File List

  • File List
File List
Here is a list of all files with brief descriptions:
[detail level 123]
▼ 6312
▼ C#
AIAdvanced.cs
AIChannel.cs
AIClock.cs
AISignalExport.cs
AITrigger.cs
JY6312AITask.cs


6312 C# Programming Manual: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • g
  • i
  • j
  • m
  • p
  • r
  • s
  • t
  • v
Here is a list of all class members with links to the classes they belong to:

- a -

  • Add() : JY6312.AISignalExport
  • AddChannel() : JY6312.JY6312AITask
  • Advanced : JY6312.AIChannel
  • AvailableSamples : JY6312.JY6312AITask

- b -

  • BuildInCJC : JY6312.JY6312AITask

- c -

  • Channels : JY6312.JY6312AITask
  • Clear() : JY6312.AISignalExport
  • ClearAll() : JY6312.AISignalExport
  • ConversionTime : JY6312.JY6312AITask
  • CustomCJTemperature : JY6312.AIChannel

- d -

  • DetectOpenThermocouple() : JY6312.JY6312AITask
  • Device : JY6312.JY6312AITask
  • Digital : JY6312.AITrigger
  • DisableCalibration : JY6312.JY6312AITask

- e -

  • Edge : JY6312.AIDigitalTrigger
  • ExpectedRate : JY6312.AIExternalSampleClock
  • External : JY6312.AISampleClock

- g -

  • Gain : JY6312.AIChannel

- i -

  • ID : JY6312.AIChannel
  • InputBufferEnabled : JY6312.AIChannelAdvanced

- j -

  • JY6312AITask() : JY6312.JY6312AITask

- m -

  • MeasurementType : JY6312.AIChannel
  • Mode : JY6312.AITrigger, JY6312.JY6312AITask

- p -

  • PowerLineRejection : JY6312.JY6312AITask
  • PreTriggerSamples : JY6312.AITrigger

- r -

  • Range : JY6312.AIChannel
  • RangeHigh : JY6312.AIChannel
  • RangeLow : JY6312.AIChannel
  • ReadData() : JY6312.JY6312AITask
  • ReadRawData() : JY6312.JY6312AITask
  • ReadRawSinglePoint() : JY6312.JY6312AITask
  • ReadSinglePoint() : JY6312.JY6312AITask
  • RemoveChannel() : JY6312.JY6312AITask
  • ReportBuildInCJException() : JY6312.JY6312AITask
  • ReTriggerCount : JY6312.AITrigger

- s -

  • SampleClock : JY6312.JY6312AITask
  • SampleRate : JY6312.JY6312AITask
  • SamplesToAcquire : JY6312.JY6312AITask
  • SendSoftwareTrigger() : JY6312.JY6312AITask
  • SetCJTemperature() : JY6312.JY6312AITask
  • SignalExport : JY6312.JY6312AITask
  • Source : JY6312.AIDigitalTrigger, JY6312.AISampleClock
  • Start() : JY6312.JY6312AITask
  • Stop() : JY6312.JY6312AITask

- t -

  • Terminal : JY6312.AIExternalSampleClock
  • ThermocoupleType : JY6312.AIChannel
  • TransferedSamples : JY6312.JY6312AITask
  • Trigger : JY6312.JY6312AITask
  • Type : JY6312.AITrigger

- v -

  • VbiasEnabled : JY6312.AIChannelAdvanced


6312 C# Programming Manual: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • c
  • d
  • j
  • r
  • s
Here is a list of all functions with links to the classes they belong to:

- a -

  • Add() : JY6312.AISignalExport
  • AddChannel() : JY6312.JY6312AITask

- c -

  • Clear() : JY6312.AISignalExport
  • ClearAll() : JY6312.AISignalExport

- d -

  • DetectOpenThermocouple() : JY6312.JY6312AITask

- j -

  • JY6312AITask() : JY6312.JY6312AITask

- r -

  • ReadData() : JY6312.JY6312AITask
  • ReadRawData() : JY6312.JY6312AITask
  • ReadRawSinglePoint() : JY6312.JY6312AITask
  • ReadSinglePoint() : JY6312.JY6312AITask
  • RemoveChannel() : JY6312.JY6312AITask
  • ReportBuildInCJException() : JY6312.JY6312AITask

- s -

  • SendSoftwareTrigger() : JY6312.JY6312AITask
  • SetCJTemperature() : JY6312.JY6312AITask
  • Start() : JY6312.JY6312AITask
  • Stop() : JY6312.JY6312AITask


6312 C# Programming Manual: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • g
  • i
  • m
  • p
  • r
  • s
  • t
  • v
Here is a list of all properties with links to the classes they belong to:

- a -

  • Advanced : JY6312.AIChannel
  • AvailableSamples : JY6312.JY6312AITask

- b -

  • BuildInCJC : JY6312.JY6312AITask

- c -

  • Channels : JY6312.JY6312AITask
  • ConversionTime : JY6312.JY6312AITask
  • CustomCJTemperature : JY6312.AIChannel

- d -

  • Device : JY6312.JY6312AITask
  • Digital : JY6312.AITrigger
  • DisableCalibration : JY6312.JY6312AITask

- e -

  • Edge : JY6312.AIDigitalTrigger
  • ExpectedRate : JY6312.AIExternalSampleClock
  • External : JY6312.AISampleClock

- g -

  • Gain : JY6312.AIChannel

- i -

  • ID : JY6312.AIChannel
  • InputBufferEnabled : JY6312.AIChannelAdvanced

- m -

  • MeasurementType : JY6312.AIChannel
  • Mode : JY6312.AITrigger, JY6312.JY6312AITask

- p -

  • PowerLineRejection : JY6312.JY6312AITask
  • PreTriggerSamples : JY6312.AITrigger

- r -

  • Range : JY6312.AIChannel
  • RangeHigh : JY6312.AIChannel
  • RangeLow : JY6312.AIChannel
  • ReTriggerCount : JY6312.AITrigger

- s -

  • SampleClock : JY6312.JY6312AITask
  • SampleRate : JY6312.JY6312AITask
  • SamplesToAcquire : JY6312.JY6312AITask
  • SignalExport : JY6312.JY6312AITask
  • Source : JY6312.AIDigitalTrigger, JY6312.AISampleClock

- t -

  • Terminal : JY6312.AIExternalSampleClock
  • ThermocoupleType : JY6312.AIChannel
  • TransferedSamples : JY6312.JY6312AITask
  • Trigger : JY6312.JY6312AITask
  • Type : JY6312.AITrigger

- v -

  • VbiasEnabled : JY6312.AIChannelAdvanced


6312 C# Programming Manual: Main Page

6312 C# Programming Manual Documentation


6312 C# Programming Manual: JY6312 Namespace Reference

  • Package List
  • Package Members
Classes | Enumerations
JY6312 Namespace Reference

Classes

class | AIAdvanced
Analog Input Advance Parameter Class. More...
class | AIChannel
AI channel class. More...
class | AIChannelAdvanced
Analog Input Advance Parameter Class. More...
class | AIDigitalTrigger
AI Digital trigger params. More...
class | AIExternalSampleClock
External Sample Clock Configuration Class. More...
class | AISampleClock
Sample clock configuration class. More...
class | AISignalExport
AI Signal Export Class. More...
class | AITrigger
AI Trigger params. More...
class | JY6312AITask
JY6312 AI task class. More...

Enumerations

enum AIRange {
_1p25V = 1 , _625mV = 2 , _312p5mV = 3 , _156p2mV = 4 ,
_78p125mV = 5
}
AI voltage range. More...
enum | MeasurementType { Thermocouple = 0 , GeneralVoltage = 1 }
Measurement Type Enum. More...
enum | AISampleClockSource { Internal = JY6312Import.JY6312_InternalSampleClock , External = JY6312Import.JY6312_ExternalSampleClock }
AI Sample Clock Source. More...
enum ClockTerminal {
PFI0 = JY6312Import.JY6312_DigitalTriggerSource_PFI_0 , PFI1 = JY6312Import.JY6312_DigitalTriggerSource_PFI_1 , PXI_Trig0 = JY6312Import.JY6312_DigitalTriggerSource_BUS_0 , PXI_Trig1 = JY6312Import.JY6312_DigitalTriggerSource_BUS_1 ,
PXI_Trig2 = JY6312Import.JY6312_DigitalTriggerSource_BUS_2 , PXI_Trig3 = JY6312Import.JY6312_DigitalTriggerSource_BUS_3 , PXI_Trig4 = JY6312Import.JY6312_DigitalTriggerSource_BUS_4 , PXI_Trig5 = JY6312Import.JY6312_DigitalTriggerSource_BUS_5 ,
PXI_Trig6 = JY6312Import.JY6312_DigitalTriggerSource_BUS_6 , PXI_Trig7 = JY6312Import.JY6312_DigitalTriggerSource_BUS_7 , PXI_Star = JY6312Import.JY6312_DigitalTriggerSource_STAR
}
Clock Terminal. More...
enum | AITriggerMode { Start , Reference }
AI trigger mode enum type. More...
enum AIDigitalTriggerSource {
PFI0 = JY6312Import.JY6312_DigitalTriggerSource_PFI_0 , PFI1 = JY6312Import.JY6312_DigitalTriggerSource_PFI_1 , PXI_Trig0 = JY6312Import.JY6312_DigitalTriggerSource_BUS_0 , PXI_Trig1 = JY6312Import.JY6312_DigitalTriggerSource_BUS_1 ,
PXI_Trig2 = JY6312Import.JY6312_DigitalTriggerSource_BUS_2 , PXI_Trig3 = JY6312Import.JY6312_DigitalTriggerSource_BUS_3 , PXI_Trig4 = JY6312Import.JY6312_DigitalTriggerSource_BUS_4 , PXI_Trig5 = JY6312Import.JY6312_DigitalTriggerSource_BUS_5 ,
PXI_Trig6 = JY6312Import.JY6312_DigitalTriggerSource_BUS_6 , PXI_Trig7 = JY6312Import.JY6312_DigitalTriggerSource_BUS_7 , PXI_Star = JY6312Import.JY6312_DigitalTriggerSource_STAR
}
AI digital trigger source enum type. More...
enum | AITriggerType { Immediately = JY6312Import.JY6312_TriggerType_Immediately , Digital = JY6312Import.JY6312_TriggerType_Digital , Software = JY6312Import.JY6312_TriggerType_Software }
AI trigger type enum type. More...
enum | AIDigitalTriggerEdge { Rising = JY6312Import.JY6312_DigitalTriggerEdge_Rising , Falling = JY6312Import.JY6312_DigitalTriggerEdge_Falling }
AI digital trigger edge enum type. More...
enum | AIMode { Finite = JY6312Import.JY6312_AI_Finite , Continuous = JY6312Import.JY6312_AI_Continuous , Single = JY6312Import.JY6312_AI_Single }
AI mode enum type. More...
enum | ThermocoupleConnectionStatus { Normal = JY6312Import.JY6312_TCConState_Normal , OpenCircuit = JY6312Import.JY6312_TCConState_OpenCircuit , ShortCircuit = JY6312Import.JY6312_TCConState_ShortCircuit }
Thermocouple connection status. More...

Enumeration Type Documentation

◆ AIDigitalTriggerEdge

enum JY6312.AIDigitalTriggerEdge

AI digital trigger edge enum type.

Enumerator
Rising | Rising edge.
Falling | Falling edge.

◆ AIDigitalTriggerSource

enum JY6312.AIDigitalTriggerSource

AI digital trigger source enum type.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PXI_Trig0 | PXITrig_0.
PXI_Trig1 | PXITrig_1.
PXI_Trig2 | PXITrig_2.
PXI_Trig3 | PXITrig_3.
PXI_Trig4 | PXITrig_4.
PXI_Trig5 | PXITrig_5.
PXI_Trig6 | PXITrig_6.
PXI_Trig7 | PXITrig_7.
PXI_Star | PXI STAR.

◆ AIMode

enum JY6312.AIMode

AI mode enum type.

Enumerator
Finite | Finite mode.
Continuous | Continuous mode.
Single | Single point mode.

◆ AIRange

enum JY6312.AIRange

AI voltage range.

Enumerator
_1p25V | ±1.25V
_625mV | ±625mV
_312p5mV | ±312.5mV
_156p2mV | ±156.2mV
_78p125mV | ±78.125mV

◆ AISampleClockSource

enum JY6312.AISampleClockSource

AI Sample Clock Source.

Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ AITriggerMode

enum JY6312.AITriggerMode

AI trigger mode enum type.

Enumerator
Start | Start trigger.
Reference | Reference trigger. Only valid in the Finite mode.

◆ AITriggerType

enum JY6312.AITriggerType

AI trigger type enum type.

Enumerator
Immediately | Immediately, no trigger.
Digital | Digital trigger.
Software | Software trigger.

◆ ClockTerminal

enum JY6312.ClockTerminal

Clock Terminal.

Enumerator
PFI0 | PFI_0.
PFI1 | PFI_1.
PXI_Trig0 | PXITrig_0.
PXI_Trig1 | PXITrig_1.
PXI_Trig2 | PXITrig_2.
PXI_Trig3 | PXITrig_3.
PXI_Trig4 | PXITrig_4.
PXI_Trig5 | PXITrig_5.
PXI_Trig6 | PXITrig_6.
PXI_Trig7 | PXITrig_7.
PXI_Star | PXI STAR.

◆ MeasurementType

enum JY6312.MeasurementType

Measurement Type Enum.

Enumerator
Thermocouple | Measuring thermocouple. The data is temeprature in ℃.
GeneralVoltage | Measuring voltage. The data is voltage value in V.

◆ ThermocoupleConnectionStatus

enum JY6312.ThermocoupleConnectionStatus

Thermocouple connection status.

Enumerator
Normal | Normal.
OpenCircuit | Open circuit.
ShortCircuit | Short circuit.


6312 C# Programming Manual: Package Members

  • Package List
  • Package Members
  • All
  • Enumerations
Here is a list of all namespace members with links to the namespace documentation for each member:
  • AIDigitalTriggerEdge : JY6312
  • AIDigitalTriggerSource : JY6312
  • AIMode : JY6312
  • AIRange : JY6312
  • AISampleClockSource : JY6312
  • AITriggerMode : JY6312
  • AITriggerType : JY6312
  • ClockTerminal : JY6312
  • MeasurementType : JY6312
  • ThermocoupleConnectionStatus : JY6312


6312 C# Programming Manual: Package Members

  • Package List
  • Package Members
  • All
  • Enumerations
Here is a list of all namespace enums with links to the namespace documentation for each enum:
  • AIDigitalTriggerEdge : JY6312
  • AIDigitalTriggerSource : JY6312
  • AIMode : JY6312
  • AIRange : JY6312
  • AISampleClockSource : JY6312
  • AITriggerMode : JY6312
  • AITriggerType : JY6312
  • ClockTerminal : JY6312
  • MeasurementType : JY6312
  • ThermocoupleConnectionStatus : JY6312


6312 C# Programming Manual: Package List

  • Package List
  • Package Members
Package List
Here are the packages with brief descriptions (if available):
N JY6312