6313 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/6313 Directory Reference

6313 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 6313
6313 Directory Reference

Files

JY6313CoreOOAITask.h
JY6313CoreOOCommon.h
JY6313CoreOODevice.h
JY6313CoreOOLog.h
Generated by doxygen 1.13.2


6313 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/6313/JY6313CoreOOAITask.h File Reference

  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 6313
Classes | Namespaces | Macros | Enumerations | Functions
JY6313CoreOOAITask.h File Reference
#include <memory>
#include <map>
#include <fstream>
#include <thread>
#include <cstring>
#include <cstddef>
#include <mutex>
#include <stdexcept>
#include <algorithm>
#include "JY6313CoreOOCommon.h"
#include "JY6313CoreOODevice.h"

Classes

class | JY6313CoreOO::JY6313CoreOOAITask
aiTask类 More...
class | JY6313CoreOO::StrainMeasInfo
Strain Measuement Infomation. More...
class | JY6313CoreOO::BridgeCalInfo
Bridge Calibration Information. More...
class | JY6313CoreOO::AIChannel
JY6313 AI channel configuration. More...
class | JY6313CoreOO::AITrigger
class | JY6313CoreOO::AIDigitalTrigger
class | JY6313CoreOO::AIAnalogHysteresisComparator
class | JY6313CoreOO::AIAnalogWindowComparator
class | JY6313CoreOO::AIAnalogEdgeComparator
class | JY6313CoreOO::AIAnalogTrigger
class | JY6313CoreOO::AISignalExport
class | JY6313CoreOO::PowerLineRejection
Power Line Rejection Parameters Class. More...
class | JY6313CoreOO::AIAdvanced
class | JY6313CoreOO::AISync
Configure sync signal. More...
class | JY6313CoreOO::DeviceMiscellaneousParam
Device miscellaneous param. More...
class | JY6313CoreOO::JY6313Miscellaneous
JY6313 Miscellaneous parameters. More...
class | JY6313CoreOO::ConversionStatus
ADC Convesion Status Class. More...

Namespaces

namespace JY6313CoreOO

Macros

#define _CRT_SECURE_NO_WARNINGS

Enumerations

enum class | JY6313CoreOO::AIMode { JY6313CoreOO::Finite = JY6313Import::JY6313_AI_Finite , JY6313CoreOO::Continuous = JY6313Import::JY6313_AI_Continuous , JY6313CoreOO::Single = JY6313Import::JY6313_AI_Single }
enum class | JY6313CoreOO::ChannelRangeAssignMode { JY6313CoreOO::RangeLowHighFirst = 0 , JY6313CoreOO::GainFirst = 1 }
enum class | JY6313CoreOO::MeasurementType { JY6313CoreOO::Strain , JY6313CoreOO::Ratiometric }
Measurement type of channel. More...
enum class JY6313CoreOO::StrainConfiguration {
JY6313CoreOO::QuarterBridgeI = 0 , JY6313CoreOO::QuarterBridgeII = 1 , JY6313CoreOO::HalfBridgeI = 2 , JY6313CoreOO::HalfBridgeII = 3 ,
JY6313CoreOO::FullBridgeI = 4 , JY6313CoreOO::FullBridgeII = 5 , JY6313CoreOO::FullBridgeIII = 6
}
Strain measurement configuration. More...
enum class JY6313CoreOO::AIGain {
JY6313CoreOO::x6p25 = 0 , JY6313CoreOO::x12p5 = 1 , JY6313CoreOO::x25 = 2 , JY6313CoreOO::x50 = 3 ,
JY6313CoreOO::x100 = 4
}
AI gain. More...
enum class | JY6313CoreOO::AISampleClockSource { JY6313CoreOO::Internal , JY6313CoreOO::External }
enum class | JY6313CoreOO::AITriggerType { JY6313CoreOO::Immediate = JY6313Import::JY6313_TriggerType_Immediately , JY6313CoreOO::Digital = JY6313Import::JY6313_TriggerType_Digital , JY6313CoreOO::Soft = JY6313Import::JY6313_TriggerType_Software , JY6313CoreOO::Analog = JY6313Import::JY6313_TriggerType_Analog }
AI trigger type enum type. More...
enum class | JY6313CoreOO::AITriggerMode { JY6313CoreOO::Start , JY6313CoreOO::Reference }
AI trigger mode enum type. More...
enum class JY6313CoreOO::AIAnalogTriggerSource {
JY6313CoreOO::Channel_0 , JY6313CoreOO::Channel_1 , JY6313CoreOO::Channel_2 , JY6313CoreOO::Channel_3 ,
JY6313CoreOO::Channel_4 , JY6313CoreOO::Channel_5 , JY6313CoreOO::Channel_6 , JY6313CoreOO::Channel_7 ,
JY6313CoreOO::Channel_8 , JY6313CoreOO::Channel_9 , JY6313CoreOO::Channel_10 , JY6313CoreOO::Channel_11 ,
JY6313CoreOO::Channel_12 , JY6313CoreOO::Channel_13 , JY6313CoreOO::Channel_14 , JY6313CoreOO::Channel_15
}
enum class JY6313CoreOO::AIDigitalTriggerSource {
JY6313CoreOO::Ext_Trig = JY6313Import::JY6313_DigitalTriggerSource_ExtTrg , JY6313CoreOO::PXI_Trig0 = JY6313Import::JY6313_DigitalTriggerSource_BUS_0 , JY6313CoreOO::PXI_Trig1 = JY6313Import::JY6313_DigitalTriggerSource_BUS_1 , JY6313CoreOO::PXI_Trig2 = JY6313Import::JY6313_DigitalTriggerSource_BUS_2 ,
JY6313CoreOO::PXI_Trig3 = JY6313Import::JY6313_DigitalTriggerSource_BUS_3 , JY6313CoreOO::PXI_Trig4 = JY6313Import::JY6313_DigitalTriggerSource_BUS_4 , JY6313CoreOO::PXI_Trig5 = JY6313Import::JY6313_DigitalTriggerSource_BUS_5 , JY6313CoreOO::PXI_Trig6 = JY6313Import::JY6313_DigitalTriggerSource_BUS_6 ,
JY6313CoreOO::PXI_Trig7 = JY6313Import::JY6313_DigitalTriggerSource_BUS_7
}
enum class | JY6313CoreOO::AIDigitalTriggerEdge { JY6313CoreOO::Rising = 0x0 , JY6313CoreOO::Falling = 0x1 }
enum class | JY6313CoreOO::AIAnalogTriggerEdge { JY6313CoreOO::Rising , JY6313CoreOO::Falling }
enum class | JY6313CoreOO::AIAnalogWindowCondition { JY6313CoreOO::Entering , JY6313CoreOO::Leaving }
AI Analog Window Trigger Condition. More...
enum class | JY6313CoreOO::AIAnalogTriggerComparator { JY6313CoreOO::Edge , JY6313CoreOO::Hysteresis , JY6313CoreOO::Window }
AI Analog Trigger Comparator. More...
enum class JY6313CoreOO::AISignalExportSource {
JY6313CoreOO::SampleClock = JY6313Import::JY6313_ExportSource_SampleClock , JY6313CoreOO::Sync = JY6313Import::JY6313_ExportSource_SyncPulse , JY6313CoreOO::ReadyForTrig = JY6313Import::JY6313_ExportSource_ReadyForTrig , JY6313CoreOO::Trig = JY6313Import::JY6313_ExportSource_Trig ,
JY6313CoreOO::EndOfRecord = JY6313Import::JY6313_ExportSource_EndOfRecord , JY6313CoreOO::EndOfAcquisition = JY6313Import::JY6313_ExportSource_EndOfAcquisition
}
AI Signal Export Source Enum. More...
enum class | JY6313CoreOO::PowerLineFrequency { JY6313CoreOO::_50Hz = 0 , JY6313CoreOO::_60Hz = 1 }
enum class | JY6313CoreOO::SyncTopology { JY6313CoreOO::Independent = JY6313Import::JY6313_SyncMode_Sole , JY6313CoreOO::Master = JY6313Import::JY6313_SyncMode_Master , JY6313CoreOO::Slave = JY6313Import::JY6313_SyncMode_Slave }
Synchronization board configuration. More...
enum class JY6313CoreOO::SyncTerminal {
JY6313CoreOO::Ext_Trig = JY6313Import::JY6313_DigitalTriggerSource_ExtTrg , JY6313CoreOO::PXI_Trig0 = JY6313Import::JY6313_DigitalTriggerSource_BUS_0 , JY6313CoreOO::PXI_Trig1 = JY6313Import::JY6313_DigitalTriggerSource_BUS_1 , JY6313CoreOO::PXI_Trig2 = JY6313Import::JY6313_DigitalTriggerSource_BUS_2 ,
JY6313CoreOO::PXI_Trig3 = JY6313Import::JY6313_DigitalTriggerSource_BUS_3 , JY6313CoreOO::PXI_Trig4 = JY6313Import::JY6313_DigitalTriggerSource_BUS_4 , JY6313CoreOO::PXI_Trig5 = JY6313Import::JY6313_DigitalTriggerSource_BUS_5 , JY6313CoreOO::PXI_Trig6 = JY6313Import::JY6313_DigitalTriggerSource_BUS_6 ,
JY6313CoreOO::PXI_Trig7 = JY6313Import::JY6313_DigitalTriggerSource_BUS_7
}
Multi-device sync signal in/out terminal. More...
enum class | JY6313CoreOO::SyncState { JY6313CoreOO::WaitingSync , JY6313CoreOO::Synchronized , JY6313CoreOO::Invalid }
enum class | JY6313CoreOO::OperationMode { JY6313CoreOO::Auto = 0 , JY6313CoreOO::Normal = 1 , JY6313CoreOO::LowLatency = 2 }

Functions

double JY6313CoreOO::GetGainValue (AIGain Gain)

Macro Definition Documentation

◆ _CRT_SECURE_NO_WARNINGS

#define _CRT_SECURE_NO_WARNINGS


6313 C++ Programming Manual: JY6313CoreOO::JY6313CoreOOAITask Class Reference

  • Class List
  • Class Index
  • Class Members
  • JY6313CoreOO
  • JY6313CoreOOAITask
Public Member Functions | Public Attributes | List of all members
JY6313CoreOO::JY6313CoreOOAITask Class Reference

aiTask类 More...

#include <JY6313CoreOOAITask.h>

Public Member Functions

JY6313CoreOOAITask (int slotNum)
Constructor.
JY6313CoreOOAITask (std::string boardName)
Constructor.
void | AddChannel (int chnId, double excitationVoltage, AIGain gain)
Add one/all ratiometric measurement channel(s).
void | AddChannel (int chnId, double excitationVoltage, double rangeLow, double rangeHigh)
Add one/all ratiometric measurement channel(s).
void | AddChannel (std::vector< int > chnsId, double excitationVoltage, double rangeLow, double rangeHigh)
Add a group of ratiometric measurement channels.
void | AddChannel (std::vector< int > chnsId, std::vector< double > excitationVoltage, double rangeLow, double rangeHigh)
Add a group of ratiometric measurement channels.
void | AddChannel (std::vector< int > chnsId, std::vector< double > excitationVoltage, std::vector< double > rangeLow, double rangeHigh)
Add a group of ratiometric measurement channels.
void | AddChannel (std::vector< int > chnsId, std::vector< double > excitationVoltage, std::vector< double > rangeLow, std::vector< double > rangeHigh)
Add a group of ratiometric measurement channels.
void | AddChannel (int chnId, StrainConfiguration configuration, double excitationVoltage, double rangeLow, double rangeHigh, double gageNominalResistance, double gageFactor, double poissonFactor=0.5, double leadWireResistance=0.0)
Add one/all strain measurement channel(s).
void | AddChannel (std::vector< int > chnsId, StrainConfiguration configuration, double excitationVoltage, double rangeLow, double rangeHigh, double gageNominalResistance, double gageFactor, double poissonFactor=0.5, double leadWireResistance=0.0)
Add a group of strain measurement channel(s).
void | AddChannel (std::vector< int > chnsId, std::vector< StrainConfiguration > configuration, double excitationVoltage, double rangeLow, double rangeHigh, double gageNominalResistance, double gageFactor, double poissonFactor=0.5, double leadWireResistance=0.0)
Add a group of strain measurement channel(s).
void | AddChannel (std::vector< int > chnsId, std::vector< StrainConfiguration > configuration, std::vector< double > excitationVoltage, double rangeLow, double rangeHigh, double gageNominalResistance, double gageFactor, double poissonFactor=0.5, double leadWireResistance=0.0)
Add a group of strain measurement channel(s).
void | AddChannel (std::vector< int > chnsId, std::vector< StrainConfiguration > configuration, std::vector< double > excitationVoltage, std::vector< double > rangeLow, double rangeHigh, double gageNominalResistance, double gageFactor, double poissonFactor=0.5, double leadWireResistance=0.0)
Add a group of strain measurement channel(s).
void | AddChannel (std::vector< int > chnsId, std::vector< StrainConfiguration > configuration, std::vector< double > excitationVoltage, std::vector< double > rangeLow, std::vector< double > rangeHigh, double gageNominalResistance, double gageFactor, double poissonFactor=0.5, double leadWireResistance=0.0)
Add a group of strain measurement channel(s).
void | AddChannel (std::vector< int > chnsId, std::vector< StrainConfiguration > configuration, std::vector< double > excitationVoltage, std::vector< double > rangeLow, std::vector< double > rangeHigh, std::vector< double > gageNominalResistance, double gageFactor, double poissonFactor=0.5, double leadWireResistance=0.0)
Add a group of strain measurement channel(s).
void | AddChannel (std::vector< int > chnsId, std::vector< StrainConfiguration > configuration, std::vector< double > excitationVoltage, std::vector< double > rangeLow, std::vector< double > rangeHigh, std::vector< double > gageNominalResistance, std::vector< double > gageFactor, double poissonFactor=0.5, double leadWireResistance=0.0)
Add a group of strain measurement channel(s).
void | AddChannel (std::vector< int > chnsId, std::vector< StrainConfiguration > configuration, std::vector< double > excitationVoltage, std::vector< double > rangeLow, std::vector< double > rangeHigh, std::vector< double > gageNominalResistance, std::vector< double > gageFactor, std::vector< double > poissonFactor, double leadWireResistance=0.0)
Add a group of strain measurement channel(s).
void | AddChannel (std::vector< int > chnsId, std::vector< StrainConfiguration > configuration, std::vector< double > excitationVoltage, std::vector< double > rangeLow, std::vector< double > rangeHigh, std::vector< double > gageNominalResistance, std::vector< double > gageFactor, std::vector< double > poissonFactor, std::vector< double > leadWireResistance)
Add a group of strain measurement channel(s).
void | RemoveChannel (int chnId)
Delete the channel with the specified channel number.
void | RemoveChannel (std::vector< int > chnId)
Delete a specific set of channels.
void | ReadData (double *pBuf, int samplesPerChannel, int timeout=-1)
Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.
void | ReadData (std::vector< double > &pBuf, int samplesPerChannel, int timeout=-1)
Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.
void | ReadData (std::vector< std::vector< double > > &pBuf, int samplesPerChannel, int timeout=-1)
Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.
void | ReadRawData (int *pBuf, int samplesPerChannel, int timeout=-1)
Read one or multi-channel raw data by columns and store it in a data buffer.
void | ReadRawData (std::vector< int > &pBuf, int samplesPerChannel, int timeout=-1)
Read one or multi-channel raw data by columns and store it in a data buffer.
void | ReadSinglePoint (double &readValue, int channel)
Read one sample for specified channel in register.
void | ReadSinglePoint (std::vector< double > &readValues)
Read raw one sample for all channels in register .
void | ReadRatiometricData (std::vector< double > &dataBuf, int samplesPerChannel, int timeout)
Read voltage data and copy to buffer.
std::vector< ConversionStatus * > & | GetConversionStatus ()
Get conversion status on all enabled channels.
void | PerformOffsetNulling (int chID)
Perform offset nulling on one specified channel.
void | PerformOffsetNulling (std::vector< int > chIDs)
Perform offset nulling on a group of channels.
void | PerformShuntCalibration (std::vector< int > chIDs, std::vector< double > shuntResistance)
Perform Shunt calibration on a group of channels without TB6313 connected.
void | PerformShuntCalibration (std::vector< int > chIDs)
Perform Shunt calibration on a group of channels with TB6313 connected and used.
void | PerformShuntCalibration (int chID)
Perform Shunt calibration on a group of channels with TB6313 connected and used.
void | Start ()
Start Task.
void | SendSoftwareTrigger ()
Generate a software trigger signal generate a software trigger signal.
void | Stop ()
Stop Task.
~JY6313CoreOOAITask ()

Public Attributes

std::list< AIChannel * > | Channels
List of AI channels,(6313 support 16 channel)
JY6313CoreOOProperty< JY6313CoreOOAITask, double, JY6313CoreOOPropertyType::READ_WRITE > | SampleRate
Sampling rate per channel in Sa/s, the valid value range is 7.8125Sa/s to 80kSa/s.
JY6313CoreOOProperty< JY6313CoreOOAITask, double, JY6313CoreOOPropertyType::READ_ONLY > | GroupDelay
Group delay at current sampling rate and operating mode (unit: Samples).
unsigned int | SamplesToAcquire
Number of samples to be read per channel.
JY6313CoreOOProperty< JY6313CoreOOAITask, int, JY6313CoreOOPropertyType::READ_ONLY > | BufLenInSamples
Number of samples per channel can be storage in the buffer, the Property SamplesToAcquire must be less than or equal to this value.
JY6313CoreOOProperty< JY6313CoreOOAITask, uint64_t, JY6313CoreOOPropertyType::READ_ONLY > | AvailableSamples
Number of samples per channel that can be read in the buffer .
JY6313CoreOOProperty< JY6313CoreOOAITask, uint64_t, JY6313CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
JY6313CoreOOProperty< JY6313CoreOOAITask, OperationMode, JY6313CoreOOPropertyType::READ_WRITE > Operation_Mode
AIMode Mode
AI acquisition mode, support Finite/Continuous/Single *.
AITrigger * Trigger
AI Trigger Configuration.
AIAdvanced * Advanced
Analog Input Advance Parameter Class.
AISignalExport * SignalExport
Export AI Signal Configuration.
bool | DisableDigitalTriggerDelay
Disalble calibration Enable.
AISync * Sync
Multi card synchronous configuration.
JY6313CoreOODevice * Device
Device.

Detailed Description

aiTask类

Constructor & Destructor Documentation

◆ JY6313CoreOOAITask() [1/2]

JY6313CoreOO::JY6313CoreOOAITask::JY6313CoreOOAITask ( int slotNum )

Constructor.

Used to create an AI task by a slot number

Parameters
slotNum Card slot number.

◆ JY6313CoreOOAITask() [2/2]

JY6313CoreOO::JY6313CoreOOAITask::JY6313CoreOOAITask ( std::string boardName )

Constructor.

Used to create an AI task by a slot number

Parameters
slotNum Card slot number.

◆ ~JY6313CoreOOAITask()

JY6313CoreOO::JY6313CoreOOAITask::~JY6313CoreOOAITask ( )

Member Function Documentation

◆ AddChannel() [1/16]

void JY6313CoreOO::JY6313CoreOOAITask::AddChannel | ( | int | chnId,
 |  | double | excitationVoltage,
 |  | AIGain | gain )

Add one/all ratiometric measurement channel(s).

Parameters
chID | Channel ID
excitationVoltage | Excitation voltage in V, range: 1V~5V. The excitation voltages for Ch0~Ch7 must be equal, and for Ch8~Ch15 must be equal.
gain | Input gain.

◆ AddChannel() [2/16]

void JY6313CoreOO::JY6313CoreOOAITask::AddChannel | ( | int | chnId,
 |  | double | excitationVoltage,
 |  | double | rangeLow,
 |  | double | rangeHigh )

Add one/all ratiometric measurement channel(s).

Parameters
chID | Channel ID
excitationVoltage | Excitation voltage in V, range: 1V~5V. The excitation voltages for Ch0~Ch7 must be equal, and for Ch8~Ch15 must be equal.
rangeLow | Lower limit of range. Unit: mV/V.
rangeHigh | Higher limit of range. Unit: mV/V.

◆ AddChannel() [3/16]

void JY6313CoreOO::JY6313CoreOOAITask::AddChannel | ( | int | chnId,
 |  | StrainConfiguration | configuration,
 |  | double | excitationVoltage,
 |  | double | rangeLow,
 |  | double | rangeHigh,
 |  | double | gageNominalResistance,
 |  | double | gageFactor,
 |  | double | poissonFactor = 0.5,
 |  | double | leadWireResistance = 0.0 )

Add one/all strain measurement channel(s).

Parameters
chnId | Channel ID
configuration | Strain bridge configuration
excitationVoltage | Excitation voltage in V, range: 1V~5V. The excitation voltages for Ch0~Ch7 must be equal, and for Ch8~Ch15 must be equal.
rangeLow | Lower limit of range. Unit: ue.
rangeHigh | Higher limit of range. Unit: ue.
gageNominalResistance | Gage nominal resistance in ohm. Common value include 120, 350, and 1k ohms.
gageFactor | Gage factor. Common value is 2.0.
poissonFactor | Material's poisson factor. Common value is 0.5.
leadWireResistance | Leadwire resistance in ohm. The accurate known resistance of the wires helps to reduce the error introduced by the wire resistance.

◆ AddChannel() [4/16]

void JY6313CoreOO::JY6313CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | double | excitationVoltage,
 |  | double | rangeLow,
 |  | double | rangeHigh )

Add a group of ratiometric measurement channels.

Parameters
chIDs | IDs of channels to add.
excitationVoltage | Excitation voltage in V, range: 1V~5V. The excitation voltages for Ch0~Ch7 must be equal, and for Ch8~Ch15 must be equal.
rangeLow | Lower limit of range. Unit: mV/V.
rangeHigh | Higher limit of range. Unit: mV/V.

◆ AddChannel() [5/16]

void JY6313CoreOO::JY6313CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | std::vector< double > | excitationVoltage,
 |  | double | rangeLow,
 |  | double | rangeHigh )

Add a group of ratiometric measurement channels.

Parameters
chIDs | IDs of channels to add.
excitationVoltage | Excitation voltage in V, range: 1V~5V. The excitation voltages for Ch0~Ch7 must be equal, and for Ch8~Ch15 must be equal.
rangeLow | Lower limit of range. Unit: mV/V.
rangeHigh | Higher limit of range. Unit: mV/V.

◆ AddChannel() [6/16]

void JY6313CoreOO::JY6313CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | std::vector< double > | excitationVoltage,
 |  | std::vector< double > | rangeLow,
 |  | double | rangeHigh )

Add a group of ratiometric measurement channels.

Parameters
chIDs | IDs of channels to add.
excitationVoltage | Excitation voltage in V, range: 1V~5V. The excitation voltages for Ch0~Ch7 must be equal, and for Ch8~Ch15 must be equal.
rangeLow | Lower limit of range. Unit: mV/V.
rangeHigh | Higher limit of range. Unit: mV/V.

◆ AddChannel() [7/16]

void JY6313CoreOO::JY6313CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | std::vector< double > | excitationVoltage,
 |  | std::vector< double > | rangeLow,
 |  | std::vector< double > | rangeHigh )

Add a group of ratiometric measurement channels.

Parameters
chnsId | IDs of channels to add.
excitationVoltage | Excitation voltage in V, range: 1V~5V. The excitation voltages for Ch0~Ch7 must be equal, and for Ch8~Ch15 must be equal.
rangeLow | Lower limit of range. Unit: mV/V.
rangeHigh | Higher limit of range. Unit: mV/V.

◆ AddChannel() [8/16]

void JY6313CoreOO::JY6313CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | std::vector< StrainConfiguration > | configuration,
 |  | double | excitationVoltage,
 |  | double | rangeLow,
 |  | double | rangeHigh,
 |  | double | gageNominalResistance,
 |  | double | gageFactor,
 |  | double | poissonFactor = 0.5,
 |  | double | leadWireResistance = 0.0 )

Add a group of strain measurement channel(s).

Parameters
chnsId | Channel ID
configuration | Strain bridge configuration
excitationVoltage | Excitation voltage in V, range: 1V~5V. The excitation voltages for Ch0~Ch7 must be equal, and for Ch8~Ch15 must be equal.
rangeLow | Lower limit of range. Unit: ue.
rangeHigh | Higher limit of range. Unit: ue.
gageNominalResistance | Gage nominal resistance in ohm. Common value include 120, 350, and 1k ohms.
gageFactor | Gage factor. Common value is 2.0.
poissonFactor | Material's poisson factor. Common value is 0.5.
leadWireResistance | Leadwire resistance in ohm. The accurate known resistance of the wires helps to reduce the error introduced by the wire resistance.

◆ AddChannel() [9/16]

void JY6313CoreOO::JY6313CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | std::vector< StrainConfiguration > | configuration,
 |  | std::vector< double > | excitationVoltage,
 |  | double | rangeLow,
 |  | double | rangeHigh,
 |  | double | gageNominalResistance,
 |  | double | gageFactor,
 |  | double | poissonFactor = 0.5,
 |  | double | leadWireResistance = 0.0 )

Add a group of strain measurement channel(s).

Parameters
chnsId | Channel ID
configuration | Strain bridge configuration
excitationVoltage | Excitation voltage in V, range: 1V~5V. The excitation voltages for Ch0~Ch7 must be equal, and for Ch8~Ch15 must be equal.
rangeLow | Lower limit of range. Unit: ue.
rangeHigh | Higher limit of range. Unit: ue.
gageNominalResistance | Gage nominal resistance in ohm. Common value include 120, 350, and 1k ohms.
gageFactor | Gage factor. Common value is 2.0.
poissonFactor | Material's poisson factor. Common value is 0.5.
leadWireResistance | Leadwire resistance in ohm. The accurate known resistance of the wires helps to reduce the error introduced by the wire resistance.

◆ AddChannel() [10/16]

void JY6313CoreOO::JY6313CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | std::vector< StrainConfiguration > | configuration,
 |  | std::vector< double > | excitationVoltage,
 |  | std::vector< double > | rangeLow,
 |  | double | rangeHigh,
 |  | double | gageNominalResistance,
 |  | double | gageFactor,
 |  | double | poissonFactor = 0.5,
 |  | double | leadWireResistance = 0.0 )

Add a group of strain measurement channel(s).

Parameters
chnsId | Channel ID
configuration | Strain bridge configuration
excitationVoltage | Excitation voltage in V, range: 1V~5V. The excitation voltages for Ch0~Ch7 must be equal, and for Ch8~Ch15 must be equal.
rangeLow | Lower limit of range. Unit: ue.
rangeHigh | Higher limit of range. Unit: ue.
gageNominalResistance | Gage nominal resistance in ohm. Common value include 120, 350, and 1k ohms.
gageFactor | Gage factor. Common value is 2.0.
poissonFactor | Material's poisson factor. Common value is 0.5.
leadWireResistance | Leadwire resistance in ohm. The accurate known resistance of the wires helps to reduce the error introduced by the wire resistance.

◆ AddChannel() [11/16]

void JY6313CoreOO::JY6313CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | std::vector< StrainConfiguration > | configuration,
 |  | std::vector< double > | excitationVoltage,
 |  | std::vector< double > | rangeLow,
 |  | std::vector< double > | rangeHigh,
 |  | double | gageNominalResistance,
 |  | double | gageFactor,
 |  | double | poissonFactor = 0.5,
 |  | double | leadWireResistance = 0.0 )

Add a group of strain measurement channel(s).

Parameters
chnsId | Channel ID
configuration | Strain bridge configuration
excitationVoltage | Excitation voltage in V, range: 1V~5V. The excitation voltages for Ch0~Ch7 must be equal, and for Ch8~Ch15 must be equal.
rangeLow | Lower limit of range. Unit: ue.
rangeHigh | Higher limit of range. Unit: ue.
gageNominalResistance | Gage nominal resistance in ohm. Common value include 120, 350, and 1k ohms.
gageFactor | Gage factor. Common value is 2.0.
poissonFactor | Material's poisson factor. Common value is 0.5.
leadWireResistance | Leadwire resistance in ohm. The accurate known resistance of the wires helps to reduce the error introduced by the wire resistance.

◆ AddChannel() [12/16]

void JY6313CoreOO::JY6313CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | std::vector< StrainConfiguration > | configuration,
 |  | std::vector< double > | excitationVoltage,
 |  | std::vector< double > | rangeLow,
 |  | std::vector< double > | rangeHigh,
 |  | std::vector< double > | gageNominalResistance,
 |  | double | gageFactor,
 |  | double | poissonFactor = 0.5,
 |  | double | leadWireResistance = 0.0 )

Add a group of strain measurement channel(s).

Parameters
chnsId | Channel ID
configuration | Strain bridge configuration
excitationVoltage | Excitation voltage in V, range: 1V~5V. The excitation voltages for Ch0~Ch7 must be equal, and for Ch8~Ch15 must be equal.
rangeLow | Lower limit of range. Unit: ue.
rangeHigh | Higher limit of range. Unit: ue.
gageNominalResistance | Gage nominal resistance in ohm. Common value include 120, 350, and 1k ohms.
gageFactor | Gage factor. Common value is 2.0.
poissonFactor | Material's poisson factor. Common value is 0.5.
leadWireResistance | Leadwire resistance in ohm. The accurate known resistance of the wires helps to reduce the error introduced by the wire resistance.

◆ AddChannel() [13/16]

void JY6313CoreOO::JY6313CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | std::vector< StrainConfiguration > | configuration,
 |  | std::vector< double > | excitationVoltage,
 |  | std::vector< double > | rangeLow,
 |  | std::vector< double > | rangeHigh,
 |  | std::vector< double > | gageNominalResistance,
 |  | std::vector< double > | gageFactor,
 |  | double | poissonFactor = 0.5,
 |  | double | leadWireResistance = 0.0 )

Add a group of strain measurement channel(s).

Parameters
chnsId | Channel ID
configuration | Strain bridge configuration
excitationVoltage | Excitation voltage in V, range: 1V~5V. The excitation voltages for Ch0~Ch7 must be equal, and for Ch8~Ch15 must be equal.
rangeLow | Lower limit of range. Unit: ue.
rangeHigh | Higher limit of range. Unit: ue.
gageNominalResistance | Gage nominal resistance in ohm. Common value include 120, 350, and 1k ohms.
gageFactor | Gage factor. Common value is 2.0.
poissonFactor | Material's poisson factor. Common value is 0.5.
leadWireResistance | Leadwire resistance in ohm. The accurate known resistance of the wires helps to reduce the error introduced by the wire resistance.

◆ AddChannel() [14/16]

void JY6313CoreOO::JY6313CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | std::vector< StrainConfiguration > | configuration,
 |  | std::vector< double > | excitationVoltage,
 |  | std::vector< double > | rangeLow,
 |  | std::vector< double > | rangeHigh,
 |  | std::vector< double > | gageNominalResistance,
 |  | std::vector< double > | gageFactor,
 |  | std::vector< double > | poissonFactor,
 |  | double | leadWireResistance = 0.0 )

Add a group of strain measurement channel(s).

Parameters
chnsId | Channel ID
configuration | Strain bridge configuration
excitationVoltage | Excitation voltage in V, range: 1V~5V. The excitation voltages for Ch0~Ch7 must be equal, and for Ch8~Ch15 must be equal.
rangeLow | Lower limit of range. Unit: ue.
rangeHigh | Higher limit of range. Unit: ue.
gageNominalResistance | Gage nominal resistance in ohm. Common value include 120, 350, and 1k ohms.
gageFactor | Gage factor. Common value is 2.0.
poissonFactor | Material's poisson factor. Common value is 0.5.
leadWireResistance | Leadwire resistance in ohm. The accurate known resistance of the wires helps to reduce the error introduced by the wire resistance.

◆ AddChannel() [15/16]

void JY6313CoreOO::JY6313CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | std::vector< StrainConfiguration > | configuration,
 |  | std::vector< double > | excitationVoltage,
 |  | std::vector< double > | rangeLow,
 |  | std::vector< double > | rangeHigh,
 |  | std::vector< double > | gageNominalResistance,
 |  | std::vector< double > | gageFactor,
 |  | std::vector< double > | poissonFactor,
 |  | std::vector< double > | leadWireResistance )

Add a group of strain measurement channel(s).

Parameters
chnsId | Channel ID
configuration | Strain bridge configuration
excitationVoltage | Excitation voltage in V, range: 1V~5V. The excitation voltages for Ch0~Ch7 must be equal, and for Ch8~Ch15 must be equal.
rangeLow | Lower limit of range. Unit: ue.
rangeHigh | Higher limit of range. Unit: ue.
gageNominalResistance | Gage nominal resistance in ohm. Common value include 120, 350, and 1k ohms.
gageFactor | Gage factor. Common value is 2.0.
poissonFactor | Material's poisson factor. Common value is 0.5.
leadWireResistance | Leadwire resistance in ohm. The accurate known resistance of the wires helps to reduce the error introduced by the wire resistance.

◆ AddChannel() [16/16]

void JY6313CoreOO::JY6313CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | StrainConfiguration | configuration,
 |  | double | excitationVoltage,
 |  | double | rangeLow,
 |  | double | rangeHigh,
 |  | double | gageNominalResistance,
 |  | double | gageFactor,
 |  | double | poissonFactor = 0.5,
 |  | double | leadWireResistance = 0.0 )

Add a group of strain measurement channel(s).

Parameters
chnsId | Channel ID
configuration | Strain bridge configuration
excitationVoltage | Excitation voltage in V, range: 1V~5V. The excitation voltages for Ch0~Ch7 must be equal, and for Ch8~Ch15 must be equal.
rangeLow | Lower limit of range. Unit: ue.
rangeHigh | Higher limit of range. Unit: ue.
gageNominalResistance | Gage nominal resistance in ohm. Common value include 120, 350, and 1k ohms.
gageFactor | Gage factor. Common value is 2.0.
poissonFactor | Material's poisson factor. Common value is 0.5.
leadWireResistance | Leadwire resistance in ohm. The accurate known resistance of the wires helps to reduce the error introduced by the wire resistance.

◆ GetConversionStatus()

std::vector< ConversionStatus * > & JY6313CoreOO::JY6313CoreOOAITask::GetConversionStatus ( )

Get conversion status on all enabled channels.

Returns
ADC conversion status.

◆ PerformOffsetNulling() [1/2]

void JY6313CoreOO::JY6313CoreOOAITask::PerformOffsetNulling ( int chID )

Perform offset nulling on one specified channel.

Parameters
chID Channel to perform nulling. Write -1 is perform nulling on all enabled channels.

◆ PerformOffsetNulling() [2/2]

void JY6313CoreOO::JY6313CoreOOAITask::PerformOffsetNulling ( std::vector< int > chIDs )

Perform offset nulling on a group of channels.

Parameters
chIDs Channels to perform nulling.

◆ PerformShuntCalibration() [1/3]

void JY6313CoreOO::JY6313CoreOOAITask::PerformShuntCalibration ( int chID )

Perform Shunt calibration on a group of channels with TB6313 connected and used.

Shunt calibration is for strain measurement, if the bridge configuration is QuadTypeI, no additional pin connection is required; For other bridge configurations, connect the JY6313 SC pin to the AI+ pin of the bridge.

Parameters
chID Channel to perform shunt calibration. Write -1 is perform shunt calibration on all enabled channels.

◆ PerformShuntCalibration() [2/3]

void JY6313CoreOO::JY6313CoreOOAITask::PerformShuntCalibration ( std::vector< int > chIDs )

Perform Shunt calibration on a group of channels with TB6313 connected and used.

Shunt calibration is for strain measurement, if the bridge configuration is QuadTypeI, no additional pin connection is required; For other bridge configurations, connect the JY6313 SC pin to the AI+ pin of the bridge.

Parameters
chIDs Channels to perform shunt calibration. These channles must already been added.

◆ PerformShuntCalibration() [3/3]

void JY6313CoreOO::JY6313CoreOOAITask::PerformShuntCalibration | ( | std::vector< int > | chIDs,
 |  | std::vector< double > | shuntResistance )

Perform Shunt calibration on a group of channels without TB6313 connected.

Shunt calibration is for strain measurement, shunt resistors must be connected between the SC pin of the JY6313 and the AI+ pin of the bridge.

Parameters
chIDs | Channels to perform shunt calibration. These channles must already been added.
shuntResistance | Resistance(unit: Ω) of the shunt resistor connected to each channel. The recommended resistance is 50k or 100k.

◆ ReadData() [1/3]

void JY6313CoreOO::JY6313CoreOOAITask::ReadData | ( | double * | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = -1 )

Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.

param name="pBuf">Data buffer

Parameters
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms. timeout =-1 keep waiting until finish

◆ ReadData() [2/3]

void JY6313CoreOO::JY6313CoreOOAITask::ReadData | ( | std::vector< double > & | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = -1 )

Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.

param name="pBuf">Data buffer

Parameters
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms. timeout =-1 keep waiting until finish

◆ ReadData() [3/3]

void JY6313CoreOO::JY6313CoreOOAITask::ReadData | ( | std::vector< std::vector< double > > & | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = -1 )

Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.

param name="pBuf">Data buffer

Parameters
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms. timeout =-1 keep waiting until finish

◆ ReadRatiometricData()

void JY6313CoreOO::JY6313CoreOOAITask::ReadRatiometricData | ( | std::vector< double > & | dataBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read voltage data and copy to buffer.

Parameters
dataBuf | User buffer used to read data.
samplesPerChannel | Number of samples per channel.
timeout | Timeout in ms before generate tiemout exception. When timeout is -1, wait until the amount of data is sufficient.

◆ ReadRawData() [1/2]

void JY6313CoreOO::JY6313CoreOOAITask::ReadRawData | ( | int * | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = -1 )

Read one or multi-channel raw data by columns and store it in a data buffer.

The buffer is pointed by C/C++ data type short.

Parameters
pBuf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [2/2]

void JY6313CoreOO::JY6313CoreOOAITask::ReadRawData | ( | std::vector< int > & | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = -1 )

Read one or multi-channel raw data by columns and store it in a data buffer.

The buffer is pointed by C/C++ data type short.

Parameters
pBuf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ ReadSinglePoint() [1/2]

void JY6313CoreOO::JY6313CoreOOAITask::ReadSinglePoint | ( | double & | readValue,
 |  | int | channel )

Read one sample for specified channel in register.

Available when Mode is AIMode.Single

Parameters
readValue | value read
channel | Specified channel numbers.

◆ ReadSinglePoint() [2/2]

void JY6313CoreOO::JY6313CoreOOAITask::ReadSinglePoint ( std::vector< double > & readValues )

Read raw one sample for all channels in register .

Available when Mode is AIMode.Single

Parameters
readValues Values read. Array length >= Channels.Count.

◆ RemoveChannel() [1/2]

void JY6313CoreOO::JY6313CoreOOAITask::RemoveChannel ( int chnId )

Delete the channel with the specified channel number.

chnId=- 1, all channels will be deleted

Parameters
chnId Channel number of the channel to be deleted

◆ RemoveChannel() [2/2]

void JY6313CoreOO::JY6313CoreOOAITask::RemoveChannel ( std::vector< int > chnId )

Delete a specific set of channels.

Parameters
chnId Channel number of the channel to be deleted

◆ SendSoftwareTrigger()

void JY6313CoreOO::JY6313CoreOOAITask::SendSoftwareTrigger ( )

Generate a software trigger signal generate a software trigger signal.

Returns

◆ Start()

void JY6313CoreOO::JY6313CoreOOAITask::Start ( )

Start Task.

Parameters

return void

Exceptions
JYDriverException When startup fails

◆ Stop()

void JY6313CoreOO::JY6313CoreOOAITask::Stop ( )

Stop Task.

Parameters

return void

Exceptions
JYDriverException When stop fails

Member Data Documentation

◆ Advanced

AIAdvanced* JY6313CoreOO::JY6313CoreOOAITask::Advanced

Analog Input Advance Parameter Class.

◆ AvailableSamples

JY6313CoreOOProperty<JY6313CoreOOAITask, uint64_t, JY6313CoreOOPropertyType::READ_ONLY> JY6313CoreOO::JY6313CoreOOAITask::AvailableSamples

Number of samples per channel that can be read in the buffer .

Valid when Mode is NOT AIMode.Single.

◆ BufLenInSamples

JY6313CoreOOProperty<JY6313CoreOOAITask, int, JY6313CoreOOPropertyType::READ_ONLY> JY6313CoreOO::JY6313CoreOOAITask::BufLenInSamples

Number of samples per channel can be storage in the buffer, the Property SamplesToAcquire must be less than or equal to this value.

◆ Channels

std::list<AIChannel*> JY6313CoreOO::JY6313CoreOOAITask::Channels

List of AI channels,(6313 support 16 channel)

◆ Device

JY6313CoreOODevice* JY6313CoreOO::JY6313CoreOOAITask::Device

Device.

◆ DisableDigitalTriggerDelay

bool JY6313CoreOO::JY6313CoreOOAITask::DisableDigitalTriggerDelay

Disalble calibration Enable.

◆ GroupDelay

JY6313CoreOOProperty<JY6313CoreOOAITask, double, JY6313CoreOOPropertyType::READ_ONLY> JY6313CoreOO::JY6313CoreOOAITask::GroupDelay

Group delay at current sampling rate and operating mode (unit: Samples).

◆ Mode

AIMode JY6313CoreOO::JY6313CoreOOAITask::Mode

AI acquisition mode, support Finite/Continuous/Single *.

◆ Operation_Mode

JY6313CoreOOProperty<JY6313CoreOOAITask, OperationMode, JY6313CoreOOPropertyType::READ_WRITE> JY6313CoreOO::JY6313CoreOOAITask::Operation_Mode

◆ SampleRate

JY6313CoreOOProperty<JY6313CoreOOAITask, double, JY6313CoreOOPropertyType::READ_WRITE> JY6313CoreOO::JY6313CoreOOAITask::SampleRate

Sampling rate per channel in Sa/s, the valid value range is 7.8125Sa/s to 80kSa/s.

◆ SamplesToAcquire

unsigned int JY6313CoreOO::JY6313CoreOOAITask::SamplesToAcquire

Number of samples to be read per channel.

Only valid when Mode is Finite*

◆ SignalExport

AISignalExport* JY6313CoreOO::JY6313CoreOOAITask::SignalExport

Export AI Signal Configuration.

◆ Sync

AISync* JY6313CoreOO::JY6313CoreOOAITask::Sync

Multi card synchronous configuration.

◆ TransferedSamples

JY6313CoreOOProperty<JY6313CoreOOAITask, uint64_t, JY6313CoreOOPropertyType::READ_ONLY> JY6313CoreOO::JY6313CoreOOAITask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT AIMode.Single.

◆ Trigger

AITrigger* JY6313CoreOO::JY6313CoreOOAITask::Trigger

AI Trigger Configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6313/JY6313CoreOOAITask.h


6313 C++ Programming Manual: JY6313CoreOO::StrainMeasInfo Class Reference

  • JY6313CoreOO
  • StrainMeasInfo
Public Member Functions | Public Attributes | List of all members
JY6313CoreOO::StrainMeasInfo Class Reference

Strain Measuement Infomation. More...

#include <JY6313CoreOOAITask.h>

Public Member Functions

StrainMeasInfo ()

Public Attributes

StrainConfiguration Configuration
Strain configuration.
double | GageNominalResistance
Gage nominal resistance.
double | GageFactor
Gage factor.
double | MaterialPoissonFactor
Material's Poisson factor.

Detailed Description

Strain Measuement Infomation.

Constructor & Destructor Documentation

◆ StrainMeasInfo()

JY6313CoreOO::StrainMeasInfo::StrainMeasInfo ( )

Member Data Documentation

◆ Configuration

StrainConfiguration JY6313CoreOO::StrainMeasInfo::Configuration

Strain configuration.

This parameter is valid only when measuring strain.

◆ GageFactor

double JY6313CoreOO::StrainMeasInfo::GageFactor

Gage factor.

◆ GageNominalResistance

double JY6313CoreOO::StrainMeasInfo::GageNominalResistance

Gage nominal resistance.

Common value include 120, 350, and 1k ohms.

◆ MaterialPoissonFactor

double JY6313CoreOO::StrainMeasInfo::MaterialPoissonFactor

Material's Poisson factor.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6313/JY6313CoreOOAITask.h


6313 C++ Programming Manual: JY6313CoreOO::BridgeCalInfo Class Reference

  • BridgeCalInfo
Public Member Functions | Public Attributes | List of all members
JY6313CoreOO::BridgeCalInfo Class Reference

Bridge Calibration Information. More...

#include <JY6313CoreOOAITask.h>

Public Member Functions

BridgeCalInfo ()

Public Attributes

double | LeadWireResistance
Leadwire resistance in Ω.
double * | NullingCoef
Offset nulling coefficients.
double | GainAdjustment
Gain adjustment value derived from shunt calibration.

Detailed Description

Bridge Calibration Information.

Constructor & Destructor Documentation

◆ BridgeCalInfo()

JY6313CoreOO::BridgeCalInfo::BridgeCalInfo ( )

Member Data Documentation

◆ GainAdjustment

double JY6313CoreOO::BridgeCalInfo::GainAdjustment

Gain adjustment value derived from shunt calibration.

◆ LeadWireResistance

double JY6313CoreOO::BridgeCalInfo::LeadWireResistance

Leadwire resistance in Ω.

◆ NullingCoef

double* JY6313CoreOO::BridgeCalInfo::NullingCoef

Offset nulling coefficients.

The length of the array is 2, the first coef is coarse offset, the second coef is fine offset. Unit: mV. TotalOffset = CoarseOffset + FineOffset / Gain * 1.5625

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6313/JY6313CoreOOAITask.h


6313 C++ Programming Manual: JY6313CoreOO::AIChannel Class Reference

  • AIChannel
Public Member Functions | Public Attributes | List of all members
JY6313CoreOO::AIChannel Class Reference

JY6313 AI channel configuration. More...

#include <JY6313CoreOOAITask.h>

Public Member Functions

AIChannel (int channelId, StrainConfiguration strainConfiguration, double excitationVoltage, double rangeLow, double rangeHigh, double gageNominalResistance, double GF, double poissonFactor, double leadwireResistance, void *deviceHandle)
AIChannel (int channelId, StrainConfiguration strainConfiguration, double excitationVoltage, AIGain gain, double gageNominalResistance, double GF, double poissonFactor, double leadwireResistance, void *deviceHandle)
AIChannel (int channelId, double excitationVoltage, double rangeLow, double rangeHigh, void *deviceHandle)
AIChannel (int channelId, double excitationVoltage, AIGain gain, void *deviceHandle)

Public Attributes

JY6313CoreOOProperty< AIChannel, int, JY6313CoreOOPropertyType::READ_ONLY > | ChannelID
Channel ID.
JY6313CoreOOProperty< AIChannel, int, JY6313CoreOOPropertyType::READ_ONLY > | BankID
The Bank ID to which the channel belongs.
JY6313CoreOOProperty< AIChannel, MeasurementType, JY6313CoreOOPropertyType::READ_ONLY > Measurement_Type
Measurement type of this channel.
JY6313CoreOOProperty< AIChannel, StrainMeasInfo *, JY6313CoreOOPropertyType::READ_ONLY > Strain
Parameters of the strain measurement infomation.
JY6313CoreOOProperty< AIChannel, int, JY6313CoreOOPropertyType::READ_ONLY > | BridgeConfigurationValue
JY6313CoreOOProperty< AIChannel, double, JY6313CoreOOPropertyType::READ_WRITE > | ExcitationVoltage
Birdge excitation voltage (Vex).
JY6313CoreOOProperty< AIChannel, double, JY6313CoreOOPropertyType::READ_ONLY > | ExcitationVoltageRequired
Required bridge excitation voltage.
JY6313CoreOOProperty< AIChannel, double, JY6313CoreOOPropertyType::READ_ONLY > | RangeLow
Lower limit of range.
JY6313CoreOOProperty< AIChannel, double, JY6313CoreOOPropertyType::READ_ONLY > | RangeHigh
Higher limit of range.
JY6313CoreOOProperty< AIChannel, BridgeCalInfo *, JY6313CoreOOPropertyType::READ_ONLY > BridgeCal
Parameters of bridge calibration infomation.
JY6313CoreOOProperty< AIChannel, double, JY6313CoreOOPropertyType::READ_ONLY > | RawDataScaleFactor
RawData * [this factor] = Input Value (V)
AIGain Gain
AI gain value.

Detailed Description

JY6313 AI channel configuration.

Constructor & Destructor Documentation

◆ AIChannel() [1/4]

JY6313CoreOO::AIChannel::AIChannel | ( | int | channelId,
 |  | StrainConfiguration | strainConfiguration,
 |  | double | excitationVoltage,
 |  | double | rangeLow,
 |  | double | rangeHigh,
 |  | double | gageNominalResistance,
 |  | double | GF,
 |  | double | poissonFactor,
 |  | double | leadwireResistance,
 |  | void * | deviceHandle )

◆ AIChannel() [2/4]

JY6313CoreOO::AIChannel::AIChannel | ( | int | channelId,
 |  | StrainConfiguration | strainConfiguration,
 |  | double | excitationVoltage,
 |  | AIGain | gain,
 |  | double | gageNominalResistance,
 |  | double | GF,
 |  | double | poissonFactor,
 |  | double | leadwireResistance,
 |  | void * | deviceHandle )

◆ AIChannel() [3/4]

JY6313CoreOO::AIChannel::AIChannel | ( | int | channelId,
 |  | double | excitationVoltage,
 |  | double | rangeLow,
 |  | double | rangeHigh,
 |  | void * | deviceHandle )

◆ AIChannel() [4/4]

JY6313CoreOO::AIChannel::AIChannel | ( | int | channelId,
 |  | double | excitationVoltage,
 |  | AIGain | gain,
 |  | void * | deviceHandle )

Member Data Documentation

◆ BankID

JY6313CoreOOProperty<AIChannel, int, JY6313CoreOOPropertyType::READ_ONLY> JY6313CoreOO::AIChannel::BankID

The Bank ID to which the channel belongs.

◆ BridgeCal

JY6313CoreOOProperty<AIChannel, BridgeCalInfo*, JY6313CoreOOPropertyType::READ_ONLY> JY6313CoreOO::AIChannel::BridgeCal

Parameters of bridge calibration infomation.

◆ BridgeConfigurationValue

JY6313CoreOOProperty<AIChannel, int, JY6313CoreOOPropertyType::READ_ONLY> JY6313CoreOO::AIChannel::BridgeConfigurationValue

◆ ChannelID

JY6313CoreOOProperty<AIChannel, int, JY6313CoreOOPropertyType::READ_ONLY> JY6313CoreOO::AIChannel::ChannelID

Channel ID.

◆ ExcitationVoltage

JY6313CoreOOProperty<AIChannel, double, JY6313CoreOOPropertyType::READ_WRITE> JY6313CoreOO::AIChannel::ExcitationVoltage

Birdge excitation voltage (Vex).

Unit: V. Range: 1V~5V.

◆ ExcitationVoltageRequired

JY6313CoreOOProperty<AIChannel, double, JY6313CoreOOPropertyType::READ_ONLY> JY6313CoreOO::AIChannel::ExcitationVoltageRequired

Required bridge excitation voltage.

◆ Gain

AIGain JY6313CoreOO::AIChannel::Gain

AI gain value.

This property is associated with RangeLow and RangeHigh. Reading this property will return the gain value in effect under the current RangeLow and RangeHigh.

◆ Measurement_Type

JY6313CoreOOProperty<AIChannel, MeasurementType, JY6313CoreOOPropertyType::READ_ONLY> JY6313CoreOO::AIChannel::Measurement_Type

Measurement type of this channel.

◆ RangeHigh

JY6313CoreOOProperty<AIChannel, double, JY6313CoreOOPropertyType::READ_ONLY> JY6313CoreOO::AIChannel::RangeHigh

Higher limit of range.

Unit: ue or mV/V, determined by whether this is a strain measurement or a ratiometric measurement channel.

◆ RangeLow

JY6313CoreOOProperty<AIChannel, double, JY6313CoreOOPropertyType::READ_ONLY> JY6313CoreOO::AIChannel::RangeLow

Lower limit of range.

Unit: ue or mV/V, determined by whether this is a strain measurement or a ratiometric measurement channel.

◆ RawDataScaleFactor

JY6313CoreOOProperty<AIChannel, double, JY6313CoreOOPropertyType::READ_ONLY> JY6313CoreOO::AIChannel::RawDataScaleFactor

RawData * [this factor] = Input Value (V)

◆ Strain

JY6313CoreOOProperty<AIChannel, StrainMeasInfo*, JY6313CoreOOPropertyType::READ_ONLY> JY6313CoreOO::AIChannel::Strain

Parameters of the strain measurement infomation.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6313/JY6313CoreOOAITask.h


6313 C++ Programming Manual: JY6313CoreOO::AITrigger Class Reference

  • AITrigger
Public Attributes | List of all members
JY6313CoreOO::AITrigger Class Reference

#include <JY6313CoreOOAITask.h>

Public Attributes

AITriggerType Type
AI trigger type.
AITriggerMode Mode
AI trigger mode.
AIDigitalTrigger * Digital
Digital Trigger Congfiguration.
AIAnalogTrigger * Analog
AI Analog Trigger.
int | ReTriggerCount
Number of repeat triggers.
unsigned int | PreTriggerSamples
AI pretrigger samples, must be less than or equal to JY6313aiTask.SamplesToAcquire.

Member Data Documentation

◆ Analog

AIAnalogTrigger* JY6313CoreOO::AITrigger::Analog

AI Analog Trigger.

Valid when Type is AITriggerType.Analog.

◆ Digital

AIDigitalTrigger* JY6313CoreOO::AITrigger::Digital

Digital Trigger Congfiguration.

Valid when Type is AITriggerType.Digital.

◆ Mode

AITriggerMode JY6313CoreOO::AITrigger::Mode

AI trigger mode.

enum Start/Reference. The default value is AITriggerMode.Start.

◆ PreTriggerSamples

unsigned int JY6313CoreOO::AITrigger::PreTriggerSamples

AI pretrigger samples, must be less than or equal to JY6313aiTask.SamplesToAcquire.

Valid when Mode is AITriggerMode.Reference. Pretrigger samples, must be greater than 0. Valid when Type is AITriggerType.Analog. Pretrigger samples, must be greater than 1. Valid when Type is AITriggerType.Digital.

◆ ReTriggerCount

int JY6313CoreOO::AITrigger::ReTriggerCount

Number of repeat triggers.

When 0 or 1 only trigger once, When -1 continuous retrigger until stop.

◆ Type

AITriggerType JY6313CoreOO::AITrigger::Type

AI trigger type.

enum Analog/Digital/Immediate/Soft. The default value is AITriggerType.Immediate.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6313/JY6313CoreOOAITask.h


6313 C++ Programming Manual: JY6313CoreOO::AIDigitalTrigger Class Reference

  • AIDigitalTrigger
Public Attributes | List of all members
JY6313CoreOO::AIDigitalTrigger Class Reference

#include <JY6313CoreOOAITask.h>

Public Attributes

AIDigitalTriggerSource Source
AI Digital Trigger source.
AIDigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Member Data Documentation

◆ Edge

AIDigitalTriggerEdge JY6313CoreOO::AIDigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

AIDigitalTriggerSource JY6313CoreOO::AIDigitalTrigger::Source

AI Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6313/JY6313CoreOOAITask.h


6313 C++ Programming Manual: JY6313CoreOO::AIAnalogHysteresisComparator Class Reference

  • AIAnalogHysteresisComparator
Public Attributes | List of all members
JY6313CoreOO::AIAnalogHysteresisComparator Class Reference

#include <JY6313CoreOOAITask.h>

Public Attributes

AIAnalogTriggerEdge Slope
AI Analog Trigger Edge.
double | HighThreshold
High Threshold.
double | LowThreshold
Low Threshold.

Member Data Documentation

◆ HighThreshold

double JY6313CoreOO::AIAnalogHysteresisComparator::HighThreshold

High Threshold.

◆ LowThreshold

double JY6313CoreOO::AIAnalogHysteresisComparator::LowThreshold

Low Threshold.

◆ Slope

AIAnalogTriggerEdge JY6313CoreOO::AIAnalogHysteresisComparator::Slope

AI Analog Trigger Edge.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6313/JY6313CoreOOAITask.h


6313 C++ Programming Manual: JY6313CoreOO::AIAnalogWindowComparator Class Reference

  • AIAnalogWindowComparator
Public Attributes | List of all members
JY6313CoreOO::AIAnalogWindowComparator Class Reference

#include <JY6313CoreOOAITask.h>

Public Attributes

AIAnalogWindowCondition Condition
AI Analog Window Condition.
double | HighThreshold
High Threshold.
double | LowThreshold
Low Threshold.

Member Data Documentation

◆ Condition

AIAnalogWindowCondition JY6313CoreOO::AIAnalogWindowComparator::Condition

AI Analog Window Condition.

◆ HighThreshold

double JY6313CoreOO::AIAnalogWindowComparator::HighThreshold

High Threshold.

◆ LowThreshold

double JY6313CoreOO::AIAnalogWindowComparator::LowThreshold

Low Threshold.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6313/JY6313CoreOOAITask.h


6313 C++ Programming Manual: JY6313CoreOO::AIAnalogEdgeComparator Class Reference

  • AIAnalogEdgeComparator
Public Attributes | List of all members
JY6313CoreOO::AIAnalogEdgeComparator Class Reference

#include <JY6313CoreOOAITask.h>

Public Attributes

AIAnalogTriggerEdge Slope
AI Analog Trigger Edge.
double Threshold
Threshold.

Member Data Documentation

◆ Slope

AIAnalogTriggerEdge JY6313CoreOO::AIAnalogEdgeComparator::Slope

AI Analog Trigger Edge.

◆ Threshold

double JY6313CoreOO::AIAnalogEdgeComparator::Threshold

Threshold.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6313/JY6313CoreOOAITask.h


6313 C++ Programming Manual: JY6313CoreOO::AIAnalogTrigger Class Reference

  • AIAnalogTrigger
Public Member Functions | Public Attributes | List of all members
JY6313CoreOO::AIAnalogTrigger Class Reference

#include <JY6313CoreOOAITask.h>

Public Member Functions

AIAnalogTrigger ()
AIAnalogTrigger (AIAnalogTriggerSource src, AIAnalogTriggerComparator comparator)
~AIAnalogTrigger ()

Public Attributes

AIAnalogTriggerSource Source
Analog Trigger source.
AIAnalogTriggerComparator Comparator
AI Analog Trigger Comparator.
AIAnalogEdgeComparator * Edge
AI Analog Edge Comparator.
AIAnalogHysteresisComparator * Hysteresis
AI Analog Hysteresis Comparatorr.
AIAnalogWindowComparator * Window
AI Analog Window Comparatorr.

Constructor & Destructor Documentation

◆ AIAnalogTrigger() [1/2]

JY6313CoreOO::AIAnalogTrigger::AIAnalogTrigger ( )

◆ AIAnalogTrigger() [2/2]

JY6313CoreOO::AIAnalogTrigger::AIAnalogTrigger | ( | AIAnalogTriggerSource | src,
 |  | AIAnalogTriggerComparator | comparator )

◆ ~AIAnalogTrigger()

JY6313CoreOO::AIAnalogTrigger::~AIAnalogTrigger ( )

Member Data Documentation

◆ Comparator

AIAnalogTriggerComparator JY6313CoreOO::AIAnalogTrigger::Comparator

AI Analog Trigger Comparator.

◆ Edge

AIAnalogEdgeComparator* JY6313CoreOO::AIAnalogTrigger::Edge

AI Analog Edge Comparator.

◆ Hysteresis

AIAnalogHysteresisComparator* JY6313CoreOO::AIAnalogTrigger::Hysteresis

AI Analog Hysteresis Comparatorr.

◆ Source

AIAnalogTriggerSource JY6313CoreOO::AIAnalogTrigger::Source

Analog Trigger source.

◆ Window

AIAnalogWindowComparator* JY6313CoreOO::AIAnalogTrigger::Window

AI Analog Window Comparatorr.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6313/JY6313CoreOOAITask.h


6313 C++ Programming Manual: JY6313CoreOO::AISignalExport Class Reference

  • AISignalExport
Public Member Functions | Public Attributes | List of all members
JY6313CoreOO::AISignalExport Class Reference

#include <JY6313CoreOOAITask.h>

Public Member Functions

void | Add (AISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (AISignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Public Attributes

JY6313CoreOOProperty< AISignalExport, std::map< SignalExportDestination, AISignalExportSource > *, JY6313CoreOOPropertyType::READ_ONLY > Destination
Export Signal List.

Member Function Documentation

◆ Add() [1/2]

void JY6313CoreOO::AISignalExport::Add | ( | AISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | AI Signal Source
destination | Export Desination

◆ Add() [2/2]

void JY6313CoreOO::AISignalExport::Add | ( | AISignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | AI Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JY6313CoreOO::AISignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY6313CoreOO::AISignalExport::ClearAll ( )

Clear All Signal Export.

Member Data Documentation

◆ Destination

JY6313CoreOOProperty<AISignalExport, std::map<SignalExportDestination, AISignalExportSource>*, JY6313CoreOOPropertyType::READ_ONLY> JY6313CoreOO::AISignalExport::Destination

Export Signal List.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6313/JY6313CoreOOAITask.h


6313 C++ Programming Manual: JY6313CoreOO::PowerLineRejection Class Reference

  • PowerLineRejection
Public Attributes | List of all members
JY6313CoreOO::PowerLineRejection Class Reference

Power Line Rejection Parameters Class. More...

#include <JY6313CoreOOAITask.h>

Public Attributes

PowerLineFrequency Frequency
Power Line Rejection Frequency Preference.

Detailed Description

Power Line Rejection Parameters Class.

Member Data Documentation

◆ Frequency

PowerLineFrequency JY6313CoreOO::PowerLineRejection::Frequency

Power Line Rejection Frequency Preference.

Used to determine whether the filter should preferentially reject at 50Hz or 60Hz.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6313/JY6313CoreOOAITask.h


6313 C++ Programming Manual: JY6313CoreOO::AIAdvanced Class Reference

  • AIAdvanced
Public Attributes | List of all members
JY6313CoreOO::AIAdvanced Class Reference

#include <JY6313CoreOOAITask.h>

Public Attributes

JY6313CoreOOProperty< AIAdvanced, PowerLineRejection *, JY6313CoreOOPropertyType::READ_WRITE > PowerLine_Rejection
Power line rejection configuration.

Member Data Documentation

◆ PowerLine_Rejection

JY6313CoreOOProperty<AIAdvanced, PowerLineRejection*, JY6313CoreOOPropertyType::READ_WRITE> JY6313CoreOO::AIAdvanced::PowerLine_Rejection

Power line rejection configuration.

This configuration only affects the offset nulling process.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6313/JY6313CoreOOAITask.h


6313 C++ Programming Manual: JY6313CoreOO::AISync Class Reference

  • AISync
Public Attributes | List of all members
JY6313CoreOO::AISync Class Reference

Configure sync signal. More...

#include <JY6313CoreOOAITask.h>

Public Attributes

SyncTopology Topology
Sync Topology Configuration.
SyncTerminal Terminal
Sync Trigger Signal Routing Terminal.
JY6313CoreOOProperty< AISync, SyncState, JY6313CoreOOPropertyType::READ_ONLY > State
Sync State.

Detailed Description

Configure sync signal.

Member Data Documentation

◆ State

JY6313CoreOOProperty<AISync, SyncState, JY6313CoreOOPropertyType::READ_ONLY> JY6313CoreOO::AISync::State

Sync State.

Only valid when this is a Slave device.

◆ Terminal

SyncTerminal JY6313CoreOO::AISync::Terminal

Sync Trigger Signal Routing Terminal.

◆ Topology

SyncTopology JY6313CoreOO::AISync::Topology

Sync Topology Configuration.

The default value is SyncTopology.Independent.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6313/JY6313CoreOOAITask.h


6313 C++ Programming Manual: JY6313CoreOO::DeviceMiscellaneousParam Class Reference

  • DeviceMiscellaneousParam
Public Member Functions | Public Attributes | List of all members
JY6313CoreOO::DeviceMiscellaneousParam Class Reference

Device miscellaneous param. More...

#include <JY6313CoreOOAITask.h>

Public Member Functions

DeviceMiscellaneousParam (void *handle)
默认所有校准都开启.

Public Attributes

JY6313CoreOOProperty< DeviceMiscellaneousParam, void *, JY6313CoreOOPropertyType::READ_WRITE > | Handle
JY6313CoreOOProperty< DeviceMiscellaneousParam, bool, JY6313CoreOOPropertyType::READ_WRITE > | DisableAICalibration
JY6313CoreOOProperty< DeviceMiscellaneousParam, bool, JY6313CoreOOPropertyType::READ_WRITE > | DisableAIFlatnessCalibration
JY6313CoreOOProperty< DeviceMiscellaneousParam, bool, JY6313CoreOOPropertyType::READ_WRITE > | DisableTBCalibration

Detailed Description

Device miscellaneous param.

Constructor & Destructor Documentation

◆ DeviceMiscellaneousParam()

JY6313CoreOO::DeviceMiscellaneousParam::DeviceMiscellaneousParam ( void * handle )

默认所有校准都开启.

Parameters
device

Member Data Documentation

◆ DisableAICalibration

JY6313CoreOOProperty<DeviceMiscellaneousParam, bool, JY6313CoreOOPropertyType::READ_WRITE> JY6313CoreOO::DeviceMiscellaneousParam::DisableAICalibration

◆ DisableAIFlatnessCalibration

JY6313CoreOOProperty<DeviceMiscellaneousParam, bool, JY6313CoreOOPropertyType::READ_WRITE> JY6313CoreOO::DeviceMiscellaneousParam::DisableAIFlatnessCalibration

◆ DisableTBCalibration

JY6313CoreOOProperty<DeviceMiscellaneousParam, bool, JY6313CoreOOPropertyType::READ_WRITE> JY6313CoreOO::DeviceMiscellaneousParam::DisableTBCalibration

◆ Handle

JY6313CoreOOProperty<DeviceMiscellaneousParam, void*, JY6313CoreOOPropertyType::READ_WRITE> JY6313CoreOO::DeviceMiscellaneousParam::Handle
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6313/JY6313CoreOOAITask.h


6313 C++ Programming Manual: JY6313CoreOO::JY6313Miscellaneous Class Reference

  • JY6313Miscellaneous
Static Public Member Functions | List of all members
JY6313CoreOO::JY6313Miscellaneous Class Reference

JY6313 Miscellaneous parameters. More...

#include <JY6313CoreOOAITask.h>

Static Public Member Functions

static void | SetAICalibrationState (void *handle, bool disableCalibration)
Set AI calibration state.
static bool | GetAICalibrationState (void *handle)
Return true if AI calibration of device is disabled.
static bool | GetAIFlatnessCalibrationState (void *handle)
Return true if AI flatness calibration (Bessel digital compensation filter) of device is disabled.
static void | SetAIFlatnessCalibrationState (void *handle, bool disableFlatnessCalibration)
Set AI flatness calibration state.
static void | SetTBCalibrationState (void *handle, bool disableTBCalibration)
Set Terminal Block calibration state.
static bool | GetTBCalibrationState (void *handle)
Return true if Terminal Block calibration of device is disabled.

Detailed Description

JY6313 Miscellaneous parameters.

Member Function Documentation

◆ GetAICalibrationState()

static bool JY6313CoreOO::JY6313Miscellaneous::GetAICalibrationState ( void * handle )
static

Return true if AI calibration of device is disabled.

Parameters
device
Returns
Return true if AI calibration of device is disabled.

◆ GetAIFlatnessCalibrationState()

static bool JY6313CoreOO::JY6313Miscellaneous::GetAIFlatnessCalibrationState ( void * handle )
static

Return true if AI flatness calibration (Bessel digital compensation filter) of device is disabled.

Parameters
device
Returns
Return true if AI flatness calibration (Bessel digital compensation filter) of device is disabled.

◆ GetTBCalibrationState()

static bool JY6313CoreOO::JY6313Miscellaneous::GetTBCalibrationState ( void * handle )
static

Return true if Terminal Block calibration of device is disabled.

Parameters
device
Returns
Return true if Terminal Block calibration of device is disabled.

◆ SetAICalibrationState()

static void JY6313CoreOO::JY6313Miscellaneous::SetAICalibrationState | ( | void * | handle,
 |  | bool | disableCalibration )
 static

Set AI calibration state.

Parameters
device
disableCalibration AI calibration of device is disabled when set as true. The default value is false.

◆ SetAIFlatnessCalibrationState()

static void JY6313CoreOO::JY6313Miscellaneous::SetAIFlatnessCalibrationState | ( | void * | handle,
 |  | bool | disableFlatnessCalibration )
 static

Set AI flatness calibration state.

Parameters
device
disableFlatnessCalibration AI flatness calibration (Bessel digital compensation filter) of device is disabled when set as true. The default value is false.

◆ SetTBCalibrationState()

static void JY6313CoreOO::JY6313Miscellaneous::SetTBCalibrationState | ( | void * | handle,
 |  | bool | disableTBCalibration )
 static

Set Terminal Block calibration state.

Parameters
device
disableTBCalibration Teminal block calibration of device is disabled when set as true. The default value is false.
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6313/JY6313CoreOOAITask.h


6313 C++ Programming Manual: JY6313CoreOO::ConversionStatus Class Reference

  • ConversionStatus
Public Member Functions | Public Attributes | List of all members
JY6313CoreOO::ConversionStatus Class Reference

ADC Convesion Status Class. More...

#include <JY6313CoreOOAITask.h>

Public Member Functions

ConversionStatus (int header)
void Update (int header)

Public Attributes

JY6313CoreOOProperty< ConversionStatus, bool, JY6313CoreOOPropertyType::READ_ONLY > | ErrorFlagged
The error flagged bit indicates that a serious error has occurred.
JY6313CoreOOProperty< ConversionStatus, bool, JY6313CoreOOPropertyType::READ_ONLY > | CRCError
CRC not match.
JY6313CoreOOProperty< ConversionStatus, bool, JY6313CoreOOPropertyType::READ_ONLY > | FilterSuturated
The filter saturated bit indicates that the filter output is clipping at either positive or negative full scale.
JY6313CoreOOProperty< ConversionStatus, int, JY6313CoreOOPropertyType::READ_ONLY > | ChannelID
The channel ID bits indicate the ADC channel from which the succeeding conversion status originates.

Detailed Description

ADC Convesion Status Class.

Constructor & Destructor Documentation

◆ ConversionStatus()

JY6313CoreOO::ConversionStatus::ConversionStatus ( int header )

Member Function Documentation

◆ Update()

void JY6313CoreOO::ConversionStatus::Update ( int header )

Member Data Documentation

◆ ChannelID

JY6313CoreOOProperty<ConversionStatus, int, JY6313CoreOOPropertyType::READ_ONLY> JY6313CoreOO::ConversionStatus::ChannelID

The channel ID bits indicate the ADC channel from which the succeeding conversion status originates.

◆ CRCError

JY6313CoreOOProperty<ConversionStatus, bool, JY6313CoreOOPropertyType::READ_ONLY> JY6313CoreOO::ConversionStatus::CRCError

CRC not match.

◆ ErrorFlagged

JY6313CoreOOProperty<ConversionStatus, bool, JY6313CoreOOPropertyType::READ_ONLY> JY6313CoreOO::ConversionStatus::ErrorFlagged

The error flagged bit indicates that a serious error has occurred.

This bit indicatesthat the external clock is not detected, a memory map bit has unexpectedly changed state, or an internal CRC error has been detected.

◆ FilterSuturated

JY6313CoreOOProperty<ConversionStatus, bool, JY6313CoreOOPropertyType::READ_ONLY> JY6313CoreOO::ConversionStatus::FilterSuturated

The filter saturated bit indicates that the filter output is clipping at either positive or negative full scale.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6313/JY6313CoreOOAITask.h


6313 C++ Programming Manual: JY6313CoreOO Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Enumerations | Functions
JY6313CoreOO Namespace Reference

Classes

class | AIAdvanced
class | AIAnalogEdgeComparator
class | AIAnalogHysteresisComparator
class | AIAnalogTrigger
class | AIAnalogWindowComparator
class | AIChannel
JY6313 AI channel configuration. More...
class | AIDigitalTrigger
class | AISignalExport
class | AISync
Configure sync signal. More...
class | AITrigger
class | BankConfiguration
Configuration indexed by Bank. More...
class | BridgeCalInfo
Bridge Calibration Information. More...
class | ConversionStatus
ADC Convesion Status Class. More...
class | DeviceMiscellaneousParam
Device miscellaneous param. More...
class | DeviceStatus
Device Status. More...
class | ExternalReferenceClock
External Reference Clcok Terminal. More...
struct | FirmDriveInfo
class | JY6313CoreOOAITask
aiTask类 More...
class | JY6313CoreOODevice
class | JY6313CoreOOLog
class | JY6313CoreOOProperty
属性模板类 More...
class | JY6313CoreOOReferenceClock
class | JY6313DeviceInfo
Device Info. More...
class | JY6313Miscellaneous
JY6313 Miscellaneous parameters. More...
class | JYDriverException
class | PauseTrigger
Pause trigger configuration class. More...
class | PowerLineRejection
Power Line Rejection Parameters Class. More...
class | StrainMeasInfo
Strain Measuement Infomation. More...

Enumerations

enum class | AIMode { Finite = JY6313Import::JY6313_AI_Finite , Continuous = JY6313Import::JY6313_AI_Continuous , Single = JY6313Import::JY6313_AI_Single }
enum class | ChannelRangeAssignMode { RangeLowHighFirst = 0 , GainFirst = 1 }
enum class | MeasurementType { Strain , Ratiometric }
Measurement type of channel. More...
enum class StrainConfiguration {
QuarterBridgeI = 0 , QuarterBridgeII = 1 , HalfBridgeI = 2 , HalfBridgeII = 3 ,
FullBridgeI = 4 , FullBridgeII = 5 , FullBridgeIII = 6
}
Strain measurement configuration. More...
enum class AIGain {
x6p25 = 0 , x12p5 = 1 , x25 = 2 , x50 = 3 ,
x100 = 4
}
AI gain. More...
enum class | AISampleClockSource { Internal , External }
enum class | AITriggerType { Immediate = JY6313Import::JY6313_TriggerType_Immediately , Digital = JY6313Import::JY6313_TriggerType_Digital , Soft = JY6313Import::JY6313_TriggerType_Software , Analog = JY6313Import::JY6313_TriggerType_Analog }
AI trigger type enum type. More...
enum class | AITriggerMode { Start , Reference }
AI trigger mode enum type. More...
enum class AIAnalogTriggerSource {
Channel_0 , Channel_1 , Channel_2 , Channel_3 ,
Channel_4 , Channel_5 , Channel_6 , Channel_7 ,
Channel_8 , Channel_9 , Channel_10 , Channel_11 ,
Channel_12 , Channel_13 , Channel_14 , Channel_15
}
enum class AIDigitalTriggerSource {
Ext_Trig = JY6313Import::JY6313_DigitalTriggerSource_ExtTrg , PXI_Trig0 = JY6313Import::JY6313_DigitalTriggerSource_BUS_0 , PXI_Trig1 = JY6313Import::JY6313_DigitalTriggerSource_BUS_1 , PXI_Trig2 = JY6313Import::JY6313_DigitalTriggerSource_BUS_2 ,
PXI_Trig3 = JY6313Import::JY6313_DigitalTriggerSource_BUS_3 , PXI_Trig4 = JY6313Import::JY6313_DigitalTriggerSource_BUS_4 , PXI_Trig5 = JY6313Import::JY6313_DigitalTriggerSource_BUS_5 , PXI_Trig6 = JY6313Import::JY6313_DigitalTriggerSource_BUS_6 ,
PXI_Trig7 = JY6313Import::JY6313_DigitalTriggerSource_BUS_7
}
enum class | AIDigitalTriggerEdge { Rising = 0x0 , Falling = 0x1 }
enum class | AIAnalogTriggerEdge { Rising , Falling }
enum class | AIAnalogWindowCondition { Entering , Leaving }
AI Analog Window Trigger Condition. More...
enum class | AIAnalogTriggerComparator { Edge , Hysteresis , Window }
AI Analog Trigger Comparator. More...
enum class AISignalExportSource {
SampleClock = JY6313Import::JY6313_ExportSource_SampleClock , Sync = JY6313Import::JY6313_ExportSource_SyncPulse , ReadyForTrig = JY6313Import::JY6313_ExportSource_ReadyForTrig , Trig = JY6313Import::JY6313_ExportSource_Trig ,
EndOfRecord = JY6313Import::JY6313_ExportSource_EndOfRecord , EndOfAcquisition = JY6313Import::JY6313_ExportSource_EndOfAcquisition
}
AI Signal Export Source Enum. More...
enum class | PowerLineFrequency { _50Hz = 0 , _60Hz = 1 }
enum class | SyncTopology { Independent = JY6313Import::JY6313_SyncMode_Sole , Master = JY6313Import::JY6313_SyncMode_Master , Slave = JY6313Import::JY6313_SyncMode_Slave }
Synchronization board configuration. More...
enum class SyncTerminal {
Ext_Trig = JY6313Import::JY6313_DigitalTriggerSource_ExtTrg , PXI_Trig0 = JY6313Import::JY6313_DigitalTriggerSource_BUS_0 , PXI_Trig1 = JY6313Import::JY6313_DigitalTriggerSource_BUS_1 , PXI_Trig2 = JY6313Import::JY6313_DigitalTriggerSource_BUS_2 ,
PXI_Trig3 = JY6313Import::JY6313_DigitalTriggerSource_BUS_3 , PXI_Trig4 = JY6313Import::JY6313_DigitalTriggerSource_BUS_4 , PXI_Trig5 = JY6313Import::JY6313_DigitalTriggerSource_BUS_5 , PXI_Trig6 = JY6313Import::JY6313_DigitalTriggerSource_BUS_6 ,
PXI_Trig7 = JY6313Import::JY6313_DigitalTriggerSource_BUS_7
}
Multi-device sync signal in/out terminal. More...
enum class | SyncState { WaitingSync , Synchronized , Invalid }
enum class | OperationMode { Auto = 0 , Normal = 1 , LowLatency = 2 }
enum class | JY6313CoreOOPropertyType { READ_ONLY = 1 , WRITE_ONLY = 2 , READ_WRITE = 3 }
enum class JYDriverExceptionPublic {
Success = 0 , ErrorCodeOffset_Device = -10000 , Error_OpenDeviceFailed = ErrorCodeOffset_Device - 1 , Error_CloseDeviceFailed = ErrorCodeOffset_Device - 2 ,
Error_ResetDeviceFailed = ErrorCodeOffset_Device - 3 , Error_InitDeviceFailed = ErrorCodeOffset_Device - 4 , Error_ActivateDeviceFailed = ErrorCodeOffset_Device - 5 , Error_DeviceSlotNumberInvalid = ErrorCodeOffset_Device - 6 ,
Error_DeviceNameInvalid = ErrorCodeOffset_Device - 7 , Error_DeviceHandleInvalid = ErrorCodeOffset_Device - 8 , Error_InitEEPROMFailed = ErrorCodeOffset_Device - 9 , Error_ReadEEPROMFailed = ErrorCodeOffset_Device - 10 ,
Error_WriteEEPROMFailed = ErrorCodeOffset_Device - 11 , Error_GetDeviceAttributeFailed = ErrorCodeOffset_Device - 12 , Error_SetDeviceAttributeFailed = ErrorCodeOffset_Device - 13 , Error_GetDeviceCalibrationDataFailed = ErrorCodeOffset_Device - 14 ,
Error_ReleaseDeviceResourceFailed = ErrorCodeOffset_Device - 15 , Error_DevicePropertyInvalid = ErrorCodeOffset_Device - 16 , ErrorCodeOffset_General = -10100 , Error_ParamInvalid = ErrorCodeOffset_General - 1 ,
Error_UnsupportedOperation = ErrorCodeOffset_General - 2 , Error_BufferSizeInvalid = ErrorCodeOffset_General - 3 , Error_Timeout = ErrorCodeOffset_General - 4 , Error_TaskNotStartedYet = ErrorCodeOffset_General - 5 ,
Error_MallocMemoryFailed = ErrorCodeOffset_General - 6 , Error_BufferPointerIsNull = ErrorCodeOffset_General - 7 , Error_DataAddressIsNull = ErrorCodeOffset_General - 8 , Error_SyncNotSupported = ErrorCodeOffset_General - 9 ,
ErrorCodeOffset_Rx = -10200 , Error_Rx_InitFailed = ErrorCodeOffset_Rx - 1 , Error_Rx_BufferOverflow = ErrorCodeOffset_Rx - 2 , Error_Rx_ReadDataTimeout = ErrorCodeOffset_Rx - 3 ,
Error_Rx_UnsupportedSampleMode = ErrorCodeOffset_Rx - 4 , Error_Rx_SamplesToAcquireInvalid = ErrorCodeOffset_Rx - 5 , Error_Rx_SamplesToAcquireNotLessPreTriggerSamples = ErrorCodeOffset_Rx - 6 , Error_Rx_PreTriggerSamplesInvalid = ErrorCodeOffset_Rx - 7 ,
Error_Rx_SampleRateInvalid = ErrorCodeOffset_Rx - 8 , Error_Rx_ConvertRateInvalid = ErrorCodeOffset_Rx - 9 , ErrorCodeOffset_Tx = -10300 , Error_Tx_InitFailed = ErrorCodeOffset_Tx - 1 ,
Error_Tx_BufferUnderflow = ErrorCodeOffset_Tx - 2 , Error_Tx_WriteDataTimeout = ErrorCodeOffset_Tx - 3 , Error_Tx_UnsupportedUpdateMode = ErrorCodeOffset_Tx - 4 , Error_Tx_UpdateRateInvalid = ErrorCodeOffset_Tx - 5 ,
Error_Tx_SamplesToUpdateInvalid = ErrorCodeOffset_Tx - 6 , Error_Tx_NoDataWrittenYet = ErrorCodeOffset_Tx - 7 , ErrorCodeOffset_Trigger = -10400 , Error_Trg_RetriggerCountInvalid = ErrorCodeOffset_Trigger - 1 ,
Error_Trg_TriggerDelayInvalid = ErrorCodeOffset_Trigger - 2 , Error_Trg_TriggerTypeInvalid = ErrorCodeOffset_Trigger - 3 , Error_Trg_TriggerModeInvalid = ErrorCodeOffset_Trigger - 4 , Error_Trg_DigitalTriggerSourceInvalid = ErrorCodeOffset_Trigger - 5 ,
Error_Trg_AnalogTriggerSourceInvalid = ErrorCodeOffset_Trigger - 6 , Error_Trg_AnalogTriggerThresholdInvalid = ErrorCodeOffset_Trigger - 7 , Error_Trg_NotWaitingForSoftwareTrigger = ErrorCodeOffset_Trigger - 8 , Error_Trg_SampleModeAndTriggerModeNotMatch = ErrorCodeOffset_Trigger - 9 ,
ErrorCodeOffset_Clock = -10500 , Error_Clk_RefClkSourceInvalid = ErrorCodeOffset_Clock - 1 , Error_Clk_TimebaseSourceInvalid = ErrorCodeOffset_Clock - 2 , Error_Clk_SampleClockSourceInvalid = ErrorCodeOffset_Clock - 3 ,
Error_Clk_ClkMuxFaliedToSelectTheTargetClk = ErrorCodeOffset_Clock - 4 , Error_Clk_PLLLockFailed = ErrorCodeOffset_Clock - 5 , Error_Clk_PLLOutputFreqInvalid = ErrorCodeOffset_Clock - 6 , ErrorCodeOffset_AIO = -10600 ,
Error_AIO_ChannelCountInvalid = ErrorCodeOffset_AIO - 1 , Error_AIO_ChannelIndexInvalid = ErrorCodeOffset_AIO - 2 , Error_AIO_InputOrOutputRangeInvalid = ErrorCodeOffset_AIO - 3 , Error_AIO_TerminalInvalid = ErrorCodeOffset_AIO - 4 ,
Error_AIO_CouplingInvalid = ErrorCodeOffset_AIO - 5 , ErrorCodeOffset_DIO = -10700 , Error_DIO_LineCountInvalid = ErrorCodeOffset_DIO - 1 , Error_DIO_LineIndexInvalid = ErrorCodeOffset_DIO - 2 ,
Error_DIO_PortCountInvalid = ErrorCodeOffset_DIO - 3 , Error_DIO_PortIndexInvalid = ErrorCodeOffset_DIO - 4 , ErrorCodeOffset_CIO = -10800 , Error_CIO_ChannelInvalid = ErrorCodeOffset_CIO - 1 ,
Error_CIO_ChannelIsReserved = ErrorCodeOffset_CIO - 2 , Error_CIO_InitDelayTooShort = ErrorCodeOffset_CIO - 3 , Error_CIO_SampleClkTypeDoesNotSupportFreqOrPeriodMeasure = ErrorCodeOffset_CIO - 4 , Error_CIO_SampleModeDoesNotSupportEncoder = ErrorCodeOffset_CIO - 5 ,
Error_CIO_MeasurementTimeout = ErrorCodeOffset_CIO - 6 , ErrorCodeOffset_PFI = -10900 , Error_PFI_LineInvalid = ErrorCodeOffset_PFI - 1 , Error_PFI_LineIsReserved = ErrorCodeOffset_PFI - 2 ,
Error_PXITrgger_LineInvalid = ErrorCodeOffset_PFI - 3 , Error_PXITrgger_LineIsReserved = ErrorCodeOffset_PFI - 4 , Buffer_Data_Overflow = -100 , Task_Has_Not_Started ,
The_task_has_started , InvalidParameter , The_Channel_ID_Is_Incorrect , Channel_Number_Parameter_Invalid ,
Sampele_Mode_Parameter_Invalid , Start_Task_Failed , Trigger_Parameter_ERROR , No_Channel_Added ,
Signal_Export_Destination_Invalid
}
enum class SignalExportDestination {
Ext_Trig = JY6313Import::JY6313_DigitalTriggerSource_ExtTrg , PXI_Trig0 = JY6313Import::JY6313_DigitalTriggerSource_BUS_0 , PXI_Trig1 = JY6313Import::JY6313_DigitalTriggerSource_BUS_1 , PXI_Trig2 = JY6313Import::JY6313_DigitalTriggerSource_BUS_2 ,
PXI_Trig3 = JY6313Import::JY6313_DigitalTriggerSource_BUS_3 , PXI_Trig4 = JY6313Import::JY6313_DigitalTriggerSource_BUS_4 , PXI_Trig5 = JY6313Import::JY6313_DigitalTriggerSource_BUS_5 , PXI_Trig6 = JY6313Import::JY6313_DigitalTriggerSource_BUS_6 ,
PXI_Trig7 = JY6313Import::JY6313_DigitalTriggerSource_BUS_7
}
enum class | OutputCompleteState { Zero , Hold }
Output Complete State. More...
enum class | LevelPolarity { LowLevel = 0 , HighLevel = 1 , None = 2 }
Level Polarity. More...
enum class | ExternalReferenceClockTerminal { PXIe_Clk100 = 0x1 }
enum class | ReferenceClockSource { Internal = 0 , External = 1 }
enum class | TerminalBlockType { General , TB6313 }
enum class JY6313CoreOOLogLevel {
DEBUG_LOG_LEVEL , INFO_LOG_LEVEL , WARN_LOG_LEVEL , ERROR_LOG_LEVEL ,
FATAL_LOG_LEVEL
}

Functions

double | GetGainValue (AIGain Gain)
std::string | GetSignalExportDestinationString (SignalExportDestination destination)

Enumeration Type Documentation

◆ AIAnalogTriggerComparator

enum class JY6313CoreOO::AIAnalogTriggerComparator
strong

AI Analog Trigger Comparator.

Enumerator
Edge | Edge Comparator.
Hysteresis | Hysteresis Comparator.
Window | Window Comparator.

◆ AIAnalogTriggerEdge

enum class JY6313CoreOO::AIAnalogTriggerEdge
strong
Enumerator
Rising | Rising.
Falling | Falling.

◆ AIAnalogTriggerSource

enum class JY6313CoreOO::AIAnalogTriggerSource
strong
Enumerator
Channel_0 | Channel 0.
Channel_1 | Channel 1.
Channel_2 | Channel 2.
Channel_3 | Channel 3.
Channel_4 | Channel 4.
Channel_5 | Channel 5.
Channel_6 | Channel 6.
Channel_7 | Channel 7.
Channel_8 | Channel 8.
Channel_9 | Channel 9.
Channel_10 | Channel 10.
Channel_11 | Channel 11.
Channel_12 | Channel 12.
Channel_13 | Channel 13.
Channel_14 | Channel 14.
Channel_15 | Channel 15.

◆ AIAnalogWindowCondition

enum class JY6313CoreOO::AIAnalogWindowCondition
strong

AI Analog Window Trigger Condition.

Enumerator
Entering | Rising.
Leaving | Falling.

◆ AIDigitalTriggerEdge

enum class JY6313CoreOO::AIDigitalTriggerEdge
strong
Enumerator
Rising | Rising.
Falling | Falling.

◆ AIDigitalTriggerSource

enum class JY6313CoreOO::AIDigitalTriggerSource
strong
Enumerator
Ext_Trig | External Trigger.
PXI_Trig0 | PXI Trigger 0.
PXI_Trig1 | PXI Trigger 1.
PXI_Trig2 | PXI Trigger 2.
PXI_Trig3 | PXI Trigger 3.
PXI_Trig4 | PXI Trigger 4.
PXI_Trig5 | PXI Trigger 5.
PXI_Trig6 | PXI Trigger 6.
PXI_Trig7 | PXI Trigger 7.

◆ AIGain

enum class JY6313CoreOO::AIGain
strong

AI gain.

Enumerator
x6p25 | x6.25
x12p5 | x12.5
x25 | x25
x50 | x50
x100 | x100

◆ AIMode

enum class JY6313CoreOO::AIMode
strong
Enumerator
Finite | Finite mode.
Continuous | Continuous mode.
Single | Single point mode.

◆ AISampleClockSource

enum class JY6313CoreOO::AISampleClockSource
strong
Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ AISignalExportSource

enum class JY6313CoreOO::AISignalExportSource
strong

AI Signal Export Source Enum.

Enumerator
SampleClock | AI Sample Clock.
Sync | Sync Signal From Master to Slave(s)
ReadyForTrig | Ready for Trigger.
Trig | Trigger Out.
EndOfRecord | End of Record.
EndOfAcquisition | End of Acquisition.

◆ AITriggerMode

enum class JY6313CoreOO::AITriggerMode
strong

AI trigger mode enum type.

Enumerator
Start | Start Trigger.
Reference | Reference Trigger，Valid when JY6313aiTask.Mode is AIMode.Finite

◆ AITriggerType

enum class JY6313CoreOO::AITriggerType
strong

AI trigger type enum type.

Enumerator
Immediate | Immediately, no trigger.
Digital | Digital trigger.
Soft | Software trigger.
Analog | Analog trigger.

◆ ChannelRangeAssignMode

enum class JY6313CoreOO::ChannelRangeAssignMode
strong
Enumerator
RangeLowHighFirst | 以量程上下限指定量程. 这是默认的方式.
GainFirst | 以增益挡位指定量程. 一般用于测试.

◆ ExternalReferenceClockTerminal

enum class JY6313CoreOO::ExternalReferenceClockTerminal
strong
Enumerator
PXIe_Clk100

PXIe_Clk100.

◆ JY6313CoreOOLogLevel

enum class JY6313CoreOO::JY6313CoreOOLogLevel
strong
Enumerator
DEBUG_LOG_LEVEL
INFO_LOG_LEVEL
WARN_LOG_LEVEL
ERROR_LOG_LEVEL
FATAL_LOG_LEVEL

◆ JY6313CoreOOPropertyType

enum class JY6313CoreOO::JY6313CoreOOPropertyType
strong
Enumerator
READ_ONLY
WRITE_ONLY
READ_WRITE

◆ JYDriverExceptionPublic

enum class JY6313CoreOO::JYDriverExceptionPublic
strong
Enumerator
Success |
ErrorCodeOffset_Device |
Error_OpenDeviceFailed |
Error_CloseDeviceFailed |
Error_ResetDeviceFailed |
Error_InitDeviceFailed |
Error_ActivateDeviceFailed |
Error_DeviceSlotNumberInvalid |
Error_DeviceNameInvalid |
Error_DeviceHandleInvalid |
Error_InitEEPROMFailed |
Error_ReadEEPROMFailed |
Error_WriteEEPROMFailed |
Error_GetDeviceAttributeFailed |
Error_SetDeviceAttributeFailed |
Error_GetDeviceCalibrationDataFailed |
Error_ReleaseDeviceResourceFailed |
Error_DevicePropertyInvalid |
ErrorCodeOffset_General |
Error_ParamInvalid |
Error_UnsupportedOperation |
Error_BufferSizeInvalid |
Error_Timeout |
Error_TaskNotStartedYet |
Error_MallocMemoryFailed |
Error_BufferPointerIsNull |
Error_DataAddressIsNull |
Error_SyncNotSupported |
ErrorCodeOffset_Rx |
Error_Rx_InitFailed |
Error_Rx_BufferOverflow |
Error_Rx_ReadDataTimeout |
Error_Rx_UnsupportedSampleMode |
Error_Rx_SamplesToAcquireInvalid |
Error_Rx_SamplesToAcquireNotLessPreTriggerSamples |
Error_Rx_PreTriggerSamplesInvalid |
Error_Rx_SampleRateInvalid |
Error_Rx_ConvertRateInvalid |
ErrorCodeOffset_Tx |
Error_Tx_InitFailed |
Error_Tx_BufferUnderflow |
Error_Tx_WriteDataTimeout |
Error_Tx_UnsupportedUpdateMode |
Error_Tx_UpdateRateInvalid |
Error_Tx_SamplesToUpdateInvalid |
Error_Tx_NoDataWrittenYet |
ErrorCodeOffset_Trigger |
Error_Trg_RetriggerCountInvalid |
Error_Trg_TriggerDelayInvalid |
Error_Trg_TriggerTypeInvalid |
Error_Trg_TriggerModeInvalid |
Error_Trg_DigitalTriggerSourceInvalid |
Error_Trg_AnalogTriggerSourceInvalid |
Error_Trg_AnalogTriggerThresholdInvalid |
Error_Trg_NotWaitingForSoftwareTrigger |
Error_Trg_SampleModeAndTriggerModeNotMatch |
ErrorCodeOffset_Clock |
Error_Clk_RefClkSourceInvalid |
Error_Clk_TimebaseSourceInvalid |
Error_Clk_SampleClockSourceInvalid |
Error_Clk_ClkMuxFaliedToSelectTheTargetClk |
Error_Clk_PLLLockFailed |
Error_Clk_PLLOutputFreqInvalid |
ErrorCodeOffset_AIO |
Error_AIO_ChannelCountInvalid |
Error_AIO_ChannelIndexInvalid |
Error_AIO_InputOrOutputRangeInvalid |
Error_AIO_TerminalInvalid |
Error_AIO_CouplingInvalid |
ErrorCodeOffset_DIO |
Error_DIO_LineCountInvalid |
Error_DIO_LineIndexInvalid |
Error_DIO_PortCountInvalid |
Error_DIO_PortIndexInvalid |
ErrorCodeOffset_CIO |
Error_CIO_ChannelInvalid |
Error_CIO_ChannelIsReserved |
Error_CIO_InitDelayTooShort |
Error_CIO_SampleClkTypeDoesNotSupportFreqOrPeriodMeasure |
Error_CIO_SampleModeDoesNotSupportEncoder |
Error_CIO_MeasurementTimeout |
ErrorCodeOffset_PFI |
Error_PFI_LineInvalid |
Error_PFI_LineIsReserved |
Error_PXITrgger_LineInvalid |
Error_PXITrgger_LineIsReserved |
Buffer_Data_Overflow | 缓存区数据溢出
Task_Has_Not_Started | 任务未开始
The_task_has_started | 任务已经开始，请先停止任务再进行操作
InvalidParameter | 无效的参数配置
The_Channel_ID_Is_Incorrect | 通道ID有误
Channel_Number_Parameter_Invalid | 通道参数配置无效
Sampele_Mode_Parameter_Invalid | 采样模式参数配置无效
Start_Task_Failed | 任务启动失败
Trigger_Parameter_ERROR | 触发参数配置有误
No_Channel_Added | 未添加通道
Signal_Export_Destination_Invalid | 信号输出目的地无效

◆ LevelPolarity

enum class JY6313CoreOO::LevelPolarity
strong

Level Polarity.

Enumerator
LowLevel | Low level.
HighLevel | High level.
None | No active polarity.

◆ MeasurementType

enum class JY6313CoreOO::MeasurementType
strong

Measurement type of channel.

Enumerator
Strain | Strain measuremnt, unit: ue.
Ratiometric | Ratiometric measurement, unit: mV/V.

◆ OperationMode

enum class JY6313CoreOO::OperationMode
strong
Enumerator
Auto | Auto Mode. The driver will use Normal mode if sample rate is greater than or equal to 500S/s, otherwise, use Low Latency mode.
Normal | Normal Mode. It has 0.4535*fs passband bandwidth, high latency (group delay). The supported sample rate ranges from 500Sa/s to 80kSa/s.
LowLatency | Low Latency Mode. It has 0.1*fs passband bandwidth, low latency (group delay). The supported sample rate ranges from 7.8125Sa/s to 4000Sa/s.

◆ OutputCompleteState

enum class JY6313CoreOO::OutputCompleteState
strong

Output Complete State.

Enumerator
Zero | Output Complete Zero.
Hold | Output Complete Hold in The last point.

◆ PowerLineFrequency

enum class JY6313CoreOO::PowerLineFrequency
strong
Enumerator
_50Hz | Power Line Frequency = 50Hz.
_60Hz | Power Line Frequency = 60Hz.

◆ ReferenceClockSource

enum class JY6313CoreOO::ReferenceClockSource
strong
Enumerator
Internal | Internal Reference Clock
External | External Reference Clock

◆ SignalExportDestination

enum class JY6313CoreOO::SignalExportDestination
strong
Enumerator
Ext_Trig | External Trigger.
PXI_Trig0 | PXI Trigger 0.
PXI_Trig1 | PXI Trigger 1.
PXI_Trig2 | PXI Trigger 2.
PXI_Trig3 | PXI Trigger 3.
PXI_Trig4 | PXI Trigger 4.
PXI_Trig5 | PXI Trigger 5.
PXI_Trig6 | PXI Trigger 6.
PXI_Trig7 | PXI Trigger 7.

◆ StrainConfiguration

enum class JY6313CoreOO::StrainConfiguration
strong

Strain measurement configuration.

Enumerator
QuarterBridgeI | Quarter-Bridge Type I, which has a single active gage.
QuarterBridgeII | Quarter-Bridge Type II, which has a single active gage and one dummy gage.
HalfBridgeI | Half-Bridge Type I, which has two active gages with one aligned with maximum principal strain and one Poisson gage.
HalfBridgeII | Half-Bridge Type II, which has two active gages with equal and opposite strains.
FullBridgeI | Full-Bridge Type I, which has four active gages with two pairs subjected to equal and opposite strains.
FullBridgeII | Full-Bridge Type II, which has four active gages with two aligned with maximum principal strain and two Poisson gages in adjacent arms.
FullBridgeIII | Full-Bridge Type III, which has four active gages with two aligned with maximum principal strain and two Poisson gages in opposite arms.

◆ SyncState

enum class JY6313CoreOO::SyncState
strong
Enumerator
WaitingSync | Waiting for Sync signal as a Slave device.
Synchronized | Already received Sync signal as a Slave device.
Invalid | This status is invalid when multi-card synchronization is not enabled or when the device is a Master device.

◆ SyncTerminal

enum class JY6313CoreOO::SyncTerminal
strong

Multi-device sync signal in/out terminal.

Enumerator
Ext_Trig | External Trigger.
PXI_Trig0 | PXI Trigger 0.
PXI_Trig1 | PXI Trigger 1.
PXI_Trig2 | PXI Trigger 2.
PXI_Trig3 | PXI Trigger 3.
PXI_Trig4 | PXI Trigger 4.
PXI_Trig5 | PXI Trigger 5.
PXI_Trig6 | PXI Trigger 6.
PXI_Trig7 | PXI Trigger 7.

◆ SyncTopology

enum class JY6313CoreOO::SyncTopology
strong

Synchronization board configuration.

Enumerator
Independent | Independent.
Master | As the master device in the master-slave synchronization.
Slave | As the slave card in the master-slave synchronization.

◆ TerminalBlockType

enum class JY6313CoreOO::TerminalBlockType
strong
Enumerator
General | General terminal block.
TB6313 | TB6313.

Function Documentation

◆ GetGainValue()

double JY6313CoreOO::GetGainValue ( AIGain Gain )

◆ GetSignalExportDestinationString()

std::string JY6313CoreOO::GetSignalExportDestinationString ( SignalExportDestination destination )
inline


6313 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/6313/JY6313CoreOOCommon.h File Reference

  • File List
  • File Members
  • COO
  • 6313
Classes | Namespaces | Macros | Enumerations | Functions | Variables
JY6313CoreOOCommon.h File Reference
#include <string>
#include <stdint.h>

Classes

class | JY6313CoreOO::JYDriverException
class | JY6313CoreOO::JY6313CoreOOProperty< ContainerClass, ValueType, propertyType >
属性模板类 More...
class | JY6313CoreOO::PauseTrigger
Pause trigger configuration class. More...
struct | JY6313CoreOO::FirmDriveInfo

Namespaces

namespace | JY6313Import
namespace | JY6313CoreOO

Macros

#define | EXTERN_C extern
Windows.
#define | JY6313CoreOO_API

Enumerations

enum class | JY6313CoreOO::JY6313CoreOOPropertyType { JY6313CoreOO::READ_ONLY = 1 , JY6313CoreOO::WRITE_ONLY = 2 , JY6313CoreOO::READ_WRITE = 3 }
enum class JY6313CoreOO::JYDriverExceptionPublic {
JY6313CoreOO::Success = 0 , JY6313CoreOO::ErrorCodeOffset_Device = -10000 , JY6313CoreOO::Error_OpenDeviceFailed = ErrorCodeOffset_Device - 1 , JY6313CoreOO::Error_CloseDeviceFailed = ErrorCodeOffset_Device - 2 ,
JY6313CoreOO::Error_ResetDeviceFailed = ErrorCodeOffset_Device - 3 , JY6313CoreOO::Error_InitDeviceFailed = ErrorCodeOffset_Device - 4 , JY6313CoreOO::Error_ActivateDeviceFailed = ErrorCodeOffset_Device - 5 , JY6313CoreOO::Error_DeviceSlotNumberInvalid = ErrorCodeOffset_Device - 6 ,
JY6313CoreOO::Error_DeviceNameInvalid = ErrorCodeOffset_Device - 7 , JY6313CoreOO::Error_DeviceHandleInvalid = ErrorCodeOffset_Device - 8 , JY6313CoreOO::Error_InitEEPROMFailed = ErrorCodeOffset_Device - 9 , JY6313CoreOO::Error_ReadEEPROMFailed = ErrorCodeOffset_Device - 10 ,
JY6313CoreOO::Error_WriteEEPROMFailed = ErrorCodeOffset_Device - 11 , JY6313CoreOO::Error_GetDeviceAttributeFailed = ErrorCodeOffset_Device - 12 , JY6313CoreOO::Error_SetDeviceAttributeFailed = ErrorCodeOffset_Device - 13 , JY6313CoreOO::Error_GetDeviceCalibrationDataFailed = ErrorCodeOffset_Device - 14 ,
JY6313CoreOO::Error_ReleaseDeviceResourceFailed = ErrorCodeOffset_Device - 15 , JY6313CoreOO::Error_DevicePropertyInvalid = ErrorCodeOffset_Device - 16 , JY6313CoreOO::ErrorCodeOffset_General = -10100 , JY6313CoreOO::Error_ParamInvalid = ErrorCodeOffset_General - 1 ,
JY6313CoreOO::Error_UnsupportedOperation = ErrorCodeOffset_General - 2 , JY6313CoreOO::Error_BufferSizeInvalid = ErrorCodeOffset_General - 3 , JY6313CoreOO::Error_Timeout = ErrorCodeOffset_General - 4 , JY6313CoreOO::Error_TaskNotStartedYet = ErrorCodeOffset_General - 5 ,
JY6313CoreOO::Error_MallocMemoryFailed = ErrorCodeOffset_General - 6 , JY6313CoreOO::Error_BufferPointerIsNull = ErrorCodeOffset_General - 7 , JY6313CoreOO::Error_DataAddressIsNull = ErrorCodeOffset_General - 8 , JY6313CoreOO::Error_SyncNotSupported = ErrorCodeOffset_General - 9 ,
JY6313CoreOO::ErrorCodeOffset_Rx = -10200 , JY6313CoreOO::Error_Rx_InitFailed = ErrorCodeOffset_Rx - 1 , JY6313CoreOO::Error_Rx_BufferOverflow = ErrorCodeOffset_Rx - 2 , JY6313CoreOO::Error_Rx_ReadDataTimeout = ErrorCodeOffset_Rx - 3 ,
JY6313CoreOO::Error_Rx_UnsupportedSampleMode = ErrorCodeOffset_Rx - 4 , JY6313CoreOO::Error_Rx_SamplesToAcquireInvalid = ErrorCodeOffset_Rx - 5 , JY6313CoreOO::Error_Rx_SamplesToAcquireNotLessPreTriggerSamples = ErrorCodeOffset_Rx - 6 , JY6313CoreOO::Error_Rx_PreTriggerSamplesInvalid = ErrorCodeOffset_Rx - 7 ,
JY6313CoreOO::Error_Rx_SampleRateInvalid = ErrorCodeOffset_Rx - 8 , JY6313CoreOO::Error_Rx_ConvertRateInvalid = ErrorCodeOffset_Rx - 9 , JY6313CoreOO::ErrorCodeOffset_Tx = -10300 , JY6313CoreOO::Error_Tx_InitFailed = ErrorCodeOffset_Tx - 1 ,
JY6313CoreOO::Error_Tx_BufferUnderflow = ErrorCodeOffset_Tx - 2 , JY6313CoreOO::Error_Tx_WriteDataTimeout = ErrorCodeOffset_Tx - 3 , JY6313CoreOO::Error_Tx_UnsupportedUpdateMode = ErrorCodeOffset_Tx - 4 , JY6313CoreOO::Error_Tx_UpdateRateInvalid = ErrorCodeOffset_Tx - 5 ,
JY6313CoreOO::Error_Tx_SamplesToUpdateInvalid = ErrorCodeOffset_Tx - 6 , JY6313CoreOO::Error_Tx_NoDataWrittenYet = ErrorCodeOffset_Tx - 7 , JY6313CoreOO::ErrorCodeOffset_Trigger = -10400 , JY6313CoreOO::Error_Trg_RetriggerCountInvalid = ErrorCodeOffset_Trigger - 1 ,
JY6313CoreOO::Error_Trg_TriggerDelayInvalid = ErrorCodeOffset_Trigger - 2 , JY6313CoreOO::Error_Trg_TriggerTypeInvalid = ErrorCodeOffset_Trigger - 3 , JY6313CoreOO::Error_Trg_TriggerModeInvalid = ErrorCodeOffset_Trigger - 4 , JY6313CoreOO::Error_Trg_DigitalTriggerSourceInvalid = ErrorCodeOffset_Trigger - 5 ,
JY6313CoreOO::Error_Trg_AnalogTriggerSourceInvalid = ErrorCodeOffset_Trigger - 6 , JY6313CoreOO::Error_Trg_AnalogTriggerThresholdInvalid = ErrorCodeOffset_Trigger - 7 , JY6313CoreOO::Error_Trg_NotWaitingForSoftwareTrigger = ErrorCodeOffset_Trigger - 8 , JY6313CoreOO::Error_Trg_SampleModeAndTriggerModeNotMatch = ErrorCodeOffset_Trigger - 9 ,
JY6313CoreOO::ErrorCodeOffset_Clock = -10500 , JY6313CoreOO::Error_Clk_RefClkSourceInvalid = ErrorCodeOffset_Clock - 1 , JY6313CoreOO::Error_Clk_TimebaseSourceInvalid = ErrorCodeOffset_Clock - 2 , JY6313CoreOO::Error_Clk_SampleClockSourceInvalid = ErrorCodeOffset_Clock - 3 ,
JY6313CoreOO::Error_Clk_ClkMuxFaliedToSelectTheTargetClk = ErrorCodeOffset_Clock - 4 , JY6313CoreOO::Error_Clk_PLLLockFailed = ErrorCodeOffset_Clock - 5 , JY6313CoreOO::Error_Clk_PLLOutputFreqInvalid = ErrorCodeOffset_Clock - 6 , JY6313CoreOO::ErrorCodeOffset_AIO = -10600 ,
JY6313CoreOO::Error_AIO_ChannelCountInvalid = ErrorCodeOffset_AIO - 1 , JY6313CoreOO::Error_AIO_ChannelIndexInvalid = ErrorCodeOffset_AIO - 2 , JY6313CoreOO::Error_AIO_InputOrOutputRangeInvalid = ErrorCodeOffset_AIO - 3 , JY6313CoreOO::Error_AIO_TerminalInvalid = ErrorCodeOffset_AIO - 4 ,
JY6313CoreOO::Error_AIO_CouplingInvalid = ErrorCodeOffset_AIO - 5 , JY6313CoreOO::ErrorCodeOffset_DIO = -10700 , JY6313CoreOO::Error_DIO_LineCountInvalid = ErrorCodeOffset_DIO - 1 , JY6313CoreOO::Error_DIO_LineIndexInvalid = ErrorCodeOffset_DIO - 2 ,
JY6313CoreOO::Error_DIO_PortCountInvalid = ErrorCodeOffset_DIO - 3 , JY6313CoreOO::Error_DIO_PortIndexInvalid = ErrorCodeOffset_DIO - 4 , JY6313CoreOO::ErrorCodeOffset_CIO = -10800 , JY6313CoreOO::Error_CIO_ChannelInvalid = ErrorCodeOffset_CIO - 1 ,
JY6313CoreOO::Error_CIO_ChannelIsReserved = ErrorCodeOffset_CIO - 2 , JY6313CoreOO::Error_CIO_InitDelayTooShort = ErrorCodeOffset_CIO - 3 , JY6313CoreOO::Error_CIO_SampleClkTypeDoesNotSupportFreqOrPeriodMeasure = ErrorCodeOffset_CIO - 4 , JY6313CoreOO::Error_CIO_SampleModeDoesNotSupportEncoder = ErrorCodeOffset_CIO - 5 ,
JY6313CoreOO::Error_CIO_MeasurementTimeout = ErrorCodeOffset_CIO - 6 , JY6313CoreOO::ErrorCodeOffset_PFI = -10900 , JY6313CoreOO::Error_PFI_LineInvalid = ErrorCodeOffset_PFI - 1 , JY6313CoreOO::Error_PFI_LineIsReserved = ErrorCodeOffset_PFI - 2 ,
JY6313CoreOO::Error_PXITrgger_LineInvalid = ErrorCodeOffset_PFI - 3 , JY6313CoreOO::Error_PXITrgger_LineIsReserved = ErrorCodeOffset_PFI - 4 , JY6313CoreOO::Buffer_Data_Overflow = -100 , JY6313CoreOO::Task_Has_Not_Started ,
JY6313CoreOO::The_task_has_started , JY6313CoreOO::InvalidParameter , JY6313CoreOO::The_Channel_ID_Is_Incorrect , JY6313CoreOO::Channel_Number_Parameter_Invalid ,
JY6313CoreOO::Sampele_Mode_Parameter_Invalid , JY6313CoreOO::Start_Task_Failed , JY6313CoreOO::Trigger_Parameter_ERROR , JY6313CoreOO::No_Channel_Added ,
JY6313CoreOO::Signal_Export_Destination_Invalid
}
enum class JY6313CoreOO::SignalExportDestination {
JY6313CoreOO::Ext_Trig = JY6313Import::JY6313_DigitalTriggerSource_ExtTrg , JY6313CoreOO::PXI_Trig0 = JY6313Import::JY6313_DigitalTriggerSource_BUS_0 , JY6313CoreOO::PXI_Trig1 = JY6313Import::JY6313_DigitalTriggerSource_BUS_1 , JY6313CoreOO::PXI_Trig2 = JY6313Import::JY6313_DigitalTriggerSource_BUS_2 ,
JY6313CoreOO::PXI_Trig3 = JY6313Import::JY6313_DigitalTriggerSource_BUS_3 , JY6313CoreOO::PXI_Trig4 = JY6313Import::JY6313_DigitalTriggerSource_BUS_4 , JY6313CoreOO::PXI_Trig5 = JY6313Import::JY6313_DigitalTriggerSource_BUS_5 , JY6313CoreOO::PXI_Trig6 = JY6313Import::JY6313_DigitalTriggerSource_BUS_6 ,
JY6313CoreOO::PXI_Trig7 = JY6313Import::JY6313_DigitalTriggerSource_BUS_7
}
enum class | JY6313CoreOO::OutputCompleteState { JY6313CoreOO::Zero , JY6313CoreOO::Hold }
Output Complete State. More...
enum class | JY6313CoreOO::LevelPolarity { JY6313CoreOO::LowLevel = 0 , JY6313CoreOO::HighLevel = 1 , JY6313CoreOO::None = 2 }
Level Polarity. More...

Functions

std::string JY6313CoreOO::GetSignalExportDestinationString (SignalExportDestination destination)

Variables

const int | JY6313Import::JY6313_Onboard_25M = 0
const int | JY6313Import::JY6313_PXIe_Clk_100M = 1
const int | JY6313Import::JY6313_AI_Finite = 0
const int | JY6313Import::JY6313_AI_Continuous = 1
const int | JY6313Import::JY6313_AI_Single = 2
const int | JY6313Import::JY6313_TriggerType_Immediately = 0
const int | JY6313Import::JY6313_TriggerType_Digital = 1
const int | JY6313Import::JY6313_TriggerType_Software = 2
const int | JY6313Import::JY6313_TriggerType_Analog = 3
const int | JY6313Import::JY6313_DigitalTriggerEdge_Rising = 0
const int | JY6313Import::JY6313_DigitalTriggerEdge_Falling = 1
const int | JY6313Import::JY6313_DigitalTriggerSource_ExtTrg = 0
const int | JY6313Import::JY6313_DigitalTriggerSource_BUS_0 = 1
const int | JY6313Import::JY6313_DigitalTriggerSource_BUS_1 = 2
const int | JY6313Import::JY6313_DigitalTriggerSource_BUS_2 = 3
const int | JY6313Import::JY6313_DigitalTriggerSource_BUS_3 = 4
const int | JY6313Import::JY6313_DigitalTriggerSource_BUS_4 = 5
const int | JY6313Import::JY6313_DigitalTriggerSource_BUS_5 = 6
const int | JY6313Import::JY6313_DigitalTriggerSource_BUS_6 = 7
const int | JY6313Import::JY6313_DigitalTriggerSource_BUS_7 = 8
const int | JY6313Import::JY6313_AnlogTriggerCondition_RisingHysteresis = 0
const int | JY6313Import::JY6313_AnlogTriggerCondition_FallingHysteresis = 1
const int | JY6313Import::JY6313_AnlogTriggerCondition_EnteringWindow = 2
const int | JY6313Import::JY6313_AnlogTriggerCondition_LeavingWindow = 3
const int | JY6313Import::JY6313_SyncMode_Sole = 0
const int | JY6313Import::JY6313_SyncMode_Master = 1
const int | JY6313Import::JY6313_SyncMode_Slave = 2
const int | JY6313Import::JY6313_ExportSource_SampleClock = 0
const int | JY6313Import::JY6313_ExportSource_SyncPulse = 1
const int | JY6313Import::JY6313_ExportSource_ReadyForTrig = 2
const int | JY6313Import::JY6313_ExportSource_Trig = 3
const int | JY6313Import::JY6313_ExportSource_EndOfRecord = 4
const int | JY6313Import::JY6313_ExportSource_EndOfAcquisition = 5
const int | JY6313Import::WidebandLowRippleFilter = 0
const int | JY6313Import::Sinc5Filter = 1
const int | JY6313Import::JY6313_Strain_QuarterBridgeI = 0
const int | JY6313Import::JY6313_Strain_QuarterBridgeII = 1
const int | JY6313Import::JY6313_Strain_HalfBridgeI = 2
const int | JY6313Import::JY6313_Strain_HalfBridgeII = 3
const int | JY6313Import::JY6313_Strain_FullBridgeI = 4
const int | JY6313Import::JY6313_Strain_FullBridgeII = 5
const int | JY6313Import::JY6313_Strain_FullBridgeIII = 6
const int | JY6313Import::JY6313_Ratio_FullBridge = 7
const int | JY6313Import::TB6313_SC_R50k = 0
const int | JY6313Import::TB6313_SC_R100k = 1

Macro Definition Documentation

◆ EXTERN_C

#define EXTERN_C extern

Windows.

Linux

◆ JY6313CoreOO_API

#define JY6313CoreOO_API


6313 C++ Programming Manual: JY6313CoreOO::JYDriverException Class Reference

  • JYDriverException
Public Member Functions | Public Attributes | List of all members
JY6313CoreOO::JYDriverException Class Reference

#include <JY6313CoreOOCommon.h>

Public Member Functions

JYDriverException (JYDriverExceptionPublic exceptionCode, std::string msg="")
JYDriverException (int, std::string msg)

Public Attributes

std::string exceptionMessage
JYDriverExceptionPublic errorCode
JYDriverException * FollowingException

Constructor & Destructor Documentation

◆ JYDriverException() [1/2]

JY6313CoreOO::JYDriverException::JYDriverException | ( | JYDriverExceptionPublic | exceptionCode,
 |  | std::string | msg = "" )

◆ JYDriverException() [2/2]

JY6313CoreOO::JYDriverException::JYDriverException | ( | int | ,
 |  | std::string | msg )

Member Data Documentation

◆ errorCode

JYDriverExceptionPublic JY6313CoreOO::JYDriverException::errorCode

◆ exceptionMessage

std::string JY6313CoreOO::JYDriverException::exceptionMessage

◆ FollowingException

JYDriverException* JY6313CoreOO::JYDriverException::FollowingException
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6313/JY6313CoreOOCommon.h


6313 C++ Programming Manual: JY6313CoreOO::JY6313CoreOOProperty< ContainerClass, ValueType, propertyType > Class Template Reference

  • JY6313CoreOOProperty
Public Member Functions | List of all members
JY6313CoreOO::JY6313CoreOOProperty< ContainerClass, ValueType, propertyType > Class Template Reference

属性模板类 More...

#include <JY6313CoreOOCommon.h>

Public Member Functions

JY6313CoreOOProperty ()
JY6313CoreOOProperty (ContainerClass *cObject, ValueType(ContainerClass::*pGet)(), void(ContainerClass::*pSet)(ValueType value))
JY6313CoreOOProperty (ValueType(*pGet)(), void(*pSet)(ValueType value))
ValueType operator= (const ValueType &value)
operator ValueType ()

Detailed Description

template<typename ContainerClass, typename ValueType, JY6313CoreOOPropertyType propertyType>
class JY6313CoreOO::JY6313CoreOOProperty< ContainerClass, ValueType, propertyType >

属性模板类

Constructor & Destructor Documentation

◆ JY6313CoreOOProperty() [1/3]

template<typename ContainerClass, typename ValueType, JY6313CoreOOPropertyType propertyType>
JY6313CoreOO::JY6313CoreOOProperty< ContainerClass, ValueType, propertyType >::JY6313CoreOOProperty ( )

◆ JY6313CoreOOProperty() [2/3]

template<typename ContainerClass, typename ValueType, JY6313CoreOOPropertyType propertyType>
JY6313CoreOO::JY6313CoreOOProperty< ContainerClass, ValueType, propertyType >::JY6313CoreOOProperty | ( | ContainerClass * | cObject,
 |  | ValueType(ContainerClass::* | pGet )(),
 |  | void(ContainerClass::* | pSet )(ValueType value) )

◆ JY6313CoreOOProperty() [3/3]

template<typename ContainerClass, typename ValueType, JY6313CoreOOPropertyType propertyType>
JY6313CoreOO::JY6313CoreOOProperty< ContainerClass, ValueType, propertyType >::JY6313CoreOOProperty | ( | ValueType(* | pGet )(),
 |  | void(* | pSet )(ValueType value) )

Member Function Documentation

◆ operator ValueType()

template<typename ContainerClass, typename ValueType, JY6313CoreOOPropertyType propertyType>
JY6313CoreOO::JY6313CoreOOProperty< ContainerClass, ValueType, propertyType >::operator ValueType ( )

◆ operator=()

template<typename ContainerClass, typename ValueType, JY6313CoreOOPropertyType propertyType>
ValueType JY6313CoreOO::JY6313CoreOOProperty< ContainerClass, ValueType, propertyType >::operator= ( const ValueType & value )
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6313/JY6313CoreOOCommon.h


6313 C++ Programming Manual: JY6313CoreOO::PauseTrigger Class Reference

  • PauseTrigger
Public Attributes | List of all members
JY6313CoreOO::PauseTrigger Class Reference

Pause trigger configuration class. More...

#include <JY6313CoreOOCommon.h>

Public Attributes

LevelPolarity ActivePolarity
Pause trigger active polarity.
InputTerminal Terminal
Terminal.

Detailed Description

Pause trigger configuration class.

Member Data Documentation

◆ ActivePolarity

LevelPolarity JY6313CoreOO::PauseTrigger::ActivePolarity

Pause trigger active polarity.

The default value is LevelPolarity.None, means the pause trigger is disabled.

◆ Terminal

InputTerminal JY6313CoreOO::PauseTrigger::Terminal

Terminal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6313/JY6313CoreOOCommon.h


6313 C++ Programming Manual: JY6313CoreOO::FirmDriveInfo Struct Reference

  • FirmDriveInfo
Public Attributes | List of all members
JY6313CoreOO::FirmDriveInfo Struct Reference

#include <JY6313CoreOOCommon.h>

Public Attributes

int | VID
int | PID
int | slotNum
int | connected
int | cardNumber
int | fStreaming
char | serialNumber [33]
char | vendorName [65]
char | model [65]
char | aliasName [65]
char | PlatformType [16]
char | HardwareVer [16]
char | FirmwareVer [16]
char | FrameworkVer [16]
char | DriverSetVer [16]
char | ProductionDate [16]

Member Data Documentation

◆ aliasName

char JY6313CoreOO::FirmDriveInfo::aliasName[65]

◆ cardNumber

int JY6313CoreOO::FirmDriveInfo::cardNumber

◆ connected

int JY6313CoreOO::FirmDriveInfo::connected

◆ DriverSetVer

char JY6313CoreOO::FirmDriveInfo::DriverSetVer[16]

◆ FirmwareVer

char JY6313CoreOO::FirmDriveInfo::FirmwareVer[16]

◆ FrameworkVer

char JY6313CoreOO::FirmDriveInfo::FrameworkVer[16]

◆ fStreaming

int JY6313CoreOO::FirmDriveInfo::fStreaming

◆ HardwareVer

char JY6313CoreOO::FirmDriveInfo::HardwareVer[16]

◆ model

char JY6313CoreOO::FirmDriveInfo::model[65]

◆ PID

int JY6313CoreOO::FirmDriveInfo::PID

◆ PlatformType

char JY6313CoreOO::FirmDriveInfo::PlatformType[16]

◆ ProductionDate

char JY6313CoreOO::FirmDriveInfo::ProductionDate[16]

◆ serialNumber

char JY6313CoreOO::FirmDriveInfo::serialNumber[33]

◆ slotNum

int JY6313CoreOO::FirmDriveInfo::slotNum

◆ vendorName

char JY6313CoreOO::FirmDriveInfo::vendorName[65]

◆ VID

int JY6313CoreOO::FirmDriveInfo::VID
The documentation for this struct was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6313/JY6313CoreOOCommon.h


6313 C++ Programming Manual: JY6313Import Namespace Reference

  • Namespace List
  • Namespace Members
Variables
JY6313Import Namespace Reference

Variables

const int | JY6313_Onboard_25M = 0
const int | JY6313_PXIe_Clk_100M = 1
const int | JY6313_AI_Finite = 0
const int | JY6313_AI_Continuous = 1
const int | JY6313_AI_Single = 2
const int | JY6313_TriggerType_Immediately = 0
const int | JY6313_TriggerType_Digital = 1
const int | JY6313_TriggerType_Software = 2
const int | JY6313_TriggerType_Analog = 3
const int | JY6313_DigitalTriggerEdge_Rising = 0
const int | JY6313_DigitalTriggerEdge_Falling = 1
const int | JY6313_DigitalTriggerSource_ExtTrg = 0
const int | JY6313_DigitalTriggerSource_BUS_0 = 1
const int | JY6313_DigitalTriggerSource_BUS_1 = 2
const int | JY6313_DigitalTriggerSource_BUS_2 = 3
const int | JY6313_DigitalTriggerSource_BUS_3 = 4
const int | JY6313_DigitalTriggerSource_BUS_4 = 5
const int | JY6313_DigitalTriggerSource_BUS_5 = 6
const int | JY6313_DigitalTriggerSource_BUS_6 = 7
const int | JY6313_DigitalTriggerSource_BUS_7 = 8
const int | JY6313_AnlogTriggerCondition_RisingHysteresis = 0
const int | JY6313_AnlogTriggerCondition_FallingHysteresis = 1
const int | JY6313_AnlogTriggerCondition_EnteringWindow = 2
const int | JY6313_AnlogTriggerCondition_LeavingWindow = 3
const int | JY6313_SyncMode_Sole = 0
const int | JY6313_SyncMode_Master = 1
const int | JY6313_SyncMode_Slave = 2
const int | JY6313_ExportSource_SampleClock = 0
const int | JY6313_ExportSource_SyncPulse = 1
const int | JY6313_ExportSource_ReadyForTrig = 2
const int | JY6313_ExportSource_Trig = 3
const int | JY6313_ExportSource_EndOfRecord = 4
const int | JY6313_ExportSource_EndOfAcquisition = 5
const int | WidebandLowRippleFilter = 0
const int | Sinc5Filter = 1
const int | JY6313_Strain_QuarterBridgeI = 0
const int | JY6313_Strain_QuarterBridgeII = 1
const int | JY6313_Strain_HalfBridgeI = 2
const int | JY6313_Strain_HalfBridgeII = 3
const int | JY6313_Strain_FullBridgeI = 4
const int | JY6313_Strain_FullBridgeII = 5
const int | JY6313_Strain_FullBridgeIII = 6
const int | JY6313_Ratio_FullBridge = 7
const int | TB6313_SC_R50k = 0
const int | TB6313_SC_R100k = 1

Variable Documentation

◆ JY6313_AI_Continuous

const int JY6313Import::JY6313_AI_Continuous = 1

◆ JY6313_AI_Finite

const int JY6313Import::JY6313_AI_Finite = 0

◆ JY6313_AI_Single

const int JY6313Import::JY6313_AI_Single = 2

◆ JY6313_AnlogTriggerCondition_EnteringWindow

const int JY6313Import::JY6313_AnlogTriggerCondition_EnteringWindow = 2

◆ JY6313_AnlogTriggerCondition_FallingHysteresis

const int JY6313Import::JY6313_AnlogTriggerCondition_FallingHysteresis = 1

◆ JY6313_AnlogTriggerCondition_LeavingWindow

const int JY6313Import::JY6313_AnlogTriggerCondition_LeavingWindow = 3

◆ JY6313_AnlogTriggerCondition_RisingHysteresis

const int JY6313Import::JY6313_AnlogTriggerCondition_RisingHysteresis = 0

◆ JY6313_DigitalTriggerEdge_Falling

const int JY6313Import::JY6313_DigitalTriggerEdge_Falling = 1

◆ JY6313_DigitalTriggerEdge_Rising

const int JY6313Import::JY6313_DigitalTriggerEdge_Rising = 0

◆ JY6313_DigitalTriggerSource_BUS_0

const int JY6313Import::JY6313_DigitalTriggerSource_BUS_0 = 1

◆ JY6313_DigitalTriggerSource_BUS_1

const int JY6313Import::JY6313_DigitalTriggerSource_BUS_1 = 2

◆ JY6313_DigitalTriggerSource_BUS_2

const int JY6313Import::JY6313_DigitalTriggerSource_BUS_2 = 3

◆ JY6313_DigitalTriggerSource_BUS_3

const int JY6313Import::JY6313_DigitalTriggerSource_BUS_3 = 4

◆ JY6313_DigitalTriggerSource_BUS_4

const int JY6313Import::JY6313_DigitalTriggerSource_BUS_4 = 5

◆ JY6313_DigitalTriggerSource_BUS_5

const int JY6313Import::JY6313_DigitalTriggerSource_BUS_5 = 6

◆ JY6313_DigitalTriggerSource_BUS_6

const int JY6313Import::JY6313_DigitalTriggerSource_BUS_6 = 7

◆ JY6313_DigitalTriggerSource_BUS_7

const int JY6313Import::JY6313_DigitalTriggerSource_BUS_7 = 8

◆ JY6313_DigitalTriggerSource_ExtTrg

const int JY6313Import::JY6313_DigitalTriggerSource_ExtTrg = 0

◆ JY6313_ExportSource_EndOfAcquisition

const int JY6313Import::JY6313_ExportSource_EndOfAcquisition = 5

◆ JY6313_ExportSource_EndOfRecord

const int JY6313Import::JY6313_ExportSource_EndOfRecord = 4

◆ JY6313_ExportSource_ReadyForTrig

const int JY6313Import::JY6313_ExportSource_ReadyForTrig = 2

◆ JY6313_ExportSource_SampleClock

const int JY6313Import::JY6313_ExportSource_SampleClock = 0

◆ JY6313_ExportSource_SyncPulse

const int JY6313Import::JY6313_ExportSource_SyncPulse = 1

◆ JY6313_ExportSource_Trig

const int JY6313Import::JY6313_ExportSource_Trig = 3

◆ JY6313_Onboard_25M

const int JY6313Import::JY6313_Onboard_25M = 0

◆ JY6313_PXIe_Clk_100M

const int JY6313Import::JY6313_PXIe_Clk_100M = 1

◆ JY6313_Ratio_FullBridge

const int JY6313Import::JY6313_Ratio_FullBridge = 7

◆ JY6313_Strain_FullBridgeI

const int JY6313Import::JY6313_Strain_FullBridgeI = 4

◆ JY6313_Strain_FullBridgeII

const int JY6313Import::JY6313_Strain_FullBridgeII = 5

◆ JY6313_Strain_FullBridgeIII

const int JY6313Import::JY6313_Strain_FullBridgeIII = 6

◆ JY6313_Strain_HalfBridgeI

const int JY6313Import::JY6313_Strain_HalfBridgeI = 2

◆ JY6313_Strain_HalfBridgeII

const int JY6313Import::JY6313_Strain_HalfBridgeII = 3

◆ JY6313_Strain_QuarterBridgeI

const int JY6313Import::JY6313_Strain_QuarterBridgeI = 0

◆ JY6313_Strain_QuarterBridgeII

const int JY6313Import::JY6313_Strain_QuarterBridgeII = 1

◆ JY6313_SyncMode_Master

const int JY6313Import::JY6313_SyncMode_Master = 1

◆ JY6313_SyncMode_Slave

const int JY6313Import::JY6313_SyncMode_Slave = 2

◆ JY6313_SyncMode_Sole

const int JY6313Import::JY6313_SyncMode_Sole = 0

◆ JY6313_TriggerType_Analog

const int JY6313Import::JY6313_TriggerType_Analog = 3

◆ JY6313_TriggerType_Digital

const int JY6313Import::JY6313_TriggerType_Digital = 1

◆ JY6313_TriggerType_Immediately

const int JY6313Import::JY6313_TriggerType_Immediately = 0

◆ JY6313_TriggerType_Software

const int JY6313Import::JY6313_TriggerType_Software = 2

◆ Sinc5Filter

const int JY6313Import::Sinc5Filter = 1

◆ TB6313_SC_R100k

const int JY6313Import::TB6313_SC_R100k = 1

◆ TB6313_SC_R50k

const int JY6313Import::TB6313_SC_R50k = 0

◆ WidebandLowRippleFilter

const int JY6313Import::WidebandLowRippleFilter = 0


6313 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/6313/JY6313CoreOODevice.h File Reference

  • File List
  • File Members
  • COO
  • 6313
Classes | Namespaces | Enumerations
JY6313CoreOODevice.h File Reference
#include <iostream>
#include <list>
#include <vector>
#include <cstring>
#include "JY6313CoreOOCommon.h"

Classes

class | JY6313CoreOO::JY6313CoreOODevice
class | JY6313CoreOO::DeviceStatus
Device Status. More...
class | JY6313CoreOO::ExternalReferenceClock
External Reference Clcok Terminal. More...
class | JY6313CoreOO::JY6313CoreOOReferenceClock
class | JY6313CoreOO::BankConfiguration
Configuration indexed by Bank. More...
class | JY6313CoreOO::JY6313DeviceInfo
Device Info. More...

Namespaces

namespace JY6313CoreOO

Enumerations

enum class | JY6313CoreOO::ExternalReferenceClockTerminal { JY6313CoreOO::PXIe_Clk100 = 0x1 }
enum class | JY6313CoreOO::ReferenceClockSource { JY6313CoreOO::Internal = 0 , JY6313CoreOO::External = 1 }
enum class | JY6313CoreOO::TerminalBlockType { JY6313CoreOO::General , JY6313CoreOO::TB6313 }


6313 C++ Programming Manual: JY6313CoreOO::JY6313CoreOODevice Class Reference

  • JY6313CoreOODevice
Static Public Member Functions | Public Attributes | List of all members
JY6313CoreOO::JY6313CoreOODevice Class Reference

#include <JY6313CoreOODevice.h>

Static Public Member Functions

static JY6313CoreOODevice * | GetInstance (int cardNum)
The operation instance is obtained according to the board number to ensure that there is only one registered instance for each board.
static JY6313CoreOODevice * | GetInstance (std::string aliasName)
The operation instance is obtained according to aliasName to ensure that there is only one registration instance for each board.

Public Attributes

const double | BoardClockRate = 100000000
Board Clock Rate.
int | SubCardADCChannelNum
Sub Card Channel Number.
const unsigned long | AIBufferSizeInBytes = 1024 * 1024 * 512
AI Buffer Size.
const double | MaxSampleRate = 80000
Maximum Sampling Rate.
const double | MinSampleRate = 7.8125
Minimum Sampling Rate.
const double | MaxLowLatencyModeSampleRate = 4000.0
Maximum sample rate in low latency operation mode.
const double | MinNormalModeSampleRate = 500.0
Minimum sample rate in wide bandwidth operation mode.
const int | TotalNumberOfChannels = 16
Total Number of Channels Provided.
const bool | IsAISync = true
const bool | IsAOSync = true
IsAOSync.
const int | LineCountPerPort = 2
DIOLineCountPerPort.
const double | MinExcitationVoltage = 1.0
Min Bridge Excitation Voltage.
JY6313CoreOOProperty< JY6313CoreOODevice, int, JY6313CoreOOPropertyType::READ_ONLY > | DeviceID
JY6313CoreOOProperty< JY6313CoreOODevice, JY6313DeviceInfo *, JY6313CoreOOPropertyType::READ_ONLY > Info
JY6313CoreOOProperty< JY6313CoreOODevice, DeviceStatus *, JY6313CoreOOPropertyType::READ_ONLY > Status
JY6313CoreOOProperty< JY6313CoreOODevice, BankConfiguration **, JY6313CoreOOPropertyType::READ_ONLY > Banks
JY6313CoreOOReferenceClock * ReferenceClock
Reference Clock Configuration.

Member Function Documentation

◆ GetInstance() [1/2]

static JY6313CoreOODevice * JY6313CoreOO::JY6313CoreOODevice::GetInstance ( int cardNum )
static

The operation instance is obtained according to the board number to ensure that there is only one registered instance for each board.

Parameters
cardNum
Returns

◆ GetInstance() [2/2]

static JY6313CoreOODevice * JY6313CoreOO::JY6313CoreOODevice::GetInstance ( std::string aliasName )
static

The operation instance is obtained according to aliasName to ensure that there is only one registration instance for each board.

Parameters
aliasName
Returns

Member Data Documentation

◆ AIBufferSizeInBytes

const unsigned long JY6313CoreOO::JY6313CoreOODevice::AIBufferSizeInBytes = 1024 * 1024 * 512

AI Buffer Size.

◆ Banks

JY6313CoreOOProperty<JY6313CoreOODevice, BankConfiguration**, JY6313CoreOOPropertyType::READ_ONLY> JY6313CoreOO::JY6313CoreOODevice::Banks

◆ BoardClockRate

const double JY6313CoreOO::JY6313CoreOODevice::BoardClockRate = 100000000

Board Clock Rate.

◆ DeviceID

JY6313CoreOOProperty<JY6313CoreOODevice, int, JY6313CoreOOPropertyType::READ_ONLY> JY6313CoreOO::JY6313CoreOODevice::DeviceID

◆ Info

JY6313CoreOOProperty<JY6313CoreOODevice, JY6313DeviceInfo*, JY6313CoreOOPropertyType::READ_ONLY> JY6313CoreOO::JY6313CoreOODevice::Info

◆ IsAISync

const bool JY6313CoreOO::JY6313CoreOODevice::IsAISync = true

◆ IsAOSync

const bool JY6313CoreOO::JY6313CoreOODevice::IsAOSync = true

IsAOSync.

◆ LineCountPerPort

const int JY6313CoreOO::JY6313CoreOODevice::LineCountPerPort = 2

DIOLineCountPerPort.

◆ MaxLowLatencyModeSampleRate

const double JY6313CoreOO::JY6313CoreOODevice::MaxLowLatencyModeSampleRate = 4000.0

Maximum sample rate in low latency operation mode.

◆ MaxSampleRate

const double JY6313CoreOO::JY6313CoreOODevice::MaxSampleRate = 80000

Maximum Sampling Rate.

◆ MinExcitationVoltage

const double JY6313CoreOO::JY6313CoreOODevice::MinExcitationVoltage = 1.0

Min Bridge Excitation Voltage.

◆ MinNormalModeSampleRate

const double JY6313CoreOO::JY6313CoreOODevice::MinNormalModeSampleRate = 500.0

Minimum sample rate in wide bandwidth operation mode.

◆ MinSampleRate

const double JY6313CoreOO::JY6313CoreOODevice::MinSampleRate = 7.8125

Minimum Sampling Rate.

◆ ReferenceClock

JY6313CoreOOReferenceClock* JY6313CoreOO::JY6313CoreOODevice::ReferenceClock

Reference Clock Configuration.

◆ Status

JY6313CoreOOProperty<JY6313CoreOODevice, DeviceStatus*, JY6313CoreOOPropertyType::READ_ONLY> JY6313CoreOO::JY6313CoreOODevice::Status

◆ SubCardADCChannelNum

int JY6313CoreOO::JY6313CoreOODevice::SubCardADCChannelNum

Sub Card Channel Number.

◆ TotalNumberOfChannels

const int JY6313CoreOO::JY6313CoreOODevice::TotalNumberOfChannels = 16

Total Number of Channels Provided.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6313/JY6313CoreOODevice.h


6313 C++ Programming Manual: JY6313CoreOO::DeviceStatus Class Reference

  • DeviceStatus
Public Member Functions | Public Attributes | List of all members
JY6313CoreOO::DeviceStatus Class Referencefinal

Device Status. More...

#include <JY6313CoreOODevice.h>

Public Member Functions

DeviceStatus (void *deviceHandle)
~DeviceStatus ()

Public Attributes

JY6313CoreOOProperty< DeviceStatus, double, JY6313CoreOOPropertyType::READ_ONLY > Temperature

Detailed Description

Device Status.

Constructor & Destructor Documentation

◆ DeviceStatus()

JY6313CoreOO::DeviceStatus::DeviceStatus ( void * deviceHandle )

◆ ~DeviceStatus()

JY6313CoreOO::DeviceStatus::~DeviceStatus ( )

Member Data Documentation

◆ Temperature

JY6313CoreOOProperty<DeviceStatus, double, JY6313CoreOOPropertyType::READ_ONLY> JY6313CoreOO::DeviceStatus::Temperature
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6313/JY6313CoreOODevice.h


6313 C++ Programming Manual: JY6313CoreOO::ExternalReferenceClock Class Reference

  • ExternalReferenceClock
Public Attributes | List of all members
JY6313CoreOO::ExternalReferenceClock Class Reference

External Reference Clcok Terminal. More...

#include <JY6313CoreOODevice.h>

Public Attributes

ExternalReferenceClockTerminal Terminal

Detailed Description

External Reference Clcok Terminal.

Member Data Documentation

◆ Terminal

ExternalReferenceClockTerminal JY6313CoreOO::ExternalReferenceClock::Terminal
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6313/JY6313CoreOODevice.h


6313 C++ Programming Manual: JY6313CoreOO::JY6313CoreOOReferenceClock Class Reference

  • JY6313CoreOOReferenceClock
Public Attributes | List of all members
JY6313CoreOO::JY6313CoreOOReferenceClock Class Reference

#include <JY6313CoreOODevice.h>

Public Attributes

ReferenceClockSource Source
ExternalReferenceClock * External
External Reference Clock Source.
JY6313CoreOOProperty< JY6313CoreOOReferenceClock, int, JY6313CoreOOPropertyType::READ_ONLY > SelectedReferenceClock
Commit configuration.

Member Data Documentation

◆ External

ExternalReferenceClock* JY6313CoreOO::JY6313CoreOOReferenceClock::External

External Reference Clock Source.

Required when ReferenceClock.Source is ReferenceClockSource.External

◆ SelectedReferenceClock

JY6313CoreOOProperty<JY6313CoreOOReferenceClock, int, JY6313CoreOOPropertyType::READ_ONLY> JY6313CoreOO::JY6313CoreOOReferenceClock::SelectedReferenceClock

Commit configuration.

Available only when the device is idle. WARNING: Incorrect parameters will cause the PLL to be unable to lock the reference clock and cannot be recovered until shutdown and restart.

◆ Source

ReferenceClockSource JY6313CoreOO::JY6313CoreOOReferenceClock::Source
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6313/JY6313CoreOODevice.h


6313 C++ Programming Manual: JY6313CoreOO::BankConfiguration Class Reference

  • BankConfiguration
Public Member Functions | Public Attributes | List of all members
JY6313CoreOO::BankConfiguration Class Reference

Configuration indexed by Bank. More...

#include <JY6313CoreOODevice.h>

Public Member Functions

BankConfiguration (int id)
BankConfiguration (const BankConfiguration &)=delete
BankConfiguration & operator= (const BankConfiguration &)=delete

Public Attributes

int ID
Bank ID.
TerminalBlockType TerminalBlock
Terminal block type of Bank0(for Ch0~Ch7) and Bank1(for Ch8~Ch15).

Detailed Description

Configuration indexed by Bank.

Constructor & Destructor Documentation

◆ BankConfiguration() [1/2]

JY6313CoreOO::BankConfiguration::BankConfiguration ( int id )
inline

◆ BankConfiguration() [2/2]

JY6313CoreOO::BankConfiguration::BankConfiguration ( const BankConfiguration & )
delete

Member Function Documentation

◆ operator=()

BankConfiguration & JY6313CoreOO::BankConfiguration::operator= ( const BankConfiguration & )
delete

Member Data Documentation

◆ ID

int JY6313CoreOO::BankConfiguration::ID

Bank ID.

Ch0 to Ch7 belong to Bank0, Ch8 to Ch15 belong to Bank1.

◆ TerminalBlock

TerminalBlockType JY6313CoreOO::BankConfiguration::TerminalBlock

Terminal block type of Bank0(for Ch0~Ch7) and Bank1(for Ch8~Ch15).

The default value is using TB6313.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6313/JY6313CoreOODevice.h


6313 C++ Programming Manual: JY6313CoreOO::JY6313DeviceInfo Class Reference

  • JY6313DeviceInfo
Public Member Functions | Public Attributes | List of all members
JY6313CoreOO::JY6313DeviceInfo Class Reference

Device Info. More...

#include <JY6313CoreOODevice.h>

Public Member Functions

JY6313DeviceInfo ()
JY6313DeviceInfo (void *deviceHandle)
JY6313DeviceInfo (FirmDriveInfo info)
int | GetPID ()
int | GetSlotNum ()
std::string | GetAliasName ()
std::string | GetSN ()

Public Attributes

JY6313CoreOOProperty< JY6313DeviceInfo, int, JY6313CoreOOPropertyType::READ_ONLY > | HardwareVersion
JY6313CoreOOProperty< JY6313DeviceInfo, int, JY6313CoreOOPropertyType::READ_ONLY > | FirmwareVersionInt
JY6313CoreOOProperty< JY6313DeviceInfo, std::string, JY6313CoreOOPropertyType::READ_ONLY > | FirmwareVersion
JY6313CoreOOProperty< JY6313DeviceInfo, bool, JY6313CoreOOPropertyType::READ_ONLY > | IsPXIeDevice
JY6313CoreOOProperty< JY6313DeviceInfo, bool, JY6313CoreOOPropertyType::READ_ONLY > | IEPEAvailable
JY6313CoreOOProperty< JY6313DeviceInfo, int, JY6313CoreOOPropertyType::READ_ONLY > | PID
JY6313CoreOOProperty< JY6313DeviceInfo, int, JY6313CoreOOPropertyType::READ_ONLY > | SlotNum
JY6313CoreOOProperty< JY6313DeviceInfo, std::string, JY6313CoreOOPropertyType::READ_ONLY > | AliasName
JY6313CoreOOProperty< JY6313DeviceInfo, std::string, JY6313CoreOOPropertyType::READ_ONLY > | SN

Detailed Description

Device Info.

Constructor & Destructor Documentation

◆ JY6313DeviceInfo() [1/3]

JY6313CoreOO::JY6313DeviceInfo::JY6313DeviceInfo ( )

◆ JY6313DeviceInfo() [2/3]

JY6313CoreOO::JY6313DeviceInfo::JY6313DeviceInfo ( void * deviceHandle )

◆ JY6313DeviceInfo() [3/3]

JY6313CoreOO::JY6313DeviceInfo::JY6313DeviceInfo ( FirmDriveInfo info )

Member Function Documentation

◆ GetAliasName()

std::string JY6313CoreOO::JY6313DeviceInfo::GetAliasName ( )

◆ GetPID()

int JY6313CoreOO::JY6313DeviceInfo::GetPID ( )

◆ GetSlotNum()

int JY6313CoreOO::JY6313DeviceInfo::GetSlotNum ( )

◆ GetSN()

std::string JY6313CoreOO::JY6313DeviceInfo::GetSN ( )

Member Data Documentation

◆ AliasName

JY6313CoreOOProperty<JY6313DeviceInfo, std::string, JY6313CoreOOPropertyType::READ_ONLY> JY6313CoreOO::JY6313DeviceInfo::AliasName

◆ FirmwareVersion

JY6313CoreOOProperty<JY6313DeviceInfo, std::string, JY6313CoreOOPropertyType::READ_ONLY> JY6313CoreOO::JY6313DeviceInfo::FirmwareVersion

◆ FirmwareVersionInt

JY6313CoreOOProperty<JY6313DeviceInfo, int, JY6313CoreOOPropertyType::READ_ONLY> JY6313CoreOO::JY6313DeviceInfo::FirmwareVersionInt

◆ HardwareVersion

JY6313CoreOOProperty<JY6313DeviceInfo, int, JY6313CoreOOPropertyType::READ_ONLY> JY6313CoreOO::JY6313DeviceInfo::HardwareVersion

◆ IEPEAvailable

JY6313CoreOOProperty<JY6313DeviceInfo, bool, JY6313CoreOOPropertyType::READ_ONLY> JY6313CoreOO::JY6313DeviceInfo::IEPEAvailable

◆ IsPXIeDevice

JY6313CoreOOProperty<JY6313DeviceInfo, bool, JY6313CoreOOPropertyType::READ_ONLY> JY6313CoreOO::JY6313DeviceInfo::IsPXIeDevice

◆ PID

JY6313CoreOOProperty<JY6313DeviceInfo, int, JY6313CoreOOPropertyType::READ_ONLY> JY6313CoreOO::JY6313DeviceInfo::PID

◆ SlotNum

JY6313CoreOOProperty<JY6313DeviceInfo, int, JY6313CoreOOPropertyType::READ_ONLY> JY6313CoreOO::JY6313DeviceInfo::SlotNum

◆ SN

JY6313CoreOOProperty<JY6313DeviceInfo, std::string, JY6313CoreOOPropertyType::READ_ONLY> JY6313CoreOO::JY6313DeviceInfo::SN
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6313/JY6313CoreOODevice.h


6313 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/6313/JY6313CoreOOLog.h File Reference

  • File List
  • File Members
  • COO
  • 6313
Classes | Namespaces | Enumerations
JY6313CoreOOLog.h File Reference
#include <queue>
#include <thread>
#include "JY6313CoreOOCommon.h"

Classes

class JY6313CoreOO::JY6313CoreOOLog

Namespaces

namespace JY6313CoreOO

Enumerations

enum class JY6313CoreOO::JY6313CoreOOLogLevel {
JY6313CoreOO::DEBUG_LOG_LEVEL , JY6313CoreOO::INFO_LOG_LEVEL , JY6313CoreOO::WARN_LOG_LEVEL , JY6313CoreOO::ERROR_LOG_LEVEL ,
JY6313CoreOO::FATAL_LOG_LEVEL
}


6313 C++ Programming Manual: JY6313CoreOO::JY6313CoreOOLog Class Reference

  • JY6313CoreOOLog
Static Public Member Functions | Static Public Attributes | List of all members
JY6313CoreOO::JY6313CoreOOLog Class Reference

#include <JY6313CoreOOLog.h>

Static Public Member Functions

static void | Print (const char *format,...)
static void | Print (JY6313CoreOOLogLevel logLevel, const char *format,...)
static void | Flush ()

Static Public Attributes

static JY6313CoreOOLogLevel | LogLevel
static JY6313CoreOOProperty< JY6313CoreOOLog, bool, JY6313CoreOOPropertyType::READ_WRITE > | EnableLog

Member Function Documentation

◆ Flush()

static void JY6313CoreOO::JY6313CoreOOLog::Flush ( )
static

◆ Print() [1/2]

static void JY6313CoreOO::JY6313CoreOOLog::Print | ( | const char * | format,
 |  |  | ... )
 static

◆ Print() [2/2]

static void JY6313CoreOO::JY6313CoreOOLog::Print | ( | JY6313CoreOOLogLevel | logLevel,
 |  | const char * | format,
 |  |  | ... )
 static

Member Data Documentation

◆ EnableLog

JY6313CoreOOProperty<JY6313CoreOOLog, bool, JY6313CoreOOPropertyType::READ_WRITE> JY6313CoreOO::JY6313CoreOOLog::EnableLog
static

◆ LogLevel

JY6313CoreOOLogLevel JY6313CoreOO::JY6313CoreOOLog::LogLevel
static
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6313/JY6313CoreOOLog.h


6313 C++ Programming Manual: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
▼N JY6313CoreOO |
C AIAdvanced |
C AIAnalogEdgeComparator |
C AIAnalogHysteresisComparator |
C AIAnalogTrigger |
C AIAnalogWindowComparator |
C AIChannel | JY6313 AI channel configuration
C AIDigitalTrigger |
C AISignalExport |
C AISync | Configure sync signal
C AITrigger |
C BankConfiguration | Configuration indexed by Bank
C BridgeCalInfo | Bridge Calibration Information
C ConversionStatus | ADC Convesion Status Class
C DeviceMiscellaneousParam | Device miscellaneous param
C DeviceStatus | Device Status
C ExternalReferenceClock | External Reference Clcok Terminal
C FirmDriveInfo |
C JY6313CoreOOAITask | AiTask类
C JY6313CoreOODevice |
C JY6313CoreOOLog |
C JY6313CoreOOProperty | 属性模板类
C JY6313CoreOOReferenceClock |
C JY6313DeviceInfo | Device Info
C JY6313Miscellaneous | JY6313 Miscellaneous parameters
C JYDriverException |
C PauseTrigger | Pause trigger configuration class
C PowerLineRejection | Power Line Rejection Parameters Class
C StrainMeasInfo | Strain Measuement Infomation
C JY6313CoreOOAIMode | AIMode


6313 C++ Programming Manual: Member List

  • AIAdvanced
JY6313CoreOO::AIAdvanced Member List

This is the complete list of members for JY6313CoreOO::AIAdvanced, including all inherited members.

PowerLine_Rejection JY6313CoreOO::AIAdvanced


6313 C++ Programming Manual: Member List

  • AIAnalogEdgeComparator
JY6313CoreOO::AIAnalogEdgeComparator Member List

This is the complete list of members for JY6313CoreOO::AIAnalogEdgeComparator, including all inherited members.

Slope | JY6313CoreOO::AIAnalogEdgeComparator
Threshold | JY6313CoreOO::AIAnalogEdgeComparator


6313 C++ Programming Manual: Member List

  • AIAnalogHysteresisComparator
JY6313CoreOO::AIAnalogHysteresisComparator Member List

This is the complete list of members for JY6313CoreOO::AIAnalogHysteresisComparator, including all inherited members.

HighThreshold | JY6313CoreOO::AIAnalogHysteresisComparator
LowThreshold | JY6313CoreOO::AIAnalogHysteresisComparator
Slope | JY6313CoreOO::AIAnalogHysteresisComparator


6313 C++ Programming Manual: Member List

  • AIAnalogTrigger
JY6313CoreOO::AIAnalogTrigger Member List

This is the complete list of members for JY6313CoreOO::AIAnalogTrigger, including all inherited members.

AIAnalogTrigger() | JY6313CoreOO::AIAnalogTrigger
AIAnalogTrigger(AIAnalogTriggerSource src, AIAnalogTriggerComparator comparator) | JY6313CoreOO::AIAnalogTrigger
Comparator | JY6313CoreOO::AIAnalogTrigger
Edge | JY6313CoreOO::AIAnalogTrigger
Hysteresis | JY6313CoreOO::AIAnalogTrigger
Source | JY6313CoreOO::AIAnalogTrigger
Window | JY6313CoreOO::AIAnalogTrigger
~AIAnalogTrigger() | JY6313CoreOO::AIAnalogTrigger


6313 C++ Programming Manual: Member List

  • AIAnalogWindowComparator
JY6313CoreOO::AIAnalogWindowComparator Member List

This is the complete list of members for JY6313CoreOO::AIAnalogWindowComparator, including all inherited members.

Condition | JY6313CoreOO::AIAnalogWindowComparator
HighThreshold | JY6313CoreOO::AIAnalogWindowComparator
LowThreshold | JY6313CoreOO::AIAnalogWindowComparator


6313 C++ Programming Manual: Member List

  • AIChannel
JY6313CoreOO::AIChannel Member List

This is the complete list of members for JY6313CoreOO::AIChannel, including all inherited members.

AIChannel(int channelId, StrainConfiguration strainConfiguration, double excitationVoltage, double rangeLow, double rangeHigh, double gageNominalResistance, double GF, double poissonFactor, double leadwireResistance, void *deviceHandle) | JY6313CoreOO::AIChannel
AIChannel(int channelId, StrainConfiguration strainConfiguration, double excitationVoltage, AIGain gain, double gageNominalResistance, double GF, double poissonFactor, double leadwireResistance, void *deviceHandle) | JY6313CoreOO::AIChannel
AIChannel(int channelId, double excitationVoltage, double rangeLow, double rangeHigh, void *deviceHandle) | JY6313CoreOO::AIChannel
AIChannel(int channelId, double excitationVoltage, AIGain gain, void *deviceHandle) | JY6313CoreOO::AIChannel
BankID | JY6313CoreOO::AIChannel
BridgeCal | JY6313CoreOO::AIChannel
BridgeConfigurationValue | JY6313CoreOO::AIChannel
ChannelID | JY6313CoreOO::AIChannel
ExcitationVoltage | JY6313CoreOO::AIChannel
ExcitationVoltageRequired | JY6313CoreOO::AIChannel
Gain | JY6313CoreOO::AIChannel
Measurement_Type | JY6313CoreOO::AIChannel
RangeHigh | JY6313CoreOO::AIChannel
RangeLow | JY6313CoreOO::AIChannel
RawDataScaleFactor | JY6313CoreOO::AIChannel
Strain | JY6313CoreOO::AIChannel


6313 C++ Programming Manual: Member List

  • AIDigitalTrigger
JY6313CoreOO::AIDigitalTrigger Member List

This is the complete list of members for JY6313CoreOO::AIDigitalTrigger, including all inherited members.

Edge | JY6313CoreOO::AIDigitalTrigger
Source | JY6313CoreOO::AIDigitalTrigger


6313 C++ Programming Manual: Member List

  • AISignalExport
JY6313CoreOO::AISignalExport Member List

This is the complete list of members for JY6313CoreOO::AISignalExport, including all inherited members.

Add(AISignalExportSource source, SignalExportDestination destination) | JY6313CoreOO::AISignalExport
Add(AISignalExportSource source, std::list< SignalExportDestination > destinations) | JY6313CoreOO::AISignalExport
Clear(SignalExportDestination destination) | JY6313CoreOO::AISignalExport
ClearAll() | JY6313CoreOO::AISignalExport
Destination | JY6313CoreOO::AISignalExport


6313 C++ Programming Manual: Member List

  • AISync
JY6313CoreOO::AISync Member List

This is the complete list of members for JY6313CoreOO::AISync, including all inherited members.

State | JY6313CoreOO::AISync
Terminal | JY6313CoreOO::AISync
Topology | JY6313CoreOO::AISync


6313 C++ Programming Manual: Member List

  • AITrigger
JY6313CoreOO::AITrigger Member List

This is the complete list of members for JY6313CoreOO::AITrigger, including all inherited members.

Analog | JY6313CoreOO::AITrigger
Digital | JY6313CoreOO::AITrigger
Mode | JY6313CoreOO::AITrigger
PreTriggerSamples | JY6313CoreOO::AITrigger
ReTriggerCount | JY6313CoreOO::AITrigger
Type | JY6313CoreOO::AITrigger


6313 C++ Programming Manual: Member List

  • BankConfiguration
JY6313CoreOO::BankConfiguration Member List

This is the complete list of members for JY6313CoreOO::BankConfiguration, including all inherited members.

BankConfiguration(int id) | JY6313CoreOO::BankConfiguration | inline
BankConfiguration(const BankConfiguration &)=delete | JY6313CoreOO::BankConfiguration |
ID | JY6313CoreOO::BankConfiguration |
operator=(const BankConfiguration &)=delete | JY6313CoreOO::BankConfiguration |
TerminalBlock | JY6313CoreOO::BankConfiguration |


6313 C++ Programming Manual: Member List

  • BridgeCalInfo
JY6313CoreOO::BridgeCalInfo Member List

This is the complete list of members for JY6313CoreOO::BridgeCalInfo, including all inherited members.

BridgeCalInfo() | JY6313CoreOO::BridgeCalInfo
GainAdjustment | JY6313CoreOO::BridgeCalInfo
LeadWireResistance | JY6313CoreOO::BridgeCalInfo
NullingCoef | JY6313CoreOO::BridgeCalInfo


6313 C++ Programming Manual: Member List

  • ConversionStatus
JY6313CoreOO::ConversionStatus Member List

This is the complete list of members for JY6313CoreOO::ConversionStatus, including all inherited members.

ChannelID | JY6313CoreOO::ConversionStatus
ConversionStatus(int header) | JY6313CoreOO::ConversionStatus
CRCError | JY6313CoreOO::ConversionStatus
ErrorFlagged | JY6313CoreOO::ConversionStatus
FilterSuturated | JY6313CoreOO::ConversionStatus
Update(int header) | JY6313CoreOO::ConversionStatus


6313 C++ Programming Manual: Member List

  • DeviceMiscellaneousParam
JY6313CoreOO::DeviceMiscellaneousParam Member List

This is the complete list of members for JY6313CoreOO::DeviceMiscellaneousParam, including all inherited members.

DeviceMiscellaneousParam(void *handle) | JY6313CoreOO::DeviceMiscellaneousParam
DisableAICalibration | JY6313CoreOO::DeviceMiscellaneousParam
DisableAIFlatnessCalibration | JY6313CoreOO::DeviceMiscellaneousParam
DisableTBCalibration | JY6313CoreOO::DeviceMiscellaneousParam
Handle | JY6313CoreOO::DeviceMiscellaneousParam


6313 C++ Programming Manual: Member List

  • DeviceStatus
JY6313CoreOO::DeviceStatus Member List

This is the complete list of members for JY6313CoreOO::DeviceStatus, including all inherited members.

DeviceStatus(void *deviceHandle) | JY6313CoreOO::DeviceStatus
Temperature | JY6313CoreOO::DeviceStatus
~DeviceStatus() | JY6313CoreOO::DeviceStatus


6313 C++ Programming Manual: Member List

  • ExternalReferenceClock
JY6313CoreOO::ExternalReferenceClock Member List

This is the complete list of members for JY6313CoreOO::ExternalReferenceClock, including all inherited members.

Terminal JY6313CoreOO::ExternalReferenceClock


6313 C++ Programming Manual: Member List

  • JY6313CoreOOAITask
JY6313CoreOO::JY6313CoreOOAITask Member List

This is the complete list of members for JY6313CoreOO::JY6313CoreOOAITask, including all inherited members.

AddChannel(int chnId, double excitationVoltage, AIGain gain) | JY6313CoreOO::JY6313CoreOOAITask
AddChannel(int chnId, double excitationVoltage, double rangeLow, double rangeHigh) | JY6313CoreOO::JY6313CoreOOAITask
AddChannel(std::vector< int > chnsId, double excitationVoltage, double rangeLow, double rangeHigh) | JY6313CoreOO::JY6313CoreOOAITask
AddChannel(std::vector< int > chnsId, std::vector< double > excitationVoltage, double rangeLow, double rangeHigh) | JY6313CoreOO::JY6313CoreOOAITask
AddChannel(std::vector< int > chnsId, std::vector< double > excitationVoltage, std::vector< double > rangeLow, double rangeHigh) | JY6313CoreOO::JY6313CoreOOAITask
AddChannel(std::vector< int > chnsId, std::vector< double > excitationVoltage, std::vector< double > rangeLow, std::vector< double > rangeHigh) | JY6313CoreOO::JY6313CoreOOAITask
AddChannel(int chnId, StrainConfiguration configuration, double excitationVoltage, double rangeLow, double rangeHigh, double gageNominalResistance, double gageFactor, double poissonFactor=0.5, double leadWireResistance=0.0) | JY6313CoreOO::JY6313CoreOOAITask
AddChannel(std::vector< int > chnsId, StrainConfiguration configuration, double excitationVoltage, double rangeLow, double rangeHigh, double gageNominalResistance, double gageFactor, double poissonFactor=0.5, double leadWireResistance=0.0) | JY6313CoreOO::JY6313CoreOOAITask
AddChannel(std::vector< int > chnsId, std::vector< StrainConfiguration > configuration, double excitationVoltage, double rangeLow, double rangeHigh, double gageNominalResistance, double gageFactor, double poissonFactor=0.5, double leadWireResistance=0.0) | JY6313CoreOO::JY6313CoreOOAITask
AddChannel(std::vector< int > chnsId, std::vector< StrainConfiguration > configuration, std::vector< double > excitationVoltage, double rangeLow, double rangeHigh, double gageNominalResistance, double gageFactor, double poissonFactor=0.5, double leadWireResistance=0.0) | JY6313CoreOO::JY6313CoreOOAITask
AddChannel(std::vector< int > chnsId, std::vector< StrainConfiguration > configuration, std::vector< double > excitationVoltage, std::vector< double > rangeLow, double rangeHigh, double gageNominalResistance, double gageFactor, double poissonFactor=0.5, double leadWireResistance=0.0) | JY6313CoreOO::JY6313CoreOOAITask
AddChannel(std::vector< int > chnsId, std::vector< StrainConfiguration > configuration, std::vector< double > excitationVoltage, std::vector< double > rangeLow, std::vector< double > rangeHigh, double gageNominalResistance, double gageFactor, double poissonFactor=0.5, double leadWireResistance=0.0) | JY6313CoreOO::JY6313CoreOOAITask
AddChannel(std::vector< int > chnsId, std::vector< StrainConfiguration > configuration, std::vector< double > excitationVoltage, std::vector< double > rangeLow, std::vector< double > rangeHigh, std::vector< double > gageNominalResistance, double gageFactor, double poissonFactor=0.5, double leadWireResistance=0.0) | JY6313CoreOO::JY6313CoreOOAITask
AddChannel(std::vector< int > chnsId, std::vector< StrainConfiguration > configuration, std::vector< double > excitationVoltage, std::vector< double > rangeLow, std::vector< double > rangeHigh, std::vector< double > gageNominalResistance, std::vector< double > gageFactor, double poissonFactor=0.5, double leadWireResistance=0.0) | JY6313CoreOO::JY6313CoreOOAITask
AddChannel(std::vector< int > chnsId, std::vector< StrainConfiguration > configuration, std::vector< double > excitationVoltage, std::vector< double > rangeLow, std::vector< double > rangeHigh, std::vector< double > gageNominalResistance, std::vector< double > gageFactor, std::vector< double > poissonFactor, double leadWireResistance=0.0) | JY6313CoreOO::JY6313CoreOOAITask
AddChannel(std::vector< int > chnsId, std::vector< StrainConfiguration > configuration, std::vector< double > excitationVoltage, std::vector< double > rangeLow, std::vector< double > rangeHigh, std::vector< double > gageNominalResistance, std::vector< double > gageFactor, std::vector< double > poissonFactor, std::vector< double > leadWireResistance) | JY6313CoreOO::JY6313CoreOOAITask
Advanced | JY6313CoreOO::JY6313CoreOOAITask
AvailableSamples | JY6313CoreOO::JY6313CoreOOAITask
BufLenInSamples | JY6313CoreOO::JY6313CoreOOAITask
Channels | JY6313CoreOO::JY6313CoreOOAITask
Device | JY6313CoreOO::JY6313CoreOOAITask
DisableDigitalTriggerDelay | JY6313CoreOO::JY6313CoreOOAITask
GetConversionStatus() | JY6313CoreOO::JY6313CoreOOAITask
GroupDelay | JY6313CoreOO::JY6313CoreOOAITask
JY6313CoreOOAITask(int slotNum) | JY6313CoreOO::JY6313CoreOOAITask
JY6313CoreOOAITask(std::string boardName) | JY6313CoreOO::JY6313CoreOOAITask
Mode | JY6313CoreOO::JY6313CoreOOAITask
Operation_Mode | JY6313CoreOO::JY6313CoreOOAITask
PerformOffsetNulling(int chID) | JY6313CoreOO::JY6313CoreOOAITask
PerformOffsetNulling(std::vector< int > chIDs) | JY6313CoreOO::JY6313CoreOOAITask
PerformShuntCalibration(std::vector< int > chIDs, std::vector< double > shuntResistance) | JY6313CoreOO::JY6313CoreOOAITask
PerformShuntCalibration(std::vector< int > chIDs) | JY6313CoreOO::JY6313CoreOOAITask
PerformShuntCalibration(int chID) | JY6313CoreOO::JY6313CoreOOAITask
ReadData(double *pBuf, int samplesPerChannel, int timeout=-1) | JY6313CoreOO::JY6313CoreOOAITask
ReadData(std::vector< double > &pBuf, int samplesPerChannel, int timeout=-1) | JY6313CoreOO::JY6313CoreOOAITask
ReadData(std::vector< std::vector< double > > &pBuf, int samplesPerChannel, int timeout=-1) | JY6313CoreOO::JY6313CoreOOAITask
ReadRatiometricData(std::vector< double > &dataBuf, int samplesPerChannel, int timeout) | JY6313CoreOO::JY6313CoreOOAITask
ReadRawData(int *pBuf, int samplesPerChannel, int timeout=-1) | JY6313CoreOO::JY6313CoreOOAITask
ReadRawData(std::vector< int > &pBuf, int samplesPerChannel, int timeout=-1) | JY6313CoreOO::JY6313CoreOOAITask
ReadSinglePoint(double &readValue, int channel) | JY6313CoreOO::JY6313CoreOOAITask
ReadSinglePoint(std::vector< double > &readValues) | JY6313CoreOO::JY6313CoreOOAITask
RemoveChannel(int chnId) | JY6313CoreOO::JY6313CoreOOAITask
RemoveChannel(std::vector< int > chnId) | JY6313CoreOO::JY6313CoreOOAITask
SampleRate | JY6313CoreOO::JY6313CoreOOAITask
SamplesToAcquire | JY6313CoreOO::JY6313CoreOOAITask
SendSoftwareTrigger() | JY6313CoreOO::JY6313CoreOOAITask
SignalExport | JY6313CoreOO::JY6313CoreOOAITask
Start() | JY6313CoreOO::JY6313CoreOOAITask
Stop() | JY6313CoreOO::JY6313CoreOOAITask
Sync | JY6313CoreOO::JY6313CoreOOAITask
TransferedSamples | JY6313CoreOO::JY6313CoreOOAITask
Trigger | JY6313CoreOO::JY6313CoreOOAITask
~JY6313CoreOOAITask() | JY6313CoreOO::JY6313CoreOOAITask


6313 C++ Programming Manual: Member List

  • JY6313CoreOODevice
JY6313CoreOO::JY6313CoreOODevice Member List

This is the complete list of members for JY6313CoreOO::JY6313CoreOODevice, including all inherited members.

AIBufferSizeInBytes | JY6313CoreOO::JY6313CoreOODevice |
Banks | JY6313CoreOO::JY6313CoreOODevice |
BoardClockRate | JY6313CoreOO::JY6313CoreOODevice |
DeviceID | JY6313CoreOO::JY6313CoreOODevice |
GetInstance(int cardNum) | JY6313CoreOO::JY6313CoreOODevice | static
GetInstance(std::string aliasName) | JY6313CoreOO::JY6313CoreOODevice | static
Info | JY6313CoreOO::JY6313CoreOODevice |
IsAISync | JY6313CoreOO::JY6313CoreOODevice |
IsAOSync | JY6313CoreOO::JY6313CoreOODevice |
LineCountPerPort | JY6313CoreOO::JY6313CoreOODevice |
MaxLowLatencyModeSampleRate | JY6313CoreOO::JY6313CoreOODevice |
MaxSampleRate | JY6313CoreOO::JY6313CoreOODevice |
MinExcitationVoltage | JY6313CoreOO::JY6313CoreOODevice |
MinNormalModeSampleRate | JY6313CoreOO::JY6313CoreOODevice |
MinSampleRate | JY6313CoreOO::JY6313CoreOODevice |
ReferenceClock | JY6313CoreOO::JY6313CoreOODevice |
Status | JY6313CoreOO::JY6313CoreOODevice |
SubCardADCChannelNum | JY6313CoreOO::JY6313CoreOODevice |
TotalNumberOfChannels | JY6313CoreOO::JY6313CoreOODevice |


6313 C++ Programming Manual: Member List

  • JY6313CoreOOLog
JY6313CoreOO::JY6313CoreOOLog Member List

This is the complete list of members for JY6313CoreOO::JY6313CoreOOLog, including all inherited members.

EnableLog | JY6313CoreOO::JY6313CoreOOLog | static
Flush() | JY6313CoreOO::JY6313CoreOOLog | static
LogLevel | JY6313CoreOO::JY6313CoreOOLog | static
Print(const char *format,...) | JY6313CoreOO::JY6313CoreOOLog | static
Print(JY6313CoreOOLogLevel logLevel, const char *format,...) | JY6313CoreOO::JY6313CoreOOLog | static


6313 C++ Programming Manual: Member List

  • JY6313CoreOOProperty
JY6313CoreOO::JY6313CoreOOProperty< ContainerClass, ValueType, propertyType > Member List

This is the complete list of members for JY6313CoreOO::JY6313CoreOOProperty< ContainerClass, ValueType, propertyType >, including all inherited members.

JY6313CoreOOProperty() | JY6313CoreOO::JY6313CoreOOProperty< ContainerClass, ValueType, propertyType >
JY6313CoreOOProperty(ContainerClass *cObject, ValueType(ContainerClass::*pGet)(), void(ContainerClass::*pSet)(ValueType value)) | JY6313CoreOO::JY6313CoreOOProperty< ContainerClass, ValueType, propertyType >
JY6313CoreOOProperty(ValueType(*pGet)(), void(*pSet)(ValueType value)) | JY6313CoreOO::JY6313CoreOOProperty< ContainerClass, ValueType, propertyType >
operator ValueType() | JY6313CoreOO::JY6313CoreOOProperty< ContainerClass, ValueType, propertyType >
operator=(const ValueType &value) | JY6313CoreOO::JY6313CoreOOProperty< ContainerClass, ValueType, propertyType >


6313 C++ Programming Manual: Member List

  • JY6313CoreOOReferenceClock
JY6313CoreOO::JY6313CoreOOReferenceClock Member List

This is the complete list of members for JY6313CoreOO::JY6313CoreOOReferenceClock, including all inherited members.

External | JY6313CoreOO::JY6313CoreOOReferenceClock
SelectedReferenceClock | JY6313CoreOO::JY6313CoreOOReferenceClock
Source | JY6313CoreOO::JY6313CoreOOReferenceClock


6313 C++ Programming Manual: Member List

  • JY6313DeviceInfo
JY6313CoreOO::JY6313DeviceInfo Member List

This is the complete list of members for JY6313CoreOO::JY6313DeviceInfo, including all inherited members.

AliasName | JY6313CoreOO::JY6313DeviceInfo
FirmwareVersion | JY6313CoreOO::JY6313DeviceInfo
FirmwareVersionInt | JY6313CoreOO::JY6313DeviceInfo
GetAliasName() | JY6313CoreOO::JY6313DeviceInfo
GetPID() | JY6313CoreOO::JY6313DeviceInfo
GetSlotNum() | JY6313CoreOO::JY6313DeviceInfo
GetSN() | JY6313CoreOO::JY6313DeviceInfo
HardwareVersion | JY6313CoreOO::JY6313DeviceInfo
IEPEAvailable | JY6313CoreOO::JY6313DeviceInfo
IsPXIeDevice | JY6313CoreOO::JY6313DeviceInfo
JY6313DeviceInfo() | JY6313CoreOO::JY6313DeviceInfo
JY6313DeviceInfo(void *deviceHandle) | JY6313CoreOO::JY6313DeviceInfo
JY6313DeviceInfo(FirmDriveInfo info) | JY6313CoreOO::JY6313DeviceInfo
PID | JY6313CoreOO::JY6313DeviceInfo
SlotNum | JY6313CoreOO::JY6313DeviceInfo
SN | JY6313CoreOO::JY6313DeviceInfo


6313 C++ Programming Manual: Member List

  • JY6313Miscellaneous
JY6313CoreOO::JY6313Miscellaneous Member List

This is the complete list of members for JY6313CoreOO::JY6313Miscellaneous, including all inherited members.

GetAICalibrationState(void *handle) | JY6313CoreOO::JY6313Miscellaneous | static
GetAIFlatnessCalibrationState(void *handle) | JY6313CoreOO::JY6313Miscellaneous | static
GetTBCalibrationState(void *handle) | JY6313CoreOO::JY6313Miscellaneous | static
SetAICalibrationState(void *handle, bool disableCalibration) | JY6313CoreOO::JY6313Miscellaneous | static
SetAIFlatnessCalibrationState(void *handle, bool disableFlatnessCalibration) | JY6313CoreOO::JY6313Miscellaneous | static
SetTBCalibrationState(void *handle, bool disableTBCalibration) | JY6313CoreOO::JY6313Miscellaneous | static


6313 C++ Programming Manual: Member List

  • JYDriverException
JY6313CoreOO::JYDriverException Member List

This is the complete list of members for JY6313CoreOO::JYDriverException, including all inherited members.

errorCode | JY6313CoreOO::JYDriverException
exceptionMessage | JY6313CoreOO::JYDriverException
FollowingException | JY6313CoreOO::JYDriverException
JYDriverException(JYDriverExceptionPublic exceptionCode, std::string msg="") | JY6313CoreOO::JYDriverException
JYDriverException(int, std::string msg) | JY6313CoreOO::JYDriverException


6313 C++ Programming Manual: Member List

  • PauseTrigger
JY6313CoreOO::PauseTrigger Member List

This is the complete list of members for JY6313CoreOO::PauseTrigger, including all inherited members.

ActivePolarity | JY6313CoreOO::PauseTrigger
Terminal | JY6313CoreOO::PauseTrigger


6313 C++ Programming Manual: Member List

  • PowerLineRejection
JY6313CoreOO::PowerLineRejection Member List

This is the complete list of members for JY6313CoreOO::PowerLineRejection, including all inherited members.

Frequency JY6313CoreOO::PowerLineRejection


6313 C++ Programming Manual: Member List

  • StrainMeasInfo
JY6313CoreOO::StrainMeasInfo Member List

This is the complete list of members for JY6313CoreOO::StrainMeasInfo, including all inherited members.

Configuration | JY6313CoreOO::StrainMeasInfo
GageFactor | JY6313CoreOO::StrainMeasInfo
GageNominalResistance | JY6313CoreOO::StrainMeasInfo
MaterialPoissonFactor | JY6313CoreOO::StrainMeasInfo
StrainMeasInfo() | JY6313CoreOO::StrainMeasInfo


6313 C++ Programming Manual: JY6313CoreOOAIMode Class Reference

JY6313CoreOOAIMode Class Reference

AIMode. More...

#include <JY6313CoreOOAITask.h>

Detailed Description

AIMode.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/6313/JY6313CoreOOAITask.h


6313 C++ Programming Manual: Class Index

Class Index
A | B | C | D | E | F | J | P | S
A
AIAdvanced (JY6313CoreOO)
AIAnalogEdgeComparator (JY6313CoreOO)
AIAnalogHysteresisComparator (JY6313CoreOO)
AIAnalogTrigger (JY6313CoreOO)
AIAnalogWindowComparator (JY6313CoreOO)
AIChannel (JY6313CoreOO)
AIDigitalTrigger (JY6313CoreOO)
AISignalExport (JY6313CoreOO)
AISync (JY6313CoreOO)
AITrigger (JY6313CoreOO)
B
BankConfiguration (JY6313CoreOO)
BridgeCalInfo (JY6313CoreOO)
C
ConversionStatus (JY6313CoreOO)
D
DeviceMiscellaneousParam (JY6313CoreOO)
DeviceStatus (JY6313CoreOO)
E
ExternalReferenceClock (JY6313CoreOO)
F
FirmDriveInfo (JY6313CoreOO)
J
JY6313CoreOOAIMode
JY6313CoreOOAITask (JY6313CoreOO)
JY6313CoreOODevice (JY6313CoreOO)
JY6313CoreOOLog (JY6313CoreOO)
JY6313CoreOOProperty (JY6313CoreOO)
JY6313CoreOOReferenceClock (JY6313CoreOO)
JY6313DeviceInfo (JY6313CoreOO)
JY6313Miscellaneous (JY6313CoreOO)
JYDriverException (JY6313CoreOO)
P
PauseTrigger (JY6313CoreOO)
PowerLineRejection (JY6313CoreOO)
S
StrainMeasInfo (JY6313CoreOO)


6313 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO Directory Reference

  • File List
  • File Members
  • COO
COO Directory Reference

Directories

6313


6313 C++ Programming Manual: File List

  • File List
  • File Members
File List
Here is a list of all files with brief descriptions:
[detail level 123]
▼ COO
▼ 6313
JY6313CoreOOAITask.h
JY6313CoreOOCommon.h
JY6313CoreOODevice.h
JY6313CoreOOLog.h


6313 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- a -

  • ActivePolarity : JY6313CoreOO::PauseTrigger
  • Add() : JY6313CoreOO::AISignalExport
  • AddChannel() : JY6313CoreOO::JY6313CoreOOAITask
  • Advanced : JY6313CoreOO::JY6313CoreOOAITask
  • AIAnalogTrigger() : JY6313CoreOO::AIAnalogTrigger
  • AIBufferSizeInBytes : JY6313CoreOO::JY6313CoreOODevice
  • AIChannel() : JY6313CoreOO::AIChannel
  • AliasName : JY6313CoreOO::JY6313DeviceInfo
  • aliasName : JY6313CoreOO::FirmDriveInfo
  • Analog : JY6313CoreOO::AITrigger
  • AvailableSamples : JY6313CoreOO::JY6313CoreOOAITask


6313 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- b -

  • BankConfiguration() : JY6313CoreOO::BankConfiguration
  • BankID : JY6313CoreOO::AIChannel
  • Banks : JY6313CoreOO::JY6313CoreOODevice
  • BoardClockRate : JY6313CoreOO::JY6313CoreOODevice
  • BridgeCal : JY6313CoreOO::AIChannel
  • BridgeCalInfo() : JY6313CoreOO::BridgeCalInfo
  • BridgeConfigurationValue : JY6313CoreOO::AIChannel
  • BufLenInSamples : JY6313CoreOO::JY6313CoreOOAITask


6313 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- c -

  • cardNumber : JY6313CoreOO::FirmDriveInfo
  • ChannelID : JY6313CoreOO::AIChannel, JY6313CoreOO::ConversionStatus
  • Channels : JY6313CoreOO::JY6313CoreOOAITask
  • Clear() : JY6313CoreOO::AISignalExport
  • ClearAll() : JY6313CoreOO::AISignalExport
  • Comparator : JY6313CoreOO::AIAnalogTrigger
  • Condition : JY6313CoreOO::AIAnalogWindowComparator
  • Configuration : JY6313CoreOO::StrainMeasInfo
  • connected : JY6313CoreOO::FirmDriveInfo
  • ConversionStatus() : JY6313CoreOO::ConversionStatus
  • CRCError : JY6313CoreOO::ConversionStatus


6313 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- d -

  • Destination : JY6313CoreOO::AISignalExport
  • Device : JY6313CoreOO::JY6313CoreOOAITask
  • DeviceID : JY6313CoreOO::JY6313CoreOODevice
  • DeviceMiscellaneousParam() : JY6313CoreOO::DeviceMiscellaneousParam
  • DeviceStatus() : JY6313CoreOO::DeviceStatus
  • Digital : JY6313CoreOO::AITrigger
  • DisableAICalibration : JY6313CoreOO::DeviceMiscellaneousParam
  • DisableAIFlatnessCalibration : JY6313CoreOO::DeviceMiscellaneousParam
  • DisableDigitalTriggerDelay : JY6313CoreOO::JY6313CoreOOAITask
  • DisableTBCalibration : JY6313CoreOO::DeviceMiscellaneousParam
  • DriverSetVer : JY6313CoreOO::FirmDriveInfo


6313 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- e -

  • Edge : JY6313CoreOO::AIAnalogTrigger, JY6313CoreOO::AIDigitalTrigger
  • EnableLog : JY6313CoreOO::JY6313CoreOOLog
  • errorCode : JY6313CoreOO::JYDriverException
  • ErrorFlagged : JY6313CoreOO::ConversionStatus
  • exceptionMessage : JY6313CoreOO::JYDriverException
  • ExcitationVoltage : JY6313CoreOO::AIChannel
  • ExcitationVoltageRequired : JY6313CoreOO::AIChannel
  • External : JY6313CoreOO::JY6313CoreOOReferenceClock


6313 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- f -

  • FilterSuturated : JY6313CoreOO::ConversionStatus
  • FirmwareVer : JY6313CoreOO::FirmDriveInfo
  • FirmwareVersion : JY6313CoreOO::JY6313DeviceInfo
  • FirmwareVersionInt : JY6313CoreOO::JY6313DeviceInfo
  • Flush() : JY6313CoreOO::JY6313CoreOOLog
  • FollowingException : JY6313CoreOO::JYDriverException
  • FrameworkVer : JY6313CoreOO::FirmDriveInfo
  • Frequency : JY6313CoreOO::PowerLineRejection
  • fStreaming : JY6313CoreOO::FirmDriveInfo


6313 C++ Programming Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • f
  • g
  • j
  • o
  • p
  • r
  • s
  • u
  • ~
Here is a list of all functions with links to the classes they belong to:

- a -

  • Add() : JY6313CoreOO::AISignalExport
  • AddChannel() : JY6313CoreOO::JY6313CoreOOAITask
  • AIAnalogTrigger() : JY6313CoreOO::AIAnalogTrigger
  • AIChannel() : JY6313CoreOO::AIChannel

- b -

  • BankConfiguration() : JY6313CoreOO::BankConfiguration
  • BridgeCalInfo() : JY6313CoreOO::BridgeCalInfo

- c -

  • Clear() : JY6313CoreOO::AISignalExport
  • ClearAll() : JY6313CoreOO::AISignalExport
  • ConversionStatus() : JY6313CoreOO::ConversionStatus

- d -

  • DeviceMiscellaneousParam() : JY6313CoreOO::DeviceMiscellaneousParam
  • DeviceStatus() : JY6313CoreOO::DeviceStatus

- f -

  • Flush() : JY6313CoreOO::JY6313CoreOOLog

- g -

  • GetAICalibrationState() : JY6313CoreOO::JY6313Miscellaneous
  • GetAIFlatnessCalibrationState() : JY6313CoreOO::JY6313Miscellaneous
  • GetAliasName() : JY6313CoreOO::JY6313DeviceInfo
  • GetConversionStatus() : JY6313CoreOO::JY6313CoreOOAITask
  • GetInstance() : JY6313CoreOO::JY6313CoreOODevice
  • GetPID() : JY6313CoreOO::JY6313DeviceInfo
  • GetSlotNum() : JY6313CoreOO::JY6313DeviceInfo
  • GetSN() : JY6313CoreOO::JY6313DeviceInfo
  • GetTBCalibrationState() : JY6313CoreOO::JY6313Miscellaneous

- j -

  • JY6313CoreOOAITask() : JY6313CoreOO::JY6313CoreOOAITask
  • JY6313CoreOOProperty() : JY6313CoreOO::JY6313CoreOOProperty< ContainerClass, ValueType, propertyType >
  • JY6313DeviceInfo() : JY6313CoreOO::JY6313DeviceInfo
  • JYDriverException() : JY6313CoreOO::JYDriverException

- o -

  • operator ValueType() : JY6313CoreOO::JY6313CoreOOProperty< ContainerClass, ValueType, propertyType >
  • operator=() : JY6313CoreOO::BankConfiguration, JY6313CoreOO::JY6313CoreOOProperty< ContainerClass, ValueType, propertyType >

- p -

  • PerformOffsetNulling() : JY6313CoreOO::JY6313CoreOOAITask
  • PerformShuntCalibration() : JY6313CoreOO::JY6313CoreOOAITask
  • Print() : JY6313CoreOO::JY6313CoreOOLog

- r -

  • ReadData() : JY6313CoreOO::JY6313CoreOOAITask
  • ReadRatiometricData() : JY6313CoreOO::JY6313CoreOOAITask
  • ReadRawData() : JY6313CoreOO::JY6313CoreOOAITask
  • ReadSinglePoint() : JY6313CoreOO::JY6313CoreOOAITask
  • RemoveChannel() : JY6313CoreOO::JY6313CoreOOAITask

- s -

  • SendSoftwareTrigger() : JY6313CoreOO::JY6313CoreOOAITask
  • SetAICalibrationState() : JY6313CoreOO::JY6313Miscellaneous
  • SetAIFlatnessCalibrationState() : JY6313CoreOO::JY6313Miscellaneous
  • SetTBCalibrationState() : JY6313CoreOO::JY6313Miscellaneous
  • Start() : JY6313CoreOO::JY6313CoreOOAITask
  • Stop() : JY6313CoreOO::JY6313CoreOOAITask
  • StrainMeasInfo() : JY6313CoreOO::StrainMeasInfo

- u -

  • Update() : JY6313CoreOO::ConversionStatus

- ~ -

  • ~AIAnalogTrigger() : JY6313CoreOO::AIAnalogTrigger
  • ~DeviceStatus() : JY6313CoreOO::DeviceStatus
  • ~JY6313CoreOOAITask() : JY6313CoreOO::JY6313CoreOOAITask


6313 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- g -

  • GageFactor : JY6313CoreOO::StrainMeasInfo
  • GageNominalResistance : JY6313CoreOO::StrainMeasInfo
  • Gain : JY6313CoreOO::AIChannel
  • GainAdjustment : JY6313CoreOO::BridgeCalInfo
  • GetAICalibrationState() : JY6313CoreOO::JY6313Miscellaneous
  • GetAIFlatnessCalibrationState() : JY6313CoreOO::JY6313Miscellaneous
  • GetAliasName() : JY6313CoreOO::JY6313DeviceInfo
  • GetConversionStatus() : JY6313CoreOO::JY6313CoreOOAITask
  • GetInstance() : JY6313CoreOO::JY6313CoreOODevice
  • GetPID() : JY6313CoreOO::JY6313DeviceInfo
  • GetSlotNum() : JY6313CoreOO::JY6313DeviceInfo
  • GetSN() : JY6313CoreOO::JY6313DeviceInfo
  • GetTBCalibrationState() : JY6313CoreOO::JY6313Miscellaneous
  • GroupDelay : JY6313CoreOO::JY6313CoreOOAITask


6313 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- h -

  • Handle : JY6313CoreOO::DeviceMiscellaneousParam
  • HardwareVer : JY6313CoreOO::FirmDriveInfo
  • HardwareVersion : JY6313CoreOO::JY6313DeviceInfo
  • HighThreshold : JY6313CoreOO::AIAnalogHysteresisComparator, JY6313CoreOO::AIAnalogWindowComparator
  • Hysteresis : JY6313CoreOO::AIAnalogTrigger


6313 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- i -

  • ID : JY6313CoreOO::BankConfiguration
  • IEPEAvailable : JY6313CoreOO::JY6313DeviceInfo
  • Info : JY6313CoreOO::JY6313CoreOODevice
  • IsAISync : JY6313CoreOO::JY6313CoreOODevice
  • IsAOSync : JY6313CoreOO::JY6313CoreOODevice
  • IsPXIeDevice : JY6313CoreOO::JY6313DeviceInfo


6313 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- j -

  • JY6313CoreOOAITask() : JY6313CoreOO::JY6313CoreOOAITask
  • JY6313CoreOOProperty() : JY6313CoreOO::JY6313CoreOOProperty< ContainerClass, ValueType, propertyType >
  • JY6313DeviceInfo() : JY6313CoreOO::JY6313DeviceInfo
  • JYDriverException() : JY6313CoreOO::JYDriverException


6313 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- l -

  • LeadWireResistance : JY6313CoreOO::BridgeCalInfo
  • LineCountPerPort : JY6313CoreOO::JY6313CoreOODevice
  • LogLevel : JY6313CoreOO::JY6313CoreOOLog
  • LowThreshold : JY6313CoreOO::AIAnalogHysteresisComparator, JY6313CoreOO::AIAnalogWindowComparator


6313 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- m -

  • MaterialPoissonFactor : JY6313CoreOO::StrainMeasInfo
  • MaxLowLatencyModeSampleRate : JY6313CoreOO::JY6313CoreOODevice
  • MaxSampleRate : JY6313CoreOO::JY6313CoreOODevice
  • Measurement_Type : JY6313CoreOO::AIChannel
  • MinExcitationVoltage : JY6313CoreOO::JY6313CoreOODevice
  • MinNormalModeSampleRate : JY6313CoreOO::JY6313CoreOODevice
  • MinSampleRate : JY6313CoreOO::JY6313CoreOODevice
  • Mode : JY6313CoreOO::AITrigger, JY6313CoreOO::JY6313CoreOOAITask
  • model : JY6313CoreOO::FirmDriveInfo


6313 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- n -

  • NullingCoef : JY6313CoreOO::BridgeCalInfo


6313 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- o -

  • Operation_Mode : JY6313CoreOO::JY6313CoreOOAITask
  • operator ValueType() : JY6313CoreOO::JY6313CoreOOProperty< ContainerClass, ValueType, propertyType >
  • operator=() : JY6313CoreOO::BankConfiguration, JY6313CoreOO::JY6313CoreOOProperty< ContainerClass, ValueType, propertyType >


6313 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- p -

  • PerformOffsetNulling() : JY6313CoreOO::JY6313CoreOOAITask
  • PerformShuntCalibration() : JY6313CoreOO::JY6313CoreOOAITask
  • PID : JY6313CoreOO::FirmDriveInfo, JY6313CoreOO::JY6313DeviceInfo
  • PlatformType : JY6313CoreOO::FirmDriveInfo
  • PowerLine_Rejection : JY6313CoreOO::AIAdvanced
  • PreTriggerSamples : JY6313CoreOO::AITrigger
  • Print() : JY6313CoreOO::JY6313CoreOOLog
  • ProductionDate : JY6313CoreOO::FirmDriveInfo


6313 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- r -

  • RangeHigh : JY6313CoreOO::AIChannel
  • RangeLow : JY6313CoreOO::AIChannel
  • RawDataScaleFactor : JY6313CoreOO::AIChannel
  • ReadData() : JY6313CoreOO::JY6313CoreOOAITask
  • ReadRatiometricData() : JY6313CoreOO::JY6313CoreOOAITask
  • ReadRawData() : JY6313CoreOO::JY6313CoreOOAITask
  • ReadSinglePoint() : JY6313CoreOO::JY6313CoreOOAITask
  • ReferenceClock : JY6313CoreOO::JY6313CoreOODevice
  • RemoveChannel() : JY6313CoreOO::JY6313CoreOOAITask
  • ReTriggerCount : JY6313CoreOO::AITrigger


6313 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- s -

  • SampleRate : JY6313CoreOO::JY6313CoreOOAITask
  • SamplesToAcquire : JY6313CoreOO::JY6313CoreOOAITask
  • SelectedReferenceClock : JY6313CoreOO::JY6313CoreOOReferenceClock
  • SendSoftwareTrigger() : JY6313CoreOO::JY6313CoreOOAITask
  • serialNumber : JY6313CoreOO::FirmDriveInfo
  • SetAICalibrationState() : JY6313CoreOO::JY6313Miscellaneous
  • SetAIFlatnessCalibrationState() : JY6313CoreOO::JY6313Miscellaneous
  • SetTBCalibrationState() : JY6313CoreOO::JY6313Miscellaneous
  • SignalExport : JY6313CoreOO::JY6313CoreOOAITask
  • Slope : JY6313CoreOO::AIAnalogEdgeComparator, JY6313CoreOO::AIAnalogHysteresisComparator
  • SlotNum : JY6313CoreOO::JY6313DeviceInfo
  • slotNum : JY6313CoreOO::FirmDriveInfo
  • SN : JY6313CoreOO::JY6313DeviceInfo
  • Source : JY6313CoreOO::AIAnalogTrigger, JY6313CoreOO::AIDigitalTrigger, JY6313CoreOO::JY6313CoreOOReferenceClock
  • Start() : JY6313CoreOO::JY6313CoreOOAITask
  • State : JY6313CoreOO::AISync
  • Status : JY6313CoreOO::JY6313CoreOODevice
  • Stop() : JY6313CoreOO::JY6313CoreOOAITask
  • Strain : JY6313CoreOO::AIChannel
  • StrainMeasInfo() : JY6313CoreOO::StrainMeasInfo
  • SubCardADCChannelNum : JY6313CoreOO::JY6313CoreOODevice
  • Sync : JY6313CoreOO::JY6313CoreOOAITask


6313 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- t -

  • Temperature : JY6313CoreOO::DeviceStatus
  • Terminal : JY6313CoreOO::AISync, JY6313CoreOO::ExternalReferenceClock, JY6313CoreOO::PauseTrigger
  • TerminalBlock : JY6313CoreOO::BankConfiguration
  • Threshold : JY6313CoreOO::AIAnalogEdgeComparator
  • Topology : JY6313CoreOO::AISync
  • TotalNumberOfChannels : JY6313CoreOO::JY6313CoreOODevice
  • TransferedSamples : JY6313CoreOO::JY6313CoreOOAITask
  • Trigger : JY6313CoreOO::JY6313CoreOOAITask
  • Type : JY6313CoreOO::AITrigger


6313 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- u -

  • Update() : JY6313CoreOO::ConversionStatus


6313 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- v -

  • vendorName : JY6313CoreOO::FirmDriveInfo
  • VID : JY6313CoreOO::FirmDriveInfo


6313 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w
Here is a list of all variables with links to the classes they belong to:

- a -

  • ActivePolarity : JY6313CoreOO::PauseTrigger
  • Advanced : JY6313CoreOO::JY6313CoreOOAITask
  • AIBufferSizeInBytes : JY6313CoreOO::JY6313CoreOODevice
  • AliasName : JY6313CoreOO::JY6313DeviceInfo
  • aliasName : JY6313CoreOO::FirmDriveInfo
  • Analog : JY6313CoreOO::AITrigger
  • AvailableSamples : JY6313CoreOO::JY6313CoreOOAITask

- b -

  • BankID : JY6313CoreOO::AIChannel
  • Banks : JY6313CoreOO::JY6313CoreOODevice
  • BoardClockRate : JY6313CoreOO::JY6313CoreOODevice
  • BridgeCal : JY6313CoreOO::AIChannel
  • BridgeConfigurationValue : JY6313CoreOO::AIChannel
  • BufLenInSamples : JY6313CoreOO::JY6313CoreOOAITask

- c -

  • cardNumber : JY6313CoreOO::FirmDriveInfo
  • ChannelID : JY6313CoreOO::AIChannel, JY6313CoreOO::ConversionStatus
  • Channels : JY6313CoreOO::JY6313CoreOOAITask
  • Comparator : JY6313CoreOO::AIAnalogTrigger
  • Condition : JY6313CoreOO::AIAnalogWindowComparator
  • Configuration : JY6313CoreOO::StrainMeasInfo
  • connected : JY6313CoreOO::FirmDriveInfo
  • CRCError : JY6313CoreOO::ConversionStatus

- d -

  • Destination : JY6313CoreOO::AISignalExport
  • Device : JY6313CoreOO::JY6313CoreOOAITask
  • DeviceID : JY6313CoreOO::JY6313CoreOODevice
  • Digital : JY6313CoreOO::AITrigger
  • DisableAICalibration : JY6313CoreOO::DeviceMiscellaneousParam
  • DisableAIFlatnessCalibration : JY6313CoreOO::DeviceMiscellaneousParam
  • DisableDigitalTriggerDelay : JY6313CoreOO::JY6313CoreOOAITask
  • DisableTBCalibration : JY6313CoreOO::DeviceMiscellaneousParam
  • DriverSetVer : JY6313CoreOO::FirmDriveInfo

- e -

  • Edge : JY6313CoreOO::AIAnalogTrigger, JY6313CoreOO::AIDigitalTrigger
  • EnableLog : JY6313CoreOO::JY6313CoreOOLog
  • errorCode : JY6313CoreOO::JYDriverException
  • ErrorFlagged : JY6313CoreOO::ConversionStatus
  • exceptionMessage : JY6313CoreOO::JYDriverException
  • ExcitationVoltage : JY6313CoreOO::AIChannel
  • ExcitationVoltageRequired : JY6313CoreOO::AIChannel
  • External : JY6313CoreOO::JY6313CoreOOReferenceClock

- f -

  • FilterSuturated : JY6313CoreOO::ConversionStatus
  • FirmwareVer : JY6313CoreOO::FirmDriveInfo
  • FirmwareVersion : JY6313CoreOO::JY6313DeviceInfo
  • FirmwareVersionInt : JY6313CoreOO::JY6313DeviceInfo
  • FollowingException : JY6313CoreOO::JYDriverException
  • FrameworkVer : JY6313CoreOO::FirmDriveInfo
  • Frequency : JY6313CoreOO::PowerLineRejection
  • fStreaming : JY6313CoreOO::FirmDriveInfo

- g -

  • GageFactor : JY6313CoreOO::StrainMeasInfo
  • GageNominalResistance : JY6313CoreOO::StrainMeasInfo
  • Gain : JY6313CoreOO::AIChannel
  • GainAdjustment : JY6313CoreOO::BridgeCalInfo
  • GroupDelay : JY6313CoreOO::JY6313CoreOOAITask

- h -

  • Handle : JY6313CoreOO::DeviceMiscellaneousParam
  • HardwareVer : JY6313CoreOO::FirmDriveInfo
  • HardwareVersion : JY6313CoreOO::JY6313DeviceInfo
  • HighThreshold : JY6313CoreOO::AIAnalogHysteresisComparator, JY6313CoreOO::AIAnalogWindowComparator
  • Hysteresis : JY6313CoreOO::AIAnalogTrigger

- i -

  • ID : JY6313CoreOO::BankConfiguration
  • IEPEAvailable : JY6313CoreOO::JY6313DeviceInfo
  • Info : JY6313CoreOO::JY6313CoreOODevice
  • IsAISync : JY6313CoreOO::JY6313CoreOODevice
  • IsAOSync : JY6313CoreOO::JY6313CoreOODevice
  • IsPXIeDevice : JY6313CoreOO::JY6313DeviceInfo

- l -

  • LeadWireResistance : JY6313CoreOO::BridgeCalInfo
  • LineCountPerPort : JY6313CoreOO::JY6313CoreOODevice
  • LogLevel : JY6313CoreOO::JY6313CoreOOLog
  • LowThreshold : JY6313CoreOO::AIAnalogHysteresisComparator, JY6313CoreOO::AIAnalogWindowComparator

- m -

  • MaterialPoissonFactor : JY6313CoreOO::StrainMeasInfo
  • MaxLowLatencyModeSampleRate : JY6313CoreOO::JY6313CoreOODevice
  • MaxSampleRate : JY6313CoreOO::JY6313CoreOODevice
  • Measurement_Type : JY6313CoreOO::AIChannel
  • MinExcitationVoltage : JY6313CoreOO::JY6313CoreOODevice
  • MinNormalModeSampleRate : JY6313CoreOO::JY6313CoreOODevice
  • MinSampleRate : JY6313CoreOO::JY6313CoreOODevice
  • Mode : JY6313CoreOO::AITrigger, JY6313CoreOO::JY6313CoreOOAITask
  • model : JY6313CoreOO::FirmDriveInfo

- n -

  • NullingCoef : JY6313CoreOO::BridgeCalInfo

- o -

  • Operation_Mode : JY6313CoreOO::JY6313CoreOOAITask

- p -

  • PID : JY6313CoreOO::FirmDriveInfo, JY6313CoreOO::JY6313DeviceInfo
  • PlatformType : JY6313CoreOO::FirmDriveInfo
  • PowerLine_Rejection : JY6313CoreOO::AIAdvanced
  • PreTriggerSamples : JY6313CoreOO::AITrigger
  • ProductionDate : JY6313CoreOO::FirmDriveInfo

- r -

  • RangeHigh : JY6313CoreOO::AIChannel
  • RangeLow : JY6313CoreOO::AIChannel
  • RawDataScaleFactor : JY6313CoreOO::AIChannel
  • ReferenceClock : JY6313CoreOO::JY6313CoreOODevice
  • ReTriggerCount : JY6313CoreOO::AITrigger

- s -

  • SampleRate : JY6313CoreOO::JY6313CoreOOAITask
  • SamplesToAcquire : JY6313CoreOO::JY6313CoreOOAITask
  • SelectedReferenceClock : JY6313CoreOO::JY6313CoreOOReferenceClock
  • serialNumber : JY6313CoreOO::FirmDriveInfo
  • SignalExport : JY6313CoreOO::JY6313CoreOOAITask
  • Slope : JY6313CoreOO::AIAnalogEdgeComparator, JY6313CoreOO::AIAnalogHysteresisComparator
  • SlotNum : JY6313CoreOO::JY6313DeviceInfo
  • slotNum : JY6313CoreOO::FirmDriveInfo
  • SN : JY6313CoreOO::JY6313DeviceInfo
  • Source : JY6313CoreOO::AIAnalogTrigger, JY6313CoreOO::AIDigitalTrigger, JY6313CoreOO::JY6313CoreOOReferenceClock
  • State : JY6313CoreOO::AISync
  • Status : JY6313CoreOO::JY6313CoreOODevice
  • Strain : JY6313CoreOO::AIChannel
  • SubCardADCChannelNum : JY6313CoreOO::JY6313CoreOODevice
  • Sync : JY6313CoreOO::JY6313CoreOOAITask

- t -

  • Temperature : JY6313CoreOO::DeviceStatus
  • Terminal : JY6313CoreOO::AISync, JY6313CoreOO::ExternalReferenceClock, JY6313CoreOO::PauseTrigger
  • TerminalBlock : JY6313CoreOO::BankConfiguration
  • Threshold : JY6313CoreOO::AIAnalogEdgeComparator
  • Topology : JY6313CoreOO::AISync
  • TotalNumberOfChannels : JY6313CoreOO::JY6313CoreOODevice
  • TransferedSamples : JY6313CoreOO::JY6313CoreOOAITask
  • Trigger : JY6313CoreOO::JY6313CoreOOAITask
  • Type : JY6313CoreOO::AITrigger

- v -

  • vendorName : JY6313CoreOO::FirmDriveInfo
  • VID : JY6313CoreOO::FirmDriveInfo

- w -

  • Window : JY6313CoreOO::AIAnalogTrigger


6313 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- w -

  • Window : JY6313CoreOO::AIAnalogTrigger


6313 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- ~ -

  • ~AIAnalogTrigger() : JY6313CoreOO::AIAnalogTrigger
  • ~DeviceStatus() : JY6313CoreOO::DeviceStatus
  • ~JY6313CoreOOAITask() : JY6313CoreOO::JY6313CoreOOAITask


6313 C++ Programming Manual: File Members

  • File List
  • File Members
  • All
  • Macros
Here is a list of all file members with links to the files they belong to:
  • _CRT_SECURE_NO_WARNINGS : JY6313CoreOOAITask.h
  • EXTERN_C : JY6313CoreOOCommon.h
  • JY6313CoreOO_API : JY6313CoreOOCommon.h


6313 C++ Programming Manual: File Members

  • File List
  • File Members
  • All
  • Macros
Here is a list of all macros with links to the files they belong to:
  • _CRT_SECURE_NO_WARNINGS : JY6313CoreOOAITask.h
  • EXTERN_C : JY6313CoreOOCommon.h
  • JY6313CoreOO_API : JY6313CoreOOCommon.h


6313 C++ Programming Manual: Main Page

6313 C++ Programming Manual Documentation


6313 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
  • a
  • c
  • e
  • g
  • j
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- a -

  • AIAnalogTriggerComparator : JY6313CoreOO
  • AIAnalogTriggerEdge : JY6313CoreOO
  • AIAnalogTriggerSource : JY6313CoreOO
  • AIAnalogWindowCondition : JY6313CoreOO
  • AIDigitalTriggerEdge : JY6313CoreOO
  • AIDigitalTriggerSource : JY6313CoreOO
  • AIGain : JY6313CoreOO
  • AIMode : JY6313CoreOO
  • AISampleClockSource : JY6313CoreOO
  • AISignalExportSource : JY6313CoreOO
  • AITriggerMode : JY6313CoreOO
  • AITriggerType : JY6313CoreOO

- c -

  • ChannelRangeAssignMode : JY6313CoreOO

- e -

  • ExternalReferenceClockTerminal : JY6313CoreOO

- g -

  • GetGainValue() : JY6313CoreOO
  • GetSignalExportDestinationString() : JY6313CoreOO

- j -

  • JY6313_AI_Continuous : JY6313Import
  • JY6313_AI_Finite : JY6313Import
  • JY6313_AI_Single : JY6313Import
  • JY6313_AnlogTriggerCondition_EnteringWindow : JY6313Import
  • JY6313_AnlogTriggerCondition_FallingHysteresis : JY6313Import
  • JY6313_AnlogTriggerCondition_LeavingWindow : JY6313Import
  • JY6313_AnlogTriggerCondition_RisingHysteresis : JY6313Import
  • JY6313_DigitalTriggerEdge_Falling : JY6313Import
  • JY6313_DigitalTriggerEdge_Rising : JY6313Import
  • JY6313_DigitalTriggerSource_BUS_0 : JY6313Import
  • JY6313_DigitalTriggerSource_BUS_1 : JY6313Import
  • JY6313_DigitalTriggerSource_BUS_2 : JY6313Import
  • JY6313_DigitalTriggerSource_BUS_3 : JY6313Import
  • JY6313_DigitalTriggerSource_BUS_4 : JY6313Import
  • JY6313_DigitalTriggerSource_BUS_5 : JY6313Import
  • JY6313_DigitalTriggerSource_BUS_6 : JY6313Import
  • JY6313_DigitalTriggerSource_BUS_7 : JY6313Import
  • JY6313_DigitalTriggerSource_ExtTrg : JY6313Import
  • JY6313_ExportSource_EndOfAcquisition : JY6313Import
  • JY6313_ExportSource_EndOfRecord : JY6313Import
  • JY6313_ExportSource_ReadyForTrig : JY6313Import
  • JY6313_ExportSource_SampleClock : JY6313Import
  • JY6313_ExportSource_SyncPulse : JY6313Import
  • JY6313_ExportSource_Trig : JY6313Import
  • JY6313_Onboard_25M : JY6313Import
  • JY6313_PXIe_Clk_100M : JY6313Import
  • JY6313_Ratio_FullBridge : JY6313Import
  • JY6313_Strain_FullBridgeI : JY6313Import
  • JY6313_Strain_FullBridgeII : JY6313Import
  • JY6313_Strain_FullBridgeIII : JY6313Import
  • JY6313_Strain_HalfBridgeI : JY6313Import
  • JY6313_Strain_HalfBridgeII : JY6313Import
  • JY6313_Strain_QuarterBridgeI : JY6313Import
  • JY6313_Strain_QuarterBridgeII : JY6313Import
  • JY6313_SyncMode_Master : JY6313Import
  • JY6313_SyncMode_Slave : JY6313Import
  • JY6313_SyncMode_Sole : JY6313Import
  • JY6313_TriggerType_Analog : JY6313Import
  • JY6313_TriggerType_Digital : JY6313Import
  • JY6313_TriggerType_Immediately : JY6313Import
  • JY6313_TriggerType_Software : JY6313Import
  • JY6313CoreOOLogLevel : JY6313CoreOO
  • JY6313CoreOOPropertyType : JY6313CoreOO
  • JYDriverExceptionPublic : JY6313CoreOO

- l -

  • LevelPolarity : JY6313CoreOO

- m -

  • MeasurementType : JY6313CoreOO

- o -

  • OperationMode : JY6313CoreOO
  • OutputCompleteState : JY6313CoreOO

- p -

  • PowerLineFrequency : JY6313CoreOO

- r -

  • ReferenceClockSource : JY6313CoreOO

- s -

  • SignalExportDestination : JY6313CoreOO
  • Sinc5Filter : JY6313Import
  • StrainConfiguration : JY6313CoreOO
  • SyncState : JY6313CoreOO
  • SyncTerminal : JY6313CoreOO
  • SyncTopology : JY6313CoreOO

- t -

  • TB6313_SC_R100k : JY6313Import
  • TB6313_SC_R50k : JY6313Import
  • TerminalBlockType : JY6313CoreOO

- w -

  • WidebandLowRippleFilter : JY6313Import


6313 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
Here is a list of all namespace enums with links to the namespace documentation for each enum:
  • AIAnalogTriggerComparator : JY6313CoreOO
  • AIAnalogTriggerEdge : JY6313CoreOO
  • AIAnalogTriggerSource : JY6313CoreOO
  • AIAnalogWindowCondition : JY6313CoreOO
  • AIDigitalTriggerEdge : JY6313CoreOO
  • AIDigitalTriggerSource : JY6313CoreOO
  • AIGain : JY6313CoreOO
  • AIMode : JY6313CoreOO
  • AISampleClockSource : JY6313CoreOO
  • AISignalExportSource : JY6313CoreOO
  • AITriggerMode : JY6313CoreOO
  • AITriggerType : JY6313CoreOO
  • ChannelRangeAssignMode : JY6313CoreOO
  • ExternalReferenceClockTerminal : JY6313CoreOO
  • JY6313CoreOOLogLevel : JY6313CoreOO
  • JY6313CoreOOPropertyType : JY6313CoreOO
  • JYDriverExceptionPublic : JY6313CoreOO
  • LevelPolarity : JY6313CoreOO
  • MeasurementType : JY6313CoreOO
  • OperationMode : JY6313CoreOO
  • OutputCompleteState : JY6313CoreOO
  • PowerLineFrequency : JY6313CoreOO
  • ReferenceClockSource : JY6313CoreOO
  • SignalExportDestination : JY6313CoreOO
  • StrainConfiguration : JY6313CoreOO
  • SyncState : JY6313CoreOO
  • SyncTerminal : JY6313CoreOO
  • SyncTopology : JY6313CoreOO
  • TerminalBlockType : JY6313CoreOO


6313 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
Here is a list of all namespace functions with links to the namespace documentation for each function:
  • GetGainValue() : JY6313CoreOO
  • GetSignalExportDestinationString() : JY6313CoreOO


6313 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
  • j
  • s
  • t
  • w
Here is a list of all namespace variables with links to the namespace documentation for each variable:

- j -

  • JY6313_AI_Continuous : JY6313Import
  • JY6313_AI_Finite : JY6313Import
  • JY6313_AI_Single : JY6313Import
  • JY6313_AnlogTriggerCondition_EnteringWindow : JY6313Import
  • JY6313_AnlogTriggerCondition_FallingHysteresis : JY6313Import
  • JY6313_AnlogTriggerCondition_LeavingWindow : JY6313Import
  • JY6313_AnlogTriggerCondition_RisingHysteresis : JY6313Import
  • JY6313_DigitalTriggerEdge_Falling : JY6313Import
  • JY6313_DigitalTriggerEdge_Rising : JY6313Import
  • JY6313_DigitalTriggerSource_BUS_0 : JY6313Import
  • JY6313_DigitalTriggerSource_BUS_1 : JY6313Import
  • JY6313_DigitalTriggerSource_BUS_2 : JY6313Import
  • JY6313_DigitalTriggerSource_BUS_3 : JY6313Import
  • JY6313_DigitalTriggerSource_BUS_4 : JY6313Import
  • JY6313_DigitalTriggerSource_BUS_5 : JY6313Import
  • JY6313_DigitalTriggerSource_BUS_6 : JY6313Import
  • JY6313_DigitalTriggerSource_BUS_7 : JY6313Import
  • JY6313_DigitalTriggerSource_ExtTrg : JY6313Import
  • JY6313_ExportSource_EndOfAcquisition : JY6313Import
  • JY6313_ExportSource_EndOfRecord : JY6313Import
  • JY6313_ExportSource_ReadyForTrig : JY6313Import
  • JY6313_ExportSource_SampleClock : JY6313Import
  • JY6313_ExportSource_SyncPulse : JY6313Import
  • JY6313_ExportSource_Trig : JY6313Import
  • JY6313_Onboard_25M : JY6313Import
  • JY6313_PXIe_Clk_100M : JY6313Import
  • JY6313_Ratio_FullBridge : JY6313Import
  • JY6313_Strain_FullBridgeI : JY6313Import
  • JY6313_Strain_FullBridgeII : JY6313Import
  • JY6313_Strain_FullBridgeIII : JY6313Import
  • JY6313_Strain_HalfBridgeI : JY6313Import
  • JY6313_Strain_HalfBridgeII : JY6313Import
  • JY6313_Strain_QuarterBridgeI : JY6313Import
  • JY6313_Strain_QuarterBridgeII : JY6313Import
  • JY6313_SyncMode_Master : JY6313Import
  • JY6313_SyncMode_Slave : JY6313Import
  • JY6313_SyncMode_Sole : JY6313Import
  • JY6313_TriggerType_Analog : JY6313Import
  • JY6313_TriggerType_Digital : JY6313Import
  • JY6313_TriggerType_Immediately : JY6313Import
  • JY6313_TriggerType_Software : JY6313Import

- s -

  • Sinc5Filter : JY6313Import

- t -

  • TB6313_SC_R100k : JY6313Import
  • TB6313_SC_R50k : JY6313Import

- w -

  • WidebandLowRippleFilter : JY6313Import


6313 C++ Programming Manual: Namespace List

  • Namespace List
  • Namespace Members
Namespace List
Here is a list of all namespaces with brief descriptions:
N JY6313CoreOO
N JY6313Import


6313 C++ Programming Manual: Member List

  • FirmDriveInfo
JY6313CoreOO::FirmDriveInfo Member List

This is the complete list of members for JY6313CoreOO::FirmDriveInfo, including all inherited members.

aliasName | JY6313CoreOO::FirmDriveInfo
cardNumber | JY6313CoreOO::FirmDriveInfo
connected | JY6313CoreOO::FirmDriveInfo
DriverSetVer | JY6313CoreOO::FirmDriveInfo
FirmwareVer | JY6313CoreOO::FirmDriveInfo
FrameworkVer | JY6313CoreOO::FirmDriveInfo
fStreaming | JY6313CoreOO::FirmDriveInfo
HardwareVer | JY6313CoreOO::FirmDriveInfo
model | JY6313CoreOO::FirmDriveInfo
PID | JY6313CoreOO::FirmDriveInfo
PlatformType | JY6313CoreOO::FirmDriveInfo
ProductionDate | JY6313CoreOO::FirmDriveInfo
serialNumber | JY6313CoreOO::FirmDriveInfo
slotNum | JY6313CoreOO::FirmDriveInfo
vendorName | JY6313CoreOO::FirmDriveInfo
VID | JY6313CoreOO::FirmDriveInfo