7131 C++ Programming Manual: D:/7131/C++/JY7131Core.h File Reference

7131 C++ Programming Manual
  • Main Page
  • Files
  • File List
  • File Members
  • 7131
  • C++
Typedefs | Enumerations | Functions
JY7131Core.h File Reference

Typedefs

typedef void * JY7131_DeviceHandle
Windows.

Enumerations

enum | JY7131_DOMode { JY7131_Sourcing = 0x0 , JY7131_Sinking = 0x1 , JY7131_PushPull = 0x2 }
enum | JY7131_CI_SampleMode { JY7131_CI_Finite = 0x0 , JY7131_CI_Continuous = 0x1 , JY7131_CI_Single = 0x2 }
enum | JY7131_CO_OutMode { JY7131_CO_Finite = 0x0 , JY7131_CO_ContinuousWrapping = 0x1 , JY7131_CO_ContinuousNoWrapping = 0x2 , JY7131_CO_Single = 0x3 }
enum | JY7131_CIO_TriggerType { JY7131_CIO_Immediately = 0x0 , JY7131_CIO_Soft = 0x1 , JY7131_CIO_Digital = 0x2 }
enum | JY7131_DigitalTriggerEdge { JY7131_Rising = 0x0 , JY7131_Falling = 0x1 }
enum JY7131_DigitalTriggerSource {
JY7131_PFI_In_0 = 0 , JY7131_PFI_In_1 = 1 , JY7131_PFI_In_2 = 2 , JY7131_PFI_In_3 = 3 ,
JY7131_PFI_In_4 = 4 , JY7131_PFI_In_5 = 5 , JY7131_PFI_In_6 = 6 , JY7131_PFI_In_7 = 7 ,
JY7131_PFI_In_8 = 8 , JY7131_PFI_In_9 = 9 , JY7131_PFI_In_10 = 10 , JY7131_PFI_In_11 = 11 ,
JY7131_PFI_In_12 = 12 , JY7131_PFI_In_13 = 13 , JY7131_PFI_In_14 = 14 , JY7131_PFI_In_15 = 15 ,
JY7131_PFI_In_16 = 16 , JY7131_PFI_In_17 = 17 , JY7131_PFI_In_18 = 18 , JY7131_PFI_In_19 = 19 ,
JY7131_PFI_In_20 = 20 , JY7131_PFI_In_21 = 21 , JY7131_PFI_In_22 = 22 , JY7131_PFI_In_23 = 23 ,
JY7131_PFI_In_24 = 24 , JY7131_PFI_In_25 = 25 , JY7131_PFI_In_26 = 26 , JY7131_PFI_In_27 = 27 ,
JY7131_PFI_In_28 = 28 , JY7131_PFI_In_29 = 29 , JY7131_PFI_In_30 = 30 , JY7131_PFI_In_31 = 31 ,
JY7131_PXI_Trig0 = 32 , JY7131_PXI_Trig1 = 33 , JY7131_PXI_Trig2 = 34 , JY7131_PXI_Trig3 = 35 ,
JY7131_PXI_Trig4 = 36 , JY7131_PXI_Trig5 = 37 , JY7131_PXI_Trig6 = 38 , JY7131_PXI_Trig7 = 39 ,
JY7131_CIO_0_StartTrig = 40 , JY7131_CIO_1_StartTrig = 41 , JY7131_CIO_2_StartTrig = 42 , JY7131_CIO_3_StartTrig = 43 ,
JY7131_CIO_4_StartTrig = 44 , JY7131_CIO_5_StartTrig = 45 , JY7131_CIO_6_StartTrig = 46 , JY7131_CIO_7_StartTrig = 47 ,
JY7131_Counter_0_Output = 48 , JY7131_Counter_1_Output = 49 , JY7131_Counter_2_Output = 50 , JY7131_Counter_3_Output = 51 ,
JY7131_Counter_4_Output = 52 , JY7131_Counter_5_Output = 53 , JY7131_Counter_6_Output = 54 , JY7131_Counter_7_Output = 55
}
enum JY7131_ExternalClockTerminal {
JY7131_Clock_PFI_In_0 = 0 , JY7131_Clock_PFI_In_1 = 1 , JY7131_Clock_PFI_In_2 = 2 , JY7131_Clock_PFI_In_3 = 3 ,
JY7131_Clock_PFI_In_4 = 4 , JY7131_Clock_PFI_In_5 = 5 , JY7131_Clock_PFI_In_6 = 6 , JY7131_Clock_PFI_In_7 = 7 ,
JY7131_Clock_PFI_In_8 = 8 , JY7131_Clock_PFI_In_9 = 9 , JY7131_Clock_PFI_In_10 = 10 , JY7131_Clock_PFI_In_11 = 11 ,
JY7131_Clock_PFI_In_12 = 12 , JY7131_Clock_PFI_In_13 = 13 , JY7131_Clock_PFI_In_14 = 14 , JY7131_Clock_PFI_In_15 = 15 ,
JY7131_Clock_PFI_In_16 = 16 , JY7131_Clock_PFI_In_17 = 17 , JY7131_Clock_PFI_In_18 = 18 , JY7131_Clock_PFI_In_19 = 19 ,
JY7131_Clock_PFI_In_20 = 20 , JY7131_Clock_PFI_In_21 = 21 , JY7131_Clock_PFI_In_22 = 22 , JY7131_Clock_PFI_In_23 = 23 ,
JY7131_Clock_PFI_In_24 = 24 , JY7131_Clock_PFI_In_25 = 25 , JY7131_Clock_PFI_In_26 = 26 , JY7131_Clock_PFI_In_27 = 27 ,
JY7131_Clock_PFI_In_28 = 28 , JY7131_Clock_PFI_In_29 = 29 , JY7131_Clock_PFI_In_30 = 30 , JY7131_Clock_PFI_In_31 = 31 ,
JY7131_Clock_PXI_Trig_0 = 32 , JY7131_Clock_PXI_Trig_1 = 33 , JY7131_Clock_PXI_Trig_2 = 34 , JY7131_Clock_PXI_Trig_3 = 35 ,
JY7131_Clock_PXI_Trig_4 = 36 , JY7131_Clock_PXI_Trig_5 = 37 , JY7131_Clock_PXI_Trig_6 = 38 , JY7131_Clock_PXI_Trig_7 = 39 ,
JY7131_Clock_CI_0_SampleClock = 40 , JY7131_Clock_CI_1_SampleClock = 41 , JY7131_Clock_CI_2_SampleClock = 42 , JY7131_Clock_CI_3_SampleClock = 43 ,
JY7131_Clock_CI_4_SampleClock = 44 , JY7131_Clock_CI_5_SampleClock = 45 , JY7131_Clock_CI_6_SampleClock = 46 , JY7131_Clock_CI_7_SampleClock = 47 ,
JY7131_Clock_Counter_0_Output = 48 , JY7131_Clock_Counter_1_Output = 49 , JY7131_Clock_Counter_2_Output = 50 , JY7131_Clock_Counter_3_Output = 51 ,
JY7131_Clock_Counter_4_Output = 52 , JY7131_Clock_Counter_5_Output = 53 , JY7131_Clock_Counter_6_Output = 54 , JY7131_Clock_Counter_7_Output = 55
}
enum JY7131_Signal_Source {
JY7131_Signal_PFI_In_0 = 0 , JY7131_Signal_PFI_In_2 = 2 , JY7131_Signal_PFI_In_3 = 3 , JY7131_Signal_PFI_In_4 = 4 ,
JY7131_Signal_PFI_In_5 = 5 , JY7131_Signal_PFI_In_6 = 6 , JY7131_Signal_PFI_In_7 = 7 , JY7131_Signal_PFI_In_8 = 8 ,
JY7131_Signal_PFI_In_9 = 9 , JY7131_Signal_PFI_In_10 = 10 , JY7131_Signal_PFI_In_11 = 11 , JY7131_Signal_PFI_In_12 = 12 ,
JY7131_Signal_PFI_In_13 = 13 , JY7131_Signal_PFI_In_14 = 14 , JY7131_Signal_PFI_In_15 = 15 , JY7131_Signal_PFI_In_16 = 16 ,
JY7131_Signal_PFI_In_17 = 17 , JY7131_Signal_PFI_In_18 = 18 , JY7131_Signal_PFI_In_19 = 19 , JY7131_Signal_PFI_In_20 = 20 ,
JY7131_Signal_PFI_In_21 = 21 , JY7131_Signal_PFI_In_22 = 22 , JY7131_Signal_PFI_In_23 = 23 , JY7131_Signal_PFI_In_24 = 24 ,
JY7131_Signal_PFI_In_25 = 25 , JY7131_Signal_PFI_In_26 = 26 , JY7131_Signal_PFI_In_27 = 27 , JY7131_Signal_PFI_In_28 = 28 ,
JY7131_Signal_PFI_In_29 = 29 , JY7131_Signal_PFI_In_30 = 30 , JY7131_Signal_PFI_In_31 = 31 , JY7131_Signal_PXI_Trig_0 = 32 ,
JY7131_Signal_PXI_Trig_1 = 33 , JY7131_Signal_PXI_Trig_2 = 34 , JY7131_Signal_PXI_Trig_3 = 35 , JY7131_Signal_PXI_Trig_4 = 36 ,
JY7131_Signal_PXI_Trig_5 = 37 , JY7131_Signal_PXI_Trig_6 = 38 , JY7131_Signal_PXI_Trig_7 = 39 , JY7131_Signal_CIO_0_StartTrig = 40 ,
JY7131_Signal_CIO_1_StartTrig = 41 , JY7131_Signal_CIO_2_StartTrig = 42 , JY7131_Signal_CIO_3_StartTrig = 43 , JY7131_Signal_CIO_4_StartTrig = 44 ,
JY7131_Signal_CIO_5_StartTrig = 45 , JY7131_Signal_CIO_6_StartTrig = 46 , JY7131_Signal_CIO_7_StartTrig = 47 , JY7131_Signal_Counter_0_Output = 48 ,
JY7131_Signal_Counter_1_Output = 49 , JY7131_Signal_Counter_2_Output = 50 , JY7131_Signal_Counter_3_Output = 51 , JY7131_Signal_Counter_4_Output = 52 ,
JY7131_Signal_Counter_5_Output = 53 , JY7131_Signal_Counter_6_Output = 54 , JY7131_Signal_Counter_7_Output = 55 , JY7131_Signal_CI_0_SampleClock = 56 ,
JY7131_Signal_CI_1_SampleClock = 57 , JY7131_Signal_CI_2_SampleClock = 58 , JY7131_Signal_CI_3_SampleClock = 59 , JY7131_Signal_CI_4_SampleClock = 60 ,
JY7131_Signal_CI_5_SampleClock = 61 , JY7131_Signal_CI_6_SampleClock = 62 , JY7131_Signal_CI_7_SampleClock = 63 , JY7131_Signal_CIO_100MHz = 64 ,
JY7131_Signal_CIO_5MHz = 65 , JY7131_Signal_CIO_100kHz = 66
}
enum JY7131_Signal_Destination {
JY7131_None = 40 , JY7131_PFI_Out_0 = 0 , JY7131_PFI_Out_1 = 1 , JY7131_PFI_Out_2 = 2 ,
JY7131_PFI_Out_3 = 3 , JY7131_PFI_Out_4 = 4 , JY7131_PFI_Out_5 = 5 , JY7131_PFI_Out_6 = 6 ,
JY7131_PFI_Out_7 = 7 , JY7131_PFI_Out_8 = 8 , JY7131_PFI_Out_9 = 9 , JY7131_PFI_Out_10 = 10 ,
JY7131_PFI_Out_11 = 11 , JY7131_PFI_Out_12 = 12 , JY7131_PFI_Out_13 = 13 , JY7131_PFI_Out_14 = 14 ,
JY7131_PFI_Out_15 = 15 , JY7131_PFI_Out_16 = 16 , JY7131_PFI_Out_17 = 17 , JY7131_PFI_Out_18 = 18 ,
JY7131_PFI_Out_19 = 19 , JY7131_PFI_Out_20 = 20 , JY7131_PFI_Out_21 = 21 , JY7131_PFI_Out_22 = 22 ,
JY7131_PFI_Out_23 = 23 , JY7131_PFI_Out_24 = 24 , JY7131_PFI_Out_25 = 25 , JY7131_PFI_Out_26 = 26 ,
JY7131_PFI_Out_27 = 27 , JY7131_PFI_Out_28 = 28 , JY7131_PFI_Out_29 = 29 , JY7131_PFI_Out_30 = 30 ,
JY7131_PFI_Out_31 = 31 , JY7131_PXITrig0_Out = 32 , JY7131_PXITrig1_Out = 33 , JY7131_PXITrig2_Out = 34 ,
JY7131_PXITrig3_Out = 35 , JY7131_PXITrig4_Out = 36 , JY7131_PXITrig5_Out = 37 , JY7131_PXITrig6_Out = 38 ,
JY7131_PXITrig7_Out = 39
}
enum | JY7131_CountTimeBase { JY7131_Internal_Timebase_100M = 0x0 , JY7131_Internal_Timebase_5M = 0x1 , JY7131_Internal_Timebase_100K = 0x2 , JY7131_External_Timebase = 0x3 }
enum | JY7131_CountDirection { JY7131_CI_Count_Up , JY7131_CI_Count_Down , JY7131_CI_Count_External }
enum JY7131_CI_MeasureType {
JY7131_CI_EdgeCount = 0 , JY7131_CI_Measure_FrequencyOrPeriod = 1 , JY7131_CI_Measure_EdgeSeparation = 4 , JY7131_CI_EncoderX1 = 5 ,
JY7131_CI_EncoderX2 = 6 , JY7131_CI_EncoderX4 = 7 , JY7131_CI_EncoderTwoPulse = 8
}
enum JY7131_InputTerminal {
JY7131_IN_PFI_In_0 = 0 , JY7131_IN_PFI_In_1 = 1 , JY7131_IN_PFI_In_2 = 2 , JY7131_IN_PFI_In_3 = 3 ,
JY7131_IN_PFI_In_4 = 4 , JY7131_IN_PFI_In_5 = 5 , JY7131_IN_PFI_In_6 = 6 , JY7131_IN_PFI_In_7 = 7 ,
JY7131_IN_PFI_In_8 = 8 , JY7131_IN_PFI_In_9 = 9 , JY7131_IN_PFI_In_10 = 10 , JY7131_IN_PFI_In_11 = 11 ,
JY7131_IN_PFI_In_12 = 12 , JY7131_IN_PFI_In_13 = 13 , JY7131_IN_PFI_In_14 = 14 , JY7131_IN_PFI_In_15 = 15 ,
JY7131_IN_PFI_In_16 = 16 , JY7131_IN_PFI_In_17 = 17 , JY7131_IN_PFI_In_18 = 18 , JY7131_IN_PFI_In_19 = 19 ,
JY7131_IN_PFI_In_20 = 20 , JY7131_IN_PFI_In_21 = 21 , JY7131_IN_PFI_In_22 = 22 , JY7131_IN_PFI_In_23 = 23 ,
JY7131_IN_PFI_In_24 = 24 , JY7131_IN_PFI_In_25 = 25 , JY7131_IN_PFI_In_26 = 26 , JY7131_IN_PFI_In_27 = 27 ,
JY7131_IN_PFI_In_28 = 28 , JY7131_IN_PFI_In_29 = 29 , JY7131_IN_PFI_In_30 = 30 , JY7131_IN_PFI_In_31 = 31 ,
JY7131_IN_PXI_Trig0 = 32 , JY7131_IN_PXI_Trig1 = 33 , JY7131_IN_PXI_Trig2 = 34 , JY7131_IN_PXI_Trig3 = 35 ,
JY7131_IN_PXI_Trig4 = 36 , JY7131_IN_PXI_Trig5 = 37 , JY7131_IN_PXI_Trig6 = 38 , JY7131_IN_PXI_Trig7 = 39 ,
JY7131_IN_CO_0_Output = 40 , JY7131_IN_CO_1_Output = 41 , JY7131_IN_CO_2_Output = 42 , JY7131_IN_CO_3_Output = 43 ,
JY7131_IN_CO_4_Output = 44 , JY7131_IN_CO_5_Output = 45 , JY7131_IN_CO_6_Output = 46 , JY7131_IN_CO_7_Output = 47 ,
JY7131_IN_CIO_100MHz = 48 , JY7131_IN_CIO_5MHz = 49 , JY7131_IN_CIO_100kHz = 50
}
enum | JY7131_CI_SampleClock { JY7131_CI_ImplicitClock = 0 , JY7131_CI_InternalClock = 1 , JY7131_CI_ExternalClock = 2 }
enum | JY7131_CI_CounterEventSignalIdleState { JY7131_CI_CounterEventSignalIdleState_Low = 0 , JY7131_CI_CounterEventSignalIdleState_High = 1 }
CI Counter Event Signal Idle State. More...
enum | JY7131_LevelState { JY7131_LowLevel = 0 , JY7131_HighLevel = 1 }
enum | JY7131_CI_ValueReturnMode { JY7131_CI_ReturnTwoValue = 0 , JY7131_CI_ReturnOneValue = 1 }
enum | JY7131_CI_StartingEdge { JY7131_RisingEdge = 0 , JY7131_FallingEdge = 1 , JY7131_AnyEdge = 2 }
enum | JY7131_CO_IdleState { JY7131_CO_LowLevel = 0 , JY7131_CO_HighLevel = 1 }
enum | JY7131_ReferenceClock { JY7131_Internal = 0 , JY7131_PXIe_Clk100 = 1 }
enum | JY7131_DOPowerOn_State { JY7131_PowerOn_High = 0 , JY7131_PowerOn_Low = 1 }

Functions

JY7131API int | JY7131_Open (int slotNumber, JY7131_DeviceHandle *hDevice)
Open the 7131 series boards using the slot number or the board serial number.
JY7131API int | JY7131_OpenByAliasName (const char *aliasName, JY7131_DeviceHandle *hDevice)
Open this 7131 series boards using the board alias name which is set by JYTEK utility JYDM.
JY7131API int | JY7131_Close (JY7131_DeviceHandle hDevice)
Close this 7131 board.
JY7131API int | JY7131_GetDeviceID (JY7131_DeviceHandle hDevice, int *deviceID)
Obtain the board ID.
JY7131API int | JY7131_GetDeviceSerialNumber (JY7131_DeviceHandle hDevice, char *serialNumber, int length)
Obtain the device serialNumber.
JY7131API int | JY7131_SetDeviceReferenceClock (JY7131_DeviceHandle hDevice, JY7131_ReferenceClock clockSource)
Set Reference Clock for the device.There are two ReferenceClock, 25MHz from this device or 100MHz from the PXIe chassis.
JY7131API int | JY7131_SetDOPowerOnState (JY7131_DeviceHandle hDevice, JY7131_DOMode *doMode, bool *writeValues, int length=32)
Set DO Power On State.
JY7131API int | JY7131_SignalRouting (JY7131_DeviceHandle hDevice, JY7131_Signal_Source sourceSignal, JY7131_Signal_Destination distination)
Get DO Power On State.
JY7131API int | JY7131_DisconnectSignalRouting (JY7131_DeviceHandle hDevice, JY7131_Signal_Destination destination)
Disconnect an established routing.
JY7131API int | JY7131_DI_AddLines (JY7131_DeviceHandle hDevice, unsigned int *port, unsigned int portCount)
DI Add port.
JY7131API int | JY7131_DI_ReadSinglePoint_U32 (JY7131_DeviceHandle hDevice, unsigned long *readValue)
Read DI single point.The data type is uint.
JY7131API int | JY7131_DI_ReadSinglePoint_ByPort (JY7131_DeviceHandle hDevice, bool *readValues, int port)
Read DI single port point.The data type is bool array.
JY7131API int | JY7131_DI_Start (JY7131_DeviceHandle hDevice)
DI Start.
JY7131API int | JY7131_DI_Stop (JY7131_DeviceHandle hDevice)
DI Stop.
JY7131API int | JY7131_DI_ReadSinglePoint_ByLine (JY7131_DeviceHandle hDevice, bool *readValue, unsigned int port, unsigned int line)
Read DI single line point.The data type is bool.
JY7131API int | JY7131_DO_AddLines (JY7131_DeviceHandle hDevice, unsigned int *port, unsigned int portCount)
DO Add port.
JY7131API int | JY7131_DO_SetOutMode (JY7131_DeviceHandle hDevice, JY7131_DOMode mode)
Set DO out mode.
JY7131API int | JY7131_DO_Start (JY7131_DeviceHandle hDevice)
DO Start.
JY7131API int | JY7131_DO_Stop (JY7131_DeviceHandle hDevice)
DO Stop.
JY7131API int | JY7131_DO_WriteSinglePoint_U32 (JY7131_DeviceHandle hDevice, unsigned int writeValue)
Write DO single point.The data type is uint.
JY7131API int | JY7131_DO_WriteSinglePoint_ByPort (JY7131_DeviceHandle hDevice, bool *writeValues, int port)
Write DO single point.The data type is bool array.
JY7131API int | JY7131_DO_WriteSinglePoint_ByLine (JY7131_DeviceHandle hDevice, bool writeValue, unsigned int port, unsigned int line)
Write DO single point.The data type is bool .
JY7131API int | JY7131_CI_EnableChannel (JY7131_DeviceHandle hDevice, unsigned int channel)
Enables CI channel.There are 8 counter,from 0 to 7.
JY7131API int | JY7131_CI_SetCounterType (JY7131_DeviceHandle hDevice, unsigned int channel, JY7131_CI_MeasureType measureType)
Set CI measure type.
JY7131API int | JY7131_CI_SetSignalReverse (JY7131_DeviceHandle hDevice, unsigned int channel, int signalReverse)
Set the Signal Reverse terminal.
JY7131API int | JY7131_CI_SetCounterParament (JY7131_DeviceHandle hDevice, unsigned int channel, int initCount, JY7131_CountDirection countDirection)
Set CI count parameter.
JY7131API int | JY7131_CI_SetZReloadEnabled (JY7131_DeviceHandle hDevice, unsigned int channel, bool zReloadEnabled)
Set the Z signal enable in Encoder mode.
JY7131API int | JY7131_CI_SetStartingEdge (JY7131_DeviceHandle hDevice, unsigned int channel, JY7131_CI_StartingEdge startingEdge)
Set starting edge，only valid in JY7131_CI_Measure_FrequencyOrPeriod。
JY7131API int | JY7131_CI_SetFirstSampleClock (JY7131_DeviceHandle hDevice, unsigned int channel, bool ignore)
Set the first sample clock data ignore or not.
JY7131API int | JY7131_CI_SetMode (JY7131_DeviceHandle hDevice, unsigned int channel, JY7131_CI_SampleMode mode)
Set counter input mode, the mode is defined by enum JY7131_CI_SampleMode.
JY7131API int | JY7131_CI_SetSampleClock (JY7131_DeviceHandle hDevice, unsigned int channel, JY7131_CI_SampleClock clock, JY7131_ExternalClockTerminal terminal, double rate)
Set counter input sampling clock source.
JY7131API int | JY7131_CI_SetTimeBase (JY7131_DeviceHandle hDevice, unsigned int channel, JY7131_CountTimeBase timebaseSrc, double externalTimebaseFreq, double *actualTimebaseFreq)
Set counter input time base,the time base defined by enum JY7131_CountTimeBase.
JY7131API int | JY7131_CI_SetSamplesToAcquire (JY7131_DeviceHandle hDevice, unsigned int channel, unsigned int samplesToAcquire)
Set samples to acquire in finite mode.The samples range is 1 to 4M.
JY7131API int | JY7131_CI_SetEdgeCountEvent (JY7131_DeviceHandle hDevice, unsigned int channel, JY7131_CI_CounterEventSignalIdleState idleState, unsigned int threshold)
Set the counter threshold, and when the count reaches this threshold, output a single pulse at the output terminal.
JY7131API int | JY7131_CI_SetPauseTriggerLevel (JY7131_DeviceHandle hDevice, unsigned int channel, bool enable, JY7131_LevelState pauseTriggerActiveLevel)
Config CI pause trigger.
JY7131API int | JY7131_CI_ReadSingleCountValue (JY7131_DeviceHandle hDevice, unsigned int channel, unsigned int *countValue)
Counter reads a single count value, this API supports the CI Type: JY7131_CI_EdgeCount、JY7131_CI_EncoderX1、 JY7131_CI_EncoderX2 、 JY7131_CI_EncoderX4 、JY7131_CI_EncoderTwoPulse.
JY7131API int | JY7131_CI_ReadSingleMeasureValue (JY7131_DeviceHandle hDevice, unsigned int channel, double *measureValue1, double *measureValue2, int timeOut)
Reads a single counter measurement as follows.
JY7131API int | JY7131_CI_ReadCountValues (JY7131_DeviceHandle hDevice, unsigned int channel, unsigned int *countValues, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
Counter reads the count values, this API is supprot CI Type ：JY7131_CI_EdgeCount、JY7131_CI_EncoderX1、 JY7131_CI_EncoderX2 、 JY7131_CI_EncoderX4 、JY7131_CI_EncoderTwoPulse.
JY7131API int | JY7131_CI_ReadMeasureValues (JY7131_DeviceHandle hDevice, unsigned int channel, double *measureValues1, double *measureValues2, unsigned int dataLength, int timeOut, unsigned int *actualReadLength)
Counter reads the measured values, this API only support CI Type for JY7131_CI_Measure_EdgeSeparation JY7131_CI_Measure_Pulse JY7131_CI_Measure_Frequency JY7131_CI_Measure_Period JY7131_CI_Measure_SemiPeriod for JY7131_CI_Measure_EdgeSeparation type, the measureValues1 is the Gate signel to the Aux signal interval, the measureValues2 is the Aux signel to the Gate signal interval, the unit is s.
JY7131API int | JY7131_CI_Start (JY7131_DeviceHandle hDevice, unsigned int channel)
Start Counter input.
JY7131API int | JY7131_CI_Stop (JY7131_DeviceHandle hDevice, unsigned int channel)
Stop Counter input.
JY7131API int | JY7131_CI_SetValueReturnMode (JY7131_DeviceHandle hDevice, unsigned int channel, JY7131_CI_ValueReturnMode mode)
Config CI return value mode, only for JY7131_CI_Measure_EdgeSeparation type.
JY7131API int | JY7131_CI_CheckBufferStatus (JY7131_DeviceHandle hDevice, unsigned int channel, unsigned long long *avaliableSamples, unsigned long long *transferedSamples, bool *overrun)
Check CI task buffer status.
JY7131API int | JY7131_CI_SendSoftTrigger (JY7131_DeviceHandle hDevice, int channel)
Send the software trigger signal for CI.
JY7131API int | JY7131_CI_SetStartTriggerType (JY7131_DeviceHandle hDevice, int channel, JY7131_CIO_TriggerType triggerTyp)
Set CI start trigger type,the triggerType is defined by enum JY7131_CI_TriggerType.
JY7131API int | JY7131_CI_SetDigitalStartTrigger (JY7131_DeviceHandle hDevice, int channel, JY7131_DigitalTriggerSource triggerSource, JY7131_DigitalTriggerEdge triggerEdge)
Set CI digital start trigger.the triggerSource is defined by enum JY7131_DigitalTriggerSource, the triggerEdge is defined by enum JY7131_DigitalTriggerEdge.
JY7131API int | JY7131_CI_SetSourceTerminal (JY7131_DeviceHandle hDevice, int channel, JY7131_InputTerminal sourceTerminal)
Set source terminal.
JY7131API int | JY7131_CI_SetGateTerminal (JY7131_DeviceHandle hDevice, int channel, JY7131_InputTerminal gateTerminal)
Set gate terminal.
JY7131API int | JY7131_CI_SetAuxTerminal (JY7131_DeviceHandle hDevice, int channel, JY7131_InputTerminal auxTerminal)
Set aux terminal.
JY7131API int | JY7131_CI_SetOutTerminal (JY7131_DeviceHandle hDevice, int channel, JY7131_Signal_Destination outTerminal)
Set out terminal.
JY7131API int | JY7131_CO_EnableChannel (JY7131_DeviceHandle hDevice, unsigned int channel)
Enabled counter output channel.
JY7131API int | JY7131_CO_SetOutTerminalMode (JY7131_DeviceHandle hDevice, unsigned int channel, JY7131_DOMode mode)
Set counter output terminal mode.
JY7131API int | JY7131_CO_SetCounterParament (JY7131_DeviceHandle hDevice, unsigned int channel, int pulseCount, JY7131_CO_IdleState IdleState, double delay)
Set CO parameter.
JY7131API int | JY7131_CO_SetFrequency (JY7131_DeviceHandle hDevice, unsigned int channel, unsigned int highTicks, unsigned int lowTicks)
Set counter output pulse frequency.
JY7131API int | JY7131_CO_WriteData (JY7131_DeviceHandle hDevice, int channel, unsigned int *dataBuffer, unsigned int dataLength, int timeOut, unsigned int *actualWriteLength)
CO write data.One sampling point consists of three datas, high level ticks, low level ticks, and number of pulses.
JY7131API int | JY7131_CO_CheckBufferStatus (JY7131_DeviceHandle hDevice, unsigned int channel, unsigned long *avaliableSamples, unsigned long long *transferedSamples, bool *overrun)
Check CO task buffer status.
JY7131API int | JY7131_CO_CheckCounterStatus (JY7131_DeviceHandle hDevice, unsigned int channel, unsigned int *pulseTransfered, bool *underflow)
Check counter output status.
JY7131API int | JY7131_CO_WaitUntilDone (JY7131_DeviceHandle hDevice, unsigned int channel, bool *done)
Check counter output complete status.
JY7131API int | JY7131_CO_SetSamplesToUpdate (JY7131_DeviceHandle hDevice, unsigned int channel, unsigned int samplesToUpdate)
Set CO samples for each channel in the finite mode.The sample range is from 1 to 4M samples.
JY7131API int | JY7131_CO_Start (JY7131_DeviceHandle hDevice, unsigned int channel)
Start counter output.
JY7131API int | JY7131_CO_Stop (JY7131_DeviceHandle hDevice, unsigned int channel)
Stop counter output.
JY7131API int | JY7131_CO_SendSoftTrigger (JY7131_DeviceHandle hDevice, int channel)
Send the software trigger signal.
JY7131API int | JY7131_CO_SetMode (JY7131_DeviceHandle hDevice, unsigned int channel, JY7131_CO_OutMode mode)
Set counter output mode, the mode defined by enum JY7131_CO_UpdateMode.
JY7131API int | JY7131_CO_SetStartTriggerType (JY7131_DeviceHandle hDevice, int channel, JY7131_CIO_TriggerType triggerTyp)
Set CO start trigger type,the triggerType is defined by enum JY7131_AI_TriggerType.
JY7131API int | JY7131_CO_SetDigitalStartTrigger (JY7131_DeviceHandle hDevice, int channel, JY7131_DigitalTriggerSource triggerSource, JY7131_DigitalTriggerEdge triggerEdge)
Set CO digital start trigger,the triggerSource is defined by enum JY7131_DigitalTriggerSource, the triggerEdge is defined by enum JY7131_DigitalTriggerEdge.
JY7131API int | JY7131_CO_SetTimeBase (JY7131_DeviceHandle hDevice, unsigned int channel, JY7131_CountTimeBase timebaseSrc, JY7131_InputTerminal externalTimebaseTerminal, double externalTimebaseFreq, double *actualTimebaseFreq)
Set counter output time base,the time base defined by enum JY7131_CountTimeBase.
JY7131API int | JY7131_CO_SetGateTerminal (JY7131_DeviceHandle hDevice, int channel, JY7131_InputTerminal gateTerminal)
Set CO gate terminal.
JY7131API int | JY7131_CO_SetPauseTriggerLevel (JY7131_DeviceHandle hDevice, unsigned int channel, bool enable, JY7131_LevelState pauseTriggerActiveLevel)
Config CO pause trigger.
JY7131API int | JY7131_CO_SetOutTerminal (JY7131_DeviceHandle hDevice, int channel, JY7131_Signal_Destination outTerminal)
Set CO out terminal.

Typedef Documentation

◆ JY7131_DeviceHandle

typedef void* JY7131_DeviceHandle

Windows.

Linux

Enumeration Type Documentation

◆ JY7131_CI_CounterEventSignalIdleState

enum JY7131_CI_CounterEventSignalIdleState

CI Counter Event Signal Idle State.

Enumerator
JY7131_CI_CounterEventSignalIdleState_Low | Low Level as the CI Counter Event Signal Idle State.
JY7131_CI_CounterEventSignalIdleState_High | High Level as the CI Counter Event Signal Idle State.

◆ JY7131_CI_MeasureType

enum JY7131_CI_MeasureType
Enumerator
JY7131_CI_EdgeCount | Edge count.
JY7131_CI_Measure_FrequencyOrPeriod | FrequencyOrPeriod Measurement.
JY7131_CI_Measure_EdgeSeparation | Two Edge Separation Measurement.
JY7131_CI_EncoderX1 | Quadrature Encoded X1.
JY7131_CI_EncoderX2 | Quadrature Encoded X2.
JY7131_CI_EncoderX4 | Quadrature Encoded X4.
JY7131_CI_EncoderTwoPulse | Two Pulse Encoder.

◆ JY7131_CI_SampleClock

enum JY7131_CI_SampleClock
Enumerator
JY7131_CI_ImplicitClock | CI Implicit Clock.
JY7131_CI_InternalClock | CI Internal Clock.
JY7131_CI_ExternalClock | CI External Clock.

◆ JY7131_CI_SampleMode

enum JY7131_CI_SampleMode
Enumerator
JY7131_CI_Finite | CI Finite mode.
JY7131_CI_Continuous | CI Continuous mode.
JY7131_CI_Single | CI Single mode.

◆ JY7131_CI_StartingEdge

enum JY7131_CI_StartingEdge
Enumerator
JY7131_RisingEdge | Rising edge as the start edge.
JY7131_FallingEdge | Falling edge as the start edge.
JY7131_AnyEdge | any edge edge as the start edge.

◆ JY7131_CI_ValueReturnMode

enum JY7131_CI_ValueReturnMode
Enumerator
JY7131_CI_ReturnTwoValue |
JY7131_CI_ReturnOneValue | High Level as the CI Counter Event Signal Idle State.

◆ JY7131_CIO_TriggerType

enum JY7131_CIO_TriggerType
Enumerator
JY7131_CIO_Immediately | CI Immediately trigger.
JY7131_CIO_Soft | CI Soft trigger.
JY7131_CIO_Digital | CI Digital trigger.

◆ JY7131_CO_IdleState

enum JY7131_CO_IdleState
Enumerator
JY7131_CO_LowLevel | Low Level as the co idle state.
JY7131_CO_HighLevel | High Level as the co idle state.

◆ JY7131_CO_OutMode

enum JY7131_CO_OutMode
Enumerator
JY7131_CO_Finite | CO Finite mode.
JY7131_CO_ContinuousWrapping | CO ContinuousWrapping mode.
JY7131_CO_ContinuousNoWrapping | CO ContinuousNoWrapping mode.
JY7131_CO_Single | CO Finite mode.

◆ JY7131_CountDirection

enum JY7131_CountDirection
Enumerator
JY7131_CI_Count_Up | Increases count.
JY7131_CI_Count_Down | Reduction count.
JY7131_CI_Count_External | External terminal determines the count direction.

◆ JY7131_CountTimeBase

enum JY7131_CountTimeBase
Enumerator
JY7131_Internal_Timebase_100M | 100MHz Internal TimeBase
JY7131_Internal_Timebase_5M | 5MHz Internal TimeBase
JY7131_Internal_Timebase_100K | 100KHz Internal TimeBase
JY7131_External_Timebase | External TimeBase.

◆ JY7131_DigitalTriggerEdge

enum JY7131_DigitalTriggerEdge
Enumerator
JY7131_Rising | Rsing edge for digital trigger.
JY7131_Falling | Falling edge for digital trigger.

◆ JY7131_DigitalTriggerSource

enum JY7131_DigitalTriggerSource
Enumerator
JY7131_PFI_In_0 | PFI_0 as the digital trigger source.
JY7131_PFI_In_1 | PFI_1 as the digital trigger source.
JY7131_PFI_In_2 | PFI_2 as the digital trigger source.
JY7131_PFI_In_3 | PFI_3 as the digital trigger source.
JY7131_PFI_In_4 | PFI_4 as the digital trigger source.
JY7131_PFI_In_5 | PFI_5 as the digital trigger source.
JY7131_PFI_In_6 | PFI_6 as the digital trigger source.
JY7131_PFI_In_7 | PFI_7 as the digital trigger source.
JY7131_PFI_In_8 | PFI_8 as the digital trigger source.
JY7131_PFI_In_9 | PFI_9 as the digital trigger source.
JY7131_PFI_In_10 | PFI_10 as the digital trigger source.
JY7131_PFI_In_11 | PFI_11 as the digital trigger source.
JY7131_PFI_In_12 | PFI_12 as the digital trigger source.
JY7131_PFI_In_13 | PFI_13 as the digital trigger source.
JY7131_PFI_In_14 | PFI_14 as the digital trigger source.
JY7131_PFI_In_15 | PFI_15 as the digital trigger source.
JY7131_PFI_In_16 | PFI_16 as the digital trigger source.
JY7131_PFI_In_17 | PFI_17 as the digital trigger source.
JY7131_PFI_In_18 | PFI_18 as the digital trigger source.
JY7131_PFI_In_19 | PFI_19 as the digital trigger source.
JY7131_PFI_In_20 | PFI_20 as the digital trigger source.
JY7131_PFI_In_21 | PFI_21 as the digital trigger source.
JY7131_PFI_In_22 | PFI_22 as the digital trigger source.
JY7131_PFI_In_23 | PFI_23 as the digital trigger source.
JY7131_PFI_In_24 | PFI_24 as the digital trigger source.
JY7131_PFI_In_25 | PFI_25 as the digital trigger source.
JY7131_PFI_In_26 | PFI_26 as the digital trigger source.
JY7131_PFI_In_27 | PFI_27 as the digital trigger source.
JY7131_PFI_In_28 | PFI_28 as the digital trigger source.
JY7131_PFI_In_29 | PFI_29 as the digital trigger source.
JY7131_PFI_In_30 | PFI_30 as the digital trigger source.
JY7131_PFI_In_31 | PFI_31 as the digital trigger source.
JY7131_PXI_Trig0 | PXI_Trig0 as the digital trigger source.
JY7131_PXI_Trig1 | PXI_Trig1 as the digital trigger source.
JY7131_PXI_Trig2 | PXI_Trig2 as the digital trigger source.
JY7131_PXI_Trig3 | PXI_Trig3 as the digital trigger source.
JY7131_PXI_Trig4 | PXI_Trig4 as the digital trigger source.
JY7131_PXI_Trig5 | PXI_Trig5 as the digital trigger source.
JY7131_PXI_Trig6 | PXI_Trig6 as the digital trigger source.
JY7131_PXI_Trig7 | PXI_Trig7 as the digital trigger source.
JY7131_CIO_0_StartTrig | CIO 0 StartTrig as the digital trigger source.
JY7131_CIO_1_StartTrig | CIO 1 StartTrig as the digital trigger source.
JY7131_CIO_2_StartTrig | CIO 2 StartTrig as the digital trigger source.
JY7131_CIO_3_StartTrig | CIO 3 StartTrig as the digital trigger source.
JY7131_CIO_4_StartTrig | CIO 4 StartTrig as the digital trigger source.
JY7131_CIO_5_StartTrig | CIO 5 StartTrig as the digital trigger source.
JY7131_CIO_6_StartTrig | CIO 6 StartTrig as the digital trigger source.
JY7131_CIO_7_StartTrig | CIO 7 StartTrig as the digital trigger source.
JY7131_Counter_0_Output | CO_0_Output as other task External Clock Source.
JY7131_Counter_1_Output | CO_1_Output as other task External Clock Source.
JY7131_Counter_2_Output | CO_2_Output as other task External Clock Source.
JY7131_Counter_3_Output | CO_3_Output as other task External Clock Source.
JY7131_Counter_4_Output | CO_4_Output as other task External Clock Source.
JY7131_Counter_5_Output | CO_5_Output as other task External Clock Source.
JY7131_Counter_6_Output | CO_6_Output as other task External Clock Source.
JY7131_Counter_7_Output | CO_7_Output as other task External Clock Source.

◆ JY7131_DOMode

enum JY7131_DOMode
Enumerator
JY7131_Sourcing
JY7131_Sinking
JY7131_PushPull

◆ JY7131_DOPowerOn_State

enum JY7131_DOPowerOn_State
Enumerator
JY7131_PowerOn_High | DO power on out put high level.
JY7131_PowerOn_Low | DO power on out put low level.

◆ JY7131_ExternalClockTerminal

enum JY7131_ExternalClockTerminal
Enumerator
JY7131_Clock_PFI_In_0 | PFI0 as External Clock Source.
JY7131_Clock_PFI_In_1 | PFI1 as External Clock Source.
JY7131_Clock_PFI_In_2 | PFI2 as External Clock Source.
JY7131_Clock_PFI_In_3 | PFI3 as External Clock Source.
JY7131_Clock_PFI_In_4 | PFI4 as External Clock Source.
JY7131_Clock_PFI_In_5 | PFI5 as External Clock Source.
JY7131_Clock_PFI_In_6 | PFI6 as External Clock Source.
JY7131_Clock_PFI_In_7 | PFI7 as External Clock Source.
JY7131_Clock_PFI_In_8 | PFI8 as External Clock Source.
JY7131_Clock_PFI_In_9 | PFI9 as External Clock Source.
JY7131_Clock_PFI_In_10 | PFI10 as External Clock Source.
JY7131_Clock_PFI_In_11 | PFI11 as External Clock Source.
JY7131_Clock_PFI_In_12 | PFI12 as External Clock Source.
JY7131_Clock_PFI_In_13 | PFI13 as External Clock Source.
JY7131_Clock_PFI_In_14 | PFI14 as External Clock Source.
JY7131_Clock_PFI_In_15 | PFI15 as External Clock Source.
JY7131_Clock_PFI_In_16 | PFI16 as External Clock Source.
JY7131_Clock_PFI_In_17 | PFI17 as External Clock Source.
JY7131_Clock_PFI_In_18 | PFI18 as External Clock Source.
JY7131_Clock_PFI_In_19 | PFI19 as External Clock Source.
JY7131_Clock_PFI_In_20 | PFI20 as External Clock Source.
JY7131_Clock_PFI_In_21 | PFI21 as External Clock Source.
JY7131_Clock_PFI_In_22 | PFI22 as External Clock Source.
JY7131_Clock_PFI_In_23 | PFI23 as External Clock Source.
JY7131_Clock_PFI_In_24 | PFI24 as External Clock Source.
JY7131_Clock_PFI_In_25 | PFI25 as External Clock Source.
JY7131_Clock_PFI_In_26 | PFI26 as External Clock Source.
JY7131_Clock_PFI_In_27 | PFI27 as External Clock Source.
JY7131_Clock_PFI_In_28 | PFI28 as External Clock Source.
JY7131_Clock_PFI_In_29 | PFI29 as External Clock Source.
JY7131_Clock_PFI_In_30 | PFI30 as External Clock Source.
JY7131_Clock_PFI_In_31 | PFI31 as External Clock Source.
JY7131_Clock_PXI_Trig_0 | PXI_Trig0 as External Clock Source.
JY7131_Clock_PXI_Trig_1 | PXI_Trig1 as External Clock Source.
JY7131_Clock_PXI_Trig_2 | PXI_Trig2 as External Clock Source.
JY7131_Clock_PXI_Trig_3 | PXI_Trig3 as External Clock Source.
JY7131_Clock_PXI_Trig_4 | PXI_Trig4 as External Clock Source.
JY7131_Clock_PXI_Trig_5 | PXI_Trig5 as External Clock Source.
JY7131_Clock_PXI_Trig_6 | PXI_Trig6 as External Clock Source.
JY7131_Clock_PXI_Trig_7 | PXI_Trig7 as External Clock Source.
JY7131_Clock_CI_0_SampleClock | CI0_SampleClock as other task External Clock Source.
JY7131_Clock_CI_1_SampleClock | CI1_SampleClock as other task External Clock Source.
JY7131_Clock_CI_2_SampleClock | CI2_SampleClock as other task External Clock Source.
JY7131_Clock_CI_3_SampleClock | CI3_SampleClock as other task External Clock Source.
JY7131_Clock_CI_4_SampleClock | CI4_SampleClock as other task External Clock Source.
JY7131_Clock_CI_5_SampleClock | CI5_SampleClock as other task External Clock Source.
JY7131_Clock_CI_6_SampleClock | CI6_SampleClock as other task External Clock Source.
JY7131_Clock_CI_7_SampleClock | CI7_SampleClock as other task External Clock Source.
JY7131_Clock_Counter_0_Output | CO_0_Output as other task External Clock Source.
JY7131_Clock_Counter_1_Output | CO_1_Output as other task External Clock Source.
JY7131_Clock_Counter_2_Output | CO_2_Output as other task External Clock Source.
JY7131_Clock_Counter_3_Output | CO_3_Output as other task External Clock Source.
JY7131_Clock_Counter_4_Output | CO_4_Output as other task External Clock Source.
JY7131_Clock_Counter_5_Output | CO_5_Output as other task External Clock Source.
JY7131_Clock_Counter_6_Output | CO_6_Output as other task External Clock Source.
JY7131_Clock_Counter_7_Output | CO_7_Output as other task External Clock Source.

◆ JY7131_InputTerminal

enum JY7131_InputTerminal
Enumerator
JY7131_IN_PFI_In_0 | PFI_0 as the Input Terminal.
JY7131_IN_PFI_In_1 | PFI_1 as the Input Terminal.
JY7131_IN_PFI_In_2 | PFI_2 as the Input Terminal.
JY7131_IN_PFI_In_3 | PFI_3 as the Input Terminal.
JY7131_IN_PFI_In_4 | PFI_4 as the Input Terminal.
JY7131_IN_PFI_In_5 | PFI_5 as the Input Terminal.
JY7131_IN_PFI_In_6 | PFI_6 as the Input Terminal.
JY7131_IN_PFI_In_7 | PFI_7 as the Input Terminal.
JY7131_IN_PFI_In_8 | PFI_8 as the Input Terminal.
JY7131_IN_PFI_In_9 | PFI_9 as the Input Terminal.
JY7131_IN_PFI_In_10 | PFI_10 as the Input Terminal.
JY7131_IN_PFI_In_11 | PFI_11 as the Input Terminal.
JY7131_IN_PFI_In_12 | PFI_12 as the Input Terminal.
JY7131_IN_PFI_In_13 | PFI_13 as the Input Terminal.
JY7131_IN_PFI_In_14 | PFI_14 as the Input Terminal.
JY7131_IN_PFI_In_15 | PFI_15 as the Input Terminal.
JY7131_IN_PFI_In_16 | PFI_16 as the Input Terminal.
JY7131_IN_PFI_In_17 | PFI_17 as the Input Terminal.
JY7131_IN_PFI_In_18 | PFI_18 as the Input Terminal.
JY7131_IN_PFI_In_19 | PFI_19 as the Input Terminal.
JY7131_IN_PFI_In_20 | PFI_20 as the Input Terminal.
JY7131_IN_PFI_In_21 | PFI_21 as the Input Terminal.
JY7131_IN_PFI_In_22 | PFI_22 as the Input Terminal.
JY7131_IN_PFI_In_23 | PFI_23 as the Input Terminal.
JY7131_IN_PFI_In_24 | PFI_24 as the Input Terminal.
JY7131_IN_PFI_In_25 | PFI_25 as the Input Terminal.
JY7131_IN_PFI_In_26 | PFI_26 as the Input Terminal.
JY7131_IN_PFI_In_27 | PFI_27 as the Input Terminal.
JY7131_IN_PFI_In_28 | PFI_28 as the Input Terminal.
JY7131_IN_PFI_In_29 | PFI_29 as the Input Terminal.
JY7131_IN_PFI_In_30 | PFI_30 as the Input Terminal.
JY7131_IN_PFI_In_31 | PFI_31 as the Input Terminal.
JY7131_IN_PXI_Trig0 | PXI_Trig0 as the Input Terminal.
JY7131_IN_PXI_Trig1 | PXI_Trig1 as the Input Terminal.
JY7131_IN_PXI_Trig2 | PXI_Trig2 as the Input Terminal.
JY7131_IN_PXI_Trig3 | PXI_Trig3 as the Input Terminal.
JY7131_IN_PXI_Trig4 | PXI_Trig4 as the Input Terminal.
JY7131_IN_PXI_Trig5 | PXI_Trig5 as the Input Terminal.
JY7131_IN_PXI_Trig6 | PXI_Trig6 as the Input Terminal.
JY7131_IN_PXI_Trig7 | PXI_Trig7 as the Input Terminal.
JY7131_IN_CO_0_Output | CO_0_Output as the Input Terminal.
JY7131_IN_CO_1_Output | CO_1_Output as the Input Terminal.
JY7131_IN_CO_2_Output | CO_0_Output as the Input Terminal.
JY7131_IN_CO_3_Output | CO_1_Output as the Input Terminal.
JY7131_IN_CO_4_Output | CO_0_Output as the Input Terminal.
JY7131_IN_CO_5_Output | CO_1_Output as the Input Terminal.
JY7131_IN_CO_6_Output | CO_0_Output as the Input Terminal.
JY7131_IN_CO_7_Output | CO_1_Output as the Input Terminal.
JY7131_IN_CIO_100MHz | Counter 100MHz timebase as the Input Terminal.
JY7131_IN_CIO_5MHz | Counter 5MHz timebase as the Input Terminal.
JY7131_IN_CIO_100kHz | Counter 100kHz timebase as the Input Terminal.

◆ JY7131_LevelState

enum JY7131_LevelState
Enumerator
JY7131_LowLevel | Low Level as the pause trigger active level.
JY7131_HighLevel | High Level as the pause trigger active level.

◆ JY7131_ReferenceClock

enum JY7131_ReferenceClock
Enumerator
JY7131_Internal | The onboard 25 MHz as JY7131_ReferenceClock.
JY7131_PXIe_Clk100 | The PXIe chassis 100MHz as JY7131_ReferenceClock, only for PXIe module.

◆ JY7131_Signal_Destination

enum JY7131_Signal_Destination
Enumerator
JY7131_None | None desition to rout.
JY7131_PFI_Out_0 | PFI0 as the signal desition to rout.
JY7131_PFI_Out_1 | PFI1 as the signal desition to rout.
JY7131_PFI_Out_2 | PFI2 as the signal desition to rout.
JY7131_PFI_Out_3 | PFI3 as the signal desition to rout.
JY7131_PFI_Out_4 | PFI4 as the signal desition to rout.
JY7131_PFI_Out_5 | PFI5 as the signal desition to rout.
JY7131_PFI_Out_6 | PFI6 as the signal desition to rout.
JY7131_PFI_Out_7 | PFI7 as the signal desition to rout.
JY7131_PFI_Out_8 | PFI8 as the signal desition to rout.
JY7131_PFI_Out_9 | PFI9 as the signal desition to rout.
JY7131_PFI_Out_10 | PFI10 as the signal desition to rout.
JY7131_PFI_Out_11 | PFI11 as the signal desition to rout.
JY7131_PFI_Out_12 | PFI12 as the signal desition to rout.
JY7131_PFI_Out_13 | PFI13 as the signal desition to rout.
JY7131_PFI_Out_14 | PFI14 as the signal desition to rout.
JY7131_PFI_Out_15 | PFI15 as the signal desition to rout.
JY7131_PFI_Out_16 | PFI16 as the signal desition to rout.
JY7131_PFI_Out_17 | PFI17 as the signal desition to rout.
JY7131_PFI_Out_18 | PFI18 as the signal desition to rout.
JY7131_PFI_Out_19 | PFI19 as the signal desition to rout.
JY7131_PFI_Out_20 | PFI20 as the signal desition to rout.
JY7131_PFI_Out_21 | PFI21 as the signal desition to rout.
JY7131_PFI_Out_22 | PFI22 as the signal desition to rout.
JY7131_PFI_Out_23 | PFI23 as the signal desition to rout.
JY7131_PFI_Out_24 | PFI24 as the signal desition to rout.
JY7131_PFI_Out_25 | PFI25 as the signal desition to rout.
JY7131_PFI_Out_26 | PFI26 as the signal desition to rout.
JY7131_PFI_Out_27 | PFI27 as the signal desition to rout.
JY7131_PFI_Out_28 | PFI28 as the signal desition to rout.
JY7131_PFI_Out_29 | PFI29 as the signal desition to rout.
JY7131_PFI_Out_30 | PFI30 as the signal desition to rout.
JY7131_PFI_Out_31 | PFI31 as the signal desition to rout.
JY7131_PXITrig0_Out | PXITrig0 as the signal desition to rout.
JY7131_PXITrig1_Out | PXITrig1 as the signal desition to rout.
JY7131_PXITrig2_Out | PXITrig2 as the signal desition to rout.
JY7131_PXITrig3_Out | PXITrig3 as the signal desition to rout.
JY7131_PXITrig4_Out | PXITrig4 as the signal desition to rout.
JY7131_PXITrig5_Out | PXITrig5 as the signal desition to rout.
JY7131_PXITrig6_Out | PXITrig6 as the signal desition to rout.
JY7131_PXITrig7_Out | PXITrig7 as the signal desition to rout.

◆ JY7131_Signal_Source

enum JY7131_Signal_Source
Enumerator
JY7131_Signal_PFI_In_0 | PFI0 as the source signal to rout.
JY7131_Signal_PFI_In_2 | PFI2 as the source signal to rout.
JY7131_Signal_PFI_In_3 | PFI3 as the source signal to rout.
JY7131_Signal_PFI_In_4 | PFI4 as the source signal to rout.
JY7131_Signal_PFI_In_5 | PFI5 as the source signal to rout.
JY7131_Signal_PFI_In_6 | PFI6 as the source signal to rout.
JY7131_Signal_PFI_In_7 | PFI7 as the source signal to rout.
JY7131_Signal_PFI_In_8 | PFI8 as the source signal to rout.
JY7131_Signal_PFI_In_9 | PFI9 as the source signal to rout.
JY7131_Signal_PFI_In_10 | PFI10 as the source signal to rout.
JY7131_Signal_PFI_In_11 | PFI11 as the source signal to rout.
JY7131_Signal_PFI_In_12 | PFI12 as the source signal to rout.
JY7131_Signal_PFI_In_13 | PFI13 as the source signal to rout.
JY7131_Signal_PFI_In_14 | PFI14 as the source signal to rout.
JY7131_Signal_PFI_In_15 | PFI15 as the source signal to rout.
JY7131_Signal_PFI_In_16 | PFI16 as the source signal to rout.
JY7131_Signal_PFI_In_17 | PFI17 as the source signal to rout.
JY7131_Signal_PFI_In_18 | PFI18 as the source signal to rout.
JY7131_Signal_PFI_In_19 | PFI19 as the source signal to rout.
JY7131_Signal_PFI_In_20 | PFI20 as the source signal to rout.
JY7131_Signal_PFI_In_21 | PFI21 as the source signal to rout.
JY7131_Signal_PFI_In_22 | PFI22 as the source signal to rout.
JY7131_Signal_PFI_In_23 | PFI23 as the source signal to rout.
JY7131_Signal_PFI_In_24 | PFI24 as the source signal to rout.
JY7131_Signal_PFI_In_25 | PFI25 as the source signal to rout.
JY7131_Signal_PFI_In_26 | PFI26 as the source signal to rout.
JY7131_Signal_PFI_In_27 | PFI27 as the source signal to rout.
JY7131_Signal_PFI_In_28 | PFI28 as the source signal to rout.
JY7131_Signal_PFI_In_29 | PFI29 as the source signal to rout.
JY7131_Signal_PFI_In_30 | PFI30 as the source signal to rout.
JY7131_Signal_PFI_In_31 | PFI31 as the source signal to rout.
JY7131_Signal_PXI_Trig_0 | PXI_Trig0 as the source signal to rout.
JY7131_Signal_PXI_Trig_1 | PXI_Trig1 as the source signal to rout.
JY7131_Signal_PXI_Trig_2 | PXI_Trig2 as the source signal to rout.
JY7131_Signal_PXI_Trig_3 | PXI_Trig3 as the source signal to rout.
JY7131_Signal_PXI_Trig_4 | PXI_Trig4 as the source signal to rout.
JY7131_Signal_PXI_Trig_5 | PXI_Trig5 as the source signal to rout.
JY7131_Signal_PXI_Trig_6 | PXI_Trig6 as the source signal to rout.
JY7131_Signal_PXI_Trig_7 | PXI_Trig7 as the source signal to rout.
JY7131_Signal_CIO_0_StartTrig | CIO 0 StartTrig as the digital trigger source.
JY7131_Signal_CIO_1_StartTrig | CIO 1 StartTrig as the digital trigger source.
JY7131_Signal_CIO_2_StartTrig | CIO 2 StartTrig as the digital trigger source.
JY7131_Signal_CIO_3_StartTrig | CIO 3 StartTrig as the digital trigger source.
JY7131_Signal_CIO_4_StartTrig | CIO 4 StartTrig as the digital trigger source.
JY7131_Signal_CIO_5_StartTrig | CIO 5 StartTrig as the digital trigger source.
JY7131_Signal_CIO_6_StartTrig | CIO 6 StartTrig as the digital trigger source.
JY7131_Signal_CIO_7_StartTrig | CIO 7 StartTrig as the digital trigger source.
JY7131_Signal_Counter_0_Output | CO_0_Output as other task External Clock Source.
JY7131_Signal_Counter_1_Output | CO_1_Output as other task External Clock Source.
JY7131_Signal_Counter_2_Output | CO_2_Output as other task External Clock Source.
JY7131_Signal_Counter_3_Output | CO_3_Output as other task External Clock Source.
JY7131_Signal_Counter_4_Output | CO_4_Output as other task External Clock Source.
JY7131_Signal_Counter_5_Output | CO_5_Output as other task External Clock Source.
JY7131_Signal_Counter_6_Output | CO_6_Output as other task External Clock Source.
JY7131_Signal_Counter_7_Output | CO_7_Output as other task External Clock Source.
JY7131_Signal_CI_0_SampleClock | CI0_SampleClock as other task External Clock Source.
JY7131_Signal_CI_1_SampleClock | CI1_SampleClock as other task External Clock Source.
JY7131_Signal_CI_2_SampleClock | CI2_SampleClock as other task External Clock Source.
JY7131_Signal_CI_3_SampleClock | CI3_SampleClock as other task External Clock Source.
JY7131_Signal_CI_4_SampleClock | CI4_SampleClock as other task External Clock Source.
JY7131_Signal_CI_5_SampleClock | CI5_SampleClock as other task External Clock Source.
JY7131_Signal_CI_6_SampleClock | CI6_SampleClock as other task External Clock Source.
JY7131_Signal_CI_7_SampleClock | CI7_SampleClock as other task External Clock Source.
JY7131_Signal_CIO_100MHz | Counter 100MHz timebase as the source signal to rout.
JY7131_Signal_CIO_5MHz | Counter 5MHz timebase as the source signal to rout.
JY7131_Signal_CIO_100kHz | Counter 100kHz timebase as the source signal to rout.

Function Documentation

◆ JY7131_CI_CheckBufferStatus()

JY7131API int JY7131_CI_CheckBufferStatus | ( | JY7131_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned long long * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun )

Check CI task buffer status.

Parameters
hDevice | device handle
channel | counter input channel
avaliableSamples | number of samples that the device buffer can read
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY7131_CI_EnableChannel()

JY7131API int JY7131_CI_EnableChannel | ( | JY7131_DeviceHandle | hDevice,
 |  | unsigned int | channel )

Enables CI channel.There are 8 counter,from 0 to 7.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if success or other error code

◆ JY7131_CI_ReadCountValues()

JY7131API int JY7131_CI_ReadCountValues | ( | JY7131_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int * | countValues,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength )

Counter reads the count values, this API is supprot CI Type ：JY7131_CI_EdgeCount、JY7131_CI_EncoderX1、 JY7131_CI_EncoderX2 、 JY7131_CI_EncoderX4 、JY7131_CI_EncoderTwoPulse.

Parameters
hDevice | device handle
channel | counter input channel
countValues | user buffer,the buffer size must be greater than or equal to dataLength
dataLength | read data length
timeOut | timeout time in microsecond
actualReadLength | return value, the actual length of the data read.
Returns
0 if success or other error code

◆ JY7131_CI_ReadMeasureValues()

JY7131API int JY7131_CI_ReadMeasureValues | ( | JY7131_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | double * | measureValues1,
 |  | double * | measureValues2,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength )

Counter reads the measured values, this API only support CI Type for JY7131_CI_Measure_EdgeSeparation JY7131_CI_Measure_Pulse JY7131_CI_Measure_Frequency JY7131_CI_Measure_Period JY7131_CI_Measure_SemiPeriod for JY7131_CI_Measure_EdgeSeparation type, the measureValues1 is the Gate signel to the Aux signal interval, the measureValues2 is the Aux signel to the Gate signal interval, the unit is s.

for JY7131_CI_Measure_Pulse type, the measureValues1 is the Low level signal time, the measureValues2 is the Highe level signal time, the unit is s. for JY7131_CI_Measure_SemiPeriod type, the measureValues1 is signal period, the unit is s,the measureValues2 invalid. for JY7131_CI_Measure_Frequency type, the measureValues1 is signal frequency, the unit is Hz. for JY7131_CI_Measure_Period type, the measureValues2 is signal period, the unit is s. The JY7131_CI_Measure_Period type and JY7131_CI_Measure_Frequency type is same time measurement, user need to read both measurements simultaneously.

Parameters
hDevice | device handle
channel | counter input channel
measureValues | user buffer.The buffer size must be greater than or equal to dataLength
dataLength | read data length
timeOut | measure timeout time in microsecond
actualReadLength | reture the actual length of the data read
Returns
0 if success or other error code

◆ JY7131_CI_ReadSingleCountValue()

JY7131API int JY7131_CI_ReadSingleCountValue | ( | JY7131_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int * | countValue )

Counter reads a single count value, this API supports the CI Type: JY7131_CI_EdgeCount、JY7131_CI_EncoderX1、 JY7131_CI_EncoderX2 、 JY7131_CI_EncoderX4 、JY7131_CI_EncoderTwoPulse.

Parameters
hDevice | device handle
channel | counter input channel. An integer counter number, eg, 0 for counter 0.
countValue | return the current count value of counter.
Returns
0 if success or other error code

◆ JY7131_CI_ReadSingleMeasureValue()

JY7131API int JY7131_CI_ReadSingleMeasureValue | ( | JY7131_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | double * | measureValue1,
 |  | double * | measureValue2,
 |  | int | timeOut )

Reads a single counter measurement as follows.

for JY7131_CI_Measure_EdgeSeparation type, measureValues1 is the Gate signel to the Aux signal interval, the measureValues2 is the Aux signel to the Gate signal interval, the unit is in s. for JY7131_CI_Measure_Pulse type, measureValues1 is the Low level signal time, the measureValues2 is the high level signal time, the unit is in second. for JY7131_CI_Measure_Frequency type, measureValues1 is signal frequency in Hz, measureValue2 has no meaning. for JY7131_CI_Measure_Period type, measureValues2 is signal period in second; measureValue1 has no meaning.

Parameters
hDevice | device handle
channel | Counter input channel
measureValue1 | current measure value of counter
measureValue2 | current measure value of counter
timeOut | timeout time in microsecond
Returns
0 if success or other error code

◆ JY7131_CI_SendSoftTrigger()

JY7131API int JY7131_CI_SendSoftTrigger | ( | JY7131_DeviceHandle | hDevice,
 |  | int | channel )

Send the software trigger signal for CI.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if success or other error code

◆ JY7131_CI_SetAuxTerminal()

JY7131API int JY7131_CI_SetAuxTerminal | ( | JY7131_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY7131_InputTerminal | auxTerminal )

Set aux terminal.

Parameters
hDevice | device handle
channel | counter output channel
auxTerminal | aux terminal
Returns
0 if success or other error code

◆ JY7131_CI_SetCounterParament()

JY7131API int JY7131_CI_SetCounterParament | ( | JY7131_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | int | initCount,
 |  | JY7131_CountDirection | countDirection )

Set CI count parameter.

Parameters
hDevice | device handle
channel | counter input channel
initCount | counter initial value
countDirection | counting direction of the counter defined by enum JY7131_CountDirection
Returns
0 if success or other error code

◆ JY7131_CI_SetCounterType()

JY7131API int JY7131_CI_SetCounterType | ( | JY7131_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY7131_CI_MeasureType | measureType )

Set CI measure type.

Parameters
hDevice | device handle
channel | counter input channel
measureType | measure type. defined by enum JY7131_CI_MeasureType
Returns
0 if success or other error code

◆ JY7131_CI_SetDigitalStartTrigger()

JY7131API int JY7131_CI_SetDigitalStartTrigger | ( | JY7131_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY7131_DigitalTriggerSource | triggerSource,
 |  | JY7131_DigitalTriggerEdge | triggerEdge )

Set CI digital start trigger.the triggerSource is defined by enum JY7131_DigitalTriggerSource, the triggerEdge is defined by enum JY7131_DigitalTriggerEdge.

Parameters
hDevice | device handle
channel | counter input channel
triggerSource | CI digital start trigger source
triggerEdge | CI digital start trigger edge. Options: rising or falling edge.
Returns
0 if success or other error code

◆ JY7131_CI_SetEdgeCountEvent()

JY7131API int JY7131_CI_SetEdgeCountEvent | ( | JY7131_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY7131_CI_CounterEventSignalIdleState | idleState,
 |  | unsigned int | threshold )

Set the counter threshold, and when the count reaches this threshold, output a single pulse at the output terminal.

Parameters
hDevice | device handle
channel | counter input channel
idleState | output terminal idle state
threshold | threshold
Returns
0 if success or other error code

◆ JY7131_CI_SetFirstSampleClock()

JY7131API int JY7131_CI_SetFirstSampleClock | ( | JY7131_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool | ignore )

Set the first sample clock data ignore or not.

Parameters
hDevice | device handle
channel | counter input channel
ignore | ignore the first sample clock data. true : ignore; false: not ignore
Returns
0 if success or other error code

◆ JY7131_CI_SetGateTerminal()

JY7131API int JY7131_CI_SetGateTerminal | ( | JY7131_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY7131_InputTerminal | gateTerminal )

Set gate terminal.

Parameters
hDevice | device handle
channel | counter output channel
gateTerminal | gate terminal
Returns
0 if success or other error code

◆ JY7131_CI_SetMode()

JY7131API int JY7131_CI_SetMode | ( | JY7131_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY7131_CI_SampleMode | mode )

Set counter input mode, the mode is defined by enum JY7131_CI_SampleMode.

Parameters
hDevice | device handle
channel | counter input channel
mode | counter input mode, Options: single,finite,continuous.
Returns
0 if success or other error code

◆ JY7131_CI_SetOutTerminal()

JY7131API int JY7131_CI_SetOutTerminal | ( | JY7131_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY7131_Signal_Destination | outTerminal )

Set out terminal.

Parameters
hDevice | device handle
channel | counter output channel
outTerminal | source terminal
Returns
0 if success or other error code

◆ JY7131_CI_SetPauseTriggerLevel()

JY7131API int JY7131_CI_SetPauseTriggerLevel | ( | JY7131_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool | enable,
 |  | JY7131_LevelState | pauseTriggerActiveLevel )

Config CI pause trigger.

Parameters
hDevice | Device handle
channel | Counter channel
enable | Enable pasue trigger
pauseTriggerActiveLevel | Pause trigger active level.
Returns
Succeed: 0 , Error: !=0

◆ JY7131_CI_SetSampleClock()

JY7131API int JY7131_CI_SetSampleClock | ( | JY7131_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY7131_CI_SampleClock | clock,
 |  | JY7131_ExternalClockTerminal | terminal,
 |  | double | rate )

Set counter input sampling clock source.

If the clockType is internal, user need to define sampleRate, if the clockType is JY7131_CI_ImplicitClk, the sample rate determine by the measuer signal.

Parameters
hDevice | device handle
channel | counter input channel
clockType | counter input clock type. Option: internal clock 、 implicit clock、external clock.
terminal | external clock terminal,defined by enum JY7131_ExternalClockTerminal
rate | external clock frequency,when clockType is implicit clock or external clock. when clockType is Internal clock, the rate is internal sample rate
Returns
0 if success or other error code

◆ JY7131_CI_SetSamplesToAcquire()

JY7131API int JY7131_CI_SetSamplesToAcquire | ( | JY7131_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int | samplesToAcquire )

Set samples to acquire in finite mode.The samples range is 1 to 4M.

Parameters
hDevice | device handle
channel | counter input channel
samplesToAcquire | CI finite samples to acquire, samples range:1 to 4M samples.
Returns
0 if success or other error code

◆ JY7131_CI_SetSignalReverse()

JY7131API int JY7131_CI_SetSignalReverse | ( | JY7131_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | int | signalReverse )

Set the Signal Reverse terminal.

Parameters
hDevice | device handle
channel | counter input channel
signalReverse | The lower 4bit is valid. 0bit represents Source, 1bit represents Gate, 2bit represents Aux, and 3bit represents Extclk
Returns
0 if success or other error code

◆ JY7131_CI_SetSourceTerminal()

JY7131API int JY7131_CI_SetSourceTerminal | ( | JY7131_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY7131_InputTerminal | sourceTerminal )

Set source terminal.

Parameters
hDevice | device handle
channel | counter output channel
sourceTerminal | source terminal
Returns
0 if success or other error code

◆ JY7131_CI_SetStartingEdge()

JY7131API int JY7131_CI_SetStartingEdge | ( | JY7131_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY7131_CI_StartingEdge | startingEdge )

Set starting edge，only valid in JY7131_CI_Measure_FrequencyOrPeriod。

Parameters
hDevice | device handle
channel | counter input channel
startingEdge | starting edge.
Returns
0 if success or other error code

◆ JY7131_CI_SetStartTriggerType()

JY7131API int JY7131_CI_SetStartTriggerType | ( | JY7131_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY7131_CIO_TriggerType | triggerTyp )

Set CI start trigger type,the triggerType is defined by enum JY7131_CI_TriggerType.

Parameters
hDevice | device handle
channel | counter input channel
triggerType | CI start trigger type. Options: immediate trigger, software trigger, digital trigger.
Returns
0 if success or other error code

◆ JY7131_CI_SetTimeBase()

JY7131API int JY7131_CI_SetTimeBase | ( | JY7131_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY7131_CountTimeBase | timebaseSrc,
 |  | double | externalTimebaseFreq,
 |  | double * | actualTimebaseFreq )

Set counter input time base,the time base defined by enum JY7131_CountTimeBase.

Parameters
hDevice | device handle
channel | counter input channel
timebaseSrc | counter timebase source
externalTimebaseFreq | timebase frequnency when the source is external timebase
actualTimebaseFreq | return the counter actual timebase frequency
Returns
0 if success or other error code

◆ JY7131_CI_SetValueReturnMode()

JY7131API int JY7131_CI_SetValueReturnMode | ( | JY7131_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY7131_CI_ValueReturnMode | mode )

Config CI return value mode, only for JY7131_CI_Measure_EdgeSeparation type.

Parameters
hDevice | Device handle
channel | Counter channel
mode | Counter return value mode
Returns
Succeed: 0 , Error: !=0

◆ JY7131_CI_SetZReloadEnabled()

JY7131API int JY7131_CI_SetZReloadEnabled | ( | JY7131_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool | zReloadEnabled )

Set the Z signal enable in Encoder mode.

Parameters
hDevice | device handle
channel | counter input channel
zReloadEnabled | enable z signal. True: enabled; False: disabled.Valid only under encoder mode.
Returns
0 if success or other error code

◆ JY7131_CI_Start()

JY7131API int JY7131_CI_Start | ( | JY7131_DeviceHandle | hDevice,
 |  | unsigned int | channel )

Start Counter input.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if success or other error code

◆ JY7131_CI_Stop()

JY7131API int JY7131_CI_Stop | ( | JY7131_DeviceHandle | hDevice,
 |  | unsigned int | channel )

Stop Counter input.

Parameters
hDevice | device handle
channel | counter input channel
Returns
0 if success or other error code

◆ JY7131_Close()

JY7131API int JY7131_Close ( JY7131_DeviceHandle hDevice )

Close this 7131 board.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY7131_CO_CheckBufferStatus()

JY7131API int JY7131_CO_CheckBufferStatus | ( | JY7131_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned long * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun )

Check CO task buffer status.

Parameters
hDevice | device handle
channel | counter output channel
avaliableSamples | number of CO samples per channel user can write
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY7131_CO_CheckCounterStatus()

JY7131API int JY7131_CO_CheckCounterStatus | ( | JY7131_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int * | pulseTransfered,
 |  | bool * | underflow )

Check counter output status.

Parameters
hDevice | device handle
channel | counter output channel
pulseTransfered | The number of pulse that have been transfered
overrun | true:overflow, false:not overflow.
Returns
0 if success or other error code

◆ JY7131_CO_EnableChannel()

JY7131API int JY7131_CO_EnableChannel | ( | JY7131_DeviceHandle | hDevice,
 |  | unsigned int | channel )

Enabled counter output channel.

Parameters
hDevice | device handle
channel | counter output channel
Returns
0 if success or other error code

◆ JY7131_CO_SendSoftTrigger()

JY7131API int JY7131_CO_SendSoftTrigger | ( | JY7131_DeviceHandle | hDevice,
 |  | int | channel )

Send the software trigger signal.

Parameters
hDevice | device handle
channel | counter channel
Returns
0 if success or other error code

◆ JY7131_CO_SetCounterParament()

JY7131API int JY7131_CO_SetCounterParament | ( | JY7131_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | int | pulseCount,
 |  | JY7131_CO_IdleState | IdleState,
 |  | double | delay )

Set CO parameter.

Parameters
hDevice | device handle
channel | counter output channel
pulseCount | counter output pulse number, if pulseCount = -1 ,the device always responds to output until the user stops it.
IdleState | counter output idle state
delay | counter output delay, unit:s. There are five ticks of the timebase fixed delay in counter internal, so the total delay(s) = delay + (5 / timebase)
Returns
0 if success or other error code

◆ JY7131_CO_SetDigitalStartTrigger()

JY7131API int JY7131_CO_SetDigitalStartTrigger | ( | JY7131_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY7131_DigitalTriggerSource | triggerSource,
 |  | JY7131_DigitalTriggerEdge | triggerEdge )

Set CO digital start trigger,the triggerSource is defined by enum JY7131_DigitalTriggerSource, the triggerEdge is defined by enum JY7131_DigitalTriggerEdge.

Parameters
hDevice | device handle
channel | counter channel
triggerSource | CO digital start trigger source
triggerEdge | CO digital start trigger edge. Options: rising or falling edge.
Returns
0 if success or other error code

◆ JY7131_CO_SetFrequency()

JY7131API int JY7131_CO_SetFrequency | ( | JY7131_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int | highTicks,
 |  | unsigned int | lowTicks )

Set counter output pulse frequency.

Parameters
hDevice | device handle
channel | counter output channel
highTicks | the number of ticks for the high pulse, default:timebase is 100MHz.
lowTicks | the number of ticks for the low pulse, default:timebase is 100MHz.
Returns
0 if success or other error code

◆ JY7131_CO_SetGateTerminal()

JY7131API int JY7131_CO_SetGateTerminal | ( | JY7131_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY7131_InputTerminal | gateTerminal )

Set CO gate terminal.

Parameters
hDevice | device handle
channel | counter output channel
gateTerminal | source terminal
Returns
0 if success or other error code

◆ JY7131_CO_SetMode()

JY7131API int JY7131_CO_SetMode | ( | JY7131_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY7131_CO_OutMode | mode )

Set counter output mode, the mode defined by enum JY7131_CO_UpdateMode.

Parameters
hDevice | device handle
mode | CO mode.Options: Single,Finite,ContinuousWrapping,ContinuousNoWrapping mode.
Returns
0 if success or other error code

◆ JY7131_CO_SetOutTerminal()

JY7131API int JY7131_CO_SetOutTerminal | ( | JY7131_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY7131_Signal_Destination | outTerminal )

Set CO out terminal.

Parameters
hDevice | device handle
channel | counter output channel
outTerminal | source terminal
Returns
0 if success or other error code

◆ JY7131_CO_SetOutTerminalMode()

JY7131API int JY7131_CO_SetOutTerminalMode | ( | JY7131_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY7131_DOMode | mode )

Set counter output terminal mode.

Parameters
hDevice | device handle
channel | counter output channel
mode | counter output terminal mode. defalut:Sourcing
Returns
0 if success or other error code

◆ JY7131_CO_SetPauseTriggerLevel()

JY7131API int JY7131_CO_SetPauseTriggerLevel | ( | JY7131_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool | enable,
 |  | JY7131_LevelState | pauseTriggerActiveLevel )

Config CO pause trigger.

Parameters
hDevice | Device handle
channel | Counter channel
enable | Enable pasue trigger
pauseTriggerActiveLevel | Pause trigger active level.
Returns
Succeed: 0 , Error: !=0

◆ JY7131_CO_SetSamplesToUpdate()

JY7131API int JY7131_CO_SetSamplesToUpdate | ( | JY7131_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | unsigned int | samplesToUpdate )

Set CO samples for each channel in the finite mode.The sample range is from 1 to 4M samples.

Parameters
hDevice | device handle
channel | counter output channel
sampleToUpdate | number of CO samples per channel. Data range:1 to 4M samples.
Returns
0 if success or other error code

◆ JY7131_CO_SetStartTriggerType()

JY7131API int JY7131_CO_SetStartTriggerType | ( | JY7131_DeviceHandle | hDevice,
 |  | int | channel,
 |  | JY7131_CIO_TriggerType | triggerTyp )

Set CO start trigger type,the triggerType is defined by enum JY7131_AI_TriggerType.

Parameters
hDevice | device handle
channel | counter channel
triggerType | CO start trigger type. Options:immediate trigger, software trigger, digital trigger.
Returns
0 if success or other error code

◆ JY7131_CO_SetTimeBase()

JY7131API int JY7131_CO_SetTimeBase | ( | JY7131_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | JY7131_CountTimeBase | timebaseSrc,
 |  | JY7131_InputTerminal | externalTimebaseTerminal,
 |  | double | externalTimebaseFreq,
 |  | double * | actualTimebaseFreq )

Set counter output time base,the time base defined by enum JY7131_CountTimeBase.

Parameters
hDevice | device handle
channel | counter input channel
timebaseSrc | counter timebase source
externalTimebaseTerminal | external timebase terminal
externalTimebaseFreq | timebase frequnency when the source is external timebase
actualTimebaseFreq | return the counter actual timebase frequency
Returns
0 if success or other error code

◆ JY7131_CO_Start()

JY7131API int JY7131_CO_Start | ( | JY7131_DeviceHandle | hDevice,
 |  | unsigned int | channel )

Start counter output.

Parameters
hDevice | device handle
channel | counter output channel
Returns
0 if success or other error code

◆ JY7131_CO_Stop()

JY7131API int JY7131_CO_Stop | ( | JY7131_DeviceHandle | hDevice,
 |  | unsigned int | channel )

Stop counter output.

Parameters
hDevice | device handle
channel | counter output channel
Returns
0 if success or other error code

◆ JY7131_CO_WaitUntilDone()

JY7131API int JY7131_CO_WaitUntilDone | ( | JY7131_DeviceHandle | hDevice,
 |  | unsigned int | channel,
 |  | bool * | done )

Check counter output complete status.

Parameters
hDevice | device handle
channel | counter output channel
done | true :counter output complete, false:counter output not complete
Returns
0 if success or other error code

◆ JY7131_CO_WriteData()

JY7131API int JY7131_CO_WriteData | ( | JY7131_DeviceHandle | hDevice,
 |  | int | channel,
 |  | unsigned int * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeOut,
 |  | unsigned int * | actualWriteLength )

CO write data.One sampling point consists of three datas, high level ticks, low level ticks, and number of pulses.

Parameters
hDevice | device handle
channel | counter output channel
dataBuffer | user buffer, the buffer size must be greater than or equal to dataLength*3.
dataLength | length of pulse output
timeOut | timeout time in microsecond
actualWriteLength | the number of samples per channel actually write
Returns
0 if success or other error code

◆ JY7131_DI_AddLines()

JY7131API int JY7131_DI_AddLines | ( | JY7131_DeviceHandle | hDevice,
 |  | unsigned int * | port,
 |  | unsigned int | portCount )

DI Add port.

Parameters
hDevice | device handle
port | port number array
portCount | port count
Returns
0 if success or other error code

◆ JY7131_DI_ReadSinglePoint_ByLine()

JY7131API int JY7131_DI_ReadSinglePoint_ByLine | ( | JY7131_DeviceHandle | hDevice,
 |  | bool * | readValue,
 |  | unsigned int | port,
 |  | unsigned int | line )

Read DI single line point.The data type is bool.

Parameters
hDevice device handle
readValue read the specified port specified line value.
Parameters
port | port number
line | line number
Returns
0 if success or other error code

◆ JY7131_DI_ReadSinglePoint_ByPort()

JY7131API int JY7131_DI_ReadSinglePoint_ByPort | ( | JY7131_DeviceHandle | hDevice,
 |  | bool * | readValues,
 |  | int | port )

Read DI single port point.The data type is bool array.

one bool defined one line status.

Parameters
hDevice | device handle
readValues | read the specified port values. when the port is -1, read all ports values,the readValues Length equal to 32, and the values store in the order of lines.

when the port is 0 - 7, read specified port values,the readValues Length equal to 8, and the values store in the order of lines.

Parameters
port port number
Returns
0 if success or other error code

◆ JY7131_DI_ReadSinglePoint_U32()

JY7131API int JY7131_DI_ReadSinglePoint_U32 | ( | JY7131_DeviceHandle | hDevice,
 |  | unsigned long * | readValue )

Read DI single point.The data type is uint.

There are a total of 4 ports from 0 to 7. Each port has 8 lines form 0 to 7.

Parameters
hDevice device handle
readValue read all line values. each bit from low to high represents one line.
Returns
0 if success or other error code

◆ JY7131_DI_Start()

JY7131API int JY7131_DI_Start ( JY7131_DeviceHandle hDevice )

DI Start.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY7131_DI_Stop()

JY7131API int JY7131_DI_Stop ( JY7131_DeviceHandle hDevice )

DI Stop.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY7131_DisconnectSignalRouting()

JY7131API int JY7131_DisconnectSignalRouting | ( | JY7131_DeviceHandle | hDevice,
 |  | JY7131_Signal_Destination | destination )

Disconnect an established routing.

Parameters
hDevice | device handle
destination | destination of the signal defined by enum JY7131_DestinationSignal
Returns
0 if success or other error code

◆ JY7131_DO_AddLines()

JY7131API int JY7131_DO_AddLines | ( | JY7131_DeviceHandle | hDevice,
 |  | unsigned int * | port,
 |  | unsigned int | portCount )

DO Add port.

Parameters
hDevice | device handle
port | port number array
portCount | port count
Returns
0 if success or other error code

◆ JY7131_DO_SetOutMode()

JY7131API int JY7131_DO_SetOutMode | ( | JY7131_DeviceHandle | hDevice,
 |  | JY7131_DOMode | mode )

Set DO out mode.

Parameters
hDevice device handle
doMode do output mode. enum:Sourcing,Sinking,PushPull.default:Sourcing.
Returns
0 if success or other error code

◆ JY7131_DO_Start()

JY7131API int JY7131_DO_Start ( JY7131_DeviceHandle hDevice )

DO Start.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY7131_DO_Stop()

JY7131API int JY7131_DO_Stop ( JY7131_DeviceHandle hDevice )

DO Stop.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY7131_DO_WriteSinglePoint_ByLine()

JY7131API int JY7131_DO_WriteSinglePoint_ByLine | ( | JY7131_DeviceHandle | hDevice,
 |  | bool | writeValue,
 |  | unsigned int | port,
 |  | unsigned int | line )

Write DO single point.The data type is bool .

Parameters
hDevice device handle
writeValue write the specified port specified line value.
Parameters
port | port number
line | line number
Returns
0 if success or other error code

◆ JY7131_DO_WriteSinglePoint_ByPort()

JY7131API int JY7131_DO_WriteSinglePoint_ByPort | ( | JY7131_DeviceHandle | hDevice,
 |  | bool * | writeValues,
 |  | int | port )

Write DO single point.The data type is bool array.

one bool defined one line status.

Parameters
hDevice | device handle
writeValues | write the specified port values. when the port is -1, write all ports values,the writeValues Length equal to 32, and the values store in the order of lines.

when the port is 0 - 7, write specified port values,the writeValues Length equal to 8, and the values store in the order of lines.

Parameters
port port number
Returns
0 if success or other error code

◆ JY7131_DO_WriteSinglePoint_U32()

JY7131API int JY7131_DO_WriteSinglePoint_U32 | ( | JY7131_DeviceHandle | hDevice,
 |  | unsigned int | writeValue )

Write DO single point.The data type is uint.

There are a total of 4 ports from 0 to 7. Each port has 8 lines form 0 to 7.

Parameters
hDevice device handle
writeValue wirte the all line values. each bit from low to high represents one line.
Returns
0 if success or other error code

◆ JY7131_GetDeviceID()

JY7131API int JY7131_GetDeviceID | ( | JY7131_DeviceHandle | hDevice,
 |  | int * | deviceID )

Obtain the board ID.

The 7131 is a series of boards. The PXIe-7131 board ID is Ox7131 The PCIe-7131 board ID is OxA131 The USB-7131 board ID is OxB131

Parameters
hDevice | device handle
deviceID | board ID
Returns
0 if success or other error code

◆ JY7131_GetDeviceSerialNumber()

JY7131API int JY7131_GetDeviceSerialNumber | ( | JY7131_DeviceHandle | hDevice,
 |  | char * | serialNumber,
 |  | int | length )

Obtain the device serialNumber.

Parameters
hDevice | device handle
serialNumber | Pointer to a buffer receiving the serial number. The length of the serial number is 10.
length | serial Number length ,length is 10
Returns
0 if success or other error code

◆ JY7131_Open()

JY7131API int JY7131_Open | ( | int | slotNumber,
 |  | JY7131_DeviceHandle * | hDevice )

Open the 7131 series boards using the slot number or the board serial number.

PXIe slot number is predefined by the PXIe chassis. PCIe slot number is defined by the DIP switch. The board serial number is defined by the system starting from 0. It's your responsibility to know the number. For a single board, the serial number is 0.

Parameters
slotNumber | slot number or board serial number
hDevice | device handle. All other functions uses hDevice to represent this device.
Returns
0 if success or other error code

◆ JY7131_OpenByAliasName()

JY7131API int JY7131_OpenByAliasName | ( | const char * | aliasName,
 |  | JY7131_DeviceHandle * | hDevice )

Open this 7131 series boards using the board alias name which is set by JYTEK utility JYDM.

You can change the name using JYDM.

Parameters
cardName | board alias name
hDevice | device handle
Returns
0 if success or other error code

◆ JY7131_SetDeviceReferenceClock()

JY7131API int JY7131_SetDeviceReferenceClock | ( | JY7131_DeviceHandle | hDevice,
 |  | JY7131_ReferenceClock | clockSource )

Set Reference Clock for the device.There are two ReferenceClock, 25MHz from this device or 100MHz from the PXIe chassis.

PCIe device only supports 25MHz timebase.

Parameters
hDevice | device handle
clkSource | ReferenceClock source defined by enum JY7131_ReferenceClock
Returns
0 if success or other error code

◆ JY7131_SetDOPowerOnState()

JY7131API int JY7131_SetDOPowerOnState | ( | JY7131_DeviceHandle | hDevice,
 |  | JY7131_DOMode * | doMode,
 |  | bool * | writeValues,
 |  | int | length = 32 )

Set DO Power On State.

Parameters
hDevice device handle
doMode do output mode. enum:Sourcing,Sinking,PushPull.default:Sourcing.
Parameters
writeValues write all do line value.
Parameters
length state array length is 32
Returns
0 if success or other error code

◆ JY7131_SignalRouting()

JY7131API int JY7131_SignalRouting | ( | JY7131_DeviceHandle | hDevice,
 |  | JY7131_Signal_Source | sourceSignal,
 |  | JY7131_Signal_Destination | distination )

Get DO Power On State.

Parameters
hDevice | device handle
doMode do output mode. enum:Sourcing,Sinking,PushPull.default:Sourcing.
Parameters
readValues read all do line value.
Parameters
length state array length is 32
Returns
0 if success or other error code
Route a singal from source to destination. Both source and destination are defined by the corresponding enum Y7131_SourceSignal and JY7131_DestinationSignal. One source signal may be routed to multiple destinations.
hDevice | device handle
source | source of the signal defined by enum JY7131_SourceSignal
destination | destination of the signal defined by enum JY7131_DestinationSignal
Returns
0 if success or other error code
Generated by doxygen 1.12.0


7131 C++ Programming Manual: D:/7131 Directory Reference

  • 7131
7131 Directory Reference

Directories

C++


7131 C++ Programming Manual: D:/7131/C++ Directory Reference

  • 7131
  • C++
C++ Directory Reference

Files

JY7131Core.h


7131 C++ Programming Manual: File List

File List
Here is a list of all files with brief descriptions:
[detail level 123]
▼ 7131
▼ C++
JY7131Core.h


7131 C++ Programming Manual: File Members

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • j
Here is a list of all file members with links to the files they belong to:

- j -

  • JY7131_AnyEdge : JY7131Core.h
  • JY7131_CI_CheckBufferStatus() : JY7131Core.h
  • JY7131_CI_Continuous : JY7131Core.h
  • JY7131_CI_Count_Down : JY7131Core.h
  • JY7131_CI_Count_External : JY7131Core.h
  • JY7131_CI_Count_Up : JY7131Core.h
  • JY7131_CI_CounterEventSignalIdleState : JY7131Core.h
  • JY7131_CI_CounterEventSignalIdleState_High : JY7131Core.h
  • JY7131_CI_CounterEventSignalIdleState_Low : JY7131Core.h
  • JY7131_CI_EdgeCount : JY7131Core.h
  • JY7131_CI_EnableChannel() : JY7131Core.h
  • JY7131_CI_EncoderTwoPulse : JY7131Core.h
  • JY7131_CI_EncoderX1 : JY7131Core.h
  • JY7131_CI_EncoderX2 : JY7131Core.h
  • JY7131_CI_EncoderX4 : JY7131Core.h
  • JY7131_CI_ExternalClock : JY7131Core.h
  • JY7131_CI_Finite : JY7131Core.h
  • JY7131_CI_ImplicitClock : JY7131Core.h
  • JY7131_CI_InternalClock : JY7131Core.h
  • JY7131_CI_Measure_EdgeSeparation : JY7131Core.h
  • JY7131_CI_Measure_FrequencyOrPeriod : JY7131Core.h
  • JY7131_CI_MeasureType : JY7131Core.h
  • JY7131_CI_ReadCountValues() : JY7131Core.h
  • JY7131_CI_ReadMeasureValues() : JY7131Core.h
  • JY7131_CI_ReadSingleCountValue() : JY7131Core.h
  • JY7131_CI_ReadSingleMeasureValue() : JY7131Core.h
  • JY7131_CI_ReturnOneValue : JY7131Core.h
  • JY7131_CI_ReturnTwoValue : JY7131Core.h
  • JY7131_CI_SampleClock : JY7131Core.h
  • JY7131_CI_SampleMode : JY7131Core.h
  • JY7131_CI_SendSoftTrigger() : JY7131Core.h
  • JY7131_CI_SetAuxTerminal() : JY7131Core.h
  • JY7131_CI_SetCounterParament() : JY7131Core.h
  • JY7131_CI_SetCounterType() : JY7131Core.h
  • JY7131_CI_SetDigitalStartTrigger() : JY7131Core.h
  • JY7131_CI_SetEdgeCountEvent() : JY7131Core.h
  • JY7131_CI_SetFirstSampleClock() : JY7131Core.h
  • JY7131_CI_SetGateTerminal() : JY7131Core.h
  • JY7131_CI_SetMode() : JY7131Core.h
  • JY7131_CI_SetOutTerminal() : JY7131Core.h
  • JY7131_CI_SetPauseTriggerLevel() : JY7131Core.h
  • JY7131_CI_SetSampleClock() : JY7131Core.h
  • JY7131_CI_SetSamplesToAcquire() : JY7131Core.h
  • JY7131_CI_SetSignalReverse() : JY7131Core.h
  • JY7131_CI_SetSourceTerminal() : JY7131Core.h
  • JY7131_CI_SetStartingEdge() : JY7131Core.h
  • JY7131_CI_SetStartTriggerType() : JY7131Core.h
  • JY7131_CI_SetTimeBase() : JY7131Core.h
  • JY7131_CI_SetValueReturnMode() : JY7131Core.h
  • JY7131_CI_SetZReloadEnabled() : JY7131Core.h
  • JY7131_CI_Single : JY7131Core.h
  • JY7131_CI_Start() : JY7131Core.h
  • JY7131_CI_StartingEdge : JY7131Core.h
  • JY7131_CI_Stop() : JY7131Core.h
  • JY7131_CI_ValueReturnMode : JY7131Core.h
  • JY7131_CIO_0_StartTrig : JY7131Core.h
  • JY7131_CIO_1_StartTrig : JY7131Core.h
  • JY7131_CIO_2_StartTrig : JY7131Core.h
  • JY7131_CIO_3_StartTrig : JY7131Core.h
  • JY7131_CIO_4_StartTrig : JY7131Core.h
  • JY7131_CIO_5_StartTrig : JY7131Core.h
  • JY7131_CIO_6_StartTrig : JY7131Core.h
  • JY7131_CIO_7_StartTrig : JY7131Core.h
  • JY7131_CIO_Digital : JY7131Core.h
  • JY7131_CIO_Immediately : JY7131Core.h
  • JY7131_CIO_Soft : JY7131Core.h
  • JY7131_CIO_TriggerType : JY7131Core.h
  • JY7131_Clock_CI_0_SampleClock : JY7131Core.h
  • JY7131_Clock_CI_1_SampleClock : JY7131Core.h
  • JY7131_Clock_CI_2_SampleClock : JY7131Core.h
  • JY7131_Clock_CI_3_SampleClock : JY7131Core.h
  • JY7131_Clock_CI_4_SampleClock : JY7131Core.h
  • JY7131_Clock_CI_5_SampleClock : JY7131Core.h
  • JY7131_Clock_CI_6_SampleClock : JY7131Core.h
  • JY7131_Clock_CI_7_SampleClock : JY7131Core.h
  • JY7131_Clock_Counter_0_Output : JY7131Core.h
  • JY7131_Clock_Counter_1_Output : JY7131Core.h
  • JY7131_Clock_Counter_2_Output : JY7131Core.h
  • JY7131_Clock_Counter_3_Output : JY7131Core.h
  • JY7131_Clock_Counter_4_Output : JY7131Core.h
  • JY7131_Clock_Counter_5_Output : JY7131Core.h
  • JY7131_Clock_Counter_6_Output : JY7131Core.h
  • JY7131_Clock_Counter_7_Output : JY7131Core.h
  • JY7131_Clock_PFI_In_0 : JY7131Core.h
  • JY7131_Clock_PFI_In_1 : JY7131Core.h
  • JY7131_Clock_PFI_In_10 : JY7131Core.h
  • JY7131_Clock_PFI_In_11 : JY7131Core.h
  • JY7131_Clock_PFI_In_12 : JY7131Core.h
  • JY7131_Clock_PFI_In_13 : JY7131Core.h
  • JY7131_Clock_PFI_In_14 : JY7131Core.h
  • JY7131_Clock_PFI_In_15 : JY7131Core.h
  • JY7131_Clock_PFI_In_16 : JY7131Core.h
  • JY7131_Clock_PFI_In_17 : JY7131Core.h
  • JY7131_Clock_PFI_In_18 : JY7131Core.h
  • JY7131_Clock_PFI_In_19 : JY7131Core.h
  • JY7131_Clock_PFI_In_2 : JY7131Core.h
  • JY7131_Clock_PFI_In_20 : JY7131Core.h
  • JY7131_Clock_PFI_In_21 : JY7131Core.h
  • JY7131_Clock_PFI_In_22 : JY7131Core.h
  • JY7131_Clock_PFI_In_23 : JY7131Core.h
  • JY7131_Clock_PFI_In_24 : JY7131Core.h
  • JY7131_Clock_PFI_In_25 : JY7131Core.h
  • JY7131_Clock_PFI_In_26 : JY7131Core.h
  • JY7131_Clock_PFI_In_27 : JY7131Core.h
  • JY7131_Clock_PFI_In_28 : JY7131Core.h
  • JY7131_Clock_PFI_In_29 : JY7131Core.h
  • JY7131_Clock_PFI_In_3 : JY7131Core.h
  • JY7131_Clock_PFI_In_30 : JY7131Core.h
  • JY7131_Clock_PFI_In_31 : JY7131Core.h
  • JY7131_Clock_PFI_In_4 : JY7131Core.h
  • JY7131_Clock_PFI_In_5 : JY7131Core.h
  • JY7131_Clock_PFI_In_6 : JY7131Core.h
  • JY7131_Clock_PFI_In_7 : JY7131Core.h
  • JY7131_Clock_PFI_In_8 : JY7131Core.h
  • JY7131_Clock_PFI_In_9 : JY7131Core.h
  • JY7131_Clock_PXI_Trig_0 : JY7131Core.h
  • JY7131_Clock_PXI_Trig_1 : JY7131Core.h
  • JY7131_Clock_PXI_Trig_2 : JY7131Core.h
  • JY7131_Clock_PXI_Trig_3 : JY7131Core.h
  • JY7131_Clock_PXI_Trig_4 : JY7131Core.h
  • JY7131_Clock_PXI_Trig_5 : JY7131Core.h
  • JY7131_Clock_PXI_Trig_6 : JY7131Core.h
  • JY7131_Clock_PXI_Trig_7 : JY7131Core.h
  • JY7131_Close() : JY7131Core.h
  • JY7131_CO_CheckBufferStatus() : JY7131Core.h
  • JY7131_CO_CheckCounterStatus() : JY7131Core.h
  • JY7131_CO_ContinuousNoWrapping : JY7131Core.h
  • JY7131_CO_ContinuousWrapping : JY7131Core.h
  • JY7131_CO_EnableChannel() : JY7131Core.h
  • JY7131_CO_Finite : JY7131Core.h
  • JY7131_CO_HighLevel : JY7131Core.h
  • JY7131_CO_IdleState : JY7131Core.h
  • JY7131_CO_LowLevel : JY7131Core.h
  • JY7131_CO_OutMode : JY7131Core.h
  • JY7131_CO_SendSoftTrigger() : JY7131Core.h
  • JY7131_CO_SetCounterParament() : JY7131Core.h
  • JY7131_CO_SetDigitalStartTrigger() : JY7131Core.h
  • JY7131_CO_SetFrequency() : JY7131Core.h
  • JY7131_CO_SetGateTerminal() : JY7131Core.h
  • JY7131_CO_SetMode() : JY7131Core.h
  • JY7131_CO_SetOutTerminal() : JY7131Core.h
  • JY7131_CO_SetOutTerminalMode() : JY7131Core.h
  • JY7131_CO_SetPauseTriggerLevel() : JY7131Core.h
  • JY7131_CO_SetSamplesToUpdate() : JY7131Core.h
  • JY7131_CO_SetStartTriggerType() : JY7131Core.h
  • JY7131_CO_SetTimeBase() : JY7131Core.h
  • JY7131_CO_Single : JY7131Core.h
  • JY7131_CO_Start() : JY7131Core.h
  • JY7131_CO_Stop() : JY7131Core.h
  • JY7131_CO_WaitUntilDone() : JY7131Core.h
  • JY7131_CO_WriteData() : JY7131Core.h
  • JY7131_CountDirection : JY7131Core.h
  • JY7131_Counter_0_Output : JY7131Core.h
  • JY7131_Counter_1_Output : JY7131Core.h
  • JY7131_Counter_2_Output : JY7131Core.h
  • JY7131_Counter_3_Output : JY7131Core.h
  • JY7131_Counter_4_Output : JY7131Core.h
  • JY7131_Counter_5_Output : JY7131Core.h
  • JY7131_Counter_6_Output : JY7131Core.h
  • JY7131_Counter_7_Output : JY7131Core.h
  • JY7131_CountTimeBase : JY7131Core.h
  • JY7131_DeviceHandle : JY7131Core.h
  • JY7131_DI_AddLines() : JY7131Core.h
  • JY7131_DI_ReadSinglePoint_ByLine() : JY7131Core.h
  • JY7131_DI_ReadSinglePoint_ByPort() : JY7131Core.h
  • JY7131_DI_ReadSinglePoint_U32() : JY7131Core.h
  • JY7131_DI_Start() : JY7131Core.h
  • JY7131_DI_Stop() : JY7131Core.h
  • JY7131_DigitalTriggerEdge : JY7131Core.h
  • JY7131_DigitalTriggerSource : JY7131Core.h
  • JY7131_DisconnectSignalRouting() : JY7131Core.h
  • JY7131_DO_AddLines() : JY7131Core.h
  • JY7131_DO_SetOutMode() : JY7131Core.h
  • JY7131_DO_Start() : JY7131Core.h
  • JY7131_DO_Stop() : JY7131Core.h
  • JY7131_DO_WriteSinglePoint_ByLine() : JY7131Core.h
  • JY7131_DO_WriteSinglePoint_ByPort() : JY7131Core.h
  • JY7131_DO_WriteSinglePoint_U32() : JY7131Core.h
  • JY7131_DOMode : JY7131Core.h
  • JY7131_DOPowerOn_State : JY7131Core.h
  • JY7131_External_Timebase : JY7131Core.h
  • JY7131_ExternalClockTerminal : JY7131Core.h
  • JY7131_Falling : JY7131Core.h
  • JY7131_FallingEdge : JY7131Core.h
  • JY7131_GetDeviceID() : JY7131Core.h
  • JY7131_GetDeviceSerialNumber() : JY7131Core.h
  • JY7131_HighLevel : JY7131Core.h
  • JY7131_IN_CIO_100kHz : JY7131Core.h
  • JY7131_IN_CIO_100MHz : JY7131Core.h
  • JY7131_IN_CIO_5MHz : JY7131Core.h
  • JY7131_IN_CO_0_Output : JY7131Core.h
  • JY7131_IN_CO_1_Output : JY7131Core.h
  • JY7131_IN_CO_2_Output : JY7131Core.h
  • JY7131_IN_CO_3_Output : JY7131Core.h
  • JY7131_IN_CO_4_Output : JY7131Core.h
  • JY7131_IN_CO_5_Output : JY7131Core.h
  • JY7131_IN_CO_6_Output : JY7131Core.h
  • JY7131_IN_CO_7_Output : JY7131Core.h
  • JY7131_IN_PFI_In_0 : JY7131Core.h
  • JY7131_IN_PFI_In_1 : JY7131Core.h
  • JY7131_IN_PFI_In_10 : JY7131Core.h
  • JY7131_IN_PFI_In_11 : JY7131Core.h
  • JY7131_IN_PFI_In_12 : JY7131Core.h
  • JY7131_IN_PFI_In_13 : JY7131Core.h
  • JY7131_IN_PFI_In_14 : JY7131Core.h
  • JY7131_IN_PFI_In_15 : JY7131Core.h
  • JY7131_IN_PFI_In_16 : JY7131Core.h
  • JY7131_IN_PFI_In_17 : JY7131Core.h
  • JY7131_IN_PFI_In_18 : JY7131Core.h
  • JY7131_IN_PFI_In_19 : JY7131Core.h
  • JY7131_IN_PFI_In_2 : JY7131Core.h
  • JY7131_IN_PFI_In_20 : JY7131Core.h
  • JY7131_IN_PFI_In_21 : JY7131Core.h
  • JY7131_IN_PFI_In_22 : JY7131Core.h
  • JY7131_IN_PFI_In_23 : JY7131Core.h
  • JY7131_IN_PFI_In_24 : JY7131Core.h
  • JY7131_IN_PFI_In_25 : JY7131Core.h
  • JY7131_IN_PFI_In_26 : JY7131Core.h
  • JY7131_IN_PFI_In_27 : JY7131Core.h
  • JY7131_IN_PFI_In_28 : JY7131Core.h
  • JY7131_IN_PFI_In_29 : JY7131Core.h
  • JY7131_IN_PFI_In_3 : JY7131Core.h
  • JY7131_IN_PFI_In_30 : JY7131Core.h
  • JY7131_IN_PFI_In_31 : JY7131Core.h
  • JY7131_IN_PFI_In_4 : JY7131Core.h
  • JY7131_IN_PFI_In_5 : JY7131Core.h
  • JY7131_IN_PFI_In_6 : JY7131Core.h
  • JY7131_IN_PFI_In_7 : JY7131Core.h
  • JY7131_IN_PFI_In_8 : JY7131Core.h
  • JY7131_IN_PFI_In_9 : JY7131Core.h
  • JY7131_IN_PXI_Trig0 : JY7131Core.h
  • JY7131_IN_PXI_Trig1 : JY7131Core.h
  • JY7131_IN_PXI_Trig2 : JY7131Core.h
  • JY7131_IN_PXI_Trig3 : JY7131Core.h
  • JY7131_IN_PXI_Trig4 : JY7131Core.h
  • JY7131_IN_PXI_Trig5 : JY7131Core.h
  • JY7131_IN_PXI_Trig6 : JY7131Core.h
  • JY7131_IN_PXI_Trig7 : JY7131Core.h
  • JY7131_InputTerminal : JY7131Core.h
  • JY7131_Internal : JY7131Core.h
  • JY7131_Internal_Timebase_100K : JY7131Core.h
  • JY7131_Internal_Timebase_100M : JY7131Core.h
  • JY7131_Internal_Timebase_5M : JY7131Core.h
  • JY7131_LevelState : JY7131Core.h
  • JY7131_LowLevel : JY7131Core.h
  • JY7131_None : JY7131Core.h
  • JY7131_Open() : JY7131Core.h
  • JY7131_OpenByAliasName() : JY7131Core.h
  • JY7131_PFI_In_0 : JY7131Core.h
  • JY7131_PFI_In_1 : JY7131Core.h
  • JY7131_PFI_In_10 : JY7131Core.h
  • JY7131_PFI_In_11 : JY7131Core.h
  • JY7131_PFI_In_12 : JY7131Core.h
  • JY7131_PFI_In_13 : JY7131Core.h
  • JY7131_PFI_In_14 : JY7131Core.h
  • JY7131_PFI_In_15 : JY7131Core.h
  • JY7131_PFI_In_16 : JY7131Core.h
  • JY7131_PFI_In_17 : JY7131Core.h
  • JY7131_PFI_In_18 : JY7131Core.h
  • JY7131_PFI_In_19 : JY7131Core.h
  • JY7131_PFI_In_2 : JY7131Core.h
  • JY7131_PFI_In_20 : JY7131Core.h
  • JY7131_PFI_In_21 : JY7131Core.h
  • JY7131_PFI_In_22 : JY7131Core.h
  • JY7131_PFI_In_23 : JY7131Core.h
  • JY7131_PFI_In_24 : JY7131Core.h
  • JY7131_PFI_In_25 : JY7131Core.h
  • JY7131_PFI_In_26 : JY7131Core.h
  • JY7131_PFI_In_27 : JY7131Core.h
  • JY7131_PFI_In_28 : JY7131Core.h
  • JY7131_PFI_In_29 : JY7131Core.h
  • JY7131_PFI_In_3 : JY7131Core.h
  • JY7131_PFI_In_30 : JY7131Core.h
  • JY7131_PFI_In_31 : JY7131Core.h
  • JY7131_PFI_In_4 : JY7131Core.h
  • JY7131_PFI_In_5 : JY7131Core.h
  • JY7131_PFI_In_6 : JY7131Core.h
  • JY7131_PFI_In_7 : JY7131Core.h
  • JY7131_PFI_In_8 : JY7131Core.h
  • JY7131_PFI_In_9 : JY7131Core.h
  • JY7131_PFI_Out_0 : JY7131Core.h
  • JY7131_PFI_Out_1 : JY7131Core.h
  • JY7131_PFI_Out_10 : JY7131Core.h
  • JY7131_PFI_Out_11 : JY7131Core.h
  • JY7131_PFI_Out_12 : JY7131Core.h
  • JY7131_PFI_Out_13 : JY7131Core.h
  • JY7131_PFI_Out_14 : JY7131Core.h
  • JY7131_PFI_Out_15 : JY7131Core.h
  • JY7131_PFI_Out_16 : JY7131Core.h
  • JY7131_PFI_Out_17 : JY7131Core.h
  • JY7131_PFI_Out_18 : JY7131Core.h
  • JY7131_PFI_Out_19 : JY7131Core.h
  • JY7131_PFI_Out_2 : JY7131Core.h
  • JY7131_PFI_Out_20 : JY7131Core.h
  • JY7131_PFI_Out_21 : JY7131Core.h
  • JY7131_PFI_Out_22 : JY7131Core.h
  • JY7131_PFI_Out_23 : JY7131Core.h
  • JY7131_PFI_Out_24 : JY7131Core.h
  • JY7131_PFI_Out_25 : JY7131Core.h
  • JY7131_PFI_Out_26 : JY7131Core.h
  • JY7131_PFI_Out_27 : JY7131Core.h
  • JY7131_PFI_Out_28 : JY7131Core.h
  • JY7131_PFI_Out_29 : JY7131Core.h
  • JY7131_PFI_Out_3 : JY7131Core.h
  • JY7131_PFI_Out_30 : JY7131Core.h
  • JY7131_PFI_Out_31 : JY7131Core.h
  • JY7131_PFI_Out_4 : JY7131Core.h
  • JY7131_PFI_Out_5 : JY7131Core.h
  • JY7131_PFI_Out_6 : JY7131Core.h
  • JY7131_PFI_Out_7 : JY7131Core.h
  • JY7131_PFI_Out_8 : JY7131Core.h
  • JY7131_PFI_Out_9 : JY7131Core.h
  • JY7131_PowerOn_High : JY7131Core.h
  • JY7131_PowerOn_Low : JY7131Core.h
  • JY7131_PushPull : JY7131Core.h
  • JY7131_PXI_Trig0 : JY7131Core.h
  • JY7131_PXI_Trig1 : JY7131Core.h
  • JY7131_PXI_Trig2 : JY7131Core.h
  • JY7131_PXI_Trig3 : JY7131Core.h
  • JY7131_PXI_Trig4 : JY7131Core.h
  • JY7131_PXI_Trig5 : JY7131Core.h
  • JY7131_PXI_Trig6 : JY7131Core.h
  • JY7131_PXI_Trig7 : JY7131Core.h
  • JY7131_PXIe_Clk100 : JY7131Core.h
  • JY7131_PXITrig0_Out : JY7131Core.h
  • JY7131_PXITrig1_Out : JY7131Core.h
  • JY7131_PXITrig2_Out : JY7131Core.h
  • JY7131_PXITrig3_Out : JY7131Core.h
  • JY7131_PXITrig4_Out : JY7131Core.h
  • JY7131_PXITrig5_Out : JY7131Core.h
  • JY7131_PXITrig6_Out : JY7131Core.h
  • JY7131_PXITrig7_Out : JY7131Core.h
  • JY7131_ReferenceClock : JY7131Core.h
  • JY7131_Rising : JY7131Core.h
  • JY7131_RisingEdge : JY7131Core.h
  • JY7131_SetDeviceReferenceClock() : JY7131Core.h
  • JY7131_SetDOPowerOnState() : JY7131Core.h
  • JY7131_Signal_CI_0_SampleClock : JY7131Core.h
  • JY7131_Signal_CI_1_SampleClock : JY7131Core.h
  • JY7131_Signal_CI_2_SampleClock : JY7131Core.h
  • JY7131_Signal_CI_3_SampleClock : JY7131Core.h
  • JY7131_Signal_CI_4_SampleClock : JY7131Core.h
  • JY7131_Signal_CI_5_SampleClock : JY7131Core.h
  • JY7131_Signal_CI_6_SampleClock : JY7131Core.h
  • JY7131_Signal_CI_7_SampleClock : JY7131Core.h
  • JY7131_Signal_CIO_0_StartTrig : JY7131Core.h
  • JY7131_Signal_CIO_100kHz : JY7131Core.h
  • JY7131_Signal_CIO_100MHz : JY7131Core.h
  • JY7131_Signal_CIO_1_StartTrig : JY7131Core.h
  • JY7131_Signal_CIO_2_StartTrig : JY7131Core.h
  • JY7131_Signal_CIO_3_StartTrig : JY7131Core.h
  • JY7131_Signal_CIO_4_StartTrig : JY7131Core.h
  • JY7131_Signal_CIO_5_StartTrig : JY7131Core.h
  • JY7131_Signal_CIO_5MHz : JY7131Core.h
  • JY7131_Signal_CIO_6_StartTrig : JY7131Core.h
  • JY7131_Signal_CIO_7_StartTrig : JY7131Core.h
  • JY7131_Signal_Counter_0_Output : JY7131Core.h
  • JY7131_Signal_Counter_1_Output : JY7131Core.h
  • JY7131_Signal_Counter_2_Output : JY7131Core.h
  • JY7131_Signal_Counter_3_Output : JY7131Core.h
  • JY7131_Signal_Counter_4_Output : JY7131Core.h
  • JY7131_Signal_Counter_5_Output : JY7131Core.h
  • JY7131_Signal_Counter_6_Output : JY7131Core.h
  • JY7131_Signal_Counter_7_Output : JY7131Core.h
  • JY7131_Signal_Destination : JY7131Core.h
  • JY7131_Signal_PFI_In_0 : JY7131Core.h
  • JY7131_Signal_PFI_In_10 : JY7131Core.h
  • JY7131_Signal_PFI_In_11 : JY7131Core.h
  • JY7131_Signal_PFI_In_12 : JY7131Core.h
  • JY7131_Signal_PFI_In_13 : JY7131Core.h
  • JY7131_Signal_PFI_In_14 : JY7131Core.h
  • JY7131_Signal_PFI_In_15 : JY7131Core.h
  • JY7131_Signal_PFI_In_16 : JY7131Core.h
  • JY7131_Signal_PFI_In_17 : JY7131Core.h
  • JY7131_Signal_PFI_In_18 : JY7131Core.h
  • JY7131_Signal_PFI_In_19 : JY7131Core.h
  • JY7131_Signal_PFI_In_2 : JY7131Core.h
  • JY7131_Signal_PFI_In_20 : JY7131Core.h
  • JY7131_Signal_PFI_In_21 : JY7131Core.h
  • JY7131_Signal_PFI_In_22 : JY7131Core.h
  • JY7131_Signal_PFI_In_23 : JY7131Core.h
  • JY7131_Signal_PFI_In_24 : JY7131Core.h
  • JY7131_Signal_PFI_In_25 : JY7131Core.h
  • JY7131_Signal_PFI_In_26 : JY7131Core.h
  • JY7131_Signal_PFI_In_27 : JY7131Core.h
  • JY7131_Signal_PFI_In_28 : JY7131Core.h
  • JY7131_Signal_PFI_In_29 : JY7131Core.h
  • JY7131_Signal_PFI_In_3 : JY7131Core.h
  • JY7131_Signal_PFI_In_30 : JY7131Core.h
  • JY7131_Signal_PFI_In_31 : JY7131Core.h
  • JY7131_Signal_PFI_In_4 : JY7131Core.h
  • JY7131_Signal_PFI_In_5 : JY7131Core.h
  • JY7131_Signal_PFI_In_6 : JY7131Core.h
  • JY7131_Signal_PFI_In_7 : JY7131Core.h
  • JY7131_Signal_PFI_In_8 : JY7131Core.h
  • JY7131_Signal_PFI_In_9 : JY7131Core.h
  • JY7131_Signal_PXI_Trig_0 : JY7131Core.h
  • JY7131_Signal_PXI_Trig_1 : JY7131Core.h
  • JY7131_Signal_PXI_Trig_2 : JY7131Core.h
  • JY7131_Signal_PXI_Trig_3 : JY7131Core.h
  • JY7131_Signal_PXI_Trig_4 : JY7131Core.h
  • JY7131_Signal_PXI_Trig_5 : JY7131Core.h
  • JY7131_Signal_PXI_Trig_6 : JY7131Core.h
  • JY7131_Signal_PXI_Trig_7 : JY7131Core.h
  • JY7131_Signal_Source : JY7131Core.h
  • JY7131_SignalRouting() : JY7131Core.h
  • JY7131_Sinking : JY7131Core.h
  • JY7131_Sourcing : JY7131Core.h


  • Enumerations
  • Enumerator
Here is a list of all enums with links to the files they belong to:
  • JY7131_CI_CounterEventSignalIdleState : JY7131Core.h
  • JY7131_CI_MeasureType : JY7131Core.h
  • JY7131_CI_SampleClock : JY7131Core.h
  • JY7131_CI_SampleMode : JY7131Core.h
  • JY7131_CI_StartingEdge : JY7131Core.h
  • JY7131_CI_ValueReturnMode : JY7131Core.h
  • JY7131_CIO_TriggerType : JY7131Core.h
  • JY7131_CO_IdleState : JY7131Core.h
  • JY7131_CO_OutMode : JY7131Core.h
  • JY7131_CountDirection : JY7131Core.h
  • JY7131_CountTimeBase : JY7131Core.h
  • JY7131_DigitalTriggerEdge : JY7131Core.h
  • JY7131_DigitalTriggerSource : JY7131Core.h
  • JY7131_DOMode : JY7131Core.h
  • JY7131_DOPowerOn_State : JY7131Core.h
  • JY7131_ExternalClockTerminal : JY7131Core.h
  • JY7131_InputTerminal : JY7131Core.h
  • JY7131_LevelState : JY7131Core.h
  • JY7131_ReferenceClock : JY7131Core.h
  • JY7131_Signal_Destination : JY7131Core.h
  • JY7131_Signal_Source : JY7131Core.h


  • Enumerations
  • Enumerator
  • j
Here is a list of all enum values with links to the files they belong to:

- j -

  • JY7131_AnyEdge : JY7131Core.h
  • JY7131_CI_Continuous : JY7131Core.h
  • JY7131_CI_Count_Down : JY7131Core.h
  • JY7131_CI_Count_External : JY7131Core.h
  • JY7131_CI_Count_Up : JY7131Core.h
  • JY7131_CI_CounterEventSignalIdleState_High : JY7131Core.h
  • JY7131_CI_CounterEventSignalIdleState_Low : JY7131Core.h
  • JY7131_CI_EdgeCount : JY7131Core.h
  • JY7131_CI_EncoderTwoPulse : JY7131Core.h
  • JY7131_CI_EncoderX1 : JY7131Core.h
  • JY7131_CI_EncoderX2 : JY7131Core.h
  • JY7131_CI_EncoderX4 : JY7131Core.h
  • JY7131_CI_ExternalClock : JY7131Core.h
  • JY7131_CI_Finite : JY7131Core.h
  • JY7131_CI_ImplicitClock : JY7131Core.h
  • JY7131_CI_InternalClock : JY7131Core.h
  • JY7131_CI_Measure_EdgeSeparation : JY7131Core.h
  • JY7131_CI_Measure_FrequencyOrPeriod : JY7131Core.h
  • JY7131_CI_ReturnOneValue : JY7131Core.h
  • JY7131_CI_ReturnTwoValue : JY7131Core.h
  • JY7131_CI_Single : JY7131Core.h
  • JY7131_CIO_0_StartTrig : JY7131Core.h
  • JY7131_CIO_1_StartTrig : JY7131Core.h
  • JY7131_CIO_2_StartTrig : JY7131Core.h
  • JY7131_CIO_3_StartTrig : JY7131Core.h
  • JY7131_CIO_4_StartTrig : JY7131Core.h
  • JY7131_CIO_5_StartTrig : JY7131Core.h
  • JY7131_CIO_6_StartTrig : JY7131Core.h
  • JY7131_CIO_7_StartTrig : JY7131Core.h
  • JY7131_CIO_Digital : JY7131Core.h
  • JY7131_CIO_Immediately : JY7131Core.h
  • JY7131_CIO_Soft : JY7131Core.h
  • JY7131_Clock_CI_0_SampleClock : JY7131Core.h
  • JY7131_Clock_CI_1_SampleClock : JY7131Core.h
  • JY7131_Clock_CI_2_SampleClock : JY7131Core.h
  • JY7131_Clock_CI_3_SampleClock : JY7131Core.h
  • JY7131_Clock_CI_4_SampleClock : JY7131Core.h
  • JY7131_Clock_CI_5_SampleClock : JY7131Core.h
  • JY7131_Clock_CI_6_SampleClock : JY7131Core.h
  • JY7131_Clock_CI_7_SampleClock : JY7131Core.h
  • JY7131_Clock_Counter_0_Output : JY7131Core.h
  • JY7131_Clock_Counter_1_Output : JY7131Core.h
  • JY7131_Clock_Counter_2_Output : JY7131Core.h
  • JY7131_Clock_Counter_3_Output : JY7131Core.h
  • JY7131_Clock_Counter_4_Output : JY7131Core.h
  • JY7131_Clock_Counter_5_Output : JY7131Core.h
  • JY7131_Clock_Counter_6_Output : JY7131Core.h
  • JY7131_Clock_Counter_7_Output : JY7131Core.h
  • JY7131_Clock_PFI_In_0 : JY7131Core.h
  • JY7131_Clock_PFI_In_1 : JY7131Core.h
  • JY7131_Clock_PFI_In_10 : JY7131Core.h
  • JY7131_Clock_PFI_In_11 : JY7131Core.h
  • JY7131_Clock_PFI_In_12 : JY7131Core.h
  • JY7131_Clock_PFI_In_13 : JY7131Core.h
  • JY7131_Clock_PFI_In_14 : JY7131Core.h
  • JY7131_Clock_PFI_In_15 : JY7131Core.h
  • JY7131_Clock_PFI_In_16 : JY7131Core.h
  • JY7131_Clock_PFI_In_17 : JY7131Core.h
  • JY7131_Clock_PFI_In_18 : JY7131Core.h
  • JY7131_Clock_PFI_In_19 : JY7131Core.h
  • JY7131_Clock_PFI_In_2 : JY7131Core.h
  • JY7131_Clock_PFI_In_20 : JY7131Core.h
  • JY7131_Clock_PFI_In_21 : JY7131Core.h
  • JY7131_Clock_PFI_In_22 : JY7131Core.h
  • JY7131_Clock_PFI_In_23 : JY7131Core.h
  • JY7131_Clock_PFI_In_24 : JY7131Core.h
  • JY7131_Clock_PFI_In_25 : JY7131Core.h
  • JY7131_Clock_PFI_In_26 : JY7131Core.h
  • JY7131_Clock_PFI_In_27 : JY7131Core.h
  • JY7131_Clock_PFI_In_28 : JY7131Core.h
  • JY7131_Clock_PFI_In_29 : JY7131Core.h
  • JY7131_Clock_PFI_In_3 : JY7131Core.h
  • JY7131_Clock_PFI_In_30 : JY7131Core.h
  • JY7131_Clock_PFI_In_31 : JY7131Core.h
  • JY7131_Clock_PFI_In_4 : JY7131Core.h
  • JY7131_Clock_PFI_In_5 : JY7131Core.h
  • JY7131_Clock_PFI_In_6 : JY7131Core.h
  • JY7131_Clock_PFI_In_7 : JY7131Core.h
  • JY7131_Clock_PFI_In_8 : JY7131Core.h
  • JY7131_Clock_PFI_In_9 : JY7131Core.h
  • JY7131_Clock_PXI_Trig_0 : JY7131Core.h
  • JY7131_Clock_PXI_Trig_1 : JY7131Core.h
  • JY7131_Clock_PXI_Trig_2 : JY7131Core.h
  • JY7131_Clock_PXI_Trig_3 : JY7131Core.h
  • JY7131_Clock_PXI_Trig_4 : JY7131Core.h
  • JY7131_Clock_PXI_Trig_5 : JY7131Core.h
  • JY7131_Clock_PXI_Trig_6 : JY7131Core.h
  • JY7131_Clock_PXI_Trig_7 : JY7131Core.h
  • JY7131_CO_ContinuousNoWrapping : JY7131Core.h
  • JY7131_CO_ContinuousWrapping : JY7131Core.h
  • JY7131_CO_Finite : JY7131Core.h
  • JY7131_CO_HighLevel : JY7131Core.h
  • JY7131_CO_LowLevel : JY7131Core.h
  • JY7131_CO_Single : JY7131Core.h
  • JY7131_Counter_0_Output : JY7131Core.h
  • JY7131_Counter_1_Output : JY7131Core.h
  • JY7131_Counter_2_Output : JY7131Core.h
  • JY7131_Counter_3_Output : JY7131Core.h
  • JY7131_Counter_4_Output : JY7131Core.h
  • JY7131_Counter_5_Output : JY7131Core.h
  • JY7131_Counter_6_Output : JY7131Core.h
  • JY7131_Counter_7_Output : JY7131Core.h
  • JY7131_External_Timebase : JY7131Core.h
  • JY7131_Falling : JY7131Core.h
  • JY7131_FallingEdge : JY7131Core.h
  • JY7131_HighLevel : JY7131Core.h
  • JY7131_IN_CIO_100kHz : JY7131Core.h
  • JY7131_IN_CIO_100MHz : JY7131Core.h
  • JY7131_IN_CIO_5MHz : JY7131Core.h
  • JY7131_IN_CO_0_Output : JY7131Core.h
  • JY7131_IN_CO_1_Output : JY7131Core.h
  • JY7131_IN_CO_2_Output : JY7131Core.h
  • JY7131_IN_CO_3_Output : JY7131Core.h
  • JY7131_IN_CO_4_Output : JY7131Core.h
  • JY7131_IN_CO_5_Output : JY7131Core.h
  • JY7131_IN_CO_6_Output : JY7131Core.h
  • JY7131_IN_CO_7_Output : JY7131Core.h
  • JY7131_IN_PFI_In_0 : JY7131Core.h
  • JY7131_IN_PFI_In_1 : JY7131Core.h
  • JY7131_IN_PFI_In_10 : JY7131Core.h
  • JY7131_IN_PFI_In_11 : JY7131Core.h
  • JY7131_IN_PFI_In_12 : JY7131Core.h
  • JY7131_IN_PFI_In_13 : JY7131Core.h
  • JY7131_IN_PFI_In_14 : JY7131Core.h
  • JY7131_IN_PFI_In_15 : JY7131Core.h
  • JY7131_IN_PFI_In_16 : JY7131Core.h
  • JY7131_IN_PFI_In_17 : JY7131Core.h
  • JY7131_IN_PFI_In_18 : JY7131Core.h
  • JY7131_IN_PFI_In_19 : JY7131Core.h
  • JY7131_IN_PFI_In_2 : JY7131Core.h
  • JY7131_IN_PFI_In_20 : JY7131Core.h
  • JY7131_IN_PFI_In_21 : JY7131Core.h
  • JY7131_IN_PFI_In_22 : JY7131Core.h
  • JY7131_IN_PFI_In_23 : JY7131Core.h
  • JY7131_IN_PFI_In_24 : JY7131Core.h
  • JY7131_IN_PFI_In_25 : JY7131Core.h
  • JY7131_IN_PFI_In_26 : JY7131Core.h
  • JY7131_IN_PFI_In_27 : JY7131Core.h
  • JY7131_IN_PFI_In_28 : JY7131Core.h
  • JY7131_IN_PFI_In_29 : JY7131Core.h
  • JY7131_IN_PFI_In_3 : JY7131Core.h
  • JY7131_IN_PFI_In_30 : JY7131Core.h
  • JY7131_IN_PFI_In_31 : JY7131Core.h
  • JY7131_IN_PFI_In_4 : JY7131Core.h
  • JY7131_IN_PFI_In_5 : JY7131Core.h
  • JY7131_IN_PFI_In_6 : JY7131Core.h
  • JY7131_IN_PFI_In_7 : JY7131Core.h
  • JY7131_IN_PFI_In_8 : JY7131Core.h
  • JY7131_IN_PFI_In_9 : JY7131Core.h
  • JY7131_IN_PXI_Trig0 : JY7131Core.h
  • JY7131_IN_PXI_Trig1 : JY7131Core.h
  • JY7131_IN_PXI_Trig2 : JY7131Core.h
  • JY7131_IN_PXI_Trig3 : JY7131Core.h
  • JY7131_IN_PXI_Trig4 : JY7131Core.h
  • JY7131_IN_PXI_Trig5 : JY7131Core.h
  • JY7131_IN_PXI_Trig6 : JY7131Core.h
  • JY7131_IN_PXI_Trig7 : JY7131Core.h
  • JY7131_Internal : JY7131Core.h
  • JY7131_Internal_Timebase_100K : JY7131Core.h
  • JY7131_Internal_Timebase_100M : JY7131Core.h
  • JY7131_Internal_Timebase_5M : JY7131Core.h
  • JY7131_LowLevel : JY7131Core.h
  • JY7131_None : JY7131Core.h
  • JY7131_PFI_In_0 : JY7131Core.h
  • JY7131_PFI_In_1 : JY7131Core.h
  • JY7131_PFI_In_10 : JY7131Core.h
  • JY7131_PFI_In_11 : JY7131Core.h
  • JY7131_PFI_In_12 : JY7131Core.h
  • JY7131_PFI_In_13 : JY7131Core.h
  • JY7131_PFI_In_14 : JY7131Core.h
  • JY7131_PFI_In_15 : JY7131Core.h
  • JY7131_PFI_In_16 : JY7131Core.h
  • JY7131_PFI_In_17 : JY7131Core.h
  • JY7131_PFI_In_18 : JY7131Core.h
  • JY7131_PFI_In_19 : JY7131Core.h
  • JY7131_PFI_In_2 : JY7131Core.h
  • JY7131_PFI_In_20 : JY7131Core.h
  • JY7131_PFI_In_21 : JY7131Core.h
  • JY7131_PFI_In_22 : JY7131Core.h
  • JY7131_PFI_In_23 : JY7131Core.h
  • JY7131_PFI_In_24 : JY7131Core.h
  • JY7131_PFI_In_25 : JY7131Core.h
  • JY7131_PFI_In_26 : JY7131Core.h
  • JY7131_PFI_In_27 : JY7131Core.h
  • JY7131_PFI_In_28 : JY7131Core.h
  • JY7131_PFI_In_29 : JY7131Core.h
  • JY7131_PFI_In_3 : JY7131Core.h
  • JY7131_PFI_In_30 : JY7131Core.h
  • JY7131_PFI_In_31 : JY7131Core.h
  • JY7131_PFI_In_4 : JY7131Core.h
  • JY7131_PFI_In_5 : JY7131Core.h
  • JY7131_PFI_In_6 : JY7131Core.h
  • JY7131_PFI_In_7 : JY7131Core.h
  • JY7131_PFI_In_8 : JY7131Core.h
  • JY7131_PFI_In_9 : JY7131Core.h
  • JY7131_PFI_Out_0 : JY7131Core.h
  • JY7131_PFI_Out_1 : JY7131Core.h
  • JY7131_PFI_Out_10 : JY7131Core.h
  • JY7131_PFI_Out_11 : JY7131Core.h
  • JY7131_PFI_Out_12 : JY7131Core.h
  • JY7131_PFI_Out_13 : JY7131Core.h
  • JY7131_PFI_Out_14 : JY7131Core.h
  • JY7131_PFI_Out_15 : JY7131Core.h
  • JY7131_PFI_Out_16 : JY7131Core.h
  • JY7131_PFI_Out_17 : JY7131Core.h
  • JY7131_PFI_Out_18 : JY7131Core.h
  • JY7131_PFI_Out_19 : JY7131Core.h
  • JY7131_PFI_Out_2 : JY7131Core.h
  • JY7131_PFI_Out_20 : JY7131Core.h
  • JY7131_PFI_Out_21 : JY7131Core.h
  • JY7131_PFI_Out_22 : JY7131Core.h
  • JY7131_PFI_Out_23 : JY7131Core.h
  • JY7131_PFI_Out_24 : JY7131Core.h
  • JY7131_PFI_Out_25 : JY7131Core.h
  • JY7131_PFI_Out_26 : JY7131Core.h
  • JY7131_PFI_Out_27 : JY7131Core.h
  • JY7131_PFI_Out_28 : JY7131Core.h
  • JY7131_PFI_Out_29 : JY7131Core.h
  • JY7131_PFI_Out_3 : JY7131Core.h
  • JY7131_PFI_Out_30 : JY7131Core.h
  • JY7131_PFI_Out_31 : JY7131Core.h
  • JY7131_PFI_Out_4 : JY7131Core.h
  • JY7131_PFI_Out_5 : JY7131Core.h
  • JY7131_PFI_Out_6 : JY7131Core.h
  • JY7131_PFI_Out_7 : JY7131Core.h
  • JY7131_PFI_Out_8 : JY7131Core.h
  • JY7131_PFI_Out_9 : JY7131Core.h
  • JY7131_PowerOn_High : JY7131Core.h
  • JY7131_PowerOn_Low : JY7131Core.h
  • JY7131_PushPull : JY7131Core.h
  • JY7131_PXI_Trig0 : JY7131Core.h
  • JY7131_PXI_Trig1 : JY7131Core.h
  • JY7131_PXI_Trig2 : JY7131Core.h
  • JY7131_PXI_Trig3 : JY7131Core.h
  • JY7131_PXI_Trig4 : JY7131Core.h
  • JY7131_PXI_Trig5 : JY7131Core.h
  • JY7131_PXI_Trig6 : JY7131Core.h
  • JY7131_PXI_Trig7 : JY7131Core.h
  • JY7131_PXIe_Clk100 : JY7131Core.h
  • JY7131_PXITrig0_Out : JY7131Core.h
  • JY7131_PXITrig1_Out : JY7131Core.h
  • JY7131_PXITrig2_Out : JY7131Core.h
  • JY7131_PXITrig3_Out : JY7131Core.h
  • JY7131_PXITrig4_Out : JY7131Core.h
  • JY7131_PXITrig5_Out : JY7131Core.h
  • JY7131_PXITrig6_Out : JY7131Core.h
  • JY7131_PXITrig7_Out : JY7131Core.h
  • JY7131_Rising : JY7131Core.h
  • JY7131_RisingEdge : JY7131Core.h
  • JY7131_Signal_CI_0_SampleClock : JY7131Core.h
  • JY7131_Signal_CI_1_SampleClock : JY7131Core.h
  • JY7131_Signal_CI_2_SampleClock : JY7131Core.h
  • JY7131_Signal_CI_3_SampleClock : JY7131Core.h
  • JY7131_Signal_CI_4_SampleClock : JY7131Core.h
  • JY7131_Signal_CI_5_SampleClock : JY7131Core.h
  • JY7131_Signal_CI_6_SampleClock : JY7131Core.h
  • JY7131_Signal_CI_7_SampleClock : JY7131Core.h
  • JY7131_Signal_CIO_0_StartTrig : JY7131Core.h
  • JY7131_Signal_CIO_100kHz : JY7131Core.h
  • JY7131_Signal_CIO_100MHz : JY7131Core.h
  • JY7131_Signal_CIO_1_StartTrig : JY7131Core.h
  • JY7131_Signal_CIO_2_StartTrig : JY7131Core.h
  • JY7131_Signal_CIO_3_StartTrig : JY7131Core.h
  • JY7131_Signal_CIO_4_StartTrig : JY7131Core.h
  • JY7131_Signal_CIO_5_StartTrig : JY7131Core.h
  • JY7131_Signal_CIO_5MHz : JY7131Core.h
  • JY7131_Signal_CIO_6_StartTrig : JY7131Core.h
  • JY7131_Signal_CIO_7_StartTrig : JY7131Core.h
  • JY7131_Signal_Counter_0_Output : JY7131Core.h
  • JY7131_Signal_Counter_1_Output : JY7131Core.h
  • JY7131_Signal_Counter_2_Output : JY7131Core.h
  • JY7131_Signal_Counter_3_Output : JY7131Core.h
  • JY7131_Signal_Counter_4_Output : JY7131Core.h
  • JY7131_Signal_Counter_5_Output : JY7131Core.h
  • JY7131_Signal_Counter_6_Output : JY7131Core.h
  • JY7131_Signal_Counter_7_Output : JY7131Core.h
  • JY7131_Signal_PFI_In_0 : JY7131Core.h
  • JY7131_Signal_PFI_In_10 : JY7131Core.h
  • JY7131_Signal_PFI_In_11 : JY7131Core.h
  • JY7131_Signal_PFI_In_12 : JY7131Core.h
  • JY7131_Signal_PFI_In_13 : JY7131Core.h
  • JY7131_Signal_PFI_In_14 : JY7131Core.h
  • JY7131_Signal_PFI_In_15 : JY7131Core.h
  • JY7131_Signal_PFI_In_16 : JY7131Core.h
  • JY7131_Signal_PFI_In_17 : JY7131Core.h
  • JY7131_Signal_PFI_In_18 : JY7131Core.h
  • JY7131_Signal_PFI_In_19 : JY7131Core.h
  • JY7131_Signal_PFI_In_2 : JY7131Core.h
  • JY7131_Signal_PFI_In_20 : JY7131Core.h
  • JY7131_Signal_PFI_In_21 : JY7131Core.h
  • JY7131_Signal_PFI_In_22 : JY7131Core.h
  • JY7131_Signal_PFI_In_23 : JY7131Core.h
  • JY7131_Signal_PFI_In_24 : JY7131Core.h
  • JY7131_Signal_PFI_In_25 : JY7131Core.h
  • JY7131_Signal_PFI_In_26 : JY7131Core.h
  • JY7131_Signal_PFI_In_27 : JY7131Core.h
  • JY7131_Signal_PFI_In_28 : JY7131Core.h
  • JY7131_Signal_PFI_In_29 : JY7131Core.h
  • JY7131_Signal_PFI_In_3 : JY7131Core.h
  • JY7131_Signal_PFI_In_30 : JY7131Core.h
  • JY7131_Signal_PFI_In_31 : JY7131Core.h
  • JY7131_Signal_PFI_In_4 : JY7131Core.h
  • JY7131_Signal_PFI_In_5 : JY7131Core.h
  • JY7131_Signal_PFI_In_6 : JY7131Core.h
  • JY7131_Signal_PFI_In_7 : JY7131Core.h
  • JY7131_Signal_PFI_In_8 : JY7131Core.h
  • JY7131_Signal_PFI_In_9 : JY7131Core.h
  • JY7131_Signal_PXI_Trig_0 : JY7131Core.h
  • JY7131_Signal_PXI_Trig_1 : JY7131Core.h
  • JY7131_Signal_PXI_Trig_2 : JY7131Core.h
  • JY7131_Signal_PXI_Trig_3 : JY7131Core.h
  • JY7131_Signal_PXI_Trig_4 : JY7131Core.h
  • JY7131_Signal_PXI_Trig_5 : JY7131Core.h
  • JY7131_Signal_PXI_Trig_6 : JY7131Core.h
  • JY7131_Signal_PXI_Trig_7 : JY7131Core.h
  • JY7131_Sinking : JY7131Core.h
  • JY7131_Sourcing : JY7131Core.h


  • Enumerations
  • Enumerator
  • j
Here is a list of all functions with links to the files they belong to:

- j -

  • JY7131_CI_CheckBufferStatus() : JY7131Core.h
  • JY7131_CI_EnableChannel() : JY7131Core.h
  • JY7131_CI_ReadCountValues() : JY7131Core.h
  • JY7131_CI_ReadMeasureValues() : JY7131Core.h
  • JY7131_CI_ReadSingleCountValue() : JY7131Core.h
  • JY7131_CI_ReadSingleMeasureValue() : JY7131Core.h
  • JY7131_CI_SendSoftTrigger() : JY7131Core.h
  • JY7131_CI_SetAuxTerminal() : JY7131Core.h
  • JY7131_CI_SetCounterParament() : JY7131Core.h
  • JY7131_CI_SetCounterType() : JY7131Core.h
  • JY7131_CI_SetDigitalStartTrigger() : JY7131Core.h
  • JY7131_CI_SetEdgeCountEvent() : JY7131Core.h
  • JY7131_CI_SetFirstSampleClock() : JY7131Core.h
  • JY7131_CI_SetGateTerminal() : JY7131Core.h
  • JY7131_CI_SetMode() : JY7131Core.h
  • JY7131_CI_SetOutTerminal() : JY7131Core.h
  • JY7131_CI_SetPauseTriggerLevel() : JY7131Core.h
  • JY7131_CI_SetSampleClock() : JY7131Core.h
  • JY7131_CI_SetSamplesToAcquire() : JY7131Core.h
  • JY7131_CI_SetSignalReverse() : JY7131Core.h
  • JY7131_CI_SetSourceTerminal() : JY7131Core.h
  • JY7131_CI_SetStartingEdge() : JY7131Core.h
  • JY7131_CI_SetStartTriggerType() : JY7131Core.h
  • JY7131_CI_SetTimeBase() : JY7131Core.h
  • JY7131_CI_SetValueReturnMode() : JY7131Core.h
  • JY7131_CI_SetZReloadEnabled() : JY7131Core.h
  • JY7131_CI_Start() : JY7131Core.h
  • JY7131_CI_Stop() : JY7131Core.h
  • JY7131_Close() : JY7131Core.h
  • JY7131_CO_CheckBufferStatus() : JY7131Core.h
  • JY7131_CO_CheckCounterStatus() : JY7131Core.h
  • JY7131_CO_EnableChannel() : JY7131Core.h
  • JY7131_CO_SendSoftTrigger() : JY7131Core.h
  • JY7131_CO_SetCounterParament() : JY7131Core.h
  • JY7131_CO_SetDigitalStartTrigger() : JY7131Core.h
  • JY7131_CO_SetFrequency() : JY7131Core.h
  • JY7131_CO_SetGateTerminal() : JY7131Core.h
  • JY7131_CO_SetMode() : JY7131Core.h
  • JY7131_CO_SetOutTerminal() : JY7131Core.h
  • JY7131_CO_SetOutTerminalMode() : JY7131Core.h
  • JY7131_CO_SetPauseTriggerLevel() : JY7131Core.h
  • JY7131_CO_SetSamplesToUpdate() : JY7131Core.h
  • JY7131_CO_SetStartTriggerType() : JY7131Core.h
  • JY7131_CO_SetTimeBase() : JY7131Core.h
  • JY7131_CO_Start() : JY7131Core.h
  • JY7131_CO_Stop() : JY7131Core.h
  • JY7131_CO_WaitUntilDone() : JY7131Core.h
  • JY7131_CO_WriteData() : JY7131Core.h
  • JY7131_DI_AddLines() : JY7131Core.h
  • JY7131_DI_ReadSinglePoint_ByLine() : JY7131Core.h
  • JY7131_DI_ReadSinglePoint_ByPort() : JY7131Core.h
  • JY7131_DI_ReadSinglePoint_U32() : JY7131Core.h
  • JY7131_DI_Start() : JY7131Core.h
  • JY7131_DI_Stop() : JY7131Core.h
  • JY7131_DisconnectSignalRouting() : JY7131Core.h
  • JY7131_DO_AddLines() : JY7131Core.h
  • JY7131_DO_SetOutMode() : JY7131Core.h
  • JY7131_DO_Start() : JY7131Core.h
  • JY7131_DO_Stop() : JY7131Core.h
  • JY7131_DO_WriteSinglePoint_ByLine() : JY7131Core.h
  • JY7131_DO_WriteSinglePoint_ByPort() : JY7131Core.h
  • JY7131_DO_WriteSinglePoint_U32() : JY7131Core.h
  • JY7131_GetDeviceID() : JY7131Core.h
  • JY7131_GetDeviceSerialNumber() : JY7131Core.h
  • JY7131_Open() : JY7131Core.h
  • JY7131_OpenByAliasName() : JY7131Core.h
  • JY7131_SetDeviceReferenceClock() : JY7131Core.h
  • JY7131_SetDOPowerOnState() : JY7131Core.h
  • JY7131_SignalRouting() : JY7131Core.h


  • Enumerations
  • Enumerator
Here is a list of all typedefs with links to the files they belong to:
  • JY7131_DeviceHandle : JY7131Core.h


7131 C++ Programming Manual: Main Page

7131 C++ Programming Manual Documentation