7131 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/7131 Directory Reference

7131 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 7131
7131 Directory Reference

Files

JY7131CoreOOCITask.h
JY7131CoreOOCommon.h
JY7131CoreOOCOTask.h
JY7131CoreOODevice.h
JY7131CoreOODITask.h
JY7131CoreOODOTask.h
JY7131CoreOOLog.h
Generated by doxygen 1.13.2


7131 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOOCITask.h File Reference

  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 7131
Classes | Namespaces | Enumerations
JY7131CoreOOCITask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JY7131CoreOOCommon.h"
#include "JY7131CoreOODevice.h"

Classes

class | JY7131CoreOO::JY7131CoreOOCITask
class | JY7131CoreOO::CIInternalSampleClock
CI Internal Sample Clock Configuration Class. More...
class | JY7131CoreOO::CIImplicitSampleClock
CI Implicit Sample Clock class. More...
class | JY7131CoreOO::CIExternalSampleClock
CI Implicit Sample Clock class. More...
class | JY7131CoreOO::CISampleClock
CI Sample Clock class. More...
class | JY7131CoreOO::EdgeCounting
Configure CI EdgeCounting. More...
class | JY7131CoreOO::FrequencyMeas
Configure CI Measure. More...
class | JY7131CoreOO::PeriodMeas
Configure CI Measure. More...
class | JY7131CoreOO::PulseMeas
Configure CI Measure. More...
class | JY7131CoreOO::SemiPeriodMeas
Configure CI SemiPeriodMeas. More...
class | JY7131CoreOO::TwoEdgeSeparation
Configure CI Measure. More...
class | JY7131CoreOO::QuadEncoder
Configure CI Measure. More...
class | JY7131CoreOO::TwoPulseEncoder
Configure CI Measure. More...
class | JY7131CoreOO::CITrigger
Constructor to create an CITrigger task object. More...
class | JY7131CoreOO::CIDigitalTrigger
CI Digital trigger . More...
class | JY7131CoreOO::EdgeCountingOutEvent
Edge counting output event configuration class. More...
class | JY7131CoreOO::CIExternalTimebase
class | JY7131CoreOO::CITimebase
Timebase configuration class. More...
class | JY7131CoreOO::CISignalExport
CI Signal Export Class. More...

Namespaces

namespace JY7131CoreOO

Enumerations

enum class | JY7131CoreOO::CountDirection { JY7131CoreOO::Up = 0x0 , JY7131CoreOO::Down = 0x1 , JY7131CoreOO::External = 0x2 }
Counter direction. More...
enum class | JY7131CoreOO::ValueReturnMode { JY7131CoreOO::TwoValue , JY7131CoreOO::OneValue }
enum class | JY7131CoreOO::CIMode { JY7131CoreOO::Single = 2 , JY7131CoreOO::Finite = 0 , JY7131CoreOO::Continuous = 1 }
enum class JY7131CoreOO::CIType {
JY7131CoreOO::EdgeCounting , JY7131CoreOO::Period , JY7131CoreOO::Frequency , JY7131CoreOO::SemiPeriod ,
JY7131CoreOO::TwoEdgeSeparation , JY7131CoreOO::QuadEncoder , JY7131CoreOO::TwoPulseEncoder
}
Counter Input Application Type. More...
enum class | JY7131CoreOO::CISampleClockSource { JY7131CoreOO::Implicit = 0x0 , JY7131CoreOO::Internal = 0x1 , JY7131CoreOO::External = 0x2 }
CI Sample Clock Source. More...
enum class | JY7131CoreOO::EdgeType { JY7131CoreOO::Rising =0 , JY7131CoreOO::Falling =1 , JY7131CoreOO::Any =2 }
Edge Type. More...
enum class | JY7131CoreOO::QuadEncodingType { JY7131CoreOO::X1 , JY7131CoreOO::X2 , JY7131CoreOO::X4 }
Quadrature Encoding Type. More...
enum class | JY7131CoreOO::CITriggerType { JY7131CoreOO::Immediate = 0x0 , JY7131CoreOO::Digital = 0x2 , JY7131CoreOO::Soft = 0x1 }
TriggerType Digital/Immediate/Soft. More...
enum class JY7131CoreOO::CIDigitalTriggerSource {
JY7131CoreOO::PFI_In_0 =0 , JY7131CoreOO::PFI_In_1 =1 , JY7131CoreOO::PFI_In_2 =2 , JY7131CoreOO::PFI_In_3 =3 ,
JY7131CoreOO::PFI_In_4 =4 , JY7131CoreOO::PFI_In_5 =5 , JY7131CoreOO::PFI_In_6 =6 , JY7131CoreOO::PFI_In_7 =7 ,
JY7131CoreOO::PFI_In_8 =8 , JY7131CoreOO::PFI_In_9 =9 , JY7131CoreOO::PFI_In_10 =10 , JY7131CoreOO::PFI_In_11 =11 ,
JY7131CoreOO::PFI_In_12 =12 , JY7131CoreOO::PFI_In_13 =13 , JY7131CoreOO::PFI_In_14 =14 , JY7131CoreOO::PFI_In_15 =15 ,
JY7131CoreOO::PFI_In_16 =16 , JY7131CoreOO::PFI_In_17 =17 , JY7131CoreOO::PFI_In_18 =18 , JY7131CoreOO::PFI_In_19 =19 ,
JY7131CoreOO::PFI_In_20 =20 , JY7131CoreOO::PFI_In_21 =21 , JY7131CoreOO::PFI_In_22 =22 , JY7131CoreOO::PFI_In_23 =23 ,
JY7131CoreOO::PFI_In_24 =24 , JY7131CoreOO::PFI_In_25 =25 , JY7131CoreOO::PFI_In_26 =26 , JY7131CoreOO::PFI_In_27 =27 ,
JY7131CoreOO::PFI_In_28 =28 , JY7131CoreOO::PFI_In_29 =29 , JY7131CoreOO::PFI_In_30 =30 , JY7131CoreOO::PFI_In_31 =31 ,
JY7131CoreOO::PXI_Trig0 = 32 , JY7131CoreOO::PXI_Trig1 = 33 , JY7131CoreOO::PXI_Trig2 = 34 , JY7131CoreOO::PXI_Trig3 = 35 ,
JY7131CoreOO::PXI_Trig4 = 36 , JY7131CoreOO::PXI_Trig5 = 37 , JY7131CoreOO::PXI_Trig6 = 38 , JY7131CoreOO::PXI_Trig7 = 39 ,
JY7131CoreOO::CIO_0_StartTrig = 40 , JY7131CoreOO::CIO_1_StartTrig = 41 , JY7131CoreOO::CIO_2_StartTrig = 42 , JY7131CoreOO::CIO_3_StartTrig = 43 ,
JY7131CoreOO::CIO_4_StartTrig = 44 , JY7131CoreOO::CIO_5_StartTrig = 45 , JY7131CoreOO::CIO_6_StartTrig = 46 , JY7131CoreOO::CIO_7_StartTrig = 47 ,
JY7131CoreOO::CO_0_OutPut = 48 , JY7131CoreOO::CO_1_OutPut = 49 , JY7131CoreOO::CO_2_OutPut = 50 , JY7131CoreOO::CO_3_OutPut = 51 ,
JY7131CoreOO::CO_4_OutPut = 52 , JY7131CoreOO::CO_5_OutPut = 53 , JY7131CoreOO::CO_6_OutPut = 54 , JY7131CoreOO::CO_7_OutPut = 55
}
CI Digital trigger source. More...
enum class | JY7131CoreOO::CIDigitalTriggerEdge { JY7131CoreOO::Rising , JY7131CoreOO::Falling }
CI Digital Trigger Edge. More...
enum class | JY7131CoreOO::EdgeCntOunEvtIdleState { JY7131CoreOO::LowLevel = 0 , JY7131CoreOO::HighLevel = 1 }
Output idle state when the event has not occurred. More...
enum class | JY7131CoreOO::CISignalExportSource { JY7131CoreOO::StartTrig , JY7131CoreOO::SampleClock }
SourceSignal. More...
enum class | JY7131CoreOO::CITimebaseSource { JY7131CoreOO::Internal100MHz = 0 , JY7131CoreOO::Internal5MHz = 1 , JY7131CoreOO::Internal100kHz = 2 }
Timebase source. More...
enum class JY7131CoreOO::CIMeasureType {
JY7131CoreOO::JY7131_CI_EdgeCount = 0 , JY7131CoreOO::JY7131_CI_Measure_FrequencyOrPeriod = 1 , JY7131CoreOO::JY7131_CI_Measure_PulseWidth = 2 , JY7131CoreOO::JY7131_CI_Measure_SemiPeriod = 3 ,
JY7131CoreOO::JY7131_CI_Measure_EdgeSeparation = 4 , JY7131CoreOO::JY7131_CI_EncoderX1 = 5 , JY7131CoreOO::JY7131_CI_EncoderX2 = 6 , JY7131CoreOO::JY7131_CI_EncoderX4 = 7 ,
JY7131CoreOO::JY7131_CI_EncoderTwoPulse = 8
}
Timebase source. More...


7131 C++ Programming Manual: JY7131CoreOO::JY7131CoreOOCITask Class Reference

  • Class List
  • Class Index
  • Class Members
  • JY7131CoreOO
  • JY7131CoreOOCITask
Public Member Functions | Public Attributes | List of all members
JY7131CoreOO::JY7131CoreOOCITask Class Reference

#include <JY7131CoreOOCITask.h>

Public Member Functions

JY7131CoreOOCITask (int slotNum, int channel)
JY7131CoreOOCITask (std::string boardName, int channel)
~JY7131CoreOOCITask ()
void | Start ()
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Stop ()
Stop CI task .
void | ReadSinglePoint (uint32_t &count)
Read a signle count value from register, Available when Type is CIType.EdgeCounting, CIType.QuadEncoder or CIType.TwoPulseEncoder.
void | ReadData (uint32_t *pBufCount, int samplesToAcquire, int timeout=10000)
Read counter values from buffer.
void | ReadData (std::vector< uint32_t > &pBufCount, int samplesToAcquire, int timeout=10000)
Read counter values from buffer.
void | ReadData (double *pBufMeasurement, int samplesToAcquire, int timeout=10000)
Read frequency value or period value from buffer.
void | ReadData (std::vector< double > &pBufMeasurement, int samplesToAcquire, int timeout=10000)
Read frequency value or period value from buffer.
void | ReadSinglePoint (double &measurement, int timeout=10000)
Read a signle frequency value or period value from register.
void | ReadSinglePoint (double &measurement1, double &measurement2, int timeout=10000)
Read a signle measurement of pulse's duration value, or two-edge separtion value (two results at a time) from register.
void | ReadData (double *pBufMeasurement1, double *pBufMeasurement2, int samplesToAcquire, int timeout=10000)
Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.
void | ReadData (std::vector< double > &pBufMeasurement1, std::vector< double > &pBufMeasurement2, int samplesToAcquire, int timeout=10000)
Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.

Public Attributes

CIType Type
CI Application types.
CIMode Mode
JY7131CoreOOProperty< JY7131CoreOOCITask, uint64_t, JY7131CoreOOPropertyType::READ_ONLY > | AvailableSamples
Number of points per channel that can be read in the buffer .
JY7131CoreOOProperty< JY7131CoreOOCITask, uint64_t, JY7131CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
CISampleClock * SampleClock
Clock Source.
uint32_t | SamplesToAcquire
Number of samples to be read per channel.Only valid when Mode is CIMode.Finite.
JY7131CoreOO::EdgeCounting * EdgeCounting
Edge Counting Configuration.
JY7131CoreOO::FrequencyMeas * FrequencyMeas
Frequency Measurement Configuration.
JY7131CoreOO::PeriodMeas * PeriodMeas
Period Measurement Configuration.
JY7131CoreOO::TwoEdgeSeparation * TwoEdgeSeparation
TwoEdgeSeparation.
JY7131CoreOO::QuadEncoder * QuadEncoder
QuadEncoder.
JY7131CoreOO::TwoPulseEncoder * TwoPulseEncoder
TwoPulseEncoder.
CITrigger * Trigger
CI Trigger Configuration.
CITimebase * TimeBase
CISignalExport * SignalExport
Export CI Signal Configuration.
JY7131CoreOODevice * Device
Device.

Constructor & Destructor Documentation

◆ JY7131CoreOOCITask() [1/2]

JY7131CoreOO::JY7131CoreOOCITask::JY7131CoreOOCITask | ( | int | slotNum,
 |  | int | channel )

◆ JY7131CoreOOCITask() [2/2]

JY7131CoreOO::JY7131CoreOOCITask::JY7131CoreOOCITask | ( | std::string | boardName,
 |  | int | channel )

◆ ~JY7131CoreOOCITask()

JY7131CoreOO::JY7131CoreOOCITask::~JY7131CoreOOCITask ( )

Member Function Documentation

◆ ReadData() [1/6]

void JY7131CoreOO::JY7131CoreOOCITask::ReadData | ( | double * | pBufMeasurement,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read frequency value or period value from buffer.

Available when JY7131CITask.Mode is NOT CIMode.Single, and Type is CIType.Frequency or CIType.Period.

Parameters
bufMeasurement | Buffer for reading data. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period in seconds when Type is CIType.Period.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [2/6]

void JY7131CoreOO::JY7131CoreOOCITask::ReadData | ( | double * | pBufMeasurement1,
 |  | double * | pBufMeasurement2,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.

. Available when JY7131CITask.Mode is NOT CIMode.Single, Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
bufMeasurement1 | Buffer for reading data. Indicates high level duration in seconds when Type is CIType.Pulse锛汭ndicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
bufMeasurement2 | Buffer for reading data. Indicates low level duration in seconds when Type is CIType.Pulse 锛汭ndicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [3/6]

void JY7131CoreOO::JY7131CoreOOCITask::ReadData | ( | std::vector< double > & | pBufMeasurement,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read frequency value or period value from buffer.

Available when JY7131CITask.Mode is NOT CIMode.Single, and Type is CIType.Frequency or CIType.Period.

Parameters
bufMeasurement | Buffer for reading data. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period in seconds when Type is CIType.Period.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [4/6]

void JY7131CoreOO::JY7131CoreOOCITask::ReadData | ( | std::vector< double > & | pBufMeasurement1,
 |  | std::vector< double > & | pBufMeasurement2,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.

. Available when JY7131CITask.Mode is NOT CIMode.Single, Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
bufMeasurement1 | Buffer for reading data. Indicates high level duration in seconds when Type is CIType.Pulse锛汭ndicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
bufMeasurement2 | Buffer for reading data. Indicates low level duration in seconds when Type is CIType.Pulse 锛汭ndicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [5/6]

void JY7131CoreOO::JY7131CoreOOCITask::ReadData | ( | std::vector< uint32_t > & | pBufCount,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read counter values from buffer.

Available when JY7131CITask.Mode is NOT CIMode.Single, and Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder

Parameters
bufCount | Buffer for reading data.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [6/6]

void JY7131CoreOO::JY7131CoreOOCITask::ReadData | ( | uint32_t * | pBufCount,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read counter values from buffer.

Available when JY7131CITask.Mode is NOT CIMode.Single, and Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder

Parameters
bufCount | Buffer for reading data.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [1/3]

void JY7131CoreOO::JY7131CoreOOCITask::ReadSinglePoint | ( | double & | measurement,
 |  | int | timeout = 10000 )

Read a signle frequency value or period value from register.

Valid when Type is CIType.Frequency or CIType.Period.

Parameters
measurement Measurement value. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period is seconds when Type is CIType.Period.
timeout
Timeout (ms). Wait until the measurement is completed or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [2/3]

void JY7131CoreOO::JY7131CoreOOCITask::ReadSinglePoint | ( | double & | measurement1,
 |  | double & | measurement2,
 |  | int | timeout = 10000 )

Read a signle measurement of pulse's duration value, or two-edge separtion value (two results at a time) from register.

Available when Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
measurement1 | Measurement Value 1. Indicates low level duration in seconds when Type is CIType.Pulse锛汭ndicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
measurement2 | Measurement Value 2. Indicates high level duration in seconds when Type is CIType.Pulse 锛汭ndicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
timeout
Timeout (ms). Wait until the measurement is completed or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [3/3]

void JY7131CoreOO::JY7131CoreOOCITask::ReadSinglePoint ( uint32_t & count )

Read a signle count value from register, Available when Type is CIType.EdgeCounting, CIType.QuadEncoder or CIType.TwoPulseEncoder.

Parameters
count counter value銆?/param>

◆ SendSoftwareTrigger()

void JY7131CoreOO::JY7131CoreOOCITask::SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY7131CoreOO::JY7131CoreOOCITask::Start ( )

◆ Stop()

void JY7131CoreOO::JY7131CoreOOCITask::Stop ( )

Stop CI task .

Member Data Documentation

◆ AvailableSamples

JY7131CoreOOProperty<JY7131CoreOOCITask, uint64_t, JY7131CoreOOPropertyType::READ_ONLY> JY7131CoreOO::JY7131CoreOOCITask::AvailableSamples

Number of points per channel that can be read in the buffer .

◆ Device

JY7131CoreOODevice* JY7131CoreOO::JY7131CoreOOCITask::Device

Device.

◆ EdgeCounting

JY7131CoreOO::EdgeCounting* JY7131CoreOO::JY7131CoreOOCITask::EdgeCounting

Edge Counting Configuration.

◆ FrequencyMeas

JY7131CoreOO::FrequencyMeas* JY7131CoreOO::JY7131CoreOOCITask::FrequencyMeas

Frequency Measurement Configuration.

◆ Mode

CIMode JY7131CoreOO::JY7131CoreOOCITask::Mode

◆ PeriodMeas

JY7131CoreOO::PeriodMeas* JY7131CoreOO::JY7131CoreOOCITask::PeriodMeas

Period Measurement Configuration.

◆ QuadEncoder

JY7131CoreOO::QuadEncoder* JY7131CoreOO::JY7131CoreOOCITask::QuadEncoder

QuadEncoder.

◆ SampleClock

CISampleClock* JY7131CoreOO::JY7131CoreOOCITask::SampleClock

Clock Source.

◆ SamplesToAcquire

uint32_t JY7131CoreOO::JY7131CoreOOCITask::SamplesToAcquire

Number of samples to be read per channel.Only valid when Mode is CIMode.Finite.

◆ SignalExport

CISignalExport* JY7131CoreOO::JY7131CoreOOCITask::SignalExport

Export CI Signal Configuration.

◆ TimeBase

CITimebase* JY7131CoreOO::JY7131CoreOOCITask::TimeBase

◆ TransferedSamples

JY7131CoreOOProperty<JY7131CoreOOCITask, uint64_t, JY7131CoreOOPropertyType::READ_ONLY> JY7131CoreOO::JY7131CoreOOCITask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT CIMode.Single.

◆ Trigger

CITrigger* JY7131CoreOO::JY7131CoreOOCITask::Trigger

CI Trigger Configuration.

◆ TwoEdgeSeparation

JY7131CoreOO::TwoEdgeSeparation* JY7131CoreOO::JY7131CoreOOCITask::TwoEdgeSeparation

TwoEdgeSeparation.

◆ TwoPulseEncoder

JY7131CoreOO::TwoPulseEncoder* JY7131CoreOO::JY7131CoreOOCITask::TwoPulseEncoder

TwoPulseEncoder.

◆ Type

CIType JY7131CoreOO::JY7131CoreOOCITask::Type

CI Application types.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOOCITask.h


7131 C++ Programming Manual: JY7131CoreOO::CIInternalSampleClock Class Reference

  • JY7131CoreOO
  • CIInternalSampleClock
Public Attributes | List of all members
JY7131CoreOO::CIInternalSampleClock Class Reference

CI Internal Sample Clock Configuration Class. More...

#include <JY7131CoreOOCITask.h>

Public Attributes

JY7131CoreOOProperty< CIInternalSampleClock, double, JY7131CoreOOPropertyType::READ_WRITE > | Rate
The rate of the internal sample clock (sample rate) which is generated by dividing the internal clock (200MHz).
bool | IgnoreFirstSampleClock = true

Detailed Description

CI Internal Sample Clock Configuration Class.

Member Data Documentation

◆ IgnoreFirstSampleClock

bool JY7131CoreOO::CIInternalSampleClock::IgnoreFirstSampleClock = true

◆ Rate

JY7131CoreOOProperty<CIInternalSampleClock, double, JY7131CoreOOPropertyType::READ_WRITE> JY7131CoreOO::CIInternalSampleClock::Rate

The rate of the internal sample clock (sample rate) which is generated by dividing the internal clock (200MHz).

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOOCITask.h


7131 C++ Programming Manual: JY7131CoreOO::CIImplicitSampleClock Class Reference

  • CIImplicitSampleClock
Public Attributes | List of all members
JY7131CoreOO::CIImplicitSampleClock Class Reference

CI Implicit Sample Clock class. More...

#include <JY7131CoreOOCITask.h>

Public Attributes

double ExpectedRate
Expected Rate of Implicit Sample Clock.

Detailed Description

CI Implicit Sample Clock class.

Member Data Documentation

◆ ExpectedRate

double JY7131CoreOO::CIImplicitSampleClock::ExpectedRate

Expected Rate of Implicit Sample Clock.

Filling this parameter accurately would helps the driver to set a proper DDR write frequency internally.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOOCITask.h


7131 C++ Programming Manual: JY7131CoreOO::CIExternalSampleClock Class Reference

  • CIExternalSampleClock
Public Attributes | List of all members
JY7131CoreOO::CIExternalSampleClock Class Reference

CI Implicit Sample Clock class. More...

#include <JY7131CoreOOCITask.h>

Public Attributes

ClockTerminal Terminal
External Sample Clock Input Terminal.
double | ExpectedRate
Expected Rate of External Sample Clock.
bool | IgnoreFirstSampleClock = true

Detailed Description

CI Implicit Sample Clock class.

Member Data Documentation

◆ ExpectedRate

double JY7131CoreOO::CIExternalSampleClock::ExpectedRate

Expected Rate of External Sample Clock.

Filling this parameter accurately would helps the driver to set a proper DDR write frequency internally.

◆ IgnoreFirstSampleClock

bool JY7131CoreOO::CIExternalSampleClock::IgnoreFirstSampleClock = true

◆ Terminal

ClockTerminal JY7131CoreOO::CIExternalSampleClock::Terminal

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOOCITask.h


7131 C++ Programming Manual: JY7131CoreOO::CISampleClock Class Reference

  • CISampleClock
Public Attributes | List of all members
JY7131CoreOO::CISampleClock Class Reference

CI Sample Clock class. More...

#include <JY7131CoreOOCITask.h>

Public Attributes

CISampleClockSource Source
CI Sample Clock Source.
CIExternalSampleClock * External
CI External Sample Clock Configuration.
CIImplicitSampleClock * Implicit
CI Implicit Sample Clock Configuration.
CIInternalSampleClock * Internal
Internal Sample Clock Configuration.

Detailed Description

CI Sample Clock class.

Member Data Documentation

◆ External

CIExternalSampleClock* JY7131CoreOO::CISampleClock::External

CI External Sample Clock Configuration.

Valid when Source is CISampleClockSource.External.

◆ Implicit

CIImplicitSampleClock* JY7131CoreOO::CISampleClock::Implicit

CI Implicit Sample Clock Configuration.

Valid when Source is CISampleClockSource.Implicit.

◆ Internal

CIInternalSampleClock* JY7131CoreOO::CISampleClock::Internal

Internal Sample Clock Configuration.

Valid when Source is CISampleClockSource.Internal.

◆ Source

CISampleClockSource JY7131CoreOO::CISampleClock::Source

CI Sample Clock Source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOOCITask.h


7131 C++ Programming Manual: JY7131CoreOO::EdgeCounting Class Reference

  • EdgeCounting
Public Attributes | List of all members
JY7131CoreOO::EdgeCounting Class Reference

Configure CI EdgeCounting. More...

#include <JY7131CoreOOCITask.h>

Public Attributes

int InitialCount
Initial Count.
CountDirection Direction
Counter direction.
EdgeType ActiveEdge
The avtive edge of the input signal, the counter will count up or down on this edge.
PauseTrigger * Pause
Pause Trigger Configuration.
EdgeCountingOutEvent * OutEvent
Edge counting output event.
JY7131CoreOO::InputTerminal DirTerminal
Terminal of External Count Diretion Control.
JY7131CoreOO::InputTerminal Input_Terminal
Input Terminal.

Detailed Description

Configure CI EdgeCounting.

Member Data Documentation

◆ ActiveEdge

EdgeType JY7131CoreOO::EdgeCounting::ActiveEdge

The avtive edge of the input signal, the counter will count up or down on this edge.

◆ Direction

CountDirection JY7131CoreOO::EdgeCounting::Direction

Counter direction.

enum Up/Down/External

◆ DirTerminal

JY7131CoreOO::InputTerminal JY7131CoreOO::EdgeCounting::DirTerminal

Terminal of External Count Diretion Control.

Valid when Direction is CountDirection.External

◆ InitialCount

int JY7131CoreOO::EdgeCounting::InitialCount

Initial Count.

◆ Input_Terminal

JY7131CoreOO::InputTerminal JY7131CoreOO::EdgeCounting::Input_Terminal

Input Terminal.

◆ OutEvent

EdgeCountingOutEvent* JY7131CoreOO::EdgeCounting::OutEvent

Edge counting output event.

A pulse will be generated when the count value reaches specified threshold

◆ Pause

PauseTrigger* JY7131CoreOO::EdgeCounting::Pause

Pause Trigger Configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOOCITask.h


7131 C++ Programming Manual: JY7131CoreOO::FrequencyMeas Class Reference

  • FrequencyMeas
Public Attributes | List of all members
JY7131CoreOO::FrequencyMeas Class Reference

Configure CI Measure. More...

#include <JY7131CoreOOCITask.h>

Public Attributes

CITimebase * Timebase
Timebase configuration.
EdgeType StartingEdge
JY7131CoreOO::InputTerminal Input_Terminal
Input Terminal.

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ Input_Terminal

JY7131CoreOO::InputTerminal JY7131CoreOO::FrequencyMeas::Input_Terminal

Input Terminal.

◆ StartingEdge

EdgeType JY7131CoreOO::FrequencyMeas::StartingEdge

◆ Timebase

CITimebase* JY7131CoreOO::FrequencyMeas::Timebase

Timebase configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOOCITask.h


7131 C++ Programming Manual: JY7131CoreOO::PeriodMeas Class Reference

  • PeriodMeas
Public Attributes | List of all members
JY7131CoreOO::PeriodMeas Class Reference

Configure CI Measure. More...

#include <JY7131CoreOOCITask.h>

Public Attributes

CITimebase * Timebase
GetDefautTerminal Timebase configuration.
EdgeType StartingEdge
JY7131CoreOO::InputTerminal Input_Terminal
Input Terminal.

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ Input_Terminal

JY7131CoreOO::InputTerminal JY7131CoreOO::PeriodMeas::Input_Terminal

Input Terminal.

◆ StartingEdge

EdgeType JY7131CoreOO::PeriodMeas::StartingEdge

◆ Timebase

CITimebase* JY7131CoreOO::PeriodMeas::Timebase

GetDefautTerminal Timebase configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOOCITask.h


7131 C++ Programming Manual: JY7131CoreOO::PulseMeas Class Reference

  • PulseMeas
Public Attributes | List of all members
JY7131CoreOO::PulseMeas Class Reference

Configure CI Measure. More...

#include <JY7131CoreOOCITask.h>

Public Attributes

CITimebase * Timebase
Timebase configuration.
JY7131CoreOO::InputTerminal Input_Terminal
Input Terminal.
EdgeType StartingEdge = EdgeType::Rising

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ Input_Terminal

JY7131CoreOO::InputTerminal JY7131CoreOO::PulseMeas::Input_Terminal

Input Terminal.

◆ StartingEdge

EdgeType JY7131CoreOO::PulseMeas::StartingEdge = EdgeType::Rising

◆ Timebase

CITimebase* JY7131CoreOO::PulseMeas::Timebase

Timebase configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOOCITask.h


7131 C++ Programming Manual: JY7131CoreOO::SemiPeriodMeas Class Reference

  • SemiPeriodMeas
Public Attributes | List of all members
JY7131CoreOO::SemiPeriodMeas Class Reference

Configure CI SemiPeriodMeas. More...

#include <JY7131CoreOOCITask.h>

Public Attributes

CITimebase * Timebase
Timebase configuration.
JY7131CoreOO::InputTerminal Input_Terminal
Input Terminal.
EdgeType StartingEdge = EdgeType::Rising

Detailed Description

Configure CI SemiPeriodMeas.

Member Data Documentation

◆ Input_Terminal

JY7131CoreOO::InputTerminal JY7131CoreOO::SemiPeriodMeas::Input_Terminal

Input Terminal.

◆ StartingEdge

EdgeType JY7131CoreOO::SemiPeriodMeas::StartingEdge = EdgeType::Rising

◆ Timebase

CITimebase* JY7131CoreOO::SemiPeriodMeas::Timebase

Timebase configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOOCITask.h


7131 C++ Programming Manual: JY7131CoreOO::TwoEdgeSeparation Class Reference

  • TwoEdgeSeparation
Public Attributes | List of all members
JY7131CoreOO::TwoEdgeSeparation Class Reference

Configure CI Measure. More...

#include <JY7131CoreOOCITask.h>

Public Attributes

CITimebase * Timebase
Timebase configuration.
InputTerminal FirstInputTerminal
Input Terminal.
InputTerminal SecondInputTerminal
Input Terminal.
ValueReturnMode EdgeSeparationMode = ValueReturnMode::OneValue

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ EdgeSeparationMode

ValueReturnMode JY7131CoreOO::TwoEdgeSeparation::EdgeSeparationMode = ValueReturnMode::OneValue

◆ FirstInputTerminal

InputTerminal JY7131CoreOO::TwoEdgeSeparation::FirstInputTerminal

Input Terminal.

◆ SecondInputTerminal

InputTerminal JY7131CoreOO::TwoEdgeSeparation::SecondInputTerminal

Input Terminal.

◆ Timebase

CITimebase* JY7131CoreOO::TwoEdgeSeparation::Timebase

Timebase configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOOCITask.h


7131 C++ Programming Manual: JY7131CoreOO::QuadEncoder Class Reference

  • QuadEncoder
Public Attributes | List of all members
JY7131CoreOO::QuadEncoder Class Reference

Configure CI Measure. More...

#include <JY7131CoreOOCITask.h>

Public Attributes

QuadEncodingType EncodingType
Type of Encoding.
bool | ZReloadEnabled
In Encoder mode ,the Z signal enable.
int | InitialCount
Initial Count.
InputTerminal AInputTerminal
Input Terminal.
InputTerminal BInputTerminal
Input Terminal.
InputTerminal ZInputTerminal
Input Terminal.

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ AInputTerminal

InputTerminal JY7131CoreOO::QuadEncoder::AInputTerminal

Input Terminal.

◆ BInputTerminal

InputTerminal JY7131CoreOO::QuadEncoder::BInputTerminal

Input Terminal.

◆ EncodingType

QuadEncodingType JY7131CoreOO::QuadEncoder::EncodingType

Type of Encoding.

◆ InitialCount

int JY7131CoreOO::QuadEncoder::InitialCount

Initial Count.

◆ ZInputTerminal

InputTerminal JY7131CoreOO::QuadEncoder::ZInputTerminal

Input Terminal.

◆ ZReloadEnabled

bool JY7131CoreOO::QuadEncoder::ZReloadEnabled

In Encoder mode ,the Z signal enable.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOOCITask.h


7131 C++ Programming Manual: JY7131CoreOO::TwoPulseEncoder Class Reference

  • TwoPulseEncoder
Public Attributes | List of all members
JY7131CoreOO::TwoPulseEncoder Class Reference

Configure CI Measure. More...

#include <JY7131CoreOOCITask.h>

Public Attributes

int InitialCount
Initial Count.
InputTerminal AInputTerminal
Input Terminal.
InputTerminal BInputTerminal
Input Terminal.

Detailed Description

Configure CI Measure.

Member Data Documentation

◆ AInputTerminal

InputTerminal JY7131CoreOO::TwoPulseEncoder::AInputTerminal

Input Terminal.

◆ BInputTerminal

InputTerminal JY7131CoreOO::TwoPulseEncoder::BInputTerminal

Input Terminal.

◆ InitialCount

int JY7131CoreOO::TwoPulseEncoder::InitialCount

Initial Count.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOOCITask.h


7131 C++ Programming Manual: JY7131CoreOO::CITrigger Class Reference

  • CITrigger
Public Attributes | List of all members
JY7131CoreOO::CITrigger Class Reference

Constructor to create an CITrigger task object. More...

#include <JY7131CoreOOCITask.h>

Public Attributes

CITriggerType Type
CI trigger type.
CIDigitalTrigger * Digital
CI Digital Trigger.

Detailed Description

Constructor to create an CITrigger task object.

Used to build CI Trigger

Member Data Documentation

◆ Digital

CIDigitalTrigger* JY7131CoreOO::CITrigger::Digital

CI Digital Trigger.

Valid when Type is CITriggerType.Digital

◆ Type

CITriggerType JY7131CoreOO::CITrigger::Type

CI trigger type.

enum Immediate/Digital/Soft.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOOCITask.h


7131 C++ Programming Manual: JY7131CoreOO::CIDigitalTrigger Class Reference

  • CIDigitalTrigger
Public Attributes | List of all members
JY7131CoreOO::CIDigitalTrigger Class Reference

CI Digital trigger . More...

#include <JY7131CoreOOCITask.h>

Public Attributes

CIDigitalTriggerSource Source
CI Digital Trigger source.
CIDigitalTriggerEdge Edge
Digital Trigger edge锛孯ising/Falling.

Detailed Description

CI Digital trigger .

Member Data Documentation

◆ Edge

CIDigitalTriggerEdge JY7131CoreOO::CIDigitalTrigger::Edge

Digital Trigger edge锛孯ising/Falling.

◆ Source

CIDigitalTriggerSource JY7131CoreOO::CIDigitalTrigger::Source

CI Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOOCITask.h


7131 C++ Programming Manual: JY7131CoreOO::EdgeCountingOutEvent Class Reference

  • EdgeCountingOutEvent
Public Attributes | List of all members
JY7131CoreOO::EdgeCountingOutEvent Class Reference

Edge counting output event configuration class. More...

#include <JY7131CoreOOCITask.h>

Public Attributes

EdgeCntOunEvtIdleState IdleState
Output idle state when the event has not occurred.
uint32_t Threshold
Comparison threshold.
IOTerminal Terminal
Terminal.

Detailed Description

Edge counting output event configuration class.

Member Data Documentation

◆ IdleState

EdgeCntOunEvtIdleState JY7131CoreOO::EdgeCountingOutEvent::IdleState

Output idle state when the event has not occurred.

The default value is EdgeCntOunEvtIdleState.LowLevel

◆ Terminal

IOTerminal JY7131CoreOO::EdgeCountingOutEvent::Terminal

Terminal.

◆ Threshold

uint32_t JY7131CoreOO::EdgeCountingOutEvent::Threshold

Comparison threshold.

The default value is 2^32-1

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOOCITask.h


7131 C++ Programming Manual: JY7131CoreOO::CIExternalTimebase Class Reference

  • CIExternalTimebase
Public Attributes | List of all members
JY7131CoreOO::CIExternalTimebase Class Reference

#include <JY7131CoreOOCITask.h>

Public Attributes

JY7131CoreOO::InputTerminal Terminal
double Frequency = 100e6

Member Data Documentation

◆ Frequency

double JY7131CoreOO::CIExternalTimebase::Frequency = 100e6

◆ Terminal

JY7131CoreOO::InputTerminal JY7131CoreOO::CIExternalTimebase::Terminal
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOOCITask.h


7131 C++ Programming Manual: JY7131CoreOO::CITimebase Class Reference

  • CITimebase
Public Member Functions | Public Attributes | List of all members
JY7131CoreOO::CITimebase Class Reference

Timebase configuration class. More...

#include <JY7131CoreOOCITask.h>

Public Member Functions

CITimebase ()
Timebase Source.
~CITimebase ()

Public Attributes

CITimebaseSource Source
CIExternalTimebase * External
JY7131CoreOOProperty< CITimebase, double, JY7131CoreOOPropertyType::READ_ONLY > ActualFreq

Detailed Description

Timebase configuration class.

Constructor & Destructor Documentation

◆ CITimebase()

JY7131CoreOO::CITimebase::CITimebase ( )

Timebase Source.

◆ ~CITimebase()

JY7131CoreOO::CITimebase::~CITimebase ( )
inline

Member Data Documentation

◆ ActualFreq

JY7131CoreOOProperty<CITimebase, double, JY7131CoreOOPropertyType::READ_ONLY> JY7131CoreOO::CITimebase::ActualFreq

◆ External

CIExternalTimebase* JY7131CoreOO::CITimebase::External

◆ Source

CITimebaseSource JY7131CoreOO::CITimebase::Source
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOOCITask.h


7131 C++ Programming Manual: JY7131CoreOO::CISignalExport Class Reference

  • CISignalExport
Public Member Functions | List of all members
JY7131CoreOO::CISignalExport Class Reference

CI Signal Export Class. More...

#include <JY7131CoreOOCITask.h>

Public Member Functions

void | Add (CISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (CISignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

CI Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY7131CoreOO::CISignalExport::Add | ( | CISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | CI Signal Source
destination | Export Desination

◆ Add() [2/2]

void JY7131CoreOO::CISignalExport::Add | ( | CISignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | CI Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JY7131CoreOO::CISignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY7131CoreOO::CISignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOOCITask.h


7131 C++ Programming Manual: JY7131CoreOO Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Enumerations | Functions
JY7131CoreOO Namespace Reference

Classes

class | CIDigitalTrigger
CI Digital trigger . More...
class | CIExternalSampleClock
CI Implicit Sample Clock class. More...
class | CIExternalTimebase
class | CIImplicitSampleClock
CI Implicit Sample Clock class. More...
class | CIInternalSampleClock
CI Internal Sample Clock Configuration Class. More...
class | CISampleClock
CI Sample Clock class. More...
class | CISignalExport
CI Signal Export Class. More...
class | CITimebase
Timebase configuration class. More...
class | CITrigger
Constructor to create an CITrigger task object. More...
class | CODigitalTrigger
CO Digital trigger . More...
class | COExternalTimebase
class | COPulse
Pulse Parameter. More...
class | COSignalExport
CO Signal Export Class. More...
class | COTimebase
Timebase configuration class. More...
class | COTrigger
Constructor to create an COTrigger task object. More...
class | DIChannel
DI Channel parameter class . More...
class | DOChannel
DO Channel parameter class . More...
class | EdgeCounting
Configure CI EdgeCounting. More...
class | EdgeCountingOutEvent
Edge counting output event configuration class. More...
class | ExternalReferenceClock
class | FrequencyMeas
Configure CI Measure. More...
class | JY7131CoreOOCITask
class | JY7131CoreOOCOTask
class | JY7131CoreOODevice
class | JY7131CoreOODITask
class | JY7131CoreOODOTask
class | JY7131CoreOOLog
class | JY7131CoreOOProperty
属性模板类 More...
class | JY7131CoreOOReferenceClock
class | JYDriverException
class | PauseTrigger
Pause trigger configuration class. More...
class | PeriodMeas
Configure CI Measure. More...
class | PulseMeas
Configure CI Measure. More...
class | QuadEncoder
Configure CI Measure. More...
class | SemiPeriodMeas
Configure CI SemiPeriodMeas. More...
class | TwoEdgeSeparation
Configure CI Measure. More...
class | TwoPulseEncoder
Configure CI Measure. More...

Enumerations

enum class | CountDirection { Up = 0x0 , Down = 0x1 , External = 0x2 }
Counter direction. More...
enum class | ValueReturnMode { TwoValue , OneValue }
enum class | CIMode { Single = 2 , Finite = 0 , Continuous = 1 }
enum class CIType {
EdgeCounting , Period , Frequency , SemiPeriod ,
TwoEdgeSeparation , QuadEncoder , TwoPulseEncoder
}
Counter Input Application Type. More...
enum class | CISampleClockSource { Implicit = 0x0 , Internal = 0x1 , External = 0x2 }
CI Sample Clock Source. More...
enum class | EdgeType { Rising =0 , Falling =1 , Any =2 }
Edge Type. More...
enum class | QuadEncodingType { X1 , X2 , X4 }
Quadrature Encoding Type. More...
enum class | CITriggerType { Immediate = 0x0 , Digital = 0x2 , Soft = 0x1 }
TriggerType Digital/Immediate/Soft. More...
enum class CIDigitalTriggerSource {
PFI_In_0 =0 , PFI_In_1 =1 , PFI_In_2 =2 , PFI_In_3 =3 ,
PFI_In_4 =4 , PFI_In_5 =5 , PFI_In_6 =6 , PFI_In_7 =7 ,
PFI_In_8 =8 , PFI_In_9 =9 , PFI_In_10 =10 , PFI_In_11 =11 ,
PFI_In_12 =12 , PFI_In_13 =13 , PFI_In_14 =14 , PFI_In_15 =15 ,
PFI_In_16 =16 , PFI_In_17 =17 , PFI_In_18 =18 , PFI_In_19 =19 ,
PFI_In_20 =20 , PFI_In_21 =21 , PFI_In_22 =22 , PFI_In_23 =23 ,
PFI_In_24 =24 , PFI_In_25 =25 , PFI_In_26 =26 , PFI_In_27 =27 ,
PFI_In_28 =28 , PFI_In_29 =29 , PFI_In_30 =30 , PFI_In_31 =31 ,
PXI_Trig0 = 32 , PXI_Trig1 = 33 , PXI_Trig2 = 34 , PXI_Trig3 = 35 ,
PXI_Trig4 = 36 , PXI_Trig5 = 37 , PXI_Trig6 = 38 , PXI_Trig7 = 39 ,
CIO_0_StartTrig = 40 , CIO_1_StartTrig = 41 , CIO_2_StartTrig = 42 , CIO_3_StartTrig = 43 ,
CIO_4_StartTrig = 44 , CIO_5_StartTrig = 45 , CIO_6_StartTrig = 46 , CIO_7_StartTrig = 47 ,
CO_0_OutPut = 48 , CO_1_OutPut = 49 , CO_2_OutPut = 50 , CO_3_OutPut = 51 ,
CO_4_OutPut = 52 , CO_5_OutPut = 53 , CO_6_OutPut = 54 , CO_7_OutPut = 55
}
CI Digital trigger source. More...
enum class | CIDigitalTriggerEdge { Rising , Falling }
CI Digital Trigger Edge. More...
enum class | EdgeCntOunEvtIdleState { LowLevel = 0 , HighLevel = 1 }
Output idle state when the event has not occurred. More...
enum class | CISignalExportSource { StartTrig , SampleClock }
SourceSignal. More...
enum class | CITimebaseSource { Internal100MHz = 0 , Internal5MHz = 1 , Internal100kHz = 2 }
Timebase source. More...
enum class CIMeasureType {
JY7131_CI_EdgeCount = 0 , JY7131_CI_Measure_FrequencyOrPeriod = 1 , JY7131_CI_Measure_PulseWidth = 2 , JY7131_CI_Measure_SemiPeriod = 3 ,
JY7131_CI_Measure_EdgeSeparation = 4 , JY7131_CI_EncoderX1 = 5 , JY7131_CI_EncoderX2 = 6 , JY7131_CI_EncoderX4 = 7 ,
JY7131_CI_EncoderTwoPulse = 8
}
Timebase source. More...
enum class | OutputState { HoldOn = 0 , HighLevel = 1 , LowLevel = 2 }
CO output state when pause trigger valid. More...
enum class | JY7131CoreOOPropertyType { READ_ONLY = 1 , WRITE_ONLY = 2 , READ_WRITE = 3 }
enum class JYDriverExceptionPublic {
UnKnown = 0 , OpenDeviceFailed = -10001 , CloseDeviceFailed = -10002 , ResetDeviceFailed = -10003 ,
GetDevicePropertyFailed = -10004 , SetDevicePropertyFailed = -10005 , HardwareResourceIsReserved = -10006 , MethodNotPermitedToCallWhenCurrentStatus = -10007 ,
InvalidUserDataBuffer = -10008 , NoChannelAdded = -10009 , NotSupportOperationForCurrentDevice = -10010 , CreatTaskFailed = -10100 ,
StartTaskFailed = -10101 , StopTaskFailed = -10102 , TaskHasNotStarted = -10103 , TaskHasStartedCannotPerformTheSetOperation = -10104 ,
ChannelNumberParameterInvalid = -10105 , ChannelInputRangeParameterInvalid = -10106 , ChannelTerminalParameterInvalid = -10107 , ChannelCouplingParameterInvalid = -10108 ,
SampeleModeParameterInvalid = -10109 , SampleClockParameterInvalid = -10110 , SampleRateParameterInvalid = -10111 , UpdateRateParameterInvalid = -10112 ,
TriggerParameterInvalid = -10113 , ReferenceTriggerDoesNotMatchWithSampleMode = -10114 , PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint = -10115 , ReadDataFailed = -10016 ,
ReadDataTimeout = -10017 , WriteDataFailed = -10018 , WriteDataTimeout = -10019 , WriteDataLengthCannotBeLessThanN = -10020 ,
BufferDataOverflow = -10021 , BufferDataDownflow = -10022 , CheckBufferFailed = -10023 , PointInvalidInFiniteMode = -10024 ,
ReadPointInvalid = -10025 , OnlySupportRecordMode = -10026 , SendSoftTirggerFailed = -10027 , TaskTimeout = -10028 ,
CounterParametersInvalid = -10029 , WritePointInvalid = -10030 , SignalExportDestinationInvalid = -10031 , InvalidParameter = -10033
}
enum class ClockTerminal {
PFI0 = 0 , PFI_In_1 =1 , PFI_In_2 = 2 , PFI_In_3 = 3 ,
PFI_In_4 = 4 , PFI_In_5 = 5 , PFI_In_6 = 6 , PFI_In_7 = 7 ,
PFI_In_8 = 8 , PFI_In_9 = 9 , PFI_In_10 = 10 , PFI_In_11 = 11 ,
PFI_In_12 = 12 , PFI_In_13 = 13 , PFI_In_14 = 14 , PFI_In_15 =15 ,
PFI_In_16 = 16 , PFI_In_17 =17 , PFI_In_18 =18 , PFI_In_19 = 19 ,
PFI_In_20 = 20 , PFI_In_21 = 21 , PFI_In_22 = 22 , PFI_In_23 = 23 ,
PFI_In_24 = 24 , PFI_In_25 = 25 , PFI_In_26 = 26 , PFI_In_27 = 27 ,
PFI_In_28 = 28 , PFI_In_29 = 29 , PFI_In_30 = 30 , PFI_In_31 = 31 ,
PXI_Trig0 = 32 , PXI_Trig1 =33 , PXI_Trig2 = 34 , PXI_Trig3 = 35 ,
PXI_Trig4 = 36 , PXI_Trig5 = 37 , PXI_Trig6 = 38 , PXI_Trig7 = 39 ,
CI0_SampleClock = 40 , CI1_SampleClock = 41 , CI2_SampleClock = 42 , CI3_SampleClock = 43 ,
CI4_SampleClock = 44 , CI5_SampleClock = 45 , CI6_SampleClock = 46 , CI7_SampleClock = 47 ,
CO0_Output = 48 , CO1_Output = 49 , CO2_Output = 50 , CO3_Output = 51 ,
CO4_Output = 52 , CO5_Output = 53 , CO6_Output = 54 , CO7_Output = 55
}
enum class SignalExportDestination {
PFI0 = 0 , PFI_In_1 = 1 , PFI_In_2 = 2 , PFI_In_3 = 3 ,
PFI_In_4 = 4 , PFI_In_5 = 5 , PFI_In_6 = 6 , PFI_In_7 = 7 ,
PFI_In_8 = 8 , PFI_In_9 = 9 , PFI_In_10 = 10 , PFI_In_11 = 11 ,
PFI_In_12 = 12 , PFI_In_13 = 13 , PFI_In_14 = 14 , PFI_In_15 = 15 ,
PFI_In_16 = 16 , PFI_In_17 = 17 , PFI_In_18 = 18 , PFI_In_19 = 19 ,
PFI_In_20 = 20 , PFI_In_21 = 21 , PFI_In_22 = 22 , PFI_In_23 = 23 ,
PFI_In_24 = 24 , PFI_In_25 = 25 , PFI_In_26 = 26 , PFI_In_27 = 27 ,
PFI_In_28 = 28 , PFI_In_29 = 29 , PFI_In_30 = 30 , PFI_In_31 = 31 ,
PXI_Trig0 = 32 , PXI_Trig1 = 33 , PXI_Trig2 = 34 , PXI_Trig3 = 35 ,
PXI_Trig4 = 36 , PXI_Trig5 = 37 , PXI_Trig6 = 38 , PXI_Trig7 = 39
}
enum class | OutputCompleteState { Zero , Hold }
Output Complete State. More...
enum class IOTerminal {
None = 40 , PFI_Out_0 = 0 , PFI_Out_1 = 1 , PFI_Out_2 = 2 ,
PFI_Out_3 = 3 , PFI_Out_4 = 4 , PFI_Out_5 = 5 , PFI_Out_6 = 6 ,
PFI_Out_7 = 7 , PFI_Out_8 = 8 , PFI_Out_9 = 9 , PFI_Out_10 = 10 ,
PFI_Out_11 = 11 , PFI_Out_12 = 12 , PFI_Out_13 = 13 , PFI_Out_14 = 14 ,
PFI_Out_15 = 15 , PFI_Out_16 = 16 , PFI_Out_17 = 17 , PFI_Out_18 = 18 ,
PFI_Out_19 = 19 , PFI_Out_20 = 20 , PFI_Out_21 = 21 , PFI_Out_22 = 22 ,
PFI_Out_23 = 23 , PFI_Out_24 = 24 , PFI_Out_25 = 25 , PFI_Out_26 = 26 ,
PFI_Out_27 = 27 , PFI_Out_28 = 28 , PFI_Out_29 = 29 , PFI_Out_30 = 30 ,
PFI_Out_31 = 31 , PXI_Trig0 = 32 , PXI_Trig1 = 33 , PXI_Trig2 = 34 ,
PXI_Trig3 = 35 , PXI_Trig4 = 36 , PXI_Trig5 = 37 , PXI_Trig6 = 38 ,
PXI_Trig7 = 39
}
enum class | LevelPolarity { LowLevel = 0 , HighLevel = 1 , None = 2 }
Level Polarity. More...
enum class InputTerminal {
PFI_In_0 = 0 , PFI_In_1 = 1 , PFI_In_2 = 2 , PFI_In_3 = 3 ,
PFI_In_4 = 4 , PFI_In_5 = 5 , PFI_In_6 = 6 , PFI_In_7 = 7 ,
PFI_In_8 = 8 , PFI_In_9 = 9 , PFI_In_10 = 10 , PFI_In_11 = 11 ,
PFI_In_12 = 12 , PFI_In_13 = 13 , PFI_In_14 = 14 , PFI_In_15 = 15 ,
PFI_In_16 = 16 , PFI_In_17 = 17 , PFI_In_18 = 18 , PFI_In_19 = 19 ,
PFI_In_20 = 20 , PFI_In_21 = 21 , PFI_In_22 = 22 , PFI_In_23 = 23 ,
PFI_In_24 = 24 , PFI_In_25 = 25 , PFI_In_26 = 26 , PFI_In_27 = 27 ,
PFI_In_28 = 28 , PFI_In_29 = 29 , PFI_In_30 = 30 , PFI_In_31 = 31 ,
PXI_Trig0 = 32 , PXI_Trig1 = 33 , PXI_Trig2 = 34 , PXI_Trig3 = 35 ,
PXI_Trig4 = 36 , PXI_Trig5 = 37 , PXI_Trig6 = 38 , PXI_Trig7 = 39 ,
CI_0_OutPut = 40 , CI_1_OutPut = 41 , CI_2_OutPut = 42 , CI_3_OutPut = 43 ,
CI_4_OutPut = 44 , CI_5_OutPut = 45 , CI_6_OutPut = 46 , CI_7_OutPut = 47 ,
Timebase_100MHz = 48 , Timebase_5MHz = 49 , Timebase_100kHz = 50
}
Cunter Input Terminal. More...
enum class | COIdleState { HighLevel = 0x1 , LowLevel = 0x0 }
Idle state when pulse output before start and after stop. More...
enum class | COMode { Single = 3 , Finite = 0 , ContinuousNoWrapping = 2 , ContinuousWrapping = 1 }
enum class | COTriggerType { Immediate = 0x0 , Digital = 0x1 , Soft = 0x3 }
TriggerType Digital/Immediate/Soft. More...
enum class CODigitalTriggerSource {
PFI_In_0 = 0 , PFI_In_1 = 1 , PFI_In_2 = 2 , PFI_In_3 = 3 ,
PFI_In_4 = 4 , PFI_In_5 = 5 , PFI_In_6 = 6 , PFI_In_7 = 7 ,
PFI_In_8 = 8 , PFI_In_9 = 9 , PFI_In_10 = 10 , PFI_In_11 = 11 ,
PFI_In_12 = 12 , PFI_In_13 = 13 , PFI_In_14 = 14 , PFI_In_15 = 15 ,
PFI_In_16 = 16 , PFI_In_17 = 17 , PFI_In_18 = 18 , PFI_In_19 = 19 ,
PFI_In_20 = 20 , PFI_In_21 = 21 , PFI_In_22 = 22 , PFI_In_23 = 23 ,
PFI_In_24 = 24 , PFI_In_25 = 25 , PFI_In_26 = 26 , PFI_In_27 = 27 ,
PFI_In_28 = 28 , PFI_In_29 = 29 , PFI_In_30 = 30 , PFI_In_31 = 31 ,
PXI_Trig0 = 32 , PXI_Trig1 = 33 , PXI_Trig2 = 34 , PXI_Trig3 = 35 ,
PXI_Trig4 = 36 , PXI_Trig5 = 37 , PXI_Trig6 = 38 , PXI_Trig7 = 39 ,
CIO_0_StartTrig = 40 , CIO_1_StartTrig = 41 , CIO_2_StartTrig = 42 , CIO_3_StartTrig = 43 ,
CIO_4_StartTrig = 44 , CIO_5_StartTrig = 45 , CIO_6_StartTrig = 46 , CIO_7_StartTrig = 47 ,
CO_0_OutPut = 48 , CO_1_OutPut = 49 , CO_2_OutPut = 50 , CO_3_OutPut = 51 ,
CO_4_OutPut = 52 , CO_5_OutPut = 53 , CO_6_OutPut = 54 , CO_7_OutPut = 55
}
CO Digital trigger source. More...
enum class | CODigitalTriggerEdge { Rising , Falling }
CO Digital Trigger Edge. More...
enum class | COPulseType { DutyCycleFrequency , HighLowTime , HighLowTick }
Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick. More...
enum class | COTimebaseSource { Internal100MHz = 0 , Internal5MHz = 1 , Internal100kHz = 2 , External = 3 }
Timebase source. More...
enum class | COSignalExportSource { StartTrig , Output }
SourceSignal. More...
enum class | ExternalReferenceClockTerminal { PXIe_Clk100 = 0x1 }
enum class | ReferenceClockSource { Internal = 0x0 , External = 0x1 }
enum class PFITerminal {
PFI0 = 0 , PFI1 = 1 , PFI2 = 2 , PFI3 = 3 ,
PFI4 = 4 , PFI5 = 5 , PFI6 = 6 , PFI7 = 7 ,
PFI8 = 8 , PFI9 = 9 , PFI10 = 10 , PFI11 = 11 ,
PFI12 = 12 , PFI13 = 13 , PFI14 = 14 , PFI15 = 15
}
Input/Output Terminal of PFI. More...
enum class | DOLineMode { Sourcing = 0 , Sinking = 1 , Push_Pull = 2 }
enum class JY7131CoreOOLogLevel {
DEBUG_LOG_LEVEL , INFO_LOG_LEVEL , WARN_LOG_LEVEL , ERROR_LOG_LEVEL ,
FATAL_LOG_LEVEL
}

Functions

std::string GetSignalExportDestinationString (SignalExportDestination destination)

Enumeration Type Documentation

◆ CIDigitalTriggerEdge

enum class JY7131CoreOO::CIDigitalTriggerEdge
strong

CI Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ CIDigitalTriggerSource

enum class JY7131CoreOO::CIDigitalTriggerSource
strong

CI Digital trigger source.

Enumerator
PFI_In_0 | PFI_In_0.
PFI_In_1 | PFI_In_1.
PFI_In_2 | PFI_In_2.
PFI_In_3 | PFI_In_3.
PFI_In_4 | PFI_In_4.
PFI_In_5 | PFI_In_5.
PFI_In_6 | PFI_In_6.
PFI_In_7 | PFI_In_7.
PFI_In_8 | PFI_In_8.
PFI_In_9 | PFI_In_9.
PFI_In_10 | PFI_In_10.
PFI_In_11 | PFI_In_11.
PFI_In_12 | PFI_In_12.
PFI_In_13 | PFI_In_13.
PFI_In_14 | PFI_In_14.
PFI_In_15 | PFI_In_15.
PFI_In_16 | PFI_In_16.
PFI_In_17 | PFI_In_17.
PFI_In_18 | PFI_In_18.
PFI_In_19 | PFI_In_19.
PFI_In_20 | PFI_In_20.
PFI_In_21 | PFI_In_21.
PFI_In_22 | PFI_In_22.
PFI_In_23 | PFI_In_23.
PFI_In_24 | PFI_In_24.
PFI_In_25 | PFI_In_25.
PFI_In_26 | PFI_In_26.
PFI_In_27 | PFI_In_27.
PFI_In_28 | PFI_In_28.
PFI_In_29 | PFI_In_29.
PFI_In_30 | PFI_In_30.
PFI_In_31 | PFI_In_31.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
CIO_0_StartTrig | CIO0_StartTrig.
CIO_1_StartTrig | CI1_StartTrig.
CIO_2_StartTrig | CIO2_StartTrig.
CIO_3_StartTrig | CI3_StartTrig.
CIO_4_StartTrig | CIO4_StartTrig.
CIO_5_StartTrig | CI5_StartTrig.
CIO_6_StartTrig | CIO6_StartTrig.
CIO_7_StartTrig | CI7_StartTrig.
CO_0_OutPut | CO_0_OutPut.
CO_1_OutPut | CO_1_OutPut.
CO_2_OutPut | CO_2_OutPut.
CO_3_OutPut | CO_3_OutPut.
CO_4_OutPut | CO_4_OutPut.
CO_5_OutPut | CO_5_OutPut.
CO_6_OutPut | CO_6_OutPut.
CO_7_OutPut | CO_7_OutPut.

◆ CIMeasureType

enum class JY7131CoreOO::CIMeasureType
strong

Timebase source.

Enumerator
JY7131_CI_EdgeCount
JY7131_CI_Measure_FrequencyOrPeriod
JY7131_CI_Measure_PulseWidth
JY7131_CI_Measure_SemiPeriod
JY7131_CI_Measure_EdgeSeparation
JY7131_CI_EncoderX1
JY7131_CI_EncoderX2
JY7131_CI_EncoderX4
JY7131_CI_EncoderTwoPulse

◆ CIMode

enum class JY7131CoreOO::CIMode
strong
Enumerator
Single | Single.
Finite | Finite.
Continuous | Continuous.

◆ CISampleClockSource

enum class JY7131CoreOO::CISampleClockSource
strong

CI Sample Clock Source.

Enumerator
Implicit | Implicit.
Internal | Internal.
External | External.

◆ CISignalExportSource

enum class JY7131CoreOO::CISignalExportSource
strong

SourceSignal.

Enumerator
StartTrig | CI_StartTrig.
SampleClock | CI_SampleClock.

◆ CITimebaseSource

enum class JY7131CoreOO::CITimebaseSource
strong

Timebase source.

Enumerator
Internal100MHz | 鍐呴儴100MHz鏃跺熀 Internal 100MHz Timebase
Internal5MHz | 鍐呴儴5MHz鏃跺熀 Internal 5MHz Timebase
Internal100kHz | 鍐呴儴100kHz鏃跺熀 Internal 100kHz Timebase

◆ CITriggerType

enum class JY7131CoreOO::CITriggerType
strong

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ CIType

enum class JY7131CoreOO::CIType
strong

Counter Input Application Type.

Enumerator
EdgeCounting | Edge Counting.
Period | Period Measure.
Frequency | Frequenc Measure.
SemiPeriod | SemiPeriod Measure.
TwoEdgeSeparation | TwoEdgeSeparation Measure.
QuadEncoder | QuadEncoder.
TwoPulseEncoder | EncoderTwoPulse.

◆ ClockTerminal

enum class JY7131CoreOO::ClockTerminal
strong
Enumerator
PFI0 | PFI0.
PFI_In_1 | PFI_In_1.
PFI_In_2 | PFI_In_2.
PFI_In_3 | PFI_In_3.
PFI_In_4 | PFI_In_4.
PFI_In_5 | PFI_In_5.
PFI_In_6 | PFI_In_6.
PFI_In_7 | PFI_In_7.
PFI_In_8 | PFI_In_8.
PFI_In_9 | PFI_In_9.
PFI_In_10 | PFI_In_10.
PFI_In_11 | PFI_In_11.
PFI_In_12 | PFI_In_12.
PFI_In_13 | PFI_In_13.
PFI_In_14 | PFI_In_14.
PFI_In_15 | PFI_In_15.
PFI_In_16 | PFI_In_16.
PFI_In_17 | PFI_In_17.
PFI_In_18 | PFI_In_18.
PFI_In_19 | PFI_In_19.
PFI_In_20 | PFI_In_20.
PFI_In_21 | PFI_In_21.
PFI_In_22 | PFI_In_6.
PFI_In_23 | PFI_In_23.
PFI_In_24 | PFI_In_24.
PFI_In_25 | PFI_In_25.
PFI_In_26 | PFI_In_26.
PFI_In_27 | PFI_In_27.
PFI_In_28 | PFI_In_28.
PFI_In_29 | PFI_In_29.
PFI_In_30 | PFI_In_30.
PFI_In_31 | PFI_In_31.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
CI0_SampleClock | CI0_SampleClock.
CI1_SampleClock | CI1_SampleClock.
CI2_SampleClock | CI2_SampleClock.
CI3_SampleClock | CI3_SampleClock.
CI4_SampleClock | CI4_SampleClock.
CI5_SampleClock | CI5_SampleClock.
CI6_SampleClock | CI6_SampleClock.
CI7_SampleClock | CI7_SampleClock.
CO0_Output | CO0_Output.
CO1_Output | CO1_Output.
CO2_Output | CO0_Output.
CO3_Output | CO1_Output.
CO4_Output | CO0_Output.
CO5_Output | CO1_Output.
CO6_Output | CO0_Output.
CO7_Output | CO1_Output.

◆ CODigitalTriggerEdge

enum class JY7131CoreOO::CODigitalTriggerEdge
strong

CO Digital Trigger Edge.

Enumerator
Rising | Rising Edge.
Falling | Falling Edge.

◆ CODigitalTriggerSource

enum class JY7131CoreOO::CODigitalTriggerSource
strong

CO Digital trigger source.

Enumerator
PFI_In_0 | PFI_In_0.
PFI_In_1 | PFI_In_1.
PFI_In_2 | PFI_In_2.
PFI_In_3 | PFI_In_3.
PFI_In_4 | PFI_In_4.
PFI_In_5 | PFI_In_5.
PFI_In_6 | PFI_In_6.
PFI_In_7 | PFI_In_7.
PFI_In_8 | PFI_In_8.
PFI_In_9 | PFI_In_9.
PFI_In_10 | PFI_In_10.
PFI_In_11 | PFI_In_11.
PFI_In_12 | PFI_In_12.
PFI_In_13 | PFI_In_13.
PFI_In_14 | PFI_In_14.
PFI_In_15 | PFI_In_15.
PFI_In_16 | PFI_In_16.
PFI_In_17 | PFI_In_17.
PFI_In_18 | PFI_In_18.
PFI_In_19 | PFI_In_19.
PFI_In_20 | PFI_In_20.
PFI_In_21 | PFI_In_21.
PFI_In_22 | PFI_In_22.
PFI_In_23 | PFI_In_23.
PFI_In_24 | PFI_In_24.
PFI_In_25 | PFI_In_25.
PFI_In_26 | PFI_In_26.
PFI_In_27 | PFI_In_27.
PFI_In_28 | PFI_In_28.
PFI_In_29 | PFI_In_29.
PFI_In_30 | PFI_In_30.
PFI_In_31 | PFI_In_31.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
CIO_0_StartTrig | CIO0_StartTrig.
CIO_1_StartTrig | CI1_StartTrig.
CIO_2_StartTrig | CIO2_StartTrig.
CIO_3_StartTrig | CI3_StartTrig.
CIO_4_StartTrig | CIO4_StartTrig.
CIO_5_StartTrig | CI5_StartTrig.
CIO_6_StartTrig | CIO6_StartTrig.
CIO_7_StartTrig | CI7_StartTrig.
CO_0_OutPut | CO_0_OutPut.
CO_1_OutPut | CO_1_OutPut.
CO_2_OutPut | CO_2_OutPut.
CO_3_OutPut | CO_3_OutPut.
CO_4_OutPut | CO_4_OutPut.
CO_5_OutPut | CO_5_OutPut.
CO_6_OutPut | CO_6_OutPut.
CO_7_OutPut | CO_7_OutPut.

◆ COIdleState

enum class JY7131CoreOO::COIdleState
strong

Idle state when pulse output before start and after stop.

Enumerator
HighLevel | Idle state is high level.
LowLevel | Idle state is low level.

◆ COMode

enum class JY7131CoreOO::COMode
strong
Enumerator
Single | Single pulse output.
Finite | Finite.
ContinuousNoWrapping | ContinuousNoWrapping.
ContinuousWrapping | ContinuousWrapping.

◆ COPulseType

enum class JY7131CoreOO::COPulseType
strong

Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick.

Enumerator
DutyCycleFrequency | Configure CO output pulse according to its DutyCycle and Freqency.
HighLowTime | Configure CO output pulse according to duration of its high/low voltage levels.
HighLowTick | Configure CO output pulse according to its high/low tick level.

◆ COSignalExportSource

enum class JY7131CoreOO::COSignalExportSource
strong

SourceSignal.

Enumerator
StartTrig | CI_StartTrig.
Output | CO_Output.

◆ COTimebaseSource

enum class JY7131CoreOO::COTimebaseSource
strong

Timebase source.

Enumerator
Internal100MHz | 内部100MHz时基 Internal 100MHz Timebase
Internal5MHz | 内部5MHz时基 Internal 5MHz Timebase
Internal100kHz | 内部100kHz时基 Internal 100kHz Timebase
External | 外部时基 External Timebase

◆ COTriggerType

enum class JY7131CoreOO::COTriggerType
strong

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ CountDirection

enum class JY7131CoreOO::CountDirection
strong

Counter direction.

enum Up/Down/External

Enumerator
Up | Counter increases.
Down | Counter decreases.
External | External signal control counter direction. If External signal is highlevel counter increases, or lowlevel counter decreases.

◆ DOLineMode

enum class JY7131CoreOO::DOLineMode
strong
Enumerator
Sourcing | Sourcing Mode.
Sinking | Sinking Mode.
Push_Pull | Push_Pull Mode.

◆ EdgeCntOunEvtIdleState

enum class JY7131CoreOO::EdgeCntOunEvtIdleState
strong

Output idle state when the event has not occurred.

Enumerator
LowLevel | Idle state is low level.
HighLevel | Idle state is high level.

◆ EdgeType

enum class JY7131CoreOO::EdgeType
strong

Edge Type.

Enumerator
Rising | Rising Edge.
Falling | Falling Edge.
Any | Any Edge.

◆ ExternalReferenceClockTerminal

enum class JY7131CoreOO::ExternalReferenceClockTerminal
strong
Enumerator
PXIe_Clk100

PXIe_Clk100.

◆ InputTerminal

enum class JY7131CoreOO::InputTerminal
strong

Cunter Input Terminal.

Enumerator
PFI_In_0 | PFI_In_0.
PFI_In_1 | PFI_In_1.
PFI_In_2 | PFI_In_2.
PFI_In_3 | PFI_In_3.
PFI_In_4 | PFI_In_4.
PFI_In_5 | PFI_In_5.
PFI_In_6 | PFI_In_6.
PFI_In_7 | PFI_In_7.
PFI_In_8 | PFI_In_8.
PFI_In_9 | PFI_In_9.
PFI_In_10 | PFI_In_10.
PFI_In_11 | PFI_In_11.
PFI_In_12 | PFI_In_12.
PFI_In_13 | PFI_In_13.
PFI_In_14 | PFI_In_14.
PFI_In_15 | PFI_In_15.
PFI_In_16 | PFI_In_16.
PFI_In_17 | PFI_In_17.
PFI_In_18 | PFI_In_18.
PFI_In_19 | PFI_In_19.
PFI_In_20 | PFI_In_20.
PFI_In_21 | PFI_In_21.
PFI_In_22 | PFI_In_22.
PFI_In_23 | PFI_In_23.
PFI_In_24 | PFI_In_24.
PFI_In_25 | PFI_In_25.
PFI_In_26 | PFI_In_26.
PFI_In_27 | PFI_In_27.
PFI_In_28 | PFI_In_28.
PFI_In_29 | PFI_In_29.
PFI_In_30 | PFI_In_30.
PFI_In_31 | PFI_In_31.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
CI_0_OutPut | CI_0_OutPut.
CI_1_OutPut | CI_1_OutPut.
CI_2_OutPut | CI_2_OutPut.
CI_3_OutPut | CI_3_OutPut.
CI_4_OutPut | CI_4_OutPut.
CI_5_OutPut | CI_5_OutPut.
CI_6_OutPut | CI_6_OutPut.
CI_7_OutPut | CI_7_OutPut.
Timebase_100MHz | Timebase_100MHz.
Timebase_5MHz | Timebase_5MHz.
Timebase_100kHz | Timebase_100kHz.

◆ IOTerminal

enum class JY7131CoreOO::IOTerminal
strong
Enumerator
None | None.
PFI_Out_0 | PFI_Out_0.
PFI_Out_1 | PFI_Out_1.
PFI_Out_2 | PFI_Out_2.
PFI_Out_3 | PFI_Out_3.
PFI_Out_4 | PFI_Out_4.
PFI_Out_5 | PFI_Out_5.
PFI_Out_6 | PFI_Out_6.
PFI_Out_7 | PFI_Out_7.
PFI_Out_8 | PFI_Out_8.
PFI_Out_9 | PFI_Out_9.
PFI_Out_10 | PFI_Out_10.
PFI_Out_11 | PFI_Out_11.
PFI_Out_12 | PFI_Out_12.
PFI_Out_13 | PFI_Out_13.
PFI_Out_14 | PFI_Out_14.
PFI_Out_15 | PFI_Out_15.
PFI_Out_16 | PFI_Out_16.
PFI_Out_17 | PFI_Out_17.
PFI_Out_18 | PFI_Out_18.
PFI_Out_19 | PFI_Out_19.
PFI_Out_20 | PFI_Out_20.
PFI_Out_21 | PFI_Out_21.
PFI_Out_22 | PFI_Out_22.
PFI_Out_23 | PFI_Out_23.
PFI_Out_24 | PFI_Out_24.
PFI_Out_25 | PFI_Out_25.
PFI_Out_26 | PFI_Out_26.
PFI_Out_27 | PFI_Out_27.
PFI_Out_28 | PFI_Out_28.
PFI_Out_29 | PFI_Out_29.
PFI_Out_30 | PFI_Out_30.
PFI_Out_31 | PFI_Out_31.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.

◆ JY7131CoreOOLogLevel

enum class JY7131CoreOO::JY7131CoreOOLogLevel
strong
Enumerator
DEBUG_LOG_LEVEL
INFO_LOG_LEVEL
WARN_LOG_LEVEL
ERROR_LOG_LEVEL
FATAL_LOG_LEVEL

◆ JY7131CoreOOPropertyType

enum class JY7131CoreOO::JY7131CoreOOPropertyType
strong
Enumerator
READ_ONLY
WRITE_ONLY
READ_WRITE

◆ JYDriverExceptionPublic

enum class JY7131CoreOO::JYDriverExceptionPublic
strong
Enumerator
UnKnown | JYDriverExceptionPublic.
OpenDeviceFailed | JYDriverExceptionPublic.
CloseDeviceFailed | JYDriverExceptionPublic.
ResetDeviceFailed | JYDriverExceptionPublic.
GetDevicePropertyFailed | JYDriverExceptionPublic.
SetDevicePropertyFailed | JYDriverExceptionPublic.
HardwareResourceIsReserved | JYDriverExceptionPublic.
MethodNotPermitedToCallWhenCurrentStatus | JYDriverExceptionPublic.
InvalidUserDataBuffer | JYDriverExceptionPublic.
NoChannelAdded | JYDriverExceptionPublic.
NotSupportOperationForCurrentDevice | JYDriverExceptionPublic.
CreatTaskFailed | JYDriverExceptionPublic.
StartTaskFailed | JYDriverExceptionPublic.
StopTaskFailed | JYDriverExceptionPublic.
TaskHasNotStarted | JYDriverExceptionPublic.
TaskHasStartedCannotPerformTheSetOperation | JYDriverExceptionPublic.
ChannelNumberParameterInvalid | JYDriverExceptionPublic.
ChannelInputRangeParameterInvalid | JYDriverExceptionPublic.
ChannelTerminalParameterInvalid | JYDriverExceptionPublic.
ChannelCouplingParameterInvalid | JYDriverExceptionPublic.
SampeleModeParameterInvalid | JYDriverExceptionPublic.
SampleClockParameterInvalid | JYDriverExceptionPublic.
SampleRateParameterInvalid | JYDriverExceptionPublic.
UpdateRateParameterInvalid | JYDriverExceptionPublic.
TriggerParameterInvalid | JYDriverExceptionPublic.
ReferenceTriggerDoesNotMatchWithSampleMode | JYDriverExceptionPublic.
PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint | JYDriverExceptionPublic.
ReadDataFailed | JYDriverExceptionPublic.
ReadDataTimeout | JYDriverExceptionPublic.
WriteDataFailed | JYDriverExceptionPublic.
WriteDataTimeout | JYDriverExceptionPublic.
WriteDataLengthCannotBeLessThanN | JYDriverExceptionPublic.
BufferDataOverflow | JYDriverExceptionPublic.
BufferDataDownflow | JYDriverExceptionPublic.
CheckBufferFailed | JYDriverExceptionPublic.
PointInvalidInFiniteMode | JYDriverExceptionPublic.
ReadPointInvalid | JYDriverExceptionPublic.
OnlySupportRecordMode | JYDriverExceptionPublic.
SendSoftTirggerFailed | JYDriverExceptionPublic.
TaskTimeout | JYDriverExceptionPublic.
CounterParametersInvalid | JYDriverExceptionPublic.
WritePointInvalid | JYDriverExceptionPublic.
SignalExportDestinationInvalid | JYDriverExceptionPublic.
InvalidParameter | 无效参数。 Invalid parameter.

◆ LevelPolarity

enum class JY7131CoreOO::LevelPolarity
strong

Level Polarity.

Enumerator
LowLevel | Low level.
HighLevel | High level.
None | No active polarity.

◆ OutputCompleteState

enum class JY7131CoreOO::OutputCompleteState
strong

Output Complete State.

Enumerator
Zero | Output Complete Zero.
Hold | Output Complete Hold in The last point.

◆ OutputState

enum class JY7131CoreOO::OutputState
strong

CO output state when pause trigger valid.

Enumerator
HoldOn | output hold on
HighLevel | output HighLevel
LowLevel | output LowLevel

◆ PFITerminal

enum class JY7131CoreOO::PFITerminal
strong

Input/Output Terminal of PFI.

Enumerator
PFI0 | PFI 0.
PFI1 | PFI 1.
PFI2 | PFI 2.
PFI3 | PFI 3.
PFI4 | PFI 4.
PFI5 | PFI 5.
PFI6 | PFI 6.
PFI7 | PFI 7.
PFI8 | PFI 8.
PFI9 | PFI 9.
PFI10 | PFI 10.
PFI11 | PFI 11.
PFI12 | PFI 12.
PFI13 | PFI 13.
PFI14 | PFI 14.
PFI15 | PFI 15.

◆ QuadEncodingType

enum class JY7131CoreOO::QuadEncodingType
strong

Quadrature Encoding Type.

Enumerator
X1 | X1.
X2 | X2.
X4 | X4.

◆ ReferenceClockSource

enum class JY7131CoreOO::ReferenceClockSource
strong
Enumerator
Internal | Internal on board 25MHz Clock.
External | External Reference Clock Source.

◆ SignalExportDestination

enum class JY7131CoreOO::SignalExportDestination
strong
Enumerator
PFI0 | PFI0.
PFI_In_1 | PFI_In_1.
PFI_In_2 | PFI_In_2.
PFI_In_3 | PFI_In_3.
PFI_In_4 | PFI_In_4.
PFI_In_5 | PFI_In_5.
PFI_In_6 | PFI_In_6.
PFI_In_7 | PFI_In_7.
PFI_In_8 | PFI_In_8.
PFI_In_9 | PFI_In_9.
PFI_In_10 | PFI_In_10.
PFI_In_11 | PFI_In_11.
PFI_In_12 | PFI_In_12.
PFI_In_13 | PFI_In_13.
PFI_In_14 | PFI_In_14.
PFI_In_15 | PFI_In_15.
PFI_In_16 | PFI_In_16.
PFI_In_17 | PFI_In_17.
PFI_In_18 | PFI_In_18.
PFI_In_19 | PFI_In_19.
PFI_In_20 | PFI_In_20.
PFI_In_21 | PFI_In_21.
PFI_In_22 | PFI_In_22.
PFI_In_23 | PFI_In_23.
PFI_In_24 | PFI_In_24.
PFI_In_25 | PFI_In_25.
PFI_In_26 | PFI_In_26.
PFI_In_27 | PFI_In_27.
PFI_In_28 | PFI_In_28.
PFI_In_29 | PFI_In_29.
PFI_In_30 | PFI_In_30.
PFI_In_31 | PFI_In_31.
PXI_Trig0 | PXI Trig0.
PXI_Trig1 | PXI Trig1.
PXI_Trig2 | PXI Trig2.
PXI_Trig3 | PXI Trig3.
PXI_Trig4 | PXI Trig4.
PXI_Trig5 | PXI Trig5.
PXI_Trig6 | PXI Trig6.
PXI_Trig7 | PXI Trig7.

◆ ValueReturnMode

enum class JY7131CoreOO::ValueReturnMode
strong
Enumerator
TwoValue | Return two data simultaneously. first data is gate to aux edge separation, second data is aux to gate edge separation.
OneValue | only return gate to aux edge separation

Function Documentation

◆ GetSignalExportDestinationString()

std::string JY7131CoreOO::GetSignalExportDestinationString ( SignalExportDestination destination )
inline


7131 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOOCommon.h File Reference

  • File List
  • File Members
  • COO
  • 7131
Classes | Namespaces | Macros | Enumerations | Functions
JY7131CoreOOCommon.h File Reference
#include <string>
#include <stdint.h>

Classes

class | JY7131CoreOO::JYDriverException
class | JY7131CoreOO::JY7131CoreOOProperty< ContainerClass, ValueType, propertyType >
属性模板类 More...
class | JY7131CoreOO::PauseTrigger
Pause trigger configuration class. More...

Namespaces

namespace JY7131CoreOO

Macros

#define | EXTERN_C extern
Windows.
#define | JY7131CoreOO_API

Enumerations

enum class | JY7131CoreOO::OutputState { JY7131CoreOO::HoldOn = 0 , JY7131CoreOO::HighLevel = 1 , JY7131CoreOO::LowLevel = 2 }
CO output state when pause trigger valid. More...
enum class | JY7131CoreOO::JY7131CoreOOPropertyType { JY7131CoreOO::READ_ONLY = 1 , JY7131CoreOO::WRITE_ONLY = 2 , JY7131CoreOO::READ_WRITE = 3 }
enum class JY7131CoreOO::JYDriverExceptionPublic {
JY7131CoreOO::UnKnown = 0 , JY7131CoreOO::OpenDeviceFailed = -10001 , JY7131CoreOO::CloseDeviceFailed = -10002 , JY7131CoreOO::ResetDeviceFailed = -10003 ,
JY7131CoreOO::GetDevicePropertyFailed = -10004 , JY7131CoreOO::SetDevicePropertyFailed = -10005 , JY7131CoreOO::HardwareResourceIsReserved = -10006 , JY7131CoreOO::MethodNotPermitedToCallWhenCurrentStatus = -10007 ,
JY7131CoreOO::InvalidUserDataBuffer = -10008 , JY7131CoreOO::NoChannelAdded = -10009 , JY7131CoreOO::NotSupportOperationForCurrentDevice = -10010 , JY7131CoreOO::CreatTaskFailed = -10100 ,
JY7131CoreOO::StartTaskFailed = -10101 , JY7131CoreOO::StopTaskFailed = -10102 , JY7131CoreOO::TaskHasNotStarted = -10103 , JY7131CoreOO::TaskHasStartedCannotPerformTheSetOperation = -10104 ,
JY7131CoreOO::ChannelNumberParameterInvalid = -10105 , JY7131CoreOO::ChannelInputRangeParameterInvalid = -10106 , JY7131CoreOO::ChannelTerminalParameterInvalid = -10107 , JY7131CoreOO::ChannelCouplingParameterInvalid = -10108 ,
JY7131CoreOO::SampeleModeParameterInvalid = -10109 , JY7131CoreOO::SampleClockParameterInvalid = -10110 , JY7131CoreOO::SampleRateParameterInvalid = -10111 , JY7131CoreOO::UpdateRateParameterInvalid = -10112 ,
JY7131CoreOO::TriggerParameterInvalid = -10113 , JY7131CoreOO::ReferenceTriggerDoesNotMatchWithSampleMode = -10114 , JY7131CoreOO::PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint = -10115 , JY7131CoreOO::ReadDataFailed = -10016 ,
JY7131CoreOO::ReadDataTimeout = -10017 , JY7131CoreOO::WriteDataFailed = -10018 , JY7131CoreOO::WriteDataTimeout = -10019 , JY7131CoreOO::WriteDataLengthCannotBeLessThanN = -10020 ,
JY7131CoreOO::BufferDataOverflow = -10021 , JY7131CoreOO::BufferDataDownflow = -10022 , JY7131CoreOO::CheckBufferFailed = -10023 , JY7131CoreOO::PointInvalidInFiniteMode = -10024 ,
JY7131CoreOO::ReadPointInvalid = -10025 , JY7131CoreOO::OnlySupportRecordMode = -10026 , JY7131CoreOO::SendSoftTirggerFailed = -10027 , JY7131CoreOO::TaskTimeout = -10028 ,
JY7131CoreOO::CounterParametersInvalid = -10029 , JY7131CoreOO::WritePointInvalid = -10030 , JY7131CoreOO::SignalExportDestinationInvalid = -10031 , JY7131CoreOO::InvalidParameter = -10033
}
enum class JY7131CoreOO::ClockTerminal {
JY7131CoreOO::PFI0 = 0 , JY7131CoreOO::PFI_In_1 =1 , JY7131CoreOO::PFI_In_2 = 2 , JY7131CoreOO::PFI_In_3 = 3 ,
JY7131CoreOO::PFI_In_4 = 4 , JY7131CoreOO::PFI_In_5 = 5 , JY7131CoreOO::PFI_In_6 = 6 , JY7131CoreOO::PFI_In_7 = 7 ,
JY7131CoreOO::PFI_In_8 = 8 , JY7131CoreOO::PFI_In_9 = 9 , JY7131CoreOO::PFI_In_10 = 10 , JY7131CoreOO::PFI_In_11 = 11 ,
JY7131CoreOO::PFI_In_12 = 12 , JY7131CoreOO::PFI_In_13 = 13 , JY7131CoreOO::PFI_In_14 = 14 , JY7131CoreOO::PFI_In_15 =15 ,
JY7131CoreOO::PFI_In_16 = 16 , JY7131CoreOO::PFI_In_17 =17 , JY7131CoreOO::PFI_In_18 =18 , JY7131CoreOO::PFI_In_19 = 19 ,
JY7131CoreOO::PFI_In_20 = 20 , JY7131CoreOO::PFI_In_21 = 21 , JY7131CoreOO::PFI_In_22 = 22 , JY7131CoreOO::PFI_In_23 = 23 ,
JY7131CoreOO::PFI_In_24 = 24 , JY7131CoreOO::PFI_In_25 = 25 , JY7131CoreOO::PFI_In_26 = 26 , JY7131CoreOO::PFI_In_27 = 27 ,
JY7131CoreOO::PFI_In_28 = 28 , JY7131CoreOO::PFI_In_29 = 29 , JY7131CoreOO::PFI_In_30 = 30 , JY7131CoreOO::PFI_In_31 = 31 ,
JY7131CoreOO::PXI_Trig0 = 32 , JY7131CoreOO::PXI_Trig1 =33 , JY7131CoreOO::PXI_Trig2 = 34 , JY7131CoreOO::PXI_Trig3 = 35 ,
JY7131CoreOO::PXI_Trig4 = 36 , JY7131CoreOO::PXI_Trig5 = 37 , JY7131CoreOO::PXI_Trig6 = 38 , JY7131CoreOO::PXI_Trig7 = 39 ,
JY7131CoreOO::CI0_SampleClock = 40 , JY7131CoreOO::CI1_SampleClock = 41 , JY7131CoreOO::CI2_SampleClock = 42 , JY7131CoreOO::CI3_SampleClock = 43 ,
JY7131CoreOO::CI4_SampleClock = 44 , JY7131CoreOO::CI5_SampleClock = 45 , JY7131CoreOO::CI6_SampleClock = 46 , JY7131CoreOO::CI7_SampleClock = 47 ,
JY7131CoreOO::CO0_Output = 48 , JY7131CoreOO::CO1_Output = 49 , JY7131CoreOO::CO2_Output = 50 , JY7131CoreOO::CO3_Output = 51 ,
JY7131CoreOO::CO4_Output = 52 , JY7131CoreOO::CO5_Output = 53 , JY7131CoreOO::CO6_Output = 54 , JY7131CoreOO::CO7_Output = 55
}
enum class JY7131CoreOO::SignalExportDestination {
JY7131CoreOO::PFI0 = 0 , JY7131CoreOO::PFI_In_1 = 1 , JY7131CoreOO::PFI_In_2 = 2 , JY7131CoreOO::PFI_In_3 = 3 ,
JY7131CoreOO::PFI_In_4 = 4 , JY7131CoreOO::PFI_In_5 = 5 , JY7131CoreOO::PFI_In_6 = 6 , JY7131CoreOO::PFI_In_7 = 7 ,
JY7131CoreOO::PFI_In_8 = 8 , JY7131CoreOO::PFI_In_9 = 9 , JY7131CoreOO::PFI_In_10 = 10 , JY7131CoreOO::PFI_In_11 = 11 ,
JY7131CoreOO::PFI_In_12 = 12 , JY7131CoreOO::PFI_In_13 = 13 , JY7131CoreOO::PFI_In_14 = 14 , JY7131CoreOO::PFI_In_15 = 15 ,
JY7131CoreOO::PFI_In_16 = 16 , JY7131CoreOO::PFI_In_17 = 17 , JY7131CoreOO::PFI_In_18 = 18 , JY7131CoreOO::PFI_In_19 = 19 ,
JY7131CoreOO::PFI_In_20 = 20 , JY7131CoreOO::PFI_In_21 = 21 , JY7131CoreOO::PFI_In_22 = 22 , JY7131CoreOO::PFI_In_23 = 23 ,
JY7131CoreOO::PFI_In_24 = 24 , JY7131CoreOO::PFI_In_25 = 25 , JY7131CoreOO::PFI_In_26 = 26 , JY7131CoreOO::PFI_In_27 = 27 ,
JY7131CoreOO::PFI_In_28 = 28 , JY7131CoreOO::PFI_In_29 = 29 , JY7131CoreOO::PFI_In_30 = 30 , JY7131CoreOO::PFI_In_31 = 31 ,
JY7131CoreOO::PXI_Trig0 = 32 , JY7131CoreOO::PXI_Trig1 = 33 , JY7131CoreOO::PXI_Trig2 = 34 , JY7131CoreOO::PXI_Trig3 = 35 ,
JY7131CoreOO::PXI_Trig4 = 36 , JY7131CoreOO::PXI_Trig5 = 37 , JY7131CoreOO::PXI_Trig6 = 38 , JY7131CoreOO::PXI_Trig7 = 39
}
enum class | JY7131CoreOO::OutputCompleteState { JY7131CoreOO::Zero , JY7131CoreOO::Hold }
Output Complete State. More...
enum class JY7131CoreOO::IOTerminal {
JY7131CoreOO::None = 40 , JY7131CoreOO::PFI_Out_0 = 0 , JY7131CoreOO::PFI_Out_1 = 1 , JY7131CoreOO::PFI_Out_2 = 2 ,
JY7131CoreOO::PFI_Out_3 = 3 , JY7131CoreOO::PFI_Out_4 = 4 , JY7131CoreOO::PFI_Out_5 = 5 , JY7131CoreOO::PFI_Out_6 = 6 ,
JY7131CoreOO::PFI_Out_7 = 7 , JY7131CoreOO::PFI_Out_8 = 8 , JY7131CoreOO::PFI_Out_9 = 9 , JY7131CoreOO::PFI_Out_10 = 10 ,
JY7131CoreOO::PFI_Out_11 = 11 , JY7131CoreOO::PFI_Out_12 = 12 , JY7131CoreOO::PFI_Out_13 = 13 , JY7131CoreOO::PFI_Out_14 = 14 ,
JY7131CoreOO::PFI_Out_15 = 15 , JY7131CoreOO::PFI_Out_16 = 16 , JY7131CoreOO::PFI_Out_17 = 17 , JY7131CoreOO::PFI_Out_18 = 18 ,
JY7131CoreOO::PFI_Out_19 = 19 , JY7131CoreOO::PFI_Out_20 = 20 , JY7131CoreOO::PFI_Out_21 = 21 , JY7131CoreOO::PFI_Out_22 = 22 ,
JY7131CoreOO::PFI_Out_23 = 23 , JY7131CoreOO::PFI_Out_24 = 24 , JY7131CoreOO::PFI_Out_25 = 25 , JY7131CoreOO::PFI_Out_26 = 26 ,
JY7131CoreOO::PFI_Out_27 = 27 , JY7131CoreOO::PFI_Out_28 = 28 , JY7131CoreOO::PFI_Out_29 = 29 , JY7131CoreOO::PFI_Out_30 = 30 ,
JY7131CoreOO::PFI_Out_31 = 31 , JY7131CoreOO::PXI_Trig0 = 32 , JY7131CoreOO::PXI_Trig1 = 33 , JY7131CoreOO::PXI_Trig2 = 34 ,
JY7131CoreOO::PXI_Trig3 = 35 , JY7131CoreOO::PXI_Trig4 = 36 , JY7131CoreOO::PXI_Trig5 = 37 , JY7131CoreOO::PXI_Trig6 = 38 ,
JY7131CoreOO::PXI_Trig7 = 39
}
enum class | JY7131CoreOO::LevelPolarity { JY7131CoreOO::LowLevel = 0 , JY7131CoreOO::HighLevel = 1 , JY7131CoreOO::None = 2 }
Level Polarity. More...
enum class JY7131CoreOO::InputTerminal {
JY7131CoreOO::PFI_In_0 = 0 , JY7131CoreOO::PFI_In_1 = 1 , JY7131CoreOO::PFI_In_2 = 2 , JY7131CoreOO::PFI_In_3 = 3 ,
JY7131CoreOO::PFI_In_4 = 4 , JY7131CoreOO::PFI_In_5 = 5 , JY7131CoreOO::PFI_In_6 = 6 , JY7131CoreOO::PFI_In_7 = 7 ,
JY7131CoreOO::PFI_In_8 = 8 , JY7131CoreOO::PFI_In_9 = 9 , JY7131CoreOO::PFI_In_10 = 10 , JY7131CoreOO::PFI_In_11 = 11 ,
JY7131CoreOO::PFI_In_12 = 12 , JY7131CoreOO::PFI_In_13 = 13 , JY7131CoreOO::PFI_In_14 = 14 , JY7131CoreOO::PFI_In_15 = 15 ,
JY7131CoreOO::PFI_In_16 = 16 , JY7131CoreOO::PFI_In_17 = 17 , JY7131CoreOO::PFI_In_18 = 18 , JY7131CoreOO::PFI_In_19 = 19 ,
JY7131CoreOO::PFI_In_20 = 20 , JY7131CoreOO::PFI_In_21 = 21 , JY7131CoreOO::PFI_In_22 = 22 , JY7131CoreOO::PFI_In_23 = 23 ,
JY7131CoreOO::PFI_In_24 = 24 , JY7131CoreOO::PFI_In_25 = 25 , JY7131CoreOO::PFI_In_26 = 26 , JY7131CoreOO::PFI_In_27 = 27 ,
JY7131CoreOO::PFI_In_28 = 28 , JY7131CoreOO::PFI_In_29 = 29 , JY7131CoreOO::PFI_In_30 = 30 , JY7131CoreOO::PFI_In_31 = 31 ,
JY7131CoreOO::PXI_Trig0 = 32 , JY7131CoreOO::PXI_Trig1 = 33 , JY7131CoreOO::PXI_Trig2 = 34 , JY7131CoreOO::PXI_Trig3 = 35 ,
JY7131CoreOO::PXI_Trig4 = 36 , JY7131CoreOO::PXI_Trig5 = 37 , JY7131CoreOO::PXI_Trig6 = 38 , JY7131CoreOO::PXI_Trig7 = 39 ,
JY7131CoreOO::CI_0_OutPut = 40 , JY7131CoreOO::CI_1_OutPut = 41 , JY7131CoreOO::CI_2_OutPut = 42 , JY7131CoreOO::CI_3_OutPut = 43 ,
JY7131CoreOO::CI_4_OutPut = 44 , JY7131CoreOO::CI_5_OutPut = 45 , JY7131CoreOO::CI_6_OutPut = 46 , JY7131CoreOO::CI_7_OutPut = 47 ,
JY7131CoreOO::Timebase_100MHz = 48 , JY7131CoreOO::Timebase_5MHz = 49 , JY7131CoreOO::Timebase_100kHz = 50
}
Cunter Input Terminal. More...

Functions

std::string JY7131CoreOO::GetSignalExportDestinationString (SignalExportDestination destination)

Macro Definition Documentation

◆ EXTERN_C

#define EXTERN_C extern

Windows.

Linux

◆ JY7131CoreOO_API

#define JY7131CoreOO_API


7131 C++ Programming Manual: JY7131CoreOO::JYDriverException Class Reference

  • JYDriverException
Public Member Functions | Public Attributes | List of all members
JY7131CoreOO::JYDriverException Class Reference

#include <JY7131CoreOOCommon.h>

Public Member Functions

JYDriverException (JYDriverExceptionPublic exceptionCode, std::string msg="")
JYDriverException (int, std::string msg)

Public Attributes

std::string exceptionMessage
JYDriverExceptionPublic errorCode
JYDriverException * FollowingException

Constructor & Destructor Documentation

◆ JYDriverException() [1/2]

JY7131CoreOO::JYDriverException::JYDriverException | ( | JYDriverExceptionPublic | exceptionCode,
 |  | std::string | msg = "" )

◆ JYDriverException() [2/2]

JY7131CoreOO::JYDriverException::JYDriverException | ( | int | ,
 |  | std::string | msg )

Member Data Documentation

◆ errorCode

JYDriverExceptionPublic JY7131CoreOO::JYDriverException::errorCode

◆ exceptionMessage

std::string JY7131CoreOO::JYDriverException::exceptionMessage

◆ FollowingException

JYDriverException* JY7131CoreOO::JYDriverException::FollowingException
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOOCommon.h


7131 C++ Programming Manual: JY7131CoreOO::JY7131CoreOOProperty< ContainerClass, ValueType, propertyType > Class Template Reference

  • JY7131CoreOOProperty
Public Member Functions | List of all members
JY7131CoreOO::JY7131CoreOOProperty< ContainerClass, ValueType, propertyType > Class Template Reference

属性模板类 More...

#include <JY7131CoreOOCommon.h>

Public Member Functions

JY7131CoreOOProperty ()
JY7131CoreOOProperty (ContainerClass *cObject, ValueType(ContainerClass::*pGet)(), void(ContainerClass::*pSet)(ValueType value))
JY7131CoreOOProperty (ValueType(*pGet)(), void(*pSet)(ValueType value))
ValueType operator= (const ValueType &value)
operator ValueType ()

Detailed Description

template<typename ContainerClass, typename ValueType, JY7131CoreOOPropertyType propertyType>
class JY7131CoreOO::JY7131CoreOOProperty< ContainerClass, ValueType, propertyType >

属性模板类

Constructor & Destructor Documentation

◆ JY7131CoreOOProperty() [1/3]

template<typename ContainerClass, typename ValueType, JY7131CoreOOPropertyType propertyType>
JY7131CoreOO::JY7131CoreOOProperty< ContainerClass, ValueType, propertyType >::JY7131CoreOOProperty ( )

◆ JY7131CoreOOProperty() [2/3]

template<typename ContainerClass, typename ValueType, JY7131CoreOOPropertyType propertyType>
JY7131CoreOO::JY7131CoreOOProperty< ContainerClass, ValueType, propertyType >::JY7131CoreOOProperty | ( | ContainerClass * | cObject,
 |  | ValueType(ContainerClass::* | pGet )(),
 |  | void(ContainerClass::* | pSet )(ValueType value) )

◆ JY7131CoreOOProperty() [3/3]

template<typename ContainerClass, typename ValueType, JY7131CoreOOPropertyType propertyType>
JY7131CoreOO::JY7131CoreOOProperty< ContainerClass, ValueType, propertyType >::JY7131CoreOOProperty | ( | ValueType(* | pGet )(),
 |  | void(* | pSet )(ValueType value) )

Member Function Documentation

◆ operator ValueType()

template<typename ContainerClass, typename ValueType, JY7131CoreOOPropertyType propertyType>
JY7131CoreOO::JY7131CoreOOProperty< ContainerClass, ValueType, propertyType >::operator ValueType ( )

◆ operator=()

template<typename ContainerClass, typename ValueType, JY7131CoreOOPropertyType propertyType>
ValueType JY7131CoreOO::JY7131CoreOOProperty< ContainerClass, ValueType, propertyType >::operator= ( const ValueType & value )
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOOCommon.h


7131 C++ Programming Manual: JY7131CoreOO::PauseTrigger Class Reference

  • PauseTrigger
Public Attributes | List of all members
JY7131CoreOO::PauseTrigger Class Reference

Pause trigger configuration class. More...

#include <JY7131CoreOOCommon.h>

Public Attributes

LevelPolarity ActivePolarity
Pause trigger active polarity.
InputTerminal Terminal
Terminal.
OutputState Output_State

Detailed Description

Pause trigger configuration class.

Member Data Documentation

◆ ActivePolarity

LevelPolarity JY7131CoreOO::PauseTrigger::ActivePolarity

Pause trigger active polarity.

The default value is LevelPolarity.None, means the pause trigger is disabled.

◆ Output_State

OutputState JY7131CoreOO::PauseTrigger::Output_State

◆ Terminal

InputTerminal JY7131CoreOO::PauseTrigger::Terminal

Terminal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOOCommon.h


7131 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOOCOTask.h File Reference

  • File List
  • File Members
  • COO
  • 7131
Classes | Namespaces | Enumerations
JY7131CoreOOCOTask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JY7131CoreOOCommon.h"
#include "JY7131CoreOODevice.h"
#include "JY7131CoreOODOTask.h"

Classes

class | JY7131CoreOO::JY7131CoreOOCOTask
class | JY7131CoreOO::CODigitalTrigger
CO Digital trigger . More...
class | JY7131CoreOO::COTrigger
Constructor to create an COTrigger task object. More...
class | JY7131CoreOO::COPulse
Pulse Parameter. More...
class | JY7131CoreOO::COExternalTimebase
class | JY7131CoreOO::COTimebase
Timebase configuration class. More...
class | JY7131CoreOO::COSignalExport
CO Signal Export Class. More...

Namespaces

namespace JY7131CoreOO

Enumerations

enum class | JY7131CoreOO::COIdleState { JY7131CoreOO::HighLevel = 0x1 , JY7131CoreOO::LowLevel = 0x0 }
Idle state when pulse output before start and after stop. More...
enum class | JY7131CoreOO::COMode { JY7131CoreOO::Single = 3 , JY7131CoreOO::Finite = 0 , JY7131CoreOO::ContinuousNoWrapping = 2 , JY7131CoreOO::ContinuousWrapping = 1 }
enum class | JY7131CoreOO::COTriggerType { JY7131CoreOO::Immediate = 0x0 , JY7131CoreOO::Digital = 0x1 , JY7131CoreOO::Soft = 0x3 }
TriggerType Digital/Immediate/Soft. More...
enum class JY7131CoreOO::CODigitalTriggerSource {
JY7131CoreOO::PFI_In_0 = 0 , JY7131CoreOO::PFI_In_1 = 1 , JY7131CoreOO::PFI_In_2 = 2 , JY7131CoreOO::PFI_In_3 = 3 ,
JY7131CoreOO::PFI_In_4 = 4 , JY7131CoreOO::PFI_In_5 = 5 , JY7131CoreOO::PFI_In_6 = 6 , JY7131CoreOO::PFI_In_7 = 7 ,
JY7131CoreOO::PFI_In_8 = 8 , JY7131CoreOO::PFI_In_9 = 9 , JY7131CoreOO::PFI_In_10 = 10 , JY7131CoreOO::PFI_In_11 = 11 ,
JY7131CoreOO::PFI_In_12 = 12 , JY7131CoreOO::PFI_In_13 = 13 , JY7131CoreOO::PFI_In_14 = 14 , JY7131CoreOO::PFI_In_15 = 15 ,
JY7131CoreOO::PFI_In_16 = 16 , JY7131CoreOO::PFI_In_17 = 17 , JY7131CoreOO::PFI_In_18 = 18 , JY7131CoreOO::PFI_In_19 = 19 ,
JY7131CoreOO::PFI_In_20 = 20 , JY7131CoreOO::PFI_In_21 = 21 , JY7131CoreOO::PFI_In_22 = 22 , JY7131CoreOO::PFI_In_23 = 23 ,
JY7131CoreOO::PFI_In_24 = 24 , JY7131CoreOO::PFI_In_25 = 25 , JY7131CoreOO::PFI_In_26 = 26 , JY7131CoreOO::PFI_In_27 = 27 ,
JY7131CoreOO::PFI_In_28 = 28 , JY7131CoreOO::PFI_In_29 = 29 , JY7131CoreOO::PFI_In_30 = 30 , JY7131CoreOO::PFI_In_31 = 31 ,
JY7131CoreOO::PXI_Trig0 = 32 , JY7131CoreOO::PXI_Trig1 = 33 , JY7131CoreOO::PXI_Trig2 = 34 , JY7131CoreOO::PXI_Trig3 = 35 ,
JY7131CoreOO::PXI_Trig4 = 36 , JY7131CoreOO::PXI_Trig5 = 37 , JY7131CoreOO::PXI_Trig6 = 38 , JY7131CoreOO::PXI_Trig7 = 39 ,
JY7131CoreOO::CIO_0_StartTrig = 40 , JY7131CoreOO::CIO_1_StartTrig = 41 , JY7131CoreOO::CIO_2_StartTrig = 42 , JY7131CoreOO::CIO_3_StartTrig = 43 ,
JY7131CoreOO::CIO_4_StartTrig = 44 , JY7131CoreOO::CIO_5_StartTrig = 45 , JY7131CoreOO::CIO_6_StartTrig = 46 , JY7131CoreOO::CIO_7_StartTrig = 47 ,
JY7131CoreOO::CO_0_OutPut = 48 , JY7131CoreOO::CO_1_OutPut = 49 , JY7131CoreOO::CO_2_OutPut = 50 , JY7131CoreOO::CO_3_OutPut = 51 ,
JY7131CoreOO::CO_4_OutPut = 52 , JY7131CoreOO::CO_5_OutPut = 53 , JY7131CoreOO::CO_6_OutPut = 54 , JY7131CoreOO::CO_7_OutPut = 55
}
CO Digital trigger source. More...
enum class | JY7131CoreOO::CODigitalTriggerEdge { JY7131CoreOO::Rising , JY7131CoreOO::Falling }
CO Digital Trigger Edge. More...
enum class | JY7131CoreOO::COPulseType { JY7131CoreOO::DutyCycleFrequency , JY7131CoreOO::HighLowTime , JY7131CoreOO::HighLowTick }
Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick. More...
enum class | JY7131CoreOO::COTimebaseSource { JY7131CoreOO::Internal100MHz = 0 , JY7131CoreOO::Internal5MHz = 1 , JY7131CoreOO::Internal100kHz = 2 , JY7131CoreOO::External = 3 }
Timebase source. More...
enum class | JY7131CoreOO::COSignalExportSource { JY7131CoreOO::StartTrig , JY7131CoreOO::Output }
SourceSignal. More...


7131 C++ Programming Manual: JY7131CoreOO::JY7131CoreOOCOTask Class Reference

  • JY7131CoreOOCOTask
Public Member Functions | Public Attributes | List of all members
JY7131CoreOO::JY7131CoreOOCOTask Class Reference

#include <JY7131CoreOOCOTask.h>

Public Member Functions

JY7131CoreOOCOTask (int slotNum, int channel)
JY7131CoreOOCOTask (std::string boardName, int channel)
~JY7131CoreOOCOTask ()
void | WriteSinglePoint (COPulse &pulse)
Write a single pulse parameter to the register.
void | WriteData (COPulse *pulsesGroup[], int samplesToWrite, int timeout=10000)
Write pulse parameters to be output to the buffer.
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Start ()
Start CO task .
void | Stop ()
Stop COtask .
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.

Public Attributes

COMode Mode
CO output mode.
IOTerminal OutputTerminal
PauseTrigger * Pause
COTimebase * Timebase
CO's time base.
double | InitialDelay
Counter output initial delay in seconds.
COIdleState IdleState
Idle state when pulse output before start and after stop.
uint32_t | SamplesToUpdate
有限频率输出
DOLineMode OutTerminalMode
JY7131CoreOOProperty< JY7131CoreOOCOTask, uint32_t, JY7131CoreOOPropertyType::READ_ONLY > | AvailableSamples
Number of points per channel that can be read in the buffer .
JY7131CoreOOProperty< JY7131CoreOOCOTask, uint64_t, JY7131CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
JY7131CoreOOProperty< JY7131CoreOOCOTask, uint32_t, JY7131CoreOOPropertyType::READ_ONLY > | TransferedPulses
COTrigger * Trigger
CO trigger property configured by CO Trigger().
JY7131CoreOODevice * Device
Device.
COSignalExport * SignalExport
Export CO Signal Configuration.

Constructor & Destructor Documentation

◆ JY7131CoreOOCOTask() [1/2]

JY7131CoreOO::JY7131CoreOOCOTask::JY7131CoreOOCOTask | ( | int | slotNum,
 |  | int | channel )

◆ JY7131CoreOOCOTask() [2/2]

JY7131CoreOO::JY7131CoreOOCOTask::JY7131CoreOOCOTask | ( | std::string | boardName,
 |  | int | channel )

◆ ~JY7131CoreOOCOTask()

JY7131CoreOO::JY7131CoreOOCOTask::~JY7131CoreOOCOTask ( )

Member Function Documentation

◆ SendSoftwareTrigger()

void JY7131CoreOO::JY7131CoreOOCOTask::SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY7131CoreOO::JY7131CoreOOCOTask::Start ( )

Start CO task .

◆ Stop()

void JY7131CoreOO::JY7131CoreOOCOTask::Stop ( )

Stop COtask .

◆ WaitUntilDone()

bool JY7131CoreOO::JY7131CoreOOCOTask::WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteData()

void JY7131CoreOO::JY7131CoreOOCOTask::WriteData | ( | COPulse * | pulsesGroup[],
 |  | int | samplesToWrite,
 |  | int | timeout = 10000 )

Write pulse parameters to be output to the buffer.

Valid when Mode is NOT COMode.Single. When Mode is COMode.Finite or COMode.ContinuousWrapping, this function can only be called once before starting the task.

Parameters
pulsesGroup | A group of pulse parameters
samplesToWrite | Number of samples to write. If Mode is COMode.ContinuousWrapping, you need to write at least 2 samples before starting the task
timeout | Timeout (ms). Wait until all data is written to buffer or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ WriteSinglePoint()

void JY7131CoreOO::JY7131CoreOOCOTask::WriteSinglePoint ( COPulse & pulse )

Write a single pulse parameter to the register.

Valid when Mode is COMode.Single. This function is also available after starting the task when the number of pulses being sent is infinite.

Parameters
pulse Pulse Parameter

Member Data Documentation

◆ AvailableSamples

JY7131CoreOOProperty<JY7131CoreOOCOTask, uint32_t, JY7131CoreOOPropertyType::READ_ONLY> JY7131CoreOO::JY7131CoreOOCOTask::AvailableSamples

Number of points per channel that can be read in the buffer .

◆ Device

JY7131CoreOODevice* JY7131CoreOO::JY7131CoreOOCOTask::Device

Device.

◆ IdleState

COIdleState JY7131CoreOO::JY7131CoreOOCOTask::IdleState

Idle state when pulse output before start and after stop.

◆ InitialDelay

double JY7131CoreOO::JY7131CoreOOCOTask::InitialDelay

Counter output initial delay in seconds.

There are five ticks of the timebase fixed delay in counter internal, so the total delay(s) = InitialDelay + (5 / timebase)

◆ Mode

COMode JY7131CoreOO::JY7131CoreOOCOTask::Mode

CO output mode.

◆ OutputTerminal

IOTerminal JY7131CoreOO::JY7131CoreOOCOTask::OutputTerminal

脉冲输出端口

Pulse Output Terminal

◆ OutTerminalMode

DOLineMode JY7131CoreOO::JY7131CoreOOCOTask::OutTerminalMode

◆ Pause

PauseTrigger* JY7131CoreOO::JY7131CoreOOCOTask::Pause

暂停触发配置

Pause Trigger Configuration

◆ SamplesToUpdate

uint32_t JY7131CoreOO::JY7131CoreOOCOTask::SamplesToUpdate

有限频率输出

◆ SignalExport

COSignalExport* JY7131CoreOO::JY7131CoreOOCOTask::SignalExport

Export CO Signal Configuration.

◆ Timebase

COTimebase* JY7131CoreOO::JY7131CoreOOCOTask::Timebase

CO's time base.

◆ TransferedPulses

JY7131CoreOOProperty<JY7131CoreOOCOTask, uint32_t, JY7131CoreOOPropertyType::READ_ONLY> JY7131CoreOO::JY7131CoreOOCOTask::TransferedPulses

当前配置下已发送的脉冲的数量。

The number of pulses transfered under the current configuration.

◆ TransferedSamples

JY7131CoreOOProperty<JY7131CoreOOCOTask, uint64_t, JY7131CoreOOPropertyType::READ_ONLY> JY7131CoreOO::JY7131CoreOOCOTask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT CIMode.Single.

◆ Trigger

COTrigger* JY7131CoreOO::JY7131CoreOOCOTask::Trigger

CO trigger property configured by CO Trigger().

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOOCOTask.h


7131 C++ Programming Manual: JY7131CoreOO::CODigitalTrigger Class Reference

  • CODigitalTrigger
Public Attributes | List of all members
JY7131CoreOO::CODigitalTrigger Class Reference

CO Digital trigger . More...

#include <JY7131CoreOOCOTask.h>

Public Attributes

CODigitalTriggerSource Source
CO Digital Trigger source.
CODigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Detailed Description

CO Digital trigger .

Member Data Documentation

◆ Edge

CODigitalTriggerEdge JY7131CoreOO::CODigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

CODigitalTriggerSource JY7131CoreOO::CODigitalTrigger::Source

CO Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOOCOTask.h


7131 C++ Programming Manual: JY7131CoreOO::COTrigger Class Reference

  • COTrigger
Public Attributes | List of all members
JY7131CoreOO::COTrigger Class Reference

Constructor to create an COTrigger task object. More...

#include <JY7131CoreOOCOTask.h>

Public Attributes

COTriggerType Type
CO trigger type.
CODigitalTrigger * Digital
CO Digital Trigger.

Detailed Description

Constructor to create an COTrigger task object.

Used to build CO Trigger

Member Data Documentation

◆ Digital

CODigitalTrigger* JY7131CoreOO::COTrigger::Digital

CO Digital Trigger.

Valid when Type is COTriggerType.Digital

◆ Type

COTriggerType JY7131CoreOO::COTrigger::Type

CO trigger type.

enum Immediate/Digital/Soft.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOOCOTask.h


7131 C++ Programming Manual: JY7131CoreOO::COPulse Class Reference

  • COPulse
Public Member Functions | List of all members
JY7131CoreOO::COPulse Class Reference

Pulse Parameter. More...

#include <JY7131CoreOOCOTask.h>

Public Member Functions

COPulse (COPulseType type, double param1, double param2, int count)
Pulse Parameter.

Detailed Description

Pulse Parameter.

Constructor & Destructor Documentation

◆ COPulse()

JY7131CoreOO::COPulse::COPulse | ( | COPulseType | type,
 |  | double | param1,
 |  | double | param2,
 |  | int | count )

Pulse Parameter.

Parameters
type | The pulse type characteristics.
param1 | Parameter 1. Frequency (Hz) when constructed as COPulseType.DutyCycleFrequency; High duration in seconds when constructed as COPulseType.HighLowTime; High ticks of the clock when constructed as COPulseType.HighLowTick.
param2 | Parameter 1. Duty cycle (greater than 0 and less than 1) when constructed as COPulseType.DutyCycleFrequency; Low duration in seconds when constructed as COPulseType.HighLowTime; Low ticks of the clock when constructed as COPulseType.HighLowTick.
count | Number of pulses. When the value is -1 (indicating that the number of pulses is infinite), pulses will be continuously sent until requested to stop.
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOOCOTask.h


7131 C++ Programming Manual: JY7131CoreOO::COExternalTimebase Class Reference

  • COExternalTimebase
Public Attributes | List of all members
JY7131CoreOO::COExternalTimebase Class Reference

#include <JY7131CoreOOCOTask.h>

Public Attributes

JY7131CoreOO::InputTerminal Terminal
double Frequency = 100e6

Member Data Documentation

◆ Frequency

double JY7131CoreOO::COExternalTimebase::Frequency = 100e6

◆ Terminal

JY7131CoreOO::InputTerminal JY7131CoreOO::COExternalTimebase::Terminal
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOOCOTask.h


7131 C++ Programming Manual: JY7131CoreOO::COTimebase Class Reference

  • COTimebase
Public Attributes | List of all members
JY7131CoreOO::COTimebase Class Reference

Timebase configuration class. More...

#include <JY7131CoreOOCOTask.h>

Public Attributes

COTimebaseSource Source
Timebase Source.
COExternalTimebase * External
JY7131CoreOOProperty< COTimebase, double, JY7131CoreOOPropertyType::READ_ONLY > ActualFreq

Detailed Description

Timebase configuration class.

Member Data Documentation

◆ ActualFreq

JY7131CoreOOProperty<COTimebase, double, JY7131CoreOOPropertyType::READ_ONLY> JY7131CoreOO::COTimebase::ActualFreq

◆ External

COExternalTimebase* JY7131CoreOO::COTimebase::External

◆ Source

COTimebaseSource JY7131CoreOO::COTimebase::Source

Timebase Source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOOCOTask.h


7131 C++ Programming Manual: JY7131CoreOO::COSignalExport Class Reference

  • COSignalExport
Public Member Functions | List of all members
JY7131CoreOO::COSignalExport Class Reference

CO Signal Export Class. More...

#include <JY7131CoreOOCOTask.h>

Public Member Functions

void | Add (COSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (COSignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

CO Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY7131CoreOO::COSignalExport::Add | ( | COSignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | CI Signal Source
destination | Export Desination

◆ Add() [2/2]

void JY7131CoreOO::COSignalExport::Add | ( | COSignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | CI Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JY7131CoreOO::COSignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY7131CoreOO::COSignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOOCOTask.h


7131 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOODevice.h File Reference

  • File List
  • File Members
  • COO
  • 7131
Classes | Namespaces | Enumerations
JY7131CoreOODevice.h File Reference
#include <iostream>
#include <string>
#include <list>
#include <vector>
#include "JY7131CoreOOCommon.h"

Classes

class | JY7131CoreOO::JY7131CoreOODevice
class | JY7131CoreOO::ExternalReferenceClock
class | JY7131CoreOO::JY7131CoreOOReferenceClock

Namespaces

namespace JY7131CoreOO

Enumerations

enum class | JY7131CoreOO::ExternalReferenceClockTerminal { JY7131CoreOO::PXIe_Clk100 = 0x1 }
enum class | JY7131CoreOO::ReferenceClockSource { JY7131CoreOO::Internal = 0x0 , JY7131CoreOO::External = 0x1 }
enum class JY7131CoreOO::PFITerminal {
JY7131CoreOO::PFI0 = 0 , JY7131CoreOO::PFI1 = 1 , JY7131CoreOO::PFI2 = 2 , JY7131CoreOO::PFI3 = 3 ,
JY7131CoreOO::PFI4 = 4 , JY7131CoreOO::PFI5 = 5 , JY7131CoreOO::PFI6 = 6 , JY7131CoreOO::PFI7 = 7 ,
JY7131CoreOO::PFI8 = 8 , JY7131CoreOO::PFI9 = 9 , JY7131CoreOO::PFI10 = 10 , JY7131CoreOO::PFI11 = 11 ,
JY7131CoreOO::PFI12 = 12 , JY7131CoreOO::PFI13 = 13 , JY7131CoreOO::PFI14 = 14 , JY7131CoreOO::PFI15 = 15
}
Input/Output Terminal of PFI. More...


7131 C++ Programming Manual: JY7131CoreOO::JY7131CoreOODevice Class Reference

  • JY7131CoreOODevice
Static Public Member Functions | Public Attributes | List of all members
JY7131CoreOO::JY7131CoreOODevice Class Reference

#include <JY7131CoreOODevice.h>

Static Public Member Functions

static JY7131CoreOODevice * | GetInstance (int cardNum)
static JY7131CoreOODevice * | GetInstance (std::string aliasName)

Public Attributes

const double | BoardClockRate = 100e6
JY7131CoreOOProperty< JY7131CoreOODevice, std::string, JY7131CoreOOPropertyType::READ_ONLY > | SerialNumber
JY7131CoreOOProperty< JY7131CoreOODevice, int, JY7131CoreOOPropertyType::READ_ONLY > | DeviceID
JY7131CoreOOProperty< JY7131CoreOODevice, void *, JY7131CoreOOPropertyType::READ_ONLY > | Handle
JY7131CoreOOReferenceClock * ReferenceClock

Member Function Documentation

◆ GetInstance() [1/2]

static JY7131CoreOODevice * JY7131CoreOO::JY7131CoreOODevice::GetInstance ( int cardNum )
static

◆ GetInstance() [2/2]

static JY7131CoreOODevice * JY7131CoreOO::JY7131CoreOODevice::GetInstance ( std::string aliasName )
static

Member Data Documentation

◆ BoardClockRate

const double JY7131CoreOO::JY7131CoreOODevice::BoardClockRate = 100e6

◆ DeviceID

JY7131CoreOOProperty<JY7131CoreOODevice, int, JY7131CoreOOPropertyType::READ_ONLY> JY7131CoreOO::JY7131CoreOODevice::DeviceID

◆ Handle

JY7131CoreOOProperty<JY7131CoreOODevice, void*, JY7131CoreOOPropertyType::READ_ONLY> JY7131CoreOO::JY7131CoreOODevice::Handle

◆ ReferenceClock

JY7131CoreOOReferenceClock* JY7131CoreOO::JY7131CoreOODevice::ReferenceClock

◆ SerialNumber

JY7131CoreOOProperty<JY7131CoreOODevice, std::string, JY7131CoreOOPropertyType::READ_ONLY> JY7131CoreOO::JY7131CoreOODevice::SerialNumber
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOODevice.h


7131 C++ Programming Manual: JY7131CoreOO::ExternalReferenceClock Class Reference

  • ExternalReferenceClock
Public Attributes | List of all members
JY7131CoreOO::ExternalReferenceClock Class Reference

#include <JY7131CoreOODevice.h>

Public Attributes

ExternalReferenceClockTerminal Terminal

Member Data Documentation

◆ Terminal

ExternalReferenceClockTerminal JY7131CoreOO::ExternalReferenceClock::Terminal
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOODevice.h


7131 C++ Programming Manual: JY7131CoreOO::JY7131CoreOOReferenceClock Class Reference

  • JY7131CoreOOReferenceClock
Public Member Functions | Public Attributes | Friends | List of all members
JY7131CoreOO::JY7131CoreOOReferenceClock Class Reference

#include <JY7131CoreOODevice.h>

Public Member Functions

void Commit ()
Commit configuration.

Public Attributes

ReferenceClockSource Source
ExternalReferenceClock * External
External Reference Clock Source.

Friends

class JY7131CoreOODevice

Member Function Documentation

◆ Commit()

void JY7131CoreOO::JY7131CoreOOReferenceClock::Commit ( )

Commit configuration.

Available only when the device is idle. WARNING: Incorrect parameters will cause the PLL to be unable to lock the reference clock and cannot be recovered until shutdown and restart.

Friends And Related Symbol Documentation

◆ JY7131CoreOODevice

friend class JY7131CoreOODevice
friend

Member Data Documentation

◆ External

ExternalReferenceClock* JY7131CoreOO::JY7131CoreOOReferenceClock::External

External Reference Clock Source.

Required when ReferenceClock.Source is ReferenceClockSource.External

◆ Source

ReferenceClockSource JY7131CoreOO::JY7131CoreOOReferenceClock::Source
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOODevice.h


7131 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOODITask.h File Reference

  • File List
  • File Members
  • COO
  • 7131
Classes | Namespaces
JY7131CoreOODITask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JY7131CoreOOCommon.h"
#include "JY7131CoreOODevice.h"

Classes

class | JY7131CoreOO::JY7131CoreOODITask
class | JY7131CoreOO::DIChannel
DI Channel parameter class . More...

Namespaces

namespace JY7131CoreOO


7131 C++ Programming Manual: JY7131CoreOO::JY7131CoreOODITask Class Reference

  • JY7131CoreOODITask
Public Member Functions | Public Attributes | List of all members
JY7131CoreOO::JY7131CoreOODITask Class Reference

#include <JY7131CoreOODITask.h>

Public Member Functions

JY7131CoreOODITask (int slotNum)
JY7131CoreOODITask (std::string boardName)
~JY7131CoreOODITask ()
void | AddChannel (int portNum)
Add one channel.
void | AddChannel (std::vector< int > portsNum)
Add a group of channel.
void | RemoveChannel (int portNum)
Delete the specified port number .If it is -1, delete all ports.
void | Start ()
Start DI task .
void | Stop ()
Stop DI task .
void | ReadSinglePoint (bool *readValues, int port, int line)
Specify the line reads the latest point.
void | ReadSinglePoint (bool &readValues, int port, int line)
Specify the line reads the latest point.
void | ReadSinglePoint (bool *readValues, int port)
Specify port reads the latest point.
void | ReadSinglePoint (std::vector< bool > &readValues, int port)
Specify port reads the latest point.
void | ReadSinglePoint (unsigned long *readValues)
All ports all lines read the latest point.
void | ReadSinglePoint (unsigned long &readValues)
All ports all lines read the latest point.

Public Attributes

std::list< DIChannel * > Channels
List of DI channels,(The 7131 supports 4 ports for a total of 32 lines)
JY7131CoreOODevice * Device
Device.

Constructor & Destructor Documentation

◆ JY7131CoreOODITask() [1/2]

JY7131CoreOO::JY7131CoreOODITask::JY7131CoreOODITask ( int slotNum )

◆ JY7131CoreOODITask() [2/2]

JY7131CoreOO::JY7131CoreOODITask::JY7131CoreOODITask ( std::string boardName )

◆ ~JY7131CoreOODITask()

JY7131CoreOO::JY7131CoreOODITask::~JY7131CoreOODITask ( )

Member Function Documentation

◆ AddChannel() [1/2]

void JY7131CoreOO::JY7131CoreOODITask::AddChannel ( int portNum )

Add one channel.

Parameters
portNum port number to be added.

◆ AddChannel() [2/2]

void JY7131CoreOO::JY7131CoreOODITask::AddChannel ( std::vector< int > portsNum )

Add a group of channel.

Parameters
portsNum an array of port numbers of added ports.

◆ ReadSinglePoint() [1/6]

void JY7131CoreOO::JY7131CoreOODITask::ReadSinglePoint | ( | bool & | readValues,
 |  | int | port,
 |  | int | line )

Specify the line reads the latest point.

Parameters
readValue | read Value
port | Specify the port to read
line | Specify the line to read

◆ ReadSinglePoint() [2/6]

void JY7131CoreOO::JY7131CoreOODITask::ReadSinglePoint | ( | bool * | readValues,
 |  | int | port )

Specify port reads the latest point.

Parameters
readValues | User buffer array,Buffer size>= 8
port | Specify port

◆ ReadSinglePoint() [3/6]

void JY7131CoreOO::JY7131CoreOODITask::ReadSinglePoint | ( | bool * | readValues,
 |  | int | port,
 |  | int | line )

Specify the line reads the latest point.

Parameters
readValue | read Value
port | Specify the port to read
line | Specify the line to read

◆ ReadSinglePoint() [4/6]

void JY7131CoreOO::JY7131CoreOODITask::ReadSinglePoint | ( | std::vector< bool > & | readValues,
 |  | int | port )

Specify port reads the latest point.

Parameters
readValues | User buffer array,Buffer size>= 8
port | Specify port

◆ ReadSinglePoint() [5/6]

void JY7131CoreOO::JY7131CoreOODITask::ReadSinglePoint ( unsigned long & readValues )

All ports all lines read the latest point.

Parameters
readValues read Value

◆ ReadSinglePoint() [6/6]

void JY7131CoreOO::JY7131CoreOODITask::ReadSinglePoint ( unsigned long * readValues )

All ports all lines read the latest point.

Parameters
readValues read Value

◆ RemoveChannel()

void JY7131CoreOO::JY7131CoreOODITask::RemoveChannel ( int portNum )

Delete the specified port number .If it is -1, delete all ports.

Parameters
portNum port number to be delete.

◆ Start()

void JY7131CoreOO::JY7131CoreOODITask::Start ( )

Start DI task .

◆ Stop()

void JY7131CoreOO::JY7131CoreOODITask::Stop ( )

Stop DI task .

Member Data Documentation

◆ Channels

std::list<DIChannel*> JY7131CoreOO::JY7131CoreOODITask::Channels

List of DI channels,(The 7131 supports 4 ports for a total of 32 lines)

◆ Device

JY7131CoreOODevice* JY7131CoreOO::JY7131CoreOODITask::Device

Device.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOODITask.h


7131 C++ Programming Manual: JY7131CoreOO::DIChannel Class Reference

  • DIChannel
Public Attributes | List of all members
JY7131CoreOO::DIChannel Class Reference

DI Channel parameter class . More...

#include <JY7131CoreOODITask.h>

Public Attributes

int PortNum
port number.

Detailed Description

DI Channel parameter class .

Member Data Documentation

◆ PortNum

int JY7131CoreOO::DIChannel::PortNum

port number.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOODITask.h


7131 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOODOTask.h File Reference

  • File List
  • File Members
  • COO
  • 7131
Classes | Namespaces | Enumerations
JY7131CoreOODOTask.h File Reference
#include <string>
#include <map>
#include <mutex>
#include "JY7131CoreOOCommon.h"
#include "JY7131CoreOODevice.h"

Classes

class | JY7131CoreOO::JY7131CoreOODOTask
class | JY7131CoreOO::DOChannel
DO Channel parameter class . More...

Namespaces

namespace JY7131CoreOO

Enumerations

enum class JY7131CoreOO::DOLineMode { JY7131CoreOO::Sourcing = 0 , JY7131CoreOO::Sinking = 1 , JY7131CoreOO::Push_Pull = 2 }


7131 C++ Programming Manual: JY7131CoreOO::JY7131CoreOODOTask Class Reference

  • JY7131CoreOODOTask
Public Member Functions | Public Attributes | List of all members
JY7131CoreOO::JY7131CoreOODOTask Class Reference

#include <JY7131CoreOODOTask.h>

Public Member Functions

JY7131CoreOODOTask (int slotNum)
JY7131CoreOODOTask (std::string boardName)
~JY7131CoreOODOTask ()
void | AddChannel (int portNum)
Add one channel.
void | AddChannel (std::vector< int > portsNum)
Add a group of channel.
void | RemoveChannel (int portNum)
Delete the specified port number .If it is -1, delete all ports.
void | Start ()
Start DO task .
void | Stop ()
Stop DO task .
void | WriteSinglePoint (bool writeValue, int port, int line)
write the latest point of specify port specify line
void | WriteSinglePoint (std::vector< bool > writeValues)
write all lines the latest point
void | WriteSinglePoint (std::vector< bool > writeValues, int port)
write all lines the latest point
void | SetPowerOn (DOLineMode mode[], bool writeValues[])
write all lines the latest point

Public Attributes

std::list< DOChannel * > Channels
List of DO channels, (The 7131 supports 3 ports for a total of 32 lines)
DOLineMode DOLine_Mode
DO acquisition mode，support Single/ Finite/Continuous.
JY7131CoreOODevice * Device
Device.

Constructor & Destructor Documentation

◆ JY7131CoreOODOTask() [1/2]

JY7131CoreOO::JY7131CoreOODOTask::JY7131CoreOODOTask ( int slotNum )

◆ JY7131CoreOODOTask() [2/2]

JY7131CoreOO::JY7131CoreOODOTask::JY7131CoreOODOTask ( std::string boardName )

◆ ~JY7131CoreOODOTask()

JY7131CoreOO::JY7131CoreOODOTask::~JY7131CoreOODOTask ( )

Member Function Documentation

◆ AddChannel() [1/2]

void JY7131CoreOO::JY7131CoreOODOTask::AddChannel ( int portNum )

Add one channel.

Parameters
portNum port number to be added.

◆ AddChannel() [2/2]

void JY7131CoreOO::JY7131CoreOODOTask::AddChannel ( std::vector< int > portsNum )

Add a group of channel.

Parameters
portsNum an array of port numbers of added ports.

◆ RemoveChannel()

void JY7131CoreOO::JY7131CoreOODOTask::RemoveChannel ( int portNum )

Delete the specified port number .If it is -1, delete all ports.

Parameters
portNum port number to be delete.

◆ SetPowerOn()

void JY7131CoreOO::JY7131CoreOODOTask::SetPowerOn | ( | DOLineMode | mode[],
 |  | bool | writeValues[] )

write all lines the latest point

Parameters
writeValues User buffer array

◆ Start()

void JY7131CoreOO::JY7131CoreOODOTask::Start ( )

Start DO task .

◆ Stop()

void JY7131CoreOO::JY7131CoreOODOTask::Stop ( )

Stop DO task .

◆ WriteSinglePoint() [1/3]

void JY7131CoreOO::JY7131CoreOODOTask::WriteSinglePoint | ( | bool | writeValue,
 |  | int | port,
 |  | int | line )

write the latest point of specify port specify line

Parameters
writeValue | write Value
port | Specify the port to write,port cannot be equal to -1
line | Specify the line to write,line cannot be equal to -1

◆ WriteSinglePoint() [2/3]

void JY7131CoreOO::JY7131CoreOODOTask::WriteSinglePoint ( std::vector< bool > writeValues )

write all lines the latest point

Parameters
writeValues User buffer array,Buffer size = Port count * 8

◆ WriteSinglePoint() [3/3]

void JY7131CoreOO::JY7131CoreOODOTask::WriteSinglePoint | ( | std::vector< bool > | writeValues,
 |  | int | port )

write all lines the latest point

Parameters
writeValues | User buffer array,Buffer size = 8
port | Specify the port to write, port = - 1, Write to all added ports

Member Data Documentation

◆ Channels

std::list<DOChannel*> JY7131CoreOO::JY7131CoreOODOTask::Channels

List of DO channels, (The 7131 supports 3 ports for a total of 32 lines)

◆ Device

JY7131CoreOODevice* JY7131CoreOO::JY7131CoreOODOTask::Device

Device.

◆ DOLine_Mode

DOLineMode JY7131CoreOO::JY7131CoreOODOTask::DOLine_Mode

DO acquisition mode，support Single/ Finite/Continuous.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOODOTask.h


7131 C++ Programming Manual: JY7131CoreOO::DOChannel Class Reference

  • DOChannel
Public Attributes | List of all members
JY7131CoreOO::DOChannel Class Reference

DO Channel parameter class . More...

#include <JY7131CoreOODOTask.h>

Public Attributes

int PortNum
port number.

Detailed Description

DO Channel parameter class .

Member Data Documentation

◆ PortNum

int JY7131CoreOO::DOChannel::PortNum

port number.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOODOTask.h


7131 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOOLog.h File Reference

  • File List
  • File Members
  • COO
  • 7131
Classes | Namespaces | Enumerations
JY7131CoreOOLog.h File Reference
#include <queue>
#include <string>
#include <thread>
#include "JY7131CoreOOCommon.h"

Classes

class JY7131CoreOO::JY7131CoreOOLog

Namespaces

namespace JY7131CoreOO

Enumerations

enum class JY7131CoreOO::JY7131CoreOOLogLevel {
JY7131CoreOO::DEBUG_LOG_LEVEL , JY7131CoreOO::INFO_LOG_LEVEL , JY7131CoreOO::WARN_LOG_LEVEL , JY7131CoreOO::ERROR_LOG_LEVEL ,
JY7131CoreOO::FATAL_LOG_LEVEL
}


7131 C++ Programming Manual: JY7131CoreOO::JY7131CoreOOLog Class Reference

  • JY7131CoreOOLog
Static Public Member Functions | Static Public Attributes | List of all members
JY7131CoreOO::JY7131CoreOOLog Class Reference

#include <JY7131CoreOOLog.h>

Static Public Member Functions

static void | Print (const char *format,...)
static void | Print (JY7131CoreOOLogLevel logLevel, const char *format,...)
static void | Flush ()

Static Public Attributes

static JY7131CoreOOLogLevel | LogLevel
static JY7131CoreOOProperty< JY7131CoreOOLog, bool, JY7131CoreOOPropertyType::READ_WRITE > | EnableLog

Member Function Documentation

◆ Flush()

static void JY7131CoreOO::JY7131CoreOOLog::Flush ( )
static

◆ Print() [1/2]

static void JY7131CoreOO::JY7131CoreOOLog::Print | ( | const char * | format,
 |  |  | ... )
 static

◆ Print() [2/2]

static void JY7131CoreOO::JY7131CoreOOLog::Print | ( | JY7131CoreOOLogLevel | logLevel,
 |  | const char * | format,
 |  |  | ... )
 static

Member Data Documentation

◆ EnableLog

JY7131CoreOOProperty<JY7131CoreOOLog, bool, JY7131CoreOOPropertyType::READ_WRITE> JY7131CoreOO::JY7131CoreOOLog::EnableLog
static

◆ LogLevel

JY7131CoreOOLogLevel JY7131CoreOO::JY7131CoreOOLog::LogLevel
static
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/7131/JY7131CoreOOLog.h


7131 C++ Programming Manual: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
▼N JY7131CoreOO |
C CIDigitalTrigger | CI Digital trigger
C CIExternalSampleClock | CI Implicit Sample Clock class
C CIExternalTimebase |
C CIImplicitSampleClock | CI Implicit Sample Clock class
C CIInternalSampleClock | CI Internal Sample Clock Configuration Class
C CISampleClock | CI Sample Clock class
C CISignalExport | CI Signal Export Class
C CITimebase | Timebase configuration class
C CITrigger | Constructor to create an CITrigger task object
C CODigitalTrigger | CO Digital trigger
C COExternalTimebase |
C COPulse | Pulse Parameter
C COSignalExport | CO Signal Export Class
C COTimebase | Timebase configuration class
C COTrigger | Constructor to create an COTrigger task object
C DIChannel | DI Channel parameter class
C DOChannel | DO Channel parameter class
C EdgeCounting | Configure CI EdgeCounting
C EdgeCountingOutEvent | Edge counting output event configuration class
C ExternalReferenceClock |
C FrequencyMeas | Configure CI Measure
C JY7131CoreOOCITask |
C JY7131CoreOOCOTask |
C JY7131CoreOODevice |
C JY7131CoreOODITask |
C JY7131CoreOODOTask |
C JY7131CoreOOLog |
C JY7131CoreOOProperty | 属性模板类
C JY7131CoreOOReferenceClock |
C JYDriverException |
C PauseTrigger | Pause trigger configuration class
C PeriodMeas | Configure CI Measure
C PulseMeas | Configure CI Measure
C QuadEncoder | Configure CI Measure
C SemiPeriodMeas | Configure CI SemiPeriodMeas
C TwoEdgeSeparation | Configure CI Measure
C TwoPulseEncoder | Configure CI Measure


7131 C++ Programming Manual: Member List

  • CIDigitalTrigger
JY7131CoreOO::CIDigitalTrigger Member List

This is the complete list of members for JY7131CoreOO::CIDigitalTrigger, including all inherited members.

Edge | JY7131CoreOO::CIDigitalTrigger
Source | JY7131CoreOO::CIDigitalTrigger


7131 C++ Programming Manual: Member List

  • CIExternalSampleClock
JY7131CoreOO::CIExternalSampleClock Member List

This is the complete list of members for JY7131CoreOO::CIExternalSampleClock, including all inherited members.

ExpectedRate | JY7131CoreOO::CIExternalSampleClock
IgnoreFirstSampleClock | JY7131CoreOO::CIExternalSampleClock
Terminal | JY7131CoreOO::CIExternalSampleClock


7131 C++ Programming Manual: Member List

  • CIExternalTimebase
JY7131CoreOO::CIExternalTimebase Member List

This is the complete list of members for JY7131CoreOO::CIExternalTimebase, including all inherited members.

Frequency | JY7131CoreOO::CIExternalTimebase
Terminal | JY7131CoreOO::CIExternalTimebase


7131 C++ Programming Manual: Member List

  • CIImplicitSampleClock
JY7131CoreOO::CIImplicitSampleClock Member List

This is the complete list of members for JY7131CoreOO::CIImplicitSampleClock, including all inherited members.

ExpectedRate JY7131CoreOO::CIImplicitSampleClock


7131 C++ Programming Manual: Member List

  • CIInternalSampleClock
JY7131CoreOO::CIInternalSampleClock Member List

This is the complete list of members for JY7131CoreOO::CIInternalSampleClock, including all inherited members.

IgnoreFirstSampleClock | JY7131CoreOO::CIInternalSampleClock
Rate | JY7131CoreOO::CIInternalSampleClock


7131 C++ Programming Manual: Member List

  • CISampleClock
JY7131CoreOO::CISampleClock Member List

This is the complete list of members for JY7131CoreOO::CISampleClock, including all inherited members.

External | JY7131CoreOO::CISampleClock
Implicit | JY7131CoreOO::CISampleClock
Internal | JY7131CoreOO::CISampleClock
Source | JY7131CoreOO::CISampleClock


7131 C++ Programming Manual: Member List

  • CISignalExport
JY7131CoreOO::CISignalExport Member List

This is the complete list of members for JY7131CoreOO::CISignalExport, including all inherited members.

Add(CISignalExportSource source, SignalExportDestination destination) | JY7131CoreOO::CISignalExport
Add(CISignalExportSource source, std::list< SignalExportDestination > destinations) | JY7131CoreOO::CISignalExport
Clear(SignalExportDestination destination) | JY7131CoreOO::CISignalExport
ClearAll() | JY7131CoreOO::CISignalExport


7131 C++ Programming Manual: Member List

  • CITimebase
JY7131CoreOO::CITimebase Member List

This is the complete list of members for JY7131CoreOO::CITimebase, including all inherited members.

ActualFreq | JY7131CoreOO::CITimebase |
CITimebase() | JY7131CoreOO::CITimebase |
External | JY7131CoreOO::CITimebase |
Source | JY7131CoreOO::CITimebase |
~CITimebase() | JY7131CoreOO::CITimebase | inline


7131 C++ Programming Manual: Member List

  • CITrigger
JY7131CoreOO::CITrigger Member List

This is the complete list of members for JY7131CoreOO::CITrigger, including all inherited members.

Digital | JY7131CoreOO::CITrigger
Type | JY7131CoreOO::CITrigger


7131 C++ Programming Manual: Member List

  • CODigitalTrigger
JY7131CoreOO::CODigitalTrigger Member List

This is the complete list of members for JY7131CoreOO::CODigitalTrigger, including all inherited members.

Edge | JY7131CoreOO::CODigitalTrigger
Source | JY7131CoreOO::CODigitalTrigger


7131 C++ Programming Manual: Member List

  • COExternalTimebase
JY7131CoreOO::COExternalTimebase Member List

This is the complete list of members for JY7131CoreOO::COExternalTimebase, including all inherited members.

Frequency | JY7131CoreOO::COExternalTimebase
Terminal | JY7131CoreOO::COExternalTimebase


7131 C++ Programming Manual: Member List

  • COPulse
JY7131CoreOO::COPulse Member List

This is the complete list of members for JY7131CoreOO::COPulse, including all inherited members.

COPulse(COPulseType type, double param1, double param2, int count) JY7131CoreOO::COPulse


7131 C++ Programming Manual: Member List

  • COSignalExport
JY7131CoreOO::COSignalExport Member List

This is the complete list of members for JY7131CoreOO::COSignalExport, including all inherited members.

Add(COSignalExportSource source, SignalExportDestination destination) | JY7131CoreOO::COSignalExport
Add(COSignalExportSource source, std::list< SignalExportDestination > destinations) | JY7131CoreOO::COSignalExport
Clear(SignalExportDestination destination) | JY7131CoreOO::COSignalExport
ClearAll() | JY7131CoreOO::COSignalExport


7131 C++ Programming Manual: Member List

  • COTimebase
JY7131CoreOO::COTimebase Member List

This is the complete list of members for JY7131CoreOO::COTimebase, including all inherited members.

ActualFreq | JY7131CoreOO::COTimebase
External | JY7131CoreOO::COTimebase
Source | JY7131CoreOO::COTimebase


7131 C++ Programming Manual: Member List

  • COTrigger
JY7131CoreOO::COTrigger Member List

This is the complete list of members for JY7131CoreOO::COTrigger, including all inherited members.

Digital | JY7131CoreOO::COTrigger
Type | JY7131CoreOO::COTrigger


7131 C++ Programming Manual: Member List

  • DIChannel
JY7131CoreOO::DIChannel Member List

This is the complete list of members for JY7131CoreOO::DIChannel, including all inherited members.

PortNum JY7131CoreOO::DIChannel


7131 C++ Programming Manual: Member List

  • DOChannel
JY7131CoreOO::DOChannel Member List

This is the complete list of members for JY7131CoreOO::DOChannel, including all inherited members.

PortNum JY7131CoreOO::DOChannel


7131 C++ Programming Manual: Member List

  • EdgeCounting
JY7131CoreOO::EdgeCounting Member List

This is the complete list of members for JY7131CoreOO::EdgeCounting, including all inherited members.

ActiveEdge | JY7131CoreOO::EdgeCounting
Direction | JY7131CoreOO::EdgeCounting
DirTerminal | JY7131CoreOO::EdgeCounting
InitialCount | JY7131CoreOO::EdgeCounting
Input_Terminal | JY7131CoreOO::EdgeCounting
OutEvent | JY7131CoreOO::EdgeCounting
Pause | JY7131CoreOO::EdgeCounting


7131 C++ Programming Manual: Member List

  • EdgeCountingOutEvent
JY7131CoreOO::EdgeCountingOutEvent Member List

This is the complete list of members for JY7131CoreOO::EdgeCountingOutEvent, including all inherited members.

IdleState | JY7131CoreOO::EdgeCountingOutEvent
Terminal | JY7131CoreOO::EdgeCountingOutEvent
Threshold | JY7131CoreOO::EdgeCountingOutEvent


7131 C++ Programming Manual: Member List

  • ExternalReferenceClock
JY7131CoreOO::ExternalReferenceClock Member List

This is the complete list of members for JY7131CoreOO::ExternalReferenceClock, including all inherited members.

Terminal JY7131CoreOO::ExternalReferenceClock


7131 C++ Programming Manual: Member List

  • FrequencyMeas
JY7131CoreOO::FrequencyMeas Member List

This is the complete list of members for JY7131CoreOO::FrequencyMeas, including all inherited members.

Input_Terminal | JY7131CoreOO::FrequencyMeas
StartingEdge | JY7131CoreOO::FrequencyMeas
Timebase | JY7131CoreOO::FrequencyMeas


7131 C++ Programming Manual: Member List

  • JY7131CoreOOCITask
JY7131CoreOO::JY7131CoreOOCITask Member List

This is the complete list of members for JY7131CoreOO::JY7131CoreOOCITask, including all inherited members.

AvailableSamples | JY7131CoreOO::JY7131CoreOOCITask
Device | JY7131CoreOO::JY7131CoreOOCITask
EdgeCounting | JY7131CoreOO::JY7131CoreOOCITask
FrequencyMeas | JY7131CoreOO::JY7131CoreOOCITask
JY7131CoreOOCITask(int slotNum, int channel) | JY7131CoreOO::JY7131CoreOOCITask
JY7131CoreOOCITask(std::string boardName, int channel) | JY7131CoreOO::JY7131CoreOOCITask
Mode | JY7131CoreOO::JY7131CoreOOCITask
PeriodMeas | JY7131CoreOO::JY7131CoreOOCITask
QuadEncoder | JY7131CoreOO::JY7131CoreOOCITask
ReadData(uint32_t *pBufCount, int samplesToAcquire, int timeout=10000) | JY7131CoreOO::JY7131CoreOOCITask
ReadData(std::vector< uint32_t > &pBufCount, int samplesToAcquire, int timeout=10000) | JY7131CoreOO::JY7131CoreOOCITask
ReadData(double *pBufMeasurement, int samplesToAcquire, int timeout=10000) | JY7131CoreOO::JY7131CoreOOCITask
ReadData(std::vector< double > &pBufMeasurement, int samplesToAcquire, int timeout=10000) | JY7131CoreOO::JY7131CoreOOCITask
ReadData(double *pBufMeasurement1, double *pBufMeasurement2, int samplesToAcquire, int timeout=10000) | JY7131CoreOO::JY7131CoreOOCITask
ReadData(std::vector< double > &pBufMeasurement1, std::vector< double > &pBufMeasurement2, int samplesToAcquire, int timeout=10000) | JY7131CoreOO::JY7131CoreOOCITask
ReadSinglePoint(uint32_t &count) | JY7131CoreOO::JY7131CoreOOCITask
ReadSinglePoint(double &measurement, int timeout=10000) | JY7131CoreOO::JY7131CoreOOCITask
ReadSinglePoint(double &measurement1, double &measurement2, int timeout=10000) | JY7131CoreOO::JY7131CoreOOCITask
SampleClock | JY7131CoreOO::JY7131CoreOOCITask
SamplesToAcquire | JY7131CoreOO::JY7131CoreOOCITask
SendSoftwareTrigger() | JY7131CoreOO::JY7131CoreOOCITask
SignalExport | JY7131CoreOO::JY7131CoreOOCITask
Start() | JY7131CoreOO::JY7131CoreOOCITask
Stop() | JY7131CoreOO::JY7131CoreOOCITask
TimeBase | JY7131CoreOO::JY7131CoreOOCITask
TransferedSamples | JY7131CoreOO::JY7131CoreOOCITask
Trigger | JY7131CoreOO::JY7131CoreOOCITask
TwoEdgeSeparation | JY7131CoreOO::JY7131CoreOOCITask
TwoPulseEncoder | JY7131CoreOO::JY7131CoreOOCITask
Type | JY7131CoreOO::JY7131CoreOOCITask
~JY7131CoreOOCITask() | JY7131CoreOO::JY7131CoreOOCITask


7131 C++ Programming Manual: Member List

  • JY7131CoreOOCOTask
JY7131CoreOO::JY7131CoreOOCOTask Member List

This is the complete list of members for JY7131CoreOO::JY7131CoreOOCOTask, including all inherited members.

AvailableSamples | JY7131CoreOO::JY7131CoreOOCOTask
Device | JY7131CoreOO::JY7131CoreOOCOTask
IdleState | JY7131CoreOO::JY7131CoreOOCOTask
InitialDelay | JY7131CoreOO::JY7131CoreOOCOTask
JY7131CoreOOCOTask(int slotNum, int channel) | JY7131CoreOO::JY7131CoreOOCOTask
JY7131CoreOOCOTask(std::string boardName, int channel) | JY7131CoreOO::JY7131CoreOOCOTask
Mode | JY7131CoreOO::JY7131CoreOOCOTask
OutputTerminal | JY7131CoreOO::JY7131CoreOOCOTask
OutTerminalMode | JY7131CoreOO::JY7131CoreOOCOTask
Pause | JY7131CoreOO::JY7131CoreOOCOTask
SamplesToUpdate | JY7131CoreOO::JY7131CoreOOCOTask
SendSoftwareTrigger() | JY7131CoreOO::JY7131CoreOOCOTask
SignalExport | JY7131CoreOO::JY7131CoreOOCOTask
Start() | JY7131CoreOO::JY7131CoreOOCOTask
Stop() | JY7131CoreOO::JY7131CoreOOCOTask
Timebase | JY7131CoreOO::JY7131CoreOOCOTask
TransferedPulses | JY7131CoreOO::JY7131CoreOOCOTask
TransferedSamples | JY7131CoreOO::JY7131CoreOOCOTask
Trigger | JY7131CoreOO::JY7131CoreOOCOTask
WaitUntilDone(int timeout=-1) | JY7131CoreOO::JY7131CoreOOCOTask
WriteData(COPulse *pulsesGroup[], int samplesToWrite, int timeout=10000) | JY7131CoreOO::JY7131CoreOOCOTask
WriteSinglePoint(COPulse &pulse) | JY7131CoreOO::JY7131CoreOOCOTask
~JY7131CoreOOCOTask() | JY7131CoreOO::JY7131CoreOOCOTask


7131 C++ Programming Manual: Member List

  • JY7131CoreOODITask
JY7131CoreOO::JY7131CoreOODITask Member List

This is the complete list of members for JY7131CoreOO::JY7131CoreOODITask, including all inherited members.

AddChannel(int portNum) | JY7131CoreOO::JY7131CoreOODITask
AddChannel(std::vector< int > portsNum) | JY7131CoreOO::JY7131CoreOODITask
Channels | JY7131CoreOO::JY7131CoreOODITask
Device | JY7131CoreOO::JY7131CoreOODITask
JY7131CoreOODITask(int slotNum) | JY7131CoreOO::JY7131CoreOODITask
JY7131CoreOODITask(std::string boardName) | JY7131CoreOO::JY7131CoreOODITask
ReadSinglePoint(bool *readValues, int port, int line) | JY7131CoreOO::JY7131CoreOODITask
ReadSinglePoint(bool &readValues, int port, int line) | JY7131CoreOO::JY7131CoreOODITask
ReadSinglePoint(bool *readValues, int port) | JY7131CoreOO::JY7131CoreOODITask
ReadSinglePoint(std::vector< bool > &readValues, int port) | JY7131CoreOO::JY7131CoreOODITask
ReadSinglePoint(unsigned long *readValues) | JY7131CoreOO::JY7131CoreOODITask
ReadSinglePoint(unsigned long &readValues) | JY7131CoreOO::JY7131CoreOODITask
RemoveChannel(int portNum) | JY7131CoreOO::JY7131CoreOODITask
Start() | JY7131CoreOO::JY7131CoreOODITask
Stop() | JY7131CoreOO::JY7131CoreOODITask
~JY7131CoreOODITask() | JY7131CoreOO::JY7131CoreOODITask


7131 C++ Programming Manual: Member List

  • JY7131CoreOODOTask
JY7131CoreOO::JY7131CoreOODOTask Member List

This is the complete list of members for JY7131CoreOO::JY7131CoreOODOTask, including all inherited members.

AddChannel(int portNum) | JY7131CoreOO::JY7131CoreOODOTask
AddChannel(std::vector< int > portsNum) | JY7131CoreOO::JY7131CoreOODOTask
Channels | JY7131CoreOO::JY7131CoreOODOTask
Device | JY7131CoreOO::JY7131CoreOODOTask
DOLine_Mode | JY7131CoreOO::JY7131CoreOODOTask
JY7131CoreOODOTask(int slotNum) | JY7131CoreOO::JY7131CoreOODOTask
JY7131CoreOODOTask(std::string boardName) | JY7131CoreOO::JY7131CoreOODOTask
RemoveChannel(int portNum) | JY7131CoreOO::JY7131CoreOODOTask
SetPowerOn(DOLineMode mode[], bool writeValues[]) | JY7131CoreOO::JY7131CoreOODOTask
Start() | JY7131CoreOO::JY7131CoreOODOTask
Stop() | JY7131CoreOO::JY7131CoreOODOTask
WriteSinglePoint(bool writeValue, int port, int line) | JY7131CoreOO::JY7131CoreOODOTask
WriteSinglePoint(std::vector< bool > writeValues) | JY7131CoreOO::JY7131CoreOODOTask
WriteSinglePoint(std::vector< bool > writeValues, int port) | JY7131CoreOO::JY7131CoreOODOTask
~JY7131CoreOODOTask() | JY7131CoreOO::JY7131CoreOODOTask


7131 C++ Programming Manual: Member List

  • JY7131CoreOODevice
JY7131CoreOO::JY7131CoreOODevice Member List

This is the complete list of members for JY7131CoreOO::JY7131CoreOODevice, including all inherited members.

BoardClockRate | JY7131CoreOO::JY7131CoreOODevice |
DeviceID | JY7131CoreOO::JY7131CoreOODevice |
GetInstance(int cardNum) | JY7131CoreOO::JY7131CoreOODevice | static
GetInstance(std::string aliasName) | JY7131CoreOO::JY7131CoreOODevice | static
Handle | JY7131CoreOO::JY7131CoreOODevice |
ReferenceClock | JY7131CoreOO::JY7131CoreOODevice |
SerialNumber | JY7131CoreOO::JY7131CoreOODevice |


7131 C++ Programming Manual: Member List

  • JY7131CoreOOLog
JY7131CoreOO::JY7131CoreOOLog Member List

This is the complete list of members for JY7131CoreOO::JY7131CoreOOLog, including all inherited members.

EnableLog | JY7131CoreOO::JY7131CoreOOLog | static
Flush() | JY7131CoreOO::JY7131CoreOOLog | static
LogLevel | JY7131CoreOO::JY7131CoreOOLog | static
Print(const char *format,...) | JY7131CoreOO::JY7131CoreOOLog | static
Print(JY7131CoreOOLogLevel logLevel, const char *format,...) | JY7131CoreOO::JY7131CoreOOLog | static


7131 C++ Programming Manual: Member List

  • JY7131CoreOOProperty
JY7131CoreOO::JY7131CoreOOProperty< ContainerClass, ValueType, propertyType > Member List

This is the complete list of members for JY7131CoreOO::JY7131CoreOOProperty< ContainerClass, ValueType, propertyType >, including all inherited members.

JY7131CoreOOProperty() | JY7131CoreOO::JY7131CoreOOProperty< ContainerClass, ValueType, propertyType >
JY7131CoreOOProperty(ContainerClass *cObject, ValueType(ContainerClass::*pGet)(), void(ContainerClass::*pSet)(ValueType value)) | JY7131CoreOO::JY7131CoreOOProperty< ContainerClass, ValueType, propertyType >
JY7131CoreOOProperty(ValueType(*pGet)(), void(*pSet)(ValueType value)) | JY7131CoreOO::JY7131CoreOOProperty< ContainerClass, ValueType, propertyType >
operator ValueType() | JY7131CoreOO::JY7131CoreOOProperty< ContainerClass, ValueType, propertyType >
operator=(const ValueType &value) | JY7131CoreOO::JY7131CoreOOProperty< ContainerClass, ValueType, propertyType >


7131 C++ Programming Manual: Member List

  • JY7131CoreOOReferenceClock
JY7131CoreOO::JY7131CoreOOReferenceClock Member List

This is the complete list of members for JY7131CoreOO::JY7131CoreOOReferenceClock, including all inherited members.

Commit() | JY7131CoreOO::JY7131CoreOOReferenceClock |
External | JY7131CoreOO::JY7131CoreOOReferenceClock |
JY7131CoreOODevice class | JY7131CoreOO::JY7131CoreOOReferenceClock | friend
Source | JY7131CoreOO::JY7131CoreOOReferenceClock |


7131 C++ Programming Manual: Member List

  • JYDriverException
JY7131CoreOO::JYDriverException Member List

This is the complete list of members for JY7131CoreOO::JYDriverException, including all inherited members.

errorCode | JY7131CoreOO::JYDriverException
exceptionMessage | JY7131CoreOO::JYDriverException
FollowingException | JY7131CoreOO::JYDriverException
JYDriverException(JYDriverExceptionPublic exceptionCode, std::string msg="") | JY7131CoreOO::JYDriverException
JYDriverException(int, std::string msg) | JY7131CoreOO::JYDriverException


7131 C++ Programming Manual: Member List

  • PauseTrigger
JY7131CoreOO::PauseTrigger Member List

This is the complete list of members for JY7131CoreOO::PauseTrigger, including all inherited members.

ActivePolarity | JY7131CoreOO::PauseTrigger
Output_State | JY7131CoreOO::PauseTrigger
Terminal | JY7131CoreOO::PauseTrigger


7131 C++ Programming Manual: Member List

  • PeriodMeas
JY7131CoreOO::PeriodMeas Member List

This is the complete list of members for JY7131CoreOO::PeriodMeas, including all inherited members.

Input_Terminal | JY7131CoreOO::PeriodMeas
StartingEdge | JY7131CoreOO::PeriodMeas
Timebase | JY7131CoreOO::PeriodMeas


7131 C++ Programming Manual: Member List

  • PulseMeas
JY7131CoreOO::PulseMeas Member List

This is the complete list of members for JY7131CoreOO::PulseMeas, including all inherited members.

Input_Terminal | JY7131CoreOO::PulseMeas
StartingEdge | JY7131CoreOO::PulseMeas
Timebase | JY7131CoreOO::PulseMeas


7131 C++ Programming Manual: Member List

  • QuadEncoder
JY7131CoreOO::QuadEncoder Member List

This is the complete list of members for JY7131CoreOO::QuadEncoder, including all inherited members.

AInputTerminal | JY7131CoreOO::QuadEncoder
BInputTerminal | JY7131CoreOO::QuadEncoder
EncodingType | JY7131CoreOO::QuadEncoder
InitialCount | JY7131CoreOO::QuadEncoder
ZInputTerminal | JY7131CoreOO::QuadEncoder
ZReloadEnabled | JY7131CoreOO::QuadEncoder


7131 C++ Programming Manual: Member List

  • SemiPeriodMeas
JY7131CoreOO::SemiPeriodMeas Member List

This is the complete list of members for JY7131CoreOO::SemiPeriodMeas, including all inherited members.

Input_Terminal | JY7131CoreOO::SemiPeriodMeas
StartingEdge | JY7131CoreOO::SemiPeriodMeas
Timebase | JY7131CoreOO::SemiPeriodMeas


7131 C++ Programming Manual: Member List

  • TwoEdgeSeparation
JY7131CoreOO::TwoEdgeSeparation Member List

This is the complete list of members for JY7131CoreOO::TwoEdgeSeparation, including all inherited members.

EdgeSeparationMode | JY7131CoreOO::TwoEdgeSeparation
FirstInputTerminal | JY7131CoreOO::TwoEdgeSeparation
SecondInputTerminal | JY7131CoreOO::TwoEdgeSeparation
Timebase | JY7131CoreOO::TwoEdgeSeparation


7131 C++ Programming Manual: Member List

  • TwoPulseEncoder
JY7131CoreOO::TwoPulseEncoder Member List

This is the complete list of members for JY7131CoreOO::TwoPulseEncoder, including all inherited members.

AInputTerminal | JY7131CoreOO::TwoPulseEncoder
BInputTerminal | JY7131CoreOO::TwoPulseEncoder
InitialCount | JY7131CoreOO::TwoPulseEncoder


7131 C++ Programming Manual: Class Index

Class Index
C | D | E | F | J | P | Q | S | T
C
CIDigitalTrigger (JY7131CoreOO)
CIExternalSampleClock (JY7131CoreOO)
CIExternalTimebase (JY7131CoreOO)
CIImplicitSampleClock (JY7131CoreOO)
CIInternalSampleClock (JY7131CoreOO)
CISampleClock (JY7131CoreOO)
CISignalExport (JY7131CoreOO)
CITimebase (JY7131CoreOO)
CITrigger (JY7131CoreOO)
CODigitalTrigger (JY7131CoreOO)
COExternalTimebase (JY7131CoreOO)
COPulse (JY7131CoreOO)
COSignalExport (JY7131CoreOO)
COTimebase (JY7131CoreOO)
COTrigger (JY7131CoreOO)
D
DIChannel (JY7131CoreOO)
DOChannel (JY7131CoreOO)
E
EdgeCounting (JY7131CoreOO)
EdgeCountingOutEvent (JY7131CoreOO)
ExternalReferenceClock (JY7131CoreOO)
F
FrequencyMeas (JY7131CoreOO)
J
JY7131CoreOOCITask (JY7131CoreOO)
JY7131CoreOOCOTask (JY7131CoreOO)
JY7131CoreOODevice (JY7131CoreOO)
JY7131CoreOODITask (JY7131CoreOO)
JY7131CoreOODOTask (JY7131CoreOO)
JY7131CoreOOLog (JY7131CoreOO)
JY7131CoreOOProperty (JY7131CoreOO)
JY7131CoreOOReferenceClock (JY7131CoreOO)
JYDriverException (JY7131CoreOO)
P
PauseTrigger (JY7131CoreOO)
PeriodMeas (JY7131CoreOO)
PulseMeas (JY7131CoreOO)
Q
QuadEncoder (JY7131CoreOO)
S
SemiPeriodMeas (JY7131CoreOO)
T
TwoEdgeSeparation (JY7131CoreOO)
TwoPulseEncoder (JY7131CoreOO)


7131 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO Directory Reference

  • File List
  • File Members
  • COO
COO Directory Reference

Directories

7131


7131 C++ Programming Manual: File List

  • File List
  • File Members
File List
Here is a list of all files with brief descriptions:
[detail level 123]
▼ COO
▼ 7131
JY7131CoreOOCITask.h
JY7131CoreOOCommon.h
JY7131CoreOOCOTask.h
JY7131CoreOODevice.h
JY7131CoreOODITask.h
JY7131CoreOODOTask.h
JY7131CoreOOLog.h


7131 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • w
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- a -

  • ActiveEdge : JY7131CoreOO::EdgeCounting
  • ActivePolarity : JY7131CoreOO::PauseTrigger
  • ActualFreq : JY7131CoreOO::CITimebase, JY7131CoreOO::COTimebase
  • Add() : JY7131CoreOO::CISignalExport, JY7131CoreOO::COSignalExport
  • AddChannel() : JY7131CoreOO::JY7131CoreOODITask, JY7131CoreOO::JY7131CoreOODOTask
  • AInputTerminal : JY7131CoreOO::QuadEncoder, JY7131CoreOO::TwoPulseEncoder
  • AvailableSamples : JY7131CoreOO::JY7131CoreOOCITask, JY7131CoreOO::JY7131CoreOOCOTask

- b -

  • BInputTerminal : JY7131CoreOO::QuadEncoder, JY7131CoreOO::TwoPulseEncoder
  • BoardClockRate : JY7131CoreOO::JY7131CoreOODevice

- c -

  • Channels : JY7131CoreOO::JY7131CoreOODITask, JY7131CoreOO::JY7131CoreOODOTask
  • CITimebase() : JY7131CoreOO::CITimebase
  • Clear() : JY7131CoreOO::CISignalExport, JY7131CoreOO::COSignalExport
  • ClearAll() : JY7131CoreOO::CISignalExport, JY7131CoreOO::COSignalExport
  • Commit() : JY7131CoreOO::JY7131CoreOOReferenceClock
  • COPulse() : JY7131CoreOO::COPulse

- d -

  • Device : JY7131CoreOO::JY7131CoreOOCITask, JY7131CoreOO::JY7131CoreOOCOTask, JY7131CoreOO::JY7131CoreOODITask, JY7131CoreOO::JY7131CoreOODOTask
  • DeviceID : JY7131CoreOO::JY7131CoreOODevice
  • Digital : JY7131CoreOO::CITrigger, JY7131CoreOO::COTrigger
  • Direction : JY7131CoreOO::EdgeCounting
  • DirTerminal : JY7131CoreOO::EdgeCounting
  • DOLine_Mode : JY7131CoreOO::JY7131CoreOODOTask

- e -

  • Edge : JY7131CoreOO::CIDigitalTrigger, JY7131CoreOO::CODigitalTrigger
  • EdgeCounting : JY7131CoreOO::JY7131CoreOOCITask
  • EdgeSeparationMode : JY7131CoreOO::TwoEdgeSeparation
  • EnableLog : JY7131CoreOO::JY7131CoreOOLog
  • EncodingType : JY7131CoreOO::QuadEncoder
  • errorCode : JY7131CoreOO::JYDriverException
  • exceptionMessage : JY7131CoreOO::JYDriverException
  • ExpectedRate : JY7131CoreOO::CIExternalSampleClock, JY7131CoreOO::CIImplicitSampleClock
  • External : JY7131CoreOO::CISampleClock, JY7131CoreOO::CITimebase, JY7131CoreOO::COTimebase, JY7131CoreOO::JY7131CoreOOReferenceClock

- f -

  • FirstInputTerminal : JY7131CoreOO::TwoEdgeSeparation
  • Flush() : JY7131CoreOO::JY7131CoreOOLog
  • FollowingException : JY7131CoreOO::JYDriverException
  • Frequency : JY7131CoreOO::CIExternalTimebase, JY7131CoreOO::COExternalTimebase
  • FrequencyMeas : JY7131CoreOO::JY7131CoreOOCITask

- g -

  • GetInstance() : JY7131CoreOO::JY7131CoreOODevice

- h -

  • Handle : JY7131CoreOO::JY7131CoreOODevice

- i -

  • IdleState : JY7131CoreOO::EdgeCountingOutEvent, JY7131CoreOO::JY7131CoreOOCOTask
  • IgnoreFirstSampleClock : JY7131CoreOO::CIExternalSampleClock, JY7131CoreOO::CIInternalSampleClock
  • Implicit : JY7131CoreOO::CISampleClock
  • InitialCount : JY7131CoreOO::EdgeCounting, JY7131CoreOO::QuadEncoder, JY7131CoreOO::TwoPulseEncoder
  • InitialDelay : JY7131CoreOO::JY7131CoreOOCOTask
  • Input_Terminal : JY7131CoreOO::EdgeCounting, JY7131CoreOO::FrequencyMeas, JY7131CoreOO::PeriodMeas, JY7131CoreOO::PulseMeas, JY7131CoreOO::SemiPeriodMeas
  • Internal : JY7131CoreOO::CISampleClock

- j -

  • JY7131CoreOOCITask() : JY7131CoreOO::JY7131CoreOOCITask
  • JY7131CoreOOCOTask() : JY7131CoreOO::JY7131CoreOOCOTask
  • JY7131CoreOODevice : JY7131CoreOO::JY7131CoreOOReferenceClock
  • JY7131CoreOODITask() : JY7131CoreOO::JY7131CoreOODITask
  • JY7131CoreOODOTask() : JY7131CoreOO::JY7131CoreOODOTask
  • JY7131CoreOOProperty() : JY7131CoreOO::JY7131CoreOOProperty< ContainerClass, ValueType, propertyType >
  • JYDriverException() : JY7131CoreOO::JYDriverException

- l -

  • LogLevel : JY7131CoreOO::JY7131CoreOOLog

- m -

  • Mode : JY7131CoreOO::JY7131CoreOOCITask, JY7131CoreOO::JY7131CoreOOCOTask

- o -

  • operator ValueType() : JY7131CoreOO::JY7131CoreOOProperty< ContainerClass, ValueType, propertyType >
  • operator=() : JY7131CoreOO::JY7131CoreOOProperty< ContainerClass, ValueType, propertyType >
  • OutEvent : JY7131CoreOO::EdgeCounting
  • Output_State : JY7131CoreOO::PauseTrigger
  • OutputTerminal : JY7131CoreOO::JY7131CoreOOCOTask
  • OutTerminalMode : JY7131CoreOO::JY7131CoreOOCOTask

- p -

  • Pause : JY7131CoreOO::EdgeCounting, JY7131CoreOO::JY7131CoreOOCOTask
  • PeriodMeas : JY7131CoreOO::JY7131CoreOOCITask
  • PortNum : JY7131CoreOO::DIChannel, JY7131CoreOO::DOChannel
  • Print() : JY7131CoreOO::JY7131CoreOOLog

- q -

  • QuadEncoder : JY7131CoreOO::JY7131CoreOOCITask

- r -

  • Rate : JY7131CoreOO::CIInternalSampleClock
  • ReadData() : JY7131CoreOO::JY7131CoreOOCITask
  • ReadSinglePoint() : JY7131CoreOO::JY7131CoreOOCITask, JY7131CoreOO::JY7131CoreOODITask
  • ReferenceClock : JY7131CoreOO::JY7131CoreOODevice
  • RemoveChannel() : JY7131CoreOO::JY7131CoreOODITask, JY7131CoreOO::JY7131CoreOODOTask

- s -

  • SampleClock : JY7131CoreOO::JY7131CoreOOCITask
  • SamplesToAcquire : JY7131CoreOO::JY7131CoreOOCITask
  • SamplesToUpdate : JY7131CoreOO::JY7131CoreOOCOTask
  • SecondInputTerminal : JY7131CoreOO::TwoEdgeSeparation
  • SendSoftwareTrigger() : JY7131CoreOO::JY7131CoreOOCITask, JY7131CoreOO::JY7131CoreOOCOTask
  • SerialNumber : JY7131CoreOO::JY7131CoreOODevice
  • SetPowerOn() : JY7131CoreOO::JY7131CoreOODOTask
  • SignalExport : JY7131CoreOO::JY7131CoreOOCITask, JY7131CoreOO::JY7131CoreOOCOTask
  • Source : JY7131CoreOO::CIDigitalTrigger, JY7131CoreOO::CISampleClock, JY7131CoreOO::CITimebase, JY7131CoreOO::CODigitalTrigger, JY7131CoreOO::COTimebase, JY7131CoreOO::JY7131CoreOOReferenceClock
  • Start() : JY7131CoreOO::JY7131CoreOOCITask, JY7131CoreOO::JY7131CoreOOCOTask, JY7131CoreOO::JY7131CoreOODITask, JY7131CoreOO::JY7131CoreOODOTask
  • StartingEdge : JY7131CoreOO::FrequencyMeas, JY7131CoreOO::PeriodMeas, JY7131CoreOO::PulseMeas, JY7131CoreOO::SemiPeriodMeas
  • Stop() : JY7131CoreOO::JY7131CoreOOCITask, JY7131CoreOO::JY7131CoreOOCOTask, JY7131CoreOO::JY7131CoreOODITask, JY7131CoreOO::JY7131CoreOODOTask

- t -

  • Terminal : JY7131CoreOO::CIExternalSampleClock, JY7131CoreOO::CIExternalTimebase, JY7131CoreOO::COExternalTimebase, JY7131CoreOO::EdgeCountingOutEvent, JY7131CoreOO::ExternalReferenceClock, JY7131CoreOO::PauseTrigger
  • Threshold : JY7131CoreOO::EdgeCountingOutEvent
  • TimeBase : JY7131CoreOO::JY7131CoreOOCITask
  • Timebase : JY7131CoreOO::FrequencyMeas, JY7131CoreOO::JY7131CoreOOCOTask, JY7131CoreOO::PeriodMeas, JY7131CoreOO::PulseMeas, JY7131CoreOO::SemiPeriodMeas, JY7131CoreOO::TwoEdgeSeparation
  • TransferedPulses : JY7131CoreOO::JY7131CoreOOCOTask
  • TransferedSamples : JY7131CoreOO::JY7131CoreOOCITask, JY7131CoreOO::JY7131CoreOOCOTask
  • Trigger : JY7131CoreOO::JY7131CoreOOCITask, JY7131CoreOO::JY7131CoreOOCOTask
  • TwoEdgeSeparation : JY7131CoreOO::JY7131CoreOOCITask
  • TwoPulseEncoder : JY7131CoreOO::JY7131CoreOOCITask
  • Type : JY7131CoreOO::CITrigger, JY7131CoreOO::COTrigger, JY7131CoreOO::JY7131CoreOOCITask

- w -

  • WaitUntilDone() : JY7131CoreOO::JY7131CoreOOCOTask
  • WriteData() : JY7131CoreOO::JY7131CoreOOCOTask
  • WriteSinglePoint() : JY7131CoreOO::JY7131CoreOOCOTask, JY7131CoreOO::JY7131CoreOODOTask

- z -

  • ZInputTerminal : JY7131CoreOO::QuadEncoder
  • ZReloadEnabled : JY7131CoreOO::QuadEncoder

- ~ -

  • ~CITimebase() : JY7131CoreOO::CITimebase
  • ~JY7131CoreOOCITask() : JY7131CoreOO::JY7131CoreOOCITask
  • ~JY7131CoreOOCOTask() : JY7131CoreOO::JY7131CoreOOCOTask
  • ~JY7131CoreOODITask() : JY7131CoreOO::JY7131CoreOODITask
  • ~JY7131CoreOODOTask() : JY7131CoreOO::JY7131CoreOODOTask


7131 C++ Programming Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • c
  • f
  • g
  • j
  • o
  • p
  • r
  • s
  • w
  • ~
Here is a list of all functions with links to the classes they belong to:

- a -

  • Add() : JY7131CoreOO::CISignalExport, JY7131CoreOO::COSignalExport
  • AddChannel() : JY7131CoreOO::JY7131CoreOODITask, JY7131CoreOO::JY7131CoreOODOTask

- c -

  • CITimebase() : JY7131CoreOO::CITimebase
  • Clear() : JY7131CoreOO::CISignalExport, JY7131CoreOO::COSignalExport
  • ClearAll() : JY7131CoreOO::CISignalExport, JY7131CoreOO::COSignalExport
  • Commit() : JY7131CoreOO::JY7131CoreOOReferenceClock
  • COPulse() : JY7131CoreOO::COPulse

- f -

  • Flush() : JY7131CoreOO::JY7131CoreOOLog

- g -

  • GetInstance() : JY7131CoreOO::JY7131CoreOODevice

- j -

  • JY7131CoreOOCITask() : JY7131CoreOO::JY7131CoreOOCITask
  • JY7131CoreOOCOTask() : JY7131CoreOO::JY7131CoreOOCOTask
  • JY7131CoreOODITask() : JY7131CoreOO::JY7131CoreOODITask
  • JY7131CoreOODOTask() : JY7131CoreOO::JY7131CoreOODOTask
  • JY7131CoreOOProperty() : JY7131CoreOO::JY7131CoreOOProperty< ContainerClass, ValueType, propertyType >
  • JYDriverException() : JY7131CoreOO::JYDriverException

- o -

  • operator ValueType() : JY7131CoreOO::JY7131CoreOOProperty< ContainerClass, ValueType, propertyType >
  • operator=() : JY7131CoreOO::JY7131CoreOOProperty< ContainerClass, ValueType, propertyType >

- p -

  • Print() : JY7131CoreOO::JY7131CoreOOLog

- r -

  • ReadData() : JY7131CoreOO::JY7131CoreOOCITask
  • ReadSinglePoint() : JY7131CoreOO::JY7131CoreOOCITask, JY7131CoreOO::JY7131CoreOODITask
  • RemoveChannel() : JY7131CoreOO::JY7131CoreOODITask, JY7131CoreOO::JY7131CoreOODOTask

- s -

  • SendSoftwareTrigger() : JY7131CoreOO::JY7131CoreOOCITask, JY7131CoreOO::JY7131CoreOOCOTask
  • SetPowerOn() : JY7131CoreOO::JY7131CoreOODOTask
  • Start() : JY7131CoreOO::JY7131CoreOOCITask, JY7131CoreOO::JY7131CoreOOCOTask, JY7131CoreOO::JY7131CoreOODITask, JY7131CoreOO::JY7131CoreOODOTask
  • Stop() : JY7131CoreOO::JY7131CoreOOCITask, JY7131CoreOO::JY7131CoreOOCOTask, JY7131CoreOO::JY7131CoreOODITask, JY7131CoreOO::JY7131CoreOODOTask

- w -

  • WaitUntilDone() : JY7131CoreOO::JY7131CoreOOCOTask
  • WriteData() : JY7131CoreOO::JY7131CoreOOCOTask
  • WriteSinglePoint() : JY7131CoreOO::JY7131CoreOOCOTask, JY7131CoreOO::JY7131CoreOODOTask

- ~ -

  • ~CITimebase() : JY7131CoreOO::CITimebase
  • ~JY7131CoreOOCITask() : JY7131CoreOO::JY7131CoreOOCITask
  • ~JY7131CoreOOCOTask() : JY7131CoreOO::JY7131CoreOOCOTask
  • ~JY7131CoreOODITask() : JY7131CoreOO::JY7131CoreOODITask
  • ~JY7131CoreOODOTask() : JY7131CoreOO::JY7131CoreOODOTask


7131 C++ Programming Manual: Class Members - Related Symbols

  • All
  • Functions
  • Variables
  • Related Symbols
Here is a list of all related symbols with links to the classes they belong to:
  • JY7131CoreOODevice : JY7131CoreOO::JY7131CoreOOReferenceClock


7131 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Related Symbols
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • z
Here is a list of all variables with links to the classes they belong to:

- a -

  • ActiveEdge : JY7131CoreOO::EdgeCounting
  • ActivePolarity : JY7131CoreOO::PauseTrigger
  • ActualFreq : JY7131CoreOO::CITimebase, JY7131CoreOO::COTimebase
  • AInputTerminal : JY7131CoreOO::QuadEncoder, JY7131CoreOO::TwoPulseEncoder
  • AvailableSamples : JY7131CoreOO::JY7131CoreOOCITask, JY7131CoreOO::JY7131CoreOOCOTask

- b -

  • BInputTerminal : JY7131CoreOO::QuadEncoder, JY7131CoreOO::TwoPulseEncoder
  • BoardClockRate : JY7131CoreOO::JY7131CoreOODevice

- c -

  • Channels : JY7131CoreOO::JY7131CoreOODITask, JY7131CoreOO::JY7131CoreOODOTask

- d -

  • Device : JY7131CoreOO::JY7131CoreOOCITask, JY7131CoreOO::JY7131CoreOOCOTask, JY7131CoreOO::JY7131CoreOODITask, JY7131CoreOO::JY7131CoreOODOTask
  • DeviceID : JY7131CoreOO::JY7131CoreOODevice
  • Digital : JY7131CoreOO::CITrigger, JY7131CoreOO::COTrigger
  • Direction : JY7131CoreOO::EdgeCounting
  • DirTerminal : JY7131CoreOO::EdgeCounting
  • DOLine_Mode : JY7131CoreOO::JY7131CoreOODOTask

- e -

  • Edge : JY7131CoreOO::CIDigitalTrigger, JY7131CoreOO::CODigitalTrigger
  • EdgeCounting : JY7131CoreOO::JY7131CoreOOCITask
  • EdgeSeparationMode : JY7131CoreOO::TwoEdgeSeparation
  • EnableLog : JY7131CoreOO::JY7131CoreOOLog
  • EncodingType : JY7131CoreOO::QuadEncoder
  • errorCode : JY7131CoreOO::JYDriverException
  • exceptionMessage : JY7131CoreOO::JYDriverException
  • ExpectedRate : JY7131CoreOO::CIExternalSampleClock, JY7131CoreOO::CIImplicitSampleClock
  • External : JY7131CoreOO::CISampleClock, JY7131CoreOO::CITimebase, JY7131CoreOO::COTimebase, JY7131CoreOO::JY7131CoreOOReferenceClock

- f -

  • FirstInputTerminal : JY7131CoreOO::TwoEdgeSeparation
  • FollowingException : JY7131CoreOO::JYDriverException
  • Frequency : JY7131CoreOO::CIExternalTimebase, JY7131CoreOO::COExternalTimebase
  • FrequencyMeas : JY7131CoreOO::JY7131CoreOOCITask

- h -

  • Handle : JY7131CoreOO::JY7131CoreOODevice

- i -

  • IdleState : JY7131CoreOO::EdgeCountingOutEvent, JY7131CoreOO::JY7131CoreOOCOTask
  • IgnoreFirstSampleClock : JY7131CoreOO::CIExternalSampleClock, JY7131CoreOO::CIInternalSampleClock
  • Implicit : JY7131CoreOO::CISampleClock
  • InitialCount : JY7131CoreOO::EdgeCounting, JY7131CoreOO::QuadEncoder, JY7131CoreOO::TwoPulseEncoder
  • InitialDelay : JY7131CoreOO::JY7131CoreOOCOTask
  • Input_Terminal : JY7131CoreOO::EdgeCounting, JY7131CoreOO::FrequencyMeas, JY7131CoreOO::PeriodMeas, JY7131CoreOO::PulseMeas, JY7131CoreOO::SemiPeriodMeas
  • Internal : JY7131CoreOO::CISampleClock

- l -

  • LogLevel : JY7131CoreOO::JY7131CoreOOLog

- m -

  • Mode : JY7131CoreOO::JY7131CoreOOCITask, JY7131CoreOO::JY7131CoreOOCOTask

- o -

  • OutEvent : JY7131CoreOO::EdgeCounting
  • Output_State : JY7131CoreOO::PauseTrigger
  • OutputTerminal : JY7131CoreOO::JY7131CoreOOCOTask
  • OutTerminalMode : JY7131CoreOO::JY7131CoreOOCOTask

- p -

  • Pause : JY7131CoreOO::EdgeCounting, JY7131CoreOO::JY7131CoreOOCOTask
  • PeriodMeas : JY7131CoreOO::JY7131CoreOOCITask
  • PortNum : JY7131CoreOO::DIChannel, JY7131CoreOO::DOChannel

- q -

  • QuadEncoder : JY7131CoreOO::JY7131CoreOOCITask

- r -

  • Rate : JY7131CoreOO::CIInternalSampleClock
  • ReferenceClock : JY7131CoreOO::JY7131CoreOODevice

- s -

  • SampleClock : JY7131CoreOO::JY7131CoreOOCITask
  • SamplesToAcquire : JY7131CoreOO::JY7131CoreOOCITask
  • SamplesToUpdate : JY7131CoreOO::JY7131CoreOOCOTask
  • SecondInputTerminal : JY7131CoreOO::TwoEdgeSeparation
  • SerialNumber : JY7131CoreOO::JY7131CoreOODevice
  • SignalExport : JY7131CoreOO::JY7131CoreOOCITask, JY7131CoreOO::JY7131CoreOOCOTask
  • Source : JY7131CoreOO::CIDigitalTrigger, JY7131CoreOO::CISampleClock, JY7131CoreOO::CITimebase, JY7131CoreOO::CODigitalTrigger, JY7131CoreOO::COTimebase, JY7131CoreOO::JY7131CoreOOReferenceClock
  • StartingEdge : JY7131CoreOO::FrequencyMeas, JY7131CoreOO::PeriodMeas, JY7131CoreOO::PulseMeas, JY7131CoreOO::SemiPeriodMeas

- t -

  • Terminal : JY7131CoreOO::CIExternalSampleClock, JY7131CoreOO::CIExternalTimebase, JY7131CoreOO::COExternalTimebase, JY7131CoreOO::EdgeCountingOutEvent, JY7131CoreOO::ExternalReferenceClock, JY7131CoreOO::PauseTrigger
  • Threshold : JY7131CoreOO::EdgeCountingOutEvent
  • TimeBase : JY7131CoreOO::JY7131CoreOOCITask
  • Timebase : JY7131CoreOO::FrequencyMeas, JY7131CoreOO::JY7131CoreOOCOTask, JY7131CoreOO::PeriodMeas, JY7131CoreOO::PulseMeas, JY7131CoreOO::SemiPeriodMeas, JY7131CoreOO::TwoEdgeSeparation
  • TransferedPulses : JY7131CoreOO::JY7131CoreOOCOTask
  • TransferedSamples : JY7131CoreOO::JY7131CoreOOCITask, JY7131CoreOO::JY7131CoreOOCOTask
  • Trigger : JY7131CoreOO::JY7131CoreOOCITask, JY7131CoreOO::JY7131CoreOOCOTask
  • TwoEdgeSeparation : JY7131CoreOO::JY7131CoreOOCITask
  • TwoPulseEncoder : JY7131CoreOO::JY7131CoreOOCITask
  • Type : JY7131CoreOO::CITrigger, JY7131CoreOO::COTrigger, JY7131CoreOO::JY7131CoreOOCITask

- z -

  • ZInputTerminal : JY7131CoreOO::QuadEncoder
  • ZReloadEnabled : JY7131CoreOO::QuadEncoder


7131 C++ Programming Manual: File Members

  • File List
  • File Members
  • All
  • Macros
Here is a list of all file members with links to the files they belong to:
  • EXTERN_C : JY7131CoreOOCommon.h
  • JY7131CoreOO_API : JY7131CoreOOCommon.h


7131 C++ Programming Manual: File Members

  • File List
  • File Members
  • All
  • Macros
Here is a list of all macros with links to the files they belong to:
  • EXTERN_C : JY7131CoreOOCommon.h
  • JY7131CoreOO_API : JY7131CoreOOCommon.h


7131 C++ Programming Manual: Main Page

7131 C++ Programming Manual Documentation


7131 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • c
  • d
  • e
  • g
  • i
  • j
  • l
  • o
  • p
  • q
  • r
  • s
  • v
Here is a list of all namespace members with links to the namespace documentation for each member:

- c -

  • CIDigitalTriggerEdge : JY7131CoreOO
  • CIDigitalTriggerSource : JY7131CoreOO
  • CIMeasureType : JY7131CoreOO
  • CIMode : JY7131CoreOO
  • CISampleClockSource : JY7131CoreOO
  • CISignalExportSource : JY7131CoreOO
  • CITimebaseSource : JY7131CoreOO
  • CITriggerType : JY7131CoreOO
  • CIType : JY7131CoreOO
  • ClockTerminal : JY7131CoreOO
  • CODigitalTriggerEdge : JY7131CoreOO
  • CODigitalTriggerSource : JY7131CoreOO
  • COIdleState : JY7131CoreOO
  • COMode : JY7131CoreOO
  • COPulseType : JY7131CoreOO
  • COSignalExportSource : JY7131CoreOO
  • COTimebaseSource : JY7131CoreOO
  • COTriggerType : JY7131CoreOO
  • CountDirection : JY7131CoreOO

- d -

  • DOLineMode : JY7131CoreOO

- e -

  • EdgeCntOunEvtIdleState : JY7131CoreOO
  • EdgeType : JY7131CoreOO
  • ExternalReferenceClockTerminal : JY7131CoreOO

- g -

  • GetSignalExportDestinationString() : JY7131CoreOO

- i -

  • InputTerminal : JY7131CoreOO
  • IOTerminal : JY7131CoreOO

- j -

  • JY7131CoreOOLogLevel : JY7131CoreOO
  • JY7131CoreOOPropertyType : JY7131CoreOO
  • JYDriverExceptionPublic : JY7131CoreOO

- l -

  • LevelPolarity : JY7131CoreOO

- o -

  • OutputCompleteState : JY7131CoreOO
  • OutputState : JY7131CoreOO

- p -

  • PFITerminal : JY7131CoreOO

- q -

  • QuadEncodingType : JY7131CoreOO

- r -

  • ReferenceClockSource : JY7131CoreOO

- s -

  • SignalExportDestination : JY7131CoreOO

- v -

  • ValueReturnMode : JY7131CoreOO


7131 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
  • c
  • d
  • e
  • i
  • j
  • l
  • o
  • p
  • q
  • r
  • s
  • v
Here is a list of all namespace enums with links to the namespace documentation for each enum:

- c -

  • CIDigitalTriggerEdge : JY7131CoreOO
  • CIDigitalTriggerSource : JY7131CoreOO
  • CIMeasureType : JY7131CoreOO
  • CIMode : JY7131CoreOO
  • CISampleClockSource : JY7131CoreOO
  • CISignalExportSource : JY7131CoreOO
  • CITimebaseSource : JY7131CoreOO
  • CITriggerType : JY7131CoreOO
  • CIType : JY7131CoreOO
  • ClockTerminal : JY7131CoreOO
  • CODigitalTriggerEdge : JY7131CoreOO
  • CODigitalTriggerSource : JY7131CoreOO
  • COIdleState : JY7131CoreOO
  • COMode : JY7131CoreOO
  • COPulseType : JY7131CoreOO
  • COSignalExportSource : JY7131CoreOO
  • COTimebaseSource : JY7131CoreOO
  • COTriggerType : JY7131CoreOO
  • CountDirection : JY7131CoreOO

- d -

  • DOLineMode : JY7131CoreOO

- e -

  • EdgeCntOunEvtIdleState : JY7131CoreOO
  • EdgeType : JY7131CoreOO
  • ExternalReferenceClockTerminal : JY7131CoreOO

- i -

  • InputTerminal : JY7131CoreOO
  • IOTerminal : JY7131CoreOO

- j -

  • JY7131CoreOOLogLevel : JY7131CoreOO
  • JY7131CoreOOPropertyType : JY7131CoreOO
  • JYDriverExceptionPublic : JY7131CoreOO

- l -

  • LevelPolarity : JY7131CoreOO

- o -

  • OutputCompleteState : JY7131CoreOO
  • OutputState : JY7131CoreOO

- p -

  • PFITerminal : JY7131CoreOO

- q -

  • QuadEncodingType : JY7131CoreOO

- r -

  • ReferenceClockSource : JY7131CoreOO

- s -

  • SignalExportDestination : JY7131CoreOO

- v -

  • ValueReturnMode : JY7131CoreOO


7131 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Enumerations
Here is a list of all namespace functions with links to the namespace documentation for each function:
  • GetSignalExportDestinationString() : JY7131CoreOO


7131 C++ Programming Manual: Namespace List

  • Namespace List
  • Namespace Members
Namespace List
Here is a list of all namespaces with brief descriptions:
N JY7131CoreOO