7131 C# Programming Manual: D:/7131/C# Directory Reference

7131 C# Programming Manual
  • Main Page
  • Packages
  • Classes
  • Files
  • File List
  • 7131
  • C#
C# Directory Reference

Files

JY7131CITask.cs
JY7131COTask.cs
JY7131DITask.cs
JY7131DOTask.cs
Generated by doxygen 1.12.0


7131 C# Programming Manual: D:/7131/C#/JY7131CITask.cs File Reference

  • Packages
  • Classes
  • Files
  • File List
  • 7131
  • C#
Classes | Namespaces | Enumerations
JY7131CITask.cs File Reference

Classes

class | JY7131.JY7131CITask
JY7131 Counter Input Task. More...
class | JY7131.CISampleClock
CI Sample Clock class. More...
class | JY7131.CIInternalSampleClock
CI Internal Sample Clock Configuration Class. More...
class | JY7131.CIImplicitSampleClock
CI Implicit Sample Clock class. More...
class | JY7131.CIExternalSampleClock
CI Implicit Sample Clock class. More...
class | JY7131.CITimebase
class | JY7131.EdgeCounting
Configure CI EdgeCounting. More...
class | JY7131.EdgeCountingOutEvent
Edge counting output event configuration class. More...
class | JY7131.PauseTrigger
Pause trigger configuration class. More...
class | JY7131.FrequencyMeas
Configure CI Measure. More...
class | JY7131.PeriodMeas
Configure CI Measure. More...
class | JY7131.TwoEdgeSeparation
Configure CI Measure. More...
class | JY7131.QuadEncoder
Configure CI Measure. More...
class | JY7131.TwoPulseEncoder
Configure CI Measure. More...
class | JY7131.CITrigger
Constructor to create an CITrigger task object. More...
class | JY7131.CIDigitalTrigger
CI Digital trigger . More...
class | JY7131.CISignalExport
CI Signal Export Class. More...

Namespaces

namespace JY7131

Enumerations

enum | JY7131.CountDirection { JY7131.Up = JY7131Import.JY7131_CI_Count_Up , JY7131.Down = JY7131Import.JY7131_CI_Count_Down , JY7131.External = JY7131Import.JY7131_CI_Count_External }
Counter direction. More...
enum | JY7131.CIMode { JY7131.Single = JY7131Import.JY7131_CI_Single , JY7131.Finite = JY7131Import.JY7131_CI_Finite , JY7131.Continuous = JY7131Import.JY7131_CI_Continuous }
CIMode. More...
enum JY7131.CIType {
JY7131.EdgeCounting , JY7131.Period , JY7131.Frequency , JY7131.TwoEdgeSeparation ,
JY7131.QuadEncoder , JY7131.TwoPulseEncoder
}
Counter Input Application Type. More...
enum | JY7131.CISampleClockSource { JY7131.Implicit = JY7131Import.JY7131_CI_ImplicitClock , JY7131.Internal = JY7131Import.JY7131_CI_InternalClock , JY7131.External = JY7131Import.JY7131_CI_ExternalClock }
CI Sample Clock Source. More...
enum JY7131.ClockTerminal {
JY7131.PFI_In_0 = JY7131Import.JY7131_Clock_PFI_0 , JY7131.PFI_In_1 = JY7131Import.JY7131_Clock_PFI_1 , JY7131.PFI_In_2 = JY7131Import.JY7131_Clock_PFI_2 , JY7131.PFI_In_3 = JY7131Import.JY7131_Clock_PFI_3 ,
JY7131.PFI_In_4 = JY7131Import.JY7131_Clock_PFI_4 , JY7131.PFI_In_5 = JY7131Import.JY7131_Clock_PFI_5 , JY7131.PFI_In_6 = JY7131Import.JY7131_Clock_PFI_6 , JY7131.PFI_In_7 = JY7131Import.JY7131_Clock_PFI_7 ,
JY7131.PFI_In_8 = JY7131Import.JY7131_Clock_PFI_8 , JY7131.PFI_In_9 = JY7131Import.JY7131_Clock_PFI_9 , JY7131.PFI_In_10 = JY7131Import.JY7131_Clock_PFI_10 , JY7131.PFI_In_11 = JY7131Import.JY7131_Clock_PFI_11 ,
JY7131.PFI_In_12 = JY7131Import.JY7131_Clock_PFI_12 , JY7131.PFI_In_13 = JY7131Import.JY7131_Clock_PFI_13 , JY7131.PFI_In_14 = JY7131Import.JY7131_Clock_PFI_14 , JY7131.PFI_In_15 = JY7131Import.JY7131_Clock_PFI_15 ,
JY7131.PFI_In_16 = JY7131Import.JY7131_Clock_PFI_16 , JY7131.PFI_In_17 = JY7131Import.JY7131_Clock_PFI_17 , JY7131.PFI_In_18 = JY7131Import.JY7131_Clock_PFI_18 , JY7131.PFI_In_19 = JY7131Import.JY7131_Clock_PFI_19 ,
JY7131.PFI_In_20 = JY7131Import.JY7131_Clock_PFI_20 , JY7131.PFI_In_21 = JY7131Import.JY7131_Clock_PFI_21 , JY7131.PFI_In_22 = JY7131Import.JY7131_Clock_PFI_22 , JY7131.PFI_In_23 = JY7131Import.JY7131_Clock_PFI_23 ,
JY7131.PFI_In_24 = JY7131Import.JY7131_Clock_PFI_24 , JY7131.PFI_In_25 = JY7131Import.JY7131_Clock_PFI_25 , JY7131.PFI_In_26 = JY7131Import.JY7131_Clock_PFI_26 , JY7131.PFI_In_27 = JY7131Import.JY7131_Clock_PFI_27 ,
JY7131.PFI_In_28 = JY7131Import.JY7131_Clock_PFI_28 , JY7131.PFI_In_29 = JY7131Import.JY7131_Clock_PFI_29 , JY7131.PFI_In_30 = JY7131Import.JY7131_Clock_PFI_30 , JY7131.PFI_In_31 = JY7131Import.JY7131_Clock_PFI_31 ,
JY7131.PXI_Trig0 = JY7131Import.JY7131_Clock_PXI_Trig_0 , JY7131.PXI_Trig1 = JY7131Import.JY7131_Clock_PXI_Trig_1 , JY7131.PXI_Trig2 = JY7131Import.JY7131_Clock_PXI_Trig_2 , JY7131.PXI_Trig3 = JY7131Import.JY7131_Clock_PXI_Trig_3 ,
JY7131.PXI_Trig4 = JY7131Import.JY7131_Clock_PXI_Trig_4 , JY7131.PXI_Trig5 = JY7131Import.JY7131_Clock_PXI_Trig_5 , JY7131.PXI_Trig6 = JY7131Import.JY7131_Clock_PXI_Trig_6 , JY7131.PXI_Trig7 = JY7131Import.JY7131_Clock_PXI_Trig_7 ,
JY7131.CI0_SampleClock = JY7131Import.JY7131_Clock_CIO_0_SampleClock , JY7131.CI1_SampleClock = JY7131Import.JY7131_Clock_CIO_1_SampleClock , JY7131.CI2_SampleClock = JY7131Import.JY7131_Clock_CIO_2_SampleClock , JY7131.CI3_SampleClock = JY7131Import.JY7131_Clock_CIO_3_SampleClock ,
JY7131.CI4_SampleClock = JY7131Import.JY7131_Clock_CIO_4_SampleClock , JY7131.CI5_SampleClock = JY7131Import.JY7131_Clock_CIO_5_SampleClock , JY7131.CI6_SampleClock = JY7131Import.JY7131_Clock_CIO_6_SampleClock , JY7131.CI7_SampleClock = JY7131Import.JY7131_Clock_CIO_7_SampleClock ,
JY7131.CO0_Output = JY7131Import.JY7131_Clock_Counter_0_Output , JY7131.CO1_Output = JY7131Import.JY7131_Clock_Counter_1_Output , JY7131.CO2_Output = JY7131Import.JY7131_Clock_Counter_2_Output , JY7131.CO3_Output = JY7131Import.JY7131_Clock_Counter_3_Output ,
JY7131.CO4_Output = JY7131Import.JY7131_Clock_Counter_4_Output , JY7131.CO5_Output = JY7131Import.JY7131_Clock_Counter_5_Output , JY7131.CO6_Output = JY7131Import.JY7131_Clock_Counter_6_Output , JY7131.CO7_Output = JY7131Import.JY7131_Clock_Counter_7_Output
}
External Sample Clock Terminal. More...
enum | JY7131.EdgeType { JY7131.Rising = JY7131Import.JY7131_RisingEdge , JY7131.Falling = JY7131Import.JY7131_FallingEdge , JY7131.Any = JY7131Import.JY7131_AnyEdge }
Edge Type. More...
enum | JY7131.CITimebaseSource { JY7131.Internal100MHz = JY7131Import.JY7131_Internal_Timebase_100M , JY7131.Internal5MHz = JY7131Import.JY7131_Internal_Timebase_5M , JY7131.Internal100kHz = JY7131Import.JY7131_Internal_Timebase_100K }
enum | JY7131.EdgeCntOunEvtIdleState { JY7131.LowLevel = JY7131Import.JY7131_CI_CounterEventSignalIdleState_Low , JY7131.HighLevel = JY7131Import.JY7131_CI_CounterEventSignalIdleState_High }
Output idle state when the event has not occurred. More...
enum | JY7131.LevelPolarity { JY7131.LowLevel = 0 , JY7131.HighLevel = 1 , JY7131.None = 2 }
Level Polarity. More...
enum | JY7131.ValueReturnMode { JY7131.TwoValue = JY7131Import.JY7131_CI_ReturnTwoValue , JY7131.OneValue = JY7131Import.JY7131_CI_ReturnOneValue }
TwoEdgeSeparation value return mode.only for TwoEdgeSeparation type. More...
enum | JY7131.QuadEncodingType { JY7131.X1 , JY7131.X2 , JY7131.X4 }
Quadrature Encoding Type. More...
enum | JY7131.CITriggerType { JY7131.Immediate = JY7131Import.JY7131_CIO_Immediately , JY7131.Digital = JY7131Import.JY7131_CIO_Digital , JY7131.Soft = JY7131Import.JY7131_CIO_Soft }
TriggerType Digital/Immediate/Soft. More...
enum JY7131.CIDigitalTriggerSource {
JY7131.PFI_In_0 = JY7131Import.JY7131_DigitalTriggerSource_PFI_0 , JY7131.PFI_In_1 = JY7131Import.JY7131_DigitalTriggerSource_PFI_1 , JY7131.PFI_In_2 = JY7131Import.JY7131_DigitalTriggerSource_PFI_2 , JY7131.PFI_In_3 = JY7131Import.JY7131_DigitalTriggerSource_PFI_3 ,
JY7131.PFI_In_4 = JY7131Import.JY7131_DigitalTriggerSource_PFI_4 , JY7131.PFI_In_5 = JY7131Import.JY7131_DigitalTriggerSource_PFI_5 , JY7131.PFI_In_6 = JY7131Import.JY7131_DigitalTriggerSource_PFI_6 , JY7131.PFI_In_7 = JY7131Import.JY7131_DigitalTriggerSource_PFI_7 ,
JY7131.PFI_In_8 = JY7131Import.JY7131_DigitalTriggerSource_PFI_8 , JY7131.PFI_In_9 = JY7131Import.JY7131_DigitalTriggerSource_PFI_9 , JY7131.PFI_In_10 = JY7131Import.JY7131_DigitalTriggerSource_PFI_10 , JY7131.PFI_In_11 = JY7131Import.JY7131_DigitalTriggerSource_PFI_11 ,
JY7131.PFI_In_12 = JY7131Import.JY7131_DigitalTriggerSource_PFI_12 , JY7131.PFI_In_13 = JY7131Import.JY7131_DigitalTriggerSource_PFI_13 , JY7131.PFI_In_14 = JY7131Import.JY7131_DigitalTriggerSource_PFI_14 , JY7131.PFI_In_15 = JY7131Import.JY7131_DigitalTriggerSource_PFI_15 ,
JY7131.PFI_In_16 = JY7131Import.JY7131_DigitalTriggerSource_PFI_16 , JY7131.PFI_In_17 = JY7131Import.JY7131_DigitalTriggerSource_PFI_17 , JY7131.PFI_In_18 = JY7131Import.JY7131_DigitalTriggerSource_PFI_18 , JY7131.PFI_In_19 = JY7131Import.JY7131_DigitalTriggerSource_PFI_19 ,
JY7131.PFI_In_20 = JY7131Import.JY7131_DigitalTriggerSource_PFI_20 , JY7131.PFI_In_21 = JY7131Import.JY7131_DigitalTriggerSource_PFI_21 , JY7131.PFI_In_22 = JY7131Import.JY7131_DigitalTriggerSource_PFI_22 , JY7131.PFI_In_23 = JY7131Import.JY7131_DigitalTriggerSource_PFI_23 ,
JY7131.PFI_In_24 = JY7131Import.JY7131_DigitalTriggerSource_PFI_24 , JY7131.PFI_In_25 = JY7131Import.JY7131_DigitalTriggerSource_PFI_25 , JY7131.PFI_In_26 = JY7131Import.JY7131_DigitalTriggerSource_PFI_26 , JY7131.PFI_In_27 = JY7131Import.JY7131_DigitalTriggerSource_PFI_27 ,
JY7131.PFI_In_28 = JY7131Import.JY7131_DigitalTriggerSource_PFI_28 , JY7131.PFI_In_29 = JY7131Import.JY7131_DigitalTriggerSource_PFI_29 , JY7131.PFI_In_30 = JY7131Import.JY7131_DigitalTriggerSource_PFI_30 , JY7131.PFI_In_31 = JY7131Import.JY7131_DigitalTriggerSource_PFI_31 ,
JY7131.PXI_Trig0 = JY7131Import.JY7131_DigitalTriggerSource_PXI_Trig_0 , JY7131.PXI_Trig1 = JY7131Import.JY7131_DigitalTriggerSource_PXI_Trig_1 , JY7131.PXI_Trig2 = JY7131Import.JY7131_DigitalTriggerSource_PXI_Trig_2 , JY7131.PXI_Trig3 = JY7131Import.JY7131_DigitalTriggerSource_PXI_Trig_3 ,
JY7131.PXI_Trig4 = JY7131Import.JY7131_DigitalTriggerSource_PXI_Trig_4 , JY7131.PXI_Trig5 = JY7131Import.JY7131_DigitalTriggerSource_PXI_Trig_5 , JY7131.PXI_Trig6 = JY7131Import.JY7131_DigitalTriggerSource_PXI_Trig_6 , JY7131.PXI_Trig7 = JY7131Import.JY7131_DigitalTriggerSource_PXI_Trig_7 ,
JY7131.CIO_0_StartTrig = JY7131Import.JY7131_DigitalTriggerSource_CIO_0_StartTrig , JY7131.CIO_1_StartTrig = JY7131Import.JY7131_DigitalTriggerSource_CIO_1_StartTrig , JY7131.CIO_2_StartTrig = JY7131Import.JY7131_DigitalTriggerSource_CIO_2_StartTrig , JY7131.CIO_3_StartTrig = JY7131Import.JY7131_DigitalTriggerSource_CIO_3_StartTrig ,
JY7131.CIO_4_StartTrig = JY7131Import.JY7131_DigitalTriggerSource_CIO_4_StartTrig , JY7131.CIO_5_StartTrig = JY7131Import.JY7131_DigitalTriggerSource_CIO_5_StartTrig , JY7131.CIO_6_StartTrig = JY7131Import.JY7131_DigitalTriggerSource_CIO_6_StartTrig , JY7131.CIO_7_StartTrig = JY7131Import.JY7131_DigitalTriggerSource_CIO_7_StartTrig ,
JY7131.CO_0_OutPut = JY7131Import.JY7131_DigitalTriggerSource_Counter_0_Output , JY7131.CO_1_OutPut = JY7131Import.JY7131_DigitalTriggerSource_Counter_1_Output , JY7131.CO_2_OutPut = JY7131Import.JY7131_DigitalTriggerSource_Counter_2_Output , JY7131.CO_3_OutPut = JY7131Import.JY7131_DigitalTriggerSource_Counter_3_Output ,
JY7131.CO_4_OutPut = JY7131Import.JY7131_DigitalTriggerSource_Counter_4_Output , JY7131.CO_5_OutPut = JY7131Import.JY7131_DigitalTriggerSource_Counter_5_Output , JY7131.CO_6_OutPut = JY7131Import.JY7131_DigitalTriggerSource_Counter_6_Output , JY7131.CO_7_OutPut = JY7131Import.JY7131_DigitalTriggerSource_Counter_7_Output
}
CI Digital trigger source. More...
enum | JY7131.CIDigitalTriggerEdge { JY7131.Rising , JY7131.Falling }
CI Digital Trigger Edge. More...
enum JY7131.InputTerminal {
JY7131.PFI_In_0 = JY7131Import.JY7131_IN_PFI0 , JY7131.PFI_In_1 = JY7131Import.JY7131_IN_PFI1 , JY7131.PFI_In_2 = JY7131Import.JY7131_IN_PFI2 , JY7131.PFI_In_3 = JY7131Import.JY7131_IN_PFI3 ,
JY7131.PFI_In_4 = JY7131Import.JY7131_IN_PFI4 , JY7131.PFI_In_5 = JY7131Import.JY7131_IN_PFI5 , JY7131.PFI_In_6 = JY7131Import.JY7131_IN_PFI6 , JY7131.PFI_In_7 = JY7131Import.JY7131_IN_PFI7 ,
JY7131.PFI_In_8 = JY7131Import.JY7131_IN_PFI8 , JY7131.PFI_In_9 = JY7131Import.JY7131_IN_PFI9 , JY7131.PFI_In_10 = JY7131Import.JY7131_IN_PFI10 , JY7131.PFI_In_11 = JY7131Import.JY7131_IN_PFI11 ,
JY7131.PFI_In_12 = JY7131Import.JY7131_IN_PFI12 , JY7131.PFI_In_13 = JY7131Import.JY7131_IN_PFI13 , JY7131.PFI_In_14 = JY7131Import.JY7131_IN_PFI14 , JY7131.PFI_In_15 = JY7131Import.JY7131_IN_PFI15 ,
JY7131.PFI_In_16 = JY7131Import.JY7131_IN_PFI16 , JY7131.PFI_In_17 = JY7131Import.JY7131_IN_PFI17 , JY7131.PFI_In_18 = JY7131Import.JY7131_IN_PFI18 , JY7131.PFI_In_19 = JY7131Import.JY7131_IN_PFI19 ,
JY7131.PFI_In_20 = JY7131Import.JY7131_IN_PFI20 , JY7131.PFI_In_21 = JY7131Import.JY7131_IN_PFI21 , JY7131.PFI_In_22 = JY7131Import.JY7131_IN_PFI22 , JY7131.PFI_In_23 = JY7131Import.JY7131_IN_PFI23 ,
JY7131.PFI_In_24 = JY7131Import.JY7131_IN_PFI24 , JY7131.PFI_In_25 = JY7131Import.JY7131_IN_PFI25 , JY7131.PFI_In_26 = JY7131Import.JY7131_IN_PFI26 , JY7131.PFI_In_27 = JY7131Import.JY7131_IN_PFI27 ,
JY7131.PFI_In_28 = JY7131Import.JY7131_IN_PFI28 , JY7131.PFI_In_29 = JY7131Import.JY7131_IN_PFI29 , JY7131.PFI_In_30 = JY7131Import.JY7131_IN_PFI30 , JY7131.PFI_In_31 = JY7131Import.JY7131_IN_PFI31 ,
JY7131.PXI_Trig0 = JY7131Import.JY7131_IN_PXI_Trig_0 , JY7131.PXI_Trig1 = JY7131Import.JY7131_IN_PXI_Trig_1 , JY7131.PXI_Trig2 = JY7131Import.JY7131_IN_PXI_Trig_2 , JY7131.PXI_Trig3 = JY7131Import.JY7131_IN_PXI_Trig_3 ,
JY7131.PXI_Trig4 = JY7131Import.JY7131_IN_PXI_Trig_4 , JY7131.PXI_Trig5 = JY7131Import.JY7131_IN_PXI_Trig_5 , JY7131.PXI_Trig6 = JY7131Import.JY7131_IN_PXI_Trig_6 , JY7131.PXI_Trig7 = JY7131Import.JY7131_IN_PXI_Trig_7 ,
JY7131.CI_0_OutPut = JY7131Import.JY7131_IN_Counter_0_Output , JY7131.CI_1_OutPut = JY7131Import.JY7131_IN_Counter_1_Output , JY7131.CI_2_OutPut = JY7131Import.JY7131_IN_Counter_2_Output , JY7131.CI_3_OutPut = JY7131Import.JY7131_IN_Counter_3_Output ,
JY7131.CI_4_OutPut = JY7131Import.JY7131_IN_Counter_4_Output , JY7131.CI_5_OutPut = JY7131Import.JY7131_IN_Counter_5_Output , JY7131.CI_6_OutPut = JY7131Import.JY7131_IN_Counter_6_Output , JY7131.CI_7_OutPut = JY7131Import.JY7131_IN_Counter_7_Output ,
JY7131.Timebase_100MHz = JY7131Import.JY7131_IN_CIO_100MHz , JY7131.Timebase_5MHz = JY7131Import.JY7131_IN_CIO_5MHz , JY7131.Timebase_100kHz = JY7131Import.JY7131_IN_CIO_100kHz
}
enum JY7131.IOTerminal {
JY7131.None = JY7131Import.JY7131_None , JY7131.PFI_Out_0 = JY7131Import.JY7131_IN_PFI0 , JY7131.PFI_Out_1 = JY7131Import.JY7131_IN_PFI1 , JY7131.PFI_Out_2 = JY7131Import.JY7131_IN_PFI2 ,
JY7131.PFI_Out_3 = JY7131Import.JY7131_IN_PFI3 , JY7131.PFI_Out_4 = JY7131Import.JY7131_IN_PFI4 , JY7131.PFI_Out_5 = JY7131Import.JY7131_IN_PFI5 , JY7131.PFI_Out_6 = JY7131Import.JY7131_IN_PFI6 ,
JY7131.PFI_Out_7 = JY7131Import.JY7131_IN_PFI7 , JY7131.PFI_Out_8 = JY7131Import.JY7131_IN_PFI8 , JY7131.PFI_Out_9 = JY7131Import.JY7131_IN_PFI9 , JY7131.PFI_Out_10 = JY7131Import.JY7131_IN_PFI10 ,
JY7131.PFI_Out_11 = JY7131Import.JY7131_IN_PFI11 , JY7131.PFI_Out_12 = JY7131Import.JY7131_IN_PFI12 , JY7131.PFI_Out_13 = JY7131Import.JY7131_IN_PFI13 , JY7131.PFI_Out_14 = JY7131Import.JY7131_IN_PFI14 ,
JY7131.PFI_Out_15 = JY7131Import.JY7131_IN_PFI15 , JY7131.PFI_Out_16 = JY7131Import.JY7131_IN_PFI16 , JY7131.PFI_Out_17 = JY7131Import.JY7131_IN_PFI17 , JY7131.PFI_Out_18 = JY7131Import.JY7131_IN_PFI18 ,
JY7131.PFI_Out_19 = JY7131Import.JY7131_IN_PFI19 , JY7131.PFI_Out_20 = JY7131Import.JY7131_IN_PFI20 , JY7131.PFI_Out_21 = JY7131Import.JY7131_IN_PFI21 , JY7131.PFI_Out_22 = JY7131Import.JY7131_IN_PFI22 ,
JY7131.PFI_Out_23 = JY7131Import.JY7131_IN_PFI23 , JY7131.PFI_Out_24 = JY7131Import.JY7131_IN_PFI24 , JY7131.PFI_Out_25 = JY7131Import.JY7131_IN_PFI25 , JY7131.PFI_Out_26 = JY7131Import.JY7131_IN_PFI26 ,
JY7131.PFI_Out_27 = JY7131Import.JY7131_IN_PFI27 , JY7131.PFI_Out_28 = JY7131Import.JY7131_IN_PFI28 , JY7131.PFI_Out_29 = JY7131Import.JY7131_IN_PFI29 , JY7131.PFI_Out_30 = JY7131Import.JY7131_IN_PFI30 ,
JY7131.PFI_Out_31 = JY7131Import.JY7131_IN_PFI31 , JY7131.PXI_Trig0 = JY7131Import.JY7131_IN_PXI_Trig_0 , JY7131.PXI_Trig1 = JY7131Import.JY7131_IN_PXI_Trig_1 , JY7131.PXI_Trig2 = JY7131Import.JY7131_IN_PXI_Trig_2 ,
JY7131.PXI_Trig3 = JY7131Import.JY7131_IN_PXI_Trig_3 , JY7131.PXI_Trig4 = JY7131Import.JY7131_IN_PXI_Trig_4 , JY7131.PXI_Trig5 = JY7131Import.JY7131_IN_PXI_Trig_5 , JY7131.PXI_Trig6 = JY7131Import.JY7131_IN_PXI_Trig_6 ,
JY7131.PXI_Trig7 = JY7131Import.JY7131_IN_PXI_Trig_7
}
enum JY7131.SignalExportDestination {
JY7131.PFI_In_0 = JY7131Import.JY7131_PFI0_OUT , JY7131.PFI_In_1 = JY7131Import.JY7131_PFI1_OUT , JY7131.PFI_In_2 = JY7131Import.JY7131_PFI2_OUT , JY7131.PFI_In_3 = JY7131Import.JY7131_PFI3_OUT ,
JY7131.PFI_In_4 = JY7131Import.JY7131_PFI4_OUT , JY7131.PFI_In_5 = JY7131Import.JY7131_PFI5_OUT , JY7131.PFI_In_6 = JY7131Import.JY7131_PFI6_OUT , JY7131.PFI_In_7 = JY7131Import.JY7131_PFI7_OUT ,
JY7131.PFI_In_8 = JY7131Import.JY7131_PFI8_OUT , JY7131.PFI_In_9 = JY7131Import.JY7131_PFI9_OUT , JY7131.PFI_In_10 = JY7131Import.JY7131_PFI10_OUT , JY7131.PFI_In_11 = JY7131Import.JY7131_PFI11_OUT ,
JY7131.PFI_In_12 = JY7131Import.JY7131_PFI12_OUT , JY7131.PFI_In_13 = JY7131Import.JY7131_PFI13_OUT , JY7131.PFI_In_14 = JY7131Import.JY7131_PFI14_OUT , JY7131.PFI_In_15 = JY7131Import.JY7131_PFI15_OUT ,
JY7131.PFI_In_16 = JY7131Import.JY7131_PFI16_OUT , JY7131.PFI_In_17 = JY7131Import.JY7131_PFI17_OUT , JY7131.PFI_In_18 = JY7131Import.JY7131_PFI18_OUT , JY7131.PFI_In_19 = JY7131Import.JY7131_PFI19_OUT ,
JY7131.PFI_In_20 = JY7131Import.JY7131_PFI20_OUT , JY7131.PFI_In_21 = JY7131Import.JY7131_PFI21_OUT , JY7131.PFI_In_22 = JY7131Import.JY7131_PFI22_OUT , JY7131.PFI_In_23 = JY7131Import.JY7131_PFI23_OUT ,
JY7131.PFI_In_24 = JY7131Import.JY7131_PFI24_OUT , JY7131.PFI_In_25 = JY7131Import.JY7131_PFI25_OUT , JY7131.PFI_In_26 = JY7131Import.JY7131_PFI26_OUT , JY7131.PFI_In_27 = JY7131Import.JY7131_PFI27_OUT ,
JY7131.PFI_In_28 = JY7131Import.JY7131_PFI28_OUT , JY7131.PFI_In_29 = JY7131Import.JY7131_PFI29_OUT , JY7131.PFI_In_30 = JY7131Import.JY7131_PFI30_OUT , JY7131.PFI_In_31 = JY7131Import.JY7131_PFI31_OUT ,
JY7131.PXI_Trig0 = JY7131Import.JY7131_PXITrig0_OUT , JY7131.PXI_Trig1 = JY7131Import.JY7131_PXITrig1_OUT , JY7131.PXI_Trig2 = JY7131Import.JY7131_PXITrig2_OUT , JY7131.PXI_Trig3 = JY7131Import.JY7131_PXITrig3_OUT ,
JY7131.PXI_Trig4 = JY7131Import.JY7131_PXITrig4_OUT , JY7131.PXI_Trig5 = JY7131Import.JY7131_PXITrig5_OUT , JY7131.PXI_Trig6 = JY7131Import.JY7131_PXITrig6_OUT , JY7131.PXI_Trig7 = JY7131Import.JY7131_PXITrig7_OUT
}
Output DestinationTerminal. More...
enum | JY7131.CISignalExportSource { JY7131.StartTrig , JY7131.SampleClock }
SourceSignal. More...


7131 C# Programming Manual: JY7131.JY7131CITask Class Reference

  • Class List
  • Class Index
  • Class Members
  • JY7131
  • JY7131CITask
Public Member Functions | Properties | List of all members
JY7131.JY7131CITask Class Referencesealed

JY7131 Counter Input Task. More...

Public Member Functions

JY7131CITask (int slotNum, int channel)
Constructor.
JY7131CITask (string boardName, int channel)
Constructor.
void | Start ()
Start CI task .
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Stop ()
Stop CI task .
void | ReadSinglePoint (ref uint count)
Read a signle count value from register, Available when Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder
void | ReadData (ref uint[] bufCount, int samplesToAcquire, int timeout=10000)
Read counter values from buffer.
void | ReadData (ref uint[] bufCount, int timeout=10000)
Read counter values from buffer.
void | ReadData (ref double[] bufMeasurement, int samplesToAcquire, int timeout=10000)
Read frequency value or period value from buffer.
void | ReadData (ref double[] bufMeasurement, int timeout=10000)
Read frequency value or period value from buffer.
void | ReadSinglePoint (ref double measurement, int timeout=10000)
Read a signle frequency value or period value from register.
void | ReadSinglePoint (ref double measurement1, ref double measurement2, int timeout=10000)
Read a signle measurement of pulse's duration value, or two-edge separtion value (two results at a time) from register.
void | ReadData (ref double[] bufMeasurement1, ref double[] bufMeasurement2, int samplesToAcquire, int timeout=10000)
Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.
void | ReadData (ref double[] bufMeasurement1, ref double[] bufMeasurement2, int timeout=10000)
Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.

Properties

CIType | Type [get, set]
CI Application types.
ulong | AvailableSamples [get]
Number of points per channel that can be read in the buffer .
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel).
CIMode | Mode [get, set]
CI Sampling mode，support Single/Finite/Continuous.
CISampleClock | SampleClock [get, set]
Clock Source.
uint | SamplesToAcquire [get, set]
Number of samples to be read per channel.Only valid when Mode is CIMode.Finite.
EdgeCounting | EdgeCounting [get, set]
Edge Counting Configuration.
FrequencyMeas | FrequencyMeas [get, set]
Frequency Measurement Configuration.
PeriodMeas | PeriodMeas [get, set]
Period Measurement Configuration.
TwoEdgeSeparation | TwoEdgeSeparation [get, set]
TwoEdgeSeparation.
QuadEncoder | QuadEncoder [get, set]
QuadEncoder.
TwoPulseEncoder | TwoPulseEncoder [get, set]
TwoPulseEncoder.
CITrigger | Trigger = new CITrigger() [get, set]
CI Trigger Configuration.
CISignalExport | SignalExport [get, set]
Export CI Signal Configuration.
JY7131Device | Device [get]
Device.

Detailed Description

JY7131 Counter Input Task.

Constructor & Destructor Documentation

◆ JY7131CITask() [1/2]

JY7131.JY7131CITask.JY7131CITask | ( | int | slotNum,
 |  | int | channel )

Constructor.

Used to create an CI task by a slot number.

Parameters
slotNum | Card slot number.
channel | Counter channel （5510 5511 support0-3,5515 5516 suppor0-1

◆ JY7131CITask() [2/2]

JY7131.JY7131CITask.JY7131CITask | ( | string | boardName,
 |  | int | channel )

Constructor.

Used to create an CI task by a board name.

Parameters
boardName | Board name(device alias), set by device manager
channel | Counter channel （5510 5511 support0-3,5515 5516 suppor0-1）.

Member Function Documentation

◆ ReadData() [1/6]

void JY7131.JY7131CITask.ReadData | ( | ref double[] | bufMeasurement,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read frequency value or period value from buffer.

Available when JY7131CITask.Mode is NOT CIMode.Single, and Type is CIType.Frequency or CIType.Period.

Parameters
bufMeasurement | Buffer for reading data. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period in seconds when Type is CIType.Period.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [2/6]

void JY7131.JY7131CITask.ReadData | ( | ref double[] | bufMeasurement,
 |  | int | timeout = 10000 )

Read frequency value or period value from buffer.

Available when JY7131CITask.Mode is NOT CIMode.Single, and Type is CIType.Frequency or CIType.Period.

Parameters
bufMeasurement | Buffer for reading data. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period in seconds when Type is CIType.Period.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [3/6]

void JY7131.JY7131CITask.ReadData | ( | ref double[] | bufMeasurement1,
 |  | ref double[] | bufMeasurement2,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.

. Available when JY7131CITask.Mode is NOT CIMode.Single, Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
bufMeasurement1 | Buffer for reading data. Indicates high level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
bufMeasurement2 | Buffer for reading data. Indicates low level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [4/6]

void JY7131.JY7131CITask.ReadData | ( | ref double[] | bufMeasurement1,
 |  | ref double[] | bufMeasurement2,
 |  | int | timeout = 10000 )

Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.

. Available when JY7131CITask.Mode is NOT CIMode.Single, Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
bufMeasurement1 | Buffer for reading data. Indicates high level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
bufMeasurement2 | Buffer for reading data. Indicates low level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [5/6]

void JY7131.JY7131CITask.ReadData | ( | ref uint[] | bufCount,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read counter values from buffer.

Available when JY7131CITask.Mode is NOT CIMode.Single, and Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder

Parameters
bufCount | Buffer for reading data.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [6/6]

void JY7131.JY7131CITask.ReadData | ( | ref uint[] | bufCount,
 |  | int | timeout = 10000 )

Read counter values from buffer.

Available when JY7131CITask.Mode is NOT CIMode.Single, and Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder

Parameters
bufCount | Buffer for reading data.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [1/3]

void JY7131.JY7131CITask.ReadSinglePoint | ( | ref double | measurement,
 |  | int | timeout = 10000 )

Read a signle frequency value or period value from register.

Valid when Type is CIType.Frequency or CIType.Period.

Parameters
measurement Measurement value. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period is seconds when Type is CIType.Period.
timeout
Timeout (ms). Wait until the measurement is completed or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [2/3]

void JY7131.JY7131CITask.ReadSinglePoint | ( | ref double | measurement1,
 |  | ref double | measurement2,
 |  | int | timeout = 10000 )

Read a signle measurement of pulse's duration value, or two-edge separtion value (two results at a time) from register.

Available when Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
measurement1 | Measurement Value 1. Indicates low level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
measurement2 | Measurement Value 2. Indicates high level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
timeout
Timeout (ms). Wait until the measurement is completed or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [3/3]

void JY7131.JY7131CITask.ReadSinglePoint ( ref uint count )

Read a signle count value from register, Available when Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder

Parameters
count counter value。

◆ SendSoftwareTrigger()

void JY7131.JY7131CITask.SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY7131.JY7131CITask.Start ( )

Start CI task .

◆ Stop()

void JY7131.JY7131CITask.Stop ( )

Stop CI task .

Property Documentation

◆ AvailableSamples

ulong JY7131.JY7131CITask.AvailableSamples
get

Number of points per channel that can be read in the buffer .

◆ Device

JY7131Device JY7131.JY7131CITask.Device
get

Device.

◆ EdgeCounting

EdgeCounting JY7131.JY7131CITask.EdgeCounting
getset

Edge Counting Configuration.

◆ FrequencyMeas

FrequencyMeas JY7131.JY7131CITask.FrequencyMeas
getset

Frequency Measurement Configuration.

◆ Mode

CIMode JY7131.JY7131CITask.Mode
getset

CI Sampling mode，support Single/Finite/Continuous.

◆ PeriodMeas

PeriodMeas JY7131.JY7131CITask.PeriodMeas
getset

Period Measurement Configuration.

◆ QuadEncoder

QuadEncoder JY7131.JY7131CITask.QuadEncoder
getset

QuadEncoder.

◆ SampleClock

CISampleClock JY7131.JY7131CITask.SampleClock
getset

Clock Source.

◆ SamplesToAcquire

uint JY7131.JY7131CITask.SamplesToAcquire
getset

Number of samples to be read per channel.Only valid when Mode is CIMode.Finite.

◆ SignalExport

CISignalExport JY7131.JY7131CITask.SignalExport
getset

Export CI Signal Configuration.

◆ TransferedSamples

ulong JY7131.JY7131CITask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT CIMode.Single.

◆ Trigger

CITrigger JY7131.JY7131CITask.Trigger = new CITrigger()
getset

CI Trigger Configuration.

◆ TwoEdgeSeparation

TwoEdgeSeparation JY7131.JY7131CITask.TwoEdgeSeparation
getset

TwoEdgeSeparation.

◆ TwoPulseEncoder

TwoPulseEncoder JY7131.JY7131CITask.TwoPulseEncoder
getset

TwoPulseEncoder.

◆ Type

CIType JY7131.JY7131CITask.Type
getset

CI Application types.

The documentation for this class was generated from the following file:
  • D:/7131/C#/JY7131CITask.cs


7131 C# Programming Manual: JY7131.CISampleClock Class Reference

  • JY7131
  • CISampleClock
Properties | List of all members
JY7131.CISampleClock Class Reference

CI Sample Clock class. More...

Properties

CISampleClockSource | Source [get, set]
CI Sample Clock Source.
CIExternalSampleClock | External [get, set]
CI External Sample Clock Configuration.
CIImplicitSampleClock | Implicit [get, set]
CI Implicit Sample Clock Configuration.
CIInternalSampleClock | Internal [get]
Internal Sample Clock Configuration.

Detailed Description

CI Sample Clock class.

Property Documentation

◆ External

CIExternalSampleClock JY7131.CISampleClock.External
getset

CI External Sample Clock Configuration.

Valid when Source is CISampleClockSource.External.

◆ Implicit

CIImplicitSampleClock JY7131.CISampleClock.Implicit
getset

CI Implicit Sample Clock Configuration.

Valid when Source is CISampleClockSource.Implicit.

◆ Internal

CIInternalSampleClock JY7131.CISampleClock.Internal
get

Internal Sample Clock Configuration.

Valid when Source is CISampleClockSource.Internal.

◆ Source

CISampleClockSource JY7131.CISampleClock.Source
getset

CI Sample Clock Source.

The documentation for this class was generated from the following file:
  • D:/7131/C#/JY7131CITask.cs


7131 C# Programming Manual: JY7131.CIInternalSampleClock Class Reference

  • CIInternalSampleClock
Properties | List of all members
JY7131.CIInternalSampleClock Class Reference

CI Internal Sample Clock Configuration Class. More...

Properties

double | Rate [get, set]
The rate of the internal sample clock (sample rate) which is generated by dividing the internal clock (200MHz).
bool | IgnoreFirstSampleClock [get, set]
Ignore the first sample clock data.

Detailed Description

CI Internal Sample Clock Configuration Class.

Property Documentation

◆ IgnoreFirstSampleClock

bool JY7131.CIInternalSampleClock.IgnoreFirstSampleClock
getset

Ignore the first sample clock data.

◆ Rate

double JY7131.CIInternalSampleClock.Rate
getset

The rate of the internal sample clock (sample rate) which is generated by dividing the internal clock (200MHz).

The documentation for this class was generated from the following file:
  • D:/7131/C#/JY7131CITask.cs


7131 C# Programming Manual: JY7131.CIImplicitSampleClock Class Reference

  • CIImplicitSampleClock
Properties | List of all members
JY7131.CIImplicitSampleClock Class Reference

CI Implicit Sample Clock class. More...

Properties

double ExpectedRate [get, set]
Expected Rate of Implicit Sample Clock.

Detailed Description

CI Implicit Sample Clock class.

Property Documentation

◆ ExpectedRate

double JY7131.CIImplicitSampleClock.ExpectedRate
getset

Expected Rate of Implicit Sample Clock.

Filling this parameter accurately would helps the driver to set a proper DDR write frequency internally.

The documentation for this class was generated from the following file:
  • D:/7131/C#/JY7131CITask.cs


7131 C# Programming Manual: JY7131.CIExternalSampleClock Class Reference

  • CIExternalSampleClock
Properties | List of all members
JY7131.CIExternalSampleClock Class Reference

CI Implicit Sample Clock class. More...

Properties

ClockTerminal | Terminal [get, set]
External Sample Clock Input Terminal.
double | ExpectedRate [get, set]
Expected Rate of External Sample Clock.
bool | IgnoreFirstSampleClock [get, set]
Ignore the first sample clock data.

Detailed Description

CI Implicit Sample Clock class.

Property Documentation

◆ ExpectedRate

double JY7131.CIExternalSampleClock.ExpectedRate
getset

Expected Rate of External Sample Clock.

Filling this parameter accurately would helps the driver to set a proper DDR write frequency internally.

◆ IgnoreFirstSampleClock

bool JY7131.CIExternalSampleClock.IgnoreFirstSampleClock
getset

Ignore the first sample clock data.

◆ Terminal

ClockTerminal JY7131.CIExternalSampleClock.Terminal
getset

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • D:/7131/C#/JY7131CITask.cs


7131 C# Programming Manual: JY7131.CITimebase Class Reference

  • CITimebase
Properties | List of all members
JY7131.CITimebase Class Referencesealed

Properties

CITimebaseSource Source [get, set]

Detailed Description

时基配置类

Timebase configuration class

Property Documentation

◆ Source

CITimebaseSource JY7131.CITimebase.Source
getset

时基源。默认值为 CITimebaseSource.Internal100MHz。

Timebase Source. The default value is CITimebaseSource.Internal100MHz.

The documentation for this class was generated from the following file:
  • D:/7131/C#/JY7131CITask.cs


7131 C# Programming Manual: JY7131.EdgeCounting Class Reference

  • EdgeCounting
Properties | List of all members
JY7131.EdgeCounting Class Referencesealed

Configure CI EdgeCounting. More...

Properties

int | InitialCount [get, set]
Initial Count.
CountDirection | Direction [get, set]
Counter direction.
PauseTrigger | Pause [get, set]
Pause Trigger Configuration.
EdgeType | ActiveEdge [get, set]
The avtive edge of the input signal, the counter will count up or down on this edge.
EdgeCountingOutEvent | OutEvent [get, set]
Edge counting output event.
InputTerminal | InputTerminal [get, set]
Input Terminal.
InputTerminal | DirTerminal [get, set]
Terminal of External Count Diretion Control.

Detailed Description

Configure CI EdgeCounting.

Property Documentation

◆ ActiveEdge

EdgeType JY7131.EdgeCounting.ActiveEdge
getset

The avtive edge of the input signal, the counter will count up or down on this edge.

◆ Direction

CountDirection JY7131.EdgeCounting.Direction
getset

Counter direction.

enum Up/Down/External

◆ DirTerminal

InputTerminal JY7131.EdgeCounting.DirTerminal
getset

Terminal of External Count Diretion Control.

Valid when Direction is CountDirection.External

◆ InitialCount

int JY7131.EdgeCounting.InitialCount
getset

Initial Count.

◆ InputTerminal

InputTerminal JY7131.EdgeCounting.InputTerminal
getset

Input Terminal.

◆ OutEvent

EdgeCountingOutEvent JY7131.EdgeCounting.OutEvent
getset

Edge counting output event.

A pulse will be generated when the count value reaches specified threshold

◆ Pause

PauseTrigger JY7131.EdgeCounting.Pause
getset

Pause Trigger Configuration.

The documentation for this class was generated from the following file:
  • D:/7131/C#/JY7131CITask.cs


7131 C# Programming Manual: JY7131.EdgeCountingOutEvent Class Reference

  • EdgeCountingOutEvent
Properties | List of all members
JY7131.EdgeCountingOutEvent Class Reference

Edge counting output event configuration class. More...

Properties

EdgeCntOunEvtIdleState | IdleState [get, set]
Output idle state when the event has not occurred.
uint | Threshold [get, set]
Comparison threshold.
IOTerminal | Terminal [get, set]
Terminal.

Detailed Description

Edge counting output event configuration class.

Property Documentation

◆ IdleState

EdgeCntOunEvtIdleState JY7131.EdgeCountingOutEvent.IdleState
getset

Output idle state when the event has not occurred.

The default value is EdgeCntOunEvtIdleState.LowLevel

◆ Terminal

IOTerminal JY7131.EdgeCountingOutEvent.Terminal
getset

Terminal.

◆ Threshold

uint JY7131.EdgeCountingOutEvent.Threshold
getset

Comparison threshold.

The default value is 2^32-1

The documentation for this class was generated from the following file:
  • D:/7131/C#/JY7131CITask.cs


7131 C# Programming Manual: JY7131.PauseTrigger Class Reference

  • PauseTrigger
Properties | List of all members
JY7131.PauseTrigger Class Referencesealed

Pause trigger configuration class. More...

Properties

LevelPolarity | ActivePolarity [get, set]
Pause trigger active polarity.
InputTerminal | Terminal [get, set]
Terminal.

Detailed Description

Pause trigger configuration class.

Property Documentation

◆ ActivePolarity

LevelPolarity JY7131.PauseTrigger.ActivePolarity
getset

Pause trigger active polarity.

The default value is LevelPolarity.None, means the pause trigger is disabled.

◆ Terminal

InputTerminal JY7131.PauseTrigger.Terminal
getset

Terminal.

The documentation for this class was generated from the following file:
  • D:/7131/C#/JY7131CITask.cs


7131 C# Programming Manual: JY7131.FrequencyMeas Class Reference

  • FrequencyMeas
Properties | List of all members
JY7131.FrequencyMeas Class Referencesealed

Configure CI Measure. More...

Properties

CITimebase | Timebase [get, set]
Timebase configuration.
EdgeType | StartingEdge [get, set]
The start edge of the input signal, the counter will count up or down on this edge.
InputTerminal | InputTerminal [get, set]
Input Terminal.

Detailed Description

Configure CI Measure.

Property Documentation

◆ InputTerminal

InputTerminal JY7131.FrequencyMeas.InputTerminal
getset

Input Terminal.

◆ StartingEdge

EdgeType JY7131.FrequencyMeas.StartingEdge
getset

The start edge of the input signal, the counter will count up or down on this edge.

◆ Timebase

CITimebase JY7131.FrequencyMeas.Timebase
getset

Timebase configuration.

The documentation for this class was generated from the following file:
  • D:/7131/C#/JY7131CITask.cs


7131 C# Programming Manual: JY7131.PeriodMeas Class Reference

  • PeriodMeas
Properties | List of all members
JY7131.PeriodMeas Class Referencesealed

Configure CI Measure. More...

Properties

CITimebase | Timebase [get, set]
Timebase configuration.
EdgeType | StartingEdge [get, set]
The start edge of the input signal, the counter will count up or down on this edge.
InputTerminal | InputTerminal [get, set]
Input Terminal.

Detailed Description

Configure CI Measure.

Property Documentation

◆ InputTerminal

InputTerminal JY7131.PeriodMeas.InputTerminal
getset

Input Terminal.

◆ StartingEdge

EdgeType JY7131.PeriodMeas.StartingEdge
getset

The start edge of the input signal, the counter will count up or down on this edge.

◆ Timebase

CITimebase JY7131.PeriodMeas.Timebase
getset

Timebase configuration.

The documentation for this class was generated from the following file:
  • D:/7131/C#/JY7131CITask.cs


7131 C# Programming Manual: JY7131.TwoEdgeSeparation Class Reference

  • TwoEdgeSeparation
Properties | List of all members
JY7131.TwoEdgeSeparation Class Referencesealed

Configure CI Measure. More...

Properties

CITimebase | Timebase [get, set]
Timebase configuration.
InputTerminal | FirstInputTerminal [get, set]
Input Terminal.
InputTerminal | SecondInputTerminal [get, set]
Input Terminal.
ValueReturnMode | EdgeSeparationMode [get, set]

Detailed Description

Configure CI Measure.

Property Documentation

◆ EdgeSeparationMode

ValueReturnMode JY7131.TwoEdgeSeparation.EdgeSeparationMode
getset

数据返回模式

data return mode

◆ FirstInputTerminal

InputTerminal JY7131.TwoEdgeSeparation.FirstInputTerminal
getset

Input Terminal.

◆ SecondInputTerminal

InputTerminal JY7131.TwoEdgeSeparation.SecondInputTerminal
getset

Input Terminal.

◆ Timebase

CITimebase JY7131.TwoEdgeSeparation.Timebase
getset

Timebase configuration.

The documentation for this class was generated from the following file:
  • D:/7131/C#/JY7131CITask.cs


7131 C# Programming Manual: JY7131.QuadEncoder Class Reference

  • QuadEncoder
Properties | List of all members
JY7131.QuadEncoder Class Referencesealed

Configure CI Measure. More...

Properties

QuadEncodingType | EncodingType [get, set]
Type of Encoding.
bool | ZReloadEnabled [get, set]
In Encoder mode ,the Z signal enable.
InputTerminal | AInputTerminal [get, set]
Input Terminal.
InputTerminal | BInputTerminal [get, set]
Input Terminal.
InputTerminal | ZInputTerminal [get, set]
Input Terminal.

Detailed Description

Configure CI Measure.

Property Documentation

◆ AInputTerminal

InputTerminal JY7131.QuadEncoder.AInputTerminal
getset

Input Terminal.

◆ BInputTerminal

InputTerminal JY7131.QuadEncoder.BInputTerminal
getset

Input Terminal.

◆ EncodingType

QuadEncodingType JY7131.QuadEncoder.EncodingType
getset

Type of Encoding.

◆ ZInputTerminal

InputTerminal JY7131.QuadEncoder.ZInputTerminal
getset

Input Terminal.

◆ ZReloadEnabled

bool JY7131.QuadEncoder.ZReloadEnabled
getset

In Encoder mode ,the Z signal enable.

The documentation for this class was generated from the following file:
  • D:/7131/C#/JY7131CITask.cs


7131 C# Programming Manual: JY7131.TwoPulseEncoder Class Reference

  • TwoPulseEncoder
Properties | List of all members
JY7131.TwoPulseEncoder Class Referencesealed

Configure CI Measure. More...

Properties

InputTerminal | AInputTerminal [get, set]
Input Terminal.
InputTerminal | BInputTerminal [get, set]
Input Terminal.

Detailed Description

Configure CI Measure.

Property Documentation

◆ AInputTerminal

InputTerminal JY7131.TwoPulseEncoder.AInputTerminal
getset

Input Terminal.

◆ BInputTerminal

InputTerminal JY7131.TwoPulseEncoder.BInputTerminal
getset

Input Terminal.

The documentation for this class was generated from the following file:
  • D:/7131/C#/JY7131CITask.cs


7131 C# Programming Manual: JY7131.CITrigger Class Reference

  • CITrigger
Properties | List of all members
JY7131.CITrigger Class Referencesealed

Constructor to create an CITrigger task object. More...

Properties

CITriggerType | Type [get, set]
CI trigger type.
CIDigitalTrigger | Digital [get, set]
CI Digital Trigger.

Detailed Description

Constructor to create an CITrigger task object.

Used to build CI Trigger

Property Documentation

◆ Digital

CIDigitalTrigger JY7131.CITrigger.Digital
getset

CI Digital Trigger.

Valid when Type is CITriggerType.Digital

◆ Type

CITriggerType JY7131.CITrigger.Type
getset

CI trigger type.

enum Immediate/Digital/Soft.

The documentation for this class was generated from the following file:
  • D:/7131/C#/JY7131CITask.cs


7131 C# Programming Manual: JY7131.CIDigitalTrigger Class Reference

  • CIDigitalTrigger
Properties | List of all members
JY7131.CIDigitalTrigger Class Referencesealed

CI Digital trigger . More...

Properties

CIDigitalTriggerSource | Source [get, set]
CI Digital Trigger source.
CIDigitalTriggerEdge | Edge [get, set]
Digital Trigger edge，Rising/Falling.

Detailed Description

CI Digital trigger .

Property Documentation

◆ Edge

CIDigitalTriggerEdge JY7131.CIDigitalTrigger.Edge
getset

Digital Trigger edge，Rising/Falling.

◆ Source

CIDigitalTriggerSource JY7131.CIDigitalTrigger.Source
getset

CI Digital Trigger source.

The documentation for this class was generated from the following file:
  • D:/7131/C#/JY7131CITask.cs


7131 C# Programming Manual: JY7131.CISignalExport Class Reference

  • CISignalExport
Public Member Functions | List of all members
JY7131.CISignalExport Class Reference

CI Signal Export Class. More...

Public Member Functions

void | Add (CISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (CISignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

CI Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY7131.CISignalExport.Add | ( | CISignalExportSource | source,
 |  | List< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | CI Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY7131.CISignalExport.Add | ( | CISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | CI Signal Source
destination | Export Desination

◆ Clear()

void JY7131.CISignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY7131.CISignalExport.ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • D:/7131/C#/JY7131CITask.cs


7131 C# Programming Manual: D:/7131/C#/JY7131COTask.cs File Reference

  • File List
  • 7131
  • C#
Classes | Namespaces | Enumerations
JY7131COTask.cs File Reference

Classes

class | JY7131.JY7131COTask
JY7131 Counter Output Task. More...
class | JY7131.COTrigger
Constructor to create an COTrigger task object. More...
class | JY7131.CODigitalTrigger
CO Digital trigger . More...
class | JY7131.COPulse
Pulse Parameter. More...
class | JY7131.COExternalTimebase
class | JY7131.COTimebase
class | JY7131.COSignalExport
CO Signal Export Class. More...

Namespaces

namespace JY7131

Enumerations

enum | JY7131.COIdleState { JY7131.HighLevel = JY7131Import.JY7131_HighLevel , JY7131.LowLevel = JY7131Import.JY7131_LowLevel }
Idle state when pulse output before start and after stop. More...
enum | JY7131.COMode { JY7131.Single = JY7131Import.JY7131_CO_Single , JY7131.Finite = JY7131Import.JY7131_CO_Finite , JY7131.ContinuousNoWrapping = JY7131Import.JY7131_CO_ContinuousNoWrapping , JY7131.ContinuousWrapping = JY7131Import.JY7131_CO_ContinuousWrapping }
CO output mode. More...
enum | JY7131.COTriggerType { JY7131.Immediate = JY7131Import.JY7131_CIO_Immediately , JY7131.Digital = JY7131Import.JY7131_CIO_Digital , JY7131.Soft = JY7131Import.JY7131_CIO_Soft }
TriggerType Digital/Immediate/Soft. More...
enum JY7131.CODigitalTriggerSource {
JY7131.PFI_In_0 = JY7131Import.JY7131_DigitalTriggerSource_PFI_0 , JY7131.PFI_In_1 = JY7131Import.JY7131_DigitalTriggerSource_PFI_1 , JY7131.PFI_In_2 = JY7131Import.JY7131_DigitalTriggerSource_PFI_2 , JY7131.PFI_In_3 = JY7131Import.JY7131_DigitalTriggerSource_PFI_3 ,
JY7131.PFI_In_4 = JY7131Import.JY7131_DigitalTriggerSource_PFI_4 , JY7131.PFI_In_5 = JY7131Import.JY7131_DigitalTriggerSource_PFI_5 , JY7131.PFI_In_6 = JY7131Import.JY7131_DigitalTriggerSource_PFI_6 , JY7131.PFI_In_7 = JY7131Import.JY7131_DigitalTriggerSource_PFI_7 ,
JY7131.PFI_In_8 = JY7131Import.JY7131_DigitalTriggerSource_PFI_8 , JY7131.PFI_In_9 = JY7131Import.JY7131_DigitalTriggerSource_PFI_9 , JY7131.PFI_In_10 = JY7131Import.JY7131_DigitalTriggerSource_PFI_10 , JY7131.PFI_In_11 = JY7131Import.JY7131_DigitalTriggerSource_PFI_11 ,
JY7131.PFI_In_12 = JY7131Import.JY7131_DigitalTriggerSource_PFI_12 , JY7131.PFI_In_13 = JY7131Import.JY7131_DigitalTriggerSource_PFI_13 , JY7131.PFI_In_14 = JY7131Import.JY7131_DigitalTriggerSource_PFI_14 , JY7131.PFI_In_15 = JY7131Import.JY7131_DigitalTriggerSource_PFI_15 ,
JY7131.PFI_In_16 = JY7131Import.JY7131_DigitalTriggerSource_PFI_16 , JY7131.PFI_In_17 = JY7131Import.JY7131_DigitalTriggerSource_PFI_17 , JY7131.PFI_In_18 = JY7131Import.JY7131_DigitalTriggerSource_PFI_18 , JY7131.PFI_In_19 = JY7131Import.JY7131_DigitalTriggerSource_PFI_19 ,
JY7131.PFI_In_20 = JY7131Import.JY7131_DigitalTriggerSource_PFI_20 , JY7131.PFI_In_21 = JY7131Import.JY7131_DigitalTriggerSource_PFI_21 , JY7131.PFI_In_22 = JY7131Import.JY7131_DigitalTriggerSource_PFI_22 , JY7131.PFI_In_23 = JY7131Import.JY7131_DigitalTriggerSource_PFI_23 ,
JY7131.PFI_In_24 = JY7131Import.JY7131_DigitalTriggerSource_PFI_24 , JY7131.PFI_In_25 = JY7131Import.JY7131_DigitalTriggerSource_PFI_25 , JY7131.PFI_In_26 = JY7131Import.JY7131_DigitalTriggerSource_PFI_26 , JY7131.PFI_In_27 = JY7131Import.JY7131_DigitalTriggerSource_PFI_27 ,
JY7131.PFI_In_28 = JY7131Import.JY7131_DigitalTriggerSource_PFI_28 , JY7131.PFI_In_29 = JY7131Import.JY7131_DigitalTriggerSource_PFI_29 , JY7131.PFI_In_30 = JY7131Import.JY7131_DigitalTriggerSource_PFI_30 , JY7131.PFI_In_31 = JY7131Import.JY7131_DigitalTriggerSource_PFI_31 ,
JY7131.PXI_Trig0 = JY7131Import.JY7131_DigitalTriggerSource_PXI_Trig_0 , JY7131.PXI_Trig1 = JY7131Import.JY7131_DigitalTriggerSource_PXI_Trig_1 , JY7131.PXI_Trig2 = JY7131Import.JY7131_DigitalTriggerSource_PXI_Trig_2 , JY7131.PXI_Trig3 = JY7131Import.JY7131_DigitalTriggerSource_PXI_Trig_3 ,
JY7131.PXI_Trig4 = JY7131Import.JY7131_DigitalTriggerSource_PXI_Trig_4 , JY7131.PXI_Trig5 = JY7131Import.JY7131_DigitalTriggerSource_PXI_Trig_5 , JY7131.PXI_Trig6 = JY7131Import.JY7131_DigitalTriggerSource_PXI_Trig_6 , JY7131.PXI_Trig7 = JY7131Import.JY7131_DigitalTriggerSource_PXI_Trig_7 ,
JY7131.CIO_0_StartTrig = JY7131Import.JY7131_DigitalTriggerSource_CIO_0_StartTrig , JY7131.CIO_1_StartTrig = JY7131Import.JY7131_DigitalTriggerSource_CIO_1_StartTrig , JY7131.CIO_2_StartTrig = JY7131Import.JY7131_DigitalTriggerSource_CIO_2_StartTrig , JY7131.CIO_3_StartTrig = JY7131Import.JY7131_DigitalTriggerSource_CIO_3_StartTrig ,
JY7131.CIO_4_StartTrig = JY7131Import.JY7131_DigitalTriggerSource_CIO_4_StartTrig , JY7131.CIO_5_StartTrig = JY7131Import.JY7131_DigitalTriggerSource_CIO_5_StartTrig , JY7131.CIO_6_StartTrig = JY7131Import.JY7131_DigitalTriggerSource_CIO_6_StartTrig , JY7131.CIO_7_StartTrig = JY7131Import.JY7131_DigitalTriggerSource_CIO_7_StartTrig ,
JY7131.CO_0_OutPut = JY7131Import.JY7131_DigitalTriggerSource_Counter_0_Output , JY7131.CO_1_OutPut = JY7131Import.JY7131_DigitalTriggerSource_Counter_1_Output , JY7131.CO_2_OutPut = JY7131Import.JY7131_DigitalTriggerSource_Counter_2_Output , JY7131.CO_3_OutPut = JY7131Import.JY7131_DigitalTriggerSource_Counter_3_Output ,
JY7131.CO_4_OutPut = JY7131Import.JY7131_DigitalTriggerSource_Counter_4_Output , JY7131.CO_5_OutPut = JY7131Import.JY7131_DigitalTriggerSource_Counter_5_Output , JY7131.CO_6_OutPut = JY7131Import.JY7131_DigitalTriggerSource_Counter_6_Output , JY7131.CO_7_OutPut = JY7131Import.JY7131_DigitalTriggerSource_Counter_7_Output
}
CO Digital trigger source. More...
enum | JY7131.CODigitalTriggerEdge { JY7131.Rising , JY7131.Falling }
CO Digital Trigger Edge. More...
enum | JY7131.COPulseType { JY7131.DutyCycleFrequency , JY7131.HighLowTime , JY7131.HighLowTick }
Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick. More...
enum | JY7131.COTimebaseSource { JY7131.Internal100MHz = 0 , JY7131.Internal5MHz = 1 , JY7131.Internal100kHz = 2 , JY7131.External = 3 }
enum | JY7131.COSignalExportSource { JY7131.StartTrig , JY7131.Output }
SourceSignal. More...


7131 C# Programming Manual: JY7131.JY7131COTask Class Reference

  • JY7131COTask
Public Member Functions | Properties | List of all members
JY7131.JY7131COTask Class Referencesealed

JY7131 Counter Output Task. More...

Public Member Functions

JY7131COTask (int slotNum, int channel)
Constructor.
JY7131COTask (string boardName, int channel)
Constructor.
void | WriteSinglePoint (COPulse pulse)
Write a single pulse parameter to the register.
void | WriteData (COPulse[] pulsesGroup, int samplesToWrite, int timeout=10000)
Write pulse parameters to be output to the buffer.
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Start ()
Start CO task .
void | Stop ()
Stop COtask .
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.

Properties

COMode | Mode [get, set]
CO output mode.
IOTerminal | OutputTerminal [get, set]
DOLineMode | OutTerminalMode [get, set]
DO output mode.
COTimebase | Timebase [get, set]
CO's time base.
double | InitialDelay [get, set]
Counter output initial delay in seconds.
COIdleState | IdleState [get, set]
Idle state when pulse output before start and after stop.
PauseTrigger | Pause [get, set]
uint | SamplesToUpdate [get, set]
有限频率输出
uint | AvaliableLenInSamples [get]
本地缓冲区当前可容纳的样点数（当前每通道可写入缓冲区的样点数）
ulong | TransferedSamples [get]
uint | TransferedPulses [get]
COTrigger | Trigger = new COTrigger() [get, set]
CO trigger property configured by CO Trigger().
JY7131Device | Device [get]
Device.
COSignalExport | SignalExport [get, set]
Export CO Signal Configuration.

Detailed Description

JY7131 Counter Output Task.

Constructor & Destructor Documentation

◆ JY7131COTask() [1/2]

JY7131.JY7131COTask.JY7131COTask | ( | int | slotNum,
 |  | int | channel )

Constructor.

Used to create an CO task by a slot number.

Parameters
slotNum | Card slot number.
channel | Counter channel （5510 5511 support0-3,5515 5516 suppor0-1）.

◆ JY7131COTask() [2/2]

JY7131.JY7131COTask.JY7131COTask | ( | string | boardName,
 |  | int | channel )

Constructor.

Used to create an CO task by a board name.

Parameters
boardName | Board name(device alias), set by device manager
channel | Counter channel （5510 5511 support0-3,5515 5516 suppor0-1）.

Member Function Documentation

◆ SendSoftwareTrigger()

void JY7131.JY7131COTask.SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY7131.JY7131COTask.Start ( )

Start CO task .

◆ Stop()

void JY7131.JY7131COTask.Stop ( )

Stop COtask .

◆ WaitUntilDone()

bool JY7131.JY7131COTask.WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteData()

void JY7131.JY7131COTask.WriteData | ( | COPulse[] | pulsesGroup,
 |  | int | samplesToWrite,
 |  | int | timeout = 10000 )

Write pulse parameters to be output to the buffer.

Valid when Mode is NOT COMode.Single. When Mode is COMode.Finite or COMode.ContinuousWrapping, this function can only be called once before starting the task.

Parameters
pulsesGroup | A group of pulse parameters
samplesToWrite | Number of samples to write. If Mode is COMode.ContinuousWrapping, you need to write at least 2 samples before starting the task
timeout | Timeout (ms). Wait until all data is written to buffer or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ WriteSinglePoint()

void JY7131.JY7131COTask.WriteSinglePoint ( COPulse pulse )

Write a single pulse parameter to the register.

Valid when Mode is COMode.Single. This function is also available after starting the task when the number of pulses being sent is infinite.

Parameters
pulse Pulse Parameter

Property Documentation

◆ AvaliableLenInSamples

uint JY7131.JY7131COTask.AvaliableLenInSamples
get

本地缓冲区当前可容纳的样点数（当前每通道可写入缓冲区的样点数）

◆ Device

JY7131Device JY7131.JY7131COTask.Device
get

Device.

◆ IdleState

COIdleState JY7131.JY7131COTask.IdleState
getset

Idle state when pulse output before start and after stop.

◆ InitialDelay

double JY7131.JY7131COTask.InitialDelay
getset

Counter output initial delay in seconds.

There are five ticks of the timebase fixed delay in counter internal, so the total delay(s) = InitialDelay + (5 / timebase)

◆ Mode

COMode JY7131.JY7131COTask.Mode
getset

CO output mode.

◆ OutputTerminal

IOTerminal JY7131.JY7131COTask.OutputTerminal
getset

脉冲输出端口

Pulse Output Terminal

◆ OutTerminalMode

DOLineMode JY7131.JY7131COTask.OutTerminalMode
getset

DO output mode.

default Sourcing

◆ Pause

PauseTrigger JY7131.JY7131COTask.Pause
getset

暂停触发配置

Pause Trigger Configuration

◆ SamplesToUpdate

uint JY7131.JY7131COTask.SamplesToUpdate
getset

有限频率输出

◆ SignalExport

COSignalExport JY7131.JY7131COTask.SignalExport
getset

Export CO Signal Configuration.

◆ Timebase

COTimebase JY7131.JY7131COTask.Timebase
getset

CO's time base.

◆ TransferedPulses

uint JY7131.JY7131COTask.TransferedPulses
get

当前配置下已发送的脉冲的数量。

The number of pulses transfered under the current configuration.

◆ TransferedSamples

ulong JY7131.JY7131COTask.TransferedSamples
get

已从本地缓冲区传出的样点数（每通道），当 Mode 不为 COMode.Single 时有效。

The number of samples that have been transfered from the local buffer (per channel). Valid when Mode is NOT COMode.Single.

◆ Trigger

COTrigger JY7131.JY7131COTask.Trigger = new COTrigger()
getset

CO trigger property configured by CO Trigger().

The documentation for this class was generated from the following file:
  • D:/7131/C#/JY7131COTask.cs


7131 C# Programming Manual: JY7131.COTrigger Class Reference

  • COTrigger
Properties | List of all members
JY7131.COTrigger Class Referencesealed

Constructor to create an COTrigger task object. More...

Properties

COTriggerType | Type [get, set]
CO trigger type.
CODigitalTrigger | Digital [get, set]
CO Digital Trigger.

Detailed Description

Constructor to create an COTrigger task object.

Used to build CO Trigger

Property Documentation

◆ Digital

CODigitalTrigger JY7131.COTrigger.Digital
getset

CO Digital Trigger.

Valid when Type is COTriggerType.Digital

◆ Type

COTriggerType JY7131.COTrigger.Type
getset

CO trigger type.

enum Immediate/Digital/Soft.

The documentation for this class was generated from the following file:
  • D:/7131/C#/JY7131COTask.cs


7131 C# Programming Manual: JY7131.CODigitalTrigger Class Reference

  • CODigitalTrigger
Properties | List of all members
JY7131.CODigitalTrigger Class Referencesealed

CO Digital trigger . More...

Properties

CODigitalTriggerSource | Source [get, set]
CO Digital Trigger source.
CODigitalTriggerEdge | Edge [get, set]
Digital Trigger edge，Rising/Falling.

Detailed Description

CO Digital trigger .

Property Documentation

◆ Edge

CODigitalTriggerEdge JY7131.CODigitalTrigger.Edge
getset

Digital Trigger edge，Rising/Falling.

◆ Source

CODigitalTriggerSource JY7131.CODigitalTrigger.Source
getset

CO Digital Trigger source.

The documentation for this class was generated from the following file:
  • D:/7131/C#/JY7131COTask.cs


7131 C# Programming Manual: JY7131.COPulse Class Reference

  • COPulse
Public Member Functions | List of all members
JY7131.COPulse Class Reference

Pulse Parameter. More...

Public Member Functions

COPulse (COPulseType type, double param1, double param2, int count)
Pulse Parameter.

Detailed Description

Pulse Parameter.

Constructor & Destructor Documentation

◆ COPulse()

JY7131.COPulse.COPulse | ( | COPulseType | type,
 |  | double | param1,
 |  | double | param2,
 |  | int | count )

Pulse Parameter.

Parameters
type | The pulse type characteristics.
param1 | Parameter 1. Frequency (Hz) when constructed as COPulseType.DutyCycleFrequency; High duration in seconds when constructed as COPulseType.HighLowTime; High ticks of the clock when constructed as COPulseType.HighLowTick.
param2 | Parameter 1. Duty cycle (greater than 0 and less than 1) when constructed as COPulseType.DutyCycleFrequency; Low duration in seconds when constructed as COPulseType.HighLowTime; Low ticks of the clock when constructed as COPulseType.HighLowTick.
count | Number of pulses. When the value is -1 (indicating that the number of pulses is infinite), pulses will be continuously sent until requested to stop.
The documentation for this class was generated from the following file:
  • D:/7131/C#/JY7131COTask.cs


7131 C# Programming Manual: JY7131.COExternalTimebase Class Reference

  • COExternalTimebase
Properties | List of all members
JY7131.COExternalTimebase Class Referencesealed

Properties

InputTerminal | Terminal [get, set]
double | Frequency [get, set]

Detailed Description

外部时基配置类

External timebase configuration class

Property Documentation

◆ Frequency

double JY7131.COExternalTimebase.Frequency
getset

外部时基的频率

Frequency of The External Timebase

◆ Terminal

InputTerminal JY7131.COExternalTimebase.Terminal
getset

外部时基的输入端口

External Timebase Input Terminal

The documentation for this class was generated from the following file:
  • D:/7131/C#/JY7131COTask.cs


7131 C# Programming Manual: JY7131.COTimebase Class Reference

  • COTimebase
Properties | List of all members
JY7131.COTimebase Class Referencesealed

Properties

COTimebaseSource | Source [get, set]
COExternalTimebase | External [get, set]

Detailed Description

时基配置类

Timebase configuration class

Property Documentation

◆ External

COExternalTimebase JY7131.COTimebase.External
getset

外部时基配置。当 COTimebase.Source 为 COTimebaseSource.External时有效。

External Timebase Configuration. Valid when COTimebase.Source is COTimebaseSource.External.

◆ Source

COTimebaseSource JY7131.COTimebase.Source
getset

时基源。默认值为 COTimebaseSource.Internal100MHz。

Timebase Source. The default value is COTimebaseSource.Internal100MHz.

The documentation for this class was generated from the following file:
  • D:/7131/C#/JY7131COTask.cs


7131 C# Programming Manual: JY7131.COSignalExport Class Reference

  • COSignalExport
Public Member Functions | List of all members
JY7131.COSignalExport Class Reference

CO Signal Export Class. More...

Public Member Functions

void | Add (COSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (COSignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

CO Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY7131.COSignalExport.Add | ( | COSignalExportSource | source,
 |  | List< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | CO Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY7131.COSignalExport.Add | ( | COSignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | CO Signal Source
destination | Export Desination

◆ Clear()

void JY7131.COSignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY7131.COSignalExport.ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • D:/7131/C#/JY7131COTask.cs


7131 C# Programming Manual: D:/7131/C#/JY7131DITask.cs File Reference

  • File List
  • 7131
  • C#
Classes | Namespaces
JY7131DITask.cs File Reference

Classes

class | JY7131.JY7131DITask
JY7131DITask Class. More...
class | JY7131.DIChannel
DI Channel parameter class. More...

Namespaces

namespace JY7131


7131 C# Programming Manual: JY7131.JY7131DITask Class Reference

  • JY7131DITask
Public Member Functions | Properties | List of all members
JY7131.JY7131DITask Class Referencesealed

JY7131DITask Class. More...

Public Member Functions

JY7131DITask (int slotNum)
Constructor.
JY7131DITask (string aliasName)
Constructor.
void | AddChannel (int portNum)
Add one port.
void | AddChannel (int[] portsNum)
Add a group of ports.
void | RemoveChannel (int portNum)
Delete the specified port number.
void | Start ()
Start DITask.
void | Stop ()
Stop DITask.
void | ReadSinglePoint (ref bool readValue, int port, int line)
Specify the line reads the latest point.
void | ReadSinglePoint (ref bool[] readValues)
All ports all lines read the latest point.
void | ReadSinglePoint (ref bool[] readValues, int port)
Specify port reads the latest point.

Properties

JY7131Device | Device [get]
Device Handle.
List< DIChannel > | Channels [get]
List of DI channels.

Detailed Description

JY7131DITask Class.

Constructor & Destructor Documentation

◆ JY7131DITask() [1/2]

JY7131.JY7131DITask.JY7131DITask ( int slotNum )

Constructor.

Used to create an DItask object

Parameters
slotNum Card slot number

◆ JY7131DITask() [2/2]

JY7131.JY7131DITask.JY7131DITask ( string aliasName )

Constructor.

Used to create an DItask object

Parameters
aliasName AliasName

Member Function Documentation

◆ AddChannel() [1/2]

void JY7131.JY7131DITask.AddChannel ( int portNum )

Add one port.

Parameters
portNum port number

◆ AddChannel() [2/2]

void JY7131.JY7131DITask.AddChannel ( int[] portsNum )

Add a group of ports.

Parameters
portsNum port number

◆ ReadSinglePoint() [1/3]

void JY7131.JY7131DITask.ReadSinglePoint | ( | ref bool | readValue,
 |  | int | port,
 |  | int | line )

Specify the line reads the latest point.

Parameters
readValue | read Value
port | Specify the port to read
line | Specify the line to read

◆ ReadSinglePoint() [2/3]

void JY7131.JY7131DITask.ReadSinglePoint ( ref bool[] readValues )

All ports all lines read the latest point.

Parameters
readValues User buffer array

◆ ReadSinglePoint() [3/3]

void JY7131.JY7131DITask.ReadSinglePoint | ( | ref bool[] | readValues,
 |  | int | port )

Specify port reads the latest point.

Parameters
readValues | User buffer array
port | Specify port

◆ RemoveChannel()

void JY7131.JY7131DITask.RemoveChannel ( int portNum )

Delete the specified port number.

Parameters
portNum port number

◆ Start()

void JY7131.JY7131DITask.Start ( )

Start DITask.

◆ Stop()

void JY7131.JY7131DITask.Stop ( )

Stop DITask.

Property Documentation

◆ Channels

List<DIChannel> JY7131.JY7131DITask.Channels
get

List of DI channels.

◆ Device

JY7131Device JY7131.JY7131DITask.Device
get

Device Handle.

The documentation for this class was generated from the following file:
  • D:/7131/C#/JY7131DITask.cs


7131 C# Programming Manual: JY7131.DIChannel Class Reference

  • DIChannel
Properties | List of all members
JY7131.DIChannel Class Referencesealed

DI Channel parameter class. More...

Properties

int PortNum [get, set]
Port Number.

Detailed Description

DI Channel parameter class.

Property Documentation

◆ PortNum

int JY7131.DIChannel.PortNum
getset

Port Number.

The documentation for this class was generated from the following file:
  • D:/7131/C#/JY7131DITask.cs


7131 C# Programming Manual: D:/7131/C#/JY7131DOTask.cs File Reference

  • File List
  • 7131
  • C#
Classes | Namespaces | Enumerations
JY7131DOTask.cs File Reference

Classes

class | JY7131.JY7131DOTask
JY7131 DOTask. More...
class | JY7131.DOChannel
DO Channel parameter class. More...

Namespaces

namespace JY7131

Enumerations

enum JY7131.DOLineMode { JY7131.Sourcing = 0 , JY7131.Sinking = 1 , JY7131.Push_Pull = 2 }
Channel Type. More...


7131 C# Programming Manual: JY7131.JY7131DOTask Class Reference

  • JY7131DOTask
Public Member Functions | Properties | List of all members
JY7131.JY7131DOTask Class Referencesealed

JY7131 DOTask. More...

Public Member Functions

JY7131DOTask (int slotNum)
Constructor.
JY7131DOTask (string aliasName)
Constructor.
void | AddChannel (int portNum)
Add one port.
void | AddChannel (int[] portsNum)
Add a group of ports.
void | RemoveChannel (int portNum)
Delete the specified port number.
void | WriteSinglePoint (bool writeValue=false, int port=0, int line=0)
write the latest point of specify port specify line
void | WriteSinglePoint (bool[] writeValues)
write all lines the latest point
void | WriteSinglePoint (bool[] writeValues, int port)
write specify prot all lines the latest point
void | Start ()
DO Start.
void | Stop ()
DO Start.

Properties

JY7131Device | Device [get]
Device Handle.
DOLineMode | DOLineMode [get, set]
DO output mode.
List< DOChannel > | Channels [get]
List of DO channels.

Detailed Description

JY7131 DOTask.

Constructor & Destructor Documentation

◆ JY7131DOTask() [1/2]

JY7131.JY7131DOTask.JY7131DOTask ( int slotNum )

Constructor.

Used to create an DOtask object

Parameters
slotNum slot Number

◆ JY7131DOTask() [2/2]

JY7131.JY7131DOTask.JY7131DOTask ( string aliasName )

Constructor.

Used to create an DOtask object

Parameters
aliasName AliasName

Member Function Documentation

◆ AddChannel() [1/2]

void JY7131.JY7131DOTask.AddChannel ( int portNum )

Add one port.

Parameters
portNum port number

◆ AddChannel() [2/2]

void JY7131.JY7131DOTask.AddChannel ( int[] portsNum )

Add a group of ports.

Parameters
portsNum port number

◆ RemoveChannel()

void JY7131.JY7131DOTask.RemoveChannel ( int portNum )

Delete the specified port number.

Parameters
portNum port number

◆ Start()

void JY7131.JY7131DOTask.Start ( )

DO Start.

◆ Stop()

void JY7131.JY7131DOTask.Stop ( )

DO Start.

◆ WriteSinglePoint() [1/3]

void JY7131.JY7131DOTask.WriteSinglePoint | ( | bool | writeValue = false,
 |  | int | port = 0,
 |  | int | line = 0 )

write the latest point of specify port specify line

Parameters
writeValue | write Value
port | Specify the port to write
line | Specify the line to write

◆ WriteSinglePoint() [2/3]

void JY7131.JY7131DOTask.WriteSinglePoint ( bool[] writeValues )

write all lines the latest point

Parameters
writeValues User buffer array

◆ WriteSinglePoint() [3/3]

void JY7131.JY7131DOTask.WriteSinglePoint | ( | bool[] | writeValues,
 |  | int | port )

write specify prot all lines the latest point

Parameters
writeValues | User buffer array
port | Specify port

Property Documentation

◆ Channels

List<DOChannel> JY7131.JY7131DOTask.Channels
get

List of DO channels.

◆ Device

JY7131Device JY7131.JY7131DOTask.Device
get

Device Handle.

◆ DOLineMode

DOLineMode JY7131.JY7131DOTask.DOLineMode
getset

DO output mode.

default Sourcing

The documentation for this class was generated from the following file:
  • D:/7131/C#/JY7131DOTask.cs


7131 C# Programming Manual: JY7131.DOChannel Class Reference

  • DOChannel
Properties | List of all members
JY7131.DOChannel Class Referencesealed

DO Channel parameter class. More...

Properties

int PortNum [get, set]
Port Number.

Detailed Description

DO Channel parameter class.

Property Documentation

◆ PortNum

int JY7131.DOChannel.PortNum
getset

Port Number.

The documentation for this class was generated from the following file:
  • D:/7131/C#/JY7131DOTask.cs


7131 C# Programming Manual: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
▼N JY7131 |
C CIDigitalTrigger | CI Digital trigger
C CIExternalSampleClock | CI Implicit Sample Clock class
C CIImplicitSampleClock | CI Implicit Sample Clock class
C CIInternalSampleClock | CI Internal Sample Clock Configuration Class
C CISampleClock | CI Sample Clock class
C CISignalExport | CI Signal Export Class
C CITimebase |
C CITrigger | Constructor to create an CITrigger task object
C CODigitalTrigger | CO Digital trigger
C COExternalTimebase |
C COPulse | Pulse Parameter
C COSignalExport | CO Signal Export Class
C COTimebase |
C COTrigger | Constructor to create an COTrigger task object
C DIChannel | DI Channel parameter class
C DOChannel | DO Channel parameter class
C EdgeCounting | Configure CI EdgeCounting
C EdgeCountingOutEvent | Edge counting output event configuration class
C FrequencyMeas | Configure CI Measure
C JY7131CITask | JY7131 Counter Input Task
C JY7131COTask | JY7131 Counter Output Task
C JY7131DITask | JY7131DITask Class
C JY7131DOTask | JY7131 DOTask
C PauseTrigger | Pause trigger configuration class
C PeriodMeas | Configure CI Measure
C QuadEncoder | Configure CI Measure
C TwoEdgeSeparation | Configure CI Measure
C TwoPulseEncoder | Configure CI Measure


7131 C# Programming Manual: Member List

  • CIDigitalTrigger
JY7131.CIDigitalTrigger Member List

This is the complete list of members for JY7131.CIDigitalTrigger, including all inherited members.

Edge | JY7131.CIDigitalTrigger
Source | JY7131.CIDigitalTrigger


7131 C# Programming Manual: Member List

  • CIExternalSampleClock
JY7131.CIExternalSampleClock Member List

This is the complete list of members for JY7131.CIExternalSampleClock, including all inherited members.

ExpectedRate | JY7131.CIExternalSampleClock
IgnoreFirstSampleClock | JY7131.CIExternalSampleClock
Terminal | JY7131.CIExternalSampleClock


7131 C# Programming Manual: Member List

  • CIImplicitSampleClock
JY7131.CIImplicitSampleClock Member List

This is the complete list of members for JY7131.CIImplicitSampleClock, including all inherited members.

ExpectedRate JY7131.CIImplicitSampleClock


7131 C# Programming Manual: Member List

  • CIInternalSampleClock
JY7131.CIInternalSampleClock Member List

This is the complete list of members for JY7131.CIInternalSampleClock, including all inherited members.

IgnoreFirstSampleClock | JY7131.CIInternalSampleClock
Rate | JY7131.CIInternalSampleClock


7131 C# Programming Manual: Member List

  • CISampleClock
JY7131.CISampleClock Member List

This is the complete list of members for JY7131.CISampleClock, including all inherited members.

External | JY7131.CISampleClock
Implicit | JY7131.CISampleClock
Internal | JY7131.CISampleClock
Source | JY7131.CISampleClock


7131 C# Programming Manual: Member List

  • CISignalExport
JY7131.CISignalExport Member List

This is the complete list of members for JY7131.CISignalExport, including all inherited members.

Add(CISignalExportSource source, SignalExportDestination destination) | JY7131.CISignalExport
Add(CISignalExportSource source, List< SignalExportDestination > destinations) | JY7131.CISignalExport
Clear(SignalExportDestination destination) | JY7131.CISignalExport
ClearAll() | JY7131.CISignalExport


7131 C# Programming Manual: Member List

  • CITimebase
JY7131.CITimebase Member List

This is the complete list of members for JY7131.CITimebase, including all inherited members.

Source JY7131.CITimebase


7131 C# Programming Manual: Member List

  • CITrigger
JY7131.CITrigger Member List

This is the complete list of members for JY7131.CITrigger, including all inherited members.

Digital | JY7131.CITrigger
Type | JY7131.CITrigger


7131 C# Programming Manual: Member List

  • CODigitalTrigger
JY7131.CODigitalTrigger Member List

This is the complete list of members for JY7131.CODigitalTrigger, including all inherited members.

Edge | JY7131.CODigitalTrigger
Source | JY7131.CODigitalTrigger


7131 C# Programming Manual: Member List

  • COExternalTimebase
JY7131.COExternalTimebase Member List

This is the complete list of members for JY7131.COExternalTimebase, including all inherited members.

Frequency | JY7131.COExternalTimebase
Terminal | JY7131.COExternalTimebase


7131 C# Programming Manual: Member List

  • COPulse
JY7131.COPulse Member List

This is the complete list of members for JY7131.COPulse, including all inherited members.

COPulse(COPulseType type, double param1, double param2, int count) JY7131.COPulse


7131 C# Programming Manual: Member List

  • COSignalExport
JY7131.COSignalExport Member List

This is the complete list of members for JY7131.COSignalExport, including all inherited members.

Add(COSignalExportSource source, SignalExportDestination destination) | JY7131.COSignalExport
Add(COSignalExportSource source, List< SignalExportDestination > destinations) | JY7131.COSignalExport
Clear(SignalExportDestination destination) | JY7131.COSignalExport
ClearAll() | JY7131.COSignalExport


7131 C# Programming Manual: Member List

  • COTimebase
JY7131.COTimebase Member List

This is the complete list of members for JY7131.COTimebase, including all inherited members.

External | JY7131.COTimebase
Source | JY7131.COTimebase


7131 C# Programming Manual: Member List

  • COTrigger
JY7131.COTrigger Member List

This is the complete list of members for JY7131.COTrigger, including all inherited members.

Digital | JY7131.COTrigger
Type | JY7131.COTrigger


7131 C# Programming Manual: Member List

  • DIChannel
JY7131.DIChannel Member List

This is the complete list of members for JY7131.DIChannel, including all inherited members.

PortNum JY7131.DIChannel


7131 C# Programming Manual: Member List

  • DOChannel
JY7131.DOChannel Member List

This is the complete list of members for JY7131.DOChannel, including all inherited members.

PortNum JY7131.DOChannel


7131 C# Programming Manual: Member List

  • EdgeCounting
JY7131.EdgeCounting Member List

This is the complete list of members for JY7131.EdgeCounting, including all inherited members.

ActiveEdge | JY7131.EdgeCounting
Direction | JY7131.EdgeCounting
DirTerminal | JY7131.EdgeCounting
InitialCount | JY7131.EdgeCounting
InputTerminal | JY7131.EdgeCounting
OutEvent | JY7131.EdgeCounting
Pause | JY7131.EdgeCounting


7131 C# Programming Manual: Member List

  • EdgeCountingOutEvent
JY7131.EdgeCountingOutEvent Member List

This is the complete list of members for JY7131.EdgeCountingOutEvent, including all inherited members.

IdleState | JY7131.EdgeCountingOutEvent
Terminal | JY7131.EdgeCountingOutEvent
Threshold | JY7131.EdgeCountingOutEvent


7131 C# Programming Manual: Member List

  • FrequencyMeas
JY7131.FrequencyMeas Member List

This is the complete list of members for JY7131.FrequencyMeas, including all inherited members.

InputTerminal | JY7131.FrequencyMeas
StartingEdge | JY7131.FrequencyMeas
Timebase | JY7131.FrequencyMeas


7131 C# Programming Manual: Member List

  • JY7131CITask
JY7131.JY7131CITask Member List

This is the complete list of members for JY7131.JY7131CITask, including all inherited members.

AvailableSamples | JY7131.JY7131CITask
Device | JY7131.JY7131CITask
EdgeCounting | JY7131.JY7131CITask
FrequencyMeas | JY7131.JY7131CITask
JY7131CITask(int slotNum, int channel) | JY7131.JY7131CITask
JY7131CITask(string boardName, int channel) | JY7131.JY7131CITask
Mode | JY7131.JY7131CITask
PeriodMeas | JY7131.JY7131CITask
QuadEncoder | JY7131.JY7131CITask
ReadData(ref uint[] bufCount, int samplesToAcquire, int timeout=10000) | JY7131.JY7131CITask
ReadData(ref uint[] bufCount, int timeout=10000) | JY7131.JY7131CITask
ReadData(ref double[] bufMeasurement, int samplesToAcquire, int timeout=10000) | JY7131.JY7131CITask
ReadData(ref double[] bufMeasurement, int timeout=10000) | JY7131.JY7131CITask
ReadData(ref double[] bufMeasurement1, ref double[] bufMeasurement2, int samplesToAcquire, int timeout=10000) | JY7131.JY7131CITask
ReadData(ref double[] bufMeasurement1, ref double[] bufMeasurement2, int timeout=10000) | JY7131.JY7131CITask
ReadSinglePoint(ref uint count) | JY7131.JY7131CITask
ReadSinglePoint(ref double measurement, int timeout=10000) | JY7131.JY7131CITask
ReadSinglePoint(ref double measurement1, ref double measurement2, int timeout=10000) | JY7131.JY7131CITask
SampleClock | JY7131.JY7131CITask
SamplesToAcquire | JY7131.JY7131CITask
SendSoftwareTrigger() | JY7131.JY7131CITask
SignalExport | JY7131.JY7131CITask
Start() | JY7131.JY7131CITask
Stop() | JY7131.JY7131CITask
TransferedSamples | JY7131.JY7131CITask
Trigger | JY7131.JY7131CITask
TwoEdgeSeparation | JY7131.JY7131CITask
TwoPulseEncoder | JY7131.JY7131CITask
Type | JY7131.JY7131CITask


7131 C# Programming Manual: Member List

  • JY7131COTask
JY7131.JY7131COTask Member List

This is the complete list of members for JY7131.JY7131COTask, including all inherited members.

AvaliableLenInSamples | JY7131.JY7131COTask
Device | JY7131.JY7131COTask
IdleState | JY7131.JY7131COTask
InitialDelay | JY7131.JY7131COTask
JY7131COTask(int slotNum, int channel) | JY7131.JY7131COTask
JY7131COTask(string boardName, int channel) | JY7131.JY7131COTask
Mode | JY7131.JY7131COTask
OutputTerminal | JY7131.JY7131COTask
OutTerminalMode | JY7131.JY7131COTask
Pause | JY7131.JY7131COTask
SamplesToUpdate | JY7131.JY7131COTask
SendSoftwareTrigger() | JY7131.JY7131COTask
SignalExport | JY7131.JY7131COTask
Start() | JY7131.JY7131COTask
Stop() | JY7131.JY7131COTask
Timebase | JY7131.JY7131COTask
TransferedPulses | JY7131.JY7131COTask
TransferedSamples | JY7131.JY7131COTask
Trigger | JY7131.JY7131COTask
WaitUntilDone(int timeout=-1) | JY7131.JY7131COTask
WriteData(COPulse[] pulsesGroup, int samplesToWrite, int timeout=10000) | JY7131.JY7131COTask
WriteSinglePoint(COPulse pulse) | JY7131.JY7131COTask


7131 C# Programming Manual: Member List

  • JY7131DITask
JY7131.JY7131DITask Member List

This is the complete list of members for JY7131.JY7131DITask, including all inherited members.

AddChannel(int portNum) | JY7131.JY7131DITask
AddChannel(int[] portsNum) | JY7131.JY7131DITask
Channels | JY7131.JY7131DITask
Device | JY7131.JY7131DITask
JY7131DITask(int slotNum) | JY7131.JY7131DITask
JY7131DITask(string aliasName) | JY7131.JY7131DITask
ReadSinglePoint(ref bool readValue, int port, int line) | JY7131.JY7131DITask
ReadSinglePoint(ref bool[] readValues) | JY7131.JY7131DITask
ReadSinglePoint(ref bool[] readValues, int port) | JY7131.JY7131DITask
RemoveChannel(int portNum) | JY7131.JY7131DITask
Start() | JY7131.JY7131DITask
Stop() | JY7131.JY7131DITask


7131 C# Programming Manual: Member List

  • JY7131DOTask
JY7131.JY7131DOTask Member List

This is the complete list of members for JY7131.JY7131DOTask, including all inherited members.

AddChannel(int portNum) | JY7131.JY7131DOTask
AddChannel(int[] portsNum) | JY7131.JY7131DOTask
Channels | JY7131.JY7131DOTask
Device | JY7131.JY7131DOTask
DOLineMode | JY7131.JY7131DOTask
JY7131DOTask(int slotNum) | JY7131.JY7131DOTask
JY7131DOTask(string aliasName) | JY7131.JY7131DOTask
RemoveChannel(int portNum) | JY7131.JY7131DOTask
Start() | JY7131.JY7131DOTask
Stop() | JY7131.JY7131DOTask
WriteSinglePoint(bool writeValue=false, int port=0, int line=0) | JY7131.JY7131DOTask
WriteSinglePoint(bool[] writeValues) | JY7131.JY7131DOTask
WriteSinglePoint(bool[] writeValues, int port) | JY7131.JY7131DOTask


7131 C# Programming Manual: Member List

  • PauseTrigger
JY7131.PauseTrigger Member List

This is the complete list of members for JY7131.PauseTrigger, including all inherited members.

ActivePolarity | JY7131.PauseTrigger
Terminal | JY7131.PauseTrigger


7131 C# Programming Manual: Member List

  • PeriodMeas
JY7131.PeriodMeas Member List

This is the complete list of members for JY7131.PeriodMeas, including all inherited members.

InputTerminal | JY7131.PeriodMeas
StartingEdge | JY7131.PeriodMeas
Timebase | JY7131.PeriodMeas


7131 C# Programming Manual: Member List

  • QuadEncoder
JY7131.QuadEncoder Member List

This is the complete list of members for JY7131.QuadEncoder, including all inherited members.

AInputTerminal | JY7131.QuadEncoder
BInputTerminal | JY7131.QuadEncoder
EncodingType | JY7131.QuadEncoder
ZInputTerminal | JY7131.QuadEncoder
ZReloadEnabled | JY7131.QuadEncoder


7131 C# Programming Manual: Member List

  • TwoEdgeSeparation
JY7131.TwoEdgeSeparation Member List

This is the complete list of members for JY7131.TwoEdgeSeparation, including all inherited members.

EdgeSeparationMode | JY7131.TwoEdgeSeparation
FirstInputTerminal | JY7131.TwoEdgeSeparation
SecondInputTerminal | JY7131.TwoEdgeSeparation
Timebase | JY7131.TwoEdgeSeparation


7131 C# Programming Manual: Member List

  • TwoPulseEncoder
JY7131.TwoPulseEncoder Member List

This is the complete list of members for JY7131.TwoPulseEncoder, including all inherited members.

AInputTerminal | JY7131.TwoPulseEncoder
BInputTerminal | JY7131.TwoPulseEncoder


7131 C# Programming Manual: Class Index

Class Index
C | D | E | F | J | P | Q | T
C
CIDigitalTrigger (JY7131)
CIExternalSampleClock (JY7131)
CIImplicitSampleClock (JY7131)
CIInternalSampleClock (JY7131)
CISampleClock (JY7131)
CISignalExport (JY7131)
CITimebase (JY7131)
CITrigger (JY7131)
CODigitalTrigger (JY7131)
COExternalTimebase (JY7131)
COPulse (JY7131)
COSignalExport (JY7131)
COTimebase (JY7131)
COTrigger (JY7131)
D
DIChannel (JY7131)
DOChannel (JY7131)
E
EdgeCounting (JY7131)
EdgeCountingOutEvent (JY7131)
F
FrequencyMeas (JY7131)
J
JY7131CITask (JY7131)
JY7131COTask (JY7131)
JY7131DITask (JY7131)
JY7131DOTask (JY7131)
P
PauseTrigger (JY7131)
PeriodMeas (JY7131)
Q
QuadEncoder (JY7131)
T
TwoEdgeSeparation (JY7131)
TwoPulseEncoder (JY7131)


7131 C# Programming Manual: D:/7131 Directory Reference

  • File List
  • 7131
7131 Directory Reference

Directories

C#


7131 C# Programming Manual: File List

  • File List
File List
Here is a list of all files with brief descriptions:
[detail level 123]
▼ 7131
▼ C#
JY7131CITask.cs
JY7131COTask.cs
JY7131DITask.cs
JY7131DOTask.cs


7131 C# Programming Manual: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • j
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- a -

  • ActiveEdge : JY7131.EdgeCounting
  • ActivePolarity : JY7131.PauseTrigger
  • Add() : JY7131.CISignalExport, JY7131.COSignalExport
  • AddChannel() : JY7131.JY7131DITask, JY7131.JY7131DOTask
  • AInputTerminal : JY7131.QuadEncoder, JY7131.TwoPulseEncoder
  • AvailableSamples : JY7131.JY7131CITask
  • AvaliableLenInSamples : JY7131.JY7131COTask

- b -

  • BInputTerminal : JY7131.QuadEncoder, JY7131.TwoPulseEncoder

- c -

  • Channels : JY7131.JY7131DITask, JY7131.JY7131DOTask
  • Clear() : JY7131.CISignalExport, JY7131.COSignalExport
  • ClearAll() : JY7131.CISignalExport, JY7131.COSignalExport
  • COPulse() : JY7131.COPulse

- d -

  • Device : JY7131.JY7131CITask, JY7131.JY7131COTask, JY7131.JY7131DITask, JY7131.JY7131DOTask
  • Digital : JY7131.CITrigger, JY7131.COTrigger
  • Direction : JY7131.EdgeCounting
  • DirTerminal : JY7131.EdgeCounting
  • DOLineMode : JY7131.JY7131DOTask

- e -

  • Edge : JY7131.CIDigitalTrigger, JY7131.CODigitalTrigger
  • EdgeCounting : JY7131.JY7131CITask
  • EdgeSeparationMode : JY7131.TwoEdgeSeparation
  • EncodingType : JY7131.QuadEncoder
  • ExpectedRate : JY7131.CIExternalSampleClock, JY7131.CIImplicitSampleClock
  • External : JY7131.CISampleClock, JY7131.COTimebase

- f -

  • FirstInputTerminal : JY7131.TwoEdgeSeparation
  • Frequency : JY7131.COExternalTimebase
  • FrequencyMeas : JY7131.JY7131CITask

- i -

  • IdleState : JY7131.EdgeCountingOutEvent, JY7131.JY7131COTask
  • IgnoreFirstSampleClock : JY7131.CIExternalSampleClock, JY7131.CIInternalSampleClock
  • Implicit : JY7131.CISampleClock
  • InitialCount : JY7131.EdgeCounting
  • InitialDelay : JY7131.JY7131COTask
  • InputTerminal : JY7131.EdgeCounting, JY7131.FrequencyMeas, JY7131.PeriodMeas
  • Internal : JY7131.CISampleClock

- j -

  • JY7131CITask() : JY7131.JY7131CITask
  • JY7131COTask() : JY7131.JY7131COTask
  • JY7131DITask() : JY7131.JY7131DITask
  • JY7131DOTask() : JY7131.JY7131DOTask

- m -

  • Mode : JY7131.JY7131CITask, JY7131.JY7131COTask

- o -

  • OutEvent : JY7131.EdgeCounting
  • OutputTerminal : JY7131.JY7131COTask
  • OutTerminalMode : JY7131.JY7131COTask

- p -

  • Pause : JY7131.EdgeCounting, JY7131.JY7131COTask
  • PeriodMeas : JY7131.JY7131CITask
  • PortNum : JY7131.DIChannel, JY7131.DOChannel

- q -

  • QuadEncoder : JY7131.JY7131CITask

- r -

  • Rate : JY7131.CIInternalSampleClock
  • ReadData() : JY7131.JY7131CITask
  • ReadSinglePoint() : JY7131.JY7131CITask, JY7131.JY7131DITask
  • RemoveChannel() : JY7131.JY7131DITask, JY7131.JY7131DOTask

- s -

  • SampleClock : JY7131.JY7131CITask
  • SamplesToAcquire : JY7131.JY7131CITask
  • SamplesToUpdate : JY7131.JY7131COTask
  • SecondInputTerminal : JY7131.TwoEdgeSeparation
  • SendSoftwareTrigger() : JY7131.JY7131CITask, JY7131.JY7131COTask
  • SignalExport : JY7131.JY7131CITask, JY7131.JY7131COTask
  • Source : JY7131.CIDigitalTrigger, JY7131.CISampleClock, JY7131.CITimebase, JY7131.CODigitalTrigger, JY7131.COTimebase
  • Start() : JY7131.JY7131CITask, JY7131.JY7131COTask, JY7131.JY7131DITask, JY7131.JY7131DOTask
  • StartingEdge : JY7131.FrequencyMeas, JY7131.PeriodMeas
  • Stop() : JY7131.JY7131CITask, JY7131.JY7131COTask, JY7131.JY7131DITask, JY7131.JY7131DOTask

- t -

  • Terminal : JY7131.CIExternalSampleClock, JY7131.COExternalTimebase, JY7131.EdgeCountingOutEvent, JY7131.PauseTrigger
  • Threshold : JY7131.EdgeCountingOutEvent
  • Timebase : JY7131.FrequencyMeas, JY7131.JY7131COTask, JY7131.PeriodMeas, JY7131.TwoEdgeSeparation
  • TransferedPulses : JY7131.JY7131COTask
  • TransferedSamples : JY7131.JY7131CITask, JY7131.JY7131COTask
  • Trigger : JY7131.JY7131CITask, JY7131.JY7131COTask
  • TwoEdgeSeparation : JY7131.JY7131CITask
  • TwoPulseEncoder : JY7131.JY7131CITask
  • Type : JY7131.CITrigger, JY7131.COTrigger, JY7131.JY7131CITask

- w -

  • WaitUntilDone() : JY7131.JY7131COTask
  • WriteData() : JY7131.JY7131COTask
  • WriteSinglePoint() : JY7131.JY7131COTask, JY7131.JY7131DOTask

- z -

  • ZInputTerminal : JY7131.QuadEncoder
  • ZReloadEnabled : JY7131.QuadEncoder


7131 C# Programming Manual: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • c
  • j
  • r
  • s
  • w
Here is a list of all functions with links to the classes they belong to:

- a -

  • Add() : JY7131.CISignalExport, JY7131.COSignalExport
  • AddChannel() : JY7131.JY7131DITask, JY7131.JY7131DOTask

- c -

  • Clear() : JY7131.CISignalExport, JY7131.COSignalExport
  • ClearAll() : JY7131.CISignalExport, JY7131.COSignalExport
  • COPulse() : JY7131.COPulse

- j -

  • JY7131CITask() : JY7131.JY7131CITask
  • JY7131COTask() : JY7131.JY7131COTask
  • JY7131DITask() : JY7131.JY7131DITask
  • JY7131DOTask() : JY7131.JY7131DOTask

- r -

  • ReadData() : JY7131.JY7131CITask
  • ReadSinglePoint() : JY7131.JY7131CITask, JY7131.JY7131DITask
  • RemoveChannel() : JY7131.JY7131DITask, JY7131.JY7131DOTask

- s -

  • SendSoftwareTrigger() : JY7131.JY7131CITask, JY7131.JY7131COTask
  • Start() : JY7131.JY7131CITask, JY7131.JY7131COTask, JY7131.JY7131DITask, JY7131.JY7131DOTask
  • Stop() : JY7131.JY7131CITask, JY7131.JY7131COTask, JY7131.JY7131DITask, JY7131.JY7131DOTask

- w -

  • WaitUntilDone() : JY7131.JY7131COTask
  • WriteData() : JY7131.JY7131COTask
  • WriteSinglePoint() : JY7131.JY7131COTask, JY7131.JY7131DOTask


7131 C# Programming Manual: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • z
Here is a list of all properties with links to the classes they belong to:

- a -

  • ActiveEdge : JY7131.EdgeCounting
  • ActivePolarity : JY7131.PauseTrigger
  • AInputTerminal : JY7131.QuadEncoder, JY7131.TwoPulseEncoder
  • AvailableSamples : JY7131.JY7131CITask
  • AvaliableLenInSamples : JY7131.JY7131COTask

- b -

  • BInputTerminal : JY7131.QuadEncoder, JY7131.TwoPulseEncoder

- c -

  • Channels : JY7131.JY7131DITask, JY7131.JY7131DOTask

- d -

  • Device : JY7131.JY7131CITask, JY7131.JY7131COTask, JY7131.JY7131DITask, JY7131.JY7131DOTask
  • Digital : JY7131.CITrigger, JY7131.COTrigger
  • Direction : JY7131.EdgeCounting
  • DirTerminal : JY7131.EdgeCounting
  • DOLineMode : JY7131.JY7131DOTask

- e -

  • Edge : JY7131.CIDigitalTrigger, JY7131.CODigitalTrigger
  • EdgeCounting : JY7131.JY7131CITask
  • EdgeSeparationMode : JY7131.TwoEdgeSeparation
  • EncodingType : JY7131.QuadEncoder
  • ExpectedRate : JY7131.CIExternalSampleClock, JY7131.CIImplicitSampleClock
  • External : JY7131.CISampleClock, JY7131.COTimebase

- f -

  • FirstInputTerminal : JY7131.TwoEdgeSeparation
  • Frequency : JY7131.COExternalTimebase
  • FrequencyMeas : JY7131.JY7131CITask

- i -

  • IdleState : JY7131.EdgeCountingOutEvent, JY7131.JY7131COTask
  • IgnoreFirstSampleClock : JY7131.CIExternalSampleClock, JY7131.CIInternalSampleClock
  • Implicit : JY7131.CISampleClock
  • InitialCount : JY7131.EdgeCounting
  • InitialDelay : JY7131.JY7131COTask
  • InputTerminal : JY7131.EdgeCounting, JY7131.FrequencyMeas, JY7131.PeriodMeas
  • Internal : JY7131.CISampleClock

- m -

  • Mode : JY7131.JY7131CITask, JY7131.JY7131COTask

- o -

  • OutEvent : JY7131.EdgeCounting
  • OutputTerminal : JY7131.JY7131COTask
  • OutTerminalMode : JY7131.JY7131COTask

- p -

  • Pause : JY7131.EdgeCounting, JY7131.JY7131COTask
  • PeriodMeas : JY7131.JY7131CITask
  • PortNum : JY7131.DIChannel, JY7131.DOChannel

- q -

  • QuadEncoder : JY7131.JY7131CITask

- r -

  • Rate : JY7131.CIInternalSampleClock

- s -

  • SampleClock : JY7131.JY7131CITask
  • SamplesToAcquire : JY7131.JY7131CITask
  • SamplesToUpdate : JY7131.JY7131COTask
  • SecondInputTerminal : JY7131.TwoEdgeSeparation
  • SignalExport : JY7131.JY7131CITask, JY7131.JY7131COTask
  • Source : JY7131.CIDigitalTrigger, JY7131.CISampleClock, JY7131.CITimebase, JY7131.CODigitalTrigger, JY7131.COTimebase
  • StartingEdge : JY7131.FrequencyMeas, JY7131.PeriodMeas

- t -

  • Terminal : JY7131.CIExternalSampleClock, JY7131.COExternalTimebase, JY7131.EdgeCountingOutEvent, JY7131.PauseTrigger
  • Threshold : JY7131.EdgeCountingOutEvent
  • Timebase : JY7131.FrequencyMeas, JY7131.JY7131COTask, JY7131.PeriodMeas, JY7131.TwoEdgeSeparation
  • TransferedPulses : JY7131.JY7131COTask
  • TransferedSamples : JY7131.JY7131CITask, JY7131.JY7131COTask
  • Trigger : JY7131.JY7131CITask, JY7131.JY7131COTask
  • TwoEdgeSeparation : JY7131.JY7131CITask
  • TwoPulseEncoder : JY7131.JY7131CITask
  • Type : JY7131.CITrigger, JY7131.COTrigger, JY7131.JY7131CITask

- z -

  • ZInputTerminal : JY7131.QuadEncoder
  • ZReloadEnabled : JY7131.QuadEncoder


7131 C# Programming Manual: Main Page

7131 C# Programming Manual Documentation


7131 C# Programming Manual: JY7131 Namespace Reference

  • Package List
  • Package Members
Classes | Enumerations
JY7131 Namespace Reference

Classes

class | CIDigitalTrigger
CI Digital trigger . More...
class | CIExternalSampleClock
CI Implicit Sample Clock class. More...
class | CIImplicitSampleClock
CI Implicit Sample Clock class. More...
class | CIInternalSampleClock
CI Internal Sample Clock Configuration Class. More...
class | CISampleClock
CI Sample Clock class. More...
class | CISignalExport
CI Signal Export Class. More...
class | CITimebase
class | CITrigger
Constructor to create an CITrigger task object. More...
class | CODigitalTrigger
CO Digital trigger . More...
class | COExternalTimebase
class | COPulse
Pulse Parameter. More...
class | COSignalExport
CO Signal Export Class. More...
class | COTimebase
class | COTrigger
Constructor to create an COTrigger task object. More...
class | DIChannel
DI Channel parameter class. More...
class | DOChannel
DO Channel parameter class. More...
class | EdgeCounting
Configure CI EdgeCounting. More...
class | EdgeCountingOutEvent
Edge counting output event configuration class. More...
class | FrequencyMeas
Configure CI Measure. More...
class | JY7131CITask
JY7131 Counter Input Task. More...
class | JY7131COTask
JY7131 Counter Output Task. More...
class | JY7131DITask
JY7131DITask Class. More...
class | JY7131DOTask
JY7131 DOTask. More...
class | PauseTrigger
Pause trigger configuration class. More...
class | PeriodMeas
Configure CI Measure. More...
class | QuadEncoder
Configure CI Measure. More...
class | TwoEdgeSeparation
Configure CI Measure. More...
class | TwoPulseEncoder
Configure CI Measure. More...

Enumerations

enum | CountDirection { Up = JY7131Import.JY7131_CI_Count_Up , Down = JY7131Import.JY7131_CI_Count_Down , External = JY7131Import.JY7131_CI_Count_External }
Counter direction. More...
enum | CIMode { Single = JY7131Import.JY7131_CI_Single , Finite = JY7131Import.JY7131_CI_Finite , Continuous = JY7131Import.JY7131_CI_Continuous }
CIMode. More...
enum CIType {
EdgeCounting , Period , Frequency , TwoEdgeSeparation ,
QuadEncoder , TwoPulseEncoder
}
Counter Input Application Type. More...
enum | CISampleClockSource { Implicit = JY7131Import.JY7131_CI_ImplicitClock , Internal = JY7131Import.JY7131_CI_InternalClock , External = JY7131Import.JY7131_CI_ExternalClock }
CI Sample Clock Source. More...
enum ClockTerminal {
PFI_In_0 = JY7131Import.JY7131_Clock_PFI_0 , PFI_In_1 = JY7131Import.JY7131_Clock_PFI_1 , PFI_In_2 = JY7131Import.JY7131_Clock_PFI_2 , PFI_In_3 = JY7131Import.JY7131_Clock_PFI_3 ,
PFI_In_4 = JY7131Import.JY7131_Clock_PFI_4 , PFI_In_5 = JY7131Import.JY7131_Clock_PFI_5 , PFI_In_6 = JY7131Import.JY7131_Clock_PFI_6 , PFI_In_7 = JY7131Import.JY7131_Clock_PFI_7 ,
PFI_In_8 = JY7131Import.JY7131_Clock_PFI_8 , PFI_In_9 = JY7131Import.JY7131_Clock_PFI_9 , PFI_In_10 = JY7131Import.JY7131_Clock_PFI_10 , PFI_In_11 = JY7131Import.JY7131_Clock_PFI_11 ,
PFI_In_12 = JY7131Import.JY7131_Clock_PFI_12 , PFI_In_13 = JY7131Import.JY7131_Clock_PFI_13 , PFI_In_14 = JY7131Import.JY7131_Clock_PFI_14 , PFI_In_15 = JY7131Import.JY7131_Clock_PFI_15 ,
PFI_In_16 = JY7131Import.JY7131_Clock_PFI_16 , PFI_In_17 = JY7131Import.JY7131_Clock_PFI_17 , PFI_In_18 = JY7131Import.JY7131_Clock_PFI_18 , PFI_In_19 = JY7131Import.JY7131_Clock_PFI_19 ,
PFI_In_20 = JY7131Import.JY7131_Clock_PFI_20 , PFI_In_21 = JY7131Import.JY7131_Clock_PFI_21 , PFI_In_22 = JY7131Import.JY7131_Clock_PFI_22 , PFI_In_23 = JY7131Import.JY7131_Clock_PFI_23 ,
PFI_In_24 = JY7131Import.JY7131_Clock_PFI_24 , PFI_In_25 = JY7131Import.JY7131_Clock_PFI_25 , PFI_In_26 = JY7131Import.JY7131_Clock_PFI_26 , PFI_In_27 = JY7131Import.JY7131_Clock_PFI_27 ,
PFI_In_28 = JY7131Import.JY7131_Clock_PFI_28 , PFI_In_29 = JY7131Import.JY7131_Clock_PFI_29 , PFI_In_30 = JY7131Import.JY7131_Clock_PFI_30 , PFI_In_31 = JY7131Import.JY7131_Clock_PFI_31 ,
PXI_Trig0 = JY7131Import.JY7131_Clock_PXI_Trig_0 , PXI_Trig1 = JY7131Import.JY7131_Clock_PXI_Trig_1 , PXI_Trig2 = JY7131Import.JY7131_Clock_PXI_Trig_2 , PXI_Trig3 = JY7131Import.JY7131_Clock_PXI_Trig_3 ,
PXI_Trig4 = JY7131Import.JY7131_Clock_PXI_Trig_4 , PXI_Trig5 = JY7131Import.JY7131_Clock_PXI_Trig_5 , PXI_Trig6 = JY7131Import.JY7131_Clock_PXI_Trig_6 , PXI_Trig7 = JY7131Import.JY7131_Clock_PXI_Trig_7 ,
CI0_SampleClock = JY7131Import.JY7131_Clock_CIO_0_SampleClock , CI1_SampleClock = JY7131Import.JY7131_Clock_CIO_1_SampleClock , CI2_SampleClock = JY7131Import.JY7131_Clock_CIO_2_SampleClock , CI3_SampleClock = JY7131Import.JY7131_Clock_CIO_3_SampleClock ,
CI4_SampleClock = JY7131Import.JY7131_Clock_CIO_4_SampleClock , CI5_SampleClock = JY7131Import.JY7131_Clock_CIO_5_SampleClock , CI6_SampleClock = JY7131Import.JY7131_Clock_CIO_6_SampleClock , CI7_SampleClock = JY7131Import.JY7131_Clock_CIO_7_SampleClock ,
CO0_Output = JY7131Import.JY7131_Clock_Counter_0_Output , CO1_Output = JY7131Import.JY7131_Clock_Counter_1_Output , CO2_Output = JY7131Import.JY7131_Clock_Counter_2_Output , CO3_Output = JY7131Import.JY7131_Clock_Counter_3_Output ,
CO4_Output = JY7131Import.JY7131_Clock_Counter_4_Output , CO5_Output = JY7131Import.JY7131_Clock_Counter_5_Output , CO6_Output = JY7131Import.JY7131_Clock_Counter_6_Output , CO7_Output = JY7131Import.JY7131_Clock_Counter_7_Output
}
External Sample Clock Terminal. More...
enum | EdgeType { Rising = JY7131Import.JY7131_RisingEdge , Falling = JY7131Import.JY7131_FallingEdge , Any = JY7131Import.JY7131_AnyEdge }
Edge Type. More...
enum | CITimebaseSource { Internal100MHz = JY7131Import.JY7131_Internal_Timebase_100M , Internal5MHz = JY7131Import.JY7131_Internal_Timebase_5M , Internal100kHz = JY7131Import.JY7131_Internal_Timebase_100K }
enum | EdgeCntOunEvtIdleState { LowLevel = JY7131Import.JY7131_CI_CounterEventSignalIdleState_Low , HighLevel = JY7131Import.JY7131_CI_CounterEventSignalIdleState_High }
Output idle state when the event has not occurred. More...
enum | LevelPolarity { LowLevel = 0 , HighLevel = 1 , None = 2 }
Level Polarity. More...
enum | ValueReturnMode { TwoValue = JY7131Import.JY7131_CI_ReturnTwoValue , OneValue = JY7131Import.JY7131_CI_ReturnOneValue }
TwoEdgeSeparation value return mode.only for TwoEdgeSeparation type. More...
enum | QuadEncodingType { X1 , X2 , X4 }
Quadrature Encoding Type. More...
enum | CITriggerType { Immediate = JY7131Import.JY7131_CIO_Immediately , Digital = JY7131Import.JY7131_CIO_Digital , Soft = JY7131Import.JY7131_CIO_Soft }
TriggerType Digital/Immediate/Soft. More...
enum CIDigitalTriggerSource {
PFI_In_0 = JY7131Import.JY7131_DigitalTriggerSource_PFI_0 , PFI_In_1 = JY7131Import.JY7131_DigitalTriggerSource_PFI_1 , PFI_In_2 = JY7131Import.JY7131_DigitalTriggerSource_PFI_2 , PFI_In_3 = JY7131Import.JY7131_DigitalTriggerSource_PFI_3 ,
PFI_In_4 = JY7131Import.JY7131_DigitalTriggerSource_PFI_4 , PFI_In_5 = JY7131Import.JY7131_DigitalTriggerSource_PFI_5 , PFI_In_6 = JY7131Import.JY7131_DigitalTriggerSource_PFI_6 , PFI_In_7 = JY7131Import.JY7131_DigitalTriggerSource_PFI_7 ,
PFI_In_8 = JY7131Import.JY7131_DigitalTriggerSource_PFI_8 , PFI_In_9 = JY7131Import.JY7131_DigitalTriggerSource_PFI_9 , PFI_In_10 = JY7131Import.JY7131_DigitalTriggerSource_PFI_10 , PFI_In_11 = JY7131Import.JY7131_DigitalTriggerSource_PFI_11 ,
PFI_In_12 = JY7131Import.JY7131_DigitalTriggerSource_PFI_12 , PFI_In_13 = JY7131Import.JY7131_DigitalTriggerSource_PFI_13 , PFI_In_14 = JY7131Import.JY7131_DigitalTriggerSource_PFI_14 , PFI_In_15 = JY7131Import.JY7131_DigitalTriggerSource_PFI_15 ,
PFI_In_16 = JY7131Import.JY7131_DigitalTriggerSource_PFI_16 , PFI_In_17 = JY7131Import.JY7131_DigitalTriggerSource_PFI_17 , PFI_In_18 = JY7131Import.JY7131_DigitalTriggerSource_PFI_18 , PFI_In_19 = JY7131Import.JY7131_DigitalTriggerSource_PFI_19 ,
PFI_In_20 = JY7131Import.JY7131_DigitalTriggerSource_PFI_20 , PFI_In_21 = JY7131Import.JY7131_DigitalTriggerSource_PFI_21 , PFI_In_22 = JY7131Import.JY7131_DigitalTriggerSource_PFI_22 , PFI_In_23 = JY7131Import.JY7131_DigitalTriggerSource_PFI_23 ,
PFI_In_24 = JY7131Import.JY7131_DigitalTriggerSource_PFI_24 , PFI_In_25 = JY7131Import.JY7131_DigitalTriggerSource_PFI_25 , PFI_In_26 = JY7131Import.JY7131_DigitalTriggerSource_PFI_26 , PFI_In_27 = JY7131Import.JY7131_DigitalTriggerSource_PFI_27 ,
PFI_In_28 = JY7131Import.JY7131_DigitalTriggerSource_PFI_28 , PFI_In_29 = JY7131Import.JY7131_DigitalTriggerSource_PFI_29 , PFI_In_30 = JY7131Import.JY7131_DigitalTriggerSource_PFI_30 , PFI_In_31 = JY7131Import.JY7131_DigitalTriggerSource_PFI_31 ,
PXI_Trig0 = JY7131Import.JY7131_DigitalTriggerSource_PXI_Trig_0 , PXI_Trig1 = JY7131Import.JY7131_DigitalTriggerSource_PXI_Trig_1 , PXI_Trig2 = JY7131Import.JY7131_DigitalTriggerSource_PXI_Trig_2 , PXI_Trig3 = JY7131Import.JY7131_DigitalTriggerSource_PXI_Trig_3 ,
PXI_Trig4 = JY7131Import.JY7131_DigitalTriggerSource_PXI_Trig_4 , PXI_Trig5 = JY7131Import.JY7131_DigitalTriggerSource_PXI_Trig_5 , PXI_Trig6 = JY7131Import.JY7131_DigitalTriggerSource_PXI_Trig_6 , PXI_Trig7 = JY7131Import.JY7131_DigitalTriggerSource_PXI_Trig_7 ,
CIO_0_StartTrig = JY7131Import.JY7131_DigitalTriggerSource_CIO_0_StartTrig , CIO_1_StartTrig = JY7131Import.JY7131_DigitalTriggerSource_CIO_1_StartTrig , CIO_2_StartTrig = JY7131Import.JY7131_DigitalTriggerSource_CIO_2_StartTrig , CIO_3_StartTrig = JY7131Import.JY7131_DigitalTriggerSource_CIO_3_StartTrig ,
CIO_4_StartTrig = JY7131Import.JY7131_DigitalTriggerSource_CIO_4_StartTrig , CIO_5_StartTrig = JY7131Import.JY7131_DigitalTriggerSource_CIO_5_StartTrig , CIO_6_StartTrig = JY7131Import.JY7131_DigitalTriggerSource_CIO_6_StartTrig , CIO_7_StartTrig = JY7131Import.JY7131_DigitalTriggerSource_CIO_7_StartTrig ,
CO_0_OutPut = JY7131Import.JY7131_DigitalTriggerSource_Counter_0_Output , CO_1_OutPut = JY7131Import.JY7131_DigitalTriggerSource_Counter_1_Output , CO_2_OutPut = JY7131Import.JY7131_DigitalTriggerSource_Counter_2_Output , CO_3_OutPut = JY7131Import.JY7131_DigitalTriggerSource_Counter_3_Output ,
CO_4_OutPut = JY7131Import.JY7131_DigitalTriggerSource_Counter_4_Output , CO_5_OutPut = JY7131Import.JY7131_DigitalTriggerSource_Counter_5_Output , CO_6_OutPut = JY7131Import.JY7131_DigitalTriggerSource_Counter_6_Output , CO_7_OutPut = JY7131Import.JY7131_DigitalTriggerSource_Counter_7_Output
}
CI Digital trigger source. More...
enum | CIDigitalTriggerEdge { Rising , Falling }
CI Digital Trigger Edge. More...
enum InputTerminal {
PFI_In_0 = JY7131Import.JY7131_IN_PFI0 , PFI_In_1 = JY7131Import.JY7131_IN_PFI1 , PFI_In_2 = JY7131Import.JY7131_IN_PFI2 , PFI_In_3 = JY7131Import.JY7131_IN_PFI3 ,
PFI_In_4 = JY7131Import.JY7131_IN_PFI4 , PFI_In_5 = JY7131Import.JY7131_IN_PFI5 , PFI_In_6 = JY7131Import.JY7131_IN_PFI6 , PFI_In_7 = JY7131Import.JY7131_IN_PFI7 ,
PFI_In_8 = JY7131Import.JY7131_IN_PFI8 , PFI_In_9 = JY7131Import.JY7131_IN_PFI9 , PFI_In_10 = JY7131Import.JY7131_IN_PFI10 , PFI_In_11 = JY7131Import.JY7131_IN_PFI11 ,
PFI_In_12 = JY7131Import.JY7131_IN_PFI12 , PFI_In_13 = JY7131Import.JY7131_IN_PFI13 , PFI_In_14 = JY7131Import.JY7131_IN_PFI14 , PFI_In_15 = JY7131Import.JY7131_IN_PFI15 ,
PFI_In_16 = JY7131Import.JY7131_IN_PFI16 , PFI_In_17 = JY7131Import.JY7131_IN_PFI17 , PFI_In_18 = JY7131Import.JY7131_IN_PFI18 , PFI_In_19 = JY7131Import.JY7131_IN_PFI19 ,
PFI_In_20 = JY7131Import.JY7131_IN_PFI20 , PFI_In_21 = JY7131Import.JY7131_IN_PFI21 , PFI_In_22 = JY7131Import.JY7131_IN_PFI22 , PFI_In_23 = JY7131Import.JY7131_IN_PFI23 ,
PFI_In_24 = JY7131Import.JY7131_IN_PFI24 , PFI_In_25 = JY7131Import.JY7131_IN_PFI25 , PFI_In_26 = JY7131Import.JY7131_IN_PFI26 , PFI_In_27 = JY7131Import.JY7131_IN_PFI27 ,
PFI_In_28 = JY7131Import.JY7131_IN_PFI28 , PFI_In_29 = JY7131Import.JY7131_IN_PFI29 , PFI_In_30 = JY7131Import.JY7131_IN_PFI30 , PFI_In_31 = JY7131Import.JY7131_IN_PFI31 ,
PXI_Trig0 = JY7131Import.JY7131_IN_PXI_Trig_0 , PXI_Trig1 = JY7131Import.JY7131_IN_PXI_Trig_1 , PXI_Trig2 = JY7131Import.JY7131_IN_PXI_Trig_2 , PXI_Trig3 = JY7131Import.JY7131_IN_PXI_Trig_3 ,
PXI_Trig4 = JY7131Import.JY7131_IN_PXI_Trig_4 , PXI_Trig5 = JY7131Import.JY7131_IN_PXI_Trig_5 , PXI_Trig6 = JY7131Import.JY7131_IN_PXI_Trig_6 , PXI_Trig7 = JY7131Import.JY7131_IN_PXI_Trig_7 ,
CI_0_OutPut = JY7131Import.JY7131_IN_Counter_0_Output , CI_1_OutPut = JY7131Import.JY7131_IN_Counter_1_Output , CI_2_OutPut = JY7131Import.JY7131_IN_Counter_2_Output , CI_3_OutPut = JY7131Import.JY7131_IN_Counter_3_Output ,
CI_4_OutPut = JY7131Import.JY7131_IN_Counter_4_Output , CI_5_OutPut = JY7131Import.JY7131_IN_Counter_5_Output , CI_6_OutPut = JY7131Import.JY7131_IN_Counter_6_Output , CI_7_OutPut = JY7131Import.JY7131_IN_Counter_7_Output ,
Timebase_100MHz = JY7131Import.JY7131_IN_CIO_100MHz , Timebase_5MHz = JY7131Import.JY7131_IN_CIO_5MHz , Timebase_100kHz = JY7131Import.JY7131_IN_CIO_100kHz
}
enum IOTerminal {
None = JY7131Import.JY7131_None , PFI_Out_0 = JY7131Import.JY7131_IN_PFI0 , PFI_Out_1 = JY7131Import.JY7131_IN_PFI1 , PFI_Out_2 = JY7131Import.JY7131_IN_PFI2 ,
PFI_Out_3 = JY7131Import.JY7131_IN_PFI3 , PFI_Out_4 = JY7131Import.JY7131_IN_PFI4 , PFI_Out_5 = JY7131Import.JY7131_IN_PFI5 , PFI_Out_6 = JY7131Import.JY7131_IN_PFI6 ,
PFI_Out_7 = JY7131Import.JY7131_IN_PFI7 , PFI_Out_8 = JY7131Import.JY7131_IN_PFI8 , PFI_Out_9 = JY7131Import.JY7131_IN_PFI9 , PFI_Out_10 = JY7131Import.JY7131_IN_PFI10 ,
PFI_Out_11 = JY7131Import.JY7131_IN_PFI11 , PFI_Out_12 = JY7131Import.JY7131_IN_PFI12 , PFI_Out_13 = JY7131Import.JY7131_IN_PFI13 , PFI_Out_14 = JY7131Import.JY7131_IN_PFI14 ,
PFI_Out_15 = JY7131Import.JY7131_IN_PFI15 , PFI_Out_16 = JY7131Import.JY7131_IN_PFI16 , PFI_Out_17 = JY7131Import.JY7131_IN_PFI17 , PFI_Out_18 = JY7131Import.JY7131_IN_PFI18 ,
PFI_Out_19 = JY7131Import.JY7131_IN_PFI19 , PFI_Out_20 = JY7131Import.JY7131_IN_PFI20 , PFI_Out_21 = JY7131Import.JY7131_IN_PFI21 , PFI_Out_22 = JY7131Import.JY7131_IN_PFI22 ,
PFI_Out_23 = JY7131Import.JY7131_IN_PFI23 , PFI_Out_24 = JY7131Import.JY7131_IN_PFI24 , PFI_Out_25 = JY7131Import.JY7131_IN_PFI25 , PFI_Out_26 = JY7131Import.JY7131_IN_PFI26 ,
PFI_Out_27 = JY7131Import.JY7131_IN_PFI27 , PFI_Out_28 = JY7131Import.JY7131_IN_PFI28 , PFI_Out_29 = JY7131Import.JY7131_IN_PFI29 , PFI_Out_30 = JY7131Import.JY7131_IN_PFI30 ,
PFI_Out_31 = JY7131Import.JY7131_IN_PFI31 , PXI_Trig0 = JY7131Import.JY7131_IN_PXI_Trig_0 , PXI_Trig1 = JY7131Import.JY7131_IN_PXI_Trig_1 , PXI_Trig2 = JY7131Import.JY7131_IN_PXI_Trig_2 ,
PXI_Trig3 = JY7131Import.JY7131_IN_PXI_Trig_3 , PXI_Trig4 = JY7131Import.JY7131_IN_PXI_Trig_4 , PXI_Trig5 = JY7131Import.JY7131_IN_PXI_Trig_5 , PXI_Trig6 = JY7131Import.JY7131_IN_PXI_Trig_6 ,
PXI_Trig7 = JY7131Import.JY7131_IN_PXI_Trig_7
}
enum SignalExportDestination {
PFI_In_0 = JY7131Import.JY7131_PFI0_OUT , PFI_In_1 = JY7131Import.JY7131_PFI1_OUT , PFI_In_2 = JY7131Import.JY7131_PFI2_OUT , PFI_In_3 = JY7131Import.JY7131_PFI3_OUT ,
PFI_In_4 = JY7131Import.JY7131_PFI4_OUT , PFI_In_5 = JY7131Import.JY7131_PFI5_OUT , PFI_In_6 = JY7131Import.JY7131_PFI6_OUT , PFI_In_7 = JY7131Import.JY7131_PFI7_OUT ,
PFI_In_8 = JY7131Import.JY7131_PFI8_OUT , PFI_In_9 = JY7131Import.JY7131_PFI9_OUT , PFI_In_10 = JY7131Import.JY7131_PFI10_OUT , PFI_In_11 = JY7131Import.JY7131_PFI11_OUT ,
PFI_In_12 = JY7131Import.JY7131_PFI12_OUT , PFI_In_13 = JY7131Import.JY7131_PFI13_OUT , PFI_In_14 = JY7131Import.JY7131_PFI14_OUT , PFI_In_15 = JY7131Import.JY7131_PFI15_OUT ,
PFI_In_16 = JY7131Import.JY7131_PFI16_OUT , PFI_In_17 = JY7131Import.JY7131_PFI17_OUT , PFI_In_18 = JY7131Import.JY7131_PFI18_OUT , PFI_In_19 = JY7131Import.JY7131_PFI19_OUT ,
PFI_In_20 = JY7131Import.JY7131_PFI20_OUT , PFI_In_21 = JY7131Import.JY7131_PFI21_OUT , PFI_In_22 = JY7131Import.JY7131_PFI22_OUT , PFI_In_23 = JY7131Import.JY7131_PFI23_OUT ,
PFI_In_24 = JY7131Import.JY7131_PFI24_OUT , PFI_In_25 = JY7131Import.JY7131_PFI25_OUT , PFI_In_26 = JY7131Import.JY7131_PFI26_OUT , PFI_In_27 = JY7131Import.JY7131_PFI27_OUT ,
PFI_In_28 = JY7131Import.JY7131_PFI28_OUT , PFI_In_29 = JY7131Import.JY7131_PFI29_OUT , PFI_In_30 = JY7131Import.JY7131_PFI30_OUT , PFI_In_31 = JY7131Import.JY7131_PFI31_OUT ,
PXI_Trig0 = JY7131Import.JY7131_PXITrig0_OUT , PXI_Trig1 = JY7131Import.JY7131_PXITrig1_OUT , PXI_Trig2 = JY7131Import.JY7131_PXITrig2_OUT , PXI_Trig3 = JY7131Import.JY7131_PXITrig3_OUT ,
PXI_Trig4 = JY7131Import.JY7131_PXITrig4_OUT , PXI_Trig5 = JY7131Import.JY7131_PXITrig5_OUT , PXI_Trig6 = JY7131Import.JY7131_PXITrig6_OUT , PXI_Trig7 = JY7131Import.JY7131_PXITrig7_OUT
}
Output DestinationTerminal. More...
enum | CISignalExportSource { StartTrig , SampleClock }
SourceSignal. More...
enum | COIdleState { HighLevel = JY7131Import.JY7131_HighLevel , LowLevel = JY7131Import.JY7131_LowLevel }
Idle state when pulse output before start and after stop. More...
enum | COMode { Single = JY7131Import.JY7131_CO_Single , Finite = JY7131Import.JY7131_CO_Finite , ContinuousNoWrapping = JY7131Import.JY7131_CO_ContinuousNoWrapping , ContinuousWrapping = JY7131Import.JY7131_CO_ContinuousWrapping }
CO output mode. More...
enum | COTriggerType { Immediate = JY7131Import.JY7131_CIO_Immediately , Digital = JY7131Import.JY7131_CIO_Digital , Soft = JY7131Import.JY7131_CIO_Soft }
TriggerType Digital/Immediate/Soft. More...
enum CODigitalTriggerSource {
PFI_In_0 = JY7131Import.JY7131_DigitalTriggerSource_PFI_0 , PFI_In_1 = JY7131Import.JY7131_DigitalTriggerSource_PFI_1 , PFI_In_2 = JY7131Import.JY7131_DigitalTriggerSource_PFI_2 , PFI_In_3 = JY7131Import.JY7131_DigitalTriggerSource_PFI_3 ,
PFI_In_4 = JY7131Import.JY7131_DigitalTriggerSource_PFI_4 , PFI_In_5 = JY7131Import.JY7131_DigitalTriggerSource_PFI_5 , PFI_In_6 = JY7131Import.JY7131_DigitalTriggerSource_PFI_6 , PFI_In_7 = JY7131Import.JY7131_DigitalTriggerSource_PFI_7 ,
PFI_In_8 = JY7131Import.JY7131_DigitalTriggerSource_PFI_8 , PFI_In_9 = JY7131Import.JY7131_DigitalTriggerSource_PFI_9 , PFI_In_10 = JY7131Import.JY7131_DigitalTriggerSource_PFI_10 , PFI_In_11 = JY7131Import.JY7131_DigitalTriggerSource_PFI_11 ,
PFI_In_12 = JY7131Import.JY7131_DigitalTriggerSource_PFI_12 , PFI_In_13 = JY7131Import.JY7131_DigitalTriggerSource_PFI_13 , PFI_In_14 = JY7131Import.JY7131_DigitalTriggerSource_PFI_14 , PFI_In_15 = JY7131Import.JY7131_DigitalTriggerSource_PFI_15 ,
PFI_In_16 = JY7131Import.JY7131_DigitalTriggerSource_PFI_16 , PFI_In_17 = JY7131Import.JY7131_DigitalTriggerSource_PFI_17 , PFI_In_18 = JY7131Import.JY7131_DigitalTriggerSource_PFI_18 , PFI_In_19 = JY7131Import.JY7131_DigitalTriggerSource_PFI_19 ,
PFI_In_20 = JY7131Import.JY7131_DigitalTriggerSource_PFI_20 , PFI_In_21 = JY7131Import.JY7131_DigitalTriggerSource_PFI_21 , PFI_In_22 = JY7131Import.JY7131_DigitalTriggerSource_PFI_22 , PFI_In_23 = JY7131Import.JY7131_DigitalTriggerSource_PFI_23 ,
PFI_In_24 = JY7131Import.JY7131_DigitalTriggerSource_PFI_24 , PFI_In_25 = JY7131Import.JY7131_DigitalTriggerSource_PFI_25 , PFI_In_26 = JY7131Import.JY7131_DigitalTriggerSource_PFI_26 , PFI_In_27 = JY7131Import.JY7131_DigitalTriggerSource_PFI_27 ,
PFI_In_28 = JY7131Import.JY7131_DigitalTriggerSource_PFI_28 , PFI_In_29 = JY7131Import.JY7131_DigitalTriggerSource_PFI_29 , PFI_In_30 = JY7131Import.JY7131_DigitalTriggerSource_PFI_30 , PFI_In_31 = JY7131Import.JY7131_DigitalTriggerSource_PFI_31 ,
PXI_Trig0 = JY7131Import.JY7131_DigitalTriggerSource_PXI_Trig_0 , PXI_Trig1 = JY7131Import.JY7131_DigitalTriggerSource_PXI_Trig_1 , PXI_Trig2 = JY7131Import.JY7131_DigitalTriggerSource_PXI_Trig_2 , PXI_Trig3 = JY7131Import.JY7131_DigitalTriggerSource_PXI_Trig_3 ,
PXI_Trig4 = JY7131Import.JY7131_DigitalTriggerSource_PXI_Trig_4 , PXI_Trig5 = JY7131Import.JY7131_DigitalTriggerSource_PXI_Trig_5 , PXI_Trig6 = JY7131Import.JY7131_DigitalTriggerSource_PXI_Trig_6 , PXI_Trig7 = JY7131Import.JY7131_DigitalTriggerSource_PXI_Trig_7 ,
CIO_0_StartTrig = JY7131Import.JY7131_DigitalTriggerSource_CIO_0_StartTrig , CIO_1_StartTrig = JY7131Import.JY7131_DigitalTriggerSource_CIO_1_StartTrig , CIO_2_StartTrig = JY7131Import.JY7131_DigitalTriggerSource_CIO_2_StartTrig , CIO_3_StartTrig = JY7131Import.JY7131_DigitalTriggerSource_CIO_3_StartTrig ,
CIO_4_StartTrig = JY7131Import.JY7131_DigitalTriggerSource_CIO_4_StartTrig , CIO_5_StartTrig = JY7131Import.JY7131_DigitalTriggerSource_CIO_5_StartTrig , CIO_6_StartTrig = JY7131Import.JY7131_DigitalTriggerSource_CIO_6_StartTrig , CIO_7_StartTrig = JY7131Import.JY7131_DigitalTriggerSource_CIO_7_StartTrig ,
CO_0_OutPut = JY7131Import.JY7131_DigitalTriggerSource_Counter_0_Output , CO_1_OutPut = JY7131Import.JY7131_DigitalTriggerSource_Counter_1_Output , CO_2_OutPut = JY7131Import.JY7131_DigitalTriggerSource_Counter_2_Output , CO_3_OutPut = JY7131Import.JY7131_DigitalTriggerSource_Counter_3_Output ,
CO_4_OutPut = JY7131Import.JY7131_DigitalTriggerSource_Counter_4_Output , CO_5_OutPut = JY7131Import.JY7131_DigitalTriggerSource_Counter_5_Output , CO_6_OutPut = JY7131Import.JY7131_DigitalTriggerSource_Counter_6_Output , CO_7_OutPut = JY7131Import.JY7131_DigitalTriggerSource_Counter_7_Output
}
CO Digital trigger source. More...
enum | CODigitalTriggerEdge { Rising , Falling }
CO Digital Trigger Edge. More...
enum | COPulseType { DutyCycleFrequency , HighLowTime , HighLowTick }
Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick. More...
enum | COTimebaseSource { Internal100MHz = 0 , Internal5MHz = 1 , Internal100kHz = 2 , External = 3 }
enum | COSignalExportSource { StartTrig , Output }
SourceSignal. More...
enum | DOLineMode { Sourcing = 0 , Sinking = 1 , Push_Pull = 2 }
Channel Type. More...

Enumeration Type Documentation

◆ CIDigitalTriggerEdge

enum JY7131.CIDigitalTriggerEdge

CI Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ CIDigitalTriggerSource

enum JY7131.CIDigitalTriggerSource

CI Digital trigger source.

Enumerator
PFI_In_0 | PFI_In_0.
PFI_In_1 | PFI_In_1.
PFI_In_2 | PFI_In_2.
PFI_In_3 | PFI_In_3.
PFI_In_4 | PFI_In_4.
PFI_In_5 | PFI_In_5.
PFI_In_6 | PFI_In_6.
PFI_In_7 | PFI_In_7.
PFI_In_8 | PFI_In_8.
PFI_In_9 | PFI_In_9.
PFI_In_10 | PFI_In_10.
PFI_In_11 | PFI_In_11.
PFI_In_12 | PFI_In_12.
PFI_In_13 | PFI_In_13.
PFI_In_14 | PFI_In_14.
PFI_In_15 | PFI_In_15.
PFI_In_16 | PFI_In_16.
PFI_In_17 | PFI_In_17.
PFI_In_18 | PFI_In_18.
PFI_In_19 | PFI_In_19.
PFI_In_20 | PFI_In_20.
PFI_In_21 | PFI_In_21.
PFI_In_22 | PFI_In_22.
PFI_In_23 | PFI_In_23.
PFI_In_24 | PFI_In_24.
PFI_In_25 | PFI_In_25.
PFI_In_26 | PFI_In_26.
PFI_In_27 | PFI_In_27.
PFI_In_28 | PFI_In_28.
PFI_In_29 | PFI_In_29.
PFI_In_30 | PFI_In_30.
PFI_In_31 | PFI_In_31.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
CIO_0_StartTrig | CIO0_StartTrig.
CIO_1_StartTrig | CI1_StartTrig.
CIO_2_StartTrig | CIO2_StartTrig.
CIO_3_StartTrig | CI3_StartTrig.
CIO_4_StartTrig | CIO4_StartTrig.
CIO_5_StartTrig | CI5_StartTrig.
CIO_6_StartTrig | CIO6_StartTrig.
CIO_7_StartTrig | CI7_StartTrig.
CO_0_OutPut | CO_0_OutPut.
CO_1_OutPut | CO_1_OutPut.
CO_2_OutPut | CO_2_OutPut.
CO_3_OutPut | CO_3_OutPut.
CO_4_OutPut | CO_4_OutPut.
CO_5_OutPut | CO_5_OutPut.
CO_6_OutPut | CO_6_OutPut.
CO_7_OutPut | CO_7_OutPut.

◆ CIMode

enum JY7131.CIMode

CIMode.

Enumerator
Single | Single.
Finite | Finite.
Continuous | Continuous.

◆ CISampleClockSource

enum JY7131.CISampleClockSource

CI Sample Clock Source.

Enumerator
Implicit | Implicit.
Internal | Internal.
External | External.

◆ CISignalExportSource

enum JY7131.CISignalExportSource

SourceSignal.

Enumerator
StartTrig | CI_StartTrig.
SampleClock | CI_SampleClock.

◆ CITimebaseSource

enum JY7131.CITimebaseSource

时基源

Timebase source

Enumerator
Internal100MHz | 内部100MHz时基 Internal 100MHz Timebase
Internal5MHz | 内部5MHz时基 Internal 5MHz Timebase
Internal100kHz | 内部100kHz时基 Internal 100kHz Timebase

◆ CITriggerType

enum JY7131.CITriggerType

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ CIType

enum JY7131.CIType

Counter Input Application Type.

Enumerator
EdgeCounting | Edge Counting.
Period | Period Measure.
Frequency | Frequenc Measure.
TwoEdgeSeparation | TwoEdgeSeparation Measure.
QuadEncoder | QuadEncoder.
TwoPulseEncoder | EncoderTwoPulse.

◆ ClockTerminal

enum JY7131.ClockTerminal

External Sample Clock Terminal.

Enumerator
PFI_In_0 | PFI_In_0.
PFI_In_1 | PFI_In_1.
PFI_In_2 | PFI_In_2.
PFI_In_3 | PFI_In_3.
PFI_In_4 | PFI_In_4.
PFI_In_5 | PFI_In_5.
PFI_In_6 | PFI_In_6.
PFI_In_7 | PFI_In_7.
PFI_In_8 | PFI_In_8.
PFI_In_9 | PFI_In_9.
PFI_In_10 | PFI_In_10.
PFI_In_11 | PFI_In_11.
PFI_In_12 | PFI_In_12.
PFI_In_13 | PFI_In_13.
PFI_In_14 | PFI_In_14.
PFI_In_15 | PFI_In_15.
PFI_In_16 | PFI_In_16.
PFI_In_17 | PFI_In_17.
PFI_In_18 | PFI_In_18.
PFI_In_19 | PFI_In_19.
PFI_In_20 | PFI_In_20.
PFI_In_21 | PFI_In_21.
PFI_In_22 | PFI_In_6.
PFI_In_23 | PFI_In_23.
PFI_In_24 | PFI_In_24.
PFI_In_25 | PFI_In_25.
PFI_In_26 | PFI_In_26.
PFI_In_27 | PFI_In_27.
PFI_In_28 | PFI_In_28.
PFI_In_29 | PFI_In_29.
PFI_In_30 | PFI_In_30.
PFI_In_31 | PFI_In_31.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
CI0_SampleClock | CI0_SampleClock.
CI1_SampleClock | CI1_SampleClock.
CI2_SampleClock | CI2_SampleClock.
CI3_SampleClock | CI3_SampleClock.
CI4_SampleClock | CI4_SampleClock.
CI5_SampleClock | CI5_SampleClock.
CI6_SampleClock | CI6_SampleClock.
CI7_SampleClock | CI7_SampleClock.
CO0_Output | CO0_Output.
CO1_Output | CO1_Output.
CO2_Output | CO0_Output.
CO3_Output | CO1_Output.
CO4_Output | CO0_Output.
CO5_Output | CO1_Output.
CO6_Output | CO0_Output.
CO7_Output | CO1_Output.

◆ CODigitalTriggerEdge

enum JY7131.CODigitalTriggerEdge

CO Digital Trigger Edge.

Enumerator
Rising | Rising Edge.
Falling | Falling Edge.

◆ CODigitalTriggerSource

enum JY7131.CODigitalTriggerSource

CO Digital trigger source.

Enumerator
PFI_In_0 | PFI_In_0.
PFI_In_1 | PFI_In_1.
PFI_In_2 | PFI_In_2.
PFI_In_3 | PFI_In_3.
PFI_In_4 | PFI_In_4.
PFI_In_5 | PFI_In_5.
PFI_In_6 | PFI_In_6.
PFI_In_7 | PFI_In_7.
PFI_In_8 | PFI_In_8.
PFI_In_9 | PFI_In_9.
PFI_In_10 | PFI_In_10.
PFI_In_11 | PFI_In_11.
PFI_In_12 | PFI_In_12.
PFI_In_13 | PFI_In_13.
PFI_In_14 | PFI_In_14.
PFI_In_15 | PFI_In_15.
PFI_In_16 | PFI_In_16.
PFI_In_17 | PFI_In_17.
PFI_In_18 | PFI_In_18.
PFI_In_19 | PFI_In_19.
PFI_In_20 | PFI_In_20.
PFI_In_21 | PFI_In_21.
PFI_In_22 | PFI_In_22.
PFI_In_23 | PFI_In_23.
PFI_In_24 | PFI_In_24.
PFI_In_25 | PFI_In_25.
PFI_In_26 | PFI_In_26.
PFI_In_27 | PFI_In_27.
PFI_In_28 | PFI_In_28.
PFI_In_29 | PFI_In_29.
PFI_In_30 | PFI_In_30.
PFI_In_31 | PFI_In_31.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
CIO_0_StartTrig | CIO0_StartTrig.
CIO_1_StartTrig | CI1_StartTrig.
CIO_2_StartTrig | CIO2_StartTrig.
CIO_3_StartTrig | CI3_StartTrig.
CIO_4_StartTrig | CIO4_StartTrig.
CIO_5_StartTrig | CI5_StartTrig.
CIO_6_StartTrig | CIO6_StartTrig.
CIO_7_StartTrig | CI7_StartTrig.
CO_0_OutPut | CO_0_OutPut.
CO_1_OutPut | CO_1_OutPut.
CO_2_OutPut | CO_2_OutPut.
CO_3_OutPut | CO_3_OutPut.
CO_4_OutPut | CO_4_OutPut.
CO_5_OutPut | CO_5_OutPut.
CO_6_OutPut | CO_6_OutPut.
CO_7_OutPut | CO_7_OutPut.

◆ COIdleState

enum JY7131.COIdleState

Idle state when pulse output before start and after stop.

Enumerator
HighLevel | Idle state is high level.
LowLevel | Idle state is low level.

◆ COMode

enum JY7131.COMode

CO output mode.

Enumerator
Single | Single pulse output.
Finite | Finite.
ContinuousNoWrapping | ContinuousNoWrapping.
ContinuousWrapping | ContinuousWrapping.

◆ COPulseType

enum JY7131.COPulseType

Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick.

Enumerator
DutyCycleFrequency | Configure CO output pulse according to its DutyCycle and Freqency.
HighLowTime | Configure CO output pulse according to duration of its high/low voltage levels.
HighLowTick | Configure CO output pulse according to its high/low tick level.

◆ COSignalExportSource

enum JY7131.COSignalExportSource

SourceSignal.

Enumerator
StartTrig | CI_StartTrig.
Output | CO_Output.

◆ COTimebaseSource

enum JY7131.COTimebaseSource

时基源

Timebase source

Enumerator
Internal100MHz | 内部100MHz时基 Internal 100MHz Timebase
Internal5MHz | 内部5MHz时基 Internal 5MHz Timebase
Internal100kHz | 内部100kHz时基 Internal 100kHz Timebase
External | 外部时基 External Timebase

◆ COTriggerType

enum JY7131.COTriggerType

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ CountDirection

enum JY7131.CountDirection

Counter direction.

enum Up/Down/External

Enumerator
Up | Counter increases.
Down | Counter decreases.
External | External signal control counter direction. If External signal is highlevel counter increases, or lowlevel counter decreases.

◆ DOLineMode

enum JY7131.DOLineMode

Channel Type.

Enumerator
Sourcing | Sourcing Mode.
Sinking | Sinking Mode.
Push_Pull | Push_Pull Mode.

◆ EdgeCntOunEvtIdleState

enum JY7131.EdgeCntOunEvtIdleState

Output idle state when the event has not occurred.

Enumerator
LowLevel | Idle state is low level.
HighLevel | Idle state is high level.

◆ EdgeType

enum JY7131.EdgeType

Edge Type.

Enumerator
Rising | Rising Edge.
Falling | Falling Edge.
Any | Any Edge.

◆ InputTerminal

enum JY7131.InputTerminal
Enumerator
PFI_In_0 | PFI_In_0.
PFI_In_1 | PFI_In_1.
PFI_In_2 | PFI_In_2.
PFI_In_3 | PFI_In_3.
PFI_In_4 | PFI_In_4.
PFI_In_5 | PFI_In_5.
PFI_In_6 | PFI_In_6.
PFI_In_7 | PFI_In_7.
PFI_In_8 | PFI_In_8.
PFI_In_9 | PFI_In_9.
PFI_In_10 | PFI_In_10.
PFI_In_11 | PFI_In_11.
PFI_In_12 | PFI_In_12.
PFI_In_13 | PFI_In_13.
PFI_In_14 | PFI_In_14.
PFI_In_15 | PFI_In_15.
PFI_In_16 | PFI_In_16.
PFI_In_17 | PFI_In_17.
PFI_In_18 | PFI_In_18.
PFI_In_19 | PFI_In_19.
PFI_In_20 | PFI_In_20.
PFI_In_21 | PFI_In_21.
PFI_In_22 | PFI_In_22.
PFI_In_23 | PFI_In_23.
PFI_In_24 | PFI_In_24.
PFI_In_25 | PFI_In_25.
PFI_In_26 | PFI_In_26.
PFI_In_27 | PFI_In_27.
PFI_In_28 | PFI_In_28.
PFI_In_29 | PFI_In_29.
PFI_In_30 | PFI_In_30.
PFI_In_31 | PFI_In_31.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
CI_0_OutPut | CI_0_OutPut.
CI_1_OutPut | CI_1_OutPut.
CI_2_OutPut | CI_2_OutPut.
CI_3_OutPut | CI_3_OutPut.
CI_4_OutPut | CI_4_OutPut.
CI_5_OutPut | CI_5_OutPut.
CI_6_OutPut | CI_6_OutPut.
CI_7_OutPut | CI_7_OutPut.
Timebase_100MHz | Timebase_100MHz.
Timebase_5MHz | Timebase_5MHz.
Timebase_100kHz | Timebase_100kHz.

◆ IOTerminal

enum JY7131.IOTerminal
Enumerator
None | None.
PFI_Out_0 | PFI_Out_0.
PFI_Out_1 | PFI_Out_1.
PFI_Out_2 | PFI_Out_2.
PFI_Out_3 | PFI_Out_3.
PFI_Out_4 | PFI_Out_4.
PFI_Out_5 | PFI_Out_5.
PFI_Out_6 | PFI_Out_6.
PFI_Out_7 | PFI_Out_7.
PFI_Out_8 | PFI_Out_8.
PFI_Out_9 | PFI_Out_9.
PFI_Out_10 | PFI_Out_10.
PFI_Out_11 | PFI_Out_11.
PFI_Out_12 | PFI_Out_12.
PFI_Out_13 | PFI_Out_13.
PFI_Out_14 | PFI_Out_14.
PFI_Out_15 | PFI_Out_15.
PFI_Out_16 | PFI_Out_16.
PFI_Out_17 | PFI_Out_17.
PFI_Out_18 | PFI_Out_18.
PFI_Out_19 | PFI_Out_19.
PFI_Out_20 | PFI_Out_20.
PFI_Out_21 | PFI_Out_21.
PFI_Out_22 | PFI_Out_22.
PFI_Out_23 | PFI_Out_23.
PFI_Out_24 | PFI_Out_24.
PFI_Out_25 | PFI_Out_25.
PFI_Out_26 | PFI_Out_26.
PFI_Out_27 | PFI_Out_27.
PFI_Out_28 | PFI_Out_28.
PFI_Out_29 | PFI_Out_29.
PFI_Out_30 | PFI_Out_30.
PFI_Out_31 | PFI_Out_31.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.

◆ LevelPolarity

enum JY7131.LevelPolarity

Level Polarity.

Enumerator
LowLevel | Low level.
HighLevel | High level.
None | No active polarity.

◆ QuadEncodingType

enum JY7131.QuadEncodingType

Quadrature Encoding Type.

Enumerator
X1 | X1.
X2 | X2.
X4 | X4.

◆ SignalExportDestination

enum JY7131.SignalExportDestination

Output DestinationTerminal.

Enumerator
PFI_In_0 | PFI_In_0.
PFI_In_1 | PFI_In_1.
PFI_In_2 | PFI_In_2.
PFI_In_3 | PFI_In_3.
PFI_In_4 | PFI_In_4.
PFI_In_5 | PFI_In_5.
PFI_In_6 | PFI_In_6.
PFI_In_7 | PFI_In_7.
PFI_In_8 | PFI_In_8.
PFI_In_9 | PFI_In_9.
PFI_In_10 | PFI_In_10.
PFI_In_11 | PFI_In_11.
PFI_In_12 | PFI_In_12.
PFI_In_13 | PFI_In_13.
PFI_In_14 | PFI_In_14.
PFI_In_15 | PFI_In_15.
PFI_In_16 | PFI_In_16.
PFI_In_17 | PFI_In_17.
PFI_In_18 | PFI_In_18.
PFI_In_19 | PFI_In_19.
PFI_In_20 | PFI_In_20.
PFI_In_21 | PFI_In_21.
PFI_In_22 | PFI_In_22.
PFI_In_23 | PFI_In_23.
PFI_In_24 | PFI_In_24.
PFI_In_25 | PFI_In_25.
PFI_In_26 | PFI_In_26.
PFI_In_27 | PFI_In_27.
PFI_In_28 | PFI_In_28.
PFI_In_29 | PFI_In_29.
PFI_In_30 | PFI_In_30.
PFI_In_31 | PFI_In_31.
PXI_Trig0 | PXI Trig0.
PXI_Trig1 | PXI Trig1.
PXI_Trig2 | PXI Trig2.
PXI_Trig3 | PXI Trig3.
PXI_Trig4 | PXI Trig4.
PXI_Trig5 | PXI Trig5.
PXI_Trig6 | PXI Trig6.
PXI_Trig7 | PXI Trig7.

◆ ValueReturnMode

enum JY7131.ValueReturnMode

TwoEdgeSeparation value return mode.only for TwoEdgeSeparation type.

Enumerator
TwoValue | Return two data simultaneously. first data is gate to aux edge separation, second data is aux to gate edge separation.
OneValue | only return gate to aux edge separation


7131 C# Programming Manual: Package Members

  • Package List
  • Package Members
  • All
  • Enumerations
Here is a list of all namespace members with links to the namespace documentation for each member:
  • CIDigitalTriggerEdge : JY7131
  • CIDigitalTriggerSource : JY7131
  • CIMode : JY7131
  • CISampleClockSource : JY7131
  • CISignalExportSource : JY7131
  • CITimebaseSource : JY7131
  • CITriggerType : JY7131
  • CIType : JY7131
  • ClockTerminal : JY7131
  • CODigitalTriggerEdge : JY7131
  • CODigitalTriggerSource : JY7131
  • COIdleState : JY7131
  • COMode : JY7131
  • COPulseType : JY7131
  • COSignalExportSource : JY7131
  • COTimebaseSource : JY7131
  • COTriggerType : JY7131
  • CountDirection : JY7131
  • DOLineMode : JY7131
  • EdgeCntOunEvtIdleState : JY7131
  • EdgeType : JY7131
  • InputTerminal : JY7131
  • IOTerminal : JY7131
  • LevelPolarity : JY7131
  • QuadEncodingType : JY7131
  • SignalExportDestination : JY7131
  • ValueReturnMode : JY7131


7131 C# Programming Manual: Package Members

  • Package List
  • Package Members
  • All
  • Enumerations
Here is a list of all namespace enums with links to the namespace documentation for each enum:
  • CIDigitalTriggerEdge : JY7131
  • CIDigitalTriggerSource : JY7131
  • CIMode : JY7131
  • CISampleClockSource : JY7131
  • CISignalExportSource : JY7131
  • CITimebaseSource : JY7131
  • CITriggerType : JY7131
  • CIType : JY7131
  • ClockTerminal : JY7131
  • CODigitalTriggerEdge : JY7131
  • CODigitalTriggerSource : JY7131
  • COIdleState : JY7131
  • COMode : JY7131
  • COPulseType : JY7131
  • COSignalExportSource : JY7131
  • COTimebaseSource : JY7131
  • COTriggerType : JY7131
  • CountDirection : JY7131
  • DOLineMode : JY7131
  • EdgeCntOunEvtIdleState : JY7131
  • EdgeType : JY7131
  • InputTerminal : JY7131
  • IOTerminal : JY7131
  • LevelPolarity : JY7131
  • QuadEncodingType : JY7131
  • SignalExportDestination : JY7131
  • ValueReturnMode : JY7131


7131 C# Programming Manual: Package List

  • Package List
  • Package Members
Package List
Here are the packages with brief descriptions (if available):
N JY7131