7811 C++ Programming Manual: D:/7811/C++/JY7811Core.h File Reference

7811 C++ Programming Manual
  • Main Page
  • Files
  • File List
  • File Members
  • 7811
  • C++
Typedefs | Enumerations | Functions
JY7811Core.h File Reference

Typedefs

typedef void * JY7811_DeviceHandle
Windows.

Enumerations

enum | JY7811_Switch_Mode { JY7811_Static = 0x0 , JY7811_Scanning = 0x1 }
enum | JY7811_Switch_State { JY7811_NormalOpen = 0x0 , JY7811_NormalClose = 0x1 }
enum JY7811_Signal_Source {
JY7811_Signal_PXI_Trig0 = 0 , JY7811_Signal_PXI_Trig1 = 1 , JY7811_Signal_PXI_Trig2 = 2 , JY7811_Signal_PXI_Trig3 = 3 ,
JY7811_Signal_PXI_Trig4 = 4 , JY7811_Signal_PXI_Trig5 = 5 , JY7811_Signal_PXI_Trig6 = 6 , JY7811_Signal_PXI_Trig7 = 7 ,
JY7811_Signal_SwitchingComplete = 8
}
enum JY7811_Signal_Destination {
JY7811_PXI_Trig0_OUT = 0 , JY7811_PXI_Trig1_OUT = 1 , JY7811_PXI_Trig2_OUT = 2 , JY7811_PXI_Trig3_OUT = 3 ,
JY7811_PXI_Trig4_OUT = 4 , JY7811_PXI_Trig5_OUT = 5 , JY7811_PXI_Trig6_OUT = 6 , JY7811_PXI_Trig7_OUT = 7 ,
JY7811_None = 8
}
enum | JY7811_TriggerType { JY7811_Soft = 0x0 , JY7811_Digital = 0x1 }
enum JY7811_DigitalTriggerSource {
JY7811_PXI_Trig0 = 0 , JY7811_PXI_Trig1 = 1 , JY7811_PXI_Trig2 = 2 , JY7811_PXI_Trig3 = 3 ,
JY7811_PXI_Trig4 = 4 , JY7811_PXI_Trig5 = 5 , JY7811_PXI_Trig6 = 6 , JY7811_PXI_Trig7 = 7
}
Scan Mode Digital TriggerIn Source. More...
enum | JY7811_DigitalTriggerEdge { JY7811_Rising , JY7811_Falling }
Scan Mode Digital TriggerIn Edge. More...

Functions

JY7811API int | JY7811_Open (int slotNumber, JY7811_DeviceHandle *hDevice)
Open the 7811 series boards using the slot number or the board serial number.
JY7811API int | JY7811_OpenByAliasName (const char *aliasName, JY7811_DeviceHandle *hDevice)
Open this 7811 series boards using the board alias name which is set by JYTEK utility JYDM.
JY7811API int | JY7811_Close (JY7811_DeviceHandle hDevice)
Close this 7811 board.
JY7811API int | JY7811_GetDeviceID (JY7811_DeviceHandle hDevice, int *deviceID)
Obtain Device the board ID.
JY7811API int | JY7811_GetDeviceSerialNumber (JY7811_DeviceHandle hDevice, char *serialNumber, int length)
Obtain Switch the device serial Number.
JY7811API int | JY7811_Switch_SetMode (JY7811_DeviceHandle hDevice, JY7811_Switch_Mode mode, bool isContinuousScan)
Set Switch mode.
JY7811API int | JY7811_Switch_SetState (JY7811_DeviceHandle hDevice, int switchID, JY7811_Switch_State switchState)
Set the switch status of the specified switchID.
JY7811API int | JY7811_Switch_SetMultiChannelState (JY7811_DeviceHandle hDevice, int switchCount, int *switchsID, JY7811_Switch_State *switchState)
Set the switch status of multi switchIDs.
JY7811API int | JY7811_Switch_SetRelayControlPulseWidth (JY7811_DeviceHandle hDevice, int relayControlPulseWidth)
Configure the pulse width of the switch relay control signal, and the switching of the relay is controlled by the pulse signal, and the manual requires more than 1ms.
JY7811API int | JY7811_Switch_ConfigureScanList (JY7811_DeviceHandle hDevice, char *scanList, int scanDelay)
Set the switch status of scan mode.The status is interleaved in the buffer the order defined by enable ChannelID.
JY7811API int | JY7811_Switch_CheckScanStatus (JY7811_DeviceHandle hDevice, bool *scanComplete)
Check scan mode is complete.
JY7811API int | JY7811_Switch_GetState (JY7811_DeviceHandle hDevice, int switchID, JY7811_Switch_State *switchState)
Obtain the latest switch status of a single switch, applicable in both static mode and scan mode.
JY7811API int | JY7811_Switch_GetMultiChannelState (JY7811_DeviceHandle hDevice, int switchCount, int *switchsID, JY7811_Switch_State *switchState)
Obtain the latest switch status of multi switchs, applicable in both static mode and scan mode.
JY7811API int | JY7811_Switch_Start (JY7811_DeviceHandle hDevice)
Start Operate Switch Task.
JY7811API int | JY7811_Switch_SetTriggerType (JY7811_DeviceHandle hDevice, JY7811_TriggerType triggerType)
Set switch task trigger type.
JY7811API int | JY7811_Switch_SetDigitalTrigger (JY7811_DeviceHandle hDevice, JY7811_DigitalTriggerSource triggerSource, JY7811_DigitalTriggerEdge triggerEdge)
Set switch task Digital Trigger Param.
JY7811API int | JY7811_Switch_SetSwitchingCompleteDestination (JY7811_DeviceHandle hDevice, JY7811_Signal_Destination destination)
Set switching complete signal rout.
JY7811API int | JY7811_Switch_Stop (JY7811_DeviceHandle hDevice)
Stop Operate Switch Task.
JY7811API int | JY7811_Switch_SendSoftTrigger (JY7811_DeviceHandle hDevice)
Send the software trigger signal for Switch.
JY7811API int | JY7811_SignalRouting (JY7811_DeviceHandle hDevice, JY7811_Signal_Source source, JY7811_Signal_Destination destination)
Route a singal from source to destination.
JY7811API int | JY7811_DisconnectSignalRouting (JY7811_DeviceHandle hDevice, JY7811_Signal_Destination destination)
Disconnect an established routing.
JY7811API int | JY7811_GetSwitchingTimes (JY7811_DeviceHandle hDevice, int switchID, unsigned int *switchingTimes)
Get Switching times.
JY7811API int | JY7811_SetSwitchingTimes (JY7811_DeviceHandle hDevice, int switchID, unsigned int switchingTimes)
Set Switching times.
JY7811API int | JY7811_EEPROM_CounterInitialMemoryToZero (JY7811_DeviceHandle hDevice, int switchID)
JY7811API int | JY7811_EEPROM_CounterIsChanged (JY7811_DeviceHandle hDevice, bool *isChanged)

Typedef Documentation

◆ JY7811_DeviceHandle

typedef void* JY7811_DeviceHandle

Windows.

Linux

Enumeration Type Documentation

◆ JY7811_DigitalTriggerEdge

enum JY7811_DigitalTriggerEdge

Scan Mode Digital TriggerIn Edge.

Enumerator
JY7811_Rising |
JY7811_Falling | Active on the rising edge. Active on the falling edge

◆ JY7811_DigitalTriggerSource

enum JY7811_DigitalTriggerSource

Scan Mode Digital TriggerIn Source.

Enumerator
JY7811_PXI_Trig0 | PXI_Trig0 as the digital trigger source.
JY7811_PXI_Trig1 | PXI_Trig1 as the digital trigger source.
JY7811_PXI_Trig2 | PXI_Trig2 as the digital trigger source.
JY7811_PXI_Trig3 | PXI_Trig3 as the digital trigger source.
JY7811_PXI_Trig4 | PXI_Trig4 as the digital trigger source.
JY7811_PXI_Trig5 | PXI_Trig5 as the digital trigger source.
JY7811_PXI_Trig6 | PXI_Trig6 as the digital trigger source.
JY7811_PXI_Trig7 | PXI_Trig7 as the digital trigger source.

◆ JY7811_Signal_Destination

enum JY7811_Signal_Destination
Enumerator
JY7811_PXI_Trig0_OUT | pxi trigger0 as the desition signal to rout.
JY7811_PXI_Trig1_OUT | pxi trigger1 as the desition signal to rout.
JY7811_PXI_Trig2_OUT | pxi trigger2 as the desition signal to rout.
JY7811_PXI_Trig3_OUT | pxi trigger3 as the desition signal to rout.
JY7811_PXI_Trig4_OUT | pxi trigger4 as the desition signal to rout.
JY7811_PXI_Trig5_OUT | pxi trigger5 as the desition signal to rout.
JY7811_PXI_Trig6_OUT | pxi trigger6 as the desition signal to rout.
JY7811_PXI_Trig7_OUT | pxi trigger7 as the desition signal to rout.
JY7811_None |

◆ JY7811_Signal_Source

enum JY7811_Signal_Source
Enumerator
JY7811_Signal_PXI_Trig0 | pxi trigger0 as the source signal to rout.
JY7811_Signal_PXI_Trig1 | pxi trigger1 as the source signal to rout.
JY7811_Signal_PXI_Trig2 | pxi trigger2 as the source signal to rout.
JY7811_Signal_PXI_Trig3 | pxi trigger3 as the source signal to rout.
JY7811_Signal_PXI_Trig4 | pxi trigger4 as the source signal to rout.
JY7811_Signal_PXI_Trig5 | pxi trigger5 as the source signal to rout.
JY7811_Signal_PXI_Trig6 | pxi trigger6 as the source signal to rout.
JY7811_Signal_PXI_Trig7 | pxi trigger7 as the source signal to rout.
JY7811_Signal_SwitchingComplete | switching complete as the source signal to rout.

◆ JY7811_Switch_Mode

enum JY7811_Switch_Mode
Enumerator
JY7811_Static
JY7811_Scanning

◆ JY7811_Switch_State

enum JY7811_Switch_State
Enumerator
JY7811_NormalOpen
JY7811_NormalClose

◆ JY7811_TriggerType

enum JY7811_TriggerType
Enumerator
JY7811_Soft | Switch Soft trigger.
JY7811_Digital | Switch Digital trigger

Function Documentation

◆ JY7811_Close()

JY7811API int JY7811_Close ( JY7811_DeviceHandle hDevice )

Close this 7811 board.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY7811_DisconnectSignalRouting()

JY7811API int JY7811_DisconnectSignalRouting | ( | JY7811_DeviceHandle | hDevice,
 |  | JY7811_Signal_Destination | destination )

Disconnect an established routing.

Parameters
hDevice | device handle
destination | destination of the signal defined by enum JY7811_Signal_Destination
Returns
0 if success or other error code

◆ JY7811_EEPROM_CounterInitialMemoryToZero()

JY7811API int JY7811_EEPROM_CounterInitialMemoryToZero | ( | JY7811_DeviceHandle | hDevice,
 |  | int | switchID )

◆ JY7811_EEPROM_CounterIsChanged()

JY7811API int JY7811_EEPROM_CounterIsChanged | ( | JY7811_DeviceHandle | hDevice,
 |  | bool * | isChanged )

◆ JY7811_GetDeviceID()

JY7811API int JY7811_GetDeviceID | ( | JY7811_DeviceHandle | hDevice,
 |  | int * | deviceID )

Obtain Device the board ID.

The PXIe-7811 board ID is Ox7811

Parameters
hDevice | device handle
deviceID | board ID
Returns
0 if success or other error code

◆ JY7811_GetDeviceSerialNumber()

JY7811API int JY7811_GetDeviceSerialNumber | ( | JY7811_DeviceHandle | hDevice,
 |  | char * | serialNumber,
 |  | int | length )

Obtain Switch the device serial Number.

Parameters
hDevice | device handle
serialNumber | Pointer to a buffer receiving the serial number. The length of the serial number is 10.
length | serial Number length ,length is 10
Returns
0 if success or other error code

◆ JY7811_GetSwitchingTimes()

JY7811API int JY7811_GetSwitchingTimes | ( | JY7811_DeviceHandle | hDevice,
 |  | int | switchID,
 |  | unsigned int * | switchingTimes )

Get Switching times.

Parameters
hDevice | device handle
switchID | switch ID . 0 - 65
switchingTimes | switching times
Returns
0 if success or other error code

◆ JY7811_Open()

JY7811API int JY7811_Open | ( | int | slotNumber,
 |  | JY7811_DeviceHandle * | hDevice )

Open the 7811 series boards using the slot number or the board serial number.

PXIe slot number is predefined by the PXIe chassis. PCIe slot number is defined by the DIP switch. The board serial number is defined by the system starting from 0. It's your responsibility to know the number. For a single board, the serial number is 0.

Parameters
slotNumber | slot number or board serial number
hDevice | device handle. All other functions uses hDevice to represent this device.
Returns
0 if success or other error code

◆ JY7811_OpenByAliasName()

JY7811API int JY7811_OpenByAliasName | ( | const char * | aliasName,
 |  | JY7811_DeviceHandle * | hDevice )

Open this 7811 series boards using the board alias name which is set by JYTEK utility JYDM.

You can change the name using JYDM.

Parameters
aliasName | board alias name
hDevice | device handle
Returns
0 if success or other error code

◆ JY7811_SetSwitchingTimes()

JY7811API int JY7811_SetSwitchingTimes | ( | JY7811_DeviceHandle | hDevice,
 |  | int | switchID,
 |  | unsigned int | switchingTimes )

Set Switching times.

Parameters
hDevice | device handle
switchID | switch ID . 0 - 65
switchingTimes | switching times
Returns
0 if success or other error code

◆ JY7811_SignalRouting()

JY7811API int JY7811_SignalRouting | ( | JY7811_DeviceHandle | hDevice,
 |  | JY7811_Signal_Source | source,
 |  | JY7811_Signal_Destination | destination )

Route a singal from source to destination.

Both source and destination are defined by the corresponding enum JY7811_Signal_Source and JY7811_Signal_Destination. One source signal may be routed to multiple destinations.

Parameters
hDevice | device handle
source | source of the signal defined by enum JY7811_Signal_Source
destination | destination of the signal defined by enum JY7811_Signal_Destination
Returns
0 if success or other error code

◆ JY7811_Switch_CheckScanStatus()

JY7811API int JY7811_Switch_CheckScanStatus | ( | JY7811_DeviceHandle | hDevice,
 |  | bool * | scanComplete )

Check scan mode is complete.

Parameters
hDevice | device handle
scanComplete | scan complete
Returns
0 if success or other error code

◆ JY7811_Switch_ConfigureScanList()

JY7811API int JY7811_Switch_ConfigureScanList | ( | JY7811_DeviceHandle | hDevice,
 |  | char * | scanList,
 |  | int | scanDelay )

Set the switch status of scan mode.The status is interleaved in the buffer the order defined by enable ChannelID.

Parameters
hDevice | device handle
scanList | scan list, 256bit 是1个scan_list.对应256/8 = 32字节
scanDelay | scan mode scan delay.
Returns
0 if success or other error code

◆ JY7811_Switch_GetMultiChannelState()

JY7811API int JY7811_Switch_GetMultiChannelState | ( | JY7811_DeviceHandle | hDevice,
 |  | int | switchCount,
 |  | int * | switchsID,
 |  | JY7811_Switch_State * | switchState )

Obtain the latest switch status of multi switchs, applicable in both static mode and scan mode.

Parameters
hdev
switchCount | switch Count
switchsID | array[switchCount] containing switch IDs
switchState | array[switchCount] of switch state for each switch, typcially in NormalOpen/NormalClose
Returns

◆ JY7811_Switch_GetState()

JY7811API int JY7811_Switch_GetState | ( | JY7811_DeviceHandle | hDevice,
 |  | int | switchID,
 |  | JY7811_Switch_State * | switchState )

Obtain the latest switch status of a single switch, applicable in both static mode and scan mode.

Parameters
hdev
switchID | switchID to be enabled
switchState | the desired switch state to set, which can be NormalOpen/NormalClose
Returns

◆ JY7811_Switch_SendSoftTrigger()

JY7811API int JY7811_Switch_SendSoftTrigger ( JY7811_DeviceHandle hDevice )

Send the software trigger signal for Switch.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY7811_Switch_SetDigitalTrigger()

JY7811API int JY7811_Switch_SetDigitalTrigger | ( | JY7811_DeviceHandle | hDevice,
 |  | JY7811_DigitalTriggerSource | triggerSource,
 |  | JY7811_DigitalTriggerEdge | triggerEdge )

Set switch task Digital Trigger Param.

Parameters
hDevice | device handle
triggerSource | Digital Trigger Source
triggerEdge | Digital trigger Edge
Returns
0 if success or other error code

◆ JY7811_Switch_SetMode()

JY7811API int JY7811_Switch_SetMode | ( | JY7811_DeviceHandle | hDevice,
 |  | JY7811_Switch_Mode | mode,
 |  | bool | isContinuousScan )

Set Switch mode.

Parameters
hDevice | device handle
mode | Switch mode defined by enum JY7811_Switch_Mode.Static/Scan
isContinuousScan | continuousWrapping scan mode/finite scan mode
Returns
0 if success or other error code

◆ JY7811_Switch_SetMultiChannelState()

JY7811API int JY7811_Switch_SetMultiChannelState | ( | JY7811_DeviceHandle | hDevice,
 |  | int | switchCount,
 |  | int * | switchsID,
 |  | JY7811_Switch_State * | switchState )

Set the switch status of multi switchIDs.

Parameters
hDevice | device handle
switchCount | switch Count
switchsID | array[switchCount] containing switch IDs
switchState | array[switchCount] of switch state for each switch, typcially in NormalOpen/NormalClose

◆ JY7811_Switch_SetRelayControlPulseWidth()

JY7811API int JY7811_Switch_SetRelayControlPulseWidth | ( | JY7811_DeviceHandle | hDevice,
 |  | int | relayControlPulseWidth )

Configure the pulse width of the switch relay control signal, and the switching of the relay is controlled by the pulse signal, and the manual requires more than 1ms.

Parameters
hDevice | device handle
relayControlPulseWidth | relay Control Pulse Width,unit:ms

◆ JY7811_Switch_SetState()

JY7811API int JY7811_Switch_SetState | ( | JY7811_DeviceHandle | hDevice,
 |  | int | switchID,
 |  | JY7811_Switch_State | switchState )

Set the switch status of the specified switchID.

Parameters
hDevice | device handle
switchID | switchID to be enabled
switchState | the desired switch state to set, which can be NormalOpen/NormalClose

◆ JY7811_Switch_SetSwitchingCompleteDestination()

JY7811API int JY7811_Switch_SetSwitchingCompleteDestination | ( | JY7811_DeviceHandle | hDevice,
 |  | JY7811_Signal_Destination | destination )

Set switching complete signal rout.

Parameters
hDevice | device handle
destination | destination of the signal defined by enum JY7811_Signal_Destination.
Returns
0 if success or other error code

◆ JY7811_Switch_SetTriggerType()

JY7811API int JY7811_Switch_SetTriggerType | ( | JY7811_DeviceHandle | hDevice,
 |  | JY7811_TriggerType | triggerType )

Set switch task trigger type.

Parameters
hDevice | device handle
triggerType | trigger type
Returns
0 if success or other error code

◆ JY7811_Switch_Start()

JY7811API int JY7811_Switch_Start ( JY7811_DeviceHandle hDevice )

Start Operate Switch Task.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY7811_Switch_Stop()

JY7811API int JY7811_Switch_Stop ( JY7811_DeviceHandle hDevice )

Stop Operate Switch Task.

Parameters
hDevice device handle
Returns
0 if success or other error code
Generated by doxygen 1.12.0


7811 C++ Programming Manual: D:/7811/C++ Directory Reference

  • 7811
  • C++
C++ Directory Reference

Files

JY7811Core.h


7811 C++ Programming Manual: D:/7811 Directory Reference

  • 7811
7811 Directory Reference

Directories

C++


7811 C++ Programming Manual: File List

File List
Here is a list of all files with brief descriptions:
[detail level 123]
▼ 7811
▼ C++
JY7811Core.h


7811 C++ Programming Manual: File Members

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • j
Here is a list of all file members with links to the files they belong to:

- j -

  • JY7811_Close() : JY7811Core.h
  • JY7811_DeviceHandle : JY7811Core.h
  • JY7811_Digital : JY7811Core.h
  • JY7811_DigitalTriggerEdge : JY7811Core.h
  • JY7811_DigitalTriggerSource : JY7811Core.h
  • JY7811_DisconnectSignalRouting() : JY7811Core.h
  • JY7811_EEPROM_CounterInitialMemoryToZero() : JY7811Core.h
  • JY7811_EEPROM_CounterIsChanged() : JY7811Core.h
  • JY7811_Falling : JY7811Core.h
  • JY7811_GetDeviceID() : JY7811Core.h
  • JY7811_GetDeviceSerialNumber() : JY7811Core.h
  • JY7811_GetSwitchingTimes() : JY7811Core.h
  • JY7811_None : JY7811Core.h
  • JY7811_NormalClose : JY7811Core.h
  • JY7811_NormalOpen : JY7811Core.h
  • JY7811_Open() : JY7811Core.h
  • JY7811_OpenByAliasName() : JY7811Core.h
  • JY7811_PXI_Trig0 : JY7811Core.h
  • JY7811_PXI_Trig0_OUT : JY7811Core.h
  • JY7811_PXI_Trig1 : JY7811Core.h
  • JY7811_PXI_Trig1_OUT : JY7811Core.h
  • JY7811_PXI_Trig2 : JY7811Core.h
  • JY7811_PXI_Trig2_OUT : JY7811Core.h
  • JY7811_PXI_Trig3 : JY7811Core.h
  • JY7811_PXI_Trig3_OUT : JY7811Core.h
  • JY7811_PXI_Trig4 : JY7811Core.h
  • JY7811_PXI_Trig4_OUT : JY7811Core.h
  • JY7811_PXI_Trig5 : JY7811Core.h
  • JY7811_PXI_Trig5_OUT : JY7811Core.h
  • JY7811_PXI_Trig6 : JY7811Core.h
  • JY7811_PXI_Trig6_OUT : JY7811Core.h
  • JY7811_PXI_Trig7 : JY7811Core.h
  • JY7811_PXI_Trig7_OUT : JY7811Core.h
  • JY7811_Rising : JY7811Core.h
  • JY7811_Scanning : JY7811Core.h
  • JY7811_SetSwitchingTimes() : JY7811Core.h
  • JY7811_Signal_Destination : JY7811Core.h
  • JY7811_Signal_PXI_Trig0 : JY7811Core.h
  • JY7811_Signal_PXI_Trig1 : JY7811Core.h
  • JY7811_Signal_PXI_Trig2 : JY7811Core.h
  • JY7811_Signal_PXI_Trig3 : JY7811Core.h
  • JY7811_Signal_PXI_Trig4 : JY7811Core.h
  • JY7811_Signal_PXI_Trig5 : JY7811Core.h
  • JY7811_Signal_PXI_Trig6 : JY7811Core.h
  • JY7811_Signal_PXI_Trig7 : JY7811Core.h
  • JY7811_Signal_Source : JY7811Core.h
  • JY7811_Signal_SwitchingComplete : JY7811Core.h
  • JY7811_SignalRouting() : JY7811Core.h
  • JY7811_Soft : JY7811Core.h
  • JY7811_Static : JY7811Core.h
  • JY7811_Switch_CheckScanStatus() : JY7811Core.h
  • JY7811_Switch_ConfigureScanList() : JY7811Core.h
  • JY7811_Switch_GetMultiChannelState() : JY7811Core.h
  • JY7811_Switch_GetState() : JY7811Core.h
  • JY7811_Switch_Mode : JY7811Core.h
  • JY7811_Switch_SendSoftTrigger() : JY7811Core.h
  • JY7811_Switch_SetDigitalTrigger() : JY7811Core.h
  • JY7811_Switch_SetMode() : JY7811Core.h
  • JY7811_Switch_SetMultiChannelState() : JY7811Core.h
  • JY7811_Switch_SetRelayControlPulseWidth() : JY7811Core.h
  • JY7811_Switch_SetState() : JY7811Core.h
  • JY7811_Switch_SetSwitchingCompleteDestination() : JY7811Core.h
  • JY7811_Switch_SetTriggerType() : JY7811Core.h
  • JY7811_Switch_Start() : JY7811Core.h
  • JY7811_Switch_State : JY7811Core.h
  • JY7811_Switch_Stop() : JY7811Core.h
  • JY7811_TriggerType : JY7811Core.h


  • Enumerations
  • Enumerator
Here is a list of all enums with links to the files they belong to:
  • JY7811_DigitalTriggerEdge : JY7811Core.h
  • JY7811_DigitalTriggerSource : JY7811Core.h
  • JY7811_Signal_Destination : JY7811Core.h
  • JY7811_Signal_Source : JY7811Core.h
  • JY7811_Switch_Mode : JY7811Core.h
  • JY7811_Switch_State : JY7811Core.h
  • JY7811_TriggerType : JY7811Core.h


  • Enumerations
  • Enumerator
  • j
Here is a list of all enum values with links to the files they belong to:

- j -

  • JY7811_Digital : JY7811Core.h
  • JY7811_Falling : JY7811Core.h
  • JY7811_None : JY7811Core.h
  • JY7811_NormalClose : JY7811Core.h
  • JY7811_NormalOpen : JY7811Core.h
  • JY7811_PXI_Trig0 : JY7811Core.h
  • JY7811_PXI_Trig0_OUT : JY7811Core.h
  • JY7811_PXI_Trig1 : JY7811Core.h
  • JY7811_PXI_Trig1_OUT : JY7811Core.h
  • JY7811_PXI_Trig2 : JY7811Core.h
  • JY7811_PXI_Trig2_OUT : JY7811Core.h
  • JY7811_PXI_Trig3 : JY7811Core.h
  • JY7811_PXI_Trig3_OUT : JY7811Core.h
  • JY7811_PXI_Trig4 : JY7811Core.h
  • JY7811_PXI_Trig4_OUT : JY7811Core.h
  • JY7811_PXI_Trig5 : JY7811Core.h
  • JY7811_PXI_Trig5_OUT : JY7811Core.h
  • JY7811_PXI_Trig6 : JY7811Core.h
  • JY7811_PXI_Trig6_OUT : JY7811Core.h
  • JY7811_PXI_Trig7 : JY7811Core.h
  • JY7811_PXI_Trig7_OUT : JY7811Core.h
  • JY7811_Rising : JY7811Core.h
  • JY7811_Scanning : JY7811Core.h
  • JY7811_Signal_PXI_Trig0 : JY7811Core.h
  • JY7811_Signal_PXI_Trig1 : JY7811Core.h
  • JY7811_Signal_PXI_Trig2 : JY7811Core.h
  • JY7811_Signal_PXI_Trig3 : JY7811Core.h
  • JY7811_Signal_PXI_Trig4 : JY7811Core.h
  • JY7811_Signal_PXI_Trig5 : JY7811Core.h
  • JY7811_Signal_PXI_Trig6 : JY7811Core.h
  • JY7811_Signal_PXI_Trig7 : JY7811Core.h
  • JY7811_Signal_SwitchingComplete : JY7811Core.h
  • JY7811_Soft : JY7811Core.h
  • JY7811_Static : JY7811Core.h


  • Enumerations
  • Enumerator
Here is a list of all functions with links to the files they belong to:
  • JY7811_Close() : JY7811Core.h
  • JY7811_DisconnectSignalRouting() : JY7811Core.h
  • JY7811_EEPROM_CounterInitialMemoryToZero() : JY7811Core.h
  • JY7811_EEPROM_CounterIsChanged() : JY7811Core.h
  • JY7811_GetDeviceID() : JY7811Core.h
  • JY7811_GetDeviceSerialNumber() : JY7811Core.h
  • JY7811_GetSwitchingTimes() : JY7811Core.h
  • JY7811_Open() : JY7811Core.h
  • JY7811_OpenByAliasName() : JY7811Core.h
  • JY7811_SetSwitchingTimes() : JY7811Core.h
  • JY7811_SignalRouting() : JY7811Core.h
  • JY7811_Switch_CheckScanStatus() : JY7811Core.h
  • JY7811_Switch_ConfigureScanList() : JY7811Core.h
  • JY7811_Switch_GetMultiChannelState() : JY7811Core.h
  • JY7811_Switch_GetState() : JY7811Core.h
  • JY7811_Switch_SendSoftTrigger() : JY7811Core.h
  • JY7811_Switch_SetDigitalTrigger() : JY7811Core.h
  • JY7811_Switch_SetMode() : JY7811Core.h
  • JY7811_Switch_SetMultiChannelState() : JY7811Core.h
  • JY7811_Switch_SetRelayControlPulseWidth() : JY7811Core.h
  • JY7811_Switch_SetState() : JY7811Core.h
  • JY7811_Switch_SetSwitchingCompleteDestination() : JY7811Core.h
  • JY7811_Switch_SetTriggerType() : JY7811Core.h
  • JY7811_Switch_Start() : JY7811Core.h
  • JY7811_Switch_Stop() : JY7811Core.h


  • Enumerations
  • Enumerator
Here is a list of all typedefs with links to the files they belong to:
  • JY7811_DeviceHandle : JY7811Core.h


7811 C++ Programming Manual: Main Page

7811 C++ Programming Manual Documentation