7811 C# Programming Manual: D:/7811/C# Directory Reference

7811 C# Programming Manual
  • Main Page
  • Packages
  • Classes
  • Files
  • File List
  • 7811
  • C#
C# Directory Reference

Files

Enum.cs
JY7811ScanTask.cs
JY7811StaticTask.cs
Trigger.cs
Generated by doxygen 1.12.0


7811 C# Programming Manual: D:/7811/C#/Enum.cs File Reference

  • Packages
  • Classes
  • Files
  • File List
  • 7811
  • C#
Namespaces | Enumerations
Enum.cs File Reference

Namespaces

namespace JY7811

Enumerations

enum | JY7811.RelayState { JY7811.NormallyOpen = JY7811Import.JY7811_NormallyOpen , JY7811.NormallyClosed = JY7811Import.JY7811_NormallyClosed }
RelayState. More...
enum | JY7811.ScanSignalExportSource { JY7811.ScanEntryComplete = JY7811Import.JY7811_SignalSource_SwitchingComplete }
Scan Signal Export Source. More...
enum JY7811.ScanSignalExportDestination {
JY7811.PXI_Trig0 = JY7811Import.JY7811_SignalDestination_PXI_Trig0 , JY7811.PXI_Trig1 = JY7811Import.JY7811_SignalDestination_PXI_Trig1 , JY7811.PXI_Trig2 = JY7811Import.JY7811_SignalDestination_PXI_Trig2 , JY7811.PXI_Trig3 = JY7811Import.JY7811_SignalDestination_PXI_Trig3 ,
JY7811.PXI_Trig4 = JY7811Import.JY7811_SignalDestination_PXI_Trig4 , JY7811.PXI_Trig5 = JY7811Import.JY7811_SignalDestination_PXI_Trig5 , JY7811.PXI_Trig6 = JY7811Import.JY7811_SignalDestination_PXI_Trig6 , JY7811.PXI_Trig7 = JY7811Import.JY7811_SignalDestination_PXI_Trig7
}
Scan Signal Export Destination. More...


7811 C# Programming Manual: D:/7811/C#/JY7811ScanTask.cs File Reference

  • File List
  • 7811
  • C#
Classes | Namespaces
JY7811ScanTask.cs File Reference

Classes

class | JY7811.JY7811ScanTask
JY7811ScanTask. More...
class | JY7811.ScanSignalExport
Scan Signal Export Class. More...
class | JY7811.ScanEntry
Scan entry. More...
class | JY7811.ScanAction
Scan Action. More...

Namespaces

namespace JY7811


7811 C# Programming Manual: JY7811.JY7811ScanTask Class Reference

  • Class List
  • Class Index
  • Class Members
  • JY7811
  • JY7811ScanTask
Public Member Functions | Properties | List of all members
JY7811.JY7811ScanTask Class Referencesealed

JY7811ScanTask. More...

Public Member Functions

JY7811ScanTask (int slotNumber)
Constructor.
JY7811ScanTask (string boardName)
Constructor.
void | AddScanEntry (int channelID, RelayState relayState, bool waitUntilDebounced=true)
Add scan entry.
void | AddScanEntry (int[] channelIDs, RelayState relayState, bool waitUntilDebounced=true)
Add scan entry.
void | AddScanEntry (int[] channelIDs, RelayState[] relayStates, bool waitUntilDebounced=true)
Add scan entry.
void | RemoveScanEntry (int scanEntryIndex)
Delete the specified scan entry.
void | AddScanAction (int channelID, RelayState relayState, bool waitUntilDebounced)
Add scan action to the last entry.
void | AddScanAction (int[] channelIDs, RelayState relayState, bool waitUntilDebounced)
Add scan action to the last entry.
void | AddScanAction (int[] channelIDs, RelayState[] relayStates, bool waitUntilDebounced)
Add scan action to the last entry.
void | AddScan (string scanList)
add Scan List
void | Start ()
start scan task
void | Stop ()
stop scan task
void | SendSoftwareTrigger ()
Send software trigger.
bool | WaitUntilDone (int timeout=-1)
Wait until current task to complete.

Properties

JY7811Device | Device [get]
Device Handle.
List< ScanEntry > | ScanEntries [get, set]
Scan entries.
ScanTrigger | Trigger [get, set]
Switch Trigger Configuration.
bool | ContinuousScan [get, set]
If true, the task scans continuously through the scan list.
int | ScanEntryDelay [get, set]
Specifies the minimum length of time in milliseconds from when all paths of one scan entry are created to when the scan advanced output trigger is asserted.
bool | IsScanning [get]
Indicates whether task is currently scanning.
string | ScanListString [get, set]
Scan list.
ScanSignalExport | SignalExport [get, set]
Export Scan Signal Configuration.

Detailed Description

JY7811ScanTask.

Constructor & Destructor Documentation

◆ JY7811ScanTask() [1/2]

JY7811.JY7811ScanTask.JY7811ScanTask ( int slotNumber )

Constructor.

Used to create an Switch task by a slot number

Parameters
slotNumber Card slot number.

◆ JY7811ScanTask() [2/2]

JY7811.JY7811ScanTask.JY7811ScanTask ( string boardName )

Constructor.

Used to create an Switch task by a board name.

Parameters
boardName Board name(device alias), set by device manager

Member Function Documentation

◆ AddScan()

void JY7811.JY7811ScanTask.AddScan ( string scanList )

add Scan List

Parameters
scanList scan list

◆ AddScanAction() [1/3]

void JY7811.JY7811ScanTask.AddScanAction | ( | int | channelID,
 |  | RelayState | relayState,
 |  | bool | waitUntilDebounced )

Add scan action to the last entry.

Parameters
channelID | channel ID
relayState | relay state
waitUntilDebounced

◆ AddScanAction() [2/3]

void JY7811.JY7811ScanTask.AddScanAction | ( | int[] | channelIDs,
 |  | RelayState | relayState,
 |  | bool | waitUntilDebounced )

Add scan action to the last entry.

Parameters
channelIDs | channel ID Array
relayState | relay state
waitUntilDebounced

◆ AddScanAction() [3/3]

void JY7811.JY7811ScanTask.AddScanAction | ( | int[] | channelIDs,
 |  | RelayState[] | relayStates,
 |  | bool | waitUntilDebounced )

Add scan action to the last entry.

Parameters
channelIDs | channel ID Array
relayStates | relay state Array
waitUntilDebounced

◆ AddScanEntry() [1/3]

void JY7811.JY7811ScanTask.AddScanEntry | ( | int | channelID,
 |  | RelayState | relayState,
 |  | bool | waitUntilDebounced = true )

Add scan entry.

Parameters
channelID | channel ID
relayState | relay state
waitUntilDebounced

◆ AddScanEntry() [2/3]

void JY7811.JY7811ScanTask.AddScanEntry | ( | int[] | channelIDs,
 |  | RelayState | relayState,
 |  | bool | waitUntilDebounced = true )

Add scan entry.

Parameters
channelIDs | channel ID Array
relayState | relay state
waitUntilDebounced

◆ AddScanEntry() [3/3]

void JY7811.JY7811ScanTask.AddScanEntry | ( | int[] | channelIDs,
 |  | RelayState[] | relayStates,
 |  | bool | waitUntilDebounced = true )

Add scan entry.

Parameters
channelIDs | channel ID Array
relayStates | relay state Array
waitUntilDebounced

◆ RemoveScanEntry()

void JY7811.JY7811ScanTask.RemoveScanEntry ( int scanEntryIndex )

Delete the specified scan entry.

If it is -1, delete all scan entries.

Parameters
scanEntryIndex Specified scan entry index.

◆ SendSoftwareTrigger()

void JY7811.JY7811ScanTask.SendSoftwareTrigger ( )

Send software trigger.

◆ Start()

void JY7811.JY7811ScanTask.Start ( )

start scan task

◆ Stop()

void JY7811.JY7811ScanTask.Stop ( )

stop scan task

◆ WaitUntilDone()

bool JY7811.JY7811ScanTask.WaitUntilDone ( int timeout = -1 )

Wait until current task to complete.

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

Property Documentation

◆ ContinuousScan

bool JY7811.JY7811ScanTask.ContinuousScan
getset

If true, the task scans continuously through the scan list.

If false, the task scans only once through the scan list.

◆ Device

JY7811Device JY7811.JY7811ScanTask.Device
get

Device Handle.

◆ IsScanning

bool JY7811.JY7811ScanTask.IsScanning
get

Indicates whether task is currently scanning.

◆ ScanEntries

List<ScanEntry> JY7811.JY7811ScanTask.ScanEntries
getset

Scan entries.

◆ ScanEntryDelay

int JY7811.JY7811ScanTask.ScanEntryDelay
getset

Specifies the minimum length of time in milliseconds from when all paths of one scan entry are created to when the scan advanced output trigger is asserted.

unit : ms.

◆ ScanListString

string JY7811.JY7811ScanTask.ScanListString
getset

Scan list.

◆ SignalExport

ScanSignalExport JY7811.JY7811ScanTask.SignalExport
getset

Export Scan Signal Configuration.

◆ Trigger

ScanTrigger JY7811.JY7811ScanTask.Trigger
getset

Switch Trigger Configuration.

The documentation for this class was generated from the following file:
  • D:/7811/C#/JY7811ScanTask.cs


7811 C# Programming Manual: JY7811.ScanSignalExport Class Reference

  • JY7811
  • ScanSignalExport
Public Member Functions | List of all members
JY7811.ScanSignalExport Class Reference

Scan Signal Export Class. More...

Public Member Functions

void | Add (ScanSignalExportSource source, ScanSignalExportDestination destination)
Export one Signal to Desination.
void | Add (ScanSignalExportSource source, List< ScanSignalExportDestination > destinations)
Export one Signal to Mutiple Desination.
void | Clear (ScanSignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

Scan Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY7811.ScanSignalExport.Add | ( | ScanSignalExportSource | source,
 |  | List< ScanSignalExportDestination > | destinations )

Export one Signal to Mutiple Desination.

Parameters
source | Signal Source
destinations | Mutiple Export Desinations

◆ Add() [2/2]

void JY7811.ScanSignalExport.Add | ( | ScanSignalExportSource | source,
 |  | ScanSignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | Signal Source
destination | Export Desination

◆ Clear()

void JY7811.ScanSignalExport.Clear ( ScanSignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY7811.ScanSignalExport.ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • D:/7811/C#/JY7811ScanTask.cs


7811 C# Programming Manual: JY7811.ScanEntry Class Reference

  • JY7811
  • ScanEntry
Public Member Functions | Properties | List of all members
JY7811.ScanEntry Class Reference

Scan entry. More...

Public Member Functions

ScanEntry ()
Constructor.

Properties

List< ScanAction > ScanActions [get, set]
Scan actions.

Detailed Description

Scan entry.

Constructor & Destructor Documentation

◆ ScanEntry()

JY7811.ScanEntry.ScanEntry ( )

Constructor.

Property Documentation

◆ ScanActions

List<ScanAction> JY7811.ScanEntry.ScanActions
getset

Scan actions.

The documentation for this class was generated from the following file:
  • D:/7811/C#/JY7811ScanTask.cs


7811 C# Programming Manual: JY7811.ScanAction Class Reference

  • JY7811
  • ScanAction
Public Member Functions | Properties | List of all members
JY7811.ScanAction Class Reference

Scan Action. More...

Public Member Functions

ScanAction (int channelID, RelayState relayState, bool waitUntilDebounced)
Constructor.
ScanAction (int[] channelIDs, RelayState relayState, bool waitUntilDebounced)
Constructor.
ScanAction (int[] channelIDs, RelayState[] relayStates, bool waitUntilDebounced)
Constructor.

Properties

int[] | ChannelIDs [get, set]
channel ID Array.
RelayState[] | RelayStates [get, set]
relay state Array.
bool | WaitUntilDebounced [get, set]
If true, wait until all relays are stable (debounced).

Detailed Description

Scan Action.

Constructor & Destructor Documentation

◆ ScanAction() [1/3]

JY7811.ScanAction.ScanAction | ( | int | channelID,
 |  | RelayState | relayState,
 |  | bool | waitUntilDebounced )

Constructor.

Parameters
channelID | channel ID
relayState | relay state
waitUntilDebounced

◆ ScanAction() [2/3]

JY7811.ScanAction.ScanAction | ( | int[] | channelIDs,
 |  | RelayState | relayState,
 |  | bool | waitUntilDebounced )

Constructor.

Parameters
channelIDs | channel ID Array
relayState | relay state
waitUntilDebounced

◆ ScanAction() [3/3]

JY7811.ScanAction.ScanAction | ( | int[] | channelIDs,
 |  | RelayState[] | relayStates,
 |  | bool | waitUntilDebounced )

Constructor.

Parameters
channelIDs | channel ID Array
relayStates | relay state Array
waitUntilDebounced

Property Documentation

◆ ChannelIDs

int [] JY7811.ScanAction.ChannelIDs
getset

channel ID Array.

◆ RelayStates

RelayState [] JY7811.ScanAction.RelayStates
getset

relay state Array.

◆ WaitUntilDebounced

bool JY7811.ScanAction.WaitUntilDebounced
getset

If true, wait until all relays are stable (debounced).

The documentation for this class was generated from the following file:
  • D:/7811/C#/JY7811ScanTask.cs


7811 C# Programming Manual: D:/7811/C#/JY7811StaticTask.cs File Reference

  • File List
  • 7811
  • C#
Classes | Namespaces
JY7811StaticTask.cs File Reference

Classes

class JY7811.JY7811StaticTask
JY7811StaticTask. More...

Namespaces

namespace JY7811


7811 C# Programming Manual: JY7811.JY7811StaticTask Class Reference

  • JY7811
  • JY7811StaticTask
Public Member Functions | Properties | List of all members
JY7811.JY7811StaticTask Class Referencesealed

JY7811StaticTask. More...

Public Member Functions

JY7811StaticTask (int slotNumber)
Constructor.
JY7811StaticTask (string boardName)
Constructor.
void | Connect (int channelID, RelayState relayState)
connect single channel to specified state.
void | Connect (int[] channelIDs, RelayState relayState)
connect multiple channels to specified state.
void | Connect (int[] channelIDs, RelayState[] relayStates)
connect multiple channels to specified states.
void | ConnectAll (RelayState relayState)
connect all channels to specified state.
bool | WaitUntilDebounced (int timeout=-1)
Wait until all relays are stable (debounced).

Properties

JY7811Device | Device [get]
Device Handle.
bool | IsDebounced [get]
Indicates whether all relays are stable (debounced).

Detailed Description

JY7811StaticTask.

Constructor & Destructor Documentation

◆ JY7811StaticTask() [1/2]

JY7811.JY7811StaticTask.JY7811StaticTask ( int slotNumber )

Constructor.

Used to create an Switch task by a slot number

Parameters
slotNumber Card slot number.

◆ JY7811StaticTask() [2/2]

JY7811.JY7811StaticTask.JY7811StaticTask ( string boardName )

Constructor.

Used to create an Switch task by a board name.

Parameters
boardName Board name(device alias), set by device manager

Member Function Documentation

◆ Connect() [1/3]

void JY7811.JY7811StaticTask.Connect | ( | int | channelID,
 |  | RelayState | relayState )

connect single channel to specified state.

Parameters
channelID | channel ID
relayState | relay state

◆ Connect() [2/3]

void JY7811.JY7811StaticTask.Connect | ( | int[] | channelIDs,
 |  | RelayState | relayState )

connect multiple channels to specified state.

Parameters
channelIDs | channel ID Array
relayState | relay state

◆ Connect() [3/3]

void JY7811.JY7811StaticTask.Connect | ( | int[] | channelIDs,
 |  | RelayState[] | relayStates )

connect multiple channels to specified states.

Parameters
channelIDs | channel ID Array
relayStates | relay state Array

◆ ConnectAll()

void JY7811.JY7811StaticTask.ConnectAll ( RelayState relayState )

connect all channels to specified state.

Parameters
relayState

◆ WaitUntilDebounced()

bool JY7811.JY7811StaticTask.WaitUntilDebounced ( int timeout = -1 )

Wait until all relays are stable (debounced).

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N ms.
Returns

Property Documentation

◆ Device

JY7811Device JY7811.JY7811StaticTask.Device
get

Device Handle.

◆ IsDebounced

bool JY7811.JY7811StaticTask.IsDebounced
get

Indicates whether all relays are stable (debounced).

The documentation for this class was generated from the following file:
  • D:/7811/C#/JY7811StaticTask.cs


7811 C# Programming Manual: D:/7811/C#/Trigger.cs File Reference

  • File List
  • 7811
  • C#
Classes | Namespaces | Enumerations
Trigger.cs File Reference

Classes

class | JY7811.ScanTrigger
Switch Trigger class. More...
class | JY7811.DigitalTrigger
Switch Digital Trigger. More...

Namespaces

namespace JY7811

Enumerations

enum | JY7811.TriggerType { JY7811.Soft = JY7811Import.JY7811_Soft , JY7811.Digital = JY7811Import.JY7811_Digital }
Trigger Type: Digital/Soft. More...
enum JY7811.DigitalTriggerSource {
JY7811.PXI_Trig0 = JY7811Import.JY7811_DigitalTriggerSource_PXI_Trig0 , JY7811.PXI_Trig1 = JY7811Import.JY7811_DigitalTriggerSource_PXI_Trig1 , JY7811.PXI_Trig2 = JY7811Import.JY7811_DigitalTriggerSource_PXI_Trig2 , JY7811.PXI_Trig3 = JY7811Import.JY7811_DigitalTriggerSource_PXI_Trig3 ,
JY7811.PXI_Trig4 = JY7811Import.JY7811_DigitalTriggerSource_PXI_Trig4 , JY7811.PXI_Trig5 = JY7811Import.JY7811_DigitalTriggerSource_PXI_Trig5 , JY7811.PXI_Trig6 = JY7811Import.JY7811_DigitalTriggerSource_PXI_Trig6 , JY7811.PXI_Trig7 = JY7811Import.JY7811_DigitalTriggerSource_PXI_Trig7
}
trigger source More...
enum | JY7811.DigitalTriggerEdge { JY7811.Rising = JY7811Import.JY7811_RisingEdge , JY7811.Falling = JY7811Import.JY7811_FallingEdge }
Trigger signal polarity. More...


7811 C# Programming Manual: JY7811.ScanTrigger Class Reference

  • JY7811
  • ScanTrigger
Properties | List of all members
JY7811.ScanTrigger Class Referencesealed

Switch Trigger class. More...

Properties

TriggerType | Type [get, set]
Switch Trigger Type,enum Digital/Soft.
DigitalTrigger | Digital [get, set]
Digital Trigger Congfiguration.

Detailed Description

Switch Trigger class.

Property Documentation

◆ Digital

DigitalTrigger JY7811.ScanTrigger.Digital
getset

Digital Trigger Congfiguration.

Valid when Type is SwitchTriggerType.Digital.

◆ Type

TriggerType JY7811.ScanTrigger.Type
getset

Switch Trigger Type,enum Digital/Soft.

The default value is SwitchTriggerType.Soft.

The documentation for this class was generated from the following file:
  • D:/7811/C#/Trigger.cs


7811 C# Programming Manual: JY7811.DigitalTrigger Class Reference

  • JY7811
  • DigitalTrigger
Properties | List of all members
JY7811.DigitalTrigger Class Referencesealed

Switch Digital Trigger. More...

Properties

DigitalTriggerSource | Source [get, set]
Switch Digital Trigger Source.
DigitalTriggerEdge | Edge [get, set]
Switch Digital Trigger Edge，Rising/Falling.

Detailed Description

Switch Digital Trigger.

Property Documentation

◆ Edge

DigitalTriggerEdge JY7811.DigitalTrigger.Edge
getset

Switch Digital Trigger Edge，Rising/Falling.

◆ Source

DigitalTriggerSource JY7811.DigitalTrigger.Source
getset

Switch Digital Trigger Source.

The documentation for this class was generated from the following file:
  • D:/7811/C#/Trigger.cs


7811 C# Programming Manual: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
▼N JY7811 |
C DigitalTrigger | Switch Digital Trigger
C JY7811ScanTask | JY7811ScanTask
C JY7811StaticTask | JY7811StaticTask
C ScanAction | Scan Action
C ScanEntry | Scan entry
C ScanSignalExport | Scan Signal Export Class
C ScanTrigger | Switch Trigger class


7811 C# Programming Manual: Member List

  • JY7811
  • DigitalTrigger
JY7811.DigitalTrigger Member List

This is the complete list of members for JY7811.DigitalTrigger, including all inherited members.

Edge | JY7811.DigitalTrigger
Source | JY7811.DigitalTrigger


7811 C# Programming Manual: Member List

  • JY7811
  • JY7811ScanTask
JY7811.JY7811ScanTask Member List

This is the complete list of members for JY7811.JY7811ScanTask, including all inherited members.

AddScan(string scanList) | JY7811.JY7811ScanTask
AddScanAction(int channelID, RelayState relayState, bool waitUntilDebounced) | JY7811.JY7811ScanTask
AddScanAction(int[] channelIDs, RelayState relayState, bool waitUntilDebounced) | JY7811.JY7811ScanTask
AddScanAction(int[] channelIDs, RelayState[] relayStates, bool waitUntilDebounced) | JY7811.JY7811ScanTask
AddScanEntry(int channelID, RelayState relayState, bool waitUntilDebounced=true) | JY7811.JY7811ScanTask
AddScanEntry(int[] channelIDs, RelayState relayState, bool waitUntilDebounced=true) | JY7811.JY7811ScanTask
AddScanEntry(int[] channelIDs, RelayState[] relayStates, bool waitUntilDebounced=true) | JY7811.JY7811ScanTask
ContinuousScan | JY7811.JY7811ScanTask
Device | JY7811.JY7811ScanTask
IsScanning | JY7811.JY7811ScanTask
JY7811ScanTask(int slotNumber) | JY7811.JY7811ScanTask
JY7811ScanTask(string boardName) | JY7811.JY7811ScanTask
RemoveScanEntry(int scanEntryIndex) | JY7811.JY7811ScanTask
ScanEntries | JY7811.JY7811ScanTask
ScanEntryDelay | JY7811.JY7811ScanTask
ScanListString | JY7811.JY7811ScanTask
SendSoftwareTrigger() | JY7811.JY7811ScanTask
SignalExport | JY7811.JY7811ScanTask
Start() | JY7811.JY7811ScanTask
Stop() | JY7811.JY7811ScanTask
Trigger | JY7811.JY7811ScanTask
WaitUntilDone(int timeout=-1) | JY7811.JY7811ScanTask


7811 C# Programming Manual: Member List

  • JY7811
  • JY7811StaticTask
JY7811.JY7811StaticTask Member List

This is the complete list of members for JY7811.JY7811StaticTask, including all inherited members.

Connect(int channelID, RelayState relayState) | JY7811.JY7811StaticTask
Connect(int[] channelIDs, RelayState relayState) | JY7811.JY7811StaticTask
Connect(int[] channelIDs, RelayState[] relayStates) | JY7811.JY7811StaticTask
ConnectAll(RelayState relayState) | JY7811.JY7811StaticTask
Device | JY7811.JY7811StaticTask
IsDebounced | JY7811.JY7811StaticTask
JY7811StaticTask(int slotNumber) | JY7811.JY7811StaticTask
JY7811StaticTask(string boardName) | JY7811.JY7811StaticTask
WaitUntilDebounced(int timeout=-1) | JY7811.JY7811StaticTask


7811 C# Programming Manual: Member List

  • JY7811
  • ScanAction
JY7811.ScanAction Member List

This is the complete list of members for JY7811.ScanAction, including all inherited members.

ChannelIDs | JY7811.ScanAction
RelayStates | JY7811.ScanAction
ScanAction(int channelID, RelayState relayState, bool waitUntilDebounced) | JY7811.ScanAction
ScanAction(int[] channelIDs, RelayState relayState, bool waitUntilDebounced) | JY7811.ScanAction
ScanAction(int[] channelIDs, RelayState[] relayStates, bool waitUntilDebounced) | JY7811.ScanAction
WaitUntilDebounced | JY7811.ScanAction


7811 C# Programming Manual: Member List

  • JY7811
  • ScanEntry
JY7811.ScanEntry Member List

This is the complete list of members for JY7811.ScanEntry, including all inherited members.

ScanActions | JY7811.ScanEntry
ScanEntry() | JY7811.ScanEntry


7811 C# Programming Manual: Member List

  • JY7811
  • ScanSignalExport
JY7811.ScanSignalExport Member List

This is the complete list of members for JY7811.ScanSignalExport, including all inherited members.

Add(ScanSignalExportSource source, ScanSignalExportDestination destination) | JY7811.ScanSignalExport
Add(ScanSignalExportSource source, List< ScanSignalExportDestination > destinations) | JY7811.ScanSignalExport
Clear(ScanSignalExportDestination destination) | JY7811.ScanSignalExport
ClearAll() | JY7811.ScanSignalExport


7811 C# Programming Manual: Member List

  • JY7811
  • ScanTrigger
JY7811.ScanTrigger Member List

This is the complete list of members for JY7811.ScanTrigger, including all inherited members.

Digital | JY7811.ScanTrigger
Type | JY7811.ScanTrigger


7811 C# Programming Manual: Class Index

Class Index
D | J | S
D
DigitalTrigger (JY7811)
J
JY7811ScanTask (JY7811)
JY7811StaticTask (JY7811)
S
ScanAction (JY7811)
ScanEntry (JY7811)
ScanSignalExport (JY7811)
ScanTrigger (JY7811)


7811 C# Programming Manual: D:/7811 Directory Reference

  • File List
  • 7811
7811 Directory Reference

Directories

C#


7811 C# Programming Manual: File List

  • File List
File List
Here is a list of all files with brief descriptions:
[detail level 123]
▼ 7811
▼ C#
Enum.cs
JY7811ScanTask.cs
JY7811StaticTask.cs
Trigger.cs


7811 C# Programming Manual: Class Members

  • All
  • Functions
  • Properties
  • a
  • c
  • d
  • e
  • i
  • j
  • r
  • s
  • t
  • w
Here is a list of all class members with links to the classes they belong to:

- a -

  • Add() : JY7811.ScanSignalExport
  • AddScan() : JY7811.JY7811ScanTask
  • AddScanAction() : JY7811.JY7811ScanTask
  • AddScanEntry() : JY7811.JY7811ScanTask

- c -

  • ChannelIDs : JY7811.ScanAction
  • Clear() : JY7811.ScanSignalExport
  • ClearAll() : JY7811.ScanSignalExport
  • Connect() : JY7811.JY7811StaticTask
  • ConnectAll() : JY7811.JY7811StaticTask
  • ContinuousScan : JY7811.JY7811ScanTask

- d -

  • Device : JY7811.JY7811ScanTask, JY7811.JY7811StaticTask
  • Digital : JY7811.ScanTrigger

- e -

  • Edge : JY7811.DigitalTrigger

- i -

  • IsDebounced : JY7811.JY7811StaticTask
  • IsScanning : JY7811.JY7811ScanTask

- j -

  • JY7811ScanTask() : JY7811.JY7811ScanTask
  • JY7811StaticTask() : JY7811.JY7811StaticTask

- r -

  • RelayStates : JY7811.ScanAction
  • RemoveScanEntry() : JY7811.JY7811ScanTask

- s -

  • ScanAction() : JY7811.ScanAction
  • ScanActions : JY7811.ScanEntry
  • ScanEntries : JY7811.JY7811ScanTask
  • ScanEntry() : JY7811.ScanEntry
  • ScanEntryDelay : JY7811.JY7811ScanTask
  • ScanListString : JY7811.JY7811ScanTask
  • SendSoftwareTrigger() : JY7811.JY7811ScanTask
  • SignalExport : JY7811.JY7811ScanTask
  • Source : JY7811.DigitalTrigger
  • Start() : JY7811.JY7811ScanTask
  • Stop() : JY7811.JY7811ScanTask

- t -

  • Trigger : JY7811.JY7811ScanTask
  • Type : JY7811.ScanTrigger

- w -

  • WaitUntilDebounced() : JY7811.JY7811StaticTask, JY7811.ScanAction
  • WaitUntilDone() : JY7811.JY7811ScanTask


7811 C# Programming Manual: Class Members - Functions

  • All
  • Functions
  • Properties
Here is a list of all functions with links to the classes they belong to:
  • Add() : JY7811.ScanSignalExport
  • AddScan() : JY7811.JY7811ScanTask
  • AddScanAction() : JY7811.JY7811ScanTask
  • AddScanEntry() : JY7811.JY7811ScanTask
  • Clear() : JY7811.ScanSignalExport
  • ClearAll() : JY7811.ScanSignalExport
  • Connect() : JY7811.JY7811StaticTask
  • ConnectAll() : JY7811.JY7811StaticTask
  • JY7811ScanTask() : JY7811.JY7811ScanTask
  • JY7811StaticTask() : JY7811.JY7811StaticTask
  • RemoveScanEntry() : JY7811.JY7811ScanTask
  • ScanAction() : JY7811.ScanAction
  • ScanEntry() : JY7811.ScanEntry
  • SendSoftwareTrigger() : JY7811.JY7811ScanTask
  • Start() : JY7811.JY7811ScanTask
  • Stop() : JY7811.JY7811ScanTask
  • WaitUntilDebounced() : JY7811.JY7811StaticTask
  • WaitUntilDone() : JY7811.JY7811ScanTask


7811 C# Programming Manual: Class Members - Properties

  • All
  • Functions
  • Properties
Here is a list of all properties with links to the classes they belong to:
  • ChannelIDs : JY7811.ScanAction
  • ContinuousScan : JY7811.JY7811ScanTask
  • Device : JY7811.JY7811ScanTask, JY7811.JY7811StaticTask
  • Digital : JY7811.ScanTrigger
  • Edge : JY7811.DigitalTrigger
  • IsDebounced : JY7811.JY7811StaticTask
  • IsScanning : JY7811.JY7811ScanTask
  • RelayStates : JY7811.ScanAction
  • ScanActions : JY7811.ScanEntry
  • ScanEntries : JY7811.JY7811ScanTask
  • ScanEntryDelay : JY7811.JY7811ScanTask
  • ScanListString : JY7811.JY7811ScanTask
  • SignalExport : JY7811.JY7811ScanTask
  • Source : JY7811.DigitalTrigger
  • Trigger : JY7811.JY7811ScanTask
  • Type : JY7811.ScanTrigger
  • WaitUntilDebounced : JY7811.ScanAction


7811 C# Programming Manual: Main Page

7811 C# Programming Manual Documentation


7811 C# Programming Manual: JY7811 Namespace Reference

  • Package List
  • Package Members
Classes | Enumerations
JY7811 Namespace Reference

Classes

class | DigitalTrigger
Switch Digital Trigger. More...
class | JY7811ScanTask
JY7811ScanTask. More...
class | JY7811StaticTask
JY7811StaticTask. More...
class | ScanAction
Scan Action. More...
class | ScanEntry
Scan entry. More...
class | ScanSignalExport
Scan Signal Export Class. More...
class | ScanTrigger
Switch Trigger class. More...

Enumerations

enum | RelayState { NormallyOpen = JY7811Import.JY7811_NormallyOpen , NormallyClosed = JY7811Import.JY7811_NormallyClosed }
RelayState. More...
enum | ScanSignalExportSource { ScanEntryComplete = JY7811Import.JY7811_SignalSource_SwitchingComplete }
Scan Signal Export Source. More...
enum ScanSignalExportDestination {
PXI_Trig0 = JY7811Import.JY7811_SignalDestination_PXI_Trig0 , PXI_Trig1 = JY7811Import.JY7811_SignalDestination_PXI_Trig1 , PXI_Trig2 = JY7811Import.JY7811_SignalDestination_PXI_Trig2 , PXI_Trig3 = JY7811Import.JY7811_SignalDestination_PXI_Trig3 ,
PXI_Trig4 = JY7811Import.JY7811_SignalDestination_PXI_Trig4 , PXI_Trig5 = JY7811Import.JY7811_SignalDestination_PXI_Trig5 , PXI_Trig6 = JY7811Import.JY7811_SignalDestination_PXI_Trig6 , PXI_Trig7 = JY7811Import.JY7811_SignalDestination_PXI_Trig7
}
Scan Signal Export Destination. More...
enum | TriggerType { Soft = JY7811Import.JY7811_Soft , Digital = JY7811Import.JY7811_Digital }
Trigger Type: Digital/Soft. More...
enum DigitalTriggerSource {
PXI_Trig0 = JY7811Import.JY7811_DigitalTriggerSource_PXI_Trig0 , PXI_Trig1 = JY7811Import.JY7811_DigitalTriggerSource_PXI_Trig1 , PXI_Trig2 = JY7811Import.JY7811_DigitalTriggerSource_PXI_Trig2 , PXI_Trig3 = JY7811Import.JY7811_DigitalTriggerSource_PXI_Trig3 ,
PXI_Trig4 = JY7811Import.JY7811_DigitalTriggerSource_PXI_Trig4 , PXI_Trig5 = JY7811Import.JY7811_DigitalTriggerSource_PXI_Trig5 , PXI_Trig6 = JY7811Import.JY7811_DigitalTriggerSource_PXI_Trig6 , PXI_Trig7 = JY7811Import.JY7811_DigitalTriggerSource_PXI_Trig7
}
trigger source More...
enum | DigitalTriggerEdge { Rising = JY7811Import.JY7811_RisingEdge , Falling = JY7811Import.JY7811_FallingEdge }
Trigger signal polarity. More...

Enumeration Type Documentation

◆ DigitalTriggerEdge

enum JY7811.DigitalTriggerEdge

Trigger signal polarity.

Enumerator
Rising | Active on the rising edge.
Falling | Active on the falling edge.

◆ DigitalTriggerSource

enum JY7811.DigitalTriggerSource

trigger source

Enumerator
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI TRIG1.
PXI_Trig2 | PXI TRIG2.
PXI_Trig3 | PXI TRIG3.
PXI_Trig4 | PXI TRIG4.
PXI_Trig5 | PXI TRIG5.
PXI_Trig6 | PXI TRIG6.
PXI_Trig7 | PXI TRIG7.

◆ RelayState

enum JY7811.RelayState

RelayState.

Enumerator
NormallyOpen | Normally Open.
NormallyClosed | Normally Closed.

◆ ScanSignalExportDestination

enum JY7811.ScanSignalExportDestination

Scan Signal Export Destination.

Enumerator
PXI_Trig0 | PXI_Trig0.
PXI_Trig1 | PXI_Trig1.
PXI_Trig2 | PXI_Trig2.
PXI_Trig3 | PXI_Trig3.
PXI_Trig4 | PXI_Trig4.
PXI_Trig5 | PXI_Trig5.
PXI_Trig6 | PXI_Trig6.
PXI_Trig7 | PXI_Trig7.

◆ ScanSignalExportSource

enum JY7811.ScanSignalExportSource

Scan Signal Export Source.

Enumerator
ScanEntryComplete

End of one scan entry.

◆ TriggerType

enum JY7811.TriggerType

Trigger Type: Digital/Soft.

Enumerator
Soft | Soft Trigger.
Digital | Digital Trigger.


7811 C# Programming Manual: Package Members

  • Package List
  • Package Members
  • All
  • Enumerations
Here is a list of all namespace members with links to the namespace documentation for each member:
  • DigitalTriggerEdge : JY7811
  • DigitalTriggerSource : JY7811
  • RelayState : JY7811
  • ScanSignalExportDestination : JY7811
  • ScanSignalExportSource : JY7811
  • TriggerType : JY7811


7811 C# Programming Manual: Package Members

  • Package List
  • Package Members
  • All
  • Enumerations
Here is a list of all namespace enums with links to the namespace documentation for each enum:
  • DigitalTriggerEdge : JY7811
  • DigitalTriggerSource : JY7811
  • RelayState : JY7811
  • ScanSignalExportDestination : JY7811
  • ScanSignalExportSource : JY7811
  • TriggerType : JY7811


7811 C# Programming Manual: Package List

  • Package List
  • Package Members
Package List
Here are the packages with brief descriptions (if available):
N JY7811