8902 C++ Programming Manual: D:/8902/C++/JY8902.h File Reference

8902 C++ Programming Manual
  • Main Page
  • Files
  • File List
  • File Members
  • 8902
  • C++
Typedefs | Enumerations | Functions
JY8902.h File Reference

@SectionBegin JY8902FileHead More...

Typedefs

typedef void * JY8902_DeviceHandle
Windows.

Enumerations

enum JY8902_DMM_MeasurementFunction {
JY8902_DC_Volts = 0 , JY8902_AC_Volts = 1 , JY8902_DC_Current = 2 , JY8902_AC_Current = 3 ,
JY8902_2_Wire_Resistance = 4 , JY8902_4_Wire_Resistance = 5
}
enum JY8902_DMM_DC_VoltRange {
JY8902_DC_Volt_Auto = -1 , JY8902_DC_Volt_200mV = 1 , JY8902_DC_Volt_2V = 2 , JY8902_DC_Volt_20V = 3 ,
JY8902_DC_Volt_240V = 4
}
enum | JY8902_DMM_DC_CurrentRange { JY8902_DC_Current_Auto = -1 , JY8902_DC_Current_20mA = 5 , JY8902_DC_Current_200mA = 6 , JY8902_DC_Current_1000mA = 7 }
enum JY8902_DMM_2_Wire_ResistanceRange {
JY8902_2_Wire_Resistance_Auto = -1 , JY8902_2_Wire_Resistance_100 = 8 , JY8902_2_Wire_Resistance_1K = 9 , JY8902_2_Wire_Resistance_10K = 10 ,
JY8902_2_Wire_Resistance_100K = 11 , JY8902_2_Wire_Resistance_1M = 12 , JY8902_2_Wire_Resistance_10M = 13 , JY8902_2_Wire_Resistance_100M = 14
}
enum JY8902_DMM_4_Wire_ResistanceRange {
JY8902_4_Wire_Resistance_Auto = -1 , JY8902_4_Wire_Resistance_100 = 15 , JY8902_4_Wire_Resistance_1K = 16 , JY8902_4_Wire_Resistance_10K = 17 ,
JY8902_4_Wire_Resistance_100K = 18 , JY8902_4_Wire_Resistance_1M = 19
}
enum JY8902_DMM_AC_VoltRange {
JY8902_AC_Volt_Auto = -1 , JY8902_AC_Volt_200mV = 22 , JY8902_AC_Volt_2V = 23 , JY8902_AC_Volt_20V = 24 ,
JY8902_AC_Volt_240V = 25
}
enum | JY8902_DMM_AC_CurrentRange { JY8902_AC_Current_Auto = -1 , JY8902_AC_Current_20mA = 26 , JY8902_AC_Current_200mA = 27 , JY8902_AC_Current_1000mA = 28 }
enum | JY8902_DMM_SampleMode { JY8902_SingleSample = 0x0 , JY8902_MultiSample = 0x1 , JY8902_ContinuousMultiPoint = 0x2 }
enum | JY8902_DMM_TriggerType { JY8902_Immediately = 0x0 , JY8902_Soft = 0x1 , JY8902_Digital = 0x2 }
enum | JY8902_DMM_PowerFrequency { JY8902_50_Hz = 0x0 , JY8902_60_Hz = 0x1 }
enum | JY8902_DMM_ApetureUint { JY8902_Second = 0x0 , JY8902_NPLC = 0x1 }
enum JY8902_DMM_DigitalTriggerSource {
JY8902_PFI0 = 0 , JY8902_PFI1 = 1 , JY8902_PXI_Trig0 = 2 , JY8902_PXI_Trig1 = 3 ,
JY8902_PXI_Trig2 = 4 , JY8902_PXI_Trig3 = 5 , JY8902_PXI_Trig4 = 6 , JY8902_PXI_Trig5 = 7 ,
JY8902_PXI_Trig6 = 8 , JY8902_PXI_Trig7 = 9
}
enum JY8902_DMM_SampleTrigger {
JY8902_Sample_Immediately = -1 , JY8902_Sample_PFI0 = 0 , JY8902_Sample_PFI1 = 1 , JY8902_Sample_PXI_Trig0 = 2 ,
JY8902_Sample_PXI_Trig1 = 3 , JY8902_Sample_PXI_Trig2 = 4 , JY8902_Sample_PXI_Trig3 = 5 , JY8902_Sample_PXI_Trig4 = 6 ,
JY8902_Sample_PXI_Trig5 = 7 , JY8902_Sample_PXI_Trig6 = 8 , JY8902_Sample_PXI_Trig7 = 9
}
enum JY8902_DMM_ExternalSampleClock {
JY8902_Clock_PFI0 = 0 , JY8902_Clock_PFI1 = 1 , JY8902_Clock_PXI_Trig0 = 2 , JY8902_Clock_PXI_Trig1 = 3 ,
JY8902_Clock_PXI_Trig2 = 4 , JY8902_Clock_PXI_Trig3 = 5 , JY8902_Clock_PXI_Trig4 = 6 , JY8902_Clock_PXI_Trig5 = 7 ,
JY8902_Clock_PXI_Trig6 = 8 , JY8902_Clock_PXI_Trig7 = 9
}
enum | JY8902_DMM_DigitalTriggerEdge { JY8902_Rising = 0x0 , JY8902_Falling = 0x1 }
enum JY8902_Signal_Source {
JY8902_Signal_PFI0 = 0 , JY8902_Signal_PFI1 = 1 , JY8902_Signal_PXI_Trig0 = 2 , JY8902_Signal_PXI_Trig1 = 3 ,
JY8902_Signal_PXI_Trig2 = 4 , JY8902_Signal_PXI_Trig3 = 5 , JY8902_Signal_PXI_Trig4 = 6 , JY8902_Signal_PXI_Trig5 = 7 ,
JY8902_Signal_PXI_Trig6 = 8 , JY8902_Signal_PXI_Trig7 = 9 , JY8902_Signal_MeasureComplete = 10
}
enum JY8902_Signal_Destination {
JY8902_PFI0_OUT = 0 , JY8902_PFI1_OUT = 1 , JY8902_PXI_Trig0_OUT = 2 , JY8902_PXI_Trig1_OUT = 3 ,
JY8902_PXI_Trig2_OUT = 4 , JY8902_PXI_Trig3_OUT = 5 , JY8902_PXI_Trig4_OUT = 6 , JY8902_PXI_Trig5_OUT = 7 ,
JY8902_PXI_Trig6_OUT = 8 , JY8902_PXI_Trig7_OUT = 9 , JY8902_None = 10
}
enum | JY8902_DMM_ClockSource { JY8902_InternalClock = 0x0 , JY8902_ExternalClock = 0x1 }
enum | JY8902_ReferenceClock { JY8902_Internal = 0 , JY8902_PXIe_Clk100 = 1 }

Functions

JY8902API int | JY8902_Open (int slotNumber, JY8902_DeviceHandle *hDevice)
Open the 8902 series boards using the slot number or the board serial number.
JY8902API int | JY8902_OpenByAliasName (const char *aliasName, JY8902_DeviceHandle *hDevice)
Open this 8902 series boards using the board alias name which is set by JYTEK utility JYDM.
JY8902API int | JY8902_Close (JY8902_DeviceHandle hDevice)
Close this 8902 board.
JY8902API int | JY8902_GetDeviceID (JY8902_DeviceHandle hDevice, int *deviceID)
Obtain the board ID.
JY8902API int | JY8902_GetDeviceSerialNumber (JY8902_DeviceHandle hDevice, char *serialNumber, int length)
Obtain the device serialNumber.
JY8902API int | JY8902_SetDeviceReferenceClock (JY8902_DeviceHandle hDevice, JY8902_ReferenceClock clockSource)
Set Reference Clock for the device.There are two ReferenceClock, 25MHz from this device or 100MHz from the PXIe chassis.
JY8902API int | JY8902_SignalRouting (JY8902_DeviceHandle hDevice, JY8902_Signal_Source sourceSignal, JY8902_Signal_Destination distination)
Route a singal from source to destination.
JY8902API int | JY8902_DisconnectSignalRouting (JY8902_DeviceHandle hDevice, JY8902_Signal_Destination destination)
Disconnect an established routing.
JY8902API int | JY8902_SetDeviceStatusLed (JY8902_DeviceHandle hDevice, bool enable, unsigned int frequency)
Control Front Panel Status Led.
JY8902API int | JY8902_DMM_SetMeasurementFunction (JY8902_DeviceHandle hDevice, JY8902_DMM_MeasurementFunction function)
Set DMM Measurement Function,Specifies the Measurement Function used to acquire the measurement.
JY8902API int | JY8902_DMM_SetDCVolt (JY8902_DeviceHandle hDevice, JY8902_DMM_DC_VoltRange range)
Set DC Volt measurement.
JY8902API int | JY8902_DMM_SetACVolt (JY8902_DeviceHandle hDevice, JY8902_DMM_AC_VoltRange range)
Set AC Volt measurement.
JY8902API int | JY8902_DMM_SetDCCurrent (JY8902_DeviceHandle hDevice, JY8902_DMM_DC_CurrentRange range)
Set DC Current measurement.
JY8902API int | JY8902_DMM_SetACCurrent (JY8902_DeviceHandle hDevice, JY8902_DMM_AC_CurrentRange range)
Set AC Current measurement.
JY8902API int | JY8902_DMM_Set2WireResistance (JY8902_DeviceHandle hDevice, JY8902_DMM_2_Wire_ResistanceRange range)
Set 2Wire Resistance measurement.
JY8902API int | JY8902_DMM_Set4WireResistance (JY8902_DeviceHandle hDevice, JY8902_DMM_4_Wire_ResistanceRange range)
Set 4Wire Resistance measurement.
JY8902API int | JY8902_DMM_SetApertureUnit (JY8902_DeviceHandle hDevice, JY8902_DMM_ApetureUint apertureUnit)
Sets DMM Aperture Unit.
JY8902API int | JY8902_DMM_SetApertureTime (JY8902_DeviceHandle hDevice, double ApertureTime)
Sets the integration time in seconds (called aperture time) of the analog-to-digital converter for measurements.
JY8902API int | JY8902_DMM_GetApertureTime (JY8902_DeviceHandle hDevice, double *ApertureTime)
Gets the integration time in seconds (called aperture time) of the analog-to-digital converter for measurements.
JY8902API int | JY8902_DMM_SetNPLC (JY8902_DeviceHandle hDevice, double nplc)
Sets the integration time in number of power line cycles (PLCs) of the analog-to-digital converter for measurements.
JY8902API int | JY8902_DMM_GetNPLC (JY8902_DeviceHandle hDevice, double *nplc)
Get the integration time in number of power line cycles (PLCs) of the analog-to-digital converter for measurements.
JY8902API int | JY8902_DMM_PowerLineFrequency (JY8902_DeviceHandle hDevice, JY8902_DMM_PowerFrequency powerFrequency)
This function configures the power line frequency of the DMM.
JY8902API int | JY8902_DMM_SetSampleMode (JY8902_DeviceHandle hDevice, JY8902_DMM_SampleMode sampleMode)
Set measurement mode.
JY8902API int | JY8902_DMM_SetMultiSample (JY8902_DeviceHandle hDevice, unsigned int sampleCount, JY8902_DMM_SampleTrigger sampleTrigger, double sampleInterval)
Set multi sample mode.
JY8902API int | JY8902_DMM_SetTriggerType (JY8902_DeviceHandle hDevice, JY8902_DMM_TriggerType triggerType)
Set Trigger Type.
JY8902API int | JY8902_DMM_SetDigitalTrigger (JY8902_DeviceHandle hDevice, JY8902_DMM_DigitalTriggerSource triggerSource, JY8902_DMM_DigitalTriggerEdge triggerEdge)
Set Digital Trigger.
JY8902API int | JY8902_DMM_SetTriggerDelay (JY8902_DeviceHandle hDevice, double delay)
Set trigger delay.
JY8902API int | JY8902_DMM_RoutMeasurementComplete (JY8902_DeviceHandle hDevice, JY8902_Signal_Destination destination)
Set the destination of the measurement-complete signal generated after each measurement.
JY8902API int | JY8902_DMM_Start (JY8902_DeviceHandle hDevice)
DMM Start measurement.
JY8902API int | JY8902_DMM_Stop (JY8902_DeviceHandle hDevice)
DMM Stop measurement.
JY8902API int | JY8902_DMM_Read (JY8902_DeviceHandle hDevice, double *measureValue, int timeOut)
Initiates a measurement, waits for the DMM to return to the idle state, and returns the measured value.
JY8902API int | JY8902_DMM_ReadRawData (JY8902_DeviceHandle hDevice, double *measureValue, int timeOut)
Initiates a measurement, waits for the DMM to return to the idle state, and returns the measured raw voltage value.
JY8902API int | JY8902_DMM_ReadMultiPoint (JY8902_DeviceHandle hDevice, double *measureValues, int readLength, int timeOut, int *actualReadLenght)
Initiates a measurement, waits for the DMM to return to the idle state, and returns an array of values.
JY8902API int | JY8902_DMM_DisableCalibration (JY8902_DeviceHandle hDevice, bool DisableCalibration)
If disable the calibration.
JY8902API int | JY8902_DMM_SendSoftTrigger (JY8902_DeviceHandle hDevice)
Send softTrigger.
JY8902API int | JY8902_DMM_CheckBufferStatus (JY8902_DeviceHandle hDevice, unsigned long long *avaliableSamples, unsigned long long *transferedSamples, bool *overrun)
Check buffer status.
JY8902API int | JY8902_DMM_CheckMeasureStatus (JY8902_DeviceHandle hDevice, bool *overRange)
Check Measure status.

Detailed Description

@SectionBegin JY8902FileHead

COPYRIGHT NOTICE
Copyright (c) 2018, JYTEK
All rights reserved.
Author
JYTEK
Version
1.0.0
Date
2023-3-28

This header file defines C/C++ API and enums used in the JY8902 driver.

Typedef Documentation

◆ JY8902_DeviceHandle

typedef void* JY8902_DeviceHandle

Windows.

Linux

Enumeration Type Documentation

◆ JY8902_DMM_2_Wire_ResistanceRange

enum JY8902_DMM_2_Wire_ResistanceRange
Enumerator
JY8902_2_Wire_Resistance_Auto
JY8902_2_Wire_Resistance_100
JY8902_2_Wire_Resistance_1K
JY8902_2_Wire_Resistance_10K
JY8902_2_Wire_Resistance_100K
JY8902_2_Wire_Resistance_1M
JY8902_2_Wire_Resistance_10M
JY8902_2_Wire_Resistance_100M

◆ JY8902_DMM_4_Wire_ResistanceRange

enum JY8902_DMM_4_Wire_ResistanceRange
Enumerator
JY8902_4_Wire_Resistance_Auto
JY8902_4_Wire_Resistance_100
JY8902_4_Wire_Resistance_1K
JY8902_4_Wire_Resistance_10K
JY8902_4_Wire_Resistance_100K
JY8902_4_Wire_Resistance_1M

◆ JY8902_DMM_AC_CurrentRange

enum JY8902_DMM_AC_CurrentRange
Enumerator
JY8902_AC_Current_Auto
JY8902_AC_Current_20mA
JY8902_AC_Current_200mA
JY8902_AC_Current_1000mA

◆ JY8902_DMM_AC_VoltRange

enum JY8902_DMM_AC_VoltRange
Enumerator
JY8902_AC_Volt_Auto
JY8902_AC_Volt_200mV
JY8902_AC_Volt_2V
JY8902_AC_Volt_20V
JY8902_AC_Volt_240V

◆ JY8902_DMM_ApetureUint

enum JY8902_DMM_ApetureUint
Enumerator
JY8902_Second
JY8902_NPLC

◆ JY8902_DMM_ClockSource

enum JY8902_DMM_ClockSource
Enumerator
JY8902_InternalClock | Internal Clock Source.
JY8902_ExternalClock | External Clock Source.

◆ JY8902_DMM_DC_CurrentRange

enum JY8902_DMM_DC_CurrentRange
Enumerator
JY8902_DC_Current_Auto
JY8902_DC_Current_20mA
JY8902_DC_Current_200mA
JY8902_DC_Current_1000mA

◆ JY8902_DMM_DC_VoltRange

enum JY8902_DMM_DC_VoltRange
Enumerator
JY8902_DC_Volt_Auto
JY8902_DC_Volt_200mV
JY8902_DC_Volt_2V
JY8902_DC_Volt_20V
JY8902_DC_Volt_240V

◆ JY8902_DMM_DigitalTriggerEdge

enum JY8902_DMM_DigitalTriggerEdge
Enumerator
JY8902_Rising | Rising edge.
JY8902_Falling | Falling edge.

◆ JY8902_DMM_DigitalTriggerSource

enum JY8902_DMM_DigitalTriggerSource
Enumerator
JY8902_PFI0 | PFI0 as the digital trigger source.
JY8902_PFI1 | PFI1 as the digital trigger source.
JY8902_PXI_Trig0 | PXI_Trig0 as the digital trigger source.
JY8902_PXI_Trig1 | PXI_Trig1 as the digital trigger source.
JY8902_PXI_Trig2 | PXI_Trig2 as the digital trigger source.
JY8902_PXI_Trig3 | PXI_Trig3 as the digital trigger source.
JY8902_PXI_Trig4 | PXI_Trig4 as the digital trigger source.
JY8902_PXI_Trig5 | PXI_Trig5 as the digital trigger source.
JY8902_PXI_Trig6 | PXI_Trig6 as the digital trigger source.
JY8902_PXI_Trig7 | PXI_Trig7 as the digital trigger source.

◆ JY8902_DMM_ExternalSampleClock

enum JY8902_DMM_ExternalSampleClock
Enumerator
JY8902_Clock_PFI0 | PFI0 as the External Sample Clock.
JY8902_Clock_PFI1 | PFI1 as the External Sample Clock.
JY8902_Clock_PXI_Trig0 | PXI_Trig0 as the External Sample Clock.
JY8902_Clock_PXI_Trig1 | PXI_Trig1 as the External Sample Clock.
JY8902_Clock_PXI_Trig2 | PXI_Trig2 as the External Sample Clock.
JY8902_Clock_PXI_Trig3 | PXI_Trig3 as the External Sample Clock.
JY8902_Clock_PXI_Trig4 | PXI_Trig4 as the External Sample Clock.
JY8902_Clock_PXI_Trig5 | PXI_Trig5 as the External Sample Clock.
JY8902_Clock_PXI_Trig6 | PXI_Trig6 as the External Sample Clock.
JY8902_Clock_PXI_Trig7 | PXI_Trig7 as the External Sample Clock.

◆ JY8902_DMM_MeasurementFunction

enum JY8902_DMM_MeasurementFunction
Enumerator
JY8902_DC_Volts
JY8902_AC_Volts
JY8902_DC_Current
JY8902_AC_Current
JY8902_2_Wire_Resistance
JY8902_4_Wire_Resistance

◆ JY8902_DMM_PowerFrequency

enum JY8902_DMM_PowerFrequency
Enumerator
JY8902_50_Hz
JY8902_60_Hz

◆ JY8902_DMM_SampleMode

enum JY8902_DMM_SampleMode
Enumerator
JY8902_SingleSample
JY8902_MultiSample
JY8902_ContinuousMultiPoint

◆ JY8902_DMM_SampleTrigger

enum JY8902_DMM_SampleTrigger
Enumerator
JY8902_Sample_Immediately | Internal trigger as the Sample Trigger.
JY8902_Sample_PFI0 | PFI0 as the Sample Trigger.
JY8902_Sample_PFI1 | PFI1 as the Sample Trigger.
JY8902_Sample_PXI_Trig0 | PXI_Trig0 as the Sample Trigger.
JY8902_Sample_PXI_Trig1 | PXI_Trig1 as the Sample Trigger.
JY8902_Sample_PXI_Trig2 | PXI_Trig2 as the Sample Trigger.
JY8902_Sample_PXI_Trig3 | PXI_Trig3 as the Sample Trigger.
JY8902_Sample_PXI_Trig4 | PXI_Trig4 as the Sample Trigger.
JY8902_Sample_PXI_Trig5 | PXI_Trig5 as the Sample Trigger.
JY8902_Sample_PXI_Trig6 | PXI_Trig6 as the Sample Trigger.
JY8902_Sample_PXI_Trig7 | PXI_Trig7 as the Sample Trigger.

◆ JY8902_DMM_TriggerType

enum JY8902_DMM_TriggerType
Enumerator
JY8902_Immediately
JY8902_Soft
JY8902_Digital

◆ JY8902_ReferenceClock

enum JY8902_ReferenceClock
Enumerator
JY8902_Internal | The onboard 25 MHz as JY8902_ReferenceClock.
JY8902_PXIe_Clk100 | The PXIe chassis 100MHz as JY8902_ReferenceClock, only for PXIe module.

◆ JY8902_Signal_Destination

enum JY8902_Signal_Destination
Enumerator
JY8902_PFI0_OUT |
JY8902_PFI1_OUT | PFI0 as the signal desition to route.
JY8902_PXI_Trig0_OUT | PFI1 as the signal desition to route.
JY8902_PXI_Trig1_OUT | PXITrig0 as the signal desition to route.
JY8902_PXI_Trig2_OUT | PXITrig1 as the signal desition to route.
JY8902_PXI_Trig3_OUT | PXITrig2 as the signal desition to route.
JY8902_PXI_Trig4_OUT | PXITrig3 as the signal desition to route.
JY8902_PXI_Trig5_OUT | PXITrig4 as the signal desition to route.
JY8902_PXI_Trig6_OUT | PXITrig5 as the signal desition to route.
JY8902_PXI_Trig7_OUT | PXITrig6 as the signal desition to route.
JY8902_None | PXITrig7 as the signal desition to route.

◆ JY8902_Signal_Source

enum JY8902_Signal_Source
Enumerator
JY8902_Signal_PFI0 | PFI0 as the source signle to rout.
JY8902_Signal_PFI1 | PFI1 as the source signle to rout.
JY8902_Signal_PXI_Trig0 | PXI_Trig0 as the source signle to rout.
JY8902_Signal_PXI_Trig1 | PXI_Trig1 as the source signle to rout.
JY8902_Signal_PXI_Trig2 | PXI_Trig2 as the source signle to rout.
JY8902_Signal_PXI_Trig3 | PXI_Trig3 as the source signle to rout.
JY8902_Signal_PXI_Trig4 | PXI_Trig4 as the source signle to rout.
JY8902_Signal_PXI_Trig5 | PXI_Trig5 as the source signle to rout.
JY8902_Signal_PXI_Trig6 | PXI_Trig6 as the source signle to rout.
JY8902_Signal_PXI_Trig7 | PXI_Trig7 as the source signle to rout.
JY8902_Signal_MeasureComplete | MeasureComplete Signal as the source signle to rout.

Function Documentation

◆ JY8902_Close()

JY8902API int JY8902_Close ( JY8902_DeviceHandle hDevice )

Close this 8902 board.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY8902_DisconnectSignalRouting()

JY8902API int JY8902_DisconnectSignalRouting | ( | JY8902_DeviceHandle | hDevice,
 |  | JY8902_Signal_Destination | destination )

Disconnect an established routing.

Parameters
hDevice | device handle
destination | destination of the signal defined by enum JY8902_DestinationSignal
Returns
0 if success or other error code

◆ JY8902_DMM_CheckBufferStatus()

JY8902API int JY8902_DMM_CheckBufferStatus | ( | JY8902_DeviceHandle | hDevice,
 |  | unsigned long long * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun )

Check buffer status.

Parameters
hDevice | device handle
avaliableSamples | number of samples in the device buffer
transferedSamples | The number of samples that have been transfered from the device buffer
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY8902_DMM_CheckMeasureStatus()

JY8902API int JY8902_DMM_CheckMeasureStatus | ( | JY8902_DeviceHandle | hDevice,
 |  | bool * | overRange )

Check Measure status.

Parameters
hDevice | device handle
overRange | ADC over range flag.
Returns
0 if success or other error code

◆ JY8902_DMM_DisableCalibration()

JY8902API int JY8902_DMM_DisableCalibration | ( | JY8902_DeviceHandle | hDevice,
 |  | bool | DisableCalibration )

If disable the calibration.

Parameters
hDevice | device handle
DisableCalibration | If disable the calibration
Returns
0 if success or other error code

◆ JY8902_DMM_GetApertureTime()

JY8902API int JY8902_DMM_GetApertureTime | ( | JY8902_DeviceHandle | hDevice,
 |  | double * | ApertureTime )

Gets the integration time in seconds (called aperture time) of the analog-to-digital converter for measurements.

Only certain discrete apertures are supported. Setting this property will cause it to select the nearest aperture that is greater than or equal to the value specified

Parameters
hDevice | device handle
apeture | Gets the integration time in seconds (called aperture time) of the analog-to-digital converter for measurements. Only certain discrete apertures are supported. Setting this property will cause it to select the nearest aperture that is greater than or equal to the value specifieds
Returns
0 if success or other error code

◆ JY8902_DMM_GetNPLC()

JY8902API int JY8902_DMM_GetNPLC | ( | JY8902_DeviceHandle | hDevice,
 |  | double * | nplc )

Get the integration time in number of power line cycles (PLCs) of the analog-to-digital converter for measurements.

Parameters
hDevice | device handle
nplc | Gets the integration time in number of power line cycles (PLCs) of the analog-to-digital converter for measurements.
Returns
0 if success or other error code

◆ JY8902_DMM_PowerLineFrequency()

JY8902API int JY8902_DMM_PowerLineFrequency | ( | JY8902_DeviceHandle | hDevice,
 |  | JY8902_DMM_PowerFrequency | powerFrequency )

This function configures the power line frequency of the DMM.

Parameters
hDevice | device handle
powerFrequency | Specifies the power line frequency,select by enum JY8902_DMM_PowerFrequency. defalut is 50_Hz
Returns
0 if success or other error code

◆ JY8902_DMM_Read()

JY8902API int JY8902_DMM_Read | ( | JY8902_DeviceHandle | hDevice,
 |  | double * | measureValue,
 |  | int | timeOut )

Initiates a measurement, waits for the DMM to return to the idle state, and returns the measured value.

Parameters
hDevice | device handle
measureValue | Measurement value.
timeOut | The maximum time allowed for the measurement to complete in milliseconds.
Returns
0 if success or other error code

◆ JY8902_DMM_ReadMultiPoint()

JY8902API int JY8902_DMM_ReadMultiPoint | ( | JY8902_DeviceHandle | hDevice,
 |  | double * | measureValues,
 |  | int | readLength,
 |  | int | timeOut,
 |  | int * | actualReadLenght )

Initiates a measurement, waits for the DMM to return to the idle state, and returns an array of values.

Parameters
hDevice | device handle
measureValues | Measurement value. Array
readLength | read length. The measureValues ayyar length must greater than or equal to readLength
timeOut | The maximum time allowed for the measurement to complete in milliseconds.
actualReadLenght | Actual read length.
Returns
0 if success or other error code

◆ JY8902_DMM_ReadRawData()

JY8902API int JY8902_DMM_ReadRawData | ( | JY8902_DeviceHandle | hDevice,
 |  | double * | measureValue,
 |  | int | timeOut )

Initiates a measurement, waits for the DMM to return to the idle state, and returns the measured raw voltage value.

Parameters
hDevice | device handle
measureValue | Measurement value.
timeOut | The maximum time allowed for the measurement to complete in milliseconds.
Returns
0 if success or other error code

◆ JY8902_DMM_RoutMeasurementComplete()

JY8902API int JY8902_DMM_RoutMeasurementComplete | ( | JY8902_DeviceHandle | hDevice,
 |  | JY8902_Signal_Destination | destination )

Set the destination of the measurement-complete signal generated after each measurement.

Parameters
hDevice | device handle
destination | The destination of the measurement-complete signal generated after each measurement
Returns
0 if success or other error code

◆ JY8902_DMM_SendSoftTrigger()

JY8902API int JY8902_DMM_SendSoftTrigger ( JY8902_DeviceHandle hDevice )

Send softTrigger.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY8902_DMM_Set2WireResistance()

JY8902API int JY8902_DMM_Set2WireResistance | ( | JY8902_DeviceHandle | hDevice,
 |  | JY8902_DMM_2_Wire_ResistanceRange | range )

Set 2Wire Resistance measurement.

Parameters
hDevice | device handle
range | 2Wire Resistance range, select by enum JY8902_DMM_2_Wire_ResistanceRange, default JY8902_2_Wire_Resistance_1M�� range
Returns
0 if success or other error code

◆ JY8902_DMM_Set4WireResistance()

JY8902API int JY8902_DMM_Set4WireResistance | ( | JY8902_DeviceHandle | hDevice,
 |  | JY8902_DMM_4_Wire_ResistanceRange | range )

Set 4Wire Resistance measurement.

Parameters
hDevice | device handle
range | 4Wire Resistance range, select by enum JY8902_DMM_4_Wire_ResistanceRange, default JY8902_4_Wire_Resistance_1k�� range
Returns
0 if success or other error code

◆ JY8902_DMM_SetACCurrent()

JY8902API int JY8902_DMM_SetACCurrent | ( | JY8902_DeviceHandle | hDevice,
 |  | JY8902_DMM_AC_CurrentRange | range )

Set AC Current measurement.

Parameters
hDevice | device handle
range | AC Volt range, select by enum JY8902_DMM_AC_CurrentRange, default JY8902_AC_Current_2mA range
Returns
0 if success or other error code

◆ JY8902_DMM_SetACVolt()

JY8902API int JY8902_DMM_SetACVolt | ( | JY8902_DeviceHandle | hDevice,
 |  | JY8902_DMM_AC_VoltRange | range )

Set AC Volt measurement.

Parameters
hDevice | device handle
range | AC Volt range, select by enum JY8902_DMM_AC_VoltRange, default JY8902_AC_Volt_2V range
Returns
0 if success or other error code

◆ JY8902_DMM_SetApertureTime()

JY8902API int JY8902_DMM_SetApertureTime | ( | JY8902_DeviceHandle | hDevice,
 |  | double | ApertureTime )

Sets the integration time in seconds (called aperture time) of the analog-to-digital converter for measurements.

Only certain discrete apertures are supported. Setting this property will cause it to select the nearest aperture that is greater than or equal to the value specified

Parameters
hDevice | device handle
apeture | Setthe integration time in seconds (called aperture time) of the analog-to-digital converter for measurements. Only certain discrete apertures are supported. Setting this property will cause it to select the nearest aperture that is greater than or equal to the value specifieds
Returns
0 if success or other error code

◆ JY8902_DMM_SetApertureUnit()

JY8902API int JY8902_DMM_SetApertureUnit | ( | JY8902_DeviceHandle | hDevice,
 |  | JY8902_DMM_ApetureUint | apertureUnit )

Sets DMM Aperture Unit.

Parameters
hDevice | device handle
apertureUnit | Aperture Unit
Returns
0 if success or other error code

◆ JY8902_DMM_SetDCCurrent()

JY8902API int JY8902_DMM_SetDCCurrent | ( | JY8902_DeviceHandle | hDevice,
 |  | JY8902_DMM_DC_CurrentRange | range )

Set DC Current measurement.

Parameters
hDevice | device handle
range | DC Volt range, select by enum JY8902_DMM_DC_CurrentRange, default JY8902_DC_Current_2mA range
Returns
0 if success or other error code

◆ JY8902_DMM_SetDCVolt()

JY8902API int JY8902_DMM_SetDCVolt | ( | JY8902_DeviceHandle | hDevice,
 |  | JY8902_DMM_DC_VoltRange | range )

Set DC Volt measurement.

Parameters
hDevice | device handle
range | DC Volt range, select by enum JY8902_DMM_DC_VoltRange, default JY8902_DC_Volt_2V range
Returns
0 if success or other error code

◆ JY8902_DMM_SetDigitalTrigger()

JY8902API int JY8902_DMM_SetDigitalTrigger | ( | JY8902_DeviceHandle | hDevice,
 |  | JY8902_DMM_DigitalTriggerSource | triggerSource,
 |  | JY8902_DMM_DigitalTriggerEdge | triggerEdge )

Set Digital Trigger.

Parameters
hDevice | device handle
triggerSource | Digital Trigger Source
triggerEdge | Digital Trigger Edge
Returns
0 if success or other error code

◆ JY8902_DMM_SetMeasurementFunction()

JY8902API int JY8902_DMM_SetMeasurementFunction | ( | JY8902_DeviceHandle | hDevice,
 |  | JY8902_DMM_MeasurementFunction | function )

Set DMM Measurement Function,Specifies the Measurement Function used to acquire the measurement.

Parameters
hDevice | device handle
function | measurement function, select by enum JY8902_DMM_MeasurementFunction, default JY8902_DC_Volts function
Returns
0 if success or other error code

◆ JY8902_DMM_SetMultiSample()

JY8902API int JY8902_DMM_SetMultiSample | ( | JY8902_DeviceHandle | hDevice,
 |  | unsigned int | sampleCount,
 |  | JY8902_DMM_SampleTrigger | sampleTrigger,
 |  | double | sampleInterval )

Set multi sample mode.

Parameters
hDevice | device handle
sampleCount | The number of measurements the DMM takes each time it receives a trigger.
sampleInterval | The interval between samples in seconds.
Returns
0 if success or other error code

◆ JY8902_DMM_SetNPLC()

JY8902API int JY8902_DMM_SetNPLC | ( | JY8902_DeviceHandle | hDevice,
 |  | double | nplc )

Sets the integration time in number of power line cycles (PLCs) of the analog-to-digital converter for measurements.

Parameters
hDevice | device handle
nplc | Sets the integration time in number of power line cycles (PLCs) of the analog-to-digital converter for measurements.
Returns
0 if success or other error code

◆ JY8902_DMM_SetSampleMode()

JY8902API int JY8902_DMM_SetSampleMode | ( | JY8902_DeviceHandle | hDevice,
 |  | JY8902_DMM_SampleMode | sampleMode )

Set measurement mode.

Parameters
hDevice | device handle
sampleMode | sample mode. defined by enum JY8902_DMM_SampleMode,default is SinglePoint
Returns
0 if success or other error code

◆ JY8902_DMM_SetTriggerDelay()

JY8902API int JY8902_DMM_SetTriggerDelay | ( | JY8902_DeviceHandle | hDevice,
 |  | double | delay )

Set trigger delay.

Parameters
hDevice | device handle
delay | The length of time between when the DMM receives the trigger and when it takes a measurement (in seconds).
Returns
0 if success or other error code

◆ JY8902_DMM_SetTriggerType()

JY8902API int JY8902_DMM_SetTriggerType | ( | JY8902_DeviceHandle | hDevice,
 |  | JY8902_DMM_TriggerType | triggerType )

Set Trigger Type.

Parameters
hDevice | device handle
triggerType | trigger Type. defined by enum JY8902_DMM_TriggerType,default is JY8902_Immediately
Returns
0 if success or other error code

◆ JY8902_DMM_Start()

JY8902API int JY8902_DMM_Start ( JY8902_DeviceHandle hDevice )

DMM Start measurement.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY8902_DMM_Stop()

JY8902API int JY8902_DMM_Stop ( JY8902_DeviceHandle hDevice )

DMM Stop measurement.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY8902_GetDeviceID()

JY8902API int JY8902_GetDeviceID | ( | JY8902_DeviceHandle | hDevice,
 |  | int * | deviceID )

Obtain the board ID.

The 8902 is a series of boards. The PXIe-8902 board ID is Ox8902 The PCIe-8902 board ID is OxA902

Parameters
hDevice | device handle
deviceID | board ID
Returns
0 if success or other error code

◆ JY8902_GetDeviceSerialNumber()

JY8902API int JY8902_GetDeviceSerialNumber | ( | JY8902_DeviceHandle | hDevice,
 |  | char * | serialNumber,
 |  | int | length )

Obtain the device serialNumber.

Parameters
hDevice | device handle
serialNumber | Pointer to a buffer receiving the serial number. The length of the serial number is 10.
length | serial Number length ,length is 10
Returns
0 if success or other error code

◆ JY8902_Open()

JY8902API int JY8902_Open | ( | int | slotNumber,
 |  | JY8902_DeviceHandle * | hDevice )

Open the 8902 series boards using the slot number or the board serial number.

PXIe slot number is predefined by the PXIe chassis. PCIe slot number is defined by the DIP switch. The board serial number is defined by the system starting from 0. It's your responsibility to know the number. For a single board, the serial number is 0.

Parameters
slotNumber | slot number or board serial number
hDevice | device handle. All other functions uses hDevice to represent this device.
Returns
0 if success or other error code

◆ JY8902_OpenByAliasName()

JY8902API int JY8902_OpenByAliasName | ( | const char * | aliasName,
 |  | JY8902_DeviceHandle * | hDevice )

Open this 8902 series boards using the board alias name which is set by JYTEK utility JYDM.

You can change the name using JYDM.

Parameters
cardName | board alias name
hDevice | device handle
Returns
0 if success or other error code

◆ JY8902_SetDeviceReferenceClock()

JY8902API int JY8902_SetDeviceReferenceClock | ( | JY8902_DeviceHandle | hDevice,
 |  | JY8902_ReferenceClock | clockSource )

Set Reference Clock for the device.There are two ReferenceClock, 25MHz from this device or 100MHz from the PXIe chassis.

PCIe device only supports 25MHz timebase.

Parameters
hDevice | device handle
clkSource | ReferenceClock source defined by enum JY8902_ReferenceClock
Returns
0 if success or other error code

◆ JY8902_SetDeviceStatusLed()

JY8902API int JY8902_SetDeviceStatusLed | ( | JY8902_DeviceHandle | hDevice,
 |  | bool | enable,
 |  | unsigned int | frequency )

Control Front Panel Status Led.

Parameters
hDevice | device handle
enable | enable front panel status led blink, true: blink, false: not blink
frequency | when enable is ture, the led blink speed by frequency define
Returns
0 if success or other error code

◆ JY8902_SignalRouting()

JY8902API int JY8902_SignalRouting | ( | JY8902_DeviceHandle | hDevice,
 |  | JY8902_Signal_Source | sourceSignal,
 |  | JY8902_Signal_Destination | distination )

Route a singal from source to destination.

Both source and destination are defined by the corresponding enum Y5500_SourceSignal and JY8902_DestinationSignal. One source signal may be routed to multiple destinations.

Parameters
hDevice | device handle
source | source of the signal defined by enum JY8902_SourceSignal
destination | destination of the signal defined by enum JY8902_DestinationSignal
Returns
0 if success or other error code
Generated by doxygen 1.12.0


8902 C++ Programming Manual: D:/8902 Directory Reference

  • 8902
8902 Directory Reference

Directories

C++


8902 C++ Programming Manual: D:/8902/C++ Directory Reference

  • 8902
  • C++
C++ Directory Reference

Files

JY8902.h
@SectionBegin JY8902FileHead


8902 C++ Programming Manual: File List

File List
Here is a list of all files with brief descriptions:
[detail level 123]
▼ 8902 |
▼ C++ |
JY8902.h | @SectionBegin JY8902FileHead


8902 C++ Programming Manual: File Members

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • j
Here is a list of all file members with links to the files they belong to:

- j -

  • JY8902_2_Wire_Resistance : JY8902.h
  • JY8902_2_Wire_Resistance_100 : JY8902.h
  • JY8902_2_Wire_Resistance_100K : JY8902.h
  • JY8902_2_Wire_Resistance_100M : JY8902.h
  • JY8902_2_Wire_Resistance_10K : JY8902.h
  • JY8902_2_Wire_Resistance_10M : JY8902.h
  • JY8902_2_Wire_Resistance_1K : JY8902.h
  • JY8902_2_Wire_Resistance_1M : JY8902.h
  • JY8902_2_Wire_Resistance_Auto : JY8902.h
  • JY8902_4_Wire_Resistance : JY8902.h
  • JY8902_4_Wire_Resistance_100 : JY8902.h
  • JY8902_4_Wire_Resistance_100K : JY8902.h
  • JY8902_4_Wire_Resistance_10K : JY8902.h
  • JY8902_4_Wire_Resistance_1K : JY8902.h
  • JY8902_4_Wire_Resistance_1M : JY8902.h
  • JY8902_4_Wire_Resistance_Auto : JY8902.h
  • JY8902_50_Hz : JY8902.h
  • JY8902_60_Hz : JY8902.h
  • JY8902_AC_Current : JY8902.h
  • JY8902_AC_Current_1000mA : JY8902.h
  • JY8902_AC_Current_200mA : JY8902.h
  • JY8902_AC_Current_20mA : JY8902.h
  • JY8902_AC_Current_Auto : JY8902.h
  • JY8902_AC_Volt_200mV : JY8902.h
  • JY8902_AC_Volt_20V : JY8902.h
  • JY8902_AC_Volt_240V : JY8902.h
  • JY8902_AC_Volt_2V : JY8902.h
  • JY8902_AC_Volt_Auto : JY8902.h
  • JY8902_AC_Volts : JY8902.h
  • JY8902_Clock_PFI0 : JY8902.h
  • JY8902_Clock_PFI1 : JY8902.h
  • JY8902_Clock_PXI_Trig0 : JY8902.h
  • JY8902_Clock_PXI_Trig1 : JY8902.h
  • JY8902_Clock_PXI_Trig2 : JY8902.h
  • JY8902_Clock_PXI_Trig3 : JY8902.h
  • JY8902_Clock_PXI_Trig4 : JY8902.h
  • JY8902_Clock_PXI_Trig5 : JY8902.h
  • JY8902_Clock_PXI_Trig6 : JY8902.h
  • JY8902_Clock_PXI_Trig7 : JY8902.h
  • JY8902_Close() : JY8902.h
  • JY8902_ContinuousMultiPoint : JY8902.h
  • JY8902_DC_Current : JY8902.h
  • JY8902_DC_Current_1000mA : JY8902.h
  • JY8902_DC_Current_200mA : JY8902.h
  • JY8902_DC_Current_20mA : JY8902.h
  • JY8902_DC_Current_Auto : JY8902.h
  • JY8902_DC_Volt_200mV : JY8902.h
  • JY8902_DC_Volt_20V : JY8902.h
  • JY8902_DC_Volt_240V : JY8902.h
  • JY8902_DC_Volt_2V : JY8902.h
  • JY8902_DC_Volt_Auto : JY8902.h
  • JY8902_DC_Volts : JY8902.h
  • JY8902_DeviceHandle : JY8902.h
  • JY8902_Digital : JY8902.h
  • JY8902_DisconnectSignalRouting() : JY8902.h
  • JY8902_DMM_2_Wire_ResistanceRange : JY8902.h
  • JY8902_DMM_4_Wire_ResistanceRange : JY8902.h
  • JY8902_DMM_AC_CurrentRange : JY8902.h
  • JY8902_DMM_AC_VoltRange : JY8902.h
  • JY8902_DMM_ApetureUint : JY8902.h
  • JY8902_DMM_CheckBufferStatus() : JY8902.h
  • JY8902_DMM_CheckMeasureStatus() : JY8902.h
  • JY8902_DMM_ClockSource : JY8902.h
  • JY8902_DMM_DC_CurrentRange : JY8902.h
  • JY8902_DMM_DC_VoltRange : JY8902.h
  • JY8902_DMM_DigitalTriggerEdge : JY8902.h
  • JY8902_DMM_DigitalTriggerSource : JY8902.h
  • JY8902_DMM_DisableCalibration() : JY8902.h
  • JY8902_DMM_ExternalSampleClock : JY8902.h
  • JY8902_DMM_GetApertureTime() : JY8902.h
  • JY8902_DMM_GetNPLC() : JY8902.h
  • JY8902_DMM_MeasurementFunction : JY8902.h
  • JY8902_DMM_PowerFrequency : JY8902.h
  • JY8902_DMM_PowerLineFrequency() : JY8902.h
  • JY8902_DMM_Read() : JY8902.h
  • JY8902_DMM_ReadMultiPoint() : JY8902.h
  • JY8902_DMM_ReadRawData() : JY8902.h
  • JY8902_DMM_RoutMeasurementComplete() : JY8902.h
  • JY8902_DMM_SampleMode : JY8902.h
  • JY8902_DMM_SampleTrigger : JY8902.h
  • JY8902_DMM_SendSoftTrigger() : JY8902.h
  • JY8902_DMM_Set2WireResistance() : JY8902.h
  • JY8902_DMM_Set4WireResistance() : JY8902.h
  • JY8902_DMM_SetACCurrent() : JY8902.h
  • JY8902_DMM_SetACVolt() : JY8902.h
  • JY8902_DMM_SetApertureTime() : JY8902.h
  • JY8902_DMM_SetApertureUnit() : JY8902.h
  • JY8902_DMM_SetDCCurrent() : JY8902.h
  • JY8902_DMM_SetDCVolt() : JY8902.h
  • JY8902_DMM_SetDigitalTrigger() : JY8902.h
  • JY8902_DMM_SetMeasurementFunction() : JY8902.h
  • JY8902_DMM_SetMultiSample() : JY8902.h
  • JY8902_DMM_SetNPLC() : JY8902.h
  • JY8902_DMM_SetSampleMode() : JY8902.h
  • JY8902_DMM_SetTriggerDelay() : JY8902.h
  • JY8902_DMM_SetTriggerType() : JY8902.h
  • JY8902_DMM_Start() : JY8902.h
  • JY8902_DMM_Stop() : JY8902.h
  • JY8902_DMM_TriggerType : JY8902.h
  • JY8902_ExternalClock : JY8902.h
  • JY8902_Falling : JY8902.h
  • JY8902_GetDeviceID() : JY8902.h
  • JY8902_GetDeviceSerialNumber() : JY8902.h
  • JY8902_Immediately : JY8902.h
  • JY8902_Internal : JY8902.h
  • JY8902_InternalClock : JY8902.h
  • JY8902_MultiSample : JY8902.h
  • JY8902_None : JY8902.h
  • JY8902_NPLC : JY8902.h
  • JY8902_Open() : JY8902.h
  • JY8902_OpenByAliasName() : JY8902.h
  • JY8902_PFI0 : JY8902.h
  • JY8902_PFI0_OUT : JY8902.h
  • JY8902_PFI1 : JY8902.h
  • JY8902_PFI1_OUT : JY8902.h
  • JY8902_PXI_Trig0 : JY8902.h
  • JY8902_PXI_Trig0_OUT : JY8902.h
  • JY8902_PXI_Trig1 : JY8902.h
  • JY8902_PXI_Trig1_OUT : JY8902.h
  • JY8902_PXI_Trig2 : JY8902.h
  • JY8902_PXI_Trig2_OUT : JY8902.h
  • JY8902_PXI_Trig3 : JY8902.h
  • JY8902_PXI_Trig3_OUT : JY8902.h
  • JY8902_PXI_Trig4 : JY8902.h
  • JY8902_PXI_Trig4_OUT : JY8902.h
  • JY8902_PXI_Trig5 : JY8902.h
  • JY8902_PXI_Trig5_OUT : JY8902.h
  • JY8902_PXI_Trig6 : JY8902.h
  • JY8902_PXI_Trig6_OUT : JY8902.h
  • JY8902_PXI_Trig7 : JY8902.h
  • JY8902_PXI_Trig7_OUT : JY8902.h
  • JY8902_PXIe_Clk100 : JY8902.h
  • JY8902_ReferenceClock : JY8902.h
  • JY8902_Rising : JY8902.h
  • JY8902_Sample_Immediately : JY8902.h
  • JY8902_Sample_PFI0 : JY8902.h
  • JY8902_Sample_PFI1 : JY8902.h
  • JY8902_Sample_PXI_Trig0 : JY8902.h
  • JY8902_Sample_PXI_Trig1 : JY8902.h
  • JY8902_Sample_PXI_Trig2 : JY8902.h
  • JY8902_Sample_PXI_Trig3 : JY8902.h
  • JY8902_Sample_PXI_Trig4 : JY8902.h
  • JY8902_Sample_PXI_Trig5 : JY8902.h
  • JY8902_Sample_PXI_Trig6 : JY8902.h
  • JY8902_Sample_PXI_Trig7 : JY8902.h
  • JY8902_Second : JY8902.h
  • JY8902_SetDeviceReferenceClock() : JY8902.h
  • JY8902_SetDeviceStatusLed() : JY8902.h
  • JY8902_Signal_Destination : JY8902.h
  • JY8902_Signal_MeasureComplete : JY8902.h
  • JY8902_Signal_PFI0 : JY8902.h
  • JY8902_Signal_PFI1 : JY8902.h
  • JY8902_Signal_PXI_Trig0 : JY8902.h
  • JY8902_Signal_PXI_Trig1 : JY8902.h
  • JY8902_Signal_PXI_Trig2 : JY8902.h
  • JY8902_Signal_PXI_Trig3 : JY8902.h
  • JY8902_Signal_PXI_Trig4 : JY8902.h
  • JY8902_Signal_PXI_Trig5 : JY8902.h
  • JY8902_Signal_PXI_Trig6 : JY8902.h
  • JY8902_Signal_PXI_Trig7 : JY8902.h
  • JY8902_Signal_Source : JY8902.h
  • JY8902_SignalRouting() : JY8902.h
  • JY8902_SingleSample : JY8902.h
  • JY8902_Soft : JY8902.h


  • Enumerations
  • Enumerator
Here is a list of all enums with links to the files they belong to:
  • JY8902_DMM_2_Wire_ResistanceRange : JY8902.h
  • JY8902_DMM_4_Wire_ResistanceRange : JY8902.h
  • JY8902_DMM_AC_CurrentRange : JY8902.h
  • JY8902_DMM_AC_VoltRange : JY8902.h
  • JY8902_DMM_ApetureUint : JY8902.h
  • JY8902_DMM_ClockSource : JY8902.h
  • JY8902_DMM_DC_CurrentRange : JY8902.h
  • JY8902_DMM_DC_VoltRange : JY8902.h
  • JY8902_DMM_DigitalTriggerEdge : JY8902.h
  • JY8902_DMM_DigitalTriggerSource : JY8902.h
  • JY8902_DMM_ExternalSampleClock : JY8902.h
  • JY8902_DMM_MeasurementFunction : JY8902.h
  • JY8902_DMM_PowerFrequency : JY8902.h
  • JY8902_DMM_SampleMode : JY8902.h
  • JY8902_DMM_SampleTrigger : JY8902.h
  • JY8902_DMM_TriggerType : JY8902.h
  • JY8902_ReferenceClock : JY8902.h
  • JY8902_Signal_Destination : JY8902.h
  • JY8902_Signal_Source : JY8902.h


  • Enumerations
  • Enumerator
  • j
Here is a list of all enum values with links to the files they belong to:

- j -

  • JY8902_2_Wire_Resistance : JY8902.h
  • JY8902_2_Wire_Resistance_100 : JY8902.h
  • JY8902_2_Wire_Resistance_100K : JY8902.h
  • JY8902_2_Wire_Resistance_100M : JY8902.h
  • JY8902_2_Wire_Resistance_10K : JY8902.h
  • JY8902_2_Wire_Resistance_10M : JY8902.h
  • JY8902_2_Wire_Resistance_1K : JY8902.h
  • JY8902_2_Wire_Resistance_1M : JY8902.h
  • JY8902_2_Wire_Resistance_Auto : JY8902.h
  • JY8902_4_Wire_Resistance : JY8902.h
  • JY8902_4_Wire_Resistance_100 : JY8902.h
  • JY8902_4_Wire_Resistance_100K : JY8902.h
  • JY8902_4_Wire_Resistance_10K : JY8902.h
  • JY8902_4_Wire_Resistance_1K : JY8902.h
  • JY8902_4_Wire_Resistance_1M : JY8902.h
  • JY8902_4_Wire_Resistance_Auto : JY8902.h
  • JY8902_50_Hz : JY8902.h
  • JY8902_60_Hz : JY8902.h
  • JY8902_AC_Current : JY8902.h
  • JY8902_AC_Current_1000mA : JY8902.h
  • JY8902_AC_Current_200mA : JY8902.h
  • JY8902_AC_Current_20mA : JY8902.h
  • JY8902_AC_Current_Auto : JY8902.h
  • JY8902_AC_Volt_200mV : JY8902.h
  • JY8902_AC_Volt_20V : JY8902.h
  • JY8902_AC_Volt_240V : JY8902.h
  • JY8902_AC_Volt_2V : JY8902.h
  • JY8902_AC_Volt_Auto : JY8902.h
  • JY8902_AC_Volts : JY8902.h
  • JY8902_Clock_PFI0 : JY8902.h
  • JY8902_Clock_PFI1 : JY8902.h
  • JY8902_Clock_PXI_Trig0 : JY8902.h
  • JY8902_Clock_PXI_Trig1 : JY8902.h
  • JY8902_Clock_PXI_Trig2 : JY8902.h
  • JY8902_Clock_PXI_Trig3 : JY8902.h
  • JY8902_Clock_PXI_Trig4 : JY8902.h
  • JY8902_Clock_PXI_Trig5 : JY8902.h
  • JY8902_Clock_PXI_Trig6 : JY8902.h
  • JY8902_Clock_PXI_Trig7 : JY8902.h
  • JY8902_ContinuousMultiPoint : JY8902.h
  • JY8902_DC_Current : JY8902.h
  • JY8902_DC_Current_1000mA : JY8902.h
  • JY8902_DC_Current_200mA : JY8902.h
  • JY8902_DC_Current_20mA : JY8902.h
  • JY8902_DC_Current_Auto : JY8902.h
  • JY8902_DC_Volt_200mV : JY8902.h
  • JY8902_DC_Volt_20V : JY8902.h
  • JY8902_DC_Volt_240V : JY8902.h
  • JY8902_DC_Volt_2V : JY8902.h
  • JY8902_DC_Volt_Auto : JY8902.h
  • JY8902_DC_Volts : JY8902.h
  • JY8902_Digital : JY8902.h
  • JY8902_ExternalClock : JY8902.h
  • JY8902_Falling : JY8902.h
  • JY8902_Immediately : JY8902.h
  • JY8902_Internal : JY8902.h
  • JY8902_InternalClock : JY8902.h
  • JY8902_MultiSample : JY8902.h
  • JY8902_None : JY8902.h
  • JY8902_NPLC : JY8902.h
  • JY8902_PFI0 : JY8902.h
  • JY8902_PFI0_OUT : JY8902.h
  • JY8902_PFI1 : JY8902.h
  • JY8902_PFI1_OUT : JY8902.h
  • JY8902_PXI_Trig0 : JY8902.h
  • JY8902_PXI_Trig0_OUT : JY8902.h
  • JY8902_PXI_Trig1 : JY8902.h
  • JY8902_PXI_Trig1_OUT : JY8902.h
  • JY8902_PXI_Trig2 : JY8902.h
  • JY8902_PXI_Trig2_OUT : JY8902.h
  • JY8902_PXI_Trig3 : JY8902.h
  • JY8902_PXI_Trig3_OUT : JY8902.h
  • JY8902_PXI_Trig4 : JY8902.h
  • JY8902_PXI_Trig4_OUT : JY8902.h
  • JY8902_PXI_Trig5 : JY8902.h
  • JY8902_PXI_Trig5_OUT : JY8902.h
  • JY8902_PXI_Trig6 : JY8902.h
  • JY8902_PXI_Trig6_OUT : JY8902.h
  • JY8902_PXI_Trig7 : JY8902.h
  • JY8902_PXI_Trig7_OUT : JY8902.h
  • JY8902_PXIe_Clk100 : JY8902.h
  • JY8902_Rising : JY8902.h
  • JY8902_Sample_Immediately : JY8902.h
  • JY8902_Sample_PFI0 : JY8902.h
  • JY8902_Sample_PFI1 : JY8902.h
  • JY8902_Sample_PXI_Trig0 : JY8902.h
  • JY8902_Sample_PXI_Trig1 : JY8902.h
  • JY8902_Sample_PXI_Trig2 : JY8902.h
  • JY8902_Sample_PXI_Trig3 : JY8902.h
  • JY8902_Sample_PXI_Trig4 : JY8902.h
  • JY8902_Sample_PXI_Trig5 : JY8902.h
  • JY8902_Sample_PXI_Trig6 : JY8902.h
  • JY8902_Sample_PXI_Trig7 : JY8902.h
  • JY8902_Second : JY8902.h
  • JY8902_Signal_MeasureComplete : JY8902.h
  • JY8902_Signal_PFI0 : JY8902.h
  • JY8902_Signal_PFI1 : JY8902.h
  • JY8902_Signal_PXI_Trig0 : JY8902.h
  • JY8902_Signal_PXI_Trig1 : JY8902.h
  • JY8902_Signal_PXI_Trig2 : JY8902.h
  • JY8902_Signal_PXI_Trig3 : JY8902.h
  • JY8902_Signal_PXI_Trig4 : JY8902.h
  • JY8902_Signal_PXI_Trig5 : JY8902.h
  • JY8902_Signal_PXI_Trig6 : JY8902.h
  • JY8902_Signal_PXI_Trig7 : JY8902.h
  • JY8902_SingleSample : JY8902.h
  • JY8902_Soft : JY8902.h


  • Enumerations
  • Enumerator
  • j
Here is a list of all functions with links to the files they belong to:

- j -

  • JY8902_Close() : JY8902.h
  • JY8902_DisconnectSignalRouting() : JY8902.h
  • JY8902_DMM_CheckBufferStatus() : JY8902.h
  • JY8902_DMM_CheckMeasureStatus() : JY8902.h
  • JY8902_DMM_DisableCalibration() : JY8902.h
  • JY8902_DMM_GetApertureTime() : JY8902.h
  • JY8902_DMM_GetNPLC() : JY8902.h
  • JY8902_DMM_PowerLineFrequency() : JY8902.h
  • JY8902_DMM_Read() : JY8902.h
  • JY8902_DMM_ReadMultiPoint() : JY8902.h
  • JY8902_DMM_ReadRawData() : JY8902.h
  • JY8902_DMM_RoutMeasurementComplete() : JY8902.h
  • JY8902_DMM_SendSoftTrigger() : JY8902.h
  • JY8902_DMM_Set2WireResistance() : JY8902.h
  • JY8902_DMM_Set4WireResistance() : JY8902.h
  • JY8902_DMM_SetACCurrent() : JY8902.h
  • JY8902_DMM_SetACVolt() : JY8902.h
  • JY8902_DMM_SetApertureTime() : JY8902.h
  • JY8902_DMM_SetApertureUnit() : JY8902.h
  • JY8902_DMM_SetDCCurrent() : JY8902.h
  • JY8902_DMM_SetDCVolt() : JY8902.h
  • JY8902_DMM_SetDigitalTrigger() : JY8902.h
  • JY8902_DMM_SetMeasurementFunction() : JY8902.h
  • JY8902_DMM_SetMultiSample() : JY8902.h
  • JY8902_DMM_SetNPLC() : JY8902.h
  • JY8902_DMM_SetSampleMode() : JY8902.h
  • JY8902_DMM_SetTriggerDelay() : JY8902.h
  • JY8902_DMM_SetTriggerType() : JY8902.h
  • JY8902_DMM_Start() : JY8902.h
  • JY8902_DMM_Stop() : JY8902.h
  • JY8902_GetDeviceID() : JY8902.h
  • JY8902_GetDeviceSerialNumber() : JY8902.h
  • JY8902_Open() : JY8902.h
  • JY8902_OpenByAliasName() : JY8902.h
  • JY8902_SetDeviceReferenceClock() : JY8902.h
  • JY8902_SetDeviceStatusLed() : JY8902.h
  • JY8902_SignalRouting() : JY8902.h


  • Enumerations
  • Enumerator
Here is a list of all typedefs with links to the files they belong to:
  • JY8902_DeviceHandle : JY8902.h


8902 C++ Programming Manual: Main Page

8902 C++ Programming Manual Documentation