8902 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/8902 Directory Reference

8902 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 8902
8902 Directory Reference

Files

JY8902CoreOOCommon.h
JY8902CoreOODevice.h
JY8902CoreOOLog.h
jy8902coreootask.h
Generated by doxygen 1.13.2


8902 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/8902/JY8902CoreOOCommon.h File Reference

  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 8902
Classes | Namespaces | Macros | Enumerations | Functions | Variables
JY8902CoreOOCommon.h File Reference
#include <string>
#include <stdint.h>

Classes

class | JY8902CoreOO::JYDriverException
class | JY8902CoreOO::JY8902CoreOOProperty< ContainerClass, ValueType, propertyType >
属性模板类 More...
struct | TempInfor
tempInfor struct More...

Namespaces

namespace | JY8902Import
namespace | JY8902CoreOO

Macros

#define | EXTERN_C extern
Windows.
#define | JY8902CoreOO_API

Enumerations

enum class | JY8902CoreOO::JY8902CoreOOPropertyType { JY8902CoreOO::READ_ONLY = 1 , JY8902CoreOO::WRITE_ONLY = 2 , JY8902CoreOO::READ_WRITE = 3 }
enum class JY8902CoreOO::JYDriverExceptionPublic {
JY8902CoreOO::UnKnown = 0 , JY8902CoreOO::OpenDeviceFailed = -10001 , JY8902CoreOO::CloseDeviceFailed = -10002 , JY8902CoreOO::ResetDeviceFailed = -10003 ,
JY8902CoreOO::GetDevicePropertyFailed = -10004 , JY8902CoreOO::SetDevicePropertyFailed = -10005 , JY8902CoreOO::HardwareResourceIsReserved = -10006 , JY8902CoreOO::MethodNotPermitedToCallWhenCurrentStatus = -10007 ,
JY8902CoreOO::InvalidUserDataBuffer = -10008 , JY8902CoreOO::NoChannelAdded = -10009 , JY8902CoreOO::NotSupportOperationForCurrentDevice = -10010 , JY8902CoreOO::CreatTaskFailed = -10100 ,
JY8902CoreOO::StartTaskFailed = -10101 , JY8902CoreOO::StopTaskFailed = -10102 , JY8902CoreOO::TaskHasNotStarted = -10103 , JY8902CoreOO::TaskHasStartedCannotPerformTheSetOperation = -10104 ,
JY8902CoreOO::ChannelNumberParameterInvalid = -10105 , JY8902CoreOO::ChannelInputRangeParameterInvalid = -10106 , JY8902CoreOO::ChannelTerminalParameterInvalid = -10107 , JY8902CoreOO::ChannelCouplingParameterInvalid = -10108 ,
JY8902CoreOO::SampeleModeParameterInvalid = -10109 , JY8902CoreOO::SampleClockParameterInvalid = -10110 , JY8902CoreOO::SampleRateParameterInvalid = -10111 , JY8902CoreOO::UpdateRateParameterInvalid = -10112 ,
JY8902CoreOO::TriggerParameterInvalid = -10113 , JY8902CoreOO::ReferenceTriggerDoesNotMatchWithSampleMode = -10114 , JY8902CoreOO::PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint = -10115 , JY8902CoreOO::ReadDataFailed = -10016 ,
JY8902CoreOO::ReadDataTimeout = -10017 , JY8902CoreOO::WriteDataFailed = -10018 , JY8902CoreOO::WriteDataTimeout = -10019 , JY8902CoreOO::WriteDataLengthCannotBeLessThanN = -10020 ,
JY8902CoreOO::BufferDataOverflow = -10021 , JY8902CoreOO::BufferDataDownflow = -10022 , JY8902CoreOO::CheckBufferFailed = -10023 , JY8902CoreOO::PointInvalidInFiniteMode = -10024 ,
JY8902CoreOO::ReadPointInvalid = -10025 , JY8902CoreOO::OnlySupportRecordMode = -10026 , JY8902CoreOO::SendSoftTirggerFailed = -10027 , JY8902CoreOO::TaskTimeout = -10028 ,
JY8902CoreOO::CounterParametersInvalid = -10029 , JY8902CoreOO::WritePointInvalid = -10030 , JY8902CoreOO::SignalExportDestinationInvalid = -10031 , JY8902CoreOO::InvalidParameter = -10033
}
enum class | MeaurementMode { SinglePoint = JY8902Import::SinglePoint , MultiPoint = JY8902Import::MultiPoint , ContinuousMultiPoint = JY8902Import::ContinuousMultiPoint }
enum class MeasurementFunction {
DCVolt = JY8902Import::DCVolt , ACVolt = JY8902Import::ACVolt , DCCurrent = JY8902Import::DCCurrent , ACCurrent = JY8902Import::ACCurrent ,
Resistance2Wire = JY8902Import::Resistance2Wire , Resistance4Wire = JY8902Import::Resistance4Wire
}
enum class | SamplingType { Aperture = JY8902Import::Aperture , NPLC = JY8902Import::NPLC }
enum class DCVoltRange {
Auto = JY8902Import::Auto , _200mV = JY8902Import::_200mV , _2V = JY8902Import::_2V , _20V = JY8902Import::_20V ,
_240V = JY8902Import::_240V
}
enum class ACVoltRange {
Auto = JY8902Import::Auto , _200mV = JY8902Import::_200mV , _2V = JY8902Import::_2V , _20V = JY8902Import::_20V ,
_240V = JY8902Import::_240V
}
enum class | DCCurrentRange { Auto = JY8902Import::Auto , _20mA = JY8902Import::_20mA , _200mA = JY8902Import::_200mA , _1000mA = JY8902Import::_1000mA }
enum class | ACCurrentRange { Auto = JY8902Import::Auto , _20mA = JY8902Import::_20mA , _200mA = JY8902Import::_200mA , _1000mA = JY8902Import::_1000mA }
enum class Resistance2WireRange {
Auto = JY8902Import::Auto , _100 = JY8902Import::_100 , _1K = JY8902Import::_1K , _10K = JY8902Import::_10K ,
_100K = JY8902Import::_100K , _1M = JY8902Import::_1M , _10M = JY8902Import::_10M , _100M = JY8902Import::_100M
}
enum class Resistance4WireRange {
Auto = JY8902Import::Auto , _100 = JY8902Import::_100 , _1K = JY8902Import::_1K , _10K = JY8902Import::_10K ,
_100K = JY8902Import::_100K , _1M = JY8902Import::_1M
}
enum class | TriggerType { Immediate = JY8902Import::Immediate , Software = JY8902Import::Software , Digital = JY8902Import::Digital }
enum class DigitalTriggerSource {
PFI0 = JY8902Import::PFI0 , PFI1 = JY8902Import::PFI1 , PXI_Trig0 = JY8902Import::PXI_Trig0 , PXI_Trig1 = JY8902Import::PXI_Trig1 ,
PXI_Trig2 = JY8902Import::PXI_Trig2 , PXI_Trig3 = JY8902Import::PXI_Trig3 , PXI_Trig4 = JY8902Import::PXI_Trig4 , PXI_Trig5 = JY8902Import::PXI_Trig5 ,
PXI_Trig6 = JY8902Import::PXI_Trig6 , PXI_Trig7 = JY8902Import::PXI_Trig7
}
enum class | MeasurementTriggerEdge { Rising = JY8902Import::Rising , Falling = JY8902Import::Falling }
enum class SignalExportDestination {
None = JY8902Import::None , PFI0 = JY8902Import::PFI0 , PFI1 = JY8902Import::PFI1 , PXI_Trig0 = JY8902Import::PXI_Trig0 ,
PXI_Trig1 = JY8902Import::PXI_Trig1 , PXI_Trig2 = JY8902Import::PXI_Trig2 , PXI_Trig3 = JY8902Import::PXI_Trig3 , PXI_Trig4 = JY8902Import::PXI_Trig4 ,
PXI_Trig5 = JY8902Import::PXI_Trig5 , PXI_Trig6 = JY8902Import::PXI_Trig6 , PXI_Trig7 = JY8902Import::PXI_Trig7
}
enum class | PowerLineFrequency { _50Hz = JY8902Import::_50Hz , _60Hz = JY8902Import::_60Hz }
enum class TriggerOut {
None = JY8902Import::None , PFI0 = JY8902Import::PFI0 , PFI1 = JY8902Import::PFI1 , PXI_Trig0 = JY8902Import::PXI_Trig0 ,
PXI_Trig1 = JY8902Import::PXI_Trig1 , PXI_Trig2 = JY8902Import::PXI_Trig2 , PXI_Trig3 = JY8902Import::PXI_Trig3 , PXI_Trig4 = JY8902Import::PXI_Trig4 ,
PXI_Trig5 = JY8902Import::PXI_Trig5 , PXI_Trig6 = JY8902Import::PXI_Trig6 , PXI_Trig7 = JY8902Import::PXI_Trig7
}

Functions

std::string GetSignalExportDestinationString (SignalExportDestination destination)

Variables

const int | JY8902Import::SinglePoint = 0
const int | JY8902Import::MultiPoint = 1
const int | JY8902Import::ContinuousMultiPoint = 2
const int | JY8902Import::DCVolt = 0
const int | JY8902Import::ACVolt = 1
const int | JY8902Import::DCCurrent = 2
const int | JY8902Import::ACCurrent = 3
const int | JY8902Import::Resistance2Wire = 4
const int | JY8902Import::Resistance4Wire = 5
const int | JY8902Import::Aperture = 0
const int | JY8902Import::NPLC = 1
const int | JY8902Import::Auto = 0
const int | JY8902Import::_200mV = 1
const int | JY8902Import::_2V = 2
const int | JY8902Import::_20V = 3
const int | JY8902Import::_240V = 4
const int | JY8902Import::_20mA = 1
const int | JY8902Import::_200mA = 2
const int | JY8902Import::_1000mA = 3
const int | JY8902Import::_100 = 1
const int | JY8902Import::_1K = 2
const int | JY8902Import::_10K = 3
const int | JY8902Import::_100K = 4
const int | JY8902Import::_1M = 5
const int | JY8902Import::_10M = 6
const int | JY8902Import::_100M = 7
const int | JY8902Import::Immediate = 0
const int | JY8902Import::Software = 1
const int | JY8902Import::Digital = 2
const int | JY8902Import::PFI0 = 0
const int | JY8902Import::PFI1 = 1
const int | JY8902Import::PXI_Trig0 = 2
const int | JY8902Import::PXI_Trig1 = 3
const int | JY8902Import::PXI_Trig2 = 4
const int | JY8902Import::PXI_Trig3 = 5
const int | JY8902Import::PXI_Trig4 = 6
const int | JY8902Import::PXI_Trig5 = 7
const int | JY8902Import::PXI_Trig6 = 8
const int | JY8902Import::PXI_Trig7 = 9
const int | JY8902Import::None = 10
const int | JY8902Import::Rising = 0
const int | JY8902Import::Falling = 1
const int | JY8902Import::_50Hz = 0
const int | JY8902Import::_60Hz = 1
const int | JY8902Import::DC_VOLTAGE_200mV = 1
const int | JY8902Import::DC_VOLTAGE_2V = 2
const int | JY8902Import::DC_VOLTAGE_20V = 3
const int | JY8902Import::DC_VOLTAGE_240V = 4
const int | JY8902Import::DC_CURRENT_20mA = 5
const int | JY8902Import::DC_CURRENT_200mA = 6
const int | JY8902Import::DC_CURRENT_1000mA = 7
const int | JY8902Import::OHM_100 = 8
const int | JY8902Import::OHM_1K = 9
const int | JY8902Import::OHM_10K = 10
const int | JY8902Import::OHM_100K = 11
const int | JY8902Import::OHM_1M = 12
const int | JY8902Import::OHM_10M = 13
const int | JY8902Import::OHM_100M = 14
const int | JY8902Import::OHM_100_4W = 15
const int | JY8902Import::OHM_1K_4W = 16
const int | JY8902Import::OHM_10K_4W = 17
const int | JY8902Import::OHM_100K_4W = 18
const int | JY8902Import::OHM_1M_4W = 19
const int | JY8902Import::OHM_10M_4W = 20
const int | JY8902Import::OHM_100M_4W = 21
const int | JY8902Import::AC_VOLTAGE_200mV = 22
const int | JY8902Import::AC_VOLTAGE_2V = 23
const int | JY8902Import::AC_VOLTAGE_20V = 24
const int | JY8902Import::AC_VOLTAGE_240V = 25
const int | JY8902Import::AC_CURRENT_20mA = 26
const int | JY8902Import::AC_CURRENT_200mA = 27
const int | JY8902Import::AC_CURRENT_1000mA = 28
const int | JY8902Import::JY8902_Signal_MeasureComplete = 10

Macro Definition Documentation

◆ EXTERN_C

#define EXTERN_C extern

Windows.

Linux

◆ JY8902CoreOO_API

#define JY8902CoreOO_API

Enumeration Type Documentation

◆ ACCurrentRange

enum class ACCurrentRange
strong
Enumerator
Auto |
_20mA | 20mA Range
_200mA | 200mA Range
_1000mA | 1000mA Range

◆ ACVoltRange

enum class ACVoltRange
strong
Enumerator
Auto |
_200mV | 200mV range
_2V | 2V range
_20V | 20V range
_240V | 240V range

◆ DCCurrentRange

enum class DCCurrentRange
strong
Enumerator
Auto |
_20mA | 20mA Range
_200mA | 200mA Range
_1000mA | 1000mA Range

◆ DCVoltRange

enum class DCVoltRange
strong
Enumerator
Auto |
_200mV | 200mV range
_2V | 2V range
_20V | 20V range
_240V | 240V range

◆ DigitalTriggerSource

enum class DigitalTriggerSource
strong
Enumerator
PFI0 |
PFI1 |
PXI_Trig0 | PXI_Trig0 as the digital trigger source.
PXI_Trig1 | PXI_Trig1 as the digital trigger source.
PXI_Trig2 | PXI_Trig2 as the digital trigger source.
PXI_Trig3 | PXI_Trig3 as the digital trigger source.
PXI_Trig4 | PXI_Trig4 as the digital trigger source.
PXI_Trig5 | PXI_Trig5 as the digital trigger source.
PXI_Trig6 | PXI_Trig6 as the digital trigger source.
PXI_Trig7 | PXI_Trig7 as the digital trigger source.

◆ MeasurementFunction

enum class MeasurementFunction
strong
Enumerator
DCVolt | Sets the DMM to measure DC voltage.
ACVolt | Sets the DMM to measure AC voltage.
DCCurrent | Sets the DMM to measure DC current.
ACCurrent | Sets the DMM to measure AC current.
Resistance2Wire | Sets the DMM to measure 2-wire resistance.
Resistance4Wire | Sets the DMM to measure 4-wire resistance.

◆ MeasurementTriggerEdge

enum class MeasurementTriggerEdge
strong
Enumerator
Rising | Rising edge.
Falling | Falling edge.

◆ MeaurementMode

enum class MeaurementMode
strong
Enumerator
SinglePoint | SinglePoint Meaurement.
MultiPoint | MultiPoint Meaurement.
ContinuousMultiPoint | ContinuousMultiPoint Meaurement.

◆ PowerLineFrequency

enum class PowerLineFrequency
strong
Enumerator
_50Hz | 50 Hz AC Power Frequency
_60Hz | 60 Hz AC Power Frequency

◆ Resistance2WireRange

enum class Resistance2WireRange
strong
Enumerator
Auto |
_100 | 100Ω Range
_1K | 1KΩ Range
_10K | 10KΩ Range
_100K | 100KΩ Range
_1M | 1MΩ Range
_10M | 10MΩ Range
_100M | 100MΩ Range

◆ Resistance4WireRange

enum class Resistance4WireRange
strong
Enumerator
Auto |
_100 | 100Ω Range
_1K | 1KΩ Range
_10K | 10KΩ Range
_100K | 100KΩ Range
_1M | 1MΩ Range

◆ SamplingType

enum class SamplingType
strong
Enumerator
Aperture | Aperture.
NPLC | NPLC.

◆ SignalExportDestination

enum class SignalExportDestination
strong
Enumerator
None | The measurement complete signal is not routed.
PFI0 | Rout the measurement complete signal to PFI0.
PFI1 | Rout the measurement complete signal to PFI1.
PXI_Trig0 | Rout the measurement complete signal to PXI_Trig0.
PXI_Trig1 | Rout the measurement complete signal to PXI_Trig1.
PXI_Trig2 | Rout the measurement complete signal to PXI_Trig2.
PXI_Trig3 | Rout the measurement complete signal to PXI_Trig3.
PXI_Trig4 | Rout the measurement complete signal to PXI_Trig4.
PXI_Trig5 | Rout the measurement complete signal to PXI_Trig5.
PXI_Trig6 | Rout the measurement complete signal to PXI_Trig6.
PXI_Trig7 | Rout the measurement complete signal to PXI_Trig7.

◆ TriggerOut

enum class TriggerOut
strong
Enumerator
None | The measurement complete signal is not routed.
PFI0 |
PFI1 |
PXI_Trig0 | PXI_Trig0 as the digital trigger source.
PXI_Trig1 | PXI_Trig1 as the digital trigger source.
PXI_Trig2 | PXI_Trig2 as the digital trigger source.
PXI_Trig3 | PXI_Trig3 as the digital trigger source.
PXI_Trig4 | PXI_Trig4 as the digital trigger source.
PXI_Trig5 | PXI_Trig5 as the digital trigger source.
PXI_Trig6 | PXI_Trig6 as the digital trigger source.
PXI_Trig7 | PXI_Trig7 as the digital trigger source.

◆ TriggerType

enum class TriggerType
strong
Enumerator
Immediate | Immediate Trigger.
Software | Software Trigger.
Digital | Digital Trigger.

Function Documentation

◆ GetSignalExportDestinationString()

std::string GetSignalExportDestinationString ( SignalExportDestination destination )
inline


8902 C++ Programming Manual: JY8902CoreOO::JYDriverException Class Reference

  • Class List
  • Class Index
  • Class Members
  • JY8902CoreOO
  • JYDriverException
Public Member Functions | Public Attributes | List of all members
JY8902CoreOO::JYDriverException Class Reference

#include <JY8902CoreOOCommon.h>

Public Member Functions

JYDriverException (JYDriverExceptionPublic exceptionCode, std::string msg="")
JYDriverException (int, std::string msg)

Public Attributes

std::string exceptionMessage
JYDriverExceptionPublic errorCode
JYDriverException * FollowingException

Constructor & Destructor Documentation

◆ JYDriverException() [1/2]

JY8902CoreOO::JYDriverException::JYDriverException | ( | JYDriverExceptionPublic | exceptionCode,
 |  | std::string | msg = "" )

◆ JYDriverException() [2/2]

JY8902CoreOO::JYDriverException::JYDriverException | ( | int | ,
 |  | std::string | msg )

Member Data Documentation

◆ errorCode

JYDriverExceptionPublic JY8902CoreOO::JYDriverException::errorCode

◆ exceptionMessage

std::string JY8902CoreOO::JYDriverException::exceptionMessage

◆ FollowingException

JYDriverException* JY8902CoreOO::JYDriverException::FollowingException
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/8902/JY8902CoreOOCommon.h


8902 C++ Programming Manual: JY8902CoreOO::JY8902CoreOOProperty< ContainerClass, ValueType, propertyType > Class Template Reference

  • JY8902CoreOO
  • JY8902CoreOOProperty
Public Member Functions | List of all members
JY8902CoreOO::JY8902CoreOOProperty< ContainerClass, ValueType, propertyType > Class Template Reference

属性模板类 More...

#include <JY8902CoreOOCommon.h>

Public Member Functions

JY8902CoreOOProperty ()
JY8902CoreOOProperty (ContainerClass *cObject, ValueType(ContainerClass::*pGet)(), void(ContainerClass::*pSet)(ValueType value))
JY8902CoreOOProperty (ValueType(*pGet)(), void(*pSet)(ValueType value))
ValueType operator= (const ValueType &value)
operator ValueType ()

Detailed Description

template<typename ContainerClass, typename ValueType, JY8902CoreOOPropertyType propertyType>
class JY8902CoreOO::JY8902CoreOOProperty< ContainerClass, ValueType, propertyType >

属性模板类

Constructor & Destructor Documentation

◆ JY8902CoreOOProperty() [1/3]

template<typename ContainerClass, typename ValueType, JY8902CoreOOPropertyType propertyType>
JY8902CoreOO::JY8902CoreOOProperty< ContainerClass, ValueType, propertyType >::JY8902CoreOOProperty ( )

◆ JY8902CoreOOProperty() [2/3]

template<typename ContainerClass, typename ValueType, JY8902CoreOOPropertyType propertyType>
JY8902CoreOO::JY8902CoreOOProperty< ContainerClass, ValueType, propertyType >::JY8902CoreOOProperty | ( | ContainerClass * | cObject,
 |  | ValueType(ContainerClass::* | pGet )(),
 |  | void(ContainerClass::* | pSet )(ValueType value) )

◆ JY8902CoreOOProperty() [3/3]

template<typename ContainerClass, typename ValueType, JY8902CoreOOPropertyType propertyType>
JY8902CoreOO::JY8902CoreOOProperty< ContainerClass, ValueType, propertyType >::JY8902CoreOOProperty | ( | ValueType(* | pGet )(),
 |  | void(* | pSet )(ValueType value) )

Member Function Documentation

◆ operator ValueType()

template<typename ContainerClass, typename ValueType, JY8902CoreOOPropertyType propertyType>
JY8902CoreOO::JY8902CoreOOProperty< ContainerClass, ValueType, propertyType >::operator ValueType ( )

◆ operator=()

template<typename ContainerClass, typename ValueType, JY8902CoreOOPropertyType propertyType>
ValueType JY8902CoreOO::JY8902CoreOOProperty< ContainerClass, ValueType, propertyType >::operator= ( const ValueType & value )
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/8902/JY8902CoreOOCommon.h


8902 C++ Programming Manual: TempInfor Struct Reference

Public Attributes | List of all members
TempInfor Struct Reference

tempInfor struct More...

#include <JY8902CoreOOCommon.h>

Public Attributes

double | localTemp
local Temp
double | ch1Temp
ch1 Temp
double | ch2Temp
ch2 Temp
double | ch3Temp
ch3 Temp

Detailed Description

tempInfor struct

Member Data Documentation

◆ ch1Temp

double TempInfor::ch1Temp

ch1 Temp

◆ ch2Temp

double TempInfor::ch2Temp

ch2 Temp

◆ ch3Temp

double TempInfor::ch3Temp

ch3 Temp

◆ localTemp

double TempInfor::localTemp

local Temp

The documentation for this struct was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/8902/JY8902CoreOOCommon.h


8902 C++ Programming Manual: JY8902CoreOO Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Enumerations
JY8902CoreOO Namespace Reference

Classes

class | ACCurrent
class | ACVolt
class | DCCurrent
class | DCVolt
class | DigitalTrigger
class | DMMSignalExport
class | ExternalReferenceClock
External Reference Clcok Terminal. More...
class | JY8902CoreOODevice
class | JY8902CoreOOLog
class | JY8902CoreOOProperty
属性模板类 More...
class | JY8902CoreOOReferenceClock
class | JY8902CoreOOTask
class | JYDriverException
class | MultiPoint
class | Resistance2Wire
class | Resistance4Wire
class | SampleClock
class | Sampling
class | TriggerIn

Enumerations

enum class | JY8902CoreOOPropertyType { READ_ONLY = 1 , WRITE_ONLY = 2 , READ_WRITE = 3 }
enum class JYDriverExceptionPublic {
UnKnown = 0 , OpenDeviceFailed = -10001 , CloseDeviceFailed = -10002 , ResetDeviceFailed = -10003 ,
GetDevicePropertyFailed = -10004 , SetDevicePropertyFailed = -10005 , HardwareResourceIsReserved = -10006 , MethodNotPermitedToCallWhenCurrentStatus = -10007 ,
InvalidUserDataBuffer = -10008 , NoChannelAdded = -10009 , NotSupportOperationForCurrentDevice = -10010 , CreatTaskFailed = -10100 ,
StartTaskFailed = -10101 , StopTaskFailed = -10102 , TaskHasNotStarted = -10103 , TaskHasStartedCannotPerformTheSetOperation = -10104 ,
ChannelNumberParameterInvalid = -10105 , ChannelInputRangeParameterInvalid = -10106 , ChannelTerminalParameterInvalid = -10107 , ChannelCouplingParameterInvalid = -10108 ,
SampeleModeParameterInvalid = -10109 , SampleClockParameterInvalid = -10110 , SampleRateParameterInvalid = -10111 , UpdateRateParameterInvalid = -10112 ,
TriggerParameterInvalid = -10113 , ReferenceTriggerDoesNotMatchWithSampleMode = -10114 , PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint = -10115 , ReadDataFailed = -10016 ,
ReadDataTimeout = -10017 , WriteDataFailed = -10018 , WriteDataTimeout = -10019 , WriteDataLengthCannotBeLessThanN = -10020 ,
BufferDataOverflow = -10021 , BufferDataDownflow = -10022 , CheckBufferFailed = -10023 , PointInvalidInFiniteMode = -10024 ,
ReadPointInvalid = -10025 , OnlySupportRecordMode = -10026 , SendSoftTirggerFailed = -10027 , TaskTimeout = -10028 ,
CounterParametersInvalid = -10029 , WritePointInvalid = -10030 , SignalExportDestinationInvalid = -10031 , InvalidParameter = -10033
}
enum class | ExternalReferenceClockTerminal { PXIe_Clk100 = 0x1 }
enum class | ReferenceClockSource { Internal = 0x0 , External = 0x1 }
enum class JY8902CoreOOLogLevel {
DEBUG_LOG_LEVEL , INFO_LOG_LEVEL , WARN_LOG_LEVEL , ERROR_LOG_LEVEL ,
FATAL_LOG_LEVEL
}
enum class SampleTrigger {
Immediate = -1 , PFI0 = JY8902Import::PFI0 , PFI1 = JY8902Import::PFI1 , PXI_Trig0 = JY8902Import::PXI_Trig0 ,
PXI_Trig1 = JY8902Import::PXI_Trig1 , PXI_Trig2 = JY8902Import::PXI_Trig2 , PXI_Trig3 = JY8902Import::PXI_Trig3 , PXI_Trig4 = JY8902Import::PXI_Trig4 ,
PXI_Trig5 = JY8902Import::PXI_Trig5 , PXI_Trig6 = JY8902Import::PXI_Trig6 , PXI_Trig7 = JY8902Import::PXI_Trig7
}
enum class | SampleClockSource { Internal , External }
enum class | DMMSignalExportSource { MeasureComplete = JY8902Import::JY8902_Signal_MeasureComplete }

Enumeration Type Documentation

◆ DMMSignalExportSource

enum class JY8902CoreOO::DMMSignalExportSource
strong
Enumerator
MeasureComplete

◆ ExternalReferenceClockTerminal

enum class JY8902CoreOO::ExternalReferenceClockTerminal
strong
Enumerator
PXIe_Clk100

PXIe_Clk100.

◆ JY8902CoreOOLogLevel

enum class JY8902CoreOO::JY8902CoreOOLogLevel
strong
Enumerator
DEBUG_LOG_LEVEL
INFO_LOG_LEVEL
WARN_LOG_LEVEL
ERROR_LOG_LEVEL
FATAL_LOG_LEVEL

◆ JY8902CoreOOPropertyType

enum class JY8902CoreOO::JY8902CoreOOPropertyType
strong
Enumerator
READ_ONLY
WRITE_ONLY
READ_WRITE

◆ JYDriverExceptionPublic

enum class JY8902CoreOO::JYDriverExceptionPublic
strong
Enumerator
UnKnown | JYDriverExceptionPublic.
OpenDeviceFailed | JYDriverExceptionPublic.
CloseDeviceFailed | JYDriverExceptionPublic.
ResetDeviceFailed | JYDriverExceptionPublic.
GetDevicePropertyFailed | JYDriverExceptionPublic.
SetDevicePropertyFailed | JYDriverExceptionPublic.
HardwareResourceIsReserved | JYDriverExceptionPublic.
MethodNotPermitedToCallWhenCurrentStatus | JYDriverExceptionPublic.
InvalidUserDataBuffer | JYDriverExceptionPublic.
NoChannelAdded | JYDriverExceptionPublic.
NotSupportOperationForCurrentDevice | JYDriverExceptionPublic.
CreatTaskFailed | JYDriverExceptionPublic.
StartTaskFailed | JYDriverExceptionPublic.
StopTaskFailed | JYDriverExceptionPublic.
TaskHasNotStarted | JYDriverExceptionPublic.
TaskHasStartedCannotPerformTheSetOperation | JYDriverExceptionPublic.
ChannelNumberParameterInvalid | JYDriverExceptionPublic.
ChannelInputRangeParameterInvalid | JYDriverExceptionPublic.
ChannelTerminalParameterInvalid | JYDriverExceptionPublic.
ChannelCouplingParameterInvalid | JYDriverExceptionPublic.
SampeleModeParameterInvalid | JYDriverExceptionPublic.
SampleClockParameterInvalid | JYDriverExceptionPublic.
SampleRateParameterInvalid | JYDriverExceptionPublic.
UpdateRateParameterInvalid | JYDriverExceptionPublic.
TriggerParameterInvalid | JYDriverExceptionPublic.
ReferenceTriggerDoesNotMatchWithSampleMode | JYDriverExceptionPublic.
PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint | JYDriverExceptionPublic.
ReadDataFailed | JYDriverExceptionPublic.
ReadDataTimeout | JYDriverExceptionPublic.
WriteDataFailed | JYDriverExceptionPublic.
WriteDataTimeout | JYDriverExceptionPublic.
WriteDataLengthCannotBeLessThanN | JYDriverExceptionPublic.
BufferDataOverflow | JYDriverExceptionPublic.
BufferDataDownflow | JYDriverExceptionPublic.
CheckBufferFailed | JYDriverExceptionPublic.
PointInvalidInFiniteMode | JYDriverExceptionPublic.
ReadPointInvalid | JYDriverExceptionPublic.
OnlySupportRecordMode | JYDriverExceptionPublic.
SendSoftTirggerFailed | JYDriverExceptionPublic.
TaskTimeout | JYDriverExceptionPublic.
CounterParametersInvalid | JYDriverExceptionPublic.
WritePointInvalid | JYDriverExceptionPublic.
SignalExportDestinationInvalid | JYDriverExceptionPublic.
InvalidParameter | 无效参数。 Invalid parameter.

◆ ReferenceClockSource

enum class JY8902CoreOO::ReferenceClockSource
strong
Enumerator
Internal | Internal on board 25MHz Clock.
External | External Reference Clock Source.

◆ SampleClockSource

enum class JY8902CoreOO::SampleClockSource
strong
Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ SampleTrigger

enum class JY8902CoreOO::SampleTrigger
strong
Enumerator
Immediate |
PFI0 |
PFI1 |
PXI_Trig0 | PXI_Trig0 as the digital trigger source.
PXI_Trig1 | PXI_Trig1 as the digital trigger source.
PXI_Trig2 | PXI_Trig2 as the digital trigger source.
PXI_Trig3 | PXI_Trig3 as the digital trigger source.
PXI_Trig4 | PXI_Trig4 as the digital trigger source.
PXI_Trig5 | PXI_Trig5 as the digital trigger source.
PXI_Trig6 | PXI_Trig6 as the digital trigger source.
PXI_Trig7 | PXI_Trig7 as the digital trigger source.


8902 C++ Programming Manual: JY8902Import Namespace Reference

  • Namespace List
  • Namespace Members
Variables
JY8902Import Namespace Reference

Variables

const int | SinglePoint = 0
const int | MultiPoint = 1
const int | ContinuousMultiPoint = 2
const int | DCVolt = 0
const int | ACVolt = 1
const int | DCCurrent = 2
const int | ACCurrent = 3
const int | Resistance2Wire = 4
const int | Resistance4Wire = 5
const int | Aperture = 0
const int | NPLC = 1
const int | Auto = 0
const int | _200mV = 1
const int | _2V = 2
const int | _20V = 3
const int | _240V = 4
const int | _20mA = 1
const int | _200mA = 2
const int | _1000mA = 3
const int | _100 = 1
const int | _1K = 2
const int | _10K = 3
const int | _100K = 4
const int | _1M = 5
const int | _10M = 6
const int | _100M = 7
const int | Immediate = 0
const int | Software = 1
const int | Digital = 2
const int | PFI0 = 0
const int | PFI1 = 1
const int | PXI_Trig0 = 2
const int | PXI_Trig1 = 3
const int | PXI_Trig2 = 4
const int | PXI_Trig3 = 5
const int | PXI_Trig4 = 6
const int | PXI_Trig5 = 7
const int | PXI_Trig6 = 8
const int | PXI_Trig7 = 9
const int | None = 10
const int | Rising = 0
const int | Falling = 1
const int | _50Hz = 0
const int | _60Hz = 1
const int | DC_VOLTAGE_200mV = 1
const int | DC_VOLTAGE_2V = 2
const int | DC_VOLTAGE_20V = 3
const int | DC_VOLTAGE_240V = 4
const int | DC_CURRENT_20mA = 5
const int | DC_CURRENT_200mA = 6
const int | DC_CURRENT_1000mA = 7
const int | OHM_100 = 8
const int | OHM_1K = 9
const int | OHM_10K = 10
const int | OHM_100K = 11
const int | OHM_1M = 12
const int | OHM_10M = 13
const int | OHM_100M = 14
const int | OHM_100_4W = 15
const int | OHM_1K_4W = 16
const int | OHM_10K_4W = 17
const int | OHM_100K_4W = 18
const int | OHM_1M_4W = 19
const int | OHM_10M_4W = 20
const int | OHM_100M_4W = 21
const int | AC_VOLTAGE_200mV = 22
const int | AC_VOLTAGE_2V = 23
const int | AC_VOLTAGE_20V = 24
const int | AC_VOLTAGE_240V = 25
const int | AC_CURRENT_20mA = 26
const int | AC_CURRENT_200mA = 27
const int | AC_CURRENT_1000mA = 28
const int | JY8902_Signal_MeasureComplete = 10

Variable Documentation

◆ _100

const int JY8902Import::_100 = 1

◆ _1000mA

const int JY8902Import::_1000mA = 3

◆ _100K

const int JY8902Import::_100K = 4

◆ _100M

const int JY8902Import::_100M = 7

◆ _10K

const int JY8902Import::_10K = 3

◆ _10M

const int JY8902Import::_10M = 6

◆ _1K

const int JY8902Import::_1K = 2

◆ _1M

const int JY8902Import::_1M = 5

◆ _200mA

const int JY8902Import::_200mA = 2

◆ _200mV

const int JY8902Import::_200mV = 1

◆ _20mA

const int JY8902Import::_20mA = 1

◆ _20V

const int JY8902Import::_20V = 3

◆ _240V

const int JY8902Import::_240V = 4

◆ _2V

const int JY8902Import::_2V = 2

◆ _50Hz

const int JY8902Import::_50Hz = 0

◆ _60Hz

const int JY8902Import::_60Hz = 1

◆ AC_CURRENT_1000mA

const int JY8902Import::AC_CURRENT_1000mA = 28

◆ AC_CURRENT_200mA

const int JY8902Import::AC_CURRENT_200mA = 27

◆ AC_CURRENT_20mA

const int JY8902Import::AC_CURRENT_20mA = 26

◆ AC_VOLTAGE_200mV

const int JY8902Import::AC_VOLTAGE_200mV = 22

◆ AC_VOLTAGE_20V

const int JY8902Import::AC_VOLTAGE_20V = 24

◆ AC_VOLTAGE_240V

const int JY8902Import::AC_VOLTAGE_240V = 25

◆ AC_VOLTAGE_2V

const int JY8902Import::AC_VOLTAGE_2V = 23

◆ ACCurrent

const int JY8902Import::ACCurrent = 3

◆ ACVolt

const int JY8902Import::ACVolt = 1

◆ Aperture

const int JY8902Import::Aperture = 0

◆ Auto

const int JY8902Import::Auto = 0

◆ ContinuousMultiPoint

const int JY8902Import::ContinuousMultiPoint = 2

◆ DC_CURRENT_1000mA

const int JY8902Import::DC_CURRENT_1000mA = 7

◆ DC_CURRENT_200mA

const int JY8902Import::DC_CURRENT_200mA = 6

◆ DC_CURRENT_20mA

const int JY8902Import::DC_CURRENT_20mA = 5

◆ DC_VOLTAGE_200mV

const int JY8902Import::DC_VOLTAGE_200mV = 1

◆ DC_VOLTAGE_20V

const int JY8902Import::DC_VOLTAGE_20V = 3

◆ DC_VOLTAGE_240V

const int JY8902Import::DC_VOLTAGE_240V = 4

◆ DC_VOLTAGE_2V

const int JY8902Import::DC_VOLTAGE_2V = 2

◆ DCCurrent

const int JY8902Import::DCCurrent = 2

◆ DCVolt

const int JY8902Import::DCVolt = 0

◆ Digital

const int JY8902Import::Digital = 2

◆ Falling

const int JY8902Import::Falling = 1

◆ Immediate

const int JY8902Import::Immediate = 0

◆ JY8902_Signal_MeasureComplete

const int JY8902Import::JY8902_Signal_MeasureComplete = 10

◆ MultiPoint

const int JY8902Import::MultiPoint = 1

◆ None

const int JY8902Import::None = 10

◆ NPLC

const int JY8902Import::NPLC = 1

◆ OHM_100

const int JY8902Import::OHM_100 = 8

◆ OHM_100_4W

const int JY8902Import::OHM_100_4W = 15

◆ OHM_100K

const int JY8902Import::OHM_100K = 11

◆ OHM_100K_4W

const int JY8902Import::OHM_100K_4W = 18

◆ OHM_100M

const int JY8902Import::OHM_100M = 14

◆ OHM_100M_4W

const int JY8902Import::OHM_100M_4W = 21

◆ OHM_10K

const int JY8902Import::OHM_10K = 10

◆ OHM_10K_4W

const int JY8902Import::OHM_10K_4W = 17

◆ OHM_10M

const int JY8902Import::OHM_10M = 13

◆ OHM_10M_4W

const int JY8902Import::OHM_10M_4W = 20

◆ OHM_1K

const int JY8902Import::OHM_1K = 9

◆ OHM_1K_4W

const int JY8902Import::OHM_1K_4W = 16

◆ OHM_1M

const int JY8902Import::OHM_1M = 12

◆ OHM_1M_4W

const int JY8902Import::OHM_1M_4W = 19

◆ PFI0

const int JY8902Import::PFI0 = 0

◆ PFI1

const int JY8902Import::PFI1 = 1

◆ PXI_Trig0

const int JY8902Import::PXI_Trig0 = 2

◆ PXI_Trig1

const int JY8902Import::PXI_Trig1 = 3

◆ PXI_Trig2

const int JY8902Import::PXI_Trig2 = 4

◆ PXI_Trig3

const int JY8902Import::PXI_Trig3 = 5

◆ PXI_Trig4

const int JY8902Import::PXI_Trig4 = 6

◆ PXI_Trig5

const int JY8902Import::PXI_Trig5 = 7

◆ PXI_Trig6

const int JY8902Import::PXI_Trig6 = 8

◆ PXI_Trig7

const int JY8902Import::PXI_Trig7 = 9

◆ Resistance2Wire

const int JY8902Import::Resistance2Wire = 4

◆ Resistance4Wire

const int JY8902Import::Resistance4Wire = 5

◆ Rising

const int JY8902Import::Rising = 0

◆ SinglePoint

const int JY8902Import::SinglePoint = 0

◆ Software

const int JY8902Import::Software = 1


8902 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/8902/JY8902CoreOODevice.h File Reference

  • File List
  • File Members
  • COO
  • 8902
Classes | Namespaces | Enumerations
JY8902CoreOODevice.h File Reference
#include <iostream>
#include <list>
#include <vector>
#include "JY8902CoreOOCommon.h"

Classes

class | JY8902CoreOO::JY8902CoreOODevice
class | JY8902CoreOO::ExternalReferenceClock
External Reference Clcok Terminal. More...
class | JY8902CoreOO::JY8902CoreOOReferenceClock

Namespaces

namespace JY8902CoreOO

Enumerations

enum class | JY8902CoreOO::ExternalReferenceClockTerminal { JY8902CoreOO::PXIe_Clk100 = 0x1 }
enum class | JY8902CoreOO::ReferenceClockSource { JY8902CoreOO::Internal = 0x0 , JY8902CoreOO::External = 0x1 }


8902 C++ Programming Manual: JY8902CoreOO::JY8902CoreOODevice Class Reference

  • JY8902CoreOODevice
Static Public Member Functions | Public Attributes | List of all members
JY8902CoreOO::JY8902CoreOODevice Class Reference

#include <JY8902CoreOODevice.h>

Static Public Member Functions

static JY8902CoreOODevice * | GetInstance (int cardNum)
The operation instance is obtained according to the board number to ensure that there is only one registered instance for each board.
static JY8902CoreOODevice * | GetInstance (std::string aliasName)
The operation instance is obtained according to aliasName to ensure that there is only one registration instance for each board.

Public Attributes

const double | BoardClockRate = 100000000
Board Clock Rate.
uint32_t | DMMBufferSize = 0x100000 * 128
Buffer Size.
const bool | IsSync = true
int | _deviceID = 0x8902
JY8902CoreOOProperty< JY8902CoreOODevice, double, JY8902CoreOOPropertyType::READ_ONLY > | MaxSampleRate
JY8902CoreOOProperty< JY8902CoreOODevice, std::string, JY8902CoreOOPropertyType::READ_ONLY > | SerialNumber
JY8902CoreOOProperty< JY8902CoreOODevice, int, JY8902CoreOOPropertyType::READ_ONLY > | DeviceID
JY8902CoreOOProperty< JY8902CoreOODevice, void *, JY8902CoreOOPropertyType::READ_ONLY > | Handle
JY8902CoreOOReferenceClock * ReferenceClock
Reference Clock Configuration.

Member Function Documentation

◆ GetInstance() [1/2]

static JY8902CoreOODevice * JY8902CoreOO::JY8902CoreOODevice::GetInstance ( int cardNum )
static

The operation instance is obtained according to the board number to ensure that there is only one registered instance for each board.

Parameters
cardNum
Returns

◆ GetInstance() [2/2]

static JY8902CoreOODevice * JY8902CoreOO::JY8902CoreOODevice::GetInstance ( std::string aliasName )
static

The operation instance is obtained according to aliasName to ensure that there is only one registration instance for each board.

Parameters
aliasName
Returns

Member Data Documentation

◆ _deviceID

int JY8902CoreOO::JY8902CoreOODevice::_deviceID = 0x8902

◆ BoardClockRate

const double JY8902CoreOO::JY8902CoreOODevice::BoardClockRate = 100000000

Board Clock Rate.

◆ DeviceID

JY8902CoreOOProperty<JY8902CoreOODevice, int, JY8902CoreOOPropertyType::READ_ONLY> JY8902CoreOO::JY8902CoreOODevice::DeviceID

◆ DMMBufferSize

uint32_t JY8902CoreOO::JY8902CoreOODevice::DMMBufferSize = 0x100000 * 128

Buffer Size.

◆ Handle

JY8902CoreOOProperty<JY8902CoreOODevice, void*, JY8902CoreOOPropertyType::READ_ONLY> JY8902CoreOO::JY8902CoreOODevice::Handle

◆ IsSync

const bool JY8902CoreOO::JY8902CoreOODevice::IsSync = true

◆ MaxSampleRate

JY8902CoreOOProperty<JY8902CoreOODevice, double, JY8902CoreOOPropertyType::READ_ONLY> JY8902CoreOO::JY8902CoreOODevice::MaxSampleRate

◆ ReferenceClock

JY8902CoreOOReferenceClock* JY8902CoreOO::JY8902CoreOODevice::ReferenceClock

Reference Clock Configuration.

◆ SerialNumber

JY8902CoreOOProperty<JY8902CoreOODevice, std::string, JY8902CoreOOPropertyType::READ_ONLY> JY8902CoreOO::JY8902CoreOODevice::SerialNumber
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/8902/JY8902CoreOODevice.h


8902 C++ Programming Manual: JY8902CoreOO::ExternalReferenceClock Class Reference

  • ExternalReferenceClock
Public Attributes | List of all members
JY8902CoreOO::ExternalReferenceClock Class Reference

External Reference Clcok Terminal. More...

#include <JY8902CoreOODevice.h>

Public Attributes

ExternalReferenceClockTerminal Terminal

Detailed Description

External Reference Clcok Terminal.

Member Data Documentation

◆ Terminal

ExternalReferenceClockTerminal JY8902CoreOO::ExternalReferenceClock::Terminal
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/8902/JY8902CoreOODevice.h


8902 C++ Programming Manual: JY8902CoreOO::JY8902CoreOOReferenceClock Class Reference

  • JY8902CoreOOReferenceClock
Public Member Functions | Public Attributes | List of all members
JY8902CoreOO::JY8902CoreOOReferenceClock Class Reference

#include <JY8902CoreOODevice.h>

Public Member Functions

void Commit ()
Commit configuration.

Public Attributes

ReferenceClockSource Source
ExternalReferenceClock * External
External Reference Clock Source.

Member Function Documentation

◆ Commit()

void JY8902CoreOO::JY8902CoreOOReferenceClock::Commit ( )

Commit configuration.

Available only when the device is idle. WARNING: Incorrect parameters will cause the PLL to be unable to lock the reference clock and cannot be recovered until shutdown and restart.

Member Data Documentation

◆ External

ExternalReferenceClock* JY8902CoreOO::JY8902CoreOOReferenceClock::External

External Reference Clock Source.

Required when ReferenceClock.Source is ReferenceClockSource.External

◆ Source

ReferenceClockSource JY8902CoreOO::JY8902CoreOOReferenceClock::Source
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/8902/JY8902CoreOODevice.h


8902 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/8902/JY8902CoreOOLog.h File Reference

  • File List
  • File Members
  • COO
  • 8902
Classes | Namespaces | Enumerations
JY8902CoreOOLog.h File Reference
#include <queue>
#include <thread>
#include "JY8902CoreOOCommon.h"

Classes

class JY8902CoreOO::JY8902CoreOOLog

Namespaces

namespace JY8902CoreOO

Enumerations

enum class JY8902CoreOO::JY8902CoreOOLogLevel {
JY8902CoreOO::DEBUG_LOG_LEVEL , JY8902CoreOO::INFO_LOG_LEVEL , JY8902CoreOO::WARN_LOG_LEVEL , JY8902CoreOO::ERROR_LOG_LEVEL ,
JY8902CoreOO::FATAL_LOG_LEVEL
}


8902 C++ Programming Manual: JY8902CoreOO::JY8902CoreOOLog Class Reference

  • JY8902CoreOOLog
Static Public Member Functions | Static Public Attributes | List of all members
JY8902CoreOO::JY8902CoreOOLog Class Reference

#include <JY8902CoreOOLog.h>

Static Public Member Functions

static void | Print (const char *format,...)
static void | Print (JY8902CoreOOLogLevel logLevel, const char *format,...)
static void | Flush ()

Static Public Attributes

static JY8902CoreOOLogLevel | LogLevel
static JY8902CoreOOProperty< JY8902CoreOOLog, bool, JY8902CoreOOPropertyType::READ_WRITE > | EnableLog

Member Function Documentation

◆ Flush()

static void JY8902CoreOO::JY8902CoreOOLog::Flush ( )
static

◆ Print() [1/2]

static void JY8902CoreOO::JY8902CoreOOLog::Print | ( | const char * | format,
 |  |  | ... )
 static

◆ Print() [2/2]

static void JY8902CoreOO::JY8902CoreOOLog::Print | ( | JY8902CoreOOLogLevel | logLevel,
 |  | const char * | format,
 |  |  | ... )
 static

Member Data Documentation

◆ EnableLog

JY8902CoreOOProperty<JY8902CoreOOLog, bool, JY8902CoreOOPropertyType::READ_WRITE> JY8902CoreOO::JY8902CoreOOLog::EnableLog
static

◆ LogLevel

JY8902CoreOOLogLevel JY8902CoreOO::JY8902CoreOOLog::LogLevel
static
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/8902/JY8902CoreOOLog.h


8902 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/8902/jy8902coreootask.h File Reference

  • File List
  • File Members
  • COO
  • 8902
Classes | Namespaces | Macros | Enumerations
jy8902coreootask.h File Reference
#include <memory>
#include <mutex>
#include <map>
#include <fstream>
#include <thread>
#include <cstring>
#include <cstddef>
#include "JY8902CoreOOCommon.h"
#include "JY8902CoreOODevice.h"

Classes

class | JY8902CoreOO::JY8902CoreOOTask
class | JY8902CoreOO::DCVolt
class | JY8902CoreOO::Resistance2Wire
class | JY8902CoreOO::Resistance4Wire
class | JY8902CoreOO::ACVolt
class | JY8902CoreOO::DCCurrent
class | JY8902CoreOO::ACCurrent
class | JY8902CoreOO::DigitalTrigger
class | JY8902CoreOO::TriggerIn
class | JY8902CoreOO::MultiPoint
class | JY8902CoreOO::Sampling
class | JY8902CoreOO::SampleClock
class | JY8902CoreOO::DMMSignalExport

Namespaces

namespace JY8902CoreOO

Macros

#define _CRT_SECURE_NO_WARNINGS

Enumerations

enum class JY8902CoreOO::SampleTrigger {
JY8902CoreOO::Immediate = -1 , JY8902CoreOO::PFI0 = JY8902Import::PFI0 , JY8902CoreOO::PFI1 = JY8902Import::PFI1 , JY8902CoreOO::PXI_Trig0 = JY8902Import::PXI_Trig0 ,
JY8902CoreOO::PXI_Trig1 = JY8902Import::PXI_Trig1 , JY8902CoreOO::PXI_Trig2 = JY8902Import::PXI_Trig2 , JY8902CoreOO::PXI_Trig3 = JY8902Import::PXI_Trig3 , JY8902CoreOO::PXI_Trig4 = JY8902Import::PXI_Trig4 ,
JY8902CoreOO::PXI_Trig5 = JY8902Import::PXI_Trig5 , JY8902CoreOO::PXI_Trig6 = JY8902Import::PXI_Trig6 , JY8902CoreOO::PXI_Trig7 = JY8902Import::PXI_Trig7
}
enum class | JY8902CoreOO::SampleClockSource { JY8902CoreOO::Internal , JY8902CoreOO::External }
enum class | JY8902CoreOO::DMMSignalExportSource { JY8902CoreOO::MeasureComplete = JY8902Import::JY8902_Signal_MeasureComplete }

Macro Definition Documentation

◆ _CRT_SECURE_NO_WARNINGS

#define _CRT_SECURE_NO_WARNINGS


8902 C++ Programming Manual: JY8902CoreOO::JY8902CoreOOTask Class Reference

  • JY8902CoreOOTask
Public Member Functions | Public Attributes | List of all members
JY8902CoreOO::JY8902CoreOOTask Class Reference

#include <jy8902coreootask.h>

Public Member Functions

JY8902CoreOOTask (std::string deviceName)
Constructor, Used to create an DMM task by the deviceName.
JY8902CoreOOTask (std::string deviceName, MeasurementFunction function, PowerLineFrequency powerLineFrequency)
Constructor,Used to create an DMM task by the deviceName.
JY8902CoreOOTask (int slot)
Constructor, Used to create an DMM task by a slot number.
JY8902CoreOOTask (int slot, MeasurementFunction function, PowerLineFrequency powerLineFrequency)
Constructor, Used to create an DMM task by a slot number.
void | ReadSinglePoint (double &measureValue, int timeout=10000)
Read one measurement value .
void | ReadRawSinglePoint (double &measureValue, int timeout=10000)
Read one raw measurement voltage value .
void | ReadMultiPoint (double *measureValues, unsigned int numToRead=1, int timeout=-1)
Read multi measurement values.
void | ReadPoint (double *measureValues, unsigned int numToRead=1, int timeout=-1)
void | ReadRawMultiPoint (int *measureValues, unsigned int numToRead=1, int timeout=-1)
void | Start ()
Start measurement.
void | SendSoftwareTrigger ()
Send software trigger.
void | Stop ()
Stop measurement.
JY8902CoreOOTask ()
~JY8902CoreOOTask ()
deconstructor function

Public Attributes

JY8902CoreOOProperty< JY8902CoreOOTask, int, JY8902CoreOOPropertyType::READ_ONLY > | BufLenInSamples
Sample rate per channel.
JY8902CoreOOProperty< JY8902CoreOOTask, uint64_t, JY8902CoreOOPropertyType::READ_ONLY > | AvailableSamples
Number of samples per channel that can be read in the buffer .
JY8902CoreOOProperty< JY8902CoreOOTask, uint64_t, JY8902CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
JY8902CoreOODevice * Device
bool | DisableCalibration
Sampling * _Sampling
MeaurementMode Mode
MeasurementFunction Function
DCVolt * _DCVolt
ACVolt * _ACVolt
DCCurrent * _DCCurrent
ACCurrent * _ACCurrent
Resistance2Wire * _Resistance2Wire
Resistance4Wire * _Resistance4Wire
PowerLineFrequency Frequency
TriggerIn * _trigger
MultiPoint * _multiPoint
bool | IsOverRange
SampleClock * _SampleClock
DMMSignalExport * _DMMSignalExport
TriggerOut _TriggerOut

Constructor & Destructor Documentation

◆ JY8902CoreOOTask() [1/5]

JY8902CoreOO::JY8902CoreOOTask::JY8902CoreOOTask ( std::string deviceName )

Constructor, Used to create an DMM task by the deviceName.

Parameters
deviceName device name

◆ JY8902CoreOOTask() [2/5]

JY8902CoreOO::JY8902CoreOOTask::JY8902CoreOOTask | ( | std::string | deviceName,
 |  | MeasurementFunction | function,
 |  | PowerLineFrequency | powerLineFrequency )

Constructor,Used to create an DMM task by the deviceName.

Parameters
deviceName | device name
function | measurement function. default is DCVolt
powerLineFrequency | powerLineFreqency,default is 50Hz

◆ JY8902CoreOOTask() [3/5]

JY8902CoreOO::JY8902CoreOOTask::JY8902CoreOOTask ( int slot )

Constructor, Used to create an DMM task by a slot number.

Parameters
slot slot number

◆ JY8902CoreOOTask() [4/5]

JY8902CoreOO::JY8902CoreOOTask::JY8902CoreOOTask | ( | int | slot,
 |  | MeasurementFunction | function,
 |  | PowerLineFrequency | powerLineFrequency )

Constructor, Used to create an DMM task by a slot number.

Parameters
slot | slot number
function | measurement function. default is DCVolt
powerLineFrequency | powerLineFreqency,default is 50Hz

◆ JY8902CoreOOTask() [5/5]

JY8902CoreOO::JY8902CoreOOTask::JY8902CoreOOTask ( )

◆ ~JY8902CoreOOTask()

JY8902CoreOO::JY8902CoreOOTask::~JY8902CoreOOTask ( )

deconstructor function

Member Function Documentation

◆ ReadMultiPoint()

void JY8902CoreOO::JY8902CoreOOTask::ReadMultiPoint | ( | double * | measureValues,
 |  | unsigned int | numToRead = 1,
 |  | int | timeout = -1 )

Read multi measurement values.

Available when Mode Not is MeasurementMode.SinglePoint

Parameters
measureValues | measure values buffer
numToRead | number to read
timeout | The maximum time allowed for the measurement to complete in milliseconds

◆ ReadPoint()

void JY8902CoreOO::JY8902CoreOOTask::ReadPoint | ( | double * | measureValues,
 |  | unsigned int | numToRead = 1,
 |  | int | timeout = -1 )

◆ ReadRawMultiPoint()

void JY8902CoreOO::JY8902CoreOOTask::ReadRawMultiPoint | ( | int * | measureValues,
 |  | unsigned int | numToRead = 1,
 |  | int | timeout = -1 )
Parameters
measureValues
numToRead
timeout

◆ ReadRawSinglePoint()

void JY8902CoreOO::JY8902CoreOOTask::ReadRawSinglePoint | ( | double & | measureValue,
 |  | int | timeout = 10000 )

Read one raw measurement voltage value .

Available when Mode is MeasurementMode.SinglePoint

Parameters
measureValue | measureValue
timeout | The maximum time allowed for the measurement to complete in milliseconds

◆ ReadSinglePoint()

void JY8902CoreOO::JY8902CoreOOTask::ReadSinglePoint | ( | double & | measureValue,
 |  | int | timeout = 10000 )

Read one measurement value .

Available when Mode is MeasurementMode.SinglePoint

Parameters
measureValue | measureValue
timeout | The maximum time allowed for the measurement to complete in milliseconds

◆ SendSoftwareTrigger()

void JY8902CoreOO::JY8902CoreOOTask::SendSoftwareTrigger ( )

Send software trigger.

◆ Start()

void JY8902CoreOO::JY8902CoreOOTask::Start ( )

Start measurement.

◆ Stop()

void JY8902CoreOO::JY8902CoreOOTask::Stop ( )

Stop measurement.

Member Data Documentation

◆ _ACCurrent

ACCurrent* JY8902CoreOO::JY8902CoreOOTask::_ACCurrent

◆ _ACVolt

ACVolt* JY8902CoreOO::JY8902CoreOOTask::_ACVolt

◆ _DCCurrent

DCCurrent* JY8902CoreOO::JY8902CoreOOTask::_DCCurrent

◆ _DCVolt

DCVolt* JY8902CoreOO::JY8902CoreOOTask::_DCVolt

◆ _DMMSignalExport

DMMSignalExport* JY8902CoreOO::JY8902CoreOOTask::_DMMSignalExport

◆ _multiPoint

MultiPoint* JY8902CoreOO::JY8902CoreOOTask::_multiPoint

◆ _Resistance2Wire

Resistance2Wire* JY8902CoreOO::JY8902CoreOOTask::_Resistance2Wire

◆ _Resistance4Wire

Resistance4Wire* JY8902CoreOO::JY8902CoreOOTask::_Resistance4Wire

◆ _SampleClock

SampleClock* JY8902CoreOO::JY8902CoreOOTask::_SampleClock

◆ _Sampling

Sampling* JY8902CoreOO::JY8902CoreOOTask::_Sampling

◆ _trigger

TriggerIn* JY8902CoreOO::JY8902CoreOOTask::_trigger

◆ _TriggerOut

TriggerOut JY8902CoreOO::JY8902CoreOOTask::_TriggerOut

◆ AvailableSamples

JY8902CoreOOProperty<JY8902CoreOOTask, uint64_t, JY8902CoreOOPropertyType::READ_ONLY> JY8902CoreOO::JY8902CoreOOTask::AvailableSamples

Number of samples per channel that can be read in the buffer .

Valid when Mode is NOT AIMode.Single.

◆ BufLenInSamples

JY8902CoreOOProperty<JY8902CoreOOTask, int, JY8902CoreOOPropertyType::READ_ONLY> JY8902CoreOO::JY8902CoreOOTask::BufLenInSamples

Sample rate per channel.

Maximum sample rate:5323 5324 is 200k,5321 5322 is 1M The defalut sample rate = 1M You can read this property to obtain the sample rate that will actually take effect in the current configuration.

Exceptions
JYDriverException Number of samples per channel can be storage in the buffer, the Property SamplesToAcquire must be less than or equal to this value. *

◆ Device

JY8902CoreOODevice* JY8902CoreOO::JY8902CoreOOTask::Device

◆ DisableCalibration

bool JY8902CoreOO::JY8902CoreOOTask::DisableCalibration

◆ Frequency

PowerLineFrequency JY8902CoreOO::JY8902CoreOOTask::Frequency

◆ Function

MeasurementFunction JY8902CoreOO::JY8902CoreOOTask::Function

◆ IsOverRange

bool JY8902CoreOO::JY8902CoreOOTask::IsOverRange

◆ Mode

MeaurementMode JY8902CoreOO::JY8902CoreOOTask::Mode

◆ TransferedSamples

JY8902CoreOOProperty<JY8902CoreOOTask, uint64_t, JY8902CoreOOPropertyType::READ_ONLY> JY8902CoreOO::JY8902CoreOOTask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT AIMode.Single.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/8902/jy8902coreootask.h


8902 C++ Programming Manual: JY8902CoreOO::DCVolt Class Reference

  • DCVolt
Public Member Functions | Public Attributes | List of all members
JY8902CoreOO::DCVolt Class Reference

#include <jy8902coreootask.h>

Public Member Functions

DCVolt ()

Public Attributes

DCVoltRange Range
DC Volt Range.

Constructor & Destructor Documentation

◆ DCVolt()

JY8902CoreOO::DCVolt::DCVolt ( )

Member Data Documentation

◆ Range

DCVoltRange JY8902CoreOO::DCVolt::Range

DC Volt Range.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/8902/jy8902coreootask.h


8902 C++ Programming Manual: JY8902CoreOO::Resistance2Wire Class Reference

  • Resistance2Wire
Public Member Functions | Public Attributes | List of all members
JY8902CoreOO::Resistance2Wire Class Reference

#include <jy8902coreootask.h>

Public Member Functions

Resistance2Wire ()

Public Attributes

Resistance2WireRange Range
DC Volt Range.

Constructor & Destructor Documentation

◆ Resistance2Wire()

JY8902CoreOO::Resistance2Wire::Resistance2Wire ( )

Member Data Documentation

◆ Range

Resistance2WireRange JY8902CoreOO::Resistance2Wire::Range

DC Volt Range.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/8902/jy8902coreootask.h


8902 C++ Programming Manual: JY8902CoreOO::Resistance4Wire Class Reference

  • Resistance4Wire
Public Member Functions | Public Attributes | List of all members
JY8902CoreOO::Resistance4Wire Class Reference

#include <jy8902coreootask.h>

Public Member Functions

Resistance4Wire ()

Public Attributes

Resistance4WireRange Range
DC Volt Range.

Constructor & Destructor Documentation

◆ Resistance4Wire()

JY8902CoreOO::Resistance4Wire::Resistance4Wire ( )

Member Data Documentation

◆ Range

Resistance4WireRange JY8902CoreOO::Resistance4Wire::Range

DC Volt Range.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/8902/jy8902coreootask.h


8902 C++ Programming Manual: JY8902CoreOO::ACVolt Class Reference

  • ACVolt
Public Member Functions | Public Attributes | List of all members
JY8902CoreOO::ACVolt Class Reference

#include <jy8902coreootask.h>

Public Member Functions

ACVolt ()

Public Attributes

ACVoltRange Range
DC Volt Range.

Constructor & Destructor Documentation

◆ ACVolt()

JY8902CoreOO::ACVolt::ACVolt ( )

Member Data Documentation

◆ Range

ACVoltRange JY8902CoreOO::ACVolt::Range

DC Volt Range.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/8902/jy8902coreootask.h


8902 C++ Programming Manual: JY8902CoreOO::DCCurrent Class Reference

  • DCCurrent
Public Member Functions | Public Attributes | List of all members
JY8902CoreOO::DCCurrent Class Reference

#include <jy8902coreootask.h>

Public Member Functions

DCCurrent ()

Public Attributes

DCCurrentRange Range
DC Volt Range.

Constructor & Destructor Documentation

◆ DCCurrent()

JY8902CoreOO::DCCurrent::DCCurrent ( )

Member Data Documentation

◆ Range

DCCurrentRange JY8902CoreOO::DCCurrent::Range

DC Volt Range.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/8902/jy8902coreootask.h


8902 C++ Programming Manual: JY8902CoreOO::ACCurrent Class Reference

  • ACCurrent
Public Member Functions | Public Attributes | List of all members
JY8902CoreOO::ACCurrent Class Reference

#include <jy8902coreootask.h>

Public Member Functions

ACCurrent ()

Public Attributes

ACCurrentRange Range
DC Volt Range.

Constructor & Destructor Documentation

◆ ACCurrent()

JY8902CoreOO::ACCurrent::ACCurrent ( )

Member Data Documentation

◆ Range

ACCurrentRange JY8902CoreOO::ACCurrent::Range

DC Volt Range.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/8902/jy8902coreootask.h


8902 C++ Programming Manual: JY8902CoreOO::DigitalTrigger Class Reference

  • DigitalTrigger
Public Attributes | List of all members
JY8902CoreOO::DigitalTrigger Class Reference

#include <jy8902coreootask.h>

Public Attributes

DigitalTriggerSource Source
Digital Trigger source.
MeasurementTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Member Data Documentation

◆ Edge

MeasurementTriggerEdge JY8902CoreOO::DigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

DigitalTriggerSource JY8902CoreOO::DigitalTrigger::Source

Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/8902/jy8902coreootask.h


8902 C++ Programming Manual: JY8902CoreOO::TriggerIn Class Reference

  • TriggerIn
Public Attributes | List of all members
JY8902CoreOO::TriggerIn Class Reference

#include <jy8902coreootask.h>

Public Attributes

TriggerType Type
Trigger type.
DigitalTrigger * Digital
Digital Trigger Congfiguration.
double Delay
Trigger Delay.

Member Data Documentation

◆ Delay

double JY8902CoreOO::TriggerIn::Delay

Trigger Delay.

◆ Digital

DigitalTrigger* JY8902CoreOO::TriggerIn::Digital

Digital Trigger Congfiguration.

Valid when Type is AITriggerType.Digital.

◆ Type

TriggerType JY8902CoreOO::TriggerIn::Type

Trigger type.

enum Digital/Immediate/Soft. The default value is TriggerType.Immediate.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/8902/jy8902coreootask.h


8902 C++ Programming Manual: JY8902CoreOO::MultiPoint Class Reference

  • MultiPoint
Public Attributes | List of all members
JY8902CoreOO::MultiPoint Class Reference

#include <jy8902coreootask.h>

Public Attributes

int | SampleCount
double | SampleInterval
SampleTrigger _SampleTrigger

Member Data Documentation

◆ _SampleTrigger

SampleTrigger JY8902CoreOO::MultiPoint::_SampleTrigger

◆ SampleCount

int JY8902CoreOO::MultiPoint::SampleCount

◆ SampleInterval

double JY8902CoreOO::MultiPoint::SampleInterval
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/8902/jy8902coreootask.h


8902 C++ Programming Manual: JY8902CoreOO::Sampling Class Reference

  • Sampling
Public Member Functions | Public Attributes | List of all members
JY8902CoreOO::Sampling Class Reference

#include <jy8902coreootask.h>

Public Member Functions

Sampling ()

Public Attributes

JY8902CoreOOProperty< Sampling, SamplingType, JY8902CoreOOPropertyType::READ_WRITE > Type
JY8902CoreOOProperty< Sampling, double, JY8902CoreOOPropertyType::READ_WRITE > | Aperture
JY8902CoreOOProperty< Sampling, double, JY8902CoreOOPropertyType::READ_WRITE > | NPLC

Constructor & Destructor Documentation

◆ Sampling()

JY8902CoreOO::Sampling::Sampling ( )

Member Data Documentation

◆ Aperture

JY8902CoreOOProperty<Sampling, double, JY8902CoreOOPropertyType::READ_WRITE> JY8902CoreOO::Sampling::Aperture

◆ NPLC

JY8902CoreOOProperty<Sampling, double, JY8902CoreOOPropertyType::READ_WRITE> JY8902CoreOO::Sampling::NPLC

◆ Type

JY8902CoreOOProperty<Sampling, SamplingType, JY8902CoreOOPropertyType::READ_WRITE> JY8902CoreOO::Sampling::Type
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/8902/jy8902coreootask.h


8902 C++ Programming Manual: JY8902CoreOO::SampleClock Class Reference

  • SampleClock
Public Attributes | List of all members
JY8902CoreOO::SampleClock Class Reference

#include <jy8902coreootask.h>

Public Attributes

SampleClockSource Source
AI Sample Clock Source.

Member Data Documentation

◆ Source

SampleClockSource JY8902CoreOO::SampleClock::Source

AI Sample Clock Source.

enum Internal/External. The default value is AISampleClockSource.Internal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/8902/jy8902coreootask.h


8902 C++ Programming Manual: JY8902CoreOO::DMMSignalExport Class Reference

  • DMMSignalExport
Public Member Functions | List of all members
JY8902CoreOO::DMMSignalExport Class Reference

#include <jy8902coreootask.h>

Public Member Functions

void | Add (DMMSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (DMMSignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Member Function Documentation

◆ Add() [1/2]

void JY8902CoreOO::DMMSignalExport::Add | ( | DMMSignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | AI Signal Source
destination | Export Desination

◆ Add() [2/2]

void JY8902CoreOO::DMMSignalExport::Add | ( | DMMSignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | AI Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JY8902CoreOO::DMMSignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY8902CoreOO::DMMSignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/8902/jy8902coreootask.h


8902 C++ Programming Manual: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
▼N JY8902CoreOO |
C ACCurrent |
C ACVolt |
C DCCurrent |
C DCVolt |
C DigitalTrigger |
C DMMSignalExport |
C ExternalReferenceClock | External Reference Clcok Terminal
C JY8902CoreOODevice |
C JY8902CoreOOLog |
C JY8902CoreOOProperty | 属性模板类
C JY8902CoreOOReferenceClock |
C JY8902CoreOOTask |
C JYDriverException |
C MultiPoint |
C Resistance2Wire |
C Resistance4Wire |
C SampleClock |
C Sampling |
C TriggerIn |
C TempInfor | TempInfor struct


8902 C++ Programming Manual: Member List

  • ACCurrent
JY8902CoreOO::ACCurrent Member List

This is the complete list of members for JY8902CoreOO::ACCurrent, including all inherited members.

ACCurrent() | JY8902CoreOO::ACCurrent
Range | JY8902CoreOO::ACCurrent


8902 C++ Programming Manual: Member List

  • ACVolt
JY8902CoreOO::ACVolt Member List

This is the complete list of members for JY8902CoreOO::ACVolt, including all inherited members.

ACVolt() | JY8902CoreOO::ACVolt
Range | JY8902CoreOO::ACVolt


8902 C++ Programming Manual: Member List

  • DCCurrent
JY8902CoreOO::DCCurrent Member List

This is the complete list of members for JY8902CoreOO::DCCurrent, including all inherited members.

DCCurrent() | JY8902CoreOO::DCCurrent
Range | JY8902CoreOO::DCCurrent


8902 C++ Programming Manual: Member List

  • DCVolt
JY8902CoreOO::DCVolt Member List

This is the complete list of members for JY8902CoreOO::DCVolt, including all inherited members.

DCVolt() | JY8902CoreOO::DCVolt
Range | JY8902CoreOO::DCVolt


8902 C++ Programming Manual: Member List

  • DMMSignalExport
JY8902CoreOO::DMMSignalExport Member List

This is the complete list of members for JY8902CoreOO::DMMSignalExport, including all inherited members.

Add(DMMSignalExportSource source, SignalExportDestination destination) | JY8902CoreOO::DMMSignalExport
Add(DMMSignalExportSource source, std::list< SignalExportDestination > destinations) | JY8902CoreOO::DMMSignalExport
Clear(SignalExportDestination destination) | JY8902CoreOO::DMMSignalExport
ClearAll() | JY8902CoreOO::DMMSignalExport


8902 C++ Programming Manual: Member List

  • DigitalTrigger
JY8902CoreOO::DigitalTrigger Member List

This is the complete list of members for JY8902CoreOO::DigitalTrigger, including all inherited members.

Edge | JY8902CoreOO::DigitalTrigger
Source | JY8902CoreOO::DigitalTrigger


8902 C++ Programming Manual: Member List

  • ExternalReferenceClock
JY8902CoreOO::ExternalReferenceClock Member List

This is the complete list of members for JY8902CoreOO::ExternalReferenceClock, including all inherited members.

Terminal JY8902CoreOO::ExternalReferenceClock


8902 C++ Programming Manual: Member List

  • JY8902CoreOODevice
JY8902CoreOO::JY8902CoreOODevice Member List

This is the complete list of members for JY8902CoreOO::JY8902CoreOODevice, including all inherited members.

_deviceID | JY8902CoreOO::JY8902CoreOODevice |
BoardClockRate | JY8902CoreOO::JY8902CoreOODevice |
DeviceID | JY8902CoreOO::JY8902CoreOODevice |
DMMBufferSize | JY8902CoreOO::JY8902CoreOODevice |
GetInstance(int cardNum) | JY8902CoreOO::JY8902CoreOODevice | static
GetInstance(std::string aliasName) | JY8902CoreOO::JY8902CoreOODevice | static
Handle | JY8902CoreOO::JY8902CoreOODevice |
IsSync | JY8902CoreOO::JY8902CoreOODevice |
MaxSampleRate | JY8902CoreOO::JY8902CoreOODevice |
ReferenceClock | JY8902CoreOO::JY8902CoreOODevice |
SerialNumber | JY8902CoreOO::JY8902CoreOODevice |


8902 C++ Programming Manual: Member List

  • JY8902CoreOOLog
JY8902CoreOO::JY8902CoreOOLog Member List

This is the complete list of members for JY8902CoreOO::JY8902CoreOOLog, including all inherited members.

EnableLog | JY8902CoreOO::JY8902CoreOOLog | static
Flush() | JY8902CoreOO::JY8902CoreOOLog | static
LogLevel | JY8902CoreOO::JY8902CoreOOLog | static
Print(const char *format,...) | JY8902CoreOO::JY8902CoreOOLog | static
Print(JY8902CoreOOLogLevel logLevel, const char *format,...) | JY8902CoreOO::JY8902CoreOOLog | static


8902 C++ Programming Manual: Member List

  • JY8902CoreOOProperty
JY8902CoreOO::JY8902CoreOOProperty< ContainerClass, ValueType, propertyType > Member List

This is the complete list of members for JY8902CoreOO::JY8902CoreOOProperty< ContainerClass, ValueType, propertyType >, including all inherited members.

JY8902CoreOOProperty() | JY8902CoreOO::JY8902CoreOOProperty< ContainerClass, ValueType, propertyType >
JY8902CoreOOProperty(ContainerClass *cObject, ValueType(ContainerClass::*pGet)(), void(ContainerClass::*pSet)(ValueType value)) | JY8902CoreOO::JY8902CoreOOProperty< ContainerClass, ValueType, propertyType >
JY8902CoreOOProperty(ValueType(*pGet)(), void(*pSet)(ValueType value)) | JY8902CoreOO::JY8902CoreOOProperty< ContainerClass, ValueType, propertyType >
operator ValueType() | JY8902CoreOO::JY8902CoreOOProperty< ContainerClass, ValueType, propertyType >
operator=(const ValueType &value) | JY8902CoreOO::JY8902CoreOOProperty< ContainerClass, ValueType, propertyType >


8902 C++ Programming Manual: Member List

  • JY8902CoreOOReferenceClock
JY8902CoreOO::JY8902CoreOOReferenceClock Member List

This is the complete list of members for JY8902CoreOO::JY8902CoreOOReferenceClock, including all inherited members.

Commit() | JY8902CoreOO::JY8902CoreOOReferenceClock
External | JY8902CoreOO::JY8902CoreOOReferenceClock
Source | JY8902CoreOO::JY8902CoreOOReferenceClock


8902 C++ Programming Manual: Member List

  • JY8902CoreOOTask
JY8902CoreOO::JY8902CoreOOTask Member List

This is the complete list of members for JY8902CoreOO::JY8902CoreOOTask, including all inherited members.

_ACCurrent | JY8902CoreOO::JY8902CoreOOTask
_ACVolt | JY8902CoreOO::JY8902CoreOOTask
_DCCurrent | JY8902CoreOO::JY8902CoreOOTask
_DCVolt | JY8902CoreOO::JY8902CoreOOTask
_DMMSignalExport | JY8902CoreOO::JY8902CoreOOTask
_multiPoint | JY8902CoreOO::JY8902CoreOOTask
_Resistance2Wire | JY8902CoreOO::JY8902CoreOOTask
_Resistance4Wire | JY8902CoreOO::JY8902CoreOOTask
_SampleClock | JY8902CoreOO::JY8902CoreOOTask
_Sampling | JY8902CoreOO::JY8902CoreOOTask
_trigger | JY8902CoreOO::JY8902CoreOOTask
_TriggerOut | JY8902CoreOO::JY8902CoreOOTask
AvailableSamples | JY8902CoreOO::JY8902CoreOOTask
BufLenInSamples | JY8902CoreOO::JY8902CoreOOTask
Device | JY8902CoreOO::JY8902CoreOOTask
DisableCalibration | JY8902CoreOO::JY8902CoreOOTask
Frequency | JY8902CoreOO::JY8902CoreOOTask
Function | JY8902CoreOO::JY8902CoreOOTask
IsOverRange | JY8902CoreOO::JY8902CoreOOTask
JY8902CoreOOTask(std::string deviceName) | JY8902CoreOO::JY8902CoreOOTask
JY8902CoreOOTask(std::string deviceName, MeasurementFunction function, PowerLineFrequency powerLineFrequency) | JY8902CoreOO::JY8902CoreOOTask
JY8902CoreOOTask(int slot) | JY8902CoreOO::JY8902CoreOOTask
JY8902CoreOOTask(int slot, MeasurementFunction function, PowerLineFrequency powerLineFrequency) | JY8902CoreOO::JY8902CoreOOTask
JY8902CoreOOTask() | JY8902CoreOO::JY8902CoreOOTask
Mode | JY8902CoreOO::JY8902CoreOOTask
ReadMultiPoint(double *measureValues, unsigned int numToRead=1, int timeout=-1) | JY8902CoreOO::JY8902CoreOOTask
ReadPoint(double *measureValues, unsigned int numToRead=1, int timeout=-1) | JY8902CoreOO::JY8902CoreOOTask
ReadRawMultiPoint(int *measureValues, unsigned int numToRead=1, int timeout=-1) | JY8902CoreOO::JY8902CoreOOTask
ReadRawSinglePoint(double &measureValue, int timeout=10000) | JY8902CoreOO::JY8902CoreOOTask
ReadSinglePoint(double &measureValue, int timeout=10000) | JY8902CoreOO::JY8902CoreOOTask
SendSoftwareTrigger() | JY8902CoreOO::JY8902CoreOOTask
Start() | JY8902CoreOO::JY8902CoreOOTask
Stop() | JY8902CoreOO::JY8902CoreOOTask
TransferedSamples | JY8902CoreOO::JY8902CoreOOTask
~JY8902CoreOOTask() | JY8902CoreOO::JY8902CoreOOTask


8902 C++ Programming Manual: Member List

  • JYDriverException
JY8902CoreOO::JYDriverException Member List

This is the complete list of members for JY8902CoreOO::JYDriverException, including all inherited members.

errorCode | JY8902CoreOO::JYDriverException
exceptionMessage | JY8902CoreOO::JYDriverException
FollowingException | JY8902CoreOO::JYDriverException
JYDriverException(JYDriverExceptionPublic exceptionCode, std::string msg="") | JY8902CoreOO::JYDriverException
JYDriverException(int, std::string msg) | JY8902CoreOO::JYDriverException


8902 C++ Programming Manual: Member List

  • MultiPoint
JY8902CoreOO::MultiPoint Member List

This is the complete list of members for JY8902CoreOO::MultiPoint, including all inherited members.

_SampleTrigger | JY8902CoreOO::MultiPoint
SampleCount | JY8902CoreOO::MultiPoint
SampleInterval | JY8902CoreOO::MultiPoint


8902 C++ Programming Manual: Member List

  • Resistance2Wire
JY8902CoreOO::Resistance2Wire Member List

This is the complete list of members for JY8902CoreOO::Resistance2Wire, including all inherited members.

Range | JY8902CoreOO::Resistance2Wire
Resistance2Wire() | JY8902CoreOO::Resistance2Wire


8902 C++ Programming Manual: Member List

  • Resistance4Wire
JY8902CoreOO::Resistance4Wire Member List

This is the complete list of members for JY8902CoreOO::Resistance4Wire, including all inherited members.

Range | JY8902CoreOO::Resistance4Wire
Resistance4Wire() | JY8902CoreOO::Resistance4Wire


8902 C++ Programming Manual: Member List

  • SampleClock
JY8902CoreOO::SampleClock Member List

This is the complete list of members for JY8902CoreOO::SampleClock, including all inherited members.

Source JY8902CoreOO::SampleClock


8902 C++ Programming Manual: Member List

  • Sampling
JY8902CoreOO::Sampling Member List

This is the complete list of members for JY8902CoreOO::Sampling, including all inherited members.

Aperture | JY8902CoreOO::Sampling
NPLC | JY8902CoreOO::Sampling
Sampling() | JY8902CoreOO::Sampling
Type | JY8902CoreOO::Sampling


8902 C++ Programming Manual: Member List

  • TriggerIn
JY8902CoreOO::TriggerIn Member List

This is the complete list of members for JY8902CoreOO::TriggerIn, including all inherited members.

Delay | JY8902CoreOO::TriggerIn
Digital | JY8902CoreOO::TriggerIn
Type | JY8902CoreOO::TriggerIn


8902 C++ Programming Manual: Class Index

Class Index
A | D | E | J | M | R | S | T
A
ACCurrent (JY8902CoreOO)
ACVolt (JY8902CoreOO)
D
DCCurrent (JY8902CoreOO)
DCVolt (JY8902CoreOO)
DigitalTrigger (JY8902CoreOO)
DMMSignalExport (JY8902CoreOO)
E
ExternalReferenceClock (JY8902CoreOO)
J
JY8902CoreOODevice (JY8902CoreOO)
JY8902CoreOOLog (JY8902CoreOO)
JY8902CoreOOProperty (JY8902CoreOO)
JY8902CoreOOReferenceClock (JY8902CoreOO)
JY8902CoreOOTask (JY8902CoreOO)
JYDriverException (JY8902CoreOO)
M
MultiPoint (JY8902CoreOO)
R
Resistance2Wire (JY8902CoreOO)
Resistance4Wire (JY8902CoreOO)
S
SampleClock (JY8902CoreOO)
Sampling (JY8902CoreOO)
T
TempInfor
TriggerIn (JY8902CoreOO)


8902 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO Directory Reference

  • File List
  • File Members
  • COO
COO Directory Reference

Directories

8902


8902 C++ Programming Manual: File List

  • File List
  • File Members
File List
Here is a list of all files with brief descriptions:
[detail level 123]
▼ COO
▼ 8902
JY8902CoreOOCommon.h
JY8902CoreOODevice.h
JY8902CoreOOLog.h
jy8902coreootask.h


8902 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • ~
Here is a list of all class members with links to the classes they belong to:

- _ -

  • _ACCurrent : JY8902CoreOO::JY8902CoreOOTask
  • _ACVolt : JY8902CoreOO::JY8902CoreOOTask
  • _DCCurrent : JY8902CoreOO::JY8902CoreOOTask
  • _DCVolt : JY8902CoreOO::JY8902CoreOOTask
  • _deviceID : JY8902CoreOO::JY8902CoreOODevice
  • _DMMSignalExport : JY8902CoreOO::JY8902CoreOOTask
  • _multiPoint : JY8902CoreOO::JY8902CoreOOTask
  • _Resistance2Wire : JY8902CoreOO::JY8902CoreOOTask
  • _Resistance4Wire : JY8902CoreOO::JY8902CoreOOTask
  • _SampleClock : JY8902CoreOO::JY8902CoreOOTask
  • _SampleTrigger : JY8902CoreOO::MultiPoint
  • _Sampling : JY8902CoreOO::JY8902CoreOOTask
  • _trigger : JY8902CoreOO::JY8902CoreOOTask
  • _TriggerOut : JY8902CoreOO::JY8902CoreOOTask

- a -

  • ACCurrent() : JY8902CoreOO::ACCurrent
  • ACVolt() : JY8902CoreOO::ACVolt
  • Add() : JY8902CoreOO::DMMSignalExport
  • Aperture : JY8902CoreOO::Sampling
  • AvailableSamples : JY8902CoreOO::JY8902CoreOOTask

- b -

  • BoardClockRate : JY8902CoreOO::JY8902CoreOODevice
  • BufLenInSamples : JY8902CoreOO::JY8902CoreOOTask

- c -

  • ch1Temp : TempInfor
  • ch2Temp : TempInfor
  • ch3Temp : TempInfor
  • Clear() : JY8902CoreOO::DMMSignalExport
  • ClearAll() : JY8902CoreOO::DMMSignalExport
  • Commit() : JY8902CoreOO::JY8902CoreOOReferenceClock

- d -

  • DCCurrent() : JY8902CoreOO::DCCurrent
  • DCVolt() : JY8902CoreOO::DCVolt
  • Delay : JY8902CoreOO::TriggerIn
  • Device : JY8902CoreOO::JY8902CoreOOTask
  • DeviceID : JY8902CoreOO::JY8902CoreOODevice
  • Digital : JY8902CoreOO::TriggerIn
  • DisableCalibration : JY8902CoreOO::JY8902CoreOOTask
  • DMMBufferSize : JY8902CoreOO::JY8902CoreOODevice

- e -

  • Edge : JY8902CoreOO::DigitalTrigger
  • EnableLog : JY8902CoreOO::JY8902CoreOOLog
  • errorCode : JY8902CoreOO::JYDriverException
  • exceptionMessage : JY8902CoreOO::JYDriverException
  • External : JY8902CoreOO::JY8902CoreOOReferenceClock

- f -

  • Flush() : JY8902CoreOO::JY8902CoreOOLog
  • FollowingException : JY8902CoreOO::JYDriverException
  • Frequency : JY8902CoreOO::JY8902CoreOOTask
  • Function : JY8902CoreOO::JY8902CoreOOTask

- g -

  • GetInstance() : JY8902CoreOO::JY8902CoreOODevice

- h -

  • Handle : JY8902CoreOO::JY8902CoreOODevice

- i -

  • IsOverRange : JY8902CoreOO::JY8902CoreOOTask
  • IsSync : JY8902CoreOO::JY8902CoreOODevice

- j -

  • JY8902CoreOOProperty() : JY8902CoreOO::JY8902CoreOOProperty< ContainerClass, ValueType, propertyType >
  • JY8902CoreOOTask() : JY8902CoreOO::JY8902CoreOOTask
  • JYDriverException() : JY8902CoreOO::JYDriverException

- l -

  • localTemp : TempInfor
  • LogLevel : JY8902CoreOO::JY8902CoreOOLog

- m -

  • MaxSampleRate : JY8902CoreOO::JY8902CoreOODevice
  • Mode : JY8902CoreOO::JY8902CoreOOTask

- n -

  • NPLC : JY8902CoreOO::Sampling

- o -

  • operator ValueType() : JY8902CoreOO::JY8902CoreOOProperty< ContainerClass, ValueType, propertyType >
  • operator=() : JY8902CoreOO::JY8902CoreOOProperty< ContainerClass, ValueType, propertyType >

- p -

  • Print() : JY8902CoreOO::JY8902CoreOOLog

- r -

  • Range : JY8902CoreOO::ACCurrent, JY8902CoreOO::ACVolt, JY8902CoreOO::DCCurrent, JY8902CoreOO::DCVolt, JY8902CoreOO::Resistance2Wire, JY8902CoreOO::Resistance4Wire
  • ReadMultiPoint() : JY8902CoreOO::JY8902CoreOOTask
  • ReadPoint() : JY8902CoreOO::JY8902CoreOOTask
  • ReadRawMultiPoint() : JY8902CoreOO::JY8902CoreOOTask
  • ReadRawSinglePoint() : JY8902CoreOO::JY8902CoreOOTask
  • ReadSinglePoint() : JY8902CoreOO::JY8902CoreOOTask
  • ReferenceClock : JY8902CoreOO::JY8902CoreOODevice
  • Resistance2Wire() : JY8902CoreOO::Resistance2Wire
  • Resistance4Wire() : JY8902CoreOO::Resistance4Wire

- s -

  • SampleCount : JY8902CoreOO::MultiPoint
  • SampleInterval : JY8902CoreOO::MultiPoint
  • Sampling() : JY8902CoreOO::Sampling
  • SendSoftwareTrigger() : JY8902CoreOO::JY8902CoreOOTask
  • SerialNumber : JY8902CoreOO::JY8902CoreOODevice
  • Source : JY8902CoreOO::DigitalTrigger, JY8902CoreOO::JY8902CoreOOReferenceClock, JY8902CoreOO::SampleClock
  • Start() : JY8902CoreOO::JY8902CoreOOTask
  • Stop() : JY8902CoreOO::JY8902CoreOOTask

- t -

  • Terminal : JY8902CoreOO::ExternalReferenceClock
  • TransferedSamples : JY8902CoreOO::JY8902CoreOOTask
  • Type : JY8902CoreOO::Sampling, JY8902CoreOO::TriggerIn

- ~ -

  • ~JY8902CoreOOTask() : JY8902CoreOO::JY8902CoreOOTask


8902 C++ Programming Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • c
  • d
  • f
  • g
  • j
  • o
  • p
  • r
  • s
  • ~
Here is a list of all functions with links to the classes they belong to:

- a -

  • ACCurrent() : JY8902CoreOO::ACCurrent
  • ACVolt() : JY8902CoreOO::ACVolt
  • Add() : JY8902CoreOO::DMMSignalExport

- c -

  • Clear() : JY8902CoreOO::DMMSignalExport
  • ClearAll() : JY8902CoreOO::DMMSignalExport
  • Commit() : JY8902CoreOO::JY8902CoreOOReferenceClock

- d -

  • DCCurrent() : JY8902CoreOO::DCCurrent
  • DCVolt() : JY8902CoreOO::DCVolt

- f -

  • Flush() : JY8902CoreOO::JY8902CoreOOLog

- g -

  • GetInstance() : JY8902CoreOO::JY8902CoreOODevice

- j -

  • JY8902CoreOOProperty() : JY8902CoreOO::JY8902CoreOOProperty< ContainerClass, ValueType, propertyType >
  • JY8902CoreOOTask() : JY8902CoreOO::JY8902CoreOOTask
  • JYDriverException() : JY8902CoreOO::JYDriverException

- o -

  • operator ValueType() : JY8902CoreOO::JY8902CoreOOProperty< ContainerClass, ValueType, propertyType >
  • operator=() : JY8902CoreOO::JY8902CoreOOProperty< ContainerClass, ValueType, propertyType >

- p -

  • Print() : JY8902CoreOO::JY8902CoreOOLog

- r -

  • ReadMultiPoint() : JY8902CoreOO::JY8902CoreOOTask
  • ReadPoint() : JY8902CoreOO::JY8902CoreOOTask
  • ReadRawMultiPoint() : JY8902CoreOO::JY8902CoreOOTask
  • ReadRawSinglePoint() : JY8902CoreOO::JY8902CoreOOTask
  • ReadSinglePoint() : JY8902CoreOO::JY8902CoreOOTask
  • Resistance2Wire() : JY8902CoreOO::Resistance2Wire
  • Resistance4Wire() : JY8902CoreOO::Resistance4Wire

- s -

  • Sampling() : JY8902CoreOO::Sampling
  • SendSoftwareTrigger() : JY8902CoreOO::JY8902CoreOOTask
  • Start() : JY8902CoreOO::JY8902CoreOOTask
  • Stop() : JY8902CoreOO::JY8902CoreOOTask

- ~ -

  • ~JY8902CoreOOTask() : JY8902CoreOO::JY8902CoreOOTask


8902 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • r
  • s
  • t
Here is a list of all variables with links to the classes they belong to:

- _ -

  • _ACCurrent : JY8902CoreOO::JY8902CoreOOTask
  • _ACVolt : JY8902CoreOO::JY8902CoreOOTask
  • _DCCurrent : JY8902CoreOO::JY8902CoreOOTask
  • _DCVolt : JY8902CoreOO::JY8902CoreOOTask
  • _deviceID : JY8902CoreOO::JY8902CoreOODevice
  • _DMMSignalExport : JY8902CoreOO::JY8902CoreOOTask
  • _multiPoint : JY8902CoreOO::JY8902CoreOOTask
  • _Resistance2Wire : JY8902CoreOO::JY8902CoreOOTask
  • _Resistance4Wire : JY8902CoreOO::JY8902CoreOOTask
  • _SampleClock : JY8902CoreOO::JY8902CoreOOTask
  • _SampleTrigger : JY8902CoreOO::MultiPoint
  • _Sampling : JY8902CoreOO::JY8902CoreOOTask
  • _trigger : JY8902CoreOO::JY8902CoreOOTask
  • _TriggerOut : JY8902CoreOO::JY8902CoreOOTask

- a -

  • Aperture : JY8902CoreOO::Sampling
  • AvailableSamples : JY8902CoreOO::JY8902CoreOOTask

- b -

  • BoardClockRate : JY8902CoreOO::JY8902CoreOODevice
  • BufLenInSamples : JY8902CoreOO::JY8902CoreOOTask

- c -

  • ch1Temp : TempInfor
  • ch2Temp : TempInfor
  • ch3Temp : TempInfor

- d -

  • Delay : JY8902CoreOO::TriggerIn
  • Device : JY8902CoreOO::JY8902CoreOOTask
  • DeviceID : JY8902CoreOO::JY8902CoreOODevice
  • Digital : JY8902CoreOO::TriggerIn
  • DisableCalibration : JY8902CoreOO::JY8902CoreOOTask
  • DMMBufferSize : JY8902CoreOO::JY8902CoreOODevice

- e -

  • Edge : JY8902CoreOO::DigitalTrigger
  • EnableLog : JY8902CoreOO::JY8902CoreOOLog
  • errorCode : JY8902CoreOO::JYDriverException
  • exceptionMessage : JY8902CoreOO::JYDriverException
  • External : JY8902CoreOO::JY8902CoreOOReferenceClock

- f -

  • FollowingException : JY8902CoreOO::JYDriverException
  • Frequency : JY8902CoreOO::JY8902CoreOOTask
  • Function : JY8902CoreOO::JY8902CoreOOTask

- h -

  • Handle : JY8902CoreOO::JY8902CoreOODevice

- i -

  • IsOverRange : JY8902CoreOO::JY8902CoreOOTask
  • IsSync : JY8902CoreOO::JY8902CoreOODevice

- l -

  • localTemp : TempInfor
  • LogLevel : JY8902CoreOO::JY8902CoreOOLog

- m -

  • MaxSampleRate : JY8902CoreOO::JY8902CoreOODevice
  • Mode : JY8902CoreOO::JY8902CoreOOTask

- n -

  • NPLC : JY8902CoreOO::Sampling

- r -

  • Range : JY8902CoreOO::ACCurrent, JY8902CoreOO::ACVolt, JY8902CoreOO::DCCurrent, JY8902CoreOO::DCVolt, JY8902CoreOO::Resistance2Wire, JY8902CoreOO::Resistance4Wire
  • ReferenceClock : JY8902CoreOO::JY8902CoreOODevice

- s -

  • SampleCount : JY8902CoreOO::MultiPoint
  • SampleInterval : JY8902CoreOO::MultiPoint
  • SerialNumber : JY8902CoreOO::JY8902CoreOODevice
  • Source : JY8902CoreOO::DigitalTrigger, JY8902CoreOO::JY8902CoreOOReferenceClock, JY8902CoreOO::SampleClock

- t -

  • Terminal : JY8902CoreOO::ExternalReferenceClock
  • TransferedSamples : JY8902CoreOO::JY8902CoreOOTask
  • Type : JY8902CoreOO::Sampling, JY8902CoreOO::TriggerIn


8902 C++ Programming Manual: File Members

  • File List
  • File Members
  • All
  • Functions
  • Enumerations
  • Macros
Here is a list of all file members with links to the files they belong to:
  • _CRT_SECURE_NO_WARNINGS : jy8902coreootask.h
  • ACCurrentRange : JY8902CoreOOCommon.h
  • ACVoltRange : JY8902CoreOOCommon.h
  • DCCurrentRange : JY8902CoreOOCommon.h
  • DCVoltRange : JY8902CoreOOCommon.h
  • DigitalTriggerSource : JY8902CoreOOCommon.h
  • EXTERN_C : JY8902CoreOOCommon.h
  • GetSignalExportDestinationString() : JY8902CoreOOCommon.h
  • JY8902CoreOO_API : JY8902CoreOOCommon.h
  • MeasurementFunction : JY8902CoreOOCommon.h
  • MeasurementTriggerEdge : JY8902CoreOOCommon.h
  • MeaurementMode : JY8902CoreOOCommon.h
  • PowerLineFrequency : JY8902CoreOOCommon.h
  • Resistance2WireRange : JY8902CoreOOCommon.h
  • Resistance4WireRange : JY8902CoreOOCommon.h
  • SamplingType : JY8902CoreOOCommon.h
  • SignalExportDestination : JY8902CoreOOCommon.h
  • TriggerOut : JY8902CoreOOCommon.h
  • TriggerType : JY8902CoreOOCommon.h


8902 C++ Programming Manual: File Members

  • File List
  • File Members
  • All
  • Functions
  • Enumerations
  • Macros
Here is a list of all macros with links to the files they belong to:
  • _CRT_SECURE_NO_WARNINGS : jy8902coreootask.h
  • EXTERN_C : JY8902CoreOOCommon.h
  • JY8902CoreOO_API : JY8902CoreOOCommon.h


8902 C++ Programming Manual: File Members

  • File List
  • File Members
  • All
  • Functions
  • Enumerations
  • Macros
Here is a list of all enums with links to the files they belong to:
  • ACCurrentRange : JY8902CoreOOCommon.h
  • ACVoltRange : JY8902CoreOOCommon.h
  • DCCurrentRange : JY8902CoreOOCommon.h
  • DCVoltRange : JY8902CoreOOCommon.h
  • DigitalTriggerSource : JY8902CoreOOCommon.h
  • MeasurementFunction : JY8902CoreOOCommon.h
  • MeasurementTriggerEdge : JY8902CoreOOCommon.h
  • MeaurementMode : JY8902CoreOOCommon.h
  • PowerLineFrequency : JY8902CoreOOCommon.h
  • Resistance2WireRange : JY8902CoreOOCommon.h
  • Resistance4WireRange : JY8902CoreOOCommon.h
  • SamplingType : JY8902CoreOOCommon.h
  • SignalExportDestination : JY8902CoreOOCommon.h
  • TriggerOut : JY8902CoreOOCommon.h
  • TriggerType : JY8902CoreOOCommon.h


8902 C++ Programming Manual: File Members

  • File List
  • File Members
  • All
  • Functions
  • Enumerations
  • Macros
Here is a list of all functions with links to the files they belong to:
  • GetSignalExportDestinationString() : JY8902CoreOOCommon.h


8902 C++ Programming Manual: Main Page

8902 C++ Programming Manual Documentation


8902 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Enumerations
  • _
  • a
  • c
  • d
  • e
  • f
  • i
  • j
  • m
  • n
  • o
  • p
  • r
  • s
Here is a list of all namespace members with links to the namespace documentation for each member:

- _ -

  • _100 : JY8902Import
  • _1000mA : JY8902Import
  • _100K : JY8902Import
  • _100M : JY8902Import
  • _10K : JY8902Import
  • _10M : JY8902Import
  • _1K : JY8902Import
  • _1M : JY8902Import
  • _200mA : JY8902Import
  • _200mV : JY8902Import
  • _20mA : JY8902Import
  • _20V : JY8902Import
  • _240V : JY8902Import
  • _2V : JY8902Import
  • _50Hz : JY8902Import
  • _60Hz : JY8902Import

- a -

  • AC_CURRENT_1000mA : JY8902Import
  • AC_CURRENT_200mA : JY8902Import
  • AC_CURRENT_20mA : JY8902Import
  • AC_VOLTAGE_200mV : JY8902Import
  • AC_VOLTAGE_20V : JY8902Import
  • AC_VOLTAGE_240V : JY8902Import
  • AC_VOLTAGE_2V : JY8902Import
  • ACCurrent : JY8902Import
  • ACVolt : JY8902Import
  • Aperture : JY8902Import
  • Auto : JY8902Import

- c -

  • ContinuousMultiPoint : JY8902Import

- d -

  • DC_CURRENT_1000mA : JY8902Import
  • DC_CURRENT_200mA : JY8902Import
  • DC_CURRENT_20mA : JY8902Import
  • DC_VOLTAGE_200mV : JY8902Import
  • DC_VOLTAGE_20V : JY8902Import
  • DC_VOLTAGE_240V : JY8902Import
  • DC_VOLTAGE_2V : JY8902Import
  • DCCurrent : JY8902Import
  • DCVolt : JY8902Import
  • Digital : JY8902Import
  • DMMSignalExportSource : JY8902CoreOO

- e -

  • ExternalReferenceClockTerminal : JY8902CoreOO

- f -

  • Falling : JY8902Import

- i -

  • Immediate : JY8902Import

- j -

  • JY8902_Signal_MeasureComplete : JY8902Import
  • JY8902CoreOOLogLevel : JY8902CoreOO
  • JY8902CoreOOPropertyType : JY8902CoreOO
  • JYDriverExceptionPublic : JY8902CoreOO

- m -

  • MultiPoint : JY8902Import

- n -

  • None : JY8902Import
  • NPLC : JY8902Import

- o -

  • OHM_100 : JY8902Import
  • OHM_100_4W : JY8902Import
  • OHM_100K : JY8902Import
  • OHM_100K_4W : JY8902Import
  • OHM_100M : JY8902Import
  • OHM_100M_4W : JY8902Import
  • OHM_10K : JY8902Import
  • OHM_10K_4W : JY8902Import
  • OHM_10M : JY8902Import
  • OHM_10M_4W : JY8902Import
  • OHM_1K : JY8902Import
  • OHM_1K_4W : JY8902Import
  • OHM_1M : JY8902Import
  • OHM_1M_4W : JY8902Import

- p -

  • PFI0 : JY8902Import
  • PFI1 : JY8902Import
  • PXI_Trig0 : JY8902Import
  • PXI_Trig1 : JY8902Import
  • PXI_Trig2 : JY8902Import
  • PXI_Trig3 : JY8902Import
  • PXI_Trig4 : JY8902Import
  • PXI_Trig5 : JY8902Import
  • PXI_Trig6 : JY8902Import
  • PXI_Trig7 : JY8902Import

- r -

  • ReferenceClockSource : JY8902CoreOO
  • Resistance2Wire : JY8902Import
  • Resistance4Wire : JY8902Import
  • Rising : JY8902Import

- s -

  • SampleClockSource : JY8902CoreOO
  • SampleTrigger : JY8902CoreOO
  • SinglePoint : JY8902Import
  • Software : JY8902Import


8902 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Enumerations
Here is a list of all namespace enums with links to the namespace documentation for each enum:
  • DMMSignalExportSource : JY8902CoreOO
  • ExternalReferenceClockTerminal : JY8902CoreOO
  • JY8902CoreOOLogLevel : JY8902CoreOO
  • JY8902CoreOOPropertyType : JY8902CoreOO
  • JYDriverExceptionPublic : JY8902CoreOO
  • ReferenceClockSource : JY8902CoreOO
  • SampleClockSource : JY8902CoreOO
  • SampleTrigger : JY8902CoreOO


8902 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Variables
  • Enumerations
  • _
  • a
  • c
  • d
  • f
  • i
  • j
  • m
  • n
  • o
  • p
  • r
  • s
Here is a list of all namespace variables with links to the namespace documentation for each variable:

- _ -

  • _100 : JY8902Import
  • _1000mA : JY8902Import
  • _100K : JY8902Import
  • _100M : JY8902Import
  • _10K : JY8902Import
  • _10M : JY8902Import
  • _1K : JY8902Import
  • _1M : JY8902Import
  • _200mA : JY8902Import
  • _200mV : JY8902Import
  • _20mA : JY8902Import
  • _20V : JY8902Import
  • _240V : JY8902Import
  • _2V : JY8902Import
  • _50Hz : JY8902Import
  • _60Hz : JY8902Import

- a -

  • AC_CURRENT_1000mA : JY8902Import
  • AC_CURRENT_200mA : JY8902Import
  • AC_CURRENT_20mA : JY8902Import
  • AC_VOLTAGE_200mV : JY8902Import
  • AC_VOLTAGE_20V : JY8902Import
  • AC_VOLTAGE_240V : JY8902Import
  • AC_VOLTAGE_2V : JY8902Import
  • ACCurrent : JY8902Import
  • ACVolt : JY8902Import
  • Aperture : JY8902Import
  • Auto : JY8902Import

- c -

  • ContinuousMultiPoint : JY8902Import

- d -

  • DC_CURRENT_1000mA : JY8902Import
  • DC_CURRENT_200mA : JY8902Import
  • DC_CURRENT_20mA : JY8902Import
  • DC_VOLTAGE_200mV : JY8902Import
  • DC_VOLTAGE_20V : JY8902Import
  • DC_VOLTAGE_240V : JY8902Import
  • DC_VOLTAGE_2V : JY8902Import
  • DCCurrent : JY8902Import
  • DCVolt : JY8902Import
  • Digital : JY8902Import

- f -

  • Falling : JY8902Import

- i -

  • Immediate : JY8902Import

- j -

  • JY8902_Signal_MeasureComplete : JY8902Import

- m -

  • MultiPoint : JY8902Import

- n -

  • None : JY8902Import
  • NPLC : JY8902Import

- o -

  • OHM_100 : JY8902Import
  • OHM_100_4W : JY8902Import
  • OHM_100K : JY8902Import
  • OHM_100K_4W : JY8902Import
  • OHM_100M : JY8902Import
  • OHM_100M_4W : JY8902Import
  • OHM_10K : JY8902Import
  • OHM_10K_4W : JY8902Import
  • OHM_10M : JY8902Import
  • OHM_10M_4W : JY8902Import
  • OHM_1K : JY8902Import
  • OHM_1K_4W : JY8902Import
  • OHM_1M : JY8902Import
  • OHM_1M_4W : JY8902Import

- p -

  • PFI0 : JY8902Import
  • PFI1 : JY8902Import
  • PXI_Trig0 : JY8902Import
  • PXI_Trig1 : JY8902Import
  • PXI_Trig2 : JY8902Import
  • PXI_Trig3 : JY8902Import
  • PXI_Trig4 : JY8902Import
  • PXI_Trig5 : JY8902Import
  • PXI_Trig6 : JY8902Import
  • PXI_Trig7 : JY8902Import

- r -

  • Resistance2Wire : JY8902Import
  • Resistance4Wire : JY8902Import
  • Rising : JY8902Import

- s -

  • SinglePoint : JY8902Import
  • Software : JY8902Import


8902 C++ Programming Manual: Namespace List

  • Namespace List
  • Namespace Members
Namespace List
Here is a list of all namespaces with brief descriptions:
N JY8902CoreOO
N JY8902Import


8902 C++ Programming Manual: Member List

TempInfor Member List

This is the complete list of members for TempInfor, including all inherited members.

ch1Temp | TempInfor
ch2Temp | TempInfor
ch3Temp | TempInfor
localTemp | TempInfor