8902 C# Programming Manual: D:/8902/C# Directory Reference

8902 C# Programming Manual
  • Main Page
  • Packages
  • Classes
  • Files
  • File List
  • 8902
  • C#
C# Directory Reference

Files

ClassDefination.cs
EnumDefination.cs
JYPXIe8902Task.cs
Generated by doxygen 1.12.0


8902 C# Programming Manual: D:/8902/C#/ClassDefination.cs File Reference

  • Packages
  • Classes
  • Files
  • File List
  • 8902
  • C#
Classes | Namespaces | Enumerations
ClassDefination.cs File Reference

Classes

class | JY8902.DCVolt
DC voltage. More...
class | JY8902.Resistance2Wire
resistance 2 wire. More...
class | JY8902.Resistance4Wire
resistance 2 wire. More...
class | JY8902.ACVolt
AC voltage. More...
class | JY8902.DCCurrent
DC current. More...
class | JY8902.ACCurrent
AC current. More...
class | JY8902.Sampling
Sampling. More...
class | JY8902.TriggerIn
触发设置类 More...
class | JY8902.DigitalTrigger
Digital trigger class. More...
class | JY8902.MultiPoint
多点设置 More...
class | JY8902.DMMSignalExport
DMM Signal Export Class. More...
class | JY8902.SampleClock
Sample clock configuration class. More...

Namespaces

namespace JY8902

Enumerations

enum JY8902.SampleClockSource { JY8902.Internal = 0 , JY8902.External = 1 }
ClockSource Type. More...


8902 C# Programming Manual: JY8902.DCVolt Class Reference

  • Class List
  • Class Index
  • Class Members
  • JY8902
  • DCVolt
Properties | List of all members
JY8902.DCVolt Class Referencesealed

DC voltage. More...

Properties

DCVoltRange Range [get, set]
DC Volt Range.

Detailed Description

DC voltage.

Property Documentation

◆ Range

DCVoltRange JY8902.DCVolt.Range
getset

DC Volt Range.

The documentation for this class was generated from the following file:
  • D:/8902/C#/ClassDefination.cs


8902 C# Programming Manual: JY8902.Resistance2Wire Class Reference

  • JY8902
  • Resistance2Wire
Properties | List of all members
JY8902.Resistance2Wire Class Referencesealed

resistance 2 wire. More...

Properties

Resistance2WireRange Range [get, set]
Resistance 2Wire Range.

Detailed Description

resistance 2 wire.

Property Documentation

◆ Range

Resistance2WireRange JY8902.Resistance2Wire.Range
getset

Resistance 2Wire Range.

The documentation for this class was generated from the following file:
  • D:/8902/C#/ClassDefination.cs


8902 C# Programming Manual: JY8902.Resistance4Wire Class Reference

  • Resistance4Wire
Properties | List of all members
JY8902.Resistance4Wire Class Referencesealed

resistance 2 wire. More...

Properties

Resistance4WireRange Range [get, set]
Resistance 4Wire Range.

Detailed Description

resistance 2 wire.

Property Documentation

◆ Range

Resistance4WireRange JY8902.Resistance4Wire.Range
getset

Resistance 4Wire Range.

The documentation for this class was generated from the following file:
  • D:/8902/C#/ClassDefination.cs


8902 C# Programming Manual: JY8902.ACVolt Class Reference

  • ACVolt
Properties | List of all members
JY8902.ACVolt Class Referencesealed

AC voltage. More...

Properties

ACVoltRange Range [get, set]
AC Volt Range.

Detailed Description

AC voltage.

Property Documentation

◆ Range

ACVoltRange JY8902.ACVolt.Range
getset

AC Volt Range.

The documentation for this class was generated from the following file:
  • D:/8902/C#/ClassDefination.cs


8902 C# Programming Manual: JY8902.DCCurrent Class Reference

  • DCCurrent
Properties | List of all members
JY8902.DCCurrent Class Referencesealed

DC current. More...

Properties

DCCurrentRange Range [get, set]
DC Current Range.

Detailed Description

DC current.

Property Documentation

◆ Range

DCCurrentRange JY8902.DCCurrent.Range
getset

DC Current Range.

The documentation for this class was generated from the following file:
  • D:/8902/C#/ClassDefination.cs


8902 C# Programming Manual: JY8902.ACCurrent Class Reference

  • ACCurrent
Properties | List of all members
JY8902.ACCurrent Class Referencesealed

AC current. More...

Properties

ACCurrentRange Range [get, set]
AC Current Range.

Detailed Description

AC current.

Property Documentation

◆ Range

ACCurrentRange JY8902.ACCurrent.Range
getset

AC Current Range.

The documentation for this class was generated from the following file:
  • D:/8902/C#/ClassDefination.cs


8902 C# Programming Manual: JY8902.Sampling Class Reference

  • Sampling
Public Attributes | Properties | List of all members
JY8902.Sampling Class Referencesealed

Sampling. More...

Public Attributes

SamplingType Type
sampling parameter type, set Aperture or set NPLC

Properties

double | Aperture [get, set]
Aperture, the integration time in seconds (called aperture time) of the analog-to-digital converter.
double | NPLC [get, set]
NPLC, the integration time in number of power line cycles (PLCs) of the analog-to-digital converter.

Detailed Description

Sampling.

Member Data Documentation

◆ Type

SamplingType JY8902.Sampling.Type

sampling parameter type, set Aperture or set NPLC

Property Documentation

◆ Aperture

double JY8902.Sampling.Aperture
getset

Aperture, the integration time in seconds (called aperture time) of the analog-to-digital converter.

Only certain discrete apertures are supported.

Setting this property will cause it to select the nearest aperture that is greater than or equal to the value specified.

◆ NPLC

double JY8902.Sampling.NPLC
getset

NPLC, the integration time in number of power line cycles (PLCs) of the analog-to-digital converter.

The documentation for this class was generated from the following file:
  • D:/8902/C#/ClassDefination.cs


8902 C# Programming Manual: JY8902.TriggerIn Class Reference

  • TriggerIn
Properties | List of all members
JY8902.TriggerIn Class Reference

触发设置类 More...

Properties

TriggerType | Type [get, set]
触发源选择
DigitalTrigger | Digital [get, set]
Digital Trigger Congfiguration.
double | Delay [get, set]
Trigger Delay.

Detailed Description

触发设置类

Property Documentation

◆ Delay

double JY8902.TriggerIn.Delay
getset

Trigger Delay.

◆ Digital

DigitalTrigger JY8902.TriggerIn.Digital
getset

Digital Trigger Congfiguration.

Valid when Type is TriggerType.Digital.

◆ Type

TriggerType JY8902.TriggerIn.Type
getset

触发源选择

The documentation for this class was generated from the following file:
  • D:/8902/C#/ClassDefination.cs


8902 C# Programming Manual: JY8902.DigitalTrigger Class Reference

  • DigitalTrigger
Properties | List of all members
JY8902.DigitalTrigger Class Referencesealed

Digital trigger class. More...

Properties

DigitalTriggerSource | Source [get, set]
Digital Trigger source.
MeasurementTriggerEdge | Edge [get, set]
Digital Trigger edge，Rising/Falling.

Detailed Description

Digital trigger class.

Property Documentation

◆ Edge

MeasurementTriggerEdge JY8902.DigitalTrigger.Edge
getset

Digital Trigger edge，Rising/Falling.

◆ Source

DigitalTriggerSource JY8902.DigitalTrigger.Source
getset

Digital Trigger source.

The documentation for this class was generated from the following file:
  • D:/8902/C#/ClassDefination.cs


8902 C# Programming Manual: JY8902.MultiPoint Class Reference

  • MultiPoint
Properties | List of all members
JY8902.MultiPoint Class Reference

多点设置 More...

Properties

int | SampleCount [get, set]
指定Multi Point采集测量的点数
double | SampleInterval [get, set]
Sets the amount of time in seconds the DMM waits between measurement cycles.
SampleTrigger | SampleTrigger [get, set]

Detailed Description

多点设置

Property Documentation

◆ SampleCount

int JY8902.MultiPoint.SampleCount
getset

指定Multi Point采集测量的点数

◆ SampleInterval

double JY8902.MultiPoint.SampleInterval
getset

Sets the amount of time in seconds the DMM waits between measurement cycles.

◆ SampleTrigger

SampleTrigger JY8902.MultiPoint.SampleTrigger
getset
The documentation for this class was generated from the following file:
  • D:/8902/C#/ClassDefination.cs


8902 C# Programming Manual: JY8902.DMMSignalExport Class Reference

  • DMMSignalExport
Public Member Functions | List of all members
JY8902.DMMSignalExport Class Reference

DMM Signal Export Class. More...

Public Member Functions

void | Add (DMMSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (DMMSignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

DMM Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY8902.DMMSignalExport.Add | ( | DMMSignalExportSource | source,
 |  | List< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | AI Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY8902.DMMSignalExport.Add | ( | DMMSignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | AI Signal Source
destination | Export Desination

◆ Clear()

void JY8902.DMMSignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY8902.DMMSignalExport.ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • D:/8902/C#/ClassDefination.cs


8902 C# Programming Manual: JY8902.SampleClock Class Reference

  • SampleClock
Properties | List of all members
JY8902.SampleClock Class Reference

Sample clock configuration class. More...

Properties

SampleClockSource Source [get, set]
Clock Source.

Detailed Description

Sample clock configuration class.

Property Documentation

◆ Source

SampleClockSource JY8902.SampleClock.Source
getset

Clock Source.

enum Internal/External,The default value is SampleClockSource.Internal.

The documentation for this class was generated from the following file:
  • D:/8902/C#/ClassDefination.cs


8902 C# Programming Manual: D:/8902/C#/EnumDefination.cs File Reference

  • File List
  • 8902
  • C#
Classes | Namespaces | Enumerations
EnumDefination.cs File Reference

Classes

struct JY8902.TempInfor
tempInfor struct More...

Namespaces

namespace JY8902

Enumerations

enum | JY8902.MeasurementMode { JY8902.SinglePoint , JY8902.MultiPoint , JY8902.ContinuousMultiPoint }
DMM Meaurement Mode. More...
enum JY8902.MeasurementFunction : int {
JY8902.DCVolt , JY8902.ACVolt , JY8902.DCCurrent , JY8902.ACCurrent ,
JY8902.Resistance2Wire , JY8902.Resistance4Wire
}
DMM Measurement Function. More...
enum | JY8902.SamplingType { JY8902.Aperture , JY8902.NPLC }
sampling parameter type, set Aperture or set NPLC More...
enum JY8902.DCVoltRange {
JY8902.Auto = 0 , JY8902._200mV , JY8902._2V , JY8902._20V ,
JY8902._240V
}
DC RANGE. More...
enum | JY8902.DCCurrentRange { JY8902.Auto , JY8902._20mA , JY8902._200mA , JY8902._1000mA }
DC RANGE. More...
enum | JY8902.ACCurrentRange { JY8902.Auto , JY8902._20mA , JY8902._200mA , JY8902._1000mA }
DC RANGE. More...
enum JY8902.ACVoltRange {
JY8902.Auto , JY8902._200mV , JY8902._2V , JY8902._20V ,
JY8902._240V
}
AC RANGE. More...
enum JY8902.Resistance2WireRange {
JY8902.Auto , JY8902._100 , JY8902._1K , JY8902._10K ,
JY8902._100K , JY8902._1M , JY8902._10M , JY8902._100M
}
Resistance 2Wire Range. More...
enum JY8902.Resistance4WireRange {
JY8902.Auto , JY8902._100 , JY8902._1K , JY8902._10K ,
JY8902._100K , JY8902._1M
}
Resistance 4Wire Range. More...
enum | JY8902.TriggerType : int { JY8902.Immediate , JY8902.Software , JY8902.Digital }
Trigger Type. More...
enum JY8902.DigitalTriggerSource {
JY8902.PFI0 = JY8902Import.JY8902_DigitalTriggerSource_PFI_0 , JY8902.PFI1 = JY8902Import.JY8902_DigitalTriggerSource_PFI_1 , JY8902.PXI_Trig0 = JY8902Import.JY8902_DigitalTriggerSource_PXI_0 , JY8902.PXI_Trig1 = JY8902Import.JY8902_DigitalTriggerSource_PXI_1 ,
JY8902.PXI_Trig2 = JY8902Import.JY8902_DigitalTriggerSource_PXI_2 , JY8902.PXI_Trig3 = JY8902Import.JY8902_DigitalTriggerSource_PXI_3 , JY8902.PXI_Trig4 = JY8902Import.JY8902_DigitalTriggerSource_PXI_4 , JY8902.PXI_Trig5 = JY8902Import.JY8902_DigitalTriggerSource_PXI_5 ,
JY8902.PXI_Trig6 = JY8902Import.JY8902_DigitalTriggerSource_PXI_6 , JY8902.PXI_Trig7 = JY8902Import.JY8902_DigitalTriggerSource_PXI_7
}
Digital trigger source. More...
enum JY8902.SampleTrigger : int {
JY8902.Immediate = -1 , JY8902.PFI0 = JY8902Import.JY8902_DigitalTriggerSource_PFI_0 , JY8902.PFI1 = JY8902Import.JY8902_DigitalTriggerSource_PFI_1 , JY8902.PXI_Trig0 = JY8902Import.JY8902_DigitalTriggerSource_PXI_0 ,
JY8902.PXI_Trig1 = JY8902Import.JY8902_DigitalTriggerSource_PXI_1 , JY8902.PXI_Trig2 = JY8902Import.JY8902_DigitalTriggerSource_PXI_2 , JY8902.PXI_Trig3 = JY8902Import.JY8902_DigitalTriggerSource_PXI_3 , JY8902.PXI_Trig4 = JY8902Import.JY8902_DigitalTriggerSource_PXI_4 ,
JY8902.PXI_Trig5 = JY8902Import.JY8902_DigitalTriggerSource_PXI_5 , JY8902.PXI_Trig6 = JY8902Import.JY8902_DigitalTriggerSource_PXI_6 , JY8902.PXI_Trig7 = JY8902Import.JY8902_DigitalTriggerSource_PXI_7
}
Digital trigger source. More...
enum | JY8902.MeasurementTriggerEdge { JY8902.Rising , JY8902.Falling }
trigger edge More...
enum JY8902.SignalExportDestination {
JY8902.None = JY8902Import.JY8902_None , JY8902.PFI0 = JY8902Import.JY8902_TriggerOut_PFI_0 , JY8902.PFI1 = JY8902Import.JY8902_TriggerOut_PFI_1 , JY8902.PXI_Trig0 = JY8902Import.JY8902_TriggerOut_PXI_0 ,
JY8902.PXI_Trig1 = JY8902Import.JY8902_TriggerOut_PXI_1 , JY8902.PXI_Trig2 = JY8902Import.JY8902_TriggerOut_PXI_2 , JY8902.PXI_Trig3 = JY8902Import.JY8902_TriggerOut_PXI_3 , JY8902.PXI_Trig4 = JY8902Import.JY8902_TriggerOut_PXI_4 ,
JY8902.PXI_Trig5 = JY8902Import.JY8902_TriggerOut_PXI_5 , JY8902.PXI_Trig6 = JY8902Import.JY8902_TriggerOut_PXI_6 , JY8902.PXI_Trig7 = JY8902Import.JY8902_TriggerOut_PXI_7
}
Rout measurement complete signal to the destination. More...
enum JY8902.TriggerOut {
JY8902.None = JY8902Import.JY8902_None , JY8902.PFI0 = JY8902Import.JY8902_TriggerOut_PFI_0 , JY8902.PFI1 = JY8902Import.JY8902_TriggerOut_PFI_1 , JY8902.PXI_Trig0 = JY8902Import.JY8902_TriggerOut_PXI_0 ,
JY8902.PXI_Trig1 = JY8902Import.JY8902_TriggerOut_PXI_0 , JY8902.PXI_Trig2 = JY8902Import.JY8902_TriggerOut_PXI_0 , JY8902.PXI_Trig3 = JY8902Import.JY8902_TriggerOut_PXI_0 , JY8902.PXI_Trig4 = JY8902Import.JY8902_TriggerOut_PXI_0 ,
JY8902.PXI_Trig5 = JY8902Import.JY8902_TriggerOut_PXI_0 , JY8902.PXI_Trig6 = JY8902Import.JY8902_TriggerOut_PXI_0 , JY8902.PXI_Trig7 = JY8902Import.JY8902_TriggerOut_PXI_0
}
Rout trigger out signal to the destination. More...
enum | JY8902.DMMSignalExportSource { JY8902.MeasureComplete = JY8902Import.JY8902_Signal_MeasureComplete }
AI Signal Export Source. More...
enum | JY8902.PowerLineFrequency { JY8902._50Hz , JY8902._60Hz }
AC Power Frequency. More...


8902 C# Programming Manual: JY8902.TempInfor Struct Reference

  • TempInfor
Public Attributes | List of all members
JY8902.TempInfor Struct Reference

tempInfor struct More...

Public Attributes

double | localTemp
local Temp
double | ch1Temp
ch1 Temp
double | ch2Temp
ch2 Temp
double | ch3Temp
ch3 Temp

Detailed Description

tempInfor struct

Member Data Documentation

◆ ch1Temp

double JY8902.TempInfor.ch1Temp

ch1 Temp

◆ ch2Temp

double JY8902.TempInfor.ch2Temp

ch2 Temp

◆ ch3Temp

double JY8902.TempInfor.ch3Temp

ch3 Temp

◆ localTemp

double JY8902.TempInfor.localTemp

local Temp

The documentation for this struct was generated from the following file:
  • D:/8902/C#/EnumDefination.cs


8902 C# Programming Manual: D:/8902/C#/JYPXIe8902Task.cs File Reference

  • File List
  • 8902
  • C#
Classes | Namespaces
JYPXIe8902Task.cs File Reference

Classes

class JY8902.JY8902Task
DMM Task. More...

Namespaces

namespace JY8902


8902 C# Programming Manual: JY8902.JY8902Task Class Reference

  • JY8902Task
Public Member Functions | Public Attributes | Properties | List of all members
JY8902.JY8902Task Class Referencesealed

DMM Task. More...

Public Member Functions

JY8902Task (string deviceName)
Constructor, Used to create an DMM task by the deviceName.
JY8902Task (string deviceName, MeasurementFunction function=MeasurementFunction.DCVolt, PowerLineFrequency powerLineFrequency=PowerLineFrequency._50Hz)
Constructor,Used to create an DMM task by the deviceName.
JY8902Task (int slot)
Constructor, Used to create an DMM task by a slot number.
JY8902Task (int slot, MeasurementFunction function, double powerLineFrequency=50)
Constructor, Used to create an DMM task by a slot number.
void | ReadSinglePoint (ref double measureValue, int timeout=10000)
Read one measurement value .
void | ReadRawSinglePoint (ref double measureValue, int timeout=10000)
Read one raw measurement voltage value .
void | ReadMultiPoint (ref double[] measureValues, uint numToRead=1, int timeout=-1)
Read multi measurement values.
void | ReadRawMultiPoint (ref int[] measureValues, uint numToRead=1, int timeout=-1)
void | Start ()
Start measurement.
void | SendSoftwareTrigger ()
Send software trigger.
void | Stop ()
Stop measurement.

Public Attributes

bool Running = false
Sampling Sampling
set aperture/NPLC

Properties

JY8902Device | Device [get]
Device Handle.
TempInfor | TempInformation [get]
Get Temprature Information.
bool | DisableCalibration [get, set]
Disable Calibration,true is disable, false is not disable.
MeasurementMode | Mode [get, set]
Measurement Mode, support SinglePoint/MultiPoint/ContinuousMultiPoint, default is SinglePoint.
MeasurementFunction | Function [get, set]
Measurement Function, support DCVolt/ACVolt/DCCurrent/ACCurrent/Resistance2Wire/Resistance4Wire, default is DCVolt.
DCVolt | DCVolt [get]
DC voltage.
Resistance2Wire | Resistance2Wire [get]
2 wire resistance measurement.
Resistance4Wire | Resistance4Wire [get]
4 wire resistance measurement.
ACVolt | ACVolt [get]
AC voltage.
DCCurrent | DCCurrent [get]
DC current.
ACCurrent | ACCurrent [get, set]
AC current.
PowerLineFrequency | PowerLineFrequency [get, set]
Configures the power line frequency of the DMM, valid value is 50/60 Hz.
TriggerIn | Trigger [get]
Trigger Configuration.
MultiPoint | MultiPoint [get]
Multi Point Configuration.Valid when Mode is NOT MeasurementMode.SinglePoint.
int | BufLenInSamples [get]
Number of samples can be storage in the buffer, the Proprety MultiPoint.SampleCount must be less than or equal to this value.
int | AvailableSamples [get]
Number of samples per channel that can be read in the buffer .
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer.
bool | IsOverRange [get]
Measurement is over range.
DMMSignalExport | SignalExport [get, set]
Signal Export.
TriggerOut | TriggerOut [get, set]
Measure Complete Signal Out.

Detailed Description

DMM Task.

Constructor & Destructor Documentation

◆ JY8902Task() [1/4]

JY8902.JY8902Task.JY8902Task ( string deviceName )

Constructor, Used to create an DMM task by the deviceName.

Parameters
deviceName device name

◆ JY8902Task() [2/4]

JY8902.JY8902Task.JY8902Task | ( | string | deviceName,
 |  | MeasurementFunction | function = MeasurementFunction::DCVolt,
 |  | PowerLineFrequency | powerLineFrequency = PowerLineFrequency::_50Hz )

Constructor,Used to create an DMM task by the deviceName.

Parameters
deviceName | device name
function | measurement function. default is DCVolt
powerLineFrequency | powerLineFreqency,default is 50Hz

◆ JY8902Task() [3/4]

JY8902.JY8902Task.JY8902Task ( int slot )

Constructor, Used to create an DMM task by a slot number.

Parameters
slot slot number

◆ JY8902Task() [4/4]

JY8902.JY8902Task.JY8902Task | ( | int | slot,
 |  | MeasurementFunction | function,
 |  | double | powerLineFrequency = 50 )

Constructor, Used to create an DMM task by a slot number.

Parameters
slot | slot number
function | measurement function. default is DCVolt
powerLineFrequency | powerLineFreqency,default is 50Hz

Member Function Documentation

◆ ReadMultiPoint()

void JY8902.JY8902Task.ReadMultiPoint | ( | ref double[] | measureValues,
 |  | uint | numToRead = 1,
 |  | int | timeout = -1 )

Read multi measurement values.

Available when Mode Not is MeasurementMode.SinglePoint

Parameters
measureValues | measure values buffer
numToRead | number to read
timeout | The maximum time allowed for the measurement to complete in milliseconds

◆ ReadRawMultiPoint()

void JY8902.JY8902Task.ReadRawMultiPoint | ( | ref int[] | measureValues,
 |  | uint | numToRead = 1,
 |  | int | timeout = -1 )
Parameters
measureValues
numToRead
timeout

◆ ReadRawSinglePoint()

void JY8902.JY8902Task.ReadRawSinglePoint | ( | ref double | measureValue,
 |  | int | timeout = 10000 )

Read one raw measurement voltage value .

Available when Mode is MeasurementMode.SinglePoint

Parameters
measureValue | measureValue
timeout | The maximum time allowed for the measurement to complete in milliseconds

◆ ReadSinglePoint()

void JY8902.JY8902Task.ReadSinglePoint | ( | ref double | measureValue,
 |  | int | timeout = 10000 )

Read one measurement value .

Available when Mode is MeasurementMode.SinglePoint

Parameters
measureValue | measureValue
timeout | The maximum time allowed for the measurement to complete in milliseconds

◆ SendSoftwareTrigger()

void JY8902.JY8902Task.SendSoftwareTrigger ( )

Send software trigger.

◆ Start()

void JY8902.JY8902Task.Start ( )

Start measurement.

◆ Stop()

void JY8902.JY8902Task.Stop ( )

Stop measurement.

Member Data Documentation

◆ Running

bool JY8902.JY8902Task.Running = false

◆ Sampling

Sampling JY8902.JY8902Task.Sampling

set aperture/NPLC

Property Documentation

◆ ACCurrent

ACCurrent JY8902.JY8902Task.ACCurrent
getset

AC current.

◆ ACVolt

ACVolt JY8902.JY8902Task.ACVolt
get

AC voltage.

◆ AvailableSamples

int JY8902.JY8902Task.AvailableSamples
get

Number of samples per channel that can be read in the buffer .

Valid when Mode is NOT MeasurementMode.SinglePoint.

◆ BufLenInSamples

int JY8902.JY8902Task.BufLenInSamples
get

Number of samples can be storage in the buffer, the Proprety MultiPoint.SampleCount must be less than or equal to this value.

◆ DCCurrent

DCCurrent JY8902.JY8902Task.DCCurrent
get

DC current.

◆ DCVolt

DCVolt JY8902.JY8902Task.DCVolt
get

DC voltage.

◆ Device

JY8902Device JY8902.JY8902Task.Device
get

Device Handle.

◆ DisableCalibration

bool JY8902.JY8902Task.DisableCalibration
getset

Disable Calibration,true is disable, false is not disable.

defalut is false;

◆ Function

MeasurementFunction JY8902.JY8902Task.Function
getset

Measurement Function, support DCVolt/ACVolt/DCCurrent/ACCurrent/Resistance2Wire/Resistance4Wire, default is DCVolt.

◆ IsOverRange

bool JY8902.JY8902Task.IsOverRange
get

Measurement is over range.

◆ Mode

MeasurementMode JY8902.JY8902Task.Mode
getset

Measurement Mode, support SinglePoint/MultiPoint/ContinuousMultiPoint, default is SinglePoint.

◆ MultiPoint

MultiPoint JY8902.JY8902Task.MultiPoint
get

Multi Point Configuration.Valid when Mode is NOT MeasurementMode.SinglePoint.

◆ PowerLineFrequency

PowerLineFrequency JY8902.JY8902Task.PowerLineFrequency
getset

Configures the power line frequency of the DMM, valid value is 50/60 Hz.

◆ Resistance2Wire

Resistance2Wire JY8902.JY8902Task.Resistance2Wire
get

2 wire resistance measurement.

◆ Resistance4Wire

Resistance4Wire JY8902.JY8902Task.Resistance4Wire
get

4 wire resistance measurement.

◆ SignalExport

DMMSignalExport JY8902.JY8902Task.SignalExport
getset

Signal Export.

◆ TempInformation

TempInfor JY8902.JY8902Task.TempInformation
get

Get Temprature Information.

◆ TransferedSamples

ulong JY8902.JY8902Task.TransferedSamples
get

The number of samples that have been transfered from the local buffer.

Valid when Mode is NOT MeasurementMode.SinglePoint.

◆ Trigger

TriggerIn JY8902.JY8902Task.Trigger
get

Trigger Configuration.

◆ TriggerOut

TriggerOut JY8902.JY8902Task.TriggerOut
getset

Measure Complete Signal Out.

The documentation for this class was generated from the following file:
  • D:/8902/C#/JYPXIe8902Task.cs


8902 C# Programming Manual: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
▼N JY8902 |
C ACCurrent | AC current
C ACVolt | AC voltage
C DCCurrent | DC current
C DCVolt | DC voltage
C DigitalTrigger | Digital trigger class
C DMMSignalExport | DMM Signal Export Class
C JY8902Task | DMM Task
C MultiPoint | 多点设置
C Resistance2Wire | Resistance 2 wire
C Resistance4Wire | Resistance 2 wire
C SampleClock | Sample clock configuration class
C Sampling | Sampling
C TempInfor | TempInfor struct
C TriggerIn | 触发设置类


8902 C# Programming Manual: Member List

  • ACCurrent
JY8902.ACCurrent Member List

This is the complete list of members for JY8902.ACCurrent, including all inherited members.

Range JY8902.ACCurrent


8902 C# Programming Manual: Member List

  • ACVolt
JY8902.ACVolt Member List

This is the complete list of members for JY8902.ACVolt, including all inherited members.

Range JY8902.ACVolt


8902 C# Programming Manual: Member List

  • DCCurrent
JY8902.DCCurrent Member List

This is the complete list of members for JY8902.DCCurrent, including all inherited members.

Range JY8902.DCCurrent


8902 C# Programming Manual: Member List

  • DCVolt
JY8902.DCVolt Member List

This is the complete list of members for JY8902.DCVolt, including all inherited members.

Range JY8902.DCVolt


8902 C# Programming Manual: Member List

  • DMMSignalExport
JY8902.DMMSignalExport Member List

This is the complete list of members for JY8902.DMMSignalExport, including all inherited members.

Add(DMMSignalExportSource source, SignalExportDestination destination) | JY8902.DMMSignalExport
Add(DMMSignalExportSource source, List< SignalExportDestination > destinations) | JY8902.DMMSignalExport
Clear(SignalExportDestination destination) | JY8902.DMMSignalExport
ClearAll() | JY8902.DMMSignalExport


8902 C# Programming Manual: Member List

  • DigitalTrigger
JY8902.DigitalTrigger Member List

This is the complete list of members for JY8902.DigitalTrigger, including all inherited members.

Edge | JY8902.DigitalTrigger
Source | JY8902.DigitalTrigger


8902 C# Programming Manual: Member List

  • JY8902Task
JY8902.JY8902Task Member List

This is the complete list of members for JY8902.JY8902Task, including all inherited members.

ACCurrent | JY8902.JY8902Task
ACVolt | JY8902.JY8902Task
AvailableSamples | JY8902.JY8902Task
BufLenInSamples | JY8902.JY8902Task
DCCurrent | JY8902.JY8902Task
DCVolt | JY8902.JY8902Task
Device | JY8902.JY8902Task
DisableCalibration | JY8902.JY8902Task
Function | JY8902.JY8902Task
IsOverRange | JY8902.JY8902Task
JY8902Task(string deviceName) | JY8902.JY8902Task
JY8902Task(string deviceName, MeasurementFunction function=MeasurementFunction.DCVolt, PowerLineFrequency powerLineFrequency=PowerLineFrequency._50Hz) | JY8902.JY8902Task
JY8902Task(int slot) | JY8902.JY8902Task
JY8902Task(int slot, MeasurementFunction function, double powerLineFrequency=50) | JY8902.JY8902Task
Mode | JY8902.JY8902Task
MultiPoint | JY8902.JY8902Task
PowerLineFrequency | JY8902.JY8902Task
ReadMultiPoint(ref double[] measureValues, uint numToRead=1, int timeout=-1) | JY8902.JY8902Task
ReadRawMultiPoint(ref int[] measureValues, uint numToRead=1, int timeout=-1) | JY8902.JY8902Task
ReadRawSinglePoint(ref double measureValue, int timeout=10000) | JY8902.JY8902Task
ReadSinglePoint(ref double measureValue, int timeout=10000) | JY8902.JY8902Task
Resistance2Wire | JY8902.JY8902Task
Resistance4Wire | JY8902.JY8902Task
Running | JY8902.JY8902Task
Sampling | JY8902.JY8902Task
SendSoftwareTrigger() | JY8902.JY8902Task
SignalExport | JY8902.JY8902Task
Start() | JY8902.JY8902Task
Stop() | JY8902.JY8902Task
TempInformation | JY8902.JY8902Task
TransferedSamples | JY8902.JY8902Task
Trigger | JY8902.JY8902Task
TriggerOut | JY8902.JY8902Task


8902 C# Programming Manual: Member List

  • MultiPoint
JY8902.MultiPoint Member List

This is the complete list of members for JY8902.MultiPoint, including all inherited members.

SampleCount | JY8902.MultiPoint
SampleInterval | JY8902.MultiPoint
SampleTrigger | JY8902.MultiPoint


8902 C# Programming Manual: Member List

  • Resistance2Wire
JY8902.Resistance2Wire Member List

This is the complete list of members for JY8902.Resistance2Wire, including all inherited members.

Range JY8902.Resistance2Wire


8902 C# Programming Manual: Member List

  • Resistance4Wire
JY8902.Resistance4Wire Member List

This is the complete list of members for JY8902.Resistance4Wire, including all inherited members.

Range JY8902.Resistance4Wire


8902 C# Programming Manual: Member List

  • SampleClock
JY8902.SampleClock Member List

This is the complete list of members for JY8902.SampleClock, including all inherited members.

Source JY8902.SampleClock


8902 C# Programming Manual: Member List

  • Sampling
JY8902.Sampling Member List

This is the complete list of members for JY8902.Sampling, including all inherited members.

Aperture | JY8902.Sampling
NPLC | JY8902.Sampling
Type | JY8902.Sampling


8902 C# Programming Manual: Member List

  • TriggerIn
JY8902.TriggerIn Member List

This is the complete list of members for JY8902.TriggerIn, including all inherited members.

Delay | JY8902.TriggerIn
Digital | JY8902.TriggerIn
Type | JY8902.TriggerIn


8902 C# Programming Manual: Class Index

Class Index
A | D | J | M | R | S | T
A
ACCurrent (JY8902)
ACVolt (JY8902)
D
DCCurrent (JY8902)
DCVolt (JY8902)
DigitalTrigger (JY8902)
DMMSignalExport (JY8902)
J
JY8902Task (JY8902)
M
MultiPoint (JY8902)
R
Resistance2Wire (JY8902)
Resistance4Wire (JY8902)
S
SampleClock (JY8902)
Sampling (JY8902)
T
TempInfor (JY8902)
TriggerIn (JY8902)


8902 C# Programming Manual: D:/8902 Directory Reference

  • File List
  • 8902
8902 Directory Reference

Directories

C#


8902 C# Programming Manual: File List

  • File List
File List
Here is a list of all files with brief descriptions:
[detail level 123]
▼ 8902
▼ C#
ClassDefination.cs
EnumDefination.cs
JYPXIe8902Task.cs


8902 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • j
  • l
  • m
  • n
  • p
  • r
  • s
  • t
Here is a list of all class members with links to the classes they belong to:

- a -

  • ACCurrent : JY8902.JY8902Task
  • ACVolt : JY8902.JY8902Task
  • Add() : JY8902.DMMSignalExport
  • Aperture : JY8902.Sampling
  • AvailableSamples : JY8902.JY8902Task

- b -

  • BufLenInSamples : JY8902.JY8902Task

- c -

  • ch1Temp : JY8902.TempInfor
  • ch2Temp : JY8902.TempInfor
  • ch3Temp : JY8902.TempInfor
  • Clear() : JY8902.DMMSignalExport
  • ClearAll() : JY8902.DMMSignalExport

- d -

  • DCCurrent : JY8902.JY8902Task
  • DCVolt : JY8902.JY8902Task
  • Delay : JY8902.TriggerIn
  • Device : JY8902.JY8902Task
  • Digital : JY8902.TriggerIn
  • DisableCalibration : JY8902.JY8902Task

- e -

  • Edge : JY8902.DigitalTrigger

- f -

  • Function : JY8902.JY8902Task

- i -

  • IsOverRange : JY8902.JY8902Task

- j -

  • JY8902Task() : JY8902.JY8902Task

- l -

  • localTemp : JY8902.TempInfor

- m -

  • Mode : JY8902.JY8902Task
  • MultiPoint : JY8902.JY8902Task

- n -

  • NPLC : JY8902.Sampling

- p -

  • PowerLineFrequency : JY8902.JY8902Task

- r -

  • Range : JY8902.ACCurrent, JY8902.ACVolt, JY8902.DCCurrent, JY8902.DCVolt, JY8902.Resistance2Wire, JY8902.Resistance4Wire
  • ReadMultiPoint() : JY8902.JY8902Task
  • ReadRawMultiPoint() : JY8902.JY8902Task
  • ReadRawSinglePoint() : JY8902.JY8902Task
  • ReadSinglePoint() : JY8902.JY8902Task
  • Resistance2Wire : JY8902.JY8902Task
  • Resistance4Wire : JY8902.JY8902Task
  • Running : JY8902.JY8902Task

- s -

  • SampleCount : JY8902.MultiPoint
  • SampleInterval : JY8902.MultiPoint
  • SampleTrigger : JY8902.MultiPoint
  • Sampling : JY8902.JY8902Task
  • SendSoftwareTrigger() : JY8902.JY8902Task
  • SignalExport : JY8902.JY8902Task
  • Source : JY8902.DigitalTrigger, JY8902.SampleClock
  • Start() : JY8902.JY8902Task
  • Stop() : JY8902.JY8902Task

- t -

  • TempInformation : JY8902.JY8902Task
  • TransferedSamples : JY8902.JY8902Task
  • Trigger : JY8902.JY8902Task
  • TriggerOut : JY8902.JY8902Task
  • Type : JY8902.Sampling, JY8902.TriggerIn


8902 C# Programming Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • Properties
Here is a list of all functions with links to the classes they belong to:
  • Add() : JY8902.DMMSignalExport
  • Clear() : JY8902.DMMSignalExport
  • ClearAll() : JY8902.DMMSignalExport
  • JY8902Task() : JY8902.JY8902Task
  • ReadMultiPoint() : JY8902.JY8902Task
  • ReadRawMultiPoint() : JY8902.JY8902Task
  • ReadRawSinglePoint() : JY8902.JY8902Task
  • ReadSinglePoint() : JY8902.JY8902Task
  • SendSoftwareTrigger() : JY8902.JY8902Task
  • Start() : JY8902.JY8902Task
  • Stop() : JY8902.JY8902Task


8902 C# Programming Manual: Class Members - Properties

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • d
  • e
  • f
  • i
  • m
  • n
  • p
  • r
  • s
  • t
Here is a list of all properties with links to the classes they belong to:

- a -

  • ACCurrent : JY8902.JY8902Task
  • ACVolt : JY8902.JY8902Task
  • Aperture : JY8902.Sampling
  • AvailableSamples : JY8902.JY8902Task

- b -

  • BufLenInSamples : JY8902.JY8902Task

- d -

  • DCCurrent : JY8902.JY8902Task
  • DCVolt : JY8902.JY8902Task
  • Delay : JY8902.TriggerIn
  • Device : JY8902.JY8902Task
  • Digital : JY8902.TriggerIn
  • DisableCalibration : JY8902.JY8902Task

- e -

  • Edge : JY8902.DigitalTrigger

- f -

  • Function : JY8902.JY8902Task

- i -

  • IsOverRange : JY8902.JY8902Task

- m -

  • Mode : JY8902.JY8902Task
  • MultiPoint : JY8902.JY8902Task

- n -

  • NPLC : JY8902.Sampling

- p -

  • PowerLineFrequency : JY8902.JY8902Task

- r -

  • Range : JY8902.ACCurrent, JY8902.ACVolt, JY8902.DCCurrent, JY8902.DCVolt, JY8902.Resistance2Wire, JY8902.Resistance4Wire
  • Resistance2Wire : JY8902.JY8902Task
  • Resistance4Wire : JY8902.JY8902Task

- s -

  • SampleCount : JY8902.MultiPoint
  • SampleInterval : JY8902.MultiPoint
  • SampleTrigger : JY8902.MultiPoint
  • SignalExport : JY8902.JY8902Task
  • Source : JY8902.DigitalTrigger, JY8902.SampleClock

- t -

  • TempInformation : JY8902.JY8902Task
  • TransferedSamples : JY8902.JY8902Task
  • Trigger : JY8902.JY8902Task
  • TriggerOut : JY8902.JY8902Task
  • Type : JY8902.TriggerIn


8902 C# Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Properties
Here is a list of all variables with links to the classes they belong to:
  • ch1Temp : JY8902.TempInfor
  • ch2Temp : JY8902.TempInfor
  • ch3Temp : JY8902.TempInfor
  • localTemp : JY8902.TempInfor
  • Running : JY8902.JY8902Task
  • Sampling : JY8902.JY8902Task
  • Type : JY8902.Sampling


8902 C# Programming Manual: Main Page

8902 C# Programming Manual Documentation


8902 C# Programming Manual: JY8902 Namespace Reference

  • Package List
  • Package Members
Classes | Enumerations
JY8902 Namespace Reference

Classes

class | ACCurrent
AC current. More...
class | ACVolt
AC voltage. More...
class | DCCurrent
DC current. More...
class | DCVolt
DC voltage. More...
class | DigitalTrigger
Digital trigger class. More...
class | DMMSignalExport
DMM Signal Export Class. More...
class | JY8902Task
DMM Task. More...
class | MultiPoint
多点设置 More...
class | Resistance2Wire
resistance 2 wire. More...
class | Resistance4Wire
resistance 2 wire. More...
class | SampleClock
Sample clock configuration class. More...
class | Sampling
Sampling. More...
struct | TempInfor
tempInfor struct More...
class | TriggerIn
触发设置类 More...

Enumerations

enum | SampleClockSource { Internal = 0 , External = 1 }
ClockSource Type. More...
enum | MeasurementMode { SinglePoint , MultiPoint , ContinuousMultiPoint }
DMM Meaurement Mode. More...
enum MeasurementFunction : int {
DCVolt , ACVolt , DCCurrent , ACCurrent ,
Resistance2Wire , Resistance4Wire
}
DMM Measurement Function. More...
enum | SamplingType { Aperture , NPLC }
sampling parameter type, set Aperture or set NPLC More...
enum DCVoltRange {
Auto = 0 , _200mV , _2V , _20V ,
_240V
}
DC RANGE. More...
enum | DCCurrentRange { Auto , _20mA , _200mA , _1000mA }
DC RANGE. More...
enum | ACCurrentRange { Auto , _20mA , _200mA , _1000mA }
DC RANGE. More...
enum ACVoltRange {
Auto , _200mV , _2V , _20V ,
_240V
}
AC RANGE. More...
enum Resistance2WireRange {
Auto , _100 , _1K , _10K ,
_100K , _1M , _10M , _100M
}
Resistance 2Wire Range. More...
enum Resistance4WireRange {
Auto , _100 , _1K , _10K ,
_100K , _1M
}
Resistance 4Wire Range. More...
enum | TriggerType : int { Immediate , Software , Digital }
Trigger Type. More...
enum DigitalTriggerSource {
PFI0 = JY8902Import.JY8902_DigitalTriggerSource_PFI_0 , PFI1 = JY8902Import.JY8902_DigitalTriggerSource_PFI_1 , PXI_Trig0 = JY8902Import.JY8902_DigitalTriggerSource_PXI_0 , PXI_Trig1 = JY8902Import.JY8902_DigitalTriggerSource_PXI_1 ,
PXI_Trig2 = JY8902Import.JY8902_DigitalTriggerSource_PXI_2 , PXI_Trig3 = JY8902Import.JY8902_DigitalTriggerSource_PXI_3 , PXI_Trig4 = JY8902Import.JY8902_DigitalTriggerSource_PXI_4 , PXI_Trig5 = JY8902Import.JY8902_DigitalTriggerSource_PXI_5 ,
PXI_Trig6 = JY8902Import.JY8902_DigitalTriggerSource_PXI_6 , PXI_Trig7 = JY8902Import.JY8902_DigitalTriggerSource_PXI_7
}
Digital trigger source. More...
enum SampleTrigger : int {
Immediate = -1 , PFI0 = JY8902Import.JY8902_DigitalTriggerSource_PFI_0 , PFI1 = JY8902Import.JY8902_DigitalTriggerSource_PFI_1 , PXI_Trig0 = JY8902Import.JY8902_DigitalTriggerSource_PXI_0 ,
PXI_Trig1 = JY8902Import.JY8902_DigitalTriggerSource_PXI_1 , PXI_Trig2 = JY8902Import.JY8902_DigitalTriggerSource_PXI_2 , PXI_Trig3 = JY8902Import.JY8902_DigitalTriggerSource_PXI_3 , PXI_Trig4 = JY8902Import.JY8902_DigitalTriggerSource_PXI_4 ,
PXI_Trig5 = JY8902Import.JY8902_DigitalTriggerSource_PXI_5 , PXI_Trig6 = JY8902Import.JY8902_DigitalTriggerSource_PXI_6 , PXI_Trig7 = JY8902Import.JY8902_DigitalTriggerSource_PXI_7
}
Digital trigger source. More...
enum | MeasurementTriggerEdge { Rising , Falling }
trigger edge More...
enum SignalExportDestination {
None = JY8902Import.JY8902_None , PFI0 = JY8902Import.JY8902_TriggerOut_PFI_0 , PFI1 = JY8902Import.JY8902_TriggerOut_PFI_1 , PXI_Trig0 = JY8902Import.JY8902_TriggerOut_PXI_0 ,
PXI_Trig1 = JY8902Import.JY8902_TriggerOut_PXI_1 , PXI_Trig2 = JY8902Import.JY8902_TriggerOut_PXI_2 , PXI_Trig3 = JY8902Import.JY8902_TriggerOut_PXI_3 , PXI_Trig4 = JY8902Import.JY8902_TriggerOut_PXI_4 ,
PXI_Trig5 = JY8902Import.JY8902_TriggerOut_PXI_5 , PXI_Trig6 = JY8902Import.JY8902_TriggerOut_PXI_6 , PXI_Trig7 = JY8902Import.JY8902_TriggerOut_PXI_7
}
Rout measurement complete signal to the destination. More...
enum TriggerOut {
None = JY8902Import.JY8902_None , PFI0 = JY8902Import.JY8902_TriggerOut_PFI_0 , PFI1 = JY8902Import.JY8902_TriggerOut_PFI_1 , PXI_Trig0 = JY8902Import.JY8902_TriggerOut_PXI_0 ,
PXI_Trig1 = JY8902Import.JY8902_TriggerOut_PXI_0 , PXI_Trig2 = JY8902Import.JY8902_TriggerOut_PXI_0 , PXI_Trig3 = JY8902Import.JY8902_TriggerOut_PXI_0 , PXI_Trig4 = JY8902Import.JY8902_TriggerOut_PXI_0 ,
PXI_Trig5 = JY8902Import.JY8902_TriggerOut_PXI_0 , PXI_Trig6 = JY8902Import.JY8902_TriggerOut_PXI_0 , PXI_Trig7 = JY8902Import.JY8902_TriggerOut_PXI_0
}
Rout trigger out signal to the destination. More...
enum | DMMSignalExportSource { MeasureComplete = JY8902Import.JY8902_Signal_MeasureComplete }
AI Signal Export Source. More...
enum | PowerLineFrequency { _50Hz , _60Hz }
AC Power Frequency. More...

Enumeration Type Documentation

◆ ACCurrentRange

enum JY8902.ACCurrentRange

DC RANGE.

Enumerator
Auto |
_20mA | 20mA Range
_200mA | 200mA Range
_1000mA | 1000mA Range

◆ ACVoltRange

enum JY8902.ACVoltRange

AC RANGE.

Enumerator
Auto |
_200mV | 200mV Range
_2V | 2V Range
_20V | 20V Range
_240V | 240V Range

◆ DCCurrentRange

enum JY8902.DCCurrentRange

DC RANGE.

Enumerator
Auto |
_20mA | 20mA Range
_200mA | 200mA Range
_1000mA | 1000mA Range

◆ DCVoltRange

enum JY8902.DCVoltRange

DC RANGE.

Enumerator
Auto |
_200mV | 200mV range
_2V | 2V range
_20V | 20V range
_240V | 240V range

◆ DigitalTriggerSource

enum JY8902.DigitalTriggerSource

Digital trigger source.

Enumerator
PFI0 |
PFI1 |
PXI_Trig0 | PXI_Trig0 as the digital trigger source.
PXI_Trig1 | PXI_Trig1 as the digital trigger source.
PXI_Trig2 | PXI_Trig2 as the digital trigger source.
PXI_Trig3 | PXI_Trig3 as the digital trigger source.
PXI_Trig4 | PXI_Trig4 as the digital trigger source.
PXI_Trig5 | PXI_Trig5 as the digital trigger source.
PXI_Trig6 | PXI_Trig6 as the digital trigger source.
PXI_Trig7 | PXI_Trig7 as the digital trigger source.

◆ DMMSignalExportSource

enum JY8902.DMMSignalExportSource

AI Signal Export Source.

Enumerator
MeasureComplete

Measure Complete Signal.

◆ MeasurementFunction

enum JY8902.MeasurementFunction : int

DMM Measurement Function.

Enumerator
DCVolt | Sets the DMM to measure DC voltage.
ACVolt | Sets the DMM to measure AC voltage.
DCCurrent | Sets the DMM to measure DC current.
ACCurrent | Sets the DMM to measure AC current.
Resistance2Wire | Sets the DMM to measure 2-wire resistance.
Resistance4Wire | Sets the DMM to measure 4-wire resistance.

◆ MeasurementMode

enum JY8902.MeasurementMode

DMM Meaurement Mode.

Enumerator
SinglePoint | SinglePoint Meaurement.
MultiPoint | MultiPoint Meaurement.
ContinuousMultiPoint | ContinuousMultiPoint Meaurement.

◆ MeasurementTriggerEdge

enum JY8902.MeasurementTriggerEdge

trigger edge

Enumerator
Rising | Rising edge.
Falling | Falling edge.

◆ PowerLineFrequency

enum JY8902.PowerLineFrequency

AC Power Frequency.

Enumerator
_50Hz | 50 Hz AC Power Frequency
_60Hz | 60 Hz AC Power Frequency

◆ Resistance2WireRange

enum JY8902.Resistance2WireRange

Resistance 2Wire Range.

Enumerator
Auto |
_100 | 100Ω Range
_1K | 1KΩ Range
_10K | 10KΩ Range
_100K | 100KΩ Range
_1M | 1MΩ Range
_10M | 10MΩ Range
_100M | 100MΩ Range

◆ Resistance4WireRange

enum JY8902.Resistance4WireRange

Resistance 4Wire Range.

Enumerator
Auto |
_100 | 100Ω Range
_1K | 1KΩ Range
_10K | 10KΩ Range
_100K | 100KΩ Range
_1M | 1MΩ Range

◆ SampleClockSource

enum JY8902.SampleClockSource

ClockSource Type.

Enumerator
Internal | Internal.
External | External

◆ SampleTrigger

enum JY8902.SampleTrigger : int

Digital trigger source.

Enumerator
Immediate |
PFI0 |
PFI1 |
PXI_Trig0 | PXI_Trig0 as the digital trigger source.
PXI_Trig1 | PXI_Trig1 as the digital trigger source.
PXI_Trig2 | PXI_Trig2 as the digital trigger source.
PXI_Trig3 | PXI_Trig3 as the digital trigger source.
PXI_Trig4 | PXI_Trig4 as the digital trigger source.
PXI_Trig5 | PXI_Trig5 as the digital trigger source.
PXI_Trig6 | PXI_Trig6 as the digital trigger source.
PXI_Trig7 | PXI_Trig7 as the digital trigger source.

◆ SamplingType

enum JY8902.SamplingType

sampling parameter type, set Aperture or set NPLC

Enumerator
Aperture | Aperture.
NPLC | NPLC.

◆ SignalExportDestination

enum JY8902.SignalExportDestination

Rout measurement complete signal to the destination.

Enumerator
None | The measurement complete signal is not routed.
PFI0 | Rout the measurement complete signal to PFI0.
PFI1 | Rout the measurement complete signal to PFI1.
PXI_Trig0 | Rout the measurement complete signal to PXI_Trig0.
PXI_Trig1 | Rout the measurement complete signal to PXI_Trig1.
PXI_Trig2 | Rout the measurement complete signal to PXI_Trig2.
PXI_Trig3 | Rout the measurement complete signal to PXI_Trig3.
PXI_Trig4 | Rout the measurement complete signal to PXI_Trig4.
PXI_Trig5 | Rout the measurement complete signal to PXI_Trig5.
PXI_Trig6 | Rout the measurement complete signal to PXI_Trig6.
PXI_Trig7 | Rout the measurement complete signal to PXI_Trig7.

◆ TriggerOut

enum JY8902.TriggerOut

Rout trigger out signal to the destination.

Enumerator
None | The measurement complete signal is not routed.
PFI0 | Rout the measurement complete signal to PFI0.
PFI1 | Rout the measurement complete signal to PFI1.
PXI_Trig0 | Rout the measurement complete signal to PXI_Trig0.
PXI_Trig1 | Rout the measurement complete signal to PXI_Trig1.
PXI_Trig2 | Rout the measurement complete signal to PXI_Trig2.
PXI_Trig3 | Rout the measurement complete signal to PXI_Trig3.
PXI_Trig4 | Rout the measurement complete signal to PXI_Trig4.
PXI_Trig5 | Rout the measurement complete signal to PXI_Trig5.
PXI_Trig6 | Rout the measurement complete signal to PXI_Trig6.
PXI_Trig7 | Rout the measurement complete signal to PXI_Trig7.

◆ TriggerType

enum JY8902.TriggerType : int

Trigger Type.

Enumerator
Immediate | Immediate Trigger.
Software | Software Trigger.
Digital | Digital Trigger.


8902 C# Programming Manual: Package Members

  • Package List
  • Package Members
  • All
  • Enumerations
Here is a list of all namespace members with links to the namespace documentation for each member:
  • ACCurrentRange : JY8902
  • ACVoltRange : JY8902
  • DCCurrentRange : JY8902
  • DCVoltRange : JY8902
  • DigitalTriggerSource : JY8902
  • DMMSignalExportSource : JY8902
  • MeasurementFunction : JY8902
  • MeasurementMode : JY8902
  • MeasurementTriggerEdge : JY8902
  • PowerLineFrequency : JY8902
  • Resistance2WireRange : JY8902
  • Resistance4WireRange : JY8902
  • SampleClockSource : JY8902
  • SampleTrigger : JY8902
  • SamplingType : JY8902
  • SignalExportDestination : JY8902
  • TriggerOut : JY8902
  • TriggerType : JY8902


8902 C# Programming Manual: Package Members

  • Package List
  • Package Members
  • All
  • Enumerations
Here is a list of all namespace enums with links to the namespace documentation for each enum:
  • ACCurrentRange : JY8902
  • ACVoltRange : JY8902
  • DCCurrentRange : JY8902
  • DCVoltRange : JY8902
  • DigitalTriggerSource : JY8902
  • DMMSignalExportSource : JY8902
  • MeasurementFunction : JY8902
  • MeasurementMode : JY8902
  • MeasurementTriggerEdge : JY8902
  • PowerLineFrequency : JY8902
  • Resistance2WireRange : JY8902
  • Resistance4WireRange : JY8902
  • SampleClockSource : JY8902
  • SampleTrigger : JY8902
  • SamplingType : JY8902
  • SignalExportDestination : JY8902
  • TriggerOut : JY8902
  • TriggerType : JY8902


8902 C# Programming Manual: Package List

  • Package List
  • Package Members
Package List
Here are the packages with brief descriptions (if available):
N JY8902


8902 C# Programming Manual: Member List

  • TempInfor
JY8902.TempInfor Member List

This is the complete list of members for JY8902.TempInfor, including all inherited members.

ch1Temp | JY8902.TempInfor
ch2Temp | JY8902.TempInfor
ch3Temp | JY8902.TempInfor
localTemp | JY8902.TempInfor