9511 C# Programming Manual: D:/OneDrive/Desktop/9511/C# Directory Reference

9511 C# Programming Manual
  • C#
C# Directory Reference

Files

         AIChannel.cs
AIDigitalFiltering.cs
AISignalExport.cs
AISync.cs
AITrigger.cs
JY9511AITask.cs
JY9511AOTask.cs
JY9511CITask.cs
ReferenceClock.cs
TEDSCommon.cs
Generated by doxygen 1.15.0


9511 C# Programming Manual: D:/OneDrive/Desktop/9511/C#/AIChannel.cs File Reference

Classes | Namespaces | Enumerations
AIChannel.cs File Reference

Classes

class JY9511.AIChannel
AI Channel. More...

Namespaces

namespace JY9511

Enumerations

enum | JY9511.Coupling { JY9511.AC = JY9511Import.JY9511_Coupling_AC , JY9511.DC = JY9511Import.JY9511_Coupling_DC }
Coupling. More...
enum | JY9511.AITerminal { JY9511.PseudoDifferential = JY9511Import.JY9511_PseDiff , JY9511.Differential = JY9511Import.JY9511_Diff }
AITerminal. More...


9511 C# Programming Manual: JY9511.AIChannel Class Reference

  • Main Page
  • Packages
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JY9511
  • AIChannel
Properties | List of all members
JY9511.AIChannel Class Reference

AI Channel. More...

Properties

int | ChannelID [get]
Channel ID.
double | RangeHigh [get]
Upper limit of range.
double | RangeLow [get]
Lower limit of range.
Coupling | Coupling [get]
Coupling.
bool | IEPEEnabled [get]
IEPE enabled.
AITerminal | Terminal [get, set]
Configure AI terminal.
double | RawDataScaleFactor [get]
This fator is used to convert RawData(binary) to Data(voltage in V).

Detailed Description

AI Channel.

Property Documentation

◆ ChannelID

int JY9511.AIChannel.ChannelID
get

Channel ID.

◆ Coupling

Coupling JY9511.AIChannel.Coupling
get

Coupling.

◆ IEPEEnabled

bool JY9511.AIChannel.IEPEEnabled
get

IEPE enabled.

◆ RangeHigh

double JY9511.AIChannel.RangeHigh
get

Upper limit of range.

◆ RangeLow

double JY9511.AIChannel.RangeLow
get

Lower limit of range.

◆ RawDataScaleFactor

double JY9511.AIChannel.RawDataScaleFactor
get

This fator is used to convert RawData(binary) to Data(voltage in V).

RawData * factor = Data

◆ Terminal

AITerminal JY9511.AIChannel.Terminal
getset

Configure AI terminal.

(Differential,PseudoDifference)

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/9511/C#/AIChannel.cs


9511 C# Programming Manual: JY9511 Namespace Reference

  • Packages
  • Classes
  • Files
  • Package List
  • Package Members
Namespaces | Classes | Enumerations
JY9511 Namespace Reference

Namespaces

namespace TEDS

Classes

class | AIChannel
AI Channel. More...
class | AIDigitalFiltering
AI Digital Filtering Connfiguration Class. More...
class | LowPassFilter
Low-Pass Filter Configuration Class. More...
class | AISignalExport
AI Signal Export Class. More...
class | Sync
class | AIDigitalTrigger
AI Digital trigger params. More...
class | AIAnalogTrigger
AI Analog Trigger. More...
class | AIAnalogHysteresisComparator
AI Analog Hysteresis Comparator. More...
class | AIAnalogWindowComparator
AI Analog Window Comparator. More...
class | AIAnalogEdgeComparator
AI Analog Edge Comparator. More...
class | AITrigger
AI Trigger params. More...
class | JY9511AITask
JY9511 AI Task. More...
class | AIRecord
AI Record class. More...
class | JY9511AOTask
JY9511 Analog Ouput Task. More...
class | AOChannel
AO Channel parameter class . More...
class | AOTrigger
Constructor to create an AOTrigger task object. More...
class | DDSConfig
DDS waveform configuration class. More...
class | AODigitalTrigger
AO Digital trigger . More...
class | AOSignalExport
AO Signal Export Class. More...
class | JY9511CITask
JY9511 Counter Input Task. More...
class | CISampleClock
CI Sample Clock class. More...
class | CIInternalSampleClock
CI Internal Sample Clock Configuration Class. More...
class | CIImplicitSampleClock
CI Implicit Sample Clock class. More...
class | CIExternalSampleClock
CI Implicit Sample Clock class. More...
class | CIExternalTimebase
class | CIAIMCLKTimebase
class | CITimebase
class | EdgeCounting
Configure CI EdgeCounting. More...
class | PauseTrigger
Pause trigger configuration class. More...
class | FrequencyMeas
Configure CI Measure. More...
class | PeriodMeas
Configure CI Measure. More...
class | PulseMeas
Configure CI Measure. More...
class | SemiPeriodMeas
Configure CI Measure. More...
class | CITrigger
Constructor to create an CITrigger task object. More...
class | CIDigitalTrigger
CI Digital trigger . More...
class | CISignalExport
CI Signal Export Class. More...
class | ExternalReferenceClock
class | ReferenceClock

Enumerations

enum | Coupling { AC = JY9511Import.JY9511_Coupling_AC , DC = JY9511Import.JY9511_Coupling_DC }
Coupling. More...
enum | AITerminal { PseudoDifferential = JY9511Import.JY9511_PseDiff , Differential = JY9511Import.JY9511_Diff }
AITerminal. More...
enum | LPFMode { Normal = 0 , WideBandwidth = 1 }
Low-Pass Filter Mode Enum. More...
enum | AISignalExportSource { StartTrig = JY9511Import.JY9511_AI_StartTrig , ReferenceTrig = JY9511Import.JY9511_AI_ReferenceTrig }
AI Signal Export Source Enum. More...
enum SignalExportDestination {
Ext_Trig = JY9511Import.JY9511_DigitalTriggerSource_External , PXI_Trig0 = JY9511Import.JY9511_DigitalTriggerSource_BUS_0 , PXI_Trig1 = JY9511Import.JY9511_DigitalTriggerSource_BUS_1 , PXI_Trig2 = JY9511Import.JY9511_DigitalTriggerSource_BUS_2 ,
PXI_Trig3 = JY9511Import.JY9511_DigitalTriggerSource_BUS_3 , PXI_Trig4 = JY9511Import.JY9511_DigitalTriggerSource_BUS_4 , PXI_Trig5 = JY9511Import.JY9511_DigitalTriggerSource_BUS_5 , PXI_Trig6 = JY9511Import.JY9511_DigitalTriggerSource_BUS_6 ,
PXI_Trig7 = JY9511Import.JY9511_DigitalTriggerSource_BUS_7
}
Signal Export Destination Enum. More...
enum | SyncTopology { Independent = JY9511Import.JY9511_SyncMode_Sole , Master = JY9511Import.JY9511_SyncMode_Master , Slave = JY9511Import.JY9511_SyncMode_Slave }
Multi-Device Sync Topology. More...
enum SyncTerminal {
Ext_Trig = JY9511Import.JY9511_DigitalTriggerSource_External , PXI_Trig0 = JY9511Import.JY9511_DigitalTriggerSource_BUS_0 , PXI_Trig1 = JY9511Import.JY9511_DigitalTriggerSource_BUS_1 , PXI_Trig2 = JY9511Import.JY9511_DigitalTriggerSource_BUS_2 ,
PXI_Trig3 = JY9511Import.JY9511_DigitalTriggerSource_BUS_3 , PXI_Trig4 = JY9511Import.JY9511_DigitalTriggerSource_BUS_4 , PXI_Trig5 = JY9511Import.JY9511_DigitalTriggerSource_BUS_5 , PXI_Trig6 = JY9511Import.JY9511_DigitalTriggerSource_BUS_6 ,
PXI_Trig7 = JY9511Import.JY9511_DigitalTriggerSource_BUS_7
}
AI digital trigger source enum type. More...
enum | AITriggerMode { Start , Reference }
AI trigger mode enum type. More...
enum | AITriggerType { Immediately = JY9511Import.JY9511_TriggerType_Immediately , Digital = JY9511Import.JY9511_TriggerType_Digital , Software = JY9511Import.JY9511_TriggerType_Software , Analog = JY9511Import.JY9511_TriggerType_Analog }
AI trigger type enum type. More...
enum AIDigitalTriggerSource {
Ext_Trig = JY9511Import.JY9511_DigitalTriggerSource_External , PXI_Trig0 = JY9511Import.JY9511_DigitalTriggerSource_BUS_0 , PXI_Trig1 = JY9511Import.JY9511_DigitalTriggerSource_BUS_1 , PXI_Trig2 = JY9511Import.JY9511_DigitalTriggerSource_BUS_2 ,
PXI_Trig3 = JY9511Import.JY9511_DigitalTriggerSource_BUS_3 , PXI_Trig4 = JY9511Import.JY9511_DigitalTriggerSource_BUS_4 , PXI_Trig5 = JY9511Import.JY9511_DigitalTriggerSource_BUS_5 , PXI_Trig6 = JY9511Import.JY9511_DigitalTriggerSource_BUS_6 ,
PXI_Trig7 = JY9511Import.JY9511_DigitalTriggerSource_BUS_7 , AO_StartTrig = JY9511Import.JY9511_AO_StartTrig
}
AI digital trigger source enum type. More...
enum | AIDigitalTriggerEdge { Rising = JY9511Import.JY9511_DigitalTriggerEdge_Rising , Falling = JY9511Import.JY9511_DigitalTriggerEdge_Falling }
AI digital trigger edge enum type. More...
enum | AIAnalogTriggerSource { Channel_0 , Channel_1 , Channel_2 , Channel_3 }
AI Analog Trigger Source. More...
enum | AIAnalogTriggerComparator { Edge , Hysteresis , Window }
AI Analog Trigger Comparator. More...
enum | AIAnalogTriggerEdge { Rising , Falling }
AI Analog Trigger Edge. More...
enum | AIAnalogWindowCondition { Entering , Leaving }
AI Analog Window Trigger Condition. More...
enum | AIMode { Finite = JY9511Import.JY9511_AI_Finite , Continuous = JY9511Import.JY9511_AI_Continuous , Single = JY9511Import.JY9511_AI_Single , Record = 0x3 }
AI mode enum type. More...
enum SamplingState {
Idle = 1 << 0 , WaitingForStart = 1 << 1 , PreSampling = 1 << 2 , WaitingForRefTrigger = 1 << 3 ,
PostSampling = 1 << 4 , RecordCompleted = 1 << 5 , WaitingForAdvanceTrigger = 1 << 6 , Done = 1 << 7
}
Sampling State Enum. More...
enum | IEPEConnectionStatus { Normal = 0 , OpenCircuit = 1 , ShortCircuit = 2 }
IEPE Connection Status. More...
enum | FileFormat { Bin }
Streaming file format. More...
enum | RecordMode { Finite , Infinite }
Two stream mode from enum Finite/Infinite. More...
enum | AOTerminal { PseudoDifferential = JY9511Import.JY9511_PseDiff , Differential = JY9511Import.JY9511_Diff }
AOTerminal. More...
enum | AODigitalTriggerEdge { Rising , Falling }
AO Digital Trigger Edge. More...
enum AODigitalTriggerSource {
Ext_Trig = JY9511Import.JY9511_DigitalTriggerSource_External , PXI_Trig0 = JY9511Import.JY9511_DigitalTriggerSource_BUS_0 , PXI_Trig1 = JY9511Import.JY9511_DigitalTriggerSource_BUS_1 , PXI_Trig2 = JY9511Import.JY9511_DigitalTriggerSource_BUS_2 ,
PXI_Trig3 = JY9511Import.JY9511_DigitalTriggerSource_BUS_3 , PXI_Trig4 = JY9511Import.JY9511_DigitalTriggerSource_BUS_4 , PXI_Trig5 = JY9511Import.JY9511_DigitalTriggerSource_BUS_5 , PXI_Trig6 = JY9511Import.JY9511_DigitalTriggerSource_BUS_6 ,
PXI_Trig7 = JY9511Import.JY9511_DigitalTriggerSource_BUS_7 , AI_StartTrig = JY9511Import.JY9511_AI_StartTrig , AI_ReferenceTrig = JY9511Import.JY9511_AI_ReferenceTrig
}
AO Digital trigger source. More...
enum | AOMode { Finite = 0 , ContinuousNoWrapping = 2 , ContinuousWrapping = 1 , DDS =3 }
AOMode. More...
enum | AOSignalExportSource { StartTrig = JY9511Import.JY9511_AO_StartTrig }
SourceSignal. More...
enum | AOTriggerType { Immediate = JY9511Import.JY9511_TriggerType_Immediately , Digital = JY9511Import.JY9511_TriggerType_Digital , Soft = JY9511Import.JY9511_TriggerType_Software }
TriggerType Digital/Immediate/Soft. More...
enum | CountDirection { Up = JY9511Import.JY9511_CI_Count_Up , Down = JY9511Import.JY9511_CI_Count_Down }
Counter direction. More...
enum | CIMode { Single = 2 , Finite = 0 , Continuous = 1 }
CIMode. More...
enum CIType {
EdgeCounting , Period , Frequency , Pulse ,
SemiPeriod
}
Counter Input Application Type. More...
enum ClockTerminal {
PXI_Trig0 = JY9511Import.JY9511_Clock_PXI_Trig_0 , PXI_Trig1 = JY9511Import.JY9511_Clock_PXI_Trig_1 , PXI_Trig2 = JY9511Import.JY9511_Clock_PXI_Trig_2 , PXI_Trig3 = JY9511Import.JY9511_Clock_PXI_Trig_3 ,
PXI_Trig4 = JY9511Import.JY9511_Clock_PXI_Trig_4 , PXI_Trig5 = JY9511Import.JY9511_Clock_PXI_Trig_5 , PXI_Trig6 = JY9511Import.JY9511_Clock_PXI_Trig_6 , PXI_Trig7 = JY9511Import.JY9511_Clock_PXI_Trig_7
}
External Sample Clock Terminal. More...
enum | CISampleClockSource { Implicit = JY9511Import.JY9511_CI_ImplicitClock , Internal = JY9511Import.JY9511_CI_InternalClock , External = JY9511Import.JY9511_CI_ExternalClock }
CI Sample Clock Source. More...
enum | EdgeType { Rising , Falling , Any }
Edge Type. More...
enum CITimebaseSource {
Internal100MHz = 0 , Internal5MHz = 1 , Internal100kHz = 2 , External = 3 ,
AI_MCLK = 4
}
enum | EdgeCntOunEvtIdleState { LowLevel = 0 , HighLevel = 1 }
Output idle state when the event has not occurred. More...
enum | LevelPolarity { LowLevel = 0 , HighLevel = 1 , None = 2 }
Edge counting output event configuration class. More...
enum | ValueReturnMode { TwoValue , OneValue }
Configure CI Measure. More...
enum | QuadEncodingType { X1 , X2 , X4 }
Quadrature Encoding Type. More...
enum | CITriggerType { Immediate = JY9511Import.JY9511_CIO_Immediately , Digital = JY9511Import.JY9511_CIO_Digital , Soft = JY9511Import.JY9511_CIO_Soft }
Configure CI Measure. More...
enum CIDigitalTriggerSource {
PXI_Trig0 = JY9511Import.JY9511_DigitalTriggerSource_BUS_0 , PXI_Trig1 = JY9511Import.JY9511_DigitalTriggerSource_BUS_1 , PXI_Trig2 = JY9511Import.JY9511_DigitalTriggerSource_BUS_2 , PXI_Trig3 = JY9511Import.JY9511_DigitalTriggerSource_BUS_3 ,
PXI_Trig4 = JY9511Import.JY9511_DigitalTriggerSource_BUS_4 , PXI_Trig5 = JY9511Import.JY9511_DigitalTriggerSource_BUS_5 , PXI_Trig6 = JY9511Import.JY9511_DigitalTriggerSource_BUS_6 , PXI_Trig7 = JY9511Import.JY9511_DigitalTriggerSource_BUS_7
}
CI Digital trigger source. More...
enum | CIDigitalTriggerEdge { Rising }
CI Digital Trigger Edge. More...
enum InputTerminal {
PFI0 = JY9511Import.JY9511_PFI0_Input , PXI_Trig0 = JY9511Import.JY9511_PXI_Trig0_Input , PXI_Trig1 = JY9511Import.JY9511_PXI_Trig1_Input , PXI_Trig2 = JY9511Import.JY9511_PXI_Trig2_Input ,
PXI_Trig3 = JY9511Import.JY9511_PXI_Trig3_Input , PXI_Trig4 = JY9511Import.JY9511_PXI_Trig4_Input , PXI_Trig5 = JY9511Import.JY9511_PXI_Trig5_Input , PXI_Trig6 = JY9511Import.JY9511_PXI_Trig6_Input ,
PXI_Trig7 = JY9511Import.JY9511_PXI_Trig7_Input
}
输入终端 More...
enum TimebaseExternalTerminal {
PXI_Trig0 = JY9511Import.JY9511_PXI_Trig0_Input , PXI_Trig1 = JY9511Import.JY9511_PXI_Trig1_Input , PXI_Trig2 = JY9511Import.JY9511_PXI_Trig2_Input , PXI_Trig3 = JY9511Import.JY9511_PXI_Trig3_Input ,
PXI_Trig4 = JY9511Import.JY9511_PXI_Trig4_Input , PXI_Trig5 = JY9511Import.JY9511_PXI_Trig5_Input , PXI_Trig6 = JY9511Import.JY9511_PXI_Trig6_Input , PXI_Trig7 = JY9511Import.JY9511_PXI_Trig7_Input
}
输入终端 More...
enum IOTerminal {
PFI0 = JY9511Import.JY9511_DigitalTriggerOut_PFI_0 , PXI_Trig0 = JY9511Import.JY9511_TriggerOut_PXI_0 , PXI_Trig1 = JY9511Import.JY9511_TriggerOut_PXI_1 , PXI_Trig2 = JY9511Import.JY9511_TriggerOut_PXI_2 ,
PXI_Trig3 = JY9511Import.JY9511_TriggerOut_PXI_3 , PXI_Trig4 = JY9511Import.JY9511_TriggerOut_PXI_4 , PXI_Trig5 = JY9511Import.JY9511_TriggerOut_PXI_5 , PXI_Trig6 = JY9511Import.JY9511_TriggerOut_PXI_6 ,
PXI_Trig7 = JY9511Import.JY9511_TriggerOut_PXI_7 , None = 9
}
IO终端=信号的目的地（共9个） More...
enum | CISignalExportSource { StartTrig , SampleClock , EventOut }
SourceSignal. More...
enum | ExternalReferenceClockTerminal { PXIe_Clk100 = JY9511Import.JY9511_PXIe_Clk100 }
enum | ReferenceClockSource { Internal = 0 , External = 1 }

Enumeration Type Documentation

◆ AIAnalogTriggerComparator

enum JY9511.AIAnalogTriggerComparator

AI Analog Trigger Comparator.

Enumerator
Edge | Edge Comparator.
Hysteresis | Hysteresis Comparator.
Window | Window Comparator.

◆ AIAnalogTriggerEdge

enum JY9511.AIAnalogTriggerEdge

AI Analog Trigger Edge.

Enumerator
Rising | Rising.
Falling | Falling.

◆ AIAnalogTriggerSource

enum JY9511.AIAnalogTriggerSource

AI Analog Trigger Source.

Enumerator
Channel_0 | Channel 0.
Channel_1 | Channel 1.
Channel_2 | Channel 2.
Channel_3 | Channel 3.

◆ AIAnalogWindowCondition

enum JY9511.AIAnalogWindowCondition

AI Analog Window Trigger Condition.

Enumerator
Entering | Rising.
Leaving | Falling.

◆ AIDigitalTriggerEdge

enum JY9511.AIDigitalTriggerEdge

AI digital trigger edge enum type.

Enumerator
Rising | Rising edge.
Falling | Falling edge.

◆ AIDigitalTriggerSource

enum JY9511.AIDigitalTriggerSource

AI digital trigger source enum type.

Enumerator
Ext_Trig | External Trigger.
PXI_Trig0 | PXI Trigger 0.
PXI_Trig1 | PXI Trigger 1.
PXI_Trig2 | PXI Trigger 2.
PXI_Trig3 | PXI Trigger 3.
PXI_Trig4 | PXI Trigger 4.
PXI_Trig5 | PXI Trigger 5.
PXI_Trig6 | PXI Trigger 6.
PXI_Trig7 | PXI Trigger 7.
AO_StartTrig | AO_StartTrig.

◆ AIMode

enum JY9511.AIMode

AI mode enum type.

Enumerator
Finite | Finite mode.
Continuous | Continuous mode.
Single | Single point mode.
Record | Record.

◆ AISignalExportSource

enum JY9511.AISignalExportSource

AI Signal Export Source Enum.

Enumerator
StartTrig | AI_StartTrig.
ReferenceTrig | AI_ReferenceTrig.

◆ AITerminal

enum JY9511.AITerminal

AITerminal.

Enumerator
PseudoDifferential | PseudoDifferential.
Differential | Differential.

◆ AITriggerMode

enum JY9511.AITriggerMode

AI trigger mode enum type.

Enumerator
Start | Start trigger.
Reference | Reference trigger. Only valid in the Finite mode.

◆ AITriggerType

enum JY9511.AITriggerType

AI trigger type enum type.

Enumerator
Immediately | Immediately, no trigger.
Digital | Digital trigger.
Software | Software trigger.
Analog | Analog trigger.

◆ AODigitalTriggerEdge

enum JY9511.AODigitalTriggerEdge

AO Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.

◆ AODigitalTriggerSource

enum JY9511.AODigitalTriggerSource

AO Digital trigger source.

Enumerator
Ext_Trig | External Trigger.
PXI_Trig0 | PXI Trigger 0.
PXI_Trig1 | PXI Trigger 1.
PXI_Trig2 | PXI Trigger 2.
PXI_Trig3 | PXI Trigger 3.
PXI_Trig4 | PXI Trigger 4.
PXI_Trig5 | PXI Trigger 5.
PXI_Trig6 | PXI Trigger 6.
PXI_Trig7 | PXI Trigger 7.
AI_StartTrig | AI_StartTrig.
AI_ReferenceTrig | AI_ReferenceTrig.

◆ AOMode

enum JY9511.AOMode

AOMode.

Enumerator
Finite | Finite.
ContinuousNoWrapping | ContinuousNoWrapping.
ContinuousWrapping | ContinuousWrapping.
DDS | Direct Digital Synthesis.

◆ AOSignalExportSource

enum JY9511.AOSignalExportSource

SourceSignal.

Enumerator
StartTrig

AO_StartTrig.

◆ AOTerminal

enum JY9511.AOTerminal

AOTerminal.

Enumerator
PseudoDifferential | PseudoDifferential.
Differential | Differential.

◆ AOTriggerType

enum JY9511.AOTriggerType

TriggerType Digital/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ CIDigitalTriggerEdge

enum JY9511.CIDigitalTriggerEdge

CI Digital Trigger Edge.

Enumerator
Rising

RisingEdge.

◆ CIDigitalTriggerSource

enum JY9511.CIDigitalTriggerSource

CI Digital trigger source.

(共32个）

Enumerator
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.

◆ CIMode

enum JY9511.CIMode

CIMode.

Enumerator
Single | Single.
Finite | Finite.
Continuous | Continuous.

◆ CISampleClockSource

enum JY9511.CISampleClockSource

CI Sample Clock Source.

Enumerator
Implicit | Implicit.
Internal | Internal.
External | External.

◆ CISignalExportSource

enum JY9511.CISignalExportSource

SourceSignal.

Enumerator
StartTrig | CI_StartTrig.
SampleClock | CI_SampleClock.
EventOut | EventOut.

◆ CITimebaseSource

enum JY9511.CITimebaseSource

时基源

Timebase source

Enumerator
Internal100MHz | 内部100MHz时基 Internal 100MHz Timebase
Internal5MHz | 内部5MHz时基 Internal 5MHz Timebase
Internal100kHz | 内部100kHz时基 Internal 100kHz Timebase
External | 外部时基 External Timebase
AI_MCLK | AI_MCLK Timebase.

◆ CITriggerType

enum JY9511.CITriggerType

Configure CI Measure.

Configure CI Measure.

TriggerType Digital/Immediate/Soft

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ CIType

enum JY9511.CIType

Counter Input Application Type.

Enumerator
EdgeCounting | Edge Counting.
Period | Period Measure.
Frequency | Frequenc Measure.
Pulse | Pulse Measure.
SemiPeriod | SemiPeriod Measure.

◆ ClockTerminal

enum JY9511.ClockTerminal

External Sample Clock Terminal.

Enumerator
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.

◆ CountDirection

enum JY9511.CountDirection

Counter direction.

enum Up/Down/External

Enumerator
Up | Counter increases.
Down | Counter decreases.

◆ Coupling

enum JY9511.Coupling

Coupling.

Enumerator
AC | AC.
DC | DC.

◆ EdgeCntOunEvtIdleState

enum JY9511.EdgeCntOunEvtIdleState

Output idle state when the event has not occurred.

Enumerator
LowLevel | Idle state is low level.
HighLevel | Idle state is high level.

◆ EdgeType

enum JY9511.EdgeType

Edge Type.

Enumerator
Rising | Rising Edge.
Falling | Falling Edge.
Any | Any Edge.

◆ ExternalReferenceClockTerminal

enum JY9511.ExternalReferenceClockTerminal

外部参考时钟输入端口

External Reference Clcok Terminal

Enumerator
PXIe_Clk100

PXIe_DStarA

PXIe_DStarA

◆ FileFormat

enum JY9511.FileFormat

Streaming file format.

Enumerator
Bin

Binary file format.

◆ IEPEConnectionStatus

enum JY9511.IEPEConnectionStatus

IEPE Connection Status.

Enumerator
Normal | Normal.
OpenCircuit | Open circuit.
ShortCircuit | Short circuit.

◆ InputTerminal

enum JY9511.InputTerminal

输入终端

Enumerator
PFI0 | PFI_0.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.

◆ IOTerminal

enum JY9511.IOTerminal

IO终端=信号的目的地（共9个）

Enumerator
PFI0 | PFI_0.
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
None | None.

◆ LevelPolarity

enum JY9511.LevelPolarity

Edge counting output event configuration class.

Level Polarity

Enumerator
LowLevel | Low level.
HighLevel | High level.
None | No active polarity.

◆ LPFMode

enum JY9511.LPFMode

Low-Pass Filter Mode Enum.

Enumerator
Normal | Normal Mode. It has 0.4Fs bandwidth, medium latency, and a maximum sample rate of 256kSa/s
WideBandwidth | Wide Bandwidth Mode. It has 0.4535Fs bandwidth, high latency, and a maximum sample rate of 128kSa/s

◆ QuadEncodingType

enum JY9511.QuadEncodingType

Quadrature Encoding Type.

Enumerator
X1 | X1.
X2 | X2.
X4 | X4.

◆ RecordMode

enum JY9511.RecordMode

Two stream mode from enum Finite/Infinite.

Enumerator
Finite | Finite Streaming.
Infinite | InFinite Streaming.

◆ ReferenceClockSource

enum JY9511.ReferenceClockSource

Reference Clock Source

Enumerator
Internal | Internal Reference Clock
External | External Reference Clock

◆ SamplingState

enum JY9511.SamplingState

Sampling State Enum.

Enumerator
Idle | Idle.
WaitingForStart | Waiting for start trigger.
PreSampling | Pre-sampling.
WaitingForRefTrigger | Waiting for reference trigger.
PostSampling | Post-sampling.
RecordCompleted | Record completed.
WaitingForAdvanceTrigger | Waiting for advance trigger.
Done | Done.

◆ SignalExportDestination

enum JY9511.SignalExportDestination

Signal Export Destination Enum.

Enumerator
Ext_Trig | External Trigger.
PXI_Trig0 | PXI Trigger 0.
PXI_Trig1 | PXI Trigger 1.
PXI_Trig2 | PXI Trigger 2.
PXI_Trig3 | PXI Trigger 3.
PXI_Trig4 | PXI Trigger 4.
PXI_Trig5 | PXI Trigger 5.
PXI_Trig6 | PXI Trigger 6.
PXI_Trig7 | PXI Trigger 7.

◆ SyncTerminal

enum JY9511.SyncTerminal

AI digital trigger source enum type.

Enumerator
Ext_Trig | External Trigger.
PXI_Trig0 | PXI Trigger 0.
PXI_Trig1 | PXI Trigger 1.
PXI_Trig2 | PXI Trigger 2.
PXI_Trig3 | PXI Trigger 3.
PXI_Trig4 | PXI Trigger 4.
PXI_Trig5 | PXI Trigger 5.
PXI_Trig6 | PXI Trigger 6.
PXI_Trig7 | PXI Trigger 7.

◆ SyncTopology

enum JY9511.SyncTopology

Multi-Device Sync Topology.

Enumerator
Independent | Independent.
Master | As the master device in the master-slave synchronization.
Slave | As the slave card in the master-slave synchronization.

◆ TimebaseExternalTerminal

enum JY9511.TimebaseExternalTerminal

输入终端

Enumerator
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.

◆ ValueReturnMode

enum JY9511.ValueReturnMode

Configure CI Measure.

TwoEdgeSeparation value return mode.only for TwoEdgeSeparation type.

Enumerator
TwoValue | Return two data simultaneously. first data is gate to aux edge separation, second data is aux to gate edge separation.
OneValue | only return gate to aux edge separation


9511 C# Programming Manual: D:/OneDrive/Desktop/9511/C#/AIDigitalFiltering.cs File Reference

Classes | Namespaces | Enumerations
AIDigitalFiltering.cs File Reference

Classes

class | JY9511.AIDigitalFiltering
AI Digital Filtering Connfiguration Class. More...
class | JY9511.LowPassFilter
Low-Pass Filter Configuration Class. More...

Namespaces

namespace JY9511

Enumerations

enum JY9511.LPFMode { JY9511.Normal = 0 , JY9511.WideBandwidth = 1 }
Low-Pass Filter Mode Enum. More...


9511 C# Programming Manual: JY9511.AIDigitalFiltering Class Reference

  • Class List
  • Class Index
  • Class Members
  • JY9511
  • AIDigitalFiltering
Properties | List of all members
JY9511.AIDigitalFiltering Class Referencesealed

AI Digital Filtering Connfiguration Class. More...

Properties

LowPassFilter LPF [get]
Low-Pass Filter (or called Anti-Aliasing Filter) Parametes.

Detailed Description

AI Digital Filtering Connfiguration Class.

Property Documentation

◆ LPF

LowPassFilter JY9511.AIDigitalFiltering.LPF
get

Low-Pass Filter (or called Anti-Aliasing Filter) Parametes.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/9511/C#/AIDigitalFiltering.cs


9511 C# Programming Manual: JY9511.LowPassFilter Class Reference

  • JY9511
  • LowPassFilter
Properties | List of all members
JY9511.LowPassFilter Class Referencesealed

Low-Pass Filter Configuration Class. More...

Properties

LPFMode Mode [get, set]
Low-Pass Filter Mode.

Detailed Description

Low-Pass Filter Configuration Class.

Property Documentation

◆ Mode

LPFMode JY9511.LowPassFilter.Mode
getset

Low-Pass Filter Mode.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/9511/C#/AIDigitalFiltering.cs


9511 C# Programming Manual: D:/OneDrive/Desktop/9511/C#/AISignalExport.cs File Reference

Classes | Namespaces | Enumerations
AISignalExport.cs File Reference

Classes

class JY9511.AISignalExport
AI Signal Export Class. More...

Namespaces

namespace JY9511

Enumerations

enum JY9511.AISignalExportSource { JY9511.StartTrig = JY9511Import.JY9511_AI_StartTrig , JY9511.ReferenceTrig = JY9511Import.JY9511_AI_ReferenceTrig }
AI Signal Export Source Enum. More...
enum JY9511.SignalExportDestination {
JY9511.Ext_Trig = JY9511Import.JY9511_DigitalTriggerSource_External , JY9511.PXI_Trig0 = JY9511Import.JY9511_DigitalTriggerSource_BUS_0 , JY9511.PXI_Trig1 = JY9511Import.JY9511_DigitalTriggerSource_BUS_1 , JY9511.PXI_Trig2 = JY9511Import.JY9511_DigitalTriggerSource_BUS_2 ,
JY9511.PXI_Trig3 = JY9511Import.JY9511_DigitalTriggerSource_BUS_3 , JY9511.PXI_Trig4 = JY9511Import.JY9511_DigitalTriggerSource_BUS_4 , JY9511.PXI_Trig5 = JY9511Import.JY9511_DigitalTriggerSource_BUS_5 , JY9511.PXI_Trig6 = JY9511Import.JY9511_DigitalTriggerSource_BUS_6 ,
JY9511.PXI_Trig7 = JY9511Import.JY9511_DigitalTriggerSource_BUS_7
}
Signal Export Destination Enum. More...


9511 C# Programming Manual: JY9511.AISignalExport Class Reference

  • AISignalExport
Public Member Functions | List of all members
JY9511.AISignalExport Class Reference

AI Signal Export Class. More...

Public Member Functions

void | Add (AISignalExportSource source, SignalExportDestination destination)
Export one signal to desination.
void | Add (AISignalExportSource source, List< SignalExportDestination > destinations)
Export one signal to mutil desinations.
void | Clear (SignalExportDestination destination)
Clear one signal export.
void | ClearAll ()
Clear all signal export.

Detailed Description

AI Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY9511.AISignalExport.Add | ( | AISignalExportSource | source,
 |  | List< SignalExportDestination > | destinations )

Export one signal to mutil desinations.

Parameters
source | AI Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY9511.AISignalExport.Add | ( | AISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one signal to desination.

Parameters
source | AI Signal Source
destination | Export Desination

◆ Clear()

void JY9511.AISignalExport.Clear ( SignalExportDestination destination )

Clear one signal export.

Parameters
destination Export Desination

◆ ClearAll()

void JY9511.AISignalExport.ClearAll ( )

Clear all signal export.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/9511/C#/AISignalExport.cs


9511 C# Programming Manual: D:/OneDrive/Desktop/9511/C#/AISync.cs File Reference

Classes | Namespaces | Enumerations
AISync.cs File Reference

Classes

class JY9511.Sync

Namespaces

namespace JY9511

Enumerations

enum JY9511.SyncTopology { JY9511.Independent = JY9511Import.JY9511_SyncMode_Sole , JY9511.Master = JY9511Import.JY9511_SyncMode_Master , JY9511.Slave = JY9511Import.JY9511_SyncMode_Slave }
Multi-Device Sync Topology. More...
enum JY9511.SyncTerminal {
JY9511.Ext_Trig = JY9511Import.JY9511_DigitalTriggerSource_External , JY9511.PXI_Trig0 = JY9511Import.JY9511_DigitalTriggerSource_BUS_0 , JY9511.PXI_Trig1 = JY9511Import.JY9511_DigitalTriggerSource_BUS_1 , JY9511.PXI_Trig2 = JY9511Import.JY9511_DigitalTriggerSource_BUS_2 ,
JY9511.PXI_Trig3 = JY9511Import.JY9511_DigitalTriggerSource_BUS_3 , JY9511.PXI_Trig4 = JY9511Import.JY9511_DigitalTriggerSource_BUS_4 , JY9511.PXI_Trig5 = JY9511Import.JY9511_DigitalTriggerSource_BUS_5 , JY9511.PXI_Trig6 = JY9511Import.JY9511_DigitalTriggerSource_BUS_6 ,
JY9511.PXI_Trig7 = JY9511Import.JY9511_DigitalTriggerSource_BUS_7
}
AI digital trigger source enum type. More...


9511 C# Programming Manual: JY9511.Sync Class Reference

  • Sync
Properties | List of all members
JY9511.Sync Class Referencesealed

Properties

SyncTopology | Topology [get, set]
Sync Topology Configuration.
SyncTerminal | Terminal [get, set]
Sync Trigger Signal Routing Terminal.
bool | Synchronized [get]
This device has bee synchronized.

Detailed Description

同步配置类

Sync Configuration Class

Property Documentation

◆ Synchronized

bool JY9511.Sync.Synchronized
get

This device has bee synchronized.

◆ Terminal

SyncTerminal JY9511.Sync.Terminal
getset

Sync Trigger Signal Routing Terminal.

◆ Topology

SyncTopology JY9511.Sync.Topology
getset

Sync Topology Configuration.

The default value is SyncTopology.Independent.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/9511/C#/AISync.cs


9511 C# Programming Manual: D:/OneDrive/Desktop/9511/C#/AITrigger.cs File Reference

Classes | Namespaces | Enumerations
AITrigger.cs File Reference

Classes

class | JY9511.AIDigitalTrigger
AI Digital trigger params. More...
class | JY9511.AIAnalogTrigger
AI Analog Trigger. More...
class | JY9511.AIAnalogHysteresisComparator
AI Analog Hysteresis Comparator. More...
class | JY9511.AIAnalogWindowComparator
AI Analog Window Comparator. More...
class | JY9511.AIAnalogEdgeComparator
AI Analog Edge Comparator. More...
class | JY9511.AITrigger
AI Trigger params. More...

Namespaces

namespace JY9511

Enumerations

enum | JY9511.AITriggerMode { JY9511.Start , JY9511.Reference }
AI trigger mode enum type. More...
enum | JY9511.AITriggerType { JY9511.Immediately = JY9511Import.JY9511_TriggerType_Immediately , JY9511.Digital = JY9511Import.JY9511_TriggerType_Digital , JY9511.Software = JY9511Import.JY9511_TriggerType_Software , JY9511.Analog = JY9511Import.JY9511_TriggerType_Analog }
AI trigger type enum type. More...
enum JY9511.AIDigitalTriggerSource {
JY9511.Ext_Trig = JY9511Import.JY9511_DigitalTriggerSource_External , JY9511.PXI_Trig0 = JY9511Import.JY9511_DigitalTriggerSource_BUS_0 , JY9511.PXI_Trig1 = JY9511Import.JY9511_DigitalTriggerSource_BUS_1 , JY9511.PXI_Trig2 = JY9511Import.JY9511_DigitalTriggerSource_BUS_2 ,
JY9511.PXI_Trig3 = JY9511Import.JY9511_DigitalTriggerSource_BUS_3 , JY9511.PXI_Trig4 = JY9511Import.JY9511_DigitalTriggerSource_BUS_4 , JY9511.PXI_Trig5 = JY9511Import.JY9511_DigitalTriggerSource_BUS_5 , JY9511.PXI_Trig6 = JY9511Import.JY9511_DigitalTriggerSource_BUS_6 ,
JY9511.PXI_Trig7 = JY9511Import.JY9511_DigitalTriggerSource_BUS_7 , JY9511.AO_StartTrig = JY9511Import.JY9511_AO_StartTrig
}
AI digital trigger source enum type. More...
enum | JY9511.AIDigitalTriggerEdge { JY9511.Rising = JY9511Import.JY9511_DigitalTriggerEdge_Rising , JY9511.Falling = JY9511Import.JY9511_DigitalTriggerEdge_Falling }
AI digital trigger edge enum type. More...
enum | JY9511.AIAnalogTriggerSource { JY9511.Channel_0 , JY9511.Channel_1 , JY9511.Channel_2 , JY9511.Channel_3 }
AI Analog Trigger Source. More...
enum | JY9511.AIAnalogTriggerComparator { JY9511.Edge , JY9511.Hysteresis , JY9511.Window }
AI Analog Trigger Comparator. More...
enum | JY9511.AIAnalogTriggerEdge { JY9511.Rising , JY9511.Falling }
AI Analog Trigger Edge. More...
enum | JY9511.AIAnalogWindowCondition { JY9511.Entering , JY9511.Leaving }
AI Analog Window Trigger Condition. More...


9511 C# Programming Manual: JY9511.AIDigitalTrigger Class Reference

  • AIDigitalTrigger
Properties | List of all members
JY9511.AIDigitalTrigger Class Referencesealed

AI Digital trigger params. More...

Properties

AIDigitalTriggerSource | Source [get, set]
AI digital trigger source.
AIDigitalTriggerEdge | Edge [get, set]
AI digital trigger effective edge.

Detailed Description

AI Digital trigger params.

Property Documentation

◆ Edge

AIDigitalTriggerEdge JY9511.AIDigitalTrigger.Edge
getset

AI digital trigger effective edge.

◆ Source

AIDigitalTriggerSource JY9511.AIDigitalTrigger.Source
getset

AI digital trigger source.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/9511/C#/AITrigger.cs


9511 C# Programming Manual: JY9511.AIAnalogTrigger Class Reference

  • AIAnalogTrigger
Properties | List of all members
JY9511.AIAnalogTrigger Class Referencesealed

AI Analog Trigger. More...

Properties

AIAnalogTriggerSource | Source [get, set]
Analog Trigger source.
AIAnalogTriggerComparator | Comparator [get, set]
AI Analog Trigger Comparator.
AIAnalogEdgeComparator | Edge [get, set]
AI Analog Edge Comparator.
AIAnalogHysteresisComparator | Hysteresis [get, set]
AI Analog Hysteresis Comparatorr.
AIAnalogWindowComparator | Window [get, set]
AI Analog Window Comparatorr.

Detailed Description

AI Analog Trigger.

Property Documentation

◆ Comparator

AIAnalogTriggerComparator JY9511.AIAnalogTrigger.Comparator
getset

AI Analog Trigger Comparator.

◆ Edge

AIAnalogEdgeComparator JY9511.AIAnalogTrigger.Edge
getset

AI Analog Edge Comparator.

◆ Hysteresis

AIAnalogHysteresisComparator JY9511.AIAnalogTrigger.Hysteresis
getset

AI Analog Hysteresis Comparatorr.

◆ Source

AIAnalogTriggerSource JY9511.AIAnalogTrigger.Source
getset

Analog Trigger source.

◆ Window

AIAnalogWindowComparator JY9511.AIAnalogTrigger.Window
getset

AI Analog Window Comparatorr.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/9511/C#/AITrigger.cs


9511 C# Programming Manual: JY9511.AIAnalogHysteresisComparator Class Reference

  • AIAnalogHysteresisComparator
Public Attributes | Properties | List of all members
JY9511.AIAnalogHysteresisComparator Class Reference

AI Analog Hysteresis Comparator. More...

Public Attributes

double | HighThreshold
High Threshold.
double | LowThreshold
Low Threshold.

Properties

AIAnalogTriggerEdge Slope [get, set]
AI Analog Trigger Edge.

Detailed Description

AI Analog Hysteresis Comparator.

Member Data Documentation

◆ HighThreshold

double JY9511.AIAnalogHysteresisComparator.HighThreshold

High Threshold.

◆ LowThreshold

double JY9511.AIAnalogHysteresisComparator.LowThreshold

Low Threshold.

Property Documentation

◆ Slope

AIAnalogTriggerEdge JY9511.AIAnalogHysteresisComparator.Slope
getset

AI Analog Trigger Edge.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/9511/C#/AITrigger.cs


9511 C# Programming Manual: JY9511.AIAnalogWindowComparator Class Reference

  • AIAnalogWindowComparator
Public Attributes | Properties | List of all members
JY9511.AIAnalogWindowComparator Class Reference

AI Analog Window Comparator. More...

Public Attributes

double | HighThreshold
High Threshold.
double | LowThreshold
Low Threshold.

Properties

AIAnalogWindowCondition Condition [get, set]
AI Analog Window Condition.

Detailed Description

AI Analog Window Comparator.

Member Data Documentation

◆ HighThreshold

double JY9511.AIAnalogWindowComparator.HighThreshold

High Threshold.

◆ LowThreshold

double JY9511.AIAnalogWindowComparator.LowThreshold

Low Threshold.

Property Documentation

◆ Condition

AIAnalogWindowCondition JY9511.AIAnalogWindowComparator.Condition
getset

AI Analog Window Condition.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/9511/C#/AITrigger.cs


9511 C# Programming Manual: JY9511.AIAnalogEdgeComparator Class Reference

  • AIAnalogEdgeComparator
Public Attributes | Properties | List of all members
JY9511.AIAnalogEdgeComparator Class Reference

AI Analog Edge Comparator. More...

Public Attributes

double Threshold
Threshold.

Properties

AIAnalogTriggerEdge Slope [get, set]
AI Analog Trigger Edge.

Detailed Description

AI Analog Edge Comparator.

Member Data Documentation

◆ Threshold

double JY9511.AIAnalogEdgeComparator.Threshold

Threshold.

Property Documentation

◆ Slope

AIAnalogTriggerEdge JY9511.AIAnalogEdgeComparator.Slope
getset

AI Analog Trigger Edge.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/9511/C#/AITrigger.cs


9511 C# Programming Manual: JY9511.AITrigger Class Reference

  • AITrigger
Properties | List of all members
JY9511.AITrigger Class Referencesealed

AI Trigger params. More...

Properties

AITriggerType | Type [get, set]
AI trigger type.
AITriggerMode | Mode [get, set]
AI trigger mode.
AIDigitalTrigger | Digital [get]
AI digital trigger params.
AIAnalogTrigger | Analog [get]
AI analog trigger params.
int | ReTriggerCount [get, set]
Number of repeat triggers.
uint | PreTriggerSamples [get, set]
AI pretrigger points.

Detailed Description

AI Trigger params.

Property Documentation

◆ Analog

AIAnalogTrigger JY9511.AITrigger.Analog
get

AI analog trigger params.

◆ Digital

AIDigitalTrigger JY9511.AITrigger.Digital
get

AI digital trigger params.

◆ Mode

AITriggerMode JY9511.AITrigger.Mode
getset

AI trigger mode.

enum Start/Reference.

◆ PreTriggerSamples

uint JY9511.AITrigger.PreTriggerSamples
getset

AI pretrigger points.

Only valid in the reference trigger mode.

◆ ReTriggerCount

int JY9511.AITrigger.ReTriggerCount
getset

Number of repeat triggers.

No repeat the trigger when 0 or 1, or the number of repeated triggers.

◆ Type

AITriggerType JY9511.AITrigger.Type
getset

AI trigger type.

enum Analog/Digital/Immediate/Soft.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/9511/C#/AITrigger.cs


9511 C# Programming Manual: D:/OneDrive/Desktop/9511/C#/JY9511AITask.cs File Reference

Classes | Namespaces | Enumerations
JY9511AITask.cs File Reference

Classes

class | JY9511.JY9511AITask
JY9511 AI Task. More...
class | JY9511.AIRecord
AI Record class. More...

Namespaces

namespace JY9511

Enumerations

enum | JY9511.AIMode { JY9511.Finite = JY9511Import.JY9511_AI_Finite , JY9511.Continuous = JY9511Import.JY9511_AI_Continuous , JY9511.Single = JY9511Import.JY9511_AI_Single , JY9511.Record = 0x3 }
AI mode enum type. More...
enum JY9511.SamplingState {
JY9511.Idle = 1 << 0 , JY9511.WaitingForStart = 1 << 1 , JY9511.PreSampling = 1 << 2 , JY9511.WaitingForRefTrigger = 1 << 3 ,
JY9511.PostSampling = 1 << 4 , JY9511.RecordCompleted = 1 << 5 , JY9511.WaitingForAdvanceTrigger = 1 << 6 , JY9511.Done = 1 << 7
}
Sampling State Enum. More...
enum | JY9511.IEPEConnectionStatus { JY9511.Normal = 0 , JY9511.OpenCircuit = 1 , JY9511.ShortCircuit = 2 }
IEPE Connection Status. More...
enum | JY9511.FileFormat { JY9511.Bin }
Streaming file format. More...
enum | JY9511.RecordMode { JY9511.Finite , JY9511.Infinite }
Two stream mode from enum Finite/Infinite. More...


9511 C# Programming Manual: JY9511.JY9511AITask Class Reference

  • JY9511AITask
Public Member Functions | Static Public Member Functions | Properties | List of all members
JY9511.JY9511AITask Class Reference

JY9511 AI Task. More...

Public Member Functions

JY9511AITask (int slotNumber)
Create a AI task with slot number.
JY9511AITask (string cardName)
Create a AI task with card name.
void | AddChannel (int chID, double rangeLow, double rangeHigh, Coupling coupling, AITerminal terminalCfg, bool enableIEPE)
Add one/all channel(s).
void | AddChannel (int[] chIDs, double rangeLow, double rangeHigh, Coupling coupling, AITerminal terminalCfg, bool enableIEPE)
Add a set of channels and set parameters uniformly.
void | AddChannel (int[] chIDs, double[] rangeLow, double[] rangeHigh, Coupling[] coupling, AITerminal[] terminalCfg, bool[] enableIEPE)
Add a set of channels and set the parameters individually.
void | RemoveChannel (int chID)
Delete the channel with the specified channel ID.
void | RemoveChannel (int[] chIDs)
Delete a set of channels with the specified channel ID.
void | Commit ()
Commit current configuration.
void | Start ()
Start AI task.
void | Stop ()
Stop AI task.
void | StartSync ()
Start the multi-card synchronization process AGAIN.
void | ReadRawData (ref int[] dataBuf, int samplesPerChannel, int timeout)
Read raw data and copy to buffer.
void | ReadRawData (ref int[] dataBuf, int timeout=-1)
Read raw data and copy to buffer.
void | ReadRawData (ref int[,] dataBuf, int samplesPerChannel, int timeout)
Read raw data by columns and copy to buffer.
void | ReadRawData (IntPtr dataBuf, int samplesPerChannel, int timeout)
Read one or multi-channel raw data and copy to a unmannaged data buffer.
void | ReadData (ref double[] dataBuf, int samplesPerChannel, int timeout)
Read data and copy to buffer.
void | ReadData (ref double[] dataBuf, int timeout=-1)
Read data and copy to buffer.
void | ReadData (ref double[,] dataBuf, int samplesPerChannel, int timeout)
Read data by columns and copy to buffer.
void | ReadData (ref double[,] dataBuf, int timeout=-1)
Read data by columns and copy to buffer.
void | ReadData (IntPtr dataBuf, int samplesPerChannel, int timeout)
Read one or multi-channel data and copy to a unmannaged data buffer.
void | ReadSinglePoint (ref double[] dataBuf)
Read one sample (per channel) in unbuffered reading.
void | ReadSinglePoint (ref double readValue, int channel)
Read one sample for specified channel in register.
void | ReadSingleRawPoint (IntPtr dataBuf)
Read one sample (per channel) in unbuffered reading to unmannaged buffer.
void | GetRecordPreviewData (ref double[,] buf, int samplesPerChannel, int timeout=1000)
Preview multi-channel data when streaming is in progress.
void | GetRecordPreviewData (ref double[,] buf, int timeout=1000)
Preview multi-channel data when streaming is in progress.
void | GetRecordPreviewData (ref double[] buf, int samplesPerChannel, int timeout=1000)
Preview one channel data when streaming is in progress.
void | GetRecordPreviewData (ref double[] buf, int timeout=1000)
Preview one channel data when streaming is in progress.
void | GetRecordStatus (out double recordedLength, out bool recordDone)
Get the streaming status.
void | SendSoftwareTrigger ()
Send a software trigger.
Dictionary< int, IEPEConnectionStatus > | DetectIEPEConnection ()
Perform IEPE sensor connection status detection.
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.
byte[] | ReadTEDSData (int chID)
Read binary TEDS data from sensor.
AISamplingInfo | GetSamplingInfo ()
Write binary TEDS data to sensor.

Static Public Member Functions

static AISamplingInfo GetSamplingInfo (double sampleRate, LPFMode lpfMode)
Get Sampling information, including sampling rate, low-pass filter mode, digital filter group delay, and several related parameters.

Properties

JY9511Device | Device [get]
The device instance called by this AI task instance.
List< AIChannel > | Channels [get]
List of enabled channels.
AITrigger | Trigger [get]
AI trigger configuration.
AISignalExport | SignalExport [get]
Signal export configuration.
Sync | Sync [get]
Sync configuration.
AIDigitalFiltering | DigitalFiltering [get]
Digital filtering configuration.
AIMode | Mode [get, set]
Sample mode.
AIRecord | Record [get]
Data streaming Configuration.
double | SampleRate [get, set]
Sampling rate per channel in Sa/s.
int | SamplesToAcquire [get, set]
Samples to acquire.
SamplingState | State [get]
Sampling state.
UInt64 | AvailableSamples [get]
Number of samples per channel that can be read in the buffer.
UInt64 | TransferedSamples [get]
Number of points per channel that have already been read from the buffer.

Detailed Description

JY9511 AI Task.

Constructor & Destructor Documentation

◆ JY9511AITask() [1/2]

JY9511.JY9511AITask.JY9511AITask ( int slotNumber )

Create a AI task with slot number.

Parameters
slotNumber Slot Number

◆ JY9511AITask() [2/2]

JY9511.JY9511AITask.JY9511AITask ( string cardName )

Create a AI task with card name.

Parameters
cardName Card Name

Member Function Documentation

◆ AddChannel() [1/3]

void JY9511.JY9511AITask.AddChannel | ( | int | chID,
 |  | double | rangeLow,
 |  | double | rangeHigh,
 |  | Coupling | coupling,
 |  | AITerminal | terminalCfg,
 |  | bool | enableIEPE )

Add one/all channel(s).

Parameters
chID | Channel ID
rangeLow | Input Low Range. -50V/-25V/-10V/-5V/-2.5V/-1.25V/-0.625V/-0.3125V Optional.
rangeHigh | Input High Range. 50V/25V/10V/5V/2.5V/1.25V/0.625V/0.3125V Optional.
coupling | Coupling Type.
terminalCfg | Terminal Type.
enableIEPE | IEPE Enabled.

◆ AddChannel() [2/3]

void JY9511.JY9511AITask.AddChannel | ( | int[] | chIDs,
 |  | double | rangeLow,
 |  | double | rangeHigh,
 |  | Coupling | coupling,
 |  | AITerminal | terminalCfg,
 |  | bool | enableIEPE )

Add a set of channels and set parameters uniformly.

Parameters
chIDs | Channel ID
rangeLow | Input Low Range. -10V/-5V/-2.5V/-1.25V/-0.625V/-0.3125V Optional.
rangeHigh | Input High Range. 10V/5V/2.5V/1.25V/0.625V/0.3125V Optional.
coupling | Coupling Type.
terminalCfg | Terminal Type.
enableIEPE | IEPE Enabled.

◆ AddChannel() [3/3]

void JY9511.JY9511AITask.AddChannel | ( | int[] | chIDs,
 |  | double[] | rangeLow,
 |  | double[] | rangeHigh,
 |  | Coupling[] | coupling,
 |  | AITerminal[] | terminalCfg,
 |  | bool[] | enableIEPE )

Add a set of channels and set the parameters individually.

Parameters
chIDs | Channel ID
rangeLow | Input Low Range. -10V/-5V/-2.5V/-1.25V/-0.625V/-0.3125V Optional.
rangeHigh | Input High Range. 10V/5V/2.5V/1.25V/0.625V/0.3125V Optional.
coupling | Coupling Type.
terminalCfg | Terminal Type.
enableIEPE | IEPE Enabled.

◆ Commit()

void JY9511.JY9511AITask.Commit ( )

Commit current configuration.

For normal task, this method is optional. When using multi-device synchronization, this method must be called by slave devices, then called by the master device.

◆ DetectIEPEConnection()

Dictionary< int, IEPEConnectionStatus > JY9511.JY9511AITask.DetectIEPEConnection ( )

Perform IEPE sensor connection status detection.

After calling this method, the device will output the excitation current and measure the voltage, and if the voltage is too large, it will be judged as an open circuit, and if the voltage is too small, it will be judged as a short circuit.

Returns
IEPE connection status. Dictionary's key is channel's ID.

◆ GetRecordPreviewData() [1/4]

void JY9511.JY9511AITask.GetRecordPreviewData | ( | ref double | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout = 1000 )

Preview multi-channel data when streaming is in progress.

Each column represents one channel.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ GetRecordPreviewData() [2/4]

void JY9511.JY9511AITask.GetRecordPreviewData | ( | ref double | buf[,],
 |  | int | timeout = 1000 )

Preview multi-channel data when streaming is in progress.

Each column represents one channel.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms
Returns

◆ GetRecordPreviewData() [3/4]

void JY9511.JY9511AITask.GetRecordPreviewData | ( | ref double[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 1000 )

Preview one channel data when streaming is in progress.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ GetRecordPreviewData() [4/4]

void JY9511.JY9511AITask.GetRecordPreviewData | ( | ref double[] | buf,
 |  | int | timeout = 1000 )

Preview one channel data when streaming is in progress.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms

◆ GetRecordStatus()

void JY9511.JY9511AITask.GetRecordStatus | ( | out double | recordedLength,
 |  | out bool | recordDone )

Get the streaming status.

Parameters
recordedLength | Length of the streamed, unit s
recordDone | recordDone = false :streaming is not over.recordDone = true :streaming is over

◆ GetSamplingInfo() [1/2]

AISamplingInfo JY9511.JY9511AITask.GetSamplingInfo ( )

Write binary TEDS data to sensor.

Parameters
chID | ID of the channel to which the sensor connects
data | Binary TEDS data

Write binary TEDS data to sensor.

Parameters
chID | ID of the channel to which the sensor connects
romid | 根据ROM ID判断器件型号，获取相关信息
data | Binary TEDS data

Get Sampling information, including sampling rate, low-pass filter mode, digital filter group delay, and several related parameters.

Returns
Sampling infomation

◆ GetSamplingInfo() [2/2]

AISamplingInfo JY9511.JY9511AITask.GetSamplingInfo | ( | double | sampleRate,
 |  | LPFMode | lpfMode )
 static

Get Sampling information, including sampling rate, low-pass filter mode, digital filter group delay, and several related parameters.

Parameters
sampleRate | Sample rate in Sa/s
lpfMode | Low-pass filter mode
Returns
>Sampling infomation

◆ ReadData() [1/5]

void JY9511.JY9511AITask.ReadData | ( | IntPtr | dataBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read one or multi-channel data and copy to a unmannaged data buffer.

Parameters
dataBuf | User buffer used to read data.
samplesPerChannel | Number of samples per channel.
timeout | Timeout in ms before generate tiemout exception, timeout =-1 keep waiting until finish.

◆ ReadData() [2/5]

void JY9511.JY9511AITask.ReadData | ( | ref double | dataBuf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read data by columns and copy to buffer.

Parameters
dataBuf | User buffer used to read data.
samplesPerChannel | Number of samples per channel.
timeout | Timeout in ms before generate tiemout exception, timeout =-1 keep waiting until finish.

◆ ReadData() [3/5]

void JY9511.JY9511AITask.ReadData | ( | ref double | dataBuf[,],
 |  | int | timeout = -1 )

Read data by columns and copy to buffer.

Parameters
dataBuf | User buffer used to read data.
timeout | Timeout in ms before generate tiemout exception, timeout =-1 keep waiting until finish.

◆ ReadData() [4/5]

void JY9511.JY9511AITask.ReadData | ( | ref double[] | dataBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read data and copy to buffer.

Parameters
dataBuf | User buffer used to read data.
samplesPerChannel | Number of samples per channel.
timeout | Timeout in ms before generate tiemout exception, timeout =-1 keep waiting until finish.

◆ ReadData() [5/5]

void JY9511.JY9511AITask.ReadData | ( | ref double[] | dataBuf,
 |  | int | timeout = -1 )

Read data and copy to buffer.

Parameters
dataBuf | User buffer used to read data.
timeout | Timeout in ms before generate tiemout exception, timeout =-1 keep waiting until finish.

◆ ReadRawData() [1/4]

void JY9511.JY9511AITask.ReadRawData | ( | IntPtr | dataBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read one or multi-channel raw data and copy to a unmannaged data buffer.

Parameters
dataBuf | User buffer used to read data.
samplesPerChannel | Number of samples per channel.
timeout | Timeout in ms before generate tiemout exception, timeout =-1 keep waiting until finish.

◆ ReadRawData() [2/4]

void JY9511.JY9511AITask.ReadRawData | ( | ref int | dataBuf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read raw data by columns and copy to buffer.

Parameters
dataBuf | User buffer used to read raw data.
samplesPerChannel | Number of samples per channel.
timeout | Timeout in ms before generate tiemout exception, timeout =-1 keep waiting until finish.

◆ ReadRawData() [3/4]

void JY9511.JY9511AITask.ReadRawData | ( | ref int[] | dataBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read raw data and copy to buffer.

Parameters
dataBuf | User buffer used to read raw data.
samplesPerChannel | Number of samples per channel.
timeout | Timeout in ms before generate tiemout exception, timeout = -1 keep waiting until finish.

◆ ReadRawData() [4/4]

void JY9511.JY9511AITask.ReadRawData | ( | ref int[] | dataBuf,
 |  | int | timeout = -1 )

Read raw data and copy to buffer.

Parameters
dataBuf | User buffer used to read raw data.
timeout | Timeout in ms before generate tiemout exception, timeout =-1 keep waiting until finish.

◆ ReadSinglePoint() [1/2]

void JY9511.JY9511AITask.ReadSinglePoint | ( | ref double | readValue,
 |  | int | channel )

Read one sample for specified channel in register.

Available when Mode is AIMode.Single

Parameters
readValue | value read
channel | Specified channel numbers.

◆ ReadSinglePoint() [2/2]

void JY9511.JY9511AITask.ReadSinglePoint ( ref double[] dataBuf )

Read one sample (per channel) in unbuffered reading.

Parameters
dataBuf User buffer.

◆ ReadSingleRawPoint()

void JY9511.JY9511AITask.ReadSingleRawPoint ( IntPtr dataBuf )

Read one sample (per channel) in unbuffered reading to unmannaged buffer.

Parameters
dataBuf User buffer.

◆ ReadTEDSData()

byte[] JY9511.JY9511AITask.ReadTEDSData ( int chID )

Read binary TEDS data from sensor.

Parameters
chID ID of the channel to which the sensor connects
Returns
Binary TEDS data

◆ RemoveChannel() [1/2]

void JY9511.JY9511AITask.RemoveChannel ( int chID )

Delete the channel with the specified channel ID.

Parameters
chID Specified channel ID. chnId = -1: remove all channels.

◆ RemoveChannel() [2/2]

void JY9511.JY9511AITask.RemoveChannel ( int[] chIDs )

Delete a set of channels with the specified channel ID.

Parameters
chIDs Specified channels' ID.

◆ SendSoftwareTrigger()

void JY9511.JY9511AITask.SendSoftwareTrigger ( )

Send a software trigger.

Returns

◆ Start()

void JY9511.JY9511AITask.Start ( )

Start AI task.

◆ StartSync()

void JY9511.JY9511AITask.StartSync ( )

Start the multi-card synchronization process AGAIN.

This method must be called by slave devices, then called by ther master device.

◆ Stop()

void JY9511.JY9511AITask.Stop ( )

Stop AI task.

◆ WaitUntilDone()

bool JY9511.JY9511AITask.WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Only valid when Mode is AIMode.Finite.

Parameters
timeout Wait timeout in ms, or never times out when value is -1.
Returns
Whether the task has been completed

Property Documentation

◆ AvailableSamples

UInt64 JY9511.JY9511AITask.AvailableSamples
get

Number of samples per channel that can be read in the buffer.

◆ Channels

List<AIChannel> JY9511.JY9511AITask.Channels
get

List of enabled channels.

◆ Device

JY9511Device JY9511.JY9511AITask.Device
get

The device instance called by this AI task instance.

◆ DigitalFiltering

AIDigitalFiltering JY9511.JY9511AITask.DigitalFiltering
get

Digital filtering configuration.

◆ Mode

AIMode JY9511.JY9511AITask.Mode
getset

Sample mode.

◆ Record

AIRecord JY9511.JY9511AITask.Record
get

Data streaming Configuration.

◆ SampleRate

double JY9511.JY9511AITask.SampleRate
getset

Sampling rate per channel in Sa/s.

◆ SamplesToAcquire

int JY9511.JY9511AITask.SamplesToAcquire
getset

Samples to acquire.

◆ SignalExport

AISignalExport JY9511.JY9511AITask.SignalExport
get

Signal export configuration.

◆ State

SamplingState JY9511.JY9511AITask.State
get

Sampling state.

◆ Sync

Sync JY9511.JY9511AITask.Sync
get

Sync configuration.

◆ TransferedSamples

UInt64 JY9511.JY9511AITask.TransferedSamples
get

Number of points per channel that have already been read from the buffer.

◆ Trigger

AITrigger JY9511.JY9511AITask.Trigger
get

AI trigger configuration.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/9511/C#/JY9511AITask.cs


9511 C# Programming Manual: JY9511.AIRecord Class Reference

  • AIRecord
Properties | List of all members
JY9511.AIRecord Class Referencesealed

AI Record class. More...

Properties

string | FilePath [get, set]
Path of streaming file,including filePath and filename.
FileFormat | FileFormat [get]
Streaming file format.
RecordMode | Mode [get, set]
Two stream mode from enum Finite/Infinite.
double | Length [get, set]
User specified stream length in second.

Detailed Description

AI Record class.

Property Documentation

◆ FileFormat

FileFormat JY9511.AIRecord.FileFormat
get

Streaming file format.

◆ FilePath

string JY9511.AIRecord.FilePath
getset

Path of streaming file,including filePath and filename.

◆ Length

double JY9511.AIRecord.Length
getset

User specified stream length in second.

Only valid in the Finite mode

◆ Mode

RecordMode JY9511.AIRecord.Mode
getset

Two stream mode from enum Finite/Infinite.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/9511/C#/JY9511AITask.cs


9511 C# Programming Manual: D:/OneDrive/Desktop/9511/C#/JY9511AOTask.cs File Reference

Classes | Namespaces | Enumerations
JY9511AOTask.cs File Reference

Classes

class | JY9511.JY9511AOTask
JY9511 Analog Ouput Task. More...
class | JY9511.AOChannel
AO Channel parameter class . More...
class | JY9511.AOTrigger
Constructor to create an AOTrigger task object. More...
class | JY9511.DDSConfig
DDS waveform configuration class. More...
class | JY9511.AODigitalTrigger
AO Digital trigger . More...
class | JY9511.AOSignalExport
AO Signal Export Class. More...

Namespaces

namespace JY9511

Enumerations

enum | JY9511.AOTerminal { JY9511.PseudoDifferential = JY9511Import.JY9511_PseDiff , JY9511.Differential = JY9511Import.JY9511_Diff }
AOTerminal. More...
enum | JY9511.AODigitalTriggerEdge { JY9511.Rising , JY9511.Falling }
AO Digital Trigger Edge. More...
enum JY9511.AODigitalTriggerSource {
JY9511.Ext_Trig = JY9511Import.JY9511_DigitalTriggerSource_External , JY9511.PXI_Trig0 = JY9511Import.JY9511_DigitalTriggerSource_BUS_0 , JY9511.PXI_Trig1 = JY9511Import.JY9511_DigitalTriggerSource_BUS_1 , JY9511.PXI_Trig2 = JY9511Import.JY9511_DigitalTriggerSource_BUS_2 ,
JY9511.PXI_Trig3 = JY9511Import.JY9511_DigitalTriggerSource_BUS_3 , JY9511.PXI_Trig4 = JY9511Import.JY9511_DigitalTriggerSource_BUS_4 , JY9511.PXI_Trig5 = JY9511Import.JY9511_DigitalTriggerSource_BUS_5 , JY9511.PXI_Trig6 = JY9511Import.JY9511_DigitalTriggerSource_BUS_6 ,
JY9511.PXI_Trig7 = JY9511Import.JY9511_DigitalTriggerSource_BUS_7 , JY9511.AI_StartTrig = JY9511Import.JY9511_AI_StartTrig , JY9511.AI_ReferenceTrig = JY9511Import.JY9511_AI_ReferenceTrig
}
AO Digital trigger source. More...
enum | JY9511.AOMode { JY9511.Finite = 0 , JY9511.ContinuousNoWrapping = 2 , JY9511.ContinuousWrapping = 1 , JY9511.DDS =3 }
AOMode. More...
enum | JY9511.AOSignalExportSource { JY9511.StartTrig = JY9511Import.JY9511_AO_StartTrig }
SourceSignal. More...
enum | JY9511.AOTriggerType { JY9511.Immediate = JY9511Import.JY9511_TriggerType_Immediately , JY9511.Digital = JY9511Import.JY9511_TriggerType_Digital , JY9511.Soft = JY9511Import.JY9511_TriggerType_Software }
TriggerType Digital/Immediate/Soft. More...


9511 C# Programming Manual: JY9511.JY9511AOTask Class Reference

  • JY9511AOTask
Public Member Functions | Static Public Member Functions | Properties | List of all members
JY9511.JY9511AOTask Class Referencesealed

JY9511 Analog Ouput Task. More...

Public Member Functions

JY9511AOTask (int slotNum)
Constructor, Used to create an AO task by a slot number.
JY9511AOTask (string boardName)
Constructor.
void | AddChannel (int chnId, double rangeLow=-10, double rangeHigh=10, AOTerminal terminalCfg=AOTerminal.Differential)
Add one channel.
void | AddChannel (int[] chnsId, double rangeLow=-10, double rangeHigh=10, AOTerminal terminalCfg=AOTerminal.Differential)
Add a group of channels.
void | AddChannel (int[] chnsId, double[] rangeLow, double[] rangeHigh, AOTerminal[] terminalCfg)
Add a group of channels.
void | RemoveChannel (int chnId)
Delete the specified channel number.
void | WriteSinglePoint (DDSConfig ddsConfig)
Configure the output waveform parameters.
void | WriteSinglePoint (DDSConfig[] ddsConfigs)
Configure the output waveform parameters.
void | WriteData (double[,] buf, int timeout=10000)
Write multi-channel data to AO buffer, Each column represents one channel.
void | WriteData (IntPtr buf, int samplesPerChannel, int timeout=10000)
Write to AO buffer one or multi-channel data.
void | WriteData (double[] buf, int timeout=10000)
Write one channel data to AO buffer.
void | WriteRawData (int[,] buf, int timeout=10000)
Write multi-channel raw data to AO buffer, Each column represents one channel.
void | WriteRawData (IntPtr buf, int samplesPerChannel, int timeout=10000)
Write to AO buffer one or multi-channel raw data.
void | WriteRawData (int[] buf, int timeout=10000)
Write one channel raw Data to AO buffer.
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.
void | Commit ()
配置
void | Start ()
Start AO task .
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Stop ()
Stop AO task .
AOSamplingInfo | GetSamplingInfo ()
Get Sampling information, including sampling rate, low-pass filter mode, digital filter group delay, and several related parameters.

Static Public Member Functions

static AOSamplingInfo GetSamplingInfo (double sampleRate)
Get Sampling information, including sampling rate, low-pass filter mode, digital filter group delay, and several related parameters.

Properties

List< AOChannel > | Channels [get]
List of AO channels,(5510 5511 support 4 channels)(5515 5516 support 2 channels).
Sync | Sync [get]
Sync configuration.
AOMode | Mode [get, set]
Mode of AO Task.
double | UpdateRate [get, set]
Update rate per channel.
int | SamplesToUpdate [get, set]
Number of output samples to write per channel , Only valid when Mode is AOMode.Finite.
int | BufLenInSamples [get]
Number of samples per channel can be storage in the buffer, the PropretySamplesToUpdate must be less than or equal to this value.
uint | AvailableLenInSamples [get]
Number of output samples per channel that can be write in AO buffuer.
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel).
AOTrigger | Trigger = new AOTrigger() [get, set]
AO Trigger Configuration.
AOSignalExport | SignalExport [get, set]
Export AO Signal.
JY9511Device | Device [get]
Device.

Detailed Description

JY9511 Analog Ouput Task.

Constructor & Destructor Documentation

◆ JY9511AOTask() [1/2]

JY9511.JY9511AOTask.JY9511AOTask ( int slotNum )

Constructor, Used to create an AO task by a slot number.

Parameters
slotNum Card slot number.

◆ JY9511AOTask() [2/2]

JY9511.JY9511AOTask.JY9511AOTask ( string boardName )

Constructor.

Used to create an AO task by a board name.

Parameters
boardName Board name(device alias), set by device manager

Member Function Documentation

◆ AddChannel() [1/3]

void JY9511.JY9511AOTask.AddChannel | ( | int | chnId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10,
 |  | AOTerminal | terminalCfg = AOTerminal::Differential )

Add one channel.

Parameters
chnId | channel's physical number ，chnId=-1, add all channels。（5510 5511 support 4 channels）（5515 5516 support 2 channels）
rangeLow | lower range limit for the channel，-10V,-5V defalut -10
rangeHigh | higher range limit for the channel，10V,5V defalut 10
terminalCfg | terminal limit for the channel，Difference,PseudoDifference defalut Difference

◆ AddChannel() [2/3]

void JY9511.JY9511AOTask.AddChannel | ( | int[] | chnsId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10,
 |  | AOTerminal | terminalCfg = AOTerminal::Differential )

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers。（5510 5511 support 4 channels）（5515 5516 support 2 channels）
rangeLow | lower range limit for the channel，-10V,-5V defalut -10
rangeHigh | higher range limit for the channel，10V,5V defalut 10
terminalCfg | Terminal limit for the channel，PseudoDifferential,Differential defalut Differential

◆ AddChannel() [3/3]

void JY9511.JY9511AOTask.AddChannel | ( | int[] | chnsId,
 |  | double[] | rangeLow,
 |  | double[] | rangeHigh,
 |  | AOTerminal[] | terminalCfg )

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers。（5510 5511 support 4 channels）（5515 5516 support 2 channels）
rangeLow | lower range limit for the channel，-10V,-5V
rangeHigh | higher range limit for the channel，10V,5V
terminalCfg | Terminal limit for the channel，PseudoDifferential,Differential

◆ Commit()

void JY9511.JY9511AOTask.Commit ( )

配置

Exceptions
JYDriverException
Exception

◆ GetSamplingInfo() [1/2]

AOSamplingInfo JY9511.JY9511AOTask.GetSamplingInfo ( )

Get Sampling information, including sampling rate, low-pass filter mode, digital filter group delay, and several related parameters.

Returns
Sampling infomation

◆ GetSamplingInfo() [2/2]

AOSamplingInfo JY9511.JY9511AOTask.GetSamplingInfo ( double sampleRate )
static

Get Sampling information, including sampling rate, low-pass filter mode, digital filter group delay, and several related parameters.

Parameters
sampleRate Sample rate in Sa/s
Returns
>Sampling infomation

◆ RemoveChannel()

void JY9511.JY9511AOTask.RemoveChannel ( int chnId )

Delete the specified channel number.

If it is -1, delete all channels.

Parameters
chnId Specified channel ID.

◆ SendSoftwareTrigger()

void JY9511.JY9511AOTask.SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY9511.JY9511AOTask.Start ( )

Start AO task .

◆ Stop()

void JY9511.JY9511AOTask.Stop ( )

Stop AO task .

◆ WaitUntilDone()

bool JY9511.JY9511AOTask.WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Available when Mode is AOMode.Finite

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteData() [1/3]

void JY9511.JY9511AOTask.WriteData | ( | double | buf[,],
 |  | int | timeout = 10000 )

Write multi-channel data to AO buffer, Each column represents one channel.

Parameters
buf | AO buffer for data.
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [2/3]

void JY9511.JY9511AOTask.WriteData | ( | double[] | buf,
 |  | int | timeout = 10000 )

Write one channel data to AO buffer.

Parameters
buf | AO buffer for data.
timeout | >timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [3/3]

void JY9511.JY9511AOTask.WriteData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Write to AO buffer one or multi-channel data.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | data buffer.
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawData() [1/3]

void JY9511.JY9511AOTask.WriteRawData | ( | int | buf[,],
 |  | int | timeout = 10000 )

Write multi-channel raw data to AO buffer, Each column represents one channel.

Parameters
buf | AO buffer for data.
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawData() [2/3]

void JY9511.JY9511AOTask.WriteRawData | ( | int[] | buf,
 |  | int | timeout = 10000 )

Write one channel raw Data to AO buffer.

Parameters
buf | AO buffer for data.
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawData() [3/3]

void JY9511.JY9511AOTask.WriteRawData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Write to AO buffer one or multi-channel raw data.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | data buffer.
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteSinglePoint() [1/2]

void JY9511.JY9511AOTask.WriteSinglePoint ( DDSConfig ddsConfig )

Configure the output waveform parameters.

This method is only available for DDS mode.

Parameters
ddsConfig DDS waveform configuration.

◆ WriteSinglePoint() [2/2]

void JY9511.JY9511AOTask.WriteSinglePoint ( DDSConfig[] ddsConfigs )

Configure the output waveform parameters.

This method is only available for DDS mode.

Parameters
ddsConfigs DDS waveform configuration.

Property Documentation

◆ AvailableLenInSamples

uint JY9511.JY9511AOTask.AvailableLenInSamples
get

Number of output samples per channel that can be write in AO buffuer.

◆ BufLenInSamples

int JY9511.JY9511AOTask.BufLenInSamples
get

Number of samples per channel can be storage in the buffer, the PropretySamplesToUpdate must be less than or equal to this value.

◆ Channels

List<AOChannel> JY9511.JY9511AOTask.Channels
get

List of AO channels,(5510 5511 support 4 channels)(5515 5516 support 2 channels).

◆ Device

JY9511Device JY9511.JY9511AOTask.Device
get

Device.

◆ Mode

AOMode JY9511.JY9511AOTask.Mode
getset

Mode of AO Task.

Select AO Mode from enum:ContinuousNoWrapping/ContinuousWrapping/Finite/Single.

◆ SamplesToUpdate

int JY9511.JY9511AOTask.SamplesToUpdate
getset

Number of output samples to write per channel , Only valid when Mode is AOMode.Finite.

◆ SignalExport

AOSignalExport JY9511.JY9511AOTask.SignalExport
getset

Export AO Signal.

◆ Sync

Sync JY9511.JY9511AOTask.Sync
get

Sync configuration.

◆ TransferedSamples

ulong JY9511.JY9511AOTask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

/>.

◆ Trigger

AOTrigger JY9511.JY9511AOTask.Trigger = new AOTrigger()
getset

AO Trigger Configuration.

◆ UpdateRate

double JY9511.JY9511AOTask.UpdateRate
getset

Update rate per channel.

Maximum update rate is 2.86M for single channel, 2M for two channels, 1.5M for three channels, 1.25M for four channels. The defalut sample rate = 1000000 You can read this property to obtain the update rate that will actually take effect in the current configuration.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/9511/C#/JY9511AOTask.cs


9511 C# Programming Manual: JY9511.AOChannel Class Reference

  • AOChannel
Properties | List of all members
JY9511.AOChannel Class Referencesealed

AO Channel parameter class . More...

Properties

int | ChannelID [get]
AO channel ID.
double | RangeLow [get, set]
Low range limit an AO channel.
double | RangeHigh [get, set]
High range limit an AO channel.
AOTerminal | Terminaal [get, set]
Configure AO terminal.

Detailed Description

AO Channel parameter class .

Property Documentation

◆ ChannelID

int JY9511.AOChannel.ChannelID
get

AO channel ID.

◆ RangeHigh

double JY9511.AOChannel.RangeHigh
getset

High range limit an AO channel.

◆ RangeLow

double JY9511.AOChannel.RangeLow
getset

Low range limit an AO channel.

◆ Terminaal

AOTerminal JY9511.AOChannel.Terminaal
getset

Configure AO terminal.

(Differential,PseudoDifference)

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/9511/C#/JY9511AOTask.cs


9511 C# Programming Manual: JY9511.AOTrigger Class Reference

  • AOTrigger
Properties | List of all members
JY9511.AOTrigger Class Referencesealed

Constructor to create an AOTrigger task object. More...

Properties

AOTriggerType | Type [get, set]
AO trigger type.
AODigitalTrigger | Digital [get, set]
AO Digital Trigger.

Detailed Description

Constructor to create an AOTrigger task object.

Used to build AO Trigger

Property Documentation

◆ Digital

AODigitalTrigger JY9511.AOTrigger.Digital
getset

AO Digital Trigger.

Valid when Type is AOTriggerType.Digital.

◆ Type

AOTriggerType JY9511.AOTrigger.Type
getset

AO trigger type.

enum Immediate/Digital/Soft.The default value is AOTriggerType.Immediate.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/9511/C#/JY9511AOTask.cs


9511 C# Programming Manual: JY9511.DDSConfig Class Reference

  • DDSConfig
Public Member Functions | Properties | List of all members
JY9511.DDSConfig Class Referencesealed

DDS waveform configuration class. More...

Public Member Functions

DDSConfig ()
Create a instance of DDS class.

Properties

double | Frequency [get, set]
Waveform frequency.
double | Amplitude [get, set]
Waveform amplitude.
double | Offset [get, set]
Waveform offset in voltage.

Detailed Description

DDS waveform configuration class.

Constructor & Destructor Documentation

◆ DDSConfig()

JY9511.DDSConfig.DDSConfig ( )

Create a instance of DDS class.

Property Documentation

◆ Amplitude

double JY9511.DDSConfig.Amplitude
getset

Waveform amplitude.

◆ Frequency

double JY9511.DDSConfig.Frequency
getset

Waveform frequency.

◆ Offset

double JY9511.DDSConfig.Offset
getset

Waveform offset in voltage.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/9511/C#/JY9511AOTask.cs


9511 C# Programming Manual: JY9511.AODigitalTrigger Class Reference

  • AODigitalTrigger
Properties | List of all members
JY9511.AODigitalTrigger Class Referencesealed

AO Digital trigger . More...

Properties

AODigitalTriggerSource | Source [get, set]
AO Digital Trigger source.
AODigitalTriggerEdge | Edge [get, set]
Digital Trigger edge，Rising/Falling.

Detailed Description

AO Digital trigger .

Property Documentation

◆ Edge

AODigitalTriggerEdge JY9511.AODigitalTrigger.Edge
getset

Digital Trigger edge，Rising/Falling.

◆ Source

AODigitalTriggerSource JY9511.AODigitalTrigger.Source
getset

AO Digital Trigger source.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/9511/C#/JY9511AOTask.cs


9511 C# Programming Manual: JY9511.AOSignalExport Class Reference

  • AOSignalExport
Public Member Functions | List of all members
JY9511.AOSignalExport Class Reference

AO Signal Export Class. More...

Public Member Functions

void | Add (AOSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (AOSignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

AO Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY9511.AOSignalExport.Add | ( | AOSignalExportSource | source,
 |  | List< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | AO Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY9511.AOSignalExport.Add | ( | AOSignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | AO Signal Source
destination | Export Desination

◆ Clear()

void JY9511.AOSignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY9511.AOSignalExport.ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/9511/C#/JY9511AOTask.cs


9511 C# Programming Manual: D:/OneDrive/Desktop/9511/C#/JY9511CITask.cs File Reference

Classes | Namespaces | Enumerations
JY9511CITask.cs File Reference

Classes

class | JY9511.JY9511CITask
JY9511 Counter Input Task. More...
class | JY9511.CISampleClock
CI Sample Clock class. More...
class | JY9511.CIInternalSampleClock
CI Internal Sample Clock Configuration Class. More...
class | JY9511.CIImplicitSampleClock
CI Implicit Sample Clock class. More...
class | JY9511.CIExternalSampleClock
CI Implicit Sample Clock class. More...
class | JY9511.CIExternalTimebase
class | JY9511.CIAIMCLKTimebase
class | JY9511.CITimebase
class | JY9511.EdgeCounting
Configure CI EdgeCounting. More...
class | JY9511.PauseTrigger
Pause trigger configuration class. More...
class | JY9511.FrequencyMeas
Configure CI Measure. More...
class | JY9511.PeriodMeas
Configure CI Measure. More...
class | JY9511.PulseMeas
Configure CI Measure. More...
class | JY9511.SemiPeriodMeas
Configure CI Measure. More...
class | JY9511.CITrigger
Constructor to create an CITrigger task object. More...
class | JY9511.CIDigitalTrigger
CI Digital trigger . More...
class | JY9511.CISignalExport
CI Signal Export Class. More...

Namespaces

namespace JY9511

Enumerations

enum | JY9511.CountDirection { JY9511.Up = JY9511Import.JY9511_CI_Count_Up , JY9511.Down = JY9511Import.JY9511_CI_Count_Down }
Counter direction. More...
enum | JY9511.CIMode { JY9511.Single = 2 , JY9511.Finite = 0 , JY9511.Continuous = 1 }
CIMode. More...
enum JY9511.CIType {
JY9511.EdgeCounting , JY9511.Period , JY9511.Frequency , JY9511.Pulse ,
JY9511.SemiPeriod
}
Counter Input Application Type. More...
enum JY9511.ClockTerminal {
JY9511.PXI_Trig0 = JY9511Import.JY9511_Clock_PXI_Trig_0 , JY9511.PXI_Trig1 = JY9511Import.JY9511_Clock_PXI_Trig_1 , JY9511.PXI_Trig2 = JY9511Import.JY9511_Clock_PXI_Trig_2 , JY9511.PXI_Trig3 = JY9511Import.JY9511_Clock_PXI_Trig_3 ,
JY9511.PXI_Trig4 = JY9511Import.JY9511_Clock_PXI_Trig_4 , JY9511.PXI_Trig5 = JY9511Import.JY9511_Clock_PXI_Trig_5 , JY9511.PXI_Trig6 = JY9511Import.JY9511_Clock_PXI_Trig_6 , JY9511.PXI_Trig7 = JY9511Import.JY9511_Clock_PXI_Trig_7
}
External Sample Clock Terminal. More...
enum | JY9511.CISampleClockSource { JY9511.Implicit = JY9511Import.JY9511_CI_ImplicitClock , JY9511.Internal = JY9511Import.JY9511_CI_InternalClock , JY9511.External = JY9511Import.JY9511_CI_ExternalClock }
CI Sample Clock Source. More...
enum | JY9511.EdgeType { JY9511.Rising , JY9511.Falling , JY9511.Any }
Edge Type. More...
enum JY9511.CITimebaseSource {
JY9511.Internal100MHz = 0 , JY9511.Internal5MHz = 1 , JY9511.Internal100kHz = 2 , JY9511.External = 3 ,
JY9511.AI_MCLK = 4
}
enum | JY9511.EdgeCntOunEvtIdleState { JY9511.LowLevel = 0 , JY9511.HighLevel = 1 }
Output idle state when the event has not occurred. More...
enum | JY9511.LevelPolarity { JY9511.LowLevel = 0 , JY9511.HighLevel = 1 , JY9511.None = 2 }
Edge counting output event configuration class. More...
enum | JY9511.ValueReturnMode { JY9511.TwoValue , JY9511.OneValue }
Configure CI Measure. More...
enum | JY9511.QuadEncodingType { JY9511.X1 , JY9511.X2 , JY9511.X4 }
Quadrature Encoding Type. More...
enum | JY9511.CITriggerType { JY9511.Immediate = JY9511Import.JY9511_CIO_Immediately , JY9511.Digital = JY9511Import.JY9511_CIO_Digital , JY9511.Soft = JY9511Import.JY9511_CIO_Soft }
Configure CI Measure. More...
enum JY9511.CIDigitalTriggerSource {
JY9511.PXI_Trig0 = JY9511Import.JY9511_DigitalTriggerSource_BUS_0 , JY9511.PXI_Trig1 = JY9511Import.JY9511_DigitalTriggerSource_BUS_1 , JY9511.PXI_Trig2 = JY9511Import.JY9511_DigitalTriggerSource_BUS_2 , JY9511.PXI_Trig3 = JY9511Import.JY9511_DigitalTriggerSource_BUS_3 ,
JY9511.PXI_Trig4 = JY9511Import.JY9511_DigitalTriggerSource_BUS_4 , JY9511.PXI_Trig5 = JY9511Import.JY9511_DigitalTriggerSource_BUS_5 , JY9511.PXI_Trig6 = JY9511Import.JY9511_DigitalTriggerSource_BUS_6 , JY9511.PXI_Trig7 = JY9511Import.JY9511_DigitalTriggerSource_BUS_7
}
CI Digital trigger source. More...
enum | JY9511.CIDigitalTriggerEdge { JY9511.Rising }
CI Digital Trigger Edge. More...
enum JY9511.InputTerminal {
JY9511.PFI0 = JY9511Import.JY9511_PFI0_Input , JY9511.PXI_Trig0 = JY9511Import.JY9511_PXI_Trig0_Input , JY9511.PXI_Trig1 = JY9511Import.JY9511_PXI_Trig1_Input , JY9511.PXI_Trig2 = JY9511Import.JY9511_PXI_Trig2_Input ,
JY9511.PXI_Trig3 = JY9511Import.JY9511_PXI_Trig3_Input , JY9511.PXI_Trig4 = JY9511Import.JY9511_PXI_Trig4_Input , JY9511.PXI_Trig5 = JY9511Import.JY9511_PXI_Trig5_Input , JY9511.PXI_Trig6 = JY9511Import.JY9511_PXI_Trig6_Input ,
JY9511.PXI_Trig7 = JY9511Import.JY9511_PXI_Trig7_Input
}
输入终端 More...
enum JY9511.TimebaseExternalTerminal {
JY9511.PXI_Trig0 = JY9511Import.JY9511_PXI_Trig0_Input , JY9511.PXI_Trig1 = JY9511Import.JY9511_PXI_Trig1_Input , JY9511.PXI_Trig2 = JY9511Import.JY9511_PXI_Trig2_Input , JY9511.PXI_Trig3 = JY9511Import.JY9511_PXI_Trig3_Input ,
JY9511.PXI_Trig4 = JY9511Import.JY9511_PXI_Trig4_Input , JY9511.PXI_Trig5 = JY9511Import.JY9511_PXI_Trig5_Input , JY9511.PXI_Trig6 = JY9511Import.JY9511_PXI_Trig6_Input , JY9511.PXI_Trig7 = JY9511Import.JY9511_PXI_Trig7_Input
}
输入终端 More...
enum JY9511.IOTerminal {
JY9511.PFI0 = JY9511Import.JY9511_DigitalTriggerOut_PFI_0 , JY9511.PXI_Trig0 = JY9511Import.JY9511_TriggerOut_PXI_0 , JY9511.PXI_Trig1 = JY9511Import.JY9511_TriggerOut_PXI_1 , JY9511.PXI_Trig2 = JY9511Import.JY9511_TriggerOut_PXI_2 ,
JY9511.PXI_Trig3 = JY9511Import.JY9511_TriggerOut_PXI_3 , JY9511.PXI_Trig4 = JY9511Import.JY9511_TriggerOut_PXI_4 , JY9511.PXI_Trig5 = JY9511Import.JY9511_TriggerOut_PXI_5 , JY9511.PXI_Trig6 = JY9511Import.JY9511_TriggerOut_PXI_6 ,
JY9511.PXI_Trig7 = JY9511Import.JY9511_TriggerOut_PXI_7 , JY9511.None = 9
}
IO终端=信号的目的地（共9个） More...
enum | JY9511.CISignalExportSource { JY9511.StartTrig , JY9511.SampleClock , JY9511.EventOut }
SourceSignal. More...


9511 C# Programming Manual: JY9511.JY9511CITask Class Reference

  • JY9511CITask
Public Member Functions | Properties | List of all members
JY9511.JY9511CITask Class Referencesealed

JY9511 Counter Input Task. More...

Public Member Functions

JY9511CITask (int slotNum, int channel)
Constructor.
JY9511CITask (string boardName, int channel)
Constructor.
void | Start ()
Start CI task .
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Stop ()
Stop CI task .
void | ReadSinglePoint (ref uint count)
Read a signle count value from register, Available when Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder.
void | ReadSinglePoint (ref int count)
Read a signle count value from register, Available when Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder.
void | ReadData (ref uint[] bufCount, int samplesToAcquire, int timeout=10000)
Read counter values from buffer.
void | ReadData (ref uint[] bufCount, int timeout=10000)
Read counter values from buffer.
void | ReadData (ref int[] bufCount, int samplesToAcquire, int timeout=10000)
Read counter values from buffer.
void | ReadData (ref int[] bufCount, int timeout=10000)
Read counter values from buffer.
void | ReadData (ref double[] bufMeasurement, int samplesToAcquire, int timeout=10000)
Read frequency value or period value from buffer.
void | ReadData (ref double[] bufMeasurement, int timeout=10000)
Read frequency value or period value from buffer.
void | ReadSinglePoint (ref double measurement, int timeout=10000)
Read a signle frequency value or period value from register.
void | ReadSinglePoint (ref double measurement1, ref double measurement2, int timeout=10000)
Read a signle measurement of pulse's duration value, or two-edge separtion value (two results at a time) from register.
void | ReadData (ref double[] bufMeasurement1, ref double[] bufMeasurement2, int samplesToAcquire, int timeout=10000)
Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.
void | ReadData (ref double[] bufMeasurement1, ref double[] bufMeasurement2, int timeout=10000)
Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.

Properties

CIType | Type [get, set]
CI Application types.
ulong | AvailableSamples [get]
Number of points per channel that can be read in the buffer .
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel).
CIMode | Mode [get, set]
CI Sampling mode，support Single/Finite/Continuous.
CISampleClock | SampleClock [get, set]
Clock Source.
uint | SamplesToAcquire [get, set]
Number of samples to be read per channel.Only valid when Mode is CIMode.Finite.
EdgeCounting | EdgeCounting [get, set]
Edge Counting Configuration.
FrequencyMeas | FrequencyMeas [get, set]
Frequency Measurement Configuration.
PeriodMeas | PeriodMeas [get, set]
Period Measurement Configuration.
SemiPeriodMeas | SemiPeriodMeas [get, set]
SemiPeriodMeas Measurement Configuration.
PulseMeas | PulseMeas [get, set]
Pulse Measurement Configuration.
CITrigger | Trigger = new CITrigger() [get, set]
TwoEdgeSeparation.
CISignalExport | SignalExport [get, set]
Export CI Signal Configuration.
JY9511Device | Device [get]
Device.

Detailed Description

JY9511 Counter Input Task.

Constructor & Destructor Documentation

◆ JY9511CITask() [1/2]

JY9511.JY9511CITask.JY9511CITask | ( | int | slotNum,
 |  | int | channel )

Constructor.

Used to create an CI task by a slot number.

Parameters
slotNum | Card slot number.
channel | Counter channel suppor0-1

◆ JY9511CITask() [2/2]

JY9511.JY9511CITask.JY9511CITask | ( | string | boardName,
 |  | int | channel )

Constructor.

Used to create an m task by a board name.

Parameters
boardName | Board name(device alias), set by device manager
channel | Counter channel .

Member Function Documentation

◆ ReadData() [1/8]

void JY9511.JY9511CITask.ReadData | ( | ref double[] | bufMeasurement,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read frequency value or period value from buffer.

Available when JY9511CITask.Mode is NOT CIMode.Single, and Type is CIType.Frequency or CIType.Period.

Parameters
bufMeasurement | Buffer for reading data. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period in seconds when Type is CIType.Period.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [2/8]

void JY9511.JY9511CITask.ReadData | ( | ref double[] | bufMeasurement,
 |  | int | timeout = 10000 )

Read frequency value or period value from buffer.

Available when JY9511CITask.Mode is NOT CIMode.Single, and Type is CIType.Frequency or CIType.Period.

Parameters
bufMeasurement | Buffer for reading data. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period in seconds when Type is CIType.Period.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [3/8]

void JY9511.JY9511CITask.ReadData | ( | ref double[] | bufMeasurement1,
 |  | ref double[] | bufMeasurement2,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.

. Available when JY9511CITask.Mode is NOT CIMode.Single, Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
bufMeasurement1 | Buffer for reading data. Indicates high level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
bufMeasurement2 | Buffer for reading data. Indicates low level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [4/8]

void JY9511.JY9511CITask.ReadData | ( | ref double[] | bufMeasurement1,
 |  | ref double[] | bufMeasurement2,
 |  | int | timeout = 10000 )

Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.

. Available when JY9511CITask.Mode is NOT CIMode.Single, Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
bufMeasurement1 | Buffer for reading data. Indicates high level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
bufMeasurement2 | Buffer for reading data. Indicates low level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [5/8]

void JY9511.JY9511CITask.ReadData | ( | ref int[] | bufCount,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read counter values from buffer.

Available when JY9511CITask.Mode is NOT CIMode.Single, and Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder

Parameters
bufCount | Buffer for reading data.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [6/8]

void JY9511.JY9511CITask.ReadData | ( | ref int[] | bufCount,
 |  | int | timeout = 10000 )

Read counter values from buffer.

Available when JY9511CITask.Mode is NOT CIMode.Single, and Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder

Parameters
bufCount | Buffer for reading data.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [7/8]

void JY9511.JY9511CITask.ReadData | ( | ref uint[] | bufCount,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000 )

Read counter values from buffer.

Available when JY9511CITask.Mode is NOT CIMode.Single, and Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder

Parameters
bufCount | Buffer for reading data.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [8/8]

void JY9511.JY9511CITask.ReadData | ( | ref uint[] | bufCount,
 |  | int | timeout = 10000 )

Read counter values from buffer.

Available when JY9511CITask.Mode is NOT CIMode.Single, and Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder

Parameters
bufCount | Buffer for reading data.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [1/4]

void JY9511.JY9511CITask.ReadSinglePoint | ( | ref double | measurement,
 |  | int | timeout = 10000 )

Read a signle frequency value or period value from register.

Valid when Type is CIType.Frequency or CIType.Period.

Parameters
measurement Measurement value. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period is seconds when Type is CIType.Period.
timeout
Timeout (ms). Wait until the measurement is completed or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [2/4]

void JY9511.JY9511CITask.ReadSinglePoint | ( | ref double | measurement1,
 |  | ref double | measurement2,
 |  | int | timeout = 10000 )

Read a signle measurement of pulse's duration value, or two-edge separtion value (two results at a time) from register.

Available when Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
measurement1 | Measurement Value 1. Indicates low level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
measurement2 | Measurement Value 2. Indicates high level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
timeout
Timeout (ms). Wait until the measurement is completed or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [3/4]

void JY9511.JY9511CITask.ReadSinglePoint ( ref int count )

Read a signle count value from register, Available when Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder.

Parameters
count counter value。

◆ ReadSinglePoint() [4/4]

void JY9511.JY9511CITask.ReadSinglePoint ( ref uint count )

Read a signle count value from register, Available when Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder.

Parameters
count counter value。

◆ SendSoftwareTrigger()

void JY9511.JY9511CITask.SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY9511.JY9511CITask.Start ( )

Start CI task .

◆ Stop()

void JY9511.JY9511CITask.Stop ( )

Stop CI task .

Property Documentation

◆ AvailableSamples

ulong JY9511.JY9511CITask.AvailableSamples
get

Number of points per channel that can be read in the buffer .

◆ Device

JY9511Device JY9511.JY9511CITask.Device
get

Device.

◆ EdgeCounting

EdgeCounting JY9511.JY9511CITask.EdgeCounting
getset

Edge Counting Configuration.

◆ FrequencyMeas

FrequencyMeas JY9511.JY9511CITask.FrequencyMeas
getset

Frequency Measurement Configuration.

◆ Mode

CIMode JY9511.JY9511CITask.Mode
getset

CI Sampling mode，support Single/Finite/Continuous.

◆ PeriodMeas

PeriodMeas JY9511.JY9511CITask.PeriodMeas
getset

Period Measurement Configuration.

◆ PulseMeas

PulseMeas JY9511.JY9511CITask.PulseMeas
getset

Pulse Measurement Configuration.

◆ SampleClock

CISampleClock JY9511.JY9511CITask.SampleClock
getset

Clock Source.

◆ SamplesToAcquire

uint JY9511.JY9511CITask.SamplesToAcquire
getset

Number of samples to be read per channel.Only valid when Mode is CIMode.Finite.

◆ SemiPeriodMeas

SemiPeriodMeas JY9511.JY9511CITask.SemiPeriodMeas
getset

SemiPeriodMeas Measurement Configuration.

◆ SignalExport

CISignalExport JY9511.JY9511CITask.SignalExport
getset

Export CI Signal Configuration.

◆ TransferedSamples

ulong JY9511.JY9511CITask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT CIMode.Single.

◆ Trigger

CITrigger JY9511.JY9511CITask.Trigger = new CITrigger()
getset

TwoEdgeSeparation.

QuadEncoder

TwoPulseEncoder

CI Trigger Configuration.

◆ Type

CIType JY9511.JY9511CITask.Type
getset

CI Application types.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/9511/C#/JY9511CITask.cs


9511 C# Programming Manual: JY9511.CISampleClock Class Reference

  • CISampleClock
Properties | List of all members
JY9511.CISampleClock Class Reference

CI Sample Clock class. More...

Properties

CISampleClockSource | Source [get, set]
CI Sample Clock Source.
CIExternalSampleClock | External [get, set]
CI External Sample Clock Configuration.
CIImplicitSampleClock | Implicit [get, set]
CI Implicit Sample Clock Configuration.
CIInternalSampleClock | Internal [get]
Internal Sample Clock Configuration.

Detailed Description

CI Sample Clock class.

Property Documentation

◆ External

CIExternalSampleClock JY9511.CISampleClock.External
getset

CI External Sample Clock Configuration.

Valid when Source is CISampleClockSource.External.

◆ Implicit

CIImplicitSampleClock JY9511.CISampleClock.Implicit
getset

CI Implicit Sample Clock Configuration.

Valid when Source is CISampleClockSource.Implicit.

◆ Internal

CIInternalSampleClock JY9511.CISampleClock.Internal
get

Internal Sample Clock Configuration.

Valid when Source is CISampleClockSource.Internal.

◆ Source

CISampleClockSource JY9511.CISampleClock.Source
getset

CI Sample Clock Source.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/9511/C#/JY9511CITask.cs


9511 C# Programming Manual: JY9511.CIInternalSampleClock Class Reference

  • CIInternalSampleClock
Properties | List of all members
JY9511.CIInternalSampleClock Class Reference

CI Internal Sample Clock Configuration Class. More...

Properties

double | Rate [get, set]
The rate of the internal sample clock (sample rate) which is generated by dividing the internal clock (200MHz).
bool | IgnoreFirstSampleClock [get, set]
Ignore the first sample clock data.

Detailed Description

CI Internal Sample Clock Configuration Class.

Property Documentation

◆ IgnoreFirstSampleClock

bool JY9511.CIInternalSampleClock.IgnoreFirstSampleClock
getset

Ignore the first sample clock data.

◆ Rate

double JY9511.CIInternalSampleClock.Rate
getset

The rate of the internal sample clock (sample rate) which is generated by dividing the internal clock (200MHz).

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/9511/C#/JY9511CITask.cs


9511 C# Programming Manual: JY9511.CIImplicitSampleClock Class Reference

  • CIImplicitSampleClock
Properties | List of all members
JY9511.CIImplicitSampleClock Class Reference

CI Implicit Sample Clock class. More...

Properties

double ExpectedRate [get, set]
Expected Rate of Implicit Sample Clock.

Detailed Description

CI Implicit Sample Clock class.

Property Documentation

◆ ExpectedRate

double JY9511.CIImplicitSampleClock.ExpectedRate
getset

Expected Rate of Implicit Sample Clock.

Filling this parameter accurately would helps the driver to set a proper DDR write frequency internally.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/9511/C#/JY9511CITask.cs


9511 C# Programming Manual: JY9511.CIExternalSampleClock Class Reference

  • CIExternalSampleClock
Properties | List of all members
JY9511.CIExternalSampleClock Class Reference

CI Implicit Sample Clock class. More...

Properties

ClockTerminal | Terminal [get, set]
External Sample Clock Input Terminal.
double | ExpectedRate [get, set]
Expected Rate of External Sample Clock.
bool | IgnoreFirstSampleClock [get, set]
Ignore the first sample clock data.

Detailed Description

CI Implicit Sample Clock class.

Property Documentation

◆ ExpectedRate

double JY9511.CIExternalSampleClock.ExpectedRate
getset

Expected Rate of External Sample Clock.

Filling this parameter accurately would helps the driver to set a proper DDR write frequency internally.

◆ IgnoreFirstSampleClock

bool JY9511.CIExternalSampleClock.IgnoreFirstSampleClock
getset

Ignore the first sample clock data.

◆ Terminal

ClockTerminal JY9511.CIExternalSampleClock.Terminal
getset

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/9511/C#/JY9511CITask.cs


9511 C# Programming Manual: JY9511.CIExternalTimebase Class Reference

  • CIExternalTimebase
Properties | List of all members
JY9511.CIExternalTimebase Class Referencesealed

Properties

TimebaseExternalTerminal | Terminal [get, set]
double | Frequency [get, set]

Detailed Description

外部时基配置类

External timebase configuration class

Property Documentation

◆ Frequency

double JY9511.CIExternalTimebase.Frequency
getset

外部时基的频率

Frequency of The External Timebase

◆ Terminal

TimebaseExternalTerminal JY9511.CIExternalTimebase.Terminal
getset

外部时基的输入端口

External Timebase Input Terminal

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/9511/C#/JY9511CITask.cs


9511 C# Programming Manual: JY9511.CIAIMCLKTimebase Class Reference

  • CIAIMCLKTimebase
Properties | List of all members
JY9511.CIAIMCLKTimebase Class Referencesealed

Properties

double Frequency [get, set]

Detailed Description

外部时基配置类

External timebase configuration class

Property Documentation

◆ Frequency

double JY9511.CIAIMCLKTimebase.Frequency
getset

外部时基的频率

Frequency of The External Timebase

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/9511/C#/JY9511CITask.cs


9511 C# Programming Manual: JY9511.CITimebase Class Reference

  • CITimebase
Properties | List of all members
JY9511.CITimebase Class Referencesealed

Properties

CITimebaseSource | Source [get, set]
CIExternalTimebase | External [get, set]
CIAIMCLKTimebase | AISampleRate [get, set]

Detailed Description

时基配置类

Timebase configuration class

Property Documentation

◆ AISampleRate

CIAIMCLKTimebase JY9511.CITimebase.AISampleRate
getset

◆ External

CIExternalTimebase JY9511.CITimebase.External
getset

外部时基配置。当 CITimebase.Source 为 CITimebaseSource.External时有效。

External Timebase Configuration. Valid when CITimebase.Source is COTimebaseSource.External.

◆ Source

CITimebaseSource JY9511.CITimebase.Source
getset

时基源。默认值为 CITimebaseSource.Internal100MHz。

Timebase Source. The default value is CITimebaseSource.Internal100MHz.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/9511/C#/JY9511CITask.cs


9511 C# Programming Manual: JY9511.EdgeCounting Class Reference

  • EdgeCounting
Properties | List of all members
JY9511.EdgeCounting Class Referencesealed

Configure CI EdgeCounting. More...

Properties

int | InitialCount [get, set]
Initial Count.
CountDirection | Direction [get, set]
Counter direction.
EdgeType | ActiveEdge [get, set]
The avtive edge of the input signal, the counter will count up or down on this edge.
InputTerminal | InputTerminal [get, set]
Pause Trigger Configuration.
InputTerminal | DirTerminal [get, set]
Terminal of External Count Diretion Control.
bool | InputSignalReversed [get, set]
Signal Reversed,fasle not reversed.
bool | DirectionSignalReversed [get, set]
Signal Reversed,fasle not reversed.

Detailed Description

Configure CI EdgeCounting.

Property Documentation

◆ ActiveEdge

EdgeType JY9511.EdgeCounting.ActiveEdge
getset

The avtive edge of the input signal, the counter will count up or down on this edge.

◆ Direction

CountDirection JY9511.EdgeCounting.Direction
getset

Counter direction.

enum Up/Down/External

◆ DirectionSignalReversed

bool JY9511.EdgeCounting.DirectionSignalReversed
getset

Signal Reversed,fasle not reversed.

ture reversed

◆ DirTerminal

InputTerminal JY9511.EdgeCounting.DirTerminal
getset

Terminal of External Count Diretion Control.

Valid when Direction is CountDirection.External

◆ InitialCount

int JY9511.EdgeCounting.InitialCount
getset

Initial Count.

◆ InputSignalReversed

bool JY9511.EdgeCounting.InputSignalReversed
getset

Signal Reversed,fasle not reversed.

ture reversed

◆ InputTerminal

InputTerminal JY9511.EdgeCounting.InputTerminal
getset

Pause Trigger Configuration.

Edge counting output event. A pulse will be generated when the count value reaches specified threshold

Input Terminal

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/9511/C#/JY9511CITask.cs


9511 C# Programming Manual: JY9511.PauseTrigger Class Reference

  • PauseTrigger
Properties | List of all members
JY9511.PauseTrigger Class Referencesealed

Pause trigger configuration class. More...

Properties

LevelPolarity | ActivePolarity [get, set]
Pause trigger active polarity.
InputTerminal | Terminal [get, set]
Terminal.
bool | SignalReversed [get, set]
Signal Reversed,fasle not reversed.

Detailed Description

Pause trigger configuration class.

Property Documentation

◆ ActivePolarity

LevelPolarity JY9511.PauseTrigger.ActivePolarity
getset

Pause trigger active polarity.

The default value is LevelPolarity.None, means the pause trigger is disabled.

◆ SignalReversed

bool JY9511.PauseTrigger.SignalReversed
getset

Signal Reversed,fasle not reversed.

ture reversed

◆ Terminal

InputTerminal JY9511.PauseTrigger.Terminal
getset

Terminal.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/9511/C#/JY9511CITask.cs


9511 C# Programming Manual: JY9511.FrequencyMeas Class Reference

  • FrequencyMeas
Properties | List of all members
JY9511.FrequencyMeas Class Referencesealed

Configure CI Measure. More...

Properties

CITimebase | Timebase [get, set]
Timebase configuration.
InputTerminal | InputTerminal [get, set]
Input Terminal.

Detailed Description

Configure CI Measure.

Property Documentation

◆ InputTerminal

InputTerminal JY9511.FrequencyMeas.InputTerminal
getset

Input Terminal.

◆ Timebase

CITimebase JY9511.FrequencyMeas.Timebase
getset

Timebase configuration.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/9511/C#/JY9511CITask.cs


9511 C# Programming Manual: JY9511.PeriodMeas Class Reference

  • PeriodMeas
Properties | List of all members
JY9511.PeriodMeas Class Referencesealed

Configure CI Measure. More...

Properties

CITimebase | Timebase [get, set]
Timebase configuration.
InputTerminal | InputTerminal [get, set]
Input Terminal.

Detailed Description

Configure CI Measure.

Property Documentation

◆ InputTerminal

InputTerminal JY9511.PeriodMeas.InputTerminal
getset

Input Terminal.

◆ Timebase

CITimebase JY9511.PeriodMeas.Timebase
getset

Timebase configuration.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/9511/C#/JY9511CITask.cs


9511 C# Programming Manual: JY9511.PulseMeas Class Reference

  • PulseMeas
Properties | List of all members
JY9511.PulseMeas Class Referencesealed

Configure CI Measure. More...

Properties

CITimebase | Timebase [get, set]
Timebase configuration.
EdgeType | StartingEdge [get, set]
The start edge of the input signal, the counter will count up or down on this edge.
InputTerminal | InputTerminal [get, set]
Input Terminal.
bool | SignalReversed [get, set]
Signal Reversed,fasle not reversed.

Detailed Description

Configure CI Measure.

Property Documentation

◆ InputTerminal

InputTerminal JY9511.PulseMeas.InputTerminal
getset

Input Terminal.

◆ SignalReversed

bool JY9511.PulseMeas.SignalReversed
getset

Signal Reversed,fasle not reversed.

ture reversed

◆ StartingEdge

EdgeType JY9511.PulseMeas.StartingEdge
getset

The start edge of the input signal, the counter will count up or down on this edge.

◆ Timebase

CITimebase JY9511.PulseMeas.Timebase
getset

Timebase configuration.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/9511/C#/JY9511CITask.cs


9511 C# Programming Manual: JY9511.SemiPeriodMeas Class Reference

  • SemiPeriodMeas
Properties | List of all members
JY9511.SemiPeriodMeas Class Referencesealed

Configure CI Measure. More...

Properties

CITimebase | Timebase [get, set]
Timebase configuration.
EdgeType | StartingEdge [get, set]
The start edge of the input signal, the counter will count up or down on this edge.
InputTerminal | InputTerminal [get, set]
Input Terminal.
bool | SignalReversed [get, set]
Signal Reversed,fasle not reversed.

Detailed Description

Configure CI Measure.

Property Documentation

◆ InputTerminal

InputTerminal JY9511.SemiPeriodMeas.InputTerminal
getset

Input Terminal.

◆ SignalReversed

bool JY9511.SemiPeriodMeas.SignalReversed
getset

Signal Reversed,fasle not reversed.

ture reversed

◆ StartingEdge

EdgeType JY9511.SemiPeriodMeas.StartingEdge
getset

The start edge of the input signal, the counter will count up or down on this edge.

◆ Timebase

CITimebase JY9511.SemiPeriodMeas.Timebase
getset

Timebase configuration.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/9511/C#/JY9511CITask.cs


9511 C# Programming Manual: JY9511.CITrigger Class Reference

  • CITrigger
Properties | List of all members
JY9511.CITrigger Class Referencesealed

Constructor to create an CITrigger task object. More...

Properties

CITriggerType | Type [get, set]
CI trigger type.
CIDigitalTrigger | Digital [get, set]
CI Digital Trigger.

Detailed Description

Constructor to create an CITrigger task object.

Used to build CI Trigger

Property Documentation

◆ Digital

CIDigitalTrigger JY9511.CITrigger.Digital
getset

CI Digital Trigger.

Valid when Type is CITriggerType.Digital

◆ Type

CITriggerType JY9511.CITrigger.Type
getset

CI trigger type.

enum Immediate/Digital/Soft.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/9511/C#/JY9511CITask.cs


9511 C# Programming Manual: JY9511.CIDigitalTrigger Class Reference

  • CIDigitalTrigger
Properties | List of all members
JY9511.CIDigitalTrigger Class Referencesealed

CI Digital trigger . More...

Properties

CIDigitalTriggerSource | Source [get, set]
CI Digital Trigger source.
CIDigitalTriggerEdge | Edge [get, set]
Digital Trigger edge，Rising/Falling.

Detailed Description

CI Digital trigger .

Property Documentation

◆ Edge

CIDigitalTriggerEdge JY9511.CIDigitalTrigger.Edge
getset

Digital Trigger edge，Rising/Falling.

◆ Source

CIDigitalTriggerSource JY9511.CIDigitalTrigger.Source
getset

CI Digital Trigger source.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/9511/C#/JY9511CITask.cs


9511 C# Programming Manual: JY9511.CISignalExport Class Reference

  • CISignalExport
Public Member Functions | List of all members
JY9511.CISignalExport Class Reference

CI Signal Export Class. More...

Public Member Functions

void | Add (CISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (CISignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

CI Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY9511.CISignalExport.Add | ( | CISignalExportSource | source,
 |  | List< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | CI Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY9511.CISignalExport.Add | ( | CISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | CI Signal Source
destination | Export Desination

◆ Clear()

void JY9511.CISignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY9511.CISignalExport.ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/9511/C#/JY9511CITask.cs


9511 C# Programming Manual: D:/OneDrive/Desktop/9511/C#/ReferenceClock.cs File Reference

Classes | Namespaces | Enumerations
ReferenceClock.cs File Reference

Classes

class | JY9511.ExternalReferenceClock
class | JY9511.ReferenceClock

Namespaces

namespace JY9511

Enumerations

enum | JY9511.ExternalReferenceClockTerminal { JY9511.PXIe_Clk100 = JY9511Import.JY9511_PXIe_Clk100 }
enum | JY9511.ReferenceClockSource { JY9511.Internal = 0 , JY9511.External = 1 }


9511 C# Programming Manual: JY9511.ExternalReferenceClock Class Reference

  • ExternalReferenceClock
Properties | List of all members
JY9511.ExternalReferenceClock Class Referencesealed

Properties

ExternalReferenceClockTerminal | Terminal [get, set]
double | Frequency [get, set]

Detailed Description

外部参考时钟配置类

External Reference Clcok Configuration Class

Property Documentation

◆ Frequency

double JY9511.ExternalReferenceClock.Frequency
getset

外部参考时钟频率

Frequency of External Reference Clcok

◆ Terminal

ExternalReferenceClockTerminal JY9511.ExternalReferenceClock.Terminal
getset

外部参考时钟输入端口

External Reference Clcok Input Terminal

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/9511/C#/ReferenceClock.cs


9511 C# Programming Manual: JY9511.ReferenceClock Class Reference

  • ReferenceClock
Properties | List of all members
JY9511.ReferenceClock Class Referencesealed

Properties

ReferenceClockSource | Source [get, set]
ExternalReferenceClock | External [get, set]

Detailed Description

参考时钟配置类

Reference Clcok Configuration Class

Property Documentation

◆ External

ExternalReferenceClock JY9511.ReferenceClock.External
getset

外部参考时钟源配置。当 ReferenceClock.Source 选择为 ReferenceClockSource.External 时需要配置

External Reference Clock Source. Required when ReferenceClock.Source is ReferenceClockSource.External.

◆ Source

ReferenceClockSource JY9511.ReferenceClock.Source
getset

Reference Clock Source. The default value is ReferenceClockSource.Internal.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/9511/C#/ReferenceClock.cs


9511 C# Programming Manual: D:/OneDrive/Desktop/9511/C#/TEDSCommon.cs File Reference

Classes | Namespaces
TEDSCommon.cs File Reference

Classes

class | JY9511.TEDS.TEDSUtilities
class | JY9511.TEDS.TEDSChipInfo

Namespaces

namespace | JY9511
namespace | JY9511.TEDS


9511 C# Programming Manual: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
N JY9511 |
C AIChannel | AI Channel
C AIDigitalFiltering | AI Digital Filtering Connfiguration Class
C LowPassFilter | Low-Pass Filter Configuration Class
C AISignalExport | AI Signal Export Class
C Sync |
C AIDigitalTrigger | AI Digital trigger params
C AIAnalogTrigger | AI Analog Trigger
C AIAnalogHysteresisComparator | AI Analog Hysteresis Comparator
C AIAnalogWindowComparator | AI Analog Window Comparator
C AIAnalogEdgeComparator | AI Analog Edge Comparator
C AITrigger | AI Trigger params
C JY9511AITask | JY9511 AI Task
C AIRecord | AI Record class
C JY9511AOTask | JY9511 Analog Ouput Task
C AOChannel | AO Channel parameter class
C AOTrigger | Constructor to create an AOTrigger task object
C DDSConfig | DDS waveform configuration class
C AODigitalTrigger | AO Digital trigger
C AOSignalExport | AO Signal Export Class
C JY9511CITask | JY9511 Counter Input Task
C CISampleClock | CI Sample Clock class
C CIInternalSampleClock | CI Internal Sample Clock Configuration Class
C CIImplicitSampleClock | CI Implicit Sample Clock class
C CIExternalSampleClock | CI Implicit Sample Clock class
C CIExternalTimebase |
C CIAIMCLKTimebase |
C CITimebase |
C EdgeCounting | Configure CI EdgeCounting
C PauseTrigger | Pause trigger configuration class
C FrequencyMeas | Configure CI Measure
C PeriodMeas | Configure CI Measure
C PulseMeas | Configure CI Measure
C SemiPeriodMeas | Configure CI Measure
C CITrigger | Constructor to create an CITrigger task object
C CIDigitalTrigger | CI Digital trigger
C CISignalExport | CI Signal Export Class
C ExternalReferenceClock |
C ReferenceClock |


9511 C# Programming Manual: Member List

  • AIAnalogEdgeComparator
JY9511.AIAnalogEdgeComparator Member List

This is the complete list of members for JY9511.AIAnalogEdgeComparator, including all inherited members.

Slope | JY9511.AIAnalogEdgeComparator
Threshold | JY9511.AIAnalogEdgeComparator


9511 C# Programming Manual: Member List

  • AIAnalogHysteresisComparator
JY9511.AIAnalogHysteresisComparator Member List

This is the complete list of members for JY9511.AIAnalogHysteresisComparator, including all inherited members.

HighThreshold | JY9511.AIAnalogHysteresisComparator
LowThreshold | JY9511.AIAnalogHysteresisComparator
Slope | JY9511.AIAnalogHysteresisComparator


9511 C# Programming Manual: Member List

  • AIAnalogTrigger
JY9511.AIAnalogTrigger Member List

This is the complete list of members for JY9511.AIAnalogTrigger, including all inherited members.

Comparator | JY9511.AIAnalogTrigger
Edge | JY9511.AIAnalogTrigger
Hysteresis | JY9511.AIAnalogTrigger
Source | JY9511.AIAnalogTrigger
Window | JY9511.AIAnalogTrigger


9511 C# Programming Manual: Member List

  • AIAnalogWindowComparator
JY9511.AIAnalogWindowComparator Member List

This is the complete list of members for JY9511.AIAnalogWindowComparator, including all inherited members.

Condition | JY9511.AIAnalogWindowComparator
HighThreshold | JY9511.AIAnalogWindowComparator
LowThreshold | JY9511.AIAnalogWindowComparator


9511 C# Programming Manual: Member List

  • AIChannel
JY9511.AIChannel Member List

This is the complete list of members for JY9511.AIChannel, including all inherited members.

ChannelID | JY9511.AIChannel
Coupling | JY9511.AIChannel
IEPEEnabled | JY9511.AIChannel
RangeHigh | JY9511.AIChannel
RangeLow | JY9511.AIChannel
RawDataScaleFactor | JY9511.AIChannel
Terminal | JY9511.AIChannel


9511 C# Programming Manual: Member List

  • AIDigitalFiltering
JY9511.AIDigitalFiltering Member List

This is the complete list of members for JY9511.AIDigitalFiltering, including all inherited members.

LPF JY9511.AIDigitalFiltering


9511 C# Programming Manual: Member List

  • AIDigitalTrigger
JY9511.AIDigitalTrigger Member List

This is the complete list of members for JY9511.AIDigitalTrigger, including all inherited members.

Edge | JY9511.AIDigitalTrigger
Source | JY9511.AIDigitalTrigger


9511 C# Programming Manual: Member List

  • AIRecord
JY9511.AIRecord Member List

This is the complete list of members for JY9511.AIRecord, including all inherited members.

FileFormat | JY9511.AIRecord
FilePath | JY9511.AIRecord
Length | JY9511.AIRecord
Mode | JY9511.AIRecord


9511 C# Programming Manual: Member List

  • AISignalExport
JY9511.AISignalExport Member List

This is the complete list of members for JY9511.AISignalExport, including all inherited members.

Add(AISignalExportSource source, SignalExportDestination destination) | JY9511.AISignalExport
Add(AISignalExportSource source, List< SignalExportDestination > destinations) | JY9511.AISignalExport
Clear(SignalExportDestination destination) | JY9511.AISignalExport
ClearAll() | JY9511.AISignalExport


9511 C# Programming Manual: Member List

  • AITrigger
JY9511.AITrigger Member List

This is the complete list of members for JY9511.AITrigger, including all inherited members.

Analog | JY9511.AITrigger
Digital | JY9511.AITrigger
Mode | JY9511.AITrigger
PreTriggerSamples | JY9511.AITrigger
ReTriggerCount | JY9511.AITrigger
Type | JY9511.AITrigger


9511 C# Programming Manual: Member List

  • AOChannel
JY9511.AOChannel Member List

This is the complete list of members for JY9511.AOChannel, including all inherited members.

ChannelID | JY9511.AOChannel
RangeHigh | JY9511.AOChannel
RangeLow | JY9511.AOChannel
Terminaal | JY9511.AOChannel


9511 C# Programming Manual: Member List

  • AODigitalTrigger
JY9511.AODigitalTrigger Member List

This is the complete list of members for JY9511.AODigitalTrigger, including all inherited members.

Edge | JY9511.AODigitalTrigger
Source | JY9511.AODigitalTrigger


9511 C# Programming Manual: Member List

  • AOSignalExport
JY9511.AOSignalExport Member List

This is the complete list of members for JY9511.AOSignalExport, including all inherited members.

Add(AOSignalExportSource source, SignalExportDestination destination) | JY9511.AOSignalExport
Add(AOSignalExportSource source, List< SignalExportDestination > destinations) | JY9511.AOSignalExport
Clear(SignalExportDestination destination) | JY9511.AOSignalExport
ClearAll() | JY9511.AOSignalExport


9511 C# Programming Manual: Member List

  • AOTrigger
JY9511.AOTrigger Member List

This is the complete list of members for JY9511.AOTrigger, including all inherited members.

Digital | JY9511.AOTrigger
Type | JY9511.AOTrigger


9511 C# Programming Manual: Member List

  • CIAIMCLKTimebase
JY9511.CIAIMCLKTimebase Member List

This is the complete list of members for JY9511.CIAIMCLKTimebase, including all inherited members.

Frequency JY9511.CIAIMCLKTimebase


9511 C# Programming Manual: Member List

  • CIDigitalTrigger
JY9511.CIDigitalTrigger Member List

This is the complete list of members for JY9511.CIDigitalTrigger, including all inherited members.

Edge | JY9511.CIDigitalTrigger
Source | JY9511.CIDigitalTrigger


9511 C# Programming Manual: Member List

  • CIExternalSampleClock
JY9511.CIExternalSampleClock Member List

This is the complete list of members for JY9511.CIExternalSampleClock, including all inherited members.

ExpectedRate | JY9511.CIExternalSampleClock
IgnoreFirstSampleClock | JY9511.CIExternalSampleClock
Terminal | JY9511.CIExternalSampleClock


9511 C# Programming Manual: Member List

  • CIExternalTimebase
JY9511.CIExternalTimebase Member List

This is the complete list of members for JY9511.CIExternalTimebase, including all inherited members.

Frequency | JY9511.CIExternalTimebase
Terminal | JY9511.CIExternalTimebase


9511 C# Programming Manual: Member List

  • CIImplicitSampleClock
JY9511.CIImplicitSampleClock Member List

This is the complete list of members for JY9511.CIImplicitSampleClock, including all inherited members.

ExpectedRate JY9511.CIImplicitSampleClock


9511 C# Programming Manual: Member List

  • CIInternalSampleClock
JY9511.CIInternalSampleClock Member List

This is the complete list of members for JY9511.CIInternalSampleClock, including all inherited members.

IgnoreFirstSampleClock | JY9511.CIInternalSampleClock
Rate | JY9511.CIInternalSampleClock


9511 C# Programming Manual: Member List

  • CISampleClock
JY9511.CISampleClock Member List

This is the complete list of members for JY9511.CISampleClock, including all inherited members.

External | JY9511.CISampleClock
Implicit | JY9511.CISampleClock
Internal | JY9511.CISampleClock
Source | JY9511.CISampleClock


9511 C# Programming Manual: Member List

  • CISignalExport
JY9511.CISignalExport Member List

This is the complete list of members for JY9511.CISignalExport, including all inherited members.

Add(CISignalExportSource source, SignalExportDestination destination) | JY9511.CISignalExport
Add(CISignalExportSource source, List< SignalExportDestination > destinations) | JY9511.CISignalExport
Clear(SignalExportDestination destination) | JY9511.CISignalExport
ClearAll() | JY9511.CISignalExport


9511 C# Programming Manual: Member List

  • CITimebase
JY9511.CITimebase Member List

This is the complete list of members for JY9511.CITimebase, including all inherited members.

AISampleRate | JY9511.CITimebase
External | JY9511.CITimebase
Source | JY9511.CITimebase


9511 C# Programming Manual: Member List

  • CITrigger
JY9511.CITrigger Member List

This is the complete list of members for JY9511.CITrigger, including all inherited members.

Digital | JY9511.CITrigger
Type | JY9511.CITrigger


9511 C# Programming Manual: Member List

  • DDSConfig
JY9511.DDSConfig Member List

This is the complete list of members for JY9511.DDSConfig, including all inherited members.

Amplitude | JY9511.DDSConfig
DDSConfig() | JY9511.DDSConfig
Frequency | JY9511.DDSConfig
Offset | JY9511.DDSConfig


9511 C# Programming Manual: Member List

  • EdgeCounting
JY9511.EdgeCounting Member List

This is the complete list of members for JY9511.EdgeCounting, including all inherited members.

ActiveEdge | JY9511.EdgeCounting
Direction | JY9511.EdgeCounting
DirectionSignalReversed | JY9511.EdgeCounting
DirTerminal | JY9511.EdgeCounting
InitialCount | JY9511.EdgeCounting
InputSignalReversed | JY9511.EdgeCounting
InputTerminal | JY9511.EdgeCounting


9511 C# Programming Manual: Member List

  • ExternalReferenceClock
JY9511.ExternalReferenceClock Member List

This is the complete list of members for JY9511.ExternalReferenceClock, including all inherited members.

Frequency | JY9511.ExternalReferenceClock
Terminal | JY9511.ExternalReferenceClock


9511 C# Programming Manual: Member List

  • FrequencyMeas
JY9511.FrequencyMeas Member List

This is the complete list of members for JY9511.FrequencyMeas, including all inherited members.

InputTerminal | JY9511.FrequencyMeas
Timebase | JY9511.FrequencyMeas


9511 C# Programming Manual: Member List

  • JY9511AITask
JY9511.JY9511AITask Member List

This is the complete list of members for JY9511.JY9511AITask, including all inherited members.

AddChannel(int chID, double rangeLow, double rangeHigh, Coupling coupling, AITerminal terminalCfg, bool enableIEPE) | JY9511.JY9511AITask |
AddChannel(int[] chIDs, double rangeLow, double rangeHigh, Coupling coupling, AITerminal terminalCfg, bool enableIEPE) | JY9511.JY9511AITask |
AddChannel(int[] chIDs, double[] rangeLow, double[] rangeHigh, Coupling[] coupling, AITerminal[] terminalCfg, bool[] enableIEPE) | JY9511.JY9511AITask |
AvailableSamples | JY9511.JY9511AITask |
Channels | JY9511.JY9511AITask |
Commit() | JY9511.JY9511AITask |
DetectIEPEConnection() | JY9511.JY9511AITask |
Device | JY9511.JY9511AITask |
DigitalFiltering | JY9511.JY9511AITask |
GetRecordPreviewData(ref double[,] buf, int samplesPerChannel, int timeout=1000) | JY9511.JY9511AITask |
GetRecordPreviewData(ref double[,] buf, int timeout=1000) | JY9511.JY9511AITask |
GetRecordPreviewData(ref double[] buf, int samplesPerChannel, int timeout=1000) | JY9511.JY9511AITask |
GetRecordPreviewData(ref double[] buf, int timeout=1000) | JY9511.JY9511AITask |
GetRecordStatus(out double recordedLength, out bool recordDone) | JY9511.JY9511AITask |
GetSamplingInfo() | JY9511.JY9511AITask |
GetSamplingInfo(double sampleRate, LPFMode lpfMode) | JY9511.JY9511AITask | static
JY9511AITask(int slotNumber) | JY9511.JY9511AITask |
JY9511AITask(string cardName) | JY9511.JY9511AITask |
Mode | JY9511.JY9511AITask |
ReadData(ref double[] dataBuf, int samplesPerChannel, int timeout) | JY9511.JY9511AITask |
ReadData(ref double[] dataBuf, int timeout=-1) | JY9511.JY9511AITask |
ReadData(ref double[,] dataBuf, int samplesPerChannel, int timeout) | JY9511.JY9511AITask |
ReadData(ref double[,] dataBuf, int timeout=-1) | JY9511.JY9511AITask |
ReadData(IntPtr dataBuf, int samplesPerChannel, int timeout) | JY9511.JY9511AITask |
ReadRawData(ref int[] dataBuf, int samplesPerChannel, int timeout) | JY9511.JY9511AITask |
ReadRawData(ref int[] dataBuf, int timeout=-1) | JY9511.JY9511AITask |
ReadRawData(ref int[,] dataBuf, int samplesPerChannel, int timeout) | JY9511.JY9511AITask |
ReadRawData(IntPtr dataBuf, int samplesPerChannel, int timeout) | JY9511.JY9511AITask |
ReadSinglePoint(ref double[] dataBuf) | JY9511.JY9511AITask |
ReadSinglePoint(ref double readValue, int channel) | JY9511.JY9511AITask |
ReadSingleRawPoint(IntPtr dataBuf) | JY9511.JY9511AITask |
ReadTEDSData(int chID) | JY9511.JY9511AITask |
Record | JY9511.JY9511AITask |
RemoveChannel(int chID) | JY9511.JY9511AITask |
RemoveChannel(int[] chIDs) | JY9511.JY9511AITask |
SampleRate | JY9511.JY9511AITask |
SamplesToAcquire | JY9511.JY9511AITask |
SendSoftwareTrigger() | JY9511.JY9511AITask |
SignalExport | JY9511.JY9511AITask |
Start() | JY9511.JY9511AITask |
StartSync() | JY9511.JY9511AITask |
State | JY9511.JY9511AITask |
Stop() | JY9511.JY9511AITask |
Sync | JY9511.JY9511AITask |
TransferedSamples | JY9511.JY9511AITask |
Trigger | JY9511.JY9511AITask |
WaitUntilDone(int timeout=-1) | JY9511.JY9511AITask |


9511 C# Programming Manual: Member List

  • JY9511AOTask
JY9511.JY9511AOTask Member List

This is the complete list of members for JY9511.JY9511AOTask, including all inherited members.

AddChannel(int chnId, double rangeLow=-10, double rangeHigh=10, AOTerminal terminalCfg=AOTerminal.Differential) | JY9511.JY9511AOTask |
AddChannel(int[] chnsId, double rangeLow=-10, double rangeHigh=10, AOTerminal terminalCfg=AOTerminal.Differential) | JY9511.JY9511AOTask |
AddChannel(int[] chnsId, double[] rangeLow, double[] rangeHigh, AOTerminal[] terminalCfg) | JY9511.JY9511AOTask |
AvailableLenInSamples | JY9511.JY9511AOTask |
BufLenInSamples | JY9511.JY9511AOTask |
Channels | JY9511.JY9511AOTask |
Commit() | JY9511.JY9511AOTask |
Device | JY9511.JY9511AOTask |
GetSamplingInfo() | JY9511.JY9511AOTask |
GetSamplingInfo(double sampleRate) | JY9511.JY9511AOTask | static
JY9511AOTask(int slotNum) | JY9511.JY9511AOTask |
JY9511AOTask(string boardName) | JY9511.JY9511AOTask |
Mode | JY9511.JY9511AOTask |
RemoveChannel(int chnId) | JY9511.JY9511AOTask |
SamplesToUpdate | JY9511.JY9511AOTask |
SendSoftwareTrigger() | JY9511.JY9511AOTask |
SignalExport | JY9511.JY9511AOTask |
Start() | JY9511.JY9511AOTask |
Stop() | JY9511.JY9511AOTask |
Sync | JY9511.JY9511AOTask |
TransferedSamples | JY9511.JY9511AOTask |
Trigger | JY9511.JY9511AOTask |
UpdateRate | JY9511.JY9511AOTask |
WaitUntilDone(int timeout=-1) | JY9511.JY9511AOTask |
WriteData(double[,] buf, int timeout=10000) | JY9511.JY9511AOTask |
WriteData(IntPtr buf, int samplesPerChannel, int timeout=10000) | JY9511.JY9511AOTask |
WriteData(double[] buf, int timeout=10000) | JY9511.JY9511AOTask |
WriteRawData(int[,] buf, int timeout=10000) | JY9511.JY9511AOTask |
WriteRawData(IntPtr buf, int samplesPerChannel, int timeout=10000) | JY9511.JY9511AOTask |
WriteRawData(int[] buf, int timeout=10000) | JY9511.JY9511AOTask |
WriteSinglePoint(DDSConfig ddsConfig) | JY9511.JY9511AOTask |
WriteSinglePoint(DDSConfig[] ddsConfigs) | JY9511.JY9511AOTask |


9511 C# Programming Manual: Member List

  • JY9511CITask
JY9511.JY9511CITask Member List

This is the complete list of members for JY9511.JY9511CITask, including all inherited members.

AvailableSamples | JY9511.JY9511CITask
Device | JY9511.JY9511CITask
EdgeCounting | JY9511.JY9511CITask
FrequencyMeas | JY9511.JY9511CITask
JY9511CITask(int slotNum, int channel) | JY9511.JY9511CITask
JY9511CITask(string boardName, int channel) | JY9511.JY9511CITask
Mode | JY9511.JY9511CITask
PeriodMeas | JY9511.JY9511CITask
PulseMeas | JY9511.JY9511CITask
ReadData(ref uint[] bufCount, int samplesToAcquire, int timeout=10000) | JY9511.JY9511CITask
ReadData(ref uint[] bufCount, int timeout=10000) | JY9511.JY9511CITask
ReadData(ref int[] bufCount, int samplesToAcquire, int timeout=10000) | JY9511.JY9511CITask
ReadData(ref int[] bufCount, int timeout=10000) | JY9511.JY9511CITask
ReadData(ref double[] bufMeasurement, int samplesToAcquire, int timeout=10000) | JY9511.JY9511CITask
ReadData(ref double[] bufMeasurement, int timeout=10000) | JY9511.JY9511CITask
ReadData(ref double[] bufMeasurement1, ref double[] bufMeasurement2, int samplesToAcquire, int timeout=10000) | JY9511.JY9511CITask
ReadData(ref double[] bufMeasurement1, ref double[] bufMeasurement2, int timeout=10000) | JY9511.JY9511CITask
ReadSinglePoint(ref uint count) | JY9511.JY9511CITask
ReadSinglePoint(ref int count) | JY9511.JY9511CITask
ReadSinglePoint(ref double measurement, int timeout=10000) | JY9511.JY9511CITask
ReadSinglePoint(ref double measurement1, ref double measurement2, int timeout=10000) | JY9511.JY9511CITask
SampleClock | JY9511.JY9511CITask
SamplesToAcquire | JY9511.JY9511CITask
SemiPeriodMeas | JY9511.JY9511CITask
SendSoftwareTrigger() | JY9511.JY9511CITask
SignalExport | JY9511.JY9511CITask
Start() | JY9511.JY9511CITask
Stop() | JY9511.JY9511CITask
TransferedSamples | JY9511.JY9511CITask
Trigger | JY9511.JY9511CITask
Type | JY9511.JY9511CITask


9511 C# Programming Manual: Member List

  • LowPassFilter
JY9511.LowPassFilter Member List

This is the complete list of members for JY9511.LowPassFilter, including all inherited members.

Mode JY9511.LowPassFilter


9511 C# Programming Manual: Member List

  • PauseTrigger
JY9511.PauseTrigger Member List

This is the complete list of members for JY9511.PauseTrigger, including all inherited members.

ActivePolarity | JY9511.PauseTrigger
SignalReversed | JY9511.PauseTrigger
Terminal | JY9511.PauseTrigger


9511 C# Programming Manual: Member List

  • PeriodMeas
JY9511.PeriodMeas Member List

This is the complete list of members for JY9511.PeriodMeas, including all inherited members.

InputTerminal | JY9511.PeriodMeas
Timebase | JY9511.PeriodMeas


9511 C# Programming Manual: Member List

  • PulseMeas
JY9511.PulseMeas Member List

This is the complete list of members for JY9511.PulseMeas, including all inherited members.

InputTerminal | JY9511.PulseMeas
SignalReversed | JY9511.PulseMeas
StartingEdge | JY9511.PulseMeas
Timebase | JY9511.PulseMeas


9511 C# Programming Manual: Member List

  • ReferenceClock
JY9511.ReferenceClock Member List

This is the complete list of members for JY9511.ReferenceClock, including all inherited members.

External | JY9511.ReferenceClock
Source | JY9511.ReferenceClock


9511 C# Programming Manual: Member List

  • SemiPeriodMeas
JY9511.SemiPeriodMeas Member List

This is the complete list of members for JY9511.SemiPeriodMeas, including all inherited members.

InputTerminal | JY9511.SemiPeriodMeas
SignalReversed | JY9511.SemiPeriodMeas
StartingEdge | JY9511.SemiPeriodMeas
Timebase | JY9511.SemiPeriodMeas


9511 C# Programming Manual: Member List

  • Sync
JY9511.Sync Member List

This is the complete list of members for JY9511.Sync, including all inherited members.

Synchronized | JY9511.Sync
Terminal | JY9511.Sync
Topology | JY9511.Sync


9511 C# Programming Manual: Class Index

Class Index
A | C | D | E | F | J | L | P | R | S
A
AIAnalogEdgeComparator (JY9511)
AIAnalogHysteresisComparator (JY9511)
AIAnalogTrigger (JY9511)
AIAnalogWindowComparator (JY9511)
AIChannel (JY9511)
AIDigitalFiltering (JY9511)
AIDigitalTrigger (JY9511)
AIRecord (JY9511)
AISignalExport (JY9511)
AITrigger (JY9511)
AOChannel (JY9511)
AODigitalTrigger (JY9511)
AOSignalExport (JY9511)
AOTrigger (JY9511)
C
CIAIMCLKTimebase (JY9511)
CIDigitalTrigger (JY9511)
CIExternalSampleClock (JY9511)
CIExternalTimebase (JY9511)
CIImplicitSampleClock (JY9511)
CIInternalSampleClock (JY9511)
CISampleClock (JY9511)
CISignalExport (JY9511)
CITimebase (JY9511)
CITrigger (JY9511)
D
DDSConfig (JY9511)
E
EdgeCounting (JY9511)
ExternalReferenceClock (JY9511)
F
FrequencyMeas (JY9511)
J
JY9511AITask (JY9511)
JY9511AOTask (JY9511)
JY9511CITask (JY9511)
L
LowPassFilter (JY9511)
P
PauseTrigger (JY9511)
PeriodMeas (JY9511)
PulseMeas (JY9511)
R
ReferenceClock (JY9511)
S
SemiPeriodMeas (JY9511)
Sync (JY9511)


9511 C# Programming Manual: D:/OneDrive/Desktop Directory Reference

  • File List
  • OneDrive
  • Desktop
Desktop Directory Reference

Directories

         9511


9511 C# Programming Manual: D:/OneDrive/Desktop/9511 Directory Reference

  • File List
  • OneDrive
  • Desktop
  • 9511
9511 Directory Reference

Directories

         C#


9511 C# Programming Manual: D:/OneDrive Directory Reference

  • File List
  • OneDrive
OneDrive Directory Reference

Directories

         Desktop


9511 C# Programming Manual: File List

  • File List
File List
Here is a list of all files with brief descriptions:
[detail level 12345]
 OneDrive
Desktop
9511
C#
AIChannel.cs
AIDigitalFiltering.cs
AISignalExport.cs
AISync.cs
AITrigger.cs
JY9511AITask.cs
JY9511AOTask.cs
JY9511CITask.cs
ReferenceClock.cs
TEDSCommon.cs


9511 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all class members with links to the classes they belong to:

- a -

  • ActiveEdge : JY9511.EdgeCounting
  • ActivePolarity : JY9511.PauseTrigger
  • Add() : JY9511.AISignalExport, JY9511.AOSignalExport, JY9511.CISignalExport
  • AddChannel() : JY9511.JY9511AITask, JY9511.JY9511AOTask
  • AISampleRate : JY9511.CITimebase
  • Amplitude : JY9511.DDSConfig
  • Analog : JY9511.AITrigger
  • AvailableLenInSamples : JY9511.JY9511AOTask
  • AvailableSamples : JY9511.JY9511AITask, JY9511.JY9511CITask


9511 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all class members with links to the classes they belong to:

- b -

  • BufLenInSamples : JY9511.JY9511AOTask


9511 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all class members with links to the classes they belong to:

- c -

  • ChannelID : JY9511.AIChannel, JY9511.AOChannel
  • Channels : JY9511.JY9511AITask, JY9511.JY9511AOTask
  • Clear() : JY9511.AISignalExport, JY9511.AOSignalExport, JY9511.CISignalExport
  • ClearAll() : JY9511.AISignalExport, JY9511.AOSignalExport, JY9511.CISignalExport
  • Commit() : JY9511.JY9511AITask, JY9511.JY9511AOTask
  • Comparator : JY9511.AIAnalogTrigger
  • Condition : JY9511.AIAnalogWindowComparator
  • Coupling : JY9511.AIChannel


9511 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all class members with links to the classes they belong to:

- d -

  • DDSConfig() : JY9511.DDSConfig
  • DetectIEPEConnection() : JY9511.JY9511AITask
  • Device : JY9511.JY9511AITask, JY9511.JY9511AOTask, JY9511.JY9511CITask
  • Digital : JY9511.AITrigger, JY9511.AOTrigger, JY9511.CITrigger
  • DigitalFiltering : JY9511.JY9511AITask
  • Direction : JY9511.EdgeCounting
  • DirectionSignalReversed : JY9511.EdgeCounting
  • DirTerminal : JY9511.EdgeCounting


9511 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all class members with links to the classes they belong to:

- e -

  • Edge : JY9511.AIAnalogTrigger, JY9511.AIDigitalTrigger, JY9511.AODigitalTrigger, JY9511.CIDigitalTrigger
  • EdgeCounting : JY9511.JY9511CITask
  • ExpectedRate : JY9511.CIExternalSampleClock, JY9511.CIImplicitSampleClock
  • External : JY9511.CISampleClock, JY9511.CITimebase, JY9511.ReferenceClock


9511 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all class members with links to the classes they belong to:

- f -

  • FileFormat : JY9511.AIRecord
  • FilePath : JY9511.AIRecord
  • Frequency : JY9511.CIAIMCLKTimebase, JY9511.CIExternalTimebase, JY9511.DDSConfig, JY9511.ExternalReferenceClock
  • FrequencyMeas : JY9511.JY9511CITask


9511 C# Programming Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • Properties
  • a
  • c
  • d
  • g
  • j
  • r
  • s
  • w
Here is a list of all functions with links to the classes they belong to:

- a -

  • Add() : JY9511.AISignalExport, JY9511.AOSignalExport, JY9511.CISignalExport
  • AddChannel() : JY9511.JY9511AITask, JY9511.JY9511AOTask

- c -

  • Clear() : JY9511.AISignalExport, JY9511.AOSignalExport, JY9511.CISignalExport
  • ClearAll() : JY9511.AISignalExport, JY9511.AOSignalExport, JY9511.CISignalExport
  • Commit() : JY9511.JY9511AITask, JY9511.JY9511AOTask

- d -

  • DDSConfig() : JY9511.DDSConfig
  • DetectIEPEConnection() : JY9511.JY9511AITask

- g -

  • GetRecordPreviewData() : JY9511.JY9511AITask
  • GetRecordStatus() : JY9511.JY9511AITask
  • GetSamplingInfo() : JY9511.JY9511AITask, JY9511.JY9511AOTask

- j -

  • JY9511AITask() : JY9511.JY9511AITask
  • JY9511AOTask() : JY9511.JY9511AOTask
  • JY9511CITask() : JY9511.JY9511CITask

- r -

  • ReadData() : JY9511.JY9511AITask, JY9511.JY9511CITask
  • ReadRawData() : JY9511.JY9511AITask
  • ReadSinglePoint() : JY9511.JY9511AITask, JY9511.JY9511CITask
  • ReadSingleRawPoint() : JY9511.JY9511AITask
  • ReadTEDSData() : JY9511.JY9511AITask
  • RemoveChannel() : JY9511.JY9511AITask, JY9511.JY9511AOTask

- s -

  • SendSoftwareTrigger() : JY9511.JY9511AITask, JY9511.JY9511AOTask, JY9511.JY9511CITask
  • Start() : JY9511.JY9511AITask, JY9511.JY9511AOTask, JY9511.JY9511CITask
  • StartSync() : JY9511.JY9511AITask
  • Stop() : JY9511.JY9511AITask, JY9511.JY9511AOTask, JY9511.JY9511CITask

- w -

  • WaitUntilDone() : JY9511.JY9511AITask, JY9511.JY9511AOTask
  • WriteData() : JY9511.JY9511AOTask
  • WriteRawData() : JY9511.JY9511AOTask
  • WriteSinglePoint() : JY9511.JY9511AOTask


9511 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all class members with links to the classes they belong to:

- g -

  • GetRecordPreviewData() : JY9511.JY9511AITask
  • GetRecordStatus() : JY9511.JY9511AITask
  • GetSamplingInfo() : JY9511.JY9511AITask, JY9511.JY9511AOTask


9511 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all class members with links to the classes they belong to:

- h -

  • HighThreshold : JY9511.AIAnalogHysteresisComparator, JY9511.AIAnalogWindowComparator
  • Hysteresis : JY9511.AIAnalogTrigger


9511 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all class members with links to the classes they belong to:

- i -

  • IEPEEnabled : JY9511.AIChannel
  • IgnoreFirstSampleClock : JY9511.CIExternalSampleClock, JY9511.CIInternalSampleClock
  • Implicit : JY9511.CISampleClock
  • InitialCount : JY9511.EdgeCounting
  • InputSignalReversed : JY9511.EdgeCounting
  • InputTerminal : JY9511.EdgeCounting, JY9511.FrequencyMeas, JY9511.PeriodMeas, JY9511.PulseMeas, JY9511.SemiPeriodMeas
  • Internal : JY9511.CISampleClock


9511 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all class members with links to the classes they belong to:

- j -

  • JY9511AITask() : JY9511.JY9511AITask
  • JY9511AOTask() : JY9511.JY9511AOTask
  • JY9511CITask() : JY9511.JY9511CITask


9511 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all class members with links to the classes they belong to:

- l -

  • Length : JY9511.AIRecord
  • LowThreshold : JY9511.AIAnalogHysteresisComparator, JY9511.AIAnalogWindowComparator
  • LPF : JY9511.AIDigitalFiltering


9511 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all class members with links to the classes they belong to:

- m -

  • Mode : JY9511.AIRecord, JY9511.AITrigger, JY9511.JY9511AITask, JY9511.JY9511AOTask, JY9511.JY9511CITask, JY9511.LowPassFilter


9511 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all class members with links to the classes they belong to:

- o -

  • Offset : JY9511.DDSConfig


9511 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all class members with links to the classes they belong to:

- p -

  • PeriodMeas : JY9511.JY9511CITask
  • PreTriggerSamples : JY9511.AITrigger
  • PulseMeas : JY9511.JY9511CITask


9511 C# Programming Manual: Class Members - Properties

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all properties with links to the classes they belong to:

- a -

  • ActiveEdge : JY9511.EdgeCounting
  • ActivePolarity : JY9511.PauseTrigger
  • AISampleRate : JY9511.CITimebase
  • Amplitude : JY9511.DDSConfig
  • Analog : JY9511.AITrigger
  • AvailableLenInSamples : JY9511.JY9511AOTask
  • AvailableSamples : JY9511.JY9511AITask, JY9511.JY9511CITask

- b -

  • BufLenInSamples : JY9511.JY9511AOTask

- c -

  • ChannelID : JY9511.AIChannel, JY9511.AOChannel
  • Channels : JY9511.JY9511AITask, JY9511.JY9511AOTask
  • Comparator : JY9511.AIAnalogTrigger
  • Condition : JY9511.AIAnalogWindowComparator
  • Coupling : JY9511.AIChannel

- d -

  • Device : JY9511.JY9511AITask, JY9511.JY9511AOTask, JY9511.JY9511CITask
  • Digital : JY9511.AITrigger, JY9511.AOTrigger, JY9511.CITrigger
  • DigitalFiltering : JY9511.JY9511AITask
  • Direction : JY9511.EdgeCounting
  • DirectionSignalReversed : JY9511.EdgeCounting
  • DirTerminal : JY9511.EdgeCounting

- e -

  • Edge : JY9511.AIAnalogTrigger, JY9511.AIDigitalTrigger, JY9511.AODigitalTrigger, JY9511.CIDigitalTrigger
  • EdgeCounting : JY9511.JY9511CITask
  • ExpectedRate : JY9511.CIExternalSampleClock, JY9511.CIImplicitSampleClock
  • External : JY9511.CISampleClock, JY9511.CITimebase, JY9511.ReferenceClock

- f -

  • FileFormat : JY9511.AIRecord
  • FilePath : JY9511.AIRecord
  • Frequency : JY9511.CIAIMCLKTimebase, JY9511.CIExternalTimebase, JY9511.DDSConfig, JY9511.ExternalReferenceClock
  • FrequencyMeas : JY9511.JY9511CITask

- h -

  • Hysteresis : JY9511.AIAnalogTrigger

- i -

  • IEPEEnabled : JY9511.AIChannel
  • IgnoreFirstSampleClock : JY9511.CIExternalSampleClock, JY9511.CIInternalSampleClock
  • Implicit : JY9511.CISampleClock
  • InitialCount : JY9511.EdgeCounting
  • InputSignalReversed : JY9511.EdgeCounting
  • InputTerminal : JY9511.EdgeCounting, JY9511.FrequencyMeas, JY9511.PeriodMeas, JY9511.PulseMeas, JY9511.SemiPeriodMeas
  • Internal : JY9511.CISampleClock

- l -

  • Length : JY9511.AIRecord
  • LPF : JY9511.AIDigitalFiltering

- m -

  • Mode : JY9511.AIRecord, JY9511.AITrigger, JY9511.JY9511AITask, JY9511.JY9511AOTask, JY9511.JY9511CITask, JY9511.LowPassFilter

- o -

  • Offset : JY9511.DDSConfig

- p -

  • PeriodMeas : JY9511.JY9511CITask
  • PreTriggerSamples : JY9511.AITrigger
  • PulseMeas : JY9511.JY9511CITask

- r -

  • RangeHigh : JY9511.AIChannel, JY9511.AOChannel
  • RangeLow : JY9511.AIChannel, JY9511.AOChannel
  • Rate : JY9511.CIInternalSampleClock
  • RawDataScaleFactor : JY9511.AIChannel
  • Record : JY9511.JY9511AITask
  • ReTriggerCount : JY9511.AITrigger

- s -

  • SampleClock : JY9511.JY9511CITask
  • SampleRate : JY9511.JY9511AITask
  • SamplesToAcquire : JY9511.JY9511AITask, JY9511.JY9511CITask
  • SamplesToUpdate : JY9511.JY9511AOTask
  • SemiPeriodMeas : JY9511.JY9511CITask
  • SignalExport : JY9511.JY9511AITask, JY9511.JY9511AOTask, JY9511.JY9511CITask
  • SignalReversed : JY9511.PauseTrigger, JY9511.PulseMeas, JY9511.SemiPeriodMeas
  • Slope : JY9511.AIAnalogEdgeComparator, JY9511.AIAnalogHysteresisComparator
  • Source : JY9511.AIAnalogTrigger, JY9511.AIDigitalTrigger, JY9511.AODigitalTrigger, JY9511.CIDigitalTrigger, JY9511.CISampleClock, JY9511.CITimebase, JY9511.ReferenceClock
  • StartingEdge : JY9511.PulseMeas, JY9511.SemiPeriodMeas
  • State : JY9511.JY9511AITask
  • Sync : JY9511.JY9511AITask, JY9511.JY9511AOTask
  • Synchronized : JY9511.Sync

- t -

  • Terminaal : JY9511.AOChannel
  • Terminal : JY9511.AIChannel, JY9511.CIExternalSampleClock, JY9511.CIExternalTimebase, JY9511.ExternalReferenceClock, JY9511.PauseTrigger, JY9511.Sync
  • Timebase : JY9511.FrequencyMeas, JY9511.PeriodMeas, JY9511.PulseMeas, JY9511.SemiPeriodMeas
  • Topology : JY9511.Sync
  • TransferedSamples : JY9511.JY9511AITask, JY9511.JY9511AOTask, JY9511.JY9511CITask
  • Trigger : JY9511.JY9511AITask, JY9511.JY9511AOTask, JY9511.JY9511CITask
  • Type : JY9511.AITrigger, JY9511.AOTrigger, JY9511.CITrigger, JY9511.JY9511CITask

- u -

  • UpdateRate : JY9511.JY9511AOTask

- w -

  • Window : JY9511.AIAnalogTrigger


9511 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all class members with links to the classes they belong to:

- r -

  • RangeHigh : JY9511.AIChannel, JY9511.AOChannel
  • RangeLow : JY9511.AIChannel, JY9511.AOChannel
  • Rate : JY9511.CIInternalSampleClock
  • RawDataScaleFactor : JY9511.AIChannel
  • ReadData() : JY9511.JY9511AITask, JY9511.JY9511CITask
  • ReadRawData() : JY9511.JY9511AITask
  • ReadSinglePoint() : JY9511.JY9511AITask, JY9511.JY9511CITask
  • ReadSingleRawPoint() : JY9511.JY9511AITask
  • ReadTEDSData() : JY9511.JY9511AITask
  • Record : JY9511.JY9511AITask
  • RemoveChannel() : JY9511.JY9511AITask, JY9511.JY9511AOTask
  • ReTriggerCount : JY9511.AITrigger


9511 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all class members with links to the classes they belong to:

- s -

  • SampleClock : JY9511.JY9511CITask
  • SampleRate : JY9511.JY9511AITask
  • SamplesToAcquire : JY9511.JY9511AITask, JY9511.JY9511CITask
  • SamplesToUpdate : JY9511.JY9511AOTask
  • SemiPeriodMeas : JY9511.JY9511CITask
  • SendSoftwareTrigger() : JY9511.JY9511AITask, JY9511.JY9511AOTask, JY9511.JY9511CITask
  • SignalExport : JY9511.JY9511AITask, JY9511.JY9511AOTask, JY9511.JY9511CITask
  • SignalReversed : JY9511.PauseTrigger, JY9511.PulseMeas, JY9511.SemiPeriodMeas
  • Slope : JY9511.AIAnalogEdgeComparator, JY9511.AIAnalogHysteresisComparator
  • Source : JY9511.AIAnalogTrigger, JY9511.AIDigitalTrigger, JY9511.AODigitalTrigger, JY9511.CIDigitalTrigger, JY9511.CISampleClock, JY9511.CITimebase, JY9511.ReferenceClock
  • Start() : JY9511.JY9511AITask, JY9511.JY9511AOTask, JY9511.JY9511CITask
  • StartingEdge : JY9511.PulseMeas, JY9511.SemiPeriodMeas
  • StartSync() : JY9511.JY9511AITask
  • State : JY9511.JY9511AITask
  • Stop() : JY9511.JY9511AITask, JY9511.JY9511AOTask, JY9511.JY9511CITask
  • Sync : JY9511.JY9511AITask, JY9511.JY9511AOTask
  • Synchronized : JY9511.Sync


9511 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all class members with links to the classes they belong to:

- t -

  • Terminaal : JY9511.AOChannel
  • Terminal : JY9511.AIChannel, JY9511.CIExternalSampleClock, JY9511.CIExternalTimebase, JY9511.ExternalReferenceClock, JY9511.PauseTrigger, JY9511.Sync
  • Threshold : JY9511.AIAnalogEdgeComparator
  • Timebase : JY9511.FrequencyMeas, JY9511.PeriodMeas, JY9511.PulseMeas, JY9511.SemiPeriodMeas
  • Topology : JY9511.Sync
  • TransferedSamples : JY9511.JY9511AITask, JY9511.JY9511AOTask, JY9511.JY9511CITask
  • Trigger : JY9511.JY9511AITask, JY9511.JY9511AOTask, JY9511.JY9511CITask
  • Type : JY9511.AITrigger, JY9511.AOTrigger, JY9511.CITrigger, JY9511.JY9511CITask


9511 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all class members with links to the classes they belong to:

- u -

  • UpdateRate : JY9511.JY9511AOTask


9511 C# Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Properties
Here is a list of all variables with links to the classes they belong to:
  • HighThreshold : JY9511.AIAnalogHysteresisComparator, JY9511.AIAnalogWindowComparator
  • LowThreshold : JY9511.AIAnalogHysteresisComparator, JY9511.AIAnalogWindowComparator
  • Threshold : JY9511.AIAnalogEdgeComparator


9511 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all class members with links to the classes they belong to:

- w -

  • WaitUntilDone() : JY9511.JY9511AITask, JY9511.JY9511AOTask
  • Window : JY9511.AIAnalogTrigger
  • WriteData() : JY9511.JY9511AOTask
  • WriteRawData() : JY9511.JY9511AOTask
  • WriteSinglePoint() : JY9511.JY9511AOTask


9511 C# Programming Manual: Main Page

9511 C# Programming Manual Documentation


9511 C# Programming Manual: JY9511.TEDS Namespace Reference

  • Package List
  • Package Members
  • JY9511
  • TEDS
Classes
JY9511.TEDS Namespace Reference

Classes

class | TEDSUtilities
class | TEDSChipInfo


9511 C# Programming Manual: Package Members

  • Package List
  • Package Members
  • All
  • Enumerations
  • a
  • c
  • e
  • f
  • i
  • l
  • q
  • r
  • s
  • t
  • v
Here is a list of all namespace members with links to the namespace documentation for each member:

- a -

  • AIAnalogTriggerComparator : JY9511
  • AIAnalogTriggerEdge : JY9511
  • AIAnalogTriggerSource : JY9511
  • AIAnalogWindowCondition : JY9511
  • AIDigitalTriggerEdge : JY9511
  • AIDigitalTriggerSource : JY9511
  • AIMode : JY9511
  • AISignalExportSource : JY9511
  • AITerminal : JY9511
  • AITriggerMode : JY9511
  • AITriggerType : JY9511
  • AODigitalTriggerEdge : JY9511
  • AODigitalTriggerSource : JY9511
  • AOMode : JY9511
  • AOSignalExportSource : JY9511
  • AOTerminal : JY9511
  • AOTriggerType : JY9511

- c -

  • CIDigitalTriggerEdge : JY9511
  • CIDigitalTriggerSource : JY9511
  • CIMode : JY9511
  • CISampleClockSource : JY9511
  • CISignalExportSource : JY9511
  • CITimebaseSource : JY9511
  • CITriggerType : JY9511
  • CIType : JY9511
  • ClockTerminal : JY9511
  • CountDirection : JY9511
  • Coupling : JY9511

- e -

  • EdgeCntOunEvtIdleState : JY9511
  • EdgeType : JY9511
  • ExternalReferenceClockTerminal : JY9511

- f -

  • FileFormat : JY9511

- i -

  • IEPEConnectionStatus : JY9511
  • InputTerminal : JY9511
  • IOTerminal : JY9511

- l -

  • LevelPolarity : JY9511
  • LPFMode : JY9511

- q -

  • QuadEncodingType : JY9511

- r -

  • RecordMode : JY9511
  • ReferenceClockSource : JY9511

- s -

  • SamplingState : JY9511
  • SignalExportDestination : JY9511
  • SyncTerminal : JY9511
  • SyncTopology : JY9511

- t -

  • TimebaseExternalTerminal : JY9511

- v -

  • ValueReturnMode : JY9511


9511 C# Programming Manual: Package Members

  • Package List
  • Package Members
  • All
  • Enumerations
  • a
  • c
  • e
  • f
  • i
  • l
  • q
  • r
  • s
  • t
  • v
Here is a list of all namespace enums with links to the namespace documentation for each enum:

- a -

  • AIAnalogTriggerComparator : JY9511
  • AIAnalogTriggerEdge : JY9511
  • AIAnalogTriggerSource : JY9511
  • AIAnalogWindowCondition : JY9511
  • AIDigitalTriggerEdge : JY9511
  • AIDigitalTriggerSource : JY9511
  • AIMode : JY9511
  • AISignalExportSource : JY9511
  • AITerminal : JY9511
  • AITriggerMode : JY9511
  • AITriggerType : JY9511
  • AODigitalTriggerEdge : JY9511
  • AODigitalTriggerSource : JY9511
  • AOMode : JY9511
  • AOSignalExportSource : JY9511
  • AOTerminal : JY9511
  • AOTriggerType : JY9511

- c -

  • CIDigitalTriggerEdge : JY9511
  • CIDigitalTriggerSource : JY9511
  • CIMode : JY9511
  • CISampleClockSource : JY9511
  • CISignalExportSource : JY9511
  • CITimebaseSource : JY9511
  • CITriggerType : JY9511
  • CIType : JY9511
  • ClockTerminal : JY9511
  • CountDirection : JY9511
  • Coupling : JY9511

- e -

  • EdgeCntOunEvtIdleState : JY9511
  • EdgeType : JY9511
  • ExternalReferenceClockTerminal : JY9511

- f -

  • FileFormat : JY9511

- i -

  • IEPEConnectionStatus : JY9511
  • InputTerminal : JY9511
  • IOTerminal : JY9511

- l -

  • LevelPolarity : JY9511
  • LPFMode : JY9511

- q -

  • QuadEncodingType : JY9511

- r -

  • RecordMode : JY9511
  • ReferenceClockSource : JY9511

- s -

  • SamplingState : JY9511
  • SignalExportDestination : JY9511
  • SyncTerminal : JY9511
  • SyncTopology : JY9511

- t -

  • TimebaseExternalTerminal : JY9511

- v -

  • ValueReturnMode : JY9511


9511 C# Programming Manual: Package List

  • Package List
  • Package Members
Package List
Here are the packages with brief descriptions (if available):
[detail level 12]
N JY9511
N TEDS