9515 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/9515 Directory Reference

9515 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 9515
9515 Directory Reference

Files

JY9515CoreOOAITask.h
JY9515CoreOOCommon.h
JY9515CoreOODevice.h
JY9515CoreOOLog.h
Generated by doxygen 1.13.2


9515 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/9515/JY9515CoreOOAITask.h File Reference

  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 9515
Classes | Namespaces | Macros | Enumerations | Variables
JY9515CoreOOAITask.h File Reference
#include <memory>
#include <mutex>
#include <map>
#include <fstream>
#include <cstring>
#include <cstddef>
#include "JY9515CoreOOCommon.h"
#include "JY9515CoreOODevice.h"

Classes

class | JY9515CoreOO::JY9515CoreOOAITask
aiTask类 More...
class | JY9515CoreOO::AIChannel
AI Channel. More...
class | JY9515CoreOO::AITrigger
class | JY9515CoreOO::AIDigitalTrigger
AI Digital trigger params. More...
class | JY9515CoreOO::AIAnalogHysteresisComparator
AI Analog Hysteresis Comparator. More...
class | JY9515CoreOO::AIAnalogWindowComparator
AI Analog Window Comparator. More...
class | JY9515CoreOO::AIAnalogEdgeComparator
AI Analog Edge Comparator. More...
class | JY9515CoreOO::AIAnalogTrigger
AI Analog Trigger. More...
class | JY9515CoreOO::AISignalExport
AI Signal Export Class. More...
class | JY9515CoreOO::AISync
class | JY9515CoreOO::LowPassFilter
class | JY9515CoreOO::HighPassFilter
High-Pass Filter Configuration Class. More...
class | JY9515CoreOO::FlatnessCompensation
Flatness Compensation Parameters. More...
class | JY9515CoreOO::AIDigitalFiltering
AI Digital Filtering Connfiguration Class. More...
class | JY9515CoreOO::JY9515DAC
JY9515 DAC Configuration. More...
class | JY9515CoreOO::ConversionStatus
Get ADC conversion status on all enabled channels. More...

Namespaces

namespace JY9515CoreOO

Macros

#define _CRT_SECURE_NO_WARNINGS

Enumerations

enum class | JY9515CoreOO::AIMode { JY9515CoreOO::Finite , JY9515CoreOO::Continuous , JY9515CoreOO::Single }
enum class | JY9515CoreOO::IEPEConnectionStatus { JY9515CoreOO::Normal = 0 , JY9515CoreOO::OpenCircuit = 1 , JY9515CoreOO::ShortCircuit = 2 }
IEPE Connection Status. More...
enum class JY9515CoreOO::AIRange {
JY9515CoreOO::_10V = JY9515Import::JY9515_Range_10V , JY9515CoreOO::_5V = JY9515Import::JY9515_Range_5V , JY9515CoreOO::_2p5V = JY9515Import::JY9515_Range_2p5V , JY9515CoreOO::_1p25V = JY9515Import::JY9515_Range_1p25V ,
JY9515CoreOO::_0p625V = JY9515Import::JY9515_Range_0p625V , JY9515CoreOO::_0p3125V = JY9515Import::JY9515_Range_0p3125V
}
enum class | JY9515CoreOO::Coupling { JY9515CoreOO::AC = JY9515Import::JY9515_Coupling_AC , JY9515CoreOO::DC = JY9515Import::JY9515_Coupling_DC }
Coupling. More...
enum class | JY9515CoreOO::AITriggerType { JY9515CoreOO::Immediately = JY9515Import::JY9515_TriggerType_Immediately , JY9515CoreOO::Digital = JY9515Import::JY9515_TriggerType_Digital , JY9515CoreOO::Software = JY9515Import::JY9515_TriggerType_Software , JY9515CoreOO::Analog = JY9515Import::JY9515_TriggerType_Analog }
AI trigger type enum type. More...
enum class | JY9515CoreOO::AITriggerMode { JY9515CoreOO::Start , JY9515CoreOO::Reference }
AI trigger mode enum type. More...
enum class JY9515CoreOO::AIAnalogTriggerSource {
JY9515CoreOO::Channel_0 , JY9515CoreOO::Channel_1 , JY9515CoreOO::Channel_2 , JY9515CoreOO::Channel_3 ,
JY9515CoreOO::Channel_4 , JY9515CoreOO::Channel_5 , JY9515CoreOO::Channel_6 , JY9515CoreOO::Channel_7
}
Analog Trigger source. More...
enum class JY9515CoreOO::AIDigitalTriggerSource {
JY9515CoreOO::Ext_Trig = JY9515Import::JY9515_DigitalTriggerSource_External , JY9515CoreOO::PXI_Trig0 = JY9515Import::JY9515_DigitalTriggerSource_BUS_0 , JY9515CoreOO::PXI_Trig1 = JY9515Import::JY9515_DigitalTriggerSource_BUS_1 , JY9515CoreOO::PXI_Trig2 = JY9515Import::JY9515_DigitalTriggerSource_BUS_2 ,
JY9515CoreOO::PXI_Trig3 = JY9515Import::JY9515_DigitalTriggerSource_BUS_3 , JY9515CoreOO::PXI_Trig4 = JY9515Import::JY9515_DigitalTriggerSource_BUS_4 , JY9515CoreOO::PXI_Trig5 = JY9515Import::JY9515_DigitalTriggerSource_BUS_5 , JY9515CoreOO::PXI_Trig6 = JY9515Import::JY9515_DigitalTriggerSource_BUS_6 ,
JY9515CoreOO::PXI_Trig7 = JY9515Import::JY9515_DigitalTriggerSource_BUS_7 , JY9515CoreOO::PXI_Star = JY9515Import::JY9515_DigitalTriggerSource_STAR
}
AI digital trigger source enum type. More...
enum class | JY9515CoreOO::AIDigitalTriggerEdge { JY9515CoreOO::Rising = 0x0 , JY9515CoreOO::Falling = 0x1 }
AI Digital Trigger Edge enum type. More...
enum class | JY9515CoreOO::AIAnalogTriggerEdge { JY9515CoreOO::Rising , JY9515CoreOO::Falling }
AI Analog Trigger Edge. More...
enum class | JY9515CoreOO::AIAnalogWindowCondition { JY9515CoreOO::Entering , JY9515CoreOO::Leaving }
AI Analog Window Trigger Condition. More...
enum class | JY9515CoreOO::AIAnalogTriggerComparator { JY9515CoreOO::Edge , JY9515CoreOO::Hysteresis , JY9515CoreOO::Window }
AI Analog Trigger Comparator. More...
enum class JY9515CoreOO::AISignalExportSource {
JY9515CoreOO::SampleClock = JY9515Import::JY9515_EXPORT_SAMPLE_CLOCK , JY9515CoreOO::Sync = JY9515Import::JY9515_EXPORT_SYNC , JY9515CoreOO::ReadyForStartTrigger = JY9515Import::JY9515_EXPORT_RX_READY_FOR_REF_TRIG , JY9515CoreOO::StartTrigger = JY9515Import::JY9515_EXPORT_RX_REF_TRIG ,
JY9515CoreOO::EndOfRecord = JY9515Import::JY9515_EXPORT_RX_END_OF_RECORD , JY9515CoreOO::EndOfAcquisition = JY9515Import::JY9515_EXPORT_RX_ENGINE_END
}
AI Signal Export Source Enum. More...
enum class | JY9515CoreOO::SyncTopology { JY9515CoreOO::Independent , JY9515CoreOO::Master , JY9515CoreOO::Slave }
Synchronization board configuration. More...
enum JY9515CoreOO::SyncTerminal {
JY9515CoreOO::Ext_Trig , JY9515CoreOO::PXI_Trig0 , JY9515CoreOO::PXI_Trig1 , JY9515CoreOO::PXI_Trig2 ,
JY9515CoreOO::PXI_Trig3 , JY9515CoreOO::PXI_Trig4 , JY9515CoreOO::PXI_Trig5 , JY9515CoreOO::PXI_Trig6 ,
JY9515CoreOO::PXI_Trig7 , JY9515CoreOO::PXI_Star
}
AI digital trigger source enum type. More...
enum | JY9515CoreOO::SyncState { JY9515CoreOO::WaitingSync , JY9515CoreOO::Synchronized , JY9515CoreOO::Invalid }
Sync State. More...
enum | JY9515CoreOO::HPFOrder { JY9515CoreOO::OneOrder = 1 , JY9515CoreOO::TwoOrder = 2 }
High-pass filter order. More...
enum | JY9515CoreOO::ChoppingFrequency { JY9515CoreOO::fMod32 , JY9515CoreOO::fMod8 }
Modulator Chopping Frequency Enum. More...
enum class JY9515CoreOO::SamplingState {
JY9515CoreOO::Idle = 1 << 0 , JY9515CoreOO::WaitingForStart = 1 << 1 , JY9515CoreOO::PreSampling = 1 << 2 , JY9515CoreOO::WaitingForRefTrigger = 1 << 3 ,
JY9515CoreOO::PostSampling = 1 << 4 , JY9515CoreOO::RecordCompleted = 1 << 5 , JY9515CoreOO::WaitingForAdvanceTrigger = 1 << 6 , JY9515CoreOO::Done = 1 << 7
}
Sampling State Enum. More...

Variables

const std::map< int, std::string > JY9515CoreOO::AIRangeDescriptions

Macro Definition Documentation

◆ _CRT_SECURE_NO_WARNINGS

#define _CRT_SECURE_NO_WARNINGS


9515 C++ Programming Manual: JY9515CoreOO::JY9515CoreOOAITask Class Reference

  • Class List
  • Class Index
  • Class Members
  • JY9515CoreOO
  • JY9515CoreOOAITask
Public Member Functions | Public Attributes | List of all members
JY9515CoreOO::JY9515CoreOOAITask Class Reference

aiTask类 More...

#include <JY9515CoreOOAITask.h>

Public Member Functions

JY9515CoreOOAITask (int slotNum)
Constructor.
JY9515CoreOOAITask (std::string boardName)
Constructor.
void | AddChannel (int chID, double rangeLow, double rangeHigh, Coupling coupling, bool enableIEPESS)
Add one/all channel(s).
void | AddChannel (int chID, AIRange range, Coupling coupling, bool enableIEPE)
Add one/all channel(s).
void | AddChannel (std::vector< int > chnsId, double rangeLow, double rangeHigh, Coupling coupling, bool enableIEPE)
Add a set of channels and set parameters uniformly.
void | AddChannel (std::vector< int > chnsId, std::vector< double > rangeLow, std::vector< double > rangeHigh, std::vector< Coupling >_coupling, std::vector< bool > enableIEPE)
Add a group of channels, each channel range can be set differently.
void | AddChannel (std::vector< int > chnsId, AIRange range, Coupling coupling, bool enableIEPE)
Add a set of channels and set the parameters individually.
void | AddChannel (std::vector< int > chnsId, std::vector< AIRange > range, std::vector< Coupling >_coupling, std::vector< bool > enableIEPE)
Add a set of channels and set parameters uniformly.
void | RemoveChannel (int chnId)
Delete the channel with the specified channel number.
void | RemoveChannel (std::vector< int > chnsId)
Delete a set of channels with the specified channel ID.
void | ReadData (double *pBuf, int samplesPerChannel, int timeout=-1)
Read one or multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.
void | ReadRawData (int *pBuf, int samplesPerChannel, int timeout=-1)
Read one or multi-channel raw data by columns and store it in a data buffer.
void | ReadSinglePoint (double &readValue, int channel)
Read one sample for specified channel in register.
void | ReadSinglePoint (std::vector< double > &readValues)
Read raw one sample for all channels in register .
ConversionStatus * GetConversionStatus ()
Get ADC conversion status on all enabled channels.
void | Start ()
Start Task.
void | SendSoftwareTrigger ()
Generate a software trigger signal generate a software trigger signal.
void | Stop ()
Stop Task.
~JY9515CoreOOAITask ()

Public Attributes

std::list< AIChannel * > | Channels
List of AI channels,(9515 support 8 channel)
JY9515CoreOOProperty< JY9515CoreOOAITask, double, JY9515CoreOOPropertyType::READ_WRITE > | SampleRate
Sample rate per channel.
unsigned int | SamplesToAcquire
Number of samples to be read per channel.
JY9515CoreOOProperty< JY9515CoreOOAITask, int, JY9515CoreOOPropertyType::READ_ONLY > | BufLenInSamples
Number of samples per channel can be storage in the buffer, the Property SamplesToAcquire must be less than or equal to this value.
JY9515CoreOOProperty< JY9515CoreOOAITask, uint64_t, JY9515CoreOOPropertyType::READ_ONLY > | AvailableSamples
Number of samples per channel that can be read in the buffer .
JY9515CoreOOProperty< JY9515CoreOOAITask, uint64_t, JY9515CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
JY9515CoreOOProperty< JY9515CoreOOAITask, SampleInfo, JY9515CoreOOPropertyType::READ_ONLY > Sample_Info
Sampling information.
JY9515CoreOOProperty< JY9515CoreOOAITask, bool, JY9515CoreOOPropertyType::READ_WRITE > | DisableCalibration
AIMode Mode
AI acquisition mode, support Finite/Continuous/Record *.
AITrigger * Trigger
AI Trigger Configuration.
AISignalExport * SignalExport
Export AI Signal Configuration.
bool | DisableDigitalTriggerDelay
Disalble calibration Enable.
AISync * Sync
Multi card synchronous configuration.
JY9515CoreOODevice * Device
Device.
AIDigitalFiltering * DigitalFiltering
Digital filtering configuration.
JY9515DAC * DAC

Detailed Description

aiTask类

Constructor & Destructor Documentation

◆ JY9515CoreOOAITask() [1/2]

JY9515CoreOO::JY9515CoreOOAITask::JY9515CoreOOAITask ( int slotNum )

Constructor.

Used to create an AI task by a slot number

Parameters
slotNum Card slot number.

◆ JY9515CoreOOAITask() [2/2]

JY9515CoreOO::JY9515CoreOOAITask::JY9515CoreOOAITask ( std::string boardName )

Constructor.

Used to create an AI task by a slot number

Parameters
slotNum Card slot number.

◆ ~JY9515CoreOOAITask()

JY9515CoreOO::JY9515CoreOOAITask::~JY9515CoreOOAITask ( )

Member Function Documentation

◆ AddChannel() [1/6]

void JY9515CoreOO::JY9515CoreOOAITask::AddChannel | ( | int | chID,
 |  | AIRange | range,
 |  | Coupling | coupling,
 |  | bool | enableIEPE )

Add one/all channel(s).

Parameters
chID | Channel ID
range | Input Range.
coupling | Coupling Type.
enableIEPE | IEPE Enabled.

◆ AddChannel() [2/6]

void JY9515CoreOO::JY9515CoreOOAITask::AddChannel | ( | int | chID,
 |  | double | rangeLow,
 |  | double | rangeHigh,
 |  | Coupling | coupling,
 |  | bool | enableIEPESS )

Add one/all channel(s).

Parameters
chID | Channel ID
rangeLow | Input Low Range. -10V/-5V/-2.5V/-1.25V/-0.625V/-0.3125V Optional.
rangeHigh | Input High Range. 10V/5V/2.5V/1.25V/0.625V/0.3125V Optional.
coupling | Coupling Type.
enableIEPE | IEPE Enabled.

◆ AddChannel() [3/6]

void JY9515CoreOO::JY9515CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | AIRange | range,
 |  | Coupling | coupling,
 |  | bool | enableIEPE )

Add a set of channels and set the parameters individually.

Parameters
chIDs | Channel ID
rangeLow | Input Low Range. -10V/-5V/-2.5V/-1.25V/-0.625V/-0.3125V Optional.
rangeHigh | Input High Range. 10V/5V/2.5V/1.25V/0.625V/0.3125V Optional.
coupling | Coupling Type.
enableIEPE | IEPE Enabled.

◆ AddChannel() [4/6]

void JY9515CoreOO::JY9515CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | double | rangeLow,
 |  | double | rangeHigh,
 |  | Coupling | coupling,
 |  | bool | enableIEPE )

Add a set of channels and set parameters uniformly.

Parameters
chIDs | Channel ID
rangeLow | Input Low Range. -10V/-5V/-2.5V/-1.25V/-0.625V/-0.3125V Optional.
rangeHigh | Input High Range. 10V/5V/2.5V/1.25V/0.625V/0.3125V Optional.
coupling | Coupling Type.
enableIEPE | IEPE Enabled.

◆ AddChannel() [5/6]

void JY9515CoreOO::JY9515CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | std::vector< AIRange > | range,
 |  | std::vector< Coupling > | _coupling,
 |  | std::vector< bool > | enableIEPE )

Add a set of channels and set parameters uniformly.

Parameters
chIDs | Channel ID
range | Input Range.
coupling | Coupling Type.
enableIEPE | IEPE Enabled.

◆ AddChannel() [6/6]

void JY9515CoreOO::JY9515CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | std::vector< double > | rangeLow,
 |  | std::vector< double > | rangeHigh,
 |  | std::vector< Coupling > | _coupling,
 |  | std::vector< bool > | enableIEPE )

Add a group of channels, each channel range can be set differently.

Parameters
chnsId | a group of channel physical numbers,if 5322 5324 channel is 0 - 15. if 5321 5323 channel is 0 -31
rangeLow | lower range limit for the channel，5323/5324:-10V,-5V,-1V, -0.5V,5323/5324:-10,-5,-2,-1,-0.5,-0.25,default -10
rangeHigh | higher range limit for the channel,5323/5324:10V,5V,1V, 0.5V,5323/5324:10,5,2,1,0.5,0.25,default 10
bandWidth | AI Bandwidth ,default 25KHz

◆ GetConversionStatus()

ConversionStatus * JY9515CoreOO::JY9515CoreOOAITask::GetConversionStatus ( )

Get ADC conversion status on all enabled channels.

Returns
ADC conversion status.

◆ ReadData()

void JY9515CoreOO::JY9515CoreOOAITask::ReadData | ( | double * | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = -1 )

Read one or multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.

param name="pBuf">Data buffer

Parameters
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish

◆ ReadRawData()

void JY9515CoreOO::JY9515CoreOOAITask::ReadRawData | ( | int * | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = -1 )

Read one or multi-channel raw data by columns and store it in a data buffer.

The buffer is pointed by C/C++ data type int.

Parameters
pBuf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ ReadSinglePoint() [1/2]

void JY9515CoreOO::JY9515CoreOOAITask::ReadSinglePoint | ( | double & | readValue,
 |  | int | channel )

Read one sample for specified channel in register.

Available when Mode is AIMode.Single

Parameters
readValue | value read
channel | Specified channel numbers.

◆ ReadSinglePoint() [2/2]

void JY9515CoreOO::JY9515CoreOOAITask::ReadSinglePoint ( std::vector< double > & readValues )

Read raw one sample for all channels in register .

Available when Mode is AIMode.Single

Parameters
readValues Values read. Array length >= Channels.Count.

◆ RemoveChannel() [1/2]

void JY9515CoreOO::JY9515CoreOOAITask::RemoveChannel ( int chnId )

Delete the channel with the specified channel number.

chnId=- 1, all channels will be deleted

Parameters
chnId Channel number of the channel to be deleted

◆ RemoveChannel() [2/2]

void JY9515CoreOO::JY9515CoreOOAITask::RemoveChannel ( std::vector< int > chnsId )

Delete a set of channels with the specified channel ID.

Parameters
chIDs Specified channels' ID.

◆ SendSoftwareTrigger()

void JY9515CoreOO::JY9515CoreOOAITask::SendSoftwareTrigger ( )

Generate a software trigger signal generate a software trigger signal.

Returns

◆ Start()

void JY9515CoreOO::JY9515CoreOOAITask::Start ( )

Start Task.

Parameters

return void

Exceptions
JYDriverException When startup fails

◆ Stop()

void JY9515CoreOO::JY9515CoreOOAITask::Stop ( )

Stop Task.

Parameters

return void

Exceptions
JYDriverException When stop fails

Member Data Documentation

◆ AvailableSamples

JY9515CoreOOProperty<JY9515CoreOOAITask, uint64_t, JY9515CoreOOPropertyType::READ_ONLY> JY9515CoreOO::JY9515CoreOOAITask::AvailableSamples

Number of samples per channel that can be read in the buffer .

Valid when Mode is NOT AIMode.Single.

◆ BufLenInSamples

JY9515CoreOOProperty<JY9515CoreOOAITask, int, JY9515CoreOOPropertyType::READ_ONLY> JY9515CoreOO::JY9515CoreOOAITask::BufLenInSamples

Number of samples per channel can be storage in the buffer, the Property SamplesToAcquire must be less than or equal to this value.

◆ Channels

std::list<AIChannel*> JY9515CoreOO::JY9515CoreOOAITask::Channels

List of AI channels,(9515 support 8 channel)

◆ DAC

JY9515DAC* JY9515CoreOO::JY9515CoreOOAITask::DAC

◆ Device

JY9515CoreOODevice* JY9515CoreOO::JY9515CoreOOAITask::Device

Device.

◆ DigitalFiltering

AIDigitalFiltering* JY9515CoreOO::JY9515CoreOOAITask::DigitalFiltering

Digital filtering configuration.

◆ DisableCalibration

JY9515CoreOOProperty<JY9515CoreOOAITask, bool, JY9515CoreOOPropertyType::READ_WRITE> JY9515CoreOO::JY9515CoreOOAITask::DisableCalibration

◆ DisableDigitalTriggerDelay

bool JY9515CoreOO::JY9515CoreOOAITask::DisableDigitalTriggerDelay

Disalble calibration Enable.

◆ Mode

AIMode JY9515CoreOO::JY9515CoreOOAITask::Mode

AI acquisition mode, support Finite/Continuous/Record *.

◆ Sample_Info

JY9515CoreOOProperty<JY9515CoreOOAITask, SampleInfo, JY9515CoreOOPropertyType::READ_ONLY> JY9515CoreOO::JY9515CoreOOAITask::Sample_Info

Sampling information.

Including the modulation frequency and group delay in the current configuration.

◆ SampleRate

JY9515CoreOOProperty<JY9515CoreOOAITask, double, JY9515CoreOOPropertyType::READ_WRITE> JY9515CoreOO::JY9515CoreOOAITask::SampleRate

Sample rate per channel.

Minimum sample rate: 62.5 S/s Maximum sample rate: 256k S/s The defalut sample rate = 256k You can read this property to obtain the sample rate that will actually take effect in the current configuration.

Exceptions
JYDriverException

◆ SamplesToAcquire

unsigned int JY9515CoreOO::JY9515CoreOOAITask::SamplesToAcquire

Number of samples to be read per channel.

Only valid when Mode is Finite*

◆ SignalExport

AISignalExport* JY9515CoreOO::JY9515CoreOOAITask::SignalExport

Export AI Signal Configuration.

◆ Sync

AISync* JY9515CoreOO::JY9515CoreOOAITask::Sync

Multi card synchronous configuration.

◆ TransferedSamples

JY9515CoreOOProperty<JY9515CoreOOAITask, uint64_t, JY9515CoreOOPropertyType::READ_ONLY> JY9515CoreOO::JY9515CoreOOAITask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT AIMode.Single.

◆ Trigger

AITrigger* JY9515CoreOO::JY9515CoreOOAITask::Trigger

AI Trigger Configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9515/JY9515CoreOOAITask.h


9515 C++ Programming Manual: JY9515CoreOO::AIChannel Class Reference

  • JY9515CoreOO
  • AIChannel
Public Member Functions | Public Attributes | List of all members
JY9515CoreOO::AIChannel Class Reference

AI Channel. More...

#include <JY9515CoreOOAITask.h>

Public Member Functions

AIChannel (int channelId, double rangeLow, double rangeHigh, Coupling _coupling, bool IEPEenabled)
Constructor.
AIChannel (int channelId, AIRange range, Coupling _coupling, bool IEPEenabled)
Constructor.

Public Attributes

int | ChannelID
Channel ID.
Coupling coupling
Coupling.
bool | IEPEEnabled
IEPE enabled.
AIRange Range
Input voltage range(grade)
double | RangeLow
Upper limit of range.
double | RangeHigh
Lower limit of range.
JY9515CoreOOProperty< AIChannel, double, JY9515CoreOOPropertyType::READ_ONLY > | RawDataScaleFactor
This fator is used to convert RawData(binary) to Data(voltage in V).

Detailed Description

AI Channel.

Constructor & Destructor Documentation

◆ AIChannel() [1/2]

JY9515CoreOO::AIChannel::AIChannel | ( | int | channelId,
 |  | double | rangeLow,
 |  | double | rangeHigh,
 |  | Coupling | _coupling,
 |  | bool | IEPEenabled )

Constructor.

Used to create an AIChannel by Characteristic.

Parameters
channelId | Channel ID
rangeLow | Lower limit of range
rangeHigh | Upper limit of range
_coupling | Coupling
IEPEenabled | IEPE enabled

◆ AIChannel() [2/2]

JY9515CoreOO::AIChannel::AIChannel | ( | int | channelId,
 |  | AIRange | range,
 |  | Coupling | _coupling,
 |  | bool | IEPEenabled )

Constructor.

Used to create an AIChannel by Characteristic.

Parameters
channelId | Channel ID
range | Input voltage range(grade)
_coupling | Coupling
IEPEenabled | IEPE enabled

Member Data Documentation

◆ ChannelID

int JY9515CoreOO::AIChannel::ChannelID

Channel ID.

◆ coupling

Coupling JY9515CoreOO::AIChannel::coupling

Coupling.

◆ IEPEEnabled

bool JY9515CoreOO::AIChannel::IEPEEnabled

IEPE enabled.

◆ Range

AIRange JY9515CoreOO::AIChannel::Range

Input voltage range(grade)

◆ RangeHigh

double JY9515CoreOO::AIChannel::RangeHigh

Lower limit of range.

◆ RangeLow

double JY9515CoreOO::AIChannel::RangeLow

Upper limit of range.

◆ RawDataScaleFactor

JY9515CoreOOProperty<AIChannel, double, JY9515CoreOOPropertyType::READ_ONLY> JY9515CoreOO::AIChannel::RawDataScaleFactor

This fator is used to convert RawData(binary) to Data(voltage in V).

RawData * factor = Data.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9515/JY9515CoreOOAITask.h


9515 C++ Programming Manual: JY9515CoreOO::AITrigger Class Reference

  • AITrigger
Public Attributes | List of all members
JY9515CoreOO::AITrigger Class Reference

#include <JY9515CoreOOAITask.h>

Public Attributes

AITriggerType Type
AI trigger type.
AITriggerMode Mode
AI trigger mode.
AIDigitalTrigger * Digital
Digital Trigger Congfiguration.
AIAnalogTrigger * Analog
AI Analog Trigger.
int | ReTriggerCount
Number of repeat triggers.
unsigned int | PreTriggerSamples
AI pretrigger samples, must be less than or equal to JY9515aiTask.SamplesToAcquire.

Member Data Documentation

◆ Analog

AIAnalogTrigger* JY9515CoreOO::AITrigger::Analog

AI Analog Trigger.

Valid when Type is AITriggerType.Analog.

◆ Digital

AIDigitalTrigger* JY9515CoreOO::AITrigger::Digital

Digital Trigger Congfiguration.

Valid when Type is AITriggerType.Digital.

◆ Mode

AITriggerMode JY9515CoreOO::AITrigger::Mode

AI trigger mode.

enum Start/Reference. The default value is AITriggerMode.Start.

◆ PreTriggerSamples

unsigned int JY9515CoreOO::AITrigger::PreTriggerSamples

AI pretrigger samples, must be less than or equal to JY9515aiTask.SamplesToAcquire.

Valid when Mode is AITriggerMode.Reference. Pretrigger samples, must be greater than 0. Valid when Type is AITriggerType.Analog. Pretrigger samples, must be greater than 1. Valid when Type is AITriggerType.Digital.

◆ ReTriggerCount

int JY9515CoreOO::AITrigger::ReTriggerCount

Number of repeat triggers.

When 0 or 1 only trigger once, When -1 continuous retrigger until stop.

◆ Type

AITriggerType JY9515CoreOO::AITrigger::Type

AI trigger type.

enum Analog/Digital/Immediate/Soft. The default value is AITriggerType.Immediate.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9515/JY9515CoreOOAITask.h


9515 C++ Programming Manual: JY9515CoreOO::AIDigitalTrigger Class Reference

  • AIDigitalTrigger
Public Attributes | List of all members
JY9515CoreOO::AIDigitalTrigger Class Reference

AI Digital trigger params. More...

#include <JY9515CoreOOAITask.h>

Public Attributes

AIDigitalTriggerSource Source
AI Digital Trigger source.
AIDigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Detailed Description

AI Digital trigger params.

Member Data Documentation

◆ Edge

AIDigitalTriggerEdge JY9515CoreOO::AIDigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

AIDigitalTriggerSource JY9515CoreOO::AIDigitalTrigger::Source

AI Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9515/JY9515CoreOOAITask.h


9515 C++ Programming Manual: JY9515CoreOO::AIAnalogHysteresisComparator Class Reference

  • AIAnalogHysteresisComparator
Public Attributes | List of all members
JY9515CoreOO::AIAnalogHysteresisComparator Class Reference

AI Analog Hysteresis Comparator. More...

#include <JY9515CoreOOAITask.h>

Public Attributes

AIAnalogTriggerEdge Slope
AI Analog Trigger Edge.
double | HighThreshold
High Threshold.
double | LowThreshold
Low Threshold.

Detailed Description

AI Analog Hysteresis Comparator.

Member Data Documentation

◆ HighThreshold

double JY9515CoreOO::AIAnalogHysteresisComparator::HighThreshold

High Threshold.

◆ LowThreshold

double JY9515CoreOO::AIAnalogHysteresisComparator::LowThreshold

Low Threshold.

◆ Slope

AIAnalogTriggerEdge JY9515CoreOO::AIAnalogHysteresisComparator::Slope

AI Analog Trigger Edge.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9515/JY9515CoreOOAITask.h


9515 C++ Programming Manual: JY9515CoreOO::AIAnalogWindowComparator Class Reference

  • AIAnalogWindowComparator
Public Attributes | List of all members
JY9515CoreOO::AIAnalogWindowComparator Class Reference

AI Analog Window Comparator. More...

#include <JY9515CoreOOAITask.h>

Public Attributes

AIAnalogWindowCondition Condition
AI Analog Window Condition.
double | HighThreshold
High Threshold.
double | LowThreshold
Low Threshold.

Detailed Description

AI Analog Window Comparator.

Member Data Documentation

◆ Condition

AIAnalogWindowCondition JY9515CoreOO::AIAnalogWindowComparator::Condition

AI Analog Window Condition.

◆ HighThreshold

double JY9515CoreOO::AIAnalogWindowComparator::HighThreshold

High Threshold.

◆ LowThreshold

double JY9515CoreOO::AIAnalogWindowComparator::LowThreshold

Low Threshold.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9515/JY9515CoreOOAITask.h


9515 C++ Programming Manual: JY9515CoreOO::AIAnalogEdgeComparator Class Reference

  • AIAnalogEdgeComparator
Public Attributes | List of all members
JY9515CoreOO::AIAnalogEdgeComparator Class Reference

AI Analog Edge Comparator. More...

#include <JY9515CoreOOAITask.h>

Public Attributes

AIAnalogTriggerEdge Slope
AI Analog Trigger Edge.
double Threshold
Threshold.

Detailed Description

AI Analog Edge Comparator.

Member Data Documentation

◆ Slope

AIAnalogTriggerEdge JY9515CoreOO::AIAnalogEdgeComparator::Slope

AI Analog Trigger Edge.

◆ Threshold

double JY9515CoreOO::AIAnalogEdgeComparator::Threshold

Threshold.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9515/JY9515CoreOOAITask.h


9515 C++ Programming Manual: JY9515CoreOO::AIAnalogTrigger Class Reference

  • AIAnalogTrigger
Public Member Functions | Public Attributes | List of all members
JY9515CoreOO::AIAnalogTrigger Class Reference

AI Analog Trigger. More...

#include <JY9515CoreOOAITask.h>

Public Member Functions

AIAnalogTrigger ()
AIAnalogTrigger (AIAnalogTriggerSource src, AIAnalogTriggerComparator comparator)
~AIAnalogTrigger ()
void Commit (void *deviceHandle)

Public Attributes

AIAnalogTriggerSource Source
Analog Trigger source.
AIAnalogTriggerComparator Comparator
AI Analog Trigger Comparator.
AIAnalogEdgeComparator * Edge
AI Analog Edge Comparator.
AIAnalogHysteresisComparator * Hysteresis
AI Analog Hysteresis Comparatorr.
AIAnalogWindowComparator * Window
AI Analog Window Comparatorr.

Detailed Description

AI Analog Trigger.

Constructor & Destructor Documentation

◆ AIAnalogTrigger() [1/2]

JY9515CoreOO::AIAnalogTrigger::AIAnalogTrigger ( )

◆ AIAnalogTrigger() [2/2]

JY9515CoreOO::AIAnalogTrigger::AIAnalogTrigger | ( | AIAnalogTriggerSource | src,
 |  | AIAnalogTriggerComparator | comparator )

◆ ~AIAnalogTrigger()

JY9515CoreOO::AIAnalogTrigger::~AIAnalogTrigger ( )

Member Function Documentation

◆ Commit()

void JY9515CoreOO::AIAnalogTrigger::Commit ( void * deviceHandle )

Member Data Documentation

◆ Comparator

AIAnalogTriggerComparator JY9515CoreOO::AIAnalogTrigger::Comparator

AI Analog Trigger Comparator.

◆ Edge

AIAnalogEdgeComparator* JY9515CoreOO::AIAnalogTrigger::Edge

AI Analog Edge Comparator.

◆ Hysteresis

AIAnalogHysteresisComparator* JY9515CoreOO::AIAnalogTrigger::Hysteresis

AI Analog Hysteresis Comparatorr.

◆ Source

AIAnalogTriggerSource JY9515CoreOO::AIAnalogTrigger::Source

Analog Trigger source.

◆ Window

AIAnalogWindowComparator* JY9515CoreOO::AIAnalogTrigger::Window

AI Analog Window Comparatorr.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9515/JY9515CoreOOAITask.h


9515 C++ Programming Manual: JY9515CoreOO::AISignalExport Class Reference

  • AISignalExport
Public Member Functions | List of all members
JY9515CoreOO::AISignalExport Class Reference

AI Signal Export Class. More...

#include <JY9515CoreOOAITask.h>

Public Member Functions

void | Add (AISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (AISignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

AI Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY9515CoreOO::AISignalExport::Add | ( | AISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | AI Signal Source
destination | Export Desination

◆ Add() [2/2]

void JY9515CoreOO::AISignalExport::Add | ( | AISignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | AI Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JY9515CoreOO::AISignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY9515CoreOO::AISignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9515/JY9515CoreOOAITask.h


9515 C++ Programming Manual: JY9515CoreOO::AISync Class Reference

  • AISync
Public Attributes | List of all members
JY9515CoreOO::AISync Class Reference

#include <JY9515CoreOOAITask.h>

Public Attributes

SyncTopology Topology
SyncTerminal Terminal
JY9515CoreOOProperty< AISync, SyncState, JY9515CoreOOPropertyType::READ_ONLY > State
The number of samples that have been transfered from the local buffer (per channel).

Detailed Description

同步配置类

Sync Configuration Class

Member Data Documentation

◆ State

JY9515CoreOOProperty<AISync, SyncState, JY9515CoreOOPropertyType::READ_ONLY> JY9515CoreOO::AISync::State

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT AIMode.Single.

◆ Terminal

SyncTerminal JY9515CoreOO::AISync::Terminal

◆ Topology

SyncTopology JY9515CoreOO::AISync::Topology
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9515/JY9515CoreOOAITask.h


9515 C++ Programming Manual: JY9515CoreOO::LowPassFilter Class Reference

  • LowPassFilter
Public Member Functions | Public Attributes | List of all members
JY9515CoreOO::LowPassFilter Class Reference

#include <JY9515CoreOOAITask.h>

Public Member Functions

LowPassFilter ()

Public Attributes

JY9515CoreOOProperty< LowPassFilter, LPFMode, JY9515CoreOOPropertyType::READ_WRITE > Mode

Constructor & Destructor Documentation

◆ LowPassFilter()

JY9515CoreOO::LowPassFilter::LowPassFilter ( )

Member Data Documentation

◆ Mode

JY9515CoreOOProperty<LowPassFilter, LPFMode, JY9515CoreOOPropertyType::READ_WRITE> JY9515CoreOO::LowPassFilter::Mode
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9515/JY9515CoreOOAITask.h


9515 C++ Programming Manual: JY9515CoreOO::HighPassFilter Class Reference

  • HighPassFilter
Public Member Functions | Public Attributes | List of all members
JY9515CoreOO::HighPassFilter Class Reference

High-Pass Filter Configuration Class. More...

#include <JY9515CoreOOAITask.h>

Public Member Functions

HighPassFilter ()
void | EnableChannel (int chID)
void | DisableChannel (int chID)

Public Attributes

JY9515CoreOOProperty< HighPassFilter, double, JY9515CoreOOPropertyType::READ_WRITE > | CutoffFrequency
Cutoff Frequency in Hz.
JY9515CoreOOProperty< HighPassFilter, HPFOrder, JY9515CoreOOPropertyType::READ_WRITE > Order
JY9515CoreOOProperty< HighPassFilter, uint32_t, JY9515CoreOOPropertyType::READ_ONLY > | ChannelEnableMask

Detailed Description

High-Pass Filter Configuration Class.

Constructor & Destructor Documentation

◆ HighPassFilter()

JY9515CoreOO::HighPassFilter::HighPassFilter ( )

Member Function Documentation

◆ DisableChannel()

void JY9515CoreOO::HighPassFilter::DisableChannel ( int chID )

◆ EnableChannel()

void JY9515CoreOO::HighPassFilter::EnableChannel ( int chID )

Member Data Documentation

◆ ChannelEnableMask

JY9515CoreOOProperty<HighPassFilter, uint32_t, JY9515CoreOOPropertyType::READ_ONLY> JY9515CoreOO::HighPassFilter::ChannelEnableMask

◆ CutoffFrequency

JY9515CoreOOProperty<HighPassFilter, double, JY9515CoreOOPropertyType::READ_WRITE> JY9515CoreOO::HighPassFilter::CutoffFrequency

Cutoff Frequency in Hz.

The max value is SampleRate * 1%. The attenuation at this frequency is -3dB when the filter is one-order, and -6dB when the filter is two-order.

◆ Order

JY9515CoreOOProperty<HighPassFilter, HPFOrder, JY9515CoreOOPropertyType::READ_WRITE> JY9515CoreOO::HighPassFilter::Order
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9515/JY9515CoreOOAITask.h


9515 C++ Programming Manual: JY9515CoreOO::FlatnessCompensation Class Reference

  • FlatnessCompensation
Public Member Functions | Public Attributes | List of all members
JY9515CoreOO::FlatnessCompensation Class Reference

Flatness Compensation Parameters. More...

#include <JY9515CoreOOAITask.h>

Public Member Functions

FlatnessCompensation ()

Public Attributes

JY9515CoreOOProperty< FlatnessCompensation, bool, JY9515CoreOOPropertyType::READ_WRITE > Enabled

Detailed Description

Flatness Compensation Parameters.

Constructor & Destructor Documentation

◆ FlatnessCompensation()

JY9515CoreOO::FlatnessCompensation::FlatnessCompensation ( )

Member Data Documentation

◆ Enabled

JY9515CoreOOProperty<FlatnessCompensation, bool, JY9515CoreOOPropertyType::READ_WRITE> JY9515CoreOO::FlatnessCompensation::Enabled
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9515/JY9515CoreOOAITask.h


9515 C++ Programming Manual: JY9515CoreOO::AIDigitalFiltering Class Reference

  • AIDigitalFiltering
Public Member Functions | Public Attributes | List of all members
JY9515CoreOO::AIDigitalFiltering Class Reference

AI Digital Filtering Connfiguration Class. More...

#include <JY9515CoreOOAITask.h>

Public Member Functions

AIDigitalFiltering ()
~AIDigitalFiltering ()

Public Attributes

JY9515CoreOOProperty< AIDigitalFiltering, LowPassFilter, JY9515CoreOOPropertyType::READ_ONLY > LPF
JY9515CoreOOProperty< AIDigitalFiltering, HighPassFilter, JY9515CoreOOPropertyType::READ_ONLY > HPF
JY9515CoreOOProperty< AIDigitalFiltering, FlatnessCompensation, JY9515CoreOOPropertyType::READ_ONLY > Flatnesscompensation
ChoppingFrequency ModulatorChoppingFrequency

Detailed Description

AI Digital Filtering Connfiguration Class.

Constructor & Destructor Documentation

◆ AIDigitalFiltering()

JY9515CoreOO::AIDigitalFiltering::AIDigitalFiltering ( )

◆ ~AIDigitalFiltering()

JY9515CoreOO::AIDigitalFiltering::~AIDigitalFiltering ( )

Member Data Documentation

◆ Flatnesscompensation

JY9515CoreOOProperty<AIDigitalFiltering, FlatnessCompensation, JY9515CoreOOPropertyType::READ_ONLY> JY9515CoreOO::AIDigitalFiltering::Flatnesscompensation

◆ HPF

JY9515CoreOOProperty<AIDigitalFiltering, HighPassFilter, JY9515CoreOOPropertyType::READ_ONLY> JY9515CoreOO::AIDigitalFiltering::HPF

◆ LPF

JY9515CoreOOProperty<AIDigitalFiltering, LowPassFilter, JY9515CoreOOPropertyType::READ_ONLY> JY9515CoreOO::AIDigitalFiltering::LPF

◆ ModulatorChoppingFrequency

ChoppingFrequency JY9515CoreOO::AIDigitalFiltering::ModulatorChoppingFrequency
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9515/JY9515CoreOOAITask.h


9515 C++ Programming Manual: JY9515CoreOO::JY9515DAC Class Reference

  • JY9515DAC
Public Member Functions | Public Attributes | List of all members
JY9515CoreOO::JY9515DAC Class Reference

JY9515 DAC Configuration. More...

#include <JY9515CoreOOAITask.h>

Public Member Functions

JY9515DAC (void *deviceHandle)
~JY9515DAC ()
void IssueTemperatureRecalibration (int timeout=5000)
Issue temperature drift recalibration and correct the influence of temperature changes on the output voltage.

Public Attributes

JY9515CoreOOProperty< JY9515DAC, int, JY9515CoreOOPropertyType::READ_WRITE > | OutputChannel
DAC Voltage Output Channel.
JY9515CoreOOProperty< JY9515DAC, bool, JY9515CoreOOPropertyType::READ_WRITE > | Enabled
Onboard DAC Enabled.
JY9515CoreOOProperty< JY9515DAC, double, JY9515CoreOOPropertyType::READ_WRITE > | OutputVoltage
DAC Output Voltage in V, default is 0.

Detailed Description

JY9515 DAC Configuration.

Constructor & Destructor Documentation

◆ JY9515DAC()

JY9515CoreOO::JY9515DAC::JY9515DAC ( void * deviceHandle )

◆ ~JY9515DAC()

JY9515CoreOO::JY9515DAC::~JY9515DAC ( )

Member Function Documentation

◆ IssueTemperatureRecalibration()

void JY9515CoreOO::JY9515DAC::IssueTemperatureRecalibration ( int timeout = 5000 )

Issue temperature drift recalibration and correct the influence of temperature changes on the output voltage.

Please call this method before each calibration.

Parameters
timeout Process timeout in ms.

Member Data Documentation

◆ Enabled

JY9515CoreOOProperty<JY9515DAC, bool, JY9515CoreOOPropertyType::READ_WRITE> JY9515CoreOO::JY9515DAC::Enabled

Onboard DAC Enabled.

Take effect immediately.

◆ OutputChannel

JY9515CoreOOProperty<JY9515DAC, int, JY9515CoreOOPropertyType::READ_WRITE> JY9515CoreOO::JY9515DAC::OutputChannel

DAC Voltage Output Channel.

0-15

◆ OutputVoltage

JY9515CoreOOProperty<JY9515DAC, double, JY9515CoreOOPropertyType::READ_WRITE> JY9515CoreOO::JY9515DAC::OutputVoltage

DAC Output Voltage in V, default is 0.

This attribute is used for self-calibration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9515/JY9515CoreOOAITask.h


9515 C++ Programming Manual: JY9515CoreOO::ConversionStatus Class Reference

  • ConversionStatus
Public Member Functions | Public Attributes | List of all members
JY9515CoreOO::ConversionStatus Class Reference

Get ADC conversion status on all enabled channels. More...

#include <JY9515CoreOOAITask.h>

Public Member Functions

ConversionStatus (int header)
void Update (int header)

Public Attributes

JY9515CoreOOProperty< ConversionStatus, bool, JY9515CoreOOPropertyType::READ_ONLY > | ErrorFlagged
JY9515CoreOOProperty< ConversionStatus, bool, JY9515CoreOOPropertyType::READ_ONLY > | CRCError
JY9515CoreOOProperty< ConversionStatus, bool, JY9515CoreOOPropertyType::READ_ONLY > | FilterSuturated
JY9515CoreOOProperty< ConversionStatus, bool, JY9515CoreOOPropertyType::READ_ONLY > | ChannelID

Detailed Description

Get ADC conversion status on all enabled channels.

Returns
ADC conversion status.

Constructor & Destructor Documentation

◆ ConversionStatus()

JY9515CoreOO::ConversionStatus::ConversionStatus ( int header )

Member Function Documentation

◆ Update()

void JY9515CoreOO::ConversionStatus::Update ( int header )
inline

Member Data Documentation

◆ ChannelID

JY9515CoreOOProperty<ConversionStatus, bool, JY9515CoreOOPropertyType::READ_ONLY> JY9515CoreOO::ConversionStatus::ChannelID

◆ CRCError

JY9515CoreOOProperty<ConversionStatus, bool, JY9515CoreOOPropertyType::READ_ONLY> JY9515CoreOO::ConversionStatus::CRCError

◆ ErrorFlagged

JY9515CoreOOProperty<ConversionStatus, bool, JY9515CoreOOPropertyType::READ_ONLY> JY9515CoreOO::ConversionStatus::ErrorFlagged

◆ FilterSuturated

JY9515CoreOOProperty<ConversionStatus, bool, JY9515CoreOOPropertyType::READ_ONLY> JY9515CoreOO::ConversionStatus::FilterSuturated
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9515/JY9515CoreOOAITask.h


9515 C++ Programming Manual: JY9515CoreOO Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Enumerations | Functions | Variables
JY9515CoreOO Namespace Reference

Classes

class | AIAnalogEdgeComparator
AI Analog Edge Comparator. More...
class | AIAnalogHysteresisComparator
AI Analog Hysteresis Comparator. More...
class | AIAnalogTrigger
AI Analog Trigger. More...
class | AIAnalogWindowComparator
AI Analog Window Comparator. More...
class | AIChannel
AI Channel. More...
class | AIDigitalFiltering
AI Digital Filtering Connfiguration Class. More...
class | AIDigitalTrigger
AI Digital trigger params. More...
class | AISignalExport
AI Signal Export Class. More...
class | AISync
class | AITrigger
class | ConversionStatus
Get ADC conversion status on all enabled channels. More...
class | DeviceStatus
Device Status. More...
class | ExternalReferenceClock
External Reference Clcok Terminal. More...
struct | FirmDriveInfo
class | FlatnessCompensation
Flatness Compensation Parameters. More...
class | HighPassFilter
High-Pass Filter Configuration Class. More...
class | JY9515CoreOOAITask
aiTask类 More...
class | JY9515CoreOODevice
JY9515CoreOO Device. More...
class | JY9515CoreOOLog
class | JY9515CoreOOProperty
属性模板类 More...
class | JY9515CoreOOReferenceClock
class | JY9515DAC
JY9515 DAC Configuration. More...
class | JY9515DeviceInfo
Device Info. More...
class | JYDriverException
class | LowPassFilter
class | PauseTrigger
Pause trigger configuration class. More...
class | SampleInfo
Sampling information. More...

Enumerations

enum class | AIMode { Finite , Continuous , Single }
enum class | IEPEConnectionStatus { Normal = 0 , OpenCircuit = 1 , ShortCircuit = 2 }
IEPE Connection Status. More...
enum class AIRange {
_10V = JY9515Import::JY9515_Range_10V , _5V = JY9515Import::JY9515_Range_5V , _2p5V = JY9515Import::JY9515_Range_2p5V , _1p25V = JY9515Import::JY9515_Range_1p25V ,
_0p625V = JY9515Import::JY9515_Range_0p625V , _0p3125V = JY9515Import::JY9515_Range_0p3125V
}
enum class | Coupling { AC = JY9515Import::JY9515_Coupling_AC , DC = JY9515Import::JY9515_Coupling_DC }
Coupling. More...
enum class | AITriggerType { Immediately = JY9515Import::JY9515_TriggerType_Immediately , Digital = JY9515Import::JY9515_TriggerType_Digital , Software = JY9515Import::JY9515_TriggerType_Software , Analog = JY9515Import::JY9515_TriggerType_Analog }
AI trigger type enum type. More...
enum class | AITriggerMode { Start , Reference }
AI trigger mode enum type. More...
enum class AIAnalogTriggerSource {
Channel_0 , Channel_1 , Channel_2 , Channel_3 ,
Channel_4 , Channel_5 , Channel_6 , Channel_7
}
Analog Trigger source. More...
enum class AIDigitalTriggerSource {
Ext_Trig = JY9515Import::JY9515_DigitalTriggerSource_External , PXI_Trig0 = JY9515Import::JY9515_DigitalTriggerSource_BUS_0 , PXI_Trig1 = JY9515Import::JY9515_DigitalTriggerSource_BUS_1 , PXI_Trig2 = JY9515Import::JY9515_DigitalTriggerSource_BUS_2 ,
PXI_Trig3 = JY9515Import::JY9515_DigitalTriggerSource_BUS_3 , PXI_Trig4 = JY9515Import::JY9515_DigitalTriggerSource_BUS_4 , PXI_Trig5 = JY9515Import::JY9515_DigitalTriggerSource_BUS_5 , PXI_Trig6 = JY9515Import::JY9515_DigitalTriggerSource_BUS_6 ,
PXI_Trig7 = JY9515Import::JY9515_DigitalTriggerSource_BUS_7 , PXI_Star = JY9515Import::JY9515_DigitalTriggerSource_STAR
}
AI digital trigger source enum type. More...
enum class | AIDigitalTriggerEdge { Rising = 0x0 , Falling = 0x1 }
AI Digital Trigger Edge enum type. More...
enum class | AIAnalogTriggerEdge { Rising , Falling }
AI Analog Trigger Edge. More...
enum class | AIAnalogWindowCondition { Entering , Leaving }
AI Analog Window Trigger Condition. More...
enum class | AIAnalogTriggerComparator { Edge , Hysteresis , Window }
AI Analog Trigger Comparator. More...
enum class AISignalExportSource {
SampleClock = JY9515Import::JY9515_EXPORT_SAMPLE_CLOCK , Sync = JY9515Import::JY9515_EXPORT_SYNC , ReadyForStartTrigger = JY9515Import::JY9515_EXPORT_RX_READY_FOR_REF_TRIG , StartTrigger = JY9515Import::JY9515_EXPORT_RX_REF_TRIG ,
EndOfRecord = JY9515Import::JY9515_EXPORT_RX_END_OF_RECORD , EndOfAcquisition = JY9515Import::JY9515_EXPORT_RX_ENGINE_END
}
AI Signal Export Source Enum. More...
enum class | SyncTopology { Independent , Master , Slave }
Synchronization board configuration. More...
enum SyncTerminal {
Ext_Trig , PXI_Trig0 , PXI_Trig1 , PXI_Trig2 ,
PXI_Trig3 , PXI_Trig4 , PXI_Trig5 , PXI_Trig6 ,
PXI_Trig7 , PXI_Star
}
AI digital trigger source enum type. More...
enum | SyncState { WaitingSync , Synchronized , Invalid }
Sync State. More...
enum | HPFOrder { OneOrder = 1 , TwoOrder = 2 }
High-pass filter order. More...
enum | ChoppingFrequency { fMod32 , fMod8 }
Modulator Chopping Frequency Enum. More...
enum class SamplingState {
Idle = 1 << 0 , WaitingForStart = 1 << 1 , PreSampling = 1 << 2 , WaitingForRefTrigger = 1 << 3 ,
PostSampling = 1 << 4 , RecordCompleted = 1 << 5 , WaitingForAdvanceTrigger = 1 << 6 , Done = 1 << 7
}
Sampling State Enum. More...
enum class | JY9515CoreOOPropertyType { READ_ONLY = 1 , WRITE_ONLY = 2 , READ_WRITE = 3 }
enum class JYDriverExceptionPublic {
UnKnown = 0 , OpenDeviceFailed = -10001 , CloseDeviceFailed = -10002 , ResetDeviceFailed = -10003 ,
GetDevicePropertyFailed = -10004 , SetDevicePropertyFailed = -10005 , HardwareResourceIsReserved = -10006 , MethodNotPermitedToCallWhenCurrentStatus = -10007 ,
InvalidUserDataBuffer = -10008 , NoChannelAdded = -10009 , NotSupportOperationForCurrentDevice = -10010 , CreatTaskFailed = -10100 ,
StartTaskFailed = -10101 , StopTaskFailed = -10102 , TaskHasNotStarted = -10103 , TaskHasStartedCannotPerformTheSetOperation = -10104 ,
ChannelNumberParameterInvalid = -10105 , ChannelInputRangeParameterInvalid = -10106 , ChannelTerminalParameterInvalid = -10107 , ChannelCouplingParameterInvalid = -10108 ,
SampeleModeParameterInvalid = -10109 , SampleClockParameterInvalid = -10110 , SampleRateParameterInvalid = -10111 , UpdateRateParameterInvalid = -10112 ,
TriggerParameterInvalid = -10113 , ReferenceTriggerDoesNotMatchWithSampleMode = -10114 , PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint = -10115 , ReadDataFailed = -10016 ,
ReadDataTimeout = -10017 , WriteDataFailed = -10018 , WriteDataTimeout = -10019 , WriteDataLengthCannotBeLessThanN = -10020 ,
BufferDataOverflow = -10021 , BufferDataDownflow = -10022 , CheckBufferFailed = -10023 , PointInvalidInFiniteMode = -10024 ,
ReadPointInvalid = -10025 , OnlySupportRecordMode = -10026 , SendSoftTirggerFailed = -10027 , TaskTimeout = -10028 ,
CounterParametersInvalid = -10029 , WritePointInvalid = -10030 , SignalExportDestinationInvalid = -10031 , InvalidParameter = -10033
}
驱动常用错误代码枚举定义 More...
enum class SignalExportDestination {
Ext_Trig = JY9515Import::JY9515_DigitalTriggerSource_External , PXI_Trig0 = JY9515Import::JY9515_DigitalTriggerSource_BUS_0 , PXI_Trig1 = JY9515Import::JY9515_DigitalTriggerSource_BUS_1 , PXI_Trig2 = JY9515Import::JY9515_DigitalTriggerSource_BUS_2 ,
PXI_Trig3 = JY9515Import::JY9515_DigitalTriggerSource_BUS_3 , PXI_Trig4 = JY9515Import::JY9515_DigitalTriggerSource_BUS_4 , PXI_Trig5 = JY9515Import::JY9515_DigitalTriggerSource_BUS_5 , PXI_Trig6 = JY9515Import::JY9515_DigitalTriggerSource_BUS_6 ,
PXI_Trig7 = JY9515Import::JY9515_DigitalTriggerSource_BUS_7 , PXI_Star = JY9515Import::JY9515_DigitalTriggerSource_STAR
}
enum class | OutputCompleteState { Zero , Hold }
Output Complete State. More...
enum class | LevelPolarity { LowLevel = 0 , HighLevel = 1 , None = 2 }
Level Polarity. More...
enum | LPFMode { Normal = 0 , WideBandwidth = 1 }
Low-Pass Filter Mode Enum. More...
enum | ADCFilterType { WidebandLowRippleFilter = JY9515Import::WidebandLowRippleFilter , Sinc5Filter = JY9515Import::Sinc5Filter }
ADC Filter Type Enum. More...
enum class | ExternalReferenceClockTerminal { PXIe_Clk100 = JY9515Import::JY9515_PXIe_Clk_100M }
enum class | ReferenceClockSource { Internal = 0x0 , External = 0x1 }
enum class JY9515CoreOOLogLevel {
DEBUG_LOG_LEVEL , INFO_LOG_LEVEL , WARN_LOG_LEVEL , ERROR_LOG_LEVEL ,
FATAL_LOG_LEVEL
}

Functions

std::string GetSignalExportDestinationString (SignalExportDestination destination)

Variables

const std::map< int, std::string > | AIRangeDescriptions
const double | AIRagneGrade [6] = { 0.3125, 0.6250, 1.25, 2.50, 5.0, 10.0 }

Enumeration Type Documentation

◆ ADCFilterType

enum JY9515CoreOO::ADCFilterType

ADC Filter Type Enum.

Enumerator
WidebandLowRippleFilter | Wideband low ripple filter, −3dB at 0.433 * SampleRate, with 34/SampleRate group delay. This filter has a flat pass band (±0.005 dB ripple) from dc to 102.4 kHz at 256 kSPS, from dc to 51.2 kHz at 128 kSPS, or from dc to 12.8 kHz at 32 kSPS
Sinc5Filter | Sinc5 low latency filter, −3dB at 0.204 * SampleRate, with 3/SampleRate group delay. This filter has a low latency path for low bandwidth, and low noise measurements.

◆ AIAnalogTriggerComparator

enum class JY9515CoreOO::AIAnalogTriggerComparator
strong

AI Analog Trigger Comparator.

Enumerator
Edge | Edge Comparator.
Hysteresis | Hysteresis Comparator.
Window | Window Comparator.

◆ AIAnalogTriggerEdge

enum class JY9515CoreOO::AIAnalogTriggerEdge
strong

AI Analog Trigger Edge.

Enumerator
Rising | Rising.
Falling | Falling.

◆ AIAnalogTriggerSource

enum class JY9515CoreOO::AIAnalogTriggerSource
strong

Analog Trigger source.

Enumerator
Channel_0 | channel 0
Channel_1 | channel 1
Channel_2 | channel 2
Channel_3 | channel 3
Channel_4 | channel 4
Channel_5 | channel 5
Channel_6 | channel 6
Channel_7 | channel 7

◆ AIAnalogWindowCondition

enum class JY9515CoreOO::AIAnalogWindowCondition
strong

AI Analog Window Trigger Condition.

Enumerator
Entering | Rising.
Leaving | Falling.

◆ AIDigitalTriggerEdge

enum class JY9515CoreOO::AIDigitalTriggerEdge
strong

AI Digital Trigger Edge enum type.

Enumerator
Rising | Rising.
Falling | Falling.

◆ AIDigitalTriggerSource

enum class JY9515CoreOO::AIDigitalTriggerSource
strong

AI digital trigger source enum type.

Enumerator
Ext_Trig | External Trigger.
PXI_Trig0 | PXI Trigger 0.
PXI_Trig1 | PXI Trigger 1.
PXI_Trig2 | PXI Trigger 2.
PXI_Trig3 | PXI Trigger 3.
PXI_Trig4 | PXI Trigger 4.
PXI_Trig5 | PXI Trigger 5.
PXI_Trig6 | PXI Trigger 6.
PXI_Trig7 | PXI Trigger 7.
PXI_Star | PXI Star.

◆ AIMode

enum class JY9515CoreOO::AIMode
strong
Enumerator
Finite | Finite mode.
Continuous | Continuous mode.
Single | Single point mode.

◆ AIRange

enum class JY9515CoreOO::AIRange
strong
Enumerator
_10V | ±10V
_5V | ±5V
_2p5V | ±2.5V
_1p25V | ±1.25V
_0p625V | ±0.625V
_0p3125V | ±0.3125V

◆ AISignalExportSource

enum class JY9515CoreOO::AISignalExportSource
strong

AI Signal Export Source Enum.

Enumerator
SampleClock | AI Sample Clock.
Sync | Sync Signal from Master to Slave(s)
ReadyForStartTrigger | Ready for Trigger.
StartTrigger | Trigger Out.
EndOfRecord | End of Record.
EndOfAcquisition | End of Acquisition.

◆ AITriggerMode

enum class JY9515CoreOO::AITriggerMode
strong

AI trigger mode enum type.

Enumerator
Start | Start Trigger.
Reference | Reference Trigger，Valid when JY9515aiTask.Mode is AIMode.Finite

◆ AITriggerType

enum class JY9515CoreOO::AITriggerType
strong

AI trigger type enum type.

Enumerator
Immediately | Immediately, no trigger.
Digital | Digital trigger.
Software | Software trigger.
Analog | Analog trigger.

◆ ChoppingFrequency

enum JY9515CoreOO::ChoppingFrequency

Modulator Chopping Frequency Enum.

Enumerator
fMod32 | Chop at fMod/32.
fMod8 | Chop at fMod/8. Default.

◆ Coupling

enum class JY9515CoreOO::Coupling
strong

Coupling.

Enumerator
AC | AC.
DC | DC.

◆ ExternalReferenceClockTerminal

enum class JY9515CoreOO::ExternalReferenceClockTerminal
strong

外部参考时钟输入端口

External Reference Clcok Terminal

Enumerator
PXIe_Clk100

PXIe_DStarA

PXIe_DStarA

◆ HPFOrder

enum JY9515CoreOO::HPFOrder

High-pass filter order.

Enumerator
OneOrder | One-order.
TwoOrder | Two-order.

◆ IEPEConnectionStatus

enum class JY9515CoreOO::IEPEConnectionStatus
strong

IEPE Connection Status.

Enumerator
Normal | Normal.
OpenCircuit | Open circuit.
ShortCircuit | Short circuit.

◆ JY9515CoreOOLogLevel

enum class JY9515CoreOO::JY9515CoreOOLogLevel
strong
Enumerator
DEBUG_LOG_LEVEL
INFO_LOG_LEVEL
WARN_LOG_LEVEL
ERROR_LOG_LEVEL
FATAL_LOG_LEVEL

◆ JY9515CoreOOPropertyType

enum class JY9515CoreOO::JY9515CoreOOPropertyType
strong
Enumerator
READ_ONLY
WRITE_ONLY
READ_WRITE

◆ JYDriverExceptionPublic

enum class JY9515CoreOO::JYDriverExceptionPublic
strong

驱动常用错误代码枚举定义

Enumerator
UnKnown | JYDriverExceptionPublic.
OpenDeviceFailed | JYDriverExceptionPublic.
CloseDeviceFailed | JYDriverExceptionPublic.
ResetDeviceFailed | JYDriverExceptionPublic.
GetDevicePropertyFailed | JYDriverExceptionPublic.
SetDevicePropertyFailed | JYDriverExceptionPublic.
HardwareResourceIsReserved | JYDriverExceptionPublic.
MethodNotPermitedToCallWhenCurrentStatus | JYDriverExceptionPublic.
InvalidUserDataBuffer | JYDriverExceptionPublic.
NoChannelAdded | JYDriverExceptionPublic.
NotSupportOperationForCurrentDevice | JYDriverExceptionPublic.
CreatTaskFailed | JYDriverExceptionPublic.
StartTaskFailed | JYDriverExceptionPublic.
StopTaskFailed | JYDriverExceptionPublic.
TaskHasNotStarted | JYDriverExceptionPublic.
TaskHasStartedCannotPerformTheSetOperation | JYDriverExceptionPublic.
ChannelNumberParameterInvalid | JYDriverExceptionPublic.
ChannelInputRangeParameterInvalid | JYDriverExceptionPublic.
ChannelTerminalParameterInvalid | JYDriverExceptionPublic.
ChannelCouplingParameterInvalid | JYDriverExceptionPublic.
SampeleModeParameterInvalid | JYDriverExceptionPublic.
SampleClockParameterInvalid | JYDriverExceptionPublic.
SampleRateParameterInvalid | JYDriverExceptionPublic.
UpdateRateParameterInvalid | JYDriverExceptionPublic.
TriggerParameterInvalid | JYDriverExceptionPublic.
ReferenceTriggerDoesNotMatchWithSampleMode | JYDriverExceptionPublic.
PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint | JYDriverExceptionPublic.
ReadDataFailed | JYDriverExceptionPublic.
ReadDataTimeout | JYDriverExceptionPublic.
WriteDataFailed | JYDriverExceptionPublic.
WriteDataTimeout | JYDriverExceptionPublic.
WriteDataLengthCannotBeLessThanN | JYDriverExceptionPublic.
BufferDataOverflow | JYDriverExceptionPublic.
BufferDataDownflow | JYDriverExceptionPublic.
CheckBufferFailed | JYDriverExceptionPublic.
PointInvalidInFiniteMode | JYDriverExceptionPublic.
ReadPointInvalid | JYDriverExceptionPublic.
OnlySupportRecordMode | JYDriverExceptionPublic.
SendSoftTirggerFailed | JYDriverExceptionPublic.
TaskTimeout | JYDriverExceptionPublic.
CounterParametersInvalid | JYDriverExceptionPublic.
WritePointInvalid | JYDriverExceptionPublic.
SignalExportDestinationInvalid | JYDriverExceptionPublic.
InvalidParameter | 无效参数。 Invalid parameter.

◆ LevelPolarity

enum class JY9515CoreOO::LevelPolarity
strong

Level Polarity.

Enumerator
LowLevel | Low level.
HighLevel | High level.
None | No active polarity.

◆ LPFMode

enum JY9515CoreOO::LPFMode

Low-Pass Filter Mode Enum.

Enumerator
Normal | Normal Mode. It has 0.4Fs bandwidth, medium latency, and a maximum sample rate of 256kSa/s
WideBandwidth | Wide Bandwidth Mode. It has 0.4535Fs bandwidth, high latency, and a maximum sample rate of 128kSa/s

◆ OutputCompleteState

enum class JY9515CoreOO::OutputCompleteState
strong

Output Complete State.

Enumerator
Zero | Output Complete Zero.
Hold | Output Complete Hold in The last point.

◆ ReferenceClockSource

enum class JY9515CoreOO::ReferenceClockSource
strong

Reference Clock Source

Enumerator
Internal | Internal on board 25MHz Clock.
External | External Reference Clock Source.

◆ SamplingState

enum class JY9515CoreOO::SamplingState
strong

Sampling State Enum.

Enumerator
Idle | Idle.
WaitingForStart | Waiting for start trigger.
PreSampling | Pre-sampling.
WaitingForRefTrigger | Waiting for reference trigger.
PostSampling | Post-sampling.
RecordCompleted | Record completed.
WaitingForAdvanceTrigger | Waiting for advance trigger.
Done | Done.

◆ SignalExportDestination

enum class JY9515CoreOO::SignalExportDestination
strong
Enumerator
Ext_Trig | External Trigger.
PXI_Trig0 | PXI Trigger 0.
PXI_Trig1 | PXI Trigger 1.
PXI_Trig2 | PXI Trigger 2.
PXI_Trig3 | PXI Trigger 3.
PXI_Trig4 | PXI Trigger 4.
PXI_Trig5 | PXI Trigger 5.
PXI_Trig6 | PXI Trigger 6.
PXI_Trig7 | PXI Trigger 7.
PXI_Star | PXI Star.

◆ SyncState

enum JY9515CoreOO::SyncState

Sync State.

Enumerator
WaitingSync | Waiting for Sync signal as a Slave device.
Synchronized | Already received Sync signal as a Slave device.
Invalid | This status is invalid when multi-card synchronization is not enabled or when the device is a Master device.

◆ SyncTerminal

enum JY9515CoreOO::SyncTerminal

AI digital trigger source enum type.

Enumerator
Ext_Trig | External Trigger.
PXI_Trig0 | PXI Trigger 0.
PXI_Trig1 | PXI Trigger 1.
PXI_Trig2 | PXI Trigger 2.
PXI_Trig3 | PXI Trigger 3.
PXI_Trig4 | PXI Trigger 4.
PXI_Trig5 | PXI Trigger 5.
PXI_Trig6 | PXI Trigger 6.
PXI_Trig7 | PXI Trigger 7.
PXI_Star | PXI Star.

◆ SyncTopology

enum class JY9515CoreOO::SyncTopology
strong

Synchronization board configuration.

Enumerator
Independent | Independent, synchronization not supported
Master | master card
Slave | slave card

Function Documentation

◆ GetSignalExportDestinationString()

std::string JY9515CoreOO::GetSignalExportDestinationString ( SignalExportDestination destination )
inline

Variable Documentation

◆ AIRagneGrade

const double JY9515CoreOO::AIRagneGrade[6] = { 0.3125, 0.6250, 1.25, 2.50, 5.0, 10.0 }

◆ AIRangeDescriptions

const std::map<int, std::string> JY9515CoreOO::AIRangeDescriptions
Initial value:
= {
{ JY9515Import::JY9515_Range_10V, "±10V" },
{ JY9515Import::JY9515_Range_5V, "±5V" },
{ JY9515Import::JY9515_Range_2p5V, "±2.5V" },
{ JY9515Import::JY9515_Range_1p25V, "±1.25V" },
{ JY9515Import::JY9515_Range_0p625V, "±0.625V" },
{ JY9515Import::JY9515_Range_0p3125V, "±0.3125V" }
}
JY9515Import::JY9515_Range_0p625V
const int JY9515_Range_0p625V
Definition JY9515CoreOOCommon.h:42
JY9515Import::JY9515_Range_0p3125V
const int JY9515_Range_0p3125V
Definition JY9515CoreOOCommon.h:43
JY9515Import::JY9515_Range_10V
const int JY9515_Range_10V
Definition JY9515CoreOOCommon.h:38
JY9515Import::JY9515_Range_5V
const int JY9515_Range_5V
Definition JY9515CoreOOCommon.h:39
JY9515Import::JY9515_Range_1p25V
const int JY9515_Range_1p25V
Definition JY9515CoreOOCommon.h:41
JY9515Import::JY9515_Range_2p5V
const int JY9515_Range_2p5V
Definition JY9515CoreOOCommon.h:40


9515 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/9515/JY9515CoreOOCommon.h File Reference

  • File List
  • File Members
  • COO
  • 9515
Classes | Namespaces | Macros | Enumerations | Functions | Variables
JY9515CoreOOCommon.h File Reference
#include <cstring>
#include <string>
#include <stdint.h>

Classes

class | JY9515CoreOO::JYDriverException
class | JY9515CoreOO::JY9515CoreOOProperty< ContainerClass, ValueType, propertyType >
属性模板类 More...
class | JY9515CoreOO::PauseTrigger
Pause trigger configuration class. More...
struct | JY9515CoreOO::FirmDriveInfo

Namespaces

namespace | JY9515Import
namespace | JY9515CoreOO

Macros

#define | EXTERN_C extern
Windows.
#define | JY9515CoreOO_API

Enumerations

enum class | JY9515CoreOO::JY9515CoreOOPropertyType { JY9515CoreOO::READ_ONLY = 1 , JY9515CoreOO::WRITE_ONLY = 2 , JY9515CoreOO::READ_WRITE = 3 }
enum class JY9515CoreOO::JYDriverExceptionPublic {
JY9515CoreOO::UnKnown = 0 , JY9515CoreOO::OpenDeviceFailed = -10001 , JY9515CoreOO::CloseDeviceFailed = -10002 , JY9515CoreOO::ResetDeviceFailed = -10003 ,
JY9515CoreOO::GetDevicePropertyFailed = -10004 , JY9515CoreOO::SetDevicePropertyFailed = -10005 , JY9515CoreOO::HardwareResourceIsReserved = -10006 , JY9515CoreOO::MethodNotPermitedToCallWhenCurrentStatus = -10007 ,
JY9515CoreOO::InvalidUserDataBuffer = -10008 , JY9515CoreOO::NoChannelAdded = -10009 , JY9515CoreOO::NotSupportOperationForCurrentDevice = -10010 , JY9515CoreOO::CreatTaskFailed = -10100 ,
JY9515CoreOO::StartTaskFailed = -10101 , JY9515CoreOO::StopTaskFailed = -10102 , JY9515CoreOO::TaskHasNotStarted = -10103 , JY9515CoreOO::TaskHasStartedCannotPerformTheSetOperation = -10104 ,
JY9515CoreOO::ChannelNumberParameterInvalid = -10105 , JY9515CoreOO::ChannelInputRangeParameterInvalid = -10106 , JY9515CoreOO::ChannelTerminalParameterInvalid = -10107 , JY9515CoreOO::ChannelCouplingParameterInvalid = -10108 ,
JY9515CoreOO::SampeleModeParameterInvalid = -10109 , JY9515CoreOO::SampleClockParameterInvalid = -10110 , JY9515CoreOO::SampleRateParameterInvalid = -10111 , JY9515CoreOO::UpdateRateParameterInvalid = -10112 ,
JY9515CoreOO::TriggerParameterInvalid = -10113 , JY9515CoreOO::ReferenceTriggerDoesNotMatchWithSampleMode = -10114 , JY9515CoreOO::PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint = -10115 , JY9515CoreOO::ReadDataFailed = -10016 ,
JY9515CoreOO::ReadDataTimeout = -10017 , JY9515CoreOO::WriteDataFailed = -10018 , JY9515CoreOO::WriteDataTimeout = -10019 , JY9515CoreOO::WriteDataLengthCannotBeLessThanN = -10020 ,
JY9515CoreOO::BufferDataOverflow = -10021 , JY9515CoreOO::BufferDataDownflow = -10022 , JY9515CoreOO::CheckBufferFailed = -10023 , JY9515CoreOO::PointInvalidInFiniteMode = -10024 ,
JY9515CoreOO::ReadPointInvalid = -10025 , JY9515CoreOO::OnlySupportRecordMode = -10026 , JY9515CoreOO::SendSoftTirggerFailed = -10027 , JY9515CoreOO::TaskTimeout = -10028 ,
JY9515CoreOO::CounterParametersInvalid = -10029 , JY9515CoreOO::WritePointInvalid = -10030 , JY9515CoreOO::SignalExportDestinationInvalid = -10031 , JY9515CoreOO::InvalidParameter = -10033
}
驱动常用错误代码枚举定义 More...
enum class JY9515CoreOO::SignalExportDestination {
JY9515CoreOO::Ext_Trig = JY9515Import::JY9515_DigitalTriggerSource_External , JY9515CoreOO::PXI_Trig0 = JY9515Import::JY9515_DigitalTriggerSource_BUS_0 , JY9515CoreOO::PXI_Trig1 = JY9515Import::JY9515_DigitalTriggerSource_BUS_1 , JY9515CoreOO::PXI_Trig2 = JY9515Import::JY9515_DigitalTriggerSource_BUS_2 ,
JY9515CoreOO::PXI_Trig3 = JY9515Import::JY9515_DigitalTriggerSource_BUS_3 , JY9515CoreOO::PXI_Trig4 = JY9515Import::JY9515_DigitalTriggerSource_BUS_4 , JY9515CoreOO::PXI_Trig5 = JY9515Import::JY9515_DigitalTriggerSource_BUS_5 , JY9515CoreOO::PXI_Trig6 = JY9515Import::JY9515_DigitalTriggerSource_BUS_6 ,
JY9515CoreOO::PXI_Trig7 = JY9515Import::JY9515_DigitalTriggerSource_BUS_7 , JY9515CoreOO::PXI_Star = JY9515Import::JY9515_DigitalTriggerSource_STAR
}
enum class | JY9515CoreOO::OutputCompleteState { JY9515CoreOO::Zero , JY9515CoreOO::Hold }
Output Complete State. More...
enum class | JY9515CoreOO::LevelPolarity { JY9515CoreOO::LowLevel = 0 , JY9515CoreOO::HighLevel = 1 , JY9515CoreOO::None = 2 }
Level Polarity. More...

Functions

std::string JY9515CoreOO::GetSignalExportDestinationString (SignalExportDestination destination)

Variables

const int | JY9515Import::JY9515_Onboard_10M = 0
const int | JY9515Import::JY9515_PXIe_Clk_100M = 1
const int | JY9515Import::JY9515_Range_15V = 6
const int | JY9515Import::JY9515_Range_10V = 5
const int | JY9515Import::JY9515_Range_5V = 4
const int | JY9515Import::JY9515_Range_2p5V = 3
const int | JY9515Import::JY9515_Range_1p25V = 2
const int | JY9515Import::JY9515_Range_0p625V = 1
const int | JY9515Import::JY9515_Range_0p3125V = 0
const int | JY9515Import::JY9515_Coupling_AC = 0
const int | JY9515Import::JY9515_Coupling_DC = 1
const int | JY9515Import::WidebandLowRippleFilter = 0
const int | JY9515Import::Sinc5Filter = 1
const int | JY9515Import::JY9515_AI_Finite = 0
const int | JY9515Import::JY9515_AI_Continuous = 1
const int | JY9515Import::JY9515_AI_Single = 2
const int | JY9515Import::JY9515_TriggerType_Immediately = 0
const int | JY9515Import::JY9515_TriggerType_Digital = 1
const int | JY9515Import::JY9515_TriggerType_Software = 2
const int | JY9515Import::JY9515_TriggerType_Analog = 3
const int | JY9515Import::JY9515_DigitalTriggerEdge_Rising = 0
const int | JY9515Import::JY9515_DigitalTriggerEdge_Falling = 1
const int | JY9515Import::JY9515_DigitalTriggerSource_External = 0
const int | JY9515Import::JY9515_DigitalTriggerSource_BUS_0 = 1
const int | JY9515Import::JY9515_DigitalTriggerSource_BUS_1 = 2
const int | JY9515Import::JY9515_DigitalTriggerSource_BUS_2 = 3
const int | JY9515Import::JY9515_DigitalTriggerSource_BUS_3 = 4
const int | JY9515Import::JY9515_DigitalTriggerSource_BUS_4 = 5
const int | JY9515Import::JY9515_DigitalTriggerSource_BUS_5 = 6
const int | JY9515Import::JY9515_DigitalTriggerSource_BUS_6 = 7
const int | JY9515Import::JY9515_DigitalTriggerSource_BUS_7 = 8
const int | JY9515Import::JY9515_DigitalTriggerSource_STAR = 9
const int | JY9515Import::JY9515_AnlogTriggerCondition_RisingHysteresis = 0
const int | JY9515Import::JY9515_AnlogTriggerCondition_FallingHysteresis = 1
const int | JY9515Import::JY9515_AnlogTriggerCondition_EnteringWindow = 2
const int | JY9515Import::JY9515_AnlogTriggerCondition_LeavingWindow = 3
const int | JY9515Import::JY9515_SyncMode_Solo = 0
const int | JY9515Import::JY9515_SyncMode_Master = 1
const int | JY9515Import::JY9515_SyncMode_Slave = 2
const int | JY9515Import::JY9515_EXPORT_SAMPLE_CLOCK = 0
const int | JY9515Import::JY9515_EXPORT_SYNC = 1
const int | JY9515Import::JY9515_EXPORT_RX_READY_FOR_START_TRIG = 2
const int | JY9515Import::JY9515_EXPORT_RX_START_TRIG = 3
const int | JY9515Import::JY9515_EXPORT_RX_READY_FOR_REF_TRIG = 4
const int | JY9515Import::JY9515_EXPORT_RX_REF_TRIG = 5
const int | JY9515Import::JY9515_EXPORT_RX_READY_FOR_ADV_TRIG = 6
const int | JY9515Import::JY9515_EXPORT_RX_ADV_TRIG = 7
const int | JY9515Import::JY9515_EXPORT_RX_END_OF_RECORD = 8
const int | JY9515Import::JY9515_EXPORT_RX_ENGINE_END = 9
const int | JY9515Import::JY9515_EXPORT_MCLK = 10
const int | JY9515Import::JY9515_EXPORT_DCLK = 11
const int | JY9515Import::JY9515_EXPORT_PLL_SYNC = 12
const int | JY9515Import::JY9515_EXPORT_ADC_SYNC = 13
const int | JY9515Import::JY9515_EXPORT_ADC_DRDY = 14
const int | JY9515Import::JY9515_CalCoePosition_EEPROM = 0
const int | JY9515Import::JY9515_CalCoePosition_Handle = 1
const int | JY9515Import::JY9515_ADCChopping_fMod32 = 0
const int | JY9515Import::JY9517_ADCChopping_fMod8 = 1

Macro Definition Documentation

◆ EXTERN_C

#define EXTERN_C extern

Windows.

Linux

◆ JY9515CoreOO_API

#define JY9515CoreOO_API


9515 C++ Programming Manual: JY9515CoreOO::JYDriverException Class Reference

  • JYDriverException
Public Member Functions | Public Attributes | List of all members
JY9515CoreOO::JYDriverException Class Reference

#include <JY9515CoreOOCommon.h>

Public Member Functions

JYDriverException (JYDriverExceptionPublic exceptionCode, std::string msg="")
JYDriverException (int, std::string msg)

Public Attributes

std::string exceptionMessage
JYDriverExceptionPublic errorCode
JYDriverException * FollowingException

Constructor & Destructor Documentation

◆ JYDriverException() [1/2]

JY9515CoreOO::JYDriverException::JYDriverException | ( | JYDriverExceptionPublic | exceptionCode,
 |  | std::string | msg = "" )

◆ JYDriverException() [2/2]

JY9515CoreOO::JYDriverException::JYDriverException | ( | int | ,
 |  | std::string | msg )

Member Data Documentation

◆ errorCode

JYDriverExceptionPublic JY9515CoreOO::JYDriverException::errorCode

◆ exceptionMessage

std::string JY9515CoreOO::JYDriverException::exceptionMessage

◆ FollowingException

JYDriverException* JY9515CoreOO::JYDriverException::FollowingException
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9515/JY9515CoreOOCommon.h


9515 C++ Programming Manual: JY9515CoreOO::JY9515CoreOOProperty< ContainerClass, ValueType, propertyType > Class Template Reference

  • JY9515CoreOOProperty
Public Member Functions | List of all members
JY9515CoreOO::JY9515CoreOOProperty< ContainerClass, ValueType, propertyType > Class Template Reference

属性模板类 More...

#include <JY9515CoreOOCommon.h>

Public Member Functions

JY9515CoreOOProperty ()
JY9515CoreOOProperty (ContainerClass *cObject, ValueType(ContainerClass::*pGet)(), void(ContainerClass::*pSet)(ValueType value))
JY9515CoreOOProperty (ValueType(*pGet)(), void(*pSet)(ValueType value))
ValueType operator= (const ValueType &value)
operator ValueType ()

Detailed Description

template<typename ContainerClass, typename ValueType, JY9515CoreOOPropertyType propertyType>
class JY9515CoreOO::JY9515CoreOOProperty< ContainerClass, ValueType, propertyType >

属性模板类

Constructor & Destructor Documentation

◆ JY9515CoreOOProperty() [1/3]

template<typename ContainerClass, typename ValueType, JY9515CoreOOPropertyType propertyType>
JY9515CoreOO::JY9515CoreOOProperty< ContainerClass, ValueType, propertyType >::JY9515CoreOOProperty ( )

◆ JY9515CoreOOProperty() [2/3]

template<typename ContainerClass, typename ValueType, JY9515CoreOOPropertyType propertyType>
JY9515CoreOO::JY9515CoreOOProperty< ContainerClass, ValueType, propertyType >::JY9515CoreOOProperty | ( | ContainerClass * | cObject,
 |  | ValueType(ContainerClass::* | pGet )(),
 |  | void(ContainerClass::* | pSet )(ValueType value) )

◆ JY9515CoreOOProperty() [3/3]

template<typename ContainerClass, typename ValueType, JY9515CoreOOPropertyType propertyType>
JY9515CoreOO::JY9515CoreOOProperty< ContainerClass, ValueType, propertyType >::JY9515CoreOOProperty | ( | ValueType(* | pGet )(),
 |  | void(* | pSet )(ValueType value) )

Member Function Documentation

◆ operator ValueType()

template<typename ContainerClass, typename ValueType, JY9515CoreOOPropertyType propertyType>
JY9515CoreOO::JY9515CoreOOProperty< ContainerClass, ValueType, propertyType >::operator ValueType ( )

◆ operator=()

template<typename ContainerClass, typename ValueType, JY9515CoreOOPropertyType propertyType>
ValueType JY9515CoreOO::JY9515CoreOOProperty< ContainerClass, ValueType, propertyType >::operator= ( const ValueType & value )
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9515/JY9515CoreOOCommon.h


9515 C++ Programming Manual: JY9515CoreOO::PauseTrigger Class Reference

  • PauseTrigger
Public Attributes | List of all members
JY9515CoreOO::PauseTrigger Class Reference

Pause trigger configuration class. More...

#include <JY9515CoreOOCommon.h>

Public Attributes

LevelPolarity ActivePolarity
Pause trigger active polarity.
InputTerminal Terminal
Terminal.

Detailed Description

Pause trigger configuration class.

Member Data Documentation

◆ ActivePolarity

LevelPolarity JY9515CoreOO::PauseTrigger::ActivePolarity

Pause trigger active polarity.

The default value is LevelPolarity.None, means the pause trigger is disabled.

◆ Terminal

InputTerminal JY9515CoreOO::PauseTrigger::Terminal

Terminal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9515/JY9515CoreOOCommon.h


9515 C++ Programming Manual: JY9515CoreOO::FirmDriveInfo Struct Reference

  • FirmDriveInfo
Public Attributes | List of all members
JY9515CoreOO::FirmDriveInfo Struct Reference

#include <JY9515CoreOOCommon.h>

Public Attributes

int | VID
int | PID
int | slotNum
int | connected
int | cardNumber
int | fStreaming
char | serialNumber [33]
char | vendorName [65]
char | model [65]
char | aliasName [65]
char | PlatformType [16]
char | HardwareVer [16]
char | FirmwareVer [16]
char | FrameworkVer [16]
char | DriverSetVer [16]
char | ProductionDate [16]

Member Data Documentation

◆ aliasName

char JY9515CoreOO::FirmDriveInfo::aliasName[65]

◆ cardNumber

int JY9515CoreOO::FirmDriveInfo::cardNumber

◆ connected

int JY9515CoreOO::FirmDriveInfo::connected

◆ DriverSetVer

char JY9515CoreOO::FirmDriveInfo::DriverSetVer[16]

◆ FirmwareVer

char JY9515CoreOO::FirmDriveInfo::FirmwareVer[16]

◆ FrameworkVer

char JY9515CoreOO::FirmDriveInfo::FrameworkVer[16]

◆ fStreaming

int JY9515CoreOO::FirmDriveInfo::fStreaming

◆ HardwareVer

char JY9515CoreOO::FirmDriveInfo::HardwareVer[16]

◆ model

char JY9515CoreOO::FirmDriveInfo::model[65]

◆ PID

int JY9515CoreOO::FirmDriveInfo::PID

◆ PlatformType

char JY9515CoreOO::FirmDriveInfo::PlatformType[16]

◆ ProductionDate

char JY9515CoreOO::FirmDriveInfo::ProductionDate[16]

◆ serialNumber

char JY9515CoreOO::FirmDriveInfo::serialNumber[33]

◆ slotNum

int JY9515CoreOO::FirmDriveInfo::slotNum

◆ vendorName

char JY9515CoreOO::FirmDriveInfo::vendorName[65]

◆ VID

int JY9515CoreOO::FirmDriveInfo::VID
The documentation for this struct was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9515/JY9515CoreOOCommon.h


9515 C++ Programming Manual: JY9515Import Namespace Reference

  • Namespace List
  • Namespace Members
Variables
JY9515Import Namespace Reference

Variables

const int | JY9515_Onboard_10M = 0
const int | JY9515_PXIe_Clk_100M = 1
const int | JY9515_Range_15V = 6
const int | JY9515_Range_10V = 5
const int | JY9515_Range_5V = 4
const int | JY9515_Range_2p5V = 3
const int | JY9515_Range_1p25V = 2
const int | JY9515_Range_0p625V = 1
const int | JY9515_Range_0p3125V = 0
const int | JY9515_Coupling_AC = 0
const int | JY9515_Coupling_DC = 1
const int | WidebandLowRippleFilter = 0
const int | Sinc5Filter = 1
const int | JY9515_AI_Finite = 0
const int | JY9515_AI_Continuous = 1
const int | JY9515_AI_Single = 2
const int | JY9515_TriggerType_Immediately = 0
const int | JY9515_TriggerType_Digital = 1
const int | JY9515_TriggerType_Software = 2
const int | JY9515_TriggerType_Analog = 3
const int | JY9515_DigitalTriggerEdge_Rising = 0
const int | JY9515_DigitalTriggerEdge_Falling = 1
const int | JY9515_DigitalTriggerSource_External = 0
const int | JY9515_DigitalTriggerSource_BUS_0 = 1
const int | JY9515_DigitalTriggerSource_BUS_1 = 2
const int | JY9515_DigitalTriggerSource_BUS_2 = 3
const int | JY9515_DigitalTriggerSource_BUS_3 = 4
const int | JY9515_DigitalTriggerSource_BUS_4 = 5
const int | JY9515_DigitalTriggerSource_BUS_5 = 6
const int | JY9515_DigitalTriggerSource_BUS_6 = 7
const int | JY9515_DigitalTriggerSource_BUS_7 = 8
const int | JY9515_DigitalTriggerSource_STAR = 9
const int | JY9515_AnlogTriggerCondition_RisingHysteresis = 0
const int | JY9515_AnlogTriggerCondition_FallingHysteresis = 1
const int | JY9515_AnlogTriggerCondition_EnteringWindow = 2
const int | JY9515_AnlogTriggerCondition_LeavingWindow = 3
const int | JY9515_SyncMode_Solo = 0
const int | JY9515_SyncMode_Master = 1
const int | JY9515_SyncMode_Slave = 2
const int | JY9515_EXPORT_SAMPLE_CLOCK = 0
const int | JY9515_EXPORT_SYNC = 1
const int | JY9515_EXPORT_RX_READY_FOR_START_TRIG = 2
const int | JY9515_EXPORT_RX_START_TRIG = 3
const int | JY9515_EXPORT_RX_READY_FOR_REF_TRIG = 4
const int | JY9515_EXPORT_RX_REF_TRIG = 5
const int | JY9515_EXPORT_RX_READY_FOR_ADV_TRIG = 6
const int | JY9515_EXPORT_RX_ADV_TRIG = 7
const int | JY9515_EXPORT_RX_END_OF_RECORD = 8
const int | JY9515_EXPORT_RX_ENGINE_END = 9
const int | JY9515_EXPORT_MCLK = 10
const int | JY9515_EXPORT_DCLK = 11
const int | JY9515_EXPORT_PLL_SYNC = 12
const int | JY9515_EXPORT_ADC_SYNC = 13
const int | JY9515_EXPORT_ADC_DRDY = 14
const int | JY9515_CalCoePosition_EEPROM = 0
const int | JY9515_CalCoePosition_Handle = 1
const int | JY9515_ADCChopping_fMod32 = 0
const int | JY9517_ADCChopping_fMod8 = 1

Variable Documentation

◆ JY9515_ADCChopping_fMod32

const int JY9515Import::JY9515_ADCChopping_fMod32 = 0

◆ JY9515_AI_Continuous

const int JY9515Import::JY9515_AI_Continuous = 1

◆ JY9515_AI_Finite

const int JY9515Import::JY9515_AI_Finite = 0

◆ JY9515_AI_Single

const int JY9515Import::JY9515_AI_Single = 2

◆ JY9515_AnlogTriggerCondition_EnteringWindow

const int JY9515Import::JY9515_AnlogTriggerCondition_EnteringWindow = 2

◆ JY9515_AnlogTriggerCondition_FallingHysteresis

const int JY9515Import::JY9515_AnlogTriggerCondition_FallingHysteresis = 1

◆ JY9515_AnlogTriggerCondition_LeavingWindow

const int JY9515Import::JY9515_AnlogTriggerCondition_LeavingWindow = 3

◆ JY9515_AnlogTriggerCondition_RisingHysteresis

const int JY9515Import::JY9515_AnlogTriggerCondition_RisingHysteresis = 0

◆ JY9515_CalCoePosition_EEPROM

const int JY9515Import::JY9515_CalCoePosition_EEPROM = 0

◆ JY9515_CalCoePosition_Handle

const int JY9515Import::JY9515_CalCoePosition_Handle = 1

◆ JY9515_Coupling_AC

const int JY9515Import::JY9515_Coupling_AC = 0

◆ JY9515_Coupling_DC

const int JY9515Import::JY9515_Coupling_DC = 1

◆ JY9515_DigitalTriggerEdge_Falling

const int JY9515Import::JY9515_DigitalTriggerEdge_Falling = 1

◆ JY9515_DigitalTriggerEdge_Rising

const int JY9515Import::JY9515_DigitalTriggerEdge_Rising = 0

◆ JY9515_DigitalTriggerSource_BUS_0

const int JY9515Import::JY9515_DigitalTriggerSource_BUS_0 = 1

◆ JY9515_DigitalTriggerSource_BUS_1

const int JY9515Import::JY9515_DigitalTriggerSource_BUS_1 = 2

◆ JY9515_DigitalTriggerSource_BUS_2

const int JY9515Import::JY9515_DigitalTriggerSource_BUS_2 = 3

◆ JY9515_DigitalTriggerSource_BUS_3

const int JY9515Import::JY9515_DigitalTriggerSource_BUS_3 = 4

◆ JY9515_DigitalTriggerSource_BUS_4

const int JY9515Import::JY9515_DigitalTriggerSource_BUS_4 = 5

◆ JY9515_DigitalTriggerSource_BUS_5

const int JY9515Import::JY9515_DigitalTriggerSource_BUS_5 = 6

◆ JY9515_DigitalTriggerSource_BUS_6

const int JY9515Import::JY9515_DigitalTriggerSource_BUS_6 = 7

◆ JY9515_DigitalTriggerSource_BUS_7

const int JY9515Import::JY9515_DigitalTriggerSource_BUS_7 = 8

◆ JY9515_DigitalTriggerSource_External

const int JY9515Import::JY9515_DigitalTriggerSource_External = 0

◆ JY9515_DigitalTriggerSource_STAR

const int JY9515Import::JY9515_DigitalTriggerSource_STAR = 9

◆ JY9515_EXPORT_ADC_DRDY

const int JY9515Import::JY9515_EXPORT_ADC_DRDY = 14

◆ JY9515_EXPORT_ADC_SYNC

const int JY9515Import::JY9515_EXPORT_ADC_SYNC = 13

◆ JY9515_EXPORT_DCLK

const int JY9515Import::JY9515_EXPORT_DCLK = 11

◆ JY9515_EXPORT_MCLK

const int JY9515Import::JY9515_EXPORT_MCLK = 10

◆ JY9515_EXPORT_PLL_SYNC

const int JY9515Import::JY9515_EXPORT_PLL_SYNC = 12

◆ JY9515_EXPORT_RX_ADV_TRIG

const int JY9515Import::JY9515_EXPORT_RX_ADV_TRIG = 7

◆ JY9515_EXPORT_RX_END_OF_RECORD

const int JY9515Import::JY9515_EXPORT_RX_END_OF_RECORD = 8

◆ JY9515_EXPORT_RX_ENGINE_END

const int JY9515Import::JY9515_EXPORT_RX_ENGINE_END = 9

◆ JY9515_EXPORT_RX_READY_FOR_ADV_TRIG

const int JY9515Import::JY9515_EXPORT_RX_READY_FOR_ADV_TRIG = 6

◆ JY9515_EXPORT_RX_READY_FOR_REF_TRIG

const int JY9515Import::JY9515_EXPORT_RX_READY_FOR_REF_TRIG = 4

◆ JY9515_EXPORT_RX_READY_FOR_START_TRIG

const int JY9515Import::JY9515_EXPORT_RX_READY_FOR_START_TRIG = 2

◆ JY9515_EXPORT_RX_REF_TRIG

const int JY9515Import::JY9515_EXPORT_RX_REF_TRIG = 5

◆ JY9515_EXPORT_RX_START_TRIG

const int JY9515Import::JY9515_EXPORT_RX_START_TRIG = 3

◆ JY9515_EXPORT_SAMPLE_CLOCK

const int JY9515Import::JY9515_EXPORT_SAMPLE_CLOCK = 0

◆ JY9515_EXPORT_SYNC

const int JY9515Import::JY9515_EXPORT_SYNC = 1

◆ JY9515_Onboard_10M

const int JY9515Import::JY9515_Onboard_10M = 0

◆ JY9515_PXIe_Clk_100M

const int JY9515Import::JY9515_PXIe_Clk_100M = 1

◆ JY9515_Range_0p3125V

const int JY9515Import::JY9515_Range_0p3125V = 0

◆ JY9515_Range_0p625V

const int JY9515Import::JY9515_Range_0p625V = 1

◆ JY9515_Range_10V

const int JY9515Import::JY9515_Range_10V = 5

◆ JY9515_Range_15V

const int JY9515Import::JY9515_Range_15V = 6

◆ JY9515_Range_1p25V

const int JY9515Import::JY9515_Range_1p25V = 2

◆ JY9515_Range_2p5V

const int JY9515Import::JY9515_Range_2p5V = 3

◆ JY9515_Range_5V

const int JY9515Import::JY9515_Range_5V = 4

◆ JY9515_SyncMode_Master

const int JY9515Import::JY9515_SyncMode_Master = 1

◆ JY9515_SyncMode_Slave

const int JY9515Import::JY9515_SyncMode_Slave = 2

◆ JY9515_SyncMode_Solo

const int JY9515Import::JY9515_SyncMode_Solo = 0

◆ JY9515_TriggerType_Analog

const int JY9515Import::JY9515_TriggerType_Analog = 3

◆ JY9515_TriggerType_Digital

const int JY9515Import::JY9515_TriggerType_Digital = 1

◆ JY9515_TriggerType_Immediately

const int JY9515Import::JY9515_TriggerType_Immediately = 0

◆ JY9515_TriggerType_Software

const int JY9515Import::JY9515_TriggerType_Software = 2

◆ JY9517_ADCChopping_fMod8

const int JY9515Import::JY9517_ADCChopping_fMod8 = 1

◆ Sinc5Filter

const int JY9515Import::Sinc5Filter = 1

◆ WidebandLowRippleFilter

const int JY9515Import::WidebandLowRippleFilter = 0


9515 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/9515/JY9515CoreOODevice.h File Reference

  • File List
  • File Members
  • COO
  • 9515
Classes | Namespaces | Enumerations | Variables
JY9515CoreOODevice.h File Reference
#include <iostream>
#include <stdlib.h>
#include <list>
#include <vector>
#include "JY9515CoreOOCommon.h"

Classes

class | JY9515CoreOO::JY9515CoreOODevice
JY9515CoreOO Device. More...
class | JY9515CoreOO::DeviceStatus
Device Status. More...
class | JY9515CoreOO::SampleInfo
Sampling information. More...
class | JY9515CoreOO::ExternalReferenceClock
External Reference Clcok Terminal. More...
class | JY9515CoreOO::JY9515CoreOOReferenceClock
class | JY9515CoreOO::JY9515DeviceInfo
Device Info. More...

Namespaces

namespace JY9515CoreOO

Enumerations

enum | JY9515CoreOO::LPFMode { JY9515CoreOO::Normal = 0 , JY9515CoreOO::WideBandwidth = 1 }
Low-Pass Filter Mode Enum. More...
enum | JY9515CoreOO::ADCFilterType { JY9515CoreOO::WidebandLowRippleFilter = JY9515Import::WidebandLowRippleFilter , JY9515CoreOO::Sinc5Filter = JY9515Import::Sinc5Filter }
ADC Filter Type Enum. More...
enum class | JY9515CoreOO::ExternalReferenceClockTerminal { JY9515CoreOO::PXIe_Clk100 = JY9515Import::JY9515_PXIe_Clk_100M }
enum class | JY9515CoreOO::ReferenceClockSource { JY9515CoreOO::Internal = 0x0 , JY9515CoreOO::External = 0x1 }

Variables

const double JY9515CoreOO::AIRagneGrade [6] = { 0.3125, 0.6250, 1.25, 2.50, 5.0, 10.0 }


9515 C++ Programming Manual: JY9515CoreOO::JY9515CoreOODevice Class Reference

  • JY9515CoreOODevice
Static Public Member Functions | Public Attributes | List of all members
JY9515CoreOO::JY9515CoreOODevice Class Reference

JY9515CoreOO Device. More...

#include <JY9515CoreOODevice.h>

Static Public Member Functions

static JY9515CoreOODevice * | GetInstance (int cardNum)
The operation instance is obtained according to the board number to ensure that there is only one registered instance for each board.
static JY9515CoreOODevice * | GetInstance (std::string aliasName)
The operation instance is obtained according to aliasName to ensure that there is only one registration instance for each board.
static SampleInfo | ParseSampleRate (double sampleRate, LPFMode filterMode)
Get MCLK and fMod at the specified sampling rate.

Public Attributes

uint32_t | JY9515PID [6] = { 0x9515, 0xA515, 0x9B15, 0xF515, 0xE515, 0xFB15 }
friend | HighPassFilter
const double | BoardClockRate = 100000000
Board Clock Rate.
const uint32_t | AIBufferSize = 1024 * 1024 * 512
AI Buffer Size.
const double | MaxSampleRate = 256000.0
Maximum Sampling Rate.
const double | MinSampleRate = 62.5
Minimum Sampling Rate.
const int | TotalNumberOfChannels = 8
Total Number of Channels Provided.
const double | MaxInputVoltage = 10
Maximum Input Voltage.
JY9515CoreOOProperty< JY9515CoreOODevice, int, JY9515CoreOOPropertyType::READ_ONLY > | DeviceID
JY9515CoreOOProperty< JY9515CoreOODevice, JY9515DeviceInfo *, JY9515CoreOOPropertyType::READ_ONLY > Info
JY9515CoreOOProperty< JY9515CoreOODevice, DeviceStatus *, JY9515CoreOOPropertyType::READ_ONLY > Status
JY9515CoreOOReferenceClock * ReferenceClock
Reference Clock Configuration.

Detailed Description

JY9515CoreOO Device.

Member Function Documentation

◆ GetInstance() [1/2]

static JY9515CoreOODevice * JY9515CoreOO::JY9515CoreOODevice::GetInstance ( int cardNum )
static

The operation instance is obtained according to the board number to ensure that there is only one registered instance for each board.

Parameters
cardNum
Returns

◆ GetInstance() [2/2]

static JY9515CoreOODevice * JY9515CoreOO::JY9515CoreOODevice::GetInstance ( std::string aliasName )
static

The operation instance is obtained according to aliasName to ensure that there is only one registration instance for each board.

Parameters
aliasName
Returns

◆ ParseSampleRate()

static SampleInfo JY9515CoreOO::JY9515CoreOODevice::ParseSampleRate | ( | double | sampleRate,
 |  | LPFMode | filterMode )
 static

Get MCLK and fMod at the specified sampling rate.

Parameters
sampleRate | Specified Sampling Rate
filterMode | Specified Filter Mode

Member Data Documentation

◆ AIBufferSize

const uint32_t JY9515CoreOO::JY9515CoreOODevice::AIBufferSize = 1024 * 1024 * 512

AI Buffer Size.

◆ BoardClockRate

const double JY9515CoreOO::JY9515CoreOODevice::BoardClockRate = 100000000

Board Clock Rate.

◆ DeviceID

JY9515CoreOOProperty<JY9515CoreOODevice, int, JY9515CoreOOPropertyType::READ_ONLY> JY9515CoreOO::JY9515CoreOODevice::DeviceID

◆ HighPassFilter

friend JY9515CoreOO::JY9515CoreOODevice::HighPassFilter

◆ Info

JY9515CoreOOProperty<JY9515CoreOODevice, JY9515DeviceInfo*, JY9515CoreOOPropertyType::READ_ONLY> JY9515CoreOO::JY9515CoreOODevice::Info

◆ JY9515PID

uint32_t JY9515CoreOO::JY9515CoreOODevice::JY9515PID[6] = { 0x9515, 0xA515, 0x9B15, 0xF515, 0xE515, 0xFB15 }

◆ MaxInputVoltage

const double JY9515CoreOO::JY9515CoreOODevice::MaxInputVoltage = 10

Maximum Input Voltage.

◆ MaxSampleRate

const double JY9515CoreOO::JY9515CoreOODevice::MaxSampleRate = 256000.0

Maximum Sampling Rate.

◆ MinSampleRate

const double JY9515CoreOO::JY9515CoreOODevice::MinSampleRate = 62.5

Minimum Sampling Rate.

◆ ReferenceClock

JY9515CoreOOReferenceClock* JY9515CoreOO::JY9515CoreOODevice::ReferenceClock

Reference Clock Configuration.

◆ Status

JY9515CoreOOProperty<JY9515CoreOODevice, DeviceStatus*, JY9515CoreOOPropertyType::READ_ONLY> JY9515CoreOO::JY9515CoreOODevice::Status

◆ TotalNumberOfChannels

const int JY9515CoreOO::JY9515CoreOODevice::TotalNumberOfChannels = 8

Total Number of Channels Provided.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9515/JY9515CoreOODevice.h


9515 C++ Programming Manual: JY9515CoreOO::DeviceStatus Class Reference

  • DeviceStatus
Public Member Functions | Public Attributes | List of all members
JY9515CoreOO::DeviceStatus Class Referencefinal

Device Status. More...

#include <JY9515CoreOODevice.h>

Public Member Functions

DeviceStatus (void *deviceHandle)
~DeviceStatus ()

Public Attributes

JY9515CoreOOProperty< DeviceStatus, double, JY9515CoreOOPropertyType::READ_ONLY > Temperature

Detailed Description

Device Status.

Constructor & Destructor Documentation

◆ DeviceStatus()

JY9515CoreOO::DeviceStatus::DeviceStatus ( void * deviceHandle )

◆ ~DeviceStatus()

JY9515CoreOO::DeviceStatus::~DeviceStatus ( )

Member Data Documentation

◆ Temperature

JY9515CoreOOProperty<DeviceStatus, double, JY9515CoreOOPropertyType::READ_ONLY> JY9515CoreOO::DeviceStatus::Temperature
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9515/JY9515CoreOODevice.h


9515 C++ Programming Manual: JY9515CoreOO::SampleInfo Class Reference

  • SampleInfo
Public Member Functions | Public Attributes | List of all members
JY9515CoreOO::SampleInfo Class Referencefinal

Sampling information. More...

#include <JY9515CoreOODevice.h>

Public Member Functions

SampleInfo (double sampleRate, LPFMode filterMode, double mclk, double fmod, double dclk, int adcDec, int fpgaDec, ADCFilterType adcFilterType, bool fpgaSinc5Enabled, double groupDelay)

Public Attributes

JY9515CoreOOProperty< SampleInfo, double, JY9515CoreOOPropertyType::READ_ONLY > | FMod
Modulation Frequency.
JY9515CoreOOProperty< SampleInfo, double, JY9515CoreOOPropertyType::READ_ONLY > | GroupDelay
Group Delay in Samples.

Detailed Description

Sampling information.

Including the modulation frequency and group delay in the current configuration.

Constructor & Destructor Documentation

◆ SampleInfo()

JY9515CoreOO::SampleInfo::SampleInfo | ( | double | sampleRate,
 |  | LPFMode | filterMode,
 |  | double | mclk,
 |  | double | fmod,
 |  | double | dclk,
 |  | int | adcDec,
 |  | int | fpgaDec,
 |  | ADCFilterType | adcFilterType,
 |  | bool | fpgaSinc5Enabled,
 |  | double | groupDelay )

Member Data Documentation

◆ FMod

JY9515CoreOOProperty<SampleInfo, double, JY9515CoreOOPropertyType::READ_ONLY> JY9515CoreOO::SampleInfo::FMod

Modulation Frequency.

◆ GroupDelay

JY9515CoreOOProperty<SampleInfo, double, JY9515CoreOOPropertyType::READ_ONLY> JY9515CoreOO::SampleInfo::GroupDelay

Group Delay in Samples.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9515/JY9515CoreOODevice.h


9515 C++ Programming Manual: JY9515CoreOO::ExternalReferenceClock Class Reference

  • ExternalReferenceClock
Public Attributes | List of all members
JY9515CoreOO::ExternalReferenceClock Class Reference

External Reference Clcok Terminal. More...

#include <JY9515CoreOODevice.h>

Public Attributes

ExternalReferenceClockTerminal Terminal
int Frequency

Detailed Description

External Reference Clcok Terminal.

Member Data Documentation

◆ Frequency

int JY9515CoreOO::ExternalReferenceClock::Frequency

◆ Terminal

ExternalReferenceClockTerminal JY9515CoreOO::ExternalReferenceClock::Terminal
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9515/JY9515CoreOODevice.h


9515 C++ Programming Manual: JY9515CoreOO::JY9515CoreOOReferenceClock Class Reference

  • JY9515CoreOOReferenceClock
Public Attributes | List of all members
JY9515CoreOO::JY9515CoreOOReferenceClock Class Reference

#include <JY9515CoreOODevice.h>

Public Attributes

ReferenceClockSource Source
JY9515CoreOOProperty< JY9515CoreOOReferenceClock, int, JY9515CoreOOPropertyType::READ_ONLY > SelectedReferenceClock
ExternalReferenceClock * External
External Reference Clock Source.

Detailed Description

参考时钟配置类

Reference Clcok Configuration Class

Member Data Documentation

◆ External

ExternalReferenceClock* JY9515CoreOO::JY9515CoreOOReferenceClock::External

External Reference Clock Source.

Required when ReferenceClock.Source is ReferenceClockSource.External

◆ SelectedReferenceClock

JY9515CoreOOProperty<JY9515CoreOOReferenceClock, int, JY9515CoreOOPropertyType::READ_ONLY> JY9515CoreOO::JY9515CoreOOReferenceClock::SelectedReferenceClock

◆ Source

ReferenceClockSource JY9515CoreOO::JY9515CoreOOReferenceClock::Source
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9515/JY9515CoreOODevice.h


9515 C++ Programming Manual: JY9515CoreOO::JY9515DeviceInfo Class Reference

  • JY9515DeviceInfo
Public Member Functions | Public Attributes | List of all members
JY9515CoreOO::JY9515DeviceInfo Class Reference

Device Info. More...

#include <JY9515CoreOODevice.h>

Public Member Functions

JY9515DeviceInfo ()
JY9515DeviceInfo (void *deviceHandle)
JY9515DeviceInfo (FirmDriveInfo info)
int | GetPID ()
int | GetSlotNum ()
std::string | GetAliasName ()
std::string | GetSN ()

Public Attributes

JY9515CoreOOProperty< JY9515DeviceInfo, int, JY9515CoreOOPropertyType::READ_ONLY > | HardwareVersion
JY9515CoreOOProperty< JY9515DeviceInfo, int, JY9515CoreOOPropertyType::READ_ONLY > | FirmwareVersionInt
JY9515CoreOOProperty< JY9515DeviceInfo, std::string, JY9515CoreOOPropertyType::READ_ONLY > | FirmwareVersion
JY9515CoreOOProperty< JY9515DeviceInfo, bool, JY9515CoreOOPropertyType::READ_ONLY > | IsPXIeDevice
JY9515CoreOOProperty< JY9515DeviceInfo, bool, JY9515CoreOOPropertyType::READ_ONLY > | IEPEAvailable

Detailed Description

Device Info.

Constructor & Destructor Documentation

◆ JY9515DeviceInfo() [1/3]

JY9515CoreOO::JY9515DeviceInfo::JY9515DeviceInfo ( )

◆ JY9515DeviceInfo() [2/3]

JY9515CoreOO::JY9515DeviceInfo::JY9515DeviceInfo ( void * deviceHandle )

◆ JY9515DeviceInfo() [3/3]

JY9515CoreOO::JY9515DeviceInfo::JY9515DeviceInfo ( FirmDriveInfo info )

Member Function Documentation

◆ GetAliasName()

std::string JY9515CoreOO::JY9515DeviceInfo::GetAliasName ( )

◆ GetPID()

int JY9515CoreOO::JY9515DeviceInfo::GetPID ( )

◆ GetSlotNum()

int JY9515CoreOO::JY9515DeviceInfo::GetSlotNum ( )

◆ GetSN()

std::string JY9515CoreOO::JY9515DeviceInfo::GetSN ( )

Member Data Documentation

◆ FirmwareVersion

JY9515CoreOOProperty<JY9515DeviceInfo, std::string, JY9515CoreOOPropertyType::READ_ONLY> JY9515CoreOO::JY9515DeviceInfo::FirmwareVersion

◆ FirmwareVersionInt

JY9515CoreOOProperty<JY9515DeviceInfo, int, JY9515CoreOOPropertyType::READ_ONLY> JY9515CoreOO::JY9515DeviceInfo::FirmwareVersionInt

◆ HardwareVersion

JY9515CoreOOProperty<JY9515DeviceInfo, int, JY9515CoreOOPropertyType::READ_ONLY> JY9515CoreOO::JY9515DeviceInfo::HardwareVersion

◆ IEPEAvailable

JY9515CoreOOProperty<JY9515DeviceInfo, bool, JY9515CoreOOPropertyType::READ_ONLY> JY9515CoreOO::JY9515DeviceInfo::IEPEAvailable

◆ IsPXIeDevice

JY9515CoreOOProperty<JY9515DeviceInfo, bool, JY9515CoreOOPropertyType::READ_ONLY> JY9515CoreOO::JY9515DeviceInfo::IsPXIeDevice
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9515/JY9515CoreOODevice.h


9515 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/9515/JY9515CoreOOLog.h File Reference

  • File List
  • File Members
  • COO
  • 9515
Classes | Namespaces | Enumerations
JY9515CoreOOLog.h File Reference
#include <queue>
#include <thread>
#include "JY9515CoreOOCommon.h"

Classes

class JY9515CoreOO::JY9515CoreOOLog

Namespaces

namespace JY9515CoreOO

Enumerations

enum class JY9515CoreOO::JY9515CoreOOLogLevel {
JY9515CoreOO::DEBUG_LOG_LEVEL , JY9515CoreOO::INFO_LOG_LEVEL , JY9515CoreOO::WARN_LOG_LEVEL , JY9515CoreOO::ERROR_LOG_LEVEL ,
JY9515CoreOO::FATAL_LOG_LEVEL
}


9515 C++ Programming Manual: JY9515CoreOO::JY9515CoreOOLog Class Reference

  • JY9515CoreOOLog
Static Public Member Functions | Static Public Attributes | List of all members
JY9515CoreOO::JY9515CoreOOLog Class Reference

#include <JY9515CoreOOLog.h>

Static Public Member Functions

static void | Print (const char *format,...)
static void | Print (JY9515CoreOOLogLevel logLevel, const char *format,...)
static void | Flush ()

Static Public Attributes

static JY9515CoreOOLogLevel | LogLevel
static JY9515CoreOOProperty< JY9515CoreOOLog, bool, JY9515CoreOOPropertyType::READ_WRITE > | EnableLog

Member Function Documentation

◆ Flush()

static void JY9515CoreOO::JY9515CoreOOLog::Flush ( )
static

◆ Print() [1/2]

static void JY9515CoreOO::JY9515CoreOOLog::Print | ( | const char * | format,
 |  |  | ... )
 static

◆ Print() [2/2]

static void JY9515CoreOO::JY9515CoreOOLog::Print | ( | JY9515CoreOOLogLevel | logLevel,
 |  | const char * | format,
 |  |  | ... )
 static

Member Data Documentation

◆ EnableLog

JY9515CoreOOProperty<JY9515CoreOOLog, bool, JY9515CoreOOPropertyType::READ_WRITE> JY9515CoreOO::JY9515CoreOOLog::EnableLog
static

◆ LogLevel

JY9515CoreOOLogLevel JY9515CoreOO::JY9515CoreOOLog::LogLevel
static
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9515/JY9515CoreOOLog.h


9515 C++ Programming Manual: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
▼N JY9515CoreOO |
C AIAnalogEdgeComparator | AI Analog Edge Comparator
C AIAnalogHysteresisComparator | AI Analog Hysteresis Comparator
C AIAnalogTrigger | AI Analog Trigger
C AIAnalogWindowComparator | AI Analog Window Comparator
C AIChannel | AI Channel
C AIDigitalFiltering | AI Digital Filtering Connfiguration Class
C AIDigitalTrigger | AI Digital trigger params
C AISignalExport | AI Signal Export Class
C AISync |
C AITrigger |
C ConversionStatus | Get ADC conversion status on all enabled channels
C DeviceStatus | Device Status
C ExternalReferenceClock | External Reference Clcok Terminal
C FirmDriveInfo |
C FlatnessCompensation | Flatness Compensation Parameters
C HighPassFilter | High-Pass Filter Configuration Class
C JY9515CoreOOAITask | AiTask类
C JY9515CoreOODevice | JY9515CoreOO Device
C JY9515CoreOOLog |
C JY9515CoreOOProperty | 属性模板类
C JY9515CoreOOReferenceClock |
C JY9515DAC | JY9515 DAC Configuration
C JY9515DeviceInfo | Device Info
C JYDriverException |
C LowPassFilter |
C PauseTrigger | Pause trigger configuration class
C SampleInfo | Sampling information
C JY9515CoreOOAIMode | AIMode


9515 C++ Programming Manual: Member List

  • AIAnalogEdgeComparator
JY9515CoreOO::AIAnalogEdgeComparator Member List

This is the complete list of members for JY9515CoreOO::AIAnalogEdgeComparator, including all inherited members.

Slope | JY9515CoreOO::AIAnalogEdgeComparator
Threshold | JY9515CoreOO::AIAnalogEdgeComparator


9515 C++ Programming Manual: Member List

  • AIAnalogHysteresisComparator
JY9515CoreOO::AIAnalogHysteresisComparator Member List

This is the complete list of members for JY9515CoreOO::AIAnalogHysteresisComparator, including all inherited members.

HighThreshold | JY9515CoreOO::AIAnalogHysteresisComparator
LowThreshold | JY9515CoreOO::AIAnalogHysteresisComparator
Slope | JY9515CoreOO::AIAnalogHysteresisComparator


9515 C++ Programming Manual: Member List

  • AIAnalogTrigger
JY9515CoreOO::AIAnalogTrigger Member List

This is the complete list of members for JY9515CoreOO::AIAnalogTrigger, including all inherited members.

AIAnalogTrigger() | JY9515CoreOO::AIAnalogTrigger
AIAnalogTrigger(AIAnalogTriggerSource src, AIAnalogTriggerComparator comparator) | JY9515CoreOO::AIAnalogTrigger
Commit(void *deviceHandle) | JY9515CoreOO::AIAnalogTrigger
Comparator | JY9515CoreOO::AIAnalogTrigger
Edge | JY9515CoreOO::AIAnalogTrigger
Hysteresis | JY9515CoreOO::AIAnalogTrigger
Source | JY9515CoreOO::AIAnalogTrigger
Window | JY9515CoreOO::AIAnalogTrigger
~AIAnalogTrigger() | JY9515CoreOO::AIAnalogTrigger


9515 C++ Programming Manual: Member List

  • AIAnalogWindowComparator
JY9515CoreOO::AIAnalogWindowComparator Member List

This is the complete list of members for JY9515CoreOO::AIAnalogWindowComparator, including all inherited members.

Condition | JY9515CoreOO::AIAnalogWindowComparator
HighThreshold | JY9515CoreOO::AIAnalogWindowComparator
LowThreshold | JY9515CoreOO::AIAnalogWindowComparator


9515 C++ Programming Manual: Member List

  • AIChannel
JY9515CoreOO::AIChannel Member List

This is the complete list of members for JY9515CoreOO::AIChannel, including all inherited members.

AIChannel(int channelId, double rangeLow, double rangeHigh, Coupling _coupling, bool IEPEenabled) | JY9515CoreOO::AIChannel
AIChannel(int channelId, AIRange range, Coupling _coupling, bool IEPEenabled) | JY9515CoreOO::AIChannel
ChannelID | JY9515CoreOO::AIChannel
coupling | JY9515CoreOO::AIChannel
IEPEEnabled | JY9515CoreOO::AIChannel
Range | JY9515CoreOO::AIChannel
RangeHigh | JY9515CoreOO::AIChannel
RangeLow | JY9515CoreOO::AIChannel
RawDataScaleFactor | JY9515CoreOO::AIChannel


9515 C++ Programming Manual: Member List

  • AIDigitalFiltering
JY9515CoreOO::AIDigitalFiltering Member List

This is the complete list of members for JY9515CoreOO::AIDigitalFiltering, including all inherited members.

AIDigitalFiltering() | JY9515CoreOO::AIDigitalFiltering
Flatnesscompensation | JY9515CoreOO::AIDigitalFiltering
HPF | JY9515CoreOO::AIDigitalFiltering
LPF | JY9515CoreOO::AIDigitalFiltering
ModulatorChoppingFrequency | JY9515CoreOO::AIDigitalFiltering
~AIDigitalFiltering() | JY9515CoreOO::AIDigitalFiltering


9515 C++ Programming Manual: Member List

  • AIDigitalTrigger
JY9515CoreOO::AIDigitalTrigger Member List

This is the complete list of members for JY9515CoreOO::AIDigitalTrigger, including all inherited members.

Edge | JY9515CoreOO::AIDigitalTrigger
Source | JY9515CoreOO::AIDigitalTrigger


9515 C++ Programming Manual: Member List

  • AISignalExport
JY9515CoreOO::AISignalExport Member List

This is the complete list of members for JY9515CoreOO::AISignalExport, including all inherited members.

Add(AISignalExportSource source, SignalExportDestination destination) | JY9515CoreOO::AISignalExport
Add(AISignalExportSource source, std::list< SignalExportDestination > destinations) | JY9515CoreOO::AISignalExport
Clear(SignalExportDestination destination) | JY9515CoreOO::AISignalExport
ClearAll() | JY9515CoreOO::AISignalExport


9515 C++ Programming Manual: Member List

  • AISync
JY9515CoreOO::AISync Member List

This is the complete list of members for JY9515CoreOO::AISync, including all inherited members.

State | JY9515CoreOO::AISync
Terminal | JY9515CoreOO::AISync
Topology | JY9515CoreOO::AISync


9515 C++ Programming Manual: Member List

  • AITrigger
JY9515CoreOO::AITrigger Member List

This is the complete list of members for JY9515CoreOO::AITrigger, including all inherited members.

Analog | JY9515CoreOO::AITrigger
Digital | JY9515CoreOO::AITrigger
Mode | JY9515CoreOO::AITrigger
PreTriggerSamples | JY9515CoreOO::AITrigger
ReTriggerCount | JY9515CoreOO::AITrigger
Type | JY9515CoreOO::AITrigger


9515 C++ Programming Manual: Member List

  • ConversionStatus
JY9515CoreOO::ConversionStatus Member List

This is the complete list of members for JY9515CoreOO::ConversionStatus, including all inherited members.

ChannelID | JY9515CoreOO::ConversionStatus |
ConversionStatus(int header) | JY9515CoreOO::ConversionStatus |
CRCError | JY9515CoreOO::ConversionStatus |
ErrorFlagged | JY9515CoreOO::ConversionStatus |
FilterSuturated | JY9515CoreOO::ConversionStatus |
Update(int header) | JY9515CoreOO::ConversionStatus | inline


9515 C++ Programming Manual: Member List

  • DeviceStatus
JY9515CoreOO::DeviceStatus Member List

This is the complete list of members for JY9515CoreOO::DeviceStatus, including all inherited members.

DeviceStatus(void *deviceHandle) | JY9515CoreOO::DeviceStatus
Temperature | JY9515CoreOO::DeviceStatus
~DeviceStatus() | JY9515CoreOO::DeviceStatus


9515 C++ Programming Manual: Member List

  • ExternalReferenceClock
JY9515CoreOO::ExternalReferenceClock Member List

This is the complete list of members for JY9515CoreOO::ExternalReferenceClock, including all inherited members.

Frequency | JY9515CoreOO::ExternalReferenceClock
Terminal | JY9515CoreOO::ExternalReferenceClock


9515 C++ Programming Manual: Member List

  • FlatnessCompensation
JY9515CoreOO::FlatnessCompensation Member List

This is the complete list of members for JY9515CoreOO::FlatnessCompensation, including all inherited members.

Enabled | JY9515CoreOO::FlatnessCompensation
FlatnessCompensation() | JY9515CoreOO::FlatnessCompensation


9515 C++ Programming Manual: Member List

  • HighPassFilter
JY9515CoreOO::HighPassFilter Member List

This is the complete list of members for JY9515CoreOO::HighPassFilter, including all inherited members.

ChannelEnableMask | JY9515CoreOO::HighPassFilter
CutoffFrequency | JY9515CoreOO::HighPassFilter
DisableChannel(int chID) | JY9515CoreOO::HighPassFilter
EnableChannel(int chID) | JY9515CoreOO::HighPassFilter
HighPassFilter() | JY9515CoreOO::HighPassFilter
Order | JY9515CoreOO::HighPassFilter


9515 C++ Programming Manual: Member List

  • JY9515CoreOOAITask
JY9515CoreOO::JY9515CoreOOAITask Member List

This is the complete list of members for JY9515CoreOO::JY9515CoreOOAITask, including all inherited members.

AddChannel(int chID, double rangeLow, double rangeHigh, Coupling coupling, bool enableIEPESS) | JY9515CoreOO::JY9515CoreOOAITask
AddChannel(int chID, AIRange range, Coupling coupling, bool enableIEPE) | JY9515CoreOO::JY9515CoreOOAITask
AddChannel(std::vector< int > chnsId, double rangeLow, double rangeHigh, Coupling coupling, bool enableIEPE) | JY9515CoreOO::JY9515CoreOOAITask
AddChannel(std::vector< int > chnsId, std::vector< double > rangeLow, std::vector< double > rangeHigh, std::vector< Coupling >_coupling, std::vector< bool > enableIEPE) | JY9515CoreOO::JY9515CoreOOAITask
AddChannel(std::vector< int > chnsId, AIRange range, Coupling coupling, bool enableIEPE) | JY9515CoreOO::JY9515CoreOOAITask
AddChannel(std::vector< int > chnsId, std::vector< AIRange > range, std::vector< Coupling >_coupling, std::vector< bool > enableIEPE) | JY9515CoreOO::JY9515CoreOOAITask
AvailableSamples | JY9515CoreOO::JY9515CoreOOAITask
BufLenInSamples | JY9515CoreOO::JY9515CoreOOAITask
Channels | JY9515CoreOO::JY9515CoreOOAITask
DAC | JY9515CoreOO::JY9515CoreOOAITask
Device | JY9515CoreOO::JY9515CoreOOAITask
DigitalFiltering | JY9515CoreOO::JY9515CoreOOAITask
DisableCalibration | JY9515CoreOO::JY9515CoreOOAITask
DisableDigitalTriggerDelay | JY9515CoreOO::JY9515CoreOOAITask
GetConversionStatus() | JY9515CoreOO::JY9515CoreOOAITask
JY9515CoreOOAITask(int slotNum) | JY9515CoreOO::JY9515CoreOOAITask
JY9515CoreOOAITask(std::string boardName) | JY9515CoreOO::JY9515CoreOOAITask
Mode | JY9515CoreOO::JY9515CoreOOAITask
ReadData(double *pBuf, int samplesPerChannel, int timeout=-1) | JY9515CoreOO::JY9515CoreOOAITask
ReadRawData(int *pBuf, int samplesPerChannel, int timeout=-1) | JY9515CoreOO::JY9515CoreOOAITask
ReadSinglePoint(double &readValue, int channel) | JY9515CoreOO::JY9515CoreOOAITask
ReadSinglePoint(std::vector< double > &readValues) | JY9515CoreOO::JY9515CoreOOAITask
RemoveChannel(int chnId) | JY9515CoreOO::JY9515CoreOOAITask
RemoveChannel(std::vector< int > chnsId) | JY9515CoreOO::JY9515CoreOOAITask
Sample_Info | JY9515CoreOO::JY9515CoreOOAITask
SampleRate | JY9515CoreOO::JY9515CoreOOAITask
SamplesToAcquire | JY9515CoreOO::JY9515CoreOOAITask
SendSoftwareTrigger() | JY9515CoreOO::JY9515CoreOOAITask
SignalExport | JY9515CoreOO::JY9515CoreOOAITask
Start() | JY9515CoreOO::JY9515CoreOOAITask
Stop() | JY9515CoreOO::JY9515CoreOOAITask
Sync | JY9515CoreOO::JY9515CoreOOAITask
TransferedSamples | JY9515CoreOO::JY9515CoreOOAITask
Trigger | JY9515CoreOO::JY9515CoreOOAITask
~JY9515CoreOOAITask() | JY9515CoreOO::JY9515CoreOOAITask


9515 C++ Programming Manual: Member List

  • JY9515CoreOODevice
JY9515CoreOO::JY9515CoreOODevice Member List

This is the complete list of members for JY9515CoreOO::JY9515CoreOODevice, including all inherited members.

AIBufferSize | JY9515CoreOO::JY9515CoreOODevice |
BoardClockRate | JY9515CoreOO::JY9515CoreOODevice |
DeviceID | JY9515CoreOO::JY9515CoreOODevice |
GetInstance(int cardNum) | JY9515CoreOO::JY9515CoreOODevice | static
GetInstance(std::string aliasName) | JY9515CoreOO::JY9515CoreOODevice | static
HighPassFilter | JY9515CoreOO::JY9515CoreOODevice |
Info | JY9515CoreOO::JY9515CoreOODevice |
JY9515PID | JY9515CoreOO::JY9515CoreOODevice |
MaxInputVoltage | JY9515CoreOO::JY9515CoreOODevice |
MaxSampleRate | JY9515CoreOO::JY9515CoreOODevice |
MinSampleRate | JY9515CoreOO::JY9515CoreOODevice |
ParseSampleRate(double sampleRate, LPFMode filterMode) | JY9515CoreOO::JY9515CoreOODevice | static
ReferenceClock | JY9515CoreOO::JY9515CoreOODevice |
Status | JY9515CoreOO::JY9515CoreOODevice |
TotalNumberOfChannels | JY9515CoreOO::JY9515CoreOODevice |


9515 C++ Programming Manual: Member List

  • JY9515CoreOOLog
JY9515CoreOO::JY9515CoreOOLog Member List

This is the complete list of members for JY9515CoreOO::JY9515CoreOOLog, including all inherited members.

EnableLog | JY9515CoreOO::JY9515CoreOOLog | static
Flush() | JY9515CoreOO::JY9515CoreOOLog | static
LogLevel | JY9515CoreOO::JY9515CoreOOLog | static
Print(const char *format,...) | JY9515CoreOO::JY9515CoreOOLog | static
Print(JY9515CoreOOLogLevel logLevel, const char *format,...) | JY9515CoreOO::JY9515CoreOOLog | static


9515 C++ Programming Manual: Member List

  • JY9515CoreOOProperty
JY9515CoreOO::JY9515CoreOOProperty< ContainerClass, ValueType, propertyType > Member List

This is the complete list of members for JY9515CoreOO::JY9515CoreOOProperty< ContainerClass, ValueType, propertyType >, including all inherited members.

JY9515CoreOOProperty() | JY9515CoreOO::JY9515CoreOOProperty< ContainerClass, ValueType, propertyType >
JY9515CoreOOProperty(ContainerClass *cObject, ValueType(ContainerClass::*pGet)(), void(ContainerClass::*pSet)(ValueType value)) | JY9515CoreOO::JY9515CoreOOProperty< ContainerClass, ValueType, propertyType >
JY9515CoreOOProperty(ValueType(*pGet)(), void(*pSet)(ValueType value)) | JY9515CoreOO::JY9515CoreOOProperty< ContainerClass, ValueType, propertyType >
operator ValueType() | JY9515CoreOO::JY9515CoreOOProperty< ContainerClass, ValueType, propertyType >
operator=(const ValueType &value) | JY9515CoreOO::JY9515CoreOOProperty< ContainerClass, ValueType, propertyType >


9515 C++ Programming Manual: Member List

  • JY9515CoreOOReferenceClock
JY9515CoreOO::JY9515CoreOOReferenceClock Member List

This is the complete list of members for JY9515CoreOO::JY9515CoreOOReferenceClock, including all inherited members.

External | JY9515CoreOO::JY9515CoreOOReferenceClock
SelectedReferenceClock | JY9515CoreOO::JY9515CoreOOReferenceClock
Source | JY9515CoreOO::JY9515CoreOOReferenceClock


9515 C++ Programming Manual: Member List

  • JY9515DAC
JY9515CoreOO::JY9515DAC Member List

This is the complete list of members for JY9515CoreOO::JY9515DAC, including all inherited members.

Enabled | JY9515CoreOO::JY9515DAC
IssueTemperatureRecalibration(int timeout=5000) | JY9515CoreOO::JY9515DAC
JY9515DAC(void *deviceHandle) | JY9515CoreOO::JY9515DAC
OutputChannel | JY9515CoreOO::JY9515DAC
OutputVoltage | JY9515CoreOO::JY9515DAC
~JY9515DAC() | JY9515CoreOO::JY9515DAC


9515 C++ Programming Manual: Member List

  • JY9515DeviceInfo
JY9515CoreOO::JY9515DeviceInfo Member List

This is the complete list of members for JY9515CoreOO::JY9515DeviceInfo, including all inherited members.

FirmwareVersion | JY9515CoreOO::JY9515DeviceInfo
FirmwareVersionInt | JY9515CoreOO::JY9515DeviceInfo
GetAliasName() | JY9515CoreOO::JY9515DeviceInfo
GetPID() | JY9515CoreOO::JY9515DeviceInfo
GetSlotNum() | JY9515CoreOO::JY9515DeviceInfo
GetSN() | JY9515CoreOO::JY9515DeviceInfo
HardwareVersion | JY9515CoreOO::JY9515DeviceInfo
IEPEAvailable | JY9515CoreOO::JY9515DeviceInfo
IsPXIeDevice | JY9515CoreOO::JY9515DeviceInfo
JY9515DeviceInfo() | JY9515CoreOO::JY9515DeviceInfo
JY9515DeviceInfo(void *deviceHandle) | JY9515CoreOO::JY9515DeviceInfo
JY9515DeviceInfo(FirmDriveInfo info) | JY9515CoreOO::JY9515DeviceInfo


9515 C++ Programming Manual: Member List

  • JYDriverException
JY9515CoreOO::JYDriverException Member List

This is the complete list of members for JY9515CoreOO::JYDriverException, including all inherited members.

errorCode | JY9515CoreOO::JYDriverException
exceptionMessage | JY9515CoreOO::JYDriverException
FollowingException | JY9515CoreOO::JYDriverException
JYDriverException(JYDriverExceptionPublic exceptionCode, std::string msg="") | JY9515CoreOO::JYDriverException
JYDriverException(int, std::string msg) | JY9515CoreOO::JYDriverException


9515 C++ Programming Manual: Member List

  • LowPassFilter
JY9515CoreOO::LowPassFilter Member List

This is the complete list of members for JY9515CoreOO::LowPassFilter, including all inherited members.

LowPassFilter() | JY9515CoreOO::LowPassFilter
Mode | JY9515CoreOO::LowPassFilter


9515 C++ Programming Manual: Member List

  • PauseTrigger
JY9515CoreOO::PauseTrigger Member List

This is the complete list of members for JY9515CoreOO::PauseTrigger, including all inherited members.

ActivePolarity | JY9515CoreOO::PauseTrigger
Terminal | JY9515CoreOO::PauseTrigger


9515 C++ Programming Manual: Member List

  • SampleInfo
JY9515CoreOO::SampleInfo Member List

This is the complete list of members for JY9515CoreOO::SampleInfo, including all inherited members.

FMod | JY9515CoreOO::SampleInfo
GroupDelay | JY9515CoreOO::SampleInfo
SampleInfo(double sampleRate, LPFMode filterMode, double mclk, double fmod, double dclk, int adcDec, int fpgaDec, ADCFilterType adcFilterType, bool fpgaSinc5Enabled, double groupDelay) | JY9515CoreOO::SampleInfo


9515 C++ Programming Manual: JY9515CoreOOAIMode Class Reference

JY9515CoreOOAIMode Class Reference

AIMode. More...

#include <JY9515CoreOOAITask.h>

Detailed Description

AIMode.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9515/JY9515CoreOOAITask.h


9515 C++ Programming Manual: Class Index

Class Index
A | C | D | E | F | H | J | L | P | S
A
AIAnalogEdgeComparator (JY9515CoreOO)
AIAnalogHysteresisComparator (JY9515CoreOO)
AIAnalogTrigger (JY9515CoreOO)
AIAnalogWindowComparator (JY9515CoreOO)
AIChannel (JY9515CoreOO)
AIDigitalFiltering (JY9515CoreOO)
AIDigitalTrigger (JY9515CoreOO)
AISignalExport (JY9515CoreOO)
AISync (JY9515CoreOO)
AITrigger (JY9515CoreOO)
C
ConversionStatus (JY9515CoreOO)
D
DeviceStatus (JY9515CoreOO)
E
ExternalReferenceClock (JY9515CoreOO)
F
FirmDriveInfo (JY9515CoreOO)
FlatnessCompensation (JY9515CoreOO)
H
HighPassFilter (JY9515CoreOO)
J
JY9515CoreOOAIMode
JY9515CoreOOAITask (JY9515CoreOO)
JY9515CoreOODevice (JY9515CoreOO)
JY9515CoreOOLog (JY9515CoreOO)
JY9515CoreOOProperty (JY9515CoreOO)
JY9515CoreOOReferenceClock (JY9515CoreOO)
JY9515DAC (JY9515CoreOO)
JY9515DeviceInfo (JY9515CoreOO)
JYDriverException (JY9515CoreOO)
L
LowPassFilter (JY9515CoreOO)
P
PauseTrigger (JY9515CoreOO)
S
SampleInfo (JY9515CoreOO)


9515 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO Directory Reference

  • File List
  • File Members
  • COO
COO Directory Reference

Directories

9515


9515 C++ Programming Manual: File List

  • File List
  • File Members
File List
Here is a list of all files with brief descriptions:
[detail level 123]
▼ COO
▼ 9515
JY9515CoreOOAITask.h
JY9515CoreOOCommon.h
JY9515CoreOODevice.h
JY9515CoreOOLog.h


9515 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- a -

  • ActivePolarity : JY9515CoreOO::PauseTrigger
  • Add() : JY9515CoreOO::AISignalExport
  • AddChannel() : JY9515CoreOO::JY9515CoreOOAITask
  • AIAnalogTrigger() : JY9515CoreOO::AIAnalogTrigger
  • AIBufferSize : JY9515CoreOO::JY9515CoreOODevice
  • AIChannel() : JY9515CoreOO::AIChannel
  • AIDigitalFiltering() : JY9515CoreOO::AIDigitalFiltering
  • aliasName : JY9515CoreOO::FirmDriveInfo
  • Analog : JY9515CoreOO::AITrigger
  • AvailableSamples : JY9515CoreOO::JY9515CoreOOAITask

- b -

  • BoardClockRate : JY9515CoreOO::JY9515CoreOODevice
  • BufLenInSamples : JY9515CoreOO::JY9515CoreOOAITask

- c -

  • cardNumber : JY9515CoreOO::FirmDriveInfo
  • ChannelEnableMask : JY9515CoreOO::HighPassFilter
  • ChannelID : JY9515CoreOO::AIChannel, JY9515CoreOO::ConversionStatus
  • Channels : JY9515CoreOO::JY9515CoreOOAITask
  • Clear() : JY9515CoreOO::AISignalExport
  • ClearAll() : JY9515CoreOO::AISignalExport
  • Commit() : JY9515CoreOO::AIAnalogTrigger
  • Comparator : JY9515CoreOO::AIAnalogTrigger
  • Condition : JY9515CoreOO::AIAnalogWindowComparator
  • connected : JY9515CoreOO::FirmDriveInfo
  • ConversionStatus() : JY9515CoreOO::ConversionStatus
  • coupling : JY9515CoreOO::AIChannel
  • CRCError : JY9515CoreOO::ConversionStatus
  • CutoffFrequency : JY9515CoreOO::HighPassFilter

- d -

  • DAC : JY9515CoreOO::JY9515CoreOOAITask
  • Device : JY9515CoreOO::JY9515CoreOOAITask
  • DeviceID : JY9515CoreOO::JY9515CoreOODevice
  • DeviceStatus() : JY9515CoreOO::DeviceStatus
  • Digital : JY9515CoreOO::AITrigger
  • DigitalFiltering : JY9515CoreOO::JY9515CoreOOAITask
  • DisableCalibration : JY9515CoreOO::JY9515CoreOOAITask
  • DisableChannel() : JY9515CoreOO::HighPassFilter
  • DisableDigitalTriggerDelay : JY9515CoreOO::JY9515CoreOOAITask
  • DriverSetVer : JY9515CoreOO::FirmDriveInfo

- e -

  • Edge : JY9515CoreOO::AIAnalogTrigger, JY9515CoreOO::AIDigitalTrigger
  • EnableChannel() : JY9515CoreOO::HighPassFilter
  • Enabled : JY9515CoreOO::FlatnessCompensation, JY9515CoreOO::JY9515DAC
  • EnableLog : JY9515CoreOO::JY9515CoreOOLog
  • errorCode : JY9515CoreOO::JYDriverException
  • ErrorFlagged : JY9515CoreOO::ConversionStatus
  • exceptionMessage : JY9515CoreOO::JYDriverException
  • External : JY9515CoreOO::JY9515CoreOOReferenceClock

- f -

  • FilterSuturated : JY9515CoreOO::ConversionStatus
  • FirmwareVer : JY9515CoreOO::FirmDriveInfo
  • FirmwareVersion : JY9515CoreOO::JY9515DeviceInfo
  • FirmwareVersionInt : JY9515CoreOO::JY9515DeviceInfo
  • FlatnessCompensation() : JY9515CoreOO::FlatnessCompensation
  • Flatnesscompensation : JY9515CoreOO::AIDigitalFiltering
  • Flush() : JY9515CoreOO::JY9515CoreOOLog
  • FMod : JY9515CoreOO::SampleInfo
  • FollowingException : JY9515CoreOO::JYDriverException
  • FrameworkVer : JY9515CoreOO::FirmDriveInfo
  • Frequency : JY9515CoreOO::ExternalReferenceClock
  • fStreaming : JY9515CoreOO::FirmDriveInfo

- g -

  • GetAliasName() : JY9515CoreOO::JY9515DeviceInfo
  • GetConversionStatus() : JY9515CoreOO::JY9515CoreOOAITask
  • GetInstance() : JY9515CoreOO::JY9515CoreOODevice
  • GetPID() : JY9515CoreOO::JY9515DeviceInfo
  • GetSlotNum() : JY9515CoreOO::JY9515DeviceInfo
  • GetSN() : JY9515CoreOO::JY9515DeviceInfo
  • GroupDelay : JY9515CoreOO::SampleInfo

- h -

  • HardwareVer : JY9515CoreOO::FirmDriveInfo
  • HardwareVersion : JY9515CoreOO::JY9515DeviceInfo
  • HighPassFilter() : JY9515CoreOO::HighPassFilter, JY9515CoreOO::JY9515CoreOODevice
  • HighThreshold : JY9515CoreOO::AIAnalogHysteresisComparator, JY9515CoreOO::AIAnalogWindowComparator
  • HPF : JY9515CoreOO::AIDigitalFiltering
  • Hysteresis : JY9515CoreOO::AIAnalogTrigger

- i -

  • IEPEAvailable : JY9515CoreOO::JY9515DeviceInfo
  • IEPEEnabled : JY9515CoreOO::AIChannel
  • Info : JY9515CoreOO::JY9515CoreOODevice
  • IsPXIeDevice : JY9515CoreOO::JY9515DeviceInfo
  • IssueTemperatureRecalibration() : JY9515CoreOO::JY9515DAC

- j -

  • JY9515CoreOOAITask() : JY9515CoreOO::JY9515CoreOOAITask
  • JY9515CoreOOProperty() : JY9515CoreOO::JY9515CoreOOProperty< ContainerClass, ValueType, propertyType >
  • JY9515DAC() : JY9515CoreOO::JY9515DAC
  • JY9515DeviceInfo() : JY9515CoreOO::JY9515DeviceInfo
  • JY9515PID : JY9515CoreOO::JY9515CoreOODevice
  • JYDriverException() : JY9515CoreOO::JYDriverException

- l -

  • LogLevel : JY9515CoreOO::JY9515CoreOOLog
  • LowPassFilter() : JY9515CoreOO::LowPassFilter
  • LowThreshold : JY9515CoreOO::AIAnalogHysteresisComparator, JY9515CoreOO::AIAnalogWindowComparator
  • LPF : JY9515CoreOO::AIDigitalFiltering

- m -

  • MaxInputVoltage : JY9515CoreOO::JY9515CoreOODevice
  • MaxSampleRate : JY9515CoreOO::JY9515CoreOODevice
  • MinSampleRate : JY9515CoreOO::JY9515CoreOODevice
  • Mode : JY9515CoreOO::AITrigger, JY9515CoreOO::JY9515CoreOOAITask, JY9515CoreOO::LowPassFilter
  • model : JY9515CoreOO::FirmDriveInfo
  • ModulatorChoppingFrequency : JY9515CoreOO::AIDigitalFiltering

- o -

  • operator ValueType() : JY9515CoreOO::JY9515CoreOOProperty< ContainerClass, ValueType, propertyType >
  • operator=() : JY9515CoreOO::JY9515CoreOOProperty< ContainerClass, ValueType, propertyType >
  • Order : JY9515CoreOO::HighPassFilter
  • OutputChannel : JY9515CoreOO::JY9515DAC
  • OutputVoltage : JY9515CoreOO::JY9515DAC

- p -

  • ParseSampleRate() : JY9515CoreOO::JY9515CoreOODevice
  • PID : JY9515CoreOO::FirmDriveInfo
  • PlatformType : JY9515CoreOO::FirmDriveInfo
  • PreTriggerSamples : JY9515CoreOO::AITrigger
  • Print() : JY9515CoreOO::JY9515CoreOOLog
  • ProductionDate : JY9515CoreOO::FirmDriveInfo

- r -

  • Range : JY9515CoreOO::AIChannel
  • RangeHigh : JY9515CoreOO::AIChannel
  • RangeLow : JY9515CoreOO::AIChannel
  • RawDataScaleFactor : JY9515CoreOO::AIChannel
  • ReadData() : JY9515CoreOO::JY9515CoreOOAITask
  • ReadRawData() : JY9515CoreOO::JY9515CoreOOAITask
  • ReadSinglePoint() : JY9515CoreOO::JY9515CoreOOAITask
  • ReferenceClock : JY9515CoreOO::JY9515CoreOODevice
  • RemoveChannel() : JY9515CoreOO::JY9515CoreOOAITask
  • ReTriggerCount : JY9515CoreOO::AITrigger

- s -

  • Sample_Info : JY9515CoreOO::JY9515CoreOOAITask
  • SampleInfo() : JY9515CoreOO::SampleInfo
  • SampleRate : JY9515CoreOO::JY9515CoreOOAITask
  • SamplesToAcquire : JY9515CoreOO::JY9515CoreOOAITask
  • SelectedReferenceClock : JY9515CoreOO::JY9515CoreOOReferenceClock
  • SendSoftwareTrigger() : JY9515CoreOO::JY9515CoreOOAITask
  • serialNumber : JY9515CoreOO::FirmDriveInfo
  • SignalExport : JY9515CoreOO::JY9515CoreOOAITask
  • Slope : JY9515CoreOO::AIAnalogEdgeComparator, JY9515CoreOO::AIAnalogHysteresisComparator
  • slotNum : JY9515CoreOO::FirmDriveInfo
  • Source : JY9515CoreOO::AIAnalogTrigger, JY9515CoreOO::AIDigitalTrigger, JY9515CoreOO::JY9515CoreOOReferenceClock
  • Start() : JY9515CoreOO::JY9515CoreOOAITask
  • State : JY9515CoreOO::AISync
  • Status : JY9515CoreOO::JY9515CoreOODevice
  • Stop() : JY9515CoreOO::JY9515CoreOOAITask
  • Sync : JY9515CoreOO::JY9515CoreOOAITask

- t -

  • Temperature : JY9515CoreOO::DeviceStatus
  • Terminal : JY9515CoreOO::AISync, JY9515CoreOO::ExternalReferenceClock, JY9515CoreOO::PauseTrigger
  • Threshold : JY9515CoreOO::AIAnalogEdgeComparator
  • Topology : JY9515CoreOO::AISync
  • TotalNumberOfChannels : JY9515CoreOO::JY9515CoreOODevice
  • TransferedSamples : JY9515CoreOO::JY9515CoreOOAITask
  • Trigger : JY9515CoreOO::JY9515CoreOOAITask
  • Type : JY9515CoreOO::AITrigger

- u -

  • Update() : JY9515CoreOO::ConversionStatus

- v -

  • vendorName : JY9515CoreOO::FirmDriveInfo
  • VID : JY9515CoreOO::FirmDriveInfo

- w -

  • Window : JY9515CoreOO::AIAnalogTrigger

- ~ -

  • ~AIAnalogTrigger() : JY9515CoreOO::AIAnalogTrigger
  • ~AIDigitalFiltering() : JY9515CoreOO::AIDigitalFiltering
  • ~DeviceStatus() : JY9515CoreOO::DeviceStatus
  • ~JY9515CoreOOAITask() : JY9515CoreOO::JY9515CoreOOAITask
  • ~JY9515DAC() : JY9515CoreOO::JY9515DAC


9515 C++ Programming Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • o
  • p
  • r
  • s
  • u
  • ~
Here is a list of all functions with links to the classes they belong to:

- a -

  • Add() : JY9515CoreOO::AISignalExport
  • AddChannel() : JY9515CoreOO::JY9515CoreOOAITask
  • AIAnalogTrigger() : JY9515CoreOO::AIAnalogTrigger
  • AIChannel() : JY9515CoreOO::AIChannel
  • AIDigitalFiltering() : JY9515CoreOO::AIDigitalFiltering

- c -

  • Clear() : JY9515CoreOO::AISignalExport
  • ClearAll() : JY9515CoreOO::AISignalExport
  • Commit() : JY9515CoreOO::AIAnalogTrigger
  • ConversionStatus() : JY9515CoreOO::ConversionStatus

- d -

  • DeviceStatus() : JY9515CoreOO::DeviceStatus
  • DisableChannel() : JY9515CoreOO::HighPassFilter

- e -

  • EnableChannel() : JY9515CoreOO::HighPassFilter

- f -

  • FlatnessCompensation() : JY9515CoreOO::FlatnessCompensation
  • Flush() : JY9515CoreOO::JY9515CoreOOLog

- g -

  • GetAliasName() : JY9515CoreOO::JY9515DeviceInfo
  • GetConversionStatus() : JY9515CoreOO::JY9515CoreOOAITask
  • GetInstance() : JY9515CoreOO::JY9515CoreOODevice
  • GetPID() : JY9515CoreOO::JY9515DeviceInfo
  • GetSlotNum() : JY9515CoreOO::JY9515DeviceInfo
  • GetSN() : JY9515CoreOO::JY9515DeviceInfo

- h -

  • HighPassFilter() : JY9515CoreOO::HighPassFilter

- i -

  • IssueTemperatureRecalibration() : JY9515CoreOO::JY9515DAC

- j -

  • JY9515CoreOOAITask() : JY9515CoreOO::JY9515CoreOOAITask
  • JY9515CoreOOProperty() : JY9515CoreOO::JY9515CoreOOProperty< ContainerClass, ValueType, propertyType >
  • JY9515DAC() : JY9515CoreOO::JY9515DAC
  • JY9515DeviceInfo() : JY9515CoreOO::JY9515DeviceInfo
  • JYDriverException() : JY9515CoreOO::JYDriverException

- l -

  • LowPassFilter() : JY9515CoreOO::LowPassFilter

- o -

  • operator ValueType() : JY9515CoreOO::JY9515CoreOOProperty< ContainerClass, ValueType, propertyType >
  • operator=() : JY9515CoreOO::JY9515CoreOOProperty< ContainerClass, ValueType, propertyType >

- p -

  • ParseSampleRate() : JY9515CoreOO::JY9515CoreOODevice
  • Print() : JY9515CoreOO::JY9515CoreOOLog

- r -

  • ReadData() : JY9515CoreOO::JY9515CoreOOAITask
  • ReadRawData() : JY9515CoreOO::JY9515CoreOOAITask
  • ReadSinglePoint() : JY9515CoreOO::JY9515CoreOOAITask
  • RemoveChannel() : JY9515CoreOO::JY9515CoreOOAITask

- s -

  • SampleInfo() : JY9515CoreOO::SampleInfo
  • SendSoftwareTrigger() : JY9515CoreOO::JY9515CoreOOAITask
  • Start() : JY9515CoreOO::JY9515CoreOOAITask
  • Stop() : JY9515CoreOO::JY9515CoreOOAITask

- u -

  • Update() : JY9515CoreOO::ConversionStatus

- ~ -

  • ~AIAnalogTrigger() : JY9515CoreOO::AIAnalogTrigger
  • ~AIDigitalFiltering() : JY9515CoreOO::AIDigitalFiltering
  • ~DeviceStatus() : JY9515CoreOO::DeviceStatus
  • ~JY9515CoreOOAITask() : JY9515CoreOO::JY9515CoreOOAITask
  • ~JY9515DAC() : JY9515CoreOO::JY9515DAC


9515 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • v
  • w
Here is a list of all variables with links to the classes they belong to:

- a -

  • ActivePolarity : JY9515CoreOO::PauseTrigger
  • AIBufferSize : JY9515CoreOO::JY9515CoreOODevice
  • aliasName : JY9515CoreOO::FirmDriveInfo
  • Analog : JY9515CoreOO::AITrigger
  • AvailableSamples : JY9515CoreOO::JY9515CoreOOAITask

- b -

  • BoardClockRate : JY9515CoreOO::JY9515CoreOODevice
  • BufLenInSamples : JY9515CoreOO::JY9515CoreOOAITask

- c -

  • cardNumber : JY9515CoreOO::FirmDriveInfo
  • ChannelEnableMask : JY9515CoreOO::HighPassFilter
  • ChannelID : JY9515CoreOO::AIChannel, JY9515CoreOO::ConversionStatus
  • Channels : JY9515CoreOO::JY9515CoreOOAITask
  • Comparator : JY9515CoreOO::AIAnalogTrigger
  • Condition : JY9515CoreOO::AIAnalogWindowComparator
  • connected : JY9515CoreOO::FirmDriveInfo
  • coupling : JY9515CoreOO::AIChannel
  • CRCError : JY9515CoreOO::ConversionStatus
  • CutoffFrequency : JY9515CoreOO::HighPassFilter

- d -

  • DAC : JY9515CoreOO::JY9515CoreOOAITask
  • Device : JY9515CoreOO::JY9515CoreOOAITask
  • DeviceID : JY9515CoreOO::JY9515CoreOODevice
  • Digital : JY9515CoreOO::AITrigger
  • DigitalFiltering : JY9515CoreOO::JY9515CoreOOAITask
  • DisableCalibration : JY9515CoreOO::JY9515CoreOOAITask
  • DisableDigitalTriggerDelay : JY9515CoreOO::JY9515CoreOOAITask
  • DriverSetVer : JY9515CoreOO::FirmDriveInfo

- e -

  • Edge : JY9515CoreOO::AIAnalogTrigger, JY9515CoreOO::AIDigitalTrigger
  • Enabled : JY9515CoreOO::FlatnessCompensation, JY9515CoreOO::JY9515DAC
  • EnableLog : JY9515CoreOO::JY9515CoreOOLog
  • errorCode : JY9515CoreOO::JYDriverException
  • ErrorFlagged : JY9515CoreOO::ConversionStatus
  • exceptionMessage : JY9515CoreOO::JYDriverException
  • External : JY9515CoreOO::JY9515CoreOOReferenceClock

- f -

  • FilterSuturated : JY9515CoreOO::ConversionStatus
  • FirmwareVer : JY9515CoreOO::FirmDriveInfo
  • FirmwareVersion : JY9515CoreOO::JY9515DeviceInfo
  • FirmwareVersionInt : JY9515CoreOO::JY9515DeviceInfo
  • Flatnesscompensation : JY9515CoreOO::AIDigitalFiltering
  • FMod : JY9515CoreOO::SampleInfo
  • FollowingException : JY9515CoreOO::JYDriverException
  • FrameworkVer : JY9515CoreOO::FirmDriveInfo
  • Frequency : JY9515CoreOO::ExternalReferenceClock
  • fStreaming : JY9515CoreOO::FirmDriveInfo

- g -

  • GroupDelay : JY9515CoreOO::SampleInfo

- h -

  • HardwareVer : JY9515CoreOO::FirmDriveInfo
  • HardwareVersion : JY9515CoreOO::JY9515DeviceInfo
  • HighPassFilter : JY9515CoreOO::JY9515CoreOODevice
  • HighThreshold : JY9515CoreOO::AIAnalogHysteresisComparator, JY9515CoreOO::AIAnalogWindowComparator
  • HPF : JY9515CoreOO::AIDigitalFiltering
  • Hysteresis : JY9515CoreOO::AIAnalogTrigger

- i -

  • IEPEAvailable : JY9515CoreOO::JY9515DeviceInfo
  • IEPEEnabled : JY9515CoreOO::AIChannel
  • Info : JY9515CoreOO::JY9515CoreOODevice
  • IsPXIeDevice : JY9515CoreOO::JY9515DeviceInfo

- j -

  • JY9515PID : JY9515CoreOO::JY9515CoreOODevice

- l -

  • LogLevel : JY9515CoreOO::JY9515CoreOOLog
  • LowThreshold : JY9515CoreOO::AIAnalogHysteresisComparator, JY9515CoreOO::AIAnalogWindowComparator
  • LPF : JY9515CoreOO::AIDigitalFiltering

- m -

  • MaxInputVoltage : JY9515CoreOO::JY9515CoreOODevice
  • MaxSampleRate : JY9515CoreOO::JY9515CoreOODevice
  • MinSampleRate : JY9515CoreOO::JY9515CoreOODevice
  • Mode : JY9515CoreOO::AITrigger, JY9515CoreOO::JY9515CoreOOAITask, JY9515CoreOO::LowPassFilter
  • model : JY9515CoreOO::FirmDriveInfo
  • ModulatorChoppingFrequency : JY9515CoreOO::AIDigitalFiltering

- o -

  • Order : JY9515CoreOO::HighPassFilter
  • OutputChannel : JY9515CoreOO::JY9515DAC
  • OutputVoltage : JY9515CoreOO::JY9515DAC

- p -

  • PID : JY9515CoreOO::FirmDriveInfo
  • PlatformType : JY9515CoreOO::FirmDriveInfo
  • PreTriggerSamples : JY9515CoreOO::AITrigger
  • ProductionDate : JY9515CoreOO::FirmDriveInfo

- r -

  • Range : JY9515CoreOO::AIChannel
  • RangeHigh : JY9515CoreOO::AIChannel
  • RangeLow : JY9515CoreOO::AIChannel
  • RawDataScaleFactor : JY9515CoreOO::AIChannel
  • ReferenceClock : JY9515CoreOO::JY9515CoreOODevice
  • ReTriggerCount : JY9515CoreOO::AITrigger

- s -

  • Sample_Info : JY9515CoreOO::JY9515CoreOOAITask
  • SampleRate : JY9515CoreOO::JY9515CoreOOAITask
  • SamplesToAcquire : JY9515CoreOO::JY9515CoreOOAITask
  • SelectedReferenceClock : JY9515CoreOO::JY9515CoreOOReferenceClock
  • serialNumber : JY9515CoreOO::FirmDriveInfo
  • SignalExport : JY9515CoreOO::JY9515CoreOOAITask
  • Slope : JY9515CoreOO::AIAnalogEdgeComparator, JY9515CoreOO::AIAnalogHysteresisComparator
  • slotNum : JY9515CoreOO::FirmDriveInfo
  • Source : JY9515CoreOO::AIAnalogTrigger, JY9515CoreOO::AIDigitalTrigger, JY9515CoreOO::JY9515CoreOOReferenceClock
  • State : JY9515CoreOO::AISync
  • Status : JY9515CoreOO::JY9515CoreOODevice
  • Sync : JY9515CoreOO::JY9515CoreOOAITask

- t -

  • Temperature : JY9515CoreOO::DeviceStatus
  • Terminal : JY9515CoreOO::AISync, JY9515CoreOO::ExternalReferenceClock, JY9515CoreOO::PauseTrigger
  • Threshold : JY9515CoreOO::AIAnalogEdgeComparator
  • Topology : JY9515CoreOO::AISync
  • TotalNumberOfChannels : JY9515CoreOO::JY9515CoreOODevice
  • TransferedSamples : JY9515CoreOO::JY9515CoreOOAITask
  • Trigger : JY9515CoreOO::JY9515CoreOOAITask
  • Type : JY9515CoreOO::AITrigger

- v -

  • vendorName : JY9515CoreOO::FirmDriveInfo
  • VID : JY9515CoreOO::FirmDriveInfo

- w -

  • Window : JY9515CoreOO::AIAnalogTrigger


9515 C++ Programming Manual: File Members

  • File List
  • File Members
  • All
  • Macros
Here is a list of all file members with links to the files they belong to:
  • _CRT_SECURE_NO_WARNINGS : JY9515CoreOOAITask.h
  • EXTERN_C : JY9515CoreOOCommon.h
  • JY9515CoreOO_API : JY9515CoreOOCommon.h


9515 C++ Programming Manual: File Members

  • File List
  • File Members
  • All
  • Macros
Here is a list of all macros with links to the files they belong to:
  • _CRT_SECURE_NO_WARNINGS : JY9515CoreOOAITask.h
  • EXTERN_C : JY9515CoreOOCommon.h
  • JY9515CoreOO_API : JY9515CoreOOCommon.h


9515 C++ Programming Manual: Main Page

9515 C++ Programming Manual Documentation


9515 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • c
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- a -

  • ADCFilterType : JY9515CoreOO
  • AIAnalogTriggerComparator : JY9515CoreOO
  • AIAnalogTriggerEdge : JY9515CoreOO
  • AIAnalogTriggerSource : JY9515CoreOO
  • AIAnalogWindowCondition : JY9515CoreOO
  • AIDigitalTriggerEdge : JY9515CoreOO
  • AIDigitalTriggerSource : JY9515CoreOO
  • AIMode : JY9515CoreOO
  • AIRagneGrade : JY9515CoreOO
  • AIRange : JY9515CoreOO
  • AIRangeDescriptions : JY9515CoreOO
  • AISignalExportSource : JY9515CoreOO
  • AITriggerMode : JY9515CoreOO
  • AITriggerType : JY9515CoreOO

- c -

  • ChoppingFrequency : JY9515CoreOO
  • Coupling : JY9515CoreOO

- e -

  • Ext_Trig : JY9515CoreOO
  • ExternalReferenceClockTerminal : JY9515CoreOO

- f -

  • fMod32 : JY9515CoreOO
  • fMod8 : JY9515CoreOO

- g -

  • GetSignalExportDestinationString() : JY9515CoreOO

- h -

  • HPFOrder : JY9515CoreOO

- i -

  • IEPEConnectionStatus : JY9515CoreOO
  • Invalid : JY9515CoreOO

- j -

  • JY9515_ADCChopping_fMod32 : JY9515Import
  • JY9515_AI_Continuous : JY9515Import
  • JY9515_AI_Finite : JY9515Import
  • JY9515_AI_Single : JY9515Import
  • JY9515_AnlogTriggerCondition_EnteringWindow : JY9515Import
  • JY9515_AnlogTriggerCondition_FallingHysteresis : JY9515Import
  • JY9515_AnlogTriggerCondition_LeavingWindow : JY9515Import
  • JY9515_AnlogTriggerCondition_RisingHysteresis : JY9515Import
  • JY9515_CalCoePosition_EEPROM : JY9515Import
  • JY9515_CalCoePosition_Handle : JY9515Import
  • JY9515_Coupling_AC : JY9515Import
  • JY9515_Coupling_DC : JY9515Import
  • JY9515_DigitalTriggerEdge_Falling : JY9515Import
  • JY9515_DigitalTriggerEdge_Rising : JY9515Import
  • JY9515_DigitalTriggerSource_BUS_0 : JY9515Import
  • JY9515_DigitalTriggerSource_BUS_1 : JY9515Import
  • JY9515_DigitalTriggerSource_BUS_2 : JY9515Import
  • JY9515_DigitalTriggerSource_BUS_3 : JY9515Import
  • JY9515_DigitalTriggerSource_BUS_4 : JY9515Import
  • JY9515_DigitalTriggerSource_BUS_5 : JY9515Import
  • JY9515_DigitalTriggerSource_BUS_6 : JY9515Import
  • JY9515_DigitalTriggerSource_BUS_7 : JY9515Import
  • JY9515_DigitalTriggerSource_External : JY9515Import
  • JY9515_DigitalTriggerSource_STAR : JY9515Import
  • JY9515_EXPORT_ADC_DRDY : JY9515Import
  • JY9515_EXPORT_ADC_SYNC : JY9515Import
  • JY9515_EXPORT_DCLK : JY9515Import
  • JY9515_EXPORT_MCLK : JY9515Import
  • JY9515_EXPORT_PLL_SYNC : JY9515Import
  • JY9515_EXPORT_RX_ADV_TRIG : JY9515Import
  • JY9515_EXPORT_RX_END_OF_RECORD : JY9515Import
  • JY9515_EXPORT_RX_ENGINE_END : JY9515Import
  • JY9515_EXPORT_RX_READY_FOR_ADV_TRIG : JY9515Import
  • JY9515_EXPORT_RX_READY_FOR_REF_TRIG : JY9515Import
  • JY9515_EXPORT_RX_READY_FOR_START_TRIG : JY9515Import
  • JY9515_EXPORT_RX_REF_TRIG : JY9515Import
  • JY9515_EXPORT_RX_START_TRIG : JY9515Import
  • JY9515_EXPORT_SAMPLE_CLOCK : JY9515Import
  • JY9515_EXPORT_SYNC : JY9515Import
  • JY9515_Onboard_10M : JY9515Import
  • JY9515_PXIe_Clk_100M : JY9515Import
  • JY9515_Range_0p3125V : JY9515Import
  • JY9515_Range_0p625V : JY9515Import
  • JY9515_Range_10V : JY9515Import
  • JY9515_Range_15V : JY9515Import
  • JY9515_Range_1p25V : JY9515Import
  • JY9515_Range_2p5V : JY9515Import
  • JY9515_Range_5V : JY9515Import
  • JY9515_SyncMode_Master : JY9515Import
  • JY9515_SyncMode_Slave : JY9515Import
  • JY9515_SyncMode_Solo : JY9515Import
  • JY9515_TriggerType_Analog : JY9515Import
  • JY9515_TriggerType_Digital : JY9515Import
  • JY9515_TriggerType_Immediately : JY9515Import
  • JY9515_TriggerType_Software : JY9515Import
  • JY9515CoreOOLogLevel : JY9515CoreOO
  • JY9515CoreOOPropertyType : JY9515CoreOO
  • JY9517_ADCChopping_fMod8 : JY9515Import
  • JYDriverExceptionPublic : JY9515CoreOO

- l -

  • LevelPolarity : JY9515CoreOO
  • LPFMode : JY9515CoreOO

- n -

  • Normal : JY9515CoreOO

- o -

  • OneOrder : JY9515CoreOO
  • OutputCompleteState : JY9515CoreOO

- p -

  • PXI_Star : JY9515CoreOO
  • PXI_Trig0 : JY9515CoreOO
  • PXI_Trig1 : JY9515CoreOO
  • PXI_Trig2 : JY9515CoreOO
  • PXI_Trig3 : JY9515CoreOO
  • PXI_Trig4 : JY9515CoreOO
  • PXI_Trig5 : JY9515CoreOO
  • PXI_Trig6 : JY9515CoreOO
  • PXI_Trig7 : JY9515CoreOO

- r -

  • ReferenceClockSource : JY9515CoreOO

- s -

  • SamplingState : JY9515CoreOO
  • SignalExportDestination : JY9515CoreOO
  • Sinc5Filter : JY9515CoreOO, JY9515Import
  • Synchronized : JY9515CoreOO
  • SyncState : JY9515CoreOO
  • SyncTerminal : JY9515CoreOO
  • SyncTopology : JY9515CoreOO

- t -

  • TwoOrder : JY9515CoreOO

- w -

  • WaitingSync : JY9515CoreOO
  • WidebandLowRippleFilter : JY9515CoreOO, JY9515Import
  • WideBandwidth : JY9515CoreOO


9515 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
Here is a list of all namespace enums with links to the namespace documentation for each enum:
  • ADCFilterType : JY9515CoreOO
  • AIAnalogTriggerComparator : JY9515CoreOO
  • AIAnalogTriggerEdge : JY9515CoreOO
  • AIAnalogTriggerSource : JY9515CoreOO
  • AIAnalogWindowCondition : JY9515CoreOO
  • AIDigitalTriggerEdge : JY9515CoreOO
  • AIDigitalTriggerSource : JY9515CoreOO
  • AIMode : JY9515CoreOO
  • AIRange : JY9515CoreOO
  • AISignalExportSource : JY9515CoreOO
  • AITriggerMode : JY9515CoreOO
  • AITriggerType : JY9515CoreOO
  • ChoppingFrequency : JY9515CoreOO
  • Coupling : JY9515CoreOO
  • ExternalReferenceClockTerminal : JY9515CoreOO
  • HPFOrder : JY9515CoreOO
  • IEPEConnectionStatus : JY9515CoreOO
  • JY9515CoreOOLogLevel : JY9515CoreOO
  • JY9515CoreOOPropertyType : JY9515CoreOO
  • JYDriverExceptionPublic : JY9515CoreOO
  • LevelPolarity : JY9515CoreOO
  • LPFMode : JY9515CoreOO
  • OutputCompleteState : JY9515CoreOO
  • ReferenceClockSource : JY9515CoreOO
  • SamplingState : JY9515CoreOO
  • SignalExportDestination : JY9515CoreOO
  • SyncState : JY9515CoreOO
  • SyncTerminal : JY9515CoreOO
  • SyncTopology : JY9515CoreOO


9515 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
Here is a list of all namespace enum values with links to the namespace documentation for each enum value:
  • Ext_Trig : JY9515CoreOO
  • fMod32 : JY9515CoreOO
  • fMod8 : JY9515CoreOO
  • Invalid : JY9515CoreOO
  • Normal : JY9515CoreOO
  • OneOrder : JY9515CoreOO
  • PXI_Star : JY9515CoreOO
  • PXI_Trig0 : JY9515CoreOO
  • PXI_Trig1 : JY9515CoreOO
  • PXI_Trig2 : JY9515CoreOO
  • PXI_Trig3 : JY9515CoreOO
  • PXI_Trig4 : JY9515CoreOO
  • PXI_Trig5 : JY9515CoreOO
  • PXI_Trig6 : JY9515CoreOO
  • PXI_Trig7 : JY9515CoreOO
  • Sinc5Filter : JY9515CoreOO
  • Synchronized : JY9515CoreOO
  • TwoOrder : JY9515CoreOO
  • WaitingSync : JY9515CoreOO
  • WidebandLowRippleFilter : JY9515CoreOO
  • WideBandwidth : JY9515CoreOO


9515 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
Here is a list of all namespace functions with links to the namespace documentation for each function:
  • GetSignalExportDestinationString() : JY9515CoreOO


9515 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • j
  • s
  • w
Here is a list of all namespace variables with links to the namespace documentation for each variable:

- a -

  • AIRagneGrade : JY9515CoreOO
  • AIRangeDescriptions : JY9515CoreOO

- j -

  • JY9515_ADCChopping_fMod32 : JY9515Import
  • JY9515_AI_Continuous : JY9515Import
  • JY9515_AI_Finite : JY9515Import
  • JY9515_AI_Single : JY9515Import
  • JY9515_AnlogTriggerCondition_EnteringWindow : JY9515Import
  • JY9515_AnlogTriggerCondition_FallingHysteresis : JY9515Import
  • JY9515_AnlogTriggerCondition_LeavingWindow : JY9515Import
  • JY9515_AnlogTriggerCondition_RisingHysteresis : JY9515Import
  • JY9515_CalCoePosition_EEPROM : JY9515Import
  • JY9515_CalCoePosition_Handle : JY9515Import
  • JY9515_Coupling_AC : JY9515Import
  • JY9515_Coupling_DC : JY9515Import
  • JY9515_DigitalTriggerEdge_Falling : JY9515Import
  • JY9515_DigitalTriggerEdge_Rising : JY9515Import
  • JY9515_DigitalTriggerSource_BUS_0 : JY9515Import
  • JY9515_DigitalTriggerSource_BUS_1 : JY9515Import
  • JY9515_DigitalTriggerSource_BUS_2 : JY9515Import
  • JY9515_DigitalTriggerSource_BUS_3 : JY9515Import
  • JY9515_DigitalTriggerSource_BUS_4 : JY9515Import
  • JY9515_DigitalTriggerSource_BUS_5 : JY9515Import
  • JY9515_DigitalTriggerSource_BUS_6 : JY9515Import
  • JY9515_DigitalTriggerSource_BUS_7 : JY9515Import
  • JY9515_DigitalTriggerSource_External : JY9515Import
  • JY9515_DigitalTriggerSource_STAR : JY9515Import
  • JY9515_EXPORT_ADC_DRDY : JY9515Import
  • JY9515_EXPORT_ADC_SYNC : JY9515Import
  • JY9515_EXPORT_DCLK : JY9515Import
  • JY9515_EXPORT_MCLK : JY9515Import
  • JY9515_EXPORT_PLL_SYNC : JY9515Import
  • JY9515_EXPORT_RX_ADV_TRIG : JY9515Import
  • JY9515_EXPORT_RX_END_OF_RECORD : JY9515Import
  • JY9515_EXPORT_RX_ENGINE_END : JY9515Import
  • JY9515_EXPORT_RX_READY_FOR_ADV_TRIG : JY9515Import
  • JY9515_EXPORT_RX_READY_FOR_REF_TRIG : JY9515Import
  • JY9515_EXPORT_RX_READY_FOR_START_TRIG : JY9515Import
  • JY9515_EXPORT_RX_REF_TRIG : JY9515Import
  • JY9515_EXPORT_RX_START_TRIG : JY9515Import
  • JY9515_EXPORT_SAMPLE_CLOCK : JY9515Import
  • JY9515_EXPORT_SYNC : JY9515Import
  • JY9515_Onboard_10M : JY9515Import
  • JY9515_PXIe_Clk_100M : JY9515Import
  • JY9515_Range_0p3125V : JY9515Import
  • JY9515_Range_0p625V : JY9515Import
  • JY9515_Range_10V : JY9515Import
  • JY9515_Range_15V : JY9515Import
  • JY9515_Range_1p25V : JY9515Import
  • JY9515_Range_2p5V : JY9515Import
  • JY9515_Range_5V : JY9515Import
  • JY9515_SyncMode_Master : JY9515Import
  • JY9515_SyncMode_Slave : JY9515Import
  • JY9515_SyncMode_Solo : JY9515Import
  • JY9515_TriggerType_Analog : JY9515Import
  • JY9515_TriggerType_Digital : JY9515Import
  • JY9515_TriggerType_Immediately : JY9515Import
  • JY9515_TriggerType_Software : JY9515Import
  • JY9517_ADCChopping_fMod8 : JY9515Import

- s -

  • Sinc5Filter : JY9515Import

- w -

  • WidebandLowRippleFilter : JY9515Import


9515 C++ Programming Manual: Namespace List

  • Namespace List
  • Namespace Members
Namespace List
Here is a list of all namespaces with brief descriptions:
N JY9515CoreOO
N JY9515Import


9515 C++ Programming Manual: Member List

  • FirmDriveInfo
JY9515CoreOO::FirmDriveInfo Member List

This is the complete list of members for JY9515CoreOO::FirmDriveInfo, including all inherited members.

aliasName | JY9515CoreOO::FirmDriveInfo
cardNumber | JY9515CoreOO::FirmDriveInfo
connected | JY9515CoreOO::FirmDriveInfo
DriverSetVer | JY9515CoreOO::FirmDriveInfo
FirmwareVer | JY9515CoreOO::FirmDriveInfo
FrameworkVer | JY9515CoreOO::FirmDriveInfo
fStreaming | JY9515CoreOO::FirmDriveInfo
HardwareVer | JY9515CoreOO::FirmDriveInfo
model | JY9515CoreOO::FirmDriveInfo
PID | JY9515CoreOO::FirmDriveInfo
PlatformType | JY9515CoreOO::FirmDriveInfo
ProductionDate | JY9515CoreOO::FirmDriveInfo
serialNumber | JY9515CoreOO::FirmDriveInfo
slotNum | JY9515CoreOO::FirmDriveInfo
vendorName | JY9515CoreOO::FirmDriveInfo
VID | JY9515CoreOO::FirmDriveInfo