9515 C# Programming Manual: D:/9515/C#/AIChannel.cs File Reference

9515 C# Programming Manual
  • Main Page
  • Packages
  • Classes
  • Files
  • File List
  • 9515
  • C#
Classes | Namespaces | Enumerations
AIChannel.cs File Reference

Classes

class | JY9515.AIChannel
AI Channel. More...
class | JY9515.EnumExtension
JY9515 Enum Extension.

Namespaces

namespace JY9515

Enumerations

enum JY9515.AIRange {
JY9515._10V = JY9515Import.JY9515_Range_10V , JY9515._5V = JY9515Import.JY9515_Range_5V , JY9515._2p5V = JY9515Import.JY9515_Range_2p5V , JY9515._1p25V = JY9515Import.JY9515_Range_1p25V ,
JY9515._0p625V = JY9515Import.JY9515_Range_0p625V , JY9515._0p3125V = JY9515Import.JY9515_Range_0p3125V
}
AI voltage range. More...
enum JY9515.Coupling { JY9515.AC = JY9515Import.JY9515_Coupling_AC , JY9515.DC = JY9515Import.JY9515_Coupling_DC }
Coupling. More...
Generated by doxygen 1.12.0


9515 C# Programming Manual: D:/9515/C#/AIDigitalFiltering.cs File Reference

  • Packages
  • Classes
  • Files
  • File List
  • 9515
  • C#
Classes | Namespaces | Enumerations
AIDigitalFiltering.cs File Reference

Classes

class | JY9515.AIDigitalFiltering
AI Digital Filtering Connfiguration Class. More...
class | JY9515.FlatnessCompensation
Flatness Compensation Parameters. More...
class | JY9515.LowPassFilter
Low-Pass Filter Configuration Class. More...
class | JY9515.HighPassFilter
High-Pass Filter Configuration Class. More...

Namespaces

namespace JY9515

Enumerations

enum | JY9515.ChoppingFrequency { JY9515.fMod32 = JY9515Import.JY9515_ADCChopping_fMod32 , JY9515.fMod8 = JY9515Import.JY9517_ADCChopping_fMod8 }
Modulator Chopping Frequency Enum. More...
enum | JY9515.LPFMode { JY9515.Normal = 0 , JY9515.WideBandwidth = 1 }
Low-Pass Filter Mode Enum. More...
enum | JY9515.HPFOrder { JY9515.OneOrder = 1 , JY9515.TwoOrder = 2 }
High-pass filter order. More...


9515 C# Programming Manual: D:/9515/C#/AISignalExport.cs File Reference

  • File List
  • 9515
  • C#
Classes | Namespaces | Enumerations
AISignalExport.cs File Reference

Classes

class JY9515.AISignalExport
AI Signal Export Class. More...

Namespaces

namespace JY9515

Enumerations

enum JY9515.AISignalExportSource {
JY9515.SampleClock = JY9515Import.JY9515_EXPORT_SAMPLE_CLOCK , JY9515.Sync = JY9515Import.JY9515_EXPORT_SYNC , JY9515.ReadyForStartTrigger = JY9515Import.JY9515_EXPORT_RX_READY_FOR_REF_TRIG , JY9515.StartTrigger = JY9515Import.JY9515_EXPORT_RX_REF_TRIG ,
JY9515.EndOfRecord = JY9515Import.JY9515_EXPORT_RX_END_OF_RECORD , JY9515.EndOfAcquisition = JY9515Import.JY9515_EXPORT_RX_ENGINE_END
}
AI Signal Export Source Enum. More...
enum JY9515.SignalExportDestination {
JY9515.Ext_Trig = JY9515Import.JY9515_DigitalTriggerSource_External , JY9515.PXI_Trig0 = JY9515Import.JY9515_DigitalTriggerSource_BUS_0 , JY9515.PXI_Trig1 = JY9515Import.JY9515_DigitalTriggerSource_BUS_1 , JY9515.PXI_Trig2 = JY9515Import.JY9515_DigitalTriggerSource_BUS_2 ,
JY9515.PXI_Trig3 = JY9515Import.JY9515_DigitalTriggerSource_BUS_3 , JY9515.PXI_Trig4 = JY9515Import.JY9515_DigitalTriggerSource_BUS_4 , JY9515.PXI_Trig5 = JY9515Import.JY9515_DigitalTriggerSource_BUS_5 , JY9515.PXI_Trig6 = JY9515Import.JY9515_DigitalTriggerSource_BUS_6 ,
JY9515.PXI_Trig7 = JY9515Import.JY9515_DigitalTriggerSource_BUS_7 , JY9515.PXI_Star = JY9515Import.JY9515_DigitalTriggerSource_STAR
}
Signal Export Destination Enum. More...


9515 C# Programming Manual: D:/9515/C#/AISync.cs File Reference

  • File List
  • 9515
  • C#
Classes | Namespaces | Enumerations
AISync.cs File Reference

Classes

class JY9515.Sync

Namespaces

namespace JY9515

Enumerations

enum | JY9515.SyncTopology { JY9515.Independent = JY9515Import.JY9515_SyncMode_Solo , JY9515.Master = JY9515Import.JY9515_SyncMode_Master , JY9515.Slave = JY9515Import.JY9515_SyncMode_Slave }
Multi-Device Sync Topology. More...
enum JY9515.SyncTerminal {
JY9515.Ext_Trig = JY9515Import.JY9515_DigitalTriggerSource_External , JY9515.PXI_Trig0 = JY9515Import.JY9515_DigitalTriggerSource_BUS_0 , JY9515.PXI_Trig1 = JY9515Import.JY9515_DigitalTriggerSource_BUS_1 , JY9515.PXI_Trig2 = JY9515Import.JY9515_DigitalTriggerSource_BUS_2 ,
JY9515.PXI_Trig3 = JY9515Import.JY9515_DigitalTriggerSource_BUS_3 , JY9515.PXI_Trig4 = JY9515Import.JY9515_DigitalTriggerSource_BUS_4 , JY9515.PXI_Trig5 = JY9515Import.JY9515_DigitalTriggerSource_BUS_5 , JY9515.PXI_Trig6 = JY9515Import.JY9515_DigitalTriggerSource_BUS_6 ,
JY9515.PXI_Trig7 = JY9515Import.JY9515_DigitalTriggerSource_BUS_7 , JY9515.PXI_Star = JY9515Import.JY9515_DigitalTriggerSource_STAR
}
AI digital trigger source enum type. More...
enum | JY9515.SyncState { JY9515.WaitingSync , JY9515.Synchronized , JY9515.Invalid }
Sync State. More...


9515 C# Programming Manual: D:/9515/C#/AITrigger.cs File Reference

  • File List
  • 9515
  • C#
Classes | Namespaces | Enumerations
AITrigger.cs File Reference

Classes

class | JY9515.AIDigitalTrigger
AI Digital trigger params. More...
class | JY9515.AIAnalogTrigger
AI Analog Trigger. More...
class | JY9515.AIAnalogHysteresisComparator
AI Analog Hysteresis Comparator. More...
class | JY9515.AIAnalogWindowComparator
AI Analog Window Comparator. More...
class | JY9515.AIAnalogEdgeComparator
AI Analog Edge Comparator. More...
class | JY9515.AITrigger
AI Trigger params. More...

Namespaces

namespace JY9515

Enumerations

enum | JY9515.AITriggerMode { JY9515.Start , JY9515.Reference }
AI trigger mode enum type. More...
enum | JY9515.AITriggerType { JY9515.Immediately = JY9515Import.JY9515_TriggerType_Immediately , JY9515.Digital = JY9515Import.JY9515_TriggerType_Digital , JY9515.Software = JY9515Import.JY9515_TriggerType_Software , JY9515.Analog = JY9515Import.JY9515_TriggerType_Analog }
AI trigger type enum type. More...
enum JY9515.AIDigitalTriggerSource {
JY9515.Ext_Trig = JY9515Import.JY9515_DigitalTriggerSource_External , JY9515.PXI_Trig0 = JY9515Import.JY9515_DigitalTriggerSource_BUS_0 , JY9515.PXI_Trig1 = JY9515Import.JY9515_DigitalTriggerSource_BUS_1 , JY9515.PXI_Trig2 = JY9515Import.JY9515_DigitalTriggerSource_BUS_2 ,
JY9515.PXI_Trig3 = JY9515Import.JY9515_DigitalTriggerSource_BUS_3 , JY9515.PXI_Trig4 = JY9515Import.JY9515_DigitalTriggerSource_BUS_4 , JY9515.PXI_Trig5 = JY9515Import.JY9515_DigitalTriggerSource_BUS_5 , JY9515.PXI_Trig6 = JY9515Import.JY9515_DigitalTriggerSource_BUS_6 ,
JY9515.PXI_Trig7 = JY9515Import.JY9515_DigitalTriggerSource_BUS_7 , JY9515.PXI_Star = JY9515Import.JY9515_DigitalTriggerSource_STAR
}
AI digital trigger source enum type. More...
enum | JY9515.AIDigitalTriggerEdge { JY9515.Rising = JY9515Import.JY9515_DigitalTriggerEdge_Rising , JY9515.Falling = JY9515Import.JY9515_DigitalTriggerEdge_Falling }
AI digital trigger edge enum type. More...
enum JY9515.AIAnalogTriggerSource {
JY9515.Channel_0 , JY9515.Channel_1 , JY9515.Channel_2 , JY9515.Channel_3 ,
JY9515.Channel_4 , JY9515.Channel_5 , JY9515.Channel_6 , JY9515.Channel_7
}
AI Analog Trigger Source. More...
enum | JY9515.AIAnalogTriggerComparator { JY9515.Edge , JY9515.Hysteresis , JY9515.Window }
AI Analog Trigger Comparator. More...
enum | JY9515.AIAnalogTriggerEdge { JY9515.Rising , JY9515.Falling }
AI Analog Trigger Edge. More...
enum | JY9515.AIAnalogWindowCondition { JY9515.Entering , JY9515.Leaving }
AI Analog Window Trigger Condition. More...


9515 C# Programming Manual: D:/9515/C#/JY9515AITask.cs File Reference

  • File List
  • 9515
  • C#
Classes | Namespaces | Enumerations
JY9515AITask.cs File Reference

Classes

class | JY9515.JY9515AITask
JY9515 AI Task. More...
class | JY9515.ConversionStatus
ADC Convesion Status Class. More...

Namespaces

namespace JY9515

Enumerations

enum | JY9515.AIMode { JY9515.Finite = JY9515Import.JY9515_AI_Finite , JY9515.Continuous = JY9515Import.JY9515_AI_Continuous , JY9515.Single = JY9515Import.JY9515_AI_Single }
AI mode enum type. More...
enum JY9515.SamplingState {
JY9515.Idle = 1 << 0 , JY9515.WaitingForStart = 1 << 1 , JY9515.PreSampling = 1 << 2 , JY9515.WaitingForRefTrigger = 1 << 3 ,
JY9515.PostSampling = 1 << 4 , JY9515.RecordCompleted = 1 << 5 , JY9515.WaitingForAdvanceTrigger = 1 << 6 , JY9515.Done = 1 << 7
}
Sampling State Enum. More...
enum | JY9515.IEPEConnectionStatus { JY9515.Normal = 0 , JY9515.OpenCircuit = 1 , JY9515.ShortCircuit = 2 }
IEPE Connection Status. More...


9515 C# Programming Manual: D:/9515/C#/ReferenceClock.cs File Reference

  • File List
  • 9515
  • C#
Classes | Namespaces | Enumerations
ReferenceClock.cs File Reference

Classes

class | JY9515.ExternalReferenceClock
class | JY9515.ReferenceClock

Namespaces

namespace JY9515

Enumerations

enum | JY9515.ExternalReferenceClockTerminal { JY9515.PXIe_Clk100 = JY9515Import.JY9515_PXIe_Clk_100M }
enum | JY9515.ReferenceClockSource { JY9515.Internal = 0 , JY9515.External = 1 }


9515 C# Programming Manual: Class List

  • Class List
  • Class Index
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
▼N JY9515 |
C AIAnalogEdgeComparator | AI Analog Edge Comparator
C AIAnalogHysteresisComparator | AI Analog Hysteresis Comparator
C AIAnalogTrigger | AI Analog Trigger
C AIAnalogWindowComparator | AI Analog Window Comparator
C AIChannel | AI Channel
C AIDigitalFiltering | AI Digital Filtering Connfiguration Class
C AIDigitalTrigger | AI Digital trigger params
C AISignalExport | AI Signal Export Class
C AITrigger | AI Trigger params
C ConversionStatus | ADC Convesion Status Class
C ExternalReferenceClock |
C FlatnessCompensation | Flatness Compensation Parameters
C HighPassFilter | High-Pass Filter Configuration Class
C JY9515AITask | JY9515 AI Task
C LowPassFilter | Low-Pass Filter Configuration Class
C ReferenceClock |
C Sync |


9515 C# Programming Manual: JY9515.AIAnalogEdgeComparator Class Reference

  • JY9515
  • AIAnalogEdgeComparator
Public Attributes | Properties | List of all members
JY9515.AIAnalogEdgeComparator Class Reference

AI Analog Edge Comparator. More...

Public Attributes

double Threshold
Threshold.

Properties

AIAnalogTriggerEdge Slope [get, set]
AI Analog Trigger Edge.

Detailed Description

AI Analog Edge Comparator.

Member Data Documentation

◆ Threshold

double JY9515.AIAnalogEdgeComparator.Threshold

Threshold.

Property Documentation

◆ Slope

AIAnalogTriggerEdge JY9515.AIAnalogEdgeComparator.Slope
getset

AI Analog Trigger Edge.

The documentation for this class was generated from the following file:
  • D:/9515/C#/AITrigger.cs


9515 C# Programming Manual: Member List

  • AIAnalogEdgeComparator
JY9515.AIAnalogEdgeComparator Member List

This is the complete list of members for JY9515.AIAnalogEdgeComparator, including all inherited members.

Slope | JY9515.AIAnalogEdgeComparator
Threshold | JY9515.AIAnalogEdgeComparator


9515 C# Programming Manual: JY9515.AIAnalogHysteresisComparator Class Reference

  • AIAnalogHysteresisComparator
Public Attributes | Properties | List of all members
JY9515.AIAnalogHysteresisComparator Class Reference

AI Analog Hysteresis Comparator. More...

Public Attributes

double | HighThreshold
High Threshold.
double | LowThreshold
Low Threshold.

Properties

AIAnalogTriggerEdge Slope [get, set]
AI Analog Trigger Edge.

Detailed Description

AI Analog Hysteresis Comparator.

Member Data Documentation

◆ HighThreshold

double JY9515.AIAnalogHysteresisComparator.HighThreshold

High Threshold.

◆ LowThreshold

double JY9515.AIAnalogHysteresisComparator.LowThreshold

Low Threshold.

Property Documentation

◆ Slope

AIAnalogTriggerEdge JY9515.AIAnalogHysteresisComparator.Slope
getset

AI Analog Trigger Edge.

The documentation for this class was generated from the following file:
  • D:/9515/C#/AITrigger.cs


9515 C# Programming Manual: Member List

  • AIAnalogHysteresisComparator
JY9515.AIAnalogHysteresisComparator Member List

This is the complete list of members for JY9515.AIAnalogHysteresisComparator, including all inherited members.

HighThreshold | JY9515.AIAnalogHysteresisComparator
LowThreshold | JY9515.AIAnalogHysteresisComparator
Slope | JY9515.AIAnalogHysteresisComparator


9515 C# Programming Manual: JY9515.AIAnalogTrigger Class Reference

  • AIAnalogTrigger
Properties | List of all members
JY9515.AIAnalogTrigger Class Referencesealed

AI Analog Trigger. More...

Properties

AIAnalogTriggerSource | Source [get, set]
Analog Trigger source.
AIAnalogTriggerComparator | Comparator [get, set]
AI Analog Trigger Comparator.
AIAnalogEdgeComparator | Edge [get, set]
AI Analog Edge Comparator.
AIAnalogHysteresisComparator | Hysteresis [get, set]
AI Analog Hysteresis Comparatorr.
AIAnalogWindowComparator | Window [get, set]
AI Analog Window Comparatorr.

Detailed Description

AI Analog Trigger.

Property Documentation

◆ Comparator

AIAnalogTriggerComparator JY9515.AIAnalogTrigger.Comparator
getset

AI Analog Trigger Comparator.

◆ Edge

AIAnalogEdgeComparator JY9515.AIAnalogTrigger.Edge
getset

AI Analog Edge Comparator.

◆ Hysteresis

AIAnalogHysteresisComparator JY9515.AIAnalogTrigger.Hysteresis
getset

AI Analog Hysteresis Comparatorr.

◆ Source

AIAnalogTriggerSource JY9515.AIAnalogTrigger.Source
getset

Analog Trigger source.

◆ Window

AIAnalogWindowComparator JY9515.AIAnalogTrigger.Window
getset

AI Analog Window Comparatorr.

The documentation for this class was generated from the following file:
  • D:/9515/C#/AITrigger.cs


9515 C# Programming Manual: Member List

  • AIAnalogTrigger
JY9515.AIAnalogTrigger Member List

This is the complete list of members for JY9515.AIAnalogTrigger, including all inherited members.

Comparator | JY9515.AIAnalogTrigger
Edge | JY9515.AIAnalogTrigger
Hysteresis | JY9515.AIAnalogTrigger
Source | JY9515.AIAnalogTrigger
Window | JY9515.AIAnalogTrigger


9515 C# Programming Manual: JY9515.AIAnalogWindowComparator Class Reference

  • AIAnalogWindowComparator
Public Attributes | Properties | List of all members
JY9515.AIAnalogWindowComparator Class Reference

AI Analog Window Comparator. More...

Public Attributes

double | HighThreshold
High Threshold.
double | LowThreshold
Low Threshold.

Properties

AIAnalogWindowCondition Condition [get, set]
AI Analog Window Condition.

Detailed Description

AI Analog Window Comparator.

Member Data Documentation

◆ HighThreshold

double JY9515.AIAnalogWindowComparator.HighThreshold

High Threshold.

◆ LowThreshold

double JY9515.AIAnalogWindowComparator.LowThreshold

Low Threshold.

Property Documentation

◆ Condition

AIAnalogWindowCondition JY9515.AIAnalogWindowComparator.Condition
getset

AI Analog Window Condition.

The documentation for this class was generated from the following file:
  • D:/9515/C#/AITrigger.cs


9515 C# Programming Manual: Member List

  • AIAnalogWindowComparator
JY9515.AIAnalogWindowComparator Member List

This is the complete list of members for JY9515.AIAnalogWindowComparator, including all inherited members.

Condition | JY9515.AIAnalogWindowComparator
HighThreshold | JY9515.AIAnalogWindowComparator
LowThreshold | JY9515.AIAnalogWindowComparator


9515 C# Programming Manual: JY9515.AIChannel Class Reference

  • AIChannel
Properties | List of all members
JY9515.AIChannel Class Reference

AI Channel. More...

Properties

int | ID [get]
Channel ID.
double | RangeHigh [get]
Upper limit of range.
double | RangeLow [get]
Lower limit of range.
Coupling | Coupling [get]
Coupling.
bool | IEPEEnabled [get]
IEPE enabled.
AIRange | Range [get]
Input voltage range(grade)
double | RawDataScaleFactor [get]
This fator is used to convert RawData(binary) to Data(voltage in V).

Detailed Description

AI Channel.

Property Documentation

◆ Coupling

Coupling JY9515.AIChannel.Coupling
get

Coupling.

◆ ID

int JY9515.AIChannel.ID
get

Channel ID.

◆ IEPEEnabled

bool JY9515.AIChannel.IEPEEnabled
get

IEPE enabled.

◆ Range

AIRange JY9515.AIChannel.Range
get

Input voltage range(grade)

◆ RangeHigh

double JY9515.AIChannel.RangeHigh
get

Upper limit of range.

◆ RangeLow

double JY9515.AIChannel.RangeLow
get

Lower limit of range.

◆ RawDataScaleFactor

double JY9515.AIChannel.RawDataScaleFactor
get

This fator is used to convert RawData(binary) to Data(voltage in V).

RawData * factor = Data

The documentation for this class was generated from the following file:
  • D:/9515/C#/AIChannel.cs


9515 C# Programming Manual: Member List

  • AIChannel
JY9515.AIChannel Member List

This is the complete list of members for JY9515.AIChannel, including all inherited members.

Coupling | JY9515.AIChannel
ID | JY9515.AIChannel
IEPEEnabled | JY9515.AIChannel
Range | JY9515.AIChannel
RangeHigh | JY9515.AIChannel
RangeLow | JY9515.AIChannel
RawDataScaleFactor | JY9515.AIChannel


9515 C# Programming Manual: JY9515.AIDigitalFiltering Class Reference

  • AIDigitalFiltering
Properties | List of all members
JY9515.AIDigitalFiltering Class Referencesealed

AI Digital Filtering Connfiguration Class. More...

Properties

LowPassFilter | LPF [get]
Low-Pass Filter (or called Anti-Aliasing Filter) Parametes.
HighPassFilter | HPF [get]
High-Pass Filter Parameters.

Detailed Description

AI Digital Filtering Connfiguration Class.

Property Documentation

◆ HPF

HighPassFilter JY9515.AIDigitalFiltering.HPF
get

High-Pass Filter Parameters.

◆ LPF

LowPassFilter JY9515.AIDigitalFiltering.LPF
get

Low-Pass Filter (or called Anti-Aliasing Filter) Parametes.

The documentation for this class was generated from the following file:
  • D:/9515/C#/AIDigitalFiltering.cs


9515 C# Programming Manual: Member List

  • AIDigitalFiltering
JY9515.AIDigitalFiltering Member List

This is the complete list of members for JY9515.AIDigitalFiltering, including all inherited members.

HPF | JY9515.AIDigitalFiltering
LPF | JY9515.AIDigitalFiltering


9515 C# Programming Manual: JY9515.AIDigitalTrigger Class Reference

  • AIDigitalTrigger
Properties | List of all members
JY9515.AIDigitalTrigger Class Referencesealed

AI Digital trigger params. More...

Properties

AIDigitalTriggerSource | Source [get, set]
AI digital trigger source.
AIDigitalTriggerEdge | Edge [get, set]
AI digital trigger effective edge.

Detailed Description

AI Digital trigger params.

Property Documentation

◆ Edge

AIDigitalTriggerEdge JY9515.AIDigitalTrigger.Edge
getset

AI digital trigger effective edge.

◆ Source

AIDigitalTriggerSource JY9515.AIDigitalTrigger.Source
getset

AI digital trigger source.

The documentation for this class was generated from the following file:
  • D:/9515/C#/AITrigger.cs


9515 C# Programming Manual: Member List

  • AIDigitalTrigger
JY9515.AIDigitalTrigger Member List

This is the complete list of members for JY9515.AIDigitalTrigger, including all inherited members.

Edge | JY9515.AIDigitalTrigger
Source | JY9515.AIDigitalTrigger


9515 C# Programming Manual: JY9515.AISignalExport Class Reference

  • AISignalExport
Public Member Functions | List of all members
JY9515.AISignalExport Class Reference

AI Signal Export Class. More...

Public Member Functions

void | Add (AISignalExportSource source, SignalExportDestination destination)
Export one signal to desination.
void | Add (AISignalExportSource source, List< SignalExportDestination > destinations)
Export one signal to mutil desinations.
void | Clear (SignalExportDestination destination)
Clear one signal export.
void | ClearAll ()
Clear all signal export.

Detailed Description

AI Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY9515.AISignalExport.Add | ( | AISignalExportSource | source,
 |  | List< SignalExportDestination > | destinations )

Export one signal to mutil desinations.

Parameters
source | AI Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY9515.AISignalExport.Add | ( | AISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one signal to desination.

Parameters
source | AI Signal Source
destination | Export Desination

◆ Clear()

void JY9515.AISignalExport.Clear ( SignalExportDestination destination )

Clear one signal export.

Parameters
destination Export Desination

◆ ClearAll()

void JY9515.AISignalExport.ClearAll ( )

Clear all signal export.

The documentation for this class was generated from the following file:
  • D:/9515/C#/AISignalExport.cs


9515 C# Programming Manual: Member List

  • AISignalExport
JY9515.AISignalExport Member List

This is the complete list of members for JY9515.AISignalExport, including all inherited members.

Add(AISignalExportSource source, SignalExportDestination destination) | JY9515.AISignalExport
Add(AISignalExportSource source, List< SignalExportDestination > destinations) | JY9515.AISignalExport
Clear(SignalExportDestination destination) | JY9515.AISignalExport
ClearAll() | JY9515.AISignalExport


9515 C# Programming Manual: JY9515.AITrigger Class Reference

  • AITrigger
Properties | List of all members
JY9515.AITrigger Class Referencesealed

AI Trigger params. More...

Properties

AITriggerType | Type [get, set]
AI trigger type.
AITriggerMode | Mode [get, set]
AI trigger mode.
AIDigitalTrigger | Digital [get]
AI digital trigger params.
AIAnalogTrigger | Analog [get]
AI analog trigger params.
int | ReTriggerCount [get, set]
Number of repeat triggers.
uint | PreTriggerSamples [get, set]
AI pretrigger points.

Detailed Description

AI Trigger params.

Property Documentation

◆ Analog

AIAnalogTrigger JY9515.AITrigger.Analog
get

AI analog trigger params.

◆ Digital

AIDigitalTrigger JY9515.AITrigger.Digital
get

AI digital trigger params.

◆ Mode

AITriggerMode JY9515.AITrigger.Mode
getset

AI trigger mode.

enum Start/Reference.

◆ PreTriggerSamples

uint JY9515.AITrigger.PreTriggerSamples
getset

AI pretrigger points.

Only valid in the reference trigger mode.

◆ ReTriggerCount

int JY9515.AITrigger.ReTriggerCount
getset

Number of repeat triggers.

No repeat the trigger when 0 or 1, or the number of repeated triggers.

◆ Type

AITriggerType JY9515.AITrigger.Type
getset

AI trigger type.

enum Analog/Digital/Immediate/Soft.

The documentation for this class was generated from the following file:
  • D:/9515/C#/AITrigger.cs


9515 C# Programming Manual: Member List

  • AITrigger
JY9515.AITrigger Member List

This is the complete list of members for JY9515.AITrigger, including all inherited members.

Analog | JY9515.AITrigger
Digital | JY9515.AITrigger
Mode | JY9515.AITrigger
PreTriggerSamples | JY9515.AITrigger
ReTriggerCount | JY9515.AITrigger
Type | JY9515.AITrigger


9515 C# Programming Manual: JY9515.ConversionStatus Class Reference

  • ConversionStatus
Properties | List of all members
JY9515.ConversionStatus Class Reference

ADC Convesion Status Class. More...

Properties

bool | ErrorFlagged [get]
The error flagged bit indicates that a serious error has occurred.
bool | CRCError [get]
CRC not match.
bool | FilterSuturated [get]
The filter saturated bit indicates that the filter output is clipping at either positive or negative full scale.
int | ChannelID [get]
The channel ID bits indicate the ADC channel from which the succeeding conversion status originates.

Detailed Description

ADC Convesion Status Class.

Property Documentation

◆ ChannelID

int JY9515.ConversionStatus.ChannelID
get

The channel ID bits indicate the ADC channel from which the succeeding conversion status originates.

◆ CRCError

bool JY9515.ConversionStatus.CRCError
get

CRC not match.

◆ ErrorFlagged

bool JY9515.ConversionStatus.ErrorFlagged
get

The error flagged bit indicates that a serious error has occurred.

This bit indicatesthat the external clock is not detected, a memory map bit has unexpectedly changed state, or an internal CRC error has been detected.

◆ FilterSuturated

bool JY9515.ConversionStatus.FilterSuturated
get

The filter saturated bit indicates that the filter output is clipping at either positive or negative full scale.

The documentation for this class was generated from the following file:
  • D:/9515/C#/JY9515AITask.cs


9515 C# Programming Manual: Member List

  • ConversionStatus
JY9515.ConversionStatus Member List

This is the complete list of members for JY9515.ConversionStatus, including all inherited members.

ChannelID | JY9515.ConversionStatus
CRCError | JY9515.ConversionStatus
ErrorFlagged | JY9515.ConversionStatus
FilterSuturated | JY9515.ConversionStatus


9515 C# Programming Manual: JY9515.ExternalReferenceClock Class Reference

  • ExternalReferenceClock
Properties | List of all members
JY9515.ExternalReferenceClock Class Referencesealed

Properties

ExternalReferenceClockTerminal | Terminal [get, set]
int | Frequency [get, set]

Detailed Description

外部参考时钟配置类

External Reference Clcok Configuration Class

Property Documentation

◆ Frequency

int JY9515.ExternalReferenceClock.Frequency
getset

外部参考时钟频率

Frequency of External Reference Clcok

◆ Terminal

ExternalReferenceClockTerminal JY9515.ExternalReferenceClock.Terminal
getset

外部参考时钟输入端口

External Reference Clcok Input Terminal

The documentation for this class was generated from the following file:
  • D:/9515/C#/ReferenceClock.cs


9515 C# Programming Manual: Member List

  • ExternalReferenceClock
JY9515.ExternalReferenceClock Member List

This is the complete list of members for JY9515.ExternalReferenceClock, including all inherited members.

Frequency | JY9515.ExternalReferenceClock
Terminal | JY9515.ExternalReferenceClock


9515 C# Programming Manual: JY9515.FlatnessCompensation Class Reference

  • FlatnessCompensation
Properties | List of all members
JY9515.FlatnessCompensation Class Referencesealed

Flatness Compensation Parameters. More...

Properties

bool Enabled [get, set]
Enabled.

Detailed Description

Flatness Compensation Parameters.

Property Documentation

◆ Enabled

bool JY9515.FlatnessCompensation.Enabled
getset

Enabled.

The documentation for this class was generated from the following file:
  • D:/9515/C#/AIDigitalFiltering.cs


9515 C# Programming Manual: Member List

  • FlatnessCompensation
JY9515.FlatnessCompensation Member List

This is the complete list of members for JY9515.FlatnessCompensation, including all inherited members.

Enabled JY9515.FlatnessCompensation


9515 C# Programming Manual: JY9515.HighPassFilter Class Reference

  • HighPassFilter
Public Member Functions | Properties | List of all members
JY9515.HighPassFilter Class Referencesealed

High-Pass Filter Configuration Class. More...

Public Member Functions

void | EnableChannel (int chID)
Enables the high-pass filter on the specified channel.
void | DisableChannel (int chID)
Disables the high-pass filter on the specified channel.

Properties

double | CutoffFrequency [get, set]
Cutoff Frequency in Hz.
HPFOrder | Order [get, set]
Filter Order.
List< int > | FilterEnabledChannels [get]
The channels that the filter has enabled.

Detailed Description

High-Pass Filter Configuration Class.

Member Function Documentation

◆ DisableChannel()

void JY9515.HighPassFilter.DisableChannel ( int chID )

Disables the high-pass filter on the specified channel.

Parameters
chID

◆ EnableChannel()

void JY9515.HighPassFilter.EnableChannel ( int chID )

Enables the high-pass filter on the specified channel.

Parameters
chID

Property Documentation

◆ CutoffFrequency

double JY9515.HighPassFilter.CutoffFrequency
getset

Cutoff Frequency in Hz.

The max value is SampleRate * 1%. The attenuation at this frequency is -3dB when the filter is one-order, and -6dB when the filter is two-order.

◆ FilterEnabledChannels

List<int> JY9515.HighPassFilter.FilterEnabledChannels
get

The channels that the filter has enabled.

◆ Order

HPFOrder JY9515.HighPassFilter.Order
getset

Filter Order.

The documentation for this class was generated from the following file:
  • D:/9515/C#/AIDigitalFiltering.cs


9515 C# Programming Manual: Member List

  • HighPassFilter
JY9515.HighPassFilter Member List

This is the complete list of members for JY9515.HighPassFilter, including all inherited members.

CutoffFrequency | JY9515.HighPassFilter
DisableChannel(int chID) | JY9515.HighPassFilter
EnableChannel(int chID) | JY9515.HighPassFilter
FilterEnabledChannels | JY9515.HighPassFilter
Order | JY9515.HighPassFilter


9515 C# Programming Manual: JY9515.JY9515AITask Class Reference

  • JY9515AITask
Public Member Functions | Properties | List of all members
JY9515.JY9515AITask Class Reference

JY9515 AI Task. More...

Public Member Functions

JY9515AITask (int slotNumber)
Create a AI task with slot number.
JY9515AITask (string cardName)
Create a AI task with card name.
void | AddChannel (int chID, double rangeLow, double rangeHigh, Coupling coupling, bool enableIEPE)
Add one/all channel(s).
void | AddChannel (int[] chIDs, double rangeLow, double rangeHigh, Coupling coupling, bool enableIEPE)
Add a set of channels and set parameters uniformly.
void | AddChannel (int[] chIDs, double[] rangeLow, double[] rangeHigh, Coupling[] coupling, bool[] enableIEPE)
Add a set of channels and set the parameters individually.
void | AddChannel (int chID, AIRange range, Coupling coupling, bool enableIEPE)
Add one/all channel(s).
void | AddChannel (int[] chIDs, AIRange range, Coupling coupling, bool enableIEPE)
Add a set of channels and set parameters uniformly.
void | AddChannel (int[] chIDs, AIRange[] range, Coupling[] coupling, bool[] enableIEPE)
Add a set of channels and set parameters uniformly.
void | RemoveChannel (int chID)
Delete the channel with the specified channel ID.
void | RemoveChannel (int[] chIDs)
Delete a set of channels with the specified channel ID.
void | Commit ()
Commit current configuration.
void | Start ()
Start AI task.
void | Stop ()
Stop AI task.
void | StartSync ()
Start the multi-card synchronization process AGAIN.
void | ReadRawData (ref int[] dataBuf, int samplesPerChannel, int timeout)
Read raw data and copy to buffer.
void | ReadRawData (ref int[] dataBuf, int timeout=-1)
Read raw data and copy to buffer.
void | ReadRawData (ref int[,] dataBuf, int samplesPerChannel, int timeout)
Read raw data by columns and copy to buffer.
void | ReadRawData (IntPtr dataBuf, int samplesPerChannel, int timeout)
Read one or multi-channel raw data and copy to a unmannaged data buffer.
void | ReadData (ref double[] dataBuf, int samplesPerChannel, int timeout)
Read data and copy to buffer.
void | ReadData (ref double[] dataBuf, int timeout=-1)
Read data and copy to buffer.
void | ReadData (ref double[,] dataBuf, int samplesPerChannel, int timeout)
Read data by columns and copy to buffer.
void | ReadData (ref double[,] dataBuf, int timeout=-1)
Read data by columns and copy to buffer.
void | ReadData (IntPtr dataBuf, int samplesPerChannel, int timeout)
Read one or multi-channel data and copy to a unmannaged data buffer.
void | ReadSinglePoint (ref double[] dataBuf)
Read one sample (per channel) in unbuffered reading.
void | ReadSingleRawPoint (IntPtr dataBuf)
Read one sample (per channel) in unbuffered reading to unmannaged buffer.
ConversionStatus[] GetConversionStatus ()
Get ADC conversion status on all enabled channels.
void | SendSoftwareTrigger ()
Send a software trigger.
Dictionary< int, IEPEConnectionStatus > | DetectIEPEConnection ()
Perform IEPE sensor connection status detection.
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.

Properties

JY9515Device | Device [get]
The device instance called by this AI task instance.
List< AIChannel > | Channels [get]
List of enabled channels.
AITrigger | Trigger [get]
AI trigger configuration.
AISignalExport | SignalExport [get]
Signal export configuration.
Sync | Sync [get]
Sync configuration.
AIDigitalFiltering | DigitalFiltering [get]
Digital filtering configuration.
AIMode | Mode [get, set]
Sample mode.
double | SampleRate [get, set]
Sampling rate per channel in Sa/s.
int | SamplesToAcquire [get, set]
Samples to acquire.
SamplingState | State [get]
Sampling state.
UInt64 | AvailableSamples [get]
Number of samples per channel that can be read in the buffer.
UInt64 | TransferedSamples [get]
Number of points per channel that have already been read from the buffer.
SampleInfo | SampleInfo [get]
Sampling information.
bool | DisableCalibration [get, set]
Calibration is disabled when this property is true.

Detailed Description

JY9515 AI Task.

Constructor & Destructor Documentation

◆ JY9515AITask() [1/2]

JY9515.JY9515AITask.JY9515AITask ( int slotNumber )

Create a AI task with slot number.

Parameters
slotNumber Slot Number

◆ JY9515AITask() [2/2]

JY9515.JY9515AITask.JY9515AITask ( string cardName )

Create a AI task with card name.

Parameters
cardName Card Name

Member Function Documentation

◆ AddChannel() [1/6]

void JY9515.JY9515AITask.AddChannel | ( | int | chID,
 |  | AIRange | range,
 |  | Coupling | coupling,
 |  | bool | enableIEPE )

Add one/all channel(s).

Parameters
chID | Channel ID
range | Input Range.
coupling | Coupling Type.
enableIEPE | IEPE Enabled.

◆ AddChannel() [2/6]

void JY9515.JY9515AITask.AddChannel | ( | int | chID,
 |  | double | rangeLow,
 |  | double | rangeHigh,
 |  | Coupling | coupling,
 |  | bool | enableIEPE )

Add one/all channel(s).

Parameters
chID | Channel ID
rangeLow | Input Low Range. -10V/-5V/-2.5V/-1.25V/-0.625V/-0.3125V Optional.
rangeHigh | Input High Range. 10V/5V/2.5V/1.25V/0.625V/0.3125V Optional.
coupling | Coupling Type.
enableIEPE | IEPE Enabled.

◆ AddChannel() [3/6]

void JY9515.JY9515AITask.AddChannel | ( | int[] | chIDs,
 |  | AIRange | range,
 |  | Coupling | coupling,
 |  | bool | enableIEPE )

Add a set of channels and set parameters uniformly.

Parameters
chIDs | Channel ID
range | Input Range.
coupling | Coupling Type.
enableIEPE | IEPE Enabled.

◆ AddChannel() [4/6]

void JY9515.JY9515AITask.AddChannel | ( | int[] | chIDs,
 |  | AIRange[] | range,
 |  | Coupling[] | coupling,
 |  | bool[] | enableIEPE )

Add a set of channels and set parameters uniformly.

Parameters
chIDs | Channel ID
range | Input Range.
coupling | Coupling Type.
enableIEPE | IEPE Enabled.

◆ AddChannel() [5/6]

void JY9515.JY9515AITask.AddChannel | ( | int[] | chIDs,
 |  | double | rangeLow,
 |  | double | rangeHigh,
 |  | Coupling | coupling,
 |  | bool | enableIEPE )

Add a set of channels and set parameters uniformly.

Parameters
chIDs | Channel ID
rangeLow | Input Low Range. -10V/-5V/-2.5V/-1.25V/-0.625V/-0.3125V Optional.
rangeHigh | Input High Range. 10V/5V/2.5V/1.25V/0.625V/0.3125V Optional.
coupling | Coupling Type.
enableIEPE | IEPE Enabled.

◆ AddChannel() [6/6]

void JY9515.JY9515AITask.AddChannel | ( | int[] | chIDs,
 |  | double[] | rangeLow,
 |  | double[] | rangeHigh,
 |  | Coupling[] | coupling,
 |  | bool[] | enableIEPE )

Add a set of channels and set the parameters individually.

Parameters
chIDs | Channel ID
rangeLow | Input Low Range. -10V/-5V/-2.5V/-1.25V/-0.625V/-0.3125V Optional.
rangeHigh | Input High Range. 10V/5V/2.5V/1.25V/0.625V/0.3125V Optional.
coupling | Coupling Type.
enableIEPE | IEPE Enabled.

◆ Commit()

void JY9515.JY9515AITask.Commit ( )

Commit current configuration.

For normal task, this method is optional. When using multi-device synchronization, this method must be called by slave devices, then called by the master device.

◆ DetectIEPEConnection()

Dictionary< int, IEPEConnectionStatus > JY9515.JY9515AITask.DetectIEPEConnection ( )

Perform IEPE sensor connection status detection.

After calling this method, the device will output the excitation current and measure the voltage, and if the voltage is too large, it will be judged as an open circuit, and if the voltage is too small, it will be judged as a short circuit.

Returns
IEPE connection status. Dictionary's key is channel's ID.

◆ GetConversionStatus()

ConversionStatus[] JY9515.JY9515AITask.GetConversionStatus ( )

Get ADC conversion status on all enabled channels.

Returns
ADC conversion status.

◆ ReadData() [1/5]

void JY9515.JY9515AITask.ReadData | ( | IntPtr | dataBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read one or multi-channel data and copy to a unmannaged data buffer.

Parameters
dataBuf | User buffer used to read data.
samplesPerChannel | Number of samples per channel.
timeout | Timeout in ms before generate tiemout exception, timeout =-1 keep waiting until finish.

◆ ReadData() [2/5]

void JY9515.JY9515AITask.ReadData | ( | ref double | dataBuf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read data by columns and copy to buffer.

Parameters
dataBuf | User buffer used to read data.
samplesPerChannel | Number of samples per channel.
timeout | Timeout in ms before generate tiemout exception, timeout =-1 keep waiting until finish.

◆ ReadData() [3/5]

void JY9515.JY9515AITask.ReadData | ( | ref double | dataBuf[,],
 |  | int | timeout = -1 )

Read data by columns and copy to buffer.

Parameters
dataBuf | User buffer used to read data.
timeout | Timeout in ms before generate tiemout exception, timeout =-1 keep waiting until finish.

◆ ReadData() [4/5]

void JY9515.JY9515AITask.ReadData | ( | ref double[] | dataBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read data and copy to buffer.

Parameters
dataBuf | User buffer used to read data.
samplesPerChannel | Number of samples per channel.
timeout | Timeout in ms before generate tiemout exception, timeout =-1 keep waiting until finish.

◆ ReadData() [5/5]

void JY9515.JY9515AITask.ReadData | ( | ref double[] | dataBuf,
 |  | int | timeout = -1 )

Read data and copy to buffer.

Parameters
dataBuf | User buffer used to read data.
timeout | Timeout in ms before generate tiemout exception, timeout =-1 keep waiting until finish.

◆ ReadRawData() [1/4]

void JY9515.JY9515AITask.ReadRawData | ( | IntPtr | dataBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read one or multi-channel raw data and copy to a unmannaged data buffer.

Parameters
dataBuf | User buffer used to read data.
samplesPerChannel | Number of samples per channel.
timeout | Timeout in ms before generate tiemout exception, timeout =-1 keep waiting until finish.

◆ ReadRawData() [2/4]

void JY9515.JY9515AITask.ReadRawData | ( | ref int | dataBuf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read raw data by columns and copy to buffer.

Parameters
dataBuf | User buffer used to read raw data.
samplesPerChannel | Number of samples per channel.
timeout | Timeout in ms before generate tiemout exception, timeout =-1 keep waiting until finish.

◆ ReadRawData() [3/4]

void JY9515.JY9515AITask.ReadRawData | ( | ref int[] | dataBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read raw data and copy to buffer.

Parameters
dataBuf | User buffer used to read raw data.
samplesPerChannel | Number of samples per channel.
timeout | Timeout in ms before generate tiemout exception, timeout = -1 keep waiting until finish.

◆ ReadRawData() [4/4]

void JY9515.JY9515AITask.ReadRawData | ( | ref int[] | dataBuf,
 |  | int | timeout = -1 )

Read raw data and copy to buffer.

Parameters
dataBuf | User buffer used to read raw data.
timeout | Timeout in ms before generate tiemout exception, timeout =-1 keep waiting until finish.

◆ ReadSinglePoint()

void JY9515.JY9515AITask.ReadSinglePoint ( ref double[] dataBuf )

Read one sample (per channel) in unbuffered reading.

Parameters
dataBuf User buffer.

◆ ReadSingleRawPoint()

void JY9515.JY9515AITask.ReadSingleRawPoint ( IntPtr dataBuf )

Read one sample (per channel) in unbuffered reading to unmannaged buffer.

Parameters
dataBuf User buffer.

◆ RemoveChannel() [1/2]

void JY9515.JY9515AITask.RemoveChannel ( int chID )

Delete the channel with the specified channel ID.

Parameters
chID Specified channel ID. chnId = -1: remove all channels.

◆ RemoveChannel() [2/2]

void JY9515.JY9515AITask.RemoveChannel ( int[] chIDs )

Delete a set of channels with the specified channel ID.

Parameters
chIDs Specified channels' ID.

◆ SendSoftwareTrigger()

void JY9515.JY9515AITask.SendSoftwareTrigger ( )

Send a software trigger.

Returns

◆ Start()

void JY9515.JY9515AITask.Start ( )

Start AI task.

◆ StartSync()

void JY9515.JY9515AITask.StartSync ( )

Start the multi-card synchronization process AGAIN.

This method must be called by slave devices, then called by ther master device.

◆ Stop()

void JY9515.JY9515AITask.Stop ( )

Stop AI task.

◆ WaitUntilDone()

bool JY9515.JY9515AITask.WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Only valid when Mode is AIMode.Finite.

Parameters
timeout Wait timeout in ms, or never times out when value is -1.
Returns
Whether the task has been completed

Property Documentation

◆ AvailableSamples

UInt64 JY9515.JY9515AITask.AvailableSamples
get

Number of samples per channel that can be read in the buffer.

◆ Channels

List<AIChannel> JY9515.JY9515AITask.Channels
get

List of enabled channels.

◆ Device

JY9515Device JY9515.JY9515AITask.Device
get

The device instance called by this AI task instance.

◆ DigitalFiltering

AIDigitalFiltering JY9515.JY9515AITask.DigitalFiltering
get

Digital filtering configuration.

◆ DisableCalibration

bool JY9515.JY9515AITask.DisableCalibration
getset

Calibration is disabled when this property is true.

The default value is false.

◆ Mode

AIMode JY9515.JY9515AITask.Mode
getset

Sample mode.

◆ SampleInfo

SampleInfo JY9515.JY9515AITask.SampleInfo
get

Sampling information.

Including the modulation frequency and group delay in the current configuration.

◆ SampleRate

double JY9515.JY9515AITask.SampleRate
getset

Sampling rate per channel in Sa/s.

◆ SamplesToAcquire

int JY9515.JY9515AITask.SamplesToAcquire
getset

Samples to acquire.

◆ SignalExport

AISignalExport JY9515.JY9515AITask.SignalExport
get

Signal export configuration.

◆ State

SamplingState JY9515.JY9515AITask.State
get

Sampling state.

◆ Sync

Sync JY9515.JY9515AITask.Sync
get

Sync configuration.

◆ TransferedSamples

UInt64 JY9515.JY9515AITask.TransferedSamples
get

Number of points per channel that have already been read from the buffer.

◆ Trigger

AITrigger JY9515.JY9515AITask.Trigger
get

AI trigger configuration.

The documentation for this class was generated from the following file:
  • D:/9515/C#/JY9515AITask.cs


9515 C# Programming Manual: Member List

  • JY9515AITask
JY9515.JY9515AITask Member List

This is the complete list of members for JY9515.JY9515AITask, including all inherited members.

AddChannel(int chID, double rangeLow, double rangeHigh, Coupling coupling, bool enableIEPE) | JY9515.JY9515AITask
AddChannel(int[] chIDs, double rangeLow, double rangeHigh, Coupling coupling, bool enableIEPE) | JY9515.JY9515AITask
AddChannel(int[] chIDs, double[] rangeLow, double[] rangeHigh, Coupling[] coupling, bool[] enableIEPE) | JY9515.JY9515AITask
AddChannel(int chID, AIRange range, Coupling coupling, bool enableIEPE) | JY9515.JY9515AITask
AddChannel(int[] chIDs, AIRange range, Coupling coupling, bool enableIEPE) | JY9515.JY9515AITask
AddChannel(int[] chIDs, AIRange[] range, Coupling[] coupling, bool[] enableIEPE) | JY9515.JY9515AITask
AvailableSamples | JY9515.JY9515AITask
Channels | JY9515.JY9515AITask
Commit() | JY9515.JY9515AITask
DetectIEPEConnection() | JY9515.JY9515AITask
Device | JY9515.JY9515AITask
DigitalFiltering | JY9515.JY9515AITask
DisableCalibration | JY9515.JY9515AITask
GetConversionStatus() | JY9515.JY9515AITask
JY9515AITask(int slotNumber) | JY9515.JY9515AITask
JY9515AITask(string cardName) | JY9515.JY9515AITask
Mode | JY9515.JY9515AITask
ReadData(ref double[] dataBuf, int samplesPerChannel, int timeout) | JY9515.JY9515AITask
ReadData(ref double[] dataBuf, int timeout=-1) | JY9515.JY9515AITask
ReadData(ref double[,] dataBuf, int samplesPerChannel, int timeout) | JY9515.JY9515AITask
ReadData(ref double[,] dataBuf, int timeout=-1) | JY9515.JY9515AITask
ReadData(IntPtr dataBuf, int samplesPerChannel, int timeout) | JY9515.JY9515AITask
ReadRawData(ref int[] dataBuf, int samplesPerChannel, int timeout) | JY9515.JY9515AITask
ReadRawData(ref int[] dataBuf, int timeout=-1) | JY9515.JY9515AITask
ReadRawData(ref int[,] dataBuf, int samplesPerChannel, int timeout) | JY9515.JY9515AITask
ReadRawData(IntPtr dataBuf, int samplesPerChannel, int timeout) | JY9515.JY9515AITask
ReadSinglePoint(ref double[] dataBuf) | JY9515.JY9515AITask
ReadSingleRawPoint(IntPtr dataBuf) | JY9515.JY9515AITask
RemoveChannel(int chID) | JY9515.JY9515AITask
RemoveChannel(int[] chIDs) | JY9515.JY9515AITask
SampleInfo | JY9515.JY9515AITask
SampleRate | JY9515.JY9515AITask
SamplesToAcquire | JY9515.JY9515AITask
SendSoftwareTrigger() | JY9515.JY9515AITask
SignalExport | JY9515.JY9515AITask
Start() | JY9515.JY9515AITask
StartSync() | JY9515.JY9515AITask
State | JY9515.JY9515AITask
Stop() | JY9515.JY9515AITask
Sync | JY9515.JY9515AITask
TransferedSamples | JY9515.JY9515AITask
Trigger | JY9515.JY9515AITask
WaitUntilDone(int timeout=-1) | JY9515.JY9515AITask


9515 C# Programming Manual: JY9515.LowPassFilter Class Reference

  • LowPassFilter
Properties | List of all members
JY9515.LowPassFilter Class Referencesealed

Low-Pass Filter Configuration Class. More...

Properties

LPFMode Mode [get, set]
Low-Pass Filter Mode.

Detailed Description

Low-Pass Filter Configuration Class.

Property Documentation

◆ Mode

LPFMode JY9515.LowPassFilter.Mode
getset

Low-Pass Filter Mode.

The documentation for this class was generated from the following file:
  • D:/9515/C#/AIDigitalFiltering.cs


9515 C# Programming Manual: Member List

  • LowPassFilter
JY9515.LowPassFilter Member List

This is the complete list of members for JY9515.LowPassFilter, including all inherited members.

Mode JY9515.LowPassFilter


9515 C# Programming Manual: JY9515.ReferenceClock Class Reference

  • ReferenceClock
Properties | List of all members
JY9515.ReferenceClock Class Referencesealed

Properties

ReferenceClockSource | Source [get, set]
ExternalReferenceClock | External [get]

Detailed Description

参考时钟配置类

Reference Clcok Configuration Class

Property Documentation

◆ External

ExternalReferenceClock JY9515.ReferenceClock.External
get

外部参考时钟源配置。当 ReferenceClock.Source 选择为 ReferenceClockSource.External 时需要配置

External Reference Clock Source. Required when ReferenceClock.Source is ReferenceClockSource.External.

◆ Source

ReferenceClockSource JY9515.ReferenceClock.Source
getset

Reference Clock Source. The default value is ReferenceClockSource.Internal.

The documentation for this class was generated from the following file:
  • D:/9515/C#/ReferenceClock.cs


9515 C# Programming Manual: Member List

  • ReferenceClock
JY9515.ReferenceClock Member List

This is the complete list of members for JY9515.ReferenceClock, including all inherited members.

External | JY9515.ReferenceClock
Source | JY9515.ReferenceClock


9515 C# Programming Manual: JY9515.Sync Class Reference

  • Sync
Properties | List of all members
JY9515.Sync Class Referencesealed

Properties

SyncTopology | Topology [get, set]
Sync Topology Configuration.
SyncTerminal | Terminal [get, set]
Sync Trigger Signal Routing Terminal.
SyncState | State [get]
Sync State.

Detailed Description

同步配置类

Sync Configuration Class

Property Documentation

◆ State

SyncState JY9515.Sync.State
get

Sync State.

Only valid when this is a Slave device.

◆ Terminal

SyncTerminal JY9515.Sync.Terminal
getset

Sync Trigger Signal Routing Terminal.

◆ Topology

SyncTopology JY9515.Sync.Topology
getset

Sync Topology Configuration.

The default value is SyncTopology.Independent.

The documentation for this class was generated from the following file:
  • D:/9515/C#/AISync.cs


9515 C# Programming Manual: Member List

  • Sync
JY9515.Sync Member List

This is the complete list of members for JY9515.Sync, including all inherited members.

State | JY9515.Sync
Terminal | JY9515.Sync
Topology | JY9515.Sync


9515 C# Programming Manual: Class Index

Class Index
A | C | E | F | H | J | L | R | S
A
AIAnalogEdgeComparator (JY9515)
AIAnalogHysteresisComparator (JY9515)
AIAnalogTrigger (JY9515)
AIAnalogWindowComparator (JY9515)
AIChannel (JY9515)
AIDigitalFiltering (JY9515)
AIDigitalTrigger (JY9515)
AISignalExport (JY9515)
AITrigger (JY9515)
C
ConversionStatus (JY9515)
E
ExternalReferenceClock (JY9515)
F
FlatnessCompensation (JY9515)
H
HighPassFilter (JY9515)
J
JY9515AITask (JY9515)
L
LowPassFilter (JY9515)
R
ReferenceClock (JY9515)
S
Sync (JY9515)


9515 C# Programming Manual: D:/9515 Directory Reference

  • File List
  • 9515
9515 Directory Reference

Directories

C#


9515 C# Programming Manual: D:/9515/C# Directory Reference

  • File List
  • 9515
  • C#
C# Directory Reference

Files

AIChannel.cs
AIDigitalFiltering.cs
AISignalExport.cs
AISync.cs
AITrigger.cs
JY9515AITask.cs
ReferenceClock.cs


9515 C# Programming Manual: File List

  • File List
File List
Here is a list of all files with brief descriptions:
[detail level 123]
▼ 9515
▼ C#
AIChannel.cs
AIDigitalFiltering.cs
AISignalExport.cs
AISync.cs
AITrigger.cs
JY9515AITask.cs
ReferenceClock.cs


9515 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • w
Here is a list of all class members with links to the classes they belong to:

- a -

  • Add() : JY9515.AISignalExport
  • AddChannel() : JY9515.JY9515AITask
  • Analog : JY9515.AITrigger
  • AvailableSamples : JY9515.JY9515AITask

- c -

  • ChannelID : JY9515.ConversionStatus
  • Channels : JY9515.JY9515AITask
  • Clear() : JY9515.AISignalExport
  • ClearAll() : JY9515.AISignalExport
  • Commit() : JY9515.JY9515AITask
  • Comparator : JY9515.AIAnalogTrigger
  • Condition : JY9515.AIAnalogWindowComparator
  • Coupling : JY9515.AIChannel
  • CRCError : JY9515.ConversionStatus
  • CutoffFrequency : JY9515.HighPassFilter

- d -

  • DetectIEPEConnection() : JY9515.JY9515AITask
  • Device : JY9515.JY9515AITask
  • Digital : JY9515.AITrigger
  • DigitalFiltering : JY9515.JY9515AITask
  • DisableCalibration : JY9515.JY9515AITask
  • DisableChannel() : JY9515.HighPassFilter

- e -

  • Edge : JY9515.AIAnalogTrigger, JY9515.AIDigitalTrigger
  • EnableChannel() : JY9515.HighPassFilter
  • Enabled : JY9515.FlatnessCompensation
  • ErrorFlagged : JY9515.ConversionStatus
  • External : JY9515.ReferenceClock

- f -

  • FilterEnabledChannels : JY9515.HighPassFilter
  • FilterSuturated : JY9515.ConversionStatus
  • Frequency : JY9515.ExternalReferenceClock

- g -

  • GetConversionStatus() : JY9515.JY9515AITask

- h -

  • HighThreshold : JY9515.AIAnalogHysteresisComparator, JY9515.AIAnalogWindowComparator
  • HPF : JY9515.AIDigitalFiltering
  • Hysteresis : JY9515.AIAnalogTrigger

- i -

  • ID : JY9515.AIChannel
  • IEPEEnabled : JY9515.AIChannel

- j -

  • JY9515AITask() : JY9515.JY9515AITask

- l -

  • LowThreshold : JY9515.AIAnalogHysteresisComparator, JY9515.AIAnalogWindowComparator
  • LPF : JY9515.AIDigitalFiltering

- m -

  • Mode : JY9515.AITrigger, JY9515.JY9515AITask, JY9515.LowPassFilter

- o -

  • Order : JY9515.HighPassFilter

- p -

  • PreTriggerSamples : JY9515.AITrigger

- r -

  • Range : JY9515.AIChannel
  • RangeHigh : JY9515.AIChannel
  • RangeLow : JY9515.AIChannel
  • RawDataScaleFactor : JY9515.AIChannel
  • ReadData() : JY9515.JY9515AITask
  • ReadRawData() : JY9515.JY9515AITask
  • ReadSinglePoint() : JY9515.JY9515AITask
  • ReadSingleRawPoint() : JY9515.JY9515AITask
  • RemoveChannel() : JY9515.JY9515AITask
  • ReTriggerCount : JY9515.AITrigger

- s -

  • SampleInfo : JY9515.JY9515AITask
  • SampleRate : JY9515.JY9515AITask
  • SamplesToAcquire : JY9515.JY9515AITask
  • SendSoftwareTrigger() : JY9515.JY9515AITask
  • SignalExport : JY9515.JY9515AITask
  • Slope : JY9515.AIAnalogEdgeComparator, JY9515.AIAnalogHysteresisComparator
  • Source : JY9515.AIAnalogTrigger, JY9515.AIDigitalTrigger, JY9515.ReferenceClock
  • Start() : JY9515.JY9515AITask
  • StartSync() : JY9515.JY9515AITask
  • State : JY9515.JY9515AITask, JY9515.Sync
  • Stop() : JY9515.JY9515AITask
  • Sync : JY9515.JY9515AITask

- t -

  • Terminal : JY9515.ExternalReferenceClock, JY9515.Sync
  • Threshold : JY9515.AIAnalogEdgeComparator
  • Topology : JY9515.Sync
  • TransferedSamples : JY9515.JY9515AITask
  • Trigger : JY9515.JY9515AITask
  • Type : JY9515.AITrigger

- w -

  • WaitUntilDone() : JY9515.JY9515AITask
  • Window : JY9515.AIAnalogTrigger


9515 C# Programming Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • Properties
  • a
  • c
  • d
  • e
  • g
  • j
  • r
  • s
  • w
Here is a list of all functions with links to the classes they belong to:

- a -

  • Add() : JY9515.AISignalExport
  • AddChannel() : JY9515.JY9515AITask

- c -

  • Clear() : JY9515.AISignalExport
  • ClearAll() : JY9515.AISignalExport
  • Commit() : JY9515.JY9515AITask

- d -

  • DetectIEPEConnection() : JY9515.JY9515AITask
  • DisableChannel() : JY9515.HighPassFilter

- e -

  • EnableChannel() : JY9515.HighPassFilter

- g -

  • GetConversionStatus() : JY9515.JY9515AITask

- j -

  • JY9515AITask() : JY9515.JY9515AITask

- r -

  • ReadData() : JY9515.JY9515AITask
  • ReadRawData() : JY9515.JY9515AITask
  • ReadSinglePoint() : JY9515.JY9515AITask
  • ReadSingleRawPoint() : JY9515.JY9515AITask
  • RemoveChannel() : JY9515.JY9515AITask

- s -

  • SendSoftwareTrigger() : JY9515.JY9515AITask
  • Start() : JY9515.JY9515AITask
  • StartSync() : JY9515.JY9515AITask
  • Stop() : JY9515.JY9515AITask

- w -

  • WaitUntilDone() : JY9515.JY9515AITask


9515 C# Programming Manual: Class Members - Properties

  • All
  • Functions
  • Variables
  • Properties
  • a
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • w
Here is a list of all properties with links to the classes they belong to:

- a -

  • Analog : JY9515.AITrigger
  • AvailableSamples : JY9515.JY9515AITask

- c -

  • ChannelID : JY9515.ConversionStatus
  • Channels : JY9515.JY9515AITask
  • Comparator : JY9515.AIAnalogTrigger
  • Condition : JY9515.AIAnalogWindowComparator
  • Coupling : JY9515.AIChannel
  • CRCError : JY9515.ConversionStatus
  • CutoffFrequency : JY9515.HighPassFilter

- d -

  • Device : JY9515.JY9515AITask
  • Digital : JY9515.AITrigger
  • DigitalFiltering : JY9515.JY9515AITask
  • DisableCalibration : JY9515.JY9515AITask

- e -

  • Edge : JY9515.AIAnalogTrigger, JY9515.AIDigitalTrigger
  • Enabled : JY9515.FlatnessCompensation
  • ErrorFlagged : JY9515.ConversionStatus
  • External : JY9515.ReferenceClock

- f -

  • FilterEnabledChannels : JY9515.HighPassFilter
  • FilterSuturated : JY9515.ConversionStatus
  • Frequency : JY9515.ExternalReferenceClock

- h -

  • HPF : JY9515.AIDigitalFiltering
  • Hysteresis : JY9515.AIAnalogTrigger

- i -

  • ID : JY9515.AIChannel
  • IEPEEnabled : JY9515.AIChannel

- l -

  • LPF : JY9515.AIDigitalFiltering

- m -

  • Mode : JY9515.AITrigger, JY9515.JY9515AITask, JY9515.LowPassFilter

- o -

  • Order : JY9515.HighPassFilter

- p -

  • PreTriggerSamples : JY9515.AITrigger

- r -

  • Range : JY9515.AIChannel
  • RangeHigh : JY9515.AIChannel
  • RangeLow : JY9515.AIChannel
  • RawDataScaleFactor : JY9515.AIChannel
  • ReTriggerCount : JY9515.AITrigger

- s -

  • SampleInfo : JY9515.JY9515AITask
  • SampleRate : JY9515.JY9515AITask
  • SamplesToAcquire : JY9515.JY9515AITask
  • SignalExport : JY9515.JY9515AITask
  • Slope : JY9515.AIAnalogEdgeComparator, JY9515.AIAnalogHysteresisComparator
  • Source : JY9515.AIAnalogTrigger, JY9515.AIDigitalTrigger, JY9515.ReferenceClock
  • State : JY9515.JY9515AITask, JY9515.Sync
  • Sync : JY9515.JY9515AITask

- t -

  • Terminal : JY9515.ExternalReferenceClock, JY9515.Sync
  • Topology : JY9515.Sync
  • TransferedSamples : JY9515.JY9515AITask
  • Trigger : JY9515.JY9515AITask
  • Type : JY9515.AITrigger

- w -

  • Window : JY9515.AIAnalogTrigger


9515 C# Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Properties
Here is a list of all variables with links to the classes they belong to:
  • HighThreshold : JY9515.AIAnalogHysteresisComparator, JY9515.AIAnalogWindowComparator
  • LowThreshold : JY9515.AIAnalogHysteresisComparator, JY9515.AIAnalogWindowComparator
  • Threshold : JY9515.AIAnalogEdgeComparator


9515 C# Programming Manual: Main Page

9515 C# Programming Manual Documentation


9515 C# Programming Manual: JY9515 Namespace Reference

  • Package List
  • Package Members
Classes | Enumerations
JY9515 Namespace Reference

Classes

class | AIAnalogEdgeComparator
AI Analog Edge Comparator. More...
class | AIAnalogHysteresisComparator
AI Analog Hysteresis Comparator. More...
class | AIAnalogTrigger
AI Analog Trigger. More...
class | AIAnalogWindowComparator
AI Analog Window Comparator. More...
class | AIChannel
AI Channel. More...
class | AIDigitalFiltering
AI Digital Filtering Connfiguration Class. More...
class | AIDigitalTrigger
AI Digital trigger params. More...
class | AISignalExport
AI Signal Export Class. More...
class | AITrigger
AI Trigger params. More...
class | ConversionStatus
ADC Convesion Status Class. More...
class | EnumExtension
JY9515 Enum Extension.
class | ExternalReferenceClock
class | FlatnessCompensation
Flatness Compensation Parameters. More...
class | HighPassFilter
High-Pass Filter Configuration Class. More...
class | JY9515AITask
JY9515 AI Task. More...
class | LowPassFilter
Low-Pass Filter Configuration Class. More...
class | ReferenceClock
class | Sync

Enumerations

enum AIRange {
_10V = JY9515Import.JY9515_Range_10V , _5V = JY9515Import.JY9515_Range_5V , _2p5V = JY9515Import.JY9515_Range_2p5V , _1p25V = JY9515Import.JY9515_Range_1p25V ,
_0p625V = JY9515Import.JY9515_Range_0p625V , _0p3125V = JY9515Import.JY9515_Range_0p3125V
}
AI voltage range. More...
enum | Coupling { AC = JY9515Import.JY9515_Coupling_AC , DC = JY9515Import.JY9515_Coupling_DC }
Coupling. More...
enum | ChoppingFrequency { fMod32 = JY9515Import.JY9515_ADCChopping_fMod32 , fMod8 = JY9515Import.JY9517_ADCChopping_fMod8 }
Modulator Chopping Frequency Enum. More...
enum | LPFMode { Normal = 0 , WideBandwidth = 1 }
Low-Pass Filter Mode Enum. More...
enum | HPFOrder { OneOrder = 1 , TwoOrder = 2 }
High-pass filter order. More...
enum AISignalExportSource {
SampleClock = JY9515Import.JY9515_EXPORT_SAMPLE_CLOCK , Sync = JY9515Import.JY9515_EXPORT_SYNC , ReadyForStartTrigger = JY9515Import.JY9515_EXPORT_RX_READY_FOR_REF_TRIG , StartTrigger = JY9515Import.JY9515_EXPORT_RX_REF_TRIG ,
EndOfRecord = JY9515Import.JY9515_EXPORT_RX_END_OF_RECORD , EndOfAcquisition = JY9515Import.JY9515_EXPORT_RX_ENGINE_END
}
AI Signal Export Source Enum. More...
enum SignalExportDestination {
Ext_Trig = JY9515Import.JY9515_DigitalTriggerSource_External , PXI_Trig0 = JY9515Import.JY9515_DigitalTriggerSource_BUS_0 , PXI_Trig1 = JY9515Import.JY9515_DigitalTriggerSource_BUS_1 , PXI_Trig2 = JY9515Import.JY9515_DigitalTriggerSource_BUS_2 ,
PXI_Trig3 = JY9515Import.JY9515_DigitalTriggerSource_BUS_3 , PXI_Trig4 = JY9515Import.JY9515_DigitalTriggerSource_BUS_4 , PXI_Trig5 = JY9515Import.JY9515_DigitalTriggerSource_BUS_5 , PXI_Trig6 = JY9515Import.JY9515_DigitalTriggerSource_BUS_6 ,
PXI_Trig7 = JY9515Import.JY9515_DigitalTriggerSource_BUS_7 , PXI_Star = JY9515Import.JY9515_DigitalTriggerSource_STAR
}
Signal Export Destination Enum. More...
enum | SyncTopology { Independent = JY9515Import.JY9515_SyncMode_Solo , Master = JY9515Import.JY9515_SyncMode_Master , Slave = JY9515Import.JY9515_SyncMode_Slave }
Multi-Device Sync Topology. More...
enum SyncTerminal {
Ext_Trig = JY9515Import.JY9515_DigitalTriggerSource_External , PXI_Trig0 = JY9515Import.JY9515_DigitalTriggerSource_BUS_0 , PXI_Trig1 = JY9515Import.JY9515_DigitalTriggerSource_BUS_1 , PXI_Trig2 = JY9515Import.JY9515_DigitalTriggerSource_BUS_2 ,
PXI_Trig3 = JY9515Import.JY9515_DigitalTriggerSource_BUS_3 , PXI_Trig4 = JY9515Import.JY9515_DigitalTriggerSource_BUS_4 , PXI_Trig5 = JY9515Import.JY9515_DigitalTriggerSource_BUS_5 , PXI_Trig6 = JY9515Import.JY9515_DigitalTriggerSource_BUS_6 ,
PXI_Trig7 = JY9515Import.JY9515_DigitalTriggerSource_BUS_7 , PXI_Star = JY9515Import.JY9515_DigitalTriggerSource_STAR
}
AI digital trigger source enum type. More...
enum | SyncState { WaitingSync , Synchronized , Invalid }
Sync State. More...
enum | AITriggerMode { Start , Reference }
AI trigger mode enum type. More...
enum | AITriggerType { Immediately = JY9515Import.JY9515_TriggerType_Immediately , Digital = JY9515Import.JY9515_TriggerType_Digital , Software = JY9515Import.JY9515_TriggerType_Software , Analog = JY9515Import.JY9515_TriggerType_Analog }
AI trigger type enum type. More...
enum AIDigitalTriggerSource {
Ext_Trig = JY9515Import.JY9515_DigitalTriggerSource_External , PXI_Trig0 = JY9515Import.JY9515_DigitalTriggerSource_BUS_0 , PXI_Trig1 = JY9515Import.JY9515_DigitalTriggerSource_BUS_1 , PXI_Trig2 = JY9515Import.JY9515_DigitalTriggerSource_BUS_2 ,
PXI_Trig3 = JY9515Import.JY9515_DigitalTriggerSource_BUS_3 , PXI_Trig4 = JY9515Import.JY9515_DigitalTriggerSource_BUS_4 , PXI_Trig5 = JY9515Import.JY9515_DigitalTriggerSource_BUS_5 , PXI_Trig6 = JY9515Import.JY9515_DigitalTriggerSource_BUS_6 ,
PXI_Trig7 = JY9515Import.JY9515_DigitalTriggerSource_BUS_7 , PXI_Star = JY9515Import.JY9515_DigitalTriggerSource_STAR
}
AI digital trigger source enum type. More...
enum | AIDigitalTriggerEdge { Rising = JY9515Import.JY9515_DigitalTriggerEdge_Rising , Falling = JY9515Import.JY9515_DigitalTriggerEdge_Falling }
AI digital trigger edge enum type. More...
enum AIAnalogTriggerSource {
Channel_0 , Channel_1 , Channel_2 , Channel_3 ,
Channel_4 , Channel_5 , Channel_6 , Channel_7
}
AI Analog Trigger Source. More...
enum | AIAnalogTriggerComparator { Edge , Hysteresis , Window }
AI Analog Trigger Comparator. More...
enum | AIAnalogTriggerEdge { Rising , Falling }
AI Analog Trigger Edge. More...
enum | AIAnalogWindowCondition { Entering , Leaving }
AI Analog Window Trigger Condition. More...
enum | AIMode { Finite = JY9515Import.JY9515_AI_Finite , Continuous = JY9515Import.JY9515_AI_Continuous , Single = JY9515Import.JY9515_AI_Single }
AI mode enum type. More...
enum SamplingState {
Idle = 1 << 0 , WaitingForStart = 1 << 1 , PreSampling = 1 << 2 , WaitingForRefTrigger = 1 << 3 ,
PostSampling = 1 << 4 , RecordCompleted = 1 << 5 , WaitingForAdvanceTrigger = 1 << 6 , Done = 1 << 7
}
Sampling State Enum. More...
enum | IEPEConnectionStatus { Normal = 0 , OpenCircuit = 1 , ShortCircuit = 2 }
IEPE Connection Status. More...
enum | ExternalReferenceClockTerminal { PXIe_Clk100 = JY9515Import.JY9515_PXIe_Clk_100M }
enum | ReferenceClockSource { Internal = 0 , External = 1 }

Enumeration Type Documentation

◆ AIAnalogTriggerComparator

enum JY9515.AIAnalogTriggerComparator

AI Analog Trigger Comparator.

Enumerator
Edge | Edge Comparator.
Hysteresis | Hysteresis Comparator.
Window | Window Comparator.

◆ AIAnalogTriggerEdge

enum JY9515.AIAnalogTriggerEdge

AI Analog Trigger Edge.

Enumerator
Rising | Rising.
Falling | Falling.

◆ AIAnalogTriggerSource

enum JY9515.AIAnalogTriggerSource

AI Analog Trigger Source.

Enumerator
Channel_0 | Channel 0.
Channel_1 | Channel 1.
Channel_2 | Channel 2.
Channel_3 | Channel 3.
Channel_4 | Channel 4.
Channel_5 | Channel 5.
Channel_6 | Channel 6.
Channel_7 | Channel 7.

◆ AIAnalogWindowCondition

enum JY9515.AIAnalogWindowCondition

AI Analog Window Trigger Condition.

Enumerator
Entering | Rising.
Leaving | Falling.

◆ AIDigitalTriggerEdge

enum JY9515.AIDigitalTriggerEdge

AI digital trigger edge enum type.

Enumerator
Rising | Rising edge.
Falling | Falling edge.

◆ AIDigitalTriggerSource

enum JY9515.AIDigitalTriggerSource

AI digital trigger source enum type.

Enumerator
Ext_Trig | External Trigger.
PXI_Trig0 | PXI Trigger 0.
PXI_Trig1 | PXI Trigger 1.
PXI_Trig2 | PXI Trigger 2.
PXI_Trig3 | PXI Trigger 3.
PXI_Trig4 | PXI Trigger 4.
PXI_Trig5 | PXI Trigger 5.
PXI_Trig6 | PXI Trigger 6.
PXI_Trig7 | PXI Trigger 7.
PXI_Star | PXI Star.

◆ AIMode

enum JY9515.AIMode

AI mode enum type.

Enumerator
Finite | Finite mode.
Continuous | Continuous mode.
Single | Single point mode.

◆ AIRange

enum JY9515.AIRange

AI voltage range.

Enumerator
_10V | ±10V
_5V | ±5V
_2p5V | ±2.5V
_1p25V | ±1.25V
_0p625V | ±0.625V
_0p3125V | ±0.3125V

◆ AISignalExportSource

enum JY9515.AISignalExportSource

AI Signal Export Source Enum.

Enumerator
SampleClock | AI Sample Clock.
Sync | Sync Signal from Master to Slave(s)
ReadyForStartTrigger | Ready for Trigger.
StartTrigger | Trigger Out.
EndOfRecord | End of Record.
EndOfAcquisition | End of Acquisition.

◆ AITriggerMode

enum JY9515.AITriggerMode

AI trigger mode enum type.

Enumerator
Start | Start trigger.
Reference | Reference trigger. Only valid in the Finite mode.

◆ AITriggerType

enum JY9515.AITriggerType

AI trigger type enum type.

Enumerator
Immediately | Immediately, no trigger.
Digital | Digital trigger.
Software | Software trigger.
Analog | Analog trigger.

◆ ChoppingFrequency

enum JY9515.ChoppingFrequency

Modulator Chopping Frequency Enum.

Enumerator
fMod32 | Chop at fMod/32.
fMod8 | Chop at fMod/8. Default.

◆ Coupling

enum JY9515.Coupling

Coupling.

Enumerator
AC | AC.
DC | DC.

◆ ExternalReferenceClockTerminal

enum JY9515.ExternalReferenceClockTerminal

外部参考时钟输入端口

External Reference Clcok Terminal

Enumerator
PXIe_Clk100

PXIe_DStarA

PXIe_DStarA

◆ HPFOrder

enum JY9515.HPFOrder

High-pass filter order.

Enumerator
OneOrder | One-order.
TwoOrder | Two-order.

◆ IEPEConnectionStatus

enum JY9515.IEPEConnectionStatus

IEPE Connection Status.

Enumerator
Normal | Normal.
OpenCircuit | Open circuit.
ShortCircuit | Short circuit.

◆ LPFMode

enum JY9515.LPFMode

Low-Pass Filter Mode Enum.

Enumerator
Normal | Normal Mode. It has 0.4Fs bandwidth, medium latency, and a maximum sample rate of 256kSa/s
WideBandwidth | Wide Bandwidth Mode. It has 0.4535Fs bandwidth, high latency, and a maximum sample rate of 128kSa/s

◆ ReferenceClockSource

enum JY9515.ReferenceClockSource

Reference Clock Source

Enumerator
Internal | Internal Reference Clock
External | External Reference Clock

◆ SamplingState

enum JY9515.SamplingState

Sampling State Enum.

Enumerator
Idle | Idle.
WaitingForStart | Waiting for start trigger.
PreSampling | Pre-sampling.
WaitingForRefTrigger | Waiting for reference trigger.
PostSampling | Post-sampling.
RecordCompleted | Record completed.
WaitingForAdvanceTrigger | Waiting for advance trigger.
Done | Done.

◆ SignalExportDestination

enum JY9515.SignalExportDestination

Signal Export Destination Enum.

Enumerator
Ext_Trig | External Trigger.
PXI_Trig0 | PXI Trigger 0.
PXI_Trig1 | PXI Trigger 1.
PXI_Trig2 | PXI Trigger 2.
PXI_Trig3 | PXI Trigger 3.
PXI_Trig4 | PXI Trigger 4.
PXI_Trig5 | PXI Trigger 5.
PXI_Trig6 | PXI Trigger 6.
PXI_Trig7 | PXI Trigger 7.
PXI_Star | PXI Star.

◆ SyncState

enum JY9515.SyncState

Sync State.

Enumerator
WaitingSync | Waiting for Sync signal as a Slave device.
Synchronized | Already received Sync signal as a Slave device.
Invalid | This status is invalid when multi-card synchronization is not enabled or when the device is a Master device.

◆ SyncTerminal

enum JY9515.SyncTerminal

AI digital trigger source enum type.

Enumerator
Ext_Trig | External Trigger.
PXI_Trig0 | PXI Trigger 0.
PXI_Trig1 | PXI Trigger 1.
PXI_Trig2 | PXI Trigger 2.
PXI_Trig3 | PXI Trigger 3.
PXI_Trig4 | PXI Trigger 4.
PXI_Trig5 | PXI Trigger 5.
PXI_Trig6 | PXI Trigger 6.
PXI_Trig7 | PXI Trigger 7.
PXI_Star | PXI Star.

◆ SyncTopology

enum JY9515.SyncTopology

Multi-Device Sync Topology.

Enumerator
Independent | Independent.
Master | As the master device in the master-slave synchronization.
Slave | As the slave card in the master-slave synchronization.


9515 C# Programming Manual: Package Members

  • Package List
  • Package Members
  • All
  • Enumerations
Here is a list of all namespace members with links to the namespace documentation for each member:
  • AIAnalogTriggerComparator : JY9515
  • AIAnalogTriggerEdge : JY9515
  • AIAnalogTriggerSource : JY9515
  • AIAnalogWindowCondition : JY9515
  • AIDigitalTriggerEdge : JY9515
  • AIDigitalTriggerSource : JY9515
  • AIMode : JY9515
  • AIRange : JY9515
  • AISignalExportSource : JY9515
  • AITriggerMode : JY9515
  • AITriggerType : JY9515
  • ChoppingFrequency : JY9515
  • Coupling : JY9515
  • ExternalReferenceClockTerminal : JY9515
  • HPFOrder : JY9515
  • IEPEConnectionStatus : JY9515
  • LPFMode : JY9515
  • ReferenceClockSource : JY9515
  • SamplingState : JY9515
  • SignalExportDestination : JY9515
  • SyncState : JY9515
  • SyncTerminal : JY9515
  • SyncTopology : JY9515


9515 C# Programming Manual: Package Members

  • Package List
  • Package Members
  • All
  • Enumerations
Here is a list of all namespace enums with links to the namespace documentation for each enum:
  • AIAnalogTriggerComparator : JY9515
  • AIAnalogTriggerEdge : JY9515
  • AIAnalogTriggerSource : JY9515
  • AIAnalogWindowCondition : JY9515
  • AIDigitalTriggerEdge : JY9515
  • AIDigitalTriggerSource : JY9515
  • AIMode : JY9515
  • AIRange : JY9515
  • AISignalExportSource : JY9515
  • AITriggerMode : JY9515
  • AITriggerType : JY9515
  • ChoppingFrequency : JY9515
  • Coupling : JY9515
  • ExternalReferenceClockTerminal : JY9515
  • HPFOrder : JY9515
  • IEPEConnectionStatus : JY9515
  • LPFMode : JY9515
  • ReferenceClockSource : JY9515
  • SamplingState : JY9515
  • SignalExportDestination : JY9515
  • SyncState : JY9515
  • SyncTerminal : JY9515
  • SyncTopology : JY9515


9515 C# Programming Manual: Package List

  • Package List
  • Package Members
Package List
Here are the packages with brief descriptions (if available):
N JY9515