9516 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/9516 Directory Reference

9516 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 9516
9516 Directory Reference

Files

JY9516CoreOOAITask.h
JY9516CoreOOCommon.h
JY9516CoreOODevice.h
JY9516CoreOOLog.h
Generated by doxygen 1.13.2


9516 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/9516/JY9516CoreOOAITask.h File Reference

  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 9516
Classes | Namespaces | Macros | Enumerations | Variables
JY9516CoreOOAITask.h File Reference
#include <memory>
#include <mutex>
#include <map>
#include <fstream>
#include <cstring>
#include <cstddef>
#include "JY9516CoreOOCommon.h"
#include "JY9516CoreOODevice.h"

Classes

class | JY9516CoreOO::JY9516CoreOOAITask
aiTask类 More...
class | JY9516CoreOO::AIChannel
AI Channel. More...
class | JY9516CoreOO::AITrigger
class | JY9516CoreOO::AIDigitalTrigger
AI Digital trigger params. More...
class | JY9516CoreOO::AIAnalogHysteresisComparator
AI Analog Hysteresis Comparator. More...
class | JY9516CoreOO::AIAnalogWindowComparator
AI Analog Window Comparator. More...
class | JY9516CoreOO::AIAnalogEdgeComparator
AI Analog Edge Comparator. More...
class | JY9516CoreOO::AIAnalogTrigger
AI Analog Trigger. More...
class | JY9516CoreOO::AISignalExport
AI Signal Export Class. More...
class | JY9516CoreOO::AISync
class | JY9516CoreOO::LowPassFilter
class | JY9516CoreOO::HighPassFilter
High-Pass Filter Configuration Class. More...
class | JY9516CoreOO::FlatnessCompensation
Flatness Compensation Parameters. More...
class | JY9516CoreOO::AIDigitalFiltering
AI Digital Filtering Connfiguration Class. More...
class | JY9516CoreOO::JY9516DAC
JY9516 DAC Configuration. More...
class | JY9516CoreOO::ConversionStatus
Get ADC conversion status on all enabled channels. More...

Namespaces

namespace JY9516CoreOO

Macros

#define _CRT_SECURE_NO_WARNINGS

Enumerations

enum class | JY9516CoreOO::AIMode { JY9516CoreOO::Finite , JY9516CoreOO::Continuous , JY9516CoreOO::Single }
enum class | JY9516CoreOO::IEPEConnectionStatus { JY9516CoreOO::Normal = 0 , JY9516CoreOO::OpenCircuit = 1 , JY9516CoreOO::ShortCircuit = 2 }
IEPE Connection Status. More...
enum class JY9516CoreOO::AIRange {
JY9516CoreOO::_10V = JY9516Import::JY9516_Range_10V , JY9516CoreOO::_5V = JY9516Import::JY9516_Range_5V , JY9516CoreOO::_2p5V = JY9516Import::JY9516_Range_2p5V , JY9516CoreOO::_1p25V = JY9516Import::JY9516_Range_1p25V ,
JY9516CoreOO::_0p625V = JY9516Import::JY9516_Range_0p625V , JY9516CoreOO::_0p3125V = JY9516Import::JY9516_Range_0p3125V
}
enum class | JY9516CoreOO::Coupling { JY9516CoreOO::AC = JY9516Import::JY9516_Coupling_AC , JY9516CoreOO::DC = JY9516Import::JY9516_Coupling_DC }
Coupling. More...
enum class | JY9516CoreOO::AITriggerType { JY9516CoreOO::Immediately = JY9516Import::JY9516_TriggerType_Immediately , JY9516CoreOO::Digital = JY9516Import::JY9516_TriggerType_Digital , JY9516CoreOO::Software = JY9516Import::JY9516_TriggerType_Software , JY9516CoreOO::Analog = JY9516Import::JY9516_TriggerType_Analog }
AI trigger type enum type. More...
enum class | JY9516CoreOO::AITriggerMode { JY9516CoreOO::Start , JY9516CoreOO::Reference }
AI trigger mode enum type. More...
enum class JY9516CoreOO::AIAnalogTriggerSource {
JY9516CoreOO::Channel_0 , JY9516CoreOO::Channel_1 , JY9516CoreOO::Channel_2 , JY9516CoreOO::Channel_3 ,
JY9516CoreOO::Channel_4 , JY9516CoreOO::Channel_5 , JY9516CoreOO::Channel_6 , JY9516CoreOO::Channel_7 ,
JY9516CoreOO::Channel_8 , JY9516CoreOO::Channel_9 , JY9516CoreOO::Channel_10 , JY9516CoreOO::Channel_11 ,
JY9516CoreOO::Channel_12 , JY9516CoreOO::Channel_13 , JY9516CoreOO::Channel_14 , JY9516CoreOO::Channel_15 ,
JY9516CoreOO::Channel_16 , JY9516CoreOO::Channel_17 , JY9516CoreOO::Channel_18 , JY9516CoreOO::Channel_19 ,
JY9516CoreOO::Channel_20 , JY9516CoreOO::Channel_21 , JY9516CoreOO::Channel_22 , JY9516CoreOO::Channel_23 ,
JY9516CoreOO::Channel_24 , JY9516CoreOO::Channel_25 , JY9516CoreOO::Channel_26 , JY9516CoreOO::Channel_27 ,
JY9516CoreOO::Channel_28 , JY9516CoreOO::Channel_29 , JY9516CoreOO::Channel_30 , JY9516CoreOO::Channel_31
}
Analog Trigger source. More...
enum class JY9516CoreOO::AIDigitalTriggerSource {
JY9516CoreOO::Ext_Trig = JY9516Import::JY9516_DigitalTriggerSource_External , JY9516CoreOO::PXI_Trig0 = JY9516Import::JY9516_DigitalTriggerSource_BUS_0 , JY9516CoreOO::PXI_Trig1 = JY9516Import::JY9516_DigitalTriggerSource_BUS_1 , JY9516CoreOO::PXI_Trig2 = JY9516Import::JY9516_DigitalTriggerSource_BUS_2 ,
JY9516CoreOO::PXI_Trig3 = JY9516Import::JY9516_DigitalTriggerSource_BUS_3 , JY9516CoreOO::PXI_Trig4 = JY9516Import::JY9516_DigitalTriggerSource_BUS_4 , JY9516CoreOO::PXI_Trig5 = JY9516Import::JY9516_DigitalTriggerSource_BUS_5 , JY9516CoreOO::PXI_Trig6 = JY9516Import::JY9516_DigitalTriggerSource_BUS_6 ,
JY9516CoreOO::PXI_Trig7 = JY9516Import::JY9516_DigitalTriggerSource_BUS_7 , JY9516CoreOO::PXI_Star = JY9516Import::JY9516_DigitalTriggerSource_STAR
}
AI digital trigger source enum type. More...
enum class | JY9516CoreOO::AIDigitalTriggerEdge { JY9516CoreOO::Rising = 0x0 , JY9516CoreOO::Falling = 0x1 }
AI Digital Trigger Edge enum type. More...
enum class | JY9516CoreOO::AIAnalogTriggerEdge { JY9516CoreOO::Rising , JY9516CoreOO::Falling }
AI Analog Trigger Edge. More...
enum class | JY9516CoreOO::AIAnalogWindowCondition { JY9516CoreOO::Entering , JY9516CoreOO::Leaving }
AI Analog Window Trigger Condition. More...
enum class | JY9516CoreOO::AIAnalogTriggerComparator { JY9516CoreOO::Edge , JY9516CoreOO::Hysteresis , JY9516CoreOO::Window }
AI Analog Trigger Comparator. More...
enum class JY9516CoreOO::AISignalExportSource {
JY9516CoreOO::SampleClock = JY9516Import::JY9516_EXPORT_SAMPLE_CLOCK , JY9516CoreOO::Sync = JY9516Import::JY9516_EXPORT_SYNC , JY9516CoreOO::ReadyForStartTrigger = JY9516Import::JY9516_EXPORT_RX_READY_FOR_REF_TRIG , JY9516CoreOO::StartTrigger = JY9516Import::JY9516_EXPORT_RX_REF_TRIG ,
JY9516CoreOO::EndOfRecord = JY9516Import::JY9516_EXPORT_RX_END_OF_RECORD , JY9516CoreOO::EndOfAcquisition = JY9516Import::JY9516_EXPORT_RX_ENGINE_END
}
AI Signal Export Source Enum. More...
enum class | JY9516CoreOO::SyncTopology { JY9516CoreOO::Independent , JY9516CoreOO::Master , JY9516CoreOO::Slave }
Synchronization board configuration. More...
enum JY9516CoreOO::SyncTerminal {
JY9516CoreOO::Ext_Trig , JY9516CoreOO::PXI_Trig0 , JY9516CoreOO::PXI_Trig1 , JY9516CoreOO::PXI_Trig2 ,
JY9516CoreOO::PXI_Trig3 , JY9516CoreOO::PXI_Trig4 , JY9516CoreOO::PXI_Trig5 , JY9516CoreOO::PXI_Trig6 ,
JY9516CoreOO::PXI_Trig7 , JY9516CoreOO::PXI_Star
}
AI digital trigger source enum type. More...
enum | JY9516CoreOO::SyncState { JY9516CoreOO::WaitingSync , JY9516CoreOO::Synchronized , JY9516CoreOO::Invalid }
Sync State. More...
enum | JY9516CoreOO::HPFOrder { JY9516CoreOO::OneOrder = 1 , JY9516CoreOO::TwoOrder = 2 }
High-pass filter order. More...
enum | JY9516CoreOO::ChoppingFrequency { JY9516CoreOO::fMod32 , JY9516CoreOO::fMod8 }
Modulator Chopping Frequency Enum. More...
enum class JY9516CoreOO::SamplingState {
JY9516CoreOO::Idle = 1 << 0 , JY9516CoreOO::WaitingForStart = 1 << 1 , JY9516CoreOO::PreSampling = 1 << 2 , JY9516CoreOO::WaitingForRefTrigger = 1 << 3 ,
JY9516CoreOO::PostSampling = 1 << 4 , JY9516CoreOO::RecordCompleted = 1 << 5 , JY9516CoreOO::WaitingForAdvanceTrigger = 1 << 6 , JY9516CoreOO::Done = 1 << 7
}
Sampling State Enum. More...

Variables

const std::map< int, std::string > JY9516CoreOO::AIRangeDescriptions

Macro Definition Documentation

◆ _CRT_SECURE_NO_WARNINGS

#define _CRT_SECURE_NO_WARNINGS


9516 C++ Programming Manual: JY9516CoreOO::JY9516CoreOOAITask Class Reference

  • Class List
  • Class Index
  • Class Members
  • JY9516CoreOO
  • JY9516CoreOOAITask
Public Member Functions | Public Attributes | List of all members
JY9516CoreOO::JY9516CoreOOAITask Class Reference

aiTask类 More...

#include <JY9516CoreOOAITask.h>

Public Member Functions

JY9516CoreOOAITask (int slotNum)
Constructor.
JY9516CoreOOAITask (std::string boardName)
Constructor.
void | AddChannel (int chID, double rangeLow, double rangeHigh, Coupling coupling, bool enableIEPESS)
Add one/all channel(s).
void | AddChannel (int chID, AIRange range, Coupling coupling, bool enableIEPE)
Add one/all channel(s).
void | AddChannel (std::vector< int > chnsId, double rangeLow, double rangeHigh, Coupling coupling, bool enableIEPE)
Add a set of channels and set parameters uniformly.
void | AddChannel (std::vector< int > chnsId, std::vector< double > rangeLow, std::vector< double > rangeHigh, std::vector< Coupling >_coupling, std::vector< bool > enableIEPE)
Add a group of channels, each channel range can be set differently.
void | AddChannel (std::vector< int > chnsId, AIRange range, Coupling coupling, bool enableIEPE)
Add a set of channels and set the parameters individually.
void | AddChannel (std::vector< int > chnsId, std::vector< AIRange > range, std::vector< Coupling >_coupling, std::vector< bool > enableIEPE)
Add a set of channels and set parameters uniformly.
void | RemoveChannel (int chnId)
Delete the channel with the specified channel number.
void | RemoveChannel (std::vector< int > chnsId)
Delete a set of channels with the specified channel ID.
void | ReadData (double *pBuf, int samplesPerChannel, int timeout=-1)
Read one or multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.
void | ReadRawData (int *pBuf, int samplesPerChannel, int timeout=-1)
Read one or multi-channel raw data by columns and store it in a data buffer.
void | ReadSinglePoint (double &readValue, int channel)
Read one sample for specified channel in register.
void | ReadSinglePoint (std::vector< double > &readValues)
Read raw one sample for all channels in register .
ConversionStatus * GetConversionStatus ()
Get ADC conversion status on all enabled channels.
void | Start ()
Start Task.
void | SendSoftwareTrigger ()
Generate a software trigger signal generate a software trigger signal.
void | Stop ()
Stop Task.
~JY9516CoreOOAITask ()

Public Attributes

std::list< AIChannel * > | Channels
List of AI channels,(9516 support 16 channel)
JY9516CoreOOProperty< JY9516CoreOOAITask, double, JY9516CoreOOPropertyType::READ_WRITE > | SampleRate
Sample rate per channel.
unsigned int | SamplesToAcquire
Number of samples to be read per channel.
JY9516CoreOOProperty< JY9516CoreOOAITask, int, JY9516CoreOOPropertyType::READ_ONLY > | BufLenInSamples
Number of samples per channel can be storage in the buffer, the Property SamplesToAcquire must be less than or equal to this value.
JY9516CoreOOProperty< JY9516CoreOOAITask, uint64_t, JY9516CoreOOPropertyType::READ_ONLY > | AvailableSamples
Number of samples per channel that can be read in the buffer .
JY9516CoreOOProperty< JY9516CoreOOAITask, uint64_t, JY9516CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
JY9516CoreOOProperty< JY9516CoreOOAITask, SampleInfo, JY9516CoreOOPropertyType::READ_ONLY > Sample_Info
Sampling information.
JY9516CoreOOProperty< JY9516CoreOOAITask, bool, JY9516CoreOOPropertyType::READ_WRITE > | DisableCalibration
AIMode Mode
AI acquisition mode, support Finite/Continuous/Record *.
AITrigger * Trigger
AI Trigger Configuration.
AISignalExport * SignalExport
Export AI Signal Configuration.
bool | DisableDigitalTriggerDelay
Disalble calibration Enable.
AISync * Sync
Multi card synchronous configuration.
JY9516CoreOODevice * Device
Device.
AIDigitalFiltering * DigitalFiltering
Digital filtering configuration.
JY9516DAC * DAC

Detailed Description

aiTask类

Constructor & Destructor Documentation

◆ JY9516CoreOOAITask() [1/2]

JY9516CoreOO::JY9516CoreOOAITask::JY9516CoreOOAITask ( int slotNum )

Constructor.

Used to create an AI task by a slot number

Parameters
slotNum Card slot number.

◆ JY9516CoreOOAITask() [2/2]

JY9516CoreOO::JY9516CoreOOAITask::JY9516CoreOOAITask ( std::string boardName )

Constructor.

Used to create an AI task by a slot number

Parameters
slotNum Card slot number.

◆ ~JY9516CoreOOAITask()

JY9516CoreOO::JY9516CoreOOAITask::~JY9516CoreOOAITask ( )

Member Function Documentation

◆ AddChannel() [1/6]

void JY9516CoreOO::JY9516CoreOOAITask::AddChannel | ( | int | chID,
 |  | AIRange | range,
 |  | Coupling | coupling,
 |  | bool | enableIEPE )

Add one/all channel(s).

Parameters
chID | Channel ID
range | Input Range.
coupling | Coupling Type.
enableIEPE | IEPE Enabled.

◆ AddChannel() [2/6]

void JY9516CoreOO::JY9516CoreOOAITask::AddChannel | ( | int | chID,
 |  | double | rangeLow,
 |  | double | rangeHigh,
 |  | Coupling | coupling,
 |  | bool | enableIEPESS )

Add one/all channel(s).

Parameters
chID | Channel ID
rangeLow | Input Low Range. -10V/-5V/-2.5V/-1.25V/-0.625V/-0.3125V Optional.
rangeHigh | Input High Range. 10V/5V/2.5V/1.25V/0.625V/0.3125V Optional.
coupling | Coupling Type.
enableIEPE | IEPE Enabled.

◆ AddChannel() [3/6]

void JY9516CoreOO::JY9516CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | AIRange | range,
 |  | Coupling | coupling,
 |  | bool | enableIEPE )

Add a set of channels and set the parameters individually.

Parameters
chIDs | Channel ID
rangeLow | Input Low Range. -10V/-5V/-2.5V/-1.25V/-0.625V/-0.3125V Optional.
rangeHigh | Input High Range. 10V/5V/2.5V/1.25V/0.625V/0.3125V Optional.
coupling | Coupling Type.
enableIEPE | IEPE Enabled.

◆ AddChannel() [4/6]

void JY9516CoreOO::JY9516CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | double | rangeLow,
 |  | double | rangeHigh,
 |  | Coupling | coupling,
 |  | bool | enableIEPE )

Add a set of channels and set parameters uniformly.

Parameters
chIDs | Channel ID
rangeLow | Input Low Range. -10V/-5V/-2.5V/-1.25V/-0.625V/-0.3125V Optional.
rangeHigh | Input High Range. 10V/5V/2.5V/1.25V/0.625V/0.3125V Optional.
coupling | Coupling Type.
enableIEPE | IEPE Enabled.

◆ AddChannel() [5/6]

void JY9516CoreOO::JY9516CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | std::vector< AIRange > | range,
 |  | std::vector< Coupling > | _coupling,
 |  | std::vector< bool > | enableIEPE )

Add a set of channels and set parameters uniformly.

Parameters
chIDs | Channel ID
range | Input Range.
coupling | Coupling Type.
enableIEPE | IEPE Enabled.

◆ AddChannel() [6/6]

void JY9516CoreOO::JY9516CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | std::vector< double > | rangeLow,
 |  | std::vector< double > | rangeHigh,
 |  | std::vector< Coupling > | _coupling,
 |  | std::vector< bool > | enableIEPE )

Add a group of channels, each channel range can be set differently.

Parameters
chnsId | a group of channel physical numbers,if 5322 5324 channel is 0 - 15. if 5321 5323 channel is 0 -31
rangeLow | lower range limit for the channel，5323/5324:-10V,-5V,-1V, -0.5V,5323/5324:-10,-5,-2,-1,-0.5,-0.25,default -10
rangeHigh | higher range limit for the channel,5323/5324:10V,5V,1V, 0.5V,5323/5324:10,5,2,1,0.5,0.25,default 10
bandWidth | AI Bandwidth ,default 25KHz

◆ GetConversionStatus()

ConversionStatus * JY9516CoreOO::JY9516CoreOOAITask::GetConversionStatus ( )

Get ADC conversion status on all enabled channels.

Returns
ADC conversion status.

◆ ReadData()

void JY9516CoreOO::JY9516CoreOOAITask::ReadData | ( | double * | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = -1 )

Read one or multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.

param name="pBuf">Data buffer

Parameters
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish

◆ ReadRawData()

void JY9516CoreOO::JY9516CoreOOAITask::ReadRawData | ( | int * | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = -1 )

Read one or multi-channel raw data by columns and store it in a data buffer.

The buffer is pointed by C/C++ data type int.

Parameters
pBuf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ ReadSinglePoint() [1/2]

void JY9516CoreOO::JY9516CoreOOAITask::ReadSinglePoint | ( | double & | readValue,
 |  | int | channel )

Read one sample for specified channel in register.

Available when Mode is AIMode.Single

Parameters
readValue | value read
channel | Specified channel numbers.

◆ ReadSinglePoint() [2/2]

void JY9516CoreOO::JY9516CoreOOAITask::ReadSinglePoint ( std::vector< double > & readValues )

Read raw one sample for all channels in register .

Available when Mode is AIMode.Single

Parameters
readValues Values read. Array length >= Channels.Count.

◆ RemoveChannel() [1/2]

void JY9516CoreOO::JY9516CoreOOAITask::RemoveChannel ( int chnId )

Delete the channel with the specified channel number.

chnId=- 1, all channels will be deleted

Parameters
chnId Channel number of the channel to be deleted

◆ RemoveChannel() [2/2]

void JY9516CoreOO::JY9516CoreOOAITask::RemoveChannel ( std::vector< int > chnsId )

Delete a set of channels with the specified channel ID.

Parameters
chIDs Specified channels' ID.

◆ SendSoftwareTrigger()

void JY9516CoreOO::JY9516CoreOOAITask::SendSoftwareTrigger ( )

Generate a software trigger signal generate a software trigger signal.

Returns

◆ Start()

void JY9516CoreOO::JY9516CoreOOAITask::Start ( )

Start Task.

Parameters

return void

Exceptions
JYDriverException When startup fails

◆ Stop()

void JY9516CoreOO::JY9516CoreOOAITask::Stop ( )

Stop Task.

Parameters

return void

Exceptions
JYDriverException When stop fails

Member Data Documentation

◆ AvailableSamples

JY9516CoreOOProperty<JY9516CoreOOAITask, uint64_t, JY9516CoreOOPropertyType::READ_ONLY> JY9516CoreOO::JY9516CoreOOAITask::AvailableSamples

Number of samples per channel that can be read in the buffer .

Valid when Mode is NOT AIMode.Single.

◆ BufLenInSamples

JY9516CoreOOProperty<JY9516CoreOOAITask, int, JY9516CoreOOPropertyType::READ_ONLY> JY9516CoreOO::JY9516CoreOOAITask::BufLenInSamples

Number of samples per channel can be storage in the buffer, the Property SamplesToAcquire must be less than or equal to this value.

◆ Channels

std::list<AIChannel*> JY9516CoreOO::JY9516CoreOOAITask::Channels

List of AI channels,(9516 support 16 channel)

◆ DAC

JY9516DAC* JY9516CoreOO::JY9516CoreOOAITask::DAC

◆ Device

JY9516CoreOODevice* JY9516CoreOO::JY9516CoreOOAITask::Device

Device.

◆ DigitalFiltering

AIDigitalFiltering* JY9516CoreOO::JY9516CoreOOAITask::DigitalFiltering

Digital filtering configuration.

◆ DisableCalibration

JY9516CoreOOProperty<JY9516CoreOOAITask, bool, JY9516CoreOOPropertyType::READ_WRITE> JY9516CoreOO::JY9516CoreOOAITask::DisableCalibration

◆ DisableDigitalTriggerDelay

bool JY9516CoreOO::JY9516CoreOOAITask::DisableDigitalTriggerDelay

Disalble calibration Enable.

◆ Mode

AIMode JY9516CoreOO::JY9516CoreOOAITask::Mode

AI acquisition mode, support Finite/Continuous/Record *.

◆ Sample_Info

JY9516CoreOOProperty<JY9516CoreOOAITask, SampleInfo, JY9516CoreOOPropertyType::READ_ONLY> JY9516CoreOO::JY9516CoreOOAITask::Sample_Info

Sampling information.

Including the modulation frequency and group delay in the current configuration.

◆ SampleRate

JY9516CoreOOProperty<JY9516CoreOOAITask, double, JY9516CoreOOPropertyType::READ_WRITE> JY9516CoreOO::JY9516CoreOOAITask::SampleRate

Sample rate per channel.

Minimum sample rate: 62.5 S/s Maximum sample rate: 256k S/s The defalut sample rate = 256k You can read this property to obtain the sample rate that will actually take effect in the current configuration.

Exceptions
JYDriverException

◆ SamplesToAcquire

unsigned int JY9516CoreOO::JY9516CoreOOAITask::SamplesToAcquire

Number of samples to be read per channel.

Only valid when Mode is Finite*

◆ SignalExport

AISignalExport* JY9516CoreOO::JY9516CoreOOAITask::SignalExport

Export AI Signal Configuration.

◆ Sync

AISync* JY9516CoreOO::JY9516CoreOOAITask::Sync

Multi card synchronous configuration.

◆ TransferedSamples

JY9516CoreOOProperty<JY9516CoreOOAITask, uint64_t, JY9516CoreOOPropertyType::READ_ONLY> JY9516CoreOO::JY9516CoreOOAITask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT AIMode.Single.

◆ Trigger

AITrigger* JY9516CoreOO::JY9516CoreOOAITask::Trigger

AI Trigger Configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9516/JY9516CoreOOAITask.h


9516 C++ Programming Manual: JY9516CoreOO::AIChannel Class Reference

  • JY9516CoreOO
  • AIChannel
Public Member Functions | Public Attributes | List of all members
JY9516CoreOO::AIChannel Class Reference

AI Channel. More...

#include <JY9516CoreOOAITask.h>

Public Member Functions

AIChannel (int channelId, double rangeLow, double rangeHigh, Coupling _coupling, bool IEPEenabled)
Constructor.
AIChannel (int channelId, AIRange range, Coupling _coupling, bool IEPEenabled)
Constructor.

Public Attributes

int | ChannelID
Channel ID.
Coupling coupling
Coupling.
bool | IEPEEnabled
IEPE enabled.
AIRange Range
Input voltage range(grade)
double | RangeLow
Upper limit of range.
double | RangeHigh
Lower limit of range.
JY9516CoreOOProperty< AIChannel, double, JY9516CoreOOPropertyType::READ_ONLY > | RawDataScaleFactor
This fator is used to convert RawData(binary) to Data(voltage in V).

Detailed Description

AI Channel.

Constructor & Destructor Documentation

◆ AIChannel() [1/2]

JY9516CoreOO::AIChannel::AIChannel | ( | int | channelId,
 |  | double | rangeLow,
 |  | double | rangeHigh,
 |  | Coupling | _coupling,
 |  | bool | IEPEenabled )

Constructor.

Used to create an AIChannel by Characteristic.

Parameters
channelId | Channel ID
rangeLow | Lower limit of range
rangeHigh | Upper limit of range
_coupling | Coupling
IEPEenabled | IEPE enabled

◆ AIChannel() [2/2]

JY9516CoreOO::AIChannel::AIChannel | ( | int | channelId,
 |  | AIRange | range,
 |  | Coupling | _coupling,
 |  | bool | IEPEenabled )

Constructor.

Used to create an AIChannel by Characteristic.

Parameters
channelId | Channel ID
range | Input voltage range(grade)
_coupling | Coupling
IEPEenabled | IEPE enabled

Member Data Documentation

◆ ChannelID

int JY9516CoreOO::AIChannel::ChannelID

Channel ID.

◆ coupling

Coupling JY9516CoreOO::AIChannel::coupling

Coupling.

◆ IEPEEnabled

bool JY9516CoreOO::AIChannel::IEPEEnabled

IEPE enabled.

◆ Range

AIRange JY9516CoreOO::AIChannel::Range

Input voltage range(grade)

◆ RangeHigh

double JY9516CoreOO::AIChannel::RangeHigh

Lower limit of range.

◆ RangeLow

double JY9516CoreOO::AIChannel::RangeLow

Upper limit of range.

◆ RawDataScaleFactor

JY9516CoreOOProperty<AIChannel, double, JY9516CoreOOPropertyType::READ_ONLY> JY9516CoreOO::AIChannel::RawDataScaleFactor

This fator is used to convert RawData(binary) to Data(voltage in V).

RawData * factor = Data.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9516/JY9516CoreOOAITask.h


9516 C++ Programming Manual: JY9516CoreOO::AITrigger Class Reference

  • AITrigger
Public Attributes | List of all members
JY9516CoreOO::AITrigger Class Reference

#include <JY9516CoreOOAITask.h>

Public Attributes

AITriggerType Type
AI trigger type.
AITriggerMode Mode
AI trigger mode.
AIDigitalTrigger * Digital
Digital Trigger Congfiguration.
AIAnalogTrigger * Analog
AI Analog Trigger.
int | ReTriggerCount
Number of repeat triggers.
unsigned int | PreTriggerSamples
AI pretrigger samples, must be less than or equal to JY9516aiTask.SamplesToAcquire.

Member Data Documentation

◆ Analog

AIAnalogTrigger* JY9516CoreOO::AITrigger::Analog

AI Analog Trigger.

Valid when Type is AITriggerType.Analog.

◆ Digital

AIDigitalTrigger* JY9516CoreOO::AITrigger::Digital

Digital Trigger Congfiguration.

Valid when Type is AITriggerType.Digital.

◆ Mode

AITriggerMode JY9516CoreOO::AITrigger::Mode

AI trigger mode.

enum Start/Reference. The default value is AITriggerMode.Start.

◆ PreTriggerSamples

unsigned int JY9516CoreOO::AITrigger::PreTriggerSamples

AI pretrigger samples, must be less than or equal to JY9516aiTask.SamplesToAcquire.

Valid when Mode is AITriggerMode.Reference. Pretrigger samples, must be greater than 0. Valid when Type is AITriggerType.Analog. Pretrigger samples, must be greater than 1. Valid when Type is AITriggerType.Digital.

◆ ReTriggerCount

int JY9516CoreOO::AITrigger::ReTriggerCount

Number of repeat triggers.

When 0 or 1 only trigger once, When -1 continuous retrigger until stop.

◆ Type

AITriggerType JY9516CoreOO::AITrigger::Type

AI trigger type.

enum Analog/Digital/Immediate/Soft. The default value is AITriggerType.Immediate.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9516/JY9516CoreOOAITask.h


9516 C++ Programming Manual: JY9516CoreOO::AIDigitalTrigger Class Reference

  • AIDigitalTrigger
Public Attributes | List of all members
JY9516CoreOO::AIDigitalTrigger Class Reference

AI Digital trigger params. More...

#include <JY9516CoreOOAITask.h>

Public Attributes

AIDigitalTriggerSource Source
AI Digital Trigger source.
AIDigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Detailed Description

AI Digital trigger params.

Member Data Documentation

◆ Edge

AIDigitalTriggerEdge JY9516CoreOO::AIDigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

AIDigitalTriggerSource JY9516CoreOO::AIDigitalTrigger::Source

AI Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9516/JY9516CoreOOAITask.h


9516 C++ Programming Manual: JY9516CoreOO::AIAnalogHysteresisComparator Class Reference

  • AIAnalogHysteresisComparator
Public Attributes | List of all members
JY9516CoreOO::AIAnalogHysteresisComparator Class Reference

AI Analog Hysteresis Comparator. More...

#include <JY9516CoreOOAITask.h>

Public Attributes

AIAnalogTriggerEdge Slope
AI Analog Trigger Edge.
double | HighThreshold
High Threshold.
double | LowThreshold
Low Threshold.

Detailed Description

AI Analog Hysteresis Comparator.

Member Data Documentation

◆ HighThreshold

double JY9516CoreOO::AIAnalogHysteresisComparator::HighThreshold

High Threshold.

◆ LowThreshold

double JY9516CoreOO::AIAnalogHysteresisComparator::LowThreshold

Low Threshold.

◆ Slope

AIAnalogTriggerEdge JY9516CoreOO::AIAnalogHysteresisComparator::Slope

AI Analog Trigger Edge.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9516/JY9516CoreOOAITask.h


9516 C++ Programming Manual: JY9516CoreOO::AIAnalogWindowComparator Class Reference

  • AIAnalogWindowComparator
Public Attributes | List of all members
JY9516CoreOO::AIAnalogWindowComparator Class Reference

AI Analog Window Comparator. More...

#include <JY9516CoreOOAITask.h>

Public Attributes

AIAnalogWindowCondition Condition
AI Analog Window Condition.
double | HighThreshold
High Threshold.
double | LowThreshold
Low Threshold.

Detailed Description

AI Analog Window Comparator.

Member Data Documentation

◆ Condition

AIAnalogWindowCondition JY9516CoreOO::AIAnalogWindowComparator::Condition

AI Analog Window Condition.

◆ HighThreshold

double JY9516CoreOO::AIAnalogWindowComparator::HighThreshold

High Threshold.

◆ LowThreshold

double JY9516CoreOO::AIAnalogWindowComparator::LowThreshold

Low Threshold.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9516/JY9516CoreOOAITask.h


9516 C++ Programming Manual: JY9516CoreOO::AIAnalogEdgeComparator Class Reference

  • AIAnalogEdgeComparator
Public Attributes | List of all members
JY9516CoreOO::AIAnalogEdgeComparator Class Reference

AI Analog Edge Comparator. More...

#include <JY9516CoreOOAITask.h>

Public Attributes

AIAnalogTriggerEdge Slope
AI Analog Trigger Edge.
double Threshold
Threshold.

Detailed Description

AI Analog Edge Comparator.

Member Data Documentation

◆ Slope

AIAnalogTriggerEdge JY9516CoreOO::AIAnalogEdgeComparator::Slope

AI Analog Trigger Edge.

◆ Threshold

double JY9516CoreOO::AIAnalogEdgeComparator::Threshold

Threshold.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9516/JY9516CoreOOAITask.h


9516 C++ Programming Manual: JY9516CoreOO::AIAnalogTrigger Class Reference

  • AIAnalogTrigger
Public Member Functions | Public Attributes | List of all members
JY9516CoreOO::AIAnalogTrigger Class Reference

AI Analog Trigger. More...

#include <JY9516CoreOOAITask.h>

Public Member Functions

AIAnalogTrigger ()
AIAnalogTrigger (AIAnalogTriggerSource src, AIAnalogTriggerComparator comparator)
~AIAnalogTrigger ()
void Commit (void *deviceHandle)

Public Attributes

AIAnalogTriggerSource Source
Analog Trigger source.
AIAnalogTriggerComparator Comparator
AI Analog Trigger Comparator.
AIAnalogEdgeComparator * Edge
AI Analog Edge Comparator.
AIAnalogHysteresisComparator * Hysteresis
AI Analog Hysteresis Comparatorr.
AIAnalogWindowComparator * Window
AI Analog Window Comparatorr.

Detailed Description

AI Analog Trigger.

Constructor & Destructor Documentation

◆ AIAnalogTrigger() [1/2]

JY9516CoreOO::AIAnalogTrigger::AIAnalogTrigger ( )

◆ AIAnalogTrigger() [2/2]

JY9516CoreOO::AIAnalogTrigger::AIAnalogTrigger | ( | AIAnalogTriggerSource | src,
 |  | AIAnalogTriggerComparator | comparator )

◆ ~AIAnalogTrigger()

JY9516CoreOO::AIAnalogTrigger::~AIAnalogTrigger ( )

Member Function Documentation

◆ Commit()

void JY9516CoreOO::AIAnalogTrigger::Commit ( void * deviceHandle )

Member Data Documentation

◆ Comparator

AIAnalogTriggerComparator JY9516CoreOO::AIAnalogTrigger::Comparator

AI Analog Trigger Comparator.

◆ Edge

AIAnalogEdgeComparator* JY9516CoreOO::AIAnalogTrigger::Edge

AI Analog Edge Comparator.

◆ Hysteresis

AIAnalogHysteresisComparator* JY9516CoreOO::AIAnalogTrigger::Hysteresis

AI Analog Hysteresis Comparatorr.

◆ Source

AIAnalogTriggerSource JY9516CoreOO::AIAnalogTrigger::Source

Analog Trigger source.

◆ Window

AIAnalogWindowComparator* JY9516CoreOO::AIAnalogTrigger::Window

AI Analog Window Comparatorr.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9516/JY9516CoreOOAITask.h


9516 C++ Programming Manual: JY9516CoreOO::AISignalExport Class Reference

  • AISignalExport
Public Member Functions | List of all members
JY9516CoreOO::AISignalExport Class Reference

AI Signal Export Class. More...

#include <JY9516CoreOOAITask.h>

Public Member Functions

void | Add (AISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (AISignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

AI Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY9516CoreOO::AISignalExport::Add | ( | AISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | AI Signal Source
destination | Export Desination

◆ Add() [2/2]

void JY9516CoreOO::AISignalExport::Add | ( | AISignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | AI Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JY9516CoreOO::AISignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY9516CoreOO::AISignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9516/JY9516CoreOOAITask.h


9516 C++ Programming Manual: JY9516CoreOO::AISync Class Reference

  • AISync
Public Attributes | List of all members
JY9516CoreOO::AISync Class Reference

#include <JY9516CoreOOAITask.h>

Public Attributes

SyncTopology Topology
SyncTerminal Terminal
JY9516CoreOOProperty< AISync, SyncState, JY9516CoreOOPropertyType::READ_ONLY > State
The number of samples that have been transfered from the local buffer (per channel).

Detailed Description

同步配置类

Sync Configuration Class

Member Data Documentation

◆ State

JY9516CoreOOProperty<AISync, SyncState, JY9516CoreOOPropertyType::READ_ONLY> JY9516CoreOO::AISync::State

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT AIMode.Single.

◆ Terminal

SyncTerminal JY9516CoreOO::AISync::Terminal

◆ Topology

SyncTopology JY9516CoreOO::AISync::Topology
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9516/JY9516CoreOOAITask.h


9516 C++ Programming Manual: JY9516CoreOO::LowPassFilter Class Reference

  • LowPassFilter
Public Member Functions | Public Attributes | List of all members
JY9516CoreOO::LowPassFilter Class Reference

#include <JY9516CoreOOAITask.h>

Public Member Functions

LowPassFilter ()

Public Attributes

JY9516CoreOOProperty< LowPassFilter, LPFMode, JY9516CoreOOPropertyType::READ_WRITE > Mode

Constructor & Destructor Documentation

◆ LowPassFilter()

JY9516CoreOO::LowPassFilter::LowPassFilter ( )

Member Data Documentation

◆ Mode

JY9516CoreOOProperty<LowPassFilter, LPFMode, JY9516CoreOOPropertyType::READ_WRITE> JY9516CoreOO::LowPassFilter::Mode
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9516/JY9516CoreOOAITask.h


9516 C++ Programming Manual: JY9516CoreOO::HighPassFilter Class Reference

  • HighPassFilter
Public Member Functions | Public Attributes | List of all members
JY9516CoreOO::HighPassFilter Class Reference

High-Pass Filter Configuration Class. More...

#include <JY9516CoreOOAITask.h>

Public Member Functions

HighPassFilter ()
void | EnableChannel (int chID)
void | DisableChannel (int chID)

Public Attributes

JY9516CoreOOProperty< HighPassFilter, double, JY9516CoreOOPropertyType::READ_WRITE > | CutoffFrequency
Cutoff Frequency in Hz.
JY9516CoreOOProperty< HighPassFilter, HPFOrder, JY9516CoreOOPropertyType::READ_WRITE > Order
JY9516CoreOOProperty< HighPassFilter, uint32_t, JY9516CoreOOPropertyType::READ_ONLY > | ChannelEnableMask

Detailed Description

High-Pass Filter Configuration Class.

Constructor & Destructor Documentation

◆ HighPassFilter()

JY9516CoreOO::HighPassFilter::HighPassFilter ( )

Member Function Documentation

◆ DisableChannel()

void JY9516CoreOO::HighPassFilter::DisableChannel ( int chID )

◆ EnableChannel()

void JY9516CoreOO::HighPassFilter::EnableChannel ( int chID )

Member Data Documentation

◆ ChannelEnableMask

JY9516CoreOOProperty<HighPassFilter, uint32_t, JY9516CoreOOPropertyType::READ_ONLY> JY9516CoreOO::HighPassFilter::ChannelEnableMask

◆ CutoffFrequency

JY9516CoreOOProperty<HighPassFilter, double, JY9516CoreOOPropertyType::READ_WRITE> JY9516CoreOO::HighPassFilter::CutoffFrequency

Cutoff Frequency in Hz.

The max value is SampleRate * 1%. The attenuation at this frequency is -3dB when the filter is one-order, and -6dB when the filter is two-order.

◆ Order

JY9516CoreOOProperty<HighPassFilter, HPFOrder, JY9516CoreOOPropertyType::READ_WRITE> JY9516CoreOO::HighPassFilter::Order
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9516/JY9516CoreOOAITask.h


9516 C++ Programming Manual: JY9516CoreOO::FlatnessCompensation Class Reference

  • FlatnessCompensation
Public Member Functions | Public Attributes | List of all members
JY9516CoreOO::FlatnessCompensation Class Reference

Flatness Compensation Parameters. More...

#include <JY9516CoreOOAITask.h>

Public Member Functions

FlatnessCompensation ()

Public Attributes

JY9516CoreOOProperty< FlatnessCompensation, bool, JY9516CoreOOPropertyType::READ_WRITE > Enabled

Detailed Description

Flatness Compensation Parameters.

Constructor & Destructor Documentation

◆ FlatnessCompensation()

JY9516CoreOO::FlatnessCompensation::FlatnessCompensation ( )

Member Data Documentation

◆ Enabled

JY9516CoreOOProperty<FlatnessCompensation, bool, JY9516CoreOOPropertyType::READ_WRITE> JY9516CoreOO::FlatnessCompensation::Enabled
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9516/JY9516CoreOOAITask.h


9516 C++ Programming Manual: JY9516CoreOO::AIDigitalFiltering Class Reference

  • AIDigitalFiltering
Public Member Functions | Public Attributes | List of all members
JY9516CoreOO::AIDigitalFiltering Class Reference

AI Digital Filtering Connfiguration Class. More...

#include <JY9516CoreOOAITask.h>

Public Member Functions

AIDigitalFiltering ()
~AIDigitalFiltering ()

Public Attributes

JY9516CoreOOProperty< AIDigitalFiltering, LowPassFilter, JY9516CoreOOPropertyType::READ_ONLY > LPF
JY9516CoreOOProperty< AIDigitalFiltering, HighPassFilter, JY9516CoreOOPropertyType::READ_ONLY > HPF
JY9516CoreOOProperty< AIDigitalFiltering, FlatnessCompensation, JY9516CoreOOPropertyType::READ_ONLY > Flatnesscompensation
ChoppingFrequency ModulatorChoppingFrequency

Detailed Description

AI Digital Filtering Connfiguration Class.

Constructor & Destructor Documentation

◆ AIDigitalFiltering()

JY9516CoreOO::AIDigitalFiltering::AIDigitalFiltering ( )

◆ ~AIDigitalFiltering()

JY9516CoreOO::AIDigitalFiltering::~AIDigitalFiltering ( )

Member Data Documentation

◆ Flatnesscompensation

JY9516CoreOOProperty<AIDigitalFiltering, FlatnessCompensation, JY9516CoreOOPropertyType::READ_ONLY> JY9516CoreOO::AIDigitalFiltering::Flatnesscompensation

◆ HPF

JY9516CoreOOProperty<AIDigitalFiltering, HighPassFilter, JY9516CoreOOPropertyType::READ_ONLY> JY9516CoreOO::AIDigitalFiltering::HPF

◆ LPF

JY9516CoreOOProperty<AIDigitalFiltering, LowPassFilter, JY9516CoreOOPropertyType::READ_ONLY> JY9516CoreOO::AIDigitalFiltering::LPF

◆ ModulatorChoppingFrequency

ChoppingFrequency JY9516CoreOO::AIDigitalFiltering::ModulatorChoppingFrequency
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9516/JY9516CoreOOAITask.h


9516 C++ Programming Manual: JY9516CoreOO::JY9516DAC Class Reference

  • JY9516DAC
Public Member Functions | Public Attributes | List of all members
JY9516CoreOO::JY9516DAC Class Reference

JY9516 DAC Configuration. More...

#include <JY9516CoreOOAITask.h>

Public Member Functions

JY9516DAC (void *deviceHandle)
~JY9516DAC ()
void IssueTemperatureRecalibration (int timeout=5000)
Issue temperature drift recalibration and correct the influence of temperature changes on the output voltage.

Public Attributes

JY9516CoreOOProperty< JY9516DAC, int, JY9516CoreOOPropertyType::READ_WRITE > | OutputChannel
DAC Voltage Output Channel.
JY9516CoreOOProperty< JY9516DAC, bool, JY9516CoreOOPropertyType::READ_WRITE > | Enabled
Onboard DAC Enabled.
JY9516CoreOOProperty< JY9516DAC, double, JY9516CoreOOPropertyType::READ_WRITE > | OutputVoltage
DAC Output Voltage in V, default is 0.

Detailed Description

JY9516 DAC Configuration.

Constructor & Destructor Documentation

◆ JY9516DAC()

JY9516CoreOO::JY9516DAC::JY9516DAC ( void * deviceHandle )

◆ ~JY9516DAC()

JY9516CoreOO::JY9516DAC::~JY9516DAC ( )

Member Function Documentation

◆ IssueTemperatureRecalibration()

void JY9516CoreOO::JY9516DAC::IssueTemperatureRecalibration ( int timeout = 5000 )

Issue temperature drift recalibration and correct the influence of temperature changes on the output voltage.

Please call this method before each calibration.

Parameters
timeout Process timeout in ms.

Member Data Documentation

◆ Enabled

JY9516CoreOOProperty<JY9516DAC, bool, JY9516CoreOOPropertyType::READ_WRITE> JY9516CoreOO::JY9516DAC::Enabled

Onboard DAC Enabled.

Take effect immediately.

◆ OutputChannel

JY9516CoreOOProperty<JY9516DAC, int, JY9516CoreOOPropertyType::READ_WRITE> JY9516CoreOO::JY9516DAC::OutputChannel

DAC Voltage Output Channel.

0-15

◆ OutputVoltage

JY9516CoreOOProperty<JY9516DAC, double, JY9516CoreOOPropertyType::READ_WRITE> JY9516CoreOO::JY9516DAC::OutputVoltage

DAC Output Voltage in V, default is 0.

This attribute is used for self-calibration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9516/JY9516CoreOOAITask.h


9516 C++ Programming Manual: JY9516CoreOO::ConversionStatus Class Reference

  • ConversionStatus
Public Member Functions | Public Attributes | List of all members
JY9516CoreOO::ConversionStatus Class Reference

Get ADC conversion status on all enabled channels. More...

#include <JY9516CoreOOAITask.h>

Public Member Functions

ConversionStatus (int header)
void Update (int header)

Public Attributes

JY9516CoreOOProperty< ConversionStatus, bool, JY9516CoreOOPropertyType::READ_ONLY > | ErrorFlagged
JY9516CoreOOProperty< ConversionStatus, bool, JY9516CoreOOPropertyType::READ_ONLY > | CRCError
JY9516CoreOOProperty< ConversionStatus, bool, JY9516CoreOOPropertyType::READ_ONLY > | FilterSuturated
JY9516CoreOOProperty< ConversionStatus, bool, JY9516CoreOOPropertyType::READ_ONLY > | ChannelID

Detailed Description

Get ADC conversion status on all enabled channels.

Returns
ADC conversion status.

Constructor & Destructor Documentation

◆ ConversionStatus()

JY9516CoreOO::ConversionStatus::ConversionStatus ( int header )

Member Function Documentation

◆ Update()

void JY9516CoreOO::ConversionStatus::Update ( int header )
inline

Member Data Documentation

◆ ChannelID

JY9516CoreOOProperty<ConversionStatus, bool, JY9516CoreOOPropertyType::READ_ONLY> JY9516CoreOO::ConversionStatus::ChannelID

◆ CRCError

JY9516CoreOOProperty<ConversionStatus, bool, JY9516CoreOOPropertyType::READ_ONLY> JY9516CoreOO::ConversionStatus::CRCError

◆ ErrorFlagged

JY9516CoreOOProperty<ConversionStatus, bool, JY9516CoreOOPropertyType::READ_ONLY> JY9516CoreOO::ConversionStatus::ErrorFlagged

◆ FilterSuturated

JY9516CoreOOProperty<ConversionStatus, bool, JY9516CoreOOPropertyType::READ_ONLY> JY9516CoreOO::ConversionStatus::FilterSuturated
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9516/JY9516CoreOOAITask.h


9516 C++ Programming Manual: JY9516CoreOO Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Enumerations | Functions | Variables
JY9516CoreOO Namespace Reference

Classes

class | AIAnalogEdgeComparator
AI Analog Edge Comparator. More...
class | AIAnalogHysteresisComparator
AI Analog Hysteresis Comparator. More...
class | AIAnalogTrigger
AI Analog Trigger. More...
class | AIAnalogWindowComparator
AI Analog Window Comparator. More...
class | AIChannel
AI Channel. More...
class | AIDigitalFiltering
AI Digital Filtering Connfiguration Class. More...
class | AIDigitalTrigger
AI Digital trigger params. More...
class | AISignalExport
AI Signal Export Class. More...
class | AISync
class | AITrigger
class | ConversionStatus
Get ADC conversion status on all enabled channels. More...
class | DeviceStatus
Device Status. More...
class | ExternalReferenceClock
External Reference Clcok Terminal. More...
struct | FirmDriveInfo
class | FlatnessCompensation
Flatness Compensation Parameters. More...
class | HighPassFilter
High-Pass Filter Configuration Class. More...
class | JY9516CoreOOAITask
aiTask类 More...
class | JY9516CoreOODevice
JY9516CoreOO Device. More...
class | JY9516CoreOOLog
class | JY9516CoreOOProperty
属性模板类 More...
class | JY9516CoreOOReferenceClock
class | JY9516DAC
JY9516 DAC Configuration. More...
class | JY9516DeviceInfo
Device Info. More...
class | JYDriverException
class | LowPassFilter
class | PauseTrigger
Pause trigger configuration class. More...
class | SampleInfo
Sampling information. More...

Enumerations

enum class | AIMode { Finite , Continuous , Single }
enum class | IEPEConnectionStatus { Normal = 0 , OpenCircuit = 1 , ShortCircuit = 2 }
IEPE Connection Status. More...
enum class AIRange {
_10V = JY9516Import::JY9516_Range_10V , _5V = JY9516Import::JY9516_Range_5V , _2p5V = JY9516Import::JY9516_Range_2p5V , _1p25V = JY9516Import::JY9516_Range_1p25V ,
_0p625V = JY9516Import::JY9516_Range_0p625V , _0p3125V = JY9516Import::JY9516_Range_0p3125V
}
enum class | Coupling { AC = JY9516Import::JY9516_Coupling_AC , DC = JY9516Import::JY9516_Coupling_DC }
Coupling. More...
enum class | AITriggerType { Immediately = JY9516Import::JY9516_TriggerType_Immediately , Digital = JY9516Import::JY9516_TriggerType_Digital , Software = JY9516Import::JY9516_TriggerType_Software , Analog = JY9516Import::JY9516_TriggerType_Analog }
AI trigger type enum type. More...
enum class | AITriggerMode { Start , Reference }
AI trigger mode enum type. More...
enum class AIAnalogTriggerSource {
Channel_0 , Channel_1 , Channel_2 , Channel_3 ,
Channel_4 , Channel_5 , Channel_6 , Channel_7 ,
Channel_8 , Channel_9 , Channel_10 , Channel_11 ,
Channel_12 , Channel_13 , Channel_14 , Channel_15 ,
Channel_16 , Channel_17 , Channel_18 , Channel_19 ,
Channel_20 , Channel_21 , Channel_22 , Channel_23 ,
Channel_24 , Channel_25 , Channel_26 , Channel_27 ,
Channel_28 , Channel_29 , Channel_30 , Channel_31
}
Analog Trigger source. More...
enum class AIDigitalTriggerSource {
Ext_Trig = JY9516Import::JY9516_DigitalTriggerSource_External , PXI_Trig0 = JY9516Import::JY9516_DigitalTriggerSource_BUS_0 , PXI_Trig1 = JY9516Import::JY9516_DigitalTriggerSource_BUS_1 , PXI_Trig2 = JY9516Import::JY9516_DigitalTriggerSource_BUS_2 ,
PXI_Trig3 = JY9516Import::JY9516_DigitalTriggerSource_BUS_3 , PXI_Trig4 = JY9516Import::JY9516_DigitalTriggerSource_BUS_4 , PXI_Trig5 = JY9516Import::JY9516_DigitalTriggerSource_BUS_5 , PXI_Trig6 = JY9516Import::JY9516_DigitalTriggerSource_BUS_6 ,
PXI_Trig7 = JY9516Import::JY9516_DigitalTriggerSource_BUS_7 , PXI_Star = JY9516Import::JY9516_DigitalTriggerSource_STAR
}
AI digital trigger source enum type. More...
enum class | AIDigitalTriggerEdge { Rising = 0x0 , Falling = 0x1 }
AI Digital Trigger Edge enum type. More...
enum class | AIAnalogTriggerEdge { Rising , Falling }
AI Analog Trigger Edge. More...
enum class | AIAnalogWindowCondition { Entering , Leaving }
AI Analog Window Trigger Condition. More...
enum class | AIAnalogTriggerComparator { Edge , Hysteresis , Window }
AI Analog Trigger Comparator. More...
enum class AISignalExportSource {
SampleClock = JY9516Import::JY9516_EXPORT_SAMPLE_CLOCK , Sync = JY9516Import::JY9516_EXPORT_SYNC , ReadyForStartTrigger = JY9516Import::JY9516_EXPORT_RX_READY_FOR_REF_TRIG , StartTrigger = JY9516Import::JY9516_EXPORT_RX_REF_TRIG ,
EndOfRecord = JY9516Import::JY9516_EXPORT_RX_END_OF_RECORD , EndOfAcquisition = JY9516Import::JY9516_EXPORT_RX_ENGINE_END
}
AI Signal Export Source Enum. More...
enum class | SyncTopology { Independent , Master , Slave }
Synchronization board configuration. More...
enum SyncTerminal {
Ext_Trig , PXI_Trig0 , PXI_Trig1 , PXI_Trig2 ,
PXI_Trig3 , PXI_Trig4 , PXI_Trig5 , PXI_Trig6 ,
PXI_Trig7 , PXI_Star
}
AI digital trigger source enum type. More...
enum | SyncState { WaitingSync , Synchronized , Invalid }
Sync State. More...
enum | HPFOrder { OneOrder = 1 , TwoOrder = 2 }
High-pass filter order. More...
enum | ChoppingFrequency { fMod32 , fMod8 }
Modulator Chopping Frequency Enum. More...
enum class SamplingState {
Idle = 1 << 0 , WaitingForStart = 1 << 1 , PreSampling = 1 << 2 , WaitingForRefTrigger = 1 << 3 ,
PostSampling = 1 << 4 , RecordCompleted = 1 << 5 , WaitingForAdvanceTrigger = 1 << 6 , Done = 1 << 7
}
Sampling State Enum. More...
enum class | JY9516CoreOOPropertyType { READ_ONLY = 1 , WRITE_ONLY = 2 , READ_WRITE = 3 }
enum class JYDriverExceptionPublic {
UnKnown = 0 , OpenDeviceFailed = -10001 , CloseDeviceFailed = -10002 , ResetDeviceFailed = -10003 ,
GetDevicePropertyFailed = -10004 , SetDevicePropertyFailed = -10005 , HardwareResourceIsReserved = -10006 , MethodNotPermitedToCallWhenCurrentStatus = -10007 ,
InvalidUserDataBuffer = -10008 , NoChannelAdded = -10009 , NotSupportOperationForCurrentDevice = -10010 , CreatTaskFailed = -10100 ,
StartTaskFailed = -10101 , StopTaskFailed = -10102 , TaskHasNotStarted = -10103 , TaskHasStartedCannotPerformTheSetOperation = -10104 ,
ChannelNumberParameterInvalid = -10105 , ChannelInputRangeParameterInvalid = -10106 , ChannelTerminalParameterInvalid = -10107 , ChannelCouplingParameterInvalid = -10108 ,
SampeleModeParameterInvalid = -10109 , SampleClockParameterInvalid = -10110 , SampleRateParameterInvalid = -10111 , UpdateRateParameterInvalid = -10112 ,
TriggerParameterInvalid = -10113 , ReferenceTriggerDoesNotMatchWithSampleMode = -10114 , PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint = -10115 , ReadDataFailed = -10016 ,
ReadDataTimeout = -10017 , WriteDataFailed = -10018 , WriteDataTimeout = -10019 , WriteDataLengthCannotBeLessThanN = -10020 ,
BufferDataOverflow = -10021 , BufferDataDownflow = -10022 , CheckBufferFailed = -10023 , PointInvalidInFiniteMode = -10024 ,
ReadPointInvalid = -10025 , OnlySupportRecordMode = -10026 , SendSoftTirggerFailed = -10027 , TaskTimeout = -10028 ,
CounterParametersInvalid = -10029 , WritePointInvalid = -10030 , SignalExportDestinationInvalid = -10031 , InvalidParameter = -10033
}
驱动常用错误代码枚举定义 More...
enum class SignalExportDestination {
Ext_Trig = JY9516Import::JY9516_DigitalTriggerSource_External , PXI_Trig0 = JY9516Import::JY9516_DigitalTriggerSource_BUS_0 , PXI_Trig1 = JY9516Import::JY9516_DigitalTriggerSource_BUS_1 , PXI_Trig2 = JY9516Import::JY9516_DigitalTriggerSource_BUS_2 ,
PXI_Trig3 = JY9516Import::JY9516_DigitalTriggerSource_BUS_3 , PXI_Trig4 = JY9516Import::JY9516_DigitalTriggerSource_BUS_4 , PXI_Trig5 = JY9516Import::JY9516_DigitalTriggerSource_BUS_5 , PXI_Trig6 = JY9516Import::JY9516_DigitalTriggerSource_BUS_6 ,
PXI_Trig7 = JY9516Import::JY9516_DigitalTriggerSource_BUS_7 , PXI_Star = JY9516Import::JY9516_DigitalTriggerSource_STAR
}
enum class | OutputCompleteState { Zero , Hold }
Output Complete State. More...
enum class | LevelPolarity { LowLevel = 0 , HighLevel = 1 , None = 2 }
Level Polarity. More...
enum | LPFMode { Normal = 0 , WideBandwidth = 1 }
Low-Pass Filter Mode Enum. More...
enum | ADCFilterType { WidebandLowRippleFilter = JY9516Import::WidebandLowRippleFilter , Sinc5Filter = JY9516Import::Sinc5Filter }
ADC Filter Type Enum. More...
enum class | ExternalReferenceClockTerminal { PXIe_Clk100 = JY9516Import::JY9516_PXIe_Clk_100M }
enum class | ReferenceClockSource { Internal = 0x0 , External = 0x1 }
enum class JY9516CoreOOLogLevel {
DEBUG_LOG_LEVEL , INFO_LOG_LEVEL , WARN_LOG_LEVEL , ERROR_LOG_LEVEL ,
FATAL_LOG_LEVEL
}

Functions

std::string GetSignalExportDestinationString (SignalExportDestination destination)

Variables

const std::map< int, std::string > | AIRangeDescriptions
const double | AIRagneGrade [6] = { 0.3125, 0.6250, 1.25, 2.50, 5.0, 10.0 }

Enumeration Type Documentation

◆ ADCFilterType

enum JY9516CoreOO::ADCFilterType

ADC Filter Type Enum.

Enumerator
WidebandLowRippleFilter | Wideband low ripple filter, −3dB at 0.433 * SampleRate, with 34/SampleRate group delay. This filter has a flat pass band (±0.005 dB ripple) from dc to 102.4 kHz at 256 kSPS, from dc to 51.2 kHz at 128 kSPS, or from dc to 12.8 kHz at 32 kSPS
Sinc5Filter | Sinc5 low latency filter, −3dB at 0.204 * SampleRate, with 3/SampleRate group delay. This filter has a low latency path for low bandwidth, and low noise measurements.

◆ AIAnalogTriggerComparator

enum class JY9516CoreOO::AIAnalogTriggerComparator
strong

AI Analog Trigger Comparator.

Enumerator
Edge | Edge Comparator.
Hysteresis | Hysteresis Comparator.
Window | Window Comparator.

◆ AIAnalogTriggerEdge

enum class JY9516CoreOO::AIAnalogTriggerEdge
strong

AI Analog Trigger Edge.

Enumerator
Rising | Rising.
Falling | Falling.

◆ AIAnalogTriggerSource

enum class JY9516CoreOO::AIAnalogTriggerSource
strong

Analog Trigger source.

Enumerator
Channel_0 | channel 0
Channel_1 | channel 1
Channel_2 | channel 2
Channel_3 | channel 3
Channel_4 | channel 4
Channel_5 | channel 5
Channel_6 | channel 6
Channel_7 | channel 7
Channel_8 | channel 8
Channel_9 | channel 9
Channel_10 | channel 10
Channel_11 | channel 11
Channel_12 | channel 12
Channel_13 | channel 13
Channel_14 | channel 14
Channel_15 | channel 15
Channel_16 | channel 16
Channel_17 | channel 17
Channel_18 | channel 18
Channel_19 | channel 19
Channel_20 | channel 20
Channel_21 | channel 21
Channel_22 | channel 22
Channel_23 | channel 23
Channel_24 | channel 24
Channel_25 | channel 25
Channel_26 | channel 26
Channel_27 | channel 27
Channel_28 | channel 28
Channel_29 | channel 29
Channel_30 | channel 30
Channel_31 | channel 31

◆ AIAnalogWindowCondition

enum class JY9516CoreOO::AIAnalogWindowCondition
strong

AI Analog Window Trigger Condition.

Enumerator
Entering | Rising.
Leaving | Falling.

◆ AIDigitalTriggerEdge

enum class JY9516CoreOO::AIDigitalTriggerEdge
strong

AI Digital Trigger Edge enum type.

Enumerator
Rising | Rising.
Falling | Falling.

◆ AIDigitalTriggerSource

enum class JY9516CoreOO::AIDigitalTriggerSource
strong

AI digital trigger source enum type.

Enumerator
Ext_Trig | External Trigger.
PXI_Trig0 | PXI Trigger 0.
PXI_Trig1 | PXI Trigger 1.
PXI_Trig2 | PXI Trigger 2.
PXI_Trig3 | PXI Trigger 3.
PXI_Trig4 | PXI Trigger 4.
PXI_Trig5 | PXI Trigger 5.
PXI_Trig6 | PXI Trigger 6.
PXI_Trig7 | PXI Trigger 7.
PXI_Star | PXI Star.

◆ AIMode

enum class JY9516CoreOO::AIMode
strong
Enumerator
Finite | Finite mode.
Continuous | Continuous mode.
Single | Single point mode.

◆ AIRange

enum class JY9516CoreOO::AIRange
strong
Enumerator
_10V | ±10V
_5V | ±5V
_2p5V | ±2.5V
_1p25V | ±1.25V
_0p625V | ±0.625V
_0p3125V | ±0.3125V

◆ AISignalExportSource

enum class JY9516CoreOO::AISignalExportSource
strong

AI Signal Export Source Enum.

Enumerator
SampleClock | AI Sample Clock.
Sync | Sync Signal from Master to Slave(s)
ReadyForStartTrigger | Ready for Trigger.
StartTrigger | Trigger Out.
EndOfRecord | End of Record.
EndOfAcquisition | End of Acquisition.

◆ AITriggerMode

enum class JY9516CoreOO::AITriggerMode
strong

AI trigger mode enum type.

Enumerator
Start | Start Trigger.
Reference | Reference Trigger，Valid when JY9516aiTask.Mode is AIMode.Finite

◆ AITriggerType

enum class JY9516CoreOO::AITriggerType
strong

AI trigger type enum type.

Enumerator
Immediately | Immediately, no trigger.
Digital | Digital trigger.
Software | Software trigger.
Analog | Analog trigger.

◆ ChoppingFrequency

enum JY9516CoreOO::ChoppingFrequency

Modulator Chopping Frequency Enum.

Enumerator
fMod32 | Chop at fMod/32.
fMod8 | Chop at fMod/8. Default.

◆ Coupling

enum class JY9516CoreOO::Coupling
strong

Coupling.

Enumerator
AC | AC.
DC | DC.

◆ ExternalReferenceClockTerminal

enum class JY9516CoreOO::ExternalReferenceClockTerminal
strong

外部参考时钟输入端口

External Reference Clcok Terminal

Enumerator
PXIe_Clk100

PXIe_DStarA

PXIe_DStarA

◆ HPFOrder

enum JY9516CoreOO::HPFOrder

High-pass filter order.

Enumerator
OneOrder | One-order.
TwoOrder | Two-order.

◆ IEPEConnectionStatus

enum class JY9516CoreOO::IEPEConnectionStatus
strong

IEPE Connection Status.

Enumerator
Normal | Normal.
OpenCircuit | Open circuit.
ShortCircuit | Short circuit.

◆ JY9516CoreOOLogLevel

enum class JY9516CoreOO::JY9516CoreOOLogLevel
strong
Enumerator
DEBUG_LOG_LEVEL
INFO_LOG_LEVEL
WARN_LOG_LEVEL
ERROR_LOG_LEVEL
FATAL_LOG_LEVEL

◆ JY9516CoreOOPropertyType

enum class JY9516CoreOO::JY9516CoreOOPropertyType
strong
Enumerator
READ_ONLY
WRITE_ONLY
READ_WRITE

◆ JYDriverExceptionPublic

enum class JY9516CoreOO::JYDriverExceptionPublic
strong

驱动常用错误代码枚举定义

Enumerator
UnKnown | JYDriverExceptionPublic.
OpenDeviceFailed | JYDriverExceptionPublic.
CloseDeviceFailed | JYDriverExceptionPublic.
ResetDeviceFailed | JYDriverExceptionPublic.
GetDevicePropertyFailed | JYDriverExceptionPublic.
SetDevicePropertyFailed | JYDriverExceptionPublic.
HardwareResourceIsReserved | JYDriverExceptionPublic.
MethodNotPermitedToCallWhenCurrentStatus | JYDriverExceptionPublic.
InvalidUserDataBuffer | JYDriverExceptionPublic.
NoChannelAdded | JYDriverExceptionPublic.
NotSupportOperationForCurrentDevice | JYDriverExceptionPublic.
CreatTaskFailed | JYDriverExceptionPublic.
StartTaskFailed | JYDriverExceptionPublic.
StopTaskFailed | JYDriverExceptionPublic.
TaskHasNotStarted | JYDriverExceptionPublic.
TaskHasStartedCannotPerformTheSetOperation | JYDriverExceptionPublic.
ChannelNumberParameterInvalid | JYDriverExceptionPublic.
ChannelInputRangeParameterInvalid | JYDriverExceptionPublic.
ChannelTerminalParameterInvalid | JYDriverExceptionPublic.
ChannelCouplingParameterInvalid | JYDriverExceptionPublic.
SampeleModeParameterInvalid | JYDriverExceptionPublic.
SampleClockParameterInvalid | JYDriverExceptionPublic.
SampleRateParameterInvalid | JYDriverExceptionPublic.
UpdateRateParameterInvalid | JYDriverExceptionPublic.
TriggerParameterInvalid | JYDriverExceptionPublic.
ReferenceTriggerDoesNotMatchWithSampleMode | JYDriverExceptionPublic.
PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint | JYDriverExceptionPublic.
ReadDataFailed | JYDriverExceptionPublic.
ReadDataTimeout | JYDriverExceptionPublic.
WriteDataFailed | JYDriverExceptionPublic.
WriteDataTimeout | JYDriverExceptionPublic.
WriteDataLengthCannotBeLessThanN | JYDriverExceptionPublic.
BufferDataOverflow | JYDriverExceptionPublic.
BufferDataDownflow | JYDriverExceptionPublic.
CheckBufferFailed | JYDriverExceptionPublic.
PointInvalidInFiniteMode | JYDriverExceptionPublic.
ReadPointInvalid | JYDriverExceptionPublic.
OnlySupportRecordMode | JYDriverExceptionPublic.
SendSoftTirggerFailed | JYDriverExceptionPublic.
TaskTimeout | JYDriverExceptionPublic.
CounterParametersInvalid | JYDriverExceptionPublic.
WritePointInvalid | JYDriverExceptionPublic.
SignalExportDestinationInvalid | JYDriverExceptionPublic.
InvalidParameter | 无效参数。 Invalid parameter.

◆ LevelPolarity

enum class JY9516CoreOO::LevelPolarity
strong

Level Polarity.

Enumerator
LowLevel | Low level.
HighLevel | High level.
None | No active polarity.

◆ LPFMode

enum JY9516CoreOO::LPFMode

Low-Pass Filter Mode Enum.

Enumerator
Normal | Normal Mode. It has 0.4Fs bandwidth, medium latency, and a maximum sample rate of 256kSa/s
WideBandwidth | Wide Bandwidth Mode. It has 0.4535Fs bandwidth, high latency, and a maximum sample rate of 128kSa/s

◆ OutputCompleteState

enum class JY9516CoreOO::OutputCompleteState
strong

Output Complete State.

Enumerator
Zero | Output Complete Zero.
Hold | Output Complete Hold in The last point.

◆ ReferenceClockSource

enum class JY9516CoreOO::ReferenceClockSource
strong

Reference Clock Source

Enumerator
Internal | Internal on board 25MHz Clock.
External | External Reference Clock Source.

◆ SamplingState

enum class JY9516CoreOO::SamplingState
strong

Sampling State Enum.

Enumerator
Idle | Idle.
WaitingForStart | Waiting for start trigger.
PreSampling | Pre-sampling.
WaitingForRefTrigger | Waiting for reference trigger.
PostSampling | Post-sampling.
RecordCompleted | Record completed.
WaitingForAdvanceTrigger | Waiting for advance trigger.
Done | Done.

◆ SignalExportDestination

enum class JY9516CoreOO::SignalExportDestination
strong
Enumerator
Ext_Trig | External Trigger.
PXI_Trig0 | PXI Trigger 0.
PXI_Trig1 | PXI Trigger 1.
PXI_Trig2 | PXI Trigger 2.
PXI_Trig3 | PXI Trigger 3.
PXI_Trig4 | PXI Trigger 4.
PXI_Trig5 | PXI Trigger 5.
PXI_Trig6 | PXI Trigger 6.
PXI_Trig7 | PXI Trigger 7.
PXI_Star | PXI Star.

◆ SyncState

enum JY9516CoreOO::SyncState

Sync State.

Enumerator
WaitingSync | Waiting for Sync signal as a Slave device.
Synchronized | Already received Sync signal as a Slave device.
Invalid | This status is invalid when multi-card synchronization is not enabled or when the device is a Master device.

◆ SyncTerminal

enum JY9516CoreOO::SyncTerminal

AI digital trigger source enum type.

Enumerator
Ext_Trig | External Trigger.
PXI_Trig0 | PXI Trigger 0.
PXI_Trig1 | PXI Trigger 1.
PXI_Trig2 | PXI Trigger 2.
PXI_Trig3 | PXI Trigger 3.
PXI_Trig4 | PXI Trigger 4.
PXI_Trig5 | PXI Trigger 5.
PXI_Trig6 | PXI Trigger 6.
PXI_Trig7 | PXI Trigger 7.
PXI_Star | PXI Star.

◆ SyncTopology

enum class JY9516CoreOO::SyncTopology
strong

Synchronization board configuration.

Enumerator
Independent | Independent, synchronization not supported
Master | master card
Slave | slave card

Function Documentation

◆ GetSignalExportDestinationString()

std::string JY9516CoreOO::GetSignalExportDestinationString ( SignalExportDestination destination )
inline

Variable Documentation

◆ AIRagneGrade

const double JY9516CoreOO::AIRagneGrade[6] = { 0.3125, 0.6250, 1.25, 2.50, 5.0, 10.0 }

◆ AIRangeDescriptions

const std::map<int, std::string> JY9516CoreOO::AIRangeDescriptions
Initial value:
= {
{ JY9516Import::JY9516_Range_10V, "±10V" },
{ JY9516Import::JY9516_Range_5V, "±5V" },
{ JY9516Import::JY9516_Range_2p5V, "±2.5V" },
{ JY9516Import::JY9516_Range_1p25V, "±1.25V" },
{ JY9516Import::JY9516_Range_0p625V, "±0.625V" },
{ JY9516Import::JY9516_Range_0p3125V, "±0.3125V" }
}
JY9516Import::JY9516_Range_0p3125V
const int JY9516_Range_0p3125V
Definition JY9516CoreOOCommon.h:43
JY9516Import::JY9516_Range_2p5V
const int JY9516_Range_2p5V
Definition JY9516CoreOOCommon.h:40
JY9516Import::JY9516_Range_1p25V
const int JY9516_Range_1p25V
Definition JY9516CoreOOCommon.h:41
JY9516Import::JY9516_Range_5V
const int JY9516_Range_5V
Definition JY9516CoreOOCommon.h:39
JY9516Import::JY9516_Range_0p625V
const int JY9516_Range_0p625V
Definition JY9516CoreOOCommon.h:42
JY9516Import::JY9516_Range_10V
const int JY9516_Range_10V
Definition JY9516CoreOOCommon.h:38


9516 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/9516/JY9516CoreOOCommon.h File Reference

  • File List
  • File Members
  • COO
  • 9516
Classes | Namespaces | Macros | Enumerations | Functions | Variables
JY9516CoreOOCommon.h File Reference
#include <cstring>
#include <string>
#include <stdint.h>

Classes

class | JY9516CoreOO::JYDriverException
class | JY9516CoreOO::JY9516CoreOOProperty< ContainerClass, ValueType, propertyType >
属性模板类 More...
class | JY9516CoreOO::PauseTrigger
Pause trigger configuration class. More...
struct | JY9516CoreOO::FirmDriveInfo

Namespaces

namespace | JY9516Import
namespace | JY9516CoreOO

Macros

#define | EXTERN_C extern
Windows.
#define | JY9516CoreOO_API

Enumerations

enum class | JY9516CoreOO::JY9516CoreOOPropertyType { JY9516CoreOO::READ_ONLY = 1 , JY9516CoreOO::WRITE_ONLY = 2 , JY9516CoreOO::READ_WRITE = 3 }
enum class JY9516CoreOO::JYDriverExceptionPublic {
JY9516CoreOO::UnKnown = 0 , JY9516CoreOO::OpenDeviceFailed = -10001 , JY9516CoreOO::CloseDeviceFailed = -10002 , JY9516CoreOO::ResetDeviceFailed = -10003 ,
JY9516CoreOO::GetDevicePropertyFailed = -10004 , JY9516CoreOO::SetDevicePropertyFailed = -10005 , JY9516CoreOO::HardwareResourceIsReserved = -10006 , JY9516CoreOO::MethodNotPermitedToCallWhenCurrentStatus = -10007 ,
JY9516CoreOO::InvalidUserDataBuffer = -10008 , JY9516CoreOO::NoChannelAdded = -10009 , JY9516CoreOO::NotSupportOperationForCurrentDevice = -10010 , JY9516CoreOO::CreatTaskFailed = -10100 ,
JY9516CoreOO::StartTaskFailed = -10101 , JY9516CoreOO::StopTaskFailed = -10102 , JY9516CoreOO::TaskHasNotStarted = -10103 , JY9516CoreOO::TaskHasStartedCannotPerformTheSetOperation = -10104 ,
JY9516CoreOO::ChannelNumberParameterInvalid = -10105 , JY9516CoreOO::ChannelInputRangeParameterInvalid = -10106 , JY9516CoreOO::ChannelTerminalParameterInvalid = -10107 , JY9516CoreOO::ChannelCouplingParameterInvalid = -10108 ,
JY9516CoreOO::SampeleModeParameterInvalid = -10109 , JY9516CoreOO::SampleClockParameterInvalid = -10110 , JY9516CoreOO::SampleRateParameterInvalid = -10111 , JY9516CoreOO::UpdateRateParameterInvalid = -10112 ,
JY9516CoreOO::TriggerParameterInvalid = -10113 , JY9516CoreOO::ReferenceTriggerDoesNotMatchWithSampleMode = -10114 , JY9516CoreOO::PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint = -10115 , JY9516CoreOO::ReadDataFailed = -10016 ,
JY9516CoreOO::ReadDataTimeout = -10017 , JY9516CoreOO::WriteDataFailed = -10018 , JY9516CoreOO::WriteDataTimeout = -10019 , JY9516CoreOO::WriteDataLengthCannotBeLessThanN = -10020 ,
JY9516CoreOO::BufferDataOverflow = -10021 , JY9516CoreOO::BufferDataDownflow = -10022 , JY9516CoreOO::CheckBufferFailed = -10023 , JY9516CoreOO::PointInvalidInFiniteMode = -10024 ,
JY9516CoreOO::ReadPointInvalid = -10025 , JY9516CoreOO::OnlySupportRecordMode = -10026 , JY9516CoreOO::SendSoftTirggerFailed = -10027 , JY9516CoreOO::TaskTimeout = -10028 ,
JY9516CoreOO::CounterParametersInvalid = -10029 , JY9516CoreOO::WritePointInvalid = -10030 , JY9516CoreOO::SignalExportDestinationInvalid = -10031 , JY9516CoreOO::InvalidParameter = -10033
}
驱动常用错误代码枚举定义 More...
enum class JY9516CoreOO::SignalExportDestination {
JY9516CoreOO::Ext_Trig = JY9516Import::JY9516_DigitalTriggerSource_External , JY9516CoreOO::PXI_Trig0 = JY9516Import::JY9516_DigitalTriggerSource_BUS_0 , JY9516CoreOO::PXI_Trig1 = JY9516Import::JY9516_DigitalTriggerSource_BUS_1 , JY9516CoreOO::PXI_Trig2 = JY9516Import::JY9516_DigitalTriggerSource_BUS_2 ,
JY9516CoreOO::PXI_Trig3 = JY9516Import::JY9516_DigitalTriggerSource_BUS_3 , JY9516CoreOO::PXI_Trig4 = JY9516Import::JY9516_DigitalTriggerSource_BUS_4 , JY9516CoreOO::PXI_Trig5 = JY9516Import::JY9516_DigitalTriggerSource_BUS_5 , JY9516CoreOO::PXI_Trig6 = JY9516Import::JY9516_DigitalTriggerSource_BUS_6 ,
JY9516CoreOO::PXI_Trig7 = JY9516Import::JY9516_DigitalTriggerSource_BUS_7 , JY9516CoreOO::PXI_Star = JY9516Import::JY9516_DigitalTriggerSource_STAR
}
enum class | JY9516CoreOO::OutputCompleteState { JY9516CoreOO::Zero , JY9516CoreOO::Hold }
Output Complete State. More...
enum class | JY9516CoreOO::LevelPolarity { JY9516CoreOO::LowLevel = 0 , JY9516CoreOO::HighLevel = 1 , JY9516CoreOO::None = 2 }
Level Polarity. More...

Functions

std::string JY9516CoreOO::GetSignalExportDestinationString (SignalExportDestination destination)

Variables

const int | JY9516Import::JY9516_Onboard_10M = 0
const int | JY9516Import::JY9516_PXIe_Clk_100M = 1
const int | JY9516Import::JY9516_Range_15V = 6
const int | JY9516Import::JY9516_Range_10V = 5
const int | JY9516Import::JY9516_Range_5V = 4
const int | JY9516Import::JY9516_Range_2p5V = 3
const int | JY9516Import::JY9516_Range_1p25V = 2
const int | JY9516Import::JY9516_Range_0p625V = 1
const int | JY9516Import::JY9516_Range_0p3125V = 0
const int | JY9516Import::JY9516_Coupling_AC = 0
const int | JY9516Import::JY9516_Coupling_DC = 1
const int | JY9516Import::WidebandLowRippleFilter = 0
const int | JY9516Import::Sinc5Filter = 1
const int | JY9516Import::JY9516_AI_Finite = 0
const int | JY9516Import::JY9516_AI_Continuous = 1
const int | JY9516Import::JY9516_AI_Single = 2
const int | JY9516Import::JY9516_TriggerType_Immediately = 0
const int | JY9516Import::JY9516_TriggerType_Digital = 1
const int | JY9516Import::JY9516_TriggerType_Software = 2
const int | JY9516Import::JY9516_TriggerType_Analog = 3
const int | JY9516Import::JY9516_DigitalTriggerEdge_Rising = 0
const int | JY9516Import::JY9516_DigitalTriggerEdge_Falling = 1
const int | JY9516Import::JY9516_DigitalTriggerSource_External = 0
const int | JY9516Import::JY9516_DigitalTriggerSource_BUS_0 = 1
const int | JY9516Import::JY9516_DigitalTriggerSource_BUS_1 = 2
const int | JY9516Import::JY9516_DigitalTriggerSource_BUS_2 = 3
const int | JY9516Import::JY9516_DigitalTriggerSource_BUS_3 = 4
const int | JY9516Import::JY9516_DigitalTriggerSource_BUS_4 = 5
const int | JY9516Import::JY9516_DigitalTriggerSource_BUS_5 = 6
const int | JY9516Import::JY9516_DigitalTriggerSource_BUS_6 = 7
const int | JY9516Import::JY9516_DigitalTriggerSource_BUS_7 = 8
const int | JY9516Import::JY9516_DigitalTriggerSource_STAR = 9
const int | JY9516Import::JY9516_AnlogTriggerCondition_RisingHysteresis = 0
const int | JY9516Import::JY9516_AnlogTriggerCondition_FallingHysteresis = 1
const int | JY9516Import::JY9516_AnlogTriggerCondition_EnteringWindow = 2
const int | JY9516Import::JY9516_AnlogTriggerCondition_LeavingWindow = 3
const int | JY9516Import::JY9516_SyncMode_Solo = 0
const int | JY9516Import::JY9516_SyncMode_Master = 1
const int | JY9516Import::JY9516_SyncMode_Slave = 2
const int | JY9516Import::JY9516_EXPORT_SAMPLE_CLOCK = 0
const int | JY9516Import::JY9516_EXPORT_SYNC = 1
const int | JY9516Import::JY9516_EXPORT_RX_READY_FOR_START_TRIG = 2
const int | JY9516Import::JY9516_EXPORT_RX_START_TRIG = 3
const int | JY9516Import::JY9516_EXPORT_RX_READY_FOR_REF_TRIG = 4
const int | JY9516Import::JY9516_EXPORT_RX_REF_TRIG = 5
const int | JY9516Import::JY9516_EXPORT_RX_READY_FOR_ADV_TRIG = 6
const int | JY9516Import::JY9516_EXPORT_RX_ADV_TRIG = 7
const int | JY9516Import::JY9516_EXPORT_RX_END_OF_RECORD = 8
const int | JY9516Import::JY9516_EXPORT_RX_ENGINE_END = 9
const int | JY9516Import::JY9516_EXPORT_MCLK = 10
const int | JY9516Import::JY9516_EXPORT_DCLK = 11
const int | JY9516Import::JY9516_EXPORT_PLL_SYNC = 12
const int | JY9516Import::JY9516_EXPORT_ADC_SYNC = 13
const int | JY9516Import::JY9516_EXPORT_ADC_DRDY = 14
const int | JY9516Import::JY9516_CalCoePosition_EEPROM = 0
const int | JY9516Import::JY9516_CalCoePosition_Handle = 1
const int | JY9516Import::JY9516_ADCChopping_fMod32 = 0
const int | JY9516Import::JY9517_ADCChopping_fMod8 = 1

Macro Definition Documentation

◆ EXTERN_C

#define EXTERN_C extern

Windows.

Linux

◆ JY9516CoreOO_API

#define JY9516CoreOO_API


9516 C++ Programming Manual: JY9516CoreOO::JYDriverException Class Reference

  • JYDriverException
Public Member Functions | Public Attributes | List of all members
JY9516CoreOO::JYDriverException Class Reference

#include <JY9516CoreOOCommon.h>

Public Member Functions

JYDriverException (JYDriverExceptionPublic exceptionCode, std::string msg="")
JYDriverException (int, std::string msg)

Public Attributes

std::string exceptionMessage
JYDriverExceptionPublic errorCode
JYDriverException * FollowingException

Constructor & Destructor Documentation

◆ JYDriverException() [1/2]

JY9516CoreOO::JYDriverException::JYDriverException | ( | JYDriverExceptionPublic | exceptionCode,
 |  | std::string | msg = "" )

◆ JYDriverException() [2/2]

JY9516CoreOO::JYDriverException::JYDriverException | ( | int | ,
 |  | std::string | msg )

Member Data Documentation

◆ errorCode

JYDriverExceptionPublic JY9516CoreOO::JYDriverException::errorCode

◆ exceptionMessage

std::string JY9516CoreOO::JYDriverException::exceptionMessage

◆ FollowingException

JYDriverException* JY9516CoreOO::JYDriverException::FollowingException
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9516/JY9516CoreOOCommon.h


9516 C++ Programming Manual: JY9516CoreOO::JY9516CoreOOProperty< ContainerClass, ValueType, propertyType > Class Template Reference

  • JY9516CoreOOProperty
Public Member Functions | List of all members
JY9516CoreOO::JY9516CoreOOProperty< ContainerClass, ValueType, propertyType > Class Template Reference

属性模板类 More...

#include <JY9516CoreOOCommon.h>

Public Member Functions

JY9516CoreOOProperty ()
JY9516CoreOOProperty (ContainerClass *cObject, ValueType(ContainerClass::*pGet)(), void(ContainerClass::*pSet)(ValueType value))
JY9516CoreOOProperty (ValueType(*pGet)(), void(*pSet)(ValueType value))
ValueType operator= (const ValueType &value)
operator ValueType ()

Detailed Description

template<typename ContainerClass, typename ValueType, JY9516CoreOOPropertyType propertyType>
class JY9516CoreOO::JY9516CoreOOProperty< ContainerClass, ValueType, propertyType >

属性模板类

Constructor & Destructor Documentation

◆ JY9516CoreOOProperty() [1/3]

template<typename ContainerClass, typename ValueType, JY9516CoreOOPropertyType propertyType>
JY9516CoreOO::JY9516CoreOOProperty< ContainerClass, ValueType, propertyType >::JY9516CoreOOProperty ( )

◆ JY9516CoreOOProperty() [2/3]

template<typename ContainerClass, typename ValueType, JY9516CoreOOPropertyType propertyType>
JY9516CoreOO::JY9516CoreOOProperty< ContainerClass, ValueType, propertyType >::JY9516CoreOOProperty | ( | ContainerClass * | cObject,
 |  | ValueType(ContainerClass::* | pGet )(),
 |  | void(ContainerClass::* | pSet )(ValueType value) )

◆ JY9516CoreOOProperty() [3/3]

template<typename ContainerClass, typename ValueType, JY9516CoreOOPropertyType propertyType>
JY9516CoreOO::JY9516CoreOOProperty< ContainerClass, ValueType, propertyType >::JY9516CoreOOProperty | ( | ValueType(* | pGet )(),
 |  | void(* | pSet )(ValueType value) )

Member Function Documentation

◆ operator ValueType()

template<typename ContainerClass, typename ValueType, JY9516CoreOOPropertyType propertyType>
JY9516CoreOO::JY9516CoreOOProperty< ContainerClass, ValueType, propertyType >::operator ValueType ( )

◆ operator=()

template<typename ContainerClass, typename ValueType, JY9516CoreOOPropertyType propertyType>
ValueType JY9516CoreOO::JY9516CoreOOProperty< ContainerClass, ValueType, propertyType >::operator= ( const ValueType & value )
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9516/JY9516CoreOOCommon.h


9516 C++ Programming Manual: JY9516CoreOO::PauseTrigger Class Reference

  • PauseTrigger
Public Attributes | List of all members
JY9516CoreOO::PauseTrigger Class Reference

Pause trigger configuration class. More...

#include <JY9516CoreOOCommon.h>

Public Attributes

LevelPolarity ActivePolarity
Pause trigger active polarity.
InputTerminal Terminal
Terminal.

Detailed Description

Pause trigger configuration class.

Member Data Documentation

◆ ActivePolarity

LevelPolarity JY9516CoreOO::PauseTrigger::ActivePolarity

Pause trigger active polarity.

The default value is LevelPolarity.None, means the pause trigger is disabled.

◆ Terminal

InputTerminal JY9516CoreOO::PauseTrigger::Terminal

Terminal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9516/JY9516CoreOOCommon.h


9516 C++ Programming Manual: JY9516CoreOO::FirmDriveInfo Struct Reference

  • FirmDriveInfo
Public Attributes | List of all members
JY9516CoreOO::FirmDriveInfo Struct Reference

#include <JY9516CoreOOCommon.h>

Public Attributes

int | VID
int | PID
int | slotNum
int | connected
int | cardNumber
int | fStreaming
char | serialNumber [33]
char | vendorName [65]
char | model [65]
char | aliasName [65]
char | PlatformType [16]
char | HardwareVer [16]
char | FirmwareVer [16]
char | FrameworkVer [16]
char | DriverSetVer [16]
char | ProductionDate [16]

Member Data Documentation

◆ aliasName

char JY9516CoreOO::FirmDriveInfo::aliasName[65]

◆ cardNumber

int JY9516CoreOO::FirmDriveInfo::cardNumber

◆ connected

int JY9516CoreOO::FirmDriveInfo::connected

◆ DriverSetVer

char JY9516CoreOO::FirmDriveInfo::DriverSetVer[16]

◆ FirmwareVer

char JY9516CoreOO::FirmDriveInfo::FirmwareVer[16]

◆ FrameworkVer

char JY9516CoreOO::FirmDriveInfo::FrameworkVer[16]

◆ fStreaming

int JY9516CoreOO::FirmDriveInfo::fStreaming

◆ HardwareVer

char JY9516CoreOO::FirmDriveInfo::HardwareVer[16]

◆ model

char JY9516CoreOO::FirmDriveInfo::model[65]

◆ PID

int JY9516CoreOO::FirmDriveInfo::PID

◆ PlatformType

char JY9516CoreOO::FirmDriveInfo::PlatformType[16]

◆ ProductionDate

char JY9516CoreOO::FirmDriveInfo::ProductionDate[16]

◆ serialNumber

char JY9516CoreOO::FirmDriveInfo::serialNumber[33]

◆ slotNum

int JY9516CoreOO::FirmDriveInfo::slotNum

◆ vendorName

char JY9516CoreOO::FirmDriveInfo::vendorName[65]

◆ VID

int JY9516CoreOO::FirmDriveInfo::VID
The documentation for this struct was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9516/JY9516CoreOOCommon.h


9516 C++ Programming Manual: JY9516Import Namespace Reference

  • Namespace List
  • Namespace Members
Variables
JY9516Import Namespace Reference

Variables

const int | JY9516_Onboard_10M = 0
const int | JY9516_PXIe_Clk_100M = 1
const int | JY9516_Range_15V = 6
const int | JY9516_Range_10V = 5
const int | JY9516_Range_5V = 4
const int | JY9516_Range_2p5V = 3
const int | JY9516_Range_1p25V = 2
const int | JY9516_Range_0p625V = 1
const int | JY9516_Range_0p3125V = 0
const int | JY9516_Coupling_AC = 0
const int | JY9516_Coupling_DC = 1
const int | WidebandLowRippleFilter = 0
const int | Sinc5Filter = 1
const int | JY9516_AI_Finite = 0
const int | JY9516_AI_Continuous = 1
const int | JY9516_AI_Single = 2
const int | JY9516_TriggerType_Immediately = 0
const int | JY9516_TriggerType_Digital = 1
const int | JY9516_TriggerType_Software = 2
const int | JY9516_TriggerType_Analog = 3
const int | JY9516_DigitalTriggerEdge_Rising = 0
const int | JY9516_DigitalTriggerEdge_Falling = 1
const int | JY9516_DigitalTriggerSource_External = 0
const int | JY9516_DigitalTriggerSource_BUS_0 = 1
const int | JY9516_DigitalTriggerSource_BUS_1 = 2
const int | JY9516_DigitalTriggerSource_BUS_2 = 3
const int | JY9516_DigitalTriggerSource_BUS_3 = 4
const int | JY9516_DigitalTriggerSource_BUS_4 = 5
const int | JY9516_DigitalTriggerSource_BUS_5 = 6
const int | JY9516_DigitalTriggerSource_BUS_6 = 7
const int | JY9516_DigitalTriggerSource_BUS_7 = 8
const int | JY9516_DigitalTriggerSource_STAR = 9
const int | JY9516_AnlogTriggerCondition_RisingHysteresis = 0
const int | JY9516_AnlogTriggerCondition_FallingHysteresis = 1
const int | JY9516_AnlogTriggerCondition_EnteringWindow = 2
const int | JY9516_AnlogTriggerCondition_LeavingWindow = 3
const int | JY9516_SyncMode_Solo = 0
const int | JY9516_SyncMode_Master = 1
const int | JY9516_SyncMode_Slave = 2
const int | JY9516_EXPORT_SAMPLE_CLOCK = 0
const int | JY9516_EXPORT_SYNC = 1
const int | JY9516_EXPORT_RX_READY_FOR_START_TRIG = 2
const int | JY9516_EXPORT_RX_START_TRIG = 3
const int | JY9516_EXPORT_RX_READY_FOR_REF_TRIG = 4
const int | JY9516_EXPORT_RX_REF_TRIG = 5
const int | JY9516_EXPORT_RX_READY_FOR_ADV_TRIG = 6
const int | JY9516_EXPORT_RX_ADV_TRIG = 7
const int | JY9516_EXPORT_RX_END_OF_RECORD = 8
const int | JY9516_EXPORT_RX_ENGINE_END = 9
const int | JY9516_EXPORT_MCLK = 10
const int | JY9516_EXPORT_DCLK = 11
const int | JY9516_EXPORT_PLL_SYNC = 12
const int | JY9516_EXPORT_ADC_SYNC = 13
const int | JY9516_EXPORT_ADC_DRDY = 14
const int | JY9516_CalCoePosition_EEPROM = 0
const int | JY9516_CalCoePosition_Handle = 1
const int | JY9516_ADCChopping_fMod32 = 0
const int | JY9517_ADCChopping_fMod8 = 1

Variable Documentation

◆ JY9516_ADCChopping_fMod32

const int JY9516Import::JY9516_ADCChopping_fMod32 = 0

◆ JY9516_AI_Continuous

const int JY9516Import::JY9516_AI_Continuous = 1

◆ JY9516_AI_Finite

const int JY9516Import::JY9516_AI_Finite = 0

◆ JY9516_AI_Single

const int JY9516Import::JY9516_AI_Single = 2

◆ JY9516_AnlogTriggerCondition_EnteringWindow

const int JY9516Import::JY9516_AnlogTriggerCondition_EnteringWindow = 2

◆ JY9516_AnlogTriggerCondition_FallingHysteresis

const int JY9516Import::JY9516_AnlogTriggerCondition_FallingHysteresis = 1

◆ JY9516_AnlogTriggerCondition_LeavingWindow

const int JY9516Import::JY9516_AnlogTriggerCondition_LeavingWindow = 3

◆ JY9516_AnlogTriggerCondition_RisingHysteresis

const int JY9516Import::JY9516_AnlogTriggerCondition_RisingHysteresis = 0

◆ JY9516_CalCoePosition_EEPROM

const int JY9516Import::JY9516_CalCoePosition_EEPROM = 0

◆ JY9516_CalCoePosition_Handle

const int JY9516Import::JY9516_CalCoePosition_Handle = 1

◆ JY9516_Coupling_AC

const int JY9516Import::JY9516_Coupling_AC = 0

◆ JY9516_Coupling_DC

const int JY9516Import::JY9516_Coupling_DC = 1

◆ JY9516_DigitalTriggerEdge_Falling

const int JY9516Import::JY9516_DigitalTriggerEdge_Falling = 1

◆ JY9516_DigitalTriggerEdge_Rising

const int JY9516Import::JY9516_DigitalTriggerEdge_Rising = 0

◆ JY9516_DigitalTriggerSource_BUS_0

const int JY9516Import::JY9516_DigitalTriggerSource_BUS_0 = 1

◆ JY9516_DigitalTriggerSource_BUS_1

const int JY9516Import::JY9516_DigitalTriggerSource_BUS_1 = 2

◆ JY9516_DigitalTriggerSource_BUS_2

const int JY9516Import::JY9516_DigitalTriggerSource_BUS_2 = 3

◆ JY9516_DigitalTriggerSource_BUS_3

const int JY9516Import::JY9516_DigitalTriggerSource_BUS_3 = 4

◆ JY9516_DigitalTriggerSource_BUS_4

const int JY9516Import::JY9516_DigitalTriggerSource_BUS_4 = 5

◆ JY9516_DigitalTriggerSource_BUS_5

const int JY9516Import::JY9516_DigitalTriggerSource_BUS_5 = 6

◆ JY9516_DigitalTriggerSource_BUS_6

const int JY9516Import::JY9516_DigitalTriggerSource_BUS_6 = 7

◆ JY9516_DigitalTriggerSource_BUS_7

const int JY9516Import::JY9516_DigitalTriggerSource_BUS_7 = 8

◆ JY9516_DigitalTriggerSource_External

const int JY9516Import::JY9516_DigitalTriggerSource_External = 0

◆ JY9516_DigitalTriggerSource_STAR

const int JY9516Import::JY9516_DigitalTriggerSource_STAR = 9

◆ JY9516_EXPORT_ADC_DRDY

const int JY9516Import::JY9516_EXPORT_ADC_DRDY = 14

◆ JY9516_EXPORT_ADC_SYNC

const int JY9516Import::JY9516_EXPORT_ADC_SYNC = 13

◆ JY9516_EXPORT_DCLK

const int JY9516Import::JY9516_EXPORT_DCLK = 11

◆ JY9516_EXPORT_MCLK

const int JY9516Import::JY9516_EXPORT_MCLK = 10

◆ JY9516_EXPORT_PLL_SYNC

const int JY9516Import::JY9516_EXPORT_PLL_SYNC = 12

◆ JY9516_EXPORT_RX_ADV_TRIG

const int JY9516Import::JY9516_EXPORT_RX_ADV_TRIG = 7

◆ JY9516_EXPORT_RX_END_OF_RECORD

const int JY9516Import::JY9516_EXPORT_RX_END_OF_RECORD = 8

◆ JY9516_EXPORT_RX_ENGINE_END

const int JY9516Import::JY9516_EXPORT_RX_ENGINE_END = 9

◆ JY9516_EXPORT_RX_READY_FOR_ADV_TRIG

const int JY9516Import::JY9516_EXPORT_RX_READY_FOR_ADV_TRIG = 6

◆ JY9516_EXPORT_RX_READY_FOR_REF_TRIG

const int JY9516Import::JY9516_EXPORT_RX_READY_FOR_REF_TRIG = 4

◆ JY9516_EXPORT_RX_READY_FOR_START_TRIG

const int JY9516Import::JY9516_EXPORT_RX_READY_FOR_START_TRIG = 2

◆ JY9516_EXPORT_RX_REF_TRIG

const int JY9516Import::JY9516_EXPORT_RX_REF_TRIG = 5

◆ JY9516_EXPORT_RX_START_TRIG

const int JY9516Import::JY9516_EXPORT_RX_START_TRIG = 3

◆ JY9516_EXPORT_SAMPLE_CLOCK

const int JY9516Import::JY9516_EXPORT_SAMPLE_CLOCK = 0

◆ JY9516_EXPORT_SYNC

const int JY9516Import::JY9516_EXPORT_SYNC = 1

◆ JY9516_Onboard_10M

const int JY9516Import::JY9516_Onboard_10M = 0

◆ JY9516_PXIe_Clk_100M

const int JY9516Import::JY9516_PXIe_Clk_100M = 1

◆ JY9516_Range_0p3125V

const int JY9516Import::JY9516_Range_0p3125V = 0

◆ JY9516_Range_0p625V

const int JY9516Import::JY9516_Range_0p625V = 1

◆ JY9516_Range_10V

const int JY9516Import::JY9516_Range_10V = 5

◆ JY9516_Range_15V

const int JY9516Import::JY9516_Range_15V = 6

◆ JY9516_Range_1p25V

const int JY9516Import::JY9516_Range_1p25V = 2

◆ JY9516_Range_2p5V

const int JY9516Import::JY9516_Range_2p5V = 3

◆ JY9516_Range_5V

const int JY9516Import::JY9516_Range_5V = 4

◆ JY9516_SyncMode_Master

const int JY9516Import::JY9516_SyncMode_Master = 1

◆ JY9516_SyncMode_Slave

const int JY9516Import::JY9516_SyncMode_Slave = 2

◆ JY9516_SyncMode_Solo

const int JY9516Import::JY9516_SyncMode_Solo = 0

◆ JY9516_TriggerType_Analog

const int JY9516Import::JY9516_TriggerType_Analog = 3

◆ JY9516_TriggerType_Digital

const int JY9516Import::JY9516_TriggerType_Digital = 1

◆ JY9516_TriggerType_Immediately

const int JY9516Import::JY9516_TriggerType_Immediately = 0

◆ JY9516_TriggerType_Software

const int JY9516Import::JY9516_TriggerType_Software = 2

◆ JY9517_ADCChopping_fMod8

const int JY9516Import::JY9517_ADCChopping_fMod8 = 1

◆ Sinc5Filter

const int JY9516Import::Sinc5Filter = 1

◆ WidebandLowRippleFilter

const int JY9516Import::WidebandLowRippleFilter = 0


9516 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/9516/JY9516CoreOODevice.h File Reference

  • File List
  • File Members
  • COO
  • 9516
Classes | Namespaces | Enumerations | Variables
JY9516CoreOODevice.h File Reference
#include <iostream>
#include <stdlib.h>
#include <list>
#include <vector>
#include "JY9516CoreOOCommon.h"

Classes

class | JY9516CoreOO::JY9516CoreOODevice
JY9516CoreOO Device. More...
class | JY9516CoreOO::DeviceStatus
Device Status. More...
class | JY9516CoreOO::SampleInfo
Sampling information. More...
class | JY9516CoreOO::ExternalReferenceClock
External Reference Clcok Terminal. More...
class | JY9516CoreOO::JY9516CoreOOReferenceClock
class | JY9516CoreOO::JY9516DeviceInfo
Device Info. More...

Namespaces

namespace JY9516CoreOO

Enumerations

enum | JY9516CoreOO::LPFMode { JY9516CoreOO::Normal = 0 , JY9516CoreOO::WideBandwidth = 1 }
Low-Pass Filter Mode Enum. More...
enum | JY9516CoreOO::ADCFilterType { JY9516CoreOO::WidebandLowRippleFilter = JY9516Import::WidebandLowRippleFilter , JY9516CoreOO::Sinc5Filter = JY9516Import::Sinc5Filter }
ADC Filter Type Enum. More...
enum class | JY9516CoreOO::ExternalReferenceClockTerminal { JY9516CoreOO::PXIe_Clk100 = JY9516Import::JY9516_PXIe_Clk_100M }
enum class | JY9516CoreOO::ReferenceClockSource { JY9516CoreOO::Internal = 0x0 , JY9516CoreOO::External = 0x1 }

Variables

const double JY9516CoreOO::AIRagneGrade [6] = { 0.3125, 0.6250, 1.25, 2.50, 5.0, 10.0 }


9516 C++ Programming Manual: JY9516CoreOO::JY9516CoreOODevice Class Reference

  • JY9516CoreOODevice
Static Public Member Functions | Public Attributes | List of all members
JY9516CoreOO::JY9516CoreOODevice Class Reference

JY9516CoreOO Device. More...

#include <JY9516CoreOODevice.h>

Static Public Member Functions

static JY9516CoreOODevice * | GetInstance (int cardNum)
The operation instance is obtained according to the board number to ensure that there is only one registered instance for each board.
static JY9516CoreOODevice * | GetInstance (std::string aliasName)
The operation instance is obtained according to aliasName to ensure that there is only one registration instance for each board.
static SampleInfo | ParseSampleRate (double sampleRate, LPFMode filterMode)
Get MCLK and fMod at the specified sampling rate.

Public Attributes

uint32_t | JY9516PID [6] = { 0x9516, 0xA516, 0x9B16, 0xF516, 0xE516, 0xFB16 }
friend | HighPassFilter
const double | BoardClockRate = 100000000
Board Clock Rate.
const uint32_t | AIBufferSize = 1024 * 1024 * 512
AI Buffer Size.
const double | MaxSampleRate = 256000.0
Maximum Sampling Rate.
const double | MinSampleRate = 62.5
Minimum Sampling Rate.
const int | TotalNumberOfChannels = 16
Total Number of Channels Provided.
const double | MaxInputVoltage = 10
Maximum Input Voltage.
JY9516CoreOOProperty< JY9516CoreOODevice, int, JY9516CoreOOPropertyType::READ_ONLY > | DeviceID
JY9516CoreOOProperty< JY9516CoreOODevice, JY9516DeviceInfo *, JY9516CoreOOPropertyType::READ_ONLY > Info
JY9516CoreOOProperty< JY9516CoreOODevice, DeviceStatus *, JY9516CoreOOPropertyType::READ_ONLY > Status
JY9516CoreOOReferenceClock * ReferenceClock
Reference Clock Configuration.

Detailed Description

JY9516CoreOO Device.

Member Function Documentation

◆ GetInstance() [1/2]

static JY9516CoreOODevice * JY9516CoreOO::JY9516CoreOODevice::GetInstance ( int cardNum )
static

The operation instance is obtained according to the board number to ensure that there is only one registered instance for each board.

Parameters
cardNum
Returns

◆ GetInstance() [2/2]

static JY9516CoreOODevice * JY9516CoreOO::JY9516CoreOODevice::GetInstance ( std::string aliasName )
static

The operation instance is obtained according to aliasName to ensure that there is only one registration instance for each board.

Parameters
aliasName
Returns

◆ ParseSampleRate()

static SampleInfo JY9516CoreOO::JY9516CoreOODevice::ParseSampleRate | ( | double | sampleRate,
 |  | LPFMode | filterMode )
 static

Get MCLK and fMod at the specified sampling rate.

Parameters
sampleRate | Specified Sampling Rate
filterMode | Specified Filter Mode

Member Data Documentation

◆ AIBufferSize

const uint32_t JY9516CoreOO::JY9516CoreOODevice::AIBufferSize = 1024 * 1024 * 512

AI Buffer Size.

◆ BoardClockRate

const double JY9516CoreOO::JY9516CoreOODevice::BoardClockRate = 100000000

Board Clock Rate.

◆ DeviceID

JY9516CoreOOProperty<JY9516CoreOODevice, int, JY9516CoreOOPropertyType::READ_ONLY> JY9516CoreOO::JY9516CoreOODevice::DeviceID

◆ HighPassFilter

friend JY9516CoreOO::JY9516CoreOODevice::HighPassFilter

◆ Info

JY9516CoreOOProperty<JY9516CoreOODevice, JY9516DeviceInfo*, JY9516CoreOOPropertyType::READ_ONLY> JY9516CoreOO::JY9516CoreOODevice::Info

◆ JY9516PID

uint32_t JY9516CoreOO::JY9516CoreOODevice::JY9516PID[6] = { 0x9516, 0xA516, 0x9B16, 0xF516, 0xE516, 0xFB16 }

◆ MaxInputVoltage

const double JY9516CoreOO::JY9516CoreOODevice::MaxInputVoltage = 10

Maximum Input Voltage.

◆ MaxSampleRate

const double JY9516CoreOO::JY9516CoreOODevice::MaxSampleRate = 256000.0

Maximum Sampling Rate.

◆ MinSampleRate

const double JY9516CoreOO::JY9516CoreOODevice::MinSampleRate = 62.5

Minimum Sampling Rate.

◆ ReferenceClock

JY9516CoreOOReferenceClock* JY9516CoreOO::JY9516CoreOODevice::ReferenceClock

Reference Clock Configuration.

◆ Status

JY9516CoreOOProperty<JY9516CoreOODevice, DeviceStatus*, JY9516CoreOOPropertyType::READ_ONLY> JY9516CoreOO::JY9516CoreOODevice::Status

◆ TotalNumberOfChannels

const int JY9516CoreOO::JY9516CoreOODevice::TotalNumberOfChannels = 16

Total Number of Channels Provided.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9516/JY9516CoreOODevice.h


9516 C++ Programming Manual: JY9516CoreOO::DeviceStatus Class Reference

  • DeviceStatus
Public Member Functions | Public Attributes | List of all members
JY9516CoreOO::DeviceStatus Class Referencefinal

Device Status. More...

#include <JY9516CoreOODevice.h>

Public Member Functions

DeviceStatus (void *deviceHandle)
~DeviceStatus ()

Public Attributes

JY9516CoreOOProperty< DeviceStatus, double, JY9516CoreOOPropertyType::READ_ONLY > Temperature

Detailed Description

Device Status.

Constructor & Destructor Documentation

◆ DeviceStatus()

JY9516CoreOO::DeviceStatus::DeviceStatus ( void * deviceHandle )

◆ ~DeviceStatus()

JY9516CoreOO::DeviceStatus::~DeviceStatus ( )

Member Data Documentation

◆ Temperature

JY9516CoreOOProperty<DeviceStatus, double, JY9516CoreOOPropertyType::READ_ONLY> JY9516CoreOO::DeviceStatus::Temperature
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9516/JY9516CoreOODevice.h


9516 C++ Programming Manual: JY9516CoreOO::SampleInfo Class Reference

  • SampleInfo
Public Member Functions | Public Attributes | List of all members
JY9516CoreOO::SampleInfo Class Referencefinal

Sampling information. More...

#include <JY9516CoreOODevice.h>

Public Member Functions

SampleInfo (double sampleRate, LPFMode filterMode, double mclk, double fmod, double dclk, int adcDec, int fpgaDec, ADCFilterType adcFilterType, bool fpgaSinc5Enabled, double groupDelay)

Public Attributes

JY9516CoreOOProperty< SampleInfo, double, JY9516CoreOOPropertyType::READ_ONLY > | FMod
Modulation Frequency.
JY9516CoreOOProperty< SampleInfo, double, JY9516CoreOOPropertyType::READ_ONLY > | GroupDelay
Group Delay in Samples.

Detailed Description

Sampling information.

Including the modulation frequency and group delay in the current configuration.

Constructor & Destructor Documentation

◆ SampleInfo()

JY9516CoreOO::SampleInfo::SampleInfo | ( | double | sampleRate,
 |  | LPFMode | filterMode,
 |  | double | mclk,
 |  | double | fmod,
 |  | double | dclk,
 |  | int | adcDec,
 |  | int | fpgaDec,
 |  | ADCFilterType | adcFilterType,
 |  | bool | fpgaSinc5Enabled,
 |  | double | groupDelay )

Member Data Documentation

◆ FMod

JY9516CoreOOProperty<SampleInfo, double, JY9516CoreOOPropertyType::READ_ONLY> JY9516CoreOO::SampleInfo::FMod

Modulation Frequency.

◆ GroupDelay

JY9516CoreOOProperty<SampleInfo, double, JY9516CoreOOPropertyType::READ_ONLY> JY9516CoreOO::SampleInfo::GroupDelay

Group Delay in Samples.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9516/JY9516CoreOODevice.h


9516 C++ Programming Manual: JY9516CoreOO::ExternalReferenceClock Class Reference

  • ExternalReferenceClock
Public Attributes | List of all members
JY9516CoreOO::ExternalReferenceClock Class Reference

External Reference Clcok Terminal. More...

#include <JY9516CoreOODevice.h>

Public Attributes

ExternalReferenceClockTerminal Terminal
int Frequency

Detailed Description

External Reference Clcok Terminal.

Member Data Documentation

◆ Frequency

int JY9516CoreOO::ExternalReferenceClock::Frequency

◆ Terminal

ExternalReferenceClockTerminal JY9516CoreOO::ExternalReferenceClock::Terminal
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9516/JY9516CoreOODevice.h


9516 C++ Programming Manual: JY9516CoreOO::JY9516CoreOOReferenceClock Class Reference

  • JY9516CoreOOReferenceClock
Public Attributes | List of all members
JY9516CoreOO::JY9516CoreOOReferenceClock Class Reference

#include <JY9516CoreOODevice.h>

Public Attributes

ReferenceClockSource Source
JY9516CoreOOProperty< JY9516CoreOOReferenceClock, int, JY9516CoreOOPropertyType::READ_ONLY > SelectedReferenceClock
ExternalReferenceClock * External
External Reference Clock Source.

Detailed Description

参考时钟配置类

Reference Clcok Configuration Class

Member Data Documentation

◆ External

ExternalReferenceClock* JY9516CoreOO::JY9516CoreOOReferenceClock::External

External Reference Clock Source.

Required when ReferenceClock.Source is ReferenceClockSource.External

◆ SelectedReferenceClock

JY9516CoreOOProperty<JY9516CoreOOReferenceClock, int, JY9516CoreOOPropertyType::READ_ONLY> JY9516CoreOO::JY9516CoreOOReferenceClock::SelectedReferenceClock

◆ Source

ReferenceClockSource JY9516CoreOO::JY9516CoreOOReferenceClock::Source
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9516/JY9516CoreOODevice.h


9516 C++ Programming Manual: JY9516CoreOO::JY9516DeviceInfo Class Reference

  • JY9516DeviceInfo
Public Member Functions | Public Attributes | List of all members
JY9516CoreOO::JY9516DeviceInfo Class Reference

Device Info. More...

#include <JY9516CoreOODevice.h>

Public Member Functions

JY9516DeviceInfo ()
JY9516DeviceInfo (void *deviceHandle)
JY9516DeviceInfo (FirmDriveInfo info)
int | GetPID ()
int | GetSlotNum ()
std::string | GetAliasName ()
std::string | GetSN ()

Public Attributes

JY9516CoreOOProperty< JY9516DeviceInfo, int, JY9516CoreOOPropertyType::READ_ONLY > | HardwareVersion
JY9516CoreOOProperty< JY9516DeviceInfo, int, JY9516CoreOOPropertyType::READ_ONLY > | FirmwareVersionInt
JY9516CoreOOProperty< JY9516DeviceInfo, std::string, JY9516CoreOOPropertyType::READ_ONLY > | FirmwareVersion
JY9516CoreOOProperty< JY9516DeviceInfo, bool, JY9516CoreOOPropertyType::READ_ONLY > | IsPXIeDevice
JY9516CoreOOProperty< JY9516DeviceInfo, bool, JY9516CoreOOPropertyType::READ_ONLY > | IEPEAvailable

Detailed Description

Device Info.

Constructor & Destructor Documentation

◆ JY9516DeviceInfo() [1/3]

JY9516CoreOO::JY9516DeviceInfo::JY9516DeviceInfo ( )

◆ JY9516DeviceInfo() [2/3]

JY9516CoreOO::JY9516DeviceInfo::JY9516DeviceInfo ( void * deviceHandle )

◆ JY9516DeviceInfo() [3/3]

JY9516CoreOO::JY9516DeviceInfo::JY9516DeviceInfo ( FirmDriveInfo info )

Member Function Documentation

◆ GetAliasName()

std::string JY9516CoreOO::JY9516DeviceInfo::GetAliasName ( )

◆ GetPID()

int JY9516CoreOO::JY9516DeviceInfo::GetPID ( )

◆ GetSlotNum()

int JY9516CoreOO::JY9516DeviceInfo::GetSlotNum ( )

◆ GetSN()

std::string JY9516CoreOO::JY9516DeviceInfo::GetSN ( )

Member Data Documentation

◆ FirmwareVersion

JY9516CoreOOProperty<JY9516DeviceInfo, std::string, JY9516CoreOOPropertyType::READ_ONLY> JY9516CoreOO::JY9516DeviceInfo::FirmwareVersion

◆ FirmwareVersionInt

JY9516CoreOOProperty<JY9516DeviceInfo, int, JY9516CoreOOPropertyType::READ_ONLY> JY9516CoreOO::JY9516DeviceInfo::FirmwareVersionInt

◆ HardwareVersion

JY9516CoreOOProperty<JY9516DeviceInfo, int, JY9516CoreOOPropertyType::READ_ONLY> JY9516CoreOO::JY9516DeviceInfo::HardwareVersion

◆ IEPEAvailable

JY9516CoreOOProperty<JY9516DeviceInfo, bool, JY9516CoreOOPropertyType::READ_ONLY> JY9516CoreOO::JY9516DeviceInfo::IEPEAvailable

◆ IsPXIeDevice

JY9516CoreOOProperty<JY9516DeviceInfo, bool, JY9516CoreOOPropertyType::READ_ONLY> JY9516CoreOO::JY9516DeviceInfo::IsPXIeDevice
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9516/JY9516CoreOODevice.h


9516 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/9516/JY9516CoreOOLog.h File Reference

  • File List
  • File Members
  • COO
  • 9516
Classes | Namespaces | Enumerations
JY9516CoreOOLog.h File Reference
#include <queue>
#include <thread>
#include "JY9516CoreOOCommon.h"

Classes

class JY9516CoreOO::JY9516CoreOOLog

Namespaces

namespace JY9516CoreOO

Enumerations

enum class JY9516CoreOO::JY9516CoreOOLogLevel {
JY9516CoreOO::DEBUG_LOG_LEVEL , JY9516CoreOO::INFO_LOG_LEVEL , JY9516CoreOO::WARN_LOG_LEVEL , JY9516CoreOO::ERROR_LOG_LEVEL ,
JY9516CoreOO::FATAL_LOG_LEVEL
}


9516 C++ Programming Manual: JY9516CoreOO::JY9516CoreOOLog Class Reference

  • JY9516CoreOOLog
Static Public Member Functions | Static Public Attributes | List of all members
JY9516CoreOO::JY9516CoreOOLog Class Reference

#include <JY9516CoreOOLog.h>

Static Public Member Functions

static void | Print (const char *format,...)
static void | Print (JY9516CoreOOLogLevel logLevel, const char *format,...)
static void | Flush ()

Static Public Attributes

static JY9516CoreOOLogLevel | LogLevel
static JY9516CoreOOProperty< JY9516CoreOOLog, bool, JY9516CoreOOPropertyType::READ_WRITE > | EnableLog

Member Function Documentation

◆ Flush()

static void JY9516CoreOO::JY9516CoreOOLog::Flush ( )
static

◆ Print() [1/2]

static void JY9516CoreOO::JY9516CoreOOLog::Print | ( | const char * | format,
 |  |  | ... )
 static

◆ Print() [2/2]

static void JY9516CoreOO::JY9516CoreOOLog::Print | ( | JY9516CoreOOLogLevel | logLevel,
 |  | const char * | format,
 |  |  | ... )
 static

Member Data Documentation

◆ EnableLog

JY9516CoreOOProperty<JY9516CoreOOLog, bool, JY9516CoreOOPropertyType::READ_WRITE> JY9516CoreOO::JY9516CoreOOLog::EnableLog
static

◆ LogLevel

JY9516CoreOOLogLevel JY9516CoreOO::JY9516CoreOOLog::LogLevel
static
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9516/JY9516CoreOOLog.h


9516 C++ Programming Manual: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
▼N JY9516CoreOO |
C AIAnalogEdgeComparator | AI Analog Edge Comparator
C AIAnalogHysteresisComparator | AI Analog Hysteresis Comparator
C AIAnalogTrigger | AI Analog Trigger
C AIAnalogWindowComparator | AI Analog Window Comparator
C AIChannel | AI Channel
C AIDigitalFiltering | AI Digital Filtering Connfiguration Class
C AIDigitalTrigger | AI Digital trigger params
C AISignalExport | AI Signal Export Class
C AISync |
C AITrigger |
C ConversionStatus | Get ADC conversion status on all enabled channels
C DeviceStatus | Device Status
C ExternalReferenceClock | External Reference Clcok Terminal
C FirmDriveInfo |
C FlatnessCompensation | Flatness Compensation Parameters
C HighPassFilter | High-Pass Filter Configuration Class
C JY9516CoreOOAITask | AiTask类
C JY9516CoreOODevice | JY9516CoreOO Device
C JY9516CoreOOLog |
C JY9516CoreOOProperty | 属性模板类
C JY9516CoreOOReferenceClock |
C JY9516DAC | JY9516 DAC Configuration
C JY9516DeviceInfo | Device Info
C JYDriverException |
C LowPassFilter |
C PauseTrigger | Pause trigger configuration class
C SampleInfo | Sampling information
C JY9516CoreOOAIMode | AIMode


9516 C++ Programming Manual: Member List

  • AIAnalogEdgeComparator
JY9516CoreOO::AIAnalogEdgeComparator Member List

This is the complete list of members for JY9516CoreOO::AIAnalogEdgeComparator, including all inherited members.

Slope | JY9516CoreOO::AIAnalogEdgeComparator
Threshold | JY9516CoreOO::AIAnalogEdgeComparator


9516 C++ Programming Manual: Member List

  • AIAnalogHysteresisComparator
JY9516CoreOO::AIAnalogHysteresisComparator Member List

This is the complete list of members for JY9516CoreOO::AIAnalogHysteresisComparator, including all inherited members.

HighThreshold | JY9516CoreOO::AIAnalogHysteresisComparator
LowThreshold | JY9516CoreOO::AIAnalogHysteresisComparator
Slope | JY9516CoreOO::AIAnalogHysteresisComparator


9516 C++ Programming Manual: Member List

  • AIAnalogTrigger
JY9516CoreOO::AIAnalogTrigger Member List

This is the complete list of members for JY9516CoreOO::AIAnalogTrigger, including all inherited members.

AIAnalogTrigger() | JY9516CoreOO::AIAnalogTrigger
AIAnalogTrigger(AIAnalogTriggerSource src, AIAnalogTriggerComparator comparator) | JY9516CoreOO::AIAnalogTrigger
Commit(void *deviceHandle) | JY9516CoreOO::AIAnalogTrigger
Comparator | JY9516CoreOO::AIAnalogTrigger
Edge | JY9516CoreOO::AIAnalogTrigger
Hysteresis | JY9516CoreOO::AIAnalogTrigger
Source | JY9516CoreOO::AIAnalogTrigger
Window | JY9516CoreOO::AIAnalogTrigger
~AIAnalogTrigger() | JY9516CoreOO::AIAnalogTrigger


9516 C++ Programming Manual: Member List

  • AIAnalogWindowComparator
JY9516CoreOO::AIAnalogWindowComparator Member List

This is the complete list of members for JY9516CoreOO::AIAnalogWindowComparator, including all inherited members.

Condition | JY9516CoreOO::AIAnalogWindowComparator
HighThreshold | JY9516CoreOO::AIAnalogWindowComparator
LowThreshold | JY9516CoreOO::AIAnalogWindowComparator


9516 C++ Programming Manual: Member List

  • AIChannel
JY9516CoreOO::AIChannel Member List

This is the complete list of members for JY9516CoreOO::AIChannel, including all inherited members.

AIChannel(int channelId, double rangeLow, double rangeHigh, Coupling _coupling, bool IEPEenabled) | JY9516CoreOO::AIChannel
AIChannel(int channelId, AIRange range, Coupling _coupling, bool IEPEenabled) | JY9516CoreOO::AIChannel
ChannelID | JY9516CoreOO::AIChannel
coupling | JY9516CoreOO::AIChannel
IEPEEnabled | JY9516CoreOO::AIChannel
Range | JY9516CoreOO::AIChannel
RangeHigh | JY9516CoreOO::AIChannel
RangeLow | JY9516CoreOO::AIChannel
RawDataScaleFactor | JY9516CoreOO::AIChannel


9516 C++ Programming Manual: Member List

  • AIDigitalFiltering
JY9516CoreOO::AIDigitalFiltering Member List

This is the complete list of members for JY9516CoreOO::AIDigitalFiltering, including all inherited members.

AIDigitalFiltering() | JY9516CoreOO::AIDigitalFiltering
Flatnesscompensation | JY9516CoreOO::AIDigitalFiltering
HPF | JY9516CoreOO::AIDigitalFiltering
LPF | JY9516CoreOO::AIDigitalFiltering
ModulatorChoppingFrequency | JY9516CoreOO::AIDigitalFiltering
~AIDigitalFiltering() | JY9516CoreOO::AIDigitalFiltering


9516 C++ Programming Manual: Member List

  • AIDigitalTrigger
JY9516CoreOO::AIDigitalTrigger Member List

This is the complete list of members for JY9516CoreOO::AIDigitalTrigger, including all inherited members.

Edge | JY9516CoreOO::AIDigitalTrigger
Source | JY9516CoreOO::AIDigitalTrigger


9516 C++ Programming Manual: Member List

  • AISignalExport
JY9516CoreOO::AISignalExport Member List

This is the complete list of members for JY9516CoreOO::AISignalExport, including all inherited members.

Add(AISignalExportSource source, SignalExportDestination destination) | JY9516CoreOO::AISignalExport
Add(AISignalExportSource source, std::list< SignalExportDestination > destinations) | JY9516CoreOO::AISignalExport
Clear(SignalExportDestination destination) | JY9516CoreOO::AISignalExport
ClearAll() | JY9516CoreOO::AISignalExport


9516 C++ Programming Manual: Member List

  • AISync
JY9516CoreOO::AISync Member List

This is the complete list of members for JY9516CoreOO::AISync, including all inherited members.

State | JY9516CoreOO::AISync
Terminal | JY9516CoreOO::AISync
Topology | JY9516CoreOO::AISync


9516 C++ Programming Manual: Member List

  • AITrigger
JY9516CoreOO::AITrigger Member List

This is the complete list of members for JY9516CoreOO::AITrigger, including all inherited members.

Analog | JY9516CoreOO::AITrigger
Digital | JY9516CoreOO::AITrigger
Mode | JY9516CoreOO::AITrigger
PreTriggerSamples | JY9516CoreOO::AITrigger
ReTriggerCount | JY9516CoreOO::AITrigger
Type | JY9516CoreOO::AITrigger


9516 C++ Programming Manual: Member List

  • ConversionStatus
JY9516CoreOO::ConversionStatus Member List

This is the complete list of members for JY9516CoreOO::ConversionStatus, including all inherited members.

ChannelID | JY9516CoreOO::ConversionStatus |
ConversionStatus(int header) | JY9516CoreOO::ConversionStatus |
CRCError | JY9516CoreOO::ConversionStatus |
ErrorFlagged | JY9516CoreOO::ConversionStatus |
FilterSuturated | JY9516CoreOO::ConversionStatus |
Update(int header) | JY9516CoreOO::ConversionStatus | inline


9516 C++ Programming Manual: Member List

  • DeviceStatus
JY9516CoreOO::DeviceStatus Member List

This is the complete list of members for JY9516CoreOO::DeviceStatus, including all inherited members.

DeviceStatus(void *deviceHandle) | JY9516CoreOO::DeviceStatus
Temperature | JY9516CoreOO::DeviceStatus
~DeviceStatus() | JY9516CoreOO::DeviceStatus


9516 C++ Programming Manual: Member List

  • ExternalReferenceClock
JY9516CoreOO::ExternalReferenceClock Member List

This is the complete list of members for JY9516CoreOO::ExternalReferenceClock, including all inherited members.

Frequency | JY9516CoreOO::ExternalReferenceClock
Terminal | JY9516CoreOO::ExternalReferenceClock


9516 C++ Programming Manual: Member List

  • FlatnessCompensation
JY9516CoreOO::FlatnessCompensation Member List

This is the complete list of members for JY9516CoreOO::FlatnessCompensation, including all inherited members.

Enabled | JY9516CoreOO::FlatnessCompensation
FlatnessCompensation() | JY9516CoreOO::FlatnessCompensation


9516 C++ Programming Manual: Member List

  • HighPassFilter
JY9516CoreOO::HighPassFilter Member List

This is the complete list of members for JY9516CoreOO::HighPassFilter, including all inherited members.

ChannelEnableMask | JY9516CoreOO::HighPassFilter
CutoffFrequency | JY9516CoreOO::HighPassFilter
DisableChannel(int chID) | JY9516CoreOO::HighPassFilter
EnableChannel(int chID) | JY9516CoreOO::HighPassFilter
HighPassFilter() | JY9516CoreOO::HighPassFilter
Order | JY9516CoreOO::HighPassFilter


9516 C++ Programming Manual: Member List

  • JY9516CoreOOAITask
JY9516CoreOO::JY9516CoreOOAITask Member List

This is the complete list of members for JY9516CoreOO::JY9516CoreOOAITask, including all inherited members.

AddChannel(int chID, double rangeLow, double rangeHigh, Coupling coupling, bool enableIEPESS) | JY9516CoreOO::JY9516CoreOOAITask
AddChannel(int chID, AIRange range, Coupling coupling, bool enableIEPE) | JY9516CoreOO::JY9516CoreOOAITask
AddChannel(std::vector< int > chnsId, double rangeLow, double rangeHigh, Coupling coupling, bool enableIEPE) | JY9516CoreOO::JY9516CoreOOAITask
AddChannel(std::vector< int > chnsId, std::vector< double > rangeLow, std::vector< double > rangeHigh, std::vector< Coupling >_coupling, std::vector< bool > enableIEPE) | JY9516CoreOO::JY9516CoreOOAITask
AddChannel(std::vector< int > chnsId, AIRange range, Coupling coupling, bool enableIEPE) | JY9516CoreOO::JY9516CoreOOAITask
AddChannel(std::vector< int > chnsId, std::vector< AIRange > range, std::vector< Coupling >_coupling, std::vector< bool > enableIEPE) | JY9516CoreOO::JY9516CoreOOAITask
AvailableSamples | JY9516CoreOO::JY9516CoreOOAITask
BufLenInSamples | JY9516CoreOO::JY9516CoreOOAITask
Channels | JY9516CoreOO::JY9516CoreOOAITask
DAC | JY9516CoreOO::JY9516CoreOOAITask
Device | JY9516CoreOO::JY9516CoreOOAITask
DigitalFiltering | JY9516CoreOO::JY9516CoreOOAITask
DisableCalibration | JY9516CoreOO::JY9516CoreOOAITask
DisableDigitalTriggerDelay | JY9516CoreOO::JY9516CoreOOAITask
GetConversionStatus() | JY9516CoreOO::JY9516CoreOOAITask
JY9516CoreOOAITask(int slotNum) | JY9516CoreOO::JY9516CoreOOAITask
JY9516CoreOOAITask(std::string boardName) | JY9516CoreOO::JY9516CoreOOAITask
Mode | JY9516CoreOO::JY9516CoreOOAITask
ReadData(double *pBuf, int samplesPerChannel, int timeout=-1) | JY9516CoreOO::JY9516CoreOOAITask
ReadRawData(int *pBuf, int samplesPerChannel, int timeout=-1) | JY9516CoreOO::JY9516CoreOOAITask
ReadSinglePoint(double &readValue, int channel) | JY9516CoreOO::JY9516CoreOOAITask
ReadSinglePoint(std::vector< double > &readValues) | JY9516CoreOO::JY9516CoreOOAITask
RemoveChannel(int chnId) | JY9516CoreOO::JY9516CoreOOAITask
RemoveChannel(std::vector< int > chnsId) | JY9516CoreOO::JY9516CoreOOAITask
Sample_Info | JY9516CoreOO::JY9516CoreOOAITask
SampleRate | JY9516CoreOO::JY9516CoreOOAITask
SamplesToAcquire | JY9516CoreOO::JY9516CoreOOAITask
SendSoftwareTrigger() | JY9516CoreOO::JY9516CoreOOAITask
SignalExport | JY9516CoreOO::JY9516CoreOOAITask
Start() | JY9516CoreOO::JY9516CoreOOAITask
Stop() | JY9516CoreOO::JY9516CoreOOAITask
Sync | JY9516CoreOO::JY9516CoreOOAITask
TransferedSamples | JY9516CoreOO::JY9516CoreOOAITask
Trigger | JY9516CoreOO::JY9516CoreOOAITask
~JY9516CoreOOAITask() | JY9516CoreOO::JY9516CoreOOAITask


9516 C++ Programming Manual: Member List

  • JY9516CoreOODevice
JY9516CoreOO::JY9516CoreOODevice Member List

This is the complete list of members for JY9516CoreOO::JY9516CoreOODevice, including all inherited members.

AIBufferSize | JY9516CoreOO::JY9516CoreOODevice |
BoardClockRate | JY9516CoreOO::JY9516CoreOODevice |
DeviceID | JY9516CoreOO::JY9516CoreOODevice |
GetInstance(int cardNum) | JY9516CoreOO::JY9516CoreOODevice | static
GetInstance(std::string aliasName) | JY9516CoreOO::JY9516CoreOODevice | static
HighPassFilter | JY9516CoreOO::JY9516CoreOODevice |
Info | JY9516CoreOO::JY9516CoreOODevice |
JY9516PID | JY9516CoreOO::JY9516CoreOODevice |
MaxInputVoltage | JY9516CoreOO::JY9516CoreOODevice |
MaxSampleRate | JY9516CoreOO::JY9516CoreOODevice |
MinSampleRate | JY9516CoreOO::JY9516CoreOODevice |
ParseSampleRate(double sampleRate, LPFMode filterMode) | JY9516CoreOO::JY9516CoreOODevice | static
ReferenceClock | JY9516CoreOO::JY9516CoreOODevice |
Status | JY9516CoreOO::JY9516CoreOODevice |
TotalNumberOfChannels | JY9516CoreOO::JY9516CoreOODevice |


9516 C++ Programming Manual: Member List

  • JY9516CoreOOLog
JY9516CoreOO::JY9516CoreOOLog Member List

This is the complete list of members for JY9516CoreOO::JY9516CoreOOLog, including all inherited members.

EnableLog | JY9516CoreOO::JY9516CoreOOLog | static
Flush() | JY9516CoreOO::JY9516CoreOOLog | static
LogLevel | JY9516CoreOO::JY9516CoreOOLog | static
Print(const char *format,...) | JY9516CoreOO::JY9516CoreOOLog | static
Print(JY9516CoreOOLogLevel logLevel, const char *format,...) | JY9516CoreOO::JY9516CoreOOLog | static


9516 C++ Programming Manual: Member List

  • JY9516CoreOOProperty
JY9516CoreOO::JY9516CoreOOProperty< ContainerClass, ValueType, propertyType > Member List

This is the complete list of members for JY9516CoreOO::JY9516CoreOOProperty< ContainerClass, ValueType, propertyType >, including all inherited members.

JY9516CoreOOProperty() | JY9516CoreOO::JY9516CoreOOProperty< ContainerClass, ValueType, propertyType >
JY9516CoreOOProperty(ContainerClass *cObject, ValueType(ContainerClass::*pGet)(), void(ContainerClass::*pSet)(ValueType value)) | JY9516CoreOO::JY9516CoreOOProperty< ContainerClass, ValueType, propertyType >
JY9516CoreOOProperty(ValueType(*pGet)(), void(*pSet)(ValueType value)) | JY9516CoreOO::JY9516CoreOOProperty< ContainerClass, ValueType, propertyType >
operator ValueType() | JY9516CoreOO::JY9516CoreOOProperty< ContainerClass, ValueType, propertyType >
operator=(const ValueType &value) | JY9516CoreOO::JY9516CoreOOProperty< ContainerClass, ValueType, propertyType >


9516 C++ Programming Manual: Member List

  • JY9516CoreOOReferenceClock
JY9516CoreOO::JY9516CoreOOReferenceClock Member List

This is the complete list of members for JY9516CoreOO::JY9516CoreOOReferenceClock, including all inherited members.

External | JY9516CoreOO::JY9516CoreOOReferenceClock
SelectedReferenceClock | JY9516CoreOO::JY9516CoreOOReferenceClock
Source | JY9516CoreOO::JY9516CoreOOReferenceClock


9516 C++ Programming Manual: Member List

  • JY9516DAC
JY9516CoreOO::JY9516DAC Member List

This is the complete list of members for JY9516CoreOO::JY9516DAC, including all inherited members.

Enabled | JY9516CoreOO::JY9516DAC
IssueTemperatureRecalibration(int timeout=5000) | JY9516CoreOO::JY9516DAC
JY9516DAC(void *deviceHandle) | JY9516CoreOO::JY9516DAC
OutputChannel | JY9516CoreOO::JY9516DAC
OutputVoltage | JY9516CoreOO::JY9516DAC
~JY9516DAC() | JY9516CoreOO::JY9516DAC


9516 C++ Programming Manual: Member List

  • JY9516DeviceInfo
JY9516CoreOO::JY9516DeviceInfo Member List

This is the complete list of members for JY9516CoreOO::JY9516DeviceInfo, including all inherited members.

FirmwareVersion | JY9516CoreOO::JY9516DeviceInfo
FirmwareVersionInt | JY9516CoreOO::JY9516DeviceInfo
GetAliasName() | JY9516CoreOO::JY9516DeviceInfo
GetPID() | JY9516CoreOO::JY9516DeviceInfo
GetSlotNum() | JY9516CoreOO::JY9516DeviceInfo
GetSN() | JY9516CoreOO::JY9516DeviceInfo
HardwareVersion | JY9516CoreOO::JY9516DeviceInfo
IEPEAvailable | JY9516CoreOO::JY9516DeviceInfo
IsPXIeDevice | JY9516CoreOO::JY9516DeviceInfo
JY9516DeviceInfo() | JY9516CoreOO::JY9516DeviceInfo
JY9516DeviceInfo(void *deviceHandle) | JY9516CoreOO::JY9516DeviceInfo
JY9516DeviceInfo(FirmDriveInfo info) | JY9516CoreOO::JY9516DeviceInfo


9516 C++ Programming Manual: Member List

  • JYDriverException
JY9516CoreOO::JYDriverException Member List

This is the complete list of members for JY9516CoreOO::JYDriverException, including all inherited members.

errorCode | JY9516CoreOO::JYDriverException
exceptionMessage | JY9516CoreOO::JYDriverException
FollowingException | JY9516CoreOO::JYDriverException
JYDriverException(JYDriverExceptionPublic exceptionCode, std::string msg="") | JY9516CoreOO::JYDriverException
JYDriverException(int, std::string msg) | JY9516CoreOO::JYDriverException


9516 C++ Programming Manual: Member List

  • LowPassFilter
JY9516CoreOO::LowPassFilter Member List

This is the complete list of members for JY9516CoreOO::LowPassFilter, including all inherited members.

LowPassFilter() | JY9516CoreOO::LowPassFilter
Mode | JY9516CoreOO::LowPassFilter


9516 C++ Programming Manual: Member List

  • PauseTrigger
JY9516CoreOO::PauseTrigger Member List

This is the complete list of members for JY9516CoreOO::PauseTrigger, including all inherited members.

ActivePolarity | JY9516CoreOO::PauseTrigger
Terminal | JY9516CoreOO::PauseTrigger


9516 C++ Programming Manual: Member List

  • SampleInfo
JY9516CoreOO::SampleInfo Member List

This is the complete list of members for JY9516CoreOO::SampleInfo, including all inherited members.

FMod | JY9516CoreOO::SampleInfo
GroupDelay | JY9516CoreOO::SampleInfo
SampleInfo(double sampleRate, LPFMode filterMode, double mclk, double fmod, double dclk, int adcDec, int fpgaDec, ADCFilterType adcFilterType, bool fpgaSinc5Enabled, double groupDelay) | JY9516CoreOO::SampleInfo


9516 C++ Programming Manual: JY9516CoreOOAIMode Class Reference

JY9516CoreOOAIMode Class Reference

AIMode. More...

#include <JY9516CoreOOAITask.h>

Detailed Description

AIMode.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9516/JY9516CoreOOAITask.h


9516 C++ Programming Manual: Class Index

Class Index
A | C | D | E | F | H | J | L | P | S
A
AIAnalogEdgeComparator (JY9516CoreOO)
AIAnalogHysteresisComparator (JY9516CoreOO)
AIAnalogTrigger (JY9516CoreOO)
AIAnalogWindowComparator (JY9516CoreOO)
AIChannel (JY9516CoreOO)
AIDigitalFiltering (JY9516CoreOO)
AIDigitalTrigger (JY9516CoreOO)
AISignalExport (JY9516CoreOO)
AISync (JY9516CoreOO)
AITrigger (JY9516CoreOO)
C
ConversionStatus (JY9516CoreOO)
D
DeviceStatus (JY9516CoreOO)
E
ExternalReferenceClock (JY9516CoreOO)
F
FirmDriveInfo (JY9516CoreOO)
FlatnessCompensation (JY9516CoreOO)
H
HighPassFilter (JY9516CoreOO)
J
JY9516CoreOOAIMode
JY9516CoreOOAITask (JY9516CoreOO)
JY9516CoreOODevice (JY9516CoreOO)
JY9516CoreOOLog (JY9516CoreOO)
JY9516CoreOOProperty (JY9516CoreOO)
JY9516CoreOOReferenceClock (JY9516CoreOO)
JY9516DAC (JY9516CoreOO)
JY9516DeviceInfo (JY9516CoreOO)
JYDriverException (JY9516CoreOO)
L
LowPassFilter (JY9516CoreOO)
P
PauseTrigger (JY9516CoreOO)
S
SampleInfo (JY9516CoreOO)


9516 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO Directory Reference

  • File List
  • File Members
  • COO
COO Directory Reference

Directories

9516


9516 C++ Programming Manual: File List

  • File List
  • File Members
File List
Here is a list of all files with brief descriptions:
[detail level 123]
▼ COO
▼ 9516
JY9516CoreOOAITask.h
JY9516CoreOOCommon.h
JY9516CoreOODevice.h
JY9516CoreOOLog.h


9516 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- a -

  • ActivePolarity : JY9516CoreOO::PauseTrigger
  • Add() : JY9516CoreOO::AISignalExport
  • AddChannel() : JY9516CoreOO::JY9516CoreOOAITask
  • AIAnalogTrigger() : JY9516CoreOO::AIAnalogTrigger
  • AIBufferSize : JY9516CoreOO::JY9516CoreOODevice
  • AIChannel() : JY9516CoreOO::AIChannel
  • AIDigitalFiltering() : JY9516CoreOO::AIDigitalFiltering
  • aliasName : JY9516CoreOO::FirmDriveInfo
  • Analog : JY9516CoreOO::AITrigger
  • AvailableSamples : JY9516CoreOO::JY9516CoreOOAITask

- b -

  • BoardClockRate : JY9516CoreOO::JY9516CoreOODevice
  • BufLenInSamples : JY9516CoreOO::JY9516CoreOOAITask

- c -

  • cardNumber : JY9516CoreOO::FirmDriveInfo
  • ChannelEnableMask : JY9516CoreOO::HighPassFilter
  • ChannelID : JY9516CoreOO::AIChannel, JY9516CoreOO::ConversionStatus
  • Channels : JY9516CoreOO::JY9516CoreOOAITask
  • Clear() : JY9516CoreOO::AISignalExport
  • ClearAll() : JY9516CoreOO::AISignalExport
  • Commit() : JY9516CoreOO::AIAnalogTrigger
  • Comparator : JY9516CoreOO::AIAnalogTrigger
  • Condition : JY9516CoreOO::AIAnalogWindowComparator
  • connected : JY9516CoreOO::FirmDriveInfo
  • ConversionStatus() : JY9516CoreOO::ConversionStatus
  • coupling : JY9516CoreOO::AIChannel
  • CRCError : JY9516CoreOO::ConversionStatus
  • CutoffFrequency : JY9516CoreOO::HighPassFilter

- d -

  • DAC : JY9516CoreOO::JY9516CoreOOAITask
  • Device : JY9516CoreOO::JY9516CoreOOAITask
  • DeviceID : JY9516CoreOO::JY9516CoreOODevice
  • DeviceStatus() : JY9516CoreOO::DeviceStatus
  • Digital : JY9516CoreOO::AITrigger
  • DigitalFiltering : JY9516CoreOO::JY9516CoreOOAITask
  • DisableCalibration : JY9516CoreOO::JY9516CoreOOAITask
  • DisableChannel() : JY9516CoreOO::HighPassFilter
  • DisableDigitalTriggerDelay : JY9516CoreOO::JY9516CoreOOAITask
  • DriverSetVer : JY9516CoreOO::FirmDriveInfo

- e -

  • Edge : JY9516CoreOO::AIAnalogTrigger, JY9516CoreOO::AIDigitalTrigger
  • EnableChannel() : JY9516CoreOO::HighPassFilter
  • Enabled : JY9516CoreOO::FlatnessCompensation, JY9516CoreOO::JY9516DAC
  • EnableLog : JY9516CoreOO::JY9516CoreOOLog
  • errorCode : JY9516CoreOO::JYDriverException
  • ErrorFlagged : JY9516CoreOO::ConversionStatus
  • exceptionMessage : JY9516CoreOO::JYDriverException
  • External : JY9516CoreOO::JY9516CoreOOReferenceClock

- f -

  • FilterSuturated : JY9516CoreOO::ConversionStatus
  • FirmwareVer : JY9516CoreOO::FirmDriveInfo
  • FirmwareVersion : JY9516CoreOO::JY9516DeviceInfo
  • FirmwareVersionInt : JY9516CoreOO::JY9516DeviceInfo
  • FlatnessCompensation() : JY9516CoreOO::FlatnessCompensation
  • Flatnesscompensation : JY9516CoreOO::AIDigitalFiltering
  • Flush() : JY9516CoreOO::JY9516CoreOOLog
  • FMod : JY9516CoreOO::SampleInfo
  • FollowingException : JY9516CoreOO::JYDriverException
  • FrameworkVer : JY9516CoreOO::FirmDriveInfo
  • Frequency : JY9516CoreOO::ExternalReferenceClock
  • fStreaming : JY9516CoreOO::FirmDriveInfo

- g -

  • GetAliasName() : JY9516CoreOO::JY9516DeviceInfo
  • GetConversionStatus() : JY9516CoreOO::JY9516CoreOOAITask
  • GetInstance() : JY9516CoreOO::JY9516CoreOODevice
  • GetPID() : JY9516CoreOO::JY9516DeviceInfo
  • GetSlotNum() : JY9516CoreOO::JY9516DeviceInfo
  • GetSN() : JY9516CoreOO::JY9516DeviceInfo
  • GroupDelay : JY9516CoreOO::SampleInfo

- h -

  • HardwareVer : JY9516CoreOO::FirmDriveInfo
  • HardwareVersion : JY9516CoreOO::JY9516DeviceInfo
  • HighPassFilter() : JY9516CoreOO::HighPassFilter, JY9516CoreOO::JY9516CoreOODevice
  • HighThreshold : JY9516CoreOO::AIAnalogHysteresisComparator, JY9516CoreOO::AIAnalogWindowComparator
  • HPF : JY9516CoreOO::AIDigitalFiltering
  • Hysteresis : JY9516CoreOO::AIAnalogTrigger

- i -

  • IEPEAvailable : JY9516CoreOO::JY9516DeviceInfo
  • IEPEEnabled : JY9516CoreOO::AIChannel
  • Info : JY9516CoreOO::JY9516CoreOODevice
  • IsPXIeDevice : JY9516CoreOO::JY9516DeviceInfo
  • IssueTemperatureRecalibration() : JY9516CoreOO::JY9516DAC

- j -

  • JY9516CoreOOAITask() : JY9516CoreOO::JY9516CoreOOAITask
  • JY9516CoreOOProperty() : JY9516CoreOO::JY9516CoreOOProperty< ContainerClass, ValueType, propertyType >
  • JY9516DAC() : JY9516CoreOO::JY9516DAC
  • JY9516DeviceInfo() : JY9516CoreOO::JY9516DeviceInfo
  • JY9516PID : JY9516CoreOO::JY9516CoreOODevice
  • JYDriverException() : JY9516CoreOO::JYDriverException

- l -

  • LogLevel : JY9516CoreOO::JY9516CoreOOLog
  • LowPassFilter() : JY9516CoreOO::LowPassFilter
  • LowThreshold : JY9516CoreOO::AIAnalogHysteresisComparator, JY9516CoreOO::AIAnalogWindowComparator
  • LPF : JY9516CoreOO::AIDigitalFiltering

- m -

  • MaxInputVoltage : JY9516CoreOO::JY9516CoreOODevice
  • MaxSampleRate : JY9516CoreOO::JY9516CoreOODevice
  • MinSampleRate : JY9516CoreOO::JY9516CoreOODevice
  • Mode : JY9516CoreOO::AITrigger, JY9516CoreOO::JY9516CoreOOAITask, JY9516CoreOO::LowPassFilter
  • model : JY9516CoreOO::FirmDriveInfo
  • ModulatorChoppingFrequency : JY9516CoreOO::AIDigitalFiltering

- o -

  • operator ValueType() : JY9516CoreOO::JY9516CoreOOProperty< ContainerClass, ValueType, propertyType >
  • operator=() : JY9516CoreOO::JY9516CoreOOProperty< ContainerClass, ValueType, propertyType >
  • Order : JY9516CoreOO::HighPassFilter
  • OutputChannel : JY9516CoreOO::JY9516DAC
  • OutputVoltage : JY9516CoreOO::JY9516DAC

- p -

  • ParseSampleRate() : JY9516CoreOO::JY9516CoreOODevice
  • PID : JY9516CoreOO::FirmDriveInfo
  • PlatformType : JY9516CoreOO::FirmDriveInfo
  • PreTriggerSamples : JY9516CoreOO::AITrigger
  • Print() : JY9516CoreOO::JY9516CoreOOLog
  • ProductionDate : JY9516CoreOO::FirmDriveInfo

- r -

  • Range : JY9516CoreOO::AIChannel
  • RangeHigh : JY9516CoreOO::AIChannel
  • RangeLow : JY9516CoreOO::AIChannel
  • RawDataScaleFactor : JY9516CoreOO::AIChannel
  • ReadData() : JY9516CoreOO::JY9516CoreOOAITask
  • ReadRawData() : JY9516CoreOO::JY9516CoreOOAITask
  • ReadSinglePoint() : JY9516CoreOO::JY9516CoreOOAITask
  • ReferenceClock : JY9516CoreOO::JY9516CoreOODevice
  • RemoveChannel() : JY9516CoreOO::JY9516CoreOOAITask
  • ReTriggerCount : JY9516CoreOO::AITrigger

- s -

  • Sample_Info : JY9516CoreOO::JY9516CoreOOAITask
  • SampleInfo() : JY9516CoreOO::SampleInfo
  • SampleRate : JY9516CoreOO::JY9516CoreOOAITask
  • SamplesToAcquire : JY9516CoreOO::JY9516CoreOOAITask
  • SelectedReferenceClock : JY9516CoreOO::JY9516CoreOOReferenceClock
  • SendSoftwareTrigger() : JY9516CoreOO::JY9516CoreOOAITask
  • serialNumber : JY9516CoreOO::FirmDriveInfo
  • SignalExport : JY9516CoreOO::JY9516CoreOOAITask
  • Slope : JY9516CoreOO::AIAnalogEdgeComparator, JY9516CoreOO::AIAnalogHysteresisComparator
  • slotNum : JY9516CoreOO::FirmDriveInfo
  • Source : JY9516CoreOO::AIAnalogTrigger, JY9516CoreOO::AIDigitalTrigger, JY9516CoreOO::JY9516CoreOOReferenceClock
  • Start() : JY9516CoreOO::JY9516CoreOOAITask
  • State : JY9516CoreOO::AISync
  • Status : JY9516CoreOO::JY9516CoreOODevice
  • Stop() : JY9516CoreOO::JY9516CoreOOAITask
  • Sync : JY9516CoreOO::JY9516CoreOOAITask

- t -

  • Temperature : JY9516CoreOO::DeviceStatus
  • Terminal : JY9516CoreOO::AISync, JY9516CoreOO::ExternalReferenceClock, JY9516CoreOO::PauseTrigger
  • Threshold : JY9516CoreOO::AIAnalogEdgeComparator
  • Topology : JY9516CoreOO::AISync
  • TotalNumberOfChannels : JY9516CoreOO::JY9516CoreOODevice
  • TransferedSamples : JY9516CoreOO::JY9516CoreOOAITask
  • Trigger : JY9516CoreOO::JY9516CoreOOAITask
  • Type : JY9516CoreOO::AITrigger

- u -

  • Update() : JY9516CoreOO::ConversionStatus

- v -

  • vendorName : JY9516CoreOO::FirmDriveInfo
  • VID : JY9516CoreOO::FirmDriveInfo

- w -

  • Window : JY9516CoreOO::AIAnalogTrigger

- ~ -

  • ~AIAnalogTrigger() : JY9516CoreOO::AIAnalogTrigger
  • ~AIDigitalFiltering() : JY9516CoreOO::AIDigitalFiltering
  • ~DeviceStatus() : JY9516CoreOO::DeviceStatus
  • ~JY9516CoreOOAITask() : JY9516CoreOO::JY9516CoreOOAITask
  • ~JY9516DAC() : JY9516CoreOO::JY9516DAC


9516 C++ Programming Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • o
  • p
  • r
  • s
  • u
  • ~
Here is a list of all functions with links to the classes they belong to:

- a -

  • Add() : JY9516CoreOO::AISignalExport
  • AddChannel() : JY9516CoreOO::JY9516CoreOOAITask
  • AIAnalogTrigger() : JY9516CoreOO::AIAnalogTrigger
  • AIChannel() : JY9516CoreOO::AIChannel
  • AIDigitalFiltering() : JY9516CoreOO::AIDigitalFiltering

- c -

  • Clear() : JY9516CoreOO::AISignalExport
  • ClearAll() : JY9516CoreOO::AISignalExport
  • Commit() : JY9516CoreOO::AIAnalogTrigger
  • ConversionStatus() : JY9516CoreOO::ConversionStatus

- d -

  • DeviceStatus() : JY9516CoreOO::DeviceStatus
  • DisableChannel() : JY9516CoreOO::HighPassFilter

- e -

  • EnableChannel() : JY9516CoreOO::HighPassFilter

- f -

  • FlatnessCompensation() : JY9516CoreOO::FlatnessCompensation
  • Flush() : JY9516CoreOO::JY9516CoreOOLog

- g -

  • GetAliasName() : JY9516CoreOO::JY9516DeviceInfo
  • GetConversionStatus() : JY9516CoreOO::JY9516CoreOOAITask
  • GetInstance() : JY9516CoreOO::JY9516CoreOODevice
  • GetPID() : JY9516CoreOO::JY9516DeviceInfo
  • GetSlotNum() : JY9516CoreOO::JY9516DeviceInfo
  • GetSN() : JY9516CoreOO::JY9516DeviceInfo

- h -

  • HighPassFilter() : JY9516CoreOO::HighPassFilter

- i -

  • IssueTemperatureRecalibration() : JY9516CoreOO::JY9516DAC

- j -

  • JY9516CoreOOAITask() : JY9516CoreOO::JY9516CoreOOAITask
  • JY9516CoreOOProperty() : JY9516CoreOO::JY9516CoreOOProperty< ContainerClass, ValueType, propertyType >
  • JY9516DAC() : JY9516CoreOO::JY9516DAC
  • JY9516DeviceInfo() : JY9516CoreOO::JY9516DeviceInfo
  • JYDriverException() : JY9516CoreOO::JYDriverException

- l -

  • LowPassFilter() : JY9516CoreOO::LowPassFilter

- o -

  • operator ValueType() : JY9516CoreOO::JY9516CoreOOProperty< ContainerClass, ValueType, propertyType >
  • operator=() : JY9516CoreOO::JY9516CoreOOProperty< ContainerClass, ValueType, propertyType >

- p -

  • ParseSampleRate() : JY9516CoreOO::JY9516CoreOODevice
  • Print() : JY9516CoreOO::JY9516CoreOOLog

- r -

  • ReadData() : JY9516CoreOO::JY9516CoreOOAITask
  • ReadRawData() : JY9516CoreOO::JY9516CoreOOAITask
  • ReadSinglePoint() : JY9516CoreOO::JY9516CoreOOAITask
  • RemoveChannel() : JY9516CoreOO::JY9516CoreOOAITask

- s -

  • SampleInfo() : JY9516CoreOO::SampleInfo
  • SendSoftwareTrigger() : JY9516CoreOO::JY9516CoreOOAITask
  • Start() : JY9516CoreOO::JY9516CoreOOAITask
  • Stop() : JY9516CoreOO::JY9516CoreOOAITask

- u -

  • Update() : JY9516CoreOO::ConversionStatus

- ~ -

  • ~AIAnalogTrigger() : JY9516CoreOO::AIAnalogTrigger
  • ~AIDigitalFiltering() : JY9516CoreOO::AIDigitalFiltering
  • ~DeviceStatus() : JY9516CoreOO::DeviceStatus
  • ~JY9516CoreOOAITask() : JY9516CoreOO::JY9516CoreOOAITask
  • ~JY9516DAC() : JY9516CoreOO::JY9516DAC


9516 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • v
  • w
Here is a list of all variables with links to the classes they belong to:

- a -

  • ActivePolarity : JY9516CoreOO::PauseTrigger
  • AIBufferSize : JY9516CoreOO::JY9516CoreOODevice
  • aliasName : JY9516CoreOO::FirmDriveInfo
  • Analog : JY9516CoreOO::AITrigger
  • AvailableSamples : JY9516CoreOO::JY9516CoreOOAITask

- b -

  • BoardClockRate : JY9516CoreOO::JY9516CoreOODevice
  • BufLenInSamples : JY9516CoreOO::JY9516CoreOOAITask

- c -

  • cardNumber : JY9516CoreOO::FirmDriveInfo
  • ChannelEnableMask : JY9516CoreOO::HighPassFilter
  • ChannelID : JY9516CoreOO::AIChannel, JY9516CoreOO::ConversionStatus
  • Channels : JY9516CoreOO::JY9516CoreOOAITask
  • Comparator : JY9516CoreOO::AIAnalogTrigger
  • Condition : JY9516CoreOO::AIAnalogWindowComparator
  • connected : JY9516CoreOO::FirmDriveInfo
  • coupling : JY9516CoreOO::AIChannel
  • CRCError : JY9516CoreOO::ConversionStatus
  • CutoffFrequency : JY9516CoreOO::HighPassFilter

- d -

  • DAC : JY9516CoreOO::JY9516CoreOOAITask
  • Device : JY9516CoreOO::JY9516CoreOOAITask
  • DeviceID : JY9516CoreOO::JY9516CoreOODevice
  • Digital : JY9516CoreOO::AITrigger
  • DigitalFiltering : JY9516CoreOO::JY9516CoreOOAITask
  • DisableCalibration : JY9516CoreOO::JY9516CoreOOAITask
  • DisableDigitalTriggerDelay : JY9516CoreOO::JY9516CoreOOAITask
  • DriverSetVer : JY9516CoreOO::FirmDriveInfo

- e -

  • Edge : JY9516CoreOO::AIAnalogTrigger, JY9516CoreOO::AIDigitalTrigger
  • Enabled : JY9516CoreOO::FlatnessCompensation, JY9516CoreOO::JY9516DAC
  • EnableLog : JY9516CoreOO::JY9516CoreOOLog
  • errorCode : JY9516CoreOO::JYDriverException
  • ErrorFlagged : JY9516CoreOO::ConversionStatus
  • exceptionMessage : JY9516CoreOO::JYDriverException
  • External : JY9516CoreOO::JY9516CoreOOReferenceClock

- f -

  • FilterSuturated : JY9516CoreOO::ConversionStatus
  • FirmwareVer : JY9516CoreOO::FirmDriveInfo
  • FirmwareVersion : JY9516CoreOO::JY9516DeviceInfo
  • FirmwareVersionInt : JY9516CoreOO::JY9516DeviceInfo
  • Flatnesscompensation : JY9516CoreOO::AIDigitalFiltering
  • FMod : JY9516CoreOO::SampleInfo
  • FollowingException : JY9516CoreOO::JYDriverException
  • FrameworkVer : JY9516CoreOO::FirmDriveInfo
  • Frequency : JY9516CoreOO::ExternalReferenceClock
  • fStreaming : JY9516CoreOO::FirmDriveInfo

- g -

  • GroupDelay : JY9516CoreOO::SampleInfo

- h -

  • HardwareVer : JY9516CoreOO::FirmDriveInfo
  • HardwareVersion : JY9516CoreOO::JY9516DeviceInfo
  • HighPassFilter : JY9516CoreOO::JY9516CoreOODevice
  • HighThreshold : JY9516CoreOO::AIAnalogHysteresisComparator, JY9516CoreOO::AIAnalogWindowComparator
  • HPF : JY9516CoreOO::AIDigitalFiltering
  • Hysteresis : JY9516CoreOO::AIAnalogTrigger

- i -

  • IEPEAvailable : JY9516CoreOO::JY9516DeviceInfo
  • IEPEEnabled : JY9516CoreOO::AIChannel
  • Info : JY9516CoreOO::JY9516CoreOODevice
  • IsPXIeDevice : JY9516CoreOO::JY9516DeviceInfo

- j -

  • JY9516PID : JY9516CoreOO::JY9516CoreOODevice

- l -

  • LogLevel : JY9516CoreOO::JY9516CoreOOLog
  • LowThreshold : JY9516CoreOO::AIAnalogHysteresisComparator, JY9516CoreOO::AIAnalogWindowComparator
  • LPF : JY9516CoreOO::AIDigitalFiltering

- m -

  • MaxInputVoltage : JY9516CoreOO::JY9516CoreOODevice
  • MaxSampleRate : JY9516CoreOO::JY9516CoreOODevice
  • MinSampleRate : JY9516CoreOO::JY9516CoreOODevice
  • Mode : JY9516CoreOO::AITrigger, JY9516CoreOO::JY9516CoreOOAITask, JY9516CoreOO::LowPassFilter
  • model : JY9516CoreOO::FirmDriveInfo
  • ModulatorChoppingFrequency : JY9516CoreOO::AIDigitalFiltering

- o -

  • Order : JY9516CoreOO::HighPassFilter
  • OutputChannel : JY9516CoreOO::JY9516DAC
  • OutputVoltage : JY9516CoreOO::JY9516DAC

- p -

  • PID : JY9516CoreOO::FirmDriveInfo
  • PlatformType : JY9516CoreOO::FirmDriveInfo
  • PreTriggerSamples : JY9516CoreOO::AITrigger
  • ProductionDate : JY9516CoreOO::FirmDriveInfo

- r -

  • Range : JY9516CoreOO::AIChannel
  • RangeHigh : JY9516CoreOO::AIChannel
  • RangeLow : JY9516CoreOO::AIChannel
  • RawDataScaleFactor : JY9516CoreOO::AIChannel
  • ReferenceClock : JY9516CoreOO::JY9516CoreOODevice
  • ReTriggerCount : JY9516CoreOO::AITrigger

- s -

  • Sample_Info : JY9516CoreOO::JY9516CoreOOAITask
  • SampleRate : JY9516CoreOO::JY9516CoreOOAITask
  • SamplesToAcquire : JY9516CoreOO::JY9516CoreOOAITask
  • SelectedReferenceClock : JY9516CoreOO::JY9516CoreOOReferenceClock
  • serialNumber : JY9516CoreOO::FirmDriveInfo
  • SignalExport : JY9516CoreOO::JY9516CoreOOAITask
  • Slope : JY9516CoreOO::AIAnalogEdgeComparator, JY9516CoreOO::AIAnalogHysteresisComparator
  • slotNum : JY9516CoreOO::FirmDriveInfo
  • Source : JY9516CoreOO::AIAnalogTrigger, JY9516CoreOO::AIDigitalTrigger, JY9516CoreOO::JY9516CoreOOReferenceClock
  • State : JY9516CoreOO::AISync
  • Status : JY9516CoreOO::JY9516CoreOODevice
  • Sync : JY9516CoreOO::JY9516CoreOOAITask

- t -

  • Temperature : JY9516CoreOO::DeviceStatus
  • Terminal : JY9516CoreOO::AISync, JY9516CoreOO::ExternalReferenceClock, JY9516CoreOO::PauseTrigger
  • Threshold : JY9516CoreOO::AIAnalogEdgeComparator
  • Topology : JY9516CoreOO::AISync
  • TotalNumberOfChannels : JY9516CoreOO::JY9516CoreOODevice
  • TransferedSamples : JY9516CoreOO::JY9516CoreOOAITask
  • Trigger : JY9516CoreOO::JY9516CoreOOAITask
  • Type : JY9516CoreOO::AITrigger

- v -

  • vendorName : JY9516CoreOO::FirmDriveInfo
  • VID : JY9516CoreOO::FirmDriveInfo

- w -

  • Window : JY9516CoreOO::AIAnalogTrigger


9516 C++ Programming Manual: File Members

  • File List
  • File Members
  • All
  • Macros
Here is a list of all file members with links to the files they belong to:
  • _CRT_SECURE_NO_WARNINGS : JY9516CoreOOAITask.h
  • EXTERN_C : JY9516CoreOOCommon.h
  • JY9516CoreOO_API : JY9516CoreOOCommon.h


9516 C++ Programming Manual: File Members

  • File List
  • File Members
  • All
  • Macros
Here is a list of all macros with links to the files they belong to:
  • _CRT_SECURE_NO_WARNINGS : JY9516CoreOOAITask.h
  • EXTERN_C : JY9516CoreOOCommon.h
  • JY9516CoreOO_API : JY9516CoreOOCommon.h


9516 C++ Programming Manual: Main Page

9516 C++ Programming Manual Documentation


9516 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • c
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
  • w
Here is a list of all namespace members with links to the namespace documentation for each member:

- a -

  • ADCFilterType : JY9516CoreOO
  • AIAnalogTriggerComparator : JY9516CoreOO
  • AIAnalogTriggerEdge : JY9516CoreOO
  • AIAnalogTriggerSource : JY9516CoreOO
  • AIAnalogWindowCondition : JY9516CoreOO
  • AIDigitalTriggerEdge : JY9516CoreOO
  • AIDigitalTriggerSource : JY9516CoreOO
  • AIMode : JY9516CoreOO
  • AIRagneGrade : JY9516CoreOO
  • AIRange : JY9516CoreOO
  • AIRangeDescriptions : JY9516CoreOO
  • AISignalExportSource : JY9516CoreOO
  • AITriggerMode : JY9516CoreOO
  • AITriggerType : JY9516CoreOO

- c -

  • ChoppingFrequency : JY9516CoreOO
  • Coupling : JY9516CoreOO

- e -

  • Ext_Trig : JY9516CoreOO
  • ExternalReferenceClockTerminal : JY9516CoreOO

- f -

  • fMod32 : JY9516CoreOO
  • fMod8 : JY9516CoreOO

- g -

  • GetSignalExportDestinationString() : JY9516CoreOO

- h -

  • HPFOrder : JY9516CoreOO

- i -

  • IEPEConnectionStatus : JY9516CoreOO
  • Invalid : JY9516CoreOO

- j -

  • JY9516_ADCChopping_fMod32 : JY9516Import
  • JY9516_AI_Continuous : JY9516Import
  • JY9516_AI_Finite : JY9516Import
  • JY9516_AI_Single : JY9516Import
  • JY9516_AnlogTriggerCondition_EnteringWindow : JY9516Import
  • JY9516_AnlogTriggerCondition_FallingHysteresis : JY9516Import
  • JY9516_AnlogTriggerCondition_LeavingWindow : JY9516Import
  • JY9516_AnlogTriggerCondition_RisingHysteresis : JY9516Import
  • JY9516_CalCoePosition_EEPROM : JY9516Import
  • JY9516_CalCoePosition_Handle : JY9516Import
  • JY9516_Coupling_AC : JY9516Import
  • JY9516_Coupling_DC : JY9516Import
  • JY9516_DigitalTriggerEdge_Falling : JY9516Import
  • JY9516_DigitalTriggerEdge_Rising : JY9516Import
  • JY9516_DigitalTriggerSource_BUS_0 : JY9516Import
  • JY9516_DigitalTriggerSource_BUS_1 : JY9516Import
  • JY9516_DigitalTriggerSource_BUS_2 : JY9516Import
  • JY9516_DigitalTriggerSource_BUS_3 : JY9516Import
  • JY9516_DigitalTriggerSource_BUS_4 : JY9516Import
  • JY9516_DigitalTriggerSource_BUS_5 : JY9516Import
  • JY9516_DigitalTriggerSource_BUS_6 : JY9516Import
  • JY9516_DigitalTriggerSource_BUS_7 : JY9516Import
  • JY9516_DigitalTriggerSource_External : JY9516Import
  • JY9516_DigitalTriggerSource_STAR : JY9516Import
  • JY9516_EXPORT_ADC_DRDY : JY9516Import
  • JY9516_EXPORT_ADC_SYNC : JY9516Import
  • JY9516_EXPORT_DCLK : JY9516Import
  • JY9516_EXPORT_MCLK : JY9516Import
  • JY9516_EXPORT_PLL_SYNC : JY9516Import
  • JY9516_EXPORT_RX_ADV_TRIG : JY9516Import
  • JY9516_EXPORT_RX_END_OF_RECORD : JY9516Import
  • JY9516_EXPORT_RX_ENGINE_END : JY9516Import
  • JY9516_EXPORT_RX_READY_FOR_ADV_TRIG : JY9516Import
  • JY9516_EXPORT_RX_READY_FOR_REF_TRIG : JY9516Import
  • JY9516_EXPORT_RX_READY_FOR_START_TRIG : JY9516Import
  • JY9516_EXPORT_RX_REF_TRIG : JY9516Import
  • JY9516_EXPORT_RX_START_TRIG : JY9516Import
  • JY9516_EXPORT_SAMPLE_CLOCK : JY9516Import
  • JY9516_EXPORT_SYNC : JY9516Import
  • JY9516_Onboard_10M : JY9516Import
  • JY9516_PXIe_Clk_100M : JY9516Import
  • JY9516_Range_0p3125V : JY9516Import
  • JY9516_Range_0p625V : JY9516Import
  • JY9516_Range_10V : JY9516Import
  • JY9516_Range_15V : JY9516Import
  • JY9516_Range_1p25V : JY9516Import
  • JY9516_Range_2p5V : JY9516Import
  • JY9516_Range_5V : JY9516Import
  • JY9516_SyncMode_Master : JY9516Import
  • JY9516_SyncMode_Slave : JY9516Import
  • JY9516_SyncMode_Solo : JY9516Import
  • JY9516_TriggerType_Analog : JY9516Import
  • JY9516_TriggerType_Digital : JY9516Import
  • JY9516_TriggerType_Immediately : JY9516Import
  • JY9516_TriggerType_Software : JY9516Import
  • JY9516CoreOOLogLevel : JY9516CoreOO
  • JY9516CoreOOPropertyType : JY9516CoreOO
  • JY9517_ADCChopping_fMod8 : JY9516Import
  • JYDriverExceptionPublic : JY9516CoreOO

- l -

  • LevelPolarity : JY9516CoreOO
  • LPFMode : JY9516CoreOO

- n -

  • Normal : JY9516CoreOO

- o -

  • OneOrder : JY9516CoreOO
  • OutputCompleteState : JY9516CoreOO

- p -

  • PXI_Star : JY9516CoreOO
  • PXI_Trig0 : JY9516CoreOO
  • PXI_Trig1 : JY9516CoreOO
  • PXI_Trig2 : JY9516CoreOO
  • PXI_Trig3 : JY9516CoreOO
  • PXI_Trig4 : JY9516CoreOO
  • PXI_Trig5 : JY9516CoreOO
  • PXI_Trig6 : JY9516CoreOO
  • PXI_Trig7 : JY9516CoreOO

- r -

  • ReferenceClockSource : JY9516CoreOO

- s -

  • SamplingState : JY9516CoreOO
  • SignalExportDestination : JY9516CoreOO
  • Sinc5Filter : JY9516CoreOO, JY9516Import
  • Synchronized : JY9516CoreOO
  • SyncState : JY9516CoreOO
  • SyncTerminal : JY9516CoreOO
  • SyncTopology : JY9516CoreOO

- t -

  • TwoOrder : JY9516CoreOO

- w -

  • WaitingSync : JY9516CoreOO
  • WidebandLowRippleFilter : JY9516CoreOO, JY9516Import
  • WideBandwidth : JY9516CoreOO


9516 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
Here is a list of all namespace enums with links to the namespace documentation for each enum:
  • ADCFilterType : JY9516CoreOO
  • AIAnalogTriggerComparator : JY9516CoreOO
  • AIAnalogTriggerEdge : JY9516CoreOO
  • AIAnalogTriggerSource : JY9516CoreOO
  • AIAnalogWindowCondition : JY9516CoreOO
  • AIDigitalTriggerEdge : JY9516CoreOO
  • AIDigitalTriggerSource : JY9516CoreOO
  • AIMode : JY9516CoreOO
  • AIRange : JY9516CoreOO
  • AISignalExportSource : JY9516CoreOO
  • AITriggerMode : JY9516CoreOO
  • AITriggerType : JY9516CoreOO
  • ChoppingFrequency : JY9516CoreOO
  • Coupling : JY9516CoreOO
  • ExternalReferenceClockTerminal : JY9516CoreOO
  • HPFOrder : JY9516CoreOO
  • IEPEConnectionStatus : JY9516CoreOO
  • JY9516CoreOOLogLevel : JY9516CoreOO
  • JY9516CoreOOPropertyType : JY9516CoreOO
  • JYDriverExceptionPublic : JY9516CoreOO
  • LevelPolarity : JY9516CoreOO
  • LPFMode : JY9516CoreOO
  • OutputCompleteState : JY9516CoreOO
  • ReferenceClockSource : JY9516CoreOO
  • SamplingState : JY9516CoreOO
  • SignalExportDestination : JY9516CoreOO
  • SyncState : JY9516CoreOO
  • SyncTerminal : JY9516CoreOO
  • SyncTopology : JY9516CoreOO


9516 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
Here is a list of all namespace enum values with links to the namespace documentation for each enum value:
  • Ext_Trig : JY9516CoreOO
  • fMod32 : JY9516CoreOO
  • fMod8 : JY9516CoreOO
  • Invalid : JY9516CoreOO
  • Normal : JY9516CoreOO
  • OneOrder : JY9516CoreOO
  • PXI_Star : JY9516CoreOO
  • PXI_Trig0 : JY9516CoreOO
  • PXI_Trig1 : JY9516CoreOO
  • PXI_Trig2 : JY9516CoreOO
  • PXI_Trig3 : JY9516CoreOO
  • PXI_Trig4 : JY9516CoreOO
  • PXI_Trig5 : JY9516CoreOO
  • PXI_Trig6 : JY9516CoreOO
  • PXI_Trig7 : JY9516CoreOO
  • Sinc5Filter : JY9516CoreOO
  • Synchronized : JY9516CoreOO
  • TwoOrder : JY9516CoreOO
  • WaitingSync : JY9516CoreOO
  • WidebandLowRippleFilter : JY9516CoreOO
  • WideBandwidth : JY9516CoreOO


9516 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
Here is a list of all namespace functions with links to the namespace documentation for each function:
  • GetSignalExportDestinationString() : JY9516CoreOO


9516 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
  • Enumerator
  • a
  • j
  • s
  • w
Here is a list of all namespace variables with links to the namespace documentation for each variable:

- a -

  • AIRagneGrade : JY9516CoreOO
  • AIRangeDescriptions : JY9516CoreOO

- j -

  • JY9516_ADCChopping_fMod32 : JY9516Import
  • JY9516_AI_Continuous : JY9516Import
  • JY9516_AI_Finite : JY9516Import
  • JY9516_AI_Single : JY9516Import
  • JY9516_AnlogTriggerCondition_EnteringWindow : JY9516Import
  • JY9516_AnlogTriggerCondition_FallingHysteresis : JY9516Import
  • JY9516_AnlogTriggerCondition_LeavingWindow : JY9516Import
  • JY9516_AnlogTriggerCondition_RisingHysteresis : JY9516Import
  • JY9516_CalCoePosition_EEPROM : JY9516Import
  • JY9516_CalCoePosition_Handle : JY9516Import
  • JY9516_Coupling_AC : JY9516Import
  • JY9516_Coupling_DC : JY9516Import
  • JY9516_DigitalTriggerEdge_Falling : JY9516Import
  • JY9516_DigitalTriggerEdge_Rising : JY9516Import
  • JY9516_DigitalTriggerSource_BUS_0 : JY9516Import
  • JY9516_DigitalTriggerSource_BUS_1 : JY9516Import
  • JY9516_DigitalTriggerSource_BUS_2 : JY9516Import
  • JY9516_DigitalTriggerSource_BUS_3 : JY9516Import
  • JY9516_DigitalTriggerSource_BUS_4 : JY9516Import
  • JY9516_DigitalTriggerSource_BUS_5 : JY9516Import
  • JY9516_DigitalTriggerSource_BUS_6 : JY9516Import
  • JY9516_DigitalTriggerSource_BUS_7 : JY9516Import
  • JY9516_DigitalTriggerSource_External : JY9516Import
  • JY9516_DigitalTriggerSource_STAR : JY9516Import
  • JY9516_EXPORT_ADC_DRDY : JY9516Import
  • JY9516_EXPORT_ADC_SYNC : JY9516Import
  • JY9516_EXPORT_DCLK : JY9516Import
  • JY9516_EXPORT_MCLK : JY9516Import
  • JY9516_EXPORT_PLL_SYNC : JY9516Import
  • JY9516_EXPORT_RX_ADV_TRIG : JY9516Import
  • JY9516_EXPORT_RX_END_OF_RECORD : JY9516Import
  • JY9516_EXPORT_RX_ENGINE_END : JY9516Import
  • JY9516_EXPORT_RX_READY_FOR_ADV_TRIG : JY9516Import
  • JY9516_EXPORT_RX_READY_FOR_REF_TRIG : JY9516Import
  • JY9516_EXPORT_RX_READY_FOR_START_TRIG : JY9516Import
  • JY9516_EXPORT_RX_REF_TRIG : JY9516Import
  • JY9516_EXPORT_RX_START_TRIG : JY9516Import
  • JY9516_EXPORT_SAMPLE_CLOCK : JY9516Import
  • JY9516_EXPORT_SYNC : JY9516Import
  • JY9516_Onboard_10M : JY9516Import
  • JY9516_PXIe_Clk_100M : JY9516Import
  • JY9516_Range_0p3125V : JY9516Import
  • JY9516_Range_0p625V : JY9516Import
  • JY9516_Range_10V : JY9516Import
  • JY9516_Range_15V : JY9516Import
  • JY9516_Range_1p25V : JY9516Import
  • JY9516_Range_2p5V : JY9516Import
  • JY9516_Range_5V : JY9516Import
  • JY9516_SyncMode_Master : JY9516Import
  • JY9516_SyncMode_Slave : JY9516Import
  • JY9516_SyncMode_Solo : JY9516Import
  • JY9516_TriggerType_Analog : JY9516Import
  • JY9516_TriggerType_Digital : JY9516Import
  • JY9516_TriggerType_Immediately : JY9516Import
  • JY9516_TriggerType_Software : JY9516Import
  • JY9517_ADCChopping_fMod8 : JY9516Import

- s -

  • Sinc5Filter : JY9516Import

- w -

  • WidebandLowRippleFilter : JY9516Import


9516 C++ Programming Manual: Namespace List

  • Namespace List
  • Namespace Members
Namespace List
Here is a list of all namespaces with brief descriptions:
N JY9516CoreOO
N JY9516Import


9516 C++ Programming Manual: Member List

  • FirmDriveInfo
JY9516CoreOO::FirmDriveInfo Member List

This is the complete list of members for JY9516CoreOO::FirmDriveInfo, including all inherited members.

aliasName | JY9516CoreOO::FirmDriveInfo
cardNumber | JY9516CoreOO::FirmDriveInfo
connected | JY9516CoreOO::FirmDriveInfo
DriverSetVer | JY9516CoreOO::FirmDriveInfo
FirmwareVer | JY9516CoreOO::FirmDriveInfo
FrameworkVer | JY9516CoreOO::FirmDriveInfo
fStreaming | JY9516CoreOO::FirmDriveInfo
HardwareVer | JY9516CoreOO::FirmDriveInfo
model | JY9516CoreOO::FirmDriveInfo
PID | JY9516CoreOO::FirmDriveInfo
PlatformType | JY9516CoreOO::FirmDriveInfo
ProductionDate | JY9516CoreOO::FirmDriveInfo
serialNumber | JY9516CoreOO::FirmDriveInfo
slotNum | JY9516CoreOO::FirmDriveInfo
vendorName | JY9516CoreOO::FirmDriveInfo
VID | JY9516CoreOO::FirmDriveInfo