9516T C++ Programming Manual: D:/OneDrive/Desktop/产品文档/CHM/9516T/C++/JY9516T.h File Reference

9516T C++ Programming Manual
  • Main Page
  • Files
  • File List
  • File Members
  • OneDrive
  • Desktop
  • 产品文档
  • CHM
  • 9516T
  • C++
Typedefs | Enumerations | Functions
JY9516T.h File Reference

Typedefs

typedef void * JY9516T_DeviceHandle
Windows.

Enumerations

enum | JY9516T_RefClockSource { JY9516T_Onboard_10M = 0 , JY9516T_PXIe_Clk_100M = 1 }
enum JY9516T_AI_Range {
JY9516T_Range_10V = 5 , JY9516T_Range_5V = 4 , JY9516T_Range_2p5V = 3 , JY9516T_Range_1p25V = 2 ,
JY9516T_Range_0p625V = 1 , JY9516T_Range_0p3125V = 0
}
enum | JY9516T_AI_Terminal { JY9516T_Terminal_Pseudodifferential = 0 , JY9516T_Terminal_Differential = 1 }
enum | JY9516T_AI_Coupling { JY9516T_Coupling_AC = 0 , JY9516T_Coupling_DC = 1 }
enum | JY9516T_AI_SampleMode { JY9516T_AI_Finite = 0 , JY9516T_AI_Continuous = 1 , JY9516T_AI_Single = 2 }
enum | JY9516T_AI_TriggerType { JY9516T_AI_Immediate = 0 , JY9516T_AI_Digital = 1 , JY9516T_AI_Software = 2 , JY9516T_AI_Analog = 3 }
enum JY9516T_IOTerminal {
JY9516T_External_Trigger = 0 , JY9516T_PXI_Trig_0 = 1 , JY9516T_PXI_Trig_1 = 2 , JY9516T_PXI_Trig_2 = 3 ,
JY9516T_PXI_Trig_3 = 4 , JY9516T_PXI_Trig_4 = 5 , JY9516T_PXI_Trig_5 = 6 , JY9516T_PXI_Trig_6 = 7 ,
JY9516T_PXI_Trig_7 = 8
}
enum | JY9516T_DigitalTriggerEdge { JY9516T_Rising = 0 , JY9516T_Falling = 1 }
enum | JY9516T_AnalogTriggerCondition { JY9516T_RisingHysteresis = 0 , JY9516T_FallingHysteresis = 1 , JY9516T_EnteringWindow = 2 , JY9516T_LeavingWindow = 3 }
enum | JY9516T_SyncMode { JY9516T_SyncMode_Solo = 0 , JY9516T_SyncMode_Master = 1 , JY9516T_SyncMode_Slave = 2 }
enum JY9516T_AI_ExportSource {
JY9516T_ExportSource_SampleClock = 0 , JY9516T_ExportSource_SyncPulse = 1 , JY9516T_ExportSource_ReadyForTrig = 2 , JY9516T_ExportSource_Trig = 3 ,
JY9516T_ExportSource_EndOfRecord = 4 , JY9516T_ExportSource_EndOfAcquisition = 5
}
enum | JY9516T_ADC_fChop_Div { JY9516T_ADC_fChop_32 = 0 , JY9516T_ADC_fChop_8 = 1 }
enum | JY9516T_IEPEConnectionStatus { JY9516T_IEPEConnection_Normal = 0 , JY9516T_IEPEConnection_Open = 1 , JY9516T_IEPEConnection_Short = 2 }
enum | JY9516T_AI_LPFMode { JY9516T_AI_LPF_Normal = 0 , JY9516T_AI_LPF_WideBandwidth = 1 , JY9516T_AI_LPF_LowLatency = 2 }
enum JY9516T_RxState {
RxState_Idle = 0 , RxState_PreSampling = 1 , RxState_WaitingForTrigger = 2 , RxState_PostSampling = 3 ,
RxState_Done = 4
}
enum | JY9516T_AI_Capability_Item { JY9516T_AI_NumberOfChannels_Int = 0 , JY9516T_AI_MaxSampleRate_Double = 1 , JY9516T_AI_MinSampleRate_Double = 2 }

Functions

JY9516T_API int | JY9516T_Open (int slotNumber, JY9516T_DeviceHandle *hDevice)
打开板卡
JY9516T_API int | JY9516T_OpenByName (const char *cardName, JY9516T_DeviceHandle *hDevice)
以别名打开板卡
JY9516T_API int | JY9516T_Close (JY9516T_DeviceHandle hDevice)
关闭设备，释放句柄
JY9516T_API int | JY9516T_GetCapabilityIntBySlotNumber (int slotNumber, JY9516T_AI_Capability_Item item, int *value, bool setDefaultIfDeviceNotFound=true)
在不打开设备的情况下，获取位于指定卡槽号的设备的能力信息中的整型数值参数，比如通道数
JY9516T_API int | JY9516T_GetCapabilityDoubleBySlotNumber (int slotNumber, JY9516T_AI_Capability_Item item, double *value, bool setDefaultIfDeviceNotFound=true)
在不打开设备的情况下，获取位于指定卡槽号的设备的能力信息中的浮点型数值参数，比如最高采样率
JY9516T_API int | JY9516T_GetCapabilityIntByName (const char *deviceName, JY9516T_AI_Capability_Item item, int *value, bool setDefaultIfDeviceNotFound=true)
在不打开设备的情况下，获取指定别名的设备的能力信息中的整型数值参数，比如通道数
JY9516T_API int | JY9516T_GetCapabilityDoubleByName (const char *deviceName, JY9516T_AI_Capability_Item item, double *value, bool setDefaultIfDeviceNotFound=true)
在不打开设备的情况下，获取指定别名的设备的能力信息中的浮点型数值参数，比如最高采样率
JY9516T_API int | JY9516T_GetCapabilityInt (JY9516T_DeviceHandle hDevice, JY9516T_AI_Capability_Item item, int *value)
获取当前设备的能力信息中的整型数值参数，比如通道数
JY9516T_API int | JY9516T_GetCapabilityDouble (JY9516T_DeviceHandle hDevice, JY9516T_AI_Capability_Item item, double *value)
获取当前设备的能力信息，比如最高采样率
JY9516T_API int | JY9516T_GetDeviceInfo (JY9516T_DeviceHandle hDevice, unsigned char *info)
获取设备信息
JY9516T_API int | JY9516T_AI_EnableChannel (JY9516T_DeviceHandle hDevice, unsigned int chCnt, int *chID, JY9516T_AI_Range *range, JY9516T_AI_Terminal *terminal, JY9516T_AI_Coupling *coupling, int *enableIEPE)
使能通道
JY9516T_API int | JY9516T_AI_SetRefClkSrc (JY9516T_DeviceHandle hDevice, JY9516T_RefClockSource refClkSrc)
设置参考时钟源
JY9516T_API int | JY9516T_AI_SetSampleRate (JY9516T_DeviceHandle hDevice, double sampleRate, JY9516T_AI_LPFMode filterMode)
设置采样率
JY9516T_API int | JY9516T_AI_SetSampleMode (JY9516T_DeviceHandle hDevice, JY9516T_AI_SampleMode mode)
设置采样模式
JY9516T_API int | JY9516T_AI_SetSamplesToAcquire (JY9516T_DeviceHandle hDevice, unsigned int samplesToAcquire)
设置待采样数
JY9516T_API int | JY9516T_AI_Commit (JY9516T_DeviceHandle hDevice)
提交配置。开始采集前必须先调用本API以使所有配置生效。
JY9516T_API int | JY9516T_AI_Start (JY9516T_DeviceHandle hDevice)
开始采集任务
JY9516T_API int | JY9516T_AI_Stop (JY9516T_DeviceHandle hDevice)
停止采集
JY9516T_API int | JY9516T_AI_ReadSingleHeader (JY9516T_DeviceHandle hDevice, int *headerBuffer)
获取所有已使能通道的转换输出标头（非缓冲式读取）
JY9516T_API int | JY9516T_AI_ReadSinglePoint (JY9516T_DeviceHandle hDevice, double *dataBuffer)
获取所有已使能通道的转换输出数据（非缓冲式读取）
JY9516T_API int | JY9516T_AI_ReadRawData (JY9516T_DeviceHandle hDevice, int *dataBuffer, unsigned int dataLength, int timeout, unsigned int *actualReadLength)
读取数据(原始值)
JY9516T_API int | JY9516T_AI_ReadData (JY9516T_DeviceHandle hDevice, double *dataBuffer, unsigned int dataLength, int timeout, unsigned int *actualReadLength)
读取数据
JY9516T_API int | JY9516T_AI_WaitUntilDone (JY9516T_DeviceHandle hDevice, int timeout, bool *done)
检查有限点采集是否已完成
JY9516T_API int | JY9516T_AI_CheckRxStatus (JY9516T_DeviceHandle hDevice, JY9516T_RxState *rxState)
获取采集状态
JY9516T_API int | JY9516T_AI_CheckBufferStatus (JY9516T_DeviceHandle hDevice, unsigned long *availableSamplesCount, unsigned long *transferedSamplesCount, bool *overflow)
获取缓冲区状态
JY9516T_API int | JY9516T_AI_SetTriggerType (JY9516T_DeviceHandle hDevice, JY9516T_AI_TriggerType triggerType)
设置StartTigger的触发模式
JY9516T_API int | JY9516T_AI_SetDigitalTrigger (JY9516T_DeviceHandle hDevice, JY9516T_IOTerminal triggerSource, JY9516T_DigitalTriggerEdge triggerEdge)
设置StartTrigger的数字触发源
JY9516T_API int | JY9516T_AI_SetAnalogTrigger (JY9516T_DeviceHandle hDevice, unsigned int triggerSource, JY9516T_AnalogTriggerCondition triggerCondition, double highThreshold, double lowThreshold)
设置模拟触发
JY9516T_API int | JY9516T_AI_SetPreTriggerSamples (JY9516T_DeviceHandle hDevice, unsigned int preTriggerSamples)
设置预触发点数
JY9516T_API int | JY9516T_AI_SetReTriggerCount (JY9516T_DeviceHandle hDevice, int reTriggerCount)
设置重触发次数
JY9516T_API int | JY9516T_AI_SendSoftwareTrigger (JY9516T_DeviceHandle hDevice)
发送软件触发
JY9516T_API int | JY9516T_AI_ConfigSync (JY9516T_DeviceHandle hDevice, JY9516T_SyncMode syncMode, JY9516T_IOTerminal syncRequestRouting)
配置多卡同步
JY9516T_API int | JY9516T_AI_Sync (JY9516T_DeviceHandle hDevice)
启动同步。当同步模式为Sole时，立即同步PLL和ADC，不输出同步请求；当同步模式为Master时，立即同步PLL和ADC，并输出同步请求；当同步模式为Slave时，等待同步请求到达后同步PLL和ADC。应先开启Slave的同步流程，再开启Master的同步流程。
JY9516T_API int | JY9516T_AI_CheckSyncStatus (JY9516T_DeviceHandle hDevice, bool *synchronized)
获取同步状态
JY9516T_API int | JY9516T_AI_ConfigSignalExport (JY9516T_DeviceHandle hDevice, unsigned int routesCount, JY9516T_IOTerminal *dests, JY9516T_AI_ExportSource *srcs)
配置信号导出。要导出的信号源将在AITask.Commit()时连接到指定的导出端口，在Stop时断开、恢复到低电平。
JY9516T_API int | JY9516T_AI_GetCurrentClkFreq (JY9516T_DeviceHandle hDevice, double *mclkFreq, double *fMod, double *dclkFreq)
获取当前状态下的各个时钟的频率，至少Arm()一次后才有效
JY9516T_API int | JY9516T_AI_ParseSampleRate (double sampleRate, JY9516T_AI_LPFMode filterMode, double *fMod, double *groupDelay)
获取指定采样率、和数字滤波器模式下的相关参数
JY9516T_API int | JY9516T_AI_ConfigHPF (JY9516T_DeviceHandle hDevice, unsigned int channelEnableMask, double cutoffFreq, int order)
设置高通滤波器
JY9516T_API int | JY9516T_AI_ConfigADChoppingFrequency (JY9516T_DeviceHandle hDevice, JY9516T_ADC_fChop_Div fchopDiv)
设置ADC调制器斩波频率
JY9516T_API int | JY9516T_AI_DetectIEPEConnection (JY9516T_DeviceHandle hDevice, JY9516T_IEPEConnectionStatus *buf)
检测IEPE连接状态（正常/开路/短路）。当采集任务正在运行时不要调用；执行本操作前无需调用Commit(),但执行过本操作后若要执行采集任务则必须重新调用Commit()。
JY9516T_API int | JY9516T_AI_DisableDCCalibration (JY9516T_DeviceHandle hDevice, bool disable)
禁用DC校准
JY9516T_API int | JY9516T_AI_DisableLinerityCalibration (JY9516T_DeviceHandle hDevice, bool disable)
禁用线性度校准
JY9516T_API int | JY9516T_AI_DisableFlatnessCalibration (JY9516T_DeviceHandle hDevice, bool disable)
禁用平坦度校准
JY9516T_API int | JY9516T_IdentifyTEDSChip (JY9516T_DeviceHandle hDevice, int chID, unsigned long long *romID, int *totalPageCount)
识别指定通道上连接的TEDS传感器的TEDS芯片（EEPROM），以获取其型号和存储容量。
JY9516T_API int | JY9516T_ReadTEDSData (JY9516T_DeviceHandle hDevice, int chID, unsigned long long romID, char *data, int readPageCount)
从指定通道上读取TEDS传感器的TEDS数据。

Typedef Documentation

◆ JY9516T_DeviceHandle

typedef void* JY9516T_DeviceHandle

Windows.

Linux

Enumeration Type Documentation

◆ JY9516T_ADC_fChop_Div

enum JY9516T_ADC_fChop_Div
Enumerator
JY9516T_ADC_fChop_32
JY9516T_ADC_fChop_8

◆ JY9516T_AI_Capability_Item

enum JY9516T_AI_Capability_Item
Enumerator
JY9516T_AI_NumberOfChannels_Int | Number of channels.
JY9516T_AI_MaxSampleRate_Double | Max Sample Rate.
JY9516T_AI_MinSampleRate_Double | Min Sample Rate.

◆ JY9516T_AI_Coupling

enum JY9516T_AI_Coupling
Enumerator
JY9516T_Coupling_AC
JY9516T_Coupling_DC

◆ JY9516T_AI_ExportSource

enum JY9516T_AI_ExportSource
Enumerator
JY9516T_ExportSource_SampleClock
JY9516T_ExportSource_SyncPulse
JY9516T_ExportSource_ReadyForTrig
JY9516T_ExportSource_Trig
JY9516T_ExportSource_EndOfRecord
JY9516T_ExportSource_EndOfAcquisition

◆ JY9516T_AI_LPFMode

enum JY9516T_AI_LPFMode
Enumerator
JY9516T_AI_LPF_Normal | Normal Mode. It has 0.4*fs bandwidth, medium latency, and a maximum sample rate of 256kSa/s.
JY9516T_AI_LPF_WideBandwidth | Wide Bandwidth Mode. It has 0.4535*fs bandwidth, high latency, and a maximum sample rate of 128kSa/s.
JY9516T_AI_LPF_LowLatency | Low Latency Mode. It has 0.1*fs bandwidth, low latency, and a maximum sample rate of 4kSa/s.

◆ JY9516T_AI_Range

enum JY9516T_AI_Range
Enumerator
JY9516T_Range_10V
JY9516T_Range_5V
JY9516T_Range_2p5V
JY9516T_Range_1p25V
JY9516T_Range_0p625V
JY9516T_Range_0p3125V

◆ JY9516T_AI_SampleMode

enum JY9516T_AI_SampleMode
Enumerator
JY9516T_AI_Finite
JY9516T_AI_Continuous
JY9516T_AI_Single

◆ JY9516T_AI_Terminal

enum JY9516T_AI_Terminal
Enumerator
JY9516T_Terminal_Pseudodifferential
JY9516T_Terminal_Differential

◆ JY9516T_AI_TriggerType

enum JY9516T_AI_TriggerType
Enumerator
JY9516T_AI_Immediate
JY9516T_AI_Digital
JY9516T_AI_Software
JY9516T_AI_Analog

◆ JY9516T_AnalogTriggerCondition

enum JY9516T_AnalogTriggerCondition
Enumerator
JY9516T_RisingHysteresis
JY9516T_FallingHysteresis
JY9516T_EnteringWindow
JY9516T_LeavingWindow

◆ JY9516T_DigitalTriggerEdge

enum JY9516T_DigitalTriggerEdge
Enumerator
JY9516T_Rising
JY9516T_Falling

◆ JY9516T_IEPEConnectionStatus

enum JY9516T_IEPEConnectionStatus
Enumerator
JY9516T_IEPEConnection_Normal
JY9516T_IEPEConnection_Open
JY9516T_IEPEConnection_Short

◆ JY9516T_IOTerminal

enum JY9516T_IOTerminal
Enumerator
JY9516T_External_Trigger
JY9516T_PXI_Trig_0
JY9516T_PXI_Trig_1
JY9516T_PXI_Trig_2
JY9516T_PXI_Trig_3
JY9516T_PXI_Trig_4
JY9516T_PXI_Trig_5
JY9516T_PXI_Trig_6
JY9516T_PXI_Trig_7

◆ JY9516T_RefClockSource

enum JY9516T_RefClockSource
Enumerator
JY9516T_Onboard_10M
JY9516T_PXIe_Clk_100M

◆ JY9516T_RxState

enum JY9516T_RxState
Enumerator
RxState_Idle | Idle.
RxState_PreSampling | Pre-sampling.
RxState_WaitingForTrigger | Waiting for trigger.
RxState_PostSampling | Post-sampling.
RxState_Done | Done.

◆ JY9516T_SyncMode

enum JY9516T_SyncMode
Enumerator
JY9516T_SyncMode_Solo
JY9516T_SyncMode_Master
JY9516T_SyncMode_Slave

Function Documentation

◆ JY9516T_AI_CheckBufferStatus()

JY9516T_API int JY9516T_AI_CheckBufferStatus | ( | JY9516T_DeviceHandle | hDevice,
 |  | unsigned long * | availableSamplesCount,
 |  | unsigned long * | transferedSamplesCount,
 |  | bool * | overflow )

获取缓冲区状态

Parameters
hDevice | 板卡句柄
availableSamplesCount | 缓冲区已有的Sample的数量
overflow | 是否发生溢出
Returns
0：无错误；其它：发生错误

◆ JY9516T_AI_CheckRxStatus()

JY9516T_API int JY9516T_AI_CheckRxStatus | ( | JY9516T_DeviceHandle | hDevice,
 |  | JY9516T_RxState * | rxState )

获取采集状态

Parameters
hDevice | 板卡句柄
rxState | 返回有当前采集状态
Returns
0：无错误；其它：发生错误

◆ JY9516T_AI_CheckSyncStatus()

JY9516T_API int JY9516T_AI_CheckSyncStatus | ( | JY9516T_DeviceHandle | hDevice,
 |  | bool * | synchronized )

获取同步状态

Parameters
hDevice | 板卡句柄
synchronized | 是否已同步
Returns
0：无错误；其它：发生错误

◆ JY9516T_AI_Commit()

JY9516T_API int JY9516T_AI_Commit ( JY9516T_DeviceHandle hDevice )

提交配置。开始采集前必须先调用本API以使所有配置生效。

Parameters
hDevice 板卡句柄
Returns
成功：0 , 失败：!=0

◆ JY9516T_AI_ConfigADChoppingFrequency()

JY9516T_API int JY9516T_AI_ConfigADChoppingFrequency | ( | JY9516T_DeviceHandle | hDevice,
 |  | JY9516T_ADC_fChop_Div | fchopDiv )

设置ADC调制器斩波频率

Parameters
hDevice 板卡句柄
fchopDiv

◆ JY9516T_AI_ConfigHPF()

JY9516T_API int JY9516T_AI_ConfigHPF | ( | JY9516T_DeviceHandle | hDevice,
 |  | unsigned int | channelEnableMask,
 |  | double | cutoffFreq,
 |  | int | order )

设置高通滤波器

Parameters
hDevice | 板卡句柄
channelEnableMask | 各通道上的滤波器使能，按bit设置，对应比特位为1时表示使能。如0x00FF表示使能Ch0~Ch7上的滤波器，禁用Ch8~Ch15上的滤波器。
cutoffFreq | 截至频率。最大只能为采样率的1。当使用一阶滤波器时该处的衰减为-3dB；当使用二阶滤波器时该处的衰减为-3dB。
order | HPF滤波器的阶数。可选阶数为1或2。

◆ JY9516T_AI_ConfigSignalExport()

JY9516T_API int JY9516T_AI_ConfigSignalExport | ( | JY9516T_DeviceHandle | hDevice,
 |  | unsigned int | routesCount,
 |  | JY9516T_IOTerminal * | dests,
 |  | JY9516T_AI_ExportSource * | srcs )

配置信号导出。要导出的信号源将在AITask.Commit()时连接到指定的导出端口，在Stop时断开、恢复到低电平。

Parameters
hDevice | 板卡句柄
routesCount | 导出路径的数量
dests | 导出端口
srcs | 导出源
Returns
0：无错误；其它：发生错误

◆ JY9516T_AI_ConfigSync()

JY9516T_API int JY9516T_AI_ConfigSync | ( | JY9516T_DeviceHandle | hDevice,
 |  | JY9516T_SyncMode | syncMode,
 |  | JY9516T_IOTerminal | syncRequestRouting )

配置多卡同步

Parameters
hDevice | 板卡句柄
syncMode | 同步模式
syncRequestRouting | 同步请求路由路径
Returns
0：无错误；其它：发生错误

◆ JY9516T_AI_DetectIEPEConnection()

JY9516T_API int JY9516T_AI_DetectIEPEConnection | ( | JY9516T_DeviceHandle | hDevice,
 |  | JY9516T_IEPEConnectionStatus * | buf )

检测IEPE连接状态（正常/开路/短路）。当采集任务正在运行时不要调用；执行本操作前无需调用Commit(),但执行过本操作后若要执行采集任务则必须重新调用Commit()。

Parameters
hDevice | 板卡句柄
buf | 返回各通道的IEPE开路/短路检测结果

◆ JY9516T_AI_DisableDCCalibration()

JY9516T_API int JY9516T_AI_DisableDCCalibration | ( | JY9516T_DeviceHandle | hDevice,
 |  | bool | disable )

禁用DC校准

Parameters
hDevice | 板卡句柄
enabled | 是否禁用校准，为true时禁用
Returns
0：无错误；其它：发生错误

◆ JY9516T_AI_DisableFlatnessCalibration()

JY9516T_API int JY9516T_AI_DisableFlatnessCalibration | ( | JY9516T_DeviceHandle | hDevice,
 |  | bool | disable )

禁用平坦度校准

Parameters
hDevice | 板卡句柄
enabled | 是否禁用校准，为true时禁用
Returns
0：无错误；其它：发生错误

◆ JY9516T_AI_DisableLinerityCalibration()

JY9516T_API int JY9516T_AI_DisableLinerityCalibration | ( | JY9516T_DeviceHandle | hDevice,
 |  | bool | disable )

禁用线性度校准

Parameters
hDevice | 板卡句柄
enabled | 是否禁用校准，为true时禁用
Returns
0：无错误；其它：发生错误

◆ JY9516T_AI_EnableChannel()

JY9516T_API int JY9516T_AI_EnableChannel | ( | JY9516T_DeviceHandle | hDevice,
 |  | unsigned int | chCnt,
 |  | int * | chID,
 |  | JY9516T_AI_Range * | range,
 |  | JY9516T_AI_Terminal * | terminal,
 |  | JY9516T_AI_Coupling * | coupling,
 |  | int * | enableIEPE )

使能通道

Parameters
hDevice | 板卡句柄
chCnt | 要使能的通道的数量
chID | 要使能的通道的物理号
range | 输入电压范围
terminal | 输入接线方式
coupling | 输入耦合方式
enableIEPE | 是否使能IEPE
Returns
0：无错误；其它：发生错误

◆ JY9516T_AI_GetCurrentClkFreq()

JY9516T_API int JY9516T_AI_GetCurrentClkFreq | ( | JY9516T_DeviceHandle | hDevice,
 |  | double * | mclkFreq,
 |  | double * | fMod,
 |  | double * | dclkFreq )

获取当前状态下的各个时钟的频率，至少Arm()一次后才有效

Parameters
hDevice | 板卡句柄
mclkFreq | 提供给ADC的时钟MCLK（即PLL输出的时钟）的频率
fMod | adc调制器频率
dclkFreq | ADC提供的数据时钟DCLK的频率
Returns
0：无错误；其它：发生错误

◆ JY9516T_AI_ParseSampleRate()

JY9516T_API int JY9516T_AI_ParseSampleRate | ( | double | sampleRate,
 |  | JY9516T_AI_LPFMode | filterMode,
 |  | double * | fMod,
 |  | double * | groupDelay )

获取指定采样率、和数字滤波器模式下的相关参数

Parameters
sampleRate | 板卡句柄
filterMode | 滤波器模式
fMod | adc调制器频率
groupDelay | 总的群延迟，单位Sa
Returns
0：无错误；其它：发生错误

◆ JY9516T_AI_ReadData()

JY9516T_API int JY9516T_AI_ReadData | ( | JY9516T_DeviceHandle | hDevice,
 |  | double * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeout,
 |  | unsigned int * | actualReadLength )

读取数据

Parameters
hDevice | 板卡句柄
dataBuffer | 返回采集数据的工程值（电压，单位V）
dataLength | 要读取的数据长度
timeout | 读取数据超时时间(ms)，为-1时永不超时
actualReadLength | 返回实际读取到的数据长度
Returns
0：无错误；其它：发生错误

◆ JY9516T_AI_ReadRawData()

JY9516T_API int JY9516T_AI_ReadRawData | ( | JY9516T_DeviceHandle | hDevice,
 |  | int * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeout,
 |  | unsigned int * | actualReadLength )

读取数据(原始值)

Parameters
hDevice | 板卡句柄
dataBuffer | 返回采集数据原始值
dataLength | 要读取的数据长度
timeout | 读取数据超时时间(ms)，为-1时永不超时
actualReadLength | 返回实际读取到的数据长度
Returns
0：无错误；其它：发生错误

◆ JY9516T_AI_ReadSingleHeader()

JY9516T_API int JY9516T_AI_ReadSingleHeader | ( | JY9516T_DeviceHandle | hDevice,
 |  | int * | headerBuffer )

获取所有已使能通道的转换输出标头（非缓冲式读取）

Parameters
hDevice | 板卡句柄
header | 返回标头数组。bit[3:0]: 通道ID；bit4: 滤波器饱和；bit5: 滤波器类型（0-宽带滤波器，1-sinc5滤波器）；bit6：重复数据；bit7：滤波器未建立；bit8：芯片错误。
Returns
0：无错误；其它：发生错误

◆ JY9516T_AI_ReadSinglePoint()

JY9516T_API int JY9516T_AI_ReadSinglePoint | ( | JY9516T_DeviceHandle | hDevice,
 |  | double * | dataBuffer )

获取所有已使能通道的转换输出数据（非缓冲式读取）

Parameters
hDevice | 板卡句柄
dataBuffer | 返回转换输出数据（电压，单位V）
Returns
0：无错误；其它：发生错误

◆ JY9516T_AI_SendSoftwareTrigger()

JY9516T_API int JY9516T_AI_SendSoftwareTrigger ( JY9516T_DeviceHandle hDevice )

发送软件触发

Parameters
hDevice 板卡句柄
Returns
0：无错误；其它：发生错误

◆ JY9516T_AI_SetAnalogTrigger()

JY9516T_API int JY9516T_AI_SetAnalogTrigger | ( | JY9516T_DeviceHandle | hDevice,
 |  | unsigned int | triggerSource,
 |  | JY9516T_AnalogTriggerCondition | triggerCondition,
 |  | double | highThreshold,
 |  | double | lowThreshold )

设置模拟触发

Parameters
hDevice | 板卡句柄
triggerSource | 模拟触发源通道选择
triggerCondition | 数字触发源触发条件选择
highThreshold | 高阈值电压(V)
lowThreshold | 低阈值电压(V)
Returns
0：无错误；其它：发生错误

◆ JY9516T_AI_SetDigitalTrigger()

JY9516T_API int JY9516T_AI_SetDigitalTrigger | ( | JY9516T_DeviceHandle | hDevice,
 |  | JY9516T_IOTerminal | triggerSource,
 |  | JY9516T_DigitalTriggerEdge | triggerEdge )

设置StartTrigger的数字触发源

Parameters
hDevice | 板卡句柄
triggerSource | 数字触发源通道选择
triggerEdge | 数字触发源触发条件选择
Returns
0：无错误；其它：发生错误

◆ JY9516T_AI_SetPreTriggerSamples()

JY9516T_API int JY9516T_AI_SetPreTriggerSamples | ( | JY9516T_DeviceHandle | hDevice,
 |  | unsigned int | preTriggerSamples )

设置预触发点数

Parameters
hDevice | 板卡句柄
preTriggerSamples | 预触发点数
Returns
0：无错误；其它：发生错误

◆ JY9516T_AI_SetRefClkSrc()

JY9516T_API int JY9516T_AI_SetRefClkSrc | ( | JY9516T_DeviceHandle | hDevice,
 |  | JY9516T_RefClockSource | refClkSrc )

设置参考时钟源

Parameters
hDevice | 板卡句柄
refClkSrc | 参考时钟源
Returns
0：无错误；其它：发生错误

◆ JY9516T_AI_SetReTriggerCount()

JY9516T_API int JY9516T_AI_SetReTriggerCount | ( | JY9516T_DeviceHandle | hDevice,
 |  | int | reTriggerCount )

设置重触发次数

Parameters
hDevice | 板卡句柄
reTriggerCount | 重触发次数
Returns
0：无错误；其它：发生错误

◆ JY9516T_AI_SetSampleMode()

JY9516T_API int JY9516T_AI_SetSampleMode | ( | JY9516T_DeviceHandle | hDevice,
 |  | JY9516T_AI_SampleMode | mode )

设置采样模式

Parameters
hDevice | 板卡句柄
mode | 采样模式
Returns
0：无错误；其它：发生错误

◆ JY9516T_AI_SetSampleRate()

JY9516T_API int JY9516T_AI_SetSampleRate | ( | JY9516T_DeviceHandle | hDevice,
 |  | double | sampleRate,
 |  | JY9516T_AI_LPFMode | filterMode )

设置采样率

Parameters
hDevice | 板卡句柄
sampleRate | 要设置的采样率
Returns
0：无错误；其它：发生错误

◆ JY9516T_AI_SetSamplesToAcquire()

JY9516T_API int JY9516T_AI_SetSamplesToAcquire | ( | JY9516T_DeviceHandle | hDevice,
 |  | unsigned int | samplesToAcquire )

设置待采样数

Parameters
hDevice | 板卡句柄
samplesToAcquire | 待采样数，即每个通道上要采集的样点数
Returns
0：无错误；其它：发生错误

◆ JY9516T_AI_SetTriggerType()

JY9516T_API int JY9516T_AI_SetTriggerType | ( | JY9516T_DeviceHandle | hDevice,
 |  | JY9516T_AI_TriggerType | triggerType )

设置StartTigger的触发模式

Parameters
hDevice | 板卡句柄
triggerType | 开始触发的工作模式(Immediate/Digital/Analog/Software)
Returns
0：无错误；其它：发生错误

◆ JY9516T_AI_Start()

JY9516T_API int JY9516T_AI_Start ( JY9516T_DeviceHandle hDevice )

开始采集任务

Parameters
hDevice 板卡句柄
Returns
成功：0 , 失败：!=0

◆ JY9516T_AI_Stop()

JY9516T_API int JY9516T_AI_Stop ( JY9516T_DeviceHandle hDevice )

停止采集

Parameters
hDevice 板卡句柄
Returns
0：无错误；其它：发生错误

◆ JY9516T_AI_Sync()

JY9516T_API int JY9516T_AI_Sync ( JY9516T_DeviceHandle hDevice )

启动同步。当同步模式为Sole时，立即同步PLL和ADC，不输出同步请求；当同步模式为Master时，立即同步PLL和ADC，并输出同步请求；当同步模式为Slave时，等待同步请求到达后同步PLL和ADC。应先开启Slave的同步流程，再开启Master的同步流程。

Parameters
hDevice 板卡句柄
Returns
0：无错误；其它：发生错误

◆ JY9516T_AI_WaitUntilDone()

JY9516T_API int JY9516T_AI_WaitUntilDone | ( | JY9516T_DeviceHandle | hDevice,
 |  | int | timeout,
 |  | bool * | done )

检查有限点采集是否已完成

Parameters
hDevice | 板卡句柄
timeout | 超时时间(ms)，为-1时永不超时
done | 返回有限点采集是否已完成(true/false)
Returns
0：无错误；其它：发生错误

◆ JY9516T_Close()

JY9516T_API int JY9516T_Close ( JY9516T_DeviceHandle hDevice )

关闭设备，释放句柄

Parameters
cardName | 板卡名
hDevice | 返回板卡句柄
Returns
0：无错误；其它：发生错误

◆ JY9516T_GetCapabilityDouble()

JY9516T_API int JY9516T_GetCapabilityDouble | ( | JY9516T_DeviceHandle | hDevice,
 |  | JY9516T_AI_Capability_Item | item,
 |  | double * | value )

获取当前设备的能力信息，比如最高采样率

Parameters
hDevice | 板卡句柄
item | 设备能力项
value | 设备能力值
Returns
0：无错误；其它：发生错误

◆ JY9516T_GetCapabilityDoubleByName()

JY9516T_API int JY9516T_GetCapabilityDoubleByName | ( | const char * | deviceName,
 |  | JY9516T_AI_Capability_Item | item,
 |  | double * | value,
 |  | bool | setDefaultIfDeviceNotFound = true )

在不打开设备的情况下，获取指定别名的设备的能力信息中的浮点型数值参数，比如最高采样率

Parameters
deviceName | 设备别名
item | 设备能力项
value | 设备能力值
setDefaultIfDeviceNotFound | 当无法找到指定设备时，若该参数为true，则设置设备能力信息为默认值、不报错；若该参数为false，则返回无法打开设备错误
Returns
0：无错误；其它：发生错误

◆ JY9516T_GetCapabilityDoubleBySlotNumber()

JY9516T_API int JY9516T_GetCapabilityDoubleBySlotNumber | ( | int | slotNumber,
 |  | JY9516T_AI_Capability_Item | item,
 |  | double * | value,
 |  | bool | setDefaultIfDeviceNotFound = true )

在不打开设备的情况下，获取位于指定卡槽号的设备的能力信息中的浮点型数值参数，比如最高采样率

Parameters
slotNumber | 卡槽号
item | 设备能力项
value | 设备能力值
setDefaultIfDeviceNotFound | 当无法找到指定设备时，若该参数为true，则设置设备能力信息为默认值、不报错；若该参数为false，则返回无法打开设备错误
Returns
0：无错误；其它：发生错误

◆ JY9516T_GetCapabilityInt()

JY9516T_API int JY9516T_GetCapabilityInt | ( | JY9516T_DeviceHandle | hDevice,
 |  | JY9516T_AI_Capability_Item | item,
 |  | int * | value )

获取当前设备的能力信息中的整型数值参数，比如通道数

Parameters
hDevice | 板卡句柄
item | 设备能力项
value | 设备能力值
Returns
0：无错误；其它：发生错误

◆ JY9516T_GetCapabilityIntByName()

JY9516T_API int JY9516T_GetCapabilityIntByName | ( | const char * | deviceName,
 |  | JY9516T_AI_Capability_Item | item,
 |  | int * | value,
 |  | bool | setDefaultIfDeviceNotFound = true )

在不打开设备的情况下，获取指定别名的设备的能力信息中的整型数值参数，比如通道数

Parameters
deviceName | 设备别名
item | 设备能力项
value | 设备能力值
setDefaultIfDeviceNotFound | 当无法找到指定设备时，若该参数为true，则设置设备能力信息为默认值、不报错；若该参数为false，则返回无法打开设备错误
Returns
0：无错误；其它：发生错误

◆ JY9516T_GetCapabilityIntBySlotNumber()

JY9516T_API int JY9516T_GetCapabilityIntBySlotNumber | ( | int | slotNumber,
 |  | JY9516T_AI_Capability_Item | item,
 |  | int * | value,
 |  | bool | setDefaultIfDeviceNotFound = true )

在不打开设备的情况下，获取位于指定卡槽号的设备的能力信息中的整型数值参数，比如通道数

Parameters
slotNumber | 卡槽号
item | 设备能力项
value | 设备能力值
setDefaultIfDeviceNotFound | 当无法找到指定设备时，若该参数为true，则设置设备能力信息为默认值、不报错；若该参数为false，则返回无法打开设备错误
Returns
0：无错误；其它：发生错误

◆ JY9516T_GetDeviceInfo()

JY9516T_API int JY9516T_GetDeviceInfo | ( | JY9516T_DeviceHandle | hDevice,
 |  | unsigned char * | info )

获取设备信息

Parameters
hDevice | 板卡句柄
deviceID | 板卡ID
Returns
0：无错误；其它：发生错误

◆ JY9516T_IdentifyTEDSChip()

JY9516T_API int JY9516T_IdentifyTEDSChip | ( | JY9516T_DeviceHandle | hDevice,
 |  | int | chID,
 |  | unsigned long long * | romID,
 |  | int * | totalPageCount )

识别指定通道上连接的TEDS传感器的TEDS芯片（EEPROM），以获取其型号和存储容量。

Parameters
hDevice | 板卡句柄
chID | 要进行TEDS读写的通道
romID | TEDS芯片的64-bit ROM ID。该ID的低8-bit为表征器件型号的Family ID，中间48-bit为SN，高8-bit为CRC-8-Maxim校验码。
totalPageCount | 该TEDS芯片的Memory的总页数。每页长度固定为32bytes。
Returns
0：无错误；其它：发生错误

◆ JY9516T_Open()

JY9516T_API int JY9516T_Open | ( | int | slotNumber,
 |  | JY9516T_DeviceHandle * | hDevice )

打开板卡

Parameters
slotNumber | 板卡号
hDevice | 返回板卡句柄
Returns
0：无错误；其它：发生错误

◆ JY9516T_OpenByName()

JY9516T_API int JY9516T_OpenByName | ( | const char * | cardName,
 |  | JY9516T_DeviceHandle * | hDevice )

以别名打开板卡

Parameters
cardName | 板卡名
hDevice | 返回板卡句柄
Returns
0：无错误；其它：发生错误

◆ JY9516T_ReadTEDSData()

JY9516T_API int JY9516T_ReadTEDSData | ( | JY9516T_DeviceHandle | hDevice,
 |  | int | chID,
 |  | unsigned long long | romID,
 |  | char * | data,
 |  | int | readPageCount )

从指定通道上读取TEDS传感器的TEDS数据。

Parameters
hDevice | 板卡句柄
chID | 要进行TEDS读写的通道
romID | TEDS器件内存的64-bit ROM ID。通过 JY9516T_IdentifyTEDSDevice() 获取该ID。
data | 数据缓存
readPageCount | 要读取的页的数量。固定从第1页开始读取，每页TEDS数据的长度固定为32bytes，总读取长度不得超过TEDS芯片的存储总页数。通过 JY9516T_IdentifyTEDSDevice() 获取TEDS芯片的存储总页数。
Returns
0：无错误；其它：发生错误
Generated by doxygen 1.15.0


9516T C++ Programming Manual: D:/OneDrive/Desktop/产品文档/CHM/9516T Directory Reference

  • Files
  • File List
  • File Members
  • OneDrive
  • Desktop
  • 产品文档
  • CHM
  • 9516T
9516T Directory Reference

Directories

         C++


9516T C++ Programming Manual: D:/OneDrive/Desktop/产品文档/CHM/9516T/C++ Directory Reference

  • OneDrive
  • Desktop
  • 产品文档
  • CHM
  • 9516T
  • C++
C++ Directory Reference

Files

         JY9516T.h


9516T C++ Programming Manual: D:/OneDrive/Desktop/产品文档/CHM Directory Reference

  • OneDrive
  • Desktop
  • 产品文档
  • CHM
CHM Directory Reference

Directories

         9516T


9516T C++ Programming Manual: D:/OneDrive/Desktop Directory Reference

  • OneDrive
  • Desktop
Desktop Directory Reference

Directories

         产品文档


9516T C++ Programming Manual: D:/OneDrive/Desktop/产品文档 Directory Reference

  • OneDrive
  • Desktop
  • 产品文档
产品文档 Directory Reference

Directories

         CHM


9516T C++ Programming Manual: D:/OneDrive Directory Reference

  • OneDrive
OneDrive Directory Reference

Directories

         Desktop


9516T C++ Programming Manual: File List

File List
Here is a list of all files with brief descriptions:
[detail level 1234567]
 OneDrive
Desktop
产品文档
CHM
9516T
C++
JY9516T.h


9516T C++ Programming Manual: File Members

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • j
  • r
Here is a list of all file members with links to the files they belong to:

- j -

  • JY9516T_ADC_fChop_32 : JY9516T.h
  • JY9516T_ADC_fChop_8 : JY9516T.h
  • JY9516T_ADC_fChop_Div : JY9516T.h
  • JY9516T_AI_Analog : JY9516T.h
  • JY9516T_AI_Capability_Item : JY9516T.h
  • JY9516T_AI_CheckBufferStatus() : JY9516T.h
  • JY9516T_AI_CheckRxStatus() : JY9516T.h
  • JY9516T_AI_CheckSyncStatus() : JY9516T.h
  • JY9516T_AI_Commit() : JY9516T.h
  • JY9516T_AI_ConfigADChoppingFrequency() : JY9516T.h
  • JY9516T_AI_ConfigHPF() : JY9516T.h
  • JY9516T_AI_ConfigSignalExport() : JY9516T.h
  • JY9516T_AI_ConfigSync() : JY9516T.h
  • JY9516T_AI_Continuous : JY9516T.h
  • JY9516T_AI_Coupling : JY9516T.h
  • JY9516T_AI_DetectIEPEConnection() : JY9516T.h
  • JY9516T_AI_Digital : JY9516T.h
  • JY9516T_AI_DisableDCCalibration() : JY9516T.h
  • JY9516T_AI_DisableFlatnessCalibration() : JY9516T.h
  • JY9516T_AI_DisableLinerityCalibration() : JY9516T.h
  • JY9516T_AI_EnableChannel() : JY9516T.h
  • JY9516T_AI_ExportSource : JY9516T.h
  • JY9516T_AI_Finite : JY9516T.h
  • JY9516T_AI_GetCurrentClkFreq() : JY9516T.h
  • JY9516T_AI_Immediate : JY9516T.h
  • JY9516T_AI_LPF_LowLatency : JY9516T.h
  • JY9516T_AI_LPF_Normal : JY9516T.h
  • JY9516T_AI_LPF_WideBandwidth : JY9516T.h
  • JY9516T_AI_LPFMode : JY9516T.h
  • JY9516T_AI_MaxSampleRate_Double : JY9516T.h
  • JY9516T_AI_MinSampleRate_Double : JY9516T.h
  • JY9516T_AI_NumberOfChannels_Int : JY9516T.h
  • JY9516T_AI_ParseSampleRate() : JY9516T.h
  • JY9516T_AI_Range : JY9516T.h
  • JY9516T_AI_ReadData() : JY9516T.h
  • JY9516T_AI_ReadRawData() : JY9516T.h
  • JY9516T_AI_ReadSingleHeader() : JY9516T.h
  • JY9516T_AI_ReadSinglePoint() : JY9516T.h
  • JY9516T_AI_SampleMode : JY9516T.h
  • JY9516T_AI_SendSoftwareTrigger() : JY9516T.h
  • JY9516T_AI_SetAnalogTrigger() : JY9516T.h
  • JY9516T_AI_SetDigitalTrigger() : JY9516T.h
  • JY9516T_AI_SetPreTriggerSamples() : JY9516T.h
  • JY9516T_AI_SetRefClkSrc() : JY9516T.h
  • JY9516T_AI_SetReTriggerCount() : JY9516T.h
  • JY9516T_AI_SetSampleMode() : JY9516T.h
  • JY9516T_AI_SetSampleRate() : JY9516T.h
  • JY9516T_AI_SetSamplesToAcquire() : JY9516T.h
  • JY9516T_AI_SetTriggerType() : JY9516T.h
  • JY9516T_AI_Single : JY9516T.h
  • JY9516T_AI_Software : JY9516T.h
  • JY9516T_AI_Start() : JY9516T.h
  • JY9516T_AI_Stop() : JY9516T.h
  • JY9516T_AI_Sync() : JY9516T.h
  • JY9516T_AI_Terminal : JY9516T.h
  • JY9516T_AI_TriggerType : JY9516T.h
  • JY9516T_AI_WaitUntilDone() : JY9516T.h
  • JY9516T_AnalogTriggerCondition : JY9516T.h
  • JY9516T_Close() : JY9516T.h
  • JY9516T_Coupling_AC : JY9516T.h
  • JY9516T_Coupling_DC : JY9516T.h
  • JY9516T_DeviceHandle : JY9516T.h
  • JY9516T_DigitalTriggerEdge : JY9516T.h
  • JY9516T_EnteringWindow : JY9516T.h
  • JY9516T_ExportSource_EndOfAcquisition : JY9516T.h
  • JY9516T_ExportSource_EndOfRecord : JY9516T.h
  • JY9516T_ExportSource_ReadyForTrig : JY9516T.h
  • JY9516T_ExportSource_SampleClock : JY9516T.h
  • JY9516T_ExportSource_SyncPulse : JY9516T.h
  • JY9516T_ExportSource_Trig : JY9516T.h
  • JY9516T_External_Trigger : JY9516T.h
  • JY9516T_Falling : JY9516T.h
  • JY9516T_FallingHysteresis : JY9516T.h
  • JY9516T_GetCapabilityDouble() : JY9516T.h
  • JY9516T_GetCapabilityDoubleByName() : JY9516T.h
  • JY9516T_GetCapabilityDoubleBySlotNumber() : JY9516T.h
  • JY9516T_GetCapabilityInt() : JY9516T.h
  • JY9516T_GetCapabilityIntByName() : JY9516T.h
  • JY9516T_GetCapabilityIntBySlotNumber() : JY9516T.h
  • JY9516T_GetDeviceInfo() : JY9516T.h
  • JY9516T_IdentifyTEDSChip() : JY9516T.h
  • JY9516T_IEPEConnection_Normal : JY9516T.h
  • JY9516T_IEPEConnection_Open : JY9516T.h
  • JY9516T_IEPEConnection_Short : JY9516T.h
  • JY9516T_IEPEConnectionStatus : JY9516T.h
  • JY9516T_IOTerminal : JY9516T.h
  • JY9516T_LeavingWindow : JY9516T.h
  • JY9516T_Onboard_10M : JY9516T.h
  • JY9516T_Open() : JY9516T.h
  • JY9516T_OpenByName() : JY9516T.h
  • JY9516T_PXI_Trig_0 : JY9516T.h
  • JY9516T_PXI_Trig_1 : JY9516T.h
  • JY9516T_PXI_Trig_2 : JY9516T.h
  • JY9516T_PXI_Trig_3 : JY9516T.h
  • JY9516T_PXI_Trig_4 : JY9516T.h
  • JY9516T_PXI_Trig_5 : JY9516T.h
  • JY9516T_PXI_Trig_6 : JY9516T.h
  • JY9516T_PXI_Trig_7 : JY9516T.h
  • JY9516T_PXIe_Clk_100M : JY9516T.h
  • JY9516T_Range_0p3125V : JY9516T.h
  • JY9516T_Range_0p625V : JY9516T.h
  • JY9516T_Range_10V : JY9516T.h
  • JY9516T_Range_1p25V : JY9516T.h
  • JY9516T_Range_2p5V : JY9516T.h
  • JY9516T_Range_5V : JY9516T.h
  • JY9516T_ReadTEDSData() : JY9516T.h
  • JY9516T_RefClockSource : JY9516T.h
  • JY9516T_Rising : JY9516T.h
  • JY9516T_RisingHysteresis : JY9516T.h
  • JY9516T_RxState : JY9516T.h
  • JY9516T_SyncMode : JY9516T.h
  • JY9516T_SyncMode_Master : JY9516T.h
  • JY9516T_SyncMode_Slave : JY9516T.h
  • JY9516T_SyncMode_Solo : JY9516T.h
  • JY9516T_Terminal_Differential : JY9516T.h
  • JY9516T_Terminal_Pseudodifferential : JY9516T.h

- r -

  • RxState_Done : JY9516T.h
  • RxState_Idle : JY9516T.h
  • RxState_PostSampling : JY9516T.h
  • RxState_PreSampling : JY9516T.h
  • RxState_WaitingForTrigger : JY9516T.h


9516T C++ Programming Manual: File Members

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
Here is a list of all enums with links to the files they belong to:
  • JY9516T_ADC_fChop_Div : JY9516T.h
  • JY9516T_AI_Capability_Item : JY9516T.h
  • JY9516T_AI_Coupling : JY9516T.h
  • JY9516T_AI_ExportSource : JY9516T.h
  • JY9516T_AI_LPFMode : JY9516T.h
  • JY9516T_AI_Range : JY9516T.h
  • JY9516T_AI_SampleMode : JY9516T.h
  • JY9516T_AI_Terminal : JY9516T.h
  • JY9516T_AI_TriggerType : JY9516T.h
  • JY9516T_AnalogTriggerCondition : JY9516T.h
  • JY9516T_DigitalTriggerEdge : JY9516T.h
  • JY9516T_IEPEConnectionStatus : JY9516T.h
  • JY9516T_IOTerminal : JY9516T.h
  • JY9516T_RefClockSource : JY9516T.h
  • JY9516T_RxState : JY9516T.h
  • JY9516T_SyncMode : JY9516T.h


9516T C++ Programming Manual: File Members

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • j
  • r
Here is a list of all enum values with links to the files they belong to:

- j -

  • JY9516T_ADC_fChop_32 : JY9516T.h
  • JY9516T_ADC_fChop_8 : JY9516T.h
  • JY9516T_AI_Analog : JY9516T.h
  • JY9516T_AI_Continuous : JY9516T.h
  • JY9516T_AI_Digital : JY9516T.h
  • JY9516T_AI_Finite : JY9516T.h
  • JY9516T_AI_Immediate : JY9516T.h
  • JY9516T_AI_LPF_LowLatency : JY9516T.h
  • JY9516T_AI_LPF_Normal : JY9516T.h
  • JY9516T_AI_LPF_WideBandwidth : JY9516T.h
  • JY9516T_AI_MaxSampleRate_Double : JY9516T.h
  • JY9516T_AI_MinSampleRate_Double : JY9516T.h
  • JY9516T_AI_NumberOfChannels_Int : JY9516T.h
  • JY9516T_AI_Single : JY9516T.h
  • JY9516T_AI_Software : JY9516T.h
  • JY9516T_Coupling_AC : JY9516T.h
  • JY9516T_Coupling_DC : JY9516T.h
  • JY9516T_EnteringWindow : JY9516T.h
  • JY9516T_ExportSource_EndOfAcquisition : JY9516T.h
  • JY9516T_ExportSource_EndOfRecord : JY9516T.h
  • JY9516T_ExportSource_ReadyForTrig : JY9516T.h
  • JY9516T_ExportSource_SampleClock : JY9516T.h
  • JY9516T_ExportSource_SyncPulse : JY9516T.h
  • JY9516T_ExportSource_Trig : JY9516T.h
  • JY9516T_External_Trigger : JY9516T.h
  • JY9516T_Falling : JY9516T.h
  • JY9516T_FallingHysteresis : JY9516T.h
  • JY9516T_IEPEConnection_Normal : JY9516T.h
  • JY9516T_IEPEConnection_Open : JY9516T.h
  • JY9516T_IEPEConnection_Short : JY9516T.h
  • JY9516T_LeavingWindow : JY9516T.h
  • JY9516T_Onboard_10M : JY9516T.h
  • JY9516T_PXI_Trig_0 : JY9516T.h
  • JY9516T_PXI_Trig_1 : JY9516T.h
  • JY9516T_PXI_Trig_2 : JY9516T.h
  • JY9516T_PXI_Trig_3 : JY9516T.h
  • JY9516T_PXI_Trig_4 : JY9516T.h
  • JY9516T_PXI_Trig_5 : JY9516T.h
  • JY9516T_PXI_Trig_6 : JY9516T.h
  • JY9516T_PXI_Trig_7 : JY9516T.h
  • JY9516T_PXIe_Clk_100M : JY9516T.h
  • JY9516T_Range_0p3125V : JY9516T.h
  • JY9516T_Range_0p625V : JY9516T.h
  • JY9516T_Range_10V : JY9516T.h
  • JY9516T_Range_1p25V : JY9516T.h
  • JY9516T_Range_2p5V : JY9516T.h
  • JY9516T_Range_5V : JY9516T.h
  • JY9516T_Rising : JY9516T.h
  • JY9516T_RisingHysteresis : JY9516T.h
  • JY9516T_SyncMode_Master : JY9516T.h
  • JY9516T_SyncMode_Slave : JY9516T.h
  • JY9516T_SyncMode_Solo : JY9516T.h
  • JY9516T_Terminal_Differential : JY9516T.h
  • JY9516T_Terminal_Pseudodifferential : JY9516T.h

- r -

  • RxState_Done : JY9516T.h
  • RxState_Idle : JY9516T.h
  • RxState_PostSampling : JY9516T.h
  • RxState_PreSampling : JY9516T.h
  • RxState_WaitingForTrigger : JY9516T.h


9516T C++ Programming Manual: File Members

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • j
Here is a list of all functions with links to the files they belong to:

- j -

  • JY9516T_AI_CheckBufferStatus() : JY9516T.h
  • JY9516T_AI_CheckRxStatus() : JY9516T.h
  • JY9516T_AI_CheckSyncStatus() : JY9516T.h
  • JY9516T_AI_Commit() : JY9516T.h
  • JY9516T_AI_ConfigADChoppingFrequency() : JY9516T.h
  • JY9516T_AI_ConfigHPF() : JY9516T.h
  • JY9516T_AI_ConfigSignalExport() : JY9516T.h
  • JY9516T_AI_ConfigSync() : JY9516T.h
  • JY9516T_AI_DetectIEPEConnection() : JY9516T.h
  • JY9516T_AI_DisableDCCalibration() : JY9516T.h
  • JY9516T_AI_DisableFlatnessCalibration() : JY9516T.h
  • JY9516T_AI_DisableLinerityCalibration() : JY9516T.h
  • JY9516T_AI_EnableChannel() : JY9516T.h
  • JY9516T_AI_GetCurrentClkFreq() : JY9516T.h
  • JY9516T_AI_ParseSampleRate() : JY9516T.h
  • JY9516T_AI_ReadData() : JY9516T.h
  • JY9516T_AI_ReadRawData() : JY9516T.h
  • JY9516T_AI_ReadSingleHeader() : JY9516T.h
  • JY9516T_AI_ReadSinglePoint() : JY9516T.h
  • JY9516T_AI_SendSoftwareTrigger() : JY9516T.h
  • JY9516T_AI_SetAnalogTrigger() : JY9516T.h
  • JY9516T_AI_SetDigitalTrigger() : JY9516T.h
  • JY9516T_AI_SetPreTriggerSamples() : JY9516T.h
  • JY9516T_AI_SetRefClkSrc() : JY9516T.h
  • JY9516T_AI_SetReTriggerCount() : JY9516T.h
  • JY9516T_AI_SetSampleMode() : JY9516T.h
  • JY9516T_AI_SetSampleRate() : JY9516T.h
  • JY9516T_AI_SetSamplesToAcquire() : JY9516T.h
  • JY9516T_AI_SetTriggerType() : JY9516T.h
  • JY9516T_AI_Start() : JY9516T.h
  • JY9516T_AI_Stop() : JY9516T.h
  • JY9516T_AI_Sync() : JY9516T.h
  • JY9516T_AI_WaitUntilDone() : JY9516T.h
  • JY9516T_Close() : JY9516T.h
  • JY9516T_GetCapabilityDouble() : JY9516T.h
  • JY9516T_GetCapabilityDoubleByName() : JY9516T.h
  • JY9516T_GetCapabilityDoubleBySlotNumber() : JY9516T.h
  • JY9516T_GetCapabilityInt() : JY9516T.h
  • JY9516T_GetCapabilityIntByName() : JY9516T.h
  • JY9516T_GetCapabilityIntBySlotNumber() : JY9516T.h
  • JY9516T_GetDeviceInfo() : JY9516T.h
  • JY9516T_IdentifyTEDSChip() : JY9516T.h
  • JY9516T_Open() : JY9516T.h
  • JY9516T_OpenByName() : JY9516T.h
  • JY9516T_ReadTEDSData() : JY9516T.h


9516T C++ Programming Manual: File Members

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
Here is a list of all typedefs with links to the files they belong to:
  • JY9516T_DeviceHandle : JY9516T.h


9516T C++ Programming Manual: Main Page

  • Files
9516T C++ Programming Manual Documentation