9516T C# Programming Manual: D:/OneDrive/Desktop/产品文档/CHM/9516T/C# Directory Reference

9516T C# Programming Manual

C# Directory Reference

Files

         AIChannel.cs
AIDigitalFiltering.cs
AIRecord.cs
AISignalExport.cs
AISync.cs
AITrigger.cs
JY9516TAITask.cs
ReferenceClock.cs
TEDSCommon.cs
Generated by doxygen 1.15.0


9516T C# Programming Manual: D:/OneDrive/Desktop/产品文档/CHM/9516T/C#/AIChannel.cs File Reference

Classes | Namespaces | Enumerations
AIChannel.cs File Reference

Classes

class | JY9516T.AIChannel
AI Channel. More...
class | JY9516T.EnumExtension
JY9516T Enum Extension.

Namespaces

namespace JY9516T

Enumerations

enum JY9516T.AIRange {
JY9516T._10V = JY9516TImport.JY9516T_Range_10V , JY9516T._5V = JY9516TImport.JY9516T_Range_5V , JY9516T._2p5V = JY9516TImport.JY9516T_Range_2p5V , JY9516T._1p25V = JY9516TImport.JY9516T_Range_1p25V ,
JY9516T._0p625V = JY9516TImport.JY9516T_Range_0p625V , JY9516T._0p3125V = JY9516TImport.JY9516T_Range_0p3125V
}
AI voltage range. More...
enum | JY9516T.Coupling { JY9516T.AC = JY9516TImport.JY9516T_Coupling_AC , JY9516T.DC = JY9516TImport.JY9516T_Coupling_DC }
Coupling. More...
enum | JY9516T.AITerminal { JY9516T.PseudoDifferential = 0 , JY9516T.Differential = 1 }
AI Terminal Configuration Enum. More...


9516T C# Programming Manual: JY9516T.AIChannel Class Reference

  • Main Page
  • Packages
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
  • JY9516T
  • AIChannel
Properties | List of all members
JY9516T.AIChannel Class Reference

AI Channel. More...

Properties

int | ID [get]
Channel ID.
double | RangeHigh [get]
Upper limit of range.
double | RangeLow [get]
Lower limit of range.
Coupling | Coupling [get]
Coupling.
bool | IEPEEnabled [get]
IEPE enabled.
AIRange | Range [get]
Input voltage range(grade).
AITerminal | Terminal [get]
Terminal.
double | RawDataScaleFactor [get]
This fator is used to convert RawData(binary) to Data(voltage in V).

Detailed Description

AI Channel.

Property Documentation

◆ Coupling

Coupling JY9516T.AIChannel.Coupling
get

Coupling.

◆ ID

int JY9516T.AIChannel.ID
get

Channel ID.

◆ IEPEEnabled

bool JY9516T.AIChannel.IEPEEnabled
get

IEPE enabled.

◆ Range

AIRange JY9516T.AIChannel.Range
get

Input voltage range(grade).

◆ RangeHigh

double JY9516T.AIChannel.RangeHigh
get

Upper limit of range.

◆ RangeLow

double JY9516T.AIChannel.RangeLow
get

Lower limit of range.

◆ RawDataScaleFactor

double JY9516T.AIChannel.RawDataScaleFactor
get

This fator is used to convert RawData(binary) to Data(voltage in V).

RawData * factor = Data

◆ Terminal

AITerminal JY9516T.AIChannel.Terminal
get

Terminal.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/9516T/C#/AIChannel.cs


9516T C# Programming Manual: JY9516T Namespace Reference

  • Packages
  • Classes
  • Files
  • Package List
  • Package Members
Namespaces | Classes | Enumerations
JY9516T Namespace Reference

Namespaces

namespace TEDS

Classes

class | AIChannel
AI Channel. More...
class | EnumExtension
JY9516T Enum Extension.
class | AIDigitalFiltering
AI Digital Filtering Connfiguration Class. More...
class | FlatnessCompensation
Flatness Compensation Parameters. More...
class | LowPassFilter
Low-Pass Filter Configuration Class. More...
class | HighPassFilter
High-Pass Filter Configuration Class. More...
class | AIRecord
AI Record Mode Configuration Class. More...
class | AISignalExport
AI Signal Export Class. More...
class | Sync
class | AIDigitalTrigger
AI Digital trigger params. More...
class | AIAnalogTrigger
AI Analog Trigger. More...
class | AIAnalogHysteresisComparator
AI Analog Hysteresis Comparator. More...
class | AIAnalogWindowComparator
AI Analog Window Comparator. More...
class | AIAnalogEdgeComparator
AI Analog Edge Comparator. More...
class | AITrigger
AI Trigger params. More...
class | JY9516TAITask
JY9516T AI Task. More...
class | ConversionStatus
ADC Convesion Status Class. More...
class | ExternalReferenceClock
class | ReferenceClock

Enumerations

enum AIRange {
_10V = JY9516TImport.JY9516T_Range_10V , _5V = JY9516TImport.JY9516T_Range_5V , _2p5V = JY9516TImport.JY9516T_Range_2p5V , _1p25V = JY9516TImport.JY9516T_Range_1p25V ,
_0p625V = JY9516TImport.JY9516T_Range_0p625V , _0p3125V = JY9516TImport.JY9516T_Range_0p3125V
}
AI voltage range. More...
enum | Coupling { AC = JY9516TImport.JY9516T_Coupling_AC , DC = JY9516TImport.JY9516T_Coupling_DC }
Coupling. More...
enum | AITerminal { PseudoDifferential = 0 , Differential = 1 }
AI Terminal Configuration Enum. More...
enum | ChoppingFrequency { fMod32 = JY9516TImport.JY9516T_ADCChopping_fMod32 , fMod8 = JY9516TImport.JY9517_ADCChopping_fMod8 }
Modulator Chopping Frequency Enum. More...
enum | LPFMode { Normal = 0 , WideBandwidth = 1 , LowLatency = 2 }
Low-Pass Filter Mode Enum. More...
enum | HPFOrder { OneOrder = 1 , TwoOrder = 2 }
High-pass filter order. More...
enum | FileFormat { Bin }
Record file format enum. More...
enum | RecordMode { Finite , Infinite }
Record mode enum. More...
enum AISignalExportSource {
SampleClock = JY9516TImport.JY9516T_ExportSource_SampleClock , Sync = JY9516TImport.JY9516T_ExportSource_SyncPulse , ReadyForStartTrigger = JY9516TImport.JY9516T_ExportSource_ReadyForTrig , StartTrigger = JY9516TImport.JY9516T_ExportSource_Trig ,
EndOfRecord = JY9516TImport.JY9516T_ExportSource_EndOfRecord , EndOfAcquisition = JY9516TImport.JY9516T_ExportSource_EndOfAcquisition
}
AI Signal Export Source Enum. More...
enum SignalExportDestination {
Ext_Trig = JY9516TImport.JY9516T_DigitalTriggerSource_External , PXI_Trig0 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_0 , PXI_Trig1 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_1 , PXI_Trig2 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_2 ,
PXI_Trig3 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_3 , PXI_Trig4 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_4 , PXI_Trig5 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_5 , PXI_Trig6 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_6 ,
PXI_Trig7 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_7
}
Signal Export Destination Enum. More...
enum | SyncTopology { Independent = JY9516TImport.JY9516T_SyncMode_Solo , Master = JY9516TImport.JY9516T_SyncMode_Master , Slave = JY9516TImport.JY9516T_SyncMode_Slave }
Multi-Device Sync Topology. More...
enum SyncTerminal {
Ext_Trig = JY9516TImport.JY9516T_DigitalTriggerSource_External , PXI_Trig0 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_0 , PXI_Trig1 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_1 , PXI_Trig2 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_2 ,
PXI_Trig3 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_3 , PXI_Trig4 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_4 , PXI_Trig5 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_5 , PXI_Trig6 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_6 ,
PXI_Trig7 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_7
}
AI digital trigger source enum type. More...
enum | SyncState { WaitingSync , Synchronized , Invalid }
Sync State. More...
enum | AITriggerMode { Start , Reference }
AI trigger mode enum type. More...
enum | AITriggerType { Immediate = JY9516TImport.JY9516T_TriggerType_Immediate , Digital = JY9516TImport.JY9516T_TriggerType_Digital , Software = JY9516TImport.JY9516T_TriggerType_Software , Analog = JY9516TImport.JY9516T_TriggerType_Analog }
AI trigger type enum type. More...
enum AIDigitalTriggerSource {
Ext_Trig = JY9516TImport.JY9516T_DigitalTriggerSource_External , PXI_Trig0 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_0 , PXI_Trig1 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_1 , PXI_Trig2 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_2 ,
PXI_Trig3 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_3 , PXI_Trig4 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_4 , PXI_Trig5 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_5 , PXI_Trig6 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_6 ,
PXI_Trig7 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_7
}
AI digital trigger source enum type. More...
enum | AIDigitalTriggerEdge { Rising = JY9516TImport.JY9516T_DigitalTriggerEdge_Rising , Falling = JY9516TImport.JY9516T_DigitalTriggerEdge_Falling }
AI digital trigger edge enum type. More...
enum AIAnalogTriggerSource {
Channel_0 , Channel_1 , Channel_2 , Channel_3 ,
Channel_4 , Channel_5 , Channel_6 , Channel_7 ,
Channel_8 , Channel_9 , Channel_10 , Channel_11 ,
Channel_12 , Channel_13 , Channel_14 , Channel_15
}
AI Analog Trigger Source. More...
enum | AIAnalogTriggerComparator { Edge , Hysteresis , Window }
AI Analog Trigger Comparator. More...
enum | AIAnalogTriggerEdge { Rising , Falling }
AI Analog Trigger Edge. More...
enum | AIAnalogWindowCondition { Entering , Leaving }
AI Analog Window Trigger Condition. More...
enum | AIMode { Finite = JY9516TImport.JY9516T_AI_Finite , Continuous = JY9516TImport.JY9516T_AI_Continuous , Single = JY9516TImport.JY9516T_AI_Single , Record = 3 }
AI mode enum type. More...
enum SamplingState {
Idle = 0 , PreSampling = 1 , WaitingForTrigger = 2 , PostSampling = 3 ,
Done = 4
}
Sampling State Enum. More...
enum | IEPEConnectionStatus { Normal = 0 , OpenCircuit = 1 , ShortCircuit = 2 }
IEPE Connection Status. More...
enum | ExternalReferenceClockTerminal { PXIe_Clk100 = JY9516TImport.JY9516T_PXIe_Clk_100M }
enum | ReferenceClockSource { Internal = 0 , External = 1 }

Enumeration Type Documentation

◆ AIAnalogTriggerComparator

enum JY9516T.AIAnalogTriggerComparator

AI Analog Trigger Comparator.

Enumerator
Edge | Edge Comparator.
Hysteresis | Hysteresis Comparator.
Window | Window Comparator.

◆ AIAnalogTriggerEdge

enum JY9516T.AIAnalogTriggerEdge

AI Analog Trigger Edge.

Enumerator
Rising | Rising.
Falling | Falling.

◆ AIAnalogTriggerSource

enum JY9516T.AIAnalogTriggerSource

AI Analog Trigger Source.

Enumerator
Channel_0 | Channel 0.
Channel_1 | Channel 1.
Channel_2 | Channel 2.
Channel_3 | Channel 3.
Channel_4 | Channel 4.
Channel_5 | Channel 5.
Channel_6 | Channel 6.
Channel_7 | Channel 7.
Channel_8 | Channel 8.
Channel_9 | Channel 9.
Channel_10 | Channel 10.
Channel_11 | Channel 11.
Channel_12 | Channel 12.
Channel_13 | Channel 13.
Channel_14 | Channel 14.
Channel_15 | Channel 15.

◆ AIAnalogWindowCondition

enum JY9516T.AIAnalogWindowCondition

AI Analog Window Trigger Condition.

Enumerator
Entering | Rising.
Leaving | Falling.

◆ AIDigitalTriggerEdge

enum JY9516T.AIDigitalTriggerEdge

AI digital trigger edge enum type.

Enumerator
Rising | Rising edge.
Falling | Falling edge.

◆ AIDigitalTriggerSource

enum JY9516T.AIDigitalTriggerSource

AI digital trigger source enum type.

Enumerator
Ext_Trig | External Trigger.
PXI_Trig0 | PXI Trigger 0.
PXI_Trig1 | PXI Trigger 1.
PXI_Trig2 | PXI Trigger 2.
PXI_Trig3 | PXI Trigger 3.
PXI_Trig4 | PXI Trigger 4.
PXI_Trig5 | PXI Trigger 5.
PXI_Trig6 | PXI Trigger 6.
PXI_Trig7 | PXI Trigger 7.

◆ AIMode

enum JY9516T.AIMode

AI mode enum type.

Enumerator
Finite | Finite mode.
Continuous | Continuous mode.
Single | Single point mode.
Record | Record mode.

◆ AIRange

enum JY9516T.AIRange

AI voltage range.

Enumerator
_10V | ±10V
_5V | ±5V
_2p5V | ±2.5V
_1p25V | ±1.25V
_0p625V | ±0.625V
_0p3125V | ±0.3125V

◆ AISignalExportSource

enum JY9516T.AISignalExportSource

AI Signal Export Source Enum.

Enumerator
SampleClock | AI Sample Clock.
Sync | Sync Signal from Master to Slave(s).
ReadyForStartTrigger | Ready for Trigger.
StartTrigger | Trigger Out.
EndOfRecord | End of Record.
EndOfAcquisition | End of Acquisition.

◆ AITerminal

enum JY9516T.AITerminal

AI Terminal Configuration Enum.

Enumerator
PseudoDifferential | Pseudo Differential.
Differential | Differential.

◆ AITriggerMode

enum JY9516T.AITriggerMode

AI trigger mode enum type.

Enumerator
Start | Start trigger.
Reference | Reference trigger. Only valid in the Finite mode.

◆ AITriggerType

enum JY9516T.AITriggerType

AI trigger type enum type.

Enumerator
Immediate | Immediately, no trigger.
Digital | Digital trigger.
Software | Software trigger.
Analog | Analog trigger.

◆ ChoppingFrequency

enum JY9516T.ChoppingFrequency

Modulator Chopping Frequency Enum.

Enumerator
fMod32 | Chop at fMod/32.
fMod8 | Chop at fMod/8. Default.

◆ Coupling

enum JY9516T.Coupling

Coupling.

Enumerator
AC | AC.
DC | DC.

◆ ExternalReferenceClockTerminal

enum JY9516T.ExternalReferenceClockTerminal

外部参考时钟输入端口

External Reference Clcok Terminal

Enumerator
PXIe_Clk100

PXIe_DStarA

PXIe_DStarA

◆ FileFormat

enum JY9516T.FileFormat

Record file format enum.

Enumerator
Bin

Binary file.

◆ HPFOrder

enum JY9516T.HPFOrder

High-pass filter order.

Enumerator
OneOrder | One-order.
TwoOrder | Two-order.

◆ IEPEConnectionStatus

enum JY9516T.IEPEConnectionStatus

IEPE Connection Status.

Enumerator
Normal | Normal.
OpenCircuit | Open circuit.
ShortCircuit | Short circuit.

◆ LPFMode

enum JY9516T.LPFMode

Low-Pass Filter Mode Enum.

Enumerator
Normal | Normal Mode. It has 0.4*fs bandwidth, medium latency, minimum sample rate of 62.5Sa/s, and maximum sample rate of 256kSa/s
WideBandwidth | Wide Bandwidth Mode. It has 0.4535*fs bandwidth, high latency, minimum sample rate of 62.5Sa/s, and maximum sample rate of 128kSa/s
LowLatency | Low Latency Mode. It has 0.1*fs bandwidth, low latency, minimum sample rate of 7.8125Sa/s, and maximum sample rate of 4kSa/s

◆ RecordMode

enum JY9516T.RecordMode

Record mode enum.

Enumerator
Finite | Finite Record.
Infinite | Infinite Record.

◆ ReferenceClockSource

enum JY9516T.ReferenceClockSource

Reference Clock Source

Enumerator
Internal | Internal Reference Clock
External | External Reference Clock

◆ SamplingState

enum JY9516T.SamplingState

Sampling State Enum.

Enumerator
Idle | Idle.
PreSampling | Pre-sampling.
WaitingForTrigger | Waiting for trigger.
PostSampling | Post-sampling.
Done | Done.

◆ SignalExportDestination

enum JY9516T.SignalExportDestination

Signal Export Destination Enum.

Enumerator
Ext_Trig | External Trigger.
PXI_Trig0 | PXI Trigger 0.
PXI_Trig1 | PXI Trigger 1.
PXI_Trig2 | PXI Trigger 2.
PXI_Trig3 | PXI Trigger 3.
PXI_Trig4 | PXI Trigger 4.
PXI_Trig5 | PXI Trigger 5.
PXI_Trig6 | PXI Trigger 6.
PXI_Trig7 | PXI Trigger 7.

◆ SyncState

enum JY9516T.SyncState

Sync State.

Enumerator
WaitingSync | Waiting for Sync signal as a Slave device.
Synchronized | Already received Sync signal as a Slave device.
Invalid | This status is invalid when multi-card synchronization is not enabled or when the device is a Master device.

◆ SyncTerminal

enum JY9516T.SyncTerminal

AI digital trigger source enum type.

Enumerator
Ext_Trig | External Trigger.
PXI_Trig0 | PXI Trigger 0.
PXI_Trig1 | PXI Trigger 1.
PXI_Trig2 | PXI Trigger 2.
PXI_Trig3 | PXI Trigger 3.
PXI_Trig4 | PXI Trigger 4.
PXI_Trig5 | PXI Trigger 5.
PXI_Trig6 | PXI Trigger 6.
PXI_Trig7 | PXI Trigger 7.

◆ SyncTopology

enum JY9516T.SyncTopology

Multi-Device Sync Topology.

Enumerator
Independent | Independent.
Master | As the master device in the master-slave synchronization.
Slave | As the slave card in the master-slave synchronization.


9516T C# Programming Manual: D:/OneDrive/Desktop/产品文档/CHM/9516T/C#/AIDigitalFiltering.cs File Reference

Classes | Namespaces | Enumerations
AIDigitalFiltering.cs File Reference

Classes

class | JY9516T.AIDigitalFiltering
AI Digital Filtering Connfiguration Class. More...
class | JY9516T.FlatnessCompensation
Flatness Compensation Parameters. More...
class | JY9516T.LowPassFilter
Low-Pass Filter Configuration Class. More...
class | JY9516T.HighPassFilter
High-Pass Filter Configuration Class. More...

Namespaces

namespace JY9516T

Enumerations

enum | JY9516T.ChoppingFrequency { JY9516T.fMod32 = JY9516TImport.JY9516T_ADCChopping_fMod32 , JY9516T.fMod8 = JY9516TImport.JY9517_ADCChopping_fMod8 }
Modulator Chopping Frequency Enum. More...
enum | JY9516T.LPFMode { JY9516T.Normal = 0 , JY9516T.WideBandwidth = 1 , JY9516T.LowLatency = 2 }
Low-Pass Filter Mode Enum. More...
enum | JY9516T.HPFOrder { JY9516T.OneOrder = 1 , JY9516T.TwoOrder = 2 }
High-pass filter order. More...


9516T C# Programming Manual: JY9516T.AIDigitalFiltering Class Reference

  • Class List
  • Class Index
  • Class Members
  • JY9516T
  • AIDigitalFiltering
Properties | List of all members
JY9516T.AIDigitalFiltering Class Referencesealed

AI Digital Filtering Connfiguration Class. More...

Properties

LowPassFilter | LPF [get]
Low-Pass Filter (or called Anti-Aliasing Filter) Parametes.
HighPassFilter | HPF [get]
High-Pass Filter Parameters.

Detailed Description

AI Digital Filtering Connfiguration Class.

Property Documentation

◆ HPF

HighPassFilter JY9516T.AIDigitalFiltering.HPF
get

High-Pass Filter Parameters.

◆ LPF

LowPassFilter JY9516T.AIDigitalFiltering.LPF
get

Low-Pass Filter (or called Anti-Aliasing Filter) Parametes.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/9516T/C#/AIDigitalFiltering.cs


9516T C# Programming Manual: JY9516T.FlatnessCompensation Class Reference

  • JY9516T
  • FlatnessCompensation
Properties | List of all members
JY9516T.FlatnessCompensation Class Referencesealed

Flatness Compensation Parameters. More...

Properties

bool Enabled [get, set]
Enabled.

Detailed Description

Flatness Compensation Parameters.

Property Documentation

◆ Enabled

bool JY9516T.FlatnessCompensation.Enabled
getset

Enabled.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/9516T/C#/AIDigitalFiltering.cs


9516T C# Programming Manual: JY9516T.LowPassFilter Class Reference

  • LowPassFilter
Properties | List of all members
JY9516T.LowPassFilter Class Referencesealed

Low-Pass Filter Configuration Class. More...

Properties

LPFMode Mode [get, set]
Low-Pass Filter Mode.

Detailed Description

Low-Pass Filter Configuration Class.

Property Documentation

◆ Mode

LPFMode JY9516T.LowPassFilter.Mode
getset

Low-Pass Filter Mode.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/9516T/C#/AIDigitalFiltering.cs


9516T C# Programming Manual: JY9516T.HighPassFilter Class Reference

  • HighPassFilter
Public Member Functions | Properties | List of all members
JY9516T.HighPassFilter Class Referencesealed

High-Pass Filter Configuration Class. More...

Public Member Functions

void | EnableChannel (int chID)
Enables the high-pass filter on the specified channel.
void | DisableChannel (int chID)
Disables the high-pass filter on the specified channel.

Properties

double | CutoffFrequency [get, set]
Cutoff Frequency in Hz.
HPFOrder | Order [get, set]
Filter Order.
List< int > | FilterEnabledChannels [get]
The channels that the filter has enabled.

Detailed Description

High-Pass Filter Configuration Class.

Member Function Documentation

◆ DisableChannel()

void JY9516T.HighPassFilter.DisableChannel ( int chID )

Disables the high-pass filter on the specified channel.

Parameters
chID

◆ EnableChannel()

void JY9516T.HighPassFilter.EnableChannel ( int chID )

Enables the high-pass filter on the specified channel.

Parameters
chID

Property Documentation

◆ CutoffFrequency

double JY9516T.HighPassFilter.CutoffFrequency
getset

Cutoff Frequency in Hz.

The max value is SampleRate * 1%. The attenuation at this frequency is -3dB when the filter is one-order, and -6dB when the filter is two-order.

◆ FilterEnabledChannels

List<int> JY9516T.HighPassFilter.FilterEnabledChannels
get

The channels that the filter has enabled.

◆ Order

HPFOrder JY9516T.HighPassFilter.Order
getset

Filter Order.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/9516T/C#/AIDigitalFiltering.cs


9516T C# Programming Manual: D:/OneDrive/Desktop/产品文档/CHM/9516T/C#/AIRecord.cs File Reference

Classes | Namespaces | Enumerations
AIRecord.cs File Reference

Classes

class JY9516T.AIRecord
AI Record Mode Configuration Class. More...

Namespaces

namespace JY9516T

Enumerations

enum | JY9516T.FileFormat { JY9516T.Bin }
Record file format enum. More...
enum | JY9516T.RecordMode { JY9516T.Finite , JY9516T.Infinite }
Record mode enum. More...


9516T C# Programming Manual: JY9516T.AIRecord Class Reference

  • AIRecord
Properties | List of all members
JY9516T.AIRecord Class Referencesealed

AI Record Mode Configuration Class. More...

Properties

string | FilePath [get, set]
The path of the data recording file (including the file name).
FileFormat | FileFormat [get]
Record file format.
RecordMode | Mode [get, set]
Record mode (Finite / Infinite).
double | Length [get, set]
User specified record length in second.

Detailed Description

AI Record Mode Configuration Class.

Property Documentation

◆ FileFormat

FileFormat JY9516T.AIRecord.FileFormat
get

Record file format.

◆ FilePath

string JY9516T.AIRecord.FilePath
getset

The path of the data recording file (including the file name).

◆ Length

double JY9516T.AIRecord.Length
getset

User specified record length in second.

Only valid in the Finite record mode.

◆ Mode

RecordMode JY9516T.AIRecord.Mode
getset

Record mode (Finite / Infinite).

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/9516T/C#/AIRecord.cs


9516T C# Programming Manual: D:/OneDrive/Desktop/产品文档/CHM/9516T/C#/AISignalExport.cs File Reference

Classes | Namespaces | Enumerations
AISignalExport.cs File Reference

Classes

class JY9516T.AISignalExport
AI Signal Export Class. More...

Namespaces

namespace JY9516T

Enumerations

enum JY9516T.AISignalExportSource {
JY9516T.SampleClock = JY9516TImport.JY9516T_ExportSource_SampleClock , JY9516T.Sync = JY9516TImport.JY9516T_ExportSource_SyncPulse , JY9516T.ReadyForStartTrigger = JY9516TImport.JY9516T_ExportSource_ReadyForTrig , JY9516T.StartTrigger = JY9516TImport.JY9516T_ExportSource_Trig ,
JY9516T.EndOfRecord = JY9516TImport.JY9516T_ExportSource_EndOfRecord , JY9516T.EndOfAcquisition = JY9516TImport.JY9516T_ExportSource_EndOfAcquisition
}
AI Signal Export Source Enum. More...
enum JY9516T.SignalExportDestination {
JY9516T.Ext_Trig = JY9516TImport.JY9516T_DigitalTriggerSource_External , JY9516T.PXI_Trig0 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_0 , JY9516T.PXI_Trig1 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_1 , JY9516T.PXI_Trig2 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_2 ,
JY9516T.PXI_Trig3 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_3 , JY9516T.PXI_Trig4 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_4 , JY9516T.PXI_Trig5 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_5 , JY9516T.PXI_Trig6 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_6 ,
JY9516T.PXI_Trig7 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_7
}
Signal Export Destination Enum. More...


9516T C# Programming Manual: JY9516T.AISignalExport Class Reference

  • AISignalExport
Public Member Functions | List of all members
JY9516T.AISignalExport Class Reference

AI Signal Export Class. More...

Public Member Functions

void | Add (AISignalExportSource source, SignalExportDestination destination)
Export one signal to desination.
void | Add (AISignalExportSource source, List< SignalExportDestination > destinations)
Export one signal to mutil desinations.
void | Clear (SignalExportDestination destination)
Clear one signal export.
void | ClearAll ()
Clear all signal export.

Detailed Description

AI Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JY9516T.AISignalExport.Add | ( | AISignalExportSource | source,
 |  | List< SignalExportDestination > | destinations )

Export one signal to mutil desinations.

Parameters
source | AI Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY9516T.AISignalExport.Add | ( | AISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one signal to desination.

Parameters
source | AI Signal Source
destination | Export Desination

◆ Clear()

void JY9516T.AISignalExport.Clear ( SignalExportDestination destination )

Clear one signal export.

Parameters
destination Export Desination

◆ ClearAll()

void JY9516T.AISignalExport.ClearAll ( )

Clear all signal export.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/9516T/C#/AISignalExport.cs


9516T C# Programming Manual: D:/OneDrive/Desktop/产品文档/CHM/9516T/C#/AISync.cs File Reference

Classes | Namespaces | Enumerations
AISync.cs File Reference

Classes

class JY9516T.Sync

Namespaces

namespace JY9516T

Enumerations

enum | JY9516T.SyncTopology { JY9516T.Independent = JY9516TImport.JY9516T_SyncMode_Solo , JY9516T.Master = JY9516TImport.JY9516T_SyncMode_Master , JY9516T.Slave = JY9516TImport.JY9516T_SyncMode_Slave }
Multi-Device Sync Topology. More...
enum JY9516T.SyncTerminal {
JY9516T.Ext_Trig = JY9516TImport.JY9516T_DigitalTriggerSource_External , JY9516T.PXI_Trig0 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_0 , JY9516T.PXI_Trig1 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_1 , JY9516T.PXI_Trig2 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_2 ,
JY9516T.PXI_Trig3 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_3 , JY9516T.PXI_Trig4 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_4 , JY9516T.PXI_Trig5 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_5 , JY9516T.PXI_Trig6 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_6 ,
JY9516T.PXI_Trig7 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_7
}
AI digital trigger source enum type. More...
enum | JY9516T.SyncState { JY9516T.WaitingSync , JY9516T.Synchronized , JY9516T.Invalid }
Sync State. More...


9516T C# Programming Manual: JY9516T.Sync Class Reference

  • Sync
Properties | List of all members
JY9516T.Sync Class Referencesealed

Properties

SyncTopology | Topology [get, set]
Sync Topology Configuration.
SyncTerminal | Terminal [get, set]
Sync Trigger Signal Routing Terminal.
SyncState | State [get]
Sync State.

Detailed Description

同步配置类

Sync Configuration Class

Property Documentation

◆ State

SyncState JY9516T.Sync.State
get

Sync State.

Only valid when this is a Slave device.

◆ Terminal

SyncTerminal JY9516T.Sync.Terminal
getset

Sync Trigger Signal Routing Terminal.

◆ Topology

SyncTopology JY9516T.Sync.Topology
getset

Sync Topology Configuration.

The default value is SyncTopology.Independent.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/9516T/C#/AISync.cs


9516T C# Programming Manual: D:/OneDrive/Desktop/产品文档/CHM/9516T/C#/AITrigger.cs File Reference

Classes | Namespaces | Enumerations
AITrigger.cs File Reference

Classes

class | JY9516T.AIDigitalTrigger
AI Digital trigger params. More...
class | JY9516T.AIAnalogTrigger
AI Analog Trigger. More...
class | JY9516T.AIAnalogHysteresisComparator
AI Analog Hysteresis Comparator. More...
class | JY9516T.AIAnalogWindowComparator
AI Analog Window Comparator. More...
class | JY9516T.AIAnalogEdgeComparator
AI Analog Edge Comparator. More...
class | JY9516T.AITrigger
AI Trigger params. More...

Namespaces

namespace JY9516T

Enumerations

enum | JY9516T.AITriggerMode { JY9516T.Start , JY9516T.Reference }
AI trigger mode enum type. More...
enum | JY9516T.AITriggerType { JY9516T.Immediate = JY9516TImport.JY9516T_TriggerType_Immediate , JY9516T.Digital = JY9516TImport.JY9516T_TriggerType_Digital , JY9516T.Software = JY9516TImport.JY9516T_TriggerType_Software , JY9516T.Analog = JY9516TImport.JY9516T_TriggerType_Analog }
AI trigger type enum type. More...
enum JY9516T.AIDigitalTriggerSource {
JY9516T.Ext_Trig = JY9516TImport.JY9516T_DigitalTriggerSource_External , JY9516T.PXI_Trig0 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_0 , JY9516T.PXI_Trig1 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_1 , JY9516T.PXI_Trig2 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_2 ,
JY9516T.PXI_Trig3 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_3 , JY9516T.PXI_Trig4 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_4 , JY9516T.PXI_Trig5 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_5 , JY9516T.PXI_Trig6 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_6 ,
JY9516T.PXI_Trig7 = JY9516TImport.JY9516T_DigitalTriggerSource_BUS_7
}
AI digital trigger source enum type. More...
enum | JY9516T.AIDigitalTriggerEdge { JY9516T.Rising = JY9516TImport.JY9516T_DigitalTriggerEdge_Rising , JY9516T.Falling = JY9516TImport.JY9516T_DigitalTriggerEdge_Falling }
AI digital trigger edge enum type. More...
enum JY9516T.AIAnalogTriggerSource {
JY9516T.Channel_0 , JY9516T.Channel_1 , JY9516T.Channel_2 , JY9516T.Channel_3 ,
JY9516T.Channel_4 , JY9516T.Channel_5 , JY9516T.Channel_6 , JY9516T.Channel_7 ,
JY9516T.Channel_8 , JY9516T.Channel_9 , JY9516T.Channel_10 , JY9516T.Channel_11 ,
JY9516T.Channel_12 , JY9516T.Channel_13 , JY9516T.Channel_14 , JY9516T.Channel_15
}
AI Analog Trigger Source. More...
enum | JY9516T.AIAnalogTriggerComparator { JY9516T.Edge , JY9516T.Hysteresis , JY9516T.Window }
AI Analog Trigger Comparator. More...
enum | JY9516T.AIAnalogTriggerEdge { JY9516T.Rising , JY9516T.Falling }
AI Analog Trigger Edge. More...
enum | JY9516T.AIAnalogWindowCondition { JY9516T.Entering , JY9516T.Leaving }
AI Analog Window Trigger Condition. More...


9516T C# Programming Manual: JY9516T.AIDigitalTrigger Class Reference

  • AIDigitalTrigger
Properties | List of all members
JY9516T.AIDigitalTrigger Class Referencesealed

AI Digital trigger params. More...

Properties

AIDigitalTriggerSource | Source [get, set]
AI digital trigger source.
AIDigitalTriggerEdge | Edge [get, set]
AI digital trigger effective edge.

Detailed Description

AI Digital trigger params.

Property Documentation

◆ Edge

AIDigitalTriggerEdge JY9516T.AIDigitalTrigger.Edge
getset

AI digital trigger effective edge.

◆ Source

AIDigitalTriggerSource JY9516T.AIDigitalTrigger.Source
getset

AI digital trigger source.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/9516T/C#/AITrigger.cs


9516T C# Programming Manual: JY9516T.AIAnalogTrigger Class Reference

  • AIAnalogTrigger
Properties | List of all members
JY9516T.AIAnalogTrigger Class Referencesealed

AI Analog Trigger. More...

Properties

AIAnalogTriggerSource | Source [get, set]
Analog Trigger source.
AIAnalogTriggerComparator | Comparator [get, set]
AI Analog Trigger Comparator.
AIAnalogEdgeComparator | Edge [get, set]
AI Analog Edge Comparator.
AIAnalogHysteresisComparator | Hysteresis [get, set]
AI Analog Hysteresis Comparatorr.
AIAnalogWindowComparator | Window [get, set]
AI Analog Window Comparatorr.

Detailed Description

AI Analog Trigger.

Property Documentation

◆ Comparator

AIAnalogTriggerComparator JY9516T.AIAnalogTrigger.Comparator
getset

AI Analog Trigger Comparator.

◆ Edge

AIAnalogEdgeComparator JY9516T.AIAnalogTrigger.Edge
getset

AI Analog Edge Comparator.

◆ Hysteresis

AIAnalogHysteresisComparator JY9516T.AIAnalogTrigger.Hysteresis
getset

AI Analog Hysteresis Comparatorr.

◆ Source

AIAnalogTriggerSource JY9516T.AIAnalogTrigger.Source
getset

Analog Trigger source.

◆ Window

AIAnalogWindowComparator JY9516T.AIAnalogTrigger.Window
getset

AI Analog Window Comparatorr.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/9516T/C#/AITrigger.cs


9516T C# Programming Manual: JY9516T.AIAnalogHysteresisComparator Class Reference

  • AIAnalogHysteresisComparator
Public Attributes | Properties | List of all members
JY9516T.AIAnalogHysteresisComparator Class Reference

AI Analog Hysteresis Comparator. More...

Public Attributes

double | HighThreshold
High Threshold.
double | LowThreshold
Low Threshold.

Properties

AIAnalogTriggerEdge Slope [get, set]
AI Analog Trigger Edge.

Detailed Description

AI Analog Hysteresis Comparator.

Member Data Documentation

◆ HighThreshold

double JY9516T.AIAnalogHysteresisComparator.HighThreshold

High Threshold.

◆ LowThreshold

double JY9516T.AIAnalogHysteresisComparator.LowThreshold

Low Threshold.

Property Documentation

◆ Slope

AIAnalogTriggerEdge JY9516T.AIAnalogHysteresisComparator.Slope
getset

AI Analog Trigger Edge.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/9516T/C#/AITrigger.cs


9516T C# Programming Manual: JY9516T.AIAnalogWindowComparator Class Reference

  • AIAnalogWindowComparator
Public Attributes | Properties | List of all members
JY9516T.AIAnalogWindowComparator Class Reference

AI Analog Window Comparator. More...

Public Attributes

double | HighThreshold
High Threshold.
double | LowThreshold
Low Threshold.

Properties

AIAnalogWindowCondition Condition [get, set]
AI Analog Window Condition.

Detailed Description

AI Analog Window Comparator.

Member Data Documentation

◆ HighThreshold

double JY9516T.AIAnalogWindowComparator.HighThreshold

High Threshold.

◆ LowThreshold

double JY9516T.AIAnalogWindowComparator.LowThreshold

Low Threshold.

Property Documentation

◆ Condition

AIAnalogWindowCondition JY9516T.AIAnalogWindowComparator.Condition
getset

AI Analog Window Condition.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/9516T/C#/AITrigger.cs


9516T C# Programming Manual: JY9516T.AIAnalogEdgeComparator Class Reference

  • AIAnalogEdgeComparator
Public Attributes | Properties | List of all members
JY9516T.AIAnalogEdgeComparator Class Reference

AI Analog Edge Comparator. More...

Public Attributes

double Threshold
Threshold.

Properties

AIAnalogTriggerEdge Slope [get, set]
AI Analog Trigger Edge.

Detailed Description

AI Analog Edge Comparator.

Member Data Documentation

◆ Threshold

double JY9516T.AIAnalogEdgeComparator.Threshold

Threshold.

Property Documentation

◆ Slope

AIAnalogTriggerEdge JY9516T.AIAnalogEdgeComparator.Slope
getset

AI Analog Trigger Edge.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/9516T/C#/AITrigger.cs


9516T C# Programming Manual: JY9516T.AITrigger Class Reference

  • AITrigger
Properties | List of all members
JY9516T.AITrigger Class Referencesealed

AI Trigger params. More...

Properties

AITriggerType | Type [get, set]
AI trigger type.
AITriggerMode | Mode [get, set]
AI trigger mode.
AIDigitalTrigger | Digital [get]
AI digital trigger params.
AIAnalogTrigger | Analog [get]
AI analog trigger params.
int | ReTriggerCount [get, set]
Number of repeat triggers.
uint | PreTriggerSamples [get, set]
AI pretrigger points.

Detailed Description

AI Trigger params.

Property Documentation

◆ Analog

AIAnalogTrigger JY9516T.AITrigger.Analog
get

AI analog trigger params.

◆ Digital

AIDigitalTrigger JY9516T.AITrigger.Digital
get

AI digital trigger params.

◆ Mode

AITriggerMode JY9516T.AITrigger.Mode
getset

AI trigger mode.

enum Start/Reference.

◆ PreTriggerSamples

uint JY9516T.AITrigger.PreTriggerSamples
getset

AI pretrigger points.

Only valid in the reference trigger mode.

◆ ReTriggerCount

int JY9516T.AITrigger.ReTriggerCount
getset

Number of repeat triggers.

No repeat the trigger when 0 or 1, or the number of repeated triggers.

◆ Type

AITriggerType JY9516T.AITrigger.Type
getset

AI trigger type.

enum Analog/Digital/Immediate/Soft.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/9516T/C#/AITrigger.cs


9516T C# Programming Manual: D:/OneDrive/Desktop/产品文档/CHM/9516T/C#/JY9516TAITask.cs File Reference

Classes | Namespaces | Enumerations
JY9516TAITask.cs File Reference

Classes

class | JY9516T.JY9516TAITask
JY9516T AI Task. More...
class | JY9516T.ConversionStatus
ADC Convesion Status Class. More...

Namespaces

namespace JY9516T

Enumerations

enum | JY9516T.AIMode { JY9516T.Finite = JY9516TImport.JY9516T_AI_Finite , JY9516T.Continuous = JY9516TImport.JY9516T_AI_Continuous , JY9516T.Single = JY9516TImport.JY9516T_AI_Single , JY9516T.Record = 3 }
AI mode enum type. More...
enum JY9516T.SamplingState {
JY9516T.Idle = 0 , JY9516T.PreSampling = 1 , JY9516T.WaitingForTrigger = 2 , JY9516T.PostSampling = 3 ,
JY9516T.Done = 4
}
Sampling State Enum. More...
enum | JY9516T.IEPEConnectionStatus { JY9516T.Normal = 0 , JY9516T.OpenCircuit = 1 , JY9516T.ShortCircuit = 2 }
IEPE Connection Status. More...


9516T C# Programming Manual: JY9516T.JY9516TAITask Class Reference

  • JY9516TAITask
Public Member Functions | Static Public Member Functions | Properties | List of all members
JY9516T.JY9516TAITask Class Reference

JY9516T AI Task. More...

Public Member Functions

JY9516TAITask (int slotNumber)
Create a AI task with slot number.
JY9516TAITask (string cardName)
Create a AI task with card name.
void | AddChannel (int chID, double rangeLow, double rangeHigh, AITerminal terminal, Coupling coupling, bool enableIEPE)
Add one/all channel(s).
void | AddChannel (int[] chIDs, double rangeLow, double rangeHigh, AITerminal terminal, Coupling coupling, bool enableIEPE)
Add a set of channels and set parameters uniformly.
void | AddChannel (int[] chIDs, double[] rangeLow, double[] rangeHigh, AITerminal[] terminal, Coupling[] coupling, bool[] enableIEPE)
Add a set of channels and set the parameters individually.
void | AddChannel (int chID, AIRange range, AITerminal terminal, Coupling coupling, bool enableIEPE)
Add one/all channel(s).
void | AddChannel (int[] chIDs, AIRange range, AITerminal terminal, Coupling coupling, bool enableIEPE)
Add a set of channels and set parameters uniformly.
void | AddChannel (int[] chIDs, AIRange[] range, AITerminal[] terminal, Coupling[] coupling, bool[] enableIEPE)
Add a set of channels and set parameters uniformly.
void | RemoveChannel (int chID)
Delete the channel with the specified channel ID.
void | RemoveChannel (int[] chIDs)
Delete a set of channels with the specified channel ID.
void | Commit ()
Commit current configuration.
void | Start ()
Start AI task.
void | Stop ()
Stop AI task.
void | StartSync ()
Start the multi-card synchronization process AGAIN.
void | ReadRawData (ref int[] dataBuf, int samplesPerChannel, int timeout)
Read raw data and copy to buffer.
void | ReadRawData (ref int[] dataBuf, int timeout=-1)
Read raw data and copy to buffer.
void | ReadRawData (ref int[,] dataBuf, int samplesPerChannel, int timeout)
Read raw data by columns and copy to buffer.
void | ReadRawData (IntPtr dataBuf, int samplesPerChannel, int timeout)
Read one or multi-channel raw data and copy to a unmannaged data buffer.
void | ReadData (ref double[] dataBuf, int samplesPerChannel, int timeout)
Read data and copy to buffer.
void | ReadData (ref double[] dataBuf, int timeout=-1)
Read data and copy to buffer.
void | ReadData (ref double[,] dataBuf, int samplesPerChannel, int timeout)
Read data by columns and copy to buffer.
void | ReadData (ref double[,] dataBuf, int timeout=-1)
Read data by columns and copy to buffer.
void | ReadData (IntPtr dataBuf, int samplesPerChannel, int timeout)
Read one or multi-channel data and copy to a unmannaged data buffer.
void | ReadSinglePoint (ref double[] dataBuf)
Read one sample (per channel) in unbuffered reading.
void | ReadSingleRawPoint (IntPtr dataBuf)
Read one sample (per channel) in unbuffered reading to unmannaged buffer.
ConversionStatus[] GetConversionStatus ()
Get ADC conversion status on all enabled channels.
void | GetRecordPreviewData (ref double[,] buf, int samplesPerChannel, int timeout=1000)
Get preview data of in Record mode.
void | GetRecordPreviewData (ref double[,] buf, int timeout=1000)
Get preview data of in Record mode.
void | GetRecordPreviewData (ref double[] buf, int samplesPerChannel, int timeout=1000)
Get preview data in Record mode.
void | GetRecordPreviewData (ref double[] buf, int timeout=1000)
Get preview data in Record mode.
void | GetRecordStatus (out double recordedLength, out bool recordDone)
Get the current status of the Record Mode.
void | SendSoftwareTrigger ()
Send a software trigger.
Dictionary< int, IEPEConnectionStatus > | DetectIEPEConnection ()
Perform IEPE sensor connection status detection.
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.
byte[] | ReadTEDSData (int chID)
Read binary TEDS data from TEDS sensor.
SamplingInfo | GetSamplingInfo ()
Get Sampling information, including sampling rate, low-pass filter mode, digital filter group delay, and several related parameters.

Static Public Member Functions

static SamplingInfo GetSamplingInfo (double sampleRate, LPFMode lpfMode)
Get Sampling information, including sampling rate, low-pass filter mode, digital filter group delay, and several related parameters.

Properties

JY9516TDevice | Device [get]
The device instance called by this AI task instance.
List< AIChannel > | Channels [get]
List of enabled channels.
AITrigger | Trigger [get]
AI trigger configuration.
AISignalExport | SignalExport [get]
Signal export configuration.
Sync | Sync [get]
Sync configuration.
AIDigitalFiltering | DigitalFiltering [get]
Digital filtering configuration.
AIMode | Mode [get, set]
Sample mode.
AIRecord | Record [get]
Data Record Mode Configuration.
double | SampleRate [get, set]
Sampling rate per channel in Sa/s.
int | SamplesToAcquire [get, set]
Samples to acquire.
SamplingState | State [get]
Sampling state.
UInt64 | AvailableSamples [get]
Number of samples per channel that can be read in the buffer.
UInt64 | TransferedSamples [get]
Number of points per channel that have already been read from the buffer.

Detailed Description

JY9516T AI Task.

Constructor & Destructor Documentation

◆ JY9516TAITask() [1/2]

JY9516T.JY9516TAITask.JY9516TAITask ( int slotNumber )

Create a AI task with slot number.

Parameters
slotNumber Slot Number

◆ JY9516TAITask() [2/2]

JY9516T.JY9516TAITask.JY9516TAITask ( string cardName )

Create a AI task with card name.

Parameters
cardName Card Name

Member Function Documentation

◆ AddChannel() [1/6]

void JY9516T.JY9516TAITask.AddChannel | ( | int | chID,
 |  | AIRange | range,
 |  | AITerminal | terminal,
 |  | Coupling | coupling,
 |  | bool | enableIEPE )

Add one/all channel(s).

Parameters
chID | Channel ID
range | Input Range.
terminal | Terminal configuration.
coupling | Coupling Type.
enableIEPE | IEPE Enabled.

◆ AddChannel() [2/6]

void JY9516T.JY9516TAITask.AddChannel | ( | int | chID,
 |  | double | rangeLow,
 |  | double | rangeHigh,
 |  | AITerminal | terminal,
 |  | Coupling | coupling,
 |  | bool | enableIEPE )

Add one/all channel(s).

Parameters
chID | Channel ID
rangeLow | Input Low Range. -10V/-5V/-2.5V/-1.25V/-0.625V/-0.3125V Optional.
rangeHigh | Input High Range. 10V/5V/2.5V/1.25V/0.625V/0.3125V Optional.
terminal | Terminal configuration.
coupling | Coupling Type.
enableIEPE | IEPE Enabled.

◆ AddChannel() [3/6]

void JY9516T.JY9516TAITask.AddChannel | ( | int[] | chIDs,
 |  | AIRange | range,
 |  | AITerminal | terminal,
 |  | Coupling | coupling,
 |  | bool | enableIEPE )

Add a set of channels and set parameters uniformly.

Parameters
chIDs | Channel ID
range | Input Range.
terminal | Terminal configuration.
coupling | Coupling Type.
enableIEPE | IEPE Enabled.

◆ AddChannel() [4/6]

void JY9516T.JY9516TAITask.AddChannel | ( | int[] | chIDs,
 |  | AIRange[] | range,
 |  | AITerminal[] | terminal,
 |  | Coupling[] | coupling,
 |  | bool[] | enableIEPE )

Add a set of channels and set parameters uniformly.

Parameters
chIDs | Channel ID
range | Input Range.
terminal | Terminal configuration.
coupling | Coupling Type.
enableIEPE | IEPE Enabled.

◆ AddChannel() [5/6]

void JY9516T.JY9516TAITask.AddChannel | ( | int[] | chIDs,
 |  | double | rangeLow,
 |  | double | rangeHigh,
 |  | AITerminal | terminal,
 |  | Coupling | coupling,
 |  | bool | enableIEPE )

Add a set of channels and set parameters uniformly.

Parameters
chIDs | Channel ID
rangeLow | Input Low Range. -10V/-5V/-2.5V/-1.25V/-0.625V/-0.3125V Optional.
rangeHigh | Input High Range. 10V/5V/2.5V/1.25V/0.625V/0.3125V Optional.
terminal | Terminal configuration.
coupling | Coupling Type.
enableIEPE | IEPE Enabled.

◆ AddChannel() [6/6]

void JY9516T.JY9516TAITask.AddChannel | ( | int[] | chIDs,
 |  | double[] | rangeLow,
 |  | double[] | rangeHigh,
 |  | AITerminal[] | terminal,
 |  | Coupling[] | coupling,
 |  | bool[] | enableIEPE )

Add a set of channels and set the parameters individually.

Parameters
chIDs | Channel ID
rangeLow | Input Low Range. -10V/-5V/-2.5V/-1.25V/-0.625V/-0.3125V Optional.
rangeHigh | Input High Range. 10V/5V/2.5V/1.25V/0.625V/0.3125V Optional.
terminal | Terminal configuration.
coupling | Coupling Type.
enableIEPE | IEPE Enabled.

◆ Commit()

void JY9516T.JY9516TAITask.Commit ( )

Commit current configuration.

For normal task, this method is optional. When using multi-device synchronization, this method must be called by slave devices, then called by the master device.

◆ DetectIEPEConnection()

Dictionary< int, IEPEConnectionStatus > JY9516T.JY9516TAITask.DetectIEPEConnection ( )

Perform IEPE sensor connection status detection.

After calling this method, the device will output the excitation current and measure the voltage, and if the voltage is too large, it will be judged as an open circuit, and if the voltage is too small, it will be judged as a short circuit.

Returns
IEPE connection status. Dictionary's key is channel's ID.

◆ GetConversionStatus()

ConversionStatus[] JY9516T.JY9516TAITask.GetConversionStatus ( )

Get ADC conversion status on all enabled channels.

Returns
ADC conversion status.

◆ GetRecordPreviewData() [1/4]

void JY9516T.JY9516TAITask.GetRecordPreviewData | ( | ref double | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout = 1000 )

Get preview data of in Record mode.

Parameters
buf | User buffer used to get multi-channel preview data. Each channel's data occupies one column in the array.
samplesPerChannel | Number of samples per channel.
timeout | Timeout in ms before generate tiemout exception.

◆ GetRecordPreviewData() [2/4]

void JY9516T.JY9516TAITask.GetRecordPreviewData | ( | ref double | buf[,],
 |  | int | timeout = 1000 )

Get preview data of in Record mode.

Parameters
buf | User buffer used to get multi-channel preview data. Each channel's data occupies one column in the array.
timeout | Timeout in ms before generate tiemout exception.

◆ GetRecordPreviewData() [3/4]

void JY9516T.JY9516TAITask.GetRecordPreviewData | ( | ref double[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 1000 )

Get preview data in Record mode.

Parameters
buf | User buffer used to get preview data. The data of each channel is interleaved in the array.
samplesPerChannel | Number of samples per channel.
timeout | Timeout in ms before generate tiemout exception.

◆ GetRecordPreviewData() [4/4]

void JY9516T.JY9516TAITask.GetRecordPreviewData | ( | ref double[] | buf,
 |  | int | timeout = 1000 )

Get preview data in Record mode.

Parameters
buf | User buffer used to get preview data. The data of each channel is interleaved in the array.
timeout | Timeout in ms before generate tiemout exception.

◆ GetRecordStatus()

void JY9516T.JY9516TAITask.GetRecordStatus | ( | out double | recordedLength,
 |  | out bool | recordDone )

Get the current status of the Record Mode.

Parameters
recordedLength | The length of the recorded data (already written to the file) in seconds.
recordDone | Whether the record has been completed. Only valid when Record.Mode is Finite.

◆ GetSamplingInfo() [1/2]

SamplingInfo JY9516T.JY9516TAITask.GetSamplingInfo ( )

Get Sampling information, including sampling rate, low-pass filter mode, digital filter group delay, and several related parameters.

Returns
Sampling infomation

◆ GetSamplingInfo() [2/2]

SamplingInfo JY9516T.JY9516TAITask.GetSamplingInfo | ( | double | sampleRate,
 |  | LPFMode | lpfMode )
 static

Get Sampling information, including sampling rate, low-pass filter mode, digital filter group delay, and several related parameters.

Parameters
sampleRate | Sample rate in Sa/s
lpfMode | Low-pass filter mode
Returns
>Sampling infomation

◆ ReadData() [1/5]

void JY9516T.JY9516TAITask.ReadData | ( | IntPtr | dataBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read one or multi-channel data and copy to a unmannaged data buffer.

Parameters
dataBuf | User buffer used to read data.
samplesPerChannel | Number of samples per channel.
timeout | Timeout in ms before generate tiemout exception, timeout =-1 keep waiting until finish.

◆ ReadData() [2/5]

void JY9516T.JY9516TAITask.ReadData | ( | ref double | dataBuf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read data by columns and copy to buffer.

Parameters
dataBuf | User buffer used to read data.
samplesPerChannel | Number of samples per channel.
timeout | Timeout in ms before generate tiemout exception, timeout =-1 keep waiting until finish.

◆ ReadData() [3/5]

void JY9516T.JY9516TAITask.ReadData | ( | ref double | dataBuf[,],
 |  | int | timeout = -1 )

Read data by columns and copy to buffer.

Parameters
dataBuf | User buffer used to read data.
timeout | Timeout in ms before generate tiemout exception, timeout =-1 keep waiting until finish.

◆ ReadData() [4/5]

void JY9516T.JY9516TAITask.ReadData | ( | ref double[] | dataBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read data and copy to buffer.

Parameters
dataBuf | User buffer used to read data.
samplesPerChannel | Number of samples per channel.
timeout | Timeout in ms before generate tiemout exception, timeout =-1 keep waiting until finish.

◆ ReadData() [5/5]

void JY9516T.JY9516TAITask.ReadData | ( | ref double[] | dataBuf,
 |  | int | timeout = -1 )

Read data and copy to buffer.

Parameters
dataBuf | User buffer used to read data.
timeout | Timeout in ms before generate tiemout exception, timeout =-1 keep waiting until finish.

◆ ReadRawData() [1/4]

void JY9516T.JY9516TAITask.ReadRawData | ( | IntPtr | dataBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read one or multi-channel raw data and copy to a unmannaged data buffer.

Parameters
dataBuf | User buffer used to read data.
samplesPerChannel | Number of samples per channel.
timeout | Timeout in ms before generate tiemout exception, timeout =-1 keep waiting until finish.

◆ ReadRawData() [2/4]

void JY9516T.JY9516TAITask.ReadRawData | ( | ref int | dataBuf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read raw data by columns and copy to buffer.

Parameters
dataBuf | User buffer used to read raw data.
samplesPerChannel | Number of samples per channel.
timeout | Timeout in ms before generate tiemout exception, timeout =-1 keep waiting until finish.

◆ ReadRawData() [3/4]

void JY9516T.JY9516TAITask.ReadRawData | ( | ref int[] | dataBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read raw data and copy to buffer.

Parameters
dataBuf | User buffer used to read raw data.
samplesPerChannel | Number of samples per channel.
timeout | Timeout in ms before generate tiemout exception, timeout = -1 keep waiting until finish.

◆ ReadRawData() [4/4]

void JY9516T.JY9516TAITask.ReadRawData | ( | ref int[] | dataBuf,
 |  | int | timeout = -1 )

Read raw data and copy to buffer.

Parameters
dataBuf | User buffer used to read raw data.
timeout | Timeout in ms before generate tiemout exception, timeout =-1 keep waiting until finish.

◆ ReadSinglePoint()

void JY9516T.JY9516TAITask.ReadSinglePoint ( ref double[] dataBuf )

Read one sample (per channel) in unbuffered reading.

Parameters
dataBuf User buffer.

◆ ReadSingleRawPoint()

void JY9516T.JY9516TAITask.ReadSingleRawPoint ( IntPtr dataBuf )

Read one sample (per channel) in unbuffered reading to unmannaged buffer.

Parameters
dataBuf User buffer.

◆ ReadTEDSData()

byte[] JY9516T.JY9516TAITask.ReadTEDSData ( int chID )

Read binary TEDS data from TEDS sensor.

Parameters
chID ID of the channel to which the TEDS sensor connects
Returns
Binary TEDS data. The first byte of every 32 bytes is a checksum

◆ RemoveChannel() [1/2]

void JY9516T.JY9516TAITask.RemoveChannel ( int chID )

Delete the channel with the specified channel ID.

Parameters
chID Specified channel ID. chnId = -1: remove all channels.

◆ RemoveChannel() [2/2]

void JY9516T.JY9516TAITask.RemoveChannel ( int[] chIDs )

Delete a set of channels with the specified channel ID.

Parameters
chIDs Specified channels' ID.

◆ SendSoftwareTrigger()

void JY9516T.JY9516TAITask.SendSoftwareTrigger ( )

Send a software trigger.

Returns

◆ Start()

void JY9516T.JY9516TAITask.Start ( )

Start AI task.

◆ StartSync()

void JY9516T.JY9516TAITask.StartSync ( )

Start the multi-card synchronization process AGAIN.

This method must be called by slave devices, then called by ther master device.

◆ Stop()

void JY9516T.JY9516TAITask.Stop ( )

Stop AI task.

◆ WaitUntilDone()

bool JY9516T.JY9516TAITask.WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Only valid when Mode is AIMode.Finite.

Parameters
timeout Wait timeout in ms, or never times out when value is -1.
Returns
Whether the task has been completed

Property Documentation

◆ AvailableSamples

UInt64 JY9516T.JY9516TAITask.AvailableSamples
get

Number of samples per channel that can be read in the buffer.

◆ Channels

List<AIChannel> JY9516T.JY9516TAITask.Channels
get

List of enabled channels.

◆ Device

JY9516TDevice JY9516T.JY9516TAITask.Device
get

The device instance called by this AI task instance.

◆ DigitalFiltering

AIDigitalFiltering JY9516T.JY9516TAITask.DigitalFiltering
get

Digital filtering configuration.

◆ Mode

AIMode JY9516T.JY9516TAITask.Mode
getset

Sample mode.

◆ Record

AIRecord JY9516T.JY9516TAITask.Record
get

Data Record Mode Configuration.

◆ SampleRate

double JY9516T.JY9516TAITask.SampleRate
getset

Sampling rate per channel in Sa/s.

◆ SamplesToAcquire

int JY9516T.JY9516TAITask.SamplesToAcquire
getset

Samples to acquire.

◆ SignalExport

AISignalExport JY9516T.JY9516TAITask.SignalExport
get

Signal export configuration.

◆ State

SamplingState JY9516T.JY9516TAITask.State
get

Sampling state.

◆ Sync

Sync JY9516T.JY9516TAITask.Sync
get

Sync configuration.

◆ TransferedSamples

UInt64 JY9516T.JY9516TAITask.TransferedSamples
get

Number of points per channel that have already been read from the buffer.

◆ Trigger

AITrigger JY9516T.JY9516TAITask.Trigger
get

AI trigger configuration.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/9516T/C#/JY9516TAITask.cs


9516T C# Programming Manual: JY9516T.ConversionStatus Class Reference

  • ConversionStatus
Properties | List of all members
JY9516T.ConversionStatus Class Reference

ADC Convesion Status Class. More...

Properties

bool | ErrorFlagged [get]
The error flagged bit indicates that a serious error has occurred.
bool | CRCError [get]
CRC not match.
bool | FilterSuturated [get]
The filter saturated bit indicates that the filter output is clipping at either positive or negative full scale.
int | ChannelID [get]
The channel ID bits indicate the ADC channel from which the succeeding conversion status originates.

Detailed Description

ADC Convesion Status Class.

Property Documentation

◆ ChannelID

int JY9516T.ConversionStatus.ChannelID
get

The channel ID bits indicate the ADC channel from which the succeeding conversion status originates.

◆ CRCError

bool JY9516T.ConversionStatus.CRCError
get

CRC not match.

◆ ErrorFlagged

bool JY9516T.ConversionStatus.ErrorFlagged
get

The error flagged bit indicates that a serious error has occurred.

This bit indicatesthat the external clock is not detected, a memory map bit has unexpectedly changed state, or an internal CRC error has been detected.

◆ FilterSuturated

bool JY9516T.ConversionStatus.FilterSuturated
get

The filter saturated bit indicates that the filter output is clipping at either positive or negative full scale.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/9516T/C#/JY9516TAITask.cs


9516T C# Programming Manual: D:/OneDrive/Desktop/产品文档/CHM/9516T/C#/ReferenceClock.cs File Reference

Classes | Namespaces | Enumerations
ReferenceClock.cs File Reference

Classes

class | JY9516T.ExternalReferenceClock
class | JY9516T.ReferenceClock

Namespaces

namespace JY9516T

Enumerations

enum | JY9516T.ExternalReferenceClockTerminal { JY9516T.PXIe_Clk100 = JY9516TImport.JY9516T_PXIe_Clk_100M }
enum | JY9516T.ReferenceClockSource { JY9516T.Internal = 0 , JY9516T.External = 1 }


9516T C# Programming Manual: JY9516T.ExternalReferenceClock Class Reference

  • ExternalReferenceClock
Properties | List of all members
JY9516T.ExternalReferenceClock Class Referencesealed

Properties

ExternalReferenceClockTerminal | Terminal [get, set]
int | Frequency [get, set]

Detailed Description

外部参考时钟配置类

External Reference Clcok Configuration Class

Property Documentation

◆ Frequency

int JY9516T.ExternalReferenceClock.Frequency
getset

外部参考时钟频率

Frequency of External Reference Clcok

◆ Terminal

ExternalReferenceClockTerminal JY9516T.ExternalReferenceClock.Terminal
getset

外部参考时钟输入端口

External Reference Clcok Input Terminal

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/9516T/C#/ReferenceClock.cs


9516T C# Programming Manual: JY9516T.ReferenceClock Class Reference

  • ReferenceClock
Properties | List of all members
JY9516T.ReferenceClock Class Referencesealed

Properties

ReferenceClockSource | Source [get, set]
ExternalReferenceClock | External [get]

Detailed Description

参考时钟配置类

Reference Clcok Configuration Class

Property Documentation

◆ External

ExternalReferenceClock JY9516T.ReferenceClock.External
get

外部参考时钟源配置。当 ReferenceClock.Source 选择为 ReferenceClockSource.External 时需要配置

External Reference Clock Source. Required when ReferenceClock.Source is ReferenceClockSource.External.

◆ Source

ReferenceClockSource JY9516T.ReferenceClock.Source
getset

Reference Clock Source. The default value is ReferenceClockSource.Internal.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/9516T/C#/ReferenceClock.cs


9516T C# Programming Manual: D:/OneDrive/Desktop/产品文档/CHM/9516T/C#/TEDSCommon.cs File Reference

Classes | Namespaces
TEDSCommon.cs File Reference

Classes

class | JY9516T.TEDS.TEDSUtilities
class | JY9516T.TEDS.TEDSChipInfo

Namespaces

namespace | JY9516T
namespace | JY9516T.TEDS


9516T C# Programming Manual: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
N JY9516T |
C AIChannel | AI Channel
C AIDigitalFiltering | AI Digital Filtering Connfiguration Class
C FlatnessCompensation | Flatness Compensation Parameters
C LowPassFilter | Low-Pass Filter Configuration Class
C HighPassFilter | High-Pass Filter Configuration Class
C AIRecord | AI Record Mode Configuration Class
C AISignalExport | AI Signal Export Class
C Sync |
C AIDigitalTrigger | AI Digital trigger params
C AIAnalogTrigger | AI Analog Trigger
C AIAnalogHysteresisComparator | AI Analog Hysteresis Comparator
C AIAnalogWindowComparator | AI Analog Window Comparator
C AIAnalogEdgeComparator | AI Analog Edge Comparator
C AITrigger | AI Trigger params
C JY9516TAITask | JY9516T AI Task
C ConversionStatus | ADC Convesion Status Class
C ExternalReferenceClock |
C ReferenceClock |


9516T C# Programming Manual: Member List

  • AIAnalogEdgeComparator
JY9516T.AIAnalogEdgeComparator Member List

This is the complete list of members for JY9516T.AIAnalogEdgeComparator, including all inherited members.

Slope | JY9516T.AIAnalogEdgeComparator
Threshold | JY9516T.AIAnalogEdgeComparator


9516T C# Programming Manual: Member List

  • AIAnalogHysteresisComparator
JY9516T.AIAnalogHysteresisComparator Member List

This is the complete list of members for JY9516T.AIAnalogHysteresisComparator, including all inherited members.

HighThreshold | JY9516T.AIAnalogHysteresisComparator
LowThreshold | JY9516T.AIAnalogHysteresisComparator
Slope | JY9516T.AIAnalogHysteresisComparator


9516T C# Programming Manual: Member List

  • AIAnalogTrigger
JY9516T.AIAnalogTrigger Member List

This is the complete list of members for JY9516T.AIAnalogTrigger, including all inherited members.

Comparator | JY9516T.AIAnalogTrigger
Edge | JY9516T.AIAnalogTrigger
Hysteresis | JY9516T.AIAnalogTrigger
Source | JY9516T.AIAnalogTrigger
Window | JY9516T.AIAnalogTrigger


9516T C# Programming Manual: Member List

  • AIAnalogWindowComparator
JY9516T.AIAnalogWindowComparator Member List

This is the complete list of members for JY9516T.AIAnalogWindowComparator, including all inherited members.

Condition | JY9516T.AIAnalogWindowComparator
HighThreshold | JY9516T.AIAnalogWindowComparator
LowThreshold | JY9516T.AIAnalogWindowComparator


9516T C# Programming Manual: Member List

  • AIChannel
JY9516T.AIChannel Member List

This is the complete list of members for JY9516T.AIChannel, including all inherited members.

Coupling | JY9516T.AIChannel
ID | JY9516T.AIChannel
IEPEEnabled | JY9516T.AIChannel
Range | JY9516T.AIChannel
RangeHigh | JY9516T.AIChannel
RangeLow | JY9516T.AIChannel
RawDataScaleFactor | JY9516T.AIChannel
Terminal | JY9516T.AIChannel


9516T C# Programming Manual: Member List

  • AIDigitalFiltering
JY9516T.AIDigitalFiltering Member List

This is the complete list of members for JY9516T.AIDigitalFiltering, including all inherited members.

HPF | JY9516T.AIDigitalFiltering
LPF | JY9516T.AIDigitalFiltering


9516T C# Programming Manual: Member List

  • AIDigitalTrigger
JY9516T.AIDigitalTrigger Member List

This is the complete list of members for JY9516T.AIDigitalTrigger, including all inherited members.

Edge | JY9516T.AIDigitalTrigger
Source | JY9516T.AIDigitalTrigger


9516T C# Programming Manual: Member List

  • AIRecord
JY9516T.AIRecord Member List

This is the complete list of members for JY9516T.AIRecord, including all inherited members.

FileFormat | JY9516T.AIRecord
FilePath | JY9516T.AIRecord
Length | JY9516T.AIRecord
Mode | JY9516T.AIRecord


9516T C# Programming Manual: Member List

  • AISignalExport
JY9516T.AISignalExport Member List

This is the complete list of members for JY9516T.AISignalExport, including all inherited members.

Add(AISignalExportSource source, SignalExportDestination destination) | JY9516T.AISignalExport
Add(AISignalExportSource source, List< SignalExportDestination > destinations) | JY9516T.AISignalExport
Clear(SignalExportDestination destination) | JY9516T.AISignalExport
ClearAll() | JY9516T.AISignalExport


9516T C# Programming Manual: Member List

  • AITrigger
JY9516T.AITrigger Member List

This is the complete list of members for JY9516T.AITrigger, including all inherited members.

Analog | JY9516T.AITrigger
Digital | JY9516T.AITrigger
Mode | JY9516T.AITrigger
PreTriggerSamples | JY9516T.AITrigger
ReTriggerCount | JY9516T.AITrigger
Type | JY9516T.AITrigger


9516T C# Programming Manual: Member List

  • ConversionStatus
JY9516T.ConversionStatus Member List

This is the complete list of members for JY9516T.ConversionStatus, including all inherited members.

ChannelID | JY9516T.ConversionStatus
CRCError | JY9516T.ConversionStatus
ErrorFlagged | JY9516T.ConversionStatus
FilterSuturated | JY9516T.ConversionStatus


9516T C# Programming Manual: Member List

  • ExternalReferenceClock
JY9516T.ExternalReferenceClock Member List

This is the complete list of members for JY9516T.ExternalReferenceClock, including all inherited members.

Frequency | JY9516T.ExternalReferenceClock
Terminal | JY9516T.ExternalReferenceClock


9516T C# Programming Manual: Member List

  • FlatnessCompensation
JY9516T.FlatnessCompensation Member List

This is the complete list of members for JY9516T.FlatnessCompensation, including all inherited members.

Enabled JY9516T.FlatnessCompensation


9516T C# Programming Manual: Member List

  • HighPassFilter
JY9516T.HighPassFilter Member List

This is the complete list of members for JY9516T.HighPassFilter, including all inherited members.

CutoffFrequency | JY9516T.HighPassFilter
DisableChannel(int chID) | JY9516T.HighPassFilter
EnableChannel(int chID) | JY9516T.HighPassFilter
FilterEnabledChannels | JY9516T.HighPassFilter
Order | JY9516T.HighPassFilter


9516T C# Programming Manual: Member List

  • JY9516TAITask
JY9516T.JY9516TAITask Member List

This is the complete list of members for JY9516T.JY9516TAITask, including all inherited members.

AddChannel(int chID, double rangeLow, double rangeHigh, AITerminal terminal, Coupling coupling, bool enableIEPE) | JY9516T.JY9516TAITask |
AddChannel(int[] chIDs, double rangeLow, double rangeHigh, AITerminal terminal, Coupling coupling, bool enableIEPE) | JY9516T.JY9516TAITask |
AddChannel(int[] chIDs, double[] rangeLow, double[] rangeHigh, AITerminal[] terminal, Coupling[] coupling, bool[] enableIEPE) | JY9516T.JY9516TAITask |
AddChannel(int chID, AIRange range, AITerminal terminal, Coupling coupling, bool enableIEPE) | JY9516T.JY9516TAITask |
AddChannel(int[] chIDs, AIRange range, AITerminal terminal, Coupling coupling, bool enableIEPE) | JY9516T.JY9516TAITask |
AddChannel(int[] chIDs, AIRange[] range, AITerminal[] terminal, Coupling[] coupling, bool[] enableIEPE) | JY9516T.JY9516TAITask |
AvailableSamples | JY9516T.JY9516TAITask |
Channels | JY9516T.JY9516TAITask |
Commit() | JY9516T.JY9516TAITask |
DetectIEPEConnection() | JY9516T.JY9516TAITask |
Device | JY9516T.JY9516TAITask |
DigitalFiltering | JY9516T.JY9516TAITask |
GetConversionStatus() | JY9516T.JY9516TAITask |
GetRecordPreviewData(ref double[,] buf, int samplesPerChannel, int timeout=1000) | JY9516T.JY9516TAITask |
GetRecordPreviewData(ref double[,] buf, int timeout=1000) | JY9516T.JY9516TAITask |
GetRecordPreviewData(ref double[] buf, int samplesPerChannel, int timeout=1000) | JY9516T.JY9516TAITask |
GetRecordPreviewData(ref double[] buf, int timeout=1000) | JY9516T.JY9516TAITask |
GetRecordStatus(out double recordedLength, out bool recordDone) | JY9516T.JY9516TAITask |
GetSamplingInfo() | JY9516T.JY9516TAITask |
GetSamplingInfo(double sampleRate, LPFMode lpfMode) | JY9516T.JY9516TAITask | static
JY9516TAITask(int slotNumber) | JY9516T.JY9516TAITask |
JY9516TAITask(string cardName) | JY9516T.JY9516TAITask |
Mode | JY9516T.JY9516TAITask |
ReadData(ref double[] dataBuf, int samplesPerChannel, int timeout) | JY9516T.JY9516TAITask |
ReadData(ref double[] dataBuf, int timeout=-1) | JY9516T.JY9516TAITask |
ReadData(ref double[,] dataBuf, int samplesPerChannel, int timeout) | JY9516T.JY9516TAITask |
ReadData(ref double[,] dataBuf, int timeout=-1) | JY9516T.JY9516TAITask |
ReadData(IntPtr dataBuf, int samplesPerChannel, int timeout) | JY9516T.JY9516TAITask |
ReadRawData(ref int[] dataBuf, int samplesPerChannel, int timeout) | JY9516T.JY9516TAITask |
ReadRawData(ref int[] dataBuf, int timeout=-1) | JY9516T.JY9516TAITask |
ReadRawData(ref int[,] dataBuf, int samplesPerChannel, int timeout) | JY9516T.JY9516TAITask |
ReadRawData(IntPtr dataBuf, int samplesPerChannel, int timeout) | JY9516T.JY9516TAITask |
ReadSinglePoint(ref double[] dataBuf) | JY9516T.JY9516TAITask |
ReadSingleRawPoint(IntPtr dataBuf) | JY9516T.JY9516TAITask |
ReadTEDSData(int chID) | JY9516T.JY9516TAITask |
Record | JY9516T.JY9516TAITask |
RemoveChannel(int chID) | JY9516T.JY9516TAITask |
RemoveChannel(int[] chIDs) | JY9516T.JY9516TAITask |
SampleRate | JY9516T.JY9516TAITask |
SamplesToAcquire | JY9516T.JY9516TAITask |
SendSoftwareTrigger() | JY9516T.JY9516TAITask |
SignalExport | JY9516T.JY9516TAITask |
Start() | JY9516T.JY9516TAITask |
StartSync() | JY9516T.JY9516TAITask |
State | JY9516T.JY9516TAITask |
Stop() | JY9516T.JY9516TAITask |
Sync | JY9516T.JY9516TAITask |
TransferedSamples | JY9516T.JY9516TAITask |
Trigger | JY9516T.JY9516TAITask |
WaitUntilDone(int timeout=-1) | JY9516T.JY9516TAITask |


9516T C# Programming Manual: Member List

  • LowPassFilter
JY9516T.LowPassFilter Member List

This is the complete list of members for JY9516T.LowPassFilter, including all inherited members.

Mode JY9516T.LowPassFilter


9516T C# Programming Manual: Member List

  • ReferenceClock
JY9516T.ReferenceClock Member List

This is the complete list of members for JY9516T.ReferenceClock, including all inherited members.

External | JY9516T.ReferenceClock
Source | JY9516T.ReferenceClock


9516T C# Programming Manual: Member List

  • Sync
JY9516T.Sync Member List

This is the complete list of members for JY9516T.Sync, including all inherited members.

State | JY9516T.Sync
Terminal | JY9516T.Sync
Topology | JY9516T.Sync


9516T C# Programming Manual: Class Index

Class Index
A | C | E | F | H | J | L | R | S
A
AIAnalogEdgeComparator (JY9516T)
AIAnalogHysteresisComparator (JY9516T)
AIAnalogTrigger (JY9516T)
AIAnalogWindowComparator (JY9516T)
AIChannel (JY9516T)
AIDigitalFiltering (JY9516T)
AIDigitalTrigger (JY9516T)
AIRecord (JY9516T)
AISignalExport (JY9516T)
AITrigger (JY9516T)
C
ConversionStatus (JY9516T)
E
ExternalReferenceClock (JY9516T)
F
FlatnessCompensation (JY9516T)
H
HighPassFilter (JY9516T)
J
JY9516TAITask (JY9516T)
L
LowPassFilter (JY9516T)
R
ReferenceClock (JY9516T)
S
Sync (JY9516T)


9516T C# Programming Manual: D:/OneDrive/Desktop/产品文档/CHM/9516T Directory Reference

  • File List
  • OneDrive
  • Desktop
  • 产品文档
  • CHM
  • 9516T
9516T Directory Reference

Directories

         C#


9516T C# Programming Manual: D:/OneDrive/Desktop/产品文档/CHM Directory Reference

  • File List
  • OneDrive
  • Desktop
  • 产品文档
  • CHM
CHM Directory Reference

Directories

         9516T


9516T C# Programming Manual: D:/OneDrive/Desktop Directory Reference

  • File List
  • OneDrive
  • Desktop
Desktop Directory Reference

Directories

         产品文档


9516T C# Programming Manual: D:/OneDrive/Desktop/产品文档 Directory Reference

  • File List
  • OneDrive
  • Desktop
  • 产品文档
产品文档 Directory Reference

Directories

         CHM


9516T C# Programming Manual: D:/OneDrive Directory Reference

  • File List
  • OneDrive
OneDrive Directory Reference

Directories

         Desktop


9516T C# Programming Manual: File List

  • File List
File List
Here is a list of all files with brief descriptions:
[detail level 1234567]
 OneDrive
Desktop
产品文档
CHM
9516T
C#
AIChannel.cs
AIDigitalFiltering.cs
AIRecord.cs
AISignalExport.cs
AISync.cs
AITrigger.cs
JY9516TAITask.cs
ReferenceClock.cs
TEDSCommon.cs


9516T C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • w
Here is a list of all class members with links to the classes they belong to:

- a -

  • Add() : JY9516T.AISignalExport
  • AddChannel() : JY9516T.JY9516TAITask
  • Analog : JY9516T.AITrigger
  • AvailableSamples : JY9516T.JY9516TAITask

- c -

  • ChannelID : JY9516T.ConversionStatus
  • Channels : JY9516T.JY9516TAITask
  • Clear() : JY9516T.AISignalExport
  • ClearAll() : JY9516T.AISignalExport
  • Commit() : JY9516T.JY9516TAITask
  • Comparator : JY9516T.AIAnalogTrigger
  • Condition : JY9516T.AIAnalogWindowComparator
  • Coupling : JY9516T.AIChannel
  • CRCError : JY9516T.ConversionStatus
  • CutoffFrequency : JY9516T.HighPassFilter

- d -

  • DetectIEPEConnection() : JY9516T.JY9516TAITask
  • Device : JY9516T.JY9516TAITask
  • Digital : JY9516T.AITrigger
  • DigitalFiltering : JY9516T.JY9516TAITask
  • DisableChannel() : JY9516T.HighPassFilter

- e -

  • Edge : JY9516T.AIAnalogTrigger, JY9516T.AIDigitalTrigger
  • EnableChannel() : JY9516T.HighPassFilter
  • Enabled : JY9516T.FlatnessCompensation
  • ErrorFlagged : JY9516T.ConversionStatus
  • External : JY9516T.ReferenceClock

- f -

  • FileFormat : JY9516T.AIRecord
  • FilePath : JY9516T.AIRecord
  • FilterEnabledChannels : JY9516T.HighPassFilter
  • FilterSuturated : JY9516T.ConversionStatus
  • Frequency : JY9516T.ExternalReferenceClock

- g -

  • GetConversionStatus() : JY9516T.JY9516TAITask
  • GetRecordPreviewData() : JY9516T.JY9516TAITask
  • GetRecordStatus() : JY9516T.JY9516TAITask
  • GetSamplingInfo() : JY9516T.JY9516TAITask

- h -

  • HighThreshold : JY9516T.AIAnalogHysteresisComparator, JY9516T.AIAnalogWindowComparator
  • HPF : JY9516T.AIDigitalFiltering
  • Hysteresis : JY9516T.AIAnalogTrigger

- i -

  • ID : JY9516T.AIChannel
  • IEPEEnabled : JY9516T.AIChannel

- j -

  • JY9516TAITask() : JY9516T.JY9516TAITask

- l -

  • Length : JY9516T.AIRecord
  • LowThreshold : JY9516T.AIAnalogHysteresisComparator, JY9516T.AIAnalogWindowComparator
  • LPF : JY9516T.AIDigitalFiltering

- m -

  • Mode : JY9516T.AIRecord, JY9516T.AITrigger, JY9516T.JY9516TAITask, JY9516T.LowPassFilter

- o -

  • Order : JY9516T.HighPassFilter

- p -

  • PreTriggerSamples : JY9516T.AITrigger

- r -

  • Range : JY9516T.AIChannel
  • RangeHigh : JY9516T.AIChannel
  • RangeLow : JY9516T.AIChannel
  • RawDataScaleFactor : JY9516T.AIChannel
  • ReadData() : JY9516T.JY9516TAITask
  • ReadRawData() : JY9516T.JY9516TAITask
  • ReadSinglePoint() : JY9516T.JY9516TAITask
  • ReadSingleRawPoint() : JY9516T.JY9516TAITask
  • ReadTEDSData() : JY9516T.JY9516TAITask
  • Record : JY9516T.JY9516TAITask
  • RemoveChannel() : JY9516T.JY9516TAITask
  • ReTriggerCount : JY9516T.AITrigger

- s -

  • SampleRate : JY9516T.JY9516TAITask
  • SamplesToAcquire : JY9516T.JY9516TAITask
  • SendSoftwareTrigger() : JY9516T.JY9516TAITask
  • SignalExport : JY9516T.JY9516TAITask
  • Slope : JY9516T.AIAnalogEdgeComparator, JY9516T.AIAnalogHysteresisComparator
  • Source : JY9516T.AIAnalogTrigger, JY9516T.AIDigitalTrigger, JY9516T.ReferenceClock
  • Start() : JY9516T.JY9516TAITask
  • StartSync() : JY9516T.JY9516TAITask
  • State : JY9516T.JY9516TAITask, JY9516T.Sync
  • Stop() : JY9516T.JY9516TAITask
  • Sync : JY9516T.JY9516TAITask

- t -

  • Terminal : JY9516T.AIChannel, JY9516T.ExternalReferenceClock, JY9516T.Sync
  • Threshold : JY9516T.AIAnalogEdgeComparator
  • Topology : JY9516T.Sync
  • TransferedSamples : JY9516T.JY9516TAITask
  • Trigger : JY9516T.JY9516TAITask
  • Type : JY9516T.AITrigger

- w -

  • WaitUntilDone() : JY9516T.JY9516TAITask
  • Window : JY9516T.AIAnalogTrigger


9516T C# Programming Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • Properties
  • a
  • c
  • d
  • e
  • g
  • j
  • r
  • s
  • w
Here is a list of all functions with links to the classes they belong to:

- a -

  • Add() : JY9516T.AISignalExport
  • AddChannel() : JY9516T.JY9516TAITask

- c -

  • Clear() : JY9516T.AISignalExport
  • ClearAll() : JY9516T.AISignalExport
  • Commit() : JY9516T.JY9516TAITask

- d -

  • DetectIEPEConnection() : JY9516T.JY9516TAITask
  • DisableChannel() : JY9516T.HighPassFilter

- e -

  • EnableChannel() : JY9516T.HighPassFilter

- g -

  • GetConversionStatus() : JY9516T.JY9516TAITask
  • GetRecordPreviewData() : JY9516T.JY9516TAITask
  • GetRecordStatus() : JY9516T.JY9516TAITask
  • GetSamplingInfo() : JY9516T.JY9516TAITask

- j -

  • JY9516TAITask() : JY9516T.JY9516TAITask

- r -

  • ReadData() : JY9516T.JY9516TAITask
  • ReadRawData() : JY9516T.JY9516TAITask
  • ReadSinglePoint() : JY9516T.JY9516TAITask
  • ReadSingleRawPoint() : JY9516T.JY9516TAITask
  • ReadTEDSData() : JY9516T.JY9516TAITask
  • RemoveChannel() : JY9516T.JY9516TAITask

- s -

  • SendSoftwareTrigger() : JY9516T.JY9516TAITask
  • Start() : JY9516T.JY9516TAITask
  • StartSync() : JY9516T.JY9516TAITask
  • Stop() : JY9516T.JY9516TAITask

- w -

  • WaitUntilDone() : JY9516T.JY9516TAITask


9516T C# Programming Manual: Class Members - Properties

  • All
  • Functions
  • Variables
  • Properties
  • a
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • w
Here is a list of all properties with links to the classes they belong to:

- a -

  • Analog : JY9516T.AITrigger
  • AvailableSamples : JY9516T.JY9516TAITask

- c -

  • ChannelID : JY9516T.ConversionStatus
  • Channels : JY9516T.JY9516TAITask
  • Comparator : JY9516T.AIAnalogTrigger
  • Condition : JY9516T.AIAnalogWindowComparator
  • Coupling : JY9516T.AIChannel
  • CRCError : JY9516T.ConversionStatus
  • CutoffFrequency : JY9516T.HighPassFilter

- d -

  • Device : JY9516T.JY9516TAITask
  • Digital : JY9516T.AITrigger
  • DigitalFiltering : JY9516T.JY9516TAITask

- e -

  • Edge : JY9516T.AIAnalogTrigger, JY9516T.AIDigitalTrigger
  • Enabled : JY9516T.FlatnessCompensation
  • ErrorFlagged : JY9516T.ConversionStatus
  • External : JY9516T.ReferenceClock

- f -

  • FileFormat : JY9516T.AIRecord
  • FilePath : JY9516T.AIRecord
  • FilterEnabledChannels : JY9516T.HighPassFilter
  • FilterSuturated : JY9516T.ConversionStatus
  • Frequency : JY9516T.ExternalReferenceClock

- h -

  • HPF : JY9516T.AIDigitalFiltering
  • Hysteresis : JY9516T.AIAnalogTrigger

- i -

  • ID : JY9516T.AIChannel
  • IEPEEnabled : JY9516T.AIChannel

- l -

  • Length : JY9516T.AIRecord
  • LPF : JY9516T.AIDigitalFiltering

- m -

  • Mode : JY9516T.AIRecord, JY9516T.AITrigger, JY9516T.JY9516TAITask, JY9516T.LowPassFilter

- o -

  • Order : JY9516T.HighPassFilter

- p -

  • PreTriggerSamples : JY9516T.AITrigger

- r -

  • Range : JY9516T.AIChannel
  • RangeHigh : JY9516T.AIChannel
  • RangeLow : JY9516T.AIChannel
  • RawDataScaleFactor : JY9516T.AIChannel
  • Record : JY9516T.JY9516TAITask
  • ReTriggerCount : JY9516T.AITrigger

- s -

  • SampleRate : JY9516T.JY9516TAITask
  • SamplesToAcquire : JY9516T.JY9516TAITask
  • SignalExport : JY9516T.JY9516TAITask
  • Slope : JY9516T.AIAnalogEdgeComparator, JY9516T.AIAnalogHysteresisComparator
  • Source : JY9516T.AIAnalogTrigger, JY9516T.AIDigitalTrigger, JY9516T.ReferenceClock
  • State : JY9516T.JY9516TAITask, JY9516T.Sync
  • Sync : JY9516T.JY9516TAITask

- t -

  • Terminal : JY9516T.AIChannel, JY9516T.ExternalReferenceClock, JY9516T.Sync
  • Topology : JY9516T.Sync
  • TransferedSamples : JY9516T.JY9516TAITask
  • Trigger : JY9516T.JY9516TAITask
  • Type : JY9516T.AITrigger

- w -

  • Window : JY9516T.AIAnalogTrigger


9516T C# Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Properties
Here is a list of all variables with links to the classes they belong to:
  • HighThreshold : JY9516T.AIAnalogHysteresisComparator, JY9516T.AIAnalogWindowComparator
  • LowThreshold : JY9516T.AIAnalogHysteresisComparator, JY9516T.AIAnalogWindowComparator
  • Threshold : JY9516T.AIAnalogEdgeComparator


9516T C# Programming Manual: Main Page

9516T C# Programming Manual Documentation


9516T C# Programming Manual: JY9516T.TEDS Namespace Reference

  • Package List
  • Package Members
  • JY9516T
  • TEDS
Classes
JY9516T.TEDS Namespace Reference

Classes

class | TEDSUtilities
class | TEDSChipInfo


9516T C# Programming Manual: Package Members

  • Package List
  • Package Members
  • All
  • Enumerations
Here is a list of all namespace members with links to the namespace documentation for each member:
  • AIAnalogTriggerComparator : JY9516T
  • AIAnalogTriggerEdge : JY9516T
  • AIAnalogTriggerSource : JY9516T
  • AIAnalogWindowCondition : JY9516T
  • AIDigitalTriggerEdge : JY9516T
  • AIDigitalTriggerSource : JY9516T
  • AIMode : JY9516T
  • AIRange : JY9516T
  • AISignalExportSource : JY9516T
  • AITerminal : JY9516T
  • AITriggerMode : JY9516T
  • AITriggerType : JY9516T
  • ChoppingFrequency : JY9516T
  • Coupling : JY9516T
  • ExternalReferenceClockTerminal : JY9516T
  • FileFormat : JY9516T
  • HPFOrder : JY9516T
  • IEPEConnectionStatus : JY9516T
  • LPFMode : JY9516T
  • RecordMode : JY9516T
  • ReferenceClockSource : JY9516T
  • SamplingState : JY9516T
  • SignalExportDestination : JY9516T
  • SyncState : JY9516T
  • SyncTerminal : JY9516T
  • SyncTopology : JY9516T


9516T C# Programming Manual: Package Members

  • Package List
  • Package Members
  • All
  • Enumerations
Here is a list of all namespace enums with links to the namespace documentation for each enum:
  • AIAnalogTriggerComparator : JY9516T
  • AIAnalogTriggerEdge : JY9516T
  • AIAnalogTriggerSource : JY9516T
  • AIAnalogWindowCondition : JY9516T
  • AIDigitalTriggerEdge : JY9516T
  • AIDigitalTriggerSource : JY9516T
  • AIMode : JY9516T
  • AIRange : JY9516T
  • AISignalExportSource : JY9516T
  • AITerminal : JY9516T
  • AITriggerMode : JY9516T
  • AITriggerType : JY9516T
  • ChoppingFrequency : JY9516T
  • Coupling : JY9516T
  • ExternalReferenceClockTerminal : JY9516T
  • FileFormat : JY9516T
  • HPFOrder : JY9516T
  • IEPEConnectionStatus : JY9516T
  • LPFMode : JY9516T
  • RecordMode : JY9516T
  • ReferenceClockSource : JY9516T
  • SamplingState : JY9516T
  • SignalExportDestination : JY9516T
  • SyncState : JY9516T
  • SyncTerminal : JY9516T
  • SyncTopology : JY9516T


9516T C# Programming Manual: Package List

  • Package List
  • Package Members
Package List
Here are the packages with brief descriptions (if available):
[detail level 12]
N JY9516T
N TEDS