9802 C++ Programming Manual: D:/9802/C++/JY9802Core.h File Reference

9802 C++ Programming Manual
  • Main Page
  • Classes
  • Files
  • File List
  • File Members
  • 9802
  • C++
Classes | Macros | Typedefs | Enumerations | Functions
JY9802Core.h File Reference

Classes

struct | JY9802CoreDeviceInfo
struct | JY9802CoreCalibrationConstant
struct | JY9802CoreCalibrationInfo
struct | CARD_ABILITY
struct | JY9802DeviceInfo

Macros

#define | STDCALL
FileName:JY9802Core.h Copyright NOTICE(版权声明) Copyright (c) 2017, JYTek All rights reserved.
#define | CCALL
#define | JYDLL_API
#define | STDCALL
FileName:JY9802Core.h Copyright NOTICE(版权声明) Copyright (c) 2017, JYTek All rights reserved.
#define | ErrorCodeOffset (int)(-11000)
#define | JYSuccess (0)
#define | JYFailed (-1)
#define | NoError (0)
无错误

#define | ErrorInvalidParam (ErrorCodeOffset-2)
#define | ErrorWriteRegisterFailed (ErrorCodeOffset-3)
#define | ErrorReadRegisterFailed (ErrorCodeOffset-4)
#define | ErrorCardNotOpened (ErrorCodeOffset-5)
#define | ErrorCardHasBeenOpened (ErrorCodeOffset-6)
#define | ErrorInternalError (ErrorCodeOffset-7)
#define | ErrorEEPROMCalCRCFailed (ErrorCodeOffset-8)
#define | ErrorTaskIsStartDonotAllowConfig (ErrorCodeOffset-9)
#define | ErrorOpenDeviceFailed (ErrorCodeOffset-10)
打开设备失败
#define | ErrorCloseDeviceFailed (ErrorCodeOffset-11)
关闭设备失败
#define | CardNotOpened (ErrorCodeOffset-12)
设置设备信息失败
#define | ErrorTimeOut (ErrorCodeOffset-13)
超时错误
#define | ErrorClockSource (ErrorCodeOffset-14)
不正确的时钟源
#define | ErrorSampleRateParam (ErrorCodeOffset-15)
采样率参数不正确
#define | ErrorOSPModeParam (ErrorCodeOffset-16)
OSP_Mode参数不正确
#define | ErrorSampleModeParam (ErrorCodeOffset-17)
采样模式参数不正确
#define | ErrorSetSampleModeFailed (ErrorCodeOffset-18)
采样模式设置失败
#define | ErrorTriggerTypeParam (ErrorCodeOffset-19)
触发类型不正确
#define | ErrorChannelParam (ErrorCodeOffset-20)
通道参数不正确
#define | ErrorPreTriggerSamplesParam (ErrorCodeOffset-21)
预触发点数参数不正确
#define | ErrorSamplesParam (ErrorCodeOffset-22)
有限采样点数，有限或者连续环绕生成点数不正确
#define | ErrorGetAcquisitionStatusFailed (ErrorCodeOffset-23)
获取采集状态失败
#define | ErrorPointerNotNull (ErrorCodeOffset-24)
指针不能为空
#define | ErrorDDCFrequence (ErrorCodeOffset-25)
#define | ErrorAnalogTriggerConditioningParam (ErrorCodeOffset-26)
模拟触发条件不正确
#define | ErrorAD9517InitFailed (ErrorCodeOffset-27)
#define | ErrorCardNumberNotExistInDeviceManager (ErrorCodeOffset-28)
#define | ErrorAWGStopFailed (ErrorCodeOffset-29)
#define | ErrorDigitizerStopFailed (ErrorCodeOffset-30)
#define | ErrorGetTemperatureFailed (ErrorCodeOffset-31)
#define | ErrorTimebaseMaster (ErrorCodeOffset-32)
#define | ErrorTimebaseParam (ErrorCodeOffset-33)
#define | ErrorDigitalTriggerParam (ErrorCodeOffset-34)
#define | ErrorAnnalogTriggerParam (ErrorCodeOffset-35)
#define | ErrorAnnalogTriggerThreshold (ErrorCodeOffset-36)
#define | ErrorDigitizerStartFailed (ErrorCodeOffset-37)
#define | ErrorGetDDCInputPeakValueFailed (ErrorCodeOffset-38)
#define | ErrorReadDateFailed (ErrorCodeOffset-39)
#define | ErrorBufferLengthParam (ErrorCodeOffset-40)
#define | ErrorTimebaseMasterParam (ErrorCodeOffset-41)
#define | ErrorCommitAWGFirst (ErrorCodeOffset-42)
#define | ErrorCalcUpDownConverterParaFailed (ErrorCodeOffset-43)
#define | ErrorCalcMixerParamFailed (ErrorCodeOffset-44)
#define | ErrorAD9517ConfigPLLFailed (ErrorCodeOffset-45)
#define | ErrorAD9517WaitPLLLockFailed (ErrorCodeOffset-46)
#define | ErrorAD9517ConfigChannelDividerFailed (ErrorCodeOffset-47)
#define | ErrorResetDDCFailed (ErrorCodeOffset-48)
#define | ErrorConfigDDCFailed (ErrorCodeOffset-49)
#define | ErrorResetDUCFailed (ErrorCodeOffset-50)
#define | ErrorConfigDUCFailed (ErrorCodeOffset-51)
#define | ErrorSetDUCInputGainFailed (ErrorCodeOffset-52)
#define | ErrorAD4249InitFailed (ErrorCodeOffset-53)
#define | ErrorAD9122ConfigPLLFailed (ErrorCodeOffset-54)
#define | ErrorRxClearFailed (ErrorCodeOffset-55)
#define | ErrorRxConfigSingleTransferBytesFailed (ErrorCodeOffset-56)
#define | ErrorRxConfigBufferFailed (ErrorCodeOffset-57)
#define | ErrorRxSetParallelModeByteMaskFailed (ErrorCodeOffset-58)
#define | ErrorRxConfigAquisitionFailed (ErrorCodeOffset-59)
#define | ErrorRxEnableHWTriggerFailed (ErrorCodeOffset-60)
#define | ErrorRxConfigTriggerFailed (ErrorCodeOffset-61)
#define | ErrorTxClearFailed (ErrorCodeOffset-62)
#define | ErrorTxConfigSingleTransferBytesFailed (ErrorCodeOffset-63)
#define | ErrorTxConfigBufferFailed (ErrorCodeOffset-64)
#define | ErrorTxConfigOutputStrobelFailed (ErrorCodeOffset-65)
#define | ErrorTxConfigGenerationFailed (ErrorCodeOffset-66)
#define | ErrorTxEnableHWTriggerFailed (ErrorCodeOffset-67)
#define | ErrorTxConfigTriggerFailed (ErrorCodeOffset-68)
#define | ErrorPFIConfigFailed (ErrorCodeOffset-69)
#define | ErrorRoutingMatrixConfigFailed (ErrorCodeOffset-70)
#define | ErrorAnalogTriggerConfigFailed (ErrorCodeOffset-71)
#define | ErrorIQTriggerConfigFailed (ErrorCodeOffset-72)
#define | ErrorGenerationModeParam (ErrorCodeOffset-73)
#define | ErrorAWGStartFailed (ErrorCodeOffset-74)
#define | ErrorGetGenerationStatusFailed (ErrorCodeOffset-75)
#define | ErrorWriteDataFailed (ErrorCodeOffset-76)
#define | ErrorCommitDigitizerFirst (ErrorCodeOffset-77)
#define | ErrorCenterFrequencyParam (ErrorCodeOffset-78)
#define | ErrorDigitialGainParam (ErrorCodeOffset-79)
#define | ErrorSendSoftwareTriggerFailed (ErrorCodeOffset-80)
#define | ErrorDataSourceSlectFailed (ErrorCodeOffset-81)
#define | ErrorExpectedFrequencyParam (ErrorCodeOffset-82)
#define | ErrorDDSSignalFreConfigFailed (ErrorCodeOffset-83)
#define | ErrorAD9122PowerOffFailed (ErrorCodeOffset-84)
#define | ErrorAD9122PowerOnFailed (ErrorCodeOffset-85)
#define | ErrorAWGDataSourceParam (ErrorCodeOffset-86)
#define | ErrorBITFrequencyParam (ErrorCodeOffset-87)
#define | ErrorRxCloseFailed (ErrorCodeOffset-88)
#define | ErrorTxCloseFailed (ErrorCodeOffset-89)
#define | ErrorTxInitFailed (ErrorCodeOffset-90)
#define | ErrorRxInitFailed (ErrorCodeOffset-91)
#define | ExternalClockFrequencyParam (ErrorCodeOffset-92)
#define | ErrorReadCalibrationBlockFailed (ErrorCodeOffset-93)
#define | ErrorAD4249AdjustFailed (ErrorCodeOffset-94)
#define | ErrorAD9122AdjustFailed (ErrorCodeOffset-95)
#define | ErrorAD9517EnableOutputChannel (ErrorCodeOffset-96)
#define | ErrorPFIInitFailed (ErrorCodeOffset-97)
#define | ErrorPFICloseFailed (ErrorCodeOffset-98)
#define | ErrorControlLEDSetHighLowTicksFailed (ErrorCodeOffset-99)
#define | ErrorReTriggerCountsParam (ErrorCodeOffset-100)
#define | ErrorAutoTriggerTimeParam (ErrorCodeOffset-101)
#define | ErrorHoldOffTimeParam (ErrorCodeOffset-102)
#define | ErrorReTriggerCountsNotMatchSampleMode (ErrorCodeOffset-103)
#define | ErrorRxSetAutoTriggerFailed (ErrorCodeOffset-104)
#define | ErrorRxSetHoldOffTimeFailed (ErrorCodeOffset-105)
#define | ErrorRxMultiRecordReadFailed (ErrorCodeOffset-106)
#define | ErrorAD9517ParamDigitizerNotMatchAWG (ErrorCodeOffset-107)
#define | ExportClockFrequencyParam (ErrorCodeOffset-108)
#define | ErrorCommitAWGOrDigitizerFirst (ErrorCodeOffset-109)
#define | ErrorExportClkAD9517ParamNotMatch (ErrorCodeOffset-110)
#define | ErrorAWGChannelDelayParam (ErrorCodeOffset - 111)
#define | ErrorExportSignalDestinationNotSupport (ErrorCodeOffset - 112)
#define | ErrorExportSignalDestinationReserved (ErrorCodeOffset - 113)
#define | ErrorExportSignalCannotRepeatConfig (ErrorCodeOffset - 114)
#define | ErrorExportSignalConfig (ErrorCodeOffset - 115)
#define | ErrorTxUnderflow (ErrorCodeOffset - 116)
#define | ErrorReadReg (ErrorCodeOffset - 117)
#define | ErrorNotSupportAWG (ErrorCodeOffset - 118)
#define | ErrorNotSupportDigitizer (ErrorCodeOffset - 119)
#define | ErrorInvalidCalibration (ErrorCodeOffset - 120)
#define | ErrorWarningCalibration (ErrorCodeOffset - 121)
#define | ErrorAliasNameNotMatchSupportedCard (ErrorCodeOffset - 122)
#define | ErrorGetDeviceInfoFailed (ErrorCodeOffset - 123)
#define | ErrorBasebandModeOnlySupoortCH0 (ErrorCodeOffset - 124)

Typedefs

typedef unsigned long long | UINT64
typedef unsigned char | BYTE
typedef void * | Handle

Enumerations

enum | GenerationMode { Finite = 0 , ContinuousWrapping = 1 , Stream = 2 }
enum | ExportClockType { None , AISampleClk , AOSampleClk , SpecifiedFrequency }
enum | OSPMode { OSPReal = 0 , OSPComplex = 1 }
enum | AWGDataSource { AWGDataSourceBIT = 0 , AWGDataSourceDAC = 1 }
enum | TriggerMode { StartTrigger = 0x1 , ReferenceTrigger =0x2 , StartAndReferenceTrigger =0x3 }
enum | TriggerType { Immediate_Trigger =0x0 , Soft_Trigger =0x1 , Digital_Trigger =0x2 , Analog_Trigger =0x3 }
enum | AWGTriggerType { ImmediateTrigger = 0x0 , SoftTrigger = 0x1 , DigitalTrigger = 0x2 }
enum | AcquisitionMode { Finite_Sample =0x0 , Continuous_Sample =0x1 }
enum DigitalTriggerSource {
TriggerIn =8 , AO_Start_Event = 18 , AI_REF_TRIGGER_Event = 13 , AI_Start_TRIGGER_Event = 12 ,
AI_Advance_TRIGGER_EVENT = 14 , PFI0 = 0 , PFI1 = 1 , PFI2 = 2 ,
PFI3 = 3 , PFI4 = 4 , PFI5 = 5 , PFI6 = 6 ,
PFI7 = 7
}
enum | DigitalTriggerConditioning { Rising_Edge_Trigger = (0x1 << 1) , Falling_Edge_Trigger = (0x1 << 2) , High_Level_Trigger = (0x1 << 3) , Low_Level_Trigger = (0x1 << 4) }
enum | ClockSource { ExternalClock =0x0 , InternalClock =0x1 }
enum | AnalogTriggerType { AnalogHysteresisTrigger = 0x00 , AnalogWindowTrigger = 0x1 , AnalogPowerTrigger = 0x2 }
enum | AnalogTriggerSource { AnalogTriggerSourceCH0Raw = 0x00 , AnalogTriggerSourceCH1Raw = 0x01 , AnalogTriggerSourceIQCHO = 0x02 , AnalogTriggerSourceIQCH1 =0x03 }
enum AnalogTriggerConditioning {
AnalogTriggerConditioningPowerHigh = High_Level_Trigger , AnalogTriggerConditioningPowerLow = Low_Level_Trigger , AnalogTriggerConditioningEnteringWindow = Rising_Edge_Trigger , AnalogTriggerConditioningLeavingWindow = Falling_Edge_Trigger ,
AnalogTriggerConditioningRising = Rising_Edge_Trigger , AnalogTriggerConditioningFalling = Falling_Edge_Trigger
}
enum ExportSignalSource {
AIReadyForStartTrigger = 9 , AIReadyForRefTrigger = 10 , AIReadyForAdvanceTrigger = 11 , AIStartTrigger = 12 ,
AIRefTrigger0 = 13 , AIAdvanceTriggerO = 14 , AIEndOfRecord = 15 , AIEndOfAcquisition = 16 ,
AOReadyForStartTrigger = 17 , AOStartTrigger = 18 , AOGenerationDone =19 , AIPowerTrigger = 20 ,
AIAnalogTrigger = 21
}
enum ExportSignalDestination {
PFIOut0 = 0 , PFIOut1 = 1 , PFIOut2 = 2 , PFIOut3 = 3 ,
PFIOut4 = 4 , PFIOut5 = 5 , PFIOut6 = 6 , PFIOut7 = 7 ,
TriggerOut = 8
}
enum | PFI_SOURCE_SEL { TRIGGER_ADDR = 0x00002000 , GPIO_ADDR = 0x00001000 }

Functions

JYDLL_API int STDCALL | JY9802Core_GetDeviceList (JY9802DeviceInfo deviceInfo[], int deviceInfoLength)
获取所有设备
JYDLL_API int STDCALL | JY9802Core_Open (int slotNumber, int *cardID)
打开设备
JYDLL_API int STDCALL | JY9802Core_Open_WithAliasName (const char *aliasName, int *cardID)
打开设备
JYDLL_API int STDCALL | JY9802Core_Close (int cardID)
关闭设备
JYDLL_API int STDCALL | JY9802Core_GetCardAbility (int cardID, CARD_ABILITY *cardAbility)
获取当前卡具备的能力
JYDLL_API int STDCALL | JY9802Core_Digitizer_Init (int cardID)
初始化Digitizer
JYDLL_API int STDCALL | JY9802Core_AWG_Init (int cardID)
初始化AO
JYDLL_API int STDCALL | JY9802Core_GetTemperature (int cardID, double *CardTemp, double *fpgaTemp=NULL)
获取板卡温度
JYDLL_API int STDCALL | JY9802Core_SetClockSource (int cardID, ClockSource clockSource)
选择时钟源,默认内部时钟
JYDLL_API int STDCALL | JY9802Core_SetExternalReferenceClockFrequency (int cardID, double frequency=10e6)
设置外参考时钟的频率
JYDLL_API int STDCALL | JY9802Core_GetLastError (int cardID, char *message, int *errorCode)
获取最后一条错误信息
JYDLL_API int STDCALL | JY9802Core_ExportClock (int cardID, ExportClockType exportClockType, double expectedFrequency=10e6)
导出时钟到Ref_Out
JYDLL_API int STDCALL | JY9802Core_ExportSignal (int cardID, ExportSignalSource source, ExportSignalDestination destination)
导出信号配置
JYDLL_API int STDCALL | JY9802Core_Digitizer_Commit (int cardID)
提交配置
JYDLL_API int STDCALL | JY9802Core_Digitizer_SetTimebase (int cardID, double timebaseRate)
设置时基
JYDLL_API int STDCALL | JY9802Core_Digitizer_GetTimebase (int cardID, double *actualTimebase)
获取时基
JYDLL_API int STDCALL | JY9802Core_Digitizer_SetSampleRate (int cardID, double sampleRate)
设置采样率
JYDLL_API int STDCALL | JY9802Core_Digitizer_GetSampleRate (int cardID, double *sampleRate)
获取采样率
JYDLL_API int STDCALL | JY9802Core_Digitizer_SetOSPMode (int cardID, OSPMode ospMode, bool enbleDDC=false)
设置OSP模式
JYDLL_API int STDCALL | JY9802Core_Digitizer_SetDDCParam (int cardID, int channelMask, double frequency, int digitalgain=0)
设置DDC参数
JYDLL_API int STDCALL | JY9802Core_Digitizer_EnableLowLatencyDDC (int cardID, bool enbaleLowLatencyDDC=false)
是否使能低延时的DDC
JYDLL_API int STDCALL | JY9802Core_Digitizer_SetBasebandModeEnabled (int cardID, int enabled)
设置DDC参数
JYDLL_API int STDCALL | JY9802Core_Digitizer_SetTriggerType (int cardID, TriggerType triggerType)
设置触发类型
JYDLL_API int STDCALL | JY9802Core_Digitizer_SetDigitalTrigger (int cardID, DigitalTriggerConditioning digitalTriggerType, DigitalTriggerSource digitalTriggerSource)
设置数字触发类型
JYDLL_API int STDCALL | JY9802Core_Digitizer_SetAnalogTrigger (int cardID, AnalogTriggerType analogTriggerType, AnalogTriggerSource analogTriggerSource, AnalogTriggerConditioning analogTriggerConditioning, double highThreshold, double lowThreshold)
设置模拟触发类型
JYDLL_API int STDCALL | JY9802Core_Digitizer_SetPreTriggerSamples (int cardID, unsigned int preTriggerSamples)
设置预触发点数
JYDLL_API int STDCALL | JY9802Core_Digitizer_SetEnabledChannels (int cardID, int channelMask)
设置使能通道
JYDLL_API int STDCALL | JY9802Core_Digitizer_SetAcquisitionMode (int cardID, AcquisitionMode acquisitionMode)
设置采集模式
JYDLL_API int STDCALL | JY9802Core_Digitizer_SetSamplesToAcquire (int cardID, int samplesToAcquire)
设置采集点数，有限点模式下有效
JYDLL_API int STDCALL | JY9802Core_Digitizer_Start (int cardID)
开始
JYDLL_API int STDCALL | JY9802Core_Digitizer_Stop (int cardID)
停止
JYDLL_API int STDCALL | JY9802Core_Digitizer_GetAcquisitionStatus (int cardID, bool *isOverFlow, unsigned long long *availableSamples)
获取采集状态，ReTriggerCount=1时有效
JYDLL_API int STDCALL | JY9802Core_Digitizer_WaitForAcqComplete (int cardID, int timeout, bool *complete)
获取采集状态，有限点，ReTriggerCount=1时有效
JYDLL_API int STDCALL | JY9802Core_Digitizer_ReadDataBinary16 (int cardID, short *dataBuffer, unsigned int samplesToRead, unsigned int *actualSamples, double *scaleFactor, bool *isOverLoad, int timeout)
读数据
JYDLL_API int STDCALL | JY9802Core_Digitizer_SetBufferLength (int cardID, unsigned int length)
设置缓冲区大小，ReTriggerCount=1时有效
JYDLL_API int STDCALL | JY9802Core_Digitizer_ReadDataDbl64 (int cardID, double *dataBuffer, unsigned int samplesToRead, int timeout)
读double数据
JYDLL_API int STDCALL | JY9802Core_Digitizer_SendSoftwareTrigger (int cardID)
发送软件触发
JYDLL_API int STDCALL | JY9802Core_Digitizer_SetReTriggerParam (int cardID, unsigned long long reTriggerCounts, double autoTriggerTime=-1.0, double holdOffTime=1)
设置重触发参数
JYDLL_API int STDCALL | JY9802Core_Digitizer_GetReTriggerStatus (int cardID, bool *isOverFlow, unsigned long long *remainingCounts, unsigned long long *completedCounts)
获取采集状态
JYDLL_API int STDCALL | JY9802Core_AWG_SendSoftwareTrigger (int cardID)
AWG发送软件触发
JYDLL_API int STDCALL | JY9802Core_AWG_SetEnabledChannels (int cardID, int channelMask)
AWG使能通道
JYDLL_API int STDCALL | JY9802Core_AWG_SetGenerationMode (int cardID, GenerationMode generationMode)
AWG设置波形生成模式
JYDLL_API int STDCALL | JY9802Core_AWG_Commit (int cardID)
提交配置
JYDLL_API int STDCALL | JY9802Core_AWG_Start (int cardID)
开始
JYDLL_API int STDCALL | JY9802Core_AWG_Stop (int cardID)
停止
JYDLL_API int STDCALL | JY9802Core_AWG_GetGenerationStatus (int cardID, bool *complete, unsigned long long *samplesGenerated, unsigned int *availableBufferLength)
获取生成状态
JYDLL_API int STDCALL | JY9802Core_AWG_SetOSPMode (int cardID, OSPMode ospMode, bool enableDUC=false)
设置OSP模式
JYDLL_API int STDCALL | JY9802Core_AWG_SetBasebandModeEnabled (int cardID, int enabled)
设置DDC参数
JYDLL_API int STDCALL | JY9802Core_AWG_SetCenterFrequency (int cardID, int channelMask, double frequency)
设置DUC的中心频率
JYDLL_API int STDCALL | JY9802Core_AWG_SetDigitalGain (int cardID, int channelMask, double digitalgain)
设置通道增益
JYDLL_API int STDCALL | JY9802Core_AWG_SetTriggerType (int cardID, AWGTriggerType triggerType)
设置触发类型
JYDLL_API int STDCALL | JY9802Core_AWG_SetDigitalTrigger (int cardID, DigitalTriggerConditioning digitalTriggerType, DigitalTriggerSource digitalTriggerSource)
设置触发类型
JYDLL_API int STDCALL | JY9802Core_AWG_SetSampleRate (int cardID, double sampleRate)
设置采样率
JYDLL_API int STDCALL | JY9802Core_AWG_GetSampleRate (int cardID, double *sampleRate)
获取采样率
JYDLL_API int STDCALL | JY9802Core_AWG_SetTimebase (int cardID, double timebaseRate)
设置时基
JYDLL_API int STDCALL | JY9802Core_AWG_GetTimebase (int cardID, double *actualTimebase)
获取时基
JYDLL_API int STDCALL | JY9802Core_AWG_WriteDataBinary16 (int cardID, short *dataBuffer, unsigned int samplesToWrite, unsigned int *actualSamples, int timeout)
写数据，需要在commit之后调用此函数
JYDLL_API int STDCALL | JY9802Core_AWG_WriteDbl64 (int cardID, double *dataBuffer, unsigned int samplesToWrite, unsigned int *actualSamples, int timeout)
写数据，需要在commit之后调用此函数
JYDLL_API int STDCALL | JY9802Core_AWG_SetBufferLength (int cardID, unsigned int length)
设置缓冲区大小，连续环绕模式的时候，length必须等于写入数据的字节数
JYDLL_API int STDCALL | JY9802Core_AWG_SetSamplesToWrite (int cardID, int samplesToWrite)
设置每个通道写入点数，有限点模式和连续环绕模式下有效
JYDLL_API int STDCALL | JY9802Core_AWG_SetDataSource (int cardID, AWGDataSource dataSource)
设置数据源
JYDLL_API int STDCALL | JY9802Core_AWG_SetBITFrequency (int cardID, double expectedFrequency=1e6)
BIT输出信号的频率
JYDLL_API int STDCALL | JY9802Core_AWG_SetEnableInverseSinc (int cardID, bool enableInverseSinc=false)
是否使能DA的InverseSinc
JYDLL_API int STDCALL | JY9802Core_AWG_SetChannelDelay (int cardID, double Ch0Delay, double Ch1Delay)
设置通道时延
JYDLL_API int STDCALL | JY9802Core_AWG_GetChannelDelay (int cardID, double *Ch0Delay, double *Ch1Delay)
获取通道时延，commit之后调用此函数有效
JYDLL_API int STDCALL | JY9802Core_EEPROM_ReadIdBlock (int card_int, JY9802CoreDeviceInfo *id)
读EEPROMIdBlock
JYDLL_API int STDCALL | JY9802Core_EEPROM_WriteIdBlock (int card_int, JY9802CoreDeviceInfo *id)
写EEPROMIdBlock
JYDLL_API int STDCALL | JY9802Core_EEPROM_ReadCalibrationBlock (int card_int, JY9802CoreCalibrationInfo *cb)
读EEPROMCalibrationBlock
JYDLL_API int STDCALL | JY9802Core_EEPROM_WriteCalibrationBlock (int card_int, JY9802CoreCalibrationInfo *cb)
写EEPROMCalibrationBlock
JYDLL_API int STDCALL | JY9802Core_EEPROM_InitializeIdBlock (int card_int)
初始化IdBlock
JYDLL_API int STDCALL | JY9802Core_EEPROM_InitializeCalibrationBlock (int card_int)
初始化CalibrationBlock
JYDLL_API int STDCALL | JY9802Core_EEPROM_SerialNumber_String2Int (const char *const serialNumberString, int *serialNumberInt)
序列字符转序列号
JYDLL_API int STDCALL | JY9802Core_EEPROM_SerialNumber_Int2String (int serialNumberInt, char *serialNumberString)
序列号转序列字符
JYDLL_API int STDCALL | JY9802Core_EEPROM_Reset (int card_int, int val=0, int beginAddr=0, int endAddr=1023)
重置

Macro Definition Documentation

◆ CardNotOpened

#define CardNotOpened (ErrorCodeOffset-12)

设置设备信息失败

◆ CCALL

#define CCALL

◆ ErrorAD4249AdjustFailed

#define ErrorAD4249AdjustFailed (ErrorCodeOffset-94)

◆ ErrorAD4249InitFailed

#define ErrorAD4249InitFailed (ErrorCodeOffset-53)

◆ ErrorAD9122AdjustFailed

#define ErrorAD9122AdjustFailed (ErrorCodeOffset-95)

◆ ErrorAD9122ConfigPLLFailed

#define ErrorAD9122ConfigPLLFailed (ErrorCodeOffset-54)

◆ ErrorAD9122PowerOffFailed

#define ErrorAD9122PowerOffFailed (ErrorCodeOffset-84)

◆ ErrorAD9122PowerOnFailed

#define ErrorAD9122PowerOnFailed (ErrorCodeOffset-85)

◆ ErrorAD9517ConfigChannelDividerFailed

#define ErrorAD9517ConfigChannelDividerFailed (ErrorCodeOffset-47)

◆ ErrorAD9517ConfigPLLFailed

#define ErrorAD9517ConfigPLLFailed (ErrorCodeOffset-45)

◆ ErrorAD9517EnableOutputChannel

#define ErrorAD9517EnableOutputChannel (ErrorCodeOffset-96)

◆ ErrorAD9517InitFailed

#define ErrorAD9517InitFailed (ErrorCodeOffset-27)

◆ ErrorAD9517ParamDigitizerNotMatchAWG

#define ErrorAD9517ParamDigitizerNotMatchAWG (ErrorCodeOffset-107)

◆ ErrorAD9517WaitPLLLockFailed

#define ErrorAD9517WaitPLLLockFailed (ErrorCodeOffset-46)

◆ ErrorAliasNameNotMatchSupportedCard

#define ErrorAliasNameNotMatchSupportedCard (ErrorCodeOffset - 122)

◆ ErrorAnalogTriggerConditioningParam

#define ErrorAnalogTriggerConditioningParam (ErrorCodeOffset-26)

模拟触发条件不正确

◆ ErrorAnalogTriggerConfigFailed

#define ErrorAnalogTriggerConfigFailed (ErrorCodeOffset-71)

◆ ErrorAnnalogTriggerParam

#define ErrorAnnalogTriggerParam (ErrorCodeOffset-35)

◆ ErrorAnnalogTriggerThreshold

#define ErrorAnnalogTriggerThreshold (ErrorCodeOffset-36)

◆ ErrorAutoTriggerTimeParam

#define ErrorAutoTriggerTimeParam (ErrorCodeOffset-101)

◆ ErrorAWGChannelDelayParam

#define ErrorAWGChannelDelayParam (ErrorCodeOffset - 111)

◆ ErrorAWGDataSourceParam

#define ErrorAWGDataSourceParam (ErrorCodeOffset-86)

◆ ErrorAWGStartFailed

#define ErrorAWGStartFailed (ErrorCodeOffset-74)

◆ ErrorAWGStopFailed

#define ErrorAWGStopFailed (ErrorCodeOffset-29)

◆ ErrorBasebandModeOnlySupoortCH0

#define ErrorBasebandModeOnlySupoortCH0 (ErrorCodeOffset - 124)

◆ ErrorBITFrequencyParam

#define ErrorBITFrequencyParam (ErrorCodeOffset-87)

◆ ErrorBufferLengthParam

#define ErrorBufferLengthParam (ErrorCodeOffset-40)

◆ ErrorCalcMixerParamFailed

#define ErrorCalcMixerParamFailed (ErrorCodeOffset-44)

◆ ErrorCalcUpDownConverterParaFailed

#define ErrorCalcUpDownConverterParaFailed (ErrorCodeOffset-43)

◆ ErrorCardHasBeenOpened

#define ErrorCardHasBeenOpened (ErrorCodeOffset-6)

◆ ErrorCardNotOpened

#define ErrorCardNotOpened (ErrorCodeOffset-5)

◆ ErrorCardNumberNotExistInDeviceManager

#define ErrorCardNumberNotExistInDeviceManager (ErrorCodeOffset-28)

◆ ErrorCenterFrequencyParam

#define ErrorCenterFrequencyParam (ErrorCodeOffset-78)

◆ ErrorChannelParam

#define ErrorChannelParam (ErrorCodeOffset-20)

通道参数不正确

◆ ErrorClockSource

#define ErrorClockSource (ErrorCodeOffset-14)

不正确的时钟源

◆ ErrorCloseDeviceFailed

#define ErrorCloseDeviceFailed (ErrorCodeOffset-11)

关闭设备失败

◆ ErrorCodeOffset

#define ErrorCodeOffset (int)(-11000)

◆ ErrorCommitAWGFirst

#define ErrorCommitAWGFirst (ErrorCodeOffset-42)

◆ ErrorCommitAWGOrDigitizerFirst

#define ErrorCommitAWGOrDigitizerFirst (ErrorCodeOffset-109)

◆ ErrorCommitDigitizerFirst

#define ErrorCommitDigitizerFirst (ErrorCodeOffset-77)

◆ ErrorConfigDDCFailed

#define ErrorConfigDDCFailed (ErrorCodeOffset-49)

◆ ErrorConfigDUCFailed

#define ErrorConfigDUCFailed (ErrorCodeOffset-51)

◆ ErrorControlLEDSetHighLowTicksFailed

#define ErrorControlLEDSetHighLowTicksFailed (ErrorCodeOffset-99)

◆ ErrorDataSourceSlectFailed

#define ErrorDataSourceSlectFailed (ErrorCodeOffset-81)

◆ ErrorDDCFrequence

#define ErrorDDCFrequence (ErrorCodeOffset-25)

◆ ErrorDDSSignalFreConfigFailed

#define ErrorDDSSignalFreConfigFailed (ErrorCodeOffset-83)

◆ ErrorDigitalTriggerParam

#define ErrorDigitalTriggerParam (ErrorCodeOffset-34)

◆ ErrorDigitialGainParam

#define ErrorDigitialGainParam (ErrorCodeOffset-79)

◆ ErrorDigitizerStartFailed

#define ErrorDigitizerStartFailed (ErrorCodeOffset-37)

◆ ErrorDigitizerStopFailed

#define ErrorDigitizerStopFailed (ErrorCodeOffset-30)

◆ ErrorEEPROMCalCRCFailed

#define ErrorEEPROMCalCRCFailed (ErrorCodeOffset-8)

◆ ErrorExpectedFrequencyParam

#define ErrorExpectedFrequencyParam (ErrorCodeOffset-82)

◆ ErrorExportClkAD9517ParamNotMatch

#define ErrorExportClkAD9517ParamNotMatch (ErrorCodeOffset-110)

◆ ErrorExportSignalCannotRepeatConfig

#define ErrorExportSignalCannotRepeatConfig (ErrorCodeOffset - 114)

◆ ErrorExportSignalConfig

#define ErrorExportSignalConfig (ErrorCodeOffset - 115)

◆ ErrorExportSignalDestinationNotSupport

#define ErrorExportSignalDestinationNotSupport (ErrorCodeOffset - 112)

◆ ErrorExportSignalDestinationReserved

#define ErrorExportSignalDestinationReserved (ErrorCodeOffset - 113)

◆ ErrorGenerationModeParam

#define ErrorGenerationModeParam (ErrorCodeOffset-73)

◆ ErrorGetAcquisitionStatusFailed

#define ErrorGetAcquisitionStatusFailed (ErrorCodeOffset-23)

获取采集状态失败

◆ ErrorGetDDCInputPeakValueFailed

#define ErrorGetDDCInputPeakValueFailed (ErrorCodeOffset-38)

◆ ErrorGetDeviceInfoFailed

#define ErrorGetDeviceInfoFailed (ErrorCodeOffset - 123)

◆ ErrorGetGenerationStatusFailed

#define ErrorGetGenerationStatusFailed (ErrorCodeOffset-75)

◆ ErrorGetTemperatureFailed

#define ErrorGetTemperatureFailed (ErrorCodeOffset-31)

◆ ErrorHoldOffTimeParam

#define ErrorHoldOffTimeParam (ErrorCodeOffset-102)

◆ ErrorInternalError

#define ErrorInternalError (ErrorCodeOffset-7)

◆ ErrorInvalidCalibration

#define ErrorInvalidCalibration (ErrorCodeOffset - 120)

◆ ErrorInvalidParam

#define ErrorInvalidParam (ErrorCodeOffset-2)

◆ ErrorIQTriggerConfigFailed

#define ErrorIQTriggerConfigFailed (ErrorCodeOffset-72)

◆ ErrorNotSupportAWG

#define ErrorNotSupportAWG (ErrorCodeOffset - 118)

◆ ErrorNotSupportDigitizer

#define ErrorNotSupportDigitizer (ErrorCodeOffset - 119)

◆ ErrorOpenDeviceFailed

#define ErrorOpenDeviceFailed (ErrorCodeOffset-10)

打开设备失败

◆ ErrorOSPModeParam

#define ErrorOSPModeParam (ErrorCodeOffset-16)

OSP_Mode参数不正确

◆ ErrorPFICloseFailed

#define ErrorPFICloseFailed (ErrorCodeOffset-98)

◆ ErrorPFIConfigFailed

#define ErrorPFIConfigFailed (ErrorCodeOffset-69)

◆ ErrorPFIInitFailed

#define ErrorPFIInitFailed (ErrorCodeOffset-97)

◆ ErrorPointerNotNull

#define ErrorPointerNotNull (ErrorCodeOffset-24)

指针不能为空

◆ ErrorPreTriggerSamplesParam

#define ErrorPreTriggerSamplesParam (ErrorCodeOffset-21)

预触发点数参数不正确

◆ ErrorReadCalibrationBlockFailed

#define ErrorReadCalibrationBlockFailed (ErrorCodeOffset-93)

◆ ErrorReadDateFailed

#define ErrorReadDateFailed (ErrorCodeOffset-39)

◆ ErrorReadReg

#define ErrorReadReg (ErrorCodeOffset - 117)

◆ ErrorReadRegisterFailed

#define ErrorReadRegisterFailed (ErrorCodeOffset-4)

◆ ErrorResetDDCFailed

#define ErrorResetDDCFailed (ErrorCodeOffset-48)

◆ ErrorResetDUCFailed

#define ErrorResetDUCFailed (ErrorCodeOffset-50)

◆ ErrorReTriggerCountsNotMatchSampleMode

#define ErrorReTriggerCountsNotMatchSampleMode (ErrorCodeOffset-103)

◆ ErrorReTriggerCountsParam

#define ErrorReTriggerCountsParam (ErrorCodeOffset-100)

◆ ErrorRoutingMatrixConfigFailed

#define ErrorRoutingMatrixConfigFailed (ErrorCodeOffset-70)

◆ ErrorRxClearFailed

#define ErrorRxClearFailed (ErrorCodeOffset-55)

◆ ErrorRxCloseFailed

#define ErrorRxCloseFailed (ErrorCodeOffset-88)

◆ ErrorRxConfigAquisitionFailed

#define ErrorRxConfigAquisitionFailed (ErrorCodeOffset-59)

◆ ErrorRxConfigBufferFailed

#define ErrorRxConfigBufferFailed (ErrorCodeOffset-57)

◆ ErrorRxConfigSingleTransferBytesFailed

#define ErrorRxConfigSingleTransferBytesFailed (ErrorCodeOffset-56)

◆ ErrorRxConfigTriggerFailed

#define ErrorRxConfigTriggerFailed (ErrorCodeOffset-61)

◆ ErrorRxEnableHWTriggerFailed

#define ErrorRxEnableHWTriggerFailed (ErrorCodeOffset-60)

◆ ErrorRxInitFailed

#define ErrorRxInitFailed (ErrorCodeOffset-91)

◆ ErrorRxMultiRecordReadFailed

#define ErrorRxMultiRecordReadFailed (ErrorCodeOffset-106)

◆ ErrorRxSetAutoTriggerFailed

#define ErrorRxSetAutoTriggerFailed (ErrorCodeOffset-104)

◆ ErrorRxSetHoldOffTimeFailed

#define ErrorRxSetHoldOffTimeFailed (ErrorCodeOffset-105)

◆ ErrorRxSetParallelModeByteMaskFailed

#define ErrorRxSetParallelModeByteMaskFailed (ErrorCodeOffset-58)

◆ ErrorSampleModeParam

#define ErrorSampleModeParam (ErrorCodeOffset-17)

采样模式参数不正确

◆ ErrorSampleRateParam

#define ErrorSampleRateParam (ErrorCodeOffset-15)

采样率参数不正确

◆ ErrorSamplesParam

#define ErrorSamplesParam (ErrorCodeOffset-22)

有限采样点数，有限或者连续环绕生成点数不正确

◆ ErrorSendSoftwareTriggerFailed

#define ErrorSendSoftwareTriggerFailed (ErrorCodeOffset-80)

◆ ErrorSetDUCInputGainFailed

#define ErrorSetDUCInputGainFailed (ErrorCodeOffset-52)

◆ ErrorSetSampleModeFailed

#define ErrorSetSampleModeFailed (ErrorCodeOffset-18)

采样模式设置失败

◆ ErrorTaskIsStartDonotAllowConfig

#define ErrorTaskIsStartDonotAllowConfig (ErrorCodeOffset-9)

◆ ErrorTimebaseMaster

#define ErrorTimebaseMaster (ErrorCodeOffset-32)

◆ ErrorTimebaseMasterParam

#define ErrorTimebaseMasterParam (ErrorCodeOffset-41)

◆ ErrorTimebaseParam

#define ErrorTimebaseParam (ErrorCodeOffset-33)

◆ ErrorTimeOut

#define ErrorTimeOut (ErrorCodeOffset-13)

超时错误

◆ ErrorTriggerTypeParam

#define ErrorTriggerTypeParam (ErrorCodeOffset-19)

触发类型不正确

◆ ErrorTxClearFailed

#define ErrorTxClearFailed (ErrorCodeOffset-62)

◆ ErrorTxCloseFailed

#define ErrorTxCloseFailed (ErrorCodeOffset-89)

◆ ErrorTxConfigBufferFailed

#define ErrorTxConfigBufferFailed (ErrorCodeOffset-64)

◆ ErrorTxConfigGenerationFailed

#define ErrorTxConfigGenerationFailed (ErrorCodeOffset-66)

◆ ErrorTxConfigOutputStrobelFailed

#define ErrorTxConfigOutputStrobelFailed (ErrorCodeOffset-65)

◆ ErrorTxConfigSingleTransferBytesFailed

#define ErrorTxConfigSingleTransferBytesFailed (ErrorCodeOffset-63)

◆ ErrorTxConfigTriggerFailed

#define ErrorTxConfigTriggerFailed (ErrorCodeOffset-68)

◆ ErrorTxEnableHWTriggerFailed

#define ErrorTxEnableHWTriggerFailed (ErrorCodeOffset-67)

◆ ErrorTxInitFailed

#define ErrorTxInitFailed (ErrorCodeOffset-90)

◆ ErrorTxUnderflow

#define ErrorTxUnderflow (ErrorCodeOffset - 116)

◆ ErrorWarningCalibration

#define ErrorWarningCalibration (ErrorCodeOffset - 121)

◆ ErrorWriteDataFailed

#define ErrorWriteDataFailed (ErrorCodeOffset-76)

◆ ErrorWriteRegisterFailed

#define ErrorWriteRegisterFailed (ErrorCodeOffset-3)

◆ ExportClockFrequencyParam

#define ExportClockFrequencyParam (ErrorCodeOffset-108)

◆ ExternalClockFrequencyParam

#define ExternalClockFrequencyParam (ErrorCodeOffset-92)

◆ JYDLL_API

#define JYDLL_API

◆ JYFailed

#define JYFailed (-1)

◆ JYSuccess

#define JYSuccess (0)

◆ NoError

#define NoError (0)

无错误

◆ STDCALL [1/2]

#define STDCALL

FileName:JY9802Core.h Copyright NOTICE(版权声明) Copyright (c) 2017, JYTek All rights reserved.

Author: fwang @JYTek Version 1.0.0 Date:2017-06-21 Description:9604 Digitizer驱动API定义 History: Merge Digitizer's header by fwang @20170906

Windows Linux

◆ STDCALL [2/2]

#define STDCALL

FileName:JY9802Core.h Copyright NOTICE(版权声明) Copyright (c) 2017, JYTek All rights reserved.

Author: fwang @JYTek Version 1.0.0 Date:2017-06-21 Description:9604 Digitizer驱动API定义 History: Merge Digitizer's header by fwang @20170906

Windows Linux

Typedef Documentation

◆ BYTE

typedef unsigned char BYTE

◆ Handle

typedef void* Handle

◆ UINT64

typedef unsigned long long UINT64

Enumeration Type Documentation

◆ AcquisitionMode

enum AcquisitionMode
Enumerator
Finite_Sample
Continuous_Sample

◆ AnalogTriggerConditioning

enum AnalogTriggerConditioning
Enumerator
AnalogTriggerConditioningPowerHigh
AnalogTriggerConditioningPowerLow
AnalogTriggerConditioningEnteringWindow
AnalogTriggerConditioningLeavingWindow
AnalogTriggerConditioningRising
AnalogTriggerConditioningFalling

◆ AnalogTriggerSource

enum AnalogTriggerSource
Enumerator
AnalogTriggerSourceCH0Raw
AnalogTriggerSourceCH1Raw
AnalogTriggerSourceIQCHO
AnalogTriggerSourceIQCH1

◆ AnalogTriggerType

enum AnalogTriggerType
Enumerator
AnalogHysteresisTrigger
AnalogWindowTrigger
AnalogPowerTrigger

◆ AWGDataSource

enum AWGDataSource
Enumerator
AWGDataSourceBIT
AWGDataSourceDAC

◆ AWGTriggerType

enum AWGTriggerType
Enumerator
ImmediateTrigger
SoftTrigger
DigitalTrigger

◆ ClockSource

enum ClockSource
Enumerator
ExternalClock
InternalClock

◆ DigitalTriggerConditioning

enum DigitalTriggerConditioning
Enumerator
Rising_Edge_Trigger
Falling_Edge_Trigger
High_Level_Trigger
Low_Level_Trigger

◆ DigitalTriggerSource

enum DigitalTriggerSource
Enumerator
TriggerIn
AO_Start_Event
AI_REF_TRIGGER_Event
AI_Start_TRIGGER_Event
AI_Advance_TRIGGER_EVENT
PFI0
PFI1
PFI2
PFI3
PFI4
PFI5
PFI6
PFI7

◆ ExportClockType

enum ExportClockType
Enumerator
None
AISampleClk
AOSampleClk
SpecifiedFrequency

◆ ExportSignalDestination

enum ExportSignalDestination
Enumerator
PFIOut0
PFIOut1
PFIOut2
PFIOut3
PFIOut4
PFIOut5
PFIOut6
PFIOut7
TriggerOut

◆ ExportSignalSource

enum ExportSignalSource
Enumerator
AIReadyForStartTrigger
AIReadyForRefTrigger
AIReadyForAdvanceTrigger
AIStartTrigger
AIRefTrigger0
AIAdvanceTriggerO
AIEndOfRecord
AIEndOfAcquisition
AOReadyForStartTrigger
AOStartTrigger
AOGenerationDone
AIPowerTrigger
AIAnalogTrigger

◆ GenerationMode

enum GenerationMode
Enumerator
Finite
ContinuousWrapping
Stream

◆ OSPMode

enum OSPMode
Enumerator
OSPReal
OSPComplex

◆ PFI_SOURCE_SEL

enum PFI_SOURCE_SEL
Enumerator
TRIGGER_ADDR
GPIO_ADDR

◆ TriggerMode

enum TriggerMode
Enumerator
StartTrigger
ReferenceTrigger
StartAndReferenceTrigger

◆ TriggerType

enum TriggerType
Enumerator
Immediate_Trigger
Soft_Trigger
Digital_Trigger
Analog_Trigger

Function Documentation

◆ JY9802Core_AWG_Commit()

JYDLL_API int STDCALL JY9802Core_AWG_Commit ( int cardID )

提交配置

Parameters
cardID cardID
Returns
成功 0；失败 ：错误码

◆ JY9802Core_AWG_GetChannelDelay()

JYDLL_API int STDCALL JY9802Core_AWG_GetChannelDelay | ( | int | cardID,
 |  | double * | Ch0Delay,
 |  | double * | Ch1Delay )

获取通道时延，commit之后调用此函数有效

Parameters
cardID | cardID
Ch0Delay | 通道0的时延，单位ns
Ch1Delay | 通道1的时延，单位ns
Returns
成功 0；失败 ：错误码

◆ JY9802Core_AWG_GetGenerationStatus()

JYDLL_API int STDCALL JY9802Core_AWG_GetGenerationStatus | ( | int | cardID,
 |  | bool * | complete,
 |  | unsigned long long * | samplesGenerated,
 |  | unsigned int * | availableBufferLength )

获取生成状态

Parameters
cardID | cardID
complete | 是否完成
samplesGenerated | 生成的点数
availableBufferLength | 剩余缓存长度，单位字节
Returns
成功 0；失败 ：错误码

◆ JY9802Core_AWG_GetSampleRate()

JYDLL_API int STDCALL JY9802Core_AWG_GetSampleRate | ( | int | cardID,
 |  | double * | sampleRate )

获取采样率

Parameters
cardID | cardID
sampleRate | 实际的采样率,调用commit之后有效
Returns
成功 0；失败 ：错误码

◆ JY9802Core_AWG_GetTimebase()

JYDLL_API int STDCALL JY9802Core_AWG_GetTimebase | ( | int | cardID,
 |  | double * | actualTimebase )

获取时基

Parameters
cardID | cardID
actualTimebase | 真实的时基，调用commit之后有效
Returns
成功 0；失败 ：错误码

◆ JY9802Core_AWG_Init()

JYDLL_API int STDCALL JY9802Core_AWG_Init ( int cardID )

初始化AO

Parameters
cardID
Returns

<created>yasing,2018/12/17</created> <changed>yasing,2018/12/17</changed>

◆ JY9802Core_AWG_SendSoftwareTrigger()

JYDLL_API int STDCALL JY9802Core_AWG_SendSoftwareTrigger ( int cardID )

AWG发送软件触发

Parameters
cardID cardID
Returns
成功 0；失败 ：错误码

◆ JY9802Core_AWG_SetBasebandModeEnabled()

JYDLL_API int STDCALL JY9802Core_AWG_SetBasebandModeEnabled | ( | int | cardID,
 |  | int | enabled )

设置DDC参数

Parameters
cardID | cardID
enabled | 是否使能基带模式:1使能，0：不使能
Returns
成功 0；失败 ：错误码

◆ JY9802Core_AWG_SetBITFrequency()

JYDLL_API int STDCALL JY9802Core_AWG_SetBITFrequency | ( | int | cardID,
 |  | double | expectedFrequency = 1e6 )

BIT输出信号的频率

Parameters
cardID | cardID
expectedFrequency | BIT期望的输出信号的频率
Returns
成功 0；失败 ：错误码

◆ JY9802Core_AWG_SetBufferLength()

JYDLL_API int STDCALL JY9802Core_AWG_SetBufferLength | ( | int | cardID,
 |  | unsigned int | length )

设置缓冲区大小，连续环绕模式的时候，length必须等于写入数据的字节数

Parameters
cardID cardID

Parameters
length 长度,单位字节，不能超过512M
Returns
成功 0；失败 ：错误码

◆ JY9802Core_AWG_SetCenterFrequency()

JYDLL_API int STDCALL JY9802Core_AWG_SetCenterFrequency | ( | int | cardID,
 |  | int | channelMask,
 |  | double | frequency )

设置DUC的中心频率

Parameters
cardID | cardID
channel | 通道掩码
frequency | 中心频率
Returns
成功 0；失败 ：错误码

◆ JY9802Core_AWG_SetChannelDelay()

JYDLL_API int STDCALL JY9802Core_AWG_SetChannelDelay | ( | int | cardID,
 |  | double | Ch0Delay,
 |  | double | Ch1Delay )

设置通道时延

Parameters
cardID | cardID
Ch0Delay | 通道0的时延，单位ns
Ch1Delay | 通道1的时延，单位ns
Returns
成功 0；失败 ：错误码

◆ JY9802Core_AWG_SetDataSource()

JYDLL_API int STDCALL JY9802Core_AWG_SetDataSource | ( | int | cardID,
 |  | AWGDataSource | dataSource )

设置数据源

Parameters
cardID | cardID
dataSource | 数据源,默认AWGDataSourceDAC
Returns
成功 0；失败 ：错误码

◆ JY9802Core_AWG_SetDigitalGain()

JYDLL_API int STDCALL JY9802Core_AWG_SetDigitalGain | ( | int | cardID,
 |  | int | channelMask,
 |  | double | digitalgain )

设置通道增益

Parameters
cardID | cardID
channel | 通道掩码
frequency | 通道增益
Returns
成功 0；失败 ：错误码

◆ JY9802Core_AWG_SetDigitalTrigger()

JYDLL_API int STDCALL JY9802Core_AWG_SetDigitalTrigger | ( | int | cardID,
 |  | DigitalTriggerConditioning | digitalTriggerType,
 |  | DigitalTriggerSource | digitalTriggerSource )

设置触发类型

Parameters
cardID | cardID
digitalTriggerType | 数字触发类型
digitalTriggerSource | 数字触发源
Returns
成功 0；失败 ：错误码

◆ JY9802Core_AWG_SetEnabledChannels()

JYDLL_API int STDCALL JY9802Core_AWG_SetEnabledChannels | ( | int | cardID,
 |  | int | channelMask )

AWG使能通道

Parameters
cardID | cardID
channelMask | 二进制从低到高表示各通道，-1为所有通道
Returns
成功 0；失败 ：错误码

◆ JY9802Core_AWG_SetEnableInverseSinc()

JYDLL_API int STDCALL JY9802Core_AWG_SetEnableInverseSinc | ( | int | cardID,
 |  | bool | enableInverseSinc = false )

是否使能DA的InverseSinc

Parameters
cardID | cardID
enableInverseSinc | 是否使能DA的InverseSinc，默认否
Returns
成功 0；失败 ：错误码

◆ JY9802Core_AWG_SetGenerationMode()

JYDLL_API int STDCALL JY9802Core_AWG_SetGenerationMode | ( | int | cardID,
 |  | GenerationMode | generationMode )

AWG设置波形生成模式

Parameters
cardID | cardID
generationMode | 波形生成模式
Returns
成功 0；失败 ：错误码

◆ JY9802Core_AWG_SetOSPMode()

JYDLL_API int STDCALL JY9802Core_AWG_SetOSPMode | ( | int | cardID,
 |  | OSPMode | ospMode,
 |  | bool | enableDUC = false )

设置OSP模式

Parameters
cardID | cardID
ospMode | OSP模式
enableDUC | 实数模式下是否使能DUC
Returns
成功 0；失败 ：错误码

◆ JY9802Core_AWG_SetSampleRate()

JYDLL_API int STDCALL JY9802Core_AWG_SetSampleRate | ( | int | cardID,
 |  | double | sampleRate )

设置采样率

Parameters
cardID | cardID
sampleRate | 期望的采样率
Returns
成功 0；失败 ：错误码

◆ JY9802Core_AWG_SetSamplesToWrite()

JYDLL_API int STDCALL JY9802Core_AWG_SetSamplesToWrite | ( | int | cardID,
 |  | int | samplesToWrite )

设置每个通道写入点数，有限点模式和连续环绕模式下有效

Parameters
cardID | cardID
samplesToAcquire | 写入点数
Returns
成功 0；失败 ：错误码

◆ JY9802Core_AWG_SetTimebase()

JYDLL_API int STDCALL JY9802Core_AWG_SetTimebase | ( | int | cardID,
 |  | double | timebaseRate )

设置时基

Parameters
cardID | cardID
timebaseRate | 期望的时基
Returns
成功 0；失败 ：错误码

◆ JY9802Core_AWG_SetTriggerType()

JYDLL_API int STDCALL JY9802Core_AWG_SetTriggerType | ( | int | cardID,
 |  | AWGTriggerType | triggerType )

设置触发类型

Parameters
cardID | cardID
triggerType | 触发类型
Returns
成功 0；失败 ：错误码

◆ JY9802Core_AWG_Start()

JYDLL_API int STDCALL JY9802Core_AWG_Start ( int cardID )

开始

Parameters
cardID cardID
Returns
成功 0；失败 ：错误码

◆ JY9802Core_AWG_Stop()

JYDLL_API int STDCALL JY9802Core_AWG_Stop ( int cardID )

停止

Parameters
cardID cardID
Returns
成功 0；失败 ：错误码

◆ JY9802Core_AWG_WriteDataBinary16()

JYDLL_API int STDCALL JY9802Core_AWG_WriteDataBinary16 | ( | int | cardID,
 |  | short * | dataBuffer,
 |  | unsigned int | samplesToWrite,
 |  | unsigned int * | actualSamples,
 |  | int | timeout )

写数据，需要在commit之后调用此函数

Parameters
cardID cardID

Parameters
dataBuffer | 数据指针
samplesToWrite | 每通道写的点数
timeout | 超时时间
Returns
成功 0；失败 ：错误码

◆ JY9802Core_AWG_WriteDbl64()

JYDLL_API int STDCALL JY9802Core_AWG_WriteDbl64 | ( | int | cardID,
 |  | double * | dataBuffer,
 |  | unsigned int | samplesToWrite,
 |  | unsigned int * | actualSamples,
 |  | int | timeout )

写数据，需要在commit之后调用此函数

Parameters
cardID cardID

Parameters
dataBuffer | 数据指针
samplesToWrite | 每通道写的点数
timeout | 超时时间
Returns
成功 0；失败 ：错误码

◆ JY9802Core_Close()

JYDLL_API int STDCALL JY9802Core_Close ( int cardID )

关闭设备

Parameters
cardID cardID
Returns
成功 0；失败 ：错误码

◆ JY9802Core_Digitizer_Commit()

JYDLL_API int STDCALL JY9802Core_Digitizer_Commit ( int cardID )

提交配置

Parameters
cardID cardID
Returns
成功 0；失败 ：错误码

◆ JY9802Core_Digitizer_EnableLowLatencyDDC()

JYDLL_API int STDCALL JY9802Core_Digitizer_EnableLowLatencyDDC | ( | int | cardID,
 |  | bool | enbaleLowLatencyDDC = false )

是否使能低延时的DDC

Parameters
cardID | cardID
enbaleLowLatencyDDC | 是否使能低延时的DDC，如果使能将只使用CIC，而不使用HB
Returns
成功 0；失败 ：错误码

◆ JY9802Core_Digitizer_GetAcquisitionStatus()

JYDLL_API int STDCALL JY9802Core_Digitizer_GetAcquisitionStatus | ( | int | cardID,
 |  | bool * | isOverFlow,
 |  | unsigned long long * | availableSamples )

获取采集状态，ReTriggerCount=1时有效

Parameters
cardID | cardID
isOverFlow | 是否溢出
availableSamples | 可读取点数
Returns
成功 0；失败 ：错误码

◆ JY9802Core_Digitizer_GetReTriggerStatus()

JYDLL_API int STDCALL JY9802Core_Digitizer_GetReTriggerStatus | ( | int | cardID,
 |  | bool * | isOverFlow,
 |  | unsigned long long * | remainingCounts,
 |  | unsigned long long * | completedCounts )

获取采集状态

Parameters
cardID | cardID
isOverFlow | 是否溢出
remainingCounts | 还未完成的触发次数
completedCounts | 已经完成触发次数
Returns
成功 0；失败 ：错误码

◆ JY9802Core_Digitizer_GetSampleRate()

JYDLL_API int STDCALL JY9802Core_Digitizer_GetSampleRate | ( | int | cardID,
 |  | double * | sampleRate )

获取采样率

Parameters
cardID | cardID
*sampleRate | 实际采样率，调用commit之后有效
Returns
成功 0；失败 ：错误码

◆ JY9802Core_Digitizer_GetTimebase()

JYDLL_API int STDCALL JY9802Core_Digitizer_GetTimebase | ( | int | cardID,
 |  | double * | actualTimebase )

获取时基

Parameters
cardID | cardID
actualTimebase | 真实的时基，调用commit之后有效
Returns
成功 0；失败 ：错误码

◆ JY9802Core_Digitizer_Init()

JYDLL_API int STDCALL JY9802Core_Digitizer_Init ( int cardID )

初始化Digitizer

Parameters
cardID
Returns

<created>yasing,2018/12/17</created> <changed>yasing,2018/12/17</changed>

◆ JY9802Core_Digitizer_ReadDataBinary16()

JYDLL_API int STDCALL JY9802Core_Digitizer_ReadDataBinary16 | ( | int | cardID,
 |  | short * | dataBuffer,
 |  | unsigned int | samplesToRead,
 |  | unsigned int * | actualSamples,
 |  | double * | scaleFactor,
 |  | bool * | isOverLoad,
 |  | int | timeout )

读数据

Parameters
cardID cardID

Parameters
dataBuffer | 数据指针
samplesToRead | 每通道需要读取的点数，使用重触发时，需要读的点数必须是设置的每通道需要采集点数的整数倍
scaleFactor | 量化因子
isOverLoad | ADC是否过载
timeout | 超时时间
Returns
成功 0；失败 ：错误码

◆ JY9802Core_Digitizer_ReadDataDbl64()

JYDLL_API int STDCALL JY9802Core_Digitizer_ReadDataDbl64 | ( | int | cardID,
 |  | double * | dataBuffer,
 |  | unsigned int | samplesToRead,
 |  | int | timeout )

读double数据

Parameters
cardID cardID

Parameters
dataBuffer | 数据指针
samplesToRead | 每通道需要读取的点数
timeout | 超时时间
Returns
成功 0；失败 ：错误码

◆ JY9802Core_Digitizer_SendSoftwareTrigger()

JYDLL_API int STDCALL JY9802Core_Digitizer_SendSoftwareTrigger ( int cardID )

发送软件触发

Parameters
cardID cardID

Returns
成功 0；失败 ：错误码

◆ JY9802Core_Digitizer_SetAcquisitionMode()

JYDLL_API int STDCALL JY9802Core_Digitizer_SetAcquisitionMode | ( | int | cardID,
 |  | AcquisitionMode | acquisitionMode )

设置采集模式

Parameters
cardID | cardID
acquisitionMode | 采集模式,有限点/连续
Returns
成功 0；失败 ：错误码

◆ JY9802Core_Digitizer_SetAnalogTrigger()

JYDLL_API int STDCALL JY9802Core_Digitizer_SetAnalogTrigger | ( | int | cardID,
 |  | AnalogTriggerType | analogTriggerType,
 |  | AnalogTriggerSource | analogTriggerSource,
 |  | AnalogTriggerConditioning | analogTriggerConditioning,
 |  | double | highThreshold,
 |  | double | lowThreshold )

设置模拟触发类型

Parameters
cardID | cardID
analogTriggerType | 触发类型
analogTriggerSource | 触发源
highThreshold | 阈值上限，归一化值,其中 1 对应满量程的正值
lowThreshold | 阈值下限，归一化值，其中 -1 对应满量程的负值
Returns
成功 0；失败 ：错误码

◆ JY9802Core_Digitizer_SetBasebandModeEnabled()

JYDLL_API int STDCALL JY9802Core_Digitizer_SetBasebandModeEnabled | ( | int | cardID,
 |  | int | enabled )

设置DDC参数

Parameters
cardID | cardID
enabled | 是否使能基带模式:1使能，0：不使能
Returns
成功 0；失败 ：错误码

◆ JY9802Core_Digitizer_SetBufferLength()

JYDLL_API int STDCALL JY9802Core_Digitizer_SetBufferLength | ( | int | cardID,
 |  | unsigned int | length )

设置缓冲区大小，ReTriggerCount=1时有效

Parameters
cardID cardID

Parameters
length 长度,单位字节，不能超过512M
Returns
成功 0；失败 ：错误码

◆ JY9802Core_Digitizer_SetDDCParam()

JYDLL_API int STDCALL JY9802Core_Digitizer_SetDDCParam | ( | int | cardID,
 |  | int | channelMask,
 |  | double | frequency,
 |  | int | digitalgain = 0 )

设置DDC参数

Parameters
cardID | cardID
channelMask | 通道掩码
frequency | 中心频率
digitalgain | 数字增益，左移位数
Returns
成功 0；失败 ：错误码

◆ JY9802Core_Digitizer_SetDigitalTrigger()

JYDLL_API int STDCALL JY9802Core_Digitizer_SetDigitalTrigger | ( | int | cardID,
 |  | DigitalTriggerConditioning | digitalTriggerType,
 |  | DigitalTriggerSource | digitalTriggerSource )

设置数字触发类型

Parameters
cardID | cardID
digitalTriggerType | 触发类型
digitalTriggerSource | 触发源
Returns
成功 0；失败 ：错误码

◆ JY9802Core_Digitizer_SetEnabledChannels()

JYDLL_API int STDCALL JY9802Core_Digitizer_SetEnabledChannels | ( | int | cardID,
 |  | int | channelMask )

设置使能通道

Parameters
cardID | cardID
channelMask | 通道掩码，1代表通道0，2代表通道1，3/-1代表双通道
Returns
成功 0；失败 ：错误码

◆ JY9802Core_Digitizer_SetOSPMode()

JYDLL_API int STDCALL JY9802Core_Digitizer_SetOSPMode | ( | int | cardID,
 |  | OSPMode | ospMode,
 |  | bool | enbleDDC = false )

设置OSP模式

Parameters
cardID | cardID
ospMode | OSP模式
enbleDDC | 实数模式下是否使能DDC
Returns
成功 0；失败 ：错误码

◆ JY9802Core_Digitizer_SetPreTriggerSamples()

JYDLL_API int STDCALL JY9802Core_Digitizer_SetPreTriggerSamples | ( | int | cardID,
 |  | unsigned int | preTriggerSamples )

设置预触发点数

Parameters
cardID | cardID
preTriggerSamples | 预触发点数
Returns
成功 0；失败 ：错误码

◆ JY9802Core_Digitizer_SetReTriggerParam()

JYDLL_API int STDCALL JY9802Core_Digitizer_SetReTriggerParam | ( | int | cardID,
 |  | unsigned long long | reTriggerCounts,
 |  | double | autoTriggerTime = -1.0,
 |  | double | holdOffTime = 1 )

设置重触发参数

Parameters
cardID | cardID
reTriggerCounts | 重触发次数
autoTriggerTime | 两个trigger间隔的最大时间，超时之后自动触发，-1为永久等待,单位us
HoldOffTime | 两个trigger间隔的最小时间长度，在HOLD_OFF这段时间内，不允许接收新的trigger信号,单位us
Returns
成功 0；失败 ：错误码

◆ JY9802Core_Digitizer_SetSampleRate()

JYDLL_API int STDCALL JY9802Core_Digitizer_SetSampleRate | ( | int | cardID,
 |  | double | sampleRate )

设置采样率

Parameters
cardID | cardID
sampleRate | 期望的采样率
Returns
成功 0；失败 ：错误码

◆ JY9802Core_Digitizer_SetSamplesToAcquire()

JYDLL_API int STDCALL JY9802Core_Digitizer_SetSamplesToAcquire | ( | int | cardID,
 |  | int | samplesToAcquire )

设置采集点数，有限点模式下有效

Parameters
cardID | cardID
samplesToAcquire | 采集点数
Returns
成功 0；失败 ：错误码

◆ JY9802Core_Digitizer_SetTimebase()

JYDLL_API int STDCALL JY9802Core_Digitizer_SetTimebase | ( | int | cardID,
 |  | double | timebaseRate )

设置时基

Parameters
cardID | cardID
timebaseRate | 期望的时基
Returns
成功 0；失败 ：错误码

◆ JY9802Core_Digitizer_SetTriggerType()

JYDLL_API int STDCALL JY9802Core_Digitizer_SetTriggerType | ( | int | cardID,
 |  | TriggerType | triggerType )

设置触发类型

Parameters
cardID | cardID
triggerType | 触发类型：立即触发、软件触发、数字触发、模拟触发
Returns
成功 0；失败 ：错误码

◆ JY9802Core_Digitizer_Start()

JYDLL_API int STDCALL JY9802Core_Digitizer_Start ( int cardID )

开始

Parameters
cardID cardID
Returns
成功 0；失败 ：错误码

◆ JY9802Core_Digitizer_Stop()

JYDLL_API int STDCALL JY9802Core_Digitizer_Stop ( int cardID )

停止

Parameters
cardID cardID
Returns
成功 0；失败 ：错误码

◆ JY9802Core_Digitizer_WaitForAcqComplete()

JYDLL_API int STDCALL JY9802Core_Digitizer_WaitForAcqComplete | ( | int | cardID,
 |  | int | timeout,
 |  | bool * | complete )

获取采集状态，有限点，ReTriggerCount=1时有效

Parameters
cardID | cardID
timeout | 超时
complete | 是否完成采集
Returns
成功 0；失败 ：错误码

◆ JY9802Core_EEPROM_InitializeCalibrationBlock()

JYDLL_API int STDCALL JY9802Core_EEPROM_InitializeCalibrationBlock ( int card_int )

初始化CalibrationBlock

Parameters
card_int cardID
Returns
成功 0；失败 ：错误码

◆ JY9802Core_EEPROM_InitializeIdBlock()

JYDLL_API int STDCALL JY9802Core_EEPROM_InitializeIdBlock ( int card_int )

初始化IdBlock

Parameters
card_int cardID
Returns
成功 0；失败 ：错误码

◆ JY9802Core_EEPROM_ReadCalibrationBlock()

JYDLL_API int STDCALL JY9802Core_EEPROM_ReadCalibrationBlock | ( | int | card_int,
 |  | JY9802CoreCalibrationInfo * | cb )

读EEPROMCalibrationBlock

Parameters
card_int | cardID
EEPROMCalibrationBlock | EEPROMCalibrationBlock
Returns
成功 0；失败 ：错误码

◆ JY9802Core_EEPROM_ReadIdBlock()

JYDLL_API int STDCALL JY9802Core_EEPROM_ReadIdBlock | ( | int | card_int,
 |  | JY9802CoreDeviceInfo * | id )

读EEPROMIdBlock

Parameters
card_int | cardID
EEPROMIdBlock | EEPROMIdBlock
Returns
成功 0；失败 ：错误码

◆ JY9802Core_EEPROM_Reset()

JYDLL_API int STDCALL JY9802Core_EEPROM_Reset | ( | int | card_int,
 |  | int | val = 0,
 |  | int | beginAddr = 0,
 |  | int | endAddr = 1023 )

重置

Parameters
card_int | cardID
val | val
beginAddr | beginAddr
endAddr | endAddr
Returns
成功 0；失败 ：错误码

◆ JY9802Core_EEPROM_SerialNumber_Int2String()

JYDLL_API int STDCALL JY9802Core_EEPROM_SerialNumber_Int2String | ( | int | serialNumberInt,
 |  | char * | serialNumberString )

序列号转序列字符

Parameters
card_int | cardID
serialNumberInt | serialNumberInt
serialNumberString | serialNumberString
Returns
成功 0；失败 ：错误码

◆ JY9802Core_EEPROM_SerialNumber_String2Int()

JYDLL_API int STDCALL JY9802Core_EEPROM_SerialNumber_String2Int | ( | const char *const | serialNumberString,
 |  | int * | serialNumberInt )

序列字符转序列号

Parameters
card_int | cardID
serialNumberString | serialNumberString
serialNumberInt | serialNumberInt
Returns
成功 0；失败 ：错误码

◆ JY9802Core_EEPROM_WriteCalibrationBlock()

JYDLL_API int STDCALL JY9802Core_EEPROM_WriteCalibrationBlock | ( | int | card_int,
 |  | JY9802CoreCalibrationInfo * | cb )

写EEPROMCalibrationBlock

Parameters
card_int | cardID
EEPROMCalibrationBlock | EEPROMCalibrationBlock
Returns
成功 0；失败 ：错误码

◆ JY9802Core_EEPROM_WriteIdBlock()

JYDLL_API int STDCALL JY9802Core_EEPROM_WriteIdBlock | ( | int | card_int,
 |  | JY9802CoreDeviceInfo * | id )

写EEPROMIdBlock

Parameters
card_int | cardID
EEPROMIdBlock | EEPROMIdBlock
Returns
成功 0；失败 ：错误码

◆ JY9802Core_ExportClock()

JYDLL_API int STDCALL JY9802Core_ExportClock | ( | int | cardID,
 |  | ExportClockType | exportClockType,
 |  | double | expectedFrequency = 10e6 )

导出时钟到Ref_Out

Parameters
cardID | cardID
exportClockType | 导出时钟的类型
expectedFrequency | 期望的频率，ExportClockType为SpecifiedFrequency时，有效
Returns
成功 0；失败 ：错误码

◆ JY9802Core_ExportSignal()

JYDLL_API int STDCALL JY9802Core_ExportSignal | ( | int | cardID,
 |  | ExportSignalSource | source,
 |  | ExportSignalDestination | destination )

导出信号配置

Parameters
cardID | cardID
source | 导出信号的源
destination | 导出信号的目标端口
Returns
成功 0；失败 ：错误码

◆ JY9802Core_GetCardAbility()

JYDLL_API int STDCALL JY9802Core_GetCardAbility | ( | int | cardID,
 |  | CARD_ABILITY * | cardAbility )

获取当前卡具备的能力

Parameters
cardID cardID
cardAbility
Returns
成功 0；失败 ：错误码

<created>yasing,2018/12/17</created> <changed>yasing,2018/12/17</changed>

◆ JY9802Core_GetDeviceList()

JYDLL_API int STDCALL JY9802Core_GetDeviceList | ( | JY9802DeviceInfo | deviceInfo[],
 |  | int | deviceInfoLength )

获取所有设备

Parameters
deviceInfo | 卡槽号
deviceInfoLength | cardID
Returns
成功 0；失败 ：错误码

◆ JY9802Core_GetLastError()

JYDLL_API int STDCALL JY9802Core_GetLastError | ( | int | cardID,
 |  | char * | message,
 |  | int * | errorCode )

获取最后一条错误信息

Parameters
cardID | cardID
message | 最后一条错误信息
errorCode | 错误信息对应的错误码
Returns
大于等于0：错误信息字符串的长度；小于零：错误代码

◆ JY9802Core_GetTemperature()

JYDLL_API int STDCALL JY9802Core_GetTemperature | ( | int | cardID,
 |  | double * | CardTemp,
 |  | double * | fpgaTemp = NULL )

获取板卡温度

Parameters
cardID | cardID
CardTemp | 板卡温度传感器温度
fpgaTem | FPGA芯片内部温度
Returns
成功 0；失败 ：错误码

<created>yasing,2019/5/8</created> <changed>yasing,2019/5/8</changed>

◆ JY9802Core_Open()

JYDLL_API int STDCALL JY9802Core_Open | ( | int | slotNumber,
 |  | int * | cardID )

打开设备

Parameters
slotNumber | 卡槽号
cardID | cardID
Returns
成功 0；失败 ：错误码

◆ JY9802Core_Open_WithAliasName()

JYDLL_API int STDCALL JY9802Core_Open_WithAliasName | ( | const char * | aliasName,
 |  | int * | cardID )

打开设备

Parameters
aliasName | 设备别名
cardID | cardID
Returns
成功 0；失败 ：错误码

◆ JY9802Core_SetClockSource()

JYDLL_API int STDCALL JY9802Core_SetClockSource | ( | int | cardID,
 |  | ClockSource | clockSource )

选择时钟源,默认内部时钟

Parameters
cardID | cardID
clockSource | 时钟源
Returns
成功 0；失败 ：错误码

◆ JY9802Core_SetExternalReferenceClockFrequency()

JYDLL_API int STDCALL JY9802Core_SetExternalReferenceClockFrequency | ( | int | cardID,
 |  | double | frequency = 10e6 )

设置外参考时钟的频率

Parameters
cardID | cardID
frequency | 频率
Returns
成功 0；失败 ：错误码
Generated by doxygen 1.12.0


9802 C++ Programming Manual: Class List

  • Class List
  • Class Index
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
C CARD_ABILITY
C JY9802CoreCalibrationConstant
C JY9802CoreCalibrationInfo
C JY9802CoreDeviceInfo
C JY9802DeviceInfo


9802 C++ Programming Manual: Class Index

  • Class List
  • Class Index
  • Class Members
Class Index
C | J
C
CARD_ABILITY
J
JY9802CoreCalibrationConstant
JY9802CoreCalibrationInfo
JY9802CoreDeviceInfo
JY9802DeviceInfo


9802 C++ Programming Manual: D:/9802 Directory Reference

  • 9802
9802 Directory Reference

Directories

C++


9802 C++ Programming Manual: D:/9802/C++ Directory Reference

  • 9802
  • C++
C++ Directory Reference

Files

JY9802Core.h


9802 C++ Programming Manual: File List

File List
Here is a list of all files with brief descriptions:
[detail level 123]
▼ 9802
▼ C++
JY9802Core.h


9802 C++ Programming Manual: Class Members

  • Class List
  • Class Index
  • Class Members
  • All
  • Variables
  • a
  • c
  • d
  • e
  • f
  • h
  • m
  • p
  • r
  • s
Here is a list of all class members with links to the classes they belong to:

- a -

  • AI_CH0_b : JY9802CoreCalibrationConstant
  • AI_CH0_k : JY9802CoreCalibrationConstant
  • AI_CH1_b : JY9802CoreCalibrationConstant
  • AI_CH1_k : JY9802CoreCalibrationConstant
  • aliasName : JY9802DeviceInfo
  • AO_CH0_b : JY9802CoreCalibrationConstant
  • AO_CH0_FS_mA : JY9802CoreCalibrationConstant
  • AO_CH0_k : JY9802CoreCalibrationConstant
  • AO_CH1_b : JY9802CoreCalibrationConstant
  • AO_CH1_FS_mA : JY9802CoreCalibrationConstant
  • AO_CH1_k : JY9802CoreCalibrationConstant
  • AWG_AVAILIABLE : CARD_ABILITY

- c -

  • CalibrationAddr : JY9802CoreDeviceInfo
  • CalibrationTemperature : JY9802CoreCalibrationInfo
  • CalibrationTimeStamp : JY9802CoreCalibrationInfo
  • ConstantList : JY9802CoreCalibrationInfo
  • ConstantListSize : JY9802CoreCalibrationInfo
  • CRC16 : JY9802CoreCalibrationInfo

- d -

  • DIGITIZER_AVAILIABLE : CARD_ABILITY
  • DriverSetVer : JY9802DeviceInfo

- e -

  • EEPROMSize : JY9802CoreDeviceInfo

- f -

  • FirmwareVer : JY9802DeviceInfo
  • FrameworkVer : JY9802DeviceInfo

- h -

  • HardwareVer : JY9802DeviceInfo
  • HWRev : JY9802CoreDeviceInfo

- m -

  • Model : JY9802CoreDeviceInfo
  • model : JY9802DeviceInfo

- p -

  • ProductionDate : JY9802CoreDeviceInfo, JY9802DeviceInfo

- r -

  • Reserved : JY9802CoreDeviceInfo

- s -

  • SerialNumber : JY9802CoreDeviceInfo
  • serialNumber : JY9802DeviceInfo
  • slotNumber : JY9802DeviceInfo
  • StartSentinel : JY9802CoreDeviceInfo


9802 C++ Programming Manual: Class Members - Variables

  • Class List
  • Class Index
  • Class Members
  • All
  • Variables
  • a
  • c
  • d
  • e
  • f
  • h
  • m
  • p
  • r
  • s
Here is a list of all variables with links to the classes they belong to:

- a -

  • AI_CH0_b : JY9802CoreCalibrationConstant
  • AI_CH0_k : JY9802CoreCalibrationConstant
  • AI_CH1_b : JY9802CoreCalibrationConstant
  • AI_CH1_k : JY9802CoreCalibrationConstant
  • aliasName : JY9802DeviceInfo
  • AO_CH0_b : JY9802CoreCalibrationConstant
  • AO_CH0_FS_mA : JY9802CoreCalibrationConstant
  • AO_CH0_k : JY9802CoreCalibrationConstant
  • AO_CH1_b : JY9802CoreCalibrationConstant
  • AO_CH1_FS_mA : JY9802CoreCalibrationConstant
  • AO_CH1_k : JY9802CoreCalibrationConstant
  • AWG_AVAILIABLE : CARD_ABILITY

- c -

  • CalibrationAddr : JY9802CoreDeviceInfo
  • CalibrationTemperature : JY9802CoreCalibrationInfo
  • CalibrationTimeStamp : JY9802CoreCalibrationInfo
  • ConstantList : JY9802CoreCalibrationInfo
  • ConstantListSize : JY9802CoreCalibrationInfo
  • CRC16 : JY9802CoreCalibrationInfo

- d -

  • DIGITIZER_AVAILIABLE : CARD_ABILITY
  • DriverSetVer : JY9802DeviceInfo

- e -

  • EEPROMSize : JY9802CoreDeviceInfo

- f -

  • FirmwareVer : JY9802DeviceInfo
  • FrameworkVer : JY9802DeviceInfo

- h -

  • HardwareVer : JY9802DeviceInfo
  • HWRev : JY9802CoreDeviceInfo

- m -

  • Model : JY9802CoreDeviceInfo
  • model : JY9802DeviceInfo

- p -

  • ProductionDate : JY9802CoreDeviceInfo, JY9802DeviceInfo

- r -

  • Reserved : JY9802CoreDeviceInfo

- s -

  • SerialNumber : JY9802CoreDeviceInfo
  • serialNumber : JY9802DeviceInfo
  • slotNumber : JY9802DeviceInfo
  • StartSentinel : JY9802CoreDeviceInfo


9802 C++ Programming Manual: File Members

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
  • u
Here is a list of all file members with links to the files they belong to:

- a -

  • AcquisitionMode : JY9802Core.h
  • AI_Advance_TRIGGER_EVENT : JY9802Core.h
  • AI_REF_TRIGGER_Event : JY9802Core.h
  • AI_Start_TRIGGER_Event : JY9802Core.h
  • AIAdvanceTriggerO : JY9802Core.h
  • AIAnalogTrigger : JY9802Core.h
  • AIEndOfAcquisition : JY9802Core.h
  • AIEndOfRecord : JY9802Core.h
  • AIPowerTrigger : JY9802Core.h
  • AIReadyForAdvanceTrigger : JY9802Core.h
  • AIReadyForRefTrigger : JY9802Core.h
  • AIReadyForStartTrigger : JY9802Core.h
  • AIRefTrigger0 : JY9802Core.h
  • AISampleClk : JY9802Core.h
  • AIStartTrigger : JY9802Core.h
  • Analog_Trigger : JY9802Core.h
  • AnalogHysteresisTrigger : JY9802Core.h
  • AnalogPowerTrigger : JY9802Core.h
  • AnalogTriggerConditioning : JY9802Core.h
  • AnalogTriggerConditioningEnteringWindow : JY9802Core.h
  • AnalogTriggerConditioningFalling : JY9802Core.h
  • AnalogTriggerConditioningLeavingWindow : JY9802Core.h
  • AnalogTriggerConditioningPowerHigh : JY9802Core.h
  • AnalogTriggerConditioningPowerLow : JY9802Core.h
  • AnalogTriggerConditioningRising : JY9802Core.h
  • AnalogTriggerSource : JY9802Core.h
  • AnalogTriggerSourceCH0Raw : JY9802Core.h
  • AnalogTriggerSourceCH1Raw : JY9802Core.h
  • AnalogTriggerSourceIQCH1 : JY9802Core.h
  • AnalogTriggerSourceIQCHO : JY9802Core.h
  • AnalogTriggerType : JY9802Core.h
  • AnalogWindowTrigger : JY9802Core.h
  • AO_Start_Event : JY9802Core.h
  • AOGenerationDone : JY9802Core.h
  • AOReadyForStartTrigger : JY9802Core.h
  • AOSampleClk : JY9802Core.h
  • AOStartTrigger : JY9802Core.h
  • AWGDataSource : JY9802Core.h
  • AWGDataSourceBIT : JY9802Core.h
  • AWGDataSourceDAC : JY9802Core.h
  • AWGTriggerType : JY9802Core.h


  • Enumerations
  • Enumerator
  • Macros
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
  • u
Here is a list of all file members with links to the files they belong to:

- b -

  • BYTE : JY9802Core.h


  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
  • u
Here is a list of all file members with links to the files they belong to:

- c -

  • CardNotOpened : JY9802Core.h
  • CCALL : JY9802Core.h
  • ClockSource : JY9802Core.h
  • Continuous_Sample : JY9802Core.h
  • ContinuousWrapping : JY9802Core.h


  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
  • u
Here is a list of all file members with links to the files they belong to:

- d -

  • Digital_Trigger : JY9802Core.h
  • DigitalTrigger : JY9802Core.h
  • DigitalTriggerConditioning : JY9802Core.h
  • DigitalTriggerSource : JY9802Core.h


  • c
  • e
  • j
  • n
  • s
Here is a list of all macros with links to the files they belong to:

- c -

  • CardNotOpened : JY9802Core.h
  • CCALL : JY9802Core.h

- e -

  • ErrorAD4249AdjustFailed : JY9802Core.h
  • ErrorAD4249InitFailed : JY9802Core.h
  • ErrorAD9122AdjustFailed : JY9802Core.h
  • ErrorAD9122ConfigPLLFailed : JY9802Core.h
  • ErrorAD9122PowerOffFailed : JY9802Core.h
  • ErrorAD9122PowerOnFailed : JY9802Core.h
  • ErrorAD9517ConfigChannelDividerFailed : JY9802Core.h
  • ErrorAD9517ConfigPLLFailed : JY9802Core.h
  • ErrorAD9517EnableOutputChannel : JY9802Core.h
  • ErrorAD9517InitFailed : JY9802Core.h
  • ErrorAD9517ParamDigitizerNotMatchAWG : JY9802Core.h
  • ErrorAD9517WaitPLLLockFailed : JY9802Core.h
  • ErrorAliasNameNotMatchSupportedCard : JY9802Core.h
  • ErrorAnalogTriggerConditioningParam : JY9802Core.h
  • ErrorAnalogTriggerConfigFailed : JY9802Core.h
  • ErrorAnnalogTriggerParam : JY9802Core.h
  • ErrorAnnalogTriggerThreshold : JY9802Core.h
  • ErrorAutoTriggerTimeParam : JY9802Core.h
  • ErrorAWGChannelDelayParam : JY9802Core.h
  • ErrorAWGDataSourceParam : JY9802Core.h
  • ErrorAWGStartFailed : JY9802Core.h
  • ErrorAWGStopFailed : JY9802Core.h
  • ErrorBasebandModeOnlySupoortCH0 : JY9802Core.h
  • ErrorBITFrequencyParam : JY9802Core.h
  • ErrorBufferLengthParam : JY9802Core.h
  • ErrorCalcMixerParamFailed : JY9802Core.h
  • ErrorCalcUpDownConverterParaFailed : JY9802Core.h
  • ErrorCardHasBeenOpened : JY9802Core.h
  • ErrorCardNotOpened : JY9802Core.h
  • ErrorCardNumberNotExistInDeviceManager : JY9802Core.h
  • ErrorCenterFrequencyParam : JY9802Core.h
  • ErrorChannelParam : JY9802Core.h
  • ErrorClockSource : JY9802Core.h
  • ErrorCloseDeviceFailed : JY9802Core.h
  • ErrorCodeOffset : JY9802Core.h
  • ErrorCommitAWGFirst : JY9802Core.h
  • ErrorCommitAWGOrDigitizerFirst : JY9802Core.h
  • ErrorCommitDigitizerFirst : JY9802Core.h
  • ErrorConfigDDCFailed : JY9802Core.h
  • ErrorConfigDUCFailed : JY9802Core.h
  • ErrorControlLEDSetHighLowTicksFailed : JY9802Core.h
  • ErrorDataSourceSlectFailed : JY9802Core.h
  • ErrorDDCFrequence : JY9802Core.h
  • ErrorDDSSignalFreConfigFailed : JY9802Core.h
  • ErrorDigitalTriggerParam : JY9802Core.h
  • ErrorDigitialGainParam : JY9802Core.h
  • ErrorDigitizerStartFailed : JY9802Core.h
  • ErrorDigitizerStopFailed : JY9802Core.h
  • ErrorEEPROMCalCRCFailed : JY9802Core.h
  • ErrorExpectedFrequencyParam : JY9802Core.h
  • ErrorExportClkAD9517ParamNotMatch : JY9802Core.h
  • ErrorExportSignalCannotRepeatConfig : JY9802Core.h
  • ErrorExportSignalConfig : JY9802Core.h
  • ErrorExportSignalDestinationNotSupport : JY9802Core.h
  • ErrorExportSignalDestinationReserved : JY9802Core.h
  • ErrorGenerationModeParam : JY9802Core.h
  • ErrorGetAcquisitionStatusFailed : JY9802Core.h
  • ErrorGetDDCInputPeakValueFailed : JY9802Core.h
  • ErrorGetDeviceInfoFailed : JY9802Core.h
  • ErrorGetGenerationStatusFailed : JY9802Core.h
  • ErrorGetTemperatureFailed : JY9802Core.h
  • ErrorHoldOffTimeParam : JY9802Core.h
  • ErrorInternalError : JY9802Core.h
  • ErrorInvalidCalibration : JY9802Core.h
  • ErrorInvalidParam : JY9802Core.h
  • ErrorIQTriggerConfigFailed : JY9802Core.h
  • ErrorNotSupportAWG : JY9802Core.h
  • ErrorNotSupportDigitizer : JY9802Core.h
  • ErrorOpenDeviceFailed : JY9802Core.h
  • ErrorOSPModeParam : JY9802Core.h
  • ErrorPFICloseFailed : JY9802Core.h
  • ErrorPFIConfigFailed : JY9802Core.h
  • ErrorPFIInitFailed : JY9802Core.h
  • ErrorPointerNotNull : JY9802Core.h
  • ErrorPreTriggerSamplesParam : JY9802Core.h
  • ErrorReadCalibrationBlockFailed : JY9802Core.h
  • ErrorReadDateFailed : JY9802Core.h
  • ErrorReadReg : JY9802Core.h
  • ErrorReadRegisterFailed : JY9802Core.h
  • ErrorResetDDCFailed : JY9802Core.h
  • ErrorResetDUCFailed : JY9802Core.h
  • ErrorReTriggerCountsNotMatchSampleMode : JY9802Core.h
  • ErrorReTriggerCountsParam : JY9802Core.h
  • ErrorRoutingMatrixConfigFailed : JY9802Core.h
  • ErrorRxClearFailed : JY9802Core.h
  • ErrorRxCloseFailed : JY9802Core.h
  • ErrorRxConfigAquisitionFailed : JY9802Core.h
  • ErrorRxConfigBufferFailed : JY9802Core.h
  • ErrorRxConfigSingleTransferBytesFailed : JY9802Core.h
  • ErrorRxConfigTriggerFailed : JY9802Core.h
  • ErrorRxEnableHWTriggerFailed : JY9802Core.h
  • ErrorRxInitFailed : JY9802Core.h
  • ErrorRxMultiRecordReadFailed : JY9802Core.h
  • ErrorRxSetAutoTriggerFailed : JY9802Core.h
  • ErrorRxSetHoldOffTimeFailed : JY9802Core.h
  • ErrorRxSetParallelModeByteMaskFailed : JY9802Core.h
  • ErrorSampleModeParam : JY9802Core.h
  • ErrorSampleRateParam : JY9802Core.h
  • ErrorSamplesParam : JY9802Core.h
  • ErrorSendSoftwareTriggerFailed : JY9802Core.h
  • ErrorSetDUCInputGainFailed : JY9802Core.h
  • ErrorSetSampleModeFailed : JY9802Core.h
  • ErrorTaskIsStartDonotAllowConfig : JY9802Core.h
  • ErrorTimebaseMaster : JY9802Core.h
  • ErrorTimebaseMasterParam : JY9802Core.h
  • ErrorTimebaseParam : JY9802Core.h
  • ErrorTimeOut : JY9802Core.h
  • ErrorTriggerTypeParam : JY9802Core.h
  • ErrorTxClearFailed : JY9802Core.h
  • ErrorTxCloseFailed : JY9802Core.h
  • ErrorTxConfigBufferFailed : JY9802Core.h
  • ErrorTxConfigGenerationFailed : JY9802Core.h
  • ErrorTxConfigOutputStrobelFailed : JY9802Core.h
  • ErrorTxConfigSingleTransferBytesFailed : JY9802Core.h
  • ErrorTxConfigTriggerFailed : JY9802Core.h
  • ErrorTxEnableHWTriggerFailed : JY9802Core.h
  • ErrorTxInitFailed : JY9802Core.h
  • ErrorTxUnderflow : JY9802Core.h
  • ErrorWarningCalibration : JY9802Core.h
  • ErrorWriteDataFailed : JY9802Core.h
  • ErrorWriteRegisterFailed : JY9802Core.h
  • ExportClockFrequencyParam : JY9802Core.h
  • ExternalClockFrequencyParam : JY9802Core.h

- j -

  • JYDLL_API : JY9802Core.h
  • JYFailed : JY9802Core.h
  • JYSuccess : JY9802Core.h

- n -

  • NoError : JY9802Core.h

- s -

  • STDCALL : JY9802Core.h


  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
  • u
Here is a list of all file members with links to the files they belong to:

- e -

  • ErrorAD4249AdjustFailed : JY9802Core.h
  • ErrorAD4249InitFailed : JY9802Core.h
  • ErrorAD9122AdjustFailed : JY9802Core.h
  • ErrorAD9122ConfigPLLFailed : JY9802Core.h
  • ErrorAD9122PowerOffFailed : JY9802Core.h
  • ErrorAD9122PowerOnFailed : JY9802Core.h
  • ErrorAD9517ConfigChannelDividerFailed : JY9802Core.h
  • ErrorAD9517ConfigPLLFailed : JY9802Core.h
  • ErrorAD9517EnableOutputChannel : JY9802Core.h
  • ErrorAD9517InitFailed : JY9802Core.h
  • ErrorAD9517ParamDigitizerNotMatchAWG : JY9802Core.h
  • ErrorAD9517WaitPLLLockFailed : JY9802Core.h
  • ErrorAliasNameNotMatchSupportedCard : JY9802Core.h
  • ErrorAnalogTriggerConditioningParam : JY9802Core.h
  • ErrorAnalogTriggerConfigFailed : JY9802Core.h
  • ErrorAnnalogTriggerParam : JY9802Core.h
  • ErrorAnnalogTriggerThreshold : JY9802Core.h
  • ErrorAutoTriggerTimeParam : JY9802Core.h
  • ErrorAWGChannelDelayParam : JY9802Core.h
  • ErrorAWGDataSourceParam : JY9802Core.h
  • ErrorAWGStartFailed : JY9802Core.h
  • ErrorAWGStopFailed : JY9802Core.h
  • ErrorBasebandModeOnlySupoortCH0 : JY9802Core.h
  • ErrorBITFrequencyParam : JY9802Core.h
  • ErrorBufferLengthParam : JY9802Core.h
  • ErrorCalcMixerParamFailed : JY9802Core.h
  • ErrorCalcUpDownConverterParaFailed : JY9802Core.h
  • ErrorCardHasBeenOpened : JY9802Core.h
  • ErrorCardNotOpened : JY9802Core.h
  • ErrorCardNumberNotExistInDeviceManager : JY9802Core.h
  • ErrorCenterFrequencyParam : JY9802Core.h
  • ErrorChannelParam : JY9802Core.h
  • ErrorClockSource : JY9802Core.h
  • ErrorCloseDeviceFailed : JY9802Core.h
  • ErrorCodeOffset : JY9802Core.h
  • ErrorCommitAWGFirst : JY9802Core.h
  • ErrorCommitAWGOrDigitizerFirst : JY9802Core.h
  • ErrorCommitDigitizerFirst : JY9802Core.h
  • ErrorConfigDDCFailed : JY9802Core.h
  • ErrorConfigDUCFailed : JY9802Core.h
  • ErrorControlLEDSetHighLowTicksFailed : JY9802Core.h
  • ErrorDataSourceSlectFailed : JY9802Core.h
  • ErrorDDCFrequence : JY9802Core.h
  • ErrorDDSSignalFreConfigFailed : JY9802Core.h
  • ErrorDigitalTriggerParam : JY9802Core.h
  • ErrorDigitialGainParam : JY9802Core.h
  • ErrorDigitizerStartFailed : JY9802Core.h
  • ErrorDigitizerStopFailed : JY9802Core.h
  • ErrorEEPROMCalCRCFailed : JY9802Core.h
  • ErrorExpectedFrequencyParam : JY9802Core.h
  • ErrorExportClkAD9517ParamNotMatch : JY9802Core.h
  • ErrorExportSignalCannotRepeatConfig : JY9802Core.h
  • ErrorExportSignalConfig : JY9802Core.h
  • ErrorExportSignalDestinationNotSupport : JY9802Core.h
  • ErrorExportSignalDestinationReserved : JY9802Core.h
  • ErrorGenerationModeParam : JY9802Core.h
  • ErrorGetAcquisitionStatusFailed : JY9802Core.h
  • ErrorGetDDCInputPeakValueFailed : JY9802Core.h
  • ErrorGetDeviceInfoFailed : JY9802Core.h
  • ErrorGetGenerationStatusFailed : JY9802Core.h
  • ErrorGetTemperatureFailed : JY9802Core.h
  • ErrorHoldOffTimeParam : JY9802Core.h
  • ErrorInternalError : JY9802Core.h
  • ErrorInvalidCalibration : JY9802Core.h
  • ErrorInvalidParam : JY9802Core.h
  • ErrorIQTriggerConfigFailed : JY9802Core.h
  • ErrorNotSupportAWG : JY9802Core.h
  • ErrorNotSupportDigitizer : JY9802Core.h
  • ErrorOpenDeviceFailed : JY9802Core.h
  • ErrorOSPModeParam : JY9802Core.h
  • ErrorPFICloseFailed : JY9802Core.h
  • ErrorPFIConfigFailed : JY9802Core.h
  • ErrorPFIInitFailed : JY9802Core.h
  • ErrorPointerNotNull : JY9802Core.h
  • ErrorPreTriggerSamplesParam : JY9802Core.h
  • ErrorReadCalibrationBlockFailed : JY9802Core.h
  • ErrorReadDateFailed : JY9802Core.h
  • ErrorReadReg : JY9802Core.h
  • ErrorReadRegisterFailed : JY9802Core.h
  • ErrorResetDDCFailed : JY9802Core.h
  • ErrorResetDUCFailed : JY9802Core.h
  • ErrorReTriggerCountsNotMatchSampleMode : JY9802Core.h
  • ErrorReTriggerCountsParam : JY9802Core.h
  • ErrorRoutingMatrixConfigFailed : JY9802Core.h
  • ErrorRxClearFailed : JY9802Core.h
  • ErrorRxCloseFailed : JY9802Core.h
  • ErrorRxConfigAquisitionFailed : JY9802Core.h
  • ErrorRxConfigBufferFailed : JY9802Core.h
  • ErrorRxConfigSingleTransferBytesFailed : JY9802Core.h
  • ErrorRxConfigTriggerFailed : JY9802Core.h
  • ErrorRxEnableHWTriggerFailed : JY9802Core.h
  • ErrorRxInitFailed : JY9802Core.h
  • ErrorRxMultiRecordReadFailed : JY9802Core.h
  • ErrorRxSetAutoTriggerFailed : JY9802Core.h
  • ErrorRxSetHoldOffTimeFailed : JY9802Core.h
  • ErrorRxSetParallelModeByteMaskFailed : JY9802Core.h
  • ErrorSampleModeParam : JY9802Core.h
  • ErrorSampleRateParam : JY9802Core.h
  • ErrorSamplesParam : JY9802Core.h
  • ErrorSendSoftwareTriggerFailed : JY9802Core.h
  • ErrorSetDUCInputGainFailed : JY9802Core.h
  • ErrorSetSampleModeFailed : JY9802Core.h
  • ErrorTaskIsStartDonotAllowConfig : JY9802Core.h
  • ErrorTimebaseMaster : JY9802Core.h
  • ErrorTimebaseMasterParam : JY9802Core.h
  • ErrorTimebaseParam : JY9802Core.h
  • ErrorTimeOut : JY9802Core.h
  • ErrorTriggerTypeParam : JY9802Core.h
  • ErrorTxClearFailed : JY9802Core.h
  • ErrorTxCloseFailed : JY9802Core.h
  • ErrorTxConfigBufferFailed : JY9802Core.h
  • ErrorTxConfigGenerationFailed : JY9802Core.h
  • ErrorTxConfigOutputStrobelFailed : JY9802Core.h
  • ErrorTxConfigSingleTransferBytesFailed : JY9802Core.h
  • ErrorTxConfigTriggerFailed : JY9802Core.h
  • ErrorTxEnableHWTriggerFailed : JY9802Core.h
  • ErrorTxInitFailed : JY9802Core.h
  • ErrorTxUnderflow : JY9802Core.h
  • ErrorWarningCalibration : JY9802Core.h
  • ErrorWriteDataFailed : JY9802Core.h
  • ErrorWriteRegisterFailed : JY9802Core.h
  • ExportClockFrequencyParam : JY9802Core.h
  • ExportClockType : JY9802Core.h
  • ExportSignalDestination : JY9802Core.h
  • ExportSignalSource : JY9802Core.h
  • ExternalClock : JY9802Core.h
  • ExternalClockFrequencyParam : JY9802Core.h


Here is a list of all enums with links to the files they belong to:
  • AcquisitionMode : JY9802Core.h
  • AnalogTriggerConditioning : JY9802Core.h
  • AnalogTriggerSource : JY9802Core.h
  • AnalogTriggerType : JY9802Core.h
  • AWGDataSource : JY9802Core.h
  • AWGTriggerType : JY9802Core.h
  • ClockSource : JY9802Core.h
  • DigitalTriggerConditioning : JY9802Core.h
  • DigitalTriggerSource : JY9802Core.h
  • ExportClockType : JY9802Core.h
  • ExportSignalDestination : JY9802Core.h
  • ExportSignalSource : JY9802Core.h
  • GenerationMode : JY9802Core.h
  • OSPMode : JY9802Core.h
  • PFI_SOURCE_SEL : JY9802Core.h
  • TriggerMode : JY9802Core.h
  • TriggerType : JY9802Core.h


  • a
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • n
  • o
  • p
  • r
  • s
  • t
Here is a list of all enum values with links to the files they belong to:

- a -

  • AI_Advance_TRIGGER_EVENT : JY9802Core.h
  • AI_REF_TRIGGER_Event : JY9802Core.h
  • AI_Start_TRIGGER_Event : JY9802Core.h
  • AIAdvanceTriggerO : JY9802Core.h
  • AIAnalogTrigger : JY9802Core.h
  • AIEndOfAcquisition : JY9802Core.h
  • AIEndOfRecord : JY9802Core.h
  • AIPowerTrigger : JY9802Core.h
  • AIReadyForAdvanceTrigger : JY9802Core.h
  • AIReadyForRefTrigger : JY9802Core.h
  • AIReadyForStartTrigger : JY9802Core.h
  • AIRefTrigger0 : JY9802Core.h
  • AISampleClk : JY9802Core.h
  • AIStartTrigger : JY9802Core.h
  • Analog_Trigger : JY9802Core.h
  • AnalogHysteresisTrigger : JY9802Core.h
  • AnalogPowerTrigger : JY9802Core.h
  • AnalogTriggerConditioningEnteringWindow : JY9802Core.h
  • AnalogTriggerConditioningFalling : JY9802Core.h
  • AnalogTriggerConditioningLeavingWindow : JY9802Core.h
  • AnalogTriggerConditioningPowerHigh : JY9802Core.h
  • AnalogTriggerConditioningPowerLow : JY9802Core.h
  • AnalogTriggerConditioningRising : JY9802Core.h
  • AnalogTriggerSourceCH0Raw : JY9802Core.h
  • AnalogTriggerSourceCH1Raw : JY9802Core.h
  • AnalogTriggerSourceIQCH1 : JY9802Core.h
  • AnalogTriggerSourceIQCHO : JY9802Core.h
  • AnalogWindowTrigger : JY9802Core.h
  • AO_Start_Event : JY9802Core.h
  • AOGenerationDone : JY9802Core.h
  • AOReadyForStartTrigger : JY9802Core.h
  • AOSampleClk : JY9802Core.h
  • AOStartTrigger : JY9802Core.h
  • AWGDataSourceBIT : JY9802Core.h
  • AWGDataSourceDAC : JY9802Core.h

- c -

  • Continuous_Sample : JY9802Core.h
  • ContinuousWrapping : JY9802Core.h

- d -

  • Digital_Trigger : JY9802Core.h
  • DigitalTrigger : JY9802Core.h

- e -

  • ExternalClock : JY9802Core.h

- f -

  • Falling_Edge_Trigger : JY9802Core.h
  • Finite : JY9802Core.h
  • Finite_Sample : JY9802Core.h

- g -

  • GPIO_ADDR : JY9802Core.h

- h -

  • High_Level_Trigger : JY9802Core.h

- i -

  • Immediate_Trigger : JY9802Core.h
  • ImmediateTrigger : JY9802Core.h
  • InternalClock : JY9802Core.h

- l -

  • Low_Level_Trigger : JY9802Core.h

- n -

  • None : JY9802Core.h

- o -

  • OSPComplex : JY9802Core.h
  • OSPReal : JY9802Core.h

- p -

  • PFI0 : JY9802Core.h
  • PFI1 : JY9802Core.h
  • PFI2 : JY9802Core.h
  • PFI3 : JY9802Core.h
  • PFI4 : JY9802Core.h
  • PFI5 : JY9802Core.h
  • PFI6 : JY9802Core.h
  • PFI7 : JY9802Core.h
  • PFIOut0 : JY9802Core.h
  • PFIOut1 : JY9802Core.h
  • PFIOut2 : JY9802Core.h
  • PFIOut3 : JY9802Core.h
  • PFIOut4 : JY9802Core.h
  • PFIOut5 : JY9802Core.h
  • PFIOut6 : JY9802Core.h
  • PFIOut7 : JY9802Core.h

- r -

  • ReferenceTrigger : JY9802Core.h
  • Rising_Edge_Trigger : JY9802Core.h

- s -

  • Soft_Trigger : JY9802Core.h
  • SoftTrigger : JY9802Core.h
  • SpecifiedFrequency : JY9802Core.h
  • StartAndReferenceTrigger : JY9802Core.h
  • StartTrigger : JY9802Core.h
  • Stream : JY9802Core.h

- t -

  • TRIGGER_ADDR : JY9802Core.h
  • TriggerIn : JY9802Core.h
  • TriggerOut : JY9802Core.h


  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
  • u
Here is a list of all file members with links to the files they belong to:

- f -

  • Falling_Edge_Trigger : JY9802Core.h
  • Finite : JY9802Core.h
  • Finite_Sample : JY9802Core.h


  • j
Here is a list of all functions with links to the files they belong to:

- j -

  • JY9802Core_AWG_Commit() : JY9802Core.h
  • JY9802Core_AWG_GetChannelDelay() : JY9802Core.h
  • JY9802Core_AWG_GetGenerationStatus() : JY9802Core.h
  • JY9802Core_AWG_GetSampleRate() : JY9802Core.h
  • JY9802Core_AWG_GetTimebase() : JY9802Core.h
  • JY9802Core_AWG_Init() : JY9802Core.h
  • JY9802Core_AWG_SendSoftwareTrigger() : JY9802Core.h
  • JY9802Core_AWG_SetBasebandModeEnabled() : JY9802Core.h
  • JY9802Core_AWG_SetBITFrequency() : JY9802Core.h
  • JY9802Core_AWG_SetBufferLength() : JY9802Core.h
  • JY9802Core_AWG_SetCenterFrequency() : JY9802Core.h
  • JY9802Core_AWG_SetChannelDelay() : JY9802Core.h
  • JY9802Core_AWG_SetDataSource() : JY9802Core.h
  • JY9802Core_AWG_SetDigitalGain() : JY9802Core.h
  • JY9802Core_AWG_SetDigitalTrigger() : JY9802Core.h
  • JY9802Core_AWG_SetEnabledChannels() : JY9802Core.h
  • JY9802Core_AWG_SetEnableInverseSinc() : JY9802Core.h
  • JY9802Core_AWG_SetGenerationMode() : JY9802Core.h
  • JY9802Core_AWG_SetOSPMode() : JY9802Core.h
  • JY9802Core_AWG_SetSampleRate() : JY9802Core.h
  • JY9802Core_AWG_SetSamplesToWrite() : JY9802Core.h
  • JY9802Core_AWG_SetTimebase() : JY9802Core.h
  • JY9802Core_AWG_SetTriggerType() : JY9802Core.h
  • JY9802Core_AWG_Start() : JY9802Core.h
  • JY9802Core_AWG_Stop() : JY9802Core.h
  • JY9802Core_AWG_WriteDataBinary16() : JY9802Core.h
  • JY9802Core_AWG_WriteDbl64() : JY9802Core.h
  • JY9802Core_Close() : JY9802Core.h
  • JY9802Core_Digitizer_Commit() : JY9802Core.h
  • JY9802Core_Digitizer_EnableLowLatencyDDC() : JY9802Core.h
  • JY9802Core_Digitizer_GetAcquisitionStatus() : JY9802Core.h
  • JY9802Core_Digitizer_GetReTriggerStatus() : JY9802Core.h
  • JY9802Core_Digitizer_GetSampleRate() : JY9802Core.h
  • JY9802Core_Digitizer_GetTimebase() : JY9802Core.h
  • JY9802Core_Digitizer_Init() : JY9802Core.h
  • JY9802Core_Digitizer_ReadDataBinary16() : JY9802Core.h
  • JY9802Core_Digitizer_ReadDataDbl64() : JY9802Core.h
  • JY9802Core_Digitizer_SendSoftwareTrigger() : JY9802Core.h
  • JY9802Core_Digitizer_SetAcquisitionMode() : JY9802Core.h
  • JY9802Core_Digitizer_SetAnalogTrigger() : JY9802Core.h
  • JY9802Core_Digitizer_SetBasebandModeEnabled() : JY9802Core.h
  • JY9802Core_Digitizer_SetBufferLength() : JY9802Core.h
  • JY9802Core_Digitizer_SetDDCParam() : JY9802Core.h
  • JY9802Core_Digitizer_SetDigitalTrigger() : JY9802Core.h
  • JY9802Core_Digitizer_SetEnabledChannels() : JY9802Core.h
  • JY9802Core_Digitizer_SetOSPMode() : JY9802Core.h
  • JY9802Core_Digitizer_SetPreTriggerSamples() : JY9802Core.h
  • JY9802Core_Digitizer_SetReTriggerParam() : JY9802Core.h
  • JY9802Core_Digitizer_SetSampleRate() : JY9802Core.h
  • JY9802Core_Digitizer_SetSamplesToAcquire() : JY9802Core.h
  • JY9802Core_Digitizer_SetTimebase() : JY9802Core.h
  • JY9802Core_Digitizer_SetTriggerType() : JY9802Core.h
  • JY9802Core_Digitizer_Start() : JY9802Core.h
  • JY9802Core_Digitizer_Stop() : JY9802Core.h
  • JY9802Core_Digitizer_WaitForAcqComplete() : JY9802Core.h
  • JY9802Core_EEPROM_InitializeCalibrationBlock() : JY9802Core.h
  • JY9802Core_EEPROM_InitializeIdBlock() : JY9802Core.h
  • JY9802Core_EEPROM_ReadCalibrationBlock() : JY9802Core.h
  • JY9802Core_EEPROM_ReadIdBlock() : JY9802Core.h
  • JY9802Core_EEPROM_Reset() : JY9802Core.h
  • JY9802Core_EEPROM_SerialNumber_Int2String() : JY9802Core.h
  • JY9802Core_EEPROM_SerialNumber_String2Int() : JY9802Core.h
  • JY9802Core_EEPROM_WriteCalibrationBlock() : JY9802Core.h
  • JY9802Core_EEPROM_WriteIdBlock() : JY9802Core.h
  • JY9802Core_ExportClock() : JY9802Core.h
  • JY9802Core_ExportSignal() : JY9802Core.h
  • JY9802Core_GetCardAbility() : JY9802Core.h
  • JY9802Core_GetDeviceList() : JY9802Core.h
  • JY9802Core_GetLastError() : JY9802Core.h
  • JY9802Core_GetTemperature() : JY9802Core.h
  • JY9802Core_Open() : JY9802Core.h
  • JY9802Core_Open_WithAliasName() : JY9802Core.h
  • JY9802Core_SetClockSource() : JY9802Core.h
  • JY9802Core_SetExternalReferenceClockFrequency() : JY9802Core.h


  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
  • u
Here is a list of all file members with links to the files they belong to:

- g -

  • GenerationMode : JY9802Core.h
  • GPIO_ADDR : JY9802Core.h


  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
  • u
Here is a list of all file members with links to the files they belong to:

- h -

  • Handle : JY9802Core.h
  • High_Level_Trigger : JY9802Core.h


  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
  • u
Here is a list of all file members with links to the files they belong to:

- i -

  • Immediate_Trigger : JY9802Core.h
  • ImmediateTrigger : JY9802Core.h
  • InternalClock : JY9802Core.h


  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
  • u
Here is a list of all file members with links to the files they belong to:

- j -

  • JY9802Core_AWG_Commit() : JY9802Core.h
  • JY9802Core_AWG_GetChannelDelay() : JY9802Core.h
  • JY9802Core_AWG_GetGenerationStatus() : JY9802Core.h
  • JY9802Core_AWG_GetSampleRate() : JY9802Core.h
  • JY9802Core_AWG_GetTimebase() : JY9802Core.h
  • JY9802Core_AWG_Init() : JY9802Core.h
  • JY9802Core_AWG_SendSoftwareTrigger() : JY9802Core.h
  • JY9802Core_AWG_SetBasebandModeEnabled() : JY9802Core.h
  • JY9802Core_AWG_SetBITFrequency() : JY9802Core.h
  • JY9802Core_AWG_SetBufferLength() : JY9802Core.h
  • JY9802Core_AWG_SetCenterFrequency() : JY9802Core.h
  • JY9802Core_AWG_SetChannelDelay() : JY9802Core.h
  • JY9802Core_AWG_SetDataSource() : JY9802Core.h
  • JY9802Core_AWG_SetDigitalGain() : JY9802Core.h
  • JY9802Core_AWG_SetDigitalTrigger() : JY9802Core.h
  • JY9802Core_AWG_SetEnabledChannels() : JY9802Core.h
  • JY9802Core_AWG_SetEnableInverseSinc() : JY9802Core.h
  • JY9802Core_AWG_SetGenerationMode() : JY9802Core.h
  • JY9802Core_AWG_SetOSPMode() : JY9802Core.h
  • JY9802Core_AWG_SetSampleRate() : JY9802Core.h
  • JY9802Core_AWG_SetSamplesToWrite() : JY9802Core.h
  • JY9802Core_AWG_SetTimebase() : JY9802Core.h
  • JY9802Core_AWG_SetTriggerType() : JY9802Core.h
  • JY9802Core_AWG_Start() : JY9802Core.h
  • JY9802Core_AWG_Stop() : JY9802Core.h
  • JY9802Core_AWG_WriteDataBinary16() : JY9802Core.h
  • JY9802Core_AWG_WriteDbl64() : JY9802Core.h
  • JY9802Core_Close() : JY9802Core.h
  • JY9802Core_Digitizer_Commit() : JY9802Core.h
  • JY9802Core_Digitizer_EnableLowLatencyDDC() : JY9802Core.h
  • JY9802Core_Digitizer_GetAcquisitionStatus() : JY9802Core.h
  • JY9802Core_Digitizer_GetReTriggerStatus() : JY9802Core.h
  • JY9802Core_Digitizer_GetSampleRate() : JY9802Core.h
  • JY9802Core_Digitizer_GetTimebase() : JY9802Core.h
  • JY9802Core_Digitizer_Init() : JY9802Core.h
  • JY9802Core_Digitizer_ReadDataBinary16() : JY9802Core.h
  • JY9802Core_Digitizer_ReadDataDbl64() : JY9802Core.h
  • JY9802Core_Digitizer_SendSoftwareTrigger() : JY9802Core.h
  • JY9802Core_Digitizer_SetAcquisitionMode() : JY9802Core.h
  • JY9802Core_Digitizer_SetAnalogTrigger() : JY9802Core.h
  • JY9802Core_Digitizer_SetBasebandModeEnabled() : JY9802Core.h
  • JY9802Core_Digitizer_SetBufferLength() : JY9802Core.h
  • JY9802Core_Digitizer_SetDDCParam() : JY9802Core.h
  • JY9802Core_Digitizer_SetDigitalTrigger() : JY9802Core.h
  • JY9802Core_Digitizer_SetEnabledChannels() : JY9802Core.h
  • JY9802Core_Digitizer_SetOSPMode() : JY9802Core.h
  • JY9802Core_Digitizer_SetPreTriggerSamples() : JY9802Core.h
  • JY9802Core_Digitizer_SetReTriggerParam() : JY9802Core.h
  • JY9802Core_Digitizer_SetSampleRate() : JY9802Core.h
  • JY9802Core_Digitizer_SetSamplesToAcquire() : JY9802Core.h
  • JY9802Core_Digitizer_SetTimebase() : JY9802Core.h
  • JY9802Core_Digitizer_SetTriggerType() : JY9802Core.h
  • JY9802Core_Digitizer_Start() : JY9802Core.h
  • JY9802Core_Digitizer_Stop() : JY9802Core.h
  • JY9802Core_Digitizer_WaitForAcqComplete() : JY9802Core.h
  • JY9802Core_EEPROM_InitializeCalibrationBlock() : JY9802Core.h
  • JY9802Core_EEPROM_InitializeIdBlock() : JY9802Core.h
  • JY9802Core_EEPROM_ReadCalibrationBlock() : JY9802Core.h
  • JY9802Core_EEPROM_ReadIdBlock() : JY9802Core.h
  • JY9802Core_EEPROM_Reset() : JY9802Core.h
  • JY9802Core_EEPROM_SerialNumber_Int2String() : JY9802Core.h
  • JY9802Core_EEPROM_SerialNumber_String2Int() : JY9802Core.h
  • JY9802Core_EEPROM_WriteCalibrationBlock() : JY9802Core.h
  • JY9802Core_EEPROM_WriteIdBlock() : JY9802Core.h
  • JY9802Core_ExportClock() : JY9802Core.h
  • JY9802Core_ExportSignal() : JY9802Core.h
  • JY9802Core_GetCardAbility() : JY9802Core.h
  • JY9802Core_GetDeviceList() : JY9802Core.h
  • JY9802Core_GetLastError() : JY9802Core.h
  • JY9802Core_GetTemperature() : JY9802Core.h
  • JY9802Core_Open() : JY9802Core.h
  • JY9802Core_Open_WithAliasName() : JY9802Core.h
  • JY9802Core_SetClockSource() : JY9802Core.h
  • JY9802Core_SetExternalReferenceClockFrequency() : JY9802Core.h
  • JYDLL_API : JY9802Core.h
  • JYFailed : JY9802Core.h
  • JYSuccess : JY9802Core.h


  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
  • u
Here is a list of all file members with links to the files they belong to:

- l -

  • Low_Level_Trigger : JY9802Core.h


  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
  • u
Here is a list of all file members with links to the files they belong to:

- n -

  • NoError : JY9802Core.h
  • None : JY9802Core.h


  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
  • u
Here is a list of all file members with links to the files they belong to:

- o -

  • OSPComplex : JY9802Core.h
  • OSPMode : JY9802Core.h
  • OSPReal : JY9802Core.h


  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
  • u
Here is a list of all file members with links to the files they belong to:

- p -

  • PFI0 : JY9802Core.h
  • PFI1 : JY9802Core.h
  • PFI2 : JY9802Core.h
  • PFI3 : JY9802Core.h
  • PFI4 : JY9802Core.h
  • PFI5 : JY9802Core.h
  • PFI6 : JY9802Core.h
  • PFI7 : JY9802Core.h
  • PFI_SOURCE_SEL : JY9802Core.h
  • PFIOut0 : JY9802Core.h
  • PFIOut1 : JY9802Core.h
  • PFIOut2 : JY9802Core.h
  • PFIOut3 : JY9802Core.h
  • PFIOut4 : JY9802Core.h
  • PFIOut5 : JY9802Core.h
  • PFIOut6 : JY9802Core.h
  • PFIOut7 : JY9802Core.h


  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
  • u
Here is a list of all file members with links to the files they belong to:

- r -

  • ReferenceTrigger : JY9802Core.h
  • Rising_Edge_Trigger : JY9802Core.h


  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
  • u
Here is a list of all file members with links to the files they belong to:

- s -

  • Soft_Trigger : JY9802Core.h
  • SoftTrigger : JY9802Core.h
  • SpecifiedFrequency : JY9802Core.h
  • StartAndReferenceTrigger : JY9802Core.h
  • StartTrigger : JY9802Core.h
  • STDCALL : JY9802Core.h
  • Stream : JY9802Core.h


  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
  • u
Here is a list of all file members with links to the files they belong to:

- t -

  • TRIGGER_ADDR : JY9802Core.h
  • TriggerIn : JY9802Core.h
  • TriggerMode : JY9802Core.h
  • TriggerOut : JY9802Core.h
  • TriggerType : JY9802Core.h


Here is a list of all typedefs with links to the files they belong to:
  • BYTE : JY9802Core.h
  • Handle : JY9802Core.h
  • UINT64 : JY9802Core.h


  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • n
  • o
  • p
  • r
  • s
  • t
  • u
Here is a list of all file members with links to the files they belong to:

- u -

  • UINT64 : JY9802Core.h


9802 C++ Programming Manual: Main Page

9802 C++ Programming Manual Documentation


9802 C++ Programming Manual: CARD_ABILITY Struct Reference

  • Class List
  • Class Index
  • Class Members
Public Attributes | List of all members
CARD_ABILITY Struct Reference

#include <JY9802Core.h>

Public Attributes

int | DIGITIZER_AVAILIABLE
int | AWG_AVAILIABLE

Member Data Documentation

◆ AWG_AVAILIABLE

int CARD_ABILITY::AWG_AVAILIABLE

◆ DIGITIZER_AVAILIABLE

int CARD_ABILITY::DIGITIZER_AVAILIABLE
The documentation for this struct was generated from the following file:
  • D:/9802/C++/JY9802Core.h


9802 C++ Programming Manual: Member List

  • Class List
  • Class Index
  • Class Members
CARD_ABILITY Member List

This is the complete list of members for CARD_ABILITY, including all inherited members.

AWG_AVAILIABLE | CARD_ABILITY
DIGITIZER_AVAILIABLE | CARD_ABILITY


9802 C++ Programming Manual: JY9802CoreCalibrationConstant Struct Reference

  • Class List
  • Class Index
  • Class Members
Public Attributes | List of all members
JY9802CoreCalibrationConstant Struct Reference

#include <JY9802Core.h>

Public Attributes

float | AI_CH0_k
float | AI_CH0_b
float | AI_CH1_k
float | AI_CH1_b
float | AO_CH0_k
float | AO_CH0_b
float | AO_CH1_k
float | AO_CH1_b
float | AO_CH0_FS_mA
float | AO_CH1_FS_mA

Member Data Documentation

◆ AI_CH0_b

float JY9802CoreCalibrationConstant::AI_CH0_b

◆ AI_CH0_k

float JY9802CoreCalibrationConstant::AI_CH0_k

◆ AI_CH1_b

float JY9802CoreCalibrationConstant::AI_CH1_b

◆ AI_CH1_k

float JY9802CoreCalibrationConstant::AI_CH1_k

◆ AO_CH0_b

float JY9802CoreCalibrationConstant::AO_CH0_b

◆ AO_CH0_FS_mA

float JY9802CoreCalibrationConstant::AO_CH0_FS_mA

◆ AO_CH0_k

float JY9802CoreCalibrationConstant::AO_CH0_k

◆ AO_CH1_b

float JY9802CoreCalibrationConstant::AO_CH1_b

◆ AO_CH1_FS_mA

float JY9802CoreCalibrationConstant::AO_CH1_FS_mA

◆ AO_CH1_k

float JY9802CoreCalibrationConstant::AO_CH1_k
The documentation for this struct was generated from the following file:
  • D:/9802/C++/JY9802Core.h


9802 C++ Programming Manual: Member List

  • Class List
  • Class Index
  • Class Members
JY9802CoreCalibrationConstant Member List

This is the complete list of members for JY9802CoreCalibrationConstant, including all inherited members.

AI_CH0_b | JY9802CoreCalibrationConstant
AI_CH0_k | JY9802CoreCalibrationConstant
AI_CH1_b | JY9802CoreCalibrationConstant
AI_CH1_k | JY9802CoreCalibrationConstant
AO_CH0_b | JY9802CoreCalibrationConstant
AO_CH0_FS_mA | JY9802CoreCalibrationConstant
AO_CH0_k | JY9802CoreCalibrationConstant
AO_CH1_b | JY9802CoreCalibrationConstant
AO_CH1_FS_mA | JY9802CoreCalibrationConstant
AO_CH1_k | JY9802CoreCalibrationConstant


9802 C++ Programming Manual: JY9802CoreCalibrationInfo Struct Reference

  • Class List
  • Class Index
  • Class Members
Public Attributes | List of all members
JY9802CoreCalibrationInfo Struct Reference

#include <JY9802Core.h>

Public Attributes

long long | CalibrationTimeStamp
short | CalibrationTemperature
short | ConstantListSize
JY9802CoreCalibrationConstant ConstantList
short | CRC16

Member Data Documentation

◆ CalibrationTemperature

short JY9802CoreCalibrationInfo::CalibrationTemperature

◆ CalibrationTimeStamp

long long JY9802CoreCalibrationInfo::CalibrationTimeStamp

◆ ConstantList

JY9802CoreCalibrationConstant JY9802CoreCalibrationInfo::ConstantList

◆ ConstantListSize

short JY9802CoreCalibrationInfo::ConstantListSize

◆ CRC16

short JY9802CoreCalibrationInfo::CRC16
The documentation for this struct was generated from the following file:
  • D:/9802/C++/JY9802Core.h


9802 C++ Programming Manual: Member List

  • Class List
  • Class Index
  • Class Members
JY9802CoreCalibrationInfo Member List

This is the complete list of members for JY9802CoreCalibrationInfo, including all inherited members.

CalibrationTemperature | JY9802CoreCalibrationInfo
CalibrationTimeStamp | JY9802CoreCalibrationInfo
ConstantList | JY9802CoreCalibrationInfo
ConstantListSize | JY9802CoreCalibrationInfo
CRC16 | JY9802CoreCalibrationInfo


9802 C++ Programming Manual: JY9802CoreDeviceInfo Struct Reference

  • Class List
  • Class Index
  • Class Members
Public Attributes | List of all members
JY9802CoreDeviceInfo Struct Reference

#include <JY9802Core.h>

Public Attributes

short | StartSentinel
short | EEPROMSize
short | CalibrationAddr
char | SerialNumber [10]
char | Model [8]
unsigned char | HWRev
short | ProductionDate
unsigned char | Reserved [5]

Member Data Documentation

◆ CalibrationAddr

short JY9802CoreDeviceInfo::CalibrationAddr

◆ EEPROMSize

short JY9802CoreDeviceInfo::EEPROMSize

◆ HWRev

unsigned char JY9802CoreDeviceInfo::HWRev

◆ Model

char JY9802CoreDeviceInfo::Model[8]

◆ ProductionDate

short JY9802CoreDeviceInfo::ProductionDate

◆ Reserved

unsigned char JY9802CoreDeviceInfo::Reserved[5]

◆ SerialNumber

char JY9802CoreDeviceInfo::SerialNumber[10]

◆ StartSentinel

short JY9802CoreDeviceInfo::StartSentinel
The documentation for this struct was generated from the following file:
  • D:/9802/C++/JY9802Core.h


9802 C++ Programming Manual: Member List

  • Class List
  • Class Index
  • Class Members
JY9802CoreDeviceInfo Member List

This is the complete list of members for JY9802CoreDeviceInfo, including all inherited members.

CalibrationAddr | JY9802CoreDeviceInfo
EEPROMSize | JY9802CoreDeviceInfo
HWRev | JY9802CoreDeviceInfo
Model | JY9802CoreDeviceInfo
ProductionDate | JY9802CoreDeviceInfo
Reserved | JY9802CoreDeviceInfo
SerialNumber | JY9802CoreDeviceInfo
StartSentinel | JY9802CoreDeviceInfo


9802 C++ Programming Manual: JY9802DeviceInfo Struct Reference

  • Class List
  • Class Index
  • Class Members
Public Attributes | List of all members
JY9802DeviceInfo Struct Reference

#include <JY9802Core.h>

Public Attributes

char | aliasName [64]
int | slotNumber
char | serialNumber [33]
char | model [65]
char | HardwareVer [16]
char | FirmwareVer [16]
char | FrameworkVer [16]
char | DriverSetVer [16]
char | ProductionDate [16]

Member Data Documentation

◆ aliasName

char JY9802DeviceInfo::aliasName[64]

◆ DriverSetVer

char JY9802DeviceInfo::DriverSetVer[16]

◆ FirmwareVer

char JY9802DeviceInfo::FirmwareVer[16]

◆ FrameworkVer

char JY9802DeviceInfo::FrameworkVer[16]

◆ HardwareVer

char JY9802DeviceInfo::HardwareVer[16]

◆ model

char JY9802DeviceInfo::model[65]

◆ ProductionDate

char JY9802DeviceInfo::ProductionDate[16]

◆ serialNumber

char JY9802DeviceInfo::serialNumber[33]

◆ slotNumber

int JY9802DeviceInfo::slotNumber
The documentation for this struct was generated from the following file:
  • D:/9802/C++/JY9802Core.h


9802 C++ Programming Manual: Member List

  • Class List
  • Class Index
  • Class Members
JY9802DeviceInfo Member List

This is the complete list of members for JY9802DeviceInfo, including all inherited members.

aliasName | JY9802DeviceInfo
DriverSetVer | JY9802DeviceInfo
FirmwareVer | JY9802DeviceInfo
FrameworkVer | JY9802DeviceInfo
HardwareVer | JY9802DeviceInfo
model | JY9802DeviceInfo
ProductionDate | JY9802DeviceInfo
serialNumber | JY9802DeviceInfo
slotNumber | JY9802DeviceInfo