9802 C# Programming Manual: D:/9802/C#/JY9802AITask.cs File Reference

9802 C# Programming Manual
  • Main Page
  • Packages
  • Classes
  • Files
  • File List
  • 9802
  • C#
Classes | Namespaces | Enumerations
JY9802AITask.cs File Reference

Classes

class | JY9802.JY9802AITask
AI采集任务类,是Sealed类，不可被继承
class | JY9802.Record
流盘相关的参数定义 More...
class | JY9802.AIChannel
AI通道参数类 More...
class | JY9802.AITrigger
AI触发参数配置类 More...
class | JY9802.AIRetrigger
重触发配置类 More...
class | JY9802.AIDigitalTrigger
AI数字触发 More...
class | JY9802.AIAnalogTrigger
AI模拟触发 More...
class | JY9802.AIAdvanced
高级属性 More...

Namespaces

namespace JY9802

Enumerations

enum | JY9802.RecordMode { JY9802.Finite , JY9802.Infinite }
流盘模式枚举定义 More...
enum | JY9802.RecordFormat { JY9802.VectorFile , JY9802.Raw }
流盘格式 More...
enum | JY9802.AIAnalogTriggerSource { JY9802.CH0Raw , JY9802.CH1Raw }
AI模拟触发源 More...
enum | JY9802.AIAnalogTriggerType { JY9802.Power = JY9802Import.AnalogTriggerType.AnalogPowerTrigger , JY9802.Window = JY9802Import.AnalogTriggerType.AnalogWindowTrigger , JY9802.Hysteresis = JY9802Import.AnalogTriggerType.AnalogHysteresisTrigger }
AI模拟触发类型 More...
enum JY9802.AIAnalogTriggerCondition {
JY9802.EnteringWindow = JY9802Import.AnalogTriggerConditioning.AnalogTriggerConditioningEnteringWindow , JY9802.LeavingWindow = JY9802Import.AnalogTriggerConditioning.AnalogTriggerConditioningLeavingWindow , JY9802.RisingHysteresis = JY9802Import.AnalogTriggerConditioning.AnalogTriggerConditioningRising , JY9802.FallingHysteresis = JY9802Import.AnalogTriggerConditioning.AnalogTriggerConditioningFalling ,
JY9802.PowerHigh = JY9802Import.AnalogTriggerConditioning.AnalogTriggerConditioningPowerHigh , JY9802.PowerLow = JY9802Import.AnalogTriggerConditioning.AnalogTriggerConditioningPowerLow
}
AI模拟触发条件 More...
enum | JY9802.AIMode { JY9802.Finite = JY9802Import.AcquisitionMode.Finite_Sample , JY9802.Continuous = JY9802Import.AcquisitionMode.Continuous_Sample , JY9802.Record }
AI工作模式枚举类型 More...
enum | JY9802.AITriggerType { JY9802.Immediate = JY9802Import.TriggerType.Immediate_Trigger , JY9802.Software = JY9802Import.TriggerType.Soft_Trigger , JY9802.Digital = JY9802Import.TriggerType.Digital_Trigger , JY9802.Analog = JY9802Import.TriggerType.Analog_Trigger }
AI触发类型 More...
enum JY9802.AIDigitalTriggerSource {
JY9802.Trig_In = JY9802Import.DigitalTriggerSource.TriggerIn , JY9802.PFI0 = JY9802Import.DigitalTriggerSource.PFI0 , JY9802.PFI1 = JY9802Import.DigitalTriggerSource.PFI1 , JY9802.PFI2 = JY9802Import.DigitalTriggerSource.PFI2 ,
JY9802.PFI3 = JY9802Import.DigitalTriggerSource.PFI3 , JY9802.PFI4 = JY9802Import.DigitalTriggerSource.PFI4 , JY9802.PFI5 = JY9802Import.DigitalTriggerSource.PFI5 , JY9802.PFI6 = JY9802Import.DigitalTriggerSource.PFI6 ,
JY9802.PFI7 = JY9802Import.DigitalTriggerSource.PFI7
}
AI外部数字触发源 More...
enum | JY9802.AIDigitalTriggerCondition { JY9802.RisingEdge = JY9802Import.DigitalTriggerConditioning.Rising_Edge_Trigger , JY9802.FallingEdge = JY9802Import.DigitalTriggerConditioning.Falling_Edge_Trigger , JY9802.HighLevel = JY9802Import.DigitalTriggerConditioning.High_Level_Trigger , JY9802.LowLevel = JY9802Import.DigitalTriggerConditioning.Low_Level_Trigger }
AI外部数字出发边沿 More...
Generated by doxygen 1.12.0


9802 C# Programming Manual: D:/9802/C#/JY9802AOTask.cs File Reference

  • Packages
  • Classes
  • Files
  • File List
  • 9802
  • C#
Classes | Namespaces | Enumerations
JY9802AOTask.cs File Reference

Classes

class | JY9802.JY9802AOTask
AO输出任务类,是Sealed类，不可被继承
class | JY9802.Playback
回放相关的参数定义 More...
class | JY9802.AOTrigger
AO触发参数配置类 More...
class | JY9802.AODigitalTrigger
AO数字触发 More...
class | JY9802.AOChannel
AO通道参数类 More...
class | JY9802.BITSignal
BITSignal. More...
class | JY9802.AOPlaybackStatus
Playback status. More...
class | JY9802.AOAdvanced
高级属性 More...

Namespaces

namespace JY9802

Enumerations

enum | JY9802.PlaybackMode { JY9802.Finite , JY9802.Wrapping }
回放模式 More...
enum | JY9802.AOTriggerType { JY9802.Immediate , JY9802.Software , JY9802.Digital }
AO触发类型 More...
enum JY9802.AODigitalTriggerSource {
JY9802.Trig_In = JY9802Import.DigitalTriggerSource.TriggerIn , JY9802.AIStartTriggerEvent = JY9802Import.DigitalTriggerSource.AI_Start_TRIGGER_Event , JY9802.AIReferenceTriggerEvent = JY9802Import.DigitalTriggerSource.AI_REF_TRIGGER_Event , JY9802.AIAdvanceTriggerEvent = JY9802Import.DigitalTriggerSource.AI_Advance_TRIGGER_EVENT ,
JY9802.PFI0 = JY9802Import.DigitalTriggerSource.PFI0 , JY9802.PFI1 = JY9802Import.DigitalTriggerSource.PFI1 , JY9802.PFI2 = JY9802Import.DigitalTriggerSource.PFI2 , JY9802.PFI3 = JY9802Import.DigitalTriggerSource.PFI3 ,
JY9802.PFI4 = JY9802Import.DigitalTriggerSource.PFI4 , JY9802.PFI5 = JY9802Import.DigitalTriggerSource.PFI5 , JY9802.PFI6 = JY9802Import.DigitalTriggerSource.PFI6 , JY9802.PFI7 = JY9802Import.DigitalTriggerSource.PFI7
}
AI外部数字触发源 More...
enum | JY9802.AODigitalTriggerCondition { JY9802.RisingEdge = (1) << (1) , JY9802.FallingEdge = (1) << (2) , JY9802.HighLevel = (1) << (3) , JY9802.LowLevel = (1) << (4) }
AO外部数字出发边沿 More...
enum | JY9802.AOMode { JY9802.Finite = JY9802Import.GenerationMode.Finite , JY9802.ContinuousWrapping = JY9802Import.GenerationMode.ContinuousWrapping , JY9802.Stream = JY9802Import.GenerationMode.Stream , JY9802.Playback }
AO工作模式枚举类型 More...
enum | JY9802.AODataSource { JY9802.Waveform = JY9802Import.AWGDataSource.AWGDataSourceDAC , JY9802.BIT = JY9802Import.AWGDataSource.AWGDataSourceBIT }
数据来源 More...


9802 C# Programming Manual: Class List

  • Class List
  • Class Index
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
▼N JY9802 |
C AIAdvanced | 高级属性
C AIAnalogTrigger | AI模拟触发
C AIChannel | AI通道参数类
C AIDigitalTrigger | AI数字触发
C AIRetrigger | 重触发配置类
C AITrigger | AI触发参数配置类
C AOAdvanced | 高级属性
C AOChannel | AO通道参数类
C AODigitalTrigger | AO数字触发
C AOPlaybackStatus | Playback status
C AOTrigger | AO触发参数配置类
C BITSignal | BITSignal
C Playback | 回放相关的参数定义
C Record | 流盘相关的参数定义


9802 C# Programming Manual: JY9802.AIAdvanced Class Reference

  • JY9802
  • AIAdvanced
Public Member Functions | Properties | List of all members
JY9802.AIAdvanced Class Reference

高级属性 More...

Public Member Functions

AIAdvanced ()
构造函数

Properties

bool | EnableDDC [get, set]
是否使能DDC
bool | EnableDDCLowLatency [get, set]
是否使能DDC

Detailed Description

高级属性

Constructor & Destructor Documentation

◆ AIAdvanced()

JY9802.AIAdvanced.AIAdvanced ( )

构造函数

Property Documentation

◆ EnableDDC

bool JY9802.AIAdvanced.EnableDDC
getset

是否使能DDC

◆ EnableDDCLowLatency

bool JY9802.AIAdvanced.EnableDDCLowLatency
getset

是否使能DDC

The documentation for this class was generated from the following file:
  • D:/9802/C#/JY9802AITask.cs


9802 C# Programming Manual: Member List

  • AIAdvanced
JY9802.AIAdvanced Member List

This is the complete list of members for JY9802.AIAdvanced, including all inherited members.

AIAdvanced() | JY9802.AIAdvanced
EnableDDC | JY9802.AIAdvanced
EnableDDCLowLatency | JY9802.AIAdvanced


9802 C# Programming Manual: JY9802.AIAnalogTrigger Class Reference

  • AIAnalogTrigger
Properties | List of all members
JY9802.AIAnalogTrigger Class Reference

AI模拟触发 More...

Properties

AIAnalogTriggerCondition | Condition [get, set]
AI模拟触发条件
AIAnalogTriggerSource | Source [get, set]
AI模拟触发源
AIAnalogTriggerType | Type [get, set]
AI模拟触发类型
double | HighLevel [get, set]
高阈值
double | LowLevel [get, set]
低阈值

Detailed Description

AI模拟触发

Property Documentation

◆ Condition

AIAnalogTriggerCondition JY9802.AIAnalogTrigger.Condition
getset

AI模拟触发条件

◆ HighLevel

double JY9802.AIAnalogTrigger.HighLevel
getset

高阈值

◆ LowLevel

double JY9802.AIAnalogTrigger.LowLevel
getset

低阈值

◆ Source

AIAnalogTriggerSource JY9802.AIAnalogTrigger.Source
getset

AI模拟触发源

◆ Type

AIAnalogTriggerType JY9802.AIAnalogTrigger.Type
getset

AI模拟触发类型

The documentation for this class was generated from the following file:
  • D:/9802/C#/JY9802AITask.cs


9802 C# Programming Manual: Member List

  • AIAnalogTrigger
JY9802.AIAnalogTrigger Member List

This is the complete list of members for JY9802.AIAnalogTrigger, including all inherited members.

Condition | JY9802.AIAnalogTrigger
HighLevel | JY9802.AIAnalogTrigger
LowLevel | JY9802.AIAnalogTrigger
Source | JY9802.AIAnalogTrigger
Type | JY9802.AIAnalogTrigger


9802 C# Programming Manual: JY9802.AIChannel Class Reference

  • AIChannel
Properties | List of all members
JY9802.AIChannel Class Referencesealed

AI通道参数类 More...

Properties

int | ChannelID [get]
通道号。与AI通道的物理序号相对应。
double | Frequency [get, set]
Frequency.
double | DigitalGain [get, set]
数字增益倍数，取值为2^N，N=0~7，自动向下取最接近的数值，如100，自动向下找2^N，则取值64

Detailed Description

AI通道参数类

Property Documentation

◆ ChannelID

int JY9802.AIChannel.ChannelID
get

通道号。与AI通道的物理序号相对应。

◆ DigitalGain

double JY9802.AIChannel.DigitalGain
getset

数字增益倍数，取值为2^N，N=0~7，自动向下取最接近的数值，如100，自动向下找2^N，则取值64

◆ Frequency

double JY9802.AIChannel.Frequency
getset

Frequency.

The documentation for this class was generated from the following file:
  • D:/9802/C#/JY9802AITask.cs


9802 C# Programming Manual: Member List

  • AIChannel
JY9802.AIChannel Member List

This is the complete list of members for JY9802.AIChannel, including all inherited members.

ChannelID | JY9802.AIChannel
DigitalGain | JY9802.AIChannel
Frequency | JY9802.AIChannel


9802 C# Programming Manual: JY9802.AIDigitalTrigger Class Reference

  • AIDigitalTrigger
Properties | List of all members
JY9802.AIDigitalTrigger Class Reference

AI数字触发 More...

Properties

AIDigitalTriggerSource | Source [get, set]
AI数字触发源
AIDigitalTriggerCondition | Condition [get, set]
AI数字触发条件

Detailed Description

AI数字触发

Property Documentation

◆ Condition

AIDigitalTriggerCondition JY9802.AIDigitalTrigger.Condition
getset

AI数字触发条件

◆ Source

AIDigitalTriggerSource JY9802.AIDigitalTrigger.Source
getset

AI数字触发源

The documentation for this class was generated from the following file:
  • D:/9802/C#/JY9802AITask.cs


9802 C# Programming Manual: Member List

  • AIDigitalTrigger
JY9802.AIDigitalTrigger Member List

This is the complete list of members for JY9802.AIDigitalTrigger, including all inherited members.

Condition | JY9802.AIDigitalTrigger
Source | JY9802.AIDigitalTrigger


9802 C# Programming Manual: JY9802.AIRetrigger Class Reference

  • AIRetrigger
Properties | List of all members
JY9802.AIRetrigger Class Reference

重触发配置类 More...

Properties

long | Count [get, set]
重触发的次数, -1表示无限重触发，0表示不使能重触发
ulong | AvailableCount [get]
已完成还未读取的触发次数
ulong | CompletedCount [get]
已完成触发的次数

Detailed Description

重触发配置类

Property Documentation

◆ AvailableCount

ulong JY9802.AIRetrigger.AvailableCount
get

已完成还未读取的触发次数

◆ CompletedCount

ulong JY9802.AIRetrigger.CompletedCount
get

已完成触发的次数

◆ Count

long JY9802.AIRetrigger.Count
getset

重触发的次数, -1表示无限重触发，0表示不使能重触发

The documentation for this class was generated from the following file:
  • D:/9802/C#/JY9802AITask.cs


9802 C# Programming Manual: Member List

  • AIRetrigger
JY9802.AIRetrigger Member List

This is the complete list of members for JY9802.AIRetrigger, including all inherited members.

AvailableCount | JY9802.AIRetrigger
CompletedCount | JY9802.AIRetrigger
Count | JY9802.AIRetrigger


9802 C# Programming Manual: JY9802.AITrigger Class Reference

  • AITrigger
Properties | List of all members
JY9802.AITrigger Class Referencesealed

AI触发参数配置类 More...

Properties

uint | PreTriggerSamples [get, set]
触发前的点数,使用硬件的立即触发或延迟触发模式应将其置为0, 使用硬件的预触发或中间触发模式应将其设置为触发前需要采集的点数(>0)
double | AutoTriggerTime [get, set]
两个trigger间隔的最大时间，超时之后自动触发，-1为永久等待,单位us
double | HoldOffTime [get, set]
两个trigger间隔的最小时间长度，在HOLD_OFF这段时间内，不允许接收新的trigger信号,单位us
AIRetrigger | Retrigger [get]
重触发配置
AIDigitalTrigger | Digital [get]
AI数字触发设置
AIAnalogTrigger | Analog [get]
AI模拟触发设置
AITriggerType | Type [get, set]
AI触发类型

Detailed Description

AI触发参数配置类

Property Documentation

◆ Analog

AIAnalogTrigger JY9802.AITrigger.Analog
get

AI模拟触发设置

◆ AutoTriggerTime

double JY9802.AITrigger.AutoTriggerTime
getset

两个trigger间隔的最大时间，超时之后自动触发，-1为永久等待,单位us

◆ Digital

AIDigitalTrigger JY9802.AITrigger.Digital
get

AI数字触发设置

◆ HoldOffTime

double JY9802.AITrigger.HoldOffTime
getset

两个trigger间隔的最小时间长度，在HOLD_OFF这段时间内，不允许接收新的trigger信号,单位us

◆ PreTriggerSamples

uint JY9802.AITrigger.PreTriggerSamples
getset

触发前的点数,使用硬件的立即触发或延迟触发模式应将其置为0, 使用硬件的预触发或中间触发模式应将其设置为触发前需要采集的点数(>0)

◆ Retrigger

AIRetrigger JY9802.AITrigger.Retrigger
get

重触发配置

◆ Type

AITriggerType JY9802.AITrigger.Type
getset

AI触发类型

The documentation for this class was generated from the following file:
  • D:/9802/C#/JY9802AITask.cs


9802 C# Programming Manual: Member List

  • AITrigger
JY9802.AITrigger Member List

This is the complete list of members for JY9802.AITrigger, including all inherited members.

Analog | JY9802.AITrigger
AutoTriggerTime | JY9802.AITrigger
Digital | JY9802.AITrigger
HoldOffTime | JY9802.AITrigger
PreTriggerSamples | JY9802.AITrigger
Retrigger | JY9802.AITrigger
Type | JY9802.AITrigger


9802 C# Programming Manual: JY9802.AOAdvanced Class Reference

  • AOAdvanced
Public Member Functions | Properties | List of all members
JY9802.AOAdvanced Class Reference

高级属性 More...

Public Member Functions

AOAdvanced ()
构造函数

Properties

bool | InverseSincEnabled [get, set]
是否使能DA的InverseSinc，默认false
bool | EnableDUC [get, set]
是否使能DDC

Detailed Description

高级属性

Constructor & Destructor Documentation

◆ AOAdvanced()

JY9802.AOAdvanced.AOAdvanced ( )

构造函数

Property Documentation

◆ EnableDUC

bool JY9802.AOAdvanced.EnableDUC
getset

是否使能DDC

◆ InverseSincEnabled

bool JY9802.AOAdvanced.InverseSincEnabled
getset

是否使能DA的InverseSinc，默认false

The documentation for this class was generated from the following file:
  • D:/9802/C#/JY9802AOTask.cs


9802 C# Programming Manual: Member List

  • AOAdvanced
JY9802.AOAdvanced Member List

This is the complete list of members for JY9802.AOAdvanced, including all inherited members.

AOAdvanced() | JY9802.AOAdvanced
EnableDUC | JY9802.AOAdvanced
InverseSincEnabled | JY9802.AOAdvanced


9802 C# Programming Manual: JY9802.AOChannel Class Reference

  • AOChannel
Properties | List of all members
JY9802.AOChannel Class Referencesealed

AO通道参数类 More...

Properties

int | ChannelID [get]
通道号。与AO通道的物理序号相对应。
double | CenterFrequency [get, set]
Center Frequency.
double | DigitalGain [get, set]
DigitalGain.
double | Delay [get, set]
通道0的时延，单位ns

Detailed Description

AO通道参数类

Property Documentation

◆ CenterFrequency

double JY9802.AOChannel.CenterFrequency
getset

Center Frequency.

◆ ChannelID

int JY9802.AOChannel.ChannelID
get

通道号。与AO通道的物理序号相对应。

◆ Delay

double JY9802.AOChannel.Delay
getset

通道0的时延，单位ns

◆ DigitalGain

double JY9802.AOChannel.DigitalGain
getset

DigitalGain.

The documentation for this class was generated from the following file:
  • D:/9802/C#/JY9802AOTask.cs


9802 C# Programming Manual: Member List

  • AOChannel
JY9802.AOChannel Member List

This is the complete list of members for JY9802.AOChannel, including all inherited members.

CenterFrequency | JY9802.AOChannel
ChannelID | JY9802.AOChannel
Delay | JY9802.AOChannel
DigitalGain | JY9802.AOChannel


9802 C# Programming Manual: JY9802.AODigitalTrigger Class Reference

  • AODigitalTrigger
Properties | List of all members
JY9802.AODigitalTrigger Class Reference

AO数字触发 More...

Properties

AODigitalTriggerSource | Source [get, set]
AI数字触发源
AODigitalTriggerCondition | Condition [get, set]
AI数字触发边沿

Detailed Description

AO数字触发

Property Documentation

◆ Condition

AODigitalTriggerCondition JY9802.AODigitalTrigger.Condition
getset

AI数字触发边沿

◆ Source

AODigitalTriggerSource JY9802.AODigitalTrigger.Source
getset

AI数字触发源

The documentation for this class was generated from the following file:
  • D:/9802/C#/JY9802AOTask.cs


9802 C# Programming Manual: Member List

  • AODigitalTrigger
JY9802.AODigitalTrigger Member List

This is the complete list of members for JY9802.AODigitalTrigger, including all inherited members.

Condition | JY9802.AODigitalTrigger
Source | JY9802.AODigitalTrigger


9802 C# Programming Manual: JY9802.AOPlaybackStatus Class Reference

  • AOPlaybackStatus
Public Member Functions | Properties | List of all members
JY9802.AOPlaybackStatus Class Reference

Playback status. More...

Public Member Functions

AOPlaybackStatus ()
constructor of AOPlaybackStatus

Properties

double | PlayedLength [get, set]
played length
bool | IsPlayDone [get, set]
is play done
double | BufferUsedRatio [get, set]
the percentage of buffer used in total playback buffer alloc, 0~1.0

Detailed Description

Playback status.

Constructor & Destructor Documentation

◆ AOPlaybackStatus()

JY9802.AOPlaybackStatus.AOPlaybackStatus ( )

constructor of AOPlaybackStatus

Property Documentation

◆ BufferUsedRatio

double JY9802.AOPlaybackStatus.BufferUsedRatio
getset

the percentage of buffer used in total playback buffer alloc, 0~1.0

◆ IsPlayDone

bool JY9802.AOPlaybackStatus.IsPlayDone
getset

is play done

◆ PlayedLength

double JY9802.AOPlaybackStatus.PlayedLength
getset

played length

The documentation for this class was generated from the following file:
  • D:/9802/C#/JY9802AOTask.cs


9802 C# Programming Manual: Member List

  • AOPlaybackStatus
JY9802.AOPlaybackStatus Member List

This is the complete list of members for JY9802.AOPlaybackStatus, including all inherited members.

AOPlaybackStatus() | JY9802.AOPlaybackStatus
BufferUsedRatio | JY9802.AOPlaybackStatus
IsPlayDone | JY9802.AOPlaybackStatus
PlayedLength | JY9802.AOPlaybackStatus


9802 C# Programming Manual: JY9802.AOTrigger Class Reference

  • AOTrigger
Properties | List of all members
JY9802.AOTrigger Class Referencesealed

AO触发参数配置类 More...

Properties

AOTriggerType | Type [get, set]
AO触发类型
AODigitalTrigger | Digital [get, set]
AO数字触发设置

Detailed Description

AO触发参数配置类

Property Documentation

◆ Digital

AODigitalTrigger JY9802.AOTrigger.Digital
getset

AO数字触发设置

◆ Type

AOTriggerType JY9802.AOTrigger.Type
getset

AO触发类型

The documentation for this class was generated from the following file:
  • D:/9802/C#/JY9802AOTask.cs


9802 C# Programming Manual: Member List

  • AOTrigger
JY9802.AOTrigger Member List

This is the complete list of members for JY9802.AOTrigger, including all inherited members.

Digital | JY9802.AOTrigger
Type | JY9802.AOTrigger


9802 C# Programming Manual: JY9802.BITSignal Class Reference

  • BITSignal
Properties | List of all members
JY9802.BITSignal Class Referencesealed

BITSignal. More...

Properties

double Frequency [get, set]
频率

Detailed Description

BITSignal.

Property Documentation

◆ Frequency

double JY9802.BITSignal.Frequency
getset

频率

The documentation for this class was generated from the following file:
  • D:/9802/C#/JY9802AOTask.cs


9802 C# Programming Manual: Member List

  • BITSignal
JY9802.BITSignal Member List

This is the complete list of members for JY9802.BITSignal, including all inherited members.

Frequency JY9802.BITSignal


9802 C# Programming Manual: JY9802.Playback Class Reference

  • Playback
Public Member Functions | Properties | List of all members
JY9802.Playback Class Reference

回放相关的参数定义 More...

Public Member Functions

void | AddFile (string path)
添加要回放的文件
void | AddFile (string[] paths)
添加要回放的文件
void | RemoveFile (string path)
移除指定文件
void | RemoveFile (string[] paths)
移除指定文件
int | IndexOfFile (string path)
根据文件路径获取文件在List中的索引

Properties

List< JXIVectorFileInfo > | FileList [get]
已添加的文件列表
PlaybackMode | Mode [get, set]
回放模式，有限回放或者循环回放
long | FileSampleLengh [get]
获取文件的样点数（每通道），在设置文件路径之后可获取
long | BufferLength [get, set]
回放缓冲区大小，单位MByte
string | StartFile [get, set]
回放起始的文件
long | StartFilePosition [get, set]
回放开始的文件起始位置
long | Lengh [get, set]
回放点数（每通道），需小于文件的样点数（每通道）,减去起始位置之前的样点数，如果是Wrapping模式，这该值为环绕读取的点数

Detailed Description

回放相关的参数定义

Member Function Documentation

◆ AddFile() [1/2]

void JY9802.Playback.AddFile ( string path )

添加要回放的文件

Parameters
path 文件路径

◆ AddFile() [2/2]

void JY9802.Playback.AddFile ( string[] paths )

添加要回放的文件

Parameters
paths 文件路径数组

◆ IndexOfFile()

int JY9802.Playback.IndexOfFile ( string path )

根据文件路径获取文件在List中的索引

Parameters
path
Returns

◆ RemoveFile() [1/2]

void JY9802.Playback.RemoveFile ( string path )

移除指定文件

Parameters
path 文件路径

◆ RemoveFile() [2/2]

void JY9802.Playback.RemoveFile ( string[] paths )

移除指定文件

Parameters
paths 文件路径数组

Property Documentation

◆ BufferLength

long JY9802.Playback.BufferLength
getset

回放缓冲区大小，单位MByte

◆ FileList

List<JXIVectorFileInfo> JY9802.Playback.FileList
get

已添加的文件列表

◆ FileSampleLengh

long JY9802.Playback.FileSampleLengh
get

获取文件的样点数（每通道），在设置文件路径之后可获取

◆ Lengh

long JY9802.Playback.Lengh
getset

回放点数（每通道），需小于文件的样点数（每通道）,减去起始位置之前的样点数，如果是Wrapping模式，这该值为环绕读取的点数

◆ Mode

PlaybackMode JY9802.Playback.Mode
getset

回放模式，有限回放或者循环回放

◆ StartFile

string JY9802.Playback.StartFile
getset

回放起始的文件

◆ StartFilePosition

long JY9802.Playback.StartFilePosition
getset

回放开始的文件起始位置

The documentation for this class was generated from the following file:
  • D:/9802/C#/JY9802AOTask.cs


9802 C# Programming Manual: Member List

  • Playback
JY9802.Playback Member List

This is the complete list of members for JY9802.Playback, including all inherited members.

AddFile(string path) | JY9802.Playback
AddFile(string[] paths) | JY9802.Playback
BufferLength | JY9802.Playback
FileList | JY9802.Playback
FileSampleLengh | JY9802.Playback
IndexOfFile(string path) | JY9802.Playback
Lengh | JY9802.Playback
Mode | JY9802.Playback
RemoveFile(string path) | JY9802.Playback
RemoveFile(string[] paths) | JY9802.Playback
StartFile | JY9802.Playback
StartFilePosition | JY9802.Playback


9802 C# Programming Manual: JY9802.Record Class Reference

  • Record
Properties | List of all members
JY9802.Record Class Reference

流盘相关的参数定义 More...

Properties

string | FilePath [get, set]
流盘文件的路径，绝对路径，包含文件名
RecordMode | Mode [get, set]
流盘模式
double | Length [get, set]
流盘时间长度，单位为秒，当Mode为Finite时有效
bool | EnablePreview [get, set]
是否使能预览
RecordFormat | Format [get, set]
流盘文件格式
int | MaxMemorySizeInByte [get, set]
最大使用的内存大小（单位MByte），最小200

Detailed Description

流盘相关的参数定义

Property Documentation

◆ EnablePreview

bool JY9802.Record.EnablePreview
getset

是否使能预览

◆ FilePath

string JY9802.Record.FilePath
getset

流盘文件的路径，绝对路径，包含文件名

◆ Format

RecordFormat JY9802.Record.Format
getset

流盘文件格式

◆ Length

double JY9802.Record.Length
getset

流盘时间长度，单位为秒，当Mode为Finite时有效

◆ MaxMemorySizeInByte

int JY9802.Record.MaxMemorySizeInByte
getset

最大使用的内存大小（单位MByte），最小200

◆ Mode

RecordMode JY9802.Record.Mode
getset

流盘模式

The documentation for this class was generated from the following file:
  • D:/9802/C#/JY9802AITask.cs


9802 C# Programming Manual: Member List

  • Record
JY9802.Record Member List

This is the complete list of members for JY9802.Record, including all inherited members.

EnablePreview | JY9802.Record
FilePath | JY9802.Record
Format | JY9802.Record
Length | JY9802.Record
MaxMemorySizeInByte | JY9802.Record
Mode | JY9802.Record


9802 C# Programming Manual: Class Index

Class Index
A | B | P | R
A
AIAdvanced (JY9802)
AIAnalogTrigger (JY9802)
AIChannel (JY9802)
AIDigitalTrigger (JY9802)
AIRetrigger (JY9802)
AITrigger (JY9802)
AOAdvanced (JY9802)
AOChannel (JY9802)
AODigitalTrigger (JY9802)
AOPlaybackStatus (JY9802)
AOTrigger (JY9802)
B
BITSignal (JY9802)
P
Playback (JY9802)
R
Record (JY9802)


9802 C# Programming Manual: D:/9802 Directory Reference

  • File List
  • 9802
9802 Directory Reference

Directories

C#


9802 C# Programming Manual: D:/9802/C# Directory Reference

  • File List
  • 9802
  • C#
C# Directory Reference

Files

JY9802AITask.cs
JY9802AOTask.cs


9802 C# Programming Manual: File List

  • File List
File List
Here is a list of all files with brief descriptions:
[detail level 123]
▼ 9802
▼ C#
JY9802AITask.cs
JY9802AOTask.cs


9802 C# Programming Manual: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
Here is a list of all class members with links to the classes they belong to:

- a -

  • AddFile() : JY9802.Playback
  • AIAdvanced() : JY9802.AIAdvanced
  • Analog : JY9802.AITrigger
  • AOAdvanced() : JY9802.AOAdvanced
  • AOPlaybackStatus() : JY9802.AOPlaybackStatus
  • AutoTriggerTime : JY9802.AITrigger
  • AvailableCount : JY9802.AIRetrigger

- b -

  • BufferLength : JY9802.Playback
  • BufferUsedRatio : JY9802.AOPlaybackStatus

- c -

  • CenterFrequency : JY9802.AOChannel
  • ChannelID : JY9802.AIChannel, JY9802.AOChannel
  • CompletedCount : JY9802.AIRetrigger
  • Condition : JY9802.AIAnalogTrigger, JY9802.AIDigitalTrigger, JY9802.AODigitalTrigger
  • Count : JY9802.AIRetrigger

- d -

  • Delay : JY9802.AOChannel
  • Digital : JY9802.AITrigger, JY9802.AOTrigger
  • DigitalGain : JY9802.AIChannel, JY9802.AOChannel

- e -

  • EnableDDC : JY9802.AIAdvanced
  • EnableDDCLowLatency : JY9802.AIAdvanced
  • EnableDUC : JY9802.AOAdvanced
  • EnablePreview : JY9802.Record

- f -

  • FileList : JY9802.Playback
  • FilePath : JY9802.Record
  • FileSampleLengh : JY9802.Playback
  • Format : JY9802.Record
  • Frequency : JY9802.AIChannel, JY9802.BITSignal

- h -

  • HighLevel : JY9802.AIAnalogTrigger
  • HoldOffTime : JY9802.AITrigger

- i -

  • IndexOfFile() : JY9802.Playback
  • InverseSincEnabled : JY9802.AOAdvanced
  • IsPlayDone : JY9802.AOPlaybackStatus

- l -

  • Lengh : JY9802.Playback
  • Length : JY9802.Record
  • LowLevel : JY9802.AIAnalogTrigger

- m -

  • MaxMemorySizeInByte : JY9802.Record
  • Mode : JY9802.Playback, JY9802.Record

- p -

  • PlayedLength : JY9802.AOPlaybackStatus
  • PreTriggerSamples : JY9802.AITrigger

- r -

  • RemoveFile() : JY9802.Playback
  • Retrigger : JY9802.AITrigger

- s -

  • Source : JY9802.AIAnalogTrigger, JY9802.AIDigitalTrigger, JY9802.AODigitalTrigger
  • StartFile : JY9802.Playback
  • StartFilePosition : JY9802.Playback

- t -

  • Type : JY9802.AIAnalogTrigger, JY9802.AITrigger, JY9802.AOTrigger


9802 C# Programming Manual: Class Members - Functions

  • All
  • Functions
  • Properties
Here is a list of all functions with links to the classes they belong to:
  • AddFile() : JY9802.Playback
  • AIAdvanced() : JY9802.AIAdvanced
  • AOAdvanced() : JY9802.AOAdvanced
  • AOPlaybackStatus() : JY9802.AOPlaybackStatus
  • IndexOfFile() : JY9802.Playback
  • RemoveFile() : JY9802.Playback


9802 C# Programming Manual: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
Here is a list of all properties with links to the classes they belong to:

- a -

  • Analog : JY9802.AITrigger
  • AutoTriggerTime : JY9802.AITrigger
  • AvailableCount : JY9802.AIRetrigger

- b -

  • BufferLength : JY9802.Playback
  • BufferUsedRatio : JY9802.AOPlaybackStatus

- c -

  • CenterFrequency : JY9802.AOChannel
  • ChannelID : JY9802.AIChannel, JY9802.AOChannel
  • CompletedCount : JY9802.AIRetrigger
  • Condition : JY9802.AIAnalogTrigger, JY9802.AIDigitalTrigger, JY9802.AODigitalTrigger
  • Count : JY9802.AIRetrigger

- d -

  • Delay : JY9802.AOChannel
  • Digital : JY9802.AITrigger, JY9802.AOTrigger
  • DigitalGain : JY9802.AIChannel, JY9802.AOChannel

- e -

  • EnableDDC : JY9802.AIAdvanced
  • EnableDDCLowLatency : JY9802.AIAdvanced
  • EnableDUC : JY9802.AOAdvanced
  • EnablePreview : JY9802.Record

- f -

  • FileList : JY9802.Playback
  • FilePath : JY9802.Record
  • FileSampleLengh : JY9802.Playback
  • Format : JY9802.Record
  • Frequency : JY9802.AIChannel, JY9802.BITSignal

- h -

  • HighLevel : JY9802.AIAnalogTrigger
  • HoldOffTime : JY9802.AITrigger

- i -

  • InverseSincEnabled : JY9802.AOAdvanced
  • IsPlayDone : JY9802.AOPlaybackStatus

- l -

  • Lengh : JY9802.Playback
  • Length : JY9802.Record
  • LowLevel : JY9802.AIAnalogTrigger

- m -

  • MaxMemorySizeInByte : JY9802.Record
  • Mode : JY9802.Playback, JY9802.Record

- p -

  • PlayedLength : JY9802.AOPlaybackStatus
  • PreTriggerSamples : JY9802.AITrigger

- r -

  • Retrigger : JY9802.AITrigger

- s -

  • Source : JY9802.AIAnalogTrigger, JY9802.AIDigitalTrigger, JY9802.AODigitalTrigger
  • StartFile : JY9802.Playback
  • StartFilePosition : JY9802.Playback

- t -

  • Type : JY9802.AIAnalogTrigger, JY9802.AITrigger, JY9802.AOTrigger


9802 C# Programming Manual: Main Page

9802 C# Programming Manual Documentation


9802 C# Programming Manual: JY9802 Namespace Reference

  • Package List
  • Package Members
Classes | Enumerations
JY9802 Namespace Reference

Classes

class | AIAdvanced
高级属性 More...
class | AIAnalogTrigger
AI模拟触发 More...
class | AIChannel
AI通道参数类 More...
class | AIDigitalTrigger
AI数字触发 More...
class | AIRetrigger
重触发配置类 More...
class | AITrigger
AI触发参数配置类 More...
class | AOAdvanced
高级属性 More...
class | AOChannel
AO通道参数类 More...
class | AODigitalTrigger
AO数字触发 More...
class | AOPlaybackStatus
Playback status. More...
class | AOTrigger
AO触发参数配置类 More...
class | BITSignal
BITSignal. More...
class | JY9802AITask
AI采集任务类,是Sealed类，不可被继承
class | JY9802AOTask
AO输出任务类,是Sealed类，不可被继承
class | Playback
回放相关的参数定义 More...
class | Record
流盘相关的参数定义 More...

Enumerations

enum | RecordMode { Finite , Infinite }
流盘模式枚举定义 More...
enum | RecordFormat { VectorFile , Raw }
流盘格式 More...
enum | AIAnalogTriggerSource { CH0Raw , CH1Raw }
AI模拟触发源 More...
enum | AIAnalogTriggerType { Power = JY9802Import.AnalogTriggerType.AnalogPowerTrigger , Window = JY9802Import.AnalogTriggerType.AnalogWindowTrigger , Hysteresis = JY9802Import.AnalogTriggerType.AnalogHysteresisTrigger }
AI模拟触发类型 More...
enum AIAnalogTriggerCondition {
EnteringWindow = JY9802Import.AnalogTriggerConditioning.AnalogTriggerConditioningEnteringWindow , LeavingWindow = JY9802Import.AnalogTriggerConditioning.AnalogTriggerConditioningLeavingWindow , RisingHysteresis = JY9802Import.AnalogTriggerConditioning.AnalogTriggerConditioningRising , FallingHysteresis = JY9802Import.AnalogTriggerConditioning.AnalogTriggerConditioningFalling ,
PowerHigh = JY9802Import.AnalogTriggerConditioning.AnalogTriggerConditioningPowerHigh , PowerLow = JY9802Import.AnalogTriggerConditioning.AnalogTriggerConditioningPowerLow
}
AI模拟触发条件 More...
enum | AIMode { Finite = JY9802Import.AcquisitionMode.Finite_Sample , Continuous = JY9802Import.AcquisitionMode.Continuous_Sample , Record }
AI工作模式枚举类型 More...
enum | AITriggerType { Immediate = JY9802Import.TriggerType.Immediate_Trigger , Software = JY9802Import.TriggerType.Soft_Trigger , Digital = JY9802Import.TriggerType.Digital_Trigger , Analog = JY9802Import.TriggerType.Analog_Trigger }
AI触发类型 More...
enum AIDigitalTriggerSource {
Trig_In = JY9802Import.DigitalTriggerSource.TriggerIn , PFI0 = JY9802Import.DigitalTriggerSource.PFI0 , PFI1 = JY9802Import.DigitalTriggerSource.PFI1 , PFI2 = JY9802Import.DigitalTriggerSource.PFI2 ,
PFI3 = JY9802Import.DigitalTriggerSource.PFI3 , PFI4 = JY9802Import.DigitalTriggerSource.PFI4 , PFI5 = JY9802Import.DigitalTriggerSource.PFI5 , PFI6 = JY9802Import.DigitalTriggerSource.PFI6 ,
PFI7 = JY9802Import.DigitalTriggerSource.PFI7
}
AI外部数字触发源 More...
enum | AIDigitalTriggerCondition { RisingEdge = JY9802Import.DigitalTriggerConditioning.Rising_Edge_Trigger , FallingEdge = JY9802Import.DigitalTriggerConditioning.Falling_Edge_Trigger , HighLevel = JY9802Import.DigitalTriggerConditioning.High_Level_Trigger , LowLevel = JY9802Import.DigitalTriggerConditioning.Low_Level_Trigger }
AI外部数字出发边沿 More...
enum | PlaybackMode { Finite , Wrapping }
回放模式 More...
enum | AOTriggerType { Immediate , Software , Digital }
AO触发类型 More...
enum AODigitalTriggerSource {
Trig_In = JY9802Import.DigitalTriggerSource.TriggerIn , AIStartTriggerEvent = JY9802Import.DigitalTriggerSource.AI_Start_TRIGGER_Event , AIReferenceTriggerEvent = JY9802Import.DigitalTriggerSource.AI_REF_TRIGGER_Event , AIAdvanceTriggerEvent = JY9802Import.DigitalTriggerSource.AI_Advance_TRIGGER_EVENT ,
PFI0 = JY9802Import.DigitalTriggerSource.PFI0 , PFI1 = JY9802Import.DigitalTriggerSource.PFI1 , PFI2 = JY9802Import.DigitalTriggerSource.PFI2 , PFI3 = JY9802Import.DigitalTriggerSource.PFI3 ,
PFI4 = JY9802Import.DigitalTriggerSource.PFI4 , PFI5 = JY9802Import.DigitalTriggerSource.PFI5 , PFI6 = JY9802Import.DigitalTriggerSource.PFI6 , PFI7 = JY9802Import.DigitalTriggerSource.PFI7
}
AI外部数字触发源 More...
enum | AODigitalTriggerCondition { RisingEdge = (1) << (1) , FallingEdge = (1) << (2) , HighLevel = (1) << (3) , LowLevel = (1) << (4) }
AO外部数字出发边沿 More...
enum | AOMode { Finite = JY9802Import.GenerationMode.Finite , ContinuousWrapping = JY9802Import.GenerationMode.ContinuousWrapping , Stream = JY9802Import.GenerationMode.Stream , Playback }
AO工作模式枚举类型 More...
enum | AODataSource { Waveform = JY9802Import.AWGDataSource.AWGDataSourceDAC , BIT = JY9802Import.AWGDataSource.AWGDataSourceBIT }
数据来源 More...

Enumeration Type Documentation

◆ AIAnalogTriggerCondition

enum JY9802.AIAnalogTriggerCondition

AI模拟触发条件

Enumerator
EnteringWindow | 进窗
LeavingWindow | 出窗
RisingHysteresis | 上升沿
FallingHysteresis | 下降沿
PowerHigh | PowerHigh.
PowerLow | PowerLow.

◆ AIAnalogTriggerSource

enum JY9802.AIAnalogTriggerSource

AI模拟触发源

Enumerator
CH0Raw | 通道0
CH1Raw | 通道1

◆ AIAnalogTriggerType

enum JY9802.AIAnalogTriggerType

AI模拟触发类型

Enumerator
Power | 边沿触发
Window | 窗触发
Hysteresis | 迟滞触发

◆ AIDigitalTriggerCondition

enum JY9802.AIDigitalTriggerCondition

AI外部数字出发边沿

Enumerator
RisingEdge | 上升沿触发
FallingEdge | 下降沿触发
HighLevel | 高电平触发
LowLevel | 低电平触发

◆ AIDigitalTriggerSource

enum JY9802.AIDigitalTriggerSource

AI外部数字触发源

Enumerator
Trig_In | External digital trigger in.
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.

◆ AIMode

enum JY9802.AIMode

AI工作模式枚举类型

Enumerator
Finite | 有限点方式
Continuous | 连续方式
Record | 流盘模式

◆ AITriggerType

enum JY9802.AITriggerType

AI触发类型

Enumerator
Immediate | 立即触发
Software | 软件触发
Digital | 外部数字触发
Analog | 外部模拟触发

◆ AODataSource

enum JY9802.AODataSource

数据来源

Enumerator
Waveform | 输出通过Write方法设定的波形
BIT | 输出板载数字波形发生器生成的波形，用于自测试

◆ AODigitalTriggerCondition

enum JY9802.AODigitalTriggerCondition

AO外部数字出发边沿

Enumerator
RisingEdge | Rising_Edge_Trigger.
FallingEdge | Falling_Edge_Trigger.
HighLevel | High_Level_Trigger.
LowLevel | Low_Level_Trigger.

◆ AODigitalTriggerSource

enum JY9802.AODigitalTriggerSource

AI外部数字触发源

Enumerator
Trig_In | External digital trigger in.
AIStartTriggerEvent | AI Start Trigger Event.
AIReferenceTriggerEvent | AI Reference Trigger Event.
AIAdvanceTriggerEvent | AI Advance Trigger Event.
PFI0 | PFI0.
PFI1 | PFI1.
PFI2 | PFI2.
PFI3 | PFI3.
PFI4 | PFI4.
PFI5 | PFI5.
PFI6 | PFI6.
PFI7 | PFI7.

◆ AOMode

enum JY9802.AOMode

AO工作模式枚举类型

Enumerator
Finite | 有限点方式
ContinuousWrapping | 连续方式
Stream | Stream.
Playback | 回放

◆ AOTriggerType

enum JY9802.AOTriggerType

AO触发类型

Enumerator
Immediate | 立即触发
Software | 软件触发
Digital | 外部数字触发

◆ PlaybackMode

enum JY9802.PlaybackMode

回放模式

Enumerator
Finite | 有限点回放，可设置文件起始位置和回放的长度，回放完成后自动停止
Wrapping | 循环回放，回放到文件末尾后自动跳转到文件头继续回放，用户执行stop时停止

◆ RecordFormat

enum JY9802.RecordFormat

流盘格式

Enumerator
VectorFile | 矢量文件，包括4k的Header
Raw | 原始二进制文件

◆ RecordMode

enum JY9802.RecordMode

流盘模式枚举定义

Enumerator
Finite | 有限长度流盘
Infinite | 无限长度流盘


9802 C# Programming Manual: Package Members

  • Package List
  • Package Members
  • All
  • Enumerations
Here is a list of all namespace members with links to the namespace documentation for each member:
  • AIAnalogTriggerCondition : JY9802
  • AIAnalogTriggerSource : JY9802
  • AIAnalogTriggerType : JY9802
  • AIDigitalTriggerCondition : JY9802
  • AIDigitalTriggerSource : JY9802
  • AIMode : JY9802
  • AITriggerType : JY9802
  • AODataSource : JY9802
  • AODigitalTriggerCondition : JY9802
  • AODigitalTriggerSource : JY9802
  • AOMode : JY9802
  • AOTriggerType : JY9802
  • PlaybackMode : JY9802
  • RecordFormat : JY9802
  • RecordMode : JY9802


9802 C# Programming Manual: Package Members

  • Package List
  • Package Members
  • All
  • Enumerations
Here is a list of all namespace enums with links to the namespace documentation for each enum:
  • AIAnalogTriggerCondition : JY9802
  • AIAnalogTriggerSource : JY9802
  • AIAnalogTriggerType : JY9802
  • AIDigitalTriggerCondition : JY9802
  • AIDigitalTriggerSource : JY9802
  • AIMode : JY9802
  • AITriggerType : JY9802
  • AODataSource : JY9802
  • AODigitalTriggerCondition : JY9802
  • AODigitalTriggerSource : JY9802
  • AOMode : JY9802
  • AOTriggerType : JY9802
  • PlaybackMode : JY9802
  • RecordFormat : JY9802
  • RecordMode : JY9802


9802 C# Programming Manual: Package List

  • Package List
  • Package Members
Package List
Here are the packages with brief descriptions (if available):
N JY9802