9810 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/9810 Directory Reference

9810 C++ Programming Manual
  • Main Page
  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 9810
9810 Directory Reference

Files

JY9810CoreOOAITask.h
JY9810CoreOOCommon.h
JY9810CoreOODevice.h
JY9810CoreOOLog.h
Generated by doxygen 1.13.2


9810 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/9810/JY9810CoreOOAITask.h File Reference

  • Namespaces
  • Classes
  • Files
  • File List
  • File Members
  • COO
  • 9810
Classes | Namespaces | Macros | Enumerations
JY9810CoreOOAITask.h File Reference
#include <memory>
#include <mutex>
#include <map>
#include <fstream>
#include <thread>
#include <cstring>
#include <cstddef>
#include <queue>
#include <condition_variable>
#include <atomic>
#include <vector>
#include "JY9810CoreOOCommon.h"
#include "JY9810CoreOODevice.h"

Classes

class | JY9810CoreOO::JY9810CoreOOAITask
aiTask类 More...
class | JY9810CoreOO::AIChannel
class | JY9810CoreOO::AIExternalSampleClock
class | JY9810CoreOO::AISampleClock
class | JY9810CoreOO::AITrigger
class | JY9810CoreOO::AIDigitalTrigger
class | JY9810CoreOO::AIAnalogHysteresisComparator
class | JY9810CoreOO::AIAnalogWindowComparator
class | JY9810CoreOO::AIAnalogEdgeComparator
class | JY9810CoreOO::AIAnalogTrigger
class | JY9810CoreOO::AIMultiChannelAnalogTrigger
class | JY9810CoreOO::AISignalExport
class | JY9810CoreOO::AIRecordAdvanced
class | JY9810CoreOO::AIRecord
class | JY9810CoreOO::AISync
Configure sync signal. More...

Namespaces

namespace JY9810CoreOO

Macros

#define _CRT_SECURE_NO_WARNINGS

Enumerations

enum class | JY9810CoreOO::AIMode { JY9810CoreOO::Finite = JY9810Import::JY9810_Finite , JY9810CoreOO::Continuous = JY9810Import::JY9810_Continuous , JY9810CoreOO::Record = 0x3 }
enum class | JY9810CoreOO::AICoupling { JY9810CoreOO::DC = JY9810Import::JY9810_AI_DC_Couple , JY9810CoreOO::AC = JY9810Import::JY9810_AI_AC_Couple }
AI Coupling. More...
enum class | JY9810CoreOO::AIImpedance { JY9810CoreOO::Impedance50Ohm = JY9810Import::JY9810_AI_OHM_50 , JY9810CoreOO::ImpedanceHigh = JY9810Import::JY9810_AI_OHM_1M }
AI Impedance. More...
enum class | JY9810CoreOO::MultiChannelCompositionLogic { JY9810CoreOO::Or , JY9810CoreOO::And }
Multichannel composition logic. More...
enum class | JY9810CoreOO::AISampleClockSource { JY9810CoreOO::Internal , JY9810CoreOO::External }
enum class JY9810CoreOO::AITriggerType {
JY9810CoreOO::Immediate = JY9810Import::JY9810_TriggerType_Immediately , JY9810CoreOO::Digital = JY9810Import::JY9810_TriggerType_Digital , JY9810CoreOO::Analog = JY9810Import::JY9810_TriggerType_Analog , JY9810CoreOO::Soft = JY9810Import::JY9810_TriggerType_Soft ,
JY9810CoreOO::MultiChannelAanlog = 4
}
enum class | JY9810CoreOO::AITriggerMode { JY9810CoreOO::Start , JY9810CoreOO::Reference }
enum class | JY9810CoreOO::AIAnalogTriggerSource { JY9810CoreOO::Channel_0 , JY9810CoreOO::Channel_1 , JY9810CoreOO::Channel_2 , JY9810CoreOO::Channel_3 }
enum class JY9810CoreOO::AIDigitalTriggerSource {
JY9810CoreOO::PXI_Trig0 = JY9810Import::JY9810_DigitalTriggerSource_PXI_0 , JY9810CoreOO::PXI_Trig1 = JY9810Import::JY9810_DigitalTriggerSource_PXI_1 , JY9810CoreOO::PXI_Trig2 = JY9810Import::JY9810_DigitalTriggerSource_PXI_2 , JY9810CoreOO::PXI_Trig3 = JY9810Import::JY9810_DigitalTriggerSource_PXI_3 ,
JY9810CoreOO::PXI_Trig4 = JY9810Import::JY9810_DigitalTriggerSource_PXI_4 , JY9810CoreOO::PXI_Trig5 = JY9810Import::JY9810_DigitalTriggerSource_PXI_5 , JY9810CoreOO::PXI_Trig6 = JY9810Import::JY9810_DigitalTriggerSource_PXI_6 , JY9810CoreOO::PXI_Trig7 = JY9810Import::JY9810_DigitalTriggerSource_PXI_7 ,
JY9810CoreOO::PFI_0 = JY9810Import::JY9810_DigitalTriggerSource_TRIG_IN , JY9810CoreOO::PXIe_DStarB = JY9810Import::JY9810_DigitalTriggerSource_PXIe_DStarB , JY9810CoreOO::PXIe_DStarC = JY9810Import::JY9810_DigitalTriggerSource_PXIe_DStarC
}
enum class | JY9810CoreOO::AIDigitalTriggerEdge { JY9810CoreOO::Rising = 0x0 , JY9810CoreOO::Falling = 0x1 }
enum class | JY9810CoreOO::AIAnalogTriggerEdge { JY9810CoreOO::Rising , JY9810CoreOO::Falling }
enum class | JY9810CoreOO::AIAnalogWindowCondition { JY9810CoreOO::Entering , JY9810CoreOO::Leaving }
AI Analog Window Trigger Condition. More...
enum class | JY9810CoreOO::AIAnalogTriggerComparator { JY9810CoreOO::Edge , JY9810CoreOO::Hysteresis , JY9810CoreOO::Window }
AI Analog Trigger Comparator. More...
enum class JY9810CoreOO::AISignalExportSource {
JY9810CoreOO::PXI_Trig0 = JY9810Import::JY9810_TriggerOut_PXI_0 , JY9810CoreOO::PXI_Trig1 = JY9810Import::JY9810_TriggerOut_PXI_1 , JY9810CoreOO::PXI_Trig2 = JY9810Import::JY9810_TriggerOut_PXI_2 , JY9810CoreOO::PXI_Trig3 = JY9810Import::JY9810_TriggerOut_PXI_3 ,
JY9810CoreOO::PXI_Trig4 = JY9810Import::JY9810_TriggerOut_PXI_4 , JY9810CoreOO::PXI_Trig5 = JY9810Import::JY9810_TriggerOut_PXI_5 , JY9810CoreOO::PXI_Trig6 = JY9810Import::JY9810_TriggerOut_PXI_6 , JY9810CoreOO::PXI_Trig7 = JY9810Import::JY9810_TriggerOut_PXI_7 ,
JY9810CoreOO::StartTrig = JY9810Import::JY9810_StartTrigger , JY9810CoreOO::ReferenceTrig = JY9810Import::JY9810_RefTrigger , JY9810CoreOO::SyncTriggerOut = JY9810Import::SyncSignal_IN , JY9810CoreOO::SyncValidOut = JY9810Import::JY9810_PLL_SYNC_OUT ,
JY9810CoreOO::AIClkOut = 20 , JY9810CoreOO::PLLClkOut = 19 , JY9810CoreOO::AIClkDivider = 7 , JY9810CoreOO::SyncValidDelayOut = 25
}
enum class | JY9810CoreOO::FileFormat { JY9810CoreOO::Bin }
enum class | JY9810CoreOO::RecordMode { JY9810CoreOO::Finite , JY9810CoreOO::Infinite }
enum class | JY9810CoreOO::SyncTopology { JY9810CoreOO::Independent , JY9810CoreOO::Master , JY9810CoreOO::Slave }
Synchronization board configuration. More...
enum class JY9810CoreOO::SyncTriggerRouting {
JY9810CoreOO::NONE = -1 , JY9810CoreOO::PXI_Trig0 = JY9810Import::JY9810_TriggerOut_PXI_0 , JY9810CoreOO::PXI_Trig1 = JY9810Import::JY9810_TriggerOut_PXI_1 , JY9810CoreOO::PXI_Trig2 = JY9810Import::JY9810_TriggerOut_PXI_2 ,
JY9810CoreOO::PXI_Trig3 = JY9810Import::JY9810_TriggerOut_PXI_3 , JY9810CoreOO::PXI_Trig4 = JY9810Import::JY9810_TriggerOut_PXI_4 , JY9810CoreOO::PXI_Trig5 = JY9810Import::JY9810_TriggerOut_PXI_5 , JY9810CoreOO::PXI_Trig6 = JY9810Import::JY9810_TriggerOut_PXI_6 ,
JY9810CoreOO::PXI_Trig7 = JY9810Import::JY9810_TriggerOut_PXI_7 , JY9810CoreOO::PFI_0 = JY9810Import::JY9810_TriggerOut_TRG_OUT
}
enum class JY9810CoreOO::SyncPulseRouting {
JY9810CoreOO::NONE = -1 , JY9810CoreOO::PXI_Trig0 = JY9810Import::JY9810_TriggerOut_PXI_0 , JY9810CoreOO::PXI_Trig1 = JY9810Import::JY9810_TriggerOut_PXI_1 , JY9810CoreOO::PXI_Trig2 = JY9810Import::JY9810_TriggerOut_PXI_2 ,
JY9810CoreOO::PXI_Trig3 = JY9810Import::JY9810_TriggerOut_PXI_3 , JY9810CoreOO::PXI_Trig4 = JY9810Import::JY9810_TriggerOut_PXI_4 , JY9810CoreOO::PXI_Trig5 = JY9810Import::JY9810_TriggerOut_PXI_5 , JY9810CoreOO::PXI_Trig6 = JY9810Import::JY9810_TriggerOut_PXI_6 ,
JY9810CoreOO::PXI_Trig7 = JY9810Import::JY9810_TriggerOut_PXI_7 , JY9810CoreOO::PFI_0 = JY9810Import::JY9810_TriggerOut_TRG_OUT
}

Macro Definition Documentation

◆ _CRT_SECURE_NO_WARNINGS

#define _CRT_SECURE_NO_WARNINGS


9810 C++ Programming Manual: JY9810CoreOO::JY9810CoreOOAITask Class Reference

  • Class List
  • Class Index
  • Class Members
  • JY9810CoreOO
  • JY9810CoreOOAITask
Public Member Functions | Public Attributes | List of all members
JY9810CoreOO::JY9810CoreOOAITask Class Reference

aiTask类 More...

#include <JY9810CoreOOAITask.h>

Public Member Functions

JY9810CoreOOAITask (int slotNum)
Constructor.
JY9810CoreOOAITask (std::string boardName)
Constructor.
void | AddChannel (int chnId, double rangeLow=-10, double rangeHigh=10, AICoupling coupling=AICoupling::DC, AIImpedance impedance=AIImpedance::Impedance50Ohm)
Add one channel.
void | AddChannel (std::vector< int > chnsId, double rangeLow=-10, double rangeHigh=10, AICoupling coupling=AICoupling::DC, AIImpedance impedance=AIImpedance::Impedance50Ohm)
Add a group of channels.
void | AddChannel (std::vector< int > chnsId, std::vector< double > rangeLow, std::vector< double > rangeHigh, std::vector< AICoupling > coupling, std::vector< AIImpedance > impedance)
Add a group of channels, each channel range can be set differently.
void | RemoveChannel (int chnId)
Delete the channel with the specified channel number.
void | ReadData (double *pBuf, int samplesPerChannel, int timeout=-1)
Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.
void | ReadRawData (short *pBuf, int samplesPerChannel, int timeout=-1)
Read one or multi-channel raw data by columns and store it in a data buffer.
void | GetRecordPreviewData (double *buf, int samplesPerChannel, int timeout=1000)
Preview one channel or multi-channel data when streaming is in progress.
void | GetRecordStatus (double *recordedLength, bool *recordDone)
Get the streaming status.
void | Start ()
Start Task.
void | SendSoftwareTrigger ()
Generate a software trigger signal generate a software trigger signal.
void | Stop ()
Stop Task.
~JY9810CoreOOAITask ()

Public Attributes

std::list< AIChannel * > | Channels
List of AI channels,(9815 9817 support 4 Diff channel)
JY9810CoreOOProperty< JY9810CoreOOAITask, double, JY9810CoreOOPropertyType::READ_WRITE > | SampleRate
Sample rate per channel.
unsigned int | SamplesToAcquire
Number of samples to be read per channel.
JY9810CoreOOProperty< JY9810CoreOOAITask, int, JY9810CoreOOPropertyType::READ_ONLY > | BufLenInSamples
Number of samples per channel can be storage in the buffer, the Property SamplesToAcquire must be less than or equal to this value.
JY9810CoreOOProperty< JY9810CoreOOAITask, uint64_t, JY9810CoreOOPropertyType::READ_ONLY > | AvailableSamples
Number of samples per channel that can be read in the buffer .
JY9810CoreOOProperty< JY9810CoreOOAITask, uint64_t, JY9810CoreOOPropertyType::READ_ONLY > | TransferedSamples
The number of samples that have been transfered from the local buffer (per channel).
AIMode Mode
AI acquisition mode, support Finite/Continuous/Record *.
AISampleClock * SampleClock
AI Sample Clock.
AITrigger * Trigger
AI Trigger Configuration.
AIRecord * Record
AI Data streaming Configuration.
bool | DisableCalibration
AISignalExport * SignalExport
Export AI Signal Configuration.
bool | DisableDigitalTriggerDelay
Disalble calibration Enable.
AISync * Sync
Multi card synchronous configuration.
JY9810CoreOODevice * Device
Device.

Detailed Description

aiTask类

Constructor & Destructor Documentation

◆ JY9810CoreOOAITask() [1/2]

JY9810CoreOO::JY9810CoreOOAITask::JY9810CoreOOAITask ( int slotNum )

Constructor.

Used to create an AI task by a slot number

Parameters
slotNum Card slot number.

◆ JY9810CoreOOAITask() [2/2]

JY9810CoreOO::JY9810CoreOOAITask::JY9810CoreOOAITask ( std::string boardName )

Constructor.

Used to create an AI task by a slot number

Parameters
slotNum Card slot number.

◆ ~JY9810CoreOOAITask()

JY9810CoreOO::JY9810CoreOOAITask::~JY9810CoreOOAITask ( )

Member Function Documentation

◆ AddChannel() [1/3]

void JY9810CoreOO::JY9810CoreOOAITask::AddChannel | ( | int | chnId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10,
 |  | AICoupling | coupling = AICoupling::DC,
 |  | AIImpedance | impedance = AIImpedance::Impedance50Ohm )

Add one channel.

Parameters
channelID | channel's physical number ，chnId=-1, add all channels
rangeLow | lower range limit for the channel，-50V，-25V，-10V，5V，-1V，-0.5V
rangeHigh | higher range limit for the channel，50V，25V，10V，5V，1V，0.5V
coupling | coupling
impedance | impedance
Returns

◆ AddChannel() [2/3]

void JY9810CoreOO::JY9810CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10,
 |  | AICoupling | coupling = AICoupling::DC,
 |  | AIImpedance | impedance = AIImpedance::Impedance50Ohm )

Add a group of channels.

Parameters
channelIDs | a group of channel physical numbers
rangeLow | lower range limit for the channel，-50V，-25V，-10V，-5V，-1V，-0.5V
rangeHigh | higher range limit for the channel，50V，25V，10V，5V，1V，0.5V
coupling | coupling
impedance | impedance
Returns

◆ AddChannel() [3/3]

void JY9810CoreOO::JY9810CoreOOAITask::AddChannel | ( | std::vector< int > | chnsId,
 |  | std::vector< double > | rangeLow,
 |  | std::vector< double > | rangeHigh,
 |  | std::vector< AICoupling > | coupling,
 |  | std::vector< AIImpedance > | impedance )

Add a group of channels, each channel range can be set differently.

Parameters
channelIDs | a group of channel physical numbers,different mode 0-15
rangeLow | lower range limit for the channel，-50V，-25V，-10V,-5V,-2V，-1V
rangeHigh | higher range limit for the channel,50V，25V，10V,5V,2V，1V
coupling | coupling
impedance | impedance

◆ GetRecordPreviewData()

void JY9810CoreOO::JY9810CoreOOAITask::GetRecordPreviewData | ( | double * | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 1000 )

Preview one channel or multi-channel data when streaming is in progress.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ GetRecordStatus()

void JY9810CoreOO::JY9810CoreOOAITask::GetRecordStatus | ( | double * | recordedLength,
 |  | bool * | recordDone )

Get the streaming status.

Parameters
recordedLength | Length of the streamed, unit s
recordDone | recordDone = false :streaming is not over.recordDone = true :streaming is over

◆ ReadData()

void JY9810CoreOO::JY9810CoreOOAITask::ReadData | ( | double * | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = -1 )

Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.

param name="pBuf">Data buffer

Parameters
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish

◆ ReadRawData()

void JY9810CoreOO::JY9810CoreOOAITask::ReadRawData | ( | short * | pBuf,
 |  | int | samplesPerChannel,
 |  | int | timeout = -1 )

Read one or multi-channel raw data by columns and store it in a data buffer.

The buffer is pointed by C/C++ data type short.

Parameters
pBuf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ RemoveChannel()

void JY9810CoreOO::JY9810CoreOOAITask::RemoveChannel ( int chnId )

Delete the channel with the specified channel number.

chnId=- 1, all channels will be deleted

Parameters
chnId Channel number of the channel to be deleted

◆ SendSoftwareTrigger()

void JY9810CoreOO::JY9810CoreOOAITask::SendSoftwareTrigger ( )

Generate a software trigger signal generate a software trigger signal.

Returns

◆ Start()

void JY9810CoreOO::JY9810CoreOOAITask::Start ( )

Start Task.

Parameters

return void

Exceptions
JYDriverException When startup fails

◆ Stop()

void JY9810CoreOO::JY9810CoreOOAITask::Stop ( )

Stop Task.

Parameters

return void

Exceptions
JYDriverException When stop fails

Member Data Documentation

◆ AvailableSamples

JY9810CoreOOProperty<JY9810CoreOOAITask, uint64_t, JY9810CoreOOPropertyType::READ_ONLY> JY9810CoreOO::JY9810CoreOOAITask::AvailableSamples

Number of samples per channel that can be read in the buffer .

Valid when Mode is NOT AIMode.Single.

◆ BufLenInSamples

JY9810CoreOOProperty<JY9810CoreOOAITask, int, JY9810CoreOOPropertyType::READ_ONLY> JY9810CoreOO::JY9810CoreOOAITask::BufLenInSamples

Number of samples per channel can be storage in the buffer, the Property SamplesToAcquire must be less than or equal to this value.

◆ Channels

std::list<AIChannel*> JY9810CoreOO::JY9810CoreOOAITask::Channels

List of AI channels,(9815 9817 support 4 Diff channel)

◆ Device

JY9810CoreOODevice* JY9810CoreOO::JY9810CoreOOAITask::Device

Device.

◆ DisableCalibration

bool JY9810CoreOO::JY9810CoreOOAITask::DisableCalibration

◆ DisableDigitalTriggerDelay

bool JY9810CoreOO::JY9810CoreOOAITask::DisableDigitalTriggerDelay

Disalble calibration Enable.

◆ Mode

AIMode JY9810CoreOO::JY9810CoreOOAITask::Mode

AI acquisition mode, support Finite/Continuous/Record *.

◆ Record

AIRecord* JY9810CoreOO::JY9810CoreOOAITask::Record

AI Data streaming Configuration.

◆ SampleClock

AISampleClock* JY9810CoreOO::JY9810CoreOOAITask::SampleClock

AI Sample Clock.

◆ SampleRate

JY9810CoreOOProperty<JY9810CoreOOAITask, double, JY9810CoreOOPropertyType::READ_WRITE> JY9810CoreOO::JY9810CoreOOAITask::SampleRate

Sample rate per channel.

Maximum sample rate is 125M for ecah channel. The defalut sample rate = 125M You can read this property to obtain the sample rate that will actually take effect in the current configuration.

Exceptions
JYDriverException

◆ SamplesToAcquire

unsigned int JY9810CoreOO::JY9810CoreOOAITask::SamplesToAcquire

Number of samples to be read per channel.

Only valid when Mode is Finite*

◆ SignalExport

AISignalExport* JY9810CoreOO::JY9810CoreOOAITask::SignalExport

Export AI Signal Configuration.

◆ Sync

AISync* JY9810CoreOO::JY9810CoreOOAITask::Sync

Multi card synchronous configuration.

◆ TransferedSamples

JY9810CoreOOProperty<JY9810CoreOOAITask, uint64_t, JY9810CoreOOPropertyType::READ_ONLY> JY9810CoreOO::JY9810CoreOOAITask::TransferedSamples

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT AIMode.Single.

◆ Trigger

AITrigger* JY9810CoreOO::JY9810CoreOOAITask::Trigger

AI Trigger Configuration.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9810/JY9810CoreOOAITask.h


9810 C++ Programming Manual: JY9810CoreOO::AIChannel Class Reference

  • JY9810CoreOO
  • AIChannel
Public Member Functions | Public Attributes | List of all members
JY9810CoreOO::AIChannel Class Reference

#include <JY9810CoreOOAITask.h>

Public Member Functions

AIChannel (int channelId, double rangeLow, double rangeHigh, AICoupling coupling, AIImpedance impedance=AIImpedance::Impedance50Ohm)

Public Attributes

int | ChannelID
double | RangeLow
double | RangeHigh
AICoupling Coupling
AIImpedance Impedance

Constructor & Destructor Documentation

◆ AIChannel()

JY9810CoreOO::AIChannel::AIChannel | ( | int | channelId,
 |  | double | rangeLow,
 |  | double | rangeHigh,
 |  | AICoupling | coupling,
 |  | AIImpedance | impedance = AIImpedance::Impedance50Ohm )
 inline

Member Data Documentation

◆ ChannelID

int JY9810CoreOO::AIChannel::ChannelID

◆ Coupling

AICoupling JY9810CoreOO::AIChannel::Coupling

◆ Impedance

AIImpedance JY9810CoreOO::AIChannel::Impedance

◆ RangeHigh

double JY9810CoreOO::AIChannel::RangeHigh

◆ RangeLow

double JY9810CoreOO::AIChannel::RangeLow
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9810/JY9810CoreOOAITask.h


9810 C++ Programming Manual: JY9810CoreOO::AIExternalSampleClock Class Reference

  • AIExternalSampleClock
Public Attributes | List of all members
JY9810CoreOO::AIExternalSampleClock Class Reference

#include <JY9810CoreOOAITask.h>

Public Attributes

ClockTerminal Terminal
External Sample Clock Input Terminal.
double ExpectedRate
Expected External Sample Clock Rate.

Member Data Documentation

◆ ExpectedRate

double JY9810CoreOO::AIExternalSampleClock::ExpectedRate

Expected External Sample Clock Rate.

◆ Terminal

ClockTerminal JY9810CoreOO::AIExternalSampleClock::Terminal

External Sample Clock Input Terminal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9810/JY9810CoreOOAITask.h


9810 C++ Programming Manual: JY9810CoreOO::AISampleClock Class Reference

  • AISampleClock
Public Attributes | List of all members
JY9810CoreOO::AISampleClock Class Reference

#include <JY9810CoreOOAITask.h>

Public Attributes

AISampleClockSource Source
AI Sample Clock Source.
AIExternalSampleClock * External
External Sample Clock Configuration.

Member Data Documentation

◆ External

AIExternalSampleClock* JY9810CoreOO::AISampleClock::External

External Sample Clock Configuration.

Valid when Source is AISampleClockSource.External.

◆ Source

AISampleClockSource JY9810CoreOO::AISampleClock::Source

AI Sample Clock Source.

enum Internal/External. The default value is AISampleClockSource.Internal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9810/JY9810CoreOOAITask.h


9810 C++ Programming Manual: JY9810CoreOO::AITrigger Class Reference

  • AITrigger
Public Attributes | List of all members
JY9810CoreOO::AITrigger Class Reference

#include <JY9810CoreOOAITask.h>

Public Attributes

AITriggerType Type
AI trigger type.
AITriggerMode Mode
AI trigger mode.
AIDigitalTrigger * Digital
Digital Trigger Congfiguration.
AIAnalogTrigger * Analog
AI Analog Trigger.
AIMultiChannelAnalogTrigger * MultiChannel
AI Analog Trigger.
int | ReTriggerCount
Number of repeat triggers.
unsigned int | PreTriggerSamples
AI pretrigger samples, must be less than or equal to JY9810aiTask.SamplesToAcquire.

Member Data Documentation

◆ Analog

AIAnalogTrigger* JY9810CoreOO::AITrigger::Analog

AI Analog Trigger.

Valid when Type is AITriggerType.Analog.

◆ Digital

AIDigitalTrigger* JY9810CoreOO::AITrigger::Digital

Digital Trigger Congfiguration.

Valid when Type is AITriggerType.Digital.

◆ Mode

AITriggerMode JY9810CoreOO::AITrigger::Mode

AI trigger mode.

enum Start/Reference. The default value is AITriggerMode.Start.

◆ MultiChannel

AIMultiChannelAnalogTrigger* JY9810CoreOO::AITrigger::MultiChannel

AI Analog Trigger.

Valid when Type is AITriggerType.Analog.

◆ PreTriggerSamples

unsigned int JY9810CoreOO::AITrigger::PreTriggerSamples

AI pretrigger samples, must be less than or equal to JY9810aiTask.SamplesToAcquire.

Valid when Mode is AITriggerMode.Reference. Pretrigger samples, must be greater than 0. Valid when Type is AITriggerType.Analog. Pretrigger samples, must be greater than 1. Valid when Type is AITriggerType.Digital.

◆ ReTriggerCount

int JY9810CoreOO::AITrigger::ReTriggerCount

Number of repeat triggers.

When 0 or 1 only trigger once, When -1 continuous retrigger until stop.

◆ Type

AITriggerType JY9810CoreOO::AITrigger::Type

AI trigger type.

enum Analog/Digital/Immediate/Soft. The default value is AITriggerType.Immediate.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9810/JY9810CoreOOAITask.h


9810 C++ Programming Manual: JY9810CoreOO::AIDigitalTrigger Class Reference

  • AIDigitalTrigger
Public Attributes | List of all members
JY9810CoreOO::AIDigitalTrigger Class Reference

#include <JY9810CoreOOAITask.h>

Public Attributes

AIDigitalTriggerSource Source
AI Digital Trigger source.
AIDigitalTriggerEdge Edge
Digital Trigger edge，Rising/Falling.

Member Data Documentation

◆ Edge

AIDigitalTriggerEdge JY9810CoreOO::AIDigitalTrigger::Edge

Digital Trigger edge，Rising/Falling.

◆ Source

AIDigitalTriggerSource JY9810CoreOO::AIDigitalTrigger::Source

AI Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9810/JY9810CoreOOAITask.h


9810 C++ Programming Manual: JY9810CoreOO::AIAnalogHysteresisComparator Class Reference

  • AIAnalogHysteresisComparator
Public Attributes | List of all members
JY9810CoreOO::AIAnalogHysteresisComparator Class Reference

#include <JY9810CoreOOAITask.h>

Public Attributes

AIAnalogTriggerEdge Slope
AI Analog Trigger Edge.
double | HighThreshold
High Threshold.
double | LowThreshold
Low Threshold.

Member Data Documentation

◆ HighThreshold

double JY9810CoreOO::AIAnalogHysteresisComparator::HighThreshold

High Threshold.

◆ LowThreshold

double JY9810CoreOO::AIAnalogHysteresisComparator::LowThreshold

Low Threshold.

◆ Slope

AIAnalogTriggerEdge JY9810CoreOO::AIAnalogHysteresisComparator::Slope

AI Analog Trigger Edge.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9810/JY9810CoreOOAITask.h


9810 C++ Programming Manual: JY9810CoreOO::AIAnalogWindowComparator Class Reference

  • AIAnalogWindowComparator
Public Attributes | List of all members
JY9810CoreOO::AIAnalogWindowComparator Class Reference

#include <JY9810CoreOOAITask.h>

Public Attributes

AIAnalogWindowCondition Condition
AI Analog Window Condition.
double | HighThreshold
High Threshold.
double | LowThreshold
Low Threshold.

Member Data Documentation

◆ Condition

AIAnalogWindowCondition JY9810CoreOO::AIAnalogWindowComparator::Condition

AI Analog Window Condition.

◆ HighThreshold

double JY9810CoreOO::AIAnalogWindowComparator::HighThreshold

High Threshold.

◆ LowThreshold

double JY9810CoreOO::AIAnalogWindowComparator::LowThreshold

Low Threshold.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9810/JY9810CoreOOAITask.h


9810 C++ Programming Manual: JY9810CoreOO::AIAnalogEdgeComparator Class Reference

  • AIAnalogEdgeComparator
Public Attributes | List of all members
JY9810CoreOO::AIAnalogEdgeComparator Class Reference

#include <JY9810CoreOOAITask.h>

Public Attributes

AIAnalogTriggerEdge Slope
AI Analog Trigger Edge.
double Threshold
Threshold.

Member Data Documentation

◆ Slope

AIAnalogTriggerEdge JY9810CoreOO::AIAnalogEdgeComparator::Slope

AI Analog Trigger Edge.

◆ Threshold

double JY9810CoreOO::AIAnalogEdgeComparator::Threshold

Threshold.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9810/JY9810CoreOOAITask.h


9810 C++ Programming Manual: JY9810CoreOO::AIAnalogTrigger Class Reference

  • AIAnalogTrigger
Public Member Functions | Public Attributes | List of all members
JY9810CoreOO::AIAnalogTrigger Class Reference

#include <JY9810CoreOOAITask.h>

Public Member Functions

AIAnalogTrigger ()
AIAnalogTrigger (AIAnalogTriggerSource src, AIAnalogTriggerComparator comparator)
~AIAnalogTrigger ()

Public Attributes

AIAnalogTriggerSource Source
Analog Trigger source.
AIAnalogTriggerComparator Comparator
AI Analog Trigger Comparator.
AIAnalogEdgeComparator * Edge
AI Analog Edge Comparator.
AIAnalogHysteresisComparator * Hysteresis
AI Analog Hysteresis Comparatorr.
AIAnalogWindowComparator * Window
AI Analog Window Comparatorr.

Constructor & Destructor Documentation

◆ AIAnalogTrigger() [1/2]

JY9810CoreOO::AIAnalogTrigger::AIAnalogTrigger ( )

◆ AIAnalogTrigger() [2/2]

JY9810CoreOO::AIAnalogTrigger::AIAnalogTrigger | ( | AIAnalogTriggerSource | src,
 |  | AIAnalogTriggerComparator | comparator )

◆ ~AIAnalogTrigger()

JY9810CoreOO::AIAnalogTrigger::~AIAnalogTrigger ( )

Member Data Documentation

◆ Comparator

AIAnalogTriggerComparator JY9810CoreOO::AIAnalogTrigger::Comparator

AI Analog Trigger Comparator.

◆ Edge

AIAnalogEdgeComparator* JY9810CoreOO::AIAnalogTrigger::Edge

AI Analog Edge Comparator.

◆ Hysteresis

AIAnalogHysteresisComparator* JY9810CoreOO::AIAnalogTrigger::Hysteresis

AI Analog Hysteresis Comparatorr.

◆ Source

AIAnalogTriggerSource JY9810CoreOO::AIAnalogTrigger::Source

Analog Trigger source.

◆ Window

AIAnalogWindowComparator* JY9810CoreOO::AIAnalogTrigger::Window

AI Analog Window Comparatorr.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9810/JY9810CoreOOAITask.h


9810 C++ Programming Manual: JY9810CoreOO::AIMultiChannelAnalogTrigger Class Reference

  • AIMultiChannelAnalogTrigger
Public Attributes | List of all members
JY9810CoreOO::AIMultiChannelAnalogTrigger Class Reference

#include <JY9810CoreOOAITask.h>

Public Attributes

MultiChannelCompositionLogic Logic
Multichannel composition logic, and / or.
std::vector< AIAnalogTrigger > Analog
Analog Trigger Config.

Member Data Documentation

◆ Analog

std::vector<AIAnalogTrigger> JY9810CoreOO::AIMultiChannelAnalogTrigger::Analog

Analog Trigger Config.

◆ Logic

MultiChannelCompositionLogic JY9810CoreOO::AIMultiChannelAnalogTrigger::Logic

Multichannel composition logic, and / or.

defalut or.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9810/JY9810CoreOOAITask.h


9810 C++ Programming Manual: JY9810CoreOO::AISignalExport Class Reference

  • AISignalExport
Public Member Functions | List of all members
JY9810CoreOO::AISignalExport Class Reference

#include <JY9810CoreOOAITask.h>

Public Member Functions

void | Add (AISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (AISignalExportSource source, std::list< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Member Function Documentation

◆ Add() [1/2]

void JY9810CoreOO::AISignalExport::Add | ( | AISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | AI Signal Source
destination | Export Desination

◆ Add() [2/2]

void JY9810CoreOO::AISignalExport::Add | ( | AISignalExportSource | source,
 |  | std::list< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | AI Signal Source
destinations | Mutil Export Desinations

◆ Clear()

void JY9810CoreOO::AISignalExport::Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JY9810CoreOO::AISignalExport::ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9810/JY9810CoreOOAITask.h


9810 C++ Programming Manual: JY9810CoreOO::AIRecordAdvanced Class Reference

  • AIRecordAdvanced
JY9810CoreOO::AIRecordAdvanced Class Reference

#include <JY9810CoreOOAITask.h>

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9810/JY9810CoreOOAITask.h


9810 C++ Programming Manual: JY9810CoreOO::AIRecord Class Reference

  • AIRecord
Public Attributes | List of all members
JY9810CoreOO::AIRecord Class Reference

#include <JY9810CoreOOAITask.h>

Public Attributes

std::string | FilePath
User specified file path.
FileFormat File_Format
Streaming file format.
RecordMode Mode
stream mode .
double | Length
User specified stream length in second.
AIRecordAdvanced * Advanced
The adcanced property for record.

Member Data Documentation

◆ Advanced

AIRecordAdvanced* JY9810CoreOO::AIRecord::Advanced

The adcanced property for record.

◆ File_Format

FileFormat JY9810CoreOO::AIRecord::File_Format

Streaming file format.

enum BIN.

◆ FilePath

std::string JY9810CoreOO::AIRecord::FilePath

User specified file path.

◆ Length

double JY9810CoreOO::AIRecord::Length

User specified stream length in second.

Only when Mode is RecordMode.Finite.

◆ Mode

RecordMode JY9810CoreOO::AIRecord::Mode

stream mode .

enum Finite/Infinite.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9810/JY9810CoreOOAITask.h


9810 C++ Programming Manual: JY9810CoreOO::AISync Class Reference

  • AISync
Public Attributes | List of all members
JY9810CoreOO::AISync Class Reference

Configure sync signal. More...

#include <JY9810CoreOOAITask.h>

Public Attributes

SyncTopology Topology
SyncTriggerRouting TriggerRouting
SyncPulseRouting PulseRouting

Detailed Description

Configure sync signal.

Member Data Documentation

◆ PulseRouting

SyncPulseRouting JY9810CoreOO::AISync::PulseRouting

◆ Topology

SyncTopology JY9810CoreOO::AISync::Topology

◆ TriggerRouting

SyncTriggerRouting JY9810CoreOO::AISync::TriggerRouting
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9810/JY9810CoreOOAITask.h


9810 C++ Programming Manual: JY9810CoreOO Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Enumerations | Functions
JY9810CoreOO Namespace Reference

Classes

class | AIAnalogEdgeComparator
class | AIAnalogHysteresisComparator
class | AIAnalogTrigger
class | AIAnalogWindowComparator
class | AIChannel
class | AIDigitalTrigger
class | AIExternalSampleClock
class | AIMultiChannelAnalogTrigger
class | AIRecord
class | AIRecordAdvanced
class | AISampleClock
class | AISignalExport
class | AISync
Configure sync signal. More...
class | AITrigger
class | ExternalReferenceClock
External Reference Clcok Terminal. More...
class | JY9810CoreOOAITask
aiTask类 More...
class | JY9810CoreOODevice
class | JY9810CoreOOLog
class | JY9810CoreOOProperty
属性模板类 More...
class | JY9810CoreOOReferenceClock
class | JYDriverException
class | PauseTrigger
Pause trigger configuration class. More...

Enumerations

enum class | AIMode { Finite = JY9810Import::JY9810_Finite , Continuous = JY9810Import::JY9810_Continuous , Record = 0x3 }
enum class | AICoupling { DC = JY9810Import::JY9810_AI_DC_Couple , AC = JY9810Import::JY9810_AI_AC_Couple }
AI Coupling. More...
enum class | AIImpedance { Impedance50Ohm = JY9810Import::JY9810_AI_OHM_50 , ImpedanceHigh = JY9810Import::JY9810_AI_OHM_1M }
AI Impedance. More...
enum class | MultiChannelCompositionLogic { Or , And }
Multichannel composition logic. More...
enum class | AISampleClockSource { Internal , External }
enum class AITriggerType {
Immediate = JY9810Import::JY9810_TriggerType_Immediately , Digital = JY9810Import::JY9810_TriggerType_Digital , Analog = JY9810Import::JY9810_TriggerType_Analog , Soft = JY9810Import::JY9810_TriggerType_Soft ,
MultiChannelAanlog = 4
}
enum class | AITriggerMode { Start , Reference }
enum class | AIAnalogTriggerSource { Channel_0 , Channel_1 , Channel_2 , Channel_3 }
enum class AIDigitalTriggerSource {
PXI_Trig0 = JY9810Import::JY9810_DigitalTriggerSource_PXI_0 , PXI_Trig1 = JY9810Import::JY9810_DigitalTriggerSource_PXI_1 , PXI_Trig2 = JY9810Import::JY9810_DigitalTriggerSource_PXI_2 , PXI_Trig3 = JY9810Import::JY9810_DigitalTriggerSource_PXI_3 ,
PXI_Trig4 = JY9810Import::JY9810_DigitalTriggerSource_PXI_4 , PXI_Trig5 = JY9810Import::JY9810_DigitalTriggerSource_PXI_5 , PXI_Trig6 = JY9810Import::JY9810_DigitalTriggerSource_PXI_6 , PXI_Trig7 = JY9810Import::JY9810_DigitalTriggerSource_PXI_7 ,
PFI_0 = JY9810Import::JY9810_DigitalTriggerSource_TRIG_IN , PXIe_DStarB = JY9810Import::JY9810_DigitalTriggerSource_PXIe_DStarB , PXIe_DStarC = JY9810Import::JY9810_DigitalTriggerSource_PXIe_DStarC
}
enum class | AIDigitalTriggerEdge { Rising = 0x0 , Falling = 0x1 }
enum class | AIAnalogTriggerEdge { Rising , Falling }
enum class | AIAnalogWindowCondition { Entering , Leaving }
AI Analog Window Trigger Condition. More...
enum class | AIAnalogTriggerComparator { Edge , Hysteresis , Window }
AI Analog Trigger Comparator. More...
enum class AISignalExportSource {
PXI_Trig0 = JY9810Import::JY9810_TriggerOut_PXI_0 , PXI_Trig1 = JY9810Import::JY9810_TriggerOut_PXI_1 , PXI_Trig2 = JY9810Import::JY9810_TriggerOut_PXI_2 , PXI_Trig3 = JY9810Import::JY9810_TriggerOut_PXI_3 ,
PXI_Trig4 = JY9810Import::JY9810_TriggerOut_PXI_4 , PXI_Trig5 = JY9810Import::JY9810_TriggerOut_PXI_5 , PXI_Trig6 = JY9810Import::JY9810_TriggerOut_PXI_6 , PXI_Trig7 = JY9810Import::JY9810_TriggerOut_PXI_7 ,
StartTrig = JY9810Import::JY9810_StartTrigger , ReferenceTrig = JY9810Import::JY9810_RefTrigger , SyncTriggerOut = JY9810Import::SyncSignal_IN , SyncValidOut = JY9810Import::JY9810_PLL_SYNC_OUT ,
AIClkOut = 20 , PLLClkOut = 19 , AIClkDivider = 7 , SyncValidDelayOut = 25
}
enum class | FileFormat { Bin }
enum class | RecordMode { Finite , Infinite }
enum class | SyncTopology { Independent , Master , Slave }
Synchronization board configuration. More...
enum class SyncTriggerRouting {
NONE = -1 , PXI_Trig0 = JY9810Import::JY9810_TriggerOut_PXI_0 , PXI_Trig1 = JY9810Import::JY9810_TriggerOut_PXI_1 , PXI_Trig2 = JY9810Import::JY9810_TriggerOut_PXI_2 ,
PXI_Trig3 = JY9810Import::JY9810_TriggerOut_PXI_3 , PXI_Trig4 = JY9810Import::JY9810_TriggerOut_PXI_4 , PXI_Trig5 = JY9810Import::JY9810_TriggerOut_PXI_5 , PXI_Trig6 = JY9810Import::JY9810_TriggerOut_PXI_6 ,
PXI_Trig7 = JY9810Import::JY9810_TriggerOut_PXI_7 , PFI_0 = JY9810Import::JY9810_TriggerOut_TRG_OUT
}
enum class SyncPulseRouting {
NONE = -1 , PXI_Trig0 = JY9810Import::JY9810_TriggerOut_PXI_0 , PXI_Trig1 = JY9810Import::JY9810_TriggerOut_PXI_1 , PXI_Trig2 = JY9810Import::JY9810_TriggerOut_PXI_2 ,
PXI_Trig3 = JY9810Import::JY9810_TriggerOut_PXI_3 , PXI_Trig4 = JY9810Import::JY9810_TriggerOut_PXI_4 , PXI_Trig5 = JY9810Import::JY9810_TriggerOut_PXI_5 , PXI_Trig6 = JY9810Import::JY9810_TriggerOut_PXI_6 ,
PXI_Trig7 = JY9810Import::JY9810_TriggerOut_PXI_7 , PFI_0 = JY9810Import::JY9810_TriggerOut_TRG_OUT
}
enum class | JY9810CoreOOPropertyType { READ_ONLY = 1 , WRITE_ONLY = 2 , READ_WRITE = 3 }
enum class JYDriverExceptionPublic {
UnKnown = 0 , OpenDeviceFailed = -10001 , CloseDeviceFailed = -10002 , ResetDeviceFailed = -10003 ,
GetDevicePropertyFailed = -10004 , SetDevicePropertyFailed = -10005 , HardwareResourceIsReserved = -10006 , MethodNotPermitedToCallWhenCurrentStatus = -10007 ,
InvalidUserDataBuffer = -10008 , NoChannelAdded = -10009 , NotSupportOperationForCurrentDevice = -10010 , CreatTaskFailed = -10100 ,
StartTaskFailed = -10101 , StopTaskFailed = -10102 , TaskHasNotStarted = -10103 , TaskHasStartedCannotPerformTheSetOperation = -10104 ,
ChannelNumberParameterInvalid = -10105 , ChannelInputRangeParameterInvalid = -10106 , ChannelTerminalParameterInvalid = -10107 , ChannelCouplingParameterInvalid = -10108 ,
SampeleModeParameterInvalid = -10109 , SampleClockParameterInvalid = -10110 , SampleRateParameterInvalid = -10111 , UpdateRateParameterInvalid = -10112 ,
TriggerParameterInvalid = -10113 , ReferenceTriggerDoesNotMatchWithSampleMode = -10114 , PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint = -10115 , ReadDataFailed = -10016 ,
ReadDataTimeout = -10017 , WriteDataFailed = -10018 , WriteDataTimeout = -10019 , WriteDataLengthCannotBeLessThanN = -10020 ,
BufferDataOverflow = -10021 , BufferDataDownflow = -10022 , CheckBufferFailed = -10023 , PointInvalidInFiniteMode = -10024 ,
ReadPointInvalid = -10025 , OnlySupportRecordMode = -10026 , SendSoftTirggerFailed = -10027 , TaskTimeout = -10028 ,
CounterParametersInvalid = -10029 , WritePointInvalid = -10030 , SignalExportDestinationInvalid = -10031 , InvalidParameter = -10033
}
enum class | ClockTerminal { CLK_IN }
enum class SignalExportDestination {
PXI_Trig0 = JY9810Import::JY9810_TriggerOut_PXI_0 , PXI_Trig1 = JY9810Import::JY9810_TriggerOut_PXI_1 , PXI_Trig2 = JY9810Import::JY9810_TriggerOut_PXI_2 , PXI_Trig3 = JY9810Import::JY9810_TriggerOut_PXI_3 ,
PXI_Trig4 = JY9810Import::JY9810_TriggerOut_PXI_4 , PXI_Trig5 = JY9810Import::JY9810_TriggerOut_PXI_5 , PXI_Trig6 = JY9810Import::JY9810_TriggerOut_PXI_6 , PXI_Trig7 = JY9810Import::JY9810_TriggerOut_PXI_7 ,
PFI_0 = JY9810Import::JY9810_TriggerOut_TRG_OUT
}
enum class | LevelPolarity { LowLevel = 0 , HighLevel = 1 , None = 2 }
Level Polarity. More...
enum class | ExternalReferenceClockTerminal { CLK_IN = JY9810Import::JY9810_Extenal_Ref_10M , PXIe_Clk100 = JY9810Import::JY9810_CB_100M }
enum class | ReferenceClockSource { Internal = 0x0 , External = 0x1 }
enum class JY9810CoreOOLogLevel {
DEBUG_LOG_LEVEL , INFO_LOG_LEVEL , WARN_LOG_LEVEL , ERROR_LOG_LEVEL ,
FATAL_LOG_LEVEL
}

Functions

std::string GetSignalExportDestinationString (SignalExportDestination destination)

Enumeration Type Documentation

◆ AIAnalogTriggerComparator

enum class JY9810CoreOO::AIAnalogTriggerComparator
strong

AI Analog Trigger Comparator.

Enumerator
Edge | Edge Comparator.
Hysteresis | Hysteresis Comparator.
Window | Window Comparator.

◆ AIAnalogTriggerEdge

enum class JY9810CoreOO::AIAnalogTriggerEdge
strong
Enumerator
Rising | Rising.
Falling | Falling.

◆ AIAnalogTriggerSource

enum class JY9810CoreOO::AIAnalogTriggerSource
strong
Enumerator
Channel_0 | Channel_0.
Channel_1 | Channel_1.
Channel_2 | Channel_2.
Channel_3 | Channel_3.

◆ AIAnalogWindowCondition

enum class JY9810CoreOO::AIAnalogWindowCondition
strong

AI Analog Window Trigger Condition.

Enumerator
Entering | Rising.
Leaving | Falling.

◆ AICoupling

enum class JY9810CoreOO::AICoupling
strong

AI Coupling.

Enumerator
DC | DC Coupling.
AC | AC Coupling.

◆ AIDigitalTriggerEdge

enum class JY9810CoreOO::AIDigitalTriggerEdge
strong
Enumerator
Rising | Rising.
Falling | Falling.

◆ AIDigitalTriggerSource

enum class JY9810CoreOO::AIDigitalTriggerSource
strong
Enumerator
PXI_Trig0 | PXI Trig 0.
PXI_Trig1 | PXI Trig 1.
PXI_Trig2 | PXI Trig 2.
PXI_Trig3 | PXI Trig 3.
PXI_Trig4 | PXI Trig 4.
PXI_Trig5 | PXI Trig 5.
PXI_Trig6 | PXI Trig 6.
PXI_Trig7 | PXI Trig 7.
PFI_0 | Front Panel PFI_0.
PXIe_DStarB | PXIe_DStarB.
PXIe_DStarC | PXIe_DStarC.

◆ AIImpedance

enum class JY9810CoreOO::AIImpedance
strong

AI Impedance.

Enumerator
Impedance50Ohm | 50Ohm Impedance
ImpedanceHigh | 1MOhm High Impedance

◆ AIMode

enum class JY9810CoreOO::AIMode
strong
Enumerator
Finite | Finite.
Continuous | Continuous.
Record | Record.

◆ AISampleClockSource

enum class JY9810CoreOO::AISampleClockSource
strong
Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ AISignalExportSource

enum class JY9810CoreOO::AISignalExportSource
strong
Enumerator
PXI_Trig0 | PXI Trig0.
PXI_Trig1 | PXI Trig1.
PXI_Trig2 | PXI Trig2.
PXI_Trig3 | PXI Trig3.
PXI_Trig4 | PXI Trig4.
PXI_Trig5 | PXI Trig5.
PXI_Trig6 | PXI Trig6.
PXI_Trig7 | PXI Trig7.
StartTrig | AI_StartTrig.
ReferenceTrig | AI_ReferenceTrig.
SyncTriggerOut | PLL sync trigger out.
SyncValidOut | PLL sync valid out.
AIClkOut | PLL sync valid out.
PLLClkOut | PLL sync valid out.
AIClkDivider |
SyncValidDelayOut |

◆ AITriggerMode

enum class JY9810CoreOO::AITriggerMode
strong
Enumerator
Start | Start Trigger.
Reference | Reference Trigger，Valid when JY9810aiTask.Mode is AIMode.Finite

◆ AITriggerType

enum class JY9810CoreOO::AITriggerType
strong
Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Analog | Analog Trigger.
Soft | Soft Trigger.
MultiChannelAanlog | multichannel analog Trigger

◆ ClockTerminal

enum class JY9810CoreOO::ClockTerminal
strong
Enumerator
CLK_IN

Front Panel CLK_IN.

◆ ExternalReferenceClockTerminal

enum class JY9810CoreOO::ExternalReferenceClockTerminal
strong
Enumerator
CLK_IN | Front Panel CLK_IN（10M）
PXIe_Clk100 | PXIe_Clk100M.

◆ FileFormat

enum class JY9810CoreOO::FileFormat
strong
Enumerator
Bin

BIN。

BIN.

◆ JY9810CoreOOLogLevel

enum class JY9810CoreOO::JY9810CoreOOLogLevel
strong
Enumerator
DEBUG_LOG_LEVEL
INFO_LOG_LEVEL
WARN_LOG_LEVEL
ERROR_LOG_LEVEL
FATAL_LOG_LEVEL

◆ JY9810CoreOOPropertyType

enum class JY9810CoreOO::JY9810CoreOOPropertyType
strong
Enumerator
READ_ONLY
WRITE_ONLY
READ_WRITE

◆ JYDriverExceptionPublic

enum class JY9810CoreOO::JYDriverExceptionPublic
strong
Enumerator
UnKnown | JYDriverExceptionPublic.
OpenDeviceFailed | JYDriverExceptionPublic.
CloseDeviceFailed | JYDriverExceptionPublic.
ResetDeviceFailed | JYDriverExceptionPublic.
GetDevicePropertyFailed | JYDriverExceptionPublic.
SetDevicePropertyFailed | JYDriverExceptionPublic.
HardwareResourceIsReserved | JYDriverExceptionPublic.
MethodNotPermitedToCallWhenCurrentStatus | JYDriverExceptionPublic.
InvalidUserDataBuffer | JYDriverExceptionPublic.
NoChannelAdded | JYDriverExceptionPublic.
NotSupportOperationForCurrentDevice | JYDriverExceptionPublic.
CreatTaskFailed | JYDriverExceptionPublic.
StartTaskFailed | JYDriverExceptionPublic.
StopTaskFailed | JYDriverExceptionPublic.
TaskHasNotStarted | JYDriverExceptionPublic.
TaskHasStartedCannotPerformTheSetOperation | JYDriverExceptionPublic.
ChannelNumberParameterInvalid | JYDriverExceptionPublic.
ChannelInputRangeParameterInvalid | JYDriverExceptionPublic.
ChannelTerminalParameterInvalid | JYDriverExceptionPublic.
ChannelCouplingParameterInvalid | JYDriverExceptionPublic.
SampeleModeParameterInvalid | JYDriverExceptionPublic.
SampleClockParameterInvalid | JYDriverExceptionPublic.
SampleRateParameterInvalid | JYDriverExceptionPublic.
UpdateRateParameterInvalid | JYDriverExceptionPublic.
TriggerParameterInvalid | JYDriverExceptionPublic.
ReferenceTriggerDoesNotMatchWithSampleMode | JYDriverExceptionPublic.
PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint | JYDriverExceptionPublic.
ReadDataFailed | JYDriverExceptionPublic.
ReadDataTimeout | JYDriverExceptionPublic.
WriteDataFailed | JYDriverExceptionPublic.
WriteDataTimeout | JYDriverExceptionPublic.
WriteDataLengthCannotBeLessThanN | JYDriverExceptionPublic.
BufferDataOverflow | JYDriverExceptionPublic.
BufferDataDownflow | JYDriverExceptionPublic.
CheckBufferFailed | JYDriverExceptionPublic.
PointInvalidInFiniteMode | JYDriverExceptionPublic.
ReadPointInvalid | JYDriverExceptionPublic.
OnlySupportRecordMode | JYDriverExceptionPublic.
SendSoftTirggerFailed | JYDriverExceptionPublic.
TaskTimeout | JYDriverExceptionPublic.
CounterParametersInvalid | JYDriverExceptionPublic.
WritePointInvalid | JYDriverExceptionPublic.
SignalExportDestinationInvalid | JYDriverExceptionPublic.
InvalidParameter | 无效参数。 Invalid parameter.

◆ LevelPolarity

enum class JY9810CoreOO::LevelPolarity
strong

Level Polarity.

Enumerator
LowLevel | Low level.
HighLevel | High level.
None | No active polarity.

◆ MultiChannelCompositionLogic

enum class JY9810CoreOO::MultiChannelCompositionLogic
strong

Multichannel composition logic.

Enumerator
Or | Multichannel result take or.
And | Multichannel results take and.

◆ RecordMode

enum class JY9810CoreOO::RecordMode
strong
Enumerator
Finite | Finite Streaming.
Infinite | Infinite Streaming.

◆ ReferenceClockSource

enum class JY9810CoreOO::ReferenceClockSource
strong
Enumerator
Internal | Internal on board 25MHz Clock.
External | External Reference Clock Source.

◆ SignalExportDestination

enum class JY9810CoreOO::SignalExportDestination
strong
Enumerator
PXI_Trig0 | PXI Trig0.
PXI_Trig1 | PXI Trig1.
PXI_Trig2 | PXI Trig2.
PXI_Trig3 | PXI Trig3.
PXI_Trig4 | PXI Trig4.
PXI_Trig5 | PXI Trig5.
PXI_Trig6 | PXI Trig6.
PXI_Trig7 | PXI Trig7.
PFI_0 | Front Panel PFI_0 Terminal.

◆ SyncPulseRouting

enum class JY9810CoreOO::SyncPulseRouting
strong
Enumerator
NONE | default NONE
PXI_Trig0 | PXI Trig0.
PXI_Trig1 | PXI Trig1.
PXI_Trig2 | PXI Trig2.
PXI_Trig3 | PXI Trig3.
PXI_Trig4 | PXI Trig4.
PXI_Trig5 | PXI Trig5.
PXI_Trig6 | PXI Trig6.
PXI_Trig7 | PXI Trig7.
PFI_0 | Front Panel PFI_0 Terminal.

◆ SyncTopology

enum class JY9810CoreOO::SyncTopology
strong

Synchronization board configuration.

Enumerator
Independent | Independent, synchronization not supported
Master | master card
Slave | slave card

◆ SyncTriggerRouting

enum class JY9810CoreOO::SyncTriggerRouting
strong
Enumerator
NONE | default NONE
PXI_Trig0 | PXI Trig0.
PXI_Trig1 | PXI Trig1.
PXI_Trig2 | PXI Trig2.
PXI_Trig3 | PXI Trig3.
PXI_Trig4 | PXI Trig4.
PXI_Trig5 | PXI Trig5.
PXI_Trig6 | PXI Trig6.
PXI_Trig7 | PXI Trig7.
PFI_0 | Front Panel TRG PFI_0.

Function Documentation

◆ GetSignalExportDestinationString()

std::string JY9810CoreOO::GetSignalExportDestinationString ( SignalExportDestination destination )
inline


9810 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/9810/JY9810CoreOOCommon.h File Reference

  • File List
  • File Members
  • COO
  • 9810
Classes | Namespaces | Macros | Enumerations | Functions | Variables
JY9810CoreOOCommon.h File Reference
#include <string>
#include <stdint.h>
#include <functional>
#include <queue>
#include <mutex>
#include <condition_variable>
#include <iostream>
#include <atomic>
#include <vector>

Classes

class | JY9810CoreOO::JYDriverException
class | JY9810CoreOO::JY9810CoreOOProperty< ContainerClass, ValueType, propertyType >
属性模板类 More...
class | JY9810CoreOO::PauseTrigger
Pause trigger configuration class. More...

Namespaces

namespace | JY9810Import
namespace | JY9810CoreOO

Macros

#define | EXTERN_C extern
Windows.
#define | JY9810CoreOO_API

Enumerations

enum class | JY9810CoreOO::JY9810CoreOOPropertyType { JY9810CoreOO::READ_ONLY = 1 , JY9810CoreOO::WRITE_ONLY = 2 , JY9810CoreOO::READ_WRITE = 3 }
enum class JY9810CoreOO::JYDriverExceptionPublic {
JY9810CoreOO::UnKnown = 0 , JY9810CoreOO::OpenDeviceFailed = -10001 , JY9810CoreOO::CloseDeviceFailed = -10002 , JY9810CoreOO::ResetDeviceFailed = -10003 ,
JY9810CoreOO::GetDevicePropertyFailed = -10004 , JY9810CoreOO::SetDevicePropertyFailed = -10005 , JY9810CoreOO::HardwareResourceIsReserved = -10006 , JY9810CoreOO::MethodNotPermitedToCallWhenCurrentStatus = -10007 ,
JY9810CoreOO::InvalidUserDataBuffer = -10008 , JY9810CoreOO::NoChannelAdded = -10009 , JY9810CoreOO::NotSupportOperationForCurrentDevice = -10010 , JY9810CoreOO::CreatTaskFailed = -10100 ,
JY9810CoreOO::StartTaskFailed = -10101 , JY9810CoreOO::StopTaskFailed = -10102 , JY9810CoreOO::TaskHasNotStarted = -10103 , JY9810CoreOO::TaskHasStartedCannotPerformTheSetOperation = -10104 ,
JY9810CoreOO::ChannelNumberParameterInvalid = -10105 , JY9810CoreOO::ChannelInputRangeParameterInvalid = -10106 , JY9810CoreOO::ChannelTerminalParameterInvalid = -10107 , JY9810CoreOO::ChannelCouplingParameterInvalid = -10108 ,
JY9810CoreOO::SampeleModeParameterInvalid = -10109 , JY9810CoreOO::SampleClockParameterInvalid = -10110 , JY9810CoreOO::SampleRateParameterInvalid = -10111 , JY9810CoreOO::UpdateRateParameterInvalid = -10112 ,
JY9810CoreOO::TriggerParameterInvalid = -10113 , JY9810CoreOO::ReferenceTriggerDoesNotMatchWithSampleMode = -10114 , JY9810CoreOO::PretriggerPointCanNotBeLongerThanTheNumberOfFinitePoint = -10115 , JY9810CoreOO::ReadDataFailed = -10016 ,
JY9810CoreOO::ReadDataTimeout = -10017 , JY9810CoreOO::WriteDataFailed = -10018 , JY9810CoreOO::WriteDataTimeout = -10019 , JY9810CoreOO::WriteDataLengthCannotBeLessThanN = -10020 ,
JY9810CoreOO::BufferDataOverflow = -10021 , JY9810CoreOO::BufferDataDownflow = -10022 , JY9810CoreOO::CheckBufferFailed = -10023 , JY9810CoreOO::PointInvalidInFiniteMode = -10024 ,
JY9810CoreOO::ReadPointInvalid = -10025 , JY9810CoreOO::OnlySupportRecordMode = -10026 , JY9810CoreOO::SendSoftTirggerFailed = -10027 , JY9810CoreOO::TaskTimeout = -10028 ,
JY9810CoreOO::CounterParametersInvalid = -10029 , JY9810CoreOO::WritePointInvalid = -10030 , JY9810CoreOO::SignalExportDestinationInvalid = -10031 , JY9810CoreOO::InvalidParameter = -10033
}
enum class | JY9810CoreOO::ClockTerminal { JY9810CoreOO::CLK_IN }
enum class JY9810CoreOO::SignalExportDestination {
JY9810CoreOO::PXI_Trig0 = JY9810Import::JY9810_TriggerOut_PXI_0 , JY9810CoreOO::PXI_Trig1 = JY9810Import::JY9810_TriggerOut_PXI_1 , JY9810CoreOO::PXI_Trig2 = JY9810Import::JY9810_TriggerOut_PXI_2 , JY9810CoreOO::PXI_Trig3 = JY9810Import::JY9810_TriggerOut_PXI_3 ,
JY9810CoreOO::PXI_Trig4 = JY9810Import::JY9810_TriggerOut_PXI_4 , JY9810CoreOO::PXI_Trig5 = JY9810Import::JY9810_TriggerOut_PXI_5 , JY9810CoreOO::PXI_Trig6 = JY9810Import::JY9810_TriggerOut_PXI_6 , JY9810CoreOO::PXI_Trig7 = JY9810Import::JY9810_TriggerOut_PXI_7 ,
JY9810CoreOO::PFI_0 = JY9810Import::JY9810_TriggerOut_TRG_OUT
}
enum class | JY9810CoreOO::LevelPolarity { JY9810CoreOO::LowLevel = 0 , JY9810CoreOO::HighLevel = 1 , JY9810CoreOO::None = 2 }
Level Polarity. More...

Functions

std::string JY9810CoreOO::GetSignalExportDestinationString (SignalExportDestination destination)

Variables

const double | JY9810Import::JY9810_MAX_SampleRate = 125.0E6
const double | JY9810Import::JY9810_MIN_SampleRate = 2.0E3
const int | JY9810Import::JY9810_Finite = 0x00
const int | JY9810Import::JY9810_Continuous = 0x01
const int | JY9810Import::JY9810_InternalClock = 0
const int | JY9810Import::JY9810_ExternalClock = 1
const int | JY9810Import::JY9810_TriggerType_Immediately = 0x0
const int | JY9810Import::JY9810_TriggerType_Digital = 0x2
const int | JY9810Import::JY9810_TriggerType_Analog = 0x3
const int | JY9810Import::JY9810_TriggerType_Soft = 0x1
const int | JY9810Import::JY9810_Soft_Start_Trigger = 0x0
const int | JY9810Import::JY9810_Soft_Ref_Trigger = 0x1
const int | JY9810Import::JY9810_DigitalTriggerEdge_Rising = 0x0
const int | JY9810Import::JY9810_DigitalTriggerEdge_Falling = 0x1
const int | JY9810Import::JY9810_DigitalTriggerSource_PXI_0 = 8
const int | JY9810Import::JY9810_DigitalTriggerSource_PXI_1 = 9
const int | JY9810Import::JY9810_DigitalTriggerSource_PXI_2 = 10
const int | JY9810Import::JY9810_DigitalTriggerSource_PXI_3 = 11
const int | JY9810Import::JY9810_DigitalTriggerSource_PXI_4 = 12
const int | JY9810Import::JY9810_DigitalTriggerSource_PXI_5 = 13
const int | JY9810Import::JY9810_DigitalTriggerSource_PXI_6 = 14
const int | JY9810Import::JY9810_DigitalTriggerSource_PXI_7 = 15
const int | JY9810Import::JY9810_DigitalTriggerSource_TRIG_IN = 16
const int | JY9810Import::JY9810_DigitalTriggerSource_PXIe_DStarB = 17
const int | JY9810Import::JY9810_DigitalTriggerSource_PXIe_DStarC = 18
const int | JY9810Import::JY9810_TriggerOut_PXI_0 = 8
const int | JY9810Import::JY9810_TriggerOut_PXI_1 = 9
const int | JY9810Import::JY9810_TriggerOut_PXI_2 = 10
const int | JY9810Import::JY9810_TriggerOut_PXI_3 = 11
const int | JY9810Import::JY9810_TriggerOut_PXI_4 = 12
const int | JY9810Import::JY9810_TriggerOut_PXI_5 = 13
const int | JY9810Import::JY9810_TriggerOut_PXI_6 = 14
const int | JY9810Import::JY9810_TriggerOut_PXI_7 = 15
const int | JY9810Import::JY9810_TriggerOut_TRG_OUT = 16
const int | JY9810Import::JY9810_SyncSignal_PXI_0 = 8
const int | JY9810Import::JY9810_SyncSignal_PXI_1 = 9
const int | JY9810Import::JY9810_SyncSignal_PXI_2 = 10
const int | JY9810Import::JY9810_SyncSignal_PXI_3 = 11
const int | JY9810Import::JY9810_SyncSignal_PXI_4 = 12
const int | JY9810Import::JY9810_SyncSignal_PXI_5 = 13
const int | JY9810Import::JY9810_SyncSignal_PXI_6 = 14
const int | JY9810Import::JY9810_SyncSignal_PXI_7 = 15
const int | JY9810Import::JY9810_StartTrigger = 3
const int | JY9810Import::JY9810_RefTrigger = 4
const int | JY9810Import::JY9810_Independent = 0x0
const int | JY9810Import::JY9810_MASTER = 0x1
const int | JY9810Import::JY9810_SLAVE = 0x3
const int | JY9810Import::SyncSignal_IN = 22
const int | JY9810Import::SyncSignal_OUT = 0
const int | JY9810Import::JY9810_PLL_SYNC_OUT = 23
const int | JY9810Import::JY9810_Onboard_10M = 0x0
const int | JY9810Import::JY9810_Extenal_Ref_10M = 0x1
const int | JY9810Import::JY9810_CB_100M = 0x2
const int | JY9810Import::JY9810_AnalogTriggerCondition_RisingHysteresis = 0x2
const int | JY9810Import::JY9810_AnaloglTriggerCondition_FallingHysteresis = 0x3
const int | JY9810Import::JY9810_AnalogTriggerCondition_EnteringWindow = 0x0
const int | JY9810Import::JY9810_AnaloglTriggerCondition_LeavingWindow = 0x1
const int | JY9810Import::JY9810_AnalogTriggerType_Hysteresis = 0x1
const int | JY9810Import::JY9810_AnalogTriggerType_Window = 0x0
const int | JY9810Import::JY9810_AI_AC_Couple = 0x1
const int | JY9810Import::JY9810_AI_DC_Couple = 0x0
const int | JY9810Import::JY9810_AI_OHM_50 = 0x1
const int | JY9810Import::JY9810_AI_OHM_1M = 0x0
const int | JY9810Import::JY9810_125M = 0x1
const int | JY9810Import::JY9810_80M = 0x2

Macro Definition Documentation

◆ EXTERN_C

#define EXTERN_C extern

Windows.

Linux

◆ JY9810CoreOO_API

#define JY9810CoreOO_API


9810 C++ Programming Manual: JY9810CoreOO::JYDriverException Class Reference

  • JYDriverException
Public Member Functions | Public Attributes | List of all members
JY9810CoreOO::JYDriverException Class Reference

#include <JY9810CoreOOCommon.h>

Public Member Functions

JYDriverException (JYDriverExceptionPublic exceptionCode, std::string msg="")
JYDriverException (int, std::string msg)

Public Attributes

std::string exceptionMessage
JYDriverExceptionPublic errorCode
JYDriverException * FollowingException

Constructor & Destructor Documentation

◆ JYDriverException() [1/2]

JY9810CoreOO::JYDriverException::JYDriverException | ( | JYDriverExceptionPublic | exceptionCode,
 |  | std::string | msg = "" )

◆ JYDriverException() [2/2]

JY9810CoreOO::JYDriverException::JYDriverException | ( | int | ,
 |  | std::string | msg )

Member Data Documentation

◆ errorCode

JYDriverExceptionPublic JY9810CoreOO::JYDriverException::errorCode

◆ exceptionMessage

std::string JY9810CoreOO::JYDriverException::exceptionMessage

◆ FollowingException

JYDriverException* JY9810CoreOO::JYDriverException::FollowingException
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9810/JY9810CoreOOCommon.h


9810 C++ Programming Manual: JY9810CoreOO::JY9810CoreOOProperty< ContainerClass, ValueType, propertyType > Class Template Reference

  • JY9810CoreOOProperty
Public Member Functions | List of all members
JY9810CoreOO::JY9810CoreOOProperty< ContainerClass, ValueType, propertyType > Class Template Reference

属性模板类 More...

#include <JY9810CoreOOCommon.h>

Public Member Functions

JY9810CoreOOProperty ()
JY9810CoreOOProperty (ContainerClass *cObject, ValueType(ContainerClass::*pGet)(), void(ContainerClass::*pSet)(ValueType value))
JY9810CoreOOProperty (ValueType(*pGet)(), void(*pSet)(ValueType value))
ValueType operator= (const ValueType &value)
operator ValueType ()

Detailed Description

template<typename ContainerClass, typename ValueType, JY9810CoreOOPropertyType propertyType>
class JY9810CoreOO::JY9810CoreOOProperty< ContainerClass, ValueType, propertyType >

属性模板类

Constructor & Destructor Documentation

◆ JY9810CoreOOProperty() [1/3]

template<typename ContainerClass, typename ValueType, JY9810CoreOOPropertyType propertyType>
JY9810CoreOO::JY9810CoreOOProperty< ContainerClass, ValueType, propertyType >::JY9810CoreOOProperty ( )

◆ JY9810CoreOOProperty() [2/3]

template<typename ContainerClass, typename ValueType, JY9810CoreOOPropertyType propertyType>
JY9810CoreOO::JY9810CoreOOProperty< ContainerClass, ValueType, propertyType >::JY9810CoreOOProperty | ( | ContainerClass * | cObject,
 |  | ValueType(ContainerClass::* | pGet )(),
 |  | void(ContainerClass::* | pSet )(ValueType value) )

◆ JY9810CoreOOProperty() [3/3]

template<typename ContainerClass, typename ValueType, JY9810CoreOOPropertyType propertyType>
JY9810CoreOO::JY9810CoreOOProperty< ContainerClass, ValueType, propertyType >::JY9810CoreOOProperty | ( | ValueType(* | pGet )(),
 |  | void(* | pSet )(ValueType value) )

Member Function Documentation

◆ operator ValueType()

template<typename ContainerClass, typename ValueType, JY9810CoreOOPropertyType propertyType>
JY9810CoreOO::JY9810CoreOOProperty< ContainerClass, ValueType, propertyType >::operator ValueType ( )

◆ operator=()

template<typename ContainerClass, typename ValueType, JY9810CoreOOPropertyType propertyType>
ValueType JY9810CoreOO::JY9810CoreOOProperty< ContainerClass, ValueType, propertyType >::operator= ( const ValueType & value )
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9810/JY9810CoreOOCommon.h


9810 C++ Programming Manual: JY9810CoreOO::PauseTrigger Class Reference

  • PauseTrigger
Public Attributes | List of all members
JY9810CoreOO::PauseTrigger Class Reference

Pause trigger configuration class. More...

#include <JY9810CoreOOCommon.h>

Public Attributes

LevelPolarity ActivePolarity
Pause trigger active polarity.
InputTerminal Terminal
Terminal.

Detailed Description

Pause trigger configuration class.

Member Data Documentation

◆ ActivePolarity

LevelPolarity JY9810CoreOO::PauseTrigger::ActivePolarity

Pause trigger active polarity.

The default value is LevelPolarity.None, means the pause trigger is disabled.

◆ Terminal

InputTerminal JY9810CoreOO::PauseTrigger::Terminal

Terminal.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9810/JY9810CoreOOCommon.h


9810 C++ Programming Manual: JY9810Import Namespace Reference

  • Namespace List
  • Namespace Members
Variables
JY9810Import Namespace Reference

Variables

const double | JY9810_MAX_SampleRate = 125.0E6
const double | JY9810_MIN_SampleRate = 2.0E3
const int | JY9810_Finite = 0x00
const int | JY9810_Continuous = 0x01
const int | JY9810_InternalClock = 0
const int | JY9810_ExternalClock = 1
const int | JY9810_TriggerType_Immediately = 0x0
const int | JY9810_TriggerType_Digital = 0x2
const int | JY9810_TriggerType_Analog = 0x3
const int | JY9810_TriggerType_Soft = 0x1
const int | JY9810_Soft_Start_Trigger = 0x0
const int | JY9810_Soft_Ref_Trigger = 0x1
const int | JY9810_DigitalTriggerEdge_Rising = 0x0
const int | JY9810_DigitalTriggerEdge_Falling = 0x1
const int | JY9810_DigitalTriggerSource_PXI_0 = 8
const int | JY9810_DigitalTriggerSource_PXI_1 = 9
const int | JY9810_DigitalTriggerSource_PXI_2 = 10
const int | JY9810_DigitalTriggerSource_PXI_3 = 11
const int | JY9810_DigitalTriggerSource_PXI_4 = 12
const int | JY9810_DigitalTriggerSource_PXI_5 = 13
const int | JY9810_DigitalTriggerSource_PXI_6 = 14
const int | JY9810_DigitalTriggerSource_PXI_7 = 15
const int | JY9810_DigitalTriggerSource_TRIG_IN = 16
const int | JY9810_DigitalTriggerSource_PXIe_DStarB = 17
const int | JY9810_DigitalTriggerSource_PXIe_DStarC = 18
const int | JY9810_TriggerOut_PXI_0 = 8
const int | JY9810_TriggerOut_PXI_1 = 9
const int | JY9810_TriggerOut_PXI_2 = 10
const int | JY9810_TriggerOut_PXI_3 = 11
const int | JY9810_TriggerOut_PXI_4 = 12
const int | JY9810_TriggerOut_PXI_5 = 13
const int | JY9810_TriggerOut_PXI_6 = 14
const int | JY9810_TriggerOut_PXI_7 = 15
const int | JY9810_TriggerOut_TRG_OUT = 16
const int | JY9810_SyncSignal_PXI_0 = 8
const int | JY9810_SyncSignal_PXI_1 = 9
const int | JY9810_SyncSignal_PXI_2 = 10
const int | JY9810_SyncSignal_PXI_3 = 11
const int | JY9810_SyncSignal_PXI_4 = 12
const int | JY9810_SyncSignal_PXI_5 = 13
const int | JY9810_SyncSignal_PXI_6 = 14
const int | JY9810_SyncSignal_PXI_7 = 15
const int | JY9810_StartTrigger = 3
const int | JY9810_RefTrigger = 4
const int | JY9810_Independent = 0x0
const int | JY9810_MASTER = 0x1
const int | JY9810_SLAVE = 0x3
const int | SyncSignal_IN = 22
const int | SyncSignal_OUT = 0
const int | JY9810_PLL_SYNC_OUT = 23
const int | JY9810_Onboard_10M = 0x0
const int | JY9810_Extenal_Ref_10M = 0x1
const int | JY9810_CB_100M = 0x2
const int | JY9810_AnalogTriggerCondition_RisingHysteresis = 0x2
const int | JY9810_AnaloglTriggerCondition_FallingHysteresis = 0x3
const int | JY9810_AnalogTriggerCondition_EnteringWindow = 0x0
const int | JY9810_AnaloglTriggerCondition_LeavingWindow = 0x1
const int | JY9810_AnalogTriggerType_Hysteresis = 0x1
const int | JY9810_AnalogTriggerType_Window = 0x0
const int | JY9810_AI_AC_Couple = 0x1
const int | JY9810_AI_DC_Couple = 0x0
const int | JY9810_AI_OHM_50 = 0x1
const int | JY9810_AI_OHM_1M = 0x0
const int | JY9810_125M = 0x1
const int | JY9810_80M = 0x2

Variable Documentation

◆ JY9810_125M

const int JY9810Import::JY9810_125M = 0x1

◆ JY9810_80M

const int JY9810Import::JY9810_80M = 0x2

◆ JY9810_AI_AC_Couple

const int JY9810Import::JY9810_AI_AC_Couple = 0x1

◆ JY9810_AI_DC_Couple

const int JY9810Import::JY9810_AI_DC_Couple = 0x0

◆ JY9810_AI_OHM_1M

const int JY9810Import::JY9810_AI_OHM_1M = 0x0

◆ JY9810_AI_OHM_50

const int JY9810Import::JY9810_AI_OHM_50 = 0x1

◆ JY9810_AnaloglTriggerCondition_FallingHysteresis

const int JY9810Import::JY9810_AnaloglTriggerCondition_FallingHysteresis = 0x3

◆ JY9810_AnaloglTriggerCondition_LeavingWindow

const int JY9810Import::JY9810_AnaloglTriggerCondition_LeavingWindow = 0x1

◆ JY9810_AnalogTriggerCondition_EnteringWindow

const int JY9810Import::JY9810_AnalogTriggerCondition_EnteringWindow = 0x0

◆ JY9810_AnalogTriggerCondition_RisingHysteresis

const int JY9810Import::JY9810_AnalogTriggerCondition_RisingHysteresis = 0x2

◆ JY9810_AnalogTriggerType_Hysteresis

const int JY9810Import::JY9810_AnalogTriggerType_Hysteresis = 0x1

◆ JY9810_AnalogTriggerType_Window

const int JY9810Import::JY9810_AnalogTriggerType_Window = 0x0

◆ JY9810_CB_100M

const int JY9810Import::JY9810_CB_100M = 0x2

◆ JY9810_Continuous

const int JY9810Import::JY9810_Continuous = 0x01

◆ JY9810_DigitalTriggerEdge_Falling

const int JY9810Import::JY9810_DigitalTriggerEdge_Falling = 0x1

◆ JY9810_DigitalTriggerEdge_Rising

const int JY9810Import::JY9810_DigitalTriggerEdge_Rising = 0x0

◆ JY9810_DigitalTriggerSource_PXI_0

const int JY9810Import::JY9810_DigitalTriggerSource_PXI_0 = 8

◆ JY9810_DigitalTriggerSource_PXI_1

const int JY9810Import::JY9810_DigitalTriggerSource_PXI_1 = 9

◆ JY9810_DigitalTriggerSource_PXI_2

const int JY9810Import::JY9810_DigitalTriggerSource_PXI_2 = 10

◆ JY9810_DigitalTriggerSource_PXI_3

const int JY9810Import::JY9810_DigitalTriggerSource_PXI_3 = 11

◆ JY9810_DigitalTriggerSource_PXI_4

const int JY9810Import::JY9810_DigitalTriggerSource_PXI_4 = 12

◆ JY9810_DigitalTriggerSource_PXI_5

const int JY9810Import::JY9810_DigitalTriggerSource_PXI_5 = 13

◆ JY9810_DigitalTriggerSource_PXI_6

const int JY9810Import::JY9810_DigitalTriggerSource_PXI_6 = 14

◆ JY9810_DigitalTriggerSource_PXI_7

const int JY9810Import::JY9810_DigitalTriggerSource_PXI_7 = 15

◆ JY9810_DigitalTriggerSource_PXIe_DStarB

const int JY9810Import::JY9810_DigitalTriggerSource_PXIe_DStarB = 17

◆ JY9810_DigitalTriggerSource_PXIe_DStarC

const int JY9810Import::JY9810_DigitalTriggerSource_PXIe_DStarC = 18

◆ JY9810_DigitalTriggerSource_TRIG_IN

const int JY9810Import::JY9810_DigitalTriggerSource_TRIG_IN = 16

◆ JY9810_Extenal_Ref_10M

const int JY9810Import::JY9810_Extenal_Ref_10M = 0x1

◆ JY9810_ExternalClock

const int JY9810Import::JY9810_ExternalClock = 1

◆ JY9810_Finite

const int JY9810Import::JY9810_Finite = 0x00

◆ JY9810_Independent

const int JY9810Import::JY9810_Independent = 0x0

◆ JY9810_InternalClock

const int JY9810Import::JY9810_InternalClock = 0

◆ JY9810_MASTER

const int JY9810Import::JY9810_MASTER = 0x1

◆ JY9810_MAX_SampleRate

const double JY9810Import::JY9810_MAX_SampleRate = 125.0E6

◆ JY9810_MIN_SampleRate

const double JY9810Import::JY9810_MIN_SampleRate = 2.0E3

◆ JY9810_Onboard_10M

const int JY9810Import::JY9810_Onboard_10M = 0x0

◆ JY9810_PLL_SYNC_OUT

const int JY9810Import::JY9810_PLL_SYNC_OUT = 23

◆ JY9810_RefTrigger

const int JY9810Import::JY9810_RefTrigger = 4

◆ JY9810_SLAVE

const int JY9810Import::JY9810_SLAVE = 0x3

◆ JY9810_Soft_Ref_Trigger

const int JY9810Import::JY9810_Soft_Ref_Trigger = 0x1

◆ JY9810_Soft_Start_Trigger

const int JY9810Import::JY9810_Soft_Start_Trigger = 0x0

◆ JY9810_StartTrigger

const int JY9810Import::JY9810_StartTrigger = 3

◆ JY9810_SyncSignal_PXI_0

const int JY9810Import::JY9810_SyncSignal_PXI_0 = 8

◆ JY9810_SyncSignal_PXI_1

const int JY9810Import::JY9810_SyncSignal_PXI_1 = 9

◆ JY9810_SyncSignal_PXI_2

const int JY9810Import::JY9810_SyncSignal_PXI_2 = 10

◆ JY9810_SyncSignal_PXI_3

const int JY9810Import::JY9810_SyncSignal_PXI_3 = 11

◆ JY9810_SyncSignal_PXI_4

const int JY9810Import::JY9810_SyncSignal_PXI_4 = 12

◆ JY9810_SyncSignal_PXI_5

const int JY9810Import::JY9810_SyncSignal_PXI_5 = 13

◆ JY9810_SyncSignal_PXI_6

const int JY9810Import::JY9810_SyncSignal_PXI_6 = 14

◆ JY9810_SyncSignal_PXI_7

const int JY9810Import::JY9810_SyncSignal_PXI_7 = 15

◆ JY9810_TriggerOut_PXI_0

const int JY9810Import::JY9810_TriggerOut_PXI_0 = 8

◆ JY9810_TriggerOut_PXI_1

const int JY9810Import::JY9810_TriggerOut_PXI_1 = 9

◆ JY9810_TriggerOut_PXI_2

const int JY9810Import::JY9810_TriggerOut_PXI_2 = 10

◆ JY9810_TriggerOut_PXI_3

const int JY9810Import::JY9810_TriggerOut_PXI_3 = 11

◆ JY9810_TriggerOut_PXI_4

const int JY9810Import::JY9810_TriggerOut_PXI_4 = 12

◆ JY9810_TriggerOut_PXI_5

const int JY9810Import::JY9810_TriggerOut_PXI_5 = 13

◆ JY9810_TriggerOut_PXI_6

const int JY9810Import::JY9810_TriggerOut_PXI_6 = 14

◆ JY9810_TriggerOut_PXI_7

const int JY9810Import::JY9810_TriggerOut_PXI_7 = 15

◆ JY9810_TriggerOut_TRG_OUT

const int JY9810Import::JY9810_TriggerOut_TRG_OUT = 16

◆ JY9810_TriggerType_Analog

const int JY9810Import::JY9810_TriggerType_Analog = 0x3

◆ JY9810_TriggerType_Digital

const int JY9810Import::JY9810_TriggerType_Digital = 0x2

◆ JY9810_TriggerType_Immediately

const int JY9810Import::JY9810_TriggerType_Immediately = 0x0

◆ JY9810_TriggerType_Soft

const int JY9810Import::JY9810_TriggerType_Soft = 0x1

◆ SyncSignal_IN

const int JY9810Import::SyncSignal_IN = 22

◆ SyncSignal_OUT

const int JY9810Import::SyncSignal_OUT = 0


9810 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/9810/JY9810CoreOODevice.h File Reference

  • File List
  • File Members
  • COO
  • 9810
Classes | Namespaces | Enumerations
JY9810CoreOODevice.h File Reference
#include <iostream>
#include <list>
#include <vector>
#include "JY9810CoreOOCommon.h"

Classes

class | JY9810CoreOO::JY9810CoreOODevice
class | JY9810CoreOO::ExternalReferenceClock
External Reference Clcok Terminal. More...
class | JY9810CoreOO::JY9810CoreOOReferenceClock

Namespaces

namespace JY9810CoreOO

Enumerations

enum class | JY9810CoreOO::ExternalReferenceClockTerminal { JY9810CoreOO::CLK_IN = JY9810Import::JY9810_Extenal_Ref_10M , JY9810CoreOO::PXIe_Clk100 = JY9810Import::JY9810_CB_100M }
enum class | JY9810CoreOO::ReferenceClockSource { JY9810CoreOO::Internal = 0x0 , JY9810CoreOO::External = 0x1 }


9810 C++ Programming Manual: JY9810CoreOO::JY9810CoreOODevice Class Reference

  • JY9810CoreOODevice
Static Public Member Functions | Public Attributes | List of all members
JY9810CoreOO::JY9810CoreOODevice Class Reference

#include <JY9810CoreOODevice.h>

Static Public Member Functions

static JY9810CoreOODevice * | GetInstance (int cardNum)
The operation instance is obtained according to the board number to ensure that there is only one registered instance for each board.
static JY9810CoreOODevice * | GetInstance (std::string aliasName)
The operation instance is obtained according to aliasName to ensure that there is only one registration instance for each board.

Public Attributes

const double | BoardClockRate = 125000000
Board Clock Rate.
int | SubCardADCType
Sub Card ADC Type.
uint32_t | AIBufferSize = 0x100000 * 256
AI Buffer Size.
const bool | IsAOSync = true
IsAOSync.
int | LineCountPerPort = 2
DIOLineCountPerPort.
JY9810CoreOOProperty< JY9810CoreOODevice, int, JY9810CoreOOPropertyType::READ_ONLY > | DiffChannelCount
JY9810CoreOOProperty< JY9810CoreOODevice, int, JY9810CoreOOPropertyType::READ_ONLY > | DIOPortCount
JY9810CoreOOProperty< JY9810CoreOODevice, double, JY9810CoreOOPropertyType::READ_ONLY > | MaxSampleRateSingleChannel
JY9810CoreOOProperty< JY9810CoreOODevice, std::string, JY9810CoreOOPropertyType::READ_ONLY > | SerialNumber
JY9810CoreOOProperty< JY9810CoreOODevice, int, JY9810CoreOOPropertyType::READ_ONLY > | DeviceID
JY9810CoreOOProperty< JY9810CoreOODevice, void *, JY9810CoreOOPropertyType::READ_ONLY > | Handle
JY9810CoreOOReferenceClock * ReferenceClock
Reference Clock Configuration.

Member Function Documentation

◆ GetInstance() [1/2]

static JY9810CoreOODevice * JY9810CoreOO::JY9810CoreOODevice::GetInstance ( int cardNum )
static

The operation instance is obtained according to the board number to ensure that there is only one registered instance for each board.

Parameters
cardNum
Returns

◆ GetInstance() [2/2]

static JY9810CoreOODevice * JY9810CoreOO::JY9810CoreOODevice::GetInstance ( std::string aliasName )
static

The operation instance is obtained according to aliasName to ensure that there is only one registration instance for each board.

Parameters
aliasName
Returns

Member Data Documentation

◆ AIBufferSize

uint32_t JY9810CoreOO::JY9810CoreOODevice::AIBufferSize = 0x100000 * 256

AI Buffer Size.

◆ BoardClockRate

const double JY9810CoreOO::JY9810CoreOODevice::BoardClockRate = 125000000

Board Clock Rate.

◆ DeviceID

JY9810CoreOOProperty<JY9810CoreOODevice, int, JY9810CoreOOPropertyType::READ_ONLY> JY9810CoreOO::JY9810CoreOODevice::DeviceID

◆ DiffChannelCount

JY9810CoreOOProperty<JY9810CoreOODevice, int, JY9810CoreOOPropertyType::READ_ONLY> JY9810CoreOO::JY9810CoreOODevice::DiffChannelCount

◆ DIOPortCount

JY9810CoreOOProperty<JY9810CoreOODevice, int, JY9810CoreOOPropertyType::READ_ONLY> JY9810CoreOO::JY9810CoreOODevice::DIOPortCount

◆ Handle

JY9810CoreOOProperty<JY9810CoreOODevice, void*, JY9810CoreOOPropertyType::READ_ONLY> JY9810CoreOO::JY9810CoreOODevice::Handle

◆ IsAOSync

const bool JY9810CoreOO::JY9810CoreOODevice::IsAOSync = true

IsAOSync.

◆ LineCountPerPort

int JY9810CoreOO::JY9810CoreOODevice::LineCountPerPort = 2

DIOLineCountPerPort.

◆ MaxSampleRateSingleChannel

JY9810CoreOOProperty<JY9810CoreOODevice, double, JY9810CoreOOPropertyType::READ_ONLY> JY9810CoreOO::JY9810CoreOODevice::MaxSampleRateSingleChannel

◆ ReferenceClock

JY9810CoreOOReferenceClock* JY9810CoreOO::JY9810CoreOODevice::ReferenceClock

Reference Clock Configuration.

◆ SerialNumber

JY9810CoreOOProperty<JY9810CoreOODevice, std::string, JY9810CoreOOPropertyType::READ_ONLY> JY9810CoreOO::JY9810CoreOODevice::SerialNumber

◆ SubCardADCType

int JY9810CoreOO::JY9810CoreOODevice::SubCardADCType

Sub Card ADC Type.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9810/JY9810CoreOODevice.h


9810 C++ Programming Manual: JY9810CoreOO::ExternalReferenceClock Class Reference

  • ExternalReferenceClock
Public Member Functions | Public Attributes | List of all members
JY9810CoreOO::ExternalReferenceClock Class Reference

External Reference Clcok Terminal. More...

#include <JY9810CoreOODevice.h>

Public Member Functions

ExternalReferenceClock ()

Public Attributes

ExternalReferenceClockTerminal Terminal
double Frequency

Detailed Description

External Reference Clcok Terminal.

Constructor & Destructor Documentation

◆ ExternalReferenceClock()

JY9810CoreOO::ExternalReferenceClock::ExternalReferenceClock ( )
inline

Member Data Documentation

◆ Frequency

double JY9810CoreOO::ExternalReferenceClock::Frequency

◆ Terminal

ExternalReferenceClockTerminal JY9810CoreOO::ExternalReferenceClock::Terminal
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9810/JY9810CoreOODevice.h


9810 C++ Programming Manual: JY9810CoreOO::JY9810CoreOOReferenceClock Class Reference

  • JY9810CoreOOReferenceClock
Public Member Functions | Public Attributes | List of all members
JY9810CoreOO::JY9810CoreOOReferenceClock Class Reference

#include <JY9810CoreOODevice.h>

Public Member Functions

void Commit ()
Commit configuration.

Public Attributes

ReferenceClockSource Source
ExternalReferenceClock * External
External Reference Clock Source.

Member Function Documentation

◆ Commit()

void JY9810CoreOO::JY9810CoreOOReferenceClock::Commit ( )

Commit configuration.

Available only when the device is idle. WARNING: Incorrect parameters will cause the PLL to be unable to lock the reference clock and cannot be recovered until shutdown and restart.

Member Data Documentation

◆ External

ExternalReferenceClock* JY9810CoreOO::JY9810CoreOOReferenceClock::External

External Reference Clock Source.

Required when ReferenceClock.Source is ReferenceClockSource.External

◆ Source

ReferenceClockSource JY9810CoreOO::JY9810CoreOOReferenceClock::Source
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9810/JY9810CoreOODevice.h


9810 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO/9810/JY9810CoreOOLog.h File Reference

  • File List
  • File Members
  • COO
  • 9810
Classes | Namespaces | Enumerations
JY9810CoreOOLog.h File Reference
#include <queue>
#include <thread>
#include "JY9810CoreOOCommon.h"

Classes

class JY9810CoreOO::JY9810CoreOOLog

Namespaces

namespace JY9810CoreOO

Enumerations

enum class JY9810CoreOO::JY9810CoreOOLogLevel {
JY9810CoreOO::DEBUG_LOG_LEVEL , JY9810CoreOO::INFO_LOG_LEVEL , JY9810CoreOO::WARN_LOG_LEVEL , JY9810CoreOO::ERROR_LOG_LEVEL ,
JY9810CoreOO::FATAL_LOG_LEVEL
}


9810 C++ Programming Manual: JY9810CoreOO::JY9810CoreOOLog Class Reference

  • JY9810CoreOOLog
Static Public Member Functions | Static Public Attributes | List of all members
JY9810CoreOO::JY9810CoreOOLog Class Reference

#include <JY9810CoreOOLog.h>

Static Public Member Functions

static void | Print (const char *format,...)
static void | Print (JY9810CoreOOLogLevel logLevel, const char *format,...)
static void | Flush ()

Static Public Attributes

static JY9810CoreOOLogLevel | LogLevel
static JY9810CoreOOProperty< JY9810CoreOOLog, bool, JY9810CoreOOPropertyType::READ_WRITE > | EnableLog

Member Function Documentation

◆ Flush()

static void JY9810CoreOO::JY9810CoreOOLog::Flush ( )
static

◆ Print() [1/2]

static void JY9810CoreOO::JY9810CoreOOLog::Print | ( | const char * | format,
 |  |  | ... )
 static

◆ Print() [2/2]

static void JY9810CoreOO::JY9810CoreOOLog::Print | ( | JY9810CoreOOLogLevel | logLevel,
 |  | const char * | format,
 |  |  | ... )
 static

Member Data Documentation

◆ EnableLog

JY9810CoreOOProperty<JY9810CoreOOLog, bool, JY9810CoreOOPropertyType::READ_WRITE> JY9810CoreOO::JY9810CoreOOLog::EnableLog
static

◆ LogLevel

JY9810CoreOOLogLevel JY9810CoreOO::JY9810CoreOOLog::LogLevel
static
The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9810/JY9810CoreOOLog.h


9810 C++ Programming Manual: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
▼N JY9810CoreOO |
C AIAnalogEdgeComparator |
C AIAnalogHysteresisComparator |
C AIAnalogTrigger |
C AIAnalogWindowComparator |
C AIChannel |
C AIDigitalTrigger |
C AIExternalSampleClock |
C AIMultiChannelAnalogTrigger |
C AIRecord |
C AIRecordAdvanced |
C AISampleClock |
C AISignalExport |
C AISync | Configure sync signal
C AITrigger |
C ExternalReferenceClock | External Reference Clcok Terminal
C JY9810CoreOOAITask | AiTask类
C JY9810CoreOODevice |
C JY9810CoreOOLog |
C JY9810CoreOOProperty | 属性模板类
C JY9810CoreOOReferenceClock |
C JYDriverException |
C PauseTrigger | Pause trigger configuration class
C JY9810CoreOOAIMode | AIMode


9810 C++ Programming Manual: Member List

  • AIAnalogEdgeComparator
JY9810CoreOO::AIAnalogEdgeComparator Member List

This is the complete list of members for JY9810CoreOO::AIAnalogEdgeComparator, including all inherited members.

Slope | JY9810CoreOO::AIAnalogEdgeComparator
Threshold | JY9810CoreOO::AIAnalogEdgeComparator


9810 C++ Programming Manual: Member List

  • AIAnalogHysteresisComparator
JY9810CoreOO::AIAnalogHysteresisComparator Member List

This is the complete list of members for JY9810CoreOO::AIAnalogHysteresisComparator, including all inherited members.

HighThreshold | JY9810CoreOO::AIAnalogHysteresisComparator
LowThreshold | JY9810CoreOO::AIAnalogHysteresisComparator
Slope | JY9810CoreOO::AIAnalogHysteresisComparator


9810 C++ Programming Manual: Member List

  • AIAnalogTrigger
JY9810CoreOO::AIAnalogTrigger Member List

This is the complete list of members for JY9810CoreOO::AIAnalogTrigger, including all inherited members.

AIAnalogTrigger() | JY9810CoreOO::AIAnalogTrigger
AIAnalogTrigger(AIAnalogTriggerSource src, AIAnalogTriggerComparator comparator) | JY9810CoreOO::AIAnalogTrigger
Comparator | JY9810CoreOO::AIAnalogTrigger
Edge | JY9810CoreOO::AIAnalogTrigger
Hysteresis | JY9810CoreOO::AIAnalogTrigger
Source | JY9810CoreOO::AIAnalogTrigger
Window | JY9810CoreOO::AIAnalogTrigger
~AIAnalogTrigger() | JY9810CoreOO::AIAnalogTrigger


9810 C++ Programming Manual: Member List

  • AIAnalogWindowComparator
JY9810CoreOO::AIAnalogWindowComparator Member List

This is the complete list of members for JY9810CoreOO::AIAnalogWindowComparator, including all inherited members.

Condition | JY9810CoreOO::AIAnalogWindowComparator
HighThreshold | JY9810CoreOO::AIAnalogWindowComparator
LowThreshold | JY9810CoreOO::AIAnalogWindowComparator


9810 C++ Programming Manual: Member List

  • AIChannel
JY9810CoreOO::AIChannel Member List

This is the complete list of members for JY9810CoreOO::AIChannel, including all inherited members.

AIChannel(int channelId, double rangeLow, double rangeHigh, AICoupling coupling, AIImpedance impedance=AIImpedance::Impedance50Ohm) | JY9810CoreOO::AIChannel | inline
ChannelID | JY9810CoreOO::AIChannel |
Coupling | JY9810CoreOO::AIChannel |
Impedance | JY9810CoreOO::AIChannel |
RangeHigh | JY9810CoreOO::AIChannel |
RangeLow | JY9810CoreOO::AIChannel |


9810 C++ Programming Manual: Member List

  • AIDigitalTrigger
JY9810CoreOO::AIDigitalTrigger Member List

This is the complete list of members for JY9810CoreOO::AIDigitalTrigger, including all inherited members.

Edge | JY9810CoreOO::AIDigitalTrigger
Source | JY9810CoreOO::AIDigitalTrigger


9810 C++ Programming Manual: Member List

  • AIExternalSampleClock
JY9810CoreOO::AIExternalSampleClock Member List

This is the complete list of members for JY9810CoreOO::AIExternalSampleClock, including all inherited members.

ExpectedRate | JY9810CoreOO::AIExternalSampleClock
Terminal | JY9810CoreOO::AIExternalSampleClock


9810 C++ Programming Manual: Member List

  • AIMultiChannelAnalogTrigger
JY9810CoreOO::AIMultiChannelAnalogTrigger Member List

This is the complete list of members for JY9810CoreOO::AIMultiChannelAnalogTrigger, including all inherited members.

Analog | JY9810CoreOO::AIMultiChannelAnalogTrigger
Logic | JY9810CoreOO::AIMultiChannelAnalogTrigger


9810 C++ Programming Manual: Member List

  • AIRecord
JY9810CoreOO::AIRecord Member List

This is the complete list of members for JY9810CoreOO::AIRecord, including all inherited members.

Advanced | JY9810CoreOO::AIRecord
File_Format | JY9810CoreOO::AIRecord
FilePath | JY9810CoreOO::AIRecord
Length | JY9810CoreOO::AIRecord
Mode | JY9810CoreOO::AIRecord


9810 C++ Programming Manual: Member List

  • AISampleClock
JY9810CoreOO::AISampleClock Member List

This is the complete list of members for JY9810CoreOO::AISampleClock, including all inherited members.

External | JY9810CoreOO::AISampleClock
Source | JY9810CoreOO::AISampleClock


9810 C++ Programming Manual: Member List

  • AISignalExport
JY9810CoreOO::AISignalExport Member List

This is the complete list of members for JY9810CoreOO::AISignalExport, including all inherited members.

Add(AISignalExportSource source, SignalExportDestination destination) | JY9810CoreOO::AISignalExport
Add(AISignalExportSource source, std::list< SignalExportDestination > destinations) | JY9810CoreOO::AISignalExport
Clear(SignalExportDestination destination) | JY9810CoreOO::AISignalExport
ClearAll() | JY9810CoreOO::AISignalExport


9810 C++ Programming Manual: Member List

  • AISync
JY9810CoreOO::AISync Member List

This is the complete list of members for JY9810CoreOO::AISync, including all inherited members.

PulseRouting | JY9810CoreOO::AISync
Topology | JY9810CoreOO::AISync
TriggerRouting | JY9810CoreOO::AISync


9810 C++ Programming Manual: Member List

  • AITrigger
JY9810CoreOO::AITrigger Member List

This is the complete list of members for JY9810CoreOO::AITrigger, including all inherited members.

Analog | JY9810CoreOO::AITrigger
Digital | JY9810CoreOO::AITrigger
Mode | JY9810CoreOO::AITrigger
MultiChannel | JY9810CoreOO::AITrigger
PreTriggerSamples | JY9810CoreOO::AITrigger
ReTriggerCount | JY9810CoreOO::AITrigger
Type | JY9810CoreOO::AITrigger


9810 C++ Programming Manual: Member List

  • ExternalReferenceClock
JY9810CoreOO::ExternalReferenceClock Member List

This is the complete list of members for JY9810CoreOO::ExternalReferenceClock, including all inherited members.

ExternalReferenceClock() | JY9810CoreOO::ExternalReferenceClock | inline
Frequency | JY9810CoreOO::ExternalReferenceClock |
Terminal | JY9810CoreOO::ExternalReferenceClock |


9810 C++ Programming Manual: Member List

  • JY9810CoreOOAITask
JY9810CoreOO::JY9810CoreOOAITask Member List

This is the complete list of members for JY9810CoreOO::JY9810CoreOOAITask, including all inherited members.

AddChannel(int chnId, double rangeLow=-10, double rangeHigh=10, AICoupling coupling=AICoupling::DC, AIImpedance impedance=AIImpedance::Impedance50Ohm) | JY9810CoreOO::JY9810CoreOOAITask
AddChannel(std::vector< int > chnsId, double rangeLow=-10, double rangeHigh=10, AICoupling coupling=AICoupling::DC, AIImpedance impedance=AIImpedance::Impedance50Ohm) | JY9810CoreOO::JY9810CoreOOAITask
AddChannel(std::vector< int > chnsId, std::vector< double > rangeLow, std::vector< double > rangeHigh, std::vector< AICoupling > coupling, std::vector< AIImpedance > impedance) | JY9810CoreOO::JY9810CoreOOAITask
AvailableSamples | JY9810CoreOO::JY9810CoreOOAITask
BufLenInSamples | JY9810CoreOO::JY9810CoreOOAITask
Channels | JY9810CoreOO::JY9810CoreOOAITask
Device | JY9810CoreOO::JY9810CoreOOAITask
DisableCalibration | JY9810CoreOO::JY9810CoreOOAITask
DisableDigitalTriggerDelay | JY9810CoreOO::JY9810CoreOOAITask
GetRecordPreviewData(double *buf, int samplesPerChannel, int timeout=1000) | JY9810CoreOO::JY9810CoreOOAITask
GetRecordStatus(double *recordedLength, bool *recordDone) | JY9810CoreOO::JY9810CoreOOAITask
JY9810CoreOOAITask(int slotNum) | JY9810CoreOO::JY9810CoreOOAITask
JY9810CoreOOAITask(std::string boardName) | JY9810CoreOO::JY9810CoreOOAITask
Mode | JY9810CoreOO::JY9810CoreOOAITask
ReadData(double *pBuf, int samplesPerChannel, int timeout=-1) | JY9810CoreOO::JY9810CoreOOAITask
ReadRawData(short *pBuf, int samplesPerChannel, int timeout=-1) | JY9810CoreOO::JY9810CoreOOAITask
Record | JY9810CoreOO::JY9810CoreOOAITask
RemoveChannel(int chnId) | JY9810CoreOO::JY9810CoreOOAITask
SampleClock | JY9810CoreOO::JY9810CoreOOAITask
SampleRate | JY9810CoreOO::JY9810CoreOOAITask
SamplesToAcquire | JY9810CoreOO::JY9810CoreOOAITask
SendSoftwareTrigger() | JY9810CoreOO::JY9810CoreOOAITask
SignalExport | JY9810CoreOO::JY9810CoreOOAITask
Start() | JY9810CoreOO::JY9810CoreOOAITask
Stop() | JY9810CoreOO::JY9810CoreOOAITask
Sync | JY9810CoreOO::JY9810CoreOOAITask
TransferedSamples | JY9810CoreOO::JY9810CoreOOAITask
Trigger | JY9810CoreOO::JY9810CoreOOAITask
~JY9810CoreOOAITask() | JY9810CoreOO::JY9810CoreOOAITask


9810 C++ Programming Manual: Member List

  • JY9810CoreOODevice
JY9810CoreOO::JY9810CoreOODevice Member List

This is the complete list of members for JY9810CoreOO::JY9810CoreOODevice, including all inherited members.

AIBufferSize | JY9810CoreOO::JY9810CoreOODevice |
BoardClockRate | JY9810CoreOO::JY9810CoreOODevice |
DeviceID | JY9810CoreOO::JY9810CoreOODevice |
DiffChannelCount | JY9810CoreOO::JY9810CoreOODevice |
DIOPortCount | JY9810CoreOO::JY9810CoreOODevice |
GetInstance(int cardNum) | JY9810CoreOO::JY9810CoreOODevice | static
GetInstance(std::string aliasName) | JY9810CoreOO::JY9810CoreOODevice | static
Handle | JY9810CoreOO::JY9810CoreOODevice |
IsAOSync | JY9810CoreOO::JY9810CoreOODevice |
LineCountPerPort | JY9810CoreOO::JY9810CoreOODevice |
MaxSampleRateSingleChannel | JY9810CoreOO::JY9810CoreOODevice |
ReferenceClock | JY9810CoreOO::JY9810CoreOODevice |
SerialNumber | JY9810CoreOO::JY9810CoreOODevice |
SubCardADCType | JY9810CoreOO::JY9810CoreOODevice |


9810 C++ Programming Manual: Member List

  • JY9810CoreOOLog
JY9810CoreOO::JY9810CoreOOLog Member List

This is the complete list of members for JY9810CoreOO::JY9810CoreOOLog, including all inherited members.

EnableLog | JY9810CoreOO::JY9810CoreOOLog | static
Flush() | JY9810CoreOO::JY9810CoreOOLog | static
LogLevel | JY9810CoreOO::JY9810CoreOOLog | static
Print(const char *format,...) | JY9810CoreOO::JY9810CoreOOLog | static
Print(JY9810CoreOOLogLevel logLevel, const char *format,...) | JY9810CoreOO::JY9810CoreOOLog | static


9810 C++ Programming Manual: Member List

  • JY9810CoreOOProperty
JY9810CoreOO::JY9810CoreOOProperty< ContainerClass, ValueType, propertyType > Member List

This is the complete list of members for JY9810CoreOO::JY9810CoreOOProperty< ContainerClass, ValueType, propertyType >, including all inherited members.

JY9810CoreOOProperty() | JY9810CoreOO::JY9810CoreOOProperty< ContainerClass, ValueType, propertyType >
JY9810CoreOOProperty(ContainerClass *cObject, ValueType(ContainerClass::*pGet)(), void(ContainerClass::*pSet)(ValueType value)) | JY9810CoreOO::JY9810CoreOOProperty< ContainerClass, ValueType, propertyType >
JY9810CoreOOProperty(ValueType(*pGet)(), void(*pSet)(ValueType value)) | JY9810CoreOO::JY9810CoreOOProperty< ContainerClass, ValueType, propertyType >
operator ValueType() | JY9810CoreOO::JY9810CoreOOProperty< ContainerClass, ValueType, propertyType >
operator=(const ValueType &value) | JY9810CoreOO::JY9810CoreOOProperty< ContainerClass, ValueType, propertyType >


9810 C++ Programming Manual: Member List

  • JY9810CoreOOReferenceClock
JY9810CoreOO::JY9810CoreOOReferenceClock Member List

This is the complete list of members for JY9810CoreOO::JY9810CoreOOReferenceClock, including all inherited members.

Commit() | JY9810CoreOO::JY9810CoreOOReferenceClock
External | JY9810CoreOO::JY9810CoreOOReferenceClock
Source | JY9810CoreOO::JY9810CoreOOReferenceClock


9810 C++ Programming Manual: Member List

  • JYDriverException
JY9810CoreOO::JYDriverException Member List

This is the complete list of members for JY9810CoreOO::JYDriverException, including all inherited members.

errorCode | JY9810CoreOO::JYDriverException
exceptionMessage | JY9810CoreOO::JYDriverException
FollowingException | JY9810CoreOO::JYDriverException
JYDriverException(JYDriverExceptionPublic exceptionCode, std::string msg="") | JY9810CoreOO::JYDriverException
JYDriverException(int, std::string msg) | JY9810CoreOO::JYDriverException


9810 C++ Programming Manual: Member List

  • PauseTrigger
JY9810CoreOO::PauseTrigger Member List

This is the complete list of members for JY9810CoreOO::PauseTrigger, including all inherited members.

ActivePolarity | JY9810CoreOO::PauseTrigger
Terminal | JY9810CoreOO::PauseTrigger


9810 C++ Programming Manual: JY9810CoreOOAIMode Class Reference

JY9810CoreOOAIMode Class Reference

AIMode. More...

#include <JY9810CoreOOAITask.h>

Detailed Description

AIMode.

The documentation for this class was generated from the following file:
  • C:/Users/JYTEK-NUC1/Desktop/COO/9810/JY9810CoreOOAITask.h


9810 C++ Programming Manual: Class Index

Class Index
A | E | J | P
A
AIAnalogEdgeComparator (JY9810CoreOO)
AIAnalogHysteresisComparator (JY9810CoreOO)
AIAnalogTrigger (JY9810CoreOO)
AIAnalogWindowComparator (JY9810CoreOO)
AIChannel (JY9810CoreOO)
AIDigitalTrigger (JY9810CoreOO)
AIExternalSampleClock (JY9810CoreOO)
AIMultiChannelAnalogTrigger (JY9810CoreOO)
AIRecord (JY9810CoreOO)
AIRecordAdvanced (JY9810CoreOO)
AISampleClock (JY9810CoreOO)
AISignalExport (JY9810CoreOO)
AISync (JY9810CoreOO)
AITrigger (JY9810CoreOO)
E
ExternalReferenceClock (JY9810CoreOO)
J
JY9810CoreOOAIMode
JY9810CoreOOAITask (JY9810CoreOO)
JY9810CoreOODevice (JY9810CoreOO)
JY9810CoreOOLog (JY9810CoreOO)
JY9810CoreOOProperty (JY9810CoreOO)
JY9810CoreOOReferenceClock (JY9810CoreOO)
JYDriverException (JY9810CoreOO)
P
PauseTrigger (JY9810CoreOO)


9810 C++ Programming Manual: C:/Users/JYTEK-NUC1/Desktop/COO Directory Reference

  • File List
  • File Members
  • COO
COO Directory Reference

Directories

9810


9810 C++ Programming Manual: File List

  • File List
  • File Members
File List
Here is a list of all files with brief descriptions:
[detail level 123]
▼ COO
▼ 9810
JY9810CoreOOAITask.h
JY9810CoreOOCommon.h
JY9810CoreOODevice.h
JY9810CoreOOLog.h


9810 C++ Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • w
  • ~
Here is a list of all class members with links to the classes they belong to:

- a -

  • ActivePolarity : JY9810CoreOO::PauseTrigger
  • Add() : JY9810CoreOO::AISignalExport
  • AddChannel() : JY9810CoreOO::JY9810CoreOOAITask
  • Advanced : JY9810CoreOO::AIRecord
  • AIAnalogTrigger() : JY9810CoreOO::AIAnalogTrigger
  • AIBufferSize : JY9810CoreOO::JY9810CoreOODevice
  • AIChannel() : JY9810CoreOO::AIChannel
  • Analog : JY9810CoreOO::AIMultiChannelAnalogTrigger, JY9810CoreOO::AITrigger
  • AvailableSamples : JY9810CoreOO::JY9810CoreOOAITask

- b -

  • BoardClockRate : JY9810CoreOO::JY9810CoreOODevice
  • BufLenInSamples : JY9810CoreOO::JY9810CoreOOAITask

- c -

  • ChannelID : JY9810CoreOO::AIChannel
  • Channels : JY9810CoreOO::JY9810CoreOOAITask
  • Clear() : JY9810CoreOO::AISignalExport
  • ClearAll() : JY9810CoreOO::AISignalExport
  • Commit() : JY9810CoreOO::JY9810CoreOOReferenceClock
  • Comparator : JY9810CoreOO::AIAnalogTrigger
  • Condition : JY9810CoreOO::AIAnalogWindowComparator
  • Coupling : JY9810CoreOO::AIChannel

- d -

  • Device : JY9810CoreOO::JY9810CoreOOAITask
  • DeviceID : JY9810CoreOO::JY9810CoreOODevice
  • DiffChannelCount : JY9810CoreOO::JY9810CoreOODevice
  • Digital : JY9810CoreOO::AITrigger
  • DIOPortCount : JY9810CoreOO::JY9810CoreOODevice
  • DisableCalibration : JY9810CoreOO::JY9810CoreOOAITask
  • DisableDigitalTriggerDelay : JY9810CoreOO::JY9810CoreOOAITask

- e -

  • Edge : JY9810CoreOO::AIAnalogTrigger, JY9810CoreOO::AIDigitalTrigger
  • EnableLog : JY9810CoreOO::JY9810CoreOOLog
  • errorCode : JY9810CoreOO::JYDriverException
  • exceptionMessage : JY9810CoreOO::JYDriverException
  • ExpectedRate : JY9810CoreOO::AIExternalSampleClock
  • External : JY9810CoreOO::AISampleClock, JY9810CoreOO::JY9810CoreOOReferenceClock
  • ExternalReferenceClock() : JY9810CoreOO::ExternalReferenceClock

- f -

  • File_Format : JY9810CoreOO::AIRecord
  • FilePath : JY9810CoreOO::AIRecord
  • Flush() : JY9810CoreOO::JY9810CoreOOLog
  • FollowingException : JY9810CoreOO::JYDriverException
  • Frequency : JY9810CoreOO::ExternalReferenceClock

- g -

  • GetInstance() : JY9810CoreOO::JY9810CoreOODevice
  • GetRecordPreviewData() : JY9810CoreOO::JY9810CoreOOAITask
  • GetRecordStatus() : JY9810CoreOO::JY9810CoreOOAITask

- h -

  • Handle : JY9810CoreOO::JY9810CoreOODevice
  • HighThreshold : JY9810CoreOO::AIAnalogHysteresisComparator, JY9810CoreOO::AIAnalogWindowComparator
  • Hysteresis : JY9810CoreOO::AIAnalogTrigger

- i -

  • Impedance : JY9810CoreOO::AIChannel
  • IsAOSync : JY9810CoreOO::JY9810CoreOODevice

- j -

  • JY9810CoreOOAITask() : JY9810CoreOO::JY9810CoreOOAITask
  • JY9810CoreOOProperty() : JY9810CoreOO::JY9810CoreOOProperty< ContainerClass, ValueType, propertyType >
  • JYDriverException() : JY9810CoreOO::JYDriverException

- l -

  • Length : JY9810CoreOO::AIRecord
  • LineCountPerPort : JY9810CoreOO::JY9810CoreOODevice
  • Logic : JY9810CoreOO::AIMultiChannelAnalogTrigger
  • LogLevel : JY9810CoreOO::JY9810CoreOOLog
  • LowThreshold : JY9810CoreOO::AIAnalogHysteresisComparator, JY9810CoreOO::AIAnalogWindowComparator

- m -

  • MaxSampleRateSingleChannel : JY9810CoreOO::JY9810CoreOODevice
  • Mode : JY9810CoreOO::AIRecord, JY9810CoreOO::AITrigger, JY9810CoreOO::JY9810CoreOOAITask
  • MultiChannel : JY9810CoreOO::AITrigger

- o -

  • operator ValueType() : JY9810CoreOO::JY9810CoreOOProperty< ContainerClass, ValueType, propertyType >
  • operator=() : JY9810CoreOO::JY9810CoreOOProperty< ContainerClass, ValueType, propertyType >

- p -

  • PreTriggerSamples : JY9810CoreOO::AITrigger
  • Print() : JY9810CoreOO::JY9810CoreOOLog
  • PulseRouting : JY9810CoreOO::AISync

- r -

  • RangeHigh : JY9810CoreOO::AIChannel
  • RangeLow : JY9810CoreOO::AIChannel
  • ReadData() : JY9810CoreOO::JY9810CoreOOAITask
  • ReadRawData() : JY9810CoreOO::JY9810CoreOOAITask
  • Record : JY9810CoreOO::JY9810CoreOOAITask
  • ReferenceClock : JY9810CoreOO::JY9810CoreOODevice
  • RemoveChannel() : JY9810CoreOO::JY9810CoreOOAITask
  • ReTriggerCount : JY9810CoreOO::AITrigger

- s -

  • SampleClock : JY9810CoreOO::JY9810CoreOOAITask
  • SampleRate : JY9810CoreOO::JY9810CoreOOAITask
  • SamplesToAcquire : JY9810CoreOO::JY9810CoreOOAITask
  • SendSoftwareTrigger() : JY9810CoreOO::JY9810CoreOOAITask
  • SerialNumber : JY9810CoreOO::JY9810CoreOODevice
  • SignalExport : JY9810CoreOO::JY9810CoreOOAITask
  • Slope : JY9810CoreOO::AIAnalogEdgeComparator, JY9810CoreOO::AIAnalogHysteresisComparator
  • Source : JY9810CoreOO::AIAnalogTrigger, JY9810CoreOO::AIDigitalTrigger, JY9810CoreOO::AISampleClock, JY9810CoreOO::JY9810CoreOOReferenceClock
  • Start() : JY9810CoreOO::JY9810CoreOOAITask
  • Stop() : JY9810CoreOO::JY9810CoreOOAITask
  • SubCardADCType : JY9810CoreOO::JY9810CoreOODevice
  • Sync : JY9810CoreOO::JY9810CoreOOAITask

- t -

  • Terminal : JY9810CoreOO::AIExternalSampleClock, JY9810CoreOO::ExternalReferenceClock, JY9810CoreOO::PauseTrigger
  • Threshold : JY9810CoreOO::AIAnalogEdgeComparator
  • Topology : JY9810CoreOO::AISync
  • TransferedSamples : JY9810CoreOO::JY9810CoreOOAITask
  • Trigger : JY9810CoreOO::JY9810CoreOOAITask
  • TriggerRouting : JY9810CoreOO::AISync
  • Type : JY9810CoreOO::AITrigger

- w -

  • Window : JY9810CoreOO::AIAnalogTrigger

- ~ -

  • ~AIAnalogTrigger() : JY9810CoreOO::AIAnalogTrigger
  • ~JY9810CoreOOAITask() : JY9810CoreOO::JY9810CoreOOAITask


9810 C++ Programming Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • c
  • e
  • f
  • g
  • j
  • o
  • p
  • r
  • s
  • ~
Here is a list of all functions with links to the classes they belong to:

- a -

  • Add() : JY9810CoreOO::AISignalExport
  • AddChannel() : JY9810CoreOO::JY9810CoreOOAITask
  • AIAnalogTrigger() : JY9810CoreOO::AIAnalogTrigger
  • AIChannel() : JY9810CoreOO::AIChannel

- c -

  • Clear() : JY9810CoreOO::AISignalExport
  • ClearAll() : JY9810CoreOO::AISignalExport
  • Commit() : JY9810CoreOO::JY9810CoreOOReferenceClock

- e -

  • ExternalReferenceClock() : JY9810CoreOO::ExternalReferenceClock

- f -

  • Flush() : JY9810CoreOO::JY9810CoreOOLog

- g -

  • GetInstance() : JY9810CoreOO::JY9810CoreOODevice
  • GetRecordPreviewData() : JY9810CoreOO::JY9810CoreOOAITask
  • GetRecordStatus() : JY9810CoreOO::JY9810CoreOOAITask

- j -

  • JY9810CoreOOAITask() : JY9810CoreOO::JY9810CoreOOAITask
  • JY9810CoreOOProperty() : JY9810CoreOO::JY9810CoreOOProperty< ContainerClass, ValueType, propertyType >
  • JYDriverException() : JY9810CoreOO::JYDriverException

- o -

  • operator ValueType() : JY9810CoreOO::JY9810CoreOOProperty< ContainerClass, ValueType, propertyType >
  • operator=() : JY9810CoreOO::JY9810CoreOOProperty< ContainerClass, ValueType, propertyType >

- p -

  • Print() : JY9810CoreOO::JY9810CoreOOLog

- r -

  • ReadData() : JY9810CoreOO::JY9810CoreOOAITask
  • ReadRawData() : JY9810CoreOO::JY9810CoreOOAITask
  • RemoveChannel() : JY9810CoreOO::JY9810CoreOOAITask

- s -

  • SendSoftwareTrigger() : JY9810CoreOO::JY9810CoreOOAITask
  • Start() : JY9810CoreOO::JY9810CoreOOAITask
  • Stop() : JY9810CoreOO::JY9810CoreOOAITask

- ~ -

  • ~AIAnalogTrigger() : JY9810CoreOO::AIAnalogTrigger
  • ~JY9810CoreOOAITask() : JY9810CoreOO::JY9810CoreOOAITask


9810 C++ Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • p
  • r
  • s
  • t
  • w
Here is a list of all variables with links to the classes they belong to:

- a -

  • ActivePolarity : JY9810CoreOO::PauseTrigger
  • Advanced : JY9810CoreOO::AIRecord
  • AIBufferSize : JY9810CoreOO::JY9810CoreOODevice
  • Analog : JY9810CoreOO::AIMultiChannelAnalogTrigger, JY9810CoreOO::AITrigger
  • AvailableSamples : JY9810CoreOO::JY9810CoreOOAITask

- b -

  • BoardClockRate : JY9810CoreOO::JY9810CoreOODevice
  • BufLenInSamples : JY9810CoreOO::JY9810CoreOOAITask

- c -

  • ChannelID : JY9810CoreOO::AIChannel
  • Channels : JY9810CoreOO::JY9810CoreOOAITask
  • Comparator : JY9810CoreOO::AIAnalogTrigger
  • Condition : JY9810CoreOO::AIAnalogWindowComparator
  • Coupling : JY9810CoreOO::AIChannel

- d -

  • Device : JY9810CoreOO::JY9810CoreOOAITask
  • DeviceID : JY9810CoreOO::JY9810CoreOODevice
  • DiffChannelCount : JY9810CoreOO::JY9810CoreOODevice
  • Digital : JY9810CoreOO::AITrigger
  • DIOPortCount : JY9810CoreOO::JY9810CoreOODevice
  • DisableCalibration : JY9810CoreOO::JY9810CoreOOAITask
  • DisableDigitalTriggerDelay : JY9810CoreOO::JY9810CoreOOAITask

- e -

  • Edge : JY9810CoreOO::AIAnalogTrigger, JY9810CoreOO::AIDigitalTrigger
  • EnableLog : JY9810CoreOO::JY9810CoreOOLog
  • errorCode : JY9810CoreOO::JYDriverException
  • exceptionMessage : JY9810CoreOO::JYDriverException
  • ExpectedRate : JY9810CoreOO::AIExternalSampleClock
  • External : JY9810CoreOO::AISampleClock, JY9810CoreOO::JY9810CoreOOReferenceClock

- f -

  • File_Format : JY9810CoreOO::AIRecord
  • FilePath : JY9810CoreOO::AIRecord
  • FollowingException : JY9810CoreOO::JYDriverException
  • Frequency : JY9810CoreOO::ExternalReferenceClock

- h -

  • Handle : JY9810CoreOO::JY9810CoreOODevice
  • HighThreshold : JY9810CoreOO::AIAnalogHysteresisComparator, JY9810CoreOO::AIAnalogWindowComparator
  • Hysteresis : JY9810CoreOO::AIAnalogTrigger

- i -

  • Impedance : JY9810CoreOO::AIChannel
  • IsAOSync : JY9810CoreOO::JY9810CoreOODevice

- l -

  • Length : JY9810CoreOO::AIRecord
  • LineCountPerPort : JY9810CoreOO::JY9810CoreOODevice
  • Logic : JY9810CoreOO::AIMultiChannelAnalogTrigger
  • LogLevel : JY9810CoreOO::JY9810CoreOOLog
  • LowThreshold : JY9810CoreOO::AIAnalogHysteresisComparator, JY9810CoreOO::AIAnalogWindowComparator

- m -

  • MaxSampleRateSingleChannel : JY9810CoreOO::JY9810CoreOODevice
  • Mode : JY9810CoreOO::AIRecord, JY9810CoreOO::AITrigger, JY9810CoreOO::JY9810CoreOOAITask
  • MultiChannel : JY9810CoreOO::AITrigger

- p -

  • PreTriggerSamples : JY9810CoreOO::AITrigger
  • PulseRouting : JY9810CoreOO::AISync

- r -

  • RangeHigh : JY9810CoreOO::AIChannel
  • RangeLow : JY9810CoreOO::AIChannel
  • Record : JY9810CoreOO::JY9810CoreOOAITask
  • ReferenceClock : JY9810CoreOO::JY9810CoreOODevice
  • ReTriggerCount : JY9810CoreOO::AITrigger

- s -

  • SampleClock : JY9810CoreOO::JY9810CoreOOAITask
  • SampleRate : JY9810CoreOO::JY9810CoreOOAITask
  • SamplesToAcquire : JY9810CoreOO::JY9810CoreOOAITask
  • SerialNumber : JY9810CoreOO::JY9810CoreOODevice
  • SignalExport : JY9810CoreOO::JY9810CoreOOAITask
  • Slope : JY9810CoreOO::AIAnalogEdgeComparator, JY9810CoreOO::AIAnalogHysteresisComparator
  • Source : JY9810CoreOO::AIAnalogTrigger, JY9810CoreOO::AIDigitalTrigger, JY9810CoreOO::AISampleClock, JY9810CoreOO::JY9810CoreOOReferenceClock
  • SubCardADCType : JY9810CoreOO::JY9810CoreOODevice
  • Sync : JY9810CoreOO::JY9810CoreOOAITask

- t -

  • Terminal : JY9810CoreOO::AIExternalSampleClock, JY9810CoreOO::ExternalReferenceClock, JY9810CoreOO::PauseTrigger
  • Threshold : JY9810CoreOO::AIAnalogEdgeComparator
  • Topology : JY9810CoreOO::AISync
  • TransferedSamples : JY9810CoreOO::JY9810CoreOOAITask
  • Trigger : JY9810CoreOO::JY9810CoreOOAITask
  • TriggerRouting : JY9810CoreOO::AISync
  • Type : JY9810CoreOO::AITrigger

- w -

  • Window : JY9810CoreOO::AIAnalogTrigger


9810 C++ Programming Manual: File Members

  • File List
  • File Members
  • All
  • Macros
Here is a list of all file members with links to the files they belong to:
  • _CRT_SECURE_NO_WARNINGS : JY9810CoreOOAITask.h
  • EXTERN_C : JY9810CoreOOCommon.h
  • JY9810CoreOO_API : JY9810CoreOOCommon.h


9810 C++ Programming Manual: File Members

  • File List
  • File Members
  • All
  • Macros
Here is a list of all macros with links to the files they belong to:
  • _CRT_SECURE_NO_WARNINGS : JY9810CoreOOAITask.h
  • EXTERN_C : JY9810CoreOOCommon.h
  • JY9810CoreOO_API : JY9810CoreOOCommon.h


9810 C++ Programming Manual: Main Page

9810 C++ Programming Manual Documentation


9810 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
  • a
  • c
  • e
  • f
  • g
  • j
  • l
  • m
  • r
  • s
Here is a list of all namespace members with links to the namespace documentation for each member:

- a -

  • AIAnalogTriggerComparator : JY9810CoreOO
  • AIAnalogTriggerEdge : JY9810CoreOO
  • AIAnalogTriggerSource : JY9810CoreOO
  • AIAnalogWindowCondition : JY9810CoreOO
  • AICoupling : JY9810CoreOO
  • AIDigitalTriggerEdge : JY9810CoreOO
  • AIDigitalTriggerSource : JY9810CoreOO
  • AIImpedance : JY9810CoreOO
  • AIMode : JY9810CoreOO
  • AISampleClockSource : JY9810CoreOO
  • AISignalExportSource : JY9810CoreOO
  • AITriggerMode : JY9810CoreOO
  • AITriggerType : JY9810CoreOO

- c -

  • ClockTerminal : JY9810CoreOO

- e -

  • ExternalReferenceClockTerminal : JY9810CoreOO

- f -

  • FileFormat : JY9810CoreOO

- g -

  • GetSignalExportDestinationString() : JY9810CoreOO

- j -

  • JY9810_125M : JY9810Import
  • JY9810_80M : JY9810Import
  • JY9810_AI_AC_Couple : JY9810Import
  • JY9810_AI_DC_Couple : JY9810Import
  • JY9810_AI_OHM_1M : JY9810Import
  • JY9810_AI_OHM_50 : JY9810Import
  • JY9810_AnaloglTriggerCondition_FallingHysteresis : JY9810Import
  • JY9810_AnaloglTriggerCondition_LeavingWindow : JY9810Import
  • JY9810_AnalogTriggerCondition_EnteringWindow : JY9810Import
  • JY9810_AnalogTriggerCondition_RisingHysteresis : JY9810Import
  • JY9810_AnalogTriggerType_Hysteresis : JY9810Import
  • JY9810_AnalogTriggerType_Window : JY9810Import
  • JY9810_CB_100M : JY9810Import
  • JY9810_Continuous : JY9810Import
  • JY9810_DigitalTriggerEdge_Falling : JY9810Import
  • JY9810_DigitalTriggerEdge_Rising : JY9810Import
  • JY9810_DigitalTriggerSource_PXI_0 : JY9810Import
  • JY9810_DigitalTriggerSource_PXI_1 : JY9810Import
  • JY9810_DigitalTriggerSource_PXI_2 : JY9810Import
  • JY9810_DigitalTriggerSource_PXI_3 : JY9810Import
  • JY9810_DigitalTriggerSource_PXI_4 : JY9810Import
  • JY9810_DigitalTriggerSource_PXI_5 : JY9810Import
  • JY9810_DigitalTriggerSource_PXI_6 : JY9810Import
  • JY9810_DigitalTriggerSource_PXI_7 : JY9810Import
  • JY9810_DigitalTriggerSource_PXIe_DStarB : JY9810Import
  • JY9810_DigitalTriggerSource_PXIe_DStarC : JY9810Import
  • JY9810_DigitalTriggerSource_TRIG_IN : JY9810Import
  • JY9810_Extenal_Ref_10M : JY9810Import
  • JY9810_ExternalClock : JY9810Import
  • JY9810_Finite : JY9810Import
  • JY9810_Independent : JY9810Import
  • JY9810_InternalClock : JY9810Import
  • JY9810_MASTER : JY9810Import
  • JY9810_MAX_SampleRate : JY9810Import
  • JY9810_MIN_SampleRate : JY9810Import
  • JY9810_Onboard_10M : JY9810Import
  • JY9810_PLL_SYNC_OUT : JY9810Import
  • JY9810_RefTrigger : JY9810Import
  • JY9810_SLAVE : JY9810Import
  • JY9810_Soft_Ref_Trigger : JY9810Import
  • JY9810_Soft_Start_Trigger : JY9810Import
  • JY9810_StartTrigger : JY9810Import
  • JY9810_SyncSignal_PXI_0 : JY9810Import
  • JY9810_SyncSignal_PXI_1 : JY9810Import
  • JY9810_SyncSignal_PXI_2 : JY9810Import
  • JY9810_SyncSignal_PXI_3 : JY9810Import
  • JY9810_SyncSignal_PXI_4 : JY9810Import
  • JY9810_SyncSignal_PXI_5 : JY9810Import
  • JY9810_SyncSignal_PXI_6 : JY9810Import
  • JY9810_SyncSignal_PXI_7 : JY9810Import
  • JY9810_TriggerOut_PXI_0 : JY9810Import
  • JY9810_TriggerOut_PXI_1 : JY9810Import
  • JY9810_TriggerOut_PXI_2 : JY9810Import
  • JY9810_TriggerOut_PXI_3 : JY9810Import
  • JY9810_TriggerOut_PXI_4 : JY9810Import
  • JY9810_TriggerOut_PXI_5 : JY9810Import
  • JY9810_TriggerOut_PXI_6 : JY9810Import
  • JY9810_TriggerOut_PXI_7 : JY9810Import
  • JY9810_TriggerOut_TRG_OUT : JY9810Import
  • JY9810_TriggerType_Analog : JY9810Import
  • JY9810_TriggerType_Digital : JY9810Import
  • JY9810_TriggerType_Immediately : JY9810Import
  • JY9810_TriggerType_Soft : JY9810Import
  • JY9810CoreOOLogLevel : JY9810CoreOO
  • JY9810CoreOOPropertyType : JY9810CoreOO
  • JYDriverExceptionPublic : JY9810CoreOO

- l -

  • LevelPolarity : JY9810CoreOO

- m -

  • MultiChannelCompositionLogic : JY9810CoreOO

- r -

  • RecordMode : JY9810CoreOO
  • ReferenceClockSource : JY9810CoreOO

- s -

  • SignalExportDestination : JY9810CoreOO
  • SyncPulseRouting : JY9810CoreOO
  • SyncSignal_IN : JY9810Import
  • SyncSignal_OUT : JY9810Import
  • SyncTopology : JY9810CoreOO
  • SyncTriggerRouting : JY9810CoreOO


9810 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
Here is a list of all namespace enums with links to the namespace documentation for each enum:
  • AIAnalogTriggerComparator : JY9810CoreOO
  • AIAnalogTriggerEdge : JY9810CoreOO
  • AIAnalogTriggerSource : JY9810CoreOO
  • AIAnalogWindowCondition : JY9810CoreOO
  • AICoupling : JY9810CoreOO
  • AIDigitalTriggerEdge : JY9810CoreOO
  • AIDigitalTriggerSource : JY9810CoreOO
  • AIImpedance : JY9810CoreOO
  • AIMode : JY9810CoreOO
  • AISampleClockSource : JY9810CoreOO
  • AISignalExportSource : JY9810CoreOO
  • AITriggerMode : JY9810CoreOO
  • AITriggerType : JY9810CoreOO
  • ClockTerminal : JY9810CoreOO
  • ExternalReferenceClockTerminal : JY9810CoreOO
  • FileFormat : JY9810CoreOO
  • JY9810CoreOOLogLevel : JY9810CoreOO
  • JY9810CoreOOPropertyType : JY9810CoreOO
  • JYDriverExceptionPublic : JY9810CoreOO
  • LevelPolarity : JY9810CoreOO
  • MultiChannelCompositionLogic : JY9810CoreOO
  • RecordMode : JY9810CoreOO
  • ReferenceClockSource : JY9810CoreOO
  • SignalExportDestination : JY9810CoreOO
  • SyncPulseRouting : JY9810CoreOO
  • SyncTopology : JY9810CoreOO
  • SyncTriggerRouting : JY9810CoreOO


9810 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
Here is a list of all namespace functions with links to the namespace documentation for each function:
  • GetSignalExportDestinationString() : JY9810CoreOO


9810 C++ Programming Manual: Namespace Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Enumerations
  • j
  • s
Here is a list of all namespace variables with links to the namespace documentation for each variable:

- j -

  • JY9810_125M : JY9810Import
  • JY9810_80M : JY9810Import
  • JY9810_AI_AC_Couple : JY9810Import
  • JY9810_AI_DC_Couple : JY9810Import
  • JY9810_AI_OHM_1M : JY9810Import
  • JY9810_AI_OHM_50 : JY9810Import
  • JY9810_AnaloglTriggerCondition_FallingHysteresis : JY9810Import
  • JY9810_AnaloglTriggerCondition_LeavingWindow : JY9810Import
  • JY9810_AnalogTriggerCondition_EnteringWindow : JY9810Import
  • JY9810_AnalogTriggerCondition_RisingHysteresis : JY9810Import
  • JY9810_AnalogTriggerType_Hysteresis : JY9810Import
  • JY9810_AnalogTriggerType_Window : JY9810Import
  • JY9810_CB_100M : JY9810Import
  • JY9810_Continuous : JY9810Import
  • JY9810_DigitalTriggerEdge_Falling : JY9810Import
  • JY9810_DigitalTriggerEdge_Rising : JY9810Import
  • JY9810_DigitalTriggerSource_PXI_0 : JY9810Import
  • JY9810_DigitalTriggerSource_PXI_1 : JY9810Import
  • JY9810_DigitalTriggerSource_PXI_2 : JY9810Import
  • JY9810_DigitalTriggerSource_PXI_3 : JY9810Import
  • JY9810_DigitalTriggerSource_PXI_4 : JY9810Import
  • JY9810_DigitalTriggerSource_PXI_5 : JY9810Import
  • JY9810_DigitalTriggerSource_PXI_6 : JY9810Import
  • JY9810_DigitalTriggerSource_PXI_7 : JY9810Import
  • JY9810_DigitalTriggerSource_PXIe_DStarB : JY9810Import
  • JY9810_DigitalTriggerSource_PXIe_DStarC : JY9810Import
  • JY9810_DigitalTriggerSource_TRIG_IN : JY9810Import
  • JY9810_Extenal_Ref_10M : JY9810Import
  • JY9810_ExternalClock : JY9810Import
  • JY9810_Finite : JY9810Import
  • JY9810_Independent : JY9810Import
  • JY9810_InternalClock : JY9810Import
  • JY9810_MASTER : JY9810Import
  • JY9810_MAX_SampleRate : JY9810Import
  • JY9810_MIN_SampleRate : JY9810Import
  • JY9810_Onboard_10M : JY9810Import
  • JY9810_PLL_SYNC_OUT : JY9810Import
  • JY9810_RefTrigger : JY9810Import
  • JY9810_SLAVE : JY9810Import
  • JY9810_Soft_Ref_Trigger : JY9810Import
  • JY9810_Soft_Start_Trigger : JY9810Import
  • JY9810_StartTrigger : JY9810Import
  • JY9810_SyncSignal_PXI_0 : JY9810Import
  • JY9810_SyncSignal_PXI_1 : JY9810Import
  • JY9810_SyncSignal_PXI_2 : JY9810Import
  • JY9810_SyncSignal_PXI_3 : JY9810Import
  • JY9810_SyncSignal_PXI_4 : JY9810Import
  • JY9810_SyncSignal_PXI_5 : JY9810Import
  • JY9810_SyncSignal_PXI_6 : JY9810Import
  • JY9810_SyncSignal_PXI_7 : JY9810Import
  • JY9810_TriggerOut_PXI_0 : JY9810Import
  • JY9810_TriggerOut_PXI_1 : JY9810Import
  • JY9810_TriggerOut_PXI_2 : JY9810Import
  • JY9810_TriggerOut_PXI_3 : JY9810Import
  • JY9810_TriggerOut_PXI_4 : JY9810Import
  • JY9810_TriggerOut_PXI_5 : JY9810Import
  • JY9810_TriggerOut_PXI_6 : JY9810Import
  • JY9810_TriggerOut_PXI_7 : JY9810Import
  • JY9810_TriggerOut_TRG_OUT : JY9810Import
  • JY9810_TriggerType_Analog : JY9810Import
  • JY9810_TriggerType_Digital : JY9810Import
  • JY9810_TriggerType_Immediately : JY9810Import
  • JY9810_TriggerType_Soft : JY9810Import

- s -

  • SyncSignal_IN : JY9810Import
  • SyncSignal_OUT : JY9810Import


9810 C++ Programming Manual: Namespace List

  • Namespace List
  • Namespace Members
Namespace List
Here is a list of all namespaces with brief descriptions:
N JY9810CoreOO
N JY9810Import