9818 C++ Programming Manual: D:/9818/C++/JY9810Core.h File Reference

9818 C++ Programming Manual
  • Main Page
  • Classes
  • Files
  • File List
  • File Members
  • 9818
  • C++
Classes | Typedefs | Enumerations | Functions
JY9810Core.h File Reference

Classes

struct JY9810_SpectralInformation

Typedefs

typedef void * | JY9810_Device_Handle
Windows.
typedef unsigned long long | UINT64

Enumerations

enum | JY9810_ReferenceClock { JY9810_Internal = 0 , JY9810_Front_Panel_Clock_In = 1 , JY9810_PXIe_Clk100 = 2 }
enum | JY9810_SampleClockSource { JY9810_InternalClock = 0x0 , JY9810_ExternalClock = 0x1 , JY9810_QuasiExternelClock = 0x2 }
enum JY9810_QuasiClockTerminal {
JY9818_QuasiClock_AnalogTrigger = 6 , JY9818_QuasiClock_PXI_Trig0 = 8 , JY9818_QuasiClock_PXI_Trig1 = 9 , JY9818_QuasiClock_PXI_Trig2 = 10 ,
JY9818_QuasiClock_PXI_Trig3 = 11 , JY9818_QuasiClock_PXI_Trig4 = 12 , JY9818_QuasiClock_PXI_Trig5 = 13 , JY9818_QuasiClock_PXI_Trig6 = 14 ,
JY9818_QuasiClock_PXI_Trig7 = 15 , JY9818_QuasiClock_PFI0 = 16 , JY9818_QuasiClock_PXIe_DStarB = 17 , JY9818_QuasiClock_PXIe_DStarC = 18
}
enum | JY9810_Impedance { JY9810_1M_ohm = 0x0 , JY9810_50_ohm = 0x1 }
enum | JY9810_Coupling { JY9810_Coupling_DC = 0x0 , JY9810_Coupling_AC = 0x1 }
enum | JY9810_SampleMode { JY9810_Finite = 0 , JY9810_Continuous = 1 }
enum | JY9810_TriggerType { JY9810_Immediately = 0 , JY9810_Software = 1 , JY9810_Digital = 2 , JY9810_Analog = 3 }
enum | JY9810_TriggerMode { JY9810_StartTrigger = 0 , JY9810_ReferenceTrigger = 1 }
enum | JY9810_DigitalTriggerEdge { JY9810_Rising = 0x0 , JY9810_Falling = 0x1 }
enum JY9810_DigitalTriggerSource {
JY9810_PXI_Trig0 = 8 , JY9810_PXI_Trig1 = 9 , JY9810_PXI_Trig2 = 10 , JY9810_PXI_Trig3 = 11 ,
JY9810_PXI_Trig4 = 12 , JY9810_PXI_Trig5 = 13 , JY9810_PXI_Trig6 = 14 , JY9810_PXI_Trig7 = 15 ,
JY9810_PFI_0 = 16 , JY9810_PXIe_DStarB = 17 , JY9810_PXIe_DStarC = 18
}
enum | JY9810_AnalogWindowCondition { JY9810_Entering = 0x0 , JY9810_Leaving = 0x1 }
enum | JY9810_AnalogTriggerEdge { JY9810_RisingSlope = 0x0 , JY9810_FallingSlope = 0x1 }
enum | JY9810_AnalogTriggerSource { JY9810_Channel_0 = 0 , JY9810_Channel_1 = 1 , JY9810_Channel_2 = 2 , JY9810_Channel_3 = 3 }
enum | JY9810_MultiChannelCompositionLogic { JY9810_Or , JY9810_And }
enum JY9810_Signal_Source {
JY9810_Signal_Constant_0 = 0 , JY9810_StartTrig = 3 , JY9810_ReferenceTrig = 4 , JY9810_Signal_PXI_Trig0 = 8 ,
JY9810_Signal_PXI_Trig1 = 9 , JY9810_Signal_PXI_Trig2 = 10 , JY9810_Signal_PXI_Trig3 = 11 , JY9810_Signal_PXI_Trig4 = 12 ,
JY9810_Signal_PXI_Trig5 = 13 , JY9810_Signal_PXI_Trig6 = 14 , JY9810_Signal_PXI_Trig7 = 15 , JY9810_Signal_PFI0 = 16 ,
JY9810_SyncSignal_In = 22
}
enum JY9810_Signal_Destination {
JY9810_SyncSignal_OUT = 0 , JY9810_StartTrig_OUT = 3 , JY9810_ReferenceTrig_OUT = 4 , JY9810_PXI_Trig0_OUT = 8 ,
JY9810_PXI_Trig1_OUT = 9 , JY9810_PXI_Trig2_OUT = 10 , JY9810_PXI_Trig3_OUT = 11 , JY9810_PXI_Trig4_OUT = 12 ,
JY9810_PXI_Trig5_OUT = 13 , JY9810_PXI_Trig6_OUT = 14 , JY9810_PXI_Trig7_OUT = 15 , JY9810_PFI0_OUT = 16
}
enum | JY9810_DeviceProperty { JY9810_Independent = 0 , JY9810_MASTER = 1 , JY9810_SLAVE = 3 }
enum JY9810_SpectrumUnitType {
JY9810_dBm = 0 , JY9810_dBFS = 1 , JY9810_dBV = 2 , JY9810_dBuV = 3 ,
JY9810_V2 = 4
}
enum JY9810_SpectrumAverageMode {
JY9810_NoAveraging = 0 , JY9810_ExponentialAverage = 1 , JY9810_PseudoPeakHold = 2 , JY9810_PeakHold = 3 ,
JY9810_LinearAverage = 4
}
enum JY9810_FFTWindowType {
JY9810_None , JY9810_Hanning , JY9810_Hamming , JY9810_Blackman_Harris ,
JY9810_Exact_Blackman , JY9810_Blackman , JY9810_Three_Term_Nuttal , JY9810_Three_Term_Blackman_Nuttal ,
JY9810_Four_Term_B_Harris , JY9810_Four_Term_Nuttal , JY9810_Four_Term_Blackman_Nuttal , JY9810_Flat_Top_95 ,
JY9810_Flat_Top_90D , JY9810_Five_Term_Least_Sidelobe , JY9810_Six_Term_Flat_Top , JY9810_Six_Term_Least_Sidelobe ,
JY9810_Seven_Term_Flat_Top , JY9810_Seven_Term_Least_Sidelobe
}
enum | JY9810_FrequencyAlignmentMode { JY9810_Center , JY9810_Lower , JY9810_Upper }

Functions

JY9810API int STDCALL | JY9810_Open (int slotNumber, JY9810_Device_Handle *hDevice)
Open the 9810 boards using the slot number or the board serial number.
JY9810API int STDCALL | JY9810_OpenByName (const char *cardName, JY9810_Device_Handle *hDevice)
Open the 9810 boards using the board alias name which is set by JYTEK utility JYDM.
JY9810API int STDCALL | JY9810_Close (JY9810_Device_Handle hDevice)
Close the board.
JY9810API int STDCALL | J9810_GetDeviceTemprature (JY9810_Device_Handle hDevice, double *temprature)
get the device temprature.
JY9810API int STDCALL | JY9810_SetDeviceReferenceClock (JY9810_Device_Handle hDevice, JY9810_ReferenceClock clockSource, double clockFrequency)
Set ReferenceClock for the device.There are three ReferenceClock, 10MHz from this device internal or 100MHz from the PXIe chassis or from Front Panel CLK_IN.
JY9810API int STDCALL | JY9810_SetDeviceProperty (JY9810_Device_Handle hDevice, JY9810_DeviceProperty deviceProperty)
Set Device Property,this API must be used in Sync function.
JY9810API int STDCALL | JY9810_SignalRouting (JY9810_Device_Handle hDevice, JY9810_Signal_Source sourceSignal, JY9810_Signal_Destination destination)
Route a singal from source to destination.
JY9810API int STDCALL | JY9810_DisconnectSignalRouting (JY9810_Device_Handle hDevice, JY9810_Signal_Source sourceSignal, JY9810_Signal_Destination destination)
Disconnect an established routing.
JY9810API int STDCALL | JY9810_DisableCalibration (JY9810_Device_Handle hDevice, bool disable)
Disable AI calibration coefficient, default false.
JY9810API int STDCALL | JY9810_SetDeviceStatusLed (JY9810_Device_Handle hDevice, bool enable, unsigned int frequency)
Control Front Panel Status Led.
JY9810API int STDCALL | JY9810_GetDeviceID (JY9810_Device_Handle hDevice, int *deviceID)
Obtain the board ID.
JY9810API int STDCALL | JY9810_GetDeviceSerialNumber (JY9810_Device_Handle hDevice, char *serialNumber, int length)
Obtain the device serialNumber.
JY9810API int STDCALL | JY9810_AI_EnableChannel (JY9810_Device_Handle hDevice, unsigned int channelCount, unsigned char *channels, double *lowRegion, double *highRegion, JY9810_Coupling *coupling, JY9810_Impedance *impedance)
Enable AI channels.
JY9810API int STDCALL | JY9810_AI_SetSampleClock (JY9810_Device_Handle hDevice, JY9810_SampleClockSource clockSource, double externalSampelRate)
config PXIe9810 sample clock, Sample Clock Source is defined by enum JY9810_SampleClockSource.
JY9810API int STDCALL | JY9810_AI_SetSampleClockEx (JY9810_Device_Handle hDevice, JY9810_SampleClockSource clockSource, JY9810_QuasiClockTerminal clockTerminal, double externalSampelRate)
config PXIe9818 sample clock, Sample Clock Source is defined by enum JY9818_SampleClockSource.
JY9810API int STDCALL | JY9810_AI_SetSampleRate (JY9810_Device_Handle hDevice, double sampleRate, double *actualSampleRate)
Set sampling rate.
JY9810API int STDCALL | JY9810_AI_DisableTriggerDelay (JY9810_Device_Handle hDevice, bool disable)
Disable Trigger Delay.
JY9810API int STDCALL | JY9810_AI_DisableMultiCardTriggerSync (JY9810_Device_Handle hDevice, bool disable)
Disable Multi Card Trigger Sync.
JY9810API int STDCALL | JY9810_AI_SetStartTriggerType (JY9810_Device_Handle hDevice, JY9810_TriggerType triggerType)
Set AI start trigger type,the triggerType is defined by enum JY9810_TriggerType.
JY9810API int STDCALL | JY9810_AI_SetDigitalStartTrigger (JY9810_Device_Handle hDevice, JY9810_DigitalTriggerSource triggerSource, JY9810_DigitalTriggerEdge triggerEdge)
Set AI digital start trigger,the triggerSource is defined by enum JY9810_DigitalTriggerSource, the triggerEdge is defined by enum JY9810_DigitalTriggerEdge.
JY9810API int STDCALL | JY9810_AI_SetAnalogWindowStartTrigger (JY9810_Device_Handle hDevice, JY9810_AnalogTriggerSource triggerSource, JY9810_AnalogWindowCondition triggerCondition, double highThreshold, double lowThreshold)
Set AI analog window start trigger,the triggerSource is defined by enum JY9810_AnalogTriggerSource, the triggerCondition is defined by enum JY9810_AnalogWindowCondition.
JY9810API int STDCALL | JY9810_AI_SetAnalogHysteresisStartTrigger (JY9810_Device_Handle hDevice, JY9810_AnalogTriggerSource triggerSource, JY9810_AnalogTriggerEdge triggerEdge, double highThreshold, double lowThreshold)
Set AI analog hysteresis start trigger,the triggerSource is defined by enum JY9810_AnalogTriggerSource, the triggerEdge is defined by enum JY9810_AnalogTriggerEdge.
JY9810API int STDCALL | JY9810_AI_SetAnalogEdgeStartTrigger (JY9810_Device_Handle hDevice, JY9810_AnalogTriggerSource triggerSource, JY9810_AnalogTriggerEdge triggerEdge, double threshold)
Set AI analog edge window start trigger,the triggerSource is defined by enum JY9810_AnalogTriggerSource, the triggerEdge is defined by enum JY9810_AnalogTriggerEdge.
JY9810API int STDCALL | JY9810_AI_SetReferenceTriggerType (JY9810_Device_Handle hDevice, JY9810_TriggerType triggerType)
Set AI reference trigger type,the triggerType is defined by enum JY9810_TriggerType.
JY9810API int STDCALL | JY9810_AI_SetDigitalReferenceTrigger (JY9810_Device_Handle hDevice, JY9810_DigitalTriggerSource triggerSource, JY9810_DigitalTriggerEdge triggerEdge)
Set AI digital reference trigger.the triggerSource is defined by enum JY9810_DigitalTriggerSource, the triggerEdge is defined by enum JY9810_DigitalTriggerEdge.
JY9810API int STDCALL | JY9810_AI_SetAnalogWindowReferenceTrigger (JY9810_Device_Handle hDevice, JY9810_AnalogTriggerSource triggerSource, JY9810_AnalogWindowCondition triggerCondition, double highThreshold, double lowThreshold)
Set AI analog reference trigger,the triggerSource is defined by enum JY9810_AnalogTriggerSource, the triggerCondition is defined by enum JY9810_AnalogTriggerCondition.
JY9810API int STDCALL | JY9810_AI_SetAnalogHysteresisReferenceTrigger (JY9810_Device_Handle hDevice, JY9810_AnalogTriggerSource triggerSource, JY9810_AnalogTriggerEdge triggerEdge, double highThreshold, double lowThreshold)
Set AI analog hysteresis reference trigger,the triggerSource is defined by enum JY9810_AnalogTriggerSource, the triggerEdge is defined by enum JY9810_AnalogTriggerEdge.
JY9810API int STDCALL | JY9810_AI_SetAnalogEdgeReferenceTrigger (JY9810_Device_Handle hDevice, JY9810_AnalogTriggerSource triggerSource, JY9810_AnalogTriggerEdge triggerEdge, double threshold)
Set AI analog edge window reference trigger,the triggerSource is defined by enum JY9810_AnalogTriggerSource, the triggerEdge is defined by enum JY9810_AnalogTriggerEdge.
JY9810API int STDCALL | JY9810_AI_SetAnalogTriggerMultiChannelMode (JY9810_Device_Handle hDevice, bool enableMultiChannelTriggerMode, JY9810_MultiChannelCompositionLogic resultLogic)
Enable the trigger mode for multiple channels.
JY9810API int STDCALL | JY9810_AI_SendSoftTrigger (JY9810_Device_Handle hDevice, JY9810_TriggerMode triggermode)
Send the software trigger signal for AI.
JY9810API int STDCALL | JY9810_AI_SetReTriggerCount (JY9810_Device_Handle hDevice, unsigned long long reTriggerCount)
Set AI retrigger count.
JY9810API int STDCALL | JY9810_AI_SetMode (JY9810_Device_Handle hDevice, JY9810_SampleMode acquisitionMode)
Set AI sampling mode.
JY9810API int STDCALL | JY9810_AI_SetPreTriggerSamples (JY9810_Device_Handle hDevice, unsigned int preTriggerSamples)
Set AI pretrigger samples, the samples must greater than 0.
JY9810API int STDCALL | JY9810_AI_SetSamplesToAcquire (JY9810_Device_Handle hDevice, UINT64 samplesToAcquire)
Set AI samples to acquire for each channel in finite mode.The samples range is 1 to 256M samples / channelCount.
JY9810API int STDCALL | JY9810_AI_CommitPLLConfiguration (JY9810_Device_Handle hDevice)
commit the PLL configuration, configure sync if needed
JY9810API int STDCALL | JY9810_AI_SetMovingAverage (JY9810_Device_Handle hDevice, int averageNum)
Moving Average configuration, 1-128.
JY9810API int STDCALL | JY9810_AI_SetDownSample (JY9810_Device_Handle hDevice, int downSample)
设置内部的down sample 即抽点功能
JY9810API int STDCALL | JY9810_AI_SetCIC (JY9810_Device_Handle hDevice, int cic1Div, int cic2Div)
设置2 个串联 CIC的抽取速率 有效范围4-32，0，1 对应不启用CIC
JY9810API int STDCALL | JY9810_AI_Start (JY9810_Device_Handle hDevice)
Start AI acquisition.
JY9810API int STDCALL | JY9810_AI_Stop (JY9810_Device_Handle hDevice)
Stop AI acquisition.
JY9810API int STDCALL | JY9810_AI_CheckBufferStatus (JY9810_Device_Handle hDevice, UINT64 *avaliableSamples, UINT64 *transferedSamples, bool *overrun)
Check AI device buffer status.
JY9810API int STDCALL | JY9810_AI_ReadStreamData (JY9810_Device_Handle hDevice, unsigned char *dataBuffer, unsigned int dataLength, int timeout, unsigned int *actualReadLength)
Read AI raw data to user defined data buffer.
JY9810API int STDCALL | JY9810_AI_ReadRawData (JY9810_Device_Handle hDevice, short *dataBuffer, unsigned int dataLength, int timeout, unsigned int *actualReadLength)
Read AI raw data to user defined data buffer.
JY9810API int STDCALL | JY9810_AI_ReadData (JY9810_Device_Handle hDevice, double *dataBuffer, int dataLength, int timeout, unsigned int *actualReadLength)
Read AI data to user defined data buffer.
JY9810API int STDCALL | JY9810_AI_ScaleData (JY9810_Device_Handle hDevice, int channelCount, short *rawData, double *scaleData, int dataLength)
Covert raw data to physical data.
JY9810API int STDCALL | JY9810_AI_FFT_Start (JY9810_Device_Handle hDevice)
Start AI acquisition.
JY9810API int STDCALL | JY9810_AI_FFT_Stop (JY9810_Device_Handle hDevice)
Stop AI acquisition.
JY9810API int STDCALL | JY9810_AI_FFT_SendSoftTrigger (JY9810_Device_Handle hDevice)
Send soft trigger.
JY9810API int STDCALL | JY9810_AI_FFT_ConfigSpectrumParam (JY9810_Device_Handle hDevice, double centerFrequency, JY9810_FrequencyAlignmentMode freAlignmentMode, double expectBandwidth, double expectNumOfSpectralLines, JY9810_FFTWindowType windowType, JY9810_SpectrumUnitType uintType, bool isPSD)
Config spectrum param.
JY9810API int STDCALL | JY9810_AI_FFT_ConfigSpectrumAverageParam (JY9810_Device_Handle hDevice, JY9810_SpectrumAverageMode averageMode, int averageSize, double timeConstant)
Config Spectrum Average param.
JY9810API int STDCALL | JY9810_AI_FFT_GetSpectralInformation (JY9810_Device_Handle hDevice, JY9810_SpectralInformation *spectralInformation)
Config Spectrum Average param.
JY9810API int STDCALL | JY9810_AI_FFT_ReadData (JY9810_Device_Handle hDevice, float *dataBuffer, unsigned int samplesToRead, int timeout, unsigned int *actualSamples)
Read AI data to user defined data buffer.
JY9810API int STDCALL | JY9810_AI_FFT_CheckBufferStatus (JY9810_Device_Handle hDevice, UINT64 *avaliableSamples, UINT64 *transferedSamples, bool *overrun)
Check AI device buffer status.

Typedef Documentation

◆ JY9810_Device_Handle

typedef void* JY9810_Device_Handle

Windows.

Linux

◆ UINT64

typedef unsigned long long UINT64

Enumeration Type Documentation

◆ JY9810_AnalogTriggerEdge

enum JY9810_AnalogTriggerEdge
Enumerator
JY9810_RisingSlope | Rsing edge for digital trigger.
JY9810_FallingSlope | Falling edge for digital trigger.

◆ JY9810_AnalogTriggerSource

enum JY9810_AnalogTriggerSource
Enumerator
JY9810_Channel_0 | AI Channel 0 as analog trigger source.
JY9810_Channel_1 | AI Channel 1 as analog trigger source.
JY9810_Channel_2 | AI Channel 2 as analog trigger source.
JY9810_Channel_3 | AI Channel 3 as analog trigger source.

◆ JY9810_AnalogWindowCondition

enum JY9810_AnalogWindowCondition
Enumerator
JY9810_Entering | Analog trigger condition is RisingHysteresis.
JY9810_Leaving | Analog trigger condition is FallingHysteresis.

◆ JY9810_Coupling

enum JY9810_Coupling
Enumerator
JY9810_Coupling_DC | DC Coupling.
JY9810_Coupling_AC | AC Coupling.

◆ JY9810_DeviceProperty

enum JY9810_DeviceProperty
Enumerator
JY9810_Independent | Device as independent.
JY9810_MASTER | Device as master.
JY9810_SLAVE | Device as slave.

◆ JY9810_DigitalTriggerEdge

enum JY9810_DigitalTriggerEdge
Enumerator
JY9810_Rising | Rsing edge for digital trigger.
JY9810_Falling | Falling edge for digital trigger.

◆ JY9810_DigitalTriggerSource

enum JY9810_DigitalTriggerSource
Enumerator
JY9810_PXI_Trig0 | PXI_Trig0 as the digital trigger source.
JY9810_PXI_Trig1 | PXI_Trig1 as the digital trigger source.
JY9810_PXI_Trig2 | PXI_Trig2 as the digital trigger source.
JY9810_PXI_Trig3 | PXI_Trig3 as the digital trigger source.
JY9810_PXI_Trig4 | PXI_Trig4 as the digital trigger source.
JY9810_PXI_Trig5 | PXI_Trig5 as the digital trigger source.
JY9810_PXI_Trig6 | PXI_Trig6 as the digital trigger source.
JY9810_PXI_Trig7 | PXI_Trig7 as the digital trigger source.
JY9810_PFI_0 | Front Panel TRG_IN as the digital trigger source.
JY9810_PXIe_DStarB | PXIe_DStarB as the digital trigger source.
JY9810_PXIe_DStarC | PXIe_DStarC as the digital trigger source.

◆ JY9810_FFTWindowType

enum JY9810_FFTWindowType
Enumerator
JY9810_None |
JY9810_Hanning |
JY9810_Hamming | Hanning (2-Term)
JY9810_Blackman_Harris | Hamming (2-Term)
JY9810_Exact_Blackman | Blackman Harris (3-Term)
JY9810_Blackman | Exact Blackman (3-Term)
JY9810_Three_Term_Nuttal | Blackman (3-Term)
JY9810_Three_Term_Blackman_Nuttal | 3_Term_Nuttal(3-Term with Continous First Derivative /Nuttal3a)
JY9810_Four_Term_B_Harris | 3_Term_Blackman_Nuttal(3-Term Minimum)
JY9810_Four_Term_Nuttal | 4 Term B-Harris
JY9810_Four_Term_Blackman_Nuttal | 4_Term_Nuttal(4-Term with Continous First Derivative /Nuttal4b)
JY9810_Flat_Top_95 | 4_Term_Blackman_Nuttal(4-Term Minimum)
JY9810_Flat_Top_90D | 5 - Term Flat Top(HFT95), the highest sidelobe is −95.0dB, located at f = ±7.49 bins.
JY9810_Five_Term_Least_Sidelobe | 5-Term Flat Top(HFT90D),the highest sidelobe is −90.2dB, located at f = ±5.58 bins
JY9810_Six_Term_Flat_Top | 5_Term_Least_Sidelobe(Low Sidelobe)
JY9810_Six_Term_Least_Sidelobe | 6_Term_Flat_Top(HFT116D),the highest sidelobe is −116.8dB, located at f = ±7.52 bins
JY9810_Seven_Term_Flat_Top | 6_Term_Least_Sidelobe
JY9810_Seven_Term_Least_Sidelobe | 7_Term_Flat_Top(HFT144D),the highest sidelobe is −144.1dB, located at f = ±7.07 bins.

◆ JY9810_FrequencyAlignmentMode

enum JY9810_FrequencyAlignmentMode
Enumerator
JY9810_Center
JY9810_Lower
JY9810_Upper

◆ JY9810_Impedance

enum JY9810_Impedance
Enumerator
JY9810_1M_ohm | 1M ohm
JY9810_50_ohm | 50 ohm

◆ JY9810_MultiChannelCompositionLogic

enum JY9810_MultiChannelCompositionLogic
Enumerator
JY9810_Or | Multichannel result take or.
JY9810_And | Multichannel results take and.

◆ JY9810_QuasiClockTerminal

enum JY9810_QuasiClockTerminal
Enumerator
JY9818_QuasiClock_AnalogTrigger | Analog Trigger signal as the Quasiclock terminal.
JY9818_QuasiClock_PXI_Trig0 | PXI_Trig0 as the Quasiclock terminal.
JY9818_QuasiClock_PXI_Trig1 | PXI_Trig1 as the Quasiclock terminal.
JY9818_QuasiClock_PXI_Trig2 | PXI_Trig2 as the Quasiclock terminal.
JY9818_QuasiClock_PXI_Trig3 | PXI_Trig3 as the Quasiclock terminal.
JY9818_QuasiClock_PXI_Trig4 | PXI_Trig4 as the Quasiclock terminal.
JY9818_QuasiClock_PXI_Trig5 | PXI_Trig5 as the Quasiclock terminal.
JY9818_QuasiClock_PXI_Trig6 | PXI_Trig6 as the Quasiclock terminal.
JY9818_QuasiClock_PXI_Trig7 | PXI_Trig7 as the Quasiclock terminal.
JY9818_QuasiClock_PFI0 | PFI0 as the the Quasiclock terminal.
JY9818_QuasiClock_PXIe_DStarB | PXIe_DStarB as the the Quasiclock terminal.
JY9818_QuasiClock_PXIe_DStarC | PXIe_DStarC as the the Quasiclock terminal.

◆ JY9810_ReferenceClock

enum JY9810_ReferenceClock
Enumerator
JY9810_Internal | The onboard 10 MHz as JY9810_ReferenceClock Source.
JY9810_Front_Panel_Clock_In | The CLOCK_IN as JY9810_ReferenceClock Source.
JY9810_PXIe_Clk100 | The PXIe chassis 100MHz as JY9810_ReferenceClock Source.

◆ JY9810_SampleClockSource

enum JY9810_SampleClockSource
Enumerator
JY9810_InternalClock | Internal Clock Source.
JY9810_ExternalClock | External Clock Source.
JY9810_QuasiExternelClock | QuasiExternel Clock Source, sample on the QuasiExternel clock source rising edge.

◆ JY9810_SampleMode

enum JY9810_SampleMode
Enumerator
JY9810_Finite | AI Finite mode.
JY9810_Continuous | AI Continuous mode.

◆ JY9810_Signal_Destination

enum JY9810_Signal_Destination
Enumerator
JY9810_SyncSignal_OUT |
JY9810_StartTrig_OUT | Pulse Sync as the signal desition to rout. StartTrig as the signal desition to rout.
JY9810_ReferenceTrig_OUT | ReferenceTrig as the signal desition to rout.
JY9810_PXI_Trig0_OUT | PXITrig0 as the signal desition to rout.
JY9810_PXI_Trig1_OUT | PXITrig1 as the signal desition to rout.
JY9810_PXI_Trig2_OUT | PXITrig2 as the signal desition to rout.
JY9810_PXI_Trig3_OUT | PXITrig3 as the signal desition to rout.
JY9810_PXI_Trig4_OUT | PXITrig4 as the signal desition to rout.
JY9810_PXI_Trig5_OUT | PXITrig5 as the signal desition to rout.
JY9810_PXI_Trig6_OUT | PXITrig6 as the signal desition to rout.
JY9810_PXI_Trig7_OUT | PXITrig7 as the signal desition to rout.
JY9810_PFI0_OUT | PFI0 as the signal desition to rout.

◆ JY9810_Signal_Source

enum JY9810_Signal_Source
Enumerator
JY9810_Signal_Constant_0 | Constant_0 as the source signal to rout.
JY9810_StartTrig | StartTrig as the source signal to rout.
JY9810_ReferenceTrig | ReferenceTrig as the source signal to rout.
JY9810_Signal_PXI_Trig0 | PXI_Trig0 as the source signal to rout.
JY9810_Signal_PXI_Trig1 | PXI_Trig1 as the source signal to rout.
JY9810_Signal_PXI_Trig2 | PXI_Trig2 as the source signal to rout.
JY9810_Signal_PXI_Trig3 | PXI_Trig3 as the source signal to rout.
JY9810_Signal_PXI_Trig4 | PXI_Trig4 as the source signal to rout.
JY9810_Signal_PXI_Trig5 | PXI_Trig5 as the source signal to rout.
JY9810_Signal_PXI_Trig6 | PXI_Trig6 as the source signal to rout.
JY9810_Signal_PXI_Trig7 | PXI_Trig7 as the source signal to rout.
JY9810_Signal_PFI0 | PFI0 as the source signal to rout.
JY9810_SyncSignal_In |

◆ JY9810_SpectrumAverageMode

enum JY9810_SpectrumAverageMode
Enumerator
JY9810_NoAveraging
JY9810_ExponentialAverage
JY9810_PseudoPeakHold
JY9810_PeakHold
JY9810_LinearAverage

◆ JY9810_SpectrumUnitType

enum JY9810_SpectrumUnitType
Enumerator
JY9810_dBm | dBm
JY9810_dBFS | dBFS
JY9810_dBV | dBV
JY9810_dBuV | dBuV
JY9810_V2 |

◆ JY9810_TriggerMode

enum JY9810_TriggerMode
Enumerator
JY9810_StartTrigger | Start trigger mode.
JY9810_ReferenceTrigger | Reference trigger mode.

◆ JY9810_TriggerType

enum JY9810_TriggerType
Enumerator
JY9810_Immediately | AI Immediately trigger.
JY9810_Software | AI Soft trigger.
JY9810_Digital | AI Digital trigger.
JY9810_Analog | AI Analog trigger.

Function Documentation

◆ J9810_GetDeviceTemprature()

JY9810API int STDCALL J9810_GetDeviceTemprature | ( | JY9810_Device_Handle | hDevice,
 |  | double * | temprature )

get the device temprature.

Parameters
hDevice | device handle
temprature | device temprature
Returns
0 if success or other error code

◆ JY9810_AI_CheckBufferStatus()

JY9810API int STDCALL JY9810_AI_CheckBufferStatus | ( | JY9810_Device_Handle | hDevice,
 |  | UINT64 * | avaliableSamples,
 |  | UINT64 * | transferedSamples,
 |  | bool * | overrun )

Check AI device buffer status.

Parameters
hDevice | device handle
avaliableSamples | number of samples per channel in the device buffer
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY9810_AI_CommitPLLConfiguration()

JY9810API int STDCALL JY9810_AI_CommitPLLConfiguration ( JY9810_Device_Handle hDevice )

commit the PLL configuration, configure sync if needed

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY9810_AI_DisableMultiCardTriggerSync()

JY9810API int STDCALL JY9810_AI_DisableMultiCardTriggerSync | ( | JY9810_Device_Handle | hDevice,
 |  | bool | disable )

Disable Multi Card Trigger Sync.

Parameters
hDevice | device handle
disable | diable the trigger delay or not
Returns
0 if success or other error code

◆ JY9810_AI_DisableTriggerDelay()

JY9810API int STDCALL JY9810_AI_DisableTriggerDelay | ( | JY9810_Device_Handle | hDevice,
 |  | bool | disable )

Disable Trigger Delay.

Parameters
hDevice | device handle
disable | diable the trigger delay or not
Returns
0 if success or other error code

◆ JY9810_AI_EnableChannel()

JY9810API int STDCALL JY9810_AI_EnableChannel | ( | JY9810_Device_Handle | hDevice,
 |  | unsigned int | channelCount,
 |  | unsigned char * | channels,
 |  | double * | lowRegion,
 |  | double * | highRegion,
 |  | JY9810_Coupling * | coupling,
 |  | JY9810_Impedance * | impedance )

Enable AI channels.

Each channel can be independently configured

Parameters
hDevice | device handle
channelCount | number of channels to be enabled
channels | array[channelCount] containing channel IDs
lowRegion | array[channelCount] of lower limit numbers for each channel,typically in volts.
highRegion | array[channelCount] of higher limit numbers for each channel, typcially in volts.
lowRegion | array[channelCount] of impedance.
highRegion | array[channelCount] of coupling.
Returns
0 if success or other error code

◆ JY9810_AI_FFT_CheckBufferStatus()

JY9810API int STDCALL JY9810_AI_FFT_CheckBufferStatus | ( | JY9810_Device_Handle | hDevice,
 |  | UINT64 * | avaliableSamples,
 |  | UINT64 * | transferedSamples,
 |  | bool * | overrun )

Check AI device buffer status.

Parameters
hDevice | device handle
avaliableSamples | number of samples per channel in the device buffer
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY9810_AI_FFT_ConfigSpectrumAverageParam()

JY9810API int STDCALL JY9810_AI_FFT_ConfigSpectrumAverageParam | ( | JY9810_Device_Handle | hDevice,
 |  | JY9810_SpectrumAverageMode | averageMode,
 |  | int | averageSize,
 |  | double | timeConstant )

Config Spectrum Average param.

Parameters
hDevice | device handle
averageMode | Spectrum averageing mode.
averageSize | Average Size.only valid in averageMode is JY9810_LinearAverage or JY9810_PeakHold
timeConstant | Exponential weighting time constant, (0, 1], the α in formula: Y[n] = α* x[n] + (1 - α) * Y[n - 1], only valid in averageMode is JY9810_ExponentialAverage or JY9810_PseudoPeakHold
Returns
0 if success or other error code

◆ JY9810_AI_FFT_ConfigSpectrumParam()

JY9810API int STDCALL JY9810_AI_FFT_ConfigSpectrumParam | ( | JY9810_Device_Handle | hDevice,
 |  | double | centerFrequency,
 |  | JY9810_FrequencyAlignmentMode | freAlignmentMode,
 |  | double | expectBandwidth,
 |  | double | expectNumOfSpectralLines,
 |  | JY9810_FFTWindowType | windowType,
 |  | JY9810_SpectrumUnitType | uintType,
 |  | bool | isPSD )

Config spectrum param.

Parameters
hDevice | device handle
centerFrequency | centerFrequency.
freAlignmentMode | FFT Frequency Alignment Mode
expectBandwidth | expect bandwidth, Hz
expectNumOfSpectralLines | expect number of spectral lines within bandwidth, Hz.
windowType | FFT window type.
uintType | Unit type.
isPSD | whether convert to Power Spectral Density.
Returns
0 if success or other error code

◆ JY9810_AI_FFT_GetSpectralInformation()

JY9810API int STDCALL JY9810_AI_FFT_GetSpectralInformation | ( | JY9810_Device_Handle | hDevice,
 |  | JY9810_SpectralInformation * | spectralInformation )

Config Spectrum Average param.

When after JY9810_AI_FFT_Start used.

Parameters
hDevice | device handle
spectralInformation | Spectral Information.
Returns
0 if success or other error code

◆ JY9810_AI_FFT_ReadData()

JY9810API int STDCALL JY9810_AI_FFT_ReadData | ( | JY9810_Device_Handle | hDevice,
 |  | float * | dataBuffer,
 |  | unsigned int | samplesToRead,
 |  | int | timeout,
 |  | unsigned int * | actualSamples )

Read AI data to user defined data buffer.

For the multi-channel acquisition, the data is interleaved in the order defined by JY9810_AI_EnableChannel.

Parameters
hDevice | device handle
dataBuffer | user buffer,the buffer size must be greater than or equal to dataLength*channelCount.
dataLength | number of samples per channel
timeOut | timeout time in microsecond
actualReadLength | returns the number of samples per channel actually read
Returns
0 if success or other error code

◆ JY9810_AI_FFT_SendSoftTrigger()

JY9810API int STDCALL JY9810_AI_FFT_SendSoftTrigger ( JY9810_Device_Handle hDevice )

Send soft trigger.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY9810_AI_FFT_Start()

JY9810API int STDCALL JY9810_AI_FFT_Start ( JY9810_Device_Handle hDevice )

Start AI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY9810_AI_FFT_Stop()

JY9810API int STDCALL JY9810_AI_FFT_Stop ( JY9810_Device_Handle hDevice )

Stop AI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY9810_AI_ReadData()

JY9810API int STDCALL JY9810_AI_ReadData | ( | JY9810_Device_Handle | hDevice,
 |  | double * | dataBuffer,
 |  | int | dataLength,
 |  | int | timeout,
 |  | unsigned int * | actualReadLength )

Read AI data to user defined data buffer.

For the multi-channel acquisition, the data is interleaved in the order defined by JY9810_AI_EnableChannel.

Parameters
hDevice | device handle
dataBuffer | user buffer,the buffer size must be greater than or equal to dataLength*channelCount.
dataLength | number of samples per channel
timeOut | timeout time in microsecond
actualReadLength | returns the number of samples per channel actually read
Returns
0 if success or other error code

◆ JY9810_AI_ReadRawData()

JY9810API int STDCALL JY9810_AI_ReadRawData | ( | JY9810_Device_Handle | hDevice,
 |  | short * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeout,
 |  | unsigned int * | actualReadLength )

Read AI raw data to user defined data buffer.

For the multi-channel acquisition, the data is interleaved in the order defined by JY9810_AI_EnableChannel.

Parameters
hDevice | device handle
dataBuffer | user buffer, The size of dataBuffer must be greater than or equal to dataLength*channelCount.
dataLength | number of samples per channel
timeOut | timeout time in microsecond
actualReadLength | return the number of samples per channel actually read
Returns
0 if success or other error code

◆ JY9810_AI_ReadStreamData()

JY9810API int STDCALL JY9810_AI_ReadStreamData | ( | JY9810_Device_Handle | hDevice,
 |  | unsigned char * | dataBuffer,
 |  | unsigned int | dataLength,
 |  | int | timeout,
 |  | unsigned int * | actualReadLength )

Read AI raw data to user defined data buffer.

Used for record mode. data type : char

Parameters
hDevice | device handle
dataBuffer | user buffer, The size of dataBuffer must be greater than or equal to dataLength*channelCount.
dataLength | total number of bytes to read
timeOut | timeout time in microsecond
actualReadLength | return the number of samples per channel actually read
Returns
0 if success or other error code

◆ JY9810_AI_ScaleData()

JY9810API int STDCALL JY9810_AI_ScaleData | ( | JY9810_Device_Handle | hDevice,
 |  | int | channelCount,
 |  | short * | rawData,
 |  | double * | scaleData,
 |  | int | dataLength )

Covert raw data to physical data.

Parameters
hDevice | Device handle
channel | channel count
rawData | raw short data
scaleData | scaled data , double
dataLength | number of samples
Returns
0 if success or other error code

◆ JY9810_AI_SendSoftTrigger()

JY9810API int STDCALL JY9810_AI_SendSoftTrigger | ( | JY9810_Device_Handle | hDevice,
 |  | JY9810_TriggerMode | triggermode )

Send the software trigger signal for AI.

Parameters
hDevice | device handle
triggerMode | software trigger mode. Options: start trigger or reference trigger.
Returns
0 if success or other error code

◆ JY9810_AI_SetAnalogEdgeReferenceTrigger()

JY9810API int STDCALL JY9810_AI_SetAnalogEdgeReferenceTrigger | ( | JY9810_Device_Handle | hDevice,
 |  | JY9810_AnalogTriggerSource | triggerSource,
 |  | JY9810_AnalogTriggerEdge | triggerEdge,
 |  | double | threshold )

Set AI analog edge window reference trigger,the triggerSource is defined by enum JY9810_AnalogTriggerSource, the triggerEdge is defined by enum JY9810_AnalogTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source,0-3<
triggerCondition | AI analog trigger conditions
threshold | threshold
Returns
0 if success or other error code

◆ JY9810_AI_SetAnalogEdgeStartTrigger()

JY9810API int STDCALL JY9810_AI_SetAnalogEdgeStartTrigger | ( | JY9810_Device_Handle | hDevice,
 |  | JY9810_AnalogTriggerSource | triggerSource,
 |  | JY9810_AnalogTriggerEdge | triggerEdge,
 |  | double | threshold )

Set AI analog edge window start trigger,the triggerSource is defined by enum JY9810_AnalogTriggerSource, the triggerEdge is defined by enum JY9810_AnalogTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source,0-3<
triggerCondition | AI analog trigger conditions
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY9810_AI_SetAnalogHysteresisReferenceTrigger()

JY9810API int STDCALL JY9810_AI_SetAnalogHysteresisReferenceTrigger | ( | JY9810_Device_Handle | hDevice,
 |  | JY9810_AnalogTriggerSource | triggerSource,
 |  | JY9810_AnalogTriggerEdge | triggerEdge,
 |  | double | highThreshold,
 |  | double | lowThreshold )

Set AI analog hysteresis reference trigger,the triggerSource is defined by enum JY9810_AnalogTriggerSource, the triggerEdge is defined by enum JY9810_AnalogTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source,0-3<
triggerCondition | AI analog trigger conditions
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY9810_AI_SetAnalogHysteresisStartTrigger()

JY9810API int STDCALL JY9810_AI_SetAnalogHysteresisStartTrigger | ( | JY9810_Device_Handle | hDevice,
 |  | JY9810_AnalogTriggerSource | triggerSource,
 |  | JY9810_AnalogTriggerEdge | triggerEdge,
 |  | double | highThreshold,
 |  | double | lowThreshold )

Set AI analog hysteresis start trigger,the triggerSource is defined by enum JY9810_AnalogTriggerSource, the triggerEdge is defined by enum JY9810_AnalogTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source,0-3<
triggerCondition | AI analog trigger conditions
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY9810_AI_SetAnalogTriggerMultiChannelMode()

JY9810API int STDCALL JY9810_AI_SetAnalogTriggerMultiChannelMode | ( | JY9810_Device_Handle | hDevice,
 |  | bool | enableMultiChannelTriggerMode,
 |  | JY9810_MultiChannelCompositionLogic | resultLogic )

Enable the trigger mode for multiple channels.

If this mode is enabled, multiple channels participate in trigger comparison. If this mode is disabled, single channel participates in trigger comparison.

Parameters
hDevice | device handle
enableMultiChannelTriggerMode | Enable the trigger mode for multiple channels<
resultLogic | Multichannel composition logic, and / or. defalut or.
Returns
0 if success or other error code

◆ JY9810_AI_SetAnalogWindowReferenceTrigger()

JY9810API int STDCALL JY9810_AI_SetAnalogWindowReferenceTrigger | ( | JY9810_Device_Handle | hDevice,
 |  | JY9810_AnalogTriggerSource | triggerSource,
 |  | JY9810_AnalogWindowCondition | triggerCondition,
 |  | double | highThreshold,
 |  | double | lowThreshold )

Set AI analog reference trigger,the triggerSource is defined by enum JY9810_AnalogTriggerSource, the triggerCondition is defined by enum JY9810_AnalogTriggerCondition.

Parameters
hDevice | device handle
triggerSource | AI reference trigger source,0-3<
triggerCondition | AI analog trigger conditions
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY9810_AI_SetAnalogWindowStartTrigger()

JY9810API int STDCALL JY9810_AI_SetAnalogWindowStartTrigger | ( | JY9810_Device_Handle | hDevice,
 |  | JY9810_AnalogTriggerSource | triggerSource,
 |  | JY9810_AnalogWindowCondition | triggerCondition,
 |  | double | highThreshold,
 |  | double | lowThreshold )

Set AI analog window start trigger,the triggerSource is defined by enum JY9810_AnalogTriggerSource, the triggerCondition is defined by enum JY9810_AnalogWindowCondition.

Parameters
hDevice | device handle
triggerSource | AI analog start trigger source,0-3
triggerCondition | AI analog trigger conditions
highThreshold | high threshold
lowThreshold | low threshold
Returns
0 if success or other error code

◆ JY9810_AI_SetCIC()

JY9810API int STDCALL JY9810_AI_SetCIC | ( | JY9810_Device_Handle | hDevice,
 |  | int | cic1Div,
 |  | int | cic2Div )

设置2 个串联 CIC的抽取速率 有效范围4-32，0，1 对应不启用CIC

Parameters
hDevice | device handle
cic1Div | cic1 的抽取设置，范围 0，1 4-32
cic2Div | cic2 的抽取设置，范围 0，1 4-32
Returns
0 if success or other error code

◆ JY9810_AI_SetDigitalReferenceTrigger()

JY9810API int STDCALL JY9810_AI_SetDigitalReferenceTrigger | ( | JY9810_Device_Handle | hDevice,
 |  | JY9810_DigitalTriggerSource | triggerSource,
 |  | JY9810_DigitalTriggerEdge | triggerEdge )

Set AI digital reference trigger.the triggerSource is defined by enum JY9810_DigitalTriggerSource, the triggerEdge is defined by enum JY9810_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI reference trigger source
triggerEdge | AI reference to the trigger edge. Options: rising or falling edge
Returns
0 if success or other error code

◆ JY9810_AI_SetDigitalStartTrigger()

JY9810API int STDCALL JY9810_AI_SetDigitalStartTrigger | ( | JY9810_Device_Handle | hDevice,
 |  | JY9810_DigitalTriggerSource | triggerSource,
 |  | JY9810_DigitalTriggerEdge | triggerEdge )

Set AI digital start trigger,the triggerSource is defined by enum JY9810_DigitalTriggerSource, the triggerEdge is defined by enum JY9810_DigitalTriggerEdge.

Parameters
hDevice | device handle
triggerSource | AI digital start trigger source
triggerEdge | AI digital start trigger edge. Options: rising or falling edge
Returns
0 if success or other error code

◆ JY9810_AI_SetDownSample()

JY9810API int STDCALL JY9810_AI_SetDownSample | ( | JY9810_Device_Handle | hDevice,
 |  | int | downSample )

设置内部的down sample 即抽点功能

Parameters
hDevice | device handle
downSample | 每N个点抽取一个点输出
Returns
0 if success or other error code

◆ JY9810_AI_SetMode()

JY9810API int STDCALL JY9810_AI_SetMode | ( | JY9810_Device_Handle | hDevice,
 |  | JY9810_SampleMode | acquisitionMode )

Set AI sampling mode.

Parameters
hDevice | device handle
mode | AI sampling mode defined by enum JY9810_AI_SampleMode.
Returns
0 if success or other error code

◆ JY9810_AI_SetMovingAverage()

JY9810API int STDCALL JY9810_AI_SetMovingAverage | ( | JY9810_Device_Handle | hDevice,
 |  | int | averageNum )

Moving Average configuration, 1-128.

Parameters
hDevice | device handle
averageNum | 1-128
Returns
0 if success or other error code

◆ JY9810_AI_SetPreTriggerSamples()

JY9810API int STDCALL JY9810_AI_SetPreTriggerSamples | ( | JY9810_Device_Handle | hDevice,
 |  | unsigned int | preTriggerSamples )

Set AI pretrigger samples, the samples must greater than 0.

Parameters
hDevice | device handle
preTriggerSamples | AI pretrigger samples, valid only in reference trigger mode.
Returns
0 if success or other error code

◆ JY9810_AI_SetReferenceTriggerType()

JY9810API int STDCALL JY9810_AI_SetReferenceTriggerType | ( | JY9810_Device_Handle | hDevice,
 |  | JY9810_TriggerType | triggerType )

Set AI reference trigger type,the triggerType is defined by enum JY9810_TriggerType.

Parameters
hDevice | device handle
triggerType | AI reference trigger type.Options: immediate trigger, software trigger, digital trigger or analog trigger.
Returns
0 if success or other error code

◆ JY9810_AI_SetReTriggerCount()

JY9810API int STDCALL JY9810_AI_SetReTriggerCount | ( | JY9810_Device_Handle | hDevice,
 |  | unsigned long long | reTriggerCount )

Set AI retrigger count.

The device will be triggered reTriggerCount times.

Parameters
hDevice | device handle
reTriggerCount | AI retrigger count
Returns
0 if success or other error code

◆ JY9810_AI_SetSampleClock()

JY9810API int STDCALL JY9810_AI_SetSampleClock | ( | JY9810_Device_Handle | hDevice,
 |  | JY9810_SampleClockSource | clockSource,
 |  | double | externalSampelRate )

config PXIe9810 sample clock, Sample Clock Source is defined by enum JY9810_SampleClockSource.

if clockSource is External, the signal must connect to CLK_IN terminal.

Parameters
hDevice | device handle
clockSource | sample clock source
externalSampelRate | external sample clock rate
Returns
0 if success or other error code

◆ JY9810_AI_SetSampleClockEx()

JY9810API int STDCALL JY9810_AI_SetSampleClockEx | ( | JY9810_Device_Handle | hDevice,
 |  | JY9810_SampleClockSource | clockSource,
 |  | JY9810_QuasiClockTerminal | clockTerminal,
 |  | double | externalSampelRate )

config PXIe9818 sample clock, Sample Clock Source is defined by enum JY9818_SampleClockSource.

if clockSource is External, the signal must connect to CLK_IN terminal.

Parameters
hDevice | device handle
clockSource | sample clock source
clockTerminal | if clock source is KClock, terminal from enum JY9818_ClockTerminal
externalSampelRate | external sample clock rate
Returns
0 if success or other error code

◆ JY9810_AI_SetSampleRate()

JY9810API int STDCALL JY9810_AI_SetSampleRate | ( | JY9810_Device_Handle | hDevice,
 |  | double | sampleRate,
 |  | double * | actualSampleRate )

Set sampling rate.

The sampling rate is the same for all channels.

Parameters
hDevice | device handle
sampleRate | AI sampling rate to be set per channel
actualSampleRate | actual sampling rate set by this device,which may be different from the desired sampleRate.
Returns
0 if success or other error code

◆ JY9810_AI_SetSamplesToAcquire()

JY9810API int STDCALL JY9810_AI_SetSamplesToAcquire | ( | JY9810_Device_Handle | hDevice,
 |  | UINT64 | samplesToAcquire )

Set AI samples to acquire for each channel in finite mode.The samples range is 1 to 256M samples / channelCount.

Parameters
hDevice | device handle
sampleToAcquire | AI finite samples to acquire for each channel, samples range:1 to 256M samples / channelCount.
Returns
0 if success or other error code

◆ JY9810_AI_SetStartTriggerType()

JY9810API int STDCALL JY9810_AI_SetStartTriggerType | ( | JY9810_Device_Handle | hDevice,
 |  | JY9810_TriggerType | triggerType )

Set AI start trigger type,the triggerType is defined by enum JY9810_TriggerType.

Parameters
hDevice | device handle
triggerType | AI start trigger type. Options:immediate trigger, software trigger, digital trigger or analog trigger.
Returns
0 if success or other error code

◆ JY9810_AI_Start()

JY9810API int STDCALL JY9810_AI_Start ( JY9810_Device_Handle hDevice )

Start AI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY9810_AI_Stop()

JY9810API int STDCALL JY9810_AI_Stop ( JY9810_Device_Handle hDevice )

Stop AI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY9810_Close()

JY9810API int STDCALL JY9810_Close ( JY9810_Device_Handle hDevice )

Close the board.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY9810_DisableCalibration()

JY9810API int STDCALL JY9810_DisableCalibration | ( | JY9810_Device_Handle | hDevice,
 |  | bool | disable )

Disable AI calibration coefficient, default false.

Parameters
hDevice | device handle
DisableCalibration | true if disabled, false if not disabled.
Returns
0 if success or other error code

◆ JY9810_DisconnectSignalRouting()

JY9810API int STDCALL JY9810_DisconnectSignalRouting | ( | JY9810_Device_Handle | hDevice,
 |  | JY9810_Signal_Source | sourceSignal,
 |  | JY9810_Signal_Destination | destination )

Disconnect an established routing.

Parameters
hDevice | device handle
source | source of the signal defined by enum JY9810_Source
destination | destination of the signal defined by enum JY9810_Destination
Returns
0 if success or other error code

◆ JY9810_GetDeviceID()

JY9810API int STDCALL JY9810_GetDeviceID | ( | JY9810_Device_Handle | hDevice,
 |  | int * | deviceID )

Obtain the board ID.

The PXIe-9810 board ID is Ox9810, PCIe-9810 board ID is OxA817.

Parameters
hDevice | device handle
deviceID | board ID
Returns
0 if success or other error code

◆ JY9810_GetDeviceSerialNumber()

JY9810API int STDCALL JY9810_GetDeviceSerialNumber | ( | JY9810_Device_Handle | hDevice,
 |  | char * | serialNumber,
 |  | int | length )

Obtain the device serialNumber.

Parameters
hDevice | device handle
serialNumber | Pointer to a buffer receiving the serial number. The length of the serial number is 10.
length | serial Number length ,lenth is 10
Returns
0 if success or other error code

◆ JY9810_Open()

JY9810API int STDCALL JY9810_Open | ( | int | slotNumber,
 |  | JY9810_Device_Handle * | hDevice )

Open the 9810 boards using the slot number or the board serial number.

PXIe slot number is predefined by the PXIe chassis. PCIe slot number is defined by the DIP switch. The board serial number is defined by the system starting from 0. It's your responsibility to know the number. For a single board, the serial number is 0.

Parameters
slotNumber | slot number or board serial number
hDevice | device handle. All other functions uses hDevice to represent this device.
Returns
0 if success or other error code

◆ JY9810_OpenByName()

JY9810API int STDCALL JY9810_OpenByName | ( | const char * | cardName,
 |  | JY9810_Device_Handle * | hDevice )

Open the 9810 boards using the board alias name which is set by JYTEK utility JYDM.

You can change the name using JYDM.

Parameters
cardName | board alias name
hDevice | device handle
Returns
0 if success or other error code

◆ JY9810_SetDeviceProperty()

JY9810API int STDCALL JY9810_SetDeviceProperty | ( | JY9810_Device_Handle | hDevice,
 |  | JY9810_DeviceProperty | deviceProperty )

Set Device Property,this API must be used in Sync function.

Parameters
hDevice | device handle
deviceProperty | defined by enum JY9810_DeviceProperty
Returns
0 if success or other error code

◆ JY9810_SetDeviceReferenceClock()

JY9810API int STDCALL JY9810_SetDeviceReferenceClock | ( | JY9810_Device_Handle | hDevice,
 |  | JY9810_ReferenceClock | clockSource,
 |  | double | clockFrequency )

Set ReferenceClock for the device.There are three ReferenceClock, 10MHz from this device internal or 100MHz from the PXIe chassis or from Front Panel CLK_IN.

PCIe device not support 100MHz from the PXIe chassis .

Parameters
hDevice | device handle
clkSource | ReferenceClock source defined by enum JY9810_ReferenceClock
Returns
0 if success or other error code

◆ JY9810_SetDeviceStatusLed()

JY9810API int STDCALL JY9810_SetDeviceStatusLed | ( | JY9810_Device_Handle | hDevice,
 |  | bool | enable,
 |  | unsigned int | frequency )

Control Front Panel Status Led.

Parameters
hDevice | device handle
enable | enable front panel status led blink, true: blink, false: not blink
frequency | when enable is ture, the led blink speed by frequency define
Returns
0 if success or other error code

◆ JY9810_SignalRouting()

JY9810API int STDCALL JY9810_SignalRouting | ( | JY9810_Device_Handle | hDevice,
 |  | JY9810_Signal_Source | sourceSignal,
 |  | JY9810_Signal_Destination | destination )

Route a singal from source to destination.

Both source and destination are defined by the corresponding enum JY9810_Signal_Source and JY9810_Signal_Destination. One source signal may be routed to multiple destinations.

Parameters
hDevice | device handle
sourceSignal | source of the signal defined by enum JY9810_Source
destination | destination of the signal defined by enum JY9810_Destination
Returns
0 if success or other error code
Generated by doxygen 1.12.0


9818 C++ Programming Manual: Class List

  • Class List
  • Class Index
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
C JY9810_SpectralInformation


9818 C++ Programming Manual: Class Index

  • Class List
  • Class Index
  • Class Members
Class Index
J
J
JY9810_SpectralInformation


9818 C++ Programming Manual: D:/9818/C++ Directory Reference

  • File Members
  • 9818
  • C++
C++ Directory Reference

Files

JY9810Core.h


9818 C++ Programming Manual: D:/9818 Directory Reference

  • 9818
9818 Directory Reference

Directories

C++


9818 C++ Programming Manual: File List

File List
Here is a list of all files with brief descriptions:
[detail level 123]
▼ 9818
▼ C++
JY9810Core.h


9818 C++ Programming Manual: Class Members

  • Class List
  • Class Index
  • Class Members
  • All
  • Variables
Here is a list of all class members with links to the classes they belong to:
  • CenterFrequency : JY9810_SpectralInformation
  • ENBW : JY9810_SpectralInformation
  • FftLength : JY9810_SpectralInformation
  • FftWindowType : JY9810_SpectralInformation
  • FrequencyStart : JY9810_SpectralInformation
  • FrequencyStep : JY9810_SpectralInformation
  • IsPsd : JY9810_SpectralInformation
  • NumOfSpectralLines : JY9810_SpectralInformation
  • ResolutionBandwidth : JY9810_SpectralInformation
  • UnitType : JY9810_SpectralInformation


9818 C++ Programming Manual: Class Members - Variables

  • Class List
  • Class Index
  • Class Members
  • All
  • Variables
Here is a list of all variables with links to the classes they belong to:
  • CenterFrequency : JY9810_SpectralInformation
  • ENBW : JY9810_SpectralInformation
  • FftLength : JY9810_SpectralInformation
  • FftWindowType : JY9810_SpectralInformation
  • FrequencyStart : JY9810_SpectralInformation
  • FrequencyStep : JY9810_SpectralInformation
  • IsPsd : JY9810_SpectralInformation
  • NumOfSpectralLines : JY9810_SpectralInformation
  • ResolutionBandwidth : JY9810_SpectralInformation
  • UnitType : JY9810_SpectralInformation


9818 C++ Programming Manual: File Members

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • j
  • u
Here is a list of all file members with links to the files they belong to:

- j -

  • J9810_GetDeviceTemprature() : JY9810Core.h
  • JY9810_1M_ohm : JY9810Core.h
  • JY9810_50_ohm : JY9810Core.h
  • JY9810_AI_CheckBufferStatus() : JY9810Core.h
  • JY9810_AI_CommitPLLConfiguration() : JY9810Core.h
  • JY9810_AI_DisableMultiCardTriggerSync() : JY9810Core.h
  • JY9810_AI_DisableTriggerDelay() : JY9810Core.h
  • JY9810_AI_EnableChannel() : JY9810Core.h
  • JY9810_AI_FFT_CheckBufferStatus() : JY9810Core.h
  • JY9810_AI_FFT_ConfigSpectrumAverageParam() : JY9810Core.h
  • JY9810_AI_FFT_ConfigSpectrumParam() : JY9810Core.h
  • JY9810_AI_FFT_GetSpectralInformation() : JY9810Core.h
  • JY9810_AI_FFT_ReadData() : JY9810Core.h
  • JY9810_AI_FFT_SendSoftTrigger() : JY9810Core.h
  • JY9810_AI_FFT_Start() : JY9810Core.h
  • JY9810_AI_FFT_Stop() : JY9810Core.h
  • JY9810_AI_ReadData() : JY9810Core.h
  • JY9810_AI_ReadRawData() : JY9810Core.h
  • JY9810_AI_ReadStreamData() : JY9810Core.h
  • JY9810_AI_ScaleData() : JY9810Core.h
  • JY9810_AI_SendSoftTrigger() : JY9810Core.h
  • JY9810_AI_SetAnalogEdgeReferenceTrigger() : JY9810Core.h
  • JY9810_AI_SetAnalogEdgeStartTrigger() : JY9810Core.h
  • JY9810_AI_SetAnalogHysteresisReferenceTrigger() : JY9810Core.h
  • JY9810_AI_SetAnalogHysteresisStartTrigger() : JY9810Core.h
  • JY9810_AI_SetAnalogTriggerMultiChannelMode() : JY9810Core.h
  • JY9810_AI_SetAnalogWindowReferenceTrigger() : JY9810Core.h
  • JY9810_AI_SetAnalogWindowStartTrigger() : JY9810Core.h
  • JY9810_AI_SetCIC() : JY9810Core.h
  • JY9810_AI_SetDigitalReferenceTrigger() : JY9810Core.h
  • JY9810_AI_SetDigitalStartTrigger() : JY9810Core.h
  • JY9810_AI_SetDownSample() : JY9810Core.h
  • JY9810_AI_SetMode() : JY9810Core.h
  • JY9810_AI_SetMovingAverage() : JY9810Core.h
  • JY9810_AI_SetPreTriggerSamples() : JY9810Core.h
  • JY9810_AI_SetReferenceTriggerType() : JY9810Core.h
  • JY9810_AI_SetReTriggerCount() : JY9810Core.h
  • JY9810_AI_SetSampleClock() : JY9810Core.h
  • JY9810_AI_SetSampleClockEx() : JY9810Core.h
  • JY9810_AI_SetSampleRate() : JY9810Core.h
  • JY9810_AI_SetSamplesToAcquire() : JY9810Core.h
  • JY9810_AI_SetStartTriggerType() : JY9810Core.h
  • JY9810_AI_Start() : JY9810Core.h
  • JY9810_AI_Stop() : JY9810Core.h
  • JY9810_Analog : JY9810Core.h
  • JY9810_AnalogTriggerEdge : JY9810Core.h
  • JY9810_AnalogTriggerSource : JY9810Core.h
  • JY9810_AnalogWindowCondition : JY9810Core.h
  • JY9810_And : JY9810Core.h
  • JY9810_Blackman : JY9810Core.h
  • JY9810_Blackman_Harris : JY9810Core.h
  • JY9810_Center : JY9810Core.h
  • JY9810_Channel_0 : JY9810Core.h
  • JY9810_Channel_1 : JY9810Core.h
  • JY9810_Channel_2 : JY9810Core.h
  • JY9810_Channel_3 : JY9810Core.h
  • JY9810_Close() : JY9810Core.h
  • JY9810_Continuous : JY9810Core.h
  • JY9810_Coupling : JY9810Core.h
  • JY9810_Coupling_AC : JY9810Core.h
  • JY9810_Coupling_DC : JY9810Core.h
  • JY9810_dBFS : JY9810Core.h
  • JY9810_dBm : JY9810Core.h
  • JY9810_dBuV : JY9810Core.h
  • JY9810_dBV : JY9810Core.h
  • JY9810_Device_Handle : JY9810Core.h
  • JY9810_DeviceProperty : JY9810Core.h
  • JY9810_Digital : JY9810Core.h
  • JY9810_DigitalTriggerEdge : JY9810Core.h
  • JY9810_DigitalTriggerSource : JY9810Core.h
  • JY9810_DisableCalibration() : JY9810Core.h
  • JY9810_DisconnectSignalRouting() : JY9810Core.h
  • JY9810_Entering : JY9810Core.h
  • JY9810_Exact_Blackman : JY9810Core.h
  • JY9810_ExponentialAverage : JY9810Core.h
  • JY9810_ExternalClock : JY9810Core.h
  • JY9810_Falling : JY9810Core.h
  • JY9810_FallingSlope : JY9810Core.h
  • JY9810_FFTWindowType : JY9810Core.h
  • JY9810_Finite : JY9810Core.h
  • JY9810_Five_Term_Least_Sidelobe : JY9810Core.h
  • JY9810_Flat_Top_90D : JY9810Core.h
  • JY9810_Flat_Top_95 : JY9810Core.h
  • JY9810_Four_Term_B_Harris : JY9810Core.h
  • JY9810_Four_Term_Blackman_Nuttal : JY9810Core.h
  • JY9810_Four_Term_Nuttal : JY9810Core.h
  • JY9810_FrequencyAlignmentMode : JY9810Core.h
  • JY9810_Front_Panel_Clock_In : JY9810Core.h
  • JY9810_GetDeviceID() : JY9810Core.h
  • JY9810_GetDeviceSerialNumber() : JY9810Core.h
  • JY9810_Hamming : JY9810Core.h
  • JY9810_Hanning : JY9810Core.h
  • JY9810_Immediately : JY9810Core.h
  • JY9810_Impedance : JY9810Core.h
  • JY9810_Independent : JY9810Core.h
  • JY9810_Internal : JY9810Core.h
  • JY9810_InternalClock : JY9810Core.h
  • JY9810_Leaving : JY9810Core.h
  • JY9810_LinearAverage : JY9810Core.h
  • JY9810_Lower : JY9810Core.h
  • JY9810_MASTER : JY9810Core.h
  • JY9810_MultiChannelCompositionLogic : JY9810Core.h
  • JY9810_NoAveraging : JY9810Core.h
  • JY9810_None : JY9810Core.h
  • JY9810_Open() : JY9810Core.h
  • JY9810_OpenByName() : JY9810Core.h
  • JY9810_Or : JY9810Core.h
  • JY9810_PeakHold : JY9810Core.h
  • JY9810_PFI0_OUT : JY9810Core.h
  • JY9810_PFI_0 : JY9810Core.h
  • JY9810_PseudoPeakHold : JY9810Core.h
  • JY9810_PXI_Trig0 : JY9810Core.h
  • JY9810_PXI_Trig0_OUT : JY9810Core.h
  • JY9810_PXI_Trig1 : JY9810Core.h
  • JY9810_PXI_Trig1_OUT : JY9810Core.h
  • JY9810_PXI_Trig2 : JY9810Core.h
  • JY9810_PXI_Trig2_OUT : JY9810Core.h
  • JY9810_PXI_Trig3 : JY9810Core.h
  • JY9810_PXI_Trig3_OUT : JY9810Core.h
  • JY9810_PXI_Trig4 : JY9810Core.h
  • JY9810_PXI_Trig4_OUT : JY9810Core.h
  • JY9810_PXI_Trig5 : JY9810Core.h
  • JY9810_PXI_Trig5_OUT : JY9810Core.h
  • JY9810_PXI_Trig6 : JY9810Core.h
  • JY9810_PXI_Trig6_OUT : JY9810Core.h
  • JY9810_PXI_Trig7 : JY9810Core.h
  • JY9810_PXI_Trig7_OUT : JY9810Core.h
  • JY9810_PXIe_Clk100 : JY9810Core.h
  • JY9810_PXIe_DStarB : JY9810Core.h
  • JY9810_PXIe_DStarC : JY9810Core.h
  • JY9810_QuasiClockTerminal : JY9810Core.h
  • JY9810_QuasiExternelClock : JY9810Core.h
  • JY9810_ReferenceClock : JY9810Core.h
  • JY9810_ReferenceTrig : JY9810Core.h
  • JY9810_ReferenceTrig_OUT : JY9810Core.h
  • JY9810_ReferenceTrigger : JY9810Core.h
  • JY9810_Rising : JY9810Core.h
  • JY9810_RisingSlope : JY9810Core.h
  • JY9810_SampleClockSource : JY9810Core.h
  • JY9810_SampleMode : JY9810Core.h
  • JY9810_SetDeviceProperty() : JY9810Core.h
  • JY9810_SetDeviceReferenceClock() : JY9810Core.h
  • JY9810_SetDeviceStatusLed() : JY9810Core.h
  • JY9810_Seven_Term_Flat_Top : JY9810Core.h
  • JY9810_Seven_Term_Least_Sidelobe : JY9810Core.h
  • JY9810_Signal_Constant_0 : JY9810Core.h
  • JY9810_Signal_Destination : JY9810Core.h
  • JY9810_Signal_PFI0 : JY9810Core.h
  • JY9810_Signal_PXI_Trig0 : JY9810Core.h
  • JY9810_Signal_PXI_Trig1 : JY9810Core.h
  • JY9810_Signal_PXI_Trig2 : JY9810Core.h
  • JY9810_Signal_PXI_Trig3 : JY9810Core.h
  • JY9810_Signal_PXI_Trig4 : JY9810Core.h
  • JY9810_Signal_PXI_Trig5 : JY9810Core.h
  • JY9810_Signal_PXI_Trig6 : JY9810Core.h
  • JY9810_Signal_PXI_Trig7 : JY9810Core.h
  • JY9810_Signal_Source : JY9810Core.h
  • JY9810_SignalRouting() : JY9810Core.h
  • JY9810_Six_Term_Flat_Top : JY9810Core.h
  • JY9810_Six_Term_Least_Sidelobe : JY9810Core.h
  • JY9810_SLAVE : JY9810Core.h
  • JY9810_Software : JY9810Core.h
  • JY9810_SpectrumAverageMode : JY9810Core.h
  • JY9810_SpectrumUnitType : JY9810Core.h
  • JY9810_StartTrig : JY9810Core.h
  • JY9810_StartTrig_OUT : JY9810Core.h
  • JY9810_StartTrigger : JY9810Core.h
  • JY9810_SyncSignal_In : JY9810Core.h
  • JY9810_SyncSignal_OUT : JY9810Core.h
  • JY9810_Three_Term_Blackman_Nuttal : JY9810Core.h
  • JY9810_Three_Term_Nuttal : JY9810Core.h
  • JY9810_TriggerMode : JY9810Core.h
  • JY9810_TriggerType : JY9810Core.h
  • JY9810_Upper : JY9810Core.h
  • JY9810_V2 : JY9810Core.h
  • JY9818_QuasiClock_AnalogTrigger : JY9810Core.h
  • JY9818_QuasiClock_PFI0 : JY9810Core.h
  • JY9818_QuasiClock_PXI_Trig0 : JY9810Core.h
  • JY9818_QuasiClock_PXI_Trig1 : JY9810Core.h
  • JY9818_QuasiClock_PXI_Trig2 : JY9810Core.h
  • JY9818_QuasiClock_PXI_Trig3 : JY9810Core.h
  • JY9818_QuasiClock_PXI_Trig4 : JY9810Core.h
  • JY9818_QuasiClock_PXI_Trig5 : JY9810Core.h
  • JY9818_QuasiClock_PXI_Trig6 : JY9810Core.h
  • JY9818_QuasiClock_PXI_Trig7 : JY9810Core.h
  • JY9818_QuasiClock_PXIe_DStarB : JY9810Core.h
  • JY9818_QuasiClock_PXIe_DStarC : JY9810Core.h

- u -

  • UINT64 : JY9810Core.h


9818 C++ Programming Manual: File Members

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
Here is a list of all enums with links to the files they belong to:
  • JY9810_AnalogTriggerEdge : JY9810Core.h
  • JY9810_AnalogTriggerSource : JY9810Core.h
  • JY9810_AnalogWindowCondition : JY9810Core.h
  • JY9810_Coupling : JY9810Core.h
  • JY9810_DeviceProperty : JY9810Core.h
  • JY9810_DigitalTriggerEdge : JY9810Core.h
  • JY9810_DigitalTriggerSource : JY9810Core.h
  • JY9810_FFTWindowType : JY9810Core.h
  • JY9810_FrequencyAlignmentMode : JY9810Core.h
  • JY9810_Impedance : JY9810Core.h
  • JY9810_MultiChannelCompositionLogic : JY9810Core.h
  • JY9810_QuasiClockTerminal : JY9810Core.h
  • JY9810_ReferenceClock : JY9810Core.h
  • JY9810_SampleClockSource : JY9810Core.h
  • JY9810_SampleMode : JY9810Core.h
  • JY9810_Signal_Destination : JY9810Core.h
  • JY9810_Signal_Source : JY9810Core.h
  • JY9810_SpectrumAverageMode : JY9810Core.h
  • JY9810_SpectrumUnitType : JY9810Core.h
  • JY9810_TriggerMode : JY9810Core.h
  • JY9810_TriggerType : JY9810Core.h


9818 C++ Programming Manual: File Members

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • j
Here is a list of all enum values with links to the files they belong to:

- j -

  • JY9810_1M_ohm : JY9810Core.h
  • JY9810_50_ohm : JY9810Core.h
  • JY9810_Analog : JY9810Core.h
  • JY9810_And : JY9810Core.h
  • JY9810_Blackman : JY9810Core.h
  • JY9810_Blackman_Harris : JY9810Core.h
  • JY9810_Center : JY9810Core.h
  • JY9810_Channel_0 : JY9810Core.h
  • JY9810_Channel_1 : JY9810Core.h
  • JY9810_Channel_2 : JY9810Core.h
  • JY9810_Channel_3 : JY9810Core.h
  • JY9810_Continuous : JY9810Core.h
  • JY9810_Coupling_AC : JY9810Core.h
  • JY9810_Coupling_DC : JY9810Core.h
  • JY9810_dBFS : JY9810Core.h
  • JY9810_dBm : JY9810Core.h
  • JY9810_dBuV : JY9810Core.h
  • JY9810_dBV : JY9810Core.h
  • JY9810_Digital : JY9810Core.h
  • JY9810_Entering : JY9810Core.h
  • JY9810_Exact_Blackman : JY9810Core.h
  • JY9810_ExponentialAverage : JY9810Core.h
  • JY9810_ExternalClock : JY9810Core.h
  • JY9810_Falling : JY9810Core.h
  • JY9810_FallingSlope : JY9810Core.h
  • JY9810_Finite : JY9810Core.h
  • JY9810_Five_Term_Least_Sidelobe : JY9810Core.h
  • JY9810_Flat_Top_90D : JY9810Core.h
  • JY9810_Flat_Top_95 : JY9810Core.h
  • JY9810_Four_Term_B_Harris : JY9810Core.h
  • JY9810_Four_Term_Blackman_Nuttal : JY9810Core.h
  • JY9810_Four_Term_Nuttal : JY9810Core.h
  • JY9810_Front_Panel_Clock_In : JY9810Core.h
  • JY9810_Hamming : JY9810Core.h
  • JY9810_Hanning : JY9810Core.h
  • JY9810_Immediately : JY9810Core.h
  • JY9810_Independent : JY9810Core.h
  • JY9810_Internal : JY9810Core.h
  • JY9810_InternalClock : JY9810Core.h
  • JY9810_Leaving : JY9810Core.h
  • JY9810_LinearAverage : JY9810Core.h
  • JY9810_Lower : JY9810Core.h
  • JY9810_MASTER : JY9810Core.h
  • JY9810_NoAveraging : JY9810Core.h
  • JY9810_None : JY9810Core.h
  • JY9810_Or : JY9810Core.h
  • JY9810_PeakHold : JY9810Core.h
  • JY9810_PFI0_OUT : JY9810Core.h
  • JY9810_PFI_0 : JY9810Core.h
  • JY9810_PseudoPeakHold : JY9810Core.h
  • JY9810_PXI_Trig0 : JY9810Core.h
  • JY9810_PXI_Trig0_OUT : JY9810Core.h
  • JY9810_PXI_Trig1 : JY9810Core.h
  • JY9810_PXI_Trig1_OUT : JY9810Core.h
  • JY9810_PXI_Trig2 : JY9810Core.h
  • JY9810_PXI_Trig2_OUT : JY9810Core.h
  • JY9810_PXI_Trig3 : JY9810Core.h
  • JY9810_PXI_Trig3_OUT : JY9810Core.h
  • JY9810_PXI_Trig4 : JY9810Core.h
  • JY9810_PXI_Trig4_OUT : JY9810Core.h
  • JY9810_PXI_Trig5 : JY9810Core.h
  • JY9810_PXI_Trig5_OUT : JY9810Core.h
  • JY9810_PXI_Trig6 : JY9810Core.h
  • JY9810_PXI_Trig6_OUT : JY9810Core.h
  • JY9810_PXI_Trig7 : JY9810Core.h
  • JY9810_PXI_Trig7_OUT : JY9810Core.h
  • JY9810_PXIe_Clk100 : JY9810Core.h
  • JY9810_PXIe_DStarB : JY9810Core.h
  • JY9810_PXIe_DStarC : JY9810Core.h
  • JY9810_QuasiExternelClock : JY9810Core.h
  • JY9810_ReferenceTrig : JY9810Core.h
  • JY9810_ReferenceTrig_OUT : JY9810Core.h
  • JY9810_ReferenceTrigger : JY9810Core.h
  • JY9810_Rising : JY9810Core.h
  • JY9810_RisingSlope : JY9810Core.h
  • JY9810_Seven_Term_Flat_Top : JY9810Core.h
  • JY9810_Seven_Term_Least_Sidelobe : JY9810Core.h
  • JY9810_Signal_Constant_0 : JY9810Core.h
  • JY9810_Signal_PFI0 : JY9810Core.h
  • JY9810_Signal_PXI_Trig0 : JY9810Core.h
  • JY9810_Signal_PXI_Trig1 : JY9810Core.h
  • JY9810_Signal_PXI_Trig2 : JY9810Core.h
  • JY9810_Signal_PXI_Trig3 : JY9810Core.h
  • JY9810_Signal_PXI_Trig4 : JY9810Core.h
  • JY9810_Signal_PXI_Trig5 : JY9810Core.h
  • JY9810_Signal_PXI_Trig6 : JY9810Core.h
  • JY9810_Signal_PXI_Trig7 : JY9810Core.h
  • JY9810_Six_Term_Flat_Top : JY9810Core.h
  • JY9810_Six_Term_Least_Sidelobe : JY9810Core.h
  • JY9810_SLAVE : JY9810Core.h
  • JY9810_Software : JY9810Core.h
  • JY9810_StartTrig : JY9810Core.h
  • JY9810_StartTrig_OUT : JY9810Core.h
  • JY9810_StartTrigger : JY9810Core.h
  • JY9810_SyncSignal_In : JY9810Core.h
  • JY9810_SyncSignal_OUT : JY9810Core.h
  • JY9810_Three_Term_Blackman_Nuttal : JY9810Core.h
  • JY9810_Three_Term_Nuttal : JY9810Core.h
  • JY9810_Upper : JY9810Core.h
  • JY9810_V2 : JY9810Core.h
  • JY9818_QuasiClock_AnalogTrigger : JY9810Core.h
  • JY9818_QuasiClock_PFI0 : JY9810Core.h
  • JY9818_QuasiClock_PXI_Trig0 : JY9810Core.h
  • JY9818_QuasiClock_PXI_Trig1 : JY9810Core.h
  • JY9818_QuasiClock_PXI_Trig2 : JY9810Core.h
  • JY9818_QuasiClock_PXI_Trig3 : JY9810Core.h
  • JY9818_QuasiClock_PXI_Trig4 : JY9810Core.h
  • JY9818_QuasiClock_PXI_Trig5 : JY9810Core.h
  • JY9818_QuasiClock_PXI_Trig6 : JY9810Core.h
  • JY9818_QuasiClock_PXI_Trig7 : JY9810Core.h
  • JY9818_QuasiClock_PXIe_DStarB : JY9810Core.h
  • JY9818_QuasiClock_PXIe_DStarC : JY9810Core.h


9818 C++ Programming Manual: File Members

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • j
Here is a list of all functions with links to the files they belong to:

- j -

  • J9810_GetDeviceTemprature() : JY9810Core.h
  • JY9810_AI_CheckBufferStatus() : JY9810Core.h
  • JY9810_AI_CommitPLLConfiguration() : JY9810Core.h
  • JY9810_AI_DisableMultiCardTriggerSync() : JY9810Core.h
  • JY9810_AI_DisableTriggerDelay() : JY9810Core.h
  • JY9810_AI_EnableChannel() : JY9810Core.h
  • JY9810_AI_FFT_CheckBufferStatus() : JY9810Core.h
  • JY9810_AI_FFT_ConfigSpectrumAverageParam() : JY9810Core.h
  • JY9810_AI_FFT_ConfigSpectrumParam() : JY9810Core.h
  • JY9810_AI_FFT_GetSpectralInformation() : JY9810Core.h
  • JY9810_AI_FFT_ReadData() : JY9810Core.h
  • JY9810_AI_FFT_SendSoftTrigger() : JY9810Core.h
  • JY9810_AI_FFT_Start() : JY9810Core.h
  • JY9810_AI_FFT_Stop() : JY9810Core.h
  • JY9810_AI_ReadData() : JY9810Core.h
  • JY9810_AI_ReadRawData() : JY9810Core.h
  • JY9810_AI_ReadStreamData() : JY9810Core.h
  • JY9810_AI_ScaleData() : JY9810Core.h
  • JY9810_AI_SendSoftTrigger() : JY9810Core.h
  • JY9810_AI_SetAnalogEdgeReferenceTrigger() : JY9810Core.h
  • JY9810_AI_SetAnalogEdgeStartTrigger() : JY9810Core.h
  • JY9810_AI_SetAnalogHysteresisReferenceTrigger() : JY9810Core.h
  • JY9810_AI_SetAnalogHysteresisStartTrigger() : JY9810Core.h
  • JY9810_AI_SetAnalogTriggerMultiChannelMode() : JY9810Core.h
  • JY9810_AI_SetAnalogWindowReferenceTrigger() : JY9810Core.h
  • JY9810_AI_SetAnalogWindowStartTrigger() : JY9810Core.h
  • JY9810_AI_SetCIC() : JY9810Core.h
  • JY9810_AI_SetDigitalReferenceTrigger() : JY9810Core.h
  • JY9810_AI_SetDigitalStartTrigger() : JY9810Core.h
  • JY9810_AI_SetDownSample() : JY9810Core.h
  • JY9810_AI_SetMode() : JY9810Core.h
  • JY9810_AI_SetMovingAverage() : JY9810Core.h
  • JY9810_AI_SetPreTriggerSamples() : JY9810Core.h
  • JY9810_AI_SetReferenceTriggerType() : JY9810Core.h
  • JY9810_AI_SetReTriggerCount() : JY9810Core.h
  • JY9810_AI_SetSampleClock() : JY9810Core.h
  • JY9810_AI_SetSampleClockEx() : JY9810Core.h
  • JY9810_AI_SetSampleRate() : JY9810Core.h
  • JY9810_AI_SetSamplesToAcquire() : JY9810Core.h
  • JY9810_AI_SetStartTriggerType() : JY9810Core.h
  • JY9810_AI_Start() : JY9810Core.h
  • JY9810_AI_Stop() : JY9810Core.h
  • JY9810_Close() : JY9810Core.h
  • JY9810_DisableCalibration() : JY9810Core.h
  • JY9810_DisconnectSignalRouting() : JY9810Core.h
  • JY9810_GetDeviceID() : JY9810Core.h
  • JY9810_GetDeviceSerialNumber() : JY9810Core.h
  • JY9810_Open() : JY9810Core.h
  • JY9810_OpenByName() : JY9810Core.h
  • JY9810_SetDeviceProperty() : JY9810Core.h
  • JY9810_SetDeviceReferenceClock() : JY9810Core.h
  • JY9810_SetDeviceStatusLed() : JY9810Core.h
  • JY9810_SignalRouting() : JY9810Core.h


9818 C++ Programming Manual: File Members

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
Here is a list of all typedefs with links to the files they belong to:
  • JY9810_Device_Handle : JY9810Core.h
  • UINT64 : JY9810Core.h


9818 C++ Programming Manual: Main Page

9818 C++ Programming Manual Documentation


9818 C++ Programming Manual: JY9810_SpectralInformation Struct Reference

  • Class List
  • Class Index
  • Class Members
Public Attributes | List of all members
JY9810_SpectralInformation Struct Reference

#include <JY9810Core.h>

Public Attributes

double | CenterFrequency
double | FrequencyStart
double | FrequencyStep
double | ResolutionBandwidth
double | ENBW
JY9810_SpectrumUnitType UnitType
JY9810_FFTWindowType FftWindowType
int | NumOfSpectralLines
int | FftLength
bool | IsPsd

Member Data Documentation

◆ CenterFrequency

double JY9810_SpectralInformation::CenterFrequency

◆ ENBW

double JY9810_SpectralInformation::ENBW

◆ FftLength

int JY9810_SpectralInformation::FftLength

◆ FftWindowType

JY9810_FFTWindowType JY9810_SpectralInformation::FftWindowType

◆ FrequencyStart

double JY9810_SpectralInformation::FrequencyStart

◆ FrequencyStep

double JY9810_SpectralInformation::FrequencyStep

◆ IsPsd

bool JY9810_SpectralInformation::IsPsd

◆ NumOfSpectralLines

int JY9810_SpectralInformation::NumOfSpectralLines

◆ ResolutionBandwidth

double JY9810_SpectralInformation::ResolutionBandwidth

◆ UnitType

JY9810_SpectrumUnitType JY9810_SpectralInformation::UnitType
The documentation for this struct was generated from the following file:
  • D:/9818/C++/JY9810Core.h


9818 C++ Programming Manual: Member List

  • Class List
  • Class Index
  • Class Members
JY9810_SpectralInformation Member List

This is the complete list of members for JY9810_SpectralInformation, including all inherited members.

CenterFrequency | JY9810_SpectralInformation
ENBW | JY9810_SpectralInformation
FftLength | JY9810_SpectralInformation
FftWindowType | JY9810_SpectralInformation
FrequencyStart | JY9810_SpectralInformation
FrequencyStep | JY9810_SpectralInformation
IsPsd | JY9810_SpectralInformation
NumOfSpectralLines | JY9810_SpectralInformation
ResolutionBandwidth | JY9810_SpectralInformation
UnitType | JY9810_SpectralInformation