9824 C++ Programming Manual: D:/9824/C++/JY9824Core.h File Reference

9824 C++ Programming Manual
  • Main Page
  • Classes
  • Files
  • File List
  • File Members
  • 9824
  • C++
Classes | Macros | Typedefs | Enumerations | Functions
JY9824Core.h File Reference
#include <stdio.h>
#include <set>

Classes

struct | JY9824CoreDeviceInfo
struct | JY9824CalibrationConstant
struct | JY9824CalibrationInfo
struct | JY9824DeviceInfo
struct | JY9824_SpectralInformation

Macros

#define | STDCALL
Windows.
#define | CCALL
#define | JYDLL_API
#define | STDCALL
Windows.
#define | Success 0
#define | JYFailed -1
#define | JY9824_ErrorCodeOffset (-10000)
#define | Error_OpenDeviceFailed (JY9824_ErrorCodeOffset - 1)
#define | Error_CloseDeviceFailed (JY9824_ErrorCodeOffset - 2)
#define | Error_DeviceNoOpened (JY9824_ErrorCodeOffset - 3)
#define | Error_InitalDeviceFailed (JY9824_ErrorCodeOffset - 4)
#define | Error_ActiveDeviceFailed (JY9824_ErrorCodeOffset - 5)
#define | Error_DeviceSlotNumberInvalid (JY9824_ErrorCodeOffset - 6)
#define | Error_DeviceNumberInvalid (JY9824_ErrorCodeOffset - 7)
#define | Error_DeviceNameInvalid (JY9824_ErrorCodeOffset - 8)
#define | Error_DeviceHandleInvalid (JY9824_ErrorCodeOffset - 9)
#define | Error_InitalEEPROMFailed (JY9824_ErrorCodeOffset - 10)
#define | Error_ReadEEPROMFailed (JY9824_ErrorCodeOffset - 11)
#define | Error_WriteEEPROMFailed (JY9824_ErrorCodeOffset - 12)
#define | Error_TimeBaseSourceInvalid (JY9824_ErrorCodeOffset - 13)
#define | Error_CLKMuxSelectFailed (JY9824_ErrorCodeOffset - 14)
#define | Error_PLLSetFailed (JY9824_ErrorCodeOffset - 15)
#define | Error_PLLLockFailed (JY9824_ErrorCodeOffset - 16)
#define | Error_PLLCrashed (JY9824_ErrorCodeOffset - 17)
#define | Error_PLLOutputFreqOutOfRange (JY9824_ErrorCodeOffset - 18)
#define | Error_GetDeviceAttributeFailed (JY9824_ErrorCodeOffset - 19)
#define | Error_SetDeviceAttributeFailed (JY9824_ErrorCodeOffset - 20)
#define | Error_GetDeviceCalibrationDataFailed (JY9824_ErrorCodeOffset - 21)
#define | Error_MallocMemoryFailed (JY9824_ErrorCodeOffset - 22)
#define | Error_UnSupportOperation (JY9824_ErrorCodeOffset - 23)
#define | Error_ReleaseDeviceResourceFailed (JY9824_ErrorCodeOffset - 24)
#define | Error_ParamInvalid (JY9824_ErrorCodeOffset - 25)
#define | Error_DevicePropertyInvalid (JY9824_ErrorCodeOffset - 26)
#define | Error_GetDevInfoFailed (JY9824_ErrorCodeOffset - 27)
#define | Error_NumOfWBIQAcqSamplesIsZero (JY9824_ErrorCodeOffset - 28)
#define | Error_ConfigChannelIDOutOfRange (JY9824_ErrorCodeOffset - 29)
#define | Error_InvalidInternalRefClock (JY9824_ErrorCodeOffset - 30)
#define | Error_InvalidSampleClock (JY9824_ErrorCodeOffset - 31)
#define | Error_InvalidChannelID (JY9824_ErrorCodeOffset - 32)
#define | Error_InvalidPhysicalCenterFreq (JY9824_ErrorCodeOffset - 33)
#define | Error_InvalidADCInputRange (JY9824_ErrorCodeOffset - 34)
#define | Error_InvalidOverRangeBufferLength (JY9824_ErrorCodeOffset - 35)
#define | Error_InvalidTriggerType (JY9824_ErrorCodeOffset - 36)
#define | Error_InvalidSamplesToRead (JY9824_ErrorCodeOffset - 37)
#define | Error_InvalidDigitalGain (JY9824_ErrorCodeOffset - 38)
#define | Error_InvalidDataRate (JY9824_ErrorCodeOffset - 39)
#define | Error_InvalidWBIQChannelEnableBufferLength (JY9824_ErrorCodeOffset - 40)
#define | Error_EEPROMCalCRCFailed (JY9824_ErrorCodeOffset - 41)
#define | ErrorTriggerDelayParam (JY9824_ErrorCodeOffset - 42)
#define | Error_ChannelID (JY9824_ErrorCodeOffset - 43)
#define | Error_GetLMK048xxPLLType (JY9824_ErrorCodeOffset - 44)
#define | Error_InitLMK048xxPLL (JY9824_ErrorCodeOffset - 45)
#define | Error_LMK048xxPLL_LockFailed (JY9824_ErrorCodeOffset - 46)
#define | Error_JESD204_PHY_GetPllStatus (JY9824_ErrorCodeOffset - 47)
#define | Error_JESD204_GetStatus (JY9824_ErrorCodeOffset - 48)
#define | Error_DACx0501_GetChipID (JY9824_ErrorCodeOffset - 49)
#define | Error_SampleModeParam (JY9824_ErrorCodeOffset - 50)
#define | Error_PreTriggerSamplesParam (JY9824_ErrorCodeOffset - 51)
#define | Error_TriggerTypeParam (JY9824_ErrorCodeOffset - 52)
#define | Error_SamplesParam (JY9824_ErrorCodeOffset - 53)
#define | Error_PointerNotNull (JY9824_ErrorCodeOffset - 54)
#define | Error_TimeOut (JY9824_ErrorCodeOffset - 55)
#define | Error_ReTriggerCountsParam (JY9824_ErrorCodeOffset - 56)
#define | Error_AutoTriggerTimeParam (JY9824_ErrorCodeOffset - 57)
#define | Error_HoldOffTimeParam (JY9824_ErrorCodeOffset - 58)
#define | Error_BufferLengthParam (JY9824_ErrorCodeOffset - 59)
#define | Error_WriteRegisterFailed (JY9824_ErrorCodeOffset - 60)
#define | EEPROM_REG_WRITE_FAILED (JY9824_ErrorCodeOffset - 61)
#define | Error_TaskIsStartDonotAllowConfig (JY9824_ErrorCodeOffset - 63)
#define | Error_RxInitFailed (JY9824_ErrorCodeOffset - 64)
#define | Error_ReTriggerCountsNotMatchSampleMode (JY9824_ErrorCodeOffset - 65)
#define | Error_InternalError (JY9824_ErrorCodeOffset - 66)
#define | Error_DigitalTriggerParam (JY9824_ErrorCodeOffset - 67)
#define | Error_AnnalogTriggerParam (JY9824_ErrorCodeOffset - 68)
#define | Error_AnalogTriggerConditioningParam (JY9824_ErrorCodeOffset - 69)
#define | Error_AnnalogTriggerThreshold (JY9824_ErrorCodeOffset - 70)
#define | Error_DataType (JY9824_ErrorCodeOffset - 71)
#define | Error_EEPROMCalOutOfRange (JY9824_ErrorCodeOffset - 72)
#define | Error_InputRange (JY9824_ErrorCodeOffset - 73)
#define | Error_ExportSignalCannotRepeatConfig (JY9824_ErrorCodeOffset - 74)
#define | Error_InvalidParam (JY9824_ErrorCodeOffset - 75)
#define | Error_InvalidAverageSize (JY9824_ErrorCodeOffset - 76)

Typedefs

typedef void * DeviceHandle

Enumerations

enum | TriggerMode { StartTrigger = 0x1 , ReferenceTrigger = 0x2 , StartAndReferenceTrigger = 0x3 }
enum | TriggerType { Immediate_Trigger = 0x0 , Soft_Trigger = 0x1 , Digital_Trigger = 0x2 , Analog_Trigger = 0x3 }
enum | AcquisitionMode { Finite_Sample = 0x0 , Continuous_Sample = 0x1 }
enum DigitalTriggerSource {
PFI0 = 0 , PXI_Trig_0 = 1 , PXI_Trig_1 = 2 , PXI_Trig_2 = 3 ,
PXI_Trig_3 = 4 , PXI_Trig_4 = 5 , PXI_Trig_5 = 6 , PXI_Trig_6 = 7 ,
PXI_Trig_7 = 8
}
enum | DigitalTriggerConditioning { Rising_Edge_Trigger = (0x1 << 1) , Falling_Edge_Trigger = (0x1 << 2) , High_Level_Trigger = (0x1 << 3) , Low_Level_Trigger = (0x1 << 4) }
enum | AnalogTriggerType { AnalogHysteresisTrigger = 0x00 , AnalogWindowTrigger = 0x1 , AnalogPowerTrigger = 0x2 }
enum AnalogTriggerSource {
AnalogTriggerSourceCH0Raw = 0x00 , AnalogTriggerSourceCH1Raw = 0x01 , AnalogTriggerSourceCH2Raw = 0x02 , AnalogTriggerSourceCH3Raw = 0x03 ,
AnalogTriggerSourceTriggerIn = 0x04
}
enum AnalogTriggerConditioning {
AnalogTriggerConditioningPowerHigh = High_Level_Trigger , AnalogTriggerConditioningPowerLow = Low_Level_Trigger , AnalogTriggerConditioningEnteringWindow = Rising_Edge_Trigger , AnalogTriggerConditioningLeavingWindow = Falling_Edge_Trigger ,
AnalogTriggerConditioningRising = Rising_Edge_Trigger , AnalogTriggerConditioningFalling = Falling_Edge_Trigger
}
enum | DataType { Real = 0 , Complex = 1 , FFT = 2 }
enum | InputRange { Vpp1V = 0 , Vpp2V = 1 }
enum | ClockSource { ExternalClock0 = 0x0 , InternalClock = 0x1 , ExternalClock1 = 0x2 }
enum | SyncMode { SOLO = 0x0 , Master = 0x1 , Slave = 0x3 }
enum ExportSignalDestination {
PXITrig_IN_0 = 0 , PXITrig_IN_1 = 1 , PXITrig_IN_2 = 2 , PXITrig_IN_3 = 3 ,
PXITrig_IN_4 = 4 , PXITrig_IN_5 = 5 , PXITrig_IN_6 = 6 , PXITrig_IN_7 = 7 ,
PFI_ui_0_0_do_IN = 8 , Rx_Engine_Real_start_trig_in = 9 , Rx_Engine_Real_reference_trig_in = 10 , Rx_Engine_Real_advance_trig_in = 11 ,
Rx_Engine_IQ_start_trig_in = 12 , Rx_Engine_IQ_reference_trig_in = 13 , Rx_Engine_IQ_advance_trig_in = 14 , Rx_Engine_FFT_start_trig_in = 15 ,
Rx_Engine_FFT_reference_trig_in = 16 , DataPackage_0_start_trig_in = 17 , FFT_Config_0_trig_in = 18
}
enum ExportSignalSource {
PXITrig_OUT_0 = 8 , PXITrig_OUT_1 = 9 , PXITrig_OUT_2 = 10 , PXITrig_OUT_3 = 11 ,
PXITrig_OUT_4 = 12 , PXITrig_OUT_5 = 13 , PXITrig_OUT_6 = 14 , PXITrig_OUT_7 = 15 ,
PFI_ui_0_0_di_OUT = 1 , TrigIn_buf_IBUF_OUT_OUT = 2 , Analog_trig_0_trig = 3 , Rx_Engine_IQ_start_trig_out = 4 ,
Rx_Engine_IQ_reference_trig_out = 5 , Rx_Engine_IQ_advance_trig_out = 6 , Rx_Engine_Real_start_trig_out = 7 , Rx_Engine_Real_reference_trig_out = 16 ,
Rx_Engine_Real_advance_trig_out = 17
}
enum JY9824_SpectrumUnitType {
JY9824_dBm = 0 , JY9824_dBFS = 1 , JY9824_dBV = 2 , JY9824_dBuV = 3 ,
JY9824_V2 = 4
}
enum JY9824_SpectrumAverageMode {
JY9824_NoAveraging = 0 , JY9824_ExponentialAverage = 1 , JY9824_PseudoPeakHold = 2 , JY9824_PeakHold = 3 ,
JY9824_LinearAverage = 4
}
enum JY9824_FFTWindowType {
JY9824_None , JY9824_Hanning , JY9824_Hamming , JY9824_Blackman_Harris ,
JY9824_Exact_Blackman , JY9824_Blackman , JY9824_Three_Term_Nuttal , JY9824_Three_Term_Blackman_Nuttal ,
JY9824_Four_Term_B_Harris , JY9824_Four_Term_Nuttal , JY9824_Four_Term_Blackman_Nuttal , JY9824_Flat_Top_95 ,
JY9824_Flat_Top_90D , JY9824_Five_Term_Least_Sidelobe , JY9824_Six_Term_Flat_Top , JY9824_Six_Term_Least_Sidelobe ,
JY9824_Seven_Term_Flat_Top , JY9824_Seven_Term_Least_Sidelobe
}
enum | JY9824_FrequencyAlignmentMode { JY9824_Center , JY9824_Lower , JY9824_Upper }

Functions

JYDLL_API int STDCALL | JY9824Core_GetDeviceList (JY9824DeviceInfo deviceInfo[], int deviceInfoLength)
获取所有设备
JYDLL_API int STDCALL | JY9824Core_Open (int slotNumber, int *cardID)
打开设备
JYDLL_API int STDCALL | JY9824Core_Open_WithAliasName (const char *aliasName, int *cardID)
打开设备
JYDLL_API int STDCALL | JY9824Core_Close (int cardID)
关闭设备
JYDLL_API int STDCALL | JY9824Core_GetTemperature (int cardID, double *cardTemp, double *fpgaTemp=NULL)
获取板卡温度
JYDLL_API int STDCALL | JY9824Core_SetReferenceClockParam (int cardID, ClockSource clockSource, double freqOption=10e6)
设置参考时钟和参考时钟的频率
JYDLL_API int STDCALL | JY9824Core_ExportSignal (int cardID, ExportSignalSource source, ExportSignalDestination destination)
导出信号配置
JYDLL_API int STDCALL | JY9824Core_SetSyncMode (int cardID, SyncMode syncMode)
设置多卡同步的参数
JYDLL_API int STDCALL | JY9824Core_GetLastError (int cardID, char *message, int *errorCode)
获取最后一次错误信息
JYDLL_API int STDCALL | JY9824Core_Commit (int cardID)
提交配置
JYDLL_API int STDCALL | JY9824Core_ConfigSampleRate (int cardID, double sampleRate, double *actualSampleRatete, int *actualDecimationRatio)
设置采样率
JYDLL_API int STDCALL | JY9824Core_SetDDCParam (int cardID, int channelMask, double frequency, double *actualFreq, int digitalgain=0)
设置DDC参数
JYDLL_API int STDCALL | JY9824Core_SetTriggerType (int cardID, TriggerType triggerType)
设置触发类型
JYDLL_API int STDCALL | JY9824Core_SetDigitalTrigger (int cardID, DigitalTriggerConditioning digitalTriggerType, DigitalTriggerSource digitalTriggerSource)
设置数字触发类型
JYDLL_API int STDCALL | JY9824Core_SetAnalogTrigger (int cardID, AnalogTriggerType analogTriggerType, AnalogTriggerSource analogTriggerSource, AnalogTriggerConditioning analogTriggerConditioning, double highThreshold, double lowThreshold)
设置模拟触发类型
JYDLL_API int STDCALL | JY9824Core_SetPreTriggerSamples (int cardID, unsigned int preTriggerSamples)
设置预触发点数
JYDLL_API int STDCALL | JY9824Core_SetEnabledChannels (int cardID, int channelMask)
设置使能通道
JYDLL_API int STDCALL | JY9824Core_SetAcquisitionMode (int cardID, AcquisitionMode acquisitionMode)
设置采集模式
JYDLL_API int STDCALL | JY9824Core_SetDataType (int cardID, DataType dataType)
设置数据类型
JYDLL_API int STDCALL | JY9824Core_SetInputRange (int cardID, int chnID, InputRange range)
设置输入量程挡位
JYDLL_API int STDCALL | JY9824Core_SetSamplesToAcquire (int cardID, int samplesToAcquire)
设置采集点数，有限点模式下有效
JYDLL_API int STDCALL | JY9824Core_Start (int cardID)
开始
JYDLL_API int STDCALL | JY9824Core_Stop (int cardID)
停止
JYDLL_API int STDCALL | JY9824Core_GetAcquisitionStatus (int cardID, bool *isOverFlow, unsigned long long *availableSamples)
获取采集状态，ReTriggerCount=1时有效
JYDLL_API int STDCALL | JY9824Core_WaitForAcqComplete (int cardID, int timeout, bool *complete)
等待采集完成
JYDLL_API int STDCALL | JY9824Core_ReadDataBinary16 (int cardID, short *dataBuffer, unsigned int samplesToRead, unsigned int *actualSamples, double *scaleFactor, int timeout)
读数据
JYDLL_API int STDCALL | JY9824Core_SetBufferLength (int cardID, unsigned int length)
设置缓冲区大小，ReTriggerCount=1时有效
JYDLL_API int STDCALL | JY9824Core_ReadDataDbl64 (int cardID, double *dataBuffer, unsigned int samplesToRead, int timeout)
读double数据
JYDLL_API int STDCALL | JY9824Core_SendSoftwareTrigger (int cardID)
发送软件触发
JYDLL_API int STDCALL | JY9824Core_SetReTriggerParam (int cardID, unsigned long long reTriggerCounts, double autoTriggerTime=-1.0, double holdOffTime=1)
设置重触发参数
JYDLL_API int STDCALL | JY9824Core_GetReTriggerStatus (int cardID, bool *isOverFlow, unsigned long long *remainingCounts, unsigned long long *completedCounts)
获取采集状态
JYDLL_API int STDCALL | JY9824Core_GetScaleFactor (int cardID, double *scaleFactor)
获取电平因子
JYDLL_API int STDCALL | JY9824Core_SetCalEnable (int cardID, bool enbale)
设置校准使能
JYDLL_API int STDCALL | JY9824Core_FFT_Start (int cardID)
Start AI acquisition.
JYDLL_API int STDCALL | JY9824Core_FFT_Stop (int cardID)
Stop AI acquisition.
JYDLL_API int STDCALL | JY9824Core_FFT_SendSoftTrigger (int cardID)
Send soft trigger.
JYDLL_API int STDCALL | JY9824Core_FFT_ConfigSpectrumParam (int cardID, double centerFrequency, JY9824_FrequencyAlignmentMode freAlignmentMode, double expectBandwidth, double expectNumOfSpectralLines, JY9824_FFTWindowType windowType, JY9824_SpectrumUnitType uintType, bool isPSD)
Config spectrum param.
JYDLL_API int STDCALL | JY9824Core_FFT_ConfigSpectrumAverageParam (int cardID, JY9824_SpectrumAverageMode averageMode, int averageSize, double timeConstant)
Config Spectrum Average param.
JYDLL_API int STDCALL | JY9824Core_FFT_GetSpectralInformation (int cardID, JY9824_SpectralInformation *spectralInformation)
Config Spectrum Average param.
JYDLL_API int STDCALL | JY9824Core_FFT_ReadData (int cardID, float *dataBuffer, unsigned int samplesToRead, int timeout, unsigned int *actualSamples)
Read AI data to user defined data buffer.
JYDLL_API int STDCALL | JY9824Core_FFT_CheckBufferStatus (int cardID, unsigned long long *avaliableSamples, unsigned long long *transferedSamples, bool *overrun)
Check AI device buffer status.
JYDLL_API int STDCALL | JY9824Core_EEPROM_ReadIdBlock (int card_int, JY9824CoreDeviceInfo *id)
读EEPROMIdBlock
JYDLL_API int STDCALL | JY9824Core_EEPROM_WriteIdBlock (int card_int, JY9824CoreDeviceInfo *id)
写EEPROMIdBlock
JYDLL_API int STDCALL | JY9824Core_EEPROM_ReadCalibrationBlock (int card_int, JY9824CalibrationInfo *cb)
读EEPROMCalibrationBlock
JYDLL_API int STDCALL | JY9824Core_EEPROM_WriteCalibrationBlock (int card_int, JY9824CalibrationInfo *cb)
写EEPROMCalibrationBlock
JYDLL_API int STDCALL | JY9824Core_EEPROM_InitializeIdBlock (int card_int)
初始化IdBlock
JYDLL_API int STDCALL | JY9824Core_EEPROM_InitializeCalibrationBlock (int card_int)
初始化CalibrationBlock
JYDLL_API int STDCALL | JY9824Core_EEPROM_SerialNumber_String2Int (const char *const serialNumberString, int *serialNumberInt)
序列字符转序列号
JYDLL_API int STDCALL | JY9824Core_EEPROM_SerialNumber_Int2String (int serialNumberInt, char *serialNumberString)
序列号转序列字符
JYDLL_API int STDCALL | JY9824Core_EEPROM_Reset (int card_int, int val=0, int beginAddr=0, int endAddr=1023)
重置
JYDLL_API int STDCALL | JY9824Core_CalculateCRC16 (unsigned char *bufData, unsigned int buflen, unsigned short *pcrc, unsigned short initVal, unsigned short polynomial)

Macro Definition Documentation

◆ CCALL

#define CCALL

◆ EEPROM_REG_WRITE_FAILED

#define EEPROM_REG_WRITE_FAILED (JY9824_ErrorCodeOffset - 61)

◆ Error_ActiveDeviceFailed

#define Error_ActiveDeviceFailed (JY9824_ErrorCodeOffset - 5)

◆ Error_AnalogTriggerConditioningParam

#define Error_AnalogTriggerConditioningParam (JY9824_ErrorCodeOffset - 69)

◆ Error_AnnalogTriggerParam

#define Error_AnnalogTriggerParam (JY9824_ErrorCodeOffset - 68)

◆ Error_AnnalogTriggerThreshold

#define Error_AnnalogTriggerThreshold (JY9824_ErrorCodeOffset - 70)

◆ Error_AutoTriggerTimeParam

#define Error_AutoTriggerTimeParam (JY9824_ErrorCodeOffset - 57)

◆ Error_BufferLengthParam

#define Error_BufferLengthParam (JY9824_ErrorCodeOffset - 59)

◆ Error_ChannelID

#define Error_ChannelID (JY9824_ErrorCodeOffset - 43)

◆ Error_CLKMuxSelectFailed

#define Error_CLKMuxSelectFailed (JY9824_ErrorCodeOffset - 14)

◆ Error_CloseDeviceFailed

#define Error_CloseDeviceFailed (JY9824_ErrorCodeOffset - 2)

◆ Error_ConfigChannelIDOutOfRange

#define Error_ConfigChannelIDOutOfRange (JY9824_ErrorCodeOffset - 29)

◆ Error_DACx0501_GetChipID

#define Error_DACx0501_GetChipID (JY9824_ErrorCodeOffset - 49)

◆ Error_DataType

#define Error_DataType (JY9824_ErrorCodeOffset - 71)

◆ Error_DeviceHandleInvalid

#define Error_DeviceHandleInvalid (JY9824_ErrorCodeOffset - 9)

◆ Error_DeviceNameInvalid

#define Error_DeviceNameInvalid (JY9824_ErrorCodeOffset - 8)

◆ Error_DeviceNoOpened

#define Error_DeviceNoOpened (JY9824_ErrorCodeOffset - 3)

◆ Error_DeviceNumberInvalid

#define Error_DeviceNumberInvalid (JY9824_ErrorCodeOffset - 7)

◆ Error_DevicePropertyInvalid

#define Error_DevicePropertyInvalid (JY9824_ErrorCodeOffset - 26)

◆ Error_DeviceSlotNumberInvalid

#define Error_DeviceSlotNumberInvalid (JY9824_ErrorCodeOffset - 6)

◆ Error_DigitalTriggerParam

#define Error_DigitalTriggerParam (JY9824_ErrorCodeOffset - 67)

◆ Error_EEPROMCalCRCFailed

#define Error_EEPROMCalCRCFailed (JY9824_ErrorCodeOffset - 41)

◆ Error_EEPROMCalOutOfRange

#define Error_EEPROMCalOutOfRange (JY9824_ErrorCodeOffset - 72)

◆ Error_ExportSignalCannotRepeatConfig

#define Error_ExportSignalCannotRepeatConfig (JY9824_ErrorCodeOffset - 74)

◆ Error_GetDeviceAttributeFailed

#define Error_GetDeviceAttributeFailed (JY9824_ErrorCodeOffset - 19)

◆ Error_GetDeviceCalibrationDataFailed

#define Error_GetDeviceCalibrationDataFailed (JY9824_ErrorCodeOffset - 21)

◆ Error_GetDevInfoFailed

#define Error_GetDevInfoFailed (JY9824_ErrorCodeOffset - 27)

◆ Error_GetLMK048xxPLLType

#define Error_GetLMK048xxPLLType (JY9824_ErrorCodeOffset - 44)

◆ Error_HoldOffTimeParam

#define Error_HoldOffTimeParam (JY9824_ErrorCodeOffset - 58)

◆ Error_InitalDeviceFailed

#define Error_InitalDeviceFailed (JY9824_ErrorCodeOffset - 4)

◆ Error_InitalEEPROMFailed

#define Error_InitalEEPROMFailed (JY9824_ErrorCodeOffset - 10)

◆ Error_InitLMK048xxPLL

#define Error_InitLMK048xxPLL (JY9824_ErrorCodeOffset - 45)

◆ Error_InputRange

#define Error_InputRange (JY9824_ErrorCodeOffset - 73)

◆ Error_InternalError

#define Error_InternalError (JY9824_ErrorCodeOffset - 66)

◆ Error_InvalidADCInputRange

#define Error_InvalidADCInputRange (JY9824_ErrorCodeOffset - 34)

◆ Error_InvalidAverageSize

#define Error_InvalidAverageSize (JY9824_ErrorCodeOffset - 76)

◆ Error_InvalidChannelID

#define Error_InvalidChannelID (JY9824_ErrorCodeOffset - 32)

◆ Error_InvalidDataRate

#define Error_InvalidDataRate (JY9824_ErrorCodeOffset - 39)

◆ Error_InvalidDigitalGain

#define Error_InvalidDigitalGain (JY9824_ErrorCodeOffset - 38)

◆ Error_InvalidInternalRefClock

#define Error_InvalidInternalRefClock (JY9824_ErrorCodeOffset - 30)

◆ Error_InvalidOverRangeBufferLength

#define Error_InvalidOverRangeBufferLength (JY9824_ErrorCodeOffset - 35)

◆ Error_InvalidParam

#define Error_InvalidParam (JY9824_ErrorCodeOffset - 75)

◆ Error_InvalidPhysicalCenterFreq

#define Error_InvalidPhysicalCenterFreq (JY9824_ErrorCodeOffset - 33)

◆ Error_InvalidSampleClock

#define Error_InvalidSampleClock (JY9824_ErrorCodeOffset - 31)

◆ Error_InvalidSamplesToRead

#define Error_InvalidSamplesToRead (JY9824_ErrorCodeOffset - 37)

◆ Error_InvalidTriggerType

#define Error_InvalidTriggerType (JY9824_ErrorCodeOffset - 36)

◆ Error_InvalidWBIQChannelEnableBufferLength

#define Error_InvalidWBIQChannelEnableBufferLength (JY9824_ErrorCodeOffset - 40)

◆ Error_JESD204_GetStatus

#define Error_JESD204_GetStatus (JY9824_ErrorCodeOffset - 48)

◆ Error_JESD204_PHY_GetPllStatus

#define Error_JESD204_PHY_GetPllStatus (JY9824_ErrorCodeOffset - 47)

◆ Error_LMK048xxPLL_LockFailed

#define Error_LMK048xxPLL_LockFailed (JY9824_ErrorCodeOffset - 46)

◆ Error_MallocMemoryFailed

#define Error_MallocMemoryFailed (JY9824_ErrorCodeOffset - 22)

◆ Error_NumOfWBIQAcqSamplesIsZero

#define Error_NumOfWBIQAcqSamplesIsZero (JY9824_ErrorCodeOffset - 28)

◆ Error_OpenDeviceFailed

#define Error_OpenDeviceFailed (JY9824_ErrorCodeOffset - 1)

◆ Error_ParamInvalid

#define Error_ParamInvalid (JY9824_ErrorCodeOffset - 25)

◆ Error_PLLCrashed

#define Error_PLLCrashed (JY9824_ErrorCodeOffset - 17)

◆ Error_PLLLockFailed

#define Error_PLLLockFailed (JY9824_ErrorCodeOffset - 16)

◆ Error_PLLOutputFreqOutOfRange

#define Error_PLLOutputFreqOutOfRange (JY9824_ErrorCodeOffset - 18)

◆ Error_PLLSetFailed

#define Error_PLLSetFailed (JY9824_ErrorCodeOffset - 15)

◆ Error_PointerNotNull

#define Error_PointerNotNull (JY9824_ErrorCodeOffset - 54)

◆ Error_PreTriggerSamplesParam

#define Error_PreTriggerSamplesParam (JY9824_ErrorCodeOffset - 51)

◆ Error_ReadEEPROMFailed

#define Error_ReadEEPROMFailed (JY9824_ErrorCodeOffset - 11)

◆ Error_ReleaseDeviceResourceFailed

#define Error_ReleaseDeviceResourceFailed (JY9824_ErrorCodeOffset - 24)

◆ Error_ReTriggerCountsNotMatchSampleMode

#define Error_ReTriggerCountsNotMatchSampleMode (JY9824_ErrorCodeOffset - 65)

◆ Error_ReTriggerCountsParam

#define Error_ReTriggerCountsParam (JY9824_ErrorCodeOffset - 56)

◆ Error_RxInitFailed

#define Error_RxInitFailed (JY9824_ErrorCodeOffset - 64)

◆ Error_SampleModeParam

#define Error_SampleModeParam (JY9824_ErrorCodeOffset - 50)

◆ Error_SamplesParam

#define Error_SamplesParam (JY9824_ErrorCodeOffset - 53)

◆ Error_SetDeviceAttributeFailed

#define Error_SetDeviceAttributeFailed (JY9824_ErrorCodeOffset - 20)

◆ Error_TaskIsStartDonotAllowConfig

#define Error_TaskIsStartDonotAllowConfig (JY9824_ErrorCodeOffset - 63)

◆ Error_TimeBaseSourceInvalid

#define Error_TimeBaseSourceInvalid (JY9824_ErrorCodeOffset - 13)

◆ Error_TimeOut

#define Error_TimeOut (JY9824_ErrorCodeOffset - 55)

◆ Error_TriggerTypeParam

#define Error_TriggerTypeParam (JY9824_ErrorCodeOffset - 52)

◆ Error_UnSupportOperation

#define Error_UnSupportOperation (JY9824_ErrorCodeOffset - 23)

◆ Error_WriteEEPROMFailed

#define Error_WriteEEPROMFailed (JY9824_ErrorCodeOffset - 12)

◆ Error_WriteRegisterFailed

#define Error_WriteRegisterFailed (JY9824_ErrorCodeOffset - 60)

◆ ErrorTriggerDelayParam

#define ErrorTriggerDelayParam (JY9824_ErrorCodeOffset - 42)

◆ JY9824_ErrorCodeOffset

#define JY9824_ErrorCodeOffset (-10000)

◆ JYDLL_API

#define JYDLL_API

◆ JYFailed

#define JYFailed -1

◆ STDCALL [1/2]

#define STDCALL

Windows.

Linux

◆ STDCALL [2/2]

#define STDCALL

Windows.

Linux

◆ Success

#define Success 0

Typedef Documentation

◆ DeviceHandle

typedef void* DeviceHandle

Enumeration Type Documentation

◆ AcquisitionMode

enum AcquisitionMode
Enumerator
Finite_Sample
Continuous_Sample

◆ AnalogTriggerConditioning

enum AnalogTriggerConditioning
Enumerator
AnalogTriggerConditioningPowerHigh
AnalogTriggerConditioningPowerLow
AnalogTriggerConditioningEnteringWindow
AnalogTriggerConditioningLeavingWindow
AnalogTriggerConditioningRising
AnalogTriggerConditioningFalling

◆ AnalogTriggerSource

enum AnalogTriggerSource
Enumerator
AnalogTriggerSourceCH0Raw
AnalogTriggerSourceCH1Raw
AnalogTriggerSourceCH2Raw
AnalogTriggerSourceCH3Raw
AnalogTriggerSourceTriggerIn

◆ AnalogTriggerType

enum AnalogTriggerType
Enumerator
AnalogHysteresisTrigger
AnalogWindowTrigger
AnalogPowerTrigger

◆ ClockSource

enum ClockSource
Enumerator
ExternalClock0
InternalClock
ExternalClock1

◆ DataType

enum DataType
Enumerator
Real
Complex
FFT

◆ DigitalTriggerConditioning

enum DigitalTriggerConditioning
Enumerator
Rising_Edge_Trigger
Falling_Edge_Trigger
High_Level_Trigger
Low_Level_Trigger

◆ DigitalTriggerSource

enum DigitalTriggerSource
Enumerator
PFI0
PXI_Trig_0
PXI_Trig_1
PXI_Trig_2
PXI_Trig_3
PXI_Trig_4
PXI_Trig_5
PXI_Trig_6
PXI_Trig_7

◆ ExportSignalDestination

enum ExportSignalDestination
Enumerator
PXITrig_IN_0
PXITrig_IN_1
PXITrig_IN_2
PXITrig_IN_3
PXITrig_IN_4
PXITrig_IN_5
PXITrig_IN_6
PXITrig_IN_7
PFI_ui_0_0_do_IN
Rx_Engine_Real_start_trig_in
Rx_Engine_Real_reference_trig_in
Rx_Engine_Real_advance_trig_in
Rx_Engine_IQ_start_trig_in
Rx_Engine_IQ_reference_trig_in
Rx_Engine_IQ_advance_trig_in
Rx_Engine_FFT_start_trig_in
Rx_Engine_FFT_reference_trig_in
DataPackage_0_start_trig_in
FFT_Config_0_trig_in

◆ ExportSignalSource

enum ExportSignalSource
Enumerator
PXITrig_OUT_0
PXITrig_OUT_1
PXITrig_OUT_2
PXITrig_OUT_3
PXITrig_OUT_4
PXITrig_OUT_5
PXITrig_OUT_6
PXITrig_OUT_7
PFI_ui_0_0_di_OUT
TrigIn_buf_IBUF_OUT_OUT
Analog_trig_0_trig
Rx_Engine_IQ_start_trig_out
Rx_Engine_IQ_reference_trig_out
Rx_Engine_IQ_advance_trig_out
Rx_Engine_Real_start_trig_out
Rx_Engine_Real_reference_trig_out
Rx_Engine_Real_advance_trig_out

◆ InputRange

enum InputRange
Enumerator
Vpp1V
Vpp2V

◆ JY9824_FFTWindowType

enum JY9824_FFTWindowType
Enumerator
JY9824_None |
JY9824_Hanning |
JY9824_Hamming | Hanning (2-Term)
JY9824_Blackman_Harris | Hamming (2-Term)
JY9824_Exact_Blackman | Blackman Harris (3-Term)
JY9824_Blackman | Exact Blackman (3-Term)
JY9824_Three_Term_Nuttal | Blackman (3-Term)
JY9824_Three_Term_Blackman_Nuttal | 3_Term_Nuttal(3-Term with Continous First Derivative /Nuttal3a)
JY9824_Four_Term_B_Harris | 3_Term_Blackman_Nuttal(3-Term Minimum)
JY9824_Four_Term_Nuttal | 4 Term B-Harris
JY9824_Four_Term_Blackman_Nuttal | 4_Term_Nuttal(4-Term with Continous First Derivative /Nuttal4b)
JY9824_Flat_Top_95 | 4_Term_Blackman_Nuttal(4-Term Minimum)
JY9824_Flat_Top_90D | 5 - Term Flat Top(HFT95), the highest sidelobe is −95.0dB, located at f = ±7.49 bins.
JY9824_Five_Term_Least_Sidelobe | 5-Term Flat Top(HFT90D),the highest sidelobe is −90.2dB, located at f = ±5.58 bins
JY9824_Six_Term_Flat_Top | 5_Term_Least_Sidelobe(Low Sidelobe)
JY9824_Six_Term_Least_Sidelobe | 6_Term_Flat_Top(HFT116D),the highest sidelobe is −116.8dB, located at f = ±7.52 bins
JY9824_Seven_Term_Flat_Top | 6_Term_Least_Sidelobe
JY9824_Seven_Term_Least_Sidelobe | 7_Term_Flat_Top(HFT144D),the highest sidelobe is −144.1dB, located at f = ±7.07 bins.

◆ JY9824_FrequencyAlignmentMode

enum JY9824_FrequencyAlignmentMode
Enumerator
JY9824_Center
JY9824_Lower
JY9824_Upper

◆ JY9824_SpectrumAverageMode

enum JY9824_SpectrumAverageMode
Enumerator
JY9824_NoAveraging
JY9824_ExponentialAverage
JY9824_PseudoPeakHold
JY9824_PeakHold
JY9824_LinearAverage

◆ JY9824_SpectrumUnitType

enum JY9824_SpectrumUnitType
Enumerator
JY9824_dBm | dBm
JY9824_dBFS | dBFS
JY9824_dBV | dBV
JY9824_dBuV | dBuV
JY9824_V2 |

◆ SyncMode

enum SyncMode
Enumerator
SOLO
Master
Slave

◆ TriggerMode

enum TriggerMode
Enumerator
StartTrigger
ReferenceTrigger
StartAndReferenceTrigger

◆ TriggerType

enum TriggerType
Enumerator
Immediate_Trigger
Soft_Trigger
Digital_Trigger
Analog_Trigger

Function Documentation

◆ JY9824Core_CalculateCRC16()

JYDLL_API int STDCALL JY9824Core_CalculateCRC16 | ( | unsigned char * | bufData,
 |  | unsigned int | buflen,
 |  | unsigned short * | pcrc,
 |  | unsigned short | initVal,
 |  | unsigned short | polynomial )

◆ JY9824Core_Close()

JYDLL_API int STDCALL JY9824Core_Close ( int cardID )

关闭设备

Parameters
cardID cardID
Returns
成功 0；失败 ：错误码

◆ JY9824Core_Commit()

JYDLL_API int STDCALL JY9824Core_Commit ( int cardID )

提交配置

Parameters
cardID cardID
Returns
成功 0；失败 ：错误码

◆ JY9824Core_ConfigSampleRate()

JYDLL_API int STDCALL JY9824Core_ConfigSampleRate | ( | int | cardID,
 |  | double | sampleRate,
 |  | double * | actualSampleRatete,
 |  | int * | actualDecimationRatio )

设置采样率

Parameters
cardID | cardID
sampleRate | 期望的采样率
actualSampleRatete | 实际的采样率
actualDecimationRatio | 降采样倍率
Returns
成功 0；失败 ：错误码

◆ JY9824Core_EEPROM_InitializeCalibrationBlock()

JYDLL_API int STDCALL JY9824Core_EEPROM_InitializeCalibrationBlock ( int card_int )

初始化CalibrationBlock

Parameters
card_int cardID
Returns
成功 0；失败 ：错误码

◆ JY9824Core_EEPROM_InitializeIdBlock()

JYDLL_API int STDCALL JY9824Core_EEPROM_InitializeIdBlock ( int card_int )

初始化IdBlock

Parameters
card_int cardID
Returns
成功 0；失败 ：错误码

◆ JY9824Core_EEPROM_ReadCalibrationBlock()

JYDLL_API int STDCALL JY9824Core_EEPROM_ReadCalibrationBlock | ( | int | card_int,
 |  | JY9824CalibrationInfo * | cb )

读EEPROMCalibrationBlock

Parameters
card_int | cardID
EEPROMCalibrationBlock | EEPROMCalibrationBlock
Returns
成功 0；失败 ：错误码

◆ JY9824Core_EEPROM_ReadIdBlock()

JYDLL_API int STDCALL JY9824Core_EEPROM_ReadIdBlock | ( | int | card_int,
 |  | JY9824CoreDeviceInfo * | id )

读EEPROMIdBlock

Parameters
card_int | cardID
EEPROMIdBlock | EEPROMIdBlock
Returns
成功 0；失败 ：错误码

◆ JY9824Core_EEPROM_Reset()

JYDLL_API int STDCALL JY9824Core_EEPROM_Reset | ( | int | card_int,
 |  | int | val = 0,
 |  | int | beginAddr = 0,
 |  | int | endAddr = 1023 )

重置

Parameters
card_int | cardID
val | val
beginAddr | beginAddr
endAddr | endAddr
Returns
成功 0；失败 ：错误码

◆ JY9824Core_EEPROM_SerialNumber_Int2String()

JYDLL_API int STDCALL JY9824Core_EEPROM_SerialNumber_Int2String | ( | int | serialNumberInt,
 |  | char * | serialNumberString )

序列号转序列字符

Parameters
card_int | cardID
serialNumberInt | serialNumberInt
serialNumberString | serialNumberString
Returns
成功 0；失败 ：错误码

◆ JY9824Core_EEPROM_SerialNumber_String2Int()

JYDLL_API int STDCALL JY9824Core_EEPROM_SerialNumber_String2Int | ( | const char *const | serialNumberString,
 |  | int * | serialNumberInt )

序列字符转序列号

Parameters
card_int | cardID
serialNumberString | serialNumberString
serialNumberInt | serialNumberInt
Returns
成功 0；失败 ：错误码

◆ JY9824Core_EEPROM_WriteCalibrationBlock()

JYDLL_API int STDCALL JY9824Core_EEPROM_WriteCalibrationBlock | ( | int | card_int,
 |  | JY9824CalibrationInfo * | cb )

写EEPROMCalibrationBlock

Parameters
card_int | cardID
EEPROMCalibrationBlock | EEPROMCalibrationBlock
Returns
成功 0；失败 ：错误码

◆ JY9824Core_EEPROM_WriteIdBlock()

JYDLL_API int STDCALL JY9824Core_EEPROM_WriteIdBlock | ( | int | card_int,
 |  | JY9824CoreDeviceInfo * | id )

写EEPROMIdBlock

Parameters
card_int | cardID
EEPROMIdBlock | EEPROMIdBlock
Returns
成功 0；失败 ：错误码

◆ JY9824Core_ExportSignal()

JYDLL_API int STDCALL JY9824Core_ExportSignal | ( | int | cardID,
 |  | ExportSignalSource | source,
 |  | ExportSignalDestination | destination )

导出信号配置

Parameters
cardID | cardID
source | 导出信号的源
destination | 导出信号的目标端口
Returns
成功 0；失败 ：错误码

◆ JY9824Core_FFT_CheckBufferStatus()

JYDLL_API int STDCALL JY9824Core_FFT_CheckBufferStatus | ( | int | cardID,
 |  | unsigned long long * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | bool * | overrun )

Check AI device buffer status.

Parameters
hDevice | device handle
avaliableSamples | number of samples per channel in the device buffer
transferedSamples | The number of samples that have been transfered from the device buffer (per channel)
overrun | true if overflow, false if not overflow.
Returns
0 if success or other error code

◆ JY9824Core_FFT_ConfigSpectrumAverageParam()

JYDLL_API int STDCALL JY9824Core_FFT_ConfigSpectrumAverageParam | ( | int | cardID,
 |  | JY9824_SpectrumAverageMode | averageMode,
 |  | int | averageSize,
 |  | double | timeConstant )

Config Spectrum Average param.

Parameters
hDevice | device handle
averageMode | Spectrum averageing mode.
averageSize | Average Size.only valid in averageMode is JY9824_LinearAverage or JY9824_PeakHold
timeConstant | Exponential weighting time constant, (0, 1], the α in formula: Y[n] = α* x[n] + (1 - α) * Y[n - 1], only valid in averageMode is JY9824_ExponentialAverage or JY9824_PseudoPeakHold
Returns
0 if success or other error code

◆ JY9824Core_FFT_ConfigSpectrumParam()

JYDLL_API int STDCALL JY9824Core_FFT_ConfigSpectrumParam | ( | int | cardID,
 |  | double | centerFrequency,
 |  | JY9824_FrequencyAlignmentMode | freAlignmentMode,
 |  | double | expectBandwidth,
 |  | double | expectNumOfSpectralLines,
 |  | JY9824_FFTWindowType | windowType,
 |  | JY9824_SpectrumUnitType | uintType,
 |  | bool | isPSD )

Config spectrum param.

Parameters
hDevice | device handle
centerFrequency | array[channelCount] of centerFrequency.
expectBandwidth | expect bandwidth, Hz
expectNumOfSpectralLines | expect number of spectral lines within bandwidth, Hz.
windowType | FFT window type.
uintType | Unit type.
isPSD | whether convert to Power Spectral Density.
Returns
0 if success or other error code

◆ JY9824Core_FFT_GetSpectralInformation()

JYDLL_API int STDCALL JY9824Core_FFT_GetSpectralInformation | ( | int | cardID,
 |  | JY9824_SpectralInformation * | spectralInformation )

Config Spectrum Average param.

When after JY9824Core_FFT_Start used.

Parameters
hDevice | device handle
spectralInformation | Spectral Information.
Returns
0 if success or other error code

◆ JY9824Core_FFT_ReadData()

JYDLL_API int STDCALL JY9824Core_FFT_ReadData | ( | int | cardID,
 |  | float * | dataBuffer,
 |  | unsigned int | samplesToRead,
 |  | int | timeout,
 |  | unsigned int * | actualSamples )

Read AI data to user defined data buffer.

For the multi-channel acquisition, the data is interleaved in the order defined by JY9824Core_EnableChannel.

Parameters
hDevice | device handle
dataBuffer | user buffer,the buffer size must be greater than or equal to dataLength*channelCount.
dataLength | number of samples per channel
timeOut | timeout time in microsecond
actualReadLength | returns the number of samples per channel actually read
Returns
0 if success or other error code

◆ JY9824Core_FFT_SendSoftTrigger()

JYDLL_API int STDCALL JY9824Core_FFT_SendSoftTrigger ( int cardID )

Send soft trigger.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY9824Core_FFT_Start()

JYDLL_API int STDCALL JY9824Core_FFT_Start ( int cardID )

Start AI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY9824Core_FFT_Stop()

JYDLL_API int STDCALL JY9824Core_FFT_Stop ( int cardID )

Stop AI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JY9824Core_GetAcquisitionStatus()

JYDLL_API int STDCALL JY9824Core_GetAcquisitionStatus | ( | int | cardID,
 |  | bool * | isOverFlow,
 |  | unsigned long long * | availableSamples )

获取采集状态，ReTriggerCount=1时有效

Parameters
cardID | cardID
isOverFlow | 是否溢出
availableSamples | 可读取点数
Returns
成功 0；失败 ：错误码

◆ JY9824Core_GetDeviceList()

JYDLL_API int STDCALL JY9824Core_GetDeviceList | ( | JY9824DeviceInfo | deviceInfo[],
 |  | int | deviceInfoLength )

获取所有设备

Parameters
deviceInfo | 卡槽号
deviceInfoLength | cardID
Returns
成功 0；失败 ：错误码

◆ JY9824Core_GetLastError()

JYDLL_API int STDCALL JY9824Core_GetLastError | ( | int | cardID,
 |  | char * | message,
 |  | int * | errorCode )

获取最后一次错误信息

Parameters
cardID | cardID
errorCode | 错误码
msg | 错误信息
Returns
成功 0；失败 ：错误码

◆ JY9824Core_GetReTriggerStatus()

JYDLL_API int STDCALL JY9824Core_GetReTriggerStatus | ( | int | cardID,
 |  | bool * | isOverFlow,
 |  | unsigned long long * | remainingCounts,
 |  | unsigned long long * | completedCounts )

获取采集状态

Parameters
cardID | cardID
isOverFlow | 是否溢出
remainingCounts | 还未完成的触发次数
completedCounts | 已经完成触发次数
Returns
成功 0；失败 ：错误码

◆ JY9824Core_GetScaleFactor()

JYDLL_API int STDCALL JY9824Core_GetScaleFactor | ( | int | cardID,
 |  | double * | scaleFactor )

获取电平因子

Parameters
cardID | cardID
scaleFactor | 电平因子，长度等于通道个数
Returns
成功 0；失败 ：错误码

◆ JY9824Core_GetTemperature()

JYDLL_API int STDCALL JY9824Core_GetTemperature | ( | int | cardID,
 |  | double * | cardTemp,
 |  | double * | fpgaTemp = NULL )

获取板卡温度

Parameters
cardID | cardID
cardTemp | 温度传感器温度
fpgaTemp | FPGA芯片内部温度
Returns
成功 0；失败 ：错误码

◆ JY9824Core_Open()

JYDLL_API int STDCALL JY9824Core_Open | ( | int | slotNumber,
 |  | int * | cardID )

打开设备

Parameters
slotNumber | 卡槽号
cardID | cardID
Returns
成功 0；失败 ：错误码

◆ JY9824Core_Open_WithAliasName()

JYDLL_API int STDCALL JY9824Core_Open_WithAliasName | ( | const char * | aliasName,
 |  | int * | cardID )

打开设备

Parameters
aliasName | 设备别名
cardID | cardID
Returns
成功 0；失败 ：错误码

◆ JY9824Core_ReadDataBinary16()

JYDLL_API int STDCALL JY9824Core_ReadDataBinary16 | ( | int | cardID,
 |  | short * | dataBuffer,
 |  | unsigned int | samplesToRead,
 |  | unsigned int * | actualSamples,
 |  | double * | scaleFactor,
 |  | int | timeout )

读数据

Parameters
cardID cardID

Parameters
dataBuffer | 数据指针
samplesToRead | 每通道需要读取的点数，使用重触发时，需要读的点数必须是设置的每通道需要采集点数的整数倍
scaleFactor | 量化因子
isOverLoad | ADC是否过载
timeout | 超时时间
Returns
成功 0；失败 ：错误码

◆ JY9824Core_ReadDataDbl64()

JYDLL_API int STDCALL JY9824Core_ReadDataDbl64 | ( | int | cardID,
 |  | double * | dataBuffer,
 |  | unsigned int | samplesToRead,
 |  | int | timeout )

读double数据

Parameters
cardID cardID

Parameters
dataBuffer | 数据指针
samplesToRead | 每通道需要读取的点数
timeout | 超时时间
Returns
成功 0；失败 ：错误码

◆ JY9824Core_SendSoftwareTrigger()

JYDLL_API int STDCALL JY9824Core_SendSoftwareTrigger ( int cardID )

发送软件触发

Parameters
cardID cardID

Returns
成功 0；失败 ：错误码

◆ JY9824Core_SetAcquisitionMode()

JYDLL_API int STDCALL JY9824Core_SetAcquisitionMode | ( | int | cardID,
 |  | AcquisitionMode | acquisitionMode )

设置采集模式

Parameters
cardID | cardID
acquisitionMode | 采集模式,有限点/连续
Returns
成功 0；失败 ：错误码

◆ JY9824Core_SetAnalogTrigger()

JYDLL_API int STDCALL JY9824Core_SetAnalogTrigger | ( | int | cardID,
 |  | AnalogTriggerType | analogTriggerType,
 |  | AnalogTriggerSource | analogTriggerSource,
 |  | AnalogTriggerConditioning | analogTriggerConditioning,
 |  | double | highThreshold,
 |  | double | lowThreshold )

设置模拟触发类型

Parameters
cardID | cardID
analogTriggerType | 触发类型
analogTriggerSource | 触发源
highThreshold | 阈值上限，归一化值,其中 1 对应满量程的正值
lowThreshold | 阈值下限，归一化值，其中 -1 对应满量程的负值
Returns
成功 0；失败 ：错误码

◆ JY9824Core_SetBufferLength()

JYDLL_API int STDCALL JY9824Core_SetBufferLength | ( | int | cardID,
 |  | unsigned int | length )

设置缓冲区大小，ReTriggerCount=1时有效

Parameters
cardID cardID

Parameters
length 长度,单位字节
Returns
成功 0；失败 ：错误码

◆ JY9824Core_SetCalEnable()

JYDLL_API int STDCALL JY9824Core_SetCalEnable | ( | int | cardID,
 |  | bool | enbale )

设置校准使能

Parameters
cardID | cardID
enbale | 使能
Returns
成功 0；失败 ：错误码

◆ JY9824Core_SetDataType()

JYDLL_API int STDCALL JY9824Core_SetDataType | ( | int | cardID,
 |  | DataType | dataType )

设置数据类型

Parameters
cardID | cardID
dataType | 数据类型,实数/IQ
Returns
成功 0；失败 ：错误码

◆ JY9824Core_SetDDCParam()

JYDLL_API int STDCALL JY9824Core_SetDDCParam | ( | int | cardID,
 |  | int | channelMask,
 |  | double | frequency,
 |  | double * | actualFreq,
 |  | int | digitalgain = 0 )

设置DDC参数

Parameters
cardID | cardID
channelMask | 通道掩码
frequency | 中心频率
digitalgain | 数字增益，左移位数
Returns
成功 0；失败 ：错误码

◆ JY9824Core_SetDigitalTrigger()

JYDLL_API int STDCALL JY9824Core_SetDigitalTrigger | ( | int | cardID,
 |  | DigitalTriggerConditioning | digitalTriggerType,
 |  | DigitalTriggerSource | digitalTriggerSource )

设置数字触发类型

Parameters
cardID | cardID
digitalTriggerType | 触发类型
digitalTriggerSource | 触发源
Returns
成功 0；失败 ：错误码

◆ JY9824Core_SetEnabledChannels()

JYDLL_API int STDCALL JY9824Core_SetEnabledChannels | ( | int | cardID,
 |  | int | channelMask )

设置使能通道

Parameters
cardID | cardID
channelMask | 通道掩码，如ch1、2需要配置，则设置为0x3
dataType | 数据类型，实数或者IQ
centerFreqOption | 中频频率挡位
Returns
成功 0；失败 ：错误码

◆ JY9824Core_SetInputRange()

JYDLL_API int STDCALL JY9824Core_SetInputRange | ( | int | cardID,
 |  | int | chnID,
 |  | InputRange | range )

设置输入量程挡位

Parameters
cardID | cardID
range0 | 挡位
Returns
成功 0；失败 ：错误码

◆ JY9824Core_SetPreTriggerSamples()

JYDLL_API int STDCALL JY9824Core_SetPreTriggerSamples | ( | int | cardID,
 |  | unsigned int | preTriggerSamples )

设置预触发点数

Parameters
cardID | cardID
preTriggerSamples | 预触发点数
Returns
成功 0；失败 ：错误码

◆ JY9824Core_SetReferenceClockParam()

JYDLL_API int STDCALL JY9824Core_SetReferenceClockParam | ( | int | cardID,
 |  | ClockSource | clockSource,
 |  | double | freqOption = 10e6 )

设置参考时钟和参考时钟的频率

Parameters
cardID | cardID
freqOption | 频率挡位，0：10M，1：100M
Returns
成功 0；失败 ：错误码

◆ JY9824Core_SetReTriggerParam()

JYDLL_API int STDCALL JY9824Core_SetReTriggerParam | ( | int | cardID,
 |  | unsigned long long | reTriggerCounts,
 |  | double | autoTriggerTime = -1.0,
 |  | double | holdOffTime = 1 )

设置重触发参数

Parameters
cardID | cardID
reTriggerCounts | 重触发次数
autoTriggerTime | 两个trigger间隔的最大时间，超时之后自动触发，-1为永久等待,单位us
HoldOffTime | 两个trigger间隔的最小时间长度，在HOLD_OFF这段时间内，不允许接收新的trigger信号,单位us
Returns
成功 0；失败 ：错误码

◆ JY9824Core_SetSamplesToAcquire()

JYDLL_API int STDCALL JY9824Core_SetSamplesToAcquire | ( | int | cardID,
 |  | int | samplesToAcquire )

设置采集点数，有限点模式下有效

Parameters
cardID | cardID
samplesToAcquire | 采集点数
Returns
成功 0；失败 ：错误码

◆ JY9824Core_SetSyncMode()

JYDLL_API int STDCALL JY9824Core_SetSyncMode | ( | int | cardID,
 |  | SyncMode | syncMode )

设置多卡同步的参数

Parameters
cardID | cardID
enable | 使能多卡同步
syncMode | 同步模式
src | 输出源，仅master模式有效
enable | 输入源，仅slave模式有效
Returns
成功 0；失败 ：错误码

◆ JY9824Core_SetTriggerType()

JYDLL_API int STDCALL JY9824Core_SetTriggerType | ( | int | cardID,
 |  | TriggerType | triggerType )

设置触发类型

Parameters
cardID | cardID
triggerType | 触发类型：立即触发、软件触发、数字触发、模拟触发
Returns
成功 0；失败 ：错误码

◆ JY9824Core_Start()

JYDLL_API int STDCALL JY9824Core_Start ( int cardID )

开始

Parameters
cardID cardID
Returns
成功 0；失败 ：错误码

◆ JY9824Core_Stop()

JYDLL_API int STDCALL JY9824Core_Stop ( int cardID )

停止

Parameters
cardID cardID
Returns
成功 0；失败 ：错误码

◆ JY9824Core_WaitForAcqComplete()

JYDLL_API int STDCALL JY9824Core_WaitForAcqComplete | ( | int | cardID,
 |  | int | timeout,
 |  | bool * | complete )

等待采集完成

Parameters
cardID | cardID
timeout | 超时
complete | 是否完成采集
Returns
成功 0；失败 ：错误码
Generated by doxygen 1.12.0


9824 C++ Programming Manual: Class List

  • Class List
  • Class Index
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
C JY9824_SpectralInformation
C JY9824CalibrationConstant
C JY9824CalibrationInfo
C JY9824CoreDeviceInfo
C JY9824DeviceInfo


9824 C++ Programming Manual: Class Index

  • Class List
  • Class Index
  • Class Members
Class Index
J
J
JY9824_SpectralInformation
JY9824CalibrationConstant
JY9824CalibrationInfo
JY9824CoreDeviceInfo
JY9824DeviceInfo


9824 C++ Programming Manual: D:/9824 Directory Reference

  • File Members
  • 9824
9824 Directory Reference

Directories

C++


9824 C++ Programming Manual: D:/9824/C++ Directory Reference

  • 9824
  • C++
C++ Directory Reference

Files

JY9824Core.h


9824 C++ Programming Manual: File List

File List
Here is a list of all files with brief descriptions:
[detail level 123]
▼ 9824
▼ C++
JY9824Core.h


9824 C++ Programming Manual: Class Members

  • Class List
  • Class Index
  • Class Members
  • All
  • Variables
  • a
  • c
  • d
  • e
  • f
  • h
  • i
  • m
  • n
  • p
  • r
  • s
  • u
Here is a list of all class members with links to the classes they belong to:

- a -

  • AI_CH0_Range0_b : JY9824CalibrationConstant
  • AI_CH0_Range0_k : JY9824CalibrationConstant
  • AI_CH0_Range1_b : JY9824CalibrationConstant
  • AI_CH0_Range1_k : JY9824CalibrationConstant
  • AI_CH1_Range0_b : JY9824CalibrationConstant
  • AI_CH1_Range0_k : JY9824CalibrationConstant
  • AI_CH1_Range1_b : JY9824CalibrationConstant
  • AI_CH1_Range1_k : JY9824CalibrationConstant
  • AI_CH2_Range0_b : JY9824CalibrationConstant
  • AI_CH2_Range0_k : JY9824CalibrationConstant
  • AI_CH2_Range1_b : JY9824CalibrationConstant
  • AI_CH2_Range1_k : JY9824CalibrationConstant
  • AI_CH3_Range0_b : JY9824CalibrationConstant
  • AI_CH3_Range0_k : JY9824CalibrationConstant
  • AI_CH3_Range1_b : JY9824CalibrationConstant
  • AI_CH3_Range1_k : JY9824CalibrationConstant
  • aliasName : JY9824DeviceInfo

- c -

  • CalibrationAddr : JY9824CoreDeviceInfo
  • CalibrationCRC16 : JY9824CalibrationInfo
  • CalibrationDataAddress : JY9824CalibrationInfo
  • CalibrationSize : JY9824CalibrationInfo
  • CalibrationTemperature : JY9824CalibrationInfo
  • CalibrationTimeStamp : JY9824CalibrationInfo
  • CenterFrequency : JY9824_SpectralInformation
  • ConstantList : JY9824CalibrationInfo

- d -

  • DriverSetVer : JY9824DeviceInfo

- e -

  • EEPROMSize : JY9824CoreDeviceInfo
  • ENBW : JY9824_SpectralInformation

- f -

  • FftLength : JY9824_SpectralInformation
  • FftWindowType : JY9824_SpectralInformation
  • FirmwareVer : JY9824DeviceInfo
  • FrameworkVer : JY9824DeviceInfo
  • FrequencyStart : JY9824_SpectralInformation
  • FrequencyStep : JY9824_SpectralInformation

- h -

  • HardwareVer : JY9824DeviceInfo
  • HWRev : JY9824CoreDeviceInfo

- i -

  • IsPsd : JY9824_SpectralInformation

- m -

  • Model : JY9824CoreDeviceInfo
  • model : JY9824DeviceInfo

- n -

  • NumOfSpectralLines : JY9824_SpectralInformation

- p -

  • ProductionDate : JY9824CoreDeviceInfo, JY9824DeviceInfo

- r -

  • Reserved : JY9824CoreDeviceInfo
  • ResolutionBandwidth : JY9824_SpectralInformation

- s -

  • SerialNumber : JY9824CoreDeviceInfo
  • serialNumber : JY9824DeviceInfo
  • slotNumber : JY9824DeviceInfo
  • StartSentinel : JY9824CoreDeviceInfo

- u -

  • UnitType : JY9824_SpectralInformation


9824 C++ Programming Manual: Class Members - Variables

  • Class List
  • Class Index
  • Class Members
  • All
  • Variables
  • a
  • c
  • d
  • e
  • f
  • h
  • i
  • m
  • n
  • p
  • r
  • s
  • u
Here is a list of all variables with links to the classes they belong to:

- a -

  • AI_CH0_Range0_b : JY9824CalibrationConstant
  • AI_CH0_Range0_k : JY9824CalibrationConstant
  • AI_CH0_Range1_b : JY9824CalibrationConstant
  • AI_CH0_Range1_k : JY9824CalibrationConstant
  • AI_CH1_Range0_b : JY9824CalibrationConstant
  • AI_CH1_Range0_k : JY9824CalibrationConstant
  • AI_CH1_Range1_b : JY9824CalibrationConstant
  • AI_CH1_Range1_k : JY9824CalibrationConstant
  • AI_CH2_Range0_b : JY9824CalibrationConstant
  • AI_CH2_Range0_k : JY9824CalibrationConstant
  • AI_CH2_Range1_b : JY9824CalibrationConstant
  • AI_CH2_Range1_k : JY9824CalibrationConstant
  • AI_CH3_Range0_b : JY9824CalibrationConstant
  • AI_CH3_Range0_k : JY9824CalibrationConstant
  • AI_CH3_Range1_b : JY9824CalibrationConstant
  • AI_CH3_Range1_k : JY9824CalibrationConstant
  • aliasName : JY9824DeviceInfo

- c -

  • CalibrationAddr : JY9824CoreDeviceInfo
  • CalibrationCRC16 : JY9824CalibrationInfo
  • CalibrationDataAddress : JY9824CalibrationInfo
  • CalibrationSize : JY9824CalibrationInfo
  • CalibrationTemperature : JY9824CalibrationInfo
  • CalibrationTimeStamp : JY9824CalibrationInfo
  • CenterFrequency : JY9824_SpectralInformation
  • ConstantList : JY9824CalibrationInfo

- d -

  • DriverSetVer : JY9824DeviceInfo

- e -

  • EEPROMSize : JY9824CoreDeviceInfo
  • ENBW : JY9824_SpectralInformation

- f -

  • FftLength : JY9824_SpectralInformation
  • FftWindowType : JY9824_SpectralInformation
  • FirmwareVer : JY9824DeviceInfo
  • FrameworkVer : JY9824DeviceInfo
  • FrequencyStart : JY9824_SpectralInformation
  • FrequencyStep : JY9824_SpectralInformation

- h -

  • HardwareVer : JY9824DeviceInfo
  • HWRev : JY9824CoreDeviceInfo

- i -

  • IsPsd : JY9824_SpectralInformation

- m -

  • Model : JY9824CoreDeviceInfo
  • model : JY9824DeviceInfo

- n -

  • NumOfSpectralLines : JY9824_SpectralInformation

- p -

  • ProductionDate : JY9824CoreDeviceInfo, JY9824DeviceInfo

- r -

  • Reserved : JY9824CoreDeviceInfo
  • ResolutionBandwidth : JY9824_SpectralInformation

- s -

  • SerialNumber : JY9824CoreDeviceInfo
  • serialNumber : JY9824DeviceInfo
  • slotNumber : JY9824DeviceInfo
  • StartSentinel : JY9824CoreDeviceInfo

- u -

  • UnitType : JY9824_SpectralInformation


9824 C++ Programming Manual: File Members

  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • c
  • d
  • e
  • f
  • h
  • i
  • j
  • l
  • m
  • p
  • r
  • s
  • t
  • v
Here is a list of all file members with links to the files they belong to:

- a -

  • AcquisitionMode : JY9824Core.h
  • Analog_trig_0_trig : JY9824Core.h
  • Analog_Trigger : JY9824Core.h
  • AnalogHysteresisTrigger : JY9824Core.h
  • AnalogPowerTrigger : JY9824Core.h
  • AnalogTriggerConditioning : JY9824Core.h
  • AnalogTriggerConditioningEnteringWindow : JY9824Core.h
  • AnalogTriggerConditioningFalling : JY9824Core.h
  • AnalogTriggerConditioningLeavingWindow : JY9824Core.h
  • AnalogTriggerConditioningPowerHigh : JY9824Core.h
  • AnalogTriggerConditioningPowerLow : JY9824Core.h
  • AnalogTriggerConditioningRising : JY9824Core.h
  • AnalogTriggerSource : JY9824Core.h
  • AnalogTriggerSourceCH0Raw : JY9824Core.h
  • AnalogTriggerSourceCH1Raw : JY9824Core.h
  • AnalogTriggerSourceCH2Raw : JY9824Core.h
  • AnalogTriggerSourceCH3Raw : JY9824Core.h
  • AnalogTriggerSourceTriggerIn : JY9824Core.h
  • AnalogTriggerType : JY9824Core.h
  • AnalogWindowTrigger : JY9824Core.h


  • Typedefs
  • Enumerations
  • Enumerator
  • Macros
  • a
  • c
  • d
  • e
  • f
  • h
  • i
  • j
  • l
  • m
  • p
  • r
  • s
  • t
  • v
Here is a list of all file members with links to the files they belong to:

- c -

  • CCALL : JY9824Core.h
  • ClockSource : JY9824Core.h
  • Complex : JY9824Core.h
  • Continuous_Sample : JY9824Core.h


  • Enumerations
  • Enumerator
  • Macros
  • a
  • c
  • d
  • e
  • f
  • h
  • i
  • j
  • l
  • m
  • p
  • r
  • s
  • t
  • v
Here is a list of all file members with links to the files they belong to:

- d -

  • DataPackage_0_start_trig_in : JY9824Core.h
  • DataType : JY9824Core.h
  • DeviceHandle : JY9824Core.h
  • Digital_Trigger : JY9824Core.h
  • DigitalTriggerConditioning : JY9824Core.h
  • DigitalTriggerSource : JY9824Core.h


  • Enumerations
  • Enumerator
  • Macros
  • c
  • e
  • j
  • s
Here is a list of all macros with links to the files they belong to:

- c -

  • CCALL : JY9824Core.h

- e -

  • EEPROM_REG_WRITE_FAILED : JY9824Core.h
  • Error_ActiveDeviceFailed : JY9824Core.h
  • Error_AnalogTriggerConditioningParam : JY9824Core.h
  • Error_AnnalogTriggerParam : JY9824Core.h
  • Error_AnnalogTriggerThreshold : JY9824Core.h
  • Error_AutoTriggerTimeParam : JY9824Core.h
  • Error_BufferLengthParam : JY9824Core.h
  • Error_ChannelID : JY9824Core.h
  • Error_CLKMuxSelectFailed : JY9824Core.h
  • Error_CloseDeviceFailed : JY9824Core.h
  • Error_ConfigChannelIDOutOfRange : JY9824Core.h
  • Error_DACx0501_GetChipID : JY9824Core.h
  • Error_DataType : JY9824Core.h
  • Error_DeviceHandleInvalid : JY9824Core.h
  • Error_DeviceNameInvalid : JY9824Core.h
  • Error_DeviceNoOpened : JY9824Core.h
  • Error_DeviceNumberInvalid : JY9824Core.h
  • Error_DevicePropertyInvalid : JY9824Core.h
  • Error_DeviceSlotNumberInvalid : JY9824Core.h
  • Error_DigitalTriggerParam : JY9824Core.h
  • Error_EEPROMCalCRCFailed : JY9824Core.h
  • Error_EEPROMCalOutOfRange : JY9824Core.h
  • Error_ExportSignalCannotRepeatConfig : JY9824Core.h
  • Error_GetDeviceAttributeFailed : JY9824Core.h
  • Error_GetDeviceCalibrationDataFailed : JY9824Core.h
  • Error_GetDevInfoFailed : JY9824Core.h
  • Error_GetLMK048xxPLLType : JY9824Core.h
  • Error_HoldOffTimeParam : JY9824Core.h
  • Error_InitalDeviceFailed : JY9824Core.h
  • Error_InitalEEPROMFailed : JY9824Core.h
  • Error_InitLMK048xxPLL : JY9824Core.h
  • Error_InputRange : JY9824Core.h
  • Error_InternalError : JY9824Core.h
  • Error_InvalidADCInputRange : JY9824Core.h
  • Error_InvalidAverageSize : JY9824Core.h
  • Error_InvalidChannelID : JY9824Core.h
  • Error_InvalidDataRate : JY9824Core.h
  • Error_InvalidDigitalGain : JY9824Core.h
  • Error_InvalidInternalRefClock : JY9824Core.h
  • Error_InvalidOverRangeBufferLength : JY9824Core.h
  • Error_InvalidParam : JY9824Core.h
  • Error_InvalidPhysicalCenterFreq : JY9824Core.h
  • Error_InvalidSampleClock : JY9824Core.h
  • Error_InvalidSamplesToRead : JY9824Core.h
  • Error_InvalidTriggerType : JY9824Core.h
  • Error_InvalidWBIQChannelEnableBufferLength : JY9824Core.h
  • Error_JESD204_GetStatus : JY9824Core.h
  • Error_JESD204_PHY_GetPllStatus : JY9824Core.h
  • Error_LMK048xxPLL_LockFailed : JY9824Core.h
  • Error_MallocMemoryFailed : JY9824Core.h
  • Error_NumOfWBIQAcqSamplesIsZero : JY9824Core.h
  • Error_OpenDeviceFailed : JY9824Core.h
  • Error_ParamInvalid : JY9824Core.h
  • Error_PLLCrashed : JY9824Core.h
  • Error_PLLLockFailed : JY9824Core.h
  • Error_PLLOutputFreqOutOfRange : JY9824Core.h
  • Error_PLLSetFailed : JY9824Core.h
  • Error_PointerNotNull : JY9824Core.h
  • Error_PreTriggerSamplesParam : JY9824Core.h
  • Error_ReadEEPROMFailed : JY9824Core.h
  • Error_ReleaseDeviceResourceFailed : JY9824Core.h
  • Error_ReTriggerCountsNotMatchSampleMode : JY9824Core.h
  • Error_ReTriggerCountsParam : JY9824Core.h
  • Error_RxInitFailed : JY9824Core.h
  • Error_SampleModeParam : JY9824Core.h
  • Error_SamplesParam : JY9824Core.h
  • Error_SetDeviceAttributeFailed : JY9824Core.h
  • Error_TaskIsStartDonotAllowConfig : JY9824Core.h
  • Error_TimeBaseSourceInvalid : JY9824Core.h
  • Error_TimeOut : JY9824Core.h
  • Error_TriggerTypeParam : JY9824Core.h
  • Error_UnSupportOperation : JY9824Core.h
  • Error_WriteEEPROMFailed : JY9824Core.h
  • Error_WriteRegisterFailed : JY9824Core.h
  • ErrorTriggerDelayParam : JY9824Core.h

- j -

  • JY9824_ErrorCodeOffset : JY9824Core.h
  • JYDLL_API : JY9824Core.h
  • JYFailed : JY9824Core.h

- s -

  • STDCALL : JY9824Core.h
  • Success : JY9824Core.h


  • Enumerations
  • Enumerator
  • Macros
  • a
  • c
  • d
  • e
  • f
  • h
  • i
  • j
  • l
  • m
  • p
  • r
  • s
  • t
  • v
Here is a list of all file members with links to the files they belong to:

- e -

  • EEPROM_REG_WRITE_FAILED : JY9824Core.h
  • Error_ActiveDeviceFailed : JY9824Core.h
  • Error_AnalogTriggerConditioningParam : JY9824Core.h
  • Error_AnnalogTriggerParam : JY9824Core.h
  • Error_AnnalogTriggerThreshold : JY9824Core.h
  • Error_AutoTriggerTimeParam : JY9824Core.h
  • Error_BufferLengthParam : JY9824Core.h
  • Error_ChannelID : JY9824Core.h
  • Error_CLKMuxSelectFailed : JY9824Core.h
  • Error_CloseDeviceFailed : JY9824Core.h
  • Error_ConfigChannelIDOutOfRange : JY9824Core.h
  • Error_DACx0501_GetChipID : JY9824Core.h
  • Error_DataType : JY9824Core.h
  • Error_DeviceHandleInvalid : JY9824Core.h
  • Error_DeviceNameInvalid : JY9824Core.h
  • Error_DeviceNoOpened : JY9824Core.h
  • Error_DeviceNumberInvalid : JY9824Core.h
  • Error_DevicePropertyInvalid : JY9824Core.h
  • Error_DeviceSlotNumberInvalid : JY9824Core.h
  • Error_DigitalTriggerParam : JY9824Core.h
  • Error_EEPROMCalCRCFailed : JY9824Core.h
  • Error_EEPROMCalOutOfRange : JY9824Core.h
  • Error_ExportSignalCannotRepeatConfig : JY9824Core.h
  • Error_GetDeviceAttributeFailed : JY9824Core.h
  • Error_GetDeviceCalibrationDataFailed : JY9824Core.h
  • Error_GetDevInfoFailed : JY9824Core.h
  • Error_GetLMK048xxPLLType : JY9824Core.h
  • Error_HoldOffTimeParam : JY9824Core.h
  • Error_InitalDeviceFailed : JY9824Core.h
  • Error_InitalEEPROMFailed : JY9824Core.h
  • Error_InitLMK048xxPLL : JY9824Core.h
  • Error_InputRange : JY9824Core.h
  • Error_InternalError : JY9824Core.h
  • Error_InvalidADCInputRange : JY9824Core.h
  • Error_InvalidAverageSize : JY9824Core.h
  • Error_InvalidChannelID : JY9824Core.h
  • Error_InvalidDataRate : JY9824Core.h
  • Error_InvalidDigitalGain : JY9824Core.h
  • Error_InvalidInternalRefClock : JY9824Core.h
  • Error_InvalidOverRangeBufferLength : JY9824Core.h
  • Error_InvalidParam : JY9824Core.h
  • Error_InvalidPhysicalCenterFreq : JY9824Core.h
  • Error_InvalidSampleClock : JY9824Core.h
  • Error_InvalidSamplesToRead : JY9824Core.h
  • Error_InvalidTriggerType : JY9824Core.h
  • Error_InvalidWBIQChannelEnableBufferLength : JY9824Core.h
  • Error_JESD204_GetStatus : JY9824Core.h
  • Error_JESD204_PHY_GetPllStatus : JY9824Core.h
  • Error_LMK048xxPLL_LockFailed : JY9824Core.h
  • Error_MallocMemoryFailed : JY9824Core.h
  • Error_NumOfWBIQAcqSamplesIsZero : JY9824Core.h
  • Error_OpenDeviceFailed : JY9824Core.h
  • Error_ParamInvalid : JY9824Core.h
  • Error_PLLCrashed : JY9824Core.h
  • Error_PLLLockFailed : JY9824Core.h
  • Error_PLLOutputFreqOutOfRange : JY9824Core.h
  • Error_PLLSetFailed : JY9824Core.h
  • Error_PointerNotNull : JY9824Core.h
  • Error_PreTriggerSamplesParam : JY9824Core.h
  • Error_ReadEEPROMFailed : JY9824Core.h
  • Error_ReleaseDeviceResourceFailed : JY9824Core.h
  • Error_ReTriggerCountsNotMatchSampleMode : JY9824Core.h
  • Error_ReTriggerCountsParam : JY9824Core.h
  • Error_RxInitFailed : JY9824Core.h
  • Error_SampleModeParam : JY9824Core.h
  • Error_SamplesParam : JY9824Core.h
  • Error_SetDeviceAttributeFailed : JY9824Core.h
  • Error_TaskIsStartDonotAllowConfig : JY9824Core.h
  • Error_TimeBaseSourceInvalid : JY9824Core.h
  • Error_TimeOut : JY9824Core.h
  • Error_TriggerTypeParam : JY9824Core.h
  • Error_UnSupportOperation : JY9824Core.h
  • Error_WriteEEPROMFailed : JY9824Core.h
  • Error_WriteRegisterFailed : JY9824Core.h
  • ErrorTriggerDelayParam : JY9824Core.h
  • ExportSignalDestination : JY9824Core.h
  • ExportSignalSource : JY9824Core.h
  • ExternalClock0 : JY9824Core.h
  • ExternalClock1 : JY9824Core.h


  • Enumerations
  • Enumerator
  • Macros
Here is a list of all enums with links to the files they belong to:
  • AcquisitionMode : JY9824Core.h
  • AnalogTriggerConditioning : JY9824Core.h
  • AnalogTriggerSource : JY9824Core.h
  • AnalogTriggerType : JY9824Core.h
  • ClockSource : JY9824Core.h
  • DataType : JY9824Core.h
  • DigitalTriggerConditioning : JY9824Core.h
  • DigitalTriggerSource : JY9824Core.h
  • ExportSignalDestination : JY9824Core.h
  • ExportSignalSource : JY9824Core.h
  • InputRange : JY9824Core.h
  • JY9824_FFTWindowType : JY9824Core.h
  • JY9824_FrequencyAlignmentMode : JY9824Core.h
  • JY9824_SpectrumAverageMode : JY9824Core.h
  • JY9824_SpectrumUnitType : JY9824Core.h
  • SyncMode : JY9824Core.h
  • TriggerMode : JY9824Core.h
  • TriggerType : JY9824Core.h


  • Enumerations
  • Enumerator
  • Macros
  • a
  • c
  • d
  • e
  • f
  • h
  • i
  • j
  • l
  • m
  • p
  • r
  • s
  • t
  • v
Here is a list of all enum values with links to the files they belong to:

- a -

  • Analog_trig_0_trig : JY9824Core.h
  • Analog_Trigger : JY9824Core.h
  • AnalogHysteresisTrigger : JY9824Core.h
  • AnalogPowerTrigger : JY9824Core.h
  • AnalogTriggerConditioningEnteringWindow : JY9824Core.h
  • AnalogTriggerConditioningFalling : JY9824Core.h
  • AnalogTriggerConditioningLeavingWindow : JY9824Core.h
  • AnalogTriggerConditioningPowerHigh : JY9824Core.h
  • AnalogTriggerConditioningPowerLow : JY9824Core.h
  • AnalogTriggerConditioningRising : JY9824Core.h
  • AnalogTriggerSourceCH0Raw : JY9824Core.h
  • AnalogTriggerSourceCH1Raw : JY9824Core.h
  • AnalogTriggerSourceCH2Raw : JY9824Core.h
  • AnalogTriggerSourceCH3Raw : JY9824Core.h
  • AnalogTriggerSourceTriggerIn : JY9824Core.h
  • AnalogWindowTrigger : JY9824Core.h

- c -

  • Complex : JY9824Core.h
  • Continuous_Sample : JY9824Core.h

- d -

  • DataPackage_0_start_trig_in : JY9824Core.h
  • Digital_Trigger : JY9824Core.h

- e -

  • ExternalClock0 : JY9824Core.h
  • ExternalClock1 : JY9824Core.h

- f -

  • Falling_Edge_Trigger : JY9824Core.h
  • FFT : JY9824Core.h
  • FFT_Config_0_trig_in : JY9824Core.h
  • Finite_Sample : JY9824Core.h

- h -

  • High_Level_Trigger : JY9824Core.h

- i -

  • Immediate_Trigger : JY9824Core.h
  • InternalClock : JY9824Core.h

- j -

  • JY9824_Blackman : JY9824Core.h
  • JY9824_Blackman_Harris : JY9824Core.h
  • JY9824_Center : JY9824Core.h
  • JY9824_dBFS : JY9824Core.h
  • JY9824_dBm : JY9824Core.h
  • JY9824_dBuV : JY9824Core.h
  • JY9824_dBV : JY9824Core.h
  • JY9824_Exact_Blackman : JY9824Core.h
  • JY9824_ExponentialAverage : JY9824Core.h
  • JY9824_Five_Term_Least_Sidelobe : JY9824Core.h
  • JY9824_Flat_Top_90D : JY9824Core.h
  • JY9824_Flat_Top_95 : JY9824Core.h
  • JY9824_Four_Term_B_Harris : JY9824Core.h
  • JY9824_Four_Term_Blackman_Nuttal : JY9824Core.h
  • JY9824_Four_Term_Nuttal : JY9824Core.h
  • JY9824_Hamming : JY9824Core.h
  • JY9824_Hanning : JY9824Core.h
  • JY9824_LinearAverage : JY9824Core.h
  • JY9824_Lower : JY9824Core.h
  • JY9824_NoAveraging : JY9824Core.h
  • JY9824_None : JY9824Core.h
  • JY9824_PeakHold : JY9824Core.h
  • JY9824_PseudoPeakHold : JY9824Core.h
  • JY9824_Seven_Term_Flat_Top : JY9824Core.h
  • JY9824_Seven_Term_Least_Sidelobe : JY9824Core.h
  • JY9824_Six_Term_Flat_Top : JY9824Core.h
  • JY9824_Six_Term_Least_Sidelobe : JY9824Core.h
  • JY9824_Three_Term_Blackman_Nuttal : JY9824Core.h
  • JY9824_Three_Term_Nuttal : JY9824Core.h
  • JY9824_Upper : JY9824Core.h
  • JY9824_V2 : JY9824Core.h

- l -

  • Low_Level_Trigger : JY9824Core.h

- m -

  • Master : JY9824Core.h

- p -

  • PFI0 : JY9824Core.h
  • PFI_ui_0_0_di_OUT : JY9824Core.h
  • PFI_ui_0_0_do_IN : JY9824Core.h
  • PXI_Trig_0 : JY9824Core.h
  • PXI_Trig_1 : JY9824Core.h
  • PXI_Trig_2 : JY9824Core.h
  • PXI_Trig_3 : JY9824Core.h
  • PXI_Trig_4 : JY9824Core.h
  • PXI_Trig_5 : JY9824Core.h
  • PXI_Trig_6 : JY9824Core.h
  • PXI_Trig_7 : JY9824Core.h
  • PXITrig_IN_0 : JY9824Core.h
  • PXITrig_IN_1 : JY9824Core.h
  • PXITrig_IN_2 : JY9824Core.h
  • PXITrig_IN_3 : JY9824Core.h
  • PXITrig_IN_4 : JY9824Core.h
  • PXITrig_IN_5 : JY9824Core.h
  • PXITrig_IN_6 : JY9824Core.h
  • PXITrig_IN_7 : JY9824Core.h
  • PXITrig_OUT_0 : JY9824Core.h
  • PXITrig_OUT_1 : JY9824Core.h
  • PXITrig_OUT_2 : JY9824Core.h
  • PXITrig_OUT_3 : JY9824Core.h
  • PXITrig_OUT_4 : JY9824Core.h
  • PXITrig_OUT_5 : JY9824Core.h
  • PXITrig_OUT_6 : JY9824Core.h
  • PXITrig_OUT_7 : JY9824Core.h

- r -

  • Real : JY9824Core.h
  • ReferenceTrigger : JY9824Core.h
  • Rising_Edge_Trigger : JY9824Core.h
  • Rx_Engine_FFT_reference_trig_in : JY9824Core.h
  • Rx_Engine_FFT_start_trig_in : JY9824Core.h
  • Rx_Engine_IQ_advance_trig_in : JY9824Core.h
  • Rx_Engine_IQ_advance_trig_out : JY9824Core.h
  • Rx_Engine_IQ_reference_trig_in : JY9824Core.h
  • Rx_Engine_IQ_reference_trig_out : JY9824Core.h
  • Rx_Engine_IQ_start_trig_in : JY9824Core.h
  • Rx_Engine_IQ_start_trig_out : JY9824Core.h
  • Rx_Engine_Real_advance_trig_in : JY9824Core.h
  • Rx_Engine_Real_advance_trig_out : JY9824Core.h
  • Rx_Engine_Real_reference_trig_in : JY9824Core.h
  • Rx_Engine_Real_reference_trig_out : JY9824Core.h
  • Rx_Engine_Real_start_trig_in : JY9824Core.h
  • Rx_Engine_Real_start_trig_out : JY9824Core.h

- s -

  • Slave : JY9824Core.h
  • Soft_Trigger : JY9824Core.h
  • SOLO : JY9824Core.h
  • StartAndReferenceTrigger : JY9824Core.h
  • StartTrigger : JY9824Core.h

- t -

  • TrigIn_buf_IBUF_OUT_OUT : JY9824Core.h

- v -

  • Vpp1V : JY9824Core.h
  • Vpp2V : JY9824Core.h


  • Enumerations
  • Enumerator
  • Macros
  • a
  • c
  • d
  • e
  • f
  • h
  • i
  • j
  • l
  • m
  • p
  • r
  • s
  • t
  • v
Here is a list of all file members with links to the files they belong to:

- f -

  • Falling_Edge_Trigger : JY9824Core.h
  • FFT : JY9824Core.h
  • FFT_Config_0_trig_in : JY9824Core.h
  • Finite_Sample : JY9824Core.h


  • Enumerations
  • Enumerator
  • Macros
  • j
Here is a list of all functions with links to the files they belong to:

- j -

  • JY9824Core_CalculateCRC16() : JY9824Core.h
  • JY9824Core_Close() : JY9824Core.h
  • JY9824Core_Commit() : JY9824Core.h
  • JY9824Core_ConfigSampleRate() : JY9824Core.h
  • JY9824Core_EEPROM_InitializeCalibrationBlock() : JY9824Core.h
  • JY9824Core_EEPROM_InitializeIdBlock() : JY9824Core.h
  • JY9824Core_EEPROM_ReadCalibrationBlock() : JY9824Core.h
  • JY9824Core_EEPROM_ReadIdBlock() : JY9824Core.h
  • JY9824Core_EEPROM_Reset() : JY9824Core.h
  • JY9824Core_EEPROM_SerialNumber_Int2String() : JY9824Core.h
  • JY9824Core_EEPROM_SerialNumber_String2Int() : JY9824Core.h
  • JY9824Core_EEPROM_WriteCalibrationBlock() : JY9824Core.h
  • JY9824Core_EEPROM_WriteIdBlock() : JY9824Core.h
  • JY9824Core_ExportSignal() : JY9824Core.h
  • JY9824Core_FFT_CheckBufferStatus() : JY9824Core.h
  • JY9824Core_FFT_ConfigSpectrumAverageParam() : JY9824Core.h
  • JY9824Core_FFT_ConfigSpectrumParam() : JY9824Core.h
  • JY9824Core_FFT_GetSpectralInformation() : JY9824Core.h
  • JY9824Core_FFT_ReadData() : JY9824Core.h
  • JY9824Core_FFT_SendSoftTrigger() : JY9824Core.h
  • JY9824Core_FFT_Start() : JY9824Core.h
  • JY9824Core_FFT_Stop() : JY9824Core.h
  • JY9824Core_GetAcquisitionStatus() : JY9824Core.h
  • JY9824Core_GetDeviceList() : JY9824Core.h
  • JY9824Core_GetLastError() : JY9824Core.h
  • JY9824Core_GetReTriggerStatus() : JY9824Core.h
  • JY9824Core_GetScaleFactor() : JY9824Core.h
  • JY9824Core_GetTemperature() : JY9824Core.h
  • JY9824Core_Open() : JY9824Core.h
  • JY9824Core_Open_WithAliasName() : JY9824Core.h
  • JY9824Core_ReadDataBinary16() : JY9824Core.h
  • JY9824Core_ReadDataDbl64() : JY9824Core.h
  • JY9824Core_SendSoftwareTrigger() : JY9824Core.h
  • JY9824Core_SetAcquisitionMode() : JY9824Core.h
  • JY9824Core_SetAnalogTrigger() : JY9824Core.h
  • JY9824Core_SetBufferLength() : JY9824Core.h
  • JY9824Core_SetCalEnable() : JY9824Core.h
  • JY9824Core_SetDataType() : JY9824Core.h
  • JY9824Core_SetDDCParam() : JY9824Core.h
  • JY9824Core_SetDigitalTrigger() : JY9824Core.h
  • JY9824Core_SetEnabledChannels() : JY9824Core.h
  • JY9824Core_SetInputRange() : JY9824Core.h
  • JY9824Core_SetPreTriggerSamples() : JY9824Core.h
  • JY9824Core_SetReferenceClockParam() : JY9824Core.h
  • JY9824Core_SetReTriggerParam() : JY9824Core.h
  • JY9824Core_SetSamplesToAcquire() : JY9824Core.h
  • JY9824Core_SetSyncMode() : JY9824Core.h
  • JY9824Core_SetTriggerType() : JY9824Core.h
  • JY9824Core_Start() : JY9824Core.h
  • JY9824Core_Stop() : JY9824Core.h
  • JY9824Core_WaitForAcqComplete() : JY9824Core.h


  • Enumerations
  • Enumerator
  • Macros
  • a
  • c
  • d
  • e
  • f
  • h
  • i
  • j
  • l
  • m
  • p
  • r
  • s
  • t
  • v
Here is a list of all file members with links to the files they belong to:

- h -

  • High_Level_Trigger : JY9824Core.h


  • Enumerations
  • Enumerator
  • Macros
  • a
  • c
  • d
  • e
  • f
  • h
  • i
  • j
  • l
  • m
  • p
  • r
  • s
  • t
  • v
Here is a list of all file members with links to the files they belong to:

- i -

  • Immediate_Trigger : JY9824Core.h
  • InputRange : JY9824Core.h
  • InternalClock : JY9824Core.h


  • Enumerations
  • Enumerator
  • Macros
  • a
  • c
  • d
  • e
  • f
  • h
  • i
  • j
  • l
  • m
  • p
  • r
  • s
  • t
  • v
Here is a list of all file members with links to the files they belong to:

- j -

  • JY9824_Blackman : JY9824Core.h
  • JY9824_Blackman_Harris : JY9824Core.h
  • JY9824_Center : JY9824Core.h
  • JY9824_dBFS : JY9824Core.h
  • JY9824_dBm : JY9824Core.h
  • JY9824_dBuV : JY9824Core.h
  • JY9824_dBV : JY9824Core.h
  • JY9824_ErrorCodeOffset : JY9824Core.h
  • JY9824_Exact_Blackman : JY9824Core.h
  • JY9824_ExponentialAverage : JY9824Core.h
  • JY9824_FFTWindowType : JY9824Core.h
  • JY9824_Five_Term_Least_Sidelobe : JY9824Core.h
  • JY9824_Flat_Top_90D : JY9824Core.h
  • JY9824_Flat_Top_95 : JY9824Core.h
  • JY9824_Four_Term_B_Harris : JY9824Core.h
  • JY9824_Four_Term_Blackman_Nuttal : JY9824Core.h
  • JY9824_Four_Term_Nuttal : JY9824Core.h
  • JY9824_FrequencyAlignmentMode : JY9824Core.h
  • JY9824_Hamming : JY9824Core.h
  • JY9824_Hanning : JY9824Core.h
  • JY9824_LinearAverage : JY9824Core.h
  • JY9824_Lower : JY9824Core.h
  • JY9824_NoAveraging : JY9824Core.h
  • JY9824_None : JY9824Core.h
  • JY9824_PeakHold : JY9824Core.h
  • JY9824_PseudoPeakHold : JY9824Core.h
  • JY9824_Seven_Term_Flat_Top : JY9824Core.h
  • JY9824_Seven_Term_Least_Sidelobe : JY9824Core.h
  • JY9824_Six_Term_Flat_Top : JY9824Core.h
  • JY9824_Six_Term_Least_Sidelobe : JY9824Core.h
  • JY9824_SpectrumAverageMode : JY9824Core.h
  • JY9824_SpectrumUnitType : JY9824Core.h
  • JY9824_Three_Term_Blackman_Nuttal : JY9824Core.h
  • JY9824_Three_Term_Nuttal : JY9824Core.h
  • JY9824_Upper : JY9824Core.h
  • JY9824_V2 : JY9824Core.h
  • JY9824Core_CalculateCRC16() : JY9824Core.h
  • JY9824Core_Close() : JY9824Core.h
  • JY9824Core_Commit() : JY9824Core.h
  • JY9824Core_ConfigSampleRate() : JY9824Core.h
  • JY9824Core_EEPROM_InitializeCalibrationBlock() : JY9824Core.h
  • JY9824Core_EEPROM_InitializeIdBlock() : JY9824Core.h
  • JY9824Core_EEPROM_ReadCalibrationBlock() : JY9824Core.h
  • JY9824Core_EEPROM_ReadIdBlock() : JY9824Core.h
  • JY9824Core_EEPROM_Reset() : JY9824Core.h
  • JY9824Core_EEPROM_SerialNumber_Int2String() : JY9824Core.h
  • JY9824Core_EEPROM_SerialNumber_String2Int() : JY9824Core.h
  • JY9824Core_EEPROM_WriteCalibrationBlock() : JY9824Core.h
  • JY9824Core_EEPROM_WriteIdBlock() : JY9824Core.h
  • JY9824Core_ExportSignal() : JY9824Core.h
  • JY9824Core_FFT_CheckBufferStatus() : JY9824Core.h
  • JY9824Core_FFT_ConfigSpectrumAverageParam() : JY9824Core.h
  • JY9824Core_FFT_ConfigSpectrumParam() : JY9824Core.h
  • JY9824Core_FFT_GetSpectralInformation() : JY9824Core.h
  • JY9824Core_FFT_ReadData() : JY9824Core.h
  • JY9824Core_FFT_SendSoftTrigger() : JY9824Core.h
  • JY9824Core_FFT_Start() : JY9824Core.h
  • JY9824Core_FFT_Stop() : JY9824Core.h
  • JY9824Core_GetAcquisitionStatus() : JY9824Core.h
  • JY9824Core_GetDeviceList() : JY9824Core.h
  • JY9824Core_GetLastError() : JY9824Core.h
  • JY9824Core_GetReTriggerStatus() : JY9824Core.h
  • JY9824Core_GetScaleFactor() : JY9824Core.h
  • JY9824Core_GetTemperature() : JY9824Core.h
  • JY9824Core_Open() : JY9824Core.h
  • JY9824Core_Open_WithAliasName() : JY9824Core.h
  • JY9824Core_ReadDataBinary16() : JY9824Core.h
  • JY9824Core_ReadDataDbl64() : JY9824Core.h
  • JY9824Core_SendSoftwareTrigger() : JY9824Core.h
  • JY9824Core_SetAcquisitionMode() : JY9824Core.h
  • JY9824Core_SetAnalogTrigger() : JY9824Core.h
  • JY9824Core_SetBufferLength() : JY9824Core.h
  • JY9824Core_SetCalEnable() : JY9824Core.h
  • JY9824Core_SetDataType() : JY9824Core.h
  • JY9824Core_SetDDCParam() : JY9824Core.h
  • JY9824Core_SetDigitalTrigger() : JY9824Core.h
  • JY9824Core_SetEnabledChannels() : JY9824Core.h
  • JY9824Core_SetInputRange() : JY9824Core.h
  • JY9824Core_SetPreTriggerSamples() : JY9824Core.h
  • JY9824Core_SetReferenceClockParam() : JY9824Core.h
  • JY9824Core_SetReTriggerParam() : JY9824Core.h
  • JY9824Core_SetSamplesToAcquire() : JY9824Core.h
  • JY9824Core_SetSyncMode() : JY9824Core.h
  • JY9824Core_SetTriggerType() : JY9824Core.h
  • JY9824Core_Start() : JY9824Core.h
  • JY9824Core_Stop() : JY9824Core.h
  • JY9824Core_WaitForAcqComplete() : JY9824Core.h
  • JYDLL_API : JY9824Core.h
  • JYFailed : JY9824Core.h


  • Enumerations
  • Enumerator
  • Macros
  • a
  • c
  • d
  • e
  • f
  • h
  • i
  • j
  • l
  • m
  • p
  • r
  • s
  • t
  • v
Here is a list of all file members with links to the files they belong to:

- l -

  • Low_Level_Trigger : JY9824Core.h


  • Enumerations
  • Enumerator
  • Macros
  • a
  • c
  • d
  • e
  • f
  • h
  • i
  • j
  • l
  • m
  • p
  • r
  • s
  • t
  • v
Here is a list of all file members with links to the files they belong to:

- m -

  • Master : JY9824Core.h


  • Enumerations
  • Enumerator
  • Macros
  • a
  • c
  • d
  • e
  • f
  • h
  • i
  • j
  • l
  • m
  • p
  • r
  • s
  • t
  • v
Here is a list of all file members with links to the files they belong to:

- p -

  • PFI0 : JY9824Core.h
  • PFI_ui_0_0_di_OUT : JY9824Core.h
  • PFI_ui_0_0_do_IN : JY9824Core.h
  • PXI_Trig_0 : JY9824Core.h
  • PXI_Trig_1 : JY9824Core.h
  • PXI_Trig_2 : JY9824Core.h
  • PXI_Trig_3 : JY9824Core.h
  • PXI_Trig_4 : JY9824Core.h
  • PXI_Trig_5 : JY9824Core.h
  • PXI_Trig_6 : JY9824Core.h
  • PXI_Trig_7 : JY9824Core.h
  • PXITrig_IN_0 : JY9824Core.h
  • PXITrig_IN_1 : JY9824Core.h
  • PXITrig_IN_2 : JY9824Core.h
  • PXITrig_IN_3 : JY9824Core.h
  • PXITrig_IN_4 : JY9824Core.h
  • PXITrig_IN_5 : JY9824Core.h
  • PXITrig_IN_6 : JY9824Core.h
  • PXITrig_IN_7 : JY9824Core.h
  • PXITrig_OUT_0 : JY9824Core.h
  • PXITrig_OUT_1 : JY9824Core.h
  • PXITrig_OUT_2 : JY9824Core.h
  • PXITrig_OUT_3 : JY9824Core.h
  • PXITrig_OUT_4 : JY9824Core.h
  • PXITrig_OUT_5 : JY9824Core.h
  • PXITrig_OUT_6 : JY9824Core.h
  • PXITrig_OUT_7 : JY9824Core.h


  • Enumerations
  • Enumerator
  • Macros
  • a
  • c
  • d
  • e
  • f
  • h
  • i
  • j
  • l
  • m
  • p
  • r
  • s
  • t
  • v
Here is a list of all file members with links to the files they belong to:

- r -

  • Real : JY9824Core.h
  • ReferenceTrigger : JY9824Core.h
  • Rising_Edge_Trigger : JY9824Core.h
  • Rx_Engine_FFT_reference_trig_in : JY9824Core.h
  • Rx_Engine_FFT_start_trig_in : JY9824Core.h
  • Rx_Engine_IQ_advance_trig_in : JY9824Core.h
  • Rx_Engine_IQ_advance_trig_out : JY9824Core.h
  • Rx_Engine_IQ_reference_trig_in : JY9824Core.h
  • Rx_Engine_IQ_reference_trig_out : JY9824Core.h
  • Rx_Engine_IQ_start_trig_in : JY9824Core.h
  • Rx_Engine_IQ_start_trig_out : JY9824Core.h
  • Rx_Engine_Real_advance_trig_in : JY9824Core.h
  • Rx_Engine_Real_advance_trig_out : JY9824Core.h
  • Rx_Engine_Real_reference_trig_in : JY9824Core.h
  • Rx_Engine_Real_reference_trig_out : JY9824Core.h
  • Rx_Engine_Real_start_trig_in : JY9824Core.h
  • Rx_Engine_Real_start_trig_out : JY9824Core.h


  • Enumerations
  • Enumerator
  • Macros
  • a
  • c
  • d
  • e
  • f
  • h
  • i
  • j
  • l
  • m
  • p
  • r
  • s
  • t
  • v
Here is a list of all file members with links to the files they belong to:

- s -

  • Slave : JY9824Core.h
  • Soft_Trigger : JY9824Core.h
  • SOLO : JY9824Core.h
  • StartAndReferenceTrigger : JY9824Core.h
  • StartTrigger : JY9824Core.h
  • STDCALL : JY9824Core.h
  • Success : JY9824Core.h
  • SyncMode : JY9824Core.h


  • Enumerations
  • Enumerator
  • Macros
  • a
  • c
  • d
  • e
  • f
  • h
  • i
  • j
  • l
  • m
  • p
  • r
  • s
  • t
  • v
Here is a list of all file members with links to the files they belong to:

- t -

  • TriggerMode : JY9824Core.h
  • TriggerType : JY9824Core.h
  • TrigIn_buf_IBUF_OUT_OUT : JY9824Core.h


  • Enumerations
  • Enumerator
  • Macros
Here is a list of all typedefs with links to the files they belong to:
  • DeviceHandle : JY9824Core.h


  • Enumerations
  • Enumerator
  • Macros
  • a
  • c
  • d
  • e
  • f
  • h
  • i
  • j
  • l
  • m
  • p
  • r
  • s
  • t
  • v
Here is a list of all file members with links to the files they belong to:

- v -

  • Vpp1V : JY9824Core.h
  • Vpp2V : JY9824Core.h


9824 C++ Programming Manual: Main Page

9824 C++ Programming Manual Documentation


9824 C++ Programming Manual: JY9824_SpectralInformation Struct Reference

  • Class List
  • Class Index
  • Class Members
Public Attributes | List of all members
JY9824_SpectralInformation Struct Reference

#include <JY9824Core.h>

Public Attributes

double | CenterFrequency
double | FrequencyStart
double | FrequencyStep
double | ResolutionBandwidth
double | ENBW
JY9824_SpectrumUnitType UnitType
JY9824_FFTWindowType FftWindowType
int | NumOfSpectralLines
int | FftLength
bool | IsPsd

Member Data Documentation

◆ CenterFrequency

double JY9824_SpectralInformation::CenterFrequency

◆ ENBW

double JY9824_SpectralInformation::ENBW

◆ FftLength

int JY9824_SpectralInformation::FftLength

◆ FftWindowType

JY9824_FFTWindowType JY9824_SpectralInformation::FftWindowType

◆ FrequencyStart

double JY9824_SpectralInformation::FrequencyStart

◆ FrequencyStep

double JY9824_SpectralInformation::FrequencyStep

◆ IsPsd

bool JY9824_SpectralInformation::IsPsd

◆ NumOfSpectralLines

int JY9824_SpectralInformation::NumOfSpectralLines

◆ ResolutionBandwidth

double JY9824_SpectralInformation::ResolutionBandwidth

◆ UnitType

JY9824_SpectrumUnitType JY9824_SpectralInformation::UnitType
The documentation for this struct was generated from the following file:
  • D:/9824/C++/JY9824Core.h


9824 C++ Programming Manual: Member List

  • Class List
  • Class Index
  • Class Members
JY9824_SpectralInformation Member List

This is the complete list of members for JY9824_SpectralInformation, including all inherited members.

CenterFrequency | JY9824_SpectralInformation
ENBW | JY9824_SpectralInformation
FftLength | JY9824_SpectralInformation
FftWindowType | JY9824_SpectralInformation
FrequencyStart | JY9824_SpectralInformation
FrequencyStep | JY9824_SpectralInformation
IsPsd | JY9824_SpectralInformation
NumOfSpectralLines | JY9824_SpectralInformation
ResolutionBandwidth | JY9824_SpectralInformation
UnitType | JY9824_SpectralInformation


9824 C++ Programming Manual: JY9824CalibrationConstant Struct Reference

  • Class List
  • Class Index
  • Class Members
Public Attributes | List of all members
JY9824CalibrationConstant Struct Reference

#include <JY9824Core.h>

Public Attributes

float | AI_CH0_Range0_k
float | AI_CH0_Range0_b
float | AI_CH1_Range0_k
float | AI_CH1_Range0_b
float | AI_CH2_Range0_k
float | AI_CH2_Range0_b
float | AI_CH3_Range0_k
float | AI_CH3_Range0_b
float | AI_CH0_Range1_k
float | AI_CH0_Range1_b
float | AI_CH1_Range1_k
float | AI_CH1_Range1_b
float | AI_CH2_Range1_k
float | AI_CH2_Range1_b
float | AI_CH3_Range1_k
float | AI_CH3_Range1_b

Member Data Documentation

◆ AI_CH0_Range0_b

float JY9824CalibrationConstant::AI_CH0_Range0_b

◆ AI_CH0_Range0_k

float JY9824CalibrationConstant::AI_CH0_Range0_k

◆ AI_CH0_Range1_b

float JY9824CalibrationConstant::AI_CH0_Range1_b

◆ AI_CH0_Range1_k

float JY9824CalibrationConstant::AI_CH0_Range1_k

◆ AI_CH1_Range0_b

float JY9824CalibrationConstant::AI_CH1_Range0_b

◆ AI_CH1_Range0_k

float JY9824CalibrationConstant::AI_CH1_Range0_k

◆ AI_CH1_Range1_b

float JY9824CalibrationConstant::AI_CH1_Range1_b

◆ AI_CH1_Range1_k

float JY9824CalibrationConstant::AI_CH1_Range1_k

◆ AI_CH2_Range0_b

float JY9824CalibrationConstant::AI_CH2_Range0_b

◆ AI_CH2_Range0_k

float JY9824CalibrationConstant::AI_CH2_Range0_k

◆ AI_CH2_Range1_b

float JY9824CalibrationConstant::AI_CH2_Range1_b

◆ AI_CH2_Range1_k

float JY9824CalibrationConstant::AI_CH2_Range1_k

◆ AI_CH3_Range0_b

float JY9824CalibrationConstant::AI_CH3_Range0_b

◆ AI_CH3_Range0_k

float JY9824CalibrationConstant::AI_CH3_Range0_k

◆ AI_CH3_Range1_b

float JY9824CalibrationConstant::AI_CH3_Range1_b

◆ AI_CH3_Range1_k

float JY9824CalibrationConstant::AI_CH3_Range1_k
The documentation for this struct was generated from the following file:
  • D:/9824/C++/JY9824Core.h


9824 C++ Programming Manual: Member List

  • Class List
  • Class Index
  • Class Members
JY9824CalibrationConstant Member List

This is the complete list of members for JY9824CalibrationConstant, including all inherited members.

AI_CH0_Range0_b | JY9824CalibrationConstant
AI_CH0_Range0_k | JY9824CalibrationConstant
AI_CH0_Range1_b | JY9824CalibrationConstant
AI_CH0_Range1_k | JY9824CalibrationConstant
AI_CH1_Range0_b | JY9824CalibrationConstant
AI_CH1_Range0_k | JY9824CalibrationConstant
AI_CH1_Range1_b | JY9824CalibrationConstant
AI_CH1_Range1_k | JY9824CalibrationConstant
AI_CH2_Range0_b | JY9824CalibrationConstant
AI_CH2_Range0_k | JY9824CalibrationConstant
AI_CH2_Range1_b | JY9824CalibrationConstant
AI_CH2_Range1_k | JY9824CalibrationConstant
AI_CH3_Range0_b | JY9824CalibrationConstant
AI_CH3_Range0_k | JY9824CalibrationConstant
AI_CH3_Range1_b | JY9824CalibrationConstant
AI_CH3_Range1_k | JY9824CalibrationConstant


9824 C++ Programming Manual: JY9824CalibrationInfo Struct Reference

  • Class List
  • Class Index
  • Class Members
Public Attributes | List of all members
JY9824CalibrationInfo Struct Reference

#include <JY9824Core.h>

Public Attributes

long long | CalibrationTimeStamp
short | CalibrationTemperature
short | CalibrationDataAddress = 0x11
short | CalibrationSize = sizeof(JY9824CalibrationConstant)
JY9824CalibrationConstant ConstantList
unsigned short | CalibrationCRC16

Member Data Documentation

◆ CalibrationCRC16

unsigned short JY9824CalibrationInfo::CalibrationCRC16

◆ CalibrationDataAddress

short JY9824CalibrationInfo::CalibrationDataAddress = 0x11

◆ CalibrationSize

short JY9824CalibrationInfo::CalibrationSize = sizeof(JY9824CalibrationConstant)

◆ CalibrationTemperature

short JY9824CalibrationInfo::CalibrationTemperature

◆ CalibrationTimeStamp

long long JY9824CalibrationInfo::CalibrationTimeStamp

◆ ConstantList

JY9824CalibrationConstant JY9824CalibrationInfo::ConstantList
The documentation for this struct was generated from the following file:
  • D:/9824/C++/JY9824Core.h


9824 C++ Programming Manual: Member List

  • Class List
  • Class Index
  • Class Members
JY9824CalibrationInfo Member List

This is the complete list of members for JY9824CalibrationInfo, including all inherited members.

CalibrationCRC16 | JY9824CalibrationInfo
CalibrationDataAddress | JY9824CalibrationInfo
CalibrationSize | JY9824CalibrationInfo
CalibrationTemperature | JY9824CalibrationInfo
CalibrationTimeStamp | JY9824CalibrationInfo
ConstantList | JY9824CalibrationInfo


9824 C++ Programming Manual: JY9824CoreDeviceInfo Struct Reference

  • Class List
  • Class Index
  • Class Members
Public Attributes | List of all members
JY9824CoreDeviceInfo Struct Reference

#include <JY9824Core.h>

Public Attributes

short | StartSentinel
short | EEPROMSize
short | CalibrationAddr
char | SerialNumber [10]
char | Model [8]
unsigned char | HWRev
short | ProductionDate
unsigned char | Reserved [5]

Member Data Documentation

◆ CalibrationAddr

short JY9824CoreDeviceInfo::CalibrationAddr

◆ EEPROMSize

short JY9824CoreDeviceInfo::EEPROMSize

◆ HWRev

unsigned char JY9824CoreDeviceInfo::HWRev

◆ Model

char JY9824CoreDeviceInfo::Model[8]

◆ ProductionDate

short JY9824CoreDeviceInfo::ProductionDate

◆ Reserved

unsigned char JY9824CoreDeviceInfo::Reserved[5]

◆ SerialNumber

char JY9824CoreDeviceInfo::SerialNumber[10]

◆ StartSentinel

short JY9824CoreDeviceInfo::StartSentinel
The documentation for this struct was generated from the following file:
  • D:/9824/C++/JY9824Core.h


9824 C++ Programming Manual: Member List

  • Class List
  • Class Index
  • Class Members
JY9824CoreDeviceInfo Member List

This is the complete list of members for JY9824CoreDeviceInfo, including all inherited members.

CalibrationAddr | JY9824CoreDeviceInfo
EEPROMSize | JY9824CoreDeviceInfo
HWRev | JY9824CoreDeviceInfo
Model | JY9824CoreDeviceInfo
ProductionDate | JY9824CoreDeviceInfo
Reserved | JY9824CoreDeviceInfo
SerialNumber | JY9824CoreDeviceInfo
StartSentinel | JY9824CoreDeviceInfo


9824 C++ Programming Manual: JY9824DeviceInfo Struct Reference

  • Class List
  • Class Index
  • Class Members
Public Attributes | List of all members
JY9824DeviceInfo Struct Reference

#include <JY9824Core.h>

Public Attributes

char | aliasName [64]
int | slotNumber
char | serialNumber [33]
char | model [65]
char | HardwareVer [16]
char | FirmwareVer [16]
char | FrameworkVer [16]
char | DriverSetVer [16]
char | ProductionDate [16]

Member Data Documentation

◆ aliasName

char JY9824DeviceInfo::aliasName[64]

◆ DriverSetVer

char JY9824DeviceInfo::DriverSetVer[16]

◆ FirmwareVer

char JY9824DeviceInfo::FirmwareVer[16]

◆ FrameworkVer

char JY9824DeviceInfo::FrameworkVer[16]

◆ HardwareVer

char JY9824DeviceInfo::HardwareVer[16]

◆ model

char JY9824DeviceInfo::model[65]

◆ ProductionDate

char JY9824DeviceInfo::ProductionDate[16]

◆ serialNumber

char JY9824DeviceInfo::serialNumber[33]

◆ slotNumber

int JY9824DeviceInfo::slotNumber
The documentation for this struct was generated from the following file:
  • D:/9824/C++/JY9824Core.h


9824 C++ Programming Manual: Member List

  • Class List
  • Class Index
  • Class Members
JY9824DeviceInfo Member List

This is the complete list of members for JY9824DeviceInfo, including all inherited members.

aliasName | JY9824DeviceInfo
DriverSetVer | JY9824DeviceInfo
FirmwareVer | JY9824DeviceInfo
FrameworkVer | JY9824DeviceInfo
HardwareVer | JY9824DeviceInfo
model | JY9824DeviceInfo
ProductionDate | JY9824DeviceInfo
serialNumber | JY9824DeviceInfo
slotNumber | JY9824DeviceInfo