9824 C# Programming Manual: D:/9824/C# Directory Reference

9824 C# Programming Manual
  • Main Page
  • Packages
  • Classes
  • Files
  • File List
  • 9824
  • C#
C# Directory Reference

Files

AIAnalogTrigger.cs
JY9824Digitizer.cs
JY9824Miscellaneous.cs
JY9824SpectrumTask.cs
Generated by doxygen 1.12.0


9824 C# Programming Manual: D:/9824/C#/AIAnalogTrigger.cs File Reference

  • Packages
  • Classes
  • Files
  • File List
  • 9824
  • C#
Classes | Namespaces | Enumerations
AIAnalogTrigger.cs File Reference

Classes

class | JY9824.AIAnalogTrigger
AI Analog Trigger. More...
class | JY9824.AIAnalogHysteresisComparator
AI Analog Hysteresis Comparator. More...
class | JY9824.AIAnalogWindowComparator
AI Analog Window Comparator. More...
class | JY9824.AIAnalogEdgeComparator
AI Analog Edge Comparator. More...

Namespaces

namespace JY9824

Enumerations

enum JY9824.AIAnalogTriggerSource {
JY9824.Channel_0 = JY9824Import.AnalogTriggerSource.AnalogTriggerSourceCH0Raw , JY9824.Channel_1 = JY9824Import.AnalogTriggerSource.AnalogTriggerSourceCH1Raw , JY9824.Channel_2 = JY9824Import.AnalogTriggerSource.AnalogTriggerSourceCH2Raw , JY9824.Channel_3 = JY9824Import.AnalogTriggerSource.AnalogTriggerSourceCH3Raw ,
JY9824.TriggerIn = JY9824Import.AnalogTriggerSource.AnalogTriggerSourceTriggerIn
}
AI Analog Trigger Source. More...
enum | JY9824.AIAnalogTriggerComparator { JY9824.Edge , JY9824.Hysteresis , JY9824.Window }
AI Analog Trigger Comparator. More...
enum | JY9824.AIAnalogTriggerEdge { JY9824.Rising , JY9824.Falling }
AI Analog Trigger Edge. More...
enum | JY9824.AIAnalogWindowCondition { JY9824.Entering , JY9824.Leaving }
AI Analog Window Trigger Condition. More...


9824 C# Programming Manual: JY9824.AIAnalogTrigger Class Reference

  • Class List
  • Class Index
  • Class Members
  • JY9824
  • AIAnalogTrigger
Properties | List of all members
JY9824.AIAnalogTrigger Class Referencesealed

AI Analog Trigger. More...

Properties

AIAnalogTriggerSource | Source [get, set]
Analog Trigger source.
AIAnalogTriggerComparator | Comparator [get, set]
AI Analog Trigger Comparator.
AIAnalogEdgeComparator | Edge [get, set]
AI Analog Edge Comparator.
AIAnalogHysteresisComparator | Hysteresis [get, set]
AI Analog Hysteresis Comparatorr.
AIAnalogWindowComparator | Window [get, set]
AI Analog Window Comparatorr.

Detailed Description

AI Analog Trigger.

Property Documentation

◆ Comparator

AIAnalogTriggerComparator JY9824.AIAnalogTrigger.Comparator
getset

AI Analog Trigger Comparator.

◆ Edge

AIAnalogEdgeComparator JY9824.AIAnalogTrigger.Edge
getset

AI Analog Edge Comparator.

◆ Hysteresis

AIAnalogHysteresisComparator JY9824.AIAnalogTrigger.Hysteresis
getset

AI Analog Hysteresis Comparatorr.

◆ Source

AIAnalogTriggerSource JY9824.AIAnalogTrigger.Source
getset

Analog Trigger source.

◆ Window

AIAnalogWindowComparator JY9824.AIAnalogTrigger.Window
getset

AI Analog Window Comparatorr.

The documentation for this class was generated from the following file:
  • D:/9824/C#/AIAnalogTrigger.cs


9824 C# Programming Manual: JY9824.AIAnalogHysteresisComparator Class Reference

  • JY9824
  • AIAnalogHysteresisComparator
Properties | List of all members
JY9824.AIAnalogHysteresisComparator Class Reference

AI Analog Hysteresis Comparator. More...

Properties

AIAnalogTriggerEdge | Slope [get, set]
AI Analog Trigger Edge.
double | HighThreshold [get, set]
High Threshold.
double | LowThreshold [get, set]
Low Threshold.

Detailed Description

AI Analog Hysteresis Comparator.

Property Documentation

◆ HighThreshold

double JY9824.AIAnalogHysteresisComparator.HighThreshold
getset

High Threshold.

◆ LowThreshold

double JY9824.AIAnalogHysteresisComparator.LowThreshold
getset

Low Threshold.

◆ Slope

AIAnalogTriggerEdge JY9824.AIAnalogHysteresisComparator.Slope
getset

AI Analog Trigger Edge.

The documentation for this class was generated from the following file:
  • D:/9824/C#/AIAnalogTrigger.cs


9824 C# Programming Manual: JY9824.AIAnalogWindowComparator Class Reference

  • AIAnalogWindowComparator
Properties | List of all members
JY9824.AIAnalogWindowComparator Class Reference

AI Analog Window Comparator. More...

Properties

AIAnalogWindowCondition | Condition [get, set]
AI Analog Window Condition.
double | HighThreshold [get, set]
High Threshold.
double | LowThreshold [get, set]
Low Threshold.

Detailed Description

AI Analog Window Comparator.

Property Documentation

◆ Condition

AIAnalogWindowCondition JY9824.AIAnalogWindowComparator.Condition
getset

AI Analog Window Condition.

◆ HighThreshold

double JY9824.AIAnalogWindowComparator.HighThreshold
getset

High Threshold.

◆ LowThreshold

double JY9824.AIAnalogWindowComparator.LowThreshold
getset

Low Threshold.

The documentation for this class was generated from the following file:
  • D:/9824/C#/AIAnalogTrigger.cs


9824 C# Programming Manual: JY9824.AIAnalogEdgeComparator Class Reference

  • AIAnalogEdgeComparator
Properties | List of all members
JY9824.AIAnalogEdgeComparator Class Reference

AI Analog Edge Comparator. More...

Properties

AIAnalogTriggerEdge | Slope [get, set]
AI Analog Trigger Edge.
double | Threshold [get, set]
Threshold.

Detailed Description

AI Analog Edge Comparator.

Property Documentation

◆ Slope

AIAnalogTriggerEdge JY9824.AIAnalogEdgeComparator.Slope
getset

AI Analog Trigger Edge.

◆ Threshold

double JY9824.AIAnalogEdgeComparator.Threshold
getset

Threshold.

The documentation for this class was generated from the following file:
  • D:/9824/C#/AIAnalogTrigger.cs


9824 C# Programming Manual: D:/9824/C#/JY9824Digitizer.cs File Reference

  • File List
  • 9824
  • C#
Classes | Namespaces | Enumerations | Functions
JY9824Digitizer.cs File Reference

Classes

class | JY9824.JY9824AITask
AI采集任务类,Sealed类，不可被继承 More...
class | JY9824.Record
流盘相关的参数定义 More...
class | JY9824.AIChannel
AI通道参数类 More...
class | JY9824.AITrigger
AI触发参数类 More...
class | JY9824.AIDigitalTrigger
AI数字触发 More...
class | JY9824.AIOnboardSignalProcessing
Onboard Signal Processing configuration class. More...
class | JY9824.AISignalExport
信号路由 More...
class | JY9824.AISync
同步配置 More...

Namespaces

namespace JY9824

Enumerations

enum | JY9824.RecordMode { JY9824.Finite , JY9824.Infinite }
流盘模式枚举定义 More...
enum | JY9824.RecordFormat { JY9824.VectorFile , JY9824.Raw }
流盘格式 More...
enum | JY9824.AIOspDataFormat { JY9824.Real , JY9824.Complex }
Data Format，Real/Complex Real：ADC data Complex：DDC(Digital DownConversion) IQ data. More...
enum | JY9824.AIMode { JY9824.Finite = JY9824Import.AcquisitionMode.Finite_Sample , JY9824.Continuous = JY9824Import.AcquisitionMode.Continuous_Sample , JY9824.Record }
AI工作模式枚举类型 More...
enum | JY9824.AITriggerType { JY9824.Immediate = JY9824Import.TriggerType.Immediate_Trigger , JY9824.Software = JY9824Import.TriggerType.Soft_Trigger , JY9824.Digital = JY9824Import.TriggerType.Digital_Trigger , JY9824.Analog = JY9824Import.TriggerType.Analog_Trigger }
AI触发类型 More...
enum JY9824.AIDigitalTriggerSource {
JY9824.PFI0 = JY9824Import.DigitalTriggerSource.PFI0 , JY9824.PXI_Trig_0 = JY9824Import.DigitalTriggerSource.PXI_Trig_0 , JY9824.PXI_Trig_1 = JY9824Import.DigitalTriggerSource.PXI_Trig_1 , JY9824.PXI_Trig_2 = JY9824Import.DigitalTriggerSource.PXI_Trig_2 ,
JY9824.PXI_Trig_3 = JY9824Import.DigitalTriggerSource.PXI_Trig_3 , JY9824.PXI_Trig_4 = JY9824Import.DigitalTriggerSource.PXI_Trig_4 , JY9824.PXI_Trig_5 = JY9824Import.DigitalTriggerSource.PXI_Trig_5 , JY9824.PXI_Trig_6 = JY9824Import.DigitalTriggerSource.PXI_Trig_6 ,
JY9824.PXI_Trig_7 = JY9824Import.DigitalTriggerSource.PXI_Trig_7
}
AI外部数字触发源 More...
enum | JY9824.AIDigitalTriggerEdge { JY9824.Rising = JY9824Import.DigitalTriggerConditioning.Rising_Edge_Trigger , JY9824.Falling = JY9824Import.DigitalTriggerConditioning.Falling_Edge_Trigger }
AI外部数字出发边沿 More...
enum JY9824.AISignalExportSource {
JY9824.None = 0 , JY9824.PFI0 = JY9824Import.ExportSignalSource.PFI_ui_0_0_di_OUT , JY9824.TriggerIn = JY9824Import.ExportSignalSource.TriggerIn_buf_IBUF_OUT_OUT , JY9824.Analog_Trigger_0_trigger = JY9824Import.ExportSignalSource.Analog_Trigger_0_trigger ,
JY9824.Rx_Engine_Real_start_trigger_out = JY9824Import.ExportSignalSource.Rx_Engine_Real_start_trigger_out , JY9824.Rx_Engine_Real_reference_trigger_out = JY9824Import.ExportSignalSource.Rx_Engine_Real_reference_trigger_out , JY9824.Rx_Engine_Real_advance_trigger_out = JY9824Import.ExportSignalSource.Rx_Engine_Real_advance_trigger_out , JY9824.PXI_Trig0 = JY9824Import.ExportSignalSource.PXITrigger_OUT_0 ,
JY9824.PXI_Trig1 = JY9824Import.ExportSignalSource.PXITrigger_OUT_1 , JY9824.PXI_Trig2 = JY9824Import.ExportSignalSource.PXITrigger_OUT_2 , JY9824.PXI_Trig3 = JY9824Import.ExportSignalSource.PXITrigger_OUT_3 , JY9824.PXI_Trig4 = JY9824Import.ExportSignalSource.PXITrigger_OUT_4 ,
JY9824.PXI_Trig5 = JY9824Import.ExportSignalSource.PXITrigger_OUT_5 , JY9824.PXI_Trig6 = JY9824Import.ExportSignalSource.PXITrigger_OUT_6 , JY9824.PXI_Trig7 = JY9824Import.ExportSignalSource.PXITrigger_OUT_7
}
导出信号的源 More...
enum JY9824.SignalExportDestination {
JY9824.None = 0 , JY9824.PXI_Trig0 = JY9824Import.ExportSignalDestination.PXITrigger_IN_0 , JY9824.PXI_Trig1 = JY9824Import.ExportSignalDestination.PXITrigger_IN_1 , JY9824.PXI_Trig2 = JY9824Import.ExportSignalDestination.PXITrigger_IN_2 ,
JY9824.PXI_Trig3 = JY9824Import.ExportSignalDestination.PXITrigger_IN_3 , JY9824.PXI_Trig4 = JY9824Import.ExportSignalDestination.PXITrigger_IN_4 , JY9824.PXI_Trig5 = JY9824Import.ExportSignalDestination.PXITrigger_IN_5 , JY9824.PXI_Trig6 = JY9824Import.ExportSignalDestination.PXITrigger_IN_6 ,
JY9824.PXI_Trig7 = JY9824Import.ExportSignalDestination.PXITrigger_IN_7 , JY9824.PFI0 = JY9824Import.ExportSignalDestination.PFI_ui_0_0_do_IN , JY9824.Rx_Engine_Real_start_trigger_in = JY9824Import.ExportSignalDestination.Rx_Engine_Real_start_trigger_in , JY9824.Rx_Engine_Real_reference_trigger_in = JY9824Import.ExportSignalDestination.Rx_Engine_Real_reference_trigger_in ,
JY9824.Rx_Engine_Real_advance_trigger_in = JY9824Import.ExportSignalDestination.Rx_Engine_Real_advance_trigger_in
}
导出信号的目标 More...
enum | JY9824.SyncTopology { JY9824.Independent = JY9824Import.SYNCMODE.SOLO , JY9824.Master = JY9824Import.SYNCMODE.MASTER , JY9824.Slave = JY9824Import.SYNCMODE.SLAVE }
Synchronization board configuration. More...

Functions

delegate void JY9824.TaskCommittedEventHandler (object sender, EventArgs args)
任务提交配置的事件委托


9824 C# Programming Manual: JY9824.JY9824AITask Class Reference

  • JY9824AITask
Public Member Functions | Properties | List of all members
JY9824.JY9824AITask Class Referencesealed

AI采集任务类,Sealed类，不可被继承 More...

Public Member Functions

JY9824AITask (string aliasName)
构造函数,仅输入板卡编号
JY9824AITask (int boardNum)
构造函数,仅输入板卡编号
void | AddChannel (int channel, double centerFrequency, double digitalGain=1.0, double rangeLow=-0.5, double rangeHigh=0.5)
添加采集通道
void | AddChannel (int channel, double rangeLow=-0.5, double rangeHigh=0.5)
添加采集通道 DataFormat=Real时调用
void | RemoveChannel (int channel)
移除已添加的通道，-1为移除所有通道。
void | Commit ()
提交已设置的公共属性至设备.
void | Start ()
启动数据采集任务。
void | Stop ()
停止正在执行的采集任务。
bool | WaitUntilDone (int timeout)
等待当前正在执行的采集任务完成,用于Finite采集模式下等待触发信号。
void | SendSoftwareTrigger ()
发送软件触发，所有已配置的触发均会被满足。
double[] | GetScaleFactor ()
获取电平因子
void | ReadData (ref double[] data, int timeout)
单通道实数
void | ReadData (ref double[,] data, int timeout)
多通道实数
void | ReadData (ref Complex[] data, int timeout)
单通道，Complex格式(IQ)
void | ReadData (ref Complex[,] data, int timeout)
多通道，Complex格式(IQ) 每列表示一个通道的数据
void | ReadData (IntPtr buf, int samplesToRead, int timeout=-1)
单通道或多通道，Complex格式(IQ)，多通道/Complex时为Channel/IQ Interleaved 单通道数据格式：I、Q、I、Q、... 多通道数据格式：Ich1、Qch1、Ich2、Qch2、Ich1、Qch1、Ich2、Qch2...
void | ReadRawData (ref short[] data, int timeout)
单通道或多通道，Complex格式(IQ)，Int16数据多通道/Complex时为Channel/IQ Interleaved 单通道数据格式：I、Q、I、Q、... 多通道数据格式：Ich1、Qch1、Ich2、Qch2、Ich1、Qch1、Ich2、Qch2...
void | ReadRawData (ref short[,] data, int timeout)
多通道，实数格式为ch1、ch1、ch1、ch1、ch2、ch2、ch2、ch2、ch3... 单通道或多通道，Complex格式(IQ)，Int16数据多通道/Complex时为Channel/IQ Interleaved 单通道数据格式：I、Q、I、Q、... 多通道数据格式：Ich1、Qch1、Ich2、Qch2、Ich1、Qch1、Ich2、Qch2...
void | ReadRawData (IntPtr buf, int samplesToRead, int timeout=-1)
单通道或多通道，Complex格式(IQ)，Int16数据多通道/Complex时为Channel/IQ Interleaved 单通道数据格式：I、Q、I、Q、... 多通道数据格式：Ich1、Qch1、Ich2、Qch2、Ich1、Qch1、Ich2、Qch2... short数据采用指针读取
void | GetRecordPreviewData (ref double[,] buf, int timeout)
获取流盘时预览的数据
void | GetRecordPreviewData (ref double[] buf, int samplesPerChannel, int timeout)
获取流盘时预览的数据
void | GetRecordPreviewData (ref double[] buf, int timeout)
获取流盘时预览的数据
void | GetRecordPreviewData (ref Complex[,] buf, int timeout)
获取流盘时预览的数据
void | GetRecordPreviewData (ref Complex[] buf, int samplesPerChannel, int timeout)
获取流盘时预览的数据
void | GetRecordPreviewData (ref Complex[] buf, int timeout)
获取流盘时预览的数据
void | GetRecordStatus (out double recordedLength, out bool recordDone)
获取流盘状态

Properties

JY9824Device | Device [get, set]
操作硬件的对象
AIMode | Mode [get, set]
AI采集模式
double | SampleRate [get, set]
ADC采样率 采样率获取：在调用Commit之前，获取的是用户设置的采样率的值； 在调用Commit之后，获取的是实际的采样率
int | SamplesToAcquire [get, set]
有限点采集时, 每通道采集的样点数。
List< AIChannel > | Channels [get]
通道列表
ulong | AvailableSamples [get]
缓冲区内可以读取的点数
AITrigger | Trigger [get, set]
AI触发参数设置
int | BufLenInSamples [get, set]
缓冲区大小设置，单位是每通道的Sample数
AIOnboardSignalProcessing | Osp [get, set]
高级属性
AISignalExport | SignalExport [get, set]
导出AI信号配置
Record | Record [get, set]
流盘相关参数设置

Detailed Description

AI采集任务类,Sealed类，不可被继承

Constructor & Destructor Documentation

◆ JY9824AITask() [1/2]

JY9824.JY9824AITask.JY9824AITask ( string aliasName )

构造函数,仅输入板卡编号

Parameters
aliasName 板卡的编号

◆ JY9824AITask() [2/2]

JY9824.JY9824AITask.JY9824AITask ( int boardNum )

构造函数,仅输入板卡编号

Parameters
boardNum 板卡的编号

Member Function Documentation

◆ AddChannel() [1/2]

void JY9824.JY9824AITask.AddChannel | ( | int | channel,
 |  | double | centerFrequency,
 |  | double | digitalGain = 1::0,
 |  | double | rangeLow = -0::5,
 |  | double | rangeHigh = 0::5 )

添加采集通道

当DataFormat=Complex时，可设定中心频率，数字增益

Parameters
channel | 通道号
centerFrequency | 中心频率
digitalGain | 数字增益倍数，取值为2^N，N=0~7，自动向下取最接近的数值，如100，自动向下找2^N，则取值64
rangeLow | 通道量程下限：-1、-0.5
rangeHigh | 通道量程上限：1、0.5

◆ AddChannel() [2/2]

void JY9824.JY9824AITask.AddChannel | ( | int | channel,
 |  | double | rangeLow = -0::5,
 |  | double | rangeHigh = 0::5 )

添加采集通道 DataFormat=Real时调用

Parameters
channel | 通道号
rangeLow | 通道量程下限：-1、-0.5
rangeHigh | 通道量程上限：1、0.5

◆ Commit()

void JY9824.JY9824AITask.Commit ( )

提交已设置的公共属性至设备.

◆ GetRecordPreviewData() [1/6]

void JY9824.JY9824AITask.GetRecordPreviewData | ( | ref Complex | buf[,],
 |  | int | timeout )

获取流盘时预览的数据

Parameters
buf | 用户定义返回数据的缓冲区
timeout | 超时时间，单位ms，-1为无限等待

◆ GetRecordPreviewData() [2/6]

void JY9824.JY9824AITask.GetRecordPreviewData | ( | ref Complex[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

获取流盘时预览的数据

Parameters
buf | 用户定义返回数据的缓冲区
samplesPerChannel | 每通道要预览的数据
timeout | 超时时间，单位ms，-1为无限等待

◆ GetRecordPreviewData() [3/6]

void JY9824.JY9824AITask.GetRecordPreviewData | ( | ref Complex[] | buf,
 |  | int | timeout )

获取流盘时预览的数据

Parameters
buf | 用户定义返回数据的缓冲区
timeout | 超时时间，单位ms，-1为无限等待

◆ GetRecordPreviewData() [4/6]

void JY9824.JY9824AITask.GetRecordPreviewData | ( | ref double | buf[,],
 |  | int | timeout )

获取流盘时预览的数据

Parameters
buf | 用户定义返回数据的缓冲区
timeout | 超时时间，单位ms，-1为无限等待

◆ GetRecordPreviewData() [5/6]

void JY9824.JY9824AITask.GetRecordPreviewData | ( | ref double[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

获取流盘时预览的数据

Parameters
buf | 用户定义返回数据的缓冲区
samplesPerChannel | 每通道要预览的数据
timeout | 超时时间，单位ms，-1为无限等待

◆ GetRecordPreviewData() [6/6]

void JY9824.JY9824AITask.GetRecordPreviewData | ( | ref double[] | buf,
 |  | int | timeout )

获取流盘时预览的数据

Parameters
buf | 用户定义返回数据的缓冲区
timeout | 超时时间，单位ms，-1为无限等待

◆ GetRecordStatus()

void JY9824.JY9824AITask.GetRecordStatus | ( | out double | recordedLength,
 |  | out bool | recordDone )

获取流盘状态

Parameters
recordedLength | 已流盘的长度
recordDone | 流盘是否结束

◆ GetScaleFactor()

double[] JY9824.JY9824AITask.GetScaleFactor ( )

获取电平因子

Returns

◆ ReadData() [1/5]

void JY9824.JY9824AITask.ReadData | ( | IntPtr | buf,
 |  | int | samplesToRead,
 |  | int | timeout = -1 )

单通道或多通道，Complex格式(IQ)，多通道/Complex时为Channel/IQ Interleaved 单通道数据格式：I、Q、I、Q、... 多通道数据格式：Ich1、Qch1、Ich2、Qch2、Ich1、Qch1、Ich2、Qch2...

Parameters
buf
samplesToRead
timeout

◆ ReadData() [2/5]

void JY9824.JY9824AITask.ReadData | ( | ref Complex | data[,],
 |  | int | timeout )

多通道，Complex格式(IQ) 每列表示一个通道的数据

Parameters
data
timeout

◆ ReadData() [3/5]

void JY9824.JY9824AITask.ReadData | ( | ref Complex[] | data,
 |  | int | timeout )

单通道，Complex格式(IQ)

Parameters
data
timeout

◆ ReadData() [4/5]

void JY9824.JY9824AITask.ReadData | ( | ref double | data[,],
 |  | int | timeout )

多通道实数

Parameters
data
timeout

◆ ReadData() [5/5]

void JY9824.JY9824AITask.ReadData | ( | ref double[] | data,
 |  | int | timeout )

单通道实数

Parameters
data
timeout

◆ ReadRawData() [1/3]

void JY9824.JY9824AITask.ReadRawData | ( | IntPtr | buf,
 |  | int | samplesToRead,
 |  | int | timeout = -1 )

单通道或多通道，Complex格式(IQ)，Int16数据多通道/Complex时为Channel/IQ Interleaved 单通道数据格式：I、Q、I、Q、... 多通道数据格式：Ich1、Qch1、Ich2、Qch2、Ich1、Qch1、Ich2、Qch2... short数据采用指针读取

Parameters
buf
samplesToRead
timeout

◆ ReadRawData() [2/3]

void JY9824.JY9824AITask.ReadRawData | ( | ref short | data[,],
 |  | int | timeout )

多通道，实数格式为ch1、ch1、ch1、ch1、ch2、ch2、ch2、ch2、ch3... 单通道或多通道，Complex格式(IQ)，Int16数据多通道/Complex时为Channel/IQ Interleaved 单通道数据格式：I、Q、I、Q、... 多通道数据格式：Ich1、Qch1、Ich2、Qch2、Ich1、Qch1、Ich2、Qch2...

Parameters
data
timeout

◆ ReadRawData() [3/3]

void JY9824.JY9824AITask.ReadRawData | ( | ref short[] | data,
 |  | int | timeout )

单通道或多通道，Complex格式(IQ)，Int16数据多通道/Complex时为Channel/IQ Interleaved 单通道数据格式：I、Q、I、Q、... 多通道数据格式：Ich1、Qch1、Ich2、Qch2、Ich1、Qch1、Ich2、Qch2...

Parameters
data
timeout

◆ RemoveChannel()

void JY9824.JY9824AITask.RemoveChannel ( int channel )

移除已添加的通道，-1为移除所有通道。

Parameters
channel

◆ SendSoftwareTrigger()

void JY9824.JY9824AITask.SendSoftwareTrigger ( )

发送软件触发，所有已配置的触发均会被满足。

◆ Start()

void JY9824.JY9824AITask.Start ( )

启动数据采集任务。

◆ Stop()

void JY9824.JY9824AITask.Stop ( )

停止正在执行的采集任务。

◆ WaitUntilDone()

bool JY9824.JY9824AITask.WaitUntilDone ( int timeout )

等待当前正在执行的采集任务完成,用于Finite采集模式下等待触发信号。

Parameters
timeout
Returns

Property Documentation

◆ AvailableSamples

ulong JY9824.JY9824AITask.AvailableSamples
get

缓冲区内可以读取的点数

◆ BufLenInSamples

int JY9824.JY9824AITask.BufLenInSamples
getset

缓冲区大小设置，单位是每通道的Sample数

◆ Channels

List<AIChannel> JY9824.JY9824AITask.Channels
get

通道列表

◆ Device

JY9824Device JY9824.JY9824AITask.Device
getset

操作硬件的对象

◆ Mode

AIMode JY9824.JY9824AITask.Mode
getset

AI采集模式

◆ Osp

AIOnboardSignalProcessing JY9824.JY9824AITask.Osp
getset

高级属性

◆ Record

Record JY9824.JY9824AITask.Record
getset

流盘相关参数设置

◆ SampleRate

double JY9824.JY9824AITask.SampleRate
getset

ADC采样率 采样率获取：在调用Commit之前，获取的是用户设置的采样率的值； 在调用Commit之后，获取的是实际的采样率

◆ SamplesToAcquire

int JY9824.JY9824AITask.SamplesToAcquire
getset

有限点采集时, 每通道采集的样点数。

默认值为1000

◆ SignalExport

AISignalExport JY9824.JY9824AITask.SignalExport
getset

导出AI信号配置

◆ Trigger

AITrigger JY9824.JY9824AITask.Trigger
getset

AI触发参数设置

The documentation for this class was generated from the following file:
  • D:/9824/C#/JY9824Digitizer.cs


9824 C# Programming Manual: JY9824.Record Class Reference

  • Record
Properties | List of all members
JY9824.Record Class Reference

流盘相关的参数定义 More...

Properties

string | FilePath [get, set]
流盘文件的路径，绝对路径，包含文件名
RecordMode | Mode [get, set]
流盘模式
double | Length [get, set]
流盘时间长度，单位为秒，当Mode为Finite时有效
bool | EnablePreview [get, set]
是否使能预览
RecordFormat | Format [get, set]
流盘文件格式
int | MaxMemorySizeInByte [get, set]
最大使用的内存大小（单位MByte），最小200

Detailed Description

流盘相关的参数定义

Property Documentation

◆ EnablePreview

bool JY9824.Record.EnablePreview
getset

是否使能预览

◆ FilePath

string JY9824.Record.FilePath
getset

流盘文件的路径，绝对路径，包含文件名

◆ Format

RecordFormat JY9824.Record.Format
getset

流盘文件格式

◆ Length

double JY9824.Record.Length
getset

流盘时间长度，单位为秒，当Mode为Finite时有效

◆ MaxMemorySizeInByte

int JY9824.Record.MaxMemorySizeInByte
getset

最大使用的内存大小（单位MByte），最小200

◆ Mode

RecordMode JY9824.Record.Mode
getset

流盘模式

The documentation for this class was generated from the following file:
  • D:/9824/C#/JY9824Digitizer.cs


9824 C# Programming Manual: JY9824.AIChannel Class Reference

  • AIChannel
Properties | List of all members
JY9824.AIChannel Class Referencesealed

AI通道参数类 More...

Properties

int | ChannelID [get]
通道号。与AI通道的物理序号相对应。
double | Frequency [get, set]
Frequency.
double | DigitalGain [get, set]
数字增益倍数，取值为2^N，N=0~7，自动向下取最接近的数值，如100，自动向下找2^N，则取值64

Detailed Description

AI通道参数类

Property Documentation

◆ ChannelID

int JY9824.AIChannel.ChannelID
get

通道号。与AI通道的物理序号相对应。

◆ DigitalGain

double JY9824.AIChannel.DigitalGain
getset

数字增益倍数，取值为2^N，N=0~7，自动向下取最接近的数值，如100，自动向下找2^N，则取值64

◆ Frequency

double JY9824.AIChannel.Frequency
getset

Frequency.

The documentation for this class was generated from the following file:
  • D:/9824/C#/JY9824Digitizer.cs


9824 C# Programming Manual: JY9824.AITrigger Class Reference

  • AITrigger
Public Member Functions | Properties | List of all members
JY9824.AITrigger Class Referencesealed

AI触发参数类 More...

Public Member Functions

AITrigger ()
构造函数

Properties

uint | PreTriggerSamples [get, set]
触发前的点数,使用硬件的立即触发或延迟触发模式应将其置为0, 使用硬件的预触发或中间触发模式应将其设置为触发前需要采集的点数(>0)
double | AutoTriggerTime [get, set]
两个trigger间隔的最大时间，超时之后自动触发，-1为永久等待,单位us
double | HoldOffTime [get, set]
两个trigger间隔的最小时间长度，在HOLD_OFF这段时间内，不允许接收新的trigger信号,单位us
double | ReTriggerCount [get, set]
AI重触发次数。为0时不重复触发，>0时为重复触发次数,为-1时无限重触发。
AIDigitalTrigger | Digital [get]
AI数字触发设置
AIAnalogTrigger | Analog [get]
AI模拟触发设置
AITriggerType | Type [get, set]
AI触发类型

Detailed Description

AI触发参数类

Constructor & Destructor Documentation

◆ AITrigger()

JY9824.AITrigger.AITrigger ( )

构造函数

Property Documentation

◆ Analog

AIAnalogTrigger JY9824.AITrigger.Analog
get

AI模拟触发设置

◆ AutoTriggerTime

double JY9824.AITrigger.AutoTriggerTime
getset

两个trigger间隔的最大时间，超时之后自动触发，-1为永久等待,单位us

◆ Digital

AIDigitalTrigger JY9824.AITrigger.Digital
get

AI数字触发设置

◆ HoldOffTime

double JY9824.AITrigger.HoldOffTime
getset

两个trigger间隔的最小时间长度，在HOLD_OFF这段时间内，不允许接收新的trigger信号,单位us

◆ PreTriggerSamples

uint JY9824.AITrigger.PreTriggerSamples
getset

触发前的点数,使用硬件的立即触发或延迟触发模式应将其置为0, 使用硬件的预触发或中间触发模式应将其设置为触发前需要采集的点数(>0)

◆ ReTriggerCount

double JY9824.AITrigger.ReTriggerCount
getset

AI重触发次数。为0时不重复触发，>0时为重复触发次数,为-1时无限重触发。

◆ Type

AITriggerType JY9824.AITrigger.Type
getset

AI触发类型

The documentation for this class was generated from the following file:
  • D:/9824/C#/JY9824Digitizer.cs


9824 C# Programming Manual: JY9824.AIDigitalTrigger Class Reference

  • AIDigitalTrigger
Properties | List of all members
JY9824.AIDigitalTrigger Class Reference

AI数字触发 More...

Properties

AIDigitalTriggerSource | Source [get, set]
AI数字触发源
AIDigitalTriggerEdge | Edge [get, set]
AI数字触发条件

Detailed Description

AI数字触发

Property Documentation

◆ Edge

AIDigitalTriggerEdge JY9824.AIDigitalTrigger.Edge
getset

AI数字触发条件

◆ Source

AIDigitalTriggerSource JY9824.AIDigitalTrigger.Source
getset

AI数字触发源

The documentation for this class was generated from the following file:
  • D:/9824/C#/JY9824Digitizer.cs


9824 C# Programming Manual: JY9824.AIOnboardSignalProcessing Class Reference

  • AIOnboardSignalProcessing
Properties | List of all members
JY9824.AIOnboardSignalProcessing Class Reference

Onboard Signal Processing configuration class. More...

Properties

AIOspDataFormat DataFormat [get, set]
Data Format，Real/Complex Real：ADC data Complex：DDC(Digital DownConversion) IQ data.

Detailed Description

Onboard Signal Processing configuration class.

Property Documentation

◆ DataFormat

AIOspDataFormat JY9824.AIOnboardSignalProcessing.DataFormat
getset

Data Format，Real/Complex Real：ADC data Complex：DDC(Digital DownConversion) IQ data.

The documentation for this class was generated from the following file:
  • D:/9824/C#/JY9824Digitizer.cs


9824 C# Programming Manual: JY9824.AISignalExport Class Reference

  • AISignalExport
Public Member Functions | List of all members
JY9824.AISignalExport Class Reference

信号路由 More...

Public Member Functions

AISignalExport (JY9824AITask taskHandle)
构造函数
void | Add (AISignalExportSource source, SignalExportDestination destination)
添加一路信号路由
void | Clear (SignalExportDestination destination)
删除一路信号路由
void | ClearAll ()
删除全部信号路由

Detailed Description

信号路由

Constructor & Destructor Documentation

◆ AISignalExport()

JY9824.AISignalExport.AISignalExport ( JY9824AITask taskHandle )

构造函数

Member Function Documentation

◆ Add()

void JY9824.AISignalExport.Add | ( | AISignalExportSource | source,
 |  | SignalExportDestination | destination )

添加一路信号路由

Parameters
source
destination

◆ Clear()

void JY9824.AISignalExport.Clear ( SignalExportDestination destination )

删除一路信号路由

Parameters
destination

◆ ClearAll()

void JY9824.AISignalExport.ClearAll ( )

删除全部信号路由

The documentation for this class was generated from the following file:
  • D:/9824/C#/JY9824Digitizer.cs


9824 C# Programming Manual: JY9824.AISync Class Reference

  • AISync
Properties | List of all members
JY9824.AISync Class Reference

同步配置 More...

Properties

SyncTopology Topology [get, set]
Configure sync.

Detailed Description

同步配置

Property Documentation

◆ Topology

SyncTopology JY9824.AISync.Topology
getset

Configure sync.

The documentation for this class was generated from the following file:
  • D:/9824/C#/JY9824Digitizer.cs


9824 C# Programming Manual: D:/9824/C#/JY9824Miscellaneous.cs File Reference

  • File List
  • 9824
  • C#
Classes | Namespaces
JY9824Miscellaneous.cs File Reference

Classes

class | JY9824.JY9824Miscellaneous
JY9824 Miscellaneous parameters.
class | JY9824.DeviceMiscellaneousParam
Device miscellaneous param.

Namespaces

namespace JY9824


9824 C# Programming Manual: D:/9824/C#/JY9824SpectrumTask.cs File Reference

  • File List
  • 9824
  • C#
Classes | Namespaces | Enumerations
JY9824SpectrumTask.cs File Reference

Classes

class | JY9824.JY9824AISpectrumTask
JY9824 AI Spectrum Task Class. More...
class | JY9824.AISpectrumChannel
AI Spectrum Channel Parament Class. More...
class | JY9824.AISpectrumAverageParam
Spectrum Average parameter. More...
class | JY9824.AISpectrumLinearAverageParam
Constructor. More...
class | JY9824.AISpectrumExponentialAverageParam
Constructor. More...
class | JY9824.AISpectrumPeakHoldParam
Constructor. More...
class | JY9824.AISpectrumPseudoPeakHoldParam
Constructor. More...
class | JY9824.AISpectrumFftParam
FFT parameter. More...
class | JY9824.AISpectrumUnitParam
Unit parameter. More...
class | JY9824.SpectralInformation
Spectral Information. More...

Namespaces

namespace JY9824

Enumerations

enum JY9824.AISpectrumAverageMode {
JY9824.NoAveraging , JY9824.ExponentialAverage , JY9824.PseudoPeakHold , JY9824.PeakHold ,
JY9824.LinearAverage
}
Spectrum averageing mode. More...
enum JY9824.FftWindowType {
JY9824.None , JY9824.Hanning , JY9824.Hamming , JY9824.Blackman_Harris ,
JY9824.Exact_Blackman , JY9824.Blackman , JY9824.Three_Term_Nuttal , JY9824.Three_Term_Blackman_Nuttal ,
JY9824.Four_Term_B_Harris , JY9824.Four_Term_Nuttal , JY9824.Four_Term_Blackman_Nuttal , JY9824.Flat_Top_95 ,
JY9824.Flat_Top_90D , JY9824.Five_Term_Least_Sidelobe , JY9824.Six_Term_Flat_Top , JY9824.Six_Term_Least_Sidelobe ,
JY9824.Seven_Term_Flat_Top , JY9824.Seven_Term_Least_Sidelobe
}
FFT window type. More...
enum JY9824.SpectrumUnitType {
JY9824.dBm , JY9824.dBFS , JY9824.dBV , JY9824.dBuV ,
JY9824.V2
}
Spectrum unit type. More...
enum JY9824.FFTFrequencyAlignmentMode { JY9824.Center , JY9824.Lower , JY9824.Upper }
Frequency Alignment Mode. More...


9824 C# Programming Manual: JY9824.JY9824AISpectrumTask Class Reference

  • JY9824AISpectrumTask
Public Member Functions | Properties | List of all members
JY9824.JY9824AISpectrumTask Class Reference

JY9824 AI Spectrum Task Class. More...

Public Member Functions

JY9824AISpectrumTask (int slotNumber)
Constructor.
JY9824AISpectrumTask (string boardName)
Constructor.
void | GetSpectralInformation (out SpectralInformation spectralInfo)
Get Spectral Information.
void | AddChannel (int channelID, double centerFrequency, double rangeLow=-1, double rangeHigh=1)
Add one channel.
void | RemoveChannel (int channelID)
Delete the channel with the specified channel number.
void | ReadSpectrum (IntPtr buf, int samplesPerChannel, int timeout=10000)
Read one or multi-channel data by columns and store it in a data buffer.
void | ReadSpectrum (ref float[,] buf, int samplesPerChannel, int timeout=10000)
Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.
void | ReadSpectrum (ref float[,] buf, int timeout)
Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.
void | ReadSpectrum (ref float[] buf, int samplesPerChannel, int timeout=10000)
Read the one channel data and store it in a data buffer.
void | ReadSpectrum (ref float[] buf, int timeout=10000)
Read the one channel data and store it in a data buffer.
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.
void | Start ()
Start AISpectrumTask.
void | SendSoftwareTrigger ()
Generate a software trigger signal.
void | Stop ()
Stop AISpectrumTask.

Properties

JY9824Device | Device [get]
Device Handle.
List< AISpectrumChannel > | Channels [get, set]
List of AI spectrum channels.
AIMode | Mode [get, set]
AI acquisition mode，support Finite/Continuous/Record.
double | SampleRate [get, set]
Sample rate per channel.
int | OutputDecimationRatio [get, set]
Spectrum data output decimation ratio, relative to FFT data before averaging.
ulong | SamplesToAcquire [get, set]
Number of samples to acquire per channel, must be multiple of number of spectral lines.
int | BufLenInSamples [get]
Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.
ulong | AvailableSamples [get]
Number of samples per channel that can be read in the buffer.
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel).
AITrigger | Trigger [get, set]
AI Trigger Configuration.
AISpectrumFftParam | FFT [get]
Configure spectrum FFT parameters.
AISpectrumAverageParam | Average [get]
Configure spectrum average parameters.
AISpectrumUnitParam | Unit [get]
Spectrum unit param.

Detailed Description

JY9824 AI Spectrum Task Class.

Constructor & Destructor Documentation

◆ JY9824AISpectrumTask() [1/2]

JY9824.JY9824AISpectrumTask.JY9824AISpectrumTask ( int slotNumber )

Constructor.

Used to create an AI spectrum task object.

Parameters
slotNumber Card slot number.

◆ JY9824AISpectrumTask() [2/2]

JY9824.JY9824AISpectrumTask.JY9824AISpectrumTask ( string boardName )

Constructor.

Used to create an AI spectrum task by a board name.

Parameters
boardName Board name(device alias), set by device manager

Member Function Documentation

◆ AddChannel()

void JY9824.JY9824AISpectrumTask.AddChannel | ( | int | channelID,
 |  | double | centerFrequency,
 |  | double | rangeLow = -1,
 |  | double | rangeHigh = 1 )

Add one channel.

Parameters
channelID | channel's physical number ，chnId=-1, add all channels
centerFrequency | spectrum center frequency, Hz
rangeLow | lower range limit for the channel，-50V，-25V，-10V，5V，-1V，-0.5V
rangeHigh | higher range limit for the channel，50V，25V，10V，5V，1V，0.5V
Returns

◆ GetSpectralInformation()

void JY9824.JY9824AISpectrumTask.GetSpectralInformation ( out SpectralInformation spectralInfo )

Get Spectral Information.

Parameters
spectralInfo

◆ ReadSpectrum() [1/5]

void JY9824.JY9824AISpectrumTask.ReadSpectrum | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Read one or multi-channel data by columns and store it in a data buffer.

The buffer is pointed by C# data type IntPtr.

param name="buf">Data buffer

Parameters
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish

◆ ReadSpectrum() [2/5]

void JY9824.JY9824AISpectrumTask.ReadSpectrum | ( | ref float | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.

param name="buf">Data buffer

Parameters
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish

◆ ReadSpectrum() [3/5]

void JY9824.JY9824AISpectrumTask.ReadSpectrum | ( | ref float | buf[,],
 |  | int | timeout )

Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.

param name="buf">Data buffer

Parameters
timeout timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish

◆ ReadSpectrum() [4/5]

void JY9824.JY9824AISpectrumTask.ReadSpectrum | ( | ref float[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000 )

Read the one channel data and store it in a data buffer.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ ReadSpectrum() [5/5]

void JY9824.JY9824AISpectrumTask.ReadSpectrum | ( | ref float[] | buf,
 |  | int | timeout = 10000 )

Read the one channel data and store it in a data buffer.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms

◆ RemoveChannel()

void JY9824.JY9824AISpectrumTask.RemoveChannel ( int channelID )

Delete the channel with the specified channel number.

chnId=- 1, all channels will be deleted

Parameters
channelID Channel number of the channel to be deleted

◆ SendSoftwareTrigger()

void JY9824.JY9824AISpectrumTask.SendSoftwareTrigger ( )

Generate a software trigger signal.

Returns

◆ Start()

void JY9824.JY9824AISpectrumTask.Start ( )

Start AISpectrumTask.

◆ Stop()

void JY9824.JY9824AISpectrumTask.Stop ( )

Stop AISpectrumTask.

◆ WaitUntilDone()

bool JY9824.JY9824AISpectrumTask.WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate

Property Documentation

◆ AvailableSamples

ulong JY9824.JY9824AISpectrumTask.AvailableSamples
get

Number of samples per channel that can be read in the buffer.

◆ Average

AISpectrumAverageParam JY9824.JY9824AISpectrumTask.Average
get

Configure spectrum average parameters.

◆ BufLenInSamples

int JY9824.JY9824AISpectrumTask.BufLenInSamples
get

Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.

◆ Channels

List<AISpectrumChannel> JY9824.JY9824AISpectrumTask.Channels
getset

List of AI spectrum channels.

◆ Device

JY9824Device JY9824.JY9824AISpectrumTask.Device
get

Device Handle.

◆ FFT

AISpectrumFftParam JY9824.JY9824AISpectrumTask.FFT
get

Configure spectrum FFT parameters.

◆ Mode

AIMode JY9824.JY9824AISpectrumTask.Mode
getset

AI acquisition mode，support Finite/Continuous/Record.

◆ OutputDecimationRatio

int JY9824.JY9824AISpectrumTask.OutputDecimationRatio
getset

Spectrum data output decimation ratio, relative to FFT data before averaging.

When average mode is AISpectrumAverageMode.LinearAverage or AISpectrumAverageMode.PeakHold, its value must be the same as average size.

◆ SampleRate

double JY9824.JY9824AISpectrumTask.SampleRate
getset

Sample rate per channel.

Maximum sample rate is 125M for ecah channel. The defalut sample rate = 125M You can read this property to obtain the sample rate that will actually take effect in the current configuration.

◆ SamplesToAcquire

ulong JY9824.JY9824AISpectrumTask.SamplesToAcquire
getset

Number of samples to acquire per channel, must be multiple of number of spectral lines.

Only valid when Mode is AIMode.Finite.

◆ TransferedSamples

ulong JY9824.JY9824AISpectrumTask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

◆ Trigger

AITrigger JY9824.JY9824AISpectrumTask.Trigger
getset

AI Trigger Configuration.

◆ Unit

AISpectrumUnitParam JY9824.JY9824AISpectrumTask.Unit
get

Spectrum unit param.

The documentation for this class was generated from the following file:
  • D:/9824/C#/JY9824SpectrumTask.cs


9824 C# Programming Manual: JY9824.AISpectrumChannel Class Reference

  • AISpectrumChannel
Properties | List of all members
JY9824.AISpectrumChannel Class Referencesealed

AI Spectrum Channel Parament Class. More...

Properties

int | ChannelID [get]
AI channel ID.
double | RangeLow [get, set]
Low range limit an AI channel -10V,-5V, -1V，-0.5V.
double | RangeHigh [get, set]
High range limit an AI channel 10V,5V, 1V，0.5V.
double | CenterFrequency [get, set]
Center frequency of spectrum, Hz.

Detailed Description

AI Spectrum Channel Parament Class.

Property Documentation

◆ CenterFrequency

double JY9824.AISpectrumChannel.CenterFrequency
getset

Center frequency of spectrum, Hz.

◆ ChannelID

int JY9824.AISpectrumChannel.ChannelID
get

AI channel ID.

◆ RangeHigh

double JY9824.AISpectrumChannel.RangeHigh
getset

High range limit an AI channel 10V,5V, 1V，0.5V.

◆ RangeLow

double JY9824.AISpectrumChannel.RangeLow
getset

Low range limit an AI channel -10V,-5V, -1V，-0.5V.

The documentation for this class was generated from the following file:
  • D:/9824/C#/JY9824SpectrumTask.cs


9824 C# Programming Manual: JY9824.AISpectrumAverageParam Class Reference

  • AISpectrumAverageParam
Properties | List of all members
JY9824.AISpectrumAverageParam Class Reference

Spectrum Average parameter. More...

Properties

AISpectrumAverageMode | Mode [get, set]
Spectrum averageing mode.
AISpectrumLinearAverageParam | Linear [get]
Spectrum average param when averaging mode is AISpectrumAverageMode.LinearAverage.
AISpectrumExponentialAverageParam | Exponential [get]
Spectrum average param when averaging mode is AISpectrumAverageMode.ExponentialAverage.
AISpectrumPeakHoldParam | PeakHold [get]
Spectrum average param when averaging mode is AISpectrumAverageMode.PeakHold.
AISpectrumPseudoPeakHoldParam | PseudoPeakHold [get]
Spectrum average param when averaging mode is AISpectrumAverageMode.PseudoPeakHold.

Detailed Description

Spectrum Average parameter.

Property Documentation

◆ Exponential

AISpectrumExponentialAverageParam JY9824.AISpectrumAverageParam.Exponential
get

Spectrum average param when averaging mode is AISpectrumAverageMode.ExponentialAverage.

◆ Linear

AISpectrumLinearAverageParam JY9824.AISpectrumAverageParam.Linear
get

Spectrum average param when averaging mode is AISpectrumAverageMode.LinearAverage.

◆ Mode

AISpectrumAverageMode JY9824.AISpectrumAverageParam.Mode
getset

Spectrum averageing mode.

◆ PeakHold

AISpectrumPeakHoldParam JY9824.AISpectrumAverageParam.PeakHold
get

Spectrum average param when averaging mode is AISpectrumAverageMode.PeakHold.

◆ PseudoPeakHold

AISpectrumPseudoPeakHoldParam JY9824.AISpectrumAverageParam.PseudoPeakHold
get

Spectrum average param when averaging mode is AISpectrumAverageMode.PseudoPeakHold.

The documentation for this class was generated from the following file:
  • D:/9824/C#/JY9824SpectrumTask.cs


9824 C# Programming Manual: JY9824.AISpectrumLinearAverageParam Class Reference

  • AISpectrumLinearAverageParam
Properties | List of all members
JY9824.AISpectrumLinearAverageParam Class Reference

Constructor. More...

Properties

int Size [get, set]
Average Size.

Detailed Description

Constructor.

Used to create a AISpectrumLinearAverageParam object.

Property Documentation

◆ Size

int JY9824.AISpectrumLinearAverageParam.Size
getset

Average Size.

The documentation for this class was generated from the following file:
  • D:/9824/C#/JY9824SpectrumTask.cs


9824 C# Programming Manual: JY9824.AISpectrumExponentialAverageParam Class Reference

  • AISpectrumExponentialAverageParam
Properties | List of all members
JY9824.AISpectrumExponentialAverageParam Class Reference

Constructor. More...

Properties

double TimeConstant [get, set]
Exponential weighting time constant, (0, 1], the α in formula: Y[n] = α* x[n] + (1 - α) * Y[n - 1].

Detailed Description

Constructor.

Used to create a AISpectrumExponentialAverageParam object.

Property Documentation

◆ TimeConstant

double JY9824.AISpectrumExponentialAverageParam.TimeConstant
getset

Exponential weighting time constant, (0, 1], the α in formula: Y[n] = α* x[n] + (1 - α) * Y[n - 1].

The documentation for this class was generated from the following file:
  • D:/9824/C#/JY9824SpectrumTask.cs


9824 C# Programming Manual: JY9824.AISpectrumPeakHoldParam Class Reference

  • AISpectrumPeakHoldParam
Properties | List of all members
JY9824.AISpectrumPeakHoldParam Class Reference

Constructor. More...

Properties

int Size [get, set]
Average Size.

Detailed Description

Constructor.

Used to create a AISpectrumPeakHoldParam object.

Property Documentation

◆ Size

int JY9824.AISpectrumPeakHoldParam.Size
getset

Average Size.

The documentation for this class was generated from the following file:
  • D:/9824/C#/JY9824SpectrumTask.cs


9824 C# Programming Manual: JY9824.AISpectrumPseudoPeakHoldParam Class Reference

  • AISpectrumPseudoPeakHoldParam
Properties | List of all members
JY9824.AISpectrumPseudoPeakHoldParam Class Reference

Constructor. More...

Properties

double TimeConstant [get, set]
Exponential weighting time constant, (0, 1], the α in formula: Y[n] = α* x[n] + (1 - α) * Y[n - 1].

Detailed Description

Constructor.

Used to create a AISpectrumPseudoPeakHoldParam object.

Property Documentation

◆ TimeConstant

double JY9824.AISpectrumPseudoPeakHoldParam.TimeConstant
getset

Exponential weighting time constant, (0, 1], the α in formula: Y[n] = α* x[n] + (1 - α) * Y[n - 1].

The documentation for this class was generated from the following file:
  • D:/9824/C#/JY9824SpectrumTask.cs


9824 C# Programming Manual: JY9824.AISpectrumFftParam Class Reference

  • AISpectrumFftParam
Properties | List of all members
JY9824.AISpectrumFftParam Class Reference

FFT parameter. More...

Properties

double | ExpectBandwidth [get, set]
Expect bandwidth, Hz.
int | ExpectNumOfSpectralLines [get, set]
Expect number of spectral lines within bandwidth, Hz.
FftWindowType | WindowType [get, set]
FFT window type.
FFTFrequencyAlignmentMode | FrequencyAlignmentMode [get, set]
FFT Frequency Alignment Mode.

Detailed Description

FFT parameter.

Property Documentation

◆ ExpectBandwidth

double JY9824.AISpectrumFftParam.ExpectBandwidth
getset

Expect bandwidth, Hz.

Actual bandwidth could be get by GetSpectralInformation() Method. 预期频谱带宽，以Hz为单位。本属性不会返回实际的频谱带宽，实际的频谱带宽可通过GetSpectralInformation()方法获取。

◆ ExpectNumOfSpectralLines

int JY9824.AISpectrumFftParam.ExpectNumOfSpectralLines
getset

Expect number of spectral lines within bandwidth, Hz.

Actual number of spectral lines could be get by GetSpectralInformation() Method. 在设定带宽内预期的频谱线数。本属性不会返回实际的频谱线数，实际的频谱线数可通过GetSpectralInformation()方法获取。

◆ FrequencyAlignmentMode

FFTFrequencyAlignmentMode JY9824.AISpectrumFftParam.FrequencyAlignmentMode
getset

FFT Frequency Alignment Mode.

◆ WindowType

FftWindowType JY9824.AISpectrumFftParam.WindowType
getset

FFT window type.

The documentation for this class was generated from the following file:
  • D:/9824/C#/JY9824SpectrumTask.cs


9824 C# Programming Manual: JY9824.AISpectrumUnitParam Class Reference

  • AISpectrumUnitParam
Properties | List of all members
JY9824.AISpectrumUnitParam Class Reference

Unit parameter. More...

Properties

SpectrumUnitType | Type [get, set]
Unit type.
bool | IsPSD [get, set]
whether convert to Power Spectral Density.

Detailed Description

Unit parameter.

Property Documentation

◆ IsPSD

bool JY9824.AISpectrumUnitParam.IsPSD
getset

whether convert to Power Spectral Density.

◆ Type

SpectrumUnitType JY9824.AISpectrumUnitParam.Type
getset

Unit type.

The documentation for this class was generated from the following file:
  • D:/9824/C#/JY9824SpectrumTask.cs


9824 C# Programming Manual: JY9824.SpectralInformation Class Reference

  • SpectralInformation
Properties | List of all members
JY9824.SpectralInformation Class Reference

Spectral Information. More...

Properties

double | CenterFrequency [get, set]
Actual center frequency.
double | FrequencyStart [get, set]
Actual start frequency of spectrum.
double | FrequencyStep [get, set]
Actual frequency step of spectrum.
int | NumOfSpectralLines [get, set]
Number of spectral lines.
double | ResolutionBandwidth [get, set]
Frequency resolution bandwidth of spectrum.
SpectrumUnitType | UnitType [get, set]
Unit of spectrum enum(dBm/dBuV/V^2...)
bool | IsPsd [get, set]
whether spectrum is psd (Power Spectral Density) type.
FftWindowType | FftWindowType [get, set]
FFT window type.
double | ENBW [get, set]
ENBW.
int | FftSize [get, set]
FFT size.

Detailed Description

Spectral Information.

Property Documentation

◆ CenterFrequency

double JY9824.SpectralInformation.CenterFrequency
getset

Actual center frequency.

◆ ENBW

double JY9824.SpectralInformation.ENBW
getset

ENBW.

◆ FftSize

int JY9824.SpectralInformation.FftSize
getset

FFT size.

◆ FftWindowType

FftWindowType JY9824.SpectralInformation.FftWindowType
getset

FFT window type.

◆ FrequencyStart

double JY9824.SpectralInformation.FrequencyStart
getset

Actual start frequency of spectrum.

◆ FrequencyStep

double JY9824.SpectralInformation.FrequencyStep
getset

Actual frequency step of spectrum.

◆ IsPsd

bool JY9824.SpectralInformation.IsPsd
getset

whether spectrum is psd (Power Spectral Density) type.

◆ NumOfSpectralLines

int JY9824.SpectralInformation.NumOfSpectralLines
getset

Number of spectral lines.

◆ ResolutionBandwidth

double JY9824.SpectralInformation.ResolutionBandwidth
getset

Frequency resolution bandwidth of spectrum.

◆ UnitType

SpectrumUnitType JY9824.SpectralInformation.UnitType
getset

Unit of spectrum enum(dBm/dBuV/V^2...)

The documentation for this class was generated from the following file:
  • D:/9824/C#/JY9824SpectrumTask.cs


9824 C# Programming Manual: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
▼N JY9824 |
C AIAnalogEdgeComparator | AI Analog Edge Comparator
C AIAnalogHysteresisComparator | AI Analog Hysteresis Comparator
C AIAnalogTrigger | AI Analog Trigger
C AIAnalogWindowComparator | AI Analog Window Comparator
C AIChannel | AI通道参数类
C AIDigitalTrigger | AI数字触发
C AIOnboardSignalProcessing | Onboard Signal Processing configuration class
C AISignalExport | 信号路由
C AISpectrumAverageParam | Spectrum Average parameter
C AISpectrumChannel | AI Spectrum Channel Parament Class
C AISpectrumExponentialAverageParam | Constructor
C AISpectrumFftParam | FFT parameter
C AISpectrumLinearAverageParam | Constructor
C AISpectrumPeakHoldParam | Constructor
C AISpectrumPseudoPeakHoldParam | Constructor
C AISpectrumUnitParam | Unit parameter
C AISync | 同步配置
C AITrigger | AI触发参数类
C JY9824AISpectrumTask | JY9824 AI Spectrum Task Class
C JY9824AITask | AI采集任务类,Sealed类，不可被继承
C Record | 流盘相关的参数定义
C SpectralInformation | Spectral Information


9824 C# Programming Manual: Member List

  • AIAnalogEdgeComparator
JY9824.AIAnalogEdgeComparator Member List

This is the complete list of members for JY9824.AIAnalogEdgeComparator, including all inherited members.

Slope | JY9824.AIAnalogEdgeComparator
Threshold | JY9824.AIAnalogEdgeComparator


9824 C# Programming Manual: Member List

  • AIAnalogHysteresisComparator
JY9824.AIAnalogHysteresisComparator Member List

This is the complete list of members for JY9824.AIAnalogHysteresisComparator, including all inherited members.

HighThreshold | JY9824.AIAnalogHysteresisComparator
LowThreshold | JY9824.AIAnalogHysteresisComparator
Slope | JY9824.AIAnalogHysteresisComparator


9824 C# Programming Manual: Member List

  • AIAnalogTrigger
JY9824.AIAnalogTrigger Member List

This is the complete list of members for JY9824.AIAnalogTrigger, including all inherited members.

Comparator | JY9824.AIAnalogTrigger
Edge | JY9824.AIAnalogTrigger
Hysteresis | JY9824.AIAnalogTrigger
Source | JY9824.AIAnalogTrigger
Window | JY9824.AIAnalogTrigger


9824 C# Programming Manual: Member List

  • AIAnalogWindowComparator
JY9824.AIAnalogWindowComparator Member List

This is the complete list of members for JY9824.AIAnalogWindowComparator, including all inherited members.

Condition | JY9824.AIAnalogWindowComparator
HighThreshold | JY9824.AIAnalogWindowComparator
LowThreshold | JY9824.AIAnalogWindowComparator


9824 C# Programming Manual: Member List

  • AIChannel
JY9824.AIChannel Member List

This is the complete list of members for JY9824.AIChannel, including all inherited members.

ChannelID | JY9824.AIChannel
DigitalGain | JY9824.AIChannel
Frequency | JY9824.AIChannel


9824 C# Programming Manual: Member List

  • AIDigitalTrigger
JY9824.AIDigitalTrigger Member List

This is the complete list of members for JY9824.AIDigitalTrigger, including all inherited members.

Edge | JY9824.AIDigitalTrigger
Source | JY9824.AIDigitalTrigger


9824 C# Programming Manual: Member List

  • AIOnboardSignalProcessing
JY9824.AIOnboardSignalProcessing Member List

This is the complete list of members for JY9824.AIOnboardSignalProcessing, including all inherited members.

DataFormat JY9824.AIOnboardSignalProcessing


9824 C# Programming Manual: Member List

  • AISignalExport
JY9824.AISignalExport Member List

This is the complete list of members for JY9824.AISignalExport, including all inherited members.

Add(AISignalExportSource source, SignalExportDestination destination) | JY9824.AISignalExport
AISignalExport(JY9824AITask taskHandle) | JY9824.AISignalExport
Clear(SignalExportDestination destination) | JY9824.AISignalExport
ClearAll() | JY9824.AISignalExport


9824 C# Programming Manual: Member List

  • AISpectrumAverageParam
JY9824.AISpectrumAverageParam Member List

This is the complete list of members for JY9824.AISpectrumAverageParam, including all inherited members.

Exponential | JY9824.AISpectrumAverageParam
Linear | JY9824.AISpectrumAverageParam
Mode | JY9824.AISpectrumAverageParam
PeakHold | JY9824.AISpectrumAverageParam
PseudoPeakHold | JY9824.AISpectrumAverageParam


9824 C# Programming Manual: Member List

  • AISpectrumChannel
JY9824.AISpectrumChannel Member List

This is the complete list of members for JY9824.AISpectrumChannel, including all inherited members.

CenterFrequency | JY9824.AISpectrumChannel
ChannelID | JY9824.AISpectrumChannel
RangeHigh | JY9824.AISpectrumChannel
RangeLow | JY9824.AISpectrumChannel


9824 C# Programming Manual: Member List

  • AISpectrumExponentialAverageParam
JY9824.AISpectrumExponentialAverageParam Member List

This is the complete list of members for JY9824.AISpectrumExponentialAverageParam, including all inherited members.

TimeConstant JY9824.AISpectrumExponentialAverageParam


9824 C# Programming Manual: Member List

  • AISpectrumFftParam
JY9824.AISpectrumFftParam Member List

This is the complete list of members for JY9824.AISpectrumFftParam, including all inherited members.

ExpectBandwidth | JY9824.AISpectrumFftParam
ExpectNumOfSpectralLines | JY9824.AISpectrumFftParam
FrequencyAlignmentMode | JY9824.AISpectrumFftParam
WindowType | JY9824.AISpectrumFftParam


9824 C# Programming Manual: Member List

  • AISpectrumLinearAverageParam
JY9824.AISpectrumLinearAverageParam Member List

This is the complete list of members for JY9824.AISpectrumLinearAverageParam, including all inherited members.

Size JY9824.AISpectrumLinearAverageParam


9824 C# Programming Manual: Member List

  • AISpectrumPeakHoldParam
JY9824.AISpectrumPeakHoldParam Member List

This is the complete list of members for JY9824.AISpectrumPeakHoldParam, including all inherited members.

Size JY9824.AISpectrumPeakHoldParam


9824 C# Programming Manual: Member List

  • AISpectrumPseudoPeakHoldParam
JY9824.AISpectrumPseudoPeakHoldParam Member List

This is the complete list of members for JY9824.AISpectrumPseudoPeakHoldParam, including all inherited members.

TimeConstant JY9824.AISpectrumPseudoPeakHoldParam


9824 C# Programming Manual: Member List

  • AISpectrumUnitParam
JY9824.AISpectrumUnitParam Member List

This is the complete list of members for JY9824.AISpectrumUnitParam, including all inherited members.

IsPSD | JY9824.AISpectrumUnitParam
Type | JY9824.AISpectrumUnitParam


9824 C# Programming Manual: Member List

  • AISync
JY9824.AISync Member List

This is the complete list of members for JY9824.AISync, including all inherited members.

Topology JY9824.AISync


9824 C# Programming Manual: Member List

  • AITrigger
JY9824.AITrigger Member List

This is the complete list of members for JY9824.AITrigger, including all inherited members.

AITrigger() | JY9824.AITrigger
Analog | JY9824.AITrigger
AutoTriggerTime | JY9824.AITrigger
Digital | JY9824.AITrigger
HoldOffTime | JY9824.AITrigger
PreTriggerSamples | JY9824.AITrigger
ReTriggerCount | JY9824.AITrigger
Type | JY9824.AITrigger


9824 C# Programming Manual: Member List

  • JY9824AISpectrumTask
JY9824.JY9824AISpectrumTask Member List

This is the complete list of members for JY9824.JY9824AISpectrumTask, including all inherited members.

AddChannel(int channelID, double centerFrequency, double rangeLow=-1, double rangeHigh=1) | JY9824.JY9824AISpectrumTask
AvailableSamples | JY9824.JY9824AISpectrumTask
Average | JY9824.JY9824AISpectrumTask
BufLenInSamples | JY9824.JY9824AISpectrumTask
Channels | JY9824.JY9824AISpectrumTask
Device | JY9824.JY9824AISpectrumTask
FFT | JY9824.JY9824AISpectrumTask
GetSpectralInformation(out SpectralInformation spectralInfo) | JY9824.JY9824AISpectrumTask
JY9824AISpectrumTask(int slotNumber) | JY9824.JY9824AISpectrumTask
JY9824AISpectrumTask(string boardName) | JY9824.JY9824AISpectrumTask
Mode | JY9824.JY9824AISpectrumTask
OutputDecimationRatio | JY9824.JY9824AISpectrumTask
ReadSpectrum(IntPtr buf, int samplesPerChannel, int timeout=10000) | JY9824.JY9824AISpectrumTask
ReadSpectrum(ref float[,] buf, int samplesPerChannel, int timeout=10000) | JY9824.JY9824AISpectrumTask
ReadSpectrum(ref float[,] buf, int timeout) | JY9824.JY9824AISpectrumTask
ReadSpectrum(ref float[] buf, int samplesPerChannel, int timeout=10000) | JY9824.JY9824AISpectrumTask
ReadSpectrum(ref float[] buf, int timeout=10000) | JY9824.JY9824AISpectrumTask
RemoveChannel(int channelID) | JY9824.JY9824AISpectrumTask
SampleRate | JY9824.JY9824AISpectrumTask
SamplesToAcquire | JY9824.JY9824AISpectrumTask
SendSoftwareTrigger() | JY9824.JY9824AISpectrumTask
Start() | JY9824.JY9824AISpectrumTask
Stop() | JY9824.JY9824AISpectrumTask
TransferedSamples | JY9824.JY9824AISpectrumTask
Trigger | JY9824.JY9824AISpectrumTask
Unit | JY9824.JY9824AISpectrumTask
WaitUntilDone(int timeout=-1) | JY9824.JY9824AISpectrumTask


9824 C# Programming Manual: Member List

  • JY9824AITask
JY9824.JY9824AITask Member List

This is the complete list of members for JY9824.JY9824AITask, including all inherited members.

AddChannel(int channel, double centerFrequency, double digitalGain=1.0, double rangeLow=-0.5, double rangeHigh=0.5) | JY9824.JY9824AITask
AddChannel(int channel, double rangeLow=-0.5, double rangeHigh=0.5) | JY9824.JY9824AITask
AvailableSamples | JY9824.JY9824AITask
BufLenInSamples | JY9824.JY9824AITask
Channels | JY9824.JY9824AITask
Commit() | JY9824.JY9824AITask
Device | JY9824.JY9824AITask
GetRecordPreviewData(ref double[,] buf, int timeout) | JY9824.JY9824AITask
GetRecordPreviewData(ref double[] buf, int samplesPerChannel, int timeout) | JY9824.JY9824AITask
GetRecordPreviewData(ref double[] buf, int timeout) | JY9824.JY9824AITask
GetRecordPreviewData(ref Complex[,] buf, int timeout) | JY9824.JY9824AITask
GetRecordPreviewData(ref Complex[] buf, int samplesPerChannel, int timeout) | JY9824.JY9824AITask
GetRecordPreviewData(ref Complex[] buf, int timeout) | JY9824.JY9824AITask
GetRecordStatus(out double recordedLength, out bool recordDone) | JY9824.JY9824AITask
GetScaleFactor() | JY9824.JY9824AITask
JY9824AITask(string aliasName) | JY9824.JY9824AITask
JY9824AITask(int boardNum) | JY9824.JY9824AITask
Mode | JY9824.JY9824AITask
Osp | JY9824.JY9824AITask
ReadData(ref double[] data, int timeout) | JY9824.JY9824AITask
ReadData(ref double[,] data, int timeout) | JY9824.JY9824AITask
ReadData(ref Complex[] data, int timeout) | JY9824.JY9824AITask
ReadData(ref Complex[,] data, int timeout) | JY9824.JY9824AITask
ReadData(IntPtr buf, int samplesToRead, int timeout=-1) | JY9824.JY9824AITask
ReadRawData(ref short[] data, int timeout) | JY9824.JY9824AITask
ReadRawData(ref short[,] data, int timeout) | JY9824.JY9824AITask
ReadRawData(IntPtr buf, int samplesToRead, int timeout=-1) | JY9824.JY9824AITask
Record | JY9824.JY9824AITask
RemoveChannel(int channel) | JY9824.JY9824AITask
SampleRate | JY9824.JY9824AITask
SamplesToAcquire | JY9824.JY9824AITask
SendSoftwareTrigger() | JY9824.JY9824AITask
SignalExport | JY9824.JY9824AITask
Start() | JY9824.JY9824AITask
Stop() | JY9824.JY9824AITask
Trigger | JY9824.JY9824AITask
WaitUntilDone(int timeout) | JY9824.JY9824AITask


9824 C# Programming Manual: Member List

  • Record
JY9824.Record Member List

This is the complete list of members for JY9824.Record, including all inherited members.

EnablePreview | JY9824.Record
FilePath | JY9824.Record
Format | JY9824.Record
Length | JY9824.Record
MaxMemorySizeInByte | JY9824.Record
Mode | JY9824.Record


9824 C# Programming Manual: Member List

  • SpectralInformation
JY9824.SpectralInformation Member List

This is the complete list of members for JY9824.SpectralInformation, including all inherited members.

CenterFrequency | JY9824.SpectralInformation
ENBW | JY9824.SpectralInformation
FftSize | JY9824.SpectralInformation
FftWindowType | JY9824.SpectralInformation
FrequencyStart | JY9824.SpectralInformation
FrequencyStep | JY9824.SpectralInformation
IsPsd | JY9824.SpectralInformation
NumOfSpectralLines | JY9824.SpectralInformation
ResolutionBandwidth | JY9824.SpectralInformation
UnitType | JY9824.SpectralInformation


9824 C# Programming Manual: Class Index

Class Index
A | J | R | S
A
AIAnalogEdgeComparator (JY9824)
AIAnalogHysteresisComparator (JY9824)
AIAnalogTrigger (JY9824)
AIAnalogWindowComparator (JY9824)
AIChannel (JY9824)
AIDigitalTrigger (JY9824)
AIOnboardSignalProcessing (JY9824)
AISignalExport (JY9824)
AISpectrumAverageParam (JY9824)
AISpectrumChannel (JY9824)
AISpectrumExponentialAverageParam (JY9824)
AISpectrumFftParam (JY9824)
AISpectrumLinearAverageParam (JY9824)
AISpectrumPeakHoldParam (JY9824)
AISpectrumPseudoPeakHoldParam (JY9824)
AISpectrumUnitParam (JY9824)
AISync (JY9824)
AITrigger (JY9824)
J
JY9824AISpectrumTask (JY9824)
JY9824AITask (JY9824)
R
Record (JY9824)
S
SpectralInformation (JY9824)


9824 C# Programming Manual: D:/9824 Directory Reference

  • File List
  • 9824
9824 Directory Reference

Directories

C#


9824 C# Programming Manual: File List

  • File List
File List
Here is a list of all files with brief descriptions:
[detail level 123]
▼ 9824
▼ C#
AIAnalogTrigger.cs
JY9824Digitizer.cs
JY9824Miscellaneous.cs
JY9824SpectrumTask.cs


9824 C# Programming Manual: Class Members

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all class members with links to the classes they belong to:

- a -

  • Add() : JY9824.AISignalExport
  • AddChannel() : JY9824.JY9824AISpectrumTask, JY9824.JY9824AITask
  • AISignalExport() : JY9824.AISignalExport
  • AITrigger() : JY9824.AITrigger
  • Analog : JY9824.AITrigger
  • AutoTriggerTime : JY9824.AITrigger
  • AvailableSamples : JY9824.JY9824AISpectrumTask, JY9824.JY9824AITask
  • Average : JY9824.JY9824AISpectrumTask

- b -

  • BufLenInSamples : JY9824.JY9824AISpectrumTask, JY9824.JY9824AITask

- c -

  • CenterFrequency : JY9824.AISpectrumChannel, JY9824.SpectralInformation
  • ChannelID : JY9824.AIChannel, JY9824.AISpectrumChannel
  • Channels : JY9824.JY9824AISpectrumTask, JY9824.JY9824AITask
  • Clear() : JY9824.AISignalExport
  • ClearAll() : JY9824.AISignalExport
  • Commit() : JY9824.JY9824AITask
  • Comparator : JY9824.AIAnalogTrigger
  • Condition : JY9824.AIAnalogWindowComparator

- d -

  • DataFormat : JY9824.AIOnboardSignalProcessing
  • Device : JY9824.JY9824AISpectrumTask, JY9824.JY9824AITask
  • Digital : JY9824.AITrigger
  • DigitalGain : JY9824.AIChannel

- e -

  • Edge : JY9824.AIAnalogTrigger, JY9824.AIDigitalTrigger
  • EnablePreview : JY9824.Record
  • ENBW : JY9824.SpectralInformation
  • ExpectBandwidth : JY9824.AISpectrumFftParam
  • ExpectNumOfSpectralLines : JY9824.AISpectrumFftParam
  • Exponential : JY9824.AISpectrumAverageParam

- f -

  • FFT : JY9824.JY9824AISpectrumTask
  • FftSize : JY9824.SpectralInformation
  • FftWindowType : JY9824.SpectralInformation
  • FilePath : JY9824.Record
  • Format : JY9824.Record
  • Frequency : JY9824.AIChannel
  • FrequencyAlignmentMode : JY9824.AISpectrumFftParam
  • FrequencyStart : JY9824.SpectralInformation
  • FrequencyStep : JY9824.SpectralInformation

- g -

  • GetRecordPreviewData() : JY9824.JY9824AITask
  • GetRecordStatus() : JY9824.JY9824AITask
  • GetScaleFactor() : JY9824.JY9824AITask
  • GetSpectralInformation() : JY9824.JY9824AISpectrumTask

- h -

  • HighThreshold : JY9824.AIAnalogHysteresisComparator, JY9824.AIAnalogWindowComparator
  • HoldOffTime : JY9824.AITrigger
  • Hysteresis : JY9824.AIAnalogTrigger

- i -

  • IsPSD : JY9824.AISpectrumUnitParam
  • IsPsd : JY9824.SpectralInformation

- j -

  • JY9824AISpectrumTask() : JY9824.JY9824AISpectrumTask
  • JY9824AITask() : JY9824.JY9824AITask

- l -

  • Length : JY9824.Record
  • Linear : JY9824.AISpectrumAverageParam
  • LowThreshold : JY9824.AIAnalogHysteresisComparator, JY9824.AIAnalogWindowComparator

- m -

  • MaxMemorySizeInByte : JY9824.Record
  • Mode : JY9824.AISpectrumAverageParam, JY9824.JY9824AISpectrumTask, JY9824.JY9824AITask, JY9824.Record

- n -

  • NumOfSpectralLines : JY9824.SpectralInformation

- o -

  • Osp : JY9824.JY9824AITask
  • OutputDecimationRatio : JY9824.JY9824AISpectrumTask

- p -

  • PeakHold : JY9824.AISpectrumAverageParam
  • PreTriggerSamples : JY9824.AITrigger
  • PseudoPeakHold : JY9824.AISpectrumAverageParam

- r -

  • RangeHigh : JY9824.AISpectrumChannel
  • RangeLow : JY9824.AISpectrumChannel
  • ReadData() : JY9824.JY9824AITask
  • ReadRawData() : JY9824.JY9824AITask
  • ReadSpectrum() : JY9824.JY9824AISpectrumTask
  • Record : JY9824.JY9824AITask
  • RemoveChannel() : JY9824.JY9824AISpectrumTask, JY9824.JY9824AITask
  • ResolutionBandwidth : JY9824.SpectralInformation
  • ReTriggerCount : JY9824.AITrigger

- s -

  • SampleRate : JY9824.JY9824AISpectrumTask, JY9824.JY9824AITask
  • SamplesToAcquire : JY9824.JY9824AISpectrumTask, JY9824.JY9824AITask
  • SendSoftwareTrigger() : JY9824.JY9824AISpectrumTask, JY9824.JY9824AITask
  • SignalExport : JY9824.JY9824AITask
  • Size : JY9824.AISpectrumLinearAverageParam, JY9824.AISpectrumPeakHoldParam
  • Slope : JY9824.AIAnalogEdgeComparator, JY9824.AIAnalogHysteresisComparator
  • Source : JY9824.AIAnalogTrigger, JY9824.AIDigitalTrigger
  • Start() : JY9824.JY9824AISpectrumTask, JY9824.JY9824AITask
  • Stop() : JY9824.JY9824AISpectrumTask, JY9824.JY9824AITask

- t -

  • Threshold : JY9824.AIAnalogEdgeComparator
  • TimeConstant : JY9824.AISpectrumExponentialAverageParam, JY9824.AISpectrumPseudoPeakHoldParam
  • Topology : JY9824.AISync
  • TransferedSamples : JY9824.JY9824AISpectrumTask
  • Trigger : JY9824.JY9824AISpectrumTask, JY9824.JY9824AITask
  • Type : JY9824.AISpectrumUnitParam, JY9824.AITrigger

- u -

  • Unit : JY9824.JY9824AISpectrumTask
  • UnitType : JY9824.SpectralInformation

- w -

  • WaitUntilDone() : JY9824.JY9824AISpectrumTask, JY9824.JY9824AITask
  • Window : JY9824.AIAnalogTrigger
  • WindowType : JY9824.AISpectrumFftParam


9824 C# Programming Manual: Class Members - Functions

  • All
  • Functions
  • Properties
  • a
  • c
  • g
  • j
  • r
  • s
  • w
Here is a list of all functions with links to the classes they belong to:

- a -

  • Add() : JY9824.AISignalExport
  • AddChannel() : JY9824.JY9824AISpectrumTask, JY9824.JY9824AITask
  • AISignalExport() : JY9824.AISignalExport
  • AITrigger() : JY9824.AITrigger

- c -

  • Clear() : JY9824.AISignalExport
  • ClearAll() : JY9824.AISignalExport
  • Commit() : JY9824.JY9824AITask

- g -

  • GetRecordPreviewData() : JY9824.JY9824AITask
  • GetRecordStatus() : JY9824.JY9824AITask
  • GetScaleFactor() : JY9824.JY9824AITask
  • GetSpectralInformation() : JY9824.JY9824AISpectrumTask

- j -

  • JY9824AISpectrumTask() : JY9824.JY9824AISpectrumTask
  • JY9824AITask() : JY9824.JY9824AITask

- r -

  • ReadData() : JY9824.JY9824AITask
  • ReadRawData() : JY9824.JY9824AITask
  • ReadSpectrum() : JY9824.JY9824AISpectrumTask
  • RemoveChannel() : JY9824.JY9824AISpectrumTask, JY9824.JY9824AITask

- s -

  • SendSoftwareTrigger() : JY9824.JY9824AISpectrumTask, JY9824.JY9824AITask
  • Start() : JY9824.JY9824AISpectrumTask, JY9824.JY9824AITask
  • Stop() : JY9824.JY9824AISpectrumTask, JY9824.JY9824AITask

- w -

  • WaitUntilDone() : JY9824.JY9824AISpectrumTask, JY9824.JY9824AITask


9824 C# Programming Manual: Class Members - Properties

  • All
  • Functions
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
Here is a list of all properties with links to the classes they belong to:

- a -

  • Analog : JY9824.AITrigger
  • AutoTriggerTime : JY9824.AITrigger
  • AvailableSamples : JY9824.JY9824AISpectrumTask, JY9824.JY9824AITask
  • Average : JY9824.JY9824AISpectrumTask

- b -

  • BufLenInSamples : JY9824.JY9824AISpectrumTask, JY9824.JY9824AITask

- c -

  • CenterFrequency : JY9824.AISpectrumChannel, JY9824.SpectralInformation
  • ChannelID : JY9824.AIChannel, JY9824.AISpectrumChannel
  • Channels : JY9824.JY9824AISpectrumTask, JY9824.JY9824AITask
  • Comparator : JY9824.AIAnalogTrigger
  • Condition : JY9824.AIAnalogWindowComparator

- d -

  • DataFormat : JY9824.AIOnboardSignalProcessing
  • Device : JY9824.JY9824AISpectrumTask, JY9824.JY9824AITask
  • Digital : JY9824.AITrigger
  • DigitalGain : JY9824.AIChannel

- e -

  • Edge : JY9824.AIAnalogTrigger, JY9824.AIDigitalTrigger
  • EnablePreview : JY9824.Record
  • ENBW : JY9824.SpectralInformation
  • ExpectBandwidth : JY9824.AISpectrumFftParam
  • ExpectNumOfSpectralLines : JY9824.AISpectrumFftParam
  • Exponential : JY9824.AISpectrumAverageParam

- f -

  • FFT : JY9824.JY9824AISpectrumTask
  • FftSize : JY9824.SpectralInformation
  • FftWindowType : JY9824.SpectralInformation
  • FilePath : JY9824.Record
  • Format : JY9824.Record
  • Frequency : JY9824.AIChannel
  • FrequencyAlignmentMode : JY9824.AISpectrumFftParam
  • FrequencyStart : JY9824.SpectralInformation
  • FrequencyStep : JY9824.SpectralInformation

- h -

  • HighThreshold : JY9824.AIAnalogHysteresisComparator, JY9824.AIAnalogWindowComparator
  • HoldOffTime : JY9824.AITrigger
  • Hysteresis : JY9824.AIAnalogTrigger

- i -

  • IsPSD : JY9824.AISpectrumUnitParam
  • IsPsd : JY9824.SpectralInformation

- l -

  • Length : JY9824.Record
  • Linear : JY9824.AISpectrumAverageParam
  • LowThreshold : JY9824.AIAnalogHysteresisComparator, JY9824.AIAnalogWindowComparator

- m -

  • MaxMemorySizeInByte : JY9824.Record
  • Mode : JY9824.AISpectrumAverageParam, JY9824.JY9824AISpectrumTask, JY9824.JY9824AITask, JY9824.Record

- n -

  • NumOfSpectralLines : JY9824.SpectralInformation

- o -

  • Osp : JY9824.JY9824AITask
  • OutputDecimationRatio : JY9824.JY9824AISpectrumTask

- p -

  • PeakHold : JY9824.AISpectrumAverageParam
  • PreTriggerSamples : JY9824.AITrigger
  • PseudoPeakHold : JY9824.AISpectrumAverageParam

- r -

  • RangeHigh : JY9824.AISpectrumChannel
  • RangeLow : JY9824.AISpectrumChannel
  • Record : JY9824.JY9824AITask
  • ResolutionBandwidth : JY9824.SpectralInformation
  • ReTriggerCount : JY9824.AITrigger

- s -

  • SampleRate : JY9824.JY9824AISpectrumTask, JY9824.JY9824AITask
  • SamplesToAcquire : JY9824.JY9824AISpectrumTask, JY9824.JY9824AITask
  • SignalExport : JY9824.JY9824AITask
  • Size : JY9824.AISpectrumLinearAverageParam, JY9824.AISpectrumPeakHoldParam
  • Slope : JY9824.AIAnalogEdgeComparator, JY9824.AIAnalogHysteresisComparator
  • Source : JY9824.AIAnalogTrigger, JY9824.AIDigitalTrigger

- t -

  • Threshold : JY9824.AIAnalogEdgeComparator
  • TimeConstant : JY9824.AISpectrumExponentialAverageParam, JY9824.AISpectrumPseudoPeakHoldParam
  • Topology : JY9824.AISync
  • TransferedSamples : JY9824.JY9824AISpectrumTask
  • Trigger : JY9824.JY9824AISpectrumTask, JY9824.JY9824AITask
  • Type : JY9824.AISpectrumUnitParam, JY9824.AITrigger

- u -

  • Unit : JY9824.JY9824AISpectrumTask
  • UnitType : JY9824.SpectralInformation

- w -

  • Window : JY9824.AIAnalogTrigger
  • WindowType : JY9824.AISpectrumFftParam


9824 C# Programming Manual: Main Page

9824 C# Programming Manual Documentation


9824 C# Programming Manual: JY9824 Namespace Reference

  • Package List
  • Package Members
Classes | Enumerations | Functions
JY9824 Namespace Reference

Classes

class | AIAnalogEdgeComparator
AI Analog Edge Comparator. More...
class | AIAnalogHysteresisComparator
AI Analog Hysteresis Comparator. More...
class | AIAnalogTrigger
AI Analog Trigger. More...
class | AIAnalogWindowComparator
AI Analog Window Comparator. More...
class | AIChannel
AI通道参数类 More...
class | AIDigitalTrigger
AI数字触发 More...
class | AIOnboardSignalProcessing
Onboard Signal Processing configuration class. More...
class | AISignalExport
信号路由 More...
class | AISpectrumAverageParam
Spectrum Average parameter. More...
class | AISpectrumChannel
AI Spectrum Channel Parament Class. More...
class | AISpectrumExponentialAverageParam
Constructor. More...
class | AISpectrumFftParam
FFT parameter. More...
class | AISpectrumLinearAverageParam
Constructor. More...
class | AISpectrumPeakHoldParam
Constructor. More...
class | AISpectrumPseudoPeakHoldParam
Constructor. More...
class | AISpectrumUnitParam
Unit parameter. More...
class | AISync
同步配置 More...
class | AITrigger
AI触发参数类 More...
class | DeviceMiscellaneousParam
Device miscellaneous param.
class | JY9824AISpectrumTask
JY9824 AI Spectrum Task Class. More...
class | JY9824AITask
AI采集任务类,Sealed类，不可被继承 More...
class | JY9824Miscellaneous
JY9824 Miscellaneous parameters.
class | Record
流盘相关的参数定义 More...
class | SpectralInformation
Spectral Information. More...

Enumerations

enum AIAnalogTriggerSource {
Channel_0 = JY9824Import.AnalogTriggerSource.AnalogTriggerSourceCH0Raw , Channel_1 = JY9824Import.AnalogTriggerSource.AnalogTriggerSourceCH1Raw , Channel_2 = JY9824Import.AnalogTriggerSource.AnalogTriggerSourceCH2Raw , Channel_3 = JY9824Import.AnalogTriggerSource.AnalogTriggerSourceCH3Raw ,
TriggerIn = JY9824Import.AnalogTriggerSource.AnalogTriggerSourceTriggerIn
}
AI Analog Trigger Source. More...
enum | AIAnalogTriggerComparator { Edge , Hysteresis , Window }
AI Analog Trigger Comparator. More...
enum | AIAnalogTriggerEdge { Rising , Falling }
AI Analog Trigger Edge. More...
enum | AIAnalogWindowCondition { Entering , Leaving }
AI Analog Window Trigger Condition. More...
enum | RecordMode { Finite , Infinite }
流盘模式枚举定义 More...
enum | RecordFormat { VectorFile , Raw }
流盘格式 More...
enum | AIOspDataFormat { Real , Complex }
Data Format，Real/Complex Real：ADC data Complex：DDC(Digital DownConversion) IQ data. More...
enum | AIMode { Finite = JY9824Import.AcquisitionMode.Finite_Sample , Continuous = JY9824Import.AcquisitionMode.Continuous_Sample , Record }
AI工作模式枚举类型 More...
enum | AITriggerType { Immediate = JY9824Import.TriggerType.Immediate_Trigger , Software = JY9824Import.TriggerType.Soft_Trigger , Digital = JY9824Import.TriggerType.Digital_Trigger , Analog = JY9824Import.TriggerType.Analog_Trigger }
AI触发类型 More...
enum AIDigitalTriggerSource {
PFI0 = JY9824Import.DigitalTriggerSource.PFI0 , PXI_Trig_0 = JY9824Import.DigitalTriggerSource.PXI_Trig_0 , PXI_Trig_1 = JY9824Import.DigitalTriggerSource.PXI_Trig_1 , PXI_Trig_2 = JY9824Import.DigitalTriggerSource.PXI_Trig_2 ,
PXI_Trig_3 = JY9824Import.DigitalTriggerSource.PXI_Trig_3 , PXI_Trig_4 = JY9824Import.DigitalTriggerSource.PXI_Trig_4 , PXI_Trig_5 = JY9824Import.DigitalTriggerSource.PXI_Trig_5 , PXI_Trig_6 = JY9824Import.DigitalTriggerSource.PXI_Trig_6 ,
PXI_Trig_7 = JY9824Import.DigitalTriggerSource.PXI_Trig_7
}
AI外部数字触发源 More...
enum | AIDigitalTriggerEdge { Rising = JY9824Import.DigitalTriggerConditioning.Rising_Edge_Trigger , Falling = JY9824Import.DigitalTriggerConditioning.Falling_Edge_Trigger }
AI外部数字出发边沿 More...
enum AISignalExportSource {
None = 0 , PFI0 = JY9824Import.ExportSignalSource.PFI_ui_0_0_di_OUT , TriggerIn = JY9824Import.ExportSignalSource.TriggerIn_buf_IBUF_OUT_OUT , Analog_Trigger_0_trigger = JY9824Import.ExportSignalSource.Analog_Trigger_0_trigger ,
Rx_Engine_Real_start_trigger_out = JY9824Import.ExportSignalSource.Rx_Engine_Real_start_trigger_out , Rx_Engine_Real_reference_trigger_out = JY9824Import.ExportSignalSource.Rx_Engine_Real_reference_trigger_out , Rx_Engine_Real_advance_trigger_out = JY9824Import.ExportSignalSource.Rx_Engine_Real_advance_trigger_out , PXI_Trig0 = JY9824Import.ExportSignalSource.PXITrigger_OUT_0 ,
PXI_Trig1 = JY9824Import.ExportSignalSource.PXITrigger_OUT_1 , PXI_Trig2 = JY9824Import.ExportSignalSource.PXITrigger_OUT_2 , PXI_Trig3 = JY9824Import.ExportSignalSource.PXITrigger_OUT_3 , PXI_Trig4 = JY9824Import.ExportSignalSource.PXITrigger_OUT_4 ,
PXI_Trig5 = JY9824Import.ExportSignalSource.PXITrigger_OUT_5 , PXI_Trig6 = JY9824Import.ExportSignalSource.PXITrigger_OUT_6 , PXI_Trig7 = JY9824Import.ExportSignalSource.PXITrigger_OUT_7
}
导出信号的源 More...
enum SignalExportDestination {
None = 0 , PXI_Trig0 = JY9824Import.ExportSignalDestination.PXITrigger_IN_0 , PXI_Trig1 = JY9824Import.ExportSignalDestination.PXITrigger_IN_1 , PXI_Trig2 = JY9824Import.ExportSignalDestination.PXITrigger_IN_2 ,
PXI_Trig3 = JY9824Import.ExportSignalDestination.PXITrigger_IN_3 , PXI_Trig4 = JY9824Import.ExportSignalDestination.PXITrigger_IN_4 , PXI_Trig5 = JY9824Import.ExportSignalDestination.PXITrigger_IN_5 , PXI_Trig6 = JY9824Import.ExportSignalDestination.PXITrigger_IN_6 ,
PXI_Trig7 = JY9824Import.ExportSignalDestination.PXITrigger_IN_7 , PFI0 = JY9824Import.ExportSignalDestination.PFI_ui_0_0_do_IN , Rx_Engine_Real_start_trigger_in = JY9824Import.ExportSignalDestination.Rx_Engine_Real_start_trigger_in , Rx_Engine_Real_reference_trigger_in = JY9824Import.ExportSignalDestination.Rx_Engine_Real_reference_trigger_in ,
Rx_Engine_Real_advance_trigger_in = JY9824Import.ExportSignalDestination.Rx_Engine_Real_advance_trigger_in
}
导出信号的目标 More...
enum | SyncTopology { Independent = JY9824Import.SYNCMODE.SOLO , Master = JY9824Import.SYNCMODE.MASTER , Slave = JY9824Import.SYNCMODE.SLAVE }
Synchronization board configuration. More...
enum AISpectrumAverageMode {
NoAveraging , ExponentialAverage , PseudoPeakHold , PeakHold ,
LinearAverage
}
Spectrum averageing mode. More...
enum FftWindowType {
None , Hanning , Hamming , Blackman_Harris ,
Exact_Blackman , Blackman , Three_Term_Nuttal , Three_Term_Blackman_Nuttal ,
Four_Term_B_Harris , Four_Term_Nuttal , Four_Term_Blackman_Nuttal , Flat_Top_95 ,
Flat_Top_90D , Five_Term_Least_Sidelobe , Six_Term_Flat_Top , Six_Term_Least_Sidelobe ,
Seven_Term_Flat_Top , Seven_Term_Least_Sidelobe
}
FFT window type. More...
enum SpectrumUnitType {
dBm , dBFS , dBV , dBuV ,
V2
}
Spectrum unit type. More...
enum | FFTFrequencyAlignmentMode { Center , Lower , Upper }
Frequency Alignment Mode. More...

Functions

delegate void TaskCommittedEventHandler (object sender, EventArgs args)
任务提交配置的事件委托

Enumeration Type Documentation

◆ AIAnalogTriggerComparator

enum JY9824.AIAnalogTriggerComparator

AI Analog Trigger Comparator.

Enumerator
Edge | Edge Comparator.
Hysteresis | Hysteresis Comparator.
Window | Window Comparator.

◆ AIAnalogTriggerEdge

enum JY9824.AIAnalogTriggerEdge

AI Analog Trigger Edge.

Enumerator
Rising | Rising.
Falling | Falling.

◆ AIAnalogTriggerSource

enum JY9824.AIAnalogTriggerSource

AI Analog Trigger Source.

Enumerator
Channel_0 | Ch0.
Channel_1 | Ch1.
Channel_2 | Ch2.
Channel_3 | Ch3.
TriggerIn | TriggerIn.

◆ AIAnalogWindowCondition

enum JY9824.AIAnalogWindowCondition

AI Analog Window Trigger Condition.

Enumerator
Entering | Rising.
Leaving | Falling.

◆ AIDigitalTriggerEdge

enum JY9824.AIDigitalTriggerEdge

AI外部数字出发边沿

Enumerator
Rising | 上升沿触发
Falling | 下降沿触发

◆ AIDigitalTriggerSource

enum JY9824.AIDigitalTriggerSource

AI外部数字触发源

Enumerator
PFI0 | PFI0.
PXI_Trig_0 | PXI_Trig_0.
PXI_Trig_1 | PXI_Trig_1.
PXI_Trig_2 | PXI_Trig_2.
PXI_Trig_3 | PXI_Trig_3.
PXI_Trig_4 | PXI_Trig_4.
PXI_Trig_5 | PXI_Trig_5.
PXI_Trig_6 | PXI_Trig_6.
PXI_Trig_7 | PXI_Trig_7.

◆ AIMode

enum JY9824.AIMode

AI工作模式枚举类型

Enumerator
Finite | 有限点方式
Continuous | 连续方式
Record | 流盘模式

◆ AIOspDataFormat

enum JY9824.AIOspDataFormat

Data Format，Real/Complex Real：ADC data Complex：DDC(Digital DownConversion) IQ data.

Enumerator
Real | ADC data.
Complex | DDC(Digital DownConversion) IQ data.

◆ AISignalExportSource

enum JY9824.AISignalExportSource

导出信号的源

Enumerator
None | None.
PFI0 | PFI0.
TriggerIn | 面板TriggerIn
Analog_Trigger_0_trigger | 模拟触发
Rx_Engine_Real_start_trigger_out | AI_StartTrig.
Rx_Engine_Real_reference_trigger_out | AI_ReferenceTrig.
Rx_Engine_Real_advance_trigger_out | AI_AdvanceTrig.
PXI_Trig0 | PXI_Trig_0.
PXI_Trig1 | PXI_Trig_1.
PXI_Trig2 | PXI_Trig_2.
PXI_Trig3 | PXI_Trig_3.
PXI_Trig4 | PXI_Trig_4.
PXI_Trig5 | PXI_Trig_5.
PXI_Trig6 | PXI_Trig_6.
PXI_Trig7 | PXI_Trig_7.

◆ AISpectrumAverageMode

enum JY9824.AISpectrumAverageMode

Spectrum averageing mode.

Enumerator
NoAveraging | No averaging.
ExponentialAverage | Exponential RMS average.
PseudoPeakHold | Pseudo-PeakHold.
PeakHold | PeakHold.
LinearAverage | Linear RMS average.

◆ AITriggerType

enum JY9824.AITriggerType

AI触发类型

Enumerator
Immediate | 立即触发
Software | 软件触发
Digital | 外部数字触发
Analog | 外部模拟触发

◆ FFTFrequencyAlignmentMode

enum JY9824.FFTFrequencyAlignmentMode

Frequency Alignment Mode.

Enumerator
Center
Lower
Upper

◆ FftWindowType

enum JY9824.FftWindowType

FFT window type.

Enumerator
None | Rectangle.
Hanning | Hanning (2-Term)
Hamming | Hamming (2-Term)
Blackman_Harris | Blackman Harris (3-Term.
Exact_Blackman | Exact Blackman (3-Term)
Blackman | Blackman (3-Term)
Three_Term_Nuttal | 3_Term_Nuttal(3-Term with Continous First Derivative /Nuttal3a)
Three_Term_Blackman_Nuttal | 3_Term_Blackman_Nuttal(3-Term Minimum)
Four_Term_B_Harris | 4 Term B-Harris
Four_Term_Nuttal | 4_Term_Nuttal(4-Term with Continous First Derivative /Nuttal4b)
Four_Term_Blackman_Nuttal | 4_Term_Blackman_Nuttal(4-Term Minimum)
Flat_Top_95 | 5-Term Flat Top(HFT95), the highest sidelobe is −95.0dB, located at f = ±7.49 bins.
Flat_Top_90D | 5-Term Flat Top(HFT90D),the highest sidelobe is −90.2dB, located at f = ±5.58 bins
Five_Term_Least_Sidelobe | 5_Term_Least_Sidelobe(Low Sidelobe)
Six_Term_Flat_Top | 6_Term_Flat_Top(HFT116D),the highest sidelobe is −116.8dB, located at f = ±7.52 bins
Six_Term_Least_Sidelobe | 6_Term_Least_Sidelobe
Seven_Term_Flat_Top | 7_Term_Flat_Top(HFT144D),the highest sidelobe is −144.1dB, located at f = ±7.07 bins.
Seven_Term_Least_Sidelobe | 7_Term_Least_Sidelobe(7-Term B-Harris)

◆ RecordFormat

enum JY9824.RecordFormat

流盘格式

Enumerator
VectorFile | 矢量文件，包括4k的Header
Raw | 原始二进制文件

◆ RecordMode

enum JY9824.RecordMode

流盘模式枚举定义

Enumerator
Finite | 有限长度流盘
Infinite | 无限长度流盘

◆ SignalExportDestination

enum JY9824.SignalExportDestination

导出信号的目标

Enumerator
None | None.
PXI_Trig0 | PXI_Trig_0.
PXI_Trig1 | PXI_Trig_1.
PXI_Trig2 | PXI_Trig_2.
PXI_Trig3 | PXI_Trig_3.
PXI_Trig4 | PXI_Trig_4.
PXI_Trig5 | PXI_Trig_5.
PXI_Trig6 | PXI_Trig_6.
PXI_Trig7 | PXI_Trig_7.
PFI0 | PFI0.
Rx_Engine_Real_start_trigger_in | AI_StartTrig.
Rx_Engine_Real_reference_trigger_in | AI_ReferenceTrig.
Rx_Engine_Real_advance_trigger_in | AI_AdvanceTrig.

◆ SpectrumUnitType

enum JY9824.SpectrumUnitType

Spectrum unit type.

Enumerator
dBm | dBm
dBFS | dBFS
dBV | dBV
dBuV | dBuV
V2 | V2.

◆ SyncTopology

enum JY9824.SyncTopology

Synchronization board configuration.

Enumerator
Independent | Independent, synchronization not supported
Master | master card
Slave | slave card

Function Documentation

◆ TaskCommittedEventHandler()

delegate void JY9824.TaskCommittedEventHandler | ( | object | sender,
 |  | EventArgs | args )

任务提交配置的事件委托

Parameters
sender
args


9824 C# Programming Manual: Package Members

  • Package List
  • Package Members
  • All
  • Functions
  • Enumerations
Here is a list of all namespace members with links to the namespace documentation for each member:
  • AIAnalogTriggerComparator : JY9824
  • AIAnalogTriggerEdge : JY9824
  • AIAnalogTriggerSource : JY9824
  • AIAnalogWindowCondition : JY9824
  • AIDigitalTriggerEdge : JY9824
  • AIDigitalTriggerSource : JY9824
  • AIMode : JY9824
  • AIOspDataFormat : JY9824
  • AISignalExportSource : JY9824
  • AISpectrumAverageMode : JY9824
  • AITriggerType : JY9824
  • FFTFrequencyAlignmentMode : JY9824
  • FftWindowType : JY9824
  • RecordFormat : JY9824
  • RecordMode : JY9824
  • SignalExportDestination : JY9824
  • SpectrumUnitType : JY9824
  • SyncTopology : JY9824
  • TaskCommittedEventHandler() : JY9824


9824 C# Programming Manual: Package Members

  • Package List
  • Package Members
  • All
  • Functions
  • Enumerations
Here is a list of all namespace enums with links to the namespace documentation for each enum:
  • AIAnalogTriggerComparator : JY9824
  • AIAnalogTriggerEdge : JY9824
  • AIAnalogTriggerSource : JY9824
  • AIAnalogWindowCondition : JY9824
  • AIDigitalTriggerEdge : JY9824
  • AIDigitalTriggerSource : JY9824
  • AIMode : JY9824
  • AIOspDataFormat : JY9824
  • AISignalExportSource : JY9824
  • AISpectrumAverageMode : JY9824
  • AITriggerType : JY9824
  • FFTFrequencyAlignmentMode : JY9824
  • FftWindowType : JY9824
  • RecordFormat : JY9824
  • RecordMode : JY9824
  • SignalExportDestination : JY9824
  • SpectrumUnitType : JY9824
  • SyncTopology : JY9824


9824 C# Programming Manual: Package Members

  • Package List
  • Package Members
  • All
  • Functions
  • Enumerations
Here is a list of all namespace functions with links to the namespace documentation for each function:
  • TaskCommittedEventHandler() : JY9824


9824 C# Programming Manual: Package List

  • Package List
  • Package Members
Package List
Here are the packages with brief descriptions (if available):
N JY9824