USB-1202 C# Programming Manual: D:/OneDrive/Desktop/产品文档/CHM/1202/C#/JYUSB1202AITask.cs File Reference

USB-1202 C# Programming Manual
Classes | Namespaces | Enumerations
JYUSB1202AITask.cs File Reference

Classes

class | JYUSB1202.JYUSB1202AITask
JYUSB1202 Analog Input Task. More...
class | JYUSB1202.AIChannel
AI Channel parameter class . More...
class | JYUSB1202.AISampleClock
Sample clock configuration class. More...
class | JYUSB1202.AIExternalSampleClock
External Sample Clock Configuration Class. More...
class | JYUSB1202.AITrigger
Clock Terminal. More...
class | JYUSB1202.AIDigitalTrigger
AI Digital trigger class. More...
class | JYUSB1202.AIRecord
AI Record Parameters. More...
class | JYUSB1202.AISignalExport
AI Signal Export Class. More...

Namespaces

namespace JYUSB1202

Enumerations

enum | JYUSB1202.AIFilterType { JYUSB1202.Sinc5_DEC_X32_X1024 = 0 , JYUSB1202.Sinc3 = 3 , JYUSB1202.Wideband = 4 }
AIFilterType. More...
enum | JYUSB1202.AIFDAMODE { JYUSB1202.FULLPOWER = 0 , JYUSB1202.STANDBY = 1 }
AIFDAMODE. More...
enum | JYUSB1202.AITerminal { JYUSB1202.PSEUDIFF = 0 , JYUSB1202.Differential = 1 }
AITerminal. More...
enum | JYUSB1202.AICoupling { JYUSB1202.AC = 0 , JYUSB1202.DC = 1 }
AICoupling. More...
enum | JYUSB1202.AITriggerType { JYUSB1202.Immediate = 0 , JYUSB1202.Digital = 1 , JYUSB1202.Soft = 2 }
Trigger Type Digital/Analog/Immediate/Soft. More...
enum | JYUSB1202.AIDigitalTriggerEdge { JYUSB1202.Rising = 0 , JYUSB1202.Falling = 1 , JYUSB1202.HighLevel = 2 , JYUSB1202.LowLevel = 3 }
AI Digital Trigger Edge. More...
enum | JYUSB1202.AIMode { JYUSB1202.Finite = JYUSB1202Import.JYUSB1202_AI_Finite , JYUSB1202.Continuous = JYUSB1202Import.JYUSB1202_AI_Continuous , JYUSB1202.Record = 0x2 }
AIMode. More...
enum | JYUSB1202.AISampleClockSource { JYUSB1202.Internal , JYUSB1202.External }
AI Sample Clock Source. More...
enum | JYUSB1202.AIDigitalTriggerSource { JYUSB1202.DIO_0 = 0 , JYUSB1202.DIO_1 = 1 , JYUSB1202.DIO_2 = 2 , JYUSB1202.DIO_3 = 3 }
Output DestinationTerminal. More...
enum | JYUSB1202.FileFormat { JYUSB1202.Bin }
Streaming file format. More...
enum | JYUSB1202.RecordMode { JYUSB1202.Finite , JYUSB1202.Infinite }
stream mode .enum Finite/Infinite More...
enum JYUSB1202.SignalExportDestination {
JYUSB1202.NONE = -1 , JYUSB1202.DIO_0 = 0 , JYUSB1202.DIO_1 = 1 , JYUSB1202.DIO_2 = 2 ,
JYUSB1202.DIO_3 = 3
}
Output DestinationTerminal. More...
enum | JYUSB1202.AISignalExportSource { JYUSB1202.StartTrig , JYUSB1202.SampleClock }
AI Signal Export Source. More...
Generated by doxygen 1.15.0


USB-1202 C# Programming Manual: D:/OneDrive/Desktop/产品文档/CHM/1202/C#/JYUSB1202CITask.cs File Reference

Classes | Namespaces | Enumerations
JYUSB1202CITask.cs File Reference

Classes

class | JYUSB1202.JYUSB1202CITask
JYUSB1202 Counter Input Task. More...
class | JYUSB1202.EdgeCounting
Configure CI EdgeCounting. More...
class | JYUSB1202.EdgeCountingOutEvent
Edge counting output event configuration class. More...
class | JYUSB1202.PauseTrigger
Pause trigger configuration class. More...
class | JYUSB1202.FrequencyMeas
Configure CI Measure. More...
class | JYUSB1202.PeriodMeas
Configure CI Measure. More...
class | JYUSB1202.PulseMeas
Configure CI Measure. More...
class | JYUSB1202.TwoEdgeSeparation
Configure CI Measure. More...
class | JYUSB1202.QuadEncoder
Configure CI Measure. More...
class | JYUSB1202.TwoPulseEncoder
Configure CI Measure. More...

Namespaces

namespace JYUSB1202

Enumerations

enum | JYUSB1202.CountDirection { JYUSB1202.Up = JYUSB1202Import.JYUSB1202_CI_Count_Up , JYUSB1202.Down = JYUSB1202Import.JYUSB1202_CI_Count_Down }
Counter direction. More...
enum JYUSB1202.CIType {
JYUSB1202.EdgeCounting , JYUSB1202.Period , JYUSB1202.Frequency , JYUSB1202.Pulse ,
JYUSB1202.TwoEdgeSeparation , JYUSB1202.QuadEncoder
}
Counter Input Application Type. More...
enum | JYUSB1202.EdgeType { JYUSB1202.Rising , JYUSB1202.Falling , JYUSB1202.Any }
Edge Type. More...
enum | JYUSB1202.EdgeCntOunEvtIdleState { JYUSB1202.LowLevel = 0 , JYUSB1202.HighLevel = 1 }
Output idle state when the event has not occurred. More...
enum | JYUSB1202.LevelPolarity { JYUSB1202.LowLevel = 0 , JYUSB1202.HighLevel = 1 , JYUSB1202.None = 2 }
Level Polarity. More...
enum | JYUSB1202.QuadEncodingType { JYUSB1202.X2 , JYUSB1202.X4 }
Quadrature Encoding Type. More...


USB-1202 C# Programming Manual: D:/OneDrive/Desktop/产品文档/CHM/1202/C#/JYUSB1202COTask.cs File Reference

Classes | Namespaces | Enumerations
JYUSB1202COTask.cs File Reference

Classes

class | JYUSB1202.JYUSB1202COTask
JYUSB1202 Counter Output Task. More...
class | JYUSB1202.COPulse
Pulse Parameter. More...

Namespaces

namespace JYUSB1202

Enumerations

enum | JYUSB1202.COIdleState { JYUSB1202.HighLevel = JYUSB1202Import.JYUSB1202_HighLevel , JYUSB1202.LowLevel = JYUSB1202Import.JYUSB1202_LowLevel }
Idle state when pulse output before start and after stop. More...
enum | JYUSB1202.COPulseType { JYUSB1202.DutyCycleFrequency , JYUSB1202.HighLowTime , JYUSB1202.HighLowTick }
Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick. More...


USB-1202 C# Programming Manual: D:/OneDrive/Desktop/产品文档/CHM/1202/C++/JYUSB1202Core.h File Reference

  • Main Page
  • Packages
  • Classes
  • Files
  • File List
  • File Members
  • OneDrive
  • Desktop
  • 产品文档
  • CHM
  • 1202
  • C++
Classes | Typedefs | Enumerations | Functions
JYUSB1202Core.h File Reference

Classes

struct ScalingCoefficients

Typedefs

typedef int | BOOL
Windows.
typedef void * | JYUSB1202_DeviceHandle

Enumerations

enum | JYUSB1202_AI_Terminal { JYUSB1202_AI_PSEUDIFF = 0x0 , JYUSB1202_AI_DIFF = 0x1 }
enum | JYUSB1202_AI_Coupling { JYUSB1202_AI_AC = 0x0 , JYUSB1202_AI_DC = 0x1 }
enum | JYUSB1202_AI_TEDS_IEPE_MODE { JYUSB1202_AI_TEDS = 0x0 , JYUSB1202_AI_IEPE = 0x1 , JYUSB1202_AI_TEDS_IEPE_OFF = 0x2 }
enum | JYUSB1202_AI_SampleMode { JYUSB1202_AI_Finite = 0x0 , JYUSB1202_AI_Continuous = 0x1 , JYUSB1202_AI_Single = 0x2 }
enum | JYUSB1202_AIFilterType { JYUSB1202_AI_Sinc5_Filter_DEC_X32_X1024 = 0x0 , JYUSB1202_AI_Sinc3_Filter = 0x3 , JYUSB1202_AI_Wideband_Filter = 0x4 }
enum | JYUSB1202_AIFDAMODE { JYUSB1202_AI_FULLPOWER = 0x0 , JYUSB1202_AI_STANDBY = 0x1 }
enum | JYUSB1202_TriggerType { JYUSB1202_Immediately = 0x0 , JYUSB1202_Digital = 0x1 , JYUSB1202_Soft = 0x2 }
enum | JYUSB1202_DigitalTriggerSource { JYUSB1202_GPIO_0 = 0x0 , JYUSB1202_GPIO_1 = 0x1 , JYUSB1202_GPIO_2 = 0x2 , JYUSB1202_GPIO_3 = 0x3 }
enum | JYUSB1202_DigitalTriggerEdge { JYUSB1202_Rising = 0x0 , JYUSB1202_Falling = 0x1 , JYUSB1202_High_Level = 0x2 , JYUSB1202_Low_Level = 0x3 }
enum JYUSB1202_CI_MeasureType {
JYUSB1202_CI_EdgeCount = 0 , JYUSB1202_CI_Measure_FrequencyOrPeriod = 1 , JYUSB1202_CI_Measure_PulseWidth = 2 , JYUSB1202_CI_Measure_EdgeSeparation = 3 ,
JYUSB1202_CI_Encoder_X2 = 4 , JYUSB1202_CI_Encoder_X4 = 5
}
enum | JYUSB1202_CountDirection { JYUSB1202_CI_Count_Up , JYUSB1202_CI_Count_Down }
enum | JYUSB1202_CI_CounterEventSignalIdleState { JYUSB1202_CI_CounterEventSignalIdleState_Low = 0 , JYUSB1202_CI_CounterEventSignalIdleState_High = 1 }
CI Counter Event Signal Idle State. More...
enum | JYUSB1202_LevelState { JYUSB1202_LowLevel = 0 , JYUSB1202_HighLevel = 1 }
enum | JYUSB1202_CO_IdleState { JYUSB1202_CO_LowLevel = 0 , JYUSB1202_CO_HighLevel = 1 }
enum JYUSB1202_Signal_SrcAndDest {
JYUSB1202_NONE = -1 , JYUSB1202_DIO_0 = 0 , JYUSB1202_DIO_1 = 1 , JYUSB1202_DIO_2 = 2 ,
JYUSB1202_DIO_3 = 3
}
enum | JYUSB1202_Capability_Item { JYUSB1202_AI_NumberOfChannels_Int = 0 , JYUSB1202_AI_MaxSampleRate_Double = 1 , JYUSB1202_AI_MinSampleRate_Double = 2 }

Functions

JYUSB1202API int | JYUSB1202_Open (JYUSB1202_DeviceHandle *hDevice)
Open the USB1202 board，default open the first card.
JYUSB1202API int | JYUSB1202_OpenByName (const char *cardName, JYUSB1202_DeviceHandle *hDevice)
Open this USB1202 board using the board alias name which is set by JYTEK utility JYDM.
JYUSB1202API int | JYUSB1202_Close (JYUSB1202_DeviceHandle hDevice)
Close this USB1202 board.
JYUSB1202API int | JYUSB1202_GetDeviceSerialNumber (JYUSB1202_DeviceHandle hDevice, char *serialNumber, int length)
Obtain the device serialNumber.
JYUSB1202API int | JYUSB1202_AI_EnableChannel (JYUSB1202_DeviceHandle hDevice, unsigned int channelCount, unsigned char *channels, double *lowRegion, double *highRegion, JYUSB1202_AI_Terminal *terminal, JYUSB1202_AI_Coupling *coupling, bool *enableIEPE)
Enable AI channels.
JYUSB1202API int | JYUSB1202_AI_SetMode (JYUSB1202_DeviceHandle hDevice, JYUSB1202_AI_SampleMode mode)
Set AI sampling mode.
JYUSB1202API int | JYUSB1202_AI_SetSampleRate (JYUSB1202_DeviceHandle hDevice, double sampleRate, double *actualSampleRate)
Set sampling rate.
JYUSB1202API int | JYUSB1202_AI_SetFilterType (JYUSB1202_DeviceHandle hDevice, JYUSB1202_AIFilterType filterType)
Set sampling rate.
JYUSB1202API int | JYUSB1202_AI_SetFDAMODE (JYUSB1202_DeviceHandle hDevice, JYUSB1202_AIFDAMODE fdaMode)
Set sampling rate.
JYUSB1202API int | JYUSB1202_AI_SetSamplesToAcquire (JYUSB1202_DeviceHandle hDevice, unsigned int sampleToAcquire)
Set AI samples to acquire for each channel in finite mode.The samples range is 1 to 64M samples / channelCount.
JYUSB1202API int | JYUSB1202_AI_SetStartTriggerType (JYUSB1202_DeviceHandle hDevice, JYUSB1202_TriggerType triggerType)
Set AI trigger type.
JYUSB1202API int | JYUSB1202_AI_SetDigitalStartTrigger (JYUSB1202_DeviceHandle hDevice, JYUSB1202_DigitalTriggerSource triggerSource, JYUSB1202_DigitalTriggerEdge triggerEdge)
Set AI digital trigger edge.
JYUSB1202API int | JYUSB1202_AI_ExportTriggerSignal (JYUSB1202_DeviceHandle hDevice, JYUSB1202_Signal_SrcAndDest triggerOutDestination)
Export trigger signal.
JYUSB1202API int | JYUSB1202_AI_GetScalingCoefficients (JYUSB1202_DeviceHandle hDevice, ScalingCoefficients coefOfEnabledChannels[], int enabledChannelCount)
在调用AI_Commit()或AI_Start()方法之后调用，获取当前已启用通道的电压换算因子，用于将Raw数据转换为电压值。
JYUSB1202API int | JYUSB1202_AI_Start (JYUSB1202_DeviceHandle hDevice)
Start AI acquisition.
JYUSB1202API int | JYUSB1202_AI_CheckBufferStatus (JYUSB1202_DeviceHandle hDevice, unsigned int *avaliableSamples, unsigned long long *transferedSamples, BOOL *overrun)
Check AI Buffer Status.
JYUSB1202API int | JYUSB1202_AI_SendSoftTrigger (JYUSB1202_DeviceHandle hDevice)
AI Send soft trigger.
JYUSB1202API int | JYUSB1202_AI_ReadData (JYUSB1202_DeviceHandle hDevice, double *dataBuffer, unsigned int samplesToRead, int timeOut, unsigned int *actualReadLength)
Read AI data to user defined data buffer.
JYUSB1202API int | JYUSB1202_AI_ExportSampleClock (JYUSB1202_DeviceHandle hDevice, bool sampleClkOutputEnable)
Export AI Sample clock.
JYUSB1202API int | JYUSB1202_AI_Stop (JYUSB1202_DeviceHandle hDevice)
Stop AI acquisition.
JYUSB1202API int | JYUSB1202_AI_ReadRawData (JYUSB1202_DeviceHandle hDevice, short *dataBuffer, unsigned int samplesToRead, int timeOut, unsigned int *actualReadSamples)
Read AI raw data to user defined data buffer.
JYUSB1202API int | JYUSB1202_AI_DisableCalibration (JYUSB1202_DeviceHandle hDevice, bool disableCalibration)
Disable AI calibration coefficient, default false.
JYUSB1202API int | JYUSB1202_GetCapabilityInt (JYUSB1202_DeviceHandle hDevice, JYUSB1202_Capability_Item item, int *value)
获取当前设备的能力信息中的整型数值参数，比如通道数
JYUSB1202API int | JYUSB1202_GetCapabilityDouble (JYUSB1202_DeviceHandle hDevice, JYUSB1202_Capability_Item item, double *value)
获取当前设备的能力信息，比如最高采样率
JYUSB1202API int | JYUSB1202_GetCapabilityIntBySlotNumber (int slotNumber, JYUSB1202_Capability_Item item, int *value, bool setDefaultIfDeviceNotFound=true)
在不打开设备的情况下，获取位于指定卡槽号的设备的能力信息中的整型数值参数，比如通道数
JYUSB1202API int | JYUSB1202_GetCapabilityDoubleBySlotNumber (int slotNumber, JYUSB1202_Capability_Item item, double *value, bool setDefaultIfDeviceNotFound=true)
在不打开设备的情况下，获取位于指定卡槽号的设备的能力信息中的浮点型数值参数，比如最高采样率
JYUSB1202API int | JYUSB1202_GetCapabilityIntByName (const char *deviceName, JYUSB1202_Capability_Item item, int *value, bool setDefaultIfDeviceNotFound=true)
在不打开设备的情况下，获取指定别名的设备的能力信息中的整型数值参数，比如通道数
JYUSB1202API int | JYUSB1202_GetCapabilityDoubleByName (const char *deviceName, JYUSB1202_Capability_Item item, double *value, bool setDefaultIfDeviceNotFound=true)
在不打开设备的情况下，获取指定别名的设备的能力信息中的浮点型数值参数，比如最高采样率
JYUSB1202API int | JYUSB1202_DI_AddLines (JYUSB1202_DeviceHandle hDevice, char *line, int lineCount)
Enabled DI channels.
JYUSB1202API int | JYUSB1202_DI_ReadSinglePoint (JYUSB1202_DeviceHandle hDevice, bool *readValues, int lineID)
read single data from a single line by lineID defined.if the lineID == -1,read all line data.The data type is bool, one bool defined one line status.
JYUSB1202API int | JYUSB1202_DI_Start (JYUSB1202_DeviceHandle hDevice)
Start digital signal input.
JYUSB1202API int | JYUSB1202_DI_Stop (JYUSB1202_DeviceHandle hDevice)
Stop digital signal input.
JYUSB1202API int | JYUSB1202_DO_AddLines (JYUSB1202_DeviceHandle hDevice, char *line, int lineCount)
Enabled DO channels.
JYUSB1202API int | JYUSB1202_DO_WriteSinglePoint (JYUSB1202_DeviceHandle hDevice, bool *writeValues, int lineID)
write single data to the line by lineID defined.if the lineID == -1,write all line data.
JYUSB1202API int | JYUSB1202_DO_Start (JYUSB1202_DeviceHandle hDevice)
Start digital signal output.
JYUSB1202API int | JYUSB1202_DO_Stop (JYUSB1202_DeviceHandle hDevice)
Stop digital signal output.
JYUSB1202API int | JYUSB1202_CI_SetCounterType (JYUSB1202_DeviceHandle hDevice, JYUSB1202_CI_MeasureType measureType)
Set CI measure type.
JYUSB1202API int | JYUSB1202_CI_SetCounterParamet (JYUSB1202_DeviceHandle hDevice, int initCount, JYUSB1202_CountDirection countDirection)
Set CI count parameter.
JYUSB1202API int | JYUSB1202_CI_SetZReloadEnabled (JYUSB1202_DeviceHandle hDevice, bool zReloadEnabled)
Set the Z signal enable in Encoder mode.
JYUSB1202API int | JYUSB1202_CI_SetEdgeCountEvent (JYUSB1202_DeviceHandle hDevice, JYUSB1202_CI_CounterEventSignalIdleState idleState, unsigned int threshold)
Set the counter threshold, and when the count reaches this threshold, output a single pulse at the output terminal.
JYUSB1202API int | JYUSB1202_CI_SetPauseTriggerLevel (JYUSB1202_DeviceHandle hDevice, bool enable, JYUSB1202_LevelState pauseTriggerActiveLevel)
Config CI pause trigger.
JYUSB1202API int | JYUSB1202_CI_ReadSingleCountValue (JYUSB1202_DeviceHandle hDevice, int *countValue)
Counter reads a single count value, this API supports the CI Type: JYUSB1202_CI_EdgeCount、JYUSB1202_CI_EncoderX1、 JYUSB1202_CI_EncoderX2 、 JYUSB1202_CI_EncoderX4 、JYUSB1202_CI_EncoderTwoPulse.
JYUSB1202API int | JYUSB1202_CI_CheckStatus (JYUSB1202_DeviceHandle hDevice, bool *completed)
check the CI measure is completed or not
JYUSB1202API int | JYUSB1202_CI_ReadSingleMeasureValue (JYUSB1202_DeviceHandle hDevice, double *measureValue1, double *measureValue2, int timeOut)
Reads a single counter measurement as follows.
JYUSB1202API int | JYUSB1202_CI_Start (JYUSB1202_DeviceHandle hDevice)
Start Counter input.
JYUSB1202API int | JYUSB1202_CI_Stop (JYUSB1202_DeviceHandle hDevice)
Stop Counter input.
JYUSB1202API int | JYUSB1202_CO_SetPauseTriggerLevel (JYUSB1202_DeviceHandle hDevice, bool enable, JYUSB1202_LevelState pauseTriggerActiveLevel)
Config CO pause trigger.
JYUSB1202API int | JYUSB1202_CO_SetCounterParamet (JYUSB1202_DeviceHandle hDevice, int pulseCount, JYUSB1202_CO_IdleState IdleState)
Set CO parameter.
JYUSB1202API int | JYUSB1202_CO_SetFrequency (JYUSB1202_DeviceHandle hDevice, unsigned int highTicks, unsigned int lowTicks)
Set counter output pulse frequency.
JYUSB1202API int | JYUSB1202_CO_Start (JYUSB1202_DeviceHandle hDevice)
Start counter output.
JYUSB1202API int | JYUSB1202_CO_Stop (JYUSB1202_DeviceHandle hDevice)
Stop counter output.
JYUSB1202API int | JYUSB1202_CO_WaitUntilDone (JYUSB1202_DeviceHandle hDevice, bool *done, int timeOut)
Check CO output is completed or not.

Typedef Documentation

◆ BOOL

typedef int BOOL

Windows.

Linux

◆ JYUSB1202_DeviceHandle

typedef void* JYUSB1202_DeviceHandle

Enumeration Type Documentation

◆ JYUSB1202_AI_Coupling

enum JYUSB1202_AI_Coupling
Enumerator
JYUSB1202_AI_AC | AI AC Coupling.
JYUSB1202_AI_DC | AI DC Coupling.

◆ JYUSB1202_AI_SampleMode

enum JYUSB1202_AI_SampleMode
Enumerator
JYUSB1202_AI_Finite | AI Finite mode.
JYUSB1202_AI_Continuous | AI Continuous mode.
JYUSB1202_AI_Single | AI Single mode.

◆ JYUSB1202_AI_TEDS_IEPE_MODE

enum JYUSB1202_AI_TEDS_IEPE_MODE
Enumerator
JYUSB1202_AI_TEDS
JYUSB1202_AI_IEPE
JYUSB1202_AI_TEDS_IEPE_OFF

◆ JYUSB1202_AI_Terminal

enum JYUSB1202_AI_Terminal
Enumerator
JYUSB1202_AI_PSEUDIFF | AI PSEUDIFF connection mode.
JYUSB1202_AI_DIFF | AI Diff connection mode.

◆ JYUSB1202_AIFDAMODE

enum JYUSB1202_AIFDAMODE
Enumerator
JYUSB1202_AI_FULLPOWER
JYUSB1202_AI_STANDBY

◆ JYUSB1202_AIFilterType

enum JYUSB1202_AIFilterType
Enumerator
JYUSB1202_AI_Sinc5_Filter_DEC_X32_X1024
JYUSB1202_AI_Sinc3_Filter
JYUSB1202_AI_Wideband_Filter

◆ JYUSB1202_Capability_Item

enum JYUSB1202_Capability_Item
Enumerator
JYUSB1202_AI_NumberOfChannels_Int | Number of channels.
JYUSB1202_AI_MaxSampleRate_Double | Max Sample Rate.
JYUSB1202_AI_MinSampleRate_Double | Min Sample Rate.

◆ JYUSB1202_CI_CounterEventSignalIdleState

enum JYUSB1202_CI_CounterEventSignalIdleState

CI Counter Event Signal Idle State.

Enumerator
JYUSB1202_CI_CounterEventSignalIdleState_Low | Low Level as the CI Counter Event Signal Idle State.
JYUSB1202_CI_CounterEventSignalIdleState_High | High Level as the CI Counter Event Signal Idle State.

◆ JYUSB1202_CI_MeasureType

enum JYUSB1202_CI_MeasureType
Enumerator
JYUSB1202_CI_EdgeCount | Edge count.
JYUSB1202_CI_Measure_FrequencyOrPeriod | FrequencyOrPeriod Measurement.
JYUSB1202_CI_Measure_PulseWidth | Pulse Measurement.
JYUSB1202_CI_Measure_EdgeSeparation | Two Edge Separation Measurement.
JYUSB1202_CI_Encoder_X2 | Encoder_X2.
JYUSB1202_CI_Encoder_X4 | Encoder_X4.

◆ JYUSB1202_CO_IdleState

enum JYUSB1202_CO_IdleState
Enumerator
JYUSB1202_CO_LowLevel | Low Level as the co idle state.
JYUSB1202_CO_HighLevel | High Level as the co idle state.

◆ JYUSB1202_CountDirection

enum JYUSB1202_CountDirection
Enumerator
JYUSB1202_CI_Count_Up | Increases count.
JYUSB1202_CI_Count_Down | Reduction count.

◆ JYUSB1202_DigitalTriggerEdge

enum JYUSB1202_DigitalTriggerEdge
Enumerator
JYUSB1202_Rising | Rsing edge for digital trigger.
JYUSB1202_Falling | Falling edge for digital trigger.
JYUSB1202_High_Level | High Level for digital trigger.
JYUSB1202_Low_Level | Low Level for digital trigger.

◆ JYUSB1202_DigitalTriggerSource

enum JYUSB1202_DigitalTriggerSource
Enumerator
JYUSB1202_GPIO_0 | GPIO_0 Source for digital trigger.
JYUSB1202_GPIO_1 | GPIO10 Source for digital trigger.
JYUSB1202_GPIO_2 | GPIO_2 Source for digital trigger.
JYUSB1202_GPIO_3 | GPIO_3 Source for digital trigger.

◆ JYUSB1202_LevelState

enum JYUSB1202_LevelState
Enumerator
JYUSB1202_LowLevel | Low Level as the pause trigger active level.
JYUSB1202_HighLevel | High Level as the pause trigger active level.

◆ JYUSB1202_Signal_SrcAndDest

enum JYUSB1202_Signal_SrcAndDest
Enumerator
JYUSB1202_NONE | NO signal need route.
JYUSB1202_DIO_0 | DIO_0 as the signal desition to rout.
JYUSB1202_DIO_1 | DIO_1 as the signal desition to rout.
JYUSB1202_DIO_2 | DIO_2 as the signal desition to rout.
JYUSB1202_DIO_3 | DIO_3 as the signal desition to rout.

◆ JYUSB1202_TriggerType

enum JYUSB1202_TriggerType
Enumerator
JYUSB1202_Immediately | AI Immediately trigger.
JYUSB1202_Digital | AI Digital trigger.
JYUSB1202_Soft | AI Soft trigger.

Function Documentation

◆ JYUSB1202_AI_CheckBufferStatus()

JYUSB1202API int JYUSB1202_AI_CheckBufferStatus | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | unsigned int * | avaliableSamples,
 |  | unsigned long long * | transferedSamples,
 |  | BOOL * | overrun )

Check AI Buffer Status.

Parameters
hDevice | device handle
avaliableSamples | avaliableSamples
transferedSamples | transferedSamples
overrun | overrun
Returns
0 if success or other error code

◆ JYUSB1202_AI_DisableCalibration()

JYUSB1202API int JYUSB1202_AI_DisableCalibration | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | bool | disableCalibration )

Disable AI calibration coefficient, default false.

Parameters
hDevice | device handle
DisableCalibration | true if disabled, false if not disabled.
Returns
0 if Success or other error code

◆ JYUSB1202_AI_EnableChannel()

JYUSB1202API int JYUSB1202_AI_EnableChannel | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | unsigned int | channelCount,
 |  | unsigned char * | channels,
 |  | double * | lowRegion,
 |  | double * | highRegion,
 |  | JYUSB1202_AI_Terminal * | terminal,
 |  | JYUSB1202_AI_Coupling * | coupling,
 |  | bool * | enableIEPE )

Enable AI channels.

Each channel can be independently configured

Parameters
hDevice | device handle
channelCount | number of channels to be enabled
channels | array[channelCount] containing channel IDs
lowRegion | array[channelCount] of lower limit numbers for each channel,typically in volts.
highRegion | higher limit numbers for each channel, typcially in volts.
terminal | terminal configuration defined by enum JYUSB1202_AI_Terminal which can be RSE,DIFF. Defalut : RSE
coupling | coupling configuration defined by enum JYUSB1202_AI_Coupling which can be DC,AC. Defalut : DC
enableIEPE | IEPE configuration defined by enum JYUSB1202_AI_TEDS_IEPE_MODE
Returns
0 if success or other error code

◆ JYUSB1202_AI_ExportSampleClock()

JYUSB1202API int JYUSB1202_AI_ExportSampleClock | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | bool | sampleClkOutputEnable )

Export AI Sample clock.

◆ JYUSB1202_AI_ExportTriggerSignal()

JYUSB1202API int JYUSB1202_AI_ExportTriggerSignal | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | JYUSB1202_Signal_SrcAndDest | triggerOutDestination )

Export trigger signal.

Parameters
hDevice | device handle
triggerOutDestination | destination
triggerOutEnable | enable
Returns

◆ JYUSB1202_AI_GetScalingCoefficients()

JYUSB1202API int JYUSB1202_AI_GetScalingCoefficients | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | ScalingCoefficients | coefOfEnabledChannels[],
 |  | int | enabledChannelCount )

在调用AI_Commit()或AI_Start()方法之后调用，获取当前已启用通道的电压换算因子，用于将Raw数据转换为电压值。

Parameters
hDevice | 板卡句柄
coefOfEnabledChannels | 已启用通道的电压换算因子
enabledChannelCount | 已启用的通道数
Returns
0：无错误；其它：发生错误

◆ JYUSB1202_AI_ReadData()

JYUSB1202API int JYUSB1202_AI_ReadData | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | double * | dataBuffer,
 |  | unsigned int | samplesToRead,
 |  | int | timeOut,
 |  | unsigned int * | actualReadLength )

Read AI data to user defined data buffer.

For the multi-channel acquisition, the data is interleaved in the order defined by JYUSB1202_AI_EnableChannel.

Parameters
hDevice | device handle
dataBuffer | user buffer,the buffer size must be greater than or equal to dataLength*channelCount.
samplesToRead | number of samples per channel
timeOut | timeout time in microsecond
actualReadLength | returns the number of samples per channel actually read
Returns
0 if success or other error code

◆ JYUSB1202_AI_ReadRawData()

JYUSB1202API int JYUSB1202_AI_ReadRawData | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | short * | dataBuffer,
 |  | unsigned int | samplesToRead,
 |  | int | timeOut,
 |  | unsigned int * | actualReadSamples )

Read AI raw data to user defined data buffer.

For the multi-channel acquisition, the data is interleaved in the order defined by JYUSB1202_AI_EnableChannel.

Parameters
hDevice | device handle
dataBuffer | user buffer, The size of dataBuffer must be greater than or equal to dataLength*channelCount.
samplesToRead | number of samples per channel
timeOut | timeout time in microsecond
actualReadSamples | return the number of samples per channel actually read
Returns
0 if success or other error code

◆ JYUSB1202_AI_SendSoftTrigger()

JYUSB1202API int JYUSB1202_AI_SendSoftTrigger ( JYUSB1202_DeviceHandle hDevice )

AI Send soft trigger.

Parameters
hDevice
Returns

◆ JYUSB1202_AI_SetDigitalStartTrigger()

JYUSB1202API int JYUSB1202_AI_SetDigitalStartTrigger | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | JYUSB1202_DigitalTriggerSource | triggerSource,
 |  | JYUSB1202_DigitalTriggerEdge | triggerEdge )

Set AI digital trigger edge.

Parameters
hDevice | device handle
triggerEdge | trigger edge
Returns

◆ JYUSB1202_AI_SetFDAMODE()

JYUSB1202API int JYUSB1202_AI_SetFDAMODE | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | JYUSB1202_AIFDAMODE | fdaMode )

Set sampling rate.

The sampling rate is the same for all channels.

Parameters
hDevice | device handle
fdaMode | fdaMode
Returns
0 if success or other error code

◆ JYUSB1202_AI_SetFilterType()

JYUSB1202API int JYUSB1202_AI_SetFilterType | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | JYUSB1202_AIFilterType | filterType )

Set sampling rate.

The sampling rate is the same for all channels.

Parameters
hDevice | device handle
filterType | filterType
Returns
0 if success or other error code

◆ JYUSB1202_AI_SetMode()

JYUSB1202API int JYUSB1202_AI_SetMode | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | JYUSB1202_AI_SampleMode | mode )

Set AI sampling mode.

Parameters
hDevice | device handle
mode | AI sampling mode defined by enum JYUSB1202_AI_SampleMode.
Returns
0 if success or other error code

◆ JYUSB1202_AI_SetSampleRate()

JYUSB1202API int JYUSB1202_AI_SetSampleRate | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | double | sampleRate,
 |  | double * | actualSampleRate )

Set sampling rate.

The sampling rate is the same for all channels.

Parameters
hDevice | device handle
sampleRate | AI sampling rate to be set per channel
actualSampleRate | actual sampling rate set by this device,which may be different from the desired sampleRate.
Returns
0 if success or other error code

◆ JYUSB1202_AI_SetSamplesToAcquire()

JYUSB1202API int JYUSB1202_AI_SetSamplesToAcquire | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | unsigned int | sampleToAcquire )

Set AI samples to acquire for each channel in finite mode.The samples range is 1 to 64M samples / channelCount.

Parameters
hDevice | device handle
sampleToAcquire | AI finite samples to acquire for each channel, samples range:1 to 64M samples / channelCount.
Returns
0 if success or other error code

◆ JYUSB1202_AI_SetStartTriggerType()

JYUSB1202API int JYUSB1202_AI_SetStartTriggerType | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | JYUSB1202_TriggerType | triggerType )

Set AI trigger type.

Parameters
hDevice | device handle
triggerType | AI trigger type. Options:immediate trigger, software trigger, digital trigger or analog trigger.
Returns

◆ JYUSB1202_AI_Start()

JYUSB1202API int JYUSB1202_AI_Start ( JYUSB1202_DeviceHandle hDevice )

Start AI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JYUSB1202_AI_Stop()

JYUSB1202API int JYUSB1202_AI_Stop ( JYUSB1202_DeviceHandle hDevice )

Stop AI acquisition.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JYUSB1202_CI_CheckStatus()

JYUSB1202API int JYUSB1202_CI_CheckStatus | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | bool * | completed )

check the CI measure is completed or not

Parameters
hDevice | device handle
completed | true: completed; false: uncompleted
Returns
0 if success or other error code

◆ JYUSB1202_CI_ReadSingleCountValue()

JYUSB1202API int JYUSB1202_CI_ReadSingleCountValue | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | int * | countValue )

Counter reads a single count value, this API supports the CI Type: JYUSB1202_CI_EdgeCount、JYUSB1202_CI_EncoderX1、 JYUSB1202_CI_EncoderX2 、 JYUSB1202_CI_EncoderX4 、JYUSB1202_CI_EncoderTwoPulse.

Parameters
hDevice | device handle
countValue | return the current count value of counter.
Returns
0 if success or other error code

◆ JYUSB1202_CI_ReadSingleMeasureValue()

JYUSB1202API int JYUSB1202_CI_ReadSingleMeasureValue | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | double * | measureValue1,
 |  | double * | measureValue2,
 |  | int | timeOut )

Reads a single counter measurement as follows.

for JYUSB1202_CI_Measure_EdgeSeparation type, measureValues1 is the Gate signel to the Aux signal interval, the measureValues2 is the Aux signel to the Gate signal interval, the unit is in s. for JYUSB1202_CI_Measure_Pulse type, measureValues1 is the Low level signal time, the measureValues2 is the high level signal time, the unit is in second. for JYUSB1202_CI_Measure_Frequency type, measureValues1 is signal frequency in Hz, measureValue2 has no meaning. for JYUSB1202_CI_Measure_Period type, measureValues2 is signal period in second; measureValue1 has no meaning.

Parameters
hDevice | device handle
measureValue1 | current measure value of counter
measureValue2 | current measure value of counter
timeOut | timeout time in microsecond
Returns
0 if success or other error code

◆ JYUSB1202_CI_SetCounterParamet()

JYUSB1202API int JYUSB1202_CI_SetCounterParamet | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | int | initCount,
 |  | JYUSB1202_CountDirection | countDirection )

Set CI count parameter.

Parameters
hDevice | device handle
initCount | counter initial value
countDirection | counting direction of the counter defined by enum USB1202_CountDirection
Returns
0 if success or other error code

◆ JYUSB1202_CI_SetCounterType()

JYUSB1202API int JYUSB1202_CI_SetCounterType | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | JYUSB1202_CI_MeasureType | measureType )

Set CI measure type.

Parameters
hDevice | device handle
measureType | measure type. defined by enum USB1202_CI_MeasureType
Returns
0 if success or other error code

◆ JYUSB1202_CI_SetEdgeCountEvent()

JYUSB1202API int JYUSB1202_CI_SetEdgeCountEvent | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | JYUSB1202_CI_CounterEventSignalIdleState | idleState,
 |  | unsigned int | threshold )

Set the counter threshold, and when the count reaches this threshold, output a single pulse at the output terminal.

Parameters
hDevice | device handle
idleState | output terminal idle state
threshold | threshold
Returns
0 if success or other error code

◆ JYUSB1202_CI_SetPauseTriggerLevel()

JYUSB1202API int JYUSB1202_CI_SetPauseTriggerLevel | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | bool | enable,
 |  | JYUSB1202_LevelState | pauseTriggerActiveLevel )

Config CI pause trigger.

Parameters
hDevice | Device handle
enable | Enable pasue trigger
pauseTriggerActiveLevel | Pause trigger active level.
Returns
Succeed: 0 , Error: !=0

◆ JYUSB1202_CI_SetZReloadEnabled()

JYUSB1202API int JYUSB1202_CI_SetZReloadEnabled | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | bool | zReloadEnabled )

Set the Z signal enable in Encoder mode.

Parameters
hDevice | device handle
zReloadEnabled | enable z signal. True: enabled; False: disabled.Valid only under encoder mode.
Returns
0 if success or other error code

◆ JYUSB1202_CI_Start()

JYUSB1202API int JYUSB1202_CI_Start ( JYUSB1202_DeviceHandle hDevice )

Start Counter input.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JYUSB1202_CI_Stop()

JYUSB1202API int JYUSB1202_CI_Stop ( JYUSB1202_DeviceHandle hDevice )

Stop Counter input.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JYUSB1202_Close()

JYUSB1202API int JYUSB1202_Close ( JYUSB1202_DeviceHandle hDevice )

Close this USB1202 board.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JYUSB1202_CO_SetCounterParamet()

JYUSB1202API int JYUSB1202_CO_SetCounterParamet | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | int | pulseCount,
 |  | JYUSB1202_CO_IdleState | IdleState )

Set CO parameter.

Parameters
hDevice | device handle
pulseCount | counter output pulse number, if pulseCount = -1 ,the device always responds to output until the user stops it.
IdleState | counter output idle state
Returns
0 if success or other error code

◆ JYUSB1202_CO_SetFrequency()

JYUSB1202API int JYUSB1202_CO_SetFrequency | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | unsigned int | highTicks,
 |  | unsigned int | lowTicks )

Set counter output pulse frequency.

Parameters
hDevice | device handle
highTicks | the number of ticks for the high pulse, timebase is 200MHz.
lowTicks | the number of ticks for the low pulse, timebase is 200MHz.
Returns
0 if success or other error code

◆ JYUSB1202_CO_SetPauseTriggerLevel()

JYUSB1202API int JYUSB1202_CO_SetPauseTriggerLevel | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | bool | enable,
 |  | JYUSB1202_LevelState | pauseTriggerActiveLevel )

Config CO pause trigger.

Parameters
hDevice | Device handle
enable | Enable pasue trigger
pauseTriggerActiveLevel | Pause trigger active level.
Returns
Succeed: 0 , Error: !=0

◆ JYUSB1202_CO_Start()

JYUSB1202API int JYUSB1202_CO_Start ( JYUSB1202_DeviceHandle hDevice )

Start counter output.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JYUSB1202_CO_Stop()

JYUSB1202API int JYUSB1202_CO_Stop ( JYUSB1202_DeviceHandle hDevice )

Stop counter output.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JYUSB1202_CO_WaitUntilDone()

JYUSB1202API int JYUSB1202_CO_WaitUntilDone | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | bool * | done,
 |  | int | timeOut )

Check CO output is completed or not.

Parameters
hDevice | device handle
done | true if completed, false if not yet completed.
timeOut | timeout time in microsecond, this parament not valid in current version
Returns
0 if success or other error code

◆ JYUSB1202_DI_AddLines()

JYUSB1202API int JYUSB1202_DI_AddLines | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | char * | line,
 |  | int | lineCount )

Enabled DI channels.

Parameters
hDevice | device handle
line | array[lineCount] containing line IDs
lineCount | number of lines to be enabled
Returns
0 if success or other error code

◆ JYUSB1202_DI_ReadSinglePoint()

JYUSB1202API int JYUSB1202_DI_ReadSinglePoint | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | bool * | readValues,
 |  | int | lineID )

read single data from a single line by lineID defined.if the lineID == -1,read all line data.The data type is bool, one bool defined one line status.

Parameters
hDevice | device handle
readValues | read the specified line values. when the lineID is -1, read all enabled line values,the readValues Length must equal to lineCount(In function JYUSB1202_DI_AddLines defined), and the values store order is add order.
lineID | line number
Returns
0 if success or other error code

◆ JYUSB1202_DI_Start()

JYUSB1202API int JYUSB1202_DI_Start ( JYUSB1202_DeviceHandle hDevice )

Start digital signal input.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JYUSB1202_DI_Stop()

JYUSB1202API int JYUSB1202_DI_Stop ( JYUSB1202_DeviceHandle hDevice )

Stop digital signal input.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JYUSB1202_DO_AddLines()

JYUSB1202API int JYUSB1202_DO_AddLines | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | char * | line,
 |  | int | lineCount )

Enabled DO channels.

Parameters
hDevice | device handle
line | array[lineCount] containing line IDs.
lineCount | number of lines to be enabled
Returns
0 if success or other error code

◆ JYUSB1202_DO_Start()

JYUSB1202API int JYUSB1202_DO_Start ( JYUSB1202_DeviceHandle hDevice )

Start digital signal output.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JYUSB1202_DO_Stop()

JYUSB1202API int JYUSB1202_DO_Stop ( JYUSB1202_DeviceHandle hDevice )

Stop digital signal output.

Parameters
hDevice device handle
Returns
0 if success or other error code

◆ JYUSB1202_DO_WriteSinglePoint()

JYUSB1202API int JYUSB1202_DO_WriteSinglePoint | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | bool * | writeValues,
 |  | int | lineID )

write single data to the line by lineID defined.if the lineID == -1,write all line data.

Parameters
hDevice | device handle
writeValues | write the specified line values when the lineID is -1, write all enabled lines values,the writeValues Length must equal to lineCount(In function JYUSB1202_DO_AddLines defined), and the values order is add order.
lineCount | line count
Returns
0 if success or other error code

◆ JYUSB1202_GetCapabilityDouble()

JYUSB1202API int JYUSB1202_GetCapabilityDouble | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | JYUSB1202_Capability_Item | item,
 |  | double * | value )

获取当前设备的能力信息，比如最高采样率

Parameters
hDevice | 板卡句柄
item | 设备能力项
value | 设备能力值
Returns
0：无错误；其它：发生错误

◆ JYUSB1202_GetCapabilityDoubleByName()

JYUSB1202API int JYUSB1202_GetCapabilityDoubleByName | ( | const char * | deviceName,
 |  | JYUSB1202_Capability_Item | item,
 |  | double * | value,
 |  | bool | setDefaultIfDeviceNotFound = true )

在不打开设备的情况下，获取指定别名的设备的能力信息中的浮点型数值参数，比如最高采样率

Parameters
deviceName | 设备别名
item | 设备能力项
value | 设备能力值
setDefaultIfDeviceNotFound | 当无法找到指定设备时，若该参数为true，则设置设备能力信息为默认值、不报错；若该参数为false，则返回无法打开设备错误
Returns
0：无错误；其它：发生错误

◆ JYUSB1202_GetCapabilityDoubleBySlotNumber()

JYUSB1202API int JYUSB1202_GetCapabilityDoubleBySlotNumber | ( | int | slotNumber,
 |  | JYUSB1202_Capability_Item | item,
 |  | double * | value,
 |  | bool | setDefaultIfDeviceNotFound = true )

在不打开设备的情况下，获取位于指定卡槽号的设备的能力信息中的浮点型数值参数，比如最高采样率

Parameters
slotNumber | 卡槽号
item | 设备能力项
value | 设备能力值
setDefaultIfDeviceNotFound | 当无法找到指定设备时，若该参数为true，则设置设备能力信息为默认值、不报错；若该参数为false，则返回无法打开设备错误
Returns
0：无错误；其它：发生错误

◆ JYUSB1202_GetCapabilityInt()

JYUSB1202API int JYUSB1202_GetCapabilityInt | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | JYUSB1202_Capability_Item | item,
 |  | int * | value )

获取当前设备的能力信息中的整型数值参数，比如通道数

Parameters
hDevice | 板卡句柄
item | 设备能力项
value | 设备能力值
Returns
0：无错误；其它：发生错误

◆ JYUSB1202_GetCapabilityIntByName()

JYUSB1202API int JYUSB1202_GetCapabilityIntByName | ( | const char * | deviceName,
 |  | JYUSB1202_Capability_Item | item,
 |  | int * | value,
 |  | bool | setDefaultIfDeviceNotFound = true )

在不打开设备的情况下，获取指定别名的设备的能力信息中的整型数值参数，比如通道数

Parameters
deviceName | 设备别名
item | 设备能力项
value | 设备能力值
setDefaultIfDeviceNotFound | 当无法找到指定设备时，若该参数为true，则设置设备能力信息为默认值、不报错；若该参数为false，则返回无法打开设备错误
Returns
0：无错误；其它：发生错误

◆ JYUSB1202_GetCapabilityIntBySlotNumber()

JYUSB1202API int JYUSB1202_GetCapabilityIntBySlotNumber | ( | int | slotNumber,
 |  | JYUSB1202_Capability_Item | item,
 |  | int * | value,
 |  | bool | setDefaultIfDeviceNotFound = true )

在不打开设备的情况下，获取位于指定卡槽号的设备的能力信息中的整型数值参数，比如通道数

Parameters
slotNumber | 卡槽号
item | 设备能力项
value | 设备能力值
setDefaultIfDeviceNotFound | 当无法找到指定设备时，若该参数为true，则设置设备能力信息为默认值、不报错；若该参数为false，则返回无法打开设备错误
Returns
0：无错误；其它：发生错误

◆ JYUSB1202_GetDeviceSerialNumber()

JYUSB1202API int JYUSB1202_GetDeviceSerialNumber | ( | JYUSB1202_DeviceHandle | hDevice,
 |  | char * | serialNumber,
 |  | int | length )

Obtain the device serialNumber.

Parameters
hDevice | device handle
serialNumber | Pointer to a buffer receiving the serial number. The length of the serial number is 10.
length | serial Number length ,length is 10
Returns
0 if success or other error code

◆ JYUSB1202_Open()

JYUSB1202API int JYUSB1202_Open ( JYUSB1202_DeviceHandle * hDevice )

Open the USB1202 board，default open the first card.

Parameters
hDevice device handle. All other functions uses hDevice to represent this device.
Returns
0 if success or other error code

◆ JYUSB1202_OpenByName()

JYUSB1202API int JYUSB1202_OpenByName | ( | const char * | cardName,
 |  | JYUSB1202_DeviceHandle * | hDevice )

Open this USB1202 board using the board alias name which is set by JYTEK utility JYDM.

You can change the name using JYDM.

Parameters
cardName | board alias name
hDevice | device handle
Returns
0 if success or other error code


USB-1202 C# Programming Manual: D:/OneDrive/Desktop/产品文档/CHM/1202/C#/JYUSB1202DITask.cs File Reference

Classes | Namespaces
JYUSB1202DITask.cs File Reference

Classes

class | JYUSB1202.JYUSB1202DITask
JYUSB1202 Digital Iuput Task. More...
class | JYUSB1202.DIChannel
DI Channel parameter class . More...

Namespaces

namespace JYUSB1202


USB-1202 C# Programming Manual: D:/OneDrive/Desktop/产品文档/CHM/1202/C#/JYUSB1202DOTask.cs File Reference

Classes | Namespaces
JYUSB1202DOTask.cs File Reference

Classes

class | JYUSB1202.JYUSB1202DOTask
JYUSB1202 Digital Output Task. More...
class | JYUSB1202.DOChannel
DO Channel parameter class . More...

Namespaces

namespace JYUSB1202


USB-1202 C# Programming Manual: Class List

  • Packages
  • Classes
  • Files
  • Class List
  • Class Index
  • Class Members
Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
N JYUSB1202 |
C JYUSB1202AITask | JYUSB1202 Analog Input Task
C AIChannel | AI Channel parameter class
C AISampleClock | Sample clock configuration class
C AIExternalSampleClock | External Sample Clock Configuration Class
C AITrigger | Clock Terminal
C AIDigitalTrigger | AI Digital trigger class
C AIRecord | AI Record Parameters
C AISignalExport | AI Signal Export Class
C JYUSB1202CITask | JYUSB1202 Counter Input Task
C EdgeCounting | Configure CI EdgeCounting
C EdgeCountingOutEvent | Edge counting output event configuration class
C PauseTrigger | Pause trigger configuration class
C FrequencyMeas | Configure CI Measure
C PeriodMeas | Configure CI Measure
C PulseMeas | Configure CI Measure
C TwoEdgeSeparation | Configure CI Measure
C QuadEncoder | Configure CI Measure
C TwoPulseEncoder | Configure CI Measure
C JYUSB1202COTask | JYUSB1202 Counter Output Task
C COPulse | Pulse Parameter
C JYUSB1202DITask | JYUSB1202 Digital Iuput Task
C DIChannel | DI Channel parameter class
C JYUSB1202DOTask | JYUSB1202 Digital Output Task
C DOChannel | DO Channel parameter class
C ScalingCoefficients |


USB-1202 C# Programming Manual: JYUSB1202.AIChannel Class Reference

  • Class List
  • Class Index
  • Class Members
  • JYUSB1202
  • AIChannel
Public Member Functions | Properties | List of all members
JYUSB1202.AIChannel Class Referencesealed

AI Channel parameter class . More...

Public Member Functions

AIChannel (int channelId, double rangeLow, double rangeHigh, AITerminal terminalCfg=AITerminal.Differential, AICoupling couplingCfg=AICoupling.DC, bool enableIEPE=false)
Constructor to create an AIChnParam task object.

Properties

int | ChannelID [get]
AI channel ID.
double | RangeLow [get, set]
Low range limit an AI channel.
double | RangeHigh [get, set]
High range limit an AI channel.
AITerminal | Terminal [get, set]
Configure AI terminal.
AICoupling | Coupling [get, set]
Configure AI coupling.
bool | EnableIEPE [get, set]
Configure IEPE Mode.

Detailed Description

AI Channel parameter class .

Constructor & Destructor Documentation

◆ AIChannel()

JYUSB1202.AIChannel.AIChannel | ( | int | channelId,
 |  | double | rangeLow,
 |  | double | rangeHigh,
 |  | AITerminal | terminalCfg = AITerminal::Differential,
 |  | AICoupling | couplingCfg = AICoupling::DC,
 |  | bool | enableIEPE = false )

Constructor to create an AIChnParam task object.

Parameters
channelId | AI channel ID.
rangeLow | Low range limit an AI channel.
rangeHigh | High range limit an AI channel.
terminalCfg | Configure AI terminal.

Property Documentation

◆ ChannelID

int JYUSB1202.AIChannel.ChannelID
get

AI channel ID.

◆ Coupling

AICoupling JYUSB1202.AIChannel.Coupling
getset

Configure AI coupling.

(AC,DC)

◆ EnableIEPE

bool JYUSB1202.AIChannel.EnableIEPE
getset

Configure IEPE Mode.

◆ RangeHigh

double JYUSB1202.AIChannel.RangeHigh
getset

High range limit an AI channel.

◆ RangeLow

double JYUSB1202.AIChannel.RangeLow
getset

Low range limit an AI channel.

◆ Terminal

AITerminal JYUSB1202.AIChannel.Terminal
getset

Configure AI terminal.

(PSEUDIFF,Differential)

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/1202/C#/JYUSB1202AITask.cs


USB-1202 C# Programming Manual: Member List

  • JYUSB1202
  • AIChannel
JYUSB1202.AIChannel Member List

This is the complete list of members for JYUSB1202.AIChannel, including all inherited members.

AIChannel(int channelId, double rangeLow, double rangeHigh, AITerminal terminalCfg=AITerminal.Differential, AICoupling couplingCfg=AICoupling.DC, bool enableIEPE=false) | JYUSB1202.AIChannel
ChannelID | JYUSB1202.AIChannel
Coupling | JYUSB1202.AIChannel
EnableIEPE | JYUSB1202.AIChannel
RangeHigh | JYUSB1202.AIChannel
RangeLow | JYUSB1202.AIChannel
Terminal | JYUSB1202.AIChannel


USB-1202 C# Programming Manual: JYUSB1202.AIDigitalTrigger Class Reference

  • AIDigitalTrigger
Properties | List of all members
JYUSB1202.AIDigitalTrigger Class Referencesealed

AI Digital trigger class. More...

Properties

AIDigitalTriggerEdge | Edge [get, set]
Digital Trigger edge，Rising/Falling.
AIDigitalTriggerSource | Source [get, set]
Digital Trigger Source.

Detailed Description

AI Digital trigger class.

Property Documentation

◆ Edge

AIDigitalTriggerEdge JYUSB1202.AIDigitalTrigger.Edge
getset

Digital Trigger edge，Rising/Falling.

◆ Source

AIDigitalTriggerSource JYUSB1202.AIDigitalTrigger.Source
getset

Digital Trigger Source.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/1202/C#/JYUSB1202AITask.cs


USB-1202 C# Programming Manual: Member List

  • AIDigitalTrigger
JYUSB1202.AIDigitalTrigger Member List

This is the complete list of members for JYUSB1202.AIDigitalTrigger, including all inherited members.

Edge | JYUSB1202.AIDigitalTrigger
Source | JYUSB1202.AIDigitalTrigger


USB-1202 C# Programming Manual: JYUSB1202.AIExternalSampleClock Class Reference

  • AIExternalSampleClock
Properties | List of all members
JYUSB1202.AIExternalSampleClock Class Reference

External Sample Clock Configuration Class. More...

Properties

double ExpectedRate [get, set]
Expected External Sample Clock Rate.

Detailed Description

External Sample Clock Configuration Class.

Property Documentation

◆ ExpectedRate

double JYUSB1202.AIExternalSampleClock.ExpectedRate
getset

Expected External Sample Clock Rate.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/1202/C#/JYUSB1202AITask.cs


USB-1202 C# Programming Manual: Member List

  • AIExternalSampleClock
JYUSB1202.AIExternalSampleClock Member List

This is the complete list of members for JYUSB1202.AIExternalSampleClock, including all inherited members.

ExpectedRate JYUSB1202.AIExternalSampleClock


USB-1202 C# Programming Manual: JYUSB1202.AIRecord Class Reference

  • AIRecord
Properties | List of all members
JYUSB1202.AIRecord Class Referencesealed

AI Record Parameters. More...

Properties

string | FilePath [get, set]
User specified file path.
FileFormat | FileFormat [get]
Streaming file format.
RecordMode | Mode [get, set]
stream mode .
double | Length [get, set]
User specified stream length in second.

Detailed Description

AI Record Parameters.

Property Documentation

◆ FileFormat

FileFormat JYUSB1202.AIRecord.FileFormat
get

Streaming file format.

enum BIN.

◆ FilePath

string JYUSB1202.AIRecord.FilePath
getset

User specified file path.

◆ Length

double JYUSB1202.AIRecord.Length
getset

User specified stream length in second.

Only when Mode is RecordMode.Finite.

◆ Mode

RecordMode JYUSB1202.AIRecord.Mode
getset

stream mode .

enum Finite/Infinite.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/1202/C#/JYUSB1202AITask.cs


USB-1202 C# Programming Manual: Member List

  • AIRecord
JYUSB1202.AIRecord Member List

This is the complete list of members for JYUSB1202.AIRecord, including all inherited members.

FileFormat | JYUSB1202.AIRecord
FilePath | JYUSB1202.AIRecord
Length | JYUSB1202.AIRecord
Mode | JYUSB1202.AIRecord


USB-1202 C# Programming Manual: JYUSB1202.AISampleClock Class Reference

  • AISampleClock
Properties | List of all members
JYUSB1202.AISampleClock Class Reference

Sample clock configuration class. More...

Properties

AISampleClockSource | Source [get, set]
AI Sample Clock Source.
AIExternalSampleClock | External [get, set]
External Sample Clock Configuration.

Detailed Description

Sample clock configuration class.

Property Documentation

◆ External

AIExternalSampleClock JYUSB1202.AISampleClock.External
getset

External Sample Clock Configuration.

Valid when Source is AISampleClockSource.External.

◆ Source

AISampleClockSource JYUSB1202.AISampleClock.Source
getset

AI Sample Clock Source.

enum Internal/External. The default value is AISampleClockSource.Internal.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/1202/C#/JYUSB1202AITask.cs


USB-1202 C# Programming Manual: Member List

  • AISampleClock
JYUSB1202.AISampleClock Member List

This is the complete list of members for JYUSB1202.AISampleClock, including all inherited members.

External | JYUSB1202.AISampleClock
Source | JYUSB1202.AISampleClock


USB-1202 C# Programming Manual: JYUSB1202.AISignalExport Class Reference

  • AISignalExport
Public Member Functions | List of all members
JYUSB1202.AISignalExport Class Reference

AI Signal Export Class. More...

Public Member Functions

void | Add (AISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination.
void | Add (AISignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination.
void | Clear (SignalExportDestination destination)
Clear one Signal Export.
void | ClearAll ()
Clear All Signal Export.

Detailed Description

AI Signal Export Class.

Member Function Documentation

◆ Add() [1/2]

void JYUSB1202.AISignalExport.Add | ( | AISignalExportSource | source,
 |  | List< SignalExportDestination > | destinations )

Export one Signal to Mutil Desination.

Parameters
source | AI Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JYUSB1202.AISignalExport.Add | ( | AISignalExportSource | source,
 |  | SignalExportDestination | destination )

Export one Signal to Desination.

Parameters
source | AI Signal Source
destination | Export Desination

◆ Clear()

void JYUSB1202.AISignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export.

Parameters
destination Export Desination

◆ ClearAll()

void JYUSB1202.AISignalExport.ClearAll ( )

Clear All Signal Export.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/1202/C#/JYUSB1202AITask.cs


USB-1202 C# Programming Manual: Member List

  • AISignalExport
JYUSB1202.AISignalExport Member List

This is the complete list of members for JYUSB1202.AISignalExport, including all inherited members.

Add(AISignalExportSource source, SignalExportDestination destination) | JYUSB1202.AISignalExport
Add(AISignalExportSource source, List< SignalExportDestination > destinations) | JYUSB1202.AISignalExport
Clear(SignalExportDestination destination) | JYUSB1202.AISignalExport
ClearAll() | JYUSB1202.AISignalExport


USB-1202 C# Programming Manual: JYUSB1202.AITrigger Class Reference

  • AITrigger
Properties | List of all members
JYUSB1202.AITrigger Class Referencesealed

Clock Terminal. More...

Properties

AITriggerType | Type [get, set]
AI trigger type.
AIDigitalTrigger | Digital [get, set]
Digital Trigger Congfiguration.

Detailed Description

Clock Terminal.

Constructor to create an AITrigger task object. Used to build AI Trigger

Property Documentation

◆ Digital

AIDigitalTrigger JYUSB1202.AITrigger.Digital
getset

Digital Trigger Congfiguration.

Valid when Type is AITriggerType.Digital.

◆ Type

AITriggerType JYUSB1202.AITrigger.Type
getset

AI trigger type.

enum Analog/Digital/Immediate/Soft. The default value is AITriggerType.Immediate.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/1202/C#/JYUSB1202AITask.cs


USB-1202 C# Programming Manual: Member List

  • AITrigger
JYUSB1202.AITrigger Member List

This is the complete list of members for JYUSB1202.AITrigger, including all inherited members.

Digital | JYUSB1202.AITrigger
Type | JYUSB1202.AITrigger


USB-1202 C# Programming Manual: JYUSB1202.COPulse Class Reference

  • COPulse
Public Member Functions | List of all members
JYUSB1202.COPulse Class Reference

Pulse Parameter. More...

Public Member Functions

COPulse (COPulseType type, double param1, double param2, int count)
Pulse Parameter.

Detailed Description

Pulse Parameter.

Constructor & Destructor Documentation

◆ COPulse()

JYUSB1202.COPulse.COPulse | ( | COPulseType | type,
 |  | double | param1,
 |  | double | param2,
 |  | int | count )

Pulse Parameter.

Parameters
type | The pulse type characteristics.
param1 | Parameter 1. Frequency (Hz) when constructed as COPulseType.DutyCycleFrequency; High duration in seconds when constructed as COPulseType.HighLowTime; High ticks of the clock when constructed as COPulseType.HighLowTick.
param2 | Parameter 1. Duty cycle (greater than 0 and less than 1) when constructed as COPulseType.DutyCycleFrequency; Low duration in seconds when constructed as COPulseType.HighLowTime; Low ticks of the clock when constructed as COPulseType.HighLowTick.
count | Number of pulses. When the value is -1 (indicating that the number of pulses is infinite), pulses will be continuously sent until requested to stop.
The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/1202/C#/JYUSB1202COTask.cs


USB-1202 C# Programming Manual: Member List

  • COPulse
JYUSB1202.COPulse Member List

This is the complete list of members for JYUSB1202.COPulse, including all inherited members.

COPulse(COPulseType type, double param1, double param2, int count) JYUSB1202.COPulse


USB-1202 C# Programming Manual: JYUSB1202.DIChannel Class Reference

  • DIChannel
Properties | List of all members
JYUSB1202.DIChannel Class Referencesealed

DI Channel parameter class . More...

Properties

int LineNum [get, set]
port number.

Detailed Description

DI Channel parameter class .

Property Documentation

◆ LineNum

int JYUSB1202.DIChannel.LineNum
getset

port number.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/1202/C#/JYUSB1202DITask.cs


USB-1202 C# Programming Manual: Member List

  • DIChannel
JYUSB1202.DIChannel Member List

This is the complete list of members for JYUSB1202.DIChannel, including all inherited members.

LineNum JYUSB1202.DIChannel


USB-1202 C# Programming Manual: JYUSB1202.DOChannel Class Reference

  • DOChannel
Properties | List of all members
JYUSB1202.DOChannel Class Referencesealed

DO Channel parameter class . More...

Properties

int LineNum [get, set]
port number.

Detailed Description

DO Channel parameter class .

Property Documentation

◆ LineNum

int JYUSB1202.DOChannel.LineNum
getset

port number.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/1202/C#/JYUSB1202DOTask.cs


USB-1202 C# Programming Manual: Member List

  • DOChannel
JYUSB1202.DOChannel Member List

This is the complete list of members for JYUSB1202.DOChannel, including all inherited members.

LineNum JYUSB1202.DOChannel


USB-1202 C# Programming Manual: JYUSB1202.EdgeCounting Class Reference

  • EdgeCounting
Properties | List of all members
JYUSB1202.EdgeCounting Class Referencesealed

Configure CI EdgeCounting. More...

Properties

int | InitialCount [get, set]
Initial Count.
CountDirection | Direction [get, set]
Counter direction.
PauseTrigger | Pause [get, set]
Pause Trigger Configuration.
EdgeCountingOutEvent | OutEvent [get, set]
Edge counting output event.

Detailed Description

Configure CI EdgeCounting.

Property Documentation

◆ Direction

CountDirection JYUSB1202.EdgeCounting.Direction
getset

Counter direction.

enum Up/Down/External

◆ InitialCount

int JYUSB1202.EdgeCounting.InitialCount
getset

Initial Count.

◆ OutEvent

EdgeCountingOutEvent JYUSB1202.EdgeCounting.OutEvent
getset

Edge counting output event.

A pulse will be generated when the count value reaches specified threshold

◆ Pause

PauseTrigger JYUSB1202.EdgeCounting.Pause
getset

Pause Trigger Configuration.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/1202/C#/JYUSB1202CITask.cs


USB-1202 C# Programming Manual: Member List

  • EdgeCounting
JYUSB1202.EdgeCounting Member List

This is the complete list of members for JYUSB1202.EdgeCounting, including all inherited members.

Direction | JYUSB1202.EdgeCounting
InitialCount | JYUSB1202.EdgeCounting
OutEvent | JYUSB1202.EdgeCounting
Pause | JYUSB1202.EdgeCounting


USB-1202 C# Programming Manual: JYUSB1202.EdgeCountingOutEvent Class Reference

  • EdgeCountingOutEvent
Properties | List of all members
JYUSB1202.EdgeCountingOutEvent Class Reference

Edge counting output event configuration class. More...

Properties

EdgeCntOunEvtIdleState | IdleState [get, set]
Output idle state when the event has not occurred.
uint | Threshold [get, set]
Comparison threshold.

Detailed Description

Edge counting output event configuration class.

Property Documentation

◆ IdleState

EdgeCntOunEvtIdleState JYUSB1202.EdgeCountingOutEvent.IdleState
getset

Output idle state when the event has not occurred.

The default value is EdgeCntOunEvtIdleState.LowLevel

◆ Threshold

uint JYUSB1202.EdgeCountingOutEvent.Threshold
getset

Comparison threshold.

The default value is 2^32-1

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/1202/C#/JYUSB1202CITask.cs


USB-1202 C# Programming Manual: Member List

  • EdgeCountingOutEvent
JYUSB1202.EdgeCountingOutEvent Member List

This is the complete list of members for JYUSB1202.EdgeCountingOutEvent, including all inherited members.

IdleState | JYUSB1202.EdgeCountingOutEvent
Threshold | JYUSB1202.EdgeCountingOutEvent


USB-1202 C# Programming Manual: JYUSB1202.FrequencyMeas Class Reference

  • FrequencyMeas
List of all members
JYUSB1202.FrequencyMeas Class Referencesealed

Configure CI Measure. More...

Detailed Description

Configure CI Measure.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/1202/C#/JYUSB1202CITask.cs


USB-1202 C# Programming Manual: Member List

  • FrequencyMeas
JYUSB1202.FrequencyMeas Member List

This is the complete list of members for JYUSB1202.FrequencyMeas, including all inherited members.


USB-1202 C# Programming Manual: JYUSB1202.JYUSB1202AITask Class Reference

  • JYUSB1202AITask
Public Member Functions | Public Attributes | Properties | List of all members
JYUSB1202.JYUSB1202AITask Class Referencesealed

JYUSB1202 Analog Input Task. More...

Public Member Functions

JYUSB1202AITask (int slotNumber)
Constructor, Used to create an AI task by a slot number.
JYUSB1202AITask (string boardName)
Constructor.
void | AddChannel (int chnId, double rangeLow=-12, double rangeHigh=12, AITerminal terminalCfg=AITerminal.Differential, AICoupling couplingCfg=AICoupling.DC, bool enableIEPE=false)
Add one channel.
void | AddChannel (int[] chnsId, double rangeLow=-12, double rangeHigh=12, AITerminal terminalCfg=AITerminal.Differential, AICoupling couplingCfg=AICoupling.DC, bool enableIEPE=false)
Add a group of channels.
void | AddChannel (int[] chnsId, double[] rangeLow, double[] rangeHigh, AITerminal[] terminalCfg, AICoupling[] couplingCfg, bool[] enableIEPE)
Add a group of channels.
void | RemoveChannel (int chnId)
Delete the specified channel number.
void | ReadData (IntPtr buf, int samplesPerChannel, int timeout)
Read one or multi-channel data by columns and store it in a data buffer.
void | ReadData (ref double[,] buf, int samplesPerChannel, int timeout)
Read the multi-channel data by columns and store it in a data buffer.
void | ReadData (ref double[,] buf, int timeout=-1)
Read the multi-channel data by columns and store it in a data buffer.
void | ReadData (ref double[] buf, int samplesPerChannel, int timeout)
Read the one channel data and store it in a data buffer.
void | ReadData (ref double[] buf, int timeout=-1)
Read the one channel data and store it in a data buffer.
void | ReadRawData (IntPtr buf, int samplesPerChannel, int timeout)
Read one or multi-channel raw data by columns and store it in a data buffer.
void | ReadRawData (ref short[,] buf, int samplesPerChannel, int timeout)
Read the multi-channel raw data by columns and store it in a data buffer.
void | ReadRawData (ref short[,] buf, int timeout=-1)
Read the multi-channel raw data by columns and store it in a data buffer.
void | ReadRawData (ref short[] buf, int samplesPerChannel, int timeout)
Read the one channel raw data and store it in a data buffer.
void | ReadRawData (ref short[] buf, int timeout=-1)
Read the one channel raw data and store it in a data buffer.
void | GetRecordPreviewData (ref double[,] buf, int samplesPerChannel, int timeout)
Preview multi-channel data when streaming is in progress.
void | GetRecordPreviewData (ref double[,] buf, int timeout=-1)
Preview multi-channel data when streaming is in progress.
void | GetRecordPreviewData (ref double[] buf, int samplesPerChannel, int timeout)
Preview one channel data when streaming is in progress.
void | GetRecordPreviewData (ref double[] buf, int timeout=-1)
Preview one channel data when streaming is in progress.
void | GetRecordStatus (out double recordedLength, out bool recordDone)
Read one sample for all channels in register .
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete.
ScalingCoefficients[] GetScalingCoefficients ()
在Commit()或Start()之后调用，获取当前任务已添加通道的电压换算因子，用于将Raw数据转换为电压值。
void | Start ()
Start AI task .
void | SendSoftwareTrigger ()
Generate a software trigger.
void | Stop ()
Stop AI task .

Public Attributes

double MaxSampleRate

Properties

List< AIChannel > | Channels [get]
List of AI channels,(1202 support 4 channel).
AIMode | Mode [get, set]
AI acquisition mode，support Single/Finite/Continuous/Record.
AIFDAMODE | FDAMode [get, set]
AIFilterType | FilterType [get, set]
double | SampleRate [get, set]
Sample rate per channel.
int | SamplesToAcquire [get, set]
Number of samples to be read per channel.
int | BufLenInSamples [get]
Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.
ulong | AvailableSamples [get]
Number of samples per channel that can be read in the buffer .
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel).
AISampleClock | SampleClock [get, set]
AI Sample Clock Configuration.
AITrigger | Trigger [get, set]
AI Trigger Configuration.
AIRecord | Record = new AIRecord() [get]
ai Data streaming Configuration
AISignalExport | SignalExport [get, set]
Export AI Signal Configuration.
JYUSB1202Device | Device [get]
Device.

Detailed Description

JYUSB1202 Analog Input Task.

Constructor & Destructor Documentation

◆ JYUSB1202AITask() [1/2]

JYUSB1202.JYUSB1202AITask.JYUSB1202AITask ( int slotNumber )

Constructor, Used to create an AI task by a slot number.

◆ JYUSB1202AITask() [2/2]

JYUSB1202.JYUSB1202AITask.JYUSB1202AITask ( string boardName )

Constructor.

Used to create an AI task by a board name.

Parameters
boardName Board name(device alias), set by device manager

Member Function Documentation

◆ AddChannel() [1/3]

void JYUSB1202.JYUSB1202AITask.AddChannel | ( | int | chnId,
 |  | double | rangeLow = -12,
 |  | double | rangeHigh = 12,
 |  | AITerminal | terminalCfg = AITerminal::Differential,
 |  | AICoupling | couplingCfg = AICoupling::DC,
 |  | bool | enableIEPE = false )

Add one channel.

Parameters
chnId | channel's physical number ，chnId=-1, add all channels。
rangeLow | lower range limit for the channel，-10V,-5V defalut -10
rangeHigh | higher range limit for the channel，10V,5V defalut 10
terminalCfg | terminal input mode configuration，PSEUDIFF/Differential.Default Differential
couplingCfg | coupling input mode configuration，AC/DC.Default DC
enableIEPE | IEPE Enable, defalut: false

◆ AddChannel() [2/3]

void JYUSB1202.JYUSB1202AITask.AddChannel | ( | int[] | chnsId,
 |  | double | rangeLow = -12,
 |  | double | rangeHigh = 12,
 |  | AITerminal | terminalCfg = AITerminal::Differential,
 |  | AICoupling | couplingCfg = AICoupling::DC,
 |  | bool | enableIEPE = false )

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers
rangeLow | lower range limit for the channel，-10V,-5V defalut -10
rangeHigh | higher range limit for the channel，10V,5V defalut 10
terminalCfg | terminal input mode configuration，RSE/Differential.Default RSE
couplingCfg | coupling input mode configuration，AC/DC.Default DC
enableIEPE | IEPE Enable, defalut: false

◆ AddChannel() [3/3]

void JYUSB1202.JYUSB1202AITask.AddChannel | ( | int[] | chnsId,
 |  | double[] | rangeLow,
 |  | double[] | rangeHigh,
 |  | AITerminal[] | terminalCfg,
 |  | AICoupling[] | couplingCfg,
 |  | bool[] | enableIEPE )

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers
rangeLow | lower range limit for the channel，-10V,-5V
rangeHigh | higher range limit for the channel，10V,5V
terminalCfg | terminal input mode configuration，RSE/Differential.Default RSE
couplingCfg | coupling input mode configuration，AC/DC.Default DC
enableIEPE | IEPE Enable, defalut: false

◆ GetRecordPreviewData() [1/4]

void JYUSB1202.JYUSB1202AITask.GetRecordPreviewData | ( | ref double | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout )

Preview multi-channel data when streaming is in progress.

Each column represents one channel.

Parameters
buf | Data buffer
samplesPerChannel | Number of preview samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ GetRecordPreviewData() [2/4]

void JYUSB1202.JYUSB1202AITask.GetRecordPreviewData | ( | ref double | buf[,],
 |  | int | timeout = -1 )

Preview multi-channel data when streaming is in progress.

Each column represents one channel.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ GetRecordPreviewData() [3/4]

void JYUSB1202.JYUSB1202AITask.GetRecordPreviewData | ( | ref double[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Preview one channel data when streaming is in progress.

Parameters
buf | Data buffer
samplesPerChannel | Number of preview samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ GetRecordPreviewData() [4/4]

void JYUSB1202.JYUSB1202AITask.GetRecordPreviewData | ( | ref double[] | buf,
 |  | int | timeout = -1 )

Preview one channel data when streaming is in progress.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ GetRecordStatus()

void JYUSB1202.JYUSB1202AITask.GetRecordStatus | ( | out double | recordedLength,
 |  | out bool | recordDone )

Read one sample for all channels in register .

Available when Mode is AIMode.Single

Parameters
readValues Values read. Array length >= Channels.Count.

get the streaming status. Available when Mode is AIMode.Record

Parameters
recordedLength | Length of the streamed
recordDone | recordDone = false :streaming is not over.recordDone = true :streaming is over.

◆ GetScalingCoefficients()

ScalingCoefficients[] JYUSB1202.JYUSB1202AITask.GetScalingCoefficients ( )

在Commit()或Start()之后调用，获取当前任务已添加通道的电压换算因子，用于将Raw数据转换为电压值。

Returns

◆ ReadData() [1/5]

void JYUSB1202.JYUSB1202AITask.ReadData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read one or multi-channel data by columns and store it in a data buffer.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel to read
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadData() [2/5]

void JYUSB1202.JYUSB1202AITask.ReadData | ( | ref double | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read the multi-channel data by columns and store it in a data buffer.

Each channel is represented by one column of data.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel to read
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadData() [3/5]

void JYUSB1202.JYUSB1202AITask.ReadData | ( | ref double | buf[,],
 |  | int | timeout = -1 )

Read the multi-channel data by columns and store it in a data buffer.

Each channel is represented by one column of data.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadData() [4/5]

void JYUSB1202.JYUSB1202AITask.ReadData | ( | ref double[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read the one channel data and store it in a data buffer.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel to read
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadData() [5/5]

void JYUSB1202.JYUSB1202AITask.ReadData | ( | ref double[] | buf,
 |  | int | timeout = -1 )

Read the one channel data and store it in a data buffer.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadRawData() [1/5]

void JYUSB1202.JYUSB1202AITask.ReadRawData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read one or multi-channel raw data by columns and store it in a data buffer.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel to read
timeout | timeout before generating error message, uint is ms。, timeout =-1 keep waiting until finish.

◆ ReadRawData() [2/5]

void JYUSB1202.JYUSB1202AITask.ReadRawData | ( | ref short | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read the multi-channel raw data by columns and store it in a data buffer.

Each channel is represented by one column of data.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel to read
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadRawData() [3/5]

void JYUSB1202.JYUSB1202AITask.ReadRawData | ( | ref short | buf[,],
 |  | int | timeout = -1 )

Read the multi-channel raw data by columns and store it in a data buffer.

Each channel is represented by one column of data.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadRawData() [4/5]

void JYUSB1202.JYUSB1202AITask.ReadRawData | ( | ref short[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout )

Read the one channel raw data and store it in a data buffer.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel to read
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadRawData() [5/5]

void JYUSB1202.JYUSB1202AITask.ReadRawData | ( | ref short[] | buf,
 |  | int | timeout = -1 )

Read the one channel raw data and store it in a data buffer.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ RemoveChannel()

void JYUSB1202.JYUSB1202AITask.RemoveChannel ( int chnId )

Delete the specified channel number.

If it is -1, delete all channels.

Parameters
chnId Specified channel ID.

◆ SendSoftwareTrigger()

void JYUSB1202.JYUSB1202AITask.SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JYUSB1202.JYUSB1202AITask.Start ( )

Start AI task .

◆ Stop()

void JYUSB1202.JYUSB1202AITask.Stop ( )

Stop AI task .

◆ WaitUntilDone()

bool JYUSB1202.JYUSB1202AITask.WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

Member Data Documentation

◆ MaxSampleRate

double JYUSB1202.JYUSB1202AITask.MaxSampleRate

Property Documentation

◆ AvailableSamples

ulong JYUSB1202.JYUSB1202AITask.AvailableSamples
get

Number of samples per channel that can be read in the buffer .

Valid when Mode is NOT AIMode.Single.

◆ BufLenInSamples

int JYUSB1202.JYUSB1202AITask.BufLenInSamples
get

Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.

◆ Channels

List<AIChannel> JYUSB1202.JYUSB1202AITask.Channels
get

List of AI channels,(1202 support 4 channel).

◆ Device

JYUSB1202Device JYUSB1202.JYUSB1202AITask.Device
get

Device.

◆ FDAMode

AIFDAMODE JYUSB1202.JYUSB1202AITask.FDAMode
getset

◆ FilterType

AIFilterType JYUSB1202.JYUSB1202AITask.FilterType
getset

◆ Mode

AIMode JYUSB1202.JYUSB1202AITask.Mode
getset

AI acquisition mode，support Single/Finite/Continuous/Record.

◆ Record

AIRecord JYUSB1202.JYUSB1202AITask.Record = new AIRecord()
get

ai Data streaming Configuration

◆ SampleClock

AISampleClock JYUSB1202.JYUSB1202AITask.SampleClock
getset

AI Sample Clock Configuration.

◆ SampleRate

double JYUSB1202.JYUSB1202AITask.SampleRate
getset

Sample rate per channel.

Maximum sample rate is 250K for single channel, 250K/N for multichannel (N) The defalut sample rate = 10k You can read this property to obtain the sample rate that will actually take effect in the current configuration.

◆ SamplesToAcquire

int JYUSB1202.JYUSB1202AITask.SamplesToAcquire
getset

Number of samples to be read per channel.

Only valid when Mode is AIMode.Finite.

◆ SignalExport

AISignalExport JYUSB1202.JYUSB1202AITask.SignalExport
getset

Export AI Signal Configuration.

◆ TransferedSamples

ulong JYUSB1202.JYUSB1202AITask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT AIMode.Single.

◆ Trigger

AITrigger JYUSB1202.JYUSB1202AITask.Trigger
getset

AI Trigger Configuration.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/1202/C#/JYUSB1202AITask.cs


USB-1202 C# Programming Manual: Member List

  • JYUSB1202AITask
JYUSB1202.JYUSB1202AITask Member List

This is the complete list of members for JYUSB1202.JYUSB1202AITask, including all inherited members.

AddChannel(int chnId, double rangeLow=-12, double rangeHigh=12, AITerminal terminalCfg=AITerminal.Differential, AICoupling couplingCfg=AICoupling.DC, bool enableIEPE=false) | JYUSB1202.JYUSB1202AITask
AddChannel(int[] chnsId, double rangeLow=-12, double rangeHigh=12, AITerminal terminalCfg=AITerminal.Differential, AICoupling couplingCfg=AICoupling.DC, bool enableIEPE=false) | JYUSB1202.JYUSB1202AITask
AddChannel(int[] chnsId, double[] rangeLow, double[] rangeHigh, AITerminal[] terminalCfg, AICoupling[] couplingCfg, bool[] enableIEPE) | JYUSB1202.JYUSB1202AITask
AvailableSamples | JYUSB1202.JYUSB1202AITask
BufLenInSamples | JYUSB1202.JYUSB1202AITask
Channels | JYUSB1202.JYUSB1202AITask
Device | JYUSB1202.JYUSB1202AITask
FDAMode | JYUSB1202.JYUSB1202AITask
FilterType | JYUSB1202.JYUSB1202AITask
GetRecordPreviewData(ref double[,] buf, int samplesPerChannel, int timeout) | JYUSB1202.JYUSB1202AITask
GetRecordPreviewData(ref double[,] buf, int timeout=-1) | JYUSB1202.JYUSB1202AITask
GetRecordPreviewData(ref double[] buf, int samplesPerChannel, int timeout) | JYUSB1202.JYUSB1202AITask
GetRecordPreviewData(ref double[] buf, int timeout=-1) | JYUSB1202.JYUSB1202AITask
GetRecordStatus(out double recordedLength, out bool recordDone) | JYUSB1202.JYUSB1202AITask
GetScalingCoefficients() | JYUSB1202.JYUSB1202AITask
JYUSB1202AITask(int slotNumber) | JYUSB1202.JYUSB1202AITask
JYUSB1202AITask(string boardName) | JYUSB1202.JYUSB1202AITask
MaxSampleRate | JYUSB1202.JYUSB1202AITask
Mode | JYUSB1202.JYUSB1202AITask
ReadData(IntPtr buf, int samplesPerChannel, int timeout) | JYUSB1202.JYUSB1202AITask
ReadData(ref double[,] buf, int samplesPerChannel, int timeout) | JYUSB1202.JYUSB1202AITask
ReadData(ref double[,] buf, int timeout=-1) | JYUSB1202.JYUSB1202AITask
ReadData(ref double[] buf, int samplesPerChannel, int timeout) | JYUSB1202.JYUSB1202AITask
ReadData(ref double[] buf, int timeout=-1) | JYUSB1202.JYUSB1202AITask
ReadRawData(IntPtr buf, int samplesPerChannel, int timeout) | JYUSB1202.JYUSB1202AITask
ReadRawData(ref short[,] buf, int samplesPerChannel, int timeout) | JYUSB1202.JYUSB1202AITask
ReadRawData(ref short[,] buf, int timeout=-1) | JYUSB1202.JYUSB1202AITask
ReadRawData(ref short[] buf, int samplesPerChannel, int timeout) | JYUSB1202.JYUSB1202AITask
ReadRawData(ref short[] buf, int timeout=-1) | JYUSB1202.JYUSB1202AITask
Record | JYUSB1202.JYUSB1202AITask
RemoveChannel(int chnId) | JYUSB1202.JYUSB1202AITask
SampleClock | JYUSB1202.JYUSB1202AITask
SampleRate | JYUSB1202.JYUSB1202AITask
SamplesToAcquire | JYUSB1202.JYUSB1202AITask
SendSoftwareTrigger() | JYUSB1202.JYUSB1202AITask
SignalExport | JYUSB1202.JYUSB1202AITask
Start() | JYUSB1202.JYUSB1202AITask
Stop() | JYUSB1202.JYUSB1202AITask
TransferedSamples | JYUSB1202.JYUSB1202AITask
Trigger | JYUSB1202.JYUSB1202AITask
WaitUntilDone(int timeout=-1) | JYUSB1202.JYUSB1202AITask


USB-1202 C# Programming Manual: JYUSB1202.JYUSB1202CITask Class Reference

  • JYUSB1202CITask
Public Member Functions | Properties | List of all members
JYUSB1202.JYUSB1202CITask Class Referencesealed

JYUSB1202 Counter Input Task. More...

Public Member Functions

JYUSB1202CITask ()
Constructor.
JYUSB1202CITask (string boardName)
Constructor.
void | Start ()
Start CI task .
void | Stop ()
Stop CI task .
void | ReadSinglePoint (ref uint count)
Read a signle count value from register, Available when Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder.
void | ReadSinglePoint (ref double measurement, int timeout=10000)
Read a signle frequency value or period value from register.
void | ReadSinglePoint (ref double measurement1, ref double measurement2, int timeout=10000)
Read a signle measurement of pulse's duration value, or two-edge separtion value (two results at a time) from register.

Properties

CIType | Type [get, set]
CI Application types.
EdgeCounting | EdgeCounting [get, set]
Edge Counting Configuration.
FrequencyMeas | FrequencyMeas [get, set]
Frequency Measurement Configuration.
PeriodMeas | PeriodMeas [get, set]
Period Measurement Configuration.
PulseMeas | PulseMeas [get, set]
Pulse Measurement Configuration.
TwoEdgeSeparation | TwoEdgeSeparation [get, set]
TwoEdgeSeparation.
QuadEncoder | QuadEncoder [get, set]
QuadEncoder.
JYUSB1202Device | Device [get]
Device.

Detailed Description

JYUSB1202 Counter Input Task.

Constructor & Destructor Documentation

◆ JYUSB1202CITask() [1/2]

JYUSB1202.JYUSB1202CITask.JYUSB1202CITask ( )

Constructor.

Used to create an CI task by a slot number.

Parameters
channel Counter channel suppor0-1

◆ JYUSB1202CITask() [2/2]

JYUSB1202.JYUSB1202CITask.JYUSB1202CITask ( string boardName )

Constructor.

Used to create an m task by a board name.

Parameters
boardName | Board name(device alias), set by device manager
channel | Counter channel （5112 support0-1）.

Member Function Documentation

◆ ReadSinglePoint() [1/3]

void JYUSB1202.JYUSB1202CITask.ReadSinglePoint | ( | ref double | measurement,
 |  | int | timeout = 10000 )

Read a signle frequency value or period value from register.

Valid when Type is CIType.Frequency or CIType.Period.

Parameters
measurement Measurement value. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period is seconds when Type is CIType.Period.
timeout
Timeout (ms). Wait until the measurement is completed or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [2/3]

void JYUSB1202.JYUSB1202CITask.ReadSinglePoint | ( | ref double | measurement1,
 |  | ref double | measurement2,
 |  | int | timeout = 10000 )

Read a signle measurement of pulse's duration value, or two-edge separtion value (two results at a time) from register.

Available when Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
measurement1 | Measurement Value 1. Indicates low level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
measurement2 | Measurement Value 2. Indicates high level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
timeout
Timeout (ms). Wait until the measurement is completed or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [3/3]

void JYUSB1202.JYUSB1202CITask.ReadSinglePoint ( ref uint count )

Read a signle count value from register, Available when Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder.

Parameters
count counter value。

◆ Start()

void JYUSB1202.JYUSB1202CITask.Start ( )

Start CI task .

◆ Stop()

void JYUSB1202.JYUSB1202CITask.Stop ( )

Stop CI task .

Property Documentation

◆ Device

JYUSB1202Device JYUSB1202.JYUSB1202CITask.Device
get

Device.

◆ EdgeCounting

EdgeCounting JYUSB1202.JYUSB1202CITask.EdgeCounting
getset

Edge Counting Configuration.

◆ FrequencyMeas

FrequencyMeas JYUSB1202.JYUSB1202CITask.FrequencyMeas
getset

Frequency Measurement Configuration.

◆ PeriodMeas

PeriodMeas JYUSB1202.JYUSB1202CITask.PeriodMeas
getset

Period Measurement Configuration.

◆ PulseMeas

PulseMeas JYUSB1202.JYUSB1202CITask.PulseMeas
getset

Pulse Measurement Configuration.

◆ QuadEncoder

QuadEncoder JYUSB1202.JYUSB1202CITask.QuadEncoder
getset

QuadEncoder.

◆ TwoEdgeSeparation

TwoEdgeSeparation JYUSB1202.JYUSB1202CITask.TwoEdgeSeparation
getset

TwoEdgeSeparation.

◆ Type

CIType JYUSB1202.JYUSB1202CITask.Type
getset

CI Application types.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/1202/C#/JYUSB1202CITask.cs


USB-1202 C# Programming Manual: Member List

  • JYUSB1202CITask
JYUSB1202.JYUSB1202CITask Member List

This is the complete list of members for JYUSB1202.JYUSB1202CITask, including all inherited members.

Device | JYUSB1202.JYUSB1202CITask
EdgeCounting | JYUSB1202.JYUSB1202CITask
FrequencyMeas | JYUSB1202.JYUSB1202CITask
JYUSB1202CITask() | JYUSB1202.JYUSB1202CITask
JYUSB1202CITask(string boardName) | JYUSB1202.JYUSB1202CITask
PeriodMeas | JYUSB1202.JYUSB1202CITask
PulseMeas | JYUSB1202.JYUSB1202CITask
QuadEncoder | JYUSB1202.JYUSB1202CITask
ReadSinglePoint(ref uint count) | JYUSB1202.JYUSB1202CITask
ReadSinglePoint(ref double measurement, int timeout=10000) | JYUSB1202.JYUSB1202CITask
ReadSinglePoint(ref double measurement1, ref double measurement2, int timeout=10000) | JYUSB1202.JYUSB1202CITask
Start() | JYUSB1202.JYUSB1202CITask
Stop() | JYUSB1202.JYUSB1202CITask
TwoEdgeSeparation | JYUSB1202.JYUSB1202CITask
Type | JYUSB1202.JYUSB1202CITask


USB-1202 C# Programming Manual: JYUSB1202.JYUSB1202COTask Class Reference

  • JYUSB1202COTask
Public Member Functions | Properties | List of all members
JYUSB1202.JYUSB1202COTask Class Referencesealed

JYUSB1202 Counter Output Task. More...

Public Member Functions

JYUSB1202COTask ()
Constructor.
JYUSB1202COTask (string boardName)
Constructor.
void | WriteSinglePoint (COPulse pulse)
Write a single pulse parameter to the register.
void | Start ()
Start CO task .
void | Stop ()
Stop COtask .
bool | WaitUntilDone (int timeout=10000)
Waiting until current task to complete.

Properties

PauseTrigger | Pause [get, set]
COIdleState | IdleState [get, set]
Idle state when pulse output before start and after stop.
JYUSB1202Device | Device [get]
Device.

Detailed Description

JYUSB1202 Counter Output Task.

Constructor & Destructor Documentation

◆ JYUSB1202COTask() [1/2]

JYUSB1202.JYUSB1202COTask.JYUSB1202COTask ( )

Constructor.

Used to create an CO task by a slot number.

Parameters
channel Counter channel （1202 support0-1）.

◆ JYUSB1202COTask() [2/2]

JYUSB1202.JYUSB1202COTask.JYUSB1202COTask ( string boardName )

Constructor.

Used to create an CO task by a board name.

Parameters
boardName | Board name(device alias), set by device manager
channel | Counter channel （5112 support0-1）.

Member Function Documentation

◆ Start()

void JYUSB1202.JYUSB1202COTask.Start ( )

Start CO task .

◆ Stop()

void JYUSB1202.JYUSB1202COTask.Stop ( )

Stop COtask .

◆ WaitUntilDone()

bool JYUSB1202.JYUSB1202COTask.WaitUntilDone ( int timeout = 10000 )

Waiting until current task to complete.

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteSinglePoint()

void JYUSB1202.JYUSB1202COTask.WriteSinglePoint ( COPulse pulse )

Write a single pulse parameter to the register.

This function is also available after starting the task when the number of pulses being sent is infinite.

Parameters
pulse Pulse Parameter

Property Documentation

◆ Device

JYUSB1202Device JYUSB1202.JYUSB1202COTask.Device
get

Device.

◆ IdleState

COIdleState JYUSB1202.JYUSB1202COTask.IdleState
getset

Idle state when pulse output before start and after stop.

◆ Pause

PauseTrigger JYUSB1202.JYUSB1202COTask.Pause
getset

暂停触发配置

Pause Trigger Configuration

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/1202/C#/JYUSB1202COTask.cs


USB-1202 C# Programming Manual: Member List

  • JYUSB1202COTask
JYUSB1202.JYUSB1202COTask Member List

This is the complete list of members for JYUSB1202.JYUSB1202COTask, including all inherited members.

Device | JYUSB1202.JYUSB1202COTask
IdleState | JYUSB1202.JYUSB1202COTask
JYUSB1202COTask() | JYUSB1202.JYUSB1202COTask
JYUSB1202COTask(string boardName) | JYUSB1202.JYUSB1202COTask
Pause | JYUSB1202.JYUSB1202COTask
Start() | JYUSB1202.JYUSB1202COTask
Stop() | JYUSB1202.JYUSB1202COTask
WaitUntilDone(int timeout=10000) | JYUSB1202.JYUSB1202COTask
WriteSinglePoint(COPulse pulse) | JYUSB1202.JYUSB1202COTask


USB-1202 C# Programming Manual: JYUSB1202.JYUSB1202DITask Class Reference

  • JYUSB1202DITask
Public Member Functions | Properties | List of all members
JYUSB1202.JYUSB1202DITask Class Referencesealed

JYUSB1202 Digital Iuput Task. More...

Public Member Functions

JYUSB1202DITask ()
Constructor.
JYUSB1202DITask (string boardName)
Constructor.
void | AddChannel (int lineNum)
Add one channel.
void | AddChannel (int[] linesNum)
Add a group of channel.
void | RemoveChannel (int lineNum)
Delete the specified line number .If it is -1, delete all lines.
void | Start ()
Start DI task .
void | Stop ()
Stop DI task .
void | ReadSinglePoint (ref bool readValue, int line)
Read one sample for specified line in register.
void | ReadSinglePoint (ref bool[] readValues)
Read one sample for all lines in register.

Properties

List< DIChannel > | Channels [get]
List of DI channels,(1202 support 8 lines).
JYUSB1202Device | Device [get]
Device.

Detailed Description

JYUSB1202 Digital Iuput Task.

Constructor & Destructor Documentation

◆ JYUSB1202DITask() [1/2]

JYUSB1202.JYUSB1202DITask.JYUSB1202DITask ( )

Constructor.

Used to create an DItask by a slot number.

◆ JYUSB1202DITask() [2/2]

JYUSB1202.JYUSB1202DITask.JYUSB1202DITask ( string boardName )

Constructor.

Used to create an DI task by a board name.

Parameters
boardName Board name(device alias), set by device manager

Member Function Documentation

◆ AddChannel() [1/2]

void JYUSB1202.JYUSB1202DITask.AddChannel ( int lineNum )

Add one channel.

Parameters
lineNum line number to be added.

◆ AddChannel() [2/2]

void JYUSB1202.JYUSB1202DITask.AddChannel ( int[] linesNum )

Add a group of channel.

Parameters
linesNum an array of line numbers of added lines.

◆ ReadSinglePoint() [1/2]

void JYUSB1202.JYUSB1202DITask.ReadSinglePoint | ( | ref bool | readValue,
 |  | int | line )

Read one sample for specified line in register.

Parameters
readValue | values read.
line | Specified line number.

◆ ReadSinglePoint() [2/2]

void JYUSB1202.JYUSB1202DITask.ReadSinglePoint ( ref bool[] readValues )

Read one sample for all lines in register.

Parameters
readValues Values read. Buffer size >= number of lines.

◆ RemoveChannel()

void JYUSB1202.JYUSB1202DITask.RemoveChannel ( int lineNum )

Delete the specified line number .If it is -1, delete all lines.

Parameters
lineNum port number to be delete.

◆ Start()

void JYUSB1202.JYUSB1202DITask.Start ( )

Start DI task .

◆ Stop()

void JYUSB1202.JYUSB1202DITask.Stop ( )

Stop DI task .

Property Documentation

◆ Channels

List<DIChannel> JYUSB1202.JYUSB1202DITask.Channels
get

List of DI channels,(1202 support 8 lines).

◆ Device

JYUSB1202Device JYUSB1202.JYUSB1202DITask.Device
get

Device.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/1202/C#/JYUSB1202DITask.cs


USB-1202 C# Programming Manual: Member List

  • JYUSB1202DITask
JYUSB1202.JYUSB1202DITask Member List

This is the complete list of members for JYUSB1202.JYUSB1202DITask, including all inherited members.

AddChannel(int lineNum) | JYUSB1202.JYUSB1202DITask
AddChannel(int[] linesNum) | JYUSB1202.JYUSB1202DITask
Channels | JYUSB1202.JYUSB1202DITask
Device | JYUSB1202.JYUSB1202DITask
JYUSB1202DITask() | JYUSB1202.JYUSB1202DITask
JYUSB1202DITask(string boardName) | JYUSB1202.JYUSB1202DITask
ReadSinglePoint(ref bool readValue, int line) | JYUSB1202.JYUSB1202DITask
ReadSinglePoint(ref bool[] readValues) | JYUSB1202.JYUSB1202DITask
RemoveChannel(int lineNum) | JYUSB1202.JYUSB1202DITask
Start() | JYUSB1202.JYUSB1202DITask
Stop() | JYUSB1202.JYUSB1202DITask


USB-1202 C# Programming Manual: JYUSB1202.JYUSB1202DOTask Class Reference

  • JYUSB1202DOTask
Public Member Functions | Properties | List of all members
JYUSB1202.JYUSB1202DOTask Class Referencesealed

JYUSB1202 Digital Output Task. More...

Public Member Functions

JYUSB1202DOTask ()
Constructor.
JYUSB1202DOTask (string boardName)
Constructor.
void | AddChannel (int lineNum)
Add one channel.
void | AddChannel (int[] linesNum)
Add a group of channels.
void | RemoveChannel (int lineNum)
Delete the specified line number .If it is -1, delete all lines.
void | Start ()
Start DO task .
void | Stop ()
Stop DO task .
void | WriteSinglePoint (bool writeValue, int line)
Write one sample to the specified line in register.
void | WriteSinglePoint (bool[] writeValues)
write one sample to all lines in register .

Properties

List< DOChannel > | Channels [get]
List of DO channels,(1202 support 8 lines).
JYUSB1202Device | Device [get]
Device.

Detailed Description

JYUSB1202 Digital Output Task.

Constructor & Destructor Documentation

◆ JYUSB1202DOTask() [1/2]

JYUSB1202.JYUSB1202DOTask.JYUSB1202DOTask ( )

Constructor.

Used to create an DOtask by a slot number.

◆ JYUSB1202DOTask() [2/2]

JYUSB1202.JYUSB1202DOTask.JYUSB1202DOTask ( string boardName )

Constructor.

Used to create an DO task by a board name.

Parameters
boardName Board name(device alias), set by device manager

Member Function Documentation

◆ AddChannel() [1/2]

void JYUSB1202.JYUSB1202DOTask.AddChannel ( int lineNum )

Add one channel.

Parameters
lineNum line number to be added.

◆ AddChannel() [2/2]

void JYUSB1202.JYUSB1202DOTask.AddChannel ( int[] linesNum )

Add a group of channels.

Parameters
linesNum an array of line numbers of added lines.

◆ RemoveChannel()

void JYUSB1202.JYUSB1202DOTask.RemoveChannel ( int lineNum )

Delete the specified line number .If it is -1, delete all lines.

Parameters
lineNum line number to be delete.

◆ Start()

void JYUSB1202.JYUSB1202DOTask.Start ( )

Start DO task .

◆ Stop()

void JYUSB1202.JYUSB1202DOTask.Stop ( )

Stop DO task .

◆ WriteSinglePoint() [1/2]

void JYUSB1202.JYUSB1202DOTask.WriteSinglePoint | ( | bool | writeValue,
 |  | int | line )

Write one sample to the specified line in register.

Parameters
writeValue | Write values.
line | Specified line.

◆ WriteSinglePoint() [2/2]

void JYUSB1202.JYUSB1202DOTask.WriteSinglePoint ( bool[] writeValues )

write one sample to all lines in register .

Parameters
writeValues Data to be written.Buffer size >= number of lines。

Property Documentation

◆ Channels

List<DOChannel> JYUSB1202.JYUSB1202DOTask.Channels
get

List of DO channels,(1202 support 8 lines).

◆ Device

JYUSB1202Device JYUSB1202.JYUSB1202DOTask.Device
get

Device.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/1202/C#/JYUSB1202DOTask.cs


USB-1202 C# Programming Manual: Member List

  • JYUSB1202DOTask
JYUSB1202.JYUSB1202DOTask Member List

This is the complete list of members for JYUSB1202.JYUSB1202DOTask, including all inherited members.

AddChannel(int lineNum) | JYUSB1202.JYUSB1202DOTask
AddChannel(int[] linesNum) | JYUSB1202.JYUSB1202DOTask
Channels | JYUSB1202.JYUSB1202DOTask
Device | JYUSB1202.JYUSB1202DOTask
JYUSB1202DOTask() | JYUSB1202.JYUSB1202DOTask
JYUSB1202DOTask(string boardName) | JYUSB1202.JYUSB1202DOTask
RemoveChannel(int lineNum) | JYUSB1202.JYUSB1202DOTask
Start() | JYUSB1202.JYUSB1202DOTask
Stop() | JYUSB1202.JYUSB1202DOTask
WriteSinglePoint(bool writeValue, int line) | JYUSB1202.JYUSB1202DOTask
WriteSinglePoint(bool[] writeValues) | JYUSB1202.JYUSB1202DOTask


USB-1202 C# Programming Manual: JYUSB1202.PauseTrigger Class Reference

  • PauseTrigger
Properties | List of all members
JYUSB1202.PauseTrigger Class Referencesealed

Pause trigger configuration class. More...

Properties

LevelPolarity ActivePolarity [get, set]
Pause trigger active polarity.

Detailed Description

Pause trigger configuration class.

Property Documentation

◆ ActivePolarity

LevelPolarity JYUSB1202.PauseTrigger.ActivePolarity
getset

Pause trigger active polarity.

The default value is LevelPolarity.None, means the pause trigger is disabled.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/1202/C#/JYUSB1202CITask.cs


USB-1202 C# Programming Manual: Member List

  • PauseTrigger
JYUSB1202.PauseTrigger Member List

This is the complete list of members for JYUSB1202.PauseTrigger, including all inherited members.

ActivePolarity JYUSB1202.PauseTrigger


USB-1202 C# Programming Manual: JYUSB1202.PeriodMeas Class Reference

  • PeriodMeas
List of all members
JYUSB1202.PeriodMeas Class Referencesealed

Configure CI Measure. More...

Detailed Description

Configure CI Measure.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/1202/C#/JYUSB1202CITask.cs


USB-1202 C# Programming Manual: Member List

  • PeriodMeas
JYUSB1202.PeriodMeas Member List

This is the complete list of members for JYUSB1202.PeriodMeas, including all inherited members.


USB-1202 C# Programming Manual: JYUSB1202.PulseMeas Class Reference

  • PulseMeas
List of all members
JYUSB1202.PulseMeas Class Referencesealed

Configure CI Measure. More...

Detailed Description

Configure CI Measure.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/1202/C#/JYUSB1202CITask.cs


USB-1202 C# Programming Manual: Member List

  • PulseMeas
JYUSB1202.PulseMeas Member List

This is the complete list of members for JYUSB1202.PulseMeas, including all inherited members.


USB-1202 C# Programming Manual: JYUSB1202.QuadEncoder Class Reference

  • QuadEncoder
Properties | List of all members
JYUSB1202.QuadEncoder Class Referencesealed

Configure CI Measure. More...

Properties

QuadEncodingType | EncodingType [get, set]
Type of Encoding.
bool | ZReloadEnabled [get, set]
In Encoder mode ,the Z signal enable.
int | InitialCount [get, set]
Initial Count.

Detailed Description

Configure CI Measure.

Property Documentation

◆ EncodingType

QuadEncodingType JYUSB1202.QuadEncoder.EncodingType
getset

Type of Encoding.

◆ InitialCount

int JYUSB1202.QuadEncoder.InitialCount
getset

Initial Count.

◆ ZReloadEnabled

bool JYUSB1202.QuadEncoder.ZReloadEnabled
getset

In Encoder mode ,the Z signal enable.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/1202/C#/JYUSB1202CITask.cs


USB-1202 C# Programming Manual: Member List

  • QuadEncoder
JYUSB1202.QuadEncoder Member List

This is the complete list of members for JYUSB1202.QuadEncoder, including all inherited members.

EncodingType | JYUSB1202.QuadEncoder
InitialCount | JYUSB1202.QuadEncoder
ZReloadEnabled | JYUSB1202.QuadEncoder


USB-1202 C# Programming Manual: JYUSB1202.TwoEdgeSeparation Class Reference

  • TwoEdgeSeparation
List of all members
JYUSB1202.TwoEdgeSeparation Class Referencesealed

Configure CI Measure. More...

Detailed Description

Configure CI Measure.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/1202/C#/JYUSB1202CITask.cs


USB-1202 C# Programming Manual: Member List

  • TwoEdgeSeparation
JYUSB1202.TwoEdgeSeparation Member List

This is the complete list of members for JYUSB1202.TwoEdgeSeparation, including all inherited members.


USB-1202 C# Programming Manual: JYUSB1202.TwoPulseEncoder Class Reference

  • TwoPulseEncoder
Properties | List of all members
JYUSB1202.TwoPulseEncoder Class Referencesealed

Configure CI Measure. More...

Properties

int InitialCount [get, set]
Initial Count.

Detailed Description

Configure CI Measure.

Property Documentation

◆ InitialCount

int JYUSB1202.TwoPulseEncoder.InitialCount
getset

Initial Count.

The documentation for this class was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/1202/C#/JYUSB1202CITask.cs


USB-1202 C# Programming Manual: Member List

  • TwoPulseEncoder
JYUSB1202.TwoPulseEncoder Member List

This is the complete list of members for JYUSB1202.TwoPulseEncoder, including all inherited members.

InitialCount JYUSB1202.TwoPulseEncoder


USB-1202 C# Programming Manual: Class Index

Class Index
A | C | D | E | F | J | P | Q | S | T
A
AIChannel (JYUSB1202)
AIDigitalTrigger (JYUSB1202)
AIExternalSampleClock (JYUSB1202)
AIRecord (JYUSB1202)
AISampleClock (JYUSB1202)
AISignalExport (JYUSB1202)
AITrigger (JYUSB1202)
C
COPulse (JYUSB1202)
D
DIChannel (JYUSB1202)
DOChannel (JYUSB1202)
E
EdgeCounting (JYUSB1202)
EdgeCountingOutEvent (JYUSB1202)
F
FrequencyMeas (JYUSB1202)
J
JYUSB1202AITask (JYUSB1202)
JYUSB1202CITask (JYUSB1202)
JYUSB1202COTask (JYUSB1202)
JYUSB1202DITask (JYUSB1202)
JYUSB1202DOTask (JYUSB1202)
P
PauseTrigger (JYUSB1202)
PeriodMeas (JYUSB1202)
PulseMeas (JYUSB1202)
Q
QuadEncoder (JYUSB1202)
S
ScalingCoefficients
T
TwoEdgeSeparation (JYUSB1202)
TwoPulseEncoder (JYUSB1202)


USB-1202 C# Programming Manual: D:/OneDrive/Desktop/产品文档/CHM/1202/C# Directory Reference

C# Directory Reference

Files

         JYUSB1202AITask.cs
JYUSB1202CITask.cs
JYUSB1202COTask.cs
JYUSB1202DITask.cs
JYUSB1202DOTask.cs


USB-1202 C# Programming Manual: D:/OneDrive/Desktop/产品文档/CHM/1202 Directory Reference

  • File List
  • File Members
  • OneDrive
  • Desktop
  • 产品文档
  • CHM
  • 1202
1202 Directory Reference

Directories

         C#
C++


USB-1202 C# Programming Manual: D:/OneDrive/Desktop/产品文档/CHM Directory Reference

  • File List
  • File Members
  • OneDrive
  • Desktop
  • 产品文档
  • CHM
CHM Directory Reference

Directories

         1202


USB-1202 C# Programming Manual: D:/OneDrive/Desktop Directory Reference

  • File List
  • File Members
  • OneDrive
  • Desktop
Desktop Directory Reference

Directories

         产品文档


USB-1202 C# Programming Manual: D:/OneDrive/Desktop/产品文档 Directory Reference

  • File List
  • File Members
  • OneDrive
  • Desktop
  • 产品文档
产品文档 Directory Reference

Directories

         CHM


USB-1202 C# Programming Manual: D:/OneDrive Directory Reference

  • File List
  • File Members
  • OneDrive
OneDrive Directory Reference

Directories

         Desktop


USB-1202 C# Programming Manual: D:/OneDrive/Desktop/产品文档/CHM/1202/C++ Directory Reference

  • File List
  • File Members
  • OneDrive
  • Desktop
  • 产品文档
  • CHM
  • 1202
  • C++
C++ Directory Reference

Files

         JYUSB1202Core.h


USB-1202 C# Programming Manual: File List

  • File List
  • File Members
File List
Here is a list of all files with brief descriptions:
[detail level 1234567]
 OneDrive
Desktop
产品文档
CHM
1202
C#
JYUSB1202AITask.cs
JYUSB1202CITask.cs
JYUSB1202COTask.cs
JYUSB1202DITask.cs
JYUSB1202DOTask.cs
C++
JYUSB1202Core.h


USB-1202 C# Programming Manual: Class Members

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • j
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • w
  • z
Here is a list of all class members with links to the classes they belong to:

- a -

  • ActivePolarity : JYUSB1202.PauseTrigger
  • Add() : JYUSB1202.AISignalExport
  • AddChannel() : JYUSB1202.JYUSB1202AITask, JYUSB1202.JYUSB1202DITask, JYUSB1202.JYUSB1202DOTask
  • AIChannel() : JYUSB1202.AIChannel
  • AvailableSamples : JYUSB1202.JYUSB1202AITask

- b -

  • BufLenInSamples : JYUSB1202.JYUSB1202AITask

- c -

  • ChannelID : JYUSB1202.AIChannel
  • Channels : JYUSB1202.JYUSB1202AITask, JYUSB1202.JYUSB1202DITask, JYUSB1202.JYUSB1202DOTask
  • Clear() : JYUSB1202.AISignalExport
  • ClearAll() : JYUSB1202.AISignalExport
  • COPulse() : JYUSB1202.COPulse
  • Coupling : JYUSB1202.AIChannel

- d -

  • Device : JYUSB1202.JYUSB1202AITask, JYUSB1202.JYUSB1202CITask, JYUSB1202.JYUSB1202COTask, JYUSB1202.JYUSB1202DITask, JYUSB1202.JYUSB1202DOTask
  • Digital : JYUSB1202.AITrigger
  • Direction : JYUSB1202.EdgeCounting

- e -

  • Edge : JYUSB1202.AIDigitalTrigger
  • EdgeCounting : JYUSB1202.JYUSB1202CITask
  • EnableIEPE : JYUSB1202.AIChannel
  • EncodingType : JYUSB1202.QuadEncoder
  • ExpectedRate : JYUSB1202.AIExternalSampleClock
  • External : JYUSB1202.AISampleClock

- f -

  • FDAMode : JYUSB1202.JYUSB1202AITask
  • FileFormat : JYUSB1202.AIRecord
  • FilePath : JYUSB1202.AIRecord
  • FilterType : JYUSB1202.JYUSB1202AITask
  • FrequencyMeas : JYUSB1202.JYUSB1202CITask

- g -

  • Gain : ScalingCoefficients
  • GetRecordPreviewData() : JYUSB1202.JYUSB1202AITask
  • GetRecordStatus() : JYUSB1202.JYUSB1202AITask
  • GetScalingCoefficients() : JYUSB1202.JYUSB1202AITask

- i -

  • IdleState : JYUSB1202.EdgeCountingOutEvent, JYUSB1202.JYUSB1202COTask
  • InitialCount : JYUSB1202.EdgeCounting, JYUSB1202.QuadEncoder, JYUSB1202.TwoPulseEncoder

- j -

  • JYUSB1202AITask() : JYUSB1202.JYUSB1202AITask
  • JYUSB1202CITask() : JYUSB1202.JYUSB1202CITask
  • JYUSB1202COTask() : JYUSB1202.JYUSB1202COTask
  • JYUSB1202DITask() : JYUSB1202.JYUSB1202DITask
  • JYUSB1202DOTask() : JYUSB1202.JYUSB1202DOTask

- l -

  • Length : JYUSB1202.AIRecord
  • LineNum : JYUSB1202.DIChannel, JYUSB1202.DOChannel

- m -

  • MaxSampleRate : JYUSB1202.JYUSB1202AITask
  • Mode : JYUSB1202.AIRecord, JYUSB1202.JYUSB1202AITask

- o -

  • Offset : ScalingCoefficients
  • OutEvent : JYUSB1202.EdgeCounting

- p -

  • Pause : JYUSB1202.EdgeCounting, JYUSB1202.JYUSB1202COTask
  • PeriodMeas : JYUSB1202.JYUSB1202CITask
  • PulseMeas : JYUSB1202.JYUSB1202CITask

- q -

  • QuadEncoder : JYUSB1202.JYUSB1202CITask

- r -

  • RangeHigh : JYUSB1202.AIChannel
  • RangeLow : JYUSB1202.AIChannel
  • ReadData() : JYUSB1202.JYUSB1202AITask
  • ReadRawData() : JYUSB1202.JYUSB1202AITask
  • ReadSinglePoint() : JYUSB1202.JYUSB1202CITask, JYUSB1202.JYUSB1202DITask
  • Record : JYUSB1202.JYUSB1202AITask
  • RemoveChannel() : JYUSB1202.JYUSB1202AITask, JYUSB1202.JYUSB1202DITask, JYUSB1202.JYUSB1202DOTask

- s -

  • SampleClock : JYUSB1202.JYUSB1202AITask
  • SampleRate : JYUSB1202.JYUSB1202AITask
  • SamplesToAcquire : JYUSB1202.JYUSB1202AITask
  • SendSoftwareTrigger() : JYUSB1202.JYUSB1202AITask
  • SignalExport : JYUSB1202.JYUSB1202AITask
  • Source : JYUSB1202.AIDigitalTrigger, JYUSB1202.AISampleClock
  • Start() : JYUSB1202.JYUSB1202AITask, JYUSB1202.JYUSB1202CITask, JYUSB1202.JYUSB1202COTask, JYUSB1202.JYUSB1202DITask, JYUSB1202.JYUSB1202DOTask
  • Stop() : JYUSB1202.JYUSB1202AITask, JYUSB1202.JYUSB1202CITask, JYUSB1202.JYUSB1202COTask, JYUSB1202.JYUSB1202DITask, JYUSB1202.JYUSB1202DOTask

- t -

  • Terminal : JYUSB1202.AIChannel
  • Threshold : JYUSB1202.EdgeCountingOutEvent
  • TransferedSamples : JYUSB1202.JYUSB1202AITask
  • Trigger : JYUSB1202.JYUSB1202AITask
  • TwoEdgeSeparation : JYUSB1202.JYUSB1202CITask
  • Type : JYUSB1202.AITrigger, JYUSB1202.JYUSB1202CITask

- w -

  • WaitUntilDone() : JYUSB1202.JYUSB1202AITask, JYUSB1202.JYUSB1202COTask
  • WriteSinglePoint() : JYUSB1202.JYUSB1202COTask, JYUSB1202.JYUSB1202DOTask

- z -

  • ZReloadEnabled : JYUSB1202.QuadEncoder


USB-1202 C# Programming Manual: Class Members - Functions

  • All
  • Functions
  • Variables
  • Properties
  • a
  • c
  • g
  • j
  • r
  • s
  • w
Here is a list of all functions with links to the classes they belong to:

- a -

  • Add() : JYUSB1202.AISignalExport
  • AddChannel() : JYUSB1202.JYUSB1202AITask, JYUSB1202.JYUSB1202DITask, JYUSB1202.JYUSB1202DOTask
  • AIChannel() : JYUSB1202.AIChannel

- c -

  • Clear() : JYUSB1202.AISignalExport
  • ClearAll() : JYUSB1202.AISignalExport
  • COPulse() : JYUSB1202.COPulse

- g -

  • GetRecordPreviewData() : JYUSB1202.JYUSB1202AITask
  • GetRecordStatus() : JYUSB1202.JYUSB1202AITask
  • GetScalingCoefficients() : JYUSB1202.JYUSB1202AITask

- j -

  • JYUSB1202AITask() : JYUSB1202.JYUSB1202AITask
  • JYUSB1202CITask() : JYUSB1202.JYUSB1202CITask
  • JYUSB1202COTask() : JYUSB1202.JYUSB1202COTask
  • JYUSB1202DITask() : JYUSB1202.JYUSB1202DITask
  • JYUSB1202DOTask() : JYUSB1202.JYUSB1202DOTask

- r -

  • ReadData() : JYUSB1202.JYUSB1202AITask
  • ReadRawData() : JYUSB1202.JYUSB1202AITask
  • ReadSinglePoint() : JYUSB1202.JYUSB1202CITask, JYUSB1202.JYUSB1202DITask
  • RemoveChannel() : JYUSB1202.JYUSB1202AITask, JYUSB1202.JYUSB1202DITask, JYUSB1202.JYUSB1202DOTask

- s -

  • SendSoftwareTrigger() : JYUSB1202.JYUSB1202AITask
  • Start() : JYUSB1202.JYUSB1202AITask, JYUSB1202.JYUSB1202CITask, JYUSB1202.JYUSB1202COTask, JYUSB1202.JYUSB1202DITask, JYUSB1202.JYUSB1202DOTask
  • Stop() : JYUSB1202.JYUSB1202AITask, JYUSB1202.JYUSB1202CITask, JYUSB1202.JYUSB1202COTask, JYUSB1202.JYUSB1202DITask, JYUSB1202.JYUSB1202DOTask

- w -

  • WaitUntilDone() : JYUSB1202.JYUSB1202AITask, JYUSB1202.JYUSB1202COTask
  • WriteSinglePoint() : JYUSB1202.JYUSB1202COTask, JYUSB1202.JYUSB1202DOTask


USB-1202 C# Programming Manual: Class Members - Properties

  • All
  • Functions
  • Variables
  • Properties
  • a
  • b
  • c
  • d
  • e
  • f
  • i
  • l
  • m
  • o
  • p
  • q
  • r
  • s
  • t
  • z
Here is a list of all properties with links to the classes they belong to:

- a -

  • ActivePolarity : JYUSB1202.PauseTrigger
  • AvailableSamples : JYUSB1202.JYUSB1202AITask

- b -

  • BufLenInSamples : JYUSB1202.JYUSB1202AITask

- c -

  • ChannelID : JYUSB1202.AIChannel
  • Channels : JYUSB1202.JYUSB1202AITask, JYUSB1202.JYUSB1202DITask, JYUSB1202.JYUSB1202DOTask
  • Coupling : JYUSB1202.AIChannel

- d -

  • Device : JYUSB1202.JYUSB1202AITask, JYUSB1202.JYUSB1202CITask, JYUSB1202.JYUSB1202COTask, JYUSB1202.JYUSB1202DITask, JYUSB1202.JYUSB1202DOTask
  • Digital : JYUSB1202.AITrigger
  • Direction : JYUSB1202.EdgeCounting

- e -

  • Edge : JYUSB1202.AIDigitalTrigger
  • EdgeCounting : JYUSB1202.JYUSB1202CITask
  • EnableIEPE : JYUSB1202.AIChannel
  • EncodingType : JYUSB1202.QuadEncoder
  • ExpectedRate : JYUSB1202.AIExternalSampleClock
  • External : JYUSB1202.AISampleClock

- f -

  • FDAMode : JYUSB1202.JYUSB1202AITask
  • FileFormat : JYUSB1202.AIRecord
  • FilePath : JYUSB1202.AIRecord
  • FilterType : JYUSB1202.JYUSB1202AITask
  • FrequencyMeas : JYUSB1202.JYUSB1202CITask

- i -

  • IdleState : JYUSB1202.EdgeCountingOutEvent, JYUSB1202.JYUSB1202COTask
  • InitialCount : JYUSB1202.EdgeCounting, JYUSB1202.QuadEncoder, JYUSB1202.TwoPulseEncoder

- l -

  • Length : JYUSB1202.AIRecord
  • LineNum : JYUSB1202.DIChannel, JYUSB1202.DOChannel

- m -

  • Mode : JYUSB1202.AIRecord, JYUSB1202.JYUSB1202AITask

- o -

  • OutEvent : JYUSB1202.EdgeCounting

- p -

  • Pause : JYUSB1202.EdgeCounting, JYUSB1202.JYUSB1202COTask
  • PeriodMeas : JYUSB1202.JYUSB1202CITask
  • PulseMeas : JYUSB1202.JYUSB1202CITask

- q -

  • QuadEncoder : JYUSB1202.JYUSB1202CITask

- r -

  • RangeHigh : JYUSB1202.AIChannel
  • RangeLow : JYUSB1202.AIChannel
  • Record : JYUSB1202.JYUSB1202AITask

- s -

  • SampleClock : JYUSB1202.JYUSB1202AITask
  • SampleRate : JYUSB1202.JYUSB1202AITask
  • SamplesToAcquire : JYUSB1202.JYUSB1202AITask
  • SignalExport : JYUSB1202.JYUSB1202AITask
  • Source : JYUSB1202.AIDigitalTrigger, JYUSB1202.AISampleClock

- t -

  • Terminal : JYUSB1202.AIChannel
  • Threshold : JYUSB1202.EdgeCountingOutEvent
  • TransferedSamples : JYUSB1202.JYUSB1202AITask
  • Trigger : JYUSB1202.JYUSB1202AITask
  • TwoEdgeSeparation : JYUSB1202.JYUSB1202CITask
  • Type : JYUSB1202.AITrigger, JYUSB1202.JYUSB1202CITask

- z -

  • ZReloadEnabled : JYUSB1202.QuadEncoder


USB-1202 C# Programming Manual: Class Members - Variables

  • All
  • Functions
  • Variables
  • Properties
Here is a list of all variables with links to the classes they belong to:
  • Gain : ScalingCoefficients
  • MaxSampleRate : JYUSB1202.JYUSB1202AITask
  • Offset : ScalingCoefficients


USB-1202 C# Programming Manual: File Members

  • File List
  • File Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • b
  • j
Here is a list of all file members with links to the files they belong to:

- b -

  • BOOL : JYUSB1202Core.h

- j -

  • JYUSB1202_AI_AC : JYUSB1202Core.h
  • JYUSB1202_AI_CheckBufferStatus() : JYUSB1202Core.h
  • JYUSB1202_AI_Continuous : JYUSB1202Core.h
  • JYUSB1202_AI_Coupling : JYUSB1202Core.h
  • JYUSB1202_AI_DC : JYUSB1202Core.h
  • JYUSB1202_AI_DIFF : JYUSB1202Core.h
  • JYUSB1202_AI_DisableCalibration() : JYUSB1202Core.h
  • JYUSB1202_AI_EnableChannel() : JYUSB1202Core.h
  • JYUSB1202_AI_ExportSampleClock() : JYUSB1202Core.h
  • JYUSB1202_AI_ExportTriggerSignal() : JYUSB1202Core.h
  • JYUSB1202_AI_Finite : JYUSB1202Core.h
  • JYUSB1202_AI_FULLPOWER : JYUSB1202Core.h
  • JYUSB1202_AI_GetScalingCoefficients() : JYUSB1202Core.h
  • JYUSB1202_AI_IEPE : JYUSB1202Core.h
  • JYUSB1202_AI_MaxSampleRate_Double : JYUSB1202Core.h
  • JYUSB1202_AI_MinSampleRate_Double : JYUSB1202Core.h
  • JYUSB1202_AI_NumberOfChannels_Int : JYUSB1202Core.h
  • JYUSB1202_AI_PSEUDIFF : JYUSB1202Core.h
  • JYUSB1202_AI_ReadData() : JYUSB1202Core.h
  • JYUSB1202_AI_ReadRawData() : JYUSB1202Core.h
  • JYUSB1202_AI_SampleMode : JYUSB1202Core.h
  • JYUSB1202_AI_SendSoftTrigger() : JYUSB1202Core.h
  • JYUSB1202_AI_SetDigitalStartTrigger() : JYUSB1202Core.h
  • JYUSB1202_AI_SetFDAMODE() : JYUSB1202Core.h
  • JYUSB1202_AI_SetFilterType() : JYUSB1202Core.h
  • JYUSB1202_AI_SetMode() : JYUSB1202Core.h
  • JYUSB1202_AI_SetSampleRate() : JYUSB1202Core.h
  • JYUSB1202_AI_SetSamplesToAcquire() : JYUSB1202Core.h
  • JYUSB1202_AI_SetStartTriggerType() : JYUSB1202Core.h
  • JYUSB1202_AI_Sinc3_Filter : JYUSB1202Core.h
  • JYUSB1202_AI_Sinc5_Filter_DEC_X32_X1024 : JYUSB1202Core.h
  • JYUSB1202_AI_Single : JYUSB1202Core.h
  • JYUSB1202_AI_STANDBY : JYUSB1202Core.h
  • JYUSB1202_AI_Start() : JYUSB1202Core.h
  • JYUSB1202_AI_Stop() : JYUSB1202Core.h
  • JYUSB1202_AI_TEDS : JYUSB1202Core.h
  • JYUSB1202_AI_TEDS_IEPE_MODE : JYUSB1202Core.h
  • JYUSB1202_AI_TEDS_IEPE_OFF : JYUSB1202Core.h
  • JYUSB1202_AI_Terminal : JYUSB1202Core.h
  • JYUSB1202_AI_Wideband_Filter : JYUSB1202Core.h
  • JYUSB1202_AIFDAMODE : JYUSB1202Core.h
  • JYUSB1202_AIFilterType : JYUSB1202Core.h
  • JYUSB1202_Capability_Item : JYUSB1202Core.h
  • JYUSB1202_CI_CheckStatus() : JYUSB1202Core.h
  • JYUSB1202_CI_Count_Down : JYUSB1202Core.h
  • JYUSB1202_CI_Count_Up : JYUSB1202Core.h
  • JYUSB1202_CI_CounterEventSignalIdleState : JYUSB1202Core.h
  • JYUSB1202_CI_CounterEventSignalIdleState_High : JYUSB1202Core.h
  • JYUSB1202_CI_CounterEventSignalIdleState_Low : JYUSB1202Core.h
  • JYUSB1202_CI_EdgeCount : JYUSB1202Core.h
  • JYUSB1202_CI_Encoder_X2 : JYUSB1202Core.h
  • JYUSB1202_CI_Encoder_X4 : JYUSB1202Core.h
  • JYUSB1202_CI_Measure_EdgeSeparation : JYUSB1202Core.h
  • JYUSB1202_CI_Measure_FrequencyOrPeriod : JYUSB1202Core.h
  • JYUSB1202_CI_Measure_PulseWidth : JYUSB1202Core.h
  • JYUSB1202_CI_MeasureType : JYUSB1202Core.h
  • JYUSB1202_CI_ReadSingleCountValue() : JYUSB1202Core.h
  • JYUSB1202_CI_ReadSingleMeasureValue() : JYUSB1202Core.h
  • JYUSB1202_CI_SetCounterParamet() : JYUSB1202Core.h
  • JYUSB1202_CI_SetCounterType() : JYUSB1202Core.h
  • JYUSB1202_CI_SetEdgeCountEvent() : JYUSB1202Core.h
  • JYUSB1202_CI_SetPauseTriggerLevel() : JYUSB1202Core.h
  • JYUSB1202_CI_SetZReloadEnabled() : JYUSB1202Core.h
  • JYUSB1202_CI_Start() : JYUSB1202Core.h
  • JYUSB1202_CI_Stop() : JYUSB1202Core.h
  • JYUSB1202_Close() : JYUSB1202Core.h
  • JYUSB1202_CO_HighLevel : JYUSB1202Core.h
  • JYUSB1202_CO_IdleState : JYUSB1202Core.h
  • JYUSB1202_CO_LowLevel : JYUSB1202Core.h
  • JYUSB1202_CO_SetCounterParamet() : JYUSB1202Core.h
  • JYUSB1202_CO_SetFrequency() : JYUSB1202Core.h
  • JYUSB1202_CO_SetPauseTriggerLevel() : JYUSB1202Core.h
  • JYUSB1202_CO_Start() : JYUSB1202Core.h
  • JYUSB1202_CO_Stop() : JYUSB1202Core.h
  • JYUSB1202_CO_WaitUntilDone() : JYUSB1202Core.h
  • JYUSB1202_CountDirection : JYUSB1202Core.h
  • JYUSB1202_DeviceHandle : JYUSB1202Core.h
  • JYUSB1202_DI_AddLines() : JYUSB1202Core.h
  • JYUSB1202_DI_ReadSinglePoint() : JYUSB1202Core.h
  • JYUSB1202_DI_Start() : JYUSB1202Core.h
  • JYUSB1202_DI_Stop() : JYUSB1202Core.h
  • JYUSB1202_Digital : JYUSB1202Core.h
  • JYUSB1202_DigitalTriggerEdge : JYUSB1202Core.h
  • JYUSB1202_DigitalTriggerSource : JYUSB1202Core.h
  • JYUSB1202_DIO_0 : JYUSB1202Core.h
  • JYUSB1202_DIO_1 : JYUSB1202Core.h
  • JYUSB1202_DIO_2 : JYUSB1202Core.h
  • JYUSB1202_DIO_3 : JYUSB1202Core.h
  • JYUSB1202_DO_AddLines() : JYUSB1202Core.h
  • JYUSB1202_DO_Start() : JYUSB1202Core.h
  • JYUSB1202_DO_Stop() : JYUSB1202Core.h
  • JYUSB1202_DO_WriteSinglePoint() : JYUSB1202Core.h
  • JYUSB1202_Falling : JYUSB1202Core.h
  • JYUSB1202_GetCapabilityDouble() : JYUSB1202Core.h
  • JYUSB1202_GetCapabilityDoubleByName() : JYUSB1202Core.h
  • JYUSB1202_GetCapabilityDoubleBySlotNumber() : JYUSB1202Core.h
  • JYUSB1202_GetCapabilityInt() : JYUSB1202Core.h
  • JYUSB1202_GetCapabilityIntByName() : JYUSB1202Core.h
  • JYUSB1202_GetCapabilityIntBySlotNumber() : JYUSB1202Core.h
  • JYUSB1202_GetDeviceSerialNumber() : JYUSB1202Core.h
  • JYUSB1202_GPIO_0 : JYUSB1202Core.h
  • JYUSB1202_GPIO_1 : JYUSB1202Core.h
  • JYUSB1202_GPIO_2 : JYUSB1202Core.h
  • JYUSB1202_GPIO_3 : JYUSB1202Core.h
  • JYUSB1202_High_Level : JYUSB1202Core.h
  • JYUSB1202_HighLevel : JYUSB1202Core.h
  • JYUSB1202_Immediately : JYUSB1202Core.h
  • JYUSB1202_LevelState : JYUSB1202Core.h
  • JYUSB1202_Low_Level : JYUSB1202Core.h
  • JYUSB1202_LowLevel : JYUSB1202Core.h
  • JYUSB1202_NONE : JYUSB1202Core.h
  • JYUSB1202_Open() : JYUSB1202Core.h
  • JYUSB1202_OpenByName() : JYUSB1202Core.h
  • JYUSB1202_Rising : JYUSB1202Core.h
  • JYUSB1202_Signal_SrcAndDest : JYUSB1202Core.h
  • JYUSB1202_Soft : JYUSB1202Core.h
  • JYUSB1202_TriggerType : JYUSB1202Core.h


USB-1202 C# Programming Manual: File Members

  • File List
  • File Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
Here is a list of all enums with links to the files they belong to:
  • JYUSB1202_AI_Coupling : JYUSB1202Core.h
  • JYUSB1202_AI_SampleMode : JYUSB1202Core.h
  • JYUSB1202_AI_TEDS_IEPE_MODE : JYUSB1202Core.h
  • JYUSB1202_AI_Terminal : JYUSB1202Core.h
  • JYUSB1202_AIFDAMODE : JYUSB1202Core.h
  • JYUSB1202_AIFilterType : JYUSB1202Core.h
  • JYUSB1202_Capability_Item : JYUSB1202Core.h
  • JYUSB1202_CI_CounterEventSignalIdleState : JYUSB1202Core.h
  • JYUSB1202_CI_MeasureType : JYUSB1202Core.h
  • JYUSB1202_CO_IdleState : JYUSB1202Core.h
  • JYUSB1202_CountDirection : JYUSB1202Core.h
  • JYUSB1202_DigitalTriggerEdge : JYUSB1202Core.h
  • JYUSB1202_DigitalTriggerSource : JYUSB1202Core.h
  • JYUSB1202_LevelState : JYUSB1202Core.h
  • JYUSB1202_Signal_SrcAndDest : JYUSB1202Core.h
  • JYUSB1202_TriggerType : JYUSB1202Core.h


USB-1202 C# Programming Manual: File Members

  • File List
  • File Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • j
Here is a list of all enum values with links to the files they belong to:

- j -

  • JYUSB1202_AI_AC : JYUSB1202Core.h
  • JYUSB1202_AI_Continuous : JYUSB1202Core.h
  • JYUSB1202_AI_DC : JYUSB1202Core.h
  • JYUSB1202_AI_DIFF : JYUSB1202Core.h
  • JYUSB1202_AI_Finite : JYUSB1202Core.h
  • JYUSB1202_AI_FULLPOWER : JYUSB1202Core.h
  • JYUSB1202_AI_IEPE : JYUSB1202Core.h
  • JYUSB1202_AI_MaxSampleRate_Double : JYUSB1202Core.h
  • JYUSB1202_AI_MinSampleRate_Double : JYUSB1202Core.h
  • JYUSB1202_AI_NumberOfChannels_Int : JYUSB1202Core.h
  • JYUSB1202_AI_PSEUDIFF : JYUSB1202Core.h
  • JYUSB1202_AI_Sinc3_Filter : JYUSB1202Core.h
  • JYUSB1202_AI_Sinc5_Filter_DEC_X32_X1024 : JYUSB1202Core.h
  • JYUSB1202_AI_Single : JYUSB1202Core.h
  • JYUSB1202_AI_STANDBY : JYUSB1202Core.h
  • JYUSB1202_AI_TEDS : JYUSB1202Core.h
  • JYUSB1202_AI_TEDS_IEPE_OFF : JYUSB1202Core.h
  • JYUSB1202_AI_Wideband_Filter : JYUSB1202Core.h
  • JYUSB1202_CI_Count_Down : JYUSB1202Core.h
  • JYUSB1202_CI_Count_Up : JYUSB1202Core.h
  • JYUSB1202_CI_CounterEventSignalIdleState_High : JYUSB1202Core.h
  • JYUSB1202_CI_CounterEventSignalIdleState_Low : JYUSB1202Core.h
  • JYUSB1202_CI_EdgeCount : JYUSB1202Core.h
  • JYUSB1202_CI_Encoder_X2 : JYUSB1202Core.h
  • JYUSB1202_CI_Encoder_X4 : JYUSB1202Core.h
  • JYUSB1202_CI_Measure_EdgeSeparation : JYUSB1202Core.h
  • JYUSB1202_CI_Measure_FrequencyOrPeriod : JYUSB1202Core.h
  • JYUSB1202_CI_Measure_PulseWidth : JYUSB1202Core.h
  • JYUSB1202_CO_HighLevel : JYUSB1202Core.h
  • JYUSB1202_CO_LowLevel : JYUSB1202Core.h
  • JYUSB1202_Digital : JYUSB1202Core.h
  • JYUSB1202_DIO_0 : JYUSB1202Core.h
  • JYUSB1202_DIO_1 : JYUSB1202Core.h
  • JYUSB1202_DIO_2 : JYUSB1202Core.h
  • JYUSB1202_DIO_3 : JYUSB1202Core.h
  • JYUSB1202_Falling : JYUSB1202Core.h
  • JYUSB1202_GPIO_0 : JYUSB1202Core.h
  • JYUSB1202_GPIO_1 : JYUSB1202Core.h
  • JYUSB1202_GPIO_2 : JYUSB1202Core.h
  • JYUSB1202_GPIO_3 : JYUSB1202Core.h
  • JYUSB1202_High_Level : JYUSB1202Core.h
  • JYUSB1202_HighLevel : JYUSB1202Core.h
  • JYUSB1202_Immediately : JYUSB1202Core.h
  • JYUSB1202_Low_Level : JYUSB1202Core.h
  • JYUSB1202_LowLevel : JYUSB1202Core.h
  • JYUSB1202_NONE : JYUSB1202Core.h
  • JYUSB1202_Rising : JYUSB1202Core.h
  • JYUSB1202_Soft : JYUSB1202Core.h


USB-1202 C# Programming Manual: File Members

  • File List
  • File Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
  • j
Here is a list of all functions with links to the files they belong to:

- j -

  • JYUSB1202_AI_CheckBufferStatus() : JYUSB1202Core.h
  • JYUSB1202_AI_DisableCalibration() : JYUSB1202Core.h
  • JYUSB1202_AI_EnableChannel() : JYUSB1202Core.h
  • JYUSB1202_AI_ExportSampleClock() : JYUSB1202Core.h
  • JYUSB1202_AI_ExportTriggerSignal() : JYUSB1202Core.h
  • JYUSB1202_AI_GetScalingCoefficients() : JYUSB1202Core.h
  • JYUSB1202_AI_ReadData() : JYUSB1202Core.h
  • JYUSB1202_AI_ReadRawData() : JYUSB1202Core.h
  • JYUSB1202_AI_SendSoftTrigger() : JYUSB1202Core.h
  • JYUSB1202_AI_SetDigitalStartTrigger() : JYUSB1202Core.h
  • JYUSB1202_AI_SetFDAMODE() : JYUSB1202Core.h
  • JYUSB1202_AI_SetFilterType() : JYUSB1202Core.h
  • JYUSB1202_AI_SetMode() : JYUSB1202Core.h
  • JYUSB1202_AI_SetSampleRate() : JYUSB1202Core.h
  • JYUSB1202_AI_SetSamplesToAcquire() : JYUSB1202Core.h
  • JYUSB1202_AI_SetStartTriggerType() : JYUSB1202Core.h
  • JYUSB1202_AI_Start() : JYUSB1202Core.h
  • JYUSB1202_AI_Stop() : JYUSB1202Core.h
  • JYUSB1202_CI_CheckStatus() : JYUSB1202Core.h
  • JYUSB1202_CI_ReadSingleCountValue() : JYUSB1202Core.h
  • JYUSB1202_CI_ReadSingleMeasureValue() : JYUSB1202Core.h
  • JYUSB1202_CI_SetCounterParamet() : JYUSB1202Core.h
  • JYUSB1202_CI_SetCounterType() : JYUSB1202Core.h
  • JYUSB1202_CI_SetEdgeCountEvent() : JYUSB1202Core.h
  • JYUSB1202_CI_SetPauseTriggerLevel() : JYUSB1202Core.h
  • JYUSB1202_CI_SetZReloadEnabled() : JYUSB1202Core.h
  • JYUSB1202_CI_Start() : JYUSB1202Core.h
  • JYUSB1202_CI_Stop() : JYUSB1202Core.h
  • JYUSB1202_Close() : JYUSB1202Core.h
  • JYUSB1202_CO_SetCounterParamet() : JYUSB1202Core.h
  • JYUSB1202_CO_SetFrequency() : JYUSB1202Core.h
  • JYUSB1202_CO_SetPauseTriggerLevel() : JYUSB1202Core.h
  • JYUSB1202_CO_Start() : JYUSB1202Core.h
  • JYUSB1202_CO_Stop() : JYUSB1202Core.h
  • JYUSB1202_CO_WaitUntilDone() : JYUSB1202Core.h
  • JYUSB1202_DI_AddLines() : JYUSB1202Core.h
  • JYUSB1202_DI_ReadSinglePoint() : JYUSB1202Core.h
  • JYUSB1202_DI_Start() : JYUSB1202Core.h
  • JYUSB1202_DI_Stop() : JYUSB1202Core.h
  • JYUSB1202_DO_AddLines() : JYUSB1202Core.h
  • JYUSB1202_DO_Start() : JYUSB1202Core.h
  • JYUSB1202_DO_Stop() : JYUSB1202Core.h
  • JYUSB1202_DO_WriteSinglePoint() : JYUSB1202Core.h
  • JYUSB1202_GetCapabilityDouble() : JYUSB1202Core.h
  • JYUSB1202_GetCapabilityDoubleByName() : JYUSB1202Core.h
  • JYUSB1202_GetCapabilityDoubleBySlotNumber() : JYUSB1202Core.h
  • JYUSB1202_GetCapabilityInt() : JYUSB1202Core.h
  • JYUSB1202_GetCapabilityIntByName() : JYUSB1202Core.h
  • JYUSB1202_GetCapabilityIntBySlotNumber() : JYUSB1202Core.h
  • JYUSB1202_GetDeviceSerialNumber() : JYUSB1202Core.h
  • JYUSB1202_Open() : JYUSB1202Core.h
  • JYUSB1202_OpenByName() : JYUSB1202Core.h


USB-1202 C# Programming Manual: File Members

  • File List
  • File Members
  • All
  • Functions
  • Typedefs
  • Enumerations
  • Enumerator
Here is a list of all typedefs with links to the files they belong to:
  • BOOL : JYUSB1202Core.h
  • JYUSB1202_DeviceHandle : JYUSB1202Core.h


USB-1202 C# Programming Manual: Main Page

USB-1202 C# Programming Manual Documentation


USB-1202 C# Programming Manual: JYUSB1202 Namespace Reference

  • Package List
  • Package Members
Classes | Enumerations
JYUSB1202 Namespace Reference

Classes

class | JYUSB1202AITask
JYUSB1202 Analog Input Task. More...
class | AIChannel
AI Channel parameter class . More...
class | AISampleClock
Sample clock configuration class. More...
class | AIExternalSampleClock
External Sample Clock Configuration Class. More...
class | AITrigger
Clock Terminal. More...
class | AIDigitalTrigger
AI Digital trigger class. More...
class | AIRecord
AI Record Parameters. More...
class | AISignalExport
AI Signal Export Class. More...
class | JYUSB1202CITask
JYUSB1202 Counter Input Task. More...
class | EdgeCounting
Configure CI EdgeCounting. More...
class | EdgeCountingOutEvent
Edge counting output event configuration class. More...
class | PauseTrigger
Pause trigger configuration class. More...
class | FrequencyMeas
Configure CI Measure. More...
class | PeriodMeas
Configure CI Measure. More...
class | PulseMeas
Configure CI Measure. More...
class | TwoEdgeSeparation
Configure CI Measure. More...
class | QuadEncoder
Configure CI Measure. More...
class | TwoPulseEncoder
Configure CI Measure. More...
class | JYUSB1202COTask
JYUSB1202 Counter Output Task. More...
class | COPulse
Pulse Parameter. More...
class | JYUSB1202DITask
JYUSB1202 Digital Iuput Task. More...
class | DIChannel
DI Channel parameter class . More...
class | JYUSB1202DOTask
JYUSB1202 Digital Output Task. More...
class | DOChannel
DO Channel parameter class . More...

Enumerations

enum | AIFilterType { Sinc5_DEC_X32_X1024 = 0 , Sinc3 = 3 , Wideband = 4 }
AIFilterType. More...
enum | AIFDAMODE { FULLPOWER = 0 , STANDBY = 1 }
AIFDAMODE. More...
enum | AITerminal { PSEUDIFF = 0 , Differential = 1 }
AITerminal. More...
enum | AICoupling { AC = 0 , DC = 1 }
AICoupling. More...
enum | AITriggerType { Immediate = 0 , Digital = 1 , Soft = 2 }
Trigger Type Digital/Analog/Immediate/Soft. More...
enum | AIDigitalTriggerEdge { Rising = 0 , Falling = 1 , HighLevel = 2 , LowLevel = 3 }
AI Digital Trigger Edge. More...
enum | AIMode { Finite = JYUSB1202Import.JYUSB1202_AI_Finite , Continuous = JYUSB1202Import.JYUSB1202_AI_Continuous , Record = 0x2 }
AIMode. More...
enum | AISampleClockSource { Internal , External }
AI Sample Clock Source. More...
enum | AIDigitalTriggerSource { DIO_0 = 0 , DIO_1 = 1 , DIO_2 = 2 , DIO_3 = 3 }
Output DestinationTerminal. More...
enum | FileFormat { Bin }
Streaming file format. More...
enum | RecordMode { Finite , Infinite }
stream mode .enum Finite/Infinite More...
enum SignalExportDestination {
NONE = -1 , DIO_0 = 0 , DIO_1 = 1 , DIO_2 = 2 ,
DIO_3 = 3
}
Output DestinationTerminal. More...
enum | AISignalExportSource { StartTrig , SampleClock }
AI Signal Export Source. More...
enum | CountDirection { Up = JYUSB1202Import.JYUSB1202_CI_Count_Up , Down = JYUSB1202Import.JYUSB1202_CI_Count_Down }
Counter direction. More...
enum CIType {
EdgeCounting , Period , Frequency , Pulse ,
TwoEdgeSeparation , QuadEncoder
}
Counter Input Application Type. More...
enum | EdgeType { Rising , Falling , Any }
Edge Type. More...
enum | EdgeCntOunEvtIdleState { LowLevel = 0 , HighLevel = 1 }
Output idle state when the event has not occurred. More...
enum | LevelPolarity { LowLevel = 0 , HighLevel = 1 , None = 2 }
Level Polarity. More...
enum | QuadEncodingType { X2 , X4 }
Quadrature Encoding Type. More...
enum | COIdleState { HighLevel = JYUSB1202Import.JYUSB1202_HighLevel , LowLevel = JYUSB1202Import.JYUSB1202_LowLevel }
Idle state when pulse output before start and after stop. More...
enum | COPulseType { DutyCycleFrequency , HighLowTime , HighLowTick }
Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick. More...

Enumeration Type Documentation

◆ AICoupling

enum JYUSB1202.AICoupling

AICoupling.

Enumerator
AC | AC.
DC | DC.

◆ AIDigitalTriggerEdge

enum JYUSB1202.AIDigitalTriggerEdge

AI Digital Trigger Edge.

Enumerator
Rising | RisingEdge.
Falling | FallingEdge.
HighLevel | High Level.
LowLevel | Low Level.

◆ AIDigitalTriggerSource

enum JYUSB1202.AIDigitalTriggerSource

Output DestinationTerminal.

Enumerator
DIO_0 | DIO_0.
DIO_1 | DIO_1.
DIO_2 | DIO_2.
DIO_3 | DIO_3.

◆ AIFDAMODE

enum JYUSB1202.AIFDAMODE

AIFDAMODE.

Enumerator
FULLPOWER | FULLPOWER.
STANDBY | STANDBY.

◆ AIFilterType

enum JYUSB1202.AIFilterType

AIFilterType.

Enumerator
Sinc5_DEC_X32_X1024 | Sinc5_DEC_X32_X1024.
Sinc3 | Sinc3.
Wideband | Wideband.

◆ AIMode

enum JYUSB1202.AIMode

AIMode.

Enumerator
Finite | Finite.
Continuous | Continuous.
Record | Record.

◆ AISampleClockSource

enum JYUSB1202.AISampleClockSource

AI Sample Clock Source.

Enumerator
Internal | Internal Clock Source.
External | External Clock Source.

◆ AISignalExportSource

enum JYUSB1202.AISignalExportSource

AI Signal Export Source.

Enumerator
StartTrig | AI_StartTrig.
SampleClock | AI_SampleClock.

◆ AITerminal

enum JYUSB1202.AITerminal

AITerminal.

Enumerator
PSEUDIFF | PSEUDIFF.
Differential | Differential.

◆ AITriggerType

enum JYUSB1202.AITriggerType

Trigger Type Digital/Analog/Immediate/Soft.

Enumerator
Immediate | Immediate Trigger.
Digital | Digital Trigger.
Soft | Soft Trigger.

◆ CIType

enum JYUSB1202.CIType

Counter Input Application Type.

Enumerator
EdgeCounting | Edge Counting.
Period | Period Measure.
Frequency | Frequenc Measure.
Pulse | Pulse Measure.
TwoEdgeSeparation | TwoEdgeSeparation Measure.
QuadEncoder | QuadEncoder.

◆ COIdleState

enum JYUSB1202.COIdleState

Idle state when pulse output before start and after stop.

Enumerator
HighLevel | Idle state is high level.
LowLevel | Idle state is low level.

◆ COPulseType

enum JYUSB1202.COPulseType

Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick.

Enumerator
DutyCycleFrequency | Configure CO output pulse according to its DutyCycle and Freqency.
HighLowTime | Configure CO output pulse according to duration of its high/low voltage levels.
HighLowTick | Configure CO output pulse according to its high/low tick level.

◆ CountDirection

enum JYUSB1202.CountDirection

Counter direction.

enum Up/Down/External

Enumerator
Up | Counter increases.
Down | Counter decreases.

◆ EdgeCntOunEvtIdleState

enum JYUSB1202.EdgeCntOunEvtIdleState

Output idle state when the event has not occurred.

Enumerator
LowLevel | Idle state is low level.
HighLevel | Idle state is high level.

◆ EdgeType

enum JYUSB1202.EdgeType

Edge Type.

Enumerator
Rising | Rising Edge.
Falling | Falling Edge.
Any | Any Edge.

◆ FileFormat

enum JYUSB1202.FileFormat

Streaming file format.

enum BIN.

Enumerator
Bin

BIN。

BIN.

◆ LevelPolarity

enum JYUSB1202.LevelPolarity

Level Polarity.

Enumerator
LowLevel | Low level.
HighLevel | High level.
None | No active polarity.

◆ QuadEncodingType

enum JYUSB1202.QuadEncodingType

Quadrature Encoding Type.

Enumerator
X2 | X2.
X4 | X4.

◆ RecordMode

enum JYUSB1202.RecordMode

stream mode .enum Finite/Infinite

Enumerator
Finite | Finite Streaming.
Infinite | Infinite Streaming.

◆ SignalExportDestination

enum JYUSB1202.SignalExportDestination

Output DestinationTerminal.

Enumerator
NONE |
DIO_0 | DIO_0.
DIO_1 | DIO_1.
DIO_2 | DIO_2.
DIO_3 | DIO_3.


USB-1202 C# Programming Manual: Package Members

  • Package List
  • Package Members
  • All
  • Enumerations
Here is a list of all namespace members with links to the namespace documentation for each member:
  • AICoupling : JYUSB1202
  • AIDigitalTriggerEdge : JYUSB1202
  • AIDigitalTriggerSource : JYUSB1202
  • AIFDAMODE : JYUSB1202
  • AIFilterType : JYUSB1202
  • AIMode : JYUSB1202
  • AISampleClockSource : JYUSB1202
  • AISignalExportSource : JYUSB1202
  • AITerminal : JYUSB1202
  • AITriggerType : JYUSB1202
  • CIType : JYUSB1202
  • COIdleState : JYUSB1202
  • COPulseType : JYUSB1202
  • CountDirection : JYUSB1202
  • EdgeCntOunEvtIdleState : JYUSB1202
  • EdgeType : JYUSB1202
  • FileFormat : JYUSB1202
  • LevelPolarity : JYUSB1202
  • QuadEncodingType : JYUSB1202
  • RecordMode : JYUSB1202
  • SignalExportDestination : JYUSB1202


USB-1202 C# Programming Manual: Package Members

  • Package List
  • Package Members
  • All
  • Enumerations
Here is a list of all namespace enums with links to the namespace documentation for each enum:
  • AICoupling : JYUSB1202
  • AIDigitalTriggerEdge : JYUSB1202
  • AIDigitalTriggerSource : JYUSB1202
  • AIFDAMODE : JYUSB1202
  • AIFilterType : JYUSB1202
  • AIMode : JYUSB1202
  • AISampleClockSource : JYUSB1202
  • AISignalExportSource : JYUSB1202
  • AITerminal : JYUSB1202
  • AITriggerType : JYUSB1202
  • CIType : JYUSB1202
  • COIdleState : JYUSB1202
  • COPulseType : JYUSB1202
  • CountDirection : JYUSB1202
  • EdgeCntOunEvtIdleState : JYUSB1202
  • EdgeType : JYUSB1202
  • FileFormat : JYUSB1202
  • LevelPolarity : JYUSB1202
  • QuadEncodingType : JYUSB1202
  • RecordMode : JYUSB1202
  • SignalExportDestination : JYUSB1202


USB-1202 C# Programming Manual: Package List

  • Package List
  • Package Members
Package List
Here are the packages with brief descriptions (if available):
N JYUSB1202


USB-1202 C# Programming Manual: ScalingCoefficients Struct Reference

Public Attributes | List of all members
ScalingCoefficients Struct Reference

#include <JYUSB1202Core.h>

Public Attributes

double | Offset
double | Gain

Member Data Documentation

◆ Gain

double ScalingCoefficients::Gain

◆ Offset

double ScalingCoefficients::Offset
The documentation for this struct was generated from the following file:
  • D:/OneDrive/Desktop/产品文档/CHM/1202/C++/JYUSB1202Core.h


USB-1202 C# Programming Manual: Member List

ScalingCoefficients Member List

This is the complete list of members for ScalingCoefficients, including all inherited members.

Gain | ScalingCoefficients
Offset | ScalingCoefficients